Namespaces

Namespaces NFX Class Library

[This is preliminary documentation and is subject to change.]

NET Framework Extension Library

What is NFX?

The name "NFX" stands for ".NET Framework Extension" / "Unistack". "Unistack" = "Unified Software Stack", a conceptually-monolithic library that facilitates whatever service/facilities developers need to create scale-able, solid business/data-driven application systems (not just applications). As such, the unistack support many facilities that traditionally are scattered among myriads of disjoint software frameworks.

NFX Resources on the Web

See Online Aum Code/IT Adapter Blog for the latest project updates/blog posts.

Namespaces
Namespace | Description
( Default Namespace ) |
NFX | Root namespace for NFX framework, contains some commonly-used classes
NFX.ApplicationModel | Stipulates base contracts for application containers - ApplicationModel. Application Containers unify the way how different types of applications are written (i.e. console, service, web, GUI)
NFX.ApplicationModel.Pile |
NFX.ApplicationModel.Pile.Instrumentation |
NFX.ApplicationModel.Volatile | Facilitates operation of applications in volatile environments when processes can be restarted/crash
NFX.CodeAnalysis | Provides code analysis-related base contracts/models for writing compilers and various textual processors. JSON, C#, Laconic parsers are implemented using this concept
NFX.CodeAnalysis.CSharp | Provides functions for working with C# syntax
NFX.CodeAnalysis.JSON | Provides functions for working with JSON syntax
NFX.CodeAnalysis.Laconfig | Provides functions for working with Laconic Configuration syntax
NFX.CodeAnalysis.Source | Provides functions for working with textual source code i.e. reading source form file, named memory buffer, project items and the like
NFX.CodeAnalysis.XML |
NFX.Collections | Provides special purpose collections
NFX.DataAccess | Facilitates data access tasks
NFX.DataAccess.Cache | Provides efficient caching options
NFX.DataAccess.Cache.Instrumentation | Defines instrumentation gauges and events for caching engine
NFX.DataAccess.CRUD | Facilitates working with SQL and NoSQL backends on the level of records, rowsets, tables and queries
NFX.DataAccess.CRUD.Subscriptions |
NFX.DataAccess.Distributed | Facilitates working with large-scale distributed database systems like the ones used by Google, Facebook, Twitter et. al.
NFX.DataAccess.Erlang |
NFX.DataAccess.MongoDB | Provides NFX data access apis for MongoDB
NFX.DataAccess.MongoDB.Connector |
NFX.DataAccess.MySQL | Provides NFX data access apis for MySQL
NFX.Environment | Provides configuration and environment-related(i.e. environment variables, command-line parser) classes
NFX.Erlang | Natively provides Erlang types/terms/parsing and OTP support
NFX.Erlang.DataAccess |
NFX.Erlang.Internal | Internal Erlang-related classes
NFX.Financial | Provides various financial functions
NFX.Financial.Market |
NFX.Financial.Market.SecDb |
NFX.Geometry | Provides various geometry functions/types like Cartesian utilities and polar coordinate support
NFX.Glue | Provides master contract stipulations and native implementations for distributed component communication technology. "Glue" is used to glue contract endpoints between hosts
NFX.Glue.Implementation | Provides default Glue implementation
NFX.Glue.Instrumentation | Provides instrumentation gauges and events for Glue
NFX.Glue.Native | Provides implementations for NFX-native Glue bindings whoch are based on NFX.Serialization and TCP/IP sockets
NFX.Glue.Protocol | Defines protocol headers and messages for Glue
NFX.Glue.Tools |
NFX.Health | Provides classes for application/process health monitoring
NFX.Instrumentation | Provides base types for Instrumentation: gauges, events, providers
NFX.Instrumentation.Analytics | Provides instrumentation-related classes that facilitate analytical processing - various histograms
NFX.Instrumentation.Self |
NFX.Instrumentation.Telemetry | Provides means for remote acquisition of instrumentation data
NFX.Inventorization | Provides types for code/asset inventory
NFX.IO | Provides various IO-related functions like error correction and efficient binary streamers
NFX.IO.ErrorHandling | Provides varios error-correction functions like checksums and polynomial fields
NFX.IO.FileSystem | Provides abstraction for working with varios file systems like Amazon S3, NFTS, FDFS, ACFS
NFX.IO.FileSystem.GoogleDrive |
NFX.IO.FileSystem.GoogleDrive.Auth |
NFX.IO.FileSystem.GoogleDrive.V2 |
NFX.IO.FileSystem.Local | Provides local file system implementation
NFX.IO.FileSystem.Packaging |
NFX.IO.FileSystem.S3 |
NFX.IO.FileSystem.S3.V4 |
NFX.IO.FileSystem.S3.V4.S3V4Sign |
NFX.IO.FileSystem.SVN |
NFX.IO.Net |
NFX.IO.Net.Gate |
NFX.Log | Logging services
NFX.Log.Bin |
NFX.Log.Destinations | Various log destinations/sinks
NFX.Log.Instrumentation |
NFX.Log.Syslog | Provides *nix SYSLOG related classes
NFX.Media.Graphics |
NFX.Media.PDF |
NFX.Media.PDF.DocumentModel |
NFX.Media.PDF.Elements |
NFX.Media.PDF.Styling |
NFX.Media.PDF.Text |
NFX.Media.TagCodes.QR | Provides functions for working with QR codes
NFX.OS | OS-related functions, like running processes and getting information about local machine
NFX.OS.Instrumentation |
NFX.Parsing | Provides varios string-parsing/text-related utils
NFX.Parsing.JavaScript | Provides JavaScript-related parsing utils
NFX.RelationalModel | Provides types for working with relational schemas that can be compiled to DDL and other kinds of scripts
NFX.RelationalModel.DataTypes | Provides types for domains used by relational schemas
NFX.Security | Defines fundamental security types like users and permissions
NFX.Security.CAPTCHA |
NFX.Serialization | Provides serialization functionality
NFX.Serialization.Arow |
NFX.Serialization.BSON |
NFX.Serialization.CSV |
NFX.Serialization.JSON | Provides JSON+ serialization functionality
NFX.Serialization.POD | Provides Portable Object Document serialization functionality
NFX.Serialization.Slim | Provides Slim serialization functionality
NFX.ServiceModel | Provides fundamental concepts for writing in-process services
NFX.Standards |
NFX.Templatization | Defines base template types and compilers
NFX.Throttling | Provides throttling functions like time-spacing rate limiters
NFX.Time | Facilittates working with time sources
NFX.Time.Instrumentation |
NFX.Wave |
NFX.Wave.Client |
NFX.Wave.Filters |
NFX.Wave.Handlers |
NFX.Wave.Instrumentation |
NFX.Wave.MVC |
NFX.Wave.Templatization |
NFX.Wave.Templatization.StockContent |
NFX.Web | Provides various web functions like MVC, Templates and various utilities
NFX.Web.GeoLookup |
NFX.Web.IO |
NFX.Web.Messaging |
NFX.Web.Messaging.Instrumentation |
NFX.Web.Pay |
NFX.Web.Pay.Braintree |
NFX.Web.Pay.Instrumentation |
NFX.Web.Pay.Mock |
NFX.Web.Pay.PayPal |
NFX.Web.Pay.Stripe |
NFX.Web.Shipping |
NFX.Web.Shipping.Instrumentation |
NFX.Web.Shipping.Shippo |
NFX.Web.Social | Provides functions for working with social networks like GooglePlus, Facebook and others
NFX.Web.Social.Instrumentation |
NFX.WinApi | [Deprecated] Microsoft Windows APIs
NFX.WinForms | [Deprecated] Windows Forms support
NFX.WinForms.Controls | [Deprecated] Windows Forms - custom controls
NFX.WinForms.Controls.ChartKit |
NFX.WinForms.Controls.ChartKit.Temporal |
NFX.WinForms.Controls.GridKit | [Deprecated] Windows Forms support for building flexible grids
NFX.WinForms.Elements | [Deprecated] Windows Forms support for building handle-less controls
NFX.WinForms.Forms | [Deprecated] Windows Forms support support for abstract forms

Online Copyright © 2006-2017 ITAdapter Corp Inc. (http://www.itadapter.com)

Send Feedback on this topic to Contact Us.


( Default Namespace ) Namespace

( Default Namespace ) Namespace NFX Class Library

Classes
 | Class | Description
Protected class | <Module> |


<Module> Class

<Module> Class NFX Class Library

Inheritance Hierarchy
(Default Namespace) <Module>

Namespace: (Default Namespace)
Assemblies: NFX.WinForms (in NFX.WinForms.dll) Version: 3.0.0.1 (3.0.0.1)
NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
NFX.Wave (in NFX.Wave.dll) Version: 3.0.0.1 (3.0.0.1)
NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class <Module>
internal class <Module>
Friend Class <Module>
Friend Class <Module>
internal ref class <Module>
internal ref class <Module>
type <Module> =  class end
type <Module> =  class end
See Also
(Default Namespace) Namespace


NFX Namespace

NFX Namespace NFX Class Library

Root namespace for NFX framework, contains some commonly-used classes
Classes
 | Class | Description
Public class | AbsentValue | Represents a special value that signifies the absence of any entity/state/value/data. The instances may be stored in a cache to indicate that the key exists, but points to a non-existing "absent" entity. This is usefull for DB lookups, not to touch the backend for values that dont exist. Use AbsentValue.Instance singleton
Public class | App | Provides a shortcut access to app-global context NFX.ApplicationModel.ExecutionContext.Application.*
Public class | Aver | Provides basic averments for test construction. May call Aver.Fail(msg) manually
Public class | AvermentException | Thrown by Aver class to indicate averment failures
Public class | CollectionUtils | Some helpful extensions for standard collections
Public class | CoreConsts | Central non-lozalizable NFX system consts
Public class | DataUtils |
Public class | Debug | Facilitates debugging tasks enabled by DEBUG conditional define
Public class | DebugAssertionException | Thrown by Debug class to indicate assertion failures
Public class | Debugging | Facilitates debugging tasks that do not depend on any conditional defines
Public class | DisposableObject | General-purpose base class for objects that need to be disposed
Public class | DisposedObjectException | This exception is thrown from DisposableObject.EnsureObjectNotDisposed() method
Public class | ELink | Represents an Electronic Link which is an alpha-encoded identifier along with metadata information. Warning! This class MAY generate fragments of profanity, however any ID can be regenerated using a different seed passed to Encode(seed)
Public class | EmbeddedResource | Fetches resources such as script statement text by scriptName from assembly resource stream. Mostly used for SQL and JavaScript but maybe used for any text retrieval. This class is 100% safe for multithreading operations. Script texts are cached in ram for faster subsequent access.
Public class | ExternalParameterAttribute | Decorates properties that may be used as bindable external parameters. Provides methods for extraction of parameter names, values and binding of external object values into public read/write properties decorated by this attribute
Public class | ExternalRandomGenerator | Represents a random generator which is based on System.Random() yet has an ability to feed external samples into it. Use ExtrenalRandomGenerator.Instance to use the default thread-safe instance.
Public class | IntMath |
Public class | IOMiscUtils | Misc utils for I/O
Public class | MiscUtils |
Public class | NFXException | Base exception thrown by the framework
Public class | ObjectValueConversion | Provides extension methods for converting object values to different scalar types
Public class | OrderedRegistry T | Represents a thread-safe registry of T which is ordered by Order property. This class is efficient for concurrent read access and is not designed for cases when frequent modifications happen. It is ideal for lookup of named instances that have much longer time span than components that look them up. Note: since registry does reading in a lock-free manner, it is possible to have an inconsistent read snapshot of ordered items which may capture items that have already/not yet been added to the registry
Public class | ReferenceEqualityComparer T | Checks for reference equality. Use ReferenceEqualityComparer(T).Instance
Public class | Registry T | Represents a thread-safe registry of T. This class is efficient for concurrent read access and is not designed for cases when frequent modifications happen. It is ideal for lookup of named instances (such as components) that have much longer time span than components that look them up. Registry performs lock-free lookup which speeds-up many concurrent operations that need to map names into objects. The enumeration over registry makes a snapshot of its data, hence a registry may be modified by other threads while being enumerated.
Protected class | RegistryDictionary T | Internal dictionary of string-named objects
Public class | Scope | Helper class to be used in the context of 'using' clause to facilitate cleanup on scope exit and performing of other functions such as status logging
Public class | SealedString Scope | Represents a scope of a SealedString creation that tracks the existing strings. Use Seal(string) to get an existing string or create a new one. Do not persist the instance of Scope for a long time as it accumulates references (string keys) that pressure the GC. This class is used in batched that create many sealed strings. Once those strings rae created the scope can be released.
Protected class | StringConsts | A dictionary of framework text messages. Localization may be done in this class in future
Public class | StringValueConversion | Provides extension methods for converting string values to different scalar types
Public class | TaskUtils |
Public class | Trace | Facilitates debugging tasks enabled by TRACE conditional define
Public class | URIUtils |
Public class | WrappedException | Represents exception that contains data about causing exception with all of it's chain
Public class | WrappedExceptionData | Marshalls exception details
Structures
Structure | Description
Public structure FID
Represents an ultra-efficient 64 bit in-process-wide unique identifier "Fast Id". The ID is going to wrap-around after at least 2 weeks (19 days). The ID consists of 3 segments: [timestamp: 24bit][threadseed: 24bit][counter: 16 bit]. This is needed because: a). FID stays unique after process restarts b). This design does not use interlock on global seed, but uses thread-static vars which is 10-20 times faster The timestamp is the number of 100ms intervals elapsed since Jan 1 2015 expressed as a 24 bit unsigned int, which gives 2^24 = 16,777,216 combinations which covers 19 days (around 2 weeks) at 100 msec resolution, consequently the ID will generate duplicates after this period. This struct is useful for creating unique IDs for protocol/traffic messages that live for a limited time (no more than 2 weeks). Caution: This ID does not identify the machine or process, only items within the process, however when a hosting process restarts(i.e. crash or reboot) the new IDs will not collide with IDs generated right before the crash for at least 14 days (14 day sliding window). In a parallel test on 6 Core i7 3.2 GHz this class generates 405 million IDs/sec, which is 57 times faster than Guid that only generates 7 million IDs/sec
Public structure | Scope _scopeExit
Public structure | Scope _scopeExit TCtx1
Public structure | Scope _scopeExit TCtx1, TCtx2
Public structure | Scope _scopeExit TCtx1, TCtx2, TCtx3
Public structure | Scope _scopeExit TCtx1, TCtx2, TCtx3, TCtx4
Public structure SealedString
Represents an immutable string data that is stored in an efficient way that relieves the GC pressure. The string can not be changed or deleted. Once created it stays as-is until the process is terminated. This structure is used to store much dictionary data (100s of millions of strings) in the process without causing GC overload. Note: The default .ctor DOES NOT check whether the same string is already present in memory. Use SealedString.Scope to store unique strings only (do not store the repetitions). This struct is THREAD SAFE and NOT SERIALIZABLE.
Interfaces
 | Interface | Description
Public interface | IEndableInstance | Describes an entity that can request some hosting container to end its lifetime by calling End() method
Public interface | IExternallyParameterized | Denotes an entity that has external parameters that can be get/set
Public interface | INamed | Denotes an entity that has a Name property. This interface is primarily used with Registry[INamed] class that allows for string-based addressing (getting instances by object instance name). The names are ideal for many system functions, like naming components in configs and admin tools
Public interface | IOrdered | Denotes an entity that has a relative Order property within a collection of entities
Public interface | IOrderedRegistry T | Provides read-only named ordered object lookup capabilities
Public interface | IParameter | Represents abstract parameter
Public interface | IParameters | Represents abstract parameters bag
Public interface | IRegistry T | Provides read-only named object lookup capabilities
Enumerations
 | Enumeration | Description
Public enumeration | ConvertErrorHandling | Specifies how to handle errors during object value conversion
Public enumeration | DebugAction | Specifies how to handle Assertion and other failures
Public enumeration | DumpFormat | Format of the String Dump
Public enumeration | ExternalParameterSecurityCheck | Specifies when security permissions should be checked while getting/setting extrenal parameters
Public enumeration | ObjectValueConversion TriStateBool | A "hack" enum used to provide tri-state checkbox functionality in some systems, i.e. HTML checkmarks do not understand "nulls". This is a surrogate type not used in server-side programming


AbsentValue Class

AbsentValue Class NFX Class Library

Represents a special value that signifies the absence of any entity/state/value/data. The instances may be stored in a cache to indicate that the key exists, but points to a non-existing "absent" entity. This is usefull for DB lookups, not to touch the backend for values that dont exist. Use AbsentValue.Instance singleton
Inheritance Hierarchy
Online System Object
NFX AbsentValue

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class AbsentValue
[SerializableAttribute]
public sealed class AbsentValue
<SerializableAttribute>
Public NotInheritable Class AbsentValue
<SerializableAttribute>
Public NotInheritable Class AbsentValue
[SerializableAttribute]
public ref class AbsentValue sealed
[SerializableAttribute]
public ref class AbsentValue sealed
[<SealedAttribute>]
[<SerializableAttribute>]
type AbsentValue =  class end
[<SealedAttribute>]
[<SerializableAttribute>]
type AbsentValue =  class end
See Also
AbsentValue Members
NFX Namespace


AbsentValue Members

AbsentValue Members NFX Class Library

The AbsentValue type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
Instance |
Back to Top
See Also
AbsentValue Class
NFX Namespace


AbsentValue Fields

AbsentValue Fields NFX Class Library

The AbsentValue type exposes the following members.
Fields
Name | Description
Instance |
Back to Top
See Also
AbsentValue Class
NFX Namespace


AbsentValue.Instance Field

AbsentValue Instance Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly AbsentValue Instance
public static readonly AbsentValue Instance
Public Shared ReadOnly Instance As AbsentValue
Public Shared ReadOnly Instance As AbsentValue
public:
static initonly AbsentValue^ Instance
public:
static initonly AbsentValue^ Instance
static val Instance: AbsentValue
static val Instance: AbsentValue

Field Value

Type: AbsentValue
See Also
AbsentValue Class
AbsentValue Members
NFX Namespace


AbsentValue Methods

AbsentValue Methods NFX Class Library

The AbsentValue type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
AbsentValue Class
NFX Namespace


AbsentValue.Equals Method

AbsentValue Equals Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
AbsentValue Class
AbsentValue Members
NFX Namespace


AbsentValue.GetHashCode Method

AbsentValue GetHashCode Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
AbsentValue Class
AbsentValue Members
NFX Namespace


AbsentValue.ToString Method

AbsentValue ToString Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
AbsentValue Class
AbsentValue Members
NFX Namespace


App Class

App Class NFX Class Library

Provides a shortcut access to app-global context NFX.ApplicationModel.ExecutionContext.Application.*
Inheritance Hierarchy
Online System Object
NFX App

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class App
public static class App
Public NotInheritable Class App
Public NotInheritable Class App
public ref class App abstract sealed
public ref class App abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type App =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type App =  class end
See Also
App Members
NFX Namespace


App Members

App Members NFX Class Library

The App type exposes the following members.
Methods
Name | Description
LocalizedTimeToUniversalTime | Converts localized time to universal time as of TimeLocation property
UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property
Back to Top
Properties
Name | Description
Active | Returns true when application instance is active and working. This property returns false as soon as application finalization starts on shutdown Use to exit long-running loops and such
Available | Returns true when application container is active non-NOPApplication instance
ConfigRoot | References application configuration root
CurrentCallUser | Returns the current call context user
DataStore | References application data store
EventTimer | References event timer that maintains and runs scheduled Event instances
Glue | References glue implementation that may be used to "glue" remote instances/processes/contracts together
Instance |
InstanceID | Returns unique identifier of this running instance
Instrumentation | References instrumentation for this application instance
LocalizedTime | Returns current time localized per TimeLocation
Log | References app log
Name | Returns application name
ObjectStore | References object store that may be used to persist object graphs between volatile application shutdown cycles
SecurityManager | References security manager that performs user authentication based on passed credentials and other security-related global tasks
Session | Returns current session, this is a shortuct to ExecutionContext.Session
StartTime | Returns timestamp when application started as localized app time
Throttling | References throttling for this application instance
TimeLocation | Returns the location
TimeSource | References time source - an entity that supplies local and UTC times. The concrete implementation may elect to get accurate times from the network or other external precision time sources (i.e. NASA atomic clock)
Back to Top
See Also
App Class
NFX Namespace


App Methods

App Methods NFX Class Library

The App type exposes the following members.
Methods
Name | Description
LocalizedTimeToUniversalTime | Converts localized time to universal time as of TimeLocation property
UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property
Back to Top
See Also
App Class
NFX Namespace


App.LocalizedTimeToUniversalTime Method

App LocalizedTimeToUniversalTime Method NFX Class Library

Converts localized time to universal time as of TimeLocation property

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
public static DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
Public Shared Function LocalizedTimeToUniversalTime (
    local As DateTime
) As DateTime
Public Shared Function LocalizedTimeToUniversalTime (
    local As DateTime
) As DateTime
public:
static DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
public:
static DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
static member LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
static member LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime

Parameters

local
Type: Online System DateTime

Return Value

Type: Online DateTime
See Also
App Class
App Members
NFX Namespace


App.UniversalTimeToLocalizedTime Method

App UniversalTimeToLocalizedTime Method NFX Class Library

Converts universal time to local time as of TimeLocation property

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
public static DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
Public Shared Function UniversalTimeToLocalizedTime (
    utc As DateTime
) As DateTime
Public Shared Function UniversalTimeToLocalizedTime (
    utc As DateTime
) As DateTime
public:
static DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
public:
static DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
static member UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
static member UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime

Parameters

utc
Type: Online System DateTime

Return Value

Type: Online DateTime
See Also
App Class
App Members
NFX Namespace


App Properties

App Properties NFX Class Library

The App type exposes the following members.
Properties
Name | Description
Active | Returns true when application instance is active and working. This property returns false as soon as application finalization starts on shutdown Use to exit long-running loops and such
Available | Returns true when application container is active non-NOPApplication instance
ConfigRoot | References application configuration root
CurrentCallUser | Returns the current call context user
DataStore | References application data store
EventTimer | References event timer that maintains and runs scheduled Event instances
Glue | References glue implementation that may be used to "glue" remote instances/processes/contracts together
Instance |
InstanceID | Returns unique identifier of this running instance
Instrumentation | References instrumentation for this application instance
LocalizedTime | Returns current time localized per TimeLocation
Log | References app log
Name | Returns application name
ObjectStore | References object store that may be used to persist object graphs between volatile application shutdown cycles
SecurityManager | References security manager that performs user authentication based on passed credentials and other security-related global tasks
Session | Returns current session, this is a shortuct to ExecutionContext.Session
StartTime | Returns timestamp when application started as localized app time
Throttling | References throttling for this application instance
TimeLocation | Returns the location
TimeSource | References time source - an entity that supplies local and UTC times. The concrete implementation may elect to get accurate times from the network or other external precision time sources (i.e. NASA atomic clock)
Back to Top
See Also
App Class
NFX Namespace


App.Active Property

App Active Property NFX Class Library

Returns true when application instance is active and working. This property returns false as soon as application finalization starts on shutdown Use to exit long-running loops and such

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool Active { get; }
public static bool Active { get; }
Public Shared ReadOnly Property Active As Boolean
    Get
Public Shared ReadOnly Property Active As Boolean
    Get
public:
static property bool Active {
    bool get ();
}
public:
static property bool Active {
    bool get ();
}
static member Active : bool with get
static member Active : bool with get

Property Value

Type: Online Boolean
See Also
App Class
App Members
NFX Namespace


App.Available Property

App Available Property NFX Class Library

Returns true when application container is active non-NOPApplication instance

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool Available { get; }
public static bool Available { get; }
Public Shared ReadOnly Property Available As Boolean
    Get
Public Shared ReadOnly Property Available As Boolean
    Get
public:
static property bool Available {
    bool get ();
}
public:
static property bool Available {
    bool get ();
}
static member Available : bool with get
static member Available : bool with get

Property Value

Type: Online Boolean
See Also
App Class
App Members
NFX Namespace


App.ConfigRoot Property

App ConfigRoot Property NFX Class Library

References application configuration root

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ConfigSectionNode ConfigRoot { get; }
public static ConfigSectionNode ConfigRoot { get; }
Public Shared ReadOnly Property ConfigRoot As ConfigSectionNode
    Get
Public Shared ReadOnly Property ConfigRoot As ConfigSectionNode
    Get
public:
static property ConfigSectionNode^ ConfigRoot {
    ConfigSectionNode^ get ();
}
public:
static property ConfigSectionNode^ ConfigRoot {
    ConfigSectionNode^ get ();
}
static member ConfigRoot : ConfigSectionNode with get
static member ConfigRoot : ConfigSectionNode with get

Property Value

Type: ConfigSectionNode
See Also
App Class
App Members
NFX Namespace


App.CurrentCallUser Property

App CurrentCallUser Property NFX Class Library

Returns the current call context user

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static User CurrentCallUser { get; }
public static User CurrentCallUser { get; }
Public Shared ReadOnly Property CurrentCallUser As User
    Get
Public Shared ReadOnly Property CurrentCallUser As User
    Get
public:
static property User^ CurrentCallUser {
    User^ get ();
}
public:
static property User^ CurrentCallUser {
    User^ get ();
}
static member CurrentCallUser : User with get
static member CurrentCallUser : User with get

Property Value

Type: User
See Also
App Class
App Members
NFX Namespace


App.DataStore Property

App DataStore Property NFX Class Library

References application data store

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IDataStore DataStore { get; }
public static IDataStore DataStore { get; }
Public Shared ReadOnly Property DataStore As IDataStore
    Get
Public Shared ReadOnly Property DataStore As IDataStore
    Get
public:
static property IDataStore^ DataStore {
    IDataStore^ get ();
}
public:
static property IDataStore^ DataStore {
    IDataStore^ get ();
}
static member DataStore : IDataStore with get
static member DataStore : IDataStore with get

Property Value

Type: IDataStore
See Also
App Class
App Members
NFX Namespace


App.EventTimer Property

App EventTimer Property NFX Class Library

References event timer that maintains and runs scheduled Event instances

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEventTimer EventTimer { get; }
public static IEventTimer EventTimer { get; }
Public Shared ReadOnly Property EventTimer As IEventTimer
    Get
Public Shared ReadOnly Property EventTimer As IEventTimer
    Get
public:
static property IEventTimer^ EventTimer {
    IEventTimer^ get ();
}
public:
static property IEventTimer^ EventTimer {
    IEventTimer^ get ();
}
static member EventTimer : IEventTimer with get
static member EventTimer : IEventTimer with get

Property Value

Type: IEventTimer
See Also
App Class
App Members
NFX Namespace


App.Glue Property

App Glue Property NFX Class Library

References glue implementation that may be used to "glue" remote instances/processes/contracts together

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IGlue Glue { get; }
public static IGlue Glue { get; }
Public Shared ReadOnly Property Glue As IGlue
    Get
Public Shared ReadOnly Property Glue As IGlue
    Get
public:
static property IGlue^ Glue {
    IGlue^ get ();
}
public:
static property IGlue^ Glue {
    IGlue^ get ();
}
static member Glue : IGlue with get
static member Glue : IGlue with get

Property Value

Type: IGlue
See Also
App Class
App Members
NFX Namespace


App.Instance Property

App Instance Property NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IApplication Instance { get; }
public static IApplication Instance { get; }
Public Shared ReadOnly Property Instance As IApplication
    Get
Public Shared ReadOnly Property Instance As IApplication
    Get
public:
static property IApplication^ Instance {
    IApplication^ get ();
}
public:
static property IApplication^ Instance {
    IApplication^ get ();
}
static member Instance : IApplication with get
static member Instance : IApplication with get

Property Value

Type: IApplication
See Also
App Class
App Members
NFX Namespace


App.InstanceID Property

App InstanceID Property NFX Class Library

Returns unique identifier of this running instance

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Guid InstanceID { get; }
public static Guid InstanceID { get; }
Public Shared ReadOnly Property InstanceID As Guid
    Get
Public Shared ReadOnly Property InstanceID As Guid
    Get
public:
static property Guid InstanceID {
    Guid get ();
}
public:
static property Guid InstanceID {
    Guid get ();
}
static member InstanceID : Guid with get
static member InstanceID : Guid with get

Property Value

Type: Online Guid
See Also
App Class
App Members
NFX Namespace


App.Instrumentation Property

App Instrumentation Property NFX Class Library

References instrumentation for this application instance

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IInstrumentation Instrumentation { get; }
public static IInstrumentation Instrumentation { get; }
Public Shared ReadOnly Property Instrumentation As IInstrumentation
    Get
Public Shared ReadOnly Property Instrumentation As IInstrumentation
    Get
public:
static property IInstrumentation^ Instrumentation {
    IInstrumentation^ get ();
}
public:
static property IInstrumentation^ Instrumentation {
    IInstrumentation^ get ();
}
static member Instrumentation : IInstrumentation with get
static member Instrumentation : IInstrumentation with get

Property Value

Type: IInstrumentation
See Also
App Class
App Members
NFX Namespace


App.LocalizedTime Property

App LocalizedTime Property NFX Class Library

Returns current time localized per TimeLocation

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DateTime LocalizedTime { get; }
public static DateTime LocalizedTime { get; }
Public Shared ReadOnly Property LocalizedTime As DateTime
    Get
Public Shared ReadOnly Property LocalizedTime As DateTime
    Get
public:
static property DateTime LocalizedTime {
    DateTime get ();
}
public:
static property DateTime LocalizedTime {
    DateTime get ();
}
static member LocalizedTime : DateTime with get
static member LocalizedTime : DateTime with get

Property Value

Type: Online DateTime
See Also
App Class
App Members
NFX Namespace


App.Log Property

App Log Property NFX Class Library

References app log

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILog Log { get; }
public static ILog Log { get; }
Public Shared ReadOnly Property Log As ILog
    Get
Public Shared ReadOnly Property Log As ILog
    Get
public:
static property ILog^ Log {
    ILog^ get ();
}
public:
static property ILog^ Log {
    ILog^ get ();
}
static member Log : ILog with get
static member Log : ILog with get

Property Value

Type: ILog
See Also
App Class
App Members
NFX Namespace


App.Name Property

App Name Property NFX Class Library

Returns application name

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Name { get; }
public static string Name { get; }
Public Shared ReadOnly Property Name As String
    Get
Public Shared ReadOnly Property Name As String
    Get
public:
static property String^ Name {
    String^ get ();
}
public:
static property String^ Name {
    String^ get ();
}
static member Name : string with get
static member Name : string with get

Property Value

Type: Online String
See Also
App Class
App Members
NFX Namespace


App.ObjectStore Property

App ObjectStore Property NFX Class Library

References object store that may be used to persist object graphs between volatile application shutdown cycles

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IObjectStore ObjectStore { get; }
public static IObjectStore ObjectStore { get; }
Public Shared ReadOnly Property ObjectStore As IObjectStore
    Get
Public Shared ReadOnly Property ObjectStore As IObjectStore
    Get
public:
static property IObjectStore^ ObjectStore {
    IObjectStore^ get ();
}
public:
static property IObjectStore^ ObjectStore {
    IObjectStore^ get ();
}
static member ObjectStore : IObjectStore with get
static member ObjectStore : IObjectStore with get

Property Value

Type: IObjectStore
See Also
App Class
App Members
NFX Namespace


App.SecurityManager Property

App SecurityManager Property NFX Class Library

References security manager that performs user authentication based on passed credentials and other security-related global tasks

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ISecurityManager SecurityManager { get; }
public static ISecurityManager SecurityManager { get; }
Public Shared ReadOnly Property SecurityManager As ISecurityManager
    Get
Public Shared ReadOnly Property SecurityManager As ISecurityManager
    Get
public:
static property ISecurityManager^ SecurityManager {
    ISecurityManager^ get ();
}
public:
static property ISecurityManager^ SecurityManager {
    ISecurityManager^ get ();
}
static member SecurityManager : ISecurityManager with get
static member SecurityManager : ISecurityManager with get

Property Value

Type: ISecurityManager
See Also
App Class
App Members
NFX Namespace


App.Session Property

App Session Property NFX Class Library

Returns current session, this is a shortuct to ExecutionContext.Session

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ISession Session { get; }
public static ISession Session { get; }
Public Shared ReadOnly Property Session As ISession
    Get
Public Shared ReadOnly Property Session As ISession
    Get
public:
static property ISession^ Session {
    ISession^ get ();
}
public:
static property ISession^ Session {
    ISession^ get ();
}
static member Session : ISession with get
static member Session : ISession with get

Property Value

Type: ISession
See Also
App Class
App Members
NFX Namespace


App.StartTime Property

App StartTime Property NFX Class Library

Returns timestamp when application started as localized app time

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DateTime StartTime { get; }
public static DateTime StartTime { get; }
Public Shared ReadOnly Property StartTime As DateTime
    Get
Public Shared ReadOnly Property StartTime As DateTime
    Get
public:
static property DateTime StartTime {
    DateTime get ();
}
public:
static property DateTime StartTime {
    DateTime get ();
}
static member StartTime : DateTime with get
static member StartTime : DateTime with get

Property Value

Type: Online DateTime
See Also
App Class
App Members
NFX Namespace


App.Throttling Property

App Throttling Property NFX Class Library

References throttling for this application instance

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IThrottling Throttling { get; }
public static IThrottling Throttling { get; }
Public Shared ReadOnly Property Throttling As IThrottling
    Get
Public Shared ReadOnly Property Throttling As IThrottling
    Get
public:
static property IThrottling^ Throttling {
    IThrottling^ get ();
}
public:
static property IThrottling^ Throttling {
    IThrottling^ get ();
}
static member Throttling : IThrottling with get
static member Throttling : IThrottling with get

Property Value

Type: IThrottling
See Also
App Class
App Members
NFX Namespace


App.TimeLocation Property

App TimeLocation Property NFX Class Library

Returns the location

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TimeLocation TimeLocation { get; }
public static TimeLocation TimeLocation { get; }
Public Shared ReadOnly Property TimeLocation As TimeLocation
    Get
Public Shared ReadOnly Property TimeLocation As TimeLocation
    Get
public:
static property TimeLocation^ TimeLocation {
    TimeLocation^ get ();
}
public:
static property TimeLocation^ TimeLocation {
    TimeLocation^ get ();
}
static member TimeLocation : TimeLocation with get
static member TimeLocation : TimeLocation with get

Property Value

Type: TimeLocation
See Also
App Class
App Members
NFX Namespace


App.TimeSource Property

App TimeSource Property NFX Class Library

References time source - an entity that supplies local and UTC times. The concrete implementation may elect to get accurate times from the network or other external precision time sources (i.e. NASA atomic clock)

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ITimeSource TimeSource { get; }
public static ITimeSource TimeSource { get; }
Public Shared ReadOnly Property TimeSource As ITimeSource
    Get
Public Shared ReadOnly Property TimeSource As ITimeSource
    Get
public:
static property ITimeSource^ TimeSource {
    ITimeSource^ get ();
}
public:
static property ITimeSource^ TimeSource {
    ITimeSource^ get ();
}
static member TimeSource : ITimeSource with get
static member TimeSource : ITimeSource with get

Property Value

Type: ITimeSource
See Also
App Class
App Members
NFX Namespace


Aver Class

Aver Class NFX Class Library

Provides basic averments for test construction. May call Aver.Fail(msg) manually
Inheritance Hierarchy
Online System Object
NFX Aver

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class Aver
public static class Aver
<ExtensionAttribute>
Public NotInheritable Class Aver
<ExtensionAttribute>
Public NotInheritable Class Aver
[ExtensionAttribute]
public ref class Aver abstract sealed
[ExtensionAttribute]
public ref class Aver abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Aver =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Aver =  class end
See Also
Aver Members
NFX Namespace


Aver Members

Aver Members NFX Class Library

The Aver type exposes the following members.
Methods
Name | Description
AreEqual(String, String, String) |
AreEqual(String, String, StringComparison, String) |
AreEqual T (Nullable T , Nullable T , String) |
AreEqual T (T, T, String) |
AreEqualTest T |
AreNotEqual(String, String, String) |
AreNotEqual(String, String, StringComparison, String) |
AreNotEqual T (Nullable T , Nullable T , String) |
AreNotEqual T (T, T, String) |
AreNotSameRef |
AreNotWithin(Decimal, Decimal, Decimal, String) |
AreNotWithin(Double, Double, Double, String) |
AreNotWithin(Single, Single, Single, String) |
AreObjectEqualTest | Test for equality via object.Equals()only disregarding all other possible equality comparers like IEquatable etc...
AreObjectsEqual | Test for equality via object.Equals()only disregarding all other possible equality comparers like IEquatable etc...
AreObjectsNotEqual | Test for inequality via object.Equals()only disregarding all other possible equality comparers like IEquatable etc...
AreSameRef |
AreSameRefTest |
AreWithin(Decimal, Decimal, Decimal, String) |
AreWithin(Double, Double, Double, String) |
AreWithin(Single, Single, Single, String) |
AreWithinTest(Decimal, Decimal, Decimal) |
AreWithinTest(Double, Double, Double) |
AreWithinTest(Single, Single, Single) |
Fail | Fails averment by throwing AvermentException
IsFalse |
IsNotNull(Object, String) |
IsNotNull T (Nullable T , String) |
IsNull(Object, String) |
IsNull T (Nullable T , String) |
IsTrue |
Back to Top
See Also
Aver Class
NFX Namespace


Aver Methods

Aver Methods NFX Class Library

The Aver type exposes the following members.
Methods
Name | Description
AreEqual(String, String, String) |
AreEqual(String, String, StringComparison, String) |
AreEqual T (Nullable T , Nullable T , String) |
AreEqual T (T, T, String) |
AreEqualTest T |
AreNotEqual(String, String, String) |
AreNotEqual(String, String, StringComparison, String) |
AreNotEqual T (Nullable T , Nullable T , String) |
AreNotEqual T (T, T, String) |
AreNotSameRef |
AreNotWithin(Decimal, Decimal, Decimal, String) |
AreNotWithin(Double, Double, Double, String) |
AreNotWithin(Single, Single, Single, String) |
AreObjectEqualTest | Test for equality via object.Equals()only disregarding all other possible equality comparers like IEquatable etc...
AreObjectsEqual | Test for equality via object.Equals()only disregarding all other possible equality comparers like IEquatable etc...
AreObjectsNotEqual | Test for inequality via object.Equals()only disregarding all other possible equality comparers like IEquatable etc...
AreSameRef |
AreSameRefTest |
AreWithin(Decimal, Decimal, Decimal, String) |
AreWithin(Double, Double, Double, String) |
AreWithin(Single, Single, Single, String) |
AreWithinTest(Decimal, Decimal, Decimal) |
AreWithinTest(Double, Double, Double) |
AreWithinTest(Single, Single, Single) |
Fail | Fails averment by throwing AvermentException
IsFalse |
IsNotNull(Object, String) |
IsNotNull T (Nullable T , String) |
IsNull(Object, String) |
IsNull T (Nullable T , String) |
IsTrue |
Back to Top
See Also
Aver Class
NFX Namespace


Aver.AreEqual Method

Aver AreEqual Method NFX Class Library

Overload List
Name | Description
AreEqual T (Nullable T , Nullable T , String) |
AreEqual(String, String, String) |
AreEqual T (T, T, String) |
AreEqual(String, String, StringComparison, String) |
Back to Top
See Also
Aver Class
Aver Members
NFX Namespace


Aver.AreEqual(T) Method (Nullable(T), Nullable(T), String)

Aver AreEqual T Method (Nullable T , Nullable T , String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AreEqual<T>(
    Nullable<T> expect,
    Nullable<T> got,
    string from = null
)
where T : struct, new(), IEquatable<T>
public static void AreEqual<T>(
    Nullable<T> expect,
    Nullable<T> got,
    string from = null
)
where T : struct, new(), IEquatable<T>
Public Shared Sub AreEqual(Of T As {Structure, New, IEquatable(Of T)}) (
    expect As Nullable(Of T),
    got As Nullable(Of T),
    Optional from As String = Nothing
)
Public Shared Sub AreEqual(Of T As {Structure, New, IEquatable(Of T)}) (
    expect As Nullable(Of T),
    got As Nullable(Of T),
    Optional from As String = Nothing
)
public:
generic<typename T>
where T : value class, gcnew(), IEquatable<T>
static void AreEqual(
    Nullable<T> expect,
    Nullable<T> got,
    String^ from = nullptr
)
public:
generic<typename T>
where T : value class, gcnew(), IEquatable<T>
static void AreEqual(
    Nullable<T> expect,
    Nullable<T> got,
    String^ from = nullptr
)
static member AreEqual :
        expect : Nullable<'T> *
        got : Nullable<'T> *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit  when 'T : struct, new() and IEquatable<'T>
static member AreEqual :
        expect : Nullable<'T> *
        got : Nullable<'T> *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit  when 'T : struct, new() and IEquatable<'T>

Parameters

expect
Type: Online System Nullable T
got
Type: Online System Nullable T
from (Optional)
Type: Online System String
Type Parameters
T
See Also
Aver Class
Aver Members
AreEqual Overload
NFX Namespace


Aver.AreEqual Method (String, String, String)

Aver AreEqual Method (String, String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AreEqual(
    string expect,
    string got,
    string from = null
)
public static void AreEqual(
    string expect,
    string got,
    string from = null
)
Public Shared Sub AreEqual (
    expect As String,
    got As String,
    Optional from As String = Nothing
)
Public Shared Sub AreEqual (
    expect As String,
    got As String,
    Optional from As String = Nothing
)
public:
static void AreEqual(
    String^ expect,
    String^ got,
    String^ from = nullptr
)
public:
static void AreEqual(
    String^ expect,
    String^ got,
    String^ from = nullptr
)
static member AreEqual :
        expect : string *
        got : string *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit
static member AreEqual :
        expect : string *
        got : string *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit

Parameters

expect
Type: Online System String
got
Type: Online System String
from (Optional)
Type: Online System String
See Also
Aver Class
Aver Members
AreEqual Overload
NFX Namespace


Aver.AreEqual(T) Method (T, T, String)

Aver AreEqual T Method (T, T, String) NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AreEqual<T>(
    T expect,
    T got,
    string from = null
)
where T : Object, IEquatable<T>
public static void AreEqual<T>(
    T expect,
    T got,
    string from = null
)
where T : Object, IEquatable<T>
Public Shared Sub AreEqual(Of T As {Object, IEquatable(Of T)}) (
    expect As T,
    got As T,
    Optional from As String = Nothing
)
Public Shared Sub AreEqual(Of T As {Object, IEquatable(Of T)}) (
    expect As T,
    got As T,
    Optional from As String = Nothing
)
public:
generic<typename T>
where T : Object, IEquatable<T>
static void AreEqual(
    T expect,
    T got,
    String^ from = nullptr
)
public:
generic<typename T>
where T : Object, IEquatable<T>
static void AreEqual(
    T expect,
    T got,
    String^ from = nullptr
)
static member AreEqual :
        expect : 'T *
        got : 'T *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit  when 'T : Object and IEquatable<'T>
static member AreEqual :
        expect : 'T *
        got : 'T *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit  when 'T : Object and IEquatable<'T>

Parameters

expect
Type: T
got
Type: T
from (Optional)
Type: Online System String
Type Parameters
T
See Also
Aver Class
Aver Members
AreEqual Overload
NFX Namespace


Aver.AreEqual Method (String, String, StringComparison, String)

Aver AreEqual Method (String, String, StringComparison, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AreEqual(
    string expect,
    string got,
    StringComparison comparison,
    string from = null
)
public static void AreEqual(
    string expect,
    string got,
    StringComparison comparison,
    string from = null
)
Public Shared Sub AreEqual (
    expect As String,
    got As String,
    comparison As StringComparison,
    Optional from As String = Nothing
)
Public Shared Sub AreEqual (
    expect As String,
    got As String,
    comparison As StringComparison,
    Optional from As String = Nothing
)
public:
static void AreEqual(
    String^ expect,
    String^ got,
    StringComparison comparison,
    String^ from = nullptr
)
public:
static void AreEqual(
    String^ expect,
    String^ got,
    StringComparison comparison,
    String^ from = nullptr
)
static member AreEqual :
        expect : string *
        got : string *
        comparison : StringComparison *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit
static member AreEqual :
        expect : string *
        got : string *
        comparison : StringComparison *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit

Parameters

expect
Type: Online System String
got
Type: Online System String
comparison
Type: Online System StringComparison
from (Optional)
Type: Online System String
See Also
Aver Class
Aver Members
AreEqual Overload
NFX Namespace


Aver.AreEqualTest(T) Method

Aver AreEqualTest T Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool AreEqualTest<T>(
    Nullable<T> expect,
    Nullable<T> got
)
where T : struct, new(), IEquatable<T>
public static bool AreEqualTest<T>(
    Nullable<T> expect,
    Nullable<T> got
)
where T : struct, new(), IEquatable<T>
Public Shared Function AreEqualTest(Of T As {Structure, New, IEquatable(Of T)}) (
    expect As Nullable(Of T),
    got As Nullable(Of T)
) As Boolean
Public Shared Function AreEqualTest(Of T As {Structure, New, IEquatable(Of T)}) (
    expect As Nullable(Of T),
    got As Nullable(Of T)
) As Boolean
public:
generic<typename T>
where T : value class, gcnew(), IEquatable<T>
static bool AreEqualTest(
    Nullable<T> expect,
    Nullable<T> got
)
public:
generic<typename T>
where T : value class, gcnew(), IEquatable<T>
static bool AreEqualTest(
    Nullable<T> expect,
    Nullable<T> got
)
static member AreEqualTest :
        expect : Nullable<'T> *
        got : Nullable<'T> -> bool  when 'T : struct, new() and IEquatable<'T>
static member AreEqualTest :
        expect : Nullable<'T> *
        got : Nullable<'T> -> bool  when 'T : struct, new() and IEquatable<'T>

Parameters

expect
Type: Online System Nullable T
got
Type: Online System Nullable T
Type Parameters
T

Return Value

Type: Online Boolean
See Also
Aver Class
Aver Members
NFX Namespace


Aver.AreNotEqual Method

Aver AreNotEqual Method NFX Class Library

Overload List
Name | Description
AreNotEqual T (Nullable T , Nullable T , String) |
AreNotEqual(String, String, String) |
AreNotEqual T (T, T, String) |
AreNotEqual(String, String, StringComparison, String) |
Back to Top
See Also
Aver Class
Aver Members
NFX Namespace


Aver.AreNotEqual(T) Method (Nullable(T), Nullable(T), String)

Aver AreNotEqual T Method (Nullable T , Nullable T , String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AreNotEqual<T>(
    Nullable<T> expect,
    Nullable<T> got,
    string from = null
)
where T : struct, new(), IEquatable<T>
public static void AreNotEqual<T>(
    Nullable<T> expect,
    Nullable<T> got,
    string from = null
)
where T : struct, new(), IEquatable<T>
Public Shared Sub AreNotEqual(Of T As {Structure, New, IEquatable(Of T)}) (
    expect As Nullable(Of T),
    got As Nullable(Of T),
    Optional from As String = Nothing
)
Public Shared Sub AreNotEqual(Of T As {Structure, New, IEquatable(Of T)}) (
    expect As Nullable(Of T),
    got As Nullable(Of T),
    Optional from As String = Nothing
)
public:
generic<typename T>
where T : value class, gcnew(), IEquatable<T>
static void AreNotEqual(
    Nullable<T> expect,
    Nullable<T> got,
    String^ from = nullptr
)
public:
generic<typename T>
where T : value class, gcnew(), IEquatable<T>
static void AreNotEqual(
    Nullable<T> expect,
    Nullable<T> got,
    String^ from = nullptr
)
static member AreNotEqual :
        expect : Nullable<'T> *
        got : Nullable<'T> *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit  when 'T : struct, new() and IEquatable<'T>
static member AreNotEqual :
        expect : Nullable<'T> *
        got : Nullable<'T> *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit  when 'T : struct, new() and IEquatable<'T>

Parameters

expect
Type: Online System Nullable T
got
Type: Online System Nullable T
from (Optional)
Type: Online System String
Type Parameters
T
See Also
Aver Class
Aver Members
AreNotEqual Overload
NFX Namespace


Aver.AreNotEqual Method (String, String, String)

Aver AreNotEqual Method (String, String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AreNotEqual(
    string expect,
    string got,
    string from = null
)
public static void AreNotEqual(
    string expect,
    string got,
    string from = null
)
Public Shared Sub AreNotEqual (
    expect As String,
    got As String,
    Optional from As String = Nothing
)
Public Shared Sub AreNotEqual (
    expect As String,
    got As String,
    Optional from As String = Nothing
)
public:
static void AreNotEqual(
    String^ expect,
    String^ got,
    String^ from = nullptr
)
public:
static void AreNotEqual(
    String^ expect,
    String^ got,
    String^ from = nullptr
)
static member AreNotEqual :
        expect : string *
        got : string *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit
static member AreNotEqual :
        expect : string *
        got : string *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit

Parameters

expect
Type: Online System String
got
Type: Online System String
from (Optional)
Type: Online System String
See Also
Aver Class
Aver Members
AreNotEqual Overload
NFX Namespace


Aver.AreNotEqual(T) Method (T, T, String)

Aver AreNotEqual T Method (T, T, String) NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AreNotEqual<T>(
    T expect,
    T got,
    string from = null
)
where T : Object, IEquatable<T>
public static void AreNotEqual<T>(
    T expect,
    T got,
    string from = null
)
where T : Object, IEquatable<T>
Public Shared Sub AreNotEqual(Of T As {Object, IEquatable(Of T)}) (
    expect As T,
    got As T,
    Optional from As String = Nothing
)
Public Shared Sub AreNotEqual(Of T As {Object, IEquatable(Of T)}) (
    expect As T,
    got As T,
    Optional from As String = Nothing
)
public:
generic<typename T>
where T : Object, IEquatable<T>
static void AreNotEqual(
    T expect,
    T got,
    String^ from = nullptr
)
public:
generic<typename T>
where T : Object, IEquatable<T>
static void AreNotEqual(
    T expect,
    T got,
    String^ from = nullptr
)
static member AreNotEqual :
        expect : 'T *
        got : 'T *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit  when 'T : Object and IEquatable<'T>
static member AreNotEqual :
        expect : 'T *
        got : 'T *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit  when 'T : Object and IEquatable<'T>

Parameters

expect
Type: T
got
Type: T
from (Optional)
Type: Online System String
Type Parameters
T
See Also
Aver Class
Aver Members
AreNotEqual Overload
NFX Namespace


Aver.AreNotEqual Method (String, String, StringComparison, String)

Aver AreNotEqual Method (String, String, StringComparison, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AreNotEqual(
    string expect,
    string got,
    StringComparison comparison,
    string from = null
)
public static void AreNotEqual(
    string expect,
    string got,
    StringComparison comparison,
    string from = null
)
Public Shared Sub AreNotEqual (
    expect As String,
    got As String,
    comparison As StringComparison,
    Optional from As String = Nothing
)
Public Shared Sub AreNotEqual (
    expect As String,
    got As String,
    comparison As StringComparison,
    Optional from As String = Nothing
)
public:
static void AreNotEqual(
    String^ expect,
    String^ got,
    StringComparison comparison,
    String^ from = nullptr
)
public:
static void AreNotEqual(
    String^ expect,
    String^ got,
    StringComparison comparison,
    String^ from = nullptr
)
static member AreNotEqual :
        expect : string *
        got : string *
        comparison : StringComparison *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit
static member AreNotEqual :
        expect : string *
        got : string *
        comparison : StringComparison *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit

Parameters

expect
Type: Online System String
got
Type: Online System String
comparison
Type: Online System StringComparison
from (Optional)
Type: Online System String
See Also
Aver Class
Aver Members
AreNotEqual Overload
NFX Namespace


Aver.AreNotSameRef Method

Aver AreNotSameRef Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AreNotSameRef(
    Object expect,
    Object got,
    string from = null
)
public static void AreNotSameRef(
    Object expect,
    Object got,
    string from = null
)
Public Shared Sub AreNotSameRef (
    expect As Object,
    got As Object,
    Optional from As String = Nothing
)
Public Shared Sub AreNotSameRef (
    expect As Object,
    got As Object,
    Optional from As String = Nothing
)
public:
static void AreNotSameRef(
    Object^ expect,
    Object^ got,
    String^ from = nullptr
)
public:
static void AreNotSameRef(
    Object^ expect,
    Object^ got,
    String^ from = nullptr
)
static member AreNotSameRef :
        expect : Object *
        got : Object *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit
static member AreNotSameRef :
        expect : Object *
        got : Object *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit

Parameters

expect
Type: Online System Object
got
Type: Online System Object
from (Optional)
Type: Online System String
See Also
Aver Class
Aver Members
NFX Namespace


Aver.AreNotWithin Method

Aver AreNotWithin Method NFX Class Library

Overload List
Name | Description
AreNotWithin(Decimal, Decimal, Decimal, String) |
AreNotWithin(Double, Double, Double, String) |
AreNotWithin(Single, Single, Single, String) |
Back to Top
See Also
Aver Class
Aver Members
NFX Namespace


Aver.AreNotWithin Method (Decimal, Decimal, Decimal, String)

Aver AreNotWithin Method (Decimal, Decimal, Decimal, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AreNotWithin(
    decimal expect,
    decimal got,
    decimal delta,
    string from = null
)
public static void AreNotWithin(
    decimal expect,
    decimal got,
    decimal delta,
    string from = null
)
Public Shared Sub AreNotWithin (
    expect As Decimal,
    got As Decimal,
    delta As Decimal,
    Optional from As String = Nothing
)
Public Shared Sub AreNotWithin (
    expect As Decimal,
    got As Decimal,
    delta As Decimal,
    Optional from As String = Nothing
)
public:
static void AreNotWithin(
    Decimal expect,
    Decimal got,
    Decimal delta,
    String^ from = nullptr
)
public:
static void AreNotWithin(
    Decimal expect,
    Decimal got,
    Decimal delta,
    String^ from = nullptr
)
static member AreNotWithin :
        expect : decimal *
        got : decimal *
        delta : decimal *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit
static member AreNotWithin :
        expect : decimal *
        got : decimal *
        delta : decimal *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit

Parameters

expect
Type: Online System Decimal
got
Type: Online System Decimal
delta
Type: Online System Decimal
from (Optional)
Type: Online System String
See Also
Aver Class
Aver Members
AreNotWithin Overload
NFX Namespace


Aver.AreNotWithin Method (Double, Double, Double, String)

Aver AreNotWithin Method (Double, Double, Double, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AreNotWithin(
    double expect,
    double got,
    double delta,
    string from = null
)
public static void AreNotWithin(
    double expect,
    double got,
    double delta,
    string from = null
)
Public Shared Sub AreNotWithin (
    expect As Double,
    got As Double,
    delta As Double,
    Optional from As String = Nothing
)
Public Shared Sub AreNotWithin (
    expect As Double,
    got As Double,
    delta As Double,
    Optional from As String = Nothing
)
public:
static void AreNotWithin(
    double expect,
    double got,
    double delta,
    String^ from = nullptr
)
public:
static void AreNotWithin(
    double expect,
    double got,
    double delta,
    String^ from = nullptr
)
static member AreNotWithin :
        expect : float *
        got : float *
        delta : float *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit
static member AreNotWithin :
        expect : float *
        got : float *
        delta : float *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit

Parameters

expect
Type: Online System Double
got
Type: Online System Double
delta
Type: Online System Double
from (Optional)
Type: Online System String
See Also
Aver Class
Aver Members
AreNotWithin Overload
NFX Namespace


Aver.AreNotWithin Method (Single, Single, Single, String)

Aver AreNotWithin Method (Single, Single, Single, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AreNotWithin(
    float expect,
    float got,
    float delta,
    string from = null
)
public static void AreNotWithin(
    float expect,
    float got,
    float delta,
    string from = null
)
Public Shared Sub AreNotWithin (
    expect As Single,
    got As Single,
    delta As Single,
    Optional from As String = Nothing
)
Public Shared Sub AreNotWithin (
    expect As Single,
    got As Single,
    delta As Single,
    Optional from As String = Nothing
)
public:
static void AreNotWithin(
    float expect,
    float got,
    float delta,
    String^ from = nullptr
)
public:
static void AreNotWithin(
    float expect,
    float got,
    float delta,
    String^ from = nullptr
)
static member AreNotWithin :
        expect : float32 *
        got : float32 *
        delta : float32 *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit
static member AreNotWithin :
        expect : float32 *
        got : float32 *
        delta : float32 *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit

Parameters

expect
Type: Online System Single
got
Type: Online System Single
delta
Type: Online System Single
from (Optional)
Type: Online System String
See Also
Aver Class
Aver Members
AreNotWithin Overload
NFX Namespace


Aver.AreObjectEqualTest Method

Aver AreObjectEqualTest Method NFX Class Library

Test for equality via object.Equals()only disregarding all other possible equality comparers like IEquatable etc...

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool AreObjectEqualTest(
    Object expect,
    Object got
)
public static bool AreObjectEqualTest(
    Object expect,
    Object got
)
Public Shared Function AreObjectEqualTest (
    expect As Object,
    got As Object
) As Boolean
Public Shared Function AreObjectEqualTest (
    expect As Object,
    got As Object
) As Boolean
public:
static bool AreObjectEqualTest(
    Object^ expect,
    Object^ got
)
public:
static bool AreObjectEqualTest(
    Object^ expect,
    Object^ got
)
static member AreObjectEqualTest :
        expect : Object *
        got : Object -> bool
static member AreObjectEqualTest :
        expect : Object *
        got : Object -> bool

Parameters

expect
Type: Online System Object
got
Type: Online System Object

Return Value

Type: Online Boolean
See Also
Aver Class
Aver Members
NFX Namespace


Aver.AreObjectsEqual Method

Aver AreObjectsEqual Method NFX Class Library

Test for equality via object.Equals()only disregarding all other possible equality comparers like IEquatable etc...

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AreObjectsEqual(
    Object expect,
    Object got,
    string from = null
)
public static void AreObjectsEqual(
    Object expect,
    Object got,
    string from = null
)
Public Shared Sub AreObjectsEqual (
    expect As Object,
    got As Object,
    Optional from As String = Nothing
)
Public Shared Sub AreObjectsEqual (
    expect As Object,
    got As Object,
    Optional from As String = Nothing
)
public:
static void AreObjectsEqual(
    Object^ expect,
    Object^ got,
    String^ from = nullptr
)
public:
static void AreObjectsEqual(
    Object^ expect,
    Object^ got,
    String^ from = nullptr
)
static member AreObjectsEqual :
        expect : Object *
        got : Object *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit
static member AreObjectsEqual :
        expect : Object *
        got : Object *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit

Parameters

expect
Type: Online System Object
got
Type: Online System Object
from (Optional)
Type: Online System String
See Also
Aver Class
Aver Members
NFX Namespace


Aver.AreObjectsNotEqual Method

Aver AreObjectsNotEqual Method NFX Class Library

Test for inequality via object.Equals()only disregarding all other possible equality comparers like IEquatable etc...

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AreObjectsNotEqual(
    Object expect,
    Object got,
    string from = null
)
public static void AreObjectsNotEqual(
    Object expect,
    Object got,
    string from = null
)
Public Shared Sub AreObjectsNotEqual (
    expect As Object,
    got As Object,
    Optional from As String = Nothing
)
Public Shared Sub AreObjectsNotEqual (
    expect As Object,
    got As Object,
    Optional from As String = Nothing
)
public:
static void AreObjectsNotEqual(
    Object^ expect,
    Object^ got,
    String^ from = nullptr
)
public:
static void AreObjectsNotEqual(
    Object^ expect,
    Object^ got,
    String^ from = nullptr
)
static member AreObjectsNotEqual :
        expect : Object *
        got : Object *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit
static member AreObjectsNotEqual :
        expect : Object *
        got : Object *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit

Parameters

expect
Type: Online System Object
got
Type: Online System Object
from (Optional)
Type: Online System String
See Also
Aver Class
Aver Members
NFX Namespace


Aver.AreSameRef Method

Aver AreSameRef Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AreSameRef(
    Object expect,
    Object got,
    string from = null
)
public static void AreSameRef(
    Object expect,
    Object got,
    string from = null
)
Public Shared Sub AreSameRef (
    expect As Object,
    got As Object,
    Optional from As String = Nothing
)
Public Shared Sub AreSameRef (
    expect As Object,
    got As Object,
    Optional from As String = Nothing
)
public:
static void AreSameRef(
    Object^ expect,
    Object^ got,
    String^ from = nullptr
)
public:
static void AreSameRef(
    Object^ expect,
    Object^ got,
    String^ from = nullptr
)
static member AreSameRef :
        expect : Object *
        got : Object *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit
static member AreSameRef :
        expect : Object *
        got : Object *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit

Parameters

expect
Type: Online System Object
got
Type: Online System Object
from (Optional)
Type: Online System String
See Also
Aver Class
Aver Members
NFX Namespace


Aver.AreSameRefTest Method

Aver AreSameRefTest Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool AreSameRefTest(
    Object expect,
    Object got
)
public static bool AreSameRefTest(
    Object expect,
    Object got
)
Public Shared Function AreSameRefTest (
    expect As Object,
    got As Object
) As Boolean
Public Shared Function AreSameRefTest (
    expect As Object,
    got As Object
) As Boolean
public:
static bool AreSameRefTest(
    Object^ expect,
    Object^ got
)
public:
static bool AreSameRefTest(
    Object^ expect,
    Object^ got
)
static member AreSameRefTest :
        expect : Object *
        got : Object -> bool
static member AreSameRefTest :
        expect : Object *
        got : Object -> bool

Parameters

expect
Type: Online System Object
got
Type: Online System Object

Return Value

Type: Online Boolean
See Also
Aver Class
Aver Members
NFX Namespace


Aver.AreWithin Method

Aver AreWithin Method NFX Class Library

Overload List
Name | Description
AreWithin(Decimal, Decimal, Decimal, String) |
AreWithin(Double, Double, Double, String) |
AreWithin(Single, Single, Single, String) |
Back to Top
See Also
Aver Class
Aver Members
NFX Namespace


Aver.AreWithin Method (Decimal, Decimal, Decimal, String)

Aver AreWithin Method (Decimal, Decimal, Decimal, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AreWithin(
    decimal expect,
    decimal got,
    decimal delta,
    string from = null
)
public static void AreWithin(
    decimal expect,
    decimal got,
    decimal delta,
    string from = null
)
Public Shared Sub AreWithin (
    expect As Decimal,
    got As Decimal,
    delta As Decimal,
    Optional from As String = Nothing
)
Public Shared Sub AreWithin (
    expect As Decimal,
    got As Decimal,
    delta As Decimal,
    Optional from As String = Nothing
)
public:
static void AreWithin(
    Decimal expect,
    Decimal got,
    Decimal delta,
    String^ from = nullptr
)
public:
static void AreWithin(
    Decimal expect,
    Decimal got,
    Decimal delta,
    String^ from = nullptr
)
static member AreWithin :
        expect : decimal *
        got : decimal *
        delta : decimal *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit
static member AreWithin :
        expect : decimal *
        got : decimal *
        delta : decimal *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit

Parameters

expect
Type: Online System Decimal
got
Type: Online System Decimal
delta
Type: Online System Decimal
from (Optional)
Type: Online System String
See Also
Aver Class
Aver Members
AreWithin Overload
NFX Namespace


Aver.AreWithin Method (Double, Double, Double, String)

Aver AreWithin Method (Double, Double, Double, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AreWithin(
    double expect,
    double got,
    double delta,
    string from = null
)
public static void AreWithin(
    double expect,
    double got,
    double delta,
    string from = null
)
Public Shared Sub AreWithin (
    expect As Double,
    got As Double,
    delta As Double,
    Optional from As String = Nothing
)
Public Shared Sub AreWithin (
    expect As Double,
    got As Double,
    delta As Double,
    Optional from As String = Nothing
)
public:
static void AreWithin(
    double expect,
    double got,
    double delta,
    String^ from = nullptr
)
public:
static void AreWithin(
    double expect,
    double got,
    double delta,
    String^ from = nullptr
)
static member AreWithin :
        expect : float *
        got : float *
        delta : float *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit
static member AreWithin :
        expect : float *
        got : float *
        delta : float *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit

Parameters

expect
Type: Online System Double
got
Type: Online System Double
delta
Type: Online System Double
from (Optional)
Type: Online System String
See Also
Aver Class
Aver Members
AreWithin Overload
NFX Namespace


Aver.AreWithin Method (Single, Single, Single, String)

Aver AreWithin Method (Single, Single, Single, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AreWithin(
    float expect,
    float got,
    float delta,
    string from = null
)
public static void AreWithin(
    float expect,
    float got,
    float delta,
    string from = null
)
Public Shared Sub AreWithin (
    expect As Single,
    got As Single,
    delta As Single,
    Optional from As String = Nothing
)
Public Shared Sub AreWithin (
    expect As Single,
    got As Single,
    delta As Single,
    Optional from As String = Nothing
)
public:
static void AreWithin(
    float expect,
    float got,
    float delta,
    String^ from = nullptr
)
public:
static void AreWithin(
    float expect,
    float got,
    float delta,
    String^ from = nullptr
)
static member AreWithin :
        expect : float32 *
        got : float32 *
        delta : float32 *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit
static member AreWithin :
        expect : float32 *
        got : float32 *
        delta : float32 *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit

Parameters

expect
Type: Online System Single
got
Type: Online System Single
delta
Type: Online System Single
from (Optional)
Type: Online System String
See Also
Aver Class
Aver Members
AreWithin Overload
NFX Namespace


Aver.AreWithinTest Method

Aver AreWithinTest Method NFX Class Library

Overload List
Name | Description
AreWithinTest(Decimal, Decimal, Decimal) |
AreWithinTest(Double, Double, Double) |
AreWithinTest(Single, Single, Single) |
Back to Top
See Also
Aver Class
Aver Members
NFX Namespace


Aver.AreWithinTest Method (Decimal, Decimal, Decimal)

Aver AreWithinTest Method (Decimal, Decimal, Decimal) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool AreWithinTest(
    decimal expect,
    decimal got,
    decimal delta
)
public static bool AreWithinTest(
    decimal expect,
    decimal got,
    decimal delta
)
Public Shared Function AreWithinTest (
    expect As Decimal,
    got As Decimal,
    delta As Decimal
) As Boolean
Public Shared Function AreWithinTest (
    expect As Decimal,
    got As Decimal,
    delta As Decimal
) As Boolean
public:
static bool AreWithinTest(
    Decimal expect,
    Decimal got,
    Decimal delta
)
public:
static bool AreWithinTest(
    Decimal expect,
    Decimal got,
    Decimal delta
)
static member AreWithinTest :
        expect : decimal *
        got : decimal *
        delta : decimal -> bool
static member AreWithinTest :
        expect : decimal *
        got : decimal *
        delta : decimal -> bool

Parameters

expect
Type: Online System Decimal
got
Type: Online System Decimal
delta
Type: Online System Decimal

Return Value

Type: Online Boolean
See Also
Aver Class
Aver Members
AreWithinTest Overload
NFX Namespace


Aver.AreWithinTest Method (Double, Double, Double)

Aver AreWithinTest Method (Double, Double, Double) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool AreWithinTest(
    double expect,
    double got,
    double delta
)
public static bool AreWithinTest(
    double expect,
    double got,
    double delta
)
Public Shared Function AreWithinTest (
    expect As Double,
    got As Double,
    delta As Double
) As Boolean
Public Shared Function AreWithinTest (
    expect As Double,
    got As Double,
    delta As Double
) As Boolean
public:
static bool AreWithinTest(
    double expect,
    double got,
    double delta
)
public:
static bool AreWithinTest(
    double expect,
    double got,
    double delta
)
static member AreWithinTest :
        expect : float *
        got : float *
        delta : float -> bool
static member AreWithinTest :
        expect : float *
        got : float *
        delta : float -> bool

Parameters

expect
Type: Online System Double
got
Type: Online System Double
delta
Type: Online System Double

Return Value

Type: Online Boolean
See Also
Aver Class
Aver Members
AreWithinTest Overload
NFX Namespace


Aver.AreWithinTest Method (Single, Single, Single)

Aver AreWithinTest Method (Single, Single, Single) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool AreWithinTest(
    float expect,
    float got,
    float delta
)
public static bool AreWithinTest(
    float expect,
    float got,
    float delta
)
Public Shared Function AreWithinTest (
    expect As Single,
    got As Single,
    delta As Single
) As Boolean
Public Shared Function AreWithinTest (
    expect As Single,
    got As Single,
    delta As Single
) As Boolean
public:
static bool AreWithinTest(
    float expect,
    float got,
    float delta
)
public:
static bool AreWithinTest(
    float expect,
    float got,
    float delta
)
static member AreWithinTest :
        expect : float32 *
        got : float32 *
        delta : float32 -> bool
static member AreWithinTest :
        expect : float32 *
        got : float32 *
        delta : float32 -> bool

Parameters

expect
Type: Online System Single
got
Type: Online System Single
delta
Type: Online System Single

Return Value

Type: Online Boolean
See Also
Aver Class
Aver Members
AreWithinTest Overload
NFX Namespace


Aver.Fail Method

Aver Fail Method NFX Class Library

Fails averment by throwing AvermentException

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Fail(
    string message,
    string from = null
)
public static void Fail(
    string message,
    string from = null
)
Public Shared Sub Fail (
    message As String,
    Optional from As String = Nothing
)
Public Shared Sub Fail (
    message As String,
    Optional from As String = Nothing
)
public:
static void Fail(
    String^ message,
    String^ from = nullptr
)
public:
static void Fail(
    String^ message,
    String^ from = nullptr
)
static member Fail :
        message : string *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit
static member Fail :
        message : string *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit

Parameters

message
Type: Online System String
from (Optional)
Type: Online System String
See Also
Aver Class
Aver Members
NFX Namespace


Aver.IsFalse Method

Aver IsFalse Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void IsFalse(
    bool condition,
    string from = null
)
public static void IsFalse(
    bool condition,
    string from = null
)
Public Shared Sub IsFalse (
    condition As Boolean,
    Optional from As String = Nothing
)
Public Shared Sub IsFalse (
    condition As Boolean,
    Optional from As String = Nothing
)
public:
static void IsFalse(
    bool condition,
    String^ from = nullptr
)
public:
static void IsFalse(
    bool condition,
    String^ from = nullptr
)
static member IsFalse :
        condition : bool *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit
static member IsFalse :
        condition : bool *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit

Parameters

condition
Type: Online System Boolean
from (Optional)
Type: Online System String
See Also
Aver Class
Aver Members
NFX Namespace


Aver.IsNotNull Method

Aver IsNotNull Method NFX Class Library

Overload List
Name | Description
IsNotNull T (Nullable T , String) |
IsNotNull(Object, String) |
Back to Top
See Also
Aver Class
Aver Members
NFX Namespace


Aver.IsNotNull(T) Method (Nullable(T), String)

Aver IsNotNull T Method (Nullable T , String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void IsNotNull<T>(
    Nullable<T> got,
    string from = null
)
where T : struct, new()
public static void IsNotNull<T>(
    Nullable<T> got,
    string from = null
)
where T : struct, new()
Public Shared Sub IsNotNull(Of T As {Structure, New}) (
    got As Nullable(Of T),
    Optional from As String = Nothing
)
Public Shared Sub IsNotNull(Of T As {Structure, New}) (
    got As Nullable(Of T),
    Optional from As String = Nothing
)
public:
generic<typename T>
where T : value class, gcnew()
static void IsNotNull(
    Nullable<T> got,
    String^ from = nullptr
)
public:
generic<typename T>
where T : value class, gcnew()
static void IsNotNull(
    Nullable<T> got,
    String^ from = nullptr
)
static member IsNotNull :
        got : Nullable<'T> *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit  when 'T : struct, new()
static member IsNotNull :
        got : Nullable<'T> *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit  when 'T : struct, new()

Parameters

got
Type: Online System Nullable T
from (Optional)
Type: Online System String
Type Parameters
T
See Also
Aver Class
Aver Members
IsNotNull Overload
NFX Namespace


Aver.IsNotNull Method (Object, String)

Aver IsNotNull Method (Object, String) NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void IsNotNull(
    Object reference,
    string from = null
)
public static void IsNotNull(
    Object reference,
    string from = null
)
Public Shared Sub IsNotNull (
    reference As Object,
    Optional from As String = Nothing
)
Public Shared Sub IsNotNull (
    reference As Object,
    Optional from As String = Nothing
)
public:
static void IsNotNull(
    Object^ reference,
    String^ from = nullptr
)
public:
static void IsNotNull(
    Object^ reference,
    String^ from = nullptr
)
static member IsNotNull :
        reference : Object *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit
static member IsNotNull :
        reference : Object *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit

Parameters

reference
Type: Online System Object
from (Optional)
Type: Online System String
See Also
Aver Class
Aver Members
IsNotNull Overload
NFX Namespace


Aver.IsNull Method

Aver IsNull Method NFX Class Library

Overload List
Name | Description
IsNull T (Nullable T , String) |
IsNull(Object, String) |
Back to Top
See Also
Aver Class
Aver Members
NFX Namespace


Aver.IsNull(T) Method (Nullable(T), String)

Aver IsNull T Method (Nullable T , String) NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void IsNull<T>(
    Nullable<T> got,
    string from = null
)
where T : struct, new()
public static void IsNull<T>(
    Nullable<T> got,
    string from = null
)
where T : struct, new()
Public Shared Sub IsNull(Of T As {Structure, New}) (
    got As Nullable(Of T),
    Optional from As String = Nothing
)
Public Shared Sub IsNull(Of T As {Structure, New}) (
    got As Nullable(Of T),
    Optional from As String = Nothing
)
public:
generic<typename T>
where T : value class, gcnew()
static void IsNull(
    Nullable<T> got,
    String^ from = nullptr
)
public:
generic<typename T>
where T : value class, gcnew()
static void IsNull(
    Nullable<T> got,
    String^ from = nullptr
)
static member IsNull :
        got : Nullable<'T> *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit  when 'T : struct, new()
static member IsNull :
        got : Nullable<'T> *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit  when 'T : struct, new()

Parameters

got
Type: Online System Nullable T
from (Optional)
Type: Online System String
Type Parameters
T
See Also
Aver Class
Aver Members
IsNull Overload
NFX Namespace


Aver.IsNull Method (Object, String)

Aver IsNull Method (Object, String) NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void IsNull(
    Object reference,
    string from = null
)
public static void IsNull(
    Object reference,
    string from = null
)
Public Shared Sub IsNull (
    reference As Object,
    Optional from As String = Nothing
)
Public Shared Sub IsNull (
    reference As Object,
    Optional from As String = Nothing
)
public:
static void IsNull(
    Object^ reference,
    String^ from = nullptr
)
public:
static void IsNull(
    Object^ reference,
    String^ from = nullptr
)
static member IsNull :
        reference : Object *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit
static member IsNull :
        reference : Object *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit

Parameters

reference
Type: Online System Object
from (Optional)
Type: Online System String
See Also
Aver Class
Aver Members
IsNull Overload
NFX Namespace


Aver.IsTrue Method

Aver IsTrue Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void IsTrue(
    bool condition,
    string from = null
)
public static void IsTrue(
    bool condition,
    string from = null
)
Public Shared Sub IsTrue (
    condition As Boolean,
    Optional from As String = Nothing
)
Public Shared Sub IsTrue (
    condition As Boolean,
    Optional from As String = Nothing
)
public:
static void IsTrue(
    bool condition,
    String^ from = nullptr
)
public:
static void IsTrue(
    bool condition,
    String^ from = nullptr
)
static member IsTrue :
        condition : bool *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit
static member IsTrue :
        condition : bool *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit

Parameters

condition
Type: Online System Boolean
from (Optional)
Type: Online System String
See Also
Aver Class
Aver Members
NFX Namespace


AvermentException Class

AvermentException Class NFX Class Library

Thrown by Aver class to indicate averment failures
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX AvermentException

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class AvermentException : NFXException
[SerializableAttribute]
public sealed class AvermentException : NFXException
<SerializableAttribute>
Public NotInheritable Class AvermentException
    Inherits NFXException
<SerializableAttribute>
Public NotInheritable Class AvermentException
    Inherits NFXException
[SerializableAttribute]
public ref class AvermentException sealed : public NFXException
[SerializableAttribute]
public ref class AvermentException sealed : public NFXException
[<SealedAttribute>]
[<SerializableAttribute>]
type AvermentException =
    class
        inherit NFXException
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type AvermentException =
    class
        inherit NFXException
    end
See Also
AvermentException Members
NFX Namespace


AvermentException Members

AvermentException Members NFX Class Library

The AvermentException type exposes the following members.
Constructors
 | Name | Description
Public method | AvermentException | Initializes a new instance of the AvermentException class
Public method | AvermentException(SerializationInfo, StreamingContext) | Initializes a new instance of the AvermentException class
Public method | AvermentException(String, String) | Initializes a new instance of the AvermentException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | From |
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
AvermentException Class
NFX Namespace


AvermentException Constructor

AvermentException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | AvermentException | Initializes a new instance of the AvermentException class
Public method | AvermentException(SerializationInfo, StreamingContext) | Initializes a new instance of the AvermentException class
Public method | AvermentException(String, String) | Initializes a new instance of the AvermentException class
Back to Top
See Also
AvermentException Class
AvermentException Members
NFX Namespace


AvermentException Constructor

AvermentException Constructor NFX Class Library

Initializes a new instance of the AvermentException class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AvermentException()
public AvermentException()
Public Sub New
Public Sub New
public:
AvermentException()
public:
AvermentException()
new : unit -> AvermentException
new : unit -> AvermentException
See Also
AvermentException Class
AvermentException Members
AvermentException Overload
NFX Namespace


AvermentException Constructor (SerializationInfo, StreamingContext)

AvermentException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AvermentException class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AvermentException(
    SerializationInfo info,
    StreamingContext context
)
public AvermentException(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
AvermentException(
    SerializationInfo^ info,
    StreamingContext context
)
public:
AvermentException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> AvermentException
new :
        info : SerializationInfo *
        context : StreamingContext -> AvermentException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
AvermentException Class
AvermentException Members
AvermentException Overload
NFX Namespace


AvermentException Constructor (String, String)

AvermentException Constructor (String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AvermentException class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AvermentException(
    string message,
    string from = null
)
public AvermentException(
    string message,
    string from = null
)
Public Sub New (
    message As String,
    Optional from As String = Nothing
)
Public Sub New (
    message As String,
    Optional from As String = Nothing
)
public:
AvermentException(
    String^ message,
    String^ from = nullptr
)
public:
AvermentException(
    String^ message,
    String^ from = nullptr
)
new :
        message : string *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> AvermentException
new :
        message : string *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> AvermentException

Parameters

message
Type: Online System String
from (Optional)
Type: Online System String
See Also
AvermentException Class
AvermentException Members
AvermentException Overload
NFX Namespace


AvermentException Methods

AvermentException Methods NFX Class Library

The AvermentException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
AvermentException Class
NFX Namespace


AvermentException Properties

AvermentException Properties NFX Class Library

The AvermentException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | From |
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
AvermentException Class
NFX Namespace


AvermentException.From Property

AvermentException From Property NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string From { get; }
public string From { get; }
Public ReadOnly Property From As String
    Get
Public ReadOnly Property From As String
    Get
public:
property String^ From {
    String^ get ();
}
public:
property String^ From {
    String^ get ();
}
member From : string with get
member From : string with get

Property Value

Type: Online String
See Also
AvermentException Class
AvermentException Members
NFX Namespace


AvermentException Events

AvermentException Events NFX Class Library

The AvermentException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
AvermentException Class
NFX Namespace


CollectionUtils Class

CollectionUtils Class NFX Class Library

Some helpful extensions for standard collections
Inheritance Hierarchy
Online System Object
NFX CollectionUtils

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class CollectionUtils
public static class CollectionUtils
<ExtensionAttribute>
Public NotInheritable Class CollectionUtils
<ExtensionAttribute>
Public NotInheritable Class CollectionUtils
[ExtensionAttribute]
public ref class CollectionUtils abstract sealed
[ExtensionAttribute]
public ref class CollectionUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CollectionUtils =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CollectionUtils =  class end
See Also
CollectionUtils Members
NFX Namespace


CollectionUtils Members

CollectionUtils Members NFX Class Library

The CollectionUtils type exposes the following members.
Methods
Name | Description
AddRange TKey, TValue | Add all values from range sequence to src IDictionary. Source is actually modified.
AppendToNew T | Returns a new array that contains source elements with additional elements appended at the end
Distinct TResult, TKey |
FirstMax TResult, TComparand (IEnumerable TResult , Func TResult, TComparand ) |
FirstMax TResult, TComparand (IEnumerable TResult , Func TResult, TComparand , TComparand ) |
FirstMin TResult, TComparand (IEnumerable TResult , Func TResult, TComparand ) |
FirstMin TResult, TComparand (IEnumerable TResult , Func TResult, TComparand , TComparand ) |
FirstOrAnyOrDefault TResult | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null)
ForEach T (IEnumerable T , Action T ) | Runs some method over each element of src sequence
ForEach T (IEnumerable T , Action T, Int32 ) | Runs some method over each element of src sequence
SkipLast T (IEnumerable T ) | Takes all elements except for last element from the given source
SkipLast T (IEnumerable T , Int32) | Takes all but last N elements from the source
Back to Top
See Also
CollectionUtils Class
NFX Namespace


CollectionUtils Methods

CollectionUtils Methods NFX Class Library

The CollectionUtils type exposes the following members.
Methods
Name | Description
AddRange TKey, TValue | Add all values from range sequence to src IDictionary. Source is actually modified.
AppendToNew T | Returns a new array that contains source elements with additional elements appended at the end
Distinct TResult, TKey |
FirstMax TResult, TComparand (IEnumerable TResult , Func TResult, TComparand ) |
FirstMax TResult, TComparand (IEnumerable TResult , Func TResult, TComparand , TComparand ) |
FirstMin TResult, TComparand (IEnumerable TResult , Func TResult, TComparand ) |
FirstMin TResult, TComparand (IEnumerable TResult , Func TResult, TComparand , TComparand ) |
FirstOrAnyOrDefault TResult | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null)
ForEach T (IEnumerable T , Action T ) | Runs some method over each element of src sequence
ForEach T (IEnumerable T , Action T, Int32 ) | Runs some method over each element of src sequence
SkipLast T (IEnumerable T ) | Takes all elements except for last element from the given source
SkipLast T (IEnumerable T , Int32) | Takes all but last N elements from the source
Back to Top
See Also
CollectionUtils Class
NFX Namespace


CollectionUtils.AddRange(TKey, TValue) Method

CollectionUtils AddRange TKey, TValue Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Add all values from range sequence to src IDictionary. Source is actually modified.

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IDictionary<TKey, TValue> AddRange<TKey, TValue>(
    this IDictionary<TKey, TValue> src,
    IEnumerable<KeyValuePair<TKey, TValue>> range
)
public static IDictionary<TKey, TValue> AddRange<TKey, TValue>(
    this IDictionary<TKey, TValue> src,
    IEnumerable<KeyValuePair<TKey, TValue>> range
)
<ExtensionAttribute>
Public Shared Function AddRange(Of TKey, TValue) (
    src As IDictionary(Of TKey, TValue),
    range As IEnumerable(Of KeyValuePair(Of TKey, TValue))
) As IDictionary(Of TKey, TValue)
<ExtensionAttribute>
Public Shared Function AddRange(Of TKey, TValue) (
    src As IDictionary(Of TKey, TValue),
    range As IEnumerable(Of KeyValuePair(Of TKey, TValue))
) As IDictionary(Of TKey, TValue)
public:
[ExtensionAttribute]
generic<typename TKey, typename TValue>
static IDictionary<TKey, TValue>^ AddRange(
    IDictionary<TKey, TValue>^ src,
    IEnumerable<KeyValuePair<TKey, TValue>>^ range
)
public:
[ExtensionAttribute]
generic<typename TKey, typename TValue>
static IDictionary<TKey, TValue>^ AddRange(
    IDictionary<TKey, TValue>^ src,
    IEnumerable<KeyValuePair<TKey, TValue>>^ range
)
static member AddRange :
        src : IDictionary<'TKey, 'TValue> *
        range : IEnumerable<KeyValuePair<'TKey, 'TValue>> -> IDictionary<'TKey, 'TValue>
static member AddRange :
        src : IDictionary<'TKey, 'TValue> *
        range : IEnumerable<KeyValuePair<'TKey, 'TValue>> -> IDictionary<'TKey, 'TValue>

Parameters

src
Type: Online System.Collections.Generic IDictionary TKey, TValue
Source IDictionary (where to add range)
range
Type: Online System.Collections.Generic IEnumerable Online KeyValuePair TKey, TValue
Sequence that should be added to source IDictionary
Type Parameters
TKey
Type of key
TValue
Type of value

Return Value

Type: Online IDictionary TKey, TValue
Source with added elements from range (to have ability to chain operations)

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online IDictionary TKey, TValue . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
CollectionUtils Class
CollectionUtils Members
NFX Namespace


CollectionUtils.AppendToNew(T) Method

CollectionUtils AppendToNew T Method NFX Class Library

Returns a new array that contains source elements with additional elements appended at the end

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static T[] AppendToNew<T>(
    this T[] source,
    params T[] elements
)
public static T[] AppendToNew<T>(
    this T[] source,
    params T[] elements
)
<ExtensionAttribute>
Public Shared Function AppendToNew(Of T) (
    source As T(),
    ParamArray elements As T()
) As T()
<ExtensionAttribute>
Public Shared Function AppendToNew(Of T) (
    source As T(),
    ParamArray elements As T()
) As T()
public:
[ExtensionAttribute]
generic<typename T>
static array<T>^ AppendToNew(
    array<T>^ source,
    ... array<T>^ elements
)
public:
[ExtensionAttribute]
generic<typename T>
static array<T>^ AppendToNew(
    array<T>^ source,
    ... array<T>^ elements
)
static member AppendToNew :
        source : 'T[] *
        elements : 'T[] -> 'T[]
static member AppendToNew :
        source : 'T[] *
        elements : 'T[] -> 'T[]

Parameters

source
Type: T
elements
Type: T
Type Parameters
T

Return Value

Type: T

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
CollectionUtils Class
CollectionUtils Members
NFX Namespace


CollectionUtils.Distinct(TResult, TKey) Method

CollectionUtils Distinct TResult, TKey Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<TResult> Distinct<TResult, TKey>(
    this IEnumerable<TResult> source,
    Func<TResult, TKey> selector
)
public static IEnumerable<TResult> Distinct<TResult, TKey>(
    this IEnumerable<TResult> source,
    Func<TResult, TKey> selector
)
<ExtensionAttribute>
Public Shared Function Distinct(Of TResult, TKey) (
    source As IEnumerable(Of TResult),
    selector As Func(Of TResult, TKey)
) As IEnumerable(Of TResult)
<ExtensionAttribute>
Public Shared Function Distinct(Of TResult, TKey) (
    source As IEnumerable(Of TResult),
    selector As Func(Of TResult, TKey)
) As IEnumerable(Of TResult)
public:
[ExtensionAttribute]
generic<typename TResult, typename TKey>
static IEnumerable<TResult>^ Distinct(
    IEnumerable<TResult>^ source,
    Func<TResult, TKey>^ selector
)
public:
[ExtensionAttribute]
generic<typename TResult, typename TKey>
static IEnumerable<TResult>^ Distinct(
    IEnumerable<TResult>^ source,
    Func<TResult, TKey>^ selector
)
static member Distinct :
        source : IEnumerable<'TResult> *
        selector : Func<'TResult, 'TKey> -> IEnumerable<'TResult>
static member Distinct :
        source : IEnumerable<'TResult> *
        selector : Func<'TResult, 'TKey> -> IEnumerable<'TResult>

Parameters

source
Type: Online System.Collections.Generic IEnumerable TResult
selector
Type: Online System Func TResult, TKey
Type Parameters
TResult
TKey

Return Value

Type: Online IEnumerable TResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online IEnumerable TResult . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
CollectionUtils Class
CollectionUtils Members
NFX Namespace


CollectionUtils.FirstMax Method

CollectionUtils FirstMax Method NFX Class Library

Overload List
Name | Description
FirstMax TResult, TComparand (IEnumerable TResult , Func TResult, TComparand ) |
FirstMax TResult, TComparand (IEnumerable TResult , Func TResult, TComparand , TComparand ) |
Back to Top
See Also
CollectionUtils Class
CollectionUtils Members
NFX Namespace


CollectionUtils.FirstMax(TResult, TComparand) Method (IEnumerable(TResult), Func(TResult, TComparand))

CollectionUtils FirstMax TResult, TComparand Method (IEnumerable TResult , Func TResult, TComparand ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TResult FirstMax<TResult, TComparand>(
    this IEnumerable<TResult> source,
    Func<TResult, TComparand> selector
)
where TComparand : IComparable
public static TResult FirstMax<TResult, TComparand>(
    this IEnumerable<TResult> source,
    Func<TResult, TComparand> selector
)
where TComparand : IComparable
<ExtensionAttribute>
Public Shared Function FirstMax(Of TResult, TComparand As IComparable) (
    source As IEnumerable(Of TResult),
    selector As Func(Of TResult, TComparand)
) As TResult
<ExtensionAttribute>
Public Shared Function FirstMax(Of TResult, TComparand As IComparable) (
    source As IEnumerable(Of TResult),
    selector As Func(Of TResult, TComparand)
) As TResult
public:
[ExtensionAttribute]
generic<typename TResult, typename TComparand>
where TComparand : IComparable
static TResult FirstMax(
    IEnumerable<TResult>^ source,
    Func<TResult, TComparand>^ selector
)
public:
[ExtensionAttribute]
generic<typename TResult, typename TComparand>
where TComparand : IComparable
static TResult FirstMax(
    IEnumerable<TResult>^ source,
    Func<TResult, TComparand>^ selector
)
static member FirstMax :
        source : IEnumerable<'TResult> *
        selector : Func<'TResult, 'TComparand> -> 'TResult  when 'TComparand : IComparable
static member FirstMax :
        source : IEnumerable<'TResult> *
        selector : Func<'TResult, 'TComparand> -> 'TResult  when 'TComparand : IComparable

Parameters

source
Type: Online System.Collections.Generic IEnumerable TResult
selector
Type: Online System Func TResult, TComparand
Type Parameters
TResult
TComparand

Return Value

Type: TResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online IEnumerable TResult . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
CollectionUtils Class
CollectionUtils Members
FirstMax Overload
NFX Namespace


CollectionUtils.FirstMax(TResult, TComparand) Method (IEnumerable(TResult), Func(TResult, TComparand), TComparand)

CollectionUtils FirstMax TResult, TComparand Method (IEnumerable TResult , Func TResult, TComparand , TComparand ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TResult FirstMax<TResult, TComparand>(
    this IEnumerable<TResult> source,
    Func<TResult, TComparand> selector,
    out TComparand maxComparand
)
where TComparand : IComparable
public static TResult FirstMax<TResult, TComparand>(
    this IEnumerable<TResult> source,
    Func<TResult, TComparand> selector,
    out TComparand maxComparand
)
where TComparand : IComparable
<ExtensionAttribute>
Public Shared Function FirstMax(Of TResult, TComparand As IComparable) (
    source As IEnumerable(Of TResult),
    selector As Func(Of TResult, TComparand),
    <OutAttribute> ByRef maxComparand As TComparand
) As TResult
<ExtensionAttribute>
Public Shared Function FirstMax(Of TResult, TComparand As IComparable) (
    source As IEnumerable(Of TResult),
    selector As Func(Of TResult, TComparand),
    <OutAttribute> ByRef maxComparand As TComparand
) As TResult
public:
[ExtensionAttribute]
generic<typename TResult, typename TComparand>
where TComparand : IComparable
static TResult FirstMax(
    IEnumerable<TResult>^ source,
    Func<TResult, TComparand>^ selector,
    [OutAttribute] TComparand% maxComparand
)
public:
[ExtensionAttribute]
generic<typename TResult, typename TComparand>
where TComparand : IComparable
static TResult FirstMax(
    IEnumerable<TResult>^ source,
    Func<TResult, TComparand>^ selector,
    [OutAttribute] TComparand% maxComparand
)
static member FirstMax :
        source : IEnumerable<'TResult> *
        selector : Func<'TResult, 'TComparand> *
        maxComparand : 'TComparand byref -> 'TResult  when 'TComparand : IComparable
static member FirstMax :
        source : IEnumerable<'TResult> *
        selector : Func<'TResult, 'TComparand> *
        maxComparand : 'TComparand byref -> 'TResult  when 'TComparand : IComparable

Parameters

source
Type: Online System.Collections.Generic IEnumerable TResult
selector
Type: Online System Func TResult, TComparand
maxComparand
Type: TComparand
Type Parameters
TResult
TComparand

Return Value

Type: TResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online IEnumerable TResult . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
CollectionUtils Class
CollectionUtils Members
FirstMax Overload
NFX Namespace


CollectionUtils.FirstMin Method

CollectionUtils FirstMin Method NFX Class Library

Overload List
Name | Description
FirstMin TResult, TComparand (IEnumerable TResult , Func TResult, TComparand ) |
FirstMin TResult, TComparand (IEnumerable TResult , Func TResult, TComparand , TComparand ) |
Back to Top
See Also
CollectionUtils Class
CollectionUtils Members
NFX Namespace


CollectionUtils.FirstMin(TResult, TComparand) Method (IEnumerable(TResult), Func(TResult, TComparand))

CollectionUtils FirstMin TResult, TComparand Method (IEnumerable TResult , Func TResult, TComparand ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TResult FirstMin<TResult, TComparand>(
    this IEnumerable<TResult> source,
    Func<TResult, TComparand> selector
)
where TComparand : IComparable
public static TResult FirstMin<TResult, TComparand>(
    this IEnumerable<TResult> source,
    Func<TResult, TComparand> selector
)
where TComparand : IComparable
<ExtensionAttribute>
Public Shared Function FirstMin(Of TResult, TComparand As IComparable) (
    source As IEnumerable(Of TResult),
    selector As Func(Of TResult, TComparand)
) As TResult
<ExtensionAttribute>
Public Shared Function FirstMin(Of TResult, TComparand As IComparable) (
    source As IEnumerable(Of TResult),
    selector As Func(Of TResult, TComparand)
) As TResult
public:
[ExtensionAttribute]
generic<typename TResult, typename TComparand>
where TComparand : IComparable
static TResult FirstMin(
    IEnumerable<TResult>^ source,
    Func<TResult, TComparand>^ selector
)
public:
[ExtensionAttribute]
generic<typename TResult, typename TComparand>
where TComparand : IComparable
static TResult FirstMin(
    IEnumerable<TResult>^ source,
    Func<TResult, TComparand>^ selector
)
static member FirstMin :
        source : IEnumerable<'TResult> *
        selector : Func<'TResult, 'TComparand> -> 'TResult  when 'TComparand : IComparable
static member FirstMin :
        source : IEnumerable<'TResult> *
        selector : Func<'TResult, 'TComparand> -> 'TResult  when 'TComparand : IComparable

Parameters

source
Type: Online System.Collections.Generic IEnumerable TResult
selector
Type: Online System Func TResult, TComparand
Type Parameters
TResult
TComparand

Return Value

Type: TResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online IEnumerable TResult . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
CollectionUtils Class
CollectionUtils Members
FirstMin Overload
NFX Namespace


CollectionUtils.FirstMin(TResult, TComparand) Method (IEnumerable(TResult), Func(TResult, TComparand), TComparand)

CollectionUtils FirstMin TResult, TComparand Method (IEnumerable TResult , Func TResult, TComparand , TComparand ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TResult FirstMin<TResult, TComparand>(
    this IEnumerable<TResult> source,
    Func<TResult, TComparand> selector,
    out TComparand minComparand
)
where TComparand : IComparable
public static TResult FirstMin<TResult, TComparand>(
    this IEnumerable<TResult> source,
    Func<TResult, TComparand> selector,
    out TComparand minComparand
)
where TComparand : IComparable
<ExtensionAttribute>
Public Shared Function FirstMin(Of TResult, TComparand As IComparable) (
    source As IEnumerable(Of TResult),
    selector As Func(Of TResult, TComparand),
    <OutAttribute> ByRef minComparand As TComparand
) As TResult
<ExtensionAttribute>
Public Shared Function FirstMin(Of TResult, TComparand As IComparable) (
    source As IEnumerable(Of TResult),
    selector As Func(Of TResult, TComparand),
    <OutAttribute> ByRef minComparand As TComparand
) As TResult
public:
[ExtensionAttribute]
generic<typename TResult, typename TComparand>
where TComparand : IComparable
static TResult FirstMin(
    IEnumerable<TResult>^ source,
    Func<TResult, TComparand>^ selector,
    [OutAttribute] TComparand% minComparand
)
public:
[ExtensionAttribute]
generic<typename TResult, typename TComparand>
where TComparand : IComparable
static TResult FirstMin(
    IEnumerable<TResult>^ source,
    Func<TResult, TComparand>^ selector,
    [OutAttribute] TComparand% minComparand
)
static member FirstMin :
        source : IEnumerable<'TResult> *
        selector : Func<'TResult, 'TComparand> *
        minComparand : 'TComparand byref -> 'TResult  when 'TComparand : IComparable
static member FirstMin :
        source : IEnumerable<'TResult> *
        selector : Func<'TResult, 'TComparand> *
        minComparand : 'TComparand byref -> 'TResult  when 'TComparand : IComparable

Parameters

source
Type: Online System.Collections.Generic IEnumerable TResult
selector
Type: Online System Func TResult, TComparand
minComparand
Type: TComparand
Type Parameters
TResult
TComparand

Return Value

Type: TResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online IEnumerable TResult . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
CollectionUtils Class
CollectionUtils Members
FirstMin Overload
NFX Namespace


CollectionUtils.FirstOrAnyOrDefault(TResult) Method

CollectionUtils FirstOrAnyOrDefault TResult Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null)

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TResult FirstOrAnyOrDefault<TResult>(
    this IEnumerable<TResult> source,
    Func<TResult, bool> predicate
)
public static TResult FirstOrAnyOrDefault<TResult>(
    this IEnumerable<TResult> source,
    Func<TResult, bool> predicate
)
<ExtensionAttribute>
Public Shared Function FirstOrAnyOrDefault(Of TResult) (
    source As IEnumerable(Of TResult),
    predicate As Func(Of TResult, Boolean)
) As TResult
<ExtensionAttribute>
Public Shared Function FirstOrAnyOrDefault(Of TResult) (
    source As IEnumerable(Of TResult),
    predicate As Func(Of TResult, Boolean)
) As TResult
public:
[ExtensionAttribute]
generic<typename TResult>
static TResult FirstOrAnyOrDefault(
    IEnumerable<TResult>^ source,
    Func<TResult, bool>^ predicate
)
public:
[ExtensionAttribute]
generic<typename TResult>
static TResult FirstOrAnyOrDefault(
    IEnumerable<TResult>^ source,
    Func<TResult, bool>^ predicate
)
static member FirstOrAnyOrDefault :
        source : IEnumerable<'TResult> *
        predicate : Func<'TResult, bool> -> 'TResult
static member FirstOrAnyOrDefault :
        source : IEnumerable<'TResult> *
        predicate : Func<'TResult, bool> -> 'TResult

Parameters

source
Type: Online System.Collections.Generic IEnumerable TResult
predicate
Type: Online System Func TResult, Online Boolean
Type Parameters
TResult

Return Value

Type: TResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online IEnumerable TResult . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
CollectionUtils Class
CollectionUtils Members
NFX Namespace


CollectionUtils.ForEach Method

CollectionUtils ForEach Method NFX Class Library

Overload List
Name | Description
ForEach T (IEnumerable T , Action T ) | Runs some method over each element of src sequence
ForEach T (IEnumerable T , Action T, Int32 ) | Runs some method over each element of src sequence
Back to Top
See Also
CollectionUtils Class
CollectionUtils Members
NFX Namespace


CollectionUtils.ForEach(T) Method (IEnumerable(T), Action(T))

CollectionUtils ForEach T Method (IEnumerable T , Action T ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Runs some method over each element of src sequence

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<T> ForEach<T>(
    this IEnumerable<T> src,
    Action<T> action
)
public static IEnumerable<T> ForEach<T>(
    this IEnumerable<T> src,
    Action<T> action
)
<ExtensionAttribute>
Public Shared Function ForEach(Of T) (
    src As IEnumerable(Of T),
    action As Action(Of T)
) As IEnumerable(Of T)
<ExtensionAttribute>
Public Shared Function ForEach(Of T) (
    src As IEnumerable(Of T),
    action As Action(Of T)
) As IEnumerable(Of T)
public:
[ExtensionAttribute]
generic<typename T>
static IEnumerable<T>^ ForEach(
    IEnumerable<T>^ src,
    Action<T>^ action
)
public:
[ExtensionAttribute]
generic<typename T>
static IEnumerable<T>^ ForEach(
    IEnumerable<T>^ src,
    Action<T>^ action
)
static member ForEach :
        src : IEnumerable<'T> *
        action : Action<'T> -> IEnumerable<'T>
static member ForEach :
        src : IEnumerable<'T> *
        action : Action<'T> -> IEnumerable<'T>

Parameters

src
Type: Online System.Collections.Generic IEnumerable T
Source sequence
action
Type: Online System Action T
Method to run over each element
Type Parameters
T
Sequence item type

Return Value

Type: Online IEnumerable T
Source sequence (to have ability to chain similar calls)

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online IEnumerable T . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
CollectionUtils Class
CollectionUtils Members
ForEach Overload
NFX Namespace


CollectionUtils.ForEach(T) Method (IEnumerable(T), Action(T, Int32))

CollectionUtils ForEach T Method (IEnumerable T , Action T, Int32 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Runs some method over each element of src sequence

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<T> ForEach<T>(
    this IEnumerable<T> src,
    Action<T, int> action
)
public static IEnumerable<T> ForEach<T>(
    this IEnumerable<T> src,
    Action<T, int> action
)
<ExtensionAttribute>
Public Shared Function ForEach(Of T) (
    src As IEnumerable(Of T),
    action As Action(Of T, Integer)
) As IEnumerable(Of T)
<ExtensionAttribute>
Public Shared Function ForEach(Of T) (
    src As IEnumerable(Of T),
    action As Action(Of T, Integer)
) As IEnumerable(Of T)
public:
[ExtensionAttribute]
generic<typename T>
static IEnumerable<T>^ ForEach(
    IEnumerable<T>^ src,
    Action<T, int>^ action
)
public:
[ExtensionAttribute]
generic<typename T>
static IEnumerable<T>^ ForEach(
    IEnumerable<T>^ src,
    Action<T, int>^ action
)
static member ForEach :
        src : IEnumerable<'T> *
        action : Action<'T, int> -> IEnumerable<'T>
static member ForEach :
        src : IEnumerable<'T> *
        action : Action<'T, int> -> IEnumerable<'T>

Parameters

src
Type: Online System.Collections.Generic IEnumerable T
Source sequence
action
Type: Online System Action T, Online Int32
Method to call on each element and its sequence number
Type Parameters
T
Sequence item type

Return Value

Type: Online IEnumerable T
Source sequence (to have ability to chain similar calls)

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online IEnumerable T . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
CollectionUtils Class
CollectionUtils Members
ForEach Overload
NFX Namespace


CollectionUtils.SkipLast Method

CollectionUtils SkipLast Method NFX Class Library

Overload List
Name | Description
SkipLast T (IEnumerable T ) | Takes all elements except for last element from the given source
SkipLast T (IEnumerable T , Int32) | Takes all but last N elements from the source
Back to Top
See Also
CollectionUtils Class
CollectionUtils Members
NFX Namespace


CollectionUtils.SkipLast(T) Method (IEnumerable(T))

CollectionUtils SkipLast T Method (IEnumerable T ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Takes all elements except for last element from the given source

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<T> SkipLast<T>(
    this IEnumerable<T> source
)
public static IEnumerable<T> SkipLast<T>(
    this IEnumerable<T> source
)
<ExtensionAttribute>
Public Shared Function SkipLast(Of T) (
    source As IEnumerable(Of T)
) As IEnumerable(Of T)
<ExtensionAttribute>
Public Shared Function SkipLast(Of T) (
    source As IEnumerable(Of T)
) As IEnumerable(Of T)
public:
[ExtensionAttribute]
generic<typename T>
static IEnumerable<T>^ SkipLast(
    IEnumerable<T>^ source
)
public:
[ExtensionAttribute]
generic<typename T>
static IEnumerable<T>^ SkipLast(
    IEnumerable<T>^ source
)
static member SkipLast :
        source : IEnumerable<'T> -> IEnumerable<'T>
static member SkipLast :
        source : IEnumerable<'T> -> IEnumerable<'T>

Parameters

source
Type: Online System.Collections.Generic IEnumerable T
Type Parameters
T

Return Value

Type: Online IEnumerable T

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online IEnumerable T . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
CollectionUtils Class
CollectionUtils Members
SkipLast Overload
NFX Namespace


CollectionUtils.SkipLast(T) Method (IEnumerable(T), Int32)

CollectionUtils SkipLast T Method (IEnumerable T , Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Takes all but last N elements from the source

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<T> SkipLast<T>(
    this IEnumerable<T> source,
    int n
)
public static IEnumerable<T> SkipLast<T>(
    this IEnumerable<T> source,
    int n
)
<ExtensionAttribute>
Public Shared Function SkipLast(Of T) (
    source As IEnumerable(Of T),
    n As Integer
) As IEnumerable(Of T)
<ExtensionAttribute>
Public Shared Function SkipLast(Of T) (
    source As IEnumerable(Of T),
    n As Integer
) As IEnumerable(Of T)
public:
[ExtensionAttribute]
generic<typename T>
static IEnumerable<T>^ SkipLast(
    IEnumerable<T>^ source,
    int n
)
public:
[ExtensionAttribute]
generic<typename T>
static IEnumerable<T>^ SkipLast(
    IEnumerable<T>^ source,
    int n
)
static member SkipLast :
        source : IEnumerable<'T> *
        n : int -> IEnumerable<'T>
static member SkipLast :
        source : IEnumerable<'T> *
        n : int -> IEnumerable<'T>

Parameters

source
Type: Online System.Collections.Generic IEnumerable T
n
Type: Online System Int32
Type Parameters
T

Return Value

Type: Online IEnumerable T

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online IEnumerable T . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
CollectionUtils Class
CollectionUtils Members
SkipLast Overload
NFX Namespace


ConvertErrorHandling Enumeration

ConvertErrorHandling Enumeration NFX Class Library

Specifies how to handle errors during object value conversion

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum ConvertErrorHandling
public enum ConvertErrorHandling
Public Enumeration ConvertErrorHandling
Public Enumeration ConvertErrorHandling
public enum class ConvertErrorHandling
public enum class ConvertErrorHandling
type ConvertErrorHandling
type ConvertErrorHandling
Members
Member name | Value | Description
ReturnDefault | 0 |
Throw | 1 |
See Also
NFX Namespace


CoreConsts Class

CoreConsts Class NFX Class Library

Central non-lozalizable NFX system consts
Inheritance Hierarchy
Online System Object
NFX CoreConsts

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class CoreConsts
public static class CoreConsts
Public NotInheritable Class CoreConsts
Public NotInheritable Class CoreConsts
public ref class CoreConsts abstract sealed
public ref class CoreConsts abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CoreConsts =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CoreConsts =  class end
See Also
CoreConsts Members
NFX Namespace


CoreConsts Members

CoreConsts Members NFX Class Library

The CoreConsts type exposes the following members.
Fields
Name | Description
ABS_HASH_MASK |
APPLICATION_TOPIC |
ASSERT_TOPIC |
CACHE_TOPIC |
CHANGE_EVENTS_CATEGORY |
CS_EXTENSION |
CS_LANGUAGE |
CSRF_TOKEN_NAME |
DATA_CATEGORY |
DEBUG_TOPIC |
ERLANG_TOPIC |
EXT_PARAM_CONTENT_JSON |
EXT_PARAM_CONTENT_LACONIC |
EXT_PARAM_GROUP_CACHE |
EXT_PARAM_GROUP_DATA |
EXT_PARAM_GROUP_GLUE |
EXT_PARAM_GROUP_INSTRUMENTATION |
EXT_PARAM_GROUP_LOCKING |
EXT_PARAM_GROUP_LOG |
EXT_PARAM_GROUP_OBJSTORE |
EXT_PARAM_GROUP_PAY |
EXT_PARAM_GROUP_PILE |
EXT_PARAM_GROUP_SHIPPING |
EXT_PARAM_GROUP_SOCIAL |
EXT_PARAM_GROUP_TAX |
EXT_PARAM_GROUP_TIME |
EXT_PARAM_GROUP_WEB |
FORMULA_FIELD_NAME_PREFIX |
GLUE_TOPIC |
INSTRUMENTATION_TIMEFRAME_TOPIC |
INSTRUMENTATIONSVC_PROVIDER_TOPIC |
INSTRUMENTATIONSVC_TOPIC |
INTERACTIONS_CATEGORY |
ISO_COUNTRY_CANADA |
ISO_COUNTRY_FRANCE |
ISO_COUNTRY_GERMANY |
ISO_COUNTRY_MEXICO |
ISO_COUNTRY_RUSSIA |
ISO_COUNTRY_USA |
ISO_CURRENCY_EUR |
ISO_CURRENCY_MXN |
ISO_CURRENCY_RUB |
ISO_CURRENCY_USD |
ISO_LANG_ENGLISH |
ISO_LANG_FRENCH |
ISO_LANG_GERMAN |
ISO_LANG_RUSSIAN |
ISO_LANG_SPANISH |
LOCALIZATION_TOPIC |
LOG_NET_TOPIC |
LOG_TOPIC |
MAX_BYTE_BUFFER_SIZE |
OBJSTORESVC_PROVIDER_TOPIC |
OBJSTORESVC_TOPIC |
PRESENTATION_CATEGORY |
SCHEDULE_TOPIC |
SECURITY_CATEGORY |
THROTTLINGSVC_TOPIC |
TIME_TOPIC |
TRACE_TOPIC |
UNIT_NAME_BYTE |
UNIT_NAME_BYTES |
UNIT_NAME_CALL |
UNIT_NAME_CHANNEL |
UNIT_NAME_ERROR |
UNIT_NAME_EVENT |
UNIT_NAME_EXCEPTION |
UNIT_NAME_GEO_LOOKUP |
UNIT_NAME_GEO_LOOKUP_HIT |
UNIT_NAME_MB |
UNIT_NAME_MESSAGE |
UNIT_NAME_MONEY |
UNIT_NAME_MSEC |
UNIT_NAME_NAMESPACE |
UNIT_NAME_OBJECT |
UNIT_NAME_OCCURENCE |
UNIT_NAME_PAGE |
UNIT_NAME_PAGE_PER_BUCKET |
UNIT_NAME_PERCENT |
UNIT_NAME_RECORD |
UNIT_NAME_REQUEST |
UNIT_NAME_RESPONSE |
UNIT_NAME_SEC |
UNIT_NAME_SEGMENT |
UNIT_NAME_SESSION |
UNIT_NAME_SLOT |
UNIT_NAME_SWEEP |
UNIT_NAME_TABLE |
UNIT_NAME_TIME |
UNIT_NAME_TRANSACTION |
UNIT_NAME_TRANSPORT |
UNIT_NAME_UNSPECIFIED |
UNIT_NAME_WORK_CONTEXT |
UNKNOWN |
UNNAMED_MEMORY_BUFFER |
UNNAMED_PROJECT_ITEM |
VALIDATION_CATEGORY |
Back to Top
See Also
CoreConsts Class
NFX Namespace


CoreConsts Fields

CoreConsts Fields NFX Class Library

The CoreConsts type exposes the following members.
Fields
Name | Description
ABS_HASH_MASK |
APPLICATION_TOPIC |
ASSERT_TOPIC |
CACHE_TOPIC |
CHANGE_EVENTS_CATEGORY |
CS_EXTENSION |
CS_LANGUAGE |
CSRF_TOKEN_NAME |
DATA_CATEGORY |
DEBUG_TOPIC |
ERLANG_TOPIC |
EXT_PARAM_CONTENT_JSON |
EXT_PARAM_CONTENT_LACONIC |
EXT_PARAM_GROUP_CACHE |
EXT_PARAM_GROUP_DATA |
EXT_PARAM_GROUP_GLUE |
EXT_PARAM_GROUP_INSTRUMENTATION |
EXT_PARAM_GROUP_LOCKING |
EXT_PARAM_GROUP_LOG |
EXT_PARAM_GROUP_OBJSTORE |
EXT_PARAM_GROUP_PAY |
EXT_PARAM_GROUP_PILE |
EXT_PARAM_GROUP_SHIPPING |
EXT_PARAM_GROUP_SOCIAL |
EXT_PARAM_GROUP_TAX |
EXT_PARAM_GROUP_TIME |
EXT_PARAM_GROUP_WEB |
FORMULA_FIELD_NAME_PREFIX |
GLUE_TOPIC |
INSTRUMENTATION_TIMEFRAME_TOPIC |
INSTRUMENTATIONSVC_PROVIDER_TOPIC |
INSTRUMENTATIONSVC_TOPIC |
INTERACTIONS_CATEGORY |
ISO_COUNTRY_CANADA |
ISO_COUNTRY_FRANCE |
ISO_COUNTRY_GERMANY |
ISO_COUNTRY_MEXICO |
ISO_COUNTRY_RUSSIA |
ISO_COUNTRY_USA |
ISO_CURRENCY_EUR |
ISO_CURRENCY_MXN |
ISO_CURRENCY_RUB |
ISO_CURRENCY_USD |
ISO_LANG_ENGLISH |
ISO_LANG_FRENCH |
ISO_LANG_GERMAN |
ISO_LANG_RUSSIAN |
ISO_LANG_SPANISH |
LOCALIZATION_TOPIC |
LOG_NET_TOPIC |
LOG_TOPIC |
MAX_BYTE_BUFFER_SIZE |
OBJSTORESVC_PROVIDER_TOPIC |
OBJSTORESVC_TOPIC |
PRESENTATION_CATEGORY |
SCHEDULE_TOPIC |
SECURITY_CATEGORY |
THROTTLINGSVC_TOPIC |
TIME_TOPIC |
TRACE_TOPIC |
UNIT_NAME_BYTE |
UNIT_NAME_BYTES |
UNIT_NAME_CALL |
UNIT_NAME_CHANNEL |
UNIT_NAME_ERROR |
UNIT_NAME_EVENT |
UNIT_NAME_EXCEPTION |
UNIT_NAME_GEO_LOOKUP |
UNIT_NAME_GEO_LOOKUP_HIT |
UNIT_NAME_MB |
UNIT_NAME_MESSAGE |
UNIT_NAME_MONEY |
UNIT_NAME_MSEC |
UNIT_NAME_NAMESPACE |
UNIT_NAME_OBJECT |
UNIT_NAME_OCCURENCE |
UNIT_NAME_PAGE |
UNIT_NAME_PAGE_PER_BUCKET |
UNIT_NAME_PERCENT |
UNIT_NAME_RECORD |
UNIT_NAME_REQUEST |
UNIT_NAME_RESPONSE |
UNIT_NAME_SEC |
UNIT_NAME_SEGMENT |
UNIT_NAME_SESSION |
UNIT_NAME_SLOT |
UNIT_NAME_SWEEP |
UNIT_NAME_TABLE |
UNIT_NAME_TIME |
UNIT_NAME_TRANSACTION |
UNIT_NAME_TRANSPORT |
UNIT_NAME_UNSPECIFIED |
UNIT_NAME_WORK_CONTEXT |
UNKNOWN |
UNNAMED_MEMORY_BUFFER |
UNNAMED_PROJECT_ITEM |
VALIDATION_CATEGORY |
Back to Top
See Also
CoreConsts Class
NFX Namespace


CoreConsts.ABS_HASH_MASK Field

CoreConsts ABS_HASH_MASK Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int ABS_HASH_MASK
public const int ABS_HASH_MASK
Public Const ABS_HASH_MASK As Integer
Public Const ABS_HASH_MASK As Integer
public:
literal int ABS_HASH_MASK
public:
literal int ABS_HASH_MASK
static val mutable ABS_HASH_MASK: int
static val mutable ABS_HASH_MASK: int

Field Value

Type: Online Int32
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.APPLICATION_TOPIC Field

CoreConsts APPLICATION_TOPIC Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APPLICATION_TOPIC
public const string APPLICATION_TOPIC
Public Const APPLICATION_TOPIC As String
Public Const APPLICATION_TOPIC As String
public:
literal String^ APPLICATION_TOPIC
public:
literal String^ APPLICATION_TOPIC
static val mutable APPLICATION_TOPIC: string
static val mutable APPLICATION_TOPIC: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.ASSERT_TOPIC Field

CoreConsts ASSERT_TOPIC Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ASSERT_TOPIC
public const string ASSERT_TOPIC
Public Const ASSERT_TOPIC As String
Public Const ASSERT_TOPIC As String
public:
literal String^ ASSERT_TOPIC
public:
literal String^ ASSERT_TOPIC
static val mutable ASSERT_TOPIC: string
static val mutable ASSERT_TOPIC: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.CACHE_TOPIC Field

CoreConsts CACHE_TOPIC Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CACHE_TOPIC
public const string CACHE_TOPIC
Public Const CACHE_TOPIC As String
Public Const CACHE_TOPIC As String
public:
literal String^ CACHE_TOPIC
public:
literal String^ CACHE_TOPIC
static val mutable CACHE_TOPIC: string
static val mutable CACHE_TOPIC: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.CHANGE_EVENTS_CATEGORY Field

CoreConsts CHANGE_EVENTS_CATEGORY Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CHANGE_EVENTS_CATEGORY
public const string CHANGE_EVENTS_CATEGORY
Public Const CHANGE_EVENTS_CATEGORY As String
Public Const CHANGE_EVENTS_CATEGORY As String
public:
literal String^ CHANGE_EVENTS_CATEGORY
public:
literal String^ CHANGE_EVENTS_CATEGORY
static val mutable CHANGE_EVENTS_CATEGORY: string
static val mutable CHANGE_EVENTS_CATEGORY: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.CS_EXTENSION Field

CoreConsts CS_EXTENSION Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CS_EXTENSION
public const string CS_EXTENSION
Public Const CS_EXTENSION As String
Public Const CS_EXTENSION As String
public:
literal String^ CS_EXTENSION
public:
literal String^ CS_EXTENSION
static val mutable CS_EXTENSION: string
static val mutable CS_EXTENSION: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.CS_LANGUAGE Field

CoreConsts CS_LANGUAGE Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CS_LANGUAGE
public const string CS_LANGUAGE
Public Const CS_LANGUAGE As String
Public Const CS_LANGUAGE As String
public:
literal String^ CS_LANGUAGE
public:
literal String^ CS_LANGUAGE
static val mutable CS_LANGUAGE: string
static val mutable CS_LANGUAGE: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.CSRF_TOKEN_NAME Field

CoreConsts CSRF_TOKEN_NAME Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CSRF_TOKEN_NAME
public const string CSRF_TOKEN_NAME
Public Const CSRF_TOKEN_NAME As String
Public Const CSRF_TOKEN_NAME As String
public:
literal String^ CSRF_TOKEN_NAME
public:
literal String^ CSRF_TOKEN_NAME
static val mutable CSRF_TOKEN_NAME: string
static val mutable CSRF_TOKEN_NAME: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.DATA_CATEGORY Field

CoreConsts DATA_CATEGORY Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DATA_CATEGORY
public const string DATA_CATEGORY
Public Const DATA_CATEGORY As String
Public Const DATA_CATEGORY As String
public:
literal String^ DATA_CATEGORY
public:
literal String^ DATA_CATEGORY
static val mutable DATA_CATEGORY: string
static val mutable DATA_CATEGORY: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.DEBUG_TOPIC Field

CoreConsts DEBUG_TOPIC Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEBUG_TOPIC
public const string DEBUG_TOPIC
Public Const DEBUG_TOPIC As String
Public Const DEBUG_TOPIC As String
public:
literal String^ DEBUG_TOPIC
public:
literal String^ DEBUG_TOPIC
static val mutable DEBUG_TOPIC: string
static val mutable DEBUG_TOPIC: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.ERLANG_TOPIC Field

CoreConsts ERLANG_TOPIC Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERLANG_TOPIC
public const string ERLANG_TOPIC
Public Const ERLANG_TOPIC As String
Public Const ERLANG_TOPIC As String
public:
literal String^ ERLANG_TOPIC
public:
literal String^ ERLANG_TOPIC
static val mutable ERLANG_TOPIC: string
static val mutable ERLANG_TOPIC: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.EXT_PARAM_CONTENT_JSON Field

CoreConsts EXT_PARAM_CONTENT_JSON Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string EXT_PARAM_CONTENT_JSON
public const string EXT_PARAM_CONTENT_JSON
Public Const EXT_PARAM_CONTENT_JSON As String
Public Const EXT_PARAM_CONTENT_JSON As String
public:
literal String^ EXT_PARAM_CONTENT_JSON
public:
literal String^ EXT_PARAM_CONTENT_JSON
static val mutable EXT_PARAM_CONTENT_JSON: string
static val mutable EXT_PARAM_CONTENT_JSON: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.EXT_PARAM_CONTENT_LACONIC Field

CoreConsts EXT_PARAM_CONTENT_LACONIC Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string EXT_PARAM_CONTENT_LACONIC
public const string EXT_PARAM_CONTENT_LACONIC
Public Const EXT_PARAM_CONTENT_LACONIC As String
Public Const EXT_PARAM_CONTENT_LACONIC As String
public:
literal String^ EXT_PARAM_CONTENT_LACONIC
public:
literal String^ EXT_PARAM_CONTENT_LACONIC
static val mutable EXT_PARAM_CONTENT_LACONIC: string
static val mutable EXT_PARAM_CONTENT_LACONIC: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.EXT_PARAM_GROUP_CACHE Field

CoreConsts EXT_PARAM_GROUP_CACHE Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string EXT_PARAM_GROUP_CACHE
public const string EXT_PARAM_GROUP_CACHE
Public Const EXT_PARAM_GROUP_CACHE As String
Public Const EXT_PARAM_GROUP_CACHE As String
public:
literal String^ EXT_PARAM_GROUP_CACHE
public:
literal String^ EXT_PARAM_GROUP_CACHE
static val mutable EXT_PARAM_GROUP_CACHE: string
static val mutable EXT_PARAM_GROUP_CACHE: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.EXT_PARAM_GROUP_DATA Field

CoreConsts EXT_PARAM_GROUP_DATA Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string EXT_PARAM_GROUP_DATA
public const string EXT_PARAM_GROUP_DATA
Public Const EXT_PARAM_GROUP_DATA As String
Public Const EXT_PARAM_GROUP_DATA As String
public:
literal String^ EXT_PARAM_GROUP_DATA
public:
literal String^ EXT_PARAM_GROUP_DATA
static val mutable EXT_PARAM_GROUP_DATA: string
static val mutable EXT_PARAM_GROUP_DATA: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.EXT_PARAM_GROUP_GLUE Field

CoreConsts EXT_PARAM_GROUP_GLUE Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string EXT_PARAM_GROUP_GLUE
public const string EXT_PARAM_GROUP_GLUE
Public Const EXT_PARAM_GROUP_GLUE As String
Public Const EXT_PARAM_GROUP_GLUE As String
public:
literal String^ EXT_PARAM_GROUP_GLUE
public:
literal String^ EXT_PARAM_GROUP_GLUE
static val mutable EXT_PARAM_GROUP_GLUE: string
static val mutable EXT_PARAM_GROUP_GLUE: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.EXT_PARAM_GROUP_INSTRUMENTATION Field

CoreConsts EXT_PARAM_GROUP_INSTRUMENTATION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string EXT_PARAM_GROUP_INSTRUMENTATION
public const string EXT_PARAM_GROUP_INSTRUMENTATION
Public Const EXT_PARAM_GROUP_INSTRUMENTATION As String
Public Const EXT_PARAM_GROUP_INSTRUMENTATION As String
public:
literal String^ EXT_PARAM_GROUP_INSTRUMENTATION
public:
literal String^ EXT_PARAM_GROUP_INSTRUMENTATION
static val mutable EXT_PARAM_GROUP_INSTRUMENTATION: string
static val mutable EXT_PARAM_GROUP_INSTRUMENTATION: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.EXT_PARAM_GROUP_LOCKING Field

CoreConsts EXT_PARAM_GROUP_LOCKING Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string EXT_PARAM_GROUP_LOCKING
public const string EXT_PARAM_GROUP_LOCKING
Public Const EXT_PARAM_GROUP_LOCKING As String
Public Const EXT_PARAM_GROUP_LOCKING As String
public:
literal String^ EXT_PARAM_GROUP_LOCKING
public:
literal String^ EXT_PARAM_GROUP_LOCKING
static val mutable EXT_PARAM_GROUP_LOCKING: string
static val mutable EXT_PARAM_GROUP_LOCKING: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.EXT_PARAM_GROUP_LOG Field

CoreConsts EXT_PARAM_GROUP_LOG Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string EXT_PARAM_GROUP_LOG
public const string EXT_PARAM_GROUP_LOG
Public Const EXT_PARAM_GROUP_LOG As String
Public Const EXT_PARAM_GROUP_LOG As String
public:
literal String^ EXT_PARAM_GROUP_LOG
public:
literal String^ EXT_PARAM_GROUP_LOG
static val mutable EXT_PARAM_GROUP_LOG: string
static val mutable EXT_PARAM_GROUP_LOG: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.EXT_PARAM_GROUP_OBJSTORE Field

CoreConsts EXT_PARAM_GROUP_OBJSTORE Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string EXT_PARAM_GROUP_OBJSTORE
public const string EXT_PARAM_GROUP_OBJSTORE
Public Const EXT_PARAM_GROUP_OBJSTORE As String
Public Const EXT_PARAM_GROUP_OBJSTORE As String
public:
literal String^ EXT_PARAM_GROUP_OBJSTORE
public:
literal String^ EXT_PARAM_GROUP_OBJSTORE
static val mutable EXT_PARAM_GROUP_OBJSTORE: string
static val mutable EXT_PARAM_GROUP_OBJSTORE: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.EXT_PARAM_GROUP_PAY Field

CoreConsts EXT_PARAM_GROUP_PAY Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string EXT_PARAM_GROUP_PAY
public const string EXT_PARAM_GROUP_PAY
Public Const EXT_PARAM_GROUP_PAY As String
Public Const EXT_PARAM_GROUP_PAY As String
public:
literal String^ EXT_PARAM_GROUP_PAY
public:
literal String^ EXT_PARAM_GROUP_PAY
static val mutable EXT_PARAM_GROUP_PAY: string
static val mutable EXT_PARAM_GROUP_PAY: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.EXT_PARAM_GROUP_PILE Field

CoreConsts EXT_PARAM_GROUP_PILE Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string EXT_PARAM_GROUP_PILE
public const string EXT_PARAM_GROUP_PILE
Public Const EXT_PARAM_GROUP_PILE As String
Public Const EXT_PARAM_GROUP_PILE As String
public:
literal String^ EXT_PARAM_GROUP_PILE
public:
literal String^ EXT_PARAM_GROUP_PILE
static val mutable EXT_PARAM_GROUP_PILE: string
static val mutable EXT_PARAM_GROUP_PILE: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.EXT_PARAM_GROUP_SHIPPING Field

CoreConsts EXT_PARAM_GROUP_SHIPPING Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string EXT_PARAM_GROUP_SHIPPING
public const string EXT_PARAM_GROUP_SHIPPING
Public Const EXT_PARAM_GROUP_SHIPPING As String
Public Const EXT_PARAM_GROUP_SHIPPING As String
public:
literal String^ EXT_PARAM_GROUP_SHIPPING
public:
literal String^ EXT_PARAM_GROUP_SHIPPING
static val mutable EXT_PARAM_GROUP_SHIPPING: string
static val mutable EXT_PARAM_GROUP_SHIPPING: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.EXT_PARAM_GROUP_SOCIAL Field

CoreConsts EXT_PARAM_GROUP_SOCIAL Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string EXT_PARAM_GROUP_SOCIAL
public const string EXT_PARAM_GROUP_SOCIAL
Public Const EXT_PARAM_GROUP_SOCIAL As String
Public Const EXT_PARAM_GROUP_SOCIAL As String
public:
literal String^ EXT_PARAM_GROUP_SOCIAL
public:
literal String^ EXT_PARAM_GROUP_SOCIAL
static val mutable EXT_PARAM_GROUP_SOCIAL: string
static val mutable EXT_PARAM_GROUP_SOCIAL: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.EXT_PARAM_GROUP_TAX Field

CoreConsts EXT_PARAM_GROUP_TAX Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string EXT_PARAM_GROUP_TAX
public const string EXT_PARAM_GROUP_TAX
Public Const EXT_PARAM_GROUP_TAX As String
Public Const EXT_PARAM_GROUP_TAX As String
public:
literal String^ EXT_PARAM_GROUP_TAX
public:
literal String^ EXT_PARAM_GROUP_TAX
static val mutable EXT_PARAM_GROUP_TAX: string
static val mutable EXT_PARAM_GROUP_TAX: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.EXT_PARAM_GROUP_TIME Field

CoreConsts EXT_PARAM_GROUP_TIME Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string EXT_PARAM_GROUP_TIME
public const string EXT_PARAM_GROUP_TIME
Public Const EXT_PARAM_GROUP_TIME As String
Public Const EXT_PARAM_GROUP_TIME As String
public:
literal String^ EXT_PARAM_GROUP_TIME
public:
literal String^ EXT_PARAM_GROUP_TIME
static val mutable EXT_PARAM_GROUP_TIME: string
static val mutable EXT_PARAM_GROUP_TIME: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.EXT_PARAM_GROUP_WEB Field

CoreConsts EXT_PARAM_GROUP_WEB Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string EXT_PARAM_GROUP_WEB
public const string EXT_PARAM_GROUP_WEB
Public Const EXT_PARAM_GROUP_WEB As String
Public Const EXT_PARAM_GROUP_WEB As String
public:
literal String^ EXT_PARAM_GROUP_WEB
public:
literal String^ EXT_PARAM_GROUP_WEB
static val mutable EXT_PARAM_GROUP_WEB: string
static val mutable EXT_PARAM_GROUP_WEB: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.FORMULA_FIELD_NAME_PREFIX Field

CoreConsts FORMULA_FIELD_NAME_PREFIX Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FORMULA_FIELD_NAME_PREFIX
public const string FORMULA_FIELD_NAME_PREFIX
Public Const FORMULA_FIELD_NAME_PREFIX As String
Public Const FORMULA_FIELD_NAME_PREFIX As String
public:
literal String^ FORMULA_FIELD_NAME_PREFIX
public:
literal String^ FORMULA_FIELD_NAME_PREFIX
static val mutable FORMULA_FIELD_NAME_PREFIX: string
static val mutable FORMULA_FIELD_NAME_PREFIX: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.GLUE_TOPIC Field

CoreConsts GLUE_TOPIC Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_TOPIC
public const string GLUE_TOPIC
Public Const GLUE_TOPIC As String
Public Const GLUE_TOPIC As String
public:
literal String^ GLUE_TOPIC
public:
literal String^ GLUE_TOPIC
static val mutable GLUE_TOPIC: string
static val mutable GLUE_TOPIC: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.INSTRUMENTATION_TIMEFRAME_TOPIC Field

CoreConsts INSTRUMENTATION_TIMEFRAME_TOPIC Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string INSTRUMENTATION_TIMEFRAME_TOPIC
public const string INSTRUMENTATION_TIMEFRAME_TOPIC
Public Const INSTRUMENTATION_TIMEFRAME_TOPIC As String
Public Const INSTRUMENTATION_TIMEFRAME_TOPIC As String
public:
literal String^ INSTRUMENTATION_TIMEFRAME_TOPIC
public:
literal String^ INSTRUMENTATION_TIMEFRAME_TOPIC
static val mutable INSTRUMENTATION_TIMEFRAME_TOPIC: string
static val mutable INSTRUMENTATION_TIMEFRAME_TOPIC: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.INSTRUMENTATIONSVC_PROVIDER_TOPIC Field

CoreConsts INSTRUMENTATIONSVC_PROVIDER_TOPIC Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string INSTRUMENTATIONSVC_PROVIDER_TOPIC
public const string INSTRUMENTATIONSVC_PROVIDER_TOPIC
Public Const INSTRUMENTATIONSVC_PROVIDER_TOPIC As String
Public Const INSTRUMENTATIONSVC_PROVIDER_TOPIC As String
public:
literal String^ INSTRUMENTATIONSVC_PROVIDER_TOPIC
public:
literal String^ INSTRUMENTATIONSVC_PROVIDER_TOPIC
static val mutable INSTRUMENTATIONSVC_PROVIDER_TOPIC: string
static val mutable INSTRUMENTATIONSVC_PROVIDER_TOPIC: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.INSTRUMENTATIONSVC_TOPIC Field

CoreConsts INSTRUMENTATIONSVC_TOPIC Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string INSTRUMENTATIONSVC_TOPIC
public const string INSTRUMENTATIONSVC_TOPIC
Public Const INSTRUMENTATIONSVC_TOPIC As String
Public Const INSTRUMENTATIONSVC_TOPIC As String
public:
literal String^ INSTRUMENTATIONSVC_TOPIC
public:
literal String^ INSTRUMENTATIONSVC_TOPIC
static val mutable INSTRUMENTATIONSVC_TOPIC: string
static val mutable INSTRUMENTATIONSVC_TOPIC: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.INTERACTIONS_CATEGORY Field

CoreConsts INTERACTIONS_CATEGORY Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string INTERACTIONS_CATEGORY
public const string INTERACTIONS_CATEGORY
Public Const INTERACTIONS_CATEGORY As String
Public Const INTERACTIONS_CATEGORY As String
public:
literal String^ INTERACTIONS_CATEGORY
public:
literal String^ INTERACTIONS_CATEGORY
static val mutable INTERACTIONS_CATEGORY: string
static val mutable INTERACTIONS_CATEGORY: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.ISO_COUNTRY_CANADA Field

CoreConsts ISO_COUNTRY_CANADA Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ISO_COUNTRY_CANADA
public const string ISO_COUNTRY_CANADA
Public Const ISO_COUNTRY_CANADA As String
Public Const ISO_COUNTRY_CANADA As String
public:
literal String^ ISO_COUNTRY_CANADA
public:
literal String^ ISO_COUNTRY_CANADA
static val mutable ISO_COUNTRY_CANADA: string
static val mutable ISO_COUNTRY_CANADA: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.ISO_COUNTRY_FRANCE Field

CoreConsts ISO_COUNTRY_FRANCE Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ISO_COUNTRY_FRANCE
public const string ISO_COUNTRY_FRANCE
Public Const ISO_COUNTRY_FRANCE As String
Public Const ISO_COUNTRY_FRANCE As String
public:
literal String^ ISO_COUNTRY_FRANCE
public:
literal String^ ISO_COUNTRY_FRANCE
static val mutable ISO_COUNTRY_FRANCE: string
static val mutable ISO_COUNTRY_FRANCE: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.ISO_COUNTRY_GERMANY Field

CoreConsts ISO_COUNTRY_GERMANY Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ISO_COUNTRY_GERMANY
public const string ISO_COUNTRY_GERMANY
Public Const ISO_COUNTRY_GERMANY As String
Public Const ISO_COUNTRY_GERMANY As String
public:
literal String^ ISO_COUNTRY_GERMANY
public:
literal String^ ISO_COUNTRY_GERMANY
static val mutable ISO_COUNTRY_GERMANY: string
static val mutable ISO_COUNTRY_GERMANY: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.ISO_COUNTRY_MEXICO Field

CoreConsts ISO_COUNTRY_MEXICO Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ISO_COUNTRY_MEXICO
public const string ISO_COUNTRY_MEXICO
Public Const ISO_COUNTRY_MEXICO As String
Public Const ISO_COUNTRY_MEXICO As String
public:
literal String^ ISO_COUNTRY_MEXICO
public:
literal String^ ISO_COUNTRY_MEXICO
static val mutable ISO_COUNTRY_MEXICO: string
static val mutable ISO_COUNTRY_MEXICO: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.ISO_COUNTRY_RUSSIA Field

CoreConsts ISO_COUNTRY_RUSSIA Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ISO_COUNTRY_RUSSIA
public const string ISO_COUNTRY_RUSSIA
Public Const ISO_COUNTRY_RUSSIA As String
Public Const ISO_COUNTRY_RUSSIA As String
public:
literal String^ ISO_COUNTRY_RUSSIA
public:
literal String^ ISO_COUNTRY_RUSSIA
static val mutable ISO_COUNTRY_RUSSIA: string
static val mutable ISO_COUNTRY_RUSSIA: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.ISO_COUNTRY_USA Field

CoreConsts ISO_COUNTRY_USA Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ISO_COUNTRY_USA
public const string ISO_COUNTRY_USA
Public Const ISO_COUNTRY_USA As String
Public Const ISO_COUNTRY_USA As String
public:
literal String^ ISO_COUNTRY_USA
public:
literal String^ ISO_COUNTRY_USA
static val mutable ISO_COUNTRY_USA: string
static val mutable ISO_COUNTRY_USA: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.ISO_CURRENCY_EUR Field

CoreConsts ISO_CURRENCY_EUR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ISO_CURRENCY_EUR
public const string ISO_CURRENCY_EUR
Public Const ISO_CURRENCY_EUR As String
Public Const ISO_CURRENCY_EUR As String
public:
literal String^ ISO_CURRENCY_EUR
public:
literal String^ ISO_CURRENCY_EUR
static val mutable ISO_CURRENCY_EUR: string
static val mutable ISO_CURRENCY_EUR: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.ISO_CURRENCY_MXN Field

CoreConsts ISO_CURRENCY_MXN Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ISO_CURRENCY_MXN
public const string ISO_CURRENCY_MXN
Public Const ISO_CURRENCY_MXN As String
Public Const ISO_CURRENCY_MXN As String
public:
literal String^ ISO_CURRENCY_MXN
public:
literal String^ ISO_CURRENCY_MXN
static val mutable ISO_CURRENCY_MXN: string
static val mutable ISO_CURRENCY_MXN: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.ISO_CURRENCY_RUB Field

CoreConsts ISO_CURRENCY_RUB Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ISO_CURRENCY_RUB
public const string ISO_CURRENCY_RUB
Public Const ISO_CURRENCY_RUB As String
Public Const ISO_CURRENCY_RUB As String
public:
literal String^ ISO_CURRENCY_RUB
public:
literal String^ ISO_CURRENCY_RUB
static val mutable ISO_CURRENCY_RUB: string
static val mutable ISO_CURRENCY_RUB: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.ISO_CURRENCY_USD Field

CoreConsts ISO_CURRENCY_USD Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ISO_CURRENCY_USD
public const string ISO_CURRENCY_USD
Public Const ISO_CURRENCY_USD As String
Public Const ISO_CURRENCY_USD As String
public:
literal String^ ISO_CURRENCY_USD
public:
literal String^ ISO_CURRENCY_USD
static val mutable ISO_CURRENCY_USD: string
static val mutable ISO_CURRENCY_USD: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.ISO_LANG_ENGLISH Field

CoreConsts ISO_LANG_ENGLISH Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ISO_LANG_ENGLISH
public const string ISO_LANG_ENGLISH
Public Const ISO_LANG_ENGLISH As String
Public Const ISO_LANG_ENGLISH As String
public:
literal String^ ISO_LANG_ENGLISH
public:
literal String^ ISO_LANG_ENGLISH
static val mutable ISO_LANG_ENGLISH: string
static val mutable ISO_LANG_ENGLISH: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.ISO_LANG_FRENCH Field

CoreConsts ISO_LANG_FRENCH Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ISO_LANG_FRENCH
public const string ISO_LANG_FRENCH
Public Const ISO_LANG_FRENCH As String
Public Const ISO_LANG_FRENCH As String
public:
literal String^ ISO_LANG_FRENCH
public:
literal String^ ISO_LANG_FRENCH
static val mutable ISO_LANG_FRENCH: string
static val mutable ISO_LANG_FRENCH: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.ISO_LANG_GERMAN Field

CoreConsts ISO_LANG_GERMAN Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ISO_LANG_GERMAN
public const string ISO_LANG_GERMAN
Public Const ISO_LANG_GERMAN As String
Public Const ISO_LANG_GERMAN As String
public:
literal String^ ISO_LANG_GERMAN
public:
literal String^ ISO_LANG_GERMAN
static val mutable ISO_LANG_GERMAN: string
static val mutable ISO_LANG_GERMAN: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.ISO_LANG_RUSSIAN Field

CoreConsts ISO_LANG_RUSSIAN Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ISO_LANG_RUSSIAN
public const string ISO_LANG_RUSSIAN
Public Const ISO_LANG_RUSSIAN As String
Public Const ISO_LANG_RUSSIAN As String
public:
literal String^ ISO_LANG_RUSSIAN
public:
literal String^ ISO_LANG_RUSSIAN
static val mutable ISO_LANG_RUSSIAN: string
static val mutable ISO_LANG_RUSSIAN: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.ISO_LANG_SPANISH Field

CoreConsts ISO_LANG_SPANISH Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ISO_LANG_SPANISH
public const string ISO_LANG_SPANISH
Public Const ISO_LANG_SPANISH As String
Public Const ISO_LANG_SPANISH As String
public:
literal String^ ISO_LANG_SPANISH
public:
literal String^ ISO_LANG_SPANISH
static val mutable ISO_LANG_SPANISH: string
static val mutable ISO_LANG_SPANISH: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.LOCALIZATION_TOPIC Field

CoreConsts LOCALIZATION_TOPIC Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string LOCALIZATION_TOPIC
public const string LOCALIZATION_TOPIC
Public Const LOCALIZATION_TOPIC As String
Public Const LOCALIZATION_TOPIC As String
public:
literal String^ LOCALIZATION_TOPIC
public:
literal String^ LOCALIZATION_TOPIC
static val mutable LOCALIZATION_TOPIC: string
static val mutable LOCALIZATION_TOPIC: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.LOG_NET_TOPIC Field

CoreConsts LOG_NET_TOPIC Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string LOG_NET_TOPIC
public const string LOG_NET_TOPIC
Public Const LOG_NET_TOPIC As String
Public Const LOG_NET_TOPIC As String
public:
literal String^ LOG_NET_TOPIC
public:
literal String^ LOG_NET_TOPIC
static val mutable LOG_NET_TOPIC: string
static val mutable LOG_NET_TOPIC: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.LOG_TOPIC Field

CoreConsts LOG_TOPIC Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string LOG_TOPIC
public const string LOG_TOPIC
Public Const LOG_TOPIC As String
Public Const LOG_TOPIC As String
public:
literal String^ LOG_TOPIC
public:
literal String^ LOG_TOPIC
static val mutable LOG_TOPIC: string
static val mutable LOG_TOPIC: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.MAX_BYTE_BUFFER_SIZE Field

CoreConsts MAX_BYTE_BUFFER_SIZE Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_BYTE_BUFFER_SIZE
public const int MAX_BYTE_BUFFER_SIZE
Public Const MAX_BYTE_BUFFER_SIZE As Integer
Public Const MAX_BYTE_BUFFER_SIZE As Integer
public:
literal int MAX_BYTE_BUFFER_SIZE
public:
literal int MAX_BYTE_BUFFER_SIZE
static val mutable MAX_BYTE_BUFFER_SIZE: int
static val mutable MAX_BYTE_BUFFER_SIZE: int

Field Value

Type: Online Int32
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.OBJSTORESVC_PROVIDER_TOPIC Field

CoreConsts OBJSTORESVC_PROVIDER_TOPIC Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string OBJSTORESVC_PROVIDER_TOPIC
public const string OBJSTORESVC_PROVIDER_TOPIC
Public Const OBJSTORESVC_PROVIDER_TOPIC As String
Public Const OBJSTORESVC_PROVIDER_TOPIC As String
public:
literal String^ OBJSTORESVC_PROVIDER_TOPIC
public:
literal String^ OBJSTORESVC_PROVIDER_TOPIC
static val mutable OBJSTORESVC_PROVIDER_TOPIC: string
static val mutable OBJSTORESVC_PROVIDER_TOPIC: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.OBJSTORESVC_TOPIC Field

CoreConsts OBJSTORESVC_TOPIC Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string OBJSTORESVC_TOPIC
public const string OBJSTORESVC_TOPIC
Public Const OBJSTORESVC_TOPIC As String
Public Const OBJSTORESVC_TOPIC As String
public:
literal String^ OBJSTORESVC_TOPIC
public:
literal String^ OBJSTORESVC_TOPIC
static val mutable OBJSTORESVC_TOPIC: string
static val mutable OBJSTORESVC_TOPIC: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.PRESENTATION_CATEGORY Field

CoreConsts PRESENTATION_CATEGORY Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PRESENTATION_CATEGORY
public const string PRESENTATION_CATEGORY
Public Const PRESENTATION_CATEGORY As String
Public Const PRESENTATION_CATEGORY As String
public:
literal String^ PRESENTATION_CATEGORY
public:
literal String^ PRESENTATION_CATEGORY
static val mutable PRESENTATION_CATEGORY: string
static val mutable PRESENTATION_CATEGORY: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.SCHEDULE_TOPIC Field

CoreConsts SCHEDULE_TOPIC Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SCHEDULE_TOPIC
public const string SCHEDULE_TOPIC
Public Const SCHEDULE_TOPIC As String
Public Const SCHEDULE_TOPIC As String
public:
literal String^ SCHEDULE_TOPIC
public:
literal String^ SCHEDULE_TOPIC
static val mutable SCHEDULE_TOPIC: string
static val mutable SCHEDULE_TOPIC: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.SECURITY_CATEGORY Field

CoreConsts SECURITY_CATEGORY Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SECURITY_CATEGORY
public const string SECURITY_CATEGORY
Public Const SECURITY_CATEGORY As String
Public Const SECURITY_CATEGORY As String
public:
literal String^ SECURITY_CATEGORY
public:
literal String^ SECURITY_CATEGORY
static val mutable SECURITY_CATEGORY: string
static val mutable SECURITY_CATEGORY: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.THROTTLINGSVC_TOPIC Field

CoreConsts THROTTLINGSVC_TOPIC Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string THROTTLINGSVC_TOPIC
public const string THROTTLINGSVC_TOPIC
Public Const THROTTLINGSVC_TOPIC As String
Public Const THROTTLINGSVC_TOPIC As String
public:
literal String^ THROTTLINGSVC_TOPIC
public:
literal String^ THROTTLINGSVC_TOPIC
static val mutable THROTTLINGSVC_TOPIC: string
static val mutable THROTTLINGSVC_TOPIC: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.TIME_TOPIC Field

CoreConsts TIME_TOPIC Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string TIME_TOPIC
public const string TIME_TOPIC
Public Const TIME_TOPIC As String
Public Const TIME_TOPIC As String
public:
literal String^ TIME_TOPIC
public:
literal String^ TIME_TOPIC
static val mutable TIME_TOPIC: string
static val mutable TIME_TOPIC: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.TRACE_TOPIC Field

CoreConsts TRACE_TOPIC Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string TRACE_TOPIC
public const string TRACE_TOPIC
Public Const TRACE_TOPIC As String
Public Const TRACE_TOPIC As String
public:
literal String^ TRACE_TOPIC
public:
literal String^ TRACE_TOPIC
static val mutable TRACE_TOPIC: string
static val mutable TRACE_TOPIC: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_BYTE Field

CoreConsts UNIT_NAME_BYTE Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_BYTE
public const string UNIT_NAME_BYTE
Public Const UNIT_NAME_BYTE As String
Public Const UNIT_NAME_BYTE As String
public:
literal String^ UNIT_NAME_BYTE
public:
literal String^ UNIT_NAME_BYTE
static val mutable UNIT_NAME_BYTE: string
static val mutable UNIT_NAME_BYTE: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_BYTES Field

CoreConsts UNIT_NAME_BYTES Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_BYTES
public const string UNIT_NAME_BYTES
Public Const UNIT_NAME_BYTES As String
Public Const UNIT_NAME_BYTES As String
public:
literal String^ UNIT_NAME_BYTES
public:
literal String^ UNIT_NAME_BYTES
static val mutable UNIT_NAME_BYTES: string
static val mutable UNIT_NAME_BYTES: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_CALL Field

CoreConsts UNIT_NAME_CALL Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_CALL
public const string UNIT_NAME_CALL
Public Const UNIT_NAME_CALL As String
Public Const UNIT_NAME_CALL As String
public:
literal String^ UNIT_NAME_CALL
public:
literal String^ UNIT_NAME_CALL
static val mutable UNIT_NAME_CALL: string
static val mutable UNIT_NAME_CALL: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_CHANNEL Field

CoreConsts UNIT_NAME_CHANNEL Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_CHANNEL
public const string UNIT_NAME_CHANNEL
Public Const UNIT_NAME_CHANNEL As String
Public Const UNIT_NAME_CHANNEL As String
public:
literal String^ UNIT_NAME_CHANNEL
public:
literal String^ UNIT_NAME_CHANNEL
static val mutable UNIT_NAME_CHANNEL: string
static val mutable UNIT_NAME_CHANNEL: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_ERROR Field

CoreConsts UNIT_NAME_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_ERROR
public const string UNIT_NAME_ERROR
Public Const UNIT_NAME_ERROR As String
Public Const UNIT_NAME_ERROR As String
public:
literal String^ UNIT_NAME_ERROR
public:
literal String^ UNIT_NAME_ERROR
static val mutable UNIT_NAME_ERROR: string
static val mutable UNIT_NAME_ERROR: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_EVENT Field

CoreConsts UNIT_NAME_EVENT Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_EVENT
public const string UNIT_NAME_EVENT
Public Const UNIT_NAME_EVENT As String
Public Const UNIT_NAME_EVENT As String
public:
literal String^ UNIT_NAME_EVENT
public:
literal String^ UNIT_NAME_EVENT
static val mutable UNIT_NAME_EVENT: string
static val mutable UNIT_NAME_EVENT: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_EXCEPTION Field

CoreConsts UNIT_NAME_EXCEPTION Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_EXCEPTION
public const string UNIT_NAME_EXCEPTION
Public Const UNIT_NAME_EXCEPTION As String
Public Const UNIT_NAME_EXCEPTION As String
public:
literal String^ UNIT_NAME_EXCEPTION
public:
literal String^ UNIT_NAME_EXCEPTION
static val mutable UNIT_NAME_EXCEPTION: string
static val mutable UNIT_NAME_EXCEPTION: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_GEO_LOOKUP Field

CoreConsts UNIT_NAME_GEO_LOOKUP Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_GEO_LOOKUP
public const string UNIT_NAME_GEO_LOOKUP
Public Const UNIT_NAME_GEO_LOOKUP As String
Public Const UNIT_NAME_GEO_LOOKUP As String
public:
literal String^ UNIT_NAME_GEO_LOOKUP
public:
literal String^ UNIT_NAME_GEO_LOOKUP
static val mutable UNIT_NAME_GEO_LOOKUP: string
static val mutable UNIT_NAME_GEO_LOOKUP: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_GEO_LOOKUP_HIT Field

CoreConsts UNIT_NAME_GEO_LOOKUP_HIT Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_GEO_LOOKUP_HIT
public const string UNIT_NAME_GEO_LOOKUP_HIT
Public Const UNIT_NAME_GEO_LOOKUP_HIT As String
Public Const UNIT_NAME_GEO_LOOKUP_HIT As String
public:
literal String^ UNIT_NAME_GEO_LOOKUP_HIT
public:
literal String^ UNIT_NAME_GEO_LOOKUP_HIT
static val mutable UNIT_NAME_GEO_LOOKUP_HIT: string
static val mutable UNIT_NAME_GEO_LOOKUP_HIT: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_MB Field

CoreConsts UNIT_NAME_MB Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_MB
public const string UNIT_NAME_MB
Public Const UNIT_NAME_MB As String
Public Const UNIT_NAME_MB As String
public:
literal String^ UNIT_NAME_MB
public:
literal String^ UNIT_NAME_MB
static val mutable UNIT_NAME_MB: string
static val mutable UNIT_NAME_MB: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_MESSAGE Field

CoreConsts UNIT_NAME_MESSAGE Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_MESSAGE
public const string UNIT_NAME_MESSAGE
Public Const UNIT_NAME_MESSAGE As String
Public Const UNIT_NAME_MESSAGE As String
public:
literal String^ UNIT_NAME_MESSAGE
public:
literal String^ UNIT_NAME_MESSAGE
static val mutable UNIT_NAME_MESSAGE: string
static val mutable UNIT_NAME_MESSAGE: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_MONEY Field

CoreConsts UNIT_NAME_MONEY Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_MONEY
public const string UNIT_NAME_MONEY
Public Const UNIT_NAME_MONEY As String
Public Const UNIT_NAME_MONEY As String
public:
literal String^ UNIT_NAME_MONEY
public:
literal String^ UNIT_NAME_MONEY
static val mutable UNIT_NAME_MONEY: string
static val mutable UNIT_NAME_MONEY: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_MSEC Field

CoreConsts UNIT_NAME_MSEC Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_MSEC
public const string UNIT_NAME_MSEC
Public Const UNIT_NAME_MSEC As String
Public Const UNIT_NAME_MSEC As String
public:
literal String^ UNIT_NAME_MSEC
public:
literal String^ UNIT_NAME_MSEC
static val mutable UNIT_NAME_MSEC: string
static val mutable UNIT_NAME_MSEC: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_NAMESPACE Field

CoreConsts UNIT_NAME_NAMESPACE Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_NAMESPACE
public const string UNIT_NAME_NAMESPACE
Public Const UNIT_NAME_NAMESPACE As String
Public Const UNIT_NAME_NAMESPACE As String
public:
literal String^ UNIT_NAME_NAMESPACE
public:
literal String^ UNIT_NAME_NAMESPACE
static val mutable UNIT_NAME_NAMESPACE: string
static val mutable UNIT_NAME_NAMESPACE: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_OBJECT Field

CoreConsts UNIT_NAME_OBJECT Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_OBJECT
public const string UNIT_NAME_OBJECT
Public Const UNIT_NAME_OBJECT As String
Public Const UNIT_NAME_OBJECT As String
public:
literal String^ UNIT_NAME_OBJECT
public:
literal String^ UNIT_NAME_OBJECT
static val mutable UNIT_NAME_OBJECT: string
static val mutable UNIT_NAME_OBJECT: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_OCCURENCE Field

CoreConsts UNIT_NAME_OCCURENCE Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_OCCURENCE
public const string UNIT_NAME_OCCURENCE
Public Const UNIT_NAME_OCCURENCE As String
Public Const UNIT_NAME_OCCURENCE As String
public:
literal String^ UNIT_NAME_OCCURENCE
public:
literal String^ UNIT_NAME_OCCURENCE
static val mutable UNIT_NAME_OCCURENCE: string
static val mutable UNIT_NAME_OCCURENCE: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_PAGE Field

CoreConsts UNIT_NAME_PAGE Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_PAGE
public const string UNIT_NAME_PAGE
Public Const UNIT_NAME_PAGE As String
Public Const UNIT_NAME_PAGE As String
public:
literal String^ UNIT_NAME_PAGE
public:
literal String^ UNIT_NAME_PAGE
static val mutable UNIT_NAME_PAGE: string
static val mutable UNIT_NAME_PAGE: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_PAGE_PER_BUCKET Field

CoreConsts UNIT_NAME_PAGE_PER_BUCKET Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_PAGE_PER_BUCKET
public const string UNIT_NAME_PAGE_PER_BUCKET
Public Const UNIT_NAME_PAGE_PER_BUCKET As String
Public Const UNIT_NAME_PAGE_PER_BUCKET As String
public:
literal String^ UNIT_NAME_PAGE_PER_BUCKET
public:
literal String^ UNIT_NAME_PAGE_PER_BUCKET
static val mutable UNIT_NAME_PAGE_PER_BUCKET: string
static val mutable UNIT_NAME_PAGE_PER_BUCKET: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_PERCENT Field

CoreConsts UNIT_NAME_PERCENT Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_PERCENT
public const string UNIT_NAME_PERCENT
Public Const UNIT_NAME_PERCENT As String
Public Const UNIT_NAME_PERCENT As String
public:
literal String^ UNIT_NAME_PERCENT
public:
literal String^ UNIT_NAME_PERCENT
static val mutable UNIT_NAME_PERCENT: string
static val mutable UNIT_NAME_PERCENT: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_RECORD Field

CoreConsts UNIT_NAME_RECORD Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_RECORD
public const string UNIT_NAME_RECORD
Public Const UNIT_NAME_RECORD As String
Public Const UNIT_NAME_RECORD As String
public:
literal String^ UNIT_NAME_RECORD
public:
literal String^ UNIT_NAME_RECORD
static val mutable UNIT_NAME_RECORD: string
static val mutable UNIT_NAME_RECORD: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_REQUEST Field

CoreConsts UNIT_NAME_REQUEST Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_REQUEST
public const string UNIT_NAME_REQUEST
Public Const UNIT_NAME_REQUEST As String
Public Const UNIT_NAME_REQUEST As String
public:
literal String^ UNIT_NAME_REQUEST
public:
literal String^ UNIT_NAME_REQUEST
static val mutable UNIT_NAME_REQUEST: string
static val mutable UNIT_NAME_REQUEST: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_RESPONSE Field

CoreConsts UNIT_NAME_RESPONSE Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_RESPONSE
public const string UNIT_NAME_RESPONSE
Public Const UNIT_NAME_RESPONSE As String
Public Const UNIT_NAME_RESPONSE As String
public:
literal String^ UNIT_NAME_RESPONSE
public:
literal String^ UNIT_NAME_RESPONSE
static val mutable UNIT_NAME_RESPONSE: string
static val mutable UNIT_NAME_RESPONSE: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_SEC Field

CoreConsts UNIT_NAME_SEC Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_SEC
public const string UNIT_NAME_SEC
Public Const UNIT_NAME_SEC As String
Public Const UNIT_NAME_SEC As String
public:
literal String^ UNIT_NAME_SEC
public:
literal String^ UNIT_NAME_SEC
static val mutable UNIT_NAME_SEC: string
static val mutable UNIT_NAME_SEC: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_SEGMENT Field

CoreConsts UNIT_NAME_SEGMENT Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_SEGMENT
public const string UNIT_NAME_SEGMENT
Public Const UNIT_NAME_SEGMENT As String
Public Const UNIT_NAME_SEGMENT As String
public:
literal String^ UNIT_NAME_SEGMENT
public:
literal String^ UNIT_NAME_SEGMENT
static val mutable UNIT_NAME_SEGMENT: string
static val mutable UNIT_NAME_SEGMENT: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_SESSION Field

CoreConsts UNIT_NAME_SESSION Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_SESSION
public const string UNIT_NAME_SESSION
Public Const UNIT_NAME_SESSION As String
Public Const UNIT_NAME_SESSION As String
public:
literal String^ UNIT_NAME_SESSION
public:
literal String^ UNIT_NAME_SESSION
static val mutable UNIT_NAME_SESSION: string
static val mutable UNIT_NAME_SESSION: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_SLOT Field

CoreConsts UNIT_NAME_SLOT Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_SLOT
public const string UNIT_NAME_SLOT
Public Const UNIT_NAME_SLOT As String
Public Const UNIT_NAME_SLOT As String
public:
literal String^ UNIT_NAME_SLOT
public:
literal String^ UNIT_NAME_SLOT
static val mutable UNIT_NAME_SLOT: string
static val mutable UNIT_NAME_SLOT: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_SWEEP Field

CoreConsts UNIT_NAME_SWEEP Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_SWEEP
public const string UNIT_NAME_SWEEP
Public Const UNIT_NAME_SWEEP As String
Public Const UNIT_NAME_SWEEP As String
public:
literal String^ UNIT_NAME_SWEEP
public:
literal String^ UNIT_NAME_SWEEP
static val mutable UNIT_NAME_SWEEP: string
static val mutable UNIT_NAME_SWEEP: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_TABLE Field

CoreConsts UNIT_NAME_TABLE Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_TABLE
public const string UNIT_NAME_TABLE
Public Const UNIT_NAME_TABLE As String
Public Const UNIT_NAME_TABLE As String
public:
literal String^ UNIT_NAME_TABLE
public:
literal String^ UNIT_NAME_TABLE
static val mutable UNIT_NAME_TABLE: string
static val mutable UNIT_NAME_TABLE: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_TIME Field

CoreConsts UNIT_NAME_TIME Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_TIME
public const string UNIT_NAME_TIME
Public Const UNIT_NAME_TIME As String
Public Const UNIT_NAME_TIME As String
public:
literal String^ UNIT_NAME_TIME
public:
literal String^ UNIT_NAME_TIME
static val mutable UNIT_NAME_TIME: string
static val mutable UNIT_NAME_TIME: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_TRANSACTION Field

CoreConsts UNIT_NAME_TRANSACTION Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_TRANSACTION
public const string UNIT_NAME_TRANSACTION
Public Const UNIT_NAME_TRANSACTION As String
Public Const UNIT_NAME_TRANSACTION As String
public:
literal String^ UNIT_NAME_TRANSACTION
public:
literal String^ UNIT_NAME_TRANSACTION
static val mutable UNIT_NAME_TRANSACTION: string
static val mutable UNIT_NAME_TRANSACTION: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_TRANSPORT Field

CoreConsts UNIT_NAME_TRANSPORT Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_TRANSPORT
public const string UNIT_NAME_TRANSPORT
Public Const UNIT_NAME_TRANSPORT As String
Public Const UNIT_NAME_TRANSPORT As String
public:
literal String^ UNIT_NAME_TRANSPORT
public:
literal String^ UNIT_NAME_TRANSPORT
static val mutable UNIT_NAME_TRANSPORT: string
static val mutable UNIT_NAME_TRANSPORT: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_UNSPECIFIED Field

CoreConsts UNIT_NAME_UNSPECIFIED Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_UNSPECIFIED
public const string UNIT_NAME_UNSPECIFIED
Public Const UNIT_NAME_UNSPECIFIED As String
Public Const UNIT_NAME_UNSPECIFIED As String
public:
literal String^ UNIT_NAME_UNSPECIFIED
public:
literal String^ UNIT_NAME_UNSPECIFIED
static val mutable UNIT_NAME_UNSPECIFIED: string
static val mutable UNIT_NAME_UNSPECIFIED: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNIT_NAME_WORK_CONTEXT Field

CoreConsts UNIT_NAME_WORK_CONTEXT Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIT_NAME_WORK_CONTEXT
public const string UNIT_NAME_WORK_CONTEXT
Public Const UNIT_NAME_WORK_CONTEXT As String
Public Const UNIT_NAME_WORK_CONTEXT As String
public:
literal String^ UNIT_NAME_WORK_CONTEXT
public:
literal String^ UNIT_NAME_WORK_CONTEXT
static val mutable UNIT_NAME_WORK_CONTEXT: string
static val mutable UNIT_NAME_WORK_CONTEXT: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNKNOWN Field

CoreConsts UNKNOWN Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNKNOWN
public const string UNKNOWN
Public Const UNKNOWN As String
Public Const UNKNOWN As String
public:
literal String^ UNKNOWN
public:
literal String^ UNKNOWN
static val mutable UNKNOWN: string
static val mutable UNKNOWN: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNNAMED_MEMORY_BUFFER Field

CoreConsts UNNAMED_MEMORY_BUFFER Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNNAMED_MEMORY_BUFFER
public const string UNNAMED_MEMORY_BUFFER
Public Const UNNAMED_MEMORY_BUFFER As String
Public Const UNNAMED_MEMORY_BUFFER As String
public:
literal String^ UNNAMED_MEMORY_BUFFER
public:
literal String^ UNNAMED_MEMORY_BUFFER
static val mutable UNNAMED_MEMORY_BUFFER: string
static val mutable UNNAMED_MEMORY_BUFFER: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.UNNAMED_PROJECT_ITEM Field

CoreConsts UNNAMED_PROJECT_ITEM Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNNAMED_PROJECT_ITEM
public const string UNNAMED_PROJECT_ITEM
Public Const UNNAMED_PROJECT_ITEM As String
Public Const UNNAMED_PROJECT_ITEM As String
public:
literal String^ UNNAMED_PROJECT_ITEM
public:
literal String^ UNNAMED_PROJECT_ITEM
static val mutable UNNAMED_PROJECT_ITEM: string
static val mutable UNNAMED_PROJECT_ITEM: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


CoreConsts.VALIDATION_CATEGORY Field

CoreConsts VALIDATION_CATEGORY Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string VALIDATION_CATEGORY
public const string VALIDATION_CATEGORY
Public Const VALIDATION_CATEGORY As String
Public Const VALIDATION_CATEGORY As String
public:
literal String^ VALIDATION_CATEGORY
public:
literal String^ VALIDATION_CATEGORY
static val mutable VALIDATION_CATEGORY: string
static val mutable VALIDATION_CATEGORY: string

Field Value

Type: Online String
See Also
CoreConsts Class
CoreConsts Members
NFX Namespace


DataUtils Class

DataUtils Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX DataUtils

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class DataUtils
public static class DataUtils
<ExtensionAttribute>
Public NotInheritable Class DataUtils
<ExtensionAttribute>
Public NotInheritable Class DataUtils
[ExtensionAttribute]
public ref class DataUtils abstract sealed
[ExtensionAttribute]
public ref class DataUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DataUtils =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DataUtils =  class end
See Also
DataUtils Members
NFX Namespace


DataUtils Members

DataUtils Members NFX Class Library

The DataUtils type exposes the following members.
Methods
Name | Description
AllButTheseFields(IEnumerable String , Boolean) | Converts field names separated by ',' or ';' into a FieldFilterFunction
AllButTheseFields(String, Boolean) | Converts field names separated by ',' or ';' into a FieldFilterFunction
AsEnumerableOf TRow | Casts enumerable of rows (such as rowset) to the specified row type, returning empty enumerable if the source is null
Clone TRow | If source is not null, creates a shallow clone using 'source.CopyFields(copy)'
LoadEnumerable TRow | Loads rowset with rows cast per Query(T) or empty enum
LoadEnumerableAsync TRow | Async version - loads rowset with rows cast per Query(T) or empty enum
LoadRow TRow | Loads one row cast per Query(T) or null
LoadRowAsync TRow | Async version - loads one row cast per Query(T) or null
OnlyTheseFields(IEnumerable String , Boolean) | Converts field names separated by ',' or ';' into a FieldFilterFunction
OnlyTheseFields(String, Boolean) | Converts field names separated by ',' or ';' into a FieldFilterFunction
Back to Top
See Also
DataUtils Class
NFX Namespace


DataUtils Methods

DataUtils Methods NFX Class Library

The DataUtils type exposes the following members.
Methods
Name | Description
AllButTheseFields(IEnumerable String , Boolean) | Converts field names separated by ',' or ';' into a FieldFilterFunction
AllButTheseFields(String, Boolean) | Converts field names separated by ',' or ';' into a FieldFilterFunction
AsEnumerableOf TRow | Casts enumerable of rows (such as rowset) to the specified row type, returning empty enumerable if the source is null
Clone TRow | If source is not null, creates a shallow clone using 'source.CopyFields(copy)'
LoadEnumerable TRow | Loads rowset with rows cast per Query(T) or empty enum
LoadEnumerableAsync TRow | Async version - loads rowset with rows cast per Query(T) or empty enum
LoadRow TRow | Loads one row cast per Query(T) or null
LoadRowAsync TRow | Async version - loads one row cast per Query(T) or null
OnlyTheseFields(IEnumerable String , Boolean) | Converts field names separated by ',' or ';' into a FieldFilterFunction
OnlyTheseFields(String, Boolean) | Converts field names separated by ',' or ';' into a FieldFilterFunction
Back to Top
See Also
DataUtils Class
NFX Namespace


DataUtils.AllButTheseFields Method

DataUtils AllButTheseFields Method NFX Class Library

Overload List
Name | Description
AllButTheseFields(IEnumerable String , Boolean) | Converts field names separated by ',' or ';' into a FieldFilterFunction
AllButTheseFields(String, Boolean) | Converts field names separated by ',' or ';' into a FieldFilterFunction
Back to Top
See Also
DataUtils Class
DataUtils Members
NFX Namespace


DataUtils.AllButTheseFields Method (IEnumerable(String), Boolean)

DataUtils AllButTheseFields Method (IEnumerable String , Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Converts field names separated by ',' or ';' into a FieldFilterFunction

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FieldFilterFunc AllButTheseFields(
    this IEnumerable<string> fields,
    bool caseSensitive = false
)
public static FieldFilterFunc AllButTheseFields(
    this IEnumerable<string> fields,
    bool caseSensitive = false
)
<ExtensionAttribute>
Public Shared Function AllButTheseFields (
    fields As IEnumerable(Of String),
    Optional caseSensitive As Boolean = false
) As FieldFilterFunc
<ExtensionAttribute>
Public Shared Function AllButTheseFields (
    fields As IEnumerable(Of String),
    Optional caseSensitive As Boolean = false
) As FieldFilterFunc
public:
[ExtensionAttribute]
static FieldFilterFunc^ AllButTheseFields(
    IEnumerable<String^>^ fields,
    bool caseSensitive = false
)
public:
[ExtensionAttribute]
static FieldFilterFunc^ AllButTheseFields(
    IEnumerable<String^>^ fields,
    bool caseSensitive = false
)
static member AllButTheseFields :
        fields : IEnumerable<string> *
        ?caseSensitive : bool
(* Defaults:
        let _caseSensitive = defaultArg caseSensitive false
*)
-> FieldFilterFunc
static member AllButTheseFields :
        fields : IEnumerable<string> *
        ?caseSensitive : bool
(* Defaults:
        let _caseSensitive = defaultArg caseSensitive false
*)
-> FieldFilterFunc

Parameters

fields
Type: Online System.Collections.Generic IEnumerable Online String
caseSensitive (Optional)
Type: Online System Boolean

Return Value

Type: FieldFilterFunc

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online IEnumerable Online String . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
DataUtils Class
DataUtils Members
AllButTheseFields Overload
NFX Namespace


DataUtils.AllButTheseFields Method (String, Boolean)

DataUtils AllButTheseFields Method (String, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Converts field names separated by ',' or ';' into a FieldFilterFunction

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FieldFilterFunc AllButTheseFields(
    this string fields,
    bool caseSensitive = false
)
public static FieldFilterFunc AllButTheseFields(
    this string fields,
    bool caseSensitive = false
)
<ExtensionAttribute>
Public Shared Function AllButTheseFields (
    fields As String,
    Optional caseSensitive As Boolean = false
) As FieldFilterFunc
<ExtensionAttribute>
Public Shared Function AllButTheseFields (
    fields As String,
    Optional caseSensitive As Boolean = false
) As FieldFilterFunc
public:
[ExtensionAttribute]
static FieldFilterFunc^ AllButTheseFields(
    String^ fields,
    bool caseSensitive = false
)
public:
[ExtensionAttribute]
static FieldFilterFunc^ AllButTheseFields(
    String^ fields,
    bool caseSensitive = false
)
static member AllButTheseFields :
        fields : string *
        ?caseSensitive : bool
(* Defaults:
        let _caseSensitive = defaultArg caseSensitive false
*)
-> FieldFilterFunc
static member AllButTheseFields :
        fields : string *
        ?caseSensitive : bool
(* Defaults:
        let _caseSensitive = defaultArg caseSensitive false
*)
-> FieldFilterFunc

Parameters

fields
Type: Online System String
caseSensitive (Optional)
Type: Online System Boolean

Return Value

Type: FieldFilterFunc

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
DataUtils Class
DataUtils Members
AllButTheseFields Overload
NFX Namespace


DataUtils.AsEnumerableOf(TRow) Method

DataUtils AsEnumerableOf TRow Method NFX Class Library

Casts enumerable of rows (such as rowset) to the specified row type, returning empty enumerable if the source is null

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<TRow> AsEnumerableOf<TRow>(
    this IEnumerable<Row> source
)
where TRow : Row
public static IEnumerable<TRow> AsEnumerableOf<TRow>(
    this IEnumerable<Row> source
)
where TRow : Row
<ExtensionAttribute>
Public Shared Function AsEnumerableOf(Of TRow As Row) (
    source As IEnumerable(Of Row)
) As IEnumerable(Of TRow)
<ExtensionAttribute>
Public Shared Function AsEnumerableOf(Of TRow As Row) (
    source As IEnumerable(Of Row)
) As IEnumerable(Of TRow)
public:
[ExtensionAttribute]
generic<typename TRow>
where TRow : Row
static IEnumerable<TRow>^ AsEnumerableOf(
    IEnumerable<Row^>^ source
)
public:
[ExtensionAttribute]
generic<typename TRow>
where TRow : Row
static IEnumerable<TRow>^ AsEnumerableOf(
    IEnumerable<Row^>^ source
)
static member AsEnumerableOf :
        source : IEnumerable<Row> -> IEnumerable<'TRow>  when 'TRow : Row
static member AsEnumerableOf :
        source : IEnumerable<Row> -> IEnumerable<'TRow>  when 'TRow : Row

Parameters

source
Type: Online System.Collections.Generic IEnumerable Row
Type Parameters
TRow

Return Value

Type: Online IEnumerable TRow

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online IEnumerable Row . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
DataUtils Class
DataUtils Members
NFX Namespace


DataUtils.Clone(TRow) Method

DataUtils Clone TRow Method NFX Class Library

If source is not null, creates a shallow clone using 'source.CopyFields(copy)'

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TRow Clone<TRow>(
    this TRow source,
    bool includeAmorphousData = true,
    bool invokeAmorphousAfterLoad = true,
    Func<string, Schema..::..FieldDef, bool> fieldFilter = null,
    Func<string, string, bool> amorphousFieldFilter = null
)
where TRow : Row
public static TRow Clone<TRow>(
    this TRow source,
    bool includeAmorphousData = true,
    bool invokeAmorphousAfterLoad = true,
    Func<string, Schema..::..FieldDef, bool> fieldFilter = null,
    Func<string, string, bool> amorphousFieldFilter = null
)
where TRow : Row
<ExtensionAttribute>
Public Shared Function Clone(Of TRow As Row) (
    source As TRow,
    Optional includeAmorphousData As Boolean = true,
    Optional invokeAmorphousAfterLoad As Boolean = true,
    Optional fieldFilter As Func(Of String, Schema..::..FieldDef, Boolean) = Nothing,
    Optional amorphousFieldFilter As Func(Of String, String, Boolean) = Nothing
) As TRow
<ExtensionAttribute>
Public Shared Function Clone(Of TRow As Row) (
    source As TRow,
    Optional includeAmorphousData As Boolean = true,
    Optional invokeAmorphousAfterLoad As Boolean = true,
    Optional fieldFilter As Func(Of String, Schema..::..FieldDef, Boolean) = Nothing,
    Optional amorphousFieldFilter As Func(Of String, String, Boolean) = Nothing
) As TRow
public:
[ExtensionAttribute]
generic<typename TRow>
where TRow : Row
static TRow Clone(
    TRow source,
    bool includeAmorphousData = true,
    bool invokeAmorphousAfterLoad = true,
    Func<String^, Schema..::..FieldDef^, bool>^ fieldFilter = nullptr,
    Func<String^, String^, bool>^ amorphousFieldFilter = nullptr
)
public:
[ExtensionAttribute]
generic<typename TRow>
where TRow : Row
static TRow Clone(
    TRow source,
    bool includeAmorphousData = true,
    bool invokeAmorphousAfterLoad = true,
    Func<String^, Schema..::..FieldDef^, bool>^ fieldFilter = nullptr,
    Func<String^, String^, bool>^ amorphousFieldFilter = nullptr
)
static member Clone :
        source : 'TRow *
        ?includeAmorphousData : bool *
        ?invokeAmorphousAfterLoad : bool *
        ?fieldFilter : Func<string, Schema..::..FieldDef, bool> *
        ?amorphousFieldFilter : Func<string, string, bool>
(* Defaults:
        let _includeAmorphousData = defaultArg includeAmorphousData true
        let _invokeAmorphousAfterLoad = defaultArg invokeAmorphousAfterLoad true
        let _fieldFilter = defaultArg fieldFilter null
        let _amorphousFieldFilter = defaultArg amorphousFieldFilter null
*)
-> 'TRow  when 'TRow : Row
static member Clone :
        source : 'TRow *
        ?includeAmorphousData : bool *
        ?invokeAmorphousAfterLoad : bool *
        ?fieldFilter : Func<string, Schema..::..FieldDef, bool> *
        ?amorphousFieldFilter : Func<string, string, bool>
(* Defaults:
        let _includeAmorphousData = defaultArg includeAmorphousData true
        let _invokeAmorphousAfterLoad = defaultArg invokeAmorphousAfterLoad true
        let _fieldFilter = defaultArg fieldFilter null
        let _amorphousFieldFilter = defaultArg amorphousFieldFilter null
*)
-> 'TRow  when 'TRow : Row

Parameters

source
Type: TRow
includeAmorphousData (Optional)
Type: Online System Boolean
invokeAmorphousAfterLoad (Optional)
Type: Online System Boolean
fieldFilter (Optional)
Type: Online System Func Online String, Schema FieldDef, Online Boolean
amorphousFieldFilter (Optional)
Type: Online System Func Online String, Online String, Online Boolean
Type Parameters
TRow

Return Value

Type: TRow

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
DataUtils Class
DataUtils Members
NFX Namespace


DataUtils.LoadEnumerable(TRow) Method

DataUtils LoadEnumerable TRow Method NFX Class Library

Loads rowset with rows cast per Query(T) or empty enum

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<TRow> LoadEnumerable<TRow>(
    this ICRUDOperations operations,
    Query<TRow> query
)
where TRow : Row
public static IEnumerable<TRow> LoadEnumerable<TRow>(
    this ICRUDOperations operations,
    Query<TRow> query
)
where TRow : Row
<ExtensionAttribute>
Public Shared Function LoadEnumerable(Of TRow As Row) (
    operations As ICRUDOperations,
    query As Query(Of TRow)
) As IEnumerable(Of TRow)
<ExtensionAttribute>
Public Shared Function LoadEnumerable(Of TRow As Row) (
    operations As ICRUDOperations,
    query As Query(Of TRow)
) As IEnumerable(Of TRow)
public:
[ExtensionAttribute]
generic<typename TRow>
where TRow : Row
static IEnumerable<TRow>^ LoadEnumerable(
    ICRUDOperations^ operations,
    Query<TRow>^ query
)
public:
[ExtensionAttribute]
generic<typename TRow>
where TRow : Row
static IEnumerable<TRow>^ LoadEnumerable(
    ICRUDOperations^ operations,
    Query<TRow>^ query
)
static member LoadEnumerable :
        operations : ICRUDOperations *
        query : Query<'TRow> -> IEnumerable<'TRow>  when 'TRow : Row
static member LoadEnumerable :
        operations : ICRUDOperations *
        query : Query<'TRow> -> IEnumerable<'TRow>  when 'TRow : Row

Parameters

operations
Type: NFX.DataAccess.CRUD ICRUDOperations
query
Type: NFX.DataAccess.CRUD Query TRow
Type Parameters
TRow

Return Value

Type: Online IEnumerable TRow

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ICRUDOperations. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
DataUtils Class
DataUtils Members
NFX Namespace


DataUtils.LoadEnumerableAsync(TRow) Method

DataUtils LoadEnumerableAsync TRow Method NFX Class Library

Async version - loads rowset with rows cast per Query(T) or empty enum

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task<IEnumerable<TRow>> LoadEnumerableAsync<TRow>(
    this ICRUDOperations operations,
    Query<TRow> query
)
where TRow : Row
public static Task<IEnumerable<TRow>> LoadEnumerableAsync<TRow>(
    this ICRUDOperations operations,
    Query<TRow> query
)
where TRow : Row
<ExtensionAttribute>
Public Shared Function LoadEnumerableAsync(Of TRow As Row) (
    operations As ICRUDOperations,
    query As Query(Of TRow)
) As Task(Of IEnumerable(Of TRow))
<ExtensionAttribute>
Public Shared Function LoadEnumerableAsync(Of TRow As Row) (
    operations As ICRUDOperations,
    query As Query(Of TRow)
) As Task(Of IEnumerable(Of TRow))
public:
[ExtensionAttribute]
generic<typename TRow>
where TRow : Row
static Task<IEnumerable<TRow>^>^ LoadEnumerableAsync(
    ICRUDOperations^ operations,
    Query<TRow>^ query
)
public:
[ExtensionAttribute]
generic<typename TRow>
where TRow : Row
static Task<IEnumerable<TRow>^>^ LoadEnumerableAsync(
    ICRUDOperations^ operations,
    Query<TRow>^ query
)
static member LoadEnumerableAsync :
        operations : ICRUDOperations *
        query : Query<'TRow> -> Task<IEnumerable<'TRow>>  when 'TRow : Row
static member LoadEnumerableAsync :
        operations : ICRUDOperations *
        query : Query<'TRow> -> Task<IEnumerable<'TRow>>  when 'TRow : Row

Parameters

operations
Type: NFX.DataAccess.CRUD ICRUDOperations
query
Type: NFX.DataAccess.CRUD Query TRow
Type Parameters
TRow

Return Value

Type: Online Task Online IEnumerable TRow

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ICRUDOperations. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
DataUtils Class
DataUtils Members
NFX Namespace


DataUtils.LoadRow(TRow) Method

DataUtils LoadRow TRow Method NFX Class Library

Loads one row cast per Query(T) or null

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TRow LoadRow<TRow>(
    this ICRUDOperations operations,
    Query<TRow> query
)
where TRow : Row
public static TRow LoadRow<TRow>(
    this ICRUDOperations operations,
    Query<TRow> query
)
where TRow : Row
<ExtensionAttribute>
Public Shared Function LoadRow(Of TRow As Row) (
    operations As ICRUDOperations,
    query As Query(Of TRow)
) As TRow
<ExtensionAttribute>
Public Shared Function LoadRow(Of TRow As Row) (
    operations As ICRUDOperations,
    query As Query(Of TRow)
) As TRow
public:
[ExtensionAttribute]
generic<typename TRow>
where TRow : Row
static TRow LoadRow(
    ICRUDOperations^ operations,
    Query<TRow>^ query
)
public:
[ExtensionAttribute]
generic<typename TRow>
where TRow : Row
static TRow LoadRow(
    ICRUDOperations^ operations,
    Query<TRow>^ query
)
static member LoadRow :
        operations : ICRUDOperations *
        query : Query<'TRow> -> 'TRow  when 'TRow : Row
static member LoadRow :
        operations : ICRUDOperations *
        query : Query<'TRow> -> 'TRow  when 'TRow : Row

Parameters

operations
Type: NFX.DataAccess.CRUD ICRUDOperations
query
Type: NFX.DataAccess.CRUD Query TRow
Type Parameters
TRow

Return Value

Type: TRow

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ICRUDOperations. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
DataUtils Class
DataUtils Members
NFX Namespace


DataUtils.LoadRowAsync(TRow) Method

DataUtils LoadRowAsync TRow Method NFX Class Library

Async version - loads one row cast per Query(T) or null

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task<TRow> LoadRowAsync<TRow>(
    this ICRUDOperations operations,
    Query<TRow> query
)
where TRow : Row
public static Task<TRow> LoadRowAsync<TRow>(
    this ICRUDOperations operations,
    Query<TRow> query
)
where TRow : Row
<ExtensionAttribute>
Public Shared Function LoadRowAsync(Of TRow As Row) (
    operations As ICRUDOperations,
    query As Query(Of TRow)
) As Task(Of TRow)
<ExtensionAttribute>
Public Shared Function LoadRowAsync(Of TRow As Row) (
    operations As ICRUDOperations,
    query As Query(Of TRow)
) As Task(Of TRow)
public:
[ExtensionAttribute]
generic<typename TRow>
where TRow : Row
static Task<TRow>^ LoadRowAsync(
    ICRUDOperations^ operations,
    Query<TRow>^ query
)
public:
[ExtensionAttribute]
generic<typename TRow>
where TRow : Row
static Task<TRow>^ LoadRowAsync(
    ICRUDOperations^ operations,
    Query<TRow>^ query
)
static member LoadRowAsync :
        operations : ICRUDOperations *
        query : Query<'TRow> -> Task<'TRow>  when 'TRow : Row
static member LoadRowAsync :
        operations : ICRUDOperations *
        query : Query<'TRow> -> Task<'TRow>  when 'TRow : Row

Parameters

operations
Type: NFX.DataAccess.CRUD ICRUDOperations
query
Type: NFX.DataAccess.CRUD Query TRow
Type Parameters
TRow

Return Value

Type: Online Task TRow

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ICRUDOperations. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
DataUtils Class
DataUtils Members
NFX Namespace


DataUtils.OnlyTheseFields Method

DataUtils OnlyTheseFields Method NFX Class Library

Overload List
Name | Description
OnlyTheseFields(IEnumerable String , Boolean) | Converts field names separated by ',' or ';' into a FieldFilterFunction
OnlyTheseFields(String, Boolean) | Converts field names separated by ',' or ';' into a FieldFilterFunction
Back to Top
See Also
DataUtils Class
DataUtils Members
NFX Namespace


DataUtils.OnlyTheseFields Method (IEnumerable(String), Boolean)

DataUtils OnlyTheseFields Method (IEnumerable String , Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Converts field names separated by ',' or ';' into a FieldFilterFunction

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FieldFilterFunc OnlyTheseFields(
    this IEnumerable<string> fields,
    bool caseSensitive = false
)
public static FieldFilterFunc OnlyTheseFields(
    this IEnumerable<string> fields,
    bool caseSensitive = false
)
<ExtensionAttribute>
Public Shared Function OnlyTheseFields (
    fields As IEnumerable(Of String),
    Optional caseSensitive As Boolean = false
) As FieldFilterFunc
<ExtensionAttribute>
Public Shared Function OnlyTheseFields (
    fields As IEnumerable(Of String),
    Optional caseSensitive As Boolean = false
) As FieldFilterFunc
public:
[ExtensionAttribute]
static FieldFilterFunc^ OnlyTheseFields(
    IEnumerable<String^>^ fields,
    bool caseSensitive = false
)
public:
[ExtensionAttribute]
static FieldFilterFunc^ OnlyTheseFields(
    IEnumerable<String^>^ fields,
    bool caseSensitive = false
)
static member OnlyTheseFields :
        fields : IEnumerable<string> *
        ?caseSensitive : bool
(* Defaults:
        let _caseSensitive = defaultArg caseSensitive false
*)
-> FieldFilterFunc
static member OnlyTheseFields :
        fields : IEnumerable<string> *
        ?caseSensitive : bool
(* Defaults:
        let _caseSensitive = defaultArg caseSensitive false
*)
-> FieldFilterFunc

Parameters

fields
Type: Online System.Collections.Generic IEnumerable Online String
caseSensitive (Optional)
Type: Online System Boolean

Return Value

Type: FieldFilterFunc

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online IEnumerable Online String . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
DataUtils Class
DataUtils Members
OnlyTheseFields Overload
NFX Namespace


DataUtils.OnlyTheseFields Method (String, Boolean)

DataUtils OnlyTheseFields Method (String, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Converts field names separated by ',' or ';' into a FieldFilterFunction

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FieldFilterFunc OnlyTheseFields(
    this string fields,
    bool caseSensitive = false
)
public static FieldFilterFunc OnlyTheseFields(
    this string fields,
    bool caseSensitive = false
)
<ExtensionAttribute>
Public Shared Function OnlyTheseFields (
    fields As String,
    Optional caseSensitive As Boolean = false
) As FieldFilterFunc
<ExtensionAttribute>
Public Shared Function OnlyTheseFields (
    fields As String,
    Optional caseSensitive As Boolean = false
) As FieldFilterFunc
public:
[ExtensionAttribute]
static FieldFilterFunc^ OnlyTheseFields(
    String^ fields,
    bool caseSensitive = false
)
public:
[ExtensionAttribute]
static FieldFilterFunc^ OnlyTheseFields(
    String^ fields,
    bool caseSensitive = false
)
static member OnlyTheseFields :
        fields : string *
        ?caseSensitive : bool
(* Defaults:
        let _caseSensitive = defaultArg caseSensitive false
*)
-> FieldFilterFunc
static member OnlyTheseFields :
        fields : string *
        ?caseSensitive : bool
(* Defaults:
        let _caseSensitive = defaultArg caseSensitive false
*)
-> FieldFilterFunc

Parameters

fields
Type: Online System String
caseSensitive (Optional)
Type: Online System Boolean

Return Value

Type: FieldFilterFunc

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
DataUtils Class
DataUtils Members
OnlyTheseFields Overload
NFX Namespace


Debug Class

Debug Class NFX Class Library

Facilitates debugging tasks enabled by DEBUG conditional define
Inheritance Hierarchy
Online System Object
NFX Debug

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class Debug
public static class Debug
Public NotInheritable Class Debug
Public NotInheritable Class Debug
public ref class Debug abstract sealed
public ref class Debug abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Debug =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Debug =  class end
See Also
Debug Members
NFX Namespace


Debug Members

Debug Members NFX Class Library

The Debug type exposes the following members.
Methods
Name | Description
Assert |
Fail |
Write(Func String , MessageType, Nullable Guid ) | A simplified method for tracing that doesn't evaluate text generation function if tracing is disabled by configuration
Write(String, String, MessageType, Int32, String, String, Nullable Guid , Int32) |
Back to Top
Fields
Name | Description
DEBUG |
Back to Top
See Also
Debug Class
NFX Namespace


Debug Fields

Debug Fields NFX Class Library

The Debug type exposes the following members.
Fields
Name | Description
DEBUG |
Back to Top
See Also
Debug Class
NFX Namespace


Debug.DEBUG Field

Debug DEBUG Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEBUG
public const string DEBUG
Public Const DEBUG As String
Public Const DEBUG As String
public:
literal String^ DEBUG
public:
literal String^ DEBUG
static val mutable DEBUG: string
static val mutable DEBUG: string

Field Value

Type: Online String
See Also
Debug Class
Debug Members
NFX Namespace


Debug Methods

Debug Methods NFX Class Library

The Debug type exposes the following members.
Methods
Name | Description
Assert |
Fail |
Write(Func String , MessageType, Nullable Guid ) | A simplified method for tracing that doesn't evaluate text generation function if tracing is disabled by configuration
Write(String, String, MessageType, Int32, String, String, Nullable Guid , Int32) |
Back to Top
See Also
Debug Class
NFX Namespace


Debug.Assert Method

Debug Assert Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConditionalAttribute("DEBUG")]
public static void Assert(
    bool condition,
    string text = null,
    DebugAction action = DebugAction.Default,
    string from = null,
    MessageType type = MessageType.Debug,
    int source = 0,
    string topic = null,
    string pars = null,
    Nullable<Guid> correlationContext = null,
    int frameOffset = 2
)
[ConditionalAttribute("DEBUG")]
public static void Assert(
    bool condition,
    string text = null,
    DebugAction action = DebugAction.Default,
    string from = null,
    MessageType type = MessageType.Debug,
    int source = 0,
    string topic = null,
    string pars = null,
    Nullable<Guid> correlationContext = null,
    int frameOffset = 2
)
<ConditionalAttribute("DEBUG")>
Public Shared Sub Assert (
    condition As Boolean,
    Optional text As String = Nothing,
    Optional action As DebugAction = DebugAction.Default,
    Optional from As String = Nothing,
    Optional type As MessageType = MessageType.Debug,
    Optional source As Integer = 0,
    Optional topic As String = Nothing,
    Optional pars As String = Nothing,
    Optional correlationContext As Nullable(Of Guid) = Nothing,
    Optional frameOffset As Integer = 2
)
<ConditionalAttribute("DEBUG")>
Public Shared Sub Assert (
    condition As Boolean,
    Optional text As String = Nothing,
    Optional action As DebugAction = DebugAction.Default,
    Optional from As String = Nothing,
    Optional type As MessageType = MessageType.Debug,
    Optional source As Integer = 0,
    Optional topic As String = Nothing,
    Optional pars As String = Nothing,
    Optional correlationContext As Nullable(Of Guid) = Nothing,
    Optional frameOffset As Integer = 2
)
public:
[ConditionalAttribute(L"DEBUG")]
static void Assert(
    bool condition,
    String^ text = nullptr,
    DebugAction action = DebugAction::Default,
    String^ from = nullptr,
    MessageType type = MessageType::Debug,
    int source = 0,
    String^ topic = nullptr,
    String^ pars = nullptr,
    Nullable<Guid> correlationContext = nullptr,
    int frameOffset = 2
)
public:
[ConditionalAttribute(L"DEBUG")]
static void Assert(
    bool condition,
    String^ text = nullptr,
    DebugAction action = DebugAction::Default,
    String^ from = nullptr,
    MessageType type = MessageType::Debug,
    int source = 0,
    String^ topic = nullptr,
    String^ pars = nullptr,
    Nullable<Guid> correlationContext = nullptr,
    int frameOffset = 2
)
[<ConditionalAttribute("DEBUG")>]
static member Assert :
        condition : bool *
        ?text : string *
        ?action : DebugAction *
        ?from : string *
        ?type : MessageType *
        ?source : int *
        ?topic : string *
        ?pars : string *
        ?correlationContext : Nullable<Guid> *
        ?frameOffset : int
(* Defaults:
        let _text = defaultArg text null
        let _action = defaultArg action DebugAction.Default
        let _from = defaultArg from null
        let _type = defaultArg type MessageType.Debug
        let _source = defaultArg source 0
        let _topic = defaultArg topic null
        let _pars = defaultArg pars null
        let _correlationContext = defaultArg correlationContext null
        let _frameOffset = defaultArg frameOffset 2
*)
-> unit
[<ConditionalAttribute("DEBUG")>]
static member Assert :
        condition : bool *
        ?text : string *
        ?action : DebugAction *
        ?from : string *
        ?type : MessageType *
        ?source : int *
        ?topic : string *
        ?pars : string *
        ?correlationContext : Nullable<Guid> *
        ?frameOffset : int
(* Defaults:
        let _text = defaultArg text null
        let _action = defaultArg action DebugAction.Default
        let _from = defaultArg from null
        let _type = defaultArg type MessageType.Debug
        let _source = defaultArg source 0
        let _topic = defaultArg topic null
        let _pars = defaultArg pars null
        let _correlationContext = defaultArg correlationContext null
        let _frameOffset = defaultArg frameOffset 2
*)
-> unit

Parameters

condition
Type: Online System Boolean
text (Optional)
Type: Online System String
action (Optional)
Type: NFX DebugAction
from (Optional)
Type: Online System String
type (Optional)
Type: NFX.Log MessageType
source (Optional)
Type: Online System Int32
topic (Optional)
Type: Online System String
pars (Optional)
Type: Online System String
correlationContext (Optional)
Type: Online System Nullable Online Guid
frameOffset (Optional)
Type: Online System Int32
See Also
Debug Class
Debug Members
NFX Namespace


Debug.Fail Method

Debug Fail Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConditionalAttribute("DEBUG")]
public static void Fail(
    string text = null,
    DebugAction action = DebugAction.Default,
    string from = null,
    MessageType type = MessageType.Debug,
    int source = 0,
    string topic = null,
    string pars = null,
    Nullable<Guid> correlationContext = null,
    int frameOffset = 2
)
[ConditionalAttribute("DEBUG")]
public static void Fail(
    string text = null,
    DebugAction action = DebugAction.Default,
    string from = null,
    MessageType type = MessageType.Debug,
    int source = 0,
    string topic = null,
    string pars = null,
    Nullable<Guid> correlationContext = null,
    int frameOffset = 2
)
<ConditionalAttribute("DEBUG")>
Public Shared Sub Fail (
    Optional text As String = Nothing,
    Optional action As DebugAction = DebugAction.Default,
    Optional from As String = Nothing,
    Optional type As MessageType = MessageType.Debug,
    Optional source As Integer = 0,
    Optional topic As String = Nothing,
    Optional pars As String = Nothing,
    Optional correlationContext As Nullable(Of Guid) = Nothing,
    Optional frameOffset As Integer = 2
)
<ConditionalAttribute("DEBUG")>
Public Shared Sub Fail (
    Optional text As String = Nothing,
    Optional action As DebugAction = DebugAction.Default,
    Optional from As String = Nothing,
    Optional type As MessageType = MessageType.Debug,
    Optional source As Integer = 0,
    Optional topic As String = Nothing,
    Optional pars As String = Nothing,
    Optional correlationContext As Nullable(Of Guid) = Nothing,
    Optional frameOffset As Integer = 2
)
public:
[ConditionalAttribute(L"DEBUG")]
static void Fail(
    String^ text = nullptr,
    DebugAction action = DebugAction::Default,
    String^ from = nullptr,
    MessageType type = MessageType::Debug,
    int source = 0,
    String^ topic = nullptr,
    String^ pars = nullptr,
    Nullable<Guid> correlationContext = nullptr,
    int frameOffset = 2
)
public:
[ConditionalAttribute(L"DEBUG")]
static void Fail(
    String^ text = nullptr,
    DebugAction action = DebugAction::Default,
    String^ from = nullptr,
    MessageType type = MessageType::Debug,
    int source = 0,
    String^ topic = nullptr,
    String^ pars = nullptr,
    Nullable<Guid> correlationContext = nullptr,
    int frameOffset = 2
)
[<ConditionalAttribute("DEBUG")>]
static member Fail :
        ?text : string *
        ?action : DebugAction *
        ?from : string *
        ?type : MessageType *
        ?source : int *
        ?topic : string *
        ?pars : string *
        ?correlationContext : Nullable<Guid> *
        ?frameOffset : int
(* Defaults:
        let _text = defaultArg text null
        let _action = defaultArg action DebugAction.Default
        let _from = defaultArg from null
        let _type = defaultArg type MessageType.Debug
        let _source = defaultArg source 0
        let _topic = defaultArg topic null
        let _pars = defaultArg pars null
        let _correlationContext = defaultArg correlationContext null
        let _frameOffset = defaultArg frameOffset 2
*)
-> unit
[<ConditionalAttribute("DEBUG")>]
static member Fail :
        ?text : string *
        ?action : DebugAction *
        ?from : string *
        ?type : MessageType *
        ?source : int *
        ?topic : string *
        ?pars : string *
        ?correlationContext : Nullable<Guid> *
        ?frameOffset : int
(* Defaults:
        let _text = defaultArg text null
        let _action = defaultArg action DebugAction.Default
        let _from = defaultArg from null
        let _type = defaultArg type MessageType.Debug
        let _source = defaultArg source 0
        let _topic = defaultArg topic null
        let _pars = defaultArg pars null
        let _correlationContext = defaultArg correlationContext null
        let _frameOffset = defaultArg frameOffset 2
*)
-> unit

Parameters

text (Optional)
Type: Online System String
action (Optional)
Type: NFX DebugAction
from (Optional)
Type: Online System String
type (Optional)
Type: NFX.Log MessageType
source (Optional)
Type: Online System Int32
topic (Optional)
Type: Online System String
pars (Optional)
Type: Online System String
correlationContext (Optional)
Type: Online System Nullable Online Guid
frameOffset (Optional)
Type: Online System Int32
See Also
Debug Class
Debug Members
NFX Namespace


Debug.Write Method

Debug Write Method NFX Class Library

Overload List
Name | Description
Write(Func String , MessageType, Nullable Guid ) | A simplified method for tracing that doesn't evaluate text generation function if tracing is disabled by configuration
Write(String, String, MessageType, Int32, String, String, Nullable Guid , Int32) |
Back to Top
See Also
Debug Class
Debug Members
NFX Namespace


Debug.Write Method (Func(String), MessageType, Nullable(Guid))

Debug Write Method (Func String , MessageType, Nullable Guid ) NFX Class Library

[This is preliminary documentation and is subject to change.]

A simplified method for tracing that doesn't evaluate text generation function if tracing is disabled by configuration

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConditionalAttribute("DEBUG")]
public static void Write(
    Func<string> textFunc,
    MessageType type = MessageType.Trace,
    Nullable<Guid> correlationContext = null
)
[ConditionalAttribute("DEBUG")]
public static void Write(
    Func<string> textFunc,
    MessageType type = MessageType.Trace,
    Nullable<Guid> correlationContext = null
)
<ConditionalAttribute("DEBUG")>
Public Shared Sub Write (
    textFunc As Func(Of String),
    Optional type As MessageType = MessageType.Trace,
    Optional correlationContext As Nullable(Of Guid) = Nothing
)
<ConditionalAttribute("DEBUG")>
Public Shared Sub Write (
    textFunc As Func(Of String),
    Optional type As MessageType = MessageType.Trace,
    Optional correlationContext As Nullable(Of Guid) = Nothing
)
public:
[ConditionalAttribute(L"DEBUG")]
static void Write(
    Func<String^>^ textFunc,
    MessageType type = MessageType::Trace,
    Nullable<Guid> correlationContext = nullptr
)
public:
[ConditionalAttribute(L"DEBUG")]
static void Write(
    Func<String^>^ textFunc,
    MessageType type = MessageType::Trace,
    Nullable<Guid> correlationContext = nullptr
)
[<ConditionalAttribute("DEBUG")>]
static member Write :
        textFunc : Func<string> *
        ?type : MessageType *
        ?correlationContext : Nullable<Guid>
(* Defaults:
        let _type = defaultArg type MessageType.Trace
        let _correlationContext = defaultArg correlationContext null
*)
-> unit
[<ConditionalAttribute("DEBUG")>]
static member Write :
        textFunc : Func<string> *
        ?type : MessageType *
        ?correlationContext : Nullable<Guid>
(* Defaults:
        let _type = defaultArg type MessageType.Trace
        let _correlationContext = defaultArg correlationContext null
*)
-> unit

Parameters

textFunc
Type: Online System Func Online String
Functor to evaluate to get the text sent to logger
type (Optional)
Type: NFX.Log MessageType
Message type to log
correlationContext (Optional)
Type: Online System Nullable Online Guid
Optional correlation token to relate log entries
See Also
Debug Class
Debug Members
Write Overload
NFX Namespace


Debug.Write Method (String, String, MessageType, Int32, String, String, Nullable(Guid), Int32)

Debug Write Method (String, String, MessageType, Int32, String, String, Nullable Guid , Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConditionalAttribute("DEBUG")]
public static void Write(
    string text,
    string from = null,
    MessageType type = MessageType.Debug,
    int source = 0,
    string topic = null,
    string pars = null,
    Nullable<Guid> correlationContext = null,
    int frameOffset = 2
)
[ConditionalAttribute("DEBUG")]
public static void Write(
    string text,
    string from = null,
    MessageType type = MessageType.Debug,
    int source = 0,
    string topic = null,
    string pars = null,
    Nullable<Guid> correlationContext = null,
    int frameOffset = 2
)
<ConditionalAttribute("DEBUG")>
Public Shared Sub Write (
    text As String,
    Optional from As String = Nothing,
    Optional type As MessageType = MessageType.Debug,
    Optional source As Integer = 0,
    Optional topic As String = Nothing,
    Optional pars As String = Nothing,
    Optional correlationContext As Nullable(Of Guid) = Nothing,
    Optional frameOffset As Integer = 2
)
<ConditionalAttribute("DEBUG")>
Public Shared Sub Write (
    text As String,
    Optional from As String = Nothing,
    Optional type As MessageType = MessageType.Debug,
    Optional source As Integer = 0,
    Optional topic As String = Nothing,
    Optional pars As String = Nothing,
    Optional correlationContext As Nullable(Of Guid) = Nothing,
    Optional frameOffset As Integer = 2
)
public:
[ConditionalAttribute(L"DEBUG")]
static void Write(
    String^ text,
    String^ from = nullptr,
    MessageType type = MessageType::Debug,
    int source = 0,
    String^ topic = nullptr,
    String^ pars = nullptr,
    Nullable<Guid> correlationContext = nullptr,
    int frameOffset = 2
)
public:
[ConditionalAttribute(L"DEBUG")]
static void Write(
    String^ text,
    String^ from = nullptr,
    MessageType type = MessageType::Debug,
    int source = 0,
    String^ topic = nullptr,
    String^ pars = nullptr,
    Nullable<Guid> correlationContext = nullptr,
    int frameOffset = 2
)
[<ConditionalAttribute("DEBUG")>]
static member Write :
        text : string *
        ?from : string *
        ?type : MessageType *
        ?source : int *
        ?topic : string *
        ?pars : string *
        ?correlationContext : Nullable<Guid> *
        ?frameOffset : int
(* Defaults:
        let _from = defaultArg from null
        let _type = defaultArg type MessageType.Debug
        let _source = defaultArg source 0
        let _topic = defaultArg topic null
        let _pars = defaultArg pars null
        let _correlationContext = defaultArg correlationContext null
        let _frameOffset = defaultArg frameOffset 2
*)
-> unit
[<ConditionalAttribute("DEBUG")>]
static member Write :
        text : string *
        ?from : string *
        ?type : MessageType *
        ?source : int *
        ?topic : string *
        ?pars : string *
        ?correlationContext : Nullable<Guid> *
        ?frameOffset : int
(* Defaults:
        let _from = defaultArg from null
        let _type = defaultArg type MessageType.Debug
        let _source = defaultArg source 0
        let _topic = defaultArg topic null
        let _pars = defaultArg pars null
        let _correlationContext = defaultArg correlationContext null
        let _frameOffset = defaultArg frameOffset 2
*)
-> unit

Parameters

text
Type: Online System String
from (Optional)
Type: Online System String
type (Optional)
Type: NFX.Log MessageType
source (Optional)
Type: Online System Int32
topic (Optional)
Type: Online System String
pars (Optional)
Type: Online System String
correlationContext (Optional)
Type: Online System Nullable Online Guid
frameOffset (Optional)
Type: Online System Int32
See Also
Debug Class
Debug Members
Write Overload
NFX Namespace


DebugAction Enumeration

DebugAction Enumeration NFX Class Library

Specifies how to handle Assertion and other failures

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[FlagsAttribute]
public enum DebugAction
[FlagsAttribute]
public enum DebugAction
<FlagsAttribute>
Public Enumeration DebugAction
<FlagsAttribute>
Public Enumeration DebugAction
[FlagsAttribute]
public enum class DebugAction
[FlagsAttribute]
public enum class DebugAction
[<FlagsAttribute>]
type DebugAction
[<FlagsAttribute>]
type DebugAction
Members
Member name | Value | Description
Default | 0 | Default to the value of Debugging.DefaultDebugAction
Throw | 1 | Throw exception
Log | 2 | Write message to log
ThrowAndLog | 3 | Shortcut for throwing exception and writing a message to log
See Also
NFX Namespace


DebugAssertionException Class

DebugAssertionException Class NFX Class Library

Thrown by Debug class to indicate assertion failures
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX DebugAssertionException

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class DebugAssertionException : NFXException
[SerializableAttribute]
public sealed class DebugAssertionException : NFXException
<SerializableAttribute>
Public NotInheritable Class DebugAssertionException
    Inherits NFXException
<SerializableAttribute>
Public NotInheritable Class DebugAssertionException
    Inherits NFXException
[SerializableAttribute]
public ref class DebugAssertionException sealed : public NFXException
[SerializableAttribute]
public ref class DebugAssertionException sealed : public NFXException
[<SealedAttribute>]
[<SerializableAttribute>]
type DebugAssertionException =
    class
        inherit NFXException
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type DebugAssertionException =
    class
        inherit NFXException
    end
See Also
DebugAssertionException Members
NFX Namespace


DebugAssertionException Members

DebugAssertionException Members NFX Class Library

The DebugAssertionException type exposes the following members.
Constructors
 | Name | Description
Public method | DebugAssertionException | Initializes a new instance of the DebugAssertionException class
Public method | DebugAssertionException(SerializationInfo, StreamingContext) | Initializes a new instance of the DebugAssertionException class
Public method | DebugAssertionException(String, String) | Initializes a new instance of the DebugAssertionException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | From |
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
DebugAssertionException Class
NFX Namespace


DebugAssertionException Constructor

DebugAssertionException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | DebugAssertionException | Initializes a new instance of the DebugAssertionException class
Public method | DebugAssertionException(SerializationInfo, StreamingContext) | Initializes a new instance of the DebugAssertionException class
Public method | DebugAssertionException(String, String) | Initializes a new instance of the DebugAssertionException class
Back to Top
See Also
DebugAssertionException Class
DebugAssertionException Members
NFX Namespace


DebugAssertionException Constructor

DebugAssertionException Constructor NFX Class Library

Initializes a new instance of the DebugAssertionException class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DebugAssertionException()
public DebugAssertionException()
Public Sub New
Public Sub New
public:
DebugAssertionException()
public:
DebugAssertionException()
new : unit -> DebugAssertionException
new : unit -> DebugAssertionException
See Also
DebugAssertionException Class
DebugAssertionException Members
DebugAssertionException Overload
NFX Namespace


DebugAssertionException Constructor (SerializationInfo, StreamingContext)

DebugAssertionException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DebugAssertionException class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DebugAssertionException(
    SerializationInfo info,
    StreamingContext context
)
public DebugAssertionException(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
DebugAssertionException(
    SerializationInfo^ info,
    StreamingContext context
)
public:
DebugAssertionException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DebugAssertionException
new :
        info : SerializationInfo *
        context : StreamingContext -> DebugAssertionException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
DebugAssertionException Class
DebugAssertionException Members
DebugAssertionException Overload
NFX Namespace


DebugAssertionException Constructor (String, String)

DebugAssertionException Constructor (String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DebugAssertionException class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DebugAssertionException(
    string message,
    string from = null
)
public DebugAssertionException(
    string message,
    string from = null
)
Public Sub New (
    message As String,
    Optional from As String = Nothing
)
Public Sub New (
    message As String,
    Optional from As String = Nothing
)
public:
DebugAssertionException(
    String^ message,
    String^ from = nullptr
)
public:
DebugAssertionException(
    String^ message,
    String^ from = nullptr
)
new :
        message : string *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> DebugAssertionException
new :
        message : string *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> DebugAssertionException

Parameters

message
Type: Online System String
from (Optional)
Type: Online System String
See Also
DebugAssertionException Class
DebugAssertionException Members
DebugAssertionException Overload
NFX Namespace


DebugAssertionException Methods

DebugAssertionException Methods NFX Class Library

The DebugAssertionException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
DebugAssertionException Class
NFX Namespace


DebugAssertionException Properties

DebugAssertionException Properties NFX Class Library

The DebugAssertionException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | From |
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
DebugAssertionException Class
NFX Namespace


DebugAssertionException.From Property

DebugAssertionException From Property NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string From { get; }
public string From { get; }
Public ReadOnly Property From As String
    Get
Public ReadOnly Property From As String
    Get
public:
property String^ From {
    String^ get ();
}
public:
property String^ From {
    String^ get ();
}
member From : string with get
member From : string with get

Property Value

Type: Online String
See Also
DebugAssertionException Class
DebugAssertionException Members
NFX Namespace


DebugAssertionException Events

DebugAssertionException Events NFX Class Library

The DebugAssertionException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
DebugAssertionException Class
NFX Namespace


Debugging Class

Debugging Class NFX Class Library

Facilitates debugging tasks that do not depend on any conditional defines
Inheritance Hierarchy
Online System Object
NFX Debugging

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class Debugging
public static class Debugging
Public NotInheritable Class Debugging
Public NotInheritable Class Debugging
public ref class Debugging abstract sealed
public ref class Debugging abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Debugging =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Debugging =  class end
See Also
Debugging Members
NFX Namespace


Debugging Members

Debugging Members NFX Class Library

The Debugging type exposes the following members.
Methods
Name | Description
Assert |
Fail |
ReadDefaultDebugActionFromConfig |
ReadTraceDisableFromConfig |
Write |
Back to Top
Fields
Name | Description
CONFIG_DEBUG_CONF_REFRESH_ATTR |
CONFIG_DEFAULT_DEBUG_ACTION_ATTR |
CONFIG_TRACE_DISABLE_ATTR |
Back to Top
Properties
Name | Description
DefaultDebugAction | Returns the global default setting, and optionally reads default debug action from global application's configuration if its value is DefaultFromConfig (default). Application can override this value at startup in order to avoid dynamic configuration lookups on every call
TraceDisabled | Controls wether to send Trace.Write() and Debug.Write() output to LogService
Back to Top
See Also
Debugging Class
NFX Namespace


Debugging Fields

Debugging Fields NFX Class Library

The Debugging type exposes the following members.
Fields
Name | Description
CONFIG_DEBUG_CONF_REFRESH_ATTR |
CONFIG_DEFAULT_DEBUG_ACTION_ATTR |
CONFIG_TRACE_DISABLE_ATTR |
Back to Top
See Also
Debugging Class
NFX Namespace


Debugging.CONFIG_DEBUG_CONF_REFRESH_ATTR Field

Debugging CONFIG_DEBUG_CONF_REFRESH_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_DEBUG_CONF_REFRESH_ATTR
public const string CONFIG_DEBUG_CONF_REFRESH_ATTR
Public Const CONFIG_DEBUG_CONF_REFRESH_ATTR As String
Public Const CONFIG_DEBUG_CONF_REFRESH_ATTR As String
public:
literal String^ CONFIG_DEBUG_CONF_REFRESH_ATTR
public:
literal String^ CONFIG_DEBUG_CONF_REFRESH_ATTR
static val mutable CONFIG_DEBUG_CONF_REFRESH_ATTR: string
static val mutable CONFIG_DEBUG_CONF_REFRESH_ATTR: string

Field Value

Type: Online String
See Also
Debugging Class
Debugging Members
NFX Namespace


Debugging.CONFIG_DEFAULT_DEBUG_ACTION_ATTR Field

Debugging CONFIG_DEFAULT_DEBUG_ACTION_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_DEFAULT_DEBUG_ACTION_ATTR
public const string CONFIG_DEFAULT_DEBUG_ACTION_ATTR
Public Const CONFIG_DEFAULT_DEBUG_ACTION_ATTR As String
Public Const CONFIG_DEFAULT_DEBUG_ACTION_ATTR As String
public:
literal String^ CONFIG_DEFAULT_DEBUG_ACTION_ATTR
public:
literal String^ CONFIG_DEFAULT_DEBUG_ACTION_ATTR
static val mutable CONFIG_DEFAULT_DEBUG_ACTION_ATTR: string
static val mutable CONFIG_DEFAULT_DEBUG_ACTION_ATTR: string

Field Value

Type: Online String
See Also
Debugging Class
Debugging Members
NFX Namespace


Debugging.CONFIG_TRACE_DISABLE_ATTR Field

Debugging CONFIG_TRACE_DISABLE_ATTR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_TRACE_DISABLE_ATTR
public const string CONFIG_TRACE_DISABLE_ATTR
Public Const CONFIG_TRACE_DISABLE_ATTR As String
Public Const CONFIG_TRACE_DISABLE_ATTR As String
public:
literal String^ CONFIG_TRACE_DISABLE_ATTR
public:
literal String^ CONFIG_TRACE_DISABLE_ATTR
static val mutable CONFIG_TRACE_DISABLE_ATTR: string
static val mutable CONFIG_TRACE_DISABLE_ATTR: string

Field Value

Type: Online String
See Also
Debugging Class
Debugging Members
NFX Namespace


Debugging Methods

Debugging Methods NFX Class Library

The Debugging type exposes the following members.
Methods
Name | Description
Assert |
Fail |
ReadDefaultDebugActionFromConfig |
ReadTraceDisableFromConfig |
Write |
Back to Top
See Also
Debugging Class
NFX Namespace


Debugging.Assert Method

Debugging Assert Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Assert(
    bool condition,
    string text = null,
    DebugAction action = DebugAction.Default,
    string from = null,
    MessageType type = MessageType.Debug,
    int source = 0,
    string topic = null,
    string pars = null,
    Nullable<Guid> correlationContext = null,
    int frameOffset = 1
)
public static void Assert(
    bool condition,
    string text = null,
    DebugAction action = DebugAction.Default,
    string from = null,
    MessageType type = MessageType.Debug,
    int source = 0,
    string topic = null,
    string pars = null,
    Nullable<Guid> correlationContext = null,
    int frameOffset = 1
)
Public Shared Sub Assert (
    condition As Boolean,
    Optional text As String = Nothing,
    Optional action As DebugAction = DebugAction.Default,
    Optional from As String = Nothing,
    Optional type As MessageType = MessageType.Debug,
    Optional source As Integer = 0,
    Optional topic As String = Nothing,
    Optional pars As String = Nothing,
    Optional correlationContext As Nullable(Of Guid) = Nothing,
    Optional frameOffset As Integer = 1
)
Public Shared Sub Assert (
    condition As Boolean,
    Optional text As String = Nothing,
    Optional action As DebugAction = DebugAction.Default,
    Optional from As String = Nothing,
    Optional type As MessageType = MessageType.Debug,
    Optional source As Integer = 0,
    Optional topic As String = Nothing,
    Optional pars As String = Nothing,
    Optional correlationContext As Nullable(Of Guid) = Nothing,
    Optional frameOffset As Integer = 1
)
public:
static void Assert(
    bool condition,
    String^ text = nullptr,
    DebugAction action = DebugAction::Default,
    String^ from = nullptr,
    MessageType type = MessageType::Debug,
    int source = 0,
    String^ topic = nullptr,
    String^ pars = nullptr,
    Nullable<Guid> correlationContext = nullptr,
    int frameOffset = 1
)
public:
static void Assert(
    bool condition,
    String^ text = nullptr,
    DebugAction action = DebugAction::Default,
    String^ from = nullptr,
    MessageType type = MessageType::Debug,
    int source = 0,
    String^ topic = nullptr,
    String^ pars = nullptr,
    Nullable<Guid> correlationContext = nullptr,
    int frameOffset = 1
)
static member Assert :
        condition : bool *
        ?text : string *
        ?action : DebugAction *
        ?from : string *
        ?type : MessageType *
        ?source : int *
        ?topic : string *
        ?pars : string *
        ?correlationContext : Nullable<Guid> *
        ?frameOffset : int
(* Defaults:
        let _text = defaultArg text null
        let _action = defaultArg action DebugAction.Default
        let _from = defaultArg from null
        let _type = defaultArg type MessageType.Debug
        let _source = defaultArg source 0
        let _topic = defaultArg topic null
        let _pars = defaultArg pars null
        let _correlationContext = defaultArg correlationContext null
        let _frameOffset = defaultArg frameOffset 1
*)
-> unit
static member Assert :
        condition : bool *
        ?text : string *
        ?action : DebugAction *
        ?from : string *
        ?type : MessageType *
        ?source : int *
        ?topic : string *
        ?pars : string *
        ?correlationContext : Nullable<Guid> *
        ?frameOffset : int
(* Defaults:
        let _text = defaultArg text null
        let _action = defaultArg action DebugAction.Default
        let _from = defaultArg from null
        let _type = defaultArg type MessageType.Debug
        let _source = defaultArg source 0
        let _topic = defaultArg topic null
        let _pars = defaultArg pars null
        let _correlationContext = defaultArg correlationContext null
        let _frameOffset = defaultArg frameOffset 1
*)
-> unit

Parameters

condition
Type: Online System Boolean
text (Optional)
Type: Online System String
action (Optional)
Type: NFX DebugAction
from (Optional)
Type: Online System String
type (Optional)
Type: NFX.Log MessageType
source (Optional)
Type: Online System Int32
topic (Optional)
Type: Online System String
pars (Optional)
Type: Online System String
correlationContext (Optional)
Type: Online System Nullable Online Guid
frameOffset (Optional)
Type: Online System Int32
See Also
Debugging Class
Debugging Members
NFX Namespace


Debugging.Fail Method

Debugging Fail Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Fail(
    string text = null,
    DebugAction action = DebugAction.Default,
    string from = null,
    MessageType type = MessageType.Debug,
    int source = 0,
    string topic = null,
    string pars = null,
    Nullable<Guid> correlationContext = null,
    int frameOffset = 1
)
public static void Fail(
    string text = null,
    DebugAction action = DebugAction.Default,
    string from = null,
    MessageType type = MessageType.Debug,
    int source = 0,
    string topic = null,
    string pars = null,
    Nullable<Guid> correlationContext = null,
    int frameOffset = 1
)
Public Shared Sub Fail (
    Optional text As String = Nothing,
    Optional action As DebugAction = DebugAction.Default,
    Optional from As String = Nothing,
    Optional type As MessageType = MessageType.Debug,
    Optional source As Integer = 0,
    Optional topic As String = Nothing,
    Optional pars As String = Nothing,
    Optional correlationContext As Nullable(Of Guid) = Nothing,
    Optional frameOffset As Integer = 1
)
Public Shared Sub Fail (
    Optional text As String = Nothing,
    Optional action As DebugAction = DebugAction.Default,
    Optional from As String = Nothing,
    Optional type As MessageType = MessageType.Debug,
    Optional source As Integer = 0,
    Optional topic As String = Nothing,
    Optional pars As String = Nothing,
    Optional correlationContext As Nullable(Of Guid) = Nothing,
    Optional frameOffset As Integer = 1
)
public:
static void Fail(
    String^ text = nullptr,
    DebugAction action = DebugAction::Default,
    String^ from = nullptr,
    MessageType type = MessageType::Debug,
    int source = 0,
    String^ topic = nullptr,
    String^ pars = nullptr,
    Nullable<Guid> correlationContext = nullptr,
    int frameOffset = 1
)
public:
static void Fail(
    String^ text = nullptr,
    DebugAction action = DebugAction::Default,
    String^ from = nullptr,
    MessageType type = MessageType::Debug,
    int source = 0,
    String^ topic = nullptr,
    String^ pars = nullptr,
    Nullable<Guid> correlationContext = nullptr,
    int frameOffset = 1
)
static member Fail :
        ?text : string *
        ?action : DebugAction *
        ?from : string *
        ?type : MessageType *
        ?source : int *
        ?topic : string *
        ?pars : string *
        ?correlationContext : Nullable<Guid> *
        ?frameOffset : int
(* Defaults:
        let _text = defaultArg text null
        let _action = defaultArg action DebugAction.Default
        let _from = defaultArg from null
        let _type = defaultArg type MessageType.Debug
        let _source = defaultArg source 0
        let _topic = defaultArg topic null
        let _pars = defaultArg pars null
        let _correlationContext = defaultArg correlationContext null
        let _frameOffset = defaultArg frameOffset 1
*)
-> unit
static member Fail :
        ?text : string *
        ?action : DebugAction *
        ?from : string *
        ?type : MessageType *
        ?source : int *
        ?topic : string *
        ?pars : string *
        ?correlationContext : Nullable<Guid> *
        ?frameOffset : int
(* Defaults:
        let _text = defaultArg text null
        let _action = defaultArg action DebugAction.Default
        let _from = defaultArg from null
        let _type = defaultArg type MessageType.Debug
        let _source = defaultArg source 0
        let _topic = defaultArg topic null
        let _pars = defaultArg pars null
        let _correlationContext = defaultArg correlationContext null
        let _frameOffset = defaultArg frameOffset 1
*)
-> unit

Parameters

text (Optional)
Type: Online System String
action (Optional)
Type: NFX DebugAction
from (Optional)
Type: Online System String
type (Optional)
Type: NFX.Log MessageType
source (Optional)
Type: Online System Int32
topic (Optional)
Type: Online System String
pars (Optional)
Type: Online System String
correlationContext (Optional)
Type: Online System Nullable Online Guid
frameOffset (Optional)
Type: Online System Int32
See Also
Debugging Class
Debugging Members
NFX Namespace


Debugging.ReadDefaultDebugActionFromConfig Method

Debugging ReadDefaultDebugActionFromConfig Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static DebugAction ReadDefaultDebugActionFromConfig()
internal static DebugAction ReadDefaultDebugActionFromConfig()
Friend Shared Function ReadDefaultDebugActionFromConfig As DebugAction
Friend Shared Function ReadDefaultDebugActionFromConfig As DebugAction
internal:
static DebugAction ReadDefaultDebugActionFromConfig()
internal:
static DebugAction ReadDefaultDebugActionFromConfig()
internal static member ReadDefaultDebugActionFromConfig : unit -> DebugAction
internal static member ReadDefaultDebugActionFromConfig : unit -> DebugAction

Return Value

Type: DebugAction
See Also
Debugging Class
Debugging Members
NFX Namespace


Debugging.ReadTraceDisableFromConfig Method

Debugging ReadTraceDisableFromConfig Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static bool ReadTraceDisableFromConfig()
internal static bool ReadTraceDisableFromConfig()
Friend Shared Function ReadTraceDisableFromConfig As Boolean
Friend Shared Function ReadTraceDisableFromConfig As Boolean
internal:
static bool ReadTraceDisableFromConfig()
internal:
static bool ReadTraceDisableFromConfig()
internal static member ReadTraceDisableFromConfig : unit -> bool
internal static member ReadTraceDisableFromConfig : unit -> bool

Return Value

Type: Online Boolean
See Also
Debugging Class
Debugging Members
NFX Namespace


Debugging.Write Method

Debugging Write Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    string text,
    string from = null,
    MessageType type = MessageType.Debug,
    int source = 0,
    string topic = null,
    string pars = null,
    Nullable<Guid> correlationContext = null,
    int frameOffset = 1
)
public static void Write(
    string text,
    string from = null,
    MessageType type = MessageType.Debug,
    int source = 0,
    string topic = null,
    string pars = null,
    Nullable<Guid> correlationContext = null,
    int frameOffset = 1
)
Public Shared Sub Write (
    text As String,
    Optional from As String = Nothing,
    Optional type As MessageType = MessageType.Debug,
    Optional source As Integer = 0,
    Optional topic As String = Nothing,
    Optional pars As String = Nothing,
    Optional correlationContext As Nullable(Of Guid) = Nothing,
    Optional frameOffset As Integer = 1
)
Public Shared Sub Write (
    text As String,
    Optional from As String = Nothing,
    Optional type As MessageType = MessageType.Debug,
    Optional source As Integer = 0,
    Optional topic As String = Nothing,
    Optional pars As String = Nothing,
    Optional correlationContext As Nullable(Of Guid) = Nothing,
    Optional frameOffset As Integer = 1
)
public:
static void Write(
    String^ text,
    String^ from = nullptr,
    MessageType type = MessageType::Debug,
    int source = 0,
    String^ topic = nullptr,
    String^ pars = nullptr,
    Nullable<Guid> correlationContext = nullptr,
    int frameOffset = 1
)
public:
static void Write(
    String^ text,
    String^ from = nullptr,
    MessageType type = MessageType::Debug,
    int source = 0,
    String^ topic = nullptr,
    String^ pars = nullptr,
    Nullable<Guid> correlationContext = nullptr,
    int frameOffset = 1
)
static member Write :
        text : string *
        ?from : string *
        ?type : MessageType *
        ?source : int *
        ?topic : string *
        ?pars : string *
        ?correlationContext : Nullable<Guid> *
        ?frameOffset : int
(* Defaults:
        let _from = defaultArg from null
        let _type = defaultArg type MessageType.Debug
        let _source = defaultArg source 0
        let _topic = defaultArg topic null
        let _pars = defaultArg pars null
        let _correlationContext = defaultArg correlationContext null
        let _frameOffset = defaultArg frameOffset 1
*)
-> unit
static member Write :
        text : string *
        ?from : string *
        ?type : MessageType *
        ?source : int *
        ?topic : string *
        ?pars : string *
        ?correlationContext : Nullable<Guid> *
        ?frameOffset : int
(* Defaults:
        let _from = defaultArg from null
        let _type = defaultArg type MessageType.Debug
        let _source = defaultArg source 0
        let _topic = defaultArg topic null
        let _pars = defaultArg pars null
        let _correlationContext = defaultArg correlationContext null
        let _frameOffset = defaultArg frameOffset 1
*)
-> unit

Parameters

text
Type: Online System String
from (Optional)
Type: Online System String
type (Optional)
Type: NFX.Log MessageType
source (Optional)
Type: Online System Int32
topic (Optional)
Type: Online System String
pars (Optional)
Type: Online System String
correlationContext (Optional)
Type: Online System Nullable Online Guid
frameOffset (Optional)
Type: Online System Int32
See Also
Debugging Class
Debugging Members
NFX Namespace


Debugging Properties

Debugging Properties NFX Class Library

The Debugging type exposes the following members.
Properties
Name | Description
DefaultDebugAction | Returns the global default setting, and optionally reads default debug action from global application's configuration if its value is DefaultFromConfig (default). Application can override this value at startup in order to avoid dynamic configuration lookups on every call
TraceDisabled | Controls wether to send Trace.Write() and Debug.Write() output to LogService
Back to Top
See Also
Debugging Class
NFX Namespace


Debugging.DefaultDebugAction Property

Debugging DefaultDebugAction Property NFX Class Library

Returns the global default setting, and optionally reads default debug action from global application's configuration if its value is DefaultFromConfig (default). Application can override this value at startup in order to avoid dynamic configuration lookups on every call

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DebugAction DefaultDebugAction { get; set; }
public static DebugAction DefaultDebugAction { get; set; }
Public Shared Property DefaultDebugAction As DebugAction
    Get
    Set
Public Shared Property DefaultDebugAction As DebugAction
    Get
    Set
public:
static property DebugAction DefaultDebugAction {
    DebugAction get ();
    void set (DebugAction value);
}
public:
static property DebugAction DefaultDebugAction {
    DebugAction get ();
    void set (DebugAction value);
}
static member DefaultDebugAction : DebugAction with get, set
static member DefaultDebugAction : DebugAction with get, set

Property Value

Type: DebugAction
See Also
Debugging Class
Debugging Members
NFX Namespace


Debugging.TraceDisabled Property

Debugging TraceDisabled Property NFX Class Library

Controls wether to send Trace.Write() and Debug.Write() output to LogService

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool TraceDisabled { get; set; }
public static bool TraceDisabled { get; set; }
Public Shared Property TraceDisabled As Boolean
    Get
    Set
Public Shared Property TraceDisabled As Boolean
    Get
    Set
public:
static property bool TraceDisabled {
    bool get ();
    void set (bool value);
}
public:
static property bool TraceDisabled {
    bool get ();
    void set (bool value);
}
static member TraceDisabled : bool with get, set
static member TraceDisabled : bool with get, set

Property Value

Type: Online Boolean
See Also
Debugging Class
Debugging Members
NFX Namespace


DisposableObject Class

DisposableObject Class NFX Class Library

General-purpose base class for objects that need to be disposed
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ApplicationModel CommonApplicationLogic
NFX.ApplicationModel TestApplication
NFX.DataAccess.Cache Bucketed
NFX.DataAccess.CRUD CRUDOperationCallContext
NFX.DataAccess.CRUD CRUDTransaction
NFX.DataAccess.CRUD Cursor
NFX.DataAccess.Distributed Parcel
NFX.DataAccess.MongoDB.Connector Collection
NFX.DataAccess.MongoDB.Connector Cursor
NFX.DataAccess.MongoDB.Connector Database
NFX.Erlang ErlAbstractConnection
NFX.Erlang ErlMbox
NFX.Erlang.Internal ErlAcceptor
NFX.Erlang.Internal ErlBlockingQueue T
NFX.Erlang.Internal ErlIoServer
NFX.Erlang.Internal ErlRpcServer
NFX.Financial.Market.SecDb SecDBFileReader
NFX.Glue EndPoint
NFX.Glue.Native MpxListener
NFX.Glue.Native MpxSocket TTransport
NFX.IO.FileSystem FileSystemSession
NFX.IO.FileSystem FileSystemSessionItem
NFX.IO.FileSystem.Packaging LocalInstallation
NFX.Log.Syslog SyslogClient
NFX.Media.Graphics DrawingOutput
NFX Scope
NFX.Security SecureBuffer
NFX.Serialization.Arow CodeGenerator
NFX.Templatization TemplateCompiler
NFX.Wave.MVC Controller
NFX.Wave Response
NFX.Wave WorkContext
NFX.Web.Pay PaySession
NFX.Web.Shipping ShippingSession
NFX.WinForms.Controls.ChartKit.Temporal TimeSeries
NFX.WinForms.Controls.GridKit Column
NFX.WinForms.Elements Element

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class DisposableObject : IDisposable
[SerializableAttribute]
public abstract class DisposableObject : IDisposable
<SerializableAttribute>
Public MustInherit Class DisposableObject
    Implements IDisposable
<SerializableAttribute>
Public MustInherit Class DisposableObject
    Implements IDisposable
[SerializableAttribute]
public ref class DisposableObject abstract : IDisposable
[SerializableAttribute]
public ref class DisposableObject abstract : IDisposable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type DisposableObject =
    class
        interface IDisposable
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type DisposableObject =
    class
        interface IDisposable
    end
See Also
DisposableObject Members
NFX Namespace


DisposableObject Members

DisposableObject Members NFX Class Library

The DisposableObject type exposes the following members.
Constructors
 | Name | Description
Protected method | DisposableObject | Initializes a new instance of the DisposableObject class
Back to Top
Methods
 | Name | Description
Protected method | Destructor | Override this method to do actual destructor work
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead
 | DisposeAndNull T | Checks to see if the IDisposable reference is not null and sets it to null in a thread-safe way then calls Dispose(). Returns false if it is already null or not the original reference
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Overrides Online Object Finalize .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet
Back to Top
See Also
DisposableObject Class
NFX Namespace


DisposableObject Constructor

DisposableObject Constructor NFX Class Library

Initializes a new instance of the DisposableObject class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected DisposableObject()
protected DisposableObject()
Protected Sub New
Protected Sub New
protected:
DisposableObject()
protected:
DisposableObject()
new : unit -> DisposableObject
new : unit -> DisposableObject
See Also
DisposableObject Class
DisposableObject Members
NFX Namespace


DisposableObject Methods

DisposableObject Methods NFX Class Library

The DisposableObject type exposes the following members.
Methods
 | Name | Description
Protected method | Destructor | Override this method to do actual destructor work
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead
 | DisposeAndNull T | Checks to see if the IDisposable reference is not null and sets it to null in a thread-safe way then calls Dispose(). Returns false if it is already null or not the original reference
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Overrides Online Object Finalize .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
DisposableObject Class
NFX Namespace


DisposableObject.Destructor Method

DisposableObject Destructor Method NFX Class Library

Override this method to do actual destructor work

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void Destructor()
protected virtual void Destructor()
Protected Overridable Sub Destructor
Protected Overridable Sub Destructor
protected:
virtual void Destructor()
protected:
virtual void Destructor()
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
DisposableObject Class
DisposableObject Members
NFX Namespace


DisposableObject.Dispose Method

DisposableObject Dispose Method NFX Class Library

Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

Online IDisposable Dispose
See Also
DisposableObject Class
DisposableObject Members
NFX Namespace


DisposableObject.DisposeAndNull(T) Method

DisposableObject DisposeAndNull T Method NFX Class Library

Checks to see if the IDisposable reference is not null and sets it to null in a thread-safe way then calls Dispose(). Returns false if it is already null or not the original reference

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool DisposeAndNull<T>(
    ref T obj
)
where T : class, IDisposable
public static bool DisposeAndNull<T>(
    ref T obj
)
where T : class, IDisposable
Public Shared Function DisposeAndNull(Of T As {Class, IDisposable}) (
    ByRef obj As T
) As Boolean
Public Shared Function DisposeAndNull(Of T As {Class, IDisposable}) (
    ByRef obj As T
) As Boolean
public:
generic<typename T>
where T : ref class, IDisposable
static bool DisposeAndNull(
    T% obj
)
public:
generic<typename T>
where T : ref class, IDisposable
static bool DisposeAndNull(
    T% obj
)
static member DisposeAndNull :
        obj : 'T byref -> bool  when 'T : not struct and IDisposable
static member DisposeAndNull :
        obj : 'T byref -> bool  when 'T : not struct and IDisposable

Parameters

obj
Type: T
Type Parameters
T

Return Value

Type: Online Boolean
See Also
DisposableObject Class
DisposableObject Members
NFX Namespace


DisposableObject.EnsureObjectNotDisposed Method

DisposableObject EnsureObjectNotDisposed Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void EnsureObjectNotDisposed()
public void EnsureObjectNotDisposed()
Public Sub EnsureObjectNotDisposed
Public Sub EnsureObjectNotDisposed
public:
void EnsureObjectNotDisposed()
public:
void EnsureObjectNotDisposed()
member EnsureObjectNotDisposed : unit -> unit
member EnsureObjectNotDisposed : unit -> unit
See Also
DisposableObject Class
DisposableObject Members
NFX Namespace


DisposableObject.Finalize Method

DisposableObject Finalize Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Finalize()
protected override void Finalize()
Protected Overrides Sub Finalize
Protected Overrides Sub Finalize
protected:
virtual void Finalize() override
protected:
virtual void Finalize() override
abstract Finalize : unit -> unit
override Finalize : unit -> unit
abstract Finalize : unit -> unit
override Finalize : unit -> unit
See Also
DisposableObject Class
DisposableObject Members
NFX Namespace


DisposableObject Properties

DisposableObject Properties NFX Class Library

The DisposableObject type exposes the following members.
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet
Back to Top
See Also
DisposableObject Class
NFX Namespace


DisposableObject.Disposed Property

DisposableObject Disposed Property NFX Class Library

Indicates whether this object was already disposed - the Dispose() has finished

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Disposed { get; }
public bool Disposed { get; }
Public ReadOnly Property Disposed As Boolean
    Get
Public ReadOnly Property Disposed As Boolean
    Get
public:
property bool Disposed {
    bool get ();
}
public:
property bool Disposed {
    bool get ();
}
member Disposed : bool with get
member Disposed : bool with get

Property Value

Type: Online Boolean
See Also
DisposableObject Class
DisposableObject Members
NFX Namespace


DisposableObject.DisposeStarted Property

DisposableObject DisposeStarted Property NFX Class Library

Indicates whether this object Dispose() has been called and dispose started but not finished yet

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool DisposeStarted { get; }
public bool DisposeStarted { get; }
Public ReadOnly Property DisposeStarted As Boolean
    Get
Public ReadOnly Property DisposeStarted As Boolean
    Get
public:
property bool DisposeStarted {
    bool get ();
}
public:
property bool DisposeStarted {
    bool get ();
}
member DisposeStarted : bool with get
member DisposeStarted : bool with get

Property Value

Type: Online Boolean
See Also
DisposableObject Class
DisposableObject Members
NFX Namespace


DisposedObjectException Class

DisposedObjectException Class NFX Class Library

This exception is thrown from DisposableObject.EnsureObjectNotDisposed() method
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX DisposedObjectException

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class DisposedObjectException : NFXException
[SerializableAttribute]
public class DisposedObjectException : NFXException
<SerializableAttribute>
Public Class DisposedObjectException
    Inherits NFXException
<SerializableAttribute>
Public Class DisposedObjectException
    Inherits NFXException
[SerializableAttribute]
public ref class DisposedObjectException : public NFXException
[SerializableAttribute]
public ref class DisposedObjectException : public NFXException
[<SerializableAttribute>]
type DisposedObjectException =
    class
        inherit NFXException
    end
[<SerializableAttribute>]
type DisposedObjectException =
    class
        inherit NFXException
    end
See Also
DisposedObjectException Members
NFX Namespace


DisposedObjectException Members

DisposedObjectException Members NFX Class Library

The DisposedObjectException type exposes the following members.
Constructors
 | Name | Description
Public method | DisposedObjectException | Initializes a new instance of the DisposedObjectException class
Public method | DisposedObjectException(String) | Initializes a new instance of the DisposedObjectException class
Protected method | DisposedObjectException(SerializationInfo, StreamingContext) | Initializes a new instance of the DisposedObjectException class
Public method | DisposedObjectException(String, Exception) | Initializes a new instance of the DisposedObjectException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
DisposedObjectException Class
NFX Namespace


DisposedObjectException Constructor

DisposedObjectException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | DisposedObjectException | Initializes a new instance of the DisposedObjectException class
Public method | DisposedObjectException(String) | Initializes a new instance of the DisposedObjectException class
Protected method | DisposedObjectException(SerializationInfo, StreamingContext) | Initializes a new instance of the DisposedObjectException class
Public method | DisposedObjectException(String, Exception) | Initializes a new instance of the DisposedObjectException class
Back to Top
See Also
DisposedObjectException Class
DisposedObjectException Members
NFX Namespace


DisposedObjectException Constructor

DisposedObjectException Constructor NFX Class Library

Initializes a new instance of the DisposedObjectException class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DisposedObjectException()
public DisposedObjectException()
Public Sub New
Public Sub New
public:
DisposedObjectException()
public:
DisposedObjectException()
new : unit -> DisposedObjectException
new : unit -> DisposedObjectException
See Also
DisposedObjectException Class
DisposedObjectException Members
DisposedObjectException Overload
NFX Namespace


DisposedObjectException Constructor (String)

DisposedObjectException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DisposedObjectException class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DisposedObjectException(
    string message
)
public DisposedObjectException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
DisposedObjectException(
    String^ message
)
public:
DisposedObjectException(
    String^ message
)
new :
        message : string -> DisposedObjectException
new :
        message : string -> DisposedObjectException

Parameters

message
Type: Online System String
See Also
DisposedObjectException Class
DisposedObjectException Members
DisposedObjectException Overload
NFX Namespace


DisposedObjectException Constructor (SerializationInfo, StreamingContext)

DisposedObjectException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DisposedObjectException class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected DisposedObjectException(
    SerializationInfo info,
    StreamingContext context
)
protected DisposedObjectException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
DisposedObjectException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
DisposedObjectException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DisposedObjectException
new :
        info : SerializationInfo *
        context : StreamingContext -> DisposedObjectException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
DisposedObjectException Class
DisposedObjectException Members
DisposedObjectException Overload
NFX Namespace


DisposedObjectException Constructor (String, Exception)

DisposedObjectException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DisposedObjectException class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DisposedObjectException(
    string message,
    Exception inner
)
public DisposedObjectException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
DisposedObjectException(
    String^ message,
    Exception^ inner
)
public:
DisposedObjectException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> DisposedObjectException
new :
        message : string *
        inner : Exception -> DisposedObjectException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
DisposedObjectException Class
DisposedObjectException Members
DisposedObjectException Overload
NFX Namespace


DisposedObjectException Methods

DisposedObjectException Methods NFX Class Library

The DisposedObjectException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
DisposedObjectException Class
NFX Namespace


DisposedObjectException Properties

DisposedObjectException Properties NFX Class Library

The DisposedObjectException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
DisposedObjectException Class
NFX Namespace


DisposedObjectException Events

DisposedObjectException Events NFX Class Library

The DisposedObjectException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
DisposedObjectException Class
NFX Namespace


DumpFormat Enumeration

DumpFormat Enumeration NFX Class Library

Format of the String Dump

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum DumpFormat
public enum DumpFormat
Public Enumeration DumpFormat
Public Enumeration DumpFormat
public enum class DumpFormat
public enum class DumpFormat
type DumpFormat
type DumpFormat
Members
Member name | Value | Description
Binary | 0 | Perform no conversion - data copied as is
Decimal | 1 | Decimal string representation. E.g. "<<39, 16, 25, ...>>"
Hex | 2 | Hex string representation. E.g. "A1 B9 16 ..."
Printable | 3 | Human readable string representation. E.g. "...Test 123\n..."
See Also
NFX Namespace


ELink Class

ELink Class NFX Class Library

Represents an Electronic Link which is an alpha-encoded identifier along with metadata information. Warning! This class MAY generate fragments of profanity, however any ID can be regenerated using a different seed passed to Encode(seed)
Inheritance Hierarchy
Online System Object
NFX ELink

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ELink
public sealed class ELink
Public NotInheritable Class ELink
Public NotInheritable Class ELink
public ref class ELink sealed
public ref class ELink sealed
[<SealedAttribute>]
type ELink =  class end
[<SealedAttribute>]
type ELink =  class end
See Also
ELink Members
NFX Namespace


ELink Members

ELink Members NFX Class Library

The ELink type exposes the following members.
Constructors
 | Name | Description
Public method | ELink(String) | Initializes a new instance of the ELink class
Public method | ELink(UInt64, Byte ) | Creates an Elink instance initialized with GDID of 0 Era having its ID set to ulong value
Public method | ELink(GDID, Byte ) | Create ELink instance from GDID (with era).
Back to Top
Methods
 | Name | Description
Public method | Encode | Encodes a link into a textual form, using the supplied randomization seed, otherwise the system rnd is used. A seed has 4 effective bits, yielding 16 possible variations for every link
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
ALPHABET |
MAX_LINK_CHAR_SIZE |
RALPHABET |
VARIATIONS | Represents how many variations every link has (seeds)
Back to Top
Properties
 | Name | Description
Public property | AsGDIDSymbol |
Public property | GDID | Returns the GDID that this link represents
Public property | ID | Returns the ID portion of GDID represented by this instance
Public property | Link | Returns a link encoded as a string using whatever randomization seed was passed to the last Encode(seed) call. If Encode() was not called, then the link will get encoded using system rnd for a seed value
Public property | Metadata | Returns metadata attached to this instance, or null if there is no metadata specified
Back to Top
See Also
ELink Class
NFX Namespace


ELink Constructor

ELink Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ELink(String) | Initializes a new instance of the ELink class
Public method | ELink(UInt64, Byte ) | Creates an Elink instance initialized with GDID of 0 Era having its ID set to ulong value
Public method | ELink(GDID, Byte ) | Create ELink instance from GDID (with era).
Back to Top
See Also
ELink Class
ELink Members
NFX Namespace


ELink Constructor (String)

ELink Constructor (String) NFX Class Library

Initializes a new instance of the ELink class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ELink(
    string link
)
public ELink(
    string link
)
Public Sub New (
    link As String
)
Public Sub New (
    link As String
)
public:
ELink(
    String^ link
)
public:
ELink(
    String^ link
)
new :
        link : string -> ELink
new :
        link : string -> ELink

Parameters

link
Type: Online System String
See Also
ELink Class
ELink Members
ELink Overload
NFX Namespace


ELink Constructor (UInt64, Byte[])

ELink Constructor (UInt64, Byte ) NFX Class Library

Creates an Elink instance initialized with GDID of 0 Era having its ID set to ulong value

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ELink(
    ulong id,
    byte[] metadata
)
public ELink(
    ulong id,
    byte[] metadata
)
Public Sub New (
    id As ULong,
    metadata As Byte()
)
Public Sub New (
    id As ULong,
    metadata As Byte()
)
public:
ELink(
    unsigned long long id,
    array<unsigned char>^ metadata
)
public:
ELink(
    unsigned long long id,
    array<unsigned char>^ metadata
)
new :
        id : uint64 *
        metadata : byte[] -> ELink
new :
        id : uint64 *
        metadata : byte[] -> ELink

Parameters

id
Type: Online System UInt64
metadata
Type: Online System Byte
See Also
ELink Class
ELink Members
ELink Overload
NFX Namespace


ELink Constructor (GDID, Byte[])

ELink Constructor (GDID, Byte ) NFX Class Library

Create ELink instance from GDID (with era).

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ELink(
    GDID gdid,
    byte[] metadata = null
)
public ELink(
    GDID gdid,
    byte[] metadata = null
)
Public Sub New (
    gdid As GDID,
    Optional metadata As Byte() = Nothing
)
Public Sub New (
    gdid As GDID,
    Optional metadata As Byte() = Nothing
)
public:
ELink(
    GDID gdid,
    array<unsigned char>^ metadata = nullptr
)
public:
ELink(
    GDID gdid,
    array<unsigned char>^ metadata = nullptr
)
new :
        gdid : GDID *
        ?metadata : byte[]
(* Defaults:
        let _metadata = defaultArg metadata null
*)
-> ELink
new :
        gdid : GDID *
        ?metadata : byte[]
(* Defaults:
        let _metadata = defaultArg metadata null
*)
-> ELink

Parameters

gdid
Type: NFX.DataAccess.Distributed GDID
metadata (Optional)
Type: Online System Byte
See Also
ELink Class
ELink Members
ELink Overload
NFX Namespace


ELink Fields

ELink Fields NFX Class Library

The ELink type exposes the following members.
Fields
Name | Description
ALPHABET |
MAX_LINK_CHAR_SIZE |
RALPHABET |
VARIATIONS | Represents how many variations every link has (seeds)
Back to Top
See Also
ELink Class
NFX Namespace


ELink.ALPHABET Field

ELink ALPHABET Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string[] ALPHABET
public static readonly string[] ALPHABET
Public Shared ReadOnly ALPHABET As String()
Public Shared ReadOnly ALPHABET As String()
public:
static initonly array<String^>^ ALPHABET
public:
static initonly array<String^>^ ALPHABET
static val ALPHABET: string[]
static val ALPHABET: string[]

Field Value

Type: Online String
See Also
ELink Class
ELink Members
NFX Namespace


ELink.MAX_LINK_CHAR_SIZE Field

ELink MAX_LINK_CHAR_SIZE Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_LINK_CHAR_SIZE
public const int MAX_LINK_CHAR_SIZE
Public Const MAX_LINK_CHAR_SIZE As Integer
Public Const MAX_LINK_CHAR_SIZE As Integer
public:
literal int MAX_LINK_CHAR_SIZE
public:
literal int MAX_LINK_CHAR_SIZE
static val mutable MAX_LINK_CHAR_SIZE: int
static val mutable MAX_LINK_CHAR_SIZE: int

Field Value

Type: Online Int32
See Also
ELink Class
ELink Members
NFX Namespace


ELink.RALPHABET Field

ELink RALPHABET Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Dictionary<string, int> RALPHABET
public static readonly Dictionary<string, int> RALPHABET
Public Shared ReadOnly RALPHABET As Dictionary(Of String, Integer)
Public Shared ReadOnly RALPHABET As Dictionary(Of String, Integer)
public:
static initonly Dictionary<String^, int>^ RALPHABET
public:
static initonly Dictionary<String^, int>^ RALPHABET
static val RALPHABET: Dictionary<string, int>
static val RALPHABET: Dictionary<string, int>

Field Value

Type: Online Dictionary Online String, Online Int32
See Also
ELink Class
ELink Members
NFX Namespace


ELink.VARIATIONS Field

ELink VARIATIONS Field NFX Class Library

Represents how many variations every link has (seeds)

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int VARIATIONS
public const int VARIATIONS
Public Const VARIATIONS As Integer
Public Const VARIATIONS As Integer
public:
literal int VARIATIONS
public:
literal int VARIATIONS
static val mutable VARIATIONS: int
static val mutable VARIATIONS: int

Field Value

Type: Online Int32
See Also
ELink Class
ELink Members
NFX Namespace


ELink Methods

ELink Methods NFX Class Library

The ELink type exposes the following members.
Methods
 | Name | Description
Public method | Encode | Encodes a link into a textual form, using the supplied randomization seed, otherwise the system rnd is used. A seed has 4 effective bits, yielding 16 possible variations for every link
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ELink Class
NFX Namespace


ELink.Encode Method

ELink Encode Method NFX Class Library

Encodes a link into a textual form, using the supplied randomization seed, otherwise the system rnd is used. A seed has 4 effective bits, yielding 16 possible variations for every link

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Encode(
    Nullable<byte> seed = null
)
public string Encode(
    Nullable<byte> seed = null
)
Public Function Encode (
    Optional seed As Nullable(Of Byte) = Nothing
) As String
Public Function Encode (
    Optional seed As Nullable(Of Byte) = Nothing
) As String
public:
String^ Encode(
    Nullable<unsigned char> seed = nullptr
)
public:
String^ Encode(
    Nullable<unsigned char> seed = nullptr
)
member Encode :
        ?seed : Nullable<byte>
(* Defaults:
        let _seed = defaultArg seed null
*)
-> string
member Encode :
        ?seed : Nullable<byte>
(* Defaults:
        let _seed = defaultArg seed null
*)
-> string

Parameters

seed (Optional)
Type: Online System Nullable Online Byte

Return Value

Type: Online String
See Also
ELink Class
ELink Members
NFX Namespace


ELink Properties

ELink Properties NFX Class Library

The ELink type exposes the following members.
Properties
 | Name | Description
Public property | AsGDIDSymbol |
Public property | GDID | Returns the GDID that this link represents
Public property | ID | Returns the ID portion of GDID represented by this instance
Public property | Link | Returns a link encoded as a string using whatever randomization seed was passed to the last Encode(seed) call. If Encode() was not called, then the link will get encoded using system rnd for a seed value
Public property | Metadata | Returns metadata attached to this instance, or null if there is no metadata specified
Back to Top
See Also
ELink Class
NFX Namespace


ELink.AsGDIDSymbol Property

ELink AsGDIDSymbol Property NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GDIDSymbol AsGDIDSymbol { get; }
public GDIDSymbol AsGDIDSymbol { get; }
Public ReadOnly Property AsGDIDSymbol As GDIDSymbol
    Get
Public ReadOnly Property AsGDIDSymbol As GDIDSymbol
    Get
public:
property GDIDSymbol AsGDIDSymbol {
    GDIDSymbol get ();
}
public:
property GDIDSymbol AsGDIDSymbol {
    GDIDSymbol get ();
}
member AsGDIDSymbol : GDIDSymbol with get
member AsGDIDSymbol : GDIDSymbol with get

Property Value

Type: GDIDSymbol
See Also
ELink Class
ELink Members
NFX Namespace


ELink.GDID Property

ELink GDID Property NFX Class Library

Returns the GDID that this link represents

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GDID GDID { get; }
public GDID GDID { get; }
Public ReadOnly Property GDID As GDID
    Get
Public ReadOnly Property GDID As GDID
    Get
public:
property GDID GDID {
    GDID get ();
}
public:
property GDID GDID {
    GDID get ();
}
member GDID : GDID with get
member GDID : GDID with get

Property Value

Type: GDID
See Also
ELink Class
ELink Members
NFX Namespace


ELink.ID Property

ELink ID Property NFX Class Library

Returns the ID portion of GDID represented by this instance

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong ID { get; }
public ulong ID { get; }
Public ReadOnly Property ID As ULong
    Get
Public ReadOnly Property ID As ULong
    Get
public:
property unsigned long long ID {
    unsigned long long get ();
}
public:
property unsigned long long ID {
    unsigned long long get ();
}
member ID : uint64 with get
member ID : uint64 with get

Property Value

Type: Online UInt64
See Also
ELink Class
ELink Members
NFX Namespace


ELink.Link Property

ELink Link Property NFX Class Library

Returns a link encoded as a string using whatever randomization seed was passed to the last Encode(seed) call. If Encode() was not called, then the link will get encoded using system rnd for a seed value

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Link { get; }
public string Link { get; }
Public ReadOnly Property Link As String
    Get
Public ReadOnly Property Link As String
    Get
public:
property String^ Link {
    String^ get ();
}
public:
property String^ Link {
    String^ get ();
}
member Link : string with get
member Link : string with get

Property Value

Type: Online String
See Also
ELink Class
ELink Members
NFX Namespace


ELink.Metadata Property

ELink Metadata Property NFX Class Library

Returns metadata attached to this instance, or null if there is no metadata specified

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] Metadata { get; }
public byte[] Metadata { get; }
Public ReadOnly Property Metadata As Byte()
    Get
Public ReadOnly Property Metadata As Byte()
    Get
public:
property array<unsigned char>^ Metadata {
    array<unsigned char>^ get ();
}
public:
property array<unsigned char>^ Metadata {
    array<unsigned char>^ get ();
}
member Metadata : byte[] with get
member Metadata : byte[] with get

Property Value

Type: Online Byte
See Also
ELink Class
ELink Members
NFX Namespace


EmbeddedResource Class

EmbeddedResource Class NFX Class Library

Fetches resources such as script statement text by scriptName from assembly resource stream. Mostly used for SQL and JavaScript but maybe used for any text retrieval. This class is 100% safe for multithreading operations. Script texts are cached in ram for faster subsequent access.
Inheritance Hierarchy
Online System Object
NFX EmbeddedResource

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class EmbeddedResource
public static class EmbeddedResource
<ExtensionAttribute>
Public NotInheritable Class EmbeddedResource
<ExtensionAttribute>
Public NotInheritable Class EmbeddedResource
[ExtensionAttribute]
public ref class EmbeddedResource abstract sealed
[ExtensionAttribute]
public ref class EmbeddedResource abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type EmbeddedResource =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type EmbeddedResource =  class end
See Also
EmbeddedResource Members
NFX Namespace


EmbeddedResource Members

EmbeddedResource Members NFX Class Library

The EmbeddedResource type exposes the following members.
Methods
Name Description
GetBinaryContent
Pass a type and resource path rooted at type's namespace, for example given
View Colorized Copy to Clipboard Print
using (var stream = typeof(SomeType).GetBinary("My.Picture.gif")){...}
using (var stream = typeof(SomeType).GetBinary("My.Picture.gif")){...}
If "SomeType" is declared in "TestApp.Types", then statement's resource will have to be embedded under resource named: "TestApp.Types.My.Picture.gif"
GetBinaryStream
Pass a type and resource path rooted at type's namespace, for example given
View Colorized Copy to Clipboard Print
using (var stream = typeof(SomeType).GetBinary("My.Picture.gif")){...}
using (var stream = typeof(SomeType).GetBinary("My.Picture.gif")){...}
If "SomeType" is declared in "TestApp.Types", then statement's resource will have to be embedded under resource named: "TestApp.Types.My.Picture.gif"
GetText
Pass a type and resource path rooted at type's namespace, for example given
View Colorized Copy to Clipboard Print
string sql = typeof(SomeType).GetText("SQL.User.Insert.sql");
string sql = typeof(SomeType).GetText("SQL.User.Insert.sql");
If "SomeType" is declared in "TestApp.Types", then statement's resource will have to be embedded under resource named: "TestApp.Types.SQL.User.Insert.sql"
Back to Top
See Also
EmbeddedResource Class
NFX Namespace


EmbeddedResource Methods

EmbeddedResource Methods NFX Class Library

The EmbeddedResource type exposes the following members.
Methods
Name Description
GetBinaryContent
Pass a type and resource path rooted at type's namespace, for example given
View Colorized Copy to Clipboard Print
using (var stream = typeof(SomeType).GetBinary("My.Picture.gif")){...}
using (var stream = typeof(SomeType).GetBinary("My.Picture.gif")){...}
If "SomeType" is declared in "TestApp.Types", then statement's resource will have to be embedded under resource named: "TestApp.Types.My.Picture.gif"
GetBinaryStream
Pass a type and resource path rooted at type's namespace, for example given
View Colorized Copy to Clipboard Print
using (var stream = typeof(SomeType).GetBinary("My.Picture.gif")){...}
using (var stream = typeof(SomeType).GetBinary("My.Picture.gif")){...}
If "SomeType" is declared in "TestApp.Types", then statement's resource will have to be embedded under resource named: "TestApp.Types.My.Picture.gif"
GetText
Pass a type and resource path rooted at type's namespace, for example given
View Colorized Copy to Clipboard Print
string sql = typeof(SomeType).GetText("SQL.User.Insert.sql");
string sql = typeof(SomeType).GetText("SQL.User.Insert.sql");
If "SomeType" is declared in "TestApp.Types", then statement's resource will have to be embedded under resource named: "TestApp.Types.SQL.User.Insert.sql"
Back to Top
See Also
EmbeddedResource Class
NFX Namespace


EmbeddedResource.GetBinaryContent Method

EmbeddedResource GetBinaryContent Method NFX Class Library

Pass a type and resource path rooted at type's namespace, for example given
View Colorized Copy to Clipboard Print
using (var stream = typeof(SomeType).GetBinary("My.Picture.gif")){...}
using (var stream = typeof(SomeType).GetBinary("My.Picture.gif")){...}
If "SomeType" is declared in "TestApp.Types", then statement's resource will have to be embedded under resource named: "TestApp.Types.My.Picture.gif"

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte[] GetBinaryContent(
    this Type scopingType,
    string resourceName
)
public static byte[] GetBinaryContent(
    this Type scopingType,
    string resourceName
)
<ExtensionAttribute>
Public Shared Function GetBinaryContent (
    scopingType As Type,
    resourceName As String
) As Byte()
<ExtensionAttribute>
Public Shared Function GetBinaryContent (
    scopingType As Type,
    resourceName As String
) As Byte()
public:
[ExtensionAttribute]
static array<unsigned char>^ GetBinaryContent(
    Type^ scopingType,
    String^ resourceName
)
public:
[ExtensionAttribute]
static array<unsigned char>^ GetBinaryContent(
    Type^ scopingType,
    String^ resourceName
)
static member GetBinaryContent :
        scopingType : Type *
        resourceName : string -> byte[]
static member GetBinaryContent :
        scopingType : Type *
        resourceName : string -> byte[]

Parameters

scopingType
Type: Online System Type
resourceName
Type: Online System String

Return Value

Type: Online Byte

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
EmbeddedResource Class
EmbeddedResource Members
NFX Namespace


EmbeddedResource.GetBinaryStream Method

EmbeddedResource GetBinaryStream Method NFX Class Library

Pass a type and resource path rooted at type's namespace, for example given
View Colorized Copy to Clipboard Print
using (var stream = typeof(SomeType).GetBinary("My.Picture.gif")){...}
using (var stream = typeof(SomeType).GetBinary("My.Picture.gif")){...}
If "SomeType" is declared in "TestApp.Types", then statement's resource will have to be embedded under resource named: "TestApp.Types.My.Picture.gif"

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Stream GetBinaryStream(
    this Type scopingType,
    string resourceName
)
public static Stream GetBinaryStream(
    this Type scopingType,
    string resourceName
)
<ExtensionAttribute>
Public Shared Function GetBinaryStream (
    scopingType As Type,
    resourceName As String
) As Stream
<ExtensionAttribute>
Public Shared Function GetBinaryStream (
    scopingType As Type,
    resourceName As String
) As Stream
public:
[ExtensionAttribute]
static Stream^ GetBinaryStream(
    Type^ scopingType,
    String^ resourceName
)
public:
[ExtensionAttribute]
static Stream^ GetBinaryStream(
    Type^ scopingType,
    String^ resourceName
)
static member GetBinaryStream :
        scopingType : Type *
        resourceName : string -> Stream
static member GetBinaryStream :
        scopingType : Type *
        resourceName : string -> Stream

Parameters

scopingType
Type: Online System Type
resourceName
Type: Online System String

Return Value

Type: Online Stream

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
EmbeddedResource Class
EmbeddedResource Members
NFX Namespace


EmbeddedResource.GetText Method

EmbeddedResource GetText Method NFX Class Library

Pass a type and resource path rooted at type's namespace, for example given
View Colorized Copy to Clipboard Print
string sql = typeof(SomeType).GetText("SQL.User.Insert.sql");
string sql = typeof(SomeType).GetText("SQL.User.Insert.sql");
If "SomeType" is declared in "TestApp.Types", then statement's resource will have to be embedded under resource named: "TestApp.Types.SQL.User.Insert.sql"

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetText(
    this Type scopingType,
    string scriptName
)
public static string GetText(
    this Type scopingType,
    string scriptName
)
<ExtensionAttribute>
Public Shared Function GetText (
    scopingType As Type,
    scriptName As String
) As String
<ExtensionAttribute>
Public Shared Function GetText (
    scopingType As Type,
    scriptName As String
) As String
public:
[ExtensionAttribute]
static String^ GetText(
    Type^ scopingType,
    String^ scriptName
)
public:
[ExtensionAttribute]
static String^ GetText(
    Type^ scopingType,
    String^ scriptName
)
static member GetText :
        scopingType : Type *
        scriptName : string -> string
static member GetText :
        scopingType : Type *
        scriptName : string -> string

Parameters

scopingType
Type: Online System Type
scriptName
Type: Online System String

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
EmbeddedResource Class
EmbeddedResource Members
NFX Namespace


ExternalParameterAttribute Class

ExternalParameterAttribute Class NFX Class Library

Decorates properties that may be used as bindable external parameters. Provides methods for extraction of parameter names, values and binding of external object values into public read/write properties decorated by this attribute
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX ExternalParameterAttribute

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.Property, Inherited = true, AllowMultiple = false)]
public sealed class ExternalParameterAttribute : Attribute
[AttributeUsageAttribute(AttributeTargets.Property, Inherited = true, AllowMultiple = false)]
public sealed class ExternalParameterAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Property, Inherited := true, AllowMultiple := false)>
Public NotInheritable Class ExternalParameterAttribute
    Inherits Attribute
<AttributeUsageAttribute(AttributeTargets.Property, Inherited := true, AllowMultiple := false)>
Public NotInheritable Class ExternalParameterAttribute
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Property, Inherited = true, AllowMultiple = false)]
public ref class ExternalParameterAttribute sealed : public Attribute
[AttributeUsageAttribute(AttributeTargets::Property, Inherited = true, AllowMultiple = false)]
public ref class ExternalParameterAttribute sealed : public Attribute
[<SealedAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Property, Inherited = true, AllowMultiple = false)>]
type ExternalParameterAttribute =
    class
        inherit Attribute
    end
[<SealedAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Property, Inherited = true, AllowMultiple = false)>]
type ExternalParameterAttribute =
    class
        inherit Attribute
    end
See Also
ExternalParameterAttribute Members
NFX Namespace


ExternalParameterAttribute Members

ExternalParameterAttribute Members NFX Class Library

The ExternalParameterAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | ExternalParameterAttribute | Initializes a new instance of the ExternalParameterAttribute class
Public method | ExternalParameterAttribute( String ) | Provides a list of group names where this parameter applies
Public method | ExternalParameterAttribute(String, ExternalParameterSecurityCheck, String ) | Provides a name override with list of groups names where this parameter applies
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
 | GetParameter | Gets instrumentation parameter value returning true if parameter was found. Parameter names are case-insensitive. If groups is null then all parameters are searched, else parameters must intersect in their group sets with the supplied value
 | GetParameters(Object, String ) | Returns external parameter names and type - names for read/write public properties decorated with this attribute. If groups is null then all parameters returned, else parameters must intersect in their group sets with the supplied value
 | GetParameters(Type, String ) | Returns external parameter names and type - names for read/write public properties decorated with this attribute. If groups is null then all parameters returned, else parameters must intersect in their group sets with the supplied value
 | GetParametersWithAttrs | Returns external parameter names, type and attributes - names for read/write public properties decorated with this attribute. If groups is null then all parameters returned, else parameters must intersect in their group sets with the supplied value
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | SetParameter | Sets instrumentation parameter value, true if parameter name was found and set succeeded. The property is tried to be set directly to the supplied value first, then, in case of assignment error, the value is converted into string then tried to be re-converted to target type. Returns true for successful set. Parameter names are case-insensitive. If groups is null then all parameters are searched, else parameters must intersect in their group sets with the supplied value
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Groups | Returns null or a set of group names where parameter is applicable. This is needed to disregard parameters that do not belong to things being managed, for example, some parameters may be only set for isntrumentation, not for glue etc.
Public field | Name | Provides name override for external parameter. When this value is not set the name is taken from the decorated member name
Public field | SecurityCheck | Specifies what security check must be done on get/set
Back to Top
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
ExternalParameterAttribute Class
NFX Namespace


ExternalParameterAttribute Constructor

ExternalParameterAttribute Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ExternalParameterAttribute | Initializes a new instance of the ExternalParameterAttribute class
Public method | ExternalParameterAttribute( String ) | Provides a list of group names where this parameter applies
Public method | ExternalParameterAttribute(String, ExternalParameterSecurityCheck, String ) | Provides a name override with list of groups names where this parameter applies
Back to Top
See Also
ExternalParameterAttribute Class
ExternalParameterAttribute Members
NFX Namespace


ExternalParameterAttribute Constructor

ExternalParameterAttribute Constructor NFX Class Library

Initializes a new instance of the ExternalParameterAttribute class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ExternalParameterAttribute()
public ExternalParameterAttribute()
Public Sub New
Public Sub New
public:
ExternalParameterAttribute()
public:
ExternalParameterAttribute()
new : unit -> ExternalParameterAttribute
new : unit -> ExternalParameterAttribute
See Also
ExternalParameterAttribute Class
ExternalParameterAttribute Members
ExternalParameterAttribute Overload
NFX Namespace


ExternalParameterAttribute Constructor (String[])

ExternalParameterAttribute Constructor ( String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Provides a list of group names where this parameter applies

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ExternalParameterAttribute(
    params string[] groups
)
public ExternalParameterAttribute(
    params string[] groups
)
Public Sub New (
    ParamArray groups As String()
)
Public Sub New (
    ParamArray groups As String()
)
public:
ExternalParameterAttribute(
    ... array<String^>^ groups
)
public:
ExternalParameterAttribute(
    ... array<String^>^ groups
)
new :
        groups : string[] -> ExternalParameterAttribute
new :
        groups : string[] -> ExternalParameterAttribute

Parameters

groups
Type: Online System String
See Also
ExternalParameterAttribute Class
ExternalParameterAttribute Members
ExternalParameterAttribute Overload
NFX Namespace


ExternalParameterAttribute Constructor (String, ExternalParameterSecurityCheck, String[])

ExternalParameterAttribute Constructor (String, ExternalParameterSecurityCheck, String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Provides a name override with list of groups names where this parameter applies

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ExternalParameterAttribute(
    string name,
    ExternalParameterSecurityCheck security,
    params string[] groups
)
public ExternalParameterAttribute(
    string name,
    ExternalParameterSecurityCheck security,
    params string[] groups
)
Public Sub New (
    name As String,
    security As ExternalParameterSecurityCheck,
    ParamArray groups As String()
)
Public Sub New (
    name As String,
    security As ExternalParameterSecurityCheck,
    ParamArray groups As String()
)
public:
ExternalParameterAttribute(
    String^ name,
    ExternalParameterSecurityCheck security,
    ... array<String^>^ groups
)
public:
ExternalParameterAttribute(
    String^ name,
    ExternalParameterSecurityCheck security,
    ... array<String^>^ groups
)
new :
        name : string *
        security : ExternalParameterSecurityCheck *
        groups : string[] -> ExternalParameterAttribute
new :
        name : string *
        security : ExternalParameterSecurityCheck *
        groups : string[] -> ExternalParameterAttribute

Parameters

name
Type: Online System String
security
Type: NFX ExternalParameterSecurityCheck
groups
Type: Online System String
See Also
ExternalParameterAttribute Class
ExternalParameterAttribute Members
ExternalParameterAttribute Overload
NFX Namespace


ExternalParameterAttribute Fields

ExternalParameterAttribute Fields NFX Class Library

The ExternalParameterAttribute type exposes the following members.
Fields
 | Name | Description
Public field | Groups | Returns null or a set of group names where parameter is applicable. This is needed to disregard parameters that do not belong to things being managed, for example, some parameters may be only set for isntrumentation, not for glue etc.
Public field | Name | Provides name override for external parameter. When this value is not set the name is taken from the decorated member name
Public field | SecurityCheck | Specifies what security check must be done on get/set
Back to Top
See Also
ExternalParameterAttribute Class
NFX Namespace


ExternalParameterAttribute.Groups Field

ExternalParameterAttribute Groups Field NFX Class Library

Returns null or a set of group names where parameter is applicable. This is needed to disregard parameters that do not belong to things being managed, for example, some parameters may be only set for isntrumentation, not for glue etc.

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly IEnumerable<string> Groups
public readonly IEnumerable<string> Groups
Public ReadOnly Groups As IEnumerable(Of String)
Public ReadOnly Groups As IEnumerable(Of String)
public:
initonly IEnumerable<String^>^ Groups
public:
initonly IEnumerable<String^>^ Groups
val Groups: IEnumerable<string>
val Groups: IEnumerable<string>

Field Value

Type: Online IEnumerable Online String
See Also
ExternalParameterAttribute Class
ExternalParameterAttribute Members
NFX Namespace


ExternalParameterAttribute.Name Field

ExternalParameterAttribute Name Field NFX Class Library

Provides name override for external parameter. When this value is not set the name is taken from the decorated member name

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Name
public readonly string Name
Public ReadOnly Name As String
Public ReadOnly Name As String
public:
initonly String^ Name
public:
initonly String^ Name
val Name: string
val Name: string

Field Value

Type: Online String
See Also
ExternalParameterAttribute Class
ExternalParameterAttribute Members
NFX Namespace


ExternalParameterAttribute.SecurityCheck Field

ExternalParameterAttribute SecurityCheck Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Specifies what security check must be done on get/set

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ExternalParameterSecurityCheck SecurityCheck
public readonly ExternalParameterSecurityCheck SecurityCheck
Public ReadOnly SecurityCheck As ExternalParameterSecurityCheck
Public ReadOnly SecurityCheck As ExternalParameterSecurityCheck
public:
initonly ExternalParameterSecurityCheck SecurityCheck
public:
initonly ExternalParameterSecurityCheck SecurityCheck
val SecurityCheck: ExternalParameterSecurityCheck
val SecurityCheck: ExternalParameterSecurityCheck

Field Value

Type: ExternalParameterSecurityCheck
See Also
ExternalParameterAttribute Class
ExternalParameterAttribute Members
NFX Namespace


ExternalParameterAttribute Methods

ExternalParameterAttribute Methods NFX Class Library

The ExternalParameterAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
 | GetParameter | Gets instrumentation parameter value returning true if parameter was found. Parameter names are case-insensitive. If groups is null then all parameters are searched, else parameters must intersect in their group sets with the supplied value
 | GetParameters(Object, String ) | Returns external parameter names and type - names for read/write public properties decorated with this attribute. If groups is null then all parameters returned, else parameters must intersect in their group sets with the supplied value
 | GetParameters(Type, String ) | Returns external parameter names and type - names for read/write public properties decorated with this attribute. If groups is null then all parameters returned, else parameters must intersect in their group sets with the supplied value
 | GetParametersWithAttrs | Returns external parameter names, type and attributes - names for read/write public properties decorated with this attribute. If groups is null then all parameters returned, else parameters must intersect in their group sets with the supplied value
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | SetParameter | Sets instrumentation parameter value, true if parameter name was found and set succeeded. The property is tried to be set directly to the supplied value first, then, in case of assignment error, the value is converted into string then tried to be re-converted to target type. Returns true for successful set. Parameter names are case-insensitive. If groups is null then all parameters are searched, else parameters must intersect in their group sets with the supplied value
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ExternalParameterAttribute Class
NFX Namespace


ExternalParameterAttribute.GetParameter Method

ExternalParameterAttribute GetParameter Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets instrumentation parameter value returning true if parameter was found. Parameter names are case-insensitive. If groups is null then all parameters are searched, else parameters must intersect in their group sets with the supplied value

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool GetParameter(
    Object target,
    string name,
    out Object value,
    params string[] groups
)
public static bool GetParameter(
    Object target,
    string name,
    out Object value,
    params string[] groups
)
Public Shared Function GetParameter (
    target As Object,
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
Public Shared Function GetParameter (
    target As Object,
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
public:
static bool GetParameter(
    Object^ target,
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
)
public:
static bool GetParameter(
    Object^ target,
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
)
static member GetParameter :
        target : Object *
        name : string *
        value : Object byref *
        groups : string[] -> bool
static member GetParameter :
        target : Object *
        name : string *
        value : Object byref *
        groups : string[] -> bool

Parameters

target
Type: Online System Object
name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean
See Also
ExternalParameterAttribute Class
ExternalParameterAttribute Members
NFX Namespace


ExternalParameterAttribute.GetParameters Method

ExternalParameterAttribute GetParameters Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
Name | Description
GetParameters(Object, String ) | Returns external parameter names and type - names for read/write public properties decorated with this attribute. If groups is null then all parameters returned, else parameters must intersect in their group sets with the supplied value
GetParameters(Type, String ) | Returns external parameter names and type - names for read/write public properties decorated with this attribute. If groups is null then all parameters returned, else parameters must intersect in their group sets with the supplied value
Back to Top
See Also
ExternalParameterAttribute Class
ExternalParameterAttribute Members
NFX Namespace


ExternalParameterAttribute.GetParameters Method (Object, String[])

ExternalParameterAttribute GetParameters Method (Object, String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns external parameter names and type - names for read/write public properties decorated with this attribute. If groups is null then all parameters returned, else parameters must intersect in their group sets with the supplied value

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<KeyValuePair<string, Type>> GetParameters(
    Object target,
    params string[] groups
)
public static IEnumerable<KeyValuePair<string, Type>> GetParameters(
    Object target,
    params string[] groups
)
Public Shared Function GetParameters (
    target As Object,
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
Public Shared Function GetParameters (
    target As Object,
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
public:
static IEnumerable<KeyValuePair<String^, Type^>>^ GetParameters(
    Object^ target,
    ... array<String^>^ groups
)
public:
static IEnumerable<KeyValuePair<String^, Type^>>^ GetParameters(
    Object^ target,
    ... array<String^>^ groups
)
static member GetParameters :
        target : Object *
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
static member GetParameters :
        target : Object *
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>

Parameters

target
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type
See Also
ExternalParameterAttribute Class
ExternalParameterAttribute Members
GetParameters Overload
NFX Namespace


ExternalParameterAttribute.GetParameters Method (Type, String[])

ExternalParameterAttribute GetParameters Method (Type, String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns external parameter names and type - names for read/write public properties decorated with this attribute. If groups is null then all parameters returned, else parameters must intersect in their group sets with the supplied value

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<KeyValuePair<string, Type>> GetParameters(
    Type target,
    params string[] groups
)
public static IEnumerable<KeyValuePair<string, Type>> GetParameters(
    Type target,
    params string[] groups
)
Public Shared Function GetParameters (
    target As Type,
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
Public Shared Function GetParameters (
    target As Type,
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
public:
static IEnumerable<KeyValuePair<String^, Type^>>^ GetParameters(
    Type^ target,
    ... array<String^>^ groups
)
public:
static IEnumerable<KeyValuePair<String^, Type^>>^ GetParameters(
    Type^ target,
    ... array<String^>^ groups
)
static member GetParameters :
        target : Type *
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
static member GetParameters :
        target : Type *
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>

Parameters

target
Type: Online System Type
groups
Type: Online System String

Return Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type
See Also
ExternalParameterAttribute Class
ExternalParameterAttribute Members
GetParameters Overload
NFX Namespace


ExternalParameterAttribute.GetParametersWithAttrs Method

ExternalParameterAttribute GetParametersWithAttrs Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns external parameter names, type and attributes - names for read/write public properties decorated with this attribute. If groups is null then all parameters returned, else parameters must intersect in their group sets with the supplied value

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<Tuple<string, Type, ExternalParameterAttribute>> GetParametersWithAttrs(
    Type target,
    params string[] groups
)
public static IEnumerable<Tuple<string, Type, ExternalParameterAttribute>> GetParametersWithAttrs(
    Type target,
    params string[] groups
)
Public Shared Function GetParametersWithAttrs (
    target As Type,
    ParamArray groups As String()
) As IEnumerable(Of Tuple(Of String, Type, ExternalParameterAttribute))
Public Shared Function GetParametersWithAttrs (
    target As Type,
    ParamArray groups As String()
) As IEnumerable(Of Tuple(Of String, Type, ExternalParameterAttribute))
public:
static IEnumerable<Tuple<String^, Type^, ExternalParameterAttribute^>^>^ GetParametersWithAttrs(
    Type^ target,
    ... array<String^>^ groups
)
public:
static IEnumerable<Tuple<String^, Type^, ExternalParameterAttribute^>^>^ GetParametersWithAttrs(
    Type^ target,
    ... array<String^>^ groups
)
static member GetParametersWithAttrs :
        target : Type *
        groups : string[] -> IEnumerable<Tuple<string, Type, ExternalParameterAttribute>>
static member GetParametersWithAttrs :
        target : Type *
        groups : string[] -> IEnumerable<Tuple<string, Type, ExternalParameterAttribute>>

Parameters

target
Type: Online System Type
groups
Type: Online System String

Return Value

Type: Online IEnumerable Online Tuple Online String, Online Type, ExternalParameterAttribute
See Also
ExternalParameterAttribute Class
ExternalParameterAttribute Members
NFX Namespace


ExternalParameterAttribute.SetParameter Method

ExternalParameterAttribute SetParameter Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Sets instrumentation parameter value, true if parameter name was found and set succeeded. The property is tried to be set directly to the supplied value first, then, in case of assignment error, the value is converted into string then tried to be re-converted to target type. Returns true for successful set. Parameter names are case-insensitive. If groups is null then all parameters are searched, else parameters must intersect in their group sets with the supplied value

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool SetParameter(
    Object target,
    string name,
    Object value,
    params string[] groups
)
public static bool SetParameter(
    Object target,
    string name,
    Object value,
    params string[] groups
)
Public Shared Function SetParameter (
    target As Object,
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
Public Shared Function SetParameter (
    target As Object,
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
public:
static bool SetParameter(
    Object^ target,
    String^ name,
    Object^ value,
    ... array<String^>^ groups
)
public:
static bool SetParameter(
    Object^ target,
    String^ name,
    Object^ value,
    ... array<String^>^ groups
)
static member SetParameter :
        target : Object *
        name : string *
        value : Object *
        groups : string[] -> bool
static member SetParameter :
        target : Object *
        name : string *
        value : Object *
        groups : string[] -> bool

Parameters

target
Type: Online System Object
name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean
See Also
ExternalParameterAttribute Class
ExternalParameterAttribute Members
NFX Namespace


ExternalParameterAttribute Properties

ExternalParameterAttribute Properties NFX Class Library

The ExternalParameterAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
ExternalParameterAttribute Class
NFX Namespace


ExternalParameterSecurityCheck Enumeration

ExternalParameterSecurityCheck Enumeration NFX Class Library

Specifies when security permissions should be checked while getting/setting extrenal parameters

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[FlagsAttribute]
public enum ExternalParameterSecurityCheck
[FlagsAttribute]
public enum ExternalParameterSecurityCheck
<FlagsAttribute>
Public Enumeration ExternalParameterSecurityCheck
<FlagsAttribute>
Public Enumeration ExternalParameterSecurityCheck
[FlagsAttribute]
public enum class ExternalParameterSecurityCheck
[FlagsAttribute]
public enum class ExternalParameterSecurityCheck
[<FlagsAttribute>]
type ExternalParameterSecurityCheck
[<FlagsAttribute>]
type ExternalParameterSecurityCheck
Members
Member name | Value | Description
None | 0 |
OnGet | 1 |
OnSet | 2 |
OnGetSet | 3 |
See Also
NFX Namespace


ExternalRandomGenerator Class

ExternalRandomGenerator Class NFX Class Library

Represents a random generator which is based on System.Random() yet has an ability to feed external samples into it. Use ExtrenalRandomGenerator.Instance to use the default thread-safe instance.
Inheritance Hierarchy
Online System Object
NFX ExternalRandomGenerator

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ExternalRandomGenerator
public sealed class ExternalRandomGenerator
Public NotInheritable Class ExternalRandomGenerator
Public NotInheritable Class ExternalRandomGenerator
public ref class ExternalRandomGenerator sealed
public ref class ExternalRandomGenerator sealed
[<SealedAttribute>]
type ExternalRandomGenerator =  class end
[<SealedAttribute>]
type ExternalRandomGenerator =  class end
Remarks
Introduces external entropy into the generation sequence by adding a sample into the ring buffer. Call FeedExternalEntropySample(int sample) method from places that have true entropy values, i.e. a network-related code may have good entropy sources in server applications. External entropy sources may rely on user-dependent actions, i.e.: number of bytes/requests received per second, dollar(or cent remainders) amount of purchases made (on a server), zip codes of customers, IP addresses of site visitors, average noise level sampled on an open WAVE device(microphone), mouse position (i.e. in GUI app) etc... This class MAY be crypto-safe if it is fed a good entropy data at high rate, however that depends on the use pattern. The framework implementation feeds some entropy from Glue and cache components infrequently (once every few seconds), which is definitely not strong for cryptography
See Also
ExternalRandomGenerator Members
NFX Namespace


ExternalRandomGenerator Members

ExternalRandomGenerator Members NFX Class Library

The ExternalRandomGenerator type exposes the following members.
Constructors
 | Name | Description
Public method | ExternalRandomGenerator | Create new instance of ExternalRandomGenerator. Create new instances only if you need to use different sample ring buffers. In majority of cases use ExternalRandomGenerator.Instance to use default instance instead of creating a new instance. Default instance is thread-safe for process-wide use
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FeedExternalEntropySample | Introduces external entropy into the generation sequence by adding a sample into the ring buffer. Call this method from places that have true entropy values, i.e. a network-related code may have good entropy sources in server applications. External entropy sources may rely on user-dependent actions, i.e.: number of bytes/requests received per second, dollar(or cent remainders) amount of purchases made (on a server), zip codes of customers, IP addresses of site visitors, average noise level sampled on an open WAVE device(microphone), mouse position (i.e. in GUI app) etc...
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextRandomBytes(Int32) | Generates a random buffer of bytes
Public method | NextRandomBytes(Int32, Int32) | Generates a random buffer of bytes
Public method | NextRandomSecureBuffer(Int32) | Generates a random secure buffer of bytes
Public method | NextRandomSecureBuffer(Int32, Int32) | Generates a random secure buffer of bytes
Public method | NextRandomWebSafeSecureBuffer | Generates a random secure buffer of chars which are safe for the use on the web - a string that only contains "a-z"/"A-Z" and "0-9" and "-"/"_" chars, i.e.: "bo7O0EFasZe-wEty9w0__JiOKk81". The length of the string can not be less than 4 and more than 1024 chars
Public method | NextRandomWebSafeString | Generates a random string of chars which are safe for the use on the web - a string that only contains "a-z"/"A-Z" and "0-9" and "-"/"_" chars, i.e.: "bo7O0EFasZe-wEty9w0__JiOKk81". The length of the string can not be less than 4 and more than 1024 chars
Public method | NextScaledRandomDouble | Generates random double number in min..max range
Public method | NextScaledRandomInteger | Generates random number in min..max range
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
 | Instance | Returns the default instance of the generator. This instance is thread-safe
Public property | NextRandom16Bytes | Generates random byte[16] buffer
Public property | NextRandomDouble | Returns 0..1 random double
Public property | NextRandomInteger | Generates next random integer in the Int32.MinValue..Int32.MaxValue diapason
Public property | NextRandomUnsignedInteger | Generates next random integer in the Uint32.MinValue..Uint32.MaxValue diapason
Public property | NextRandomUnsignedLong | Generates next random ulong in the Uint64.MinValue..Uint64.MaxValue range
Back to Top
See Also
ExternalRandomGenerator Class
NFX Namespace


ExternalRandomGenerator Constructor

ExternalRandomGenerator Constructor NFX Class Library

Create new instance of ExternalRandomGenerator. Create new instances only if you need to use different sample ring buffers. In majority of cases use ExternalRandomGenerator.Instance to use default instance instead of creating a new instance. Default instance is thread-safe for process-wide use

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ExternalRandomGenerator()
public ExternalRandomGenerator()
Public Sub New
Public Sub New
public:
ExternalRandomGenerator()
public:
ExternalRandomGenerator()
new : unit -> ExternalRandomGenerator
new : unit -> ExternalRandomGenerator
See Also
ExternalRandomGenerator Class
ExternalRandomGenerator Members
NFX Namespace


ExternalRandomGenerator Methods

ExternalRandomGenerator Methods NFX Class Library

The ExternalRandomGenerator type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FeedExternalEntropySample | Introduces external entropy into the generation sequence by adding a sample into the ring buffer. Call this method from places that have true entropy values, i.e. a network-related code may have good entropy sources in server applications. External entropy sources may rely on user-dependent actions, i.e.: number of bytes/requests received per second, dollar(or cent remainders) amount of purchases made (on a server), zip codes of customers, IP addresses of site visitors, average noise level sampled on an open WAVE device(microphone), mouse position (i.e. in GUI app) etc...
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NextRandomBytes(Int32) | Generates a random buffer of bytes
Public method | NextRandomBytes(Int32, Int32) | Generates a random buffer of bytes
Public method | NextRandomSecureBuffer(Int32) | Generates a random secure buffer of bytes
Public method | NextRandomSecureBuffer(Int32, Int32) | Generates a random secure buffer of bytes
Public method | NextRandomWebSafeSecureBuffer | Generates a random secure buffer of chars which are safe for the use on the web - a string that only contains "a-z"/"A-Z" and "0-9" and "-"/"_" chars, i.e.: "bo7O0EFasZe-wEty9w0__JiOKk81". The length of the string can not be less than 4 and more than 1024 chars
Public method | NextRandomWebSafeString | Generates a random string of chars which are safe for the use on the web - a string that only contains "a-z"/"A-Z" and "0-9" and "-"/"_" chars, i.e.: "bo7O0EFasZe-wEty9w0__JiOKk81". The length of the string can not be less than 4 and more than 1024 chars
Public method | NextScaledRandomDouble | Generates random double number in min..max range
Public method | NextScaledRandomInteger | Generates random number in min..max range
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ExternalRandomGenerator Class
NFX Namespace


ExternalRandomGenerator.FeedExternalEntropySample Method

ExternalRandomGenerator FeedExternalEntropySample Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Introduces external entropy into the generation sequence by adding a sample into the ring buffer. Call this method from places that have true entropy values, i.e. a network-related code may have good entropy sources in server applications. External entropy sources may rely on user-dependent actions, i.e.: number of bytes/requests received per second, dollar(or cent remainders) amount of purchases made (on a server), zip codes of customers, IP addresses of site visitors, average noise level sampled on an open WAVE device(microphone), mouse position (i.e. in GUI app) etc...

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void FeedExternalEntropySample(
    int sample
)
public void FeedExternalEntropySample(
    int sample
)
Public Sub FeedExternalEntropySample (
    sample As Integer
)
Public Sub FeedExternalEntropySample (
    sample As Integer
)
public:
void FeedExternalEntropySample(
    int sample
)
public:
void FeedExternalEntropySample(
    int sample
)
member FeedExternalEntropySample :
        sample : int -> unit
member FeedExternalEntropySample :
        sample : int -> unit

Parameters

sample
Type: Online System Int32
See Also
ExternalRandomGenerator Class
ExternalRandomGenerator Members
NFX Namespace


ExternalRandomGenerator.NextRandomBytes Method

ExternalRandomGenerator NextRandomBytes Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public method | NextRandomBytes(Int32) | Generates a random buffer of bytes
Public method | NextRandomBytes(Int32, Int32) | Generates a random buffer of bytes
Back to Top
See Also
ExternalRandomGenerator Class
ExternalRandomGenerator Members
NFX Namespace


ExternalRandomGenerator.NextRandomBytes Method (Int32)

ExternalRandomGenerator NextRandomBytes Method (Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Generates a random buffer of bytes

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] NextRandomBytes(
    int length
)
public byte[] NextRandomBytes(
    int length
)
Public Function NextRandomBytes (
    length As Integer
) As Byte()
Public Function NextRandomBytes (
    length As Integer
) As Byte()
public:
array<unsigned char>^ NextRandomBytes(
    int length
)
public:
array<unsigned char>^ NextRandomBytes(
    int length
)
member NextRandomBytes :
        length : int -> byte[]
member NextRandomBytes :
        length : int -> byte[]

Parameters

length
Type: Online System Int32

Return Value

Type: Online Byte
See Also
ExternalRandomGenerator Class
ExternalRandomGenerator Members
NextRandomBytes Overload
NFX Namespace


ExternalRandomGenerator.NextRandomBytes Method (Int32, Int32)

ExternalRandomGenerator NextRandomBytes Method (Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Generates a random buffer of bytes

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] NextRandomBytes(
    int minLength,
    int maxLength
)
public byte[] NextRandomBytes(
    int minLength,
    int maxLength
)
Public Function NextRandomBytes (
    minLength As Integer,
    maxLength As Integer
) As Byte()
Public Function NextRandomBytes (
    minLength As Integer,
    maxLength As Integer
) As Byte()
public:
array<unsigned char>^ NextRandomBytes(
    int minLength,
    int maxLength
)
public:
array<unsigned char>^ NextRandomBytes(
    int minLength,
    int maxLength
)
member NextRandomBytes :
        minLength : int *
        maxLength : int -> byte[]
member NextRandomBytes :
        minLength : int *
        maxLength : int -> byte[]

Parameters

minLength
Type: Online System Int32
maxLength
Type: Online System Int32

Return Value

Type: Online Byte
See Also
ExternalRandomGenerator Class
ExternalRandomGenerator Members
NextRandomBytes Overload
NFX Namespace


ExternalRandomGenerator.NextRandomSecureBuffer Method

ExternalRandomGenerator NextRandomSecureBuffer Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public method | NextRandomSecureBuffer(Int32) | Generates a random secure buffer of bytes
Public method | NextRandomSecureBuffer(Int32, Int32) | Generates a random secure buffer of bytes
Back to Top
See Also
ExternalRandomGenerator Class
ExternalRandomGenerator Members
NFX Namespace


ExternalRandomGenerator.NextRandomSecureBuffer Method (Int32)

ExternalRandomGenerator NextRandomSecureBuffer Method (Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Generates a random secure buffer of bytes

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SecureBuffer NextRandomSecureBuffer(
    int length
)
public SecureBuffer NextRandomSecureBuffer(
    int length
)
Public Function NextRandomSecureBuffer (
    length As Integer
) As SecureBuffer
Public Function NextRandomSecureBuffer (
    length As Integer
) As SecureBuffer
public:
SecureBuffer^ NextRandomSecureBuffer(
    int length
)
public:
SecureBuffer^ NextRandomSecureBuffer(
    int length
)
member NextRandomSecureBuffer :
        length : int -> SecureBuffer
member NextRandomSecureBuffer :
        length : int -> SecureBuffer

Parameters

length
Type: Online System Int32

Return Value

Type: SecureBuffer
See Also
ExternalRandomGenerator Class
ExternalRandomGenerator Members
NextRandomSecureBuffer Overload
NFX Namespace


ExternalRandomGenerator.NextRandomSecureBuffer Method (Int32, Int32)

ExternalRandomGenerator NextRandomSecureBuffer Method (Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Generates a random secure buffer of bytes

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SecureBuffer NextRandomSecureBuffer(
    int minLength,
    int maxLength
)
public SecureBuffer NextRandomSecureBuffer(
    int minLength,
    int maxLength
)
Public Function NextRandomSecureBuffer (
    minLength As Integer,
    maxLength As Integer
) As SecureBuffer
Public Function NextRandomSecureBuffer (
    minLength As Integer,
    maxLength As Integer
) As SecureBuffer
public:
SecureBuffer^ NextRandomSecureBuffer(
    int minLength,
    int maxLength
)
public:
SecureBuffer^ NextRandomSecureBuffer(
    int minLength,
    int maxLength
)
member NextRandomSecureBuffer :
        minLength : int *
        maxLength : int -> SecureBuffer
member NextRandomSecureBuffer :
        minLength : int *
        maxLength : int -> SecureBuffer

Parameters

minLength
Type: Online System Int32
maxLength
Type: Online System Int32

Return Value

Type: SecureBuffer
See Also
ExternalRandomGenerator Class
ExternalRandomGenerator Members
NextRandomSecureBuffer Overload
NFX Namespace


ExternalRandomGenerator.NextRandomWebSafeSecureBuffer Method

ExternalRandomGenerator NextRandomWebSafeSecureBuffer Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Generates a random secure buffer of chars which are safe for the use on the web - a string that only contains "a-z"/"A-Z" and "0-9" and "-"/"_" chars, i.e.: "bo7O0EFasZe-wEty9w0__JiOKk81". The length of the string can not be less than 4 and more than 1024 chars

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SecureBuffer NextRandomWebSafeSecureBuffer(
    int minLength = 16,
    int maxLength = 32
)
public SecureBuffer NextRandomWebSafeSecureBuffer(
    int minLength = 16,
    int maxLength = 32
)
Public Function NextRandomWebSafeSecureBuffer (
    Optional minLength As Integer = 16,
    Optional maxLength As Integer = 32
) As SecureBuffer
Public Function NextRandomWebSafeSecureBuffer (
    Optional minLength As Integer = 16,
    Optional maxLength As Integer = 32
) As SecureBuffer
public:
SecureBuffer^ NextRandomWebSafeSecureBuffer(
    int minLength = 16,
    int maxLength = 32
)
public:
SecureBuffer^ NextRandomWebSafeSecureBuffer(
    int minLength = 16,
    int maxLength = 32
)
member NextRandomWebSafeSecureBuffer :
        ?minLength : int *
        ?maxLength : int
(* Defaults:
        let _minLength = defaultArg minLength 16
        let _maxLength = defaultArg maxLength 32
*)
-> SecureBuffer
member NextRandomWebSafeSecureBuffer :
        ?minLength : int *
        ?maxLength : int
(* Defaults:
        let _minLength = defaultArg minLength 16
        let _maxLength = defaultArg maxLength 32
*)
-> SecureBuffer

Parameters

minLength (Optional)
Type: Online System Int32
maxLength (Optional)
Type: Online System Int32

Return Value

Type: SecureBuffer
See Also
ExternalRandomGenerator Class
ExternalRandomGenerator Members
NFX Namespace


ExternalRandomGenerator.NextRandomWebSafeString Method

ExternalRandomGenerator NextRandomWebSafeString Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Generates a random string of chars which are safe for the use on the web - a string that only contains "a-z"/"A-Z" and "0-9" and "-"/"_" chars, i.e.: "bo7O0EFasZe-wEty9w0__JiOKk81". The length of the string can not be less than 4 and more than 1024 chars

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string NextRandomWebSafeString(
    int minLength = 16,
    int maxLength = 32
)
public string NextRandomWebSafeString(
    int minLength = 16,
    int maxLength = 32
)
Public Function NextRandomWebSafeString (
    Optional minLength As Integer = 16,
    Optional maxLength As Integer = 32
) As String
Public Function NextRandomWebSafeString (
    Optional minLength As Integer = 16,
    Optional maxLength As Integer = 32
) As String
public:
String^ NextRandomWebSafeString(
    int minLength = 16,
    int maxLength = 32
)
public:
String^ NextRandomWebSafeString(
    int minLength = 16,
    int maxLength = 32
)
member NextRandomWebSafeString :
        ?minLength : int *
        ?maxLength : int
(* Defaults:
        let _minLength = defaultArg minLength 16
        let _maxLength = defaultArg maxLength 32
*)
-> string
member NextRandomWebSafeString :
        ?minLength : int *
        ?maxLength : int
(* Defaults:
        let _minLength = defaultArg minLength 16
        let _maxLength = defaultArg maxLength 32
*)
-> string

Parameters

minLength (Optional)
Type: Online System Int32
maxLength (Optional)
Type: Online System Int32

Return Value

Type: Online String
See Also
ExternalRandomGenerator Class
ExternalRandomGenerator Members
NFX Namespace


ExternalRandomGenerator.NextScaledRandomDouble Method

ExternalRandomGenerator NextScaledRandomDouble Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Generates random double number in min..max range

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double NextScaledRandomDouble(
    double bound1,
    double bound2 = 0
)
public double NextScaledRandomDouble(
    double bound1,
    double bound2 = 0
)
Public Function NextScaledRandomDouble (
    bound1 As Double,
    Optional bound2 As Double = 0
) As Double
Public Function NextScaledRandomDouble (
    bound1 As Double,
    Optional bound2 As Double = 0
) As Double
public:
double NextScaledRandomDouble(
    double bound1,
    double bound2 = 0
)
public:
double NextScaledRandomDouble(
    double bound1,
    double bound2 = 0
)
member NextScaledRandomDouble :
        bound1 : float *
        ?bound2 : float
(* Defaults:
        let _bound2 = defaultArg bound2 0
*)
-> float
member NextScaledRandomDouble :
        bound1 : float *
        ?bound2 : float
(* Defaults:
        let _bound2 = defaultArg bound2 0
*)
-> float

Parameters

bound1
Type: Online System Double
bound2 (Optional)
Type: Online System Double

Return Value

Type: Online Double
See Also
ExternalRandomGenerator Class
ExternalRandomGenerator Members
NFX Namespace


ExternalRandomGenerator.NextScaledRandomInteger Method

ExternalRandomGenerator NextScaledRandomInteger Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Generates random number in min..max range

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int NextScaledRandomInteger(
    int bound1,
    int bound2 = 0
)
public int NextScaledRandomInteger(
    int bound1,
    int bound2 = 0
)
Public Function NextScaledRandomInteger (
    bound1 As Integer,
    Optional bound2 As Integer = 0
) As Integer
Public Function NextScaledRandomInteger (
    bound1 As Integer,
    Optional bound2 As Integer = 0
) As Integer
public:
int NextScaledRandomInteger(
    int bound1,
    int bound2 = 0
)
public:
int NextScaledRandomInteger(
    int bound1,
    int bound2 = 0
)
member NextScaledRandomInteger :
        bound1 : int *
        ?bound2 : int
(* Defaults:
        let _bound2 = defaultArg bound2 0
*)
-> int
member NextScaledRandomInteger :
        bound1 : int *
        ?bound2 : int
(* Defaults:
        let _bound2 = defaultArg bound2 0
*)
-> int

Parameters

bound1
Type: Online System Int32
bound2 (Optional)
Type: Online System Int32

Return Value

Type: Online Int32
See Also
ExternalRandomGenerator Class
ExternalRandomGenerator Members
NFX Namespace


ExternalRandomGenerator Properties

ExternalRandomGenerator Properties NFX Class Library

The ExternalRandomGenerator type exposes the following members.
Properties
 | Name | Description
 | Instance | Returns the default instance of the generator. This instance is thread-safe
Public property | NextRandom16Bytes | Generates random byte[16] buffer
Public property | NextRandomDouble | Returns 0..1 random double
Public property | NextRandomInteger | Generates next random integer in the Int32.MinValue..Int32.MaxValue diapason
Public property | NextRandomUnsignedInteger | Generates next random integer in the Uint32.MinValue..Uint32.MaxValue diapason
Public property | NextRandomUnsignedLong | Generates next random ulong in the Uint64.MinValue..Uint64.MaxValue range
Back to Top
See Also
ExternalRandomGenerator Class
NFX Namespace


ExternalRandomGenerator.Instance Property

ExternalRandomGenerator Instance Property NFX Class Library

Returns the default instance of the generator. This instance is thread-safe

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ExternalRandomGenerator Instance { get; }
public static ExternalRandomGenerator Instance { get; }
Public Shared ReadOnly Property Instance As ExternalRandomGenerator
    Get
Public Shared ReadOnly Property Instance As ExternalRandomGenerator
    Get
public:
static property ExternalRandomGenerator^ Instance {
    ExternalRandomGenerator^ get ();
}
public:
static property ExternalRandomGenerator^ Instance {
    ExternalRandomGenerator^ get ();
}
static member Instance : ExternalRandomGenerator with get
static member Instance : ExternalRandomGenerator with get

Property Value

Type: ExternalRandomGenerator
See Also
ExternalRandomGenerator Class
ExternalRandomGenerator Members
NFX Namespace


ExternalRandomGenerator.NextRandom16Bytes Property

ExternalRandomGenerator NextRandom16Bytes Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Generates random byte[16] buffer

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] NextRandom16Bytes { get; }
public byte[] NextRandom16Bytes { get; }
Public ReadOnly Property NextRandom16Bytes As Byte()
    Get
Public ReadOnly Property NextRandom16Bytes As Byte()
    Get
public:
property array<unsigned char>^ NextRandom16Bytes {
    array<unsigned char>^ get ();
}
public:
property array<unsigned char>^ NextRandom16Bytes {
    array<unsigned char>^ get ();
}
member NextRandom16Bytes : byte[] with get
member NextRandom16Bytes : byte[] with get

Property Value

Type: Online Byte
See Also
ExternalRandomGenerator Class
ExternalRandomGenerator Members
NFX Namespace


ExternalRandomGenerator.NextRandomDouble Property

ExternalRandomGenerator NextRandomDouble Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns 0..1 random double

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double NextRandomDouble { get; }
public double NextRandomDouble { get; }
Public ReadOnly Property NextRandomDouble As Double
    Get
Public ReadOnly Property NextRandomDouble As Double
    Get
public:
property double NextRandomDouble {
    double get ();
}
public:
property double NextRandomDouble {
    double get ();
}
member NextRandomDouble : float with get
member NextRandomDouble : float with get

Property Value

Type: Online Double
See Also
ExternalRandomGenerator Class
ExternalRandomGenerator Members
NFX Namespace


ExternalRandomGenerator.NextRandomInteger Property

ExternalRandomGenerator NextRandomInteger Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Generates next random integer in the Int32.MinValue..Int32.MaxValue diapason

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int NextRandomInteger { get; }
public int NextRandomInteger { get; }
Public ReadOnly Property NextRandomInteger As Integer
    Get
Public ReadOnly Property NextRandomInteger As Integer
    Get
public:
property int NextRandomInteger {
    int get ();
}
public:
property int NextRandomInteger {
    int get ();
}
member NextRandomInteger : int with get
member NextRandomInteger : int with get

Property Value

Type: Online Int32
See Also
ExternalRandomGenerator Class
ExternalRandomGenerator Members
NFX Namespace


ExternalRandomGenerator.NextRandomUnsignedInteger Property

ExternalRandomGenerator NextRandomUnsignedInteger Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Generates next random integer in the Uint32.MinValue..Uint32.MaxValue diapason

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint NextRandomUnsignedInteger { get; }
public uint NextRandomUnsignedInteger { get; }
Public ReadOnly Property NextRandomUnsignedInteger As UInteger
    Get
Public ReadOnly Property NextRandomUnsignedInteger As UInteger
    Get
public:
property unsigned int NextRandomUnsignedInteger {
    unsigned int get ();
}
public:
property unsigned int NextRandomUnsignedInteger {
    unsigned int get ();
}
member NextRandomUnsignedInteger : uint32 with get
member NextRandomUnsignedInteger : uint32 with get

Property Value

Type: Online UInt32
See Also
ExternalRandomGenerator Class
ExternalRandomGenerator Members
NFX Namespace


ExternalRandomGenerator.NextRandomUnsignedLong Property

ExternalRandomGenerator NextRandomUnsignedLong Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Generates next random ulong in the Uint64.MinValue..Uint64.MaxValue range

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong NextRandomUnsignedLong { get; }
public ulong NextRandomUnsignedLong { get; }
Public ReadOnly Property NextRandomUnsignedLong As ULong
    Get
Public ReadOnly Property NextRandomUnsignedLong As ULong
    Get
public:
property unsigned long long NextRandomUnsignedLong {
    unsigned long long get ();
}
public:
property unsigned long long NextRandomUnsignedLong {
    unsigned long long get ();
}
member NextRandomUnsignedLong : uint64 with get
member NextRandomUnsignedLong : uint64 with get

Property Value

Type: Online UInt64
See Also
ExternalRandomGenerator Class
ExternalRandomGenerator Members
NFX Namespace


FID Structure

FID Structure NFX Class Library

Represents an ultra-efficient 64 bit in-process-wide unique identifier "Fast Id". The ID is going to wrap-around after at least 2 weeks (19 days). The ID consists of 3 segments: [timestamp: 24bit][threadseed: 24bit][counter: 16 bit]. This is needed because: a). FID stays unique after process restarts b). This design does not use interlock on global seed, but uses thread-static vars which is 10-20 times faster The timestamp is the number of 100ms intervals elapsed since Jan 1 2015 expressed as a 24 bit unsigned int, which gives 2^24 = 16,777,216 combinations which covers 19 days (around 2 weeks) at 100 msec resolution, consequently the ID will generate duplicates after this period. This struct is useful for creating unique IDs for protocol/traffic messages that live for a limited time (no more than 2 weeks). Caution: This ID does not identify the machine or process, only items within the process, however when a hosting process restarts(i.e. crash or reboot) the new IDs will not collide with IDs generated right before the crash for at least 14 days (14 day sliding window). In a parallel test on 6 Core i7 3.2 GHz this class generates 405 million IDs/sec, which is 57 times faster than Guid that only generates 7 million IDs/sec

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public struct FID : IEquatable<FID>, IDistributedStableHashProvider
[SerializableAttribute]
public struct FID : IEquatable<FID>, IDistributedStableHashProvider
<SerializableAttribute>
Public Structure FID
    Implements IEquatable(Of FID), IDistributedStableHashProvider
<SerializableAttribute>
Public Structure FID
    Implements IEquatable(Of FID), IDistributedStableHashProvider
[SerializableAttribute]
public value class FID : IEquatable<FID>,
    IDistributedStableHashProvider
[SerializableAttribute]
public value class FID : IEquatable<FID>,
    IDistributedStableHashProvider
[<SealedAttribute>]
[<SerializableAttribute>]
type FID =
    struct
        interface IEquatable<FID>
        interface IDistributedStableHashProvider
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type FID =
    struct
        interface IEquatable<FID>
        interface IDistributedStableHashProvider
    end
See Also
FID Members
NFX Namespace


FID Members

FID Members NFX Class Library

The FID type exposes the following members.
Constructors
 | Name | Description
Public method | FID | Creates instance from ULONG value. Use FID.Generate() to create new IDs instead
Back to Top
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(FID) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | Generate | Generates new process-wide unique ID which is unique for up to 2 weeks
Public method | GetDistributedStableHash |
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToGuid | Converts to Guid by copying ID twice
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | ID | Returns 64 bit process-wide unique ID which is unique for up to 2 weeks
Back to Top
See Also
FID Structure
NFX Namespace


FID Constructor

FID Constructor NFX Class Library

Creates instance from ULONG value. Use FID.Generate() to create new IDs instead

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FID(
    ulong id
)
public FID(
    ulong id
)
Public Sub New (
    id As ULong
)
Public Sub New (
    id As ULong
)
public:
FID(
    unsigned long long id
)
public:
FID(
    unsigned long long id
)
new :
        id : uint64 -> FID
new :
        id : uint64 -> FID

Parameters

id
Type: Online System UInt64
See Also
FID Structure
FID Members
NFX Namespace


FID Fields

FID Fields NFX Class Library

The FID type exposes the following members.
Fields
 | Name | Description
Public field | ID | Returns 64 bit process-wide unique ID which is unique for up to 2 weeks
Back to Top
See Also
FID Structure
NFX Namespace


FID.ID Field

FID ID Field NFX Class Library

Returns 64 bit process-wide unique ID which is unique for up to 2 weeks

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ulong ID
public readonly ulong ID
Public ReadOnly ID As ULong
Public ReadOnly ID As ULong
public:
initonly unsigned long long ID
public:
initonly unsigned long long ID
val ID: uint64
val ID: uint64

Field Value

Type: Online UInt64
See Also
FID Structure
FID Members
NFX Namespace


FID Methods

FID Methods NFX Class Library

The FID type exposes the following members.
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(FID) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | Generate | Generates new process-wide unique ID which is unique for up to 2 weeks
Public method | GetDistributedStableHash |
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToGuid | Converts to Guid by copying ID twice
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
FID Structure
NFX Namespace


FID.Equals Method

FID Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(FID) |
Back to Top
See Also
FID Structure
FID Members
NFX Namespace


FID.Equals Method (Object)

FID Equals Method (Object) NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
FID Structure
FID Members
Equals Overload
NFX Namespace


FID.Equals Method (FID)

FID Equals Method (FID) NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    FID other
)
public bool Equals(
    FID other
)
Public Function Equals (
    other As FID
) As Boolean
Public Function Equals (
    other As FID
) As Boolean
public:
virtual bool Equals(
    FID other
) sealed
public:
virtual bool Equals(
    FID other
) sealed
abstract Equals :
        other : FID -> bool
override Equals :
        other : FID -> bool
abstract Equals :
        other : FID -> bool
override Equals :
        other : FID -> bool

Parameters

other
Type: NFX FID

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
FID Structure
FID Members
Equals Overload
NFX Namespace


FID.Generate Method

FID Generate Method NFX Class Library

Generates new process-wide unique ID which is unique for up to 2 weeks

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FID Generate()
public static FID Generate()
Public Shared Function Generate As FID
Public Shared Function Generate As FID
public:
static FID Generate()
public:
static FID Generate()
static member Generate : unit -> FID
static member Generate : unit -> FID

Return Value

Type: FID
See Also
FID Structure
FID Members
NFX Namespace


FID.GetDistributedStableHash Method

FID GetDistributedStableHash Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong GetDistributedStableHash()
public ulong GetDistributedStableHash()
Public Function GetDistributedStableHash As ULong
Public Function GetDistributedStableHash As ULong
public:
virtual unsigned long long GetDistributedStableHash() sealed
public:
virtual unsigned long long GetDistributedStableHash() sealed
abstract GetDistributedStableHash : unit -> uint64
override GetDistributedStableHash : unit -> uint64
abstract GetDistributedStableHash : unit -> uint64
override GetDistributedStableHash : unit -> uint64

Return Value

Type: Online UInt64

Implements

IDistributedStableHashProvider GetDistributedStableHash
See Also
FID Structure
FID Members
NFX Namespace


FID.GetHashCode Method

FID GetHashCode Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
FID Structure
FID Members
NFX Namespace


FID.ToGuid Method

FID ToGuid Method NFX Class Library

Converts to Guid by copying ID twice

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid ToGuid()
public Guid ToGuid()
Public Function ToGuid As Guid
Public Function ToGuid As Guid
public:
Guid ToGuid()
public:
Guid ToGuid()
member ToGuid : unit -> Guid
member ToGuid : unit -> Guid

Return Value

Type: Online Guid
See Also
FID Structure
FID Members
NFX Namespace


FID.ToString Method

FID ToString Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
FID Structure
FID Members
NFX Namespace


IEndableInstance Interface

IEndableInstance Interface NFX Class Library

Describes an entity that can request some hosting container to end its lifetime by calling End() method

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IEndableInstance
public interface IEndableInstance
Public Interface IEndableInstance
Public Interface IEndableInstance
public interface class IEndableInstance
public interface class IEndableInstance
type IEndableInstance =  interface end
type IEndableInstance =  interface end
See Also
IEndableInstance Members
NFX Namespace


IEndableInstance Members

IEndableInstance Members NFX Class Library

The IEndableInstance type exposes the following members.
Methods
 | Name | Description
Public method | End | Requests container that hosts.runs this entity to end its instance
Back to Top
Properties
 | Name | Description
Public property | IsEnded | Indicates whether this instance was requested to be ended and will get destoyed by the hosting container
Back to Top
See Also
IEndableInstance Interface
NFX Namespace


IEndableInstance Methods

IEndableInstance Methods NFX Class Library

The IEndableInstance type exposes the following members.
Methods
 | Name | Description
Public method | End | Requests container that hosts.runs this entity to end its instance
Back to Top
See Also
IEndableInstance Interface
NFX Namespace


IEndableInstance.End Method

IEndableInstance End Method NFX Class Library

Requests container that hosts.runs this entity to end its instance

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void End()
void End()
Sub End
Sub End
void End()
void End()
abstract End : unit -> unit
abstract End : unit -> unit
See Also
IEndableInstance Interface
IEndableInstance Members
NFX Namespace


IEndableInstance Properties

IEndableInstance Properties NFX Class Library

The IEndableInstance type exposes the following members.
Properties
 | Name | Description
Public property | IsEnded | Indicates whether this instance was requested to be ended and will get destoyed by the hosting container
Back to Top
See Also
IEndableInstance Interface
NFX Namespace


IEndableInstance.IsEnded Property

IEndableInstance IsEnded Property NFX Class Library

Indicates whether this instance was requested to be ended and will get destoyed by the hosting container

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsEnded { get; }
bool IsEnded { get; }
ReadOnly Property IsEnded As Boolean
    Get
ReadOnly Property IsEnded As Boolean
    Get
property bool IsEnded {
    bool get ();
}
property bool IsEnded {
    bool get ();
}
abstract IsEnded : bool with get
abstract IsEnded : bool with get

Property Value

Type: Online Boolean
See Also
IEndableInstance Interface
IEndableInstance Members
NFX Namespace


IExternallyParameterized Interface

IExternallyParameterized Interface NFX Class Library

Denotes an entity that has external parameters that can be get/set

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IExternallyParameterized
public interface IExternallyParameterized
Public Interface IExternallyParameterized
Public Interface IExternallyParameterized
public interface class IExternallyParameterized
public interface class IExternallyParameterized
type IExternallyParameterized =  interface end
type IExternallyParameterized =  interface end
See Also
IExternallyParameterized Members
NFX Namespace


IExternallyParameterized Members

IExternallyParameterized Members NFX Class Library

The IExternallyParameterized type exposes the following members.
Methods
 | Name | Description
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded
Back to Top
Properties
 | Name | Description
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle
Back to Top
See Also
IExternallyParameterized Interface
NFX Namespace


IExternallyParameterized Methods

IExternallyParameterized Methods NFX Class Library

The IExternallyParameterized type exposes the following members.
Methods
 | Name | Description
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded
Back to Top
See Also
IExternallyParameterized Interface
NFX Namespace


IExternallyParameterized.ExternalGetParameter Method

IExternallyParameterized ExternalGetParameter Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets external parameter value returning true if parameter was found

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
)
bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
)
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean
See Also
IExternallyParameterized Interface
IExternallyParameterized Members
NFX Namespace


IExternallyParameterized.ExternalParametersForGroups Method

IExternallyParameterized ExternalParametersForGroups Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets names of supported external parameters or null if parameters are not supported in principle

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
)
IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
)
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>

Parameters

groups
Type: Online System String

Return Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type
See Also
IExternallyParameterized Interface
IExternallyParameterized Members
NFX Namespace


IExternallyParameterized.ExternalSetParameter Method

IExternallyParameterized ExternalSetParameter Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Sets external parameter value, true if parameter name was found and set succeeded

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
)
bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
)
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean
See Also
IExternallyParameterized Interface
IExternallyParameterized Members
NFX Namespace


IExternallyParameterized Properties

IExternallyParameterized Properties NFX Class Library

The IExternallyParameterized type exposes the following members.
Properties
 | Name | Description
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle
Back to Top
See Also
IExternallyParameterized Interface
NFX Namespace


IExternallyParameterized.ExternalParameters Property

IExternallyParameterized ExternalParameters Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets names/types of supported external parameters or null if parameters are not supported in principle

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get ();
}
property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get ();
}
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get

Property Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type
See Also
IExternallyParameterized Interface
IExternallyParameterized Members
NFX Namespace


INamed Interface

INamed Interface NFX Class Library

Denotes an entity that has a Name property. This interface is primarily used with Registry[INamed] class that allows for string-based addressing (getting instances by object instance name). The names are ideal for many system functions, like naming components in configs and admin tools

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface INamed
public interface INamed
Public Interface INamed
Public Interface INamed
public interface class INamed
public interface class INamed
type INamed =  interface end
type INamed =  interface end
See Also
INamed Members
NFX Namespace


INamed Members

INamed Members NFX Class Library

The INamed type exposes the following members.
Properties
 | Name | Description
Public property | Name |
Back to Top
See Also
INamed Interface
NFX Namespace


INamed Properties

INamed Properties NFX Class Library

The INamed type exposes the following members.
Properties
 | Name | Description
Public property | Name |
Back to Top
See Also
INamed Interface
NFX Namespace


INamed.Name Property

INamed Name Property NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Name { get; }
string Name { get; }
ReadOnly Property Name As String
    Get
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
property String^ Name {
    String^ get ();
}
abstract Name : string with get
abstract Name : string with get

Property Value

Type: Online String
See Also
INamed Interface
INamed Members
NFX Namespace


IntMath Class

IntMath Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX IntMath

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class IntMath
public static class IntMath
Public NotInheritable Class IntMath
Public NotInheritable Class IntMath
public ref class IntMath abstract sealed
public ref class IntMath abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type IntMath =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type IntMath =  class end
See Also
IntMath Members
NFX Namespace


IntMath Members

IntMath Members NFX Class Library

The IntMath type exposes the following members.
Methods
Name | Description
Align16(Int32) | Returns argument increased to the nearest number divisible by 16
Align16(Int64) | Returns argument increased to the nearest number divisible by 16
Align8(Int32) | Returns argument increased to the nearest number divisible by 8
Align8(Int64) | Returns argument increased to the nearest number divisible by 8
GetAdjacentPrimeNumberLessThanOrEqualTo | Gets adjacent prime number which is less than or equal to the specified number. Arguments less than 3 yield 2;
GetCapacityFactoredToPrime | Increases a capacity to a prime number by the factor. Both numbers must be positive
GetPrimeCapacityOfAtLeast | Gets the capacity of at least or larger larger than the specified number. For numbers <= 16300007 the function uses lookup table for speed
IsPrime | Tests if the number is prime
Log |
MinMax |
Pow |
UpperLog |
UpperPow |
Back to Top
Fields
Name | Description
PRIME_CAPACITIES |
Back to Top
See Also
IntMath Class
NFX Namespace


IntMath Fields

IntMath Fields NFX Class Library

The IntMath type exposes the following members.
Fields
Name | Description
PRIME_CAPACITIES |
Back to Top
See Also
IntMath Class
NFX Namespace


IntMath.PRIME_CAPACITIES Field

IntMath PRIME_CAPACITIES Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly int[] PRIME_CAPACITIES
public static readonly int[] PRIME_CAPACITIES
Public Shared ReadOnly PRIME_CAPACITIES As Integer()
Public Shared ReadOnly PRIME_CAPACITIES As Integer()
public:
static initonly array<int>^ PRIME_CAPACITIES
public:
static initonly array<int>^ PRIME_CAPACITIES
static val PRIME_CAPACITIES: int[]
static val PRIME_CAPACITIES: int[]

Field Value

Type: Online Int32
See Also
IntMath Class
IntMath Members
NFX Namespace


IntMath Methods

IntMath Methods NFX Class Library

The IntMath type exposes the following members.
Methods
Name | Description
Align16(Int32) | Returns argument increased to the nearest number divisible by 16
Align16(Int64) | Returns argument increased to the nearest number divisible by 16
Align8(Int32) | Returns argument increased to the nearest number divisible by 8
Align8(Int64) | Returns argument increased to the nearest number divisible by 8
GetAdjacentPrimeNumberLessThanOrEqualTo | Gets adjacent prime number which is less than or equal to the specified number. Arguments less than 3 yield 2;
GetCapacityFactoredToPrime | Increases a capacity to a prime number by the factor. Both numbers must be positive
GetPrimeCapacityOfAtLeast | Gets the capacity of at least or larger larger than the specified number. For numbers <= 16300007 the function uses lookup table for speed
IsPrime | Tests if the number is prime
Log |
MinMax |
Pow |
UpperLog |
UpperPow |
Back to Top
See Also
IntMath Class
NFX Namespace


IntMath.Align16 Method

IntMath Align16 Method NFX Class Library

Overload List
Name | Description
Align16(Int32) | Returns argument increased to the nearest number divisible by 16
Align16(Int64) | Returns argument increased to the nearest number divisible by 16
Back to Top
See Also
IntMath Class
IntMath Members
NFX Namespace


IntMath.Align16 Method (Int32)

IntMath Align16 Method (Int32) NFX Class Library

Returns argument increased to the nearest number divisible by 16

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Align16(
    int i
)
public static int Align16(
    int i
)
Public Shared Function Align16 (
    i As Integer
) As Integer
Public Shared Function Align16 (
    i As Integer
) As Integer
public:
static int Align16(
    int i
)
public:
static int Align16(
    int i
)
static member Align16 :
        i : int -> int
static member Align16 :
        i : int -> int

Parameters

i
Type: Online System Int32

Return Value

Type: Online Int32
See Also
IntMath Class
IntMath Members
Align16 Overload
NFX Namespace


IntMath.Align16 Method (Int64)

IntMath Align16 Method (Int64) NFX Class Library

Returns argument increased to the nearest number divisible by 16

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long Align16(
    long i
)
public static long Align16(
    long i
)
Public Shared Function Align16 (
    i As Long
) As Long
Public Shared Function Align16 (
    i As Long
) As Long
public:
static long long Align16(
    long long i
)
public:
static long long Align16(
    long long i
)
static member Align16 :
        i : int64 -> int64
static member Align16 :
        i : int64 -> int64

Parameters

i
Type: Online System Int64

Return Value

Type: Online Int64
See Also
IntMath Class
IntMath Members
Align16 Overload
NFX Namespace


IntMath.Align8 Method

IntMath Align8 Method NFX Class Library

Overload List
Name | Description
Align8(Int32) | Returns argument increased to the nearest number divisible by 8
Align8(Int64) | Returns argument increased to the nearest number divisible by 8
Back to Top
See Also
IntMath Class
IntMath Members
NFX Namespace


IntMath.Align8 Method (Int32)

IntMath Align8 Method (Int32) NFX Class Library

Returns argument increased to the nearest number divisible by 8

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Align8(
    int i
)
public static int Align8(
    int i
)
Public Shared Function Align8 (
    i As Integer
) As Integer
Public Shared Function Align8 (
    i As Integer
) As Integer
public:
static int Align8(
    int i
)
public:
static int Align8(
    int i
)
static member Align8 :
        i : int -> int
static member Align8 :
        i : int -> int

Parameters

i
Type: Online System Int32

Return Value

Type: Online Int32
See Also
IntMath Class
IntMath Members
Align8 Overload
NFX Namespace


IntMath.Align8 Method (Int64)

IntMath Align8 Method (Int64) NFX Class Library

Returns argument increased to the nearest number divisible by 8

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long Align8(
    long i
)
public static long Align8(
    long i
)
Public Shared Function Align8 (
    i As Long
) As Long
Public Shared Function Align8 (
    i As Long
) As Long
public:
static long long Align8(
    long long i
)
public:
static long long Align8(
    long long i
)
static member Align8 :
        i : int64 -> int64
static member Align8 :
        i : int64 -> int64

Parameters

i
Type: Online System Int64

Return Value

Type: Online Int64
See Also
IntMath Class
IntMath Members
Align8 Overload
NFX Namespace


IntMath.GetAdjacentPrimeNumberLessThanOrEqualTo Method

IntMath GetAdjacentPrimeNumberLessThanOrEqualTo Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets adjacent prime number which is less than or equal to the specified number. Arguments less than 3 yield 2;

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int GetAdjacentPrimeNumberLessThanOrEqualTo(
    int number
)
public static int GetAdjacentPrimeNumberLessThanOrEqualTo(
    int number
)
Public Shared Function GetAdjacentPrimeNumberLessThanOrEqualTo (
    number As Integer
) As Integer
Public Shared Function GetAdjacentPrimeNumberLessThanOrEqualTo (
    number As Integer
) As Integer
public:
static int GetAdjacentPrimeNumberLessThanOrEqualTo(
    int number
)
public:
static int GetAdjacentPrimeNumberLessThanOrEqualTo(
    int number
)
static member GetAdjacentPrimeNumberLessThanOrEqualTo :
        number : int -> int
static member GetAdjacentPrimeNumberLessThanOrEqualTo :
        number : int -> int

Parameters

number
Type: Online System Int32

Return Value

Type: Online Int32
See Also
IntMath Class
IntMath Members
NFX Namespace


IntMath.GetCapacityFactoredToPrime Method

IntMath GetCapacityFactoredToPrime Method NFX Class Library

Increases a capacity to a prime number by the factor. Both numbers must be positive

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int GetCapacityFactoredToPrime(
    int capacity,
    double factor
)
public static int GetCapacityFactoredToPrime(
    int capacity,
    double factor
)
Public Shared Function GetCapacityFactoredToPrime (
    capacity As Integer,
    factor As Double
) As Integer
Public Shared Function GetCapacityFactoredToPrime (
    capacity As Integer,
    factor As Double
) As Integer
public:
static int GetCapacityFactoredToPrime(
    int capacity,
    double factor
)
public:
static int GetCapacityFactoredToPrime(
    int capacity,
    double factor
)
static member GetCapacityFactoredToPrime :
        capacity : int *
        factor : float -> int
static member GetCapacityFactoredToPrime :
        capacity : int *
        factor : float -> int

Parameters

capacity
Type: Online System Int32
factor
Type: Online System Double

Return Value

Type: Online Int32
See Also
IntMath Class
IntMath Members
NFX Namespace


IntMath.GetPrimeCapacityOfAtLeast Method

IntMath GetPrimeCapacityOfAtLeast Method NFX Class Library

Gets the capacity of at least or larger larger than the specified number. For numbers <= 16300007 the function uses lookup table for speed

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int GetPrimeCapacityOfAtLeast(
    int capacity
)
public static int GetPrimeCapacityOfAtLeast(
    int capacity
)
Public Shared Function GetPrimeCapacityOfAtLeast (
    capacity As Integer
) As Integer
Public Shared Function GetPrimeCapacityOfAtLeast (
    capacity As Integer
) As Integer
public:
static int GetPrimeCapacityOfAtLeast(
    int capacity
)
public:
static int GetPrimeCapacityOfAtLeast(
    int capacity
)
static member GetPrimeCapacityOfAtLeast :
        capacity : int -> int
static member GetPrimeCapacityOfAtLeast :
        capacity : int -> int

Parameters

capacity
Type: Online System Int32

Return Value

Type: Online Int32
See Also
IntMath Class
IntMath Members
NFX Namespace


IntMath.IsPrime Method

IntMath IsPrime Method NFX Class Library

Tests if the number is prime

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsPrime(
    int number
)
public static bool IsPrime(
    int number
)
Public Shared Function IsPrime (
    number As Integer
) As Boolean
Public Shared Function IsPrime (
    number As Integer
) As Boolean
public:
static bool IsPrime(
    int number
)
public:
static bool IsPrime(
    int number
)
static member IsPrime :
        number : int -> bool
static member IsPrime :
        number : int -> bool

Parameters

number
Type: Online System Int32

Return Value

Type: Online Boolean
See Also
IntMath Class
IntMath Members
NFX Namespace


IntMath.Log Method

IntMath Log Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Log(
    long n,
    int logBase = 2
)
public static int Log(
    long n,
    int logBase = 2
)
Public Shared Function Log (
    n As Long,
    Optional logBase As Integer = 2
) As Integer
Public Shared Function Log (
    n As Long,
    Optional logBase As Integer = 2
) As Integer
public:
static int Log(
    long long n,
    int logBase = 2
)
public:
static int Log(
    long long n,
    int logBase = 2
)
static member Log :
        n : int64 *
        ?logBase : int
(* Defaults:
        let _logBase = defaultArg logBase 2
*)
-> int
static member Log :
        n : int64 *
        ?logBase : int
(* Defaults:
        let _logBase = defaultArg logBase 2
*)
-> int

Parameters

n
Type: Online System Int64
logBase (Optional)
Type: Online System Int32

Return Value

Type: Online Int32
See Also
IntMath Class
IntMath Members
NFX Namespace


IntMath.MinMax Method

IntMath MinMax Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int MinMax(
    int min,
    int value,
    int max
)
public static int MinMax(
    int min,
    int value,
    int max
)
Public Shared Function MinMax (
    min As Integer,
    value As Integer,
    max As Integer
) As Integer
Public Shared Function MinMax (
    min As Integer,
    value As Integer,
    max As Integer
) As Integer
public:
static int MinMax(
    int min,
    int value,
    int max
)
public:
static int MinMax(
    int min,
    int value,
    int max
)
static member MinMax :
        min : int *
        value : int *
        max : int -> int
static member MinMax :
        min : int *
        value : int *
        max : int -> int

Parameters

min
Type: Online System Int32
value
Type: Online System Int32
max
Type: Online System Int32

Return Value

Type: Online Int32
See Also
IntMath Class
IntMath Members
NFX Namespace


IntMath.Pow Method

IntMath Pow Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long Pow(
    long n,
    int power
)
public static long Pow(
    long n,
    int power
)
Public Shared Function Pow (
    n As Long,
    power As Integer
) As Long
Public Shared Function Pow (
    n As Long,
    power As Integer
) As Long
public:
static long long Pow(
    long long n,
    int power
)
public:
static long long Pow(
    long long n,
    int power
)
static member Pow :
        n : int64 *
        power : int -> int64
static member Pow :
        n : int64 *
        power : int -> int64

Parameters

n
Type: Online System Int64
power
Type: Online System Int32

Return Value

Type: Online Int64
See Also
IntMath Class
IntMath Members
NFX Namespace


IntMath.UpperLog Method

IntMath UpperLog Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int UpperLog(
    long n,
    int logBase = 2
)
public static int UpperLog(
    long n,
    int logBase = 2
)
Public Shared Function UpperLog (
    n As Long,
    Optional logBase As Integer = 2
) As Integer
Public Shared Function UpperLog (
    n As Long,
    Optional logBase As Integer = 2
) As Integer
public:
static int UpperLog(
    long long n,
    int logBase = 2
)
public:
static int UpperLog(
    long long n,
    int logBase = 2
)
static member UpperLog :
        n : int64 *
        ?logBase : int
(* Defaults:
        let _logBase = defaultArg logBase 2
*)
-> int
static member UpperLog :
        n : int64 *
        ?logBase : int
(* Defaults:
        let _logBase = defaultArg logBase 2
*)
-> int

Parameters

n
Type: Online System Int64
logBase (Optional)
Type: Online System Int32

Return Value

Type: Online Int32
See Also
IntMath Class
IntMath Members
NFX Namespace


IntMath.UpperPow Method

IntMath UpperPow Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long UpperPow(
    int n,
    int powBase = 2
)
public static long UpperPow(
    int n,
    int powBase = 2
)
Public Shared Function UpperPow (
    n As Integer,
    Optional powBase As Integer = 2
) As Long
Public Shared Function UpperPow (
    n As Integer,
    Optional powBase As Integer = 2
) As Long
public:
static long long UpperPow(
    int n,
    int powBase = 2
)
public:
static long long UpperPow(
    int n,
    int powBase = 2
)
static member UpperPow :
        n : int *
        ?powBase : int
(* Defaults:
        let _powBase = defaultArg powBase 2
*)
-> int64
static member UpperPow :
        n : int *
        ?powBase : int
(* Defaults:
        let _powBase = defaultArg powBase 2
*)
-> int64

Parameters

n
Type: Online System Int32
powBase (Optional)
Type: Online System Int32

Return Value

Type: Online Int64
See Also
IntMath Class
IntMath Members
NFX Namespace


IOMiscUtils Class

IOMiscUtils Class NFX Class Library

Misc utils for I/O
Inheritance Hierarchy
Online System Object
NFX IOMiscUtils

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class IOMiscUtils
public static class IOMiscUtils
<ExtensionAttribute>
Public NotInheritable Class IOMiscUtils
<ExtensionAttribute>
Public NotInheritable Class IOMiscUtils
[ExtensionAttribute]
public ref class IOMiscUtils abstract sealed
[ExtensionAttribute]
public ref class IOMiscUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type IOMiscUtils =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type IOMiscUtils =  class end
See Also
IOMiscUtils Members
NFX Namespace


IOMiscUtils Members

IOMiscUtils Members NFX Class Library

The IOMiscUtils type exposes the following members.
Methods
Name | Description
AsCharEnumerable(Stream) |
AsCharEnumerable(TextReader) |
CopyStream | Copies one stream into another using temp buffer
EnsureAccessibleDirectory | Creates directory and immediately grants it accessibility rules for everyone if it does not exists, or returns the existing directory
EnsureDirectoryDeleted | Tries to delete the specified directory if it exists BLOCKING for up to the specified interval until directory is PHYSICALLY deleted. Returns true when directory either did not exist in the first place or was successfully deleted (with confirmation). Returns false when directory could not be confirmed to be deleted within the specified timeout, this does not mean that the OS will not delete the directory later, so calling this function in a loop is expected. NOTE: Directory.Delete() does not guarantee that directory is no longer on disk upon its return
EnsureFileEventuallyDeleted | Deleted file if it exists - does not block until file is deleted, the behavior is up to the OS
GetURL | Fetch the content of a given URL.
MemBufferEquals | Returns true if both buffers contain the same number of the same bytes. The implementation uses quad-word comparison as much as possible for speed. Requires UNSAFE switch
NormalizeCenteredImage | Scales source image so it fits in the desired image size preserving aspect ratio. This function is usable for profile picture size/aspect normalization
PackISO3CodeToInt | Represents an ISO code as 4 byte integer filled with up to 3 ASCII chars converted to upper case, the highest byte is free to be used by the application
ReadBEInt32( Byte ) | Reads an integer encoded as big endian from buffer at index 0
ReadBEInt32(Stream) | Reads an integer encoded as big endian from buffer at the specified index
ReadBEInt32( Byte , Int32 ) | Reads an integer encoded as big endian from buffer at the specified index and increments the idx by the number of bytes read
ReadBEInt32( Byte , Int64 ) | Reads an integer encoded as big endian from buffer at the specified index and increments the idx by the number of bytes read
ReadBEShort(Stream) | Reads a short encoded as big endian from stream
ReadBEShort( Byte , Int32 ) | Reads a short encoded as big endian from buffer at the specified index
ReadBEUInt32( Byte ) | Reads an unsigned integer encoded as big endian from buffer at index 0
ReadBEUInt32( Byte , Int32 ) | Reads an unsigned integer encoded as big endian from buffer at the specified index and increments the idx by the number of bytes read
ReadBEUInt32( Byte , Int64 ) | Reads an unsigned integer encoded as big endian from buffer at the specified index and increments the idx by the number of bytes read
ReadBEUInt64(Stream) | Reads an integer encoded as big endian from buffer at the specified index
ReadBEUInt64( Byte , Int32) | Reads an integer encoded as big endian from buffer at the specified index and increments the idx by the number of bytes read
ReadBEUInt64( Byte , Int32 ) | Reads an integer encoded as big endian from buffer at the specified index and increments the idx by the number of bytes read
ReadBEUShort | Reads an ushort encoded as big endian from stream
ReadLine | Reads first line from the string
UnpackISO3CodeFromInt | Unpacks an ISO code from int which was packed with PackISO3CodeToInt
WriteBEInt32( Byte , Int32) | Writes an integer encoded as big endian to buffer at index 0
WriteBEInt32(Stream, Int32) | Writes an integer encoded as big endian to the given stream
WriteBEInt32( Byte , Int32, Int32) | Writes an integer encoded as big endian to buffer at the specified index
WriteBEShort(Stream, Int16) | Writes a short encoded as big endian to the given stream
WriteBEShort( Byte , Int32, Int16) | Writes a short encoded as big endian to buffer at the specified index
WriteBEUInt32( Byte , UInt32) | Writes an unsigned integer encoded as big endian to buffer at index 0
WriteBEUInt32( Byte , Int32, UInt32) | Writes an unsigned integer encoded as big endian to buffer at the specified index
WriteBEUInt64( Byte , UInt64) | Writes an unsigned long integer encoded as big endian to buffer at the beginning
WriteBEUInt64(Stream, UInt64) | Writes an unsigned long integer encoded as big endian to the given stream
WriteBEUInt64( Byte , Int32, UInt64) | Writes an unsigned long integer encoded as big endian to buffer at the specified index
WriteBEUShort | Writes an ushort encoded as big endian to the given stream
Back to Top
Fields
Name | Description
IO_WAIT_DEFAULT_TIMEOUT |
IO_WAIT_GRANULARITY_MS |
IO_WAIT_MIN_TIMEOUT |
Back to Top
See Also
IOMiscUtils Class
NFX Namespace


IOMiscUtils Fields

IOMiscUtils Fields NFX Class Library

The IOMiscUtils type exposes the following members.
Fields
Name | Description
IO_WAIT_DEFAULT_TIMEOUT |
IO_WAIT_GRANULARITY_MS |
IO_WAIT_MIN_TIMEOUT |
Back to Top
See Also
IOMiscUtils Class
NFX Namespace


IOMiscUtils.IO_WAIT_DEFAULT_TIMEOUT Field

IOMiscUtils IO_WAIT_DEFAULT_TIMEOUT Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int IO_WAIT_DEFAULT_TIMEOUT
public const int IO_WAIT_DEFAULT_TIMEOUT
Public Const IO_WAIT_DEFAULT_TIMEOUT As Integer
Public Const IO_WAIT_DEFAULT_TIMEOUT As Integer
public:
literal int IO_WAIT_DEFAULT_TIMEOUT
public:
literal int IO_WAIT_DEFAULT_TIMEOUT
static val mutable IO_WAIT_DEFAULT_TIMEOUT: int
static val mutable IO_WAIT_DEFAULT_TIMEOUT: int

Field Value

Type: Online Int32
See Also
IOMiscUtils Class
IOMiscUtils Members
NFX Namespace


IOMiscUtils.IO_WAIT_GRANULARITY_MS Field

IOMiscUtils IO_WAIT_GRANULARITY_MS Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int IO_WAIT_GRANULARITY_MS
public const int IO_WAIT_GRANULARITY_MS
Public Const IO_WAIT_GRANULARITY_MS As Integer
Public Const IO_WAIT_GRANULARITY_MS As Integer
public:
literal int IO_WAIT_GRANULARITY_MS
public:
literal int IO_WAIT_GRANULARITY_MS
static val mutable IO_WAIT_GRANULARITY_MS: int
static val mutable IO_WAIT_GRANULARITY_MS: int

Field Value

Type: Online Int32
See Also
IOMiscUtils Class
IOMiscUtils Members
NFX Namespace


IOMiscUtils.IO_WAIT_MIN_TIMEOUT Field

IOMiscUtils IO_WAIT_MIN_TIMEOUT Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int IO_WAIT_MIN_TIMEOUT
public const int IO_WAIT_MIN_TIMEOUT
Public Const IO_WAIT_MIN_TIMEOUT As Integer
Public Const IO_WAIT_MIN_TIMEOUT As Integer
public:
literal int IO_WAIT_MIN_TIMEOUT
public:
literal int IO_WAIT_MIN_TIMEOUT
static val mutable IO_WAIT_MIN_TIMEOUT: int
static val mutable IO_WAIT_MIN_TIMEOUT: int

Field Value

Type: Online Int32
See Also
IOMiscUtils Class
IOMiscUtils Members
NFX Namespace


IOMiscUtils Methods

IOMiscUtils Methods NFX Class Library

The IOMiscUtils type exposes the following members.
Methods
Name | Description
AsCharEnumerable(Stream) |
AsCharEnumerable(TextReader) |
CopyStream | Copies one stream into another using temp buffer
EnsureAccessibleDirectory | Creates directory and immediately grants it accessibility rules for everyone if it does not exists, or returns the existing directory
EnsureDirectoryDeleted | Tries to delete the specified directory if it exists BLOCKING for up to the specified interval until directory is PHYSICALLY deleted. Returns true when directory either did not exist in the first place or was successfully deleted (with confirmation). Returns false when directory could not be confirmed to be deleted within the specified timeout, this does not mean that the OS will not delete the directory later, so calling this function in a loop is expected. NOTE: Directory.Delete() does not guarantee that directory is no longer on disk upon its return
EnsureFileEventuallyDeleted | Deleted file if it exists - does not block until file is deleted, the behavior is up to the OS
GetURL | Fetch the content of a given URL.
MemBufferEquals | Returns true if both buffers contain the same number of the same bytes. The implementation uses quad-word comparison as much as possible for speed. Requires UNSAFE switch
NormalizeCenteredImage | Scales source image so it fits in the desired image size preserving aspect ratio. This function is usable for profile picture size/aspect normalization
PackISO3CodeToInt | Represents an ISO code as 4 byte integer filled with up to 3 ASCII chars converted to upper case, the highest byte is free to be used by the application
ReadBEInt32( Byte ) | Reads an integer encoded as big endian from buffer at index 0
ReadBEInt32(Stream) | Reads an integer encoded as big endian from buffer at the specified index
ReadBEInt32( Byte , Int32 ) | Reads an integer encoded as big endian from buffer at the specified index and increments the idx by the number of bytes read
ReadBEInt32( Byte , Int64 ) | Reads an integer encoded as big endian from buffer at the specified index and increments the idx by the number of bytes read
ReadBEShort(Stream) | Reads a short encoded as big endian from stream
ReadBEShort( Byte , Int32 ) | Reads a short encoded as big endian from buffer at the specified index
ReadBEUInt32( Byte ) | Reads an unsigned integer encoded as big endian from buffer at index 0
ReadBEUInt32( Byte , Int32 ) | Reads an unsigned integer encoded as big endian from buffer at the specified index and increments the idx by the number of bytes read
ReadBEUInt32( Byte , Int64 ) | Reads an unsigned integer encoded as big endian from buffer at the specified index and increments the idx by the number of bytes read
ReadBEUInt64(Stream) | Reads an integer encoded as big endian from buffer at the specified index
ReadBEUInt64( Byte , Int32) | Reads an integer encoded as big endian from buffer at the specified index and increments the idx by the number of bytes read
ReadBEUInt64( Byte , Int32 ) | Reads an integer encoded as big endian from buffer at the specified index and increments the idx by the number of bytes read
ReadBEUShort | Reads an ushort encoded as big endian from stream
ReadLine | Reads first line from the string
UnpackISO3CodeFromInt | Unpacks an ISO code from int which was packed with PackISO3CodeToInt
WriteBEInt32( Byte , Int32) | Writes an integer encoded as big endian to buffer at index 0
WriteBEInt32(Stream, Int32) | Writes an integer encoded as big endian to the given stream
WriteBEInt32( Byte , Int32, Int32) | Writes an integer encoded as big endian to buffer at the specified index
WriteBEShort(Stream, Int16) | Writes a short encoded as big endian to the given stream
WriteBEShort( Byte , Int32, Int16) | Writes a short encoded as big endian to buffer at the specified index
WriteBEUInt32( Byte , UInt32) | Writes an unsigned integer encoded as big endian to buffer at index 0
WriteBEUInt32( Byte , Int32, UInt32) | Writes an unsigned integer encoded as big endian to buffer at the specified index
WriteBEUInt64( Byte , UInt64) | Writes an unsigned long integer encoded as big endian to buffer at the beginning
WriteBEUInt64(Stream, UInt64) | Writes an unsigned long integer encoded as big endian to the given stream
WriteBEUInt64( Byte , Int32, UInt64) | Writes an unsigned long integer encoded as big endian to buffer at the specified index
WriteBEUShort | Writes an ushort encoded as big endian to the given stream
Back to Top
See Also
IOMiscUtils Class
NFX Namespace


IOMiscUtils.AsCharEnumerable Method

IOMiscUtils AsCharEnumerable Method NFX Class Library

Overload List
Name | Description
AsCharEnumerable(Stream) |
AsCharEnumerable(TextReader) |
Back to Top
See Also
IOMiscUtils Class
IOMiscUtils Members
NFX Namespace


IOMiscUtils.AsCharEnumerable Method (Stream)

IOMiscUtils AsCharEnumerable Method (Stream) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<char> AsCharEnumerable(
    this Stream stream
)
public static IEnumerable<char> AsCharEnumerable(
    this Stream stream
)
<ExtensionAttribute>
Public Shared Function AsCharEnumerable (
    stream As Stream
) As IEnumerable(Of Char)
<ExtensionAttribute>
Public Shared Function AsCharEnumerable (
    stream As Stream
) As IEnumerable(Of Char)
public:
[ExtensionAttribute]
static IEnumerable<wchar_t>^ AsCharEnumerable(
    Stream^ stream
)
public:
[ExtensionAttribute]
static IEnumerable<wchar_t>^ AsCharEnumerable(
    Stream^ stream
)
static member AsCharEnumerable :
        stream : Stream -> IEnumerable<char>
static member AsCharEnumerable :
        stream : Stream -> IEnumerable<char>

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online IEnumerable Online Char

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
AsCharEnumerable Overload
NFX Namespace


IOMiscUtils.AsCharEnumerable Method (TextReader)

IOMiscUtils AsCharEnumerable Method (TextReader) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<char> AsCharEnumerable(
    this TextReader reader
)
public static IEnumerable<char> AsCharEnumerable(
    this TextReader reader
)
<ExtensionAttribute>
Public Shared Function AsCharEnumerable (
    reader As TextReader
) As IEnumerable(Of Char)
<ExtensionAttribute>
Public Shared Function AsCharEnumerable (
    reader As TextReader
) As IEnumerable(Of Char)
public:
[ExtensionAttribute]
static IEnumerable<wchar_t>^ AsCharEnumerable(
    TextReader^ reader
)
public:
[ExtensionAttribute]
static IEnumerable<wchar_t>^ AsCharEnumerable(
    TextReader^ reader
)
static member AsCharEnumerable :
        reader : TextReader -> IEnumerable<char>
static member AsCharEnumerable :
        reader : TextReader -> IEnumerable<char>

Parameters

reader
Type: Online System.IO TextReader

Return Value

Type: Online IEnumerable Online Char

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online TextReader. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
AsCharEnumerable Overload
NFX Namespace


IOMiscUtils.CopyStream Method

IOMiscUtils CopyStream Method NFX Class Library

Copies one stream into another using temp buffer

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void CopyStream(
    Stream from,
    Stream to
)
public static void CopyStream(
    Stream from,
    Stream to
)
Public Shared Sub CopyStream (
    from As Stream,
    to As Stream
)
Public Shared Sub CopyStream (
    from As Stream,
    to As Stream
)
public:
static void CopyStream(
    Stream^ from,
    Stream^ to
)
public:
static void CopyStream(
    Stream^ from,
    Stream^ to
)
static member CopyStream :
        from : Stream *
        to : Stream -> unit
static member CopyStream :
        from : Stream *
        to : Stream -> unit

Parameters

from
Type: Online System.IO Stream
to
Type: Online System.IO Stream
See Also
IOMiscUtils Class
IOMiscUtils Members
NFX Namespace


IOMiscUtils.EnsureAccessibleDirectory Method

IOMiscUtils EnsureAccessibleDirectory Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates directory and immediately grants it accessibility rules for everyone if it does not exists, or returns the existing directory

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DirectoryInfo EnsureAccessibleDirectory(
    string path
)
public static DirectoryInfo EnsureAccessibleDirectory(
    string path
)
Public Shared Function EnsureAccessibleDirectory (
    path As String
) As DirectoryInfo
Public Shared Function EnsureAccessibleDirectory (
    path As String
) As DirectoryInfo
public:
static DirectoryInfo^ EnsureAccessibleDirectory(
    String^ path
)
public:
static DirectoryInfo^ EnsureAccessibleDirectory(
    String^ path
)
static member EnsureAccessibleDirectory :
        path : string -> DirectoryInfo
static member EnsureAccessibleDirectory :
        path : string -> DirectoryInfo

Parameters

path
Type: Online System String

Return Value

Type: Online DirectoryInfo
See Also
IOMiscUtils Class
IOMiscUtils Members
NFX Namespace


IOMiscUtils.EnsureDirectoryDeleted Method

IOMiscUtils EnsureDirectoryDeleted Method NFX Class Library

Tries to delete the specified directory if it exists BLOCKING for up to the specified interval until directory is PHYSICALLY deleted. Returns true when directory either did not exist in the first place or was successfully deleted (with confirmation). Returns false when directory could not be confirmed to be deleted within the specified timeout, this does not mean that the OS will not delete the directory later, so calling this function in a loop is expected. NOTE: Directory.Delete() does not guarantee that directory is no longer on disk upon its return

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool EnsureDirectoryDeleted(
    string dirName,
    int timeoutMs = 2000
)
public static bool EnsureDirectoryDeleted(
    string dirName,
    int timeoutMs = 2000
)
Public Shared Function EnsureDirectoryDeleted (
    dirName As String,
    Optional timeoutMs As Integer = 2000
) As Boolean
Public Shared Function EnsureDirectoryDeleted (
    dirName As String,
    Optional timeoutMs As Integer = 2000
) As Boolean
public:
static bool EnsureDirectoryDeleted(
    String^ dirName,
    int timeoutMs = 2000
)
public:
static bool EnsureDirectoryDeleted(
    String^ dirName,
    int timeoutMs = 2000
)
static member EnsureDirectoryDeleted :
        dirName : string *
        ?timeoutMs : int
(* Defaults:
        let _timeoutMs = defaultArg timeoutMs 2000
*)
-> bool
static member EnsureDirectoryDeleted :
        dirName : string *
        ?timeoutMs : int
(* Defaults:
        let _timeoutMs = defaultArg timeoutMs 2000
*)
-> bool

Parameters

dirName
Type: Online System String
Directory to delete
timeoutMs (Optional)
Type: Online System Int32
Timeout in ms

Return Value

Type: Online Boolean
See Also
IOMiscUtils Class
IOMiscUtils Members
NFX Namespace


IOMiscUtils.EnsureFileEventuallyDeleted Method

IOMiscUtils EnsureFileEventuallyDeleted Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Deleted file if it exists - does not block until file is deleted, the behavior is up to the OS

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void EnsureFileEventuallyDeleted(
    string fileName
)
public static void EnsureFileEventuallyDeleted(
    string fileName
)
Public Shared Sub EnsureFileEventuallyDeleted (
    fileName As String
)
Public Shared Sub EnsureFileEventuallyDeleted (
    fileName As String
)
public:
static void EnsureFileEventuallyDeleted(
    String^ fileName
)
public:
static void EnsureFileEventuallyDeleted(
    String^ fileName
)
static member EnsureFileEventuallyDeleted :
        fileName : string -> unit
static member EnsureFileEventuallyDeleted :
        fileName : string -> unit

Parameters

fileName
Type: Online System String
Full file name with path
See Also
IOMiscUtils Class
IOMiscUtils Members
NFX Namespace


IOMiscUtils.GetURL Method

IOMiscUtils GetURL Method NFX Class Library

Fetch the content of a given URL.

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static KeyValuePair<HttpStatusCode, string> GetURL(
    string urlAddress,
    int timeout = 5000
)
public static KeyValuePair<HttpStatusCode, string> GetURL(
    string urlAddress,
    int timeout = 5000
)
Public Shared Function GetURL (
    urlAddress As String,
    Optional timeout As Integer = 5000
) As KeyValuePair(Of HttpStatusCode, String)
Public Shared Function GetURL (
    urlAddress As String,
    Optional timeout As Integer = 5000
) As KeyValuePair(Of HttpStatusCode, String)
public:
static KeyValuePair<HttpStatusCode, String^> GetURL(
    String^ urlAddress,
    int timeout = 5000
)
public:
static KeyValuePair<HttpStatusCode, String^> GetURL(
    String^ urlAddress,
    int timeout = 5000
)
static member GetURL :
        urlAddress : string *
        ?timeout : int
(* Defaults:
        let _timeout = defaultArg timeout 5000
*)
-> KeyValuePair<HttpStatusCode, string>
static member GetURL :
        urlAddress : string *
        ?timeout : int
(* Defaults:
        let _timeout = defaultArg timeout 5000
*)
-> KeyValuePair<HttpStatusCode, string>

Parameters

urlAddress
Type: Online System String
timeout (Optional)
Type: Online System Int32

Return Value

Type: Online KeyValuePair Online HttpStatusCode, Online String
Return fetched URL as a string, or null string when resulting status code is not HttpStatusCode.OK.
See Also
IOMiscUtils Class
IOMiscUtils Members
NFX Namespace


IOMiscUtils.MemBufferEquals Method

IOMiscUtils MemBufferEquals Method NFX Class Library

Returns true if both buffers contain the same number of the same bytes. The implementation uses quad-word comparison as much as possible for speed. Requires UNSAFE switch

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool MemBufferEquals(
    this byte[] buf1,
    byte[] buf2
)
public static bool MemBufferEquals(
    this byte[] buf1,
    byte[] buf2
)
<ExtensionAttribute>
Public Shared Function MemBufferEquals (
    buf1 As Byte(),
    buf2 As Byte()
) As Boolean
<ExtensionAttribute>
Public Shared Function MemBufferEquals (
    buf1 As Byte(),
    buf2 As Byte()
) As Boolean
public:
[ExtensionAttribute]
static bool MemBufferEquals(
    array<unsigned char>^ buf1,
    array<unsigned char>^ buf2
)
public:
[ExtensionAttribute]
static bool MemBufferEquals(
    array<unsigned char>^ buf1,
    array<unsigned char>^ buf2
)
static member MemBufferEquals :
        buf1 : byte[] *
        buf2 : byte[] -> bool
static member MemBufferEquals :
        buf1 : byte[] *
        buf2 : byte[] -> bool

Parameters

buf1
Type: Online System Byte
buf2
Type: Online System Byte

Return Value

Type: Online Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
NFX Namespace


IOMiscUtils.NormalizeCenteredImage Method

IOMiscUtils NormalizeCenteredImage Method NFX Class Library

Scales source image so it fits in the desired image size preserving aspect ratio. This function is usable for profile picture size/aspect normalization

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Image NormalizeCenteredImage(
    this Image srcImage,
    int targetWidth = 128,
    int targetHeight = 128,
    int xDpi = 96,
    int yDpi = 96
)
public static Image NormalizeCenteredImage(
    this Image srcImage,
    int targetWidth = 128,
    int targetHeight = 128,
    int xDpi = 96,
    int yDpi = 96
)
<ExtensionAttribute>
Public Shared Function NormalizeCenteredImage (
    srcImage As Image,
    Optional targetWidth As Integer = 128,
    Optional targetHeight As Integer = 128,
    Optional xDpi As Integer = 96,
    Optional yDpi As Integer = 96
) As Image
<ExtensionAttribute>
Public Shared Function NormalizeCenteredImage (
    srcImage As Image,
    Optional targetWidth As Integer = 128,
    Optional targetHeight As Integer = 128,
    Optional xDpi As Integer = 96,
    Optional yDpi As Integer = 96
) As Image
public:
[ExtensionAttribute]
static Image^ NormalizeCenteredImage(
    Image^ srcImage,
    int targetWidth = 128,
    int targetHeight = 128,
    int xDpi = 96,
    int yDpi = 96
)
public:
[ExtensionAttribute]
static Image^ NormalizeCenteredImage(
    Image^ srcImage,
    int targetWidth = 128,
    int targetHeight = 128,
    int xDpi = 96,
    int yDpi = 96
)
static member NormalizeCenteredImage :
        srcImage : Image *
        ?targetWidth : int *
        ?targetHeight : int *
        ?xDpi : int *
        ?yDpi : int
(* Defaults:
        let _targetWidth = defaultArg targetWidth 128
        let _targetHeight = defaultArg targetHeight 128
        let _xDpi = defaultArg xDpi 96
        let _yDpi = defaultArg yDpi 96
*)
-> Image
static member NormalizeCenteredImage :
        srcImage : Image *
        ?targetWidth : int *
        ?targetHeight : int *
        ?xDpi : int *
        ?yDpi : int
(* Defaults:
        let _targetWidth = defaultArg targetWidth 128
        let _targetHeight = defaultArg targetHeight 128
        let _xDpi = defaultArg xDpi 96
        let _yDpi = defaultArg yDpi 96
*)
-> Image

Parameters

srcImage
Type: Online System.Drawing Image
targetWidth (Optional)
Type: Online System Int32
targetHeight (Optional)
Type: Online System Int32
xDpi (Optional)
Type: Online System Int32
yDpi (Optional)
Type: Online System Int32

Return Value

Type: Online Image

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Image. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
NFX Namespace


IOMiscUtils.PackISO3CodeToInt Method

IOMiscUtils PackISO3CodeToInt Method NFX Class Library

Represents an ISO code as 4 byte integer filled with up to 3 ASCII chars converted to upper case, the highest byte is free to be used by the application

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int PackISO3CodeToInt(
    string iso
)
public static int PackISO3CodeToInt(
    string iso
)
Public Shared Function PackISO3CodeToInt (
    iso As String
) As Integer
Public Shared Function PackISO3CodeToInt (
    iso As String
) As Integer
public:
static int PackISO3CodeToInt(
    String^ iso
)
public:
static int PackISO3CodeToInt(
    String^ iso
)
static member PackISO3CodeToInt :
        iso : string -> int
static member PackISO3CodeToInt :
        iso : string -> int

Parameters

iso
Type: Online System String

Return Value

Type: Online Int32
See Also
IOMiscUtils Class
IOMiscUtils Members
NFX Namespace


IOMiscUtils.ReadBEInt32 Method

IOMiscUtils ReadBEInt32 Method NFX Class Library

Overload List
Name | Description
ReadBEInt32( Byte ) | Reads an integer encoded as big endian from buffer at index 0
ReadBEInt32(Stream) | Reads an integer encoded as big endian from buffer at the specified index
ReadBEInt32( Byte , Int32 ) | Reads an integer encoded as big endian from buffer at the specified index and increments the idx by the number of bytes read
ReadBEInt32( Byte , Int64 ) | Reads an integer encoded as big endian from buffer at the specified index and increments the idx by the number of bytes read
Back to Top
See Also
IOMiscUtils Class
IOMiscUtils Members
NFX Namespace


IOMiscUtils.ReadBEInt32 Method (Byte[])

IOMiscUtils ReadBEInt32 Method ( Byte ) NFX Class Library

Reads an integer encoded as big endian from buffer at index 0

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int ReadBEInt32(
    this byte[] buf
)
public static int ReadBEInt32(
    this byte[] buf
)
<ExtensionAttribute>
Public Shared Function ReadBEInt32 (
    buf As Byte()
) As Integer
<ExtensionAttribute>
Public Shared Function ReadBEInt32 (
    buf As Byte()
) As Integer
public:
[ExtensionAttribute]
static int ReadBEInt32(
    array<unsigned char>^ buf
)
public:
[ExtensionAttribute]
static int ReadBEInt32(
    array<unsigned char>^ buf
)
static member ReadBEInt32 :
        buf : byte[] -> int
static member ReadBEInt32 :
        buf : byte[] -> int

Parameters

buf
Type: Online System Byte

Return Value

Type: Online Int32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
ReadBEInt32 Overload
NFX Namespace


IOMiscUtils.ReadBEInt32 Method (Stream)

IOMiscUtils ReadBEInt32 Method (Stream) NFX Class Library

Reads an integer encoded as big endian from buffer at the specified index

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int ReadBEInt32(
    this Stream s
)
public static int ReadBEInt32(
    this Stream s
)
<ExtensionAttribute>
Public Shared Function ReadBEInt32 (
    s As Stream
) As Integer
<ExtensionAttribute>
Public Shared Function ReadBEInt32 (
    s As Stream
) As Integer
public:
[ExtensionAttribute]
static int ReadBEInt32(
    Stream^ s
)
public:
[ExtensionAttribute]
static int ReadBEInt32(
    Stream^ s
)
static member ReadBEInt32 :
        s : Stream -> int
static member ReadBEInt32 :
        s : Stream -> int

Parameters

s
Type: Online System.IO Stream

Return Value

Type: Online Int32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
ReadBEInt32 Overload
NFX Namespace


IOMiscUtils.ReadBEInt32 Method (Byte[], Int32)

IOMiscUtils ReadBEInt32 Method ( Byte , Int32 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Reads an integer encoded as big endian from buffer at the specified index and increments the idx by the number of bytes read

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int ReadBEInt32(
    this byte[] buf,
    ref int idx
)
public static int ReadBEInt32(
    this byte[] buf,
    ref int idx
)
<ExtensionAttribute>
Public Shared Function ReadBEInt32 (
    buf As Byte(),
    ByRef idx As Integer
) As Integer
<ExtensionAttribute>
Public Shared Function ReadBEInt32 (
    buf As Byte(),
    ByRef idx As Integer
) As Integer
public:
[ExtensionAttribute]
static int ReadBEInt32(
    array<unsigned char>^ buf,
    int% idx
)
public:
[ExtensionAttribute]
static int ReadBEInt32(
    array<unsigned char>^ buf,
    int% idx
)
static member ReadBEInt32 :
        buf : byte[] *
        idx : int byref -> int
static member ReadBEInt32 :
        buf : byte[] *
        idx : int byref -> int

Parameters

buf
Type: Online System Byte
idx
Type: Online System Int32

Return Value

Type: Online Int32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
ReadBEInt32 Overload
NFX Namespace


IOMiscUtils.ReadBEInt32 Method (Byte[], Int64)

IOMiscUtils ReadBEInt32 Method ( Byte , Int64 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Reads an integer encoded as big endian from buffer at the specified index and increments the idx by the number of bytes read

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int ReadBEInt32(
    this byte[] buf,
    ref long idx
)
public static int ReadBEInt32(
    this byte[] buf,
    ref long idx
)
<ExtensionAttribute>
Public Shared Function ReadBEInt32 (
    buf As Byte(),
    ByRef idx As Long
) As Integer
<ExtensionAttribute>
Public Shared Function ReadBEInt32 (
    buf As Byte(),
    ByRef idx As Long
) As Integer
public:
[ExtensionAttribute]
static int ReadBEInt32(
    array<unsigned char>^ buf,
    long long% idx
)
public:
[ExtensionAttribute]
static int ReadBEInt32(
    array<unsigned char>^ buf,
    long long% idx
)
static member ReadBEInt32 :
        buf : byte[] *
        idx : int64 byref -> int
static member ReadBEInt32 :
        buf : byte[] *
        idx : int64 byref -> int

Parameters

buf
Type: Online System Byte
idx
Type: Online System Int64

Return Value

Type: Online Int32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
ReadBEInt32 Overload
NFX Namespace


IOMiscUtils.ReadBEShort Method

IOMiscUtils ReadBEShort Method NFX Class Library

Overload List
Name | Description
ReadBEShort(Stream) | Reads a short encoded as big endian from stream
ReadBEShort( Byte , Int32 ) | Reads a short encoded as big endian from buffer at the specified index
Back to Top
See Also
IOMiscUtils Class
IOMiscUtils Members
NFX Namespace


IOMiscUtils.ReadBEShort Method (Stream)

IOMiscUtils ReadBEShort Method (Stream) NFX Class Library

Reads a short encoded as big endian from stream

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static short ReadBEShort(
    this Stream s
)
public static short ReadBEShort(
    this Stream s
)
<ExtensionAttribute>
Public Shared Function ReadBEShort (
    s As Stream
) As Short
<ExtensionAttribute>
Public Shared Function ReadBEShort (
    s As Stream
) As Short
public:
[ExtensionAttribute]
static short ReadBEShort(
    Stream^ s
)
public:
[ExtensionAttribute]
static short ReadBEShort(
    Stream^ s
)
static member ReadBEShort :
        s : Stream -> int16
static member ReadBEShort :
        s : Stream -> int16

Parameters

s
Type: Online System.IO Stream

Return Value

Type: Online Int16

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
ReadBEShort Overload
NFX Namespace


IOMiscUtils.ReadBEShort Method (Byte[], Int32)

IOMiscUtils ReadBEShort Method ( Byte , Int32 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Reads a short encoded as big endian from buffer at the specified index

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static short ReadBEShort(
    this byte[] buf,
    ref int idx
)
public static short ReadBEShort(
    this byte[] buf,
    ref int idx
)
<ExtensionAttribute>
Public Shared Function ReadBEShort (
    buf As Byte(),
    ByRef idx As Integer
) As Short
<ExtensionAttribute>
Public Shared Function ReadBEShort (
    buf As Byte(),
    ByRef idx As Integer
) As Short
public:
[ExtensionAttribute]
static short ReadBEShort(
    array<unsigned char>^ buf,
    int% idx
)
public:
[ExtensionAttribute]
static short ReadBEShort(
    array<unsigned char>^ buf,
    int% idx
)
static member ReadBEShort :
        buf : byte[] *
        idx : int byref -> int16
static member ReadBEShort :
        buf : byte[] *
        idx : int byref -> int16

Parameters

buf
Type: Online System Byte
idx
Type: Online System Int32

Return Value

Type: Online Int16

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
ReadBEShort Overload
NFX Namespace


IOMiscUtils.ReadBEUInt32 Method

IOMiscUtils ReadBEUInt32 Method NFX Class Library

Overload List
Name | Description
ReadBEUInt32( Byte ) | Reads an unsigned integer encoded as big endian from buffer at index 0
ReadBEUInt32( Byte , Int32 ) | Reads an unsigned integer encoded as big endian from buffer at the specified index and increments the idx by the number of bytes read
ReadBEUInt32( Byte , Int64 ) | Reads an unsigned integer encoded as big endian from buffer at the specified index and increments the idx by the number of bytes read
Back to Top
See Also
IOMiscUtils Class
IOMiscUtils Members
NFX Namespace


IOMiscUtils.ReadBEUInt32 Method (Byte[])

IOMiscUtils ReadBEUInt32 Method ( Byte ) NFX Class Library

Reads an unsigned integer encoded as big endian from buffer at index 0

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static uint ReadBEUInt32(
    this byte[] buf
)
public static uint ReadBEUInt32(
    this byte[] buf
)
<ExtensionAttribute>
Public Shared Function ReadBEUInt32 (
    buf As Byte()
) As UInteger
<ExtensionAttribute>
Public Shared Function ReadBEUInt32 (
    buf As Byte()
) As UInteger
public:
[ExtensionAttribute]
static unsigned int ReadBEUInt32(
    array<unsigned char>^ buf
)
public:
[ExtensionAttribute]
static unsigned int ReadBEUInt32(
    array<unsigned char>^ buf
)
static member ReadBEUInt32 :
        buf : byte[] -> uint32
static member ReadBEUInt32 :
        buf : byte[] -> uint32

Parameters

buf
Type: Online System Byte

Return Value

Type: Online UInt32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
ReadBEUInt32 Overload
NFX Namespace


IOMiscUtils.ReadBEUInt32 Method (Byte[], Int32)

IOMiscUtils ReadBEUInt32 Method ( Byte , Int32 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Reads an unsigned integer encoded as big endian from buffer at the specified index and increments the idx by the number of bytes read

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static uint ReadBEUInt32(
    this byte[] buf,
    ref int idx
)
public static uint ReadBEUInt32(
    this byte[] buf,
    ref int idx
)
<ExtensionAttribute>
Public Shared Function ReadBEUInt32 (
    buf As Byte(),
    ByRef idx As Integer
) As UInteger
<ExtensionAttribute>
Public Shared Function ReadBEUInt32 (
    buf As Byte(),
    ByRef idx As Integer
) As UInteger
public:
[ExtensionAttribute]
static unsigned int ReadBEUInt32(
    array<unsigned char>^ buf,
    int% idx
)
public:
[ExtensionAttribute]
static unsigned int ReadBEUInt32(
    array<unsigned char>^ buf,
    int% idx
)
static member ReadBEUInt32 :
        buf : byte[] *
        idx : int byref -> uint32
static member ReadBEUInt32 :
        buf : byte[] *
        idx : int byref -> uint32

Parameters

buf
Type: Online System Byte
idx
Type: Online System Int32

Return Value

Type: Online UInt32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
ReadBEUInt32 Overload
NFX Namespace


IOMiscUtils.ReadBEUInt32 Method (Byte[], Int64)

IOMiscUtils ReadBEUInt32 Method ( Byte , Int64 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Reads an unsigned integer encoded as big endian from buffer at the specified index and increments the idx by the number of bytes read

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static uint ReadBEUInt32(
    this byte[] buf,
    ref long idx
)
public static uint ReadBEUInt32(
    this byte[] buf,
    ref long idx
)
<ExtensionAttribute>
Public Shared Function ReadBEUInt32 (
    buf As Byte(),
    ByRef idx As Long
) As UInteger
<ExtensionAttribute>
Public Shared Function ReadBEUInt32 (
    buf As Byte(),
    ByRef idx As Long
) As UInteger
public:
[ExtensionAttribute]
static unsigned int ReadBEUInt32(
    array<unsigned char>^ buf,
    long long% idx
)
public:
[ExtensionAttribute]
static unsigned int ReadBEUInt32(
    array<unsigned char>^ buf,
    long long% idx
)
static member ReadBEUInt32 :
        buf : byte[] *
        idx : int64 byref -> uint32
static member ReadBEUInt32 :
        buf : byte[] *
        idx : int64 byref -> uint32

Parameters

buf
Type: Online System Byte
idx
Type: Online System Int64

Return Value

Type: Online UInt32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
ReadBEUInt32 Overload
NFX Namespace


IOMiscUtils.ReadBEUInt64 Method

IOMiscUtils ReadBEUInt64 Method NFX Class Library

Overload List
Name | Description
ReadBEUInt64(Stream) | Reads an integer encoded as big endian from buffer at the specified index
ReadBEUInt64( Byte , Int32) | Reads an integer encoded as big endian from buffer at the specified index and increments the idx by the number of bytes read
ReadBEUInt64( Byte , Int32 ) | Reads an integer encoded as big endian from buffer at the specified index and increments the idx by the number of bytes read
Back to Top
See Also
IOMiscUtils Class
IOMiscUtils Members
NFX Namespace


IOMiscUtils.ReadBEUInt64 Method (Stream)

IOMiscUtils ReadBEUInt64 Method (Stream) NFX Class Library

Reads an integer encoded as big endian from buffer at the specified index

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ulong ReadBEUInt64(
    this Stream s
)
public static ulong ReadBEUInt64(
    this Stream s
)
<ExtensionAttribute>
Public Shared Function ReadBEUInt64 (
    s As Stream
) As ULong
<ExtensionAttribute>
Public Shared Function ReadBEUInt64 (
    s As Stream
) As ULong
public:
[ExtensionAttribute]
static unsigned long long ReadBEUInt64(
    Stream^ s
)
public:
[ExtensionAttribute]
static unsigned long long ReadBEUInt64(
    Stream^ s
)
static member ReadBEUInt64 :
        s : Stream -> uint64
static member ReadBEUInt64 :
        s : Stream -> uint64

Parameters

s
Type: Online System.IO Stream

Return Value

Type: Online UInt64

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
ReadBEUInt64 Overload
NFX Namespace


IOMiscUtils.ReadBEUInt64 Method (Byte[], Int32)

IOMiscUtils ReadBEUInt64 Method ( Byte , Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Reads an integer encoded as big endian from buffer at the specified index and increments the idx by the number of bytes read

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ulong ReadBEUInt64(
    this byte[] buf,
    int idx = 0
)
public static ulong ReadBEUInt64(
    this byte[] buf,
    int idx = 0
)
<ExtensionAttribute>
Public Shared Function ReadBEUInt64 (
    buf As Byte(),
    Optional idx As Integer = 0
) As ULong
<ExtensionAttribute>
Public Shared Function ReadBEUInt64 (
    buf As Byte(),
    Optional idx As Integer = 0
) As ULong
public:
[ExtensionAttribute]
static unsigned long long ReadBEUInt64(
    array<unsigned char>^ buf,
    int idx = 0
)
public:
[ExtensionAttribute]
static unsigned long long ReadBEUInt64(
    array<unsigned char>^ buf,
    int idx = 0
)
static member ReadBEUInt64 :
        buf : byte[] *
        ?idx : int
(* Defaults:
        let _idx = defaultArg idx 0
*)
-> uint64
static member ReadBEUInt64 :
        buf : byte[] *
        ?idx : int
(* Defaults:
        let _idx = defaultArg idx 0
*)
-> uint64

Parameters

buf
Type: Online System Byte
idx (Optional)
Type: Online System Int32

Return Value

Type: Online UInt64

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
ReadBEUInt64 Overload
NFX Namespace


IOMiscUtils.ReadBEUInt64 Method (Byte[], Int32)

IOMiscUtils ReadBEUInt64 Method ( Byte , Int32 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Reads an integer encoded as big endian from buffer at the specified index and increments the idx by the number of bytes read

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ulong ReadBEUInt64(
    this byte[] buf,
    ref int idx
)
public static ulong ReadBEUInt64(
    this byte[] buf,
    ref int idx
)
<ExtensionAttribute>
Public Shared Function ReadBEUInt64 (
    buf As Byte(),
    ByRef idx As Integer
) As ULong
<ExtensionAttribute>
Public Shared Function ReadBEUInt64 (
    buf As Byte(),
    ByRef idx As Integer
) As ULong
public:
[ExtensionAttribute]
static unsigned long long ReadBEUInt64(
    array<unsigned char>^ buf,
    int% idx
)
public:
[ExtensionAttribute]
static unsigned long long ReadBEUInt64(
    array<unsigned char>^ buf,
    int% idx
)
static member ReadBEUInt64 :
        buf : byte[] *
        idx : int byref -> uint64
static member ReadBEUInt64 :
        buf : byte[] *
        idx : int byref -> uint64

Parameters

buf
Type: Online System Byte
idx
Type: Online System Int32

Return Value

Type: Online UInt64

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
ReadBEUInt64 Overload
NFX Namespace


IOMiscUtils.ReadBEUShort Method

IOMiscUtils ReadBEUShort Method NFX Class Library

Reads an ushort encoded as big endian from stream

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ushort ReadBEUShort(
    this Stream s
)
public static ushort ReadBEUShort(
    this Stream s
)
<ExtensionAttribute>
Public Shared Function ReadBEUShort (
    s As Stream
) As UShort
<ExtensionAttribute>
Public Shared Function ReadBEUShort (
    s As Stream
) As UShort
public:
[ExtensionAttribute]
static unsigned short ReadBEUShort(
    Stream^ s
)
public:
[ExtensionAttribute]
static unsigned short ReadBEUShort(
    Stream^ s
)
static member ReadBEUShort :
        s : Stream -> uint16
static member ReadBEUShort :
        s : Stream -> uint16

Parameters

s
Type: Online System.IO Stream

Return Value

Type: Online UInt16

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
NFX Namespace


IOMiscUtils.ReadLine Method

IOMiscUtils ReadLine Method NFX Class Library

Reads first line from the string

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ReadLine(
    this string str
)
public static string ReadLine(
    this string str
)
<ExtensionAttribute>
Public Shared Function ReadLine (
    str As String
) As String
<ExtensionAttribute>
Public Shared Function ReadLine (
    str As String
) As String
public:
[ExtensionAttribute]
static String^ ReadLine(
    String^ str
)
public:
[ExtensionAttribute]
static String^ ReadLine(
    String^ str
)
static member ReadLine :
        str : string -> string
static member ReadLine :
        str : string -> string

Parameters

str
Type: Online System String

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
NFX Namespace


IOMiscUtils.UnpackISO3CodeFromInt Method

IOMiscUtils UnpackISO3CodeFromInt Method NFX Class Library

Unpacks an ISO code from int which was packed with PackISO3CodeToInt

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string UnpackISO3CodeFromInt(
    int iso
)
public static string UnpackISO3CodeFromInt(
    int iso
)
Public Shared Function UnpackISO3CodeFromInt (
    iso As Integer
) As String
Public Shared Function UnpackISO3CodeFromInt (
    iso As Integer
) As String
public:
static String^ UnpackISO3CodeFromInt(
    int iso
)
public:
static String^ UnpackISO3CodeFromInt(
    int iso
)
static member UnpackISO3CodeFromInt :
        iso : int -> string
static member UnpackISO3CodeFromInt :
        iso : int -> string

Parameters

iso
Type: Online System Int32

Return Value

Type: Online String
See Also
IOMiscUtils Class
IOMiscUtils Members
NFX Namespace


IOMiscUtils.WriteBEInt32 Method

IOMiscUtils WriteBEInt32 Method NFX Class Library

Overload List
Name | Description
WriteBEInt32( Byte , Int32) | Writes an integer encoded as big endian to buffer at index 0
WriteBEInt32(Stream, Int32) | Writes an integer encoded as big endian to the given stream
WriteBEInt32( Byte , Int32, Int32) | Writes an integer encoded as big endian to buffer at the specified index
Back to Top
See Also
IOMiscUtils Class
IOMiscUtils Members
NFX Namespace


IOMiscUtils.WriteBEInt32 Method (Byte[], Int32)

IOMiscUtils WriteBEInt32 Method ( Byte , Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes an integer encoded as big endian to buffer at index 0

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteBEInt32(
    this byte[] buf,
    int value
)
public static void WriteBEInt32(
    this byte[] buf,
    int value
)
<ExtensionAttribute>
Public Shared Sub WriteBEInt32 (
    buf As Byte(),
    value As Integer
)
<ExtensionAttribute>
Public Shared Sub WriteBEInt32 (
    buf As Byte(),
    value As Integer
)
public:
[ExtensionAttribute]
static void WriteBEInt32(
    array<unsigned char>^ buf,
    int value
)
public:
[ExtensionAttribute]
static void WriteBEInt32(
    array<unsigned char>^ buf,
    int value
)
static member WriteBEInt32 :
        buf : byte[] *
        value : int -> unit
static member WriteBEInt32 :
        buf : byte[] *
        value : int -> unit

Parameters

buf
Type: Online System Byte
value
Type: Online System Int32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
WriteBEInt32 Overload
NFX Namespace


IOMiscUtils.WriteBEInt32 Method (Stream, Int32)

IOMiscUtils WriteBEInt32 Method (Stream, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes an integer encoded as big endian to the given stream

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteBEInt32(
    this Stream s,
    int value
)
public static void WriteBEInt32(
    this Stream s,
    int value
)
<ExtensionAttribute>
Public Shared Sub WriteBEInt32 (
    s As Stream,
    value As Integer
)
<ExtensionAttribute>
Public Shared Sub WriteBEInt32 (
    s As Stream,
    value As Integer
)
public:
[ExtensionAttribute]
static void WriteBEInt32(
    Stream^ s,
    int value
)
public:
[ExtensionAttribute]
static void WriteBEInt32(
    Stream^ s,
    int value
)
static member WriteBEInt32 :
        s : Stream *
        value : int -> unit
static member WriteBEInt32 :
        s : Stream *
        value : int -> unit

Parameters

s
Type: Online System.IO Stream
value
Type: Online System Int32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
WriteBEInt32 Overload
NFX Namespace


IOMiscUtils.WriteBEInt32 Method (Byte[], Int32, Int32)

IOMiscUtils WriteBEInt32 Method ( Byte , Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes an integer encoded as big endian to buffer at the specified index

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteBEInt32(
    this byte[] buf,
    int idx,
    int value
)
public static void WriteBEInt32(
    this byte[] buf,
    int idx,
    int value
)
<ExtensionAttribute>
Public Shared Sub WriteBEInt32 (
    buf As Byte(),
    idx As Integer,
    value As Integer
)
<ExtensionAttribute>
Public Shared Sub WriteBEInt32 (
    buf As Byte(),
    idx As Integer,
    value As Integer
)
public:
[ExtensionAttribute]
static void WriteBEInt32(
    array<unsigned char>^ buf,
    int idx,
    int value
)
public:
[ExtensionAttribute]
static void WriteBEInt32(
    array<unsigned char>^ buf,
    int idx,
    int value
)
static member WriteBEInt32 :
        buf : byte[] *
        idx : int *
        value : int -> unit
static member WriteBEInt32 :
        buf : byte[] *
        idx : int *
        value : int -> unit

Parameters

buf
Type: Online System Byte
idx
Type: Online System Int32
value
Type: Online System Int32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
WriteBEInt32 Overload
NFX Namespace


IOMiscUtils.WriteBEShort Method

IOMiscUtils WriteBEShort Method NFX Class Library

Overload List
Name | Description
WriteBEShort(Stream, Int16) | Writes a short encoded as big endian to the given stream
WriteBEShort( Byte , Int32, Int16) | Writes a short encoded as big endian to buffer at the specified index
Back to Top
See Also
IOMiscUtils Class
IOMiscUtils Members
NFX Namespace


IOMiscUtils.WriteBEShort Method (Stream, Int16)

IOMiscUtils WriteBEShort Method (Stream, Int16) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes a short encoded as big endian to the given stream

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteBEShort(
    this Stream s,
    short value
)
public static void WriteBEShort(
    this Stream s,
    short value
)
<ExtensionAttribute>
Public Shared Sub WriteBEShort (
    s As Stream,
    value As Short
)
<ExtensionAttribute>
Public Shared Sub WriteBEShort (
    s As Stream,
    value As Short
)
public:
[ExtensionAttribute]
static void WriteBEShort(
    Stream^ s,
    short value
)
public:
[ExtensionAttribute]
static void WriteBEShort(
    Stream^ s,
    short value
)
static member WriteBEShort :
        s : Stream *
        value : int16 -> unit
static member WriteBEShort :
        s : Stream *
        value : int16 -> unit

Parameters

s
Type: Online System.IO Stream
value
Type: Online System Int16

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
WriteBEShort Overload
NFX Namespace


IOMiscUtils.WriteBEShort Method (Byte[], Int32, Int16)

IOMiscUtils WriteBEShort Method ( Byte , Int32, Int16) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes a short encoded as big endian to buffer at the specified index

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteBEShort(
    this byte[] buf,
    int idx,
    short value
)
public static void WriteBEShort(
    this byte[] buf,
    int idx,
    short value
)
<ExtensionAttribute>
Public Shared Sub WriteBEShort (
    buf As Byte(),
    idx As Integer,
    value As Short
)
<ExtensionAttribute>
Public Shared Sub WriteBEShort (
    buf As Byte(),
    idx As Integer,
    value As Short
)
public:
[ExtensionAttribute]
static void WriteBEShort(
    array<unsigned char>^ buf,
    int idx,
    short value
)
public:
[ExtensionAttribute]
static void WriteBEShort(
    array<unsigned char>^ buf,
    int idx,
    short value
)
static member WriteBEShort :
        buf : byte[] *
        idx : int *
        value : int16 -> unit
static member WriteBEShort :
        buf : byte[] *
        idx : int *
        value : int16 -> unit

Parameters

buf
Type: Online System Byte
idx
Type: Online System Int32
value
Type: Online System Int16

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
WriteBEShort Overload
NFX Namespace


IOMiscUtils.WriteBEUInt32 Method

IOMiscUtils WriteBEUInt32 Method NFX Class Library

Overload List
Name | Description
WriteBEUInt32( Byte , UInt32) | Writes an unsigned integer encoded as big endian to buffer at index 0
WriteBEUInt32( Byte , Int32, UInt32) | Writes an unsigned integer encoded as big endian to buffer at the specified index
Back to Top
See Also
IOMiscUtils Class
IOMiscUtils Members
NFX Namespace


IOMiscUtils.WriteBEUInt32 Method (Byte[], UInt32)

IOMiscUtils WriteBEUInt32 Method ( Byte , UInt32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes an unsigned integer encoded as big endian to buffer at index 0

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteBEUInt32(
    this byte[] buf,
    uint value
)
public static void WriteBEUInt32(
    this byte[] buf,
    uint value
)
<ExtensionAttribute>
Public Shared Sub WriteBEUInt32 (
    buf As Byte(),
    value As UInteger
)
<ExtensionAttribute>
Public Shared Sub WriteBEUInt32 (
    buf As Byte(),
    value As UInteger
)
public:
[ExtensionAttribute]
static void WriteBEUInt32(
    array<unsigned char>^ buf,
    unsigned int value
)
public:
[ExtensionAttribute]
static void WriteBEUInt32(
    array<unsigned char>^ buf,
    unsigned int value
)
static member WriteBEUInt32 :
        buf : byte[] *
        value : uint32 -> unit
static member WriteBEUInt32 :
        buf : byte[] *
        value : uint32 -> unit

Parameters

buf
Type: Online System Byte
value
Type: Online System UInt32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
WriteBEUInt32 Overload
NFX Namespace


IOMiscUtils.WriteBEUInt32 Method (Byte[], Int32, UInt32)

IOMiscUtils WriteBEUInt32 Method ( Byte , Int32, UInt32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes an unsigned integer encoded as big endian to buffer at the specified index

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteBEUInt32(
    this byte[] buf,
    int idx,
    uint value
)
public static void WriteBEUInt32(
    this byte[] buf,
    int idx,
    uint value
)
<ExtensionAttribute>
Public Shared Sub WriteBEUInt32 (
    buf As Byte(),
    idx As Integer,
    value As UInteger
)
<ExtensionAttribute>
Public Shared Sub WriteBEUInt32 (
    buf As Byte(),
    idx As Integer,
    value As UInteger
)
public:
[ExtensionAttribute]
static void WriteBEUInt32(
    array<unsigned char>^ buf,
    int idx,
    unsigned int value
)
public:
[ExtensionAttribute]
static void WriteBEUInt32(
    array<unsigned char>^ buf,
    int idx,
    unsigned int value
)
static member WriteBEUInt32 :
        buf : byte[] *
        idx : int *
        value : uint32 -> unit
static member WriteBEUInt32 :
        buf : byte[] *
        idx : int *
        value : uint32 -> unit

Parameters

buf
Type: Online System Byte
idx
Type: Online System Int32
value
Type: Online System UInt32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
WriteBEUInt32 Overload
NFX Namespace


IOMiscUtils.WriteBEUInt64 Method

IOMiscUtils WriteBEUInt64 Method NFX Class Library

Overload List
Name | Description
WriteBEUInt64( Byte , UInt64) | Writes an unsigned long integer encoded as big endian to buffer at the beginning
WriteBEUInt64(Stream, UInt64) | Writes an unsigned long integer encoded as big endian to the given stream
WriteBEUInt64( Byte , Int32, UInt64) | Writes an unsigned long integer encoded as big endian to buffer at the specified index
Back to Top
See Also
IOMiscUtils Class
IOMiscUtils Members
NFX Namespace


IOMiscUtils.WriteBEUInt64 Method (Byte[], UInt64)

IOMiscUtils WriteBEUInt64 Method ( Byte , UInt64) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes an unsigned long integer encoded as big endian to buffer at the beginning

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteBEUInt64(
    this byte[] buf,
    ulong value
)
public static void WriteBEUInt64(
    this byte[] buf,
    ulong value
)
<ExtensionAttribute>
Public Shared Sub WriteBEUInt64 (
    buf As Byte(),
    value As ULong
)
<ExtensionAttribute>
Public Shared Sub WriteBEUInt64 (
    buf As Byte(),
    value As ULong
)
public:
[ExtensionAttribute]
static void WriteBEUInt64(
    array<unsigned char>^ buf,
    unsigned long long value
)
public:
[ExtensionAttribute]
static void WriteBEUInt64(
    array<unsigned char>^ buf,
    unsigned long long value
)
static member WriteBEUInt64 :
        buf : byte[] *
        value : uint64 -> unit
static member WriteBEUInt64 :
        buf : byte[] *
        value : uint64 -> unit

Parameters

buf
Type: Online System Byte
value
Type: Online System UInt64

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
WriteBEUInt64 Overload
NFX Namespace


IOMiscUtils.WriteBEUInt64 Method (Stream, UInt64)

IOMiscUtils WriteBEUInt64 Method (Stream, UInt64) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes an unsigned long integer encoded as big endian to the given stream

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteBEUInt64(
    this Stream s,
    ulong value
)
public static void WriteBEUInt64(
    this Stream s,
    ulong value
)
<ExtensionAttribute>
Public Shared Sub WriteBEUInt64 (
    s As Stream,
    value As ULong
)
<ExtensionAttribute>
Public Shared Sub WriteBEUInt64 (
    s As Stream,
    value As ULong
)
public:
[ExtensionAttribute]
static void WriteBEUInt64(
    Stream^ s,
    unsigned long long value
)
public:
[ExtensionAttribute]
static void WriteBEUInt64(
    Stream^ s,
    unsigned long long value
)
static member WriteBEUInt64 :
        s : Stream *
        value : uint64 -> unit
static member WriteBEUInt64 :
        s : Stream *
        value : uint64 -> unit

Parameters

s
Type: Online System.IO Stream
value
Type: Online System UInt64

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
WriteBEUInt64 Overload
NFX Namespace


IOMiscUtils.WriteBEUInt64 Method (Byte[], Int32, UInt64)

IOMiscUtils WriteBEUInt64 Method ( Byte , Int32, UInt64) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes an unsigned long integer encoded as big endian to buffer at the specified index

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteBEUInt64(
    this byte[] buf,
    int idx,
    ulong value
)
public static void WriteBEUInt64(
    this byte[] buf,
    int idx,
    ulong value
)
<ExtensionAttribute>
Public Shared Sub WriteBEUInt64 (
    buf As Byte(),
    idx As Integer,
    value As ULong
)
<ExtensionAttribute>
Public Shared Sub WriteBEUInt64 (
    buf As Byte(),
    idx As Integer,
    value As ULong
)
public:
[ExtensionAttribute]
static void WriteBEUInt64(
    array<unsigned char>^ buf,
    int idx,
    unsigned long long value
)
public:
[ExtensionAttribute]
static void WriteBEUInt64(
    array<unsigned char>^ buf,
    int idx,
    unsigned long long value
)
static member WriteBEUInt64 :
        buf : byte[] *
        idx : int *
        value : uint64 -> unit
static member WriteBEUInt64 :
        buf : byte[] *
        idx : int *
        value : uint64 -> unit

Parameters

buf
Type: Online System Byte
idx
Type: Online System Int32
value
Type: Online System UInt64

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
WriteBEUInt64 Overload
NFX Namespace


IOMiscUtils.WriteBEUShort Method

IOMiscUtils WriteBEUShort Method NFX Class Library

Writes an ushort encoded as big endian to the given stream

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteBEUShort(
    this Stream s,
    ushort value
)
public static void WriteBEUShort(
    this Stream s,
    ushort value
)
<ExtensionAttribute>
Public Shared Sub WriteBEUShort (
    s As Stream,
    value As UShort
)
<ExtensionAttribute>
Public Shared Sub WriteBEUShort (
    s As Stream,
    value As UShort
)
public:
[ExtensionAttribute]
static void WriteBEUShort(
    Stream^ s,
    unsigned short value
)
public:
[ExtensionAttribute]
static void WriteBEUShort(
    Stream^ s,
    unsigned short value
)
static member WriteBEUShort :
        s : Stream *
        value : uint16 -> unit
static member WriteBEUShort :
        s : Stream *
        value : uint16 -> unit

Parameters

s
Type: Online System.IO Stream
value
Type: Online System UInt16

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
IOMiscUtils Class
IOMiscUtils Members
NFX Namespace


IOrdered Interface

IOrdered Interface NFX Class Library

Denotes an entity that has a relative Order property within a collection of entities

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IOrdered
public interface IOrdered
Public Interface IOrdered
Public Interface IOrdered
public interface class IOrdered
public interface class IOrdered
type IOrdered =  interface end
type IOrdered =  interface end
See Also
IOrdered Members
NFX Namespace


IOrdered Members

IOrdered Members NFX Class Library

The IOrdered type exposes the following members.
Properties
 | Name | Description
Public property | Order |
Back to Top
See Also
IOrdered Interface
NFX Namespace


IOrdered Properties

IOrdered Properties NFX Class Library

The IOrdered type exposes the following members.
Properties
 | Name | Description
Public property | Order |
Back to Top
See Also
IOrdered Interface
NFX Namespace


IOrdered.Order Property

IOrdered Order Property NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int Order { get; }
int Order { get; }
ReadOnly Property Order As Integer
    Get
ReadOnly Property Order As Integer
    Get
property int Order {
    int get ();
}
property int Order {
    int get ();
}
abstract Order : int with get
abstract Order : int with get

Property Value

Type: Online Int32
See Also
IOrdered Interface
IOrdered Members
NFX Namespace


IOrderedRegistry(T) Interface

IOrderedRegistry T Interface NFX Class Library

Provides read-only named ordered object lookup capabilities

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IOrderedRegistry<out T> : IRegistry<T>,
    IEnumerable<T>, IEnumerable
where T : INamed, IOrdered
public interface IOrderedRegistry<out T> : IRegistry<T>,
    IEnumerable<T>, IEnumerable
where T : INamed, IOrdered
Public Interface IOrderedRegistry(Of Out T As {INamed, IOrdered})
    Inherits IRegistry(Of T), IEnumerable(Of T), IEnumerable
Public Interface IOrderedRegistry(Of Out T As {INamed, IOrdered})
    Inherits IRegistry(Of T), IEnumerable(Of T), IEnumerable
generic<typename T>
where T : INamed, IOrdered
public interface class IOrderedRegistry : IRegistry<T>,
    IEnumerable<T>, IEnumerable
generic<typename T>
where T : INamed, IOrdered
public interface class IOrderedRegistry : IRegistry<T>,
    IEnumerable<T>, IEnumerable
type IOrderedRegistry<'T when 'T : INamed and IOrdered> =
    interface
        interface IRegistry<'T>
        interface IEnumerable<'T>
        interface IEnumerable
    end
type IOrderedRegistry<'T when 'T : INamed and IOrdered> =
    interface
        interface IRegistry<'T>
        interface IEnumerable<'T>
        interface IEnumerable
    end
Type Parameters
T
See Also
IOrderedRegistry T Members
NFX Namespace


IOrderedRegistry(T) Members

IOrderedRegistry T Members NFX Class Library

The IOrderedRegistry T type exposes the following members.
Methods
 | Name | Description
Public method | ContainsName | Returns true if when this registry contains the specified name (Inherited from IRegistry T .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from Online IEnumerable T .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Online IEnumerable.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsLookAheadEnumerable T | (Defined by LookAheadExtensions.)
Public Extension Method | Distinct T, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault T | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast T | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast T (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns the count of items registered in this instance (Inherited from IRegistry T .)
Public property | IsCaseSensitive | Returns true if the instance differentiates names by case (Inherited from IRegistry T .)
Public property | Item Int32 | Tries to return an item by its position index in ordered set of items that this registry keeps. Null is returned when index is out of bounds. Note: since registry does reading in a lock-free manner, it is possible to have an inconsistent read snapshot of ordered items which may capture items that have already/not yet been added to the registry
Public property | Item String | Returns item by name or default item (such as null) if the named instance could not be found (Inherited from IRegistry T .)
Public property | Names | (Inherited from IRegistry T .)
Public property | OrderedValues | Returns items that registry contains ordered by their Order property. The returned sequence is pre-sorted during alteration of registry, so this property access is efficient. Note: since registry does reading in a lock-free manner, it is possible to have an inconsistent read snapshot of ordered items which may capture items that have already/not yet been added to the registry
Public property | Values | (Inherited from IRegistry T .)
Back to Top
See Also
IOrderedRegistry T Interface
NFX Namespace


IOrderedRegistry(T) Methods

IOrderedRegistry T Methods NFX Class Library

The IOrderedRegistry T type exposes the following members.
Methods
 | Name | Description
Public method | ContainsName | Returns true if when this registry contains the specified name (Inherited from IRegistry T .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from Online IEnumerable T .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Online IEnumerable.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsLookAheadEnumerable T | (Defined by LookAheadExtensions.)
Public Extension Method | Distinct T, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault T | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast T | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast T (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Back to Top
See Also
IOrderedRegistry T Interface
NFX Namespace


IOrderedRegistry(T) Properties

IOrderedRegistry T Properties NFX Class Library

The IOrderedRegistry T type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns the count of items registered in this instance (Inherited from IRegistry T .)
Public property | IsCaseSensitive | Returns true if the instance differentiates names by case (Inherited from IRegistry T .)
Public property | Item Int32 | Tries to return an item by its position index in ordered set of items that this registry keeps. Null is returned when index is out of bounds. Note: since registry does reading in a lock-free manner, it is possible to have an inconsistent read snapshot of ordered items which may capture items that have already/not yet been added to the registry
Public property | Item String | Returns item by name or default item (such as null) if the named instance could not be found (Inherited from IRegistry T .)
Public property | Names | (Inherited from IRegistry T .)
Public property | OrderedValues | Returns items that registry contains ordered by their Order property. The returned sequence is pre-sorted during alteration of registry, so this property access is efficient. Note: since registry does reading in a lock-free manner, it is possible to have an inconsistent read snapshot of ordered items which may capture items that have already/not yet been added to the registry
Public property | Values | (Inherited from IRegistry T .)
Back to Top
See Also
IOrderedRegistry T Interface
NFX Namespace


IOrderedRegistry(T).Item Property

IOrderedRegistry T Item Property NFX Class Library

Overload List
 | Name | Description
Public property | Item Int32 | Tries to return an item by its position index in ordered set of items that this registry keeps. Null is returned when index is out of bounds. Note: since registry does reading in a lock-free manner, it is possible to have an inconsistent read snapshot of ordered items which may capture items that have already/not yet been added to the registry
Public property | Item String | Returns item by name or default item (such as null) if the named instance could not be found (Inherited from IRegistry T .)
Back to Top
See Also
IOrderedRegistry T Interface
IOrderedRegistry T Members
NFX Namespace


IOrderedRegistry(T).Item Property (Int32)

IOrderedRegistry T Item Property (Int32) NFX Class Library

Tries to return an item by its position index in ordered set of items that this registry keeps. Null is returned when index is out of bounds. Note: since registry does reading in a lock-free manner, it is possible to have an inconsistent read snapshot of ordered items which may capture items that have already/not yet been added to the registry

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
T this[
    int index
] { get; }
T this[
    int index
] { get; }
ReadOnly Default Property Item (
    index As Integer
) As T
    Get
ReadOnly Default Property Item (
    index As Integer
) As T
    Get
property T default[int index] {
    T get (int index);
}
property T default[int index] {
    T get (int index);
}
abstract Item : 'T with get
abstract Item : 'T with get

Parameters

index
Type: Online System Int32

Property Value

Type: T
See Also
IOrderedRegistry T Interface
IOrderedRegistry T Members
Item Overload
NFX Namespace


IOrderedRegistry(T).OrderedValues Property

IOrderedRegistry T OrderedValues Property NFX Class Library

Returns items that registry contains ordered by their Order property. The returned sequence is pre-sorted during alteration of registry, so this property access is efficient. Note: since registry does reading in a lock-free manner, it is possible to have an inconsistent read snapshot of ordered items which may capture items that have already/not yet been added to the registry

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<T> OrderedValues { get; }
IEnumerable<T> OrderedValues { get; }
ReadOnly Property OrderedValues As IEnumerable(Of T)
    Get
ReadOnly Property OrderedValues As IEnumerable(Of T)
    Get
property IEnumerable<T>^ OrderedValues {
    IEnumerable<T>^ get ();
}
property IEnumerable<T>^ OrderedValues {
    IEnumerable<T>^ get ();
}
abstract OrderedValues : IEnumerable<'T> with get
abstract OrderedValues : IEnumerable<'T> with get

Property Value

Type: Online IEnumerable T
See Also
IOrderedRegistry T Interface
IOrderedRegistry T Members
NFX Namespace


IParameter Interface

IParameter Interface NFX Class Library

Represents abstract parameter

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IParameter : INamed
public interface IParameter : INamed
Public Interface IParameter
    Inherits INamed
Public Interface IParameter
    Inherits INamed
public interface class IParameter : INamed
public interface class IParameter : INamed
type IParameter =
    interface
        interface INamed
    end
type IParameter =
    interface
        interface INamed
    end
See Also
IParameter Members
NFX Namespace


IParameter Members

IParameter Members NFX Class Library

The IParameter type exposes the following members.
Properties
 | Name | Description
Public property | HasValue | Indicates whether parameter has a value, even if Value==null parameter may or may not have a value (be assigned) in some scenarious
Public property | IsInput | Indicates whether parameter is purposed as an input for a target
Public property | Name | (Inherited from INamed.)
Public property | Value | Parameter Value
Back to Top
See Also
IParameter Interface
NFX Namespace


IParameter Properties

IParameter Properties NFX Class Library

The IParameter type exposes the following members.
Properties
 | Name | Description
Public property | HasValue | Indicates whether parameter has a value, even if Value==null parameter may or may not have a value (be assigned) in some scenarious
Public property | IsInput | Indicates whether parameter is purposed as an input for a target
Public property | Name | (Inherited from INamed.)
Public property | Value | Parameter Value
Back to Top
See Also
IParameter Interface
NFX Namespace


IParameter.HasValue Property

IParameter HasValue Property NFX Class Library

Indicates whether parameter has a value, even if Value==null parameter may or may not have a value (be assigned) in some scenarious

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool HasValue { get; }
bool HasValue { get; }
ReadOnly Property HasValue As Boolean
    Get
ReadOnly Property HasValue As Boolean
    Get
property bool HasValue {
    bool get ();
}
property bool HasValue {
    bool get ();
}
abstract HasValue : bool with get
abstract HasValue : bool with get

Property Value

Type: Online Boolean
See Also
IParameter Interface
IParameter Members
NFX Namespace


IParameter.IsInput Property

IParameter IsInput Property NFX Class Library

Indicates whether parameter is purposed as an input for a target

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsInput { get; }
bool IsInput { get; }
ReadOnly Property IsInput As Boolean
    Get
ReadOnly Property IsInput As Boolean
    Get
property bool IsInput {
    bool get ();
}
property bool IsInput {
    bool get ();
}
abstract IsInput : bool with get
abstract IsInput : bool with get

Property Value

Type: Online Boolean
See Also
IParameter Interface
IParameter Members
NFX Namespace


IParameter.Value Property

IParameter Value Property NFX Class Library

Parameter Value

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object Value { get; }
Object Value { get; }
ReadOnly Property Value As Object
    Get
ReadOnly Property Value As Object
    Get
property Object^ Value {
    Object^ get ();
}
property Object^ Value {
    Object^ get ();
}
abstract Value : Object with get
abstract Value : Object with get

Property Value

Type: Online Object
See Also
IParameter Interface
IParameter Members
NFX Namespace


IParameters Interface

IParameters Interface NFX Class Library

Represents abstract parameters bag

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IParameters
public interface IParameters
Public Interface IParameters
Public Interface IParameters
public interface class IParameters
public interface class IParameters
type IParameters =  interface end
type IParameters =  interface end
See Also
IParameters Members
NFX Namespace


IParameters Members

IParameters Members NFX Class Library

The IParameters type exposes the following members.
Methods
 | Name | Description
Public method | FindParamByName | Tries to find parameter by name and returns null if parameter could not be found
Public method | ParamByName | Returns a parameter found by name or throws exception if it could not be found
Back to Top
Properties
 | Name | Description
Public property | AllParameters | Enumerates all parameters
Back to Top
See Also
IParameters Interface
NFX Namespace


IParameters Methods

IParameters Methods NFX Class Library

The IParameters type exposes the following members.
Methods
 | Name | Description
Public method | FindParamByName | Tries to find parameter by name and returns null if parameter could not be found
Public method | ParamByName | Returns a parameter found by name or throws exception if it could not be found
Back to Top
See Also
IParameters Interface
NFX Namespace


IParameters.FindParamByName Method

IParameters FindParamByName Method NFX Class Library

Tries to find parameter by name and returns null if parameter could not be found

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IParameter FindParamByName(
    string name
)
IParameter FindParamByName(
    string name
)
Function FindParamByName (
    name As String
) As IParameter
Function FindParamByName (
    name As String
) As IParameter
IParameter^ FindParamByName(
    String^ name
)
IParameter^ FindParamByName(
    String^ name
)
abstract FindParamByName :
        name : string -> IParameter
abstract FindParamByName :
        name : string -> IParameter

Parameters

name
Type: Online System String

Return Value

Type: IParameter
See Also
IParameters Interface
IParameters Members
NFX Namespace


IParameters.ParamByName Method

IParameters ParamByName Method NFX Class Library

Returns a parameter found by name or throws exception if it could not be found

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IParameter ParamByName(
    string name
)
IParameter ParamByName(
    string name
)
Function ParamByName (
    name As String
) As IParameter
Function ParamByName (
    name As String
) As IParameter
IParameter^ ParamByName(
    String^ name
)
IParameter^ ParamByName(
    String^ name
)
abstract ParamByName :
        name : string -> IParameter
abstract ParamByName :
        name : string -> IParameter

Parameters

name
Type: Online System String

Return Value

Type: IParameter
See Also
IParameters Interface
IParameters Members
NFX Namespace


IParameters Properties

IParameters Properties NFX Class Library

The IParameters type exposes the following members.
Properties
 | Name | Description
Public property | AllParameters | Enumerates all parameters
Back to Top
See Also
IParameters Interface
NFX Namespace


IParameters.AllParameters Property

IParameters AllParameters Property NFX Class Library

Enumerates all parameters

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<IParameter> AllParameters { get; }
IEnumerable<IParameter> AllParameters { get; }
ReadOnly Property AllParameters As IEnumerable(Of IParameter)
    Get
ReadOnly Property AllParameters As IEnumerable(Of IParameter)
    Get
property IEnumerable<IParameter^>^ AllParameters {
    IEnumerable<IParameter^>^ get ();
}
property IEnumerable<IParameter^>^ AllParameters {
    IEnumerable<IParameter^>^ get ();
}
abstract AllParameters : IEnumerable<IParameter> with get
abstract AllParameters : IEnumerable<IParameter> with get

Property Value

Type: Online IEnumerable IParameter
See Also
IParameters Interface
IParameters Members
NFX Namespace


IRegistry(T) Interface

IRegistry T Interface NFX Class Library

Provides read-only named object lookup capabilities

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IRegistry<out T> : IEnumerable<T>,
    IEnumerable
where T : INamed
public interface IRegistry<out T> : IEnumerable<T>,
    IEnumerable
where T : INamed
Public Interface IRegistry(Of Out T As INamed)
    Inherits IEnumerable(Of T), IEnumerable
Public Interface IRegistry(Of Out T As INamed)
    Inherits IEnumerable(Of T), IEnumerable
generic<typename T>
where T : INamed
public interface class IRegistry : IEnumerable<T>,
    IEnumerable
generic<typename T>
where T : INamed
public interface class IRegistry : IEnumerable<T>,
    IEnumerable
type IRegistry<'T when 'T : INamed> =
    interface
        interface IEnumerable<'T>
        interface IEnumerable
    end
type IRegistry<'T when 'T : INamed> =
    interface
        interface IEnumerable<'T>
        interface IEnumerable
    end
Type Parameters
T
See Also
IRegistry T Members
NFX Namespace


IRegistry(T) Members

IRegistry T Members NFX Class Library

The IRegistry T type exposes the following members.
Methods
 | Name | Description
Public method | ContainsName | Returns true if when this registry contains the specified name
Public method | Online GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from Online IEnumerable T .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Online IEnumerable.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsLookAheadEnumerable T | (Defined by LookAheadExtensions.)
Public Extension Method | Distinct T, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault T | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast T | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast T (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns the count of items registered in this instance
Public property | IsCaseSensitive | Returns true if the instance differentiates names by case
Public property | Item | Returns item by name or default item (such as null) if the named instance could not be found
Public property | Names |
Public property | Values |
Back to Top
See Also
IRegistry T Interface
NFX Namespace


IRegistry(T) Methods

IRegistry T Methods NFX Class Library

The IRegistry T type exposes the following members.
Methods
 | Name | Description
Public method | ContainsName | Returns true if when this registry contains the specified name
Public method | Online GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from Online IEnumerable T .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Online IEnumerable.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsLookAheadEnumerable T | (Defined by LookAheadExtensions.)
Public Extension Method | Distinct T, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault T | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast T | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast T (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Back to Top
See Also
IRegistry T Interface
NFX Namespace


IRegistry(T).ContainsName Method

IRegistry T ContainsName Method NFX Class Library

Returns true if when this registry contains the specified name

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool ContainsName(
    string name
)
bool ContainsName(
    string name
)
Function ContainsName (
    name As String
) As Boolean
Function ContainsName (
    name As String
) As Boolean
bool ContainsName(
    String^ name
)
bool ContainsName(
    String^ name
)
abstract ContainsName :
        name : string -> bool
abstract ContainsName :
        name : string -> bool

Parameters

name
Type: Online System String

Return Value

Type: Online Boolean
See Also
IRegistry T Interface
IRegistry T Members
NFX Namespace


IRegistry(T) Properties

IRegistry T Properties NFX Class Library

The IRegistry T type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns the count of items registered in this instance
Public property | IsCaseSensitive | Returns true if the instance differentiates names by case
Public property | Item | Returns item by name or default item (such as null) if the named instance could not be found
Public property | Names |
Public property | Values |
Back to Top
See Also
IRegistry T Interface
NFX Namespace


IRegistry(T).Count Property

IRegistry T Count Property NFX Class Library

Returns the count of items registered in this instance

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int Count { get; }
int Count { get; }
ReadOnly Property Count As Integer
    Get
ReadOnly Property Count As Integer
    Get
property int Count {
    int get ();
}
property int Count {
    int get ();
}
abstract Count : int with get
abstract Count : int with get

Property Value

Type: Online Int32
See Also
IRegistry T Interface
IRegistry T Members
NFX Namespace


IRegistry(T).IsCaseSensitive Property

IRegistry T IsCaseSensitive Property NFX Class Library

Returns true if the instance differentiates names by case

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsCaseSensitive { get; }
bool IsCaseSensitive { get; }
ReadOnly Property IsCaseSensitive As Boolean
    Get
ReadOnly Property IsCaseSensitive As Boolean
    Get
property bool IsCaseSensitive {
    bool get ();
}
property bool IsCaseSensitive {
    bool get ();
}
abstract IsCaseSensitive : bool with get
abstract IsCaseSensitive : bool with get

Property Value

Type: Online Boolean
See Also
IRegistry T Interface
IRegistry T Members
NFX Namespace


IRegistry(T).Item Property

IRegistry T Item Property NFX Class Library

Returns item by name or default item (such as null) if the named instance could not be found

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
T this[
    string name
] { get; }
T this[
    string name
] { get; }
ReadOnly Default Property Item (
    name As String
) As T
    Get
ReadOnly Default Property Item (
    name As String
) As T
    Get
property T default[String^ name] {
    T get (String^ name);
}
property T default[String^ name] {
    T get (String^ name);
}
abstract Item : 'T with get
abstract Item : 'T with get

Parameters

name
Type: Online System String

Property Value

Type: T
See Also
IRegistry T Interface
IRegistry T Members
NFX Namespace


IRegistry(T).Names Property

IRegistry T Names Property NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<string> Names { get; }
IEnumerable<string> Names { get; }
ReadOnly Property Names As IEnumerable(Of String)
    Get
ReadOnly Property Names As IEnumerable(Of String)
    Get
property IEnumerable<String^>^ Names {
    IEnumerable<String^>^ get ();
}
property IEnumerable<String^>^ Names {
    IEnumerable<String^>^ get ();
}
abstract Names : IEnumerable<string> with get
abstract Names : IEnumerable<string> with get

Property Value

Type: Online IEnumerable Online String
See Also
IRegistry T Interface
IRegistry T Members
NFX Namespace


IRegistry(T).Values Property

IRegistry T Values Property NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<T> Values { get; }
IEnumerable<T> Values { get; }
ReadOnly Property Values As IEnumerable(Of T)
    Get
ReadOnly Property Values As IEnumerable(Of T)
    Get
property IEnumerable<T>^ Values {
    IEnumerable<T>^ get ();
}
property IEnumerable<T>^ Values {
    IEnumerable<T>^ get ();
}
abstract Values : IEnumerable<'T> with get
abstract Values : IEnumerable<'T> with get

Property Value

Type: Online IEnumerable T
See Also
IRegistry T Interface
IRegistry T Members
NFX Namespace


MiscUtils Class

MiscUtils Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX MiscUtils

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class MiscUtils
public static class MiscUtils
<ExtensionAttribute>
Public NotInheritable Class MiscUtils
<ExtensionAttribute>
Public NotInheritable Class MiscUtils
[ExtensionAttribute]
public ref class MiscUtils abstract sealed
[ExtensionAttribute]
public ref class MiscUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MiscUtils =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MiscUtils =  class end
See Also
MiscUtils Members
NFX Namespace


MiscUtils Members

MiscUtils Members NFX Class Library

The MiscUtils type exposes the following members.
Methods
Name | Description
AllFileNames | Walks all file names in a directory
AllFileNamesThatMatch | Walks all file names that match the pattern in a directory
AppendFormatLine(StringBuilder, String, Object) | Appends the string followed by new line and returned by processing a composite format string, which contains zero or more format items, to this instance. Each format item is replaced by the string representation of a single argument.
AppendFormatLine(StringBuilder, String, Object ) | Appends the string followed by new line and returned by processing a composite format string, which contains zero or more format items, to this instance. Each format item is replaced by the string representation of a single argument.
AppendFormatLine(StringBuilder, String, Object, Object) | Appends the string followed by new line and returned by processing a composite format string, which contains zero or more format items, to this instance. Each format item is replaced by the string representation of a single argument.
AppendFormatLine(StringBuilder, String, Object, Object, Object) | Appends the string followed by new line and returned by processing a composite format string, which contains zero or more format items, to this instance. Each format item is replaced by the string representation of a single argument.
Args | Shortcut helper for string.Format(tpl, params object[] args)
ArgsTpl(String, Object) | Interprets template of the form: Some text {@value_name@:C} by replacing with property/field values. Note: this function does not recognize escapes for simplicity (as escapes can be replaced by regular strings instead)
ArgsTpl(String, Object, Boolean ) | Interprets template of the form: Some text {@value_name@:C} by replacing with property/field values. Note: this function does not recognize escapes for simplicity (as escapes can be replaced by regular strings instead). Matched is set to true if at least one property match was made
Burmatographize | Swaps string letters that "obfuscates" string- usefull for generation of keys from strings that have to become non-obvious to user. This function does not offer any real protection (as it is easy to decipher the original value), just visual. The name comes from non-existing science "Burmatography" used in "Neznaika" kids books
CapitalizeFirstChar | Capitalizes first character of string
Default | Defaults string if it is null or whitespace
DisplayNameWithExpandedGenericArgs | Returns the the name of the type with expanded generic argument names. This helper is useful for printing class names to logs/messages. List'1[System.Object] -> List<Object>
EntryExeName | Returns the name of entry point executable file optionaly with its path
EqualsIgnoreCase | Helper function that performs case-insensitive comparison between strings using invariant comparison. Either lhs and rhs can be null. Use this in conjunction with GetHashCodeIgnoreCase
EqualsOrdIgnoreCase | Helper function that performs case-insensitive comparison between strings using ordinal comparison. Either lhs and rhs can be null. Use this in conjunction with GetHashCodeOrdIgnoreCase
EqualsOrdSenseCase | Helper function that performs case-insensitive comparison between strings using ordinal comparison. Either lhs and rhs can be null. Use this in conjunction with GetHashCodeOrdSenseCase
EqualsSenseCase | Helper function that performs comparison between strings using invariant comparison. Either lhs and rhs can be null. Use this in conjunction with GetHashCodeSenseCase
EvaluateVars | Evaluates variables in a context of optional variable resolver and macro runner
EvaluateVarsInConfigScope | Evaluates variables in a context of optional configuration supplied as config object
EvaluateVarsInDictionaryScope | Evaluates variables in a context of optional configuration supplied as dictionary which is converted to attributes
EvaluateVarsInXMLConfigScope | Evaluates variables in a context of optional configuration supplied in XML format
FromMicrosecondsSinceUnixEpochStart(Int64) | Gets UTC DateTime from number of microseconds since Unix epoch start (1970/1/1 0:0:0)
FromMicrosecondsSinceUnixEpochStart(UInt64) | Gets UTC DateTime from number of microseconds since Unix epoch start (1970/1/1 0:0:0)
FromMillisecondsSinceUnixEpochStart(Int64) | Gets UTC DateTime from number of milliseconds since Unix epoch start (1970/1/1 0:0:0)
FromMillisecondsSinceUnixEpochStart(UInt64) | Gets UTC DateTime from number of milliseconds since Unix epoch start (1970/1/1 0:0:0)
FromSecondsSinceUnixEpochStart(Int64) | Gets UTC DateTime from number of seconds since Unix epoch start (1970/1/1 0:0:0)
FromSecondsSinceUnixEpochStart(UInt64) | Gets UTC DateTime from number of seconds since Unix epoch start (1970/1/1 0:0:0)
FromUTF8Bytes | Decode string with standart UTF8 decoder
FullNameWithExpandedGenericArgs | Returns the full name of the type optionally prefixed with verbatim id specifier '@'. The generic arguments ar expanded into their full names i.e. List'1[System.Object] -> System.Collections.Generic.List<System.Object>
GetHashCodeIgnoreCase | Helper function that performs case-insensitive GetHashcode for string using invariant comparison. Use this in conjunction with EqualsIgnoreCase
GetHashCodeOrdIgnoreCase | Helper function that performs case-insensitive GetHashcode for string using ordinal comparison. Use this in conjunction with EqualsOrdIgnoreCase
GetHashCodeOrdSenseCase | Helper function that performs case-insensitive GetHashcode for string using ordinal comparison. Use this in conjunction with EqualsOrdSenseCase
GetHashCodeSenseCase | Helper function that performs GetHashcode for string using invariant comparison. Use this in conjunction with EqualsSenseCase
IPStringToIPEndPoint | Obsolete. Converts string of format "xx.xx.xx.xx:nnnn" into IPEndPoint. DNS names are NOT supported
IsComponentDesignerHosted | Determines if component is being used within designer
IsNotNullOrEmpty | Helper function that calls !string.IsNullOrEmpty()
IsNotNullOrWhiteSpace | Helper function that calls !string.IsNullOrWhiteSpace()
IsNullOrEmpty | Helper function that calls string.IsNullOrEmpty()
IsNullOrWhiteSpace | Helper function that calls string.IsNullOrWhiteSpace()
IsTrue |
IsValidXMLName | Returns true when supplied name can be used for XML node naming (node names, attribute names)
NonNull T | Checks the value for null and throws exception if it is. The method is useful for .ctor call chaining to preclude otherwise anonymous NullReferenceException
RoundToNextWeekDay | Round date to next specific week day
RoundToWeekDay | Round date to specific week day
RunAndCompleteProcess | Runs specified process and waits for termination returning standard process output. This is a blocking call
SplitLines | Splits string into lines using Win or .nix line brakes
StripSimpleHtml | Strip simple html from string
TakeFirstChars | Takes first X chars from a string. If string is null returns null. If string does not have enough the function returns what the string has
ToConfigAttributes | Converts dictionary into configuration where every original node gets represented as an attribute of config's root
ToConfigSections | Converts dictionary into configuration where every original node gets represented as a sub-section of config's root
ToDebugView | Converts expression tree to simple textual form for debugging
ToDescription | Returns MemberInfo described as short string
ToDumpString | Convert a buffer to a printable string
ToGUID | Generates GUID based on a string MD5 hash
ToIPEndPoint | Resolve IP address by Name
ToJSONDataMap | If there is error, converts its details to JSOnDataMap
ToMD5( Byte ) | Returns a MD5 hash of a byte array
ToMD5(String) | Returns a MD5 hash of a UTF8 string represented as byte[]
ToMD5String | Returns a MD5 hash of a UTF8 string represented as hex string
ToMessageWithType | Writes exception message with exception type
ToMicrosecondsSinceUnixEpochStart | Gets number of microseconds since Unix epoch start (1970/1/1 0:0:0)
ToMillisecondsSinceUnixEpochStart | Gets number of milliseconds since Unix epoch start (1970/1/1 0:0:0)
ToSecondsSinceUnixEpochStart | Gets number of seconds since Unix epoch start (1970/1/1 0:0:0)
ToUTF8Bytes | Encodes string with standart UTF8 encoder
Truncate | Tuncate date to specific resolution
Back to Top
Fields
Name | Description
UNIX_EPOCH_START_DATE |
WIN_UNIX_LINE_BRAKES |
Back to Top
See Also
MiscUtils Class
NFX Namespace


MiscUtils Fields

MiscUtils Fields NFX Class Library

The MiscUtils type exposes the following members.
Fields
Name | Description
UNIX_EPOCH_START_DATE |
WIN_UNIX_LINE_BRAKES |
Back to Top
See Also
MiscUtils Class
NFX Namespace


MiscUtils.UNIX_EPOCH_START_DATE Field

MiscUtils UNIX_EPOCH_START_DATE Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly DateTime UNIX_EPOCH_START_DATE
public static readonly DateTime UNIX_EPOCH_START_DATE
Public Shared ReadOnly UNIX_EPOCH_START_DATE As DateTime
Public Shared ReadOnly UNIX_EPOCH_START_DATE As DateTime
public:
static initonly DateTime UNIX_EPOCH_START_DATE
public:
static initonly DateTime UNIX_EPOCH_START_DATE
static val UNIX_EPOCH_START_DATE: DateTime
static val UNIX_EPOCH_START_DATE: DateTime

Field Value

Type: Online DateTime
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.WIN_UNIX_LINE_BRAKES Field

MiscUtils WIN_UNIX_LINE_BRAKES Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string[] WIN_UNIX_LINE_BRAKES
public static readonly string[] WIN_UNIX_LINE_BRAKES
Public Shared ReadOnly WIN_UNIX_LINE_BRAKES As String()
Public Shared ReadOnly WIN_UNIX_LINE_BRAKES As String()
public:
static initonly array<String^>^ WIN_UNIX_LINE_BRAKES
public:
static initonly array<String^>^ WIN_UNIX_LINE_BRAKES
static val WIN_UNIX_LINE_BRAKES: string[]
static val WIN_UNIX_LINE_BRAKES: string[]

Field Value

Type: Online String
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils Methods

MiscUtils Methods NFX Class Library

The MiscUtils type exposes the following members.
Methods
Name | Description
AllFileNames | Walks all file names in a directory
AllFileNamesThatMatch | Walks all file names that match the pattern in a directory
AppendFormatLine(StringBuilder, String, Object) | Appends the string followed by new line and returned by processing a composite format string, which contains zero or more format items, to this instance. Each format item is replaced by the string representation of a single argument.
AppendFormatLine(StringBuilder, String, Object ) | Appends the string followed by new line and returned by processing a composite format string, which contains zero or more format items, to this instance. Each format item is replaced by the string representation of a single argument.
AppendFormatLine(StringBuilder, String, Object, Object) | Appends the string followed by new line and returned by processing a composite format string, which contains zero or more format items, to this instance. Each format item is replaced by the string representation of a single argument.
AppendFormatLine(StringBuilder, String, Object, Object, Object) | Appends the string followed by new line and returned by processing a composite format string, which contains zero or more format items, to this instance. Each format item is replaced by the string representation of a single argument.
Args | Shortcut helper for string.Format(tpl, params object[] args)
ArgsTpl(String, Object) | Interprets template of the form: Some text {@value_name@:C} by replacing with property/field values. Note: this function does not recognize escapes for simplicity (as escapes can be replaced by regular strings instead)
ArgsTpl(String, Object, Boolean ) | Interprets template of the form: Some text {@value_name@:C} by replacing with property/field values. Note: this function does not recognize escapes for simplicity (as escapes can be replaced by regular strings instead). Matched is set to true if at least one property match was made
Burmatographize | Swaps string letters that "obfuscates" string- usefull for generation of keys from strings that have to become non-obvious to user. This function does not offer any real protection (as it is easy to decipher the original value), just visual. The name comes from non-existing science "Burmatography" used in "Neznaika" kids books
CapitalizeFirstChar | Capitalizes first character of string
Default | Defaults string if it is null or whitespace
DisplayNameWithExpandedGenericArgs | Returns the the name of the type with expanded generic argument names. This helper is useful for printing class names to logs/messages. List'1[System.Object] -> List<Object>
EntryExeName | Returns the name of entry point executable file optionaly with its path
EqualsIgnoreCase | Helper function that performs case-insensitive comparison between strings using invariant comparison. Either lhs and rhs can be null. Use this in conjunction with GetHashCodeIgnoreCase
EqualsOrdIgnoreCase | Helper function that performs case-insensitive comparison between strings using ordinal comparison. Either lhs and rhs can be null. Use this in conjunction with GetHashCodeOrdIgnoreCase
EqualsOrdSenseCase | Helper function that performs case-insensitive comparison between strings using ordinal comparison. Either lhs and rhs can be null. Use this in conjunction with GetHashCodeOrdSenseCase
EqualsSenseCase | Helper function that performs comparison between strings using invariant comparison. Either lhs and rhs can be null. Use this in conjunction with GetHashCodeSenseCase
EvaluateVars | Evaluates variables in a context of optional variable resolver and macro runner
EvaluateVarsInConfigScope | Evaluates variables in a context of optional configuration supplied as config object
EvaluateVarsInDictionaryScope | Evaluates variables in a context of optional configuration supplied as dictionary which is converted to attributes
EvaluateVarsInXMLConfigScope | Evaluates variables in a context of optional configuration supplied in XML format
FromMicrosecondsSinceUnixEpochStart(Int64) | Gets UTC DateTime from number of microseconds since Unix epoch start (1970/1/1 0:0:0)
FromMicrosecondsSinceUnixEpochStart(UInt64) | Gets UTC DateTime from number of microseconds since Unix epoch start (1970/1/1 0:0:0)
FromMillisecondsSinceUnixEpochStart(Int64) | Gets UTC DateTime from number of milliseconds since Unix epoch start (1970/1/1 0:0:0)
FromMillisecondsSinceUnixEpochStart(UInt64) | Gets UTC DateTime from number of milliseconds since Unix epoch start (1970/1/1 0:0:0)
FromSecondsSinceUnixEpochStart(Int64) | Gets UTC DateTime from number of seconds since Unix epoch start (1970/1/1 0:0:0)
FromSecondsSinceUnixEpochStart(UInt64) | Gets UTC DateTime from number of seconds since Unix epoch start (1970/1/1 0:0:0)
FromUTF8Bytes | Decode string with standart UTF8 decoder
FullNameWithExpandedGenericArgs | Returns the full name of the type optionally prefixed with verbatim id specifier '@'. The generic arguments ar expanded into their full names i.e. List'1[System.Object] -> System.Collections.Generic.List<System.Object>
GetHashCodeIgnoreCase | Helper function that performs case-insensitive GetHashcode for string using invariant comparison. Use this in conjunction with EqualsIgnoreCase
GetHashCodeOrdIgnoreCase | Helper function that performs case-insensitive GetHashcode for string using ordinal comparison. Use this in conjunction with EqualsOrdIgnoreCase
GetHashCodeOrdSenseCase | Helper function that performs case-insensitive GetHashcode for string using ordinal comparison. Use this in conjunction with EqualsOrdSenseCase
GetHashCodeSenseCase | Helper function that performs GetHashcode for string using invariant comparison. Use this in conjunction with EqualsSenseCase
IPStringToIPEndPoint | Obsolete. Converts string of format "xx.xx.xx.xx:nnnn" into IPEndPoint. DNS names are NOT supported
IsComponentDesignerHosted | Determines if component is being used within designer
IsNotNullOrEmpty | Helper function that calls !string.IsNullOrEmpty()
IsNotNullOrWhiteSpace | Helper function that calls !string.IsNullOrWhiteSpace()
IsNullOrEmpty | Helper function that calls string.IsNullOrEmpty()
IsNullOrWhiteSpace | Helper function that calls string.IsNullOrWhiteSpace()
IsTrue |
IsValidXMLName | Returns true when supplied name can be used for XML node naming (node names, attribute names)
NonNull T | Checks the value for null and throws exception if it is. The method is useful for .ctor call chaining to preclude otherwise anonymous NullReferenceException
RoundToNextWeekDay | Round date to next specific week day
RoundToWeekDay | Round date to specific week day
RunAndCompleteProcess | Runs specified process and waits for termination returning standard process output. This is a blocking call
SplitLines | Splits string into lines using Win or .nix line brakes
StripSimpleHtml | Strip simple html from string
TakeFirstChars | Takes first X chars from a string. If string is null returns null. If string does not have enough the function returns what the string has
ToConfigAttributes | Converts dictionary into configuration where every original node gets represented as an attribute of config's root
ToConfigSections | Converts dictionary into configuration where every original node gets represented as a sub-section of config's root
ToDebugView | Converts expression tree to simple textual form for debugging
ToDescription | Returns MemberInfo described as short string
ToDumpString | Convert a buffer to a printable string
ToGUID | Generates GUID based on a string MD5 hash
ToIPEndPoint | Resolve IP address by Name
ToJSONDataMap | If there is error, converts its details to JSOnDataMap
ToMD5( Byte ) | Returns a MD5 hash of a byte array
ToMD5(String) | Returns a MD5 hash of a UTF8 string represented as byte[]
ToMD5String | Returns a MD5 hash of a UTF8 string represented as hex string
ToMessageWithType | Writes exception message with exception type
ToMicrosecondsSinceUnixEpochStart | Gets number of microseconds since Unix epoch start (1970/1/1 0:0:0)
ToMillisecondsSinceUnixEpochStart | Gets number of milliseconds since Unix epoch start (1970/1/1 0:0:0)
ToSecondsSinceUnixEpochStart | Gets number of seconds since Unix epoch start (1970/1/1 0:0:0)
ToUTF8Bytes | Encodes string with standart UTF8 encoder
Truncate | Tuncate date to specific resolution
Back to Top
See Also
MiscUtils Class
NFX Namespace


MiscUtils.AllFileNames Method

MiscUtils AllFileNames Method NFX Class Library

Walks all file names in a directory

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<string> AllFileNames(
    this string fromFolder,
    bool recurse
)
public static IEnumerable<string> AllFileNames(
    this string fromFolder,
    bool recurse
)
<ExtensionAttribute>
Public Shared Function AllFileNames (
    fromFolder As String,
    recurse As Boolean
) As IEnumerable(Of String)
<ExtensionAttribute>
Public Shared Function AllFileNames (
    fromFolder As String,
    recurse As Boolean
) As IEnumerable(Of String)
public:
[ExtensionAttribute]
static IEnumerable<String^>^ AllFileNames(
    String^ fromFolder,
    bool recurse
)
public:
[ExtensionAttribute]
static IEnumerable<String^>^ AllFileNames(
    String^ fromFolder,
    bool recurse
)
static member AllFileNames :
        fromFolder : string *
        recurse : bool -> IEnumerable<string>
static member AllFileNames :
        fromFolder : string *
        recurse : bool -> IEnumerable<string>

Parameters

fromFolder
Type: Online System String
recurse
Type: Online System Boolean

Return Value

Type: Online IEnumerable Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.AllFileNamesThatMatch Method

MiscUtils AllFileNamesThatMatch Method NFX Class Library

Walks all file names that match the pattern in a directory

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<string> AllFileNamesThatMatch(
    this string fromFolder,
    string pattern,
    bool recurse
)
public static IEnumerable<string> AllFileNamesThatMatch(
    this string fromFolder,
    string pattern,
    bool recurse
)
<ExtensionAttribute>
Public Shared Function AllFileNamesThatMatch (
    fromFolder As String,
    pattern As String,
    recurse As Boolean
) As IEnumerable(Of String)
<ExtensionAttribute>
Public Shared Function AllFileNamesThatMatch (
    fromFolder As String,
    pattern As String,
    recurse As Boolean
) As IEnumerable(Of String)
public:
[ExtensionAttribute]
static IEnumerable<String^>^ AllFileNamesThatMatch(
    String^ fromFolder,
    String^ pattern,
    bool recurse
)
public:
[ExtensionAttribute]
static IEnumerable<String^>^ AllFileNamesThatMatch(
    String^ fromFolder,
    String^ pattern,
    bool recurse
)
static member AllFileNamesThatMatch :
        fromFolder : string *
        pattern : string *
        recurse : bool -> IEnumerable<string>
static member AllFileNamesThatMatch :
        fromFolder : string *
        pattern : string *
        recurse : bool -> IEnumerable<string>

Parameters

fromFolder
Type: Online System String
pattern
Type: Online System String
recurse
Type: Online System Boolean

Return Value

Type: Online IEnumerable Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.AppendFormatLine Method

MiscUtils AppendFormatLine Method NFX Class Library

Overload List
Name | Description
AppendFormatLine(StringBuilder, String, Object) | Appends the string followed by new line and returned by processing a composite format string, which contains zero or more format items, to this instance. Each format item is replaced by the string representation of a single argument.
AppendFormatLine(StringBuilder, String, Object ) | Appends the string followed by new line and returned by processing a composite format string, which contains zero or more format items, to this instance. Each format item is replaced by the string representation of a single argument.
AppendFormatLine(StringBuilder, String, Object, Object) | Appends the string followed by new line and returned by processing a composite format string, which contains zero or more format items, to this instance. Each format item is replaced by the string representation of a single argument.
AppendFormatLine(StringBuilder, String, Object, Object, Object) | Appends the string followed by new line and returned by processing a composite format string, which contains zero or more format items, to this instance. Each format item is replaced by the string representation of a single argument.
Back to Top
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.AppendFormatLine Method (StringBuilder, String, Object)

MiscUtils AppendFormatLine Method (StringBuilder, String, Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Appends the string followed by new line and returned by processing a composite format string, which contains zero or more format items, to this instance. Each format item is replaced by the string representation of a single argument.

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static StringBuilder AppendFormatLine(
    this StringBuilder builder,
    string str,
    Object arg0
)
public static StringBuilder AppendFormatLine(
    this StringBuilder builder,
    string str,
    Object arg0
)
<ExtensionAttribute>
Public Shared Function AppendFormatLine (
    builder As StringBuilder,
    str As String,
    arg0 As Object
) As StringBuilder
<ExtensionAttribute>
Public Shared Function AppendFormatLine (
    builder As StringBuilder,
    str As String,
    arg0 As Object
) As StringBuilder
public:
[ExtensionAttribute]
static StringBuilder^ AppendFormatLine(
    StringBuilder^ builder,
    String^ str,
    Object^ arg0
)
public:
[ExtensionAttribute]
static StringBuilder^ AppendFormatLine(
    StringBuilder^ builder,
    String^ str,
    Object^ arg0
)
static member AppendFormatLine :
        builder : StringBuilder *
        str : string *
        arg0 : Object -> StringBuilder
static member AppendFormatLine :
        builder : StringBuilder *
        str : string *
        arg0 : Object -> StringBuilder

Parameters

builder
Type: Online System.Text StringBuilder
str
Type: Online System String
arg0
Type: Online System Object

Return Value

Type: Online StringBuilder

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online StringBuilder. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
AppendFormatLine Overload
NFX Namespace


MiscUtils.AppendFormatLine Method (StringBuilder, String, Object[])

MiscUtils AppendFormatLine Method (StringBuilder, String, Object ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Appends the string followed by new line and returned by processing a composite format string, which contains zero or more format items, to this instance. Each format item is replaced by the string representation of a single argument.

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static StringBuilder AppendFormatLine(
    this StringBuilder builder,
    string str,
    params Object[] args
)
public static StringBuilder AppendFormatLine(
    this StringBuilder builder,
    string str,
    params Object[] args
)
<ExtensionAttribute>
Public Shared Function AppendFormatLine (
    builder As StringBuilder,
    str As String,
    ParamArray args As Object()
) As StringBuilder
<ExtensionAttribute>
Public Shared Function AppendFormatLine (
    builder As StringBuilder,
    str As String,
    ParamArray args As Object()
) As StringBuilder
public:
[ExtensionAttribute]
static StringBuilder^ AppendFormatLine(
    StringBuilder^ builder,
    String^ str,
    ... array<Object^>^ args
)
public:
[ExtensionAttribute]
static StringBuilder^ AppendFormatLine(
    StringBuilder^ builder,
    String^ str,
    ... array<Object^>^ args
)
static member AppendFormatLine :
        builder : StringBuilder *
        str : string *
        args : Object[] -> StringBuilder
static member AppendFormatLine :
        builder : StringBuilder *
        str : string *
        args : Object[] -> StringBuilder

Parameters

builder
Type: Online System.Text StringBuilder
str
Type: Online System String
args
Type: Online System Object

Return Value

Type: Online StringBuilder

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online StringBuilder. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
AppendFormatLine Overload
NFX Namespace


MiscUtils.AppendFormatLine Method (StringBuilder, String, Object, Object)

MiscUtils AppendFormatLine Method (StringBuilder, String, Object, Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Appends the string followed by new line and returned by processing a composite format string, which contains zero or more format items, to this instance. Each format item is replaced by the string representation of a single argument.

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static StringBuilder AppendFormatLine(
    this StringBuilder builder,
    string str,
    Object arg0,
    Object arg1
)
public static StringBuilder AppendFormatLine(
    this StringBuilder builder,
    string str,
    Object arg0,
    Object arg1
)
<ExtensionAttribute>
Public Shared Function AppendFormatLine (
    builder As StringBuilder,
    str As String,
    arg0 As Object,
    arg1 As Object
) As StringBuilder
<ExtensionAttribute>
Public Shared Function AppendFormatLine (
    builder As StringBuilder,
    str As String,
    arg0 As Object,
    arg1 As Object
) As StringBuilder
public:
[ExtensionAttribute]
static StringBuilder^ AppendFormatLine(
    StringBuilder^ builder,
    String^ str,
    Object^ arg0,
    Object^ arg1
)
public:
[ExtensionAttribute]
static StringBuilder^ AppendFormatLine(
    StringBuilder^ builder,
    String^ str,
    Object^ arg0,
    Object^ arg1
)
static member AppendFormatLine :
        builder : StringBuilder *
        str : string *
        arg0 : Object *
        arg1 : Object -> StringBuilder
static member AppendFormatLine :
        builder : StringBuilder *
        str : string *
        arg0 : Object *
        arg1 : Object -> StringBuilder

Parameters

builder
Type: Online System.Text StringBuilder
str
Type: Online System String
arg0
Type: Online System Object
arg1
Type: Online System Object

Return Value

Type: Online StringBuilder

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online StringBuilder. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
AppendFormatLine Overload
NFX Namespace


MiscUtils.AppendFormatLine Method (StringBuilder, String, Object, Object, Object)

MiscUtils AppendFormatLine Method (StringBuilder, String, Object, Object, Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Appends the string followed by new line and returned by processing a composite format string, which contains zero or more format items, to this instance. Each format item is replaced by the string representation of a single argument.

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static StringBuilder AppendFormatLine(
    this StringBuilder builder,
    string str,
    Object arg0,
    Object arg1,
    Object arg2
)
public static StringBuilder AppendFormatLine(
    this StringBuilder builder,
    string str,
    Object arg0,
    Object arg1,
    Object arg2
)
<ExtensionAttribute>
Public Shared Function AppendFormatLine (
    builder As StringBuilder,
    str As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
) As StringBuilder
<ExtensionAttribute>
Public Shared Function AppendFormatLine (
    builder As StringBuilder,
    str As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
) As StringBuilder
public:
[ExtensionAttribute]
static StringBuilder^ AppendFormatLine(
    StringBuilder^ builder,
    String^ str,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
public:
[ExtensionAttribute]
static StringBuilder^ AppendFormatLine(
    StringBuilder^ builder,
    String^ str,
    Object^ arg0,
    Object^ arg1,
    Object^ arg2
)
static member AppendFormatLine :
        builder : StringBuilder *
        str : string *
        arg0 : Object *
        arg1 : Object *
        arg2 : Object -> StringBuilder
static member AppendFormatLine :
        builder : StringBuilder *
        str : string *
        arg0 : Object *
        arg1 : Object *
        arg2 : Object -> StringBuilder

Parameters

builder
Type: Online System.Text StringBuilder
str
Type: Online System String
arg0
Type: Online System Object
arg1
Type: Online System Object
arg2
Type: Online System Object

Return Value

Type: Online StringBuilder

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online StringBuilder. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
AppendFormatLine Overload
NFX Namespace


MiscUtils.Args Method

MiscUtils Args Method NFX Class Library

Shortcut helper for string.Format(tpl, params object[] args)

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Args(
    this string tpl,
    params Object[] args
)
public static string Args(
    this string tpl,
    params Object[] args
)
<ExtensionAttribute>
Public Shared Function Args (
    tpl As String,
    ParamArray args As Object()
) As String
<ExtensionAttribute>
Public Shared Function Args (
    tpl As String,
    ParamArray args As Object()
) As String
public:
[ExtensionAttribute]
static String^ Args(
    String^ tpl,
    ... array<Object^>^ args
)
public:
[ExtensionAttribute]
static String^ Args(
    String^ tpl,
    ... array<Object^>^ args
)
static member Args :
        tpl : string *
        args : Object[] -> string
static member Args :
        tpl : string *
        args : Object[] -> string

Parameters

tpl
Type: Online System String
args
Type: Online System Object

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.ArgsTpl Method

MiscUtils ArgsTpl Method NFX Class Library

Overload List
Name | Description
ArgsTpl(String, Object) | Interprets template of the form: Some text {@value_name@:C} by replacing with property/field values. Note: this function does not recognize escapes for simplicity (as escapes can be replaced by regular strings instead)
ArgsTpl(String, Object, Boolean ) | Interprets template of the form: Some text {@value_name@:C} by replacing with property/field values. Note: this function does not recognize escapes for simplicity (as escapes can be replaced by regular strings instead). Matched is set to true if at least one property match was made
Back to Top
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.ArgsTpl Method (String, Object)

MiscUtils ArgsTpl Method (String, Object) NFX Class Library

Interprets template of the form: Some text {@value_name@:C} by replacing with property/field values. Note: this function does not recognize escapes for simplicity (as escapes can be replaced by regular strings instead)

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ArgsTpl(
    this string tpl,
    Object args
)
public static string ArgsTpl(
    this string tpl,
    Object args
)
<ExtensionAttribute>
Public Shared Function ArgsTpl (
    tpl As String,
    args As Object
) As String
<ExtensionAttribute>
Public Shared Function ArgsTpl (
    tpl As String,
    args As Object
) As String
public:
[ExtensionAttribute]
static String^ ArgsTpl(
    String^ tpl,
    Object^ args
)
public:
[ExtensionAttribute]
static String^ ArgsTpl(
    String^ tpl,
    Object^ args
)
static member ArgsTpl :
        tpl : string *
        args : Object -> string
static member ArgsTpl :
        tpl : string *
        args : Object -> string

Parameters

tpl
Type: Online System String
args
Type: Online System Object

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
ArgsTpl Overload
NFX Namespace


MiscUtils.ArgsTpl Method (String, Object, Boolean)

MiscUtils ArgsTpl Method (String, Object, Boolean ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Interprets template of the form: Some text {@value_name@:C} by replacing with property/field values. Note: this function does not recognize escapes for simplicity (as escapes can be replaced by regular strings instead). Matched is set to true if at least one property match was made

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ArgsTpl(
    this string tpl,
    Object args,
    out bool matched
)
public static string ArgsTpl(
    this string tpl,
    Object args,
    out bool matched
)
<ExtensionAttribute>
Public Shared Function ArgsTpl (
    tpl As String,
    args As Object,
    <OutAttribute> ByRef matched As Boolean
) As String
<ExtensionAttribute>
Public Shared Function ArgsTpl (
    tpl As String,
    args As Object,
    <OutAttribute> ByRef matched As Boolean
) As String
public:
[ExtensionAttribute]
static String^ ArgsTpl(
    String^ tpl,
    Object^ args,
    [OutAttribute] bool% matched
)
public:
[ExtensionAttribute]
static String^ ArgsTpl(
    String^ tpl,
    Object^ args,
    [OutAttribute] bool% matched
)
static member ArgsTpl :
        tpl : string *
        args : Object *
        matched : bool byref -> string
static member ArgsTpl :
        tpl : string *
        args : Object *
        matched : bool byref -> string

Parameters

tpl
Type: Online System String
args
Type: Online System Object
matched
Type: Online System Boolean

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
ArgsTpl Overload
NFX Namespace


MiscUtils.Burmatographize Method

MiscUtils Burmatographize Method NFX Class Library

Swaps string letters that "obfuscates" string- usefull for generation of keys from strings that have to become non-obvious to user. This function does not offer any real protection (as it is easy to decipher the original value), just visual. The name comes from non-existing science "Burmatography" used in "Neznaika" kids books

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Burmatographize(
    this string src,
    bool rtl = false
)
public static string Burmatographize(
    this string src,
    bool rtl = false
)
<ExtensionAttribute>
Public Shared Function Burmatographize (
    src As String,
    Optional rtl As Boolean = false
) As String
<ExtensionAttribute>
Public Shared Function Burmatographize (
    src As String,
    Optional rtl As Boolean = false
) As String
public:
[ExtensionAttribute]
static String^ Burmatographize(
    String^ src,
    bool rtl = false
)
public:
[ExtensionAttribute]
static String^ Burmatographize(
    String^ src,
    bool rtl = false
)
static member Burmatographize :
        src : string *
        ?rtl : bool
(* Defaults:
        let _rtl = defaultArg rtl false
*)
-> string
static member Burmatographize :
        src : string *
        ?rtl : bool
(* Defaults:
        let _rtl = defaultArg rtl false
*)
-> string

Parameters

src
Type: Online System String
rtl (Optional)
Type: Online System Boolean

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.CapitalizeFirstChar Method

MiscUtils CapitalizeFirstChar Method NFX Class Library

Capitalizes first character of string

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string CapitalizeFirstChar(
    this string str
)
public static string CapitalizeFirstChar(
    this string str
)
<ExtensionAttribute>
Public Shared Function CapitalizeFirstChar (
    str As String
) As String
<ExtensionAttribute>
Public Shared Function CapitalizeFirstChar (
    str As String
) As String
public:
[ExtensionAttribute]
static String^ CapitalizeFirstChar(
    String^ str
)
public:
[ExtensionAttribute]
static String^ CapitalizeFirstChar(
    String^ str
)
static member CapitalizeFirstChar :
        str : string -> string
static member CapitalizeFirstChar :
        str : string -> string

Parameters

str
Type: Online System String

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.Default Method

MiscUtils Default Method NFX Class Library

Defaults string if it is null or whitespace

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Default(
    this string str,
    string val = ""
)
public static string Default(
    this string str,
    string val = ""
)
<ExtensionAttribute>
Public Shared Function Default (
    str As String,
    Optional val As String = ""
) As String
<ExtensionAttribute>
Public Shared Function Default (
    str As String,
    Optional val As String = ""
) As String
public:
[ExtensionAttribute]
static String^ Default(
    String^ str,
    String^ val = L""
)
public:
[ExtensionAttribute]
static String^ Default(
    String^ str,
    String^ val = L""
)
static member Default :
        str : string *
        ?val : string
(* Defaults:
        let _val = defaultArg val ""
*)
-> string
static member Default :
        str : string *
        ?val : string
(* Defaults:
        let _val = defaultArg val ""
*)
-> string

Parameters

str
Type: Online System String
val (Optional)
Type: Online System String

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.DisplayNameWithExpandedGenericArgs Method

MiscUtils DisplayNameWithExpandedGenericArgs Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns the the name of the type with expanded generic argument names. This helper is useful for printing class names to logs/messages. List'1[System.Object] -> List<Object>

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string DisplayNameWithExpandedGenericArgs(
    this Type type
)
public static string DisplayNameWithExpandedGenericArgs(
    this Type type
)
<ExtensionAttribute>
Public Shared Function DisplayNameWithExpandedGenericArgs (
    type As Type
) As String
<ExtensionAttribute>
Public Shared Function DisplayNameWithExpandedGenericArgs (
    type As Type
) As String
public:
[ExtensionAttribute]
static String^ DisplayNameWithExpandedGenericArgs(
    Type^ type
)
public:
[ExtensionAttribute]
static String^ DisplayNameWithExpandedGenericArgs(
    Type^ type
)
static member DisplayNameWithExpandedGenericArgs :
        type : Type -> string
static member DisplayNameWithExpandedGenericArgs :
        type : Type -> string

Parameters

type
Type: Online System Type

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.EntryExeName Method

MiscUtils EntryExeName Method NFX Class Library

Returns the name of entry point executable file optionaly with its path

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string EntryExeName(
    bool withPath = true
)
public static string EntryExeName(
    bool withPath = true
)
Public Shared Function EntryExeName (
    Optional withPath As Boolean = true
) As String
Public Shared Function EntryExeName (
    Optional withPath As Boolean = true
) As String
public:
static String^ EntryExeName(
    bool withPath = true
)
public:
static String^ EntryExeName(
    bool withPath = true
)
static member EntryExeName :
        ?withPath : bool
(* Defaults:
        let _withPath = defaultArg withPath true
*)
-> string
static member EntryExeName :
        ?withPath : bool
(* Defaults:
        let _withPath = defaultArg withPath true
*)
-> string

Parameters

withPath (Optional)
Type: Online System Boolean

Return Value

Type: Online String
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.EqualsIgnoreCase Method

MiscUtils EqualsIgnoreCase Method NFX Class Library

Helper function that performs case-insensitive comparison between strings using invariant comparison. Either lhs and rhs can be null. Use this in conjunction with GetHashCodeIgnoreCase

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool EqualsIgnoreCase(
    this string lhs,
    string rhs
)
public static bool EqualsIgnoreCase(
    this string lhs,
    string rhs
)
<ExtensionAttribute>
Public Shared Function EqualsIgnoreCase (
    lhs As String,
    rhs As String
) As Boolean
<ExtensionAttribute>
Public Shared Function EqualsIgnoreCase (
    lhs As String,
    rhs As String
) As Boolean
public:
[ExtensionAttribute]
static bool EqualsIgnoreCase(
    String^ lhs,
    String^ rhs
)
public:
[ExtensionAttribute]
static bool EqualsIgnoreCase(
    String^ lhs,
    String^ rhs
)
static member EqualsIgnoreCase :
        lhs : string *
        rhs : string -> bool
static member EqualsIgnoreCase :
        lhs : string *
        rhs : string -> bool

Parameters

lhs
Type: Online System String
rhs
Type: Online System String

Return Value

Type: Online Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.EqualsOrdIgnoreCase Method

MiscUtils EqualsOrdIgnoreCase Method NFX Class Library

Helper function that performs case-insensitive comparison between strings using ordinal comparison. Either lhs and rhs can be null. Use this in conjunction with GetHashCodeOrdIgnoreCase

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool EqualsOrdIgnoreCase(
    this string lhs,
    string rhs
)
public static bool EqualsOrdIgnoreCase(
    this string lhs,
    string rhs
)
<ExtensionAttribute>
Public Shared Function EqualsOrdIgnoreCase (
    lhs As String,
    rhs As String
) As Boolean
<ExtensionAttribute>
Public Shared Function EqualsOrdIgnoreCase (
    lhs As String,
    rhs As String
) As Boolean
public:
[ExtensionAttribute]
static bool EqualsOrdIgnoreCase(
    String^ lhs,
    String^ rhs
)
public:
[ExtensionAttribute]
static bool EqualsOrdIgnoreCase(
    String^ lhs,
    String^ rhs
)
static member EqualsOrdIgnoreCase :
        lhs : string *
        rhs : string -> bool
static member EqualsOrdIgnoreCase :
        lhs : string *
        rhs : string -> bool

Parameters

lhs
Type: Online System String
rhs
Type: Online System String

Return Value

Type: Online Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.EqualsOrdSenseCase Method

MiscUtils EqualsOrdSenseCase Method NFX Class Library

Helper function that performs case-insensitive comparison between strings using ordinal comparison. Either lhs and rhs can be null. Use this in conjunction with GetHashCodeOrdSenseCase

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool EqualsOrdSenseCase(
    this string lhs,
    string rhs
)
public static bool EqualsOrdSenseCase(
    this string lhs,
    string rhs
)
<ExtensionAttribute>
Public Shared Function EqualsOrdSenseCase (
    lhs As String,
    rhs As String
) As Boolean
<ExtensionAttribute>
Public Shared Function EqualsOrdSenseCase (
    lhs As String,
    rhs As String
) As Boolean
public:
[ExtensionAttribute]
static bool EqualsOrdSenseCase(
    String^ lhs,
    String^ rhs
)
public:
[ExtensionAttribute]
static bool EqualsOrdSenseCase(
    String^ lhs,
    String^ rhs
)
static member EqualsOrdSenseCase :
        lhs : string *
        rhs : string -> bool
static member EqualsOrdSenseCase :
        lhs : string *
        rhs : string -> bool

Parameters

lhs
Type: Online System String
rhs
Type: Online System String

Return Value

Type: Online Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.EqualsSenseCase Method

MiscUtils EqualsSenseCase Method NFX Class Library

Helper function that performs comparison between strings using invariant comparison. Either lhs and rhs can be null. Use this in conjunction with GetHashCodeSenseCase

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool EqualsSenseCase(
    this string lhs,
    string rhs
)
public static bool EqualsSenseCase(
    this string lhs,
    string rhs
)
<ExtensionAttribute>
Public Shared Function EqualsSenseCase (
    lhs As String,
    rhs As String
) As Boolean
<ExtensionAttribute>
Public Shared Function EqualsSenseCase (
    lhs As String,
    rhs As String
) As Boolean
public:
[ExtensionAttribute]
static bool EqualsSenseCase(
    String^ lhs,
    String^ rhs
)
public:
[ExtensionAttribute]
static bool EqualsSenseCase(
    String^ lhs,
    String^ rhs
)
static member EqualsSenseCase :
        lhs : string *
        rhs : string -> bool
static member EqualsSenseCase :
        lhs : string *
        rhs : string -> bool

Parameters

lhs
Type: Online System String
rhs
Type: Online System String

Return Value

Type: Online Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.EvaluateVars Method

MiscUtils EvaluateVars Method NFX Class Library

Evaluates variables in a context of optional variable resolver and macro runner

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string EvaluateVars(
    this string line,
    IEnvironmentVariableResolver envResolver = null,
    IMacroRunner macroRunner = null
)
public static string EvaluateVars(
    this string line,
    IEnvironmentVariableResolver envResolver = null,
    IMacroRunner macroRunner = null
)
<ExtensionAttribute>
Public Shared Function EvaluateVars (
    line As String,
    Optional envResolver As IEnvironmentVariableResolver = Nothing,
    Optional macroRunner As IMacroRunner = Nothing
) As String
<ExtensionAttribute>
Public Shared Function EvaluateVars (
    line As String,
    Optional envResolver As IEnvironmentVariableResolver = Nothing,
    Optional macroRunner As IMacroRunner = Nothing
) As String
public:
[ExtensionAttribute]
static String^ EvaluateVars(
    String^ line,
    IEnvironmentVariableResolver^ envResolver = nullptr,
    IMacroRunner^ macroRunner = nullptr
)
public:
[ExtensionAttribute]
static String^ EvaluateVars(
    String^ line,
    IEnvironmentVariableResolver^ envResolver = nullptr,
    IMacroRunner^ macroRunner = nullptr
)
static member EvaluateVars :
        line : string *
        ?envResolver : IEnvironmentVariableResolver *
        ?macroRunner : IMacroRunner
(* Defaults:
        let _envResolver = defaultArg envResolver null
        let _macroRunner = defaultArg macroRunner null
*)
-> string
static member EvaluateVars :
        line : string *
        ?envResolver : IEnvironmentVariableResolver *
        ?macroRunner : IMacroRunner
(* Defaults:
        let _envResolver = defaultArg envResolver null
        let _macroRunner = defaultArg macroRunner null
*)
-> string

Parameters

line
Type: Online System String
envResolver (Optional)
Type: NFX.Environment IEnvironmentVariableResolver
macroRunner (Optional)
Type: NFX.Environment IMacroRunner

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.EvaluateVarsInConfigScope Method

MiscUtils EvaluateVarsInConfigScope Method NFX Class Library

Evaluates variables in a context of optional configuration supplied as config object

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string EvaluateVarsInConfigScope(
    this string line,
    Configuration scopeConfig = null
)
public static string EvaluateVarsInConfigScope(
    this string line,
    Configuration scopeConfig = null
)
<ExtensionAttribute>
Public Shared Function EvaluateVarsInConfigScope (
    line As String,
    Optional scopeConfig As Configuration = Nothing
) As String
<ExtensionAttribute>
Public Shared Function EvaluateVarsInConfigScope (
    line As String,
    Optional scopeConfig As Configuration = Nothing
) As String
public:
[ExtensionAttribute]
static String^ EvaluateVarsInConfigScope(
    String^ line,
    Configuration^ scopeConfig = nullptr
)
public:
[ExtensionAttribute]
static String^ EvaluateVarsInConfigScope(
    String^ line,
    Configuration^ scopeConfig = nullptr
)
static member EvaluateVarsInConfigScope :
        line : string *
        ?scopeConfig : Configuration
(* Defaults:
        let _scopeConfig = defaultArg scopeConfig null
*)
-> string
static member EvaluateVarsInConfigScope :
        line : string *
        ?scopeConfig : Configuration
(* Defaults:
        let _scopeConfig = defaultArg scopeConfig null
*)
-> string

Parameters

line
Type: Online System String
scopeConfig (Optional)
Type: NFX.Environment Configuration

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.EvaluateVarsInDictionaryScope Method

MiscUtils EvaluateVarsInDictionaryScope Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Evaluates variables in a context of optional configuration supplied as dictionary which is converted to attributes

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string EvaluateVarsInDictionaryScope(
    this string line,
    IDictionary<string, Object> dict = null,
    IEnvironmentVariableResolver envResolver = null,
    IMacroRunner macroRunner = null
)
public static string EvaluateVarsInDictionaryScope(
    this string line,
    IDictionary<string, Object> dict = null,
    IEnvironmentVariableResolver envResolver = null,
    IMacroRunner macroRunner = null
)
<ExtensionAttribute>
Public Shared Function EvaluateVarsInDictionaryScope (
    line As String,
    Optional dict As IDictionary(Of String, Object) = Nothing,
    Optional envResolver As IEnvironmentVariableResolver = Nothing,
    Optional macroRunner As IMacroRunner = Nothing
) As String
<ExtensionAttribute>
Public Shared Function EvaluateVarsInDictionaryScope (
    line As String,
    Optional dict As IDictionary(Of String, Object) = Nothing,
    Optional envResolver As IEnvironmentVariableResolver = Nothing,
    Optional macroRunner As IMacroRunner = Nothing
) As String
public:
[ExtensionAttribute]
static String^ EvaluateVarsInDictionaryScope(
    String^ line,
    IDictionary<String^, Object^>^ dict = nullptr,
    IEnvironmentVariableResolver^ envResolver = nullptr,
    IMacroRunner^ macroRunner = nullptr
)
public:
[ExtensionAttribute]
static String^ EvaluateVarsInDictionaryScope(
    String^ line,
    IDictionary<String^, Object^>^ dict = nullptr,
    IEnvironmentVariableResolver^ envResolver = nullptr,
    IMacroRunner^ macroRunner = nullptr
)
static member EvaluateVarsInDictionaryScope :
        line : string *
        ?dict : IDictionary<string, Object> *
        ?envResolver : IEnvironmentVariableResolver *
        ?macroRunner : IMacroRunner
(* Defaults:
        let _dict = defaultArg dict null
        let _envResolver = defaultArg envResolver null
        let _macroRunner = defaultArg macroRunner null
*)
-> string
static member EvaluateVarsInDictionaryScope :
        line : string *
        ?dict : IDictionary<string, Object> *
        ?envResolver : IEnvironmentVariableResolver *
        ?macroRunner : IMacroRunner
(* Defaults:
        let _dict = defaultArg dict null
        let _envResolver = defaultArg envResolver null
        let _macroRunner = defaultArg macroRunner null
*)
-> string

Parameters

line
Type: Online System String
dict (Optional)
Type: Online System.Collections.Generic IDictionary Online String, Online Object
envResolver (Optional)
Type: NFX.Environment IEnvironmentVariableResolver
macroRunner (Optional)
Type: NFX.Environment IMacroRunner

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.EvaluateVarsInXMLConfigScope Method

MiscUtils EvaluateVarsInXMLConfigScope Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Evaluates variables in a context of optional configuration supplied in XML format

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string EvaluateVarsInXMLConfigScope(
    this string line,
    string xmlScope = null,
    IEnvironmentVariableResolver envResolver = null,
    IMacroRunner macroRunner = null
)
public static string EvaluateVarsInXMLConfigScope(
    this string line,
    string xmlScope = null,
    IEnvironmentVariableResolver envResolver = null,
    IMacroRunner macroRunner = null
)
<ExtensionAttribute>
Public Shared Function EvaluateVarsInXMLConfigScope (
    line As String,
    Optional xmlScope As String = Nothing,
    Optional envResolver As IEnvironmentVariableResolver = Nothing,
    Optional macroRunner As IMacroRunner = Nothing
) As String
<ExtensionAttribute>
Public Shared Function EvaluateVarsInXMLConfigScope (
    line As String,
    Optional xmlScope As String = Nothing,
    Optional envResolver As IEnvironmentVariableResolver = Nothing,
    Optional macroRunner As IMacroRunner = Nothing
) As String
public:
[ExtensionAttribute]
static String^ EvaluateVarsInXMLConfigScope(
    String^ line,
    String^ xmlScope = nullptr,
    IEnvironmentVariableResolver^ envResolver = nullptr,
    IMacroRunner^ macroRunner = nullptr
)
public:
[ExtensionAttribute]
static String^ EvaluateVarsInXMLConfigScope(
    String^ line,
    String^ xmlScope = nullptr,
    IEnvironmentVariableResolver^ envResolver = nullptr,
    IMacroRunner^ macroRunner = nullptr
)
static member EvaluateVarsInXMLConfigScope :
        line : string *
        ?xmlScope : string *
        ?envResolver : IEnvironmentVariableResolver *
        ?macroRunner : IMacroRunner
(* Defaults:
        let _xmlScope = defaultArg xmlScope null
        let _envResolver = defaultArg envResolver null
        let _macroRunner = defaultArg macroRunner null
*)
-> string
static member EvaluateVarsInXMLConfigScope :
        line : string *
        ?xmlScope : string *
        ?envResolver : IEnvironmentVariableResolver *
        ?macroRunner : IMacroRunner
(* Defaults:
        let _xmlScope = defaultArg xmlScope null
        let _envResolver = defaultArg envResolver null
        let _macroRunner = defaultArg macroRunner null
*)
-> string

Parameters

line
Type: Online System String
xmlScope (Optional)
Type: Online System String
envResolver (Optional)
Type: NFX.Environment IEnvironmentVariableResolver
macroRunner (Optional)
Type: NFX.Environment IMacroRunner

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.FromMicrosecondsSinceUnixEpochStart Method

MiscUtils FromMicrosecondsSinceUnixEpochStart Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
Name | Description
FromMicrosecondsSinceUnixEpochStart(Int64) | Gets UTC DateTime from number of microseconds since Unix epoch start (1970/1/1 0:0:0)
FromMicrosecondsSinceUnixEpochStart(UInt64) | Gets UTC DateTime from number of microseconds since Unix epoch start (1970/1/1 0:0:0)
Back to Top
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.FromMicrosecondsSinceUnixEpochStart Method (Int64)

MiscUtils FromMicrosecondsSinceUnixEpochStart Method (Int64) NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets UTC DateTime from number of microseconds since Unix epoch start (1970/1/1 0:0:0)

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DateTime FromMicrosecondsSinceUnixEpochStart(
    this long when
)
public static DateTime FromMicrosecondsSinceUnixEpochStart(
    this long when
)
<ExtensionAttribute>
Public Shared Function FromMicrosecondsSinceUnixEpochStart (
    when As Long
) As DateTime
<ExtensionAttribute>
Public Shared Function FromMicrosecondsSinceUnixEpochStart (
    when As Long
) As DateTime
public:
[ExtensionAttribute]
static DateTime FromMicrosecondsSinceUnixEpochStart(
    long long when
)
public:
[ExtensionAttribute]
static DateTime FromMicrosecondsSinceUnixEpochStart(
    long long when
)
static member FromMicrosecondsSinceUnixEpochStart :
        when : int64 -> DateTime
static member FromMicrosecondsSinceUnixEpochStart :
        when : int64 -> DateTime

Parameters

when
Type: Online System Int64

Return Value

Type: Online DateTime

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Int64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
FromMicrosecondsSinceUnixEpochStart Overload
NFX Namespace


MiscUtils.FromMicrosecondsSinceUnixEpochStart Method (UInt64)

MiscUtils FromMicrosecondsSinceUnixEpochStart Method (UInt64) NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets UTC DateTime from number of microseconds since Unix epoch start (1970/1/1 0:0:0)

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DateTime FromMicrosecondsSinceUnixEpochStart(
    this ulong when
)
public static DateTime FromMicrosecondsSinceUnixEpochStart(
    this ulong when
)
<ExtensionAttribute>
Public Shared Function FromMicrosecondsSinceUnixEpochStart (
    when As ULong
) As DateTime
<ExtensionAttribute>
Public Shared Function FromMicrosecondsSinceUnixEpochStart (
    when As ULong
) As DateTime
public:
[ExtensionAttribute]
static DateTime FromMicrosecondsSinceUnixEpochStart(
    unsigned long long when
)
public:
[ExtensionAttribute]
static DateTime FromMicrosecondsSinceUnixEpochStart(
    unsigned long long when
)
static member FromMicrosecondsSinceUnixEpochStart :
        when : uint64 -> DateTime
static member FromMicrosecondsSinceUnixEpochStart :
        when : uint64 -> DateTime

Parameters

when
Type: Online System UInt64

Return Value

Type: Online DateTime

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online UInt64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
FromMicrosecondsSinceUnixEpochStart Overload
NFX Namespace


MiscUtils.FromMillisecondsSinceUnixEpochStart Method

MiscUtils FromMillisecondsSinceUnixEpochStart Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
Name | Description
FromMillisecondsSinceUnixEpochStart(Int64) | Gets UTC DateTime from number of milliseconds since Unix epoch start (1970/1/1 0:0:0)
FromMillisecondsSinceUnixEpochStart(UInt64) | Gets UTC DateTime from number of milliseconds since Unix epoch start (1970/1/1 0:0:0)
Back to Top
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.FromMillisecondsSinceUnixEpochStart Method (Int64)

MiscUtils FromMillisecondsSinceUnixEpochStart Method (Int64) NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets UTC DateTime from number of milliseconds since Unix epoch start (1970/1/1 0:0:0)

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DateTime FromMillisecondsSinceUnixEpochStart(
    this long when
)
public static DateTime FromMillisecondsSinceUnixEpochStart(
    this long when
)
<ExtensionAttribute>
Public Shared Function FromMillisecondsSinceUnixEpochStart (
    when As Long
) As DateTime
<ExtensionAttribute>
Public Shared Function FromMillisecondsSinceUnixEpochStart (
    when As Long
) As DateTime
public:
[ExtensionAttribute]
static DateTime FromMillisecondsSinceUnixEpochStart(
    long long when
)
public:
[ExtensionAttribute]
static DateTime FromMillisecondsSinceUnixEpochStart(
    long long when
)
static member FromMillisecondsSinceUnixEpochStart :
        when : int64 -> DateTime
static member FromMillisecondsSinceUnixEpochStart :
        when : int64 -> DateTime

Parameters

when
Type: Online System Int64

Return Value

Type: Online DateTime

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Int64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
FromMillisecondsSinceUnixEpochStart Overload
NFX Namespace


MiscUtils.FromMillisecondsSinceUnixEpochStart Method (UInt64)

MiscUtils FromMillisecondsSinceUnixEpochStart Method (UInt64) NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets UTC DateTime from number of milliseconds since Unix epoch start (1970/1/1 0:0:0)

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DateTime FromMillisecondsSinceUnixEpochStart(
    this ulong when
)
public static DateTime FromMillisecondsSinceUnixEpochStart(
    this ulong when
)
<ExtensionAttribute>
Public Shared Function FromMillisecondsSinceUnixEpochStart (
    when As ULong
) As DateTime
<ExtensionAttribute>
Public Shared Function FromMillisecondsSinceUnixEpochStart (
    when As ULong
) As DateTime
public:
[ExtensionAttribute]
static DateTime FromMillisecondsSinceUnixEpochStart(
    unsigned long long when
)
public:
[ExtensionAttribute]
static DateTime FromMillisecondsSinceUnixEpochStart(
    unsigned long long when
)
static member FromMillisecondsSinceUnixEpochStart :
        when : uint64 -> DateTime
static member FromMillisecondsSinceUnixEpochStart :
        when : uint64 -> DateTime

Parameters

when
Type: Online System UInt64

Return Value

Type: Online DateTime

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online UInt64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
FromMillisecondsSinceUnixEpochStart Overload
NFX Namespace


MiscUtils.FromSecondsSinceUnixEpochStart Method

MiscUtils FromSecondsSinceUnixEpochStart Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
Name | Description
FromSecondsSinceUnixEpochStart(Int64) | Gets UTC DateTime from number of seconds since Unix epoch start (1970/1/1 0:0:0)
FromSecondsSinceUnixEpochStart(UInt64) | Gets UTC DateTime from number of seconds since Unix epoch start (1970/1/1 0:0:0)
Back to Top
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.FromSecondsSinceUnixEpochStart Method (Int64)

MiscUtils FromSecondsSinceUnixEpochStart Method (Int64) NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets UTC DateTime from number of seconds since Unix epoch start (1970/1/1 0:0:0)

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DateTime FromSecondsSinceUnixEpochStart(
    this long when
)
public static DateTime FromSecondsSinceUnixEpochStart(
    this long when
)
<ExtensionAttribute>
Public Shared Function FromSecondsSinceUnixEpochStart (
    when As Long
) As DateTime
<ExtensionAttribute>
Public Shared Function FromSecondsSinceUnixEpochStart (
    when As Long
) As DateTime
public:
[ExtensionAttribute]
static DateTime FromSecondsSinceUnixEpochStart(
    long long when
)
public:
[ExtensionAttribute]
static DateTime FromSecondsSinceUnixEpochStart(
    long long when
)
static member FromSecondsSinceUnixEpochStart :
        when : int64 -> DateTime
static member FromSecondsSinceUnixEpochStart :
        when : int64 -> DateTime

Parameters

when
Type: Online System Int64

Return Value

Type: Online DateTime

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Int64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
FromSecondsSinceUnixEpochStart Overload
NFX Namespace


MiscUtils.FromSecondsSinceUnixEpochStart Method (UInt64)

MiscUtils FromSecondsSinceUnixEpochStart Method (UInt64) NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets UTC DateTime from number of seconds since Unix epoch start (1970/1/1 0:0:0)

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DateTime FromSecondsSinceUnixEpochStart(
    this ulong when
)
public static DateTime FromSecondsSinceUnixEpochStart(
    this ulong when
)
<ExtensionAttribute>
Public Shared Function FromSecondsSinceUnixEpochStart (
    when As ULong
) As DateTime
<ExtensionAttribute>
Public Shared Function FromSecondsSinceUnixEpochStart (
    when As ULong
) As DateTime
public:
[ExtensionAttribute]
static DateTime FromSecondsSinceUnixEpochStart(
    unsigned long long when
)
public:
[ExtensionAttribute]
static DateTime FromSecondsSinceUnixEpochStart(
    unsigned long long when
)
static member FromSecondsSinceUnixEpochStart :
        when : uint64 -> DateTime
static member FromSecondsSinceUnixEpochStart :
        when : uint64 -> DateTime

Parameters

when
Type: Online System UInt64

Return Value

Type: Online DateTime

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online UInt64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
FromSecondsSinceUnixEpochStart Overload
NFX Namespace


MiscUtils.FromUTF8Bytes Method

MiscUtils FromUTF8Bytes Method NFX Class Library

Decode string with standart UTF8 decoder

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string FromUTF8Bytes(
    this byte[] buf,
    int idx = -1,
    int cnt = -1
)
public static string FromUTF8Bytes(
    this byte[] buf,
    int idx = -1,
    int cnt = -1
)
<ExtensionAttribute>
Public Shared Function FromUTF8Bytes (
    buf As Byte(),
    Optional idx As Integer = -1,
    Optional cnt As Integer = -1
) As String
<ExtensionAttribute>
Public Shared Function FromUTF8Bytes (
    buf As Byte(),
    Optional idx As Integer = -1,
    Optional cnt As Integer = -1
) As String
public:
[ExtensionAttribute]
static String^ FromUTF8Bytes(
    array<unsigned char>^ buf,
    int idx = -1,
    int cnt = -1
)
public:
[ExtensionAttribute]
static String^ FromUTF8Bytes(
    array<unsigned char>^ buf,
    int idx = -1,
    int cnt = -1
)
static member FromUTF8Bytes :
        buf : byte[] *
        ?idx : int *
        ?cnt : int
(* Defaults:
        let _idx = defaultArg idx -1
        let _cnt = defaultArg cnt -1
*)
-> string
static member FromUTF8Bytes :
        buf : byte[] *
        ?idx : int *
        ?cnt : int
(* Defaults:
        let _idx = defaultArg idx -1
        let _cnt = defaultArg cnt -1
*)
-> string

Parameters

buf
Type: Online System Byte
idx (Optional)
Type: Online System Int32
cnt (Optional)
Type: Online System Int32

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.FullNameWithExpandedGenericArgs Method

MiscUtils FullNameWithExpandedGenericArgs Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns the full name of the type optionally prefixed with verbatim id specifier '@'. The generic arguments ar expanded into their full names i.e. List'1[System.Object] -> System.Collections.Generic.List<System.Object>

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string FullNameWithExpandedGenericArgs(
    this Type type,
    bool verbatimPrefix = true
)
public static string FullNameWithExpandedGenericArgs(
    this Type type,
    bool verbatimPrefix = true
)
<ExtensionAttribute>
Public Shared Function FullNameWithExpandedGenericArgs (
    type As Type,
    Optional verbatimPrefix As Boolean = true
) As String
<ExtensionAttribute>
Public Shared Function FullNameWithExpandedGenericArgs (
    type As Type,
    Optional verbatimPrefix As Boolean = true
) As String
public:
[ExtensionAttribute]
static String^ FullNameWithExpandedGenericArgs(
    Type^ type,
    bool verbatimPrefix = true
)
public:
[ExtensionAttribute]
static String^ FullNameWithExpandedGenericArgs(
    Type^ type,
    bool verbatimPrefix = true
)
static member FullNameWithExpandedGenericArgs :
        type : Type *
        ?verbatimPrefix : bool
(* Defaults:
        let _verbatimPrefix = defaultArg verbatimPrefix true
*)
-> string
static member FullNameWithExpandedGenericArgs :
        type : Type *
        ?verbatimPrefix : bool
(* Defaults:
        let _verbatimPrefix = defaultArg verbatimPrefix true
*)
-> string

Parameters

type
Type: Online System Type
verbatimPrefix (Optional)
Type: Online System Boolean

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.GetHashCodeIgnoreCase Method

MiscUtils GetHashCodeIgnoreCase Method NFX Class Library

Helper function that performs case-insensitive GetHashcode for string using invariant comparison. Use this in conjunction with EqualsIgnoreCase

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int GetHashCodeIgnoreCase(
    this string str
)
public static int GetHashCodeIgnoreCase(
    this string str
)
<ExtensionAttribute>
Public Shared Function GetHashCodeIgnoreCase (
    str As String
) As Integer
<ExtensionAttribute>
Public Shared Function GetHashCodeIgnoreCase (
    str As String
) As Integer
public:
[ExtensionAttribute]
static int GetHashCodeIgnoreCase(
    String^ str
)
public:
[ExtensionAttribute]
static int GetHashCodeIgnoreCase(
    String^ str
)
static member GetHashCodeIgnoreCase :
        str : string -> int
static member GetHashCodeIgnoreCase :
        str : string -> int

Parameters

str
Type: Online System String

Return Value

Type: Online Int32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.GetHashCodeOrdIgnoreCase Method

MiscUtils GetHashCodeOrdIgnoreCase Method NFX Class Library

Helper function that performs case-insensitive GetHashcode for string using ordinal comparison. Use this in conjunction with EqualsOrdIgnoreCase

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int GetHashCodeOrdIgnoreCase(
    this string str
)
public static int GetHashCodeOrdIgnoreCase(
    this string str
)
<ExtensionAttribute>
Public Shared Function GetHashCodeOrdIgnoreCase (
    str As String
) As Integer
<ExtensionAttribute>
Public Shared Function GetHashCodeOrdIgnoreCase (
    str As String
) As Integer
public:
[ExtensionAttribute]
static int GetHashCodeOrdIgnoreCase(
    String^ str
)
public:
[ExtensionAttribute]
static int GetHashCodeOrdIgnoreCase(
    String^ str
)
static member GetHashCodeOrdIgnoreCase :
        str : string -> int
static member GetHashCodeOrdIgnoreCase :
        str : string -> int

Parameters

str
Type: Online System String

Return Value

Type: Online Int32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.GetHashCodeOrdSenseCase Method

MiscUtils GetHashCodeOrdSenseCase Method NFX Class Library

Helper function that performs case-insensitive GetHashcode for string using ordinal comparison. Use this in conjunction with EqualsOrdSenseCase

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int GetHashCodeOrdSenseCase(
    this string str
)
public static int GetHashCodeOrdSenseCase(
    this string str
)
<ExtensionAttribute>
Public Shared Function GetHashCodeOrdSenseCase (
    str As String
) As Integer
<ExtensionAttribute>
Public Shared Function GetHashCodeOrdSenseCase (
    str As String
) As Integer
public:
[ExtensionAttribute]
static int GetHashCodeOrdSenseCase(
    String^ str
)
public:
[ExtensionAttribute]
static int GetHashCodeOrdSenseCase(
    String^ str
)
static member GetHashCodeOrdSenseCase :
        str : string -> int
static member GetHashCodeOrdSenseCase :
        str : string -> int

Parameters

str
Type: Online System String

Return Value

Type: Online Int32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.GetHashCodeSenseCase Method

MiscUtils GetHashCodeSenseCase Method NFX Class Library

Helper function that performs GetHashcode for string using invariant comparison. Use this in conjunction with EqualsSenseCase

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int GetHashCodeSenseCase(
    this string str
)
public static int GetHashCodeSenseCase(
    this string str
)
<ExtensionAttribute>
Public Shared Function GetHashCodeSenseCase (
    str As String
) As Integer
<ExtensionAttribute>
Public Shared Function GetHashCodeSenseCase (
    str As String
) As Integer
public:
[ExtensionAttribute]
static int GetHashCodeSenseCase(
    String^ str
)
public:
[ExtensionAttribute]
static int GetHashCodeSenseCase(
    String^ str
)
static member GetHashCodeSenseCase :
        str : string -> int
static member GetHashCodeSenseCase :
        str : string -> int

Parameters

str
Type: Online System String

Return Value

Type: Online Int32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.IPStringToIPEndPoint Method

MiscUtils IPStringToIPEndPoint Method NFX Class Library

Converts string of format "xx.xx.xx.xx:nnnn" into IPEndPoint. DNS names are NOT supported

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ObsoleteAttribute]
public static IPEndPoint IPStringToIPEndPoint(
    this string str
)
[ObsoleteAttribute]
public static IPEndPoint IPStringToIPEndPoint(
    this string str
)
<ObsoleteAttribute>
<ExtensionAttribute>
Public Shared Function IPStringToIPEndPoint (
    str As String
) As IPEndPoint
<ObsoleteAttribute>
<ExtensionAttribute>
Public Shared Function IPStringToIPEndPoint (
    str As String
) As IPEndPoint
public:
[ObsoleteAttribute]
[ExtensionAttribute]
static IPEndPoint^ IPStringToIPEndPoint(
    String^ str
)
public:
[ObsoleteAttribute]
[ExtensionAttribute]
static IPEndPoint^ IPStringToIPEndPoint(
    String^ str
)
[<ObsoleteAttribute>]
static member IPStringToIPEndPoint :
        str : string -> IPEndPoint
[<ObsoleteAttribute>]
static member IPStringToIPEndPoint :
        str : string -> IPEndPoint

Parameters

str
Type: Online System String

Return Value

Type: Online IPEndPoint

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.IsComponentDesignerHosted Method

MiscUtils IsComponentDesignerHosted Method NFX Class Library

Determines if component is being used within designer

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsComponentDesignerHosted(
    Component cmp
)
public static bool IsComponentDesignerHosted(
    Component cmp
)
Public Shared Function IsComponentDesignerHosted (
    cmp As Component
) As Boolean
Public Shared Function IsComponentDesignerHosted (
    cmp As Component
) As Boolean
public:
static bool IsComponentDesignerHosted(
    Component^ cmp
)
public:
static bool IsComponentDesignerHosted(
    Component^ cmp
)
static member IsComponentDesignerHosted :
        cmp : Component -> bool
static member IsComponentDesignerHosted :
        cmp : Component -> bool

Parameters

cmp
Type: Online System.ComponentModel Component

Return Value

Type: Online Boolean
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.IsNotNullOrEmpty Method

MiscUtils IsNotNullOrEmpty Method NFX Class Library

Helper function that calls !string.IsNullOrEmpty()

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsNotNullOrEmpty(
    this string s
)
public static bool IsNotNullOrEmpty(
    this string s
)
<ExtensionAttribute>
Public Shared Function IsNotNullOrEmpty (
    s As String
) As Boolean
<ExtensionAttribute>
Public Shared Function IsNotNullOrEmpty (
    s As String
) As Boolean
public:
[ExtensionAttribute]
static bool IsNotNullOrEmpty(
    String^ s
)
public:
[ExtensionAttribute]
static bool IsNotNullOrEmpty(
    String^ s
)
static member IsNotNullOrEmpty :
        s : string -> bool
static member IsNotNullOrEmpty :
        s : string -> bool

Parameters

s
Type: Online System String

Return Value

Type: Online Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.IsNotNullOrWhiteSpace Method

MiscUtils IsNotNullOrWhiteSpace Method NFX Class Library

Helper function that calls !string.IsNullOrWhiteSpace()

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsNotNullOrWhiteSpace(
    this string s
)
public static bool IsNotNullOrWhiteSpace(
    this string s
)
<ExtensionAttribute>
Public Shared Function IsNotNullOrWhiteSpace (
    s As String
) As Boolean
<ExtensionAttribute>
Public Shared Function IsNotNullOrWhiteSpace (
    s As String
) As Boolean
public:
[ExtensionAttribute]
static bool IsNotNullOrWhiteSpace(
    String^ s
)
public:
[ExtensionAttribute]
static bool IsNotNullOrWhiteSpace(
    String^ s
)
static member IsNotNullOrWhiteSpace :
        s : string -> bool
static member IsNotNullOrWhiteSpace :
        s : string -> bool

Parameters

s
Type: Online System String

Return Value

Type: Online Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.IsNullOrEmpty Method

MiscUtils IsNullOrEmpty Method NFX Class Library

Helper function that calls string.IsNullOrEmpty()

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsNullOrEmpty(
    this string s
)
public static bool IsNullOrEmpty(
    this string s
)
<ExtensionAttribute>
Public Shared Function IsNullOrEmpty (
    s As String
) As Boolean
<ExtensionAttribute>
Public Shared Function IsNullOrEmpty (
    s As String
) As Boolean
public:
[ExtensionAttribute]
static bool IsNullOrEmpty(
    String^ s
)
public:
[ExtensionAttribute]
static bool IsNullOrEmpty(
    String^ s
)
static member IsNullOrEmpty :
        s : string -> bool
static member IsNullOrEmpty :
        s : string -> bool

Parameters

s
Type: Online System String

Return Value

Type: Online Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.IsNullOrWhiteSpace Method

MiscUtils IsNullOrWhiteSpace Method NFX Class Library

Helper function that calls string.IsNullOrWhiteSpace()

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsNullOrWhiteSpace(
    this string s
)
public static bool IsNullOrWhiteSpace(
    this string s
)
<ExtensionAttribute>
Public Shared Function IsNullOrWhiteSpace (
    s As String
) As Boolean
<ExtensionAttribute>
Public Shared Function IsNullOrWhiteSpace (
    s As String
) As Boolean
public:
[ExtensionAttribute]
static bool IsNullOrWhiteSpace(
    String^ s
)
public:
[ExtensionAttribute]
static bool IsNullOrWhiteSpace(
    String^ s
)
static member IsNullOrWhiteSpace :
        s : string -> bool
static member IsNullOrWhiteSpace :
        s : string -> bool

Parameters

s
Type: Online System String

Return Value

Type: Online Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.IsTrue Method

MiscUtils IsTrue Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsTrue(
    this Nullable<bool> value,
    bool dflt = false
)
public static bool IsTrue(
    this Nullable<bool> value,
    bool dflt = false
)
<ExtensionAttribute>
Public Shared Function IsTrue (
    value As Nullable(Of Boolean),
    Optional dflt As Boolean = false
) As Boolean
<ExtensionAttribute>
Public Shared Function IsTrue (
    value As Nullable(Of Boolean),
    Optional dflt As Boolean = false
) As Boolean
public:
[ExtensionAttribute]
static bool IsTrue(
    Nullable<bool> value,
    bool dflt = false
)
public:
[ExtensionAttribute]
static bool IsTrue(
    Nullable<bool> value,
    bool dflt = false
)
static member IsTrue :
        value : Nullable<bool> *
        ?dflt : bool
(* Defaults:
        let _dflt = defaultArg dflt false
*)
-> bool
static member IsTrue :
        value : Nullable<bool> *
        ?dflt : bool
(* Defaults:
        let _dflt = defaultArg dflt false
*)
-> bool

Parameters

value
Type: Online System Nullable Online Boolean
dflt (Optional)
Type: Online System Boolean

Return Value

Type: Online Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Nullable Online Boolean . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.IsValidXMLName Method

MiscUtils IsValidXMLName Method NFX Class Library

Returns true when supplied name can be used for XML node naming (node names, attribute names)

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsValidXMLName(
    this string name
)
public static bool IsValidXMLName(
    this string name
)
<ExtensionAttribute>
Public Shared Function IsValidXMLName (
    name As String
) As Boolean
<ExtensionAttribute>
Public Shared Function IsValidXMLName (
    name As String
) As Boolean
public:
[ExtensionAttribute]
static bool IsValidXMLName(
    String^ name
)
public:
[ExtensionAttribute]
static bool IsValidXMLName(
    String^ name
)
static member IsValidXMLName :
        name : string -> bool
static member IsValidXMLName :
        name : string -> bool

Parameters

name
Type: Online System String

Return Value

Type: Online Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.NonNull(T) Method

MiscUtils NonNull T Method NFX Class Library

Checks the value for null and throws exception if it is. The method is useful for .ctor call chaining to preclude otherwise anonymous NullReferenceException

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static T NonNull<T>(
    this T obj,
    Func<Exception> error = null,
    string text = null
)
where T : class
public static T NonNull<T>(
    this T obj,
    Func<Exception> error = null,
    string text = null
)
where T : class
<ExtensionAttribute>
Public Shared Function NonNull(Of T As Class) (
    obj As T,
    Optional error As Func(Of Exception) = Nothing,
    Optional text As String = Nothing
) As T
<ExtensionAttribute>
Public Shared Function NonNull(Of T As Class) (
    obj As T,
    Optional error As Func(Of Exception) = Nothing,
    Optional text As String = Nothing
) As T
public:
[ExtensionAttribute]
generic<typename T>
where T : ref class
static T NonNull(
    T obj,
    Func<Exception^>^ error = nullptr,
    String^ text = nullptr
)
public:
[ExtensionAttribute]
generic<typename T>
where T : ref class
static T NonNull(
    T obj,
    Func<Exception^>^ error = nullptr,
    String^ text = nullptr
)
static member NonNull :
        obj : 'T *
        ?error : Func<Exception> *
        ?text : string
(* Defaults:
        let _error = defaultArg error null
        let _text = defaultArg text null
*)
-> 'T  when 'T : not struct
static member NonNull :
        obj : 'T *
        ?error : Func<Exception> *
        ?text : string
(* Defaults:
        let _error = defaultArg error null
        let _text = defaultArg text null
*)
-> 'T  when 'T : not struct

Parameters

obj
Type: T
error (Optional)
Type: Online System Func Online Exception
text (Optional)
Type: Online System String
Type Parameters
T

Return Value

Type: T

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.RoundToNextWeekDay Method

MiscUtils RoundToNextWeekDay Method NFX Class Library

Round date to next specific week day

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DateTime RoundToNextWeekDay(
    this DateTime now,
    DayOfWeek dayOfWeek,
    bool keepTime = false
)
public static DateTime RoundToNextWeekDay(
    this DateTime now,
    DayOfWeek dayOfWeek,
    bool keepTime = false
)
<ExtensionAttribute>
Public Shared Function RoundToNextWeekDay (
    now As DateTime,
    dayOfWeek As DayOfWeek,
    Optional keepTime As Boolean = false
) As DateTime
<ExtensionAttribute>
Public Shared Function RoundToNextWeekDay (
    now As DateTime,
    dayOfWeek As DayOfWeek,
    Optional keepTime As Boolean = false
) As DateTime
public:
[ExtensionAttribute]
static DateTime RoundToNextWeekDay(
    DateTime now,
    DayOfWeek dayOfWeek,
    bool keepTime = false
)
public:
[ExtensionAttribute]
static DateTime RoundToNextWeekDay(
    DateTime now,
    DayOfWeek dayOfWeek,
    bool keepTime = false
)
static member RoundToNextWeekDay :
        now : DateTime *
        dayOfWeek : DayOfWeek *
        ?keepTime : bool
(* Defaults:
        let _keepTime = defaultArg keepTime false
*)
-> DateTime
static member RoundToNextWeekDay :
        now : DateTime *
        dayOfWeek : DayOfWeek *
        ?keepTime : bool
(* Defaults:
        let _keepTime = defaultArg keepTime false
*)
-> DateTime

Parameters

now
Type: Online System DateTime
dayOfWeek
Type: Online System DayOfWeek
keepTime (Optional)
Type: Online System Boolean

Return Value

Type: Online DateTime

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.RoundToWeekDay Method

MiscUtils RoundToWeekDay Method NFX Class Library

Round date to specific week day

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DateTime RoundToWeekDay(
    this DateTime now,
    DayOfWeek dayOfWeek,
    bool keepTime = false
)
public static DateTime RoundToWeekDay(
    this DateTime now,
    DayOfWeek dayOfWeek,
    bool keepTime = false
)
<ExtensionAttribute>
Public Shared Function RoundToWeekDay (
    now As DateTime,
    dayOfWeek As DayOfWeek,
    Optional keepTime As Boolean = false
) As DateTime
<ExtensionAttribute>
Public Shared Function RoundToWeekDay (
    now As DateTime,
    dayOfWeek As DayOfWeek,
    Optional keepTime As Boolean = false
) As DateTime
public:
[ExtensionAttribute]
static DateTime RoundToWeekDay(
    DateTime now,
    DayOfWeek dayOfWeek,
    bool keepTime = false
)
public:
[ExtensionAttribute]
static DateTime RoundToWeekDay(
    DateTime now,
    DayOfWeek dayOfWeek,
    bool keepTime = false
)
static member RoundToWeekDay :
        now : DateTime *
        dayOfWeek : DayOfWeek *
        ?keepTime : bool
(* Defaults:
        let _keepTime = defaultArg keepTime false
*)
-> DateTime
static member RoundToWeekDay :
        now : DateTime *
        dayOfWeek : DayOfWeek *
        ?keepTime : bool
(* Defaults:
        let _keepTime = defaultArg keepTime false
*)
-> DateTime

Parameters

now
Type: Online System DateTime
dayOfWeek
Type: Online System DayOfWeek
keepTime (Optional)
Type: Online System Boolean

Return Value

Type: Online DateTime

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.RunAndCompleteProcess Method

MiscUtils RunAndCompleteProcess Method NFX Class Library

Runs specified process and waits for termination returning standard process output. This is a blocking call

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string RunAndCompleteProcess(
    string name,
    string args
)
public static string RunAndCompleteProcess(
    string name,
    string args
)
Public Shared Function RunAndCompleteProcess (
    name As String,
    args As String
) As String
Public Shared Function RunAndCompleteProcess (
    name As String,
    args As String
) As String
public:
static String^ RunAndCompleteProcess(
    String^ name,
    String^ args
)
public:
static String^ RunAndCompleteProcess(
    String^ name,
    String^ args
)
static member RunAndCompleteProcess :
        name : string *
        args : string -> string
static member RunAndCompleteProcess :
        name : string *
        args : string -> string

Parameters

name
Type: Online System String
args
Type: Online System String

Return Value

Type: Online String
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.SplitLines Method

MiscUtils SplitLines Method NFX Class Library

Splits string into lines using Win or .nix line brakes

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string[] SplitLines(
    this string str
)
public static string[] SplitLines(
    this string str
)
<ExtensionAttribute>
Public Shared Function SplitLines (
    str As String
) As String()
<ExtensionAttribute>
Public Shared Function SplitLines (
    str As String
) As String()
public:
[ExtensionAttribute]
static array<String^>^ SplitLines(
    String^ str
)
public:
[ExtensionAttribute]
static array<String^>^ SplitLines(
    String^ str
)
static member SplitLines :
        str : string -> string[]
static member SplitLines :
        str : string -> string[]

Parameters

str
Type: Online System String

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.StripSimpleHtml Method

MiscUtils StripSimpleHtml Method NFX Class Library

Strip simple html from string

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string StripSimpleHtml(
    this string str
)
public static string StripSimpleHtml(
    this string str
)
<ExtensionAttribute>
Public Shared Function StripSimpleHtml (
    str As String
) As String
<ExtensionAttribute>
Public Shared Function StripSimpleHtml (
    str As String
) As String
public:
[ExtensionAttribute]
static String^ StripSimpleHtml(
    String^ str
)
public:
[ExtensionAttribute]
static String^ StripSimpleHtml(
    String^ str
)
static member StripSimpleHtml :
        str : string -> string
static member StripSimpleHtml :
        str : string -> string

Parameters

str
Type: Online System String

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.TakeFirstChars Method

MiscUtils TakeFirstChars Method NFX Class Library

Takes first X chars from a string. If string is null returns null. If string does not have enough the function returns what the string has

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string TakeFirstChars(
    this string str,
    int count,
    string ellipsis = null
)
public static string TakeFirstChars(
    this string str,
    int count,
    string ellipsis = null
)
<ExtensionAttribute>
Public Shared Function TakeFirstChars (
    str As String,
    count As Integer,
    Optional ellipsis As String = Nothing
) As String
<ExtensionAttribute>
Public Shared Function TakeFirstChars (
    str As String,
    count As Integer,
    Optional ellipsis As String = Nothing
) As String
public:
[ExtensionAttribute]
static String^ TakeFirstChars(
    String^ str,
    int count,
    String^ ellipsis = nullptr
)
public:
[ExtensionAttribute]
static String^ TakeFirstChars(
    String^ str,
    int count,
    String^ ellipsis = nullptr
)
static member TakeFirstChars :
        str : string *
        count : int *
        ?ellipsis : string
(* Defaults:
        let _ellipsis = defaultArg ellipsis null
*)
-> string
static member TakeFirstChars :
        str : string *
        count : int *
        ?ellipsis : string
(* Defaults:
        let _ellipsis = defaultArg ellipsis null
*)
-> string

Parameters

str
Type: Online System String
count
Type: Online System Int32
ellipsis (Optional)
Type: Online System String

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.ToConfigAttributes Method

MiscUtils ToConfigAttributes Method NFX Class Library

Converts dictionary into configuration where every original node gets represented as an attribute of config's root

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Configuration ToConfigAttributes(
    this IDictionary<string, Object> dict
)
public static Configuration ToConfigAttributes(
    this IDictionary<string, Object> dict
)
<ExtensionAttribute>
Public Shared Function ToConfigAttributes (
    dict As IDictionary(Of String, Object)
) As Configuration
<ExtensionAttribute>
Public Shared Function ToConfigAttributes (
    dict As IDictionary(Of String, Object)
) As Configuration
public:
[ExtensionAttribute]
static Configuration^ ToConfigAttributes(
    IDictionary<String^, Object^>^ dict
)
public:
[ExtensionAttribute]
static Configuration^ ToConfigAttributes(
    IDictionary<String^, Object^>^ dict
)
static member ToConfigAttributes :
        dict : IDictionary<string, Object> -> Configuration
static member ToConfigAttributes :
        dict : IDictionary<string, Object> -> Configuration

Parameters

dict
Type: Online System.Collections.Generic IDictionary Online String, Online Object

Return Value

Type: Configuration

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online IDictionary Online String, Online Object . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.ToConfigSections Method

MiscUtils ToConfigSections Method NFX Class Library

Converts dictionary into configuration where every original node gets represented as a sub-section of config's root

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Configuration ToConfigSections(
    this IDictionary<string, Object> dict
)
public static Configuration ToConfigSections(
    this IDictionary<string, Object> dict
)
<ExtensionAttribute>
Public Shared Function ToConfigSections (
    dict As IDictionary(Of String, Object)
) As Configuration
<ExtensionAttribute>
Public Shared Function ToConfigSections (
    dict As IDictionary(Of String, Object)
) As Configuration
public:
[ExtensionAttribute]
static Configuration^ ToConfigSections(
    IDictionary<String^, Object^>^ dict
)
public:
[ExtensionAttribute]
static Configuration^ ToConfigSections(
    IDictionary<String^, Object^>^ dict
)
static member ToConfigSections :
        dict : IDictionary<string, Object> -> Configuration
static member ToConfigSections :
        dict : IDictionary<string, Object> -> Configuration

Parameters

dict
Type: Online System.Collections.Generic IDictionary Online String, Online Object

Return Value

Type: Configuration

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online IDictionary Online String, Online Object . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.ToDebugView Method

MiscUtils ToDebugView Method NFX Class Library

Converts expression tree to simple textual form for debugging

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ToDebugView(
    this Expression expr,
    int indent = 0
)
public static string ToDebugView(
    this Expression expr,
    int indent = 0
)
<ExtensionAttribute>
Public Shared Function ToDebugView (
    expr As Expression,
    Optional indent As Integer = 0
) As String
<ExtensionAttribute>
Public Shared Function ToDebugView (
    expr As Expression,
    Optional indent As Integer = 0
) As String
public:
[ExtensionAttribute]
static String^ ToDebugView(
    Expression^ expr,
    int indent = 0
)
public:
[ExtensionAttribute]
static String^ ToDebugView(
    Expression^ expr,
    int indent = 0
)
static member ToDebugView :
        expr : Expression *
        ?indent : int
(* Defaults:
        let _indent = defaultArg indent 0
*)
-> string
static member ToDebugView :
        expr : Expression *
        ?indent : int
(* Defaults:
        let _indent = defaultArg indent 0
*)
-> string

Parameters

expr
Type: Online System.Linq.Expressions Expression
indent (Optional)
Type: Online System Int32

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Expression. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.ToDescription Method

MiscUtils ToDescription Method NFX Class Library

Returns MemberInfo described as short string

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ToDescription(
    this MemberInfo mem
)
public static string ToDescription(
    this MemberInfo mem
)
<ExtensionAttribute>
Public Shared Function ToDescription (
    mem As MemberInfo
) As String
<ExtensionAttribute>
Public Shared Function ToDescription (
    mem As MemberInfo
) As String
public:
[ExtensionAttribute]
static String^ ToDescription(
    MemberInfo^ mem
)
public:
[ExtensionAttribute]
static String^ ToDescription(
    MemberInfo^ mem
)
static member ToDescription :
        mem : MemberInfo -> string
static member ToDescription :
        mem : MemberInfo -> string

Parameters

mem
Type: Online System.Reflection MemberInfo

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online MemberInfo. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.ToDumpString Method

MiscUtils ToDumpString Method NFX Class Library

Convert a buffer to a printable string

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ToDumpString(
    this byte[] buf,
    DumpFormat fmt,
    int offset = 0,
    int count = -1,
    bool eol = false,
    Encoding encoding = null,
    int maxLen = 0
)
public static string ToDumpString(
    this byte[] buf,
    DumpFormat fmt,
    int offset = 0,
    int count = -1,
    bool eol = false,
    Encoding encoding = null,
    int maxLen = 0
)
<ExtensionAttribute>
Public Shared Function ToDumpString (
    buf As Byte(),
    fmt As DumpFormat,
    Optional offset As Integer = 0,
    Optional count As Integer = -1,
    Optional eol As Boolean = false,
    Optional encoding As Encoding = Nothing,
    Optional maxLen As Integer = 0
) As String
<ExtensionAttribute>
Public Shared Function ToDumpString (
    buf As Byte(),
    fmt As DumpFormat,
    Optional offset As Integer = 0,
    Optional count As Integer = -1,
    Optional eol As Boolean = false,
    Optional encoding As Encoding = Nothing,
    Optional maxLen As Integer = 0
) As String
public:
[ExtensionAttribute]
static String^ ToDumpString(
    array<unsigned char>^ buf,
    DumpFormat fmt,
    int offset = 0,
    int count = -1,
    bool eol = false,
    Encoding^ encoding = nullptr,
    int maxLen = 0
)
public:
[ExtensionAttribute]
static String^ ToDumpString(
    array<unsigned char>^ buf,
    DumpFormat fmt,
    int offset = 0,
    int count = -1,
    bool eol = false,
    Encoding^ encoding = nullptr,
    int maxLen = 0
)
static member ToDumpString :
        buf : byte[] *
        fmt : DumpFormat *
        ?offset : int *
        ?count : int *
        ?eol : bool *
        ?encoding : Encoding *
        ?maxLen : int
(* Defaults:
        let _offset = defaultArg offset 0
        let _count = defaultArg count -1
        let _eol = defaultArg eol false
        let _encoding = defaultArg encoding null
        let _maxLen = defaultArg maxLen 0
*)
-> string
static member ToDumpString :
        buf : byte[] *
        fmt : DumpFormat *
        ?offset : int *
        ?count : int *
        ?eol : bool *
        ?encoding : Encoding *
        ?maxLen : int
(* Defaults:
        let _offset = defaultArg offset 0
        let _count = defaultArg count -1
        let _eol = defaultArg eol false
        let _encoding = defaultArg encoding null
        let _maxLen = defaultArg maxLen 0
*)
-> string

Parameters

buf
Type: Online System Byte
Buffer to convert
fmt
Type: NFX DumpFormat
Dumping format
offset (Optional)
Type: Online System Int32
Starting index
count (Optional)
Type: Online System Int32
Number of bytes to process (-1 means all bytes in the buffer)
eol (Optional)
Type: Online System Boolean
If true, terminate with end-of-line
encoding (Optional)
Type: Online System.Text Encoding
Encoding to use for writing data in Binary format
maxLen (Optional)
Type: Online System Int32
Max length of the returned string. Pass 0 for unlimited length

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.ToGUID Method

MiscUtils ToGUID Method NFX Class Library

Generates GUID based on a string MD5 hash

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Guid ToGUID(
    this string input
)
public static Guid ToGUID(
    this string input
)
<ExtensionAttribute>
Public Shared Function ToGUID (
    input As String
) As Guid
<ExtensionAttribute>
Public Shared Function ToGUID (
    input As String
) As Guid
public:
[ExtensionAttribute]
static Guid ToGUID(
    String^ input
)
public:
[ExtensionAttribute]
static Guid ToGUID(
    String^ input
)
static member ToGUID :
        input : string -> Guid
static member ToGUID :
        input : string -> Guid

Parameters

input
Type: Online System String

Return Value

Type: Online Guid

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.ToIPEndPoint Method

MiscUtils ToIPEndPoint Method NFX Class Library

Resolve IP address by Name

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IPEndPoint ToIPEndPoint(
    this string epoint,
    int dfltPort = 0
)
public static IPEndPoint ToIPEndPoint(
    this string epoint,
    int dfltPort = 0
)
<ExtensionAttribute>
Public Shared Function ToIPEndPoint (
    epoint As String,
    Optional dfltPort As Integer = 0
) As IPEndPoint
<ExtensionAttribute>
Public Shared Function ToIPEndPoint (
    epoint As String,
    Optional dfltPort As Integer = 0
) As IPEndPoint
public:
[ExtensionAttribute]
static IPEndPoint^ ToIPEndPoint(
    String^ epoint,
    int dfltPort = 0
)
public:
[ExtensionAttribute]
static IPEndPoint^ ToIPEndPoint(
    String^ epoint,
    int dfltPort = 0
)
static member ToIPEndPoint :
        epoint : string *
        ?dfltPort : int
(* Defaults:
        let _dfltPort = defaultArg dfltPort 0
*)
-> IPEndPoint
static member ToIPEndPoint :
        epoint : string *
        ?dfltPort : int
(* Defaults:
        let _dfltPort = defaultArg dfltPort 0
*)
-> IPEndPoint

Parameters

epoint
Type: Online System String
An ip address or DNS host name with optional port separated by ':'
dfltPort (Optional)
Type: Online System Int32
Port number to use if not supplied in endpoint string

Return Value

Type: Online IPEndPoint
IPEndPoint instance or null supplied string could not be parsed

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.ToJSONDataMap Method

MiscUtils ToJSONDataMap Method NFX Class Library

If there is error, converts its details to JSOnDataMap

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static JSONDataMap ToJSONDataMap(
    this Exception error,
    bool recurse = true,
    bool stackTrace = false
)
public static JSONDataMap ToJSONDataMap(
    this Exception error,
    bool recurse = true,
    bool stackTrace = false
)
<ExtensionAttribute>
Public Shared Function ToJSONDataMap (
    error As Exception,
    Optional recurse As Boolean = true,
    Optional stackTrace As Boolean = false
) As JSONDataMap
<ExtensionAttribute>
Public Shared Function ToJSONDataMap (
    error As Exception,
    Optional recurse As Boolean = true,
    Optional stackTrace As Boolean = false
) As JSONDataMap
public:
[ExtensionAttribute]
static JSONDataMap^ ToJSONDataMap(
    Exception^ error,
    bool recurse = true,
    bool stackTrace = false
)
public:
[ExtensionAttribute]
static JSONDataMap^ ToJSONDataMap(
    Exception^ error,
    bool recurse = true,
    bool stackTrace = false
)
static member ToJSONDataMap :
        error : Exception *
        ?recurse : bool *
        ?stackTrace : bool
(* Defaults:
        let _recurse = defaultArg recurse true
        let _stackTrace = defaultArg stackTrace false
*)
-> JSONDataMap
static member ToJSONDataMap :
        error : Exception *
        ?recurse : bool *
        ?stackTrace : bool
(* Defaults:
        let _recurse = defaultArg recurse true
        let _stackTrace = defaultArg stackTrace false
*)
-> JSONDataMap

Parameters

error
Type: Online System Exception
recurse (Optional)
Type: Online System Boolean
stackTrace (Optional)
Type: Online System Boolean

Return Value

Type: JSONDataMap

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Exception. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.ToMD5 Method

MiscUtils ToMD5 Method NFX Class Library

Overload List
Name | Description
ToMD5( Byte ) | Returns a MD5 hash of a byte array
ToMD5(String) | Returns a MD5 hash of a UTF8 string represented as byte[]
Back to Top
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.ToMD5 Method (Byte[])

MiscUtils ToMD5 Method ( Byte ) NFX Class Library

Returns a MD5 hash of a byte array

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte[] ToMD5(
    this byte[] input
)
public static byte[] ToMD5(
    this byte[] input
)
<ExtensionAttribute>
Public Shared Function ToMD5 (
    input As Byte()
) As Byte()
<ExtensionAttribute>
Public Shared Function ToMD5 (
    input As Byte()
) As Byte()
public:
[ExtensionAttribute]
static array<unsigned char>^ ToMD5(
    array<unsigned char>^ input
)
public:
[ExtensionAttribute]
static array<unsigned char>^ ToMD5(
    array<unsigned char>^ input
)
static member ToMD5 :
        input : byte[] -> byte[]
static member ToMD5 :
        input : byte[] -> byte[]

Parameters

input
Type: Online System Byte

Return Value

Type: Online Byte

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
ToMD5 Overload
NFX Namespace


MiscUtils.ToMD5 Method (String)

MiscUtils ToMD5 Method (String) NFX Class Library

Returns a MD5 hash of a UTF8 string represented as byte[]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte[] ToMD5(
    this string input
)
public static byte[] ToMD5(
    this string input
)
<ExtensionAttribute>
Public Shared Function ToMD5 (
    input As String
) As Byte()
<ExtensionAttribute>
Public Shared Function ToMD5 (
    input As String
) As Byte()
public:
[ExtensionAttribute]
static array<unsigned char>^ ToMD5(
    String^ input
)
public:
[ExtensionAttribute]
static array<unsigned char>^ ToMD5(
    String^ input
)
static member ToMD5 :
        input : string -> byte[]
static member ToMD5 :
        input : string -> byte[]

Parameters

input
Type: Online System String

Return Value

Type: Online Byte

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
ToMD5 Overload
NFX Namespace


MiscUtils.ToMD5String Method

MiscUtils ToMD5String Method NFX Class Library

Returns a MD5 hash of a UTF8 string represented as hex string

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ToMD5String(
    this string input
)
public static string ToMD5String(
    this string input
)
<ExtensionAttribute>
Public Shared Function ToMD5String (
    input As String
) As String
<ExtensionAttribute>
Public Shared Function ToMD5String (
    input As String
) As String
public:
[ExtensionAttribute]
static String^ ToMD5String(
    String^ input
)
public:
[ExtensionAttribute]
static String^ ToMD5String(
    String^ input
)
static member ToMD5String :
        input : string -> string
static member ToMD5String :
        input : string -> string

Parameters

input
Type: Online System String

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.ToMessageWithType Method

MiscUtils ToMessageWithType Method NFX Class Library

Writes exception message with exception type

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ToMessageWithType(
    this Exception error
)
public static string ToMessageWithType(
    this Exception error
)
<ExtensionAttribute>
Public Shared Function ToMessageWithType (
    error As Exception
) As String
<ExtensionAttribute>
Public Shared Function ToMessageWithType (
    error As Exception
) As String
public:
[ExtensionAttribute]
static String^ ToMessageWithType(
    Exception^ error
)
public:
[ExtensionAttribute]
static String^ ToMessageWithType(
    Exception^ error
)
static member ToMessageWithType :
        error : Exception -> string
static member ToMessageWithType :
        error : Exception -> string

Parameters

error
Type: Online System Exception

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Exception. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.ToMicrosecondsSinceUnixEpochStart Method

MiscUtils ToMicrosecondsSinceUnixEpochStart Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets number of microseconds since Unix epoch start (1970/1/1 0:0:0)

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long ToMicrosecondsSinceUnixEpochStart(
    this DateTime when
)
public static long ToMicrosecondsSinceUnixEpochStart(
    this DateTime when
)
<ExtensionAttribute>
Public Shared Function ToMicrosecondsSinceUnixEpochStart (
    when As DateTime
) As Long
<ExtensionAttribute>
Public Shared Function ToMicrosecondsSinceUnixEpochStart (
    when As DateTime
) As Long
public:
[ExtensionAttribute]
static long long ToMicrosecondsSinceUnixEpochStart(
    DateTime when
)
public:
[ExtensionAttribute]
static long long ToMicrosecondsSinceUnixEpochStart(
    DateTime when
)
static member ToMicrosecondsSinceUnixEpochStart :
        when : DateTime -> int64
static member ToMicrosecondsSinceUnixEpochStart :
        when : DateTime -> int64

Parameters

when
Type: Online System DateTime

Return Value

Type: Online Int64

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.ToMillisecondsSinceUnixEpochStart Method

MiscUtils ToMillisecondsSinceUnixEpochStart Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets number of milliseconds since Unix epoch start (1970/1/1 0:0:0)

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long ToMillisecondsSinceUnixEpochStart(
    this DateTime when
)
public static long ToMillisecondsSinceUnixEpochStart(
    this DateTime when
)
<ExtensionAttribute>
Public Shared Function ToMillisecondsSinceUnixEpochStart (
    when As DateTime
) As Long
<ExtensionAttribute>
Public Shared Function ToMillisecondsSinceUnixEpochStart (
    when As DateTime
) As Long
public:
[ExtensionAttribute]
static long long ToMillisecondsSinceUnixEpochStart(
    DateTime when
)
public:
[ExtensionAttribute]
static long long ToMillisecondsSinceUnixEpochStart(
    DateTime when
)
static member ToMillisecondsSinceUnixEpochStart :
        when : DateTime -> int64
static member ToMillisecondsSinceUnixEpochStart :
        when : DateTime -> int64

Parameters

when
Type: Online System DateTime

Return Value

Type: Online Int64

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.ToSecondsSinceUnixEpochStart Method

MiscUtils ToSecondsSinceUnixEpochStart Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets number of seconds since Unix epoch start (1970/1/1 0:0:0)

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long ToSecondsSinceUnixEpochStart(
    this DateTime when
)
public static long ToSecondsSinceUnixEpochStart(
    this DateTime when
)
<ExtensionAttribute>
Public Shared Function ToSecondsSinceUnixEpochStart (
    when As DateTime
) As Long
<ExtensionAttribute>
Public Shared Function ToSecondsSinceUnixEpochStart (
    when As DateTime
) As Long
public:
[ExtensionAttribute]
static long long ToSecondsSinceUnixEpochStart(
    DateTime when
)
public:
[ExtensionAttribute]
static long long ToSecondsSinceUnixEpochStart(
    DateTime when
)
static member ToSecondsSinceUnixEpochStart :
        when : DateTime -> int64
static member ToSecondsSinceUnixEpochStart :
        when : DateTime -> int64

Parameters

when
Type: Online System DateTime

Return Value

Type: Online Int64

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.ToUTF8Bytes Method

MiscUtils ToUTF8Bytes Method NFX Class Library

Encodes string with standart UTF8 encoder

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte[] ToUTF8Bytes(
    this string str
)
public static byte[] ToUTF8Bytes(
    this string str
)
<ExtensionAttribute>
Public Shared Function ToUTF8Bytes (
    str As String
) As Byte()
<ExtensionAttribute>
Public Shared Function ToUTF8Bytes (
    str As String
) As Byte()
public:
[ExtensionAttribute]
static array<unsigned char>^ ToUTF8Bytes(
    String^ str
)
public:
[ExtensionAttribute]
static array<unsigned char>^ ToUTF8Bytes(
    String^ str
)
static member ToUTF8Bytes :
        str : string -> byte[]
static member ToUTF8Bytes :
        str : string -> byte[]

Parameters

str
Type: Online System String

Return Value

Type: Online Byte

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


MiscUtils.Truncate Method

MiscUtils Truncate Method NFX Class Library

Tuncate date to specific resolution

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DateTime Truncate(
    this DateTime now,
    long tickResolution
)
public static DateTime Truncate(
    this DateTime now,
    long tickResolution
)
<ExtensionAttribute>
Public Shared Function Truncate (
    now As DateTime,
    tickResolution As Long
) As DateTime
<ExtensionAttribute>
Public Shared Function Truncate (
    now As DateTime,
    tickResolution As Long
) As DateTime
public:
[ExtensionAttribute]
static DateTime Truncate(
    DateTime now,
    long long tickResolution
)
public:
[ExtensionAttribute]
static DateTime Truncate(
    DateTime now,
    long long tickResolution
)
static member Truncate :
        now : DateTime *
        tickResolution : int64 -> DateTime
static member Truncate :
        now : DateTime *
        tickResolution : int64 -> DateTime

Parameters

now
Type: Online System DateTime
tickResolution
Type: Online System Int64

Return Value

Type: Online DateTime

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
MiscUtils Class
MiscUtils Members
NFX Namespace


NFXException Class

NFXException Class NFX Class Library

Base exception thrown by the framework
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.ApplicationModel.Pile PileException
NFX AvermentException
NFX.CodeAnalysis CodeAnalysisException
NFX.DataAccess DataAccessException
NFX DebugAssertionException
NFX DisposedObjectException
NFX.Environment ConfigException
NFX.Erlang ErlException
NFX.Financial FinancialException
NFX.Glue GlueException
NFX.Health HealthCheckListException
NFX.Health HealthException
NFX.Inventorization InventorizationException
NFX.IO.FileSystem FileSystemException
NFX.IO.Net.Gate NetGateException
NFX.IO NFXIOException
NFX.Log.Bin BinLogException
NFX.Media.PDF PdfException
NFX.RelationalModel RelationalException
NFX.Security SecurityException
NFX.Serialization.BSON BSONException
NFX.Serialization.CSV CSVParserException
NFX.Serialization NFXSerializationException
NFX.ServiceModel SvcHostException
NFX.Templatization TemplatizationException
NFX.Time TimeException
NFX.Wave WaveException
NFX.Web.Pay PaymentException
NFX.Web.Social NFXSocialException
NFX.Web WebException
NFX.WinForms WFormsException
NFX WrappedException

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class NFXException : Exception
[SerializableAttribute]
public class NFXException : Exception
<SerializableAttribute>
Public Class NFXException
    Inherits Exception
<SerializableAttribute>
Public Class NFXException
    Inherits Exception
[SerializableAttribute]
public ref class NFXException : public Exception
[SerializableAttribute]
public ref class NFXException : public Exception
[<SerializableAttribute>]
type NFXException =
    class
        inherit Exception
    end
[<SerializableAttribute>]
type NFXException =
    class
        inherit Exception
    end
See Also
NFXException Members
NFX Namespace


NFXException Members

NFXException Members NFX Class Library

The NFXException type exposes the following members.
Constructors
 | Name | Description
Public method | NFXException | Initializes a new instance of the NFXException class
Public method | NFXException(String) | Initializes a new instance of the NFXException class
Protected method | NFXException(SerializationInfo, StreamingContext) | Initializes a new instance of the NFXException class
Public method | NFXException(String, Exception) | Initializes a new instance of the NFXException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
NFXException Class
NFX Namespace


NFXException Constructor

NFXException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | NFXException | Initializes a new instance of the NFXException class
Public method | NFXException(String) | Initializes a new instance of the NFXException class
Protected method | NFXException(SerializationInfo, StreamingContext) | Initializes a new instance of the NFXException class
Public method | NFXException(String, Exception) | Initializes a new instance of the NFXException class
Back to Top
See Also
NFXException Class
NFXException Members
NFX Namespace


NFXException Constructor

NFXException Constructor NFX Class Library

Initializes a new instance of the NFXException class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NFXException()
public NFXException()
Public Sub New
Public Sub New
public:
NFXException()
public:
NFXException()
new : unit -> NFXException
new : unit -> NFXException
See Also
NFXException Class
NFXException Members
NFXException Overload
NFX Namespace


NFXException Constructor (String)

NFXException Constructor (String) NFX Class Library

Initializes a new instance of the NFXException class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NFXException(
    string message
)
public NFXException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
NFXException(
    String^ message
)
public:
NFXException(
    String^ message
)
new :
        message : string -> NFXException
new :
        message : string -> NFXException

Parameters

message
Type: Online System String
See Also
NFXException Class
NFXException Members
NFXException Overload
NFX Namespace


NFXException Constructor (SerializationInfo, StreamingContext)

NFXException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NFXException class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected NFXException(
    SerializationInfo info,
    StreamingContext context
)
protected NFXException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
NFXException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
NFXException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> NFXException
new :
        info : SerializationInfo *
        context : StreamingContext -> NFXException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
NFXException Class
NFXException Members
NFXException Overload
NFX Namespace


NFXException Constructor (String, Exception)

NFXException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NFXException class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NFXException(
    string message,
    Exception inner
)
public NFXException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
NFXException(
    String^ message,
    Exception^ inner
)
public:
NFXException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> NFXException
new :
        message : string *
        inner : Exception -> NFXException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
NFXException Class
NFXException Members
NFXException Overload
NFX Namespace


NFXException Methods

NFXException Methods NFX Class Library

The NFXException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
NFXException Class
NFX Namespace


NFXException Properties

NFXException Properties NFX Class Library

The NFXException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
NFXException Class
NFX Namespace


NFXException.Code Property

NFXException Code Property NFX Class Library

Provides general-purpose error code

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Code { get; set; }
public int Code { get; set; }
Public Property Code As Integer
    Get
    Set
Public Property Code As Integer
    Get
    Set
public:
property int Code {
    int get ();
    void set (int value);
}
public:
property int Code {
    int get ();
    void set (int value);
}
member Code : int with get, set
member Code : int with get, set

Property Value

Type: Online Int32
See Also
NFXException Class
NFXException Members
NFX Namespace


NFXException Events

NFXException Events NFX Class Library

The NFXException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
NFXException Class
NFX Namespace


ObjectValueConversion Class

ObjectValueConversion Class NFX Class Library

Provides extension methods for converting object values to different scalar types
Inheritance Hierarchy
Online System Object
NFX ObjectValueConversion

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class ObjectValueConversion
public static class ObjectValueConversion
<ExtensionAttribute>
Public NotInheritable Class ObjectValueConversion
<ExtensionAttribute>
Public NotInheritable Class ObjectValueConversion
[ExtensionAttribute]
public ref class ObjectValueConversion abstract sealed
[ExtensionAttribute]
public ref class ObjectValueConversion abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ObjectValueConversion =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ObjectValueConversion =  class end
See Also
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion Members

ObjectValueConversion Members NFX Class Library

The ObjectValueConversion type exposes the following members.
Methods
Name | Description
AsBool |
AsByte |
AsChar |
AsDateTime(Object) |
AsDateTime(Object, DateTime, ConvertErrorHandling) |
AsDecimal |
AsDouble |
AsEnum TEnum |
AsFloat |
AsGDID(Object) |
AsGDID(Object, GDID, ConvertErrorHandling) |
AsGDIDSymbol(Object) |
AsGDIDSymbol(Object, GDIDSymbol, ConvertErrorHandling) |
AsGUID |
AsInt |
AsJSONConfig |
AsLaconicConfig |
AsLong |
AsNonNullOrEmptyString |
AsNullableBool(ObjectValueConversion TriStateBool) |
AsNullableBool(Object, Nullable Boolean , ConvertErrorHandling) |
AsNullableByte |
AsNullableChar |
AsNullableDateTime |
AsNullableDecimal |
AsNullableDouble |
AsNullableEnum TEnum |
AsNullableFloat |
AsNullableGDID |
AsNullableGDIDSymbol |
AsNullableGUID |
AsNullableInt |
AsNullableLong |
AsNullableSByte |
AsNullableShort |
AsNullableTimeSpan |
AsNullableUInt |
AsNullableULong |
AsNullableUShort |
AsSByte |
AsShort |
AsString |
AsTimeSpan(Object) |
AsTimeSpan(Object, TimeSpan, ConvertErrorHandling) |
AsUInt |
AsULong |
AsUri |
AsUShort |
AsXMLConfig |
Back to Top
Fields
Name | Description
RADIX_BIN |
RADIX_HEX |
Back to Top
See Also
ObjectValueConversion Class
NFX Namespace


ObjectValueConversion Fields

ObjectValueConversion Fields NFX Class Library

The ObjectValueConversion type exposes the following members.
Fields
Name | Description
RADIX_BIN |
RADIX_HEX |
Back to Top
See Also
ObjectValueConversion Class
NFX Namespace


ObjectValueConversion.RADIX_BIN Field

ObjectValueConversion RADIX_BIN Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string RADIX_BIN
public const string RADIX_BIN
Public Const RADIX_BIN As String
Public Const RADIX_BIN As String
public:
literal String^ RADIX_BIN
public:
literal String^ RADIX_BIN
static val mutable RADIX_BIN: string
static val mutable RADIX_BIN: string

Field Value

Type: Online String
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.RADIX_HEX Field

ObjectValueConversion RADIX_HEX Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string RADIX_HEX
public const string RADIX_HEX
Public Const RADIX_HEX As String
Public Const RADIX_HEX As String
public:
literal String^ RADIX_HEX
public:
literal String^ RADIX_HEX
static val mutable RADIX_HEX: string
static val mutable RADIX_HEX: string

Field Value

Type: Online String
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion Methods

ObjectValueConversion Methods NFX Class Library

The ObjectValueConversion type exposes the following members.
Methods
Name | Description
AsBool |
AsByte |
AsChar |
AsDateTime(Object) |
AsDateTime(Object, DateTime, ConvertErrorHandling) |
AsDecimal |
AsDouble |
AsEnum TEnum |
AsFloat |
AsGDID(Object) |
AsGDID(Object, GDID, ConvertErrorHandling) |
AsGDIDSymbol(Object) |
AsGDIDSymbol(Object, GDIDSymbol, ConvertErrorHandling) |
AsGUID |
AsInt |
AsJSONConfig |
AsLaconicConfig |
AsLong |
AsNonNullOrEmptyString |
AsNullableBool(ObjectValueConversion TriStateBool) |
AsNullableBool(Object, Nullable Boolean , ConvertErrorHandling) |
AsNullableByte |
AsNullableChar |
AsNullableDateTime |
AsNullableDecimal |
AsNullableDouble |
AsNullableEnum TEnum |
AsNullableFloat |
AsNullableGDID |
AsNullableGDIDSymbol |
AsNullableGUID |
AsNullableInt |
AsNullableLong |
AsNullableSByte |
AsNullableShort |
AsNullableTimeSpan |
AsNullableUInt |
AsNullableULong |
AsNullableUShort |
AsSByte |
AsShort |
AsString |
AsTimeSpan(Object) |
AsTimeSpan(Object, TimeSpan, ConvertErrorHandling) |
AsUInt |
AsULong |
AsUri |
AsUShort |
AsXMLConfig |
Back to Top
See Also
ObjectValueConversion Class
NFX Namespace


ObjectValueConversion.AsBool Method

ObjectValueConversion AsBool Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool AsBool(
    this Object val,
    bool dflt = false,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static bool AsBool(
    this Object val,
    bool dflt = false,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsBool (
    val As Object,
    Optional dflt As Boolean = false,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Boolean
<ExtensionAttribute>
Public Shared Function AsBool (
    val As Object,
    Optional dflt As Boolean = false,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Boolean
public:
[ExtensionAttribute]
static bool AsBool(
    Object^ val,
    bool dflt = false,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static bool AsBool(
    Object^ val,
    bool dflt = false,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsBool :
        val : Object *
        ?dflt : bool *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt false
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> bool
static member AsBool :
        val : Object *
        ?dflt : bool *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt false
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> bool

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Boolean
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsByte Method

ObjectValueConversion AsByte Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte AsByte(
    this Object val,
    byte dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static byte AsByte(
    this Object val,
    byte dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsByte (
    val As Object,
    Optional dflt As Byte = 0,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Byte
<ExtensionAttribute>
Public Shared Function AsByte (
    val As Object,
    Optional dflt As Byte = 0,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Byte
public:
[ExtensionAttribute]
static unsigned char AsByte(
    Object^ val,
    unsigned char dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static unsigned char AsByte(
    Object^ val,
    unsigned char dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsByte :
        val : Object *
        ?dflt : byte *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> byte
static member AsByte :
        val : Object *
        ?dflt : byte *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> byte

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Byte
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Byte

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsChar Method

ObjectValueConversion AsChar Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static char AsChar(
    this Object val,
    char dflt = '',
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static char AsChar(
    this Object val,
    char dflt = '',
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsChar (
    val As Object,
    Optional dflt As Char = ""C,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Char
<ExtensionAttribute>
Public Shared Function AsChar (
    val As Object,
    Optional dflt As Char = ""C,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Char
public:
[ExtensionAttribute]
static wchar_t AsChar(
    Object^ val,
    wchar_t dflt = L'',
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static wchar_t AsChar(
    Object^ val,
    wchar_t dflt = L'',
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsChar :
        val : Object *
        ?dflt : char *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt ''
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> char
static member AsChar :
        val : Object *
        ?dflt : char *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt ''
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> char

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Char
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Char

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsDateTime Method

ObjectValueConversion AsDateTime Method NFX Class Library

Overload List
Name | Description
AsDateTime(Object) |
AsDateTime(Object, DateTime, ConvertErrorHandling) |
Back to Top
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsDateTime Method (Object)

ObjectValueConversion AsDateTime Method (Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DateTime AsDateTime(
    this Object val
)
public static DateTime AsDateTime(
    this Object val
)
<ExtensionAttribute>
Public Shared Function AsDateTime (
    val As Object
) As DateTime
<ExtensionAttribute>
Public Shared Function AsDateTime (
    val As Object
) As DateTime
public:
[ExtensionAttribute]
static DateTime AsDateTime(
    Object^ val
)
public:
[ExtensionAttribute]
static DateTime AsDateTime(
    Object^ val
)
static member AsDateTime :
        val : Object -> DateTime
static member AsDateTime :
        val : Object -> DateTime

Parameters

val
Type: Online System Object

Return Value

Type: Online DateTime

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
AsDateTime Overload
NFX Namespace


ObjectValueConversion.AsDateTime Method (Object, DateTime, ConvertErrorHandling)

ObjectValueConversion AsDateTime Method (Object, DateTime, ConvertErrorHandling) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DateTime AsDateTime(
    this Object val,
    DateTime dflt,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static DateTime AsDateTime(
    this Object val,
    DateTime dflt,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsDateTime (
    val As Object,
    dflt As DateTime,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As DateTime
<ExtensionAttribute>
Public Shared Function AsDateTime (
    val As Object,
    dflt As DateTime,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As DateTime
public:
[ExtensionAttribute]
static DateTime AsDateTime(
    Object^ val,
    DateTime dflt,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static DateTime AsDateTime(
    Object^ val,
    DateTime dflt,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsDateTime :
        val : Object *
        dflt : DateTime *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> DateTime
static member AsDateTime :
        val : Object *
        dflt : DateTime *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> DateTime

Parameters

val
Type: Online System Object
dflt
Type: Online System DateTime
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online DateTime

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
AsDateTime Overload
NFX Namespace


ObjectValueConversion.AsDecimal Method

ObjectValueConversion AsDecimal Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static decimal AsDecimal(
    this Object val,
    [OptionalAttribute] decimal dflt,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static decimal AsDecimal(
    this Object val,
    [OptionalAttribute] decimal dflt,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsDecimal (
    val As Object,
    <OptionalAttribute> dflt As Decimal,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Decimal
<ExtensionAttribute>
Public Shared Function AsDecimal (
    val As Object,
    <OptionalAttribute> dflt As Decimal,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Decimal
public:
[ExtensionAttribute]
static Decimal AsDecimal(
    Object^ val,
    [OptionalAttribute] Decimal dflt,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static Decimal AsDecimal(
    Object^ val,
    [OptionalAttribute] Decimal dflt,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsDecimal :
        val : Object *
        [<OptionalAttribute>] dflt : decimal *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> decimal
static member AsDecimal :
        val : Object *
        [<OptionalAttribute>] dflt : decimal *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> decimal

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Decimal
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Decimal

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsDouble Method

ObjectValueConversion AsDouble Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static double AsDouble(
    this Object val,
    double dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static double AsDouble(
    this Object val,
    double dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsDouble (
    val As Object,
    Optional dflt As Double = 0,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Double
<ExtensionAttribute>
Public Shared Function AsDouble (
    val As Object,
    Optional dflt As Double = 0,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Double
public:
[ExtensionAttribute]
static double AsDouble(
    Object^ val,
    double dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static double AsDouble(
    Object^ val,
    double dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsDouble :
        val : Object *
        ?dflt : float *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> float
static member AsDouble :
        val : Object *
        ?dflt : float *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> float

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Double
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Double

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsEnum(TEnum) Method

ObjectValueConversion AsEnum TEnum Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TEnum AsEnum<TEnum>(
    this Object val,
    TEnum dflt,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
where TEnum : struct, new()
public static TEnum AsEnum<TEnum>(
    this Object val,
    TEnum dflt,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
where TEnum : struct, new()
<ExtensionAttribute>
Public Shared Function AsEnum(Of TEnum As {Structure, New}) (
    val As Object,
    dflt As TEnum,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As TEnum
<ExtensionAttribute>
Public Shared Function AsEnum(Of TEnum As {Structure, New}) (
    val As Object,
    dflt As TEnum,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As TEnum
public:
[ExtensionAttribute]
generic<typename TEnum>
where TEnum : value class, gcnew()
static TEnum AsEnum(
    Object^ val,
    TEnum dflt,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
generic<typename TEnum>
where TEnum : value class, gcnew()
static TEnum AsEnum(
    Object^ val,
    TEnum dflt,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsEnum :
        val : Object *
        dflt : 'TEnum *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> 'TEnum  when 'TEnum : struct, new()
static member AsEnum :
        val : Object *
        dflt : 'TEnum *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> 'TEnum  when 'TEnum : struct, new()

Parameters

val
Type: Online System Object
dflt
Type: TEnum
handling (Optional)
Type: NFX ConvertErrorHandling
Type Parameters
TEnum

Return Value

Type: TEnum

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsFloat Method

ObjectValueConversion AsFloat Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static float AsFloat(
    this Object val,
    float dflt = 0f,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static float AsFloat(
    this Object val,
    float dflt = 0f,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsFloat (
    val As Object,
    Optional dflt As Single = 0F,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Single
<ExtensionAttribute>
Public Shared Function AsFloat (
    val As Object,
    Optional dflt As Single = 0F,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Single
public:
[ExtensionAttribute]
static float AsFloat(
    Object^ val,
    float dflt = 0f,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static float AsFloat(
    Object^ val,
    float dflt = 0f,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsFloat :
        val : Object *
        ?dflt : float32 *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt 0f
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> float32
static member AsFloat :
        val : Object *
        ?dflt : float32 *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt 0f
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> float32

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Single
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Single

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsGDID Method

ObjectValueConversion AsGDID Method NFX Class Library

Overload List
Name | Description
AsGDID(Object) |
AsGDID(Object, GDID, ConvertErrorHandling) |
Back to Top
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsGDID Method (Object)

ObjectValueConversion AsGDID Method (Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static GDID AsGDID(
    this Object val
)
public static GDID AsGDID(
    this Object val
)
<ExtensionAttribute>
Public Shared Function AsGDID (
    val As Object
) As GDID
<ExtensionAttribute>
Public Shared Function AsGDID (
    val As Object
) As GDID
public:
[ExtensionAttribute]
static GDID AsGDID(
    Object^ val
)
public:
[ExtensionAttribute]
static GDID AsGDID(
    Object^ val
)
static member AsGDID :
        val : Object -> GDID
static member AsGDID :
        val : Object -> GDID

Parameters

val
Type: Online System Object

Return Value

Type: GDID

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
AsGDID Overload
NFX Namespace


ObjectValueConversion.AsGDID Method (Object, GDID, ConvertErrorHandling)

ObjectValueConversion AsGDID Method (Object, GDID, ConvertErrorHandling) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static GDID AsGDID(
    this Object val,
    GDID dflt,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static GDID AsGDID(
    this Object val,
    GDID dflt,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsGDID (
    val As Object,
    dflt As GDID,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As GDID
<ExtensionAttribute>
Public Shared Function AsGDID (
    val As Object,
    dflt As GDID,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As GDID
public:
[ExtensionAttribute]
static GDID AsGDID(
    Object^ val,
    GDID dflt,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static GDID AsGDID(
    Object^ val,
    GDID dflt,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsGDID :
        val : Object *
        dflt : GDID *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> GDID
static member AsGDID :
        val : Object *
        dflt : GDID *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> GDID

Parameters

val
Type: Online System Object
dflt
Type: NFX.DataAccess.Distributed GDID
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: GDID

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
AsGDID Overload
NFX Namespace


ObjectValueConversion.AsGDIDSymbol Method

ObjectValueConversion AsGDIDSymbol Method NFX Class Library

Overload List
Name | Description
AsGDIDSymbol(Object) |
AsGDIDSymbol(Object, GDIDSymbol, ConvertErrorHandling) |
Back to Top
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsGDIDSymbol Method (Object)

ObjectValueConversion AsGDIDSymbol Method (Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static GDIDSymbol AsGDIDSymbol(
    this Object val
)
public static GDIDSymbol AsGDIDSymbol(
    this Object val
)
<ExtensionAttribute>
Public Shared Function AsGDIDSymbol (
    val As Object
) As GDIDSymbol
<ExtensionAttribute>
Public Shared Function AsGDIDSymbol (
    val As Object
) As GDIDSymbol
public:
[ExtensionAttribute]
static GDIDSymbol AsGDIDSymbol(
    Object^ val
)
public:
[ExtensionAttribute]
static GDIDSymbol AsGDIDSymbol(
    Object^ val
)
static member AsGDIDSymbol :
        val : Object -> GDIDSymbol
static member AsGDIDSymbol :
        val : Object -> GDIDSymbol

Parameters

val
Type: Online System Object

Return Value

Type: GDIDSymbol

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
AsGDIDSymbol Overload
NFX Namespace


ObjectValueConversion.AsGDIDSymbol Method (Object, GDIDSymbol, ConvertErrorHandling)

ObjectValueConversion AsGDIDSymbol Method (Object, GDIDSymbol, ConvertErrorHandling) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static GDIDSymbol AsGDIDSymbol(
    this Object val,
    GDIDSymbol dflt,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static GDIDSymbol AsGDIDSymbol(
    this Object val,
    GDIDSymbol dflt,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsGDIDSymbol (
    val As Object,
    dflt As GDIDSymbol,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As GDIDSymbol
<ExtensionAttribute>
Public Shared Function AsGDIDSymbol (
    val As Object,
    dflt As GDIDSymbol,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As GDIDSymbol
public:
[ExtensionAttribute]
static GDIDSymbol AsGDIDSymbol(
    Object^ val,
    GDIDSymbol dflt,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static GDIDSymbol AsGDIDSymbol(
    Object^ val,
    GDIDSymbol dflt,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsGDIDSymbol :
        val : Object *
        dflt : GDIDSymbol *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> GDIDSymbol
static member AsGDIDSymbol :
        val : Object *
        dflt : GDIDSymbol *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> GDIDSymbol

Parameters

val
Type: Online System Object
dflt
Type: NFX.DataAccess.Distributed GDIDSymbol
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: GDIDSymbol

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
AsGDIDSymbol Overload
NFX Namespace


ObjectValueConversion.AsGUID Method

ObjectValueConversion AsGUID Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Guid AsGUID(
    this Object val,
    Guid dflt,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static Guid AsGUID(
    this Object val,
    Guid dflt,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsGUID (
    val As Object,
    dflt As Guid,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Guid
<ExtensionAttribute>
Public Shared Function AsGUID (
    val As Object,
    dflt As Guid,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Guid
public:
[ExtensionAttribute]
static Guid AsGUID(
    Object^ val,
    Guid dflt,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static Guid AsGUID(
    Object^ val,
    Guid dflt,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsGUID :
        val : Object *
        dflt : Guid *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Guid
static member AsGUID :
        val : Object *
        dflt : Guid *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Guid

Parameters

val
Type: Online System Object
dflt
Type: Online System Guid
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Guid

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsInt Method

ObjectValueConversion AsInt Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int AsInt(
    this Object val,
    int dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static int AsInt(
    this Object val,
    int dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsInt (
    val As Object,
    Optional dflt As Integer = 0,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Integer
<ExtensionAttribute>
Public Shared Function AsInt (
    val As Object,
    Optional dflt As Integer = 0,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Integer
public:
[ExtensionAttribute]
static int AsInt(
    Object^ val,
    int dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static int AsInt(
    Object^ val,
    int dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsInt :
        val : Object *
        ?dflt : int *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> int
static member AsInt :
        val : Object *
        ?dflt : int *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> int

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Int32
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Int32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsJSONConfig Method

ObjectValueConversion AsJSONConfig Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ConfigSectionNode AsJSONConfig(
    this Object val,
    ConfigSectionNode dflt = null,
    string wrapRootName = "nfx",
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static ConfigSectionNode AsJSONConfig(
    this Object val,
    ConfigSectionNode dflt = null,
    string wrapRootName = "nfx",
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsJSONConfig (
    val As Object,
    Optional dflt As ConfigSectionNode = Nothing,
    Optional wrapRootName As String = "nfx",
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As ConfigSectionNode
<ExtensionAttribute>
Public Shared Function AsJSONConfig (
    val As Object,
    Optional dflt As ConfigSectionNode = Nothing,
    Optional wrapRootName As String = "nfx",
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As ConfigSectionNode
public:
[ExtensionAttribute]
static ConfigSectionNode^ AsJSONConfig(
    Object^ val,
    ConfigSectionNode^ dflt = nullptr,
    String^ wrapRootName = L"nfx",
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static ConfigSectionNode^ AsJSONConfig(
    Object^ val,
    ConfigSectionNode^ dflt = nullptr,
    String^ wrapRootName = L"nfx",
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsJSONConfig :
        val : Object *
        ?dflt : ConfigSectionNode *
        ?wrapRootName : string *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _wrapRootName = defaultArg wrapRootName "nfx"
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> ConfigSectionNode
static member AsJSONConfig :
        val : Object *
        ?dflt : ConfigSectionNode *
        ?wrapRootName : string *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _wrapRootName = defaultArg wrapRootName "nfx"
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> ConfigSectionNode

Parameters

val
Type: Online System Object
dflt (Optional)
Type: NFX.Environment ConfigSectionNode
wrapRootName (Optional)
Type: Online System String
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: ConfigSectionNode

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsLaconicConfig Method

ObjectValueConversion AsLaconicConfig Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ConfigSectionNode AsLaconicConfig(
    this Object val,
    ConfigSectionNode dflt = null,
    string wrapRootName = "nfx",
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static ConfigSectionNode AsLaconicConfig(
    this Object val,
    ConfigSectionNode dflt = null,
    string wrapRootName = "nfx",
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsLaconicConfig (
    val As Object,
    Optional dflt As ConfigSectionNode = Nothing,
    Optional wrapRootName As String = "nfx",
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As ConfigSectionNode
<ExtensionAttribute>
Public Shared Function AsLaconicConfig (
    val As Object,
    Optional dflt As ConfigSectionNode = Nothing,
    Optional wrapRootName As String = "nfx",
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As ConfigSectionNode
public:
[ExtensionAttribute]
static ConfigSectionNode^ AsLaconicConfig(
    Object^ val,
    ConfigSectionNode^ dflt = nullptr,
    String^ wrapRootName = L"nfx",
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static ConfigSectionNode^ AsLaconicConfig(
    Object^ val,
    ConfigSectionNode^ dflt = nullptr,
    String^ wrapRootName = L"nfx",
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsLaconicConfig :
        val : Object *
        ?dflt : ConfigSectionNode *
        ?wrapRootName : string *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _wrapRootName = defaultArg wrapRootName "nfx"
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> ConfigSectionNode
static member AsLaconicConfig :
        val : Object *
        ?dflt : ConfigSectionNode *
        ?wrapRootName : string *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _wrapRootName = defaultArg wrapRootName "nfx"
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> ConfigSectionNode

Parameters

val
Type: Online System Object
dflt (Optional)
Type: NFX.Environment ConfigSectionNode
wrapRootName (Optional)
Type: Online System String
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: ConfigSectionNode

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsLong Method

ObjectValueConversion AsLong Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long AsLong(
    this Object val,
    long dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static long AsLong(
    this Object val,
    long dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsLong (
    val As Object,
    Optional dflt As Long = 0,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Long
<ExtensionAttribute>
Public Shared Function AsLong (
    val As Object,
    Optional dflt As Long = 0,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Long
public:
[ExtensionAttribute]
static long long AsLong(
    Object^ val,
    long long dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static long long AsLong(
    Object^ val,
    long long dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsLong :
        val : Object *
        ?dflt : int64 *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> int64
static member AsLong :
        val : Object *
        ?dflt : int64 *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> int64

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Int64
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Int64

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsNonNullOrEmptyString Method

ObjectValueConversion AsNonNullOrEmptyString Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string AsNonNullOrEmptyString(
    this Object val
)
public static string AsNonNullOrEmptyString(
    this Object val
)
<ExtensionAttribute>
Public Shared Function AsNonNullOrEmptyString (
    val As Object
) As String
<ExtensionAttribute>
Public Shared Function AsNonNullOrEmptyString (
    val As Object
) As String
public:
[ExtensionAttribute]
static String^ AsNonNullOrEmptyString(
    Object^ val
)
public:
[ExtensionAttribute]
static String^ AsNonNullOrEmptyString(
    Object^ val
)
static member AsNonNullOrEmptyString :
        val : Object -> string
static member AsNonNullOrEmptyString :
        val : Object -> string

Parameters

val
Type: Online System Object

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsNullableBool Method

ObjectValueConversion AsNullableBool Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
Name | Description
AsNullableBool(ObjectValueConversion TriStateBool) |
AsNullableBool(Object, Nullable Boolean , ConvertErrorHandling) |
Back to Top
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsNullableBool Method (ObjectValueConversion.TriStateBool)

ObjectValueConversion AsNullableBool Method (ObjectValueConversion TriStateBool) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<bool> AsNullableBool(
    this ObjectValueConversion..::..TriStateBool val
)
public static Nullable<bool> AsNullableBool(
    this ObjectValueConversion..::..TriStateBool val
)
<ExtensionAttribute>
Public Shared Function AsNullableBool (
    val As ObjectValueConversion..::..TriStateBool
) As Nullable(Of Boolean)
<ExtensionAttribute>
Public Shared Function AsNullableBool (
    val As ObjectValueConversion..::..TriStateBool
) As Nullable(Of Boolean)
public:
[ExtensionAttribute]
static Nullable<bool> AsNullableBool(
    ObjectValueConversion..::..TriStateBool val
)
public:
[ExtensionAttribute]
static Nullable<bool> AsNullableBool(
    ObjectValueConversion..::..TriStateBool val
)
static member AsNullableBool :
        val : ObjectValueConversion..::..TriStateBool -> Nullable<bool>
static member AsNullableBool :
        val : ObjectValueConversion..::..TriStateBool -> Nullable<bool>

Parameters

val
Type: NFX ObjectValueConversion TriStateBool

Return Value

Type: Online Nullable Online Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ObjectValueConversion TriStateBool. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
AsNullableBool Overload
NFX Namespace


ObjectValueConversion.AsNullableBool Method (Object, Nullable(Boolean), ConvertErrorHandling)

ObjectValueConversion AsNullableBool Method (Object, Nullable Boolean , ConvertErrorHandling) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<bool> AsNullableBool(
    this Object val,
    Nullable<bool> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static Nullable<bool> AsNullableBool(
    this Object val,
    Nullable<bool> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsNullableBool (
    val As Object,
    Optional dflt As Nullable(Of Boolean) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of Boolean)
<ExtensionAttribute>
Public Shared Function AsNullableBool (
    val As Object,
    Optional dflt As Nullable(Of Boolean) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of Boolean)
public:
[ExtensionAttribute]
static Nullable<bool> AsNullableBool(
    Object^ val,
    Nullable<bool> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static Nullable<bool> AsNullableBool(
    Object^ val,
    Nullable<bool> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsNullableBool :
        val : Object *
        ?dflt : Nullable<bool> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<bool>
static member AsNullableBool :
        val : Object *
        ?dflt : Nullable<bool> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<bool>

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Nullable Online Boolean
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Nullable Online Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
AsNullableBool Overload
NFX Namespace


ObjectValueConversion.AsNullableByte Method

ObjectValueConversion AsNullableByte Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<byte> AsNullableByte(
    this Object val,
    Nullable<byte> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static Nullable<byte> AsNullableByte(
    this Object val,
    Nullable<byte> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsNullableByte (
    val As Object,
    Optional dflt As Nullable(Of Byte) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of Byte)
<ExtensionAttribute>
Public Shared Function AsNullableByte (
    val As Object,
    Optional dflt As Nullable(Of Byte) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of Byte)
public:
[ExtensionAttribute]
static Nullable<unsigned char> AsNullableByte(
    Object^ val,
    Nullable<unsigned char> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static Nullable<unsigned char> AsNullableByte(
    Object^ val,
    Nullable<unsigned char> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsNullableByte :
        val : Object *
        ?dflt : Nullable<byte> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<byte>
static member AsNullableByte :
        val : Object *
        ?dflt : Nullable<byte> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<byte>

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Nullable Online Byte
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Nullable Online Byte

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsNullableChar Method

ObjectValueConversion AsNullableChar Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<char> AsNullableChar(
    this Object val,
    Nullable<char> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static Nullable<char> AsNullableChar(
    this Object val,
    Nullable<char> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsNullableChar (
    val As Object,
    Optional dflt As Nullable(Of Char) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of Char)
<ExtensionAttribute>
Public Shared Function AsNullableChar (
    val As Object,
    Optional dflt As Nullable(Of Char) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of Char)
public:
[ExtensionAttribute]
static Nullable<wchar_t> AsNullableChar(
    Object^ val,
    Nullable<wchar_t> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static Nullable<wchar_t> AsNullableChar(
    Object^ val,
    Nullable<wchar_t> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsNullableChar :
        val : Object *
        ?dflt : Nullable<char> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<char>
static member AsNullableChar :
        val : Object *
        ?dflt : Nullable<char> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<char>

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Nullable Online Char
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Nullable Online Char

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsNullableDateTime Method

ObjectValueConversion AsNullableDateTime Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<DateTime> AsNullableDateTime(
    this Object val,
    Nullable<DateTime> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static Nullable<DateTime> AsNullableDateTime(
    this Object val,
    Nullable<DateTime> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsNullableDateTime (
    val As Object,
    Optional dflt As Nullable(Of DateTime) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of DateTime)
<ExtensionAttribute>
Public Shared Function AsNullableDateTime (
    val As Object,
    Optional dflt As Nullable(Of DateTime) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of DateTime)
public:
[ExtensionAttribute]
static Nullable<DateTime> AsNullableDateTime(
    Object^ val,
    Nullable<DateTime> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static Nullable<DateTime> AsNullableDateTime(
    Object^ val,
    Nullable<DateTime> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsNullableDateTime :
        val : Object *
        ?dflt : Nullable<DateTime> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<DateTime>
static member AsNullableDateTime :
        val : Object *
        ?dflt : Nullable<DateTime> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<DateTime>

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Nullable Online DateTime
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Nullable Online DateTime

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsNullableDecimal Method

ObjectValueConversion AsNullableDecimal Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<decimal> AsNullableDecimal(
    this Object val,
    Nullable<decimal> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static Nullable<decimal> AsNullableDecimal(
    this Object val,
    Nullable<decimal> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsNullableDecimal (
    val As Object,
    Optional dflt As Nullable(Of Decimal) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of Decimal)
<ExtensionAttribute>
Public Shared Function AsNullableDecimal (
    val As Object,
    Optional dflt As Nullable(Of Decimal) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of Decimal)
public:
[ExtensionAttribute]
static Nullable<Decimal> AsNullableDecimal(
    Object^ val,
    Nullable<Decimal> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static Nullable<Decimal> AsNullableDecimal(
    Object^ val,
    Nullable<Decimal> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsNullableDecimal :
        val : Object *
        ?dflt : Nullable<decimal> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<decimal>
static member AsNullableDecimal :
        val : Object *
        ?dflt : Nullable<decimal> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<decimal>

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Nullable Online Decimal
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Nullable Online Decimal

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsNullableDouble Method

ObjectValueConversion AsNullableDouble Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<double> AsNullableDouble(
    this Object val,
    Nullable<double> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static Nullable<double> AsNullableDouble(
    this Object val,
    Nullable<double> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsNullableDouble (
    val As Object,
    Optional dflt As Nullable(Of Double) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of Double)
<ExtensionAttribute>
Public Shared Function AsNullableDouble (
    val As Object,
    Optional dflt As Nullable(Of Double) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of Double)
public:
[ExtensionAttribute]
static Nullable<double> AsNullableDouble(
    Object^ val,
    Nullable<double> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static Nullable<double> AsNullableDouble(
    Object^ val,
    Nullable<double> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsNullableDouble :
        val : Object *
        ?dflt : Nullable<float> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<float>
static member AsNullableDouble :
        val : Object *
        ?dflt : Nullable<float> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<float>

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Nullable Online Double
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Nullable Online Double

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsNullableEnum(TEnum) Method

ObjectValueConversion AsNullableEnum TEnum Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<TEnum> AsNullableEnum<TEnum>(
    this Object val,
    Nullable<TEnum> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
where TEnum : struct, new()
public static Nullable<TEnum> AsNullableEnum<TEnum>(
    this Object val,
    Nullable<TEnum> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
where TEnum : struct, new()
<ExtensionAttribute>
Public Shared Function AsNullableEnum(Of TEnum As {Structure, New}) (
    val As Object,
    Optional dflt As Nullable(Of TEnum) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of TEnum)
<ExtensionAttribute>
Public Shared Function AsNullableEnum(Of TEnum As {Structure, New}) (
    val As Object,
    Optional dflt As Nullable(Of TEnum) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of TEnum)
public:
[ExtensionAttribute]
generic<typename TEnum>
where TEnum : value class, gcnew()
static Nullable<TEnum> AsNullableEnum(
    Object^ val,
    Nullable<TEnum> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
generic<typename TEnum>
where TEnum : value class, gcnew()
static Nullable<TEnum> AsNullableEnum(
    Object^ val,
    Nullable<TEnum> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsNullableEnum :
        val : Object *
        ?dflt : Nullable<'TEnum> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<'TEnum>  when 'TEnum : struct, new()
static member AsNullableEnum :
        val : Object *
        ?dflt : Nullable<'TEnum> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<'TEnum>  when 'TEnum : struct, new()

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Nullable TEnum
handling (Optional)
Type: NFX ConvertErrorHandling
Type Parameters
TEnum

Return Value

Type: Online Nullable TEnum

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsNullableFloat Method

ObjectValueConversion AsNullableFloat Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<float> AsNullableFloat(
    this Object val,
    Nullable<float> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static Nullable<float> AsNullableFloat(
    this Object val,
    Nullable<float> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsNullableFloat (
    val As Object,
    Optional dflt As Nullable(Of Single) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of Single)
<ExtensionAttribute>
Public Shared Function AsNullableFloat (
    val As Object,
    Optional dflt As Nullable(Of Single) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of Single)
public:
[ExtensionAttribute]
static Nullable<float> AsNullableFloat(
    Object^ val,
    Nullable<float> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static Nullable<float> AsNullableFloat(
    Object^ val,
    Nullable<float> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsNullableFloat :
        val : Object *
        ?dflt : Nullable<float32> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<float32>
static member AsNullableFloat :
        val : Object *
        ?dflt : Nullable<float32> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<float32>

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Nullable Online Single
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Nullable Online Single

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsNullableGDID Method

ObjectValueConversion AsNullableGDID Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<GDID> AsNullableGDID(
    this Object val,
    Nullable<GDID> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static Nullable<GDID> AsNullableGDID(
    this Object val,
    Nullable<GDID> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsNullableGDID (
    val As Object,
    Optional dflt As Nullable(Of GDID) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of GDID)
<ExtensionAttribute>
Public Shared Function AsNullableGDID (
    val As Object,
    Optional dflt As Nullable(Of GDID) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of GDID)
public:
[ExtensionAttribute]
static Nullable<GDID> AsNullableGDID(
    Object^ val,
    Nullable<GDID> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static Nullable<GDID> AsNullableGDID(
    Object^ val,
    Nullable<GDID> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsNullableGDID :
        val : Object *
        ?dflt : Nullable<GDID> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<GDID>
static member AsNullableGDID :
        val : Object *
        ?dflt : Nullable<GDID> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<GDID>

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Nullable GDID
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Nullable GDID

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsNullableGDIDSymbol Method

ObjectValueConversion AsNullableGDIDSymbol Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<GDIDSymbol> AsNullableGDIDSymbol(
    this Object val,
    Nullable<GDIDSymbol> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static Nullable<GDIDSymbol> AsNullableGDIDSymbol(
    this Object val,
    Nullable<GDIDSymbol> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsNullableGDIDSymbol (
    val As Object,
    Optional dflt As Nullable(Of GDIDSymbol) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of GDIDSymbol)
<ExtensionAttribute>
Public Shared Function AsNullableGDIDSymbol (
    val As Object,
    Optional dflt As Nullable(Of GDIDSymbol) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of GDIDSymbol)
public:
[ExtensionAttribute]
static Nullable<GDIDSymbol> AsNullableGDIDSymbol(
    Object^ val,
    Nullable<GDIDSymbol> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static Nullable<GDIDSymbol> AsNullableGDIDSymbol(
    Object^ val,
    Nullable<GDIDSymbol> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsNullableGDIDSymbol :
        val : Object *
        ?dflt : Nullable<GDIDSymbol> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<GDIDSymbol>
static member AsNullableGDIDSymbol :
        val : Object *
        ?dflt : Nullable<GDIDSymbol> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<GDIDSymbol>

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Nullable GDIDSymbol
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Nullable GDIDSymbol

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsNullableGUID Method

ObjectValueConversion AsNullableGUID Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<Guid> AsNullableGUID(
    this Object val,
    Nullable<Guid> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static Nullable<Guid> AsNullableGUID(
    this Object val,
    Nullable<Guid> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsNullableGUID (
    val As Object,
    Optional dflt As Nullable(Of Guid) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of Guid)
<ExtensionAttribute>
Public Shared Function AsNullableGUID (
    val As Object,
    Optional dflt As Nullable(Of Guid) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of Guid)
public:
[ExtensionAttribute]
static Nullable<Guid> AsNullableGUID(
    Object^ val,
    Nullable<Guid> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static Nullable<Guid> AsNullableGUID(
    Object^ val,
    Nullable<Guid> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsNullableGUID :
        val : Object *
        ?dflt : Nullable<Guid> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<Guid>
static member AsNullableGUID :
        val : Object *
        ?dflt : Nullable<Guid> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<Guid>

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Nullable Online Guid
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Nullable Online Guid

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsNullableInt Method

ObjectValueConversion AsNullableInt Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<int> AsNullableInt(
    this Object val,
    Nullable<int> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static Nullable<int> AsNullableInt(
    this Object val,
    Nullable<int> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsNullableInt (
    val As Object,
    Optional dflt As Nullable(Of Integer) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of Integer)
<ExtensionAttribute>
Public Shared Function AsNullableInt (
    val As Object,
    Optional dflt As Nullable(Of Integer) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of Integer)
public:
[ExtensionAttribute]
static Nullable<int> AsNullableInt(
    Object^ val,
    Nullable<int> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static Nullable<int> AsNullableInt(
    Object^ val,
    Nullable<int> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsNullableInt :
        val : Object *
        ?dflt : Nullable<int> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<int>
static member AsNullableInt :
        val : Object *
        ?dflt : Nullable<int> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<int>

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Nullable Online Int32
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Nullable Online Int32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsNullableLong Method

ObjectValueConversion AsNullableLong Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<long> AsNullableLong(
    this Object val,
    Nullable<long> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static Nullable<long> AsNullableLong(
    this Object val,
    Nullable<long> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsNullableLong (
    val As Object,
    Optional dflt As Nullable(Of Long) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of Long)
<ExtensionAttribute>
Public Shared Function AsNullableLong (
    val As Object,
    Optional dflt As Nullable(Of Long) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of Long)
public:
[ExtensionAttribute]
static Nullable<long long> AsNullableLong(
    Object^ val,
    Nullable<long long> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static Nullable<long long> AsNullableLong(
    Object^ val,
    Nullable<long long> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsNullableLong :
        val : Object *
        ?dflt : Nullable<int64> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<int64>
static member AsNullableLong :
        val : Object *
        ?dflt : Nullable<int64> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<int64>

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Nullable Online Int64
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Nullable Online Int64

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsNullableSByte Method

ObjectValueConversion AsNullableSByte Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<sbyte> AsNullableSByte(
    this Object val,
    Nullable<sbyte> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static Nullable<sbyte> AsNullableSByte(
    this Object val,
    Nullable<sbyte> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsNullableSByte (
    val As Object,
    Optional dflt As Nullable(Of SByte) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of SByte)
<ExtensionAttribute>
Public Shared Function AsNullableSByte (
    val As Object,
    Optional dflt As Nullable(Of SByte) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of SByte)
public:
[ExtensionAttribute]
static Nullable<signed char> AsNullableSByte(
    Object^ val,
    Nullable<signed char> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static Nullable<signed char> AsNullableSByte(
    Object^ val,
    Nullable<signed char> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsNullableSByte :
        val : Object *
        ?dflt : Nullable<sbyte> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<sbyte>
static member AsNullableSByte :
        val : Object *
        ?dflt : Nullable<sbyte> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<sbyte>

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Nullable Online SByte
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Nullable Online SByte

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsNullableShort Method

ObjectValueConversion AsNullableShort Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<short> AsNullableShort(
    this Object val,
    Nullable<short> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static Nullable<short> AsNullableShort(
    this Object val,
    Nullable<short> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsNullableShort (
    val As Object,
    Optional dflt As Nullable(Of Short) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of Short)
<ExtensionAttribute>
Public Shared Function AsNullableShort (
    val As Object,
    Optional dflt As Nullable(Of Short) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of Short)
public:
[ExtensionAttribute]
static Nullable<short> AsNullableShort(
    Object^ val,
    Nullable<short> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static Nullable<short> AsNullableShort(
    Object^ val,
    Nullable<short> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsNullableShort :
        val : Object *
        ?dflt : Nullable<int16> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<int16>
static member AsNullableShort :
        val : Object *
        ?dflt : Nullable<int16> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<int16>

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Nullable Online Int16
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Nullable Online Int16

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsNullableTimeSpan Method

ObjectValueConversion AsNullableTimeSpan Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<TimeSpan> AsNullableTimeSpan(
    this Object val,
    Nullable<TimeSpan> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static Nullable<TimeSpan> AsNullableTimeSpan(
    this Object val,
    Nullable<TimeSpan> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsNullableTimeSpan (
    val As Object,
    Optional dflt As Nullable(Of TimeSpan) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of TimeSpan)
<ExtensionAttribute>
Public Shared Function AsNullableTimeSpan (
    val As Object,
    Optional dflt As Nullable(Of TimeSpan) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of TimeSpan)
public:
[ExtensionAttribute]
static Nullable<TimeSpan> AsNullableTimeSpan(
    Object^ val,
    Nullable<TimeSpan> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static Nullable<TimeSpan> AsNullableTimeSpan(
    Object^ val,
    Nullable<TimeSpan> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsNullableTimeSpan :
        val : Object *
        ?dflt : Nullable<TimeSpan> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<TimeSpan>
static member AsNullableTimeSpan :
        val : Object *
        ?dflt : Nullable<TimeSpan> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<TimeSpan>

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Nullable Online TimeSpan
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Nullable Online TimeSpan

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsNullableUInt Method

ObjectValueConversion AsNullableUInt Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<uint> AsNullableUInt(
    this Object val,
    Nullable<uint> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static Nullable<uint> AsNullableUInt(
    this Object val,
    Nullable<uint> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsNullableUInt (
    val As Object,
    Optional dflt As Nullable(Of UInteger) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of UInteger)
<ExtensionAttribute>
Public Shared Function AsNullableUInt (
    val As Object,
    Optional dflt As Nullable(Of UInteger) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of UInteger)
public:
[ExtensionAttribute]
static Nullable<unsigned int> AsNullableUInt(
    Object^ val,
    Nullable<unsigned int> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static Nullable<unsigned int> AsNullableUInt(
    Object^ val,
    Nullable<unsigned int> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsNullableUInt :
        val : Object *
        ?dflt : Nullable<uint32> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<uint32>
static member AsNullableUInt :
        val : Object *
        ?dflt : Nullable<uint32> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<uint32>

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Nullable Online UInt32
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Nullable Online UInt32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsNullableULong Method

ObjectValueConversion AsNullableULong Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<ulong> AsNullableULong(
    this Object val,
    Nullable<ulong> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static Nullable<ulong> AsNullableULong(
    this Object val,
    Nullable<ulong> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsNullableULong (
    val As Object,
    Optional dflt As Nullable(Of ULong) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of ULong)
<ExtensionAttribute>
Public Shared Function AsNullableULong (
    val As Object,
    Optional dflt As Nullable(Of ULong) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of ULong)
public:
[ExtensionAttribute]
static Nullable<unsigned long long> AsNullableULong(
    Object^ val,
    Nullable<unsigned long long> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static Nullable<unsigned long long> AsNullableULong(
    Object^ val,
    Nullable<unsigned long long> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsNullableULong :
        val : Object *
        ?dflt : Nullable<uint64> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<uint64>
static member AsNullableULong :
        val : Object *
        ?dflt : Nullable<uint64> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<uint64>

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Nullable Online UInt64
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Nullable Online UInt64

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsNullableUShort Method

ObjectValueConversion AsNullableUShort Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<ushort> AsNullableUShort(
    this Object val,
    Nullable<ushort> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static Nullable<ushort> AsNullableUShort(
    this Object val,
    Nullable<ushort> dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsNullableUShort (
    val As Object,
    Optional dflt As Nullable(Of UShort) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of UShort)
<ExtensionAttribute>
Public Shared Function AsNullableUShort (
    val As Object,
    Optional dflt As Nullable(Of UShort) = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Nullable(Of UShort)
public:
[ExtensionAttribute]
static Nullable<unsigned short> AsNullableUShort(
    Object^ val,
    Nullable<unsigned short> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static Nullable<unsigned short> AsNullableUShort(
    Object^ val,
    Nullable<unsigned short> dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsNullableUShort :
        val : Object *
        ?dflt : Nullable<uint16> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<uint16>
static member AsNullableUShort :
        val : Object *
        ?dflt : Nullable<uint16> *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Nullable<uint16>

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Nullable Online UInt16
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Nullable Online UInt16

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsSByte Method

ObjectValueConversion AsSByte Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static sbyte AsSByte(
    this Object val,
    sbyte dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static sbyte AsSByte(
    this Object val,
    sbyte dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsSByte (
    val As Object,
    Optional dflt As SByte = 0,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As SByte
<ExtensionAttribute>
Public Shared Function AsSByte (
    val As Object,
    Optional dflt As SByte = 0,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As SByte
public:
[ExtensionAttribute]
static signed char AsSByte(
    Object^ val,
    signed char dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static signed char AsSByte(
    Object^ val,
    signed char dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsSByte :
        val : Object *
        ?dflt : sbyte *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> sbyte
static member AsSByte :
        val : Object *
        ?dflt : sbyte *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> sbyte

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System SByte
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online SByte

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsShort Method

ObjectValueConversion AsShort Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static short AsShort(
    this Object val,
    short dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static short AsShort(
    this Object val,
    short dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsShort (
    val As Object,
    Optional dflt As Short = 0,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Short
<ExtensionAttribute>
Public Shared Function AsShort (
    val As Object,
    Optional dflt As Short = 0,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Short
public:
[ExtensionAttribute]
static short AsShort(
    Object^ val,
    short dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static short AsShort(
    Object^ val,
    short dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsShort :
        val : Object *
        ?dflt : int16 *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> int16
static member AsShort :
        val : Object *
        ?dflt : int16 *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> int16

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Int16
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Int16

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsString Method

ObjectValueConversion AsString Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string AsString(
    this Object val,
    string dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static string AsString(
    this Object val,
    string dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsString (
    val As Object,
    Optional dflt As String = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As String
<ExtensionAttribute>
Public Shared Function AsString (
    val As Object,
    Optional dflt As String = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As String
public:
[ExtensionAttribute]
static String^ AsString(
    Object^ val,
    String^ dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static String^ AsString(
    Object^ val,
    String^ dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsString :
        val : Object *
        ?dflt : string *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> string
static member AsString :
        val : Object *
        ?dflt : string *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> string

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System String
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsTimeSpan Method

ObjectValueConversion AsTimeSpan Method NFX Class Library

Overload List
Name | Description
AsTimeSpan(Object) |
AsTimeSpan(Object, TimeSpan, ConvertErrorHandling) |
Back to Top
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsTimeSpan Method (Object)

ObjectValueConversion AsTimeSpan Method (Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TimeSpan AsTimeSpan(
    this Object val
)
public static TimeSpan AsTimeSpan(
    this Object val
)
<ExtensionAttribute>
Public Shared Function AsTimeSpan (
    val As Object
) As TimeSpan
<ExtensionAttribute>
Public Shared Function AsTimeSpan (
    val As Object
) As TimeSpan
public:
[ExtensionAttribute]
static TimeSpan AsTimeSpan(
    Object^ val
)
public:
[ExtensionAttribute]
static TimeSpan AsTimeSpan(
    Object^ val
)
static member AsTimeSpan :
        val : Object -> TimeSpan
static member AsTimeSpan :
        val : Object -> TimeSpan

Parameters

val
Type: Online System Object

Return Value

Type: Online TimeSpan

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
AsTimeSpan Overload
NFX Namespace


ObjectValueConversion.AsTimeSpan Method (Object, TimeSpan, ConvertErrorHandling)

ObjectValueConversion AsTimeSpan Method (Object, TimeSpan, ConvertErrorHandling) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TimeSpan AsTimeSpan(
    this Object val,
    TimeSpan dflt,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static TimeSpan AsTimeSpan(
    this Object val,
    TimeSpan dflt,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsTimeSpan (
    val As Object,
    dflt As TimeSpan,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As TimeSpan
<ExtensionAttribute>
Public Shared Function AsTimeSpan (
    val As Object,
    dflt As TimeSpan,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As TimeSpan
public:
[ExtensionAttribute]
static TimeSpan AsTimeSpan(
    Object^ val,
    TimeSpan dflt,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static TimeSpan AsTimeSpan(
    Object^ val,
    TimeSpan dflt,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsTimeSpan :
        val : Object *
        dflt : TimeSpan *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> TimeSpan
static member AsTimeSpan :
        val : Object *
        dflt : TimeSpan *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> TimeSpan

Parameters

val
Type: Online System Object
dflt
Type: Online System TimeSpan
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online TimeSpan

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
AsTimeSpan Overload
NFX Namespace


ObjectValueConversion.AsUInt Method

ObjectValueConversion AsUInt Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static uint AsUInt(
    this Object val,
    uint dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static uint AsUInt(
    this Object val,
    uint dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsUInt (
    val As Object,
    Optional dflt As UInteger = 0,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As UInteger
<ExtensionAttribute>
Public Shared Function AsUInt (
    val As Object,
    Optional dflt As UInteger = 0,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As UInteger
public:
[ExtensionAttribute]
static unsigned int AsUInt(
    Object^ val,
    unsigned int dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static unsigned int AsUInt(
    Object^ val,
    unsigned int dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsUInt :
        val : Object *
        ?dflt : uint32 *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> uint32
static member AsUInt :
        val : Object *
        ?dflt : uint32 *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> uint32

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System UInt32
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online UInt32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsULong Method

ObjectValueConversion AsULong Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ulong AsULong(
    this Object val,
    ulong dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static ulong AsULong(
    this Object val,
    ulong dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsULong (
    val As Object,
    Optional dflt As ULong = 0,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As ULong
<ExtensionAttribute>
Public Shared Function AsULong (
    val As Object,
    Optional dflt As ULong = 0,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As ULong
public:
[ExtensionAttribute]
static unsigned long long AsULong(
    Object^ val,
    unsigned long long dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static unsigned long long AsULong(
    Object^ val,
    unsigned long long dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsULong :
        val : Object *
        ?dflt : uint64 *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> uint64
static member AsULong :
        val : Object *
        ?dflt : uint64 *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> uint64

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System UInt64
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online UInt64

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsUri Method

ObjectValueConversion AsUri Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Uri AsUri(
    this Object val,
    Uri dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static Uri AsUri(
    this Object val,
    Uri dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsUri (
    val As Object,
    Optional dflt As Uri = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Uri
<ExtensionAttribute>
Public Shared Function AsUri (
    val As Object,
    Optional dflt As Uri = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As Uri
public:
[ExtensionAttribute]
static Uri^ AsUri(
    Object^ val,
    Uri^ dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static Uri^ AsUri(
    Object^ val,
    Uri^ dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsUri :
        val : Object *
        ?dflt : Uri *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Uri
static member AsUri :
        val : Object *
        ?dflt : Uri *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> Uri

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System Uri
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online Uri

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsUShort Method

ObjectValueConversion AsUShort Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ushort AsUShort(
    this Object val,
    ushort dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static ushort AsUShort(
    this Object val,
    ushort dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsUShort (
    val As Object,
    Optional dflt As UShort = 0,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As UShort
<ExtensionAttribute>
Public Shared Function AsUShort (
    val As Object,
    Optional dflt As UShort = 0,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As UShort
public:
[ExtensionAttribute]
static unsigned short AsUShort(
    Object^ val,
    unsigned short dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static unsigned short AsUShort(
    Object^ val,
    unsigned short dflt = 0,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsUShort :
        val : Object *
        ?dflt : uint16 *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> uint16
static member AsUShort :
        val : Object *
        ?dflt : uint16 *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> uint16

Parameters

val
Type: Online System Object
dflt (Optional)
Type: Online System UInt16
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: Online UInt16

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.AsXMLConfig Method

ObjectValueConversion AsXMLConfig Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ConfigSectionNode AsXMLConfig(
    this Object val,
    ConfigSectionNode dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
public static ConfigSectionNode AsXMLConfig(
    this Object val,
    ConfigSectionNode dflt = null,
    ConvertErrorHandling handling = ConvertErrorHandling.ReturnDefault
)
<ExtensionAttribute>
Public Shared Function AsXMLConfig (
    val As Object,
    Optional dflt As ConfigSectionNode = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As ConfigSectionNode
<ExtensionAttribute>
Public Shared Function AsXMLConfig (
    val As Object,
    Optional dflt As ConfigSectionNode = Nothing,
    Optional handling As ConvertErrorHandling = ConvertErrorHandling.ReturnDefault
) As ConfigSectionNode
public:
[ExtensionAttribute]
static ConfigSectionNode^ AsXMLConfig(
    Object^ val,
    ConfigSectionNode^ dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
public:
[ExtensionAttribute]
static ConfigSectionNode^ AsXMLConfig(
    Object^ val,
    ConfigSectionNode^ dflt = nullptr,
    ConvertErrorHandling handling = ConvertErrorHandling::ReturnDefault
)
static member AsXMLConfig :
        val : Object *
        ?dflt : ConfigSectionNode *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> ConfigSectionNode
static member AsXMLConfig :
        val : Object *
        ?dflt : ConfigSectionNode *
        ?handling : ConvertErrorHandling
(* Defaults:
        let _dflt = defaultArg dflt null
        let _handling = defaultArg handling ConvertErrorHandling.ReturnDefault
*)
-> ConfigSectionNode

Parameters

val
Type: Online System Object
dflt (Optional)
Type: NFX.Environment ConfigSectionNode
handling (Optional)
Type: NFX ConvertErrorHandling

Return Value

Type: ConfigSectionNode

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ObjectValueConversion Class
ObjectValueConversion Members
NFX Namespace


ObjectValueConversion.TriStateBool Enumeration

ObjectValueConversion TriStateBool Enumeration NFX Class Library

[This is preliminary documentation and is subject to change.]

A "hack" enum used to provide tri-state checkbox functionality in some systems, i.e. HTML checkmarks do not understand "nulls". This is a surrogate type not used in server-side programming

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum TriStateBool
public enum TriStateBool
Public Enumeration TriStateBool
Public Enumeration TriStateBool
public enum class TriStateBool
public enum class TriStateBool
type TriStateBool
type TriStateBool
Members
Member name | Value | Description
Unspecified | 0 |
False | 1 |
True | 2 |
See Also
NFX Namespace


OrderedRegistry(T) Class

OrderedRegistry T Class NFX Class Library

Represents a thread-safe registry of T which is ordered by Order property. This class is efficient for concurrent read access and is not designed for cases when frequent modifications happen. It is ideal for lookup of named instances that have much longer time span than components that look them up. Note: since registry does reading in a lock-free manner, it is possible to have an inconsistent read snapshot of ordered items which may capture items that have already/not yet been added to the registry
Inheritance Hierarchy
Online System Object
NFX Registry T
NFX OrderedRegistry T
NFX.Wave.Handlers TypeLocations

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class OrderedRegistry<T> : Registry<T>,
    IOrderedRegistry<T>, IRegistry<T>, IEnumerable<T>, IEnumerable
where T : INamed, IOrdered
[SerializableAttribute]
public class OrderedRegistry<T> : Registry<T>,
    IOrderedRegistry<T>, IRegistry<T>, IEnumerable<T>, IEnumerable
where T : INamed, IOrdered
<SerializableAttribute>
Public Class OrderedRegistry(Of T As {INamed, IOrdered})
    Inherits Registry(Of T)
    Implements IOrderedRegistry(Of T), IRegistry(Of T),
    IEnumerable(Of T), IEnumerable
<SerializableAttribute>
Public Class OrderedRegistry(Of T As {INamed, IOrdered})
    Inherits Registry(Of T)
    Implements IOrderedRegistry(Of T), IRegistry(Of T),
    IEnumerable(Of T), IEnumerable
[SerializableAttribute]
generic<typename T>
where T : INamed, IOrdered
public ref class OrderedRegistry : public Registry<T>,
    IOrderedRegistry<T>, IRegistry<T>, IEnumerable<T>, IEnumerable
[SerializableAttribute]
generic<typename T>
where T : INamed, IOrdered
public ref class OrderedRegistry : public Registry<T>,
    IOrderedRegistry<T>, IRegistry<T>, IEnumerable<T>, IEnumerable
[<SerializableAttribute>]
type OrderedRegistry<'T when 'T : INamed and IOrdered> =
    class
        inherit Registry<'T>
        interface IOrderedRegistry<'T>
        interface IRegistry<'T>
        interface IEnumerable<'T>
        interface IEnumerable
    end
[<SerializableAttribute>]
type OrderedRegistry<'T when 'T : INamed and IOrdered> =
    class
        inherit Registry<'T>
        interface IOrderedRegistry<'T>
        interface IRegistry<'T>
        interface IEnumerable<'T>
        interface IEnumerable
    end
Type Parameters
T
See Also
OrderedRegistry T Members
NFX Namespace


OrderedRegistry(T) Members

OrderedRegistry T Members NFX Class Library

The OrderedRegistry T type exposes the following members.
Constructors
 | Name | Description
Public method | OrderedRegistry T | Initializes a new instance of the OrderedRegistry T class
Public method | OrderedRegistry T (Boolean) | Initializes a new instance of the OrderedRegistry T class
Back to Top
Methods
 | Name | Description
Public method | Clear | Deletes all items from ordered registry (Overrides Registry T Clear .)
Public method | ContainsName | (Inherited from Registry T .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | (Inherited from Registry T .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetOrRegister TContext (String, Func TContext, T , TContext) | Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency (Inherited from Registry T .)
Public method | GetOrRegister TContext (String, Func TContext, T , TContext, Boolean ) | Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency (Inherited from Registry T .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | JustRegistered | (Overrides Registry T JustRegistered(T).)
Protected method | JustReplaced | (Overrides Registry T JustReplaced(T, T).)
Protected method | JustUnregistered | (Overrides Registry T JustUnregistered(T).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Register | Registers item and returns true if it was registered, false if this named instance already existed in the list (Inherited from Registry T .)
Public method | RegisterOrReplace(T) | Registers item and returns true if it was registered, false if this named instance already existed and was replaced (Inherited from Registry T .)
Public method | RegisterOrReplace(T, T ) | Registers item and returns true if it was registered, false if this named instance already existed and was replaced (Inherited from Registry T .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryGetValue | (Inherited from Registry T .)
Public method | Unregister(String) | Unregisters item by name and returns true if it was unregistered, false if it did not exist (Inherited from Registry T .)
Public method | Unregister(T) | Unregisters item and returns true if it was unregistered, false if it did not exist (Inherited from Registry T .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable T | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct T, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault T | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast T | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast T (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Sync | (Inherited from Registry T .)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns the number of entries in the registry (Inherited from Registry T .)
Public property | IsCaseSensitive | Returns true if the instance differentiates names by case (Inherited from Registry T .)
Public property | Item Int32 | Tries to return an item by its position index in ordered set of items that this registry keeps. Null is returned when index is out of bounds. Note: since registry does reading in a lock-free manner, it is possible to have an inconsistent read snapshot of ordered items which may capture items that have already/not yet been added to the registry
Public property | Item String | Returns a value by name or null if not found (Inherited from Registry T .)
Public property | Names | (Inherited from Registry T .)
Public property | OrderedValues | Returns items that registry contains ordered by their Order property. The returned sequence is pre-sorted during alteration of registry, so this property access is efficient. Note: since registry does reading in a lock-free manner, it is possible to have an inconsistent read snapshot of ordered items which may capture items that have already/not yet been added to the registry
Public property | Values | (Inherited from Registry T .)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Registry T .)
Back to Top
See Also
OrderedRegistry T Class
NFX Namespace


OrderedRegistry(T) Constructor

OrderedRegistry T Constructor NFX Class Library

Overload List
 | Name | Description
Public method | OrderedRegistry T | Initializes a new instance of the OrderedRegistry T class
Public method | OrderedRegistry T (Boolean) | Initializes a new instance of the OrderedRegistry T class
Back to Top
See Also
OrderedRegistry T Class
OrderedRegistry T Members
NFX Namespace


OrderedRegistry(T) Constructor

OrderedRegistry T Constructor NFX Class Library

Initializes a new instance of the OrderedRegistry T class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderedRegistry()
public OrderedRegistry()
Public Sub New
Public Sub New
public:
OrderedRegistry()
public:
OrderedRegistry()
new : unit -> OrderedRegistry
new : unit -> OrderedRegistry
See Also
OrderedRegistry T Class
OrderedRegistry T Members
OrderedRegistry T Overload
NFX Namespace


OrderedRegistry(T) Constructor (Boolean)

OrderedRegistry T Constructor (Boolean) NFX Class Library

Initializes a new instance of the OrderedRegistry T class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderedRegistry(
    bool caseSensitive
)
public OrderedRegistry(
    bool caseSensitive
)
Public Sub New (
    caseSensitive As Boolean
)
Public Sub New (
    caseSensitive As Boolean
)
public:
OrderedRegistry(
    bool caseSensitive
)
public:
OrderedRegistry(
    bool caseSensitive
)
new :
        caseSensitive : bool -> OrderedRegistry
new :
        caseSensitive : bool -> OrderedRegistry

Parameters

caseSensitive
Type: Online System Boolean
See Also
OrderedRegistry T Class
OrderedRegistry T Members
OrderedRegistry T Overload
NFX Namespace


OrderedRegistry(T) Fields

OrderedRegistry T Fields NFX Class Library

The OrderedRegistry T type exposes the following members.
Fields
 | Name | Description
Protected field | m_Sync | (Inherited from Registry T .)
Back to Top
See Also
OrderedRegistry T Class
NFX Namespace


OrderedRegistry(T) Methods

OrderedRegistry T Methods NFX Class Library

The OrderedRegistry T type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Deletes all items from ordered registry (Overrides Registry T Clear .)
Public method | ContainsName | (Inherited from Registry T .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | (Inherited from Registry T .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetOrRegister TContext (String, Func TContext, T , TContext) | Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency (Inherited from Registry T .)
Public method | GetOrRegister TContext (String, Func TContext, T , TContext, Boolean ) | Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency (Inherited from Registry T .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | JustRegistered | (Overrides Registry T JustRegistered(T).)
Protected method | JustReplaced | (Overrides Registry T JustReplaced(T, T).)
Protected method | JustUnregistered | (Overrides Registry T JustUnregistered(T).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Register | Registers item and returns true if it was registered, false if this named instance already existed in the list (Inherited from Registry T .)
Public method | RegisterOrReplace(T) | Registers item and returns true if it was registered, false if this named instance already existed and was replaced (Inherited from Registry T .)
Public method | RegisterOrReplace(T, T ) | Registers item and returns true if it was registered, false if this named instance already existed and was replaced (Inherited from Registry T .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryGetValue | (Inherited from Registry T .)
Public method | Unregister(String) | Unregisters item by name and returns true if it was unregistered, false if it did not exist (Inherited from Registry T .)
Public method | Unregister(T) | Unregisters item and returns true if it was unregistered, false if it did not exist (Inherited from Registry T .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable T | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct T, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault T | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast T | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast T (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Registry T .)
Back to Top
See Also
OrderedRegistry T Class
NFX Namespace


OrderedRegistry(T).Clear Method

OrderedRegistry T Clear Method NFX Class Library

Deletes all items from ordered registry

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Clear()
public override void Clear()
Public Overrides Sub Clear
Public Overrides Sub Clear
public:
virtual void Clear() override
public:
virtual void Clear() override
abstract Clear : unit -> unit
override Clear : unit -> unit
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also
OrderedRegistry T Class
OrderedRegistry T Members
NFX Namespace


OrderedRegistry(T).JustRegistered Method

OrderedRegistry T JustRegistered Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void JustRegistered(
    T item
)
protected override void JustRegistered(
    T item
)
Protected Overrides Sub JustRegistered (
    item As T
)
Protected Overrides Sub JustRegistered (
    item As T
)
protected:
virtual void JustRegistered(
    T item
) override
protected:
virtual void JustRegistered(
    T item
) override
abstract JustRegistered :
        item : 'T -> unit
override JustRegistered :
        item : 'T -> unit
abstract JustRegistered :
        item : 'T -> unit
override JustRegistered :
        item : 'T -> unit

Parameters

item
Type: T
See Also
OrderedRegistry T Class
OrderedRegistry T Members
NFX Namespace


OrderedRegistry(T).JustReplaced Method

OrderedRegistry T JustReplaced Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void JustReplaced(
    T existingItem,
    T newItem
)
protected override void JustReplaced(
    T existingItem,
    T newItem
)
Protected Overrides Sub JustReplaced (
    existingItem As T,
    newItem As T
)
Protected Overrides Sub JustReplaced (
    existingItem As T,
    newItem As T
)
protected:
virtual void JustReplaced(
    T existingItem,
    T newItem
) override
protected:
virtual void JustReplaced(
    T existingItem,
    T newItem
) override
abstract JustReplaced :
        existingItem : 'T *
        newItem : 'T -> unit
override JustReplaced :
        existingItem : 'T *
        newItem : 'T -> unit
abstract JustReplaced :
        existingItem : 'T *
        newItem : 'T -> unit
override JustReplaced :
        existingItem : 'T *
        newItem : 'T -> unit

Parameters

existingItem
Type: T
newItem
Type: T
See Also
OrderedRegistry T Class
OrderedRegistry T Members
NFX Namespace


OrderedRegistry(T).JustUnregistered Method

OrderedRegistry T JustUnregistered Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void JustUnregistered(
    T item
)
protected override void JustUnregistered(
    T item
)
Protected Overrides Sub JustUnregistered (
    item As T
)
Protected Overrides Sub JustUnregistered (
    item As T
)
protected:
virtual void JustUnregistered(
    T item
) override
protected:
virtual void JustUnregistered(
    T item
) override
abstract JustUnregistered :
        item : 'T -> unit
override JustUnregistered :
        item : 'T -> unit
abstract JustUnregistered :
        item : 'T -> unit
override JustUnregistered :
        item : 'T -> unit

Parameters

item
Type: T
See Also
OrderedRegistry T Class
OrderedRegistry T Members
NFX Namespace


OrderedRegistry(T) Properties

OrderedRegistry T Properties NFX Class Library

The OrderedRegistry T type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns the number of entries in the registry (Inherited from Registry T .)
Public property | IsCaseSensitive | Returns true if the instance differentiates names by case (Inherited from Registry T .)
Public property | Item Int32 | Tries to return an item by its position index in ordered set of items that this registry keeps. Null is returned when index is out of bounds. Note: since registry does reading in a lock-free manner, it is possible to have an inconsistent read snapshot of ordered items which may capture items that have already/not yet been added to the registry
Public property | Item String | Returns a value by name or null if not found (Inherited from Registry T .)
Public property | Names | (Inherited from Registry T .)
Public property | OrderedValues | Returns items that registry contains ordered by their Order property. The returned sequence is pre-sorted during alteration of registry, so this property access is efficient. Note: since registry does reading in a lock-free manner, it is possible to have an inconsistent read snapshot of ordered items which may capture items that have already/not yet been added to the registry
Public property | Values | (Inherited from Registry T .)
Back to Top
See Also
OrderedRegistry T Class
NFX Namespace


OrderedRegistry(T).Item Property

OrderedRegistry T Item Property NFX Class Library

Overload List
 | Name | Description
Public property | Item Int32 | Tries to return an item by its position index in ordered set of items that this registry keeps. Null is returned when index is out of bounds. Note: since registry does reading in a lock-free manner, it is possible to have an inconsistent read snapshot of ordered items which may capture items that have already/not yet been added to the registry
Public property | Item String | Returns a value by name or null if not found (Inherited from Registry T .)
Back to Top
See Also
OrderedRegistry T Class
OrderedRegistry T Members
NFX Namespace


OrderedRegistry(T).Item Property (Int32)

OrderedRegistry T Item Property (Int32) NFX Class Library

Tries to return an item by its position index in ordered set of items that this registry keeps. Null is returned when index is out of bounds. Note: since registry does reading in a lock-free manner, it is possible to have an inconsistent read snapshot of ordered items which may capture items that have already/not yet been added to the registry

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T this[
    int index
] { get; }
public T this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As T
    Get
Public ReadOnly Default Property Item (
    index As Integer
) As T
    Get
public:
virtual property T default[int index] {
    T get (int index) sealed;
}
public:
virtual property T default[int index] {
    T get (int index) sealed;
}
abstract Item : 'T with get
override Item : 'T with get
abstract Item : 'T with get
override Item : 'T with get

Parameters

index
Type: Online System Int32

Property Value

Type: T

Implements

IOrderedRegistry T Item Int32
See Also
OrderedRegistry T Class
OrderedRegistry T Members
Item Overload
NFX Namespace


OrderedRegistry(T).OrderedValues Property

OrderedRegistry T OrderedValues Property NFX Class Library

Returns items that registry contains ordered by their Order property. The returned sequence is pre-sorted during alteration of registry, so this property access is efficient. Note: since registry does reading in a lock-free manner, it is possible to have an inconsistent read snapshot of ordered items which may capture items that have already/not yet been added to the registry

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<T> OrderedValues { get; }
public IEnumerable<T> OrderedValues { get; }
Public ReadOnly Property OrderedValues As IEnumerable(Of T)
    Get
Public ReadOnly Property OrderedValues As IEnumerable(Of T)
    Get
public:
virtual property IEnumerable<T>^ OrderedValues {
    IEnumerable<T>^ get () sealed;
}
public:
virtual property IEnumerable<T>^ OrderedValues {
    IEnumerable<T>^ get () sealed;
}
abstract OrderedValues : IEnumerable<'T> with get
override OrderedValues : IEnumerable<'T> with get
abstract OrderedValues : IEnumerable<'T> with get
override OrderedValues : IEnumerable<'T> with get

Property Value

Type: Online IEnumerable T

Implements

IOrderedRegistry T OrderedValues
See Also
OrderedRegistry T Class
OrderedRegistry T Members
NFX Namespace


ReferenceEqualityComparer(T) Class

ReferenceEqualityComparer T Class NFX Class Library

Checks for reference equality. Use ReferenceEqualityComparer(T).Instance
Inheritance Hierarchy
Online System Object
Online System.Collections.Generic EqualityComparer T
NFX ReferenceEqualityComparer T

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ReferenceEqualityComparer<T> : EqualityComparer<T>
public sealed class ReferenceEqualityComparer<T> : EqualityComparer<T>
Public NotInheritable Class ReferenceEqualityComparer(Of T)
    Inherits EqualityComparer(Of T)
Public NotInheritable Class ReferenceEqualityComparer(Of T)
    Inherits EqualityComparer(Of T)
generic<typename T>
public ref class ReferenceEqualityComparer sealed : public EqualityComparer<T>
generic<typename T>
public ref class ReferenceEqualityComparer sealed : public EqualityComparer<T>
[<SealedAttribute>]
type ReferenceEqualityComparer<'T> =
    class
        inherit EqualityComparer<'T>
    end
[<SealedAttribute>]
type ReferenceEqualityComparer<'T> =
    class
        inherit EqualityComparer<'T>
    end
Type Parameters
T
See Also
ReferenceEqualityComparer T Members
NFX Namespace


ReferenceEqualityComparer(T) Members

ReferenceEqualityComparer T Members NFX Class Library

The ReferenceEqualityComparer T type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Equals(T, T) | (Overrides Online EqualityComparer T Equals(T, T).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetHashCode(T) | (Overrides Online EqualityComparer T GetHashCode(T).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
Name | Description
Instance |
Back to Top
See Also
ReferenceEqualityComparer T Class
NFX Namespace


ReferenceEqualityComparer(T) Methods

ReferenceEqualityComparer T Methods NFX Class Library

The ReferenceEqualityComparer T type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Equals(T, T) | (Overrides Online EqualityComparer T Equals(T, T).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetHashCode(T) | (Overrides Online EqualityComparer T GetHashCode(T).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ReferenceEqualityComparer T Class
NFX Namespace


ReferenceEqualityComparer(T).Equals Method

ReferenceEqualityComparer T Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Online Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Equals(T, T) | (Overrides Online EqualityComparer T Equals(T, T).)
Back to Top
See Also
ReferenceEqualityComparer T Class
ReferenceEqualityComparer T Members
NFX Namespace


ReferenceEqualityComparer(T).Equals Method (T, T)

ReferenceEqualityComparer T Equals Method (T, T) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    T x,
    T y
)
public override bool Equals(
    T x,
    T y
)
Public Overrides Function Equals (
    x As T,
    y As T
) As Boolean
Public Overrides Function Equals (
    x As T,
    y As T
) As Boolean
public:
virtual bool Equals(
    T x,
    T y
) override
public:
virtual bool Equals(
    T x,
    T y
) override
abstract Equals :
        x : 'T *
        y : 'T -> bool
override Equals :
        x : 'T *
        y : 'T -> bool
abstract Equals :
        x : 'T *
        y : 'T -> bool
override Equals :
        x : 'T *
        y : 'T -> bool

Parameters

x
Type: T
y
Type: T

Return Value

Type: Online Boolean

Implements

Online IEqualityComparer T Equals(T, T)
See Also
ReferenceEqualityComparer T Class
ReferenceEqualityComparer T Members
Equals Overload
NFX Namespace


ReferenceEqualityComparer(T).GetHashCode Method

ReferenceEqualityComparer T GetHashCode Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetHashCode(T) | (Overrides Online EqualityComparer T GetHashCode(T).)
Back to Top
See Also
ReferenceEqualityComparer T Class
ReferenceEqualityComparer T Members
NFX Namespace


ReferenceEqualityComparer(T).GetHashCode Method (T)

ReferenceEqualityComparer T GetHashCode Method (T) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode(
    T obj
)
public override int GetHashCode(
    T obj
)
Public Overrides Function GetHashCode (
    obj As T
) As Integer
Public Overrides Function GetHashCode (
    obj As T
) As Integer
public:
virtual int GetHashCode(
    T obj
) override
public:
virtual int GetHashCode(
    T obj
) override
abstract GetHashCode :
        obj : 'T -> int
override GetHashCode :
        obj : 'T -> int
abstract GetHashCode :
        obj : 'T -> int
override GetHashCode :
        obj : 'T -> int

Parameters

obj
Type: T

Return Value

Type: Online Int32

Implements

Online IEqualityComparer T GetHashCode(T)
See Also
ReferenceEqualityComparer T Class
ReferenceEqualityComparer T Members
GetHashCode Overload
NFX Namespace


ReferenceEqualityComparer(T) Properties

ReferenceEqualityComparer T Properties NFX Class Library

The ReferenceEqualityComparer T type exposes the following members.
Properties
Name | Description
Instance |
Back to Top
See Also
ReferenceEqualityComparer T Class
NFX Namespace


ReferenceEqualityComparer(T).Instance Property

ReferenceEqualityComparer T Instance Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ReferenceEqualityComparer<T> Instance { get; }
public static ReferenceEqualityComparer<T> Instance { get; }
Public Shared ReadOnly Property Instance As ReferenceEqualityComparer(Of T)
    Get
Public Shared ReadOnly Property Instance As ReferenceEqualityComparer(Of T)
    Get
public:
static property ReferenceEqualityComparer<T>^ Instance {
    ReferenceEqualityComparer<T>^ get ();
}
public:
static property ReferenceEqualityComparer<T>^ Instance {
    ReferenceEqualityComparer<T>^ get ();
}
static member Instance : ReferenceEqualityComparer<'T> with get
static member Instance : ReferenceEqualityComparer<'T> with get

Property Value

Type: ReferenceEqualityComparer T
See Also
ReferenceEqualityComparer T Class
ReferenceEqualityComparer T Members
NFX Namespace


Registry(T) Class

Registry T Class NFX Class Library

Represents a thread-safe registry of T. This class is efficient for concurrent read access and is not designed for cases when frequent modifications happen. It is ideal for lookup of named instances (such as components) that have much longer time span than components that look them up. Registry performs lock-free lookup which speeds-up many concurrent operations that need to map names into objects. The enumeration over registry makes a snapshot of its data, hence a registry may be modified by other threads while being enumerated.
Inheritance Hierarchy
Online System Object
NFX Registry T
NFX.Glue Bindings
NFX.Glue Providers
NFX.Glue Servers
NFX OrderedRegistry T

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class Registry<T> : IRegistry<T>,
    IEnumerable<T>, IEnumerable
where T : INamed
[SerializableAttribute]
public class Registry<T> : IRegistry<T>,
    IEnumerable<T>, IEnumerable
where T : INamed
<SerializableAttribute>
Public Class Registry(Of T As INamed)
    Implements IRegistry(Of T), IEnumerable(Of T),
    IEnumerable
<SerializableAttribute>
Public Class Registry(Of T As INamed)
    Implements IRegistry(Of T), IEnumerable(Of T),
    IEnumerable
[SerializableAttribute]
generic<typename T>
where T : INamed
public ref class Registry : IRegistry<T>,
    IEnumerable<T>, IEnumerable
[SerializableAttribute]
generic<typename T>
where T : INamed
public ref class Registry : IRegistry<T>,
    IEnumerable<T>, IEnumerable
[<SerializableAttribute>]
type Registry<'T when 'T : INamed> =
    class
        interface IRegistry<'T>
        interface IEnumerable<'T>
        interface IEnumerable
    end
[<SerializableAttribute>]
type Registry<'T when 'T : INamed> =
    class
        interface IRegistry<'T>
        interface IEnumerable<'T>
        interface IEnumerable
    end
Type Parameters
T
See Also
Registry T Members
NFX Namespace


Registry(T) Members

Registry T Members NFX Class Library

The Registry T type exposes the following members.
Constructors
 | Name | Description
Public method | Registry T | Initializes a new instance of the Registry T class
Public method | Registry T (Boolean) | Initializes a new instance of the Registry T class
Public method | Registry T (IEnumerable T ) | Initializes a new instance of the Registry T class
Public method | Registry T (IEnumerable T , Boolean) | Initializes a new instance of the Registry T class
Back to Top
Methods
 | Name | Description
Public method | Clear | Deletes all items from registry
Public method | ContainsName |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetOrRegister TContext (String, Func TContext, T , TContext) | Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency
Public method | GetOrRegister TContext (String, Func TContext, T , TContext, Boolean ) | Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | JustRegistered |
Protected method | JustReplaced |
Protected method | JustUnregistered |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Register | Registers item and returns true if it was registered, false if this named instance already existed in the list
Public method | RegisterOrReplace(T) | Registers item and returns true if it was registered, false if this named instance already existed and was replaced
Public method | RegisterOrReplace(T, T ) | Registers item and returns true if it was registered, false if this named instance already existed and was replaced
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryGetValue |
Public method | Unregister(String) | Unregisters item by name and returns true if it was unregistered, false if it did not exist
Public method | Unregister(T) | Unregisters item and returns true if it was unregistered, false if it did not exist
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable T | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct T, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault T | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast T | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast T (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Sync |
Back to Top
Properties
 | Name | Description
Public property | Count | Returns the number of entries in the registry
Public property | IsCaseSensitive | Returns true if the instance differentiates names by case
Public property | Item | Returns a value by name or null if not found
Public property | Names |
Public property | Values |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
Registry T Class
NFX Namespace


Registry(T) Constructor

Registry T Constructor NFX Class Library

Overload List
 | Name | Description
Public method | Registry T | Initializes a new instance of the Registry T class
Public method | Registry T (Boolean) | Initializes a new instance of the Registry T class
Public method | Registry T (IEnumerable T ) | Initializes a new instance of the Registry T class
Public method | Registry T (IEnumerable T , Boolean) | Initializes a new instance of the Registry T class
Back to Top
See Also
Registry T Class
Registry T Members
NFX Namespace


Registry(T) Constructor

Registry T Constructor NFX Class Library

Initializes a new instance of the Registry T class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Registry()
public Registry()
Public Sub New
Public Sub New
public:
Registry()
public:
Registry()
new : unit -> Registry
new : unit -> Registry
See Also
Registry T Class
Registry T Members
Registry T Overload
NFX Namespace


Registry(T) Constructor (Boolean)

Registry T Constructor (Boolean) NFX Class Library

Initializes a new instance of the Registry T class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Registry(
    bool caseSensitive
)
public Registry(
    bool caseSensitive
)
Public Sub New (
    caseSensitive As Boolean
)
Public Sub New (
    caseSensitive As Boolean
)
public:
Registry(
    bool caseSensitive
)
public:
Registry(
    bool caseSensitive
)
new :
        caseSensitive : bool -> Registry
new :
        caseSensitive : bool -> Registry

Parameters

caseSensitive
Type: Online System Boolean
See Also
Registry T Class
Registry T Members
Registry T Overload
NFX Namespace


Registry(T) Constructor (IEnumerable(T))

Registry T Constructor (IEnumerable T ) NFX Class Library

Initializes a new instance of the Registry T class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Registry(
    IEnumerable<T> other
)
public Registry(
    IEnumerable<T> other
)
Public Sub New (
    other As IEnumerable(Of T)
)
Public Sub New (
    other As IEnumerable(Of T)
)
public:
Registry(
    IEnumerable<T>^ other
)
public:
Registry(
    IEnumerable<T>^ other
)
new :
        other : IEnumerable<'T> -> Registry
new :
        other : IEnumerable<'T> -> Registry

Parameters

other
Type: Online System.Collections.Generic IEnumerable T
See Also
Registry T Class
Registry T Members
Registry T Overload
NFX Namespace


Registry(T) Constructor (IEnumerable(T), Boolean)

Registry T Constructor (IEnumerable T , Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Registry T class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Registry(
    IEnumerable<T> other,
    bool caseSensitive
)
public Registry(
    IEnumerable<T> other,
    bool caseSensitive
)
Public Sub New (
    other As IEnumerable(Of T),
    caseSensitive As Boolean
)
Public Sub New (
    other As IEnumerable(Of T),
    caseSensitive As Boolean
)
public:
Registry(
    IEnumerable<T>^ other,
    bool caseSensitive
)
public:
Registry(
    IEnumerable<T>^ other,
    bool caseSensitive
)
new :
        other : IEnumerable<'T> *
        caseSensitive : bool -> Registry
new :
        other : IEnumerable<'T> *
        caseSensitive : bool -> Registry

Parameters

other
Type: Online System.Collections.Generic IEnumerable T
caseSensitive
Type: Online System Boolean
See Also
Registry T Class
Registry T Members
Registry T Overload
NFX Namespace


Registry(T) Fields

Registry T Fields NFX Class Library

The Registry T type exposes the following members.
Fields
 | Name | Description
Protected field | m_Sync |
Back to Top
See Also
Registry T Class
NFX Namespace


Registry(T).m_Sync Field

Registry T m_Sync Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[NonSerializedAttribute]
protected Object m_Sync
[NonSerializedAttribute]
protected Object m_Sync
<NonSerializedAttribute>
Protected m_Sync As Object
<NonSerializedAttribute>
Protected m_Sync As Object
protected:
[NonSerializedAttribute]
Object^ m_Sync
protected:
[NonSerializedAttribute]
Object^ m_Sync
[<NonSerializedAttribute>]
val mutable m_Sync: Object
[<NonSerializedAttribute>]
val mutable m_Sync: Object

Field Value

Type: Online Object
See Also
Registry T Class
Registry T Members
NFX Namespace


Registry(T) Methods

Registry T Methods NFX Class Library

The Registry T type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Deletes all items from registry
Public method | ContainsName |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetOrRegister TContext (String, Func TContext, T , TContext) | Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency
Public method | GetOrRegister TContext (String, Func TContext, T , TContext, Boolean ) | Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | JustRegistered |
Protected method | JustReplaced |
Protected method | JustUnregistered |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Register | Registers item and returns true if it was registered, false if this named instance already existed in the list
Public method | RegisterOrReplace(T) | Registers item and returns true if it was registered, false if this named instance already existed and was replaced
Public method | RegisterOrReplace(T, T ) | Registers item and returns true if it was registered, false if this named instance already existed and was replaced
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryGetValue |
Public method | Unregister(String) | Unregisters item by name and returns true if it was unregistered, false if it did not exist
Public method | Unregister(T) | Unregisters item and returns true if it was unregistered, false if it did not exist
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable T | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct T, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault T | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast T | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast T (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
Registry T Class
NFX Namespace


Registry(T).IEnumerable.GetEnumerator Method

Registry T IEnumerable GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
Registry T Class
Registry T Members
NFX Namespace


Registry(T).Clear Method

Registry T Clear Method NFX Class Library

Deletes all items from registry

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Clear()
public virtual void Clear()
Public Overridable Sub Clear
Public Overridable Sub Clear
public:
virtual void Clear()
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also
Registry T Class
Registry T Members
NFX Namespace


Registry(T).ContainsName Method

Registry T ContainsName Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ContainsName(
    string name
)
public bool ContainsName(
    string name
)
Public Function ContainsName (
    name As String
) As Boolean
Public Function ContainsName (
    name As String
) As Boolean
public:
virtual bool ContainsName(
    String^ name
) sealed
public:
virtual bool ContainsName(
    String^ name
) sealed
abstract ContainsName :
        name : string -> bool
override ContainsName :
        name : string -> bool
abstract ContainsName :
        name : string -> bool
override ContainsName :
        name : string -> bool

Parameters

name
Type: Online System String

Return Value

Type: Online Boolean

Implements

IRegistry T ContainsName(String)
See Also
Registry T Class
Registry T Members
NFX Namespace


Registry(T).GetEnumerator Method

Registry T GetEnumerator Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<T> GetEnumerator()
public IEnumerator<T> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of T)
Public Function GetEnumerator As IEnumerator(Of T)
public:
virtual IEnumerator<T>^ GetEnumerator() sealed
public:
virtual IEnumerator<T>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<'T>
override GetEnumerator : unit -> IEnumerator<'T>
abstract GetEnumerator : unit -> IEnumerator<'T>
override GetEnumerator : unit -> IEnumerator<'T>

Return Value

Type: Online IEnumerator T

Implements

Online IEnumerable T GetEnumerator
See Also
Registry T Class
Registry T Members
NFX Namespace


Registry(T).GetOrRegister Method

Registry T GetOrRegister Method NFX Class Library

Overload List
 | Name | Description
Public method | GetOrRegister TContext (String, Func TContext, T , TContext) | Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency
Public method | GetOrRegister TContext (String, Func TContext, T , TContext, Boolean ) | Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency
Back to Top
See Also
Registry T Class
Registry T Members
NFX Namespace


Registry(T).GetOrRegister(TContext) Method (String, Func(TContext, T), TContext)

Registry T GetOrRegister TContext Method (String, Func TContext, T , TContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T GetOrRegister<TContext>(
    string name,
    Func<TContext, T> regFactory,
    TContext context
)
public T GetOrRegister<TContext>(
    string name,
    Func<TContext, T> regFactory,
    TContext context
)
Public Function GetOrRegister(Of TContext) (
    name As String,
    regFactory As Func(Of TContext, T),
    context As TContext
) As T
Public Function GetOrRegister(Of TContext) (
    name As String,
    regFactory As Func(Of TContext, T),
    context As TContext
) As T
public:
generic<typename TContext>
T GetOrRegister(
    String^ name,
    Func<TContext, T>^ regFactory,
    TContext context
)
public:
generic<typename TContext>
T GetOrRegister(
    String^ name,
    Func<TContext, T>^ regFactory,
    TContext context
)
member GetOrRegister :
        name : string *
        regFactory : Func<'TContext, 'T> *
        context : 'TContext -> 'T
member GetOrRegister :
        name : string *
        regFactory : Func<'TContext, 'T> *
        context : 'TContext -> 'T

Parameters

name
Type: Online System String
regFactory
Type: Online System Func TContext, T
context
Type: TContext
Type Parameters
TContext

Return Value

Type: T
See Also
Registry T Class
Registry T Members
GetOrRegister Overload
NFX Namespace


Registry(T).GetOrRegister(TContext) Method (String, Func(TContext, T), TContext, Boolean)

Registry T GetOrRegister TContext Method (String, Func TContext, T , TContext, Boolean ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T GetOrRegister<TContext>(
    string name,
    Func<TContext, T> regFactory,
    TContext context,
    out bool wasAdded
)
public T GetOrRegister<TContext>(
    string name,
    Func<TContext, T> regFactory,
    TContext context,
    out bool wasAdded
)
Public Function GetOrRegister(Of TContext) (
    name As String,
    regFactory As Func(Of TContext, T),
    context As TContext,
    <OutAttribute> ByRef wasAdded As Boolean
) As T
Public Function GetOrRegister(Of TContext) (
    name As String,
    regFactory As Func(Of TContext, T),
    context As TContext,
    <OutAttribute> ByRef wasAdded As Boolean
) As T
public:
generic<typename TContext>
T GetOrRegister(
    String^ name,
    Func<TContext, T>^ regFactory,
    TContext context,
    [OutAttribute] bool% wasAdded
)
public:
generic<typename TContext>
T GetOrRegister(
    String^ name,
    Func<TContext, T>^ regFactory,
    TContext context,
    [OutAttribute] bool% wasAdded
)
member GetOrRegister :
        name : string *
        regFactory : Func<'TContext, 'T> *
        context : 'TContext *
        wasAdded : bool byref -> 'T
member GetOrRegister :
        name : string *
        regFactory : Func<'TContext, 'T> *
        context : 'TContext *
        wasAdded : bool byref -> 'T

Parameters

name
Type: Online System String
regFactory
Type: Online System Func TContext, T
context
Type: TContext
wasAdded
Type: Online System Boolean
Type Parameters
TContext

Return Value

Type: T
See Also
Registry T Class
Registry T Members
GetOrRegister Overload
NFX Namespace


Registry(T).JustRegistered Method

Registry T JustRegistered Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void JustRegistered(
    T item
)
protected virtual void JustRegistered(
    T item
)
Protected Overridable Sub JustRegistered (
    item As T
)
Protected Overridable Sub JustRegistered (
    item As T
)
protected:
virtual void JustRegistered(
    T item
)
protected:
virtual void JustRegistered(
    T item
)
abstract JustRegistered :
        item : 'T -> unit
override JustRegistered :
        item : 'T -> unit
abstract JustRegistered :
        item : 'T -> unit
override JustRegistered :
        item : 'T -> unit

Parameters

item
Type: T
See Also
Registry T Class
Registry T Members
NFX Namespace


Registry(T).JustReplaced Method

Registry T JustReplaced Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void JustReplaced(
    T existingItem,
    T newItem
)
protected virtual void JustReplaced(
    T existingItem,
    T newItem
)
Protected Overridable Sub JustReplaced (
    existingItem As T,
    newItem As T
)
Protected Overridable Sub JustReplaced (
    existingItem As T,
    newItem As T
)
protected:
virtual void JustReplaced(
    T existingItem,
    T newItem
)
protected:
virtual void JustReplaced(
    T existingItem,
    T newItem
)
abstract JustReplaced :
        existingItem : 'T *
        newItem : 'T -> unit
override JustReplaced :
        existingItem : 'T *
        newItem : 'T -> unit
abstract JustReplaced :
        existingItem : 'T *
        newItem : 'T -> unit
override JustReplaced :
        existingItem : 'T *
        newItem : 'T -> unit

Parameters

existingItem
Type: T
newItem
Type: T
See Also
Registry T Class
Registry T Members
NFX Namespace


Registry(T).JustUnregistered Method

Registry T JustUnregistered Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void JustUnregistered(
    T item
)
protected virtual void JustUnregistered(
    T item
)
Protected Overridable Sub JustUnregistered (
    item As T
)
Protected Overridable Sub JustUnregistered (
    item As T
)
protected:
virtual void JustUnregistered(
    T item
)
protected:
virtual void JustUnregistered(
    T item
)
abstract JustUnregistered :
        item : 'T -> unit
override JustUnregistered :
        item : 'T -> unit
abstract JustUnregistered :
        item : 'T -> unit
override JustUnregistered :
        item : 'T -> unit

Parameters

item
Type: T
See Also
Registry T Class
Registry T Members
NFX Namespace


Registry(T).Register Method

Registry T Register Method NFX Class Library

Registers item and returns true if it was registered, false if this named instance already existed in the list

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Register(
    T item
)
public bool Register(
    T item
)
Public Function Register (
    item As T
) As Boolean
Public Function Register (
    item As T
) As Boolean
public:
bool Register(
    T item
)
public:
bool Register(
    T item
)
member Register :
        item : 'T -> bool
member Register :
        item : 'T -> bool

Parameters

item
Type: T

Return Value

Type: Online Boolean
See Also
Registry T Class
Registry T Members
NFX Namespace


Registry(T).RegisterOrReplace Method

Registry T RegisterOrReplace Method NFX Class Library

Overload List
 | Name | Description
Public method | RegisterOrReplace(T) | Registers item and returns true if it was registered, false if this named instance already existed and was replaced
Public method | RegisterOrReplace(T, T ) | Registers item and returns true if it was registered, false if this named instance already existed and was replaced
Back to Top
See Also
Registry T Class
Registry T Members
NFX Namespace


Registry(T).RegisterOrReplace Method (T)

Registry T RegisterOrReplace Method (T) NFX Class Library

Registers item and returns true if it was registered, false if this named instance already existed and was replaced

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool RegisterOrReplace(
    T item
)
public bool RegisterOrReplace(
    T item
)
Public Function RegisterOrReplace (
    item As T
) As Boolean
Public Function RegisterOrReplace (
    item As T
) As Boolean
public:
bool RegisterOrReplace(
    T item
)
public:
bool RegisterOrReplace(
    T item
)
member RegisterOrReplace :
        item : 'T -> bool
member RegisterOrReplace :
        item : 'T -> bool

Parameters

item
Type: T

Return Value

Type: Online Boolean
See Also
Registry T Class
Registry T Members
RegisterOrReplace Overload
NFX Namespace


Registry(T).RegisterOrReplace Method (T, T)

Registry T RegisterOrReplace Method (T, T ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Registers item and returns true if it was registered, false if this named instance already existed and was replaced

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool RegisterOrReplace(
    T item,
    out T existing
)
public bool RegisterOrReplace(
    T item,
    out T existing
)
Public Function RegisterOrReplace (
    item As T,
    <OutAttribute> ByRef existing As T
) As Boolean
Public Function RegisterOrReplace (
    item As T,
    <OutAttribute> ByRef existing As T
) As Boolean
public:
bool RegisterOrReplace(
    T item,
    [OutAttribute] T% existing
)
public:
bool RegisterOrReplace(
    T item,
    [OutAttribute] T% existing
)
member RegisterOrReplace :
        item : 'T *
        existing : 'T byref -> bool
member RegisterOrReplace :
        item : 'T *
        existing : 'T byref -> bool

Parameters

item
Type: T
existing
Type: T

Return Value

Type: Online Boolean
See Also
Registry T Class
Registry T Members
RegisterOrReplace Overload
NFX Namespace


Registry(T).TryGetValue Method

Registry T TryGetValue Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TryGetValue(
    string name,
    out T value
)
public bool TryGetValue(
    string name,
    out T value
)
Public Function TryGetValue (
    name As String,
    <OutAttribute> ByRef value As T
) As Boolean
Public Function TryGetValue (
    name As String,
    <OutAttribute> ByRef value As T
) As Boolean
public:
bool TryGetValue(
    String^ name,
    [OutAttribute] T% value
)
public:
bool TryGetValue(
    String^ name,
    [OutAttribute] T% value
)
member TryGetValue :
        name : string *
        value : 'T byref -> bool
member TryGetValue :
        name : string *
        value : 'T byref -> bool

Parameters

name
Type: Online System String
value
Type: T

Return Value

Type: Online Boolean
See Also
Registry T Class
Registry T Members
NFX Namespace


Registry(T).Unregister Method

Registry T Unregister Method NFX Class Library

Overload List
 | Name | Description
Public method | Unregister(String) | Unregisters item by name and returns true if it was unregistered, false if it did not exist
Public method | Unregister(T) | Unregisters item and returns true if it was unregistered, false if it did not exist
Back to Top
See Also
Registry T Class
Registry T Members
NFX Namespace


Registry(T).Unregister Method (String)

Registry T Unregister Method (String) NFX Class Library

Unregisters item by name and returns true if it was unregistered, false if it did not exist

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Unregister(
    string name
)
public bool Unregister(
    string name
)
Public Function Unregister (
    name As String
) As Boolean
Public Function Unregister (
    name As String
) As Boolean
public:
bool Unregister(
    String^ name
)
public:
bool Unregister(
    String^ name
)
member Unregister :
        name : string -> bool
member Unregister :
        name : string -> bool

Parameters

name
Type: Online System String

Return Value

Type: Online Boolean
See Also
Registry T Class
Registry T Members
Unregister Overload
NFX Namespace


Registry(T).Unregister Method (T)

Registry T Unregister Method (T) NFX Class Library

Unregisters item and returns true if it was unregistered, false if it did not exist

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Unregister(
    T item
)
public bool Unregister(
    T item
)
Public Function Unregister (
    item As T
) As Boolean
Public Function Unregister (
    item As T
) As Boolean
public:
bool Unregister(
    T item
)
public:
bool Unregister(
    T item
)
member Unregister :
        item : 'T -> bool
member Unregister :
        item : 'T -> bool

Parameters

item
Type: T

Return Value

Type: Online Boolean
See Also
Registry T Class
Registry T Members
Unregister Overload
NFX Namespace


Registry(T) Properties

Registry T Properties NFX Class Library

The Registry T type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns the number of entries in the registry
Public property | IsCaseSensitive | Returns true if the instance differentiates names by case
Public property | Item | Returns a value by name or null if not found
Public property | Names |
Public property | Values |
Back to Top
See Also
Registry T Class
NFX Namespace


Registry(T).Count Property

Registry T Count Property NFX Class Library

Returns the number of entries in the registry

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
public:
virtual property int Count {
    int get () sealed;
}
abstract Count : int with get
override Count : int with get
abstract Count : int with get
override Count : int with get

Property Value

Type: Online Int32

Implements

IRegistry T Count
See Also
Registry T Class
Registry T Members
NFX Namespace


Registry(T).IsCaseSensitive Property

Registry T IsCaseSensitive Property NFX Class Library

Returns true if the instance differentiates names by case

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsCaseSensitive { get; }
public bool IsCaseSensitive { get; }
Public ReadOnly Property IsCaseSensitive As Boolean
    Get
Public ReadOnly Property IsCaseSensitive As Boolean
    Get
public:
virtual property bool IsCaseSensitive {
    bool get () sealed;
}
public:
virtual property bool IsCaseSensitive {
    bool get () sealed;
}
abstract IsCaseSensitive : bool with get
override IsCaseSensitive : bool with get
abstract IsCaseSensitive : bool with get
override IsCaseSensitive : bool with get

Property Value

Type: Online Boolean

Implements

IRegistry T IsCaseSensitive
See Also
Registry T Class
Registry T Members
NFX Namespace


Registry(T).Item Property

Registry T Item Property NFX Class Library

Returns a value by name or null if not found

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T this[
    string name
] { get; }
public T this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As T
    Get
Public ReadOnly Default Property Item (
    name As String
) As T
    Get
public:
virtual property T default[String^ name] {
    T get (String^ name) sealed;
}
public:
virtual property T default[String^ name] {
    T get (String^ name) sealed;
}
abstract Item : 'T with get
override Item : 'T with get
abstract Item : 'T with get
override Item : 'T with get

Parameters

name
Type: Online System String

Property Value

Type: T

Implements

IRegistry T Item String
See Also
Registry T Class
Registry T Members
NFX Namespace


Registry(T).Names Property

Registry T Names Property NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<string> Names { get; }
public IEnumerable<string> Names { get; }
Public ReadOnly Property Names As IEnumerable(Of String)
    Get
Public ReadOnly Property Names As IEnumerable(Of String)
    Get
public:
virtual property IEnumerable<String^>^ Names {
    IEnumerable<String^>^ get () sealed;
}
public:
virtual property IEnumerable<String^>^ Names {
    IEnumerable<String^>^ get () sealed;
}
abstract Names : IEnumerable<string> with get
override Names : IEnumerable<string> with get
abstract Names : IEnumerable<string> with get
override Names : IEnumerable<string> with get

Property Value

Type: Online IEnumerable Online String

Implements

IRegistry T Names
See Also
Registry T Class
Registry T Members
NFX Namespace


Registry(T).Values Property

Registry T Values Property NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<T> Values { get; }
public IEnumerable<T> Values { get; }
Public ReadOnly Property Values As IEnumerable(Of T)
    Get
Public ReadOnly Property Values As IEnumerable(Of T)
    Get
public:
virtual property IEnumerable<T>^ Values {
    IEnumerable<T>^ get () sealed;
}
public:
virtual property IEnumerable<T>^ Values {
    IEnumerable<T>^ get () sealed;
}
abstract Values : IEnumerable<'T> with get
override Values : IEnumerable<'T> with get
abstract Values : IEnumerable<'T> with get
override Values : IEnumerable<'T> with get

Property Value

Type: Online IEnumerable T

Implements

IRegistry T Values
See Also
Registry T Class
Registry T Members
NFX Namespace


RegistryDictionary(T) Class

RegistryDictionary T Class NFX Class Library

Internal dictionary of string-named objects
Inheritance Hierarchy
Online System Object
Online System.Collections.Generic Dictionary Online String, T
NFX RegistryDictionary T

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
internal class RegistryDictionary<T> : Dictionary<string, T>
where T : INamed
[SerializableAttribute]
internal class RegistryDictionary<T> : Dictionary<string, T>
where T : INamed
<SerializableAttribute>
Friend Class RegistryDictionary(Of T As INamed)
    Inherits Dictionary(Of String, T)
<SerializableAttribute>
Friend Class RegistryDictionary(Of T As INamed)
    Inherits Dictionary(Of String, T)
[SerializableAttribute]
generic<typename T>
where T : INamed
internal ref class RegistryDictionary : public Dictionary<String^, T>
[SerializableAttribute]
generic<typename T>
where T : INamed
internal ref class RegistryDictionary : public Dictionary<String^, T>
[<SerializableAttribute>]
type RegistryDictionary<'T when 'T : INamed> =
    class
        inherit Dictionary<string, 'T>
    end
[<SerializableAttribute>]
type RegistryDictionary<'T when 'T : INamed> =
    class
        inherit Dictionary<string, 'T>
    end
Type Parameters
T
See Also
RegistryDictionary T Members
NFX Namespace


RegistryDictionary(T) Members

RegistryDictionary T Members NFX Class Library

The RegistryDictionary T type exposes the following members.
Constructors
 | Name | Description
Public method | RegistryDictionary T (Boolean) | Initializes a new instance of the RegistryDictionary T class
Public method | RegistryDictionary T (Boolean, IDictionary String, T ) | Initializes a new instance of the RegistryDictionary T class
Protected method | RegistryDictionary T (SerializationInfo, StreamingContext) | Initializes a new instance of the RegistryDictionary T class
Back to Top
Methods
 | Name | Description
Public method | Online Add | (Inherited from Online Dictionary Online String, T .)
Public method | Online Clear | (Inherited from Online Dictionary Online String, T .)
Public method | Online ContainsKey | (Inherited from Online Dictionary Online String, T .)
Public method | Online ContainsValue | (Inherited from Online Dictionary Online String, T .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | (Inherited from Online Dictionary Online String, T .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online Dictionary TKey, TValue instance. (Inherited from Online Dictionary Online String, T .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online Dictionary Online String, T .)
Public method | Online Remove | (Inherited from Online Dictionary Online String, T .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TryGetValue | (Inherited from Online Dictionary Online String, T .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online Comparer | (Inherited from Online Dictionary Online String, T .)
Public property | Online Count | (Inherited from Online Dictionary Online String, T .)
Public property | Online Item | (Inherited from Online Dictionary Online String, T .)
Public property | Online Keys | (Inherited from Online Dictionary Online String, T .)
Public property | Online Values | (Inherited from Online Dictionary Online String, T .)
Back to Top
See Also
RegistryDictionary T Class
NFX Namespace


RegistryDictionary(T) Constructor

RegistryDictionary T Constructor NFX Class Library

Overload List
 | Name | Description
Public method | RegistryDictionary T (Boolean) | Initializes a new instance of the RegistryDictionary T class
Public method | RegistryDictionary T (Boolean, IDictionary String, T ) | Initializes a new instance of the RegistryDictionary T class
Protected method | RegistryDictionary T (SerializationInfo, StreamingContext) | Initializes a new instance of the RegistryDictionary T class
Back to Top
See Also
RegistryDictionary T Class
RegistryDictionary T Members
NFX Namespace


RegistryDictionary(T) Constructor (Boolean)

RegistryDictionary T Constructor (Boolean) NFX Class Library

Initializes a new instance of the RegistryDictionary T class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RegistryDictionary(
    bool caseSensitive
)
public RegistryDictionary(
    bool caseSensitive
)
Public Sub New (
    caseSensitive As Boolean
)
Public Sub New (
    caseSensitive As Boolean
)
public:
RegistryDictionary(
    bool caseSensitive
)
public:
RegistryDictionary(
    bool caseSensitive
)
new :
        caseSensitive : bool -> RegistryDictionary
new :
        caseSensitive : bool -> RegistryDictionary

Parameters

caseSensitive
Type: Online System Boolean
See Also
RegistryDictionary T Class
RegistryDictionary T Members
RegistryDictionary T Overload
NFX Namespace


RegistryDictionary(T) Constructor (Boolean, IDictionary(String, T))

RegistryDictionary T Constructor (Boolean, IDictionary String, T ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RegistryDictionary T class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RegistryDictionary(
    bool caseSensitive,
    IDictionary<string, T> other
)
public RegistryDictionary(
    bool caseSensitive,
    IDictionary<string, T> other
)
Public Sub New (
    caseSensitive As Boolean,
    other As IDictionary(Of String, T)
)
Public Sub New (
    caseSensitive As Boolean,
    other As IDictionary(Of String, T)
)
public:
RegistryDictionary(
    bool caseSensitive,
    IDictionary<String^, T>^ other
)
public:
RegistryDictionary(
    bool caseSensitive,
    IDictionary<String^, T>^ other
)
new :
        caseSensitive : bool *
        other : IDictionary<string, 'T> -> RegistryDictionary
new :
        caseSensitive : bool *
        other : IDictionary<string, 'T> -> RegistryDictionary

Parameters

caseSensitive
Type: Online System Boolean
other
Type: Online System.Collections.Generic IDictionary Online String, T
See Also
RegistryDictionary T Class
RegistryDictionary T Members
RegistryDictionary T Overload
NFX Namespace


RegistryDictionary(T) Constructor (SerializationInfo, StreamingContext)

RegistryDictionary T Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RegistryDictionary T class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected RegistryDictionary(
    SerializationInfo info,
    StreamingContext context
)
protected RegistryDictionary(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
RegistryDictionary(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
RegistryDictionary(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> RegistryDictionary
new :
        info : SerializationInfo *
        context : StreamingContext -> RegistryDictionary

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
RegistryDictionary T Class
RegistryDictionary T Members
RegistryDictionary T Overload
NFX Namespace


RegistryDictionary(T) Methods

RegistryDictionary T Methods NFX Class Library

The RegistryDictionary T type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | (Inherited from Online Dictionary Online String, T .)
Public method | Online Clear | (Inherited from Online Dictionary Online String, T .)
Public method | Online ContainsKey | (Inherited from Online Dictionary Online String, T .)
Public method | Online ContainsValue | (Inherited from Online Dictionary Online String, T .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | (Inherited from Online Dictionary Online String, T .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online Dictionary TKey, TValue instance. (Inherited from Online Dictionary Online String, T .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online Dictionary Online String, T .)
Public method | Online Remove | (Inherited from Online Dictionary Online String, T .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TryGetValue | (Inherited from Online Dictionary Online String, T .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
RegistryDictionary T Class
NFX Namespace


RegistryDictionary(T) Properties

RegistryDictionary T Properties NFX Class Library

The RegistryDictionary T type exposes the following members.
Properties
 | Name | Description
Public property | Online Comparer | (Inherited from Online Dictionary Online String, T .)
Public property | Online Count | (Inherited from Online Dictionary Online String, T .)
Public property | Online Item | (Inherited from Online Dictionary Online String, T .)
Public property | Online Keys | (Inherited from Online Dictionary Online String, T .)
Public property | Online Values | (Inherited from Online Dictionary Online String, T .)
Back to Top
See Also
RegistryDictionary T Class
NFX Namespace


Scope Class

Scope Class NFX Class Library

Helper class to be used in the context of 'using' clause to facilitate cleanup on scope exit and performing of other functions such as status logging
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX Scope

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Scope : DisposableObject
public class Scope : DisposableObject
Public Class Scope
    Inherits DisposableObject
Public Class Scope
    Inherits DisposableObject
public ref class Scope : public DisposableObject
public ref class Scope : public DisposableObject
type Scope =
    class
        inherit DisposableObject
    end
type Scope =
    class
        inherit DisposableObject
    end
Remarks
Typical use case:
View Colorized Copy to Clipboard Print
using(Scope.OnExit(() => Bell.Ring()))
{
   ... do something ...
}

using(Scope.OnExit<bool>(
              ()  => { var old = Tracing.IsOn; Tracing.Off(); return old; },
              (b) => Tracing.State(b)))
{
   ... do something ...
}
using(Scope.OnExit(() => Bell.Ring()))
{
   ... do something ...
}

using(Scope.OnExit<bool>(
              ()  => { var old = Tracing.IsOn; Tracing.Off(); return old; },
              (b) => Tracing.State(b)))
{
   ... do something ...
}
See Also
Scope Members
NFX Namespace


Scope Members

Scope Members NFX Class Library

The Scope type exposes the following members.
Constructors
 | Name | Description
Public method | Scope | Initializes a new instance of the Scope class
Back to Top
Methods
 | Name | Description
Public method | AtExit(Action) |
Public method | AtExit T1 (T1, Action T1 ) |
Public method | AtExit T1, T2 (T1, T2, Action T1, T2 ) |
Public method | AtExit T1, T2, T3 (T1, T2, T3, Action T1, T2, T3 ) |
Public method | AtExit T1, T2, T3, T4 (T1, T2, T3, T4, Action T1, T2, T3, T4 ) |
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | OnExit(Action) |
 | OnExit T1 (T1, Action T1 ) |
 | OnExit T1, T2 (T1, T2, Action T1, T2 ) |
 | OnExit T1, T2, T3 (T1, T2, T3, Action T1, T2, T3 ) |
 | OnExit T1, T2, T3, T4 (T1, T2, T3, T4, Action T1, T2, T3, T4 ) |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Back to Top
See Also
Scope Class
NFX Namespace


Scope Constructor

Scope Constructor NFX Class Library

Initializes a new instance of the Scope class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Scope(
    string name = null,
    bool log = false,
    string logText = null,
    string logTopic = null,
    Nullable<MessageType> logMsgType = null,
    Action onExit = null,
    bool measureTime = false,
    int stackFrameOffset = 2
)
public Scope(
    string name = null,
    bool log = false,
    string logText = null,
    string logTopic = null,
    Nullable<MessageType> logMsgType = null,
    Action onExit = null,
    bool measureTime = false,
    int stackFrameOffset = 2
)
Public Sub New (
    Optional name As String = Nothing,
    Optional log As Boolean = false,
    Optional logText As String = Nothing,
    Optional logTopic As String = Nothing,
    Optional logMsgType As Nullable(Of MessageType) = Nothing,
    Optional onExit As Action = Nothing,
    Optional measureTime As Boolean = false,
    Optional stackFrameOffset As Integer = 2
)
Public Sub New (
    Optional name As String = Nothing,
    Optional log As Boolean = false,
    Optional logText As String = Nothing,
    Optional logTopic As String = Nothing,
    Optional logMsgType As Nullable(Of MessageType) = Nothing,
    Optional onExit As Action = Nothing,
    Optional measureTime As Boolean = false,
    Optional stackFrameOffset As Integer = 2
)
public:
Scope(
    String^ name = nullptr,
    bool log = false,
    String^ logText = nullptr,
    String^ logTopic = nullptr,
    Nullable<MessageType> logMsgType = nullptr,
    Action^ onExit = nullptr,
    bool measureTime = false,
    int stackFrameOffset = 2
)
public:
Scope(
    String^ name = nullptr,
    bool log = false,
    String^ logText = nullptr,
    String^ logTopic = nullptr,
    Nullable<MessageType> logMsgType = nullptr,
    Action^ onExit = nullptr,
    bool measureTime = false,
    int stackFrameOffset = 2
)
new :
        ?name : string *
        ?log : bool *
        ?logText : string *
        ?logTopic : string *
        ?logMsgType : Nullable<MessageType> *
        ?onExit : Action *
        ?measureTime : bool *
        ?stackFrameOffset : int
(* Defaults:
        let _name = defaultArg name null
        let _log = defaultArg log false
        let _logText = defaultArg logText null
        let _logTopic = defaultArg logTopic null
        let _logMsgType = defaultArg logMsgType null
        let _onExit = defaultArg onExit null
        let _measureTime = defaultArg measureTime false
        let _stackFrameOffset = defaultArg stackFrameOffset 2
*)
-> Scope
new :
        ?name : string *
        ?log : bool *
        ?logText : string *
        ?logTopic : string *
        ?logMsgType : Nullable<MessageType> *
        ?onExit : Action *
        ?measureTime : bool *
        ?stackFrameOffset : int
(* Defaults:
        let _name = defaultArg name null
        let _log = defaultArg log false
        let _logText = defaultArg logText null
        let _logTopic = defaultArg logTopic null
        let _logMsgType = defaultArg logMsgType null
        let _onExit = defaultArg onExit null
        let _measureTime = defaultArg measureTime false
        let _stackFrameOffset = defaultArg stackFrameOffset 2
*)
-> Scope

Parameters

name (Optional)
Type: Online System String
log (Optional)
Type: Online System Boolean
logText (Optional)
Type: Online System String
logTopic (Optional)
Type: Online System String
logMsgType (Optional)
Type: Online System Nullable MessageType
onExit (Optional)
Type: Online System Action
measureTime (Optional)
Type: Online System Boolean
stackFrameOffset (Optional)
Type: Online System Int32
See Also
Scope Class
Scope Members
NFX Namespace


Scope Methods

Scope Methods NFX Class Library

The Scope type exposes the following members.
Methods
 | Name | Description
Public method | AtExit(Action) |
Public method | AtExit T1 (T1, Action T1 ) |
Public method | AtExit T1, T2 (T1, T2, Action T1, T2 ) |
Public method | AtExit T1, T2, T3 (T1, T2, T3, Action T1, T2, T3 ) |
Public method | AtExit T1, T2, T3, T4 (T1, T2, T3, T4, Action T1, T2, T3, T4 ) |
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | OnExit(Action) |
 | OnExit T1 (T1, Action T1 ) |
 | OnExit T1, T2 (T1, T2, Action T1, T2 ) |
 | OnExit T1, T2, T3 (T1, T2, T3, Action T1, T2, T3 ) |
 | OnExit T1, T2, T3, T4 (T1, T2, T3, T4, Action T1, T2, T3, T4 ) |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Scope Class
NFX Namespace


Scope.AtExit Method

Scope AtExit Method NFX Class Library

Overload List
 | Name | Description
Public method | AtExit(Action) |
Public method | AtExit T1 (T1, Action T1 ) |
Public method | AtExit T1, T2 (T1, T2, Action T1, T2 ) |
Public method | AtExit T1, T2, T3 (T1, T2, T3, Action T1, T2, T3 ) |
Public method | AtExit T1, T2, T3, T4 (T1, T2, T3, T4, Action T1, T2, T3, T4 ) |
Back to Top
See Also
Scope Class
Scope Members
NFX Namespace


Scope.AtExit Method (Action)

Scope AtExit Method (Action) NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Scope AtExit(
    Action onExit
)
public Scope AtExit(
    Action onExit
)
Public Function AtExit (
    onExit As Action
) As Scope
Public Function AtExit (
    onExit As Action
) As Scope
public:
Scope^ AtExit(
    Action^ onExit
)
public:
Scope^ AtExit(
    Action^ onExit
)
member AtExit :
        onExit : Action -> Scope
member AtExit :
        onExit : Action -> Scope

Parameters

onExit
Type: Online System Action

Return Value

Type: Scope
See Also
Scope Class
Scope Members
AtExit Overload
NFX Namespace


Scope.AtExit(T1) Method (T1, Action(T1))

Scope AtExit T1 Method (T1, Action T1 ) NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Scope AtExit<T1>(
    T1 c1,
    Action<T1> onExit
)
public Scope AtExit<T1>(
    T1 c1,
    Action<T1> onExit
)
Public Function AtExit(Of T1) (
    c1 As T1,
    onExit As Action(Of T1)
) As Scope
Public Function AtExit(Of T1) (
    c1 As T1,
    onExit As Action(Of T1)
) As Scope
public:
generic<typename T1>
Scope^ AtExit(
    T1 c1,
    Action<T1>^ onExit
)
public:
generic<typename T1>
Scope^ AtExit(
    T1 c1,
    Action<T1>^ onExit
)
member AtExit :
        c1 : 'T1 *
        onExit : Action<'T1> -> Scope
member AtExit :
        c1 : 'T1 *
        onExit : Action<'T1> -> Scope

Parameters

c1
Type: T1
onExit
Type: Online System Action T1
Type Parameters
T1

Return Value

Type: Scope
See Also
Scope Class
Scope Members
AtExit Overload
NFX Namespace


Scope.AtExit(T1, T2) Method (T1, T2, Action(T1, T2))

Scope AtExit T1, T2 Method (T1, T2, Action T1, T2 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Scope AtExit<T1, T2>(
    T1 c1,
    T2 c2,
    Action<T1, T2> onExit
)
public Scope AtExit<T1, T2>(
    T1 c1,
    T2 c2,
    Action<T1, T2> onExit
)
Public Function AtExit(Of T1, T2) (
    c1 As T1,
    c2 As T2,
    onExit As Action(Of T1, T2)
) As Scope
Public Function AtExit(Of T1, T2) (
    c1 As T1,
    c2 As T2,
    onExit As Action(Of T1, T2)
) As Scope
public:
generic<typename T1, typename T2>
Scope^ AtExit(
    T1 c1,
    T2 c2,
    Action<T1, T2>^ onExit
)
public:
generic<typename T1, typename T2>
Scope^ AtExit(
    T1 c1,
    T2 c2,
    Action<T1, T2>^ onExit
)
member AtExit :
        c1 : 'T1 *
        c2 : 'T2 *
        onExit : Action<'T1, 'T2> -> Scope
member AtExit :
        c1 : 'T1 *
        c2 : 'T2 *
        onExit : Action<'T1, 'T2> -> Scope

Parameters

c1
Type: T1
c2
Type: T2
onExit
Type: Online System Action T1, T2
Type Parameters
T1
T2

Return Value

Type: Scope
See Also
Scope Class
Scope Members
AtExit Overload
NFX Namespace


Scope.AtExit(T1, T2, T3) Method (T1, T2, T3, Action(T1, T2, T3))

Scope AtExit T1, T2, T3 Method (T1, T2, T3, Action T1, T2, T3 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Scope AtExit<T1, T2, T3>(
    T1 c1,
    T2 c2,
    T3 c3,
    Action<T1, T2, T3> onExit
)
public Scope AtExit<T1, T2, T3>(
    T1 c1,
    T2 c2,
    T3 c3,
    Action<T1, T2, T3> onExit
)
Public Function AtExit(Of T1, T2, T3) (
    c1 As T1,
    c2 As T2,
    c3 As T3,
    onExit As Action(Of T1, T2, T3)
) As Scope
Public Function AtExit(Of T1, T2, T3) (
    c1 As T1,
    c2 As T2,
    c3 As T3,
    onExit As Action(Of T1, T2, T3)
) As Scope
public:
generic<typename T1, typename T2, typename T3>
Scope^ AtExit(
    T1 c1,
    T2 c2,
    T3 c3,
    Action<T1, T2, T3>^ onExit
)
public:
generic<typename T1, typename T2, typename T3>
Scope^ AtExit(
    T1 c1,
    T2 c2,
    T3 c3,
    Action<T1, T2, T3>^ onExit
)
member AtExit :
        c1 : 'T1 *
        c2 : 'T2 *
        c3 : 'T3 *
        onExit : Action<'T1, 'T2, 'T3> -> Scope
member AtExit :
        c1 : 'T1 *
        c2 : 'T2 *
        c3 : 'T3 *
        onExit : Action<'T1, 'T2, 'T3> -> Scope

Parameters

c1
Type: T1
c2
Type: T2
c3
Type: T3
onExit
Type: Online System Action T1, T2, T3
Type Parameters
T1
T2
T3

Return Value

Type: Scope
See Also
Scope Class
Scope Members
AtExit Overload
NFX Namespace


Scope.AtExit(T1, T2, T3, T4) Method (T1, T2, T3, T4, Action(T1, T2, T3, T4))

Scope AtExit T1, T2, T3, T4 Method (T1, T2, T3, T4, Action T1, T2, T3, T4 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Scope AtExit<T1, T2, T3, T4>(
    T1 c1,
    T2 c2,
    T3 c3,
    T4 c4,
    Action<T1, T2, T3, T4> onExit
)
public Scope AtExit<T1, T2, T3, T4>(
    T1 c1,
    T2 c2,
    T3 c3,
    T4 c4,
    Action<T1, T2, T3, T4> onExit
)
Public Function AtExit(Of T1, T2, T3, T4) (
    c1 As T1,
    c2 As T2,
    c3 As T3,
    c4 As T4,
    onExit As Action(Of T1, T2, T3, T4)
) As Scope
Public Function AtExit(Of T1, T2, T3, T4) (
    c1 As T1,
    c2 As T2,
    c3 As T3,
    c4 As T4,
    onExit As Action(Of T1, T2, T3, T4)
) As Scope
public:
generic<typename T1, typename T2, typename T3, typename T4>
Scope^ AtExit(
    T1 c1,
    T2 c2,
    T3 c3,
    T4 c4,
    Action<T1, T2, T3, T4>^ onExit
)
public:
generic<typename T1, typename T2, typename T3, typename T4>
Scope^ AtExit(
    T1 c1,
    T2 c2,
    T3 c3,
    T4 c4,
    Action<T1, T2, T3, T4>^ onExit
)
member AtExit :
        c1 : 'T1 *
        c2 : 'T2 *
        c3 : 'T3 *
        c4 : 'T4 *
        onExit : Action<'T1, 'T2, 'T3, 'T4> -> Scope
member AtExit :
        c1 : 'T1 *
        c2 : 'T2 *
        c3 : 'T3 *
        c4 : 'T4 *
        onExit : Action<'T1, 'T2, 'T3, 'T4> -> Scope

Parameters

c1
Type: T1
c2
Type: T2
c3
Type: T3
c4
Type: T4
onExit
Type: Online System Action T1, T2, T3, T4
Type Parameters
T1
T2
T3
T4

Return Value

Type: Scope
See Also
Scope Class
Scope Members
AtExit Overload
NFX Namespace


Scope.Destructor Method

Scope Destructor Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
Scope Class
Scope Members
NFX Namespace


Scope.OnExit Method

Scope OnExit Method NFX Class Library

Overload List
Name | Description
OnExit(Action) |
OnExit T1 (T1, Action T1 ) |
OnExit T1, T2 (T1, T2, Action T1, T2 ) |
OnExit T1, T2, T3 (T1, T2, T3, Action T1, T2, T3 ) |
OnExit T1, T2, T3, T4 (T1, T2, T3, T4, Action T1, T2, T3, T4 ) |
Back to Top
See Also
Scope Class
Scope Members
NFX Namespace


Scope.OnExit Method (Action)

Scope OnExit Method (Action) NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Scope..::.._scopeExit OnExit(
    Action onExit
)
public static Scope..::.._scopeExit OnExit(
    Action onExit
)
Public Shared Function OnExit (
    onExit As Action
) As Scope..::.._scopeExit
Public Shared Function OnExit (
    onExit As Action
) As Scope..::.._scopeExit
public:
static Scope..::.._scopeExit OnExit(
    Action^ onExit
)
public:
static Scope..::.._scopeExit OnExit(
    Action^ onExit
)
static member OnExit :
        onExit : Action -> Scope..::.._scopeExit
static member OnExit :
        onExit : Action -> Scope..::.._scopeExit

Parameters

onExit
Type: Online System Action

Return Value

Type: Scope _scopeExit
See Also
Scope Class
Scope Members
OnExit Overload
NFX Namespace


Scope.OnExit(T1) Method (T1, Action(T1))

Scope OnExit T1 Method (T1, Action T1 ) NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Scope..::.._scopeExit<T1> OnExit<T1>(
    T1 context,
    Action<T1> onExit
)
public static Scope..::.._scopeExit<T1> OnExit<T1>(
    T1 context,
    Action<T1> onExit
)
Public Shared Function OnExit(Of T1) (
    context As T1,
    onExit As Action(Of T1)
) As Scope..::.._scopeExit(Of T1)
Public Shared Function OnExit(Of T1) (
    context As T1,
    onExit As Action(Of T1)
) As Scope..::.._scopeExit(Of T1)
public:
generic<typename T1>
static Scope..::.._scopeExit<T1> OnExit(
    T1 context,
    Action<T1>^ onExit
)
public:
generic<typename T1>
static Scope..::.._scopeExit<T1> OnExit(
    T1 context,
    Action<T1>^ onExit
)
static member OnExit :
        context : 'T1 *
        onExit : Action<'T1> -> Scope..::.._scopeExit<'T1>
static member OnExit :
        context : 'T1 *
        onExit : Action<'T1> -> Scope..::.._scopeExit<'T1>

Parameters

context
Type: T1
onExit
Type: Online System Action T1
Type Parameters
T1

Return Value

Type: Scope _scopeExit T1
See Also
Scope Class
Scope Members
OnExit Overload
NFX Namespace


Scope.OnExit(T1, T2) Method (T1, T2, Action(T1, T2))

Scope OnExit T1, T2 Method (T1, T2, Action T1, T2 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Scope..::.._scopeExit<T1, T2> OnExit<T1, T2>(
    T1 ctx1,
    T2 ctx2,
    Action<T1, T2> onExit
)
public static Scope..::.._scopeExit<T1, T2> OnExit<T1, T2>(
    T1 ctx1,
    T2 ctx2,
    Action<T1, T2> onExit
)
Public Shared Function OnExit(Of T1, T2) (
    ctx1 As T1,
    ctx2 As T2,
    onExit As Action(Of T1, T2)
) As Scope..::.._scopeExit(Of T1, T2)
Public Shared Function OnExit(Of T1, T2) (
    ctx1 As T1,
    ctx2 As T2,
    onExit As Action(Of T1, T2)
) As Scope..::.._scopeExit(Of T1, T2)
public:
generic<typename T1, typename T2>
static Scope..::.._scopeExit<T1, T2> OnExit(
    T1 ctx1,
    T2 ctx2,
    Action<T1, T2>^ onExit
)
public:
generic<typename T1, typename T2>
static Scope..::.._scopeExit<T1, T2> OnExit(
    T1 ctx1,
    T2 ctx2,
    Action<T1, T2>^ onExit
)
static member OnExit :
        ctx1 : 'T1 *
        ctx2 : 'T2 *
        onExit : Action<'T1, 'T2> -> Scope..::.._scopeExit<'T1, 'T2>
static member OnExit :
        ctx1 : 'T1 *
        ctx2 : 'T2 *
        onExit : Action<'T1, 'T2> -> Scope..::.._scopeExit<'T1, 'T2>

Parameters

ctx1
Type: T1
ctx2
Type: T2
onExit
Type: Online System Action T1, T2
Type Parameters
T1
T2

Return Value

Type: Scope _scopeExit T1, T2
See Also
Scope Class
Scope Members
OnExit Overload
NFX Namespace


Scope.OnExit(T1, T2, T3) Method (T1, T2, T3, Action(T1, T2, T3))

Scope OnExit T1, T2, T3 Method (T1, T2, T3, Action T1, T2, T3 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Scope..::.._scopeExit<T1, T2, T3> OnExit<T1, T2, T3>(
    T1 ctx1,
    T2 ctx2,
    T3 ctx3,
    Action<T1, T2, T3> onExit
)
public static Scope..::.._scopeExit<T1, T2, T3> OnExit<T1, T2, T3>(
    T1 ctx1,
    T2 ctx2,
    T3 ctx3,
    Action<T1, T2, T3> onExit
)
Public Shared Function OnExit(Of T1, T2, T3) (
    ctx1 As T1,
    ctx2 As T2,
    ctx3 As T3,
    onExit As Action(Of T1, T2, T3)
) As Scope..::.._scopeExit(Of T1, T2, T3)
Public Shared Function OnExit(Of T1, T2, T3) (
    ctx1 As T1,
    ctx2 As T2,
    ctx3 As T3,
    onExit As Action(Of T1, T2, T3)
) As Scope..::.._scopeExit(Of T1, T2, T3)
public:
generic<typename T1, typename T2, typename T3>
static Scope..::.._scopeExit<T1, T2, T3> OnExit(
    T1 ctx1,
    T2 ctx2,
    T3 ctx3,
    Action<T1, T2, T3>^ onExit
)
public:
generic<typename T1, typename T2, typename T3>
static Scope..::.._scopeExit<T1, T2, T3> OnExit(
    T1 ctx1,
    T2 ctx2,
    T3 ctx3,
    Action<T1, T2, T3>^ onExit
)
static member OnExit :
        ctx1 : 'T1 *
        ctx2 : 'T2 *
        ctx3 : 'T3 *
        onExit : Action<'T1, 'T2, 'T3> -> Scope..::.._scopeExit<'T1, 'T2, 'T3>
static member OnExit :
        ctx1 : 'T1 *
        ctx2 : 'T2 *
        ctx3 : 'T3 *
        onExit : Action<'T1, 'T2, 'T3> -> Scope..::.._scopeExit<'T1, 'T2, 'T3>

Parameters

ctx1
Type: T1
ctx2
Type: T2
ctx3
Type: T3
onExit
Type: Online System Action T1, T2, T3
Type Parameters
T1
T2
T3

Return Value

Type: Scope _scopeExit T1, T2, T3
See Also
Scope Class
Scope Members
OnExit Overload
NFX Namespace


Scope.OnExit(T1, T2, T3, T4) Method (T1, T2, T3, T4, Action(T1, T2, T3, T4))

Scope OnExit T1, T2, T3, T4 Method (T1, T2, T3, T4, Action T1, T2, T3, T4 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Scope..::.._scopeExit<T1, T2, T3, T4> OnExit<T1, T2, T3, T4>(
    T1 c1,
    T2 c2,
    T3 c3,
    T4 c4,
    Action<T1, T2, T3, T4> onExit
)
public static Scope..::.._scopeExit<T1, T2, T3, T4> OnExit<T1, T2, T3, T4>(
    T1 c1,
    T2 c2,
    T3 c3,
    T4 c4,
    Action<T1, T2, T3, T4> onExit
)
Public Shared Function OnExit(Of T1, T2, T3, T4) (
    c1 As T1,
    c2 As T2,
    c3 As T3,
    c4 As T4,
    onExit As Action(Of T1, T2, T3, T4)
) As Scope..::.._scopeExit(Of T1, T2, T3, T4)
Public Shared Function OnExit(Of T1, T2, T3, T4) (
    c1 As T1,
    c2 As T2,
    c3 As T3,
    c4 As T4,
    onExit As Action(Of T1, T2, T3, T4)
) As Scope..::.._scopeExit(Of T1, T2, T3, T4)
public:
generic<typename T1, typename T2, typename T3, typename T4>
static Scope..::.._scopeExit<T1, T2, T3, T4> OnExit(
    T1 c1,
    T2 c2,
    T3 c3,
    T4 c4,
    Action<T1, T2, T3, T4>^ onExit
)
public:
generic<typename T1, typename T2, typename T3, typename T4>
static Scope..::.._scopeExit<T1, T2, T3, T4> OnExit(
    T1 c1,
    T2 c2,
    T3 c3,
    T4 c4,
    Action<T1, T2, T3, T4>^ onExit
)
static member OnExit :
        c1 : 'T1 *
        c2 : 'T2 *
        c3 : 'T3 *
        c4 : 'T4 *
        onExit : Action<'T1, 'T2, 'T3, 'T4> -> Scope..::.._scopeExit<'T1, 'T2, 'T3, 'T4>
static member OnExit :
        c1 : 'T1 *
        c2 : 'T2 *
        c3 : 'T3 *
        c4 : 'T4 *
        onExit : Action<'T1, 'T2, 'T3, 'T4> -> Scope..::.._scopeExit<'T1, 'T2, 'T3, 'T4>

Parameters

c1
Type: T1
c2
Type: T2
c3
Type: T3
c4
Type: T4
onExit
Type: Online System Action T1, T2, T3, T4
Type Parameters
T1
T2
T3
T4

Return Value

Type: Scope _scopeExit T1, T2, T3, T4
See Also
Scope Class
Scope Members
OnExit Overload
NFX Namespace


Scope Properties

Scope Properties NFX Class Library

The Scope type exposes the following members.
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Back to Top
See Also
Scope Class
NFX Namespace


Scope._scopeExit Structure

Scope _scopeExit Structure NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct _scopeExit : IDisposable
public struct _scopeExit : IDisposable
Public Structure _scopeExit
    Implements IDisposable
Public Structure _scopeExit
    Implements IDisposable
public value class _scopeExit : IDisposable
public value class _scopeExit : IDisposable
[<SealedAttribute>]
type _scopeExit =
    struct
        interface IDisposable
    end
[<SealedAttribute>]
type _scopeExit =
    struct
        interface IDisposable
    end
See Also
Scope _scopeExit Members
NFX Namespace


Scope._scopeExit Members

Scope _scopeExit Members NFX Class Library

The Scope _scopeExit type exposes the following members.
Constructors
 | Name | Description
Public method | Scope _scopeExit | Initializes a new instance of the Scope _scopeExit class
Back to Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the Scope _scopeExit
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Scope _scopeExit Structure
NFX Namespace


Scope._scopeExit Constructor

Scope _scopeExit Constructor NFX Class Library

Initializes a new instance of the Scope _scopeExit class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public _scopeExit(
    Action onExit
)
public _scopeExit(
    Action onExit
)
Public Sub New (
    onExit As Action
)
Public Sub New (
    onExit As Action
)
public:
_scopeExit(
    Action^ onExit
)
public:
_scopeExit(
    Action^ onExit
)
new :
        onExit : Action -> _scopeExit
new :
        onExit : Action -> _scopeExit

Parameters

onExit
Type: Online System Action
See Also
Scope _scopeExit Structure
Scope _scopeExit Members
NFX Namespace


Scope._scopeExit Methods

Scope _scopeExit Methods NFX Class Library

The Scope _scopeExit type exposes the following members.
Methods
 | Name | Description
Public method | Dispose |
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Scope _scopeExit Structure
NFX Namespace


Scope._scopeExit.Dispose Method

Scope _scopeExit Dispose Method NFX Class Library

Releases all resources used by the Scope _scopeExit

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

Online IDisposable Dispose
See Also
Scope _scopeExit Structure
Scope _scopeExit Members
NFX Namespace


Scope._scopeExit(TCtx1) Structure

Scope _scopeExit TCtx1 Structure NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct _scopeExit<TCtx1> : IDisposable
public struct _scopeExit<TCtx1> : IDisposable
Public Structure _scopeExit(Of TCtx1)
    Implements IDisposable
Public Structure _scopeExit(Of TCtx1)
    Implements IDisposable
generic<typename TCtx1>
public value class _scopeExit : IDisposable
generic<typename TCtx1>
public value class _scopeExit : IDisposable
[<SealedAttribute>]
type _scopeExit<'TCtx1> =
    struct
        interface IDisposable
    end
[<SealedAttribute>]
type _scopeExit<'TCtx1> =
    struct
        interface IDisposable
    end
Type Parameters
TCtx1
See Also
Scope _scopeExit TCtx1 Members
NFX Namespace


Scope._scopeExit(TCtx1) Members

Scope _scopeExit TCtx1 Members NFX Class Library

The Scope _scopeExit TCtx1 type exposes the following members.
Constructors
 | Name | Description
Public method | Scope _scopeExit TCtx1 | Initializes a new instance of the Scope _scopeExit TCtx1 class
Back to Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the Scope _scopeExit TCtx1
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Scope _scopeExit TCtx1 Structure
NFX Namespace


Scope._scopeExit(TCtx1) Constructor

Scope _scopeExit TCtx1 Constructor NFX Class Library

Initializes a new instance of the Scope _scopeExit TCtx1 class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public _scopeExit(
    TCtx1 ctx1,
    Action<TCtx1> onExit
)
public _scopeExit(
    TCtx1 ctx1,
    Action<TCtx1> onExit
)
Public Sub New (
    ctx1 As TCtx1,
    onExit As Action(Of TCtx1)
)
Public Sub New (
    ctx1 As TCtx1,
    onExit As Action(Of TCtx1)
)
public:
_scopeExit(
    TCtx1 ctx1,
    Action<TCtx1>^ onExit
)
public:
_scopeExit(
    TCtx1 ctx1,
    Action<TCtx1>^ onExit
)
new :
        ctx1 : 'TCtx1 *
        onExit : Action<'TCtx1> -> _scopeExit
new :
        ctx1 : 'TCtx1 *
        onExit : Action<'TCtx1> -> _scopeExit

Parameters

ctx1
Type: TCtx1
onExit
Type: Online System Action TCtx1
See Also
Scope _scopeExit TCtx1 Structure
Scope _scopeExit TCtx1 Members
NFX Namespace


Scope._scopeExit(TCtx1) Methods

Scope _scopeExit TCtx1 Methods NFX Class Library

The Scope _scopeExit TCtx1 type exposes the following members.
Methods
 | Name | Description
Public method | Dispose |
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Scope _scopeExit TCtx1 Structure
NFX Namespace


Scope._scopeExit(TCtx1).Dispose Method

Scope _scopeExit TCtx1 Dispose Method NFX Class Library

Releases all resources used by the Scope _scopeExit TCtx1

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

Online IDisposable Dispose
See Also
Scope _scopeExit TCtx1 Structure
Scope _scopeExit TCtx1 Members
NFX Namespace


Scope._scopeExit(TCtx1, TCtx2) Structure

Scope _scopeExit TCtx1, TCtx2 Structure NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct _scopeExit<TCtx1, TCtx2> : IDisposable
public struct _scopeExit<TCtx1, TCtx2> : IDisposable
Public Structure _scopeExit(Of TCtx1, TCtx2)
    Implements IDisposable
Public Structure _scopeExit(Of TCtx1, TCtx2)
    Implements IDisposable
generic<typename TCtx1, typename TCtx2>
public value class _scopeExit : IDisposable
generic<typename TCtx1, typename TCtx2>
public value class _scopeExit : IDisposable
[<SealedAttribute>]
type _scopeExit<'TCtx1, 'TCtx2> =
    struct
        interface IDisposable
    end
[<SealedAttribute>]
type _scopeExit<'TCtx1, 'TCtx2> =
    struct
        interface IDisposable
    end
Type Parameters
TCtx1
TCtx2
See Also
Scope _scopeExit TCtx1, TCtx2 Members
NFX Namespace


Scope._scopeExit(TCtx1, TCtx2) Members

Scope _scopeExit TCtx1, TCtx2 Members NFX Class Library

The Scope _scopeExit TCtx1, TCtx2 type exposes the following members.
Constructors
 | Name | Description
Public method | Scope _scopeExit TCtx1, TCtx2 | Initializes a new instance of the Scope _scopeExit TCtx1, TCtx2 class
Back to Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the Scope _scopeExit TCtx1, TCtx2
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Scope _scopeExit TCtx1, TCtx2 Structure
NFX Namespace


Scope._scopeExit(TCtx1, TCtx2) Constructor

Scope _scopeExit TCtx1, TCtx2 Constructor NFX Class Library

Initializes a new instance of the Scope _scopeExit TCtx1, TCtx2 class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public _scopeExit(
    TCtx1 ctx1,
    TCtx2 ctx2,
    Action<TCtx1, TCtx2> onExit
)
public _scopeExit(
    TCtx1 ctx1,
    TCtx2 ctx2,
    Action<TCtx1, TCtx2> onExit
)
Public Sub New (
    ctx1 As TCtx1,
    ctx2 As TCtx2,
    onExit As Action(Of TCtx1, TCtx2)
)
Public Sub New (
    ctx1 As TCtx1,
    ctx2 As TCtx2,
    onExit As Action(Of TCtx1, TCtx2)
)
public:
_scopeExit(
    TCtx1 ctx1,
    TCtx2 ctx2,
    Action<TCtx1, TCtx2>^ onExit
)
public:
_scopeExit(
    TCtx1 ctx1,
    TCtx2 ctx2,
    Action<TCtx1, TCtx2>^ onExit
)
new :
        ctx1 : 'TCtx1 *
        ctx2 : 'TCtx2 *
        onExit : Action<'TCtx1, 'TCtx2> -> _scopeExit
new :
        ctx1 : 'TCtx1 *
        ctx2 : 'TCtx2 *
        onExit : Action<'TCtx1, 'TCtx2> -> _scopeExit

Parameters

ctx1
Type: TCtx1
ctx2
Type: TCtx2
onExit
Type: Online System Action TCtx1, TCtx2
See Also
Scope _scopeExit TCtx1, TCtx2 Structure
Scope _scopeExit TCtx1, TCtx2 Members
NFX Namespace


Scope._scopeExit(TCtx1, TCtx2) Methods

Scope _scopeExit TCtx1, TCtx2 Methods NFX Class Library

The Scope _scopeExit TCtx1, TCtx2 type exposes the following members.
Methods
 | Name | Description
Public method | Dispose |
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Scope _scopeExit TCtx1, TCtx2 Structure
NFX Namespace


Scope._scopeExit(TCtx1, TCtx2).Dispose Method

Scope _scopeExit TCtx1, TCtx2 Dispose Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Releases all resources used by the Scope _scopeExit TCtx1, TCtx2

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

Online IDisposable Dispose
See Also
Scope _scopeExit TCtx1, TCtx2 Structure
Scope _scopeExit TCtx1, TCtx2 Members
NFX Namespace


Scope._scopeExit(TCtx1, TCtx2, TCtx3) Structure

Scope _scopeExit TCtx1, TCtx2, TCtx3 Structure NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct _scopeExit<TCtx1, TCtx2, TCtx3> : IDisposable
public struct _scopeExit<TCtx1, TCtx2, TCtx3> : IDisposable
Public Structure _scopeExit(Of TCtx1, TCtx2, TCtx3)
    Implements IDisposable
Public Structure _scopeExit(Of TCtx1, TCtx2, TCtx3)
    Implements IDisposable
generic<typename TCtx1, typename TCtx2, typename TCtx3>
public value class _scopeExit : IDisposable
generic<typename TCtx1, typename TCtx2, typename TCtx3>
public value class _scopeExit : IDisposable
[<SealedAttribute>]
type _scopeExit<'TCtx1, 'TCtx2, 'TCtx3> =
    struct
        interface IDisposable
    end
[<SealedAttribute>]
type _scopeExit<'TCtx1, 'TCtx2, 'TCtx3> =
    struct
        interface IDisposable
    end
Type Parameters
TCtx1
TCtx2
TCtx3
See Also
Scope _scopeExit TCtx1, TCtx2, TCtx3 Members
NFX Namespace


Scope._scopeExit(TCtx1, TCtx2, TCtx3) Members

Scope _scopeExit TCtx1, TCtx2, TCtx3 Members NFX Class Library

[This is preliminary documentation and is subject to change.]

The Scope _scopeExit TCtx1, TCtx2, TCtx3 type exposes the following members.
Constructors
 | Name | Description
Public method | Scope _scopeExit TCtx1, TCtx2, TCtx3 | Initializes a new instance of the Scope _scopeExit TCtx1, TCtx2, TCtx3 class
Back to Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the Scope _scopeExit TCtx1, TCtx2, TCtx3
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Scope _scopeExit TCtx1, TCtx2, TCtx3 Structure
NFX Namespace


Scope._scopeExit(TCtx1, TCtx2, TCtx3) Constructor

Scope _scopeExit TCtx1, TCtx2, TCtx3 Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Scope _scopeExit TCtx1, TCtx2, TCtx3 class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public _scopeExit(
    TCtx1 ctx1,
    TCtx2 ctx2,
    TCtx3 ctx3,
    Action<TCtx1, TCtx2, TCtx3> onExit
)
public _scopeExit(
    TCtx1 ctx1,
    TCtx2 ctx2,
    TCtx3 ctx3,
    Action<TCtx1, TCtx2, TCtx3> onExit
)
Public Sub New (
    ctx1 As TCtx1,
    ctx2 As TCtx2,
    ctx3 As TCtx3,
    onExit As Action(Of TCtx1, TCtx2, TCtx3)
)
Public Sub New (
    ctx1 As TCtx1,
    ctx2 As TCtx2,
    ctx3 As TCtx3,
    onExit As Action(Of TCtx1, TCtx2, TCtx3)
)
public:
_scopeExit(
    TCtx1 ctx1,
    TCtx2 ctx2,
    TCtx3 ctx3,
    Action<TCtx1, TCtx2, TCtx3>^ onExit
)
public:
_scopeExit(
    TCtx1 ctx1,
    TCtx2 ctx2,
    TCtx3 ctx3,
    Action<TCtx1, TCtx2, TCtx3>^ onExit
)
new :
        ctx1 : 'TCtx1 *
        ctx2 : 'TCtx2 *
        ctx3 : 'TCtx3 *
        onExit : Action<'TCtx1, 'TCtx2, 'TCtx3> -> _scopeExit
new :
        ctx1 : 'TCtx1 *
        ctx2 : 'TCtx2 *
        ctx3 : 'TCtx3 *
        onExit : Action<'TCtx1, 'TCtx2, 'TCtx3> -> _scopeExit

Parameters

ctx1
Type: TCtx1
ctx2
Type: TCtx2
ctx3
Type: TCtx3
onExit
Type: Online System Action TCtx1, TCtx2, TCtx3
See Also
Scope _scopeExit TCtx1, TCtx2, TCtx3 Structure
Scope _scopeExit TCtx1, TCtx2, TCtx3 Members
NFX Namespace


Scope._scopeExit(TCtx1, TCtx2, TCtx3) Methods

Scope _scopeExit TCtx1, TCtx2, TCtx3 Methods NFX Class Library

[This is preliminary documentation and is subject to change.]

The Scope _scopeExit TCtx1, TCtx2, TCtx3 type exposes the following members.
Methods
 | Name | Description
Public method | Dispose |
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Scope _scopeExit TCtx1, TCtx2, TCtx3 Structure
NFX Namespace


Scope._scopeExit(TCtx1, TCtx2, TCtx3).Dispose Method

Scope _scopeExit TCtx1, TCtx2, TCtx3 Dispose Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Releases all resources used by the Scope _scopeExit TCtx1, TCtx2, TCtx3

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

Online IDisposable Dispose
See Also
Scope _scopeExit TCtx1, TCtx2, TCtx3 Structure
Scope _scopeExit TCtx1, TCtx2, TCtx3 Members
NFX Namespace


Scope._scopeExit(TCtx1, TCtx2, TCtx3, TCtx4) Structure

Scope _scopeExit TCtx1, TCtx2, TCtx3, TCtx4 Structure NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct _scopeExit<TCtx1, TCtx2, TCtx3, TCtx4> : IDisposable
public struct _scopeExit<TCtx1, TCtx2, TCtx3, TCtx4> : IDisposable
Public Structure _scopeExit(Of TCtx1, TCtx2, TCtx3, TCtx4)
    Implements IDisposable
Public Structure _scopeExit(Of TCtx1, TCtx2, TCtx3, TCtx4)
    Implements IDisposable
generic<typename TCtx1, typename TCtx2, typename TCtx3, typename TCtx4>
public value class _scopeExit : IDisposable
generic<typename TCtx1, typename TCtx2, typename TCtx3, typename TCtx4>
public value class _scopeExit : IDisposable
[<SealedAttribute>]
type _scopeExit<'TCtx1, 'TCtx2, 'TCtx3, 'TCtx4> =
    struct
        interface IDisposable
    end
[<SealedAttribute>]
type _scopeExit<'TCtx1, 'TCtx2, 'TCtx3, 'TCtx4> =
    struct
        interface IDisposable
    end
Type Parameters
TCtx1
TCtx2
TCtx3
TCtx4
See Also
Scope _scopeExit TCtx1, TCtx2, TCtx3, TCtx4 Members
NFX Namespace


Scope._scopeExit(TCtx1, TCtx2, TCtx3, TCtx4) Members

Scope _scopeExit TCtx1, TCtx2, TCtx3, TCtx4 Members NFX Class Library

[This is preliminary documentation and is subject to change.]

The Scope _scopeExit TCtx1, TCtx2, TCtx3, TCtx4 type exposes the following members.
Constructors
 | Name | Description
Public method | Scope _scopeExit TCtx1, TCtx2, TCtx3, TCtx4 | Initializes a new instance of the Scope _scopeExit TCtx1, TCtx2, TCtx3, TCtx4 class
Back to Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the Scope _scopeExit TCtx1, TCtx2, TCtx3, TCtx4
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Scope _scopeExit TCtx1, TCtx2, TCtx3, TCtx4 Structure
NFX Namespace


Scope._scopeExit(TCtx1, TCtx2, TCtx3, TCtx4) Constructor

Scope _scopeExit TCtx1, TCtx2, TCtx3, TCtx4 Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Scope _scopeExit TCtx1, TCtx2, TCtx3, TCtx4 class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public _scopeExit(
    TCtx1 c1,
    TCtx2 c2,
    TCtx3 c3,
    TCtx4 c4,
    Action<TCtx1, TCtx2, TCtx3, TCtx4> onExit
)
public _scopeExit(
    TCtx1 c1,
    TCtx2 c2,
    TCtx3 c3,
    TCtx4 c4,
    Action<TCtx1, TCtx2, TCtx3, TCtx4> onExit
)
Public Sub New (
    c1 As TCtx1,
    c2 As TCtx2,
    c3 As TCtx3,
    c4 As TCtx4,
    onExit As Action(Of TCtx1, TCtx2, TCtx3, TCtx4)
)
Public Sub New (
    c1 As TCtx1,
    c2 As TCtx2,
    c3 As TCtx3,
    c4 As TCtx4,
    onExit As Action(Of TCtx1, TCtx2, TCtx3, TCtx4)
)
public:
_scopeExit(
    TCtx1 c1,
    TCtx2 c2,
    TCtx3 c3,
    TCtx4 c4,
    Action<TCtx1, TCtx2, TCtx3, TCtx4>^ onExit
)
public:
_scopeExit(
    TCtx1 c1,
    TCtx2 c2,
    TCtx3 c3,
    TCtx4 c4,
    Action<TCtx1, TCtx2, TCtx3, TCtx4>^ onExit
)
new :
        c1 : 'TCtx1 *
        c2 : 'TCtx2 *
        c3 : 'TCtx3 *
        c4 : 'TCtx4 *
        onExit : Action<'TCtx1, 'TCtx2, 'TCtx3, 'TCtx4> -> _scopeExit
new :
        c1 : 'TCtx1 *
        c2 : 'TCtx2 *
        c3 : 'TCtx3 *
        c4 : 'TCtx4 *
        onExit : Action<'TCtx1, 'TCtx2, 'TCtx3, 'TCtx4> -> _scopeExit

Parameters

c1
Type: TCtx1
c2
Type: TCtx2
c3
Type: TCtx3
c4
Type: TCtx4
onExit
Type: Online System Action TCtx1, TCtx2, TCtx3, TCtx4
See Also
Scope _scopeExit TCtx1, TCtx2, TCtx3, TCtx4 Structure
Scope _scopeExit TCtx1, TCtx2, TCtx3, TCtx4 Members
NFX Namespace


Scope._scopeExit(TCtx1, TCtx2, TCtx3, TCtx4) Methods

Scope _scopeExit TCtx1, TCtx2, TCtx3, TCtx4 Methods NFX Class Library

[This is preliminary documentation and is subject to change.]

The Scope _scopeExit TCtx1, TCtx2, TCtx3, TCtx4 type exposes the following members.
Methods
 | Name | Description
Public method | Dispose |
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Scope _scopeExit TCtx1, TCtx2, TCtx3, TCtx4 Structure
NFX Namespace


Scope._scopeExit(TCtx1, TCtx2, TCtx3, TCtx4).Dispose Method

Scope _scopeExit TCtx1, TCtx2, TCtx3, TCtx4 Dispose Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Releases all resources used by the Scope _scopeExit TCtx1, TCtx2, TCtx3, TCtx4

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

Online IDisposable Dispose
See Also
Scope _scopeExit TCtx1, TCtx2, TCtx3, TCtx4 Structure
Scope _scopeExit TCtx1, TCtx2, TCtx3, TCtx4 Members
NFX Namespace


SealedString Structure

SealedString Structure NFX Class Library

Represents an immutable string data that is stored in an efficient way that relieves the GC pressure. The string can not be changed or deleted. Once created it stays as-is until the process is terminated. This structure is used to store much dictionary data (100s of millions of strings) in the process without causing GC overload. Note: The default .ctor DOES NOT check whether the same string is already present in memory. Use SealedString.Scope to store unique strings only (do not store the repetitions). This struct is THREAD SAFE and NOT SERIALIZABLE.

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SlimSerializationProhibitedAttribute]
public struct SealedString : IEquatable<SealedString>
[SlimSerializationProhibitedAttribute]
public struct SealedString : IEquatable<SealedString>
<SlimSerializationProhibitedAttribute>
Public Structure SealedString
    Implements IEquatable(Of SealedString)
<SlimSerializationProhibitedAttribute>
Public Structure SealedString
    Implements IEquatable(Of SealedString)
[SlimSerializationProhibitedAttribute]
public value class SealedString : IEquatable<SealedString>
[SlimSerializationProhibitedAttribute]
public value class SealedString : IEquatable<SealedString>
[<SealedAttribute>]
[<SlimSerializationProhibitedAttribute>]
type SealedString =
    struct
        interface IEquatable<SealedString>
    end
[<SealedAttribute>]
[<SlimSerializationProhibitedAttribute>]
type SealedString =
    struct
        interface IEquatable<SealedString>
    end
See Also
SealedString Members
NFX Namespace


SealedString Members

SealedString Members NFX Class Library

The SealedString type exposes the following members.
Constructors
 | Name | Description
Public method | SealedString | Creates a sealed copy of string data. This .ctor DOES NOT check whether this string was already sealed
Back to Top
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(SealedString) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Operators
Name | Description
Equality |
Inequality |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Address |
Public field | Segment |
Back to Top
Properties
 | Name | Description
Public property | IsAssigned | Returns true if this instance represents an assigned valid string (is not equal to Unassigned)
 | TotalBytesAllocated | Returns the total number of bytes allocated
 | TotalBytesUsed | Returns the total number of bytes used
 | TotalCount | Returns the total count of strings allocated
 | TotalSegmentCount | Total number of segments
 | Unassigned | Returns a SealedString that is IsAssigned==false - a special invalid value
Public property | Value | Returns the original string copy
Back to Top
See Also
SealedString Structure
NFX Namespace


SealedString Constructor

SealedString Constructor NFX Class Library

Creates a sealed copy of string data. This .ctor DOES NOT check whether this string was already sealed

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SealedString(
    string value
)
public SealedString(
    string value
)
Public Sub New (
    value As String
)
Public Sub New (
    value As String
)
public:
SealedString(
    String^ value
)
public:
SealedString(
    String^ value
)
new :
        value : string -> SealedString
new :
        value : string -> SealedString

Parameters

value
Type: Online System String
See Also
SealedString Structure
SealedString Members
NFX Namespace


SealedString Fields

SealedString Fields NFX Class Library

The SealedString type exposes the following members.
Fields
 | Name | Description
Public field | Address |
Public field | Segment |
Back to Top
See Also
SealedString Structure
NFX Namespace


SealedString.Address Field

SealedString Address Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Address
public readonly int Address
Public ReadOnly Address As Integer
Public ReadOnly Address As Integer
public:
initonly int Address
public:
initonly int Address
val Address: int
val Address: int

Field Value

Type: Online Int32
See Also
SealedString Structure
SealedString Members
NFX Namespace


SealedString.Segment Field

SealedString Segment Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ushort Segment
public readonly ushort Segment
Public ReadOnly Segment As UShort
Public ReadOnly Segment As UShort
public:
initonly unsigned short Segment
public:
initonly unsigned short Segment
val Segment: uint16
val Segment: uint16

Field Value

Type: Online UInt16
See Also
SealedString Structure
SealedString Members
NFX Namespace


SealedString Methods

SealedString Methods NFX Class Library

The SealedString type exposes the following members.
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(SealedString) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SealedString Structure
NFX Namespace


SealedString.Equals Method

SealedString Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(SealedString) |
Back to Top
See Also
SealedString Structure
SealedString Members
NFX Namespace


SealedString.Equals Method (Object)

SealedString Equals Method (Object) NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
SealedString Structure
SealedString Members
Equals Overload
NFX Namespace


SealedString.Equals Method (SealedString)

SealedString Equals Method (SealedString) NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    SealedString other
)
public bool Equals(
    SealedString other
)
Public Function Equals (
    other As SealedString
) As Boolean
Public Function Equals (
    other As SealedString
) As Boolean
public:
virtual bool Equals(
    SealedString other
) sealed
public:
virtual bool Equals(
    SealedString other
) sealed
abstract Equals :
        other : SealedString -> bool
override Equals :
        other : SealedString -> bool
abstract Equals :
        other : SealedString -> bool
override Equals :
        other : SealedString -> bool

Parameters

other
Type: NFX SealedString

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
SealedString Structure
SealedString Members
Equals Overload
NFX Namespace


SealedString.GetHashCode Method

SealedString GetHashCode Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
SealedString Structure
SealedString Members
NFX Namespace


SealedString.ToString Method

SealedString ToString Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
SealedString Structure
SealedString Members
NFX Namespace


SealedString Operators

SealedString Operators NFX Class Library

The SealedString type exposes the following members.
Operators
Name | Description
Equality |
Inequality |
Back to Top
See Also
SealedString Structure
NFX Namespace


SealedString.Equality Operator

SealedString Equality Operator NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    SealedString l,
    SealedString r
)
public static bool operator ==(
    SealedString l,
    SealedString r
)
Public Shared Operator = (
    l As SealedString,
    r As SealedString
) As Boolean
Public Shared Operator = (
    l As SealedString,
    r As SealedString
) As Boolean
public:
static bool operator ==(
    SealedString l,
    SealedString r
)
public:
static bool operator ==(
    SealedString l,
    SealedString r
)
static let inline (=)
        l : SealedString *
        r : SealedString  : bool
static let inline (=)
        l : SealedString *
        r : SealedString  : bool

Parameters

l
Type: NFX SealedString
r
Type: NFX SealedString

Return Value

Type: Online Boolean
See Also
SealedString Structure
SealedString Members
NFX Namespace


SealedString.Inequality Operator

SealedString Inequality Operator NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    SealedString l,
    SealedString r
)
public static bool operator !=(
    SealedString l,
    SealedString r
)
Public Shared Operator <> (
    l As SealedString,
    r As SealedString
) As Boolean
Public Shared Operator <> (
    l As SealedString,
    r As SealedString
) As Boolean
public:
static bool operator !=(
    SealedString l,
    SealedString r
)
public:
static bool operator !=(
    SealedString l,
    SealedString r
)
static let inline (<>)
        l : SealedString *
        r : SealedString  : bool
static let inline (<>)
        l : SealedString *
        r : SealedString  : bool

Parameters

l
Type: NFX SealedString
r
Type: NFX SealedString

Return Value

Type: Online Boolean
See Also
SealedString Structure
SealedString Members
NFX Namespace


SealedString Properties

SealedString Properties NFX Class Library

The SealedString type exposes the following members.
Properties
 | Name | Description
Public property | IsAssigned | Returns true if this instance represents an assigned valid string (is not equal to Unassigned)
 | TotalBytesAllocated | Returns the total number of bytes allocated
 | TotalBytesUsed | Returns the total number of bytes used
 | TotalCount | Returns the total count of strings allocated
 | TotalSegmentCount | Total number of segments
 | Unassigned | Returns a SealedString that is IsAssigned==false - a special invalid value
Public property | Value | Returns the original string copy
Back to Top
See Also
SealedString Structure
NFX Namespace


SealedString.IsAssigned Property

SealedString IsAssigned Property NFX Class Library

Returns true if this instance represents an assigned valid string (is not equal to Unassigned)

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsAssigned { get; }
public bool IsAssigned { get; }
Public ReadOnly Property IsAssigned As Boolean
    Get
Public ReadOnly Property IsAssigned As Boolean
    Get
public:
property bool IsAssigned {
    bool get ();
}
public:
property bool IsAssigned {
    bool get ();
}
member IsAssigned : bool with get
member IsAssigned : bool with get

Property Value

Type: Online Boolean
See Also
SealedString Structure
SealedString Members
NFX Namespace


SealedString.TotalBytesAllocated Property

SealedString TotalBytesAllocated Property NFX Class Library

Returns the total number of bytes allocated

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long TotalBytesAllocated { get; }
public static long TotalBytesAllocated { get; }
Public Shared ReadOnly Property TotalBytesAllocated As Long
    Get
Public Shared ReadOnly Property TotalBytesAllocated As Long
    Get
public:
static property long long TotalBytesAllocated {
    long long get ();
}
public:
static property long long TotalBytesAllocated {
    long long get ();
}
static member TotalBytesAllocated : int64 with get
static member TotalBytesAllocated : int64 with get

Property Value

Type: Online Int64
See Also
SealedString Structure
SealedString Members
NFX Namespace


SealedString.TotalBytesUsed Property

SealedString TotalBytesUsed Property NFX Class Library

Returns the total number of bytes used

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long TotalBytesUsed { get; }
public static long TotalBytesUsed { get; }
Public Shared ReadOnly Property TotalBytesUsed As Long
    Get
Public Shared ReadOnly Property TotalBytesUsed As Long
    Get
public:
static property long long TotalBytesUsed {
    long long get ();
}
public:
static property long long TotalBytesUsed {
    long long get ();
}
static member TotalBytesUsed : int64 with get
static member TotalBytesUsed : int64 with get

Property Value

Type: Online Int64
See Also
SealedString Structure
SealedString Members
NFX Namespace


SealedString.TotalCount Property

SealedString TotalCount Property NFX Class Library

Returns the total count of strings allocated

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long TotalCount { get; }
public static long TotalCount { get; }
Public Shared ReadOnly Property TotalCount As Long
    Get
Public Shared ReadOnly Property TotalCount As Long
    Get
public:
static property long long TotalCount {
    long long get ();
}
public:
static property long long TotalCount {
    long long get ();
}
static member TotalCount : int64 with get
static member TotalCount : int64 with get

Property Value

Type: Online Int64
See Also
SealedString Structure
SealedString Members
NFX Namespace


SealedString.TotalSegmentCount Property

SealedString TotalSegmentCount Property NFX Class Library

Total number of segments

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int TotalSegmentCount { get; }
public static int TotalSegmentCount { get; }
Public Shared ReadOnly Property TotalSegmentCount As Integer
    Get
Public Shared ReadOnly Property TotalSegmentCount As Integer
    Get
public:
static property int TotalSegmentCount {
    int get ();
}
public:
static property int TotalSegmentCount {
    int get ();
}
static member TotalSegmentCount : int with get
static member TotalSegmentCount : int with get

Property Value

Type: Online Int32
See Also
SealedString Structure
SealedString Members
NFX Namespace


SealedString.Unassigned Property

SealedString Unassigned Property NFX Class Library

Returns a SealedString that is IsAssigned==false - a special invalid value

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static SealedString Unassigned { get; }
public static SealedString Unassigned { get; }
Public Shared ReadOnly Property Unassigned As SealedString
    Get
Public Shared ReadOnly Property Unassigned As SealedString
    Get
public:
static property SealedString Unassigned {
    SealedString get ();
}
public:
static property SealedString Unassigned {
    SealedString get ();
}
static member Unassigned : SealedString with get
static member Unassigned : SealedString with get

Property Value

Type: SealedString
See Also
SealedString Structure
SealedString Members
NFX Namespace


SealedString.Value Property

SealedString Value Property NFX Class Library

Returns the original string copy

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Value { get; }
public string Value { get; }
Public ReadOnly Property Value As String
    Get
Public ReadOnly Property Value As String
    Get
public:
property String^ Value {
    String^ get ();
}
public:
property String^ Value {
    String^ get ();
}
member Value : string with get
member Value : string with get

Property Value

Type: Online String
See Also
SealedString Structure
SealedString Members
NFX Namespace


SealedString.Scope Class

SealedString Scope Class NFX Class Library

Represents a scope of a SealedString creation that tracks the existing strings. Use Seal(string) to get an existing string or create a new one. Do not persist the instance of Scope for a long time as it accumulates references (string keys) that pressure the GC. This class is used in batched that create many sealed strings. Once those strings rae created the scope can be released.
Inheritance Hierarchy
Online System Object
NFX SealedString Scope

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Scope
public class Scope
Public Class Scope
Public Class Scope
public ref class Scope
public ref class Scope
type Scope =  class end
type Scope =  class end
See Also
SealedString Scope Members
NFX Namespace


SealedString.Scope Members

SealedString Scope Members NFX Class Library

The SealedString Scope type exposes the following members.
Constructors
 | Name | Description
Public method | SealedString Scope | Create a Scope with InvariantCultureIgnoreCase comparer
Public method | SealedString Scope(StringComparer) | Create a Scope with the specified comparer or InvariantCultureIgnoreCase comparer if the supplied one is null
Back to Top
Methods
 | Name | Description
Public method | Contains | Returns true if a unique string is in the scope
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Seal(String) | Returns an existing SealedString instance for existing data or allocates a new one. This method is thread-safe
Public method | Seal(String, Boolean ) | Returns an existing SealedString instance for existing data or allocates a new one. This method is thread-safe
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns the number of unique strings in scope
Public property | Item | Returns a SealedString for an existing key in scope or SealedString.Unassigned for a non-exisiting string
Back to Top
See Also
SealedString Scope Class
NFX Namespace


SealedString.Scope Constructor

SealedString Scope Constructor NFX Class Library

Overload List
 | Name | Description
Public method | SealedString Scope | Create a Scope with InvariantCultureIgnoreCase comparer
Public method | SealedString Scope(StringComparer) | Create a Scope with the specified comparer or InvariantCultureIgnoreCase comparer if the supplied one is null
Back to Top
See Also
SealedString Scope Class
SealedString Scope Members
NFX Namespace


SealedString.Scope Constructor

SealedString Scope Constructor NFX Class Library

Create a Scope with InvariantCultureIgnoreCase comparer

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Scope()
public Scope()
Public Sub New
Public Sub New
public:
Scope()
public:
Scope()
new : unit -> Scope
new : unit -> Scope
See Also
SealedString Scope Class
SealedString Scope Members
SealedString Scope Overload
NFX Namespace


SealedString.Scope Constructor (StringComparer)

SealedString Scope Constructor (StringComparer) NFX Class Library

[This is preliminary documentation and is subject to change.]

Create a Scope with the specified comparer or InvariantCultureIgnoreCase comparer if the supplied one is null

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Scope(
    StringComparer comparer
)
public Scope(
    StringComparer comparer
)
Public Sub New (
    comparer As StringComparer
)
Public Sub New (
    comparer As StringComparer
)
public:
Scope(
    StringComparer^ comparer
)
public:
Scope(
    StringComparer^ comparer
)
new :
        comparer : StringComparer -> Scope
new :
        comparer : StringComparer -> Scope

Parameters

comparer
Type: Online System StringComparer
See Also
SealedString Scope Class
SealedString Scope Members
SealedString Scope Overload
NFX Namespace


SealedString.Scope Methods

SealedString Scope Methods NFX Class Library

The SealedString Scope type exposes the following members.
Methods
 | Name | Description
Public method | Contains | Returns true if a unique string is in the scope
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Seal(String) | Returns an existing SealedString instance for existing data or allocates a new one. This method is thread-safe
Public method | Seal(String, Boolean ) | Returns an existing SealedString instance for existing data or allocates a new one. This method is thread-safe
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SealedString Scope Class
NFX Namespace


SealedString.Scope.Contains Method

SealedString Scope Contains Method NFX Class Library

Returns true if a unique string is in the scope

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Contains(
    string value
)
public bool Contains(
    string value
)
Public Function Contains (
    value As String
) As Boolean
Public Function Contains (
    value As String
) As Boolean
public:
bool Contains(
    String^ value
)
public:
bool Contains(
    String^ value
)
member Contains :
        value : string -> bool
member Contains :
        value : string -> bool

Parameters

value
Type: Online System String

Return Value

Type: Online Boolean
See Also
SealedString Scope Class
SealedString Scope Members
NFX Namespace


SealedString.Scope.Seal Method

SealedString Scope Seal Method NFX Class Library

Overload List
 | Name | Description
Public method | Seal(String) | Returns an existing SealedString instance for existing data or allocates a new one. This method is thread-safe
Public method | Seal(String, Boolean ) | Returns an existing SealedString instance for existing data or allocates a new one. This method is thread-safe
Back to Top
See Also
SealedString Scope Class
SealedString Scope Members
NFX Namespace


SealedString.Scope.Seal Method (String)

SealedString Scope Seal Method (String) NFX Class Library

Returns an existing SealedString instance for existing data or allocates a new one. This method is thread-safe

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SealedString Seal(
    string value
)
public SealedString Seal(
    string value
)
Public Function Seal (
    value As String
) As SealedString
Public Function Seal (
    value As String
) As SealedString
public:
SealedString Seal(
    String^ value
)
public:
SealedString Seal(
    String^ value
)
member Seal :
        value : string -> SealedString
member Seal :
        value : string -> SealedString

Parameters

value
Type: Online System String

Return Value

Type: SealedString
See Also
SealedString Scope Class
SealedString Scope Members
Seal Overload
NFX Namespace


SealedString.Scope.Seal Method (String, Boolean)

SealedString Scope Seal Method (String, Boolean ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns an existing SealedString instance for existing data or allocates a new one. This method is thread-safe

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SealedString Seal(
    string value,
    out bool existed
)
public SealedString Seal(
    string value,
    out bool existed
)
Public Function Seal (
    value As String,
    <OutAttribute> ByRef existed As Boolean
) As SealedString
Public Function Seal (
    value As String,
    <OutAttribute> ByRef existed As Boolean
) As SealedString
public:
SealedString Seal(
    String^ value,
    [OutAttribute] bool% existed
)
public:
SealedString Seal(
    String^ value,
    [OutAttribute] bool% existed
)
member Seal :
        value : string *
        existed : bool byref -> SealedString
member Seal :
        value : string *
        existed : bool byref -> SealedString

Parameters

value
Type: Online System String
existed
Type: Online System Boolean

Return Value

Type: SealedString
See Also
SealedString Scope Class
SealedString Scope Members
Seal Overload
NFX Namespace


SealedString.Scope Properties

SealedString Scope Properties NFX Class Library

The SealedString Scope type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns the number of unique strings in scope
Public property | Item | Returns a SealedString for an existing key in scope or SealedString.Unassigned for a non-exisiting string
Back to Top
See Also
SealedString Scope Class
NFX Namespace


SealedString.Scope.Count Property

SealedString Scope Count Property NFX Class Library

Returns the number of unique strings in scope

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
public:
property int Count {
    int get ();
}
member Count : int with get
member Count : int with get

Property Value

Type: Online Int32
See Also
SealedString Scope Class
SealedString Scope Members
NFX Namespace


SealedString.Scope.Item Property

SealedString Scope Item Property NFX Class Library

Returns a SealedString for an existing key in scope or SealedString.Unassigned for a non-exisiting string

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SealedString this[
    string value
] { get; }
public SealedString this[
    string value
] { get; }
Public ReadOnly Default Property Item (
    value As String
) As SealedString
    Get
Public ReadOnly Default Property Item (
    value As String
) As SealedString
    Get
public:
property SealedString default[String^ value] {
    SealedString get (String^ value);
}
public:
property SealedString default[String^ value] {
    SealedString get (String^ value);
}
member Item : SealedString with get
member Item : SealedString with get

Parameters

value
Type: Online System String

Property Value

Type: SealedString
See Also
SealedString Scope Class
SealedString Scope Members
NFX Namespace


StringConsts Class

StringConsts Class NFX Class Library

A dictionary of framework text messages. Localization may be done in this class in future
Inheritance Hierarchy
Online System Object
NFX StringConsts

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static class StringConsts
internal static class StringConsts
Friend NotInheritable Class StringConsts
Friend NotInheritable Class StringConsts
internal ref class StringConsts abstract sealed
internal ref class StringConsts abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StringConsts =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StringConsts =  class end
See Also
StringConsts Members
NFX Namespace


StringConsts Members

StringConsts Members NFX Class Library

The StringConsts type exposes the following members.
Fields
Name | Description
APP_APPLY_BEHAVIORS_ERROR |
APP_ASSEMBLY_PRELOAD_ERROR |
APP_CONFIG_SETTING_NOT_FOUND_ERROR |
APP_DATA_STORE_INIT_ERROR |
APP_EVENT_TIMER_INIT_ERROR |
APP_FINISH_NOTIFIABLE_AFTER_ERROR |
APP_FINISH_NOTIFIABLE_BEFORE_ERROR |
APP_FINISH_NOTIFIABLES_ERROR |
APP_FORMS_FACTORY_INIT_ERROR |
APP_GLUE_INIT_ERROR |
APP_INJECTION_TYPE_MISMATCH_ERROR |
APP_INSTRUMENTATION_INIT_ERROR |
APP_IS_NOT_EXPECTED_TYPE_ERROR |
APP_LOG_INIT_ERROR |
APP_OBJECT_STORE_INIT_ERROR |
APP_SECURITY_MANAGER_INIT_ERROR |
APP_STARTER_AFTER_ERROR |
APP_STARTER_BEFORE_ERROR |
APP_THROTTLING_INIT_ERROR |
APP_TIMESOURCE_INIT_ERROR |
APPLY_RECORD_CHANGES_ERROR |
ARGUMENT_ERROR |
AROW_DESER_CORRUPT_ERROR |
AROW_GENERATOR_PATH_DOESNOT_EXIST_ERROR |
AROW_HEADER_CORRUPT_ERROR |
AROW_INVALID_FIELD_NAME_ERROR |
AROW_MAX_ARRAY_LEN_ERROR |
AROW_MEMBER_TYPE_NOT_SUPPORTED_ERROR |
AROW_TYPE_NOT_SUPPORTED_ERROR |
ASSERTION_ERROR |
BINLOG_BAD_READER_TYPE_ERROR |
BINLOG_READER_FACTORY_ERROR |
BINLOG_READER_TYPE_MISMATCH_ERROR |
BINLOG_STREAM_CANT_SEEK_WRITE_ERROR |
BINLOG_STREAM_CORRUPTED_ERROR |
BINLOG_STREAM_NULL_ERROR |
BSON_ARRAY_ELM_DOC_ERROR |
BSON_ARRAY_ELM_NAME_ERROR |
BSON_DECIMAL_INT32_INT64_CONVERTION_ERROR |
BSON_DOCUMENT_RECURSION_ERROR |
BSON_DOCUMENT_SIZE_EXCEEDED_ERROR |
BSON_ELEMENT_OBJECT_VALUE_SET_ERROR |
BSON_EOD_ERROR |
BSON_INCORRECT_STRING_LENGTH_ERROR |
BSON_NAMED_ELEMENT_ADDED_ERROR |
BSON_OBJECTID_LENGTH_ERROR |
BSON_READ_BOOLEAN_ERROR |
BSON_READ_PREMATURE_EOF_ERROR |
BSON_TEMPLATE_ARG_DEPTH_EXCEEDED |
BSON_TEMPLATE_COMPILE_ERROR |
BSON_THREE_BYTES_UINT_ERROR |
BSON_TYPE_NOT_SUPORTED_ERROR |
BSON_UNEXPECTED_END_OF_STRING_ERROR |
BUFFER_LONGER_THAN_ALLOWED_ERROR |
BUILD_INFO_READ_ERROR |
CA_PROCESSOR_EXCEPTION_ERROR |
CACHE_RECORD_ITEM_DISPOSE_ERROR |
CACHE_TABLE_CTOR_SIZES_WARNING |
CACHE_VALUE_FACTORY_ERROR |
CALC_FIELD_CHANGE_ERROR |
CAN_NOT_ADD_FAILED_SCOPE_COMPILE_ERROR |
CAN_NOT_CREATE_MORE_SCOPE_EXPRESSIONS_ERROR |
CANNOT_RETURN_NULL_ERROR |
CHECK_LIST_ALREADY_RUN_ERROR |
CLR_BSON_CONVERSION_REFERENCE_CYCLE_ERROR |
CLR_BSON_CONVERSION_TYPE_NOT_SUPPORTED_ERROR |
CODE_LOGIC_ERROR |
CONFIG_BEHAVIOR_APPLY_ERROR |
CONFIG_JSON_MAP_ERROR |
CONFIG_JSON_STRUCTURE_ERROR |
CONFIG_NO_PROVIDER_LOAD_FILE_ERROR |
CONFIG_NO_PROVIDER_LOAD_FORMAT_ERROR |
CONFIG_RECURSIVE_VARS_ERROR |
CONFIG_VARS_EVAL_ERROR |
CONFIGURATION_ATTR_APPLY_VALUE_ERROR |
CONFIGURATION_ATTRIBUTE_MEMBER_READONLY_ERROR |
CONFIGURATION_CAN_NOT_INCLUDE_INSTEAD_OF_ROOT_ERROR |
CONFIGURATION_CLONE_EMPTY_NODE_ERROR |
CONFIGURATION_EMPTY_NODE_MODIFY_ERROR |
CONFIGURATION_ENTITY_NAME_ERROR |
CONFIGURATION_FILE_UNKNOWN_ERROR |
CONFIGURATION_INCLUDE_PRAGMA_ERROR |
CONFIGURATION_MAKE_USING_CTOR_ERROR |
CONFIGURATION_NAVIGATION_BAD_PATH_ERROR |
CONFIGURATION_NAVIGATION_REQUIRED_ERROR |
CONFIGURATION_NAVIGATION_SECTION_REQUIRED_ERROR |
CONFIGURATION_NODE_DOES_NOT_BELONG_TO_THIS_CONFIGURATION_ERROR |
CONFIGURATION_NODE_MUST_NOT_BELONG_TO_THIS_CONFIGURATION_ERROR |
CONFIGURATION_NODE_NAME_ERROR |
CONFIGURATION_OVERRIDE_PROHOBITED_ERROR |
CONFIGURATION_OVERRIDE_SPEC_ERROR |
CONFIGURATION_PATH_ICONFIGSECTION_SECTION_ERROR |
CONFIGURATION_PATH_ICONFIGURABLE_SECTION_ERROR |
CONFIGURATION_PATH_INDEXER_ERROR |
CONFIGURATION_PATH_INDEXER_SYNTAX_ERROR |
CONFIGURATION_PATH_SEGMENT_NOT_SECTION_ERROR |
CONFIGURATION_PATH_VALUE_INDEXER_CAN_NOT_USE_WITH_ATTRS_ERROR |
CONFIGURATION_PATH_VALUE_INDEXER_SYNTAX_ERROR |
CONFIGURATION_READONLY_ERROR |
CONFIGURATION_SCRIPT_CALL_TARGET_PATH_ERROR |
CONFIGURATION_SCRIPT_ELSE_NOT_AFTER_IF_ERROR |
CONFIGURATION_SCRIPT_EXECUTION_ERROR |
CONFIGURATION_SCRIPT_EXPRESSION_EVAL_ERROR |
CONFIGURATION_SCRIPT_SET_PATH_ERROR |
CONFIGURATION_SCRIPT_SYNTAX_ERROR |
CONFIGURATION_SCRIPT_TARGET_CONFIGURATION_MUST_BE_EMPTY_ERROR |
CONFIGURATION_SCRIPT_TIMEOUT_ERROR |
CONFIGURATION_SECTION_INDEXER_EMPTY_ERROR |
CONFIGURATION_TYPE_ASSIGNABILITY_ERROR |
CONFIGURATION_TYPE_CREATION_ERROR |
CONFIGURATION_TYPE_NOT_SUPPLIED_ERROR |
CONFIGURATION_TYPE_RESOLVE_ERROR |
CONFIGURATION_VALUE_COULD_NOT_BE_GOTTEN_AS_TYPE_ERROR |
CRUD_CONFIG_EMPTY_LOCATIONS_WARNING |
CRUD_CURSOR_ALREADY_ENUMERATED_ERROR |
CRUD_FIELD_ATTR_METADATA_PARSE_ERROR |
CRUD_FIELD_ATTR_PROTOTYPE_CTOR_ERROR |
CRUD_FIELD_NOT_FOUND_ERROR |
CRUD_FIELD_VALUE_EMAIL_ERROR |
CRUD_FIELD_VALUE_GET_ERROR |
CRUD_FIELD_VALUE_IS_NOT_IN_LIST_ERROR |
CRUD_FIELD_VALUE_MAX_BOUND_ERROR |
CRUD_FIELD_VALUE_MAX_LENGTH_ERROR |
CRUD_FIELD_VALUE_MIN_BOUND_ERROR |
CRUD_FIELD_VALUE_MIN_LENGTH_ERROR |
CRUD_FIELD_VALUE_PHONE_ERROR |
CRUD_FIELD_VALUE_REGEXP_ERROR |
CRUD_FIELD_VALUE_REQUIRED_ERROR |
CRUD_FIELD_VALUE_SCREEN_NAME_ERROR |
CRUD_FIELD_VALUE_SET_ERROR |
CRUD_FIELDDEF_ATTR_MISSING_ERROR |
CRUD_FIND_BY_KEY_LENGTH_ERROR |
CRUD_GDID_ERA_CONVERSION_ERROR |
CRUD_OPERATION_CALL_CONTEXT_SCOPE_MISMATCH_ERROR |
CRUD_OPERATION_NOT_SUPPORTED_ERROR |
CRUD_QUERY_RESOLUTION_ERROR |
CRUD_QUERY_RESOLUTION_NO_HANDLER_ERROR |
CRUD_QUERY_RESOLVER_ALREADY_STARTED_ERROR |
CRUD_QUERY_SOURCE_PRAGMA_ERROR |
CRUD_QUERY_SOURCE_PRAGMA_LINE_ERROR |
CRUD_ROWSET_OPERATION_ROW_IS_NULL_OR_SCHEMA_MISMATCH_ERROR |
CRUD_TRANSACTION_IS_NOT_OPEN_ERROR |
CRUD_TYPE_IS_NOT_DERIVED_FROM_ROW_ERROR |
CRUD_TYPE_IS_NOT_DERIVED_FROM_TYPED_ROW_ERROR |
CRUD_TYPED_ROW_CLONED_FIELD_NOTEXISTS_ERROR |
CRUD_TYPED_ROW_RECURSIVE_FIELD_DEFINITION_ERROR |
CRUD_TYPED_ROW_SINGLE_CLONED_FIELD_ERROR |
DECIMAL_OUT_OF_RANGE_ERROR |
DELETE_MODIFY_ERROR |
DISTRIBUTED_DATA_GDID_CTOR_ERROR |
DISTRIBUTED_DATA_GDID_PARSE_ERROR |
DISTRIBUTED_DATA_PARCEL_INVALID_OPERATION_ERROR |
DISTRIBUTED_DATA_PARCEL_MERGE_NOT_IMPLEMENTED_ERROR |
DISTRIBUTED_DATA_PARCEL_MISSING_ATTRIBUTE_ERROR |
DISTRIBUTED_DATA_PARCEL_SEAL_VALIDATION_ERROR |
DISTRIBUTED_DATA_PARCEL_UNWRAP_DESER_ERROR |
DISTRIBUTED_DATA_PARCEL_UNWRAP_FORMAT_ERROR |
DUPLICATE_FIELD_NAME_ERROR |
ELINK_CHAR_COMBINATION_ERROR |
ELINK_CHAR_LENGTH_ERROR |
ELINK_CHAR_LENGTH_LIMIT_ERROR |
ELINK_CSUM_MISMATCH_ERROR |
ELINK_SEGMENT_LENGTH_ERROR |
ENABLE_BINDINGS_ERROR |
ERL_ATOM_SIZE_TOO_LONG_ERROR |
ERL_ATOM_TABLE_IS_FULL_ERROR |
ERL_BIG_INTEGER_OVERFLOW_ERROR |
ERL_CANNOT_CLONE_INSTANCE_ERROR |
ERL_CANNOT_CONVERT_TYPES_CYCLE_ERROR |
ERL_CANNOT_CONVERT_TYPES_ERROR |
ERL_CANNOT_READ_FROM_STREAM_ERROR |
ERL_CONFIG_SINGLE_NODE_ERROR |
ERL_CONN_ACCEPT_ERROR |
ERL_CONN_ACCEPT_FROM |
ERL_CONN_ALREADY_CONNECTED_ERROR |
ERL_CONN_CANT_CONNECT_TO_HOST_ERROR |
ERL_CONN_CANT_CONNECT_TO_NODE_ERROR |
ERL_CONN_CANT_RPC_TO_LOCAL_NODE_ERROR |
ERL_CONN_EOF_AFTER_N_BYTES_ERROR |
ERL_CONN_HANDSHAKE_DATA_ERROR |
ERL_CONN_HANDSHAKE_EXT_PIDS_ERROR |
ERL_CONN_HANDSHAKE_FAILED_ERROR |
ERL_CONN_HANDSHAKE_REF_ERROR |
ERL_CONN_INVALID_DATA_FROM_PEER_ERROR |
ERL_CONN_LOCAL_RPC_ERROR |
ERL_CONN_MSG_SIZE_TOO_LONG_ERROR |
ERL_CONN_NO_COMMON_PROTO_ERROR |
ERL_CONN_NOT_CONNECTED_ERROR |
ERL_CONN_PEER_AUTH_ERROR |
ERL_CONN_READ_TOO_SHORT_ERROR |
ERL_CONN_REMOTE_CLOSED_ERROR |
ERL_CONN_TIMEOUT_ERROR |
ERL_CONN_UNAUTH_COOKIE_ERROR |
ERL_CONN_UNKNOWN_REMOTE_NODE_ERROR |
ERL_CONN_UNKNOWN_TAG_ERROR |
ERL_CONN_WRONG_STATUS_ERROR |
ERL_CONNECTION |
ERL_DS_CRUD_RESP_SCH_FLD_COUNT_ERROR |
ERL_DS_CRUD_RESP_SCH_MISMATCH_ERROR |
ERL_DS_CRUD_WRITE_FAILED_ERROR |
ERL_DS_INTERNAL_MAPPING_ERROR |
ERL_DS_INVALID_RESP_PROTOCOL_ERROR |
ERL_DS_QUERY_PARAM_NOT_FOUND_ERROR |
ERL_DS_QUERY_SCRIPT_PARSE_ERROR |
ERL_DS_QUERY_SUBSCR_NOT_FOUND_ERROR |
ERL_DS_QUERY_TMSTAMP_CTX_ABSENT_ERROR |
ERL_DS_QUERY_TMSTAMP_NOT_FOUND_ERROR |
ERL_DS_RPC_EXEC_ERROR |
ERL_DS_SCHEMA_INVALID_VALUE_ERROR |
ERL_DS_SCHEMA_MAP_ERL_TYPE_ERROR |
ERL_DS_SCHEMA_MAP_NOT_KNOWN_ERROR |
ERL_DS_SCHEMA_NOT_KNOWN_ERROR |
ERL_DS_START_REMOTE_ABSENT_ERROR |
ERL_DS_START_REMOTE_DUPLICATE_ERROR |
ERL_EPMD_FAILED_TO_CONNECT_ERROR |
ERL_EPMD_INVALID_PORT_ERROR |
ERL_EPMD_INVALID_RESPONSE_ERROR |
ERL_EPMD_LOOKUP_R4 |
ERL_EPMD_NO_RESPONSE |
ERL_EPMD_NOT_FOUND |
ERL_EPMD_NOT_RESPONDING |
ERL_EPMD_OK |
ERL_EPMD_PORT |
ERL_EPMD_PUBLISH |
ERL_EPMD_UNPUBLISH |
ERL_INVALID_DATA_FORMAT_ERROR |
ERL_INVALID_FORMATTING_CHAR_ERROR |
ERL_INVALID_IO_REQUEST |
ERL_INVALID_MBOX_NAME_ERROR |
ERL_INVALID_MFA_FORMAT_ERROR |
ERL_INVALID_NUMBER_OF_ARGS_ERROR |
ERL_INVALID_RPC_REQUEST_ERROR |
ERL_INVALID_TERM_TYPE_ERROR |
ERL_INVALID_VALUE_CAST_ERROR |
ERL_INVALID_VALUE_ERROR |
ERL_INVALID_VALUE_LENGTH_ERROR |
ERL_INVALID_VALUE_TYPE_ERROR |
ERL_INVALID_VARIABLE_TYPE_ERROR |
ERL_MISSING_VALUE_FOR_ARGUMENT_ERROR |
ERL_PARSING_AT_ERROR |
ERL_REF_ID_ARGUMENT_ERROR |
ERL_STOPPING_SERVER |
ERL_UNBOUND_VARIABLE_ERROR |
ERL_UNSUPPORTED_ELEMENT_TYPE_ERROR |
ERL_UNSUPPORTED_TERM_TYPE_ERROR |
ERL_VALUE_MUST_NOT_BE_NULL_ERROR |
ERL_VALUE_TOO_LARGE_FOR_TYPE_ERROR |
ERL_VARIABLE_INVALID_VALUE_TYPE_ERROR |
ERL_VARIABLE_NOT_FOUND_ERROR |
ERL_WRONG_VALUE_FOR_ARGUMENT_ERROR |
EXPRESSION_SCOPE_COMPILE_ERROR |
FAILED_TO_ALLOCATE_RESOURCE_ERROR |
FAILED_TO_CREATE_FILE_ERROR |
FIELD_ATTRIBUTES_DEFS_ERROR |
FIELD_COMPARISON_NOT_IMPLEMENTED_ERROR |
FIELD_LOOKUP_NOT_ALLOWED_ERROR |
FIELD_NAME_NOT_FOUND_ERROR |
FIELD_OPERATION_NOT_ALLOWED_ERROR |
FIELD_TYPE_MAP_ERROR |
FILE_NOT_FOUND_ERROR |
FINANCIAL_AMOUNT_DIFFERENT_CURRENCIES_ERROR |
FINANCIAL_AMOUNT_PARSE_ERROR |
FORM_CREATION_ERROR |
FORM_FACTORY_NULL_ERROR |
FORM_LOOKUP_COMMAND_ERROR |
FORMULA_CALCULATED_ANOTHER_FIELD_ERROR |
FS_DUPLICATE_NAME_ERROR |
FS_SESSION_BAD_PARAMS_ERROR |
GDID_BUFFER_ERROR |
GLUE_AMBIGUOUS_CTOR_DCTOR_DEFINITION_ERROR |
GLUE_ARGS_MARSHALLING_INVALID_REQUEST_MSG_TYPE_ERROR |
GLUE_BAD_PROTOCOL_CLIENT_SITE_ERROR |
GLUE_BAD_PROTOCOL_FRAME_ERROR |
GLUE_CALL_SERVICED_BY_DIFFERENT_REACTOR_ERROR |
GLUE_CLIENT_CALL_ERROR |
GLUE_CLIENT_CALL_NO_BINDING_ERROR |
GLUE_CLIENT_CALL_TRANSPORT_ACQUISITION_TIMEOUT_ERROR |
GLUE_CLIENT_CONNECT_ERROR |
GLUE_CLIENT_CONNECTION_REPORT |
GLUE_CLIENT_INSPECTORS_THREW_ERROR |
GLUE_CLIENT_THREAD_COMMUNICATION_ERROR |
GLUE_CLIENT_THREAD_ERROR |
GLUE_DUPLICATE_NAMED_INSTANCE_ERROR |
GLUE_ENDPOINT_CONTRACT_INTF_MAPPING_ERROR |
GLUE_ENDPOINT_CONTRACT_MANY_SERVERS_WARNING |
GLUE_ENDPOINT_CONTRACT_NOT_IMPLEMENTED_ERROR |
GLUE_ENDPOINT_MSPEC_NOT_FOUND_ERROR |
GLUE_LISTENER_EXCEPTION_ERROR |
GLUE_MAX_MSG_SIZE_EXCEEDED_ERROR |
GLUE_METHOD_ARGS_MARSHAL_LAMBDA_ERROR |
GLUE_METHOD_SPEC_UNSUPPORTED_ERROR |
GLUE_MPX_SOCKET_RECEIVE_ACTION_ERROR |
GLUE_MPX_SOCKET_SEND_CHUNK_ALREADY_GOTTEN_ERROR |
GLUE_MPX_SOCKET_SEND_CLOSED_ERROR |
GLUE_MSG_DUMP_FAILURE_ERROR |
GLUE_MSG_DUMP_PATH_INVALID_ERROR |
GLUE_NAMED_BINDING_NOT_FOUND_ERROR |
GLUE_NATIVE_SERIALIZATION_WRONG_ROOT_ERROR |
GLUE_NATIVE_SERIALIZATION_WRONG_ROOT_TOKEN_IN_STREAM_ERROR |
GLUE_NO_ARGS_MARSHAL_LAMBDA_ERROR |
GLUE_NO_INPROC_MATCHING_SERVER_ENDPOINT_ERROR |
GLUE_NO_SERVER_INSTANCE_ERROR |
GLUE_ONE_WAY_RESPONSE_ERROR |
GLUE_POOL_ITEM_ALLOCATION_ERROR |
GLUE_SERVER_CONTRACT_METHOD_INVOCATION_ERROR |
GLUE_SERVER_ENDPOINT_CONTRACT_SERVER_TYPE_ERROR |
GLUE_SERVER_HANDLER_ERROR |
GLUE_SERVER_INSTANCE_ACTIVATION_ERROR |
GLUE_SERVER_ONE_WAY_CALL_ERROR |
GLUE_SHUTTING_DOWN_REPORT |
GLUE_STATEFUL_SERVER_INSTANCE_DOES_NOT_EXIST_ERROR |
GLUE_STATEFUL_SERVER_INSTANCE_LOCK_TIMEOUT_ERROR |
GLUE_SYSTEM_NOT_RUNNING_ERROR |
GLUE_TRANSPORT_CONNECTED_REPORT |
GLUE_TRANSPORT_DISCONNECT_REPORT |
GLUE_TYPE_SPEC_ERROR |
GLUE_UNEXPECTED_MSG_ERROR |
HTTP_OPERATION_ERROR |
INSTRUMENTATIONSVC_PROVIDER_CONFIG_ERROR |
INVALID_ARGUMENT_ERROR |
INVALID_EPOINT_ERROR |
INVALID_FIELD_ACCESSOR_ERROR |
INVALID_IPSTRING_ERROR |
INVALID_OPERATION_ERROR |
INVALID_RECORD_TYPE_ERROR |
INVALID_TIMESPEC_ERROR |
INVENTORIZATION_ASSEMBLY_LOAD_ERROR |
INVENTORIZATION_NEED_STRATEGY_ERROR |
IO_FS_ITEM_IS_READONLY_ERROR |
IO_STREAM_NOT_SUPPORTED_ERROR |
IO_STREAM_POSITION_ERROR |
ITEM_ALREADY_EXISTS_ERROR |
JSON_SERIALIZATION_MAX_NESTING_EXCEEDED_ERROR |
LOCAL_INSTALL_INSTALL_SET_PACKAGE_MANIFEST_READ_ERROR |
LOCAL_INSTALL_INSTALL_SET_PACKAGE_WITHOUT_MANIFEST_ERROR |
LOCAL_INSTALL_LOCAL_MANIFEST_READ_ERROR |
LOCAL_INSTALL_NOT_STARTED_INSTALL_PACKAGE_ERROR |
LOCAL_INSTALL_PACKAGES_MANIFEST_FILE_NAME_COLLISION_ERROR |
LOCAL_INSTALL_ROOT_PATH_NOT_FOUND_ERROR |
LOGSVC_DESTINATION_EXCEEDS_MAX_PROCESSING_TIME_ERROR |
LOGSVC_DESTINATION_IS_OFFLINE_ERROR |
LOGSVC_DESTINATION_OPEN_ERROR |
LOGSVC_FAILOVER_MSG_TEXT |
LOGSVC_FILE_DESTINATION_FILENAME_ERROR |
LOGSVC_NODESTINATIONS_ERROR |
LOOKUP_COMMAND_ERROR |
LOOKUP_DICTIONARY_FIELD_ERROR |
METHOD_INVOCATION_CHANGE_ERROR |
MINMAX_FIELD_ERROR |
MODEL_METHOD_ERROR |
MODEL_METHOD_NOT_FOUND_ERROR |
MODEL_OPERATION_NOT_ALLOWED_ERROR |
NETGATE_CONFIG_DUPLICATE_ENTITY_ERROR |
NETGATE_VARDEF_NAME_EMPTY_CTOR_ERROR |
NOT_APPROPRIATE_STATE_FOR_DELETE_ERROR |
NOT_APPROPRIATE_STATE_FOR_SAVE_ERROR |
NOT_CREATE_EDIT_STATE_ERROR |
NOT_EDIT_STATE_ERROR |
NOT_LOADING_STATE_ERROR |
NOT_UNINIT_VIEW_STATE_ERROR |
NOT_VALID_ON_LOAD_ERROR |
NOT_VALID_ON_POST_ERROR |
NULL_STRING |
OBJECT_DISPOSED_ERROR |
OBJSTORESVC_PROVIDER_CONFIG_ERROR |
OPERATION_NOT_SUPPORTED_ERROR |
OWNER_BINDING_ERROR |
PARAMETER_MAY_NOT_BE_NULL_ERROR |
PDF_COLOR_DOESNOTEXIST_ERROR |
PDF_COLOR_INCONSISTENCY_ERROR |
PDF_UNIT_DOESNOTEXIST_ERROR |
PDF_UNIT_INCONSISTENCY_ERROR |
PILE_AV_BAD_ADDR_CHUNK_FLAG_ERROR |
PILE_AV_BAD_ADDR_EOF_ERROR |
PILE_AV_BAD_ADDR_PAYLOAD_SIZE_ERROR |
PILE_AV_BAD_SEGMENT_ERROR |
PILE_CACHE_SCV_START_PILE_NOT_STARTED_ERROR |
PILE_CACHE_SCV_START_PILE_NULL_ERROR |
PILE_CACHE_TBL_DOES_NOT_EXIST_ERROR |
PILE_CACHE_TBL_KEYCOMPARER_MISMATCH_ERROR |
PILE_CACHE_TBL_KEYTYPE_MISMATCH_ERROR |
PILE_CHUNK_SZ_ERROR |
PILE_CONFIG_PROPERTY_ERROR |
PILE_CRAWL_INTERNAL_SEGMENT_CORRUPTION_ERROR |
PILE_OBJECT_LARGER_SEGMENT_ERROR |
PILE_OUT_OF_SPACE_ERROR |
POD_DONT_KNOW_HOWTO_DESERIALIZE_FROM_CUSTOM_DATA |
POD_ISERIALIZABLE_MISSING_CTOR_ERROR |
READONLY_COLLECTION_MUTATION_ERROR |
READONLY_FIELD_ERROR |
RECURSIVE_FORMULA_FIELD_ERROR |
REFERENCE_TYPE_VALUE_SET_ERROR |
REGEXP_FIELD_ERROR |
RELATIONAL_COMPILER_INCLUDE_SCRIPT_NOT_FOUND_ERROR |
RELATIONAL_COMPILER_OUTPUT_PATH_DOSNT_EXIST_ERROR |
REQUIRED_FIELD_ERROR |
SAVE_MODIFY_ERROR |
SCHEMA_HAS_ALREADY_COMPILED_OPTION_CHANGE_ERROR |
SCHEMA_INCLUDE_FILE_DOSNT_EXIST_ERROR |
SCHEMA_INCLUDE_FILE_REFERENCED_MORE_THAN_ONCE_ERROR |
SEALED_STRING_OUT_OF_SPACE_ERROR |
SEALED_STRING_TOO_BIG_ERROR |
SECDB_FILE_HEADER_ERROR |
SECDB_FILE_NOT_FOUND_ERROR |
SECDB_FS_SEEK_STREAM_ERROR |
SECDB_STREAM_CORRUPTED_ERROR |
SECURITY_AUTHROIZATION_ERROR |
SECURITY_NON_AUTHENTICATED |
SECURITY_REPRESENT_CREDENTIALS_FORGOTTEN |
SERVICE_COMPOSITE_CHILD_START_ABORT_ERROR |
SERVICE_INVALID_STATE |
SIZE_FIELD_ERROR |
SLIM_ARRAYS_ARRAY_INSTANCE_ERROR |
SLIM_ARRAYS_MISSING_ARRAY_DIMS_ERROR |
SLIM_ARRAYS_OVER_MAX_DIMS_ERROR |
SLIM_ARRAYS_OVER_MAX_ELM_ERROR |
SLIM_ARRAYS_TYPE_NOT_ARRAY_ERROR |
SLIM_ARRAYS_WRONG_ARRAY_DIMS_ERROR |
SLIM_BAD_HEADER_ERROR |
SLIM_DESERIALIZATION_EXCEPTION_ERROR |
SLIM_DESERIALIZE_CALLBACK_ERROR |
SLIM_HNDLTOREF_MISSING_TYPE_NAME_ERROR |
SLIM_ISERIALIZABLE_MISSING_CTOR_ERROR |
SLIM_READ_X_ARRAY_MAX_SIZE_ERROR |
SLIM_SER_PROHIBIT_ERROR |
SLIM_SERIALIZATION_EXCEPTION_ERROR |
SLIM_STREAM_CORRUPTED_ERROR |
SLIM_TREG_COUNT_ERROR |
SLIM_TREG_CSUM_ERROR |
SLIM_WRITE_X_ARRAY_MAX_SIZE_ERROR |
STORAGE_OPERATION_IN_PROGRESS_ERROR |
STREAM_READ_EOF_ERROR |
STRING_VALUE_COULD_NOT_BE_GOTTEN_AS_TYPE_ERROR |
SURROGATE_LOAD_ERROR |
SVCAPP_INSTANCE_ALREADY_CREATED_ERROR |
SVCAPP_INSTANCE_NULL_ERROR |
SVCAPPLICATION_TOPIC |
TEMPLATE_COMPILER_ALREADY_COMPILED_ERROR |
TEMPLATE_CS_COMPILER_CONFIG_CLOSE_TAG_ERROR |
TEMPLATE_CS_COMPILER_CONFIG_ERROR |
TEMPLATE_CS_COMPILER_EMPTY_EXPRESSION_ERROR |
TEMPLATE_CS_COMPILER_UNMATCHED_SPAN_ERROR |
TEXT_PATTERN_MULTI_WC_ERROR |
UNINITIALIZED_STATE_ERROR |
UNKNOWN_STRING |
VALUE_ASSIGNMENT_ERROR |
VIEW_MODIFY_ERROR |
WORK_ITEM_NOT_AGGREGATABLE_ERROR |
Back to Top
See Also
StringConsts Class
NFX Namespace


StringConsts Fields

StringConsts Fields NFX Class Library

The StringConsts type exposes the following members.
Fields
Name | Description
APP_APPLY_BEHAVIORS_ERROR |
APP_ASSEMBLY_PRELOAD_ERROR |
APP_CONFIG_SETTING_NOT_FOUND_ERROR |
APP_DATA_STORE_INIT_ERROR |
APP_EVENT_TIMER_INIT_ERROR |
APP_FINISH_NOTIFIABLE_AFTER_ERROR |
APP_FINISH_NOTIFIABLE_BEFORE_ERROR |
APP_FINISH_NOTIFIABLES_ERROR |
APP_FORMS_FACTORY_INIT_ERROR |
APP_GLUE_INIT_ERROR |
APP_INJECTION_TYPE_MISMATCH_ERROR |
APP_INSTRUMENTATION_INIT_ERROR |
APP_IS_NOT_EXPECTED_TYPE_ERROR |
APP_LOG_INIT_ERROR |
APP_OBJECT_STORE_INIT_ERROR |
APP_SECURITY_MANAGER_INIT_ERROR |
APP_STARTER_AFTER_ERROR |
APP_STARTER_BEFORE_ERROR |
APP_THROTTLING_INIT_ERROR |
APP_TIMESOURCE_INIT_ERROR |
APPLY_RECORD_CHANGES_ERROR |
ARGUMENT_ERROR |
AROW_DESER_CORRUPT_ERROR |
AROW_GENERATOR_PATH_DOESNOT_EXIST_ERROR |
AROW_HEADER_CORRUPT_ERROR |
AROW_INVALID_FIELD_NAME_ERROR |
AROW_MAX_ARRAY_LEN_ERROR |
AROW_MEMBER_TYPE_NOT_SUPPORTED_ERROR |
AROW_TYPE_NOT_SUPPORTED_ERROR |
ASSERTION_ERROR |
BINLOG_BAD_READER_TYPE_ERROR |
BINLOG_READER_FACTORY_ERROR |
BINLOG_READER_TYPE_MISMATCH_ERROR |
BINLOG_STREAM_CANT_SEEK_WRITE_ERROR |
BINLOG_STREAM_CORRUPTED_ERROR |
BINLOG_STREAM_NULL_ERROR |
BSON_ARRAY_ELM_DOC_ERROR |
BSON_ARRAY_ELM_NAME_ERROR |
BSON_DECIMAL_INT32_INT64_CONVERTION_ERROR |
BSON_DOCUMENT_RECURSION_ERROR |
BSON_DOCUMENT_SIZE_EXCEEDED_ERROR |
BSON_ELEMENT_OBJECT_VALUE_SET_ERROR |
BSON_EOD_ERROR |
BSON_INCORRECT_STRING_LENGTH_ERROR |
BSON_NAMED_ELEMENT_ADDED_ERROR |
BSON_OBJECTID_LENGTH_ERROR |
BSON_READ_BOOLEAN_ERROR |
BSON_READ_PREMATURE_EOF_ERROR |
BSON_TEMPLATE_ARG_DEPTH_EXCEEDED |
BSON_TEMPLATE_COMPILE_ERROR |
BSON_THREE_BYTES_UINT_ERROR |
BSON_TYPE_NOT_SUPORTED_ERROR |
BSON_UNEXPECTED_END_OF_STRING_ERROR |
BUFFER_LONGER_THAN_ALLOWED_ERROR |
BUILD_INFO_READ_ERROR |
CA_PROCESSOR_EXCEPTION_ERROR |
CACHE_RECORD_ITEM_DISPOSE_ERROR |
CACHE_TABLE_CTOR_SIZES_WARNING |
CACHE_VALUE_FACTORY_ERROR |
CALC_FIELD_CHANGE_ERROR |
CAN_NOT_ADD_FAILED_SCOPE_COMPILE_ERROR |
CAN_NOT_CREATE_MORE_SCOPE_EXPRESSIONS_ERROR |
CANNOT_RETURN_NULL_ERROR |
CHECK_LIST_ALREADY_RUN_ERROR |
CLR_BSON_CONVERSION_REFERENCE_CYCLE_ERROR |
CLR_BSON_CONVERSION_TYPE_NOT_SUPPORTED_ERROR |
CODE_LOGIC_ERROR |
CONFIG_BEHAVIOR_APPLY_ERROR |
CONFIG_JSON_MAP_ERROR |
CONFIG_JSON_STRUCTURE_ERROR |
CONFIG_NO_PROVIDER_LOAD_FILE_ERROR |
CONFIG_NO_PROVIDER_LOAD_FORMAT_ERROR |
CONFIG_RECURSIVE_VARS_ERROR |
CONFIG_VARS_EVAL_ERROR |
CONFIGURATION_ATTR_APPLY_VALUE_ERROR |
CONFIGURATION_ATTRIBUTE_MEMBER_READONLY_ERROR |
CONFIGURATION_CAN_NOT_INCLUDE_INSTEAD_OF_ROOT_ERROR |
CONFIGURATION_CLONE_EMPTY_NODE_ERROR |
CONFIGURATION_EMPTY_NODE_MODIFY_ERROR |
CONFIGURATION_ENTITY_NAME_ERROR |
CONFIGURATION_FILE_UNKNOWN_ERROR |
CONFIGURATION_INCLUDE_PRAGMA_ERROR |
CONFIGURATION_MAKE_USING_CTOR_ERROR |
CONFIGURATION_NAVIGATION_BAD_PATH_ERROR |
CONFIGURATION_NAVIGATION_REQUIRED_ERROR |
CONFIGURATION_NAVIGATION_SECTION_REQUIRED_ERROR |
CONFIGURATION_NODE_DOES_NOT_BELONG_TO_THIS_CONFIGURATION_ERROR |
CONFIGURATION_NODE_MUST_NOT_BELONG_TO_THIS_CONFIGURATION_ERROR |
CONFIGURATION_NODE_NAME_ERROR |
CONFIGURATION_OVERRIDE_PROHOBITED_ERROR |
CONFIGURATION_OVERRIDE_SPEC_ERROR |
CONFIGURATION_PATH_ICONFIGSECTION_SECTION_ERROR |
CONFIGURATION_PATH_ICONFIGURABLE_SECTION_ERROR |
CONFIGURATION_PATH_INDEXER_ERROR |
CONFIGURATION_PATH_INDEXER_SYNTAX_ERROR |
CONFIGURATION_PATH_SEGMENT_NOT_SECTION_ERROR |
CONFIGURATION_PATH_VALUE_INDEXER_CAN_NOT_USE_WITH_ATTRS_ERROR |
CONFIGURATION_PATH_VALUE_INDEXER_SYNTAX_ERROR |
CONFIGURATION_READONLY_ERROR |
CONFIGURATION_SCRIPT_CALL_TARGET_PATH_ERROR |
CONFIGURATION_SCRIPT_ELSE_NOT_AFTER_IF_ERROR |
CONFIGURATION_SCRIPT_EXECUTION_ERROR |
CONFIGURATION_SCRIPT_EXPRESSION_EVAL_ERROR |
CONFIGURATION_SCRIPT_SET_PATH_ERROR |
CONFIGURATION_SCRIPT_SYNTAX_ERROR |
CONFIGURATION_SCRIPT_TARGET_CONFIGURATION_MUST_BE_EMPTY_ERROR |
CONFIGURATION_SCRIPT_TIMEOUT_ERROR |
CONFIGURATION_SECTION_INDEXER_EMPTY_ERROR |
CONFIGURATION_TYPE_ASSIGNABILITY_ERROR |
CONFIGURATION_TYPE_CREATION_ERROR |
CONFIGURATION_TYPE_NOT_SUPPLIED_ERROR |
CONFIGURATION_TYPE_RESOLVE_ERROR |
CONFIGURATION_VALUE_COULD_NOT_BE_GOTTEN_AS_TYPE_ERROR |
CRUD_CONFIG_EMPTY_LOCATIONS_WARNING |
CRUD_CURSOR_ALREADY_ENUMERATED_ERROR |
CRUD_FIELD_ATTR_METADATA_PARSE_ERROR |
CRUD_FIELD_ATTR_PROTOTYPE_CTOR_ERROR |
CRUD_FIELD_NOT_FOUND_ERROR |
CRUD_FIELD_VALUE_EMAIL_ERROR |
CRUD_FIELD_VALUE_GET_ERROR |
CRUD_FIELD_VALUE_IS_NOT_IN_LIST_ERROR |
CRUD_FIELD_VALUE_MAX_BOUND_ERROR |
CRUD_FIELD_VALUE_MAX_LENGTH_ERROR |
CRUD_FIELD_VALUE_MIN_BOUND_ERROR |
CRUD_FIELD_VALUE_MIN_LENGTH_ERROR |
CRUD_FIELD_VALUE_PHONE_ERROR |
CRUD_FIELD_VALUE_REGEXP_ERROR |
CRUD_FIELD_VALUE_REQUIRED_ERROR |
CRUD_FIELD_VALUE_SCREEN_NAME_ERROR |
CRUD_FIELD_VALUE_SET_ERROR |
CRUD_FIELDDEF_ATTR_MISSING_ERROR |
CRUD_FIND_BY_KEY_LENGTH_ERROR |
CRUD_GDID_ERA_CONVERSION_ERROR |
CRUD_OPERATION_CALL_CONTEXT_SCOPE_MISMATCH_ERROR |
CRUD_OPERATION_NOT_SUPPORTED_ERROR |
CRUD_QUERY_RESOLUTION_ERROR |
CRUD_QUERY_RESOLUTION_NO_HANDLER_ERROR |
CRUD_QUERY_RESOLVER_ALREADY_STARTED_ERROR |
CRUD_QUERY_SOURCE_PRAGMA_ERROR |
CRUD_QUERY_SOURCE_PRAGMA_LINE_ERROR |
CRUD_ROWSET_OPERATION_ROW_IS_NULL_OR_SCHEMA_MISMATCH_ERROR |
CRUD_TRANSACTION_IS_NOT_OPEN_ERROR |
CRUD_TYPE_IS_NOT_DERIVED_FROM_ROW_ERROR |
CRUD_TYPE_IS_NOT_DERIVED_FROM_TYPED_ROW_ERROR |
CRUD_TYPED_ROW_CLONED_FIELD_NOTEXISTS_ERROR |
CRUD_TYPED_ROW_RECURSIVE_FIELD_DEFINITION_ERROR |
CRUD_TYPED_ROW_SINGLE_CLONED_FIELD_ERROR |
DECIMAL_OUT_OF_RANGE_ERROR |
DELETE_MODIFY_ERROR |
DISTRIBUTED_DATA_GDID_CTOR_ERROR |
DISTRIBUTED_DATA_GDID_PARSE_ERROR |
DISTRIBUTED_DATA_PARCEL_INVALID_OPERATION_ERROR |
DISTRIBUTED_DATA_PARCEL_MERGE_NOT_IMPLEMENTED_ERROR |
DISTRIBUTED_DATA_PARCEL_MISSING_ATTRIBUTE_ERROR |
DISTRIBUTED_DATA_PARCEL_SEAL_VALIDATION_ERROR |
DISTRIBUTED_DATA_PARCEL_UNWRAP_DESER_ERROR |
DISTRIBUTED_DATA_PARCEL_UNWRAP_FORMAT_ERROR |
DUPLICATE_FIELD_NAME_ERROR |
ELINK_CHAR_COMBINATION_ERROR |
ELINK_CHAR_LENGTH_ERROR |
ELINK_CHAR_LENGTH_LIMIT_ERROR |
ELINK_CSUM_MISMATCH_ERROR |
ELINK_SEGMENT_LENGTH_ERROR |
ENABLE_BINDINGS_ERROR |
ERL_ATOM_SIZE_TOO_LONG_ERROR |
ERL_ATOM_TABLE_IS_FULL_ERROR |
ERL_BIG_INTEGER_OVERFLOW_ERROR |
ERL_CANNOT_CLONE_INSTANCE_ERROR |
ERL_CANNOT_CONVERT_TYPES_CYCLE_ERROR |
ERL_CANNOT_CONVERT_TYPES_ERROR |
ERL_CANNOT_READ_FROM_STREAM_ERROR |
ERL_CONFIG_SINGLE_NODE_ERROR |
ERL_CONN_ACCEPT_ERROR |
ERL_CONN_ACCEPT_FROM |
ERL_CONN_ALREADY_CONNECTED_ERROR |
ERL_CONN_CANT_CONNECT_TO_HOST_ERROR |
ERL_CONN_CANT_CONNECT_TO_NODE_ERROR |
ERL_CONN_CANT_RPC_TO_LOCAL_NODE_ERROR |
ERL_CONN_EOF_AFTER_N_BYTES_ERROR |
ERL_CONN_HANDSHAKE_DATA_ERROR |
ERL_CONN_HANDSHAKE_EXT_PIDS_ERROR |
ERL_CONN_HANDSHAKE_FAILED_ERROR |
ERL_CONN_HANDSHAKE_REF_ERROR |
ERL_CONN_INVALID_DATA_FROM_PEER_ERROR |
ERL_CONN_LOCAL_RPC_ERROR |
ERL_CONN_MSG_SIZE_TOO_LONG_ERROR |
ERL_CONN_NO_COMMON_PROTO_ERROR |
ERL_CONN_NOT_CONNECTED_ERROR |
ERL_CONN_PEER_AUTH_ERROR |
ERL_CONN_READ_TOO_SHORT_ERROR |
ERL_CONN_REMOTE_CLOSED_ERROR |
ERL_CONN_TIMEOUT_ERROR |
ERL_CONN_UNAUTH_COOKIE_ERROR |
ERL_CONN_UNKNOWN_REMOTE_NODE_ERROR |
ERL_CONN_UNKNOWN_TAG_ERROR |
ERL_CONN_WRONG_STATUS_ERROR |
ERL_CONNECTION |
ERL_DS_CRUD_RESP_SCH_FLD_COUNT_ERROR |
ERL_DS_CRUD_RESP_SCH_MISMATCH_ERROR |
ERL_DS_CRUD_WRITE_FAILED_ERROR |
ERL_DS_INTERNAL_MAPPING_ERROR |
ERL_DS_INVALID_RESP_PROTOCOL_ERROR |
ERL_DS_QUERY_PARAM_NOT_FOUND_ERROR |
ERL_DS_QUERY_SCRIPT_PARSE_ERROR |
ERL_DS_QUERY_SUBSCR_NOT_FOUND_ERROR |
ERL_DS_QUERY_TMSTAMP_CTX_ABSENT_ERROR |
ERL_DS_QUERY_TMSTAMP_NOT_FOUND_ERROR |
ERL_DS_RPC_EXEC_ERROR |
ERL_DS_SCHEMA_INVALID_VALUE_ERROR |
ERL_DS_SCHEMA_MAP_ERL_TYPE_ERROR |
ERL_DS_SCHEMA_MAP_NOT_KNOWN_ERROR |
ERL_DS_SCHEMA_NOT_KNOWN_ERROR |
ERL_DS_START_REMOTE_ABSENT_ERROR |
ERL_DS_START_REMOTE_DUPLICATE_ERROR |
ERL_EPMD_FAILED_TO_CONNECT_ERROR |
ERL_EPMD_INVALID_PORT_ERROR |
ERL_EPMD_INVALID_RESPONSE_ERROR |
ERL_EPMD_LOOKUP_R4 |
ERL_EPMD_NO_RESPONSE |
ERL_EPMD_NOT_FOUND |
ERL_EPMD_NOT_RESPONDING |
ERL_EPMD_OK |
ERL_EPMD_PORT |
ERL_EPMD_PUBLISH |
ERL_EPMD_UNPUBLISH |
ERL_INVALID_DATA_FORMAT_ERROR |
ERL_INVALID_FORMATTING_CHAR_ERROR |
ERL_INVALID_IO_REQUEST |
ERL_INVALID_MBOX_NAME_ERROR |
ERL_INVALID_MFA_FORMAT_ERROR |
ERL_INVALID_NUMBER_OF_ARGS_ERROR |
ERL_INVALID_RPC_REQUEST_ERROR |
ERL_INVALID_TERM_TYPE_ERROR |
ERL_INVALID_VALUE_CAST_ERROR |
ERL_INVALID_VALUE_ERROR |
ERL_INVALID_VALUE_LENGTH_ERROR |
ERL_INVALID_VALUE_TYPE_ERROR |
ERL_INVALID_VARIABLE_TYPE_ERROR |
ERL_MISSING_VALUE_FOR_ARGUMENT_ERROR |
ERL_PARSING_AT_ERROR |
ERL_REF_ID_ARGUMENT_ERROR |
ERL_STOPPING_SERVER |
ERL_UNBOUND_VARIABLE_ERROR |
ERL_UNSUPPORTED_ELEMENT_TYPE_ERROR |
ERL_UNSUPPORTED_TERM_TYPE_ERROR |
ERL_VALUE_MUST_NOT_BE_NULL_ERROR |
ERL_VALUE_TOO_LARGE_FOR_TYPE_ERROR |
ERL_VARIABLE_INVALID_VALUE_TYPE_ERROR |
ERL_VARIABLE_NOT_FOUND_ERROR |
ERL_WRONG_VALUE_FOR_ARGUMENT_ERROR |
EXPRESSION_SCOPE_COMPILE_ERROR |
FAILED_TO_ALLOCATE_RESOURCE_ERROR |
FAILED_TO_CREATE_FILE_ERROR |
FIELD_ATTRIBUTES_DEFS_ERROR |
FIELD_COMPARISON_NOT_IMPLEMENTED_ERROR |
FIELD_LOOKUP_NOT_ALLOWED_ERROR |
FIELD_NAME_NOT_FOUND_ERROR |
FIELD_OPERATION_NOT_ALLOWED_ERROR |
FIELD_TYPE_MAP_ERROR |
FILE_NOT_FOUND_ERROR |
FINANCIAL_AMOUNT_DIFFERENT_CURRENCIES_ERROR |
FINANCIAL_AMOUNT_PARSE_ERROR |
FORM_CREATION_ERROR |
FORM_FACTORY_NULL_ERROR |
FORM_LOOKUP_COMMAND_ERROR |
FORMULA_CALCULATED_ANOTHER_FIELD_ERROR |
FS_DUPLICATE_NAME_ERROR |
FS_SESSION_BAD_PARAMS_ERROR |
GDID_BUFFER_ERROR |
GLUE_AMBIGUOUS_CTOR_DCTOR_DEFINITION_ERROR |
GLUE_ARGS_MARSHALLING_INVALID_REQUEST_MSG_TYPE_ERROR |
GLUE_BAD_PROTOCOL_CLIENT_SITE_ERROR |
GLUE_BAD_PROTOCOL_FRAME_ERROR |
GLUE_CALL_SERVICED_BY_DIFFERENT_REACTOR_ERROR |
GLUE_CLIENT_CALL_ERROR |
GLUE_CLIENT_CALL_NO_BINDING_ERROR |
GLUE_CLIENT_CALL_TRANSPORT_ACQUISITION_TIMEOUT_ERROR |
GLUE_CLIENT_CONNECT_ERROR |
GLUE_CLIENT_CONNECTION_REPORT |
GLUE_CLIENT_INSPECTORS_THREW_ERROR |
GLUE_CLIENT_THREAD_COMMUNICATION_ERROR |
GLUE_CLIENT_THREAD_ERROR |
GLUE_DUPLICATE_NAMED_INSTANCE_ERROR |
GLUE_ENDPOINT_CONTRACT_INTF_MAPPING_ERROR |
GLUE_ENDPOINT_CONTRACT_MANY_SERVERS_WARNING |
GLUE_ENDPOINT_CONTRACT_NOT_IMPLEMENTED_ERROR |
GLUE_ENDPOINT_MSPEC_NOT_FOUND_ERROR |
GLUE_LISTENER_EXCEPTION_ERROR |
GLUE_MAX_MSG_SIZE_EXCEEDED_ERROR |
GLUE_METHOD_ARGS_MARSHAL_LAMBDA_ERROR |
GLUE_METHOD_SPEC_UNSUPPORTED_ERROR |
GLUE_MPX_SOCKET_RECEIVE_ACTION_ERROR |
GLUE_MPX_SOCKET_SEND_CHUNK_ALREADY_GOTTEN_ERROR |
GLUE_MPX_SOCKET_SEND_CLOSED_ERROR |
GLUE_MSG_DUMP_FAILURE_ERROR |
GLUE_MSG_DUMP_PATH_INVALID_ERROR |
GLUE_NAMED_BINDING_NOT_FOUND_ERROR |
GLUE_NATIVE_SERIALIZATION_WRONG_ROOT_ERROR |
GLUE_NATIVE_SERIALIZATION_WRONG_ROOT_TOKEN_IN_STREAM_ERROR |
GLUE_NO_ARGS_MARSHAL_LAMBDA_ERROR |
GLUE_NO_INPROC_MATCHING_SERVER_ENDPOINT_ERROR |
GLUE_NO_SERVER_INSTANCE_ERROR |
GLUE_ONE_WAY_RESPONSE_ERROR |
GLUE_POOL_ITEM_ALLOCATION_ERROR |
GLUE_SERVER_CONTRACT_METHOD_INVOCATION_ERROR |
GLUE_SERVER_ENDPOINT_CONTRACT_SERVER_TYPE_ERROR |
GLUE_SERVER_HANDLER_ERROR |
GLUE_SERVER_INSTANCE_ACTIVATION_ERROR |
GLUE_SERVER_ONE_WAY_CALL_ERROR |
GLUE_SHUTTING_DOWN_REPORT |
GLUE_STATEFUL_SERVER_INSTANCE_DOES_NOT_EXIST_ERROR |
GLUE_STATEFUL_SERVER_INSTANCE_LOCK_TIMEOUT_ERROR |
GLUE_SYSTEM_NOT_RUNNING_ERROR |
GLUE_TRANSPORT_CONNECTED_REPORT |
GLUE_TRANSPORT_DISCONNECT_REPORT |
GLUE_TYPE_SPEC_ERROR |
GLUE_UNEXPECTED_MSG_ERROR |
HTTP_OPERATION_ERROR |
INSTRUMENTATIONSVC_PROVIDER_CONFIG_ERROR |
INVALID_ARGUMENT_ERROR |
INVALID_EPOINT_ERROR |
INVALID_FIELD_ACCESSOR_ERROR |
INVALID_IPSTRING_ERROR |
INVALID_OPERATION_ERROR |
INVALID_RECORD_TYPE_ERROR |
INVALID_TIMESPEC_ERROR |
INVENTORIZATION_ASSEMBLY_LOAD_ERROR |
INVENTORIZATION_NEED_STRATEGY_ERROR |
IO_FS_ITEM_IS_READONLY_ERROR |
IO_STREAM_NOT_SUPPORTED_ERROR |
IO_STREAM_POSITION_ERROR |
ITEM_ALREADY_EXISTS_ERROR |
JSON_SERIALIZATION_MAX_NESTING_EXCEEDED_ERROR |
LOCAL_INSTALL_INSTALL_SET_PACKAGE_MANIFEST_READ_ERROR |
LOCAL_INSTALL_INSTALL_SET_PACKAGE_WITHOUT_MANIFEST_ERROR |
LOCAL_INSTALL_LOCAL_MANIFEST_READ_ERROR |
LOCAL_INSTALL_NOT_STARTED_INSTALL_PACKAGE_ERROR |
LOCAL_INSTALL_PACKAGES_MANIFEST_FILE_NAME_COLLISION_ERROR |
LOCAL_INSTALL_ROOT_PATH_NOT_FOUND_ERROR |
LOGSVC_DESTINATION_EXCEEDS_MAX_PROCESSING_TIME_ERROR |
LOGSVC_DESTINATION_IS_OFFLINE_ERROR |
LOGSVC_DESTINATION_OPEN_ERROR |
LOGSVC_FAILOVER_MSG_TEXT |
LOGSVC_FILE_DESTINATION_FILENAME_ERROR |
LOGSVC_NODESTINATIONS_ERROR |
LOOKUP_COMMAND_ERROR |
LOOKUP_DICTIONARY_FIELD_ERROR |
METHOD_INVOCATION_CHANGE_ERROR |
MINMAX_FIELD_ERROR |
MODEL_METHOD_ERROR |
MODEL_METHOD_NOT_FOUND_ERROR |
MODEL_OPERATION_NOT_ALLOWED_ERROR |
NETGATE_CONFIG_DUPLICATE_ENTITY_ERROR |
NETGATE_VARDEF_NAME_EMPTY_CTOR_ERROR |
NOT_APPROPRIATE_STATE_FOR_DELETE_ERROR |
NOT_APPROPRIATE_STATE_FOR_SAVE_ERROR |
NOT_CREATE_EDIT_STATE_ERROR |
NOT_EDIT_STATE_ERROR |
NOT_LOADING_STATE_ERROR |
NOT_UNINIT_VIEW_STATE_ERROR |
NOT_VALID_ON_LOAD_ERROR |
NOT_VALID_ON_POST_ERROR |
NULL_STRING |
OBJECT_DISPOSED_ERROR |
OBJSTORESVC_PROVIDER_CONFIG_ERROR |
OPERATION_NOT_SUPPORTED_ERROR |
OWNER_BINDING_ERROR |
PARAMETER_MAY_NOT_BE_NULL_ERROR |
PDF_COLOR_DOESNOTEXIST_ERROR |
PDF_COLOR_INCONSISTENCY_ERROR |
PDF_UNIT_DOESNOTEXIST_ERROR |
PDF_UNIT_INCONSISTENCY_ERROR |
PILE_AV_BAD_ADDR_CHUNK_FLAG_ERROR |
PILE_AV_BAD_ADDR_EOF_ERROR |
PILE_AV_BAD_ADDR_PAYLOAD_SIZE_ERROR |
PILE_AV_BAD_SEGMENT_ERROR |
PILE_CACHE_SCV_START_PILE_NOT_STARTED_ERROR |
PILE_CACHE_SCV_START_PILE_NULL_ERROR |
PILE_CACHE_TBL_DOES_NOT_EXIST_ERROR |
PILE_CACHE_TBL_KEYCOMPARER_MISMATCH_ERROR |
PILE_CACHE_TBL_KEYTYPE_MISMATCH_ERROR |
PILE_CHUNK_SZ_ERROR |
PILE_CONFIG_PROPERTY_ERROR |
PILE_CRAWL_INTERNAL_SEGMENT_CORRUPTION_ERROR |
PILE_OBJECT_LARGER_SEGMENT_ERROR |
PILE_OUT_OF_SPACE_ERROR |
POD_DONT_KNOW_HOWTO_DESERIALIZE_FROM_CUSTOM_DATA |
POD_ISERIALIZABLE_MISSING_CTOR_ERROR |
READONLY_COLLECTION_MUTATION_ERROR |
READONLY_FIELD_ERROR |
RECURSIVE_FORMULA_FIELD_ERROR |
REFERENCE_TYPE_VALUE_SET_ERROR |
REGEXP_FIELD_ERROR |
RELATIONAL_COMPILER_INCLUDE_SCRIPT_NOT_FOUND_ERROR |
RELATIONAL_COMPILER_OUTPUT_PATH_DOSNT_EXIST_ERROR |
REQUIRED_FIELD_ERROR |
SAVE_MODIFY_ERROR |
SCHEMA_HAS_ALREADY_COMPILED_OPTION_CHANGE_ERROR |
SCHEMA_INCLUDE_FILE_DOSNT_EXIST_ERROR |
SCHEMA_INCLUDE_FILE_REFERENCED_MORE_THAN_ONCE_ERROR |
SEALED_STRING_OUT_OF_SPACE_ERROR |
SEALED_STRING_TOO_BIG_ERROR |
SECDB_FILE_HEADER_ERROR |
SECDB_FILE_NOT_FOUND_ERROR |
SECDB_FS_SEEK_STREAM_ERROR |
SECDB_STREAM_CORRUPTED_ERROR |
SECURITY_AUTHROIZATION_ERROR |
SECURITY_NON_AUTHENTICATED |
SECURITY_REPRESENT_CREDENTIALS_FORGOTTEN |
SERVICE_COMPOSITE_CHILD_START_ABORT_ERROR |
SERVICE_INVALID_STATE |
SIZE_FIELD_ERROR |
SLIM_ARRAYS_ARRAY_INSTANCE_ERROR |
SLIM_ARRAYS_MISSING_ARRAY_DIMS_ERROR |
SLIM_ARRAYS_OVER_MAX_DIMS_ERROR |
SLIM_ARRAYS_OVER_MAX_ELM_ERROR |
SLIM_ARRAYS_TYPE_NOT_ARRAY_ERROR |
SLIM_ARRAYS_WRONG_ARRAY_DIMS_ERROR |
SLIM_BAD_HEADER_ERROR |
SLIM_DESERIALIZATION_EXCEPTION_ERROR |
SLIM_DESERIALIZE_CALLBACK_ERROR |
SLIM_HNDLTOREF_MISSING_TYPE_NAME_ERROR |
SLIM_ISERIALIZABLE_MISSING_CTOR_ERROR |
SLIM_READ_X_ARRAY_MAX_SIZE_ERROR |
SLIM_SER_PROHIBIT_ERROR |
SLIM_SERIALIZATION_EXCEPTION_ERROR |
SLIM_STREAM_CORRUPTED_ERROR |
SLIM_TREG_COUNT_ERROR |
SLIM_TREG_CSUM_ERROR |
SLIM_WRITE_X_ARRAY_MAX_SIZE_ERROR |
STORAGE_OPERATION_IN_PROGRESS_ERROR |
STREAM_READ_EOF_ERROR |
STRING_VALUE_COULD_NOT_BE_GOTTEN_AS_TYPE_ERROR |
SURROGATE_LOAD_ERROR |
SVCAPP_INSTANCE_ALREADY_CREATED_ERROR |
SVCAPP_INSTANCE_NULL_ERROR |
SVCAPPLICATION_TOPIC |
TEMPLATE_COMPILER_ALREADY_COMPILED_ERROR |
TEMPLATE_CS_COMPILER_CONFIG_CLOSE_TAG_ERROR |
TEMPLATE_CS_COMPILER_CONFIG_ERROR |
TEMPLATE_CS_COMPILER_EMPTY_EXPRESSION_ERROR |
TEMPLATE_CS_COMPILER_UNMATCHED_SPAN_ERROR |
TEXT_PATTERN_MULTI_WC_ERROR |
UNINITIALIZED_STATE_ERROR |
UNKNOWN_STRING |
VALUE_ASSIGNMENT_ERROR |
VIEW_MODIFY_ERROR |
WORK_ITEM_NOT_AGGREGATABLE_ERROR |
Back to Top
See Also
StringConsts Class
NFX Namespace


StringConsts.APP_APPLY_BEHAVIORS_ERROR Field

StringConsts APP_APPLY_BEHAVIORS_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_APPLY_BEHAVIORS_ERROR
public const string APP_APPLY_BEHAVIORS_ERROR
Public Const APP_APPLY_BEHAVIORS_ERROR As String
Public Const APP_APPLY_BEHAVIORS_ERROR As String
public:
literal String^ APP_APPLY_BEHAVIORS_ERROR
public:
literal String^ APP_APPLY_BEHAVIORS_ERROR
static val mutable APP_APPLY_BEHAVIORS_ERROR: string
static val mutable APP_APPLY_BEHAVIORS_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.APP_ASSEMBLY_PRELOAD_ERROR Field

StringConsts APP_ASSEMBLY_PRELOAD_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_ASSEMBLY_PRELOAD_ERROR
public const string APP_ASSEMBLY_PRELOAD_ERROR
Public Const APP_ASSEMBLY_PRELOAD_ERROR As String
Public Const APP_ASSEMBLY_PRELOAD_ERROR As String
public:
literal String^ APP_ASSEMBLY_PRELOAD_ERROR
public:
literal String^ APP_ASSEMBLY_PRELOAD_ERROR
static val mutable APP_ASSEMBLY_PRELOAD_ERROR: string
static val mutable APP_ASSEMBLY_PRELOAD_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.APP_CONFIG_SETTING_NOT_FOUND_ERROR Field

StringConsts APP_CONFIG_SETTING_NOT_FOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_CONFIG_SETTING_NOT_FOUND_ERROR
public const string APP_CONFIG_SETTING_NOT_FOUND_ERROR
Public Const APP_CONFIG_SETTING_NOT_FOUND_ERROR As String
Public Const APP_CONFIG_SETTING_NOT_FOUND_ERROR As String
public:
literal String^ APP_CONFIG_SETTING_NOT_FOUND_ERROR
public:
literal String^ APP_CONFIG_SETTING_NOT_FOUND_ERROR
static val mutable APP_CONFIG_SETTING_NOT_FOUND_ERROR: string
static val mutable APP_CONFIG_SETTING_NOT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.APP_DATA_STORE_INIT_ERROR Field

StringConsts APP_DATA_STORE_INIT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_DATA_STORE_INIT_ERROR
public const string APP_DATA_STORE_INIT_ERROR
Public Const APP_DATA_STORE_INIT_ERROR As String
Public Const APP_DATA_STORE_INIT_ERROR As String
public:
literal String^ APP_DATA_STORE_INIT_ERROR
public:
literal String^ APP_DATA_STORE_INIT_ERROR
static val mutable APP_DATA_STORE_INIT_ERROR: string
static val mutable APP_DATA_STORE_INIT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.APP_EVENT_TIMER_INIT_ERROR Field

StringConsts APP_EVENT_TIMER_INIT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_EVENT_TIMER_INIT_ERROR
public const string APP_EVENT_TIMER_INIT_ERROR
Public Const APP_EVENT_TIMER_INIT_ERROR As String
Public Const APP_EVENT_TIMER_INIT_ERROR As String
public:
literal String^ APP_EVENT_TIMER_INIT_ERROR
public:
literal String^ APP_EVENT_TIMER_INIT_ERROR
static val mutable APP_EVENT_TIMER_INIT_ERROR: string
static val mutable APP_EVENT_TIMER_INIT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.APP_FINISH_NOTIFIABLE_AFTER_ERROR Field

StringConsts APP_FINISH_NOTIFIABLE_AFTER_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_FINISH_NOTIFIABLE_AFTER_ERROR
public const string APP_FINISH_NOTIFIABLE_AFTER_ERROR
Public Const APP_FINISH_NOTIFIABLE_AFTER_ERROR As String
Public Const APP_FINISH_NOTIFIABLE_AFTER_ERROR As String
public:
literal String^ APP_FINISH_NOTIFIABLE_AFTER_ERROR
public:
literal String^ APP_FINISH_NOTIFIABLE_AFTER_ERROR
static val mutable APP_FINISH_NOTIFIABLE_AFTER_ERROR: string
static val mutable APP_FINISH_NOTIFIABLE_AFTER_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.APP_FINISH_NOTIFIABLE_BEFORE_ERROR Field

StringConsts APP_FINISH_NOTIFIABLE_BEFORE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_FINISH_NOTIFIABLE_BEFORE_ERROR
public const string APP_FINISH_NOTIFIABLE_BEFORE_ERROR
Public Const APP_FINISH_NOTIFIABLE_BEFORE_ERROR As String
Public Const APP_FINISH_NOTIFIABLE_BEFORE_ERROR As String
public:
literal String^ APP_FINISH_NOTIFIABLE_BEFORE_ERROR
public:
literal String^ APP_FINISH_NOTIFIABLE_BEFORE_ERROR
static val mutable APP_FINISH_NOTIFIABLE_BEFORE_ERROR: string
static val mutable APP_FINISH_NOTIFIABLE_BEFORE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.APP_FINISH_NOTIFIABLES_ERROR Field

StringConsts APP_FINISH_NOTIFIABLES_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_FINISH_NOTIFIABLES_ERROR
public const string APP_FINISH_NOTIFIABLES_ERROR
Public Const APP_FINISH_NOTIFIABLES_ERROR As String
Public Const APP_FINISH_NOTIFIABLES_ERROR As String
public:
literal String^ APP_FINISH_NOTIFIABLES_ERROR
public:
literal String^ APP_FINISH_NOTIFIABLES_ERROR
static val mutable APP_FINISH_NOTIFIABLES_ERROR: string
static val mutable APP_FINISH_NOTIFIABLES_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.APP_FORMS_FACTORY_INIT_ERROR Field

StringConsts APP_FORMS_FACTORY_INIT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_FORMS_FACTORY_INIT_ERROR
public const string APP_FORMS_FACTORY_INIT_ERROR
Public Const APP_FORMS_FACTORY_INIT_ERROR As String
Public Const APP_FORMS_FACTORY_INIT_ERROR As String
public:
literal String^ APP_FORMS_FACTORY_INIT_ERROR
public:
literal String^ APP_FORMS_FACTORY_INIT_ERROR
static val mutable APP_FORMS_FACTORY_INIT_ERROR: string
static val mutable APP_FORMS_FACTORY_INIT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.APP_GLUE_INIT_ERROR Field

StringConsts APP_GLUE_INIT_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_GLUE_INIT_ERROR
public const string APP_GLUE_INIT_ERROR
Public Const APP_GLUE_INIT_ERROR As String
Public Const APP_GLUE_INIT_ERROR As String
public:
literal String^ APP_GLUE_INIT_ERROR
public:
literal String^ APP_GLUE_INIT_ERROR
static val mutable APP_GLUE_INIT_ERROR: string
static val mutable APP_GLUE_INIT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.APP_INJECTION_TYPE_MISMATCH_ERROR Field

StringConsts APP_INJECTION_TYPE_MISMATCH_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_INJECTION_TYPE_MISMATCH_ERROR
public const string APP_INJECTION_TYPE_MISMATCH_ERROR
Public Const APP_INJECTION_TYPE_MISMATCH_ERROR As String
Public Const APP_INJECTION_TYPE_MISMATCH_ERROR As String
public:
literal String^ APP_INJECTION_TYPE_MISMATCH_ERROR
public:
literal String^ APP_INJECTION_TYPE_MISMATCH_ERROR
static val mutable APP_INJECTION_TYPE_MISMATCH_ERROR: string
static val mutable APP_INJECTION_TYPE_MISMATCH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.APP_INSTRUMENTATION_INIT_ERROR Field

StringConsts APP_INSTRUMENTATION_INIT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_INSTRUMENTATION_INIT_ERROR
public const string APP_INSTRUMENTATION_INIT_ERROR
Public Const APP_INSTRUMENTATION_INIT_ERROR As String
Public Const APP_INSTRUMENTATION_INIT_ERROR As String
public:
literal String^ APP_INSTRUMENTATION_INIT_ERROR
public:
literal String^ APP_INSTRUMENTATION_INIT_ERROR
static val mutable APP_INSTRUMENTATION_INIT_ERROR: string
static val mutable APP_INSTRUMENTATION_INIT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.APP_IS_NOT_EXPECTED_TYPE_ERROR Field

StringConsts APP_IS_NOT_EXPECTED_TYPE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_IS_NOT_EXPECTED_TYPE_ERROR
public const string APP_IS_NOT_EXPECTED_TYPE_ERROR
Public Const APP_IS_NOT_EXPECTED_TYPE_ERROR As String
Public Const APP_IS_NOT_EXPECTED_TYPE_ERROR As String
public:
literal String^ APP_IS_NOT_EXPECTED_TYPE_ERROR
public:
literal String^ APP_IS_NOT_EXPECTED_TYPE_ERROR
static val mutable APP_IS_NOT_EXPECTED_TYPE_ERROR: string
static val mutable APP_IS_NOT_EXPECTED_TYPE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.APP_LOG_INIT_ERROR Field

StringConsts APP_LOG_INIT_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_LOG_INIT_ERROR
public const string APP_LOG_INIT_ERROR
Public Const APP_LOG_INIT_ERROR As String
Public Const APP_LOG_INIT_ERROR As String
public:
literal String^ APP_LOG_INIT_ERROR
public:
literal String^ APP_LOG_INIT_ERROR
static val mutable APP_LOG_INIT_ERROR: string
static val mutable APP_LOG_INIT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.APP_OBJECT_STORE_INIT_ERROR Field

StringConsts APP_OBJECT_STORE_INIT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_OBJECT_STORE_INIT_ERROR
public const string APP_OBJECT_STORE_INIT_ERROR
Public Const APP_OBJECT_STORE_INIT_ERROR As String
Public Const APP_OBJECT_STORE_INIT_ERROR As String
public:
literal String^ APP_OBJECT_STORE_INIT_ERROR
public:
literal String^ APP_OBJECT_STORE_INIT_ERROR
static val mutable APP_OBJECT_STORE_INIT_ERROR: string
static val mutable APP_OBJECT_STORE_INIT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.APP_SECURITY_MANAGER_INIT_ERROR Field

StringConsts APP_SECURITY_MANAGER_INIT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_SECURITY_MANAGER_INIT_ERROR
public const string APP_SECURITY_MANAGER_INIT_ERROR
Public Const APP_SECURITY_MANAGER_INIT_ERROR As String
Public Const APP_SECURITY_MANAGER_INIT_ERROR As String
public:
literal String^ APP_SECURITY_MANAGER_INIT_ERROR
public:
literal String^ APP_SECURITY_MANAGER_INIT_ERROR
static val mutable APP_SECURITY_MANAGER_INIT_ERROR: string
static val mutable APP_SECURITY_MANAGER_INIT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.APP_STARTER_AFTER_ERROR Field

StringConsts APP_STARTER_AFTER_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_STARTER_AFTER_ERROR
public const string APP_STARTER_AFTER_ERROR
Public Const APP_STARTER_AFTER_ERROR As String
Public Const APP_STARTER_AFTER_ERROR As String
public:
literal String^ APP_STARTER_AFTER_ERROR
public:
literal String^ APP_STARTER_AFTER_ERROR
static val mutable APP_STARTER_AFTER_ERROR: string
static val mutable APP_STARTER_AFTER_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.APP_STARTER_BEFORE_ERROR Field

StringConsts APP_STARTER_BEFORE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_STARTER_BEFORE_ERROR
public const string APP_STARTER_BEFORE_ERROR
Public Const APP_STARTER_BEFORE_ERROR As String
Public Const APP_STARTER_BEFORE_ERROR As String
public:
literal String^ APP_STARTER_BEFORE_ERROR
public:
literal String^ APP_STARTER_BEFORE_ERROR
static val mutable APP_STARTER_BEFORE_ERROR: string
static val mutable APP_STARTER_BEFORE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.APP_THROTTLING_INIT_ERROR Field

StringConsts APP_THROTTLING_INIT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_THROTTLING_INIT_ERROR
public const string APP_THROTTLING_INIT_ERROR
Public Const APP_THROTTLING_INIT_ERROR As String
Public Const APP_THROTTLING_INIT_ERROR As String
public:
literal String^ APP_THROTTLING_INIT_ERROR
public:
literal String^ APP_THROTTLING_INIT_ERROR
static val mutable APP_THROTTLING_INIT_ERROR: string
static val mutable APP_THROTTLING_INIT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.APP_TIMESOURCE_INIT_ERROR Field

StringConsts APP_TIMESOURCE_INIT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APP_TIMESOURCE_INIT_ERROR
public const string APP_TIMESOURCE_INIT_ERROR
Public Const APP_TIMESOURCE_INIT_ERROR As String
Public Const APP_TIMESOURCE_INIT_ERROR As String
public:
literal String^ APP_TIMESOURCE_INIT_ERROR
public:
literal String^ APP_TIMESOURCE_INIT_ERROR
static val mutable APP_TIMESOURCE_INIT_ERROR: string
static val mutable APP_TIMESOURCE_INIT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.APPLY_RECORD_CHANGES_ERROR Field

StringConsts APPLY_RECORD_CHANGES_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string APPLY_RECORD_CHANGES_ERROR
public const string APPLY_RECORD_CHANGES_ERROR
Public Const APPLY_RECORD_CHANGES_ERROR As String
Public Const APPLY_RECORD_CHANGES_ERROR As String
public:
literal String^ APPLY_RECORD_CHANGES_ERROR
public:
literal String^ APPLY_RECORD_CHANGES_ERROR
static val mutable APPLY_RECORD_CHANGES_ERROR: string
static val mutable APPLY_RECORD_CHANGES_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ARGUMENT_ERROR Field

StringConsts ARGUMENT_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ARGUMENT_ERROR
public const string ARGUMENT_ERROR
Public Const ARGUMENT_ERROR As String
Public Const ARGUMENT_ERROR As String
public:
literal String^ ARGUMENT_ERROR
public:
literal String^ ARGUMENT_ERROR
static val mutable ARGUMENT_ERROR: string
static val mutable ARGUMENT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.AROW_DESER_CORRUPT_ERROR Field

StringConsts AROW_DESER_CORRUPT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string AROW_DESER_CORRUPT_ERROR
public const string AROW_DESER_CORRUPT_ERROR
Public Const AROW_DESER_CORRUPT_ERROR As String
Public Const AROW_DESER_CORRUPT_ERROR As String
public:
literal String^ AROW_DESER_CORRUPT_ERROR
public:
literal String^ AROW_DESER_CORRUPT_ERROR
static val mutable AROW_DESER_CORRUPT_ERROR: string
static val mutable AROW_DESER_CORRUPT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.AROW_GENERATOR_PATH_DOESNOT_EXIST_ERROR Field

StringConsts AROW_GENERATOR_PATH_DOESNOT_EXIST_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string AROW_GENERATOR_PATH_DOESNOT_EXIST_ERROR
public const string AROW_GENERATOR_PATH_DOESNOT_EXIST_ERROR
Public Const AROW_GENERATOR_PATH_DOESNOT_EXIST_ERROR As String
Public Const AROW_GENERATOR_PATH_DOESNOT_EXIST_ERROR As String
public:
literal String^ AROW_GENERATOR_PATH_DOESNOT_EXIST_ERROR
public:
literal String^ AROW_GENERATOR_PATH_DOESNOT_EXIST_ERROR
static val mutable AROW_GENERATOR_PATH_DOESNOT_EXIST_ERROR: string
static val mutable AROW_GENERATOR_PATH_DOESNOT_EXIST_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.AROW_HEADER_CORRUPT_ERROR Field

StringConsts AROW_HEADER_CORRUPT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string AROW_HEADER_CORRUPT_ERROR
public const string AROW_HEADER_CORRUPT_ERROR
Public Const AROW_HEADER_CORRUPT_ERROR As String
Public Const AROW_HEADER_CORRUPT_ERROR As String
public:
literal String^ AROW_HEADER_CORRUPT_ERROR
public:
literal String^ AROW_HEADER_CORRUPT_ERROR
static val mutable AROW_HEADER_CORRUPT_ERROR: string
static val mutable AROW_HEADER_CORRUPT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.AROW_INVALID_FIELD_NAME_ERROR Field

StringConsts AROW_INVALID_FIELD_NAME_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string AROW_INVALID_FIELD_NAME_ERROR
public const string AROW_INVALID_FIELD_NAME_ERROR
Public Const AROW_INVALID_FIELD_NAME_ERROR As String
Public Const AROW_INVALID_FIELD_NAME_ERROR As String
public:
literal String^ AROW_INVALID_FIELD_NAME_ERROR
public:
literal String^ AROW_INVALID_FIELD_NAME_ERROR
static val mutable AROW_INVALID_FIELD_NAME_ERROR: string
static val mutable AROW_INVALID_FIELD_NAME_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.AROW_MAX_ARRAY_LEN_ERROR Field

StringConsts AROW_MAX_ARRAY_LEN_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string AROW_MAX_ARRAY_LEN_ERROR
public const string AROW_MAX_ARRAY_LEN_ERROR
Public Const AROW_MAX_ARRAY_LEN_ERROR As String
Public Const AROW_MAX_ARRAY_LEN_ERROR As String
public:
literal String^ AROW_MAX_ARRAY_LEN_ERROR
public:
literal String^ AROW_MAX_ARRAY_LEN_ERROR
static val mutable AROW_MAX_ARRAY_LEN_ERROR: string
static val mutable AROW_MAX_ARRAY_LEN_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.AROW_MEMBER_TYPE_NOT_SUPPORTED_ERROR Field

StringConsts AROW_MEMBER_TYPE_NOT_SUPPORTED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string AROW_MEMBER_TYPE_NOT_SUPPORTED_ERROR
public const string AROW_MEMBER_TYPE_NOT_SUPPORTED_ERROR
Public Const AROW_MEMBER_TYPE_NOT_SUPPORTED_ERROR As String
Public Const AROW_MEMBER_TYPE_NOT_SUPPORTED_ERROR As String
public:
literal String^ AROW_MEMBER_TYPE_NOT_SUPPORTED_ERROR
public:
literal String^ AROW_MEMBER_TYPE_NOT_SUPPORTED_ERROR
static val mutable AROW_MEMBER_TYPE_NOT_SUPPORTED_ERROR: string
static val mutable AROW_MEMBER_TYPE_NOT_SUPPORTED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.AROW_TYPE_NOT_SUPPORTED_ERROR Field

StringConsts AROW_TYPE_NOT_SUPPORTED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string AROW_TYPE_NOT_SUPPORTED_ERROR
public const string AROW_TYPE_NOT_SUPPORTED_ERROR
Public Const AROW_TYPE_NOT_SUPPORTED_ERROR As String
Public Const AROW_TYPE_NOT_SUPPORTED_ERROR As String
public:
literal String^ AROW_TYPE_NOT_SUPPORTED_ERROR
public:
literal String^ AROW_TYPE_NOT_SUPPORTED_ERROR
static val mutable AROW_TYPE_NOT_SUPPORTED_ERROR: string
static val mutable AROW_TYPE_NOT_SUPPORTED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ASSERTION_ERROR Field

StringConsts ASSERTION_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ASSERTION_ERROR
public const string ASSERTION_ERROR
Public Const ASSERTION_ERROR As String
Public Const ASSERTION_ERROR As String
public:
literal String^ ASSERTION_ERROR
public:
literal String^ ASSERTION_ERROR
static val mutable ASSERTION_ERROR: string
static val mutable ASSERTION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.BINLOG_BAD_READER_TYPE_ERROR Field

StringConsts BINLOG_BAD_READER_TYPE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BINLOG_BAD_READER_TYPE_ERROR
public const string BINLOG_BAD_READER_TYPE_ERROR
Public Const BINLOG_BAD_READER_TYPE_ERROR As String
Public Const BINLOG_BAD_READER_TYPE_ERROR As String
public:
literal String^ BINLOG_BAD_READER_TYPE_ERROR
public:
literal String^ BINLOG_BAD_READER_TYPE_ERROR
static val mutable BINLOG_BAD_READER_TYPE_ERROR: string
static val mutable BINLOG_BAD_READER_TYPE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.BINLOG_READER_FACTORY_ERROR Field

StringConsts BINLOG_READER_FACTORY_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BINLOG_READER_FACTORY_ERROR
public const string BINLOG_READER_FACTORY_ERROR
Public Const BINLOG_READER_FACTORY_ERROR As String
Public Const BINLOG_READER_FACTORY_ERROR As String
public:
literal String^ BINLOG_READER_FACTORY_ERROR
public:
literal String^ BINLOG_READER_FACTORY_ERROR
static val mutable BINLOG_READER_FACTORY_ERROR: string
static val mutable BINLOG_READER_FACTORY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.BINLOG_READER_TYPE_MISMATCH_ERROR Field

StringConsts BINLOG_READER_TYPE_MISMATCH_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BINLOG_READER_TYPE_MISMATCH_ERROR
public const string BINLOG_READER_TYPE_MISMATCH_ERROR
Public Const BINLOG_READER_TYPE_MISMATCH_ERROR As String
Public Const BINLOG_READER_TYPE_MISMATCH_ERROR As String
public:
literal String^ BINLOG_READER_TYPE_MISMATCH_ERROR
public:
literal String^ BINLOG_READER_TYPE_MISMATCH_ERROR
static val mutable BINLOG_READER_TYPE_MISMATCH_ERROR: string
static val mutable BINLOG_READER_TYPE_MISMATCH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.BINLOG_STREAM_CANT_SEEK_WRITE_ERROR Field

StringConsts BINLOG_STREAM_CANT_SEEK_WRITE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BINLOG_STREAM_CANT_SEEK_WRITE_ERROR
public const string BINLOG_STREAM_CANT_SEEK_WRITE_ERROR
Public Const BINLOG_STREAM_CANT_SEEK_WRITE_ERROR As String
Public Const BINLOG_STREAM_CANT_SEEK_WRITE_ERROR As String
public:
literal String^ BINLOG_STREAM_CANT_SEEK_WRITE_ERROR
public:
literal String^ BINLOG_STREAM_CANT_SEEK_WRITE_ERROR
static val mutable BINLOG_STREAM_CANT_SEEK_WRITE_ERROR: string
static val mutable BINLOG_STREAM_CANT_SEEK_WRITE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.BINLOG_STREAM_CORRUPTED_ERROR Field

StringConsts BINLOG_STREAM_CORRUPTED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BINLOG_STREAM_CORRUPTED_ERROR
public const string BINLOG_STREAM_CORRUPTED_ERROR
Public Const BINLOG_STREAM_CORRUPTED_ERROR As String
Public Const BINLOG_STREAM_CORRUPTED_ERROR As String
public:
literal String^ BINLOG_STREAM_CORRUPTED_ERROR
public:
literal String^ BINLOG_STREAM_CORRUPTED_ERROR
static val mutable BINLOG_STREAM_CORRUPTED_ERROR: string
static val mutable BINLOG_STREAM_CORRUPTED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.BINLOG_STREAM_NULL_ERROR Field

StringConsts BINLOG_STREAM_NULL_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BINLOG_STREAM_NULL_ERROR
public const string BINLOG_STREAM_NULL_ERROR
Public Const BINLOG_STREAM_NULL_ERROR As String
Public Const BINLOG_STREAM_NULL_ERROR As String
public:
literal String^ BINLOG_STREAM_NULL_ERROR
public:
literal String^ BINLOG_STREAM_NULL_ERROR
static val mutable BINLOG_STREAM_NULL_ERROR: string
static val mutable BINLOG_STREAM_NULL_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.BSON_ARRAY_ELM_DOC_ERROR Field

StringConsts BSON_ARRAY_ELM_DOC_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BSON_ARRAY_ELM_DOC_ERROR
public const string BSON_ARRAY_ELM_DOC_ERROR
Public Const BSON_ARRAY_ELM_DOC_ERROR As String
Public Const BSON_ARRAY_ELM_DOC_ERROR As String
public:
literal String^ BSON_ARRAY_ELM_DOC_ERROR
public:
literal String^ BSON_ARRAY_ELM_DOC_ERROR
static val mutable BSON_ARRAY_ELM_DOC_ERROR: string
static val mutable BSON_ARRAY_ELM_DOC_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.BSON_ARRAY_ELM_NAME_ERROR Field

StringConsts BSON_ARRAY_ELM_NAME_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BSON_ARRAY_ELM_NAME_ERROR
public const string BSON_ARRAY_ELM_NAME_ERROR
Public Const BSON_ARRAY_ELM_NAME_ERROR As String
Public Const BSON_ARRAY_ELM_NAME_ERROR As String
public:
literal String^ BSON_ARRAY_ELM_NAME_ERROR
public:
literal String^ BSON_ARRAY_ELM_NAME_ERROR
static val mutable BSON_ARRAY_ELM_NAME_ERROR: string
static val mutable BSON_ARRAY_ELM_NAME_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.BSON_DECIMAL_INT32_INT64_CONVERTION_ERROR Field

StringConsts BSON_DECIMAL_INT32_INT64_CONVERTION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BSON_DECIMAL_INT32_INT64_CONVERTION_ERROR
public const string BSON_DECIMAL_INT32_INT64_CONVERTION_ERROR
Public Const BSON_DECIMAL_INT32_INT64_CONVERTION_ERROR As String
Public Const BSON_DECIMAL_INT32_INT64_CONVERTION_ERROR As String
public:
literal String^ BSON_DECIMAL_INT32_INT64_CONVERTION_ERROR
public:
literal String^ BSON_DECIMAL_INT32_INT64_CONVERTION_ERROR
static val mutable BSON_DECIMAL_INT32_INT64_CONVERTION_ERROR: string
static val mutable BSON_DECIMAL_INT32_INT64_CONVERTION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.BSON_DOCUMENT_RECURSION_ERROR Field

StringConsts BSON_DOCUMENT_RECURSION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BSON_DOCUMENT_RECURSION_ERROR
public const string BSON_DOCUMENT_RECURSION_ERROR
Public Const BSON_DOCUMENT_RECURSION_ERROR As String
Public Const BSON_DOCUMENT_RECURSION_ERROR As String
public:
literal String^ BSON_DOCUMENT_RECURSION_ERROR
public:
literal String^ BSON_DOCUMENT_RECURSION_ERROR
static val mutable BSON_DOCUMENT_RECURSION_ERROR: string
static val mutable BSON_DOCUMENT_RECURSION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.BSON_DOCUMENT_SIZE_EXCEEDED_ERROR Field

StringConsts BSON_DOCUMENT_SIZE_EXCEEDED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BSON_DOCUMENT_SIZE_EXCEEDED_ERROR
public const string BSON_DOCUMENT_SIZE_EXCEEDED_ERROR
Public Const BSON_DOCUMENT_SIZE_EXCEEDED_ERROR As String
Public Const BSON_DOCUMENT_SIZE_EXCEEDED_ERROR As String
public:
literal String^ BSON_DOCUMENT_SIZE_EXCEEDED_ERROR
public:
literal String^ BSON_DOCUMENT_SIZE_EXCEEDED_ERROR
static val mutable BSON_DOCUMENT_SIZE_EXCEEDED_ERROR: string
static val mutable BSON_DOCUMENT_SIZE_EXCEEDED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.BSON_ELEMENT_OBJECT_VALUE_SET_ERROR Field

StringConsts BSON_ELEMENT_OBJECT_VALUE_SET_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BSON_ELEMENT_OBJECT_VALUE_SET_ERROR
public const string BSON_ELEMENT_OBJECT_VALUE_SET_ERROR
Public Const BSON_ELEMENT_OBJECT_VALUE_SET_ERROR As String
Public Const BSON_ELEMENT_OBJECT_VALUE_SET_ERROR As String
public:
literal String^ BSON_ELEMENT_OBJECT_VALUE_SET_ERROR
public:
literal String^ BSON_ELEMENT_OBJECT_VALUE_SET_ERROR
static val mutable BSON_ELEMENT_OBJECT_VALUE_SET_ERROR: string
static val mutable BSON_ELEMENT_OBJECT_VALUE_SET_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.BSON_EOD_ERROR Field

StringConsts BSON_EOD_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BSON_EOD_ERROR
public const string BSON_EOD_ERROR
Public Const BSON_EOD_ERROR As String
Public Const BSON_EOD_ERROR As String
public:
literal String^ BSON_EOD_ERROR
public:
literal String^ BSON_EOD_ERROR
static val mutable BSON_EOD_ERROR: string
static val mutable BSON_EOD_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.BSON_INCORRECT_STRING_LENGTH_ERROR Field

StringConsts BSON_INCORRECT_STRING_LENGTH_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BSON_INCORRECT_STRING_LENGTH_ERROR
public const string BSON_INCORRECT_STRING_LENGTH_ERROR
Public Const BSON_INCORRECT_STRING_LENGTH_ERROR As String
Public Const BSON_INCORRECT_STRING_LENGTH_ERROR As String
public:
literal String^ BSON_INCORRECT_STRING_LENGTH_ERROR
public:
literal String^ BSON_INCORRECT_STRING_LENGTH_ERROR
static val mutable BSON_INCORRECT_STRING_LENGTH_ERROR: string
static val mutable BSON_INCORRECT_STRING_LENGTH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.BSON_NAMED_ELEMENT_ADDED_ERROR Field

StringConsts BSON_NAMED_ELEMENT_ADDED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BSON_NAMED_ELEMENT_ADDED_ERROR
public const string BSON_NAMED_ELEMENT_ADDED_ERROR
Public Const BSON_NAMED_ELEMENT_ADDED_ERROR As String
Public Const BSON_NAMED_ELEMENT_ADDED_ERROR As String
public:
literal String^ BSON_NAMED_ELEMENT_ADDED_ERROR
public:
literal String^ BSON_NAMED_ELEMENT_ADDED_ERROR
static val mutable BSON_NAMED_ELEMENT_ADDED_ERROR: string
static val mutable BSON_NAMED_ELEMENT_ADDED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.BSON_OBJECTID_LENGTH_ERROR Field

StringConsts BSON_OBJECTID_LENGTH_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BSON_OBJECTID_LENGTH_ERROR
public const string BSON_OBJECTID_LENGTH_ERROR
Public Const BSON_OBJECTID_LENGTH_ERROR As String
Public Const BSON_OBJECTID_LENGTH_ERROR As String
public:
literal String^ BSON_OBJECTID_LENGTH_ERROR
public:
literal String^ BSON_OBJECTID_LENGTH_ERROR
static val mutable BSON_OBJECTID_LENGTH_ERROR: string
static val mutable BSON_OBJECTID_LENGTH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.BSON_READ_BOOLEAN_ERROR Field

StringConsts BSON_READ_BOOLEAN_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BSON_READ_BOOLEAN_ERROR
public const string BSON_READ_BOOLEAN_ERROR
Public Const BSON_READ_BOOLEAN_ERROR As String
Public Const BSON_READ_BOOLEAN_ERROR As String
public:
literal String^ BSON_READ_BOOLEAN_ERROR
public:
literal String^ BSON_READ_BOOLEAN_ERROR
static val mutable BSON_READ_BOOLEAN_ERROR: string
static val mutable BSON_READ_BOOLEAN_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.BSON_READ_PREMATURE_EOF_ERROR Field

StringConsts BSON_READ_PREMATURE_EOF_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BSON_READ_PREMATURE_EOF_ERROR
public const string BSON_READ_PREMATURE_EOF_ERROR
Public Const BSON_READ_PREMATURE_EOF_ERROR As String
Public Const BSON_READ_PREMATURE_EOF_ERROR As String
public:
literal String^ BSON_READ_PREMATURE_EOF_ERROR
public:
literal String^ BSON_READ_PREMATURE_EOF_ERROR
static val mutable BSON_READ_PREMATURE_EOF_ERROR: string
static val mutable BSON_READ_PREMATURE_EOF_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.BSON_TEMPLATE_ARG_DEPTH_EXCEEDED Field

StringConsts BSON_TEMPLATE_ARG_DEPTH_EXCEEDED Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BSON_TEMPLATE_ARG_DEPTH_EXCEEDED
public const string BSON_TEMPLATE_ARG_DEPTH_EXCEEDED
Public Const BSON_TEMPLATE_ARG_DEPTH_EXCEEDED As String
Public Const BSON_TEMPLATE_ARG_DEPTH_EXCEEDED As String
public:
literal String^ BSON_TEMPLATE_ARG_DEPTH_EXCEEDED
public:
literal String^ BSON_TEMPLATE_ARG_DEPTH_EXCEEDED
static val mutable BSON_TEMPLATE_ARG_DEPTH_EXCEEDED: string
static val mutable BSON_TEMPLATE_ARG_DEPTH_EXCEEDED: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.BSON_TEMPLATE_COMPILE_ERROR Field

StringConsts BSON_TEMPLATE_COMPILE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BSON_TEMPLATE_COMPILE_ERROR
public const string BSON_TEMPLATE_COMPILE_ERROR
Public Const BSON_TEMPLATE_COMPILE_ERROR As String
Public Const BSON_TEMPLATE_COMPILE_ERROR As String
public:
literal String^ BSON_TEMPLATE_COMPILE_ERROR
public:
literal String^ BSON_TEMPLATE_COMPILE_ERROR
static val mutable BSON_TEMPLATE_COMPILE_ERROR: string
static val mutable BSON_TEMPLATE_COMPILE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.BSON_THREE_BYTES_UINT_ERROR Field

StringConsts BSON_THREE_BYTES_UINT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BSON_THREE_BYTES_UINT_ERROR
public const string BSON_THREE_BYTES_UINT_ERROR
Public Const BSON_THREE_BYTES_UINT_ERROR As String
Public Const BSON_THREE_BYTES_UINT_ERROR As String
public:
literal String^ BSON_THREE_BYTES_UINT_ERROR
public:
literal String^ BSON_THREE_BYTES_UINT_ERROR
static val mutable BSON_THREE_BYTES_UINT_ERROR: string
static val mutable BSON_THREE_BYTES_UINT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.BSON_TYPE_NOT_SUPORTED_ERROR Field

StringConsts BSON_TYPE_NOT_SUPORTED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BSON_TYPE_NOT_SUPORTED_ERROR
public const string BSON_TYPE_NOT_SUPORTED_ERROR
Public Const BSON_TYPE_NOT_SUPORTED_ERROR As String
Public Const BSON_TYPE_NOT_SUPORTED_ERROR As String
public:
literal String^ BSON_TYPE_NOT_SUPORTED_ERROR
public:
literal String^ BSON_TYPE_NOT_SUPORTED_ERROR
static val mutable BSON_TYPE_NOT_SUPORTED_ERROR: string
static val mutable BSON_TYPE_NOT_SUPORTED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.BSON_UNEXPECTED_END_OF_STRING_ERROR Field

StringConsts BSON_UNEXPECTED_END_OF_STRING_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BSON_UNEXPECTED_END_OF_STRING_ERROR
public const string BSON_UNEXPECTED_END_OF_STRING_ERROR
Public Const BSON_UNEXPECTED_END_OF_STRING_ERROR As String
Public Const BSON_UNEXPECTED_END_OF_STRING_ERROR As String
public:
literal String^ BSON_UNEXPECTED_END_OF_STRING_ERROR
public:
literal String^ BSON_UNEXPECTED_END_OF_STRING_ERROR
static val mutable BSON_UNEXPECTED_END_OF_STRING_ERROR: string
static val mutable BSON_UNEXPECTED_END_OF_STRING_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.BUFFER_LONGER_THAN_ALLOWED_ERROR Field

StringConsts BUFFER_LONGER_THAN_ALLOWED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BUFFER_LONGER_THAN_ALLOWED_ERROR
public const string BUFFER_LONGER_THAN_ALLOWED_ERROR
Public Const BUFFER_LONGER_THAN_ALLOWED_ERROR As String
Public Const BUFFER_LONGER_THAN_ALLOWED_ERROR As String
public:
literal String^ BUFFER_LONGER_THAN_ALLOWED_ERROR
public:
literal String^ BUFFER_LONGER_THAN_ALLOWED_ERROR
static val mutable BUFFER_LONGER_THAN_ALLOWED_ERROR: string
static val mutable BUFFER_LONGER_THAN_ALLOWED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.BUILD_INFO_READ_ERROR Field

StringConsts BUILD_INFO_READ_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BUILD_INFO_READ_ERROR
public const string BUILD_INFO_READ_ERROR
Public Const BUILD_INFO_READ_ERROR As String
Public Const BUILD_INFO_READ_ERROR As String
public:
literal String^ BUILD_INFO_READ_ERROR
public:
literal String^ BUILD_INFO_READ_ERROR
static val mutable BUILD_INFO_READ_ERROR: string
static val mutable BUILD_INFO_READ_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CA_PROCESSOR_EXCEPTION_ERROR Field

StringConsts CA_PROCESSOR_EXCEPTION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CA_PROCESSOR_EXCEPTION_ERROR
public const string CA_PROCESSOR_EXCEPTION_ERROR
Public Const CA_PROCESSOR_EXCEPTION_ERROR As String
Public Const CA_PROCESSOR_EXCEPTION_ERROR As String
public:
literal String^ CA_PROCESSOR_EXCEPTION_ERROR
public:
literal String^ CA_PROCESSOR_EXCEPTION_ERROR
static val mutable CA_PROCESSOR_EXCEPTION_ERROR: string
static val mutable CA_PROCESSOR_EXCEPTION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CACHE_RECORD_ITEM_DISPOSE_ERROR Field

StringConsts CACHE_RECORD_ITEM_DISPOSE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CACHE_RECORD_ITEM_DISPOSE_ERROR
public const string CACHE_RECORD_ITEM_DISPOSE_ERROR
Public Const CACHE_RECORD_ITEM_DISPOSE_ERROR As String
Public Const CACHE_RECORD_ITEM_DISPOSE_ERROR As String
public:
literal String^ CACHE_RECORD_ITEM_DISPOSE_ERROR
public:
literal String^ CACHE_RECORD_ITEM_DISPOSE_ERROR
static val mutable CACHE_RECORD_ITEM_DISPOSE_ERROR: string
static val mutable CACHE_RECORD_ITEM_DISPOSE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CACHE_TABLE_CTOR_SIZES_WARNING Field

StringConsts CACHE_TABLE_CTOR_SIZES_WARNING Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CACHE_TABLE_CTOR_SIZES_WARNING
public const string CACHE_TABLE_CTOR_SIZES_WARNING
Public Const CACHE_TABLE_CTOR_SIZES_WARNING As String
Public Const CACHE_TABLE_CTOR_SIZES_WARNING As String
public:
literal String^ CACHE_TABLE_CTOR_SIZES_WARNING
public:
literal String^ CACHE_TABLE_CTOR_SIZES_WARNING
static val mutable CACHE_TABLE_CTOR_SIZES_WARNING: string
static val mutable CACHE_TABLE_CTOR_SIZES_WARNING: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CACHE_VALUE_FACTORY_ERROR Field

StringConsts CACHE_VALUE_FACTORY_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CACHE_VALUE_FACTORY_ERROR
public const string CACHE_VALUE_FACTORY_ERROR
Public Const CACHE_VALUE_FACTORY_ERROR As String
Public Const CACHE_VALUE_FACTORY_ERROR As String
public:
literal String^ CACHE_VALUE_FACTORY_ERROR
public:
literal String^ CACHE_VALUE_FACTORY_ERROR
static val mutable CACHE_VALUE_FACTORY_ERROR: string
static val mutable CACHE_VALUE_FACTORY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CALC_FIELD_CHANGE_ERROR Field

StringConsts CALC_FIELD_CHANGE_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CALC_FIELD_CHANGE_ERROR
public const string CALC_FIELD_CHANGE_ERROR
Public Const CALC_FIELD_CHANGE_ERROR As String
Public Const CALC_FIELD_CHANGE_ERROR As String
public:
literal String^ CALC_FIELD_CHANGE_ERROR
public:
literal String^ CALC_FIELD_CHANGE_ERROR
static val mutable CALC_FIELD_CHANGE_ERROR: string
static val mutable CALC_FIELD_CHANGE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CAN_NOT_ADD_FAILED_SCOPE_COMPILE_ERROR Field

StringConsts CAN_NOT_ADD_FAILED_SCOPE_COMPILE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CAN_NOT_ADD_FAILED_SCOPE_COMPILE_ERROR
public const string CAN_NOT_ADD_FAILED_SCOPE_COMPILE_ERROR
Public Const CAN_NOT_ADD_FAILED_SCOPE_COMPILE_ERROR As String
Public Const CAN_NOT_ADD_FAILED_SCOPE_COMPILE_ERROR As String
public:
literal String^ CAN_NOT_ADD_FAILED_SCOPE_COMPILE_ERROR
public:
literal String^ CAN_NOT_ADD_FAILED_SCOPE_COMPILE_ERROR
static val mutable CAN_NOT_ADD_FAILED_SCOPE_COMPILE_ERROR: string
static val mutable CAN_NOT_ADD_FAILED_SCOPE_COMPILE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CAN_NOT_CREATE_MORE_SCOPE_EXPRESSIONS_ERROR Field

StringConsts CAN_NOT_CREATE_MORE_SCOPE_EXPRESSIONS_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CAN_NOT_CREATE_MORE_SCOPE_EXPRESSIONS_ERROR
public const string CAN_NOT_CREATE_MORE_SCOPE_EXPRESSIONS_ERROR
Public Const CAN_NOT_CREATE_MORE_SCOPE_EXPRESSIONS_ERROR As String
Public Const CAN_NOT_CREATE_MORE_SCOPE_EXPRESSIONS_ERROR As String
public:
literal String^ CAN_NOT_CREATE_MORE_SCOPE_EXPRESSIONS_ERROR
public:
literal String^ CAN_NOT_CREATE_MORE_SCOPE_EXPRESSIONS_ERROR
static val mutable CAN_NOT_CREATE_MORE_SCOPE_EXPRESSIONS_ERROR: string
static val mutable CAN_NOT_CREATE_MORE_SCOPE_EXPRESSIONS_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CANNOT_RETURN_NULL_ERROR Field

StringConsts CANNOT_RETURN_NULL_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CANNOT_RETURN_NULL_ERROR
public const string CANNOT_RETURN_NULL_ERROR
Public Const CANNOT_RETURN_NULL_ERROR As String
Public Const CANNOT_RETURN_NULL_ERROR As String
public:
literal String^ CANNOT_RETURN_NULL_ERROR
public:
literal String^ CANNOT_RETURN_NULL_ERROR
static val mutable CANNOT_RETURN_NULL_ERROR: string
static val mutable CANNOT_RETURN_NULL_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CHECK_LIST_ALREADY_RUN_ERROR Field

StringConsts CHECK_LIST_ALREADY_RUN_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CHECK_LIST_ALREADY_RUN_ERROR
public const string CHECK_LIST_ALREADY_RUN_ERROR
Public Const CHECK_LIST_ALREADY_RUN_ERROR As String
Public Const CHECK_LIST_ALREADY_RUN_ERROR As String
public:
literal String^ CHECK_LIST_ALREADY_RUN_ERROR
public:
literal String^ CHECK_LIST_ALREADY_RUN_ERROR
static val mutable CHECK_LIST_ALREADY_RUN_ERROR: string
static val mutable CHECK_LIST_ALREADY_RUN_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CLR_BSON_CONVERSION_REFERENCE_CYCLE_ERROR Field

StringConsts CLR_BSON_CONVERSION_REFERENCE_CYCLE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CLR_BSON_CONVERSION_REFERENCE_CYCLE_ERROR
public const string CLR_BSON_CONVERSION_REFERENCE_CYCLE_ERROR
Public Const CLR_BSON_CONVERSION_REFERENCE_CYCLE_ERROR As String
Public Const CLR_BSON_CONVERSION_REFERENCE_CYCLE_ERROR As String
public:
literal String^ CLR_BSON_CONVERSION_REFERENCE_CYCLE_ERROR
public:
literal String^ CLR_BSON_CONVERSION_REFERENCE_CYCLE_ERROR
static val mutable CLR_BSON_CONVERSION_REFERENCE_CYCLE_ERROR: string
static val mutable CLR_BSON_CONVERSION_REFERENCE_CYCLE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CLR_BSON_CONVERSION_TYPE_NOT_SUPPORTED_ERROR Field

StringConsts CLR_BSON_CONVERSION_TYPE_NOT_SUPPORTED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CLR_BSON_CONVERSION_TYPE_NOT_SUPPORTED_ERROR
public const string CLR_BSON_CONVERSION_TYPE_NOT_SUPPORTED_ERROR
Public Const CLR_BSON_CONVERSION_TYPE_NOT_SUPPORTED_ERROR As String
Public Const CLR_BSON_CONVERSION_TYPE_NOT_SUPPORTED_ERROR As String
public:
literal String^ CLR_BSON_CONVERSION_TYPE_NOT_SUPPORTED_ERROR
public:
literal String^ CLR_BSON_CONVERSION_TYPE_NOT_SUPPORTED_ERROR
static val mutable CLR_BSON_CONVERSION_TYPE_NOT_SUPPORTED_ERROR: string
static val mutable CLR_BSON_CONVERSION_TYPE_NOT_SUPPORTED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CODE_LOGIC_ERROR Field

StringConsts CODE_LOGIC_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CODE_LOGIC_ERROR
public const string CODE_LOGIC_ERROR
Public Const CODE_LOGIC_ERROR As String
Public Const CODE_LOGIC_ERROR As String
public:
literal String^ CODE_LOGIC_ERROR
public:
literal String^ CODE_LOGIC_ERROR
static val mutable CODE_LOGIC_ERROR: string
static val mutable CODE_LOGIC_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIG_BEHAVIOR_APPLY_ERROR Field

StringConsts CONFIG_BEHAVIOR_APPLY_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_BEHAVIOR_APPLY_ERROR
public const string CONFIG_BEHAVIOR_APPLY_ERROR
Public Const CONFIG_BEHAVIOR_APPLY_ERROR As String
Public Const CONFIG_BEHAVIOR_APPLY_ERROR As String
public:
literal String^ CONFIG_BEHAVIOR_APPLY_ERROR
public:
literal String^ CONFIG_BEHAVIOR_APPLY_ERROR
static val mutable CONFIG_BEHAVIOR_APPLY_ERROR: string
static val mutable CONFIG_BEHAVIOR_APPLY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIG_JSON_MAP_ERROR Field

StringConsts CONFIG_JSON_MAP_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_JSON_MAP_ERROR
public const string CONFIG_JSON_MAP_ERROR
Public Const CONFIG_JSON_MAP_ERROR As String
Public Const CONFIG_JSON_MAP_ERROR As String
public:
literal String^ CONFIG_JSON_MAP_ERROR
public:
literal String^ CONFIG_JSON_MAP_ERROR
static val mutable CONFIG_JSON_MAP_ERROR: string
static val mutable CONFIG_JSON_MAP_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIG_JSON_STRUCTURE_ERROR Field

StringConsts CONFIG_JSON_STRUCTURE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_JSON_STRUCTURE_ERROR
public const string CONFIG_JSON_STRUCTURE_ERROR
Public Const CONFIG_JSON_STRUCTURE_ERROR As String
Public Const CONFIG_JSON_STRUCTURE_ERROR As String
public:
literal String^ CONFIG_JSON_STRUCTURE_ERROR
public:
literal String^ CONFIG_JSON_STRUCTURE_ERROR
static val mutable CONFIG_JSON_STRUCTURE_ERROR: string
static val mutable CONFIG_JSON_STRUCTURE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIG_NO_PROVIDER_LOAD_FILE_ERROR Field

StringConsts CONFIG_NO_PROVIDER_LOAD_FILE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_NO_PROVIDER_LOAD_FILE_ERROR
public const string CONFIG_NO_PROVIDER_LOAD_FILE_ERROR
Public Const CONFIG_NO_PROVIDER_LOAD_FILE_ERROR As String
Public Const CONFIG_NO_PROVIDER_LOAD_FILE_ERROR As String
public:
literal String^ CONFIG_NO_PROVIDER_LOAD_FILE_ERROR
public:
literal String^ CONFIG_NO_PROVIDER_LOAD_FILE_ERROR
static val mutable CONFIG_NO_PROVIDER_LOAD_FILE_ERROR: string
static val mutable CONFIG_NO_PROVIDER_LOAD_FILE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIG_NO_PROVIDER_LOAD_FORMAT_ERROR Field

StringConsts CONFIG_NO_PROVIDER_LOAD_FORMAT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_NO_PROVIDER_LOAD_FORMAT_ERROR
public const string CONFIG_NO_PROVIDER_LOAD_FORMAT_ERROR
Public Const CONFIG_NO_PROVIDER_LOAD_FORMAT_ERROR As String
Public Const CONFIG_NO_PROVIDER_LOAD_FORMAT_ERROR As String
public:
literal String^ CONFIG_NO_PROVIDER_LOAD_FORMAT_ERROR
public:
literal String^ CONFIG_NO_PROVIDER_LOAD_FORMAT_ERROR
static val mutable CONFIG_NO_PROVIDER_LOAD_FORMAT_ERROR: string
static val mutable CONFIG_NO_PROVIDER_LOAD_FORMAT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIG_RECURSIVE_VARS_ERROR Field

StringConsts CONFIG_RECURSIVE_VARS_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_RECURSIVE_VARS_ERROR
public const string CONFIG_RECURSIVE_VARS_ERROR
Public Const CONFIG_RECURSIVE_VARS_ERROR As String
Public Const CONFIG_RECURSIVE_VARS_ERROR As String
public:
literal String^ CONFIG_RECURSIVE_VARS_ERROR
public:
literal String^ CONFIG_RECURSIVE_VARS_ERROR
static val mutable CONFIG_RECURSIVE_VARS_ERROR: string
static val mutable CONFIG_RECURSIVE_VARS_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIG_VARS_EVAL_ERROR Field

StringConsts CONFIG_VARS_EVAL_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_VARS_EVAL_ERROR
public const string CONFIG_VARS_EVAL_ERROR
Public Const CONFIG_VARS_EVAL_ERROR As String
Public Const CONFIG_VARS_EVAL_ERROR As String
public:
literal String^ CONFIG_VARS_EVAL_ERROR
public:
literal String^ CONFIG_VARS_EVAL_ERROR
static val mutable CONFIG_VARS_EVAL_ERROR: string
static val mutable CONFIG_VARS_EVAL_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_ATTR_APPLY_VALUE_ERROR Field

StringConsts CONFIGURATION_ATTR_APPLY_VALUE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_ATTR_APPLY_VALUE_ERROR
public const string CONFIGURATION_ATTR_APPLY_VALUE_ERROR
Public Const CONFIGURATION_ATTR_APPLY_VALUE_ERROR As String
Public Const CONFIGURATION_ATTR_APPLY_VALUE_ERROR As String
public:
literal String^ CONFIGURATION_ATTR_APPLY_VALUE_ERROR
public:
literal String^ CONFIGURATION_ATTR_APPLY_VALUE_ERROR
static val mutable CONFIGURATION_ATTR_APPLY_VALUE_ERROR: string
static val mutable CONFIGURATION_ATTR_APPLY_VALUE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_ATTRIBUTE_MEMBER_READONLY_ERROR Field

StringConsts CONFIGURATION_ATTRIBUTE_MEMBER_READONLY_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_ATTRIBUTE_MEMBER_READONLY_ERROR
public const string CONFIGURATION_ATTRIBUTE_MEMBER_READONLY_ERROR
Public Const CONFIGURATION_ATTRIBUTE_MEMBER_READONLY_ERROR As String
Public Const CONFIGURATION_ATTRIBUTE_MEMBER_READONLY_ERROR As String
public:
literal String^ CONFIGURATION_ATTRIBUTE_MEMBER_READONLY_ERROR
public:
literal String^ CONFIGURATION_ATTRIBUTE_MEMBER_READONLY_ERROR
static val mutable CONFIGURATION_ATTRIBUTE_MEMBER_READONLY_ERROR: string
static val mutable CONFIGURATION_ATTRIBUTE_MEMBER_READONLY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_CAN_NOT_INCLUDE_INSTEAD_OF_ROOT_ERROR Field

StringConsts CONFIGURATION_CAN_NOT_INCLUDE_INSTEAD_OF_ROOT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_CAN_NOT_INCLUDE_INSTEAD_OF_ROOT_ERROR
public const string CONFIGURATION_CAN_NOT_INCLUDE_INSTEAD_OF_ROOT_ERROR
Public Const CONFIGURATION_CAN_NOT_INCLUDE_INSTEAD_OF_ROOT_ERROR As String
Public Const CONFIGURATION_CAN_NOT_INCLUDE_INSTEAD_OF_ROOT_ERROR As String
public:
literal String^ CONFIGURATION_CAN_NOT_INCLUDE_INSTEAD_OF_ROOT_ERROR
public:
literal String^ CONFIGURATION_CAN_NOT_INCLUDE_INSTEAD_OF_ROOT_ERROR
static val mutable CONFIGURATION_CAN_NOT_INCLUDE_INSTEAD_OF_ROOT_ERROR: string
static val mutable CONFIGURATION_CAN_NOT_INCLUDE_INSTEAD_OF_ROOT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_CLONE_EMPTY_NODE_ERROR Field

StringConsts CONFIGURATION_CLONE_EMPTY_NODE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_CLONE_EMPTY_NODE_ERROR
public const string CONFIGURATION_CLONE_EMPTY_NODE_ERROR
Public Const CONFIGURATION_CLONE_EMPTY_NODE_ERROR As String
Public Const CONFIGURATION_CLONE_EMPTY_NODE_ERROR As String
public:
literal String^ CONFIGURATION_CLONE_EMPTY_NODE_ERROR
public:
literal String^ CONFIGURATION_CLONE_EMPTY_NODE_ERROR
static val mutable CONFIGURATION_CLONE_EMPTY_NODE_ERROR: string
static val mutable CONFIGURATION_CLONE_EMPTY_NODE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_EMPTY_NODE_MODIFY_ERROR Field

StringConsts CONFIGURATION_EMPTY_NODE_MODIFY_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_EMPTY_NODE_MODIFY_ERROR
public const string CONFIGURATION_EMPTY_NODE_MODIFY_ERROR
Public Const CONFIGURATION_EMPTY_NODE_MODIFY_ERROR As String
Public Const CONFIGURATION_EMPTY_NODE_MODIFY_ERROR As String
public:
literal String^ CONFIGURATION_EMPTY_NODE_MODIFY_ERROR
public:
literal String^ CONFIGURATION_EMPTY_NODE_MODIFY_ERROR
static val mutable CONFIGURATION_EMPTY_NODE_MODIFY_ERROR: string
static val mutable CONFIGURATION_EMPTY_NODE_MODIFY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_ENTITY_NAME_ERROR Field

StringConsts CONFIGURATION_ENTITY_NAME_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_ENTITY_NAME_ERROR
public const string CONFIGURATION_ENTITY_NAME_ERROR
Public Const CONFIGURATION_ENTITY_NAME_ERROR As String
Public Const CONFIGURATION_ENTITY_NAME_ERROR As String
public:
literal String^ CONFIGURATION_ENTITY_NAME_ERROR
public:
literal String^ CONFIGURATION_ENTITY_NAME_ERROR
static val mutable CONFIGURATION_ENTITY_NAME_ERROR: string
static val mutable CONFIGURATION_ENTITY_NAME_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_FILE_UNKNOWN_ERROR Field

StringConsts CONFIGURATION_FILE_UNKNOWN_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_FILE_UNKNOWN_ERROR
public const string CONFIGURATION_FILE_UNKNOWN_ERROR
Public Const CONFIGURATION_FILE_UNKNOWN_ERROR As String
Public Const CONFIGURATION_FILE_UNKNOWN_ERROR As String
public:
literal String^ CONFIGURATION_FILE_UNKNOWN_ERROR
public:
literal String^ CONFIGURATION_FILE_UNKNOWN_ERROR
static val mutable CONFIGURATION_FILE_UNKNOWN_ERROR: string
static val mutable CONFIGURATION_FILE_UNKNOWN_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_INCLUDE_PRAGMA_ERROR Field

StringConsts CONFIGURATION_INCLUDE_PRAGMA_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_INCLUDE_PRAGMA_ERROR
public const string CONFIGURATION_INCLUDE_PRAGMA_ERROR
Public Const CONFIGURATION_INCLUDE_PRAGMA_ERROR As String
Public Const CONFIGURATION_INCLUDE_PRAGMA_ERROR As String
public:
literal String^ CONFIGURATION_INCLUDE_PRAGMA_ERROR
public:
literal String^ CONFIGURATION_INCLUDE_PRAGMA_ERROR
static val mutable CONFIGURATION_INCLUDE_PRAGMA_ERROR: string
static val mutable CONFIGURATION_INCLUDE_PRAGMA_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_MAKE_USING_CTOR_ERROR Field

StringConsts CONFIGURATION_MAKE_USING_CTOR_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_MAKE_USING_CTOR_ERROR
public const string CONFIGURATION_MAKE_USING_CTOR_ERROR
Public Const CONFIGURATION_MAKE_USING_CTOR_ERROR As String
Public Const CONFIGURATION_MAKE_USING_CTOR_ERROR As String
public:
literal String^ CONFIGURATION_MAKE_USING_CTOR_ERROR
public:
literal String^ CONFIGURATION_MAKE_USING_CTOR_ERROR
static val mutable CONFIGURATION_MAKE_USING_CTOR_ERROR: string
static val mutable CONFIGURATION_MAKE_USING_CTOR_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_NAVIGATION_BAD_PATH_ERROR Field

StringConsts CONFIGURATION_NAVIGATION_BAD_PATH_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_NAVIGATION_BAD_PATH_ERROR
public const string CONFIGURATION_NAVIGATION_BAD_PATH_ERROR
Public Const CONFIGURATION_NAVIGATION_BAD_PATH_ERROR As String
Public Const CONFIGURATION_NAVIGATION_BAD_PATH_ERROR As String
public:
literal String^ CONFIGURATION_NAVIGATION_BAD_PATH_ERROR
public:
literal String^ CONFIGURATION_NAVIGATION_BAD_PATH_ERROR
static val mutable CONFIGURATION_NAVIGATION_BAD_PATH_ERROR: string
static val mutable CONFIGURATION_NAVIGATION_BAD_PATH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_NAVIGATION_REQUIRED_ERROR Field

StringConsts CONFIGURATION_NAVIGATION_REQUIRED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_NAVIGATION_REQUIRED_ERROR
public const string CONFIGURATION_NAVIGATION_REQUIRED_ERROR
Public Const CONFIGURATION_NAVIGATION_REQUIRED_ERROR As String
Public Const CONFIGURATION_NAVIGATION_REQUIRED_ERROR As String
public:
literal String^ CONFIGURATION_NAVIGATION_REQUIRED_ERROR
public:
literal String^ CONFIGURATION_NAVIGATION_REQUIRED_ERROR
static val mutable CONFIGURATION_NAVIGATION_REQUIRED_ERROR: string
static val mutable CONFIGURATION_NAVIGATION_REQUIRED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_NAVIGATION_SECTION_REQUIRED_ERROR Field

StringConsts CONFIGURATION_NAVIGATION_SECTION_REQUIRED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_NAVIGATION_SECTION_REQUIRED_ERROR
public const string CONFIGURATION_NAVIGATION_SECTION_REQUIRED_ERROR
Public Const CONFIGURATION_NAVIGATION_SECTION_REQUIRED_ERROR As String
Public Const CONFIGURATION_NAVIGATION_SECTION_REQUIRED_ERROR As String
public:
literal String^ CONFIGURATION_NAVIGATION_SECTION_REQUIRED_ERROR
public:
literal String^ CONFIGURATION_NAVIGATION_SECTION_REQUIRED_ERROR
static val mutable CONFIGURATION_NAVIGATION_SECTION_REQUIRED_ERROR: string
static val mutable CONFIGURATION_NAVIGATION_SECTION_REQUIRED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_NODE_DOES_NOT_BELONG_TO_THIS_CONFIGURATION_ERROR Field

StringConsts CONFIGURATION_NODE_DOES_NOT_BELONG_TO_THIS_CONFIGURATION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_NODE_DOES_NOT_BELONG_TO_THIS_CONFIGURATION_ERROR
public const string CONFIGURATION_NODE_DOES_NOT_BELONG_TO_THIS_CONFIGURATION_ERROR
Public Const CONFIGURATION_NODE_DOES_NOT_BELONG_TO_THIS_CONFIGURATION_ERROR As String
Public Const CONFIGURATION_NODE_DOES_NOT_BELONG_TO_THIS_CONFIGURATION_ERROR As String
public:
literal String^ CONFIGURATION_NODE_DOES_NOT_BELONG_TO_THIS_CONFIGURATION_ERROR
public:
literal String^ CONFIGURATION_NODE_DOES_NOT_BELONG_TO_THIS_CONFIGURATION_ERROR
static val mutable CONFIGURATION_NODE_DOES_NOT_BELONG_TO_THIS_CONFIGURATION_ERROR: string
static val mutable CONFIGURATION_NODE_DOES_NOT_BELONG_TO_THIS_CONFIGURATION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_NODE_MUST_NOT_BELONG_TO_THIS_CONFIGURATION_ERROR Field

StringConsts CONFIGURATION_NODE_MUST_NOT_BELONG_TO_THIS_CONFIGURATION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_NODE_MUST_NOT_BELONG_TO_THIS_CONFIGURATION_ERROR
public const string CONFIGURATION_NODE_MUST_NOT_BELONG_TO_THIS_CONFIGURATION_ERROR
Public Const CONFIGURATION_NODE_MUST_NOT_BELONG_TO_THIS_CONFIGURATION_ERROR As String
Public Const CONFIGURATION_NODE_MUST_NOT_BELONG_TO_THIS_CONFIGURATION_ERROR As String
public:
literal String^ CONFIGURATION_NODE_MUST_NOT_BELONG_TO_THIS_CONFIGURATION_ERROR
public:
literal String^ CONFIGURATION_NODE_MUST_NOT_BELONG_TO_THIS_CONFIGURATION_ERROR
static val mutable CONFIGURATION_NODE_MUST_NOT_BELONG_TO_THIS_CONFIGURATION_ERROR: string
static val mutable CONFIGURATION_NODE_MUST_NOT_BELONG_TO_THIS_CONFIGURATION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_NODE_NAME_ERROR Field

StringConsts CONFIGURATION_NODE_NAME_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_NODE_NAME_ERROR
public const string CONFIGURATION_NODE_NAME_ERROR
Public Const CONFIGURATION_NODE_NAME_ERROR As String
Public Const CONFIGURATION_NODE_NAME_ERROR As String
public:
literal String^ CONFIGURATION_NODE_NAME_ERROR
public:
literal String^ CONFIGURATION_NODE_NAME_ERROR
static val mutable CONFIGURATION_NODE_NAME_ERROR: string
static val mutable CONFIGURATION_NODE_NAME_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_OVERRIDE_PROHOBITED_ERROR Field

StringConsts CONFIGURATION_OVERRIDE_PROHOBITED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_OVERRIDE_PROHOBITED_ERROR
public const string CONFIGURATION_OVERRIDE_PROHOBITED_ERROR
Public Const CONFIGURATION_OVERRIDE_PROHOBITED_ERROR As String
Public Const CONFIGURATION_OVERRIDE_PROHOBITED_ERROR As String
public:
literal String^ CONFIGURATION_OVERRIDE_PROHOBITED_ERROR
public:
literal String^ CONFIGURATION_OVERRIDE_PROHOBITED_ERROR
static val mutable CONFIGURATION_OVERRIDE_PROHOBITED_ERROR: string
static val mutable CONFIGURATION_OVERRIDE_PROHOBITED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_OVERRIDE_SPEC_ERROR Field

StringConsts CONFIGURATION_OVERRIDE_SPEC_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_OVERRIDE_SPEC_ERROR
public const string CONFIGURATION_OVERRIDE_SPEC_ERROR
Public Const CONFIGURATION_OVERRIDE_SPEC_ERROR As String
Public Const CONFIGURATION_OVERRIDE_SPEC_ERROR As String
public:
literal String^ CONFIGURATION_OVERRIDE_SPEC_ERROR
public:
literal String^ CONFIGURATION_OVERRIDE_SPEC_ERROR
static val mutable CONFIGURATION_OVERRIDE_SPEC_ERROR: string
static val mutable CONFIGURATION_OVERRIDE_SPEC_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_PATH_ICONFIGSECTION_SECTION_ERROR Field

StringConsts CONFIGURATION_PATH_ICONFIGSECTION_SECTION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_PATH_ICONFIGSECTION_SECTION_ERROR
public const string CONFIGURATION_PATH_ICONFIGSECTION_SECTION_ERROR
Public Const CONFIGURATION_PATH_ICONFIGSECTION_SECTION_ERROR As String
Public Const CONFIGURATION_PATH_ICONFIGSECTION_SECTION_ERROR As String
public:
literal String^ CONFIGURATION_PATH_ICONFIGSECTION_SECTION_ERROR
public:
literal String^ CONFIGURATION_PATH_ICONFIGSECTION_SECTION_ERROR
static val mutable CONFIGURATION_PATH_ICONFIGSECTION_SECTION_ERROR: string
static val mutable CONFIGURATION_PATH_ICONFIGSECTION_SECTION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_PATH_ICONFIGURABLE_SECTION_ERROR Field

StringConsts CONFIGURATION_PATH_ICONFIGURABLE_SECTION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_PATH_ICONFIGURABLE_SECTION_ERROR
public const string CONFIGURATION_PATH_ICONFIGURABLE_SECTION_ERROR
Public Const CONFIGURATION_PATH_ICONFIGURABLE_SECTION_ERROR As String
Public Const CONFIGURATION_PATH_ICONFIGURABLE_SECTION_ERROR As String
public:
literal String^ CONFIGURATION_PATH_ICONFIGURABLE_SECTION_ERROR
public:
literal String^ CONFIGURATION_PATH_ICONFIGURABLE_SECTION_ERROR
static val mutable CONFIGURATION_PATH_ICONFIGURABLE_SECTION_ERROR: string
static val mutable CONFIGURATION_PATH_ICONFIGURABLE_SECTION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_PATH_INDEXER_ERROR Field

StringConsts CONFIGURATION_PATH_INDEXER_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_PATH_INDEXER_ERROR
public const string CONFIGURATION_PATH_INDEXER_ERROR
Public Const CONFIGURATION_PATH_INDEXER_ERROR As String
Public Const CONFIGURATION_PATH_INDEXER_ERROR As String
public:
literal String^ CONFIGURATION_PATH_INDEXER_ERROR
public:
literal String^ CONFIGURATION_PATH_INDEXER_ERROR
static val mutable CONFIGURATION_PATH_INDEXER_ERROR: string
static val mutable CONFIGURATION_PATH_INDEXER_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_PATH_INDEXER_SYNTAX_ERROR Field

StringConsts CONFIGURATION_PATH_INDEXER_SYNTAX_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_PATH_INDEXER_SYNTAX_ERROR
public const string CONFIGURATION_PATH_INDEXER_SYNTAX_ERROR
Public Const CONFIGURATION_PATH_INDEXER_SYNTAX_ERROR As String
Public Const CONFIGURATION_PATH_INDEXER_SYNTAX_ERROR As String
public:
literal String^ CONFIGURATION_PATH_INDEXER_SYNTAX_ERROR
public:
literal String^ CONFIGURATION_PATH_INDEXER_SYNTAX_ERROR
static val mutable CONFIGURATION_PATH_INDEXER_SYNTAX_ERROR: string
static val mutable CONFIGURATION_PATH_INDEXER_SYNTAX_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_PATH_SEGMENT_NOT_SECTION_ERROR Field

StringConsts CONFIGURATION_PATH_SEGMENT_NOT_SECTION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_PATH_SEGMENT_NOT_SECTION_ERROR
public const string CONFIGURATION_PATH_SEGMENT_NOT_SECTION_ERROR
Public Const CONFIGURATION_PATH_SEGMENT_NOT_SECTION_ERROR As String
Public Const CONFIGURATION_PATH_SEGMENT_NOT_SECTION_ERROR As String
public:
literal String^ CONFIGURATION_PATH_SEGMENT_NOT_SECTION_ERROR
public:
literal String^ CONFIGURATION_PATH_SEGMENT_NOT_SECTION_ERROR
static val mutable CONFIGURATION_PATH_SEGMENT_NOT_SECTION_ERROR: string
static val mutable CONFIGURATION_PATH_SEGMENT_NOT_SECTION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_PATH_VALUE_INDEXER_CAN_NOT_USE_WITH_ATTRS_ERROR Field

StringConsts CONFIGURATION_PATH_VALUE_INDEXER_CAN_NOT_USE_WITH_ATTRS_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_PATH_VALUE_INDEXER_CAN_NOT_USE_WITH_ATTRS_ERROR
public const string CONFIGURATION_PATH_VALUE_INDEXER_CAN_NOT_USE_WITH_ATTRS_ERROR
Public Const CONFIGURATION_PATH_VALUE_INDEXER_CAN_NOT_USE_WITH_ATTRS_ERROR As String
Public Const CONFIGURATION_PATH_VALUE_INDEXER_CAN_NOT_USE_WITH_ATTRS_ERROR As String
public:
literal String^ CONFIGURATION_PATH_VALUE_INDEXER_CAN_NOT_USE_WITH_ATTRS_ERROR
public:
literal String^ CONFIGURATION_PATH_VALUE_INDEXER_CAN_NOT_USE_WITH_ATTRS_ERROR
static val mutable CONFIGURATION_PATH_VALUE_INDEXER_CAN_NOT_USE_WITH_ATTRS_ERROR: string
static val mutable CONFIGURATION_PATH_VALUE_INDEXER_CAN_NOT_USE_WITH_ATTRS_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_PATH_VALUE_INDEXER_SYNTAX_ERROR Field

StringConsts CONFIGURATION_PATH_VALUE_INDEXER_SYNTAX_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_PATH_VALUE_INDEXER_SYNTAX_ERROR
public const string CONFIGURATION_PATH_VALUE_INDEXER_SYNTAX_ERROR
Public Const CONFIGURATION_PATH_VALUE_INDEXER_SYNTAX_ERROR As String
Public Const CONFIGURATION_PATH_VALUE_INDEXER_SYNTAX_ERROR As String
public:
literal String^ CONFIGURATION_PATH_VALUE_INDEXER_SYNTAX_ERROR
public:
literal String^ CONFIGURATION_PATH_VALUE_INDEXER_SYNTAX_ERROR
static val mutable CONFIGURATION_PATH_VALUE_INDEXER_SYNTAX_ERROR: string
static val mutable CONFIGURATION_PATH_VALUE_INDEXER_SYNTAX_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_READONLY_ERROR Field

StringConsts CONFIGURATION_READONLY_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_READONLY_ERROR
public const string CONFIGURATION_READONLY_ERROR
Public Const CONFIGURATION_READONLY_ERROR As String
Public Const CONFIGURATION_READONLY_ERROR As String
public:
literal String^ CONFIGURATION_READONLY_ERROR
public:
literal String^ CONFIGURATION_READONLY_ERROR
static val mutable CONFIGURATION_READONLY_ERROR: string
static val mutable CONFIGURATION_READONLY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_SCRIPT_CALL_TARGET_PATH_ERROR Field

StringConsts CONFIGURATION_SCRIPT_CALL_TARGET_PATH_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_SCRIPT_CALL_TARGET_PATH_ERROR
public const string CONFIGURATION_SCRIPT_CALL_TARGET_PATH_ERROR
Public Const CONFIGURATION_SCRIPT_CALL_TARGET_PATH_ERROR As String
Public Const CONFIGURATION_SCRIPT_CALL_TARGET_PATH_ERROR As String
public:
literal String^ CONFIGURATION_SCRIPT_CALL_TARGET_PATH_ERROR
public:
literal String^ CONFIGURATION_SCRIPT_CALL_TARGET_PATH_ERROR
static val mutable CONFIGURATION_SCRIPT_CALL_TARGET_PATH_ERROR: string
static val mutable CONFIGURATION_SCRIPT_CALL_TARGET_PATH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_SCRIPT_ELSE_NOT_AFTER_IF_ERROR Field

StringConsts CONFIGURATION_SCRIPT_ELSE_NOT_AFTER_IF_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_SCRIPT_ELSE_NOT_AFTER_IF_ERROR
public const string CONFIGURATION_SCRIPT_ELSE_NOT_AFTER_IF_ERROR
Public Const CONFIGURATION_SCRIPT_ELSE_NOT_AFTER_IF_ERROR As String
Public Const CONFIGURATION_SCRIPT_ELSE_NOT_AFTER_IF_ERROR As String
public:
literal String^ CONFIGURATION_SCRIPT_ELSE_NOT_AFTER_IF_ERROR
public:
literal String^ CONFIGURATION_SCRIPT_ELSE_NOT_AFTER_IF_ERROR
static val mutable CONFIGURATION_SCRIPT_ELSE_NOT_AFTER_IF_ERROR: string
static val mutable CONFIGURATION_SCRIPT_ELSE_NOT_AFTER_IF_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_SCRIPT_EXECUTION_ERROR Field

StringConsts CONFIGURATION_SCRIPT_EXECUTION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_SCRIPT_EXECUTION_ERROR
public const string CONFIGURATION_SCRIPT_EXECUTION_ERROR
Public Const CONFIGURATION_SCRIPT_EXECUTION_ERROR As String
Public Const CONFIGURATION_SCRIPT_EXECUTION_ERROR As String
public:
literal String^ CONFIGURATION_SCRIPT_EXECUTION_ERROR
public:
literal String^ CONFIGURATION_SCRIPT_EXECUTION_ERROR
static val mutable CONFIGURATION_SCRIPT_EXECUTION_ERROR: string
static val mutable CONFIGURATION_SCRIPT_EXECUTION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_SCRIPT_EXPRESSION_EVAL_ERROR Field

StringConsts CONFIGURATION_SCRIPT_EXPRESSION_EVAL_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_SCRIPT_EXPRESSION_EVAL_ERROR
public const string CONFIGURATION_SCRIPT_EXPRESSION_EVAL_ERROR
Public Const CONFIGURATION_SCRIPT_EXPRESSION_EVAL_ERROR As String
Public Const CONFIGURATION_SCRIPT_EXPRESSION_EVAL_ERROR As String
public:
literal String^ CONFIGURATION_SCRIPT_EXPRESSION_EVAL_ERROR
public:
literal String^ CONFIGURATION_SCRIPT_EXPRESSION_EVAL_ERROR
static val mutable CONFIGURATION_SCRIPT_EXPRESSION_EVAL_ERROR: string
static val mutable CONFIGURATION_SCRIPT_EXPRESSION_EVAL_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_SCRIPT_SET_PATH_ERROR Field

StringConsts CONFIGURATION_SCRIPT_SET_PATH_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_SCRIPT_SET_PATH_ERROR
public const string CONFIGURATION_SCRIPT_SET_PATH_ERROR
Public Const CONFIGURATION_SCRIPT_SET_PATH_ERROR As String
Public Const CONFIGURATION_SCRIPT_SET_PATH_ERROR As String
public:
literal String^ CONFIGURATION_SCRIPT_SET_PATH_ERROR
public:
literal String^ CONFIGURATION_SCRIPT_SET_PATH_ERROR
static val mutable CONFIGURATION_SCRIPT_SET_PATH_ERROR: string
static val mutable CONFIGURATION_SCRIPT_SET_PATH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_SCRIPT_SYNTAX_ERROR Field

StringConsts CONFIGURATION_SCRIPT_SYNTAX_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_SCRIPT_SYNTAX_ERROR
public const string CONFIGURATION_SCRIPT_SYNTAX_ERROR
Public Const CONFIGURATION_SCRIPT_SYNTAX_ERROR As String
Public Const CONFIGURATION_SCRIPT_SYNTAX_ERROR As String
public:
literal String^ CONFIGURATION_SCRIPT_SYNTAX_ERROR
public:
literal String^ CONFIGURATION_SCRIPT_SYNTAX_ERROR
static val mutable CONFIGURATION_SCRIPT_SYNTAX_ERROR: string
static val mutable CONFIGURATION_SCRIPT_SYNTAX_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_SCRIPT_TARGET_CONFIGURATION_MUST_BE_EMPTY_ERROR Field

StringConsts CONFIGURATION_SCRIPT_TARGET_CONFIGURATION_MUST_BE_EMPTY_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_SCRIPT_TARGET_CONFIGURATION_MUST_BE_EMPTY_ERROR
public const string CONFIGURATION_SCRIPT_TARGET_CONFIGURATION_MUST_BE_EMPTY_ERROR
Public Const CONFIGURATION_SCRIPT_TARGET_CONFIGURATION_MUST_BE_EMPTY_ERROR As String
Public Const CONFIGURATION_SCRIPT_TARGET_CONFIGURATION_MUST_BE_EMPTY_ERROR As String
public:
literal String^ CONFIGURATION_SCRIPT_TARGET_CONFIGURATION_MUST_BE_EMPTY_ERROR
public:
literal String^ CONFIGURATION_SCRIPT_TARGET_CONFIGURATION_MUST_BE_EMPTY_ERROR
static val mutable CONFIGURATION_SCRIPT_TARGET_CONFIGURATION_MUST_BE_EMPTY_ERROR: string
static val mutable CONFIGURATION_SCRIPT_TARGET_CONFIGURATION_MUST_BE_EMPTY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_SCRIPT_TIMEOUT_ERROR Field

StringConsts CONFIGURATION_SCRIPT_TIMEOUT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_SCRIPT_TIMEOUT_ERROR
public const string CONFIGURATION_SCRIPT_TIMEOUT_ERROR
Public Const CONFIGURATION_SCRIPT_TIMEOUT_ERROR As String
Public Const CONFIGURATION_SCRIPT_TIMEOUT_ERROR As String
public:
literal String^ CONFIGURATION_SCRIPT_TIMEOUT_ERROR
public:
literal String^ CONFIGURATION_SCRIPT_TIMEOUT_ERROR
static val mutable CONFIGURATION_SCRIPT_TIMEOUT_ERROR: string
static val mutable CONFIGURATION_SCRIPT_TIMEOUT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_SECTION_INDEXER_EMPTY_ERROR Field

StringConsts CONFIGURATION_SECTION_INDEXER_EMPTY_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_SECTION_INDEXER_EMPTY_ERROR
public const string CONFIGURATION_SECTION_INDEXER_EMPTY_ERROR
Public Const CONFIGURATION_SECTION_INDEXER_EMPTY_ERROR As String
Public Const CONFIGURATION_SECTION_INDEXER_EMPTY_ERROR As String
public:
literal String^ CONFIGURATION_SECTION_INDEXER_EMPTY_ERROR
public:
literal String^ CONFIGURATION_SECTION_INDEXER_EMPTY_ERROR
static val mutable CONFIGURATION_SECTION_INDEXER_EMPTY_ERROR: string
static val mutable CONFIGURATION_SECTION_INDEXER_EMPTY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_TYPE_ASSIGNABILITY_ERROR Field

StringConsts CONFIGURATION_TYPE_ASSIGNABILITY_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_TYPE_ASSIGNABILITY_ERROR
public const string CONFIGURATION_TYPE_ASSIGNABILITY_ERROR
Public Const CONFIGURATION_TYPE_ASSIGNABILITY_ERROR As String
Public Const CONFIGURATION_TYPE_ASSIGNABILITY_ERROR As String
public:
literal String^ CONFIGURATION_TYPE_ASSIGNABILITY_ERROR
public:
literal String^ CONFIGURATION_TYPE_ASSIGNABILITY_ERROR
static val mutable CONFIGURATION_TYPE_ASSIGNABILITY_ERROR: string
static val mutable CONFIGURATION_TYPE_ASSIGNABILITY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_TYPE_CREATION_ERROR Field

StringConsts CONFIGURATION_TYPE_CREATION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_TYPE_CREATION_ERROR
public const string CONFIGURATION_TYPE_CREATION_ERROR
Public Const CONFIGURATION_TYPE_CREATION_ERROR As String
Public Const CONFIGURATION_TYPE_CREATION_ERROR As String
public:
literal String^ CONFIGURATION_TYPE_CREATION_ERROR
public:
literal String^ CONFIGURATION_TYPE_CREATION_ERROR
static val mutable CONFIGURATION_TYPE_CREATION_ERROR: string
static val mutable CONFIGURATION_TYPE_CREATION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_TYPE_NOT_SUPPLIED_ERROR Field

StringConsts CONFIGURATION_TYPE_NOT_SUPPLIED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_TYPE_NOT_SUPPLIED_ERROR
public const string CONFIGURATION_TYPE_NOT_SUPPLIED_ERROR
Public Const CONFIGURATION_TYPE_NOT_SUPPLIED_ERROR As String
Public Const CONFIGURATION_TYPE_NOT_SUPPLIED_ERROR As String
public:
literal String^ CONFIGURATION_TYPE_NOT_SUPPLIED_ERROR
public:
literal String^ CONFIGURATION_TYPE_NOT_SUPPLIED_ERROR
static val mutable CONFIGURATION_TYPE_NOT_SUPPLIED_ERROR: string
static val mutable CONFIGURATION_TYPE_NOT_SUPPLIED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_TYPE_RESOLVE_ERROR Field

StringConsts CONFIGURATION_TYPE_RESOLVE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_TYPE_RESOLVE_ERROR
public const string CONFIGURATION_TYPE_RESOLVE_ERROR
Public Const CONFIGURATION_TYPE_RESOLVE_ERROR As String
Public Const CONFIGURATION_TYPE_RESOLVE_ERROR As String
public:
literal String^ CONFIGURATION_TYPE_RESOLVE_ERROR
public:
literal String^ CONFIGURATION_TYPE_RESOLVE_ERROR
static val mutable CONFIGURATION_TYPE_RESOLVE_ERROR: string
static val mutable CONFIGURATION_TYPE_RESOLVE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CONFIGURATION_VALUE_COULD_NOT_BE_GOTTEN_AS_TYPE_ERROR Field

StringConsts CONFIGURATION_VALUE_COULD_NOT_BE_GOTTEN_AS_TYPE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_VALUE_COULD_NOT_BE_GOTTEN_AS_TYPE_ERROR
public const string CONFIGURATION_VALUE_COULD_NOT_BE_GOTTEN_AS_TYPE_ERROR
Public Const CONFIGURATION_VALUE_COULD_NOT_BE_GOTTEN_AS_TYPE_ERROR As String
Public Const CONFIGURATION_VALUE_COULD_NOT_BE_GOTTEN_AS_TYPE_ERROR As String
public:
literal String^ CONFIGURATION_VALUE_COULD_NOT_BE_GOTTEN_AS_TYPE_ERROR
public:
literal String^ CONFIGURATION_VALUE_COULD_NOT_BE_GOTTEN_AS_TYPE_ERROR
static val mutable CONFIGURATION_VALUE_COULD_NOT_BE_GOTTEN_AS_TYPE_ERROR: string
static val mutable CONFIGURATION_VALUE_COULD_NOT_BE_GOTTEN_AS_TYPE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_CONFIG_EMPTY_LOCATIONS_WARNING Field

StringConsts CRUD_CONFIG_EMPTY_LOCATIONS_WARNING Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_CONFIG_EMPTY_LOCATIONS_WARNING
public const string CRUD_CONFIG_EMPTY_LOCATIONS_WARNING
Public Const CRUD_CONFIG_EMPTY_LOCATIONS_WARNING As String
Public Const CRUD_CONFIG_EMPTY_LOCATIONS_WARNING As String
public:
literal String^ CRUD_CONFIG_EMPTY_LOCATIONS_WARNING
public:
literal String^ CRUD_CONFIG_EMPTY_LOCATIONS_WARNING
static val mutable CRUD_CONFIG_EMPTY_LOCATIONS_WARNING: string
static val mutable CRUD_CONFIG_EMPTY_LOCATIONS_WARNING: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_CURSOR_ALREADY_ENUMERATED_ERROR Field

StringConsts CRUD_CURSOR_ALREADY_ENUMERATED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_CURSOR_ALREADY_ENUMERATED_ERROR
public const string CRUD_CURSOR_ALREADY_ENUMERATED_ERROR
Public Const CRUD_CURSOR_ALREADY_ENUMERATED_ERROR As String
Public Const CRUD_CURSOR_ALREADY_ENUMERATED_ERROR As String
public:
literal String^ CRUD_CURSOR_ALREADY_ENUMERATED_ERROR
public:
literal String^ CRUD_CURSOR_ALREADY_ENUMERATED_ERROR
static val mutable CRUD_CURSOR_ALREADY_ENUMERATED_ERROR: string
static val mutable CRUD_CURSOR_ALREADY_ENUMERATED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_FIELD_ATTR_METADATA_PARSE_ERROR Field

StringConsts CRUD_FIELD_ATTR_METADATA_PARSE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_FIELD_ATTR_METADATA_PARSE_ERROR
public const string CRUD_FIELD_ATTR_METADATA_PARSE_ERROR
Public Const CRUD_FIELD_ATTR_METADATA_PARSE_ERROR As String
Public Const CRUD_FIELD_ATTR_METADATA_PARSE_ERROR As String
public:
literal String^ CRUD_FIELD_ATTR_METADATA_PARSE_ERROR
public:
literal String^ CRUD_FIELD_ATTR_METADATA_PARSE_ERROR
static val mutable CRUD_FIELD_ATTR_METADATA_PARSE_ERROR: string
static val mutable CRUD_FIELD_ATTR_METADATA_PARSE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_FIELD_ATTR_PROTOTYPE_CTOR_ERROR Field

StringConsts CRUD_FIELD_ATTR_PROTOTYPE_CTOR_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_FIELD_ATTR_PROTOTYPE_CTOR_ERROR
public const string CRUD_FIELD_ATTR_PROTOTYPE_CTOR_ERROR
Public Const CRUD_FIELD_ATTR_PROTOTYPE_CTOR_ERROR As String
Public Const CRUD_FIELD_ATTR_PROTOTYPE_CTOR_ERROR As String
public:
literal String^ CRUD_FIELD_ATTR_PROTOTYPE_CTOR_ERROR
public:
literal String^ CRUD_FIELD_ATTR_PROTOTYPE_CTOR_ERROR
static val mutable CRUD_FIELD_ATTR_PROTOTYPE_CTOR_ERROR: string
static val mutable CRUD_FIELD_ATTR_PROTOTYPE_CTOR_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_FIELD_NOT_FOUND_ERROR Field

StringConsts CRUD_FIELD_NOT_FOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_FIELD_NOT_FOUND_ERROR
public const string CRUD_FIELD_NOT_FOUND_ERROR
Public Const CRUD_FIELD_NOT_FOUND_ERROR As String
Public Const CRUD_FIELD_NOT_FOUND_ERROR As String
public:
literal String^ CRUD_FIELD_NOT_FOUND_ERROR
public:
literal String^ CRUD_FIELD_NOT_FOUND_ERROR
static val mutable CRUD_FIELD_NOT_FOUND_ERROR: string
static val mutable CRUD_FIELD_NOT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_FIELD_VALUE_EMAIL_ERROR Field

StringConsts CRUD_FIELD_VALUE_EMAIL_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_FIELD_VALUE_EMAIL_ERROR
public const string CRUD_FIELD_VALUE_EMAIL_ERROR
Public Const CRUD_FIELD_VALUE_EMAIL_ERROR As String
Public Const CRUD_FIELD_VALUE_EMAIL_ERROR As String
public:
literal String^ CRUD_FIELD_VALUE_EMAIL_ERROR
public:
literal String^ CRUD_FIELD_VALUE_EMAIL_ERROR
static val mutable CRUD_FIELD_VALUE_EMAIL_ERROR: string
static val mutable CRUD_FIELD_VALUE_EMAIL_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_FIELD_VALUE_GET_ERROR Field

StringConsts CRUD_FIELD_VALUE_GET_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_FIELD_VALUE_GET_ERROR
public const string CRUD_FIELD_VALUE_GET_ERROR
Public Const CRUD_FIELD_VALUE_GET_ERROR As String
Public Const CRUD_FIELD_VALUE_GET_ERROR As String
public:
literal String^ CRUD_FIELD_VALUE_GET_ERROR
public:
literal String^ CRUD_FIELD_VALUE_GET_ERROR
static val mutable CRUD_FIELD_VALUE_GET_ERROR: string
static val mutable CRUD_FIELD_VALUE_GET_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_FIELD_VALUE_IS_NOT_IN_LIST_ERROR Field

StringConsts CRUD_FIELD_VALUE_IS_NOT_IN_LIST_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_FIELD_VALUE_IS_NOT_IN_LIST_ERROR
public const string CRUD_FIELD_VALUE_IS_NOT_IN_LIST_ERROR
Public Const CRUD_FIELD_VALUE_IS_NOT_IN_LIST_ERROR As String
Public Const CRUD_FIELD_VALUE_IS_NOT_IN_LIST_ERROR As String
public:
literal String^ CRUD_FIELD_VALUE_IS_NOT_IN_LIST_ERROR
public:
literal String^ CRUD_FIELD_VALUE_IS_NOT_IN_LIST_ERROR
static val mutable CRUD_FIELD_VALUE_IS_NOT_IN_LIST_ERROR: string
static val mutable CRUD_FIELD_VALUE_IS_NOT_IN_LIST_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_FIELD_VALUE_MAX_BOUND_ERROR Field

StringConsts CRUD_FIELD_VALUE_MAX_BOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_FIELD_VALUE_MAX_BOUND_ERROR
public const string CRUD_FIELD_VALUE_MAX_BOUND_ERROR
Public Const CRUD_FIELD_VALUE_MAX_BOUND_ERROR As String
Public Const CRUD_FIELD_VALUE_MAX_BOUND_ERROR As String
public:
literal String^ CRUD_FIELD_VALUE_MAX_BOUND_ERROR
public:
literal String^ CRUD_FIELD_VALUE_MAX_BOUND_ERROR
static val mutable CRUD_FIELD_VALUE_MAX_BOUND_ERROR: string
static val mutable CRUD_FIELD_VALUE_MAX_BOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_FIELD_VALUE_MAX_LENGTH_ERROR Field

StringConsts CRUD_FIELD_VALUE_MAX_LENGTH_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_FIELD_VALUE_MAX_LENGTH_ERROR
public const string CRUD_FIELD_VALUE_MAX_LENGTH_ERROR
Public Const CRUD_FIELD_VALUE_MAX_LENGTH_ERROR As String
Public Const CRUD_FIELD_VALUE_MAX_LENGTH_ERROR As String
public:
literal String^ CRUD_FIELD_VALUE_MAX_LENGTH_ERROR
public:
literal String^ CRUD_FIELD_VALUE_MAX_LENGTH_ERROR
static val mutable CRUD_FIELD_VALUE_MAX_LENGTH_ERROR: string
static val mutable CRUD_FIELD_VALUE_MAX_LENGTH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_FIELD_VALUE_MIN_BOUND_ERROR Field

StringConsts CRUD_FIELD_VALUE_MIN_BOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_FIELD_VALUE_MIN_BOUND_ERROR
public const string CRUD_FIELD_VALUE_MIN_BOUND_ERROR
Public Const CRUD_FIELD_VALUE_MIN_BOUND_ERROR As String
Public Const CRUD_FIELD_VALUE_MIN_BOUND_ERROR As String
public:
literal String^ CRUD_FIELD_VALUE_MIN_BOUND_ERROR
public:
literal String^ CRUD_FIELD_VALUE_MIN_BOUND_ERROR
static val mutable CRUD_FIELD_VALUE_MIN_BOUND_ERROR: string
static val mutable CRUD_FIELD_VALUE_MIN_BOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_FIELD_VALUE_MIN_LENGTH_ERROR Field

StringConsts CRUD_FIELD_VALUE_MIN_LENGTH_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_FIELD_VALUE_MIN_LENGTH_ERROR
public const string CRUD_FIELD_VALUE_MIN_LENGTH_ERROR
Public Const CRUD_FIELD_VALUE_MIN_LENGTH_ERROR As String
Public Const CRUD_FIELD_VALUE_MIN_LENGTH_ERROR As String
public:
literal String^ CRUD_FIELD_VALUE_MIN_LENGTH_ERROR
public:
literal String^ CRUD_FIELD_VALUE_MIN_LENGTH_ERROR
static val mutable CRUD_FIELD_VALUE_MIN_LENGTH_ERROR: string
static val mutable CRUD_FIELD_VALUE_MIN_LENGTH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_FIELD_VALUE_PHONE_ERROR Field

StringConsts CRUD_FIELD_VALUE_PHONE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_FIELD_VALUE_PHONE_ERROR
public const string CRUD_FIELD_VALUE_PHONE_ERROR
Public Const CRUD_FIELD_VALUE_PHONE_ERROR As String
Public Const CRUD_FIELD_VALUE_PHONE_ERROR As String
public:
literal String^ CRUD_FIELD_VALUE_PHONE_ERROR
public:
literal String^ CRUD_FIELD_VALUE_PHONE_ERROR
static val mutable CRUD_FIELD_VALUE_PHONE_ERROR: string
static val mutable CRUD_FIELD_VALUE_PHONE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_FIELD_VALUE_REGEXP_ERROR Field

StringConsts CRUD_FIELD_VALUE_REGEXP_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_FIELD_VALUE_REGEXP_ERROR
public const string CRUD_FIELD_VALUE_REGEXP_ERROR
Public Const CRUD_FIELD_VALUE_REGEXP_ERROR As String
Public Const CRUD_FIELD_VALUE_REGEXP_ERROR As String
public:
literal String^ CRUD_FIELD_VALUE_REGEXP_ERROR
public:
literal String^ CRUD_FIELD_VALUE_REGEXP_ERROR
static val mutable CRUD_FIELD_VALUE_REGEXP_ERROR: string
static val mutable CRUD_FIELD_VALUE_REGEXP_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_FIELD_VALUE_REQUIRED_ERROR Field

StringConsts CRUD_FIELD_VALUE_REQUIRED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_FIELD_VALUE_REQUIRED_ERROR
public const string CRUD_FIELD_VALUE_REQUIRED_ERROR
Public Const CRUD_FIELD_VALUE_REQUIRED_ERROR As String
Public Const CRUD_FIELD_VALUE_REQUIRED_ERROR As String
public:
literal String^ CRUD_FIELD_VALUE_REQUIRED_ERROR
public:
literal String^ CRUD_FIELD_VALUE_REQUIRED_ERROR
static val mutable CRUD_FIELD_VALUE_REQUIRED_ERROR: string
static val mutable CRUD_FIELD_VALUE_REQUIRED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_FIELD_VALUE_SCREEN_NAME_ERROR Field

StringConsts CRUD_FIELD_VALUE_SCREEN_NAME_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_FIELD_VALUE_SCREEN_NAME_ERROR
public const string CRUD_FIELD_VALUE_SCREEN_NAME_ERROR
Public Const CRUD_FIELD_VALUE_SCREEN_NAME_ERROR As String
Public Const CRUD_FIELD_VALUE_SCREEN_NAME_ERROR As String
public:
literal String^ CRUD_FIELD_VALUE_SCREEN_NAME_ERROR
public:
literal String^ CRUD_FIELD_VALUE_SCREEN_NAME_ERROR
static val mutable CRUD_FIELD_VALUE_SCREEN_NAME_ERROR: string
static val mutable CRUD_FIELD_VALUE_SCREEN_NAME_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_FIELD_VALUE_SET_ERROR Field

StringConsts CRUD_FIELD_VALUE_SET_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_FIELD_VALUE_SET_ERROR
public const string CRUD_FIELD_VALUE_SET_ERROR
Public Const CRUD_FIELD_VALUE_SET_ERROR As String
Public Const CRUD_FIELD_VALUE_SET_ERROR As String
public:
literal String^ CRUD_FIELD_VALUE_SET_ERROR
public:
literal String^ CRUD_FIELD_VALUE_SET_ERROR
static val mutable CRUD_FIELD_VALUE_SET_ERROR: string
static val mutable CRUD_FIELD_VALUE_SET_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_FIELDDEF_ATTR_MISSING_ERROR Field

StringConsts CRUD_FIELDDEF_ATTR_MISSING_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_FIELDDEF_ATTR_MISSING_ERROR
public const string CRUD_FIELDDEF_ATTR_MISSING_ERROR
Public Const CRUD_FIELDDEF_ATTR_MISSING_ERROR As String
Public Const CRUD_FIELDDEF_ATTR_MISSING_ERROR As String
public:
literal String^ CRUD_FIELDDEF_ATTR_MISSING_ERROR
public:
literal String^ CRUD_FIELDDEF_ATTR_MISSING_ERROR
static val mutable CRUD_FIELDDEF_ATTR_MISSING_ERROR: string
static val mutable CRUD_FIELDDEF_ATTR_MISSING_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_FIND_BY_KEY_LENGTH_ERROR Field

StringConsts CRUD_FIND_BY_KEY_LENGTH_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_FIND_BY_KEY_LENGTH_ERROR
public const string CRUD_FIND_BY_KEY_LENGTH_ERROR
Public Const CRUD_FIND_BY_KEY_LENGTH_ERROR As String
Public Const CRUD_FIND_BY_KEY_LENGTH_ERROR As String
public:
literal String^ CRUD_FIND_BY_KEY_LENGTH_ERROR
public:
literal String^ CRUD_FIND_BY_KEY_LENGTH_ERROR
static val mutable CRUD_FIND_BY_KEY_LENGTH_ERROR: string
static val mutable CRUD_FIND_BY_KEY_LENGTH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_GDID_ERA_CONVERSION_ERROR Field

StringConsts CRUD_GDID_ERA_CONVERSION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_GDID_ERA_CONVERSION_ERROR
public const string CRUD_GDID_ERA_CONVERSION_ERROR
Public Const CRUD_GDID_ERA_CONVERSION_ERROR As String
Public Const CRUD_GDID_ERA_CONVERSION_ERROR As String
public:
literal String^ CRUD_GDID_ERA_CONVERSION_ERROR
public:
literal String^ CRUD_GDID_ERA_CONVERSION_ERROR
static val mutable CRUD_GDID_ERA_CONVERSION_ERROR: string
static val mutable CRUD_GDID_ERA_CONVERSION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_OPERATION_CALL_CONTEXT_SCOPE_MISMATCH_ERROR Field

StringConsts CRUD_OPERATION_CALL_CONTEXT_SCOPE_MISMATCH_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_OPERATION_CALL_CONTEXT_SCOPE_MISMATCH_ERROR
public const string CRUD_OPERATION_CALL_CONTEXT_SCOPE_MISMATCH_ERROR
Public Const CRUD_OPERATION_CALL_CONTEXT_SCOPE_MISMATCH_ERROR As String
Public Const CRUD_OPERATION_CALL_CONTEXT_SCOPE_MISMATCH_ERROR As String
public:
literal String^ CRUD_OPERATION_CALL_CONTEXT_SCOPE_MISMATCH_ERROR
public:
literal String^ CRUD_OPERATION_CALL_CONTEXT_SCOPE_MISMATCH_ERROR
static val mutable CRUD_OPERATION_CALL_CONTEXT_SCOPE_MISMATCH_ERROR: string
static val mutable CRUD_OPERATION_CALL_CONTEXT_SCOPE_MISMATCH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_OPERATION_NOT_SUPPORTED_ERROR Field

StringConsts CRUD_OPERATION_NOT_SUPPORTED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_OPERATION_NOT_SUPPORTED_ERROR
public const string CRUD_OPERATION_NOT_SUPPORTED_ERROR
Public Const CRUD_OPERATION_NOT_SUPPORTED_ERROR As String
Public Const CRUD_OPERATION_NOT_SUPPORTED_ERROR As String
public:
literal String^ CRUD_OPERATION_NOT_SUPPORTED_ERROR
public:
literal String^ CRUD_OPERATION_NOT_SUPPORTED_ERROR
static val mutable CRUD_OPERATION_NOT_SUPPORTED_ERROR: string
static val mutable CRUD_OPERATION_NOT_SUPPORTED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_QUERY_RESOLUTION_ERROR Field

StringConsts CRUD_QUERY_RESOLUTION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_QUERY_RESOLUTION_ERROR
public const string CRUD_QUERY_RESOLUTION_ERROR
Public Const CRUD_QUERY_RESOLUTION_ERROR As String
Public Const CRUD_QUERY_RESOLUTION_ERROR As String
public:
literal String^ CRUD_QUERY_RESOLUTION_ERROR
public:
literal String^ CRUD_QUERY_RESOLUTION_ERROR
static val mutable CRUD_QUERY_RESOLUTION_ERROR: string
static val mutable CRUD_QUERY_RESOLUTION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_QUERY_RESOLUTION_NO_HANDLER_ERROR Field

StringConsts CRUD_QUERY_RESOLUTION_NO_HANDLER_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_QUERY_RESOLUTION_NO_HANDLER_ERROR
public const string CRUD_QUERY_RESOLUTION_NO_HANDLER_ERROR
Public Const CRUD_QUERY_RESOLUTION_NO_HANDLER_ERROR As String
Public Const CRUD_QUERY_RESOLUTION_NO_HANDLER_ERROR As String
public:
literal String^ CRUD_QUERY_RESOLUTION_NO_HANDLER_ERROR
public:
literal String^ CRUD_QUERY_RESOLUTION_NO_HANDLER_ERROR
static val mutable CRUD_QUERY_RESOLUTION_NO_HANDLER_ERROR: string
static val mutable CRUD_QUERY_RESOLUTION_NO_HANDLER_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_QUERY_RESOLVER_ALREADY_STARTED_ERROR Field

StringConsts CRUD_QUERY_RESOLVER_ALREADY_STARTED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_QUERY_RESOLVER_ALREADY_STARTED_ERROR
public const string CRUD_QUERY_RESOLVER_ALREADY_STARTED_ERROR
Public Const CRUD_QUERY_RESOLVER_ALREADY_STARTED_ERROR As String
Public Const CRUD_QUERY_RESOLVER_ALREADY_STARTED_ERROR As String
public:
literal String^ CRUD_QUERY_RESOLVER_ALREADY_STARTED_ERROR
public:
literal String^ CRUD_QUERY_RESOLVER_ALREADY_STARTED_ERROR
static val mutable CRUD_QUERY_RESOLVER_ALREADY_STARTED_ERROR: string
static val mutable CRUD_QUERY_RESOLVER_ALREADY_STARTED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_QUERY_SOURCE_PRAGMA_ERROR Field

StringConsts CRUD_QUERY_SOURCE_PRAGMA_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_QUERY_SOURCE_PRAGMA_ERROR
public const string CRUD_QUERY_SOURCE_PRAGMA_ERROR
Public Const CRUD_QUERY_SOURCE_PRAGMA_ERROR As String
Public Const CRUD_QUERY_SOURCE_PRAGMA_ERROR As String
public:
literal String^ CRUD_QUERY_SOURCE_PRAGMA_ERROR
public:
literal String^ CRUD_QUERY_SOURCE_PRAGMA_ERROR
static val mutable CRUD_QUERY_SOURCE_PRAGMA_ERROR: string
static val mutable CRUD_QUERY_SOURCE_PRAGMA_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_QUERY_SOURCE_PRAGMA_LINE_ERROR Field

StringConsts CRUD_QUERY_SOURCE_PRAGMA_LINE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_QUERY_SOURCE_PRAGMA_LINE_ERROR
public const string CRUD_QUERY_SOURCE_PRAGMA_LINE_ERROR
Public Const CRUD_QUERY_SOURCE_PRAGMA_LINE_ERROR As String
Public Const CRUD_QUERY_SOURCE_PRAGMA_LINE_ERROR As String
public:
literal String^ CRUD_QUERY_SOURCE_PRAGMA_LINE_ERROR
public:
literal String^ CRUD_QUERY_SOURCE_PRAGMA_LINE_ERROR
static val mutable CRUD_QUERY_SOURCE_PRAGMA_LINE_ERROR: string
static val mutable CRUD_QUERY_SOURCE_PRAGMA_LINE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_ROWSET_OPERATION_ROW_IS_NULL_OR_SCHEMA_MISMATCH_ERROR Field

StringConsts CRUD_ROWSET_OPERATION_ROW_IS_NULL_OR_SCHEMA_MISMATCH_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_ROWSET_OPERATION_ROW_IS_NULL_OR_SCHEMA_MISMATCH_ERROR
public const string CRUD_ROWSET_OPERATION_ROW_IS_NULL_OR_SCHEMA_MISMATCH_ERROR
Public Const CRUD_ROWSET_OPERATION_ROW_IS_NULL_OR_SCHEMA_MISMATCH_ERROR As String
Public Const CRUD_ROWSET_OPERATION_ROW_IS_NULL_OR_SCHEMA_MISMATCH_ERROR As String
public:
literal String^ CRUD_ROWSET_OPERATION_ROW_IS_NULL_OR_SCHEMA_MISMATCH_ERROR
public:
literal String^ CRUD_ROWSET_OPERATION_ROW_IS_NULL_OR_SCHEMA_MISMATCH_ERROR
static val mutable CRUD_ROWSET_OPERATION_ROW_IS_NULL_OR_SCHEMA_MISMATCH_ERROR: string
static val mutable CRUD_ROWSET_OPERATION_ROW_IS_NULL_OR_SCHEMA_MISMATCH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_TRANSACTION_IS_NOT_OPEN_ERROR Field

StringConsts CRUD_TRANSACTION_IS_NOT_OPEN_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_TRANSACTION_IS_NOT_OPEN_ERROR
public const string CRUD_TRANSACTION_IS_NOT_OPEN_ERROR
Public Const CRUD_TRANSACTION_IS_NOT_OPEN_ERROR As String
Public Const CRUD_TRANSACTION_IS_NOT_OPEN_ERROR As String
public:
literal String^ CRUD_TRANSACTION_IS_NOT_OPEN_ERROR
public:
literal String^ CRUD_TRANSACTION_IS_NOT_OPEN_ERROR
static val mutable CRUD_TRANSACTION_IS_NOT_OPEN_ERROR: string
static val mutable CRUD_TRANSACTION_IS_NOT_OPEN_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_TYPE_IS_NOT_DERIVED_FROM_ROW_ERROR Field

StringConsts CRUD_TYPE_IS_NOT_DERIVED_FROM_ROW_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_TYPE_IS_NOT_DERIVED_FROM_ROW_ERROR
public const string CRUD_TYPE_IS_NOT_DERIVED_FROM_ROW_ERROR
Public Const CRUD_TYPE_IS_NOT_DERIVED_FROM_ROW_ERROR As String
Public Const CRUD_TYPE_IS_NOT_DERIVED_FROM_ROW_ERROR As String
public:
literal String^ CRUD_TYPE_IS_NOT_DERIVED_FROM_ROW_ERROR
public:
literal String^ CRUD_TYPE_IS_NOT_DERIVED_FROM_ROW_ERROR
static val mutable CRUD_TYPE_IS_NOT_DERIVED_FROM_ROW_ERROR: string
static val mutable CRUD_TYPE_IS_NOT_DERIVED_FROM_ROW_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_TYPE_IS_NOT_DERIVED_FROM_TYPED_ROW_ERROR Field

StringConsts CRUD_TYPE_IS_NOT_DERIVED_FROM_TYPED_ROW_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_TYPE_IS_NOT_DERIVED_FROM_TYPED_ROW_ERROR
public const string CRUD_TYPE_IS_NOT_DERIVED_FROM_TYPED_ROW_ERROR
Public Const CRUD_TYPE_IS_NOT_DERIVED_FROM_TYPED_ROW_ERROR As String
Public Const CRUD_TYPE_IS_NOT_DERIVED_FROM_TYPED_ROW_ERROR As String
public:
literal String^ CRUD_TYPE_IS_NOT_DERIVED_FROM_TYPED_ROW_ERROR
public:
literal String^ CRUD_TYPE_IS_NOT_DERIVED_FROM_TYPED_ROW_ERROR
static val mutable CRUD_TYPE_IS_NOT_DERIVED_FROM_TYPED_ROW_ERROR: string
static val mutable CRUD_TYPE_IS_NOT_DERIVED_FROM_TYPED_ROW_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_TYPED_ROW_CLONED_FIELD_NOTEXISTS_ERROR Field

StringConsts CRUD_TYPED_ROW_CLONED_FIELD_NOTEXISTS_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_TYPED_ROW_CLONED_FIELD_NOTEXISTS_ERROR
public const string CRUD_TYPED_ROW_CLONED_FIELD_NOTEXISTS_ERROR
Public Const CRUD_TYPED_ROW_CLONED_FIELD_NOTEXISTS_ERROR As String
Public Const CRUD_TYPED_ROW_CLONED_FIELD_NOTEXISTS_ERROR As String
public:
literal String^ CRUD_TYPED_ROW_CLONED_FIELD_NOTEXISTS_ERROR
public:
literal String^ CRUD_TYPED_ROW_CLONED_FIELD_NOTEXISTS_ERROR
static val mutable CRUD_TYPED_ROW_CLONED_FIELD_NOTEXISTS_ERROR: string
static val mutable CRUD_TYPED_ROW_CLONED_FIELD_NOTEXISTS_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_TYPED_ROW_RECURSIVE_FIELD_DEFINITION_ERROR Field

StringConsts CRUD_TYPED_ROW_RECURSIVE_FIELD_DEFINITION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_TYPED_ROW_RECURSIVE_FIELD_DEFINITION_ERROR
public const string CRUD_TYPED_ROW_RECURSIVE_FIELD_DEFINITION_ERROR
Public Const CRUD_TYPED_ROW_RECURSIVE_FIELD_DEFINITION_ERROR As String
Public Const CRUD_TYPED_ROW_RECURSIVE_FIELD_DEFINITION_ERROR As String
public:
literal String^ CRUD_TYPED_ROW_RECURSIVE_FIELD_DEFINITION_ERROR
public:
literal String^ CRUD_TYPED_ROW_RECURSIVE_FIELD_DEFINITION_ERROR
static val mutable CRUD_TYPED_ROW_RECURSIVE_FIELD_DEFINITION_ERROR: string
static val mutable CRUD_TYPED_ROW_RECURSIVE_FIELD_DEFINITION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.CRUD_TYPED_ROW_SINGLE_CLONED_FIELD_ERROR Field

StringConsts CRUD_TYPED_ROW_SINGLE_CLONED_FIELD_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_TYPED_ROW_SINGLE_CLONED_FIELD_ERROR
public const string CRUD_TYPED_ROW_SINGLE_CLONED_FIELD_ERROR
Public Const CRUD_TYPED_ROW_SINGLE_CLONED_FIELD_ERROR As String
Public Const CRUD_TYPED_ROW_SINGLE_CLONED_FIELD_ERROR As String
public:
literal String^ CRUD_TYPED_ROW_SINGLE_CLONED_FIELD_ERROR
public:
literal String^ CRUD_TYPED_ROW_SINGLE_CLONED_FIELD_ERROR
static val mutable CRUD_TYPED_ROW_SINGLE_CLONED_FIELD_ERROR: string
static val mutable CRUD_TYPED_ROW_SINGLE_CLONED_FIELD_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.DECIMAL_OUT_OF_RANGE_ERROR Field

StringConsts DECIMAL_OUT_OF_RANGE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DECIMAL_OUT_OF_RANGE_ERROR
public const string DECIMAL_OUT_OF_RANGE_ERROR
Public Const DECIMAL_OUT_OF_RANGE_ERROR As String
Public Const DECIMAL_OUT_OF_RANGE_ERROR As String
public:
literal String^ DECIMAL_OUT_OF_RANGE_ERROR
public:
literal String^ DECIMAL_OUT_OF_RANGE_ERROR
static val mutable DECIMAL_OUT_OF_RANGE_ERROR: string
static val mutable DECIMAL_OUT_OF_RANGE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.DELETE_MODIFY_ERROR Field

StringConsts DELETE_MODIFY_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DELETE_MODIFY_ERROR
public const string DELETE_MODIFY_ERROR
Public Const DELETE_MODIFY_ERROR As String
Public Const DELETE_MODIFY_ERROR As String
public:
literal String^ DELETE_MODIFY_ERROR
public:
literal String^ DELETE_MODIFY_ERROR
static val mutable DELETE_MODIFY_ERROR: string
static val mutable DELETE_MODIFY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.DISTRIBUTED_DATA_GDID_CTOR_ERROR Field

StringConsts DISTRIBUTED_DATA_GDID_CTOR_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DISTRIBUTED_DATA_GDID_CTOR_ERROR
public const string DISTRIBUTED_DATA_GDID_CTOR_ERROR
Public Const DISTRIBUTED_DATA_GDID_CTOR_ERROR As String
Public Const DISTRIBUTED_DATA_GDID_CTOR_ERROR As String
public:
literal String^ DISTRIBUTED_DATA_GDID_CTOR_ERROR
public:
literal String^ DISTRIBUTED_DATA_GDID_CTOR_ERROR
static val mutable DISTRIBUTED_DATA_GDID_CTOR_ERROR: string
static val mutable DISTRIBUTED_DATA_GDID_CTOR_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.DISTRIBUTED_DATA_GDID_PARSE_ERROR Field

StringConsts DISTRIBUTED_DATA_GDID_PARSE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DISTRIBUTED_DATA_GDID_PARSE_ERROR
public const string DISTRIBUTED_DATA_GDID_PARSE_ERROR
Public Const DISTRIBUTED_DATA_GDID_PARSE_ERROR As String
Public Const DISTRIBUTED_DATA_GDID_PARSE_ERROR As String
public:
literal String^ DISTRIBUTED_DATA_GDID_PARSE_ERROR
public:
literal String^ DISTRIBUTED_DATA_GDID_PARSE_ERROR
static val mutable DISTRIBUTED_DATA_GDID_PARSE_ERROR: string
static val mutable DISTRIBUTED_DATA_GDID_PARSE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.DISTRIBUTED_DATA_PARCEL_INVALID_OPERATION_ERROR Field

StringConsts DISTRIBUTED_DATA_PARCEL_INVALID_OPERATION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DISTRIBUTED_DATA_PARCEL_INVALID_OPERATION_ERROR
public const string DISTRIBUTED_DATA_PARCEL_INVALID_OPERATION_ERROR
Public Const DISTRIBUTED_DATA_PARCEL_INVALID_OPERATION_ERROR As String
Public Const DISTRIBUTED_DATA_PARCEL_INVALID_OPERATION_ERROR As String
public:
literal String^ DISTRIBUTED_DATA_PARCEL_INVALID_OPERATION_ERROR
public:
literal String^ DISTRIBUTED_DATA_PARCEL_INVALID_OPERATION_ERROR
static val mutable DISTRIBUTED_DATA_PARCEL_INVALID_OPERATION_ERROR: string
static val mutable DISTRIBUTED_DATA_PARCEL_INVALID_OPERATION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.DISTRIBUTED_DATA_PARCEL_MERGE_NOT_IMPLEMENTED_ERROR Field

StringConsts DISTRIBUTED_DATA_PARCEL_MERGE_NOT_IMPLEMENTED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DISTRIBUTED_DATA_PARCEL_MERGE_NOT_IMPLEMENTED_ERROR
public const string DISTRIBUTED_DATA_PARCEL_MERGE_NOT_IMPLEMENTED_ERROR
Public Const DISTRIBUTED_DATA_PARCEL_MERGE_NOT_IMPLEMENTED_ERROR As String
Public Const DISTRIBUTED_DATA_PARCEL_MERGE_NOT_IMPLEMENTED_ERROR As String
public:
literal String^ DISTRIBUTED_DATA_PARCEL_MERGE_NOT_IMPLEMENTED_ERROR
public:
literal String^ DISTRIBUTED_DATA_PARCEL_MERGE_NOT_IMPLEMENTED_ERROR
static val mutable DISTRIBUTED_DATA_PARCEL_MERGE_NOT_IMPLEMENTED_ERROR: string
static val mutable DISTRIBUTED_DATA_PARCEL_MERGE_NOT_IMPLEMENTED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.DISTRIBUTED_DATA_PARCEL_MISSING_ATTRIBUTE_ERROR Field

StringConsts DISTRIBUTED_DATA_PARCEL_MISSING_ATTRIBUTE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DISTRIBUTED_DATA_PARCEL_MISSING_ATTRIBUTE_ERROR
public const string DISTRIBUTED_DATA_PARCEL_MISSING_ATTRIBUTE_ERROR
Public Const DISTRIBUTED_DATA_PARCEL_MISSING_ATTRIBUTE_ERROR As String
Public Const DISTRIBUTED_DATA_PARCEL_MISSING_ATTRIBUTE_ERROR As String
public:
literal String^ DISTRIBUTED_DATA_PARCEL_MISSING_ATTRIBUTE_ERROR
public:
literal String^ DISTRIBUTED_DATA_PARCEL_MISSING_ATTRIBUTE_ERROR
static val mutable DISTRIBUTED_DATA_PARCEL_MISSING_ATTRIBUTE_ERROR: string
static val mutable DISTRIBUTED_DATA_PARCEL_MISSING_ATTRIBUTE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.DISTRIBUTED_DATA_PARCEL_SEAL_VALIDATION_ERROR Field

StringConsts DISTRIBUTED_DATA_PARCEL_SEAL_VALIDATION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DISTRIBUTED_DATA_PARCEL_SEAL_VALIDATION_ERROR
public const string DISTRIBUTED_DATA_PARCEL_SEAL_VALIDATION_ERROR
Public Const DISTRIBUTED_DATA_PARCEL_SEAL_VALIDATION_ERROR As String
Public Const DISTRIBUTED_DATA_PARCEL_SEAL_VALIDATION_ERROR As String
public:
literal String^ DISTRIBUTED_DATA_PARCEL_SEAL_VALIDATION_ERROR
public:
literal String^ DISTRIBUTED_DATA_PARCEL_SEAL_VALIDATION_ERROR
static val mutable DISTRIBUTED_DATA_PARCEL_SEAL_VALIDATION_ERROR: string
static val mutable DISTRIBUTED_DATA_PARCEL_SEAL_VALIDATION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.DISTRIBUTED_DATA_PARCEL_UNWRAP_DESER_ERROR Field

StringConsts DISTRIBUTED_DATA_PARCEL_UNWRAP_DESER_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DISTRIBUTED_DATA_PARCEL_UNWRAP_DESER_ERROR
public const string DISTRIBUTED_DATA_PARCEL_UNWRAP_DESER_ERROR
Public Const DISTRIBUTED_DATA_PARCEL_UNWRAP_DESER_ERROR As String
Public Const DISTRIBUTED_DATA_PARCEL_UNWRAP_DESER_ERROR As String
public:
literal String^ DISTRIBUTED_DATA_PARCEL_UNWRAP_DESER_ERROR
public:
literal String^ DISTRIBUTED_DATA_PARCEL_UNWRAP_DESER_ERROR
static val mutable DISTRIBUTED_DATA_PARCEL_UNWRAP_DESER_ERROR: string
static val mutable DISTRIBUTED_DATA_PARCEL_UNWRAP_DESER_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.DISTRIBUTED_DATA_PARCEL_UNWRAP_FORMAT_ERROR Field

StringConsts DISTRIBUTED_DATA_PARCEL_UNWRAP_FORMAT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DISTRIBUTED_DATA_PARCEL_UNWRAP_FORMAT_ERROR
public const string DISTRIBUTED_DATA_PARCEL_UNWRAP_FORMAT_ERROR
Public Const DISTRIBUTED_DATA_PARCEL_UNWRAP_FORMAT_ERROR As String
Public Const DISTRIBUTED_DATA_PARCEL_UNWRAP_FORMAT_ERROR As String
public:
literal String^ DISTRIBUTED_DATA_PARCEL_UNWRAP_FORMAT_ERROR
public:
literal String^ DISTRIBUTED_DATA_PARCEL_UNWRAP_FORMAT_ERROR
static val mutable DISTRIBUTED_DATA_PARCEL_UNWRAP_FORMAT_ERROR: string
static val mutable DISTRIBUTED_DATA_PARCEL_UNWRAP_FORMAT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.DUPLICATE_FIELD_NAME_ERROR Field

StringConsts DUPLICATE_FIELD_NAME_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DUPLICATE_FIELD_NAME_ERROR
public const string DUPLICATE_FIELD_NAME_ERROR
Public Const DUPLICATE_FIELD_NAME_ERROR As String
Public Const DUPLICATE_FIELD_NAME_ERROR As String
public:
literal String^ DUPLICATE_FIELD_NAME_ERROR
public:
literal String^ DUPLICATE_FIELD_NAME_ERROR
static val mutable DUPLICATE_FIELD_NAME_ERROR: string
static val mutable DUPLICATE_FIELD_NAME_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ELINK_CHAR_COMBINATION_ERROR Field

StringConsts ELINK_CHAR_COMBINATION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ELINK_CHAR_COMBINATION_ERROR
public const string ELINK_CHAR_COMBINATION_ERROR
Public Const ELINK_CHAR_COMBINATION_ERROR As String
Public Const ELINK_CHAR_COMBINATION_ERROR As String
public:
literal String^ ELINK_CHAR_COMBINATION_ERROR
public:
literal String^ ELINK_CHAR_COMBINATION_ERROR
static val mutable ELINK_CHAR_COMBINATION_ERROR: string
static val mutable ELINK_CHAR_COMBINATION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ELINK_CHAR_LENGTH_ERROR Field

StringConsts ELINK_CHAR_LENGTH_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ELINK_CHAR_LENGTH_ERROR
public const string ELINK_CHAR_LENGTH_ERROR
Public Const ELINK_CHAR_LENGTH_ERROR As String
Public Const ELINK_CHAR_LENGTH_ERROR As String
public:
literal String^ ELINK_CHAR_LENGTH_ERROR
public:
literal String^ ELINK_CHAR_LENGTH_ERROR
static val mutable ELINK_CHAR_LENGTH_ERROR: string
static val mutable ELINK_CHAR_LENGTH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ELINK_CHAR_LENGTH_LIMIT_ERROR Field

StringConsts ELINK_CHAR_LENGTH_LIMIT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ELINK_CHAR_LENGTH_LIMIT_ERROR
public const string ELINK_CHAR_LENGTH_LIMIT_ERROR
Public Const ELINK_CHAR_LENGTH_LIMIT_ERROR As String
Public Const ELINK_CHAR_LENGTH_LIMIT_ERROR As String
public:
literal String^ ELINK_CHAR_LENGTH_LIMIT_ERROR
public:
literal String^ ELINK_CHAR_LENGTH_LIMIT_ERROR
static val mutable ELINK_CHAR_LENGTH_LIMIT_ERROR: string
static val mutable ELINK_CHAR_LENGTH_LIMIT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ELINK_CSUM_MISMATCH_ERROR Field

StringConsts ELINK_CSUM_MISMATCH_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ELINK_CSUM_MISMATCH_ERROR
public const string ELINK_CSUM_MISMATCH_ERROR
Public Const ELINK_CSUM_MISMATCH_ERROR As String
Public Const ELINK_CSUM_MISMATCH_ERROR As String
public:
literal String^ ELINK_CSUM_MISMATCH_ERROR
public:
literal String^ ELINK_CSUM_MISMATCH_ERROR
static val mutable ELINK_CSUM_MISMATCH_ERROR: string
static val mutable ELINK_CSUM_MISMATCH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ELINK_SEGMENT_LENGTH_ERROR Field

StringConsts ELINK_SEGMENT_LENGTH_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ELINK_SEGMENT_LENGTH_ERROR
public const string ELINK_SEGMENT_LENGTH_ERROR
Public Const ELINK_SEGMENT_LENGTH_ERROR As String
Public Const ELINK_SEGMENT_LENGTH_ERROR As String
public:
literal String^ ELINK_SEGMENT_LENGTH_ERROR
public:
literal String^ ELINK_SEGMENT_LENGTH_ERROR
static val mutable ELINK_SEGMENT_LENGTH_ERROR: string
static val mutable ELINK_SEGMENT_LENGTH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ENABLE_BINDINGS_ERROR Field

StringConsts ENABLE_BINDINGS_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ENABLE_BINDINGS_ERROR
public const string ENABLE_BINDINGS_ERROR
Public Const ENABLE_BINDINGS_ERROR As String
Public Const ENABLE_BINDINGS_ERROR As String
public:
literal String^ ENABLE_BINDINGS_ERROR
public:
literal String^ ENABLE_BINDINGS_ERROR
static val mutable ENABLE_BINDINGS_ERROR: string
static val mutable ENABLE_BINDINGS_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_ATOM_SIZE_TOO_LONG_ERROR Field

StringConsts ERL_ATOM_SIZE_TOO_LONG_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_ATOM_SIZE_TOO_LONG_ERROR
public const string ERL_ATOM_SIZE_TOO_LONG_ERROR
Public Const ERL_ATOM_SIZE_TOO_LONG_ERROR As String
Public Const ERL_ATOM_SIZE_TOO_LONG_ERROR As String
public:
literal String^ ERL_ATOM_SIZE_TOO_LONG_ERROR
public:
literal String^ ERL_ATOM_SIZE_TOO_LONG_ERROR
static val mutable ERL_ATOM_SIZE_TOO_LONG_ERROR: string
static val mutable ERL_ATOM_SIZE_TOO_LONG_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_ATOM_TABLE_IS_FULL_ERROR Field

StringConsts ERL_ATOM_TABLE_IS_FULL_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_ATOM_TABLE_IS_FULL_ERROR
public const string ERL_ATOM_TABLE_IS_FULL_ERROR
Public Const ERL_ATOM_TABLE_IS_FULL_ERROR As String
Public Const ERL_ATOM_TABLE_IS_FULL_ERROR As String
public:
literal String^ ERL_ATOM_TABLE_IS_FULL_ERROR
public:
literal String^ ERL_ATOM_TABLE_IS_FULL_ERROR
static val mutable ERL_ATOM_TABLE_IS_FULL_ERROR: string
static val mutable ERL_ATOM_TABLE_IS_FULL_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_BIG_INTEGER_OVERFLOW_ERROR Field

StringConsts ERL_BIG_INTEGER_OVERFLOW_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_BIG_INTEGER_OVERFLOW_ERROR
public const string ERL_BIG_INTEGER_OVERFLOW_ERROR
Public Const ERL_BIG_INTEGER_OVERFLOW_ERROR As String
Public Const ERL_BIG_INTEGER_OVERFLOW_ERROR As String
public:
literal String^ ERL_BIG_INTEGER_OVERFLOW_ERROR
public:
literal String^ ERL_BIG_INTEGER_OVERFLOW_ERROR
static val mutable ERL_BIG_INTEGER_OVERFLOW_ERROR: string
static val mutable ERL_BIG_INTEGER_OVERFLOW_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CANNOT_CLONE_INSTANCE_ERROR Field

StringConsts ERL_CANNOT_CLONE_INSTANCE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CANNOT_CLONE_INSTANCE_ERROR
public const string ERL_CANNOT_CLONE_INSTANCE_ERROR
Public Const ERL_CANNOT_CLONE_INSTANCE_ERROR As String
Public Const ERL_CANNOT_CLONE_INSTANCE_ERROR As String
public:
literal String^ ERL_CANNOT_CLONE_INSTANCE_ERROR
public:
literal String^ ERL_CANNOT_CLONE_INSTANCE_ERROR
static val mutable ERL_CANNOT_CLONE_INSTANCE_ERROR: string
static val mutable ERL_CANNOT_CLONE_INSTANCE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CANNOT_CONVERT_TYPES_CYCLE_ERROR Field

StringConsts ERL_CANNOT_CONVERT_TYPES_CYCLE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CANNOT_CONVERT_TYPES_CYCLE_ERROR
public const string ERL_CANNOT_CONVERT_TYPES_CYCLE_ERROR
Public Const ERL_CANNOT_CONVERT_TYPES_CYCLE_ERROR As String
Public Const ERL_CANNOT_CONVERT_TYPES_CYCLE_ERROR As String
public:
literal String^ ERL_CANNOT_CONVERT_TYPES_CYCLE_ERROR
public:
literal String^ ERL_CANNOT_CONVERT_TYPES_CYCLE_ERROR
static val mutable ERL_CANNOT_CONVERT_TYPES_CYCLE_ERROR: string
static val mutable ERL_CANNOT_CONVERT_TYPES_CYCLE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CANNOT_CONVERT_TYPES_ERROR Field

StringConsts ERL_CANNOT_CONVERT_TYPES_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CANNOT_CONVERT_TYPES_ERROR
public const string ERL_CANNOT_CONVERT_TYPES_ERROR
Public Const ERL_CANNOT_CONVERT_TYPES_ERROR As String
Public Const ERL_CANNOT_CONVERT_TYPES_ERROR As String
public:
literal String^ ERL_CANNOT_CONVERT_TYPES_ERROR
public:
literal String^ ERL_CANNOT_CONVERT_TYPES_ERROR
static val mutable ERL_CANNOT_CONVERT_TYPES_ERROR: string
static val mutable ERL_CANNOT_CONVERT_TYPES_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CANNOT_READ_FROM_STREAM_ERROR Field

StringConsts ERL_CANNOT_READ_FROM_STREAM_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CANNOT_READ_FROM_STREAM_ERROR
public const string ERL_CANNOT_READ_FROM_STREAM_ERROR
Public Const ERL_CANNOT_READ_FROM_STREAM_ERROR As String
Public Const ERL_CANNOT_READ_FROM_STREAM_ERROR As String
public:
literal String^ ERL_CANNOT_READ_FROM_STREAM_ERROR
public:
literal String^ ERL_CANNOT_READ_FROM_STREAM_ERROR
static val mutable ERL_CANNOT_READ_FROM_STREAM_ERROR: string
static val mutable ERL_CANNOT_READ_FROM_STREAM_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CONFIG_SINGLE_NODE_ERROR Field

StringConsts ERL_CONFIG_SINGLE_NODE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONFIG_SINGLE_NODE_ERROR
public const string ERL_CONFIG_SINGLE_NODE_ERROR
Public Const ERL_CONFIG_SINGLE_NODE_ERROR As String
Public Const ERL_CONFIG_SINGLE_NODE_ERROR As String
public:
literal String^ ERL_CONFIG_SINGLE_NODE_ERROR
public:
literal String^ ERL_CONFIG_SINGLE_NODE_ERROR
static val mutable ERL_CONFIG_SINGLE_NODE_ERROR: string
static val mutable ERL_CONFIG_SINGLE_NODE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CONN_ACCEPT_ERROR Field

StringConsts ERL_CONN_ACCEPT_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_ACCEPT_ERROR
public const string ERL_CONN_ACCEPT_ERROR
Public Const ERL_CONN_ACCEPT_ERROR As String
Public Const ERL_CONN_ACCEPT_ERROR As String
public:
literal String^ ERL_CONN_ACCEPT_ERROR
public:
literal String^ ERL_CONN_ACCEPT_ERROR
static val mutable ERL_CONN_ACCEPT_ERROR: string
static val mutable ERL_CONN_ACCEPT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CONN_ACCEPT_FROM Field

StringConsts ERL_CONN_ACCEPT_FROM Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_ACCEPT_FROM
public const string ERL_CONN_ACCEPT_FROM
Public Const ERL_CONN_ACCEPT_FROM As String
Public Const ERL_CONN_ACCEPT_FROM As String
public:
literal String^ ERL_CONN_ACCEPT_FROM
public:
literal String^ ERL_CONN_ACCEPT_FROM
static val mutable ERL_CONN_ACCEPT_FROM: string
static val mutable ERL_CONN_ACCEPT_FROM: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CONN_ALREADY_CONNECTED_ERROR Field

StringConsts ERL_CONN_ALREADY_CONNECTED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_ALREADY_CONNECTED_ERROR
public const string ERL_CONN_ALREADY_CONNECTED_ERROR
Public Const ERL_CONN_ALREADY_CONNECTED_ERROR As String
Public Const ERL_CONN_ALREADY_CONNECTED_ERROR As String
public:
literal String^ ERL_CONN_ALREADY_CONNECTED_ERROR
public:
literal String^ ERL_CONN_ALREADY_CONNECTED_ERROR
static val mutable ERL_CONN_ALREADY_CONNECTED_ERROR: string
static val mutable ERL_CONN_ALREADY_CONNECTED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CONN_CANT_CONNECT_TO_HOST_ERROR Field

StringConsts ERL_CONN_CANT_CONNECT_TO_HOST_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_CANT_CONNECT_TO_HOST_ERROR
public const string ERL_CONN_CANT_CONNECT_TO_HOST_ERROR
Public Const ERL_CONN_CANT_CONNECT_TO_HOST_ERROR As String
Public Const ERL_CONN_CANT_CONNECT_TO_HOST_ERROR As String
public:
literal String^ ERL_CONN_CANT_CONNECT_TO_HOST_ERROR
public:
literal String^ ERL_CONN_CANT_CONNECT_TO_HOST_ERROR
static val mutable ERL_CONN_CANT_CONNECT_TO_HOST_ERROR: string
static val mutable ERL_CONN_CANT_CONNECT_TO_HOST_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CONN_CANT_CONNECT_TO_NODE_ERROR Field

StringConsts ERL_CONN_CANT_CONNECT_TO_NODE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_CANT_CONNECT_TO_NODE_ERROR
public const string ERL_CONN_CANT_CONNECT_TO_NODE_ERROR
Public Const ERL_CONN_CANT_CONNECT_TO_NODE_ERROR As String
Public Const ERL_CONN_CANT_CONNECT_TO_NODE_ERROR As String
public:
literal String^ ERL_CONN_CANT_CONNECT_TO_NODE_ERROR
public:
literal String^ ERL_CONN_CANT_CONNECT_TO_NODE_ERROR
static val mutable ERL_CONN_CANT_CONNECT_TO_NODE_ERROR: string
static val mutable ERL_CONN_CANT_CONNECT_TO_NODE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CONN_CANT_RPC_TO_LOCAL_NODE_ERROR Field

StringConsts ERL_CONN_CANT_RPC_TO_LOCAL_NODE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_CANT_RPC_TO_LOCAL_NODE_ERROR
public const string ERL_CONN_CANT_RPC_TO_LOCAL_NODE_ERROR
Public Const ERL_CONN_CANT_RPC_TO_LOCAL_NODE_ERROR As String
Public Const ERL_CONN_CANT_RPC_TO_LOCAL_NODE_ERROR As String
public:
literal String^ ERL_CONN_CANT_RPC_TO_LOCAL_NODE_ERROR
public:
literal String^ ERL_CONN_CANT_RPC_TO_LOCAL_NODE_ERROR
static val mutable ERL_CONN_CANT_RPC_TO_LOCAL_NODE_ERROR: string
static val mutable ERL_CONN_CANT_RPC_TO_LOCAL_NODE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CONN_EOF_AFTER_N_BYTES_ERROR Field

StringConsts ERL_CONN_EOF_AFTER_N_BYTES_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_EOF_AFTER_N_BYTES_ERROR
public const string ERL_CONN_EOF_AFTER_N_BYTES_ERROR
Public Const ERL_CONN_EOF_AFTER_N_BYTES_ERROR As String
Public Const ERL_CONN_EOF_AFTER_N_BYTES_ERROR As String
public:
literal String^ ERL_CONN_EOF_AFTER_N_BYTES_ERROR
public:
literal String^ ERL_CONN_EOF_AFTER_N_BYTES_ERROR
static val mutable ERL_CONN_EOF_AFTER_N_BYTES_ERROR: string
static val mutable ERL_CONN_EOF_AFTER_N_BYTES_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CONN_HANDSHAKE_DATA_ERROR Field

StringConsts ERL_CONN_HANDSHAKE_DATA_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_HANDSHAKE_DATA_ERROR
public const string ERL_CONN_HANDSHAKE_DATA_ERROR
Public Const ERL_CONN_HANDSHAKE_DATA_ERROR As String
Public Const ERL_CONN_HANDSHAKE_DATA_ERROR As String
public:
literal String^ ERL_CONN_HANDSHAKE_DATA_ERROR
public:
literal String^ ERL_CONN_HANDSHAKE_DATA_ERROR
static val mutable ERL_CONN_HANDSHAKE_DATA_ERROR: string
static val mutable ERL_CONN_HANDSHAKE_DATA_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CONN_HANDSHAKE_EXT_PIDS_ERROR Field

StringConsts ERL_CONN_HANDSHAKE_EXT_PIDS_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_HANDSHAKE_EXT_PIDS_ERROR
public const string ERL_CONN_HANDSHAKE_EXT_PIDS_ERROR
Public Const ERL_CONN_HANDSHAKE_EXT_PIDS_ERROR As String
Public Const ERL_CONN_HANDSHAKE_EXT_PIDS_ERROR As String
public:
literal String^ ERL_CONN_HANDSHAKE_EXT_PIDS_ERROR
public:
literal String^ ERL_CONN_HANDSHAKE_EXT_PIDS_ERROR
static val mutable ERL_CONN_HANDSHAKE_EXT_PIDS_ERROR: string
static val mutable ERL_CONN_HANDSHAKE_EXT_PIDS_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CONN_HANDSHAKE_FAILED_ERROR Field

StringConsts ERL_CONN_HANDSHAKE_FAILED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_HANDSHAKE_FAILED_ERROR
public const string ERL_CONN_HANDSHAKE_FAILED_ERROR
Public Const ERL_CONN_HANDSHAKE_FAILED_ERROR As String
Public Const ERL_CONN_HANDSHAKE_FAILED_ERROR As String
public:
literal String^ ERL_CONN_HANDSHAKE_FAILED_ERROR
public:
literal String^ ERL_CONN_HANDSHAKE_FAILED_ERROR
static val mutable ERL_CONN_HANDSHAKE_FAILED_ERROR: string
static val mutable ERL_CONN_HANDSHAKE_FAILED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CONN_HANDSHAKE_REF_ERROR Field

StringConsts ERL_CONN_HANDSHAKE_REF_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_HANDSHAKE_REF_ERROR
public const string ERL_CONN_HANDSHAKE_REF_ERROR
Public Const ERL_CONN_HANDSHAKE_REF_ERROR As String
Public Const ERL_CONN_HANDSHAKE_REF_ERROR As String
public:
literal String^ ERL_CONN_HANDSHAKE_REF_ERROR
public:
literal String^ ERL_CONN_HANDSHAKE_REF_ERROR
static val mutable ERL_CONN_HANDSHAKE_REF_ERROR: string
static val mutable ERL_CONN_HANDSHAKE_REF_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CONN_INVALID_DATA_FROM_PEER_ERROR Field

StringConsts ERL_CONN_INVALID_DATA_FROM_PEER_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_INVALID_DATA_FROM_PEER_ERROR
public const string ERL_CONN_INVALID_DATA_FROM_PEER_ERROR
Public Const ERL_CONN_INVALID_DATA_FROM_PEER_ERROR As String
Public Const ERL_CONN_INVALID_DATA_FROM_PEER_ERROR As String
public:
literal String^ ERL_CONN_INVALID_DATA_FROM_PEER_ERROR
public:
literal String^ ERL_CONN_INVALID_DATA_FROM_PEER_ERROR
static val mutable ERL_CONN_INVALID_DATA_FROM_PEER_ERROR: string
static val mutable ERL_CONN_INVALID_DATA_FROM_PEER_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CONN_LOCAL_RPC_ERROR Field

StringConsts ERL_CONN_LOCAL_RPC_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_LOCAL_RPC_ERROR
public const string ERL_CONN_LOCAL_RPC_ERROR
Public Const ERL_CONN_LOCAL_RPC_ERROR As String
Public Const ERL_CONN_LOCAL_RPC_ERROR As String
public:
literal String^ ERL_CONN_LOCAL_RPC_ERROR
public:
literal String^ ERL_CONN_LOCAL_RPC_ERROR
static val mutable ERL_CONN_LOCAL_RPC_ERROR: string
static val mutable ERL_CONN_LOCAL_RPC_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CONN_MSG_SIZE_TOO_LONG_ERROR Field

StringConsts ERL_CONN_MSG_SIZE_TOO_LONG_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_MSG_SIZE_TOO_LONG_ERROR
public const string ERL_CONN_MSG_SIZE_TOO_LONG_ERROR
Public Const ERL_CONN_MSG_SIZE_TOO_LONG_ERROR As String
Public Const ERL_CONN_MSG_SIZE_TOO_LONG_ERROR As String
public:
literal String^ ERL_CONN_MSG_SIZE_TOO_LONG_ERROR
public:
literal String^ ERL_CONN_MSG_SIZE_TOO_LONG_ERROR
static val mutable ERL_CONN_MSG_SIZE_TOO_LONG_ERROR: string
static val mutable ERL_CONN_MSG_SIZE_TOO_LONG_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CONN_NO_COMMON_PROTO_ERROR Field

StringConsts ERL_CONN_NO_COMMON_PROTO_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_NO_COMMON_PROTO_ERROR
public const string ERL_CONN_NO_COMMON_PROTO_ERROR
Public Const ERL_CONN_NO_COMMON_PROTO_ERROR As String
Public Const ERL_CONN_NO_COMMON_PROTO_ERROR As String
public:
literal String^ ERL_CONN_NO_COMMON_PROTO_ERROR
public:
literal String^ ERL_CONN_NO_COMMON_PROTO_ERROR
static val mutable ERL_CONN_NO_COMMON_PROTO_ERROR: string
static val mutable ERL_CONN_NO_COMMON_PROTO_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CONN_NOT_CONNECTED_ERROR Field

StringConsts ERL_CONN_NOT_CONNECTED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_NOT_CONNECTED_ERROR
public const string ERL_CONN_NOT_CONNECTED_ERROR
Public Const ERL_CONN_NOT_CONNECTED_ERROR As String
Public Const ERL_CONN_NOT_CONNECTED_ERROR As String
public:
literal String^ ERL_CONN_NOT_CONNECTED_ERROR
public:
literal String^ ERL_CONN_NOT_CONNECTED_ERROR
static val mutable ERL_CONN_NOT_CONNECTED_ERROR: string
static val mutable ERL_CONN_NOT_CONNECTED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CONN_PEER_AUTH_ERROR Field

StringConsts ERL_CONN_PEER_AUTH_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_PEER_AUTH_ERROR
public const string ERL_CONN_PEER_AUTH_ERROR
Public Const ERL_CONN_PEER_AUTH_ERROR As String
Public Const ERL_CONN_PEER_AUTH_ERROR As String
public:
literal String^ ERL_CONN_PEER_AUTH_ERROR
public:
literal String^ ERL_CONN_PEER_AUTH_ERROR
static val mutable ERL_CONN_PEER_AUTH_ERROR: string
static val mutable ERL_CONN_PEER_AUTH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CONN_READ_TOO_SHORT_ERROR Field

StringConsts ERL_CONN_READ_TOO_SHORT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_READ_TOO_SHORT_ERROR
public const string ERL_CONN_READ_TOO_SHORT_ERROR
Public Const ERL_CONN_READ_TOO_SHORT_ERROR As String
Public Const ERL_CONN_READ_TOO_SHORT_ERROR As String
public:
literal String^ ERL_CONN_READ_TOO_SHORT_ERROR
public:
literal String^ ERL_CONN_READ_TOO_SHORT_ERROR
static val mutable ERL_CONN_READ_TOO_SHORT_ERROR: string
static val mutable ERL_CONN_READ_TOO_SHORT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CONN_REMOTE_CLOSED_ERROR Field

StringConsts ERL_CONN_REMOTE_CLOSED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_REMOTE_CLOSED_ERROR
public const string ERL_CONN_REMOTE_CLOSED_ERROR
Public Const ERL_CONN_REMOTE_CLOSED_ERROR As String
Public Const ERL_CONN_REMOTE_CLOSED_ERROR As String
public:
literal String^ ERL_CONN_REMOTE_CLOSED_ERROR
public:
literal String^ ERL_CONN_REMOTE_CLOSED_ERROR
static val mutable ERL_CONN_REMOTE_CLOSED_ERROR: string
static val mutable ERL_CONN_REMOTE_CLOSED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CONN_TIMEOUT_ERROR Field

StringConsts ERL_CONN_TIMEOUT_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_TIMEOUT_ERROR
public const string ERL_CONN_TIMEOUT_ERROR
Public Const ERL_CONN_TIMEOUT_ERROR As String
Public Const ERL_CONN_TIMEOUT_ERROR As String
public:
literal String^ ERL_CONN_TIMEOUT_ERROR
public:
literal String^ ERL_CONN_TIMEOUT_ERROR
static val mutable ERL_CONN_TIMEOUT_ERROR: string
static val mutable ERL_CONN_TIMEOUT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CONN_UNAUTH_COOKIE_ERROR Field

StringConsts ERL_CONN_UNAUTH_COOKIE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_UNAUTH_COOKIE_ERROR
public const string ERL_CONN_UNAUTH_COOKIE_ERROR
Public Const ERL_CONN_UNAUTH_COOKIE_ERROR As String
Public Const ERL_CONN_UNAUTH_COOKIE_ERROR As String
public:
literal String^ ERL_CONN_UNAUTH_COOKIE_ERROR
public:
literal String^ ERL_CONN_UNAUTH_COOKIE_ERROR
static val mutable ERL_CONN_UNAUTH_COOKIE_ERROR: string
static val mutable ERL_CONN_UNAUTH_COOKIE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CONN_UNKNOWN_REMOTE_NODE_ERROR Field

StringConsts ERL_CONN_UNKNOWN_REMOTE_NODE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_UNKNOWN_REMOTE_NODE_ERROR
public const string ERL_CONN_UNKNOWN_REMOTE_NODE_ERROR
Public Const ERL_CONN_UNKNOWN_REMOTE_NODE_ERROR As String
Public Const ERL_CONN_UNKNOWN_REMOTE_NODE_ERROR As String
public:
literal String^ ERL_CONN_UNKNOWN_REMOTE_NODE_ERROR
public:
literal String^ ERL_CONN_UNKNOWN_REMOTE_NODE_ERROR
static val mutable ERL_CONN_UNKNOWN_REMOTE_NODE_ERROR: string
static val mutable ERL_CONN_UNKNOWN_REMOTE_NODE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CONN_UNKNOWN_TAG_ERROR Field

StringConsts ERL_CONN_UNKNOWN_TAG_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_UNKNOWN_TAG_ERROR
public const string ERL_CONN_UNKNOWN_TAG_ERROR
Public Const ERL_CONN_UNKNOWN_TAG_ERROR As String
Public Const ERL_CONN_UNKNOWN_TAG_ERROR As String
public:
literal String^ ERL_CONN_UNKNOWN_TAG_ERROR
public:
literal String^ ERL_CONN_UNKNOWN_TAG_ERROR
static val mutable ERL_CONN_UNKNOWN_TAG_ERROR: string
static val mutable ERL_CONN_UNKNOWN_TAG_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CONN_WRONG_STATUS_ERROR Field

StringConsts ERL_CONN_WRONG_STATUS_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_WRONG_STATUS_ERROR
public const string ERL_CONN_WRONG_STATUS_ERROR
Public Const ERL_CONN_WRONG_STATUS_ERROR As String
Public Const ERL_CONN_WRONG_STATUS_ERROR As String
public:
literal String^ ERL_CONN_WRONG_STATUS_ERROR
public:
literal String^ ERL_CONN_WRONG_STATUS_ERROR
static val mutable ERL_CONN_WRONG_STATUS_ERROR: string
static val mutable ERL_CONN_WRONG_STATUS_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_CONNECTION Field

StringConsts ERL_CONNECTION Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONNECTION
public const string ERL_CONNECTION
Public Const ERL_CONNECTION As String
Public Const ERL_CONNECTION As String
public:
literal String^ ERL_CONNECTION
public:
literal String^ ERL_CONNECTION
static val mutable ERL_CONNECTION: string
static val mutable ERL_CONNECTION: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_DS_CRUD_RESP_SCH_FLD_COUNT_ERROR Field

StringConsts ERL_DS_CRUD_RESP_SCH_FLD_COUNT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_CRUD_RESP_SCH_FLD_COUNT_ERROR
public const string ERL_DS_CRUD_RESP_SCH_FLD_COUNT_ERROR
Public Const ERL_DS_CRUD_RESP_SCH_FLD_COUNT_ERROR As String
Public Const ERL_DS_CRUD_RESP_SCH_FLD_COUNT_ERROR As String
public:
literal String^ ERL_DS_CRUD_RESP_SCH_FLD_COUNT_ERROR
public:
literal String^ ERL_DS_CRUD_RESP_SCH_FLD_COUNT_ERROR
static val mutable ERL_DS_CRUD_RESP_SCH_FLD_COUNT_ERROR: string
static val mutable ERL_DS_CRUD_RESP_SCH_FLD_COUNT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_DS_CRUD_RESP_SCH_MISMATCH_ERROR Field

StringConsts ERL_DS_CRUD_RESP_SCH_MISMATCH_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_CRUD_RESP_SCH_MISMATCH_ERROR
public const string ERL_DS_CRUD_RESP_SCH_MISMATCH_ERROR
Public Const ERL_DS_CRUD_RESP_SCH_MISMATCH_ERROR As String
Public Const ERL_DS_CRUD_RESP_SCH_MISMATCH_ERROR As String
public:
literal String^ ERL_DS_CRUD_RESP_SCH_MISMATCH_ERROR
public:
literal String^ ERL_DS_CRUD_RESP_SCH_MISMATCH_ERROR
static val mutable ERL_DS_CRUD_RESP_SCH_MISMATCH_ERROR: string
static val mutable ERL_DS_CRUD_RESP_SCH_MISMATCH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_DS_CRUD_WRITE_FAILED_ERROR Field

StringConsts ERL_DS_CRUD_WRITE_FAILED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_CRUD_WRITE_FAILED_ERROR
public const string ERL_DS_CRUD_WRITE_FAILED_ERROR
Public Const ERL_DS_CRUD_WRITE_FAILED_ERROR As String
Public Const ERL_DS_CRUD_WRITE_FAILED_ERROR As String
public:
literal String^ ERL_DS_CRUD_WRITE_FAILED_ERROR
public:
literal String^ ERL_DS_CRUD_WRITE_FAILED_ERROR
static val mutable ERL_DS_CRUD_WRITE_FAILED_ERROR: string
static val mutable ERL_DS_CRUD_WRITE_FAILED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_DS_INTERNAL_MAPPING_ERROR Field

StringConsts ERL_DS_INTERNAL_MAPPING_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_INTERNAL_MAPPING_ERROR
public const string ERL_DS_INTERNAL_MAPPING_ERROR
Public Const ERL_DS_INTERNAL_MAPPING_ERROR As String
Public Const ERL_DS_INTERNAL_MAPPING_ERROR As String
public:
literal String^ ERL_DS_INTERNAL_MAPPING_ERROR
public:
literal String^ ERL_DS_INTERNAL_MAPPING_ERROR
static val mutable ERL_DS_INTERNAL_MAPPING_ERROR: string
static val mutable ERL_DS_INTERNAL_MAPPING_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_DS_INVALID_RESP_PROTOCOL_ERROR Field

StringConsts ERL_DS_INVALID_RESP_PROTOCOL_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_INVALID_RESP_PROTOCOL_ERROR
public const string ERL_DS_INVALID_RESP_PROTOCOL_ERROR
Public Const ERL_DS_INVALID_RESP_PROTOCOL_ERROR As String
Public Const ERL_DS_INVALID_RESP_PROTOCOL_ERROR As String
public:
literal String^ ERL_DS_INVALID_RESP_PROTOCOL_ERROR
public:
literal String^ ERL_DS_INVALID_RESP_PROTOCOL_ERROR
static val mutable ERL_DS_INVALID_RESP_PROTOCOL_ERROR: string
static val mutable ERL_DS_INVALID_RESP_PROTOCOL_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_DS_QUERY_PARAM_NOT_FOUND_ERROR Field

StringConsts ERL_DS_QUERY_PARAM_NOT_FOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_QUERY_PARAM_NOT_FOUND_ERROR
public const string ERL_DS_QUERY_PARAM_NOT_FOUND_ERROR
Public Const ERL_DS_QUERY_PARAM_NOT_FOUND_ERROR As String
Public Const ERL_DS_QUERY_PARAM_NOT_FOUND_ERROR As String
public:
literal String^ ERL_DS_QUERY_PARAM_NOT_FOUND_ERROR
public:
literal String^ ERL_DS_QUERY_PARAM_NOT_FOUND_ERROR
static val mutable ERL_DS_QUERY_PARAM_NOT_FOUND_ERROR: string
static val mutable ERL_DS_QUERY_PARAM_NOT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_DS_QUERY_SCRIPT_PARSE_ERROR Field

StringConsts ERL_DS_QUERY_SCRIPT_PARSE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_QUERY_SCRIPT_PARSE_ERROR
public const string ERL_DS_QUERY_SCRIPT_PARSE_ERROR
Public Const ERL_DS_QUERY_SCRIPT_PARSE_ERROR As String
Public Const ERL_DS_QUERY_SCRIPT_PARSE_ERROR As String
public:
literal String^ ERL_DS_QUERY_SCRIPT_PARSE_ERROR
public:
literal String^ ERL_DS_QUERY_SCRIPT_PARSE_ERROR
static val mutable ERL_DS_QUERY_SCRIPT_PARSE_ERROR: string
static val mutable ERL_DS_QUERY_SCRIPT_PARSE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_DS_QUERY_SUBSCR_NOT_FOUND_ERROR Field

StringConsts ERL_DS_QUERY_SUBSCR_NOT_FOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_QUERY_SUBSCR_NOT_FOUND_ERROR
public const string ERL_DS_QUERY_SUBSCR_NOT_FOUND_ERROR
Public Const ERL_DS_QUERY_SUBSCR_NOT_FOUND_ERROR As String
Public Const ERL_DS_QUERY_SUBSCR_NOT_FOUND_ERROR As String
public:
literal String^ ERL_DS_QUERY_SUBSCR_NOT_FOUND_ERROR
public:
literal String^ ERL_DS_QUERY_SUBSCR_NOT_FOUND_ERROR
static val mutable ERL_DS_QUERY_SUBSCR_NOT_FOUND_ERROR: string
static val mutable ERL_DS_QUERY_SUBSCR_NOT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_DS_QUERY_TMSTAMP_CTX_ABSENT_ERROR Field

StringConsts ERL_DS_QUERY_TMSTAMP_CTX_ABSENT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_QUERY_TMSTAMP_CTX_ABSENT_ERROR
public const string ERL_DS_QUERY_TMSTAMP_CTX_ABSENT_ERROR
Public Const ERL_DS_QUERY_TMSTAMP_CTX_ABSENT_ERROR As String
Public Const ERL_DS_QUERY_TMSTAMP_CTX_ABSENT_ERROR As String
public:
literal String^ ERL_DS_QUERY_TMSTAMP_CTX_ABSENT_ERROR
public:
literal String^ ERL_DS_QUERY_TMSTAMP_CTX_ABSENT_ERROR
static val mutable ERL_DS_QUERY_TMSTAMP_CTX_ABSENT_ERROR: string
static val mutable ERL_DS_QUERY_TMSTAMP_CTX_ABSENT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_DS_QUERY_TMSTAMP_NOT_FOUND_ERROR Field

StringConsts ERL_DS_QUERY_TMSTAMP_NOT_FOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_QUERY_TMSTAMP_NOT_FOUND_ERROR
public const string ERL_DS_QUERY_TMSTAMP_NOT_FOUND_ERROR
Public Const ERL_DS_QUERY_TMSTAMP_NOT_FOUND_ERROR As String
Public Const ERL_DS_QUERY_TMSTAMP_NOT_FOUND_ERROR As String
public:
literal String^ ERL_DS_QUERY_TMSTAMP_NOT_FOUND_ERROR
public:
literal String^ ERL_DS_QUERY_TMSTAMP_NOT_FOUND_ERROR
static val mutable ERL_DS_QUERY_TMSTAMP_NOT_FOUND_ERROR: string
static val mutable ERL_DS_QUERY_TMSTAMP_NOT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_DS_RPC_EXEC_ERROR Field

StringConsts ERL_DS_RPC_EXEC_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_RPC_EXEC_ERROR
public const string ERL_DS_RPC_EXEC_ERROR
Public Const ERL_DS_RPC_EXEC_ERROR As String
Public Const ERL_DS_RPC_EXEC_ERROR As String
public:
literal String^ ERL_DS_RPC_EXEC_ERROR
public:
literal String^ ERL_DS_RPC_EXEC_ERROR
static val mutable ERL_DS_RPC_EXEC_ERROR: string
static val mutable ERL_DS_RPC_EXEC_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_DS_SCHEMA_INVALID_VALUE_ERROR Field

StringConsts ERL_DS_SCHEMA_INVALID_VALUE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_SCHEMA_INVALID_VALUE_ERROR
public const string ERL_DS_SCHEMA_INVALID_VALUE_ERROR
Public Const ERL_DS_SCHEMA_INVALID_VALUE_ERROR As String
Public Const ERL_DS_SCHEMA_INVALID_VALUE_ERROR As String
public:
literal String^ ERL_DS_SCHEMA_INVALID_VALUE_ERROR
public:
literal String^ ERL_DS_SCHEMA_INVALID_VALUE_ERROR
static val mutable ERL_DS_SCHEMA_INVALID_VALUE_ERROR: string
static val mutable ERL_DS_SCHEMA_INVALID_VALUE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_DS_SCHEMA_MAP_ERL_TYPE_ERROR Field

StringConsts ERL_DS_SCHEMA_MAP_ERL_TYPE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_SCHEMA_MAP_ERL_TYPE_ERROR
public const string ERL_DS_SCHEMA_MAP_ERL_TYPE_ERROR
Public Const ERL_DS_SCHEMA_MAP_ERL_TYPE_ERROR As String
Public Const ERL_DS_SCHEMA_MAP_ERL_TYPE_ERROR As String
public:
literal String^ ERL_DS_SCHEMA_MAP_ERL_TYPE_ERROR
public:
literal String^ ERL_DS_SCHEMA_MAP_ERL_TYPE_ERROR
static val mutable ERL_DS_SCHEMA_MAP_ERL_TYPE_ERROR: string
static val mutable ERL_DS_SCHEMA_MAP_ERL_TYPE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_DS_SCHEMA_MAP_NOT_KNOWN_ERROR Field

StringConsts ERL_DS_SCHEMA_MAP_NOT_KNOWN_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_SCHEMA_MAP_NOT_KNOWN_ERROR
public const string ERL_DS_SCHEMA_MAP_NOT_KNOWN_ERROR
Public Const ERL_DS_SCHEMA_MAP_NOT_KNOWN_ERROR As String
Public Const ERL_DS_SCHEMA_MAP_NOT_KNOWN_ERROR As String
public:
literal String^ ERL_DS_SCHEMA_MAP_NOT_KNOWN_ERROR
public:
literal String^ ERL_DS_SCHEMA_MAP_NOT_KNOWN_ERROR
static val mutable ERL_DS_SCHEMA_MAP_NOT_KNOWN_ERROR: string
static val mutable ERL_DS_SCHEMA_MAP_NOT_KNOWN_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_DS_SCHEMA_NOT_KNOWN_ERROR Field

StringConsts ERL_DS_SCHEMA_NOT_KNOWN_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_SCHEMA_NOT_KNOWN_ERROR
public const string ERL_DS_SCHEMA_NOT_KNOWN_ERROR
Public Const ERL_DS_SCHEMA_NOT_KNOWN_ERROR As String
Public Const ERL_DS_SCHEMA_NOT_KNOWN_ERROR As String
public:
literal String^ ERL_DS_SCHEMA_NOT_KNOWN_ERROR
public:
literal String^ ERL_DS_SCHEMA_NOT_KNOWN_ERROR
static val mutable ERL_DS_SCHEMA_NOT_KNOWN_ERROR: string
static val mutable ERL_DS_SCHEMA_NOT_KNOWN_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_DS_START_REMOTE_ABSENT_ERROR Field

StringConsts ERL_DS_START_REMOTE_ABSENT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_START_REMOTE_ABSENT_ERROR
public const string ERL_DS_START_REMOTE_ABSENT_ERROR
Public Const ERL_DS_START_REMOTE_ABSENT_ERROR As String
Public Const ERL_DS_START_REMOTE_ABSENT_ERROR As String
public:
literal String^ ERL_DS_START_REMOTE_ABSENT_ERROR
public:
literal String^ ERL_DS_START_REMOTE_ABSENT_ERROR
static val mutable ERL_DS_START_REMOTE_ABSENT_ERROR: string
static val mutable ERL_DS_START_REMOTE_ABSENT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_DS_START_REMOTE_DUPLICATE_ERROR Field

StringConsts ERL_DS_START_REMOTE_DUPLICATE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_START_REMOTE_DUPLICATE_ERROR
public const string ERL_DS_START_REMOTE_DUPLICATE_ERROR
Public Const ERL_DS_START_REMOTE_DUPLICATE_ERROR As String
Public Const ERL_DS_START_REMOTE_DUPLICATE_ERROR As String
public:
literal String^ ERL_DS_START_REMOTE_DUPLICATE_ERROR
public:
literal String^ ERL_DS_START_REMOTE_DUPLICATE_ERROR
static val mutable ERL_DS_START_REMOTE_DUPLICATE_ERROR: string
static val mutable ERL_DS_START_REMOTE_DUPLICATE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_EPMD_FAILED_TO_CONNECT_ERROR Field

StringConsts ERL_EPMD_FAILED_TO_CONNECT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_EPMD_FAILED_TO_CONNECT_ERROR
public const string ERL_EPMD_FAILED_TO_CONNECT_ERROR
Public Const ERL_EPMD_FAILED_TO_CONNECT_ERROR As String
Public Const ERL_EPMD_FAILED_TO_CONNECT_ERROR As String
public:
literal String^ ERL_EPMD_FAILED_TO_CONNECT_ERROR
public:
literal String^ ERL_EPMD_FAILED_TO_CONNECT_ERROR
static val mutable ERL_EPMD_FAILED_TO_CONNECT_ERROR: string
static val mutable ERL_EPMD_FAILED_TO_CONNECT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_EPMD_INVALID_PORT_ERROR Field

StringConsts ERL_EPMD_INVALID_PORT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_EPMD_INVALID_PORT_ERROR
public const string ERL_EPMD_INVALID_PORT_ERROR
Public Const ERL_EPMD_INVALID_PORT_ERROR As String
Public Const ERL_EPMD_INVALID_PORT_ERROR As String
public:
literal String^ ERL_EPMD_INVALID_PORT_ERROR
public:
literal String^ ERL_EPMD_INVALID_PORT_ERROR
static val mutable ERL_EPMD_INVALID_PORT_ERROR: string
static val mutable ERL_EPMD_INVALID_PORT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_EPMD_INVALID_RESPONSE_ERROR Field

StringConsts ERL_EPMD_INVALID_RESPONSE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_EPMD_INVALID_RESPONSE_ERROR
public const string ERL_EPMD_INVALID_RESPONSE_ERROR
Public Const ERL_EPMD_INVALID_RESPONSE_ERROR As String
Public Const ERL_EPMD_INVALID_RESPONSE_ERROR As String
public:
literal String^ ERL_EPMD_INVALID_RESPONSE_ERROR
public:
literal String^ ERL_EPMD_INVALID_RESPONSE_ERROR
static val mutable ERL_EPMD_INVALID_RESPONSE_ERROR: string
static val mutable ERL_EPMD_INVALID_RESPONSE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_EPMD_LOOKUP_R4 Field

StringConsts ERL_EPMD_LOOKUP_R4 Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_EPMD_LOOKUP_R4
public const string ERL_EPMD_LOOKUP_R4
Public Const ERL_EPMD_LOOKUP_R4 As String
Public Const ERL_EPMD_LOOKUP_R4 As String
public:
literal String^ ERL_EPMD_LOOKUP_R4
public:
literal String^ ERL_EPMD_LOOKUP_R4
static val mutable ERL_EPMD_LOOKUP_R4: string
static val mutable ERL_EPMD_LOOKUP_R4: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_EPMD_NO_RESPONSE Field

StringConsts ERL_EPMD_NO_RESPONSE Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_EPMD_NO_RESPONSE
public const string ERL_EPMD_NO_RESPONSE
Public Const ERL_EPMD_NO_RESPONSE As String
Public Const ERL_EPMD_NO_RESPONSE As String
public:
literal String^ ERL_EPMD_NO_RESPONSE
public:
literal String^ ERL_EPMD_NO_RESPONSE
static val mutable ERL_EPMD_NO_RESPONSE: string
static val mutable ERL_EPMD_NO_RESPONSE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_EPMD_NOT_FOUND Field

StringConsts ERL_EPMD_NOT_FOUND Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_EPMD_NOT_FOUND
public const string ERL_EPMD_NOT_FOUND
Public Const ERL_EPMD_NOT_FOUND As String
Public Const ERL_EPMD_NOT_FOUND As String
public:
literal String^ ERL_EPMD_NOT_FOUND
public:
literal String^ ERL_EPMD_NOT_FOUND
static val mutable ERL_EPMD_NOT_FOUND: string
static val mutable ERL_EPMD_NOT_FOUND: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_EPMD_NOT_RESPONDING Field

StringConsts ERL_EPMD_NOT_RESPONDING Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_EPMD_NOT_RESPONDING
public const string ERL_EPMD_NOT_RESPONDING
Public Const ERL_EPMD_NOT_RESPONDING As String
Public Const ERL_EPMD_NOT_RESPONDING As String
public:
literal String^ ERL_EPMD_NOT_RESPONDING
public:
literal String^ ERL_EPMD_NOT_RESPONDING
static val mutable ERL_EPMD_NOT_RESPONDING: string
static val mutable ERL_EPMD_NOT_RESPONDING: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_EPMD_OK Field

StringConsts ERL_EPMD_OK Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_EPMD_OK
public const string ERL_EPMD_OK
Public Const ERL_EPMD_OK As String
Public Const ERL_EPMD_OK As String
public:
literal String^ ERL_EPMD_OK
public:
literal String^ ERL_EPMD_OK
static val mutable ERL_EPMD_OK: string
static val mutable ERL_EPMD_OK: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_EPMD_PORT Field

StringConsts ERL_EPMD_PORT Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_EPMD_PORT
public const string ERL_EPMD_PORT
Public Const ERL_EPMD_PORT As String
Public Const ERL_EPMD_PORT As String
public:
literal String^ ERL_EPMD_PORT
public:
literal String^ ERL_EPMD_PORT
static val mutable ERL_EPMD_PORT: string
static val mutable ERL_EPMD_PORT: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_EPMD_PUBLISH Field

StringConsts ERL_EPMD_PUBLISH Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_EPMD_PUBLISH
public const string ERL_EPMD_PUBLISH
Public Const ERL_EPMD_PUBLISH As String
Public Const ERL_EPMD_PUBLISH As String
public:
literal String^ ERL_EPMD_PUBLISH
public:
literal String^ ERL_EPMD_PUBLISH
static val mutable ERL_EPMD_PUBLISH: string
static val mutable ERL_EPMD_PUBLISH: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_EPMD_UNPUBLISH Field

StringConsts ERL_EPMD_UNPUBLISH Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_EPMD_UNPUBLISH
public const string ERL_EPMD_UNPUBLISH
Public Const ERL_EPMD_UNPUBLISH As String
Public Const ERL_EPMD_UNPUBLISH As String
public:
literal String^ ERL_EPMD_UNPUBLISH
public:
literal String^ ERL_EPMD_UNPUBLISH
static val mutable ERL_EPMD_UNPUBLISH: string
static val mutable ERL_EPMD_UNPUBLISH: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_INVALID_DATA_FORMAT_ERROR Field

StringConsts ERL_INVALID_DATA_FORMAT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_INVALID_DATA_FORMAT_ERROR
public const string ERL_INVALID_DATA_FORMAT_ERROR
Public Const ERL_INVALID_DATA_FORMAT_ERROR As String
Public Const ERL_INVALID_DATA_FORMAT_ERROR As String
public:
literal String^ ERL_INVALID_DATA_FORMAT_ERROR
public:
literal String^ ERL_INVALID_DATA_FORMAT_ERROR
static val mutable ERL_INVALID_DATA_FORMAT_ERROR: string
static val mutable ERL_INVALID_DATA_FORMAT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_INVALID_FORMATTING_CHAR_ERROR Field

StringConsts ERL_INVALID_FORMATTING_CHAR_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_INVALID_FORMATTING_CHAR_ERROR
public const string ERL_INVALID_FORMATTING_CHAR_ERROR
Public Const ERL_INVALID_FORMATTING_CHAR_ERROR As String
Public Const ERL_INVALID_FORMATTING_CHAR_ERROR As String
public:
literal String^ ERL_INVALID_FORMATTING_CHAR_ERROR
public:
literal String^ ERL_INVALID_FORMATTING_CHAR_ERROR
static val mutable ERL_INVALID_FORMATTING_CHAR_ERROR: string
static val mutable ERL_INVALID_FORMATTING_CHAR_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_INVALID_IO_REQUEST Field

StringConsts ERL_INVALID_IO_REQUEST Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_INVALID_IO_REQUEST
public const string ERL_INVALID_IO_REQUEST
Public Const ERL_INVALID_IO_REQUEST As String
Public Const ERL_INVALID_IO_REQUEST As String
public:
literal String^ ERL_INVALID_IO_REQUEST
public:
literal String^ ERL_INVALID_IO_REQUEST
static val mutable ERL_INVALID_IO_REQUEST: string
static val mutable ERL_INVALID_IO_REQUEST: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_INVALID_MBOX_NAME_ERROR Field

StringConsts ERL_INVALID_MBOX_NAME_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_INVALID_MBOX_NAME_ERROR
public const string ERL_INVALID_MBOX_NAME_ERROR
Public Const ERL_INVALID_MBOX_NAME_ERROR As String
Public Const ERL_INVALID_MBOX_NAME_ERROR As String
public:
literal String^ ERL_INVALID_MBOX_NAME_ERROR
public:
literal String^ ERL_INVALID_MBOX_NAME_ERROR
static val mutable ERL_INVALID_MBOX_NAME_ERROR: string
static val mutable ERL_INVALID_MBOX_NAME_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_INVALID_MFA_FORMAT_ERROR Field

StringConsts ERL_INVALID_MFA_FORMAT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_INVALID_MFA_FORMAT_ERROR
public const string ERL_INVALID_MFA_FORMAT_ERROR
Public Const ERL_INVALID_MFA_FORMAT_ERROR As String
Public Const ERL_INVALID_MFA_FORMAT_ERROR As String
public:
literal String^ ERL_INVALID_MFA_FORMAT_ERROR
public:
literal String^ ERL_INVALID_MFA_FORMAT_ERROR
static val mutable ERL_INVALID_MFA_FORMAT_ERROR: string
static val mutable ERL_INVALID_MFA_FORMAT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_INVALID_NUMBER_OF_ARGS_ERROR Field

StringConsts ERL_INVALID_NUMBER_OF_ARGS_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_INVALID_NUMBER_OF_ARGS_ERROR
public const string ERL_INVALID_NUMBER_OF_ARGS_ERROR
Public Const ERL_INVALID_NUMBER_OF_ARGS_ERROR As String
Public Const ERL_INVALID_NUMBER_OF_ARGS_ERROR As String
public:
literal String^ ERL_INVALID_NUMBER_OF_ARGS_ERROR
public:
literal String^ ERL_INVALID_NUMBER_OF_ARGS_ERROR
static val mutable ERL_INVALID_NUMBER_OF_ARGS_ERROR: string
static val mutable ERL_INVALID_NUMBER_OF_ARGS_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_INVALID_RPC_REQUEST_ERROR Field

StringConsts ERL_INVALID_RPC_REQUEST_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_INVALID_RPC_REQUEST_ERROR
public const string ERL_INVALID_RPC_REQUEST_ERROR
Public Const ERL_INVALID_RPC_REQUEST_ERROR As String
Public Const ERL_INVALID_RPC_REQUEST_ERROR As String
public:
literal String^ ERL_INVALID_RPC_REQUEST_ERROR
public:
literal String^ ERL_INVALID_RPC_REQUEST_ERROR
static val mutable ERL_INVALID_RPC_REQUEST_ERROR: string
static val mutable ERL_INVALID_RPC_REQUEST_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_INVALID_TERM_TYPE_ERROR Field

StringConsts ERL_INVALID_TERM_TYPE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_INVALID_TERM_TYPE_ERROR
public const string ERL_INVALID_TERM_TYPE_ERROR
Public Const ERL_INVALID_TERM_TYPE_ERROR As String
Public Const ERL_INVALID_TERM_TYPE_ERROR As String
public:
literal String^ ERL_INVALID_TERM_TYPE_ERROR
public:
literal String^ ERL_INVALID_TERM_TYPE_ERROR
static val mutable ERL_INVALID_TERM_TYPE_ERROR: string
static val mutable ERL_INVALID_TERM_TYPE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_INVALID_VALUE_CAST_ERROR Field

StringConsts ERL_INVALID_VALUE_CAST_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_INVALID_VALUE_CAST_ERROR
public const string ERL_INVALID_VALUE_CAST_ERROR
Public Const ERL_INVALID_VALUE_CAST_ERROR As String
Public Const ERL_INVALID_VALUE_CAST_ERROR As String
public:
literal String^ ERL_INVALID_VALUE_CAST_ERROR
public:
literal String^ ERL_INVALID_VALUE_CAST_ERROR
static val mutable ERL_INVALID_VALUE_CAST_ERROR: string
static val mutable ERL_INVALID_VALUE_CAST_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_INVALID_VALUE_ERROR Field

StringConsts ERL_INVALID_VALUE_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_INVALID_VALUE_ERROR
public const string ERL_INVALID_VALUE_ERROR
Public Const ERL_INVALID_VALUE_ERROR As String
Public Const ERL_INVALID_VALUE_ERROR As String
public:
literal String^ ERL_INVALID_VALUE_ERROR
public:
literal String^ ERL_INVALID_VALUE_ERROR
static val mutable ERL_INVALID_VALUE_ERROR: string
static val mutable ERL_INVALID_VALUE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_INVALID_VALUE_LENGTH_ERROR Field

StringConsts ERL_INVALID_VALUE_LENGTH_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_INVALID_VALUE_LENGTH_ERROR
public const string ERL_INVALID_VALUE_LENGTH_ERROR
Public Const ERL_INVALID_VALUE_LENGTH_ERROR As String
Public Const ERL_INVALID_VALUE_LENGTH_ERROR As String
public:
literal String^ ERL_INVALID_VALUE_LENGTH_ERROR
public:
literal String^ ERL_INVALID_VALUE_LENGTH_ERROR
static val mutable ERL_INVALID_VALUE_LENGTH_ERROR: string
static val mutable ERL_INVALID_VALUE_LENGTH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_INVALID_VALUE_TYPE_ERROR Field

StringConsts ERL_INVALID_VALUE_TYPE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_INVALID_VALUE_TYPE_ERROR
public const string ERL_INVALID_VALUE_TYPE_ERROR
Public Const ERL_INVALID_VALUE_TYPE_ERROR As String
Public Const ERL_INVALID_VALUE_TYPE_ERROR As String
public:
literal String^ ERL_INVALID_VALUE_TYPE_ERROR
public:
literal String^ ERL_INVALID_VALUE_TYPE_ERROR
static val mutable ERL_INVALID_VALUE_TYPE_ERROR: string
static val mutable ERL_INVALID_VALUE_TYPE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_INVALID_VARIABLE_TYPE_ERROR Field

StringConsts ERL_INVALID_VARIABLE_TYPE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_INVALID_VARIABLE_TYPE_ERROR
public const string ERL_INVALID_VARIABLE_TYPE_ERROR
Public Const ERL_INVALID_VARIABLE_TYPE_ERROR As String
Public Const ERL_INVALID_VARIABLE_TYPE_ERROR As String
public:
literal String^ ERL_INVALID_VARIABLE_TYPE_ERROR
public:
literal String^ ERL_INVALID_VARIABLE_TYPE_ERROR
static val mutable ERL_INVALID_VARIABLE_TYPE_ERROR: string
static val mutable ERL_INVALID_VARIABLE_TYPE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_MISSING_VALUE_FOR_ARGUMENT_ERROR Field

StringConsts ERL_MISSING_VALUE_FOR_ARGUMENT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_MISSING_VALUE_FOR_ARGUMENT_ERROR
public const string ERL_MISSING_VALUE_FOR_ARGUMENT_ERROR
Public Const ERL_MISSING_VALUE_FOR_ARGUMENT_ERROR As String
Public Const ERL_MISSING_VALUE_FOR_ARGUMENT_ERROR As String
public:
literal String^ ERL_MISSING_VALUE_FOR_ARGUMENT_ERROR
public:
literal String^ ERL_MISSING_VALUE_FOR_ARGUMENT_ERROR
static val mutable ERL_MISSING_VALUE_FOR_ARGUMENT_ERROR: string
static val mutable ERL_MISSING_VALUE_FOR_ARGUMENT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_PARSING_AT_ERROR Field

StringConsts ERL_PARSING_AT_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_PARSING_AT_ERROR
public const string ERL_PARSING_AT_ERROR
Public Const ERL_PARSING_AT_ERROR As String
Public Const ERL_PARSING_AT_ERROR As String
public:
literal String^ ERL_PARSING_AT_ERROR
public:
literal String^ ERL_PARSING_AT_ERROR
static val mutable ERL_PARSING_AT_ERROR: string
static val mutable ERL_PARSING_AT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_REF_ID_ARGUMENT_ERROR Field

StringConsts ERL_REF_ID_ARGUMENT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_REF_ID_ARGUMENT_ERROR
public const string ERL_REF_ID_ARGUMENT_ERROR
Public Const ERL_REF_ID_ARGUMENT_ERROR As String
Public Const ERL_REF_ID_ARGUMENT_ERROR As String
public:
literal String^ ERL_REF_ID_ARGUMENT_ERROR
public:
literal String^ ERL_REF_ID_ARGUMENT_ERROR
static val mutable ERL_REF_ID_ARGUMENT_ERROR: string
static val mutable ERL_REF_ID_ARGUMENT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_STOPPING_SERVER Field

StringConsts ERL_STOPPING_SERVER Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_STOPPING_SERVER
public const string ERL_STOPPING_SERVER
Public Const ERL_STOPPING_SERVER As String
Public Const ERL_STOPPING_SERVER As String
public:
literal String^ ERL_STOPPING_SERVER
public:
literal String^ ERL_STOPPING_SERVER
static val mutable ERL_STOPPING_SERVER: string
static val mutable ERL_STOPPING_SERVER: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_UNBOUND_VARIABLE_ERROR Field

StringConsts ERL_UNBOUND_VARIABLE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_UNBOUND_VARIABLE_ERROR
public const string ERL_UNBOUND_VARIABLE_ERROR
Public Const ERL_UNBOUND_VARIABLE_ERROR As String
Public Const ERL_UNBOUND_VARIABLE_ERROR As String
public:
literal String^ ERL_UNBOUND_VARIABLE_ERROR
public:
literal String^ ERL_UNBOUND_VARIABLE_ERROR
static val mutable ERL_UNBOUND_VARIABLE_ERROR: string
static val mutable ERL_UNBOUND_VARIABLE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_UNSUPPORTED_ELEMENT_TYPE_ERROR Field

StringConsts ERL_UNSUPPORTED_ELEMENT_TYPE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_UNSUPPORTED_ELEMENT_TYPE_ERROR
public const string ERL_UNSUPPORTED_ELEMENT_TYPE_ERROR
Public Const ERL_UNSUPPORTED_ELEMENT_TYPE_ERROR As String
Public Const ERL_UNSUPPORTED_ELEMENT_TYPE_ERROR As String
public:
literal String^ ERL_UNSUPPORTED_ELEMENT_TYPE_ERROR
public:
literal String^ ERL_UNSUPPORTED_ELEMENT_TYPE_ERROR
static val mutable ERL_UNSUPPORTED_ELEMENT_TYPE_ERROR: string
static val mutable ERL_UNSUPPORTED_ELEMENT_TYPE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_UNSUPPORTED_TERM_TYPE_ERROR Field

StringConsts ERL_UNSUPPORTED_TERM_TYPE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_UNSUPPORTED_TERM_TYPE_ERROR
public const string ERL_UNSUPPORTED_TERM_TYPE_ERROR
Public Const ERL_UNSUPPORTED_TERM_TYPE_ERROR As String
Public Const ERL_UNSUPPORTED_TERM_TYPE_ERROR As String
public:
literal String^ ERL_UNSUPPORTED_TERM_TYPE_ERROR
public:
literal String^ ERL_UNSUPPORTED_TERM_TYPE_ERROR
static val mutable ERL_UNSUPPORTED_TERM_TYPE_ERROR: string
static val mutable ERL_UNSUPPORTED_TERM_TYPE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_VALUE_MUST_NOT_BE_NULL_ERROR Field

StringConsts ERL_VALUE_MUST_NOT_BE_NULL_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_VALUE_MUST_NOT_BE_NULL_ERROR
public const string ERL_VALUE_MUST_NOT_BE_NULL_ERROR
Public Const ERL_VALUE_MUST_NOT_BE_NULL_ERROR As String
Public Const ERL_VALUE_MUST_NOT_BE_NULL_ERROR As String
public:
literal String^ ERL_VALUE_MUST_NOT_BE_NULL_ERROR
public:
literal String^ ERL_VALUE_MUST_NOT_BE_NULL_ERROR
static val mutable ERL_VALUE_MUST_NOT_BE_NULL_ERROR: string
static val mutable ERL_VALUE_MUST_NOT_BE_NULL_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_VALUE_TOO_LARGE_FOR_TYPE_ERROR Field

StringConsts ERL_VALUE_TOO_LARGE_FOR_TYPE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_VALUE_TOO_LARGE_FOR_TYPE_ERROR
public const string ERL_VALUE_TOO_LARGE_FOR_TYPE_ERROR
Public Const ERL_VALUE_TOO_LARGE_FOR_TYPE_ERROR As String
Public Const ERL_VALUE_TOO_LARGE_FOR_TYPE_ERROR As String
public:
literal String^ ERL_VALUE_TOO_LARGE_FOR_TYPE_ERROR
public:
literal String^ ERL_VALUE_TOO_LARGE_FOR_TYPE_ERROR
static val mutable ERL_VALUE_TOO_LARGE_FOR_TYPE_ERROR: string
static val mutable ERL_VALUE_TOO_LARGE_FOR_TYPE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_VARIABLE_INVALID_VALUE_TYPE_ERROR Field

StringConsts ERL_VARIABLE_INVALID_VALUE_TYPE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_VARIABLE_INVALID_VALUE_TYPE_ERROR
public const string ERL_VARIABLE_INVALID_VALUE_TYPE_ERROR
Public Const ERL_VARIABLE_INVALID_VALUE_TYPE_ERROR As String
Public Const ERL_VARIABLE_INVALID_VALUE_TYPE_ERROR As String
public:
literal String^ ERL_VARIABLE_INVALID_VALUE_TYPE_ERROR
public:
literal String^ ERL_VARIABLE_INVALID_VALUE_TYPE_ERROR
static val mutable ERL_VARIABLE_INVALID_VALUE_TYPE_ERROR: string
static val mutable ERL_VARIABLE_INVALID_VALUE_TYPE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_VARIABLE_NOT_FOUND_ERROR Field

StringConsts ERL_VARIABLE_NOT_FOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_VARIABLE_NOT_FOUND_ERROR
public const string ERL_VARIABLE_NOT_FOUND_ERROR
Public Const ERL_VARIABLE_NOT_FOUND_ERROR As String
Public Const ERL_VARIABLE_NOT_FOUND_ERROR As String
public:
literal String^ ERL_VARIABLE_NOT_FOUND_ERROR
public:
literal String^ ERL_VARIABLE_NOT_FOUND_ERROR
static val mutable ERL_VARIABLE_NOT_FOUND_ERROR: string
static val mutable ERL_VARIABLE_NOT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ERL_WRONG_VALUE_FOR_ARGUMENT_ERROR Field

StringConsts ERL_WRONG_VALUE_FOR_ARGUMENT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_WRONG_VALUE_FOR_ARGUMENT_ERROR
public const string ERL_WRONG_VALUE_FOR_ARGUMENT_ERROR
Public Const ERL_WRONG_VALUE_FOR_ARGUMENT_ERROR As String
Public Const ERL_WRONG_VALUE_FOR_ARGUMENT_ERROR As String
public:
literal String^ ERL_WRONG_VALUE_FOR_ARGUMENT_ERROR
public:
literal String^ ERL_WRONG_VALUE_FOR_ARGUMENT_ERROR
static val mutable ERL_WRONG_VALUE_FOR_ARGUMENT_ERROR: string
static val mutable ERL_WRONG_VALUE_FOR_ARGUMENT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.EXPRESSION_SCOPE_COMPILE_ERROR Field

StringConsts EXPRESSION_SCOPE_COMPILE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string EXPRESSION_SCOPE_COMPILE_ERROR
public const string EXPRESSION_SCOPE_COMPILE_ERROR
Public Const EXPRESSION_SCOPE_COMPILE_ERROR As String
Public Const EXPRESSION_SCOPE_COMPILE_ERROR As String
public:
literal String^ EXPRESSION_SCOPE_COMPILE_ERROR
public:
literal String^ EXPRESSION_SCOPE_COMPILE_ERROR
static val mutable EXPRESSION_SCOPE_COMPILE_ERROR: string
static val mutable EXPRESSION_SCOPE_COMPILE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.FAILED_TO_ALLOCATE_RESOURCE_ERROR Field

StringConsts FAILED_TO_ALLOCATE_RESOURCE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FAILED_TO_ALLOCATE_RESOURCE_ERROR
public const string FAILED_TO_ALLOCATE_RESOURCE_ERROR
Public Const FAILED_TO_ALLOCATE_RESOURCE_ERROR As String
Public Const FAILED_TO_ALLOCATE_RESOURCE_ERROR As String
public:
literal String^ FAILED_TO_ALLOCATE_RESOURCE_ERROR
public:
literal String^ FAILED_TO_ALLOCATE_RESOURCE_ERROR
static val mutable FAILED_TO_ALLOCATE_RESOURCE_ERROR: string
static val mutable FAILED_TO_ALLOCATE_RESOURCE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.FAILED_TO_CREATE_FILE_ERROR Field

StringConsts FAILED_TO_CREATE_FILE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FAILED_TO_CREATE_FILE_ERROR
public const string FAILED_TO_CREATE_FILE_ERROR
Public Const FAILED_TO_CREATE_FILE_ERROR As String
Public Const FAILED_TO_CREATE_FILE_ERROR As String
public:
literal String^ FAILED_TO_CREATE_FILE_ERROR
public:
literal String^ FAILED_TO_CREATE_FILE_ERROR
static val mutable FAILED_TO_CREATE_FILE_ERROR: string
static val mutable FAILED_TO_CREATE_FILE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.FIELD_ATTRIBUTES_DEFS_ERROR Field

StringConsts FIELD_ATTRIBUTES_DEFS_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FIELD_ATTRIBUTES_DEFS_ERROR
public const string FIELD_ATTRIBUTES_DEFS_ERROR
Public Const FIELD_ATTRIBUTES_DEFS_ERROR As String
Public Const FIELD_ATTRIBUTES_DEFS_ERROR As String
public:
literal String^ FIELD_ATTRIBUTES_DEFS_ERROR
public:
literal String^ FIELD_ATTRIBUTES_DEFS_ERROR
static val mutable FIELD_ATTRIBUTES_DEFS_ERROR: string
static val mutable FIELD_ATTRIBUTES_DEFS_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.FIELD_COMPARISON_NOT_IMPLEMENTED_ERROR Field

StringConsts FIELD_COMPARISON_NOT_IMPLEMENTED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FIELD_COMPARISON_NOT_IMPLEMENTED_ERROR
public const string FIELD_COMPARISON_NOT_IMPLEMENTED_ERROR
Public Const FIELD_COMPARISON_NOT_IMPLEMENTED_ERROR As String
Public Const FIELD_COMPARISON_NOT_IMPLEMENTED_ERROR As String
public:
literal String^ FIELD_COMPARISON_NOT_IMPLEMENTED_ERROR
public:
literal String^ FIELD_COMPARISON_NOT_IMPLEMENTED_ERROR
static val mutable FIELD_COMPARISON_NOT_IMPLEMENTED_ERROR: string
static val mutable FIELD_COMPARISON_NOT_IMPLEMENTED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.FIELD_LOOKUP_NOT_ALLOWED_ERROR Field

StringConsts FIELD_LOOKUP_NOT_ALLOWED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FIELD_LOOKUP_NOT_ALLOWED_ERROR
public const string FIELD_LOOKUP_NOT_ALLOWED_ERROR
Public Const FIELD_LOOKUP_NOT_ALLOWED_ERROR As String
Public Const FIELD_LOOKUP_NOT_ALLOWED_ERROR As String
public:
literal String^ FIELD_LOOKUP_NOT_ALLOWED_ERROR
public:
literal String^ FIELD_LOOKUP_NOT_ALLOWED_ERROR
static val mutable FIELD_LOOKUP_NOT_ALLOWED_ERROR: string
static val mutable FIELD_LOOKUP_NOT_ALLOWED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.FIELD_NAME_NOT_FOUND_ERROR Field

StringConsts FIELD_NAME_NOT_FOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FIELD_NAME_NOT_FOUND_ERROR
public const string FIELD_NAME_NOT_FOUND_ERROR
Public Const FIELD_NAME_NOT_FOUND_ERROR As String
Public Const FIELD_NAME_NOT_FOUND_ERROR As String
public:
literal String^ FIELD_NAME_NOT_FOUND_ERROR
public:
literal String^ FIELD_NAME_NOT_FOUND_ERROR
static val mutable FIELD_NAME_NOT_FOUND_ERROR: string
static val mutable FIELD_NAME_NOT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.FIELD_OPERATION_NOT_ALLOWED_ERROR Field

StringConsts FIELD_OPERATION_NOT_ALLOWED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FIELD_OPERATION_NOT_ALLOWED_ERROR
public const string FIELD_OPERATION_NOT_ALLOWED_ERROR
Public Const FIELD_OPERATION_NOT_ALLOWED_ERROR As String
Public Const FIELD_OPERATION_NOT_ALLOWED_ERROR As String
public:
literal String^ FIELD_OPERATION_NOT_ALLOWED_ERROR
public:
literal String^ FIELD_OPERATION_NOT_ALLOWED_ERROR
static val mutable FIELD_OPERATION_NOT_ALLOWED_ERROR: string
static val mutable FIELD_OPERATION_NOT_ALLOWED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.FIELD_TYPE_MAP_ERROR Field

StringConsts FIELD_TYPE_MAP_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FIELD_TYPE_MAP_ERROR
public const string FIELD_TYPE_MAP_ERROR
Public Const FIELD_TYPE_MAP_ERROR As String
Public Const FIELD_TYPE_MAP_ERROR As String
public:
literal String^ FIELD_TYPE_MAP_ERROR
public:
literal String^ FIELD_TYPE_MAP_ERROR
static val mutable FIELD_TYPE_MAP_ERROR: string
static val mutable FIELD_TYPE_MAP_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.FILE_NOT_FOUND_ERROR Field

StringConsts FILE_NOT_FOUND_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FILE_NOT_FOUND_ERROR
public const string FILE_NOT_FOUND_ERROR
Public Const FILE_NOT_FOUND_ERROR As String
Public Const FILE_NOT_FOUND_ERROR As String
public:
literal String^ FILE_NOT_FOUND_ERROR
public:
literal String^ FILE_NOT_FOUND_ERROR
static val mutable FILE_NOT_FOUND_ERROR: string
static val mutable FILE_NOT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.FINANCIAL_AMOUNT_DIFFERENT_CURRENCIES_ERROR Field

StringConsts FINANCIAL_AMOUNT_DIFFERENT_CURRENCIES_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FINANCIAL_AMOUNT_DIFFERENT_CURRENCIES_ERROR
public const string FINANCIAL_AMOUNT_DIFFERENT_CURRENCIES_ERROR
Public Const FINANCIAL_AMOUNT_DIFFERENT_CURRENCIES_ERROR As String
Public Const FINANCIAL_AMOUNT_DIFFERENT_CURRENCIES_ERROR As String
public:
literal String^ FINANCIAL_AMOUNT_DIFFERENT_CURRENCIES_ERROR
public:
literal String^ FINANCIAL_AMOUNT_DIFFERENT_CURRENCIES_ERROR
static val mutable FINANCIAL_AMOUNT_DIFFERENT_CURRENCIES_ERROR: string
static val mutable FINANCIAL_AMOUNT_DIFFERENT_CURRENCIES_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.FINANCIAL_AMOUNT_PARSE_ERROR Field

StringConsts FINANCIAL_AMOUNT_PARSE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FINANCIAL_AMOUNT_PARSE_ERROR
public const string FINANCIAL_AMOUNT_PARSE_ERROR
Public Const FINANCIAL_AMOUNT_PARSE_ERROR As String
Public Const FINANCIAL_AMOUNT_PARSE_ERROR As String
public:
literal String^ FINANCIAL_AMOUNT_PARSE_ERROR
public:
literal String^ FINANCIAL_AMOUNT_PARSE_ERROR
static val mutable FINANCIAL_AMOUNT_PARSE_ERROR: string
static val mutable FINANCIAL_AMOUNT_PARSE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.FORM_CREATION_ERROR Field

StringConsts FORM_CREATION_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FORM_CREATION_ERROR
public const string FORM_CREATION_ERROR
Public Const FORM_CREATION_ERROR As String
Public Const FORM_CREATION_ERROR As String
public:
literal String^ FORM_CREATION_ERROR
public:
literal String^ FORM_CREATION_ERROR
static val mutable FORM_CREATION_ERROR: string
static val mutable FORM_CREATION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.FORM_FACTORY_NULL_ERROR Field

StringConsts FORM_FACTORY_NULL_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FORM_FACTORY_NULL_ERROR
public const string FORM_FACTORY_NULL_ERROR
Public Const FORM_FACTORY_NULL_ERROR As String
Public Const FORM_FACTORY_NULL_ERROR As String
public:
literal String^ FORM_FACTORY_NULL_ERROR
public:
literal String^ FORM_FACTORY_NULL_ERROR
static val mutable FORM_FACTORY_NULL_ERROR: string
static val mutable FORM_FACTORY_NULL_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.FORM_LOOKUP_COMMAND_ERROR Field

StringConsts FORM_LOOKUP_COMMAND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FORM_LOOKUP_COMMAND_ERROR
public const string FORM_LOOKUP_COMMAND_ERROR
Public Const FORM_LOOKUP_COMMAND_ERROR As String
Public Const FORM_LOOKUP_COMMAND_ERROR As String
public:
literal String^ FORM_LOOKUP_COMMAND_ERROR
public:
literal String^ FORM_LOOKUP_COMMAND_ERROR
static val mutable FORM_LOOKUP_COMMAND_ERROR: string
static val mutable FORM_LOOKUP_COMMAND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.FORMULA_CALCULATED_ANOTHER_FIELD_ERROR Field

StringConsts FORMULA_CALCULATED_ANOTHER_FIELD_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FORMULA_CALCULATED_ANOTHER_FIELD_ERROR
public const string FORMULA_CALCULATED_ANOTHER_FIELD_ERROR
Public Const FORMULA_CALCULATED_ANOTHER_FIELD_ERROR As String
Public Const FORMULA_CALCULATED_ANOTHER_FIELD_ERROR As String
public:
literal String^ FORMULA_CALCULATED_ANOTHER_FIELD_ERROR
public:
literal String^ FORMULA_CALCULATED_ANOTHER_FIELD_ERROR
static val mutable FORMULA_CALCULATED_ANOTHER_FIELD_ERROR: string
static val mutable FORMULA_CALCULATED_ANOTHER_FIELD_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.FS_DUPLICATE_NAME_ERROR Field

StringConsts FS_DUPLICATE_NAME_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FS_DUPLICATE_NAME_ERROR
public const string FS_DUPLICATE_NAME_ERROR
Public Const FS_DUPLICATE_NAME_ERROR As String
Public Const FS_DUPLICATE_NAME_ERROR As String
public:
literal String^ FS_DUPLICATE_NAME_ERROR
public:
literal String^ FS_DUPLICATE_NAME_ERROR
static val mutable FS_DUPLICATE_NAME_ERROR: string
static val mutable FS_DUPLICATE_NAME_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.FS_SESSION_BAD_PARAMS_ERROR Field

StringConsts FS_SESSION_BAD_PARAMS_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FS_SESSION_BAD_PARAMS_ERROR
public const string FS_SESSION_BAD_PARAMS_ERROR
Public Const FS_SESSION_BAD_PARAMS_ERROR As String
Public Const FS_SESSION_BAD_PARAMS_ERROR As String
public:
literal String^ FS_SESSION_BAD_PARAMS_ERROR
public:
literal String^ FS_SESSION_BAD_PARAMS_ERROR
static val mutable FS_SESSION_BAD_PARAMS_ERROR: string
static val mutable FS_SESSION_BAD_PARAMS_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GDID_BUFFER_ERROR Field

StringConsts GDID_BUFFER_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GDID_BUFFER_ERROR
public const string GDID_BUFFER_ERROR
Public Const GDID_BUFFER_ERROR As String
Public Const GDID_BUFFER_ERROR As String
public:
literal String^ GDID_BUFFER_ERROR
public:
literal String^ GDID_BUFFER_ERROR
static val mutable GDID_BUFFER_ERROR: string
static val mutable GDID_BUFFER_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_AMBIGUOUS_CTOR_DCTOR_DEFINITION_ERROR Field

StringConsts GLUE_AMBIGUOUS_CTOR_DCTOR_DEFINITION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_AMBIGUOUS_CTOR_DCTOR_DEFINITION_ERROR
public const string GLUE_AMBIGUOUS_CTOR_DCTOR_DEFINITION_ERROR
Public Const GLUE_AMBIGUOUS_CTOR_DCTOR_DEFINITION_ERROR As String
Public Const GLUE_AMBIGUOUS_CTOR_DCTOR_DEFINITION_ERROR As String
public:
literal String^ GLUE_AMBIGUOUS_CTOR_DCTOR_DEFINITION_ERROR
public:
literal String^ GLUE_AMBIGUOUS_CTOR_DCTOR_DEFINITION_ERROR
static val mutable GLUE_AMBIGUOUS_CTOR_DCTOR_DEFINITION_ERROR: string
static val mutable GLUE_AMBIGUOUS_CTOR_DCTOR_DEFINITION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_ARGS_MARSHALLING_INVALID_REQUEST_MSG_TYPE_ERROR Field

StringConsts GLUE_ARGS_MARSHALLING_INVALID_REQUEST_MSG_TYPE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_ARGS_MARSHALLING_INVALID_REQUEST_MSG_TYPE_ERROR
public const string GLUE_ARGS_MARSHALLING_INVALID_REQUEST_MSG_TYPE_ERROR
Public Const GLUE_ARGS_MARSHALLING_INVALID_REQUEST_MSG_TYPE_ERROR As String
Public Const GLUE_ARGS_MARSHALLING_INVALID_REQUEST_MSG_TYPE_ERROR As String
public:
literal String^ GLUE_ARGS_MARSHALLING_INVALID_REQUEST_MSG_TYPE_ERROR
public:
literal String^ GLUE_ARGS_MARSHALLING_INVALID_REQUEST_MSG_TYPE_ERROR
static val mutable GLUE_ARGS_MARSHALLING_INVALID_REQUEST_MSG_TYPE_ERROR: string
static val mutable GLUE_ARGS_MARSHALLING_INVALID_REQUEST_MSG_TYPE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_BAD_PROTOCOL_CLIENT_SITE_ERROR Field

StringConsts GLUE_BAD_PROTOCOL_CLIENT_SITE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_BAD_PROTOCOL_CLIENT_SITE_ERROR
public const string GLUE_BAD_PROTOCOL_CLIENT_SITE_ERROR
Public Const GLUE_BAD_PROTOCOL_CLIENT_SITE_ERROR As String
Public Const GLUE_BAD_PROTOCOL_CLIENT_SITE_ERROR As String
public:
literal String^ GLUE_BAD_PROTOCOL_CLIENT_SITE_ERROR
public:
literal String^ GLUE_BAD_PROTOCOL_CLIENT_SITE_ERROR
static val mutable GLUE_BAD_PROTOCOL_CLIENT_SITE_ERROR: string
static val mutable GLUE_BAD_PROTOCOL_CLIENT_SITE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_BAD_PROTOCOL_FRAME_ERROR Field

StringConsts GLUE_BAD_PROTOCOL_FRAME_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_BAD_PROTOCOL_FRAME_ERROR
public const string GLUE_BAD_PROTOCOL_FRAME_ERROR
Public Const GLUE_BAD_PROTOCOL_FRAME_ERROR As String
Public Const GLUE_BAD_PROTOCOL_FRAME_ERROR As String
public:
literal String^ GLUE_BAD_PROTOCOL_FRAME_ERROR
public:
literal String^ GLUE_BAD_PROTOCOL_FRAME_ERROR
static val mutable GLUE_BAD_PROTOCOL_FRAME_ERROR: string
static val mutable GLUE_BAD_PROTOCOL_FRAME_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_CALL_SERVICED_BY_DIFFERENT_REACTOR_ERROR Field

StringConsts GLUE_CALL_SERVICED_BY_DIFFERENT_REACTOR_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_CALL_SERVICED_BY_DIFFERENT_REACTOR_ERROR
public const string GLUE_CALL_SERVICED_BY_DIFFERENT_REACTOR_ERROR
Public Const GLUE_CALL_SERVICED_BY_DIFFERENT_REACTOR_ERROR As String
Public Const GLUE_CALL_SERVICED_BY_DIFFERENT_REACTOR_ERROR As String
public:
literal String^ GLUE_CALL_SERVICED_BY_DIFFERENT_REACTOR_ERROR
public:
literal String^ GLUE_CALL_SERVICED_BY_DIFFERENT_REACTOR_ERROR
static val mutable GLUE_CALL_SERVICED_BY_DIFFERENT_REACTOR_ERROR: string
static val mutable GLUE_CALL_SERVICED_BY_DIFFERENT_REACTOR_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_CLIENT_CALL_ERROR Field

StringConsts GLUE_CLIENT_CALL_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_CLIENT_CALL_ERROR
public const string GLUE_CLIENT_CALL_ERROR
Public Const GLUE_CLIENT_CALL_ERROR As String
Public Const GLUE_CLIENT_CALL_ERROR As String
public:
literal String^ GLUE_CLIENT_CALL_ERROR
public:
literal String^ GLUE_CLIENT_CALL_ERROR
static val mutable GLUE_CLIENT_CALL_ERROR: string
static val mutable GLUE_CLIENT_CALL_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_CLIENT_CALL_NO_BINDING_ERROR Field

StringConsts GLUE_CLIENT_CALL_NO_BINDING_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_CLIENT_CALL_NO_BINDING_ERROR
public const string GLUE_CLIENT_CALL_NO_BINDING_ERROR
Public Const GLUE_CLIENT_CALL_NO_BINDING_ERROR As String
Public Const GLUE_CLIENT_CALL_NO_BINDING_ERROR As String
public:
literal String^ GLUE_CLIENT_CALL_NO_BINDING_ERROR
public:
literal String^ GLUE_CLIENT_CALL_NO_BINDING_ERROR
static val mutable GLUE_CLIENT_CALL_NO_BINDING_ERROR: string
static val mutable GLUE_CLIENT_CALL_NO_BINDING_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_CLIENT_CALL_TRANSPORT_ACQUISITION_TIMEOUT_ERROR Field

StringConsts GLUE_CLIENT_CALL_TRANSPORT_ACQUISITION_TIMEOUT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_CLIENT_CALL_TRANSPORT_ACQUISITION_TIMEOUT_ERROR
public const string GLUE_CLIENT_CALL_TRANSPORT_ACQUISITION_TIMEOUT_ERROR
Public Const GLUE_CLIENT_CALL_TRANSPORT_ACQUISITION_TIMEOUT_ERROR As String
Public Const GLUE_CLIENT_CALL_TRANSPORT_ACQUISITION_TIMEOUT_ERROR As String
public:
literal String^ GLUE_CLIENT_CALL_TRANSPORT_ACQUISITION_TIMEOUT_ERROR
public:
literal String^ GLUE_CLIENT_CALL_TRANSPORT_ACQUISITION_TIMEOUT_ERROR
static val mutable GLUE_CLIENT_CALL_TRANSPORT_ACQUISITION_TIMEOUT_ERROR: string
static val mutable GLUE_CLIENT_CALL_TRANSPORT_ACQUISITION_TIMEOUT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_CLIENT_CONNECT_ERROR Field

StringConsts GLUE_CLIENT_CONNECT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_CLIENT_CONNECT_ERROR
public const string GLUE_CLIENT_CONNECT_ERROR
Public Const GLUE_CLIENT_CONNECT_ERROR As String
Public Const GLUE_CLIENT_CONNECT_ERROR As String
public:
literal String^ GLUE_CLIENT_CONNECT_ERROR
public:
literal String^ GLUE_CLIENT_CONNECT_ERROR
static val mutable GLUE_CLIENT_CONNECT_ERROR: string
static val mutable GLUE_CLIENT_CONNECT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_CLIENT_CONNECTION_REPORT Field

StringConsts GLUE_CLIENT_CONNECTION_REPORT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_CLIENT_CONNECTION_REPORT
public const string GLUE_CLIENT_CONNECTION_REPORT
Public Const GLUE_CLIENT_CONNECTION_REPORT As String
Public Const GLUE_CLIENT_CONNECTION_REPORT As String
public:
literal String^ GLUE_CLIENT_CONNECTION_REPORT
public:
literal String^ GLUE_CLIENT_CONNECTION_REPORT
static val mutable GLUE_CLIENT_CONNECTION_REPORT: string
static val mutable GLUE_CLIENT_CONNECTION_REPORT: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_CLIENT_INSPECTORS_THREW_ERROR Field

StringConsts GLUE_CLIENT_INSPECTORS_THREW_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_CLIENT_INSPECTORS_THREW_ERROR
public const string GLUE_CLIENT_INSPECTORS_THREW_ERROR
Public Const GLUE_CLIENT_INSPECTORS_THREW_ERROR As String
Public Const GLUE_CLIENT_INSPECTORS_THREW_ERROR As String
public:
literal String^ GLUE_CLIENT_INSPECTORS_THREW_ERROR
public:
literal String^ GLUE_CLIENT_INSPECTORS_THREW_ERROR
static val mutable GLUE_CLIENT_INSPECTORS_THREW_ERROR: string
static val mutable GLUE_CLIENT_INSPECTORS_THREW_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_CLIENT_THREAD_COMMUNICATION_ERROR Field

StringConsts GLUE_CLIENT_THREAD_COMMUNICATION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_CLIENT_THREAD_COMMUNICATION_ERROR
public const string GLUE_CLIENT_THREAD_COMMUNICATION_ERROR
Public Const GLUE_CLIENT_THREAD_COMMUNICATION_ERROR As String
Public Const GLUE_CLIENT_THREAD_COMMUNICATION_ERROR As String
public:
literal String^ GLUE_CLIENT_THREAD_COMMUNICATION_ERROR
public:
literal String^ GLUE_CLIENT_THREAD_COMMUNICATION_ERROR
static val mutable GLUE_CLIENT_THREAD_COMMUNICATION_ERROR: string
static val mutable GLUE_CLIENT_THREAD_COMMUNICATION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_CLIENT_THREAD_ERROR Field

StringConsts GLUE_CLIENT_THREAD_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_CLIENT_THREAD_ERROR
public const string GLUE_CLIENT_THREAD_ERROR
Public Const GLUE_CLIENT_THREAD_ERROR As String
Public Const GLUE_CLIENT_THREAD_ERROR As String
public:
literal String^ GLUE_CLIENT_THREAD_ERROR
public:
literal String^ GLUE_CLIENT_THREAD_ERROR
static val mutable GLUE_CLIENT_THREAD_ERROR: string
static val mutable GLUE_CLIENT_THREAD_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_DUPLICATE_NAMED_INSTANCE_ERROR Field

StringConsts GLUE_DUPLICATE_NAMED_INSTANCE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_DUPLICATE_NAMED_INSTANCE_ERROR
public const string GLUE_DUPLICATE_NAMED_INSTANCE_ERROR
Public Const GLUE_DUPLICATE_NAMED_INSTANCE_ERROR As String
Public Const GLUE_DUPLICATE_NAMED_INSTANCE_ERROR As String
public:
literal String^ GLUE_DUPLICATE_NAMED_INSTANCE_ERROR
public:
literal String^ GLUE_DUPLICATE_NAMED_INSTANCE_ERROR
static val mutable GLUE_DUPLICATE_NAMED_INSTANCE_ERROR: string
static val mutable GLUE_DUPLICATE_NAMED_INSTANCE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_ENDPOINT_CONTRACT_INTF_MAPPING_ERROR Field

StringConsts GLUE_ENDPOINT_CONTRACT_INTF_MAPPING_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_ENDPOINT_CONTRACT_INTF_MAPPING_ERROR
public const string GLUE_ENDPOINT_CONTRACT_INTF_MAPPING_ERROR
Public Const GLUE_ENDPOINT_CONTRACT_INTF_MAPPING_ERROR As String
Public Const GLUE_ENDPOINT_CONTRACT_INTF_MAPPING_ERROR As String
public:
literal String^ GLUE_ENDPOINT_CONTRACT_INTF_MAPPING_ERROR
public:
literal String^ GLUE_ENDPOINT_CONTRACT_INTF_MAPPING_ERROR
static val mutable GLUE_ENDPOINT_CONTRACT_INTF_MAPPING_ERROR: string
static val mutable GLUE_ENDPOINT_CONTRACT_INTF_MAPPING_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_ENDPOINT_CONTRACT_MANY_SERVERS_WARNING Field

StringConsts GLUE_ENDPOINT_CONTRACT_MANY_SERVERS_WARNING Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_ENDPOINT_CONTRACT_MANY_SERVERS_WARNING
public const string GLUE_ENDPOINT_CONTRACT_MANY_SERVERS_WARNING
Public Const GLUE_ENDPOINT_CONTRACT_MANY_SERVERS_WARNING As String
Public Const GLUE_ENDPOINT_CONTRACT_MANY_SERVERS_WARNING As String
public:
literal String^ GLUE_ENDPOINT_CONTRACT_MANY_SERVERS_WARNING
public:
literal String^ GLUE_ENDPOINT_CONTRACT_MANY_SERVERS_WARNING
static val mutable GLUE_ENDPOINT_CONTRACT_MANY_SERVERS_WARNING: string
static val mutable GLUE_ENDPOINT_CONTRACT_MANY_SERVERS_WARNING: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_ENDPOINT_CONTRACT_NOT_IMPLEMENTED_ERROR Field

StringConsts GLUE_ENDPOINT_CONTRACT_NOT_IMPLEMENTED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_ENDPOINT_CONTRACT_NOT_IMPLEMENTED_ERROR
public const string GLUE_ENDPOINT_CONTRACT_NOT_IMPLEMENTED_ERROR
Public Const GLUE_ENDPOINT_CONTRACT_NOT_IMPLEMENTED_ERROR As String
Public Const GLUE_ENDPOINT_CONTRACT_NOT_IMPLEMENTED_ERROR As String
public:
literal String^ GLUE_ENDPOINT_CONTRACT_NOT_IMPLEMENTED_ERROR
public:
literal String^ GLUE_ENDPOINT_CONTRACT_NOT_IMPLEMENTED_ERROR
static val mutable GLUE_ENDPOINT_CONTRACT_NOT_IMPLEMENTED_ERROR: string
static val mutable GLUE_ENDPOINT_CONTRACT_NOT_IMPLEMENTED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_ENDPOINT_MSPEC_NOT_FOUND_ERROR Field

StringConsts GLUE_ENDPOINT_MSPEC_NOT_FOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_ENDPOINT_MSPEC_NOT_FOUND_ERROR
public const string GLUE_ENDPOINT_MSPEC_NOT_FOUND_ERROR
Public Const GLUE_ENDPOINT_MSPEC_NOT_FOUND_ERROR As String
Public Const GLUE_ENDPOINT_MSPEC_NOT_FOUND_ERROR As String
public:
literal String^ GLUE_ENDPOINT_MSPEC_NOT_FOUND_ERROR
public:
literal String^ GLUE_ENDPOINT_MSPEC_NOT_FOUND_ERROR
static val mutable GLUE_ENDPOINT_MSPEC_NOT_FOUND_ERROR: string
static val mutable GLUE_ENDPOINT_MSPEC_NOT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_LISTENER_EXCEPTION_ERROR Field

StringConsts GLUE_LISTENER_EXCEPTION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_LISTENER_EXCEPTION_ERROR
public const string GLUE_LISTENER_EXCEPTION_ERROR
Public Const GLUE_LISTENER_EXCEPTION_ERROR As String
Public Const GLUE_LISTENER_EXCEPTION_ERROR As String
public:
literal String^ GLUE_LISTENER_EXCEPTION_ERROR
public:
literal String^ GLUE_LISTENER_EXCEPTION_ERROR
static val mutable GLUE_LISTENER_EXCEPTION_ERROR: string
static val mutable GLUE_LISTENER_EXCEPTION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_MAX_MSG_SIZE_EXCEEDED_ERROR Field

StringConsts GLUE_MAX_MSG_SIZE_EXCEEDED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_MAX_MSG_SIZE_EXCEEDED_ERROR
public const string GLUE_MAX_MSG_SIZE_EXCEEDED_ERROR
Public Const GLUE_MAX_MSG_SIZE_EXCEEDED_ERROR As String
Public Const GLUE_MAX_MSG_SIZE_EXCEEDED_ERROR As String
public:
literal String^ GLUE_MAX_MSG_SIZE_EXCEEDED_ERROR
public:
literal String^ GLUE_MAX_MSG_SIZE_EXCEEDED_ERROR
static val mutable GLUE_MAX_MSG_SIZE_EXCEEDED_ERROR: string
static val mutable GLUE_MAX_MSG_SIZE_EXCEEDED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_METHOD_ARGS_MARSHAL_LAMBDA_ERROR Field

StringConsts GLUE_METHOD_ARGS_MARSHAL_LAMBDA_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_METHOD_ARGS_MARSHAL_LAMBDA_ERROR
public const string GLUE_METHOD_ARGS_MARSHAL_LAMBDA_ERROR
Public Const GLUE_METHOD_ARGS_MARSHAL_LAMBDA_ERROR As String
Public Const GLUE_METHOD_ARGS_MARSHAL_LAMBDA_ERROR As String
public:
literal String^ GLUE_METHOD_ARGS_MARSHAL_LAMBDA_ERROR
public:
literal String^ GLUE_METHOD_ARGS_MARSHAL_LAMBDA_ERROR
static val mutable GLUE_METHOD_ARGS_MARSHAL_LAMBDA_ERROR: string
static val mutable GLUE_METHOD_ARGS_MARSHAL_LAMBDA_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_METHOD_SPEC_UNSUPPORTED_ERROR Field

StringConsts GLUE_METHOD_SPEC_UNSUPPORTED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_METHOD_SPEC_UNSUPPORTED_ERROR
public const string GLUE_METHOD_SPEC_UNSUPPORTED_ERROR
Public Const GLUE_METHOD_SPEC_UNSUPPORTED_ERROR As String
Public Const GLUE_METHOD_SPEC_UNSUPPORTED_ERROR As String
public:
literal String^ GLUE_METHOD_SPEC_UNSUPPORTED_ERROR
public:
literal String^ GLUE_METHOD_SPEC_UNSUPPORTED_ERROR
static val mutable GLUE_METHOD_SPEC_UNSUPPORTED_ERROR: string
static val mutable GLUE_METHOD_SPEC_UNSUPPORTED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_MPX_SOCKET_RECEIVE_ACTION_ERROR Field

StringConsts GLUE_MPX_SOCKET_RECEIVE_ACTION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_MPX_SOCKET_RECEIVE_ACTION_ERROR
public const string GLUE_MPX_SOCKET_RECEIVE_ACTION_ERROR
Public Const GLUE_MPX_SOCKET_RECEIVE_ACTION_ERROR As String
Public Const GLUE_MPX_SOCKET_RECEIVE_ACTION_ERROR As String
public:
literal String^ GLUE_MPX_SOCKET_RECEIVE_ACTION_ERROR
public:
literal String^ GLUE_MPX_SOCKET_RECEIVE_ACTION_ERROR
static val mutable GLUE_MPX_SOCKET_RECEIVE_ACTION_ERROR: string
static val mutable GLUE_MPX_SOCKET_RECEIVE_ACTION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_MPX_SOCKET_SEND_CHUNK_ALREADY_GOTTEN_ERROR Field

StringConsts GLUE_MPX_SOCKET_SEND_CHUNK_ALREADY_GOTTEN_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_MPX_SOCKET_SEND_CHUNK_ALREADY_GOTTEN_ERROR
public const string GLUE_MPX_SOCKET_SEND_CHUNK_ALREADY_GOTTEN_ERROR
Public Const GLUE_MPX_SOCKET_SEND_CHUNK_ALREADY_GOTTEN_ERROR As String
Public Const GLUE_MPX_SOCKET_SEND_CHUNK_ALREADY_GOTTEN_ERROR As String
public:
literal String^ GLUE_MPX_SOCKET_SEND_CHUNK_ALREADY_GOTTEN_ERROR
public:
literal String^ GLUE_MPX_SOCKET_SEND_CHUNK_ALREADY_GOTTEN_ERROR
static val mutable GLUE_MPX_SOCKET_SEND_CHUNK_ALREADY_GOTTEN_ERROR: string
static val mutable GLUE_MPX_SOCKET_SEND_CHUNK_ALREADY_GOTTEN_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_MPX_SOCKET_SEND_CLOSED_ERROR Field

StringConsts GLUE_MPX_SOCKET_SEND_CLOSED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_MPX_SOCKET_SEND_CLOSED_ERROR
public const string GLUE_MPX_SOCKET_SEND_CLOSED_ERROR
Public Const GLUE_MPX_SOCKET_SEND_CLOSED_ERROR As String
Public Const GLUE_MPX_SOCKET_SEND_CLOSED_ERROR As String
public:
literal String^ GLUE_MPX_SOCKET_SEND_CLOSED_ERROR
public:
literal String^ GLUE_MPX_SOCKET_SEND_CLOSED_ERROR
static val mutable GLUE_MPX_SOCKET_SEND_CLOSED_ERROR: string
static val mutable GLUE_MPX_SOCKET_SEND_CLOSED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_MSG_DUMP_FAILURE_ERROR Field

StringConsts GLUE_MSG_DUMP_FAILURE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_MSG_DUMP_FAILURE_ERROR
public const string GLUE_MSG_DUMP_FAILURE_ERROR
Public Const GLUE_MSG_DUMP_FAILURE_ERROR As String
Public Const GLUE_MSG_DUMP_FAILURE_ERROR As String
public:
literal String^ GLUE_MSG_DUMP_FAILURE_ERROR
public:
literal String^ GLUE_MSG_DUMP_FAILURE_ERROR
static val mutable GLUE_MSG_DUMP_FAILURE_ERROR: string
static val mutable GLUE_MSG_DUMP_FAILURE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_MSG_DUMP_PATH_INVALID_ERROR Field

StringConsts GLUE_MSG_DUMP_PATH_INVALID_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_MSG_DUMP_PATH_INVALID_ERROR
public const string GLUE_MSG_DUMP_PATH_INVALID_ERROR
Public Const GLUE_MSG_DUMP_PATH_INVALID_ERROR As String
Public Const GLUE_MSG_DUMP_PATH_INVALID_ERROR As String
public:
literal String^ GLUE_MSG_DUMP_PATH_INVALID_ERROR
public:
literal String^ GLUE_MSG_DUMP_PATH_INVALID_ERROR
static val mutable GLUE_MSG_DUMP_PATH_INVALID_ERROR: string
static val mutable GLUE_MSG_DUMP_PATH_INVALID_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_NAMED_BINDING_NOT_FOUND_ERROR Field

StringConsts GLUE_NAMED_BINDING_NOT_FOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_NAMED_BINDING_NOT_FOUND_ERROR
public const string GLUE_NAMED_BINDING_NOT_FOUND_ERROR
Public Const GLUE_NAMED_BINDING_NOT_FOUND_ERROR As String
Public Const GLUE_NAMED_BINDING_NOT_FOUND_ERROR As String
public:
literal String^ GLUE_NAMED_BINDING_NOT_FOUND_ERROR
public:
literal String^ GLUE_NAMED_BINDING_NOT_FOUND_ERROR
static val mutable GLUE_NAMED_BINDING_NOT_FOUND_ERROR: string
static val mutable GLUE_NAMED_BINDING_NOT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_NATIVE_SERIALIZATION_WRONG_ROOT_ERROR Field

StringConsts GLUE_NATIVE_SERIALIZATION_WRONG_ROOT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_NATIVE_SERIALIZATION_WRONG_ROOT_ERROR
public const string GLUE_NATIVE_SERIALIZATION_WRONG_ROOT_ERROR
Public Const GLUE_NATIVE_SERIALIZATION_WRONG_ROOT_ERROR As String
Public Const GLUE_NATIVE_SERIALIZATION_WRONG_ROOT_ERROR As String
public:
literal String^ GLUE_NATIVE_SERIALIZATION_WRONG_ROOT_ERROR
public:
literal String^ GLUE_NATIVE_SERIALIZATION_WRONG_ROOT_ERROR
static val mutable GLUE_NATIVE_SERIALIZATION_WRONG_ROOT_ERROR: string
static val mutable GLUE_NATIVE_SERIALIZATION_WRONG_ROOT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_NATIVE_SERIALIZATION_WRONG_ROOT_TOKEN_IN_STREAM_ERROR Field

StringConsts GLUE_NATIVE_SERIALIZATION_WRONG_ROOT_TOKEN_IN_STREAM_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_NATIVE_SERIALIZATION_WRONG_ROOT_TOKEN_IN_STREAM_ERROR
public const string GLUE_NATIVE_SERIALIZATION_WRONG_ROOT_TOKEN_IN_STREAM_ERROR
Public Const GLUE_NATIVE_SERIALIZATION_WRONG_ROOT_TOKEN_IN_STREAM_ERROR As String
Public Const GLUE_NATIVE_SERIALIZATION_WRONG_ROOT_TOKEN_IN_STREAM_ERROR As String
public:
literal String^ GLUE_NATIVE_SERIALIZATION_WRONG_ROOT_TOKEN_IN_STREAM_ERROR
public:
literal String^ GLUE_NATIVE_SERIALIZATION_WRONG_ROOT_TOKEN_IN_STREAM_ERROR
static val mutable GLUE_NATIVE_SERIALIZATION_WRONG_ROOT_TOKEN_IN_STREAM_ERROR: string
static val mutable GLUE_NATIVE_SERIALIZATION_WRONG_ROOT_TOKEN_IN_STREAM_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_NO_ARGS_MARSHAL_LAMBDA_ERROR Field

StringConsts GLUE_NO_ARGS_MARSHAL_LAMBDA_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_NO_ARGS_MARSHAL_LAMBDA_ERROR
public const string GLUE_NO_ARGS_MARSHAL_LAMBDA_ERROR
Public Const GLUE_NO_ARGS_MARSHAL_LAMBDA_ERROR As String
Public Const GLUE_NO_ARGS_MARSHAL_LAMBDA_ERROR As String
public:
literal String^ GLUE_NO_ARGS_MARSHAL_LAMBDA_ERROR
public:
literal String^ GLUE_NO_ARGS_MARSHAL_LAMBDA_ERROR
static val mutable GLUE_NO_ARGS_MARSHAL_LAMBDA_ERROR: string
static val mutable GLUE_NO_ARGS_MARSHAL_LAMBDA_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_NO_INPROC_MATCHING_SERVER_ENDPOINT_ERROR Field

StringConsts GLUE_NO_INPROC_MATCHING_SERVER_ENDPOINT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_NO_INPROC_MATCHING_SERVER_ENDPOINT_ERROR
public const string GLUE_NO_INPROC_MATCHING_SERVER_ENDPOINT_ERROR
Public Const GLUE_NO_INPROC_MATCHING_SERVER_ENDPOINT_ERROR As String
Public Const GLUE_NO_INPROC_MATCHING_SERVER_ENDPOINT_ERROR As String
public:
literal String^ GLUE_NO_INPROC_MATCHING_SERVER_ENDPOINT_ERROR
public:
literal String^ GLUE_NO_INPROC_MATCHING_SERVER_ENDPOINT_ERROR
static val mutable GLUE_NO_INPROC_MATCHING_SERVER_ENDPOINT_ERROR: string
static val mutable GLUE_NO_INPROC_MATCHING_SERVER_ENDPOINT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_NO_SERVER_INSTANCE_ERROR Field

StringConsts GLUE_NO_SERVER_INSTANCE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_NO_SERVER_INSTANCE_ERROR
public const string GLUE_NO_SERVER_INSTANCE_ERROR
Public Const GLUE_NO_SERVER_INSTANCE_ERROR As String
Public Const GLUE_NO_SERVER_INSTANCE_ERROR As String
public:
literal String^ GLUE_NO_SERVER_INSTANCE_ERROR
public:
literal String^ GLUE_NO_SERVER_INSTANCE_ERROR
static val mutable GLUE_NO_SERVER_INSTANCE_ERROR: string
static val mutable GLUE_NO_SERVER_INSTANCE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_ONE_WAY_RESPONSE_ERROR Field

StringConsts GLUE_ONE_WAY_RESPONSE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_ONE_WAY_RESPONSE_ERROR
public const string GLUE_ONE_WAY_RESPONSE_ERROR
Public Const GLUE_ONE_WAY_RESPONSE_ERROR As String
Public Const GLUE_ONE_WAY_RESPONSE_ERROR As String
public:
literal String^ GLUE_ONE_WAY_RESPONSE_ERROR
public:
literal String^ GLUE_ONE_WAY_RESPONSE_ERROR
static val mutable GLUE_ONE_WAY_RESPONSE_ERROR: string
static val mutable GLUE_ONE_WAY_RESPONSE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_POOL_ITEM_ALLOCATION_ERROR Field

StringConsts GLUE_POOL_ITEM_ALLOCATION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_POOL_ITEM_ALLOCATION_ERROR
public const string GLUE_POOL_ITEM_ALLOCATION_ERROR
Public Const GLUE_POOL_ITEM_ALLOCATION_ERROR As String
Public Const GLUE_POOL_ITEM_ALLOCATION_ERROR As String
public:
literal String^ GLUE_POOL_ITEM_ALLOCATION_ERROR
public:
literal String^ GLUE_POOL_ITEM_ALLOCATION_ERROR
static val mutable GLUE_POOL_ITEM_ALLOCATION_ERROR: string
static val mutable GLUE_POOL_ITEM_ALLOCATION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_SERVER_CONTRACT_METHOD_INVOCATION_ERROR Field

StringConsts GLUE_SERVER_CONTRACT_METHOD_INVOCATION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_SERVER_CONTRACT_METHOD_INVOCATION_ERROR
public const string GLUE_SERVER_CONTRACT_METHOD_INVOCATION_ERROR
Public Const GLUE_SERVER_CONTRACT_METHOD_INVOCATION_ERROR As String
Public Const GLUE_SERVER_CONTRACT_METHOD_INVOCATION_ERROR As String
public:
literal String^ GLUE_SERVER_CONTRACT_METHOD_INVOCATION_ERROR
public:
literal String^ GLUE_SERVER_CONTRACT_METHOD_INVOCATION_ERROR
static val mutable GLUE_SERVER_CONTRACT_METHOD_INVOCATION_ERROR: string
static val mutable GLUE_SERVER_CONTRACT_METHOD_INVOCATION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_SERVER_ENDPOINT_CONTRACT_SERVER_TYPE_ERROR Field

StringConsts GLUE_SERVER_ENDPOINT_CONTRACT_SERVER_TYPE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_SERVER_ENDPOINT_CONTRACT_SERVER_TYPE_ERROR
public const string GLUE_SERVER_ENDPOINT_CONTRACT_SERVER_TYPE_ERROR
Public Const GLUE_SERVER_ENDPOINT_CONTRACT_SERVER_TYPE_ERROR As String
Public Const GLUE_SERVER_ENDPOINT_CONTRACT_SERVER_TYPE_ERROR As String
public:
literal String^ GLUE_SERVER_ENDPOINT_CONTRACT_SERVER_TYPE_ERROR
public:
literal String^ GLUE_SERVER_ENDPOINT_CONTRACT_SERVER_TYPE_ERROR
static val mutable GLUE_SERVER_ENDPOINT_CONTRACT_SERVER_TYPE_ERROR: string
static val mutable GLUE_SERVER_ENDPOINT_CONTRACT_SERVER_TYPE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_SERVER_HANDLER_ERROR Field

StringConsts GLUE_SERVER_HANDLER_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_SERVER_HANDLER_ERROR
public const string GLUE_SERVER_HANDLER_ERROR
Public Const GLUE_SERVER_HANDLER_ERROR As String
Public Const GLUE_SERVER_HANDLER_ERROR As String
public:
literal String^ GLUE_SERVER_HANDLER_ERROR
public:
literal String^ GLUE_SERVER_HANDLER_ERROR
static val mutable GLUE_SERVER_HANDLER_ERROR: string
static val mutable GLUE_SERVER_HANDLER_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_SERVER_INSTANCE_ACTIVATION_ERROR Field

StringConsts GLUE_SERVER_INSTANCE_ACTIVATION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_SERVER_INSTANCE_ACTIVATION_ERROR
public const string GLUE_SERVER_INSTANCE_ACTIVATION_ERROR
Public Const GLUE_SERVER_INSTANCE_ACTIVATION_ERROR As String
Public Const GLUE_SERVER_INSTANCE_ACTIVATION_ERROR As String
public:
literal String^ GLUE_SERVER_INSTANCE_ACTIVATION_ERROR
public:
literal String^ GLUE_SERVER_INSTANCE_ACTIVATION_ERROR
static val mutable GLUE_SERVER_INSTANCE_ACTIVATION_ERROR: string
static val mutable GLUE_SERVER_INSTANCE_ACTIVATION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_SERVER_ONE_WAY_CALL_ERROR Field

StringConsts GLUE_SERVER_ONE_WAY_CALL_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_SERVER_ONE_WAY_CALL_ERROR
public const string GLUE_SERVER_ONE_WAY_CALL_ERROR
Public Const GLUE_SERVER_ONE_WAY_CALL_ERROR As String
Public Const GLUE_SERVER_ONE_WAY_CALL_ERROR As String
public:
literal String^ GLUE_SERVER_ONE_WAY_CALL_ERROR
public:
literal String^ GLUE_SERVER_ONE_WAY_CALL_ERROR
static val mutable GLUE_SERVER_ONE_WAY_CALL_ERROR: string
static val mutable GLUE_SERVER_ONE_WAY_CALL_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_SHUTTING_DOWN_REPORT Field

StringConsts GLUE_SHUTTING_DOWN_REPORT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_SHUTTING_DOWN_REPORT
public const string GLUE_SHUTTING_DOWN_REPORT
Public Const GLUE_SHUTTING_DOWN_REPORT As String
Public Const GLUE_SHUTTING_DOWN_REPORT As String
public:
literal String^ GLUE_SHUTTING_DOWN_REPORT
public:
literal String^ GLUE_SHUTTING_DOWN_REPORT
static val mutable GLUE_SHUTTING_DOWN_REPORT: string
static val mutable GLUE_SHUTTING_DOWN_REPORT: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_STATEFUL_SERVER_INSTANCE_DOES_NOT_EXIST_ERROR Field

StringConsts GLUE_STATEFUL_SERVER_INSTANCE_DOES_NOT_EXIST_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_STATEFUL_SERVER_INSTANCE_DOES_NOT_EXIST_ERROR
public const string GLUE_STATEFUL_SERVER_INSTANCE_DOES_NOT_EXIST_ERROR
Public Const GLUE_STATEFUL_SERVER_INSTANCE_DOES_NOT_EXIST_ERROR As String
Public Const GLUE_STATEFUL_SERVER_INSTANCE_DOES_NOT_EXIST_ERROR As String
public:
literal String^ GLUE_STATEFUL_SERVER_INSTANCE_DOES_NOT_EXIST_ERROR
public:
literal String^ GLUE_STATEFUL_SERVER_INSTANCE_DOES_NOT_EXIST_ERROR
static val mutable GLUE_STATEFUL_SERVER_INSTANCE_DOES_NOT_EXIST_ERROR: string
static val mutable GLUE_STATEFUL_SERVER_INSTANCE_DOES_NOT_EXIST_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_STATEFUL_SERVER_INSTANCE_LOCK_TIMEOUT_ERROR Field

StringConsts GLUE_STATEFUL_SERVER_INSTANCE_LOCK_TIMEOUT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_STATEFUL_SERVER_INSTANCE_LOCK_TIMEOUT_ERROR
public const string GLUE_STATEFUL_SERVER_INSTANCE_LOCK_TIMEOUT_ERROR
Public Const GLUE_STATEFUL_SERVER_INSTANCE_LOCK_TIMEOUT_ERROR As String
Public Const GLUE_STATEFUL_SERVER_INSTANCE_LOCK_TIMEOUT_ERROR As String
public:
literal String^ GLUE_STATEFUL_SERVER_INSTANCE_LOCK_TIMEOUT_ERROR
public:
literal String^ GLUE_STATEFUL_SERVER_INSTANCE_LOCK_TIMEOUT_ERROR
static val mutable GLUE_STATEFUL_SERVER_INSTANCE_LOCK_TIMEOUT_ERROR: string
static val mutable GLUE_STATEFUL_SERVER_INSTANCE_LOCK_TIMEOUT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_SYSTEM_NOT_RUNNING_ERROR Field

StringConsts GLUE_SYSTEM_NOT_RUNNING_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_SYSTEM_NOT_RUNNING_ERROR
public const string GLUE_SYSTEM_NOT_RUNNING_ERROR
Public Const GLUE_SYSTEM_NOT_RUNNING_ERROR As String
Public Const GLUE_SYSTEM_NOT_RUNNING_ERROR As String
public:
literal String^ GLUE_SYSTEM_NOT_RUNNING_ERROR
public:
literal String^ GLUE_SYSTEM_NOT_RUNNING_ERROR
static val mutable GLUE_SYSTEM_NOT_RUNNING_ERROR: string
static val mutable GLUE_SYSTEM_NOT_RUNNING_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_TRANSPORT_CONNECTED_REPORT Field

StringConsts GLUE_TRANSPORT_CONNECTED_REPORT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_TRANSPORT_CONNECTED_REPORT
public const string GLUE_TRANSPORT_CONNECTED_REPORT
Public Const GLUE_TRANSPORT_CONNECTED_REPORT As String
Public Const GLUE_TRANSPORT_CONNECTED_REPORT As String
public:
literal String^ GLUE_TRANSPORT_CONNECTED_REPORT
public:
literal String^ GLUE_TRANSPORT_CONNECTED_REPORT
static val mutable GLUE_TRANSPORT_CONNECTED_REPORT: string
static val mutable GLUE_TRANSPORT_CONNECTED_REPORT: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_TRANSPORT_DISCONNECT_REPORT Field

StringConsts GLUE_TRANSPORT_DISCONNECT_REPORT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_TRANSPORT_DISCONNECT_REPORT
public const string GLUE_TRANSPORT_DISCONNECT_REPORT
Public Const GLUE_TRANSPORT_DISCONNECT_REPORT As String
Public Const GLUE_TRANSPORT_DISCONNECT_REPORT As String
public:
literal String^ GLUE_TRANSPORT_DISCONNECT_REPORT
public:
literal String^ GLUE_TRANSPORT_DISCONNECT_REPORT
static val mutable GLUE_TRANSPORT_DISCONNECT_REPORT: string
static val mutable GLUE_TRANSPORT_DISCONNECT_REPORT: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_TYPE_SPEC_ERROR Field

StringConsts GLUE_TYPE_SPEC_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_TYPE_SPEC_ERROR
public const string GLUE_TYPE_SPEC_ERROR
Public Const GLUE_TYPE_SPEC_ERROR As String
Public Const GLUE_TYPE_SPEC_ERROR As String
public:
literal String^ GLUE_TYPE_SPEC_ERROR
public:
literal String^ GLUE_TYPE_SPEC_ERROR
static val mutable GLUE_TYPE_SPEC_ERROR: string
static val mutable GLUE_TYPE_SPEC_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.GLUE_UNEXPECTED_MSG_ERROR Field

StringConsts GLUE_UNEXPECTED_MSG_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GLUE_UNEXPECTED_MSG_ERROR
public const string GLUE_UNEXPECTED_MSG_ERROR
Public Const GLUE_UNEXPECTED_MSG_ERROR As String
Public Const GLUE_UNEXPECTED_MSG_ERROR As String
public:
literal String^ GLUE_UNEXPECTED_MSG_ERROR
public:
literal String^ GLUE_UNEXPECTED_MSG_ERROR
static val mutable GLUE_UNEXPECTED_MSG_ERROR: string
static val mutable GLUE_UNEXPECTED_MSG_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.HTTP_OPERATION_ERROR Field

StringConsts HTTP_OPERATION_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HTTP_OPERATION_ERROR
public const string HTTP_OPERATION_ERROR
Public Const HTTP_OPERATION_ERROR As String
Public Const HTTP_OPERATION_ERROR As String
public:
literal String^ HTTP_OPERATION_ERROR
public:
literal String^ HTTP_OPERATION_ERROR
static val mutable HTTP_OPERATION_ERROR: string
static val mutable HTTP_OPERATION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.INSTRUMENTATIONSVC_PROVIDER_CONFIG_ERROR Field

StringConsts INSTRUMENTATIONSVC_PROVIDER_CONFIG_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string INSTRUMENTATIONSVC_PROVIDER_CONFIG_ERROR
public const string INSTRUMENTATIONSVC_PROVIDER_CONFIG_ERROR
Public Const INSTRUMENTATIONSVC_PROVIDER_CONFIG_ERROR As String
Public Const INSTRUMENTATIONSVC_PROVIDER_CONFIG_ERROR As String
public:
literal String^ INSTRUMENTATIONSVC_PROVIDER_CONFIG_ERROR
public:
literal String^ INSTRUMENTATIONSVC_PROVIDER_CONFIG_ERROR
static val mutable INSTRUMENTATIONSVC_PROVIDER_CONFIG_ERROR: string
static val mutable INSTRUMENTATIONSVC_PROVIDER_CONFIG_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.INVALID_ARGUMENT_ERROR Field

StringConsts INVALID_ARGUMENT_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string INVALID_ARGUMENT_ERROR
public const string INVALID_ARGUMENT_ERROR
Public Const INVALID_ARGUMENT_ERROR As String
Public Const INVALID_ARGUMENT_ERROR As String
public:
literal String^ INVALID_ARGUMENT_ERROR
public:
literal String^ INVALID_ARGUMENT_ERROR
static val mutable INVALID_ARGUMENT_ERROR: string
static val mutable INVALID_ARGUMENT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.INVALID_EPOINT_ERROR Field

StringConsts INVALID_EPOINT_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string INVALID_EPOINT_ERROR
public const string INVALID_EPOINT_ERROR
Public Const INVALID_EPOINT_ERROR As String
Public Const INVALID_EPOINT_ERROR As String
public:
literal String^ INVALID_EPOINT_ERROR
public:
literal String^ INVALID_EPOINT_ERROR
static val mutable INVALID_EPOINT_ERROR: string
static val mutable INVALID_EPOINT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.INVALID_FIELD_ACCESSOR_ERROR Field

StringConsts INVALID_FIELD_ACCESSOR_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string INVALID_FIELD_ACCESSOR_ERROR
public const string INVALID_FIELD_ACCESSOR_ERROR
Public Const INVALID_FIELD_ACCESSOR_ERROR As String
Public Const INVALID_FIELD_ACCESSOR_ERROR As String
public:
literal String^ INVALID_FIELD_ACCESSOR_ERROR
public:
literal String^ INVALID_FIELD_ACCESSOR_ERROR
static val mutable INVALID_FIELD_ACCESSOR_ERROR: string
static val mutable INVALID_FIELD_ACCESSOR_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.INVALID_IPSTRING_ERROR Field

StringConsts INVALID_IPSTRING_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string INVALID_IPSTRING_ERROR
public const string INVALID_IPSTRING_ERROR
Public Const INVALID_IPSTRING_ERROR As String
Public Const INVALID_IPSTRING_ERROR As String
public:
literal String^ INVALID_IPSTRING_ERROR
public:
literal String^ INVALID_IPSTRING_ERROR
static val mutable INVALID_IPSTRING_ERROR: string
static val mutable INVALID_IPSTRING_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.INVALID_OPERATION_ERROR Field

StringConsts INVALID_OPERATION_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string INVALID_OPERATION_ERROR
public const string INVALID_OPERATION_ERROR
Public Const INVALID_OPERATION_ERROR As String
Public Const INVALID_OPERATION_ERROR As String
public:
literal String^ INVALID_OPERATION_ERROR
public:
literal String^ INVALID_OPERATION_ERROR
static val mutable INVALID_OPERATION_ERROR: string
static val mutable INVALID_OPERATION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.INVALID_RECORD_TYPE_ERROR Field

StringConsts INVALID_RECORD_TYPE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string INVALID_RECORD_TYPE_ERROR
public const string INVALID_RECORD_TYPE_ERROR
Public Const INVALID_RECORD_TYPE_ERROR As String
Public Const INVALID_RECORD_TYPE_ERROR As String
public:
literal String^ INVALID_RECORD_TYPE_ERROR
public:
literal String^ INVALID_RECORD_TYPE_ERROR
static val mutable INVALID_RECORD_TYPE_ERROR: string
static val mutable INVALID_RECORD_TYPE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.INVALID_TIMESPEC_ERROR Field

StringConsts INVALID_TIMESPEC_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string INVALID_TIMESPEC_ERROR
public const string INVALID_TIMESPEC_ERROR
Public Const INVALID_TIMESPEC_ERROR As String
Public Const INVALID_TIMESPEC_ERROR As String
public:
literal String^ INVALID_TIMESPEC_ERROR
public:
literal String^ INVALID_TIMESPEC_ERROR
static val mutable INVALID_TIMESPEC_ERROR: string
static val mutable INVALID_TIMESPEC_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.INVENTORIZATION_ASSEMBLY_LOAD_ERROR Field

StringConsts INVENTORIZATION_ASSEMBLY_LOAD_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string INVENTORIZATION_ASSEMBLY_LOAD_ERROR
public const string INVENTORIZATION_ASSEMBLY_LOAD_ERROR
Public Const INVENTORIZATION_ASSEMBLY_LOAD_ERROR As String
Public Const INVENTORIZATION_ASSEMBLY_LOAD_ERROR As String
public:
literal String^ INVENTORIZATION_ASSEMBLY_LOAD_ERROR
public:
literal String^ INVENTORIZATION_ASSEMBLY_LOAD_ERROR
static val mutable INVENTORIZATION_ASSEMBLY_LOAD_ERROR: string
static val mutable INVENTORIZATION_ASSEMBLY_LOAD_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.INVENTORIZATION_NEED_STRATEGY_ERROR Field

StringConsts INVENTORIZATION_NEED_STRATEGY_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string INVENTORIZATION_NEED_STRATEGY_ERROR
public const string INVENTORIZATION_NEED_STRATEGY_ERROR
Public Const INVENTORIZATION_NEED_STRATEGY_ERROR As String
Public Const INVENTORIZATION_NEED_STRATEGY_ERROR As String
public:
literal String^ INVENTORIZATION_NEED_STRATEGY_ERROR
public:
literal String^ INVENTORIZATION_NEED_STRATEGY_ERROR
static val mutable INVENTORIZATION_NEED_STRATEGY_ERROR: string
static val mutable INVENTORIZATION_NEED_STRATEGY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.IO_FS_ITEM_IS_READONLY_ERROR Field

StringConsts IO_FS_ITEM_IS_READONLY_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string IO_FS_ITEM_IS_READONLY_ERROR
public const string IO_FS_ITEM_IS_READONLY_ERROR
Public Const IO_FS_ITEM_IS_READONLY_ERROR As String
Public Const IO_FS_ITEM_IS_READONLY_ERROR As String
public:
literal String^ IO_FS_ITEM_IS_READONLY_ERROR
public:
literal String^ IO_FS_ITEM_IS_READONLY_ERROR
static val mutable IO_FS_ITEM_IS_READONLY_ERROR: string
static val mutable IO_FS_ITEM_IS_READONLY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.IO_STREAM_NOT_SUPPORTED_ERROR Field

StringConsts IO_STREAM_NOT_SUPPORTED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string IO_STREAM_NOT_SUPPORTED_ERROR
public const string IO_STREAM_NOT_SUPPORTED_ERROR
Public Const IO_STREAM_NOT_SUPPORTED_ERROR As String
Public Const IO_STREAM_NOT_SUPPORTED_ERROR As String
public:
literal String^ IO_STREAM_NOT_SUPPORTED_ERROR
public:
literal String^ IO_STREAM_NOT_SUPPORTED_ERROR
static val mutable IO_STREAM_NOT_SUPPORTED_ERROR: string
static val mutable IO_STREAM_NOT_SUPPORTED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.IO_STREAM_POSITION_ERROR Field

StringConsts IO_STREAM_POSITION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string IO_STREAM_POSITION_ERROR
public const string IO_STREAM_POSITION_ERROR
Public Const IO_STREAM_POSITION_ERROR As String
Public Const IO_STREAM_POSITION_ERROR As String
public:
literal String^ IO_STREAM_POSITION_ERROR
public:
literal String^ IO_STREAM_POSITION_ERROR
static val mutable IO_STREAM_POSITION_ERROR: string
static val mutable IO_STREAM_POSITION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.ITEM_ALREADY_EXISTS_ERROR Field

StringConsts ITEM_ALREADY_EXISTS_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ITEM_ALREADY_EXISTS_ERROR
public const string ITEM_ALREADY_EXISTS_ERROR
Public Const ITEM_ALREADY_EXISTS_ERROR As String
Public Const ITEM_ALREADY_EXISTS_ERROR As String
public:
literal String^ ITEM_ALREADY_EXISTS_ERROR
public:
literal String^ ITEM_ALREADY_EXISTS_ERROR
static val mutable ITEM_ALREADY_EXISTS_ERROR: string
static val mutable ITEM_ALREADY_EXISTS_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.JSON_SERIALIZATION_MAX_NESTING_EXCEEDED_ERROR Field

StringConsts JSON_SERIALIZATION_MAX_NESTING_EXCEEDED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string JSON_SERIALIZATION_MAX_NESTING_EXCEEDED_ERROR
public const string JSON_SERIALIZATION_MAX_NESTING_EXCEEDED_ERROR
Public Const JSON_SERIALIZATION_MAX_NESTING_EXCEEDED_ERROR As String
Public Const JSON_SERIALIZATION_MAX_NESTING_EXCEEDED_ERROR As String
public:
literal String^ JSON_SERIALIZATION_MAX_NESTING_EXCEEDED_ERROR
public:
literal String^ JSON_SERIALIZATION_MAX_NESTING_EXCEEDED_ERROR
static val mutable JSON_SERIALIZATION_MAX_NESTING_EXCEEDED_ERROR: string
static val mutable JSON_SERIALIZATION_MAX_NESTING_EXCEEDED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.LOCAL_INSTALL_INSTALL_SET_PACKAGE_MANIFEST_READ_ERROR Field

StringConsts LOCAL_INSTALL_INSTALL_SET_PACKAGE_MANIFEST_READ_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string LOCAL_INSTALL_INSTALL_SET_PACKAGE_MANIFEST_READ_ERROR
public const string LOCAL_INSTALL_INSTALL_SET_PACKAGE_MANIFEST_READ_ERROR
Public Const LOCAL_INSTALL_INSTALL_SET_PACKAGE_MANIFEST_READ_ERROR As String
Public Const LOCAL_INSTALL_INSTALL_SET_PACKAGE_MANIFEST_READ_ERROR As String
public:
literal String^ LOCAL_INSTALL_INSTALL_SET_PACKAGE_MANIFEST_READ_ERROR
public:
literal String^ LOCAL_INSTALL_INSTALL_SET_PACKAGE_MANIFEST_READ_ERROR
static val mutable LOCAL_INSTALL_INSTALL_SET_PACKAGE_MANIFEST_READ_ERROR: string
static val mutable LOCAL_INSTALL_INSTALL_SET_PACKAGE_MANIFEST_READ_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.LOCAL_INSTALL_INSTALL_SET_PACKAGE_WITHOUT_MANIFEST_ERROR Field

StringConsts LOCAL_INSTALL_INSTALL_SET_PACKAGE_WITHOUT_MANIFEST_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string LOCAL_INSTALL_INSTALL_SET_PACKAGE_WITHOUT_MANIFEST_ERROR
public const string LOCAL_INSTALL_INSTALL_SET_PACKAGE_WITHOUT_MANIFEST_ERROR
Public Const LOCAL_INSTALL_INSTALL_SET_PACKAGE_WITHOUT_MANIFEST_ERROR As String
Public Const LOCAL_INSTALL_INSTALL_SET_PACKAGE_WITHOUT_MANIFEST_ERROR As String
public:
literal String^ LOCAL_INSTALL_INSTALL_SET_PACKAGE_WITHOUT_MANIFEST_ERROR
public:
literal String^ LOCAL_INSTALL_INSTALL_SET_PACKAGE_WITHOUT_MANIFEST_ERROR
static val mutable LOCAL_INSTALL_INSTALL_SET_PACKAGE_WITHOUT_MANIFEST_ERROR: string
static val mutable LOCAL_INSTALL_INSTALL_SET_PACKAGE_WITHOUT_MANIFEST_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.LOCAL_INSTALL_LOCAL_MANIFEST_READ_ERROR Field

StringConsts LOCAL_INSTALL_LOCAL_MANIFEST_READ_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string LOCAL_INSTALL_LOCAL_MANIFEST_READ_ERROR
public const string LOCAL_INSTALL_LOCAL_MANIFEST_READ_ERROR
Public Const LOCAL_INSTALL_LOCAL_MANIFEST_READ_ERROR As String
Public Const LOCAL_INSTALL_LOCAL_MANIFEST_READ_ERROR As String
public:
literal String^ LOCAL_INSTALL_LOCAL_MANIFEST_READ_ERROR
public:
literal String^ LOCAL_INSTALL_LOCAL_MANIFEST_READ_ERROR
static val mutable LOCAL_INSTALL_LOCAL_MANIFEST_READ_ERROR: string
static val mutable LOCAL_INSTALL_LOCAL_MANIFEST_READ_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.LOCAL_INSTALL_NOT_STARTED_INSTALL_PACKAGE_ERROR Field

StringConsts LOCAL_INSTALL_NOT_STARTED_INSTALL_PACKAGE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string LOCAL_INSTALL_NOT_STARTED_INSTALL_PACKAGE_ERROR
public const string LOCAL_INSTALL_NOT_STARTED_INSTALL_PACKAGE_ERROR
Public Const LOCAL_INSTALL_NOT_STARTED_INSTALL_PACKAGE_ERROR As String
Public Const LOCAL_INSTALL_NOT_STARTED_INSTALL_PACKAGE_ERROR As String
public:
literal String^ LOCAL_INSTALL_NOT_STARTED_INSTALL_PACKAGE_ERROR
public:
literal String^ LOCAL_INSTALL_NOT_STARTED_INSTALL_PACKAGE_ERROR
static val mutable LOCAL_INSTALL_NOT_STARTED_INSTALL_PACKAGE_ERROR: string
static val mutable LOCAL_INSTALL_NOT_STARTED_INSTALL_PACKAGE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.LOCAL_INSTALL_PACKAGES_MANIFEST_FILE_NAME_COLLISION_ERROR Field

StringConsts LOCAL_INSTALL_PACKAGES_MANIFEST_FILE_NAME_COLLISION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string LOCAL_INSTALL_PACKAGES_MANIFEST_FILE_NAME_COLLISION_ERROR
public const string LOCAL_INSTALL_PACKAGES_MANIFEST_FILE_NAME_COLLISION_ERROR
Public Const LOCAL_INSTALL_PACKAGES_MANIFEST_FILE_NAME_COLLISION_ERROR As String
Public Const LOCAL_INSTALL_PACKAGES_MANIFEST_FILE_NAME_COLLISION_ERROR As String
public:
literal String^ LOCAL_INSTALL_PACKAGES_MANIFEST_FILE_NAME_COLLISION_ERROR
public:
literal String^ LOCAL_INSTALL_PACKAGES_MANIFEST_FILE_NAME_COLLISION_ERROR
static val mutable LOCAL_INSTALL_PACKAGES_MANIFEST_FILE_NAME_COLLISION_ERROR: string
static val mutable LOCAL_INSTALL_PACKAGES_MANIFEST_FILE_NAME_COLLISION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.LOCAL_INSTALL_ROOT_PATH_NOT_FOUND_ERROR Field

StringConsts LOCAL_INSTALL_ROOT_PATH_NOT_FOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string LOCAL_INSTALL_ROOT_PATH_NOT_FOUND_ERROR
public const string LOCAL_INSTALL_ROOT_PATH_NOT_FOUND_ERROR
Public Const LOCAL_INSTALL_ROOT_PATH_NOT_FOUND_ERROR As String
Public Const LOCAL_INSTALL_ROOT_PATH_NOT_FOUND_ERROR As String
public:
literal String^ LOCAL_INSTALL_ROOT_PATH_NOT_FOUND_ERROR
public:
literal String^ LOCAL_INSTALL_ROOT_PATH_NOT_FOUND_ERROR
static val mutable LOCAL_INSTALL_ROOT_PATH_NOT_FOUND_ERROR: string
static val mutable LOCAL_INSTALL_ROOT_PATH_NOT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.LOGSVC_DESTINATION_EXCEEDS_MAX_PROCESSING_TIME_ERROR Field

StringConsts LOGSVC_DESTINATION_EXCEEDS_MAX_PROCESSING_TIME_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string LOGSVC_DESTINATION_EXCEEDS_MAX_PROCESSING_TIME_ERROR
public const string LOGSVC_DESTINATION_EXCEEDS_MAX_PROCESSING_TIME_ERROR
Public Const LOGSVC_DESTINATION_EXCEEDS_MAX_PROCESSING_TIME_ERROR As String
Public Const LOGSVC_DESTINATION_EXCEEDS_MAX_PROCESSING_TIME_ERROR As String
public:
literal String^ LOGSVC_DESTINATION_EXCEEDS_MAX_PROCESSING_TIME_ERROR
public:
literal String^ LOGSVC_DESTINATION_EXCEEDS_MAX_PROCESSING_TIME_ERROR
static val mutable LOGSVC_DESTINATION_EXCEEDS_MAX_PROCESSING_TIME_ERROR: string
static val mutable LOGSVC_DESTINATION_EXCEEDS_MAX_PROCESSING_TIME_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.LOGSVC_DESTINATION_IS_OFFLINE_ERROR Field

StringConsts LOGSVC_DESTINATION_IS_OFFLINE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string LOGSVC_DESTINATION_IS_OFFLINE_ERROR
public const string LOGSVC_DESTINATION_IS_OFFLINE_ERROR
Public Const LOGSVC_DESTINATION_IS_OFFLINE_ERROR As String
Public Const LOGSVC_DESTINATION_IS_OFFLINE_ERROR As String
public:
literal String^ LOGSVC_DESTINATION_IS_OFFLINE_ERROR
public:
literal String^ LOGSVC_DESTINATION_IS_OFFLINE_ERROR
static val mutable LOGSVC_DESTINATION_IS_OFFLINE_ERROR: string
static val mutable LOGSVC_DESTINATION_IS_OFFLINE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.LOGSVC_DESTINATION_OPEN_ERROR Field

StringConsts LOGSVC_DESTINATION_OPEN_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string LOGSVC_DESTINATION_OPEN_ERROR
public const string LOGSVC_DESTINATION_OPEN_ERROR
Public Const LOGSVC_DESTINATION_OPEN_ERROR As String
Public Const LOGSVC_DESTINATION_OPEN_ERROR As String
public:
literal String^ LOGSVC_DESTINATION_OPEN_ERROR
public:
literal String^ LOGSVC_DESTINATION_OPEN_ERROR
static val mutable LOGSVC_DESTINATION_OPEN_ERROR: string
static val mutable LOGSVC_DESTINATION_OPEN_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.LOGSVC_FAILOVER_MSG_TEXT Field

StringConsts LOGSVC_FAILOVER_MSG_TEXT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string LOGSVC_FAILOVER_MSG_TEXT
public const string LOGSVC_FAILOVER_MSG_TEXT
Public Const LOGSVC_FAILOVER_MSG_TEXT As String
Public Const LOGSVC_FAILOVER_MSG_TEXT As String
public:
literal String^ LOGSVC_FAILOVER_MSG_TEXT
public:
literal String^ LOGSVC_FAILOVER_MSG_TEXT
static val mutable LOGSVC_FAILOVER_MSG_TEXT: string
static val mutable LOGSVC_FAILOVER_MSG_TEXT: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.LOGSVC_FILE_DESTINATION_FILENAME_ERROR Field

StringConsts LOGSVC_FILE_DESTINATION_FILENAME_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string LOGSVC_FILE_DESTINATION_FILENAME_ERROR
public const string LOGSVC_FILE_DESTINATION_FILENAME_ERROR
Public Const LOGSVC_FILE_DESTINATION_FILENAME_ERROR As String
Public Const LOGSVC_FILE_DESTINATION_FILENAME_ERROR As String
public:
literal String^ LOGSVC_FILE_DESTINATION_FILENAME_ERROR
public:
literal String^ LOGSVC_FILE_DESTINATION_FILENAME_ERROR
static val mutable LOGSVC_FILE_DESTINATION_FILENAME_ERROR: string
static val mutable LOGSVC_FILE_DESTINATION_FILENAME_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.LOGSVC_NODESTINATIONS_ERROR Field

StringConsts LOGSVC_NODESTINATIONS_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string LOGSVC_NODESTINATIONS_ERROR
public const string LOGSVC_NODESTINATIONS_ERROR
Public Const LOGSVC_NODESTINATIONS_ERROR As String
Public Const LOGSVC_NODESTINATIONS_ERROR As String
public:
literal String^ LOGSVC_NODESTINATIONS_ERROR
public:
literal String^ LOGSVC_NODESTINATIONS_ERROR
static val mutable LOGSVC_NODESTINATIONS_ERROR: string
static val mutable LOGSVC_NODESTINATIONS_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.LOOKUP_COMMAND_ERROR Field

StringConsts LOOKUP_COMMAND_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string LOOKUP_COMMAND_ERROR
public const string LOOKUP_COMMAND_ERROR
Public Const LOOKUP_COMMAND_ERROR As String
Public Const LOOKUP_COMMAND_ERROR As String
public:
literal String^ LOOKUP_COMMAND_ERROR
public:
literal String^ LOOKUP_COMMAND_ERROR
static val mutable LOOKUP_COMMAND_ERROR: string
static val mutable LOOKUP_COMMAND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.LOOKUP_DICTIONARY_FIELD_ERROR Field

StringConsts LOOKUP_DICTIONARY_FIELD_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string LOOKUP_DICTIONARY_FIELD_ERROR
public const string LOOKUP_DICTIONARY_FIELD_ERROR
Public Const LOOKUP_DICTIONARY_FIELD_ERROR As String
Public Const LOOKUP_DICTIONARY_FIELD_ERROR As String
public:
literal String^ LOOKUP_DICTIONARY_FIELD_ERROR
public:
literal String^ LOOKUP_DICTIONARY_FIELD_ERROR
static val mutable LOOKUP_DICTIONARY_FIELD_ERROR: string
static val mutable LOOKUP_DICTIONARY_FIELD_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.METHOD_INVOCATION_CHANGE_ERROR Field

StringConsts METHOD_INVOCATION_CHANGE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string METHOD_INVOCATION_CHANGE_ERROR
public const string METHOD_INVOCATION_CHANGE_ERROR
Public Const METHOD_INVOCATION_CHANGE_ERROR As String
Public Const METHOD_INVOCATION_CHANGE_ERROR As String
public:
literal String^ METHOD_INVOCATION_CHANGE_ERROR
public:
literal String^ METHOD_INVOCATION_CHANGE_ERROR
static val mutable METHOD_INVOCATION_CHANGE_ERROR: string
static val mutable METHOD_INVOCATION_CHANGE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.MINMAX_FIELD_ERROR Field

StringConsts MINMAX_FIELD_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MINMAX_FIELD_ERROR
public const string MINMAX_FIELD_ERROR
Public Const MINMAX_FIELD_ERROR As String
Public Const MINMAX_FIELD_ERROR As String
public:
literal String^ MINMAX_FIELD_ERROR
public:
literal String^ MINMAX_FIELD_ERROR
static val mutable MINMAX_FIELD_ERROR: string
static val mutable MINMAX_FIELD_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.MODEL_METHOD_ERROR Field

StringConsts MODEL_METHOD_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MODEL_METHOD_ERROR
public const string MODEL_METHOD_ERROR
Public Const MODEL_METHOD_ERROR As String
Public Const MODEL_METHOD_ERROR As String
public:
literal String^ MODEL_METHOD_ERROR
public:
literal String^ MODEL_METHOD_ERROR
static val mutable MODEL_METHOD_ERROR: string
static val mutable MODEL_METHOD_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.MODEL_METHOD_NOT_FOUND_ERROR Field

StringConsts MODEL_METHOD_NOT_FOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MODEL_METHOD_NOT_FOUND_ERROR
public const string MODEL_METHOD_NOT_FOUND_ERROR
Public Const MODEL_METHOD_NOT_FOUND_ERROR As String
Public Const MODEL_METHOD_NOT_FOUND_ERROR As String
public:
literal String^ MODEL_METHOD_NOT_FOUND_ERROR
public:
literal String^ MODEL_METHOD_NOT_FOUND_ERROR
static val mutable MODEL_METHOD_NOT_FOUND_ERROR: string
static val mutable MODEL_METHOD_NOT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.MODEL_OPERATION_NOT_ALLOWED_ERROR Field

StringConsts MODEL_OPERATION_NOT_ALLOWED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MODEL_OPERATION_NOT_ALLOWED_ERROR
public const string MODEL_OPERATION_NOT_ALLOWED_ERROR
Public Const MODEL_OPERATION_NOT_ALLOWED_ERROR As String
Public Const MODEL_OPERATION_NOT_ALLOWED_ERROR As String
public:
literal String^ MODEL_OPERATION_NOT_ALLOWED_ERROR
public:
literal String^ MODEL_OPERATION_NOT_ALLOWED_ERROR
static val mutable MODEL_OPERATION_NOT_ALLOWED_ERROR: string
static val mutable MODEL_OPERATION_NOT_ALLOWED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.NETGATE_CONFIG_DUPLICATE_ENTITY_ERROR Field

StringConsts NETGATE_CONFIG_DUPLICATE_ENTITY_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string NETGATE_CONFIG_DUPLICATE_ENTITY_ERROR
public const string NETGATE_CONFIG_DUPLICATE_ENTITY_ERROR
Public Const NETGATE_CONFIG_DUPLICATE_ENTITY_ERROR As String
Public Const NETGATE_CONFIG_DUPLICATE_ENTITY_ERROR As String
public:
literal String^ NETGATE_CONFIG_DUPLICATE_ENTITY_ERROR
public:
literal String^ NETGATE_CONFIG_DUPLICATE_ENTITY_ERROR
static val mutable NETGATE_CONFIG_DUPLICATE_ENTITY_ERROR: string
static val mutable NETGATE_CONFIG_DUPLICATE_ENTITY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.NETGATE_VARDEF_NAME_EMPTY_CTOR_ERROR Field

StringConsts NETGATE_VARDEF_NAME_EMPTY_CTOR_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string NETGATE_VARDEF_NAME_EMPTY_CTOR_ERROR
public const string NETGATE_VARDEF_NAME_EMPTY_CTOR_ERROR
Public Const NETGATE_VARDEF_NAME_EMPTY_CTOR_ERROR As String
Public Const NETGATE_VARDEF_NAME_EMPTY_CTOR_ERROR As String
public:
literal String^ NETGATE_VARDEF_NAME_EMPTY_CTOR_ERROR
public:
literal String^ NETGATE_VARDEF_NAME_EMPTY_CTOR_ERROR
static val mutable NETGATE_VARDEF_NAME_EMPTY_CTOR_ERROR: string
static val mutable NETGATE_VARDEF_NAME_EMPTY_CTOR_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.NOT_APPROPRIATE_STATE_FOR_DELETE_ERROR Field

StringConsts NOT_APPROPRIATE_STATE_FOR_DELETE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string NOT_APPROPRIATE_STATE_FOR_DELETE_ERROR
public const string NOT_APPROPRIATE_STATE_FOR_DELETE_ERROR
Public Const NOT_APPROPRIATE_STATE_FOR_DELETE_ERROR As String
Public Const NOT_APPROPRIATE_STATE_FOR_DELETE_ERROR As String
public:
literal String^ NOT_APPROPRIATE_STATE_FOR_DELETE_ERROR
public:
literal String^ NOT_APPROPRIATE_STATE_FOR_DELETE_ERROR
static val mutable NOT_APPROPRIATE_STATE_FOR_DELETE_ERROR: string
static val mutable NOT_APPROPRIATE_STATE_FOR_DELETE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.NOT_APPROPRIATE_STATE_FOR_SAVE_ERROR Field

StringConsts NOT_APPROPRIATE_STATE_FOR_SAVE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string NOT_APPROPRIATE_STATE_FOR_SAVE_ERROR
public const string NOT_APPROPRIATE_STATE_FOR_SAVE_ERROR
Public Const NOT_APPROPRIATE_STATE_FOR_SAVE_ERROR As String
Public Const NOT_APPROPRIATE_STATE_FOR_SAVE_ERROR As String
public:
literal String^ NOT_APPROPRIATE_STATE_FOR_SAVE_ERROR
public:
literal String^ NOT_APPROPRIATE_STATE_FOR_SAVE_ERROR
static val mutable NOT_APPROPRIATE_STATE_FOR_SAVE_ERROR: string
static val mutable NOT_APPROPRIATE_STATE_FOR_SAVE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.NOT_CREATE_EDIT_STATE_ERROR Field

StringConsts NOT_CREATE_EDIT_STATE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string NOT_CREATE_EDIT_STATE_ERROR
public const string NOT_CREATE_EDIT_STATE_ERROR
Public Const NOT_CREATE_EDIT_STATE_ERROR As String
Public Const NOT_CREATE_EDIT_STATE_ERROR As String
public:
literal String^ NOT_CREATE_EDIT_STATE_ERROR
public:
literal String^ NOT_CREATE_EDIT_STATE_ERROR
static val mutable NOT_CREATE_EDIT_STATE_ERROR: string
static val mutable NOT_CREATE_EDIT_STATE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.NOT_EDIT_STATE_ERROR Field

StringConsts NOT_EDIT_STATE_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string NOT_EDIT_STATE_ERROR
public const string NOT_EDIT_STATE_ERROR
Public Const NOT_EDIT_STATE_ERROR As String
Public Const NOT_EDIT_STATE_ERROR As String
public:
literal String^ NOT_EDIT_STATE_ERROR
public:
literal String^ NOT_EDIT_STATE_ERROR
static val mutable NOT_EDIT_STATE_ERROR: string
static val mutable NOT_EDIT_STATE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.NOT_LOADING_STATE_ERROR Field

StringConsts NOT_LOADING_STATE_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string NOT_LOADING_STATE_ERROR
public const string NOT_LOADING_STATE_ERROR
Public Const NOT_LOADING_STATE_ERROR As String
Public Const NOT_LOADING_STATE_ERROR As String
public:
literal String^ NOT_LOADING_STATE_ERROR
public:
literal String^ NOT_LOADING_STATE_ERROR
static val mutable NOT_LOADING_STATE_ERROR: string
static val mutable NOT_LOADING_STATE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.NOT_UNINIT_VIEW_STATE_ERROR Field

StringConsts NOT_UNINIT_VIEW_STATE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string NOT_UNINIT_VIEW_STATE_ERROR
public const string NOT_UNINIT_VIEW_STATE_ERROR
Public Const NOT_UNINIT_VIEW_STATE_ERROR As String
Public Const NOT_UNINIT_VIEW_STATE_ERROR As String
public:
literal String^ NOT_UNINIT_VIEW_STATE_ERROR
public:
literal String^ NOT_UNINIT_VIEW_STATE_ERROR
static val mutable NOT_UNINIT_VIEW_STATE_ERROR: string
static val mutable NOT_UNINIT_VIEW_STATE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.NOT_VALID_ON_LOAD_ERROR Field

StringConsts NOT_VALID_ON_LOAD_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string NOT_VALID_ON_LOAD_ERROR
public const string NOT_VALID_ON_LOAD_ERROR
Public Const NOT_VALID_ON_LOAD_ERROR As String
Public Const NOT_VALID_ON_LOAD_ERROR As String
public:
literal String^ NOT_VALID_ON_LOAD_ERROR
public:
literal String^ NOT_VALID_ON_LOAD_ERROR
static val mutable NOT_VALID_ON_LOAD_ERROR: string
static val mutable NOT_VALID_ON_LOAD_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.NOT_VALID_ON_POST_ERROR Field

StringConsts NOT_VALID_ON_POST_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string NOT_VALID_ON_POST_ERROR
public const string NOT_VALID_ON_POST_ERROR
Public Const NOT_VALID_ON_POST_ERROR As String
Public Const NOT_VALID_ON_POST_ERROR As String
public:
literal String^ NOT_VALID_ON_POST_ERROR
public:
literal String^ NOT_VALID_ON_POST_ERROR
static val mutable NOT_VALID_ON_POST_ERROR: string
static val mutable NOT_VALID_ON_POST_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.NULL_STRING Field

StringConsts NULL_STRING Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string NULL_STRING
public const string NULL_STRING
Public Const NULL_STRING As String
Public Const NULL_STRING As String
public:
literal String^ NULL_STRING
public:
literal String^ NULL_STRING
static val mutable NULL_STRING: string
static val mutable NULL_STRING: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.OBJECT_DISPOSED_ERROR Field

StringConsts OBJECT_DISPOSED_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string OBJECT_DISPOSED_ERROR
public const string OBJECT_DISPOSED_ERROR
Public Const OBJECT_DISPOSED_ERROR As String
Public Const OBJECT_DISPOSED_ERROR As String
public:
literal String^ OBJECT_DISPOSED_ERROR
public:
literal String^ OBJECT_DISPOSED_ERROR
static val mutable OBJECT_DISPOSED_ERROR: string
static val mutable OBJECT_DISPOSED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.OBJSTORESVC_PROVIDER_CONFIG_ERROR Field

StringConsts OBJSTORESVC_PROVIDER_CONFIG_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string OBJSTORESVC_PROVIDER_CONFIG_ERROR
public const string OBJSTORESVC_PROVIDER_CONFIG_ERROR
Public Const OBJSTORESVC_PROVIDER_CONFIG_ERROR As String
Public Const OBJSTORESVC_PROVIDER_CONFIG_ERROR As String
public:
literal String^ OBJSTORESVC_PROVIDER_CONFIG_ERROR
public:
literal String^ OBJSTORESVC_PROVIDER_CONFIG_ERROR
static val mutable OBJSTORESVC_PROVIDER_CONFIG_ERROR: string
static val mutable OBJSTORESVC_PROVIDER_CONFIG_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.OPERATION_NOT_SUPPORTED_ERROR Field

StringConsts OPERATION_NOT_SUPPORTED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string OPERATION_NOT_SUPPORTED_ERROR
public const string OPERATION_NOT_SUPPORTED_ERROR
Public Const OPERATION_NOT_SUPPORTED_ERROR As String
Public Const OPERATION_NOT_SUPPORTED_ERROR As String
public:
literal String^ OPERATION_NOT_SUPPORTED_ERROR
public:
literal String^ OPERATION_NOT_SUPPORTED_ERROR
static val mutable OPERATION_NOT_SUPPORTED_ERROR: string
static val mutable OPERATION_NOT_SUPPORTED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.OWNER_BINDING_ERROR Field

StringConsts OWNER_BINDING_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string OWNER_BINDING_ERROR
public const string OWNER_BINDING_ERROR
Public Const OWNER_BINDING_ERROR As String
Public Const OWNER_BINDING_ERROR As String
public:
literal String^ OWNER_BINDING_ERROR
public:
literal String^ OWNER_BINDING_ERROR
static val mutable OWNER_BINDING_ERROR: string
static val mutable OWNER_BINDING_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.PARAMETER_MAY_NOT_BE_NULL_ERROR Field

StringConsts PARAMETER_MAY_NOT_BE_NULL_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PARAMETER_MAY_NOT_BE_NULL_ERROR
public const string PARAMETER_MAY_NOT_BE_NULL_ERROR
Public Const PARAMETER_MAY_NOT_BE_NULL_ERROR As String
Public Const PARAMETER_MAY_NOT_BE_NULL_ERROR As String
public:
literal String^ PARAMETER_MAY_NOT_BE_NULL_ERROR
public:
literal String^ PARAMETER_MAY_NOT_BE_NULL_ERROR
static val mutable PARAMETER_MAY_NOT_BE_NULL_ERROR: string
static val mutable PARAMETER_MAY_NOT_BE_NULL_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.PDF_COLOR_DOESNOTEXIST_ERROR Field

StringConsts PDF_COLOR_DOESNOTEXIST_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PDF_COLOR_DOESNOTEXIST_ERROR
public const string PDF_COLOR_DOESNOTEXIST_ERROR
Public Const PDF_COLOR_DOESNOTEXIST_ERROR As String
Public Const PDF_COLOR_DOESNOTEXIST_ERROR As String
public:
literal String^ PDF_COLOR_DOESNOTEXIST_ERROR
public:
literal String^ PDF_COLOR_DOESNOTEXIST_ERROR
static val mutable PDF_COLOR_DOESNOTEXIST_ERROR: string
static val mutable PDF_COLOR_DOESNOTEXIST_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.PDF_COLOR_INCONSISTENCY_ERROR Field

StringConsts PDF_COLOR_INCONSISTENCY_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PDF_COLOR_INCONSISTENCY_ERROR
public const string PDF_COLOR_INCONSISTENCY_ERROR
Public Const PDF_COLOR_INCONSISTENCY_ERROR As String
Public Const PDF_COLOR_INCONSISTENCY_ERROR As String
public:
literal String^ PDF_COLOR_INCONSISTENCY_ERROR
public:
literal String^ PDF_COLOR_INCONSISTENCY_ERROR
static val mutable PDF_COLOR_INCONSISTENCY_ERROR: string
static val mutable PDF_COLOR_INCONSISTENCY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.PDF_UNIT_DOESNOTEXIST_ERROR Field

StringConsts PDF_UNIT_DOESNOTEXIST_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PDF_UNIT_DOESNOTEXIST_ERROR
public const string PDF_UNIT_DOESNOTEXIST_ERROR
Public Const PDF_UNIT_DOESNOTEXIST_ERROR As String
Public Const PDF_UNIT_DOESNOTEXIST_ERROR As String
public:
literal String^ PDF_UNIT_DOESNOTEXIST_ERROR
public:
literal String^ PDF_UNIT_DOESNOTEXIST_ERROR
static val mutable PDF_UNIT_DOESNOTEXIST_ERROR: string
static val mutable PDF_UNIT_DOESNOTEXIST_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.PDF_UNIT_INCONSISTENCY_ERROR Field

StringConsts PDF_UNIT_INCONSISTENCY_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PDF_UNIT_INCONSISTENCY_ERROR
public const string PDF_UNIT_INCONSISTENCY_ERROR
Public Const PDF_UNIT_INCONSISTENCY_ERROR As String
Public Const PDF_UNIT_INCONSISTENCY_ERROR As String
public:
literal String^ PDF_UNIT_INCONSISTENCY_ERROR
public:
literal String^ PDF_UNIT_INCONSISTENCY_ERROR
static val mutable PDF_UNIT_INCONSISTENCY_ERROR: string
static val mutable PDF_UNIT_INCONSISTENCY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.PILE_AV_BAD_ADDR_CHUNK_FLAG_ERROR Field

StringConsts PILE_AV_BAD_ADDR_CHUNK_FLAG_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PILE_AV_BAD_ADDR_CHUNK_FLAG_ERROR
public const string PILE_AV_BAD_ADDR_CHUNK_FLAG_ERROR
Public Const PILE_AV_BAD_ADDR_CHUNK_FLAG_ERROR As String
Public Const PILE_AV_BAD_ADDR_CHUNK_FLAG_ERROR As String
public:
literal String^ PILE_AV_BAD_ADDR_CHUNK_FLAG_ERROR
public:
literal String^ PILE_AV_BAD_ADDR_CHUNK_FLAG_ERROR
static val mutable PILE_AV_BAD_ADDR_CHUNK_FLAG_ERROR: string
static val mutable PILE_AV_BAD_ADDR_CHUNK_FLAG_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.PILE_AV_BAD_ADDR_EOF_ERROR Field

StringConsts PILE_AV_BAD_ADDR_EOF_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PILE_AV_BAD_ADDR_EOF_ERROR
public const string PILE_AV_BAD_ADDR_EOF_ERROR
Public Const PILE_AV_BAD_ADDR_EOF_ERROR As String
Public Const PILE_AV_BAD_ADDR_EOF_ERROR As String
public:
literal String^ PILE_AV_BAD_ADDR_EOF_ERROR
public:
literal String^ PILE_AV_BAD_ADDR_EOF_ERROR
static val mutable PILE_AV_BAD_ADDR_EOF_ERROR: string
static val mutable PILE_AV_BAD_ADDR_EOF_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.PILE_AV_BAD_ADDR_PAYLOAD_SIZE_ERROR Field

StringConsts PILE_AV_BAD_ADDR_PAYLOAD_SIZE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PILE_AV_BAD_ADDR_PAYLOAD_SIZE_ERROR
public const string PILE_AV_BAD_ADDR_PAYLOAD_SIZE_ERROR
Public Const PILE_AV_BAD_ADDR_PAYLOAD_SIZE_ERROR As String
Public Const PILE_AV_BAD_ADDR_PAYLOAD_SIZE_ERROR As String
public:
literal String^ PILE_AV_BAD_ADDR_PAYLOAD_SIZE_ERROR
public:
literal String^ PILE_AV_BAD_ADDR_PAYLOAD_SIZE_ERROR
static val mutable PILE_AV_BAD_ADDR_PAYLOAD_SIZE_ERROR: string
static val mutable PILE_AV_BAD_ADDR_PAYLOAD_SIZE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.PILE_AV_BAD_SEGMENT_ERROR Field

StringConsts PILE_AV_BAD_SEGMENT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PILE_AV_BAD_SEGMENT_ERROR
public const string PILE_AV_BAD_SEGMENT_ERROR
Public Const PILE_AV_BAD_SEGMENT_ERROR As String
Public Const PILE_AV_BAD_SEGMENT_ERROR As String
public:
literal String^ PILE_AV_BAD_SEGMENT_ERROR
public:
literal String^ PILE_AV_BAD_SEGMENT_ERROR
static val mutable PILE_AV_BAD_SEGMENT_ERROR: string
static val mutable PILE_AV_BAD_SEGMENT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.PILE_CACHE_SCV_START_PILE_NOT_STARTED_ERROR Field

StringConsts PILE_CACHE_SCV_START_PILE_NOT_STARTED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PILE_CACHE_SCV_START_PILE_NOT_STARTED_ERROR
public const string PILE_CACHE_SCV_START_PILE_NOT_STARTED_ERROR
Public Const PILE_CACHE_SCV_START_PILE_NOT_STARTED_ERROR As String
Public Const PILE_CACHE_SCV_START_PILE_NOT_STARTED_ERROR As String
public:
literal String^ PILE_CACHE_SCV_START_PILE_NOT_STARTED_ERROR
public:
literal String^ PILE_CACHE_SCV_START_PILE_NOT_STARTED_ERROR
static val mutable PILE_CACHE_SCV_START_PILE_NOT_STARTED_ERROR: string
static val mutable PILE_CACHE_SCV_START_PILE_NOT_STARTED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.PILE_CACHE_SCV_START_PILE_NULL_ERROR Field

StringConsts PILE_CACHE_SCV_START_PILE_NULL_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PILE_CACHE_SCV_START_PILE_NULL_ERROR
public const string PILE_CACHE_SCV_START_PILE_NULL_ERROR
Public Const PILE_CACHE_SCV_START_PILE_NULL_ERROR As String
Public Const PILE_CACHE_SCV_START_PILE_NULL_ERROR As String
public:
literal String^ PILE_CACHE_SCV_START_PILE_NULL_ERROR
public:
literal String^ PILE_CACHE_SCV_START_PILE_NULL_ERROR
static val mutable PILE_CACHE_SCV_START_PILE_NULL_ERROR: string
static val mutable PILE_CACHE_SCV_START_PILE_NULL_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.PILE_CACHE_TBL_DOES_NOT_EXIST_ERROR Field

StringConsts PILE_CACHE_TBL_DOES_NOT_EXIST_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PILE_CACHE_TBL_DOES_NOT_EXIST_ERROR
public const string PILE_CACHE_TBL_DOES_NOT_EXIST_ERROR
Public Const PILE_CACHE_TBL_DOES_NOT_EXIST_ERROR As String
Public Const PILE_CACHE_TBL_DOES_NOT_EXIST_ERROR As String
public:
literal String^ PILE_CACHE_TBL_DOES_NOT_EXIST_ERROR
public:
literal String^ PILE_CACHE_TBL_DOES_NOT_EXIST_ERROR
static val mutable PILE_CACHE_TBL_DOES_NOT_EXIST_ERROR: string
static val mutable PILE_CACHE_TBL_DOES_NOT_EXIST_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.PILE_CACHE_TBL_KEYCOMPARER_MISMATCH_ERROR Field

StringConsts PILE_CACHE_TBL_KEYCOMPARER_MISMATCH_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PILE_CACHE_TBL_KEYCOMPARER_MISMATCH_ERROR
public const string PILE_CACHE_TBL_KEYCOMPARER_MISMATCH_ERROR
Public Const PILE_CACHE_TBL_KEYCOMPARER_MISMATCH_ERROR As String
Public Const PILE_CACHE_TBL_KEYCOMPARER_MISMATCH_ERROR As String
public:
literal String^ PILE_CACHE_TBL_KEYCOMPARER_MISMATCH_ERROR
public:
literal String^ PILE_CACHE_TBL_KEYCOMPARER_MISMATCH_ERROR
static val mutable PILE_CACHE_TBL_KEYCOMPARER_MISMATCH_ERROR: string
static val mutable PILE_CACHE_TBL_KEYCOMPARER_MISMATCH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.PILE_CACHE_TBL_KEYTYPE_MISMATCH_ERROR Field

StringConsts PILE_CACHE_TBL_KEYTYPE_MISMATCH_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PILE_CACHE_TBL_KEYTYPE_MISMATCH_ERROR
public const string PILE_CACHE_TBL_KEYTYPE_MISMATCH_ERROR
Public Const PILE_CACHE_TBL_KEYTYPE_MISMATCH_ERROR As String
Public Const PILE_CACHE_TBL_KEYTYPE_MISMATCH_ERROR As String
public:
literal String^ PILE_CACHE_TBL_KEYTYPE_MISMATCH_ERROR
public:
literal String^ PILE_CACHE_TBL_KEYTYPE_MISMATCH_ERROR
static val mutable PILE_CACHE_TBL_KEYTYPE_MISMATCH_ERROR: string
static val mutable PILE_CACHE_TBL_KEYTYPE_MISMATCH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.PILE_CHUNK_SZ_ERROR Field

StringConsts PILE_CHUNK_SZ_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PILE_CHUNK_SZ_ERROR
public const string PILE_CHUNK_SZ_ERROR
Public Const PILE_CHUNK_SZ_ERROR As String
Public Const PILE_CHUNK_SZ_ERROR As String
public:
literal String^ PILE_CHUNK_SZ_ERROR
public:
literal String^ PILE_CHUNK_SZ_ERROR
static val mutable PILE_CHUNK_SZ_ERROR: string
static val mutable PILE_CHUNK_SZ_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.PILE_CONFIG_PROPERTY_ERROR Field

StringConsts PILE_CONFIG_PROPERTY_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PILE_CONFIG_PROPERTY_ERROR
public const string PILE_CONFIG_PROPERTY_ERROR
Public Const PILE_CONFIG_PROPERTY_ERROR As String
Public Const PILE_CONFIG_PROPERTY_ERROR As String
public:
literal String^ PILE_CONFIG_PROPERTY_ERROR
public:
literal String^ PILE_CONFIG_PROPERTY_ERROR
static val mutable PILE_CONFIG_PROPERTY_ERROR: string
static val mutable PILE_CONFIG_PROPERTY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.PILE_CRAWL_INTERNAL_SEGMENT_CORRUPTION_ERROR Field

StringConsts PILE_CRAWL_INTERNAL_SEGMENT_CORRUPTION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PILE_CRAWL_INTERNAL_SEGMENT_CORRUPTION_ERROR
public const string PILE_CRAWL_INTERNAL_SEGMENT_CORRUPTION_ERROR
Public Const PILE_CRAWL_INTERNAL_SEGMENT_CORRUPTION_ERROR As String
Public Const PILE_CRAWL_INTERNAL_SEGMENT_CORRUPTION_ERROR As String
public:
literal String^ PILE_CRAWL_INTERNAL_SEGMENT_CORRUPTION_ERROR
public:
literal String^ PILE_CRAWL_INTERNAL_SEGMENT_CORRUPTION_ERROR
static val mutable PILE_CRAWL_INTERNAL_SEGMENT_CORRUPTION_ERROR: string
static val mutable PILE_CRAWL_INTERNAL_SEGMENT_CORRUPTION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.PILE_OBJECT_LARGER_SEGMENT_ERROR Field

StringConsts PILE_OBJECT_LARGER_SEGMENT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PILE_OBJECT_LARGER_SEGMENT_ERROR
public const string PILE_OBJECT_LARGER_SEGMENT_ERROR
Public Const PILE_OBJECT_LARGER_SEGMENT_ERROR As String
Public Const PILE_OBJECT_LARGER_SEGMENT_ERROR As String
public:
literal String^ PILE_OBJECT_LARGER_SEGMENT_ERROR
public:
literal String^ PILE_OBJECT_LARGER_SEGMENT_ERROR
static val mutable PILE_OBJECT_LARGER_SEGMENT_ERROR: string
static val mutable PILE_OBJECT_LARGER_SEGMENT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.PILE_OUT_OF_SPACE_ERROR Field

StringConsts PILE_OUT_OF_SPACE_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PILE_OUT_OF_SPACE_ERROR
public const string PILE_OUT_OF_SPACE_ERROR
Public Const PILE_OUT_OF_SPACE_ERROR As String
Public Const PILE_OUT_OF_SPACE_ERROR As String
public:
literal String^ PILE_OUT_OF_SPACE_ERROR
public:
literal String^ PILE_OUT_OF_SPACE_ERROR
static val mutable PILE_OUT_OF_SPACE_ERROR: string
static val mutable PILE_OUT_OF_SPACE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.POD_DONT_KNOW_HOWTO_DESERIALIZE_FROM_CUSTOM_DATA Field

StringConsts POD_DONT_KNOW_HOWTO_DESERIALIZE_FROM_CUSTOM_DATA Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string POD_DONT_KNOW_HOWTO_DESERIALIZE_FROM_CUSTOM_DATA
public const string POD_DONT_KNOW_HOWTO_DESERIALIZE_FROM_CUSTOM_DATA
Public Const POD_DONT_KNOW_HOWTO_DESERIALIZE_FROM_CUSTOM_DATA As String
Public Const POD_DONT_KNOW_HOWTO_DESERIALIZE_FROM_CUSTOM_DATA As String
public:
literal String^ POD_DONT_KNOW_HOWTO_DESERIALIZE_FROM_CUSTOM_DATA
public:
literal String^ POD_DONT_KNOW_HOWTO_DESERIALIZE_FROM_CUSTOM_DATA
static val mutable POD_DONT_KNOW_HOWTO_DESERIALIZE_FROM_CUSTOM_DATA: string
static val mutable POD_DONT_KNOW_HOWTO_DESERIALIZE_FROM_CUSTOM_DATA: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.POD_ISERIALIZABLE_MISSING_CTOR_ERROR Field

StringConsts POD_ISERIALIZABLE_MISSING_CTOR_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string POD_ISERIALIZABLE_MISSING_CTOR_ERROR
public const string POD_ISERIALIZABLE_MISSING_CTOR_ERROR
Public Const POD_ISERIALIZABLE_MISSING_CTOR_ERROR As String
Public Const POD_ISERIALIZABLE_MISSING_CTOR_ERROR As String
public:
literal String^ POD_ISERIALIZABLE_MISSING_CTOR_ERROR
public:
literal String^ POD_ISERIALIZABLE_MISSING_CTOR_ERROR
static val mutable POD_ISERIALIZABLE_MISSING_CTOR_ERROR: string
static val mutable POD_ISERIALIZABLE_MISSING_CTOR_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.READONLY_COLLECTION_MUTATION_ERROR Field

StringConsts READONLY_COLLECTION_MUTATION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string READONLY_COLLECTION_MUTATION_ERROR
public const string READONLY_COLLECTION_MUTATION_ERROR
Public Const READONLY_COLLECTION_MUTATION_ERROR As String
Public Const READONLY_COLLECTION_MUTATION_ERROR As String
public:
literal String^ READONLY_COLLECTION_MUTATION_ERROR
public:
literal String^ READONLY_COLLECTION_MUTATION_ERROR
static val mutable READONLY_COLLECTION_MUTATION_ERROR: string
static val mutable READONLY_COLLECTION_MUTATION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.READONLY_FIELD_ERROR Field

StringConsts READONLY_FIELD_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string READONLY_FIELD_ERROR
public const string READONLY_FIELD_ERROR
Public Const READONLY_FIELD_ERROR As String
Public Const READONLY_FIELD_ERROR As String
public:
literal String^ READONLY_FIELD_ERROR
public:
literal String^ READONLY_FIELD_ERROR
static val mutable READONLY_FIELD_ERROR: string
static val mutable READONLY_FIELD_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.RECURSIVE_FORMULA_FIELD_ERROR Field

StringConsts RECURSIVE_FORMULA_FIELD_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string RECURSIVE_FORMULA_FIELD_ERROR
public const string RECURSIVE_FORMULA_FIELD_ERROR
Public Const RECURSIVE_FORMULA_FIELD_ERROR As String
Public Const RECURSIVE_FORMULA_FIELD_ERROR As String
public:
literal String^ RECURSIVE_FORMULA_FIELD_ERROR
public:
literal String^ RECURSIVE_FORMULA_FIELD_ERROR
static val mutable RECURSIVE_FORMULA_FIELD_ERROR: string
static val mutable RECURSIVE_FORMULA_FIELD_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.REFERENCE_TYPE_VALUE_SET_ERROR Field

StringConsts REFERENCE_TYPE_VALUE_SET_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string REFERENCE_TYPE_VALUE_SET_ERROR
public const string REFERENCE_TYPE_VALUE_SET_ERROR
Public Const REFERENCE_TYPE_VALUE_SET_ERROR As String
Public Const REFERENCE_TYPE_VALUE_SET_ERROR As String
public:
literal String^ REFERENCE_TYPE_VALUE_SET_ERROR
public:
literal String^ REFERENCE_TYPE_VALUE_SET_ERROR
static val mutable REFERENCE_TYPE_VALUE_SET_ERROR: string
static val mutable REFERENCE_TYPE_VALUE_SET_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.REGEXP_FIELD_ERROR Field

StringConsts REGEXP_FIELD_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string REGEXP_FIELD_ERROR
public const string REGEXP_FIELD_ERROR
Public Const REGEXP_FIELD_ERROR As String
Public Const REGEXP_FIELD_ERROR As String
public:
literal String^ REGEXP_FIELD_ERROR
public:
literal String^ REGEXP_FIELD_ERROR
static val mutable REGEXP_FIELD_ERROR: string
static val mutable REGEXP_FIELD_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.RELATIONAL_COMPILER_INCLUDE_SCRIPT_NOT_FOUND_ERROR Field

StringConsts RELATIONAL_COMPILER_INCLUDE_SCRIPT_NOT_FOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string RELATIONAL_COMPILER_INCLUDE_SCRIPT_NOT_FOUND_ERROR
public const string RELATIONAL_COMPILER_INCLUDE_SCRIPT_NOT_FOUND_ERROR
Public Const RELATIONAL_COMPILER_INCLUDE_SCRIPT_NOT_FOUND_ERROR As String
Public Const RELATIONAL_COMPILER_INCLUDE_SCRIPT_NOT_FOUND_ERROR As String
public:
literal String^ RELATIONAL_COMPILER_INCLUDE_SCRIPT_NOT_FOUND_ERROR
public:
literal String^ RELATIONAL_COMPILER_INCLUDE_SCRIPT_NOT_FOUND_ERROR
static val mutable RELATIONAL_COMPILER_INCLUDE_SCRIPT_NOT_FOUND_ERROR: string
static val mutable RELATIONAL_COMPILER_INCLUDE_SCRIPT_NOT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.RELATIONAL_COMPILER_OUTPUT_PATH_DOSNT_EXIST_ERROR Field

StringConsts RELATIONAL_COMPILER_OUTPUT_PATH_DOSNT_EXIST_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string RELATIONAL_COMPILER_OUTPUT_PATH_DOSNT_EXIST_ERROR
public const string RELATIONAL_COMPILER_OUTPUT_PATH_DOSNT_EXIST_ERROR
Public Const RELATIONAL_COMPILER_OUTPUT_PATH_DOSNT_EXIST_ERROR As String
Public Const RELATIONAL_COMPILER_OUTPUT_PATH_DOSNT_EXIST_ERROR As String
public:
literal String^ RELATIONAL_COMPILER_OUTPUT_PATH_DOSNT_EXIST_ERROR
public:
literal String^ RELATIONAL_COMPILER_OUTPUT_PATH_DOSNT_EXIST_ERROR
static val mutable RELATIONAL_COMPILER_OUTPUT_PATH_DOSNT_EXIST_ERROR: string
static val mutable RELATIONAL_COMPILER_OUTPUT_PATH_DOSNT_EXIST_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.REQUIRED_FIELD_ERROR Field

StringConsts REQUIRED_FIELD_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string REQUIRED_FIELD_ERROR
public const string REQUIRED_FIELD_ERROR
Public Const REQUIRED_FIELD_ERROR As String
Public Const REQUIRED_FIELD_ERROR As String
public:
literal String^ REQUIRED_FIELD_ERROR
public:
literal String^ REQUIRED_FIELD_ERROR
static val mutable REQUIRED_FIELD_ERROR: string
static val mutable REQUIRED_FIELD_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SAVE_MODIFY_ERROR Field

StringConsts SAVE_MODIFY_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SAVE_MODIFY_ERROR
public const string SAVE_MODIFY_ERROR
Public Const SAVE_MODIFY_ERROR As String
Public Const SAVE_MODIFY_ERROR As String
public:
literal String^ SAVE_MODIFY_ERROR
public:
literal String^ SAVE_MODIFY_ERROR
static val mutable SAVE_MODIFY_ERROR: string
static val mutable SAVE_MODIFY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SCHEMA_HAS_ALREADY_COMPILED_OPTION_CHANGE_ERROR Field

StringConsts SCHEMA_HAS_ALREADY_COMPILED_OPTION_CHANGE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SCHEMA_HAS_ALREADY_COMPILED_OPTION_CHANGE_ERROR
public const string SCHEMA_HAS_ALREADY_COMPILED_OPTION_CHANGE_ERROR
Public Const SCHEMA_HAS_ALREADY_COMPILED_OPTION_CHANGE_ERROR As String
Public Const SCHEMA_HAS_ALREADY_COMPILED_OPTION_CHANGE_ERROR As String
public:
literal String^ SCHEMA_HAS_ALREADY_COMPILED_OPTION_CHANGE_ERROR
public:
literal String^ SCHEMA_HAS_ALREADY_COMPILED_OPTION_CHANGE_ERROR
static val mutable SCHEMA_HAS_ALREADY_COMPILED_OPTION_CHANGE_ERROR: string
static val mutable SCHEMA_HAS_ALREADY_COMPILED_OPTION_CHANGE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SCHEMA_INCLUDE_FILE_DOSNT_EXIST_ERROR Field

StringConsts SCHEMA_INCLUDE_FILE_DOSNT_EXIST_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SCHEMA_INCLUDE_FILE_DOSNT_EXIST_ERROR
public const string SCHEMA_INCLUDE_FILE_DOSNT_EXIST_ERROR
Public Const SCHEMA_INCLUDE_FILE_DOSNT_EXIST_ERROR As String
Public Const SCHEMA_INCLUDE_FILE_DOSNT_EXIST_ERROR As String
public:
literal String^ SCHEMA_INCLUDE_FILE_DOSNT_EXIST_ERROR
public:
literal String^ SCHEMA_INCLUDE_FILE_DOSNT_EXIST_ERROR
static val mutable SCHEMA_INCLUDE_FILE_DOSNT_EXIST_ERROR: string
static val mutable SCHEMA_INCLUDE_FILE_DOSNT_EXIST_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SCHEMA_INCLUDE_FILE_REFERENCED_MORE_THAN_ONCE_ERROR Field

StringConsts SCHEMA_INCLUDE_FILE_REFERENCED_MORE_THAN_ONCE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SCHEMA_INCLUDE_FILE_REFERENCED_MORE_THAN_ONCE_ERROR
public const string SCHEMA_INCLUDE_FILE_REFERENCED_MORE_THAN_ONCE_ERROR
Public Const SCHEMA_INCLUDE_FILE_REFERENCED_MORE_THAN_ONCE_ERROR As String
Public Const SCHEMA_INCLUDE_FILE_REFERENCED_MORE_THAN_ONCE_ERROR As String
public:
literal String^ SCHEMA_INCLUDE_FILE_REFERENCED_MORE_THAN_ONCE_ERROR
public:
literal String^ SCHEMA_INCLUDE_FILE_REFERENCED_MORE_THAN_ONCE_ERROR
static val mutable SCHEMA_INCLUDE_FILE_REFERENCED_MORE_THAN_ONCE_ERROR: string
static val mutable SCHEMA_INCLUDE_FILE_REFERENCED_MORE_THAN_ONCE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SEALED_STRING_OUT_OF_SPACE_ERROR Field

StringConsts SEALED_STRING_OUT_OF_SPACE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SEALED_STRING_OUT_OF_SPACE_ERROR
public const string SEALED_STRING_OUT_OF_SPACE_ERROR
Public Const SEALED_STRING_OUT_OF_SPACE_ERROR As String
Public Const SEALED_STRING_OUT_OF_SPACE_ERROR As String
public:
literal String^ SEALED_STRING_OUT_OF_SPACE_ERROR
public:
literal String^ SEALED_STRING_OUT_OF_SPACE_ERROR
static val mutable SEALED_STRING_OUT_OF_SPACE_ERROR: string
static val mutable SEALED_STRING_OUT_OF_SPACE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SEALED_STRING_TOO_BIG_ERROR Field

StringConsts SEALED_STRING_TOO_BIG_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SEALED_STRING_TOO_BIG_ERROR
public const string SEALED_STRING_TOO_BIG_ERROR
Public Const SEALED_STRING_TOO_BIG_ERROR As String
Public Const SEALED_STRING_TOO_BIG_ERROR As String
public:
literal String^ SEALED_STRING_TOO_BIG_ERROR
public:
literal String^ SEALED_STRING_TOO_BIG_ERROR
static val mutable SEALED_STRING_TOO_BIG_ERROR: string
static val mutable SEALED_STRING_TOO_BIG_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SECDB_FILE_HEADER_ERROR Field

StringConsts SECDB_FILE_HEADER_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SECDB_FILE_HEADER_ERROR
public const string SECDB_FILE_HEADER_ERROR
Public Const SECDB_FILE_HEADER_ERROR As String
Public Const SECDB_FILE_HEADER_ERROR As String
public:
literal String^ SECDB_FILE_HEADER_ERROR
public:
literal String^ SECDB_FILE_HEADER_ERROR
static val mutable SECDB_FILE_HEADER_ERROR: string
static val mutable SECDB_FILE_HEADER_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SECDB_FILE_NOT_FOUND_ERROR Field

StringConsts SECDB_FILE_NOT_FOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SECDB_FILE_NOT_FOUND_ERROR
public const string SECDB_FILE_NOT_FOUND_ERROR
Public Const SECDB_FILE_NOT_FOUND_ERROR As String
Public Const SECDB_FILE_NOT_FOUND_ERROR As String
public:
literal String^ SECDB_FILE_NOT_FOUND_ERROR
public:
literal String^ SECDB_FILE_NOT_FOUND_ERROR
static val mutable SECDB_FILE_NOT_FOUND_ERROR: string
static val mutable SECDB_FILE_NOT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SECDB_FS_SEEK_STREAM_ERROR Field

StringConsts SECDB_FS_SEEK_STREAM_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SECDB_FS_SEEK_STREAM_ERROR
public const string SECDB_FS_SEEK_STREAM_ERROR
Public Const SECDB_FS_SEEK_STREAM_ERROR As String
Public Const SECDB_FS_SEEK_STREAM_ERROR As String
public:
literal String^ SECDB_FS_SEEK_STREAM_ERROR
public:
literal String^ SECDB_FS_SEEK_STREAM_ERROR
static val mutable SECDB_FS_SEEK_STREAM_ERROR: string
static val mutable SECDB_FS_SEEK_STREAM_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SECDB_STREAM_CORRUPTED_ERROR Field

StringConsts SECDB_STREAM_CORRUPTED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SECDB_STREAM_CORRUPTED_ERROR
public const string SECDB_STREAM_CORRUPTED_ERROR
Public Const SECDB_STREAM_CORRUPTED_ERROR As String
Public Const SECDB_STREAM_CORRUPTED_ERROR As String
public:
literal String^ SECDB_STREAM_CORRUPTED_ERROR
public:
literal String^ SECDB_STREAM_CORRUPTED_ERROR
static val mutable SECDB_STREAM_CORRUPTED_ERROR: string
static val mutable SECDB_STREAM_CORRUPTED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SECURITY_AUTHROIZATION_ERROR Field

StringConsts SECURITY_AUTHROIZATION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SECURITY_AUTHROIZATION_ERROR
public const string SECURITY_AUTHROIZATION_ERROR
Public Const SECURITY_AUTHROIZATION_ERROR As String
Public Const SECURITY_AUTHROIZATION_ERROR As String
public:
literal String^ SECURITY_AUTHROIZATION_ERROR
public:
literal String^ SECURITY_AUTHROIZATION_ERROR
static val mutable SECURITY_AUTHROIZATION_ERROR: string
static val mutable SECURITY_AUTHROIZATION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SECURITY_NON_AUTHENTICATED Field

StringConsts SECURITY_NON_AUTHENTICATED Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SECURITY_NON_AUTHENTICATED
public const string SECURITY_NON_AUTHENTICATED
Public Const SECURITY_NON_AUTHENTICATED As String
Public Const SECURITY_NON_AUTHENTICATED As String
public:
literal String^ SECURITY_NON_AUTHENTICATED
public:
literal String^ SECURITY_NON_AUTHENTICATED
static val mutable SECURITY_NON_AUTHENTICATED: string
static val mutable SECURITY_NON_AUTHENTICATED: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SECURITY_REPRESENT_CREDENTIALS_FORGOTTEN Field

StringConsts SECURITY_REPRESENT_CREDENTIALS_FORGOTTEN Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SECURITY_REPRESENT_CREDENTIALS_FORGOTTEN
public const string SECURITY_REPRESENT_CREDENTIALS_FORGOTTEN
Public Const SECURITY_REPRESENT_CREDENTIALS_FORGOTTEN As String
Public Const SECURITY_REPRESENT_CREDENTIALS_FORGOTTEN As String
public:
literal String^ SECURITY_REPRESENT_CREDENTIALS_FORGOTTEN
public:
literal String^ SECURITY_REPRESENT_CREDENTIALS_FORGOTTEN
static val mutable SECURITY_REPRESENT_CREDENTIALS_FORGOTTEN: string
static val mutable SECURITY_REPRESENT_CREDENTIALS_FORGOTTEN: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SERVICE_COMPOSITE_CHILD_START_ABORT_ERROR Field

StringConsts SERVICE_COMPOSITE_CHILD_START_ABORT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SERVICE_COMPOSITE_CHILD_START_ABORT_ERROR
public const string SERVICE_COMPOSITE_CHILD_START_ABORT_ERROR
Public Const SERVICE_COMPOSITE_CHILD_START_ABORT_ERROR As String
Public Const SERVICE_COMPOSITE_CHILD_START_ABORT_ERROR As String
public:
literal String^ SERVICE_COMPOSITE_CHILD_START_ABORT_ERROR
public:
literal String^ SERVICE_COMPOSITE_CHILD_START_ABORT_ERROR
static val mutable SERVICE_COMPOSITE_CHILD_START_ABORT_ERROR: string
static val mutable SERVICE_COMPOSITE_CHILD_START_ABORT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SERVICE_INVALID_STATE Field

StringConsts SERVICE_INVALID_STATE Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SERVICE_INVALID_STATE
public const string SERVICE_INVALID_STATE
Public Const SERVICE_INVALID_STATE As String
Public Const SERVICE_INVALID_STATE As String
public:
literal String^ SERVICE_INVALID_STATE
public:
literal String^ SERVICE_INVALID_STATE
static val mutable SERVICE_INVALID_STATE: string
static val mutable SERVICE_INVALID_STATE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SIZE_FIELD_ERROR Field

StringConsts SIZE_FIELD_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SIZE_FIELD_ERROR
public const string SIZE_FIELD_ERROR
Public Const SIZE_FIELD_ERROR As String
Public Const SIZE_FIELD_ERROR As String
public:
literal String^ SIZE_FIELD_ERROR
public:
literal String^ SIZE_FIELD_ERROR
static val mutable SIZE_FIELD_ERROR: string
static val mutable SIZE_FIELD_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SLIM_ARRAYS_ARRAY_INSTANCE_ERROR Field

StringConsts SLIM_ARRAYS_ARRAY_INSTANCE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SLIM_ARRAYS_ARRAY_INSTANCE_ERROR
public const string SLIM_ARRAYS_ARRAY_INSTANCE_ERROR
Public Const SLIM_ARRAYS_ARRAY_INSTANCE_ERROR As String
Public Const SLIM_ARRAYS_ARRAY_INSTANCE_ERROR As String
public:
literal String^ SLIM_ARRAYS_ARRAY_INSTANCE_ERROR
public:
literal String^ SLIM_ARRAYS_ARRAY_INSTANCE_ERROR
static val mutable SLIM_ARRAYS_ARRAY_INSTANCE_ERROR: string
static val mutable SLIM_ARRAYS_ARRAY_INSTANCE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SLIM_ARRAYS_MISSING_ARRAY_DIMS_ERROR Field

StringConsts SLIM_ARRAYS_MISSING_ARRAY_DIMS_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SLIM_ARRAYS_MISSING_ARRAY_DIMS_ERROR
public const string SLIM_ARRAYS_MISSING_ARRAY_DIMS_ERROR
Public Const SLIM_ARRAYS_MISSING_ARRAY_DIMS_ERROR As String
Public Const SLIM_ARRAYS_MISSING_ARRAY_DIMS_ERROR As String
public:
literal String^ SLIM_ARRAYS_MISSING_ARRAY_DIMS_ERROR
public:
literal String^ SLIM_ARRAYS_MISSING_ARRAY_DIMS_ERROR
static val mutable SLIM_ARRAYS_MISSING_ARRAY_DIMS_ERROR: string
static val mutable SLIM_ARRAYS_MISSING_ARRAY_DIMS_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SLIM_ARRAYS_OVER_MAX_DIMS_ERROR Field

StringConsts SLIM_ARRAYS_OVER_MAX_DIMS_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SLIM_ARRAYS_OVER_MAX_DIMS_ERROR
public const string SLIM_ARRAYS_OVER_MAX_DIMS_ERROR
Public Const SLIM_ARRAYS_OVER_MAX_DIMS_ERROR As String
Public Const SLIM_ARRAYS_OVER_MAX_DIMS_ERROR As String
public:
literal String^ SLIM_ARRAYS_OVER_MAX_DIMS_ERROR
public:
literal String^ SLIM_ARRAYS_OVER_MAX_DIMS_ERROR
static val mutable SLIM_ARRAYS_OVER_MAX_DIMS_ERROR: string
static val mutable SLIM_ARRAYS_OVER_MAX_DIMS_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SLIM_ARRAYS_OVER_MAX_ELM_ERROR Field

StringConsts SLIM_ARRAYS_OVER_MAX_ELM_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SLIM_ARRAYS_OVER_MAX_ELM_ERROR
public const string SLIM_ARRAYS_OVER_MAX_ELM_ERROR
Public Const SLIM_ARRAYS_OVER_MAX_ELM_ERROR As String
Public Const SLIM_ARRAYS_OVER_MAX_ELM_ERROR As String
public:
literal String^ SLIM_ARRAYS_OVER_MAX_ELM_ERROR
public:
literal String^ SLIM_ARRAYS_OVER_MAX_ELM_ERROR
static val mutable SLIM_ARRAYS_OVER_MAX_ELM_ERROR: string
static val mutable SLIM_ARRAYS_OVER_MAX_ELM_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SLIM_ARRAYS_TYPE_NOT_ARRAY_ERROR Field

StringConsts SLIM_ARRAYS_TYPE_NOT_ARRAY_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SLIM_ARRAYS_TYPE_NOT_ARRAY_ERROR
public const string SLIM_ARRAYS_TYPE_NOT_ARRAY_ERROR
Public Const SLIM_ARRAYS_TYPE_NOT_ARRAY_ERROR As String
Public Const SLIM_ARRAYS_TYPE_NOT_ARRAY_ERROR As String
public:
literal String^ SLIM_ARRAYS_TYPE_NOT_ARRAY_ERROR
public:
literal String^ SLIM_ARRAYS_TYPE_NOT_ARRAY_ERROR
static val mutable SLIM_ARRAYS_TYPE_NOT_ARRAY_ERROR: string
static val mutable SLIM_ARRAYS_TYPE_NOT_ARRAY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SLIM_ARRAYS_WRONG_ARRAY_DIMS_ERROR Field

StringConsts SLIM_ARRAYS_WRONG_ARRAY_DIMS_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SLIM_ARRAYS_WRONG_ARRAY_DIMS_ERROR
public const string SLIM_ARRAYS_WRONG_ARRAY_DIMS_ERROR
Public Const SLIM_ARRAYS_WRONG_ARRAY_DIMS_ERROR As String
Public Const SLIM_ARRAYS_WRONG_ARRAY_DIMS_ERROR As String
public:
literal String^ SLIM_ARRAYS_WRONG_ARRAY_DIMS_ERROR
public:
literal String^ SLIM_ARRAYS_WRONG_ARRAY_DIMS_ERROR
static val mutable SLIM_ARRAYS_WRONG_ARRAY_DIMS_ERROR: string
static val mutable SLIM_ARRAYS_WRONG_ARRAY_DIMS_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SLIM_BAD_HEADER_ERROR Field

StringConsts SLIM_BAD_HEADER_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SLIM_BAD_HEADER_ERROR
public const string SLIM_BAD_HEADER_ERROR
Public Const SLIM_BAD_HEADER_ERROR As String
Public Const SLIM_BAD_HEADER_ERROR As String
public:
literal String^ SLIM_BAD_HEADER_ERROR
public:
literal String^ SLIM_BAD_HEADER_ERROR
static val mutable SLIM_BAD_HEADER_ERROR: string
static val mutable SLIM_BAD_HEADER_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SLIM_DESERIALIZATION_EXCEPTION_ERROR Field

StringConsts SLIM_DESERIALIZATION_EXCEPTION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SLIM_DESERIALIZATION_EXCEPTION_ERROR
public const string SLIM_DESERIALIZATION_EXCEPTION_ERROR
Public Const SLIM_DESERIALIZATION_EXCEPTION_ERROR As String
Public Const SLIM_DESERIALIZATION_EXCEPTION_ERROR As String
public:
literal String^ SLIM_DESERIALIZATION_EXCEPTION_ERROR
public:
literal String^ SLIM_DESERIALIZATION_EXCEPTION_ERROR
static val mutable SLIM_DESERIALIZATION_EXCEPTION_ERROR: string
static val mutable SLIM_DESERIALIZATION_EXCEPTION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SLIM_DESERIALIZE_CALLBACK_ERROR Field

StringConsts SLIM_DESERIALIZE_CALLBACK_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SLIM_DESERIALIZE_CALLBACK_ERROR
public const string SLIM_DESERIALIZE_CALLBACK_ERROR
Public Const SLIM_DESERIALIZE_CALLBACK_ERROR As String
Public Const SLIM_DESERIALIZE_CALLBACK_ERROR As String
public:
literal String^ SLIM_DESERIALIZE_CALLBACK_ERROR
public:
literal String^ SLIM_DESERIALIZE_CALLBACK_ERROR
static val mutable SLIM_DESERIALIZE_CALLBACK_ERROR: string
static val mutable SLIM_DESERIALIZE_CALLBACK_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SLIM_HNDLTOREF_MISSING_TYPE_NAME_ERROR Field

StringConsts SLIM_HNDLTOREF_MISSING_TYPE_NAME_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SLIM_HNDLTOREF_MISSING_TYPE_NAME_ERROR
public const string SLIM_HNDLTOREF_MISSING_TYPE_NAME_ERROR
Public Const SLIM_HNDLTOREF_MISSING_TYPE_NAME_ERROR As String
Public Const SLIM_HNDLTOREF_MISSING_TYPE_NAME_ERROR As String
public:
literal String^ SLIM_HNDLTOREF_MISSING_TYPE_NAME_ERROR
public:
literal String^ SLIM_HNDLTOREF_MISSING_TYPE_NAME_ERROR
static val mutable SLIM_HNDLTOREF_MISSING_TYPE_NAME_ERROR: string
static val mutable SLIM_HNDLTOREF_MISSING_TYPE_NAME_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SLIM_ISERIALIZABLE_MISSING_CTOR_ERROR Field

StringConsts SLIM_ISERIALIZABLE_MISSING_CTOR_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SLIM_ISERIALIZABLE_MISSING_CTOR_ERROR
public const string SLIM_ISERIALIZABLE_MISSING_CTOR_ERROR
Public Const SLIM_ISERIALIZABLE_MISSING_CTOR_ERROR As String
Public Const SLIM_ISERIALIZABLE_MISSING_CTOR_ERROR As String
public:
literal String^ SLIM_ISERIALIZABLE_MISSING_CTOR_ERROR
public:
literal String^ SLIM_ISERIALIZABLE_MISSING_CTOR_ERROR
static val mutable SLIM_ISERIALIZABLE_MISSING_CTOR_ERROR: string
static val mutable SLIM_ISERIALIZABLE_MISSING_CTOR_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SLIM_READ_X_ARRAY_MAX_SIZE_ERROR Field

StringConsts SLIM_READ_X_ARRAY_MAX_SIZE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SLIM_READ_X_ARRAY_MAX_SIZE_ERROR
public const string SLIM_READ_X_ARRAY_MAX_SIZE_ERROR
Public Const SLIM_READ_X_ARRAY_MAX_SIZE_ERROR As String
Public Const SLIM_READ_X_ARRAY_MAX_SIZE_ERROR As String
public:
literal String^ SLIM_READ_X_ARRAY_MAX_SIZE_ERROR
public:
literal String^ SLIM_READ_X_ARRAY_MAX_SIZE_ERROR
static val mutable SLIM_READ_X_ARRAY_MAX_SIZE_ERROR: string
static val mutable SLIM_READ_X_ARRAY_MAX_SIZE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SLIM_SER_PROHIBIT_ERROR Field

StringConsts SLIM_SER_PROHIBIT_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SLIM_SER_PROHIBIT_ERROR
public const string SLIM_SER_PROHIBIT_ERROR
Public Const SLIM_SER_PROHIBIT_ERROR As String
Public Const SLIM_SER_PROHIBIT_ERROR As String
public:
literal String^ SLIM_SER_PROHIBIT_ERROR
public:
literal String^ SLIM_SER_PROHIBIT_ERROR
static val mutable SLIM_SER_PROHIBIT_ERROR: string
static val mutable SLIM_SER_PROHIBIT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SLIM_SERIALIZATION_EXCEPTION_ERROR Field

StringConsts SLIM_SERIALIZATION_EXCEPTION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SLIM_SERIALIZATION_EXCEPTION_ERROR
public const string SLIM_SERIALIZATION_EXCEPTION_ERROR
Public Const SLIM_SERIALIZATION_EXCEPTION_ERROR As String
Public Const SLIM_SERIALIZATION_EXCEPTION_ERROR As String
public:
literal String^ SLIM_SERIALIZATION_EXCEPTION_ERROR
public:
literal String^ SLIM_SERIALIZATION_EXCEPTION_ERROR
static val mutable SLIM_SERIALIZATION_EXCEPTION_ERROR: string
static val mutable SLIM_SERIALIZATION_EXCEPTION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SLIM_STREAM_CORRUPTED_ERROR Field

StringConsts SLIM_STREAM_CORRUPTED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SLIM_STREAM_CORRUPTED_ERROR
public const string SLIM_STREAM_CORRUPTED_ERROR
Public Const SLIM_STREAM_CORRUPTED_ERROR As String
Public Const SLIM_STREAM_CORRUPTED_ERROR As String
public:
literal String^ SLIM_STREAM_CORRUPTED_ERROR
public:
literal String^ SLIM_STREAM_CORRUPTED_ERROR
static val mutable SLIM_STREAM_CORRUPTED_ERROR: string
static val mutable SLIM_STREAM_CORRUPTED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SLIM_TREG_COUNT_ERROR Field

StringConsts SLIM_TREG_COUNT_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SLIM_TREG_COUNT_ERROR
public const string SLIM_TREG_COUNT_ERROR
Public Const SLIM_TREG_COUNT_ERROR As String
Public Const SLIM_TREG_COUNT_ERROR As String
public:
literal String^ SLIM_TREG_COUNT_ERROR
public:
literal String^ SLIM_TREG_COUNT_ERROR
static val mutable SLIM_TREG_COUNT_ERROR: string
static val mutable SLIM_TREG_COUNT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SLIM_TREG_CSUM_ERROR Field

StringConsts SLIM_TREG_CSUM_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SLIM_TREG_CSUM_ERROR
public const string SLIM_TREG_CSUM_ERROR
Public Const SLIM_TREG_CSUM_ERROR As String
Public Const SLIM_TREG_CSUM_ERROR As String
public:
literal String^ SLIM_TREG_CSUM_ERROR
public:
literal String^ SLIM_TREG_CSUM_ERROR
static val mutable SLIM_TREG_CSUM_ERROR: string
static val mutable SLIM_TREG_CSUM_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SLIM_WRITE_X_ARRAY_MAX_SIZE_ERROR Field

StringConsts SLIM_WRITE_X_ARRAY_MAX_SIZE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SLIM_WRITE_X_ARRAY_MAX_SIZE_ERROR
public const string SLIM_WRITE_X_ARRAY_MAX_SIZE_ERROR
Public Const SLIM_WRITE_X_ARRAY_MAX_SIZE_ERROR As String
Public Const SLIM_WRITE_X_ARRAY_MAX_SIZE_ERROR As String
public:
literal String^ SLIM_WRITE_X_ARRAY_MAX_SIZE_ERROR
public:
literal String^ SLIM_WRITE_X_ARRAY_MAX_SIZE_ERROR
static val mutable SLIM_WRITE_X_ARRAY_MAX_SIZE_ERROR: string
static val mutable SLIM_WRITE_X_ARRAY_MAX_SIZE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.STORAGE_OPERATION_IN_PROGRESS_ERROR Field

StringConsts STORAGE_OPERATION_IN_PROGRESS_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string STORAGE_OPERATION_IN_PROGRESS_ERROR
public const string STORAGE_OPERATION_IN_PROGRESS_ERROR
Public Const STORAGE_OPERATION_IN_PROGRESS_ERROR As String
Public Const STORAGE_OPERATION_IN_PROGRESS_ERROR As String
public:
literal String^ STORAGE_OPERATION_IN_PROGRESS_ERROR
public:
literal String^ STORAGE_OPERATION_IN_PROGRESS_ERROR
static val mutable STORAGE_OPERATION_IN_PROGRESS_ERROR: string
static val mutable STORAGE_OPERATION_IN_PROGRESS_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.STREAM_READ_EOF_ERROR Field

StringConsts STREAM_READ_EOF_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string STREAM_READ_EOF_ERROR
public const string STREAM_READ_EOF_ERROR
Public Const STREAM_READ_EOF_ERROR As String
Public Const STREAM_READ_EOF_ERROR As String
public:
literal String^ STREAM_READ_EOF_ERROR
public:
literal String^ STREAM_READ_EOF_ERROR
static val mutable STREAM_READ_EOF_ERROR: string
static val mutable STREAM_READ_EOF_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.STRING_VALUE_COULD_NOT_BE_GOTTEN_AS_TYPE_ERROR Field

StringConsts STRING_VALUE_COULD_NOT_BE_GOTTEN_AS_TYPE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string STRING_VALUE_COULD_NOT_BE_GOTTEN_AS_TYPE_ERROR
public const string STRING_VALUE_COULD_NOT_BE_GOTTEN_AS_TYPE_ERROR
Public Const STRING_VALUE_COULD_NOT_BE_GOTTEN_AS_TYPE_ERROR As String
Public Const STRING_VALUE_COULD_NOT_BE_GOTTEN_AS_TYPE_ERROR As String
public:
literal String^ STRING_VALUE_COULD_NOT_BE_GOTTEN_AS_TYPE_ERROR
public:
literal String^ STRING_VALUE_COULD_NOT_BE_GOTTEN_AS_TYPE_ERROR
static val mutable STRING_VALUE_COULD_NOT_BE_GOTTEN_AS_TYPE_ERROR: string
static val mutable STRING_VALUE_COULD_NOT_BE_GOTTEN_AS_TYPE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SURROGATE_LOAD_ERROR Field

StringConsts SURROGATE_LOAD_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SURROGATE_LOAD_ERROR
public const string SURROGATE_LOAD_ERROR
Public Const SURROGATE_LOAD_ERROR As String
Public Const SURROGATE_LOAD_ERROR As String
public:
literal String^ SURROGATE_LOAD_ERROR
public:
literal String^ SURROGATE_LOAD_ERROR
static val mutable SURROGATE_LOAD_ERROR: string
static val mutable SURROGATE_LOAD_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SVCAPP_INSTANCE_ALREADY_CREATED_ERROR Field

StringConsts SVCAPP_INSTANCE_ALREADY_CREATED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SVCAPP_INSTANCE_ALREADY_CREATED_ERROR
public const string SVCAPP_INSTANCE_ALREADY_CREATED_ERROR
Public Const SVCAPP_INSTANCE_ALREADY_CREATED_ERROR As String
Public Const SVCAPP_INSTANCE_ALREADY_CREATED_ERROR As String
public:
literal String^ SVCAPP_INSTANCE_ALREADY_CREATED_ERROR
public:
literal String^ SVCAPP_INSTANCE_ALREADY_CREATED_ERROR
static val mutable SVCAPP_INSTANCE_ALREADY_CREATED_ERROR: string
static val mutable SVCAPP_INSTANCE_ALREADY_CREATED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SVCAPP_INSTANCE_NULL_ERROR Field

StringConsts SVCAPP_INSTANCE_NULL_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SVCAPP_INSTANCE_NULL_ERROR
public const string SVCAPP_INSTANCE_NULL_ERROR
Public Const SVCAPP_INSTANCE_NULL_ERROR As String
Public Const SVCAPP_INSTANCE_NULL_ERROR As String
public:
literal String^ SVCAPP_INSTANCE_NULL_ERROR
public:
literal String^ SVCAPP_INSTANCE_NULL_ERROR
static val mutable SVCAPP_INSTANCE_NULL_ERROR: string
static val mutable SVCAPP_INSTANCE_NULL_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.SVCAPPLICATION_TOPIC Field

StringConsts SVCAPPLICATION_TOPIC Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SVCAPPLICATION_TOPIC
public const string SVCAPPLICATION_TOPIC
Public Const SVCAPPLICATION_TOPIC As String
Public Const SVCAPPLICATION_TOPIC As String
public:
literal String^ SVCAPPLICATION_TOPIC
public:
literal String^ SVCAPPLICATION_TOPIC
static val mutable SVCAPPLICATION_TOPIC: string
static val mutable SVCAPPLICATION_TOPIC: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.TEMPLATE_COMPILER_ALREADY_COMPILED_ERROR Field

StringConsts TEMPLATE_COMPILER_ALREADY_COMPILED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string TEMPLATE_COMPILER_ALREADY_COMPILED_ERROR
public const string TEMPLATE_COMPILER_ALREADY_COMPILED_ERROR
Public Const TEMPLATE_COMPILER_ALREADY_COMPILED_ERROR As String
Public Const TEMPLATE_COMPILER_ALREADY_COMPILED_ERROR As String
public:
literal String^ TEMPLATE_COMPILER_ALREADY_COMPILED_ERROR
public:
literal String^ TEMPLATE_COMPILER_ALREADY_COMPILED_ERROR
static val mutable TEMPLATE_COMPILER_ALREADY_COMPILED_ERROR: string
static val mutable TEMPLATE_COMPILER_ALREADY_COMPILED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.TEMPLATE_CS_COMPILER_CONFIG_CLOSE_TAG_ERROR Field

StringConsts TEMPLATE_CS_COMPILER_CONFIG_CLOSE_TAG_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string TEMPLATE_CS_COMPILER_CONFIG_CLOSE_TAG_ERROR
public const string TEMPLATE_CS_COMPILER_CONFIG_CLOSE_TAG_ERROR
Public Const TEMPLATE_CS_COMPILER_CONFIG_CLOSE_TAG_ERROR As String
Public Const TEMPLATE_CS_COMPILER_CONFIG_CLOSE_TAG_ERROR As String
public:
literal String^ TEMPLATE_CS_COMPILER_CONFIG_CLOSE_TAG_ERROR
public:
literal String^ TEMPLATE_CS_COMPILER_CONFIG_CLOSE_TAG_ERROR
static val mutable TEMPLATE_CS_COMPILER_CONFIG_CLOSE_TAG_ERROR: string
static val mutable TEMPLATE_CS_COMPILER_CONFIG_CLOSE_TAG_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.TEMPLATE_CS_COMPILER_CONFIG_ERROR Field

StringConsts TEMPLATE_CS_COMPILER_CONFIG_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string TEMPLATE_CS_COMPILER_CONFIG_ERROR
public const string TEMPLATE_CS_COMPILER_CONFIG_ERROR
Public Const TEMPLATE_CS_COMPILER_CONFIG_ERROR As String
Public Const TEMPLATE_CS_COMPILER_CONFIG_ERROR As String
public:
literal String^ TEMPLATE_CS_COMPILER_CONFIG_ERROR
public:
literal String^ TEMPLATE_CS_COMPILER_CONFIG_ERROR
static val mutable TEMPLATE_CS_COMPILER_CONFIG_ERROR: string
static val mutable TEMPLATE_CS_COMPILER_CONFIG_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.TEMPLATE_CS_COMPILER_EMPTY_EXPRESSION_ERROR Field

StringConsts TEMPLATE_CS_COMPILER_EMPTY_EXPRESSION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string TEMPLATE_CS_COMPILER_EMPTY_EXPRESSION_ERROR
public const string TEMPLATE_CS_COMPILER_EMPTY_EXPRESSION_ERROR
Public Const TEMPLATE_CS_COMPILER_EMPTY_EXPRESSION_ERROR As String
Public Const TEMPLATE_CS_COMPILER_EMPTY_EXPRESSION_ERROR As String
public:
literal String^ TEMPLATE_CS_COMPILER_EMPTY_EXPRESSION_ERROR
public:
literal String^ TEMPLATE_CS_COMPILER_EMPTY_EXPRESSION_ERROR
static val mutable TEMPLATE_CS_COMPILER_EMPTY_EXPRESSION_ERROR: string
static val mutable TEMPLATE_CS_COMPILER_EMPTY_EXPRESSION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.TEMPLATE_CS_COMPILER_UNMATCHED_SPAN_ERROR Field

StringConsts TEMPLATE_CS_COMPILER_UNMATCHED_SPAN_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string TEMPLATE_CS_COMPILER_UNMATCHED_SPAN_ERROR
public const string TEMPLATE_CS_COMPILER_UNMATCHED_SPAN_ERROR
Public Const TEMPLATE_CS_COMPILER_UNMATCHED_SPAN_ERROR As String
Public Const TEMPLATE_CS_COMPILER_UNMATCHED_SPAN_ERROR As String
public:
literal String^ TEMPLATE_CS_COMPILER_UNMATCHED_SPAN_ERROR
public:
literal String^ TEMPLATE_CS_COMPILER_UNMATCHED_SPAN_ERROR
static val mutable TEMPLATE_CS_COMPILER_UNMATCHED_SPAN_ERROR: string
static val mutable TEMPLATE_CS_COMPILER_UNMATCHED_SPAN_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.TEXT_PATTERN_MULTI_WC_ERROR Field

StringConsts TEXT_PATTERN_MULTI_WC_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string TEXT_PATTERN_MULTI_WC_ERROR
public const string TEXT_PATTERN_MULTI_WC_ERROR
Public Const TEXT_PATTERN_MULTI_WC_ERROR As String
Public Const TEXT_PATTERN_MULTI_WC_ERROR As String
public:
literal String^ TEXT_PATTERN_MULTI_WC_ERROR
public:
literal String^ TEXT_PATTERN_MULTI_WC_ERROR
static val mutable TEXT_PATTERN_MULTI_WC_ERROR: string
static val mutable TEXT_PATTERN_MULTI_WC_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.UNINITIALIZED_STATE_ERROR Field

StringConsts UNINITIALIZED_STATE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNINITIALIZED_STATE_ERROR
public const string UNINITIALIZED_STATE_ERROR
Public Const UNINITIALIZED_STATE_ERROR As String
Public Const UNINITIALIZED_STATE_ERROR As String
public:
literal String^ UNINITIALIZED_STATE_ERROR
public:
literal String^ UNINITIALIZED_STATE_ERROR
static val mutable UNINITIALIZED_STATE_ERROR: string
static val mutable UNINITIALIZED_STATE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.UNKNOWN_STRING Field

StringConsts UNKNOWN_STRING Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNKNOWN_STRING
public const string UNKNOWN_STRING
Public Const UNKNOWN_STRING As String
Public Const UNKNOWN_STRING As String
public:
literal String^ UNKNOWN_STRING
public:
literal String^ UNKNOWN_STRING
static val mutable UNKNOWN_STRING: string
static val mutable UNKNOWN_STRING: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.VALUE_ASSIGNMENT_ERROR Field

StringConsts VALUE_ASSIGNMENT_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string VALUE_ASSIGNMENT_ERROR
public const string VALUE_ASSIGNMENT_ERROR
Public Const VALUE_ASSIGNMENT_ERROR As String
Public Const VALUE_ASSIGNMENT_ERROR As String
public:
literal String^ VALUE_ASSIGNMENT_ERROR
public:
literal String^ VALUE_ASSIGNMENT_ERROR
static val mutable VALUE_ASSIGNMENT_ERROR: string
static val mutable VALUE_ASSIGNMENT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.VIEW_MODIFY_ERROR Field

StringConsts VIEW_MODIFY_ERROR Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string VIEW_MODIFY_ERROR
public const string VIEW_MODIFY_ERROR
Public Const VIEW_MODIFY_ERROR As String
Public Const VIEW_MODIFY_ERROR As String
public:
literal String^ VIEW_MODIFY_ERROR
public:
literal String^ VIEW_MODIFY_ERROR
static val mutable VIEW_MODIFY_ERROR: string
static val mutable VIEW_MODIFY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringConsts.WORK_ITEM_NOT_AGGREGATABLE_ERROR Field

StringConsts WORK_ITEM_NOT_AGGREGATABLE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string WORK_ITEM_NOT_AGGREGATABLE_ERROR
public const string WORK_ITEM_NOT_AGGREGATABLE_ERROR
Public Const WORK_ITEM_NOT_AGGREGATABLE_ERROR As String
Public Const WORK_ITEM_NOT_AGGREGATABLE_ERROR As String
public:
literal String^ WORK_ITEM_NOT_AGGREGATABLE_ERROR
public:
literal String^ WORK_ITEM_NOT_AGGREGATABLE_ERROR
static val mutable WORK_ITEM_NOT_AGGREGATABLE_ERROR: string
static val mutable WORK_ITEM_NOT_AGGREGATABLE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX Namespace


StringValueConversion Class

StringValueConversion Class NFX Class Library

Provides extension methods for converting string values to different scalar types
Inheritance Hierarchy
Online System Object
NFX StringValueConversion

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class StringValueConversion
public static class StringValueConversion
<ExtensionAttribute>
Public NotInheritable Class StringValueConversion
<ExtensionAttribute>
Public NotInheritable Class StringValueConversion
[ExtensionAttribute]
public ref class StringValueConversion abstract sealed
[ExtensionAttribute]
public ref class StringValueConversion abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StringValueConversion =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StringValueConversion =  class end
See Also
StringValueConversion Members
NFX Namespace


StringValueConversion Members

StringValueConversion Members NFX Class Library

The StringValueConversion type exposes the following members.
Methods
Name | Description
AsBool |
AsByte |
AsByteArray |
AsDateTime |
AsDateTimeFormat |
AsDateTimeOrThrow |
AsDecimal |
AsDouble |
AsEnum TEnum |
AsFloat |
AsGDID |
AsGDIDSymbol |
AsGUID |
AsInt |
AsLong |
AsNullableBool |
AsNullableByte |
AsNullableDateTime |
AsNullableDecimal |
AsNullableDouble |
AsNullableEnum TEnum |
AsNullableFloat |
AsNullableGDID |
AsNullableGDIDSymbol |
AsNullableGUID |
AsNullableInt |
AsNullableLong |
AsNullableSByte |
AsNullableShort |
AsNullableTimeSpan |
AsNullableUInt |
AsNullableULong |
AsNullableUShort |
AsSByte |
AsShort |
AsString | Used by env var macros evaluator do not remove
AsStringWhenNullOrEmpty | Used by env var macros evaluator do not remove
AsTimeSpan |
AsTimeSpanOrThrow |
AsType | Tries to get a string value as specified type. When 'strict=false', tries to do some inference like return "true" for numbers that dont equal to zero etc. When 'strict=true' throws an exception if deterministic conversion is not possible
AsUInt |
AsULong |
AsUri |
AsUShort |
Back to Top
Fields
Name | Description
BYTE_ARRAY_SPLIT_CHARS |
Back to Top
See Also
StringValueConversion Class
NFX Namespace


StringValueConversion Fields

StringValueConversion Fields NFX Class Library

The StringValueConversion type exposes the following members.
Fields
Name | Description
BYTE_ARRAY_SPLIT_CHARS |
Back to Top
See Also
StringValueConversion Class
NFX Namespace


StringValueConversion.BYTE_ARRAY_SPLIT_CHARS Field

StringValueConversion BYTE_ARRAY_SPLIT_CHARS Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly char[] BYTE_ARRAY_SPLIT_CHARS
public static readonly char[] BYTE_ARRAY_SPLIT_CHARS
Public Shared ReadOnly BYTE_ARRAY_SPLIT_CHARS As Char()
Public Shared ReadOnly BYTE_ARRAY_SPLIT_CHARS As Char()
public:
static initonly array<wchar_t>^ BYTE_ARRAY_SPLIT_CHARS
public:
static initonly array<wchar_t>^ BYTE_ARRAY_SPLIT_CHARS
static val BYTE_ARRAY_SPLIT_CHARS: char[]
static val BYTE_ARRAY_SPLIT_CHARS: char[]

Field Value

Type: Online Char
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion Methods

StringValueConversion Methods NFX Class Library

The StringValueConversion type exposes the following members.
Methods
Name | Description
AsBool |
AsByte |
AsByteArray |
AsDateTime |
AsDateTimeFormat |
AsDateTimeOrThrow |
AsDecimal |
AsDouble |
AsEnum TEnum |
AsFloat |
AsGDID |
AsGDIDSymbol |
AsGUID |
AsInt |
AsLong |
AsNullableBool |
AsNullableByte |
AsNullableDateTime |
AsNullableDecimal |
AsNullableDouble |
AsNullableEnum TEnum |
AsNullableFloat |
AsNullableGDID |
AsNullableGDIDSymbol |
AsNullableGUID |
AsNullableInt |
AsNullableLong |
AsNullableSByte |
AsNullableShort |
AsNullableTimeSpan |
AsNullableUInt |
AsNullableULong |
AsNullableUShort |
AsSByte |
AsShort |
AsString | Used by env var macros evaluator do not remove
AsStringWhenNullOrEmpty | Used by env var macros evaluator do not remove
AsTimeSpan |
AsTimeSpanOrThrow |
AsType | Tries to get a string value as specified type. When 'strict=false', tries to do some inference like return "true" for numbers that dont equal to zero etc. When 'strict=true' throws an exception if deterministic conversion is not possible
AsUInt |
AsULong |
AsUri |
AsUShort |
Back to Top
See Also
StringValueConversion Class
NFX Namespace


StringValueConversion.AsBool Method

StringValueConversion AsBool Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool AsBool(
    this string val,
    bool dflt = false
)
public static bool AsBool(
    this string val,
    bool dflt = false
)
<ExtensionAttribute>
Public Shared Function AsBool (
    val As String,
    Optional dflt As Boolean = false
) As Boolean
<ExtensionAttribute>
Public Shared Function AsBool (
    val As String,
    Optional dflt As Boolean = false
) As Boolean
public:
[ExtensionAttribute]
static bool AsBool(
    String^ val,
    bool dflt = false
)
public:
[ExtensionAttribute]
static bool AsBool(
    String^ val,
    bool dflt = false
)
static member AsBool :
        val : string *
        ?dflt : bool
(* Defaults:
        let _dflt = defaultArg dflt false
*)
-> bool
static member AsBool :
        val : string *
        ?dflt : bool
(* Defaults:
        let _dflt = defaultArg dflt false
*)
-> bool

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Boolean

Return Value

Type: Online Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsByte Method

StringValueConversion AsByte Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte AsByte(
    this string val,
    byte dflt = 0
)
public static byte AsByte(
    this string val,
    byte dflt = 0
)
<ExtensionAttribute>
Public Shared Function AsByte (
    val As String,
    Optional dflt As Byte = 0
) As Byte
<ExtensionAttribute>
Public Shared Function AsByte (
    val As String,
    Optional dflt As Byte = 0
) As Byte
public:
[ExtensionAttribute]
static unsigned char AsByte(
    String^ val,
    unsigned char dflt = 0
)
public:
[ExtensionAttribute]
static unsigned char AsByte(
    String^ val,
    unsigned char dflt = 0
)
static member AsByte :
        val : string *
        ?dflt : byte
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> byte
static member AsByte :
        val : string *
        ?dflt : byte
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> byte

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Byte

Return Value

Type: Online Byte

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsByteArray Method

StringValueConversion AsByteArray Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte[] AsByteArray(
    this string val,
    byte[] dflt = null
)
public static byte[] AsByteArray(
    this string val,
    byte[] dflt = null
)
<ExtensionAttribute>
Public Shared Function AsByteArray (
    val As String,
    Optional dflt As Byte() = Nothing
) As Byte()
<ExtensionAttribute>
Public Shared Function AsByteArray (
    val As String,
    Optional dflt As Byte() = Nothing
) As Byte()
public:
[ExtensionAttribute]
static array<unsigned char>^ AsByteArray(
    String^ val,
    array<unsigned char>^ dflt = nullptr
)
public:
[ExtensionAttribute]
static array<unsigned char>^ AsByteArray(
    String^ val,
    array<unsigned char>^ dflt = nullptr
)
static member AsByteArray :
        val : string *
        ?dflt : byte[]
(* Defaults:
        let _dflt = defaultArg dflt null
*)
-> byte[]
static member AsByteArray :
        val : string *
        ?dflt : byte[]
(* Defaults:
        let _dflt = defaultArg dflt null
*)
-> byte[]

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Byte

Return Value

Type: Online Byte

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsDateTime Method

StringValueConversion AsDateTime Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DateTime AsDateTime(
    this string val,
    DateTime dflt
)
public static DateTime AsDateTime(
    this string val,
    DateTime dflt
)
<ExtensionAttribute>
Public Shared Function AsDateTime (
    val As String,
    dflt As DateTime
) As DateTime
<ExtensionAttribute>
Public Shared Function AsDateTime (
    val As String,
    dflt As DateTime
) As DateTime
public:
[ExtensionAttribute]
static DateTime AsDateTime(
    String^ val,
    DateTime dflt
)
public:
[ExtensionAttribute]
static DateTime AsDateTime(
    String^ val,
    DateTime dflt
)
static member AsDateTime :
        val : string *
        dflt : DateTime -> DateTime
static member AsDateTime :
        val : string *
        dflt : DateTime -> DateTime

Parameters

val
Type: Online System String
dflt
Type: Online System DateTime

Return Value

Type: Online DateTime

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsDateTimeFormat Method

StringValueConversion AsDateTimeFormat Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DateTime AsDateTimeFormat(
    this string val,
    DateTime dflt,
    string fmt,
    DateTimeStyles fmtStyles = DateTimeStyles.None
)
public static DateTime AsDateTimeFormat(
    this string val,
    DateTime dflt,
    string fmt,
    DateTimeStyles fmtStyles = DateTimeStyles.None
)
<ExtensionAttribute>
Public Shared Function AsDateTimeFormat (
    val As String,
    dflt As DateTime,
    fmt As String,
    Optional fmtStyles As DateTimeStyles = DateTimeStyles.None
) As DateTime
<ExtensionAttribute>
Public Shared Function AsDateTimeFormat (
    val As String,
    dflt As DateTime,
    fmt As String,
    Optional fmtStyles As DateTimeStyles = DateTimeStyles.None
) As DateTime
public:
[ExtensionAttribute]
static DateTime AsDateTimeFormat(
    String^ val,
    DateTime dflt,
    String^ fmt,
    DateTimeStyles fmtStyles = DateTimeStyles::None
)
public:
[ExtensionAttribute]
static DateTime AsDateTimeFormat(
    String^ val,
    DateTime dflt,
    String^ fmt,
    DateTimeStyles fmtStyles = DateTimeStyles::None
)
static member AsDateTimeFormat :
        val : string *
        dflt : DateTime *
        fmt : string *
        ?fmtStyles : DateTimeStyles
(* Defaults:
        let _fmtStyles = defaultArg fmtStyles DateTimeStyles.None
*)
-> DateTime
static member AsDateTimeFormat :
        val : string *
        dflt : DateTime *
        fmt : string *
        ?fmtStyles : DateTimeStyles
(* Defaults:
        let _fmtStyles = defaultArg fmtStyles DateTimeStyles.None
*)
-> DateTime

Parameters

val
Type: Online System String
dflt
Type: Online System DateTime
fmt
Type: Online System String
fmtStyles (Optional)
Type: Online System.Globalization DateTimeStyles

Return Value

Type: Online DateTime

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsDateTimeOrThrow Method

StringValueConversion AsDateTimeOrThrow Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DateTime AsDateTimeOrThrow(
    this string val
)
public static DateTime AsDateTimeOrThrow(
    this string val
)
<ExtensionAttribute>
Public Shared Function AsDateTimeOrThrow (
    val As String
) As DateTime
<ExtensionAttribute>
Public Shared Function AsDateTimeOrThrow (
    val As String
) As DateTime
public:
[ExtensionAttribute]
static DateTime AsDateTimeOrThrow(
    String^ val
)
public:
[ExtensionAttribute]
static DateTime AsDateTimeOrThrow(
    String^ val
)
static member AsDateTimeOrThrow :
        val : string -> DateTime
static member AsDateTimeOrThrow :
        val : string -> DateTime

Parameters

val
Type: Online System String

Return Value

Type: Online DateTime

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsDecimal Method

StringValueConversion AsDecimal Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static decimal AsDecimal(
    this string val,
    [OptionalAttribute] decimal dflt
)
public static decimal AsDecimal(
    this string val,
    [OptionalAttribute] decimal dflt
)
<ExtensionAttribute>
Public Shared Function AsDecimal (
    val As String,
    <OptionalAttribute> dflt As Decimal
) As Decimal
<ExtensionAttribute>
Public Shared Function AsDecimal (
    val As String,
    <OptionalAttribute> dflt As Decimal
) As Decimal
public:
[ExtensionAttribute]
static Decimal AsDecimal(
    String^ val,
    [OptionalAttribute] Decimal dflt
)
public:
[ExtensionAttribute]
static Decimal AsDecimal(
    String^ val,
    [OptionalAttribute] Decimal dflt
)
static member AsDecimal :
        val : string *
        [<OptionalAttribute>] dflt : decimal -> decimal
static member AsDecimal :
        val : string *
        [<OptionalAttribute>] dflt : decimal -> decimal

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Decimal

Return Value

Type: Online Decimal

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsDouble Method

StringValueConversion AsDouble Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static double AsDouble(
    this string val,
    double dflt = 0
)
public static double AsDouble(
    this string val,
    double dflt = 0
)
<ExtensionAttribute>
Public Shared Function AsDouble (
    val As String,
    Optional dflt As Double = 0
) As Double
<ExtensionAttribute>
Public Shared Function AsDouble (
    val As String,
    Optional dflt As Double = 0
) As Double
public:
[ExtensionAttribute]
static double AsDouble(
    String^ val,
    double dflt = 0
)
public:
[ExtensionAttribute]
static double AsDouble(
    String^ val,
    double dflt = 0
)
static member AsDouble :
        val : string *
        ?dflt : float
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> float
static member AsDouble :
        val : string *
        ?dflt : float
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> float

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Double

Return Value

Type: Online Double

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsEnum(TEnum) Method

StringValueConversion AsEnum TEnum Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TEnum AsEnum<TEnum>(
    this string val,
    TEnum dflt = null
)
where TEnum : struct, new()
public static TEnum AsEnum<TEnum>(
    this string val,
    TEnum dflt = null
)
where TEnum : struct, new()
<ExtensionAttribute>
Public Shared Function AsEnum(Of TEnum As {Structure, New}) (
    val As String,
    Optional dflt As TEnum = Nothing
) As TEnum
<ExtensionAttribute>
Public Shared Function AsEnum(Of TEnum As {Structure, New}) (
    val As String,
    Optional dflt As TEnum = Nothing
) As TEnum
public:
[ExtensionAttribute]
generic<typename TEnum>
where TEnum : value class, gcnew()
static TEnum AsEnum(
    String^ val,
    TEnum dflt = nullptr
)
public:
[ExtensionAttribute]
generic<typename TEnum>
where TEnum : value class, gcnew()
static TEnum AsEnum(
    String^ val,
    TEnum dflt = nullptr
)
static member AsEnum :
        val : string *
        ?dflt : 'TEnum
(* Defaults:
        let _dflt = defaultArg dflt null
*)
-> 'TEnum  when 'TEnum : struct, new()
static member AsEnum :
        val : string *
        ?dflt : 'TEnum
(* Defaults:
        let _dflt = defaultArg dflt null
*)
-> 'TEnum  when 'TEnum : struct, new()

Parameters

val
Type: Online System String
dflt (Optional)
Type: TEnum
Type Parameters
TEnum

Return Value

Type: TEnum

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsFloat Method

StringValueConversion AsFloat Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static float AsFloat(
    this string val,
    float dflt = 0f
)
public static float AsFloat(
    this string val,
    float dflt = 0f
)
<ExtensionAttribute>
Public Shared Function AsFloat (
    val As String,
    Optional dflt As Single = 0F
) As Single
<ExtensionAttribute>
Public Shared Function AsFloat (
    val As String,
    Optional dflt As Single = 0F
) As Single
public:
[ExtensionAttribute]
static float AsFloat(
    String^ val,
    float dflt = 0f
)
public:
[ExtensionAttribute]
static float AsFloat(
    String^ val,
    float dflt = 0f
)
static member AsFloat :
        val : string *
        ?dflt : float32
(* Defaults:
        let _dflt = defaultArg dflt 0f
*)
-> float32
static member AsFloat :
        val : string *
        ?dflt : float32
(* Defaults:
        let _dflt = defaultArg dflt 0f
*)
-> float32

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Single

Return Value

Type: Online Single

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsGDID Method

StringValueConversion AsGDID Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static GDID AsGDID(
    this string val,
    Nullable<GDID> dflt = null
)
public static GDID AsGDID(
    this string val,
    Nullable<GDID> dflt = null
)
<ExtensionAttribute>
Public Shared Function AsGDID (
    val As String,
    Optional dflt As Nullable(Of GDID) = Nothing
) As GDID
<ExtensionAttribute>
Public Shared Function AsGDID (
    val As String,
    Optional dflt As Nullable(Of GDID) = Nothing
) As GDID
public:
[ExtensionAttribute]
static GDID AsGDID(
    String^ val,
    Nullable<GDID> dflt = nullptr
)
public:
[ExtensionAttribute]
static GDID AsGDID(
    String^ val,
    Nullable<GDID> dflt = nullptr
)
static member AsGDID :
        val : string *
        ?dflt : Nullable<GDID>
(* Defaults:
        let _dflt = defaultArg dflt null
*)
-> GDID
static member AsGDID :
        val : string *
        ?dflt : Nullable<GDID>
(* Defaults:
        let _dflt = defaultArg dflt null
*)
-> GDID

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Nullable GDID

Return Value

Type: GDID

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsGDIDSymbol Method

StringValueConversion AsGDIDSymbol Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static GDIDSymbol AsGDIDSymbol(
    this string val,
    Nullable<GDIDSymbol> dflt = null
)
public static GDIDSymbol AsGDIDSymbol(
    this string val,
    Nullable<GDIDSymbol> dflt = null
)
<ExtensionAttribute>
Public Shared Function AsGDIDSymbol (
    val As String,
    Optional dflt As Nullable(Of GDIDSymbol) = Nothing
) As GDIDSymbol
<ExtensionAttribute>
Public Shared Function AsGDIDSymbol (
    val As String,
    Optional dflt As Nullable(Of GDIDSymbol) = Nothing
) As GDIDSymbol
public:
[ExtensionAttribute]
static GDIDSymbol AsGDIDSymbol(
    String^ val,
    Nullable<GDIDSymbol> dflt = nullptr
)
public:
[ExtensionAttribute]
static GDIDSymbol AsGDIDSymbol(
    String^ val,
    Nullable<GDIDSymbol> dflt = nullptr
)
static member AsGDIDSymbol :
        val : string *
        ?dflt : Nullable<GDIDSymbol>
(* Defaults:
        let _dflt = defaultArg dflt null
*)
-> GDIDSymbol
static member AsGDIDSymbol :
        val : string *
        ?dflt : Nullable<GDIDSymbol>
(* Defaults:
        let _dflt = defaultArg dflt null
*)
-> GDIDSymbol

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Nullable GDIDSymbol

Return Value

Type: GDIDSymbol

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsGUID Method

StringValueConversion AsGUID Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Guid AsGUID(
    this string val,
    Guid dflt
)
public static Guid AsGUID(
    this string val,
    Guid dflt
)
<ExtensionAttribute>
Public Shared Function AsGUID (
    val As String,
    dflt As Guid
) As Guid
<ExtensionAttribute>
Public Shared Function AsGUID (
    val As String,
    dflt As Guid
) As Guid
public:
[ExtensionAttribute]
static Guid AsGUID(
    String^ val,
    Guid dflt
)
public:
[ExtensionAttribute]
static Guid AsGUID(
    String^ val,
    Guid dflt
)
static member AsGUID :
        val : string *
        dflt : Guid -> Guid
static member AsGUID :
        val : string *
        dflt : Guid -> Guid

Parameters

val
Type: Online System String
dflt
Type: Online System Guid

Return Value

Type: Online Guid

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsInt Method

StringValueConversion AsInt Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int AsInt(
    this string val,
    int dflt = 0
)
public static int AsInt(
    this string val,
    int dflt = 0
)
<ExtensionAttribute>
Public Shared Function AsInt (
    val As String,
    Optional dflt As Integer = 0
) As Integer
<ExtensionAttribute>
Public Shared Function AsInt (
    val As String,
    Optional dflt As Integer = 0
) As Integer
public:
[ExtensionAttribute]
static int AsInt(
    String^ val,
    int dflt = 0
)
public:
[ExtensionAttribute]
static int AsInt(
    String^ val,
    int dflt = 0
)
static member AsInt :
        val : string *
        ?dflt : int
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> int
static member AsInt :
        val : string *
        ?dflt : int
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> int

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Int32

Return Value

Type: Online Int32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsLong Method

StringValueConversion AsLong Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long AsLong(
    this string val,
    long dflt = 0
)
public static long AsLong(
    this string val,
    long dflt = 0
)
<ExtensionAttribute>
Public Shared Function AsLong (
    val As String,
    Optional dflt As Long = 0
) As Long
<ExtensionAttribute>
Public Shared Function AsLong (
    val As String,
    Optional dflt As Long = 0
) As Long
public:
[ExtensionAttribute]
static long long AsLong(
    String^ val,
    long long dflt = 0
)
public:
[ExtensionAttribute]
static long long AsLong(
    String^ val,
    long long dflt = 0
)
static member AsLong :
        val : string *
        ?dflt : int64
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> int64
static member AsLong :
        val : string *
        ?dflt : int64
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> int64

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Int64

Return Value

Type: Online Int64

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsNullableBool Method

StringValueConversion AsNullableBool Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<bool> AsNullableBool(
    this string val,
    Nullable<bool> dflt = false
)
public static Nullable<bool> AsNullableBool(
    this string val,
    Nullable<bool> dflt = false
)
<ExtensionAttribute>
Public Shared Function AsNullableBool (
    val As String,
    Optional dflt As Nullable(Of Boolean) = false
) As Nullable(Of Boolean)
<ExtensionAttribute>
Public Shared Function AsNullableBool (
    val As String,
    Optional dflt As Nullable(Of Boolean) = false
) As Nullable(Of Boolean)
public:
[ExtensionAttribute]
static Nullable<bool> AsNullableBool(
    String^ val,
    Nullable<bool> dflt = false
)
public:
[ExtensionAttribute]
static Nullable<bool> AsNullableBool(
    String^ val,
    Nullable<bool> dflt = false
)
static member AsNullableBool :
        val : string *
        ?dflt : Nullable<bool>
(* Defaults:
        let _dflt = defaultArg dflt false
*)
-> Nullable<bool>
static member AsNullableBool :
        val : string *
        ?dflt : Nullable<bool>
(* Defaults:
        let _dflt = defaultArg dflt false
*)
-> Nullable<bool>

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Nullable Online Boolean

Return Value

Type: Online Nullable Online Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsNullableByte Method

StringValueConversion AsNullableByte Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<byte> AsNullableByte(
    this string val,
    Nullable<byte> dflt = 0
)
public static Nullable<byte> AsNullableByte(
    this string val,
    Nullable<byte> dflt = 0
)
<ExtensionAttribute>
Public Shared Function AsNullableByte (
    val As String,
    Optional dflt As Nullable(Of Byte) = 0
) As Nullable(Of Byte)
<ExtensionAttribute>
Public Shared Function AsNullableByte (
    val As String,
    Optional dflt As Nullable(Of Byte) = 0
) As Nullable(Of Byte)
public:
[ExtensionAttribute]
static Nullable<unsigned char> AsNullableByte(
    String^ val,
    Nullable<unsigned char> dflt = 0
)
public:
[ExtensionAttribute]
static Nullable<unsigned char> AsNullableByte(
    String^ val,
    Nullable<unsigned char> dflt = 0
)
static member AsNullableByte :
        val : string *
        ?dflt : Nullable<byte>
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> Nullable<byte>
static member AsNullableByte :
        val : string *
        ?dflt : Nullable<byte>
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> Nullable<byte>

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Nullable Online Byte

Return Value

Type: Online Nullable Online Byte

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsNullableDateTime Method

StringValueConversion AsNullableDateTime Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<DateTime> AsNullableDateTime(
    this string val,
    Nullable<DateTime> dflt = null
)
public static Nullable<DateTime> AsNullableDateTime(
    this string val,
    Nullable<DateTime> dflt = null
)
<ExtensionAttribute>
Public Shared Function AsNullableDateTime (
    val As String,
    Optional dflt As Nullable(Of DateTime) = Nothing
) As Nullable(Of DateTime)
<ExtensionAttribute>
Public Shared Function AsNullableDateTime (
    val As String,
    Optional dflt As Nullable(Of DateTime) = Nothing
) As Nullable(Of DateTime)
public:
[ExtensionAttribute]
static Nullable<DateTime> AsNullableDateTime(
    String^ val,
    Nullable<DateTime> dflt = nullptr
)
public:
[ExtensionAttribute]
static Nullable<DateTime> AsNullableDateTime(
    String^ val,
    Nullable<DateTime> dflt = nullptr
)
static member AsNullableDateTime :
        val : string *
        ?dflt : Nullable<DateTime>
(* Defaults:
        let _dflt = defaultArg dflt null
*)
-> Nullable<DateTime>
static member AsNullableDateTime :
        val : string *
        ?dflt : Nullable<DateTime>
(* Defaults:
        let _dflt = defaultArg dflt null
*)
-> Nullable<DateTime>

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Nullable Online DateTime

Return Value

Type: Online Nullable Online DateTime

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsNullableDecimal Method

StringValueConversion AsNullableDecimal Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<decimal> AsNullableDecimal(
    this string val,
    [OptionalAttribute] Nullable<decimal> dflt
)
public static Nullable<decimal> AsNullableDecimal(
    this string val,
    [OptionalAttribute] Nullable<decimal> dflt
)
<ExtensionAttribute>
Public Shared Function AsNullableDecimal (
    val As String,
    <OptionalAttribute> dflt As Nullable(Of Decimal)
) As Nullable(Of Decimal)
<ExtensionAttribute>
Public Shared Function AsNullableDecimal (
    val As String,
    <OptionalAttribute> dflt As Nullable(Of Decimal)
) As Nullable(Of Decimal)
public:
[ExtensionAttribute]
static Nullable<Decimal> AsNullableDecimal(
    String^ val,
    [OptionalAttribute] Nullable<Decimal> dflt
)
public:
[ExtensionAttribute]
static Nullable<Decimal> AsNullableDecimal(
    String^ val,
    [OptionalAttribute] Nullable<Decimal> dflt
)
static member AsNullableDecimal :
        val : string *
        [<OptionalAttribute>] dflt : Nullable<decimal> -> Nullable<decimal>
static member AsNullableDecimal :
        val : string *
        [<OptionalAttribute>] dflt : Nullable<decimal> -> Nullable<decimal>

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Nullable Online Decimal

Return Value

Type: Online Nullable Online Decimal

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsNullableDouble Method

StringValueConversion AsNullableDouble Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<double> AsNullableDouble(
    this string val,
    Nullable<double> dflt = 0
)
public static Nullable<double> AsNullableDouble(
    this string val,
    Nullable<double> dflt = 0
)
<ExtensionAttribute>
Public Shared Function AsNullableDouble (
    val As String,
    Optional dflt As Nullable(Of Double) = 0
) As Nullable(Of Double)
<ExtensionAttribute>
Public Shared Function AsNullableDouble (
    val As String,
    Optional dflt As Nullable(Of Double) = 0
) As Nullable(Of Double)
public:
[ExtensionAttribute]
static Nullable<double> AsNullableDouble(
    String^ val,
    Nullable<double> dflt = 0
)
public:
[ExtensionAttribute]
static Nullable<double> AsNullableDouble(
    String^ val,
    Nullable<double> dflt = 0
)
static member AsNullableDouble :
        val : string *
        ?dflt : Nullable<float>
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> Nullable<float>
static member AsNullableDouble :
        val : string *
        ?dflt : Nullable<float>
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> Nullable<float>

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Nullable Online Double

Return Value

Type: Online Nullable Online Double

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsNullableEnum(TEnum) Method

StringValueConversion AsNullableEnum TEnum Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<TEnum> AsNullableEnum<TEnum>(
    this string val,
    Nullable<TEnum> dflt = null
)
where TEnum : struct, new()
public static Nullable<TEnum> AsNullableEnum<TEnum>(
    this string val,
    Nullable<TEnum> dflt = null
)
where TEnum : struct, new()
<ExtensionAttribute>
Public Shared Function AsNullableEnum(Of TEnum As {Structure, New}) (
    val As String,
    Optional dflt As Nullable(Of TEnum) = Nothing
) As Nullable(Of TEnum)
<ExtensionAttribute>
Public Shared Function AsNullableEnum(Of TEnum As {Structure, New}) (
    val As String,
    Optional dflt As Nullable(Of TEnum) = Nothing
) As Nullable(Of TEnum)
public:
[ExtensionAttribute]
generic<typename TEnum>
where TEnum : value class, gcnew()
static Nullable<TEnum> AsNullableEnum(
    String^ val,
    Nullable<TEnum> dflt = nullptr
)
public:
[ExtensionAttribute]
generic<typename TEnum>
where TEnum : value class, gcnew()
static Nullable<TEnum> AsNullableEnum(
    String^ val,
    Nullable<TEnum> dflt = nullptr
)
static member AsNullableEnum :
        val : string *
        ?dflt : Nullable<'TEnum>
(* Defaults:
        let _dflt = defaultArg dflt null
*)
-> Nullable<'TEnum>  when 'TEnum : struct, new()
static member AsNullableEnum :
        val : string *
        ?dflt : Nullable<'TEnum>
(* Defaults:
        let _dflt = defaultArg dflt null
*)
-> Nullable<'TEnum>  when 'TEnum : struct, new()

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Nullable TEnum
Type Parameters
TEnum

Return Value

Type: Online Nullable TEnum

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsNullableFloat Method

StringValueConversion AsNullableFloat Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<float> AsNullableFloat(
    this string val,
    Nullable<float> dflt = 0f
)
public static Nullable<float> AsNullableFloat(
    this string val,
    Nullable<float> dflt = 0f
)
<ExtensionAttribute>
Public Shared Function AsNullableFloat (
    val As String,
    Optional dflt As Nullable(Of Single) = 0F
) As Nullable(Of Single)
<ExtensionAttribute>
Public Shared Function AsNullableFloat (
    val As String,
    Optional dflt As Nullable(Of Single) = 0F
) As Nullable(Of Single)
public:
[ExtensionAttribute]
static Nullable<float> AsNullableFloat(
    String^ val,
    Nullable<float> dflt = 0f
)
public:
[ExtensionAttribute]
static Nullable<float> AsNullableFloat(
    String^ val,
    Nullable<float> dflt = 0f
)
static member AsNullableFloat :
        val : string *
        ?dflt : Nullable<float32>
(* Defaults:
        let _dflt = defaultArg dflt 0f
*)
-> Nullable<float32>
static member AsNullableFloat :
        val : string *
        ?dflt : Nullable<float32>
(* Defaults:
        let _dflt = defaultArg dflt 0f
*)
-> Nullable<float32>

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Nullable Online Single

Return Value

Type: Online Nullable Online Single

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsNullableGDID Method

StringValueConversion AsNullableGDID Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<GDID> AsNullableGDID(
    this string val,
    Nullable<GDID> dflt = null
)
public static Nullable<GDID> AsNullableGDID(
    this string val,
    Nullable<GDID> dflt = null
)
<ExtensionAttribute>
Public Shared Function AsNullableGDID (
    val As String,
    Optional dflt As Nullable(Of GDID) = Nothing
) As Nullable(Of GDID)
<ExtensionAttribute>
Public Shared Function AsNullableGDID (
    val As String,
    Optional dflt As Nullable(Of GDID) = Nothing
) As Nullable(Of GDID)
public:
[ExtensionAttribute]
static Nullable<GDID> AsNullableGDID(
    String^ val,
    Nullable<GDID> dflt = nullptr
)
public:
[ExtensionAttribute]
static Nullable<GDID> AsNullableGDID(
    String^ val,
    Nullable<GDID> dflt = nullptr
)
static member AsNullableGDID :
        val : string *
        ?dflt : Nullable<GDID>
(* Defaults:
        let _dflt = defaultArg dflt null
*)
-> Nullable<GDID>
static member AsNullableGDID :
        val : string *
        ?dflt : Nullable<GDID>
(* Defaults:
        let _dflt = defaultArg dflt null
*)
-> Nullable<GDID>

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Nullable GDID

Return Value

Type: Online Nullable GDID

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsNullableGDIDSymbol Method

StringValueConversion AsNullableGDIDSymbol Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<GDIDSymbol> AsNullableGDIDSymbol(
    this string val,
    Nullable<GDIDSymbol> dflt = null
)
public static Nullable<GDIDSymbol> AsNullableGDIDSymbol(
    this string val,
    Nullable<GDIDSymbol> dflt = null
)
<ExtensionAttribute>
Public Shared Function AsNullableGDIDSymbol (
    val As String,
    Optional dflt As Nullable(Of GDIDSymbol) = Nothing
) As Nullable(Of GDIDSymbol)
<ExtensionAttribute>
Public Shared Function AsNullableGDIDSymbol (
    val As String,
    Optional dflt As Nullable(Of GDIDSymbol) = Nothing
) As Nullable(Of GDIDSymbol)
public:
[ExtensionAttribute]
static Nullable<GDIDSymbol> AsNullableGDIDSymbol(
    String^ val,
    Nullable<GDIDSymbol> dflt = nullptr
)
public:
[ExtensionAttribute]
static Nullable<GDIDSymbol> AsNullableGDIDSymbol(
    String^ val,
    Nullable<GDIDSymbol> dflt = nullptr
)
static member AsNullableGDIDSymbol :
        val : string *
        ?dflt : Nullable<GDIDSymbol>
(* Defaults:
        let _dflt = defaultArg dflt null
*)
-> Nullable<GDIDSymbol>
static member AsNullableGDIDSymbol :
        val : string *
        ?dflt : Nullable<GDIDSymbol>
(* Defaults:
        let _dflt = defaultArg dflt null
*)
-> Nullable<GDIDSymbol>

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Nullable GDIDSymbol

Return Value

Type: Online Nullable GDIDSymbol

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsNullableGUID Method

StringValueConversion AsNullableGUID Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<Guid> AsNullableGUID(
    this string val,
    Nullable<Guid> dflt = null
)
public static Nullable<Guid> AsNullableGUID(
    this string val,
    Nullable<Guid> dflt = null
)
<ExtensionAttribute>
Public Shared Function AsNullableGUID (
    val As String,
    Optional dflt As Nullable(Of Guid) = Nothing
) As Nullable(Of Guid)
<ExtensionAttribute>
Public Shared Function AsNullableGUID (
    val As String,
    Optional dflt As Nullable(Of Guid) = Nothing
) As Nullable(Of Guid)
public:
[ExtensionAttribute]
static Nullable<Guid> AsNullableGUID(
    String^ val,
    Nullable<Guid> dflt = nullptr
)
public:
[ExtensionAttribute]
static Nullable<Guid> AsNullableGUID(
    String^ val,
    Nullable<Guid> dflt = nullptr
)
static member AsNullableGUID :
        val : string *
        ?dflt : Nullable<Guid>
(* Defaults:
        let _dflt = defaultArg dflt null
*)
-> Nullable<Guid>
static member AsNullableGUID :
        val : string *
        ?dflt : Nullable<Guid>
(* Defaults:
        let _dflt = defaultArg dflt null
*)
-> Nullable<Guid>

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Nullable Online Guid

Return Value

Type: Online Nullable Online Guid

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsNullableInt Method

StringValueConversion AsNullableInt Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<int> AsNullableInt(
    this string val,
    Nullable<int> dflt = 0
)
public static Nullable<int> AsNullableInt(
    this string val,
    Nullable<int> dflt = 0
)
<ExtensionAttribute>
Public Shared Function AsNullableInt (
    val As String,
    Optional dflt As Nullable(Of Integer) = 0
) As Nullable(Of Integer)
<ExtensionAttribute>
Public Shared Function AsNullableInt (
    val As String,
    Optional dflt As Nullable(Of Integer) = 0
) As Nullable(Of Integer)
public:
[ExtensionAttribute]
static Nullable<int> AsNullableInt(
    String^ val,
    Nullable<int> dflt = 0
)
public:
[ExtensionAttribute]
static Nullable<int> AsNullableInt(
    String^ val,
    Nullable<int> dflt = 0
)
static member AsNullableInt :
        val : string *
        ?dflt : Nullable<int>
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> Nullable<int>
static member AsNullableInt :
        val : string *
        ?dflt : Nullable<int>
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> Nullable<int>

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Nullable Online Int32

Return Value

Type: Online Nullable Online Int32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsNullableLong Method

StringValueConversion AsNullableLong Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<long> AsNullableLong(
    this string val,
    Nullable<long> dflt = 0
)
public static Nullable<long> AsNullableLong(
    this string val,
    Nullable<long> dflt = 0
)
<ExtensionAttribute>
Public Shared Function AsNullableLong (
    val As String,
    Optional dflt As Nullable(Of Long) = 0
) As Nullable(Of Long)
<ExtensionAttribute>
Public Shared Function AsNullableLong (
    val As String,
    Optional dflt As Nullable(Of Long) = 0
) As Nullable(Of Long)
public:
[ExtensionAttribute]
static Nullable<long long> AsNullableLong(
    String^ val,
    Nullable<long long> dflt = 0
)
public:
[ExtensionAttribute]
static Nullable<long long> AsNullableLong(
    String^ val,
    Nullable<long long> dflt = 0
)
static member AsNullableLong :
        val : string *
        ?dflt : Nullable<int64>
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> Nullable<int64>
static member AsNullableLong :
        val : string *
        ?dflt : Nullable<int64>
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> Nullable<int64>

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Nullable Online Int64

Return Value

Type: Online Nullable Online Int64

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsNullableSByte Method

StringValueConversion AsNullableSByte Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<sbyte> AsNullableSByte(
    this string val,
    Nullable<sbyte> dflt = 0
)
public static Nullable<sbyte> AsNullableSByte(
    this string val,
    Nullable<sbyte> dflt = 0
)
<ExtensionAttribute>
Public Shared Function AsNullableSByte (
    val As String,
    Optional dflt As Nullable(Of SByte) = 0
) As Nullable(Of SByte)
<ExtensionAttribute>
Public Shared Function AsNullableSByte (
    val As String,
    Optional dflt As Nullable(Of SByte) = 0
) As Nullable(Of SByte)
public:
[ExtensionAttribute]
static Nullable<signed char> AsNullableSByte(
    String^ val,
    Nullable<signed char> dflt = 0
)
public:
[ExtensionAttribute]
static Nullable<signed char> AsNullableSByte(
    String^ val,
    Nullable<signed char> dflt = 0
)
static member AsNullableSByte :
        val : string *
        ?dflt : Nullable<sbyte>
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> Nullable<sbyte>
static member AsNullableSByte :
        val : string *
        ?dflt : Nullable<sbyte>
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> Nullable<sbyte>

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Nullable Online SByte

Return Value

Type: Online Nullable Online SByte

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsNullableShort Method

StringValueConversion AsNullableShort Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<short> AsNullableShort(
    this string val,
    Nullable<short> dflt = 0
)
public static Nullable<short> AsNullableShort(
    this string val,
    Nullable<short> dflt = 0
)
<ExtensionAttribute>
Public Shared Function AsNullableShort (
    val As String,
    Optional dflt As Nullable(Of Short) = 0
) As Nullable(Of Short)
<ExtensionAttribute>
Public Shared Function AsNullableShort (
    val As String,
    Optional dflt As Nullable(Of Short) = 0
) As Nullable(Of Short)
public:
[ExtensionAttribute]
static Nullable<short> AsNullableShort(
    String^ val,
    Nullable<short> dflt = 0
)
public:
[ExtensionAttribute]
static Nullable<short> AsNullableShort(
    String^ val,
    Nullable<short> dflt = 0
)
static member AsNullableShort :
        val : string *
        ?dflt : Nullable<int16>
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> Nullable<int16>
static member AsNullableShort :
        val : string *
        ?dflt : Nullable<int16>
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> Nullable<int16>

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Nullable Online Int16

Return Value

Type: Online Nullable Online Int16

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsNullableTimeSpan Method

StringValueConversion AsNullableTimeSpan Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<TimeSpan> AsNullableTimeSpan(
    this string val,
    Nullable<TimeSpan> dflt = null
)
public static Nullable<TimeSpan> AsNullableTimeSpan(
    this string val,
    Nullable<TimeSpan> dflt = null
)
<ExtensionAttribute>
Public Shared Function AsNullableTimeSpan (
    val As String,
    Optional dflt As Nullable(Of TimeSpan) = Nothing
) As Nullable(Of TimeSpan)
<ExtensionAttribute>
Public Shared Function AsNullableTimeSpan (
    val As String,
    Optional dflt As Nullable(Of TimeSpan) = Nothing
) As Nullable(Of TimeSpan)
public:
[ExtensionAttribute]
static Nullable<TimeSpan> AsNullableTimeSpan(
    String^ val,
    Nullable<TimeSpan> dflt = nullptr
)
public:
[ExtensionAttribute]
static Nullable<TimeSpan> AsNullableTimeSpan(
    String^ val,
    Nullable<TimeSpan> dflt = nullptr
)
static member AsNullableTimeSpan :
        val : string *
        ?dflt : Nullable<TimeSpan>
(* Defaults:
        let _dflt = defaultArg dflt null
*)
-> Nullable<TimeSpan>
static member AsNullableTimeSpan :
        val : string *
        ?dflt : Nullable<TimeSpan>
(* Defaults:
        let _dflt = defaultArg dflt null
*)
-> Nullable<TimeSpan>

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Nullable Online TimeSpan

Return Value

Type: Online Nullable Online TimeSpan

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsNullableUInt Method

StringValueConversion AsNullableUInt Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<uint> AsNullableUInt(
    this string val,
    Nullable<uint> dflt = 0
)
public static Nullable<uint> AsNullableUInt(
    this string val,
    Nullable<uint> dflt = 0
)
<ExtensionAttribute>
Public Shared Function AsNullableUInt (
    val As String,
    Optional dflt As Nullable(Of UInteger) = 0
) As Nullable(Of UInteger)
<ExtensionAttribute>
Public Shared Function AsNullableUInt (
    val As String,
    Optional dflt As Nullable(Of UInteger) = 0
) As Nullable(Of UInteger)
public:
[ExtensionAttribute]
static Nullable<unsigned int> AsNullableUInt(
    String^ val,
    Nullable<unsigned int> dflt = 0
)
public:
[ExtensionAttribute]
static Nullable<unsigned int> AsNullableUInt(
    String^ val,
    Nullable<unsigned int> dflt = 0
)
static member AsNullableUInt :
        val : string *
        ?dflt : Nullable<uint32>
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> Nullable<uint32>
static member AsNullableUInt :
        val : string *
        ?dflt : Nullable<uint32>
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> Nullable<uint32>

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Nullable Online UInt32

Return Value

Type: Online Nullable Online UInt32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsNullableULong Method

StringValueConversion AsNullableULong Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<ulong> AsNullableULong(
    this string val,
    Nullable<ulong> dflt = 0
)
public static Nullable<ulong> AsNullableULong(
    this string val,
    Nullable<ulong> dflt = 0
)
<ExtensionAttribute>
Public Shared Function AsNullableULong (
    val As String,
    Optional dflt As Nullable(Of ULong) = 0
) As Nullable(Of ULong)
<ExtensionAttribute>
Public Shared Function AsNullableULong (
    val As String,
    Optional dflt As Nullable(Of ULong) = 0
) As Nullable(Of ULong)
public:
[ExtensionAttribute]
static Nullable<unsigned long long> AsNullableULong(
    String^ val,
    Nullable<unsigned long long> dflt = 0
)
public:
[ExtensionAttribute]
static Nullable<unsigned long long> AsNullableULong(
    String^ val,
    Nullable<unsigned long long> dflt = 0
)
static member AsNullableULong :
        val : string *
        ?dflt : Nullable<uint64>
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> Nullable<uint64>
static member AsNullableULong :
        val : string *
        ?dflt : Nullable<uint64>
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> Nullable<uint64>

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Nullable Online UInt64

Return Value

Type: Online Nullable Online UInt64

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsNullableUShort Method

StringValueConversion AsNullableUShort Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Nullable<ushort> AsNullableUShort(
    this string val,
    Nullable<ushort> dflt = 0
)
public static Nullable<ushort> AsNullableUShort(
    this string val,
    Nullable<ushort> dflt = 0
)
<ExtensionAttribute>
Public Shared Function AsNullableUShort (
    val As String,
    Optional dflt As Nullable(Of UShort) = 0
) As Nullable(Of UShort)
<ExtensionAttribute>
Public Shared Function AsNullableUShort (
    val As String,
    Optional dflt As Nullable(Of UShort) = 0
) As Nullable(Of UShort)
public:
[ExtensionAttribute]
static Nullable<unsigned short> AsNullableUShort(
    String^ val,
    Nullable<unsigned short> dflt = 0
)
public:
[ExtensionAttribute]
static Nullable<unsigned short> AsNullableUShort(
    String^ val,
    Nullable<unsigned short> dflt = 0
)
static member AsNullableUShort :
        val : string *
        ?dflt : Nullable<uint16>
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> Nullable<uint16>
static member AsNullableUShort :
        val : string *
        ?dflt : Nullable<uint16>
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> Nullable<uint16>

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Nullable Online UInt16

Return Value

Type: Online Nullable Online UInt16

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsSByte Method

StringValueConversion AsSByte Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static sbyte AsSByte(
    this string val,
    sbyte dflt = 0
)
public static sbyte AsSByte(
    this string val,
    sbyte dflt = 0
)
<ExtensionAttribute>
Public Shared Function AsSByte (
    val As String,
    Optional dflt As SByte = 0
) As SByte
<ExtensionAttribute>
Public Shared Function AsSByte (
    val As String,
    Optional dflt As SByte = 0
) As SByte
public:
[ExtensionAttribute]
static signed char AsSByte(
    String^ val,
    signed char dflt = 0
)
public:
[ExtensionAttribute]
static signed char AsSByte(
    String^ val,
    signed char dflt = 0
)
static member AsSByte :
        val : string *
        ?dflt : sbyte
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> sbyte
static member AsSByte :
        val : string *
        ?dflt : sbyte
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> sbyte

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System SByte

Return Value

Type: Online SByte

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsShort Method

StringValueConversion AsShort Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static short AsShort(
    this string val,
    short dflt = 0
)
public static short AsShort(
    this string val,
    short dflt = 0
)
<ExtensionAttribute>
Public Shared Function AsShort (
    val As String,
    Optional dflt As Short = 0
) As Short
<ExtensionAttribute>
Public Shared Function AsShort (
    val As String,
    Optional dflt As Short = 0
) As Short
public:
[ExtensionAttribute]
static short AsShort(
    String^ val,
    short dflt = 0
)
public:
[ExtensionAttribute]
static short AsShort(
    String^ val,
    short dflt = 0
)
static member AsShort :
        val : string *
        ?dflt : int16
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> int16
static member AsShort :
        val : string *
        ?dflt : int16
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> int16

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Int16

Return Value

Type: Online Int16

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsString Method

StringValueConversion AsString Method NFX Class Library

Used by env var macros evaluator do not remove

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string AsString(
    this string val,
    string dflt = ""
)
public static string AsString(
    this string val,
    string dflt = ""
)
<ExtensionAttribute>
Public Shared Function AsString (
    val As String,
    Optional dflt As String = ""
) As String
<ExtensionAttribute>
Public Shared Function AsString (
    val As String,
    Optional dflt As String = ""
) As String
public:
[ExtensionAttribute]
static String^ AsString(
    String^ val,
    String^ dflt = L""
)
public:
[ExtensionAttribute]
static String^ AsString(
    String^ val,
    String^ dflt = L""
)
static member AsString :
        val : string *
        ?dflt : string
(* Defaults:
        let _dflt = defaultArg dflt ""
*)
-> string
static member AsString :
        val : string *
        ?dflt : string
(* Defaults:
        let _dflt = defaultArg dflt ""
*)
-> string

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System String

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsStringWhenNullOrEmpty Method

StringValueConversion AsStringWhenNullOrEmpty Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Used by env var macros evaluator do not remove

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string AsStringWhenNullOrEmpty(
    this string val,
    string dflt = ""
)
public static string AsStringWhenNullOrEmpty(
    this string val,
    string dflt = ""
)
<ExtensionAttribute>
Public Shared Function AsStringWhenNullOrEmpty (
    val As String,
    Optional dflt As String = ""
) As String
<ExtensionAttribute>
Public Shared Function AsStringWhenNullOrEmpty (
    val As String,
    Optional dflt As String = ""
) As String
public:
[ExtensionAttribute]
static String^ AsStringWhenNullOrEmpty(
    String^ val,
    String^ dflt = L""
)
public:
[ExtensionAttribute]
static String^ AsStringWhenNullOrEmpty(
    String^ val,
    String^ dflt = L""
)
static member AsStringWhenNullOrEmpty :
        val : string *
        ?dflt : string
(* Defaults:
        let _dflt = defaultArg dflt ""
*)
-> string
static member AsStringWhenNullOrEmpty :
        val : string *
        ?dflt : string
(* Defaults:
        let _dflt = defaultArg dflt ""
*)
-> string

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System String

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsTimeSpan Method

StringValueConversion AsTimeSpan Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TimeSpan AsTimeSpan(
    this string val,
    TimeSpan dflt
)
public static TimeSpan AsTimeSpan(
    this string val,
    TimeSpan dflt
)
<ExtensionAttribute>
Public Shared Function AsTimeSpan (
    val As String,
    dflt As TimeSpan
) As TimeSpan
<ExtensionAttribute>
Public Shared Function AsTimeSpan (
    val As String,
    dflt As TimeSpan
) As TimeSpan
public:
[ExtensionAttribute]
static TimeSpan AsTimeSpan(
    String^ val,
    TimeSpan dflt
)
public:
[ExtensionAttribute]
static TimeSpan AsTimeSpan(
    String^ val,
    TimeSpan dflt
)
static member AsTimeSpan :
        val : string *
        dflt : TimeSpan -> TimeSpan
static member AsTimeSpan :
        val : string *
        dflt : TimeSpan -> TimeSpan

Parameters

val
Type: Online System String
dflt
Type: Online System TimeSpan

Return Value

Type: Online TimeSpan

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsTimeSpanOrThrow Method

StringValueConversion AsTimeSpanOrThrow Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TimeSpan AsTimeSpanOrThrow(
    this string val
)
public static TimeSpan AsTimeSpanOrThrow(
    this string val
)
<ExtensionAttribute>
Public Shared Function AsTimeSpanOrThrow (
    val As String
) As TimeSpan
<ExtensionAttribute>
Public Shared Function AsTimeSpanOrThrow (
    val As String
) As TimeSpan
public:
[ExtensionAttribute]
static TimeSpan AsTimeSpanOrThrow(
    String^ val
)
public:
[ExtensionAttribute]
static TimeSpan AsTimeSpanOrThrow(
    String^ val
)
static member AsTimeSpanOrThrow :
        val : string -> TimeSpan
static member AsTimeSpanOrThrow :
        val : string -> TimeSpan

Parameters

val
Type: Online System String

Return Value

Type: Online TimeSpan

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsType Method

StringValueConversion AsType Method NFX Class Library

Tries to get a string value as specified type. When 'strict=false', tries to do some inference like return "true" for numbers that dont equal to zero etc. When 'strict=true' throws an exception if deterministic conversion is not possible

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Object AsType(
    this string val,
    Type tp,
    bool strict = true
)
public static Object AsType(
    this string val,
    Type tp,
    bool strict = true
)
<ExtensionAttribute>
Public Shared Function AsType (
    val As String,
    tp As Type,
    Optional strict As Boolean = true
) As Object
<ExtensionAttribute>
Public Shared Function AsType (
    val As String,
    tp As Type,
    Optional strict As Boolean = true
) As Object
public:
[ExtensionAttribute]
static Object^ AsType(
    String^ val,
    Type^ tp,
    bool strict = true
)
public:
[ExtensionAttribute]
static Object^ AsType(
    String^ val,
    Type^ tp,
    bool strict = true
)
static member AsType :
        val : string *
        tp : Type *
        ?strict : bool
(* Defaults:
        let _strict = defaultArg strict true
*)
-> Object
static member AsType :
        val : string *
        tp : Type *
        ?strict : bool
(* Defaults:
        let _strict = defaultArg strict true
*)
-> Object

Parameters

val
Type: Online System String
tp
Type: Online System Type
strict (Optional)
Type: Online System Boolean

Return Value

Type: Online Object

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsUInt Method

StringValueConversion AsUInt Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static uint AsUInt(
    this string val,
    uint dflt = 0
)
public static uint AsUInt(
    this string val,
    uint dflt = 0
)
<ExtensionAttribute>
Public Shared Function AsUInt (
    val As String,
    Optional dflt As UInteger = 0
) As UInteger
<ExtensionAttribute>
Public Shared Function AsUInt (
    val As String,
    Optional dflt As UInteger = 0
) As UInteger
public:
[ExtensionAttribute]
static unsigned int AsUInt(
    String^ val,
    unsigned int dflt = 0
)
public:
[ExtensionAttribute]
static unsigned int AsUInt(
    String^ val,
    unsigned int dflt = 0
)
static member AsUInt :
        val : string *
        ?dflt : uint32
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> uint32
static member AsUInt :
        val : string *
        ?dflt : uint32
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> uint32

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System UInt32

Return Value

Type: Online UInt32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsULong Method

StringValueConversion AsULong Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ulong AsULong(
    this string val,
    ulong dflt = 0
)
public static ulong AsULong(
    this string val,
    ulong dflt = 0
)
<ExtensionAttribute>
Public Shared Function AsULong (
    val As String,
    Optional dflt As ULong = 0
) As ULong
<ExtensionAttribute>
Public Shared Function AsULong (
    val As String,
    Optional dflt As ULong = 0
) As ULong
public:
[ExtensionAttribute]
static unsigned long long AsULong(
    String^ val,
    unsigned long long dflt = 0
)
public:
[ExtensionAttribute]
static unsigned long long AsULong(
    String^ val,
    unsigned long long dflt = 0
)
static member AsULong :
        val : string *
        ?dflt : uint64
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> uint64
static member AsULong :
        val : string *
        ?dflt : uint64
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> uint64

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System UInt64

Return Value

Type: Online UInt64

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsUri Method

StringValueConversion AsUri Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Uri AsUri(
    this string val,
    Uri dflt = null
)
public static Uri AsUri(
    this string val,
    Uri dflt = null
)
<ExtensionAttribute>
Public Shared Function AsUri (
    val As String,
    Optional dflt As Uri = Nothing
) As Uri
<ExtensionAttribute>
Public Shared Function AsUri (
    val As String,
    Optional dflt As Uri = Nothing
) As Uri
public:
[ExtensionAttribute]
static Uri^ AsUri(
    String^ val,
    Uri^ dflt = nullptr
)
public:
[ExtensionAttribute]
static Uri^ AsUri(
    String^ val,
    Uri^ dflt = nullptr
)
static member AsUri :
        val : string *
        ?dflt : Uri
(* Defaults:
        let _dflt = defaultArg dflt null
*)
-> Uri
static member AsUri :
        val : string *
        ?dflt : Uri
(* Defaults:
        let _dflt = defaultArg dflt null
*)
-> Uri

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System Uri

Return Value

Type: Online Uri

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


StringValueConversion.AsUShort Method

StringValueConversion AsUShort Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ushort AsUShort(
    this string val,
    ushort dflt = 0
)
public static ushort AsUShort(
    this string val,
    ushort dflt = 0
)
<ExtensionAttribute>
Public Shared Function AsUShort (
    val As String,
    Optional dflt As UShort = 0
) As UShort
<ExtensionAttribute>
Public Shared Function AsUShort (
    val As String,
    Optional dflt As UShort = 0
) As UShort
public:
[ExtensionAttribute]
static unsigned short AsUShort(
    String^ val,
    unsigned short dflt = 0
)
public:
[ExtensionAttribute]
static unsigned short AsUShort(
    String^ val,
    unsigned short dflt = 0
)
static member AsUShort :
        val : string *
        ?dflt : uint16
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> uint16
static member AsUShort :
        val : string *
        ?dflt : uint16
(* Defaults:
        let _dflt = defaultArg dflt 0
*)
-> uint16

Parameters

val
Type: Online System String
dflt (Optional)
Type: Online System UInt16

Return Value

Type: Online UInt16

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
StringValueConversion Class
StringValueConversion Members
NFX Namespace


TaskUtils Class

TaskUtils Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX TaskUtils

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class TaskUtils
public static class TaskUtils
<ExtensionAttribute>
Public NotInheritable Class TaskUtils
<ExtensionAttribute>
Public NotInheritable Class TaskUtils
[ExtensionAttribute]
public ref class TaskUtils abstract sealed
[ExtensionAttribute]
public ref class TaskUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type TaskUtils =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type TaskUtils =  class end
See Also
TaskUtils Members
NFX Namespace


TaskUtils Members

TaskUtils Members NFX Class Library

The TaskUtils type exposes the following members.
Methods
Name | Description
AsCompletedTask(Action) | Non-generic version of AsCompletedTask T (Func T )
AsCompletedTask T (Func T ) | Returns task completed from a synchronous functor
AssignWorkSegment | Returns the count of items in work segment along with the start index of the first item to be processed by a particular worker in the worker set
OnError | Registers action executed if task was faulted or cancelled
OnOk(Task, Action, TaskContinuationOptions) | Chains task 'first' with 'next' if first is completed, not cancelled and not faulted. Returns task that completes when 'next' completes
OnOk T1 (Task T1 , Action T1 , TaskContinuationOptions) | Chains task 'first' with 'next' passing result of 'first' to 'next' if first is completed, not cancelled and not faulted. Returns task that completes when 'next' completes
OnOk T1 (Task, Func Task T1 , TaskContinuationOptions, TaskContinuationOptions) | Chains task 'first' with task returned by 'next' if first is completed, not cancelled and not faulted. Returns task that completes after task returned by 'next' completes with result from 'next' task
OnOk T1 (Task T1 , Func T1, Task , TaskContinuationOptions, TaskContinuationOptions) | Chains task 'first' with task returned by 'next' passing result of 'first' to 'next' if first is completed, not cancelled and not faulted. Returns task that completes after task returned by 'next' completes
OnOk T1, T2 (Task T1 , Func T1, Task T2 , TaskContinuationOptions, TaskContinuationOptions) | Chains task 'first' with task returned by 'next' passing result of 'first' to 'next' if first is completed, not cancelled and not faulted. Returns task that completes after task returned by 'next' completes with result from 'next' task
OnOkOrError(Task, Action Task ) | Registers action executed disregarding task state
OnOkOrError T (Task T , Action Task ) | Registers action executed disregarding task state
Back to Top
See Also
TaskUtils Class
NFX Namespace


TaskUtils Methods

TaskUtils Methods NFX Class Library

The TaskUtils type exposes the following members.
Methods
Name | Description
AsCompletedTask(Action) | Non-generic version of AsCompletedTask T (Func T )
AsCompletedTask T (Func T ) | Returns task completed from a synchronous functor
AssignWorkSegment | Returns the count of items in work segment along with the start index of the first item to be processed by a particular worker in the worker set
OnError | Registers action executed if task was faulted or cancelled
OnOk(Task, Action, TaskContinuationOptions) | Chains task 'first' with 'next' if first is completed, not cancelled and not faulted. Returns task that completes when 'next' completes
OnOk T1 (Task T1 , Action T1 , TaskContinuationOptions) | Chains task 'first' with 'next' passing result of 'first' to 'next' if first is completed, not cancelled and not faulted. Returns task that completes when 'next' completes
OnOk T1 (Task, Func Task T1 , TaskContinuationOptions, TaskContinuationOptions) | Chains task 'first' with task returned by 'next' if first is completed, not cancelled and not faulted. Returns task that completes after task returned by 'next' completes with result from 'next' task
OnOk T1 (Task T1 , Func T1, Task , TaskContinuationOptions, TaskContinuationOptions) | Chains task 'first' with task returned by 'next' passing result of 'first' to 'next' if first is completed, not cancelled and not faulted. Returns task that completes after task returned by 'next' completes
OnOk T1, T2 (Task T1 , Func T1, Task T2 , TaskContinuationOptions, TaskContinuationOptions) | Chains task 'first' with task returned by 'next' passing result of 'first' to 'next' if first is completed, not cancelled and not faulted. Returns task that completes after task returned by 'next' completes with result from 'next' task
OnOkOrError(Task, Action Task ) | Registers action executed disregarding task state
OnOkOrError T (Task T , Action Task ) | Registers action executed disregarding task state
Back to Top
See Also
TaskUtils Class
NFX Namespace


TaskUtils.AsCompletedTask Method

TaskUtils AsCompletedTask Method NFX Class Library

Overload List
Name | Description
AsCompletedTask(Action) | Non-generic version of AsCompletedTask T (Func T )
AsCompletedTask T (Func T ) | Returns task completed from a synchronous functor
Back to Top
See Also
TaskUtils Class
TaskUtils Members
NFX Namespace


TaskUtils.AsCompletedTask Method (Action)

TaskUtils AsCompletedTask Method (Action) NFX Class Library

Non-generic version of AsCompletedTask T (Func T )

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task AsCompletedTask(
    this Action act
)
public static Task AsCompletedTask(
    this Action act
)
<ExtensionAttribute>
Public Shared Function AsCompletedTask (
    act As Action
) As Task
<ExtensionAttribute>
Public Shared Function AsCompletedTask (
    act As Action
) As Task
public:
[ExtensionAttribute]
static Task^ AsCompletedTask(
    Action^ act
)
public:
[ExtensionAttribute]
static Task^ AsCompletedTask(
    Action^ act
)
static member AsCompletedTask :
        act : Action -> Task
static member AsCompletedTask :
        act : Action -> Task

Parameters

act
Type: Online System Action

Return Value

Type: Online Task

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Action. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
Remarks
Because there is no non-generic Online TaskCompletionSource TResult version generic version typed by Online Object is used ( Online Task TResult inherits from Online Task)
See Also
TaskUtils Class
TaskUtils Members
AsCompletedTask Overload
NFX Namespace


TaskUtils.AsCompletedTask(T) Method (Func(T))

TaskUtils AsCompletedTask T Method (Func T ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns task completed from a synchronous functor

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task<T> AsCompletedTask<T>(
    this Func<T> func
)
public static Task<T> AsCompletedTask<T>(
    this Func<T> func
)
<ExtensionAttribute>
Public Shared Function AsCompletedTask(Of T) (
    func As Func(Of T)
) As Task(Of T)
<ExtensionAttribute>
Public Shared Function AsCompletedTask(Of T) (
    func As Func(Of T)
) As Task(Of T)
public:
[ExtensionAttribute]
generic<typename T>
static Task<T>^ AsCompletedTask(
    Func<T>^ func
)
public:
[ExtensionAttribute]
generic<typename T>
static Task<T>^ AsCompletedTask(
    Func<T>^ func
)
static member AsCompletedTask :
        func : Func<'T> -> Task<'T>
static member AsCompletedTask :
        func : Func<'T> -> Task<'T>

Parameters

func
Type: Online System Func T
Type Parameters
T

Return Value

Type: Online Task T

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Func T . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
TaskUtils Class
TaskUtils Members
AsCompletedTask Overload
NFX Namespace


TaskUtils.AssignWorkSegment Method

TaskUtils AssignWorkSegment Method NFX Class Library

Returns the count of items in work segment along with the start index of the first item to be processed by a particular worker in the worker set

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int AssignWorkSegment(
    int totalItemCount,
    int totalWorkerCount,
    int thisWorkerIndex,
    out int startIndex
)
public static int AssignWorkSegment(
    int totalItemCount,
    int totalWorkerCount,
    int thisWorkerIndex,
    out int startIndex
)
Public Shared Function AssignWorkSegment (
    totalItemCount As Integer,
    totalWorkerCount As Integer,
    thisWorkerIndex As Integer,
    <OutAttribute> ByRef startIndex As Integer
) As Integer
Public Shared Function AssignWorkSegment (
    totalItemCount As Integer,
    totalWorkerCount As Integer,
    thisWorkerIndex As Integer,
    <OutAttribute> ByRef startIndex As Integer
) As Integer
public:
static int AssignWorkSegment(
    int totalItemCount,
    int totalWorkerCount,
    int thisWorkerIndex,
    [OutAttribute] int% startIndex
)
public:
static int AssignWorkSegment(
    int totalItemCount,
    int totalWorkerCount,
    int thisWorkerIndex,
    [OutAttribute] int% startIndex
)
static member AssignWorkSegment :
        totalItemCount : int *
        totalWorkerCount : int *
        thisWorkerIndex : int *
        startIndex : int byref -> int
static member AssignWorkSegment :
        totalItemCount : int *
        totalWorkerCount : int *
        thisWorkerIndex : int *
        startIndex : int byref -> int

Parameters

totalItemCount
Type: Online System Int32
Total item count in the set processed by all workers
totalWorkerCount
Type: Online System Int32
Total number of workers int the set operating over the totalItemCount
thisWorkerIndex
Type: Online System Int32
The index of THIS worker in the whole worker set
startIndex
Type: Online System Int32
Returns the index of the first item in the assigned segment

Return Value

Type: Online Int32
The count of items in the assigned segment
See Also
TaskUtils Class
TaskUtils Members
NFX Namespace


TaskUtils.OnError Method

TaskUtils OnError Method NFX Class Library

Registers action executed if task was faulted or cancelled

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task OnError(
    this Task task,
    Action handler
)
public static Task OnError(
    this Task task,
    Action handler
)
<ExtensionAttribute>
Public Shared Function OnError (
    task As Task,
    handler As Action
) As Task
<ExtensionAttribute>
Public Shared Function OnError (
    task As Task,
    handler As Action
) As Task
public:
[ExtensionAttribute]
static Task^ OnError(
    Task^ task,
    Action^ handler
)
public:
[ExtensionAttribute]
static Task^ OnError(
    Task^ task,
    Action^ handler
)
static member OnError :
        task : Task *
        handler : Action -> Task
static member OnError :
        task : Task *
        handler : Action -> Task

Parameters

task
Type: Online System.Threading.Tasks Task
handler
Type: Online System Action

Return Value

Type: Online Task

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Task. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
TaskUtils Class
TaskUtils Members
NFX Namespace


TaskUtils.OnOk Method

TaskUtils OnOk Method NFX Class Library

Overload List
Name | Description
OnOk(Task, Action, TaskContinuationOptions) | Chains task 'first' with 'next' if first is completed, not cancelled and not faulted. Returns task that completes when 'next' completes
OnOk T1 (Task T1 , Action T1 , TaskContinuationOptions) | Chains task 'first' with 'next' passing result of 'first' to 'next' if first is completed, not cancelled and not faulted. Returns task that completes when 'next' completes
OnOk T1 (Task, Func Task T1 , TaskContinuationOptions, TaskContinuationOptions) | Chains task 'first' with task returned by 'next' if first is completed, not cancelled and not faulted. Returns task that completes after task returned by 'next' completes with result from 'next' task
OnOk T1, T2 (Task T1 , Func T1, Task T2 , TaskContinuationOptions, TaskContinuationOptions) | Chains task 'first' with task returned by 'next' passing result of 'first' to 'next' if first is completed, not cancelled and not faulted. Returns task that completes after task returned by 'next' completes with result from 'next' task
OnOk T1 (Task T1 , Func T1, Task , TaskContinuationOptions, TaskContinuationOptions) | Chains task 'first' with task returned by 'next' passing result of 'first' to 'next' if first is completed, not cancelled and not faulted. Returns task that completes after task returned by 'next' completes
Back to Top
See Also
TaskUtils Class
TaskUtils Members
NFX Namespace


TaskUtils.OnOk Method (Task, Action, TaskContinuationOptions)

TaskUtils OnOk Method (Task, Action, TaskContinuationOptions) NFX Class Library

[This is preliminary documentation and is subject to change.]

Chains task 'first' with 'next' if first is completed, not cancelled and not faulted. Returns task that completes when 'next' completes

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task OnOk(
    this Task first,
    Action next,
    TaskContinuationOptions options = TaskContinuationOptions.ExecuteSynchronously
)
public static Task OnOk(
    this Task first,
    Action next,
    TaskContinuationOptions options = TaskContinuationOptions.ExecuteSynchronously
)
<ExtensionAttribute>
Public Shared Function OnOk (
    first As Task,
    next As Action,
    Optional options As TaskContinuationOptions = TaskContinuationOptions.ExecuteSynchronously
) As Task
<ExtensionAttribute>
Public Shared Function OnOk (
    first As Task,
    next As Action,
    Optional options As TaskContinuationOptions = TaskContinuationOptions.ExecuteSynchronously
) As Task
public:
[ExtensionAttribute]
static Task^ OnOk(
    Task^ first,
    Action^ next,
    TaskContinuationOptions options = TaskContinuationOptions::ExecuteSynchronously
)
public:
[ExtensionAttribute]
static Task^ OnOk(
    Task^ first,
    Action^ next,
    TaskContinuationOptions options = TaskContinuationOptions::ExecuteSynchronously
)
static member OnOk :
        first : Task *
        next : Action *
        ?options : TaskContinuationOptions
(* Defaults:
        let _options = defaultArg options TaskContinuationOptions.ExecuteSynchronously
*)
-> Task
static member OnOk :
        first : Task *
        next : Action *
        ?options : TaskContinuationOptions
(* Defaults:
        let _options = defaultArg options TaskContinuationOptions.ExecuteSynchronously
*)
-> Task

Parameters

first
Type: Online System.Threading.Tasks Task
next
Type: Online System Action
options (Optional)
Type: Online System.Threading.Tasks TaskContinuationOptions

Return Value

Type: Online Task

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Task. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
TaskUtils Class
TaskUtils Members
OnOk Overload
NFX Namespace


TaskUtils.OnOk(T1) Method (Task(T1), Action(T1), TaskContinuationOptions)

TaskUtils OnOk T1 Method (Task T1 , Action T1 , TaskContinuationOptions) NFX Class Library

[This is preliminary documentation and is subject to change.]

Chains task 'first' with 'next' passing result of 'first' to 'next' if first is completed, not cancelled and not faulted. Returns task that completes when 'next' completes

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task OnOk<T1>(
    this Task<T1> first,
    Action<T1> next,
    TaskContinuationOptions options = TaskContinuationOptions.ExecuteSynchronously
)
public static Task OnOk<T1>(
    this Task<T1> first,
    Action<T1> next,
    TaskContinuationOptions options = TaskContinuationOptions.ExecuteSynchronously
)
<ExtensionAttribute>
Public Shared Function OnOk(Of T1) (
    first As Task(Of T1),
    next As Action(Of T1),
    Optional options As TaskContinuationOptions = TaskContinuationOptions.ExecuteSynchronously
) As Task
<ExtensionAttribute>
Public Shared Function OnOk(Of T1) (
    first As Task(Of T1),
    next As Action(Of T1),
    Optional options As TaskContinuationOptions = TaskContinuationOptions.ExecuteSynchronously
) As Task
public:
[ExtensionAttribute]
generic<typename T1>
static Task^ OnOk(
    Task<T1>^ first,
    Action<T1>^ next,
    TaskContinuationOptions options = TaskContinuationOptions::ExecuteSynchronously
)
public:
[ExtensionAttribute]
generic<typename T1>
static Task^ OnOk(
    Task<T1>^ first,
    Action<T1>^ next,
    TaskContinuationOptions options = TaskContinuationOptions::ExecuteSynchronously
)
static member OnOk :
        first : Task<'T1> *
        next : Action<'T1> *
        ?options : TaskContinuationOptions
(* Defaults:
        let _options = defaultArg options TaskContinuationOptions.ExecuteSynchronously
*)
-> Task
static member OnOk :
        first : Task<'T1> *
        next : Action<'T1> *
        ?options : TaskContinuationOptions
(* Defaults:
        let _options = defaultArg options TaskContinuationOptions.ExecuteSynchronously
*)
-> Task

Parameters

first
Type: Online System.Threading.Tasks Task T1
next
Type: Online System Action T1
options (Optional)
Type: Online System.Threading.Tasks TaskContinuationOptions
Type Parameters
T1

Return Value

Type: Online Task

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Task T1 . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
TaskUtils Class
TaskUtils Members
OnOk Overload
NFX Namespace


TaskUtils.OnOk(T1) Method (Task, Func(Task(T1)), TaskContinuationOptions, TaskContinuationOptions)

TaskUtils OnOk T1 Method (Task, Func Task T1 , TaskContinuationOptions, TaskContinuationOptions) NFX Class Library

[This is preliminary documentation and is subject to change.]

Chains task 'first' with task returned by 'next' if first is completed, not cancelled and not faulted. Returns task that completes after task returned by 'next' completes with result from 'next' task

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task<T1> OnOk<T1>(
    this Task first,
    Func<Task<T1>> next,
    TaskContinuationOptions firstOptions = TaskContinuationOptions.ExecuteSynchronously,
    TaskContinuationOptions nextOptions = TaskContinuationOptions.ExecuteSynchronously
)
public static Task<T1> OnOk<T1>(
    this Task first,
    Func<Task<T1>> next,
    TaskContinuationOptions firstOptions = TaskContinuationOptions.ExecuteSynchronously,
    TaskContinuationOptions nextOptions = TaskContinuationOptions.ExecuteSynchronously
)
<ExtensionAttribute>
Public Shared Function OnOk(Of T1) (
    first As Task,
    next As Func(Of Task(Of T1)),
    Optional firstOptions As TaskContinuationOptions = TaskContinuationOptions.ExecuteSynchronously,
    Optional nextOptions As TaskContinuationOptions = TaskContinuationOptions.ExecuteSynchronously
) As Task(Of T1)
<ExtensionAttribute>
Public Shared Function OnOk(Of T1) (
    first As Task,
    next As Func(Of Task(Of T1)),
    Optional firstOptions As TaskContinuationOptions = TaskContinuationOptions.ExecuteSynchronously,
    Optional nextOptions As TaskContinuationOptions = TaskContinuationOptions.ExecuteSynchronously
) As Task(Of T1)
public:
[ExtensionAttribute]
generic<typename T1>
static Task<T1>^ OnOk(
    Task^ first,
    Func<Task<T1>^>^ next,
    TaskContinuationOptions firstOptions = TaskContinuationOptions::ExecuteSynchronously,
    TaskContinuationOptions nextOptions = TaskContinuationOptions::ExecuteSynchronously
)
public:
[ExtensionAttribute]
generic<typename T1>
static Task<T1>^ OnOk(
    Task^ first,
    Func<Task<T1>^>^ next,
    TaskContinuationOptions firstOptions = TaskContinuationOptions::ExecuteSynchronously,
    TaskContinuationOptions nextOptions = TaskContinuationOptions::ExecuteSynchronously
)
static member OnOk :
        first : Task *
        next : Func<Task<'T1>> *
        ?firstOptions : TaskContinuationOptions *
        ?nextOptions : TaskContinuationOptions
(* Defaults:
        let _firstOptions = defaultArg firstOptions TaskContinuationOptions.ExecuteSynchronously
        let _nextOptions = defaultArg nextOptions TaskContinuationOptions.ExecuteSynchronously
*)
-> Task<'T1>
static member OnOk :
        first : Task *
        next : Func<Task<'T1>> *
        ?firstOptions : TaskContinuationOptions *
        ?nextOptions : TaskContinuationOptions
(* Defaults:
        let _firstOptions = defaultArg firstOptions TaskContinuationOptions.ExecuteSynchronously
        let _nextOptions = defaultArg nextOptions TaskContinuationOptions.ExecuteSynchronously
*)
-> Task<'T1>

Parameters

first
Type: Online System.Threading.Tasks Task
next
Type: Online System Func Online Task T1
firstOptions (Optional)
Type: Online System.Threading.Tasks TaskContinuationOptions
nextOptions (Optional)
Type: Online System.Threading.Tasks TaskContinuationOptions
Type Parameters
T1

Return Value

Type: Online Task T1

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Task. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
TaskUtils Class
TaskUtils Members
OnOk Overload
NFX Namespace


TaskUtils.OnOk(T1, T2) Method (Task(T1), Func(T1, Task(T2)), TaskContinuationOptions, TaskContinuationOptions)

TaskUtils OnOk T1, T2 Method (Task T1 , Func T1, Task T2 , TaskContinuationOptions, TaskContinuationOptions) NFX Class Library

[This is preliminary documentation and is subject to change.]

Chains task 'first' with task returned by 'next' passing result of 'first' to 'next' if first is completed, not cancelled and not faulted. Returns task that completes after task returned by 'next' completes with result from 'next' task

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task<T2> OnOk<T1, T2>(
    this Task<T1> first,
    Func<T1, Task<T2>> next,
    TaskContinuationOptions firstOptions = TaskContinuationOptions.ExecuteSynchronously,
    TaskContinuationOptions nextOptions = TaskContinuationOptions.ExecuteSynchronously
)
public static Task<T2> OnOk<T1, T2>(
    this Task<T1> first,
    Func<T1, Task<T2>> next,
    TaskContinuationOptions firstOptions = TaskContinuationOptions.ExecuteSynchronously,
    TaskContinuationOptions nextOptions = TaskContinuationOptions.ExecuteSynchronously
)
<ExtensionAttribute>
Public Shared Function OnOk(Of T1, T2) (
    first As Task(Of T1),
    next As Func(Of T1, Task(Of T2)),
    Optional firstOptions As TaskContinuationOptions = TaskContinuationOptions.ExecuteSynchronously,
    Optional nextOptions As TaskContinuationOptions = TaskContinuationOptions.ExecuteSynchronously
) As Task(Of T2)
<ExtensionAttribute>
Public Shared Function OnOk(Of T1, T2) (
    first As Task(Of T1),
    next As Func(Of T1, Task(Of T2)),
    Optional firstOptions As TaskContinuationOptions = TaskContinuationOptions.ExecuteSynchronously,
    Optional nextOptions As TaskContinuationOptions = TaskContinuationOptions.ExecuteSynchronously
) As Task(Of T2)
public:
[ExtensionAttribute]
generic<typename T1, typename T2>
static Task<T2>^ OnOk(
    Task<T1>^ first,
    Func<T1, Task<T2>^>^ next,
    TaskContinuationOptions firstOptions = TaskContinuationOptions::ExecuteSynchronously,
    TaskContinuationOptions nextOptions = TaskContinuationOptions::ExecuteSynchronously
)
public:
[ExtensionAttribute]
generic<typename T1, typename T2>
static Task<T2>^ OnOk(
    Task<T1>^ first,
    Func<T1, Task<T2>^>^ next,
    TaskContinuationOptions firstOptions = TaskContinuationOptions::ExecuteSynchronously,
    TaskContinuationOptions nextOptions = TaskContinuationOptions::ExecuteSynchronously
)
static member OnOk :
        first : Task<'T1> *
        next : Func<'T1, Task<'T2>> *
        ?firstOptions : TaskContinuationOptions *
        ?nextOptions : TaskContinuationOptions
(* Defaults:
        let _firstOptions = defaultArg firstOptions TaskContinuationOptions.ExecuteSynchronously
        let _nextOptions = defaultArg nextOptions TaskContinuationOptions.ExecuteSynchronously
*)
-> Task<'T2>
static member OnOk :
        first : Task<'T1> *
        next : Func<'T1, Task<'T2>> *
        ?firstOptions : TaskContinuationOptions *
        ?nextOptions : TaskContinuationOptions
(* Defaults:
        let _firstOptions = defaultArg firstOptions TaskContinuationOptions.ExecuteSynchronously
        let _nextOptions = defaultArg nextOptions TaskContinuationOptions.ExecuteSynchronously
*)
-> Task<'T2>

Parameters

first
Type: Online System.Threading.Tasks Task T1
next
Type: Online System Func T1, Online Task T2
firstOptions (Optional)
Type: Online System.Threading.Tasks TaskContinuationOptions
nextOptions (Optional)
Type: Online System.Threading.Tasks TaskContinuationOptions
Type Parameters
T1
T2

Return Value

Type: Online Task T2

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Task T1 . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
TaskUtils Class
TaskUtils Members
OnOk Overload
NFX Namespace


TaskUtils.OnOk(T1) Method (Task(T1), Func(T1, Task), TaskContinuationOptions, TaskContinuationOptions)

TaskUtils OnOk T1 Method (Task T1 , Func T1, Task , TaskContinuationOptions, TaskContinuationOptions) NFX Class Library

[This is preliminary documentation and is subject to change.]

Chains task 'first' with task returned by 'next' passing result of 'first' to 'next' if first is completed, not cancelled and not faulted. Returns task that completes after task returned by 'next' completes

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task OnOk<T1>(
    this Task<T1> first,
    Func<T1, Task> next,
    TaskContinuationOptions firstOptions = TaskContinuationOptions.ExecuteSynchronously,
    TaskContinuationOptions nextOptions = TaskContinuationOptions.ExecuteSynchronously
)
public static Task OnOk<T1>(
    this Task<T1> first,
    Func<T1, Task> next,
    TaskContinuationOptions firstOptions = TaskContinuationOptions.ExecuteSynchronously,
    TaskContinuationOptions nextOptions = TaskContinuationOptions.ExecuteSynchronously
)
<ExtensionAttribute>
Public Shared Function OnOk(Of T1) (
    first As Task(Of T1),
    next As Func(Of T1, Task),
    Optional firstOptions As TaskContinuationOptions = TaskContinuationOptions.ExecuteSynchronously,
    Optional nextOptions As TaskContinuationOptions = TaskContinuationOptions.ExecuteSynchronously
) As Task
<ExtensionAttribute>
Public Shared Function OnOk(Of T1) (
    first As Task(Of T1),
    next As Func(Of T1, Task),
    Optional firstOptions As TaskContinuationOptions = TaskContinuationOptions.ExecuteSynchronously,
    Optional nextOptions As TaskContinuationOptions = TaskContinuationOptions.ExecuteSynchronously
) As Task
public:
[ExtensionAttribute]
generic<typename T1>
static Task^ OnOk(
    Task<T1>^ first,
    Func<T1, Task^>^ next,
    TaskContinuationOptions firstOptions = TaskContinuationOptions::ExecuteSynchronously,
    TaskContinuationOptions nextOptions = TaskContinuationOptions::ExecuteSynchronously
)
public:
[ExtensionAttribute]
generic<typename T1>
static Task^ OnOk(
    Task<T1>^ first,
    Func<T1, Task^>^ next,
    TaskContinuationOptions firstOptions = TaskContinuationOptions::ExecuteSynchronously,
    TaskContinuationOptions nextOptions = TaskContinuationOptions::ExecuteSynchronously
)
static member OnOk :
        first : Task<'T1> *
        next : Func<'T1, Task> *
        ?firstOptions : TaskContinuationOptions *
        ?nextOptions : TaskContinuationOptions
(* Defaults:
        let _firstOptions = defaultArg firstOptions TaskContinuationOptions.ExecuteSynchronously
        let _nextOptions = defaultArg nextOptions TaskContinuationOptions.ExecuteSynchronously
*)
-> Task
static member OnOk :
        first : Task<'T1> *
        next : Func<'T1, Task> *
        ?firstOptions : TaskContinuationOptions *
        ?nextOptions : TaskContinuationOptions
(* Defaults:
        let _firstOptions = defaultArg firstOptions TaskContinuationOptions.ExecuteSynchronously
        let _nextOptions = defaultArg nextOptions TaskContinuationOptions.ExecuteSynchronously
*)
-> Task

Parameters

first
Type: Online System.Threading.Tasks Task T1
next
Type: Online System Func T1, Online Task
firstOptions (Optional)
Type: Online System.Threading.Tasks TaskContinuationOptions
nextOptions (Optional)
Type: Online System.Threading.Tasks TaskContinuationOptions
Type Parameters
T1

Return Value

Type: Online Task

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Task T1 . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
TaskUtils Class
TaskUtils Members
OnOk Overload
NFX Namespace


TaskUtils.OnOkOrError Method

TaskUtils OnOkOrError Method NFX Class Library

Overload List
Name | Description
OnOkOrError(Task, Action Task ) | Registers action executed disregarding task state
OnOkOrError T (Task T , Action Task ) | Registers action executed disregarding task state
Back to Top
See Also
TaskUtils Class
TaskUtils Members
NFX Namespace


TaskUtils.OnOkOrError Method (Task, Action(Task))

TaskUtils OnOkOrError Method (Task, Action Task ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Registers action executed disregarding task state

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task OnOkOrError(
    this Task task,
    Action<Task> handler
)
public static Task OnOkOrError(
    this Task task,
    Action<Task> handler
)
<ExtensionAttribute>
Public Shared Function OnOkOrError (
    task As Task,
    handler As Action(Of Task)
) As Task
<ExtensionAttribute>
Public Shared Function OnOkOrError (
    task As Task,
    handler As Action(Of Task)
) As Task
public:
[ExtensionAttribute]
static Task^ OnOkOrError(
    Task^ task,
    Action<Task^>^ handler
)
public:
[ExtensionAttribute]
static Task^ OnOkOrError(
    Task^ task,
    Action<Task^>^ handler
)
static member OnOkOrError :
        task : Task *
        handler : Action<Task> -> Task
static member OnOkOrError :
        task : Task *
        handler : Action<Task> -> Task

Parameters

task
Type: Online System.Threading.Tasks Task
handler
Type: Online System Action Online Task

Return Value

Type: Online Task

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Task. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
TaskUtils Class
TaskUtils Members
OnOkOrError Overload
NFX Namespace


TaskUtils.OnOkOrError(T) Method (Task(T), Action(Task))

TaskUtils OnOkOrError T Method (Task T , Action Task ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Registers action executed disregarding task state

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Task<T> OnOkOrError<T>(
    this Task<T> task,
    Action<Task> handler
)
public static Task<T> OnOkOrError<T>(
    this Task<T> task,
    Action<Task> handler
)
<ExtensionAttribute>
Public Shared Function OnOkOrError(Of T) (
    task As Task(Of T),
    handler As Action(Of Task)
) As Task(Of T)
<ExtensionAttribute>
Public Shared Function OnOkOrError(Of T) (
    task As Task(Of T),
    handler As Action(Of Task)
) As Task(Of T)
public:
[ExtensionAttribute]
generic<typename T>
static Task<T>^ OnOkOrError(
    Task<T>^ task,
    Action<Task^>^ handler
)
public:
[ExtensionAttribute]
generic<typename T>
static Task<T>^ OnOkOrError(
    Task<T>^ task,
    Action<Task^>^ handler
)
static member OnOkOrError :
        task : Task<'T> *
        handler : Action<Task> -> Task<'T>
static member OnOkOrError :
        task : Task<'T> *
        handler : Action<Task> -> Task<'T>

Parameters

task
Type: Online System.Threading.Tasks Task T
handler
Type: Online System Action Online Task
Type Parameters
T

Return Value

Type: Online Task T

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Task T . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
TaskUtils Class
TaskUtils Members
OnOkOrError Overload
NFX Namespace


Trace Class

Trace Class NFX Class Library

Facilitates debugging tasks enabled by TRACE conditional define
Inheritance Hierarchy
Online System Object
NFX Trace

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class Trace
public static class Trace
Public NotInheritable Class Trace
Public NotInheritable Class Trace
public ref class Trace abstract sealed
public ref class Trace abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Trace =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Trace =  class end
See Also
Trace Members
NFX Namespace


Trace Members

Trace Members NFX Class Library

The Trace type exposes the following members.
Methods
Name | Description
Assert |
Fail |
Write(Func String , MessageType, Nullable Guid ) | A simplified method for tracing that doesn't evaluate text generation function if tracing is disabled by configuration
Write(String, String, MessageType, Int32, String, String, Nullable Guid , Int32) |
Write TContext (Func TContext, String , TContext, MessageType, Nullable Guid ) | A simplified method for tracing that doesn't evaluate text generation function if tracing is disabled by configuration. It takes context argument that can be passed to the text-generating textFunc functor
Back to Top
Fields
Name | Description
TRACE |
Back to Top
See Also
Trace Class
NFX Namespace


Trace Fields

Trace Fields NFX Class Library

The Trace type exposes the following members.
Fields
Name | Description
TRACE |
Back to Top
See Also
Trace Class
NFX Namespace


Trace.TRACE Field

Trace TRACE Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string TRACE
public const string TRACE
Public Const TRACE As String
Public Const TRACE As String
public:
literal String^ TRACE
public:
literal String^ TRACE
static val mutable TRACE: string
static val mutable TRACE: string

Field Value

Type: Online String
See Also
Trace Class
Trace Members
NFX Namespace


Trace Methods

Trace Methods NFX Class Library

The Trace type exposes the following members.
Methods
Name | Description
Assert |
Fail |
Write(Func String , MessageType, Nullable Guid ) | A simplified method for tracing that doesn't evaluate text generation function if tracing is disabled by configuration
Write(String, String, MessageType, Int32, String, String, Nullable Guid , Int32) |
Write TContext (Func TContext, String , TContext, MessageType, Nullable Guid ) | A simplified method for tracing that doesn't evaluate text generation function if tracing is disabled by configuration. It takes context argument that can be passed to the text-generating textFunc functor
Back to Top
See Also
Trace Class
NFX Namespace


Trace.Assert Method

Trace Assert Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConditionalAttribute("TRACE")]
public static void Assert(
    bool condition,
    string text = null,
    DebugAction action = DebugAction.Default,
    string from = null,
    MessageType type = MessageType.Trace,
    int source = 0,
    string topic = null,
    string pars = null,
    Nullable<Guid> correlationContext = null,
    int frameOffset = 2
)
[ConditionalAttribute("TRACE")]
public static void Assert(
    bool condition,
    string text = null,
    DebugAction action = DebugAction.Default,
    string from = null,
    MessageType type = MessageType.Trace,
    int source = 0,
    string topic = null,
    string pars = null,
    Nullable<Guid> correlationContext = null,
    int frameOffset = 2
)
<ConditionalAttribute("TRACE")>
Public Shared Sub Assert (
    condition As Boolean,
    Optional text As String = Nothing,
    Optional action As DebugAction = DebugAction.Default,
    Optional from As String = Nothing,
    Optional type As MessageType = MessageType.Trace,
    Optional source As Integer = 0,
    Optional topic As String = Nothing,
    Optional pars As String = Nothing,
    Optional correlationContext As Nullable(Of Guid) = Nothing,
    Optional frameOffset As Integer = 2
)
<ConditionalAttribute("TRACE")>
Public Shared Sub Assert (
    condition As Boolean,
    Optional text As String = Nothing,
    Optional action As DebugAction = DebugAction.Default,
    Optional from As String = Nothing,
    Optional type As MessageType = MessageType.Trace,
    Optional source As Integer = 0,
    Optional topic As String = Nothing,
    Optional pars As String = Nothing,
    Optional correlationContext As Nullable(Of Guid) = Nothing,
    Optional frameOffset As Integer = 2
)
public:
[ConditionalAttribute(L"TRACE")]
static void Assert(
    bool condition,
    String^ text = nullptr,
    DebugAction action = DebugAction::Default,
    String^ from = nullptr,
    MessageType type = MessageType::Trace,
    int source = 0,
    String^ topic = nullptr,
    String^ pars = nullptr,
    Nullable<Guid> correlationContext = nullptr,
    int frameOffset = 2
)
public:
[ConditionalAttribute(L"TRACE")]
static void Assert(
    bool condition,
    String^ text = nullptr,
    DebugAction action = DebugAction::Default,
    String^ from = nullptr,
    MessageType type = MessageType::Trace,
    int source = 0,
    String^ topic = nullptr,
    String^ pars = nullptr,
    Nullable<Guid> correlationContext = nullptr,
    int frameOffset = 2
)
[<ConditionalAttribute("TRACE")>]
static member Assert :
        condition : bool *
        ?text : string *
        ?action : DebugAction *
        ?from : string *
        ?type : MessageType *
        ?source : int *
        ?topic : string *
        ?pars : string *
        ?correlationContext : Nullable<Guid> *
        ?frameOffset : int
(* Defaults:
        let _text = defaultArg text null
        let _action = defaultArg action DebugAction.Default
        let _from = defaultArg from null
        let _type = defaultArg type MessageType.Trace
        let _source = defaultArg source 0
        let _topic = defaultArg topic null
        let _pars = defaultArg pars null
        let _correlationContext = defaultArg correlationContext null
        let _frameOffset = defaultArg frameOffset 2
*)
-> unit
[<ConditionalAttribute("TRACE")>]
static member Assert :
        condition : bool *
        ?text : string *
        ?action : DebugAction *
        ?from : string *
        ?type : MessageType *
        ?source : int *
        ?topic : string *
        ?pars : string *
        ?correlationContext : Nullable<Guid> *
        ?frameOffset : int
(* Defaults:
        let _text = defaultArg text null
        let _action = defaultArg action DebugAction.Default
        let _from = defaultArg from null
        let _type = defaultArg type MessageType.Trace
        let _source = defaultArg source 0
        let _topic = defaultArg topic null
        let _pars = defaultArg pars null
        let _correlationContext = defaultArg correlationContext null
        let _frameOffset = defaultArg frameOffset 2
*)
-> unit

Parameters

condition
Type: Online System Boolean
text (Optional)
Type: Online System String
action (Optional)
Type: NFX DebugAction
from (Optional)
Type: Online System String
type (Optional)
Type: NFX.Log MessageType
source (Optional)
Type: Online System Int32
topic (Optional)
Type: Online System String
pars (Optional)
Type: Online System String
correlationContext (Optional)
Type: Online System Nullable Online Guid
frameOffset (Optional)
Type: Online System Int32
See Also
Trace Class
Trace Members
NFX Namespace


Trace.Fail Method

Trace Fail Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConditionalAttribute("TRACE")]
public static void Fail(
    string text = null,
    DebugAction action = DebugAction.Default,
    string from = null,
    MessageType type = MessageType.Debug,
    int source = 0,
    string topic = null,
    string pars = null,
    Nullable<Guid> correlationContext = null,
    int frameOffset = 2
)
[ConditionalAttribute("TRACE")]
public static void Fail(
    string text = null,
    DebugAction action = DebugAction.Default,
    string from = null,
    MessageType type = MessageType.Debug,
    int source = 0,
    string topic = null,
    string pars = null,
    Nullable<Guid> correlationContext = null,
    int frameOffset = 2
)
<ConditionalAttribute("TRACE")>
Public Shared Sub Fail (
    Optional text As String = Nothing,
    Optional action As DebugAction = DebugAction.Default,
    Optional from As String = Nothing,
    Optional type As MessageType = MessageType.Debug,
    Optional source As Integer = 0,
    Optional topic As String = Nothing,
    Optional pars As String = Nothing,
    Optional correlationContext As Nullable(Of Guid) = Nothing,
    Optional frameOffset As Integer = 2
)
<ConditionalAttribute("TRACE")>
Public Shared Sub Fail (
    Optional text As String = Nothing,
    Optional action As DebugAction = DebugAction.Default,
    Optional from As String = Nothing,
    Optional type As MessageType = MessageType.Debug,
    Optional source As Integer = 0,
    Optional topic As String = Nothing,
    Optional pars As String = Nothing,
    Optional correlationContext As Nullable(Of Guid) = Nothing,
    Optional frameOffset As Integer = 2
)
public:
[ConditionalAttribute(L"TRACE")]
static void Fail(
    String^ text = nullptr,
    DebugAction action = DebugAction::Default,
    String^ from = nullptr,
    MessageType type = MessageType::Debug,
    int source = 0,
    String^ topic = nullptr,
    String^ pars = nullptr,
    Nullable<Guid> correlationContext = nullptr,
    int frameOffset = 2
)
public:
[ConditionalAttribute(L"TRACE")]
static void Fail(
    String^ text = nullptr,
    DebugAction action = DebugAction::Default,
    String^ from = nullptr,
    MessageType type = MessageType::Debug,
    int source = 0,
    String^ topic = nullptr,
    String^ pars = nullptr,
    Nullable<Guid> correlationContext = nullptr,
    int frameOffset = 2
)
[<ConditionalAttribute("TRACE")>]
static member Fail :
        ?text : string *
        ?action : DebugAction *
        ?from : string *
        ?type : MessageType *
        ?source : int *
        ?topic : string *
        ?pars : string *
        ?correlationContext : Nullable<Guid> *
        ?frameOffset : int
(* Defaults:
        let _text = defaultArg text null
        let _action = defaultArg action DebugAction.Default
        let _from = defaultArg from null
        let _type = defaultArg type MessageType.Debug
        let _source = defaultArg source 0
        let _topic = defaultArg topic null
        let _pars = defaultArg pars null
        let _correlationContext = defaultArg correlationContext null
        let _frameOffset = defaultArg frameOffset 2
*)
-> unit
[<ConditionalAttribute("TRACE")>]
static member Fail :
        ?text : string *
        ?action : DebugAction *
        ?from : string *
        ?type : MessageType *
        ?source : int *
        ?topic : string *
        ?pars : string *
        ?correlationContext : Nullable<Guid> *
        ?frameOffset : int
(* Defaults:
        let _text = defaultArg text null
        let _action = defaultArg action DebugAction.Default
        let _from = defaultArg from null
        let _type = defaultArg type MessageType.Debug
        let _source = defaultArg source 0
        let _topic = defaultArg topic null
        let _pars = defaultArg pars null
        let _correlationContext = defaultArg correlationContext null
        let _frameOffset = defaultArg frameOffset 2
*)
-> unit

Parameters

text (Optional)
Type: Online System String
action (Optional)
Type: NFX DebugAction
from (Optional)
Type: Online System String
type (Optional)
Type: NFX.Log MessageType
source (Optional)
Type: Online System Int32
topic (Optional)
Type: Online System String
pars (Optional)
Type: Online System String
correlationContext (Optional)
Type: Online System Nullable Online Guid
frameOffset (Optional)
Type: Online System Int32
See Also
Trace Class
Trace Members
NFX Namespace


Trace.Write Method

Trace Write Method NFX Class Library

Overload List
Name | Description
Write(Func String , MessageType, Nullable Guid ) | A simplified method for tracing that doesn't evaluate text generation function if tracing is disabled by configuration
Write TContext (Func TContext, String , TContext, MessageType, Nullable Guid ) | A simplified method for tracing that doesn't evaluate text generation function if tracing is disabled by configuration. It takes context argument that can be passed to the text-generating textFunc functor
Write(String, String, MessageType, Int32, String, String, Nullable Guid , Int32) |
Back to Top
See Also
Trace Class
Trace Members
NFX Namespace


Trace.Write Method (Func(String), MessageType, Nullable(Guid))

Trace Write Method (Func String , MessageType, Nullable Guid ) NFX Class Library

[This is preliminary documentation and is subject to change.]

A simplified method for tracing that doesn't evaluate text generation function if tracing is disabled by configuration

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConditionalAttribute("TRACE")]
public static void Write(
    Func<string> textFunc,
    MessageType type = MessageType.Trace,
    Nullable<Guid> correlationContext = null
)
[ConditionalAttribute("TRACE")]
public static void Write(
    Func<string> textFunc,
    MessageType type = MessageType.Trace,
    Nullable<Guid> correlationContext = null
)
<ConditionalAttribute("TRACE")>
Public Shared Sub Write (
    textFunc As Func(Of String),
    Optional type As MessageType = MessageType.Trace,
    Optional correlationContext As Nullable(Of Guid) = Nothing
)
<ConditionalAttribute("TRACE")>
Public Shared Sub Write (
    textFunc As Func(Of String),
    Optional type As MessageType = MessageType.Trace,
    Optional correlationContext As Nullable(Of Guid) = Nothing
)
public:
[ConditionalAttribute(L"TRACE")]
static void Write(
    Func<String^>^ textFunc,
    MessageType type = MessageType::Trace,
    Nullable<Guid> correlationContext = nullptr
)
public:
[ConditionalAttribute(L"TRACE")]
static void Write(
    Func<String^>^ textFunc,
    MessageType type = MessageType::Trace,
    Nullable<Guid> correlationContext = nullptr
)
[<ConditionalAttribute("TRACE")>]
static member Write :
        textFunc : Func<string> *
        ?type : MessageType *
        ?correlationContext : Nullable<Guid>
(* Defaults:
        let _type = defaultArg type MessageType.Trace
        let _correlationContext = defaultArg correlationContext null
*)
-> unit
[<ConditionalAttribute("TRACE")>]
static member Write :
        textFunc : Func<string> *
        ?type : MessageType *
        ?correlationContext : Nullable<Guid>
(* Defaults:
        let _type = defaultArg type MessageType.Trace
        let _correlationContext = defaultArg correlationContext null
*)
-> unit

Parameters

textFunc
Type: Online System Func Online String
Functor to evaluate to get the text sent to logger
type (Optional)
Type: NFX.Log MessageType
Message type to log
correlationContext (Optional)
Type: Online System Nullable Online Guid
Optional correlation token to relate log entries
See Also
Trace Class
Trace Members
Write Overload
NFX Namespace


Trace.Write(TContext) Method (Func(TContext, String), TContext, MessageType, Nullable(Guid))

Trace Write TContext Method (Func TContext, String , TContext, MessageType, Nullable Guid ) NFX Class Library

[This is preliminary documentation and is subject to change.]

A simplified method for tracing that doesn't evaluate text generation function if tracing is disabled by configuration. It takes context argument that can be passed to the text-generating textFunc functor

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConditionalAttribute("TRACE")]
public static void Write<TContext>(
    Func<TContext, string> textFunc,
    TContext ctx,
    MessageType type = MessageType.Trace,
    Nullable<Guid> correlationContext = null
)
[ConditionalAttribute("TRACE")]
public static void Write<TContext>(
    Func<TContext, string> textFunc,
    TContext ctx,
    MessageType type = MessageType.Trace,
    Nullable<Guid> correlationContext = null
)
<ConditionalAttribute("TRACE")>
Public Shared Sub Write(Of TContext) (
    textFunc As Func(Of TContext, String),
    ctx As TContext,
    Optional type As MessageType = MessageType.Trace,
    Optional correlationContext As Nullable(Of Guid) = Nothing
)
<ConditionalAttribute("TRACE")>
Public Shared Sub Write(Of TContext) (
    textFunc As Func(Of TContext, String),
    ctx As TContext,
    Optional type As MessageType = MessageType.Trace,
    Optional correlationContext As Nullable(Of Guid) = Nothing
)
public:
[ConditionalAttribute(L"TRACE")]
generic<typename TContext>
static void Write(
    Func<TContext, String^>^ textFunc,
    TContext ctx,
    MessageType type = MessageType::Trace,
    Nullable<Guid> correlationContext = nullptr
)
public:
[ConditionalAttribute(L"TRACE")]
generic<typename TContext>
static void Write(
    Func<TContext, String^>^ textFunc,
    TContext ctx,
    MessageType type = MessageType::Trace,
    Nullable<Guid> correlationContext = nullptr
)
[<ConditionalAttribute("TRACE")>]
static member Write :
        textFunc : Func<'TContext, string> *
        ctx : 'TContext *
        ?type : MessageType *
        ?correlationContext : Nullable<Guid>
(* Defaults:
        let _type = defaultArg type MessageType.Trace
        let _correlationContext = defaultArg correlationContext null
*)
-> unit
[<ConditionalAttribute("TRACE")>]
static member Write :
        textFunc : Func<'TContext, string> *
        ctx : 'TContext *
        ?type : MessageType *
        ?correlationContext : Nullable<Guid>
(* Defaults:
        let _type = defaultArg type MessageType.Trace
        let _correlationContext = defaultArg correlationContext null
*)
-> unit

Parameters

textFunc
Type: Online System Func TContext, Online String
Functor to evaluate to get the text sent to logger
ctx
Type: TContext
Context object
type (Optional)
Type: NFX.Log MessageType
Message type to log
correlationContext (Optional)
Type: Online System Nullable Online Guid
Optional correlation token to relate log entries
Type Parameters
TContext
See Also
Trace Class
Trace Members
Write Overload
NFX Namespace


Trace.Write Method (String, String, MessageType, Int32, String, String, Nullable(Guid), Int32)

Trace Write Method (String, String, MessageType, Int32, String, String, Nullable Guid , Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConditionalAttribute("TRACE")]
public static void Write(
    string text,
    string from = null,
    MessageType type = MessageType.Trace,
    int source = 0,
    string topic = null,
    string pars = null,
    Nullable<Guid> correlationContext = null,
    int frameOffset = 2
)
[ConditionalAttribute("TRACE")]
public static void Write(
    string text,
    string from = null,
    MessageType type = MessageType.Trace,
    int source = 0,
    string topic = null,
    string pars = null,
    Nullable<Guid> correlationContext = null,
    int frameOffset = 2
)
<ConditionalAttribute("TRACE")>
Public Shared Sub Write (
    text As String,
    Optional from As String = Nothing,
    Optional type As MessageType = MessageType.Trace,
    Optional source As Integer = 0,
    Optional topic As String = Nothing,
    Optional pars As String = Nothing,
    Optional correlationContext As Nullable(Of Guid) = Nothing,
    Optional frameOffset As Integer = 2
)
<ConditionalAttribute("TRACE")>
Public Shared Sub Write (
    text As String,
    Optional from As String = Nothing,
    Optional type As MessageType = MessageType.Trace,
    Optional source As Integer = 0,
    Optional topic As String = Nothing,
    Optional pars As String = Nothing,
    Optional correlationContext As Nullable(Of Guid) = Nothing,
    Optional frameOffset As Integer = 2
)
public:
[ConditionalAttribute(L"TRACE")]
static void Write(
    String^ text,
    String^ from = nullptr,
    MessageType type = MessageType::Trace,
    int source = 0,
    String^ topic = nullptr,
    String^ pars = nullptr,
    Nullable<Guid> correlationContext = nullptr,
    int frameOffset = 2
)
public:
[ConditionalAttribute(L"TRACE")]
static void Write(
    String^ text,
    String^ from = nullptr,
    MessageType type = MessageType::Trace,
    int source = 0,
    String^ topic = nullptr,
    String^ pars = nullptr,
    Nullable<Guid> correlationContext = nullptr,
    int frameOffset = 2
)
[<ConditionalAttribute("TRACE")>]
static member Write :
        text : string *
        ?from : string *
        ?type : MessageType *
        ?source : int *
        ?topic : string *
        ?pars : string *
        ?correlationContext : Nullable<Guid> *
        ?frameOffset : int
(* Defaults:
        let _from = defaultArg from null
        let _type = defaultArg type MessageType.Trace
        let _source = defaultArg source 0
        let _topic = defaultArg topic null
        let _pars = defaultArg pars null
        let _correlationContext = defaultArg correlationContext null
        let _frameOffset = defaultArg frameOffset 2
*)
-> unit
[<ConditionalAttribute("TRACE")>]
static member Write :
        text : string *
        ?from : string *
        ?type : MessageType *
        ?source : int *
        ?topic : string *
        ?pars : string *
        ?correlationContext : Nullable<Guid> *
        ?frameOffset : int
(* Defaults:
        let _from = defaultArg from null
        let _type = defaultArg type MessageType.Trace
        let _source = defaultArg source 0
        let _topic = defaultArg topic null
        let _pars = defaultArg pars null
        let _correlationContext = defaultArg correlationContext null
        let _frameOffset = defaultArg frameOffset 2
*)
-> unit

Parameters

text
Type: Online System String
from (Optional)
Type: Online System String
type (Optional)
Type: NFX.Log MessageType
source (Optional)
Type: Online System Int32
topic (Optional)
Type: Online System String
pars (Optional)
Type: Online System String
correlationContext (Optional)
Type: Online System Nullable Online Guid
frameOffset (Optional)
Type: Online System Int32
See Also
Trace Class
Trace Members
Write Overload
NFX Namespace


URIUtils Class

URIUtils Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX URIUtils

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class URIUtils
public static class URIUtils
<ExtensionAttribute>
Public NotInheritable Class URIUtils
<ExtensionAttribute>
Public NotInheritable Class URIUtils
[ExtensionAttribute]
public ref class URIUtils abstract sealed
[ExtensionAttribute]
public ref class URIUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type URIUtils =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type URIUtils =  class end
See Also
URIUtils Members
NFX Namespace


URIUtils Members

URIUtils Members NFX Class Library

The URIUtils type exposes the following members.
Methods
Name | Description
ComposeURLQueryString |
EscapeAllDataStringChars | Escapes all chars except latin A..Z, 0..9, and . - _ This function is based on EscapeDataString but does not depend on .NET 4/4.5 differences encoding ! * ( ) and others...
EscapeURIDataStringWithQuotes | Performs URI.EscapeDataString with additional replacement of " and ' chars with their hex equivalents. This method is suitable for escaping client-side intelligent keys that may have single/double quotes
EscapeURIStringWithPlus | Performs escaping plus sign in URL into its hex value
JoinPathSegs | Joins URI path segments with "/". This function just concats strings, it does not evaluate relative paths etc. The first segment may or may not start with '/'
Back to Top
Fields
Name | Description
PATH_JOIN_TRIM_CHARS |
Back to Top
See Also
URIUtils Class
NFX Namespace


URIUtils Fields

URIUtils Fields NFX Class Library

The URIUtils type exposes the following members.
Fields
Name | Description
PATH_JOIN_TRIM_CHARS |
Back to Top
See Also
URIUtils Class
NFX Namespace


URIUtils.PATH_JOIN_TRIM_CHARS Field

URIUtils PATH_JOIN_TRIM_CHARS Field NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly char[] PATH_JOIN_TRIM_CHARS
public static readonly char[] PATH_JOIN_TRIM_CHARS
Public Shared ReadOnly PATH_JOIN_TRIM_CHARS As Char()
Public Shared ReadOnly PATH_JOIN_TRIM_CHARS As Char()
public:
static initonly array<wchar_t>^ PATH_JOIN_TRIM_CHARS
public:
static initonly array<wchar_t>^ PATH_JOIN_TRIM_CHARS
static val PATH_JOIN_TRIM_CHARS: char[]
static val PATH_JOIN_TRIM_CHARS: char[]

Field Value

Type: Online Char
See Also
URIUtils Class
URIUtils Members
NFX Namespace


URIUtils Methods

URIUtils Methods NFX Class Library

The URIUtils type exposes the following members.
Methods
Name | Description
ComposeURLQueryString |
EscapeAllDataStringChars | Escapes all chars except latin A..Z, 0..9, and . - _ This function is based on EscapeDataString but does not depend on .NET 4/4.5 differences encoding ! * ( ) and others...
EscapeURIDataStringWithQuotes | Performs URI.EscapeDataString with additional replacement of " and ' chars with their hex equivalents. This method is suitable for escaping client-side intelligent keys that may have single/double quotes
EscapeURIStringWithPlus | Performs escaping plus sign in URL into its hex value
JoinPathSegs | Joins URI path segments with "/". This function just concats strings, it does not evaluate relative paths etc. The first segment may or may not start with '/'
Back to Top
See Also
URIUtils Class
NFX Namespace


URIUtils.ComposeURLQueryString Method

URIUtils ComposeURLQueryString Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ComposeURLQueryString(
    IDictionary<string, Object> qParams
)
public static string ComposeURLQueryString(
    IDictionary<string, Object> qParams
)
Public Shared Function ComposeURLQueryString (
    qParams As IDictionary(Of String, Object)
) As String
Public Shared Function ComposeURLQueryString (
    qParams As IDictionary(Of String, Object)
) As String
public:
static String^ ComposeURLQueryString(
    IDictionary<String^, Object^>^ qParams
)
public:
static String^ ComposeURLQueryString(
    IDictionary<String^, Object^>^ qParams
)
static member ComposeURLQueryString :
        qParams : IDictionary<string, Object> -> string
static member ComposeURLQueryString :
        qParams : IDictionary<string, Object> -> string

Parameters

qParams
Type: Online System.Collections.Generic IDictionary Online String, Online Object

Return Value

Type: Online String
See Also
URIUtils Class
URIUtils Members
NFX Namespace


URIUtils.EscapeAllDataStringChars Method

URIUtils EscapeAllDataStringChars Method NFX Class Library

Escapes all chars except latin A..Z, 0..9, and . - _ This function is based on EscapeDataString but does not depend on .NET 4/4.5 differences encoding ! * ( ) and others...

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string EscapeAllDataStringChars(
    this string str
)
public static string EscapeAllDataStringChars(
    this string str
)
<ExtensionAttribute>
Public Shared Function EscapeAllDataStringChars (
    str As String
) As String
<ExtensionAttribute>
Public Shared Function EscapeAllDataStringChars (
    str As String
) As String
public:
[ExtensionAttribute]
static String^ EscapeAllDataStringChars(
    String^ str
)
public:
[ExtensionAttribute]
static String^ EscapeAllDataStringChars(
    String^ str
)
static member EscapeAllDataStringChars :
        str : string -> string
static member EscapeAllDataStringChars :
        str : string -> string

Parameters

str
Type: Online System String

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
URIUtils Class
URIUtils Members
NFX Namespace


URIUtils.EscapeURIDataStringWithQuotes Method

URIUtils EscapeURIDataStringWithQuotes Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Performs URI.EscapeDataString with additional replacement of " and ' chars with their hex equivalents. This method is suitable for escaping client-side intelligent keys that may have single/double quotes

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string EscapeURIDataStringWithQuotes(
    this string uri
)
public static string EscapeURIDataStringWithQuotes(
    this string uri
)
<ExtensionAttribute>
Public Shared Function EscapeURIDataStringWithQuotes (
    uri As String
) As String
<ExtensionAttribute>
Public Shared Function EscapeURIDataStringWithQuotes (
    uri As String
) As String
public:
[ExtensionAttribute]
static String^ EscapeURIDataStringWithQuotes(
    String^ uri
)
public:
[ExtensionAttribute]
static String^ EscapeURIDataStringWithQuotes(
    String^ uri
)
static member EscapeURIDataStringWithQuotes :
        uri : string -> string
static member EscapeURIDataStringWithQuotes :
        uri : string -> string

Parameters

uri
Type: Online System String

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
URIUtils Class
URIUtils Members
NFX Namespace


URIUtils.EscapeURIStringWithPlus Method

URIUtils EscapeURIStringWithPlus Method NFX Class Library

Performs escaping plus sign in URL into its hex value

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string EscapeURIStringWithPlus(
    this string uri
)
public static string EscapeURIStringWithPlus(
    this string uri
)
<ExtensionAttribute>
Public Shared Function EscapeURIStringWithPlus (
    uri As String
) As String
<ExtensionAttribute>
Public Shared Function EscapeURIStringWithPlus (
    uri As String
) As String
public:
[ExtensionAttribute]
static String^ EscapeURIStringWithPlus(
    String^ uri
)
public:
[ExtensionAttribute]
static String^ EscapeURIStringWithPlus(
    String^ uri
)
static member EscapeURIStringWithPlus :
        uri : string -> string
static member EscapeURIStringWithPlus :
        uri : string -> string

Parameters

uri
Type: Online System String

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
URIUtils Class
URIUtils Members
NFX Namespace


URIUtils.JoinPathSegs Method

URIUtils JoinPathSegs Method NFX Class Library

Joins URI path segments with "/". This function just concats strings, it does not evaluate relative paths etc. The first segment may or may not start with '/'

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string JoinPathSegs(
    params string[] segments
)
public static string JoinPathSegs(
    params string[] segments
)
Public Shared Function JoinPathSegs (
    ParamArray segments As String()
) As String
Public Shared Function JoinPathSegs (
    ParamArray segments As String()
) As String
public:
static String^ JoinPathSegs(
    ... array<String^>^ segments
)
public:
static String^ JoinPathSegs(
    ... array<String^>^ segments
)
static member JoinPathSegs :
        segments : string[] -> string
static member JoinPathSegs :
        segments : string[] -> string

Parameters

segments
Type: Online System String

Return Value

Type: Online String
See Also
URIUtils Class
URIUtils Members
NFX Namespace


WrappedException Class

WrappedException Class NFX Class Library

Represents exception that contains data about causing exception with all of it's chain
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX WrappedException

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class WrappedException : NFXException
[SerializableAttribute]
public sealed class WrappedException : NFXException
<SerializableAttribute>
Public NotInheritable Class WrappedException
    Inherits NFXException
<SerializableAttribute>
Public NotInheritable Class WrappedException
    Inherits NFXException
[SerializableAttribute]
public ref class WrappedException sealed : public NFXException
[SerializableAttribute]
public ref class WrappedException sealed : public NFXException
[<SealedAttribute>]
[<SerializableAttribute>]
type WrappedException =
    class
        inherit NFXException
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type WrappedException =
    class
        inherit NFXException
    end
See Also
WrappedException Members
NFX Namespace


WrappedException Members

WrappedException Members NFX Class Library

The WrappedException type exposes the following members.
Constructors
 | Name | Description
Public method | WrappedException(WrappedExceptionData) | Initializes a new instance of the WrappedException class
Protected method | WrappedException(SerializationInfo, StreamingContext) | Initializes a new instance of the WrappedException class
Public method | WrappedException(String, WrappedExceptionData) | Initializes a new instance of the WrappedException class
Public method | WrappedException(String, WrappedExceptionData, Exception) | Initializes a new instance of the WrappedException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Public property | Wrapped | Returns wrapped exception data
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
WrappedException Class
NFX Namespace


WrappedException Constructor

WrappedException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | WrappedException(WrappedExceptionData) | Initializes a new instance of the WrappedException class
Protected method | WrappedException(SerializationInfo, StreamingContext) | Initializes a new instance of the WrappedException class
Public method | WrappedException(String, WrappedExceptionData) | Initializes a new instance of the WrappedException class
Public method | WrappedException(String, WrappedExceptionData, Exception) | Initializes a new instance of the WrappedException class
Back to Top
See Also
WrappedException Class
WrappedException Members
NFX Namespace


WrappedException Constructor (WrappedExceptionData)

WrappedException Constructor (WrappedExceptionData) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the WrappedException class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WrappedException(
    WrappedExceptionData data
)
public WrappedException(
    WrappedExceptionData data
)
Public Sub New (
    data As WrappedExceptionData
)
Public Sub New (
    data As WrappedExceptionData
)
public:
WrappedException(
    WrappedExceptionData^ data
)
public:
WrappedException(
    WrappedExceptionData^ data
)
new :
        data : WrappedExceptionData -> WrappedException
new :
        data : WrappedExceptionData -> WrappedException

Parameters

data
Type: NFX WrappedExceptionData
See Also
WrappedException Class
WrappedException Members
WrappedException Overload
NFX Namespace


WrappedException Constructor (SerializationInfo, StreamingContext)

WrappedException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the WrappedException class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal WrappedException(
    SerializationInfo info,
    StreamingContext context
)
internal WrappedException(
    SerializationInfo info,
    StreamingContext context
)
Friend Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Friend Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
internal:
WrappedException(
    SerializationInfo^ info,
    StreamingContext context
)
internal:
WrappedException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> WrappedException
new :
        info : SerializationInfo *
        context : StreamingContext -> WrappedException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
WrappedException Class
WrappedException Members
WrappedException Overload
NFX Namespace


WrappedException Constructor (String, WrappedExceptionData)

WrappedException Constructor (String, WrappedExceptionData) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the WrappedException class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WrappedException(
    string message,
    WrappedExceptionData data
)
public WrappedException(
    string message,
    WrappedExceptionData data
)
Public Sub New (
    message As String,
    data As WrappedExceptionData
)
Public Sub New (
    message As String,
    data As WrappedExceptionData
)
public:
WrappedException(
    String^ message,
    WrappedExceptionData^ data
)
public:
WrappedException(
    String^ message,
    WrappedExceptionData^ data
)
new :
        message : string *
        data : WrappedExceptionData -> WrappedException
new :
        message : string *
        data : WrappedExceptionData -> WrappedException

Parameters

message
Type: Online System String
data
Type: NFX WrappedExceptionData
See Also
WrappedException Class
WrappedException Members
WrappedException Overload
NFX Namespace


WrappedException Constructor (String, WrappedExceptionData, Exception)

WrappedException Constructor (String, WrappedExceptionData, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the WrappedException class

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WrappedException(
    string message,
    WrappedExceptionData data,
    Exception inner
)
public WrappedException(
    string message,
    WrappedExceptionData data,
    Exception inner
)
Public Sub New (
    message As String,
    data As WrappedExceptionData,
    inner As Exception
)
Public Sub New (
    message As String,
    data As WrappedExceptionData,
    inner As Exception
)
public:
WrappedException(
    String^ message,
    WrappedExceptionData^ data,
    Exception^ inner
)
public:
WrappedException(
    String^ message,
    WrappedExceptionData^ data,
    Exception^ inner
)
new :
        message : string *
        data : WrappedExceptionData *
        inner : Exception -> WrappedException
new :
        message : string *
        data : WrappedExceptionData *
        inner : Exception -> WrappedException

Parameters

message
Type: Online System String
data
Type: NFX WrappedExceptionData
inner
Type: Online System Exception
See Also
WrappedException Class
WrappedException Members
WrappedException Overload
NFX Namespace


WrappedException Methods

WrappedException Methods NFX Class Library

The WrappedException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
WrappedException Class
NFX Namespace


WrappedException Properties

WrappedException Properties NFX Class Library

The WrappedException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Public property | Wrapped | Returns wrapped exception data
Back to Top
See Also
WrappedException Class
NFX Namespace


WrappedException.Wrapped Property

WrappedException Wrapped Property NFX Class Library

Returns wrapped exception data

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WrappedExceptionData Wrapped { get; }
public WrappedExceptionData Wrapped { get; }
Public ReadOnly Property Wrapped As WrappedExceptionData
    Get
Public ReadOnly Property Wrapped As WrappedExceptionData
    Get
public:
property WrappedExceptionData^ Wrapped {
    WrappedExceptionData^ get ();
}
public:
property WrappedExceptionData^ Wrapped {
    WrappedExceptionData^ get ();
}
member Wrapped : WrappedExceptionData with get
member Wrapped : WrappedExceptionData with get

Property Value

Type: WrappedExceptionData
See Also
WrappedException Class
WrappedException Members
NFX Namespace


WrappedException Events

WrappedException Events NFX Class Library

The WrappedException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
WrappedException Class
NFX Namespace


WrappedExceptionData Class

WrappedExceptionData Class NFX Class Library

Marshalls exception details
Inheritance Hierarchy
Online System Object
NFX WrappedExceptionData

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class WrappedExceptionData
[SerializableAttribute]
public sealed class WrappedExceptionData
<SerializableAttribute>
Public NotInheritable Class WrappedExceptionData
<SerializableAttribute>
Public NotInheritable Class WrappedExceptionData
[SerializableAttribute]
public ref class WrappedExceptionData sealed
[SerializableAttribute]
public ref class WrappedExceptionData sealed
[<SealedAttribute>]
[<SerializableAttribute>]
type WrappedExceptionData =  class end
[<SealedAttribute>]
[<SerializableAttribute>]
type WrappedExceptionData =  class end
See Also
WrappedExceptionData Members
NFX Namespace


WrappedExceptionData Members

WrappedExceptionData Members NFX Class Library

The WrappedExceptionData type exposes the following members.
Constructors
 | Name | Description
Public method | WrappedExceptionData | Initializes instance form local exception
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationName | Returns the name of remote application
Public property | Code | Returns the code of remote NFX exception
Public property | InnerException | Returns the inner remote exception if any
Public property | Message | Returns the message of remote exception
Public property | Source | Name of the object that caused the error
Public property | StackTrace | Returns stack trace
Public property | TypeName | Returns the name of remote exception type
Back to Top
See Also
WrappedExceptionData Class
NFX Namespace


WrappedExceptionData Constructor

WrappedExceptionData Constructor NFX Class Library

Initializes instance form local exception

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WrappedExceptionData(
    Exception error,
    bool captureStack = true
)
public WrappedExceptionData(
    Exception error,
    bool captureStack = true
)
Public Sub New (
    error As Exception,
    Optional captureStack As Boolean = true
)
Public Sub New (
    error As Exception,
    Optional captureStack As Boolean = true
)
public:
WrappedExceptionData(
    Exception^ error,
    bool captureStack = true
)
public:
WrappedExceptionData(
    Exception^ error,
    bool captureStack = true
)
new :
        error : Exception *
        ?captureStack : bool
(* Defaults:
        let _captureStack = defaultArg captureStack true
*)
-> WrappedExceptionData
new :
        error : Exception *
        ?captureStack : bool
(* Defaults:
        let _captureStack = defaultArg captureStack true
*)
-> WrappedExceptionData

Parameters

error
Type: Online System Exception
captureStack (Optional)
Type: Online System Boolean
See Also
WrappedExceptionData Class
WrappedExceptionData Members
NFX Namespace


WrappedExceptionData Methods

WrappedExceptionData Methods NFX Class Library

The WrappedExceptionData type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WrappedExceptionData Class
NFX Namespace


WrappedExceptionData.ToString Method

WrappedExceptionData ToString Method NFX Class Library

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
WrappedExceptionData Class
WrappedExceptionData Members
NFX Namespace


WrappedExceptionData Properties

WrappedExceptionData Properties NFX Class Library

The WrappedExceptionData type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationName | Returns the name of remote application
Public property | Code | Returns the code of remote NFX exception
Public property | InnerException | Returns the inner remote exception if any
Public property | Message | Returns the message of remote exception
Public property | Source | Name of the object that caused the error
Public property | StackTrace | Returns stack trace
Public property | TypeName | Returns the name of remote exception type
Back to Top
See Also
WrappedExceptionData Class
NFX Namespace


WrappedExceptionData.ApplicationName Property

WrappedExceptionData ApplicationName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns the name of remote application

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ApplicationName { get; }
public string ApplicationName { get; }
Public ReadOnly Property ApplicationName As String
    Get
Public ReadOnly Property ApplicationName As String
    Get
public:
property String^ ApplicationName {
    String^ get ();
}
public:
property String^ ApplicationName {
    String^ get ();
}
member ApplicationName : string with get
member ApplicationName : string with get

Property Value

Type: Online String
See Also
WrappedExceptionData Class
WrappedExceptionData Members
NFX Namespace


WrappedExceptionData.Code Property

WrappedExceptionData Code Property NFX Class Library

Returns the code of remote NFX exception

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Code { get; }
public int Code { get; }
Public ReadOnly Property Code As Integer
    Get
Public ReadOnly Property Code As Integer
    Get
public:
property int Code {
    int get ();
}
public:
property int Code {
    int get ();
}
member Code : int with get
member Code : int with get

Property Value

Type: Online Int32
See Also
WrappedExceptionData Class
WrappedExceptionData Members
NFX Namespace


WrappedExceptionData.InnerException Property

WrappedExceptionData InnerException Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns the inner remote exception if any

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WrappedExceptionData InnerException { get; }
public WrappedExceptionData InnerException { get; }
Public ReadOnly Property InnerException As WrappedExceptionData
    Get
Public ReadOnly Property InnerException As WrappedExceptionData
    Get
public:
property WrappedExceptionData^ InnerException {
    WrappedExceptionData^ get ();
}
public:
property WrappedExceptionData^ InnerException {
    WrappedExceptionData^ get ();
}
member InnerException : WrappedExceptionData with get
member InnerException : WrappedExceptionData with get

Property Value

Type: WrappedExceptionData
See Also
WrappedExceptionData Class
WrappedExceptionData Members
NFX Namespace


WrappedExceptionData.Message Property

WrappedExceptionData Message Property NFX Class Library

Returns the message of remote exception

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Message { get; }
public string Message { get; }
Public ReadOnly Property Message As String
    Get
Public ReadOnly Property Message As String
    Get
public:
property String^ Message {
    String^ get ();
}
public:
property String^ Message {
    String^ get ();
}
member Message : string with get
member Message : string with get

Property Value

Type: Online String
See Also
WrappedExceptionData Class
WrappedExceptionData Members
NFX Namespace


WrappedExceptionData.Source Property

WrappedExceptionData Source Property NFX Class Library

Name of the object that caused the error

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Source { get; }
public string Source { get; }
Public ReadOnly Property Source As String
    Get
Public ReadOnly Property Source As String
    Get
public:
property String^ Source {
    String^ get ();
}
public:
property String^ Source {
    String^ get ();
}
member Source : string with get
member Source : string with get

Property Value

Type: Online String
See Also
WrappedExceptionData Class
WrappedExceptionData Members
NFX Namespace


WrappedExceptionData.StackTrace Property

WrappedExceptionData StackTrace Property NFX Class Library

Returns stack trace

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string StackTrace { get; }
public string StackTrace { get; }
Public ReadOnly Property StackTrace As String
    Get
Public ReadOnly Property StackTrace As String
    Get
public:
property String^ StackTrace {
    String^ get ();
}
public:
property String^ StackTrace {
    String^ get ();
}
member StackTrace : string with get
member StackTrace : string with get

Property Value

Type: Online String
See Also
WrappedExceptionData Class
WrappedExceptionData Members
NFX Namespace


WrappedExceptionData.TypeName Property

WrappedExceptionData TypeName Property NFX Class Library

Returns the name of remote exception type

Namespace: NFX
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string TypeName { get; }
public string TypeName { get; }
Public ReadOnly Property TypeName As String
    Get
Public ReadOnly Property TypeName As String
    Get
public:
property String^ TypeName {
    String^ get ();
}
public:
property String^ TypeName {
    String^ get ();
}
member TypeName : string with get
member TypeName : string with get

Property Value

Type: Online String
See Also
WrappedExceptionData Class
WrappedExceptionData Members
NFX Namespace


NFX.ApplicationModel Namespace

NFX.ApplicationModel Namespace NFX Class Library

Stipulates base contracts for application containers - ApplicationModel. Application Containers unify the way how different types of applications are written (i.e. console, service, web, GUI)
Classes
 | Class | Description
Public class | ApplicationComponent | An abstraction of a disposable application component - major implementation/functionality part of an app. Components logically subdivide application container so their instances may be discovered by other parties, for example: one may iterate over all components in an application that support instrumentation and logging. Services are sub-types of components. Use "ApplicationComponent.AllComponents" to access all components in the container
Public class | BaseSession | Implements base ISession functionality
Public class | CommonApplicationLogic | Provides base implementation of IApplication for various application kinds
Public class | ExecutionContext | Provides access to execution context - an entity that groups Request, Response and Session object. This class has nothing to do with Web. Execution contexts are supported as easily in console, service, web, and Windows forms apps. All objects may be either application-global or thread level. This class is useful for technology-agnostic implementations of Record Models i.e. in a Record class one may write: " if (ExecutionContext.Session.User.Kind==UserKind.Administrator)..."
Public class | NOPApplication | Represents an application that consists of pure-nop providers, consequently this application does not log, does not store data and does not do anything else still satisfying its contract
Public class | NOPSession | Represents a session that does nothing and returns fake user
Public class | ServiceBaseApplication | Provides base implementation of IApplication for applications that have no forms like services and console apps. This class IS thread safe
Public class | TestApplication | Application designated for use in various unit test cases. This class is not intended for use in production systems!
Interfaces
 | Interface | Description
Public interface | IApplication | Describes general application model - usually a dependency injection container that governs application initialization, state management, logging etc... An applications is usually implemented with a singleton class that has static conduits to instance properties. Applications may be passed by reference (hence this interface) to simplify mocking that otherwise (in case of static-only class) would have been impossible
Public interface | IApplicationComponent | Provides marker contract requirement for an ApplicationComponent. This interface must be implemented only by ApplicationComponent class
Public interface | IApplicationFinishNotifiable | Represents an entity that can get notified about application finish
Public interface | IApplicationStarter | Represents an entity that performs work on application start. This entity must be either invoked directly or declared in config file under "starters" section
Public interface | ISession | Describes user session
Enumerations
 | Enumeration | Description
Public enumeration | SessionLoginType | Denotes types of session login


ApplicationComponent Class

ApplicationComponent Class NFX Class Library

An abstraction of a disposable application component - major implementation/functionality part of an app. Components logically subdivide application container so their instances may be discovered by other parties, for example: one may iterate over all components in an application that support instrumentation and logging. Services are sub-types of components. Use "ApplicationComponent.AllComponents" to access all components in the container
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ApplicationModel.Volatile NOPObjectStore
NFX.DataAccess.Cache CacheStore
NFX.DataAccess.CRUD.Subscriptions SubscriptionAppComponent
NFX.DataAccess.MongoDB.Connector Connection
NFX.DataAccess.MongoDB.Connector MongoClient
NFX.DataAccess.MongoDB.Connector ServerNode
NFX.DataAccess.MongoDB MongoDBDataStoreBase
NFX.DataAccess.MySQL MySQLDataStoreBase
NFX.DataAccess NOPDataStore
NFX.Glue NOPGlue
NFX.Instrumentation NOPInstrumentation
NFX.IO.FileSystem FileSystem
NFX.IO.Net.Gate NOPNetGate
NFX.Log.Destinations Destination
NFX.Log NOPLog
NFX.Security NOPSecurityManager
NFX.ServiceModel Service
NFX.Throttling NOPThrottling
NFX.Throttling Throttle
NFX.Time DefaultTimeSource
NFX.Time Event
NFX.Time NOPEventTimer
NFX.Wave Portal
NFX.Wave PortalHub
NFX.Wave WorkFilter
NFX.Wave WorkHandler

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class ApplicationComponent : DisposableObject,
    IApplicationComponent, IDisposable
public abstract class ApplicationComponent : DisposableObject,
    IApplicationComponent, IDisposable
Public MustInherit Class ApplicationComponent
    Inherits DisposableObject
    Implements IApplicationComponent, IDisposable
Public MustInherit Class ApplicationComponent
    Inherits DisposableObject
    Implements IApplicationComponent, IDisposable
public ref class ApplicationComponent abstract : public DisposableObject,
    IApplicationComponent, IDisposable
public ref class ApplicationComponent abstract : public DisposableObject,
    IApplicationComponent, IDisposable
[<AbstractClassAttribute>]
type ApplicationComponent =
    class
        inherit DisposableObject
        interface IApplicationComponent
        interface IDisposable
    end
[<AbstractClassAttribute>]
type ApplicationComponent =
    class
        inherit DisposableObject
        interface IApplicationComponent
        interface IDisposable
    end
See Also
ApplicationComponent Members
NFX.ApplicationModel Namespace


ApplicationComponent Members

ApplicationComponent Members NFX Class Library

The ApplicationComponent type exposes the following members.
Constructors
 | Name | Description
Protected method | ApplicationComponent | Initializes a new instance of the ApplicationComponent class
Protected method | ApplicationComponent(Object) | Initializes a new instance of the ApplicationComponent class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector |
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
 | GetAppComponentByCommonName | Looks-up an existing application component instance by its ComponentCommonName or null. The search is case-insensitive
 | GetAppComponentBySID | Looks-up an existing application component instance by its ComponentSID or null
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
 | AllComponents | Returns a thread-safe enumerable( a snapshot) of all known component instances
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null
Public property | ComponentSID | Returns process/instance unique app component system id
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Back to Top
See Also
ApplicationComponent Class
NFX.ApplicationModel Namespace


ApplicationComponent Constructor

ApplicationComponent Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | ApplicationComponent | Initializes a new instance of the ApplicationComponent class
Protected method | ApplicationComponent(Object) | Initializes a new instance of the ApplicationComponent class
Back to Top
See Also
ApplicationComponent Class
ApplicationComponent Members
NFX.ApplicationModel Namespace


ApplicationComponent Constructor

ApplicationComponent Constructor NFX Class Library

Initializes a new instance of the ApplicationComponent class

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ApplicationComponent()
protected ApplicationComponent()
Protected Sub New
Protected Sub New
protected:
ApplicationComponent()
protected:
ApplicationComponent()
new : unit -> ApplicationComponent
new : unit -> ApplicationComponent
See Also
ApplicationComponent Class
ApplicationComponent Members
ApplicationComponent Overload
NFX.ApplicationModel Namespace


ApplicationComponent Constructor (Object)

ApplicationComponent Constructor (Object) NFX Class Library

Initializes a new instance of the ApplicationComponent class

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ApplicationComponent(
    Object director
)
protected ApplicationComponent(
    Object director
)
Protected Sub New (
    director As Object
)
Protected Sub New (
    director As Object
)
protected:
ApplicationComponent(
    Object^ director
)
protected:
ApplicationComponent(
    Object^ director
)
new :
        director : Object -> ApplicationComponent
new :
        director : Object -> ApplicationComponent

Parameters

director
Type: Online System Object
See Also
ApplicationComponent Class
ApplicationComponent Members
ApplicationComponent Overload
NFX.ApplicationModel Namespace


ApplicationComponent Methods

ApplicationComponent Methods NFX Class Library

The ApplicationComponent type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector |
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
 | GetAppComponentByCommonName | Looks-up an existing application component instance by its ComponentCommonName or null. The search is case-insensitive
 | GetAppComponentBySID | Looks-up an existing application component instance by its ComponentSID or null
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ApplicationComponent Class
NFX.ApplicationModel Namespace


ApplicationComponent.__setComponentDirector Method

ApplicationComponent __setComponentDirector Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void __setComponentDirector(
    Object director
)
internal void __setComponentDirector(
    Object director
)
Friend Sub __setComponentDirector (
    director As Object
)
Friend Sub __setComponentDirector (
    director As Object
)
internal:
void __setComponentDirector(
    Object^ director
)
internal:
void __setComponentDirector(
    Object^ director
)
internal member __setComponentDirector :
        director : Object -> unit
internal member __setComponentDirector :
        director : Object -> unit

Parameters

director
Type: Online System Object
See Also
ApplicationComponent Class
ApplicationComponent Members
NFX.ApplicationModel Namespace


ApplicationComponent.Destructor Method

ApplicationComponent Destructor Method NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
ApplicationComponent Class
ApplicationComponent Members
NFX.ApplicationModel Namespace


ApplicationComponent.GetAppComponentByCommonName Method

ApplicationComponent GetAppComponentByCommonName Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Looks-up an existing application component instance by its ComponentCommonName or null. The search is case-insensitive

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ApplicationComponent GetAppComponentByCommonName(
    string name
)
public static ApplicationComponent GetAppComponentByCommonName(
    string name
)
Public Shared Function GetAppComponentByCommonName (
    name As String
) As ApplicationComponent
Public Shared Function GetAppComponentByCommonName (
    name As String
) As ApplicationComponent
public:
static ApplicationComponent^ GetAppComponentByCommonName(
    String^ name
)
public:
static ApplicationComponent^ GetAppComponentByCommonName(
    String^ name
)
static member GetAppComponentByCommonName :
        name : string -> ApplicationComponent
static member GetAppComponentByCommonName :
        name : string -> ApplicationComponent

Parameters

name
Type: Online System String

Return Value

Type: ApplicationComponent
See Also
ApplicationComponent Class
ApplicationComponent Members
NFX.ApplicationModel Namespace


ApplicationComponent.GetAppComponentBySID Method

ApplicationComponent GetAppComponentBySID Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Looks-up an existing application component instance by its ComponentSID or null

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ApplicationComponent GetAppComponentBySID(
    ulong sid
)
public static ApplicationComponent GetAppComponentBySID(
    ulong sid
)
Public Shared Function GetAppComponentBySID (
    sid As ULong
) As ApplicationComponent
Public Shared Function GetAppComponentBySID (
    sid As ULong
) As ApplicationComponent
public:
static ApplicationComponent^ GetAppComponentBySID(
    unsigned long long sid
)
public:
static ApplicationComponent^ GetAppComponentBySID(
    unsigned long long sid
)
static member GetAppComponentBySID :
        sid : uint64 -> ApplicationComponent
static member GetAppComponentBySID :
        sid : uint64 -> ApplicationComponent

Parameters

sid
Type: Online System UInt64

Return Value

Type: ApplicationComponent
See Also
ApplicationComponent Class
ApplicationComponent Members
NFX.ApplicationModel Namespace


ApplicationComponent Properties

ApplicationComponent Properties NFX Class Library

The ApplicationComponent type exposes the following members.
Properties
 | Name | Description
 | AllComponents | Returns a thread-safe enumerable( a snapshot) of all known component instances
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null
Public property | ComponentSID | Returns process/instance unique app component system id
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Back to Top
See Also
ApplicationComponent Class
NFX.ApplicationModel Namespace


ApplicationComponent.AllComponents Property

ApplicationComponent AllComponents Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns a thread-safe enumerable( a snapshot) of all known component instances

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<ApplicationComponent> AllComponents { get; }
public static IEnumerable<ApplicationComponent> AllComponents { get; }
Public Shared ReadOnly Property AllComponents As IEnumerable(Of ApplicationComponent)
    Get
Public Shared ReadOnly Property AllComponents As IEnumerable(Of ApplicationComponent)
    Get
public:
static property IEnumerable<ApplicationComponent^>^ AllComponents {
    IEnumerable<ApplicationComponent^>^ get ();
}
public:
static property IEnumerable<ApplicationComponent^>^ AllComponents {
    IEnumerable<ApplicationComponent^>^ get ();
}
static member AllComponents : IEnumerable<ApplicationComponent> with get
static member AllComponents : IEnumerable<ApplicationComponent> with get

Property Value

Type: Online IEnumerable ApplicationComponent
See Also
ApplicationComponent Class
ApplicationComponent Members
NFX.ApplicationModel Namespace


ApplicationComponent.ComponentCommonName Property

ApplicationComponent ComponentCommonName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string ComponentCommonName { get; }
public virtual string ComponentCommonName { get; }
Public Overridable ReadOnly Property ComponentCommonName As String
    Get
Public Overridable ReadOnly Property ComponentCommonName As String
    Get
public:
virtual property String^ ComponentCommonName {
    String^ get ();
}
public:
virtual property String^ ComponentCommonName {
    String^ get ();
}
abstract ComponentCommonName : string with get
override ComponentCommonName : string with get
abstract ComponentCommonName : string with get
override ComponentCommonName : string with get

Property Value

Type: Online String

Implements

IApplicationComponent ComponentCommonName
See Also
ApplicationComponent Class
ApplicationComponent Members
NFX.ApplicationModel Namespace


ApplicationComponent.ComponentDirector Property

ApplicationComponent ComponentDirector Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns a reference to an object that this app component services/operates under, or null

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object ComponentDirector { get; }
public Object ComponentDirector { get; }
Public ReadOnly Property ComponentDirector As Object
    Get
Public ReadOnly Property ComponentDirector As Object
    Get
public:
virtual property Object^ ComponentDirector {
    Object^ get () sealed;
}
public:
virtual property Object^ ComponentDirector {
    Object^ get () sealed;
}
abstract ComponentDirector : Object with get
override ComponentDirector : Object with get
abstract ComponentDirector : Object with get
override ComponentDirector : Object with get

Property Value

Type: Online Object

Implements

IApplicationComponent ComponentDirector
See Also
ApplicationComponent Class
ApplicationComponent Members
NFX.ApplicationModel Namespace


ApplicationComponent.ComponentSID Property

ApplicationComponent ComponentSID Property NFX Class Library

Returns process/instance unique app component system id

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong ComponentSID { get; }
public ulong ComponentSID { get; }
Public ReadOnly Property ComponentSID As ULong
    Get
Public ReadOnly Property ComponentSID As ULong
    Get
public:
virtual property unsigned long long ComponentSID {
    unsigned long long get () sealed;
}
public:
virtual property unsigned long long ComponentSID {
    unsigned long long get () sealed;
}
abstract ComponentSID : uint64 with get
override ComponentSID : uint64 with get
abstract ComponentSID : uint64 with get
override ComponentSID : uint64 with get

Property Value

Type: Online UInt64

Implements

IApplicationComponent ComponentSID
See Also
ApplicationComponent Class
ApplicationComponent Members
NFX.ApplicationModel Namespace


ApplicationComponent.ComponentStartTime Property

ApplicationComponent ComponentStartTime Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns local computer time of component start (not from application container time)

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime ComponentStartTime { get; }
public DateTime ComponentStartTime { get; }
Public ReadOnly Property ComponentStartTime As DateTime
    Get
Public ReadOnly Property ComponentStartTime As DateTime
    Get
public:
property DateTime ComponentStartTime {
    DateTime get ();
}
public:
property DateTime ComponentStartTime {
    DateTime get ();
}
member ComponentStartTime : DateTime with get
member ComponentStartTime : DateTime with get

Property Value

Type: Online DateTime
See Also
ApplicationComponent Class
ApplicationComponent Members
NFX.ApplicationModel Namespace


BaseSession Class

BaseSession Class NFX Class Library

Implements base ISession functionality
Inheritance Hierarchy
Online System Object
NFX.ApplicationModel BaseSession
NFX.Wave WaveSession

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class BaseSession : ISession,
    IEndableInstance
[SerializableAttribute]
public class BaseSession : ISession,
    IEndableInstance
<SerializableAttribute>
Public Class BaseSession
    Implements ISession, IEndableInstance
<SerializableAttribute>
Public Class BaseSession
    Implements ISession, IEndableInstance
[SerializableAttribute]
public ref class BaseSession : ISession,
    IEndableInstance
[SerializableAttribute]
public ref class BaseSession : ISession,
    IEndableInstance
[<SerializableAttribute>]
type BaseSession =
    class
        interface ISession
        interface IEndableInstance
    end
[<SerializableAttribute>]
type BaseSession =
    class
        interface ISession
        interface IEndableInstance
    end
See Also
BaseSession Members
NFX.ApplicationModel Namespace


BaseSession Members

BaseSession Members NFX Class Library

The BaseSession type exposes the following members.
Constructors
 | Name | Description
Protected method | BaseSession | Initializes a new instance of the BaseSession class
Public method | BaseSession(Guid) | Initializes a new instance of the BaseSession class
Back to Top
Methods
 | Name | Description
Public method | Acquire |
Public method | End | Ends session
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasJustLoggedIn | Called from business code when user supplies login credentals and/or performs another action that can be qualified as a reliable user identity proof
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegenerateID | Generates new GUID and stores it in ID storing old ID value in OldID property which is not serializable. The implementations may elect to re-stow the existing session under the new ID. This method is usefull for security, i.e. when user logs-in we may want to re-generate ID
Public method | Release |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_IsEnded |
Protected field | m_IsJustLoggedIn |
Protected field | m_IsNew |
Back to Top
Properties
 | Name | Description
Public property | ID | Returns Session ID
Public property | IDSecret | Returns Session ID secret - the ulong that identifies this session. This property is needed for cross-check upon GUID id lookup, so that Session ID GUID can not be forged by the client - a form of a "password"
Public property | IsEnded | Indicates whether this session was ended and will be destroyed after current request processing cycle
Public property | IsJustLoggedIn | Indicates that user login happened in current request processing cycle. This flag is useful for long term token assignment on release
Public property | IsNew | Indicates that session object was just created with current request processing cycle
Public property | Item | Shortcut to .Items. Getter return null instead of throwing if key is not found
Public property | Items | Provides a thread-safe dictionary of items
Public property | LanguageISOCode | Returns user language preference or null
Public property | LastLoginType | Returns the last login type
Public property | LastLoginUTC | Returns the UTC DateTime of the last login/when HasJustLoggedIn() was called for the last time within the lifetime of this session object or NULL
Public property | OldID | When this parameter is not null then RegenerateID() was called and session provider may need to re-stow session object under a new ID
Public property | User | Returns session user
Back to Top
See Also
BaseSession Class
NFX.ApplicationModel Namespace


BaseSession Constructor

BaseSession Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | BaseSession | Initializes a new instance of the BaseSession class
Public method | BaseSession(Guid) | Initializes a new instance of the BaseSession class
Back to Top
See Also
BaseSession Class
BaseSession Members
NFX.ApplicationModel Namespace


BaseSession Constructor

BaseSession Constructor NFX Class Library

Initializes a new instance of the BaseSession class

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected BaseSession()
protected BaseSession()
Protected Sub New
Protected Sub New
protected:
BaseSession()
protected:
BaseSession()
new : unit -> BaseSession
new : unit -> BaseSession
See Also
BaseSession Class
BaseSession Members
BaseSession Overload
NFX.ApplicationModel Namespace


BaseSession Constructor (Guid)

BaseSession Constructor (Guid) NFX Class Library

Initializes a new instance of the BaseSession class

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BaseSession(
    Guid id
)
public BaseSession(
    Guid id
)
Public Sub New (
    id As Guid
)
Public Sub New (
    id As Guid
)
public:
BaseSession(
    Guid id
)
public:
BaseSession(
    Guid id
)
new :
        id : Guid -> BaseSession
new :
        id : Guid -> BaseSession

Parameters

id
Type: Online System Guid
See Also
BaseSession Class
BaseSession Members
BaseSession Overload
NFX.ApplicationModel Namespace


BaseSession Fields

BaseSession Fields NFX Class Library

The BaseSession type exposes the following members.
Fields
 | Name | Description
Protected field | m_IsEnded |
Protected field | m_IsJustLoggedIn |
Protected field | m_IsNew |
Back to Top
See Also
BaseSession Class
NFX.ApplicationModel Namespace


BaseSession.m_IsEnded Field

BaseSession m_IsEnded Field NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[NonSerializedAttribute]
internal bool m_IsEnded
[NonSerializedAttribute]
internal bool m_IsEnded
<NonSerializedAttribute>
Friend m_IsEnded As Boolean
<NonSerializedAttribute>
Friend m_IsEnded As Boolean
internal:
[NonSerializedAttribute]
bool m_IsEnded
internal:
[NonSerializedAttribute]
bool m_IsEnded
[<NonSerializedAttribute>]
val mutable internal m_IsEnded: bool
[<NonSerializedAttribute>]
val mutable internal m_IsEnded: bool

Field Value

Type: Online Boolean
See Also
BaseSession Class
BaseSession Members
NFX.ApplicationModel Namespace


BaseSession.m_IsJustLoggedIn Field

BaseSession m_IsJustLoggedIn Field NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[NonSerializedAttribute]
internal bool m_IsJustLoggedIn
[NonSerializedAttribute]
internal bool m_IsJustLoggedIn
<NonSerializedAttribute>
Friend m_IsJustLoggedIn As Boolean
<NonSerializedAttribute>
Friend m_IsJustLoggedIn As Boolean
internal:
[NonSerializedAttribute]
bool m_IsJustLoggedIn
internal:
[NonSerializedAttribute]
bool m_IsJustLoggedIn
[<NonSerializedAttribute>]
val mutable internal m_IsJustLoggedIn: bool
[<NonSerializedAttribute>]
val mutable internal m_IsJustLoggedIn: bool

Field Value

Type: Online Boolean
See Also
BaseSession Class
BaseSession Members
NFX.ApplicationModel Namespace


BaseSession.m_IsNew Field

BaseSession m_IsNew Field NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[NonSerializedAttribute]
internal bool m_IsNew
[NonSerializedAttribute]
internal bool m_IsNew
<NonSerializedAttribute>
Friend m_IsNew As Boolean
<NonSerializedAttribute>
Friend m_IsNew As Boolean
internal:
[NonSerializedAttribute]
bool m_IsNew
internal:
[NonSerializedAttribute]
bool m_IsNew
[<NonSerializedAttribute>]
val mutable internal m_IsNew: bool
[<NonSerializedAttribute>]
val mutable internal m_IsNew: bool

Field Value

Type: Online Boolean
See Also
BaseSession Class
BaseSession Members
NFX.ApplicationModel Namespace


BaseSession Methods

BaseSession Methods NFX Class Library

The BaseSession type exposes the following members.
Methods
 | Name | Description
Public method | Acquire |
Public method | End | Ends session
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasJustLoggedIn | Called from business code when user supplies login credentals and/or performs another action that can be qualified as a reliable user identity proof
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegenerateID | Generates new GUID and stores it in ID storing old ID value in OldID property which is not serializable. The implementations may elect to re-stow the existing session under the new ID. This method is usefull for security, i.e. when user logs-in we may want to re-generate ID
Public method | Release |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BaseSession Class
NFX.ApplicationModel Namespace


BaseSession.Acquire Method

BaseSession Acquire Method NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Acquire()
public virtual void Acquire()
Public Overridable Sub Acquire
Public Overridable Sub Acquire
public:
virtual void Acquire()
public:
virtual void Acquire()
abstract Acquire : unit -> unit
override Acquire : unit -> unit
abstract Acquire : unit -> unit
override Acquire : unit -> unit

Implements

ISession Acquire
See Also
BaseSession Class
BaseSession Members
NFX.ApplicationModel Namespace


BaseSession.End Method

BaseSession End Method NFX Class Library

Ends session

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void End()
public virtual void End()
Public Overridable Sub End
Public Overridable Sub End
public:
virtual void End()
public:
virtual void End()
abstract End : unit -> unit
override End : unit -> unit
abstract End : unit -> unit
override End : unit -> unit

Implements

IEndableInstance End
See Also
BaseSession Class
BaseSession Members
NFX.ApplicationModel Namespace


BaseSession.HasJustLoggedIn Method

BaseSession HasJustLoggedIn Method NFX Class Library

Called from business code when user supplies login credentals and/or performs another action that can be qualified as a reliable user identity proof

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void HasJustLoggedIn(
    SessionLoginType loginType
)
public virtual void HasJustLoggedIn(
    SessionLoginType loginType
)
Public Overridable Sub HasJustLoggedIn (
    loginType As SessionLoginType
)
Public Overridable Sub HasJustLoggedIn (
    loginType As SessionLoginType
)
public:
virtual void HasJustLoggedIn(
    SessionLoginType loginType
)
public:
virtual void HasJustLoggedIn(
    SessionLoginType loginType
)
abstract HasJustLoggedIn :
        loginType : SessionLoginType -> unit
override HasJustLoggedIn :
        loginType : SessionLoginType -> unit
abstract HasJustLoggedIn :
        loginType : SessionLoginType -> unit
override HasJustLoggedIn :
        loginType : SessionLoginType -> unit

Parameters

loginType
Type: NFX.ApplicationModel SessionLoginType

Implements

ISession HasJustLoggedIn(SessionLoginType)
See Also
BaseSession Class
BaseSession Members
NFX.ApplicationModel Namespace


BaseSession.RegenerateID Method

BaseSession RegenerateID Method NFX Class Library

Generates new GUID and stores it in ID storing old ID value in OldID property which is not serializable. The implementations may elect to re-stow the existing session under the new ID. This method is usefull for security, i.e. when user logs-in we may want to re-generate ID

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RegenerateID()
public void RegenerateID()
Public Sub RegenerateID
Public Sub RegenerateID
public:
virtual void RegenerateID() sealed
public:
virtual void RegenerateID() sealed
abstract RegenerateID : unit -> unit
override RegenerateID : unit -> unit
abstract RegenerateID : unit -> unit
override RegenerateID : unit -> unit

Implements

ISession RegenerateID
See Also
BaseSession Class
BaseSession Members
NFX.ApplicationModel Namespace


BaseSession.Release Method

BaseSession Release Method NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Release()
public virtual void Release()
Public Overridable Sub Release
Public Overridable Sub Release
public:
virtual void Release()
public:
virtual void Release()
abstract Release : unit -> unit
override Release : unit -> unit
abstract Release : unit -> unit
override Release : unit -> unit

Implements

ISession Release
See Also
BaseSession Class
BaseSession Members
NFX.ApplicationModel Namespace


BaseSession Properties

BaseSession Properties NFX Class Library

The BaseSession type exposes the following members.
Properties
 | Name | Description
Public property | ID | Returns Session ID
Public property | IDSecret | Returns Session ID secret - the ulong that identifies this session. This property is needed for cross-check upon GUID id lookup, so that Session ID GUID can not be forged by the client - a form of a "password"
Public property | IsEnded | Indicates whether this session was ended and will be destroyed after current request processing cycle
Public property | IsJustLoggedIn | Indicates that user login happened in current request processing cycle. This flag is useful for long term token assignment on release
Public property | IsNew | Indicates that session object was just created with current request processing cycle
Public property | Item | Shortcut to .Items. Getter return null instead of throwing if key is not found
Public property | Items | Provides a thread-safe dictionary of items
Public property | LanguageISOCode | Returns user language preference or null
Public property | LastLoginType | Returns the last login type
Public property | LastLoginUTC | Returns the UTC DateTime of the last login/when HasJustLoggedIn() was called for the last time within the lifetime of this session object or NULL
Public property | OldID | When this parameter is not null then RegenerateID() was called and session provider may need to re-stow session object under a new ID
Public property | User | Returns session user
Back to Top
See Also
BaseSession Class
NFX.ApplicationModel Namespace


BaseSession.ID Property

BaseSession ID Property NFX Class Library

Returns Session ID

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid ID { get; }
public Guid ID { get; }
Public ReadOnly Property ID As Guid
    Get
Public ReadOnly Property ID As Guid
    Get
public:
virtual property Guid ID {
    Guid get () sealed;
}
public:
virtual property Guid ID {
    Guid get () sealed;
}
abstract ID : Guid with get
override ID : Guid with get
abstract ID : Guid with get
override ID : Guid with get

Property Value

Type: Online Guid

Implements

ISession ID
See Also
BaseSession Class
BaseSession Members
NFX.ApplicationModel Namespace


BaseSession.IDSecret Property

BaseSession IDSecret Property NFX Class Library

Returns Session ID secret - the ulong that identifies this session. This property is needed for cross-check upon GUID id lookup, so that Session ID GUID can not be forged by the client - a form of a "password"

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong IDSecret { get; }
public ulong IDSecret { get; }
Public ReadOnly Property IDSecret As ULong
    Get
Public ReadOnly Property IDSecret As ULong
    Get
public:
property unsigned long long IDSecret {
    unsigned long long get ();
}
public:
property unsigned long long IDSecret {
    unsigned long long get ();
}
member IDSecret : uint64 with get
member IDSecret : uint64 with get

Property Value

Type: Online UInt64
See Also
BaseSession Class
BaseSession Members
NFX.ApplicationModel Namespace


BaseSession.IsEnded Property

BaseSession IsEnded Property NFX Class Library

Indicates whether this session was ended and will be destroyed after current request processing cycle

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEnded { get; }
public bool IsEnded { get; }
Public ReadOnly Property IsEnded As Boolean
    Get
Public ReadOnly Property IsEnded As Boolean
    Get
public:
virtual property bool IsEnded {
    bool get () sealed;
}
public:
virtual property bool IsEnded {
    bool get () sealed;
}
abstract IsEnded : bool with get
override IsEnded : bool with get
abstract IsEnded : bool with get
override IsEnded : bool with get

Property Value

Type: Online Boolean

Implements

IEndableInstance IsEnded
See Also
BaseSession Class
BaseSession Members
NFX.ApplicationModel Namespace


BaseSession.IsJustLoggedIn Property

BaseSession IsJustLoggedIn Property NFX Class Library

Indicates that user login happened in current request processing cycle. This flag is useful for long term token assignment on release

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsJustLoggedIn { get; }
public bool IsJustLoggedIn { get; }
Public ReadOnly Property IsJustLoggedIn As Boolean
    Get
Public ReadOnly Property IsJustLoggedIn As Boolean
    Get
public:
virtual property bool IsJustLoggedIn {
    bool get () sealed;
}
public:
virtual property bool IsJustLoggedIn {
    bool get () sealed;
}
abstract IsJustLoggedIn : bool with get
override IsJustLoggedIn : bool with get
abstract IsJustLoggedIn : bool with get
override IsJustLoggedIn : bool with get

Property Value

Type: Online Boolean

Implements

ISession IsJustLoggedIn
See Also
BaseSession Class
BaseSession Members
NFX.ApplicationModel Namespace


BaseSession.IsNew Property

BaseSession IsNew Property NFX Class Library

Indicates that session object was just created with current request processing cycle

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsNew { get; }
public bool IsNew { get; }
Public ReadOnly Property IsNew As Boolean
    Get
Public ReadOnly Property IsNew As Boolean
    Get
public:
virtual property bool IsNew {
    bool get () sealed;
}
public:
virtual property bool IsNew {
    bool get () sealed;
}
abstract IsNew : bool with get
override IsNew : bool with get
abstract IsNew : bool with get
override IsNew : bool with get

Property Value

Type: Online Boolean

Implements

ISession IsNew
See Also
BaseSession Class
BaseSession Members
NFX.ApplicationModel Namespace


BaseSession.Item Property

BaseSession Item Property NFX Class Library

Shortcut to .Items. Getter return null instead of throwing if key is not found

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object this[
    Object key
] { get; set; }
public Object this[
    Object key
] { get; set; }
Public Default Property Item (
    key As Object
) As Object
    Get
    Set
Public Default Property Item (
    key As Object
) As Object
    Get
    Set
public:
virtual property Object^ default[Object^ key] {
    Object^ get (Object^ key) sealed;
    void set (Object^ key, Object^ value) sealed;
}
public:
virtual property Object^ default[Object^ key] {
    Object^ get (Object^ key) sealed;
    void set (Object^ key, Object^ value) sealed;
}
abstract Item : Object with get, set
override Item : Object with get, set
abstract Item : Object with get, set
override Item : Object with get, set

Parameters

key
Type: Online System Object

Property Value

Type: Online Object

Implements

ISession Item Object
See Also
BaseSession Class
BaseSession Members
NFX.ApplicationModel Namespace


BaseSession.Items Property

BaseSession Items Property NFX Class Library

Provides a thread-safe dictionary of items

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<Object, Object> Items { get; }
public IDictionary<Object, Object> Items { get; }
Public ReadOnly Property Items As IDictionary(Of Object, Object)
    Get
Public ReadOnly Property Items As IDictionary(Of Object, Object)
    Get
public:
virtual property IDictionary<Object^, Object^>^ Items {
    IDictionary<Object^, Object^>^ get () sealed;
}
public:
virtual property IDictionary<Object^, Object^>^ Items {
    IDictionary<Object^, Object^>^ get () sealed;
}
abstract Items : IDictionary<Object, Object> with get
override Items : IDictionary<Object, Object> with get
abstract Items : IDictionary<Object, Object> with get
override Items : IDictionary<Object, Object> with get

Property Value

Type: Online IDictionary Online Object, Online Object

Implements

ISession Items
See Also
BaseSession Class
BaseSession Members
NFX.ApplicationModel Namespace


BaseSession.LanguageISOCode Property

BaseSession LanguageISOCode Property NFX Class Library

Returns user language preference or null

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string LanguageISOCode { get; }
public virtual string LanguageISOCode { get; }
Public Overridable ReadOnly Property LanguageISOCode As String
    Get
Public Overridable ReadOnly Property LanguageISOCode As String
    Get
public:
virtual property String^ LanguageISOCode {
    String^ get ();
}
public:
virtual property String^ LanguageISOCode {
    String^ get ();
}
abstract LanguageISOCode : string with get
override LanguageISOCode : string with get
abstract LanguageISOCode : string with get
override LanguageISOCode : string with get

Property Value

Type: Online String

Implements

ISession LanguageISOCode
See Also
BaseSession Class
BaseSession Members
NFX.ApplicationModel Namespace


BaseSession.LastLoginType Property

BaseSession LastLoginType Property NFX Class Library

Returns the last login type

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SessionLoginType LastLoginType { get; }
public SessionLoginType LastLoginType { get; }
Public ReadOnly Property LastLoginType As SessionLoginType
    Get
Public ReadOnly Property LastLoginType As SessionLoginType
    Get
public:
virtual property SessionLoginType LastLoginType {
    SessionLoginType get () sealed;
}
public:
virtual property SessionLoginType LastLoginType {
    SessionLoginType get () sealed;
}
abstract LastLoginType : SessionLoginType with get
override LastLoginType : SessionLoginType with get
abstract LastLoginType : SessionLoginType with get
override LastLoginType : SessionLoginType with get

Property Value

Type: SessionLoginType

Implements

ISession LastLoginType
See Also
BaseSession Class
BaseSession Members
NFX.ApplicationModel Namespace


BaseSession.LastLoginUTC Property

BaseSession LastLoginUTC Property NFX Class Library

Returns the UTC DateTime of the last login/when HasJustLoggedIn() was called for the last time within the lifetime of this session object or NULL

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> LastLoginUTC { get; }
public Nullable<DateTime> LastLoginUTC { get; }
Public ReadOnly Property LastLoginUTC As Nullable(Of DateTime)
    Get
Public ReadOnly Property LastLoginUTC As Nullable(Of DateTime)
    Get
public:
virtual property Nullable<DateTime> LastLoginUTC {
    Nullable<DateTime> get () sealed;
}
public:
virtual property Nullable<DateTime> LastLoginUTC {
    Nullable<DateTime> get () sealed;
}
abstract LastLoginUTC : Nullable<DateTime> with get
override LastLoginUTC : Nullable<DateTime> with get
abstract LastLoginUTC : Nullable<DateTime> with get
override LastLoginUTC : Nullable<DateTime> with get

Property Value

Type: Online Nullable Online DateTime

Implements

ISession LastLoginUTC
See Also
BaseSession Class
BaseSession Members
NFX.ApplicationModel Namespace


BaseSession.OldID Property

BaseSession OldID Property NFX Class Library

When this parameter is not null then RegenerateID() was called and session provider may need to re-stow session object under a new ID

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<Guid> OldID { get; }
public Nullable<Guid> OldID { get; }
Public ReadOnly Property OldID As Nullable(Of Guid)
    Get
Public ReadOnly Property OldID As Nullable(Of Guid)
    Get
public:
virtual property Nullable<Guid> OldID {
    Nullable<Guid> get () sealed;
}
public:
virtual property Nullable<Guid> OldID {
    Nullable<Guid> get () sealed;
}
abstract OldID : Nullable<Guid> with get
override OldID : Nullable<Guid> with get
abstract OldID : Nullable<Guid> with get
override OldID : Nullable<Guid> with get

Property Value

Type: Online Nullable Online Guid

Implements

ISession OldID
See Also
BaseSession Class
BaseSession Members
NFX.ApplicationModel Namespace


BaseSession.User Property

BaseSession User Property NFX Class Library

Returns session user

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public User User { get; set; }
public User User { get; set; }
Public Property User As User
    Get
    Set
Public Property User As User
    Get
    Set
public:
virtual property User^ User {
    User^ get () sealed;
    void set (User^ value) sealed;
}
public:
virtual property User^ User {
    User^ get () sealed;
    void set (User^ value) sealed;
}
abstract User : User with get, set
override User : User with get, set
abstract User : User with get, set
override User : User with get, set

Property Value

Type: User

Implements

ISession User
See Also
BaseSession Class
BaseSession Members
NFX.ApplicationModel Namespace


CommonApplicationLogic Class

CommonApplicationLogic Class NFX Class Library

Provides base implementation of IApplication for various application kinds
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel CommonApplicationLogic
NFX.ApplicationModel ServiceBaseApplication

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigMacroContextAttribute]
public abstract class CommonApplicationLogic : DisposableObject,
    IApplication, INamed, ILocalizedTimeProvider
[ConfigMacroContextAttribute]
public abstract class CommonApplicationLogic : DisposableObject,
    IApplication, INamed, ILocalizedTimeProvider
<ConfigMacroContextAttribute>
Public MustInherit Class CommonApplicationLogic
    Inherits DisposableObject
    Implements IApplication, INamed, ILocalizedTimeProvider
<ConfigMacroContextAttribute>
Public MustInherit Class CommonApplicationLogic
    Inherits DisposableObject
    Implements IApplication, INamed, ILocalizedTimeProvider
[ConfigMacroContextAttribute]
public ref class CommonApplicationLogic abstract : public DisposableObject,
    IApplication, INamed, ILocalizedTimeProvider
[ConfigMacroContextAttribute]
public ref class CommonApplicationLogic abstract : public DisposableObject,
    IApplication, INamed, ILocalizedTimeProvider
[<AbstractClassAttribute>]
[<ConfigMacroContextAttribute>]
type CommonApplicationLogic =
    class
        inherit DisposableObject
        interface IApplication
        interface INamed
        interface ILocalizedTimeProvider
    end
[<AbstractClassAttribute>]
[<ConfigMacroContextAttribute>]
type CommonApplicationLogic =
    class
        inherit DisposableObject
        interface IApplication
        interface INamed
        interface ILocalizedTimeProvider
    end
See Also
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic Members

CommonApplicationLogic Members NFX Class Library

The CommonApplicationLogic type exposes the following members.
Constructors
 | Name | Description
Protected method | CommonApplicationLogic | Initializes a new instance of the CommonApplicationLogic class
Back to Top
Methods
 | Name | Description
Protected method | BeforeDataStoreStart | Override to prep data store implementation i.e. inject something programmaticaly
Protected method | BeforeEventTimerStart | Override to prep event timer implementation i.e. inject something programmaticaly
Protected method | BeforeGlueStart | Override to prep glue implementation i.e. inject something programmaticaly
Protected method | BeforeInstrumentationStart | Override to prep instr implementation i.e. inject something programmaticaly
Protected method | BeforeLogStart | Override to prep log implementation i.e. inject log destinations programmaticaly
Protected method | BeforeObjectStoreStart | Override to prep object store implementation i.e. inject something programmaticaly
Protected method | BeforeSecurityManagerStart | Override to prep security manager implementation i.e. inject something programmaticaly
Protected method | BeforeThrottlingStart | Override to prep throttling implementation i.e. inject something programmaticaly
Protected method | BeforeTimeSourceStart | Override to prep time source implementation i.e. inject something programmaticaly
Protected method | CleanupApplication |
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoCleanupApplication |
Protected method | DoInitApplication |
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetDefaultConfigFileName | Tries to find a configuration file name looping through various supported estensions
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Protected method | GetStarters |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InitApplication |
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property
Public method | MakeNewSessionInstance | Makes BaseSession instance
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NotifyAllConfigSettingsAboutChange | Forces notification of all registered IConfigSettings-implementers about configuration change
Protected method | NotifyAllConfigSettingsAboutChange(IConfigSectionNode) | Forces notification of all registered IConfigSettings-implementers about configuration change
Public method | PreloadAssemblies | RESERVED for future use. Loads assemblies specified in 'preload-assemblies' section from disk optionally checking the 'enabled' flag. This method is called on application startup by the framework
Public method | RegisterAppFinishNotifiable | Registers an instance of IApplicationFinishNotifiable with application container to receive a call when underlying application instance will finish its lifecycle
Public method | RegisterConfigSettings | Registers an instance of IConfigSettings with application container to receive a call when underlying app configuration changes
Public method | Stop | Initiates the stop of the application by setting its Stopping to true and Active to false so dependent services may start to terminate
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property
Public method | UnregisterAppFinishNotifiable | Removes the registration of IConfigSettings from application container
Public method | UnregisterConfigSettings | Removes the registration of IConfigSettings from application container
Protected method | WriteLog |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | CONFIG_APP_NAME_ATTR |
 | CONFIG_ASSEMBLY_SECTION |
 | CONFIG_DATA_STORE_SECTION |
 | CONFIG_ENABLED_ATTR |
 | CONFIG_EVENT_TIMER_SECTION |
 | CONFIG_GLUE_SECTION |
 | CONFIG_INSTRUMENTATION_SECTION |
 | CONFIG_LOG_SECTION |
 | CONFIG_MEMORY_MANAGEMENT_SECTION |
 | CONFIG_OBJECT_STORE_SECTION |
 | CONFIG_PATH_ATTR |
 | CONFIG_PRELOAD_ASSEMBLIES_SECTION |
 | CONFIG_SECURITY_SECTION |
 | CONFIG_STARTER_SECTION |
 | CONFIG_STARTERS_SECTION |
 | CONFIG_SWITCH |
 | CONFIG_THROTTLING_SECTION |
 | CONFIG_TIMESOURCE_SECTION |
 | CONFIG_UNIT_TEST_ATTR |
Protected field | m_ConfigRoot |
Protected field | m_ConfigSettings |
Protected field | m_DataStore |
Protected field | m_EventTimer |
Protected field | m_FinishNotifiables |
Protected field | m_Glue |
Protected field | m_Instrumentation |
Protected field | m_Log |
Protected field | m_ObjectStore |
Protected field | m_SecurityManager |
Protected field | m_Throttling |
Protected field | m_TimeSource |
Back to Top
Properties
 | Name | Description
Public property | Active | Returns true when application instance is active and working. This property returns false as soon as application finalization starts on shutdown Use to exit long-running loops and such
Public property | ConfigRoot | Provides access to configuration root for the whole application
Public property | DataStore | References application data store
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EventTimer | References event timer which maintains and runs scheduled Event instances
Public property | Glue | References glue that can be used to interconnect remote instances
Public property | InstanceID | Returns unique identifier of this running instance
Public property | Instrumentation | References application instrumentation
Public property | IsUnitTest |
Public property | LocalizedTime | Returns current time localized per TimeLocation
Public property | Log | References application logger
Public property | Name | Returns the name of this application
Public property | ObjectStore | References application object store. Objects will survive application termination
Public property | SecurityManager | References security manager that performs user authentication based on passed credentials and other security-related global tasks
Public property | ShutdownStarted | Returns true to indicate that Dispose() has been called and shutdown has started
Public property | StartTime | Returns timestamp when application started as localized app time
Public property | Stopping | Returns true to indicate that Stop() was called
Public property | Throttling | References application throttling
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation
Public property | TimeSource | References time source - an entity that supplies local and UTC times. The concrete implementation may elect to get accurate times from the network or other external precision time sources (i.e. NASA atomic clock)
Back to Top
See Also
CommonApplicationLogic Class
NFX.ApplicationModel Namespace


CommonApplicationLogic Constructor

CommonApplicationLogic Constructor NFX Class Library

Initializes a new instance of the CommonApplicationLogic class

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CommonApplicationLogic(
    string name
)
protected CommonApplicationLogic(
    string name
)
Protected Sub New (
    name As String
)
Protected Sub New (
    name As String
)
protected:
CommonApplicationLogic(
    String^ name
)
protected:
CommonApplicationLogic(
    String^ name
)
new :
        name : string -> CommonApplicationLogic
new :
        name : string -> CommonApplicationLogic

Parameters

name
Type: Online System String
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic Fields

CommonApplicationLogic Fields NFX Class Library

The CommonApplicationLogic type exposes the following members.
Fields
 | Name | Description
 | CONFIG_APP_NAME_ATTR |
 | CONFIG_ASSEMBLY_SECTION |
 | CONFIG_DATA_STORE_SECTION |
 | CONFIG_ENABLED_ATTR |
 | CONFIG_EVENT_TIMER_SECTION |
 | CONFIG_GLUE_SECTION |
 | CONFIG_INSTRUMENTATION_SECTION |
 | CONFIG_LOG_SECTION |
 | CONFIG_MEMORY_MANAGEMENT_SECTION |
 | CONFIG_OBJECT_STORE_SECTION |
 | CONFIG_PATH_ATTR |
 | CONFIG_PRELOAD_ASSEMBLIES_SECTION |
 | CONFIG_SECURITY_SECTION |
 | CONFIG_STARTER_SECTION |
 | CONFIG_STARTERS_SECTION |
 | CONFIG_SWITCH |
 | CONFIG_THROTTLING_SECTION |
 | CONFIG_TIMESOURCE_SECTION |
 | CONFIG_UNIT_TEST_ATTR |
Protected field | m_ConfigRoot |
Protected field | m_ConfigSettings |
Protected field | m_DataStore |
Protected field | m_EventTimer |
Protected field | m_FinishNotifiables |
Protected field | m_Glue |
Protected field | m_Instrumentation |
Protected field | m_Log |
Protected field | m_ObjectStore |
Protected field | m_SecurityManager |
Protected field | m_Throttling |
Protected field | m_TimeSource |
Back to Top
See Also
CommonApplicationLogic Class
NFX.ApplicationModel Namespace


CommonApplicationLogic.CONFIG_APP_NAME_ATTR Field

CommonApplicationLogic CONFIG_APP_NAME_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_APP_NAME_ATTR
public const string CONFIG_APP_NAME_ATTR
Public Const CONFIG_APP_NAME_ATTR As String
Public Const CONFIG_APP_NAME_ATTR As String
public:
literal String^ CONFIG_APP_NAME_ATTR
public:
literal String^ CONFIG_APP_NAME_ATTR
static val mutable CONFIG_APP_NAME_ATTR: string
static val mutable CONFIG_APP_NAME_ATTR: string

Field Value

Type: Online String
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.CONFIG_ASSEMBLY_SECTION Field

CommonApplicationLogic CONFIG_ASSEMBLY_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_ASSEMBLY_SECTION
public const string CONFIG_ASSEMBLY_SECTION
Public Const CONFIG_ASSEMBLY_SECTION As String
Public Const CONFIG_ASSEMBLY_SECTION As String
public:
literal String^ CONFIG_ASSEMBLY_SECTION
public:
literal String^ CONFIG_ASSEMBLY_SECTION
static val mutable CONFIG_ASSEMBLY_SECTION: string
static val mutable CONFIG_ASSEMBLY_SECTION: string

Field Value

Type: Online String
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.CONFIG_DATA_STORE_SECTION Field

CommonApplicationLogic CONFIG_DATA_STORE_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_DATA_STORE_SECTION
public const string CONFIG_DATA_STORE_SECTION
Public Const CONFIG_DATA_STORE_SECTION As String
Public Const CONFIG_DATA_STORE_SECTION As String
public:
literal String^ CONFIG_DATA_STORE_SECTION
public:
literal String^ CONFIG_DATA_STORE_SECTION
static val mutable CONFIG_DATA_STORE_SECTION: string
static val mutable CONFIG_DATA_STORE_SECTION: string

Field Value

Type: Online String
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.CONFIG_ENABLED_ATTR Field

CommonApplicationLogic CONFIG_ENABLED_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_ENABLED_ATTR
public const string CONFIG_ENABLED_ATTR
Public Const CONFIG_ENABLED_ATTR As String
Public Const CONFIG_ENABLED_ATTR As String
public:
literal String^ CONFIG_ENABLED_ATTR
public:
literal String^ CONFIG_ENABLED_ATTR
static val mutable CONFIG_ENABLED_ATTR: string
static val mutable CONFIG_ENABLED_ATTR: string

Field Value

Type: Online String
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.CONFIG_EVENT_TIMER_SECTION Field

CommonApplicationLogic CONFIG_EVENT_TIMER_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_EVENT_TIMER_SECTION
public const string CONFIG_EVENT_TIMER_SECTION
Public Const CONFIG_EVENT_TIMER_SECTION As String
Public Const CONFIG_EVENT_TIMER_SECTION As String
public:
literal String^ CONFIG_EVENT_TIMER_SECTION
public:
literal String^ CONFIG_EVENT_TIMER_SECTION
static val mutable CONFIG_EVENT_TIMER_SECTION: string
static val mutable CONFIG_EVENT_TIMER_SECTION: string

Field Value

Type: Online String
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.CONFIG_GLUE_SECTION Field

CommonApplicationLogic CONFIG_GLUE_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_GLUE_SECTION
public const string CONFIG_GLUE_SECTION
Public Const CONFIG_GLUE_SECTION As String
Public Const CONFIG_GLUE_SECTION As String
public:
literal String^ CONFIG_GLUE_SECTION
public:
literal String^ CONFIG_GLUE_SECTION
static val mutable CONFIG_GLUE_SECTION: string
static val mutable CONFIG_GLUE_SECTION: string

Field Value

Type: Online String
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.CONFIG_INSTRUMENTATION_SECTION Field

CommonApplicationLogic CONFIG_INSTRUMENTATION_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_INSTRUMENTATION_SECTION
public const string CONFIG_INSTRUMENTATION_SECTION
Public Const CONFIG_INSTRUMENTATION_SECTION As String
Public Const CONFIG_INSTRUMENTATION_SECTION As String
public:
literal String^ CONFIG_INSTRUMENTATION_SECTION
public:
literal String^ CONFIG_INSTRUMENTATION_SECTION
static val mutable CONFIG_INSTRUMENTATION_SECTION: string
static val mutable CONFIG_INSTRUMENTATION_SECTION: string

Field Value

Type: Online String
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.CONFIG_LOG_SECTION Field

CommonApplicationLogic CONFIG_LOG_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_LOG_SECTION
public const string CONFIG_LOG_SECTION
Public Const CONFIG_LOG_SECTION As String
Public Const CONFIG_LOG_SECTION As String
public:
literal String^ CONFIG_LOG_SECTION
public:
literal String^ CONFIG_LOG_SECTION
static val mutable CONFIG_LOG_SECTION: string
static val mutable CONFIG_LOG_SECTION: string

Field Value

Type: Online String
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.CONFIG_MEMORY_MANAGEMENT_SECTION Field

CommonApplicationLogic CONFIG_MEMORY_MANAGEMENT_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_MEMORY_MANAGEMENT_SECTION
public const string CONFIG_MEMORY_MANAGEMENT_SECTION
Public Const CONFIG_MEMORY_MANAGEMENT_SECTION As String
Public Const CONFIG_MEMORY_MANAGEMENT_SECTION As String
public:
literal String^ CONFIG_MEMORY_MANAGEMENT_SECTION
public:
literal String^ CONFIG_MEMORY_MANAGEMENT_SECTION
static val mutable CONFIG_MEMORY_MANAGEMENT_SECTION: string
static val mutable CONFIG_MEMORY_MANAGEMENT_SECTION: string

Field Value

Type: Online String
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.CONFIG_OBJECT_STORE_SECTION Field

CommonApplicationLogic CONFIG_OBJECT_STORE_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_OBJECT_STORE_SECTION
public const string CONFIG_OBJECT_STORE_SECTION
Public Const CONFIG_OBJECT_STORE_SECTION As String
Public Const CONFIG_OBJECT_STORE_SECTION As String
public:
literal String^ CONFIG_OBJECT_STORE_SECTION
public:
literal String^ CONFIG_OBJECT_STORE_SECTION
static val mutable CONFIG_OBJECT_STORE_SECTION: string
static val mutable CONFIG_OBJECT_STORE_SECTION: string

Field Value

Type: Online String
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.CONFIG_PATH_ATTR Field

CommonApplicationLogic CONFIG_PATH_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PATH_ATTR
public const string CONFIG_PATH_ATTR
Public Const CONFIG_PATH_ATTR As String
Public Const CONFIG_PATH_ATTR As String
public:
literal String^ CONFIG_PATH_ATTR
public:
literal String^ CONFIG_PATH_ATTR
static val mutable CONFIG_PATH_ATTR: string
static val mutable CONFIG_PATH_ATTR: string

Field Value

Type: Online String
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.CONFIG_PRELOAD_ASSEMBLIES_SECTION Field

CommonApplicationLogic CONFIG_PRELOAD_ASSEMBLIES_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PRELOAD_ASSEMBLIES_SECTION
public const string CONFIG_PRELOAD_ASSEMBLIES_SECTION
Public Const CONFIG_PRELOAD_ASSEMBLIES_SECTION As String
Public Const CONFIG_PRELOAD_ASSEMBLIES_SECTION As String
public:
literal String^ CONFIG_PRELOAD_ASSEMBLIES_SECTION
public:
literal String^ CONFIG_PRELOAD_ASSEMBLIES_SECTION
static val mutable CONFIG_PRELOAD_ASSEMBLIES_SECTION: string
static val mutable CONFIG_PRELOAD_ASSEMBLIES_SECTION: string

Field Value

Type: Online String
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.CONFIG_SECURITY_SECTION Field

CommonApplicationLogic CONFIG_SECURITY_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SECURITY_SECTION
public const string CONFIG_SECURITY_SECTION
Public Const CONFIG_SECURITY_SECTION As String
Public Const CONFIG_SECURITY_SECTION As String
public:
literal String^ CONFIG_SECURITY_SECTION
public:
literal String^ CONFIG_SECURITY_SECTION
static val mutable CONFIG_SECURITY_SECTION: string
static val mutable CONFIG_SECURITY_SECTION: string

Field Value

Type: Online String
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.CONFIG_STARTER_SECTION Field

CommonApplicationLogic CONFIG_STARTER_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_STARTER_SECTION
public const string CONFIG_STARTER_SECTION
Public Const CONFIG_STARTER_SECTION As String
Public Const CONFIG_STARTER_SECTION As String
public:
literal String^ CONFIG_STARTER_SECTION
public:
literal String^ CONFIG_STARTER_SECTION
static val mutable CONFIG_STARTER_SECTION: string
static val mutable CONFIG_STARTER_SECTION: string

Field Value

Type: Online String
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.CONFIG_STARTERS_SECTION Field

CommonApplicationLogic CONFIG_STARTERS_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_STARTERS_SECTION
public const string CONFIG_STARTERS_SECTION
Public Const CONFIG_STARTERS_SECTION As String
Public Const CONFIG_STARTERS_SECTION As String
public:
literal String^ CONFIG_STARTERS_SECTION
public:
literal String^ CONFIG_STARTERS_SECTION
static val mutable CONFIG_STARTERS_SECTION: string
static val mutable CONFIG_STARTERS_SECTION: string

Field Value

Type: Online String
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.CONFIG_SWITCH Field

CommonApplicationLogic CONFIG_SWITCH Field NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SWITCH
public const string CONFIG_SWITCH
Public Const CONFIG_SWITCH As String
Public Const CONFIG_SWITCH As String
public:
literal String^ CONFIG_SWITCH
public:
literal String^ CONFIG_SWITCH
static val mutable CONFIG_SWITCH: string
static val mutable CONFIG_SWITCH: string

Field Value

Type: Online String
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.CONFIG_THROTTLING_SECTION Field

CommonApplicationLogic CONFIG_THROTTLING_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_THROTTLING_SECTION
public const string CONFIG_THROTTLING_SECTION
Public Const CONFIG_THROTTLING_SECTION As String
Public Const CONFIG_THROTTLING_SECTION As String
public:
literal String^ CONFIG_THROTTLING_SECTION
public:
literal String^ CONFIG_THROTTLING_SECTION
static val mutable CONFIG_THROTTLING_SECTION: string
static val mutable CONFIG_THROTTLING_SECTION: string

Field Value

Type: Online String
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.CONFIG_TIMESOURCE_SECTION Field

CommonApplicationLogic CONFIG_TIMESOURCE_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_TIMESOURCE_SECTION
public const string CONFIG_TIMESOURCE_SECTION
Public Const CONFIG_TIMESOURCE_SECTION As String
Public Const CONFIG_TIMESOURCE_SECTION As String
public:
literal String^ CONFIG_TIMESOURCE_SECTION
public:
literal String^ CONFIG_TIMESOURCE_SECTION
static val mutable CONFIG_TIMESOURCE_SECTION: string
static val mutable CONFIG_TIMESOURCE_SECTION: string

Field Value

Type: Online String
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.CONFIG_UNIT_TEST_ATTR Field

CommonApplicationLogic CONFIG_UNIT_TEST_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_UNIT_TEST_ATTR
public const string CONFIG_UNIT_TEST_ATTR
Public Const CONFIG_UNIT_TEST_ATTR As String
Public Const CONFIG_UNIT_TEST_ATTR As String
public:
literal String^ CONFIG_UNIT_TEST_ATTR
public:
literal String^ CONFIG_UNIT_TEST_ATTR
static val mutable CONFIG_UNIT_TEST_ATTR: string
static val mutable CONFIG_UNIT_TEST_ATTR: string

Field Value

Type: Online String
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.m_ConfigRoot Field

CommonApplicationLogic m_ConfigRoot Field NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ConfigSectionNode m_ConfigRoot
protected ConfigSectionNode m_ConfigRoot
Protected m_ConfigRoot As ConfigSectionNode
Protected m_ConfigRoot As ConfigSectionNode
protected:
ConfigSectionNode^ m_ConfigRoot
protected:
ConfigSectionNode^ m_ConfigRoot
val mutable m_ConfigRoot: ConfigSectionNode
val mutable m_ConfigRoot: ConfigSectionNode

Field Value

Type: ConfigSectionNode
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.m_ConfigSettings Field

CommonApplicationLogic m_ConfigSettings Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected List<IConfigSettings> m_ConfigSettings
protected List<IConfigSettings> m_ConfigSettings
Protected m_ConfigSettings As List(Of IConfigSettings)
Protected m_ConfigSettings As List(Of IConfigSettings)
protected:
List<IConfigSettings^>^ m_ConfigSettings
protected:
List<IConfigSettings^>^ m_ConfigSettings
val mutable m_ConfigSettings: List<IConfigSettings>
val mutable m_ConfigSettings: List<IConfigSettings>

Field Value

Type: Online List IConfigSettings
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.m_DataStore Field

CommonApplicationLogic m_DataStore Field NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IDataStoreImplementation m_DataStore
protected IDataStoreImplementation m_DataStore
Protected m_DataStore As IDataStoreImplementation
Protected m_DataStore As IDataStoreImplementation
protected:
IDataStoreImplementation^ m_DataStore
protected:
IDataStoreImplementation^ m_DataStore
val mutable m_DataStore: IDataStoreImplementation
val mutable m_DataStore: IDataStoreImplementation

Field Value

Type: IDataStoreImplementation
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.m_EventTimer Field

CommonApplicationLogic m_EventTimer Field NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IEventTimerImplementation m_EventTimer
protected IEventTimerImplementation m_EventTimer
Protected m_EventTimer As IEventTimerImplementation
Protected m_EventTimer As IEventTimerImplementation
protected:
IEventTimerImplementation^ m_EventTimer
protected:
IEventTimerImplementation^ m_EventTimer
val mutable m_EventTimer: IEventTimerImplementation
val mutable m_EventTimer: IEventTimerImplementation

Field Value

Type: IEventTimerImplementation
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.m_FinishNotifiables Field

CommonApplicationLogic m_FinishNotifiables Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected List<IApplicationFinishNotifiable> m_FinishNotifiables
protected List<IApplicationFinishNotifiable> m_FinishNotifiables
Protected m_FinishNotifiables As List(Of IApplicationFinishNotifiable)
Protected m_FinishNotifiables As List(Of IApplicationFinishNotifiable)
protected:
List<IApplicationFinishNotifiable^>^ m_FinishNotifiables
protected:
List<IApplicationFinishNotifiable^>^ m_FinishNotifiables
val mutable m_FinishNotifiables: List<IApplicationFinishNotifiable>
val mutable m_FinishNotifiables: List<IApplicationFinishNotifiable>

Field Value

Type: Online List IApplicationFinishNotifiable
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.m_Glue Field

CommonApplicationLogic m_Glue Field NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IGlueImplementation m_Glue
protected IGlueImplementation m_Glue
Protected m_Glue As IGlueImplementation
Protected m_Glue As IGlueImplementation
protected:
IGlueImplementation^ m_Glue
protected:
IGlueImplementation^ m_Glue
val mutable m_Glue: IGlueImplementation
val mutable m_Glue: IGlueImplementation

Field Value

Type: IGlueImplementation
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.m_Instrumentation Field

CommonApplicationLogic m_Instrumentation Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IInstrumentationImplementation m_Instrumentation
protected IInstrumentationImplementation m_Instrumentation
Protected m_Instrumentation As IInstrumentationImplementation
Protected m_Instrumentation As IInstrumentationImplementation
protected:
IInstrumentationImplementation^ m_Instrumentation
protected:
IInstrumentationImplementation^ m_Instrumentation
val mutable m_Instrumentation: IInstrumentationImplementation
val mutable m_Instrumentation: IInstrumentationImplementation

Field Value

Type: IInstrumentationImplementation
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.m_Log Field

CommonApplicationLogic m_Log Field NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ILogImplementation m_Log
protected ILogImplementation m_Log
Protected m_Log As ILogImplementation
Protected m_Log As ILogImplementation
protected:
ILogImplementation^ m_Log
protected:
ILogImplementation^ m_Log
val mutable m_Log: ILogImplementation
val mutable m_Log: ILogImplementation

Field Value

Type: ILogImplementation
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.m_ObjectStore Field

CommonApplicationLogic m_ObjectStore Field NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IObjectStoreImplementation m_ObjectStore
protected IObjectStoreImplementation m_ObjectStore
Protected m_ObjectStore As IObjectStoreImplementation
Protected m_ObjectStore As IObjectStoreImplementation
protected:
IObjectStoreImplementation^ m_ObjectStore
protected:
IObjectStoreImplementation^ m_ObjectStore
val mutable m_ObjectStore: IObjectStoreImplementation
val mutable m_ObjectStore: IObjectStoreImplementation

Field Value

Type: IObjectStoreImplementation
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.m_SecurityManager Field

CommonApplicationLogic m_SecurityManager Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ISecurityManagerImplementation m_SecurityManager
protected ISecurityManagerImplementation m_SecurityManager
Protected m_SecurityManager As ISecurityManagerImplementation
Protected m_SecurityManager As ISecurityManagerImplementation
protected:
ISecurityManagerImplementation^ m_SecurityManager
protected:
ISecurityManagerImplementation^ m_SecurityManager
val mutable m_SecurityManager: ISecurityManagerImplementation
val mutable m_SecurityManager: ISecurityManagerImplementation

Field Value

Type: ISecurityManagerImplementation
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.m_Throttling Field

CommonApplicationLogic m_Throttling Field NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IThrottlingImplementation m_Throttling
protected IThrottlingImplementation m_Throttling
Protected m_Throttling As IThrottlingImplementation
Protected m_Throttling As IThrottlingImplementation
protected:
IThrottlingImplementation^ m_Throttling
protected:
IThrottlingImplementation^ m_Throttling
val mutable m_Throttling: IThrottlingImplementation
val mutable m_Throttling: IThrottlingImplementation

Field Value

Type: IThrottlingImplementation
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.m_TimeSource Field

CommonApplicationLogic m_TimeSource Field NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ITimeSourceImplementation m_TimeSource
protected ITimeSourceImplementation m_TimeSource
Protected m_TimeSource As ITimeSourceImplementation
Protected m_TimeSource As ITimeSourceImplementation
protected:
ITimeSourceImplementation^ m_TimeSource
protected:
ITimeSourceImplementation^ m_TimeSource
val mutable m_TimeSource: ITimeSourceImplementation
val mutable m_TimeSource: ITimeSourceImplementation

Field Value

Type: ITimeSourceImplementation
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic Methods

CommonApplicationLogic Methods NFX Class Library

The CommonApplicationLogic type exposes the following members.
Methods
 | Name | Description
Protected method | BeforeDataStoreStart | Override to prep data store implementation i.e. inject something programmaticaly
Protected method | BeforeEventTimerStart | Override to prep event timer implementation i.e. inject something programmaticaly
Protected method | BeforeGlueStart | Override to prep glue implementation i.e. inject something programmaticaly
Protected method | BeforeInstrumentationStart | Override to prep instr implementation i.e. inject something programmaticaly
Protected method | BeforeLogStart | Override to prep log implementation i.e. inject log destinations programmaticaly
Protected method | BeforeObjectStoreStart | Override to prep object store implementation i.e. inject something programmaticaly
Protected method | BeforeSecurityManagerStart | Override to prep security manager implementation i.e. inject something programmaticaly
Protected method | BeforeThrottlingStart | Override to prep throttling implementation i.e. inject something programmaticaly
Protected method | BeforeTimeSourceStart | Override to prep time source implementation i.e. inject something programmaticaly
Protected method | CleanupApplication |
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoCleanupApplication |
Protected method | DoInitApplication |
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetDefaultConfigFileName | Tries to find a configuration file name looping through various supported estensions
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Protected method | GetStarters |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InitApplication |
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property
Public method | MakeNewSessionInstance | Makes BaseSession instance
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NotifyAllConfigSettingsAboutChange | Forces notification of all registered IConfigSettings-implementers about configuration change
Protected method | NotifyAllConfigSettingsAboutChange(IConfigSectionNode) | Forces notification of all registered IConfigSettings-implementers about configuration change
Public method | PreloadAssemblies | RESERVED for future use. Loads assemblies specified in 'preload-assemblies' section from disk optionally checking the 'enabled' flag. This method is called on application startup by the framework
Public method | RegisterAppFinishNotifiable | Registers an instance of IApplicationFinishNotifiable with application container to receive a call when underlying application instance will finish its lifecycle
Public method | RegisterConfigSettings | Registers an instance of IConfigSettings with application container to receive a call when underlying app configuration changes
Public method | Stop | Initiates the stop of the application by setting its Stopping to true and Active to false so dependent services may start to terminate
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property
Public method | UnregisterAppFinishNotifiable | Removes the registration of IConfigSettings from application container
Public method | UnregisterConfigSettings | Removes the registration of IConfigSettings from application container
Protected method | WriteLog |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CommonApplicationLogic Class
NFX.ApplicationModel Namespace


CommonApplicationLogic.BeforeDataStoreStart Method

CommonApplicationLogic BeforeDataStoreStart Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to prep data store implementation i.e. inject something programmaticaly

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void BeforeDataStoreStart(
    IDataStoreImplementation datastoreImplementation
)
protected virtual void BeforeDataStoreStart(
    IDataStoreImplementation datastoreImplementation
)
Protected Overridable Sub BeforeDataStoreStart (
    datastoreImplementation As IDataStoreImplementation
)
Protected Overridable Sub BeforeDataStoreStart (
    datastoreImplementation As IDataStoreImplementation
)
protected:
virtual void BeforeDataStoreStart(
    IDataStoreImplementation^ datastoreImplementation
)
protected:
virtual void BeforeDataStoreStart(
    IDataStoreImplementation^ datastoreImplementation
)
abstract BeforeDataStoreStart :
        datastoreImplementation : IDataStoreImplementation -> unit
override BeforeDataStoreStart :
        datastoreImplementation : IDataStoreImplementation -> unit
abstract BeforeDataStoreStart :
        datastoreImplementation : IDataStoreImplementation -> unit
override BeforeDataStoreStart :
        datastoreImplementation : IDataStoreImplementation -> unit

Parameters

datastoreImplementation
Type: NFX.DataAccess IDataStoreImplementation
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.BeforeEventTimerStart Method

CommonApplicationLogic BeforeEventTimerStart Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to prep event timer implementation i.e. inject something programmaticaly

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void BeforeEventTimerStart(
    IEventTimerImplementation eventTimerImplementation
)
protected virtual void BeforeEventTimerStart(
    IEventTimerImplementation eventTimerImplementation
)
Protected Overridable Sub BeforeEventTimerStart (
    eventTimerImplementation As IEventTimerImplementation
)
Protected Overridable Sub BeforeEventTimerStart (
    eventTimerImplementation As IEventTimerImplementation
)
protected:
virtual void BeforeEventTimerStart(
    IEventTimerImplementation^ eventTimerImplementation
)
protected:
virtual void BeforeEventTimerStart(
    IEventTimerImplementation^ eventTimerImplementation
)
abstract BeforeEventTimerStart :
        eventTimerImplementation : IEventTimerImplementation -> unit
override BeforeEventTimerStart :
        eventTimerImplementation : IEventTimerImplementation -> unit
abstract BeforeEventTimerStart :
        eventTimerImplementation : IEventTimerImplementation -> unit
override BeforeEventTimerStart :
        eventTimerImplementation : IEventTimerImplementation -> unit

Parameters

eventTimerImplementation
Type: NFX.Time IEventTimerImplementation
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.BeforeGlueStart Method

CommonApplicationLogic BeforeGlueStart Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to prep glue implementation i.e. inject something programmaticaly

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void BeforeGlueStart(
    IGlueImplementation glueImplementation
)
protected virtual void BeforeGlueStart(
    IGlueImplementation glueImplementation
)
Protected Overridable Sub BeforeGlueStart (
    glueImplementation As IGlueImplementation
)
Protected Overridable Sub BeforeGlueStart (
    glueImplementation As IGlueImplementation
)
protected:
virtual void BeforeGlueStart(
    IGlueImplementation^ glueImplementation
)
protected:
virtual void BeforeGlueStart(
    IGlueImplementation^ glueImplementation
)
abstract BeforeGlueStart :
        glueImplementation : IGlueImplementation -> unit
override BeforeGlueStart :
        glueImplementation : IGlueImplementation -> unit
abstract BeforeGlueStart :
        glueImplementation : IGlueImplementation -> unit
override BeforeGlueStart :
        glueImplementation : IGlueImplementation -> unit

Parameters

glueImplementation
Type: NFX.Glue IGlueImplementation
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.BeforeInstrumentationStart Method

CommonApplicationLogic BeforeInstrumentationStart Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to prep instr implementation i.e. inject something programmaticaly

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void BeforeInstrumentationStart(
    IInstrumentationImplementation instrumentationImplementation
)
protected virtual void BeforeInstrumentationStart(
    IInstrumentationImplementation instrumentationImplementation
)
Protected Overridable Sub BeforeInstrumentationStart (
    instrumentationImplementation As IInstrumentationImplementation
)
Protected Overridable Sub BeforeInstrumentationStart (
    instrumentationImplementation As IInstrumentationImplementation
)
protected:
virtual void BeforeInstrumentationStart(
    IInstrumentationImplementation^ instrumentationImplementation
)
protected:
virtual void BeforeInstrumentationStart(
    IInstrumentationImplementation^ instrumentationImplementation
)
abstract BeforeInstrumentationStart :
        instrumentationImplementation : IInstrumentationImplementation -> unit
override BeforeInstrumentationStart :
        instrumentationImplementation : IInstrumentationImplementation -> unit
abstract BeforeInstrumentationStart :
        instrumentationImplementation : IInstrumentationImplementation -> unit
override BeforeInstrumentationStart :
        instrumentationImplementation : IInstrumentationImplementation -> unit

Parameters

instrumentationImplementation
Type: NFX.Instrumentation IInstrumentationImplementation
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.BeforeLogStart Method

CommonApplicationLogic BeforeLogStart Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to prep log implementation i.e. inject log destinations programmaticaly

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void BeforeLogStart(
    ILogImplementation logImplementation
)
protected virtual void BeforeLogStart(
    ILogImplementation logImplementation
)
Protected Overridable Sub BeforeLogStart (
    logImplementation As ILogImplementation
)
Protected Overridable Sub BeforeLogStart (
    logImplementation As ILogImplementation
)
protected:
virtual void BeforeLogStart(
    ILogImplementation^ logImplementation
)
protected:
virtual void BeforeLogStart(
    ILogImplementation^ logImplementation
)
abstract BeforeLogStart :
        logImplementation : ILogImplementation -> unit
override BeforeLogStart :
        logImplementation : ILogImplementation -> unit
abstract BeforeLogStart :
        logImplementation : ILogImplementation -> unit
override BeforeLogStart :
        logImplementation : ILogImplementation -> unit

Parameters

logImplementation
Type: NFX.Log ILogImplementation
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.BeforeObjectStoreStart Method

CommonApplicationLogic BeforeObjectStoreStart Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to prep object store implementation i.e. inject something programmaticaly

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void BeforeObjectStoreStart(
    IObjectStoreImplementation objectstoreImplementation
)
protected virtual void BeforeObjectStoreStart(
    IObjectStoreImplementation objectstoreImplementation
)
Protected Overridable Sub BeforeObjectStoreStart (
    objectstoreImplementation As IObjectStoreImplementation
)
Protected Overridable Sub BeforeObjectStoreStart (
    objectstoreImplementation As IObjectStoreImplementation
)
protected:
virtual void BeforeObjectStoreStart(
    IObjectStoreImplementation^ objectstoreImplementation
)
protected:
virtual void BeforeObjectStoreStart(
    IObjectStoreImplementation^ objectstoreImplementation
)
abstract BeforeObjectStoreStart :
        objectstoreImplementation : IObjectStoreImplementation -> unit
override BeforeObjectStoreStart :
        objectstoreImplementation : IObjectStoreImplementation -> unit
abstract BeforeObjectStoreStart :
        objectstoreImplementation : IObjectStoreImplementation -> unit
override BeforeObjectStoreStart :
        objectstoreImplementation : IObjectStoreImplementation -> unit

Parameters

objectstoreImplementation
Type: NFX.ApplicationModel.Volatile IObjectStoreImplementation
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.BeforeSecurityManagerStart Method

CommonApplicationLogic BeforeSecurityManagerStart Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to prep security manager implementation i.e. inject something programmaticaly

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void BeforeSecurityManagerStart(
    ISecurityManagerImplementation securitymanagerImplementation
)
protected virtual void BeforeSecurityManagerStart(
    ISecurityManagerImplementation securitymanagerImplementation
)
Protected Overridable Sub BeforeSecurityManagerStart (
    securitymanagerImplementation As ISecurityManagerImplementation
)
Protected Overridable Sub BeforeSecurityManagerStart (
    securitymanagerImplementation As ISecurityManagerImplementation
)
protected:
virtual void BeforeSecurityManagerStart(
    ISecurityManagerImplementation^ securitymanagerImplementation
)
protected:
virtual void BeforeSecurityManagerStart(
    ISecurityManagerImplementation^ securitymanagerImplementation
)
abstract BeforeSecurityManagerStart :
        securitymanagerImplementation : ISecurityManagerImplementation -> unit
override BeforeSecurityManagerStart :
        securitymanagerImplementation : ISecurityManagerImplementation -> unit
abstract BeforeSecurityManagerStart :
        securitymanagerImplementation : ISecurityManagerImplementation -> unit
override BeforeSecurityManagerStart :
        securitymanagerImplementation : ISecurityManagerImplementation -> unit

Parameters

securitymanagerImplementation
Type: NFX.Security ISecurityManagerImplementation
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.BeforeThrottlingStart Method

CommonApplicationLogic BeforeThrottlingStart Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to prep throttling implementation i.e. inject something programmaticaly

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void BeforeThrottlingStart(
    IThrottlingImplementation throttlingImplementation
)
protected virtual void BeforeThrottlingStart(
    IThrottlingImplementation throttlingImplementation
)
Protected Overridable Sub BeforeThrottlingStart (
    throttlingImplementation As IThrottlingImplementation
)
Protected Overridable Sub BeforeThrottlingStart (
    throttlingImplementation As IThrottlingImplementation
)
protected:
virtual void BeforeThrottlingStart(
    IThrottlingImplementation^ throttlingImplementation
)
protected:
virtual void BeforeThrottlingStart(
    IThrottlingImplementation^ throttlingImplementation
)
abstract BeforeThrottlingStart :
        throttlingImplementation : IThrottlingImplementation -> unit
override BeforeThrottlingStart :
        throttlingImplementation : IThrottlingImplementation -> unit
abstract BeforeThrottlingStart :
        throttlingImplementation : IThrottlingImplementation -> unit
override BeforeThrottlingStart :
        throttlingImplementation : IThrottlingImplementation -> unit

Parameters

throttlingImplementation
Type: NFX.Throttling IThrottlingImplementation
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.BeforeTimeSourceStart Method

CommonApplicationLogic BeforeTimeSourceStart Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to prep time source implementation i.e. inject something programmaticaly

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void BeforeTimeSourceStart(
    ITimeSourceImplementation timesourceImplementation
)
protected virtual void BeforeTimeSourceStart(
    ITimeSourceImplementation timesourceImplementation
)
Protected Overridable Sub BeforeTimeSourceStart (
    timesourceImplementation As ITimeSourceImplementation
)
Protected Overridable Sub BeforeTimeSourceStart (
    timesourceImplementation As ITimeSourceImplementation
)
protected:
virtual void BeforeTimeSourceStart(
    ITimeSourceImplementation^ timesourceImplementation
)
protected:
virtual void BeforeTimeSourceStart(
    ITimeSourceImplementation^ timesourceImplementation
)
abstract BeforeTimeSourceStart :
        timesourceImplementation : ITimeSourceImplementation -> unit
override BeforeTimeSourceStart :
        timesourceImplementation : ITimeSourceImplementation -> unit
abstract BeforeTimeSourceStart :
        timesourceImplementation : ITimeSourceImplementation -> unit
override BeforeTimeSourceStart :
        timesourceImplementation : ITimeSourceImplementation -> unit

Parameters

timesourceImplementation
Type: NFX.Time ITimeSourceImplementation
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.CleanupApplication Method

CommonApplicationLogic CleanupApplication Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void CleanupApplication()
protected virtual void CleanupApplication()
Protected Overridable Sub CleanupApplication
Protected Overridable Sub CleanupApplication
protected:
virtual void CleanupApplication()
protected:
virtual void CleanupApplication()
abstract CleanupApplication : unit -> unit
override CleanupApplication : unit -> unit
abstract CleanupApplication : unit -> unit
override CleanupApplication : unit -> unit
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.Destructor Method

CommonApplicationLogic Destructor Method NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.DoCleanupApplication Method

CommonApplicationLogic DoCleanupApplication Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoCleanupApplication()
protected virtual void DoCleanupApplication()
Protected Overridable Sub DoCleanupApplication
Protected Overridable Sub DoCleanupApplication
protected:
virtual void DoCleanupApplication()
protected:
virtual void DoCleanupApplication()
abstract DoCleanupApplication : unit -> unit
override DoCleanupApplication : unit -> unit
abstract DoCleanupApplication : unit -> unit
override DoCleanupApplication : unit -> unit
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.DoInitApplication Method

CommonApplicationLogic DoInitApplication Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoInitApplication()
protected virtual void DoInitApplication()
Protected Overridable Sub DoInitApplication
Protected Overridable Sub DoInitApplication
protected:
virtual void DoInitApplication()
protected:
virtual void DoInitApplication()
abstract DoInitApplication : unit -> unit
override DoInitApplication : unit -> unit
abstract DoInitApplication : unit -> unit
override DoInitApplication : unit -> unit
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.GetDefaultConfigFileName Method

CommonApplicationLogic GetDefaultConfigFileName Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Tries to find a configuration file name looping through various supported estensions

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected string GetDefaultConfigFileName()
protected string GetDefaultConfigFileName()
Protected Function GetDefaultConfigFileName As String
Protected Function GetDefaultConfigFileName As String
protected:
String^ GetDefaultConfigFileName()
protected:
String^ GetDefaultConfigFileName()
member GetDefaultConfigFileName : unit -> string
member GetDefaultConfigFileName : unit -> string

Return Value

Type: Online String
File name that exists or empty string
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.GetStarters Method

CommonApplicationLogic GetStarters Method NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IEnumerable<IApplicationStarter> GetStarters()
protected IEnumerable<IApplicationStarter> GetStarters()
Protected Function GetStarters As IEnumerable(Of IApplicationStarter)
Protected Function GetStarters As IEnumerable(Of IApplicationStarter)
protected:
IEnumerable<IApplicationStarter^>^ GetStarters()
protected:
IEnumerable<IApplicationStarter^>^ GetStarters()
member GetStarters : unit -> IEnumerable<IApplicationStarter>
member GetStarters : unit -> IEnumerable<IApplicationStarter>

Return Value

Type: Online IEnumerable IApplicationStarter
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.InitApplication Method

CommonApplicationLogic InitApplication Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void InitApplication()
protected virtual void InitApplication()
Protected Overridable Sub InitApplication
Protected Overridable Sub InitApplication
protected:
virtual void InitApplication()
protected:
virtual void InitApplication()
abstract InitApplication : unit -> unit
override InitApplication : unit -> unit
abstract InitApplication : unit -> unit
override InitApplication : unit -> unit
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.LocalizedTimeToUniversalTime Method

CommonApplicationLogic LocalizedTimeToUniversalTime Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Converts localized time to UTC time as of TimeLocation property

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
public DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
Public Function LocalizedTimeToUniversalTime (
    local As DateTime
) As DateTime
Public Function LocalizedTimeToUniversalTime (
    local As DateTime
) As DateTime
public:
virtual DateTime LocalizedTimeToUniversalTime(
    DateTime local
) sealed
public:
virtual DateTime LocalizedTimeToUniversalTime(
    DateTime local
) sealed
abstract LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
override LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
abstract LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
override LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime

Parameters

local
Type: Online System DateTime

Return Value

Type: Online DateTime

Implements

ILocalizedTimeProvider LocalizedTimeToUniversalTime(DateTime)
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.MakeNewSessionInstance Method

CommonApplicationLogic MakeNewSessionInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Makes BaseSession instance

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual ISession MakeNewSessionInstance(
    Guid sessionID,
    User user = null
)
public virtual ISession MakeNewSessionInstance(
    Guid sessionID,
    User user = null
)
Public Overridable Function MakeNewSessionInstance (
    sessionID As Guid,
    Optional user As User = Nothing
) As ISession
Public Overridable Function MakeNewSessionInstance (
    sessionID As Guid,
    Optional user As User = Nothing
) As ISession
public:
virtual ISession^ MakeNewSessionInstance(
    Guid sessionID,
    User^ user = nullptr
)
public:
virtual ISession^ MakeNewSessionInstance(
    Guid sessionID,
    User^ user = nullptr
)
abstract MakeNewSessionInstance :
        sessionID : Guid *
        ?user : User
(* Defaults:
        let _user = defaultArg user null
*)
-> ISession
override MakeNewSessionInstance :
        sessionID : Guid *
        ?user : User
(* Defaults:
        let _user = defaultArg user null
*)
-> ISession
abstract MakeNewSessionInstance :
        sessionID : Guid *
        ?user : User
(* Defaults:
        let _user = defaultArg user null
*)
-> ISession
override MakeNewSessionInstance :
        sessionID : Guid *
        ?user : User
(* Defaults:
        let _user = defaultArg user null
*)
-> ISession

Parameters

sessionID
Type: Online System Guid
user (Optional)
Type: NFX.Security User

Return Value

Type: ISession

Implements

IApplication MakeNewSessionInstance(Guid, User)
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.NotifyAllConfigSettingsAboutChange Method

CommonApplicationLogic NotifyAllConfigSettingsAboutChange Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public method | NotifyAllConfigSettingsAboutChange | Forces notification of all registered IConfigSettings-implementers about configuration change
Protected method | NotifyAllConfigSettingsAboutChange(IConfigSectionNode) | Forces notification of all registered IConfigSettings-implementers about configuration change
Back to Top
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.NotifyAllConfigSettingsAboutChange Method

CommonApplicationLogic NotifyAllConfigSettingsAboutChange Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Forces notification of all registered IConfigSettings-implementers about configuration change

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void NotifyAllConfigSettingsAboutChange()
public void NotifyAllConfigSettingsAboutChange()
Public Sub NotifyAllConfigSettingsAboutChange
Public Sub NotifyAllConfigSettingsAboutChange
public:
virtual void NotifyAllConfigSettingsAboutChange() sealed
public:
virtual void NotifyAllConfigSettingsAboutChange() sealed
abstract NotifyAllConfigSettingsAboutChange : unit -> unit
override NotifyAllConfigSettingsAboutChange : unit -> unit
abstract NotifyAllConfigSettingsAboutChange : unit -> unit
override NotifyAllConfigSettingsAboutChange : unit -> unit

Implements

IApplication NotifyAllConfigSettingsAboutChange
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NotifyAllConfigSettingsAboutChange Overload
NFX.ApplicationModel Namespace


CommonApplicationLogic.NotifyAllConfigSettingsAboutChange Method (IConfigSectionNode)

CommonApplicationLogic NotifyAllConfigSettingsAboutChange Method (IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Forces notification of all registered IConfigSettings-implementers about configuration change

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void NotifyAllConfigSettingsAboutChange(
    IConfigSectionNode node
)
protected void NotifyAllConfigSettingsAboutChange(
    IConfigSectionNode node
)
Protected Sub NotifyAllConfigSettingsAboutChange (
    node As IConfigSectionNode
)
Protected Sub NotifyAllConfigSettingsAboutChange (
    node As IConfigSectionNode
)
protected:
void NotifyAllConfigSettingsAboutChange(
    IConfigSectionNode^ node
)
protected:
void NotifyAllConfigSettingsAboutChange(
    IConfigSectionNode^ node
)
member NotifyAllConfigSettingsAboutChange :
        node : IConfigSectionNode -> unit
member NotifyAllConfigSettingsAboutChange :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NotifyAllConfigSettingsAboutChange Overload
NFX.ApplicationModel Namespace


CommonApplicationLogic.PreloadAssemblies Method

CommonApplicationLogic PreloadAssemblies Method NFX Class Library

[This is preliminary documentation and is subject to change.]

RESERVED for future use. Loads assemblies specified in 'preload-assemblies' section from disk optionally checking the 'enabled' flag. This method is called on application startup by the framework

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool PreloadAssemblies(
    bool checkFlag = true
)
public bool PreloadAssemblies(
    bool checkFlag = true
)
Public Function PreloadAssemblies (
    Optional checkFlag As Boolean = true
) As Boolean
Public Function PreloadAssemblies (
    Optional checkFlag As Boolean = true
) As Boolean
public:
bool PreloadAssemblies(
    bool checkFlag = true
)
public:
bool PreloadAssemblies(
    bool checkFlag = true
)
member PreloadAssemblies :
        ?checkFlag : bool
(* Defaults:
        let _checkFlag = defaultArg checkFlag true
*)
-> bool
member PreloadAssemblies :
        ?checkFlag : bool
(* Defaults:
        let _checkFlag = defaultArg checkFlag true
*)
-> bool

Parameters

checkFlag (Optional)
Type: Online System Boolean

Return Value

Type: Online Boolean
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.RegisterAppFinishNotifiable Method

CommonApplicationLogic RegisterAppFinishNotifiable Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Registers an instance of IApplicationFinishNotifiable with application container to receive a call when underlying application instance will finish its lifecycle

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool RegisterAppFinishNotifiable(
    IApplicationFinishNotifiable notifiable
)
public bool RegisterAppFinishNotifiable(
    IApplicationFinishNotifiable notifiable
)
Public Function RegisterAppFinishNotifiable (
    notifiable As IApplicationFinishNotifiable
) As Boolean
Public Function RegisterAppFinishNotifiable (
    notifiable As IApplicationFinishNotifiable
) As Boolean
public:
virtual bool RegisterAppFinishNotifiable(
    IApplicationFinishNotifiable^ notifiable
) sealed
public:
virtual bool RegisterAppFinishNotifiable(
    IApplicationFinishNotifiable^ notifiable
) sealed
abstract RegisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool
override RegisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool
abstract RegisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool
override RegisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool

Parameters

notifiable
Type: NFX.ApplicationModel IApplicationFinishNotifiable

Return Value

Type: Online Boolean
True if notifiable instance was not found and was added

Implements

IApplication RegisterAppFinishNotifiable(IApplicationFinishNotifiable)
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.RegisterConfigSettings Method

CommonApplicationLogic RegisterConfigSettings Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Registers an instance of IConfigSettings with application container to receive a call when underlying app configuration changes

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool RegisterConfigSettings(
    IConfigSettings settings
)
public bool RegisterConfigSettings(
    IConfigSettings settings
)
Public Function RegisterConfigSettings (
    settings As IConfigSettings
) As Boolean
Public Function RegisterConfigSettings (
    settings As IConfigSettings
) As Boolean
public:
virtual bool RegisterConfigSettings(
    IConfigSettings^ settings
) sealed
public:
virtual bool RegisterConfigSettings(
    IConfigSettings^ settings
) sealed
abstract RegisterConfigSettings :
        settings : IConfigSettings -> bool
override RegisterConfigSettings :
        settings : IConfigSettings -> bool
abstract RegisterConfigSettings :
        settings : IConfigSettings -> bool
override RegisterConfigSettings :
        settings : IConfigSettings -> bool

Parameters

settings
Type: NFX.Environment IConfigSettings

Return Value

Type: Online Boolean
True if settings instance was not found and was added

Implements

IApplication RegisterConfigSettings(IConfigSettings)
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.Stop Method

CommonApplicationLogic Stop Method NFX Class Library

Initiates the stop of the application by setting its Stopping to true and Active to false so dependent services may start to terminate

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Stop()
public void Stop()
Public Sub Stop
Public Sub Stop
public:
virtual void Stop() sealed
public:
virtual void Stop() sealed
abstract Stop : unit -> unit
override Stop : unit -> unit
abstract Stop : unit -> unit
override Stop : unit -> unit

Implements

IApplication Stop
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.UniversalTimeToLocalizedTime Method

CommonApplicationLogic UniversalTimeToLocalizedTime Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Converts universal time to local time as of TimeLocation property

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
public DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
Public Function UniversalTimeToLocalizedTime (
    utc As DateTime
) As DateTime
Public Function UniversalTimeToLocalizedTime (
    utc As DateTime
) As DateTime
public:
virtual DateTime UniversalTimeToLocalizedTime(
    DateTime utc
) sealed
public:
virtual DateTime UniversalTimeToLocalizedTime(
    DateTime utc
) sealed
abstract UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
override UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
abstract UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
override UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime

Parameters

utc
Type: Online System DateTime

Return Value

Type: Online DateTime

Implements

ILocalizedTimeProvider UniversalTimeToLocalizedTime(DateTime)
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.UnregisterAppFinishNotifiable Method

CommonApplicationLogic UnregisterAppFinishNotifiable Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Removes the registration of IConfigSettings from application container

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool UnregisterAppFinishNotifiable(
    IApplicationFinishNotifiable notifiable
)
public bool UnregisterAppFinishNotifiable(
    IApplicationFinishNotifiable notifiable
)
Public Function UnregisterAppFinishNotifiable (
    notifiable As IApplicationFinishNotifiable
) As Boolean
Public Function UnregisterAppFinishNotifiable (
    notifiable As IApplicationFinishNotifiable
) As Boolean
public:
virtual bool UnregisterAppFinishNotifiable(
    IApplicationFinishNotifiable^ notifiable
) sealed
public:
virtual bool UnregisterAppFinishNotifiable(
    IApplicationFinishNotifiable^ notifiable
) sealed
abstract UnregisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool
override UnregisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool
abstract UnregisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool
override UnregisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool

Parameters

notifiable
Type: NFX.ApplicationModel IApplicationFinishNotifiable

Return Value

Type: Online Boolean
True if notifiable instance was found and removed

Implements

IApplication UnregisterAppFinishNotifiable(IApplicationFinishNotifiable)
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.UnregisterConfigSettings Method

CommonApplicationLogic UnregisterConfigSettings Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Removes the registration of IConfigSettings from application container

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool UnregisterConfigSettings(
    IConfigSettings settings
)
public bool UnregisterConfigSettings(
    IConfigSettings settings
)
Public Function UnregisterConfigSettings (
    settings As IConfigSettings
) As Boolean
Public Function UnregisterConfigSettings (
    settings As IConfigSettings
) As Boolean
public:
virtual bool UnregisterConfigSettings(
    IConfigSettings^ settings
) sealed
public:
virtual bool UnregisterConfigSettings(
    IConfigSettings^ settings
) sealed
abstract UnregisterConfigSettings :
        settings : IConfigSettings -> bool
override UnregisterConfigSettings :
        settings : IConfigSettings -> bool
abstract UnregisterConfigSettings :
        settings : IConfigSettings -> bool
override UnregisterConfigSettings :
        settings : IConfigSettings -> bool

Parameters

settings
Type: NFX.Environment IConfigSettings

Return Value

Type: Online Boolean
True if settings instance was found and removed

Implements

IApplication UnregisterConfigSettings(IConfigSettings)
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.WriteLog Method

CommonApplicationLogic WriteLog Method NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void WriteLog(
    MessageType type,
    string from,
    string msgText,
    Exception error = null,
    string file = "",
    int line = 0,
    Object pars = null
)
protected void WriteLog(
    MessageType type,
    string from,
    string msgText,
    Exception error = null,
    string file = "",
    int line = 0,
    Object pars = null
)
Protected Sub WriteLog (
    type As MessageType,
    from As String,
    msgText As String,
    Optional error As Exception = Nothing,
    Optional file As String = "",
    Optional line As Integer = 0,
    Optional pars As Object = Nothing
)
Protected Sub WriteLog (
    type As MessageType,
    from As String,
    msgText As String,
    Optional error As Exception = Nothing,
    Optional file As String = "",
    Optional line As Integer = 0,
    Optional pars As Object = Nothing
)
protected:
void WriteLog(
    MessageType type,
    String^ from,
    String^ msgText,
    Exception^ error = nullptr,
    String^ file = L"",
    int line = 0,
    Object^ pars = nullptr
)
protected:
void WriteLog(
    MessageType type,
    String^ from,
    String^ msgText,
    Exception^ error = nullptr,
    String^ file = L"",
    int line = 0,
    Object^ pars = nullptr
)
member WriteLog :
        type : MessageType *
        from : string *
        msgText : string *
        ?error : Exception *
        ?file : string *
        ?line : int *
        ?pars : Object
(* Defaults:
        let _error = defaultArg error null
        let _file = defaultArg file ""
        let _line = defaultArg line 0
        let _pars = defaultArg pars null
*)
-> unit
member WriteLog :
        type : MessageType *
        from : string *
        msgText : string *
        ?error : Exception *
        ?file : string *
        ?line : int *
        ?pars : Object
(* Defaults:
        let _error = defaultArg error null
        let _file = defaultArg file ""
        let _line = defaultArg line 0
        let _pars = defaultArg pars null
*)
-> unit

Parameters

type
Type: NFX.Log MessageType
from
Type: Online System String
msgText
Type: Online System String
error (Optional)
Type: Online System Exception
file (Optional)
Type: Online System String
line (Optional)
Type: Online System Int32
pars (Optional)
Type: Online System Object
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic Properties

CommonApplicationLogic Properties NFX Class Library

The CommonApplicationLogic type exposes the following members.
Properties
 | Name | Description
Public property | Active | Returns true when application instance is active and working. This property returns false as soon as application finalization starts on shutdown Use to exit long-running loops and such
Public property | ConfigRoot | Provides access to configuration root for the whole application
Public property | DataStore | References application data store
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EventTimer | References event timer which maintains and runs scheduled Event instances
Public property | Glue | References glue that can be used to interconnect remote instances
Public property | InstanceID | Returns unique identifier of this running instance
Public property | Instrumentation | References application instrumentation
Public property | IsUnitTest |
Public property | LocalizedTime | Returns current time localized per TimeLocation
Public property | Log | References application logger
Public property | Name | Returns the name of this application
Public property | ObjectStore | References application object store. Objects will survive application termination
Public property | SecurityManager | References security manager that performs user authentication based on passed credentials and other security-related global tasks
Public property | ShutdownStarted | Returns true to indicate that Dispose() has been called and shutdown has started
Public property | StartTime | Returns timestamp when application started as localized app time
Public property | Stopping | Returns true to indicate that Stop() was called
Public property | Throttling | References application throttling
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation
Public property | TimeSource | References time source - an entity that supplies local and UTC times. The concrete implementation may elect to get accurate times from the network or other external precision time sources (i.e. NASA atomic clock)
Back to Top
See Also
CommonApplicationLogic Class
NFX.ApplicationModel Namespace


CommonApplicationLogic.Active Property

CommonApplicationLogic Active Property NFX Class Library

Returns true when application instance is active and working. This property returns false as soon as application finalization starts on shutdown Use to exit long-running loops and such

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Active { get; }
public bool Active { get; }
Public ReadOnly Property Active As Boolean
    Get
Public ReadOnly Property Active As Boolean
    Get
public:
virtual property bool Active {
    bool get () sealed;
}
public:
virtual property bool Active {
    bool get () sealed;
}
abstract Active : bool with get
override Active : bool with get
abstract Active : bool with get
override Active : bool with get

Property Value

Type: Online Boolean

Implements

IApplication Active
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.ConfigRoot Property

CommonApplicationLogic ConfigRoot Property NFX Class Library

Provides access to configuration root for the whole application

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigSectionNode ConfigRoot { get; }
public ConfigSectionNode ConfigRoot { get; }
Public ReadOnly Property ConfigRoot As ConfigSectionNode
    Get
Public ReadOnly Property ConfigRoot As ConfigSectionNode
    Get
public:
virtual property ConfigSectionNode^ ConfigRoot {
    ConfigSectionNode^ get () sealed;
}
public:
virtual property ConfigSectionNode^ ConfigRoot {
    ConfigSectionNode^ get () sealed;
}
abstract ConfigRoot : ConfigSectionNode with get
override ConfigRoot : ConfigSectionNode with get
abstract ConfigRoot : ConfigSectionNode with get
override ConfigRoot : ConfigSectionNode with get

Property Value

Type: ConfigSectionNode

Implements

IApplication ConfigRoot
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.DataStore Property

CommonApplicationLogic DataStore Property NFX Class Library

References application data store

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDataStore DataStore { get; }
public IDataStore DataStore { get; }
Public ReadOnly Property DataStore As IDataStore
    Get
Public ReadOnly Property DataStore As IDataStore
    Get
public:
virtual property IDataStore^ DataStore {
    IDataStore^ get () sealed;
}
public:
virtual property IDataStore^ DataStore {
    IDataStore^ get () sealed;
}
abstract DataStore : IDataStore with get
override DataStore : IDataStore with get
abstract DataStore : IDataStore with get
override DataStore : IDataStore with get

Property Value

Type: IDataStore

Implements

IApplication DataStore
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.EventTimer Property

CommonApplicationLogic EventTimer Property NFX Class Library

References event timer which maintains and runs scheduled Event instances

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEventTimer EventTimer { get; }
public IEventTimer EventTimer { get; }
Public ReadOnly Property EventTimer As IEventTimer
    Get
Public ReadOnly Property EventTimer As IEventTimer
    Get
public:
virtual property IEventTimer^ EventTimer {
    IEventTimer^ get () sealed;
}
public:
virtual property IEventTimer^ EventTimer {
    IEventTimer^ get () sealed;
}
abstract EventTimer : IEventTimer with get
override EventTimer : IEventTimer with get
abstract EventTimer : IEventTimer with get
override EventTimer : IEventTimer with get

Property Value

Type: IEventTimer

Implements

IApplication EventTimer
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.Glue Property

CommonApplicationLogic Glue Property NFX Class Library

References glue that can be used to interconnect remote instances

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IGlue Glue { get; }
public IGlue Glue { get; }
Public ReadOnly Property Glue As IGlue
    Get
Public ReadOnly Property Glue As IGlue
    Get
public:
virtual property IGlue^ Glue {
    IGlue^ get () sealed;
}
public:
virtual property IGlue^ Glue {
    IGlue^ get () sealed;
}
abstract Glue : IGlue with get
override Glue : IGlue with get
abstract Glue : IGlue with get
override Glue : IGlue with get

Property Value

Type: IGlue

Implements

IApplication Glue
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.InstanceID Property

CommonApplicationLogic InstanceID Property NFX Class Library

Returns unique identifier of this running instance

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid InstanceID { get; }
public Guid InstanceID { get; }
Public ReadOnly Property InstanceID As Guid
    Get
Public ReadOnly Property InstanceID As Guid
    Get
public:
virtual property Guid InstanceID {
    Guid get () sealed;
}
public:
virtual property Guid InstanceID {
    Guid get () sealed;
}
abstract InstanceID : Guid with get
override InstanceID : Guid with get
abstract InstanceID : Guid with get
override InstanceID : Guid with get

Property Value

Type: Online Guid

Implements

IApplication InstanceID
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.Instrumentation Property

CommonApplicationLogic Instrumentation Property NFX Class Library

[This is preliminary documentation and is subject to change.]

References application instrumentation

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IInstrumentation Instrumentation { get; }
public IInstrumentation Instrumentation { get; }
Public ReadOnly Property Instrumentation As IInstrumentation
    Get
Public ReadOnly Property Instrumentation As IInstrumentation
    Get
public:
virtual property IInstrumentation^ Instrumentation {
    IInstrumentation^ get () sealed;
}
public:
virtual property IInstrumentation^ Instrumentation {
    IInstrumentation^ get () sealed;
}
abstract Instrumentation : IInstrumentation with get
override Instrumentation : IInstrumentation with get
abstract Instrumentation : IInstrumentation with get
override Instrumentation : IInstrumentation with get

Property Value

Type: IInstrumentation

Implements

IApplication Instrumentation
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.IsUnitTest Property

CommonApplicationLogic IsUnitTest Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsUnitTest { get; }
public bool IsUnitTest { get; }
Public ReadOnly Property IsUnitTest As Boolean
    Get
Public ReadOnly Property IsUnitTest As Boolean
    Get
public:
virtual property bool IsUnitTest {
    bool get () sealed;
}
public:
virtual property bool IsUnitTest {
    bool get () sealed;
}
abstract IsUnitTest : bool with get
override IsUnitTest : bool with get
abstract IsUnitTest : bool with get
override IsUnitTest : bool with get

Property Value

Type: Online Boolean

Implements

IApplication IsUnitTest
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.LocalizedTime Property

CommonApplicationLogic LocalizedTime Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns current time localized per TimeLocation

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime LocalizedTime { get; }
public DateTime LocalizedTime { get; }
Public ReadOnly Property LocalizedTime As DateTime
    Get
Public ReadOnly Property LocalizedTime As DateTime
    Get
public:
virtual property DateTime LocalizedTime {
    DateTime get () sealed;
}
public:
virtual property DateTime LocalizedTime {
    DateTime get () sealed;
}
abstract LocalizedTime : DateTime with get
override LocalizedTime : DateTime with get
abstract LocalizedTime : DateTime with get
override LocalizedTime : DateTime with get

Property Value

Type: Online DateTime

Implements

ILocalizedTimeProvider LocalizedTime
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.Log Property

CommonApplicationLogic Log Property NFX Class Library

References application logger

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILog Log { get; }
public ILog Log { get; }
Public ReadOnly Property Log As ILog
    Get
Public ReadOnly Property Log As ILog
    Get
public:
virtual property ILog^ Log {
    ILog^ get () sealed;
}
public:
virtual property ILog^ Log {
    ILog^ get () sealed;
}
abstract Log : ILog with get
override Log : ILog with get
abstract Log : ILog with get
override Log : ILog with get

Property Value

Type: ILog

Implements

IApplication Log
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.Name Property

CommonApplicationLogic Name Property NFX Class Library

Returns the name of this application

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.ObjectStore Property

CommonApplicationLogic ObjectStore Property NFX Class Library

[This is preliminary documentation and is subject to change.]

References application object store. Objects will survive application termination

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IObjectStore ObjectStore { get; }
public IObjectStore ObjectStore { get; }
Public ReadOnly Property ObjectStore As IObjectStore
    Get
Public ReadOnly Property ObjectStore As IObjectStore
    Get
public:
virtual property IObjectStore^ ObjectStore {
    IObjectStore^ get () sealed;
}
public:
virtual property IObjectStore^ ObjectStore {
    IObjectStore^ get () sealed;
}
abstract ObjectStore : IObjectStore with get
override ObjectStore : IObjectStore with get
abstract ObjectStore : IObjectStore with get
override ObjectStore : IObjectStore with get

Property Value

Type: IObjectStore

Implements

IApplication ObjectStore
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.SecurityManager Property

CommonApplicationLogic SecurityManager Property NFX Class Library

[This is preliminary documentation and is subject to change.]

References security manager that performs user authentication based on passed credentials and other security-related global tasks

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ISecurityManager SecurityManager { get; }
public ISecurityManager SecurityManager { get; }
Public ReadOnly Property SecurityManager As ISecurityManager
    Get
Public ReadOnly Property SecurityManager As ISecurityManager
    Get
public:
virtual property ISecurityManager^ SecurityManager {
    ISecurityManager^ get () sealed;
}
public:
virtual property ISecurityManager^ SecurityManager {
    ISecurityManager^ get () sealed;
}
abstract SecurityManager : ISecurityManager with get
override SecurityManager : ISecurityManager with get
abstract SecurityManager : ISecurityManager with get
override SecurityManager : ISecurityManager with get

Property Value

Type: ISecurityManager

Implements

IApplication SecurityManager
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.ShutdownStarted Property

CommonApplicationLogic ShutdownStarted Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns true to indicate that Dispose() has been called and shutdown has started

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ShutdownStarted { get; }
public bool ShutdownStarted { get; }
Public ReadOnly Property ShutdownStarted As Boolean
    Get
Public ReadOnly Property ShutdownStarted As Boolean
    Get
public:
virtual property bool ShutdownStarted {
    bool get () sealed;
}
public:
virtual property bool ShutdownStarted {
    bool get () sealed;
}
abstract ShutdownStarted : bool with get
override ShutdownStarted : bool with get
abstract ShutdownStarted : bool with get
override ShutdownStarted : bool with get

Property Value

Type: Online Boolean

Implements

IApplication ShutdownStarted
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.StartTime Property

CommonApplicationLogic StartTime Property NFX Class Library

Returns timestamp when application started as localized app time

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime StartTime { get; }
public DateTime StartTime { get; }
Public ReadOnly Property StartTime As DateTime
    Get
Public ReadOnly Property StartTime As DateTime
    Get
public:
virtual property DateTime StartTime {
    DateTime get () sealed;
}
public:
virtual property DateTime StartTime {
    DateTime get () sealed;
}
abstract StartTime : DateTime with get
override StartTime : DateTime with get
abstract StartTime : DateTime with get
override StartTime : DateTime with get

Property Value

Type: Online DateTime

Implements

IApplication StartTime
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.Stopping Property

CommonApplicationLogic Stopping Property NFX Class Library

Returns true to indicate that Stop() was called

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Stopping { get; }
public bool Stopping { get; }
Public ReadOnly Property Stopping As Boolean
    Get
Public ReadOnly Property Stopping As Boolean
    Get
public:
virtual property bool Stopping {
    bool get () sealed;
}
public:
virtual property bool Stopping {
    bool get () sealed;
}
abstract Stopping : bool with get
override Stopping : bool with get
abstract Stopping : bool with get
override Stopping : bool with get

Property Value

Type: Online Boolean

Implements

IApplication Stopping
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.Throttling Property

CommonApplicationLogic Throttling Property NFX Class Library

References application throttling

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IThrottling Throttling { get; }
public IThrottling Throttling { get; }
Public ReadOnly Property Throttling As IThrottling
    Get
Public ReadOnly Property Throttling As IThrottling
    Get
public:
virtual property IThrottling^ Throttling {
    IThrottling^ get () sealed;
}
public:
virtual property IThrottling^ Throttling {
    IThrottling^ get () sealed;
}
abstract Throttling : IThrottling with get
override Throttling : IThrottling with get
abstract Throttling : IThrottling with get
override Throttling : IThrottling with get

Property Value

Type: IThrottling

Implements

IApplication Throttling
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.TimeLocation Property

CommonApplicationLogic TimeLocation Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns time location of this LocalizedTimeProvider implementation

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeLocation TimeLocation { get; set; }
public TimeLocation TimeLocation { get; set; }
Public Property TimeLocation As TimeLocation
    Get
    Set
Public Property TimeLocation As TimeLocation
    Get
    Set
public:
virtual property TimeLocation^ TimeLocation {
    TimeLocation^ get () sealed;
    void set (TimeLocation^ value) sealed;
}
public:
virtual property TimeLocation^ TimeLocation {
    TimeLocation^ get () sealed;
    void set (TimeLocation^ value) sealed;
}
abstract TimeLocation : TimeLocation with get, set
override TimeLocation : TimeLocation with get, set
abstract TimeLocation : TimeLocation with get, set
override TimeLocation : TimeLocation with get, set

Property Value

Type: TimeLocation

Implements

ILocalizedTimeProvider TimeLocation
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


CommonApplicationLogic.TimeSource Property

CommonApplicationLogic TimeSource Property NFX Class Library

References time source - an entity that supplies local and UTC times. The concrete implementation may elect to get accurate times from the network or other external precision time sources (i.e. NASA atomic clock)

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ITimeSource TimeSource { get; }
public ITimeSource TimeSource { get; }
Public ReadOnly Property TimeSource As ITimeSource
    Get
Public ReadOnly Property TimeSource As ITimeSource
    Get
public:
virtual property ITimeSource^ TimeSource {
    ITimeSource^ get () sealed;
}
public:
virtual property ITimeSource^ TimeSource {
    ITimeSource^ get () sealed;
}
abstract TimeSource : ITimeSource with get
override TimeSource : ITimeSource with get
abstract TimeSource : ITimeSource with get
override TimeSource : ITimeSource with get

Property Value

Type: ITimeSource

Implements

IApplication TimeSource
See Also
CommonApplicationLogic Class
CommonApplicationLogic Members
NFX.ApplicationModel Namespace


ExecutionContext Class

ExecutionContext Class NFX Class Library

Provides access to execution context - an entity that groups Request, Response and Session object. This class has nothing to do with Web. Execution contexts are supported as easily in console, service, web, and Windows forms apps. All objects may be either application-global or thread level. This class is useful for technology-agnostic implementations of Record Models i.e. in a Record class one may write: " if (ExecutionContext.Session.User.Kind==UserKind.Administrator)..."
Inheritance Hierarchy
Online System Object
NFX.ApplicationModel ExecutionContext

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class ExecutionContext
public static class ExecutionContext
Public NotInheritable Class ExecutionContext
Public NotInheritable Class ExecutionContext
public ref class ExecutionContext abstract sealed
public ref class ExecutionContext abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ExecutionContext =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ExecutionContext =  class end
See Also
ExecutionContext Members
NFX.ApplicationModel Namespace


ExecutionContext Members

ExecutionContext Members NFX Class Library

The ExecutionContext type exposes the following members.
Methods
Name | Description
__SetApplicationLevelContext | Internal framework-only method to bind application-level context
__SetThreadLevelContext | Internal framework-only method to bind thread-level context
__SetThreadLevelSessionContext | Internal framework-only method to bind thread-level context
Back to Top
Properties
Name | Description
Application | Returns global application context
HasThreadContextSession | Returns true when thread-level session object is available and not a NOPSession instance
Request | Returns Request object for current thread, or if it is null, app-global-level object is returned
Response | Returns Response object for current thread, or if it is null, app-global-level object is returned
Session | Returns Session object for current thread, or if it is null, app-global-level object is returned
Back to Top
See Also
ExecutionContext Class
NFX.ApplicationModel Namespace


ExecutionContext Methods

ExecutionContext Methods NFX Class Library

The ExecutionContext type exposes the following members.
Methods
Name | Description
__SetApplicationLevelContext | Internal framework-only method to bind application-level context
__SetThreadLevelContext | Internal framework-only method to bind thread-level context
__SetThreadLevelSessionContext | Internal framework-only method to bind thread-level context
Back to Top
See Also
ExecutionContext Class
NFX.ApplicationModel Namespace


ExecutionContext.__SetApplicationLevelContext Method

ExecutionContext __SetApplicationLevelContext Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Internal framework-only method to bind application-level context

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void __SetApplicationLevelContext(
    IApplication application,
    Object request,
    Object response,
    ISession session
)
public static void __SetApplicationLevelContext(
    IApplication application,
    Object request,
    Object response,
    ISession session
)
Public Shared Sub __SetApplicationLevelContext (
    application As IApplication,
    request As Object,
    response As Object,
    session As ISession
)
Public Shared Sub __SetApplicationLevelContext (
    application As IApplication,
    request As Object,
    response As Object,
    session As ISession
)
public:
static void __SetApplicationLevelContext(
    IApplication^ application,
    Object^ request,
    Object^ response,
    ISession^ session
)
public:
static void __SetApplicationLevelContext(
    IApplication^ application,
    Object^ request,
    Object^ response,
    ISession^ session
)
static member __SetApplicationLevelContext :
        application : IApplication *
        request : Object *
        response : Object *
        session : ISession -> unit
static member __SetApplicationLevelContext :
        application : IApplication *
        request : Object *
        response : Object *
        session : ISession -> unit

Parameters

application
Type: NFX.ApplicationModel IApplication
request
Type: Online System Object
response
Type: Online System Object
session
Type: NFX.ApplicationModel ISession
See Also
ExecutionContext Class
ExecutionContext Members
NFX.ApplicationModel Namespace


ExecutionContext.__SetThreadLevelContext Method

ExecutionContext __SetThreadLevelContext Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Internal framework-only method to bind thread-level context

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void __SetThreadLevelContext(
    Object request,
    Object response,
    ISession session
)
public static void __SetThreadLevelContext(
    Object request,
    Object response,
    ISession session
)
Public Shared Sub __SetThreadLevelContext (
    request As Object,
    response As Object,
    session As ISession
)
Public Shared Sub __SetThreadLevelContext (
    request As Object,
    response As Object,
    session As ISession
)
public:
static void __SetThreadLevelContext(
    Object^ request,
    Object^ response,
    ISession^ session
)
public:
static void __SetThreadLevelContext(
    Object^ request,
    Object^ response,
    ISession^ session
)
static member __SetThreadLevelContext :
        request : Object *
        response : Object *
        session : ISession -> unit
static member __SetThreadLevelContext :
        request : Object *
        response : Object *
        session : ISession -> unit

Parameters

request
Type: Online System Object
response
Type: Online System Object
session
Type: NFX.ApplicationModel ISession
See Also
ExecutionContext Class
ExecutionContext Members
NFX.ApplicationModel Namespace


ExecutionContext.__SetThreadLevelSessionContext Method

ExecutionContext __SetThreadLevelSessionContext Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Internal framework-only method to bind thread-level context

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void __SetThreadLevelSessionContext(
    ISession session
)
public static void __SetThreadLevelSessionContext(
    ISession session
)
Public Shared Sub __SetThreadLevelSessionContext (
    session As ISession
)
Public Shared Sub __SetThreadLevelSessionContext (
    session As ISession
)
public:
static void __SetThreadLevelSessionContext(
    ISession^ session
)
public:
static void __SetThreadLevelSessionContext(
    ISession^ session
)
static member __SetThreadLevelSessionContext :
        session : ISession -> unit
static member __SetThreadLevelSessionContext :
        session : ISession -> unit

Parameters

session
Type: NFX.ApplicationModel ISession
See Also
ExecutionContext Class
ExecutionContext Members
NFX.ApplicationModel Namespace


ExecutionContext Properties

ExecutionContext Properties NFX Class Library

The ExecutionContext type exposes the following members.
Properties
Name | Description
Application | Returns global application context
HasThreadContextSession | Returns true when thread-level session object is available and not a NOPSession instance
Request | Returns Request object for current thread, or if it is null, app-global-level object is returned
Response | Returns Response object for current thread, or if it is null, app-global-level object is returned
Session | Returns Session object for current thread, or if it is null, app-global-level object is returned
Back to Top
See Also
ExecutionContext Class
NFX.ApplicationModel Namespace


ExecutionContext.Application Property

ExecutionContext Application Property NFX Class Library

Returns global application context

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IApplication Application { get; }
public static IApplication Application { get; }
Public Shared ReadOnly Property Application As IApplication
    Get
Public Shared ReadOnly Property Application As IApplication
    Get
public:
static property IApplication^ Application {
    IApplication^ get ();
}
public:
static property IApplication^ Application {
    IApplication^ get ();
}
static member Application : IApplication with get
static member Application : IApplication with get

Property Value

Type: IApplication
See Also
ExecutionContext Class
ExecutionContext Members
NFX.ApplicationModel Namespace


ExecutionContext.HasThreadContextSession Property

ExecutionContext HasThreadContextSession Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns true when thread-level session object is available and not a NOPSession instance

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool HasThreadContextSession { get; }
public static bool HasThreadContextSession { get; }
Public Shared ReadOnly Property HasThreadContextSession As Boolean
    Get
Public Shared ReadOnly Property HasThreadContextSession As Boolean
    Get
public:
static property bool HasThreadContextSession {
    bool get ();
}
public:
static property bool HasThreadContextSession {
    bool get ();
}
static member HasThreadContextSession : bool with get
static member HasThreadContextSession : bool with get

Property Value

Type: Online Boolean
See Also
ExecutionContext Class
ExecutionContext Members
NFX.ApplicationModel Namespace


ExecutionContext.Request Property

ExecutionContext Request Property NFX Class Library

Returns Request object for current thread, or if it is null, app-global-level object is returned

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Object Request { get; }
public static Object Request { get; }
Public Shared ReadOnly Property Request As Object
    Get
Public Shared ReadOnly Property Request As Object
    Get
public:
static property Object^ Request {
    Object^ get ();
}
public:
static property Object^ Request {
    Object^ get ();
}
static member Request : Object with get
static member Request : Object with get

Property Value

Type: Online Object
See Also
ExecutionContext Class
ExecutionContext Members
NFX.ApplicationModel Namespace


ExecutionContext.Response Property

ExecutionContext Response Property NFX Class Library

Returns Response object for current thread, or if it is null, app-global-level object is returned

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Object Response { get; }
public static Object Response { get; }
Public Shared ReadOnly Property Response As Object
    Get
Public Shared ReadOnly Property Response As Object
    Get
public:
static property Object^ Response {
    Object^ get ();
}
public:
static property Object^ Response {
    Object^ get ();
}
static member Response : Object with get
static member Response : Object with get

Property Value

Type: Online Object
See Also
ExecutionContext Class
ExecutionContext Members
NFX.ApplicationModel Namespace


ExecutionContext.Session Property

ExecutionContext Session Property NFX Class Library

Returns Session object for current thread, or if it is null, app-global-level object is returned

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ISession Session { get; }
public static ISession Session { get; }
Public Shared ReadOnly Property Session As ISession
    Get
Public Shared ReadOnly Property Session As ISession
    Get
public:
static property ISession^ Session {
    ISession^ get ();
}
public:
static property ISession^ Session {
    ISession^ get ();
}
static member Session : ISession with get
static member Session : ISession with get

Property Value

Type: ISession
See Also
ExecutionContext Class
ExecutionContext Members
NFX.ApplicationModel Namespace


IApplication Interface

IApplication Interface NFX Class Library

Describes general application model - usually a dependency injection container that governs application initialization, state management, logging etc... An applications is usually implemented with a singleton class that has static conduits to instance properties. Applications may be passed by reference (hence this interface) to simplify mocking that otherwise (in case of static-only class) would have been impossible

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IApplication : INamed,
    ILocalizedTimeProvider
public interface IApplication : INamed,
    ILocalizedTimeProvider
Public Interface IApplication
    Inherits INamed, ILocalizedTimeProvider
Public Interface IApplication
    Inherits INamed, ILocalizedTimeProvider
public interface class IApplication : INamed,
    ILocalizedTimeProvider
public interface class IApplication : INamed,
    ILocalizedTimeProvider
type IApplication =
    interface
        interface INamed
        interface ILocalizedTimeProvider
    end
type IApplication =
    interface
        interface INamed
        interface ILocalizedTimeProvider
    end
See Also
IApplication Members
NFX.ApplicationModel Namespace


IApplication Members

IApplication Members NFX Class Library

The IApplication type exposes the following members.
Methods
 | Name | Description
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | MakeNewSessionInstance | Factory method that creates new session object suitable for partcular application type
Public method | NotifyAllConfigSettingsAboutChange | Forces notification of all registered IConfigSettings-implementers about configuration change
Public method | RegisterAppFinishNotifiable | Registers an instance of IApplicationFinishNotifiable with application container to receive a call when underlying application instance will finish its lifecycle.
Public method | RegisterConfigSettings | Registers an instance of IConfigSettings with application container to receive a call when underlying app configuration changes
Public method | Stop | Initiates the stop of the application by setting its Stopping to true and Active to false so dependent services may start to terminate
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | UnregisterAppFinishNotifiable | Removes the registration of IApplicationFinishNotifiable from application container
Public method | UnregisterConfigSettings | Removes the registration of IConfigSettings from application container
Back to Top
Properties
 | Name | Description
Public property | Active | Returns true when application instance is active and working. This property returns false as soon as application finalization starts on shutdown or Stop() was called Use to exit long-running loops and such
Public property | ConfigRoot | References application configuration root
Public property | DataStore | References application data store
Public property | EventTimer | References event timer - an entity that maintains and runs scheduled instances of Event
Public property | Glue | References glue implementation that may be used to "glue" remote instances/processes/contracts together
Public property | InstanceID | Returns unique identifier of this running instance
Public property | Instrumentation | References instrumentation for this application instance
Public property | IsUnitTest | True if app is launched as a unit test as set by the app config "unit-test=true" The general use of this flag is discouraged as code cnstructs should not form special cases just for unit testing, however in some cases this flag is usefull. It is not exposed via App. static accessors
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from ILocalizedTimeProvider.)
Public property | Log | References app log
Public property | Name | (Inherited from INamed.)
Public property | ObjectStore | References object store that may be used to persist object graphs between volatile application shutdown cycles
Public property | SecurityManager | References security manager that performs user authentication based on passed credentials and other security-related global tasks
Public property | ShutdownStarted | Returns true after Dispose() was called to indicate that application is shutting down
Public property | StartTime | Returns timestamp when application started as localized app time
Public property | Stopping | Returns true after Stop() was called
Public property | Throttling | References throttling for this application instance
Public property | TimeLocation | Returns the location (Inherited from ILocalizedTimeProvider.)
Public property | TimeSource | References time source - an entity that supplies local and UTC times. The concrete implementation may elect to get accurate times from the network or other external precision time sources (i.e. NASA atomic clock)
Back to Top
See Also
IApplication Interface
NFX.ApplicationModel Namespace


IApplication Methods

IApplication Methods NFX Class Library

The IApplication type exposes the following members.
Methods
 | Name | Description
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | MakeNewSessionInstance | Factory method that creates new session object suitable for partcular application type
Public method | NotifyAllConfigSettingsAboutChange | Forces notification of all registered IConfigSettings-implementers about configuration change
Public method | RegisterAppFinishNotifiable | Registers an instance of IApplicationFinishNotifiable with application container to receive a call when underlying application instance will finish its lifecycle.
Public method | RegisterConfigSettings | Registers an instance of IConfigSettings with application container to receive a call when underlying app configuration changes
Public method | Stop | Initiates the stop of the application by setting its Stopping to true and Active to false so dependent services may start to terminate
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | UnregisterAppFinishNotifiable | Removes the registration of IApplicationFinishNotifiable from application container
Public method | UnregisterConfigSettings | Removes the registration of IConfigSettings from application container
Back to Top
See Also
IApplication Interface
NFX.ApplicationModel Namespace


IApplication.MakeNewSessionInstance Method

IApplication MakeNewSessionInstance Method NFX Class Library

Factory method that creates new session object suitable for partcular application type

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ISession MakeNewSessionInstance(
    Guid sessionID,
    User user = null
)
ISession MakeNewSessionInstance(
    Guid sessionID,
    User user = null
)
Function MakeNewSessionInstance (
    sessionID As Guid,
    Optional user As User = Nothing
) As ISession
Function MakeNewSessionInstance (
    sessionID As Guid,
    Optional user As User = Nothing
) As ISession
ISession^ MakeNewSessionInstance(
    Guid sessionID,
    User^ user = nullptr
)
ISession^ MakeNewSessionInstance(
    Guid sessionID,
    User^ user = nullptr
)
abstract MakeNewSessionInstance :
        sessionID : Guid *
        ?user : User
(* Defaults:
        let _user = defaultArg user null
*)
-> ISession
abstract MakeNewSessionInstance :
        sessionID : Guid *
        ?user : User
(* Defaults:
        let _user = defaultArg user null
*)
-> ISession

Parameters

sessionID
Type: Online System Guid
Session identifier
user (Optional)
Type: NFX.Security User
Optional user object that the session is for

Return Value

Type: ISession
New session object
See Also
IApplication Interface
IApplication Members
NFX.ApplicationModel Namespace


IApplication.NotifyAllConfigSettingsAboutChange Method

IApplication NotifyAllConfigSettingsAboutChange Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Forces notification of all registered IConfigSettings-implementers about configuration change

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void NotifyAllConfigSettingsAboutChange()
void NotifyAllConfigSettingsAboutChange()
Sub NotifyAllConfigSettingsAboutChange
Sub NotifyAllConfigSettingsAboutChange
void NotifyAllConfigSettingsAboutChange()
void NotifyAllConfigSettingsAboutChange()
abstract NotifyAllConfigSettingsAboutChange : unit -> unit
abstract NotifyAllConfigSettingsAboutChange : unit -> unit
See Also
IApplication Interface
IApplication Members
NFX.ApplicationModel Namespace


IApplication.RegisterAppFinishNotifiable Method

IApplication RegisterAppFinishNotifiable Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Registers an instance of IApplicationFinishNotifiable with application container to receive a call when underlying application instance will finish its lifecycle.

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool RegisterAppFinishNotifiable(
    IApplicationFinishNotifiable notifiable
)
bool RegisterAppFinishNotifiable(
    IApplicationFinishNotifiable notifiable
)
Function RegisterAppFinishNotifiable (
    notifiable As IApplicationFinishNotifiable
) As Boolean
Function RegisterAppFinishNotifiable (
    notifiable As IApplicationFinishNotifiable
) As Boolean
bool RegisterAppFinishNotifiable(
    IApplicationFinishNotifiable^ notifiable
)
bool RegisterAppFinishNotifiable(
    IApplicationFinishNotifiable^ notifiable
)
abstract RegisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool
abstract RegisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool

Parameters

notifiable
Type: NFX.ApplicationModel IApplicationFinishNotifiable

Return Value

Type: Online Boolean
True if notifiable instance was not found and was added
See Also
IApplication Interface
IApplication Members
NFX.ApplicationModel Namespace


IApplication.RegisterConfigSettings Method

IApplication RegisterConfigSettings Method NFX Class Library

Registers an instance of IConfigSettings with application container to receive a call when underlying app configuration changes

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool RegisterConfigSettings(
    IConfigSettings settings
)
bool RegisterConfigSettings(
    IConfigSettings settings
)
Function RegisterConfigSettings (
    settings As IConfigSettings
) As Boolean
Function RegisterConfigSettings (
    settings As IConfigSettings
) As Boolean
bool RegisterConfigSettings(
    IConfigSettings^ settings
)
bool RegisterConfigSettings(
    IConfigSettings^ settings
)
abstract RegisterConfigSettings :
        settings : IConfigSettings -> bool
abstract RegisterConfigSettings :
        settings : IConfigSettings -> bool

Parameters

settings
Type: NFX.Environment IConfigSettings

Return Value

Type: Online Boolean
True if settings instance was not found and was added
See Also
IApplication Interface
IApplication Members
NFX.ApplicationModel Namespace


IApplication.Stop Method

IApplication Stop Method NFX Class Library

Initiates the stop of the application by setting its Stopping to true and Active to false so dependent services may start to terminate

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Stop()
void Stop()
Sub Stop
Sub Stop
void Stop()
void Stop()
abstract Stop : unit -> unit
abstract Stop : unit -> unit
See Also
IApplication Interface
IApplication Members
NFX.ApplicationModel Namespace


IApplication.UnregisterAppFinishNotifiable Method

IApplication UnregisterAppFinishNotifiable Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Removes the registration of IApplicationFinishNotifiable from application container

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool UnregisterAppFinishNotifiable(
    IApplicationFinishNotifiable notifiable
)
bool UnregisterAppFinishNotifiable(
    IApplicationFinishNotifiable notifiable
)
Function UnregisterAppFinishNotifiable (
    notifiable As IApplicationFinishNotifiable
) As Boolean
Function UnregisterAppFinishNotifiable (
    notifiable As IApplicationFinishNotifiable
) As Boolean
bool UnregisterAppFinishNotifiable(
    IApplicationFinishNotifiable^ notifiable
)
bool UnregisterAppFinishNotifiable(
    IApplicationFinishNotifiable^ notifiable
)
abstract UnregisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool
abstract UnregisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool

Parameters

notifiable
Type: NFX.ApplicationModel IApplicationFinishNotifiable

Return Value

Type: Online Boolean
True if notifiable instance was found and removed
See Also
IApplication Interface
IApplication Members
NFX.ApplicationModel Namespace


IApplication.UnregisterConfigSettings Method

IApplication UnregisterConfigSettings Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Removes the registration of IConfigSettings from application container

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool UnregisterConfigSettings(
    IConfigSettings settings
)
bool UnregisterConfigSettings(
    IConfigSettings settings
)
Function UnregisterConfigSettings (
    settings As IConfigSettings
) As Boolean
Function UnregisterConfigSettings (
    settings As IConfigSettings
) As Boolean
bool UnregisterConfigSettings(
    IConfigSettings^ settings
)
bool UnregisterConfigSettings(
    IConfigSettings^ settings
)
abstract UnregisterConfigSettings :
        settings : IConfigSettings -> bool
abstract UnregisterConfigSettings :
        settings : IConfigSettings -> bool

Parameters

settings
Type: NFX.Environment IConfigSettings

Return Value

Type: Online Boolean
True if settings instance was found and removed
See Also
IApplication Interface
IApplication Members
NFX.ApplicationModel Namespace


IApplication Properties

IApplication Properties NFX Class Library

The IApplication type exposes the following members.
Properties
 | Name | Description
Public property | Active | Returns true when application instance is active and working. This property returns false as soon as application finalization starts on shutdown or Stop() was called Use to exit long-running loops and such
Public property | ConfigRoot | References application configuration root
Public property | DataStore | References application data store
Public property | EventTimer | References event timer - an entity that maintains and runs scheduled instances of Event
Public property | Glue | References glue implementation that may be used to "glue" remote instances/processes/contracts together
Public property | InstanceID | Returns unique identifier of this running instance
Public property | Instrumentation | References instrumentation for this application instance
Public property | IsUnitTest | True if app is launched as a unit test as set by the app config "unit-test=true" The general use of this flag is discouraged as code cnstructs should not form special cases just for unit testing, however in some cases this flag is usefull. It is not exposed via App. static accessors
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from ILocalizedTimeProvider.)
Public property | Log | References app log
Public property | Name | (Inherited from INamed.)
Public property | ObjectStore | References object store that may be used to persist object graphs between volatile application shutdown cycles
Public property | SecurityManager | References security manager that performs user authentication based on passed credentials and other security-related global tasks
Public property | ShutdownStarted | Returns true after Dispose() was called to indicate that application is shutting down
Public property | StartTime | Returns timestamp when application started as localized app time
Public property | Stopping | Returns true after Stop() was called
Public property | Throttling | References throttling for this application instance
Public property | TimeLocation | Returns the location (Inherited from ILocalizedTimeProvider.)
Public property | TimeSource | References time source - an entity that supplies local and UTC times. The concrete implementation may elect to get accurate times from the network or other external precision time sources (i.e. NASA atomic clock)
Back to Top
See Also
IApplication Interface
NFX.ApplicationModel Namespace


IApplication.Active Property

IApplication Active Property NFX Class Library

Returns true when application instance is active and working. This property returns false as soon as application finalization starts on shutdown or Stop() was called Use to exit long-running loops and such

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Active { get; }
bool Active { get; }
ReadOnly Property Active As Boolean
    Get
ReadOnly Property Active As Boolean
    Get
property bool Active {
    bool get ();
}
property bool Active {
    bool get ();
}
abstract Active : bool with get
abstract Active : bool with get

Property Value

Type: Online Boolean
See Also
IApplication Interface
IApplication Members
NFX.ApplicationModel Namespace


IApplication.ConfigRoot Property

IApplication ConfigRoot Property NFX Class Library

References application configuration root

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ConfigSectionNode ConfigRoot { get; }
ConfigSectionNode ConfigRoot { get; }
ReadOnly Property ConfigRoot As ConfigSectionNode
    Get
ReadOnly Property ConfigRoot As ConfigSectionNode
    Get
property ConfigSectionNode^ ConfigRoot {
    ConfigSectionNode^ get ();
}
property ConfigSectionNode^ ConfigRoot {
    ConfigSectionNode^ get ();
}
abstract ConfigRoot : ConfigSectionNode with get
abstract ConfigRoot : ConfigSectionNode with get

Property Value

Type: ConfigSectionNode
See Also
IApplication Interface
IApplication Members
NFX.ApplicationModel Namespace


IApplication.DataStore Property

IApplication DataStore Property NFX Class Library

References application data store

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IDataStore DataStore { get; }
IDataStore DataStore { get; }
ReadOnly Property DataStore As IDataStore
    Get
ReadOnly Property DataStore As IDataStore
    Get
property IDataStore^ DataStore {
    IDataStore^ get ();
}
property IDataStore^ DataStore {
    IDataStore^ get ();
}
abstract DataStore : IDataStore with get
abstract DataStore : IDataStore with get

Property Value

Type: IDataStore
See Also
IApplication Interface
IApplication Members
NFX.ApplicationModel Namespace


IApplication.EventTimer Property

IApplication EventTimer Property NFX Class Library

References event timer - an entity that maintains and runs scheduled instances of Event

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEventTimer EventTimer { get; }
IEventTimer EventTimer { get; }
ReadOnly Property EventTimer As IEventTimer
    Get
ReadOnly Property EventTimer As IEventTimer
    Get
property IEventTimer^ EventTimer {
    IEventTimer^ get ();
}
property IEventTimer^ EventTimer {
    IEventTimer^ get ();
}
abstract EventTimer : IEventTimer with get
abstract EventTimer : IEventTimer with get

Property Value

Type: IEventTimer
See Also
IApplication Interface
IApplication Members
NFX.ApplicationModel Namespace


IApplication.Glue Property

IApplication Glue Property NFX Class Library

References glue implementation that may be used to "glue" remote instances/processes/contracts together

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IGlue Glue { get; }
IGlue Glue { get; }
ReadOnly Property Glue As IGlue
    Get
ReadOnly Property Glue As IGlue
    Get
property IGlue^ Glue {
    IGlue^ get ();
}
property IGlue^ Glue {
    IGlue^ get ();
}
abstract Glue : IGlue with get
abstract Glue : IGlue with get

Property Value

Type: IGlue
See Also
IApplication Interface
IApplication Members
NFX.ApplicationModel Namespace


IApplication.InstanceID Property

IApplication InstanceID Property NFX Class Library

Returns unique identifier of this running instance

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Guid InstanceID { get; }
Guid InstanceID { get; }
ReadOnly Property InstanceID As Guid
    Get
ReadOnly Property InstanceID As Guid
    Get
property Guid InstanceID {
    Guid get ();
}
property Guid InstanceID {
    Guid get ();
}
abstract InstanceID : Guid with get
abstract InstanceID : Guid with get

Property Value

Type: Online Guid
See Also
IApplication Interface
IApplication Members
NFX.ApplicationModel Namespace


IApplication.Instrumentation Property

IApplication Instrumentation Property NFX Class Library

References instrumentation for this application instance

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IInstrumentation Instrumentation { get; }
IInstrumentation Instrumentation { get; }
ReadOnly Property Instrumentation As IInstrumentation
    Get
ReadOnly Property Instrumentation As IInstrumentation
    Get
property IInstrumentation^ Instrumentation {
    IInstrumentation^ get ();
}
property IInstrumentation^ Instrumentation {
    IInstrumentation^ get ();
}
abstract Instrumentation : IInstrumentation with get
abstract Instrumentation : IInstrumentation with get

Property Value

Type: IInstrumentation
See Also
IApplication Interface
IApplication Members
NFX.ApplicationModel Namespace


IApplication.IsUnitTest Property

IApplication IsUnitTest Property NFX Class Library

True if app is launched as a unit test as set by the app config "unit-test=true" The general use of this flag is discouraged as code cnstructs should not form special cases just for unit testing, however in some cases this flag is usefull. It is not exposed via App. static accessors

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsUnitTest { get; }
bool IsUnitTest { get; }
ReadOnly Property IsUnitTest As Boolean
    Get
ReadOnly Property IsUnitTest As Boolean
    Get
property bool IsUnitTest {
    bool get ();
}
property bool IsUnitTest {
    bool get ();
}
abstract IsUnitTest : bool with get
abstract IsUnitTest : bool with get

Property Value

Type: Online Boolean
See Also
IApplication Interface
IApplication Members
NFX.ApplicationModel Namespace


IApplication.Log Property

IApplication Log Property NFX Class Library

References app log

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ILog Log { get; }
ILog Log { get; }
ReadOnly Property Log As ILog
    Get
ReadOnly Property Log As ILog
    Get
property ILog^ Log {
    ILog^ get ();
}
property ILog^ Log {
    ILog^ get ();
}
abstract Log : ILog with get
abstract Log : ILog with get

Property Value

Type: ILog
See Also
IApplication Interface
IApplication Members
NFX.ApplicationModel Namespace


IApplication.ObjectStore Property

IApplication ObjectStore Property NFX Class Library

References object store that may be used to persist object graphs between volatile application shutdown cycles

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IObjectStore ObjectStore { get; }
IObjectStore ObjectStore { get; }
ReadOnly Property ObjectStore As IObjectStore
    Get
ReadOnly Property ObjectStore As IObjectStore
    Get
property IObjectStore^ ObjectStore {
    IObjectStore^ get ();
}
property IObjectStore^ ObjectStore {
    IObjectStore^ get ();
}
abstract ObjectStore : IObjectStore with get
abstract ObjectStore : IObjectStore with get

Property Value

Type: IObjectStore
See Also
IApplication Interface
IApplication Members
NFX.ApplicationModel Namespace


IApplication.SecurityManager Property

IApplication SecurityManager Property NFX Class Library

References security manager that performs user authentication based on passed credentials and other security-related global tasks

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ISecurityManager SecurityManager { get; }
ISecurityManager SecurityManager { get; }
ReadOnly Property SecurityManager As ISecurityManager
    Get
ReadOnly Property SecurityManager As ISecurityManager
    Get
property ISecurityManager^ SecurityManager {
    ISecurityManager^ get ();
}
property ISecurityManager^ SecurityManager {
    ISecurityManager^ get ();
}
abstract SecurityManager : ISecurityManager with get
abstract SecurityManager : ISecurityManager with get

Property Value

Type: ISecurityManager
See Also
IApplication Interface
IApplication Members
NFX.ApplicationModel Namespace


IApplication.ShutdownStarted Property

IApplication ShutdownStarted Property NFX Class Library

Returns true after Dispose() was called to indicate that application is shutting down

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool ShutdownStarted { get; }
bool ShutdownStarted { get; }
ReadOnly Property ShutdownStarted As Boolean
    Get
ReadOnly Property ShutdownStarted As Boolean
    Get
property bool ShutdownStarted {
    bool get ();
}
property bool ShutdownStarted {
    bool get ();
}
abstract ShutdownStarted : bool with get
abstract ShutdownStarted : bool with get

Property Value

Type: Online Boolean
See Also
IApplication Interface
IApplication Members
NFX.ApplicationModel Namespace


IApplication.StartTime Property

IApplication StartTime Property NFX Class Library

Returns timestamp when application started as localized app time

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
DateTime StartTime { get; }
DateTime StartTime { get; }
ReadOnly Property StartTime As DateTime
    Get
ReadOnly Property StartTime As DateTime
    Get
property DateTime StartTime {
    DateTime get ();
}
property DateTime StartTime {
    DateTime get ();
}
abstract StartTime : DateTime with get
abstract StartTime : DateTime with get

Property Value

Type: Online DateTime
See Also
IApplication Interface
IApplication Members
NFX.ApplicationModel Namespace


IApplication.Stopping Property

IApplication Stopping Property NFX Class Library

Returns true after Stop() was called

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Stopping { get; }
bool Stopping { get; }
ReadOnly Property Stopping As Boolean
    Get
ReadOnly Property Stopping As Boolean
    Get
property bool Stopping {
    bool get ();
}
property bool Stopping {
    bool get ();
}
abstract Stopping : bool with get
abstract Stopping : bool with get

Property Value

Type: Online Boolean
See Also
IApplication Interface
IApplication Members
NFX.ApplicationModel Namespace


IApplication.Throttling Property

IApplication Throttling Property NFX Class Library

References throttling for this application instance

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IThrottling Throttling { get; }
IThrottling Throttling { get; }
ReadOnly Property Throttling As IThrottling
    Get
ReadOnly Property Throttling As IThrottling
    Get
property IThrottling^ Throttling {
    IThrottling^ get ();
}
property IThrottling^ Throttling {
    IThrottling^ get ();
}
abstract Throttling : IThrottling with get
abstract Throttling : IThrottling with get

Property Value

Type: IThrottling
See Also
IApplication Interface
IApplication Members
NFX.ApplicationModel Namespace


IApplication.TimeSource Property

IApplication TimeSource Property NFX Class Library

References time source - an entity that supplies local and UTC times. The concrete implementation may elect to get accurate times from the network or other external precision time sources (i.e. NASA atomic clock)

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ITimeSource TimeSource { get; }
ITimeSource TimeSource { get; }
ReadOnly Property TimeSource As ITimeSource
    Get
ReadOnly Property TimeSource As ITimeSource
    Get
property ITimeSource^ TimeSource {
    ITimeSource^ get ();
}
property ITimeSource^ TimeSource {
    ITimeSource^ get ();
}
abstract TimeSource : ITimeSource with get
abstract TimeSource : ITimeSource with get

Property Value

Type: ITimeSource
See Also
IApplication Interface
IApplication Members
NFX.ApplicationModel Namespace


IApplicationComponent Interface

IApplicationComponent Interface NFX Class Library

Provides marker contract requirement for an ApplicationComponent. This interface must be implemented only by ApplicationComponent class

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IApplicationComponent : IDisposable
public interface IApplicationComponent : IDisposable
Public Interface IApplicationComponent
    Inherits IDisposable
Public Interface IApplicationComponent
    Inherits IDisposable
public interface class IApplicationComponent : IDisposable
public interface class IApplicationComponent : IDisposable
type IApplicationComponent =
    interface
        interface IDisposable
    end
type IApplicationComponent =
    interface
        interface IDisposable
    end
See Also
IApplicationComponent Members
NFX.ApplicationModel Namespace


IApplicationComponent Members

IApplicationComponent Members NFX Class Library

The IApplicationComponent type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null
Public property | ComponentSID | Returns process/instance unique app component system id
Back to Top
See Also
IApplicationComponent Interface
NFX.ApplicationModel Namespace


IApplicationComponent Methods

IApplicationComponent Methods NFX Class Library

The IApplicationComponent type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Back to Top
See Also
IApplicationComponent Interface
NFX.ApplicationModel Namespace


IApplicationComponent Properties

IApplicationComponent Properties NFX Class Library

The IApplicationComponent type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null
Public property | ComponentSID | Returns process/instance unique app component system id
Back to Top
See Also
IApplicationComponent Interface
NFX.ApplicationModel Namespace


IApplicationComponent.ComponentCommonName Property

IApplicationComponent ComponentCommonName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string ComponentCommonName { get; }
string ComponentCommonName { get; }
ReadOnly Property ComponentCommonName As String
    Get
ReadOnly Property ComponentCommonName As String
    Get
property String^ ComponentCommonName {
    String^ get ();
}
property String^ ComponentCommonName {
    String^ get ();
}
abstract ComponentCommonName : string with get
abstract ComponentCommonName : string with get

Property Value

Type: Online String
See Also
IApplicationComponent Interface
IApplicationComponent Members
NFX.ApplicationModel Namespace


IApplicationComponent.ComponentDirector Property

IApplicationComponent ComponentDirector Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns a reference to an object that this app component services/operates under, or null

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object ComponentDirector { get; }
Object ComponentDirector { get; }
ReadOnly Property ComponentDirector As Object
    Get
ReadOnly Property ComponentDirector As Object
    Get
property Object^ ComponentDirector {
    Object^ get ();
}
property Object^ ComponentDirector {
    Object^ get ();
}
abstract ComponentDirector : Object with get
abstract ComponentDirector : Object with get

Property Value

Type: Online Object
See Also
IApplicationComponent Interface
IApplicationComponent Members
NFX.ApplicationModel Namespace


IApplicationComponent.ComponentSID Property

IApplicationComponent ComponentSID Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns process/instance unique app component system id

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ulong ComponentSID { get; }
ulong ComponentSID { get; }
ReadOnly Property ComponentSID As ULong
    Get
ReadOnly Property ComponentSID As ULong
    Get
property unsigned long long ComponentSID {
    unsigned long long get ();
}
property unsigned long long ComponentSID {
    unsigned long long get ();
}
abstract ComponentSID : uint64 with get
abstract ComponentSID : uint64 with get

Property Value

Type: Online UInt64
See Also
IApplicationComponent Interface
IApplicationComponent Members
NFX.ApplicationModel Namespace


IApplicationFinishNotifiable Interface

IApplicationFinishNotifiable Interface NFX Class Library

Represents an entity that can get notified about application finish

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IApplicationFinishNotifiable : INamed
public interface IApplicationFinishNotifiable : INamed
Public Interface IApplicationFinishNotifiable
    Inherits INamed
Public Interface IApplicationFinishNotifiable
    Inherits INamed
public interface class IApplicationFinishNotifiable : INamed
public interface class IApplicationFinishNotifiable : INamed
type IApplicationFinishNotifiable =
    interface
        interface INamed
    end
type IApplicationFinishNotifiable =
    interface
        interface INamed
    end
See Also
IApplicationFinishNotifiable Members
NFX.ApplicationModel Namespace


IApplicationFinishNotifiable Members

IApplicationFinishNotifiable Members NFX Class Library

The IApplicationFinishNotifiable type exposes the following members.
Methods
 | Name | Description
Public method | ApplicationFinishAfterCleanup |
Public method | ApplicationFinishBeforeCleanup |
Back to Top
Properties
 | Name | Description
Public property | Name | (Inherited from INamed.)
Back to Top
See Also
IApplicationFinishNotifiable Interface
NFX.ApplicationModel Namespace


IApplicationFinishNotifiable Methods

IApplicationFinishNotifiable Methods NFX Class Library

The IApplicationFinishNotifiable type exposes the following members.
Methods
 | Name | Description
Public method | ApplicationFinishAfterCleanup |
Public method | ApplicationFinishBeforeCleanup |
Back to Top
See Also
IApplicationFinishNotifiable Interface
NFX.ApplicationModel Namespace


IApplicationFinishNotifiable.ApplicationFinishAfterCleanup Method

IApplicationFinishNotifiable ApplicationFinishAfterCleanup Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ApplicationFinishAfterCleanup(
    IApplication application
)
void ApplicationFinishAfterCleanup(
    IApplication application
)
Sub ApplicationFinishAfterCleanup (
    application As IApplication
)
Sub ApplicationFinishAfterCleanup (
    application As IApplication
)
void ApplicationFinishAfterCleanup(
    IApplication^ application
)
void ApplicationFinishAfterCleanup(
    IApplication^ application
)
abstract ApplicationFinishAfterCleanup :
        application : IApplication -> unit
abstract ApplicationFinishAfterCleanup :
        application : IApplication -> unit

Parameters

application
Type: NFX.ApplicationModel IApplication
See Also
IApplicationFinishNotifiable Interface
IApplicationFinishNotifiable Members
NFX.ApplicationModel Namespace


IApplicationFinishNotifiable.ApplicationFinishBeforeCleanup Method

IApplicationFinishNotifiable ApplicationFinishBeforeCleanup Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ApplicationFinishBeforeCleanup(
    IApplication application
)
void ApplicationFinishBeforeCleanup(
    IApplication application
)
Sub ApplicationFinishBeforeCleanup (
    application As IApplication
)
Sub ApplicationFinishBeforeCleanup (
    application As IApplication
)
void ApplicationFinishBeforeCleanup(
    IApplication^ application
)
void ApplicationFinishBeforeCleanup(
    IApplication^ application
)
abstract ApplicationFinishBeforeCleanup :
        application : IApplication -> unit
abstract ApplicationFinishBeforeCleanup :
        application : IApplication -> unit

Parameters

application
Type: NFX.ApplicationModel IApplication
See Also
IApplicationFinishNotifiable Interface
IApplicationFinishNotifiable Members
NFX.ApplicationModel Namespace


IApplicationFinishNotifiable Properties

IApplicationFinishNotifiable Properties NFX Class Library

The IApplicationFinishNotifiable type exposes the following members.
Properties
 | Name | Description
Public property | Name | (Inherited from INamed.)
Back to Top
See Also
IApplicationFinishNotifiable Interface
NFX.ApplicationModel Namespace


IApplicationStarter Interface

IApplicationStarter Interface NFX Class Library

Represents an entity that performs work on application start. This entity must be either invoked directly or declared in config file under "starters" section

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IApplicationStarter : IConfigurable,
    INamed
public interface IApplicationStarter : IConfigurable,
    INamed
Public Interface IApplicationStarter
    Inherits IConfigurable, INamed
Public Interface IApplicationStarter
    Inherits IConfigurable, INamed
public interface class IApplicationStarter : IConfigurable,
    INamed
public interface class IApplicationStarter : IConfigurable,
    INamed
type IApplicationStarter =
    interface
        interface IConfigurable
        interface INamed
    end
type IApplicationStarter =
    interface
        interface IConfigurable
        interface INamed
    end
See Also
IApplicationStarter Members
NFX.ApplicationModel Namespace


IApplicationStarter Members

IApplicationStarter Members NFX Class Library

The IApplicationStarter type exposes the following members.
Methods
 | Name | Description
Public method | ApplicationStartAfterInit |
Public method | ApplicationStartBeforeInit |
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationStartBreakOnException | Indicates whether an exception that leaks from starter method invocation should break the application start, or just get logged
Public property | Name | (Inherited from INamed.)
Back to Top
See Also
IApplicationStarter Interface
NFX.ApplicationModel Namespace


IApplicationStarter Methods

IApplicationStarter Methods NFX Class Library

The IApplicationStarter type exposes the following members.
Methods
 | Name | Description
Public method | ApplicationStartAfterInit |
Public method | ApplicationStartBeforeInit |
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Back to Top
See Also
IApplicationStarter Interface
NFX.ApplicationModel Namespace


IApplicationStarter.ApplicationStartAfterInit Method

IApplicationStarter ApplicationStartAfterInit Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ApplicationStartAfterInit(
    IApplication application
)
void ApplicationStartAfterInit(
    IApplication application
)
Sub ApplicationStartAfterInit (
    application As IApplication
)
Sub ApplicationStartAfterInit (
    application As IApplication
)
void ApplicationStartAfterInit(
    IApplication^ application
)
void ApplicationStartAfterInit(
    IApplication^ application
)
abstract ApplicationStartAfterInit :
        application : IApplication -> unit
abstract ApplicationStartAfterInit :
        application : IApplication -> unit

Parameters

application
Type: NFX.ApplicationModel IApplication
See Also
IApplicationStarter Interface
IApplicationStarter Members
NFX.ApplicationModel Namespace


IApplicationStarter.ApplicationStartBeforeInit Method

IApplicationStarter ApplicationStartBeforeInit Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ApplicationStartBeforeInit(
    IApplication application
)
void ApplicationStartBeforeInit(
    IApplication application
)
Sub ApplicationStartBeforeInit (
    application As IApplication
)
Sub ApplicationStartBeforeInit (
    application As IApplication
)
void ApplicationStartBeforeInit(
    IApplication^ application
)
void ApplicationStartBeforeInit(
    IApplication^ application
)
abstract ApplicationStartBeforeInit :
        application : IApplication -> unit
abstract ApplicationStartBeforeInit :
        application : IApplication -> unit

Parameters

application
Type: NFX.ApplicationModel IApplication
See Also
IApplicationStarter Interface
IApplicationStarter Members
NFX.ApplicationModel Namespace


IApplicationStarter Properties

IApplicationStarter Properties NFX Class Library

The IApplicationStarter type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationStartBreakOnException | Indicates whether an exception that leaks from starter method invocation should break the application start, or just get logged
Public property | Name | (Inherited from INamed.)
Back to Top
See Also
IApplicationStarter Interface
NFX.ApplicationModel Namespace


IApplicationStarter.ApplicationStartBreakOnException Property

IApplicationStarter ApplicationStartBreakOnException Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Indicates whether an exception that leaks from starter method invocation should break the application start, or just get logged

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool ApplicationStartBreakOnException { get; }
bool ApplicationStartBreakOnException { get; }
ReadOnly Property ApplicationStartBreakOnException As Boolean
    Get
ReadOnly Property ApplicationStartBreakOnException As Boolean
    Get
property bool ApplicationStartBreakOnException {
    bool get ();
}
property bool ApplicationStartBreakOnException {
    bool get ();
}
abstract ApplicationStartBreakOnException : bool with get
abstract ApplicationStartBreakOnException : bool with get

Property Value

Type: Online Boolean
See Also
IApplicationStarter Interface
IApplicationStarter Members
NFX.ApplicationModel Namespace


ISession Interface

ISession Interface NFX Class Library

Describes user session

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ISession : IEndableInstance
public interface ISession : IEndableInstance
Public Interface ISession
    Inherits IEndableInstance
Public Interface ISession
    Inherits IEndableInstance
public interface class ISession : IEndableInstance
public interface class ISession : IEndableInstance
type ISession =
    interface
        interface IEndableInstance
    end
type ISession =
    interface
        interface IEndableInstance
    end
See Also
ISession Members
NFX.ApplicationModel Namespace


ISession Members

ISession Members NFX Class Library

The ISession type exposes the following members.
Methods
 | Name | Description
Public method | Acquire | Acquires session for use
Public method | End | Requests container that hosts.runs this entity to end its instance (Inherited from IEndableInstance.)
Public method | HasJustLoggedIn | Sets IsJustLoggedIn to true to indicate that user has supplied credentials/got checked via security manager. The caller of this method is implementation-specific and depends on what is considered to be "proof of users' identity"
Public method | RegenerateID | Generates new GUID and stores it in ID storing old ID value in OldID property which is not serializable. The implementations may elect to re-stow the existing session under the new ID. This method is usefull for security, i.e. when user logs-in we may want to re-generate ID
Public method | Release | Releases session after use
Back to Top
Properties
 | Name | Description
Public property | ID | Gets unique session identifier
Public property | IsEnded | Indicates whether this instance was requested to be ended and will get destoyed by the hosting container (Inherited from IEndableInstance.)
Public property | IsJustLoggedIn | Indicates that user login happened in current request processing cycle. This flag is useful for long term token assignment on release
Public property | IsNew | Indicates that session object was just created with current request processing cycle
Public property | Item | Shortcut to this.Items.TryGetValue(...). Returns null if key is not found
Public property | Items | References item dictionary that may be used to persist object graphs per session
Public property | LanguageISOCode | Returns user's language preference or null
Public property | LastLoginType | Returns last login type
Public property | LastLoginUTC | Returns the UTC DateTime of the last login/when HasJustLoggedIn() was called for the last time within the lifetime of this session object or NULL
Public property | OldID | When this parameter is not null then RegenerateID() was called and session provider may need to re-stow session object under a new ID
Public property | User | References a user this session is for
Back to Top
See Also
ISession Interface
NFX.ApplicationModel Namespace


ISession Methods

ISession Methods NFX Class Library

The ISession type exposes the following members.
Methods
 | Name | Description
Public method | Acquire | Acquires session for use
Public method | End | Requests container that hosts.runs this entity to end its instance (Inherited from IEndableInstance.)
Public method | HasJustLoggedIn | Sets IsJustLoggedIn to true to indicate that user has supplied credentials/got checked via security manager. The caller of this method is implementation-specific and depends on what is considered to be "proof of users' identity"
Public method | RegenerateID | Generates new GUID and stores it in ID storing old ID value in OldID property which is not serializable. The implementations may elect to re-stow the existing session under the new ID. This method is usefull for security, i.e. when user logs-in we may want to re-generate ID
Public method | Release | Releases session after use
Back to Top
See Also
ISession Interface
NFX.ApplicationModel Namespace


ISession.Acquire Method

ISession Acquire Method NFX Class Library

Acquires session for use

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Acquire()
void Acquire()
Sub Acquire
Sub Acquire
void Acquire()
void Acquire()
abstract Acquire : unit -> unit
abstract Acquire : unit -> unit
See Also
ISession Interface
ISession Members
NFX.ApplicationModel Namespace


ISession.HasJustLoggedIn Method

ISession HasJustLoggedIn Method NFX Class Library

Sets IsJustLoggedIn to true to indicate that user has supplied credentials/got checked via security manager. The caller of this method is implementation-specific and depends on what is considered to be "proof of users' identity"

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void HasJustLoggedIn(
    SessionLoginType loginType
)
void HasJustLoggedIn(
    SessionLoginType loginType
)
Sub HasJustLoggedIn (
    loginType As SessionLoginType
)
Sub HasJustLoggedIn (
    loginType As SessionLoginType
)
void HasJustLoggedIn(
    SessionLoginType loginType
)
void HasJustLoggedIn(
    SessionLoginType loginType
)
abstract HasJustLoggedIn :
        loginType : SessionLoginType -> unit
abstract HasJustLoggedIn :
        loginType : SessionLoginType -> unit

Parameters

loginType
Type: NFX.ApplicationModel SessionLoginType
See Also
ISession Interface
ISession Members
NFX.ApplicationModel Namespace


ISession.RegenerateID Method

ISession RegenerateID Method NFX Class Library

Generates new GUID and stores it in ID storing old ID value in OldID property which is not serializable. The implementations may elect to re-stow the existing session under the new ID. This method is usefull for security, i.e. when user logs-in we may want to re-generate ID

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void RegenerateID()
void RegenerateID()
Sub RegenerateID
Sub RegenerateID
void RegenerateID()
void RegenerateID()
abstract RegenerateID : unit -> unit
abstract RegenerateID : unit -> unit
See Also
ISession Interface
ISession Members
NFX.ApplicationModel Namespace


ISession.Release Method

ISession Release Method NFX Class Library

Releases session after use

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Release()
void Release()
Sub Release
Sub Release
void Release()
void Release()
abstract Release : unit -> unit
abstract Release : unit -> unit
See Also
ISession Interface
ISession Members
NFX.ApplicationModel Namespace


ISession Properties

ISession Properties NFX Class Library

The ISession type exposes the following members.
Properties
 | Name | Description
Public property | ID | Gets unique session identifier
Public property | IsEnded | Indicates whether this instance was requested to be ended and will get destoyed by the hosting container (Inherited from IEndableInstance.)
Public property | IsJustLoggedIn | Indicates that user login happened in current request processing cycle. This flag is useful for long term token assignment on release
Public property | IsNew | Indicates that session object was just created with current request processing cycle
Public property | Item | Shortcut to this.Items.TryGetValue(...). Returns null if key is not found
Public property | Items | References item dictionary that may be used to persist object graphs per session
Public property | LanguageISOCode | Returns user's language preference or null
Public property | LastLoginType | Returns last login type
Public property | LastLoginUTC | Returns the UTC DateTime of the last login/when HasJustLoggedIn() was called for the last time within the lifetime of this session object or NULL
Public property | OldID | When this parameter is not null then RegenerateID() was called and session provider may need to re-stow session object under a new ID
Public property | User | References a user this session is for
Back to Top
See Also
ISession Interface
NFX.ApplicationModel Namespace


ISession.ID Property

ISession ID Property NFX Class Library

Gets unique session identifier

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Guid ID { get; }
Guid ID { get; }
ReadOnly Property ID As Guid
    Get
ReadOnly Property ID As Guid
    Get
property Guid ID {
    Guid get ();
}
property Guid ID {
    Guid get ();
}
abstract ID : Guid with get
abstract ID : Guid with get

Property Value

Type: Online Guid
See Also
ISession Interface
ISession Members
NFX.ApplicationModel Namespace


ISession.IsJustLoggedIn Property

ISession IsJustLoggedIn Property NFX Class Library

Indicates that user login happened in current request processing cycle. This flag is useful for long term token assignment on release

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsJustLoggedIn { get; }
bool IsJustLoggedIn { get; }
ReadOnly Property IsJustLoggedIn As Boolean
    Get
ReadOnly Property IsJustLoggedIn As Boolean
    Get
property bool IsJustLoggedIn {
    bool get ();
}
property bool IsJustLoggedIn {
    bool get ();
}
abstract IsJustLoggedIn : bool with get
abstract IsJustLoggedIn : bool with get

Property Value

Type: Online Boolean
See Also
ISession Interface
ISession Members
NFX.ApplicationModel Namespace


ISession.IsNew Property

ISession IsNew Property NFX Class Library

Indicates that session object was just created with current request processing cycle

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsNew { get; }
bool IsNew { get; }
ReadOnly Property IsNew As Boolean
    Get
ReadOnly Property IsNew As Boolean
    Get
property bool IsNew {
    bool get ();
}
property bool IsNew {
    bool get ();
}
abstract IsNew : bool with get
abstract IsNew : bool with get

Property Value

Type: Online Boolean
See Also
ISession Interface
ISession Members
NFX.ApplicationModel Namespace


ISession.Item Property

ISession Item Property NFX Class Library

Shortcut to this.Items.TryGetValue(...). Returns null if key is not found

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object this[
    Object key
] { get; set; }
Object this[
    Object key
] { get; set; }
Default Property Item (
    key As Object
) As Object
    Get
    Set
Default Property Item (
    key As Object
) As Object
    Get
    Set
property Object^ default[Object^ key] {
    Object^ get (Object^ key);
    void set (Object^ key, Object^ value);
}
property Object^ default[Object^ key] {
    Object^ get (Object^ key);
    void set (Object^ key, Object^ value);
}
abstract Item : Object with get, set
abstract Item : Object with get, set

Parameters

key
Type: Online System Object

Property Value

Type: Online Object
See Also
ISession Interface
ISession Members
NFX.ApplicationModel Namespace


ISession.Items Property

ISession Items Property NFX Class Library

References item dictionary that may be used to persist object graphs per session

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IDictionary<Object, Object> Items { get; }
IDictionary<Object, Object> Items { get; }
ReadOnly Property Items As IDictionary(Of Object, Object)
    Get
ReadOnly Property Items As IDictionary(Of Object, Object)
    Get
property IDictionary<Object^, Object^>^ Items {
    IDictionary<Object^, Object^>^ get ();
}
property IDictionary<Object^, Object^>^ Items {
    IDictionary<Object^, Object^>^ get ();
}
abstract Items : IDictionary<Object, Object> with get
abstract Items : IDictionary<Object, Object> with get

Property Value

Type: Online IDictionary Online Object, Online Object
See Also
ISession Interface
ISession Members
NFX.ApplicationModel Namespace


ISession.LanguageISOCode Property

ISession LanguageISOCode Property NFX Class Library

Returns user's language preference or null

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string LanguageISOCode { get; }
string LanguageISOCode { get; }
ReadOnly Property LanguageISOCode As String
    Get
ReadOnly Property LanguageISOCode As String
    Get
property String^ LanguageISOCode {
    String^ get ();
}
property String^ LanguageISOCode {
    String^ get ();
}
abstract LanguageISOCode : string with get
abstract LanguageISOCode : string with get

Property Value

Type: Online String
See Also
ISession Interface
ISession Members
NFX.ApplicationModel Namespace


ISession.LastLoginType Property

ISession LastLoginType Property NFX Class Library

Returns last login type

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
SessionLoginType LastLoginType { get; }
SessionLoginType LastLoginType { get; }
ReadOnly Property LastLoginType As SessionLoginType
    Get
ReadOnly Property LastLoginType As SessionLoginType
    Get
property SessionLoginType LastLoginType {
    SessionLoginType get ();
}
property SessionLoginType LastLoginType {
    SessionLoginType get ();
}
abstract LastLoginType : SessionLoginType with get
abstract LastLoginType : SessionLoginType with get

Property Value

Type: SessionLoginType
See Also
ISession Interface
ISession Members
NFX.ApplicationModel Namespace


ISession.LastLoginUTC Property

ISession LastLoginUTC Property NFX Class Library

Returns the UTC DateTime of the last login/when HasJustLoggedIn() was called for the last time within the lifetime of this session object or NULL

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Nullable<DateTime> LastLoginUTC { get; }
Nullable<DateTime> LastLoginUTC { get; }
ReadOnly Property LastLoginUTC As Nullable(Of DateTime)
    Get
ReadOnly Property LastLoginUTC As Nullable(Of DateTime)
    Get
property Nullable<DateTime> LastLoginUTC {
    Nullable<DateTime> get ();
}
property Nullable<DateTime> LastLoginUTC {
    Nullable<DateTime> get ();
}
abstract LastLoginUTC : Nullable<DateTime> with get
abstract LastLoginUTC : Nullable<DateTime> with get

Property Value

Type: Online Nullable Online DateTime
See Also
ISession Interface
ISession Members
NFX.ApplicationModel Namespace


ISession.OldID Property

ISession OldID Property NFX Class Library

When this parameter is not null then RegenerateID() was called and session provider may need to re-stow session object under a new ID

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Nullable<Guid> OldID { get; }
Nullable<Guid> OldID { get; }
ReadOnly Property OldID As Nullable(Of Guid)
    Get
ReadOnly Property OldID As Nullable(Of Guid)
    Get
property Nullable<Guid> OldID {
    Nullable<Guid> get ();
}
property Nullable<Guid> OldID {
    Nullable<Guid> get ();
}
abstract OldID : Nullable<Guid> with get
abstract OldID : Nullable<Guid> with get

Property Value

Type: Online Nullable Online Guid
See Also
ISession Interface
ISession Members
NFX.ApplicationModel Namespace


ISession.User Property

ISession User Property NFX Class Library

References a user this session is for

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
User User { get; set; }
User User { get; set; }
Property User As User
    Get
    Set
Property User As User
    Get
    Set
property User^ User {
    User^ get ();
    void set (User^ value);
}
property User^ User {
    User^ get ();
    void set (User^ value);
}
abstract User : User with get, set
abstract User : User with get, set

Property Value

Type: User
See Also
ISession Interface
ISession Members
NFX.ApplicationModel Namespace


NOPApplication Class

NOPApplication Class NFX Class Library

Represents an application that consists of pure-nop providers, consequently this application does not log, does not store data and does not do anything else still satisfying its contract
Inheritance Hierarchy
Online System Object
NFX.ApplicationModel NOPApplication

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NOPApplication : IApplication,
    INamed, ILocalizedTimeProvider
public class NOPApplication : IApplication,
    INamed, ILocalizedTimeProvider
Public Class NOPApplication
    Implements IApplication, INamed, ILocalizedTimeProvider
Public Class NOPApplication
    Implements IApplication, INamed, ILocalizedTimeProvider
public ref class NOPApplication : IApplication,
    INamed, ILocalizedTimeProvider
public ref class NOPApplication : IApplication,
    INamed, ILocalizedTimeProvider
type NOPApplication =
    class
        interface IApplication
        interface INamed
        interface ILocalizedTimeProvider
    end
type NOPApplication =
    class
        interface IApplication
        interface INamed
        interface ILocalizedTimeProvider
    end
See Also
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication Members

NOPApplication Members NFX Class Library

The NOPApplication type exposes the following members.
Constructors
 | Name | Description
Protected method | NOPApplication | Initializes a new instance of the NOPApplication class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime |
Public method | MakeNewSessionInstance |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NotifyAllConfigSettingsAboutChange |
Public method | RegisterAppFinishNotifiable |
Public method | RegisterConfigSettings |
Public method | Stop |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime |
Public method | UnregisterAppFinishNotifiable |
Public method | UnregisterConfigSettings |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Configuration |
Back to Top
Properties
 | Name | Description
Public property | Active |
Public property | ConfigRoot |
Public property | DataStore |
Public property | EventTimer |
Public property | Glue |
 | Instance | Returns a singlelton instance of the NOPApplication
Public property | InstanceID |
Public property | Instrumentation |
Public property | IsUnitTest |
Public property | LocalizedTime |
Public property | Log |
Public property | Name |
Public property | ObjectStore |
Public property | SecurityManager |
Public property | ShutdownStarted |
Public property | StartTime |
Public property | Stopping |
Public property | Throttling |
Public property | TimeLocation |
Public property | TimeSource |
Back to Top
See Also
NOPApplication Class
NFX.ApplicationModel Namespace


NOPApplication Constructor

NOPApplication Constructor NFX Class Library

Initializes a new instance of the NOPApplication class

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected NOPApplication()
protected NOPApplication()
Protected Sub New
Protected Sub New
protected:
NOPApplication()
protected:
NOPApplication()
new : unit -> NOPApplication
new : unit -> NOPApplication
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication Fields

NOPApplication Fields NFX Class Library

The NOPApplication type exposes the following members.
Fields
 | Name | Description
Protected field | m_Configuration |
Back to Top
See Also
NOPApplication Class
NFX.ApplicationModel Namespace


NOPApplication.m_Configuration Field

NOPApplication m_Configuration Field NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MemoryConfiguration m_Configuration
protected MemoryConfiguration m_Configuration
Protected m_Configuration As MemoryConfiguration
Protected m_Configuration As MemoryConfiguration
protected:
MemoryConfiguration^ m_Configuration
protected:
MemoryConfiguration^ m_Configuration
val mutable m_Configuration: MemoryConfiguration
val mutable m_Configuration: MemoryConfiguration

Field Value

Type: MemoryConfiguration
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication Methods

NOPApplication Methods NFX Class Library

The NOPApplication type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime |
Public method | MakeNewSessionInstance |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NotifyAllConfigSettingsAboutChange |
Public method | RegisterAppFinishNotifiable |
Public method | RegisterConfigSettings |
Public method | Stop |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime |
Public method | UnregisterAppFinishNotifiable |
Public method | UnregisterConfigSettings |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NOPApplication Class
NFX.ApplicationModel Namespace


NOPApplication.LocalizedTimeToUniversalTime Method

NOPApplication LocalizedTimeToUniversalTime Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
public DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
Public Function LocalizedTimeToUniversalTime (
    local As DateTime
) As DateTime
Public Function LocalizedTimeToUniversalTime (
    local As DateTime
) As DateTime
public:
virtual DateTime LocalizedTimeToUniversalTime(
    DateTime local
) sealed
public:
virtual DateTime LocalizedTimeToUniversalTime(
    DateTime local
) sealed
abstract LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
override LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
abstract LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
override LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime

Parameters

local
Type: Online System DateTime

Return Value

Type: Online DateTime

Implements

ILocalizedTimeProvider LocalizedTimeToUniversalTime(DateTime)
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication.MakeNewSessionInstance Method

NOPApplication MakeNewSessionInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ISession MakeNewSessionInstance(
    Guid sessionID,
    User user = null
)
public ISession MakeNewSessionInstance(
    Guid sessionID,
    User user = null
)
Public Function MakeNewSessionInstance (
    sessionID As Guid,
    Optional user As User = Nothing
) As ISession
Public Function MakeNewSessionInstance (
    sessionID As Guid,
    Optional user As User = Nothing
) As ISession
public:
virtual ISession^ MakeNewSessionInstance(
    Guid sessionID,
    User^ user = nullptr
) sealed
public:
virtual ISession^ MakeNewSessionInstance(
    Guid sessionID,
    User^ user = nullptr
) sealed
abstract MakeNewSessionInstance :
        sessionID : Guid *
        ?user : User
(* Defaults:
        let _user = defaultArg user null
*)
-> ISession
override MakeNewSessionInstance :
        sessionID : Guid *
        ?user : User
(* Defaults:
        let _user = defaultArg user null
*)
-> ISession
abstract MakeNewSessionInstance :
        sessionID : Guid *
        ?user : User
(* Defaults:
        let _user = defaultArg user null
*)
-> ISession
override MakeNewSessionInstance :
        sessionID : Guid *
        ?user : User
(* Defaults:
        let _user = defaultArg user null
*)
-> ISession

Parameters

sessionID
Type: Online System Guid
user (Optional)
Type: NFX.Security User

Return Value

Type: ISession

Implements

IApplication MakeNewSessionInstance(Guid, User)
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication.NotifyAllConfigSettingsAboutChange Method

NOPApplication NotifyAllConfigSettingsAboutChange Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void NotifyAllConfigSettingsAboutChange()
public void NotifyAllConfigSettingsAboutChange()
Public Sub NotifyAllConfigSettingsAboutChange
Public Sub NotifyAllConfigSettingsAboutChange
public:
virtual void NotifyAllConfigSettingsAboutChange() sealed
public:
virtual void NotifyAllConfigSettingsAboutChange() sealed
abstract NotifyAllConfigSettingsAboutChange : unit -> unit
override NotifyAllConfigSettingsAboutChange : unit -> unit
abstract NotifyAllConfigSettingsAboutChange : unit -> unit
override NotifyAllConfigSettingsAboutChange : unit -> unit

Implements

IApplication NotifyAllConfigSettingsAboutChange
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication.RegisterAppFinishNotifiable Method

NOPApplication RegisterAppFinishNotifiable Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool RegisterAppFinishNotifiable(
    IApplicationFinishNotifiable notifiable
)
public bool RegisterAppFinishNotifiable(
    IApplicationFinishNotifiable notifiable
)
Public Function RegisterAppFinishNotifiable (
    notifiable As IApplicationFinishNotifiable
) As Boolean
Public Function RegisterAppFinishNotifiable (
    notifiable As IApplicationFinishNotifiable
) As Boolean
public:
virtual bool RegisterAppFinishNotifiable(
    IApplicationFinishNotifiable^ notifiable
) sealed
public:
virtual bool RegisterAppFinishNotifiable(
    IApplicationFinishNotifiable^ notifiable
) sealed
abstract RegisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool
override RegisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool
abstract RegisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool
override RegisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool

Parameters

notifiable
Type: NFX.ApplicationModel IApplicationFinishNotifiable

Return Value

Type: Online Boolean

Implements

IApplication RegisterAppFinishNotifiable(IApplicationFinishNotifiable)
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication.RegisterConfigSettings Method

NOPApplication RegisterConfigSettings Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool RegisterConfigSettings(
    IConfigSettings settings
)
public bool RegisterConfigSettings(
    IConfigSettings settings
)
Public Function RegisterConfigSettings (
    settings As IConfigSettings
) As Boolean
Public Function RegisterConfigSettings (
    settings As IConfigSettings
) As Boolean
public:
virtual bool RegisterConfigSettings(
    IConfigSettings^ settings
) sealed
public:
virtual bool RegisterConfigSettings(
    IConfigSettings^ settings
) sealed
abstract RegisterConfigSettings :
        settings : IConfigSettings -> bool
override RegisterConfigSettings :
        settings : IConfigSettings -> bool
abstract RegisterConfigSettings :
        settings : IConfigSettings -> bool
override RegisterConfigSettings :
        settings : IConfigSettings -> bool

Parameters

settings
Type: NFX.Environment IConfigSettings

Return Value

Type: Online Boolean

Implements

IApplication RegisterConfigSettings(IConfigSettings)
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication.Stop Method

NOPApplication Stop Method NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Stop()
public void Stop()
Public Sub Stop
Public Sub Stop
public:
virtual void Stop() sealed
public:
virtual void Stop() sealed
abstract Stop : unit -> unit
override Stop : unit -> unit
abstract Stop : unit -> unit
override Stop : unit -> unit

Implements

IApplication Stop
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication.UniversalTimeToLocalizedTime Method

NOPApplication UniversalTimeToLocalizedTime Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
public DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
Public Function UniversalTimeToLocalizedTime (
    utc As DateTime
) As DateTime
Public Function UniversalTimeToLocalizedTime (
    utc As DateTime
) As DateTime
public:
virtual DateTime UniversalTimeToLocalizedTime(
    DateTime utc
) sealed
public:
virtual DateTime UniversalTimeToLocalizedTime(
    DateTime utc
) sealed
abstract UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
override UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
abstract UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
override UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime

Parameters

utc
Type: Online System DateTime

Return Value

Type: Online DateTime

Implements

ILocalizedTimeProvider UniversalTimeToLocalizedTime(DateTime)
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication.UnregisterAppFinishNotifiable Method

NOPApplication UnregisterAppFinishNotifiable Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool UnregisterAppFinishNotifiable(
    IApplicationFinishNotifiable notifiable
)
public bool UnregisterAppFinishNotifiable(
    IApplicationFinishNotifiable notifiable
)
Public Function UnregisterAppFinishNotifiable (
    notifiable As IApplicationFinishNotifiable
) As Boolean
Public Function UnregisterAppFinishNotifiable (
    notifiable As IApplicationFinishNotifiable
) As Boolean
public:
virtual bool UnregisterAppFinishNotifiable(
    IApplicationFinishNotifiable^ notifiable
) sealed
public:
virtual bool UnregisterAppFinishNotifiable(
    IApplicationFinishNotifiable^ notifiable
) sealed
abstract UnregisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool
override UnregisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool
abstract UnregisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool
override UnregisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool

Parameters

notifiable
Type: NFX.ApplicationModel IApplicationFinishNotifiable

Return Value

Type: Online Boolean

Implements

IApplication UnregisterAppFinishNotifiable(IApplicationFinishNotifiable)
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication.UnregisterConfigSettings Method

NOPApplication UnregisterConfigSettings Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool UnregisterConfigSettings(
    IConfigSettings settings
)
public bool UnregisterConfigSettings(
    IConfigSettings settings
)
Public Function UnregisterConfigSettings (
    settings As IConfigSettings
) As Boolean
Public Function UnregisterConfigSettings (
    settings As IConfigSettings
) As Boolean
public:
virtual bool UnregisterConfigSettings(
    IConfigSettings^ settings
) sealed
public:
virtual bool UnregisterConfigSettings(
    IConfigSettings^ settings
) sealed
abstract UnregisterConfigSettings :
        settings : IConfigSettings -> bool
override UnregisterConfigSettings :
        settings : IConfigSettings -> bool
abstract UnregisterConfigSettings :
        settings : IConfigSettings -> bool
override UnregisterConfigSettings :
        settings : IConfigSettings -> bool

Parameters

settings
Type: NFX.Environment IConfigSettings

Return Value

Type: Online Boolean

Implements

IApplication UnregisterConfigSettings(IConfigSettings)
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication Properties

NOPApplication Properties NFX Class Library

The NOPApplication type exposes the following members.
Properties
 | Name | Description
Public property | Active |
Public property | ConfigRoot |
Public property | DataStore |
Public property | EventTimer |
Public property | Glue |
 | Instance | Returns a singlelton instance of the NOPApplication
Public property | InstanceID |
Public property | Instrumentation |
Public property | IsUnitTest |
Public property | LocalizedTime |
Public property | Log |
Public property | Name |
Public property | ObjectStore |
Public property | SecurityManager |
Public property | ShutdownStarted |
Public property | StartTime |
Public property | Stopping |
Public property | Throttling |
Public property | TimeLocation |
Public property | TimeSource |
Back to Top
See Also
NOPApplication Class
NFX.ApplicationModel Namespace


NOPApplication.Active Property

NOPApplication Active Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Active { get; }
public bool Active { get; }
Public ReadOnly Property Active As Boolean
    Get
Public ReadOnly Property Active As Boolean
    Get
public:
virtual property bool Active {
    bool get () sealed;
}
public:
virtual property bool Active {
    bool get () sealed;
}
abstract Active : bool with get
override Active : bool with get
abstract Active : bool with get
override Active : bool with get

Property Value

Type: Online Boolean

Implements

IApplication Active
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication.ConfigRoot Property

NOPApplication ConfigRoot Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigSectionNode ConfigRoot { get; }
public ConfigSectionNode ConfigRoot { get; }
Public ReadOnly Property ConfigRoot As ConfigSectionNode
    Get
Public ReadOnly Property ConfigRoot As ConfigSectionNode
    Get
public:
virtual property ConfigSectionNode^ ConfigRoot {
    ConfigSectionNode^ get () sealed;
}
public:
virtual property ConfigSectionNode^ ConfigRoot {
    ConfigSectionNode^ get () sealed;
}
abstract ConfigRoot : ConfigSectionNode with get
override ConfigRoot : ConfigSectionNode with get
abstract ConfigRoot : ConfigSectionNode with get
override ConfigRoot : ConfigSectionNode with get

Property Value

Type: ConfigSectionNode

Implements

IApplication ConfigRoot
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication.DataStore Property

NOPApplication DataStore Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDataStore DataStore { get; }
public IDataStore DataStore { get; }
Public ReadOnly Property DataStore As IDataStore
    Get
Public ReadOnly Property DataStore As IDataStore
    Get
public:
virtual property IDataStore^ DataStore {
    IDataStore^ get () sealed;
}
public:
virtual property IDataStore^ DataStore {
    IDataStore^ get () sealed;
}
abstract DataStore : IDataStore with get
override DataStore : IDataStore with get
abstract DataStore : IDataStore with get
override DataStore : IDataStore with get

Property Value

Type: IDataStore

Implements

IApplication DataStore
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication.EventTimer Property

NOPApplication EventTimer Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEventTimer EventTimer { get; }
public IEventTimer EventTimer { get; }
Public ReadOnly Property EventTimer As IEventTimer
    Get
Public ReadOnly Property EventTimer As IEventTimer
    Get
public:
virtual property IEventTimer^ EventTimer {
    IEventTimer^ get () sealed;
}
public:
virtual property IEventTimer^ EventTimer {
    IEventTimer^ get () sealed;
}
abstract EventTimer : IEventTimer with get
override EventTimer : IEventTimer with get
abstract EventTimer : IEventTimer with get
override EventTimer : IEventTimer with get

Property Value

Type: IEventTimer

Implements

IApplication EventTimer
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication.Glue Property

NOPApplication Glue Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IGlue Glue { get; }
public IGlue Glue { get; }
Public ReadOnly Property Glue As IGlue
    Get
Public ReadOnly Property Glue As IGlue
    Get
public:
virtual property IGlue^ Glue {
    IGlue^ get () sealed;
}
public:
virtual property IGlue^ Glue {
    IGlue^ get () sealed;
}
abstract Glue : IGlue with get
override Glue : IGlue with get
abstract Glue : IGlue with get
override Glue : IGlue with get

Property Value

Type: IGlue

Implements

IApplication Glue
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication.Instance Property

NOPApplication Instance Property NFX Class Library

Returns a singlelton instance of the NOPApplication

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NOPApplication Instance { get; }
public static NOPApplication Instance { get; }
Public Shared ReadOnly Property Instance As NOPApplication
    Get
Public Shared ReadOnly Property Instance As NOPApplication
    Get
public:
static property NOPApplication^ Instance {
    NOPApplication^ get ();
}
public:
static property NOPApplication^ Instance {
    NOPApplication^ get ();
}
static member Instance : NOPApplication with get
static member Instance : NOPApplication with get

Property Value

Type: NOPApplication
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication.InstanceID Property

NOPApplication InstanceID Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid InstanceID { get; }
public Guid InstanceID { get; }
Public ReadOnly Property InstanceID As Guid
    Get
Public ReadOnly Property InstanceID As Guid
    Get
public:
virtual property Guid InstanceID {
    Guid get () sealed;
}
public:
virtual property Guid InstanceID {
    Guid get () sealed;
}
abstract InstanceID : Guid with get
override InstanceID : Guid with get
abstract InstanceID : Guid with get
override InstanceID : Guid with get

Property Value

Type: Online Guid

Implements

IApplication InstanceID
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication.Instrumentation Property

NOPApplication Instrumentation Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IInstrumentation Instrumentation { get; }
public IInstrumentation Instrumentation { get; }
Public ReadOnly Property Instrumentation As IInstrumentation
    Get
Public ReadOnly Property Instrumentation As IInstrumentation
    Get
public:
virtual property IInstrumentation^ Instrumentation {
    IInstrumentation^ get () sealed;
}
public:
virtual property IInstrumentation^ Instrumentation {
    IInstrumentation^ get () sealed;
}
abstract Instrumentation : IInstrumentation with get
override Instrumentation : IInstrumentation with get
abstract Instrumentation : IInstrumentation with get
override Instrumentation : IInstrumentation with get

Property Value

Type: IInstrumentation

Implements

IApplication Instrumentation
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication.IsUnitTest Property

NOPApplication IsUnitTest Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsUnitTest { get; }
public bool IsUnitTest { get; }
Public ReadOnly Property IsUnitTest As Boolean
    Get
Public ReadOnly Property IsUnitTest As Boolean
    Get
public:
virtual property bool IsUnitTest {
    bool get () sealed;
}
public:
virtual property bool IsUnitTest {
    bool get () sealed;
}
abstract IsUnitTest : bool with get
override IsUnitTest : bool with get
abstract IsUnitTest : bool with get
override IsUnitTest : bool with get

Property Value

Type: Online Boolean

Implements

IApplication IsUnitTest
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication.LocalizedTime Property

NOPApplication LocalizedTime Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime LocalizedTime { get; }
public DateTime LocalizedTime { get; }
Public ReadOnly Property LocalizedTime As DateTime
    Get
Public ReadOnly Property LocalizedTime As DateTime
    Get
public:
virtual property DateTime LocalizedTime {
    DateTime get () sealed;
}
public:
virtual property DateTime LocalizedTime {
    DateTime get () sealed;
}
abstract LocalizedTime : DateTime with get
override LocalizedTime : DateTime with get
abstract LocalizedTime : DateTime with get
override LocalizedTime : DateTime with get

Property Value

Type: Online DateTime

Implements

ILocalizedTimeProvider LocalizedTime
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication.Log Property

NOPApplication Log Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILog Log { get; }
public ILog Log { get; }
Public ReadOnly Property Log As ILog
    Get
Public ReadOnly Property Log As ILog
    Get
public:
virtual property ILog^ Log {
    ILog^ get () sealed;
}
public:
virtual property ILog^ Log {
    ILog^ get () sealed;
}
abstract Log : ILog with get
override Log : ILog with get
abstract Log : ILog with get
override Log : ILog with get

Property Value

Type: ILog

Implements

IApplication Log
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication.Name Property

NOPApplication Name Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication.ObjectStore Property

NOPApplication ObjectStore Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IObjectStore ObjectStore { get; }
public IObjectStore ObjectStore { get; }
Public ReadOnly Property ObjectStore As IObjectStore
    Get
Public ReadOnly Property ObjectStore As IObjectStore
    Get
public:
virtual property IObjectStore^ ObjectStore {
    IObjectStore^ get () sealed;
}
public:
virtual property IObjectStore^ ObjectStore {
    IObjectStore^ get () sealed;
}
abstract ObjectStore : IObjectStore with get
override ObjectStore : IObjectStore with get
abstract ObjectStore : IObjectStore with get
override ObjectStore : IObjectStore with get

Property Value

Type: IObjectStore

Implements

IApplication ObjectStore
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication.SecurityManager Property

NOPApplication SecurityManager Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ISecurityManager SecurityManager { get; }
public ISecurityManager SecurityManager { get; }
Public ReadOnly Property SecurityManager As ISecurityManager
    Get
Public ReadOnly Property SecurityManager As ISecurityManager
    Get
public:
virtual property ISecurityManager^ SecurityManager {
    ISecurityManager^ get () sealed;
}
public:
virtual property ISecurityManager^ SecurityManager {
    ISecurityManager^ get () sealed;
}
abstract SecurityManager : ISecurityManager with get
override SecurityManager : ISecurityManager with get
abstract SecurityManager : ISecurityManager with get
override SecurityManager : ISecurityManager with get

Property Value

Type: ISecurityManager

Implements

IApplication SecurityManager
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication.ShutdownStarted Property

NOPApplication ShutdownStarted Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ShutdownStarted { get; }
public bool ShutdownStarted { get; }
Public ReadOnly Property ShutdownStarted As Boolean
    Get
Public ReadOnly Property ShutdownStarted As Boolean
    Get
public:
virtual property bool ShutdownStarted {
    bool get () sealed;
}
public:
virtual property bool ShutdownStarted {
    bool get () sealed;
}
abstract ShutdownStarted : bool with get
override ShutdownStarted : bool with get
abstract ShutdownStarted : bool with get
override ShutdownStarted : bool with get

Property Value

Type: Online Boolean

Implements

IApplication ShutdownStarted
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication.StartTime Property

NOPApplication StartTime Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime StartTime { get; }
public DateTime StartTime { get; }
Public ReadOnly Property StartTime As DateTime
    Get
Public ReadOnly Property StartTime As DateTime
    Get
public:
virtual property DateTime StartTime {
    DateTime get () sealed;
}
public:
virtual property DateTime StartTime {
    DateTime get () sealed;
}
abstract StartTime : DateTime with get
override StartTime : DateTime with get
abstract StartTime : DateTime with get
override StartTime : DateTime with get

Property Value

Type: Online DateTime

Implements

IApplication StartTime
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication.Stopping Property

NOPApplication Stopping Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Stopping { get; }
public bool Stopping { get; }
Public ReadOnly Property Stopping As Boolean
    Get
Public ReadOnly Property Stopping As Boolean
    Get
public:
virtual property bool Stopping {
    bool get () sealed;
}
public:
virtual property bool Stopping {
    bool get () sealed;
}
abstract Stopping : bool with get
override Stopping : bool with get
abstract Stopping : bool with get
override Stopping : bool with get

Property Value

Type: Online Boolean

Implements

IApplication Stopping
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication.Throttling Property

NOPApplication Throttling Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IThrottling Throttling { get; }
public IThrottling Throttling { get; }
Public ReadOnly Property Throttling As IThrottling
    Get
Public ReadOnly Property Throttling As IThrottling
    Get
public:
virtual property IThrottling^ Throttling {
    IThrottling^ get () sealed;
}
public:
virtual property IThrottling^ Throttling {
    IThrottling^ get () sealed;
}
abstract Throttling : IThrottling with get
override Throttling : IThrottling with get
abstract Throttling : IThrottling with get
override Throttling : IThrottling with get

Property Value

Type: IThrottling

Implements

IApplication Throttling
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication.TimeLocation Property

NOPApplication TimeLocation Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeLocation TimeLocation { get; }
public TimeLocation TimeLocation { get; }
Public ReadOnly Property TimeLocation As TimeLocation
    Get
Public ReadOnly Property TimeLocation As TimeLocation
    Get
public:
virtual property TimeLocation^ TimeLocation {
    TimeLocation^ get () sealed;
}
public:
virtual property TimeLocation^ TimeLocation {
    TimeLocation^ get () sealed;
}
abstract TimeLocation : TimeLocation with get
override TimeLocation : TimeLocation with get
abstract TimeLocation : TimeLocation with get
override TimeLocation : TimeLocation with get

Property Value

Type: TimeLocation

Implements

ILocalizedTimeProvider TimeLocation
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPApplication.TimeSource Property

NOPApplication TimeSource Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ITimeSource TimeSource { get; }
public ITimeSource TimeSource { get; }
Public ReadOnly Property TimeSource As ITimeSource
    Get
Public ReadOnly Property TimeSource As ITimeSource
    Get
public:
virtual property ITimeSource^ TimeSource {
    ITimeSource^ get () sealed;
}
public:
virtual property ITimeSource^ TimeSource {
    ITimeSource^ get () sealed;
}
abstract TimeSource : ITimeSource with get
override TimeSource : ITimeSource with get
abstract TimeSource : ITimeSource with get
override TimeSource : ITimeSource with get

Property Value

Type: ITimeSource

Implements

IApplication TimeSource
See Also
NOPApplication Class
NOPApplication Members
NFX.ApplicationModel Namespace


NOPSession Class

NOPSession Class NFX Class Library

Represents a session that does nothing and returns fake user
Inheritance Hierarchy
Online System Object
NFX.ApplicationModel NOPSession

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class NOPSession : ISession,
    IEndableInstance
public sealed class NOPSession : ISession,
    IEndableInstance
Public NotInheritable Class NOPSession
    Implements ISession, IEndableInstance
Public NotInheritable Class NOPSession
    Implements ISession, IEndableInstance
public ref class NOPSession sealed : ISession,
    IEndableInstance
public ref class NOPSession sealed : ISession,
    IEndableInstance
[<SealedAttribute>]
type NOPSession =
    class
        interface ISession
        interface IEndableInstance
    end
[<SealedAttribute>]
type NOPSession =
    class
        interface ISession
        interface IEndableInstance
    end
See Also
NOPSession Members
NFX.ApplicationModel Namespace


NOPSession Members

NOPSession Members NFX Class Library

The NOPSession type exposes the following members.
Methods
 | Name | Description
Public method | Acquire |
Public method | End |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasJustLoggedIn |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegenerateID |
Public method | Release |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ID |
 | Instance | Returns a singlelton instance of the NOPSession
Public property | IsEnded |
Public property | IsJustLoggedIn |
Public property | IsNew |
Public property | Item |
Public property | Items |
Public property | LanguageISOCode |
Public property | LastLoginType |
Public property | LastLoginUTC |
Public property | OldID |
Public property | User |
Back to Top
See Also
NOPSession Class
NFX.ApplicationModel Namespace


NOPSession Methods

NOPSession Methods NFX Class Library

The NOPSession type exposes the following members.
Methods
 | Name | Description
Public method | Acquire |
Public method | End |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HasJustLoggedIn |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegenerateID |
Public method | Release |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NOPSession Class
NFX.ApplicationModel Namespace


NOPSession.Acquire Method

NOPSession Acquire Method NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Acquire()
public void Acquire()
Public Sub Acquire
Public Sub Acquire
public:
virtual void Acquire() sealed
public:
virtual void Acquire() sealed
abstract Acquire : unit -> unit
override Acquire : unit -> unit
abstract Acquire : unit -> unit
override Acquire : unit -> unit

Implements

ISession Acquire
See Also
NOPSession Class
NOPSession Members
NFX.ApplicationModel Namespace


NOPSession.End Method

NOPSession End Method NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void End()
public void End()
Public Sub End
Public Sub End
public:
virtual void End() sealed
public:
virtual void End() sealed
abstract End : unit -> unit
override End : unit -> unit
abstract End : unit -> unit
override End : unit -> unit

Implements

IEndableInstance End
See Also
NOPSession Class
NOPSession Members
NFX.ApplicationModel Namespace


NOPSession.HasJustLoggedIn Method

NOPSession HasJustLoggedIn Method NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void HasJustLoggedIn(
    SessionLoginType loginType
)
public void HasJustLoggedIn(
    SessionLoginType loginType
)
Public Sub HasJustLoggedIn (
    loginType As SessionLoginType
)
Public Sub HasJustLoggedIn (
    loginType As SessionLoginType
)
public:
virtual void HasJustLoggedIn(
    SessionLoginType loginType
) sealed
public:
virtual void HasJustLoggedIn(
    SessionLoginType loginType
) sealed
abstract HasJustLoggedIn :
        loginType : SessionLoginType -> unit
override HasJustLoggedIn :
        loginType : SessionLoginType -> unit
abstract HasJustLoggedIn :
        loginType : SessionLoginType -> unit
override HasJustLoggedIn :
        loginType : SessionLoginType -> unit

Parameters

loginType
Type: NFX.ApplicationModel SessionLoginType

Implements

ISession HasJustLoggedIn(SessionLoginType)
See Also
NOPSession Class
NOPSession Members
NFX.ApplicationModel Namespace


NOPSession.RegenerateID Method

NOPSession RegenerateID Method NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RegenerateID()
public void RegenerateID()
Public Sub RegenerateID
Public Sub RegenerateID
public:
virtual void RegenerateID() sealed
public:
virtual void RegenerateID() sealed
abstract RegenerateID : unit -> unit
override RegenerateID : unit -> unit
abstract RegenerateID : unit -> unit
override RegenerateID : unit -> unit

Implements

ISession RegenerateID
See Also
NOPSession Class
NOPSession Members
NFX.ApplicationModel Namespace


NOPSession.Release Method

NOPSession Release Method NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Release()
public void Release()
Public Sub Release
Public Sub Release
public:
virtual void Release() sealed
public:
virtual void Release() sealed
abstract Release : unit -> unit
override Release : unit -> unit
abstract Release : unit -> unit
override Release : unit -> unit

Implements

ISession Release
See Also
NOPSession Class
NOPSession Members
NFX.ApplicationModel Namespace


NOPSession Properties

NOPSession Properties NFX Class Library

The NOPSession type exposes the following members.
Properties
 | Name | Description
Public property | ID |
 | Instance | Returns a singlelton instance of the NOPSession
Public property | IsEnded |
Public property | IsJustLoggedIn |
Public property | IsNew |
Public property | Item |
Public property | Items |
Public property | LanguageISOCode |
Public property | LastLoginType |
Public property | LastLoginUTC |
Public property | OldID |
Public property | User |
Back to Top
See Also
NOPSession Class
NFX.ApplicationModel Namespace


NOPSession.ID Property

NOPSession ID Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid ID { get; }
public Guid ID { get; }
Public ReadOnly Property ID As Guid
    Get
Public ReadOnly Property ID As Guid
    Get
public:
virtual property Guid ID {
    Guid get () sealed;
}
public:
virtual property Guid ID {
    Guid get () sealed;
}
abstract ID : Guid with get
override ID : Guid with get
abstract ID : Guid with get
override ID : Guid with get

Property Value

Type: Online Guid

Implements

ISession ID
See Also
NOPSession Class
NOPSession Members
NFX.ApplicationModel Namespace


NOPSession.Instance Property

NOPSession Instance Property NFX Class Library

Returns a singlelton instance of the NOPSession

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NOPSession Instance { get; }
public static NOPSession Instance { get; }
Public Shared ReadOnly Property Instance As NOPSession
    Get
Public Shared ReadOnly Property Instance As NOPSession
    Get
public:
static property NOPSession^ Instance {
    NOPSession^ get ();
}
public:
static property NOPSession^ Instance {
    NOPSession^ get ();
}
static member Instance : NOPSession with get
static member Instance : NOPSession with get

Property Value

Type: NOPSession
See Also
NOPSession Class
NOPSession Members
NFX.ApplicationModel Namespace


NOPSession.IsEnded Property

NOPSession IsEnded Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEnded { get; }
public bool IsEnded { get; }
Public ReadOnly Property IsEnded As Boolean
    Get
Public ReadOnly Property IsEnded As Boolean
    Get
public:
virtual property bool IsEnded {
    bool get () sealed;
}
public:
virtual property bool IsEnded {
    bool get () sealed;
}
abstract IsEnded : bool with get
override IsEnded : bool with get
abstract IsEnded : bool with get
override IsEnded : bool with get

Property Value

Type: Online Boolean

Implements

IEndableInstance IsEnded
See Also
NOPSession Class
NOPSession Members
NFX.ApplicationModel Namespace


NOPSession.IsJustLoggedIn Property

NOPSession IsJustLoggedIn Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsJustLoggedIn { get; }
public bool IsJustLoggedIn { get; }
Public ReadOnly Property IsJustLoggedIn As Boolean
    Get
Public ReadOnly Property IsJustLoggedIn As Boolean
    Get
public:
virtual property bool IsJustLoggedIn {
    bool get () sealed;
}
public:
virtual property bool IsJustLoggedIn {
    bool get () sealed;
}
abstract IsJustLoggedIn : bool with get
override IsJustLoggedIn : bool with get
abstract IsJustLoggedIn : bool with get
override IsJustLoggedIn : bool with get

Property Value

Type: Online Boolean

Implements

ISession IsJustLoggedIn
See Also
NOPSession Class
NOPSession Members
NFX.ApplicationModel Namespace


NOPSession.IsNew Property

NOPSession IsNew Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsNew { get; }
public bool IsNew { get; }
Public ReadOnly Property IsNew As Boolean
    Get
Public ReadOnly Property IsNew As Boolean
    Get
public:
virtual property bool IsNew {
    bool get () sealed;
}
public:
virtual property bool IsNew {
    bool get () sealed;
}
abstract IsNew : bool with get
override IsNew : bool with get
abstract IsNew : bool with get
override IsNew : bool with get

Property Value

Type: Online Boolean

Implements

ISession IsNew
See Also
NOPSession Class
NOPSession Members
NFX.ApplicationModel Namespace


NOPSession.Item Property

NOPSession Item Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object this[
    Object key
] { get; set; }
public Object this[
    Object key
] { get; set; }
Public Default Property Item (
    key As Object
) As Object
    Get
    Set
Public Default Property Item (
    key As Object
) As Object
    Get
    Set
public:
virtual property Object^ default[Object^ key] {
    Object^ get (Object^ key) sealed;
    void set (Object^ key, Object^ value) sealed;
}
public:
virtual property Object^ default[Object^ key] {
    Object^ get (Object^ key) sealed;
    void set (Object^ key, Object^ value) sealed;
}
abstract Item : Object with get, set
override Item : Object with get, set
abstract Item : Object with get, set
override Item : Object with get, set

Parameters

key
Type: Online System Object

Property Value

Type: Online Object

Implements

ISession Item Object
See Also
NOPSession Class
NOPSession Members
NFX.ApplicationModel Namespace


NOPSession.Items Property

NOPSession Items Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<Object, Object> Items { get; }
public IDictionary<Object, Object> Items { get; }
Public ReadOnly Property Items As IDictionary(Of Object, Object)
    Get
Public ReadOnly Property Items As IDictionary(Of Object, Object)
    Get
public:
virtual property IDictionary<Object^, Object^>^ Items {
    IDictionary<Object^, Object^>^ get () sealed;
}
public:
virtual property IDictionary<Object^, Object^>^ Items {
    IDictionary<Object^, Object^>^ get () sealed;
}
abstract Items : IDictionary<Object, Object> with get
override Items : IDictionary<Object, Object> with get
abstract Items : IDictionary<Object, Object> with get
override Items : IDictionary<Object, Object> with get

Property Value

Type: Online IDictionary Online Object, Online Object

Implements

ISession Items
See Also
NOPSession Class
NOPSession Members
NFX.ApplicationModel Namespace


NOPSession.LanguageISOCode Property

NOPSession LanguageISOCode Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string LanguageISOCode { get; }
public string LanguageISOCode { get; }
Public ReadOnly Property LanguageISOCode As String
    Get
Public ReadOnly Property LanguageISOCode As String
    Get
public:
virtual property String^ LanguageISOCode {
    String^ get () sealed;
}
public:
virtual property String^ LanguageISOCode {
    String^ get () sealed;
}
abstract LanguageISOCode : string with get
override LanguageISOCode : string with get
abstract LanguageISOCode : string with get
override LanguageISOCode : string with get

Property Value

Type: Online String

Implements

ISession LanguageISOCode
See Also
NOPSession Class
NOPSession Members
NFX.ApplicationModel Namespace


NOPSession.LastLoginType Property

NOPSession LastLoginType Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SessionLoginType LastLoginType { get; }
public SessionLoginType LastLoginType { get; }
Public ReadOnly Property LastLoginType As SessionLoginType
    Get
Public ReadOnly Property LastLoginType As SessionLoginType
    Get
public:
virtual property SessionLoginType LastLoginType {
    SessionLoginType get () sealed;
}
public:
virtual property SessionLoginType LastLoginType {
    SessionLoginType get () sealed;
}
abstract LastLoginType : SessionLoginType with get
override LastLoginType : SessionLoginType with get
abstract LastLoginType : SessionLoginType with get
override LastLoginType : SessionLoginType with get

Property Value

Type: SessionLoginType

Implements

ISession LastLoginType
See Also
NOPSession Class
NOPSession Members
NFX.ApplicationModel Namespace


NOPSession.LastLoginUTC Property

NOPSession LastLoginUTC Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> LastLoginUTC { get; }
public Nullable<DateTime> LastLoginUTC { get; }
Public ReadOnly Property LastLoginUTC As Nullable(Of DateTime)
    Get
Public ReadOnly Property LastLoginUTC As Nullable(Of DateTime)
    Get
public:
virtual property Nullable<DateTime> LastLoginUTC {
    Nullable<DateTime> get () sealed;
}
public:
virtual property Nullable<DateTime> LastLoginUTC {
    Nullable<DateTime> get () sealed;
}
abstract LastLoginUTC : Nullable<DateTime> with get
override LastLoginUTC : Nullable<DateTime> with get
abstract LastLoginUTC : Nullable<DateTime> with get
override LastLoginUTC : Nullable<DateTime> with get

Property Value

Type: Online Nullable Online DateTime

Implements

ISession LastLoginUTC
See Also
NOPSession Class
NOPSession Members
NFX.ApplicationModel Namespace


NOPSession.OldID Property

NOPSession OldID Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<Guid> OldID { get; }
public Nullable<Guid> OldID { get; }
Public ReadOnly Property OldID As Nullable(Of Guid)
    Get
Public ReadOnly Property OldID As Nullable(Of Guid)
    Get
public:
virtual property Nullable<Guid> OldID {
    Nullable<Guid> get () sealed;
}
public:
virtual property Nullable<Guid> OldID {
    Nullable<Guid> get () sealed;
}
abstract OldID : Nullable<Guid> with get
override OldID : Nullable<Guid> with get
abstract OldID : Nullable<Guid> with get
override OldID : Nullable<Guid> with get

Property Value

Type: Online Nullable Online Guid

Implements

ISession OldID
See Also
NOPSession Class
NOPSession Members
NFX.ApplicationModel Namespace


NOPSession.User Property

NOPSession User Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public User User { get; set; }
public User User { get; set; }
Public Property User As User
    Get
    Set
Public Property User As User
    Get
    Set
public:
virtual property User^ User {
    User^ get () sealed;
    void set (User^ value) sealed;
}
public:
virtual property User^ User {
    User^ get () sealed;
    void set (User^ value) sealed;
}
abstract User : User with get, set
override User : User with get, set
abstract User : User with get, set
override User : User with get, set

Property Value

Type: User

Implements

ISession User
See Also
NOPSession Class
NOPSession Members
NFX.ApplicationModel Namespace


ServiceBaseApplication Class

ServiceBaseApplication Class NFX Class Library

Provides base implementation of IApplication for applications that have no forms like services and console apps. This class IS thread safe
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel CommonApplicationLogic
NFX.ApplicationModel ServiceBaseApplication

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ServiceBaseApplication : CommonApplicationLogic
public class ServiceBaseApplication : CommonApplicationLogic
Public Class ServiceBaseApplication
    Inherits CommonApplicationLogic
Public Class ServiceBaseApplication
    Inherits CommonApplicationLogic
public ref class ServiceBaseApplication : public CommonApplicationLogic
public ref class ServiceBaseApplication : public CommonApplicationLogic
type ServiceBaseApplication =
    class
        inherit CommonApplicationLogic
    end
type ServiceBaseApplication =
    class
        inherit CommonApplicationLogic
    end
See Also
ServiceBaseApplication Members
NFX.ApplicationModel Namespace


ServiceBaseApplication Members

ServiceBaseApplication Members NFX Class Library

The ServiceBaseApplication type exposes the following members.
Constructors
 | Name | Description
Public method | ServiceBaseApplication( String , ConfigSectionNode) | Takes optional application args[] and root configuration. The args are parsed into CommandArgsConfiguration.
Public method | ServiceBaseApplication(String, Configuration, ConfigSectionNode) | Takes optional command-line configuration args and root configuration. If configuration is null then application is configured from a file co-located with entry-point assembly and called the same name as assembly with '.config' extension, unless args are specified and "/config file" switch is used in which case 'file' has to be locatable and readable.
Back to Top
Methods
 | Name | Description
Protected method | BeforeDataStoreStart | Override to prep data store implementation i.e. inject something programmaticaly (Inherited from CommonApplicationLogic.)
Protected method | BeforeEventTimerStart | Override to prep event timer implementation i.e. inject something programmaticaly (Inherited from CommonApplicationLogic.)
Protected method | BeforeGlueStart | Override to prep glue implementation i.e. inject something programmaticaly (Inherited from CommonApplicationLogic.)
Protected method | BeforeInstrumentationStart | Override to prep instr implementation i.e. inject something programmaticaly (Inherited from CommonApplicationLogic.)
Protected method | BeforeLogStart | Override to prep log implementation i.e. inject log destinations programmaticaly (Inherited from CommonApplicationLogic.)
Protected method | BeforeObjectStoreStart | Override to prep object store implementation i.e. inject something programmaticaly (Inherited from CommonApplicationLogic.)
Protected method | BeforeSecurityManagerStart | Override to prep security manager implementation i.e. inject something programmaticaly (Inherited from CommonApplicationLogic.)
Protected method | BeforeThrottlingStart | Override to prep throttling implementation i.e. inject something programmaticaly (Inherited from CommonApplicationLogic.)
Protected method | BeforeTimeSourceStart | Override to prep time source implementation i.e. inject something programmaticaly (Inherited from CommonApplicationLogic.)
Protected method | CleanupApplication | (Inherited from CommonApplicationLogic.)
 | Destroy | Destroys application effectively finalizing all services
Protected method | Destructor | (Overrides CommonApplicationLogic Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoCleanupApplication | (Inherited from CommonApplicationLogic.)
Protected method | DoInitApplication | (Inherited from CommonApplicationLogic.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetConfiguration |
Protected method | GetDefaultConfigFileName | Tries to find a configuration file name looping through various supported estensions (Inherited from CommonApplicationLogic.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Protected method | GetStarters | (Inherited from CommonApplicationLogic.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InitApplication | (Inherited from CommonApplicationLogic.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from CommonApplicationLogic.)
Public method | MakeNewSessionInstance | Makes BaseSession instance (Inherited from CommonApplicationLogic.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NotifyAllConfigSettingsAboutChange | Forces notification of all registered IConfigSettings-implementers about configuration change (Inherited from CommonApplicationLogic.)
Protected method | NotifyAllConfigSettingsAboutChange(IConfigSectionNode) | Forces notification of all registered IConfigSettings-implementers about configuration change (Inherited from CommonApplicationLogic.)
Public method | PreloadAssemblies | RESERVED for future use. Loads assemblies specified in 'preload-assemblies' section from disk optionally checking the 'enabled' flag. This method is called on application startup by the framework (Inherited from CommonApplicationLogic.)
Public method | RegisterAppFinishNotifiable | Registers an instance of IApplicationFinishNotifiable with application container to receive a call when underlying application instance will finish its lifecycle (Inherited from CommonApplicationLogic.)
Public method | RegisterConfigSettings | Registers an instance of IConfigSettings with application container to receive a call when underlying app configuration changes (Inherited from CommonApplicationLogic.)
Public method | Stop | Initiates the stop of the application by setting its Stopping to true and Active to false so dependent services may start to terminate (Inherited from CommonApplicationLogic.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from CommonApplicationLogic.)
Public method | UnregisterAppFinishNotifiable | Removes the registration of IConfigSettings from application container (Inherited from CommonApplicationLogic.)
Public method | UnregisterConfigSettings | Removes the registration of IConfigSettings from application container (Inherited from CommonApplicationLogic.)
Protected method | WriteLog | (Inherited from CommonApplicationLogic.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_CommandArgs |
Protected field | m_ConfigRoot | (Inherited from CommonApplicationLogic.)
Protected field | m_ConfigSettings | (Inherited from CommonApplicationLogic.)
Protected field | m_DataStore | (Inherited from CommonApplicationLogic.)
Protected field | m_EventTimer | (Inherited from CommonApplicationLogic.)
Protected field | m_FinishNotifiables | (Inherited from CommonApplicationLogic.)
Protected field | m_Glue | (Inherited from CommonApplicationLogic.)
Protected field | m_Instrumentation | (Inherited from CommonApplicationLogic.)
Protected field | m_Log | (Inherited from CommonApplicationLogic.)
Protected field | m_ObjectStore | (Inherited from CommonApplicationLogic.)
Protected field | m_SecurityManager | (Inherited from CommonApplicationLogic.)
Protected field | m_Throttling | (Inherited from CommonApplicationLogic.)
Protected field | m_TimeSource | (Inherited from CommonApplicationLogic.)
 | s_Instance |
Back to Top
Properties
Name | Description
Public property Active
Returns true when application instance is active and working. This property returns false as soon as application finalization starts on shutdown Use to exit long-running loops and such
(Inherited from CommonApplicationLogic.)
AppName
Returns application name
CmdArgs
References command line arguments configuration, so one can use it as:
View Colorized Copy to Clipboard Print
if (Servicepplication.CmdArgs["DeleteFiles"].Exists)
{
  // this will run if process was invoked like so: process.exe /deleteFiles
}
if (Servicepplication.CmdArgs["DeleteFiles"].Exists)
{
  // this will run if process was invoked like so: process.exe /deleteFiles
}
Public property CommandArgs
References command line arguments configuration, so one can use it as:
View Colorized Copy to Clipboard Print
if (ServiceApplication.Instance.CommandArgs["DeleteFiles"].Exists)
{
  // this will run if process was invoked like so: process.exe /deleteFiles
}
if (ServiceApplication.Instance.CommandArgs["DeleteFiles"].Exists)
{
  // this will run if process was invoked like so: process.exe /deleteFiles
}
Public property ConfigRoot
Provides access to configuration root for the whole application
(Inherited from CommonApplicationLogic.)
ConfRoot
Provides access to configuration root for the whole application
ContextAvailable
Indicates whether application context was allocated
Data
References application data store
Public property DataStore
References application data store
(Inherited from CommonApplicationLogic.)
Public property Disposed
Indicates whether this object was already disposed - the Dispose() has finished
(Inherited from DisposableObject.)
Public property DisposeStarted
Indicates whether this object Dispose() has been called and dispose started but not finished yet
(Inherited from DisposableObject.)
Public property EventTimer
References event timer which maintains and runs scheduled Event instances
(Inherited from CommonApplicationLogic.)
Public property Glue
References glue that can be used to interconnect remote instances
(Inherited from CommonApplicationLogic.)
Glues
References glue that can be used to connect to remote entities
Instance
References a singleton instance of BaseApplication
Public property InstanceID
Returns unique identifier of this running instance
(Inherited from CommonApplicationLogic.)
Public property Instrumentation
References application instrumentation
(Inherited from CommonApplicationLogic.)
Instruments
References application instrumentation
IsActive
Returns true when application instance is active and working. This property returns false as soon as application finalization starts on shutdown Use to exit long-running loops and such
Public property | IsUnitTest | (Inherited from CommonApplicationLogic.)
Public property LocalizedTime
Returns current time localized per TimeLocation
(Inherited from CommonApplicationLogic.)
Public property Log
References application logger
(Inherited from CommonApplicationLogic.)
Logger
References application logger
Public property Name
Returns the name of this application
(Inherited from CommonApplicationLogic.)
Objects
References application object store. Objects will survive application termination
Public property ObjectStore
References application object store. Objects will survive application termination
(Inherited from CommonApplicationLogic.)
Security
References security manager that performs user authentication based on passed credentials and other security-related global tasks
Public property SecurityManager
References security manager that performs user authentication based on passed credentials and other security-related global tasks
(Inherited from CommonApplicationLogic.)
Public property ShutdownStarted
Returns true to indicate that Dispose() has been called and shutdown has started
(Inherited from CommonApplicationLogic.)
Public property StartTime
Returns timestamp when application started as localized app time
(Inherited from CommonApplicationLogic.)
Public property Stopping
Returns true to indicate that Stop() was called
(Inherited from CommonApplicationLogic.)
Throttles
References application throttling
Public property Throttling
References application throttling
(Inherited from CommonApplicationLogic.)
Time
References time source - an entity that supplies local and UTC times. The concrete implementation may elect to get accurate times from the network or other external precision time sources (i.e. NASA atomic clock)
Public property TimeLocation
Returns time location of this LocalizedTimeProvider implementation
(Inherited from CommonApplicationLogic.)
Timer
References event timer which maintains and runs scheduled Event instances
Public property TimeSource
References time source - an entity that supplies local and UTC times. The concrete implementation may elect to get accurate times from the network or other external precision time sources (i.e. NASA atomic clock)
(Inherited from CommonApplicationLogic.)
Back to Top
See Also
ServiceBaseApplication Class
NFX.ApplicationModel Namespace


ServiceBaseApplication Constructor

ServiceBaseApplication Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ServiceBaseApplication( String , ConfigSectionNode) | Takes optional application args[] and root configuration. The args are parsed into CommandArgsConfiguration.
Public method | ServiceBaseApplication(String, Configuration, ConfigSectionNode) | Takes optional command-line configuration args and root configuration. If configuration is null then application is configured from a file co-located with entry-point assembly and called the same name as assembly with '.config' extension, unless args are specified and "/config file" switch is used in which case 'file' has to be locatable and readable.
Back to Top
See Also
ServiceBaseApplication Class
ServiceBaseApplication Members
NFX.ApplicationModel Namespace


ServiceBaseApplication Constructor (String[], ConfigSectionNode)

ServiceBaseApplication Constructor ( String , ConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Takes optional application args[] and root configuration. The args are parsed into CommandArgsConfiguration.

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServiceBaseApplication(
    string[] args,
    ConfigSectionNode rootConfig
)
public ServiceBaseApplication(
    string[] args,
    ConfigSectionNode rootConfig
)
Public Sub New (
    args As String(),
    rootConfig As ConfigSectionNode
)
Public Sub New (
    args As String(),
    rootConfig As ConfigSectionNode
)
public:
ServiceBaseApplication(
    array<String^>^ args,
    ConfigSectionNode^ rootConfig
)
public:
ServiceBaseApplication(
    array<String^>^ args,
    ConfigSectionNode^ rootConfig
)
new :
        args : string[] *
        rootConfig : ConfigSectionNode -> ServiceBaseApplication
new :
        args : string[] *
        rootConfig : ConfigSectionNode -> ServiceBaseApplication

Parameters

args
Type: Online System String
rootConfig
Type: NFX.Environment ConfigSectionNode
See Also
ServiceBaseApplication Class
ServiceBaseApplication Members
ServiceBaseApplication Overload
NFX.ApplicationModel Namespace


ServiceBaseApplication Constructor (String, Configuration, ConfigSectionNode)

ServiceBaseApplication Constructor (String, Configuration, ConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Takes optional command-line configuration args and root configuration. If configuration is null then application is configured from a file co-located with entry-point assembly and called the same name as assembly with '.config' extension, unless args are specified and "/config file" switch is used in which case 'file' has to be locatable and readable.

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServiceBaseApplication(
    string name,
    Configuration cmdLineArgs,
    ConfigSectionNode rootConfig
)
public ServiceBaseApplication(
    string name,
    Configuration cmdLineArgs,
    ConfigSectionNode rootConfig
)
Public Sub New (
    name As String,
    cmdLineArgs As Configuration,
    rootConfig As ConfigSectionNode
)
Public Sub New (
    name As String,
    cmdLineArgs As Configuration,
    rootConfig As ConfigSectionNode
)
public:
ServiceBaseApplication(
    String^ name,
    Configuration^ cmdLineArgs,
    ConfigSectionNode^ rootConfig
)
public:
ServiceBaseApplication(
    String^ name,
    Configuration^ cmdLineArgs,
    ConfigSectionNode^ rootConfig
)
new :
        name : string *
        cmdLineArgs : Configuration *
        rootConfig : ConfigSectionNode -> ServiceBaseApplication
new :
        name : string *
        cmdLineArgs : Configuration *
        rootConfig : ConfigSectionNode -> ServiceBaseApplication

Parameters

name
Type: Online System String
cmdLineArgs
Type: NFX.Environment Configuration
rootConfig
Type: NFX.Environment ConfigSectionNode
See Also
ServiceBaseApplication Class
ServiceBaseApplication Members
ServiceBaseApplication Overload
NFX.ApplicationModel Namespace


ServiceBaseApplication Fields

ServiceBaseApplication Fields NFX Class Library

The ServiceBaseApplication type exposes the following members.
Fields
 | Name | Description
Protected field | m_CommandArgs |
Protected field | m_ConfigRoot | (Inherited from CommonApplicationLogic.)
Protected field | m_ConfigSettings | (Inherited from CommonApplicationLogic.)
Protected field | m_DataStore | (Inherited from CommonApplicationLogic.)
Protected field | m_EventTimer | (Inherited from CommonApplicationLogic.)
Protected field | m_FinishNotifiables | (Inherited from CommonApplicationLogic.)
Protected field | m_Glue | (Inherited from CommonApplicationLogic.)
Protected field | m_Instrumentation | (Inherited from CommonApplicationLogic.)
Protected field | m_Log | (Inherited from CommonApplicationLogic.)
Protected field | m_ObjectStore | (Inherited from CommonApplicationLogic.)
Protected field | m_SecurityManager | (Inherited from CommonApplicationLogic.)
Protected field | m_Throttling | (Inherited from CommonApplicationLogic.)
Protected field | m_TimeSource | (Inherited from CommonApplicationLogic.)
 | s_Instance |
Back to Top
See Also
ServiceBaseApplication Class
NFX.ApplicationModel Namespace


ServiceBaseApplication.m_CommandArgs Field

ServiceBaseApplication m_CommandArgs Field NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ConfigSectionNode m_CommandArgs
protected ConfigSectionNode m_CommandArgs
Protected m_CommandArgs As ConfigSectionNode
Protected m_CommandArgs As ConfigSectionNode
protected:
ConfigSectionNode^ m_CommandArgs
protected:
ConfigSectionNode^ m_CommandArgs
val mutable m_CommandArgs: ConfigSectionNode
val mutable m_CommandArgs: ConfigSectionNode

Field Value

Type: ConfigSectionNode
See Also
ServiceBaseApplication Class
ServiceBaseApplication Members
NFX.ApplicationModel Namespace


ServiceBaseApplication.s_Instance Field

ServiceBaseApplication s_Instance Field NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected static ServiceBaseApplication s_Instance
protected static ServiceBaseApplication s_Instance
Protected Shared s_Instance As ServiceBaseApplication
Protected Shared s_Instance As ServiceBaseApplication
protected:
static ServiceBaseApplication^ s_Instance
protected:
static ServiceBaseApplication^ s_Instance
static val mutable s_Instance: ServiceBaseApplication
static val mutable s_Instance: ServiceBaseApplication

Field Value

Type: ServiceBaseApplication
See Also
ServiceBaseApplication Class
ServiceBaseApplication Members
NFX.ApplicationModel Namespace


ServiceBaseApplication Methods

ServiceBaseApplication Methods NFX Class Library

The ServiceBaseApplication type exposes the following members.
Methods
 | Name | Description
Protected method | BeforeDataStoreStart | Override to prep data store implementation i.e. inject something programmaticaly (Inherited from CommonApplicationLogic.)
Protected method | BeforeEventTimerStart | Override to prep event timer implementation i.e. inject something programmaticaly (Inherited from CommonApplicationLogic.)
Protected method | BeforeGlueStart | Override to prep glue implementation i.e. inject something programmaticaly (Inherited from CommonApplicationLogic.)
Protected method | BeforeInstrumentationStart | Override to prep instr implementation i.e. inject something programmaticaly (Inherited from CommonApplicationLogic.)
Protected method | BeforeLogStart | Override to prep log implementation i.e. inject log destinations programmaticaly (Inherited from CommonApplicationLogic.)
Protected method | BeforeObjectStoreStart | Override to prep object store implementation i.e. inject something programmaticaly (Inherited from CommonApplicationLogic.)
Protected method | BeforeSecurityManagerStart | Override to prep security manager implementation i.e. inject something programmaticaly (Inherited from CommonApplicationLogic.)
Protected method | BeforeThrottlingStart | Override to prep throttling implementation i.e. inject something programmaticaly (Inherited from CommonApplicationLogic.)
Protected method | BeforeTimeSourceStart | Override to prep time source implementation i.e. inject something programmaticaly (Inherited from CommonApplicationLogic.)
Protected method | CleanupApplication | (Inherited from CommonApplicationLogic.)
 | Destroy | Destroys application effectively finalizing all services
Protected method | Destructor | (Overrides CommonApplicationLogic Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoCleanupApplication | (Inherited from CommonApplicationLogic.)
Protected method | DoInitApplication | (Inherited from CommonApplicationLogic.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetConfiguration |
Protected method | GetDefaultConfigFileName | Tries to find a configuration file name looping through various supported estensions (Inherited from CommonApplicationLogic.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Protected method | GetStarters | (Inherited from CommonApplicationLogic.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InitApplication | (Inherited from CommonApplicationLogic.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from CommonApplicationLogic.)
Public method | MakeNewSessionInstance | Makes BaseSession instance (Inherited from CommonApplicationLogic.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NotifyAllConfigSettingsAboutChange | Forces notification of all registered IConfigSettings-implementers about configuration change (Inherited from CommonApplicationLogic.)
Protected method | NotifyAllConfigSettingsAboutChange(IConfigSectionNode) | Forces notification of all registered IConfigSettings-implementers about configuration change (Inherited from CommonApplicationLogic.)
Public method | PreloadAssemblies | RESERVED for future use. Loads assemblies specified in 'preload-assemblies' section from disk optionally checking the 'enabled' flag. This method is called on application startup by the framework (Inherited from CommonApplicationLogic.)
Public method | RegisterAppFinishNotifiable | Registers an instance of IApplicationFinishNotifiable with application container to receive a call when underlying application instance will finish its lifecycle (Inherited from CommonApplicationLogic.)
Public method | RegisterConfigSettings | Registers an instance of IConfigSettings with application container to receive a call when underlying app configuration changes (Inherited from CommonApplicationLogic.)
Public method | Stop | Initiates the stop of the application by setting its Stopping to true and Active to false so dependent services may start to terminate (Inherited from CommonApplicationLogic.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from CommonApplicationLogic.)
Public method | UnregisterAppFinishNotifiable | Removes the registration of IConfigSettings from application container (Inherited from CommonApplicationLogic.)
Public method | UnregisterConfigSettings | Removes the registration of IConfigSettings from application container (Inherited from CommonApplicationLogic.)
Protected method | WriteLog | (Inherited from CommonApplicationLogic.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServiceBaseApplication Class
NFX.ApplicationModel Namespace


ServiceBaseApplication.Destroy Method

ServiceBaseApplication Destroy Method NFX Class Library

Destroys application effectively finalizing all services

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Destroy()
public static void Destroy()
Public Shared Sub Destroy
Public Shared Sub Destroy
public:
static void Destroy()
public:
static void Destroy()
static member Destroy : unit -> unit
static member Destroy : unit -> unit
See Also
ServiceBaseApplication Class
ServiceBaseApplication Members
NFX.ApplicationModel Namespace


ServiceBaseApplication.Destructor Method

ServiceBaseApplication Destructor Method NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
ServiceBaseApplication Class
ServiceBaseApplication Members
NFX.ApplicationModel Namespace


ServiceBaseApplication.GetConfiguration Method

ServiceBaseApplication GetConfiguration Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Configuration GetConfiguration()
protected virtual Configuration GetConfiguration()
Protected Overridable Function GetConfiguration As Configuration
Protected Overridable Function GetConfiguration As Configuration
protected:
virtual Configuration^ GetConfiguration()
protected:
virtual Configuration^ GetConfiguration()
abstract GetConfiguration : unit -> Configuration
override GetConfiguration : unit -> Configuration
abstract GetConfiguration : unit -> Configuration
override GetConfiguration : unit -> Configuration

Return Value

Type: Configuration
See Also
ServiceBaseApplication Class
ServiceBaseApplication Members
NFX.ApplicationModel Namespace


ServiceBaseApplication Properties

ServiceBaseApplication Properties NFX Class Library

The ServiceBaseApplication type exposes the following members.
Properties
Name | Description
Public property Active
Returns true when application instance is active and working. This property returns false as soon as application finalization starts on shutdown Use to exit long-running loops and such
(Inherited from CommonApplicationLogic.)
AppName
Returns application name
CmdArgs
References command line arguments configuration, so one can use it as:
View Colorized Copy to Clipboard Print
if (Servicepplication.CmdArgs["DeleteFiles"].Exists)
{
  // this will run if process was invoked like so: process.exe /deleteFiles
}
if (Servicepplication.CmdArgs["DeleteFiles"].Exists)
{
  // this will run if process was invoked like so: process.exe /deleteFiles
}
Public property CommandArgs
References command line arguments configuration, so one can use it as:
View Colorized Copy to Clipboard Print
if (ServiceApplication.Instance.CommandArgs["DeleteFiles"].Exists)
{
  // this will run if process was invoked like so: process.exe /deleteFiles
}
if (ServiceApplication.Instance.CommandArgs["DeleteFiles"].Exists)
{
  // this will run if process was invoked like so: process.exe /deleteFiles
}
Public property ConfigRoot
Provides access to configuration root for the whole application
(Inherited from CommonApplicationLogic.)
ConfRoot
Provides access to configuration root for the whole application
ContextAvailable
Indicates whether application context was allocated
Data
References application data store
Public property DataStore
References application data store
(Inherited from CommonApplicationLogic.)
Public property Disposed
Indicates whether this object was already disposed - the Dispose() has finished
(Inherited from DisposableObject.)
Public property DisposeStarted
Indicates whether this object Dispose() has been called and dispose started but not finished yet
(Inherited from DisposableObject.)
Public property EventTimer
References event timer which maintains and runs scheduled Event instances
(Inherited from CommonApplicationLogic.)
Public property Glue
References glue that can be used to interconnect remote instances
(Inherited from CommonApplicationLogic.)
Glues
References glue that can be used to connect to remote entities
Instance
References a singleton instance of BaseApplication
Public property InstanceID
Returns unique identifier of this running instance
(Inherited from CommonApplicationLogic.)
Public property Instrumentation
References application instrumentation
(Inherited from CommonApplicationLogic.)
Instruments
References application instrumentation
IsActive
Returns true when application instance is active and working. This property returns false as soon as application finalization starts on shutdown Use to exit long-running loops and such
Public property | IsUnitTest | (Inherited from CommonApplicationLogic.)
Public property LocalizedTime
Returns current time localized per TimeLocation
(Inherited from CommonApplicationLogic.)
Public property Log
References application logger
(Inherited from CommonApplicationLogic.)
Logger
References application logger
Public property Name
Returns the name of this application
(Inherited from CommonApplicationLogic.)
Objects
References application object store. Objects will survive application termination
Public property ObjectStore
References application object store. Objects will survive application termination
(Inherited from CommonApplicationLogic.)
Security
References security manager that performs user authentication based on passed credentials and other security-related global tasks
Public property SecurityManager
References security manager that performs user authentication based on passed credentials and other security-related global tasks
(Inherited from CommonApplicationLogic.)
Public property ShutdownStarted
Returns true to indicate that Dispose() has been called and shutdown has started
(Inherited from CommonApplicationLogic.)
Public property StartTime
Returns timestamp when application started as localized app time
(Inherited from CommonApplicationLogic.)
Public property Stopping
Returns true to indicate that Stop() was called
(Inherited from CommonApplicationLogic.)
Throttles
References application throttling
Public property Throttling
References application throttling
(Inherited from CommonApplicationLogic.)
Time
References time source - an entity that supplies local and UTC times. The concrete implementation may elect to get accurate times from the network or other external precision time sources (i.e. NASA atomic clock)
Public property TimeLocation
Returns time location of this LocalizedTimeProvider implementation
(Inherited from CommonApplicationLogic.)
Timer
References event timer which maintains and runs scheduled Event instances
Public property TimeSource
References time source - an entity that supplies local and UTC times. The concrete implementation may elect to get accurate times from the network or other external precision time sources (i.e. NASA atomic clock)
(Inherited from CommonApplicationLogic.)
Back to Top
See Also
ServiceBaseApplication Class
NFX.ApplicationModel Namespace


ServiceBaseApplication.AppName Property

ServiceBaseApplication AppName Property NFX Class Library

Returns application name

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string AppName { get; }
public static string AppName { get; }
Public Shared ReadOnly Property AppName As String
    Get
Public Shared ReadOnly Property AppName As String
    Get
public:
static property String^ AppName {
    String^ get ();
}
public:
static property String^ AppName {
    String^ get ();
}
static member AppName : string with get
static member AppName : string with get

Property Value

Type: Online String
See Also
ServiceBaseApplication Class
ServiceBaseApplication Members
NFX.ApplicationModel Namespace


ServiceBaseApplication.CmdArgs Property

ServiceBaseApplication CmdArgs Property NFX Class Library

References command line arguments configuration, so one can use it as:
View Colorized Copy to Clipboard Print
if (Servicepplication.CmdArgs["DeleteFiles"].Exists)
{
  // this will run if process was invoked like so: process.exe /deleteFiles
}
if (Servicepplication.CmdArgs["DeleteFiles"].Exists)
{
  // this will run if process was invoked like so: process.exe /deleteFiles
}

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IConfigSectionNode CmdArgs { get; }
public static IConfigSectionNode CmdArgs { get; }
Public Shared ReadOnly Property CmdArgs As IConfigSectionNode
    Get
Public Shared ReadOnly Property CmdArgs As IConfigSectionNode
    Get
public:
static property IConfigSectionNode^ CmdArgs {
    IConfigSectionNode^ get ();
}
public:
static property IConfigSectionNode^ CmdArgs {
    IConfigSectionNode^ get ();
}
static member CmdArgs : IConfigSectionNode with get
static member CmdArgs : IConfigSectionNode with get

Property Value

Type: IConfigSectionNode
See Also
ServiceBaseApplication Class
ServiceBaseApplication Members
NFX.ApplicationModel Namespace


ServiceBaseApplication.CommandArgs Property

ServiceBaseApplication CommandArgs Property NFX Class Library

[This is preliminary documentation and is subject to change.]

References command line arguments configuration, so one can use it as:
View Colorized Copy to Clipboard Print
if (ServiceApplication.Instance.CommandArgs["DeleteFiles"].Exists)
{
  // this will run if process was invoked like so: process.exe /deleteFiles
}
if (ServiceApplication.Instance.CommandArgs["DeleteFiles"].Exists)
{
  // this will run if process was invoked like so: process.exe /deleteFiles
}

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IConfigSectionNode CommandArgs { get; }
public IConfigSectionNode CommandArgs { get; }
Public ReadOnly Property CommandArgs As IConfigSectionNode
    Get
Public ReadOnly Property CommandArgs As IConfigSectionNode
    Get
public:
property IConfigSectionNode^ CommandArgs {
    IConfigSectionNode^ get ();
}
public:
property IConfigSectionNode^ CommandArgs {
    IConfigSectionNode^ get ();
}
member CommandArgs : IConfigSectionNode with get
member CommandArgs : IConfigSectionNode with get

Property Value

Type: IConfigSectionNode
See Also
ServiceBaseApplication Class
ServiceBaseApplication Members
NFX.ApplicationModel Namespace


ServiceBaseApplication.ConfRoot Property

ServiceBaseApplication ConfRoot Property NFX Class Library

Provides access to configuration root for the whole application

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ConfigSectionNode ConfRoot { get; }
public static ConfigSectionNode ConfRoot { get; }
Public Shared ReadOnly Property ConfRoot As ConfigSectionNode
    Get
Public Shared ReadOnly Property ConfRoot As ConfigSectionNode
    Get
public:
static property ConfigSectionNode^ ConfRoot {
    ConfigSectionNode^ get ();
}
public:
static property ConfigSectionNode^ ConfRoot {
    ConfigSectionNode^ get ();
}
static member ConfRoot : ConfigSectionNode with get
static member ConfRoot : ConfigSectionNode with get

Property Value

Type: ConfigSectionNode
See Also
ServiceBaseApplication Class
ServiceBaseApplication Members
NFX.ApplicationModel Namespace


ServiceBaseApplication.ContextAvailable Property

ServiceBaseApplication ContextAvailable Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Indicates whether application context was allocated

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool ContextAvailable { get; }
public static bool ContextAvailable { get; }
Public Shared ReadOnly Property ContextAvailable As Boolean
    Get
Public Shared ReadOnly Property ContextAvailable As Boolean
    Get
public:
static property bool ContextAvailable {
    bool get ();
}
public:
static property bool ContextAvailable {
    bool get ();
}
static member ContextAvailable : bool with get
static member ContextAvailable : bool with get

Property Value

Type: Online Boolean
See Also
ServiceBaseApplication Class
ServiceBaseApplication Members
NFX.ApplicationModel Namespace


ServiceBaseApplication.Data Property

ServiceBaseApplication Data Property NFX Class Library

References application data store

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IDataStore Data { get; }
public static IDataStore Data { get; }
Public Shared ReadOnly Property Data As IDataStore
    Get
Public Shared ReadOnly Property Data As IDataStore
    Get
public:
static property IDataStore^ Data {
    IDataStore^ get ();
}
public:
static property IDataStore^ Data {
    IDataStore^ get ();
}
static member Data : IDataStore with get
static member Data : IDataStore with get

Property Value

Type: IDataStore
See Also
ServiceBaseApplication Class
ServiceBaseApplication Members
NFX.ApplicationModel Namespace


ServiceBaseApplication.Glues Property

ServiceBaseApplication Glues Property NFX Class Library

References glue that can be used to connect to remote entities

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IGlue Glues { get; }
public static IGlue Glues { get; }
Public Shared ReadOnly Property Glues As IGlue
    Get
Public Shared ReadOnly Property Glues As IGlue
    Get
public:
static property IGlue^ Glues {
    IGlue^ get ();
}
public:
static property IGlue^ Glues {
    IGlue^ get ();
}
static member Glues : IGlue with get
static member Glues : IGlue with get

Property Value

Type: IGlue
See Also
ServiceBaseApplication Class
ServiceBaseApplication Members
NFX.ApplicationModel Namespace


ServiceBaseApplication.Instance Property

ServiceBaseApplication Instance Property NFX Class Library

References a singleton instance of BaseApplication

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ServiceBaseApplication Instance { get; }
public static ServiceBaseApplication Instance { get; }
Public Shared ReadOnly Property Instance As ServiceBaseApplication
    Get
Public Shared ReadOnly Property Instance As ServiceBaseApplication
    Get
public:
static property ServiceBaseApplication^ Instance {
    ServiceBaseApplication^ get ();
}
public:
static property ServiceBaseApplication^ Instance {
    ServiceBaseApplication^ get ();
}
static member Instance : ServiceBaseApplication with get
static member Instance : ServiceBaseApplication with get

Property Value

Type: ServiceBaseApplication
See Also
ServiceBaseApplication Class
ServiceBaseApplication Members
NFX.ApplicationModel Namespace


ServiceBaseApplication.Instruments Property

ServiceBaseApplication Instruments Property NFX Class Library

[This is preliminary documentation and is subject to change.]

References application instrumentation

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IInstrumentation Instruments { get; }
public static IInstrumentation Instruments { get; }
Public Shared ReadOnly Property Instruments As IInstrumentation
    Get
Public Shared ReadOnly Property Instruments As IInstrumentation
    Get
public:
static property IInstrumentation^ Instruments {
    IInstrumentation^ get ();
}
public:
static property IInstrumentation^ Instruments {
    IInstrumentation^ get ();
}
static member Instruments : IInstrumentation with get
static member Instruments : IInstrumentation with get

Property Value

Type: IInstrumentation
See Also
ServiceBaseApplication Class
ServiceBaseApplication Members
NFX.ApplicationModel Namespace


ServiceBaseApplication.IsActive Property

ServiceBaseApplication IsActive Property NFX Class Library

Returns true when application instance is active and working. This property returns false as soon as application finalization starts on shutdown Use to exit long-running loops and such

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsActive { get; }
public static bool IsActive { get; }
Public Shared ReadOnly Property IsActive As Boolean
    Get
Public Shared ReadOnly Property IsActive As Boolean
    Get
public:
static property bool IsActive {
    bool get ();
}
public:
static property bool IsActive {
    bool get ();
}
static member IsActive : bool with get
static member IsActive : bool with get

Property Value

Type: Online Boolean
See Also
ServiceBaseApplication Class
ServiceBaseApplication Members
NFX.ApplicationModel Namespace


ServiceBaseApplication.Logger Property

ServiceBaseApplication Logger Property NFX Class Library

References application logger

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILog Logger { get; }
public static ILog Logger { get; }
Public Shared ReadOnly Property Logger As ILog
    Get
Public Shared ReadOnly Property Logger As ILog
    Get
public:
static property ILog^ Logger {
    ILog^ get ();
}
public:
static property ILog^ Logger {
    ILog^ get ();
}
static member Logger : ILog with get
static member Logger : ILog with get

Property Value

Type: ILog
See Also
ServiceBaseApplication Class
ServiceBaseApplication Members
NFX.ApplicationModel Namespace


ServiceBaseApplication.Objects Property

ServiceBaseApplication Objects Property NFX Class Library

References application object store. Objects will survive application termination

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IObjectStore Objects { get; }
public static IObjectStore Objects { get; }
Public Shared ReadOnly Property Objects As IObjectStore
    Get
Public Shared ReadOnly Property Objects As IObjectStore
    Get
public:
static property IObjectStore^ Objects {
    IObjectStore^ get ();
}
public:
static property IObjectStore^ Objects {
    IObjectStore^ get ();
}
static member Objects : IObjectStore with get
static member Objects : IObjectStore with get

Property Value

Type: IObjectStore
See Also
ServiceBaseApplication Class
ServiceBaseApplication Members
NFX.ApplicationModel Namespace


ServiceBaseApplication.Security Property

ServiceBaseApplication Security Property NFX Class Library

References security manager that performs user authentication based on passed credentials and other security-related global tasks

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ISecurityManager Security { get; }
public static ISecurityManager Security { get; }
Public Shared ReadOnly Property Security As ISecurityManager
    Get
Public Shared ReadOnly Property Security As ISecurityManager
    Get
public:
static property ISecurityManager^ Security {
    ISecurityManager^ get ();
}
public:
static property ISecurityManager^ Security {
    ISecurityManager^ get ();
}
static member Security : ISecurityManager with get
static member Security : ISecurityManager with get

Property Value

Type: ISecurityManager
See Also
ServiceBaseApplication Class
ServiceBaseApplication Members
NFX.ApplicationModel Namespace


ServiceBaseApplication.Throttles Property

ServiceBaseApplication Throttles Property NFX Class Library

References application throttling

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IThrottling Throttles { get; }
public static IThrottling Throttles { get; }
Public Shared ReadOnly Property Throttles As IThrottling
    Get
Public Shared ReadOnly Property Throttles As IThrottling
    Get
public:
static property IThrottling^ Throttles {
    IThrottling^ get ();
}
public:
static property IThrottling^ Throttles {
    IThrottling^ get ();
}
static member Throttles : IThrottling with get
static member Throttles : IThrottling with get

Property Value

Type: IThrottling
See Also
ServiceBaseApplication Class
ServiceBaseApplication Members
NFX.ApplicationModel Namespace


ServiceBaseApplication.Time Property

ServiceBaseApplication Time Property NFX Class Library

References time source - an entity that supplies local and UTC times. The concrete implementation may elect to get accurate times from the network or other external precision time sources (i.e. NASA atomic clock)

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ITimeSource Time { get; }
public static ITimeSource Time { get; }
Public Shared ReadOnly Property Time As ITimeSource
    Get
Public Shared ReadOnly Property Time As ITimeSource
    Get
public:
static property ITimeSource^ Time {
    ITimeSource^ get ();
}
public:
static property ITimeSource^ Time {
    ITimeSource^ get ();
}
static member Time : ITimeSource with get
static member Time : ITimeSource with get

Property Value

Type: ITimeSource
See Also
ServiceBaseApplication Class
ServiceBaseApplication Members
NFX.ApplicationModel Namespace


ServiceBaseApplication.Timer Property

ServiceBaseApplication Timer Property NFX Class Library

References event timer which maintains and runs scheduled Event instances

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEventTimer Timer { get; }
public static IEventTimer Timer { get; }
Public Shared ReadOnly Property Timer As IEventTimer
    Get
Public Shared ReadOnly Property Timer As IEventTimer
    Get
public:
static property IEventTimer^ Timer {
    IEventTimer^ get ();
}
public:
static property IEventTimer^ Timer {
    IEventTimer^ get ();
}
static member Timer : IEventTimer with get
static member Timer : IEventTimer with get

Property Value

Type: IEventTimer
See Also
ServiceBaseApplication Class
ServiceBaseApplication Members
NFX.ApplicationModel Namespace


SessionLoginType Enumeration

SessionLoginType Enumeration NFX Class Library

Denotes types of session login

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum SessionLoginType
public enum SessionLoginType
Public Enumeration SessionLoginType
Public Enumeration SessionLoginType
public enum class SessionLoginType
public enum class SessionLoginType
type SessionLoginType
type SessionLoginType
Members
Member name | Value | Description
Unspecified | 0 | Not known
Human | 1 | A human user has entered/supplied/provided the credentials
Robot | 2 | A robot/computer/process/API caller
See Also
NFX.ApplicationModel Namespace


TestApplication Class

TestApplication Class NFX Class Library

Application designated for use in various unit test cases. This class is not intended for use in production systems!
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel TestApplication

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TestApplication : DisposableObject,
    IApplication, INamed, ILocalizedTimeProvider
public class TestApplication : DisposableObject,
    IApplication, INamed, ILocalizedTimeProvider
Public Class TestApplication
    Inherits DisposableObject
    Implements IApplication, INamed, ILocalizedTimeProvider
Public Class TestApplication
    Inherits DisposableObject
    Implements IApplication, INamed, ILocalizedTimeProvider
public ref class TestApplication : public DisposableObject,
    IApplication, INamed, ILocalizedTimeProvider
public ref class TestApplication : public DisposableObject,
    IApplication, INamed, ILocalizedTimeProvider
type TestApplication =
    class
        inherit DisposableObject
        interface IApplication
        interface INamed
        interface ILocalizedTimeProvider
    end
type TestApplication =
    class
        inherit DisposableObject
        interface IApplication
        interface INamed
        interface ILocalizedTimeProvider
    end
See Also
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication Members

TestApplication Members NFX Class Library

The TestApplication type exposes the following members.
Constructors
 | Name | Description
Public method | TestApplication | Initializes a new instance of the TestApplication class
Back to Top
Methods
 | Name | Description
Protected method | Destructor | Override this method to do actual destructor work (Inherited from DisposableObject.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime |
Public method | MakeNewSessionInstance |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NotifyAllConfigSettingsAboutChange | Forces notification of all registered IConfigSettings-implementers about configuration change
Protected method | NotifyAllConfigSettingsAboutChange(IConfigSectionNode) | Forces notification of all registered IConfigSettings-implementers about configuration change
Public method | RegisterAppFinishNotifiable |
Public method | RegisterConfigSettings | Registers an instance of IConfigSettings with application container to receive a call when underlying app configuration changes
Public method | Stop |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime |
Public method | UnregisterAppFinishNotifiable |
Public method | UnregisterConfigSettings | Removes the registration of IConfigSettings from application container
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_ConfigRoot |
Protected field | m_ConfigSettings |
Protected field | m_InstanceID |
Back to Top
Properties
 | Name | Description
Public property | Active |
Public property | ConfigRoot |
Public property | DataStore |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EventTimer |
Public property | Glue |
Public property | InstanceID |
Public property | Instrumentation |
Public property | IsUnitTest |
Public property | LocalizedTime |
Public property | Log |
Public property | Name |
Public property | ObjectStore |
Public property | SecurityManager |
Public property | ShutdownStarted |
Public property | StartTime |
Public property | Stopping |
Public property | Throttling |
Public property | TimeLocation |
Public property | TimeSource |
Back to Top
See Also
TestApplication Class
NFX.ApplicationModel Namespace


TestApplication Constructor

TestApplication Constructor NFX Class Library

Initializes a new instance of the TestApplication class

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TestApplication(
    ConfigSectionNode cfgRoot = null
)
public TestApplication(
    ConfigSectionNode cfgRoot = null
)
Public Sub New (
    Optional cfgRoot As ConfigSectionNode = Nothing
)
Public Sub New (
    Optional cfgRoot As ConfigSectionNode = Nothing
)
public:
TestApplication(
    ConfigSectionNode^ cfgRoot = nullptr
)
public:
TestApplication(
    ConfigSectionNode^ cfgRoot = nullptr
)
new :
        ?cfgRoot : ConfigSectionNode
(* Defaults:
        let _cfgRoot = defaultArg cfgRoot null
*)
-> TestApplication
new :
        ?cfgRoot : ConfigSectionNode
(* Defaults:
        let _cfgRoot = defaultArg cfgRoot null
*)
-> TestApplication

Parameters

cfgRoot (Optional)
Type: NFX.Environment ConfigSectionNode
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication Fields

TestApplication Fields NFX Class Library

The TestApplication type exposes the following members.
Fields
 | Name | Description
Protected field | m_ConfigRoot |
Protected field | m_ConfigSettings |
Protected field | m_InstanceID |
Back to Top
See Also
TestApplication Class
NFX.ApplicationModel Namespace


TestApplication.m_ConfigRoot Field

TestApplication m_ConfigRoot Field NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ConfigSectionNode m_ConfigRoot
protected ConfigSectionNode m_ConfigRoot
Protected m_ConfigRoot As ConfigSectionNode
Protected m_ConfigRoot As ConfigSectionNode
protected:
ConfigSectionNode^ m_ConfigRoot
protected:
ConfigSectionNode^ m_ConfigRoot
val mutable m_ConfigRoot: ConfigSectionNode
val mutable m_ConfigRoot: ConfigSectionNode

Field Value

Type: ConfigSectionNode
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.m_ConfigSettings Field

TestApplication m_ConfigSettings Field NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected List<IConfigSettings> m_ConfigSettings
protected List<IConfigSettings> m_ConfigSettings
Protected m_ConfigSettings As List(Of IConfigSettings)
Protected m_ConfigSettings As List(Of IConfigSettings)
protected:
List<IConfigSettings^>^ m_ConfigSettings
protected:
List<IConfigSettings^>^ m_ConfigSettings
val mutable m_ConfigSettings: List<IConfigSettings>
val mutable m_ConfigSettings: List<IConfigSettings>

Field Value

Type: Online List IConfigSettings
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.m_InstanceID Field

TestApplication m_InstanceID Field NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Guid m_InstanceID
protected Guid m_InstanceID
Protected m_InstanceID As Guid
Protected m_InstanceID As Guid
protected:
Guid m_InstanceID
protected:
Guid m_InstanceID
val mutable m_InstanceID: Guid
val mutable m_InstanceID: Guid

Field Value

Type: Online Guid
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication Methods

TestApplication Methods NFX Class Library

The TestApplication type exposes the following members.
Methods
 | Name | Description
Protected method | Destructor | Override this method to do actual destructor work (Inherited from DisposableObject.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime |
Public method | MakeNewSessionInstance |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NotifyAllConfigSettingsAboutChange | Forces notification of all registered IConfigSettings-implementers about configuration change
Protected method | NotifyAllConfigSettingsAboutChange(IConfigSectionNode) | Forces notification of all registered IConfigSettings-implementers about configuration change
Public method | RegisterAppFinishNotifiable |
Public method | RegisterConfigSettings | Registers an instance of IConfigSettings with application container to receive a call when underlying app configuration changes
Public method | Stop |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime |
Public method | UnregisterAppFinishNotifiable |
Public method | UnregisterConfigSettings | Removes the registration of IConfigSettings from application container
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TestApplication Class
NFX.ApplicationModel Namespace


TestApplication.LocalizedTimeToUniversalTime Method

TestApplication LocalizedTimeToUniversalTime Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
public DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
Public Function LocalizedTimeToUniversalTime (
    local As DateTime
) As DateTime
Public Function LocalizedTimeToUniversalTime (
    local As DateTime
) As DateTime
public:
virtual DateTime LocalizedTimeToUniversalTime(
    DateTime local
) sealed
public:
virtual DateTime LocalizedTimeToUniversalTime(
    DateTime local
) sealed
abstract LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
override LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
abstract LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
override LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime

Parameters

local
Type: Online System DateTime

Return Value

Type: Online DateTime

Implements

ILocalizedTimeProvider LocalizedTimeToUniversalTime(DateTime)
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.MakeNewSessionInstance Method

TestApplication MakeNewSessionInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual ISession MakeNewSessionInstance(
    Guid sessionID,
    User user = null
)
public virtual ISession MakeNewSessionInstance(
    Guid sessionID,
    User user = null
)
Public Overridable Function MakeNewSessionInstance (
    sessionID As Guid,
    Optional user As User = Nothing
) As ISession
Public Overridable Function MakeNewSessionInstance (
    sessionID As Guid,
    Optional user As User = Nothing
) As ISession
public:
virtual ISession^ MakeNewSessionInstance(
    Guid sessionID,
    User^ user = nullptr
)
public:
virtual ISession^ MakeNewSessionInstance(
    Guid sessionID,
    User^ user = nullptr
)
abstract MakeNewSessionInstance :
        sessionID : Guid *
        ?user : User
(* Defaults:
        let _user = defaultArg user null
*)
-> ISession
override MakeNewSessionInstance :
        sessionID : Guid *
        ?user : User
(* Defaults:
        let _user = defaultArg user null
*)
-> ISession
abstract MakeNewSessionInstance :
        sessionID : Guid *
        ?user : User
(* Defaults:
        let _user = defaultArg user null
*)
-> ISession
override MakeNewSessionInstance :
        sessionID : Guid *
        ?user : User
(* Defaults:
        let _user = defaultArg user null
*)
-> ISession

Parameters

sessionID
Type: Online System Guid
user (Optional)
Type: NFX.Security User

Return Value

Type: ISession

Implements

IApplication MakeNewSessionInstance(Guid, User)
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.NotifyAllConfigSettingsAboutChange Method

TestApplication NotifyAllConfigSettingsAboutChange Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public method | NotifyAllConfigSettingsAboutChange | Forces notification of all registered IConfigSettings-implementers about configuration change
Protected method | NotifyAllConfigSettingsAboutChange(IConfigSectionNode) | Forces notification of all registered IConfigSettings-implementers about configuration change
Back to Top
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.NotifyAllConfigSettingsAboutChange Method

TestApplication NotifyAllConfigSettingsAboutChange Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Forces notification of all registered IConfigSettings-implementers about configuration change

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void NotifyAllConfigSettingsAboutChange()
public virtual void NotifyAllConfigSettingsAboutChange()
Public Overridable Sub NotifyAllConfigSettingsAboutChange
Public Overridable Sub NotifyAllConfigSettingsAboutChange
public:
virtual void NotifyAllConfigSettingsAboutChange()
public:
virtual void NotifyAllConfigSettingsAboutChange()
abstract NotifyAllConfigSettingsAboutChange : unit -> unit
override NotifyAllConfigSettingsAboutChange : unit -> unit
abstract NotifyAllConfigSettingsAboutChange : unit -> unit
override NotifyAllConfigSettingsAboutChange : unit -> unit

Implements

IApplication NotifyAllConfigSettingsAboutChange
See Also
TestApplication Class
TestApplication Members
NotifyAllConfigSettingsAboutChange Overload
NFX.ApplicationModel Namespace


TestApplication.NotifyAllConfigSettingsAboutChange Method (IConfigSectionNode)

TestApplication NotifyAllConfigSettingsAboutChange Method (IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Forces notification of all registered IConfigSettings-implementers about configuration change

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void NotifyAllConfigSettingsAboutChange(
    IConfigSectionNode node
)
protected void NotifyAllConfigSettingsAboutChange(
    IConfigSectionNode node
)
Protected Sub NotifyAllConfigSettingsAboutChange (
    node As IConfigSectionNode
)
Protected Sub NotifyAllConfigSettingsAboutChange (
    node As IConfigSectionNode
)
protected:
void NotifyAllConfigSettingsAboutChange(
    IConfigSectionNode^ node
)
protected:
void NotifyAllConfigSettingsAboutChange(
    IConfigSectionNode^ node
)
member NotifyAllConfigSettingsAboutChange :
        node : IConfigSectionNode -> unit
member NotifyAllConfigSettingsAboutChange :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
TestApplication Class
TestApplication Members
NotifyAllConfigSettingsAboutChange Overload
NFX.ApplicationModel Namespace


TestApplication.RegisterAppFinishNotifiable Method

TestApplication RegisterAppFinishNotifiable Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool RegisterAppFinishNotifiable(
    IApplicationFinishNotifiable notifiable
)
public bool RegisterAppFinishNotifiable(
    IApplicationFinishNotifiable notifiable
)
Public Function RegisterAppFinishNotifiable (
    notifiable As IApplicationFinishNotifiable
) As Boolean
Public Function RegisterAppFinishNotifiable (
    notifiable As IApplicationFinishNotifiable
) As Boolean
public:
virtual bool RegisterAppFinishNotifiable(
    IApplicationFinishNotifiable^ notifiable
) sealed
public:
virtual bool RegisterAppFinishNotifiable(
    IApplicationFinishNotifiable^ notifiable
) sealed
abstract RegisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool
override RegisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool
abstract RegisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool
override RegisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool

Parameters

notifiable
Type: NFX.ApplicationModel IApplicationFinishNotifiable

Return Value

Type: Online Boolean

Implements

IApplication RegisterAppFinishNotifiable(IApplicationFinishNotifiable)
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.RegisterConfigSettings Method

TestApplication RegisterConfigSettings Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Registers an instance of IConfigSettings with application container to receive a call when underlying app configuration changes

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool RegisterConfigSettings(
    IConfigSettings settings
)
public virtual bool RegisterConfigSettings(
    IConfigSettings settings
)
Public Overridable Function RegisterConfigSettings (
    settings As IConfigSettings
) As Boolean
Public Overridable Function RegisterConfigSettings (
    settings As IConfigSettings
) As Boolean
public:
virtual bool RegisterConfigSettings(
    IConfigSettings^ settings
)
public:
virtual bool RegisterConfigSettings(
    IConfigSettings^ settings
)
abstract RegisterConfigSettings :
        settings : IConfigSettings -> bool
override RegisterConfigSettings :
        settings : IConfigSettings -> bool
abstract RegisterConfigSettings :
        settings : IConfigSettings -> bool
override RegisterConfigSettings :
        settings : IConfigSettings -> bool

Parameters

settings
Type: NFX.Environment IConfigSettings

Return Value

Type: Online Boolean

Implements

IApplication RegisterConfigSettings(IConfigSettings)
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.Stop Method

TestApplication Stop Method NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Stop()
public void Stop()
Public Sub Stop
Public Sub Stop
public:
virtual void Stop() sealed
public:
virtual void Stop() sealed
abstract Stop : unit -> unit
override Stop : unit -> unit
abstract Stop : unit -> unit
override Stop : unit -> unit

Implements

IApplication Stop
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.UniversalTimeToLocalizedTime Method

TestApplication UniversalTimeToLocalizedTime Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
public DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
Public Function UniversalTimeToLocalizedTime (
    utc As DateTime
) As DateTime
Public Function UniversalTimeToLocalizedTime (
    utc As DateTime
) As DateTime
public:
virtual DateTime UniversalTimeToLocalizedTime(
    DateTime utc
) sealed
public:
virtual DateTime UniversalTimeToLocalizedTime(
    DateTime utc
) sealed
abstract UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
override UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
abstract UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
override UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime

Parameters

utc
Type: Online System DateTime

Return Value

Type: Online DateTime

Implements

ILocalizedTimeProvider UniversalTimeToLocalizedTime(DateTime)
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.UnregisterAppFinishNotifiable Method

TestApplication UnregisterAppFinishNotifiable Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool UnregisterAppFinishNotifiable(
    IApplicationFinishNotifiable notifiable
)
public bool UnregisterAppFinishNotifiable(
    IApplicationFinishNotifiable notifiable
)
Public Function UnregisterAppFinishNotifiable (
    notifiable As IApplicationFinishNotifiable
) As Boolean
Public Function UnregisterAppFinishNotifiable (
    notifiable As IApplicationFinishNotifiable
) As Boolean
public:
virtual bool UnregisterAppFinishNotifiable(
    IApplicationFinishNotifiable^ notifiable
) sealed
public:
virtual bool UnregisterAppFinishNotifiable(
    IApplicationFinishNotifiable^ notifiable
) sealed
abstract UnregisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool
override UnregisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool
abstract UnregisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool
override UnregisterAppFinishNotifiable :
        notifiable : IApplicationFinishNotifiable -> bool

Parameters

notifiable
Type: NFX.ApplicationModel IApplicationFinishNotifiable

Return Value

Type: Online Boolean

Implements

IApplication UnregisterAppFinishNotifiable(IApplicationFinishNotifiable)
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.UnregisterConfigSettings Method

TestApplication UnregisterConfigSettings Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Removes the registration of IConfigSettings from application container

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool UnregisterConfigSettings(
    IConfigSettings settings
)
public virtual bool UnregisterConfigSettings(
    IConfigSettings settings
)
Public Overridable Function UnregisterConfigSettings (
    settings As IConfigSettings
) As Boolean
Public Overridable Function UnregisterConfigSettings (
    settings As IConfigSettings
) As Boolean
public:
virtual bool UnregisterConfigSettings(
    IConfigSettings^ settings
)
public:
virtual bool UnregisterConfigSettings(
    IConfigSettings^ settings
)
abstract UnregisterConfigSettings :
        settings : IConfigSettings -> bool
override UnregisterConfigSettings :
        settings : IConfigSettings -> bool
abstract UnregisterConfigSettings :
        settings : IConfigSettings -> bool
override UnregisterConfigSettings :
        settings : IConfigSettings -> bool

Parameters

settings
Type: NFX.Environment IConfigSettings

Return Value

Type: Online Boolean
True if settings instance was found and removed

Implements

IApplication UnregisterConfigSettings(IConfigSettings)
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication Properties

TestApplication Properties NFX Class Library

The TestApplication type exposes the following members.
Properties
 | Name | Description
Public property | Active |
Public property | ConfigRoot |
Public property | DataStore |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EventTimer |
Public property | Glue |
Public property | InstanceID |
Public property | Instrumentation |
Public property | IsUnitTest |
Public property | LocalizedTime |
Public property | Log |
Public property | Name |
Public property | ObjectStore |
Public property | SecurityManager |
Public property | ShutdownStarted |
Public property | StartTime |
Public property | Stopping |
Public property | Throttling |
Public property | TimeLocation |
Public property | TimeSource |
Back to Top
See Also
TestApplication Class
NFX.ApplicationModel Namespace


TestApplication.Active Property

TestApplication Active Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Active { get; set; }
public virtual bool Active { get; set; }
Public Overridable Property Active As Boolean
    Get
    Set
Public Overridable Property Active As Boolean
    Get
    Set
public:
virtual property bool Active {
    bool get ();
    void set (bool value);
}
public:
virtual property bool Active {
    bool get ();
    void set (bool value);
}
abstract Active : bool with get, set
override Active : bool with get, set
abstract Active : bool with get, set
override Active : bool with get, set

Property Value

Type: Online Boolean

Implements

IApplication Active
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.ConfigRoot Property

TestApplication ConfigRoot Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual ConfigSectionNode ConfigRoot { get; set; }
public virtual ConfigSectionNode ConfigRoot { get; set; }
Public Overridable Property ConfigRoot As ConfigSectionNode
    Get
    Set
Public Overridable Property ConfigRoot As ConfigSectionNode
    Get
    Set
public:
virtual property ConfigSectionNode^ ConfigRoot {
    ConfigSectionNode^ get ();
    void set (ConfigSectionNode^ value);
}
public:
virtual property ConfigSectionNode^ ConfigRoot {
    ConfigSectionNode^ get ();
    void set (ConfigSectionNode^ value);
}
abstract ConfigRoot : ConfigSectionNode with get, set
override ConfigRoot : ConfigSectionNode with get, set
abstract ConfigRoot : ConfigSectionNode with get, set
override ConfigRoot : ConfigSectionNode with get, set

Property Value

Type: ConfigSectionNode

Implements

IApplication ConfigRoot
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.DataStore Property

TestApplication DataStore Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IDataStore DataStore { get; set; }
public virtual IDataStore DataStore { get; set; }
Public Overridable Property DataStore As IDataStore
    Get
    Set
Public Overridable Property DataStore As IDataStore
    Get
    Set
public:
virtual property IDataStore^ DataStore {
    IDataStore^ get ();
    void set (IDataStore^ value);
}
public:
virtual property IDataStore^ DataStore {
    IDataStore^ get ();
    void set (IDataStore^ value);
}
abstract DataStore : IDataStore with get, set
override DataStore : IDataStore with get, set
abstract DataStore : IDataStore with get, set
override DataStore : IDataStore with get, set

Property Value

Type: IDataStore

Implements

IApplication DataStore
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.EventTimer Property

TestApplication EventTimer Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IEventTimer EventTimer { get; set; }
public virtual IEventTimer EventTimer { get; set; }
Public Overridable Property EventTimer As IEventTimer
    Get
    Set
Public Overridable Property EventTimer As IEventTimer
    Get
    Set
public:
virtual property IEventTimer^ EventTimer {
    IEventTimer^ get ();
    void set (IEventTimer^ value);
}
public:
virtual property IEventTimer^ EventTimer {
    IEventTimer^ get ();
    void set (IEventTimer^ value);
}
abstract EventTimer : IEventTimer with get, set
override EventTimer : IEventTimer with get, set
abstract EventTimer : IEventTimer with get, set
override EventTimer : IEventTimer with get, set

Property Value

Type: IEventTimer

Implements

IApplication EventTimer
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.Glue Property

TestApplication Glue Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IGlue Glue { get; set; }
public virtual IGlue Glue { get; set; }
Public Overridable Property Glue As IGlue
    Get
    Set
Public Overridable Property Glue As IGlue
    Get
    Set
public:
virtual property IGlue^ Glue {
    IGlue^ get ();
    void set (IGlue^ value);
}
public:
virtual property IGlue^ Glue {
    IGlue^ get ();
    void set (IGlue^ value);
}
abstract Glue : IGlue with get, set
override Glue : IGlue with get, set
abstract Glue : IGlue with get, set
override Glue : IGlue with get, set

Property Value

Type: IGlue

Implements

IApplication Glue
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.InstanceID Property

TestApplication InstanceID Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Guid InstanceID { get; }
public virtual Guid InstanceID { get; }
Public Overridable ReadOnly Property InstanceID As Guid
    Get
Public Overridable ReadOnly Property InstanceID As Guid
    Get
public:
virtual property Guid InstanceID {
    Guid get ();
}
public:
virtual property Guid InstanceID {
    Guid get ();
}
abstract InstanceID : Guid with get
override InstanceID : Guid with get
abstract InstanceID : Guid with get
override InstanceID : Guid with get

Property Value

Type: Online Guid

Implements

IApplication InstanceID
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.Instrumentation Property

TestApplication Instrumentation Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IInstrumentation Instrumentation { get; set; }
public virtual IInstrumentation Instrumentation { get; set; }
Public Overridable Property Instrumentation As IInstrumentation
    Get
    Set
Public Overridable Property Instrumentation As IInstrumentation
    Get
    Set
public:
virtual property IInstrumentation^ Instrumentation {
    IInstrumentation^ get ();
    void set (IInstrumentation^ value);
}
public:
virtual property IInstrumentation^ Instrumentation {
    IInstrumentation^ get ();
    void set (IInstrumentation^ value);
}
abstract Instrumentation : IInstrumentation with get, set
override Instrumentation : IInstrumentation with get, set
abstract Instrumentation : IInstrumentation with get, set
override Instrumentation : IInstrumentation with get, set

Property Value

Type: IInstrumentation

Implements

IApplication Instrumentation
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.IsUnitTest Property

TestApplication IsUnitTest Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IsUnitTest { get; set; }
public virtual bool IsUnitTest { get; set; }
Public Overridable Property IsUnitTest As Boolean
    Get
    Set
Public Overridable Property IsUnitTest As Boolean
    Get
    Set
public:
virtual property bool IsUnitTest {
    bool get ();
    void set (bool value);
}
public:
virtual property bool IsUnitTest {
    bool get ();
    void set (bool value);
}
abstract IsUnitTest : bool with get, set
override IsUnitTest : bool with get, set
abstract IsUnitTest : bool with get, set
override IsUnitTest : bool with get, set

Property Value

Type: Online Boolean

Implements

IApplication IsUnitTest
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.LocalizedTime Property

TestApplication LocalizedTime Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual DateTime LocalizedTime { get; set; }
public virtual DateTime LocalizedTime { get; set; }
Public Overridable Property LocalizedTime As DateTime
    Get
    Set
Public Overridable Property LocalizedTime As DateTime
    Get
    Set
public:
virtual property DateTime LocalizedTime {
    DateTime get ();
    void set (DateTime value);
}
public:
virtual property DateTime LocalizedTime {
    DateTime get ();
    void set (DateTime value);
}
abstract LocalizedTime : DateTime with get, set
override LocalizedTime : DateTime with get, set
abstract LocalizedTime : DateTime with get, set
override LocalizedTime : DateTime with get, set

Property Value

Type: Online DateTime

Implements

ILocalizedTimeProvider LocalizedTime
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.Log Property

TestApplication Log Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual ILog Log { get; set; }
public virtual ILog Log { get; set; }
Public Overridable Property Log As ILog
    Get
    Set
Public Overridable Property Log As ILog
    Get
    Set
public:
virtual property ILog^ Log {
    ILog^ get ();
    void set (ILog^ value);
}
public:
virtual property ILog^ Log {
    ILog^ get ();
    void set (ILog^ value);
}
abstract Log : ILog with get, set
override Log : ILog with get, set
abstract Log : ILog with get, set
override Log : ILog with get, set

Property Value

Type: ILog

Implements

IApplication Log
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.Name Property

TestApplication Name Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Name { get; set; }
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: Online String

Implements

INamed Name
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.ObjectStore Property

TestApplication ObjectStore Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IObjectStore ObjectStore { get; set; }
public virtual IObjectStore ObjectStore { get; set; }
Public Overridable Property ObjectStore As IObjectStore
    Get
    Set
Public Overridable Property ObjectStore As IObjectStore
    Get
    Set
public:
virtual property IObjectStore^ ObjectStore {
    IObjectStore^ get ();
    void set (IObjectStore^ value);
}
public:
virtual property IObjectStore^ ObjectStore {
    IObjectStore^ get ();
    void set (IObjectStore^ value);
}
abstract ObjectStore : IObjectStore with get, set
override ObjectStore : IObjectStore with get, set
abstract ObjectStore : IObjectStore with get, set
override ObjectStore : IObjectStore with get, set

Property Value

Type: IObjectStore

Implements

IApplication ObjectStore
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.SecurityManager Property

TestApplication SecurityManager Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual ISecurityManager SecurityManager { get; set; }
public virtual ISecurityManager SecurityManager { get; set; }
Public Overridable Property SecurityManager As ISecurityManager
    Get
    Set
Public Overridable Property SecurityManager As ISecurityManager
    Get
    Set
public:
virtual property ISecurityManager^ SecurityManager {
    ISecurityManager^ get ();
    void set (ISecurityManager^ value);
}
public:
virtual property ISecurityManager^ SecurityManager {
    ISecurityManager^ get ();
    void set (ISecurityManager^ value);
}
abstract SecurityManager : ISecurityManager with get, set
override SecurityManager : ISecurityManager with get, set
abstract SecurityManager : ISecurityManager with get, set
override SecurityManager : ISecurityManager with get, set

Property Value

Type: ISecurityManager

Implements

IApplication SecurityManager
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.ShutdownStarted Property

TestApplication ShutdownStarted Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool ShutdownStarted { get; set; }
public virtual bool ShutdownStarted { get; set; }
Public Overridable Property ShutdownStarted As Boolean
    Get
    Set
Public Overridable Property ShutdownStarted As Boolean
    Get
    Set
public:
virtual property bool ShutdownStarted {
    bool get ();
    void set (bool value);
}
public:
virtual property bool ShutdownStarted {
    bool get ();
    void set (bool value);
}
abstract ShutdownStarted : bool with get, set
override ShutdownStarted : bool with get, set
abstract ShutdownStarted : bool with get, set
override ShutdownStarted : bool with get, set

Property Value

Type: Online Boolean

Implements

IApplication ShutdownStarted
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.StartTime Property

TestApplication StartTime Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual DateTime StartTime { get; set; }
public virtual DateTime StartTime { get; set; }
Public Overridable Property StartTime As DateTime
    Get
    Set
Public Overridable Property StartTime As DateTime
    Get
    Set
public:
virtual property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
public:
virtual property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
abstract StartTime : DateTime with get, set
override StartTime : DateTime with get, set
abstract StartTime : DateTime with get, set
override StartTime : DateTime with get, set

Property Value

Type: Online DateTime

Implements

IApplication StartTime
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.Stopping Property

TestApplication Stopping Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Stopping { get; set; }
public virtual bool Stopping { get; set; }
Public Overridable Property Stopping As Boolean
    Get
    Set
Public Overridable Property Stopping As Boolean
    Get
    Set
public:
virtual property bool Stopping {
    bool get ();
    void set (bool value);
}
public:
virtual property bool Stopping {
    bool get ();
    void set (bool value);
}
abstract Stopping : bool with get, set
override Stopping : bool with get, set
abstract Stopping : bool with get, set
override Stopping : bool with get, set

Property Value

Type: Online Boolean

Implements

IApplication Stopping
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.Throttling Property

TestApplication Throttling Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IThrottling Throttling { get; set; }
public virtual IThrottling Throttling { get; set; }
Public Overridable Property Throttling As IThrottling
    Get
    Set
Public Overridable Property Throttling As IThrottling
    Get
    Set
public:
virtual property IThrottling^ Throttling {
    IThrottling^ get ();
    void set (IThrottling^ value);
}
public:
virtual property IThrottling^ Throttling {
    IThrottling^ get ();
    void set (IThrottling^ value);
}
abstract Throttling : IThrottling with get, set
override Throttling : IThrottling with get, set
abstract Throttling : IThrottling with get, set
override Throttling : IThrottling with get, set

Property Value

Type: IThrottling

Implements

IApplication Throttling
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.TimeLocation Property

TestApplication TimeLocation Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual TimeLocation TimeLocation { get; set; }
public virtual TimeLocation TimeLocation { get; set; }
Public Overridable Property TimeLocation As TimeLocation
    Get
    Set
Public Overridable Property TimeLocation As TimeLocation
    Get
    Set
public:
virtual property TimeLocation^ TimeLocation {
    TimeLocation^ get ();
    void set (TimeLocation^ value);
}
public:
virtual property TimeLocation^ TimeLocation {
    TimeLocation^ get ();
    void set (TimeLocation^ value);
}
abstract TimeLocation : TimeLocation with get, set
override TimeLocation : TimeLocation with get, set
abstract TimeLocation : TimeLocation with get, set
override TimeLocation : TimeLocation with get, set

Property Value

Type: TimeLocation

Implements

ILocalizedTimeProvider TimeLocation
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


TestApplication.TimeSource Property

TestApplication TimeSource Property NFX Class Library

Namespace: NFX.ApplicationModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual ITimeSource TimeSource { get; set; }
public virtual ITimeSource TimeSource { get; set; }
Public Overridable Property TimeSource As ITimeSource
    Get
    Set
Public Overridable Property TimeSource As ITimeSource
    Get
    Set
public:
virtual property ITimeSource^ TimeSource {
    ITimeSource^ get ();
    void set (ITimeSource^ value);
}
public:
virtual property ITimeSource^ TimeSource {
    ITimeSource^ get ();
    void set (ITimeSource^ value);
}
abstract TimeSource : ITimeSource with get, set
override TimeSource : ITimeSource with get, set
abstract TimeSource : ITimeSource with get, set
override TimeSource : ITimeSource with get, set

Property Value

Type: ITimeSource

Implements

IApplication TimeSource
See Also
TestApplication Class
TestApplication Members
NFX.ApplicationModel Namespace


NFX.ApplicationModel.Pile Namespace

NFX.ApplicationModel.Pile Namespace NFX Class Library

Classes
 | Class | Description
Public class | CacheExtensions | Provides read/write-through extensions
Public class | DefaultPile | Provides default implementation of IPile which stores objects on a local machine
Public class | LocalCache | Provides default implementation of a cache that stores the mapping locally. The mapped-to objects may reside in local or distributed pile as configured
Protected class | LocalCacheTable |
Protected class | LocalCacheTable TKey |
Public class | PileAccessViolationException | Thrown by pile memory manager when a supplied PilePointer is not pointing to a valid buffer
Public class | PileCacheException | Thrown by pile cache
Public class | PileException | Thrown by pile memory manager
Public class | PileOutOfSpaceException | Thrown by pile memory manager when there is not anough room in the pile to perform the requested operation
Public class | TableOptions | Provides config options for cache tables
Structures
 | Structure | Description
Public structure | Dated2GDIDWithISOKey | Represents a date (not time)-sensitive value-type 2 GDIDs+3 char ISO code tuple, suitable for serving as a cache table key. The point of this structure is to avoid creation of references for Pile cache so keys alone do not stall the GC. The ISO code is case-insensitive
Public structure | DatedGDIDWithISOKey | Represents a date (not time)-sensitive value-type GDID+3 char ISO code tuple, suitable for serving as a cache table key. The point of this structure is to avoid creation of references for Pile cache so keys alone do not stall the GC. The ISO code is case-insensitive
Public structure | DefaultPile SegmentCrawlStatus | Holds information obtained after a segment crawl
Public structure | GDIDWithInt | Represents GDID with int
Public structure | GDIDWithISOKey | Represents a value-type GDID+3 char ISO code tuple, suitable for serving as a cache table key. The point of this structure is to avoid creation of references for Pile cache so keys alone do not stall the GC. The ISO code is case-insensitive
Public structure | GDIDWithStrHash | Represents a GDID with 8 byte string hash. The hash is case sensitive. The point of this structure is to avoid creation of references for Pile cache so keys alone do not stall the GC.
Public structure | PilePointer | Represents a pointer to the pile object (object stored in a pile). The reference may be local or distributed in which case the NodeID is>=0. Distributed pointers are very useful for organizing piles of objects distributed among many servers, for example for "Big Memory" implementations or large neural networks where nodes may inter-connect between servers. The CLR reference to the IPile is not a part of this struct for performance and practicality reasons, as it is highly unlikely that there are going to be more than one instance of a pile in a process, however should more than 1 pile be allocated than this pointer would need to be wrapped in some other structure along with source IPile reference
Public structure | TwoGDIDWithISOKey | Represents a value-type 2 GDIDs+3 char ISO code tuple, suitable for serving as a cache table key. The point of this structure is to avoid creation of references for Pile cache so keys alone do not stall the GC. The ISO code is case-insensitive
Interfaces
Interface | Description
Public interface ICache
Represents a cache of expiring objects, which are identified by a key and stored in a pile. Pile allows to store hundreds of millions of objects without overloading the managed GC. The cache may be local or distributed
Public interface | ICacheImplementation
Public interface | ICacheTable
Public interface | ICacheTable TKey
Public interface IPile
Represents a pile of objects - a custom memory heap that can store native CLR objects in a tightly-serialized form. Piles can be either local (allocate local RAM on the server), or distributed (allocate RAM on many servers). This class is designed primarily for applications that need to store/cache very many (100s of millions on local, billions on distributed) of objects in RAM (and/or possibly on disk) without causing the local CLR's GC scans of huge object graphs. Implementors of this interface are custom memory managers that favor the GC performance in apps with many objects at the cost of higher CPU usage. The implementor must be thread-safe for all operations unless stated otherwise on a member level. The memory represented by this class as a whole is not synchronizable, that is - it does not support functions like Interlocked-family, Lock, MemoryBarriers and the like that regular RAM supports. Should a need arise to interlock within the pile - a custom CLR-based lock must be used to syncronize access to pile as a whole, for example: a Get does not impose a lock on ALL concurrent writes throught the pile (a write does not block all gets either).
Public interface | IPileImplementation
Public interface IPileStatus
Provides information about the pile - number of objects, allocated bytes, etc.
Enumerations
 | Enumeration | Description
Public enumeration | AllocationMode | Defines modes of allocation: space/time tradeoff
Public enumeration | LocalityKind | Indicates where pile implementation stores data: local vs distributed
Public enumeration | ObjectPersistence | Denotes modes of object persistence
Public enumeration | PutResult | Denotes statuses of cache table Put


AllocationMode Enumeration

AllocationMode Enumeration NFX Class Library

Defines modes of allocation: space/time tradeoff

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum AllocationMode
public enum AllocationMode
Public Enumeration AllocationMode
Public Enumeration AllocationMode
public enum class AllocationMode
public enum class AllocationMode
type AllocationMode
type AllocationMode
Members
Member name | Value | Description
ReuseSpace | 0 | The pile will try to reuse ram at the cost of possibly slower allocations
FavorSpeed | 1 | The pile may use more ram in some cases but allocate faster
See Also
NFX.ApplicationModel.Pile Namespace


CacheExtensions Class

CacheExtensions Class NFX Class Library

Provides read/write-through extensions
Inheritance Hierarchy
Online System Object
NFX.ApplicationModel.Pile CacheExtensions

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class CacheExtensions
public static class CacheExtensions
<ExtensionAttribute>
Public NotInheritable Class CacheExtensions
<ExtensionAttribute>
Public NotInheritable Class CacheExtensions
[ExtensionAttribute]
public ref class CacheExtensions abstract sealed
[ExtensionAttribute]
public ref class CacheExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CacheExtensions =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CacheExtensions =  class end
See Also
CacheExtensions Members
NFX.ApplicationModel.Pile Namespace


CacheExtensions Members

CacheExtensions Members NFX Class Library

The CacheExtensions type exposes the following members.
Methods
Name | Description
DeleteThrough TKey |
FetchFrom TKey, TResult | Fetches an existing item from cache or null. IsAbsent is true when data was read from cache as an AbsentValue
FetchThrough TKey, TResult | Fetches an item through cache
SaveThrough TKey, TData |
Back to Top
See Also
CacheExtensions Class
NFX.ApplicationModel.Pile Namespace


CacheExtensions Methods

CacheExtensions Methods NFX Class Library

The CacheExtensions type exposes the following members.
Methods
Name | Description
DeleteThrough TKey |
FetchFrom TKey, TResult | Fetches an existing item from cache or null. IsAbsent is true when data was read from cache as an AbsentValue
FetchThrough TKey, TResult | Fetches an item through cache
SaveThrough TKey, TData |
Back to Top
See Also
CacheExtensions Class
NFX.ApplicationModel.Pile Namespace


CacheExtensions.DeleteThrough(TKey) Method

CacheExtensions DeleteThrough TKey Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool DeleteThrough<TKey>(
    this ICache cache,
    TKey key,
    string tblCache,
    ICacheParams caching,
    Func<TKey, bool> fDelete
)
public static bool DeleteThrough<TKey>(
    this ICache cache,
    TKey key,
    string tblCache,
    ICacheParams caching,
    Func<TKey, bool> fDelete
)
<ExtensionAttribute>
Public Shared Function DeleteThrough(Of TKey) (
    cache As ICache,
    key As TKey,
    tblCache As String,
    caching As ICacheParams,
    fDelete As Func(Of TKey, Boolean)
) As Boolean
<ExtensionAttribute>
Public Shared Function DeleteThrough(Of TKey) (
    cache As ICache,
    key As TKey,
    tblCache As String,
    caching As ICacheParams,
    fDelete As Func(Of TKey, Boolean)
) As Boolean
public:
[ExtensionAttribute]
generic<typename TKey>
static bool DeleteThrough(
    ICache^ cache,
    TKey key,
    String^ tblCache,
    ICacheParams^ caching,
    Func<TKey, bool>^ fDelete
)
public:
[ExtensionAttribute]
generic<typename TKey>
static bool DeleteThrough(
    ICache^ cache,
    TKey key,
    String^ tblCache,
    ICacheParams^ caching,
    Func<TKey, bool>^ fDelete
)
static member DeleteThrough :
        cache : ICache *
        key : 'TKey *
        tblCache : string *
        caching : ICacheParams *
        fDelete : Func<'TKey, bool> -> bool
static member DeleteThrough :
        cache : ICache *
        key : 'TKey *
        tblCache : string *
        caching : ICacheParams *
        fDelete : Func<'TKey, bool> -> bool

Parameters

cache
Type: NFX.ApplicationModel.Pile ICache
key
Type: TKey
tblCache
Type: Online System String
caching
Type: NFX.DataAccess.CRUD ICacheParams
fDelete
Type: Online System Func TKey, Online Boolean
Type Parameters
TKey

Return Value

Type: Online Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ICache. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
CacheExtensions Class
CacheExtensions Members
NFX.ApplicationModel.Pile Namespace


CacheExtensions.FetchFrom(TKey, TResult) Method

CacheExtensions FetchFrom TKey, TResult Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Fetches an existing item from cache or null. IsAbsent is true when data was read from cache as an AbsentValue

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TResult FetchFrom<TKey, TResult>(
    this ICache cache,
    TKey key,
    string tblCache,
    ICacheParams caching,
    out bool isAbsent
)
where TResult : class
public static TResult FetchFrom<TKey, TResult>(
    this ICache cache,
    TKey key,
    string tblCache,
    ICacheParams caching,
    out bool isAbsent
)
where TResult : class
<ExtensionAttribute>
Public Shared Function FetchFrom(Of TKey, TResult As Class) (
    cache As ICache,
    key As TKey,
    tblCache As String,
    caching As ICacheParams,
    <OutAttribute> ByRef isAbsent As Boolean
) As TResult
<ExtensionAttribute>
Public Shared Function FetchFrom(Of TKey, TResult As Class) (
    cache As ICache,
    key As TKey,
    tblCache As String,
    caching As ICacheParams,
    <OutAttribute> ByRef isAbsent As Boolean
) As TResult
public:
[ExtensionAttribute]
generic<typename TKey, typename TResult>
where TResult : ref class
static TResult FetchFrom(
    ICache^ cache,
    TKey key,
    String^ tblCache,
    ICacheParams^ caching,
    [OutAttribute] bool% isAbsent
)
public:
[ExtensionAttribute]
generic<typename TKey, typename TResult>
where TResult : ref class
static TResult FetchFrom(
    ICache^ cache,
    TKey key,
    String^ tblCache,
    ICacheParams^ caching,
    [OutAttribute] bool% isAbsent
)
static member FetchFrom :
        cache : ICache *
        key : 'TKey *
        tblCache : string *
        caching : ICacheParams *
        isAbsent : bool byref -> 'TResult  when 'TResult : not struct
static member FetchFrom :
        cache : ICache *
        key : 'TKey *
        tblCache : string *
        caching : ICacheParams *
        isAbsent : bool byref -> 'TResult  when 'TResult : not struct

Parameters

cache
Type: NFX.ApplicationModel.Pile ICache
key
Type: TKey
tblCache
Type: Online System String
caching
Type: NFX.DataAccess.CRUD ICacheParams
isAbsent
Type: Online System Boolean
Type Parameters
TKey
TResult

Return Value

Type: TResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ICache. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
CacheExtensions Class
CacheExtensions Members
NFX.ApplicationModel.Pile Namespace


CacheExtensions.FetchThrough(TKey, TResult) Method

CacheExtensions FetchThrough TKey, TResult Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Fetches an item through cache

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TResult FetchThrough<TKey, TResult>(
    this ICache cache,
    TKey key,
    string tblCache,
    ICacheParams caching,
    Func<TKey, TResult> fFetch,
    Func<TKey, TResult, TResult> fFilter = null
)
where TResult : class
public static TResult FetchThrough<TKey, TResult>(
    this ICache cache,
    TKey key,
    string tblCache,
    ICacheParams caching,
    Func<TKey, TResult> fFetch,
    Func<TKey, TResult, TResult> fFilter = null
)
where TResult : class
<ExtensionAttribute>
Public Shared Function FetchThrough(Of TKey, TResult As Class) (
    cache As ICache,
    key As TKey,
    tblCache As String,
    caching As ICacheParams,
    fFetch As Func(Of TKey, TResult),
    Optional fFilter As Func(Of TKey, TResult, TResult) = Nothing
) As TResult
<ExtensionAttribute>
Public Shared Function FetchThrough(Of TKey, TResult As Class) (
    cache As ICache,
    key As TKey,
    tblCache As String,
    caching As ICacheParams,
    fFetch As Func(Of TKey, TResult),
    Optional fFilter As Func(Of TKey, TResult, TResult) = Nothing
) As TResult
public:
[ExtensionAttribute]
generic<typename TKey, typename TResult>
where TResult : ref class
static TResult FetchThrough(
    ICache^ cache,
    TKey key,
    String^ tblCache,
    ICacheParams^ caching,
    Func<TKey, TResult>^ fFetch,
    Func<TKey, TResult, TResult>^ fFilter = nullptr
)
public:
[ExtensionAttribute]
generic<typename TKey, typename TResult>
where TResult : ref class
static TResult FetchThrough(
    ICache^ cache,
    TKey key,
    String^ tblCache,
    ICacheParams^ caching,
    Func<TKey, TResult>^ fFetch,
    Func<TKey, TResult, TResult>^ fFilter = nullptr
)
static member FetchThrough :
        cache : ICache *
        key : 'TKey *
        tblCache : string *
        caching : ICacheParams *
        fFetch : Func<'TKey, 'TResult> *
        ?fFilter : Func<'TKey, 'TResult, 'TResult>
(* Defaults:
        let _fFilter = defaultArg fFilter null
*)
-> 'TResult  when 'TResult : not struct
static member FetchThrough :
        cache : ICache *
        key : 'TKey *
        tblCache : string *
        caching : ICacheParams *
        fFetch : Func<'TKey, 'TResult> *
        ?fFilter : Func<'TKey, 'TResult, 'TResult>
(* Defaults:
        let _fFilter = defaultArg fFilter null
*)
-> 'TResult  when 'TResult : not struct

Parameters

cache
Type: NFX.ApplicationModel.Pile ICache
key
Type: TKey
tblCache
Type: Online System String
caching
Type: NFX.DataAccess.CRUD ICacheParams
fFetch
Type: Online System Func TKey, TResult
fFilter (Optional)
Type: Online System Func TKey, TResult, TResult
Type Parameters
TKey
TResult

Return Value

Type: TResult

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ICache. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
CacheExtensions Class
CacheExtensions Members
NFX.ApplicationModel.Pile Namespace


CacheExtensions.SaveThrough(TKey, TData) Method

CacheExtensions SaveThrough TKey, TData Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int SaveThrough<TKey, TData>(
    this ICache cache,
    TKey key,
    TData data,
    string tblCache,
    ICacheParams caching,
    Func<TKey, TData, int> fSave
)
where TData : class
public static int SaveThrough<TKey, TData>(
    this ICache cache,
    TKey key,
    TData data,
    string tblCache,
    ICacheParams caching,
    Func<TKey, TData, int> fSave
)
where TData : class
<ExtensionAttribute>
Public Shared Function SaveThrough(Of TKey, TData As Class) (
    cache As ICache,
    key As TKey,
    data As TData,
    tblCache As String,
    caching As ICacheParams,
    fSave As Func(Of TKey, TData, Integer)
) As Integer
<ExtensionAttribute>
Public Shared Function SaveThrough(Of TKey, TData As Class) (
    cache As ICache,
    key As TKey,
    data As TData,
    tblCache As String,
    caching As ICacheParams,
    fSave As Func(Of TKey, TData, Integer)
) As Integer
public:
[ExtensionAttribute]
generic<typename TKey, typename TData>
where TData : ref class
static int SaveThrough(
    ICache^ cache,
    TKey key,
    TData data,
    String^ tblCache,
    ICacheParams^ caching,
    Func<TKey, TData, int>^ fSave
)
public:
[ExtensionAttribute]
generic<typename TKey, typename TData>
where TData : ref class
static int SaveThrough(
    ICache^ cache,
    TKey key,
    TData data,
    String^ tblCache,
    ICacheParams^ caching,
    Func<TKey, TData, int>^ fSave
)
static member SaveThrough :
        cache : ICache *
        key : 'TKey *
        data : 'TData *
        tblCache : string *
        caching : ICacheParams *
        fSave : Func<'TKey, 'TData, int> -> int  when 'TData : not struct
static member SaveThrough :
        cache : ICache *
        key : 'TKey *
        data : 'TData *
        tblCache : string *
        caching : ICacheParams *
        fSave : Func<'TKey, 'TData, int> -> int  when 'TData : not struct

Parameters

cache
Type: NFX.ApplicationModel.Pile ICache
key
Type: TKey
data
Type: TData
tblCache
Type: Online System String
caching
Type: NFX.DataAccess.CRUD ICacheParams
fSave
Type: Online System Func TKey, TData, Online Int32
Type Parameters
TKey
TData

Return Value

Type: Online Int32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ICache. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
CacheExtensions Class
CacheExtensions Members
NFX.ApplicationModel.Pile Namespace


Dated2GDIDWithISOKey Structure

Dated2GDIDWithISOKey Structure NFX Class Library

Represents a date (not time)-sensitive value-type 2 GDIDs+3 char ISO code tuple, suitable for serving as a cache table key. The point of this structure is to avoid creation of references for Pile cache so keys alone do not stall the GC. The ISO code is case-insensitive

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct Dated2GDIDWithISOKey : IDistributedStableHashProvider,
    IEquatable<Dated2GDIDWithISOKey>
public struct Dated2GDIDWithISOKey : IDistributedStableHashProvider,
    IEquatable<Dated2GDIDWithISOKey>
Public Structure Dated2GDIDWithISOKey
    Implements IDistributedStableHashProvider, IEquatable(Of Dated2GDIDWithISOKey)
Public Structure Dated2GDIDWithISOKey
    Implements IDistributedStableHashProvider, IEquatable(Of Dated2GDIDWithISOKey)
public value class Dated2GDIDWithISOKey : IDistributedStableHashProvider,
    IEquatable<Dated2GDIDWithISOKey>
public value class Dated2GDIDWithISOKey : IDistributedStableHashProvider,
    IEquatable<Dated2GDIDWithISOKey>
[<SealedAttribute>]
type Dated2GDIDWithISOKey =
    struct
        interface IDistributedStableHashProvider
        interface IEquatable<Dated2GDIDWithISOKey>
    end
[<SealedAttribute>]
type Dated2GDIDWithISOKey =
    struct
        interface IDistributedStableHashProvider
        interface IEquatable<Dated2GDIDWithISOKey>
    end
See Also
Dated2GDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


Dated2GDIDWithISOKey Members

Dated2GDIDWithISOKey Members NFX Class Library

The Dated2GDIDWithISOKey type exposes the following members.
Constructors
 | Name | Description
Public method | Dated2GDIDWithISOKey | Initializes a new instance of the Dated2GDIDWithISOKey class
Back to Top
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(Dated2GDIDWithISOKey) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDistributedStableHash |
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | GDID1 |
Public field | GDID2 |
Public field | ISO |
Public field | YMD |
Back to Top
Properties
 | Name | Description
Public property | DateTime |
Public property | ISOCode |
Back to Top
See Also
Dated2GDIDWithISOKey Structure
NFX.ApplicationModel.Pile Namespace


Dated2GDIDWithISOKey Constructor

Dated2GDIDWithISOKey Constructor NFX Class Library

Initializes a new instance of the Dated2GDIDWithISOKey class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Dated2GDIDWithISOKey(
    DateTime date,
    GDID gdid1,
    GDID gdid2,
    string iso
)
public Dated2GDIDWithISOKey(
    DateTime date,
    GDID gdid1,
    GDID gdid2,
    string iso
)
Public Sub New (
    date As DateTime,
    gdid1 As GDID,
    gdid2 As GDID,
    iso As String
)
Public Sub New (
    date As DateTime,
    gdid1 As GDID,
    gdid2 As GDID,
    iso As String
)
public:
Dated2GDIDWithISOKey(
    DateTime date,
    GDID gdid1,
    GDID gdid2,
    String^ iso
)
public:
Dated2GDIDWithISOKey(
    DateTime date,
    GDID gdid1,
    GDID gdid2,
    String^ iso
)
new :
        date : DateTime *
        gdid1 : GDID *
        gdid2 : GDID *
        iso : string -> Dated2GDIDWithISOKey
new :
        date : DateTime *
        gdid1 : GDID *
        gdid2 : GDID *
        iso : string -> Dated2GDIDWithISOKey

Parameters

date
Type: Online System DateTime
gdid1
Type: NFX.DataAccess.Distributed GDID
gdid2
Type: NFX.DataAccess.Distributed GDID
iso
Type: Online System String
See Also
Dated2GDIDWithISOKey Structure
Dated2GDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


Dated2GDIDWithISOKey Fields

Dated2GDIDWithISOKey Fields NFX Class Library

The Dated2GDIDWithISOKey type exposes the following members.
Fields
 | Name | Description
Public field | GDID1 |
Public field | GDID2 |
Public field | ISO |
Public field | YMD |
Back to Top
See Also
Dated2GDIDWithISOKey Structure
NFX.ApplicationModel.Pile Namespace


Dated2GDIDWithISOKey.GDID1 Field

Dated2GDIDWithISOKey GDID1 Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly GDID GDID1
public readonly GDID GDID1
Public ReadOnly GDID1 As GDID
Public ReadOnly GDID1 As GDID
public:
initonly GDID GDID1
public:
initonly GDID GDID1
val GDID1: GDID
val GDID1: GDID

Field Value

Type: GDID
See Also
Dated2GDIDWithISOKey Structure
Dated2GDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


Dated2GDIDWithISOKey.GDID2 Field

Dated2GDIDWithISOKey GDID2 Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly GDID GDID2
public readonly GDID GDID2
Public ReadOnly GDID2 As GDID
Public ReadOnly GDID2 As GDID
public:
initonly GDID GDID2
public:
initonly GDID GDID2
val GDID2: GDID
val GDID2: GDID

Field Value

Type: GDID
See Also
Dated2GDIDWithISOKey Structure
Dated2GDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


Dated2GDIDWithISOKey.ISO Field

Dated2GDIDWithISOKey ISO Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int ISO
public readonly int ISO
Public ReadOnly ISO As Integer
Public ReadOnly ISO As Integer
public:
initonly int ISO
public:
initonly int ISO
val ISO: int
val ISO: int

Field Value

Type: Online Int32
See Also
Dated2GDIDWithISOKey Structure
Dated2GDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


Dated2GDIDWithISOKey.YMD Field

Dated2GDIDWithISOKey YMD Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int YMD
public readonly int YMD
Public ReadOnly YMD As Integer
Public ReadOnly YMD As Integer
public:
initonly int YMD
public:
initonly int YMD
val YMD: int
val YMD: int

Field Value

Type: Online Int32
See Also
Dated2GDIDWithISOKey Structure
Dated2GDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


Dated2GDIDWithISOKey Methods

Dated2GDIDWithISOKey Methods NFX Class Library

The Dated2GDIDWithISOKey type exposes the following members.
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(Dated2GDIDWithISOKey) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDistributedStableHash |
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Dated2GDIDWithISOKey Structure
NFX.ApplicationModel.Pile Namespace


Dated2GDIDWithISOKey.Equals Method

Dated2GDIDWithISOKey Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(Dated2GDIDWithISOKey) |
Back to Top
See Also
Dated2GDIDWithISOKey Structure
Dated2GDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


Dated2GDIDWithISOKey.Equals Method (Object)

Dated2GDIDWithISOKey Equals Method (Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
Dated2GDIDWithISOKey Structure
Dated2GDIDWithISOKey Members
Equals Overload
NFX.ApplicationModel.Pile Namespace


Dated2GDIDWithISOKey.Equals Method (Dated2GDIDWithISOKey)

Dated2GDIDWithISOKey Equals Method (Dated2GDIDWithISOKey) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    Dated2GDIDWithISOKey other
)
public bool Equals(
    Dated2GDIDWithISOKey other
)
Public Function Equals (
    other As Dated2GDIDWithISOKey
) As Boolean
Public Function Equals (
    other As Dated2GDIDWithISOKey
) As Boolean
public:
virtual bool Equals(
    Dated2GDIDWithISOKey other
) sealed
public:
virtual bool Equals(
    Dated2GDIDWithISOKey other
) sealed
abstract Equals :
        other : Dated2GDIDWithISOKey -> bool
override Equals :
        other : Dated2GDIDWithISOKey -> bool
abstract Equals :
        other : Dated2GDIDWithISOKey -> bool
override Equals :
        other : Dated2GDIDWithISOKey -> bool

Parameters

other
Type: NFX.ApplicationModel.Pile Dated2GDIDWithISOKey

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
Dated2GDIDWithISOKey Structure
Dated2GDIDWithISOKey Members
Equals Overload
NFX.ApplicationModel.Pile Namespace


Dated2GDIDWithISOKey.GetDistributedStableHash Method

Dated2GDIDWithISOKey GetDistributedStableHash Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong GetDistributedStableHash()
public ulong GetDistributedStableHash()
Public Function GetDistributedStableHash As ULong
Public Function GetDistributedStableHash As ULong
public:
virtual unsigned long long GetDistributedStableHash() sealed
public:
virtual unsigned long long GetDistributedStableHash() sealed
abstract GetDistributedStableHash : unit -> uint64
override GetDistributedStableHash : unit -> uint64
abstract GetDistributedStableHash : unit -> uint64
override GetDistributedStableHash : unit -> uint64

Return Value

Type: Online UInt64

Implements

IDistributedStableHashProvider GetDistributedStableHash
See Also
Dated2GDIDWithISOKey Structure
Dated2GDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


Dated2GDIDWithISOKey.GetHashCode Method

Dated2GDIDWithISOKey GetHashCode Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
Dated2GDIDWithISOKey Structure
Dated2GDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


Dated2GDIDWithISOKey.ToString Method

Dated2GDIDWithISOKey ToString Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
Dated2GDIDWithISOKey Structure
Dated2GDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


Dated2GDIDWithISOKey Properties

Dated2GDIDWithISOKey Properties NFX Class Library

The Dated2GDIDWithISOKey type exposes the following members.
Properties
 | Name | Description
Public property | DateTime |
Public property | ISOCode |
Back to Top
See Also
Dated2GDIDWithISOKey Structure
NFX.ApplicationModel.Pile Namespace


Dated2GDIDWithISOKey.DateTime Property

Dated2GDIDWithISOKey DateTime Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime DateTime { get; }
public DateTime DateTime { get; }
Public ReadOnly Property DateTime As DateTime
    Get
Public ReadOnly Property DateTime As DateTime
    Get
public:
property DateTime DateTime {
    DateTime get ();
}
public:
property DateTime DateTime {
    DateTime get ();
}
member DateTime : DateTime with get
member DateTime : DateTime with get

Property Value

Type: Online DateTime
See Also
Dated2GDIDWithISOKey Structure
Dated2GDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


Dated2GDIDWithISOKey.ISOCode Property

Dated2GDIDWithISOKey ISOCode Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ISOCode { get; }
public string ISOCode { get; }
Public ReadOnly Property ISOCode As String
    Get
Public ReadOnly Property ISOCode As String
    Get
public:
property String^ ISOCode {
    String^ get ();
}
public:
property String^ ISOCode {
    String^ get ();
}
member ISOCode : string with get
member ISOCode : string with get

Property Value

Type: Online String
See Also
Dated2GDIDWithISOKey Structure
Dated2GDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


DatedGDIDWithISOKey Structure

DatedGDIDWithISOKey Structure NFX Class Library

Represents a date (not time)-sensitive value-type GDID+3 char ISO code tuple, suitable for serving as a cache table key. The point of this structure is to avoid creation of references for Pile cache so keys alone do not stall the GC. The ISO code is case-insensitive

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct DatedGDIDWithISOKey : IDistributedStableHashProvider,
    IEquatable<DatedGDIDWithISOKey>
public struct DatedGDIDWithISOKey : IDistributedStableHashProvider,
    IEquatable<DatedGDIDWithISOKey>
Public Structure DatedGDIDWithISOKey
    Implements IDistributedStableHashProvider, IEquatable(Of DatedGDIDWithISOKey)
Public Structure DatedGDIDWithISOKey
    Implements IDistributedStableHashProvider, IEquatable(Of DatedGDIDWithISOKey)
public value class DatedGDIDWithISOKey : IDistributedStableHashProvider,
    IEquatable<DatedGDIDWithISOKey>
public value class DatedGDIDWithISOKey : IDistributedStableHashProvider,
    IEquatable<DatedGDIDWithISOKey>
[<SealedAttribute>]
type DatedGDIDWithISOKey =
    struct
        interface IDistributedStableHashProvider
        interface IEquatable<DatedGDIDWithISOKey>
    end
[<SealedAttribute>]
type DatedGDIDWithISOKey =
    struct
        interface IDistributedStableHashProvider
        interface IEquatable<DatedGDIDWithISOKey>
    end
See Also
DatedGDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


DatedGDIDWithISOKey Members

DatedGDIDWithISOKey Members NFX Class Library

The DatedGDIDWithISOKey type exposes the following members.
Constructors
 | Name | Description
Public method | DatedGDIDWithISOKey | Initializes a new instance of the DatedGDIDWithISOKey class
Back to Top
Methods
 | Name | Description
 | DateToYMD |
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(DatedGDIDWithISOKey) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDistributedStableHash |
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
 | YMDtoDate |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | GDID |
Public field | ISO |
Public field | YMD |
Back to Top
Properties
 | Name | Description
Public property | DateTime |
Public property | ISOCode |
Back to Top
See Also
DatedGDIDWithISOKey Structure
NFX.ApplicationModel.Pile Namespace


DatedGDIDWithISOKey Constructor

DatedGDIDWithISOKey Constructor NFX Class Library

Initializes a new instance of the DatedGDIDWithISOKey class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DatedGDIDWithISOKey(
    DateTime date,
    GDID gdid,
    string iso
)
public DatedGDIDWithISOKey(
    DateTime date,
    GDID gdid,
    string iso
)
Public Sub New (
    date As DateTime,
    gdid As GDID,
    iso As String
)
Public Sub New (
    date As DateTime,
    gdid As GDID,
    iso As String
)
public:
DatedGDIDWithISOKey(
    DateTime date,
    GDID gdid,
    String^ iso
)
public:
DatedGDIDWithISOKey(
    DateTime date,
    GDID gdid,
    String^ iso
)
new :
        date : DateTime *
        gdid : GDID *
        iso : string -> DatedGDIDWithISOKey
new :
        date : DateTime *
        gdid : GDID *
        iso : string -> DatedGDIDWithISOKey

Parameters

date
Type: Online System DateTime
gdid
Type: NFX.DataAccess.Distributed GDID
iso
Type: Online System String
See Also
DatedGDIDWithISOKey Structure
DatedGDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


DatedGDIDWithISOKey Fields

DatedGDIDWithISOKey Fields NFX Class Library

The DatedGDIDWithISOKey type exposes the following members.
Fields
 | Name | Description
Public field | GDID |
Public field | ISO |
Public field | YMD |
Back to Top
See Also
DatedGDIDWithISOKey Structure
NFX.ApplicationModel.Pile Namespace


DatedGDIDWithISOKey.GDID Field

DatedGDIDWithISOKey GDID Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly GDID GDID
public readonly GDID GDID
Public ReadOnly GDID As GDID
Public ReadOnly GDID As GDID
public:
initonly GDID GDID
public:
initonly GDID GDID
val GDID: GDID
val GDID: GDID

Field Value

Type: GDID
See Also
DatedGDIDWithISOKey Structure
DatedGDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


DatedGDIDWithISOKey.ISO Field

DatedGDIDWithISOKey ISO Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int ISO
public readonly int ISO
Public ReadOnly ISO As Integer
Public ReadOnly ISO As Integer
public:
initonly int ISO
public:
initonly int ISO
val ISO: int
val ISO: int

Field Value

Type: Online Int32
See Also
DatedGDIDWithISOKey Structure
DatedGDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


DatedGDIDWithISOKey.YMD Field

DatedGDIDWithISOKey YMD Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int YMD
public readonly int YMD
Public ReadOnly YMD As Integer
Public ReadOnly YMD As Integer
public:
initonly int YMD
public:
initonly int YMD
val YMD: int
val YMD: int

Field Value

Type: Online Int32
See Also
DatedGDIDWithISOKey Structure
DatedGDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


DatedGDIDWithISOKey Methods

DatedGDIDWithISOKey Methods NFX Class Library

The DatedGDIDWithISOKey type exposes the following members.
Methods
 | Name | Description
 | DateToYMD |
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(DatedGDIDWithISOKey) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDistributedStableHash |
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
 | YMDtoDate |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
DatedGDIDWithISOKey Structure
NFX.ApplicationModel.Pile Namespace


DatedGDIDWithISOKey.DateToYMD Method

DatedGDIDWithISOKey DateToYMD Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static int DateToYMD(
    DateTime dt
)
internal static int DateToYMD(
    DateTime dt
)
Friend Shared Function DateToYMD (
    dt As DateTime
) As Integer
Friend Shared Function DateToYMD (
    dt As DateTime
) As Integer
internal:
static int DateToYMD(
    DateTime dt
)
internal:
static int DateToYMD(
    DateTime dt
)
internal static member DateToYMD :
        dt : DateTime -> int
internal static member DateToYMD :
        dt : DateTime -> int

Parameters

dt
Type: Online System DateTime

Return Value

Type: Online Int32
See Also
DatedGDIDWithISOKey Structure
DatedGDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


DatedGDIDWithISOKey.Equals Method

DatedGDIDWithISOKey Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(DatedGDIDWithISOKey) |
Back to Top
See Also
DatedGDIDWithISOKey Structure
DatedGDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


DatedGDIDWithISOKey.Equals Method (Object)

DatedGDIDWithISOKey Equals Method (Object) NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
DatedGDIDWithISOKey Structure
DatedGDIDWithISOKey Members
Equals Overload
NFX.ApplicationModel.Pile Namespace


DatedGDIDWithISOKey.Equals Method (DatedGDIDWithISOKey)

DatedGDIDWithISOKey Equals Method (DatedGDIDWithISOKey) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    DatedGDIDWithISOKey other
)
public bool Equals(
    DatedGDIDWithISOKey other
)
Public Function Equals (
    other As DatedGDIDWithISOKey
) As Boolean
Public Function Equals (
    other As DatedGDIDWithISOKey
) As Boolean
public:
virtual bool Equals(
    DatedGDIDWithISOKey other
) sealed
public:
virtual bool Equals(
    DatedGDIDWithISOKey other
) sealed
abstract Equals :
        other : DatedGDIDWithISOKey -> bool
override Equals :
        other : DatedGDIDWithISOKey -> bool
abstract Equals :
        other : DatedGDIDWithISOKey -> bool
override Equals :
        other : DatedGDIDWithISOKey -> bool

Parameters

other
Type: NFX.ApplicationModel.Pile DatedGDIDWithISOKey

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
DatedGDIDWithISOKey Structure
DatedGDIDWithISOKey Members
Equals Overload
NFX.ApplicationModel.Pile Namespace


DatedGDIDWithISOKey.GetDistributedStableHash Method

DatedGDIDWithISOKey GetDistributedStableHash Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong GetDistributedStableHash()
public ulong GetDistributedStableHash()
Public Function GetDistributedStableHash As ULong
Public Function GetDistributedStableHash As ULong
public:
virtual unsigned long long GetDistributedStableHash() sealed
public:
virtual unsigned long long GetDistributedStableHash() sealed
abstract GetDistributedStableHash : unit -> uint64
override GetDistributedStableHash : unit -> uint64
abstract GetDistributedStableHash : unit -> uint64
override GetDistributedStableHash : unit -> uint64

Return Value

Type: Online UInt64

Implements

IDistributedStableHashProvider GetDistributedStableHash
See Also
DatedGDIDWithISOKey Structure
DatedGDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


DatedGDIDWithISOKey.GetHashCode Method

DatedGDIDWithISOKey GetHashCode Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
DatedGDIDWithISOKey Structure
DatedGDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


DatedGDIDWithISOKey.ToString Method

DatedGDIDWithISOKey ToString Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
DatedGDIDWithISOKey Structure
DatedGDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


DatedGDIDWithISOKey.YMDtoDate Method

DatedGDIDWithISOKey YMDtoDate Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static DateTime YMDtoDate(
    int ymd
)
internal static DateTime YMDtoDate(
    int ymd
)
Friend Shared Function YMDtoDate (
    ymd As Integer
) As DateTime
Friend Shared Function YMDtoDate (
    ymd As Integer
) As DateTime
internal:
static DateTime YMDtoDate(
    int ymd
)
internal:
static DateTime YMDtoDate(
    int ymd
)
internal static member YMDtoDate :
        ymd : int -> DateTime
internal static member YMDtoDate :
        ymd : int -> DateTime

Parameters

ymd
Type: Online System Int32

Return Value

Type: Online DateTime
See Also
DatedGDIDWithISOKey Structure
DatedGDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


DatedGDIDWithISOKey Properties

DatedGDIDWithISOKey Properties NFX Class Library

The DatedGDIDWithISOKey type exposes the following members.
Properties
 | Name | Description
Public property | DateTime |
Public property | ISOCode |
Back to Top
See Also
DatedGDIDWithISOKey Structure
NFX.ApplicationModel.Pile Namespace


DatedGDIDWithISOKey.DateTime Property

DatedGDIDWithISOKey DateTime Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime DateTime { get; }
public DateTime DateTime { get; }
Public ReadOnly Property DateTime As DateTime
    Get
Public ReadOnly Property DateTime As DateTime
    Get
public:
property DateTime DateTime {
    DateTime get ();
}
public:
property DateTime DateTime {
    DateTime get ();
}
member DateTime : DateTime with get
member DateTime : DateTime with get

Property Value

Type: Online DateTime
See Also
DatedGDIDWithISOKey Structure
DatedGDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


DatedGDIDWithISOKey.ISOCode Property

DatedGDIDWithISOKey ISOCode Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ISOCode { get; }
public string ISOCode { get; }
Public ReadOnly Property ISOCode As String
    Get
Public ReadOnly Property ISOCode As String
    Get
public:
property String^ ISOCode {
    String^ get ();
}
public:
property String^ ISOCode {
    String^ get ();
}
member ISOCode : string with get
member ISOCode : string with get

Property Value

Type: Online String
See Also
DatedGDIDWithISOKey Structure
DatedGDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


DefaultPile Class

DefaultPile Class NFX Class Library

Provides default implementation of IPile which stores objects on a local machine
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service Online Object
NFX.ServiceModel ServiceWithInstrumentationBase Online Object
NFX.ApplicationModel.Pile DefaultPile

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class DefaultPile : ServiceWithInstrumentationBase<Object>,
    IPileImplementation, IPile, IPileStatus, IApplicationComponent, IDisposable,
    IService, INamed, IConfigurable, IInstrumentable, IExternallyParameterized
public sealed class DefaultPile : ServiceWithInstrumentationBase<Object>,
    IPileImplementation, IPile, IPileStatus, IApplicationComponent, IDisposable,
    IService, INamed, IConfigurable, IInstrumentable, IExternallyParameterized
Public NotInheritable Class DefaultPile
    Inherits ServiceWithInstrumentationBase(Of Object)
    Implements IPileImplementation, IPile, IPileStatus, IApplicationComponent,
    IDisposable, IService, INamed, IConfigurable, IInstrumentable,
    IExternallyParameterized
Public NotInheritable Class DefaultPile
    Inherits ServiceWithInstrumentationBase(Of Object)
    Implements IPileImplementation, IPile, IPileStatus, IApplicationComponent,
    IDisposable, IService, INamed, IConfigurable, IInstrumentable,
    IExternallyParameterized
public ref class DefaultPile sealed : public ServiceWithInstrumentationBase<Object^>,
    IPileImplementation, IPile, IPileStatus, IApplicationComponent, IDisposable,
    IService, INamed, IConfigurable, IInstrumentable, IExternallyParameterized
public ref class DefaultPile sealed : public ServiceWithInstrumentationBase<Object^>,
    IPileImplementation, IPile, IPileStatus, IApplicationComponent, IDisposable,
    IService, INamed, IConfigurable, IInstrumentable, IExternallyParameterized
[<SealedAttribute>]
type DefaultPile =
    class
        inherit ServiceWithInstrumentationBase<Object>
        interface IPileImplementation
        interface IPile
        interface IPileStatus
        interface IApplicationComponent
        interface IDisposable
        interface IService
        interface INamed
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
[<SealedAttribute>]
type DefaultPile =
    class
        inherit ServiceWithInstrumentationBase<Object>
        interface IPileImplementation
        interface IPile
        interface IPileStatus
        interface IApplicationComponent
        interface IDisposable
        interface IService
        interface INamed
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile Members

DefaultPile Members NFX Class Library

The DefaultPile type exposes the following members.
Constructors
 | Name | Description
Public method | DefaultPile(String) | Initializes a new instance of the DefaultPile class
Public method | DefaultPile(Object, String) | Initializes a new instance of the DefaultPile class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Compact |
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Public method | Crawl | Analyzes all segments scanning for free spaces. Returns number of uncovered free bytes. This is a full-blocking long operation that may take around 8 seconds on a 64Gb heaps in non-parallel mode
Public method | Delete | Deletes object from pile by its pointer returning true if there is no access violation and pointer is pointing to the valid object, throws otherwise unless throwInvalid is set to false
Protected method | Destructor | (Overrides Service Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | (Overrides Service DoAcceptManagerVisit(Object, DateTime).)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Get | Returns a CLR object by its pointer or throws access violation if pointer is invalid
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetRawBuffer | Returns a raw byte[] occupied by the object payload, only payload is returned along with serializer flag which tells what kind of serializer was used. This method is rarely used, it is needed for debugging and special-case "direct" memory access on read to bypass the de-serialization process altogether
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Purge |
Public method | Put | Puts a CLR object into the pile and returns a newly-allocated pointer. Throws out-of-space if there is not enough space in the pile and limits are set. Optional lifeSpanSec is ignored by this implementation
Public method | Rejuvenate |
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | SizeOf |
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_FREE_CHUNK_SIZES_ATTR |
CONFIG_PILE_SECTION |
FREE_CHUNK_SIZE_MIN |
FREE_LST_COUNT |
FREE_LST_SIZE_MAX |
FREE_LST_SIZE_MIN |
SEG_SIZE_DFLT |
SEG_SIZE_MAX |
SEG_SIZE_MIN |
Back to Top
Properties
 | Name | Description
Public property | AllocatedMemoryBytes | Returns the number of bytes allocated by this pile from the system memory heap. As pile pre-allocates memory in segments, it is absolutely normal to have this property return 100s of megabytes even when pile is almost empty. This property may return close to all physical memory available
Public property | AllocMode | Defines modes of allocation: space/time tradeoff
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | FreeChunkSizes | Sets the sizes of free chunks that free lists group by. Must be an array of FREE_LST_COUNT(16) of consequitively increasing integers
Public property | FreeListSize | Determines the size of free chunk list. Every segment has FREE_LST_COUNT=16 lists each of this size. This property may only be set on an inactive service instance
Public property | InstrumentationEnabled | Implements IInstrumentable (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | Locality | Returns PileLocality.Local
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | MaxMemoryLimit | Imposes a limit on maximum number of bytes that a pile can allocate of the system heap. The default value of 0 means no limit, meaning - the pile will keep allocating objects until the system allows. The value may not be less than minimum 1 seg size (64 mb). May set on an active instance, however no existing objects will be removed if the limit is exceeded
Public property | MaxSegmentLimit | Gets the maximum count of segments tha this pile can have. The property is not thread-safe for set and can only be set if pile is inactive. The value of zero means no limit
Public property | MemoryCapacityBytes | Returns an approximate capacity of free memory that the system has left
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | NodeCount | Returns 1 as this pile is not distributed
Public property | ObjectCount | Returns the total number of objects allocated at this point in time
Public property | OverheadBytes | Returns the number of extra bytes used by pile metadata currently occupied by object stored in this pile
Public property | Persistence | Returns PilePersistence.Memory
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | SegmentCount | Returns the total number of segments allocated at this point in time
Public property | SegmentSize | Gets the maximum segment size in bytes, up to (2^31)-1 The property is not thread-safe for set and can only be set if pile is inactive
Public property | SegmentTotalCount | Returns the total number of total segments - allocated and empty at this point in time. This number is greater or equal to SegmentCount
Public property | Status | Current service status (Inherited from Service.)
Public property | SupportsObjectExpiration | Returns false
Public property | SweepExpiredObjects | Returns false and does nothing on set in this implementation if they are set
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | UtilizedBytes | Returns the number of bytes currently occupied by object stored in this pile. This number is always less than AllocatedMemoryBytes
Back to Top
See Also
DefaultPile Class
NFX.ApplicationModel.Pile Namespace


DefaultPile Constructor

DefaultPile Constructor NFX Class Library

Overload List
 | Name | Description
Public method | DefaultPile(String) | Initializes a new instance of the DefaultPile class
Public method | DefaultPile(Object, String) | Initializes a new instance of the DefaultPile class
Back to Top
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile Constructor (String)

DefaultPile Constructor (String) NFX Class Library

Initializes a new instance of the DefaultPile class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DefaultPile(
    string name = null
)
public DefaultPile(
    string name = null
)
Public Sub New (
    Optional name As String = Nothing
)
Public Sub New (
    Optional name As String = Nothing
)
public:
DefaultPile(
    String^ name = nullptr
)
public:
DefaultPile(
    String^ name = nullptr
)
new :
        ?name : string
(* Defaults:
        let _name = defaultArg name null
*)
-> DefaultPile
new :
        ?name : string
(* Defaults:
        let _name = defaultArg name null
*)
-> DefaultPile

Parameters

name (Optional)
Type: Online System String
See Also
DefaultPile Class
DefaultPile Members
DefaultPile Overload
NFX.ApplicationModel.Pile Namespace


DefaultPile Constructor (Object, String)

DefaultPile Constructor (Object, String) NFX Class Library

Initializes a new instance of the DefaultPile class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DefaultPile(
    Object director,
    string name = null
)
public DefaultPile(
    Object director,
    string name = null
)
Public Sub New (
    director As Object,
    Optional name As String = Nothing
)
Public Sub New (
    director As Object,
    Optional name As String = Nothing
)
public:
DefaultPile(
    Object^ director,
    String^ name = nullptr
)
public:
DefaultPile(
    Object^ director,
    String^ name = nullptr
)
new :
        director : Object *
        ?name : string
(* Defaults:
        let _name = defaultArg name null
*)
-> DefaultPile
new :
        director : Object *
        ?name : string
(* Defaults:
        let _name = defaultArg name null
*)
-> DefaultPile

Parameters

director
Type: Online System Object
name (Optional)
Type: Online System String
See Also
DefaultPile Class
DefaultPile Members
DefaultPile Overload
NFX.ApplicationModel.Pile Namespace


DefaultPile Fields

DefaultPile Fields NFX Class Library

The DefaultPile type exposes the following members.
Fields
Name | Description
CONFIG_FREE_CHUNK_SIZES_ATTR |
CONFIG_PILE_SECTION |
FREE_CHUNK_SIZE_MIN |
FREE_LST_COUNT |
FREE_LST_SIZE_MAX |
FREE_LST_SIZE_MIN |
SEG_SIZE_DFLT |
SEG_SIZE_MAX |
SEG_SIZE_MIN |
Back to Top
See Also
DefaultPile Class
NFX.ApplicationModel.Pile Namespace


DefaultPile.CONFIG_FREE_CHUNK_SIZES_ATTR Field

DefaultPile CONFIG_FREE_CHUNK_SIZES_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_FREE_CHUNK_SIZES_ATTR
public const string CONFIG_FREE_CHUNK_SIZES_ATTR
Public Const CONFIG_FREE_CHUNK_SIZES_ATTR As String
Public Const CONFIG_FREE_CHUNK_SIZES_ATTR As String
public:
literal String^ CONFIG_FREE_CHUNK_SIZES_ATTR
public:
literal String^ CONFIG_FREE_CHUNK_SIZES_ATTR
static val mutable CONFIG_FREE_CHUNK_SIZES_ATTR: string
static val mutable CONFIG_FREE_CHUNK_SIZES_ATTR: string

Field Value

Type: Online String
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.CONFIG_PILE_SECTION Field

DefaultPile CONFIG_PILE_SECTION Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PILE_SECTION
public const string CONFIG_PILE_SECTION
Public Const CONFIG_PILE_SECTION As String
Public Const CONFIG_PILE_SECTION As String
public:
literal String^ CONFIG_PILE_SECTION
public:
literal String^ CONFIG_PILE_SECTION
static val mutable CONFIG_PILE_SECTION: string
static val mutable CONFIG_PILE_SECTION: string

Field Value

Type: Online String
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.FREE_CHUNK_SIZE_MIN Field

DefaultPile FREE_CHUNK_SIZE_MIN Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int FREE_CHUNK_SIZE_MIN
public const int FREE_CHUNK_SIZE_MIN
Public Const FREE_CHUNK_SIZE_MIN As Integer
Public Const FREE_CHUNK_SIZE_MIN As Integer
public:
literal int FREE_CHUNK_SIZE_MIN
public:
literal int FREE_CHUNK_SIZE_MIN
static val mutable FREE_CHUNK_SIZE_MIN: int
static val mutable FREE_CHUNK_SIZE_MIN: int

Field Value

Type: Online Int32
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.FREE_LST_COUNT Field

DefaultPile FREE_LST_COUNT Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int FREE_LST_COUNT
public const int FREE_LST_COUNT
Public Const FREE_LST_COUNT As Integer
Public Const FREE_LST_COUNT As Integer
public:
literal int FREE_LST_COUNT
public:
literal int FREE_LST_COUNT
static val mutable FREE_LST_COUNT: int
static val mutable FREE_LST_COUNT: int

Field Value

Type: Online Int32
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.FREE_LST_SIZE_MAX Field

DefaultPile FREE_LST_SIZE_MAX Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int FREE_LST_SIZE_MAX
public const int FREE_LST_SIZE_MAX
Public Const FREE_LST_SIZE_MAX As Integer
Public Const FREE_LST_SIZE_MAX As Integer
public:
literal int FREE_LST_SIZE_MAX
public:
literal int FREE_LST_SIZE_MAX
static val mutable FREE_LST_SIZE_MAX: int
static val mutable FREE_LST_SIZE_MAX: int

Field Value

Type: Online Int32
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.FREE_LST_SIZE_MIN Field

DefaultPile FREE_LST_SIZE_MIN Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int FREE_LST_SIZE_MIN
public const int FREE_LST_SIZE_MIN
Public Const FREE_LST_SIZE_MIN As Integer
Public Const FREE_LST_SIZE_MIN As Integer
public:
literal int FREE_LST_SIZE_MIN
public:
literal int FREE_LST_SIZE_MIN
static val mutable FREE_LST_SIZE_MIN: int
static val mutable FREE_LST_SIZE_MIN: int

Field Value

Type: Online Int32
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.SEG_SIZE_DFLT Field

DefaultPile SEG_SIZE_DFLT Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int SEG_SIZE_DFLT
public const int SEG_SIZE_DFLT
Public Const SEG_SIZE_DFLT As Integer
Public Const SEG_SIZE_DFLT As Integer
public:
literal int SEG_SIZE_DFLT
public:
literal int SEG_SIZE_DFLT
static val mutable SEG_SIZE_DFLT: int
static val mutable SEG_SIZE_DFLT: int

Field Value

Type: Online Int32
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.SEG_SIZE_MAX Field

DefaultPile SEG_SIZE_MAX Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int SEG_SIZE_MAX
public const int SEG_SIZE_MAX
Public Const SEG_SIZE_MAX As Integer
Public Const SEG_SIZE_MAX As Integer
public:
literal int SEG_SIZE_MAX
public:
literal int SEG_SIZE_MAX
static val mutable SEG_SIZE_MAX: int
static val mutable SEG_SIZE_MAX: int

Field Value

Type: Online Int32
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.SEG_SIZE_MIN Field

DefaultPile SEG_SIZE_MIN Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int SEG_SIZE_MIN
public const int SEG_SIZE_MIN
Public Const SEG_SIZE_MIN As Integer
Public Const SEG_SIZE_MIN As Integer
public:
literal int SEG_SIZE_MIN
public:
literal int SEG_SIZE_MIN
static val mutable SEG_SIZE_MIN: int
static val mutable SEG_SIZE_MIN: int

Field Value

Type: Online Int32
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile Methods

DefaultPile Methods NFX Class Library

The DefaultPile type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Compact |
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Public method | Crawl | Analyzes all segments scanning for free spaces. Returns number of uncovered free bytes. This is a full-blocking long operation that may take around 8 seconds on a 64Gb heaps in non-parallel mode
Public method | Delete | Deletes object from pile by its pointer returning true if there is no access violation and pointer is pointing to the valid object, throws otherwise unless throwInvalid is set to false
Protected method | Destructor | (Overrides Service Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | (Overrides Service DoAcceptManagerVisit(Object, DateTime).)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Get | Returns a CLR object by its pointer or throws access violation if pointer is invalid
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetRawBuffer | Returns a raw byte[] occupied by the object payload, only payload is returned along with serializer flag which tells what kind of serializer was used. This method is rarely used, it is needed for debugging and special-case "direct" memory access on read to bypass the de-serialization process altogether
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Purge |
Public method | Put | Puts a CLR object into the pile and returns a newly-allocated pointer. Throws out-of-space if there is not enough space in the pile and limits are set. Optional lifeSpanSec is ignored by this implementation
Public method | Rejuvenate |
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | SizeOf |
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
DefaultPile Class
NFX.ApplicationModel.Pile Namespace


DefaultPile.Compact Method

DefaultPile Compact Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long Compact()
public long Compact()
Public Function Compact As Long
Public Function Compact As Long
public:
virtual long long Compact() sealed
public:
virtual long long Compact() sealed
abstract Compact : unit -> int64
override Compact : unit -> int64
abstract Compact : unit -> int64
override Compact : unit -> int64

Return Value

Type: Online Int64

Implements

IPile Compact
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.Crawl Method

DefaultPile Crawl Method NFX Class Library

Analyzes all segments scanning for free spaces. Returns number of uncovered free bytes. This is a full-blocking long operation that may take around 8 seconds on a 64Gb heaps in non-parallel mode

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DefaultPile..::..SegmentCrawlStatus Crawl(
    bool parallel
)
public DefaultPile..::..SegmentCrawlStatus Crawl(
    bool parallel
)
Public Function Crawl (
    parallel As Boolean
) As DefaultPile..::..SegmentCrawlStatus
Public Function Crawl (
    parallel As Boolean
) As DefaultPile..::..SegmentCrawlStatus
public:
DefaultPile..::..SegmentCrawlStatus Crawl(
    bool parallel
)
public:
DefaultPile..::..SegmentCrawlStatus Crawl(
    bool parallel
)
member Crawl :
        parallel : bool -> DefaultPile..::..SegmentCrawlStatus
member Crawl :
        parallel : bool -> DefaultPile..::..SegmentCrawlStatus

Parameters

parallel
Type: Online System Boolean

Return Value

Type: DefaultPile SegmentCrawlStatus
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.Delete Method

DefaultPile Delete Method NFX Class Library

Deletes object from pile by its pointer returning true if there is no access violation and pointer is pointing to the valid object, throws otherwise unless throwInvalid is set to false

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Delete(
    PilePointer ptr,
    bool throwInvalid = true
)
public bool Delete(
    PilePointer ptr,
    bool throwInvalid = true
)
Public Function Delete (
    ptr As PilePointer,
    Optional throwInvalid As Boolean = true
) As Boolean
Public Function Delete (
    ptr As PilePointer,
    Optional throwInvalid As Boolean = true
) As Boolean
public:
virtual bool Delete(
    PilePointer ptr,
    bool throwInvalid = true
) sealed
public:
virtual bool Delete(
    PilePointer ptr,
    bool throwInvalid = true
) sealed
abstract Delete :
        ptr : PilePointer *
        ?throwInvalid : bool
(* Defaults:
        let _throwInvalid = defaultArg throwInvalid true
*)
-> bool
override Delete :
        ptr : PilePointer *
        ?throwInvalid : bool
(* Defaults:
        let _throwInvalid = defaultArg throwInvalid true
*)
-> bool
abstract Delete :
        ptr : PilePointer *
        ?throwInvalid : bool
(* Defaults:
        let _throwInvalid = defaultArg throwInvalid true
*)
-> bool
override Delete :
        ptr : PilePointer *
        ?throwInvalid : bool
(* Defaults:
        let _throwInvalid = defaultArg throwInvalid true
*)
-> bool

Parameters

ptr
Type: NFX.ApplicationModel.Pile PilePointer
throwInvalid (Optional)
Type: Online System Boolean

Return Value

Type: Online Boolean

Implements

IPile Delete(PilePointer, Boolean)
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.Destructor Method

DefaultPile Destructor Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.DoAcceptManagerVisit Method

DefaultPile DoAcceptManagerVisit Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoAcceptManagerVisit(
    Object manager,
    DateTime managerNow
)
protected override void DoAcceptManagerVisit(
    Object manager,
    DateTime managerNow
)
Protected Overrides Sub DoAcceptManagerVisit (
    manager As Object,
    managerNow As DateTime
)
Protected Overrides Sub DoAcceptManagerVisit (
    manager As Object,
    managerNow As DateTime
)
protected:
virtual void DoAcceptManagerVisit(
    Object^ manager,
    DateTime managerNow
) override
protected:
virtual void DoAcceptManagerVisit(
    Object^ manager,
    DateTime managerNow
) override
abstract DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit
override DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit
abstract DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit
override DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit

Parameters

manager
Type: Online System Object
managerNow
Type: Online System DateTime
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.DoConfigure Method

DefaultPile DoConfigure Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.DoStart Method

DefaultPile DoStart Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.DoWaitForCompleteStop Method

DefaultPile DoWaitForCompleteStop Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.Get Method

DefaultPile Get Method NFX Class Library

Returns a CLR object by its pointer or throws access violation if pointer is invalid

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Get(
    PilePointer ptr
)
public Object Get(
    PilePointer ptr
)
Public Function Get (
    ptr As PilePointer
) As Object
Public Function Get (
    ptr As PilePointer
) As Object
public:
virtual Object^ Get(
    PilePointer ptr
) sealed
public:
virtual Object^ Get(
    PilePointer ptr
) sealed
abstract Get :
        ptr : PilePointer -> Object
override Get :
        ptr : PilePointer -> Object
abstract Get :
        ptr : PilePointer -> Object
override Get :
        ptr : PilePointer -> Object

Parameters

ptr
Type: NFX.ApplicationModel.Pile PilePointer

Return Value

Type: Online Object

Implements

IPile Get(PilePointer)
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.GetRawBuffer Method

DefaultPile GetRawBuffer Method NFX Class Library

Returns a raw byte[] occupied by the object payload, only payload is returned along with serializer flag which tells what kind of serializer was used. This method is rarely used, it is needed for debugging and special-case "direct" memory access on read to bypass the de-serialization process altogether

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] GetRawBuffer(
    PilePointer ptr,
    out byte serializerFlag
)
public byte[] GetRawBuffer(
    PilePointer ptr,
    out byte serializerFlag
)
Public Function GetRawBuffer (
    ptr As PilePointer,
    <OutAttribute> ByRef serializerFlag As Byte
) As Byte()
Public Function GetRawBuffer (
    ptr As PilePointer,
    <OutAttribute> ByRef serializerFlag As Byte
) As Byte()
public:
virtual array<unsigned char>^ GetRawBuffer(
    PilePointer ptr,
    [OutAttribute] unsigned char% serializerFlag
) sealed
public:
virtual array<unsigned char>^ GetRawBuffer(
    PilePointer ptr,
    [OutAttribute] unsigned char% serializerFlag
) sealed
abstract GetRawBuffer :
        ptr : PilePointer *
        serializerFlag : byte byref -> byte[]
override GetRawBuffer :
        ptr : PilePointer *
        serializerFlag : byte byref -> byte[]
abstract GetRawBuffer :
        ptr : PilePointer *
        serializerFlag : byte byref -> byte[]
override GetRawBuffer :
        ptr : PilePointer *
        serializerFlag : byte byref -> byte[]

Parameters

ptr
Type: NFX.ApplicationModel.Pile PilePointer
serializerFlag
Type: Online System Byte

Return Value

Type: Online Byte

Implements

IPile GetRawBuffer(PilePointer, Byte )
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.Purge Method

DefaultPile Purge Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Purge()
public void Purge()
Public Sub Purge
Public Sub Purge
public:
virtual void Purge() sealed
public:
virtual void Purge() sealed
abstract Purge : unit -> unit
override Purge : unit -> unit
abstract Purge : unit -> unit
override Purge : unit -> unit

Implements

IPile Purge
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.Put Method

DefaultPile Put Method NFX Class Library

Puts a CLR object into the pile and returns a newly-allocated pointer. Throws out-of-space if there is not enough space in the pile and limits are set. Optional lifeSpanSec is ignored by this implementation

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PilePointer Put(
    Object obj,
    uint lifeSpanSec = 0
)
public PilePointer Put(
    Object obj,
    uint lifeSpanSec = 0
)
Public Function Put (
    obj As Object,
    Optional lifeSpanSec As UInteger = 0
) As PilePointer
Public Function Put (
    obj As Object,
    Optional lifeSpanSec As UInteger = 0
) As PilePointer
public:
virtual PilePointer Put(
    Object^ obj,
    unsigned int lifeSpanSec = 0
) sealed
public:
virtual PilePointer Put(
    Object^ obj,
    unsigned int lifeSpanSec = 0
) sealed
abstract Put :
        obj : Object *
        ?lifeSpanSec : uint32
(* Defaults:
        let _lifeSpanSec = defaultArg lifeSpanSec 0
*)
-> PilePointer
override Put :
        obj : Object *
        ?lifeSpanSec : uint32
(* Defaults:
        let _lifeSpanSec = defaultArg lifeSpanSec 0
*)
-> PilePointer
abstract Put :
        obj : Object *
        ?lifeSpanSec : uint32
(* Defaults:
        let _lifeSpanSec = defaultArg lifeSpanSec 0
*)
-> PilePointer
override Put :
        obj : Object *
        ?lifeSpanSec : uint32
(* Defaults:
        let _lifeSpanSec = defaultArg lifeSpanSec 0
*)
-> PilePointer

Parameters

obj
Type: Online System Object
lifeSpanSec (Optional)
Type: Online System UInt32

Return Value

Type: PilePointer

Implements

IPile Put(Object, UInt32)
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.Rejuvenate Method

DefaultPile Rejuvenate Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Rejuvenate(
    PilePointer ptr
)
public bool Rejuvenate(
    PilePointer ptr
)
Public Function Rejuvenate (
    ptr As PilePointer
) As Boolean
Public Function Rejuvenate (
    ptr As PilePointer
) As Boolean
public:
virtual bool Rejuvenate(
    PilePointer ptr
) sealed
public:
virtual bool Rejuvenate(
    PilePointer ptr
) sealed
abstract Rejuvenate :
        ptr : PilePointer -> bool
override Rejuvenate :
        ptr : PilePointer -> bool
abstract Rejuvenate :
        ptr : PilePointer -> bool
override Rejuvenate :
        ptr : PilePointer -> bool

Parameters

ptr
Type: NFX.ApplicationModel.Pile PilePointer

Return Value

Type: Online Boolean

Implements

IPile Rejuvenate(PilePointer)
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.SizeOf Method

DefaultPile SizeOf Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int SizeOf(
    PilePointer ptr
)
public int SizeOf(
    PilePointer ptr
)
Public Function SizeOf (
    ptr As PilePointer
) As Integer
Public Function SizeOf (
    ptr As PilePointer
) As Integer
public:
virtual int SizeOf(
    PilePointer ptr
) sealed
public:
virtual int SizeOf(
    PilePointer ptr
) sealed
abstract SizeOf :
        ptr : PilePointer -> int
override SizeOf :
        ptr : PilePointer -> int
abstract SizeOf :
        ptr : PilePointer -> int
override SizeOf :
        ptr : PilePointer -> int

Parameters

ptr
Type: NFX.ApplicationModel.Pile PilePointer

Return Value

Type: Online Int32

Implements

IPile SizeOf(PilePointer)
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile Properties

DefaultPile Properties NFX Class Library

The DefaultPile type exposes the following members.
Properties
 | Name | Description
Public property | AllocatedMemoryBytes | Returns the number of bytes allocated by this pile from the system memory heap. As pile pre-allocates memory in segments, it is absolutely normal to have this property return 100s of megabytes even when pile is almost empty. This property may return close to all physical memory available
Public property | AllocMode | Defines modes of allocation: space/time tradeoff
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | FreeChunkSizes | Sets the sizes of free chunks that free lists group by. Must be an array of FREE_LST_COUNT(16) of consequitively increasing integers
Public property | FreeListSize | Determines the size of free chunk list. Every segment has FREE_LST_COUNT=16 lists each of this size. This property may only be set on an inactive service instance
Public property | InstrumentationEnabled | Implements IInstrumentable (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | Locality | Returns PileLocality.Local
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | MaxMemoryLimit | Imposes a limit on maximum number of bytes that a pile can allocate of the system heap. The default value of 0 means no limit, meaning - the pile will keep allocating objects until the system allows. The value may not be less than minimum 1 seg size (64 mb). May set on an active instance, however no existing objects will be removed if the limit is exceeded
Public property | MaxSegmentLimit | Gets the maximum count of segments tha this pile can have. The property is not thread-safe for set and can only be set if pile is inactive. The value of zero means no limit
Public property | MemoryCapacityBytes | Returns an approximate capacity of free memory that the system has left
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | NodeCount | Returns 1 as this pile is not distributed
Public property | ObjectCount | Returns the total number of objects allocated at this point in time
Public property | OverheadBytes | Returns the number of extra bytes used by pile metadata currently occupied by object stored in this pile
Public property | Persistence | Returns PilePersistence.Memory
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | SegmentCount | Returns the total number of segments allocated at this point in time
Public property | SegmentSize | Gets the maximum segment size in bytes, up to (2^31)-1 The property is not thread-safe for set and can only be set if pile is inactive
Public property | SegmentTotalCount | Returns the total number of total segments - allocated and empty at this point in time. This number is greater or equal to SegmentCount
Public property | Status | Current service status (Inherited from Service.)
Public property | SupportsObjectExpiration | Returns false
Public property | SweepExpiredObjects | Returns false and does nothing on set in this implementation if they are set
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | UtilizedBytes | Returns the number of bytes currently occupied by object stored in this pile. This number is always less than AllocatedMemoryBytes
Back to Top
See Also
DefaultPile Class
NFX.ApplicationModel.Pile Namespace


DefaultPile.AllocatedMemoryBytes Property

DefaultPile AllocatedMemoryBytes Property NFX Class Library

Returns the number of bytes allocated by this pile from the system memory heap. As pile pre-allocates memory in segments, it is absolutely normal to have this property return 100s of megabytes even when pile is almost empty. This property may return close to all physical memory available

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long AllocatedMemoryBytes { get; }
public long AllocatedMemoryBytes { get; }
Public ReadOnly Property AllocatedMemoryBytes As Long
    Get
Public ReadOnly Property AllocatedMemoryBytes As Long
    Get
public:
virtual property long long AllocatedMemoryBytes {
    long long get () sealed;
}
public:
virtual property long long AllocatedMemoryBytes {
    long long get () sealed;
}
abstract AllocatedMemoryBytes : int64 with get
override AllocatedMemoryBytes : int64 with get
abstract AllocatedMemoryBytes : int64 with get
override AllocatedMemoryBytes : int64 with get

Property Value

Type: Online Int64

Implements

IPileStatus AllocatedMemoryBytes
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.AllocMode Property

DefaultPile AllocMode Property NFX Class Library

Defines modes of allocation: space/time tradeoff

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public AllocationMode AllocMode { get; set; }
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public AllocationMode AllocMode { get; set; }
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property AllocMode As AllocationMode
    Get
    Set
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property AllocMode As AllocationMode
    Get
    Set
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property AllocationMode AllocMode {
    AllocationMode get () sealed;
    void set (AllocationMode value) sealed;
}
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property AllocationMode AllocMode {
    AllocationMode get () sealed;
    void set (AllocationMode value) sealed;
}
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
abstract AllocMode : AllocationMode with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
override AllocMode : AllocationMode with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
abstract AllocMode : AllocationMode with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
override AllocMode : AllocationMode with get, set

Property Value

Type: AllocationMode

Implements

IPileImplementation AllocMode
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.FreeChunkSizes Property

DefaultPile FreeChunkSizes Property NFX Class Library

Sets the sizes of free chunks that free lists group by. Must be an array of FREE_LST_COUNT(16) of consequitively increasing integers

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int[] FreeChunkSizes { get; set; }
public int[] FreeChunkSizes { get; set; }
Public Property FreeChunkSizes As Integer()
    Get
    Set
Public Property FreeChunkSizes As Integer()
    Get
    Set
public:
property array<int>^ FreeChunkSizes {
    array<int>^ get ();
    void set (array<int>^ value);
}
public:
property array<int>^ FreeChunkSizes {
    array<int>^ get ();
    void set (array<int>^ value);
}
member FreeChunkSizes : int[] with get, set
member FreeChunkSizes : int[] with get, set

Property Value

Type: Online Int32
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.FreeListSize Property

DefaultPile FreeListSize Property NFX Class Library

Determines the size of free chunk list. Every segment has FREE_LST_COUNT=16 lists each of this size. This property may only be set on an inactive service instance

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int FreeListSize { get; set; }
[ConfigAttribute]
public int FreeListSize { get; set; }
<ConfigAttribute>
Public Property FreeListSize As Integer
    Get
    Set
<ConfigAttribute>
Public Property FreeListSize As Integer
    Get
    Set
public:
[ConfigAttribute]
property int FreeListSize {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute]
property int FreeListSize {
    int get ();
    void set (int value);
}
[<ConfigAttribute>]
member FreeListSize : int with get, set
[<ConfigAttribute>]
member FreeListSize : int with get, set

Property Value

Type: Online Int32
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.InstrumentationEnabled Property

DefaultPile InstrumentationEnabled Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Implements IInstrumentable

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute(Default = false)]
public override bool InstrumentationEnabled { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute(Default = false)]
public override bool InstrumentationEnabled { get; set; }
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute(Default := false)>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute(Default := false)>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(Default = false)]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(Default = false)]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
abstract InstrumentationEnabled : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
override InstrumentationEnabled : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
abstract InstrumentationEnabled : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
override InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentable InstrumentationEnabled
IInstrumentable InstrumentationEnabled
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.Locality Property

DefaultPile Locality Property NFX Class Library

Returns PileLocality.Local

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LocalityKind Locality { get; }
public LocalityKind Locality { get; }
Public ReadOnly Property Locality As LocalityKind
    Get
Public ReadOnly Property Locality As LocalityKind
    Get
public:
virtual property LocalityKind Locality {
    LocalityKind get () sealed;
}
public:
virtual property LocalityKind Locality {
    LocalityKind get () sealed;
}
abstract Locality : LocalityKind with get
override Locality : LocalityKind with get
abstract Locality : LocalityKind with get
override Locality : LocalityKind with get

Property Value

Type: LocalityKind

Implements

IPileStatus Locality
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.MaxMemoryLimit Property

DefaultPile MaxMemoryLimit Property NFX Class Library

Imposes a limit on maximum number of bytes that a pile can allocate of the system heap. The default value of 0 means no limit, meaning - the pile will keep allocating objects until the system allows. The value may not be less than minimum 1 seg size (64 mb). May set on an active instance, however no existing objects will be removed if the limit is exceeded

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute]
public long MaxMemoryLimit { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute]
public long MaxMemoryLimit { get; set; }
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute>
Public Property MaxMemoryLimit As Long
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute>
Public Property MaxMemoryLimit As Long
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute]
virtual property long long MaxMemoryLimit {
    long long get () sealed;
    void set (long long value) sealed;
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute]
virtual property long long MaxMemoryLimit {
    long long get () sealed;
    void set (long long value) sealed;
}
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute>]
abstract MaxMemoryLimit : int64 with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute>]
override MaxMemoryLimit : int64 with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute>]
abstract MaxMemoryLimit : int64 with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute>]
override MaxMemoryLimit : int64 with get, set

Property Value

Type: Online Int64

Implements

IPileImplementation MaxMemoryLimit
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.MaxSegmentLimit Property

DefaultPile MaxSegmentLimit Property NFX Class Library

Gets the maximum count of segments tha this pile can have. The property is not thread-safe for set and can only be set if pile is inactive. The value of zero means no limit

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int MaxSegmentLimit { get; set; }
[ConfigAttribute]
public int MaxSegmentLimit { get; set; }
<ConfigAttribute>
Public Property MaxSegmentLimit As Integer
    Get
    Set
<ConfigAttribute>
Public Property MaxSegmentLimit As Integer
    Get
    Set
public:
[ConfigAttribute]
virtual property int MaxSegmentLimit {
    int get () sealed;
    void set (int value) sealed;
}
public:
[ConfigAttribute]
virtual property int MaxSegmentLimit {
    int get () sealed;
    void set (int value) sealed;
}
[<ConfigAttribute>]
abstract MaxSegmentLimit : int with get, set
[<ConfigAttribute>]
override MaxSegmentLimit : int with get, set
[<ConfigAttribute>]
abstract MaxSegmentLimit : int with get, set
[<ConfigAttribute>]
override MaxSegmentLimit : int with get, set

Property Value

Type: Online Int32

Implements

IPileImplementation MaxSegmentLimit
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.MemoryCapacityBytes Property

DefaultPile MemoryCapacityBytes Property NFX Class Library

Returns an approximate capacity of free memory that the system has left

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long MemoryCapacityBytes { get; }
public long MemoryCapacityBytes { get; }
Public ReadOnly Property MemoryCapacityBytes As Long
    Get
Public ReadOnly Property MemoryCapacityBytes As Long
    Get
public:
virtual property long long MemoryCapacityBytes {
    long long get () sealed;
}
public:
virtual property long long MemoryCapacityBytes {
    long long get () sealed;
}
abstract MemoryCapacityBytes : int64 with get
override MemoryCapacityBytes : int64 with get
abstract MemoryCapacityBytes : int64 with get
override MemoryCapacityBytes : int64 with get

Property Value

Type: Online Int64

Implements

IPileStatus MemoryCapacityBytes
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.NodeCount Property

DefaultPile NodeCount Property NFX Class Library

Returns 1 as this pile is not distributed

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int NodeCount { get; }
public int NodeCount { get; }
Public ReadOnly Property NodeCount As Integer
    Get
Public ReadOnly Property NodeCount As Integer
    Get
public:
virtual property int NodeCount {
    int get () sealed;
}
public:
virtual property int NodeCount {
    int get () sealed;
}
abstract NodeCount : int with get
override NodeCount : int with get
abstract NodeCount : int with get
override NodeCount : int with get

Property Value

Type: Online Int32

Implements

IPileStatus NodeCount
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.ObjectCount Property

DefaultPile ObjectCount Property NFX Class Library

Returns the total number of objects allocated at this point in time

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long ObjectCount { get; }
public long ObjectCount { get; }
Public ReadOnly Property ObjectCount As Long
    Get
Public ReadOnly Property ObjectCount As Long
    Get
public:
virtual property long long ObjectCount {
    long long get () sealed;
}
public:
virtual property long long ObjectCount {
    long long get () sealed;
}
abstract ObjectCount : int64 with get
override ObjectCount : int64 with get
abstract ObjectCount : int64 with get
override ObjectCount : int64 with get

Property Value

Type: Online Int64

Implements

IPileStatus ObjectCount
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.OverheadBytes Property

DefaultPile OverheadBytes Property NFX Class Library

Returns the number of extra bytes used by pile metadata currently occupied by object stored in this pile

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long OverheadBytes { get; }
public long OverheadBytes { get; }
Public ReadOnly Property OverheadBytes As Long
    Get
Public ReadOnly Property OverheadBytes As Long
    Get
public:
virtual property long long OverheadBytes {
    long long get () sealed;
}
public:
virtual property long long OverheadBytes {
    long long get () sealed;
}
abstract OverheadBytes : int64 with get
override OverheadBytes : int64 with get
abstract OverheadBytes : int64 with get
override OverheadBytes : int64 with get

Property Value

Type: Online Int64

Implements

IPileStatus OverheadBytes
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.Persistence Property

DefaultPile Persistence Property NFX Class Library

Returns PilePersistence.Memory

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ObjectPersistence Persistence { get; }
public ObjectPersistence Persistence { get; }
Public ReadOnly Property Persistence As ObjectPersistence
    Get
Public ReadOnly Property Persistence As ObjectPersistence
    Get
public:
virtual property ObjectPersistence Persistence {
    ObjectPersistence get () sealed;
}
public:
virtual property ObjectPersistence Persistence {
    ObjectPersistence get () sealed;
}
abstract Persistence : ObjectPersistence with get
override Persistence : ObjectPersistence with get
abstract Persistence : ObjectPersistence with get
override Persistence : ObjectPersistence with get

Property Value

Type: ObjectPersistence

Implements

IPileStatus Persistence
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.SegmentCount Property

DefaultPile SegmentCount Property NFX Class Library

Returns the total number of segments allocated at this point in time

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long SegmentCount { get; }
public long SegmentCount { get; }
Public ReadOnly Property SegmentCount As Long
    Get
Public ReadOnly Property SegmentCount As Long
    Get
public:
virtual property long long SegmentCount {
    long long get () sealed;
}
public:
virtual property long long SegmentCount {
    long long get () sealed;
}
abstract SegmentCount : int64 with get
override SegmentCount : int64 with get
abstract SegmentCount : int64 with get
override SegmentCount : int64 with get

Property Value

Type: Online Int64

Implements

IPileStatus SegmentCount
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.SegmentSize Property

DefaultPile SegmentSize Property NFX Class Library

Gets the maximum segment size in bytes, up to (2^31)-1 The property is not thread-safe for set and can only be set if pile is inactive

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int SegmentSize { get; set; }
[ConfigAttribute]
public int SegmentSize { get; set; }
<ConfigAttribute>
Public Property SegmentSize As Integer
    Get
    Set
<ConfigAttribute>
Public Property SegmentSize As Integer
    Get
    Set
public:
[ConfigAttribute]
virtual property int SegmentSize {
    int get () sealed;
    void set (int value) sealed;
}
public:
[ConfigAttribute]
virtual property int SegmentSize {
    int get () sealed;
    void set (int value) sealed;
}
[<ConfigAttribute>]
abstract SegmentSize : int with get, set
[<ConfigAttribute>]
override SegmentSize : int with get, set
[<ConfigAttribute>]
abstract SegmentSize : int with get, set
[<ConfigAttribute>]
override SegmentSize : int with get, set

Property Value

Type: Online Int32

Implements

IPileImplementation SegmentSize
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.SegmentTotalCount Property

DefaultPile SegmentTotalCount Property NFX Class Library

Returns the total number of total segments - allocated and empty at this point in time. This number is greater or equal to SegmentCount

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int SegmentTotalCount { get; }
public int SegmentTotalCount { get; }
Public ReadOnly Property SegmentTotalCount As Integer
    Get
Public ReadOnly Property SegmentTotalCount As Integer
    Get
public:
property int SegmentTotalCount {
    int get ();
}
public:
property int SegmentTotalCount {
    int get ();
}
member SegmentTotalCount : int with get
member SegmentTotalCount : int with get

Property Value

Type: Online Int32
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.SupportsObjectExpiration Property

DefaultPile SupportsObjectExpiration Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns false

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsObjectExpiration { get; }
public bool SupportsObjectExpiration { get; }
Public ReadOnly Property SupportsObjectExpiration As Boolean
    Get
Public ReadOnly Property SupportsObjectExpiration As Boolean
    Get
public:
virtual property bool SupportsObjectExpiration {
    bool get () sealed;
}
public:
virtual property bool SupportsObjectExpiration {
    bool get () sealed;
}
abstract SupportsObjectExpiration : bool with get
override SupportsObjectExpiration : bool with get
abstract SupportsObjectExpiration : bool with get
override SupportsObjectExpiration : bool with get

Property Value

Type: Online Boolean

Implements

IPileStatus SupportsObjectExpiration
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.SweepExpiredObjects Property

DefaultPile SweepExpiredObjects Property NFX Class Library

Returns false and does nothing on set in this implementation if they are set

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SweepExpiredObjects { get; set; }
public bool SweepExpiredObjects { get; set; }
Public Property SweepExpiredObjects As Boolean
    Get
    Set
Public Property SweepExpiredObjects As Boolean
    Get
    Set
public:
virtual property bool SweepExpiredObjects {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool SweepExpiredObjects {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract SweepExpiredObjects : bool with get, set
override SweepExpiredObjects : bool with get, set
abstract SweepExpiredObjects : bool with get, set
override SweepExpiredObjects : bool with get, set

Property Value

Type: Online Boolean

Implements

IPileImplementation SweepExpiredObjects
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.UtilizedBytes Property

DefaultPile UtilizedBytes Property NFX Class Library

Returns the number of bytes currently occupied by object stored in this pile. This number is always less than AllocatedMemoryBytes

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long UtilizedBytes { get; }
public long UtilizedBytes { get; }
Public ReadOnly Property UtilizedBytes As Long
    Get
Public ReadOnly Property UtilizedBytes As Long
    Get
public:
virtual property long long UtilizedBytes {
    long long get () sealed;
}
public:
virtual property long long UtilizedBytes {
    long long get () sealed;
}
abstract UtilizedBytes : int64 with get
override UtilizedBytes : int64 with get
abstract UtilizedBytes : int64 with get
override UtilizedBytes : int64 with get

Property Value

Type: Online Int64

Implements

IPileStatus UtilizedBytes
See Also
DefaultPile Class
DefaultPile Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.SegmentCrawlStatus Structure

DefaultPile SegmentCrawlStatus Structure NFX Class Library

Holds information obtained after a segment crawl

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct SegmentCrawlStatus
public struct SegmentCrawlStatus
Public Structure SegmentCrawlStatus
Public Structure SegmentCrawlStatus
public value class SegmentCrawlStatus
public value class SegmentCrawlStatus
[<SealedAttribute>]
type SegmentCrawlStatus =  struct end
[<SealedAttribute>]
type SegmentCrawlStatus =  struct end
See Also
DefaultPile SegmentCrawlStatus Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.SegmentCrawlStatus Members

DefaultPile SegmentCrawlStatus Members NFX Class Library

The DefaultPile SegmentCrawlStatus type exposes the following members.
Constructors
 | Name | Description
Protected method | DefaultPile SegmentCrawlStatus | Initializes a new instance of the DefaultPile SegmentCrawlStatus class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Sum |
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | CrawledChunks |
Public field | FreePayloadSize |
Public field | OriginalFreeChunks |
Public field | ResultFreeChunks |
Public field | UsedPayloadSize |
Back to Top
See Also
DefaultPile SegmentCrawlStatus Structure
NFX.ApplicationModel.Pile Namespace


DefaultPile.SegmentCrawlStatus Constructor

DefaultPile SegmentCrawlStatus Constructor NFX Class Library

Initializes a new instance of the DefaultPile SegmentCrawlStatus class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal SegmentCrawlStatus(
    long crawledChunks,
    long originalFreeChunks,
    long resultFreeChunks,
    long freePayloadSize,
    long usedPayloadSize
)
internal SegmentCrawlStatus(
    long crawledChunks,
    long originalFreeChunks,
    long resultFreeChunks,
    long freePayloadSize,
    long usedPayloadSize
)
Friend Sub New (
    crawledChunks As Long,
    originalFreeChunks As Long,
    resultFreeChunks As Long,
    freePayloadSize As Long,
    usedPayloadSize As Long
)
Friend Sub New (
    crawledChunks As Long,
    originalFreeChunks As Long,
    resultFreeChunks As Long,
    freePayloadSize As Long,
    usedPayloadSize As Long
)
internal:
SegmentCrawlStatus(
    long long crawledChunks,
    long long originalFreeChunks,
    long long resultFreeChunks,
    long long freePayloadSize,
    long long usedPayloadSize
)
internal:
SegmentCrawlStatus(
    long long crawledChunks,
    long long originalFreeChunks,
    long long resultFreeChunks,
    long long freePayloadSize,
    long long usedPayloadSize
)
new :
        crawledChunks : int64 *
        originalFreeChunks : int64 *
        resultFreeChunks : int64 *
        freePayloadSize : int64 *
        usedPayloadSize : int64 -> SegmentCrawlStatus
new :
        crawledChunks : int64 *
        originalFreeChunks : int64 *
        resultFreeChunks : int64 *
        freePayloadSize : int64 *
        usedPayloadSize : int64 -> SegmentCrawlStatus

Parameters

crawledChunks
Type: Online System Int64
originalFreeChunks
Type: Online System Int64
resultFreeChunks
Type: Online System Int64
freePayloadSize
Type: Online System Int64
usedPayloadSize
Type: Online System Int64
See Also
DefaultPile SegmentCrawlStatus Structure
DefaultPile SegmentCrawlStatus Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.SegmentCrawlStatus Fields

DefaultPile SegmentCrawlStatus Fields NFX Class Library

The DefaultPile SegmentCrawlStatus type exposes the following members.
Fields
 | Name | Description
Public field | CrawledChunks |
Public field | FreePayloadSize |
Public field | OriginalFreeChunks |
Public field | ResultFreeChunks |
Public field | UsedPayloadSize |
Back to Top
See Also
DefaultPile SegmentCrawlStatus Structure
NFX.ApplicationModel.Pile Namespace


DefaultPile.SegmentCrawlStatus.CrawledChunks Field

DefaultPile SegmentCrawlStatus CrawledChunks Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly long CrawledChunks
public readonly long CrawledChunks
Public ReadOnly CrawledChunks As Long
Public ReadOnly CrawledChunks As Long
public:
initonly long long CrawledChunks
public:
initonly long long CrawledChunks
val CrawledChunks: int64
val CrawledChunks: int64

Field Value

Type: Online Int64
See Also
DefaultPile SegmentCrawlStatus Structure
DefaultPile SegmentCrawlStatus Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.SegmentCrawlStatus.FreePayloadSize Field

DefaultPile SegmentCrawlStatus FreePayloadSize Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly long FreePayloadSize
public readonly long FreePayloadSize
Public ReadOnly FreePayloadSize As Long
Public ReadOnly FreePayloadSize As Long
public:
initonly long long FreePayloadSize
public:
initonly long long FreePayloadSize
val FreePayloadSize: int64
val FreePayloadSize: int64

Field Value

Type: Online Int64
See Also
DefaultPile SegmentCrawlStatus Structure
DefaultPile SegmentCrawlStatus Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.SegmentCrawlStatus.OriginalFreeChunks Field

DefaultPile SegmentCrawlStatus OriginalFreeChunks Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly long OriginalFreeChunks
public readonly long OriginalFreeChunks
Public ReadOnly OriginalFreeChunks As Long
Public ReadOnly OriginalFreeChunks As Long
public:
initonly long long OriginalFreeChunks
public:
initonly long long OriginalFreeChunks
val OriginalFreeChunks: int64
val OriginalFreeChunks: int64

Field Value

Type: Online Int64
See Also
DefaultPile SegmentCrawlStatus Structure
DefaultPile SegmentCrawlStatus Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.SegmentCrawlStatus.ResultFreeChunks Field

DefaultPile SegmentCrawlStatus ResultFreeChunks Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly long ResultFreeChunks
public readonly long ResultFreeChunks
Public ReadOnly ResultFreeChunks As Long
Public ReadOnly ResultFreeChunks As Long
public:
initonly long long ResultFreeChunks
public:
initonly long long ResultFreeChunks
val ResultFreeChunks: int64
val ResultFreeChunks: int64

Field Value

Type: Online Int64
See Also
DefaultPile SegmentCrawlStatus Structure
DefaultPile SegmentCrawlStatus Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.SegmentCrawlStatus.UsedPayloadSize Field

DefaultPile SegmentCrawlStatus UsedPayloadSize Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly long UsedPayloadSize
public readonly long UsedPayloadSize
Public ReadOnly UsedPayloadSize As Long
Public ReadOnly UsedPayloadSize As Long
public:
initonly long long UsedPayloadSize
public:
initonly long long UsedPayloadSize
val UsedPayloadSize: int64
val UsedPayloadSize: int64

Field Value

Type: Online Int64
See Also
DefaultPile SegmentCrawlStatus Structure
DefaultPile SegmentCrawlStatus Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.SegmentCrawlStatus Methods

DefaultPile SegmentCrawlStatus Methods NFX Class Library

The DefaultPile SegmentCrawlStatus type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Sum |
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
DefaultPile SegmentCrawlStatus Structure
NFX.ApplicationModel.Pile Namespace


DefaultPile.SegmentCrawlStatus.Sum Method

DefaultPile SegmentCrawlStatus Sum Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DefaultPile..::..SegmentCrawlStatus Sum(
    DefaultPile..::..SegmentCrawlStatus other
)
public DefaultPile..::..SegmentCrawlStatus Sum(
    DefaultPile..::..SegmentCrawlStatus other
)
Public Function Sum (
    other As DefaultPile..::..SegmentCrawlStatus
) As DefaultPile..::..SegmentCrawlStatus
Public Function Sum (
    other As DefaultPile..::..SegmentCrawlStatus
) As DefaultPile..::..SegmentCrawlStatus
public:
DefaultPile..::..SegmentCrawlStatus Sum(
    DefaultPile..::..SegmentCrawlStatus other
)
public:
DefaultPile..::..SegmentCrawlStatus Sum(
    DefaultPile..::..SegmentCrawlStatus other
)
member Sum :
        other : DefaultPile..::..SegmentCrawlStatus -> DefaultPile..::..SegmentCrawlStatus
member Sum :
        other : DefaultPile..::..SegmentCrawlStatus -> DefaultPile..::..SegmentCrawlStatus

Parameters

other
Type: NFX.ApplicationModel.Pile DefaultPile SegmentCrawlStatus

Return Value

Type: DefaultPile SegmentCrawlStatus
See Also
DefaultPile SegmentCrawlStatus Structure
DefaultPile SegmentCrawlStatus Members
NFX.ApplicationModel.Pile Namespace


DefaultPile.SegmentCrawlStatus.ToString Method

DefaultPile SegmentCrawlStatus ToString Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
DefaultPile SegmentCrawlStatus Structure
DefaultPile SegmentCrawlStatus Members
NFX.ApplicationModel.Pile Namespace


GDIDWithInt Structure

GDIDWithInt Structure NFX Class Library

Represents GDID with int

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct GDIDWithInt : IDistributedStableHashProvider,
    IEquatable<GDIDWithInt>
public struct GDIDWithInt : IDistributedStableHashProvider,
    IEquatable<GDIDWithInt>
Public Structure GDIDWithInt
    Implements IDistributedStableHashProvider, IEquatable(Of GDIDWithInt)
Public Structure GDIDWithInt
    Implements IDistributedStableHashProvider, IEquatable(Of GDIDWithInt)
public value class GDIDWithInt : IDistributedStableHashProvider,
    IEquatable<GDIDWithInt>
public value class GDIDWithInt : IDistributedStableHashProvider,
    IEquatable<GDIDWithInt>
[<SealedAttribute>]
type GDIDWithInt =
    struct
        interface IDistributedStableHashProvider
        interface IEquatable<GDIDWithInt>
    end
[<SealedAttribute>]
type GDIDWithInt =
    struct
        interface IDistributedStableHashProvider
        interface IEquatable<GDIDWithInt>
    end
See Also
GDIDWithInt Members
NFX.ApplicationModel.Pile Namespace


GDIDWithInt Members

GDIDWithInt Members NFX Class Library

The GDIDWithInt type exposes the following members.
Constructors
 | Name | Description
Public method | GDIDWithInt | Initializes a new instance of the GDIDWithInt class
Back to Top
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(GDIDWithInt) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDistributedStableHash |
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | GDID |
Public field | Int |
Back to Top
See Also
GDIDWithInt Structure
NFX.ApplicationModel.Pile Namespace


GDIDWithInt Constructor

GDIDWithInt Constructor NFX Class Library

Initializes a new instance of the GDIDWithInt class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GDIDWithInt(
    GDID gdid,
    int val
)
public GDIDWithInt(
    GDID gdid,
    int val
)
Public Sub New (
    gdid As GDID,
    val As Integer
)
Public Sub New (
    gdid As GDID,
    val As Integer
)
public:
GDIDWithInt(
    GDID gdid,
    int val
)
public:
GDIDWithInt(
    GDID gdid,
    int val
)
new :
        gdid : GDID *
        val : int -> GDIDWithInt
new :
        gdid : GDID *
        val : int -> GDIDWithInt

Parameters

gdid
Type: NFX.DataAccess.Distributed GDID
val
Type: Online System Int32
See Also
GDIDWithInt Structure
GDIDWithInt Members
NFX.ApplicationModel.Pile Namespace


GDIDWithInt Fields

GDIDWithInt Fields NFX Class Library

The GDIDWithInt type exposes the following members.
Fields
 | Name | Description
Public field | GDID |
Public field | Int |
Back to Top
See Also
GDIDWithInt Structure
NFX.ApplicationModel.Pile Namespace


GDIDWithInt.GDID Field

GDIDWithInt GDID Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly GDID GDID
public readonly GDID GDID
Public ReadOnly GDID As GDID
Public ReadOnly GDID As GDID
public:
initonly GDID GDID
public:
initonly GDID GDID
val GDID: GDID
val GDID: GDID

Field Value

Type: GDID
See Also
GDIDWithInt Structure
GDIDWithInt Members
NFX.ApplicationModel.Pile Namespace


GDIDWithInt.Int Field

GDIDWithInt Int Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Int
public readonly int Int
Public ReadOnly Int As Integer
Public ReadOnly Int As Integer
public:
initonly int Int
public:
initonly int Int
val Int: int
val Int: int

Field Value

Type: Online Int32
See Also
GDIDWithInt Structure
GDIDWithInt Members
NFX.ApplicationModel.Pile Namespace


GDIDWithInt Methods

GDIDWithInt Methods NFX Class Library

The GDIDWithInt type exposes the following members.
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(GDIDWithInt) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDistributedStableHash |
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GDIDWithInt Structure
NFX.ApplicationModel.Pile Namespace


GDIDWithInt.Equals Method

GDIDWithInt Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(GDIDWithInt) |
Back to Top
See Also
GDIDWithInt Structure
GDIDWithInt Members
NFX.ApplicationModel.Pile Namespace


GDIDWithInt.Equals Method (Object)

GDIDWithInt Equals Method (Object) NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
GDIDWithInt Structure
GDIDWithInt Members
Equals Overload
NFX.ApplicationModel.Pile Namespace


GDIDWithInt.Equals Method (GDIDWithInt)

GDIDWithInt Equals Method (GDIDWithInt) NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    GDIDWithInt other
)
public bool Equals(
    GDIDWithInt other
)
Public Function Equals (
    other As GDIDWithInt
) As Boolean
Public Function Equals (
    other As GDIDWithInt
) As Boolean
public:
virtual bool Equals(
    GDIDWithInt other
) sealed
public:
virtual bool Equals(
    GDIDWithInt other
) sealed
abstract Equals :
        other : GDIDWithInt -> bool
override Equals :
        other : GDIDWithInt -> bool
abstract Equals :
        other : GDIDWithInt -> bool
override Equals :
        other : GDIDWithInt -> bool

Parameters

other
Type: NFX.ApplicationModel.Pile GDIDWithInt

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
GDIDWithInt Structure
GDIDWithInt Members
Equals Overload
NFX.ApplicationModel.Pile Namespace


GDIDWithInt.GetDistributedStableHash Method

GDIDWithInt GetDistributedStableHash Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong GetDistributedStableHash()
public ulong GetDistributedStableHash()
Public Function GetDistributedStableHash As ULong
Public Function GetDistributedStableHash As ULong
public:
virtual unsigned long long GetDistributedStableHash() sealed
public:
virtual unsigned long long GetDistributedStableHash() sealed
abstract GetDistributedStableHash : unit -> uint64
override GetDistributedStableHash : unit -> uint64
abstract GetDistributedStableHash : unit -> uint64
override GetDistributedStableHash : unit -> uint64

Return Value

Type: Online UInt64

Implements

IDistributedStableHashProvider GetDistributedStableHash
See Also
GDIDWithInt Structure
GDIDWithInt Members
NFX.ApplicationModel.Pile Namespace


GDIDWithInt.GetHashCode Method

GDIDWithInt GetHashCode Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
GDIDWithInt Structure
GDIDWithInt Members
NFX.ApplicationModel.Pile Namespace


GDIDWithInt.ToString Method

GDIDWithInt ToString Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
GDIDWithInt Structure
GDIDWithInt Members
NFX.ApplicationModel.Pile Namespace


GDIDWithISOKey Structure

GDIDWithISOKey Structure NFX Class Library

Represents a value-type GDID+3 char ISO code tuple, suitable for serving as a cache table key. The point of this structure is to avoid creation of references for Pile cache so keys alone do not stall the GC. The ISO code is case-insensitive

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct GDIDWithISOKey : IDistributedStableHashProvider,
    IEquatable<GDIDWithISOKey>
public struct GDIDWithISOKey : IDistributedStableHashProvider,
    IEquatable<GDIDWithISOKey>
Public Structure GDIDWithISOKey
    Implements IDistributedStableHashProvider, IEquatable(Of GDIDWithISOKey)
Public Structure GDIDWithISOKey
    Implements IDistributedStableHashProvider, IEquatable(Of GDIDWithISOKey)
public value class GDIDWithISOKey : IDistributedStableHashProvider,
    IEquatable<GDIDWithISOKey>
public value class GDIDWithISOKey : IDistributedStableHashProvider,
    IEquatable<GDIDWithISOKey>
[<SealedAttribute>]
type GDIDWithISOKey =
    struct
        interface IDistributedStableHashProvider
        interface IEquatable<GDIDWithISOKey>
    end
[<SealedAttribute>]
type GDIDWithISOKey =
    struct
        interface IDistributedStableHashProvider
        interface IEquatable<GDIDWithISOKey>
    end
See Also
GDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


GDIDWithISOKey Members

GDIDWithISOKey Members NFX Class Library

The GDIDWithISOKey type exposes the following members.
Constructors
 | Name | Description
Public method | GDIDWithISOKey | Initializes a new instance of the GDIDWithISOKey class
Back to Top
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(GDIDWithISOKey) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDistributedStableHash |
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | GDID |
Public field | ISO |
Back to Top
Properties
 | Name | Description
Public property | ISOCode |
Back to Top
See Also
GDIDWithISOKey Structure
NFX.ApplicationModel.Pile Namespace


GDIDWithISOKey Constructor

GDIDWithISOKey Constructor NFX Class Library

Initializes a new instance of the GDIDWithISOKey class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GDIDWithISOKey(
    GDID gdid,
    string iso
)
public GDIDWithISOKey(
    GDID gdid,
    string iso
)
Public Sub New (
    gdid As GDID,
    iso As String
)
Public Sub New (
    gdid As GDID,
    iso As String
)
public:
GDIDWithISOKey(
    GDID gdid,
    String^ iso
)
public:
GDIDWithISOKey(
    GDID gdid,
    String^ iso
)
new :
        gdid : GDID *
        iso : string -> GDIDWithISOKey
new :
        gdid : GDID *
        iso : string -> GDIDWithISOKey

Parameters

gdid
Type: NFX.DataAccess.Distributed GDID
iso
Type: Online System String
See Also
GDIDWithISOKey Structure
GDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


GDIDWithISOKey Fields

GDIDWithISOKey Fields NFX Class Library

The GDIDWithISOKey type exposes the following members.
Fields
 | Name | Description
Public field | GDID |
Public field | ISO |
Back to Top
See Also
GDIDWithISOKey Structure
NFX.ApplicationModel.Pile Namespace


GDIDWithISOKey.GDID Field

GDIDWithISOKey GDID Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly GDID GDID
public readonly GDID GDID
Public ReadOnly GDID As GDID
Public ReadOnly GDID As GDID
public:
initonly GDID GDID
public:
initonly GDID GDID
val GDID: GDID
val GDID: GDID

Field Value

Type: GDID
See Also
GDIDWithISOKey Structure
GDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


GDIDWithISOKey.ISO Field

GDIDWithISOKey ISO Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int ISO
public readonly int ISO
Public ReadOnly ISO As Integer
Public ReadOnly ISO As Integer
public:
initonly int ISO
public:
initonly int ISO
val ISO: int
val ISO: int

Field Value

Type: Online Int32
See Also
GDIDWithISOKey Structure
GDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


GDIDWithISOKey Methods

GDIDWithISOKey Methods NFX Class Library

The GDIDWithISOKey type exposes the following members.
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(GDIDWithISOKey) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDistributedStableHash |
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GDIDWithISOKey Structure
NFX.ApplicationModel.Pile Namespace


GDIDWithISOKey.Equals Method

GDIDWithISOKey Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(GDIDWithISOKey) |
Back to Top
See Also
GDIDWithISOKey Structure
GDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


GDIDWithISOKey.Equals Method (Object)

GDIDWithISOKey Equals Method (Object) NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
GDIDWithISOKey Structure
GDIDWithISOKey Members
Equals Overload
NFX.ApplicationModel.Pile Namespace


GDIDWithISOKey.Equals Method (GDIDWithISOKey)

GDIDWithISOKey Equals Method (GDIDWithISOKey) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    GDIDWithISOKey other
)
public bool Equals(
    GDIDWithISOKey other
)
Public Function Equals (
    other As GDIDWithISOKey
) As Boolean
Public Function Equals (
    other As GDIDWithISOKey
) As Boolean
public:
virtual bool Equals(
    GDIDWithISOKey other
) sealed
public:
virtual bool Equals(
    GDIDWithISOKey other
) sealed
abstract Equals :
        other : GDIDWithISOKey -> bool
override Equals :
        other : GDIDWithISOKey -> bool
abstract Equals :
        other : GDIDWithISOKey -> bool
override Equals :
        other : GDIDWithISOKey -> bool

Parameters

other
Type: NFX.ApplicationModel.Pile GDIDWithISOKey

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
GDIDWithISOKey Structure
GDIDWithISOKey Members
Equals Overload
NFX.ApplicationModel.Pile Namespace


GDIDWithISOKey.GetDistributedStableHash Method

GDIDWithISOKey GetDistributedStableHash Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong GetDistributedStableHash()
public ulong GetDistributedStableHash()
Public Function GetDistributedStableHash As ULong
Public Function GetDistributedStableHash As ULong
public:
virtual unsigned long long GetDistributedStableHash() sealed
public:
virtual unsigned long long GetDistributedStableHash() sealed
abstract GetDistributedStableHash : unit -> uint64
override GetDistributedStableHash : unit -> uint64
abstract GetDistributedStableHash : unit -> uint64
override GetDistributedStableHash : unit -> uint64

Return Value

Type: Online UInt64

Implements

IDistributedStableHashProvider GetDistributedStableHash
See Also
GDIDWithISOKey Structure
GDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


GDIDWithISOKey.GetHashCode Method

GDIDWithISOKey GetHashCode Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
GDIDWithISOKey Structure
GDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


GDIDWithISOKey.ToString Method

GDIDWithISOKey ToString Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
GDIDWithISOKey Structure
GDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


GDIDWithISOKey Properties

GDIDWithISOKey Properties NFX Class Library

The GDIDWithISOKey type exposes the following members.
Properties
 | Name | Description
Public property | ISOCode |
Back to Top
See Also
GDIDWithISOKey Structure
NFX.ApplicationModel.Pile Namespace


GDIDWithISOKey.ISOCode Property

GDIDWithISOKey ISOCode Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ISOCode { get; }
public string ISOCode { get; }
Public ReadOnly Property ISOCode As String
    Get
Public ReadOnly Property ISOCode As String
    Get
public:
property String^ ISOCode {
    String^ get ();
}
public:
property String^ ISOCode {
    String^ get ();
}
member ISOCode : string with get
member ISOCode : string with get

Property Value

Type: Online String
See Also
GDIDWithISOKey Structure
GDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


GDIDWithStrHash Structure

GDIDWithStrHash Structure NFX Class Library

Represents a GDID with 8 byte string hash. The hash is case sensitive. The point of this structure is to avoid creation of references for Pile cache so keys alone do not stall the GC.

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct GDIDWithStrHash : IDistributedStableHashProvider,
    IEquatable<GDIDWithStrHash>
public struct GDIDWithStrHash : IDistributedStableHashProvider,
    IEquatable<GDIDWithStrHash>
Public Structure GDIDWithStrHash
    Implements IDistributedStableHashProvider, IEquatable(Of GDIDWithStrHash)
Public Structure GDIDWithStrHash
    Implements IDistributedStableHashProvider, IEquatable(Of GDIDWithStrHash)
public value class GDIDWithStrHash : IDistributedStableHashProvider,
    IEquatable<GDIDWithStrHash>
public value class GDIDWithStrHash : IDistributedStableHashProvider,
    IEquatable<GDIDWithStrHash>
[<SealedAttribute>]
type GDIDWithStrHash =
    struct
        interface IDistributedStableHashProvider
        interface IEquatable<GDIDWithStrHash>
    end
[<SealedAttribute>]
type GDIDWithStrHash =
    struct
        interface IDistributedStableHashProvider
        interface IEquatable<GDIDWithStrHash>
    end
See Also
GDIDWithStrHash Members
NFX.ApplicationModel.Pile Namespace


GDIDWithStrHash Members

GDIDWithStrHash Members NFX Class Library

The GDIDWithStrHash type exposes the following members.
Constructors
 | Name | Description
Public method | GDIDWithStrHash | Initializes a new instance of the GDIDWithStrHash class
Back to Top
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(GDIDWithStrHash) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDistributedStableHash |
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | StrToHash |
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | GDID |
Public field | Hash |
Back to Top
See Also
GDIDWithStrHash Structure
NFX.ApplicationModel.Pile Namespace


GDIDWithStrHash Constructor

GDIDWithStrHash Constructor NFX Class Library

Initializes a new instance of the GDIDWithStrHash class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GDIDWithStrHash(
    GDID gdid,
    string key
)
public GDIDWithStrHash(
    GDID gdid,
    string key
)
Public Sub New (
    gdid As GDID,
    key As String
)
Public Sub New (
    gdid As GDID,
    key As String
)
public:
GDIDWithStrHash(
    GDID gdid,
    String^ key
)
public:
GDIDWithStrHash(
    GDID gdid,
    String^ key
)
new :
        gdid : GDID *
        key : string -> GDIDWithStrHash
new :
        gdid : GDID *
        key : string -> GDIDWithStrHash

Parameters

gdid
Type: NFX.DataAccess.Distributed GDID
key
Type: Online System String
See Also
GDIDWithStrHash Structure
GDIDWithStrHash Members
NFX.ApplicationModel.Pile Namespace


GDIDWithStrHash Fields

GDIDWithStrHash Fields NFX Class Library

The GDIDWithStrHash type exposes the following members.
Fields
 | Name | Description
Public field | GDID |
Public field | Hash |
Back to Top
See Also
GDIDWithStrHash Structure
NFX.ApplicationModel.Pile Namespace


GDIDWithStrHash.GDID Field

GDIDWithStrHash GDID Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly GDID GDID
public readonly GDID GDID
Public ReadOnly GDID As GDID
Public ReadOnly GDID As GDID
public:
initonly GDID GDID
public:
initonly GDID GDID
val GDID: GDID
val GDID: GDID

Field Value

Type: GDID
See Also
GDIDWithStrHash Structure
GDIDWithStrHash Members
NFX.ApplicationModel.Pile Namespace


GDIDWithStrHash.Hash Field

GDIDWithStrHash Hash Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ulong Hash
public readonly ulong Hash
Public ReadOnly Hash As ULong
Public ReadOnly Hash As ULong
public:
initonly unsigned long long Hash
public:
initonly unsigned long long Hash
val Hash: uint64
val Hash: uint64

Field Value

Type: Online UInt64
See Also
GDIDWithStrHash Structure
GDIDWithStrHash Members
NFX.ApplicationModel.Pile Namespace


GDIDWithStrHash Methods

GDIDWithStrHash Methods NFX Class Library

The GDIDWithStrHash type exposes the following members.
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(GDIDWithStrHash) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDistributedStableHash |
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | StrToHash |
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GDIDWithStrHash Structure
NFX.ApplicationModel.Pile Namespace


GDIDWithStrHash.Equals Method

GDIDWithStrHash Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(GDIDWithStrHash) |
Back to Top
See Also
GDIDWithStrHash Structure
GDIDWithStrHash Members
NFX.ApplicationModel.Pile Namespace


GDIDWithStrHash.Equals Method (Object)

GDIDWithStrHash Equals Method (Object) NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
GDIDWithStrHash Structure
GDIDWithStrHash Members
Equals Overload
NFX.ApplicationModel.Pile Namespace


GDIDWithStrHash.Equals Method (GDIDWithStrHash)

GDIDWithStrHash Equals Method (GDIDWithStrHash) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    GDIDWithStrHash other
)
public bool Equals(
    GDIDWithStrHash other
)
Public Function Equals (
    other As GDIDWithStrHash
) As Boolean
Public Function Equals (
    other As GDIDWithStrHash
) As Boolean
public:
virtual bool Equals(
    GDIDWithStrHash other
) sealed
public:
virtual bool Equals(
    GDIDWithStrHash other
) sealed
abstract Equals :
        other : GDIDWithStrHash -> bool
override Equals :
        other : GDIDWithStrHash -> bool
abstract Equals :
        other : GDIDWithStrHash -> bool
override Equals :
        other : GDIDWithStrHash -> bool

Parameters

other
Type: NFX.ApplicationModel.Pile GDIDWithStrHash

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
GDIDWithStrHash Structure
GDIDWithStrHash Members
Equals Overload
NFX.ApplicationModel.Pile Namespace


GDIDWithStrHash.GetDistributedStableHash Method

GDIDWithStrHash GetDistributedStableHash Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong GetDistributedStableHash()
public ulong GetDistributedStableHash()
Public Function GetDistributedStableHash As ULong
Public Function GetDistributedStableHash As ULong
public:
virtual unsigned long long GetDistributedStableHash() sealed
public:
virtual unsigned long long GetDistributedStableHash() sealed
abstract GetDistributedStableHash : unit -> uint64
override GetDistributedStableHash : unit -> uint64
abstract GetDistributedStableHash : unit -> uint64
override GetDistributedStableHash : unit -> uint64

Return Value

Type: Online UInt64

Implements

IDistributedStableHashProvider GetDistributedStableHash
See Also
GDIDWithStrHash Structure
GDIDWithStrHash Members
NFX.ApplicationModel.Pile Namespace


GDIDWithStrHash.GetHashCode Method

GDIDWithStrHash GetHashCode Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
GDIDWithStrHash Structure
GDIDWithStrHash Members
NFX.ApplicationModel.Pile Namespace


GDIDWithStrHash.StrToHash Method

GDIDWithStrHash StrToHash Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ulong StrToHash(
    string key
)
public static ulong StrToHash(
    string key
)
Public Shared Function StrToHash (
    key As String
) As ULong
Public Shared Function StrToHash (
    key As String
) As ULong
public:
static unsigned long long StrToHash(
    String^ key
)
public:
static unsigned long long StrToHash(
    String^ key
)
static member StrToHash :
        key : string -> uint64
static member StrToHash :
        key : string -> uint64

Parameters

key
Type: Online System String

Return Value

Type: Online UInt64
See Also
GDIDWithStrHash Structure
GDIDWithStrHash Members
NFX.ApplicationModel.Pile Namespace


GDIDWithStrHash.ToString Method

GDIDWithStrHash ToString Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
GDIDWithStrHash Structure
GDIDWithStrHash Members
NFX.ApplicationModel.Pile Namespace


ICache Interface

ICache Interface NFX Class Library

Represents a cache of expiring objects, which are identified by a key and stored in a pile. Pile allows to store hundreds of millions of objects without overloading the managed GC. The cache may be local or distributed

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ICache : IApplicationComponent, IDisposable
public interface ICache : IApplicationComponent, IDisposable
Public Interface ICache
    Inherits IApplicationComponent, IDisposable
Public Interface ICache
    Inherits IApplicationComponent, IDisposable
public interface class ICache : IApplicationComponent,
    IDisposable
public interface class ICache : IApplicationComponent,
    IDisposable
type ICache =
    interface
        interface IApplicationComponent
        interface IDisposable
    end
type ICache =
    interface
        interface IApplicationComponent
        interface IDisposable
    end
See Also
ICache Members
NFX.ApplicationModel.Pile Namespace


ICache Members

ICache Members NFX Class Library

The ICache type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | GetOrCreateTable TKey (String, IEqualityComparer TKey ) | Returns existing table by name, if it does not exist creates a new table. For existing table the types must be identical to the ones used at creation
Public method | GetOrCreateTable TKey (String, Boolean , IEqualityComparer TKey ) | Returns existing table by name, if it does not exist creates a new table. For existing table the types must be identical to the ones used at creation
Public method | GetTable TKey | Returns existing table by name, if it does not exist thorws. The TKey must correspond to existing table
Public method | PurgeAll | Removes all data from all tables stored in the cache
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | DeleteThrough TKey | (Defined by CacheExtensions.)
Public Extension Method | FetchFrom TKey, TResult | Fetches an existing item from cache or null. IsAbsent is true when data was read from cache as an AbsentValue (Defined by CacheExtensions.)
Public Extension Method | FetchThrough TKey, TResult | Fetches an item through cache (Defined by CacheExtensions.)
Public Extension Method | SaveThrough TKey, TData | (Defined by CacheExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | Count | Returns how many records are kept in cache
Public property | Locality | Returns whether the cache key:value mappings are local or distributed
Public property | Persistence | Returns the model of key:value mapping persistence that this cache supports
Public property | PileStatus | Returns the status of the pile where object are stored
Public property | Tables | Tables that this cache contains
Back to Top
See Also
ICache Interface
NFX.ApplicationModel.Pile Namespace


ICache Methods

ICache Methods NFX Class Library

The ICache type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | GetOrCreateTable TKey (String, IEqualityComparer TKey ) | Returns existing table by name, if it does not exist creates a new table. For existing table the types must be identical to the ones used at creation
Public method | GetOrCreateTable TKey (String, Boolean , IEqualityComparer TKey ) | Returns existing table by name, if it does not exist creates a new table. For existing table the types must be identical to the ones used at creation
Public method | GetTable TKey | Returns existing table by name, if it does not exist thorws. The TKey must correspond to existing table
Public method | PurgeAll | Removes all data from all tables stored in the cache
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | DeleteThrough TKey | (Defined by CacheExtensions.)
Public Extension Method | FetchFrom TKey, TResult | Fetches an existing item from cache or null. IsAbsent is true when data was read from cache as an AbsentValue (Defined by CacheExtensions.)
Public Extension Method | FetchThrough TKey, TResult | Fetches an item through cache (Defined by CacheExtensions.)
Public Extension Method | SaveThrough TKey, TData | (Defined by CacheExtensions.)
Back to Top
See Also
ICache Interface
NFX.ApplicationModel.Pile Namespace


ICache.GetOrCreateTable Method

ICache GetOrCreateTable Method NFX Class Library

Overload List
 | Name | Description
Public method | GetOrCreateTable TKey (String, IEqualityComparer TKey ) | Returns existing table by name, if it does not exist creates a new table. For existing table the types must be identical to the ones used at creation
Public method | GetOrCreateTable TKey (String, Boolean , IEqualityComparer TKey ) | Returns existing table by name, if it does not exist creates a new table. For existing table the types must be identical to the ones used at creation
Back to Top
See Also
ICache Interface
ICache Members
NFX.ApplicationModel.Pile Namespace


ICache.GetOrCreateTable(TKey) Method (String, IEqualityComparer(TKey))

ICache GetOrCreateTable TKey Method (String, IEqualityComparer TKey ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns existing table by name, if it does not exist creates a new table. For existing table the types must be identical to the ones used at creation

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ICacheTable<TKey> GetOrCreateTable<TKey>(
    string tableName,
    IEqualityComparer<TKey> keyComparer = null
)
ICacheTable<TKey> GetOrCreateTable<TKey>(
    string tableName,
    IEqualityComparer<TKey> keyComparer = null
)
Function GetOrCreateTable(Of TKey) (
    tableName As String,
    Optional keyComparer As IEqualityComparer(Of TKey) = Nothing
) As ICacheTable(Of TKey)
Function GetOrCreateTable(Of TKey) (
    tableName As String,
    Optional keyComparer As IEqualityComparer(Of TKey) = Nothing
) As ICacheTable(Of TKey)
generic<typename TKey>
ICacheTable<TKey>^ GetOrCreateTable(
    String^ tableName,
    IEqualityComparer<TKey>^ keyComparer = nullptr
)
generic<typename TKey>
ICacheTable<TKey>^ GetOrCreateTable(
    String^ tableName,
    IEqualityComparer<TKey>^ keyComparer = nullptr
)
abstract GetOrCreateTable :
        tableName : string *
        ?keyComparer : IEqualityComparer<'TKey>
(* Defaults:
        let _keyComparer = defaultArg keyComparer null
*)
-> ICacheTable<'TKey>
abstract GetOrCreateTable :
        tableName : string *
        ?keyComparer : IEqualityComparer<'TKey>
(* Defaults:
        let _keyComparer = defaultArg keyComparer null
*)
-> ICacheTable<'TKey>

Parameters

tableName
Type: Online System String
keyComparer (Optional)
Type: Online System.Collections.Generic IEqualityComparer TKey
Type Parameters
TKey

Return Value

Type: ICacheTable TKey
See Also
ICache Interface
ICache Members
GetOrCreateTable Overload
NFX.ApplicationModel.Pile Namespace


ICache.GetOrCreateTable(TKey) Method (String, Boolean, IEqualityComparer(TKey))

ICache GetOrCreateTable TKey Method (String, Boolean , IEqualityComparer TKey ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns existing table by name, if it does not exist creates a new table. For existing table the types must be identical to the ones used at creation

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ICacheTable<TKey> GetOrCreateTable<TKey>(
    string tableName,
    out bool createdNew,
    IEqualityComparer<TKey> keyComparer = null
)
ICacheTable<TKey> GetOrCreateTable<TKey>(
    string tableName,
    out bool createdNew,
    IEqualityComparer<TKey> keyComparer = null
)
Function GetOrCreateTable(Of TKey) (
    tableName As String,
    <OutAttribute> ByRef createdNew As Boolean,
    Optional keyComparer As IEqualityComparer(Of TKey) = Nothing
) As ICacheTable(Of TKey)
Function GetOrCreateTable(Of TKey) (
    tableName As String,
    <OutAttribute> ByRef createdNew As Boolean,
    Optional keyComparer As IEqualityComparer(Of TKey) = Nothing
) As ICacheTable(Of TKey)
generic<typename TKey>
ICacheTable<TKey>^ GetOrCreateTable(
    String^ tableName,
    [OutAttribute] bool% createdNew,
    IEqualityComparer<TKey>^ keyComparer = nullptr
)
generic<typename TKey>
ICacheTable<TKey>^ GetOrCreateTable(
    String^ tableName,
    [OutAttribute] bool% createdNew,
    IEqualityComparer<TKey>^ keyComparer = nullptr
)
abstract GetOrCreateTable :
        tableName : string *
        createdNew : bool byref *
        ?keyComparer : IEqualityComparer<'TKey>
(* Defaults:
        let _keyComparer = defaultArg keyComparer null
*)
-> ICacheTable<'TKey>
abstract GetOrCreateTable :
        tableName : string *
        createdNew : bool byref *
        ?keyComparer : IEqualityComparer<'TKey>
(* Defaults:
        let _keyComparer = defaultArg keyComparer null
*)
-> ICacheTable<'TKey>

Parameters

tableName
Type: Online System String
createdNew
Type: Online System Boolean
keyComparer (Optional)
Type: Online System.Collections.Generic IEqualityComparer TKey
Type Parameters
TKey

Return Value

Type: ICacheTable TKey
See Also
ICache Interface
ICache Members
GetOrCreateTable Overload
NFX.ApplicationModel.Pile Namespace


ICache.GetTable(TKey) Method

ICache GetTable TKey Method NFX Class Library

Returns existing table by name, if it does not exist thorws. The TKey must correspond to existing table

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ICacheTable<TKey> GetTable<TKey>(
    string tableName
)
ICacheTable<TKey> GetTable<TKey>(
    string tableName
)
Function GetTable(Of TKey) (
    tableName As String
) As ICacheTable(Of TKey)
Function GetTable(Of TKey) (
    tableName As String
) As ICacheTable(Of TKey)
generic<typename TKey>
ICacheTable<TKey>^ GetTable(
    String^ tableName
)
generic<typename TKey>
ICacheTable<TKey>^ GetTable(
    String^ tableName
)
abstract GetTable :
        tableName : string -> ICacheTable<'TKey>
abstract GetTable :
        tableName : string -> ICacheTable<'TKey>

Parameters

tableName
Type: Online System String
Type Parameters
TKey

Return Value

Type: ICacheTable TKey
See Also
ICache Interface
ICache Members
NFX.ApplicationModel.Pile Namespace


ICache.PurgeAll Method

ICache PurgeAll Method NFX Class Library

Removes all data from all tables stored in the cache

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void PurgeAll()
void PurgeAll()
Sub PurgeAll
Sub PurgeAll
void PurgeAll()
void PurgeAll()
abstract PurgeAll : unit -> unit
abstract PurgeAll : unit -> unit
See Also
ICache Interface
ICache Members
NFX.ApplicationModel.Pile Namespace


ICache Properties

ICache Properties NFX Class Library

The ICache type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | Count | Returns how many records are kept in cache
Public property | Locality | Returns whether the cache key:value mappings are local or distributed
Public property | Persistence | Returns the model of key:value mapping persistence that this cache supports
Public property | PileStatus | Returns the status of the pile where object are stored
Public property | Tables | Tables that this cache contains
Back to Top
See Also
ICache Interface
NFX.ApplicationModel.Pile Namespace


ICache.Count Property

ICache Count Property NFX Class Library

Returns how many records are kept in cache

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
long Count { get; }
long Count { get; }
ReadOnly Property Count As Long
    Get
ReadOnly Property Count As Long
    Get
property long long Count {
    long long get ();
}
property long long Count {
    long long get ();
}
abstract Count : int64 with get
abstract Count : int64 with get

Property Value

Type: Online Int64
See Also
ICache Interface
ICache Members
NFX.ApplicationModel.Pile Namespace


ICache.Locality Property

ICache Locality Property NFX Class Library

Returns whether the cache key:value mappings are local or distributed

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
LocalityKind Locality { get; }
LocalityKind Locality { get; }
ReadOnly Property Locality As LocalityKind
    Get
ReadOnly Property Locality As LocalityKind
    Get
property LocalityKind Locality {
    LocalityKind get ();
}
property LocalityKind Locality {
    LocalityKind get ();
}
abstract Locality : LocalityKind with get
abstract Locality : LocalityKind with get

Property Value

Type: LocalityKind
See Also
ICache Interface
ICache Members
NFX.ApplicationModel.Pile Namespace


ICache.Persistence Property

ICache Persistence Property NFX Class Library

Returns the model of key:value mapping persistence that this cache supports

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ObjectPersistence Persistence { get; }
ObjectPersistence Persistence { get; }
ReadOnly Property Persistence As ObjectPersistence
    Get
ReadOnly Property Persistence As ObjectPersistence
    Get
property ObjectPersistence Persistence {
    ObjectPersistence get ();
}
property ObjectPersistence Persistence {
    ObjectPersistence get ();
}
abstract Persistence : ObjectPersistence with get
abstract Persistence : ObjectPersistence with get

Property Value

Type: ObjectPersistence
See Also
ICache Interface
ICache Members
NFX.ApplicationModel.Pile Namespace


ICache.PileStatus Property

ICache PileStatus Property NFX Class Library

Returns the status of the pile where object are stored

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IPileStatus PileStatus { get; }
IPileStatus PileStatus { get; }
ReadOnly Property PileStatus As IPileStatus
    Get
ReadOnly Property PileStatus As IPileStatus
    Get
property IPileStatus^ PileStatus {
    IPileStatus^ get ();
}
property IPileStatus^ PileStatus {
    IPileStatus^ get ();
}
abstract PileStatus : IPileStatus with get
abstract PileStatus : IPileStatus with get

Property Value

Type: IPileStatus
See Also
ICache Interface
ICache Members
NFX.ApplicationModel.Pile Namespace


ICache.Tables Property

ICache Tables Property NFX Class Library

Tables that this cache contains

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IRegistry<ICacheTable> Tables { get; }
IRegistry<ICacheTable> Tables { get; }
ReadOnly Property Tables As IRegistry(Of ICacheTable)
    Get
ReadOnly Property Tables As IRegistry(Of ICacheTable)
    Get
property IRegistry<ICacheTable^>^ Tables {
    IRegistry<ICacheTable^>^ get ();
}
property IRegistry<ICacheTable^>^ Tables {
    IRegistry<ICacheTable^>^ get ();
}
abstract Tables : IRegistry<ICacheTable> with get
abstract Tables : IRegistry<ICacheTable> with get

Property Value

Type: IRegistry ICacheTable
See Also
ICache Interface
ICache Members
NFX.ApplicationModel.Pile Namespace


ICacheImplementation Interface

ICacheImplementation Interface NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ICacheImplementation : ICache,
    IApplicationComponent, IDisposable, IService, INamed, IConfigurable,
    IInstrumentable, IExternallyParameterized
public interface ICacheImplementation : ICache,
    IApplicationComponent, IDisposable, IService, INamed, IConfigurable,
    IInstrumentable, IExternallyParameterized
Public Interface ICacheImplementation
    Inherits ICache, IApplicationComponent, IDisposable, IService,
    INamed, IConfigurable, IInstrumentable, IExternallyParameterized
Public Interface ICacheImplementation
    Inherits ICache, IApplicationComponent, IDisposable, IService,
    INamed, IConfigurable, IInstrumentable, IExternallyParameterized
public interface class ICacheImplementation : ICache,
    IApplicationComponent, IDisposable, IService, INamed, IConfigurable,
    IInstrumentable, IExternallyParameterized
public interface class ICacheImplementation : ICache,
    IApplicationComponent, IDisposable, IService, INamed, IConfigurable,
    IInstrumentable, IExternallyParameterized
type ICacheImplementation =
    interface
        interface ICache
        interface IApplicationComponent
        interface IDisposable
        interface IService
        interface INamed
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
type ICacheImplementation =
    interface
        interface ICache
        interface IApplicationComponent
        interface IDisposable
        interface IService
        interface INamed
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
ICacheImplementation Members
NFX.ApplicationModel.Pile Namespace


ICacheImplementation Members

ICacheImplementation Members NFX Class Library

The ICacheImplementation type exposes the following members.
Methods
 | Name | Description
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from IService.)
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Public method | GetOrCreateTable TKey (String, IEqualityComparer TKey ) | Returns existing table by name, if it does not exist creates a new table. For existing table the types must be identical to the ones used at creation (Inherited from ICache.)
Public method | GetOrCreateTable TKey (String, Boolean , IEqualityComparer TKey ) | Returns existing table by name, if it does not exist creates a new table. For existing table the types must be identical to the ones used at creation (Inherited from ICache.)
Public method | GetTable TKey | Returns existing table by name, if it does not exist thorws. The TKey must correspond to existing table (Inherited from ICache.)
Public method | PurgeAll | Removes all data from all tables stored in the cache (Inherited from ICache.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from IService.)
Public method | Start | Blocking call that starts the service instance (Inherited from IService.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from IService.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | DeleteThrough TKey | (Defined by CacheExtensions.)
Public Extension Method | FetchFrom TKey, TResult | Fetches an existing item from cache or null. IsAbsent is true when data was read from cache as an AbsentValue (Defined by CacheExtensions.)
Public Extension Method | FetchThrough TKey, TResult | Fetches an item through cache (Defined by CacheExtensions.)
Public Extension Method | SaveThrough TKey, TData | (Defined by CacheExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | Count | Returns how many records are kept in cache (Inherited from ICache.)
Public property | DefaultTableOptions | Sets default options for a table which is not found in TableOptions collection. If this property is null then every table assumes the set of constant values defined in Table class
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | Locality | Returns whether the cache key:value mappings are local or distributed (Inherited from ICache.)
Public property | Name | (Inherited from INamed.)
Public property | Persistence | Returns the model of key:value mapping persistence that this cache supports (Inherited from ICache.)
Public property | PileAllocMode | Defines modes of allocation: space/time tradeoff
Public property | PileMaxMemoryLimit | Imposes a limit on maximum number of bytes that a pile can allocate of the system heap. The default value of 0 means no limit, meaning - the pile will keep allocating objects until the system allows. If the limit is reached, then the cache will start deleting older objects to releave the memory load even if they are not due for expiration yet
Public property | PileStatus | Returns the status of the pile where object are stored (Inherited from ICache.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from IService.)
Public property | Status | Current service status (Inherited from IService.)
Public property | TableOptions | Returns table options - used for table creation
Public property | Tables | Tables that this cache contains (Inherited from ICache.)
Back to Top
See Also
ICacheImplementation Interface
NFX.ApplicationModel.Pile Namespace


ICacheImplementation Methods

ICacheImplementation Methods NFX Class Library

The ICacheImplementation type exposes the following members.
Methods
 | Name | Description
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from IService.)
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Public method | GetOrCreateTable TKey (String, IEqualityComparer TKey ) | Returns existing table by name, if it does not exist creates a new table. For existing table the types must be identical to the ones used at creation (Inherited from ICache.)
Public method | GetOrCreateTable TKey (String, Boolean , IEqualityComparer TKey ) | Returns existing table by name, if it does not exist creates a new table. For existing table the types must be identical to the ones used at creation (Inherited from ICache.)
Public method | GetTable TKey | Returns existing table by name, if it does not exist thorws. The TKey must correspond to existing table (Inherited from ICache.)
Public method | PurgeAll | Removes all data from all tables stored in the cache (Inherited from ICache.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from IService.)
Public method | Start | Blocking call that starts the service instance (Inherited from IService.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from IService.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | DeleteThrough TKey | (Defined by CacheExtensions.)
Public Extension Method | FetchFrom TKey, TResult | Fetches an existing item from cache or null. IsAbsent is true when data was read from cache as an AbsentValue (Defined by CacheExtensions.)
Public Extension Method | FetchThrough TKey, TResult | Fetches an item through cache (Defined by CacheExtensions.)
Public Extension Method | SaveThrough TKey, TData | (Defined by CacheExtensions.)
Back to Top
See Also
ICacheImplementation Interface
NFX.ApplicationModel.Pile Namespace


ICacheImplementation Properties

ICacheImplementation Properties NFX Class Library

The ICacheImplementation type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | Count | Returns how many records are kept in cache (Inherited from ICache.)
Public property | DefaultTableOptions | Sets default options for a table which is not found in TableOptions collection. If this property is null then every table assumes the set of constant values defined in Table class
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | Locality | Returns whether the cache key:value mappings are local or distributed (Inherited from ICache.)
Public property | Name | (Inherited from INamed.)
Public property | Persistence | Returns the model of key:value mapping persistence that this cache supports (Inherited from ICache.)
Public property | PileAllocMode | Defines modes of allocation: space/time tradeoff
Public property | PileMaxMemoryLimit | Imposes a limit on maximum number of bytes that a pile can allocate of the system heap. The default value of 0 means no limit, meaning - the pile will keep allocating objects until the system allows. If the limit is reached, then the cache will start deleting older objects to releave the memory load even if they are not due for expiration yet
Public property | PileStatus | Returns the status of the pile where object are stored (Inherited from ICache.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from IService.)
Public property | Status | Current service status (Inherited from IService.)
Public property | TableOptions | Returns table options - used for table creation
Public property | Tables | Tables that this cache contains (Inherited from ICache.)
Back to Top
See Also
ICacheImplementation Interface
NFX.ApplicationModel.Pile Namespace


ICacheImplementation.DefaultTableOptions Property

ICacheImplementation DefaultTableOptions Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Sets default options for a table which is not found in TableOptions collection. If this property is null then every table assumes the set of constant values defined in Table class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
TableOptions DefaultTableOptions { get; set; }
TableOptions DefaultTableOptions { get; set; }
Property DefaultTableOptions As TableOptions
    Get
    Set
Property DefaultTableOptions As TableOptions
    Get
    Set
property TableOptions^ DefaultTableOptions {
    TableOptions^ get ();
    void set (TableOptions^ value);
}
property TableOptions^ DefaultTableOptions {
    TableOptions^ get ();
    void set (TableOptions^ value);
}
abstract DefaultTableOptions : TableOptions with get, set
abstract DefaultTableOptions : TableOptions with get, set

Property Value

Type: TableOptions
See Also
ICacheImplementation Interface
ICacheImplementation Members
NFX.ApplicationModel.Pile Namespace


ICacheImplementation.PileAllocMode Property

ICacheImplementation PileAllocMode Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Defines modes of allocation: space/time tradeoff

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
AllocationMode PileAllocMode { get; set; }
AllocationMode PileAllocMode { get; set; }
Property PileAllocMode As AllocationMode
    Get
    Set
Property PileAllocMode As AllocationMode
    Get
    Set
property AllocationMode PileAllocMode {
    AllocationMode get ();
    void set (AllocationMode value);
}
property AllocationMode PileAllocMode {
    AllocationMode get ();
    void set (AllocationMode value);
}
abstract PileAllocMode : AllocationMode with get, set
abstract PileAllocMode : AllocationMode with get, set

Property Value

Type: AllocationMode
See Also
ICacheImplementation Interface
ICacheImplementation Members
NFX.ApplicationModel.Pile Namespace


ICacheImplementation.PileMaxMemoryLimit Property

ICacheImplementation PileMaxMemoryLimit Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Imposes a limit on maximum number of bytes that a pile can allocate of the system heap. The default value of 0 means no limit, meaning - the pile will keep allocating objects until the system allows. If the limit is reached, then the cache will start deleting older objects to releave the memory load even if they are not due for expiration yet

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
long PileMaxMemoryLimit { get; set; }
long PileMaxMemoryLimit { get; set; }
Property PileMaxMemoryLimit As Long
    Get
    Set
Property PileMaxMemoryLimit As Long
    Get
    Set
property long long PileMaxMemoryLimit {
    long long get ();
    void set (long long value);
}
property long long PileMaxMemoryLimit {
    long long get ();
    void set (long long value);
}
abstract PileMaxMemoryLimit : int64 with get, set
abstract PileMaxMemoryLimit : int64 with get, set

Property Value

Type: Online Int64
See Also
ICacheImplementation Interface
ICacheImplementation Members
NFX.ApplicationModel.Pile Namespace


ICacheImplementation.TableOptions Property

ICacheImplementation TableOptions Property NFX Class Library

Returns table options - used for table creation

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Registry<TableOptions> TableOptions { get; }
Registry<TableOptions> TableOptions { get; }
ReadOnly Property TableOptions As Registry(Of TableOptions)
    Get
ReadOnly Property TableOptions As Registry(Of TableOptions)
    Get
property Registry<TableOptions^>^ TableOptions {
    Registry<TableOptions^>^ get ();
}
property Registry<TableOptions^>^ TableOptions {
    Registry<TableOptions^>^ get ();
}
abstract TableOptions : Registry<TableOptions> with get
abstract TableOptions : Registry<TableOptions> with get

Property Value

Type: Registry TableOptions
See Also
ICacheImplementation Interface
ICacheImplementation Members
NFX.ApplicationModel.Pile Namespace


ICacheTable Interface

ICacheTable Interface NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ICacheTable : INamed
public interface ICacheTable : INamed
Public Interface ICacheTable
    Inherits INamed
Public Interface ICacheTable
    Inherits INamed
public interface class ICacheTable : INamed
public interface class ICacheTable : INamed
type ICacheTable =
    interface
        interface INamed
    end
type ICacheTable =
    interface
        interface INamed
    end
See Also
ICacheTable Members
NFX.ApplicationModel.Pile Namespace


ICacheTable Members

ICacheTable Members NFX Class Library

The ICacheTable type exposes the following members.
Methods
 | Name | Description
Public method | Purge | Removes all data from table
Back to Top
Properties
 | Name | Description
Public property | Cache | References cache that this table is under
Public property | Capacity | Returns how many slots/entries allocated in a table
Public property | Count | Returns how many records are kept in a table
Public property | LoadFactor | Returns the percentage of occupied table slots. When this number exceeds high-water-mark threshold the table is grown, otheriwse if the number falls below the low-water-mark level then the table is shrunk
Public property | Name | (Inherited from INamed.)
Public property | Options | Cache table options in effect
Back to Top
See Also
ICacheTable Interface
NFX.ApplicationModel.Pile Namespace


ICacheTable Methods

ICacheTable Methods NFX Class Library

The ICacheTable type exposes the following members.
Methods
 | Name | Description
Public method | Purge | Removes all data from table
Back to Top
See Also
ICacheTable Interface
NFX.ApplicationModel.Pile Namespace


ICacheTable.Purge Method

ICacheTable Purge Method NFX Class Library

Removes all data from table

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Purge()
void Purge()
Sub Purge
Sub Purge
void Purge()
void Purge()
abstract Purge : unit -> unit
abstract Purge : unit -> unit
See Also
ICacheTable Interface
ICacheTable Members
NFX.ApplicationModel.Pile Namespace


ICacheTable Properties

ICacheTable Properties NFX Class Library

The ICacheTable type exposes the following members.
Properties
 | Name | Description
Public property | Cache | References cache that this table is under
Public property | Capacity | Returns how many slots/entries allocated in a table
Public property | Count | Returns how many records are kept in a table
Public property | LoadFactor | Returns the percentage of occupied table slots. When this number exceeds high-water-mark threshold the table is grown, otheriwse if the number falls below the low-water-mark level then the table is shrunk
Public property | Name | (Inherited from INamed.)
Public property | Options | Cache table options in effect
Back to Top
See Also
ICacheTable Interface
NFX.ApplicationModel.Pile Namespace


ICacheTable.Cache Property

ICacheTable Cache Property NFX Class Library

References cache that this table is under

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ICache Cache { get; }
ICache Cache { get; }
ReadOnly Property Cache As ICache
    Get
ReadOnly Property Cache As ICache
    Get
property ICache^ Cache {
    ICache^ get ();
}
property ICache^ Cache {
    ICache^ get ();
}
abstract Cache : ICache with get
abstract Cache : ICache with get

Property Value

Type: ICache
See Also
ICacheTable Interface
ICacheTable Members
NFX.ApplicationModel.Pile Namespace


ICacheTable.Capacity Property

ICacheTable Capacity Property NFX Class Library

Returns how many slots/entries allocated in a table

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
long Capacity { get; }
long Capacity { get; }
ReadOnly Property Capacity As Long
    Get
ReadOnly Property Capacity As Long
    Get
property long long Capacity {
    long long get ();
}
property long long Capacity {
    long long get ();
}
abstract Capacity : int64 with get
abstract Capacity : int64 with get

Property Value

Type: Online Int64
See Also
ICacheTable Interface
ICacheTable Members
NFX.ApplicationModel.Pile Namespace


ICacheTable.Count Property

ICacheTable Count Property NFX Class Library

Returns how many records are kept in a table

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
long Count { get; }
long Count { get; }
ReadOnly Property Count As Long
    Get
ReadOnly Property Count As Long
    Get
property long long Count {
    long long get ();
}
property long long Count {
    long long get ();
}
abstract Count : int64 with get
abstract Count : int64 with get

Property Value

Type: Online Int64
See Also
ICacheTable Interface
ICacheTable Members
NFX.ApplicationModel.Pile Namespace


ICacheTable.LoadFactor Property

ICacheTable LoadFactor Property NFX Class Library

Returns the percentage of occupied table slots. When this number exceeds high-water-mark threshold the table is grown, otheriwse if the number falls below the low-water-mark level then the table is shrunk

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
double LoadFactor { get; }
double LoadFactor { get; }
ReadOnly Property LoadFactor As Double
    Get
ReadOnly Property LoadFactor As Double
    Get
property double LoadFactor {
    double get ();
}
property double LoadFactor {
    double get ();
}
abstract LoadFactor : float with get
abstract LoadFactor : float with get

Property Value

Type: Online Double
See Also
ICacheTable Interface
ICacheTable Members
NFX.ApplicationModel.Pile Namespace


ICacheTable.Options Property

ICacheTable Options Property NFX Class Library

Cache table options in effect

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
TableOptions Options { get; }
TableOptions Options { get; }
ReadOnly Property Options As TableOptions
    Get
ReadOnly Property Options As TableOptions
    Get
property TableOptions^ Options {
    TableOptions^ get ();
}
property TableOptions^ Options {
    TableOptions^ get ();
}
abstract Options : TableOptions with get
abstract Options : TableOptions with get

Property Value

Type: TableOptions
See Also
ICacheTable Interface
ICacheTable Members
NFX.ApplicationModel.Pile Namespace


ICacheTable(TKey) Interface

ICacheTable TKey Interface NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ICacheTable<TKey> : ICacheTable,
    INamed
public interface ICacheTable<TKey> : ICacheTable,
    INamed
Public Interface ICacheTable(Of TKey)
    Inherits ICacheTable, INamed
Public Interface ICacheTable(Of TKey)
    Inherits ICacheTable, INamed
generic<typename TKey>
public interface class ICacheTable : ICacheTable,
    INamed
generic<typename TKey>
public interface class ICacheTable : ICacheTable,
    INamed
type ICacheTable<'TKey> =
    interface
        interface ICacheTable
        interface INamed
    end
type ICacheTable<'TKey> =
    interface
        interface ICacheTable
        interface INamed
    end
Type Parameters
TKey
See Also
ICacheTable TKey Members
NFX.ApplicationModel.Pile Namespace


ICacheTable(TKey) Members

ICacheTable TKey Members NFX Class Library

The ICacheTable TKey type exposes the following members.
Methods
 | Name | Description
Public method | ContainsKey | Returns true if cache has object with the key, optionally filtering-out objects older than ageSec param if it is > zero. Returns false if there is no object with the specified key or it is older than ageSec limit.
Public method | Get | Gets cache object by key, optionally filtering-out objects older than ageSec param if it is > zero. Returns null if there is no object with the specified key or it is older than ageSec limit.
Public method | GetOrPut | Atomically tries to get object by key if it exists, otherwise calls a factory method under lock and puts the data with the specified parameters. 'newPutResult' returns the result of the put after factory method call. Keep in mind, that even if a factory method created a new object, there may be a case when the value could not be physically inserted in the cache because of a collision (data with higher priority occupies space and space is capped), so check for 'newPutResult' value which is null in case of getting an existing item. Returns object that was gotten or created anew
Public method | Purge | Removes all data from table (Inherited from ICacheTable.)
Public method | Put | Puts an object identified by a key into cache returning the result of the put. For example, put may have added nothing if the table is capped and the space is occupied with data of higher priority
Public method | Rejuvenate | Resets inetrnal object age returning true of object was found and rejuvenated
Public method | Remove | Removes data by key returning true if found and removed
Public method | SizeOfValue | Returns the size of stored object if cache has object with the key, optionally filtering-out objects older than ageSec param if it is > zero.
Back to Top
Properties
 | Name | Description
Public property | Cache | References cache that this table is under (Inherited from ICacheTable.)
Public property | Capacity | Returns how many slots/entries allocated in a table (Inherited from ICacheTable.)
Public property | Count | Returns how many records are kept in a table (Inherited from ICacheTable.)
Public property | KeyComparer | Returns equality comparer for keys, or null to use default Equals
Public property | LoadFactor | Returns the percentage of occupied table slots. When this number exceeds high-water-mark threshold the table is grown, otheriwse if the number falls below the low-water-mark level then the table is shrunk (Inherited from ICacheTable.)
Public property | Name | (Inherited from INamed.)
Public property | Options | Cache table options in effect (Inherited from ICacheTable.)
Back to Top
See Also
ICacheTable TKey Interface
NFX.ApplicationModel.Pile Namespace


ICacheTable(TKey) Methods

ICacheTable TKey Methods NFX Class Library

The ICacheTable TKey type exposes the following members.
Methods
 | Name | Description
Public method | ContainsKey | Returns true if cache has object with the key, optionally filtering-out objects older than ageSec param if it is > zero. Returns false if there is no object with the specified key or it is older than ageSec limit.
Public method | Get | Gets cache object by key, optionally filtering-out objects older than ageSec param if it is > zero. Returns null if there is no object with the specified key or it is older than ageSec limit.
Public method | GetOrPut | Atomically tries to get object by key if it exists, otherwise calls a factory method under lock and puts the data with the specified parameters. 'newPutResult' returns the result of the put after factory method call. Keep in mind, that even if a factory method created a new object, there may be a case when the value could not be physically inserted in the cache because of a collision (data with higher priority occupies space and space is capped), so check for 'newPutResult' value which is null in case of getting an existing item. Returns object that was gotten or created anew
Public method | Purge | Removes all data from table (Inherited from ICacheTable.)
Public method | Put | Puts an object identified by a key into cache returning the result of the put. For example, put may have added nothing if the table is capped and the space is occupied with data of higher priority
Public method | Rejuvenate | Resets inetrnal object age returning true of object was found and rejuvenated
Public method | Remove | Removes data by key returning true if found and removed
Public method | SizeOfValue | Returns the size of stored object if cache has object with the key, optionally filtering-out objects older than ageSec param if it is > zero.
Back to Top
See Also
ICacheTable TKey Interface
NFX.ApplicationModel.Pile Namespace


ICacheTable(TKey).ContainsKey Method

ICacheTable TKey ContainsKey Method NFX Class Library

Returns true if cache has object with the key, optionally filtering-out objects older than ageSec param if it is > zero. Returns false if there is no object with the specified key or it is older than ageSec limit.

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool ContainsKey(
    TKey key,
    int ageSec = 0
)
bool ContainsKey(
    TKey key,
    int ageSec = 0
)
Function ContainsKey (
    key As TKey,
    Optional ageSec As Integer = 0
) As Boolean
Function ContainsKey (
    key As TKey,
    Optional ageSec As Integer = 0
) As Boolean
bool ContainsKey(
    TKey key,
    int ageSec = 0
)
bool ContainsKey(
    TKey key,
    int ageSec = 0
)
abstract ContainsKey :
        key : 'TKey *
        ?ageSec : int
(* Defaults:
        let _ageSec = defaultArg ageSec 0
*)
-> bool
abstract ContainsKey :
        key : 'TKey *
        ?ageSec : int
(* Defaults:
        let _ageSec = defaultArg ageSec 0
*)
-> bool

Parameters

key
Type: TKey
ageSec (Optional)
Type: Online System Int32

Return Value

Type: Online Boolean
See Also
ICacheTable TKey Interface
ICacheTable TKey Members
NFX.ApplicationModel.Pile Namespace


ICacheTable(TKey).Get Method

ICacheTable TKey Get Method NFX Class Library

Gets cache object by key, optionally filtering-out objects older than ageSec param if it is > zero. Returns null if there is no object with the specified key or it is older than ageSec limit.

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object Get(
    TKey key,
    int ageSec = 0
)
Object Get(
    TKey key,
    int ageSec = 0
)
Function Get (
    key As TKey,
    Optional ageSec As Integer = 0
) As Object
Function Get (
    key As TKey,
    Optional ageSec As Integer = 0
) As Object
Object^ Get(
    TKey key,
    int ageSec = 0
)
Object^ Get(
    TKey key,
    int ageSec = 0
)
abstract Get :
        key : 'TKey *
        ?ageSec : int
(* Defaults:
        let _ageSec = defaultArg ageSec 0
*)
-> Object
abstract Get :
        key : 'TKey *
        ?ageSec : int
(* Defaults:
        let _ageSec = defaultArg ageSec 0
*)
-> Object

Parameters

key
Type: TKey
ageSec (Optional)
Type: Online System Int32

Return Value

Type: Online Object
See Also
ICacheTable TKey Interface
ICacheTable TKey Members
NFX.ApplicationModel.Pile Namespace


ICacheTable(TKey).GetOrPut Method

ICacheTable TKey GetOrPut Method NFX Class Library

Atomically tries to get object by key if it exists, otherwise calls a factory method under lock and puts the data with the specified parameters. 'newPutResult' returns the result of the put after factory method call. Keep in mind, that even if a factory method created a new object, there may be a case when the value could not be physically inserted in the cache because of a collision (data with higher priority occupies space and space is capped), so check for 'newPutResult' value which is null in case of getting an existing item. Returns object that was gotten or created anew

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object GetOrPut(
    TKey key,
    Func<ICacheTable<TKey>, TKey, Object, Object> valueFactory,
    Object factoryContext,
    out Nullable<PutResult> newPutResult,
    int ageSec = 0,
    int putMaxAgeSec = 0,
    int putPriority = 0,
    Nullable<DateTime> putAbsoluteExpirationUTC = null
)
Object GetOrPut(
    TKey key,
    Func<ICacheTable<TKey>, TKey, Object, Object> valueFactory,
    Object factoryContext,
    out Nullable<PutResult> newPutResult,
    int ageSec = 0,
    int putMaxAgeSec = 0,
    int putPriority = 0,
    Nullable<DateTime> putAbsoluteExpirationUTC = null
)
Function GetOrPut (
    key As TKey,
    valueFactory As Func(Of ICacheTable(Of TKey), TKey, Object, Object),
    factoryContext As Object,
    <OutAttribute> ByRef newPutResult As Nullable(Of PutResult),
    Optional ageSec As Integer = 0,
    Optional putMaxAgeSec As Integer = 0,
    Optional putPriority As Integer = 0,
    Optional putAbsoluteExpirationUTC As Nullable(Of DateTime) = Nothing
) As Object
Function GetOrPut (
    key As TKey,
    valueFactory As Func(Of ICacheTable(Of TKey), TKey, Object, Object),
    factoryContext As Object,
    <OutAttribute> ByRef newPutResult As Nullable(Of PutResult),
    Optional ageSec As Integer = 0,
    Optional putMaxAgeSec As Integer = 0,
    Optional putPriority As Integer = 0,
    Optional putAbsoluteExpirationUTC As Nullable(Of DateTime) = Nothing
) As Object
Object^ GetOrPut(
    TKey key,
    Func<ICacheTable<TKey>^, TKey, Object^, Object^>^ valueFactory,
    Object^ factoryContext,
    [OutAttribute] Nullable<PutResult>% newPutResult,
    int ageSec = 0,
    int putMaxAgeSec = 0,
    int putPriority = 0,
    Nullable<DateTime> putAbsoluteExpirationUTC = nullptr
)
Object^ GetOrPut(
    TKey key,
    Func<ICacheTable<TKey>^, TKey, Object^, Object^>^ valueFactory,
    Object^ factoryContext,
    [OutAttribute] Nullable<PutResult>% newPutResult,
    int ageSec = 0,
    int putMaxAgeSec = 0,
    int putPriority = 0,
    Nullable<DateTime> putAbsoluteExpirationUTC = nullptr
)
abstract GetOrPut :
        key : 'TKey *
        valueFactory : Func<ICacheTable<'TKey>, 'TKey, Object, Object> *
        factoryContext : Object *
        newPutResult : Nullable<PutResult> byref *
        ?ageSec : int *
        ?putMaxAgeSec : int *
        ?putPriority : int *
        ?putAbsoluteExpirationUTC : Nullable<DateTime>
(* Defaults:
        let _ageSec = defaultArg ageSec 0
        let _putMaxAgeSec = defaultArg putMaxAgeSec 0
        let _putPriority = defaultArg putPriority 0
        let _putAbsoluteExpirationUTC = defaultArg putAbsoluteExpirationUTC null
*)
-> Object
abstract GetOrPut :
        key : 'TKey *
        valueFactory : Func<ICacheTable<'TKey>, 'TKey, Object, Object> *
        factoryContext : Object *
        newPutResult : Nullable<PutResult> byref *
        ?ageSec : int *
        ?putMaxAgeSec : int *
        ?putPriority : int *
        ?putAbsoluteExpirationUTC : Nullable<DateTime>
(* Defaults:
        let _ageSec = defaultArg ageSec 0
        let _putMaxAgeSec = defaultArg putMaxAgeSec 0
        let _putPriority = defaultArg putPriority 0
        let _putAbsoluteExpirationUTC = defaultArg putAbsoluteExpirationUTC null
*)
-> Object

Parameters

key
Type: TKey
valueFactory
Type: Online System Func ICacheTable TKey , TKey, Online Object, Online Object
factoryContext
Type: Online System Object
newPutResult
Type: Online System Nullable PutResult
ageSec (Optional)
Type: Online System Int32
putMaxAgeSec (Optional)
Type: Online System Int32
putPriority (Optional)
Type: Online System Int32
putAbsoluteExpirationUTC (Optional)
Type: Online System Nullable Online DateTime

Return Value

Type: Online Object
See Also
ICacheTable TKey Interface
ICacheTable TKey Members
NFX.ApplicationModel.Pile Namespace


ICacheTable(TKey).Put Method

ICacheTable TKey Put Method NFX Class Library

Puts an object identified by a key into cache returning the result of the put. For example, put may have added nothing if the table is capped and the space is occupied with data of higher priority

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
PutResult Put(
    TKey key,
    Object obj,
    Nullable<int> maxAgeSec = null,
    int priority = 0,
    Nullable<DateTime> absoluteExpirationUTC = null
)
PutResult Put(
    TKey key,
    Object obj,
    Nullable<int> maxAgeSec = null,
    int priority = 0,
    Nullable<DateTime> absoluteExpirationUTC = null
)
Function Put (
    key As TKey,
    obj As Object,
    Optional maxAgeSec As Nullable(Of Integer) = Nothing,
    Optional priority As Integer = 0,
    Optional absoluteExpirationUTC As Nullable(Of DateTime) = Nothing
) As PutResult
Function Put (
    key As TKey,
    obj As Object,
    Optional maxAgeSec As Nullable(Of Integer) = Nothing,
    Optional priority As Integer = 0,
    Optional absoluteExpirationUTC As Nullable(Of DateTime) = Nothing
) As PutResult
PutResult Put(
    TKey key,
    Object^ obj,
    Nullable<int> maxAgeSec = nullptr,
    int priority = 0,
    Nullable<DateTime> absoluteExpirationUTC = nullptr
)
PutResult Put(
    TKey key,
    Object^ obj,
    Nullable<int> maxAgeSec = nullptr,
    int priority = 0,
    Nullable<DateTime> absoluteExpirationUTC = nullptr
)
abstract Put :
        key : 'TKey *
        obj : Object *
        ?maxAgeSec : Nullable<int> *
        ?priority : int *
        ?absoluteExpirationUTC : Nullable<DateTime>
(* Defaults:
        let _maxAgeSec = defaultArg maxAgeSec null
        let _priority = defaultArg priority 0
        let _absoluteExpirationUTC = defaultArg absoluteExpirationUTC null
*)
-> PutResult
abstract Put :
        key : 'TKey *
        obj : Object *
        ?maxAgeSec : Nullable<int> *
        ?priority : int *
        ?absoluteExpirationUTC : Nullable<DateTime>
(* Defaults:
        let _maxAgeSec = defaultArg maxAgeSec null
        let _priority = defaultArg priority 0
        let _absoluteExpirationUTC = defaultArg absoluteExpirationUTC null
*)
-> PutResult

Parameters

key
Type: TKey
A table-wide unique obvject key
obj
Type: Online System Object
An object to put
maxAgeSec (Optional)
Type: Online System Nullable Online Int32
If null then the default maxAgeSec is taken from Options property, otherwise specifies the length of items life in seconds
priority (Optional)
Type: Online System Int32
The priority of this item. If there is no space in future the items with lower priorities will not evict existing data with highr priorities
absoluteExpirationUTC (Optional)
Type: Online System Nullable Online DateTime
Optional UTC timestamp of object eviction from cache

Return Value

Type: PutResult
The status of put - whether item was inserted/replaced(if key exists)/overwritten or collided with higher-prioritized existing data
See Also
ICacheTable TKey Interface
ICacheTable TKey Members
NFX.ApplicationModel.Pile Namespace


ICacheTable(TKey).Rejuvenate Method

ICacheTable TKey Rejuvenate Method NFX Class Library

Resets inetrnal object age returning true of object was found and rejuvenated

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Rejuvenate(
    TKey key
)
bool Rejuvenate(
    TKey key
)
Function Rejuvenate (
    key As TKey
) As Boolean
Function Rejuvenate (
    key As TKey
) As Boolean
bool Rejuvenate(
    TKey key
)
bool Rejuvenate(
    TKey key
)
abstract Rejuvenate :
        key : 'TKey -> bool
abstract Rejuvenate :
        key : 'TKey -> bool

Parameters

key
Type: TKey

Return Value

Type: Online Boolean
See Also
ICacheTable TKey Interface
ICacheTable TKey Members
NFX.ApplicationModel.Pile Namespace


ICacheTable(TKey).Remove Method

ICacheTable TKey Remove Method NFX Class Library

Removes data by key returning true if found and removed

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Remove(
    TKey key
)
bool Remove(
    TKey key
)
Function Remove (
    key As TKey
) As Boolean
Function Remove (
    key As TKey
) As Boolean
bool Remove(
    TKey key
)
bool Remove(
    TKey key
)
abstract Remove :
        key : 'TKey -> bool
abstract Remove :
        key : 'TKey -> bool

Parameters

key
Type: TKey

Return Value

Type: Online Boolean
See Also
ICacheTable TKey Interface
ICacheTable TKey Members
NFX.ApplicationModel.Pile Namespace


ICacheTable(TKey).SizeOfValue Method

ICacheTable TKey SizeOfValue Method NFX Class Library

Returns the size of stored object if cache has object with the key, optionally filtering-out objects older than ageSec param if it is > zero.

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
long SizeOfValue(
    TKey key,
    int ageSec = 0
)
long SizeOfValue(
    TKey key,
    int ageSec = 0
)
Function SizeOfValue (
    key As TKey,
    Optional ageSec As Integer = 0
) As Long
Function SizeOfValue (
    key As TKey,
    Optional ageSec As Integer = 0
) As Long
long long SizeOfValue(
    TKey key,
    int ageSec = 0
)
long long SizeOfValue(
    TKey key,
    int ageSec = 0
)
abstract SizeOfValue :
        key : 'TKey *
        ?ageSec : int
(* Defaults:
        let _ageSec = defaultArg ageSec 0
*)
-> int64
abstract SizeOfValue :
        key : 'TKey *
        ?ageSec : int
(* Defaults:
        let _ageSec = defaultArg ageSec 0
*)
-> int64

Parameters

key
Type: TKey
ageSec (Optional)
Type: Online System Int32

Return Value

Type: Online Int64
See Also
ICacheTable TKey Interface
ICacheTable TKey Members
NFX.ApplicationModel.Pile Namespace


ICacheTable(TKey) Properties

ICacheTable TKey Properties NFX Class Library

The ICacheTable TKey type exposes the following members.
Properties
 | Name | Description
Public property | Cache | References cache that this table is under (Inherited from ICacheTable.)
Public property | Capacity | Returns how many slots/entries allocated in a table (Inherited from ICacheTable.)
Public property | Count | Returns how many records are kept in a table (Inherited from ICacheTable.)
Public property | KeyComparer | Returns equality comparer for keys, or null to use default Equals
Public property | LoadFactor | Returns the percentage of occupied table slots. When this number exceeds high-water-mark threshold the table is grown, otheriwse if the number falls below the low-water-mark level then the table is shrunk (Inherited from ICacheTable.)
Public property | Name | (Inherited from INamed.)
Public property | Options | Cache table options in effect (Inherited from ICacheTable.)
Back to Top
See Also
ICacheTable TKey Interface
NFX.ApplicationModel.Pile Namespace


ICacheTable(TKey).KeyComparer Property

ICacheTable TKey KeyComparer Property NFX Class Library

Returns equality comparer for keys, or null to use default Equals

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEqualityComparer<TKey> KeyComparer { get; }
IEqualityComparer<TKey> KeyComparer { get; }
ReadOnly Property KeyComparer As IEqualityComparer(Of TKey)
    Get
ReadOnly Property KeyComparer As IEqualityComparer(Of TKey)
    Get
property IEqualityComparer<TKey>^ KeyComparer {
    IEqualityComparer<TKey>^ get ();
}
property IEqualityComparer<TKey>^ KeyComparer {
    IEqualityComparer<TKey>^ get ();
}
abstract KeyComparer : IEqualityComparer<'TKey> with get
abstract KeyComparer : IEqualityComparer<'TKey> with get

Property Value

Type: Online IEqualityComparer TKey
See Also
ICacheTable TKey Interface
ICacheTable TKey Members
NFX.ApplicationModel.Pile Namespace


IPile Interface

IPile Interface NFX Class Library

Represents a pile of objects - a custom memory heap that can store native CLR objects in a tightly-serialized form. Piles can be either local (allocate local RAM on the server), or distributed (allocate RAM on many servers). This class is designed primarily for applications that need to store/cache very many (100s of millions on local, billions on distributed) of objects in RAM (and/or possibly on disk) without causing the local CLR's GC scans of huge object graphs. Implementors of this interface are custom memory managers that favor the GC performance in apps with many objects at the cost of higher CPU usage. The implementor must be thread-safe for all operations unless stated otherwise on a member level. The memory represented by this class as a whole is not synchronizable, that is - it does not support functions like Interlocked-family, Lock, MemoryBarriers and the like that regular RAM supports. Should a need arise to interlock within the pile - a custom CLR-based lock must be used to syncronize access to pile as a whole, for example: a Get does not impose a lock on ALL concurrent writes throught the pile (a write does not block all gets either).

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IPile : IPileStatus, IApplicationComponent,
    IDisposable
public interface IPile : IPileStatus, IApplicationComponent,
    IDisposable
Public Interface IPile
    Inherits IPileStatus, IApplicationComponent, IDisposable
Public Interface IPile
    Inherits IPileStatus, IApplicationComponent, IDisposable
public interface class IPile : IPileStatus,
    IApplicationComponent, IDisposable
public interface class IPile : IPileStatus,
    IApplicationComponent, IDisposable
type IPile =
    interface
        interface IPileStatus
        interface IApplicationComponent
        interface IDisposable
    end
type IPile =
    interface
        interface IPileStatus
        interface IApplicationComponent
        interface IDisposable
    end
See Also
IPile Members
NFX.ApplicationModel.Pile Namespace


IPile Members

IPile Members NFX Class Library

The IPile type exposes the following members.
Methods
 | Name | Description
Public method | Compact | Tries to delete extra capacity which is allocated but not currently needed. Returns the number of bytes freed back to the system
Public method | Delete | Deletes object from pile by its pointer returning true if there is no access violation and pointer is pointing to the valid object, throws otherwise unless throwInvalid is set to false
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | Get | Returns a CLR object by its pointer or throws access violation if pointer is invalid
Public method | GetRawBuffer | Returns a raw byte[] occupied by the object payload, only payload is returned along with serializer flag which tells what kind of serializer was used. This method is rarely used, it is needed for debugging and special-case "direct" memory access on read to bypass the de-serialization process altogether
Public method | Purge | Deletes all objects freeing all segment memory buffers. This method may require the caller to have special rights
Public method | Put | Puts a CLR object into the pile and returns a newly-allocated pointer. Throws out-of-space if there is not enough space in the pile and limits are set. Optional lifeSpanSec will auto-delete object after the interval elapses if the pile SupportsObjectExpiration and SweepExpireObjects is set to true
Public method | Rejuvenate | If pile supports expiration, resets object age to zero. Returns true if object was found and reset. N/A for pile that do not support expiration
Public method | SizeOf | Returns the size of pointed-to object in bytes or throws access violation if pointer is invalid. The serialized object size is returned, not the CLR object size.
Back to Top
Properties
 | Name | Description
Public property | AllocatedMemoryBytes | Returns the number of bytes allocated by this pile from system memory (Inherited from IPileStatus.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | Locality | Returns whether pile is local or distributed (Inherited from IPileStatus.)
Public property | MemoryCapacityBytes | Returns an approximate capacity of free memory that the system has left (Inherited from IPileStatus.)
Public property | NodeCount | Returns the number of nodes(servers) that service this distributed pile. If this pile locality is local then returns 1 (Inherited from IPileStatus.)
Public property | ObjectCount | Returns the number of allocated objects in this pile (Inherited from IPileStatus.)
Public property | OverheadBytes | Returns the number of extra bytes used by pile metadata currently occupied by object stored in this pile (Inherited from IPileStatus.)
Public property | Persistence | Returns the model of object persistence that this pile supports (Inherited from IPileStatus.)
Public property | SegmentCount | Returns the number of segments allocated (Inherited from IPileStatus.)
Public property | SupportsObjectExpiration | Returns whether this instance supports object expiration (Inherited from IPileStatus.)
Public property | UtilizedBytes | Returns the number of bytes allocated for object storage within AllocatedMemoryBytes (Inherited from IPileStatus.)
Back to Top
See Also
IPile Interface
NFX.ApplicationModel.Pile Namespace


IPile Methods

IPile Methods NFX Class Library

The IPile type exposes the following members.
Methods
 | Name | Description
Public method | Compact | Tries to delete extra capacity which is allocated but not currently needed. Returns the number of bytes freed back to the system
Public method | Delete | Deletes object from pile by its pointer returning true if there is no access violation and pointer is pointing to the valid object, throws otherwise unless throwInvalid is set to false
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | Get | Returns a CLR object by its pointer or throws access violation if pointer is invalid
Public method | GetRawBuffer | Returns a raw byte[] occupied by the object payload, only payload is returned along with serializer flag which tells what kind of serializer was used. This method is rarely used, it is needed for debugging and special-case "direct" memory access on read to bypass the de-serialization process altogether
Public method | Purge | Deletes all objects freeing all segment memory buffers. This method may require the caller to have special rights
Public method | Put | Puts a CLR object into the pile and returns a newly-allocated pointer. Throws out-of-space if there is not enough space in the pile and limits are set. Optional lifeSpanSec will auto-delete object after the interval elapses if the pile SupportsObjectExpiration and SweepExpireObjects is set to true
Public method | Rejuvenate | If pile supports expiration, resets object age to zero. Returns true if object was found and reset. N/A for pile that do not support expiration
Public method | SizeOf | Returns the size of pointed-to object in bytes or throws access violation if pointer is invalid. The serialized object size is returned, not the CLR object size.
Back to Top
See Also
IPile Interface
NFX.ApplicationModel.Pile Namespace


IPile.Compact Method

IPile Compact Method NFX Class Library

Tries to delete extra capacity which is allocated but not currently needed. Returns the number of bytes freed back to the system

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
long Compact()
long Compact()
Function Compact As Long
Function Compact As Long
long long Compact()
long long Compact()
abstract Compact : unit -> int64
abstract Compact : unit -> int64

Return Value

Type: Online Int64
See Also
IPile Interface
IPile Members
NFX.ApplicationModel.Pile Namespace


IPile.Delete Method

IPile Delete Method NFX Class Library

Deletes object from pile by its pointer returning true if there is no access violation and pointer is pointing to the valid object, throws otherwise unless throwInvalid is set to false

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Delete(
    PilePointer ptr,
    bool throwInvalid = true
)
bool Delete(
    PilePointer ptr,
    bool throwInvalid = true
)
Function Delete (
    ptr As PilePointer,
    Optional throwInvalid As Boolean = true
) As Boolean
Function Delete (
    ptr As PilePointer,
    Optional throwInvalid As Boolean = true
) As Boolean
bool Delete(
    PilePointer ptr,
    bool throwInvalid = true
)
bool Delete(
    PilePointer ptr,
    bool throwInvalid = true
)
abstract Delete :
        ptr : PilePointer *
        ?throwInvalid : bool
(* Defaults:
        let _throwInvalid = defaultArg throwInvalid true
*)
-> bool
abstract Delete :
        ptr : PilePointer *
        ?throwInvalid : bool
(* Defaults:
        let _throwInvalid = defaultArg throwInvalid true
*)
-> bool

Parameters

ptr
Type: NFX.ApplicationModel.Pile PilePointer
throwInvalid (Optional)
Type: Online System Boolean

Return Value

Type: Online Boolean
See Also
IPile Interface
IPile Members
NFX.ApplicationModel.Pile Namespace


IPile.Get Method

IPile Get Method NFX Class Library

Returns a CLR object by its pointer or throws access violation if pointer is invalid

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object Get(
    PilePointer ptr
)
Object Get(
    PilePointer ptr
)
Function Get (
    ptr As PilePointer
) As Object
Function Get (
    ptr As PilePointer
) As Object
Object^ Get(
    PilePointer ptr
)
Object^ Get(
    PilePointer ptr
)
abstract Get :
        ptr : PilePointer -> Object
abstract Get :
        ptr : PilePointer -> Object

Parameters

ptr
Type: NFX.ApplicationModel.Pile PilePointer

Return Value

Type: Online Object
See Also
IPile Interface
IPile Members
NFX.ApplicationModel.Pile Namespace


IPile.GetRawBuffer Method

IPile GetRawBuffer Method NFX Class Library

Returns a raw byte[] occupied by the object payload, only payload is returned along with serializer flag which tells what kind of serializer was used. This method is rarely used, it is needed for debugging and special-case "direct" memory access on read to bypass the de-serialization process altogether

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
byte[] GetRawBuffer(
    PilePointer ptr,
    out byte serializerFlag
)
byte[] GetRawBuffer(
    PilePointer ptr,
    out byte serializerFlag
)
Function GetRawBuffer (
    ptr As PilePointer,
    <OutAttribute> ByRef serializerFlag As Byte
) As Byte()
Function GetRawBuffer (
    ptr As PilePointer,
    <OutAttribute> ByRef serializerFlag As Byte
) As Byte()
array<unsigned char>^ GetRawBuffer(
    PilePointer ptr,
    [OutAttribute] unsigned char% serializerFlag
)
array<unsigned char>^ GetRawBuffer(
    PilePointer ptr,
    [OutAttribute] unsigned char% serializerFlag
)
abstract GetRawBuffer :
        ptr : PilePointer *
        serializerFlag : byte byref -> byte[]
abstract GetRawBuffer :
        ptr : PilePointer *
        serializerFlag : byte byref -> byte[]

Parameters

ptr
Type: NFX.ApplicationModel.Pile PilePointer
serializerFlag
Type: Online System Byte

Return Value

Type: Online Byte
See Also
IPile Interface
IPile Members
NFX.ApplicationModel.Pile Namespace


IPile.Purge Method

IPile Purge Method NFX Class Library

Deletes all objects freeing all segment memory buffers. This method may require the caller to have special rights

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Purge()
void Purge()
Sub Purge
Sub Purge
void Purge()
void Purge()
abstract Purge : unit -> unit
abstract Purge : unit -> unit
See Also
IPile Interface
IPile Members
NFX.ApplicationModel.Pile Namespace


IPile.Put Method

IPile Put Method NFX Class Library

Puts a CLR object into the pile and returns a newly-allocated pointer. Throws out-of-space if there is not enough space in the pile and limits are set. Optional lifeSpanSec will auto-delete object after the interval elapses if the pile SupportsObjectExpiration and SweepExpireObjects is set to true

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
PilePointer Put(
    Object obj,
    uint lifeSpanSec = 0
)
PilePointer Put(
    Object obj,
    uint lifeSpanSec = 0
)
Function Put (
    obj As Object,
    Optional lifeSpanSec As UInteger = 0
) As PilePointer
Function Put (
    obj As Object,
    Optional lifeSpanSec As UInteger = 0
) As PilePointer
PilePointer Put(
    Object^ obj,
    unsigned int lifeSpanSec = 0
)
PilePointer Put(
    Object^ obj,
    unsigned int lifeSpanSec = 0
)
abstract Put :
        obj : Object *
        ?lifeSpanSec : uint32
(* Defaults:
        let _lifeSpanSec = defaultArg lifeSpanSec 0
*)
-> PilePointer
abstract Put :
        obj : Object *
        ?lifeSpanSec : uint32
(* Defaults:
        let _lifeSpanSec = defaultArg lifeSpanSec 0
*)
-> PilePointer

Parameters

obj
Type: Online System Object
lifeSpanSec (Optional)
Type: Online System UInt32

Return Value

Type: PilePointer
See Also
IPile Interface
IPile Members
NFX.ApplicationModel.Pile Namespace


IPile.Rejuvenate Method

IPile Rejuvenate Method NFX Class Library

If pile supports expiration, resets object age to zero. Returns true if object was found and reset. N/A for pile that do not support expiration

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Rejuvenate(
    PilePointer ptr
)
bool Rejuvenate(
    PilePointer ptr
)
Function Rejuvenate (
    ptr As PilePointer
) As Boolean
Function Rejuvenate (
    ptr As PilePointer
) As Boolean
bool Rejuvenate(
    PilePointer ptr
)
bool Rejuvenate(
    PilePointer ptr
)
abstract Rejuvenate :
        ptr : PilePointer -> bool
abstract Rejuvenate :
        ptr : PilePointer -> bool

Parameters

ptr
Type: NFX.ApplicationModel.Pile PilePointer

Return Value

Type: Online Boolean
See Also
IPile Interface
IPile Members
NFX.ApplicationModel.Pile Namespace


IPile.SizeOf Method

IPile SizeOf Method NFX Class Library

Returns the size of pointed-to object in bytes or throws access violation if pointer is invalid. The serialized object size is returned, not the CLR object size.

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int SizeOf(
    PilePointer ptr
)
int SizeOf(
    PilePointer ptr
)
Function SizeOf (
    ptr As PilePointer
) As Integer
Function SizeOf (
    ptr As PilePointer
) As Integer
int SizeOf(
    PilePointer ptr
)
int SizeOf(
    PilePointer ptr
)
abstract SizeOf :
        ptr : PilePointer -> int
abstract SizeOf :
        ptr : PilePointer -> int

Parameters

ptr
Type: NFX.ApplicationModel.Pile PilePointer

Return Value

Type: Online Int32
See Also
IPile Interface
IPile Members
NFX.ApplicationModel.Pile Namespace


IPile Properties

IPile Properties NFX Class Library

The IPile type exposes the following members.
Properties
 | Name | Description
Public property | AllocatedMemoryBytes | Returns the number of bytes allocated by this pile from system memory (Inherited from IPileStatus.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | Locality | Returns whether pile is local or distributed (Inherited from IPileStatus.)
Public property | MemoryCapacityBytes | Returns an approximate capacity of free memory that the system has left (Inherited from IPileStatus.)
Public property | NodeCount | Returns the number of nodes(servers) that service this distributed pile. If this pile locality is local then returns 1 (Inherited from IPileStatus.)
Public property | ObjectCount | Returns the number of allocated objects in this pile (Inherited from IPileStatus.)
Public property | OverheadBytes | Returns the number of extra bytes used by pile metadata currently occupied by object stored in this pile (Inherited from IPileStatus.)
Public property | Persistence | Returns the model of object persistence that this pile supports (Inherited from IPileStatus.)
Public property | SegmentCount | Returns the number of segments allocated (Inherited from IPileStatus.)
Public property | SupportsObjectExpiration | Returns whether this instance supports object expiration (Inherited from IPileStatus.)
Public property | UtilizedBytes | Returns the number of bytes allocated for object storage within AllocatedMemoryBytes (Inherited from IPileStatus.)
Back to Top
See Also
IPile Interface
NFX.ApplicationModel.Pile Namespace


IPileImplementation Interface

IPileImplementation Interface NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IPileImplementation : IPile,
    IPileStatus, IApplicationComponent, IDisposable, IService, INamed,
    IConfigurable, IInstrumentable, IExternallyParameterized
public interface IPileImplementation : IPile,
    IPileStatus, IApplicationComponent, IDisposable, IService, INamed,
    IConfigurable, IInstrumentable, IExternallyParameterized
Public Interface IPileImplementation
    Inherits IPile, IPileStatus, IApplicationComponent, IDisposable,
    IService, INamed, IConfigurable, IInstrumentable, IExternallyParameterized
Public Interface IPileImplementation
    Inherits IPile, IPileStatus, IApplicationComponent, IDisposable,
    IService, INamed, IConfigurable, IInstrumentable, IExternallyParameterized
public interface class IPileImplementation : IPile,
    IPileStatus, IApplicationComponent, IDisposable, IService, INamed,
    IConfigurable, IInstrumentable, IExternallyParameterized
public interface class IPileImplementation : IPile,
    IPileStatus, IApplicationComponent, IDisposable, IService, INamed,
    IConfigurable, IInstrumentable, IExternallyParameterized
type IPileImplementation =
    interface
        interface IPile
        interface IPileStatus
        interface IApplicationComponent
        interface IDisposable
        interface IService
        interface INamed
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
type IPileImplementation =
    interface
        interface IPile
        interface IPileStatus
        interface IApplicationComponent
        interface IDisposable
        interface IService
        interface INamed
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
IPileImplementation Members
NFX.ApplicationModel.Pile Namespace


IPileImplementation Members

IPileImplementation Members NFX Class Library

The IPileImplementation type exposes the following members.
Methods
 | Name | Description
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from IService.)
Public method | Compact | Tries to delete extra capacity which is allocated but not currently needed. Returns the number of bytes freed back to the system (Inherited from IPile.)
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Delete | Deletes object from pile by its pointer returning true if there is no access violation and pointer is pointing to the valid object, throws otherwise unless throwInvalid is set to false (Inherited from IPile.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Public method | Get | Returns a CLR object by its pointer or throws access violation if pointer is invalid (Inherited from IPile.)
Public method | GetRawBuffer | Returns a raw byte[] occupied by the object payload, only payload is returned along with serializer flag which tells what kind of serializer was used. This method is rarely used, it is needed for debugging and special-case "direct" memory access on read to bypass the de-serialization process altogether (Inherited from IPile.)
Public method | Purge | Deletes all objects freeing all segment memory buffers. This method may require the caller to have special rights (Inherited from IPile.)
Public method | Put | Puts a CLR object into the pile and returns a newly-allocated pointer. Throws out-of-space if there is not enough space in the pile and limits are set. Optional lifeSpanSec will auto-delete object after the interval elapses if the pile SupportsObjectExpiration and SweepExpireObjects is set to true (Inherited from IPile.)
Public method | Rejuvenate | If pile supports expiration, resets object age to zero. Returns true if object was found and reset. N/A for pile that do not support expiration (Inherited from IPile.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from IService.)
Public method | SizeOf | Returns the size of pointed-to object in bytes or throws access violation if pointer is invalid. The serialized object size is returned, not the CLR object size. (Inherited from IPile.)
Public method | Start | Blocking call that starts the service instance (Inherited from IService.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from IService.)
Back to Top
Properties
 | Name | Description
Public property | AllocatedMemoryBytes | Returns the number of bytes allocated by this pile from system memory (Inherited from IPileStatus.)
Public property | AllocMode | Defines modes of allocation: space/time tradeoff
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | Locality | Returns whether pile is local or distributed (Inherited from IPileStatus.)
Public property | MaxMemoryLimit | Imposes a limit on maximum number of bytes that a pile can allocate of the system heap. The default value of 0 means no limit, meaning - the pile will keep allocating objects until the system allows
Public property | MaxSegmentLimit | Gets the maximum count of segments that this pile can have. The property is not thread-safe for set and can only be set if pile is inactive. The value of zero means no limit
Public property | MemoryCapacityBytes | Returns an approximate capacity of free memory that the system has left (Inherited from IPileStatus.)
Public property | Name | (Inherited from INamed.)
Public property | NodeCount | Returns the number of nodes(servers) that service this distributed pile. If this pile locality is local then returns 1 (Inherited from IPileStatus.)
Public property | ObjectCount | Returns the number of allocated objects in this pile (Inherited from IPileStatus.)
Public property | OverheadBytes | Returns the number of extra bytes used by pile metadata currently occupied by object stored in this pile (Inherited from IPileStatus.)
Public property | Persistence | Returns the model of object persistence that this pile supports (Inherited from IPileStatus.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from IService.)
Public property | SegmentCount | Returns the number of segments allocated (Inherited from IPileStatus.)
Public property | SegmentSize | Gets the segment size in bytes, up to (2^31)-1 The property is not thread-safe for set and can only be set if pile is inactive
Public property | Status | Current service status (Inherited from IService.)
Public property | SupportsObjectExpiration | Returns whether this instance supports object expiration (Inherited from IPileStatus.)
Public property | SweepExpiredObjects | Control whether the instance respects object life spans if they are set
Public property | UtilizedBytes | Returns the number of bytes allocated for object storage within AllocatedMemoryBytes (Inherited from IPileStatus.)
Back to Top
See Also
IPileImplementation Interface
NFX.ApplicationModel.Pile Namespace


IPileImplementation Methods

IPileImplementation Methods NFX Class Library

The IPileImplementation type exposes the following members.
Methods
 | Name | Description
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from IService.)
Public method | Compact | Tries to delete extra capacity which is allocated but not currently needed. Returns the number of bytes freed back to the system (Inherited from IPile.)
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Delete | Deletes object from pile by its pointer returning true if there is no access violation and pointer is pointing to the valid object, throws otherwise unless throwInvalid is set to false (Inherited from IPile.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Public method | Get | Returns a CLR object by its pointer or throws access violation if pointer is invalid (Inherited from IPile.)
Public method | GetRawBuffer | Returns a raw byte[] occupied by the object payload, only payload is returned along with serializer flag which tells what kind of serializer was used. This method is rarely used, it is needed for debugging and special-case "direct" memory access on read to bypass the de-serialization process altogether (Inherited from IPile.)
Public method | Purge | Deletes all objects freeing all segment memory buffers. This method may require the caller to have special rights (Inherited from IPile.)
Public method | Put | Puts a CLR object into the pile and returns a newly-allocated pointer. Throws out-of-space if there is not enough space in the pile and limits are set. Optional lifeSpanSec will auto-delete object after the interval elapses if the pile SupportsObjectExpiration and SweepExpireObjects is set to true (Inherited from IPile.)
Public method | Rejuvenate | If pile supports expiration, resets object age to zero. Returns true if object was found and reset. N/A for pile that do not support expiration (Inherited from IPile.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from IService.)
Public method | SizeOf | Returns the size of pointed-to object in bytes or throws access violation if pointer is invalid. The serialized object size is returned, not the CLR object size. (Inherited from IPile.)
Public method | Start | Blocking call that starts the service instance (Inherited from IService.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from IService.)
Back to Top
See Also
IPileImplementation Interface
NFX.ApplicationModel.Pile Namespace


IPileImplementation Properties

IPileImplementation Properties NFX Class Library

The IPileImplementation type exposes the following members.
Properties
 | Name | Description
Public property | AllocatedMemoryBytes | Returns the number of bytes allocated by this pile from system memory (Inherited from IPileStatus.)
Public property | AllocMode | Defines modes of allocation: space/time tradeoff
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | Locality | Returns whether pile is local or distributed (Inherited from IPileStatus.)
Public property | MaxMemoryLimit | Imposes a limit on maximum number of bytes that a pile can allocate of the system heap. The default value of 0 means no limit, meaning - the pile will keep allocating objects until the system allows
Public property | MaxSegmentLimit | Gets the maximum count of segments that this pile can have. The property is not thread-safe for set and can only be set if pile is inactive. The value of zero means no limit
Public property | MemoryCapacityBytes | Returns an approximate capacity of free memory that the system has left (Inherited from IPileStatus.)
Public property | Name | (Inherited from INamed.)
Public property | NodeCount | Returns the number of nodes(servers) that service this distributed pile. If this pile locality is local then returns 1 (Inherited from IPileStatus.)
Public property | ObjectCount | Returns the number of allocated objects in this pile (Inherited from IPileStatus.)
Public property | OverheadBytes | Returns the number of extra bytes used by pile metadata currently occupied by object stored in this pile (Inherited from IPileStatus.)
Public property | Persistence | Returns the model of object persistence that this pile supports (Inherited from IPileStatus.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from IService.)
Public property | SegmentCount | Returns the number of segments allocated (Inherited from IPileStatus.)
Public property | SegmentSize | Gets the segment size in bytes, up to (2^31)-1 The property is not thread-safe for set and can only be set if pile is inactive
Public property | Status | Current service status (Inherited from IService.)
Public property | SupportsObjectExpiration | Returns whether this instance supports object expiration (Inherited from IPileStatus.)
Public property | SweepExpiredObjects | Control whether the instance respects object life spans if they are set
Public property | UtilizedBytes | Returns the number of bytes allocated for object storage within AllocatedMemoryBytes (Inherited from IPileStatus.)
Back to Top
See Also
IPileImplementation Interface
NFX.ApplicationModel.Pile Namespace


IPileImplementation.AllocMode Property

IPileImplementation AllocMode Property NFX Class Library

Defines modes of allocation: space/time tradeoff

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
AllocationMode AllocMode { get; set; }
AllocationMode AllocMode { get; set; }
Property AllocMode As AllocationMode
    Get
    Set
Property AllocMode As AllocationMode
    Get
    Set
property AllocationMode AllocMode {
    AllocationMode get ();
    void set (AllocationMode value);
}
property AllocationMode AllocMode {
    AllocationMode get ();
    void set (AllocationMode value);
}
abstract AllocMode : AllocationMode with get, set
abstract AllocMode : AllocationMode with get, set

Property Value

Type: AllocationMode
See Also
IPileImplementation Interface
IPileImplementation Members
NFX.ApplicationModel.Pile Namespace


IPileImplementation.MaxMemoryLimit Property

IPileImplementation MaxMemoryLimit Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Imposes a limit on maximum number of bytes that a pile can allocate of the system heap. The default value of 0 means no limit, meaning - the pile will keep allocating objects until the system allows

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
long MaxMemoryLimit { get; set; }
long MaxMemoryLimit { get; set; }
Property MaxMemoryLimit As Long
    Get
    Set
Property MaxMemoryLimit As Long
    Get
    Set
property long long MaxMemoryLimit {
    long long get ();
    void set (long long value);
}
property long long MaxMemoryLimit {
    long long get ();
    void set (long long value);
}
abstract MaxMemoryLimit : int64 with get, set
abstract MaxMemoryLimit : int64 with get, set

Property Value

Type: Online Int64
See Also
IPileImplementation Interface
IPileImplementation Members
NFX.ApplicationModel.Pile Namespace


IPileImplementation.MaxSegmentLimit Property

IPileImplementation MaxSegmentLimit Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets the maximum count of segments that this pile can have. The property is not thread-safe for set and can only be set if pile is inactive. The value of zero means no limit

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int MaxSegmentLimit { get; set; }
int MaxSegmentLimit { get; set; }
Property MaxSegmentLimit As Integer
    Get
    Set
Property MaxSegmentLimit As Integer
    Get
    Set
property int MaxSegmentLimit {
    int get ();
    void set (int value);
}
property int MaxSegmentLimit {
    int get ();
    void set (int value);
}
abstract MaxSegmentLimit : int with get, set
abstract MaxSegmentLimit : int with get, set

Property Value

Type: Online Int32
See Also
IPileImplementation Interface
IPileImplementation Members
NFX.ApplicationModel.Pile Namespace


IPileImplementation.SegmentSize Property

IPileImplementation SegmentSize Property NFX Class Library

Gets the segment size in bytes, up to (2^31)-1 The property is not thread-safe for set and can only be set if pile is inactive

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int SegmentSize { get; set; }
int SegmentSize { get; set; }
Property SegmentSize As Integer
    Get
    Set
Property SegmentSize As Integer
    Get
    Set
property int SegmentSize {
    int get ();
    void set (int value);
}
property int SegmentSize {
    int get ();
    void set (int value);
}
abstract SegmentSize : int with get, set
abstract SegmentSize : int with get, set

Property Value

Type: Online Int32
See Also
IPileImplementation Interface
IPileImplementation Members
NFX.ApplicationModel.Pile Namespace


IPileImplementation.SweepExpiredObjects Property

IPileImplementation SweepExpiredObjects Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Control whether the instance respects object life spans if they are set

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool SweepExpiredObjects { get; set; }
bool SweepExpiredObjects { get; set; }
Property SweepExpiredObjects As Boolean
    Get
    Set
Property SweepExpiredObjects As Boolean
    Get
    Set
property bool SweepExpiredObjects {
    bool get ();
    void set (bool value);
}
property bool SweepExpiredObjects {
    bool get ();
    void set (bool value);
}
abstract SweepExpiredObjects : bool with get, set
abstract SweepExpiredObjects : bool with get, set

Property Value

Type: Online Boolean
See Also
IPileImplementation Interface
IPileImplementation Members
NFX.ApplicationModel.Pile Namespace


IPileStatus Interface

IPileStatus Interface NFX Class Library

Provides information about the pile - number of objects, allocated bytes, etc.

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IPileStatus
public interface IPileStatus
Public Interface IPileStatus
Public Interface IPileStatus
public interface class IPileStatus
public interface class IPileStatus
type IPileStatus =  interface end
type IPileStatus =  interface end
See Also
IPileStatus Members
NFX.ApplicationModel.Pile Namespace


IPileStatus Members

IPileStatus Members NFX Class Library

The IPileStatus type exposes the following members.
Properties
 | Name | Description
Public property | AllocatedMemoryBytes | Returns the number of bytes allocated by this pile from system memory
Public property | Locality | Returns whether pile is local or distributed
Public property | MemoryCapacityBytes | Returns an approximate capacity of free memory that the system has left
Public property | NodeCount | Returns the number of nodes(servers) that service this distributed pile. If this pile locality is local then returns 1
Public property | ObjectCount | Returns the number of allocated objects in this pile
Public property | OverheadBytes | Returns the number of extra bytes used by pile metadata currently occupied by object stored in this pile
Public property | Persistence | Returns the model of object persistence that this pile supports
Public property | SegmentCount | Returns the number of segments allocated
Public property | SupportsObjectExpiration | Returns whether this instance supports object expiration
Public property | UtilizedBytes | Returns the number of bytes allocated for object storage within AllocatedMemoryBytes
Back to Top
See Also
IPileStatus Interface
NFX.ApplicationModel.Pile Namespace


IPileStatus Properties

IPileStatus Properties NFX Class Library

The IPileStatus type exposes the following members.
Properties
 | Name | Description
Public property | AllocatedMemoryBytes | Returns the number of bytes allocated by this pile from system memory
Public property | Locality | Returns whether pile is local or distributed
Public property | MemoryCapacityBytes | Returns an approximate capacity of free memory that the system has left
Public property | NodeCount | Returns the number of nodes(servers) that service this distributed pile. If this pile locality is local then returns 1
Public property | ObjectCount | Returns the number of allocated objects in this pile
Public property | OverheadBytes | Returns the number of extra bytes used by pile metadata currently occupied by object stored in this pile
Public property | Persistence | Returns the model of object persistence that this pile supports
Public property | SegmentCount | Returns the number of segments allocated
Public property | SupportsObjectExpiration | Returns whether this instance supports object expiration
Public property | UtilizedBytes | Returns the number of bytes allocated for object storage within AllocatedMemoryBytes
Back to Top
See Also
IPileStatus Interface
NFX.ApplicationModel.Pile Namespace


IPileStatus.AllocatedMemoryBytes Property

IPileStatus AllocatedMemoryBytes Property NFX Class Library

Returns the number of bytes allocated by this pile from system memory

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
long AllocatedMemoryBytes { get; }
long AllocatedMemoryBytes { get; }
ReadOnly Property AllocatedMemoryBytes As Long
    Get
ReadOnly Property AllocatedMemoryBytes As Long
    Get
property long long AllocatedMemoryBytes {
    long long get ();
}
property long long AllocatedMemoryBytes {
    long long get ();
}
abstract AllocatedMemoryBytes : int64 with get
abstract AllocatedMemoryBytes : int64 with get

Property Value

Type: Online Int64
See Also
IPileStatus Interface
IPileStatus Members
NFX.ApplicationModel.Pile Namespace


IPileStatus.Locality Property

IPileStatus Locality Property NFX Class Library

Returns whether pile is local or distributed

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
LocalityKind Locality { get; }
LocalityKind Locality { get; }
ReadOnly Property Locality As LocalityKind
    Get
ReadOnly Property Locality As LocalityKind
    Get
property LocalityKind Locality {
    LocalityKind get ();
}
property LocalityKind Locality {
    LocalityKind get ();
}
abstract Locality : LocalityKind with get
abstract Locality : LocalityKind with get

Property Value

Type: LocalityKind
See Also
IPileStatus Interface
IPileStatus Members
NFX.ApplicationModel.Pile Namespace


IPileStatus.MemoryCapacityBytes Property

IPileStatus MemoryCapacityBytes Property NFX Class Library

Returns an approximate capacity of free memory that the system has left

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
long MemoryCapacityBytes { get; }
long MemoryCapacityBytes { get; }
ReadOnly Property MemoryCapacityBytes As Long
    Get
ReadOnly Property MemoryCapacityBytes As Long
    Get
property long long MemoryCapacityBytes {
    long long get ();
}
property long long MemoryCapacityBytes {
    long long get ();
}
abstract MemoryCapacityBytes : int64 with get
abstract MemoryCapacityBytes : int64 with get

Property Value

Type: Online Int64
See Also
IPileStatus Interface
IPileStatus Members
NFX.ApplicationModel.Pile Namespace


IPileStatus.NodeCount Property

IPileStatus NodeCount Property NFX Class Library

Returns the number of nodes(servers) that service this distributed pile. If this pile locality is local then returns 1

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int NodeCount { get; }
int NodeCount { get; }
ReadOnly Property NodeCount As Integer
    Get
ReadOnly Property NodeCount As Integer
    Get
property int NodeCount {
    int get ();
}
property int NodeCount {
    int get ();
}
abstract NodeCount : int with get
abstract NodeCount : int with get

Property Value

Type: Online Int32
See Also
IPileStatus Interface
IPileStatus Members
NFX.ApplicationModel.Pile Namespace


IPileStatus.ObjectCount Property

IPileStatus ObjectCount Property NFX Class Library

Returns the number of allocated objects in this pile

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
long ObjectCount { get; }
long ObjectCount { get; }
ReadOnly Property ObjectCount As Long
    Get
ReadOnly Property ObjectCount As Long
    Get
property long long ObjectCount {
    long long get ();
}
property long long ObjectCount {
    long long get ();
}
abstract ObjectCount : int64 with get
abstract ObjectCount : int64 with get

Property Value

Type: Online Int64
See Also
IPileStatus Interface
IPileStatus Members
NFX.ApplicationModel.Pile Namespace


IPileStatus.OverheadBytes Property

IPileStatus OverheadBytes Property NFX Class Library

Returns the number of extra bytes used by pile metadata currently occupied by object stored in this pile

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
long OverheadBytes { get; }
long OverheadBytes { get; }
ReadOnly Property OverheadBytes As Long
    Get
ReadOnly Property OverheadBytes As Long
    Get
property long long OverheadBytes {
    long long get ();
}
property long long OverheadBytes {
    long long get ();
}
abstract OverheadBytes : int64 with get
abstract OverheadBytes : int64 with get

Property Value

Type: Online Int64
See Also
IPileStatus Interface
IPileStatus Members
NFX.ApplicationModel.Pile Namespace


IPileStatus.Persistence Property

IPileStatus Persistence Property NFX Class Library

Returns the model of object persistence that this pile supports

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ObjectPersistence Persistence { get; }
ObjectPersistence Persistence { get; }
ReadOnly Property Persistence As ObjectPersistence
    Get
ReadOnly Property Persistence As ObjectPersistence
    Get
property ObjectPersistence Persistence {
    ObjectPersistence get ();
}
property ObjectPersistence Persistence {
    ObjectPersistence get ();
}
abstract Persistence : ObjectPersistence with get
abstract Persistence : ObjectPersistence with get

Property Value

Type: ObjectPersistence
See Also
IPileStatus Interface
IPileStatus Members
NFX.ApplicationModel.Pile Namespace


IPileStatus.SegmentCount Property

IPileStatus SegmentCount Property NFX Class Library

Returns the number of segments allocated

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
long SegmentCount { get; }
long SegmentCount { get; }
ReadOnly Property SegmentCount As Long
    Get
ReadOnly Property SegmentCount As Long
    Get
property long long SegmentCount {
    long long get ();
}
property long long SegmentCount {
    long long get ();
}
abstract SegmentCount : int64 with get
abstract SegmentCount : int64 with get

Property Value

Type: Online Int64
See Also
IPileStatus Interface
IPileStatus Members
NFX.ApplicationModel.Pile Namespace


IPileStatus.SupportsObjectExpiration Property

IPileStatus SupportsObjectExpiration Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns whether this instance supports object expiration

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool SupportsObjectExpiration { get; }
bool SupportsObjectExpiration { get; }
ReadOnly Property SupportsObjectExpiration As Boolean
    Get
ReadOnly Property SupportsObjectExpiration As Boolean
    Get
property bool SupportsObjectExpiration {
    bool get ();
}
property bool SupportsObjectExpiration {
    bool get ();
}
abstract SupportsObjectExpiration : bool with get
abstract SupportsObjectExpiration : bool with get

Property Value

Type: Online Boolean
See Also
IPileStatus Interface
IPileStatus Members
NFX.ApplicationModel.Pile Namespace


IPileStatus.UtilizedBytes Property

IPileStatus UtilizedBytes Property NFX Class Library

Returns the number of bytes allocated for object storage within AllocatedMemoryBytes

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
long UtilizedBytes { get; }
long UtilizedBytes { get; }
ReadOnly Property UtilizedBytes As Long
    Get
ReadOnly Property UtilizedBytes As Long
    Get
property long long UtilizedBytes {
    long long get ();
}
property long long UtilizedBytes {
    long long get ();
}
abstract UtilizedBytes : int64 with get
abstract UtilizedBytes : int64 with get

Property Value

Type: Online Int64
See Also
IPileStatus Interface
IPileStatus Members
NFX.ApplicationModel.Pile Namespace


LocalCache Class

LocalCache Class NFX Class Library

Provides default implementation of a cache that stores the mapping locally. The mapped-to objects may reside in local or distributed pile as configured
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service Online Object
NFX.ServiceModel ServiceWithInstrumentationBase Online Object
NFX.ApplicationModel.Pile LocalCache

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class LocalCache : ServiceWithInstrumentationBase<Object>,
    ICacheImplementation, ICache, IApplicationComponent, IDisposable, IService,
    INamed, IConfigurable, IInstrumentable, IExternallyParameterized
public sealed class LocalCache : ServiceWithInstrumentationBase<Object>,
    ICacheImplementation, ICache, IApplicationComponent, IDisposable, IService,
    INamed, IConfigurable, IInstrumentable, IExternallyParameterized
Public NotInheritable Class LocalCache
    Inherits ServiceWithInstrumentationBase(Of Object)
    Implements ICacheImplementation, ICache, IApplicationComponent, IDisposable,
    IService, INamed, IConfigurable, IInstrumentable, IExternallyParameterized
Public NotInheritable Class LocalCache
    Inherits ServiceWithInstrumentationBase(Of Object)
    Implements ICacheImplementation, ICache, IApplicationComponent, IDisposable,
    IService, INamed, IConfigurable, IInstrumentable, IExternallyParameterized
public ref class LocalCache sealed : public ServiceWithInstrumentationBase<Object^>,
    ICacheImplementation, ICache, IApplicationComponent, IDisposable, IService,
    INamed, IConfigurable, IInstrumentable, IExternallyParameterized
public ref class LocalCache sealed : public ServiceWithInstrumentationBase<Object^>,
    ICacheImplementation, ICache, IApplicationComponent, IDisposable, IService,
    INamed, IConfigurable, IInstrumentable, IExternallyParameterized
[<SealedAttribute>]
type LocalCache =
    class
        inherit ServiceWithInstrumentationBase<Object>
        interface ICacheImplementation
        interface ICache
        interface IApplicationComponent
        interface IDisposable
        interface IService
        interface INamed
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
[<SealedAttribute>]
type LocalCache =
    class
        inherit ServiceWithInstrumentationBase<Object>
        interface ICacheImplementation
        interface ICache
        interface IApplicationComponent
        interface IDisposable
        interface IService
        interface INamed
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCache Members

LocalCache Members NFX Class Library

The LocalCache type exposes the following members.
Constructors
 | Name | Description
Public method | LocalCache | Initializes a new instance of the LocalCache class
Public method | LocalCache(String, Object) | Initializes a new instance of the LocalCache class
Public method | LocalCache(IPileImplementation, Object, String) | Initializes a new instance of the LocalCache class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Overrides Service Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Overrides ServiceWithInstrumentationBase TDirector ExternalGetParameter(String, Object , String ).)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Overrides ServiceWithInstrumentationBase TDirector ExternalParametersForGroups( String ).)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Overrides ServiceWithInstrumentationBase TDirector ExternalSetParameter(String, Object, String ).)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetOrCreateTable TKey (String, IEqualityComparer TKey ) |
Public method | GetOrCreateTable TKey (String, Boolean , IEqualityComparer TKey ) |
Public method | GetTable TKey |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PurgeAll |
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | DeleteThrough TKey | (Defined by CacheExtensions.)
Public Extension Method | FetchFrom TKey, TResult | Fetches an existing item from cache or null. IsAbsent is true when data was read from cache as an AbsentValue (Defined by CacheExtensions.)
Public Extension Method | FetchThrough TKey, TResult | Fetches an item through cache (Defined by CacheExtensions.)
Public Extension Method | SaveThrough TKey, TData | (Defined by CacheExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | DEFAULT_TABLE_OPTIONS_SECTION |
Protected field | m_Pile |
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Count | Returns total number of records in cache
Public property | DefaultTableOptions | Sets default options for a table which is not found in TableOptions collection. If this property is null then every table assumes the set of constant values defined in Table class
Public property | DetailedInstrumentationForAllTables | Handy admin property that sets detailed instrumentation flag for all tables at once
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Overrides ServiceWithInstrumentationBase TDirector ExternalParameters.)
Public property | InstrumentationEnabled | Implements IInstrumentable (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | Locality |
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Persistence |
Public property | Pile | Gets/sets a pile instance that this cache is using. Can set on an inactive only. If the target pile is directed by this service then it will start/stop the pile, otherwise the pile has to be managed externally
Public property | PileAllocMode |
Public property | PileMaxMemoryLimit |
Public property | PileStatus |
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TableOptions | Returns table options - used for table creation
Public property | Tables | Tables that this cache contains
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
LocalCache Class
NFX.ApplicationModel.Pile Namespace


LocalCache Constructor

LocalCache Constructor NFX Class Library

Overload List
 | Name | Description
Public method | LocalCache | Initializes a new instance of the LocalCache class
Public method | LocalCache(String, Object) | Initializes a new instance of the LocalCache class
Public method | LocalCache(IPileImplementation, Object, String) | Initializes a new instance of the LocalCache class
Back to Top
See Also
LocalCache Class
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCache Constructor

LocalCache Constructor NFX Class Library

Initializes a new instance of the LocalCache class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LocalCache()
public LocalCache()
Public Sub New
Public Sub New
public:
LocalCache()
public:
LocalCache()
new : unit -> LocalCache
new : unit -> LocalCache
See Also
LocalCache Class
LocalCache Members
LocalCache Overload
NFX.ApplicationModel.Pile Namespace


LocalCache Constructor (String, Object)

LocalCache Constructor (String, Object) NFX Class Library

Initializes a new instance of the LocalCache class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LocalCache(
    string name,
    Object director
)
public LocalCache(
    string name,
    Object director
)
Public Sub New (
    name As String,
    director As Object
)
Public Sub New (
    name As String,
    director As Object
)
public:
LocalCache(
    String^ name,
    Object^ director
)
public:
LocalCache(
    String^ name,
    Object^ director
)
new :
        name : string *
        director : Object -> LocalCache
new :
        name : string *
        director : Object -> LocalCache

Parameters

name
Type: Online System String
director
Type: Online System Object
See Also
LocalCache Class
LocalCache Members
LocalCache Overload
NFX.ApplicationModel.Pile Namespace


LocalCache Constructor (IPileImplementation, Object, String)

LocalCache Constructor (IPileImplementation, Object, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LocalCache class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LocalCache(
    IPileImplementation pile,
    Object director,
    string name
)
public LocalCache(
    IPileImplementation pile,
    Object director,
    string name
)
Public Sub New (
    pile As IPileImplementation,
    director As Object,
    name As String
)
Public Sub New (
    pile As IPileImplementation,
    director As Object,
    name As String
)
public:
LocalCache(
    IPileImplementation^ pile,
    Object^ director,
    String^ name
)
public:
LocalCache(
    IPileImplementation^ pile,
    Object^ director,
    String^ name
)
new :
        pile : IPileImplementation *
        director : Object *
        name : string -> LocalCache
new :
        pile : IPileImplementation *
        director : Object *
        name : string -> LocalCache

Parameters

pile
Type: NFX.ApplicationModel.Pile IPileImplementation
director
Type: Online System Object
name
Type: Online System String
See Also
LocalCache Class
LocalCache Members
LocalCache Overload
NFX.ApplicationModel.Pile Namespace


LocalCache Fields

LocalCache Fields NFX Class Library

The LocalCache type exposes the following members.
Fields
 | Name | Description
 | DEFAULT_TABLE_OPTIONS_SECTION |
Protected field | m_Pile |
Back to Top
See Also
LocalCache Class
NFX.ApplicationModel.Pile Namespace


LocalCache.DEFAULT_TABLE_OPTIONS_SECTION Field

LocalCache DEFAULT_TABLE_OPTIONS_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_TABLE_OPTIONS_SECTION
public const string DEFAULT_TABLE_OPTIONS_SECTION
Public Const DEFAULT_TABLE_OPTIONS_SECTION As String
Public Const DEFAULT_TABLE_OPTIONS_SECTION As String
public:
literal String^ DEFAULT_TABLE_OPTIONS_SECTION
public:
literal String^ DEFAULT_TABLE_OPTIONS_SECTION
static val mutable DEFAULT_TABLE_OPTIONS_SECTION: string
static val mutable DEFAULT_TABLE_OPTIONS_SECTION: string

Field Value

Type: Online String
See Also
LocalCache Class
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCache.m_Pile Field

LocalCache m_Pile Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal IPileImplementation m_Pile
internal IPileImplementation m_Pile
Friend m_Pile As IPileImplementation
Friend m_Pile As IPileImplementation
internal:
IPileImplementation^ m_Pile
internal:
IPileImplementation^ m_Pile
val mutable internal m_Pile: IPileImplementation
val mutable internal m_Pile: IPileImplementation

Field Value

Type: IPileImplementation
See Also
LocalCache Class
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCache Methods

LocalCache Methods NFX Class Library

The LocalCache type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Overrides Service Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Overrides ServiceWithInstrumentationBase TDirector ExternalGetParameter(String, Object , String ).)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Overrides ServiceWithInstrumentationBase TDirector ExternalParametersForGroups( String ).)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Overrides ServiceWithInstrumentationBase TDirector ExternalSetParameter(String, Object, String ).)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetOrCreateTable TKey (String, IEqualityComparer TKey ) |
Public method | GetOrCreateTable TKey (String, Boolean , IEqualityComparer TKey ) |
Public method | GetTable TKey |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PurgeAll |
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | DeleteThrough TKey | (Defined by CacheExtensions.)
Public Extension Method | FetchFrom TKey, TResult | Fetches an existing item from cache or null. IsAbsent is true when data was read from cache as an AbsentValue (Defined by CacheExtensions.)
Public Extension Method | FetchThrough TKey, TResult | Fetches an item through cache (Defined by CacheExtensions.)
Public Extension Method | SaveThrough TKey, TData | (Defined by CacheExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LocalCache Class
NFX.ApplicationModel.Pile Namespace


LocalCache.Destructor Method

LocalCache Destructor Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
LocalCache Class
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCache.DoConfigure Method

LocalCache DoConfigure Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
LocalCache Class
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCache.DoSignalStop Method

LocalCache DoSignalStop Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSignalStop()
protected override void DoSignalStop()
Protected Overrides Sub DoSignalStop
Protected Overrides Sub DoSignalStop
protected:
virtual void DoSignalStop() override
protected:
virtual void DoSignalStop() override
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
See Also
LocalCache Class
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCache.DoStart Method

LocalCache DoStart Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
LocalCache Class
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCache.DoWaitForCompleteStop Method

LocalCache DoWaitForCompleteStop Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
LocalCache Class
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCache.ExternalGetParameter Method

LocalCache ExternalGetParameter Method NFX Class Library

Gets external parameter value returning true if parameter was found

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
public override bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
Public Overrides Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
Public Overrides Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
) override
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
) override
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalGetParameter(String, Object , String )
IExternallyParameterized ExternalGetParameter(String, Object , String )
See Also
LocalCache Class
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCache.ExternalParametersForGroups Method

LocalCache ExternalParametersForGroups Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns named parameters that can be used to control this component

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
public override IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
Public Overrides Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
Public Overrides Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
) override
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
) override
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>

Parameters

groups
Type: Online System String

Return Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParametersForGroups( String )
IExternallyParameterized ExternalParametersForGroups( String )
See Also
LocalCache Class
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCache.ExternalSetParameter Method

LocalCache ExternalSetParameter Method NFX Class Library

Sets external parameter value returning true if parameter was found and set

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
public override bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
Public Overrides Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
Public Overrides Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
) override
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
) override
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalSetParameter(String, Object, String )
IExternallyParameterized ExternalSetParameter(String, Object, String )
See Also
LocalCache Class
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCache.GetOrCreateTable Method

LocalCache GetOrCreateTable Method NFX Class Library

Overload List
 | Name | Description
Public method | GetOrCreateTable TKey (String, IEqualityComparer TKey ) |
Public method | GetOrCreateTable TKey (String, Boolean , IEqualityComparer TKey ) |
Back to Top
See Also
LocalCache Class
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCache.GetOrCreateTable(TKey) Method (String, IEqualityComparer(TKey))

LocalCache GetOrCreateTable TKey Method (String, IEqualityComparer TKey ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICacheTable<TKey> GetOrCreateTable<TKey>(
    string tableName,
    IEqualityComparer<TKey> keyComparer = null
)
public ICacheTable<TKey> GetOrCreateTable<TKey>(
    string tableName,
    IEqualityComparer<TKey> keyComparer = null
)
Public Function GetOrCreateTable(Of TKey) (
    tableName As String,
    Optional keyComparer As IEqualityComparer(Of TKey) = Nothing
) As ICacheTable(Of TKey)
Public Function GetOrCreateTable(Of TKey) (
    tableName As String,
    Optional keyComparer As IEqualityComparer(Of TKey) = Nothing
) As ICacheTable(Of TKey)
public:
generic<typename TKey>
virtual ICacheTable<TKey>^ GetOrCreateTable(
    String^ tableName,
    IEqualityComparer<TKey>^ keyComparer = nullptr
) sealed
public:
generic<typename TKey>
virtual ICacheTable<TKey>^ GetOrCreateTable(
    String^ tableName,
    IEqualityComparer<TKey>^ keyComparer = nullptr
) sealed
abstract GetOrCreateTable :
        tableName : string *
        ?keyComparer : IEqualityComparer<'TKey>
(* Defaults:
        let _keyComparer = defaultArg keyComparer null
*)
-> ICacheTable<'TKey>
override GetOrCreateTable :
        tableName : string *
        ?keyComparer : IEqualityComparer<'TKey>
(* Defaults:
        let _keyComparer = defaultArg keyComparer null
*)
-> ICacheTable<'TKey>
abstract GetOrCreateTable :
        tableName : string *
        ?keyComparer : IEqualityComparer<'TKey>
(* Defaults:
        let _keyComparer = defaultArg keyComparer null
*)
-> ICacheTable<'TKey>
override GetOrCreateTable :
        tableName : string *
        ?keyComparer : IEqualityComparer<'TKey>
(* Defaults:
        let _keyComparer = defaultArg keyComparer null
*)
-> ICacheTable<'TKey>

Parameters

tableName
Type: Online System String
keyComparer (Optional)
Type: Online System.Collections.Generic IEqualityComparer TKey
Type Parameters
TKey

Return Value

Type: ICacheTable TKey

Implements

ICache GetOrCreateTable TKey (String, IEqualityComparer TKey )
See Also
LocalCache Class
LocalCache Members
GetOrCreateTable Overload
NFX.ApplicationModel.Pile Namespace


LocalCache.GetOrCreateTable(TKey) Method (String, Boolean, IEqualityComparer(TKey))

LocalCache GetOrCreateTable TKey Method (String, Boolean , IEqualityComparer TKey ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICacheTable<TKey> GetOrCreateTable<TKey>(
    string tableName,
    out bool createdNew,
    IEqualityComparer<TKey> keyComparer = null
)
public ICacheTable<TKey> GetOrCreateTable<TKey>(
    string tableName,
    out bool createdNew,
    IEqualityComparer<TKey> keyComparer = null
)
Public Function GetOrCreateTable(Of TKey) (
    tableName As String,
    <OutAttribute> ByRef createdNew As Boolean,
    Optional keyComparer As IEqualityComparer(Of TKey) = Nothing
) As ICacheTable(Of TKey)
Public Function GetOrCreateTable(Of TKey) (
    tableName As String,
    <OutAttribute> ByRef createdNew As Boolean,
    Optional keyComparer As IEqualityComparer(Of TKey) = Nothing
) As ICacheTable(Of TKey)
public:
generic<typename TKey>
virtual ICacheTable<TKey>^ GetOrCreateTable(
    String^ tableName,
    [OutAttribute] bool% createdNew,
    IEqualityComparer<TKey>^ keyComparer = nullptr
) sealed
public:
generic<typename TKey>
virtual ICacheTable<TKey>^ GetOrCreateTable(
    String^ tableName,
    [OutAttribute] bool% createdNew,
    IEqualityComparer<TKey>^ keyComparer = nullptr
) sealed
abstract GetOrCreateTable :
        tableName : string *
        createdNew : bool byref *
        ?keyComparer : IEqualityComparer<'TKey>
(* Defaults:
        let _keyComparer = defaultArg keyComparer null
*)
-> ICacheTable<'TKey>
override GetOrCreateTable :
        tableName : string *
        createdNew : bool byref *
        ?keyComparer : IEqualityComparer<'TKey>
(* Defaults:
        let _keyComparer = defaultArg keyComparer null
*)
-> ICacheTable<'TKey>
abstract GetOrCreateTable :
        tableName : string *
        createdNew : bool byref *
        ?keyComparer : IEqualityComparer<'TKey>
(* Defaults:
        let _keyComparer = defaultArg keyComparer null
*)
-> ICacheTable<'TKey>
override GetOrCreateTable :
        tableName : string *
        createdNew : bool byref *
        ?keyComparer : IEqualityComparer<'TKey>
(* Defaults:
        let _keyComparer = defaultArg keyComparer null
*)
-> ICacheTable<'TKey>

Parameters

tableName
Type: Online System String
createdNew
Type: Online System Boolean
keyComparer (Optional)
Type: Online System.Collections.Generic IEqualityComparer TKey
Type Parameters
TKey

Return Value

Type: ICacheTable TKey

Implements

ICache GetOrCreateTable TKey (String, Boolean , IEqualityComparer TKey )
See Also
LocalCache Class
LocalCache Members
GetOrCreateTable Overload
NFX.ApplicationModel.Pile Namespace


LocalCache.GetTable(TKey) Method

LocalCache GetTable TKey Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICacheTable<TKey> GetTable<TKey>(
    string tableName
)
public ICacheTable<TKey> GetTable<TKey>(
    string tableName
)
Public Function GetTable(Of TKey) (
    tableName As String
) As ICacheTable(Of TKey)
Public Function GetTable(Of TKey) (
    tableName As String
) As ICacheTable(Of TKey)
public:
generic<typename TKey>
virtual ICacheTable<TKey>^ GetTable(
    String^ tableName
) sealed
public:
generic<typename TKey>
virtual ICacheTable<TKey>^ GetTable(
    String^ tableName
) sealed
abstract GetTable :
        tableName : string -> ICacheTable<'TKey>
override GetTable :
        tableName : string -> ICacheTable<'TKey>
abstract GetTable :
        tableName : string -> ICacheTable<'TKey>
override GetTable :
        tableName : string -> ICacheTable<'TKey>

Parameters

tableName
Type: Online System String
Type Parameters
TKey

Return Value

Type: ICacheTable TKey

Implements

ICache GetTable TKey (String)
See Also
LocalCache Class
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCache.PurgeAll Method

LocalCache PurgeAll Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void PurgeAll()
public void PurgeAll()
Public Sub PurgeAll
Public Sub PurgeAll
public:
virtual void PurgeAll() sealed
public:
virtual void PurgeAll() sealed
abstract PurgeAll : unit -> unit
override PurgeAll : unit -> unit
abstract PurgeAll : unit -> unit
override PurgeAll : unit -> unit

Implements

ICache PurgeAll
See Also
LocalCache Class
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCache Properties

LocalCache Properties NFX Class Library

The LocalCache type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Count | Returns total number of records in cache
Public property | DefaultTableOptions | Sets default options for a table which is not found in TableOptions collection. If this property is null then every table assumes the set of constant values defined in Table class
Public property | DetailedInstrumentationForAllTables | Handy admin property that sets detailed instrumentation flag for all tables at once
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Overrides ServiceWithInstrumentationBase TDirector ExternalParameters.)
Public property | InstrumentationEnabled | Implements IInstrumentable (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | Locality |
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Persistence |
Public property | Pile | Gets/sets a pile instance that this cache is using. Can set on an inactive only. If the target pile is directed by this service then it will start/stop the pile, otherwise the pile has to be managed externally
Public property | PileAllocMode |
Public property | PileMaxMemoryLimit |
Public property | PileStatus |
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TableOptions | Returns table options - used for table creation
Public property | Tables | Tables that this cache contains
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
LocalCache Class
NFX.ApplicationModel.Pile Namespace


LocalCache.Count Property

LocalCache Count Property NFX Class Library

Returns total number of records in cache

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long Count { get; }
public long Count { get; }
Public ReadOnly Property Count As Long
    Get
Public ReadOnly Property Count As Long
    Get
public:
virtual property long long Count {
    long long get () sealed;
}
public:
virtual property long long Count {
    long long get () sealed;
}
abstract Count : int64 with get
override Count : int64 with get
abstract Count : int64 with get
override Count : int64 with get

Property Value

Type: Online Int64

Implements

ICache Count
See Also
LocalCache Class
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCache.DefaultTableOptions Property

LocalCache DefaultTableOptions Property NFX Class Library

Sets default options for a table which is not found in TableOptions collection. If this property is null then every table assumes the set of constant values defined in Table class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TableOptions DefaultTableOptions { get; set; }
public TableOptions DefaultTableOptions { get; set; }
Public Property DefaultTableOptions As TableOptions
    Get
    Set
Public Property DefaultTableOptions As TableOptions
    Get
    Set
public:
virtual property TableOptions^ DefaultTableOptions {
    TableOptions^ get () sealed;
    void set (TableOptions^ value) sealed;
}
public:
virtual property TableOptions^ DefaultTableOptions {
    TableOptions^ get () sealed;
    void set (TableOptions^ value) sealed;
}
abstract DefaultTableOptions : TableOptions with get, set
override DefaultTableOptions : TableOptions with get, set
abstract DefaultTableOptions : TableOptions with get, set
override DefaultTableOptions : TableOptions with get, set

Property Value

Type: TableOptions

Implements

ICacheImplementation DefaultTableOptions
See Also
LocalCache Class
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCache.DetailedInstrumentationForAllTables Property

LocalCache DetailedInstrumentationForAllTables Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Handy admin property that sets detailed instrumentation flag for all tables at once

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute]
public Nullable<bool> DetailedInstrumentationForAllTables { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute]
public Nullable<bool> DetailedInstrumentationForAllTables { get; set; }
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute>
Public Property DetailedInstrumentationForAllTables As Nullable(Of Boolean)
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute>
Public Property DetailedInstrumentationForAllTables As Nullable(Of Boolean)
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute]
property Nullable<bool> DetailedInstrumentationForAllTables {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute]
property Nullable<bool> DetailedInstrumentationForAllTables {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute>]
member DetailedInstrumentationForAllTables : Nullable<bool> with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute>]
member DetailedInstrumentationForAllTables : Nullable<bool> with get, set

Property Value

Type: Online Nullable Online Boolean
See Also
LocalCache Class
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCache.ExternalParameters Property

LocalCache ExternalParameters Property NFX Class Library

Returns named parameters that can be used to control this component

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
public override IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
Public Overrides ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
Public Overrides ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get () override;
}
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get () override;
}
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get

Property Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParameters
IExternallyParameterized ExternalParameters
See Also
LocalCache Class
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCache.InstrumentationEnabled Property

LocalCache InstrumentationEnabled Property NFX Class Library

Implements IInstrumentable

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(new string[] { ... })]
public override bool InstrumentationEnabled { get; set; }
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(new string[] { ... })]
public override bool InstrumentationEnabled { get; set; }
<ConfigAttribute(Default := false)>
<ExternalParameterAttribute(New String() { ... })>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
<ConfigAttribute(Default := false)>
<ExternalParameterAttribute(New String() { ... })>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
public:
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
public:
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
abstract InstrumentationEnabled : bool with get, set
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
override InstrumentationEnabled : bool with get, set
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
abstract InstrumentationEnabled : bool with get, set
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
override InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentable InstrumentationEnabled
IInstrumentable InstrumentationEnabled
See Also
LocalCache Class
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCache.Locality Property

LocalCache Locality Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LocalityKind Locality { get; }
public LocalityKind Locality { get; }
Public ReadOnly Property Locality As LocalityKind
    Get
Public ReadOnly Property Locality As LocalityKind
    Get
public:
virtual property LocalityKind Locality {
    LocalityKind get () sealed;
}
public:
virtual property LocalityKind Locality {
    LocalityKind get () sealed;
}
abstract Locality : LocalityKind with get
override Locality : LocalityKind with get
abstract Locality : LocalityKind with get
override Locality : LocalityKind with get

Property Value

Type: LocalityKind

Implements

ICache Locality
See Also
LocalCache Class
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCache.Persistence Property

LocalCache Persistence Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ObjectPersistence Persistence { get; }
public ObjectPersistence Persistence { get; }
Public ReadOnly Property Persistence As ObjectPersistence
    Get
Public ReadOnly Property Persistence As ObjectPersistence
    Get
public:
virtual property ObjectPersistence Persistence {
    ObjectPersistence get () sealed;
}
public:
virtual property ObjectPersistence Persistence {
    ObjectPersistence get () sealed;
}
abstract Persistence : ObjectPersistence with get
override Persistence : ObjectPersistence with get
abstract Persistence : ObjectPersistence with get
override Persistence : ObjectPersistence with get

Property Value

Type: ObjectPersistence

Implements

ICache Persistence
See Also
LocalCache Class
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCache.Pile Property

LocalCache Pile Property NFX Class Library

Gets/sets a pile instance that this cache is using. Can set on an inactive only. If the target pile is directed by this service then it will start/stop the pile, otherwise the pile has to be managed externally

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IPileImplementation Pile { get; set; }
public IPileImplementation Pile { get; set; }
Public Property Pile As IPileImplementation
    Get
    Set
Public Property Pile As IPileImplementation
    Get
    Set
public:
property IPileImplementation^ Pile {
    IPileImplementation^ get ();
    void set (IPileImplementation^ value);
}
public:
property IPileImplementation^ Pile {
    IPileImplementation^ get ();
    void set (IPileImplementation^ value);
}
member Pile : IPileImplementation with get, set
member Pile : IPileImplementation with get, set

Property Value

Type: IPileImplementation
See Also
LocalCache Class
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCache.PileAllocMode Property

LocalCache PileAllocMode Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public AllocationMode PileAllocMode { get; set; }
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public AllocationMode PileAllocMode { get; set; }
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property PileAllocMode As AllocationMode
    Get
    Set
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property PileAllocMode As AllocationMode
    Get
    Set
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property AllocationMode PileAllocMode {
    AllocationMode get () sealed;
    void set (AllocationMode value) sealed;
}
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property AllocationMode PileAllocMode {
    AllocationMode get () sealed;
    void set (AllocationMode value) sealed;
}
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
abstract PileAllocMode : AllocationMode with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
override PileAllocMode : AllocationMode with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
abstract PileAllocMode : AllocationMode with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
override PileAllocMode : AllocationMode with get, set

Property Value

Type: AllocationMode

Implements

ICacheImplementation PileAllocMode
See Also
LocalCache Class
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCache.PileMaxMemoryLimit Property

LocalCache PileMaxMemoryLimit Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public long PileMaxMemoryLimit { get; set; }
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public long PileMaxMemoryLimit { get; set; }
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property PileMaxMemoryLimit As Long
    Get
    Set
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property PileMaxMemoryLimit As Long
    Get
    Set
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property long long PileMaxMemoryLimit {
    long long get () sealed;
    void set (long long value) sealed;
}
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property long long PileMaxMemoryLimit {
    long long get () sealed;
    void set (long long value) sealed;
}
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
abstract PileMaxMemoryLimit : int64 with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
override PileMaxMemoryLimit : int64 with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
abstract PileMaxMemoryLimit : int64 with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
override PileMaxMemoryLimit : int64 with get, set

Property Value

Type: Online Int64

Implements

ICacheImplementation PileMaxMemoryLimit
See Also
LocalCache Class
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCache.PileStatus Property

LocalCache PileStatus Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IPileStatus PileStatus { get; }
public IPileStatus PileStatus { get; }
Public ReadOnly Property PileStatus As IPileStatus
    Get
Public ReadOnly Property PileStatus As IPileStatus
    Get
public:
virtual property IPileStatus^ PileStatus {
    IPileStatus^ get () sealed;
}
public:
virtual property IPileStatus^ PileStatus {
    IPileStatus^ get () sealed;
}
abstract PileStatus : IPileStatus with get
override PileStatus : IPileStatus with get
abstract PileStatus : IPileStatus with get
override PileStatus : IPileStatus with get

Property Value

Type: IPileStatus

Implements

ICache PileStatus
See Also
LocalCache Class
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCache.TableOptions Property

LocalCache TableOptions Property NFX Class Library

Returns table options - used for table creation

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Registry<TableOptions> TableOptions { get; }
public Registry<TableOptions> TableOptions { get; }
Public ReadOnly Property TableOptions As Registry(Of TableOptions)
    Get
Public ReadOnly Property TableOptions As Registry(Of TableOptions)
    Get
public:
virtual property Registry<TableOptions^>^ TableOptions {
    Registry<TableOptions^>^ get () sealed;
}
public:
virtual property Registry<TableOptions^>^ TableOptions {
    Registry<TableOptions^>^ get () sealed;
}
abstract TableOptions : Registry<TableOptions> with get
override TableOptions : Registry<TableOptions> with get
abstract TableOptions : Registry<TableOptions> with get
override TableOptions : Registry<TableOptions> with get

Property Value

Type: Registry TableOptions

Implements

ICacheImplementation TableOptions
See Also
LocalCache Class
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCache.Tables Property

LocalCache Tables Property NFX Class Library

Tables that this cache contains

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<ICacheTable> Tables { get; }
public IRegistry<ICacheTable> Tables { get; }
Public ReadOnly Property Tables As IRegistry(Of ICacheTable)
    Get
Public ReadOnly Property Tables As IRegistry(Of ICacheTable)
    Get
public:
virtual property IRegistry<ICacheTable^>^ Tables {
    IRegistry<ICacheTable^>^ get () sealed;
}
public:
virtual property IRegistry<ICacheTable^>^ Tables {
    IRegistry<ICacheTable^>^ get () sealed;
}
abstract Tables : IRegistry<ICacheTable> with get
override Tables : IRegistry<ICacheTable> with get
abstract Tables : IRegistry<ICacheTable> with get
override Tables : IRegistry<ICacheTable> with get

Property Value

Type: IRegistry ICacheTable

Implements

ICache Tables
See Also
LocalCache Class
LocalCache Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable Class

LocalCacheTable Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.ApplicationModel.Pile LocalCacheTable
NFX.ApplicationModel.Pile LocalCacheTable TKey

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal abstract class LocalCacheTable : ICacheTable,
    INamed
internal abstract class LocalCacheTable : ICacheTable,
    INamed
Friend MustInherit Class LocalCacheTable
    Implements ICacheTable, INamed
Friend MustInherit Class LocalCacheTable
    Implements ICacheTable, INamed
internal ref class LocalCacheTable abstract : ICacheTable,
    INamed
internal ref class LocalCacheTable abstract : ICacheTable,
    INamed
[<AbstractClassAttribute>]
type LocalCacheTable =
    class
        interface ICacheTable
        interface INamed
    end
[<AbstractClassAttribute>]
type LocalCacheTable =
    class
        interface ICacheTable
        interface INamed
    end
See Also
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable Members

LocalCacheTable Members NFX Class Library

The LocalCacheTable type exposes the following members.
Constructors
 | Name | Description
Protected method | LocalCacheTable | Initializes a new instance of the LocalCacheTable class
Back to Top
Methods
 | Name | Description
Protected method | DoPurge |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Purge |
Protected method | Sweep |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | BUCKETS |
Protected field | m_Cache |
Protected field | m_Options |
Protected field | m_stat_GetHit |
Protected field | m_stat_GetMiss |
Protected field | m_stat_Grew |
Protected field | m_stat_Put |
Protected field | m_stat_PutCollision |
Protected field | m_stat_PutOverwrite |
Protected field | m_stat_PutReplace |
Protected field | m_stat_RejuvenateHit |
Protected field | m_stat_RejuvenateMiss |
Protected field | m_stat_RemoveHit |
Protected field | m_stat_RemoveMiss |
Protected field | m_stat_Shrunk |
Protected field | m_stat_Sweep |
Protected field | m_stat_SweepDuration |
 | s_GetPutLocks |
Protected field | SweepWhenBecameEmpty |
Back to Top
Properties
 | Name | Description
Public property | Cache |
Public property | Capacity |
Public property | Count |
Public property | LoadFactor |
Public property | Name |
Public property | Options |
Back to Top
See Also
LocalCacheTable Class
NFX.ApplicationModel.Pile Namespace


LocalCacheTable Constructor

LocalCacheTable Constructor NFX Class Library

Initializes a new instance of the LocalCacheTable class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected LocalCacheTable(
    LocalCache cache,
    string name,
    TableOptions options
)
protected LocalCacheTable(
    LocalCache cache,
    string name,
    TableOptions options
)
Protected Sub New (
    cache As LocalCache,
    name As String,
    options As TableOptions
)
Protected Sub New (
    cache As LocalCache,
    name As String,
    options As TableOptions
)
protected:
LocalCacheTable(
    LocalCache^ cache,
    String^ name,
    TableOptions^ options
)
protected:
LocalCacheTable(
    LocalCache^ cache,
    String^ name,
    TableOptions^ options
)
new :
        cache : LocalCache *
        name : string *
        options : TableOptions -> LocalCacheTable
new :
        cache : LocalCache *
        name : string *
        options : TableOptions -> LocalCacheTable

Parameters

cache
Type: NFX.ApplicationModel.Pile LocalCache
name
Type: Online System String
options
Type: NFX.ApplicationModel.Pile TableOptions
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable Fields

LocalCacheTable Fields NFX Class Library

The LocalCacheTable type exposes the following members.
Fields
 | Name | Description
 | BUCKETS |
Protected field | m_Cache |
Protected field | m_Options |
Protected field | m_stat_GetHit |
Protected field | m_stat_GetMiss |
Protected field | m_stat_Grew |
Protected field | m_stat_Put |
Protected field | m_stat_PutCollision |
Protected field | m_stat_PutOverwrite |
Protected field | m_stat_PutReplace |
Protected field | m_stat_RejuvenateHit |
Protected field | m_stat_RejuvenateMiss |
Protected field | m_stat_RemoveHit |
Protected field | m_stat_RemoveMiss |
Protected field | m_stat_Shrunk |
Protected field | m_stat_Sweep |
Protected field | m_stat_SweepDuration |
 | s_GetPutLocks |
Protected field | SweepWhenBecameEmpty |
Back to Top
See Also
LocalCacheTable Class
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.BUCKETS Field

LocalCacheTable BUCKETS Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int BUCKETS
public const int BUCKETS
Public Const BUCKETS As Integer
Public Const BUCKETS As Integer
public:
literal int BUCKETS
public:
literal int BUCKETS
static val mutable BUCKETS: int
static val mutable BUCKETS: int

Field Value

Type: Online Int32
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.m_Cache Field

LocalCacheTable m_Cache Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal readonly LocalCache m_Cache
protected internal readonly LocalCache m_Cache
Protected Friend ReadOnly m_Cache As LocalCache
Protected Friend ReadOnly m_Cache As LocalCache
protected public:
initonly LocalCache^ m_Cache
protected public:
initonly LocalCache^ m_Cache
val m_Cache: LocalCache
val m_Cache: LocalCache

Field Value

Type: LocalCache
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.m_Options Field

LocalCacheTable m_Options Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal readonly TableOptions m_Options
protected internal readonly TableOptions m_Options
Protected Friend ReadOnly m_Options As TableOptions
Protected Friend ReadOnly m_Options As TableOptions
protected public:
initonly TableOptions^ m_Options
protected public:
initonly TableOptions^ m_Options
val m_Options: TableOptions
val m_Options: TableOptions

Field Value

Type: TableOptions
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.m_stat_GetHit Field

LocalCacheTable m_stat_GetHit Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal int m_stat_GetHit
protected internal int m_stat_GetHit
Protected Friend m_stat_GetHit As Integer
Protected Friend m_stat_GetHit As Integer
protected public:
int m_stat_GetHit
protected public:
int m_stat_GetHit
val mutable m_stat_GetHit: int
val mutable m_stat_GetHit: int

Field Value

Type: Online Int32
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.m_stat_GetMiss Field

LocalCacheTable m_stat_GetMiss Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal int m_stat_GetMiss
protected internal int m_stat_GetMiss
Protected Friend m_stat_GetMiss As Integer
Protected Friend m_stat_GetMiss As Integer
protected public:
int m_stat_GetMiss
protected public:
int m_stat_GetMiss
val mutable m_stat_GetMiss: int
val mutable m_stat_GetMiss: int

Field Value

Type: Online Int32
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.m_stat_Grew Field

LocalCacheTable m_stat_Grew Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal int m_stat_Grew
protected internal int m_stat_Grew
Protected Friend m_stat_Grew As Integer
Protected Friend m_stat_Grew As Integer
protected public:
int m_stat_Grew
protected public:
int m_stat_Grew
val mutable m_stat_Grew: int
val mutable m_stat_Grew: int

Field Value

Type: Online Int32
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.m_stat_Put Field

LocalCacheTable m_stat_Put Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal int m_stat_Put
protected internal int m_stat_Put
Protected Friend m_stat_Put As Integer
Protected Friend m_stat_Put As Integer
protected public:
int m_stat_Put
protected public:
int m_stat_Put
val mutable m_stat_Put: int
val mutable m_stat_Put: int

Field Value

Type: Online Int32
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.m_stat_PutCollision Field

LocalCacheTable m_stat_PutCollision Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal int m_stat_PutCollision
protected internal int m_stat_PutCollision
Protected Friend m_stat_PutCollision As Integer
Protected Friend m_stat_PutCollision As Integer
protected public:
int m_stat_PutCollision
protected public:
int m_stat_PutCollision
val mutable m_stat_PutCollision: int
val mutable m_stat_PutCollision: int

Field Value

Type: Online Int32
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.m_stat_PutOverwrite Field

LocalCacheTable m_stat_PutOverwrite Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal int m_stat_PutOverwrite
protected internal int m_stat_PutOverwrite
Protected Friend m_stat_PutOverwrite As Integer
Protected Friend m_stat_PutOverwrite As Integer
protected public:
int m_stat_PutOverwrite
protected public:
int m_stat_PutOverwrite
val mutable m_stat_PutOverwrite: int
val mutable m_stat_PutOverwrite: int

Field Value

Type: Online Int32
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.m_stat_PutReplace Field

LocalCacheTable m_stat_PutReplace Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal int m_stat_PutReplace
protected internal int m_stat_PutReplace
Protected Friend m_stat_PutReplace As Integer
Protected Friend m_stat_PutReplace As Integer
protected public:
int m_stat_PutReplace
protected public:
int m_stat_PutReplace
val mutable m_stat_PutReplace: int
val mutable m_stat_PutReplace: int

Field Value

Type: Online Int32
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.m_stat_RejuvenateHit Field

LocalCacheTable m_stat_RejuvenateHit Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal int m_stat_RejuvenateHit
protected internal int m_stat_RejuvenateHit
Protected Friend m_stat_RejuvenateHit As Integer
Protected Friend m_stat_RejuvenateHit As Integer
protected public:
int m_stat_RejuvenateHit
protected public:
int m_stat_RejuvenateHit
val mutable m_stat_RejuvenateHit: int
val mutable m_stat_RejuvenateHit: int

Field Value

Type: Online Int32
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.m_stat_RejuvenateMiss Field

LocalCacheTable m_stat_RejuvenateMiss Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal int m_stat_RejuvenateMiss
protected internal int m_stat_RejuvenateMiss
Protected Friend m_stat_RejuvenateMiss As Integer
Protected Friend m_stat_RejuvenateMiss As Integer
protected public:
int m_stat_RejuvenateMiss
protected public:
int m_stat_RejuvenateMiss
val mutable m_stat_RejuvenateMiss: int
val mutable m_stat_RejuvenateMiss: int

Field Value

Type: Online Int32
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.m_stat_RemoveHit Field

LocalCacheTable m_stat_RemoveHit Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal int m_stat_RemoveHit
protected internal int m_stat_RemoveHit
Protected Friend m_stat_RemoveHit As Integer
Protected Friend m_stat_RemoveHit As Integer
protected public:
int m_stat_RemoveHit
protected public:
int m_stat_RemoveHit
val mutable m_stat_RemoveHit: int
val mutable m_stat_RemoveHit: int

Field Value

Type: Online Int32
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.m_stat_RemoveMiss Field

LocalCacheTable m_stat_RemoveMiss Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal int m_stat_RemoveMiss
protected internal int m_stat_RemoveMiss
Protected Friend m_stat_RemoveMiss As Integer
Protected Friend m_stat_RemoveMiss As Integer
protected public:
int m_stat_RemoveMiss
protected public:
int m_stat_RemoveMiss
val mutable m_stat_RemoveMiss: int
val mutable m_stat_RemoveMiss: int

Field Value

Type: Online Int32
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.m_stat_Shrunk Field

LocalCacheTable m_stat_Shrunk Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal int m_stat_Shrunk
protected internal int m_stat_Shrunk
Protected Friend m_stat_Shrunk As Integer
Protected Friend m_stat_Shrunk As Integer
protected public:
int m_stat_Shrunk
protected public:
int m_stat_Shrunk
val mutable m_stat_Shrunk: int
val mutable m_stat_Shrunk: int

Field Value

Type: Online Int32
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.m_stat_Sweep Field

LocalCacheTable m_stat_Sweep Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal int m_stat_Sweep
protected internal int m_stat_Sweep
Protected Friend m_stat_Sweep As Integer
Protected Friend m_stat_Sweep As Integer
protected public:
int m_stat_Sweep
protected public:
int m_stat_Sweep
val mutable m_stat_Sweep: int
val mutable m_stat_Sweep: int

Field Value

Type: Online Int32
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.m_stat_SweepDuration Field

LocalCacheTable m_stat_SweepDuration Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal long m_stat_SweepDuration
protected internal long m_stat_SweepDuration
Protected Friend m_stat_SweepDuration As Long
Protected Friend m_stat_SweepDuration As Long
protected public:
long long m_stat_SweepDuration
protected public:
long long m_stat_SweepDuration
val mutable m_stat_SweepDuration: int64
val mutable m_stat_SweepDuration: int64

Field Value

Type: Online Int64
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.s_GetPutLocks Field

LocalCacheTable s_GetPutLocks Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected static readonly Object[] s_GetPutLocks
protected static readonly Object[] s_GetPutLocks
Protected Shared ReadOnly s_GetPutLocks As Object()
Protected Shared ReadOnly s_GetPutLocks As Object()
protected:
static initonly array<Object^>^ s_GetPutLocks
protected:
static initonly array<Object^>^ s_GetPutLocks
static val s_GetPutLocks: Object[]
static val s_GetPutLocks: Object[]

Field Value

Type: Online Object
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.SweepWhenBecameEmpty Field

LocalCacheTable SweepWhenBecameEmpty Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Nullable<DateTime> SweepWhenBecameEmpty
internal Nullable<DateTime> SweepWhenBecameEmpty
Friend SweepWhenBecameEmpty As Nullable(Of DateTime)
Friend SweepWhenBecameEmpty As Nullable(Of DateTime)
internal:
Nullable<DateTime> SweepWhenBecameEmpty
internal:
Nullable<DateTime> SweepWhenBecameEmpty
val mutable internal SweepWhenBecameEmpty: Nullable<DateTime>
val mutable internal SweepWhenBecameEmpty: Nullable<DateTime>

Field Value

Type: Online Nullable Online DateTime
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable Methods

LocalCacheTable Methods NFX Class Library

The LocalCacheTable type exposes the following members.
Methods
 | Name | Description
Protected method | DoPurge |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Purge |
Protected method | Sweep |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LocalCacheTable Class
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.DoPurge Method

LocalCacheTable DoPurge Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal abstract void DoPurge()
internal abstract void DoPurge()
Friend MustOverride Sub DoPurge
Friend MustOverride Sub DoPurge
internal:
virtual void DoPurge() abstract
internal:
virtual void DoPurge() abstract
internal abstract DoPurge : unit -> unit
internal abstract DoPurge : unit -> unit
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.Purge Method

LocalCacheTable Purge Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Purge()
public void Purge()
Public Sub Purge
Public Sub Purge
public:
virtual void Purge() sealed
public:
virtual void Purge() sealed
abstract Purge : unit -> unit
override Purge : unit -> unit
abstract Purge : unit -> unit
override Purge : unit -> unit

Implements

ICacheTable Purge
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.Sweep Method

LocalCacheTable Sweep Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract bool Sweep(
    Stopwatch timer,
    int maxTimeMs
)
protected internal abstract bool Sweep(
    Stopwatch timer,
    int maxTimeMs
)
Protected Friend MustOverride Function Sweep (
    timer As Stopwatch,
    maxTimeMs As Integer
) As Boolean
Protected Friend MustOverride Function Sweep (
    timer As Stopwatch,
    maxTimeMs As Integer
) As Boolean
protected public:
virtual bool Sweep(
    Stopwatch^ timer,
    int maxTimeMs
) abstract
protected public:
virtual bool Sweep(
    Stopwatch^ timer,
    int maxTimeMs
) abstract
abstract Sweep :
        timer : Stopwatch *
        maxTimeMs : int -> bool
abstract Sweep :
        timer : Stopwatch *
        maxTimeMs : int -> bool

Parameters

timer
Type: Online System.Diagnostics Stopwatch
maxTimeMs
Type: Online System Int32

Return Value

Type: Online Boolean
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable Properties

LocalCacheTable Properties NFX Class Library

The LocalCacheTable type exposes the following members.
Properties
 | Name | Description
Public property | Cache |
Public property | Capacity |
Public property | Count |
Public property | LoadFactor |
Public property | Name |
Public property | Options |
Back to Top
See Also
LocalCacheTable Class
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.Cache Property

LocalCacheTable Cache Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICache Cache { get; }
public ICache Cache { get; }
Public ReadOnly Property Cache As ICache
    Get
Public ReadOnly Property Cache As ICache
    Get
public:
virtual property ICache^ Cache {
    ICache^ get () sealed;
}
public:
virtual property ICache^ Cache {
    ICache^ get () sealed;
}
abstract Cache : ICache with get
override Cache : ICache with get
abstract Cache : ICache with get
override Cache : ICache with get

Property Value

Type: ICache

Implements

ICacheTable Cache
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.Capacity Property

LocalCacheTable Capacity Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract long Capacity { get; }
public abstract long Capacity { get; }
Public MustOverride ReadOnly Property Capacity As Long
    Get
Public MustOverride ReadOnly Property Capacity As Long
    Get
public:
virtual property long long Capacity {
    long long get () abstract;
}
public:
virtual property long long Capacity {
    long long get () abstract;
}
abstract Capacity : int64 with get
abstract Capacity : int64 with get

Property Value

Type: Online Int64

Implements

ICacheTable Capacity
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.Count Property

LocalCacheTable Count Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract long Count { get; }
public abstract long Count { get; }
Public MustOverride ReadOnly Property Count As Long
    Get
Public MustOverride ReadOnly Property Count As Long
    Get
public:
virtual property long long Count {
    long long get () abstract;
}
public:
virtual property long long Count {
    long long get () abstract;
}
abstract Count : int64 with get
abstract Count : int64 with get

Property Value

Type: Online Int64

Implements

ICacheTable Count
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.LoadFactor Property

LocalCacheTable LoadFactor Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract double LoadFactor { get; }
public abstract double LoadFactor { get; }
Public MustOverride ReadOnly Property LoadFactor As Double
    Get
Public MustOverride ReadOnly Property LoadFactor As Double
    Get
public:
virtual property double LoadFactor {
    double get () abstract;
}
public:
virtual property double LoadFactor {
    double get () abstract;
}
abstract LoadFactor : float with get
abstract LoadFactor : float with get

Property Value

Type: Online Double

Implements

ICacheTable LoadFactor
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.Name Property

LocalCacheTable Name Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable.Options Property

LocalCacheTable Options Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TableOptions Options { get; }
public TableOptions Options { get; }
Public ReadOnly Property Options As TableOptions
    Get
Public ReadOnly Property Options As TableOptions
    Get
public:
virtual property TableOptions^ Options {
    TableOptions^ get () sealed;
}
public:
virtual property TableOptions^ Options {
    TableOptions^ get () sealed;
}
abstract Options : TableOptions with get
override Options : TableOptions with get
abstract Options : TableOptions with get
override Options : TableOptions with get

Property Value

Type: TableOptions

Implements

ICacheTable Options
See Also
LocalCacheTable Class
LocalCacheTable Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable(TKey) Class

LocalCacheTable TKey Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.ApplicationModel.Pile LocalCacheTable
NFX.ApplicationModel.Pile LocalCacheTable TKey

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal sealed class LocalCacheTable<TKey> : LocalCacheTable,
    ICacheTable<TKey>, ICacheTable, INamed
internal sealed class LocalCacheTable<TKey> : LocalCacheTable,
    ICacheTable<TKey>, ICacheTable, INamed
Friend NotInheritable Class LocalCacheTable(Of TKey)
    Inherits LocalCacheTable
    Implements ICacheTable(Of TKey), ICacheTable, INamed
Friend NotInheritable Class LocalCacheTable(Of TKey)
    Inherits LocalCacheTable
    Implements ICacheTable(Of TKey), ICacheTable, INamed
generic<typename TKey>
internal ref class LocalCacheTable sealed : public LocalCacheTable,
    ICacheTable<TKey>, ICacheTable, INamed
generic<typename TKey>
internal ref class LocalCacheTable sealed : public LocalCacheTable,
    ICacheTable<TKey>, ICacheTable, INamed
[<SealedAttribute>]
type LocalCacheTable<'TKey> =
    class
        inherit LocalCacheTable
        interface ICacheTable<'TKey>
        interface ICacheTable
        interface INamed
    end
[<SealedAttribute>]
type LocalCacheTable<'TKey> =
    class
        inherit LocalCacheTable
        interface ICacheTable<'TKey>
        interface ICacheTable
        interface INamed
    end
Type Parameters
TKey
See Also
LocalCacheTable TKey Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable(TKey) Members

LocalCacheTable TKey Members NFX Class Library

The LocalCacheTable TKey type exposes the following members.
Constructors
 | Name | Description
Public method | LocalCacheTable TKey | Initializes a new instance of the LocalCacheTable TKey class
Back to Top
Methods
 | Name | Description
Public method | ContainsKey |
Protected method | DoPurge | (Overrides LocalCacheTable DoPurge .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetOrPut |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Purge | (Inherited from LocalCacheTable.)
Public method | Put |
Public method | Rejuvenate |
Public method | Remove |
Public method | SizeOfValue |
Protected method | Sweep | (Overrides LocalCacheTable Sweep(Stopwatch, Int32).)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Cache | (Inherited from LocalCacheTable.)
Protected field | m_Options | (Inherited from LocalCacheTable.)
Protected field | m_stat_GetHit | (Inherited from LocalCacheTable.)
Protected field | m_stat_GetMiss | (Inherited from LocalCacheTable.)
Protected field | m_stat_Grew | (Inherited from LocalCacheTable.)
Protected field | m_stat_Put | (Inherited from LocalCacheTable.)
Protected field | m_stat_PutCollision | (Inherited from LocalCacheTable.)
Protected field | m_stat_PutOverwrite | (Inherited from LocalCacheTable.)
Protected field | m_stat_PutReplace | (Inherited from LocalCacheTable.)
Protected field | m_stat_RejuvenateHit | (Inherited from LocalCacheTable.)
Protected field | m_stat_RejuvenateMiss | (Inherited from LocalCacheTable.)
Protected field | m_stat_RemoveHit | (Inherited from LocalCacheTable.)
Protected field | m_stat_RemoveMiss | (Inherited from LocalCacheTable.)
Protected field | m_stat_Shrunk | (Inherited from LocalCacheTable.)
Protected field | m_stat_Sweep | (Inherited from LocalCacheTable.)
Protected field | m_stat_SweepDuration | (Inherited from LocalCacheTable.)
Protected field | SweepWhenBecameEmpty | (Inherited from LocalCacheTable.)
Back to Top
Properties
 | Name | Description
Public property | Cache | (Inherited from LocalCacheTable.)
Public property | Capacity | How many entries are allocated for data (Overrides LocalCacheTable Capacity.)
Public property | Count | How many records in the instance (Overrides LocalCacheTable Count.)
Public property | KeyComparer |
Public property | LoadFactor | Load factor for the table (Overrides LocalCacheTable LoadFactor.)
Public property | Name | (Inherited from LocalCacheTable.)
Public property | Options | (Inherited from LocalCacheTable.)
Back to Top
See Also
LocalCacheTable TKey Class
NFX.ApplicationModel.Pile Namespace


LocalCacheTable(TKey) Constructor

LocalCacheTable TKey Constructor NFX Class Library

Initializes a new instance of the LocalCacheTable TKey class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LocalCacheTable(
    LocalCache cache,
    string name,
    IEqualityComparer<TKey> comparer,
    TableOptions options
)
public LocalCacheTable(
    LocalCache cache,
    string name,
    IEqualityComparer<TKey> comparer,
    TableOptions options
)
Public Sub New (
    cache As LocalCache,
    name As String,
    comparer As IEqualityComparer(Of TKey),
    options As TableOptions
)
Public Sub New (
    cache As LocalCache,
    name As String,
    comparer As IEqualityComparer(Of TKey),
    options As TableOptions
)
public:
LocalCacheTable(
    LocalCache^ cache,
    String^ name,
    IEqualityComparer<TKey>^ comparer,
    TableOptions^ options
)
public:
LocalCacheTable(
    LocalCache^ cache,
    String^ name,
    IEqualityComparer<TKey>^ comparer,
    TableOptions^ options
)
new :
        cache : LocalCache *
        name : string *
        comparer : IEqualityComparer<'TKey> *
        options : TableOptions -> LocalCacheTable
new :
        cache : LocalCache *
        name : string *
        comparer : IEqualityComparer<'TKey> *
        options : TableOptions -> LocalCacheTable

Parameters

cache
Type: NFX.ApplicationModel.Pile LocalCache
name
Type: Online System String
comparer
Type: Online System.Collections.Generic IEqualityComparer TKey
options
Type: NFX.ApplicationModel.Pile TableOptions
See Also
LocalCacheTable TKey Class
LocalCacheTable TKey Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable(TKey) Fields

LocalCacheTable TKey Fields NFX Class Library

The LocalCacheTable TKey type exposes the following members.
Fields
 | Name | Description
Protected field | m_Cache | (Inherited from LocalCacheTable.)
Protected field | m_Options | (Inherited from LocalCacheTable.)
Protected field | m_stat_GetHit | (Inherited from LocalCacheTable.)
Protected field | m_stat_GetMiss | (Inherited from LocalCacheTable.)
Protected field | m_stat_Grew | (Inherited from LocalCacheTable.)
Protected field | m_stat_Put | (Inherited from LocalCacheTable.)
Protected field | m_stat_PutCollision | (Inherited from LocalCacheTable.)
Protected field | m_stat_PutOverwrite | (Inherited from LocalCacheTable.)
Protected field | m_stat_PutReplace | (Inherited from LocalCacheTable.)
Protected field | m_stat_RejuvenateHit | (Inherited from LocalCacheTable.)
Protected field | m_stat_RejuvenateMiss | (Inherited from LocalCacheTable.)
Protected field | m_stat_RemoveHit | (Inherited from LocalCacheTable.)
Protected field | m_stat_RemoveMiss | (Inherited from LocalCacheTable.)
Protected field | m_stat_Shrunk | (Inherited from LocalCacheTable.)
Protected field | m_stat_Sweep | (Inherited from LocalCacheTable.)
Protected field | m_stat_SweepDuration | (Inherited from LocalCacheTable.)
Protected field | SweepWhenBecameEmpty | (Inherited from LocalCacheTable.)
Back to Top
See Also
LocalCacheTable TKey Class
NFX.ApplicationModel.Pile Namespace


LocalCacheTable(TKey) Methods

LocalCacheTable TKey Methods NFX Class Library

The LocalCacheTable TKey type exposes the following members.
Methods
 | Name | Description
Public method | ContainsKey |
Protected method | DoPurge | (Overrides LocalCacheTable DoPurge .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetOrPut |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Purge | (Inherited from LocalCacheTable.)
Public method | Put |
Public method | Rejuvenate |
Public method | Remove |
Public method | SizeOfValue |
Protected method | Sweep | (Overrides LocalCacheTable Sweep(Stopwatch, Int32).)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LocalCacheTable TKey Class
NFX.ApplicationModel.Pile Namespace


LocalCacheTable(TKey).ContainsKey Method

LocalCacheTable TKey ContainsKey Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ContainsKey(
    TKey key,
    int ageSec = 0
)
public bool ContainsKey(
    TKey key,
    int ageSec = 0
)
Public Function ContainsKey (
    key As TKey,
    Optional ageSec As Integer = 0
) As Boolean
Public Function ContainsKey (
    key As TKey,
    Optional ageSec As Integer = 0
) As Boolean
public:
virtual bool ContainsKey(
    TKey key,
    int ageSec = 0
) sealed
public:
virtual bool ContainsKey(
    TKey key,
    int ageSec = 0
) sealed
abstract ContainsKey :
        key : 'TKey *
        ?ageSec : int
(* Defaults:
        let _ageSec = defaultArg ageSec 0
*)
-> bool
override ContainsKey :
        key : 'TKey *
        ?ageSec : int
(* Defaults:
        let _ageSec = defaultArg ageSec 0
*)
-> bool
abstract ContainsKey :
        key : 'TKey *
        ?ageSec : int
(* Defaults:
        let _ageSec = defaultArg ageSec 0
*)
-> bool
override ContainsKey :
        key : 'TKey *
        ?ageSec : int
(* Defaults:
        let _ageSec = defaultArg ageSec 0
*)
-> bool

Parameters

key
Type: TKey
ageSec (Optional)
Type: Online System Int32

Return Value

Type: Online Boolean

Implements

ICacheTable TKey ContainsKey(TKey, Int32)
See Also
LocalCacheTable TKey Class
LocalCacheTable TKey Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable(TKey).DoPurge Method

LocalCacheTable TKey DoPurge Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal override void DoPurge()
internal override void DoPurge()
Friend Overrides Sub DoPurge
Friend Overrides Sub DoPurge
internal:
virtual void DoPurge() override
internal:
virtual void DoPurge() override
internal abstract DoPurge : unit -> unit
internal override DoPurge : unit -> unit
internal abstract DoPurge : unit -> unit
internal override DoPurge : unit -> unit
See Also
LocalCacheTable TKey Class
LocalCacheTable TKey Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable(TKey).Get Method

LocalCacheTable TKey Get Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Get(
    TKey key,
    int ageSec = 0
)
public Object Get(
    TKey key,
    int ageSec = 0
)
Public Function Get (
    key As TKey,
    Optional ageSec As Integer = 0
) As Object
Public Function Get (
    key As TKey,
    Optional ageSec As Integer = 0
) As Object
public:
virtual Object^ Get(
    TKey key,
    int ageSec = 0
) sealed
public:
virtual Object^ Get(
    TKey key,
    int ageSec = 0
) sealed
abstract Get :
        key : 'TKey *
        ?ageSec : int
(* Defaults:
        let _ageSec = defaultArg ageSec 0
*)
-> Object
override Get :
        key : 'TKey *
        ?ageSec : int
(* Defaults:
        let _ageSec = defaultArg ageSec 0
*)
-> Object
abstract Get :
        key : 'TKey *
        ?ageSec : int
(* Defaults:
        let _ageSec = defaultArg ageSec 0
*)
-> Object
override Get :
        key : 'TKey *
        ?ageSec : int
(* Defaults:
        let _ageSec = defaultArg ageSec 0
*)
-> Object

Parameters

key
Type: TKey
ageSec (Optional)
Type: Online System Int32

Return Value

Type: Online Object

Implements

ICacheTable TKey Get(TKey, Int32)
See Also
LocalCacheTable TKey Class
LocalCacheTable TKey Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable(TKey).GetOrPut Method

LocalCacheTable TKey GetOrPut Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object GetOrPut(
    TKey key,
    Func<ICacheTable<TKey>, TKey, Object, Object> valueFactory,
    Object factoryContext,
    out Nullable<PutResult> putNewResult,
    int ageSec = 0,
    int putMaxAgeSec = 0,
    int putPriority = 0,
    Nullable<DateTime> putAbsoluteExpirationUTC = null
)
public Object GetOrPut(
    TKey key,
    Func<ICacheTable<TKey>, TKey, Object, Object> valueFactory,
    Object factoryContext,
    out Nullable<PutResult> putNewResult,
    int ageSec = 0,
    int putMaxAgeSec = 0,
    int putPriority = 0,
    Nullable<DateTime> putAbsoluteExpirationUTC = null
)
Public Function GetOrPut (
    key As TKey,
    valueFactory As Func(Of ICacheTable(Of TKey), TKey, Object, Object),
    factoryContext As Object,
    <OutAttribute> ByRef putNewResult As Nullable(Of PutResult),
    Optional ageSec As Integer = 0,
    Optional putMaxAgeSec As Integer = 0,
    Optional putPriority As Integer = 0,
    Optional putAbsoluteExpirationUTC As Nullable(Of DateTime) = Nothing
) As Object
Public Function GetOrPut (
    key As TKey,
    valueFactory As Func(Of ICacheTable(Of TKey), TKey, Object, Object),
    factoryContext As Object,
    <OutAttribute> ByRef putNewResult As Nullable(Of PutResult),
    Optional ageSec As Integer = 0,
    Optional putMaxAgeSec As Integer = 0,
    Optional putPriority As Integer = 0,
    Optional putAbsoluteExpirationUTC As Nullable(Of DateTime) = Nothing
) As Object
public:
virtual Object^ GetOrPut(
    TKey key,
    Func<ICacheTable<TKey>^, TKey, Object^, Object^>^ valueFactory,
    Object^ factoryContext,
    [OutAttribute] Nullable<PutResult>% putNewResult,
    int ageSec = 0,
    int putMaxAgeSec = 0,
    int putPriority = 0,
    Nullable<DateTime> putAbsoluteExpirationUTC = nullptr
) sealed
public:
virtual Object^ GetOrPut(
    TKey key,
    Func<ICacheTable<TKey>^, TKey, Object^, Object^>^ valueFactory,
    Object^ factoryContext,
    [OutAttribute] Nullable<PutResult>% putNewResult,
    int ageSec = 0,
    int putMaxAgeSec = 0,
    int putPriority = 0,
    Nullable<DateTime> putAbsoluteExpirationUTC = nullptr
) sealed
abstract GetOrPut :
        key : 'TKey *
        valueFactory : Func<ICacheTable<'TKey>, 'TKey, Object, Object> *
        factoryContext : Object *
        putNewResult : Nullable<PutResult> byref *
        ?ageSec : int *
        ?putMaxAgeSec : int *
        ?putPriority : int *
        ?putAbsoluteExpirationUTC : Nullable<DateTime>
(* Defaults:
        let _ageSec = defaultArg ageSec 0
        let _putMaxAgeSec = defaultArg putMaxAgeSec 0
        let _putPriority = defaultArg putPriority 0
        let _putAbsoluteExpirationUTC = defaultArg putAbsoluteExpirationUTC null
*)
-> Object
override GetOrPut :
        key : 'TKey *
        valueFactory : Func<ICacheTable<'TKey>, 'TKey, Object, Object> *
        factoryContext : Object *
        putNewResult : Nullable<PutResult> byref *
        ?ageSec : int *
        ?putMaxAgeSec : int *
        ?putPriority : int *
        ?putAbsoluteExpirationUTC : Nullable<DateTime>
(* Defaults:
        let _ageSec = defaultArg ageSec 0
        let _putMaxAgeSec = defaultArg putMaxAgeSec 0
        let _putPriority = defaultArg putPriority 0
        let _putAbsoluteExpirationUTC = defaultArg putAbsoluteExpirationUTC null
*)
-> Object
abstract GetOrPut :
        key : 'TKey *
        valueFactory : Func<ICacheTable<'TKey>, 'TKey, Object, Object> *
        factoryContext : Object *
        putNewResult : Nullable<PutResult> byref *
        ?ageSec : int *
        ?putMaxAgeSec : int *
        ?putPriority : int *
        ?putAbsoluteExpirationUTC : Nullable<DateTime>
(* Defaults:
        let _ageSec = defaultArg ageSec 0
        let _putMaxAgeSec = defaultArg putMaxAgeSec 0
        let _putPriority = defaultArg putPriority 0
        let _putAbsoluteExpirationUTC = defaultArg putAbsoluteExpirationUTC null
*)
-> Object
override GetOrPut :
        key : 'TKey *
        valueFactory : Func<ICacheTable<'TKey>, 'TKey, Object, Object> *
        factoryContext : Object *
        putNewResult : Nullable<PutResult> byref *
        ?ageSec : int *
        ?putMaxAgeSec : int *
        ?putPriority : int *
        ?putAbsoluteExpirationUTC : Nullable<DateTime>
(* Defaults:
        let _ageSec = defaultArg ageSec 0
        let _putMaxAgeSec = defaultArg putMaxAgeSec 0
        let _putPriority = defaultArg putPriority 0
        let _putAbsoluteExpirationUTC = defaultArg putAbsoluteExpirationUTC null
*)
-> Object

Parameters

key
Type: TKey
valueFactory
Type: Online System Func ICacheTable TKey , TKey, Online Object, Online Object
factoryContext
Type: Online System Object
putNewResult
Type: Online System Nullable PutResult
ageSec (Optional)
Type: Online System Int32
putMaxAgeSec (Optional)
Type: Online System Int32
putPriority (Optional)
Type: Online System Int32
putAbsoluteExpirationUTC (Optional)
Type: Online System Nullable Online DateTime

Return Value

Type: Online Object

Implements

ICacheTable TKey GetOrPut(TKey, Func ICacheTable TKey , TKey, Object, Object , Object, Nullable PutResult , Int32, Int32, Int32, Nullable DateTime )
See Also
LocalCacheTable TKey Class
LocalCacheTable TKey Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable(TKey).Put Method

LocalCacheTable TKey Put Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PutResult Put(
    TKey key,
    Object obj,
    Nullable<int> maxAgeSec = null,
    int priority = 0,
    Nullable<DateTime> absoluteExpirationUTC = null
)
public PutResult Put(
    TKey key,
    Object obj,
    Nullable<int> maxAgeSec = null,
    int priority = 0,
    Nullable<DateTime> absoluteExpirationUTC = null
)
Public Function Put (
    key As TKey,
    obj As Object,
    Optional maxAgeSec As Nullable(Of Integer) = Nothing,
    Optional priority As Integer = 0,
    Optional absoluteExpirationUTC As Nullable(Of DateTime) = Nothing
) As PutResult
Public Function Put (
    key As TKey,
    obj As Object,
    Optional maxAgeSec As Nullable(Of Integer) = Nothing,
    Optional priority As Integer = 0,
    Optional absoluteExpirationUTC As Nullable(Of DateTime) = Nothing
) As PutResult
public:
virtual PutResult Put(
    TKey key,
    Object^ obj,
    Nullable<int> maxAgeSec = nullptr,
    int priority = 0,
    Nullable<DateTime> absoluteExpirationUTC = nullptr
) sealed
public:
virtual PutResult Put(
    TKey key,
    Object^ obj,
    Nullable<int> maxAgeSec = nullptr,
    int priority = 0,
    Nullable<DateTime> absoluteExpirationUTC = nullptr
) sealed
abstract Put :
        key : 'TKey *
        obj : Object *
        ?maxAgeSec : Nullable<int> *
        ?priority : int *
        ?absoluteExpirationUTC : Nullable<DateTime>
(* Defaults:
        let _maxAgeSec = defaultArg maxAgeSec null
        let _priority = defaultArg priority 0
        let _absoluteExpirationUTC = defaultArg absoluteExpirationUTC null
*)
-> PutResult
override Put :
        key : 'TKey *
        obj : Object *
        ?maxAgeSec : Nullable<int> *
        ?priority : int *
        ?absoluteExpirationUTC : Nullable<DateTime>
(* Defaults:
        let _maxAgeSec = defaultArg maxAgeSec null
        let _priority = defaultArg priority 0
        let _absoluteExpirationUTC = defaultArg absoluteExpirationUTC null
*)
-> PutResult
abstract Put :
        key : 'TKey *
        obj : Object *
        ?maxAgeSec : Nullable<int> *
        ?priority : int *
        ?absoluteExpirationUTC : Nullable<DateTime>
(* Defaults:
        let _maxAgeSec = defaultArg maxAgeSec null
        let _priority = defaultArg priority 0
        let _absoluteExpirationUTC = defaultArg absoluteExpirationUTC null
*)
-> PutResult
override Put :
        key : 'TKey *
        obj : Object *
        ?maxAgeSec : Nullable<int> *
        ?priority : int *
        ?absoluteExpirationUTC : Nullable<DateTime>
(* Defaults:
        let _maxAgeSec = defaultArg maxAgeSec null
        let _priority = defaultArg priority 0
        let _absoluteExpirationUTC = defaultArg absoluteExpirationUTC null
*)
-> PutResult

Parameters

key
Type: TKey
obj
Type: Online System Object
maxAgeSec (Optional)
Type: Online System Nullable Online Int32
priority (Optional)
Type: Online System Int32
absoluteExpirationUTC (Optional)
Type: Online System Nullable Online DateTime

Return Value

Type: PutResult

Implements

ICacheTable TKey Put(TKey, Object, Nullable Int32 , Int32, Nullable DateTime )
See Also
LocalCacheTable TKey Class
LocalCacheTable TKey Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable(TKey).Rejuvenate Method

LocalCacheTable TKey Rejuvenate Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Rejuvenate(
    TKey key
)
public bool Rejuvenate(
    TKey key
)
Public Function Rejuvenate (
    key As TKey
) As Boolean
Public Function Rejuvenate (
    key As TKey
) As Boolean
public:
virtual bool Rejuvenate(
    TKey key
) sealed
public:
virtual bool Rejuvenate(
    TKey key
) sealed
abstract Rejuvenate :
        key : 'TKey -> bool
override Rejuvenate :
        key : 'TKey -> bool
abstract Rejuvenate :
        key : 'TKey -> bool
override Rejuvenate :
        key : 'TKey -> bool

Parameters

key
Type: TKey

Return Value

Type: Online Boolean

Implements

ICacheTable TKey Rejuvenate(TKey)
See Also
LocalCacheTable TKey Class
LocalCacheTable TKey Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable(TKey).Remove Method

LocalCacheTable TKey Remove Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Remove(
    TKey key
)
public bool Remove(
    TKey key
)
Public Function Remove (
    key As TKey
) As Boolean
Public Function Remove (
    key As TKey
) As Boolean
public:
virtual bool Remove(
    TKey key
) sealed
public:
virtual bool Remove(
    TKey key
) sealed
abstract Remove :
        key : 'TKey -> bool
override Remove :
        key : 'TKey -> bool
abstract Remove :
        key : 'TKey -> bool
override Remove :
        key : 'TKey -> bool

Parameters

key
Type: TKey

Return Value

Type: Online Boolean

Implements

ICacheTable TKey Remove(TKey)
See Also
LocalCacheTable TKey Class
LocalCacheTable TKey Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable(TKey).SizeOfValue Method

LocalCacheTable TKey SizeOfValue Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long SizeOfValue(
    TKey key,
    int ageSec = 0
)
public long SizeOfValue(
    TKey key,
    int ageSec = 0
)
Public Function SizeOfValue (
    key As TKey,
    Optional ageSec As Integer = 0
) As Long
Public Function SizeOfValue (
    key As TKey,
    Optional ageSec As Integer = 0
) As Long
public:
virtual long long SizeOfValue(
    TKey key,
    int ageSec = 0
) sealed
public:
virtual long long SizeOfValue(
    TKey key,
    int ageSec = 0
) sealed
abstract SizeOfValue :
        key : 'TKey *
        ?ageSec : int
(* Defaults:
        let _ageSec = defaultArg ageSec 0
*)
-> int64
override SizeOfValue :
        key : 'TKey *
        ?ageSec : int
(* Defaults:
        let _ageSec = defaultArg ageSec 0
*)
-> int64
abstract SizeOfValue :
        key : 'TKey *
        ?ageSec : int
(* Defaults:
        let _ageSec = defaultArg ageSec 0
*)
-> int64
override SizeOfValue :
        key : 'TKey *
        ?ageSec : int
(* Defaults:
        let _ageSec = defaultArg ageSec 0
*)
-> int64

Parameters

key
Type: TKey
ageSec (Optional)
Type: Online System Int32

Return Value

Type: Online Int64

Implements

ICacheTable TKey SizeOfValue(TKey, Int32)
See Also
LocalCacheTable TKey Class
LocalCacheTable TKey Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable(TKey).Sweep Method

LocalCacheTable TKey Sweep Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override bool Sweep(
    Stopwatch timer,
    int maxTimeMs
)
protected internal override bool Sweep(
    Stopwatch timer,
    int maxTimeMs
)
Protected Friend Overrides Function Sweep (
    timer As Stopwatch,
    maxTimeMs As Integer
) As Boolean
Protected Friend Overrides Function Sweep (
    timer As Stopwatch,
    maxTimeMs As Integer
) As Boolean
protected public:
virtual bool Sweep(
    Stopwatch^ timer,
    int maxTimeMs
) override
protected public:
virtual bool Sweep(
    Stopwatch^ timer,
    int maxTimeMs
) override
abstract Sweep :
        timer : Stopwatch *
        maxTimeMs : int -> bool
override Sweep :
        timer : Stopwatch *
        maxTimeMs : int -> bool
abstract Sweep :
        timer : Stopwatch *
        maxTimeMs : int -> bool
override Sweep :
        timer : Stopwatch *
        maxTimeMs : int -> bool

Parameters

timer
Type: Online System.Diagnostics Stopwatch
maxTimeMs
Type: Online System Int32

Return Value

Type: Online Boolean
See Also
LocalCacheTable TKey Class
LocalCacheTable TKey Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable(TKey) Properties

LocalCacheTable TKey Properties NFX Class Library

The LocalCacheTable TKey type exposes the following members.
Properties
 | Name | Description
Public property | Cache | (Inherited from LocalCacheTable.)
Public property | Capacity | How many entries are allocated for data (Overrides LocalCacheTable Capacity.)
Public property | Count | How many records in the instance (Overrides LocalCacheTable Count.)
Public property | KeyComparer |
Public property | LoadFactor | Load factor for the table (Overrides LocalCacheTable LoadFactor.)
Public property | Name | (Inherited from LocalCacheTable.)
Public property | Options | (Inherited from LocalCacheTable.)
Back to Top
See Also
LocalCacheTable TKey Class
NFX.ApplicationModel.Pile Namespace


LocalCacheTable(TKey).Capacity Property

LocalCacheTable TKey Capacity Property NFX Class Library

How many entries are allocated for data

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long Capacity { get; }
public override long Capacity { get; }
Public Overrides ReadOnly Property Capacity As Long
    Get
Public Overrides ReadOnly Property Capacity As Long
    Get
public:
virtual property long long Capacity {
    long long get () override;
}
public:
virtual property long long Capacity {
    long long get () override;
}
abstract Capacity : int64 with get
override Capacity : int64 with get
abstract Capacity : int64 with get
override Capacity : int64 with get

Property Value

Type: Online Int64

Implements

ICacheTable Capacity
ICacheTable Capacity
See Also
LocalCacheTable TKey Class
LocalCacheTable TKey Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable(TKey).Count Property

LocalCacheTable TKey Count Property NFX Class Library

How many records in the instance

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long Count { get; }
public override long Count { get; }
Public Overrides ReadOnly Property Count As Long
    Get
Public Overrides ReadOnly Property Count As Long
    Get
public:
virtual property long long Count {
    long long get () override;
}
public:
virtual property long long Count {
    long long get () override;
}
abstract Count : int64 with get
override Count : int64 with get
abstract Count : int64 with get
override Count : int64 with get

Property Value

Type: Online Int64

Implements

ICacheTable Count
ICacheTable Count
See Also
LocalCacheTable TKey Class
LocalCacheTable TKey Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable(TKey).KeyComparer Property

LocalCacheTable TKey KeyComparer Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEqualityComparer<TKey> KeyComparer { get; }
public IEqualityComparer<TKey> KeyComparer { get; }
Public ReadOnly Property KeyComparer As IEqualityComparer(Of TKey)
    Get
Public ReadOnly Property KeyComparer As IEqualityComparer(Of TKey)
    Get
public:
virtual property IEqualityComparer<TKey>^ KeyComparer {
    IEqualityComparer<TKey>^ get () sealed;
}
public:
virtual property IEqualityComparer<TKey>^ KeyComparer {
    IEqualityComparer<TKey>^ get () sealed;
}
abstract KeyComparer : IEqualityComparer<'TKey> with get
override KeyComparer : IEqualityComparer<'TKey> with get
abstract KeyComparer : IEqualityComparer<'TKey> with get
override KeyComparer : IEqualityComparer<'TKey> with get

Property Value

Type: Online IEqualityComparer TKey

Implements

ICacheTable TKey KeyComparer
See Also
LocalCacheTable TKey Class
LocalCacheTable TKey Members
NFX.ApplicationModel.Pile Namespace


LocalCacheTable(TKey).LoadFactor Property

LocalCacheTable TKey LoadFactor Property NFX Class Library

Load factor for the table

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override double LoadFactor { get; }
public override double LoadFactor { get; }
Public Overrides ReadOnly Property LoadFactor As Double
    Get
Public Overrides ReadOnly Property LoadFactor As Double
    Get
public:
virtual property double LoadFactor {
    double get () override;
}
public:
virtual property double LoadFactor {
    double get () override;
}
abstract LoadFactor : float with get
override LoadFactor : float with get
abstract LoadFactor : float with get
override LoadFactor : float with get

Property Value

Type: Online Double

Implements

ICacheTable LoadFactor
ICacheTable LoadFactor
See Also
LocalCacheTable TKey Class
LocalCacheTable TKey Members
NFX.ApplicationModel.Pile Namespace


LocalityKind Enumeration

LocalityKind Enumeration NFX Class Library

Indicates where pile implementation stores data: local vs distributed

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum LocalityKind
public enum LocalityKind
Public Enumeration LocalityKind
Public Enumeration LocalityKind
public enum class LocalityKind
public enum class LocalityKind
type LocalityKind
type LocalityKind
Members
Member name | Value | Description
Local | 0 | The pile resides on this machine and is limited by the RAM on the local server
Distributed | 1 | The pile is distributed - it runs across many machines
AumCluster | 2 | The pile is distributed - it runs across many machines using Aum Cluster
See Also
NFX.ApplicationModel.Pile Namespace


ObjectPersistence Enumeration

ObjectPersistence Enumeration NFX Class Library

Denotes modes of object persistence

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum ObjectPersistence
public enum ObjectPersistence
Public Enumeration ObjectPersistence
Public Enumeration ObjectPersistence
public enum class ObjectPersistence
public enum class ObjectPersistence
type ObjectPersistence
type ObjectPersistence
Members
Member name | Value | Description
Memory | 0 | The data is kept in memory in a format that prohibits the preservation of data between object layout changes, for example, the Slim serializer does not support versioning, hence this mode is beneficial for maximum performance of local in-process heaps
UpgreadableMemory | 1 | The data is kept in memory in a format that allows to change the object structure (serialization versioning), i.e. a distributed node may keep objects usable even after client's software changes
Disk | 2 | The data is kept on disk. The data is in object-upgreadable format (support changes of object structure)
MemoryDisk | 3 | The data is kept on disk and cached in memory (i.e. memory-mapped file). The data is in object-upgreadable format (support changes of object structure)
See Also
NFX.ApplicationModel.Pile Namespace


PileAccessViolationException Class

PileAccessViolationException Class NFX Class Library

Thrown by pile memory manager when a supplied PilePointer is not pointing to a valid buffer
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.ApplicationModel.Pile PileException
NFX.ApplicationModel.Pile PileAccessViolationException

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PileAccessViolationException : PileException
[SerializableAttribute]
public class PileAccessViolationException : PileException
<SerializableAttribute>
Public Class PileAccessViolationException
    Inherits PileException
<SerializableAttribute>
Public Class PileAccessViolationException
    Inherits PileException
[SerializableAttribute]
public ref class PileAccessViolationException : public PileException
[SerializableAttribute]
public ref class PileAccessViolationException : public PileException
[<SerializableAttribute>]
type PileAccessViolationException =
    class
        inherit PileException
    end
[<SerializableAttribute>]
type PileAccessViolationException =
    class
        inherit PileException
    end
See Also
PileAccessViolationException Members
NFX.ApplicationModel.Pile Namespace


PileAccessViolationException Members

PileAccessViolationException Members NFX Class Library

The PileAccessViolationException type exposes the following members.
Constructors
 | Name | Description
Public method | PileAccessViolationException | Initializes a new instance of the PileAccessViolationException class
Public method | PileAccessViolationException(String) | Initializes a new instance of the PileAccessViolationException class
Protected method | PileAccessViolationException(SerializationInfo, StreamingContext) | Initializes a new instance of the PileAccessViolationException class
Public method | PileAccessViolationException(String, Exception) | Initializes a new instance of the PileAccessViolationException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
PileAccessViolationException Class
NFX.ApplicationModel.Pile Namespace


PileAccessViolationException Constructor

PileAccessViolationException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | PileAccessViolationException | Initializes a new instance of the PileAccessViolationException class
Public method | PileAccessViolationException(String) | Initializes a new instance of the PileAccessViolationException class
Protected method | PileAccessViolationException(SerializationInfo, StreamingContext) | Initializes a new instance of the PileAccessViolationException class
Public method | PileAccessViolationException(String, Exception) | Initializes a new instance of the PileAccessViolationException class
Back to Top
See Also
PileAccessViolationException Class
PileAccessViolationException Members
NFX.ApplicationModel.Pile Namespace


PileAccessViolationException Constructor

PileAccessViolationException Constructor NFX Class Library

Initializes a new instance of the PileAccessViolationException class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PileAccessViolationException()
public PileAccessViolationException()
Public Sub New
Public Sub New
public:
PileAccessViolationException()
public:
PileAccessViolationException()
new : unit -> PileAccessViolationException
new : unit -> PileAccessViolationException
See Also
PileAccessViolationException Class
PileAccessViolationException Members
PileAccessViolationException Overload
NFX.ApplicationModel.Pile Namespace


PileAccessViolationException Constructor (String)

PileAccessViolationException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PileAccessViolationException class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PileAccessViolationException(
    string message
)
public PileAccessViolationException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
PileAccessViolationException(
    String^ message
)
public:
PileAccessViolationException(
    String^ message
)
new :
        message : string -> PileAccessViolationException
new :
        message : string -> PileAccessViolationException

Parameters

message
Type: Online System String
See Also
PileAccessViolationException Class
PileAccessViolationException Members
PileAccessViolationException Overload
NFX.ApplicationModel.Pile Namespace


PileAccessViolationException Constructor (SerializationInfo, StreamingContext)

PileAccessViolationException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PileAccessViolationException class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PileAccessViolationException(
    SerializationInfo info,
    StreamingContext context
)
protected PileAccessViolationException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
PileAccessViolationException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
PileAccessViolationException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PileAccessViolationException
new :
        info : SerializationInfo *
        context : StreamingContext -> PileAccessViolationException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
PileAccessViolationException Class
PileAccessViolationException Members
PileAccessViolationException Overload
NFX.ApplicationModel.Pile Namespace


PileAccessViolationException Constructor (String, Exception)

PileAccessViolationException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PileAccessViolationException class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PileAccessViolationException(
    string message,
    Exception inner
)
public PileAccessViolationException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
PileAccessViolationException(
    String^ message,
    Exception^ inner
)
public:
PileAccessViolationException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> PileAccessViolationException
new :
        message : string *
        inner : Exception -> PileAccessViolationException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
PileAccessViolationException Class
PileAccessViolationException Members
PileAccessViolationException Overload
NFX.ApplicationModel.Pile Namespace


PileAccessViolationException Methods

PileAccessViolationException Methods NFX Class Library

The PileAccessViolationException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
PileAccessViolationException Class
NFX.ApplicationModel.Pile Namespace


PileAccessViolationException Properties

PileAccessViolationException Properties NFX Class Library

The PileAccessViolationException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
PileAccessViolationException Class
NFX.ApplicationModel.Pile Namespace


PileAccessViolationException Events

PileAccessViolationException Events NFX Class Library

The PileAccessViolationException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
PileAccessViolationException Class
NFX.ApplicationModel.Pile Namespace


PileCacheException Class

PileCacheException Class NFX Class Library

Thrown by pile cache
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.ApplicationModel.Pile PileException
NFX.ApplicationModel.Pile PileCacheException

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PileCacheException : PileException
[SerializableAttribute]
public class PileCacheException : PileException
<SerializableAttribute>
Public Class PileCacheException
    Inherits PileException
<SerializableAttribute>
Public Class PileCacheException
    Inherits PileException
[SerializableAttribute]
public ref class PileCacheException : public PileException
[SerializableAttribute]
public ref class PileCacheException : public PileException
[<SerializableAttribute>]
type PileCacheException =
    class
        inherit PileException
    end
[<SerializableAttribute>]
type PileCacheException =
    class
        inherit PileException
    end
See Also
PileCacheException Members
NFX.ApplicationModel.Pile Namespace


PileCacheException Members

PileCacheException Members NFX Class Library

The PileCacheException type exposes the following members.
Constructors
 | Name | Description
Public method | PileCacheException | Initializes a new instance of the PileCacheException class
Public method | PileCacheException(String) | Initializes a new instance of the PileCacheException class
Protected method | PileCacheException(SerializationInfo, StreamingContext) | Initializes a new instance of the PileCacheException class
Public method | PileCacheException(String, Exception) | Initializes a new instance of the PileCacheException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
PileCacheException Class
NFX.ApplicationModel.Pile Namespace


PileCacheException Constructor

PileCacheException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | PileCacheException | Initializes a new instance of the PileCacheException class
Public method | PileCacheException(String) | Initializes a new instance of the PileCacheException class
Protected method | PileCacheException(SerializationInfo, StreamingContext) | Initializes a new instance of the PileCacheException class
Public method | PileCacheException(String, Exception) | Initializes a new instance of the PileCacheException class
Back to Top
See Also
PileCacheException Class
PileCacheException Members
NFX.ApplicationModel.Pile Namespace


PileCacheException Constructor

PileCacheException Constructor NFX Class Library

Initializes a new instance of the PileCacheException class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PileCacheException()
public PileCacheException()
Public Sub New
Public Sub New
public:
PileCacheException()
public:
PileCacheException()
new : unit -> PileCacheException
new : unit -> PileCacheException
See Also
PileCacheException Class
PileCacheException Members
PileCacheException Overload
NFX.ApplicationModel.Pile Namespace


PileCacheException Constructor (String)

PileCacheException Constructor (String) NFX Class Library

Initializes a new instance of the PileCacheException class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PileCacheException(
    string message
)
public PileCacheException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
PileCacheException(
    String^ message
)
public:
PileCacheException(
    String^ message
)
new :
        message : string -> PileCacheException
new :
        message : string -> PileCacheException

Parameters

message
Type: Online System String
See Also
PileCacheException Class
PileCacheException Members
PileCacheException Overload
NFX.ApplicationModel.Pile Namespace


PileCacheException Constructor (SerializationInfo, StreamingContext)

PileCacheException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PileCacheException class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PileCacheException(
    SerializationInfo info,
    StreamingContext context
)
protected PileCacheException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
PileCacheException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
PileCacheException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PileCacheException
new :
        info : SerializationInfo *
        context : StreamingContext -> PileCacheException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
PileCacheException Class
PileCacheException Members
PileCacheException Overload
NFX.ApplicationModel.Pile Namespace


PileCacheException Constructor (String, Exception)

PileCacheException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PileCacheException class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PileCacheException(
    string message,
    Exception inner
)
public PileCacheException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
PileCacheException(
    String^ message,
    Exception^ inner
)
public:
PileCacheException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> PileCacheException
new :
        message : string *
        inner : Exception -> PileCacheException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
PileCacheException Class
PileCacheException Members
PileCacheException Overload
NFX.ApplicationModel.Pile Namespace


PileCacheException Methods

PileCacheException Methods NFX Class Library

The PileCacheException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
PileCacheException Class
NFX.ApplicationModel.Pile Namespace


PileCacheException Properties

PileCacheException Properties NFX Class Library

The PileCacheException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
PileCacheException Class
NFX.ApplicationModel.Pile Namespace


PileCacheException Events

PileCacheException Events NFX Class Library

The PileCacheException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
PileCacheException Class
NFX.ApplicationModel.Pile Namespace


PileException Class

PileException Class NFX Class Library

Thrown by pile memory manager
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.ApplicationModel.Pile PileException
NFX.ApplicationModel.Pile PileAccessViolationException
NFX.ApplicationModel.Pile PileCacheException
NFX.ApplicationModel.Pile PileOutOfSpaceException

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PileException : NFXException
[SerializableAttribute]
public class PileException : NFXException
<SerializableAttribute>
Public Class PileException
    Inherits NFXException
<SerializableAttribute>
Public Class PileException
    Inherits NFXException
[SerializableAttribute]
public ref class PileException : public NFXException
[SerializableAttribute]
public ref class PileException : public NFXException
[<SerializableAttribute>]
type PileException =
    class
        inherit NFXException
    end
[<SerializableAttribute>]
type PileException =
    class
        inherit NFXException
    end
See Also
PileException Members
NFX.ApplicationModel.Pile Namespace


PileException Members

PileException Members NFX Class Library

The PileException type exposes the following members.
Constructors
 | Name | Description
Public method | PileException | Initializes a new instance of the PileException class
Public method | PileException(String) | Initializes a new instance of the PileException class
Protected method | PileException(SerializationInfo, StreamingContext) | Initializes a new instance of the PileException class
Public method | PileException(String, Exception) | Initializes a new instance of the PileException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
PileException Class
NFX.ApplicationModel.Pile Namespace


PileException Constructor

PileException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | PileException | Initializes a new instance of the PileException class
Public method | PileException(String) | Initializes a new instance of the PileException class
Protected method | PileException(SerializationInfo, StreamingContext) | Initializes a new instance of the PileException class
Public method | PileException(String, Exception) | Initializes a new instance of the PileException class
Back to Top
See Also
PileException Class
PileException Members
NFX.ApplicationModel.Pile Namespace


PileException Constructor

PileException Constructor NFX Class Library

Initializes a new instance of the PileException class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PileException()
public PileException()
Public Sub New
Public Sub New
public:
PileException()
public:
PileException()
new : unit -> PileException
new : unit -> PileException
See Also
PileException Class
PileException Members
PileException Overload
NFX.ApplicationModel.Pile Namespace


PileException Constructor (String)

PileException Constructor (String) NFX Class Library

Initializes a new instance of the PileException class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PileException(
    string message
)
public PileException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
PileException(
    String^ message
)
public:
PileException(
    String^ message
)
new :
        message : string -> PileException
new :
        message : string -> PileException

Parameters

message
Type: Online System String
See Also
PileException Class
PileException Members
PileException Overload
NFX.ApplicationModel.Pile Namespace


PileException Constructor (SerializationInfo, StreamingContext)

PileException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PileException class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PileException(
    SerializationInfo info,
    StreamingContext context
)
protected PileException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
PileException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
PileException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PileException
new :
        info : SerializationInfo *
        context : StreamingContext -> PileException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
PileException Class
PileException Members
PileException Overload
NFX.ApplicationModel.Pile Namespace


PileException Constructor (String, Exception)

PileException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PileException class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PileException(
    string message,
    Exception inner
)
public PileException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
PileException(
    String^ message,
    Exception^ inner
)
public:
PileException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> PileException
new :
        message : string *
        inner : Exception -> PileException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
PileException Class
PileException Members
PileException Overload
NFX.ApplicationModel.Pile Namespace


PileException Methods

PileException Methods NFX Class Library

The PileException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
PileException Class
NFX.ApplicationModel.Pile Namespace


PileException Properties

PileException Properties NFX Class Library

The PileException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
PileException Class
NFX.ApplicationModel.Pile Namespace


PileException Events

PileException Events NFX Class Library

The PileException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
PileException Class
NFX.ApplicationModel.Pile Namespace


PileOutOfSpaceException Class

PileOutOfSpaceException Class NFX Class Library

Thrown by pile memory manager when there is not anough room in the pile to perform the requested operation
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.ApplicationModel.Pile PileException
NFX.ApplicationModel.Pile PileOutOfSpaceException

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PileOutOfSpaceException : PileException
[SerializableAttribute]
public class PileOutOfSpaceException : PileException
<SerializableAttribute>
Public Class PileOutOfSpaceException
    Inherits PileException
<SerializableAttribute>
Public Class PileOutOfSpaceException
    Inherits PileException
[SerializableAttribute]
public ref class PileOutOfSpaceException : public PileException
[SerializableAttribute]
public ref class PileOutOfSpaceException : public PileException
[<SerializableAttribute>]
type PileOutOfSpaceException =
    class
        inherit PileException
    end
[<SerializableAttribute>]
type PileOutOfSpaceException =
    class
        inherit PileException
    end
See Also
PileOutOfSpaceException Members
NFX.ApplicationModel.Pile Namespace


PileOutOfSpaceException Members

PileOutOfSpaceException Members NFX Class Library

The PileOutOfSpaceException type exposes the following members.
Constructors
 | Name | Description
Public method | PileOutOfSpaceException | Initializes a new instance of the PileOutOfSpaceException class
Public method | PileOutOfSpaceException(String) | Initializes a new instance of the PileOutOfSpaceException class
Protected method | PileOutOfSpaceException(SerializationInfo, StreamingContext) | Initializes a new instance of the PileOutOfSpaceException class
Public method | PileOutOfSpaceException(String, Exception) | Initializes a new instance of the PileOutOfSpaceException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
PileOutOfSpaceException Class
NFX.ApplicationModel.Pile Namespace


PileOutOfSpaceException Constructor

PileOutOfSpaceException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | PileOutOfSpaceException | Initializes a new instance of the PileOutOfSpaceException class
Public method | PileOutOfSpaceException(String) | Initializes a new instance of the PileOutOfSpaceException class
Protected method | PileOutOfSpaceException(SerializationInfo, StreamingContext) | Initializes a new instance of the PileOutOfSpaceException class
Public method | PileOutOfSpaceException(String, Exception) | Initializes a new instance of the PileOutOfSpaceException class
Back to Top
See Also
PileOutOfSpaceException Class
PileOutOfSpaceException Members
NFX.ApplicationModel.Pile Namespace


PileOutOfSpaceException Constructor

PileOutOfSpaceException Constructor NFX Class Library

Initializes a new instance of the PileOutOfSpaceException class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PileOutOfSpaceException()
public PileOutOfSpaceException()
Public Sub New
Public Sub New
public:
PileOutOfSpaceException()
public:
PileOutOfSpaceException()
new : unit -> PileOutOfSpaceException
new : unit -> PileOutOfSpaceException
See Also
PileOutOfSpaceException Class
PileOutOfSpaceException Members
PileOutOfSpaceException Overload
NFX.ApplicationModel.Pile Namespace


PileOutOfSpaceException Constructor (String)

PileOutOfSpaceException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PileOutOfSpaceException class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PileOutOfSpaceException(
    string message
)
public PileOutOfSpaceException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
PileOutOfSpaceException(
    String^ message
)
public:
PileOutOfSpaceException(
    String^ message
)
new :
        message : string -> PileOutOfSpaceException
new :
        message : string -> PileOutOfSpaceException

Parameters

message
Type: Online System String
See Also
PileOutOfSpaceException Class
PileOutOfSpaceException Members
PileOutOfSpaceException Overload
NFX.ApplicationModel.Pile Namespace


PileOutOfSpaceException Constructor (SerializationInfo, StreamingContext)

PileOutOfSpaceException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PileOutOfSpaceException class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PileOutOfSpaceException(
    SerializationInfo info,
    StreamingContext context
)
protected PileOutOfSpaceException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
PileOutOfSpaceException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
PileOutOfSpaceException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PileOutOfSpaceException
new :
        info : SerializationInfo *
        context : StreamingContext -> PileOutOfSpaceException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
PileOutOfSpaceException Class
PileOutOfSpaceException Members
PileOutOfSpaceException Overload
NFX.ApplicationModel.Pile Namespace


PileOutOfSpaceException Constructor (String, Exception)

PileOutOfSpaceException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PileOutOfSpaceException class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PileOutOfSpaceException(
    string message,
    Exception inner
)
public PileOutOfSpaceException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
PileOutOfSpaceException(
    String^ message,
    Exception^ inner
)
public:
PileOutOfSpaceException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> PileOutOfSpaceException
new :
        message : string *
        inner : Exception -> PileOutOfSpaceException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
PileOutOfSpaceException Class
PileOutOfSpaceException Members
PileOutOfSpaceException Overload
NFX.ApplicationModel.Pile Namespace


PileOutOfSpaceException Methods

PileOutOfSpaceException Methods NFX Class Library

The PileOutOfSpaceException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
PileOutOfSpaceException Class
NFX.ApplicationModel.Pile Namespace


PileOutOfSpaceException Properties

PileOutOfSpaceException Properties NFX Class Library

The PileOutOfSpaceException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
PileOutOfSpaceException Class
NFX.ApplicationModel.Pile Namespace


PileOutOfSpaceException Events

PileOutOfSpaceException Events NFX Class Library

The PileOutOfSpaceException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
PileOutOfSpaceException Class
NFX.ApplicationModel.Pile Namespace


PilePointer Structure

PilePointer Structure NFX Class Library

Represents a pointer to the pile object (object stored in a pile). The reference may be local or distributed in which case the NodeID is>=0. Distributed pointers are very useful for organizing piles of objects distributed among many servers, for example for "Big Memory" implementations or large neural networks where nodes may inter-connect between servers. The CLR reference to the IPile is not a part of this struct for performance and practicality reasons, as it is highly unlikely that there are going to be more than one instance of a pile in a process, however should more than 1 pile be allocated than this pointer would need to be wrapped in some other structure along with source IPile reference

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct PilePointer : IEquatable<PilePointer>
public struct PilePointer : IEquatable<PilePointer>
Public Structure PilePointer
    Implements IEquatable(Of PilePointer)
Public Structure PilePointer
    Implements IEquatable(Of PilePointer)
public value class PilePointer : IEquatable<PilePointer>
public value class PilePointer : IEquatable<PilePointer>
[<SealedAttribute>]
type PilePointer =
    struct
        interface IEquatable<PilePointer>
    end
[<SealedAttribute>]
type PilePointer =
    struct
        interface IEquatable<PilePointer>
    end
See Also
PilePointer Members
NFX.ApplicationModel.Pile Namespace


PilePointer Members

PilePointer Members NFX Class Library

The PilePointer type exposes the following members.
Constructors
 | Name | Description
Public method | PilePointer(Int32, Int32) | Create local pointer
Public method | PilePointer(Int32, Int32, Int32) | Creates distributed pointer
Back to Top
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(PilePointer) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Operators
Name | Description
Equality |
Inequality |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Address | Address within the segment
Public field | NodeID | Distributed Node ID. The local pile sets this to -1 rendering this pointer as !DistributedValid
Public field | Segment | Segment # within pile
Back to Top
Properties
 | Name | Description
Public property | DistributedValid | Returns true if the pointer has positive distributed NodeID and has a valid local pointer
 | Invalid | Returns a -1:-1 non-valid pointer (either local or distributed)
Public property | Valid | Returns true if the pointer has positive segment and address, however this does not mean that pointed-to data exists. Even if this is a valid local pointer it may be an invalid distributed pointer
Back to Top
See Also
PilePointer Structure
NFX.ApplicationModel.Pile Namespace


PilePointer Constructor

PilePointer Constructor NFX Class Library

Overload List
 | Name | Description
Public method | PilePointer(Int32, Int32) | Create local pointer
Public method | PilePointer(Int32, Int32, Int32) | Creates distributed pointer
Back to Top
See Also
PilePointer Structure
PilePointer Members
NFX.ApplicationModel.Pile Namespace


PilePointer Constructor (Int32, Int32)

PilePointer Constructor (Int32, Int32) NFX Class Library

Create local pointer

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PilePointer(
    int seg,
    int addr
)
public PilePointer(
    int seg,
    int addr
)
Public Sub New (
    seg As Integer,
    addr As Integer
)
Public Sub New (
    seg As Integer,
    addr As Integer
)
public:
PilePointer(
    int seg,
    int addr
)
public:
PilePointer(
    int seg,
    int addr
)
new :
        seg : int *
        addr : int -> PilePointer
new :
        seg : int *
        addr : int -> PilePointer

Parameters

seg
Type: Online System Int32
addr
Type: Online System Int32
See Also
PilePointer Structure
PilePointer Members
PilePointer Overload
NFX.ApplicationModel.Pile Namespace


PilePointer Constructor (Int32, Int32, Int32)

PilePointer Constructor (Int32, Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates distributed pointer

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PilePointer(
    int nodeId,
    int seg,
    int addr
)
public PilePointer(
    int nodeId,
    int seg,
    int addr
)
Public Sub New (
    nodeId As Integer,
    seg As Integer,
    addr As Integer
)
Public Sub New (
    nodeId As Integer,
    seg As Integer,
    addr As Integer
)
public:
PilePointer(
    int nodeId,
    int seg,
    int addr
)
public:
PilePointer(
    int nodeId,
    int seg,
    int addr
)
new :
        nodeId : int *
        seg : int *
        addr : int -> PilePointer
new :
        nodeId : int *
        seg : int *
        addr : int -> PilePointer

Parameters

nodeId
Type: Online System Int32
seg
Type: Online System Int32
addr
Type: Online System Int32
See Also
PilePointer Structure
PilePointer Members
PilePointer Overload
NFX.ApplicationModel.Pile Namespace


PilePointer Fields

PilePointer Fields NFX Class Library

The PilePointer type exposes the following members.
Fields
 | Name | Description
Public field | Address | Address within the segment
Public field | NodeID | Distributed Node ID. The local pile sets this to -1 rendering this pointer as !DistributedValid
Public field | Segment | Segment # within pile
Back to Top
See Also
PilePointer Structure
NFX.ApplicationModel.Pile Namespace


PilePointer.Address Field

PilePointer Address Field NFX Class Library

Address within the segment

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Address
public readonly int Address
Public ReadOnly Address As Integer
Public ReadOnly Address As Integer
public:
initonly int Address
public:
initonly int Address
val Address: int
val Address: int

Field Value

Type: Online Int32
See Also
PilePointer Structure
PilePointer Members
NFX.ApplicationModel.Pile Namespace


PilePointer.NodeID Field

PilePointer NodeID Field NFX Class Library

Distributed Node ID. The local pile sets this to -1 rendering this pointer as !DistributedValid

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int NodeID
public readonly int NodeID
Public ReadOnly NodeID As Integer
Public ReadOnly NodeID As Integer
public:
initonly int NodeID
public:
initonly int NodeID
val NodeID: int
val NodeID: int

Field Value

Type: Online Int32
See Also
PilePointer Structure
PilePointer Members
NFX.ApplicationModel.Pile Namespace


PilePointer.Segment Field

PilePointer Segment Field NFX Class Library

Segment # within pile

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Segment
public readonly int Segment
Public ReadOnly Segment As Integer
Public ReadOnly Segment As Integer
public:
initonly int Segment
public:
initonly int Segment
val Segment: int
val Segment: int

Field Value

Type: Online Int32
See Also
PilePointer Structure
PilePointer Members
NFX.ApplicationModel.Pile Namespace


PilePointer Methods

PilePointer Methods NFX Class Library

The PilePointer type exposes the following members.
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(PilePointer) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PilePointer Structure
NFX.ApplicationModel.Pile Namespace


PilePointer.Equals Method

PilePointer Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(PilePointer) |
Back to Top
See Also
PilePointer Structure
PilePointer Members
NFX.ApplicationModel.Pile Namespace


PilePointer.Equals Method (Object)

PilePointer Equals Method (Object) NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
PilePointer Structure
PilePointer Members
Equals Overload
NFX.ApplicationModel.Pile Namespace


PilePointer.Equals Method (PilePointer)

PilePointer Equals Method (PilePointer) NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    PilePointer other
)
public bool Equals(
    PilePointer other
)
Public Function Equals (
    other As PilePointer
) As Boolean
Public Function Equals (
    other As PilePointer
) As Boolean
public:
virtual bool Equals(
    PilePointer other
) sealed
public:
virtual bool Equals(
    PilePointer other
) sealed
abstract Equals :
        other : PilePointer -> bool
override Equals :
        other : PilePointer -> bool
abstract Equals :
        other : PilePointer -> bool
override Equals :
        other : PilePointer -> bool

Parameters

other
Type: NFX.ApplicationModel.Pile PilePointer

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
PilePointer Structure
PilePointer Members
Equals Overload
NFX.ApplicationModel.Pile Namespace


PilePointer.GetHashCode Method

PilePointer GetHashCode Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
PilePointer Structure
PilePointer Members
NFX.ApplicationModel.Pile Namespace


PilePointer.ToString Method

PilePointer ToString Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
PilePointer Structure
PilePointer Members
NFX.ApplicationModel.Pile Namespace


PilePointer Operators

PilePointer Operators NFX Class Library

The PilePointer type exposes the following members.
Operators
Name | Description
Equality |
Inequality |
Back to Top
See Also
PilePointer Structure
NFX.ApplicationModel.Pile Namespace


PilePointer.Equality Operator

PilePointer Equality Operator NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    PilePointer l,
    PilePointer r
)
public static bool operator ==(
    PilePointer l,
    PilePointer r
)
Public Shared Operator = (
    l As PilePointer,
    r As PilePointer
) As Boolean
Public Shared Operator = (
    l As PilePointer,
    r As PilePointer
) As Boolean
public:
static bool operator ==(
    PilePointer l,
    PilePointer r
)
public:
static bool operator ==(
    PilePointer l,
    PilePointer r
)
static let inline (=)
        l : PilePointer *
        r : PilePointer  : bool
static let inline (=)
        l : PilePointer *
        r : PilePointer  : bool

Parameters

l
Type: NFX.ApplicationModel.Pile PilePointer
r
Type: NFX.ApplicationModel.Pile PilePointer

Return Value

Type: Online Boolean
See Also
PilePointer Structure
PilePointer Members
NFX.ApplicationModel.Pile Namespace


PilePointer.Inequality Operator

PilePointer Inequality Operator NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    PilePointer l,
    PilePointer r
)
public static bool operator !=(
    PilePointer l,
    PilePointer r
)
Public Shared Operator <> (
    l As PilePointer,
    r As PilePointer
) As Boolean
Public Shared Operator <> (
    l As PilePointer,
    r As PilePointer
) As Boolean
public:
static bool operator !=(
    PilePointer l,
    PilePointer r
)
public:
static bool operator !=(
    PilePointer l,
    PilePointer r
)
static let inline (<>)
        l : PilePointer *
        r : PilePointer  : bool
static let inline (<>)
        l : PilePointer *
        r : PilePointer  : bool

Parameters

l
Type: NFX.ApplicationModel.Pile PilePointer
r
Type: NFX.ApplicationModel.Pile PilePointer

Return Value

Type: Online Boolean
See Also
PilePointer Structure
PilePointer Members
NFX.ApplicationModel.Pile Namespace


PilePointer Properties

PilePointer Properties NFX Class Library

The PilePointer type exposes the following members.
Properties
 | Name | Description
Public property | DistributedValid | Returns true if the pointer has positive distributed NodeID and has a valid local pointer
 | Invalid | Returns a -1:-1 non-valid pointer (either local or distributed)
Public property | Valid | Returns true if the pointer has positive segment and address, however this does not mean that pointed-to data exists. Even if this is a valid local pointer it may be an invalid distributed pointer
Back to Top
See Also
PilePointer Structure
NFX.ApplicationModel.Pile Namespace


PilePointer.DistributedValid Property

PilePointer DistributedValid Property NFX Class Library

Returns true if the pointer has positive distributed NodeID and has a valid local pointer

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool DistributedValid { get; }
public bool DistributedValid { get; }
Public ReadOnly Property DistributedValid As Boolean
    Get
Public ReadOnly Property DistributedValid As Boolean
    Get
public:
property bool DistributedValid {
    bool get ();
}
public:
property bool DistributedValid {
    bool get ();
}
member DistributedValid : bool with get
member DistributedValid : bool with get

Property Value

Type: Online Boolean
See Also
PilePointer Structure
PilePointer Members
NFX.ApplicationModel.Pile Namespace


PilePointer.Invalid Property

PilePointer Invalid Property NFX Class Library

Returns a -1:-1 non-valid pointer (either local or distributed)

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PilePointer Invalid { get; }
public static PilePointer Invalid { get; }
Public Shared ReadOnly Property Invalid As PilePointer
    Get
Public Shared ReadOnly Property Invalid As PilePointer
    Get
public:
static property PilePointer Invalid {
    PilePointer get ();
}
public:
static property PilePointer Invalid {
    PilePointer get ();
}
static member Invalid : PilePointer with get
static member Invalid : PilePointer with get

Property Value

Type: PilePointer
See Also
PilePointer Structure
PilePointer Members
NFX.ApplicationModel.Pile Namespace


PilePointer.Valid Property

PilePointer Valid Property NFX Class Library

Returns true if the pointer has positive segment and address, however this does not mean that pointed-to data exists. Even if this is a valid local pointer it may be an invalid distributed pointer

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Valid { get; }
public bool Valid { get; }
Public ReadOnly Property Valid As Boolean
    Get
Public ReadOnly Property Valid As Boolean
    Get
public:
property bool Valid {
    bool get ();
}
public:
property bool Valid {
    bool get ();
}
member Valid : bool with get
member Valid : bool with get

Property Value

Type: Online Boolean
See Also
PilePointer Structure
PilePointer Members
NFX.ApplicationModel.Pile Namespace


PutResult Enumeration

PutResult Enumeration NFX Class Library

Denotes statuses of cache table Put

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum PutResult
public enum PutResult
Public Enumeration PutResult
Public Enumeration PutResult
public enum class PutResult
public enum class PutResult
type PutResult
type PutResult
Members
Member name | Value | Description
Collision | 0 | The item could not be put because it collides with existing data that can not be overwritten because it has higher priority and there is no extra space
Inserted | 1 | The item was inserted into cache table anew
Replaced | 2 | The item replaced an existing item with the same key
Overwritten | 3 | The item was inserted instead of an existing item with lower or equal priority
See Also
NFX.ApplicationModel.Pile Namespace


TableOptions Class

TableOptions Class NFX Class Library

Provides config options for cache tables
Inheritance Hierarchy
Online System Object
NFX.ApplicationModel.Pile TableOptions

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class TableOptions : INamed
[SerializableAttribute]
public sealed class TableOptions : INamed
<SerializableAttribute>
Public NotInheritable Class TableOptions
    Implements INamed
<SerializableAttribute>
Public NotInheritable Class TableOptions
    Implements INamed
[SerializableAttribute]
public ref class TableOptions sealed : INamed
[SerializableAttribute]
public ref class TableOptions sealed : INamed
[<SealedAttribute>]
[<SerializableAttribute>]
type TableOptions =
    class
        interface INamed
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type TableOptions =
    class
        interface INamed
    end
See Also
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions Members

TableOptions Members NFX Class Library

The TableOptions type exposes the following members.
Constructors
 | Name | Description
Public method | TableOptions(String) | Initializes a new instance of the TableOptions class
Public method | TableOptions(IConfigSectionNode, Boolean) | Initializes a new instance of the TableOptions class
Back to Top
Methods
 | Name | Description
Public method | Clone | Makes an identical copy of this instance
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | DEFAULT_MAX_AGE_SEC_DEFAULT |
 | GROWTH_FACTOR_DEFAULT |
 | GROWTH_FACTOR_MAX |
 | GROWTH_FACTOR_MIN |
 | INITIAL_CAPACITY_DEFAULT |
 | INITIAL_CAPACITY_MIN |
 | LOAD_FACTOR_HWM_DEFAULT |
 | LOAD_FACTOR_HWM_MAX |
 | LOAD_FACTOR_HWM_MIN |
 | LOAD_FACTOR_LWM_DEFAULT |
 | LOAD_FACTOR_LWM_MAX |
 | LOAD_FACTOR_LWM_MIN |
Protected field | m_Name |
 | SHRINK_FACTOR_DEFAULT |
 | SHRINK_FACTOR_MAX |
 | SHRINK_FACTOR_MIN |
Back to Top
Properties
 | Name | Description
Public property | AsExternalParameter | Allows to get/set options as external parameters
Public property | DefaultMaxAgeSec | Specifies default max age length which is applied to cache items if Put() does not specify particular max age
Public property | DetailedInstrumentation | True to include instrumentation details per table
Public property | GrowthFactor | Defines the factor of growth - how much does a table grow when HWM is reached. The number has to be at least 1.2d
Public property | InitialCapacity | How many elements an empty table should contain. The value is dependent on bucket count, so the actual table capacity is bucket-dependent
Public property | LoadFactorHWM | Defines the load factor above which the growth is triggered
Public property | LoadFactorLWM | Defines the load factor below which the shrinking is triggered
Public property | MaximumCapacity | How many elements a table may have at maximum, the property is checked at growth. Zero = no limit
Public property | MinimumCapacity | How many elements a table may have at minimum, the property is checked at shrinking. Zero = no limit. The value is dependent on bucket count, so the actual table capacity is bucket-dependent
Public property | Name |
Public property | ShrinkFactor | Defines the factor of shrinking - how much does a table shrink when LWM is reached. The number has to be at most 0.7d
Back to Top
See Also
TableOptions Class
NFX.ApplicationModel.Pile Namespace


TableOptions Constructor

TableOptions Constructor NFX Class Library

Overload List
 | Name | Description
Public method | TableOptions(String) | Initializes a new instance of the TableOptions class
Public method | TableOptions(IConfigSectionNode, Boolean) | Initializes a new instance of the TableOptions class
Back to Top
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions Constructor (String)

TableOptions Constructor (String) NFX Class Library

Initializes a new instance of the TableOptions class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TableOptions(
    string name
)
public TableOptions(
    string name
)
Public Sub New (
    name As String
)
Public Sub New (
    name As String
)
public:
TableOptions(
    String^ name
)
public:
TableOptions(
    String^ name
)
new :
        name : string -> TableOptions
new :
        name : string -> TableOptions

Parameters

name
Type: Online System String
See Also
TableOptions Class
TableOptions Members
TableOptions Overload
NFX.ApplicationModel.Pile Namespace


TableOptions Constructor (IConfigSectionNode, Boolean)

TableOptions Constructor (IConfigSectionNode, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TableOptions class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TableOptions(
    IConfigSectionNode node,
    bool nameRequired = true
)
public TableOptions(
    IConfigSectionNode node,
    bool nameRequired = true
)
Public Sub New (
    node As IConfigSectionNode,
    Optional nameRequired As Boolean = true
)
Public Sub New (
    node As IConfigSectionNode,
    Optional nameRequired As Boolean = true
)
public:
TableOptions(
    IConfigSectionNode^ node,
    bool nameRequired = true
)
public:
TableOptions(
    IConfigSectionNode^ node,
    bool nameRequired = true
)
new :
        node : IConfigSectionNode *
        ?nameRequired : bool
(* Defaults:
        let _nameRequired = defaultArg nameRequired true
*)
-> TableOptions
new :
        node : IConfigSectionNode *
        ?nameRequired : bool
(* Defaults:
        let _nameRequired = defaultArg nameRequired true
*)
-> TableOptions

Parameters

node
Type: NFX.Environment IConfigSectionNode
nameRequired (Optional)
Type: Online System Boolean
See Also
TableOptions Class
TableOptions Members
TableOptions Overload
NFX.ApplicationModel.Pile Namespace


TableOptions Fields

TableOptions Fields NFX Class Library

The TableOptions type exposes the following members.
Fields
 | Name | Description
 | DEFAULT_MAX_AGE_SEC_DEFAULT |
 | GROWTH_FACTOR_DEFAULT |
 | GROWTH_FACTOR_MAX |
 | GROWTH_FACTOR_MIN |
 | INITIAL_CAPACITY_DEFAULT |
 | INITIAL_CAPACITY_MIN |
 | LOAD_FACTOR_HWM_DEFAULT |
 | LOAD_FACTOR_HWM_MAX |
 | LOAD_FACTOR_HWM_MIN |
 | LOAD_FACTOR_LWM_DEFAULT |
 | LOAD_FACTOR_LWM_MAX |
 | LOAD_FACTOR_LWM_MIN |
Protected field | m_Name |
 | SHRINK_FACTOR_DEFAULT |
 | SHRINK_FACTOR_MAX |
 | SHRINK_FACTOR_MIN |
Back to Top
See Also
TableOptions Class
NFX.ApplicationModel.Pile Namespace


TableOptions.DEFAULT_MAX_AGE_SEC_DEFAULT Field

TableOptions DEFAULT_MAX_AGE_SEC_DEFAULT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_MAX_AGE_SEC_DEFAULT
public const int DEFAULT_MAX_AGE_SEC_DEFAULT
Public Const DEFAULT_MAX_AGE_SEC_DEFAULT As Integer
Public Const DEFAULT_MAX_AGE_SEC_DEFAULT As Integer
public:
literal int DEFAULT_MAX_AGE_SEC_DEFAULT
public:
literal int DEFAULT_MAX_AGE_SEC_DEFAULT
static val mutable DEFAULT_MAX_AGE_SEC_DEFAULT: int
static val mutable DEFAULT_MAX_AGE_SEC_DEFAULT: int

Field Value

Type: Online Int32
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions.GROWTH_FACTOR_DEFAULT Field

TableOptions GROWTH_FACTOR_DEFAULT Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double GROWTH_FACTOR_DEFAULT
public const double GROWTH_FACTOR_DEFAULT
Public Const GROWTH_FACTOR_DEFAULT As Double
Public Const GROWTH_FACTOR_DEFAULT As Double
public:
literal double GROWTH_FACTOR_DEFAULT
public:
literal double GROWTH_FACTOR_DEFAULT
static val mutable GROWTH_FACTOR_DEFAULT: float
static val mutable GROWTH_FACTOR_DEFAULT: float

Field Value

Type: Online Double
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions.GROWTH_FACTOR_MAX Field

TableOptions GROWTH_FACTOR_MAX Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double GROWTH_FACTOR_MAX
public const double GROWTH_FACTOR_MAX
Public Const GROWTH_FACTOR_MAX As Double
Public Const GROWTH_FACTOR_MAX As Double
public:
literal double GROWTH_FACTOR_MAX
public:
literal double GROWTH_FACTOR_MAX
static val mutable GROWTH_FACTOR_MAX: float
static val mutable GROWTH_FACTOR_MAX: float

Field Value

Type: Online Double
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions.GROWTH_FACTOR_MIN Field

TableOptions GROWTH_FACTOR_MIN Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double GROWTH_FACTOR_MIN
public const double GROWTH_FACTOR_MIN
Public Const GROWTH_FACTOR_MIN As Double
Public Const GROWTH_FACTOR_MIN As Double
public:
literal double GROWTH_FACTOR_MIN
public:
literal double GROWTH_FACTOR_MIN
static val mutable GROWTH_FACTOR_MIN: float
static val mutable GROWTH_FACTOR_MIN: float

Field Value

Type: Online Double
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions.INITIAL_CAPACITY_DEFAULT Field

TableOptions INITIAL_CAPACITY_DEFAULT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const long INITIAL_CAPACITY_DEFAULT
public const long INITIAL_CAPACITY_DEFAULT
Public Const INITIAL_CAPACITY_DEFAULT As Long
Public Const INITIAL_CAPACITY_DEFAULT As Long
public:
literal long long INITIAL_CAPACITY_DEFAULT
public:
literal long long INITIAL_CAPACITY_DEFAULT
static val mutable INITIAL_CAPACITY_DEFAULT: int64
static val mutable INITIAL_CAPACITY_DEFAULT: int64

Field Value

Type: Online Int64
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions.INITIAL_CAPACITY_MIN Field

TableOptions INITIAL_CAPACITY_MIN Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const long INITIAL_CAPACITY_MIN
public const long INITIAL_CAPACITY_MIN
Public Const INITIAL_CAPACITY_MIN As Long
Public Const INITIAL_CAPACITY_MIN As Long
public:
literal long long INITIAL_CAPACITY_MIN
public:
literal long long INITIAL_CAPACITY_MIN
static val mutable INITIAL_CAPACITY_MIN: int64
static val mutable INITIAL_CAPACITY_MIN: int64

Field Value

Type: Online Int64
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions.LOAD_FACTOR_HWM_DEFAULT Field

TableOptions LOAD_FACTOR_HWM_DEFAULT Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double LOAD_FACTOR_HWM_DEFAULT
public const double LOAD_FACTOR_HWM_DEFAULT
Public Const LOAD_FACTOR_HWM_DEFAULT As Double
Public Const LOAD_FACTOR_HWM_DEFAULT As Double
public:
literal double LOAD_FACTOR_HWM_DEFAULT
public:
literal double LOAD_FACTOR_HWM_DEFAULT
static val mutable LOAD_FACTOR_HWM_DEFAULT: float
static val mutable LOAD_FACTOR_HWM_DEFAULT: float

Field Value

Type: Online Double
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions.LOAD_FACTOR_HWM_MAX Field

TableOptions LOAD_FACTOR_HWM_MAX Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double LOAD_FACTOR_HWM_MAX
public const double LOAD_FACTOR_HWM_MAX
Public Const LOAD_FACTOR_HWM_MAX As Double
Public Const LOAD_FACTOR_HWM_MAX As Double
public:
literal double LOAD_FACTOR_HWM_MAX
public:
literal double LOAD_FACTOR_HWM_MAX
static val mutable LOAD_FACTOR_HWM_MAX: float
static val mutable LOAD_FACTOR_HWM_MAX: float

Field Value

Type: Online Double
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions.LOAD_FACTOR_HWM_MIN Field

TableOptions LOAD_FACTOR_HWM_MIN Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double LOAD_FACTOR_HWM_MIN
public const double LOAD_FACTOR_HWM_MIN
Public Const LOAD_FACTOR_HWM_MIN As Double
Public Const LOAD_FACTOR_HWM_MIN As Double
public:
literal double LOAD_FACTOR_HWM_MIN
public:
literal double LOAD_FACTOR_HWM_MIN
static val mutable LOAD_FACTOR_HWM_MIN: float
static val mutable LOAD_FACTOR_HWM_MIN: float

Field Value

Type: Online Double
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions.LOAD_FACTOR_LWM_DEFAULT Field

TableOptions LOAD_FACTOR_LWM_DEFAULT Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double LOAD_FACTOR_LWM_DEFAULT
public const double LOAD_FACTOR_LWM_DEFAULT
Public Const LOAD_FACTOR_LWM_DEFAULT As Double
Public Const LOAD_FACTOR_LWM_DEFAULT As Double
public:
literal double LOAD_FACTOR_LWM_DEFAULT
public:
literal double LOAD_FACTOR_LWM_DEFAULT
static val mutable LOAD_FACTOR_LWM_DEFAULT: float
static val mutable LOAD_FACTOR_LWM_DEFAULT: float

Field Value

Type: Online Double
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions.LOAD_FACTOR_LWM_MAX Field

TableOptions LOAD_FACTOR_LWM_MAX Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double LOAD_FACTOR_LWM_MAX
public const double LOAD_FACTOR_LWM_MAX
Public Const LOAD_FACTOR_LWM_MAX As Double
Public Const LOAD_FACTOR_LWM_MAX As Double
public:
literal double LOAD_FACTOR_LWM_MAX
public:
literal double LOAD_FACTOR_LWM_MAX
static val mutable LOAD_FACTOR_LWM_MAX: float
static val mutable LOAD_FACTOR_LWM_MAX: float

Field Value

Type: Online Double
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions.LOAD_FACTOR_LWM_MIN Field

TableOptions LOAD_FACTOR_LWM_MIN Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double LOAD_FACTOR_LWM_MIN
public const double LOAD_FACTOR_LWM_MIN
Public Const LOAD_FACTOR_LWM_MIN As Double
Public Const LOAD_FACTOR_LWM_MIN As Double
public:
literal double LOAD_FACTOR_LWM_MIN
public:
literal double LOAD_FACTOR_LWM_MIN
static val mutable LOAD_FACTOR_LWM_MIN: float
static val mutable LOAD_FACTOR_LWM_MIN: float

Field Value

Type: Online Double
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions.m_Name Field

TableOptions m_Name Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$name")]
internal string m_Name
[ConfigAttribute("$name")]
internal string m_Name
<ConfigAttribute("$name")>
Friend m_Name As String
<ConfigAttribute("$name")>
Friend m_Name As String
internal:
[ConfigAttribute(L"$name")]
String^ m_Name
internal:
[ConfigAttribute(L"$name")]
String^ m_Name
[<ConfigAttribute("$name")>]
val mutable internal m_Name: string
[<ConfigAttribute("$name")>]
val mutable internal m_Name: string

Field Value

Type: Online String
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions.SHRINK_FACTOR_DEFAULT Field

TableOptions SHRINK_FACTOR_DEFAULT Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double SHRINK_FACTOR_DEFAULT
public const double SHRINK_FACTOR_DEFAULT
Public Const SHRINK_FACTOR_DEFAULT As Double
Public Const SHRINK_FACTOR_DEFAULT As Double
public:
literal double SHRINK_FACTOR_DEFAULT
public:
literal double SHRINK_FACTOR_DEFAULT
static val mutable SHRINK_FACTOR_DEFAULT: float
static val mutable SHRINK_FACTOR_DEFAULT: float

Field Value

Type: Online Double
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions.SHRINK_FACTOR_MAX Field

TableOptions SHRINK_FACTOR_MAX Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double SHRINK_FACTOR_MAX
public const double SHRINK_FACTOR_MAX
Public Const SHRINK_FACTOR_MAX As Double
Public Const SHRINK_FACTOR_MAX As Double
public:
literal double SHRINK_FACTOR_MAX
public:
literal double SHRINK_FACTOR_MAX
static val mutable SHRINK_FACTOR_MAX: float
static val mutable SHRINK_FACTOR_MAX: float

Field Value

Type: Online Double
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions.SHRINK_FACTOR_MIN Field

TableOptions SHRINK_FACTOR_MIN Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double SHRINK_FACTOR_MIN
public const double SHRINK_FACTOR_MIN
Public Const SHRINK_FACTOR_MIN As Double
Public Const SHRINK_FACTOR_MIN As Double
public:
literal double SHRINK_FACTOR_MIN
public:
literal double SHRINK_FACTOR_MIN
static val mutable SHRINK_FACTOR_MIN: float
static val mutable SHRINK_FACTOR_MIN: float

Field Value

Type: Online Double
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions Methods

TableOptions Methods NFX Class Library

The TableOptions type exposes the following members.
Methods
 | Name | Description
Public method | Clone | Makes an identical copy of this instance
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TableOptions Class
NFX.ApplicationModel.Pile Namespace


TableOptions.Clone Method

TableOptions Clone Method NFX Class Library

Makes an identical copy of this instance

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TableOptions Clone()
public TableOptions Clone()
Public Function Clone As TableOptions
Public Function Clone As TableOptions
public:
TableOptions^ Clone()
public:
TableOptions^ Clone()
member Clone : unit -> TableOptions
member Clone : unit -> TableOptions

Return Value

Type: TableOptions
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions Properties

TableOptions Properties NFX Class Library

The TableOptions type exposes the following members.
Properties
 | Name | Description
Public property | AsExternalParameter | Allows to get/set options as external parameters
Public property | DefaultMaxAgeSec | Specifies default max age length which is applied to cache items if Put() does not specify particular max age
Public property | DetailedInstrumentation | True to include instrumentation details per table
Public property | GrowthFactor | Defines the factor of growth - how much does a table grow when HWM is reached. The number has to be at least 1.2d
Public property | InitialCapacity | How many elements an empty table should contain. The value is dependent on bucket count, so the actual table capacity is bucket-dependent
Public property | LoadFactorHWM | Defines the load factor above which the growth is triggered
Public property | LoadFactorLWM | Defines the load factor below which the shrinking is triggered
Public property | MaximumCapacity | How many elements a table may have at maximum, the property is checked at growth. Zero = no limit
Public property | MinimumCapacity | How many elements a table may have at minimum, the property is checked at shrinking. Zero = no limit. The value is dependent on bucket count, so the actual table capacity is bucket-dependent
Public property | Name |
Public property | ShrinkFactor | Defines the factor of shrinking - how much does a table shrink when LWM is reached. The number has to be at most 0.7d
Back to Top
See Also
TableOptions Class
NFX.ApplicationModel.Pile Namespace


TableOptions.AsExternalParameter Property

TableOptions AsExternalParameter Property NFX Class Library

Allows to get/set options as external parameters

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object AsExternalParameter { get; set; }
public Object AsExternalParameter { get; set; }
Public Property AsExternalParameter As Object
    Get
    Set
Public Property AsExternalParameter As Object
    Get
    Set
public:
property Object^ AsExternalParameter {
    Object^ get ();
    void set (Object^ value);
}
public:
property Object^ AsExternalParameter {
    Object^ get ();
    void set (Object^ value);
}
member AsExternalParameter : Object with get, set
member AsExternalParameter : Object with get, set

Property Value

Type: Online Object
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions.DefaultMaxAgeSec Property

TableOptions DefaultMaxAgeSec Property NFX Class Library

Specifies default max age length which is applied to cache items if Put() does not specify particular max age

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int DefaultMaxAgeSec { get; set; }
[ConfigAttribute]
public int DefaultMaxAgeSec { get; set; }
<ConfigAttribute>
Public Property DefaultMaxAgeSec As Integer
    Get
    Set
<ConfigAttribute>
Public Property DefaultMaxAgeSec As Integer
    Get
    Set
public:
[ConfigAttribute]
property int DefaultMaxAgeSec {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute]
property int DefaultMaxAgeSec {
    int get ();
    void set (int value);
}
[<ConfigAttribute>]
member DefaultMaxAgeSec : int with get, set
[<ConfigAttribute>]
member DefaultMaxAgeSec : int with get, set

Property Value

Type: Online Int32
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions.DetailedInstrumentation Property

TableOptions DetailedInstrumentation Property NFX Class Library

[This is preliminary documentation and is subject to change.]

True to include instrumentation details per table

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool DetailedInstrumentation { get; set; }
[ConfigAttribute]
public bool DetailedInstrumentation { get; set; }
<ConfigAttribute>
Public Property DetailedInstrumentation As Boolean
    Get
    Set
<ConfigAttribute>
Public Property DetailedInstrumentation As Boolean
    Get
    Set
public:
[ConfigAttribute]
property bool DetailedInstrumentation {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute]
property bool DetailedInstrumentation {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute>]
member DetailedInstrumentation : bool with get, set
[<ConfigAttribute>]
member DetailedInstrumentation : bool with get, set

Property Value

Type: Online Boolean
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions.GrowthFactor Property

TableOptions GrowthFactor Property NFX Class Library

Defines the factor of growth - how much does a table grow when HWM is reached. The number has to be at least 1.2d

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public double GrowthFactor { get; set; }
[ConfigAttribute]
public double GrowthFactor { get; set; }
<ConfigAttribute>
Public Property GrowthFactor As Double
    Get
    Set
<ConfigAttribute>
Public Property GrowthFactor As Double
    Get
    Set
public:
[ConfigAttribute]
property double GrowthFactor {
    double get ();
    void set (double value);
}
public:
[ConfigAttribute]
property double GrowthFactor {
    double get ();
    void set (double value);
}
[<ConfigAttribute>]
member GrowthFactor : float with get, set
[<ConfigAttribute>]
member GrowthFactor : float with get, set

Property Value

Type: Online Double
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions.InitialCapacity Property

TableOptions InitialCapacity Property NFX Class Library

How many elements an empty table should contain. The value is dependent on bucket count, so the actual table capacity is bucket-dependent

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public long InitialCapacity { get; set; }
[ConfigAttribute]
public long InitialCapacity { get; set; }
<ConfigAttribute>
Public Property InitialCapacity As Long
    Get
    Set
<ConfigAttribute>
Public Property InitialCapacity As Long
    Get
    Set
public:
[ConfigAttribute]
property long long InitialCapacity {
    long long get ();
    void set (long long value);
}
public:
[ConfigAttribute]
property long long InitialCapacity {
    long long get ();
    void set (long long value);
}
[<ConfigAttribute>]
member InitialCapacity : int64 with get, set
[<ConfigAttribute>]
member InitialCapacity : int64 with get, set

Property Value

Type: Online Int64
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions.LoadFactorHWM Property

TableOptions LoadFactorHWM Property NFX Class Library

Defines the load factor above which the growth is triggered

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public double LoadFactorHWM { get; set; }
[ConfigAttribute]
public double LoadFactorHWM { get; set; }
<ConfigAttribute>
Public Property LoadFactorHWM As Double
    Get
    Set
<ConfigAttribute>
Public Property LoadFactorHWM As Double
    Get
    Set
public:
[ConfigAttribute]
property double LoadFactorHWM {
    double get ();
    void set (double value);
}
public:
[ConfigAttribute]
property double LoadFactorHWM {
    double get ();
    void set (double value);
}
[<ConfigAttribute>]
member LoadFactorHWM : float with get, set
[<ConfigAttribute>]
member LoadFactorHWM : float with get, set

Property Value

Type: Online Double
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions.LoadFactorLWM Property

TableOptions LoadFactorLWM Property NFX Class Library

Defines the load factor below which the shrinking is triggered

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public double LoadFactorLWM { get; set; }
[ConfigAttribute]
public double LoadFactorLWM { get; set; }
<ConfigAttribute>
Public Property LoadFactorLWM As Double
    Get
    Set
<ConfigAttribute>
Public Property LoadFactorLWM As Double
    Get
    Set
public:
[ConfigAttribute]
property double LoadFactorLWM {
    double get ();
    void set (double value);
}
public:
[ConfigAttribute]
property double LoadFactorLWM {
    double get ();
    void set (double value);
}
[<ConfigAttribute>]
member LoadFactorLWM : float with get, set
[<ConfigAttribute>]
member LoadFactorLWM : float with get, set

Property Value

Type: Online Double
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions.MaximumCapacity Property

TableOptions MaximumCapacity Property NFX Class Library

How many elements a table may have at maximum, the property is checked at growth. Zero = no limit

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public long MaximumCapacity { get; set; }
[ConfigAttribute]
public long MaximumCapacity { get; set; }
<ConfigAttribute>
Public Property MaximumCapacity As Long
    Get
    Set
<ConfigAttribute>
Public Property MaximumCapacity As Long
    Get
    Set
public:
[ConfigAttribute]
property long long MaximumCapacity {
    long long get ();
    void set (long long value);
}
public:
[ConfigAttribute]
property long long MaximumCapacity {
    long long get ();
    void set (long long value);
}
[<ConfigAttribute>]
member MaximumCapacity : int64 with get, set
[<ConfigAttribute>]
member MaximumCapacity : int64 with get, set

Property Value

Type: Online Int64
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions.MinimumCapacity Property

TableOptions MinimumCapacity Property NFX Class Library

How many elements a table may have at minimum, the property is checked at shrinking. Zero = no limit. The value is dependent on bucket count, so the actual table capacity is bucket-dependent

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public long MinimumCapacity { get; set; }
[ConfigAttribute]
public long MinimumCapacity { get; set; }
<ConfigAttribute>
Public Property MinimumCapacity As Long
    Get
    Set
<ConfigAttribute>
Public Property MinimumCapacity As Long
    Get
    Set
public:
[ConfigAttribute]
property long long MinimumCapacity {
    long long get ();
    void set (long long value);
}
public:
[ConfigAttribute]
property long long MinimumCapacity {
    long long get ();
    void set (long long value);
}
[<ConfigAttribute>]
member MinimumCapacity : int64 with get, set
[<ConfigAttribute>]
member MinimumCapacity : int64 with get, set

Property Value

Type: Online Int64
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions.Name Property

TableOptions Name Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TableOptions.ShrinkFactor Property

TableOptions ShrinkFactor Property NFX Class Library

Defines the factor of shrinking - how much does a table shrink when LWM is reached. The number has to be at most 0.7d

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public double ShrinkFactor { get; set; }
[ConfigAttribute]
public double ShrinkFactor { get; set; }
<ConfigAttribute>
Public Property ShrinkFactor As Double
    Get
    Set
<ConfigAttribute>
Public Property ShrinkFactor As Double
    Get
    Set
public:
[ConfigAttribute]
property double ShrinkFactor {
    double get ();
    void set (double value);
}
public:
[ConfigAttribute]
property double ShrinkFactor {
    double get ();
    void set (double value);
}
[<ConfigAttribute>]
member ShrinkFactor : float with get, set
[<ConfigAttribute>]
member ShrinkFactor : float with get, set

Property Value

Type: Online Double
See Also
TableOptions Class
TableOptions Members
NFX.ApplicationModel.Pile Namespace


TwoGDIDWithISOKey Structure

TwoGDIDWithISOKey Structure NFX Class Library

Represents a value-type 2 GDIDs+3 char ISO code tuple, suitable for serving as a cache table key. The point of this structure is to avoid creation of references for Pile cache so keys alone do not stall the GC. The ISO code is case-insensitive

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct TwoGDIDWithISOKey : IDistributedStableHashProvider,
    IEquatable<TwoGDIDWithISOKey>
public struct TwoGDIDWithISOKey : IDistributedStableHashProvider,
    IEquatable<TwoGDIDWithISOKey>
Public Structure TwoGDIDWithISOKey
    Implements IDistributedStableHashProvider, IEquatable(Of TwoGDIDWithISOKey)
Public Structure TwoGDIDWithISOKey
    Implements IDistributedStableHashProvider, IEquatable(Of TwoGDIDWithISOKey)
public value class TwoGDIDWithISOKey : IDistributedStableHashProvider,
    IEquatable<TwoGDIDWithISOKey>
public value class TwoGDIDWithISOKey : IDistributedStableHashProvider,
    IEquatable<TwoGDIDWithISOKey>
[<SealedAttribute>]
type TwoGDIDWithISOKey =
    struct
        interface IDistributedStableHashProvider
        interface IEquatable<TwoGDIDWithISOKey>
    end
[<SealedAttribute>]
type TwoGDIDWithISOKey =
    struct
        interface IDistributedStableHashProvider
        interface IEquatable<TwoGDIDWithISOKey>
    end
See Also
TwoGDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


TwoGDIDWithISOKey Members

TwoGDIDWithISOKey Members NFX Class Library

The TwoGDIDWithISOKey type exposes the following members.
Constructors
 | Name | Description
Public method | TwoGDIDWithISOKey | Initializes a new instance of the TwoGDIDWithISOKey class
Back to Top
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(TwoGDIDWithISOKey) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDistributedStableHash |
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | GDID1 |
Public field | GDID2 |
Public field | ISO |
Back to Top
Properties
 | Name | Description
Public property | ISOCode |
Back to Top
See Also
TwoGDIDWithISOKey Structure
NFX.ApplicationModel.Pile Namespace


TwoGDIDWithISOKey Constructor

TwoGDIDWithISOKey Constructor NFX Class Library

Initializes a new instance of the TwoGDIDWithISOKey class

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TwoGDIDWithISOKey(
    GDID gdid1,
    GDID gdid2,
    string iso
)
public TwoGDIDWithISOKey(
    GDID gdid1,
    GDID gdid2,
    string iso
)
Public Sub New (
    gdid1 As GDID,
    gdid2 As GDID,
    iso As String
)
Public Sub New (
    gdid1 As GDID,
    gdid2 As GDID,
    iso As String
)
public:
TwoGDIDWithISOKey(
    GDID gdid1,
    GDID gdid2,
    String^ iso
)
public:
TwoGDIDWithISOKey(
    GDID gdid1,
    GDID gdid2,
    String^ iso
)
new :
        gdid1 : GDID *
        gdid2 : GDID *
        iso : string -> TwoGDIDWithISOKey
new :
        gdid1 : GDID *
        gdid2 : GDID *
        iso : string -> TwoGDIDWithISOKey

Parameters

gdid1
Type: NFX.DataAccess.Distributed GDID
gdid2
Type: NFX.DataAccess.Distributed GDID
iso
Type: Online System String
See Also
TwoGDIDWithISOKey Structure
TwoGDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


TwoGDIDWithISOKey Fields

TwoGDIDWithISOKey Fields NFX Class Library

The TwoGDIDWithISOKey type exposes the following members.
Fields
 | Name | Description
Public field | GDID1 |
Public field | GDID2 |
Public field | ISO |
Back to Top
See Also
TwoGDIDWithISOKey Structure
NFX.ApplicationModel.Pile Namespace


TwoGDIDWithISOKey.GDID1 Field

TwoGDIDWithISOKey GDID1 Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly GDID GDID1
public readonly GDID GDID1
Public ReadOnly GDID1 As GDID
Public ReadOnly GDID1 As GDID
public:
initonly GDID GDID1
public:
initonly GDID GDID1
val GDID1: GDID
val GDID1: GDID

Field Value

Type: GDID
See Also
TwoGDIDWithISOKey Structure
TwoGDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


TwoGDIDWithISOKey.GDID2 Field

TwoGDIDWithISOKey GDID2 Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly GDID GDID2
public readonly GDID GDID2
Public ReadOnly GDID2 As GDID
Public ReadOnly GDID2 As GDID
public:
initonly GDID GDID2
public:
initonly GDID GDID2
val GDID2: GDID
val GDID2: GDID

Field Value

Type: GDID
See Also
TwoGDIDWithISOKey Structure
TwoGDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


TwoGDIDWithISOKey.ISO Field

TwoGDIDWithISOKey ISO Field NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int ISO
public readonly int ISO
Public ReadOnly ISO As Integer
Public ReadOnly ISO As Integer
public:
initonly int ISO
public:
initonly int ISO
val ISO: int
val ISO: int

Field Value

Type: Online Int32
See Also
TwoGDIDWithISOKey Structure
TwoGDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


TwoGDIDWithISOKey Methods

TwoGDIDWithISOKey Methods NFX Class Library

The TwoGDIDWithISOKey type exposes the following members.
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(TwoGDIDWithISOKey) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDistributedStableHash |
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TwoGDIDWithISOKey Structure
NFX.ApplicationModel.Pile Namespace


TwoGDIDWithISOKey.Equals Method

TwoGDIDWithISOKey Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(TwoGDIDWithISOKey) |
Back to Top
See Also
TwoGDIDWithISOKey Structure
TwoGDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


TwoGDIDWithISOKey.Equals Method (Object)

TwoGDIDWithISOKey Equals Method (Object) NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
TwoGDIDWithISOKey Structure
TwoGDIDWithISOKey Members
Equals Overload
NFX.ApplicationModel.Pile Namespace


TwoGDIDWithISOKey.Equals Method (TwoGDIDWithISOKey)

TwoGDIDWithISOKey Equals Method (TwoGDIDWithISOKey) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    TwoGDIDWithISOKey other
)
public bool Equals(
    TwoGDIDWithISOKey other
)
Public Function Equals (
    other As TwoGDIDWithISOKey
) As Boolean
Public Function Equals (
    other As TwoGDIDWithISOKey
) As Boolean
public:
virtual bool Equals(
    TwoGDIDWithISOKey other
) sealed
public:
virtual bool Equals(
    TwoGDIDWithISOKey other
) sealed
abstract Equals :
        other : TwoGDIDWithISOKey -> bool
override Equals :
        other : TwoGDIDWithISOKey -> bool
abstract Equals :
        other : TwoGDIDWithISOKey -> bool
override Equals :
        other : TwoGDIDWithISOKey -> bool

Parameters

other
Type: NFX.ApplicationModel.Pile TwoGDIDWithISOKey

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
TwoGDIDWithISOKey Structure
TwoGDIDWithISOKey Members
Equals Overload
NFX.ApplicationModel.Pile Namespace


TwoGDIDWithISOKey.GetDistributedStableHash Method

TwoGDIDWithISOKey GetDistributedStableHash Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong GetDistributedStableHash()
public ulong GetDistributedStableHash()
Public Function GetDistributedStableHash As ULong
Public Function GetDistributedStableHash As ULong
public:
virtual unsigned long long GetDistributedStableHash() sealed
public:
virtual unsigned long long GetDistributedStableHash() sealed
abstract GetDistributedStableHash : unit -> uint64
override GetDistributedStableHash : unit -> uint64
abstract GetDistributedStableHash : unit -> uint64
override GetDistributedStableHash : unit -> uint64

Return Value

Type: Online UInt64

Implements

IDistributedStableHashProvider GetDistributedStableHash
See Also
TwoGDIDWithISOKey Structure
TwoGDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


TwoGDIDWithISOKey.GetHashCode Method

TwoGDIDWithISOKey GetHashCode Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
TwoGDIDWithISOKey Structure
TwoGDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


TwoGDIDWithISOKey.ToString Method

TwoGDIDWithISOKey ToString Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
TwoGDIDWithISOKey Structure
TwoGDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


TwoGDIDWithISOKey Properties

TwoGDIDWithISOKey Properties NFX Class Library

The TwoGDIDWithISOKey type exposes the following members.
Properties
 | Name | Description
Public property | ISOCode |
Back to Top
See Also
TwoGDIDWithISOKey Structure
NFX.ApplicationModel.Pile Namespace


TwoGDIDWithISOKey.ISOCode Property

TwoGDIDWithISOKey ISOCode Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ISOCode { get; }
public string ISOCode { get; }
Public ReadOnly Property ISOCode As String
    Get
Public ReadOnly Property ISOCode As String
    Get
public:
property String^ ISOCode {
    String^ get ();
}
public:
property String^ ISOCode {
    String^ get ();
}
member ISOCode : string with get
member ISOCode : string with get

Property Value

Type: Online String
See Also
TwoGDIDWithISOKey Structure
TwoGDIDWithISOKey Members
NFX.ApplicationModel.Pile Namespace


NFX.ApplicationModel.Pile.Instrumentation Namespace

NFX.ApplicationModel.Pile.Instrumentation Namespace NFX Class Library

[This is preliminary documentation and is subject to change.]

Classes
 | Class | Description
Public class | AllocatedMemoryBytes | Number of bytes allocated by the instance from system memory
Public class | AverageObjectSizeBytes | Number of bytes for average object
Public class | CacheCapacity | Provides entry/slot count in the cache instance
Public class | CacheCount | Provides object count in the cache instance
Public class | CacheDoubleGauge | Provides base for cache double gauges
Public class | CacheEvent | Provides base for cache events
Public class | CacheGetHit | How many times cached object was found and gotten by its key
Public class | CacheGetMiss | How many times cached object was tried to be gotten but not found by its key
Public class | CacheGrew | How many times cache has to increase its capacity
Public class | CacheLoadFactor | Provides load factor percentage
Public class | CacheLongGauge | Provides base for cache long gauges
Public class | CachePut | How many times put resulted in new object insertion in cache with or without overwriting the existing item
Public class | CachePutCollision | How many times put could not insert new object in cache because there was no room and existing data could not be overwritten due to higher priority
Public class | CachePutOverwrite | How many times put inserted new object in cache by overwriting existing value with lower priority
Public class | CachePutReplace | How many times put replaced existing object in cache
Public class | CacheRejuvenateHit | How many times key entry was found and its age reset to zero
Public class | CacheRejuvenateMiss | How many times key entry was not found for resetting its age
Public class | CacheRemoveHit | How many times key was found and object removed
Public class | CacheRemoveMiss | How many times key was not found and object not removed
Public class | CacheShrunk | How many times cache has to decrease its capacity
Public class | CacheSweep | How many entries/objects were removed by sweep
Public class | CacheSweepDuration | How long the sweeping took (examination + removal of expired)
Public class | CacheTableCount | Provides table count in the cache instance
Public class | CacheTableSwept | Cache table was swept
Public class | DeleteCount | Count of Delete() calls
Public class | FreeListCapacity | Number of free clots(chunks) in the free list
Public class | GetCount | Count of Get() calls
Public class | MemoryCapacityBytes | Average capacity of free memory that the system has left
Public class | ObjectCount | Provides object count in the instance
Public class | OverheadBytes | Number of extra bytes used by pile metadata currently occupied by object stored in this pile
Public class | PileDoubleGauge | Provides base for pile double gauges
Public class | PileLongGauge | Provides base for pile long gauges
Public class | PutCount | Count of Put() calls
Public class | SegmentCount | Provides segment count in the instance
Public class | UtilizedBytes | Number of bytes allocated for object storage within AllocatedMemoryBytes


AllocatedMemoryBytes Class

AllocatedMemoryBytes Class NFX Class Library

Number of bytes allocated by the instance from system memory
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation AllocatedMemoryBytes

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class AllocatedMemoryBytes : PileLongGauge
[SerializableAttribute]
public class AllocatedMemoryBytes : PileLongGauge
<SerializableAttribute>
Public Class AllocatedMemoryBytes
    Inherits PileLongGauge
<SerializableAttribute>
Public Class AllocatedMemoryBytes
    Inherits PileLongGauge
[SerializableAttribute]
public ref class AllocatedMemoryBytes : public PileLongGauge
[SerializableAttribute]
public ref class AllocatedMemoryBytes : public PileLongGauge
[<SerializableAttribute>]
type AllocatedMemoryBytes =
    class
        inherit PileLongGauge
    end
[<SerializableAttribute>]
type AllocatedMemoryBytes =
    class
        inherit PileLongGauge
    end
See Also
AllocatedMemoryBytes Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


AllocatedMemoryBytes Members

AllocatedMemoryBytes Members NFX Class Library

The AllocatedMemoryBytes type exposes the following members.
Constructors
 | Name | Description
Protected method | AllocatedMemoryBytes | Initializes a new instance of the AllocatedMemoryBytes class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
AllocatedMemoryBytes Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


AllocatedMemoryBytes Constructor

AllocatedMemoryBytes Constructor NFX Class Library

Initializes a new instance of the AllocatedMemoryBytes class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal AllocatedMemoryBytes(
    string src,
    long value
)
internal AllocatedMemoryBytes(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
AllocatedMemoryBytes(
    String^ src,
    long long value
)
internal:
AllocatedMemoryBytes(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> AllocatedMemoryBytes
new :
        src : string *
        value : int64 -> AllocatedMemoryBytes

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
AllocatedMemoryBytes Class
AllocatedMemoryBytes Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


AllocatedMemoryBytes Fields

AllocatedMemoryBytes Fields NFX Class Library

The AllocatedMemoryBytes type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
AllocatedMemoryBytes Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


AllocatedMemoryBytes Methods

AllocatedMemoryBytes Methods NFX Class Library

The AllocatedMemoryBytes type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
AllocatedMemoryBytes Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


AllocatedMemoryBytes.MakeAggregateInstance Method

AllocatedMemoryBytes MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
AllocatedMemoryBytes Class
AllocatedMemoryBytes Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


AllocatedMemoryBytes Properties

AllocatedMemoryBytes Properties NFX Class Library

The AllocatedMemoryBytes type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
AllocatedMemoryBytes Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


AllocatedMemoryBytes.Description Property

AllocatedMemoryBytes Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
AllocatedMemoryBytes Class
AllocatedMemoryBytes Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


AllocatedMemoryBytes.ValueUnitName Property

AllocatedMemoryBytes ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
AllocatedMemoryBytes Class
AllocatedMemoryBytes Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


AverageObjectSizeBytes Class

AverageObjectSizeBytes Class NFX Class Library

Number of bytes for average object
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation AverageObjectSizeBytes

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class AverageObjectSizeBytes : PileLongGauge
[SerializableAttribute]
public class AverageObjectSizeBytes : PileLongGauge
<SerializableAttribute>
Public Class AverageObjectSizeBytes
    Inherits PileLongGauge
<SerializableAttribute>
Public Class AverageObjectSizeBytes
    Inherits PileLongGauge
[SerializableAttribute]
public ref class AverageObjectSizeBytes : public PileLongGauge
[SerializableAttribute]
public ref class AverageObjectSizeBytes : public PileLongGauge
[<SerializableAttribute>]
type AverageObjectSizeBytes =
    class
        inherit PileLongGauge
    end
[<SerializableAttribute>]
type AverageObjectSizeBytes =
    class
        inherit PileLongGauge
    end
See Also
AverageObjectSizeBytes Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


AverageObjectSizeBytes Members

AverageObjectSizeBytes Members NFX Class Library

The AverageObjectSizeBytes type exposes the following members.
Constructors
 | Name | Description
Protected method | AverageObjectSizeBytes | Initializes a new instance of the AverageObjectSizeBytes class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
AverageObjectSizeBytes Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


AverageObjectSizeBytes Constructor

AverageObjectSizeBytes Constructor NFX Class Library

Initializes a new instance of the AverageObjectSizeBytes class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal AverageObjectSizeBytes(
    string src,
    long value
)
internal AverageObjectSizeBytes(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
AverageObjectSizeBytes(
    String^ src,
    long long value
)
internal:
AverageObjectSizeBytes(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> AverageObjectSizeBytes
new :
        src : string *
        value : int64 -> AverageObjectSizeBytes

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
AverageObjectSizeBytes Class
AverageObjectSizeBytes Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


AverageObjectSizeBytes Fields

AverageObjectSizeBytes Fields NFX Class Library

The AverageObjectSizeBytes type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
AverageObjectSizeBytes Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


AverageObjectSizeBytes Methods

AverageObjectSizeBytes Methods NFX Class Library

The AverageObjectSizeBytes type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
AverageObjectSizeBytes Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


AverageObjectSizeBytes.MakeAggregateInstance Method

AverageObjectSizeBytes MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
AverageObjectSizeBytes Class
AverageObjectSizeBytes Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


AverageObjectSizeBytes Properties

AverageObjectSizeBytes Properties NFX Class Library

The AverageObjectSizeBytes type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
AverageObjectSizeBytes Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


AverageObjectSizeBytes.Description Property

AverageObjectSizeBytes Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
AverageObjectSizeBytes Class
AverageObjectSizeBytes Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


AverageObjectSizeBytes.ValueUnitName Property

AverageObjectSizeBytes ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
AverageObjectSizeBytes Class
AverageObjectSizeBytes Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheCapacity Class

CacheCapacity Class NFX Class Library

Provides entry/slot count in the cache instance
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheCapacity

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CacheCapacity : CacheLongGauge
[SerializableAttribute]
public class CacheCapacity : CacheLongGauge
<SerializableAttribute>
Public Class CacheCapacity
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class CacheCapacity
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class CacheCapacity : public CacheLongGauge
[SerializableAttribute]
public ref class CacheCapacity : public CacheLongGauge
[<SerializableAttribute>]
type CacheCapacity =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type CacheCapacity =
    class
        inherit CacheLongGauge
    end
See Also
CacheCapacity Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheCapacity Members

CacheCapacity Members NFX Class Library

The CacheCapacity type exposes the following members.
Constructors
 | Name | Description
Protected method | CacheCapacity | Initializes a new instance of the CacheCapacity class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheCapacity Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheCapacity Constructor

CacheCapacity Constructor NFX Class Library

Initializes a new instance of the CacheCapacity class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CacheCapacity(
    string src,
    long value
)
internal CacheCapacity(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
CacheCapacity(
    String^ src,
    long long value
)
internal:
CacheCapacity(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> CacheCapacity
new :
        src : string *
        value : int64 -> CacheCapacity

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
CacheCapacity Class
CacheCapacity Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheCapacity Fields

CacheCapacity Fields NFX Class Library

The CacheCapacity type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
CacheCapacity Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheCapacity Methods

CacheCapacity Methods NFX Class Library

The CacheCapacity type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CacheCapacity Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheCapacity.MakeAggregateInstance Method

CacheCapacity MakeAggregateInstance Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
CacheCapacity Class
CacheCapacity Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheCapacity Properties

CacheCapacity Properties NFX Class Library

The CacheCapacity type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheCapacity Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheCapacity.Description Property

CacheCapacity Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
CacheCapacity Class
CacheCapacity Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheCapacity.ValueUnitName Property

CacheCapacity ValueUnitName Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
CacheCapacity Class
CacheCapacity Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheCount Class

CacheCount Class NFX Class Library

Provides object count in the cache instance
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheCount

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CacheCount : CacheLongGauge
[SerializableAttribute]
public class CacheCount : CacheLongGauge
<SerializableAttribute>
Public Class CacheCount
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class CacheCount
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class CacheCount : public CacheLongGauge
[SerializableAttribute]
public ref class CacheCount : public CacheLongGauge
[<SerializableAttribute>]
type CacheCount =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type CacheCount =
    class
        inherit CacheLongGauge
    end
See Also
CacheCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheCount Members

CacheCount Members NFX Class Library

The CacheCount type exposes the following members.
Constructors
 | Name | Description
Protected method | CacheCount | Initializes a new instance of the CacheCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheCount Constructor

CacheCount Constructor NFX Class Library

Initializes a new instance of the CacheCount class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CacheCount(
    string src,
    long value
)
internal CacheCount(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
CacheCount(
    String^ src,
    long long value
)
internal:
CacheCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> CacheCount
new :
        src : string *
        value : int64 -> CacheCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
CacheCount Class
CacheCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheCount Fields

CacheCount Fields NFX Class Library

The CacheCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
CacheCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheCount Methods

CacheCount Methods NFX Class Library

The CacheCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CacheCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheCount.MakeAggregateInstance Method

CacheCount MakeAggregateInstance Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
CacheCount Class
CacheCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheCount Properties

CacheCount Properties NFX Class Library

The CacheCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheCount.Description Property

CacheCount Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
CacheCount Class
CacheCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheCount.ValueUnitName Property

CacheCount ValueUnitName Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
CacheCount Class
CacheCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheDoubleGauge Class

CacheDoubleGauge Class NFX Class Library

Provides base for cache double gauges
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation DoubleGauge
NFX.ApplicationModel.Pile.Instrumentation PileDoubleGauge
NFX.ApplicationModel.Pile.Instrumentation CacheDoubleGauge
NFX.ApplicationModel.Pile.Instrumentation CacheLoadFactor

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class CacheDoubleGauge : PileDoubleGauge
[SerializableAttribute]
public abstract class CacheDoubleGauge : PileDoubleGauge
<SerializableAttribute>
Public MustInherit Class CacheDoubleGauge
    Inherits PileDoubleGauge
<SerializableAttribute>
Public MustInherit Class CacheDoubleGauge
    Inherits PileDoubleGauge
[SerializableAttribute]
public ref class CacheDoubleGauge abstract : public PileDoubleGauge
[SerializableAttribute]
public ref class CacheDoubleGauge abstract : public PileDoubleGauge
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type CacheDoubleGauge =
    class
        inherit PileDoubleGauge
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type CacheDoubleGauge =
    class
        inherit PileDoubleGauge
    end
See Also
CacheDoubleGauge Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheDoubleGauge Members

CacheDoubleGauge Members NFX Class Library

The CacheDoubleGauge type exposes the following members.
Constructors
 | Name | Description
Protected method | CacheDoubleGauge | Initializes a new instance of the CacheDoubleGauge class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from DoubleGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from DoubleGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from DoubleGauge.)
Public property | ValueAsObject | (Inherited from DoubleGauge.)
Public property | ValueUnitName | (Inherited from DoubleGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheDoubleGauge Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheDoubleGauge Constructor

CacheDoubleGauge Constructor NFX Class Library

Initializes a new instance of the CacheDoubleGauge class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CacheDoubleGauge(
    string src,
    double value
)
protected CacheDoubleGauge(
    string src,
    double value
)
Protected Sub New (
    src As String,
    value As Double
)
Protected Sub New (
    src As String,
    value As Double
)
protected:
CacheDoubleGauge(
    String^ src,
    double value
)
protected:
CacheDoubleGauge(
    String^ src,
    double value
)
new :
        src : string *
        value : float -> CacheDoubleGauge
new :
        src : string *
        value : float -> CacheDoubleGauge

Parameters

src
Type: Online System String
value
Type: Online System Double
See Also
CacheDoubleGauge Class
CacheDoubleGauge Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheDoubleGauge Fields

CacheDoubleGauge Fields NFX Class Library

The CacheDoubleGauge type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
CacheDoubleGauge Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheDoubleGauge Methods

CacheDoubleGauge Methods NFX Class Library

The CacheDoubleGauge type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from DoubleGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from DoubleGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CacheDoubleGauge Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheDoubleGauge Properties

CacheDoubleGauge Properties NFX Class Library

The CacheDoubleGauge type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from DoubleGauge.)
Public property | ValueAsObject | (Inherited from DoubleGauge.)
Public property | ValueUnitName | (Inherited from DoubleGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheDoubleGauge Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheEvent Class

CacheEvent Class NFX Class Library

Provides base for cache events
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Event
NFX.ApplicationModel.Pile.Instrumentation CacheEvent
NFX.ApplicationModel.Pile.Instrumentation CacheTableSwept

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class CacheEvent : Event
[SerializableAttribute]
public abstract class CacheEvent : Event
<SerializableAttribute>
Public MustInherit Class CacheEvent
    Inherits Event
<SerializableAttribute>
Public MustInherit Class CacheEvent
    Inherits Event
[SerializableAttribute]
public ref class CacheEvent abstract : public Event
[SerializableAttribute]
public ref class CacheEvent abstract : public Event
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type CacheEvent =
    class
        inherit Event
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type CacheEvent =
    class
        inherit Event
    end
See Also
CacheEvent Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheEvent Members

CacheEvent Members NFX Class Library

The CacheEvent type exposes the following members.
Constructors
 | Name | Description
Protected method | CacheEvent | Initializes a new instance of the CacheEvent class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheEvent Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheEvent Constructor

CacheEvent Constructor NFX Class Library

Initializes a new instance of the CacheEvent class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CacheEvent(
    string src
)
protected CacheEvent(
    string src
)
Protected Sub New (
    src As String
)
Protected Sub New (
    src As String
)
protected:
CacheEvent(
    String^ src
)
protected:
CacheEvent(
    String^ src
)
new :
        src : string -> CacheEvent
new :
        src : string -> CacheEvent

Parameters

src
Type: Online System String
See Also
CacheEvent Class
CacheEvent Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheEvent Fields

CacheEvent Fields NFX Class Library

The CacheEvent type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
CacheEvent Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheEvent Methods

CacheEvent Methods NFX Class Library

The CacheEvent type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CacheEvent Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheEvent Properties

CacheEvent Properties NFX Class Library

The CacheEvent type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheEvent Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheGetHit Class

CacheGetHit Class NFX Class Library

How many times cached object was found and gotten by its key
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheGetHit

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CacheGetHit : CacheLongGauge
[SerializableAttribute]
public class CacheGetHit : CacheLongGauge
<SerializableAttribute>
Public Class CacheGetHit
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class CacheGetHit
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class CacheGetHit : public CacheLongGauge
[SerializableAttribute]
public ref class CacheGetHit : public CacheLongGauge
[<SerializableAttribute>]
type CacheGetHit =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type CacheGetHit =
    class
        inherit CacheLongGauge
    end
See Also
CacheGetHit Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheGetHit Members

CacheGetHit Members NFX Class Library

The CacheGetHit type exposes the following members.
Constructors
 | Name | Description
Protected method | CacheGetHit | Initializes a new instance of the CacheGetHit class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheGetHit Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheGetHit Constructor

CacheGetHit Constructor NFX Class Library

Initializes a new instance of the CacheGetHit class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CacheGetHit(
    string src,
    long value
)
internal CacheGetHit(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
CacheGetHit(
    String^ src,
    long long value
)
internal:
CacheGetHit(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> CacheGetHit
new :
        src : string *
        value : int64 -> CacheGetHit

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
CacheGetHit Class
CacheGetHit Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheGetHit Fields

CacheGetHit Fields NFX Class Library

The CacheGetHit type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
CacheGetHit Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheGetHit Methods

CacheGetHit Methods NFX Class Library

The CacheGetHit type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CacheGetHit Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheGetHit.MakeAggregateInstance Method

CacheGetHit MakeAggregateInstance Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
CacheGetHit Class
CacheGetHit Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheGetHit Properties

CacheGetHit Properties NFX Class Library

The CacheGetHit type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheGetHit Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheGetHit.Description Property

CacheGetHit Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
CacheGetHit Class
CacheGetHit Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheGetHit.ValueUnitName Property

CacheGetHit ValueUnitName Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
CacheGetHit Class
CacheGetHit Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheGetMiss Class

CacheGetMiss Class NFX Class Library

How many times cached object was tried to be gotten but not found by its key
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheGetMiss

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CacheGetMiss : CacheLongGauge
[SerializableAttribute]
public class CacheGetMiss : CacheLongGauge
<SerializableAttribute>
Public Class CacheGetMiss
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class CacheGetMiss
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class CacheGetMiss : public CacheLongGauge
[SerializableAttribute]
public ref class CacheGetMiss : public CacheLongGauge
[<SerializableAttribute>]
type CacheGetMiss =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type CacheGetMiss =
    class
        inherit CacheLongGauge
    end
See Also
CacheGetMiss Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheGetMiss Members

CacheGetMiss Members NFX Class Library

The CacheGetMiss type exposes the following members.
Constructors
 | Name | Description
Protected method | CacheGetMiss | Initializes a new instance of the CacheGetMiss class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheGetMiss Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheGetMiss Constructor

CacheGetMiss Constructor NFX Class Library

Initializes a new instance of the CacheGetMiss class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CacheGetMiss(
    string src,
    long value
)
internal CacheGetMiss(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
CacheGetMiss(
    String^ src,
    long long value
)
internal:
CacheGetMiss(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> CacheGetMiss
new :
        src : string *
        value : int64 -> CacheGetMiss

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
CacheGetMiss Class
CacheGetMiss Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheGetMiss Fields

CacheGetMiss Fields NFX Class Library

The CacheGetMiss type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
CacheGetMiss Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheGetMiss Methods

CacheGetMiss Methods NFX Class Library

The CacheGetMiss type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CacheGetMiss Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheGetMiss.MakeAggregateInstance Method

CacheGetMiss MakeAggregateInstance Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
CacheGetMiss Class
CacheGetMiss Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheGetMiss Properties

CacheGetMiss Properties NFX Class Library

The CacheGetMiss type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheGetMiss Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheGetMiss.Description Property

CacheGetMiss Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
CacheGetMiss Class
CacheGetMiss Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheGetMiss.ValueUnitName Property

CacheGetMiss ValueUnitName Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
CacheGetMiss Class
CacheGetMiss Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheGrew Class

CacheGrew Class NFX Class Library

How many times cache has to increase its capacity
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheGrew

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CacheGrew : CacheLongGauge
[SerializableAttribute]
public class CacheGrew : CacheLongGauge
<SerializableAttribute>
Public Class CacheGrew
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class CacheGrew
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class CacheGrew : public CacheLongGauge
[SerializableAttribute]
public ref class CacheGrew : public CacheLongGauge
[<SerializableAttribute>]
type CacheGrew =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type CacheGrew =
    class
        inherit CacheLongGauge
    end
See Also
CacheGrew Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheGrew Members

CacheGrew Members NFX Class Library

The CacheGrew type exposes the following members.
Constructors
 | Name | Description
Protected method | CacheGrew | Initializes a new instance of the CacheGrew class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheGrew Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheGrew Constructor

CacheGrew Constructor NFX Class Library

Initializes a new instance of the CacheGrew class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CacheGrew(
    string src,
    long value
)
internal CacheGrew(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
CacheGrew(
    String^ src,
    long long value
)
internal:
CacheGrew(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> CacheGrew
new :
        src : string *
        value : int64 -> CacheGrew

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
CacheGrew Class
CacheGrew Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheGrew Fields

CacheGrew Fields NFX Class Library

The CacheGrew type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
CacheGrew Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheGrew Methods

CacheGrew Methods NFX Class Library

The CacheGrew type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CacheGrew Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheGrew.MakeAggregateInstance Method

CacheGrew MakeAggregateInstance Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
CacheGrew Class
CacheGrew Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheGrew Properties

CacheGrew Properties NFX Class Library

The CacheGrew type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheGrew Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheGrew.Description Property

CacheGrew Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
CacheGrew Class
CacheGrew Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheGrew.ValueUnitName Property

CacheGrew ValueUnitName Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
CacheGrew Class
CacheGrew Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheLoadFactor Class

CacheLoadFactor Class NFX Class Library

Provides load factor percentage
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation DoubleGauge
NFX.ApplicationModel.Pile.Instrumentation PileDoubleGauge
NFX.ApplicationModel.Pile.Instrumentation CacheDoubleGauge
NFX.ApplicationModel.Pile.Instrumentation CacheLoadFactor

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CacheLoadFactor : CacheDoubleGauge
[SerializableAttribute]
public class CacheLoadFactor : CacheDoubleGauge
<SerializableAttribute>
Public Class CacheLoadFactor
    Inherits CacheDoubleGauge
<SerializableAttribute>
Public Class CacheLoadFactor
    Inherits CacheDoubleGauge
[SerializableAttribute]
public ref class CacheLoadFactor : public CacheDoubleGauge
[SerializableAttribute]
public ref class CacheLoadFactor : public CacheDoubleGauge
[<SerializableAttribute>]
type CacheLoadFactor =
    class
        inherit CacheDoubleGauge
    end
[<SerializableAttribute>]
type CacheLoadFactor =
    class
        inherit CacheDoubleGauge
    end
See Also
CacheLoadFactor Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheLoadFactor Members

CacheLoadFactor Members NFX Class Library

The CacheLoadFactor type exposes the following members.
Constructors
 | Name | Description
Protected method | CacheLoadFactor | Initializes a new instance of the CacheLoadFactor class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from DoubleGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from DoubleGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from DoubleGauge.)
Public property | ValueAsObject | (Inherited from DoubleGauge.)
Public property | ValueUnitName | (Overrides DoubleGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheLoadFactor Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheLoadFactor Constructor

CacheLoadFactor Constructor NFX Class Library

Initializes a new instance of the CacheLoadFactor class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CacheLoadFactor(
    string src,
    double value
)
internal CacheLoadFactor(
    string src,
    double value
)
Friend Sub New (
    src As String,
    value As Double
)
Friend Sub New (
    src As String,
    value As Double
)
internal:
CacheLoadFactor(
    String^ src,
    double value
)
internal:
CacheLoadFactor(
    String^ src,
    double value
)
new :
        src : string *
        value : float -> CacheLoadFactor
new :
        src : string *
        value : float -> CacheLoadFactor

Parameters

src
Type: Online System String
value
Type: Online System Double
See Also
CacheLoadFactor Class
CacheLoadFactor Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheLoadFactor Fields

CacheLoadFactor Fields NFX Class Library

The CacheLoadFactor type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
CacheLoadFactor Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheLoadFactor Methods

CacheLoadFactor Methods NFX Class Library

The CacheLoadFactor type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from DoubleGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from DoubleGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CacheLoadFactor Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheLoadFactor.MakeAggregateInstance Method

CacheLoadFactor MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
CacheLoadFactor Class
CacheLoadFactor Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheLoadFactor Properties

CacheLoadFactor Properties NFX Class Library

The CacheLoadFactor type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from DoubleGauge.)
Public property | ValueAsObject | (Inherited from DoubleGauge.)
Public property | ValueUnitName | (Overrides DoubleGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheLoadFactor Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheLoadFactor.Description Property

CacheLoadFactor Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
CacheLoadFactor Class
CacheLoadFactor Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheLoadFactor.ValueUnitName Property

CacheLoadFactor ValueUnitName Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
CacheLoadFactor Class
CacheLoadFactor Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheLongGauge Class

CacheLongGauge Class NFX Class Library

Provides base for cache long gauges
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheCapacity
NFX.ApplicationModel.Pile.Instrumentation CacheCount
NFX.ApplicationModel.Pile.Instrumentation CacheGetHit
NFX.ApplicationModel.Pile.Instrumentation CacheGetMiss
NFX.ApplicationModel.Pile.Instrumentation CacheGrew
NFX.ApplicationModel.Pile.Instrumentation CachePut
NFX.ApplicationModel.Pile.Instrumentation CachePutCollision
NFX.ApplicationModel.Pile.Instrumentation CachePutOverwrite
NFX.ApplicationModel.Pile.Instrumentation CachePutReplace
NFX.ApplicationModel.Pile.Instrumentation CacheRejuvenateHit
NFX.ApplicationModel.Pile.Instrumentation CacheRejuvenateMiss
NFX.ApplicationModel.Pile.Instrumentation CacheRemoveHit
NFX.ApplicationModel.Pile.Instrumentation CacheRemoveMiss
NFX.ApplicationModel.Pile.Instrumentation CacheShrunk
NFX.ApplicationModel.Pile.Instrumentation CacheSweep
NFX.ApplicationModel.Pile.Instrumentation CacheSweepDuration
NFX.ApplicationModel.Pile.Instrumentation CacheTableCount

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class CacheLongGauge : PileLongGauge
[SerializableAttribute]
public abstract class CacheLongGauge : PileLongGauge
<SerializableAttribute>
Public MustInherit Class CacheLongGauge
    Inherits PileLongGauge
<SerializableAttribute>
Public MustInherit Class CacheLongGauge
    Inherits PileLongGauge
[SerializableAttribute]
public ref class CacheLongGauge abstract : public PileLongGauge
[SerializableAttribute]
public ref class CacheLongGauge abstract : public PileLongGauge
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type CacheLongGauge =
    class
        inherit PileLongGauge
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type CacheLongGauge =
    class
        inherit PileLongGauge
    end
See Also
CacheLongGauge Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheLongGauge Members

CacheLongGauge Members NFX Class Library

The CacheLongGauge type exposes the following members.
Constructors
 | Name | Description
Protected method | CacheLongGauge | Initializes a new instance of the CacheLongGauge class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Inherited from LongGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheLongGauge Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheLongGauge Constructor

CacheLongGauge Constructor NFX Class Library

Initializes a new instance of the CacheLongGauge class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CacheLongGauge(
    string src,
    long value
)
protected CacheLongGauge(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
CacheLongGauge(
    String^ src,
    long long value
)
protected:
CacheLongGauge(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> CacheLongGauge
new :
        src : string *
        value : int64 -> CacheLongGauge

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
CacheLongGauge Class
CacheLongGauge Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheLongGauge Fields

CacheLongGauge Fields NFX Class Library

The CacheLongGauge type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
CacheLongGauge Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheLongGauge Methods

CacheLongGauge Methods NFX Class Library

The CacheLongGauge type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CacheLongGauge Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheLongGauge Properties

CacheLongGauge Properties NFX Class Library

The CacheLongGauge type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Inherited from LongGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheLongGauge Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePut Class

CachePut Class NFX Class Library

How many times put resulted in new object insertion in cache with or without overwriting the existing item
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheLongGauge
NFX.ApplicationModel.Pile.Instrumentation CachePut

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CachePut : CacheLongGauge
[SerializableAttribute]
public class CachePut : CacheLongGauge
<SerializableAttribute>
Public Class CachePut
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class CachePut
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class CachePut : public CacheLongGauge
[SerializableAttribute]
public ref class CachePut : public CacheLongGauge
[<SerializableAttribute>]
type CachePut =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type CachePut =
    class
        inherit CacheLongGauge
    end
See Also
CachePut Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePut Members

CachePut Members NFX Class Library

The CachePut type exposes the following members.
Constructors
 | Name | Description
Protected method | CachePut | Initializes a new instance of the CachePut class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CachePut Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePut Constructor

CachePut Constructor NFX Class Library

Initializes a new instance of the CachePut class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CachePut(
    string src,
    long value
)
internal CachePut(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
CachePut(
    String^ src,
    long long value
)
internal:
CachePut(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> CachePut
new :
        src : string *
        value : int64 -> CachePut

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
CachePut Class
CachePut Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePut Fields

CachePut Fields NFX Class Library

The CachePut type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
CachePut Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePut Methods

CachePut Methods NFX Class Library

The CachePut type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CachePut Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePut.MakeAggregateInstance Method

CachePut MakeAggregateInstance Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
CachePut Class
CachePut Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePut Properties

CachePut Properties NFX Class Library

The CachePut type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CachePut Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePut.Description Property

CachePut Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
CachePut Class
CachePut Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePut.ValueUnitName Property

CachePut ValueUnitName Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
CachePut Class
CachePut Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePutCollision Class

CachePutCollision Class NFX Class Library

How many times put could not insert new object in cache because there was no room and existing data could not be overwritten due to higher priority
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheLongGauge
NFX.ApplicationModel.Pile.Instrumentation CachePutCollision

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CachePutCollision : CacheLongGauge
[SerializableAttribute]
public class CachePutCollision : CacheLongGauge
<SerializableAttribute>
Public Class CachePutCollision
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class CachePutCollision
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class CachePutCollision : public CacheLongGauge
[SerializableAttribute]
public ref class CachePutCollision : public CacheLongGauge
[<SerializableAttribute>]
type CachePutCollision =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type CachePutCollision =
    class
        inherit CacheLongGauge
    end
See Also
CachePutCollision Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePutCollision Members

CachePutCollision Members NFX Class Library

The CachePutCollision type exposes the following members.
Constructors
 | Name | Description
Protected method | CachePutCollision | Initializes a new instance of the CachePutCollision class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CachePutCollision Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePutCollision Constructor

CachePutCollision Constructor NFX Class Library

Initializes a new instance of the CachePutCollision class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CachePutCollision(
    string src,
    long value
)
internal CachePutCollision(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
CachePutCollision(
    String^ src,
    long long value
)
internal:
CachePutCollision(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> CachePutCollision
new :
        src : string *
        value : int64 -> CachePutCollision

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
CachePutCollision Class
CachePutCollision Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePutCollision Fields

CachePutCollision Fields NFX Class Library

The CachePutCollision type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
CachePutCollision Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePutCollision Methods

CachePutCollision Methods NFX Class Library

The CachePutCollision type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CachePutCollision Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePutCollision.MakeAggregateInstance Method

CachePutCollision MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
CachePutCollision Class
CachePutCollision Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePutCollision Properties

CachePutCollision Properties NFX Class Library

The CachePutCollision type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CachePutCollision Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePutCollision.Description Property

CachePutCollision Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
CachePutCollision Class
CachePutCollision Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePutCollision.ValueUnitName Property

CachePutCollision ValueUnitName Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
CachePutCollision Class
CachePutCollision Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePutOverwrite Class

CachePutOverwrite Class NFX Class Library

How many times put inserted new object in cache by overwriting existing value with lower priority
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheLongGauge
NFX.ApplicationModel.Pile.Instrumentation CachePutOverwrite

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CachePutOverwrite : CacheLongGauge
[SerializableAttribute]
public class CachePutOverwrite : CacheLongGauge
<SerializableAttribute>
Public Class CachePutOverwrite
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class CachePutOverwrite
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class CachePutOverwrite : public CacheLongGauge
[SerializableAttribute]
public ref class CachePutOverwrite : public CacheLongGauge
[<SerializableAttribute>]
type CachePutOverwrite =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type CachePutOverwrite =
    class
        inherit CacheLongGauge
    end
See Also
CachePutOverwrite Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePutOverwrite Members

CachePutOverwrite Members NFX Class Library

The CachePutOverwrite type exposes the following members.
Constructors
 | Name | Description
Protected method | CachePutOverwrite | Initializes a new instance of the CachePutOverwrite class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CachePutOverwrite Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePutOverwrite Constructor

CachePutOverwrite Constructor NFX Class Library

Initializes a new instance of the CachePutOverwrite class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CachePutOverwrite(
    string src,
    long value
)
internal CachePutOverwrite(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
CachePutOverwrite(
    String^ src,
    long long value
)
internal:
CachePutOverwrite(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> CachePutOverwrite
new :
        src : string *
        value : int64 -> CachePutOverwrite

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
CachePutOverwrite Class
CachePutOverwrite Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePutOverwrite Fields

CachePutOverwrite Fields NFX Class Library

The CachePutOverwrite type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
CachePutOverwrite Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePutOverwrite Methods

CachePutOverwrite Methods NFX Class Library

The CachePutOverwrite type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CachePutOverwrite Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePutOverwrite.MakeAggregateInstance Method

CachePutOverwrite MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
CachePutOverwrite Class
CachePutOverwrite Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePutOverwrite Properties

CachePutOverwrite Properties NFX Class Library

The CachePutOverwrite type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CachePutOverwrite Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePutOverwrite.Description Property

CachePutOverwrite Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
CachePutOverwrite Class
CachePutOverwrite Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePutOverwrite.ValueUnitName Property

CachePutOverwrite ValueUnitName Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
CachePutOverwrite Class
CachePutOverwrite Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePutReplace Class

CachePutReplace Class NFX Class Library

How many times put replaced existing object in cache
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheLongGauge
NFX.ApplicationModel.Pile.Instrumentation CachePutReplace

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CachePutReplace : CacheLongGauge
[SerializableAttribute]
public class CachePutReplace : CacheLongGauge
<SerializableAttribute>
Public Class CachePutReplace
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class CachePutReplace
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class CachePutReplace : public CacheLongGauge
[SerializableAttribute]
public ref class CachePutReplace : public CacheLongGauge
[<SerializableAttribute>]
type CachePutReplace =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type CachePutReplace =
    class
        inherit CacheLongGauge
    end
See Also
CachePutReplace Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePutReplace Members

CachePutReplace Members NFX Class Library

The CachePutReplace type exposes the following members.
Constructors
 | Name | Description
Protected method | CachePutReplace | Initializes a new instance of the CachePutReplace class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CachePutReplace Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePutReplace Constructor

CachePutReplace Constructor NFX Class Library

Initializes a new instance of the CachePutReplace class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CachePutReplace(
    string src,
    long value
)
internal CachePutReplace(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
CachePutReplace(
    String^ src,
    long long value
)
internal:
CachePutReplace(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> CachePutReplace
new :
        src : string *
        value : int64 -> CachePutReplace

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
CachePutReplace Class
CachePutReplace Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePutReplace Fields

CachePutReplace Fields NFX Class Library

The CachePutReplace type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
CachePutReplace Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePutReplace Methods

CachePutReplace Methods NFX Class Library

The CachePutReplace type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CachePutReplace Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePutReplace.MakeAggregateInstance Method

CachePutReplace MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
CachePutReplace Class
CachePutReplace Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePutReplace Properties

CachePutReplace Properties NFX Class Library

The CachePutReplace type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CachePutReplace Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePutReplace.Description Property

CachePutReplace Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
CachePutReplace Class
CachePutReplace Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CachePutReplace.ValueUnitName Property

CachePutReplace ValueUnitName Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
CachePutReplace Class
CachePutReplace Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRejuvenateHit Class

CacheRejuvenateHit Class NFX Class Library

How many times key entry was found and its age reset to zero
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheRejuvenateHit

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CacheRejuvenateHit : CacheLongGauge
[SerializableAttribute]
public class CacheRejuvenateHit : CacheLongGauge
<SerializableAttribute>
Public Class CacheRejuvenateHit
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class CacheRejuvenateHit
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class CacheRejuvenateHit : public CacheLongGauge
[SerializableAttribute]
public ref class CacheRejuvenateHit : public CacheLongGauge
[<SerializableAttribute>]
type CacheRejuvenateHit =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type CacheRejuvenateHit =
    class
        inherit CacheLongGauge
    end
See Also
CacheRejuvenateHit Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRejuvenateHit Members

CacheRejuvenateHit Members NFX Class Library

The CacheRejuvenateHit type exposes the following members.
Constructors
 | Name | Description
Protected method | CacheRejuvenateHit | Initializes a new instance of the CacheRejuvenateHit class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheRejuvenateHit Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRejuvenateHit Constructor

CacheRejuvenateHit Constructor NFX Class Library

Initializes a new instance of the CacheRejuvenateHit class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CacheRejuvenateHit(
    string src,
    long value
)
internal CacheRejuvenateHit(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
CacheRejuvenateHit(
    String^ src,
    long long value
)
internal:
CacheRejuvenateHit(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> CacheRejuvenateHit
new :
        src : string *
        value : int64 -> CacheRejuvenateHit

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
CacheRejuvenateHit Class
CacheRejuvenateHit Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRejuvenateHit Fields

CacheRejuvenateHit Fields NFX Class Library

The CacheRejuvenateHit type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
CacheRejuvenateHit Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRejuvenateHit Methods

CacheRejuvenateHit Methods NFX Class Library

The CacheRejuvenateHit type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CacheRejuvenateHit Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRejuvenateHit.MakeAggregateInstance Method

CacheRejuvenateHit MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
CacheRejuvenateHit Class
CacheRejuvenateHit Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRejuvenateHit Properties

CacheRejuvenateHit Properties NFX Class Library

The CacheRejuvenateHit type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheRejuvenateHit Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRejuvenateHit.Description Property

CacheRejuvenateHit Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
CacheRejuvenateHit Class
CacheRejuvenateHit Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRejuvenateHit.ValueUnitName Property

CacheRejuvenateHit ValueUnitName Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
CacheRejuvenateHit Class
CacheRejuvenateHit Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRejuvenateMiss Class

CacheRejuvenateMiss Class NFX Class Library

How many times key entry was not found for resetting its age
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheRejuvenateMiss

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CacheRejuvenateMiss : CacheLongGauge
[SerializableAttribute]
public class CacheRejuvenateMiss : CacheLongGauge
<SerializableAttribute>
Public Class CacheRejuvenateMiss
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class CacheRejuvenateMiss
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class CacheRejuvenateMiss : public CacheLongGauge
[SerializableAttribute]
public ref class CacheRejuvenateMiss : public CacheLongGauge
[<SerializableAttribute>]
type CacheRejuvenateMiss =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type CacheRejuvenateMiss =
    class
        inherit CacheLongGauge
    end
See Also
CacheRejuvenateMiss Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRejuvenateMiss Members

CacheRejuvenateMiss Members NFX Class Library

The CacheRejuvenateMiss type exposes the following members.
Constructors
 | Name | Description
Protected method | CacheRejuvenateMiss | Initializes a new instance of the CacheRejuvenateMiss class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheRejuvenateMiss Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRejuvenateMiss Constructor

CacheRejuvenateMiss Constructor NFX Class Library

Initializes a new instance of the CacheRejuvenateMiss class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CacheRejuvenateMiss(
    string src,
    long value
)
internal CacheRejuvenateMiss(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
CacheRejuvenateMiss(
    String^ src,
    long long value
)
internal:
CacheRejuvenateMiss(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> CacheRejuvenateMiss
new :
        src : string *
        value : int64 -> CacheRejuvenateMiss

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
CacheRejuvenateMiss Class
CacheRejuvenateMiss Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRejuvenateMiss Fields

CacheRejuvenateMiss Fields NFX Class Library

The CacheRejuvenateMiss type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
CacheRejuvenateMiss Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRejuvenateMiss Methods

CacheRejuvenateMiss Methods NFX Class Library

The CacheRejuvenateMiss type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CacheRejuvenateMiss Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRejuvenateMiss.MakeAggregateInstance Method

CacheRejuvenateMiss MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
CacheRejuvenateMiss Class
CacheRejuvenateMiss Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRejuvenateMiss Properties

CacheRejuvenateMiss Properties NFX Class Library

The CacheRejuvenateMiss type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheRejuvenateMiss Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRejuvenateMiss.Description Property

CacheRejuvenateMiss Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
CacheRejuvenateMiss Class
CacheRejuvenateMiss Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRejuvenateMiss.ValueUnitName Property

CacheRejuvenateMiss ValueUnitName Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
CacheRejuvenateMiss Class
CacheRejuvenateMiss Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRemoveHit Class

CacheRemoveHit Class NFX Class Library

How many times key was found and object removed
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheRemoveHit

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CacheRemoveHit : CacheLongGauge
[SerializableAttribute]
public class CacheRemoveHit : CacheLongGauge
<SerializableAttribute>
Public Class CacheRemoveHit
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class CacheRemoveHit
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class CacheRemoveHit : public CacheLongGauge
[SerializableAttribute]
public ref class CacheRemoveHit : public CacheLongGauge
[<SerializableAttribute>]
type CacheRemoveHit =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type CacheRemoveHit =
    class
        inherit CacheLongGauge
    end
See Also
CacheRemoveHit Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRemoveHit Members

CacheRemoveHit Members NFX Class Library

The CacheRemoveHit type exposes the following members.
Constructors
 | Name | Description
Protected method | CacheRemoveHit | Initializes a new instance of the CacheRemoveHit class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheRemoveHit Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRemoveHit Constructor

CacheRemoveHit Constructor NFX Class Library

Initializes a new instance of the CacheRemoveHit class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CacheRemoveHit(
    string src,
    long value
)
internal CacheRemoveHit(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
CacheRemoveHit(
    String^ src,
    long long value
)
internal:
CacheRemoveHit(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> CacheRemoveHit
new :
        src : string *
        value : int64 -> CacheRemoveHit

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
CacheRemoveHit Class
CacheRemoveHit Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRemoveHit Fields

CacheRemoveHit Fields NFX Class Library

The CacheRemoveHit type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
CacheRemoveHit Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRemoveHit Methods

CacheRemoveHit Methods NFX Class Library

The CacheRemoveHit type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CacheRemoveHit Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRemoveHit.MakeAggregateInstance Method

CacheRemoveHit MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
CacheRemoveHit Class
CacheRemoveHit Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRemoveHit Properties

CacheRemoveHit Properties NFX Class Library

The CacheRemoveHit type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheRemoveHit Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRemoveHit.Description Property

CacheRemoveHit Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
CacheRemoveHit Class
CacheRemoveHit Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRemoveHit.ValueUnitName Property

CacheRemoveHit ValueUnitName Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
CacheRemoveHit Class
CacheRemoveHit Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRemoveMiss Class

CacheRemoveMiss Class NFX Class Library

How many times key was not found and object not removed
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheRemoveMiss

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CacheRemoveMiss : CacheLongGauge
[SerializableAttribute]
public class CacheRemoveMiss : CacheLongGauge
<SerializableAttribute>
Public Class CacheRemoveMiss
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class CacheRemoveMiss
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class CacheRemoveMiss : public CacheLongGauge
[SerializableAttribute]
public ref class CacheRemoveMiss : public CacheLongGauge
[<SerializableAttribute>]
type CacheRemoveMiss =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type CacheRemoveMiss =
    class
        inherit CacheLongGauge
    end
See Also
CacheRemoveMiss Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRemoveMiss Members

CacheRemoveMiss Members NFX Class Library

The CacheRemoveMiss type exposes the following members.
Constructors
 | Name | Description
Protected method | CacheRemoveMiss | Initializes a new instance of the CacheRemoveMiss class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheRemoveMiss Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRemoveMiss Constructor

CacheRemoveMiss Constructor NFX Class Library

Initializes a new instance of the CacheRemoveMiss class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CacheRemoveMiss(
    string src,
    long value
)
internal CacheRemoveMiss(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
CacheRemoveMiss(
    String^ src,
    long long value
)
internal:
CacheRemoveMiss(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> CacheRemoveMiss
new :
        src : string *
        value : int64 -> CacheRemoveMiss

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
CacheRemoveMiss Class
CacheRemoveMiss Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRemoveMiss Fields

CacheRemoveMiss Fields NFX Class Library

The CacheRemoveMiss type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
CacheRemoveMiss Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRemoveMiss Methods

CacheRemoveMiss Methods NFX Class Library

The CacheRemoveMiss type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CacheRemoveMiss Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRemoveMiss.MakeAggregateInstance Method

CacheRemoveMiss MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
CacheRemoveMiss Class
CacheRemoveMiss Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRemoveMiss Properties

CacheRemoveMiss Properties NFX Class Library

The CacheRemoveMiss type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheRemoveMiss Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRemoveMiss.Description Property

CacheRemoveMiss Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
CacheRemoveMiss Class
CacheRemoveMiss Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheRemoveMiss.ValueUnitName Property

CacheRemoveMiss ValueUnitName Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
CacheRemoveMiss Class
CacheRemoveMiss Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheShrunk Class

CacheShrunk Class NFX Class Library

How many times cache has to decrease its capacity
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheShrunk

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CacheShrunk : CacheLongGauge
[SerializableAttribute]
public class CacheShrunk : CacheLongGauge
<SerializableAttribute>
Public Class CacheShrunk
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class CacheShrunk
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class CacheShrunk : public CacheLongGauge
[SerializableAttribute]
public ref class CacheShrunk : public CacheLongGauge
[<SerializableAttribute>]
type CacheShrunk =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type CacheShrunk =
    class
        inherit CacheLongGauge
    end
See Also
CacheShrunk Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheShrunk Members

CacheShrunk Members NFX Class Library

The CacheShrunk type exposes the following members.
Constructors
 | Name | Description
Protected method | CacheShrunk | Initializes a new instance of the CacheShrunk class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheShrunk Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheShrunk Constructor

CacheShrunk Constructor NFX Class Library

Initializes a new instance of the CacheShrunk class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CacheShrunk(
    string src,
    long value
)
internal CacheShrunk(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
CacheShrunk(
    String^ src,
    long long value
)
internal:
CacheShrunk(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> CacheShrunk
new :
        src : string *
        value : int64 -> CacheShrunk

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
CacheShrunk Class
CacheShrunk Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheShrunk Fields

CacheShrunk Fields NFX Class Library

The CacheShrunk type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
CacheShrunk Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheShrunk Methods

CacheShrunk Methods NFX Class Library

The CacheShrunk type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CacheShrunk Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheShrunk.MakeAggregateInstance Method

CacheShrunk MakeAggregateInstance Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
CacheShrunk Class
CacheShrunk Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheShrunk Properties

CacheShrunk Properties NFX Class Library

The CacheShrunk type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheShrunk Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheShrunk.Description Property

CacheShrunk Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
CacheShrunk Class
CacheShrunk Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheShrunk.ValueUnitName Property

CacheShrunk ValueUnitName Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
CacheShrunk Class
CacheShrunk Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheSweep Class

CacheSweep Class NFX Class Library

How many entries/objects were removed by sweep
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheSweep

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CacheSweep : CacheLongGauge
[SerializableAttribute]
public class CacheSweep : CacheLongGauge
<SerializableAttribute>
Public Class CacheSweep
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class CacheSweep
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class CacheSweep : public CacheLongGauge
[SerializableAttribute]
public ref class CacheSweep : public CacheLongGauge
[<SerializableAttribute>]
type CacheSweep =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type CacheSweep =
    class
        inherit CacheLongGauge
    end
See Also
CacheSweep Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheSweep Members

CacheSweep Members NFX Class Library

The CacheSweep type exposes the following members.
Constructors
 | Name | Description
Protected method | CacheSweep | Initializes a new instance of the CacheSweep class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheSweep Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheSweep Constructor

CacheSweep Constructor NFX Class Library

Initializes a new instance of the CacheSweep class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CacheSweep(
    string src,
    long value
)
internal CacheSweep(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
CacheSweep(
    String^ src,
    long long value
)
internal:
CacheSweep(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> CacheSweep
new :
        src : string *
        value : int64 -> CacheSweep

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
CacheSweep Class
CacheSweep Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheSweep Fields

CacheSweep Fields NFX Class Library

The CacheSweep type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
CacheSweep Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheSweep Methods

CacheSweep Methods NFX Class Library

The CacheSweep type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CacheSweep Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheSweep.MakeAggregateInstance Method

CacheSweep MakeAggregateInstance Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
CacheSweep Class
CacheSweep Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheSweep Properties

CacheSweep Properties NFX Class Library

The CacheSweep type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheSweep Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheSweep.Description Property

CacheSweep Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
CacheSweep Class
CacheSweep Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheSweep.ValueUnitName Property

CacheSweep ValueUnitName Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
CacheSweep Class
CacheSweep Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheSweepDuration Class

CacheSweepDuration Class NFX Class Library

How long the sweeping took (examination + removal of expired)
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheSweepDuration

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CacheSweepDuration : CacheLongGauge
[SerializableAttribute]
public class CacheSweepDuration : CacheLongGauge
<SerializableAttribute>
Public Class CacheSweepDuration
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class CacheSweepDuration
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class CacheSweepDuration : public CacheLongGauge
[SerializableAttribute]
public ref class CacheSweepDuration : public CacheLongGauge
[<SerializableAttribute>]
type CacheSweepDuration =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type CacheSweepDuration =
    class
        inherit CacheLongGauge
    end
See Also
CacheSweepDuration Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheSweepDuration Members

CacheSweepDuration Members NFX Class Library

The CacheSweepDuration type exposes the following members.
Constructors
 | Name | Description
Protected method | CacheSweepDuration | Initializes a new instance of the CacheSweepDuration class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheSweepDuration Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheSweepDuration Constructor

CacheSweepDuration Constructor NFX Class Library

Initializes a new instance of the CacheSweepDuration class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CacheSweepDuration(
    string src,
    long value
)
internal CacheSweepDuration(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
CacheSweepDuration(
    String^ src,
    long long value
)
internal:
CacheSweepDuration(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> CacheSweepDuration
new :
        src : string *
        value : int64 -> CacheSweepDuration

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
CacheSweepDuration Class
CacheSweepDuration Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheSweepDuration Fields

CacheSweepDuration Fields NFX Class Library

The CacheSweepDuration type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
CacheSweepDuration Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheSweepDuration Methods

CacheSweepDuration Methods NFX Class Library

The CacheSweepDuration type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CacheSweepDuration Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheSweepDuration.MakeAggregateInstance Method

CacheSweepDuration MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
CacheSweepDuration Class
CacheSweepDuration Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheSweepDuration Properties

CacheSweepDuration Properties NFX Class Library

The CacheSweepDuration type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheSweepDuration Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheSweepDuration.Description Property

CacheSweepDuration Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
CacheSweepDuration Class
CacheSweepDuration Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheSweepDuration.ValueUnitName Property

CacheSweepDuration ValueUnitName Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
CacheSweepDuration Class
CacheSweepDuration Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheTableCount Class

CacheTableCount Class NFX Class Library

Provides table count in the cache instance
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheLongGauge
NFX.ApplicationModel.Pile.Instrumentation CacheTableCount

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CacheTableCount : CacheLongGauge
[SerializableAttribute]
public class CacheTableCount : CacheLongGauge
<SerializableAttribute>
Public Class CacheTableCount
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class CacheTableCount
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class CacheTableCount : public CacheLongGauge
[SerializableAttribute]
public ref class CacheTableCount : public CacheLongGauge
[<SerializableAttribute>]
type CacheTableCount =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type CacheTableCount =
    class
        inherit CacheLongGauge
    end
See Also
CacheTableCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheTableCount Members

CacheTableCount Members NFX Class Library

The CacheTableCount type exposes the following members.
Constructors
 | Name | Description
Protected method | CacheTableCount | Initializes a new instance of the CacheTableCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheTableCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheTableCount Constructor

CacheTableCount Constructor NFX Class Library

Initializes a new instance of the CacheTableCount class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CacheTableCount(
    string src,
    long value
)
internal CacheTableCount(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
CacheTableCount(
    String^ src,
    long long value
)
internal:
CacheTableCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> CacheTableCount
new :
        src : string *
        value : int64 -> CacheTableCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
CacheTableCount Class
CacheTableCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheTableCount Fields

CacheTableCount Fields NFX Class Library

The CacheTableCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
CacheTableCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheTableCount Methods

CacheTableCount Methods NFX Class Library

The CacheTableCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CacheTableCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheTableCount.MakeAggregateInstance Method

CacheTableCount MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
CacheTableCount Class
CacheTableCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheTableCount Properties

CacheTableCount Properties NFX Class Library

The CacheTableCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheTableCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheTableCount.Description Property

CacheTableCount Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
CacheTableCount Class
CacheTableCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheTableCount.ValueUnitName Property

CacheTableCount ValueUnitName Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
CacheTableCount Class
CacheTableCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheTableSwept Class

CacheTableSwept Class NFX Class Library

Cache table was swept
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Event
NFX.ApplicationModel.Pile.Instrumentation CacheEvent
NFX.ApplicationModel.Pile.Instrumentation CacheTableSwept

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CacheTableSwept : CacheEvent
[SerializableAttribute]
public class CacheTableSwept : CacheEvent
<SerializableAttribute>
Public Class CacheTableSwept
    Inherits CacheEvent
<SerializableAttribute>
Public Class CacheTableSwept
    Inherits CacheEvent
[SerializableAttribute]
public ref class CacheTableSwept : public CacheEvent
[SerializableAttribute]
public ref class CacheTableSwept : public CacheEvent
[<SerializableAttribute>]
type CacheTableSwept =
    class
        inherit CacheEvent
    end
[<SerializableAttribute>]
type CacheTableSwept =
    class
        inherit CacheEvent
    end
See Also
CacheTableSwept Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheTableSwept Members

CacheTableSwept Members NFX Class Library

The CacheTableSwept type exposes the following members.
Constructors
 | Name | Description
Protected method | CacheTableSwept | Initializes a new instance of the CacheTableSwept class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Happened |
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheTableSwept Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheTableSwept Constructor

CacheTableSwept Constructor NFX Class Library

Initializes a new instance of the CacheTableSwept class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CacheTableSwept(
    string src
)
protected CacheTableSwept(
    string src
)
Protected Sub New (
    src As String
)
Protected Sub New (
    src As String
)
protected:
CacheTableSwept(
    String^ src
)
protected:
CacheTableSwept(
    String^ src
)
new :
        src : string -> CacheTableSwept
new :
        src : string -> CacheTableSwept

Parameters

src
Type: Online System String
See Also
CacheTableSwept Class
CacheTableSwept Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheTableSwept Fields

CacheTableSwept Fields NFX Class Library

The CacheTableSwept type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
CacheTableSwept Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheTableSwept Methods

CacheTableSwept Methods NFX Class Library

The CacheTableSwept type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Happened |
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CacheTableSwept Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheTableSwept.Happened Method

CacheTableSwept Happened Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Happened(
    string tableName
)
public static void Happened(
    string tableName
)
Public Shared Sub Happened (
    tableName As String
)
Public Shared Sub Happened (
    tableName As String
)
public:
static void Happened(
    String^ tableName
)
public:
static void Happened(
    String^ tableName
)
static member Happened :
        tableName : string -> unit
static member Happened :
        tableName : string -> unit

Parameters

tableName
Type: Online System String
See Also
CacheTableSwept Class
CacheTableSwept Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheTableSwept.MakeAggregateInstance Method

CacheTableSwept MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
CacheTableSwept Class
CacheTableSwept Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheTableSwept Properties

CacheTableSwept Properties NFX Class Library

The CacheTableSwept type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheTableSwept Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


CacheTableSwept.Description Property

CacheTableSwept Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
CacheTableSwept Class
CacheTableSwept Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


DeleteCount Class

DeleteCount Class NFX Class Library

Count of Delete() calls
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation DeleteCount

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class DeleteCount : PileLongGauge
[SerializableAttribute]
public class DeleteCount : PileLongGauge
<SerializableAttribute>
Public Class DeleteCount
    Inherits PileLongGauge
<SerializableAttribute>
Public Class DeleteCount
    Inherits PileLongGauge
[SerializableAttribute]
public ref class DeleteCount : public PileLongGauge
[SerializableAttribute]
public ref class DeleteCount : public PileLongGauge
[<SerializableAttribute>]
type DeleteCount =
    class
        inherit PileLongGauge
    end
[<SerializableAttribute>]
type DeleteCount =
    class
        inherit PileLongGauge
    end
See Also
DeleteCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


DeleteCount Members

DeleteCount Members NFX Class Library

The DeleteCount type exposes the following members.
Constructors
 | Name | Description
Protected method | DeleteCount | Initializes a new instance of the DeleteCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
DeleteCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


DeleteCount Constructor

DeleteCount Constructor NFX Class Library

Initializes a new instance of the DeleteCount class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal DeleteCount(
    string src,
    long value
)
internal DeleteCount(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
DeleteCount(
    String^ src,
    long long value
)
internal:
DeleteCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> DeleteCount
new :
        src : string *
        value : int64 -> DeleteCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
DeleteCount Class
DeleteCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


DeleteCount Fields

DeleteCount Fields NFX Class Library

The DeleteCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
DeleteCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


DeleteCount Methods

DeleteCount Methods NFX Class Library

The DeleteCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
DeleteCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


DeleteCount.MakeAggregateInstance Method

DeleteCount MakeAggregateInstance Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
DeleteCount Class
DeleteCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


DeleteCount Properties

DeleteCount Properties NFX Class Library

The DeleteCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
DeleteCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


DeleteCount.Description Property

DeleteCount Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
DeleteCount Class
DeleteCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


DeleteCount.ValueUnitName Property

DeleteCount ValueUnitName Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
DeleteCount Class
DeleteCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


FreeListCapacity Class

FreeListCapacity Class NFX Class Library

Number of free clots(chunks) in the free list
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation FreeListCapacity

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class FreeListCapacity : PileLongGauge
[SerializableAttribute]
public class FreeListCapacity : PileLongGauge
<SerializableAttribute>
Public Class FreeListCapacity
    Inherits PileLongGauge
<SerializableAttribute>
Public Class FreeListCapacity
    Inherits PileLongGauge
[SerializableAttribute]
public ref class FreeListCapacity : public PileLongGauge
[SerializableAttribute]
public ref class FreeListCapacity : public PileLongGauge
[<SerializableAttribute>]
type FreeListCapacity =
    class
        inherit PileLongGauge
    end
[<SerializableAttribute>]
type FreeListCapacity =
    class
        inherit PileLongGauge
    end
See Also
FreeListCapacity Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


FreeListCapacity Members

FreeListCapacity Members NFX Class Library

The FreeListCapacity type exposes the following members.
Constructors
 | Name | Description
Protected method | FreeListCapacity | Initializes a new instance of the FreeListCapacity class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
FreeListCapacity Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


FreeListCapacity Constructor

FreeListCapacity Constructor NFX Class Library

Initializes a new instance of the FreeListCapacity class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal FreeListCapacity(
    string src,
    long value
)
internal FreeListCapacity(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
FreeListCapacity(
    String^ src,
    long long value
)
internal:
FreeListCapacity(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> FreeListCapacity
new :
        src : string *
        value : int64 -> FreeListCapacity

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
FreeListCapacity Class
FreeListCapacity Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


FreeListCapacity Fields

FreeListCapacity Fields NFX Class Library

The FreeListCapacity type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
FreeListCapacity Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


FreeListCapacity Methods

FreeListCapacity Methods NFX Class Library

The FreeListCapacity type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
FreeListCapacity Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


FreeListCapacity.MakeAggregateInstance Method

FreeListCapacity MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
FreeListCapacity Class
FreeListCapacity Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


FreeListCapacity Properties

FreeListCapacity Properties NFX Class Library

The FreeListCapacity type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
FreeListCapacity Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


FreeListCapacity.Description Property

FreeListCapacity Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
FreeListCapacity Class
FreeListCapacity Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


FreeListCapacity.ValueUnitName Property

FreeListCapacity ValueUnitName Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
FreeListCapacity Class
FreeListCapacity Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


GetCount Class

GetCount Class NFX Class Library

Count of Get() calls
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation GetCount

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GetCount : PileLongGauge
[SerializableAttribute]
public class GetCount : PileLongGauge
<SerializableAttribute>
Public Class GetCount
    Inherits PileLongGauge
<SerializableAttribute>
Public Class GetCount
    Inherits PileLongGauge
[SerializableAttribute]
public ref class GetCount : public PileLongGauge
[SerializableAttribute]
public ref class GetCount : public PileLongGauge
[<SerializableAttribute>]
type GetCount =
    class
        inherit PileLongGauge
    end
[<SerializableAttribute>]
type GetCount =
    class
        inherit PileLongGauge
    end
See Also
GetCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


GetCount Members

GetCount Members NFX Class Library

The GetCount type exposes the following members.
Constructors
 | Name | Description
Protected method | GetCount | Initializes a new instance of the GetCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
GetCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


GetCount Constructor

GetCount Constructor NFX Class Library

Initializes a new instance of the GetCount class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal GetCount(
    string src,
    long value
)
internal GetCount(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
GetCount(
    String^ src,
    long long value
)
internal:
GetCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> GetCount
new :
        src : string *
        value : int64 -> GetCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
GetCount Class
GetCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


GetCount Fields

GetCount Fields NFX Class Library

The GetCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
GetCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


GetCount Methods

GetCount Methods NFX Class Library

The GetCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GetCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


GetCount.MakeAggregateInstance Method

GetCount MakeAggregateInstance Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
GetCount Class
GetCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


GetCount Properties

GetCount Properties NFX Class Library

The GetCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
GetCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


GetCount.Description Property

GetCount Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
GetCount Class
GetCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


GetCount.ValueUnitName Property

GetCount ValueUnitName Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
GetCount Class
GetCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


MemoryCapacityBytes Class

MemoryCapacityBytes Class NFX Class Library

Average capacity of free memory that the system has left
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation MemoryCapacityBytes

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MemoryCapacityBytes : PileLongGauge
[SerializableAttribute]
public class MemoryCapacityBytes : PileLongGauge
<SerializableAttribute>
Public Class MemoryCapacityBytes
    Inherits PileLongGauge
<SerializableAttribute>
Public Class MemoryCapacityBytes
    Inherits PileLongGauge
[SerializableAttribute]
public ref class MemoryCapacityBytes : public PileLongGauge
[SerializableAttribute]
public ref class MemoryCapacityBytes : public PileLongGauge
[<SerializableAttribute>]
type MemoryCapacityBytes =
    class
        inherit PileLongGauge
    end
[<SerializableAttribute>]
type MemoryCapacityBytes =
    class
        inherit PileLongGauge
    end
See Also
MemoryCapacityBytes Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


MemoryCapacityBytes Members

MemoryCapacityBytes Members NFX Class Library

The MemoryCapacityBytes type exposes the following members.
Constructors
 | Name | Description
Protected method | MemoryCapacityBytes | Initializes a new instance of the MemoryCapacityBytes class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
MemoryCapacityBytes Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


MemoryCapacityBytes Constructor

MemoryCapacityBytes Constructor NFX Class Library

Initializes a new instance of the MemoryCapacityBytes class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal MemoryCapacityBytes(
    string src,
    long value
)
internal MemoryCapacityBytes(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
MemoryCapacityBytes(
    String^ src,
    long long value
)
internal:
MemoryCapacityBytes(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> MemoryCapacityBytes
new :
        src : string *
        value : int64 -> MemoryCapacityBytes

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
MemoryCapacityBytes Class
MemoryCapacityBytes Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


MemoryCapacityBytes Fields

MemoryCapacityBytes Fields NFX Class Library

The MemoryCapacityBytes type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
MemoryCapacityBytes Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


MemoryCapacityBytes Methods

MemoryCapacityBytes Methods NFX Class Library

The MemoryCapacityBytes type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MemoryCapacityBytes Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


MemoryCapacityBytes.MakeAggregateInstance Method

MemoryCapacityBytes MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
MemoryCapacityBytes Class
MemoryCapacityBytes Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


MemoryCapacityBytes Properties

MemoryCapacityBytes Properties NFX Class Library

The MemoryCapacityBytes type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
MemoryCapacityBytes Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


MemoryCapacityBytes.Description Property

MemoryCapacityBytes Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
MemoryCapacityBytes Class
MemoryCapacityBytes Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


MemoryCapacityBytes.ValueUnitName Property

MemoryCapacityBytes ValueUnitName Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
MemoryCapacityBytes Class
MemoryCapacityBytes Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


ObjectCount Class

ObjectCount Class NFX Class Library

Provides object count in the instance
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation ObjectCount

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ObjectCount : PileLongGauge
[SerializableAttribute]
public class ObjectCount : PileLongGauge
<SerializableAttribute>
Public Class ObjectCount
    Inherits PileLongGauge
<SerializableAttribute>
Public Class ObjectCount
    Inherits PileLongGauge
[SerializableAttribute]
public ref class ObjectCount : public PileLongGauge
[SerializableAttribute]
public ref class ObjectCount : public PileLongGauge
[<SerializableAttribute>]
type ObjectCount =
    class
        inherit PileLongGauge
    end
[<SerializableAttribute>]
type ObjectCount =
    class
        inherit PileLongGauge
    end
See Also
ObjectCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


ObjectCount Members

ObjectCount Members NFX Class Library

The ObjectCount type exposes the following members.
Constructors
 | Name | Description
Protected method | ObjectCount | Initializes a new instance of the ObjectCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ObjectCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


ObjectCount Constructor

ObjectCount Constructor NFX Class Library

Initializes a new instance of the ObjectCount class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ObjectCount(
    string src,
    long value
)
internal ObjectCount(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
ObjectCount(
    String^ src,
    long long value
)
internal:
ObjectCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ObjectCount
new :
        src : string *
        value : int64 -> ObjectCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ObjectCount Class
ObjectCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


ObjectCount Fields

ObjectCount Fields NFX Class Library

The ObjectCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ObjectCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


ObjectCount Methods

ObjectCount Methods NFX Class Library

The ObjectCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ObjectCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


ObjectCount.MakeAggregateInstance Method

ObjectCount MakeAggregateInstance Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ObjectCount Class
ObjectCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


ObjectCount Properties

ObjectCount Properties NFX Class Library

The ObjectCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ObjectCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


ObjectCount.Description Property

ObjectCount Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ObjectCount Class
ObjectCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


ObjectCount.ValueUnitName Property

ObjectCount ValueUnitName Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ObjectCount Class
ObjectCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


OverheadBytes Class

OverheadBytes Class NFX Class Library

Number of extra bytes used by pile metadata currently occupied by object stored in this pile
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation OverheadBytes

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class OverheadBytes : PileLongGauge
[SerializableAttribute]
public class OverheadBytes : PileLongGauge
<SerializableAttribute>
Public Class OverheadBytes
    Inherits PileLongGauge
<SerializableAttribute>
Public Class OverheadBytes
    Inherits PileLongGauge
[SerializableAttribute]
public ref class OverheadBytes : public PileLongGauge
[SerializableAttribute]
public ref class OverheadBytes : public PileLongGauge
[<SerializableAttribute>]
type OverheadBytes =
    class
        inherit PileLongGauge
    end
[<SerializableAttribute>]
type OverheadBytes =
    class
        inherit PileLongGauge
    end
See Also
OverheadBytes Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


OverheadBytes Members

OverheadBytes Members NFX Class Library

The OverheadBytes type exposes the following members.
Constructors
 | Name | Description
Protected method | OverheadBytes | Initializes a new instance of the OverheadBytes class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
OverheadBytes Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


OverheadBytes Constructor

OverheadBytes Constructor NFX Class Library

Initializes a new instance of the OverheadBytes class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal OverheadBytes(
    string src,
    long value
)
internal OverheadBytes(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
OverheadBytes(
    String^ src,
    long long value
)
internal:
OverheadBytes(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> OverheadBytes
new :
        src : string *
        value : int64 -> OverheadBytes

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
OverheadBytes Class
OverheadBytes Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


OverheadBytes Fields

OverheadBytes Fields NFX Class Library

The OverheadBytes type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
OverheadBytes Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


OverheadBytes Methods

OverheadBytes Methods NFX Class Library

The OverheadBytes type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
OverheadBytes Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


OverheadBytes.MakeAggregateInstance Method

OverheadBytes MakeAggregateInstance Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
OverheadBytes Class
OverheadBytes Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


OverheadBytes Properties

OverheadBytes Properties NFX Class Library

The OverheadBytes type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
OverheadBytes Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


OverheadBytes.Description Property

OverheadBytes Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
OverheadBytes Class
OverheadBytes Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


OverheadBytes.ValueUnitName Property

OverheadBytes ValueUnitName Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
OverheadBytes Class
OverheadBytes Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


PileDoubleGauge Class

PileDoubleGauge Class NFX Class Library

Provides base for pile double gauges
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation DoubleGauge
NFX.ApplicationModel.Pile.Instrumentation PileDoubleGauge
NFX.ApplicationModel.Pile.Instrumentation CacheDoubleGauge

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class PileDoubleGauge : DoubleGauge,
    ICacheInstrument, IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public abstract class PileDoubleGauge : DoubleGauge,
    ICacheInstrument, IMemoryInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public MustInherit Class PileDoubleGauge
    Inherits DoubleGauge
    Implements ICacheInstrument, IMemoryInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public MustInherit Class PileDoubleGauge
    Inherits DoubleGauge
    Implements ICacheInstrument, IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class PileDoubleGauge abstract : public DoubleGauge,
    ICacheInstrument, IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class PileDoubleGauge abstract : public DoubleGauge,
    ICacheInstrument, IMemoryInstrument, IOperationClass, IInstrumentClass
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type PileDoubleGauge =
    class
        inherit DoubleGauge
        interface ICacheInstrument
        interface IMemoryInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type PileDoubleGauge =
    class
        inherit DoubleGauge
        interface ICacheInstrument
        interface IMemoryInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
PileDoubleGauge Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


PileDoubleGauge Members

PileDoubleGauge Members NFX Class Library

The PileDoubleGauge type exposes the following members.
Constructors
 | Name | Description
Protected method | PileDoubleGauge | Initializes a new instance of the PileDoubleGauge class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from DoubleGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from DoubleGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from DoubleGauge.)
Public property | ValueAsObject | (Inherited from DoubleGauge.)
Public property | ValueUnitName | (Inherited from DoubleGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
PileDoubleGauge Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


PileDoubleGauge Constructor

PileDoubleGauge Constructor NFX Class Library

Initializes a new instance of the PileDoubleGauge class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PileDoubleGauge(
    string src,
    double value
)
protected PileDoubleGauge(
    string src,
    double value
)
Protected Sub New (
    src As String,
    value As Double
)
Protected Sub New (
    src As String,
    value As Double
)
protected:
PileDoubleGauge(
    String^ src,
    double value
)
protected:
PileDoubleGauge(
    String^ src,
    double value
)
new :
        src : string *
        value : float -> PileDoubleGauge
new :
        src : string *
        value : float -> PileDoubleGauge

Parameters

src
Type: Online System String
value
Type: Online System Double
See Also
PileDoubleGauge Class
PileDoubleGauge Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


PileDoubleGauge Fields

PileDoubleGauge Fields NFX Class Library

The PileDoubleGauge type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
PileDoubleGauge Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


PileDoubleGauge Methods

PileDoubleGauge Methods NFX Class Library

The PileDoubleGauge type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from DoubleGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from DoubleGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PileDoubleGauge Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


PileDoubleGauge Properties

PileDoubleGauge Properties NFX Class Library

The PileDoubleGauge type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from DoubleGauge.)
Public property | ValueAsObject | (Inherited from DoubleGauge.)
Public property | ValueUnitName | (Inherited from DoubleGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
PileDoubleGauge Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


PileLongGauge Class

PileLongGauge Class NFX Class Library

Provides base for pile long gauges
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation AllocatedMemoryBytes
NFX.ApplicationModel.Pile.Instrumentation AverageObjectSizeBytes
NFX.ApplicationModel.Pile.Instrumentation CacheLongGauge
NFX.ApplicationModel.Pile.Instrumentation DeleteCount
NFX.ApplicationModel.Pile.Instrumentation FreeListCapacity
NFX.ApplicationModel.Pile.Instrumentation GetCount
NFX.ApplicationModel.Pile.Instrumentation MemoryCapacityBytes
NFX.ApplicationModel.Pile.Instrumentation ObjectCount
NFX.ApplicationModel.Pile.Instrumentation OverheadBytes
NFX.ApplicationModel.Pile.Instrumentation PutCount
NFX.ApplicationModel.Pile.Instrumentation SegmentCount
NFX.ApplicationModel.Pile.Instrumentation UtilizedBytes

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class PileLongGauge : LongGauge,
    ICacheInstrument, IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public abstract class PileLongGauge : LongGauge,
    ICacheInstrument, IMemoryInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public MustInherit Class PileLongGauge
    Inherits LongGauge
    Implements ICacheInstrument, IMemoryInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public MustInherit Class PileLongGauge
    Inherits LongGauge
    Implements ICacheInstrument, IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class PileLongGauge abstract : public LongGauge,
    ICacheInstrument, IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class PileLongGauge abstract : public LongGauge,
    ICacheInstrument, IMemoryInstrument, IOperationClass, IInstrumentClass
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type PileLongGauge =
    class
        inherit LongGauge
        interface ICacheInstrument
        interface IMemoryInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type PileLongGauge =
    class
        inherit LongGauge
        interface ICacheInstrument
        interface IMemoryInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
PileLongGauge Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


PileLongGauge Members

PileLongGauge Members NFX Class Library

The PileLongGauge type exposes the following members.
Constructors
 | Name | Description
Protected method | PileLongGauge | Initializes a new instance of the PileLongGauge class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Inherited from LongGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
PileLongGauge Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


PileLongGauge Constructor

PileLongGauge Constructor NFX Class Library

Initializes a new instance of the PileLongGauge class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PileLongGauge(
    string src,
    long value
)
protected PileLongGauge(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
PileLongGauge(
    String^ src,
    long long value
)
protected:
PileLongGauge(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> PileLongGauge
new :
        src : string *
        value : int64 -> PileLongGauge

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
PileLongGauge Class
PileLongGauge Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


PileLongGauge Fields

PileLongGauge Fields NFX Class Library

The PileLongGauge type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
PileLongGauge Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


PileLongGauge Methods

PileLongGauge Methods NFX Class Library

The PileLongGauge type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PileLongGauge Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


PileLongGauge Properties

PileLongGauge Properties NFX Class Library

The PileLongGauge type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Inherited from LongGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
PileLongGauge Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


PutCount Class

PutCount Class NFX Class Library

Count of Put() calls
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation PutCount

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PutCount : PileLongGauge
[SerializableAttribute]
public class PutCount : PileLongGauge
<SerializableAttribute>
Public Class PutCount
    Inherits PileLongGauge
<SerializableAttribute>
Public Class PutCount
    Inherits PileLongGauge
[SerializableAttribute]
public ref class PutCount : public PileLongGauge
[SerializableAttribute]
public ref class PutCount : public PileLongGauge
[<SerializableAttribute>]
type PutCount =
    class
        inherit PileLongGauge
    end
[<SerializableAttribute>]
type PutCount =
    class
        inherit PileLongGauge
    end
See Also
PutCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


PutCount Members

PutCount Members NFX Class Library

The PutCount type exposes the following members.
Constructors
 | Name | Description
Protected method | PutCount | Initializes a new instance of the PutCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
PutCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


PutCount Constructor

PutCount Constructor NFX Class Library

Initializes a new instance of the PutCount class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal PutCount(
    string src,
    long value
)
internal PutCount(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
PutCount(
    String^ src,
    long long value
)
internal:
PutCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> PutCount
new :
        src : string *
        value : int64 -> PutCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
PutCount Class
PutCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


PutCount Fields

PutCount Fields NFX Class Library

The PutCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
PutCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


PutCount Methods

PutCount Methods NFX Class Library

The PutCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PutCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


PutCount.MakeAggregateInstance Method

PutCount MakeAggregateInstance Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
PutCount Class
PutCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


PutCount Properties

PutCount Properties NFX Class Library

The PutCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
PutCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


PutCount.Description Property

PutCount Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
PutCount Class
PutCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


PutCount.ValueUnitName Property

PutCount ValueUnitName Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
PutCount Class
PutCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


SegmentCount Class

SegmentCount Class NFX Class Library

Provides segment count in the instance
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation SegmentCount

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SegmentCount : PileLongGauge
[SerializableAttribute]
public class SegmentCount : PileLongGauge
<SerializableAttribute>
Public Class SegmentCount
    Inherits PileLongGauge
<SerializableAttribute>
Public Class SegmentCount
    Inherits PileLongGauge
[SerializableAttribute]
public ref class SegmentCount : public PileLongGauge
[SerializableAttribute]
public ref class SegmentCount : public PileLongGauge
[<SerializableAttribute>]
type SegmentCount =
    class
        inherit PileLongGauge
    end
[<SerializableAttribute>]
type SegmentCount =
    class
        inherit PileLongGauge
    end
See Also
SegmentCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


SegmentCount Members

SegmentCount Members NFX Class Library

The SegmentCount type exposes the following members.
Constructors
 | Name | Description
Protected method | SegmentCount | Initializes a new instance of the SegmentCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
SegmentCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


SegmentCount Constructor

SegmentCount Constructor NFX Class Library

Initializes a new instance of the SegmentCount class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal SegmentCount(
    string src,
    long value
)
internal SegmentCount(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
SegmentCount(
    String^ src,
    long long value
)
internal:
SegmentCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> SegmentCount
new :
        src : string *
        value : int64 -> SegmentCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
SegmentCount Class
SegmentCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


SegmentCount Fields

SegmentCount Fields NFX Class Library

The SegmentCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
SegmentCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


SegmentCount Methods

SegmentCount Methods NFX Class Library

The SegmentCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SegmentCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


SegmentCount.MakeAggregateInstance Method

SegmentCount MakeAggregateInstance Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
SegmentCount Class
SegmentCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


SegmentCount Properties

SegmentCount Properties NFX Class Library

The SegmentCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
SegmentCount Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


SegmentCount.Description Property

SegmentCount Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
SegmentCount Class
SegmentCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


SegmentCount.ValueUnitName Property

SegmentCount ValueUnitName Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
SegmentCount Class
SegmentCount Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


UtilizedBytes Class

UtilizedBytes Class NFX Class Library

Number of bytes allocated for object storage within AllocatedMemoryBytes
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.ApplicationModel.Pile.Instrumentation UtilizedBytes

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class UtilizedBytes : PileLongGauge
[SerializableAttribute]
public class UtilizedBytes : PileLongGauge
<SerializableAttribute>
Public Class UtilizedBytes
    Inherits PileLongGauge
<SerializableAttribute>
Public Class UtilizedBytes
    Inherits PileLongGauge
[SerializableAttribute]
public ref class UtilizedBytes : public PileLongGauge
[SerializableAttribute]
public ref class UtilizedBytes : public PileLongGauge
[<SerializableAttribute>]
type UtilizedBytes =
    class
        inherit PileLongGauge
    end
[<SerializableAttribute>]
type UtilizedBytes =
    class
        inherit PileLongGauge
    end
See Also
UtilizedBytes Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


UtilizedBytes Members

UtilizedBytes Members NFX Class Library

The UtilizedBytes type exposes the following members.
Constructors
 | Name | Description
Protected method | UtilizedBytes | Initializes a new instance of the UtilizedBytes class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
UtilizedBytes Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


UtilizedBytes Constructor

UtilizedBytes Constructor NFX Class Library

Initializes a new instance of the UtilizedBytes class

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal UtilizedBytes(
    string src,
    long value
)
internal UtilizedBytes(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
UtilizedBytes(
    String^ src,
    long long value
)
internal:
UtilizedBytes(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> UtilizedBytes
new :
        src : string *
        value : int64 -> UtilizedBytes

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
UtilizedBytes Class
UtilizedBytes Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


UtilizedBytes Fields

UtilizedBytes Fields NFX Class Library

The UtilizedBytes type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
UtilizedBytes Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


UtilizedBytes Methods

UtilizedBytes Methods NFX Class Library

The UtilizedBytes type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
UtilizedBytes Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


UtilizedBytes.MakeAggregateInstance Method

UtilizedBytes MakeAggregateInstance Method NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
UtilizedBytes Class
UtilizedBytes Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


UtilizedBytes Properties

UtilizedBytes Properties NFX Class Library

The UtilizedBytes type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
UtilizedBytes Class
NFX.ApplicationModel.Pile.Instrumentation Namespace


UtilizedBytes.Description Property

UtilizedBytes Description Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
UtilizedBytes Class
UtilizedBytes Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


UtilizedBytes.ValueUnitName Property

UtilizedBytes ValueUnitName Property NFX Class Library

Namespace: NFX.ApplicationModel.Pile.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
UtilizedBytes Class
UtilizedBytes Members
NFX.ApplicationModel.Pile.Instrumentation Namespace


NFX.ApplicationModel.Volatile Namespace

NFX.ApplicationModel.Volatile Namespace NFX Class Library

Facilitates operation of applications in volatile environments when processes can be restarted/crash
Classes
 | Class | Description
Protected class | Bucket |
Public class | FileObjectStoreProvider | Defines a file-based provider that stores objects for ObjectStoreService class
Public class | NOPObjectStore | Implements ObjectStore service that does nothing
Public class | NOPObjectStoreProvider | Defines a provider that does not do anything - does not store object anywhere but memory
Public class | ObjectStoreEntry | Internal framework class that stores data in ObjectStoreService
Public class | ObjectStoreProvider | Defines a base provider that stores objects for ObjectStoreService class
Public class | ObjectStoreService | Implements service that stores object in proccess's memory, asynchronously saving objects to external non-volatile storage upon change and synchronously saving objects upon service stop. This service is useful for scenarious like ASP.NET volatile domain that can be torn down at any time. Note for ASP.NET uses: the key difference of this approach from .NET session state management is the fact that this service never blocks object CheckIn() operations as backing store is being updated asynchronously. This class is thread-safe unless specified otherwise on a property/method level
Interfaces
 | Interface | Description
Public interface | IObjectStore | Outlines interface for object store
Public interface | IObjectStoreImplementation |
Enumerations
 | Enumeration | Description
Public enumeration | FileObjectFormat | Format of files on disk
Public enumeration | ObjectStoreEntryStatus | Represents status of ObjectStoreEntry


Bucket Class

Bucket Class NFX Class Library

Inheritance Hierarchy
Online System Object
Online System.Collections.Generic Dictionary Online Guid, ObjectStoreEntry
NFX.ApplicationModel.Volatile Bucket

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class Bucket : Dictionary<Guid, ObjectStoreEntry>
internal class Bucket : Dictionary<Guid, ObjectStoreEntry>
Friend Class Bucket
    Inherits Dictionary(Of Guid, ObjectStoreEntry)
Friend Class Bucket
    Inherits Dictionary(Of Guid, ObjectStoreEntry)
internal ref class Bucket : public Dictionary<Guid, ObjectStoreEntry^>
internal ref class Bucket : public Dictionary<Guid, ObjectStoreEntry^>
type Bucket =
    class
        inherit Dictionary<Guid, ObjectStoreEntry>
    end
type Bucket =
    class
        inherit Dictionary<Guid, ObjectStoreEntry>
    end
See Also
Bucket Members
NFX.ApplicationModel.Volatile Namespace


Bucket Members

Bucket Members NFX Class Library

The Bucket type exposes the following members.
Constructors
 | Name | Description
Public method | Bucket | Initializes a new instance of the Bucket class
Back to Top
Methods
 | Name | Description
Public method | Online Add | (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Public method | Online Clear | (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Public method | Online ContainsKey | (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Public method | Online ContainsValue | (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online Dictionary TKey, TValue instance. (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Public method | Online Remove | (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TryGetValue | (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | LastAcquire |
Back to Top
Properties
 | Name | Description
Public property | Online Comparer | (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Public property | Online Count | (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Public property | Online Item | (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Public property | Online Keys | (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Public property | Online Values | (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Back to Top
See Also
Bucket Class
NFX.ApplicationModel.Volatile Namespace


Bucket Constructor

Bucket Constructor NFX Class Library

Initializes a new instance of the Bucket class

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Bucket()
public Bucket()
Public Sub New
Public Sub New
public:
Bucket()
public:
Bucket()
new : unit -> Bucket
new : unit -> Bucket
See Also
Bucket Class
Bucket Members
NFX.ApplicationModel.Volatile Namespace


Bucket Fields

Bucket Fields NFX Class Library

The Bucket type exposes the following members.
Fields
 | Name | Description
Public field | LastAcquire |
Back to Top
See Also
Bucket Class
NFX.ApplicationModel.Volatile Namespace


Bucket.LastAcquire Field

Bucket LastAcquire Field NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime LastAcquire
public DateTime LastAcquire
Public LastAcquire As DateTime
Public LastAcquire As DateTime
public:
DateTime LastAcquire
public:
DateTime LastAcquire
val mutable LastAcquire: DateTime
val mutable LastAcquire: DateTime

Field Value

Type: Online DateTime
See Also
Bucket Class
Bucket Members
NFX.ApplicationModel.Volatile Namespace


Bucket Methods

Bucket Methods NFX Class Library

The Bucket type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Public method | Online Clear | (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Public method | Online ContainsKey | (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Public method | Online ContainsValue | (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online Dictionary TKey, TValue instance. (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Public method | Online Remove | (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TryGetValue | (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Bucket Class
NFX.ApplicationModel.Volatile Namespace


Bucket Properties

Bucket Properties NFX Class Library

The Bucket type exposes the following members.
Properties
 | Name | Description
Public property | Online Comparer | (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Public property | Online Count | (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Public property | Online Item | (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Public property | Online Keys | (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Public property | Online Values | (Inherited from Online Dictionary Online Guid, ObjectStoreEntry .)
Back to Top
See Also
Bucket Class
NFX.ApplicationModel.Volatile Namespace


FileObjectFormat Enumeration

FileObjectFormat Enumeration NFX Class Library

Format of files on disk

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum FileObjectFormat
public enum FileObjectFormat
Public Enumeration FileObjectFormat
Public Enumeration FileObjectFormat
public enum class FileObjectFormat
public enum class FileObjectFormat
type FileObjectFormat
type FileObjectFormat
Members
Member name | Value | Description
Slim | 0 |
MSBinary | 1 |
See Also
NFX.ApplicationModel.Volatile Namespace


FileObjectStoreProvider Class

FileObjectStoreProvider Class NFX Class Library

Defines a file-based provider that stores objects for ObjectStoreService class
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service ObjectStoreService
NFX.ApplicationModel.Volatile ObjectStoreProvider
NFX.ApplicationModel.Volatile FileObjectStoreProvider

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class FileObjectStoreProvider : ObjectStoreProvider
public class FileObjectStoreProvider : ObjectStoreProvider
Public Class FileObjectStoreProvider
    Inherits ObjectStoreProvider
Public Class FileObjectStoreProvider
    Inherits ObjectStoreProvider
public ref class FileObjectStoreProvider : public ObjectStoreProvider
public ref class FileObjectStoreProvider : public ObjectStoreProvider
type FileObjectStoreProvider =
    class
        inherit ObjectStoreProvider
    end
type FileObjectStoreProvider =
    class
        inherit ObjectStoreProvider
    end
See Also
FileObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


FileObjectStoreProvider Members

FileObjectStoreProvider Members NFX Class Library

The FileObjectStoreProvider type exposes the following members.
Constructors
 | Name | Description
Public method | FileObjectStoreProvider | Initializes a new instance of the FileObjectStoreProvider class
Public method | FileObjectStoreProvider(ObjectStoreService) | Initializes a new instance of the FileObjectStoreProvider class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Public method | Delete | (Overrides ObjectStoreProvider Delete(ObjectStoreEntry).)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides ObjectStoreProvider DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LoadAll | (Overrides ObjectStoreProvider LoadAll .)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | Write | (Overrides ObjectStoreProvider Write(ObjectStoreEntry).)
Protected method | WriteLog | (Inherited from ObjectStoreProvider.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_FORMAT_ATTR |
CONFIG_KNOWN_SECTION |
CONFIG_KNOWN_TYPES_SECTION |
CONFIG_LOAD_LIMIT_ATTR |
CONFIG_ROOT_PATH_ATTR |
CONFIG_TYPE_ATTR |
DEFAULT_LOAD_LIMIT |
FROM |
MAX_LOAD_LIMIT |
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Format | Returns file format used for serialization/deserialization into/from files
Public property | LoadLimit | Imposes the limit on number of bytes that can be read from disk on load all. Once limit is exceeded the rest of objects will not load. Provider loads most recent objects first
Public property | LoadSize | Returns how many bytes have been loaded from disk
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | RootPath | Gets/sets the root path where objects are stored
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
FileObjectStoreProvider Class
NFX.ApplicationModel.Volatile Namespace


FileObjectStoreProvider Constructor

FileObjectStoreProvider Constructor NFX Class Library

Overload List
 | Name | Description
Public method | FileObjectStoreProvider | Initializes a new instance of the FileObjectStoreProvider class
Public method | FileObjectStoreProvider(ObjectStoreService) | Initializes a new instance of the FileObjectStoreProvider class
Back to Top
See Also
FileObjectStoreProvider Class
FileObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


FileObjectStoreProvider Constructor

FileObjectStoreProvider Constructor NFX Class Library

Initializes a new instance of the FileObjectStoreProvider class

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileObjectStoreProvider()
public FileObjectStoreProvider()
Public Sub New
Public Sub New
public:
FileObjectStoreProvider()
public:
FileObjectStoreProvider()
new : unit -> FileObjectStoreProvider
new : unit -> FileObjectStoreProvider
See Also
FileObjectStoreProvider Class
FileObjectStoreProvider Members
FileObjectStoreProvider Overload
NFX.ApplicationModel.Volatile Namespace


FileObjectStoreProvider Constructor (ObjectStoreService)

FileObjectStoreProvider Constructor (ObjectStoreService) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FileObjectStoreProvider class

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileObjectStoreProvider(
    ObjectStoreService director
)
public FileObjectStoreProvider(
    ObjectStoreService director
)
Public Sub New (
    director As ObjectStoreService
)
Public Sub New (
    director As ObjectStoreService
)
public:
FileObjectStoreProvider(
    ObjectStoreService^ director
)
public:
FileObjectStoreProvider(
    ObjectStoreService^ director
)
new :
        director : ObjectStoreService -> FileObjectStoreProvider
new :
        director : ObjectStoreService -> FileObjectStoreProvider

Parameters

director
Type: NFX.ApplicationModel.Volatile ObjectStoreService
See Also
FileObjectStoreProvider Class
FileObjectStoreProvider Members
FileObjectStoreProvider Overload
NFX.ApplicationModel.Volatile Namespace


FileObjectStoreProvider Fields

FileObjectStoreProvider Fields NFX Class Library

The FileObjectStoreProvider type exposes the following members.
Fields
Name | Description
CONFIG_FORMAT_ATTR |
CONFIG_KNOWN_SECTION |
CONFIG_KNOWN_TYPES_SECTION |
CONFIG_LOAD_LIMIT_ATTR |
CONFIG_ROOT_PATH_ATTR |
CONFIG_TYPE_ATTR |
DEFAULT_LOAD_LIMIT |
FROM |
MAX_LOAD_LIMIT |
Back to Top
See Also
FileObjectStoreProvider Class
NFX.ApplicationModel.Volatile Namespace


FileObjectStoreProvider.CONFIG_FORMAT_ATTR Field

FileObjectStoreProvider CONFIG_FORMAT_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_FORMAT_ATTR
public const string CONFIG_FORMAT_ATTR
Public Const CONFIG_FORMAT_ATTR As String
Public Const CONFIG_FORMAT_ATTR As String
public:
literal String^ CONFIG_FORMAT_ATTR
public:
literal String^ CONFIG_FORMAT_ATTR
static val mutable CONFIG_FORMAT_ATTR: string
static val mutable CONFIG_FORMAT_ATTR: string

Field Value

Type: Online String
See Also
FileObjectStoreProvider Class
FileObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


FileObjectStoreProvider.CONFIG_KNOWN_SECTION Field

FileObjectStoreProvider CONFIG_KNOWN_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_KNOWN_SECTION
public const string CONFIG_KNOWN_SECTION
Public Const CONFIG_KNOWN_SECTION As String
Public Const CONFIG_KNOWN_SECTION As String
public:
literal String^ CONFIG_KNOWN_SECTION
public:
literal String^ CONFIG_KNOWN_SECTION
static val mutable CONFIG_KNOWN_SECTION: string
static val mutable CONFIG_KNOWN_SECTION: string

Field Value

Type: Online String
See Also
FileObjectStoreProvider Class
FileObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


FileObjectStoreProvider.CONFIG_KNOWN_TYPES_SECTION Field

FileObjectStoreProvider CONFIG_KNOWN_TYPES_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_KNOWN_TYPES_SECTION
public const string CONFIG_KNOWN_TYPES_SECTION
Public Const CONFIG_KNOWN_TYPES_SECTION As String
Public Const CONFIG_KNOWN_TYPES_SECTION As String
public:
literal String^ CONFIG_KNOWN_TYPES_SECTION
public:
literal String^ CONFIG_KNOWN_TYPES_SECTION
static val mutable CONFIG_KNOWN_TYPES_SECTION: string
static val mutable CONFIG_KNOWN_TYPES_SECTION: string

Field Value

Type: Online String
See Also
FileObjectStoreProvider Class
FileObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


FileObjectStoreProvider.CONFIG_LOAD_LIMIT_ATTR Field

FileObjectStoreProvider CONFIG_LOAD_LIMIT_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_LOAD_LIMIT_ATTR
public const string CONFIG_LOAD_LIMIT_ATTR
Public Const CONFIG_LOAD_LIMIT_ATTR As String
Public Const CONFIG_LOAD_LIMIT_ATTR As String
public:
literal String^ CONFIG_LOAD_LIMIT_ATTR
public:
literal String^ CONFIG_LOAD_LIMIT_ATTR
static val mutable CONFIG_LOAD_LIMIT_ATTR: string
static val mutable CONFIG_LOAD_LIMIT_ATTR: string

Field Value

Type: Online String
See Also
FileObjectStoreProvider Class
FileObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


FileObjectStoreProvider.CONFIG_ROOT_PATH_ATTR Field

FileObjectStoreProvider CONFIG_ROOT_PATH_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_ROOT_PATH_ATTR
public const string CONFIG_ROOT_PATH_ATTR
Public Const CONFIG_ROOT_PATH_ATTR As String
Public Const CONFIG_ROOT_PATH_ATTR As String
public:
literal String^ CONFIG_ROOT_PATH_ATTR
public:
literal String^ CONFIG_ROOT_PATH_ATTR
static val mutable CONFIG_ROOT_PATH_ATTR: string
static val mutable CONFIG_ROOT_PATH_ATTR: string

Field Value

Type: Online String
See Also
FileObjectStoreProvider Class
FileObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


FileObjectStoreProvider.CONFIG_TYPE_ATTR Field

FileObjectStoreProvider CONFIG_TYPE_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_TYPE_ATTR
public const string CONFIG_TYPE_ATTR
Public Const CONFIG_TYPE_ATTR As String
Public Const CONFIG_TYPE_ATTR As String
public:
literal String^ CONFIG_TYPE_ATTR
public:
literal String^ CONFIG_TYPE_ATTR
static val mutable CONFIG_TYPE_ATTR: string
static val mutable CONFIG_TYPE_ATTR: string

Field Value

Type: Online String
See Also
FileObjectStoreProvider Class
FileObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


FileObjectStoreProvider.DEFAULT_LOAD_LIMIT Field

FileObjectStoreProvider DEFAULT_LOAD_LIMIT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const long DEFAULT_LOAD_LIMIT
public const long DEFAULT_LOAD_LIMIT
Public Const DEFAULT_LOAD_LIMIT As Long
Public Const DEFAULT_LOAD_LIMIT As Long
public:
literal long long DEFAULT_LOAD_LIMIT
public:
literal long long DEFAULT_LOAD_LIMIT
static val mutable DEFAULT_LOAD_LIMIT: int64
static val mutable DEFAULT_LOAD_LIMIT: int64

Field Value

Type: Online Int64
See Also
FileObjectStoreProvider Class
FileObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


FileObjectStoreProvider.FROM Field

FileObjectStoreProvider FROM Field NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FROM
public const string FROM
Public Const FROM As String
Public Const FROM As String
public:
literal String^ FROM
public:
literal String^ FROM
static val mutable FROM: string
static val mutable FROM: string

Field Value

Type: Online String
See Also
FileObjectStoreProvider Class
FileObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


FileObjectStoreProvider.MAX_LOAD_LIMIT Field

FileObjectStoreProvider MAX_LOAD_LIMIT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const long MAX_LOAD_LIMIT
public const long MAX_LOAD_LIMIT
Public Const MAX_LOAD_LIMIT As Long
Public Const MAX_LOAD_LIMIT As Long
public:
literal long long MAX_LOAD_LIMIT
public:
literal long long MAX_LOAD_LIMIT
static val mutable MAX_LOAD_LIMIT: int64
static val mutable MAX_LOAD_LIMIT: int64

Field Value

Type: Online Int64
See Also
FileObjectStoreProvider Class
FileObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


FileObjectStoreProvider Methods

FileObjectStoreProvider Methods NFX Class Library

The FileObjectStoreProvider type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Public method | Delete | (Overrides ObjectStoreProvider Delete(ObjectStoreEntry).)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides ObjectStoreProvider DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LoadAll | (Overrides ObjectStoreProvider LoadAll .)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | Write | (Overrides ObjectStoreProvider Write(ObjectStoreEntry).)
Protected method | WriteLog | (Inherited from ObjectStoreProvider.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
FileObjectStoreProvider Class
NFX.ApplicationModel.Volatile Namespace


FileObjectStoreProvider.Delete Method

FileObjectStoreProvider Delete Method NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Delete(
    ObjectStoreEntry entry
)
public override void Delete(
    ObjectStoreEntry entry
)
Public Overrides Sub Delete (
    entry As ObjectStoreEntry
)
Public Overrides Sub Delete (
    entry As ObjectStoreEntry
)
public:
virtual void Delete(
    ObjectStoreEntry^ entry
) override
public:
virtual void Delete(
    ObjectStoreEntry^ entry
) override
abstract Delete :
        entry : ObjectStoreEntry -> unit
override Delete :
        entry : ObjectStoreEntry -> unit
abstract Delete :
        entry : ObjectStoreEntry -> unit
override Delete :
        entry : ObjectStoreEntry -> unit

Parameters

entry
Type: NFX.ApplicationModel.Volatile ObjectStoreEntry
See Also
FileObjectStoreProvider Class
FileObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


FileObjectStoreProvider.DoConfigure Method

FileObjectStoreProvider DoConfigure Method NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
FileObjectStoreProvider Class
FileObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


FileObjectStoreProvider.DoStart Method

FileObjectStoreProvider DoStart Method NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
FileObjectStoreProvider Class
FileObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


FileObjectStoreProvider.LoadAll Method

FileObjectStoreProvider LoadAll Method NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IEnumerable<ObjectStoreEntry> LoadAll()
public override IEnumerable<ObjectStoreEntry> LoadAll()
Public Overrides Function LoadAll As IEnumerable(Of ObjectStoreEntry)
Public Overrides Function LoadAll As IEnumerable(Of ObjectStoreEntry)
public:
virtual IEnumerable<ObjectStoreEntry^>^ LoadAll() override
public:
virtual IEnumerable<ObjectStoreEntry^>^ LoadAll() override
abstract LoadAll : unit -> IEnumerable<ObjectStoreEntry>
override LoadAll : unit -> IEnumerable<ObjectStoreEntry>
abstract LoadAll : unit -> IEnumerable<ObjectStoreEntry>
override LoadAll : unit -> IEnumerable<ObjectStoreEntry>

Return Value

Type: Online IEnumerable ObjectStoreEntry
See Also
FileObjectStoreProvider Class
FileObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


FileObjectStoreProvider.Write Method

FileObjectStoreProvider Write Method NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    ObjectStoreEntry entry
)
public override void Write(
    ObjectStoreEntry entry
)
Public Overrides Sub Write (
    entry As ObjectStoreEntry
)
Public Overrides Sub Write (
    entry As ObjectStoreEntry
)
public:
virtual void Write(
    ObjectStoreEntry^ entry
) override
public:
virtual void Write(
    ObjectStoreEntry^ entry
) override
abstract Write :
        entry : ObjectStoreEntry -> unit
override Write :
        entry : ObjectStoreEntry -> unit
abstract Write :
        entry : ObjectStoreEntry -> unit
override Write :
        entry : ObjectStoreEntry -> unit

Parameters

entry
Type: NFX.ApplicationModel.Volatile ObjectStoreEntry
See Also
FileObjectStoreProvider Class
FileObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


FileObjectStoreProvider Properties

FileObjectStoreProvider Properties NFX Class Library

The FileObjectStoreProvider type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Format | Returns file format used for serialization/deserialization into/from files
Public property | LoadLimit | Imposes the limit on number of bytes that can be read from disk on load all. Once limit is exceeded the rest of objects will not load. Provider loads most recent objects first
Public property | LoadSize | Returns how many bytes have been loaded from disk
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | RootPath | Gets/sets the root path where objects are stored
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
FileObjectStoreProvider Class
NFX.ApplicationModel.Volatile Namespace


FileObjectStoreProvider.Format Property

FileObjectStoreProvider Format Property NFX Class Library

Returns file format used for serialization/deserialization into/from files

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileObjectFormat Format { get; }
public FileObjectFormat Format { get; }
Public ReadOnly Property Format As FileObjectFormat
    Get
Public ReadOnly Property Format As FileObjectFormat
    Get
public:
property FileObjectFormat Format {
    FileObjectFormat get ();
}
public:
property FileObjectFormat Format {
    FileObjectFormat get ();
}
member Format : FileObjectFormat with get
member Format : FileObjectFormat with get

Property Value

Type: FileObjectFormat
See Also
FileObjectStoreProvider Class
FileObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


FileObjectStoreProvider.LoadLimit Property

FileObjectStoreProvider LoadLimit Property NFX Class Library

Imposes the limit on number of bytes that can be read from disk on load all. Once limit is exceeded the rest of objects will not load. Provider loads most recent objects first

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long LoadLimit { get; set; }
public long LoadLimit { get; set; }
Public Property LoadLimit As Long
    Get
    Set
Public Property LoadLimit As Long
    Get
    Set
public:
property long long LoadLimit {
    long long get ();
    void set (long long value);
}
public:
property long long LoadLimit {
    long long get ();
    void set (long long value);
}
member LoadLimit : int64 with get, set
member LoadLimit : int64 with get, set

Property Value

Type: Online Int64
See Also
FileObjectStoreProvider Class
FileObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


FileObjectStoreProvider.LoadSize Property

FileObjectStoreProvider LoadSize Property NFX Class Library

Returns how many bytes have been loaded from disk

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long LoadSize { get; }
public long LoadSize { get; }
Public ReadOnly Property LoadSize As Long
    Get
Public ReadOnly Property LoadSize As Long
    Get
public:
property long long LoadSize {
    long long get ();
}
public:
property long long LoadSize {
    long long get ();
}
member LoadSize : int64 with get
member LoadSize : int64 with get

Property Value

Type: Online Int64
See Also
FileObjectStoreProvider Class
FileObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


FileObjectStoreProvider.RootPath Property

FileObjectStoreProvider RootPath Property NFX Class Library

Gets/sets the root path where objects are stored

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string RootPath { get; set; }
public string RootPath { get; set; }
Public Property RootPath As String
    Get
    Set
Public Property RootPath As String
    Get
    Set
public:
property String^ RootPath {
    String^ get ();
    void set (String^ value);
}
public:
property String^ RootPath {
    String^ get ();
    void set (String^ value);
}
member RootPath : string with get, set
member RootPath : string with get, set

Property Value

Type: Online String
See Also
FileObjectStoreProvider Class
FileObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


IObjectStore Interface

IObjectStore Interface NFX Class Library

Outlines interface for object store

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IObjectStore : IApplicationComponent,
    IDisposable, ILocalizedTimeProvider
public interface IObjectStore : IApplicationComponent,
    IDisposable, ILocalizedTimeProvider
Public Interface IObjectStore
    Inherits IApplicationComponent, IDisposable, ILocalizedTimeProvider
Public Interface IObjectStore
    Inherits IApplicationComponent, IDisposable, ILocalizedTimeProvider
public interface class IObjectStore : IApplicationComponent,
    IDisposable, ILocalizedTimeProvider
public interface class IObjectStore : IApplicationComponent,
    IDisposable, ILocalizedTimeProvider
type IObjectStore =
    interface
        interface IApplicationComponent
        interface IDisposable
        interface ILocalizedTimeProvider
    end
type IObjectStore =
    interface
        interface IApplicationComponent
        interface IDisposable
        interface ILocalizedTimeProvider
    end
See Also
IObjectStore Members
NFX.ApplicationModel.Volatile Namespace


IObjectStore Members

IObjectStore Members NFX Class Library

The IObjectStore type exposes the following members.
Methods
 | Name | Description
Public method | CheckIn(Guid, Int32) | Puts an object into store identified by the "key"
Public method | CheckIn(Guid, Object, Int32) | Puts an object reference "value" into store identified by the "key"
Public method | CheckInUnderNewKey | Puts an object reference "value" into store identified by the "oldKey" under the "newKey". If oldKey was not checked in, then checks-in under new key as normally would
Public method | CheckOut | Retrieves an object reference from the store identified by the "key" or returns null if such object does not exist. Object is not going to be persisted until it is checked back in the store.
Public method | Delete | Deletes object identified by key. Returns true when object was found and marked for deletion
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | Fetch | Retrieves an object reference from the store identified by the "key" or returns null if such object does not exist. Object is not going to be persisted as this method provides logical read-only access. If touch=true then object timestamp is updated
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | UndoCheckout | Reverts object state to Normal after the call to Checkout. This way the changes (if any) are not going to be persisted. Returns true if object was found and checkout canceled. Keep in mind: this method CAN NOT revert inner object state to its original state if it was changed, it only unmarks object as changed. This method is reentrant just like the Checkout is
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from ILocalizedTimeProvider.)
Public property | ObjectLifeSpanMS | Specifies how long objects live without being touched before becoming evicted from the list
Public property | TimeLocation | Returns the location (Inherited from ILocalizedTimeProvider.)
Back to Top
See Also
IObjectStore Interface
NFX.ApplicationModel.Volatile Namespace


IObjectStore Methods

IObjectStore Methods NFX Class Library

The IObjectStore type exposes the following members.
Methods
 | Name | Description
Public method | CheckIn(Guid, Int32) | Puts an object into store identified by the "key"
Public method | CheckIn(Guid, Object, Int32) | Puts an object reference "value" into store identified by the "key"
Public method | CheckInUnderNewKey | Puts an object reference "value" into store identified by the "oldKey" under the "newKey". If oldKey was not checked in, then checks-in under new key as normally would
Public method | CheckOut | Retrieves an object reference from the store identified by the "key" or returns null if such object does not exist. Object is not going to be persisted until it is checked back in the store.
Public method | Delete | Deletes object identified by key. Returns true when object was found and marked for deletion
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | Fetch | Retrieves an object reference from the store identified by the "key" or returns null if such object does not exist. Object is not going to be persisted as this method provides logical read-only access. If touch=true then object timestamp is updated
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | UndoCheckout | Reverts object state to Normal after the call to Checkout. This way the changes (if any) are not going to be persisted. Returns true if object was found and checkout canceled. Keep in mind: this method CAN NOT revert inner object state to its original state if it was changed, it only unmarks object as changed. This method is reentrant just like the Checkout is
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Back to Top
See Also
IObjectStore Interface
NFX.ApplicationModel.Volatile Namespace


IObjectStore.CheckIn Method

IObjectStore CheckIn Method NFX Class Library

Overload List
 | Name | Description
Public method | CheckIn(Guid, Int32) | Puts an object into store identified by the "key"
Public method | CheckIn(Guid, Object, Int32) | Puts an object reference "value" into store identified by the "key"
Back to Top
See Also
IObjectStore Interface
IObjectStore Members
NFX.ApplicationModel.Volatile Namespace


IObjectStore.CheckIn Method (Guid, Int32)

IObjectStore CheckIn Method (Guid, Int32) NFX Class Library

Puts an object into store identified by the "key"

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool CheckIn(
    Guid key,
    int msTimeout = 0
)
bool CheckIn(
    Guid key,
    int msTimeout = 0
)
Function CheckIn (
    key As Guid,
    Optional msTimeout As Integer = 0
) As Boolean
Function CheckIn (
    key As Guid,
    Optional msTimeout As Integer = 0
) As Boolean
bool CheckIn(
    Guid key,
    int msTimeout = 0
)
bool CheckIn(
    Guid key,
    int msTimeout = 0
)
abstract CheckIn :
        key : Guid *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> bool
abstract CheckIn :
        key : Guid *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> bool

Parameters

key
Type: Online System Guid
msTimeout (Optional)
Type: Online System Int32

Return Value

Type: Online Boolean
See Also
IObjectStore Interface
IObjectStore Members
CheckIn Overload
NFX.ApplicationModel.Volatile Namespace


IObjectStore.CheckIn Method (Guid, Object, Int32)

IObjectStore CheckIn Method (Guid, Object, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Puts an object reference "value" into store identified by the "key"

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void CheckIn(
    Guid key,
    Object value,
    int msTimeout = 0
)
void CheckIn(
    Guid key,
    Object value,
    int msTimeout = 0
)
Sub CheckIn (
    key As Guid,
    value As Object,
    Optional msTimeout As Integer = 0
)
Sub CheckIn (
    key As Guid,
    value As Object,
    Optional msTimeout As Integer = 0
)
void CheckIn(
    Guid key,
    Object^ value,
    int msTimeout = 0
)
void CheckIn(
    Guid key,
    Object^ value,
    int msTimeout = 0
)
abstract CheckIn :
        key : Guid *
        value : Object *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> unit
abstract CheckIn :
        key : Guid *
        value : Object *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> unit

Parameters

key
Type: Online System Guid
value
Type: Online System Object
msTimeout (Optional)
Type: Online System Int32
See Also
IObjectStore Interface
IObjectStore Members
CheckIn Overload
NFX.ApplicationModel.Volatile Namespace


IObjectStore.CheckInUnderNewKey Method

IObjectStore CheckInUnderNewKey Method NFX Class Library

Puts an object reference "value" into store identified by the "oldKey" under the "newKey". If oldKey was not checked in, then checks-in under new key as normally would

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void CheckInUnderNewKey(
    Guid oldKey,
    Guid newKey,
    Object value,
    int msTimeout = 0
)
void CheckInUnderNewKey(
    Guid oldKey,
    Guid newKey,
    Object value,
    int msTimeout = 0
)
Sub CheckInUnderNewKey (
    oldKey As Guid,
    newKey As Guid,
    value As Object,
    Optional msTimeout As Integer = 0
)
Sub CheckInUnderNewKey (
    oldKey As Guid,
    newKey As Guid,
    value As Object,
    Optional msTimeout As Integer = 0
)
void CheckInUnderNewKey(
    Guid oldKey,
    Guid newKey,
    Object^ value,
    int msTimeout = 0
)
void CheckInUnderNewKey(
    Guid oldKey,
    Guid newKey,
    Object^ value,
    int msTimeout = 0
)
abstract CheckInUnderNewKey :
        oldKey : Guid *
        newKey : Guid *
        value : Object *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> unit
abstract CheckInUnderNewKey :
        oldKey : Guid *
        newKey : Guid *
        value : Object *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> unit

Parameters

oldKey
Type: Online System Guid
newKey
Type: Online System Guid
value
Type: Online System Object
msTimeout (Optional)
Type: Online System Int32
See Also
IObjectStore Interface
IObjectStore Members
NFX.ApplicationModel.Volatile Namespace


IObjectStore.CheckOut Method

IObjectStore CheckOut Method NFX Class Library

Retrieves an object reference from the store identified by the "key" or returns null if such object does not exist. Object is not going to be persisted until it is checked back in the store.

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object CheckOut(
    Guid key
)
Object CheckOut(
    Guid key
)
Function CheckOut (
    key As Guid
) As Object
Function CheckOut (
    key As Guid
) As Object
Object^ CheckOut(
    Guid key
)
Object^ CheckOut(
    Guid key
)
abstract CheckOut :
        key : Guid -> Object
abstract CheckOut :
        key : Guid -> Object

Parameters

key
Type: Online System Guid

Return Value

Type: Online Object
See Also
IObjectStore Interface
IObjectStore Members
NFX.ApplicationModel.Volatile Namespace


IObjectStore.Delete Method

IObjectStore Delete Method NFX Class Library

Deletes object identified by key. Returns true when object was found and marked for deletion

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Delete(
    Guid key
)
bool Delete(
    Guid key
)
Function Delete (
    key As Guid
) As Boolean
Function Delete (
    key As Guid
) As Boolean
bool Delete(
    Guid key
)
bool Delete(
    Guid key
)
abstract Delete :
        key : Guid -> bool
abstract Delete :
        key : Guid -> bool

Parameters

key
Type: Online System Guid

Return Value

Type: Online Boolean
See Also
IObjectStore Interface
IObjectStore Members
NFX.ApplicationModel.Volatile Namespace


IObjectStore.Fetch Method

IObjectStore Fetch Method NFX Class Library

Retrieves an object reference from the store identified by the "key" or returns null if such object does not exist. Object is not going to be persisted as this method provides logical read-only access. If touch=true then object timestamp is updated

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object Fetch(
    Guid key,
    bool touch = false
)
Object Fetch(
    Guid key,
    bool touch = false
)
Function Fetch (
    key As Guid,
    Optional touch As Boolean = false
) As Object
Function Fetch (
    key As Guid,
    Optional touch As Boolean = false
) As Object
Object^ Fetch(
    Guid key,
    bool touch = false
)
Object^ Fetch(
    Guid key,
    bool touch = false
)
abstract Fetch :
        key : Guid *
        ?touch : bool
(* Defaults:
        let _touch = defaultArg touch false
*)
-> Object
abstract Fetch :
        key : Guid *
        ?touch : bool
(* Defaults:
        let _touch = defaultArg touch false
*)
-> Object

Parameters

key
Type: Online System Guid
touch (Optional)
Type: Online System Boolean

Return Value

Type: Online Object
See Also
IObjectStore Interface
IObjectStore Members
NFX.ApplicationModel.Volatile Namespace


IObjectStore.UndoCheckout Method

IObjectStore UndoCheckout Method NFX Class Library

Reverts object state to Normal after the call to Checkout. This way the changes (if any) are not going to be persisted. Returns true if object was found and checkout canceled. Keep in mind: this method CAN NOT revert inner object state to its original state if it was changed, it only unmarks object as changed. This method is reentrant just like the Checkout is

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool UndoCheckout(
    Guid key
)
bool UndoCheckout(
    Guid key
)
Function UndoCheckout (
    key As Guid
) As Boolean
Function UndoCheckout (
    key As Guid
) As Boolean
bool UndoCheckout(
    Guid key
)
bool UndoCheckout(
    Guid key
)
abstract UndoCheckout :
        key : Guid -> bool
abstract UndoCheckout :
        key : Guid -> bool

Parameters

key
Type: Online System Guid

Return Value

Type: Online Boolean
See Also
IObjectStore Interface
IObjectStore Members
NFX.ApplicationModel.Volatile Namespace


IObjectStore Properties

IObjectStore Properties NFX Class Library

The IObjectStore type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from ILocalizedTimeProvider.)
Public property | ObjectLifeSpanMS | Specifies how long objects live without being touched before becoming evicted from the list
Public property | TimeLocation | Returns the location (Inherited from ILocalizedTimeProvider.)
Back to Top
See Also
IObjectStore Interface
NFX.ApplicationModel.Volatile Namespace


IObjectStore.ObjectLifeSpanMS Property

IObjectStore ObjectLifeSpanMS Property NFX Class Library

Specifies how long objects live without being touched before becoming evicted from the list

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int ObjectLifeSpanMS { get; }
int ObjectLifeSpanMS { get; }
ReadOnly Property ObjectLifeSpanMS As Integer
    Get
ReadOnly Property ObjectLifeSpanMS As Integer
    Get
property int ObjectLifeSpanMS {
    int get ();
}
property int ObjectLifeSpanMS {
    int get ();
}
abstract ObjectLifeSpanMS : int with get
abstract ObjectLifeSpanMS : int with get

Property Value

Type: Online Int32
See Also
IObjectStore Interface
IObjectStore Members
NFX.ApplicationModel.Volatile Namespace


IObjectStoreImplementation Interface

IObjectStoreImplementation Interface NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IObjectStoreImplementation : IObjectStore,
    IApplicationComponent, ILocalizedTimeProvider, IDisposable, IConfigurable, IInstrumentable,
    IExternallyParameterized
public interface IObjectStoreImplementation : IObjectStore,
    IApplicationComponent, ILocalizedTimeProvider, IDisposable, IConfigurable, IInstrumentable,
    IExternallyParameterized
Public Interface IObjectStoreImplementation
    Inherits IObjectStore, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
Public Interface IObjectStoreImplementation
    Inherits IObjectStore, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
public interface class IObjectStoreImplementation : IObjectStore,
    IApplicationComponent, ILocalizedTimeProvider, IDisposable, IConfigurable, IInstrumentable,
    IExternallyParameterized
public interface class IObjectStoreImplementation : IObjectStore,
    IApplicationComponent, ILocalizedTimeProvider, IDisposable, IConfigurable, IInstrumentable,
    IExternallyParameterized
type IObjectStoreImplementation =
    interface
        interface IObjectStore
        interface IApplicationComponent
        interface ILocalizedTimeProvider
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
type IObjectStoreImplementation =
    interface
        interface IObjectStore
        interface IApplicationComponent
        interface ILocalizedTimeProvider
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
IObjectStoreImplementation Members
NFX.ApplicationModel.Volatile Namespace


IObjectStoreImplementation Members

IObjectStoreImplementation Members NFX Class Library

The IObjectStoreImplementation type exposes the following members.
Methods
 | Name | Description
Public method | CheckIn(Guid, Int32) | Puts an object into store identified by the "key" (Inherited from IObjectStore.)
Public method | CheckIn(Guid, Object, Int32) | Puts an object reference "value" into store identified by the "key" (Inherited from IObjectStore.)
Public method | CheckInUnderNewKey | Puts an object reference "value" into store identified by the "oldKey" under the "newKey". If oldKey was not checked in, then checks-in under new key as normally would (Inherited from IObjectStore.)
Public method | CheckOut | Retrieves an object reference from the store identified by the "key" or returns null if such object does not exist. Object is not going to be persisted until it is checked back in the store. (Inherited from IObjectStore.)
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Delete | Deletes object identified by key. Returns true when object was found and marked for deletion (Inherited from IObjectStore.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Public method | Fetch | Retrieves an object reference from the store identified by the "key" or returns null if such object does not exist. Object is not going to be persisted as this method provides logical read-only access. If touch=true then object timestamp is updated (Inherited from IObjectStore.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | UndoCheckout | Reverts object state to Normal after the call to Checkout. This way the changes (if any) are not going to be persisted. Returns true if object was found and checkout canceled. Keep in mind: this method CAN NOT revert inner object state to its original state if it was changed, it only unmarks object as changed. This method is reentrant just like the Checkout is (Inherited from IObjectStore.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from ILocalizedTimeProvider.)
Public property | ObjectLifeSpanMS | Specifies how long objects live without being touched before becoming evicted from the list (Inherited from IObjectStore.)
Public property | TimeLocation | Returns the location (Inherited from ILocalizedTimeProvider.)
Back to Top
See Also
IObjectStoreImplementation Interface
NFX.ApplicationModel.Volatile Namespace


IObjectStoreImplementation Methods

IObjectStoreImplementation Methods NFX Class Library

The IObjectStoreImplementation type exposes the following members.
Methods
 | Name | Description
Public method | CheckIn(Guid, Int32) | Puts an object into store identified by the "key" (Inherited from IObjectStore.)
Public method | CheckIn(Guid, Object, Int32) | Puts an object reference "value" into store identified by the "key" (Inherited from IObjectStore.)
Public method | CheckInUnderNewKey | Puts an object reference "value" into store identified by the "oldKey" under the "newKey". If oldKey was not checked in, then checks-in under new key as normally would (Inherited from IObjectStore.)
Public method | CheckOut | Retrieves an object reference from the store identified by the "key" or returns null if such object does not exist. Object is not going to be persisted until it is checked back in the store. (Inherited from IObjectStore.)
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Delete | Deletes object identified by key. Returns true when object was found and marked for deletion (Inherited from IObjectStore.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Public method | Fetch | Retrieves an object reference from the store identified by the "key" or returns null if such object does not exist. Object is not going to be persisted as this method provides logical read-only access. If touch=true then object timestamp is updated (Inherited from IObjectStore.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | UndoCheckout | Reverts object state to Normal after the call to Checkout. This way the changes (if any) are not going to be persisted. Returns true if object was found and checkout canceled. Keep in mind: this method CAN NOT revert inner object state to its original state if it was changed, it only unmarks object as changed. This method is reentrant just like the Checkout is (Inherited from IObjectStore.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Back to Top
See Also
IObjectStoreImplementation Interface
NFX.ApplicationModel.Volatile Namespace


IObjectStoreImplementation Properties

IObjectStoreImplementation Properties NFX Class Library

The IObjectStoreImplementation type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from ILocalizedTimeProvider.)
Public property | ObjectLifeSpanMS | Specifies how long objects live without being touched before becoming evicted from the list (Inherited from IObjectStore.)
Public property | TimeLocation | Returns the location (Inherited from ILocalizedTimeProvider.)
Back to Top
See Also
IObjectStoreImplementation Interface
NFX.ApplicationModel.Volatile Namespace


NOPObjectStore Class

NOPObjectStore Class NFX Class Library

Implements ObjectStore service that does nothing
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ApplicationModel.Volatile NOPObjectStore

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class NOPObjectStore : ApplicationComponent,
    IObjectStore, IApplicationComponent, IDisposable, ILocalizedTimeProvider
public sealed class NOPObjectStore : ApplicationComponent,
    IObjectStore, IApplicationComponent, IDisposable, ILocalizedTimeProvider
Public NotInheritable Class NOPObjectStore
    Inherits ApplicationComponent
    Implements IObjectStore, IApplicationComponent, IDisposable, ILocalizedTimeProvider
Public NotInheritable Class NOPObjectStore
    Inherits ApplicationComponent
    Implements IObjectStore, IApplicationComponent, IDisposable, ILocalizedTimeProvider
public ref class NOPObjectStore sealed : public ApplicationComponent,
    IObjectStore, IApplicationComponent, IDisposable, ILocalizedTimeProvider
public ref class NOPObjectStore sealed : public ApplicationComponent,
    IObjectStore, IApplicationComponent, IDisposable, ILocalizedTimeProvider
[<SealedAttribute>]
type NOPObjectStore =
    class
        inherit ApplicationComponent
        interface IObjectStore
        interface IApplicationComponent
        interface IDisposable
        interface ILocalizedTimeProvider
    end
[<SealedAttribute>]
type NOPObjectStore =
    class
        inherit ApplicationComponent
        interface IObjectStore
        interface IApplicationComponent
        interface IDisposable
        interface ILocalizedTimeProvider
    end
See Also
NOPObjectStore Members
NFX.ApplicationModel.Volatile Namespace


NOPObjectStore Members

NOPObjectStore Members NFX Class Library

The NOPObjectStore type exposes the following members.
Constructors
 | Name | Description
Public method | NOPObjectStore | Initializes a new instance of the NOPObjectStore class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | CheckIn(Guid, Int32) | Puts an object reference "value" into store identified by the "key"
Public method | CheckIn(Guid, Object, Int32) | Puts an object reference "value" into store identified by the "key"
Public method | CheckInUnderNewKey | Puts an object reference "value" into store identified by the "oldKey" under the "newKey". If oldKey was not checked in, then checks-in under new key as normally would
Public method | CheckOut | Retrieves an object reference from the store identified by the "key" or returns null if such object does not exist. Object is not going to be persisted until it is checked back in the store.
Public method | Delete | Deletes object identified by key. Returns true when object was found and marked for deletion
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Fetch |
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UndoCheckout | Reverts object state to Normal after the call to Checkout. This way the changes (if any) are not going to be persisted. Returns true if object was found and checkout canceled. Keep in mind: this method CAN NOT revert inner object state to its original state if it was changed, it only unmarks object as changed. This method is reentrant just like the Checkout is
Public method | UniversalTimeToLocalizedTime |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
 | Instance | Returns a singlelton instance of the objectstore that does not do anything
Public property | LocalizedTime |
Public property | ObjectLifeSpanMS |
Public property | TimeLocation |
Back to Top
See Also
NOPObjectStore Class
NFX.ApplicationModel.Volatile Namespace


NOPObjectStore Constructor

NOPObjectStore Constructor NFX Class Library

Initializes a new instance of the NOPObjectStore class

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NOPObjectStore()
public NOPObjectStore()
Public Sub New
Public Sub New
public:
NOPObjectStore()
public:
NOPObjectStore()
new : unit -> NOPObjectStore
new : unit -> NOPObjectStore
See Also
NOPObjectStore Class
NOPObjectStore Members
NFX.ApplicationModel.Volatile Namespace


NOPObjectStore Methods

NOPObjectStore Methods NFX Class Library

The NOPObjectStore type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | CheckIn(Guid, Int32) | Puts an object reference "value" into store identified by the "key"
Public method | CheckIn(Guid, Object, Int32) | Puts an object reference "value" into store identified by the "key"
Public method | CheckInUnderNewKey | Puts an object reference "value" into store identified by the "oldKey" under the "newKey". If oldKey was not checked in, then checks-in under new key as normally would
Public method | CheckOut | Retrieves an object reference from the store identified by the "key" or returns null if such object does not exist. Object is not going to be persisted until it is checked back in the store.
Public method | Delete | Deletes object identified by key. Returns true when object was found and marked for deletion
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Fetch |
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UndoCheckout | Reverts object state to Normal after the call to Checkout. This way the changes (if any) are not going to be persisted. Returns true if object was found and checkout canceled. Keep in mind: this method CAN NOT revert inner object state to its original state if it was changed, it only unmarks object as changed. This method is reentrant just like the Checkout is
Public method | UniversalTimeToLocalizedTime |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NOPObjectStore Class
NFX.ApplicationModel.Volatile Namespace


NOPObjectStore.CheckIn Method

NOPObjectStore CheckIn Method NFX Class Library

Overload List
 | Name | Description
Public method | CheckIn(Guid, Int32) | Puts an object reference "value" into store identified by the "key"
Public method | CheckIn(Guid, Object, Int32) | Puts an object reference "value" into store identified by the "key"
Back to Top
See Also
NOPObjectStore Class
NOPObjectStore Members
NFX.ApplicationModel.Volatile Namespace


NOPObjectStore.CheckIn Method (Guid, Int32)

NOPObjectStore CheckIn Method (Guid, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Puts an object reference "value" into store identified by the "key"

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool CheckIn(
    Guid key,
    int msTimeout = 0
)
public bool CheckIn(
    Guid key,
    int msTimeout = 0
)
Public Function CheckIn (
    key As Guid,
    Optional msTimeout As Integer = 0
) As Boolean
Public Function CheckIn (
    key As Guid,
    Optional msTimeout As Integer = 0
) As Boolean
public:
virtual bool CheckIn(
    Guid key,
    int msTimeout = 0
) sealed
public:
virtual bool CheckIn(
    Guid key,
    int msTimeout = 0
) sealed
abstract CheckIn :
        key : Guid *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> bool
override CheckIn :
        key : Guid *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> bool
abstract CheckIn :
        key : Guid *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> bool
override CheckIn :
        key : Guid *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> bool

Parameters

key
Type: Online System Guid
msTimeout (Optional)
Type: Online System Int32

Return Value

Type: Online Boolean

Implements

IObjectStore CheckIn(Guid, Int32)
See Also
NOPObjectStore Class
NOPObjectStore Members
CheckIn Overload
NFX.ApplicationModel.Volatile Namespace


NOPObjectStore.CheckIn Method (Guid, Object, Int32)

NOPObjectStore CheckIn Method (Guid, Object, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Puts an object reference "value" into store identified by the "key"

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CheckIn(
    Guid key,
    Object value,
    int msTimeout = 0
)
public void CheckIn(
    Guid key,
    Object value,
    int msTimeout = 0
)
Public Sub CheckIn (
    key As Guid,
    value As Object,
    Optional msTimeout As Integer = 0
)
Public Sub CheckIn (
    key As Guid,
    value As Object,
    Optional msTimeout As Integer = 0
)
public:
virtual void CheckIn(
    Guid key,
    Object^ value,
    int msTimeout = 0
) sealed
public:
virtual void CheckIn(
    Guid key,
    Object^ value,
    int msTimeout = 0
) sealed
abstract CheckIn :
        key : Guid *
        value : Object *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> unit
override CheckIn :
        key : Guid *
        value : Object *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> unit
abstract CheckIn :
        key : Guid *
        value : Object *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> unit
override CheckIn :
        key : Guid *
        value : Object *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> unit

Parameters

key
Type: Online System Guid
value
Type: Online System Object
msTimeout (Optional)
Type: Online System Int32

Implements

IObjectStore CheckIn(Guid, Object, Int32)
See Also
NOPObjectStore Class
NOPObjectStore Members
CheckIn Overload
NFX.ApplicationModel.Volatile Namespace


NOPObjectStore.CheckInUnderNewKey Method

NOPObjectStore CheckInUnderNewKey Method NFX Class Library

Puts an object reference "value" into store identified by the "oldKey" under the "newKey". If oldKey was not checked in, then checks-in under new key as normally would

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CheckInUnderNewKey(
    Guid oldKey,
    Guid newKey,
    Object value,
    int msTimeout = 0
)
public void CheckInUnderNewKey(
    Guid oldKey,
    Guid newKey,
    Object value,
    int msTimeout = 0
)
Public Sub CheckInUnderNewKey (
    oldKey As Guid,
    newKey As Guid,
    value As Object,
    Optional msTimeout As Integer = 0
)
Public Sub CheckInUnderNewKey (
    oldKey As Guid,
    newKey As Guid,
    value As Object,
    Optional msTimeout As Integer = 0
)
public:
virtual void CheckInUnderNewKey(
    Guid oldKey,
    Guid newKey,
    Object^ value,
    int msTimeout = 0
) sealed
public:
virtual void CheckInUnderNewKey(
    Guid oldKey,
    Guid newKey,
    Object^ value,
    int msTimeout = 0
) sealed
abstract CheckInUnderNewKey :
        oldKey : Guid *
        newKey : Guid *
        value : Object *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> unit
override CheckInUnderNewKey :
        oldKey : Guid *
        newKey : Guid *
        value : Object *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> unit
abstract CheckInUnderNewKey :
        oldKey : Guid *
        newKey : Guid *
        value : Object *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> unit
override CheckInUnderNewKey :
        oldKey : Guid *
        newKey : Guid *
        value : Object *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> unit

Parameters

oldKey
Type: Online System Guid
newKey
Type: Online System Guid
value
Type: Online System Object
msTimeout (Optional)
Type: Online System Int32

Implements

IObjectStore CheckInUnderNewKey(Guid, Guid, Object, Int32)
See Also
NOPObjectStore Class
NOPObjectStore Members
NFX.ApplicationModel.Volatile Namespace


NOPObjectStore.CheckOut Method

NOPObjectStore CheckOut Method NFX Class Library

Retrieves an object reference from the store identified by the "key" or returns null if such object does not exist. Object is not going to be persisted until it is checked back in the store.

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object CheckOut(
    Guid key
)
public Object CheckOut(
    Guid key
)
Public Function CheckOut (
    key As Guid
) As Object
Public Function CheckOut (
    key As Guid
) As Object
public:
virtual Object^ CheckOut(
    Guid key
) sealed
public:
virtual Object^ CheckOut(
    Guid key
) sealed
abstract CheckOut :
        key : Guid -> Object
override CheckOut :
        key : Guid -> Object
abstract CheckOut :
        key : Guid -> Object
override CheckOut :
        key : Guid -> Object

Parameters

key
Type: Online System Guid

Return Value

Type: Online Object

Implements

IObjectStore CheckOut(Guid)
See Also
NOPObjectStore Class
NOPObjectStore Members
NFX.ApplicationModel.Volatile Namespace


NOPObjectStore.Delete Method

NOPObjectStore Delete Method NFX Class Library

Deletes object identified by key. Returns true when object was found and marked for deletion

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Delete(
    Guid key
)
public bool Delete(
    Guid key
)
Public Function Delete (
    key As Guid
) As Boolean
Public Function Delete (
    key As Guid
) As Boolean
public:
virtual bool Delete(
    Guid key
) sealed
public:
virtual bool Delete(
    Guid key
) sealed
abstract Delete :
        key : Guid -> bool
override Delete :
        key : Guid -> bool
abstract Delete :
        key : Guid -> bool
override Delete :
        key : Guid -> bool

Parameters

key
Type: Online System Guid

Return Value

Type: Online Boolean

Implements

IObjectStore Delete(Guid)
See Also
NOPObjectStore Class
NOPObjectStore Members
NFX.ApplicationModel.Volatile Namespace


NOPObjectStore.Fetch Method

NOPObjectStore Fetch Method NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Fetch(
    Guid key,
    bool touch = false
)
public Object Fetch(
    Guid key,
    bool touch = false
)
Public Function Fetch (
    key As Guid,
    Optional touch As Boolean = false
) As Object
Public Function Fetch (
    key As Guid,
    Optional touch As Boolean = false
) As Object
public:
virtual Object^ Fetch(
    Guid key,
    bool touch = false
) sealed
public:
virtual Object^ Fetch(
    Guid key,
    bool touch = false
) sealed
abstract Fetch :
        key : Guid *
        ?touch : bool
(* Defaults:
        let _touch = defaultArg touch false
*)
-> Object
override Fetch :
        key : Guid *
        ?touch : bool
(* Defaults:
        let _touch = defaultArg touch false
*)
-> Object
abstract Fetch :
        key : Guid *
        ?touch : bool
(* Defaults:
        let _touch = defaultArg touch false
*)
-> Object
override Fetch :
        key : Guid *
        ?touch : bool
(* Defaults:
        let _touch = defaultArg touch false
*)
-> Object

Parameters

key
Type: Online System Guid
touch (Optional)
Type: Online System Boolean

Return Value

Type: Online Object

Implements

IObjectStore Fetch(Guid, Boolean)
See Also
NOPObjectStore Class
NOPObjectStore Members
NFX.ApplicationModel.Volatile Namespace


NOPObjectStore.LocalizedTimeToUniversalTime Method

NOPObjectStore LocalizedTimeToUniversalTime Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
public DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
Public Function LocalizedTimeToUniversalTime (
    local As DateTime
) As DateTime
Public Function LocalizedTimeToUniversalTime (
    local As DateTime
) As DateTime
public:
virtual DateTime LocalizedTimeToUniversalTime(
    DateTime local
) sealed
public:
virtual DateTime LocalizedTimeToUniversalTime(
    DateTime local
) sealed
abstract LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
override LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
abstract LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
override LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime

Parameters

local
Type: Online System DateTime

Return Value

Type: Online DateTime

Implements

ILocalizedTimeProvider LocalizedTimeToUniversalTime(DateTime)
See Also
NOPObjectStore Class
NOPObjectStore Members
NFX.ApplicationModel.Volatile Namespace


NOPObjectStore.UndoCheckout Method

NOPObjectStore UndoCheckout Method NFX Class Library

Reverts object state to Normal after the call to Checkout. This way the changes (if any) are not going to be persisted. Returns true if object was found and checkout canceled. Keep in mind: this method CAN NOT revert inner object state to its original state if it was changed, it only unmarks object as changed. This method is reentrant just like the Checkout is

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool UndoCheckout(
    Guid key
)
public bool UndoCheckout(
    Guid key
)
Public Function UndoCheckout (
    key As Guid
) As Boolean
Public Function UndoCheckout (
    key As Guid
) As Boolean
public:
virtual bool UndoCheckout(
    Guid key
) sealed
public:
virtual bool UndoCheckout(
    Guid key
) sealed
abstract UndoCheckout :
        key : Guid -> bool
override UndoCheckout :
        key : Guid -> bool
abstract UndoCheckout :
        key : Guid -> bool
override UndoCheckout :
        key : Guid -> bool

Parameters

key
Type: Online System Guid

Return Value

Type: Online Boolean

Implements

IObjectStore UndoCheckout(Guid)
See Also
NOPObjectStore Class
NOPObjectStore Members
NFX.ApplicationModel.Volatile Namespace


NOPObjectStore.UniversalTimeToLocalizedTime Method

NOPObjectStore UniversalTimeToLocalizedTime Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
public DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
Public Function UniversalTimeToLocalizedTime (
    utc As DateTime
) As DateTime
Public Function UniversalTimeToLocalizedTime (
    utc As DateTime
) As DateTime
public:
virtual DateTime UniversalTimeToLocalizedTime(
    DateTime utc
) sealed
public:
virtual DateTime UniversalTimeToLocalizedTime(
    DateTime utc
) sealed
abstract UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
override UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
abstract UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
override UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime

Parameters

utc
Type: Online System DateTime

Return Value

Type: Online DateTime

Implements

ILocalizedTimeProvider UniversalTimeToLocalizedTime(DateTime)
See Also
NOPObjectStore Class
NOPObjectStore Members
NFX.ApplicationModel.Volatile Namespace


NOPObjectStore Properties

NOPObjectStore Properties NFX Class Library

The NOPObjectStore type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
 | Instance | Returns a singlelton instance of the objectstore that does not do anything
Public property | LocalizedTime |
Public property | ObjectLifeSpanMS |
Public property | TimeLocation |
Back to Top
See Also
NOPObjectStore Class
NFX.ApplicationModel.Volatile Namespace


NOPObjectStore.Instance Property

NOPObjectStore Instance Property NFX Class Library

Returns a singlelton instance of the objectstore that does not do anything

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NOPObjectStore Instance { get; }
public static NOPObjectStore Instance { get; }
Public Shared ReadOnly Property Instance As NOPObjectStore
    Get
Public Shared ReadOnly Property Instance As NOPObjectStore
    Get
public:
static property NOPObjectStore^ Instance {
    NOPObjectStore^ get ();
}
public:
static property NOPObjectStore^ Instance {
    NOPObjectStore^ get ();
}
static member Instance : NOPObjectStore with get
static member Instance : NOPObjectStore with get

Property Value

Type: NOPObjectStore
See Also
NOPObjectStore Class
NOPObjectStore Members
NFX.ApplicationModel.Volatile Namespace


NOPObjectStore.LocalizedTime Property

NOPObjectStore LocalizedTime Property NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime LocalizedTime { get; }
public DateTime LocalizedTime { get; }
Public ReadOnly Property LocalizedTime As DateTime
    Get
Public ReadOnly Property LocalizedTime As DateTime
    Get
public:
virtual property DateTime LocalizedTime {
    DateTime get () sealed;
}
public:
virtual property DateTime LocalizedTime {
    DateTime get () sealed;
}
abstract LocalizedTime : DateTime with get
override LocalizedTime : DateTime with get
abstract LocalizedTime : DateTime with get
override LocalizedTime : DateTime with get

Property Value

Type: Online DateTime

Implements

ILocalizedTimeProvider LocalizedTime
See Also
NOPObjectStore Class
NOPObjectStore Members
NFX.ApplicationModel.Volatile Namespace


NOPObjectStore.ObjectLifeSpanMS Property

NOPObjectStore ObjectLifeSpanMS Property NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ObjectLifeSpanMS { get; }
public int ObjectLifeSpanMS { get; }
Public ReadOnly Property ObjectLifeSpanMS As Integer
    Get
Public ReadOnly Property ObjectLifeSpanMS As Integer
    Get
public:
virtual property int ObjectLifeSpanMS {
    int get () sealed;
}
public:
virtual property int ObjectLifeSpanMS {
    int get () sealed;
}
abstract ObjectLifeSpanMS : int with get
override ObjectLifeSpanMS : int with get
abstract ObjectLifeSpanMS : int with get
override ObjectLifeSpanMS : int with get

Property Value

Type: Online Int32

Implements

IObjectStore ObjectLifeSpanMS
See Also
NOPObjectStore Class
NOPObjectStore Members
NFX.ApplicationModel.Volatile Namespace


NOPObjectStore.TimeLocation Property

NOPObjectStore TimeLocation Property NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeLocation TimeLocation { get; }
public TimeLocation TimeLocation { get; }
Public ReadOnly Property TimeLocation As TimeLocation
    Get
Public ReadOnly Property TimeLocation As TimeLocation
    Get
public:
virtual property TimeLocation^ TimeLocation {
    TimeLocation^ get () sealed;
}
public:
virtual property TimeLocation^ TimeLocation {
    TimeLocation^ get () sealed;
}
abstract TimeLocation : TimeLocation with get
override TimeLocation : TimeLocation with get
abstract TimeLocation : TimeLocation with get
override TimeLocation : TimeLocation with get

Property Value

Type: TimeLocation

Implements

ILocalizedTimeProvider TimeLocation
See Also
NOPObjectStore Class
NOPObjectStore Members
NFX.ApplicationModel.Volatile Namespace


NOPObjectStoreProvider Class

NOPObjectStoreProvider Class NFX Class Library

Defines a provider that does not do anything - does not store object anywhere but memory
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service ObjectStoreService
NFX.ApplicationModel.Volatile ObjectStoreProvider
NFX.ApplicationModel.Volatile NOPObjectStoreProvider

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NOPObjectStoreProvider : ObjectStoreProvider
public class NOPObjectStoreProvider : ObjectStoreProvider
Public Class NOPObjectStoreProvider
    Inherits ObjectStoreProvider
Public Class NOPObjectStoreProvider
    Inherits ObjectStoreProvider
public ref class NOPObjectStoreProvider : public ObjectStoreProvider
public ref class NOPObjectStoreProvider : public ObjectStoreProvider
type NOPObjectStoreProvider =
    class
        inherit ObjectStoreProvider
    end
type NOPObjectStoreProvider =
    class
        inherit ObjectStoreProvider
    end
See Also
NOPObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


NOPObjectStoreProvider Members

NOPObjectStoreProvider Members NFX Class Library

The NOPObjectStoreProvider type exposes the following members.
Constructors
 | Name | Description
Public method | NOPObjectStoreProvider | Initializes a new instance of the NOPObjectStoreProvider class
Public method | NOPObjectStoreProvider(ObjectStoreService) | Initializes a new instance of the NOPObjectStoreProvider class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Public method | Delete | (Overrides ObjectStoreProvider Delete(ObjectStoreEntry).)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Inherited from ObjectStoreProvider.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LoadAll | (Overrides ObjectStoreProvider LoadAll .)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | Write | (Overrides ObjectStoreProvider Write(ObjectStoreEntry).)
Protected method | WriteLog | (Inherited from ObjectStoreProvider.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
NOPObjectStoreProvider Class
NFX.ApplicationModel.Volatile Namespace


NOPObjectStoreProvider Constructor

NOPObjectStoreProvider Constructor NFX Class Library

Overload List
 | Name | Description
Public method | NOPObjectStoreProvider | Initializes a new instance of the NOPObjectStoreProvider class
Public method | NOPObjectStoreProvider(ObjectStoreService) | Initializes a new instance of the NOPObjectStoreProvider class
Back to Top
See Also
NOPObjectStoreProvider Class
NOPObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


NOPObjectStoreProvider Constructor

NOPObjectStoreProvider Constructor NFX Class Library

Initializes a new instance of the NOPObjectStoreProvider class

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NOPObjectStoreProvider()
public NOPObjectStoreProvider()
Public Sub New
Public Sub New
public:
NOPObjectStoreProvider()
public:
NOPObjectStoreProvider()
new : unit -> NOPObjectStoreProvider
new : unit -> NOPObjectStoreProvider
See Also
NOPObjectStoreProvider Class
NOPObjectStoreProvider Members
NOPObjectStoreProvider Overload
NFX.ApplicationModel.Volatile Namespace


NOPObjectStoreProvider Constructor (ObjectStoreService)

NOPObjectStoreProvider Constructor (ObjectStoreService) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NOPObjectStoreProvider class

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NOPObjectStoreProvider(
    ObjectStoreService director
)
public NOPObjectStoreProvider(
    ObjectStoreService director
)
Public Sub New (
    director As ObjectStoreService
)
Public Sub New (
    director As ObjectStoreService
)
public:
NOPObjectStoreProvider(
    ObjectStoreService^ director
)
public:
NOPObjectStoreProvider(
    ObjectStoreService^ director
)
new :
        director : ObjectStoreService -> NOPObjectStoreProvider
new :
        director : ObjectStoreService -> NOPObjectStoreProvider

Parameters

director
Type: NFX.ApplicationModel.Volatile ObjectStoreService
See Also
NOPObjectStoreProvider Class
NOPObjectStoreProvider Members
NOPObjectStoreProvider Overload
NFX.ApplicationModel.Volatile Namespace


NOPObjectStoreProvider Methods

NOPObjectStoreProvider Methods NFX Class Library

The NOPObjectStoreProvider type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Public method | Delete | (Overrides ObjectStoreProvider Delete(ObjectStoreEntry).)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Inherited from ObjectStoreProvider.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LoadAll | (Overrides ObjectStoreProvider LoadAll .)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | Write | (Overrides ObjectStoreProvider Write(ObjectStoreEntry).)
Protected method | WriteLog | (Inherited from ObjectStoreProvider.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NOPObjectStoreProvider Class
NFX.ApplicationModel.Volatile Namespace


NOPObjectStoreProvider.Delete Method

NOPObjectStoreProvider Delete Method NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Delete(
    ObjectStoreEntry entry
)
public override void Delete(
    ObjectStoreEntry entry
)
Public Overrides Sub Delete (
    entry As ObjectStoreEntry
)
Public Overrides Sub Delete (
    entry As ObjectStoreEntry
)
public:
virtual void Delete(
    ObjectStoreEntry^ entry
) override
public:
virtual void Delete(
    ObjectStoreEntry^ entry
) override
abstract Delete :
        entry : ObjectStoreEntry -> unit
override Delete :
        entry : ObjectStoreEntry -> unit
abstract Delete :
        entry : ObjectStoreEntry -> unit
override Delete :
        entry : ObjectStoreEntry -> unit

Parameters

entry
Type: NFX.ApplicationModel.Volatile ObjectStoreEntry
See Also
NOPObjectStoreProvider Class
NOPObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


NOPObjectStoreProvider.LoadAll Method

NOPObjectStoreProvider LoadAll Method NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IEnumerable<ObjectStoreEntry> LoadAll()
public override IEnumerable<ObjectStoreEntry> LoadAll()
Public Overrides Function LoadAll As IEnumerable(Of ObjectStoreEntry)
Public Overrides Function LoadAll As IEnumerable(Of ObjectStoreEntry)
public:
virtual IEnumerable<ObjectStoreEntry^>^ LoadAll() override
public:
virtual IEnumerable<ObjectStoreEntry^>^ LoadAll() override
abstract LoadAll : unit -> IEnumerable<ObjectStoreEntry>
override LoadAll : unit -> IEnumerable<ObjectStoreEntry>
abstract LoadAll : unit -> IEnumerable<ObjectStoreEntry>
override LoadAll : unit -> IEnumerable<ObjectStoreEntry>

Return Value

Type: Online IEnumerable ObjectStoreEntry
See Also
NOPObjectStoreProvider Class
NOPObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


NOPObjectStoreProvider.Write Method

NOPObjectStoreProvider Write Method NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    ObjectStoreEntry entry
)
public override void Write(
    ObjectStoreEntry entry
)
Public Overrides Sub Write (
    entry As ObjectStoreEntry
)
Public Overrides Sub Write (
    entry As ObjectStoreEntry
)
public:
virtual void Write(
    ObjectStoreEntry^ entry
) override
public:
virtual void Write(
    ObjectStoreEntry^ entry
) override
abstract Write :
        entry : ObjectStoreEntry -> unit
override Write :
        entry : ObjectStoreEntry -> unit
abstract Write :
        entry : ObjectStoreEntry -> unit
override Write :
        entry : ObjectStoreEntry -> unit

Parameters

entry
Type: NFX.ApplicationModel.Volatile ObjectStoreEntry
See Also
NOPObjectStoreProvider Class
NOPObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


NOPObjectStoreProvider Properties

NOPObjectStoreProvider Properties NFX Class Library

The NOPObjectStoreProvider type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
NOPObjectStoreProvider Class
NFX.ApplicationModel.Volatile Namespace


ObjectStoreEntry Class

ObjectStoreEntry Class NFX Class Library

Internal framework class that stores data in ObjectStoreService
Inheritance Hierarchy
Online System Object
NFX.ApplicationModel.Volatile ObjectStoreEntry

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ObjectStoreEntry
public class ObjectStoreEntry
Public Class ObjectStoreEntry
Public Class ObjectStoreEntry
public ref class ObjectStoreEntry
public ref class ObjectStoreEntry
type ObjectStoreEntry =  class end
type ObjectStoreEntry =  class end
See Also
ObjectStoreEntry Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreEntry Members

ObjectStoreEntry Members NFX Class Library

The ObjectStoreEntry type exposes the following members.
Constructors
 | Name | Description
Public method | ObjectStoreEntry | Initializes a new instance of the ObjectStoreEntry class
Back to Top
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | CheckoutCount |
Public field | Key |
Public field | LastTime |
Public field | MsTimeout |
Public field | Status |
Public field | Value |
Back to Top
See Also
ObjectStoreEntry Class
NFX.ApplicationModel.Volatile Namespace


ObjectStoreEntry Constructor

ObjectStoreEntry Constructor NFX Class Library

Initializes a new instance of the ObjectStoreEntry class

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ObjectStoreEntry()
public ObjectStoreEntry()
Public Sub New
Public Sub New
public:
ObjectStoreEntry()
public:
ObjectStoreEntry()
new : unit -> ObjectStoreEntry
new : unit -> ObjectStoreEntry
See Also
ObjectStoreEntry Class
ObjectStoreEntry Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreEntry Fields

ObjectStoreEntry Fields NFX Class Library

The ObjectStoreEntry type exposes the following members.
Fields
 | Name | Description
Public field | CheckoutCount |
Public field | Key |
Public field | LastTime |
Public field | MsTimeout |
Public field | Status |
Public field | Value |
Back to Top
See Also
ObjectStoreEntry Class
NFX.ApplicationModel.Volatile Namespace


ObjectStoreEntry.CheckoutCount Field

ObjectStoreEntry CheckoutCount Field NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CheckoutCount
public int CheckoutCount
Public CheckoutCount As Integer
Public CheckoutCount As Integer
public:
int CheckoutCount
public:
int CheckoutCount
val mutable CheckoutCount: int
val mutable CheckoutCount: int

Field Value

Type: Online Int32
See Also
ObjectStoreEntry Class
ObjectStoreEntry Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreEntry.Key Field

ObjectStoreEntry Key Field NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid Key
public Guid Key
Public Key As Guid
Public Key As Guid
public:
Guid Key
public:
Guid Key
val mutable Key: Guid
val mutable Key: Guid

Field Value

Type: Online Guid
See Also
ObjectStoreEntry Class
ObjectStoreEntry Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreEntry.LastTime Field

ObjectStoreEntry LastTime Field NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime LastTime
public DateTime LastTime
Public LastTime As DateTime
Public LastTime As DateTime
public:
DateTime LastTime
public:
DateTime LastTime
val mutable LastTime: DateTime
val mutable LastTime: DateTime

Field Value

Type: Online DateTime
See Also
ObjectStoreEntry Class
ObjectStoreEntry Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreEntry.MsTimeout Field

ObjectStoreEntry MsTimeout Field NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MsTimeout
public int MsTimeout
Public MsTimeout As Integer
Public MsTimeout As Integer
public:
int MsTimeout
public:
int MsTimeout
val mutable MsTimeout: int
val mutable MsTimeout: int

Field Value

Type: Online Int32
See Also
ObjectStoreEntry Class
ObjectStoreEntry Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreEntry.Status Field

ObjectStoreEntry Status Field NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ObjectStoreEntryStatus Status
public ObjectStoreEntryStatus Status
Public Status As ObjectStoreEntryStatus
Public Status As ObjectStoreEntryStatus
public:
ObjectStoreEntryStatus Status
public:
ObjectStoreEntryStatus Status
val mutable Status: ObjectStoreEntryStatus
val mutable Status: ObjectStoreEntryStatus

Field Value

Type: ObjectStoreEntryStatus
See Also
ObjectStoreEntry Class
ObjectStoreEntry Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreEntry.Value Field

ObjectStoreEntry Value Field NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Value
public Object Value
Public Value As Object
Public Value As Object
public:
Object^ Value
public:
Object^ Value
val mutable Value: Object
val mutable Value: Object

Field Value

Type: Online Object
See Also
ObjectStoreEntry Class
ObjectStoreEntry Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreEntry Methods

ObjectStoreEntry Methods NFX Class Library

The ObjectStoreEntry type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ObjectStoreEntry Class
NFX.ApplicationModel.Volatile Namespace


ObjectStoreEntry.Equals Method

ObjectStoreEntry Equals Method NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
ObjectStoreEntry Class
ObjectStoreEntry Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreEntry.GetHashCode Method

ObjectStoreEntry GetHashCode Method NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
ObjectStoreEntry Class
ObjectStoreEntry Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreEntry.ToString Method

ObjectStoreEntry ToString Method NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
ObjectStoreEntry Class
ObjectStoreEntry Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreEntryStatus Enumeration

ObjectStoreEntryStatus Enumeration NFX Class Library

Represents status of ObjectStoreEntry

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum ObjectStoreEntryStatus
public enum ObjectStoreEntryStatus
Public Enumeration ObjectStoreEntryStatus
Public Enumeration ObjectStoreEntryStatus
public enum class ObjectStoreEntryStatus
public enum class ObjectStoreEntryStatus
type ObjectStoreEntryStatus
type ObjectStoreEntryStatus
Members
Member name | Value | Description
Normal | 0 |
CheckedOut | 1 |
ChekedIn | 2 |
Deleted | 3 |
See Also
NFX.ApplicationModel.Volatile Namespace


ObjectStoreProvider Class

ObjectStoreProvider Class NFX Class Library

Defines a base provider that stores objects for ObjectStoreService class
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service ObjectStoreService
NFX.ApplicationModel.Volatile ObjectStoreProvider
NFX.ApplicationModel.Volatile FileObjectStoreProvider
NFX.ApplicationModel.Volatile NOPObjectStoreProvider

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class ObjectStoreProvider : Service<ObjectStoreService>
public abstract class ObjectStoreProvider : Service<ObjectStoreService>
Public MustInherit Class ObjectStoreProvider
    Inherits Service(Of ObjectStoreService)
Public MustInherit Class ObjectStoreProvider
    Inherits Service(Of ObjectStoreService)
public ref class ObjectStoreProvider abstract : public Service<ObjectStoreService^>
public ref class ObjectStoreProvider abstract : public Service<ObjectStoreService^>
[<AbstractClassAttribute>]
type ObjectStoreProvider =
    class
        inherit Service<ObjectStoreService>
    end
[<AbstractClassAttribute>]
type ObjectStoreProvider =
    class
        inherit Service<ObjectStoreService>
    end
See Also
ObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreProvider Members

ObjectStoreProvider Members NFX Class Library

The ObjectStoreProvider type exposes the following members.
Constructors
 | Name | Description
Protected method | ObjectStoreProvider | Initializes a new instance of the ObjectStoreProvider class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Public method | Delete |
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LoadAll |
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | Write |
Protected method | WriteLog |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
ObjectStoreProvider Class
NFX.ApplicationModel.Volatile Namespace


ObjectStoreProvider Constructor

ObjectStoreProvider Constructor NFX Class Library

Initializes a new instance of the ObjectStoreProvider class

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ObjectStoreProvider(
    ObjectStoreService director
)
protected ObjectStoreProvider(
    ObjectStoreService director
)
Protected Sub New (
    director As ObjectStoreService
)
Protected Sub New (
    director As ObjectStoreService
)
protected:
ObjectStoreProvider(
    ObjectStoreService^ director
)
protected:
ObjectStoreProvider(
    ObjectStoreService^ director
)
new :
        director : ObjectStoreService -> ObjectStoreProvider
new :
        director : ObjectStoreService -> ObjectStoreProvider

Parameters

director
Type: NFX.ApplicationModel.Volatile ObjectStoreService
See Also
ObjectStoreProvider Class
ObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreProvider Methods

ObjectStoreProvider Methods NFX Class Library

The ObjectStoreProvider type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Public method | Delete |
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LoadAll |
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | Write |
Protected method | WriteLog |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ObjectStoreProvider Class
NFX.ApplicationModel.Volatile Namespace


ObjectStoreProvider.Delete Method

ObjectStoreProvider Delete Method NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Delete(
    ObjectStoreEntry entry
)
public abstract void Delete(
    ObjectStoreEntry entry
)
Public MustOverride Sub Delete (
    entry As ObjectStoreEntry
)
Public MustOverride Sub Delete (
    entry As ObjectStoreEntry
)
public:
virtual void Delete(
    ObjectStoreEntry^ entry
) abstract
public:
virtual void Delete(
    ObjectStoreEntry^ entry
) abstract
abstract Delete :
        entry : ObjectStoreEntry -> unit
abstract Delete :
        entry : ObjectStoreEntry -> unit

Parameters

entry
Type: NFX.ApplicationModel.Volatile ObjectStoreEntry
See Also
ObjectStoreProvider Class
ObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreProvider.DoConfigure Method

ObjectStoreProvider DoConfigure Method NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
ObjectStoreProvider Class
ObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreProvider.LoadAll Method

ObjectStoreProvider LoadAll Method NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract IEnumerable<ObjectStoreEntry> LoadAll()
public abstract IEnumerable<ObjectStoreEntry> LoadAll()
Public MustOverride Function LoadAll As IEnumerable(Of ObjectStoreEntry)
Public MustOverride Function LoadAll As IEnumerable(Of ObjectStoreEntry)
public:
virtual IEnumerable<ObjectStoreEntry^>^ LoadAll() abstract
public:
virtual IEnumerable<ObjectStoreEntry^>^ LoadAll() abstract
abstract LoadAll : unit -> IEnumerable<ObjectStoreEntry>
abstract LoadAll : unit -> IEnumerable<ObjectStoreEntry>

Return Value

Type: Online IEnumerable ObjectStoreEntry
See Also
ObjectStoreProvider Class
ObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreProvider.Write Method

ObjectStoreProvider Write Method NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    ObjectStoreEntry entry
)
public abstract void Write(
    ObjectStoreEntry entry
)
Public MustOverride Sub Write (
    entry As ObjectStoreEntry
)
Public MustOverride Sub Write (
    entry As ObjectStoreEntry
)
public:
virtual void Write(
    ObjectStoreEntry^ entry
) abstract
public:
virtual void Write(
    ObjectStoreEntry^ entry
) abstract
abstract Write :
        entry : ObjectStoreEntry -> unit
abstract Write :
        entry : ObjectStoreEntry -> unit

Parameters

entry
Type: NFX.ApplicationModel.Volatile ObjectStoreEntry
See Also
ObjectStoreProvider Class
ObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreProvider.WriteLog Method

ObjectStoreProvider WriteLog Method NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void WriteLog(
    MessageType type,
    string message,
    string parameters,
    string from = null
)
protected void WriteLog(
    MessageType type,
    string message,
    string parameters,
    string from = null
)
Protected Sub WriteLog (
    type As MessageType,
    message As String,
    parameters As String,
    Optional from As String = Nothing
)
Protected Sub WriteLog (
    type As MessageType,
    message As String,
    parameters As String,
    Optional from As String = Nothing
)
protected:
void WriteLog(
    MessageType type,
    String^ message,
    String^ parameters,
    String^ from = nullptr
)
protected:
void WriteLog(
    MessageType type,
    String^ message,
    String^ parameters,
    String^ from = nullptr
)
member WriteLog :
        type : MessageType *
        message : string *
        parameters : string *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit
member WriteLog :
        type : MessageType *
        message : string *
        parameters : string *
        ?from : string
(* Defaults:
        let _from = defaultArg from null
*)
-> unit

Parameters

type
Type: NFX.Log MessageType
message
Type: Online System String
parameters
Type: Online System String
from (Optional)
Type: Online System String
See Also
ObjectStoreProvider Class
ObjectStoreProvider Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreProvider Properties

ObjectStoreProvider Properties NFX Class Library

The ObjectStoreProvider type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
ObjectStoreProvider Class
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService Class

ObjectStoreService Class NFX Class Library

Implements service that stores object in proccess's memory, asynchronously saving objects to external non-volatile storage upon change and synchronously saving objects upon service stop. This service is useful for scenarious like ASP.NET volatile domain that can be torn down at any time. Note for ASP.NET uses: the key difference of this approach from .NET session state management is the fact that this service never blocks object CheckIn() operations as backing store is being updated asynchronously. This class is thread-safe unless specified otherwise on a property/method level
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service Online Object
NFX.ServiceModel ServiceWithInstrumentationBase Online Object
NFX.ApplicationModel.Volatile ObjectStoreService

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigMacroContextAttribute]
public class ObjectStoreService : ServiceWithInstrumentationBase<Object>,
    IObjectStoreImplementation, IObjectStore, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
[ConfigMacroContextAttribute]
public class ObjectStoreService : ServiceWithInstrumentationBase<Object>,
    IObjectStoreImplementation, IObjectStore, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
<ConfigMacroContextAttribute>
Public Class ObjectStoreService
    Inherits ServiceWithInstrumentationBase(Of Object)
    Implements IObjectStoreImplementation, IObjectStore, IApplicationComponent, ILocalizedTimeProvider,
    IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
<ConfigMacroContextAttribute>
Public Class ObjectStoreService
    Inherits ServiceWithInstrumentationBase(Of Object)
    Implements IObjectStoreImplementation, IObjectStore, IApplicationComponent, ILocalizedTimeProvider,
    IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
[ConfigMacroContextAttribute]
public ref class ObjectStoreService : public ServiceWithInstrumentationBase<Object^>,
    IObjectStoreImplementation, IObjectStore, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
[ConfigMacroContextAttribute]
public ref class ObjectStoreService : public ServiceWithInstrumentationBase<Object^>,
    IObjectStoreImplementation, IObjectStore, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
[<ConfigMacroContextAttribute>]
type ObjectStoreService =
    class
        inherit ServiceWithInstrumentationBase<Object>
        interface IObjectStoreImplementation
        interface IObjectStore
        interface IApplicationComponent
        interface ILocalizedTimeProvider
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
[<ConfigMacroContextAttribute>]
type ObjectStoreService =
    class
        inherit ServiceWithInstrumentationBase<Object>
        interface IObjectStoreImplementation
        interface IObjectStore
        interface IApplicationComponent
        interface ILocalizedTimeProvider
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService Members

ObjectStoreService Members NFX Class Library

The ObjectStoreService type exposes the following members.
Constructors
 | Name | Description
Public method | ObjectStoreService | Creates instance of the store service
Public method | ObjectStoreService(Guid) | Creates instance of the store service with the state identified by "storeGUID". Refer to "StoreGUID" property.
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckIn(Guid, Int32) | Puts an object back into store identified by the "key". The object is written in the provider when call count to this method equals to CheckOut(). Returns true if object with such id exists and was checked-in
Public method | CheckIn(Guid, Object, Int32) | Puts an object reference "value" into store identified by the "key". The object is written in the provider when call count to this method equals to CheckOut()
Public method | CheckInUnderNewKey | Puts an object reference "value" into store identified by the "oldKey" under the "newKey". If oldKey was not checked in, then checks-in under new key as normally would
Public method | CheckOut | Retrieves an object reference from the store identified by the "key" or returns null if such object does not exist. Object is not going to be persisted until it is checked back in the store using the same number of calls to CheckIn() for the same GUID.
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Public method | Delete | Deletes object identified by key. Returns true when object was found and marked for deletion
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | Fetch | Retrieves an object reference from the store identified by the "key" or returns null if such object does not exist. Object is not going to be persisted as this method provides logical read-only access. If touch=true then object timestamp is updated
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UndoCheckout | Reverts object state to Normal after the call to Checkout. This way the changes (if any) are not going to be persisted. Returns true if object was found and checkout canceled. Keep in mind: this method CAN NOT revert inner object state to its original state if it was changed, it only unmarks object as changed. This method is reentrant just like the Checkout is
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | visit |
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_BUCKET_COUNT_ATTR |
CONFIG_GUID_ATTR |
CONFIG_OBJECT_LIFE_SPAN_MS_ATTR |
CONFIG_PROVIDER_SECT |
DEFAULT_BUCKET_COUNT |
DEFAULT_OBJECT_LEFESPAN_MS |
MAX_BUCKET_COUNT |
MIN_OBJECT_LIFESPAN_MS |
MUST_ACQUIRE_INTERVAL_MS |
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | BucketCount | Specifies how many buckets objects are kept in. Increasing this number improves thread concurrency
Public property | ComponentCommonName | (Overrides ApplicationComponent ComponentCommonName.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | InstrumentationEnabled | Implements IInstrumentable (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | ObjectLifeSpanMS | Specifies how long objects live without being touched before becoming evicted from the list
Public property | Provider | References provider that persists objects
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | StoreGUID | Returns unique identifier that identifies this particular store. This ID is used to load store's state from external medium upon start-up. One may think of this ID as of a "pointer/handle" that survives phisical object destroy/create cycle
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
ObjectStoreService Class
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService Constructor

ObjectStoreService Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ObjectStoreService | Creates instance of the store service
Public method | ObjectStoreService(Guid) | Creates instance of the store service with the state identified by "storeGUID". Refer to "StoreGUID" property.
Back to Top
See Also
ObjectStoreService Class
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService Constructor

ObjectStoreService Constructor NFX Class Library

Creates instance of the store service

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ObjectStoreService()
public ObjectStoreService()
Public Sub New
Public Sub New
public:
ObjectStoreService()
public:
ObjectStoreService()
new : unit -> ObjectStoreService
new : unit -> ObjectStoreService
See Also
ObjectStoreService Class
ObjectStoreService Members
ObjectStoreService Overload
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService Constructor (Guid)

ObjectStoreService Constructor (Guid) NFX Class Library

Creates instance of the store service with the state identified by "storeGUID". Refer to "StoreGUID" property.

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ObjectStoreService(
    Guid storeGUID
)
public ObjectStoreService(
    Guid storeGUID
)
Public Sub New (
    storeGUID As Guid
)
Public Sub New (
    storeGUID As Guid
)
public:
ObjectStoreService(
    Guid storeGUID
)
public:
ObjectStoreService(
    Guid storeGUID
)
new :
        storeGUID : Guid -> ObjectStoreService
new :
        storeGUID : Guid -> ObjectStoreService

Parameters

storeGUID
Type: Online System Guid
See Also
ObjectStoreService Class
ObjectStoreService Members
ObjectStoreService Overload
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService Fields

ObjectStoreService Fields NFX Class Library

The ObjectStoreService type exposes the following members.
Fields
Name | Description
CONFIG_BUCKET_COUNT_ATTR |
CONFIG_GUID_ATTR |
CONFIG_OBJECT_LIFE_SPAN_MS_ATTR |
CONFIG_PROVIDER_SECT |
DEFAULT_BUCKET_COUNT |
DEFAULT_OBJECT_LEFESPAN_MS |
MAX_BUCKET_COUNT |
MIN_OBJECT_LIFESPAN_MS |
MUST_ACQUIRE_INTERVAL_MS |
Back to Top
See Also
ObjectStoreService Class
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.CONFIG_BUCKET_COUNT_ATTR Field

ObjectStoreService CONFIG_BUCKET_COUNT_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_BUCKET_COUNT_ATTR
public const string CONFIG_BUCKET_COUNT_ATTR
Public Const CONFIG_BUCKET_COUNT_ATTR As String
Public Const CONFIG_BUCKET_COUNT_ATTR As String
public:
literal String^ CONFIG_BUCKET_COUNT_ATTR
public:
literal String^ CONFIG_BUCKET_COUNT_ATTR
static val mutable CONFIG_BUCKET_COUNT_ATTR: string
static val mutable CONFIG_BUCKET_COUNT_ATTR: string

Field Value

Type: Online String
See Also
ObjectStoreService Class
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.CONFIG_GUID_ATTR Field

ObjectStoreService CONFIG_GUID_ATTR Field NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_GUID_ATTR
public const string CONFIG_GUID_ATTR
Public Const CONFIG_GUID_ATTR As String
Public Const CONFIG_GUID_ATTR As String
public:
literal String^ CONFIG_GUID_ATTR
public:
literal String^ CONFIG_GUID_ATTR
static val mutable CONFIG_GUID_ATTR: string
static val mutable CONFIG_GUID_ATTR: string

Field Value

Type: Online String
See Also
ObjectStoreService Class
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.CONFIG_OBJECT_LIFE_SPAN_MS_ATTR Field

ObjectStoreService CONFIG_OBJECT_LIFE_SPAN_MS_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_OBJECT_LIFE_SPAN_MS_ATTR
public const string CONFIG_OBJECT_LIFE_SPAN_MS_ATTR
Public Const CONFIG_OBJECT_LIFE_SPAN_MS_ATTR As String
Public Const CONFIG_OBJECT_LIFE_SPAN_MS_ATTR As String
public:
literal String^ CONFIG_OBJECT_LIFE_SPAN_MS_ATTR
public:
literal String^ CONFIG_OBJECT_LIFE_SPAN_MS_ATTR
static val mutable CONFIG_OBJECT_LIFE_SPAN_MS_ATTR: string
static val mutable CONFIG_OBJECT_LIFE_SPAN_MS_ATTR: string

Field Value

Type: Online String
See Also
ObjectStoreService Class
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.CONFIG_PROVIDER_SECT Field

ObjectStoreService CONFIG_PROVIDER_SECT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PROVIDER_SECT
public const string CONFIG_PROVIDER_SECT
Public Const CONFIG_PROVIDER_SECT As String
Public Const CONFIG_PROVIDER_SECT As String
public:
literal String^ CONFIG_PROVIDER_SECT
public:
literal String^ CONFIG_PROVIDER_SECT
static val mutable CONFIG_PROVIDER_SECT: string
static val mutable CONFIG_PROVIDER_SECT: string

Field Value

Type: Online String
See Also
ObjectStoreService Class
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.DEFAULT_BUCKET_COUNT Field

ObjectStoreService DEFAULT_BUCKET_COUNT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_BUCKET_COUNT
public const int DEFAULT_BUCKET_COUNT
Public Const DEFAULT_BUCKET_COUNT As Integer
Public Const DEFAULT_BUCKET_COUNT As Integer
public:
literal int DEFAULT_BUCKET_COUNT
public:
literal int DEFAULT_BUCKET_COUNT
static val mutable DEFAULT_BUCKET_COUNT: int
static val mutable DEFAULT_BUCKET_COUNT: int

Field Value

Type: Online Int32
See Also
ObjectStoreService Class
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.DEFAULT_OBJECT_LEFESPAN_MS Field

ObjectStoreService DEFAULT_OBJECT_LEFESPAN_MS Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_OBJECT_LEFESPAN_MS
public const int DEFAULT_OBJECT_LEFESPAN_MS
Public Const DEFAULT_OBJECT_LEFESPAN_MS As Integer
Public Const DEFAULT_OBJECT_LEFESPAN_MS As Integer
public:
literal int DEFAULT_OBJECT_LEFESPAN_MS
public:
literal int DEFAULT_OBJECT_LEFESPAN_MS
static val mutable DEFAULT_OBJECT_LEFESPAN_MS: int
static val mutable DEFAULT_OBJECT_LEFESPAN_MS: int

Field Value

Type: Online Int32
See Also
ObjectStoreService Class
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.MAX_BUCKET_COUNT Field

ObjectStoreService MAX_BUCKET_COUNT Field NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_BUCKET_COUNT
public const int MAX_BUCKET_COUNT
Public Const MAX_BUCKET_COUNT As Integer
Public Const MAX_BUCKET_COUNT As Integer
public:
literal int MAX_BUCKET_COUNT
public:
literal int MAX_BUCKET_COUNT
static val mutable MAX_BUCKET_COUNT: int
static val mutable MAX_BUCKET_COUNT: int

Field Value

Type: Online Int32
See Also
ObjectStoreService Class
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.MIN_OBJECT_LIFESPAN_MS Field

ObjectStoreService MIN_OBJECT_LIFESPAN_MS Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MIN_OBJECT_LIFESPAN_MS
public const int MIN_OBJECT_LIFESPAN_MS
Public Const MIN_OBJECT_LIFESPAN_MS As Integer
Public Const MIN_OBJECT_LIFESPAN_MS As Integer
public:
literal int MIN_OBJECT_LIFESPAN_MS
public:
literal int MIN_OBJECT_LIFESPAN_MS
static val mutable MIN_OBJECT_LIFESPAN_MS: int
static val mutable MIN_OBJECT_LIFESPAN_MS: int

Field Value

Type: Online Int32
See Also
ObjectStoreService Class
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.MUST_ACQUIRE_INTERVAL_MS Field

ObjectStoreService MUST_ACQUIRE_INTERVAL_MS Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MUST_ACQUIRE_INTERVAL_MS
public const int MUST_ACQUIRE_INTERVAL_MS
Public Const MUST_ACQUIRE_INTERVAL_MS As Integer
Public Const MUST_ACQUIRE_INTERVAL_MS As Integer
public:
literal int MUST_ACQUIRE_INTERVAL_MS
public:
literal int MUST_ACQUIRE_INTERVAL_MS
static val mutable MUST_ACQUIRE_INTERVAL_MS: int
static val mutable MUST_ACQUIRE_INTERVAL_MS: int

Field Value

Type: Online Int32
See Also
ObjectStoreService Class
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService Methods

ObjectStoreService Methods NFX Class Library

The ObjectStoreService type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckIn(Guid, Int32) | Puts an object back into store identified by the "key". The object is written in the provider when call count to this method equals to CheckOut(). Returns true if object with such id exists and was checked-in
Public method | CheckIn(Guid, Object, Int32) | Puts an object reference "value" into store identified by the "key". The object is written in the provider when call count to this method equals to CheckOut()
Public method | CheckInUnderNewKey | Puts an object reference "value" into store identified by the "oldKey" under the "newKey". If oldKey was not checked in, then checks-in under new key as normally would
Public method | CheckOut | Retrieves an object reference from the store identified by the "key" or returns null if such object does not exist. Object is not going to be persisted until it is checked back in the store using the same number of calls to CheckIn() for the same GUID.
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Public method | Delete | Deletes object identified by key. Returns true when object was found and marked for deletion
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | Fetch | Retrieves an object reference from the store identified by the "key" or returns null if such object does not exist. Object is not going to be persisted as this method provides logical read-only access. If touch=true then object timestamp is updated
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UndoCheckout | Reverts object state to Normal after the call to Checkout. This way the changes (if any) are not going to be persisted. Returns true if object was found and checkout canceled. Keep in mind: this method CAN NOT revert inner object state to its original state if it was changed, it only unmarks object as changed. This method is reentrant just like the Checkout is
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | visit |
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ObjectStoreService Class
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.CheckIn Method

ObjectStoreService CheckIn Method NFX Class Library

Overload List
 | Name | Description
Public method | CheckIn(Guid, Int32) | Puts an object back into store identified by the "key". The object is written in the provider when call count to this method equals to CheckOut(). Returns true if object with such id exists and was checked-in
Public method | CheckIn(Guid, Object, Int32) | Puts an object reference "value" into store identified by the "key". The object is written in the provider when call count to this method equals to CheckOut()
Back to Top
See Also
ObjectStoreService Class
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.CheckIn Method (Guid, Int32)

ObjectStoreService CheckIn Method (Guid, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Puts an object back into store identified by the "key". The object is written in the provider when call count to this method equals to CheckOut(). Returns true if object with such id exists and was checked-in

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool CheckIn(
    Guid key,
    int msTimeout = 0
)
public bool CheckIn(
    Guid key,
    int msTimeout = 0
)
Public Function CheckIn (
    key As Guid,
    Optional msTimeout As Integer = 0
) As Boolean
Public Function CheckIn (
    key As Guid,
    Optional msTimeout As Integer = 0
) As Boolean
public:
virtual bool CheckIn(
    Guid key,
    int msTimeout = 0
) sealed
public:
virtual bool CheckIn(
    Guid key,
    int msTimeout = 0
) sealed
abstract CheckIn :
        key : Guid *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> bool
override CheckIn :
        key : Guid *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> bool
abstract CheckIn :
        key : Guid *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> bool
override CheckIn :
        key : Guid *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> bool

Parameters

key
Type: Online System Guid
msTimeout (Optional)
Type: Online System Int32

Return Value

Type: Online Boolean

Implements

IObjectStore CheckIn(Guid, Int32)
See Also
ObjectStoreService Class
ObjectStoreService Members
CheckIn Overload
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.CheckIn Method (Guid, Object, Int32)

ObjectStoreService CheckIn Method (Guid, Object, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Puts an object reference "value" into store identified by the "key". The object is written in the provider when call count to this method equals to CheckOut()

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CheckIn(
    Guid key,
    Object value,
    int msTimeout = 0
)
public void CheckIn(
    Guid key,
    Object value,
    int msTimeout = 0
)
Public Sub CheckIn (
    key As Guid,
    value As Object,
    Optional msTimeout As Integer = 0
)
Public Sub CheckIn (
    key As Guid,
    value As Object,
    Optional msTimeout As Integer = 0
)
public:
virtual void CheckIn(
    Guid key,
    Object^ value,
    int msTimeout = 0
) sealed
public:
virtual void CheckIn(
    Guid key,
    Object^ value,
    int msTimeout = 0
) sealed
abstract CheckIn :
        key : Guid *
        value : Object *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> unit
override CheckIn :
        key : Guid *
        value : Object *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> unit
abstract CheckIn :
        key : Guid *
        value : Object *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> unit
override CheckIn :
        key : Guid *
        value : Object *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> unit

Parameters

key
Type: Online System Guid
value
Type: Online System Object
msTimeout (Optional)
Type: Online System Int32

Implements

IObjectStore CheckIn(Guid, Object, Int32)
See Also
ObjectStoreService Class
ObjectStoreService Members
CheckIn Overload
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.CheckInUnderNewKey Method

ObjectStoreService CheckInUnderNewKey Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Puts an object reference "value" into store identified by the "oldKey" under the "newKey". If oldKey was not checked in, then checks-in under new key as normally would

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CheckInUnderNewKey(
    Guid oldKey,
    Guid newKey,
    Object value,
    int msTimeout = 0
)
public void CheckInUnderNewKey(
    Guid oldKey,
    Guid newKey,
    Object value,
    int msTimeout = 0
)
Public Sub CheckInUnderNewKey (
    oldKey As Guid,
    newKey As Guid,
    value As Object,
    Optional msTimeout As Integer = 0
)
Public Sub CheckInUnderNewKey (
    oldKey As Guid,
    newKey As Guid,
    value As Object,
    Optional msTimeout As Integer = 0
)
public:
virtual void CheckInUnderNewKey(
    Guid oldKey,
    Guid newKey,
    Object^ value,
    int msTimeout = 0
) sealed
public:
virtual void CheckInUnderNewKey(
    Guid oldKey,
    Guid newKey,
    Object^ value,
    int msTimeout = 0
) sealed
abstract CheckInUnderNewKey :
        oldKey : Guid *
        newKey : Guid *
        value : Object *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> unit
override CheckInUnderNewKey :
        oldKey : Guid *
        newKey : Guid *
        value : Object *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> unit
abstract CheckInUnderNewKey :
        oldKey : Guid *
        newKey : Guid *
        value : Object *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> unit
override CheckInUnderNewKey :
        oldKey : Guid *
        newKey : Guid *
        value : Object *
        ?msTimeout : int
(* Defaults:
        let _msTimeout = defaultArg msTimeout 0
*)
-> unit

Parameters

oldKey
Type: Online System Guid
newKey
Type: Online System Guid
value
Type: Online System Object
msTimeout (Optional)
Type: Online System Int32

Implements

IObjectStore CheckInUnderNewKey(Guid, Guid, Object, Int32)
See Also
ObjectStoreService Class
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.CheckOut Method

ObjectStoreService CheckOut Method NFX Class Library

Retrieves an object reference from the store identified by the "key" or returns null if such object does not exist. Object is not going to be persisted until it is checked back in the store using the same number of calls to CheckIn() for the same GUID.

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object CheckOut(
    Guid key
)
public Object CheckOut(
    Guid key
)
Public Function CheckOut (
    key As Guid
) As Object
Public Function CheckOut (
    key As Guid
) As Object
public:
virtual Object^ CheckOut(
    Guid key
) sealed
public:
virtual Object^ CheckOut(
    Guid key
) sealed
abstract CheckOut :
        key : Guid -> Object
override CheckOut :
        key : Guid -> Object
abstract CheckOut :
        key : Guid -> Object
override CheckOut :
        key : Guid -> Object

Parameters

key
Type: Online System Guid

Return Value

Type: Online Object

Implements

IObjectStore CheckOut(Guid)
See Also
ObjectStoreService Class
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.Delete Method

ObjectStoreService Delete Method NFX Class Library

Deletes object identified by key. Returns true when object was found and marked for deletion

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Delete(
    Guid key
)
public bool Delete(
    Guid key
)
Public Function Delete (
    key As Guid
) As Boolean
Public Function Delete (
    key As Guid
) As Boolean
public:
virtual bool Delete(
    Guid key
) sealed
public:
virtual bool Delete(
    Guid key
) sealed
abstract Delete :
        key : Guid -> bool
override Delete :
        key : Guid -> bool
abstract Delete :
        key : Guid -> bool
override Delete :
        key : Guid -> bool

Parameters

key
Type: Online System Guid

Return Value

Type: Online Boolean

Implements

IObjectStore Delete(Guid)
See Also
ObjectStoreService Class
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.DoConfigure Method

ObjectStoreService DoConfigure Method NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
ObjectStoreService Class
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.DoSignalStop Method

ObjectStoreService DoSignalStop Method NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSignalStop()
protected override void DoSignalStop()
Protected Overrides Sub DoSignalStop
Protected Overrides Sub DoSignalStop
protected:
virtual void DoSignalStop() override
protected:
virtual void DoSignalStop() override
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
See Also
ObjectStoreService Class
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.DoStart Method

ObjectStoreService DoStart Method NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
ObjectStoreService Class
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.DoWaitForCompleteStop Method

ObjectStoreService DoWaitForCompleteStop Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
ObjectStoreService Class
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.Fetch Method

ObjectStoreService Fetch Method NFX Class Library

Retrieves an object reference from the store identified by the "key" or returns null if such object does not exist. Object is not going to be persisted as this method provides logical read-only access. If touch=true then object timestamp is updated

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Fetch(
    Guid key,
    bool touch = false
)
public Object Fetch(
    Guid key,
    bool touch = false
)
Public Function Fetch (
    key As Guid,
    Optional touch As Boolean = false
) As Object
Public Function Fetch (
    key As Guid,
    Optional touch As Boolean = false
) As Object
public:
virtual Object^ Fetch(
    Guid key,
    bool touch = false
) sealed
public:
virtual Object^ Fetch(
    Guid key,
    bool touch = false
) sealed
abstract Fetch :
        key : Guid *
        ?touch : bool
(* Defaults:
        let _touch = defaultArg touch false
*)
-> Object
override Fetch :
        key : Guid *
        ?touch : bool
(* Defaults:
        let _touch = defaultArg touch false
*)
-> Object
abstract Fetch :
        key : Guid *
        ?touch : bool
(* Defaults:
        let _touch = defaultArg touch false
*)
-> Object
override Fetch :
        key : Guid *
        ?touch : bool
(* Defaults:
        let _touch = defaultArg touch false
*)
-> Object

Parameters

key
Type: Online System Guid
touch (Optional)
Type: Online System Boolean

Return Value

Type: Online Object

Implements

IObjectStore Fetch(Guid, Boolean)
See Also
ObjectStoreService Class
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.UndoCheckout Method

ObjectStoreService UndoCheckout Method NFX Class Library

Reverts object state to Normal after the call to Checkout. This way the changes (if any) are not going to be persisted. Returns true if object was found and checkout canceled. Keep in mind: this method CAN NOT revert inner object state to its original state if it was changed, it only unmarks object as changed. This method is reentrant just like the Checkout is

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool UndoCheckout(
    Guid key
)
public bool UndoCheckout(
    Guid key
)
Public Function UndoCheckout (
    key As Guid
) As Boolean
Public Function UndoCheckout (
    key As Guid
) As Boolean
public:
virtual bool UndoCheckout(
    Guid key
) sealed
public:
virtual bool UndoCheckout(
    Guid key
) sealed
abstract UndoCheckout :
        key : Guid -> bool
override UndoCheckout :
        key : Guid -> bool
abstract UndoCheckout :
        key : Guid -> bool
override UndoCheckout :
        key : Guid -> bool

Parameters

key
Type: Online System Guid

Return Value

Type: Online Boolean

Implements

IObjectStore UndoCheckout(Guid)
See Also
ObjectStoreService Class
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.visit Method

ObjectStoreService visit Method NFX Class Library

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void visit(
    bool stopping
)
public void visit(
    bool stopping
)
Public Sub visit (
    stopping As Boolean
)
Public Sub visit (
    stopping As Boolean
)
public:
void visit(
    bool stopping
)
public:
void visit(
    bool stopping
)
member visit :
        stopping : bool -> unit
member visit :
        stopping : bool -> unit

Parameters

stopping
Type: Online System Boolean
See Also
ObjectStoreService Class
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService Properties

ObjectStoreService Properties NFX Class Library

The ObjectStoreService type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | BucketCount | Specifies how many buckets objects are kept in. Increasing this number improves thread concurrency
Public property | ComponentCommonName | (Overrides ApplicationComponent ComponentCommonName.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | InstrumentationEnabled | Implements IInstrumentable (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | ObjectLifeSpanMS | Specifies how long objects live without being touched before becoming evicted from the list
Public property | Provider | References provider that persists objects
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | StoreGUID | Returns unique identifier that identifies this particular store. This ID is used to load store's state from external medium upon start-up. One may think of this ID as of a "pointer/handle" that survives phisical object destroy/create cycle
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
ObjectStoreService Class
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.BucketCount Property

ObjectStoreService BucketCount Property NFX Class Library

Specifies how many buckets objects are kept in. Increasing this number improves thread concurrency

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int BucketCount { get; set; }
public int BucketCount { get; set; }
Public Property BucketCount As Integer
    Get
    Set
Public Property BucketCount As Integer
    Get
    Set
public:
property int BucketCount {
    int get ();
    void set (int value);
}
public:
property int BucketCount {
    int get ();
    void set (int value);
}
member BucketCount : int with get, set
member BucketCount : int with get, set

Property Value

Type: Online Int32
See Also
ObjectStoreService Class
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.ComponentCommonName Property

ObjectStoreService ComponentCommonName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ComponentCommonName { get; }
public override string ComponentCommonName { get; }
Public Overrides ReadOnly Property ComponentCommonName As String
    Get
Public Overrides ReadOnly Property ComponentCommonName As String
    Get
public:
virtual property String^ ComponentCommonName {
    String^ get () override;
}
public:
virtual property String^ ComponentCommonName {
    String^ get () override;
}
abstract ComponentCommonName : string with get
override ComponentCommonName : string with get
abstract ComponentCommonName : string with get
override ComponentCommonName : string with get

Property Value

Type: Online String

Implements

IApplicationComponent ComponentCommonName
IApplicationComponent ComponentCommonName
See Also
ObjectStoreService Class
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.InstrumentationEnabled Property

ObjectStoreService InstrumentationEnabled Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Implements IInstrumentable

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(new string[] { ... })]
public override bool InstrumentationEnabled { get; set; }
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(new string[] { ... })]
public override bool InstrumentationEnabled { get; set; }
<ConfigAttribute(Default := false)>
<ExternalParameterAttribute(New String() { ... })>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
<ConfigAttribute(Default := false)>
<ExternalParameterAttribute(New String() { ... })>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
public:
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
public:
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
abstract InstrumentationEnabled : bool with get, set
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
override InstrumentationEnabled : bool with get, set
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
abstract InstrumentationEnabled : bool with get, set
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
override InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentable InstrumentationEnabled
IInstrumentable InstrumentationEnabled
See Also
ObjectStoreService Class
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.ObjectLifeSpanMS Property

ObjectStoreService ObjectLifeSpanMS Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Specifies how long objects live without being touched before becoming evicted from the list

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
public int ObjectLifeSpanMS { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
public int ObjectLifeSpanMS { get; set; }
<ExternalParameterAttribute(New String() { ... })>
Public Property ObjectLifeSpanMS As Integer
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
Public Property ObjectLifeSpanMS As Integer
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property int ObjectLifeSpanMS {
    int get () sealed;
    void set (int value) sealed;
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property int ObjectLifeSpanMS {
    int get () sealed;
    void set (int value) sealed;
}
[<ExternalParameterAttribute(new string[] { ... })>]
abstract ObjectLifeSpanMS : int with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
override ObjectLifeSpanMS : int with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
abstract ObjectLifeSpanMS : int with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
override ObjectLifeSpanMS : int with get, set

Property Value

Type: Online Int32

Implements

IObjectStore ObjectLifeSpanMS
See Also
ObjectStoreService Class
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.Provider Property

ObjectStoreService Provider Property NFX Class Library

References provider that persists objects

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ObjectStoreProvider Provider { get; set; }
public ObjectStoreProvider Provider { get; set; }
Public Property Provider As ObjectStoreProvider
    Get
    Set
Public Property Provider As ObjectStoreProvider
    Get
    Set
public:
property ObjectStoreProvider^ Provider {
    ObjectStoreProvider^ get ();
    void set (ObjectStoreProvider^ value);
}
public:
property ObjectStoreProvider^ Provider {
    ObjectStoreProvider^ get ();
    void set (ObjectStoreProvider^ value);
}
member Provider : ObjectStoreProvider with get, set
member Provider : ObjectStoreProvider with get, set

Property Value

Type: ObjectStoreProvider
See Also
ObjectStoreService Class
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


ObjectStoreService.StoreGUID Property

ObjectStoreService StoreGUID Property NFX Class Library

Returns unique identifier that identifies this particular store. This ID is used to load store's state from external medium upon start-up. One may think of this ID as of a "pointer/handle" that survives phisical object destroy/create cycle

Namespace: NFX.ApplicationModel.Volatile
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid StoreGUID { get; set; }
public Guid StoreGUID { get; set; }
Public Property StoreGUID As Guid
    Get
    Set
Public Property StoreGUID As Guid
    Get
    Set
public:
property Guid StoreGUID {
    Guid get ();
    void set (Guid value);
}
public:
property Guid StoreGUID {
    Guid get ();
    void set (Guid value);
}
member StoreGUID : Guid with get, set
member StoreGUID : Guid with get, set

Property Value

Type: Online Guid
See Also
ObjectStoreService Class
ObjectStoreService Members
NFX.ApplicationModel.Volatile Namespace


NFX.CodeAnalysis Namespace

NFX.CodeAnalysis Namespace NFX Class Library

Provides code analysis-related base contracts/models for writing compilers and various textual processors. JSON, C#, Laconic parsers are implemented using this concept
Classes
 | Class | Description
Public class | CodeAnalysisException | Base exception thrown by the framework
Public class | CodeProcessorException | Thrown by code processors such as lexers, parsers , symantic analyzers, compilers etc...
Public class | CommonCodeProcessor | Provides base implementation for common code processors
Public class | Language | Represents and abstraction of the language
Public class | LazyFSMState TToken | Represents a state object for Lazy Finate State Machine that enumerates tokes from IEnumerable(Token) and does not support a notion of index addressing
Public class | Lexer TToken | Performs lexical analysis of the source code in particular language Allows to enumerate over source as typed Token stream - depending on implementation enumeration may do lexical analysis token-by-token or in chunks with every enumerator advance
Public class | Message | Represents a message emitted from code-analyzing entities such as lexers, parsers, semantic analyzers and compilers. Messages have severity type like warning, info or error etc.
Public class | MessageList | Provides a list of messages, this class is not thread-safe
Public class | ObjectResultAnalysisContext TObject | A context that can hold analysis result as TObject. This class is useful for cases like dynamic language parsers (i.e. JSON)
Public class | Parser TLexer | Performs parsing of token streams provided by lexers
Public class | PatternSearch | Provides Token-pattern matching utilities
Public class | SourceRefCommonCodeProcessor | Provides base implementation for common code processors
Public class | StringEscapeErrorException |
Public class | Token | Represents a lexical token of the language. This is an abstract class that particular language implementations must extend to define language-specific token types
Public class | Tokenized TToken | Provides read-only view over TokenList
Public class | TokenList TToken | A list of tokens
Public class | UnspecifiedLanguage | Represents Unspecified unknown language
Interfaces
 | Interface | Description
Public interface | IAnalysisContext | Describes an entity that retains state during analysis, such as: module compiler, project compiler, code unit translator etc. This entity may also contain compiler/parser/lexer options etc.
Public interface | ICodeProcessor | Describes an entity that may process source code in some language
Public interface | ILanguageProcessorNotifications | Describes an entity capable of receiving messages as they are emitted by entities such as parsers and compilers
Public interface | ILexer | Describes general lexer interface. Lexers turn string source input which is obtained via ISourceText implementation (i.e. FileSource,WebSource...) into tokenized stream. Some lexer implementations may support lazy analysis, that is - source text analysis which is done in chunks when lexer is iterated over, others may lex the whole source text at once
Public interface | IParser | Describes general parser interface
Public interface | IProjectItem | Represents an item that is a part of some project, i.e. a CS source file in CSharp project
Delegates
 | Delegate | Description
Public delegate | LazyFSMPredicate TToken | Lazy Finate State Machine (FSM) predicate, tries to match condition and returns appropriate next action
Enumerations
 | Enumeration | Description
Public enumeration | FSMI | Describes transition instructions for Finate State Machine (FSM)
Public enumeration | LanguageFamily | Defines various languages
Public enumeration | MessageType | Message type like: Info, Warning, Error
Public enumeration | TokenKind | Provides language-agnostic token classification


CodeAnalysisException Class

CodeAnalysisException Class NFX Class Library

Base exception thrown by the framework
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.CodeAnalysis CodeAnalysisException
NFX.CodeAnalysis CodeProcessorException
NFX.CodeAnalysis StringEscapeErrorException

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CodeAnalysisException : NFXException
[SerializableAttribute]
public class CodeAnalysisException : NFXException
<SerializableAttribute>
Public Class CodeAnalysisException
    Inherits NFXException
<SerializableAttribute>
Public Class CodeAnalysisException
    Inherits NFXException
[SerializableAttribute]
public ref class CodeAnalysisException : public NFXException
[SerializableAttribute]
public ref class CodeAnalysisException : public NFXException
[<SerializableAttribute>]
type CodeAnalysisException =
    class
        inherit NFXException
    end
[<SerializableAttribute>]
type CodeAnalysisException =
    class
        inherit NFXException
    end
See Also
CodeAnalysisException Members
NFX.CodeAnalysis Namespace


CodeAnalysisException Members

CodeAnalysisException Members NFX Class Library

The CodeAnalysisException type exposes the following members.
Constructors
 | Name | Description
Public method | CodeAnalysisException | Initializes a new instance of the CodeAnalysisException class
Public method | CodeAnalysisException(String) | Initializes a new instance of the CodeAnalysisException class
Protected method | CodeAnalysisException(SerializationInfo, StreamingContext) | Initializes a new instance of the CodeAnalysisException class
Public method | CodeAnalysisException(String, Exception) | Initializes a new instance of the CodeAnalysisException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
CodeAnalysisException Class
NFX.CodeAnalysis Namespace


CodeAnalysisException Constructor

CodeAnalysisException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | CodeAnalysisException | Initializes a new instance of the CodeAnalysisException class
Public method | CodeAnalysisException(String) | Initializes a new instance of the CodeAnalysisException class
Protected method | CodeAnalysisException(SerializationInfo, StreamingContext) | Initializes a new instance of the CodeAnalysisException class
Public method | CodeAnalysisException(String, Exception) | Initializes a new instance of the CodeAnalysisException class
Back to Top
See Also
CodeAnalysisException Class
CodeAnalysisException Members
NFX.CodeAnalysis Namespace


CodeAnalysisException Constructor

CodeAnalysisException Constructor NFX Class Library

Initializes a new instance of the CodeAnalysisException class

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CodeAnalysisException()
public CodeAnalysisException()
Public Sub New
Public Sub New
public:
CodeAnalysisException()
public:
CodeAnalysisException()
new : unit -> CodeAnalysisException
new : unit -> CodeAnalysisException
See Also
CodeAnalysisException Class
CodeAnalysisException Members
CodeAnalysisException Overload
NFX.CodeAnalysis Namespace


CodeAnalysisException Constructor (String)

CodeAnalysisException Constructor (String) NFX Class Library

Initializes a new instance of the CodeAnalysisException class

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CodeAnalysisException(
    string message
)
public CodeAnalysisException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
CodeAnalysisException(
    String^ message
)
public:
CodeAnalysisException(
    String^ message
)
new :
        message : string -> CodeAnalysisException
new :
        message : string -> CodeAnalysisException

Parameters

message
Type: Online System String
See Also
CodeAnalysisException Class
CodeAnalysisException Members
CodeAnalysisException Overload
NFX.CodeAnalysis Namespace


CodeAnalysisException Constructor (SerializationInfo, StreamingContext)

CodeAnalysisException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CodeAnalysisException class

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CodeAnalysisException(
    SerializationInfo info,
    StreamingContext context
)
protected CodeAnalysisException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
CodeAnalysisException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
CodeAnalysisException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> CodeAnalysisException
new :
        info : SerializationInfo *
        context : StreamingContext -> CodeAnalysisException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
CodeAnalysisException Class
CodeAnalysisException Members
CodeAnalysisException Overload
NFX.CodeAnalysis Namespace


CodeAnalysisException Constructor (String, Exception)

CodeAnalysisException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CodeAnalysisException class

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CodeAnalysisException(
    string message,
    Exception inner
)
public CodeAnalysisException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
CodeAnalysisException(
    String^ message,
    Exception^ inner
)
public:
CodeAnalysisException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> CodeAnalysisException
new :
        message : string *
        inner : Exception -> CodeAnalysisException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
CodeAnalysisException Class
CodeAnalysisException Members
CodeAnalysisException Overload
NFX.CodeAnalysis Namespace


CodeAnalysisException Methods

CodeAnalysisException Methods NFX Class Library

The CodeAnalysisException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
CodeAnalysisException Class
NFX.CodeAnalysis Namespace


CodeAnalysisException Properties

CodeAnalysisException Properties NFX Class Library

The CodeAnalysisException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
CodeAnalysisException Class
NFX.CodeAnalysis Namespace


CodeAnalysisException Events

CodeAnalysisException Events NFX Class Library

The CodeAnalysisException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
CodeAnalysisException Class
NFX.CodeAnalysis Namespace


CodeProcessorException Class

CodeProcessorException Class NFX Class Library

Thrown by code processors such as lexers, parsers , symantic analyzers, compilers etc...
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.CodeAnalysis CodeAnalysisException
NFX.CodeAnalysis CodeProcessorException

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CodeProcessorException : CodeAnalysisException
public class CodeProcessorException : CodeAnalysisException
Public Class CodeProcessorException
    Inherits CodeAnalysisException
Public Class CodeProcessorException
    Inherits CodeAnalysisException
public ref class CodeProcessorException : public CodeAnalysisException
public ref class CodeProcessorException : public CodeAnalysisException
type CodeProcessorException =
    class
        inherit CodeAnalysisException
    end
type CodeProcessorException =
    class
        inherit CodeAnalysisException
    end
See Also
CodeProcessorException Members
NFX.CodeAnalysis Namespace


CodeProcessorException Members

CodeProcessorException Members NFX Class Library

The CodeProcessorException type exposes the following members.
Constructors
 | Name | Description
Public method | CodeProcessorException(ICodeProcessor) | Initializes a new instance of the CodeProcessorException class
Public method | CodeProcessorException(ICodeProcessor, String) | Initializes a new instance of the CodeProcessorException class
Public method | CodeProcessorException(ICodeProcessor, String, Exception) | Initializes a new instance of the CodeProcessorException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | CodeProcessor |
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
CodeProcessorException Class
NFX.CodeAnalysis Namespace


CodeProcessorException Constructor

CodeProcessorException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | CodeProcessorException(ICodeProcessor) | Initializes a new instance of the CodeProcessorException class
Public method | CodeProcessorException(ICodeProcessor, String) | Initializes a new instance of the CodeProcessorException class
Public method | CodeProcessorException(ICodeProcessor, String, Exception) | Initializes a new instance of the CodeProcessorException class
Back to Top
See Also
CodeProcessorException Class
CodeProcessorException Members
NFX.CodeAnalysis Namespace


CodeProcessorException Constructor (ICodeProcessor)

CodeProcessorException Constructor (ICodeProcessor) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CodeProcessorException class

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CodeProcessorException(
    ICodeProcessor codeProcessor
)
public CodeProcessorException(
    ICodeProcessor codeProcessor
)
Public Sub New (
    codeProcessor As ICodeProcessor
)
Public Sub New (
    codeProcessor As ICodeProcessor
)
public:
CodeProcessorException(
    ICodeProcessor^ codeProcessor
)
public:
CodeProcessorException(
    ICodeProcessor^ codeProcessor
)
new :
        codeProcessor : ICodeProcessor -> CodeProcessorException
new :
        codeProcessor : ICodeProcessor -> CodeProcessorException

Parameters

codeProcessor
Type: NFX.CodeAnalysis ICodeProcessor
See Also
CodeProcessorException Class
CodeProcessorException Members
CodeProcessorException Overload
NFX.CodeAnalysis Namespace


CodeProcessorException Constructor (ICodeProcessor, String)

CodeProcessorException Constructor (ICodeProcessor, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CodeProcessorException class

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CodeProcessorException(
    ICodeProcessor codeProcessor,
    string message
)
public CodeProcessorException(
    ICodeProcessor codeProcessor,
    string message
)
Public Sub New (
    codeProcessor As ICodeProcessor,
    message As String
)
Public Sub New (
    codeProcessor As ICodeProcessor,
    message As String
)
public:
CodeProcessorException(
    ICodeProcessor^ codeProcessor,
    String^ message
)
public:
CodeProcessorException(
    ICodeProcessor^ codeProcessor,
    String^ message
)
new :
        codeProcessor : ICodeProcessor *
        message : string -> CodeProcessorException
new :
        codeProcessor : ICodeProcessor *
        message : string -> CodeProcessorException

Parameters

codeProcessor
Type: NFX.CodeAnalysis ICodeProcessor
message
Type: Online System String
See Also
CodeProcessorException Class
CodeProcessorException Members
CodeProcessorException Overload
NFX.CodeAnalysis Namespace


CodeProcessorException Constructor (ICodeProcessor, String, Exception)

CodeProcessorException Constructor (ICodeProcessor, String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CodeProcessorException class

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CodeProcessorException(
    ICodeProcessor codeProcessor,
    string message,
    Exception inner
)
public CodeProcessorException(
    ICodeProcessor codeProcessor,
    string message,
    Exception inner
)
Public Sub New (
    codeProcessor As ICodeProcessor,
    message As String,
    inner As Exception
)
Public Sub New (
    codeProcessor As ICodeProcessor,
    message As String,
    inner As Exception
)
public:
CodeProcessorException(
    ICodeProcessor^ codeProcessor,
    String^ message,
    Exception^ inner
)
public:
CodeProcessorException(
    ICodeProcessor^ codeProcessor,
    String^ message,
    Exception^ inner
)
new :
        codeProcessor : ICodeProcessor *
        message : string *
        inner : Exception -> CodeProcessorException
new :
        codeProcessor : ICodeProcessor *
        message : string *
        inner : Exception -> CodeProcessorException

Parameters

codeProcessor
Type: NFX.CodeAnalysis ICodeProcessor
message
Type: Online System String
inner
Type: Online System Exception
See Also
CodeProcessorException Class
CodeProcessorException Members
CodeProcessorException Overload
NFX.CodeAnalysis Namespace


CodeProcessorException Fields

CodeProcessorException Fields NFX Class Library

The CodeProcessorException type exposes the following members.
Fields
 | Name | Description
Public field | CodeProcessor |
Back to Top
See Also
CodeProcessorException Class
NFX.CodeAnalysis Namespace


CodeProcessorException.CodeProcessor Field

CodeProcessorException CodeProcessor Field NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ICodeProcessor CodeProcessor
public readonly ICodeProcessor CodeProcessor
Public ReadOnly CodeProcessor As ICodeProcessor
Public ReadOnly CodeProcessor As ICodeProcessor
public:
initonly ICodeProcessor^ CodeProcessor
public:
initonly ICodeProcessor^ CodeProcessor
val CodeProcessor: ICodeProcessor
val CodeProcessor: ICodeProcessor

Field Value

Type: ICodeProcessor
See Also
CodeProcessorException Class
CodeProcessorException Members
NFX.CodeAnalysis Namespace


CodeProcessorException Methods

CodeProcessorException Methods NFX Class Library

The CodeProcessorException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
CodeProcessorException Class
NFX.CodeAnalysis Namespace


CodeProcessorException Properties

CodeProcessorException Properties NFX Class Library

The CodeProcessorException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
CodeProcessorException Class
NFX.CodeAnalysis Namespace


CodeProcessorException Events

CodeProcessorException Events NFX Class Library

The CodeProcessorException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
CodeProcessorException Class
NFX.CodeAnalysis Namespace


CommonCodeProcessor Class

CommonCodeProcessor Class NFX Class Library

Provides base implementation for common code processors
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis CommonCodeProcessor
NFX.CodeAnalysis ObjectResultAnalysisContext TObject
NFX.CodeAnalysis Parser TLexer
NFX.CodeAnalysis SourceRefCommonCodeProcessor

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class CommonCodeProcessor : ICodeProcessor
public abstract class CommonCodeProcessor : ICodeProcessor
Public MustInherit Class CommonCodeProcessor
    Implements ICodeProcessor
Public MustInherit Class CommonCodeProcessor
    Implements ICodeProcessor
public ref class CommonCodeProcessor abstract : ICodeProcessor
public ref class CommonCodeProcessor abstract : ICodeProcessor
[<AbstractClassAttribute>]
type CommonCodeProcessor =
    class
        interface ICodeProcessor
    end
[<AbstractClassAttribute>]
type CommonCodeProcessor =
    class
        interface ICodeProcessor
    end
See Also
CommonCodeProcessor Members
NFX.CodeAnalysis Namespace


CommonCodeProcessor Members

CommonCodeProcessor Members NFX Class Library

The CommonCodeProcessor type exposes the following members.
Constructors
 | Name | Description
Protected method | CommonCodeProcessor | Initializes a new instance of the CommonCodeProcessor class
Back to Top
Methods
 | Name | Description
Protected method | EmitMessage |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MessageCodeToString | Returns string representation of message code which is output by this processor
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Context | Returns context that this processor operates under - an entity that retains state during analysis, such as: module compiler, project compiler, code unit translator etc. This entity may also contain compiler/parser/lexer options etc.
Public property | Language | Returns language that this processor is capable of processing
Public property | Messages | References message list that lexer emitts messages into. May be null
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any lexing error is always thrown regardless of this parameter
Back to Top
See Also
CommonCodeProcessor Class
NFX.CodeAnalysis Namespace


CommonCodeProcessor Constructor

CommonCodeProcessor Constructor NFX Class Library

Initializes a new instance of the CommonCodeProcessor class

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CommonCodeProcessor(
    IAnalysisContext context,
    MessageList messages = null,
    bool throwErrors = false
)
protected CommonCodeProcessor(
    IAnalysisContext context,
    MessageList messages = null,
    bool throwErrors = false
)
Protected Sub New (
    context As IAnalysisContext,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
Protected Sub New (
    context As IAnalysisContext,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
protected:
CommonCodeProcessor(
    IAnalysisContext^ context,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
protected:
CommonCodeProcessor(
    IAnalysisContext^ context,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
new :
        context : IAnalysisContext *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> CommonCodeProcessor
new :
        context : IAnalysisContext *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> CommonCodeProcessor

Parameters

context
Type: NFX.CodeAnalysis IAnalysisContext
messages (Optional)
Type: NFX.CodeAnalysis MessageList
throwErrors (Optional)
Type: Online System Boolean
See Also
CommonCodeProcessor Class
CommonCodeProcessor Members
NFX.CodeAnalysis Namespace


CommonCodeProcessor Methods

CommonCodeProcessor Methods NFX Class Library

The CommonCodeProcessor type exposes the following members.
Methods
 | Name | Description
Protected method | EmitMessage |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MessageCodeToString | Returns string representation of message code which is output by this processor
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CommonCodeProcessor Class
NFX.CodeAnalysis Namespace


CommonCodeProcessor.EmitMessage Method

CommonCodeProcessor EmitMessage Method NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void EmitMessage(
    MessageType type,
    int code,
    SourceCodeRef srcRef,
    Nullable<SourcePosition> position = null,
    Token token = null,
    string text = null,
    Exception exception = null
)
protected void EmitMessage(
    MessageType type,
    int code,
    SourceCodeRef srcRef,
    Nullable<SourcePosition> position = null,
    Token token = null,
    string text = null,
    Exception exception = null
)
Protected Sub EmitMessage (
    type As MessageType,
    code As Integer,
    srcRef As SourceCodeRef,
    Optional position As Nullable(Of SourcePosition) = Nothing,
    Optional token As Token = Nothing,
    Optional text As String = Nothing,
    Optional exception As Exception = Nothing
)
Protected Sub EmitMessage (
    type As MessageType,
    code As Integer,
    srcRef As SourceCodeRef,
    Optional position As Nullable(Of SourcePosition) = Nothing,
    Optional token As Token = Nothing,
    Optional text As String = Nothing,
    Optional exception As Exception = Nothing
)
protected:
void EmitMessage(
    MessageType type,
    int code,
    SourceCodeRef srcRef,
    Nullable<SourcePosition> position = nullptr,
    Token^ token = nullptr,
    String^ text = nullptr,
    Exception^ exception = nullptr
)
protected:
void EmitMessage(
    MessageType type,
    int code,
    SourceCodeRef srcRef,
    Nullable<SourcePosition> position = nullptr,
    Token^ token = nullptr,
    String^ text = nullptr,
    Exception^ exception = nullptr
)
member EmitMessage :
        type : MessageType *
        code : int *
        srcRef : SourceCodeRef *
        ?position : Nullable<SourcePosition> *
        ?token : Token *
        ?text : string *
        ?exception : Exception
(* Defaults:
        let _position = defaultArg position null
        let _token = defaultArg token null
        let _text = defaultArg text null
        let _exception = defaultArg exception null
*)
-> unit
member EmitMessage :
        type : MessageType *
        code : int *
        srcRef : SourceCodeRef *
        ?position : Nullable<SourcePosition> *
        ?token : Token *
        ?text : string *
        ?exception : Exception
(* Defaults:
        let _position = defaultArg position null
        let _token = defaultArg token null
        let _text = defaultArg text null
        let _exception = defaultArg exception null
*)
-> unit

Parameters

type
Type: NFX.CodeAnalysis MessageType
code
Type: Online System Int32
srcRef
Type: NFX.CodeAnalysis.Source SourceCodeRef
position (Optional)
Type: Online System Nullable SourcePosition
token (Optional)
Type: NFX.CodeAnalysis Token
text (Optional)
Type: Online System String
exception (Optional)
Type: Online System Exception
See Also
CommonCodeProcessor Class
CommonCodeProcessor Members
NFX.CodeAnalysis Namespace


CommonCodeProcessor.MessageCodeToString Method

CommonCodeProcessor MessageCodeToString Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns string representation of message code which is output by this processor

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string MessageCodeToString(
    int code
)
public abstract string MessageCodeToString(
    int code
)
Public MustOverride Function MessageCodeToString (
    code As Integer
) As String
Public MustOverride Function MessageCodeToString (
    code As Integer
) As String
public:
virtual String^ MessageCodeToString(
    int code
) abstract
public:
virtual String^ MessageCodeToString(
    int code
) abstract
abstract MessageCodeToString :
        code : int -> string
abstract MessageCodeToString :
        code : int -> string

Parameters

code
Type: Online System Int32

Return Value

Type: Online String

Implements

ICodeProcessor MessageCodeToString(Int32)
See Also
CommonCodeProcessor Class
CommonCodeProcessor Members
NFX.CodeAnalysis Namespace


CommonCodeProcessor Properties

CommonCodeProcessor Properties NFX Class Library

The CommonCodeProcessor type exposes the following members.
Properties
 | Name | Description
Public property | Context | Returns context that this processor operates under - an entity that retains state during analysis, such as: module compiler, project compiler, code unit translator etc. This entity may also contain compiler/parser/lexer options etc.
Public property | Language | Returns language that this processor is capable of processing
Public property | Messages | References message list that lexer emitts messages into. May be null
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any lexing error is always thrown regardless of this parameter
Back to Top
See Also
CommonCodeProcessor Class
NFX.CodeAnalysis Namespace


CommonCodeProcessor.Context Property

CommonCodeProcessor Context Property NFX Class Library

Returns context that this processor operates under - an entity that retains state during analysis, such as: module compiler, project compiler, code unit translator etc. This entity may also contain compiler/parser/lexer options etc.

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IAnalysisContext Context { get; }
public IAnalysisContext Context { get; }
Public ReadOnly Property Context As IAnalysisContext
    Get
Public ReadOnly Property Context As IAnalysisContext
    Get
public:
virtual property IAnalysisContext^ Context {
    IAnalysisContext^ get () sealed;
}
public:
virtual property IAnalysisContext^ Context {
    IAnalysisContext^ get () sealed;
}
abstract Context : IAnalysisContext with get
override Context : IAnalysisContext with get
abstract Context : IAnalysisContext with get
override Context : IAnalysisContext with get

Property Value

Type: IAnalysisContext

Implements

ICodeProcessor Context
See Also
CommonCodeProcessor Class
CommonCodeProcessor Members
NFX.CodeAnalysis Namespace


CommonCodeProcessor.Language Property

CommonCodeProcessor Language Property NFX Class Library

Returns language that this processor is capable of processing

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Language Language { get; }
public abstract Language Language { get; }
Public MustOverride ReadOnly Property Language As Language
    Get
Public MustOverride ReadOnly Property Language As Language
    Get
public:
virtual property Language^ Language {
    Language^ get () abstract;
}
public:
virtual property Language^ Language {
    Language^ get () abstract;
}
abstract Language : Language with get
abstract Language : Language with get

Property Value

Type: Language

Implements

ICodeProcessor Language
See Also
CommonCodeProcessor Class
CommonCodeProcessor Members
NFX.CodeAnalysis Namespace


CommonCodeProcessor.Messages Property

CommonCodeProcessor Messages Property NFX Class Library

References message list that lexer emitts messages into. May be null

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageList Messages { get; }
public MessageList Messages { get; }
Public ReadOnly Property Messages As MessageList
    Get
Public ReadOnly Property Messages As MessageList
    Get
public:
virtual property MessageList^ Messages {
    MessageList^ get () sealed;
}
public:
virtual property MessageList^ Messages {
    MessageList^ get () sealed;
}
abstract Messages : MessageList with get
override Messages : MessageList with get
abstract Messages : MessageList with get
override Messages : MessageList with get

Property Value

Type: MessageList

Implements

ICodeProcessor Messages
See Also
CommonCodeProcessor Class
CommonCodeProcessor Members
NFX.CodeAnalysis Namespace


CommonCodeProcessor.ThrowErrors Property

CommonCodeProcessor ThrowErrors Property NFX Class Library

When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any lexing error is always thrown regardless of this parameter

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ThrowErrors { get; }
public bool ThrowErrors { get; }
Public ReadOnly Property ThrowErrors As Boolean
    Get
Public ReadOnly Property ThrowErrors As Boolean
    Get
public:
virtual property bool ThrowErrors {
    bool get () sealed;
}
public:
virtual property bool ThrowErrors {
    bool get () sealed;
}
abstract ThrowErrors : bool with get
override ThrowErrors : bool with get
abstract ThrowErrors : bool with get
override ThrowErrors : bool with get

Property Value

Type: Online Boolean

Implements

ICodeProcessor ThrowErrors
See Also
CommonCodeProcessor Class
CommonCodeProcessor Members
NFX.CodeAnalysis Namespace


FSMI Enumeration

FSMI Enumeration NFX Class Library

Describes transition instructions for Finate State Machine (FSM)

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum FSMI
public enum FSMI
Public Enumeration FSMI
Public Enumeration FSMI
public enum class FSMI
public enum class FSMI
type FSMI
type FSMI
Members
Member name | Value | Description
Loop | 0 |
Abort | 1 |
Advance | 2 |
AdvanceOnSameToken | 3 |
Take | 4 |
TakeAndComplete | 5 |
Complete | 6 |
See Also
NFX.CodeAnalysis Namespace


IAnalysisContext Interface

IAnalysisContext Interface NFX Class Library

Describes an entity that retains state during analysis, such as: module compiler, project compiler, code unit translator etc. This entity may also contain compiler/parser/lexer options etc.

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IAnalysisContext : ICodeProcessor
public interface IAnalysisContext : ICodeProcessor
Public Interface IAnalysisContext
    Inherits ICodeProcessor
Public Interface IAnalysisContext
    Inherits ICodeProcessor
public interface class IAnalysisContext : ICodeProcessor
public interface class IAnalysisContext : ICodeProcessor
type IAnalysisContext =
    interface
        interface ICodeProcessor
    end
type IAnalysisContext =
    interface
        interface ICodeProcessor
    end
See Also
IAnalysisContext Members
NFX.CodeAnalysis Namespace


IAnalysisContext Members

IAnalysisContext Members NFX Class Library

The IAnalysisContext type exposes the following members.
Methods
 | Name | Description
Public method | MessageCodeToString | Returns string representation of message code which is output by this processor (Inherited from ICodeProcessor.)
Back to Top
Properties
 | Name | Description
Public property | Context | Returns context that this processor operates under (Inherited from ICodeProcessor.)
Public property | Language | References language that this entity supports (Inherited from ICodeProcessor.)
Public property | Messages | References message list that processor emitts messages into. May be null, in which case errors are always thrown because they can not get logged into message list (Inherited from ICodeProcessor.)
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any error is always thrown regardless of this parameter (Inherited from ICodeProcessor.)
Back to Top
See Also
IAnalysisContext Interface
NFX.CodeAnalysis Namespace


IAnalysisContext Methods

IAnalysisContext Methods NFX Class Library

The IAnalysisContext type exposes the following members.
Methods
 | Name | Description
Public method | MessageCodeToString | Returns string representation of message code which is output by this processor (Inherited from ICodeProcessor.)
Back to Top
See Also
IAnalysisContext Interface
NFX.CodeAnalysis Namespace


IAnalysisContext Properties

IAnalysisContext Properties NFX Class Library

The IAnalysisContext type exposes the following members.
Properties
 | Name | Description
Public property | Context | Returns context that this processor operates under (Inherited from ICodeProcessor.)
Public property | Language | References language that this entity supports (Inherited from ICodeProcessor.)
Public property | Messages | References message list that processor emitts messages into. May be null, in which case errors are always thrown because they can not get logged into message list (Inherited from ICodeProcessor.)
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any error is always thrown regardless of this parameter (Inherited from ICodeProcessor.)
Back to Top
See Also
IAnalysisContext Interface
NFX.CodeAnalysis Namespace


ICodeProcessor Interface

ICodeProcessor Interface NFX Class Library

Describes an entity that may process source code in some language

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ICodeProcessor
public interface ICodeProcessor
Public Interface ICodeProcessor
Public Interface ICodeProcessor
public interface class ICodeProcessor
public interface class ICodeProcessor
type ICodeProcessor =  interface end
type ICodeProcessor =  interface end
See Also
ICodeProcessor Members
NFX.CodeAnalysis Namespace


ICodeProcessor Members

ICodeProcessor Members NFX Class Library

The ICodeProcessor type exposes the following members.
Methods
 | Name | Description
Public method | MessageCodeToString | Returns string representation of message code which is output by this processor
Back to Top
Properties
 | Name | Description
Public property | Context | Returns context that this processor operates under
Public property | Language | References language that this entity supports
Public property | Messages | References message list that processor emitts messages into. May be null, in which case errors are always thrown because they can not get logged into message list
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any error is always thrown regardless of this parameter
Back to Top
See Also
ICodeProcessor Interface
NFX.CodeAnalysis Namespace


ICodeProcessor Methods

ICodeProcessor Methods NFX Class Library

The ICodeProcessor type exposes the following members.
Methods
 | Name | Description
Public method | MessageCodeToString | Returns string representation of message code which is output by this processor
Back to Top
See Also
ICodeProcessor Interface
NFX.CodeAnalysis Namespace


ICodeProcessor.MessageCodeToString Method

ICodeProcessor MessageCodeToString Method NFX Class Library

Returns string representation of message code which is output by this processor

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string MessageCodeToString(
    int code
)
string MessageCodeToString(
    int code
)
Function MessageCodeToString (
    code As Integer
) As String
Function MessageCodeToString (
    code As Integer
) As String
String^ MessageCodeToString(
    int code
)
String^ MessageCodeToString(
    int code
)
abstract MessageCodeToString :
        code : int -> string
abstract MessageCodeToString :
        code : int -> string

Parameters

code
Type: Online System Int32

Return Value

Type: Online String
See Also
ICodeProcessor Interface
ICodeProcessor Members
NFX.CodeAnalysis Namespace


ICodeProcessor Properties

ICodeProcessor Properties NFX Class Library

The ICodeProcessor type exposes the following members.
Properties
 | Name | Description
Public property | Context | Returns context that this processor operates under
Public property | Language | References language that this entity supports
Public property | Messages | References message list that processor emitts messages into. May be null, in which case errors are always thrown because they can not get logged into message list
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any error is always thrown regardless of this parameter
Back to Top
See Also
ICodeProcessor Interface
NFX.CodeAnalysis Namespace


ICodeProcessor.Context Property

ICodeProcessor Context Property NFX Class Library

Returns context that this processor operates under

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IAnalysisContext Context { get; }
IAnalysisContext Context { get; }
ReadOnly Property Context As IAnalysisContext
    Get
ReadOnly Property Context As IAnalysisContext
    Get
property IAnalysisContext^ Context {
    IAnalysisContext^ get ();
}
property IAnalysisContext^ Context {
    IAnalysisContext^ get ();
}
abstract Context : IAnalysisContext with get
abstract Context : IAnalysisContext with get

Property Value

Type: IAnalysisContext
See Also
ICodeProcessor Interface
ICodeProcessor Members
NFX.CodeAnalysis Namespace


ICodeProcessor.Language Property

ICodeProcessor Language Property NFX Class Library

References language that this entity supports

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Language Language { get; }
Language Language { get; }
ReadOnly Property Language As Language
    Get
ReadOnly Property Language As Language
    Get
property Language^ Language {
    Language^ get ();
}
property Language^ Language {
    Language^ get ();
}
abstract Language : Language with get
abstract Language : Language with get

Property Value

Type: Language
See Also
ICodeProcessor Interface
ICodeProcessor Members
NFX.CodeAnalysis Namespace


ICodeProcessor.Messages Property

ICodeProcessor Messages Property NFX Class Library

References message list that processor emitts messages into. May be null, in which case errors are always thrown because they can not get logged into message list

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
MessageList Messages { get; }
MessageList Messages { get; }
ReadOnly Property Messages As MessageList
    Get
ReadOnly Property Messages As MessageList
    Get
property MessageList^ Messages {
    MessageList^ get ();
}
property MessageList^ Messages {
    MessageList^ get ();
}
abstract Messages : MessageList with get
abstract Messages : MessageList with get

Property Value

Type: MessageList
See Also
ICodeProcessor Interface
ICodeProcessor Members
NFX.CodeAnalysis Namespace


ICodeProcessor.ThrowErrors Property

ICodeProcessor ThrowErrors Property NFX Class Library

When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any error is always thrown regardless of this parameter

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool ThrowErrors { get; }
bool ThrowErrors { get; }
ReadOnly Property ThrowErrors As Boolean
    Get
ReadOnly Property ThrowErrors As Boolean
    Get
property bool ThrowErrors {
    bool get ();
}
property bool ThrowErrors {
    bool get ();
}
abstract ThrowErrors : bool with get
abstract ThrowErrors : bool with get

Property Value

Type: Online Boolean
See Also
ICodeProcessor Interface
ICodeProcessor Members
NFX.CodeAnalysis Namespace


ILanguageProcessorNotifications Interface

ILanguageProcessorNotifications Interface NFX Class Library

Describes an entity capable of receiving messages as they are emitted by entities such as parsers and compilers

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ILanguageProcessorNotifications
public interface ILanguageProcessorNotifications
Public Interface ILanguageProcessorNotifications
Public Interface ILanguageProcessorNotifications
public interface class ILanguageProcessorNotifications
public interface class ILanguageProcessorNotifications
type ILanguageProcessorNotifications =  interface end
type ILanguageProcessorNotifications =  interface end
See Also
ILanguageProcessorNotifications Members
NFX.CodeAnalysis Namespace


ILanguageProcessorNotifications Members

ILanguageProcessorNotifications Members NFX Class Library

The ILanguageProcessorNotifications type exposes the following members.
Methods
 | Name | Description
Public method | MessageAdded |
Back to Top
See Also
ILanguageProcessorNotifications Interface
NFX.CodeAnalysis Namespace


ILanguageProcessorNotifications Methods

ILanguageProcessorNotifications Methods NFX Class Library

The ILanguageProcessorNotifications type exposes the following members.
Methods
 | Name | Description
Public method | MessageAdded |
Back to Top
See Also
ILanguageProcessorNotifications Interface
NFX.CodeAnalysis Namespace


ILanguageProcessorNotifications.MessageAdded Method

ILanguageProcessorNotifications MessageAdded Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void MessageAdded(
    Message message
)
void MessageAdded(
    Message message
)
Sub MessageAdded (
    message As Message
)
Sub MessageAdded (
    message As Message
)
void MessageAdded(
    Message^ message
)
void MessageAdded(
    Message^ message
)
abstract MessageAdded :
        message : Message -> unit
abstract MessageAdded :
        message : Message -> unit

Parameters

message
Type: NFX.CodeAnalysis Message
See Also
ILanguageProcessorNotifications Interface
ILanguageProcessorNotifications Members
NFX.CodeAnalysis Namespace


ILexer Interface

ILexer Interface NFX Class Library

Describes general lexer interface. Lexers turn string source input which is obtained via ISourceText implementation (i.e. FileSource,WebSource...) into tokenized stream. Some lexer implementations may support lazy analysis, that is - source text analysis which is done in chunks when lexer is iterated over, others may lex the whole source text at once

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ILexer : ICodeProcessor
public interface ILexer : ICodeProcessor
Public Interface ILexer
    Inherits ICodeProcessor
Public Interface ILexer
    Inherits ICodeProcessor
public interface class ILexer : ICodeProcessor
public interface class ILexer : ICodeProcessor
type ILexer =
    interface
        interface ICodeProcessor
    end
type ILexer =
    interface
        interface ICodeProcessor
    end
See Also
ILexer Members
NFX.CodeAnalysis Namespace


ILexer Members

ILexer Members NFX Class Library

The ILexer type exposes the following members.
Methods
 | Name | Description
Public method | AnalyzeAll | If lexer supports lazy analysis, forces analysis of the whole source
Public method | MessageCodeToString | Returns string representation of message code which is output by this processor (Inherited from ICodeProcessor.)
Back to Top
Properties
 | Name | Description
Public property | AllAnalyzed | Returns true when the shole input source has been analyzed. This property is always true for lexers that do not support lazy analysis
Public property | Context | Returns context that this processor operates under (Inherited from ICodeProcessor.)
Public property | Language | References language that this entity supports (Inherited from ICodeProcessor.)
Public property | Messages | References message list that processor emitts messages into. May be null, in which case errors are always thrown because they can not get logged into message list (Inherited from ICodeProcessor.)
Public property | Source | References source code text that was lexed
Public property | SourceCodeReference | References source code that was lexed
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any error is always thrown regardless of this parameter (Inherited from ICodeProcessor.)
Public property | TokenStream | Enumerates Token stream - depending on implementation enumeration may do lexical analysis token-by-token or in chunks with every enumerator advance
Back to Top
See Also
ILexer Interface
NFX.CodeAnalysis Namespace


ILexer Methods

ILexer Methods NFX Class Library

The ILexer type exposes the following members.
Methods
 | Name | Description
Public method | AnalyzeAll | If lexer supports lazy analysis, forces analysis of the whole source
Public method | MessageCodeToString | Returns string representation of message code which is output by this processor (Inherited from ICodeProcessor.)
Back to Top
See Also
ILexer Interface
NFX.CodeAnalysis Namespace


ILexer.AnalyzeAll Method

ILexer AnalyzeAll Method NFX Class Library

If lexer supports lazy analysis, forces analysis of the whole source

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void AnalyzeAll()
void AnalyzeAll()
Sub AnalyzeAll
Sub AnalyzeAll
void AnalyzeAll()
void AnalyzeAll()
abstract AnalyzeAll : unit -> unit
abstract AnalyzeAll : unit -> unit
See Also
ILexer Interface
ILexer Members
NFX.CodeAnalysis Namespace


ILexer Properties

ILexer Properties NFX Class Library

The ILexer type exposes the following members.
Properties
 | Name | Description
Public property | AllAnalyzed | Returns true when the shole input source has been analyzed. This property is always true for lexers that do not support lazy analysis
Public property | Context | Returns context that this processor operates under (Inherited from ICodeProcessor.)
Public property | Language | References language that this entity supports (Inherited from ICodeProcessor.)
Public property | Messages | References message list that processor emitts messages into. May be null, in which case errors are always thrown because they can not get logged into message list (Inherited from ICodeProcessor.)
Public property | Source | References source code text that was lexed
Public property | SourceCodeReference | References source code that was lexed
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any error is always thrown regardless of this parameter (Inherited from ICodeProcessor.)
Public property | TokenStream | Enumerates Token stream - depending on implementation enumeration may do lexical analysis token-by-token or in chunks with every enumerator advance
Back to Top
See Also
ILexer Interface
NFX.CodeAnalysis Namespace


ILexer.AllAnalyzed Property

ILexer AllAnalyzed Property NFX Class Library

Returns true when the shole input source has been analyzed. This property is always true for lexers that do not support lazy analysis

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool AllAnalyzed { get; }
bool AllAnalyzed { get; }
ReadOnly Property AllAnalyzed As Boolean
    Get
ReadOnly Property AllAnalyzed As Boolean
    Get
property bool AllAnalyzed {
    bool get ();
}
property bool AllAnalyzed {
    bool get ();
}
abstract AllAnalyzed : bool with get
abstract AllAnalyzed : bool with get

Property Value

Type: Online Boolean
See Also
ILexer Interface
ILexer Members
NFX.CodeAnalysis Namespace


ILexer.Source Property

ILexer Source Property NFX Class Library

References source code text that was lexed

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ISourceText Source { get; }
ISourceText Source { get; }
ReadOnly Property Source As ISourceText
    Get
ReadOnly Property Source As ISourceText
    Get
property ISourceText^ Source {
    ISourceText^ get ();
}
property ISourceText^ Source {
    ISourceText^ get ();
}
abstract Source : ISourceText with get
abstract Source : ISourceText with get

Property Value

Type: ISourceText
See Also
ILexer Interface
ILexer Members
NFX.CodeAnalysis Namespace


ILexer.SourceCodeReference Property

ILexer SourceCodeReference Property NFX Class Library

References source code that was lexed

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
SourceCodeRef SourceCodeReference { get; }
SourceCodeRef SourceCodeReference { get; }
ReadOnly Property SourceCodeReference As SourceCodeRef
    Get
ReadOnly Property SourceCodeReference As SourceCodeRef
    Get
property SourceCodeRef SourceCodeReference {
    SourceCodeRef get ();
}
property SourceCodeRef SourceCodeReference {
    SourceCodeRef get ();
}
abstract SourceCodeReference : SourceCodeRef with get
abstract SourceCodeReference : SourceCodeRef with get

Property Value

Type: SourceCodeRef
See Also
ILexer Interface
ILexer Members
NFX.CodeAnalysis Namespace


ILexer.TokenStream Property

ILexer TokenStream Property NFX Class Library

Enumerates Token stream - depending on implementation enumeration may do lexical analysis token-by-token or in chunks with every enumerator advance

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<Token> TokenStream { get; }
IEnumerable<Token> TokenStream { get; }
ReadOnly Property TokenStream As IEnumerable(Of Token)
    Get
ReadOnly Property TokenStream As IEnumerable(Of Token)
    Get
property IEnumerable<Token^>^ TokenStream {
    IEnumerable<Token^>^ get ();
}
property IEnumerable<Token^>^ TokenStream {
    IEnumerable<Token^>^ get ();
}
abstract TokenStream : IEnumerable<Token> with get
abstract TokenStream : IEnumerable<Token> with get

Property Value

Type: Online IEnumerable Token
See Also
ILexer Interface
ILexer Members
NFX.CodeAnalysis Namespace


IParser Interface

IParser Interface NFX Class Library

Describes general parser interface

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IParser : ICodeProcessor
public interface IParser : ICodeProcessor
Public Interface IParser
    Inherits ICodeProcessor
Public Interface IParser
    Inherits ICodeProcessor
public interface class IParser : ICodeProcessor
public interface class IParser : ICodeProcessor
type IParser =
    interface
        interface ICodeProcessor
    end
type IParser =
    interface
        interface ICodeProcessor
    end
See Also
IParser Members
NFX.CodeAnalysis Namespace


IParser Members

IParser Members NFX Class Library

The IParser type exposes the following members.
Methods
 | Name | Description
Public method | MessageCodeToString | Returns string representation of message code which is output by this processor (Inherited from ICodeProcessor.)
Public method | Parse | Performs parsing and sets HasParsed to true if it has not been performed yet
Back to Top
Properties
 | Name | Description
Public property | Context | Returns context that this processor operates under (Inherited from ICodeProcessor.)
Public property | HasParsed | Indicates whether Parse() already happened
Public property | Language | References language that this entity supports (Inherited from ICodeProcessor.)
Public property | Messages | References message list that processor emitts messages into. May be null, in which case errors are always thrown because they can not get logged into message list (Inherited from ICodeProcessor.)
Public property | SourceInput | Lists source lexers that supply token stream for parsing
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any error is always thrown regardless of this parameter (Inherited from ICodeProcessor.)
Back to Top
See Also
IParser Interface
NFX.CodeAnalysis Namespace


IParser Methods

IParser Methods NFX Class Library

The IParser type exposes the following members.
Methods
 | Name | Description
Public method | MessageCodeToString | Returns string representation of message code which is output by this processor (Inherited from ICodeProcessor.)
Public method | Parse | Performs parsing and sets HasParsed to true if it has not been performed yet
Back to Top
See Also
IParser Interface
NFX.CodeAnalysis Namespace


IParser.Parse Method

IParser Parse Method NFX Class Library

Performs parsing and sets HasParsed to true if it has not been performed yet

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Parse()
void Parse()
Sub Parse
Sub Parse
void Parse()
void Parse()
abstract Parse : unit -> unit
abstract Parse : unit -> unit
See Also
IParser Interface
IParser Members
NFX.CodeAnalysis Namespace


IParser Properties

IParser Properties NFX Class Library

The IParser type exposes the following members.
Properties
 | Name | Description
Public property | Context | Returns context that this processor operates under (Inherited from ICodeProcessor.)
Public property | HasParsed | Indicates whether Parse() already happened
Public property | Language | References language that this entity supports (Inherited from ICodeProcessor.)
Public property | Messages | References message list that processor emitts messages into. May be null, in which case errors are always thrown because they can not get logged into message list (Inherited from ICodeProcessor.)
Public property | SourceInput | Lists source lexers that supply token stream for parsing
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any error is always thrown regardless of this parameter (Inherited from ICodeProcessor.)
Back to Top
See Also
IParser Interface
NFX.CodeAnalysis Namespace


IParser.HasParsed Property

IParser HasParsed Property NFX Class Library

Indicates whether Parse() already happened

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool HasParsed { get; }
bool HasParsed { get; }
ReadOnly Property HasParsed As Boolean
    Get
ReadOnly Property HasParsed As Boolean
    Get
property bool HasParsed {
    bool get ();
}
property bool HasParsed {
    bool get ();
}
abstract HasParsed : bool with get
abstract HasParsed : bool with get

Property Value

Type: Online Boolean
See Also
IParser Interface
IParser Members
NFX.CodeAnalysis Namespace


IParser.SourceInput Property

IParser SourceInput Property NFX Class Library

Lists source lexers that supply token stream for parsing

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<ILexer> SourceInput { get; }
IEnumerable<ILexer> SourceInput { get; }
ReadOnly Property SourceInput As IEnumerable(Of ILexer)
    Get
ReadOnly Property SourceInput As IEnumerable(Of ILexer)
    Get
property IEnumerable<ILexer^>^ SourceInput {
    IEnumerable<ILexer^>^ get ();
}
property IEnumerable<ILexer^>^ SourceInput {
    IEnumerable<ILexer^>^ get ();
}
abstract SourceInput : IEnumerable<ILexer> with get
abstract SourceInput : IEnumerable<ILexer> with get

Property Value

Type: Online IEnumerable ILexer
See Also
IParser Interface
IParser Members
NFX.CodeAnalysis Namespace


IProjectItem Interface

IProjectItem Interface NFX Class Library

Represents an item that is a part of some project, i.e. a CS source file in CSharp project

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IProjectItem : INamed
public interface IProjectItem : INamed
Public Interface IProjectItem
    Inherits INamed
Public Interface IProjectItem
    Inherits INamed
public interface class IProjectItem : INamed
public interface class IProjectItem : INamed
type IProjectItem =
    interface
        interface INamed
    end
type IProjectItem =
    interface
        interface INamed
    end
See Also
IProjectItem Members
NFX.CodeAnalysis Namespace


IProjectItem Members

IProjectItem Members NFX Class Library

The IProjectItem type exposes the following members.
Properties
 | Name | Description
Public property | Name | (Inherited from INamed.)
Back to Top
See Also
IProjectItem Interface
NFX.CodeAnalysis Namespace


IProjectItem Properties

IProjectItem Properties NFX Class Library

The IProjectItem type exposes the following members.
Properties
 | Name | Description
Public property | Name | (Inherited from INamed.)
Back to Top
See Also
IProjectItem Interface
NFX.CodeAnalysis Namespace


Language Class

Language Class NFX Class Library

Represents and abstraction of the language
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis Language
NFX.CodeAnalysis.CSharp CSLanguage
NFX.CodeAnalysis.JSON JSONLanguage
NFX.CodeAnalysis.Laconfig LaconfigLanguage
NFX.CodeAnalysis UnspecifiedLanguage
NFX.CodeAnalysis.XML XMLLanguage

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Language
public abstract class Language
Public MustInherit Class Language
Public MustInherit Class Language
public ref class Language abstract
public ref class Language abstract
[<AbstractClassAttribute>]
type Language =  class end
[<AbstractClassAttribute>]
type Language =  class end
See Also
Language Members
NFX.CodeAnalysis Namespace


Language Members

Language Members NFX Class Library

The Language type exposes the following members.
Constructors
 | Name | Description
Protected method | Language | Initializes a new instance of the Language class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeLexer | Makes lexer capable of this language analysis
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
 | TryFindLanguageByFileExtension | Tries to find a language by file extension or returns UnspecifiedLanguage
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
 | All | Returns all languages registered in the system
Public property | Family | Returns language family categorization
Public property | FileExtensions | Returns file extensions without '.'
Back to Top
See Also
Language Class
NFX.CodeAnalysis Namespace


Language Constructor

Language Constructor NFX Class Library

Initializes a new instance of the Language class

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Language()
protected Language()
Protected Sub New
Protected Sub New
protected:
Language()
protected:
Language()
new : unit -> Language
new : unit -> Language
See Also
Language Class
Language Members
NFX.CodeAnalysis Namespace


Language Methods

Language Methods NFX Class Library

The Language type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeLexer | Makes lexer capable of this language analysis
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
 | TryFindLanguageByFileExtension | Tries to find a language by file extension or returns UnspecifiedLanguage
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Language Class
NFX.CodeAnalysis Namespace


Language.MakeLexer Method

Language MakeLexer Method NFX Class Library

Makes lexer capable of this language analysis

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract ILexer MakeLexer(
    IAnalysisContext context,
    SourceCodeRef srcRef,
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
public abstract ILexer MakeLexer(
    IAnalysisContext context,
    SourceCodeRef srcRef,
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
Public MustOverride Function MakeLexer (
    context As IAnalysisContext,
    srcRef As SourceCodeRef,
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
) As ILexer
Public MustOverride Function MakeLexer (
    context As IAnalysisContext,
    srcRef As SourceCodeRef,
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
) As ILexer
public:
virtual ILexer^ MakeLexer(
    IAnalysisContext^ context,
    SourceCodeRef srcRef,
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
) abstract
public:
virtual ILexer^ MakeLexer(
    IAnalysisContext^ context,
    SourceCodeRef srcRef,
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
) abstract
abstract MakeLexer :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> ILexer
abstract MakeLexer :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> ILexer

Parameters

context
Type: NFX.CodeAnalysis IAnalysisContext
srcRef
Type: NFX.CodeAnalysis.Source SourceCodeRef
source
Type: NFX.CodeAnalysis.Source ISourceText
messages (Optional)
Type: NFX.CodeAnalysis MessageList
throwErrors (Optional)
Type: Online System Boolean

Return Value

Type: ILexer
See Also
Language Class
Language Members
NFX.CodeAnalysis Namespace


Language.ToString Method

Language ToString Method NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
Language Class
Language Members
NFX.CodeAnalysis Namespace


Language.TryFindLanguageByFileExtension Method

Language TryFindLanguageByFileExtension Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Tries to find a language by file extension or returns UnspecifiedLanguage

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Language TryFindLanguageByFileExtension(
    string fileExtension
)
public static Language TryFindLanguageByFileExtension(
    string fileExtension
)
Public Shared Function TryFindLanguageByFileExtension (
    fileExtension As String
) As Language
Public Shared Function TryFindLanguageByFileExtension (
    fileExtension As String
) As Language
public:
static Language^ TryFindLanguageByFileExtension(
    String^ fileExtension
)
public:
static Language^ TryFindLanguageByFileExtension(
    String^ fileExtension
)
static member TryFindLanguageByFileExtension :
        fileExtension : string -> Language
static member TryFindLanguageByFileExtension :
        fileExtension : string -> Language

Parameters

fileExtension
Type: Online System String

Return Value

Type: Language
See Also
Language Class
Language Members
NFX.CodeAnalysis Namespace


Language Properties

Language Properties NFX Class Library

The Language type exposes the following members.
Properties
 | Name | Description
 | All | Returns all languages registered in the system
Public property | Family | Returns language family categorization
Public property | FileExtensions | Returns file extensions without '.'
Back to Top
See Also
Language Class
NFX.CodeAnalysis Namespace


Language.All Property

Language All Property NFX Class Library

Returns all languages registered in the system

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<Language> All { get; }
public static IEnumerable<Language> All { get; }
Public Shared ReadOnly Property All As IEnumerable(Of Language)
    Get
Public Shared ReadOnly Property All As IEnumerable(Of Language)
    Get
public:
static property IEnumerable<Language^>^ All {
    IEnumerable<Language^>^ get ();
}
public:
static property IEnumerable<Language^>^ All {
    IEnumerable<Language^>^ get ();
}
static member All : IEnumerable<Language> with get
static member All : IEnumerable<Language> with get

Property Value

Type: Online IEnumerable Language
See Also
Language Class
Language Members
NFX.CodeAnalysis Namespace


Language.Family Property

Language Family Property NFX Class Library

Returns language family categorization

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract LanguageFamily Family { get; }
public abstract LanguageFamily Family { get; }
Public MustOverride ReadOnly Property Family As LanguageFamily
    Get
Public MustOverride ReadOnly Property Family As LanguageFamily
    Get
public:
virtual property LanguageFamily Family {
    LanguageFamily get () abstract;
}
public:
virtual property LanguageFamily Family {
    LanguageFamily get () abstract;
}
abstract Family : LanguageFamily with get
abstract Family : LanguageFamily with get

Property Value

Type: LanguageFamily
See Also
Language Class
Language Members
NFX.CodeAnalysis Namespace


Language.FileExtensions Property

Language FileExtensions Property NFX Class Library

Returns file extensions without '.'

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract IEnumerable<string> FileExtensions { get; }
public abstract IEnumerable<string> FileExtensions { get; }
Public MustOverride ReadOnly Property FileExtensions As IEnumerable(Of String)
    Get
Public MustOverride ReadOnly Property FileExtensions As IEnumerable(Of String)
    Get
public:
virtual property IEnumerable<String^>^ FileExtensions {
    IEnumerable<String^>^ get () abstract;
}
public:
virtual property IEnumerable<String^>^ FileExtensions {
    IEnumerable<String^>^ get () abstract;
}
abstract FileExtensions : IEnumerable<string> with get
abstract FileExtensions : IEnumerable<string> with get

Property Value

Type: Online IEnumerable Online String
See Also
Language Class
Language Members
NFX.CodeAnalysis Namespace


LanguageFamily Enumeration

LanguageFamily Enumeration NFX Class Library

Defines various languages

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum LanguageFamily
public enum LanguageFamily
Public Enumeration LanguageFamily
Public Enumeration LanguageFamily
public enum class LanguageFamily
public enum class LanguageFamily
type LanguageFamily
type LanguageFamily
Members
Member name | Value | Description
Other | 0 |
StructuredConfig | 1 |
Aum | 2 |
CSharp | 3 |
C | 4 |
CPP | 5 |
Erlang | 6 |
JavaScript | 7 |
Java | 8 |
INI | 9 |
XML | 10 |
See Also
NFX.CodeAnalysis Namespace


LazyFSMPredicate(TToken) Delegate

LazyFSMPredicate TToken Delegate NFX Class Library

Lazy Finate State Machine (FSM) predicate, tries to match condition and returns appropriate next action

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate FSMI LazyFSMPredicate<TToken>(
    LazyFSMState<TToken> state,
    TToken token
)
where TToken : Token
public delegate FSMI LazyFSMPredicate<TToken>(
    LazyFSMState<TToken> state,
    TToken token
)
where TToken : Token
Public Delegate Function LazyFSMPredicate(Of TToken As Token) (
    state As LazyFSMState(Of TToken),
    token As TToken
) As FSMI
Public Delegate Function LazyFSMPredicate(Of TToken As Token) (
    state As LazyFSMState(Of TToken),
    token As TToken
) As FSMI
generic<typename TToken>
where TToken : Token
public delegate FSMI LazyFSMPredicate(
    LazyFSMState<TToken>^ state,
    TToken token
)
generic<typename TToken>
where TToken : Token
public delegate FSMI LazyFSMPredicate(
    LazyFSMState<TToken>^ state,
    TToken token
)
type LazyFSMPredicate =
    delegate of
        state : LazyFSMState<'TToken> *
        token : 'TToken -> FSMI
type LazyFSMPredicate =
    delegate of
        state : LazyFSMState<'TToken> *
        token : 'TToken -> FSMI

Parameters

state
Type: NFX.CodeAnalysis LazyFSMState TToken
token
Type: TToken
Type Parameters
TToken

Return Value

Type: FSMI
See Also
NFX.CodeAnalysis Namespace


LazyFSMState(TToken) Class

LazyFSMState TToken Class NFX Class Library

Represents a state object for Lazy Finate State Machine that enumerates tokes from IEnumerable(Token) and does not support a notion of index addressing
Inheritance Hierarchy
Online System Object
Online System.Collections Hashtable
NFX.CodeAnalysis LazyFSMState TToken

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LazyFSMState<TToken> : Hashtable
where TToken : Token
public class LazyFSMState<TToken> : Hashtable
where TToken : Token
Public Class LazyFSMState(Of TToken As Token)
    Inherits Hashtable
Public Class LazyFSMState(Of TToken As Token)
    Inherits Hashtable
generic<typename TToken>
where TToken : Token
public ref class LazyFSMState : public Hashtable
generic<typename TToken>
where TToken : Token
public ref class LazyFSMState : public Hashtable
type LazyFSMState<'TToken when 'TToken : Token> =
    class
        inherit Hashtable
    end
type LazyFSMState<'TToken when 'TToken : Token> =
    class
        inherit Hashtable
    end
Type Parameters
TToken
See Also
LazyFSMState TToken Members
NFX.CodeAnalysis Namespace


LazyFSMState(TToken) Members

LazyFSMState TToken Members NFX Class Library

The LazyFSMState TToken type exposes the following members.
Constructors
 | Name | Description
Public method | LazyFSMState TToken | Initializes a new instance of the LazyFSMState TToken class
Back to Top
Methods
 | Name | Description
Public method | Online Add | (Inherited from Online Hashtable.)
Public method | Online Clear | (Inherited from Online Hashtable.)
Public method | Online Clone | (Inherited from Online Hashtable.)
Public method | Online Contains | (Inherited from Online Hashtable.)
Public method | Online ContainsKey | (Inherited from Online Hashtable.)
Public method | Online ContainsValue | (Inherited from Online Hashtable.)
Public method | Online CopyTo | (Inherited from Online Hashtable.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get TCast | Gets typecasted value for a key
Public method | Online GetEnumerator | (Inherited from Online Hashtable.)
Protected method | Online GetHash | (Inherited from Online Hashtable.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online Hashtable. (Inherited from Online Hashtable.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online KeyEquals | (Inherited from Online Hashtable.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online Hashtable.)
Public method | Online Remove | (Inherited from Online Hashtable.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | LoopUntilAfterMatch TToken | Loops until token pattern match succeeds. This method matches using the same primary token filter as the parent match. Keeps state machine if match was found on the first token that follows the match (Defined by PatternSearch.)
Public Extension Method | LoopUntilMatch TToken ( LazyFSMPredicate TToken ) | Overloaded. Loops until token pattern match succeeds, considering only primary language tokens. Keeps state machine if match was found on the first matching token (Defined by PatternSearch.)
Public Extension Method | LoopUntilMatch TToken (Boolean, LazyFSMPredicate TToken ) | Overloaded. Loops until token pattern match succeeds, conditionaly considering only primary language tokens. Keeps state machine if match was found on the first matching token (Defined by PatternSearch.)
Public Extension Method | Skip TToken | Skips specified number of tokens by returning FSMI.Loop count times (Defined by PatternSearch.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_CurrentToken |
Protected field | m_CurrentTokenIndex |
Protected field | m_OnlyPrimary |
Protected field | m_PatternTokenLength |
Protected field | m_SkipCount |
Protected field | m_Tokens |
Back to Top
Properties
 | Name | Description
Protected property | Online comparer | Obsolete. Gets or sets the Online IComparer to use for the Online Hashtable. (Inherited from Online Hashtable.)
Public property | Online Count | (Inherited from Online Hashtable.)
Public property | CurrentToken | Returns token that machine is at now
Public property | CurrentTokenIndex | Returns an index for token that machine is on now
Protected property | Online EqualityComparer | (Inherited from Online Hashtable.)
Protected property | Online hcp | Obsolete. Gets or sets the object that can dispense hash codes. (Inherited from Online Hashtable.)
Public property | Online IsFixedSize | (Inherited from Online Hashtable.)
Public property | Online IsReadOnly | (Inherited from Online Hashtable.)
Public property | Online IsSynchronized | (Inherited from Online Hashtable.)
Public property | Online Item | (Inherited from Online Hashtable.)
Public property | Online Keys | (Inherited from Online Hashtable.)
Public property | OnlyPrimary | Returns true when state machine only considers language-primary tokens
Public property | PatternTokenLength | Returns how many tokens have been covered by the current match pattern, i.e. if we loop until first int literal, this property will count how many tokens have been looped + int literal itself
Public property | Online SyncRoot | (Inherited from Online Hashtable.)
Public property | Tokens | Returns token enumerable that analysis is performed on
Public property | Online Values | (Inherited from Online Hashtable.)
Back to Top
See Also
LazyFSMState TToken Class
NFX.CodeAnalysis Namespace


LazyFSMState(TToken) Constructor

LazyFSMState TToken Constructor NFX Class Library

Initializes a new instance of the LazyFSMState TToken class

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LazyFSMState()
public LazyFSMState()
Public Sub New
Public Sub New
public:
LazyFSMState()
public:
LazyFSMState()
new : unit -> LazyFSMState
new : unit -> LazyFSMState
See Also
LazyFSMState TToken Class
LazyFSMState TToken Members
NFX.CodeAnalysis Namespace


LazyFSMState(TToken) Fields

LazyFSMState TToken Fields NFX Class Library

The LazyFSMState TToken type exposes the following members.
Fields
 | Name | Description
Protected field | m_CurrentToken |
Protected field | m_CurrentTokenIndex |
Protected field | m_OnlyPrimary |
Protected field | m_PatternTokenLength |
Protected field | m_SkipCount |
Protected field | m_Tokens |
Back to Top
See Also
LazyFSMState TToken Class
NFX.CodeAnalysis Namespace


LazyFSMState(TToken).m_CurrentToken Field

LazyFSMState TToken m_CurrentToken Field NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Token m_CurrentToken
internal Token m_CurrentToken
Friend m_CurrentToken As Token
Friend m_CurrentToken As Token
internal:
Token^ m_CurrentToken
internal:
Token^ m_CurrentToken
val mutable internal m_CurrentToken: Token
val mutable internal m_CurrentToken: Token

Field Value

Type: Token
See Also
LazyFSMState TToken Class
LazyFSMState TToken Members
NFX.CodeAnalysis Namespace


LazyFSMState(TToken).m_CurrentTokenIndex Field

LazyFSMState TToken m_CurrentTokenIndex Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int m_CurrentTokenIndex
internal int m_CurrentTokenIndex
Friend m_CurrentTokenIndex As Integer
Friend m_CurrentTokenIndex As Integer
internal:
int m_CurrentTokenIndex
internal:
int m_CurrentTokenIndex
val mutable internal m_CurrentTokenIndex: int
val mutable internal m_CurrentTokenIndex: int

Field Value

Type: Online Int32
See Also
LazyFSMState TToken Class
LazyFSMState TToken Members
NFX.CodeAnalysis Namespace


LazyFSMState(TToken).m_OnlyPrimary Field

LazyFSMState TToken m_OnlyPrimary Field NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal bool m_OnlyPrimary
internal bool m_OnlyPrimary
Friend m_OnlyPrimary As Boolean
Friend m_OnlyPrimary As Boolean
internal:
bool m_OnlyPrimary
internal:
bool m_OnlyPrimary
val mutable internal m_OnlyPrimary: bool
val mutable internal m_OnlyPrimary: bool

Field Value

Type: Online Boolean
See Also
LazyFSMState TToken Class
LazyFSMState TToken Members
NFX.CodeAnalysis Namespace


LazyFSMState(TToken).m_PatternTokenLength Field

LazyFSMState TToken m_PatternTokenLength Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int m_PatternTokenLength
internal int m_PatternTokenLength
Friend m_PatternTokenLength As Integer
Friend m_PatternTokenLength As Integer
internal:
int m_PatternTokenLength
internal:
int m_PatternTokenLength
val mutable internal m_PatternTokenLength: int
val mutable internal m_PatternTokenLength: int

Field Value

Type: Online Int32
See Also
LazyFSMState TToken Class
LazyFSMState TToken Members
NFX.CodeAnalysis Namespace


LazyFSMState(TToken).m_SkipCount Field

LazyFSMState TToken m_SkipCount Field NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int m_SkipCount
internal int m_SkipCount
Friend m_SkipCount As Integer
Friend m_SkipCount As Integer
internal:
int m_SkipCount
internal:
int m_SkipCount
val mutable internal m_SkipCount: int
val mutable internal m_SkipCount: int

Field Value

Type: Online Int32
See Also
LazyFSMState TToken Class
LazyFSMState TToken Members
NFX.CodeAnalysis Namespace


LazyFSMState(TToken).m_Tokens Field

LazyFSMState TToken m_Tokens Field NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal IEnumerable<TToken> m_Tokens
internal IEnumerable<TToken> m_Tokens
Friend m_Tokens As IEnumerable(Of TToken)
Friend m_Tokens As IEnumerable(Of TToken)
internal:
IEnumerable<TToken>^ m_Tokens
internal:
IEnumerable<TToken>^ m_Tokens
val mutable internal m_Tokens: IEnumerable<'TToken>
val mutable internal m_Tokens: IEnumerable<'TToken>

Field Value

Type: Online IEnumerable TToken
See Also
LazyFSMState TToken Class
LazyFSMState TToken Members
NFX.CodeAnalysis Namespace


LazyFSMState(TToken) Methods

LazyFSMState TToken Methods NFX Class Library

The LazyFSMState TToken type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | (Inherited from Online Hashtable.)
Public method | Online Clear | (Inherited from Online Hashtable.)
Public method | Online Clone | (Inherited from Online Hashtable.)
Public method | Online Contains | (Inherited from Online Hashtable.)
Public method | Online ContainsKey | (Inherited from Online Hashtable.)
Public method | Online ContainsValue | (Inherited from Online Hashtable.)
Public method | Online CopyTo | (Inherited from Online Hashtable.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get TCast | Gets typecasted value for a key
Public method | Online GetEnumerator | (Inherited from Online Hashtable.)
Protected method | Online GetHash | (Inherited from Online Hashtable.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online Hashtable. (Inherited from Online Hashtable.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online KeyEquals | (Inherited from Online Hashtable.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online Hashtable.)
Public method | Online Remove | (Inherited from Online Hashtable.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | LoopUntilAfterMatch TToken | Loops until token pattern match succeeds. This method matches using the same primary token filter as the parent match. Keeps state machine if match was found on the first token that follows the match (Defined by PatternSearch.)
Public Extension Method | LoopUntilMatch TToken ( LazyFSMPredicate TToken ) | Overloaded. Loops until token pattern match succeeds, considering only primary language tokens. Keeps state machine if match was found on the first matching token (Defined by PatternSearch.)
Public Extension Method | LoopUntilMatch TToken (Boolean, LazyFSMPredicate TToken ) | Overloaded. Loops until token pattern match succeeds, conditionaly considering only primary language tokens. Keeps state machine if match was found on the first matching token (Defined by PatternSearch.)
Public Extension Method | Skip TToken | Skips specified number of tokens by returning FSMI.Loop count times (Defined by PatternSearch.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LazyFSMState TToken Class
NFX.CodeAnalysis Namespace


LazyFSMState(TToken).Get(TCast) Method

LazyFSMState TToken Get TCast Method NFX Class Library

Gets typecasted value for a key

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TCast Get<TCast>(
    Object key
)
public TCast Get<TCast>(
    Object key
)
Public Function Get(Of TCast) (
    key As Object
) As TCast
Public Function Get(Of TCast) (
    key As Object
) As TCast
public:
generic<typename TCast>
TCast Get(
    Object^ key
)
public:
generic<typename TCast>
TCast Get(
    Object^ key
)
member Get :
        key : Object -> 'TCast
member Get :
        key : Object -> 'TCast

Parameters

key
Type: Online System Object
Type Parameters
TCast

Return Value

Type: TCast
See Also
LazyFSMState TToken Class
LazyFSMState TToken Members
NFX.CodeAnalysis Namespace


LazyFSMState(TToken) Properties

LazyFSMState TToken Properties NFX Class Library

The LazyFSMState TToken type exposes the following members.
Properties
 | Name | Description
Protected property | Online comparer | Obsolete. Gets or sets the Online IComparer to use for the Online Hashtable. (Inherited from Online Hashtable.)
Public property | Online Count | (Inherited from Online Hashtable.)
Public property | CurrentToken | Returns token that machine is at now
Public property | CurrentTokenIndex | Returns an index for token that machine is on now
Protected property | Online EqualityComparer | (Inherited from Online Hashtable.)
Protected property | Online hcp | Obsolete. Gets or sets the object that can dispense hash codes. (Inherited from Online Hashtable.)
Public property | Online IsFixedSize | (Inherited from Online Hashtable.)
Public property | Online IsReadOnly | (Inherited from Online Hashtable.)
Public property | Online IsSynchronized | (Inherited from Online Hashtable.)
Public property | Online Item | (Inherited from Online Hashtable.)
Public property | Online Keys | (Inherited from Online Hashtable.)
Public property | OnlyPrimary | Returns true when state machine only considers language-primary tokens
Public property | PatternTokenLength | Returns how many tokens have been covered by the current match pattern, i.e. if we loop until first int literal, this property will count how many tokens have been looped + int literal itself
Public property | Online SyncRoot | (Inherited from Online Hashtable.)
Public property | Tokens | Returns token enumerable that analysis is performed on
Public property | Online Values | (Inherited from Online Hashtable.)
Back to Top
See Also
LazyFSMState TToken Class
NFX.CodeAnalysis Namespace


LazyFSMState(TToken).CurrentToken Property

LazyFSMState TToken CurrentToken Property NFX Class Library

Returns token that machine is at now

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Token CurrentToken { get; }
public Token CurrentToken { get; }
Public ReadOnly Property CurrentToken As Token
    Get
Public ReadOnly Property CurrentToken As Token
    Get
public:
property Token^ CurrentToken {
    Token^ get ();
}
public:
property Token^ CurrentToken {
    Token^ get ();
}
member CurrentToken : Token with get
member CurrentToken : Token with get

Property Value

Type: Token
See Also
LazyFSMState TToken Class
LazyFSMState TToken Members
NFX.CodeAnalysis Namespace


LazyFSMState(TToken).CurrentTokenIndex Property

LazyFSMState TToken CurrentTokenIndex Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns an index for token that machine is on now

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CurrentTokenIndex { get; }
public int CurrentTokenIndex { get; }
Public ReadOnly Property CurrentTokenIndex As Integer
    Get
Public ReadOnly Property CurrentTokenIndex As Integer
    Get
public:
property int CurrentTokenIndex {
    int get ();
}
public:
property int CurrentTokenIndex {
    int get ();
}
member CurrentTokenIndex : int with get
member CurrentTokenIndex : int with get

Property Value

Type: Online Int32
See Also
LazyFSMState TToken Class
LazyFSMState TToken Members
NFX.CodeAnalysis Namespace


LazyFSMState(TToken).OnlyPrimary Property

LazyFSMState TToken OnlyPrimary Property NFX Class Library

Returns true when state machine only considers language-primary tokens

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool OnlyPrimary { get; }
public bool OnlyPrimary { get; }
Public ReadOnly Property OnlyPrimary As Boolean
    Get
Public ReadOnly Property OnlyPrimary As Boolean
    Get
public:
property bool OnlyPrimary {
    bool get ();
}
public:
property bool OnlyPrimary {
    bool get ();
}
member OnlyPrimary : bool with get
member OnlyPrimary : bool with get

Property Value

Type: Online Boolean
See Also
LazyFSMState TToken Class
LazyFSMState TToken Members
NFX.CodeAnalysis Namespace


LazyFSMState(TToken).PatternTokenLength Property

LazyFSMState TToken PatternTokenLength Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns how many tokens have been covered by the current match pattern, i.e. if we loop until first int literal, this property will count how many tokens have been looped + int literal itself

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int PatternTokenLength { get; }
public int PatternTokenLength { get; }
Public ReadOnly Property PatternTokenLength As Integer
    Get
Public ReadOnly Property PatternTokenLength As Integer
    Get
public:
property int PatternTokenLength {
    int get ();
}
public:
property int PatternTokenLength {
    int get ();
}
member PatternTokenLength : int with get
member PatternTokenLength : int with get

Property Value

Type: Online Int32
See Also
LazyFSMState TToken Class
LazyFSMState TToken Members
NFX.CodeAnalysis Namespace


LazyFSMState(TToken).Tokens Property

LazyFSMState TToken Tokens Property NFX Class Library

Returns token enumerable that analysis is performed on

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<TToken> Tokens { get; }
public IEnumerable<TToken> Tokens { get; }
Public ReadOnly Property Tokens As IEnumerable(Of TToken)
    Get
Public ReadOnly Property Tokens As IEnumerable(Of TToken)
    Get
public:
property IEnumerable<TToken>^ Tokens {
    IEnumerable<TToken>^ get ();
}
public:
property IEnumerable<TToken>^ Tokens {
    IEnumerable<TToken>^ get ();
}
member Tokens : IEnumerable<'TToken> with get
member Tokens : IEnumerable<'TToken> with get

Property Value

Type: Online IEnumerable TToken
See Also
LazyFSMState TToken Class
LazyFSMState TToken Members
NFX.CodeAnalysis Namespace


Lexer(TToken) Class

Lexer TToken Class NFX Class Library

Performs lexical analysis of the source code in particular language Allows to enumerate over source as typed Token stream - depending on implementation enumeration may do lexical analysis token-by-token or in chunks with every enumerator advance
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis CommonCodeProcessor
NFX.CodeAnalysis SourceRefCommonCodeProcessor
NFX.CodeAnalysis Lexer TToken
NFX.CodeAnalysis.CSharp CSLexer
NFX.CodeAnalysis.JSON JSONLexer
NFX.CodeAnalysis.Laconfig LaconfigLexer

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Lexer<TToken> : SourceRefCommonCodeProcessor,
    ILexer, ICodeProcessor, IEnumerable<TToken>, IEnumerable
where TToken : Token
public abstract class Lexer<TToken> : SourceRefCommonCodeProcessor,
    ILexer, ICodeProcessor, IEnumerable<TToken>, IEnumerable
where TToken : Token
Public MustInherit Class Lexer(Of TToken As Token)
    Inherits SourceRefCommonCodeProcessor
    Implements ILexer, ICodeProcessor, IEnumerable(Of TToken),
    IEnumerable
Public MustInherit Class Lexer(Of TToken As Token)
    Inherits SourceRefCommonCodeProcessor
    Implements ILexer, ICodeProcessor, IEnumerable(Of TToken),
    IEnumerable
generic<typename TToken>
where TToken : Token
public ref class Lexer abstract : public SourceRefCommonCodeProcessor,
    ILexer, ICodeProcessor, IEnumerable<TToken>, IEnumerable
generic<typename TToken>
where TToken : Token
public ref class Lexer abstract : public SourceRefCommonCodeProcessor,
    ILexer, ICodeProcessor, IEnumerable<TToken>, IEnumerable
[<AbstractClassAttribute>]
type Lexer<'TToken when 'TToken : Token> =
    class
        inherit SourceRefCommonCodeProcessor
        interface ILexer
        interface ICodeProcessor
        interface IEnumerable<'TToken>
        interface IEnumerable
    end
[<AbstractClassAttribute>]
type Lexer<'TToken when 'TToken : Token> =
    class
        inherit SourceRefCommonCodeProcessor
        interface ILexer
        interface ICodeProcessor
        interface IEnumerable<'TToken>
        interface IEnumerable
    end
Type Parameters
TToken
See Also
Lexer TToken Members
NFX.CodeAnalysis Namespace


Lexer(TToken) Members

Lexer TToken Members NFX Class Library

The Lexer TToken type exposes the following members.
Constructors
 | Name | Description
Protected method | Lexer TToken (ISourceText, MessageList, Boolean) | Initializes a new instance of the Lexer TToken class
Protected method | Lexer TToken (IAnalysisContext, SourceCodeRef, ISourceText, MessageList, Boolean) | Initializes a new instance of the Lexer TToken class
Back to Top
Methods
 | Name | Description
Public method | AnalyzeAll | If lexer supports lazy analysis, forces analysis of the whole source
Protected method | DoLexingChunk | Lexes more source and returns true when EOF has been reached. Depending on particular implementation, a chunk may contain more than one token. Tokens are added into m_Tokens
Protected method | EmitMessage(MessageType, Int32, SourcePosition, Token, String, Exception) | (Inherited from SourceRefCommonCodeProcessor.)
Protected method | EmitMessage(MessageType, Int32, SourceCodeRef, Nullable SourcePosition , Token, String, Exception) | (Inherited from CommonCodeProcessor.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MessageCodeToString | Returns string representation of message code which is output by this processor (Inherited from CommonCodeProcessor.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable TToken | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct TToken, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax TToken, TComparand (Func TToken, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax TToken, TComparand (Func TToken, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin TToken, TComparand (Func TToken, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin TToken, TComparand (Func TToken, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault TToken | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach TToken (Action TToken ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach TToken (Action TToken, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | LazyFSM TToken ( LazyFSMPredicate TToken ) | Overloaded. Makes finite state machine fed from IEnumerable(Token) only considering primary language tokens (Defined by PatternSearch.)
Public Extension Method | LazyFSM TToken (Boolean, LazyFSMPredicate TToken ) | Overloaded. Makes finite state machine fed from IEnumerable(Token) (Defined by PatternSearch.)
Public Extension Method | LazyFSM TToken (Boolean, LazyFSMState TToken , LazyFSMPredicate TToken ) | Overloaded. Makes finite state machine fed from IEnumerable(Token) (Defined by PatternSearch.)
Public Extension Method | SkipLast TToken | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast TToken (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_AllAnalyzed |
Protected field | m_Tokens |
Back to Top
Properties
 | Name | Description
Public property | AllAnalyzed | Returns true when the whole input source has been analyzed. This property is always true for lexers that do not support lazy analysis
Public property | Context | Returns context that this processor operates under - an entity that retains state during analysis, such as: module compiler, project compiler, code unit translator etc. This entity may also contain compiler/parser/lexer options etc. (Inherited from CommonCodeProcessor.)
Public property | Language | Returns language that this processor is capable of processing (Inherited from CommonCodeProcessor.)
Public property | Messages | References message list that lexer emitts messages into. May be null (Inherited from CommonCodeProcessor.)
Public property | Source | References source code text that was lexed
Public property | SourceCodeReference | References source code that is processed (Inherited from SourceRefCommonCodeProcessor.)
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any lexing error is always thrown regardless of this parameter (Inherited from CommonCodeProcessor.)
Public property | Tokens | Returns tokenized source as indexable list. Accessing this property causes lexical analysis to complete on the whole source if it has not been completed yet
Public property | TokenStream | Enumerates Token stream - depending on implementation enumeration may do lexical analysis token-by-token or in chunks with every enumerator advance
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
Lexer TToken Class
NFX.CodeAnalysis Namespace


Lexer(TToken) Constructor

Lexer TToken Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | Lexer TToken (ISourceText, MessageList, Boolean) | Initializes a new instance of the Lexer TToken class
Protected method | Lexer TToken (IAnalysisContext, SourceCodeRef, ISourceText, MessageList, Boolean) | Initializes a new instance of the Lexer TToken class
Back to Top
See Also
Lexer TToken Class
Lexer TToken Members
NFX.CodeAnalysis Namespace


Lexer(TToken) Constructor (ISourceText, MessageList, Boolean)

Lexer TToken Constructor (ISourceText, MessageList, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Lexer TToken class

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Lexer(
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
protected Lexer(
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
Protected Sub New (
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
Protected Sub New (
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
protected:
Lexer(
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
protected:
Lexer(
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
new :
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> Lexer
new :
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> Lexer

Parameters

source
Type: NFX.CodeAnalysis.Source ISourceText
messages (Optional)
Type: NFX.CodeAnalysis MessageList
throwErrors (Optional)
Type: Online System Boolean
See Also
Lexer TToken Class
Lexer TToken Members
Lexer TToken Overload
NFX.CodeAnalysis Namespace


Lexer(TToken) Constructor (IAnalysisContext, SourceCodeRef, ISourceText, MessageList, Boolean)

Lexer TToken Constructor (IAnalysisContext, SourceCodeRef, ISourceText, MessageList, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Lexer TToken class

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Lexer(
    IAnalysisContext context,
    SourceCodeRef srcRef,
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
protected Lexer(
    IAnalysisContext context,
    SourceCodeRef srcRef,
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
Protected Sub New (
    context As IAnalysisContext,
    srcRef As SourceCodeRef,
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
Protected Sub New (
    context As IAnalysisContext,
    srcRef As SourceCodeRef,
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
protected:
Lexer(
    IAnalysisContext^ context,
    SourceCodeRef srcRef,
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
protected:
Lexer(
    IAnalysisContext^ context,
    SourceCodeRef srcRef,
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
new :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> Lexer
new :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> Lexer

Parameters

context
Type: NFX.CodeAnalysis IAnalysisContext
srcRef
Type: NFX.CodeAnalysis.Source SourceCodeRef
source
Type: NFX.CodeAnalysis.Source ISourceText
messages (Optional)
Type: NFX.CodeAnalysis MessageList
throwErrors (Optional)
Type: Online System Boolean
See Also
Lexer TToken Class
Lexer TToken Members
Lexer TToken Overload
NFX.CodeAnalysis Namespace


Lexer(TToken) Fields

Lexer TToken Fields NFX Class Library

The Lexer TToken type exposes the following members.
Fields
 | Name | Description
Protected field | m_AllAnalyzed |
Protected field | m_Tokens |
Back to Top
See Also
Lexer TToken Class
NFX.CodeAnalysis Namespace


Lexer(TToken).m_AllAnalyzed Field

Lexer TToken m_AllAnalyzed Field NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool m_AllAnalyzed
protected bool m_AllAnalyzed
Protected m_AllAnalyzed As Boolean
Protected m_AllAnalyzed As Boolean
protected:
bool m_AllAnalyzed
protected:
bool m_AllAnalyzed
val mutable m_AllAnalyzed: bool
val mutable m_AllAnalyzed: bool

Field Value

Type: Online Boolean
See Also
Lexer TToken Class
Lexer TToken Members
NFX.CodeAnalysis Namespace


Lexer(TToken).m_Tokens Field

Lexer TToken m_Tokens Field NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TokenList<TToken> m_Tokens
protected TokenList<TToken> m_Tokens
Protected m_Tokens As TokenList(Of TToken)
Protected m_Tokens As TokenList(Of TToken)
protected:
TokenList<TToken>^ m_Tokens
protected:
TokenList<TToken>^ m_Tokens
val mutable m_Tokens: TokenList<'TToken>
val mutable m_Tokens: TokenList<'TToken>

Field Value

Type: TokenList TToken
See Also
Lexer TToken Class
Lexer TToken Members
NFX.CodeAnalysis Namespace


Lexer(TToken) Methods

Lexer TToken Methods NFX Class Library

The Lexer TToken type exposes the following members.
Methods
 | Name | Description
Public method | AnalyzeAll | If lexer supports lazy analysis, forces analysis of the whole source
Protected method | DoLexingChunk | Lexes more source and returns true when EOF has been reached. Depending on particular implementation, a chunk may contain more than one token. Tokens are added into m_Tokens
Protected method | EmitMessage(MessageType, Int32, SourcePosition, Token, String, Exception) | (Inherited from SourceRefCommonCodeProcessor.)
Protected method | EmitMessage(MessageType, Int32, SourceCodeRef, Nullable SourcePosition , Token, String, Exception) | (Inherited from CommonCodeProcessor.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MessageCodeToString | Returns string representation of message code which is output by this processor (Inherited from CommonCodeProcessor.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable TToken | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct TToken, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax TToken, TComparand (Func TToken, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax TToken, TComparand (Func TToken, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin TToken, TComparand (Func TToken, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin TToken, TComparand (Func TToken, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault TToken | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach TToken (Action TToken ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach TToken (Action TToken, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | LazyFSM TToken ( LazyFSMPredicate TToken ) | Overloaded. Makes finite state machine fed from IEnumerable(Token) only considering primary language tokens (Defined by PatternSearch.)
Public Extension Method | LazyFSM TToken (Boolean, LazyFSMPredicate TToken ) | Overloaded. Makes finite state machine fed from IEnumerable(Token) (Defined by PatternSearch.)
Public Extension Method | LazyFSM TToken (Boolean, LazyFSMState TToken , LazyFSMPredicate TToken ) | Overloaded. Makes finite state machine fed from IEnumerable(Token) (Defined by PatternSearch.)
Public Extension Method | SkipLast TToken | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast TToken (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
Lexer TToken Class
NFX.CodeAnalysis Namespace


Lexer(TToken).IEnumerable.GetEnumerator Method

Lexer TToken IEnumerable GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
Lexer TToken Class
Lexer TToken Members
NFX.CodeAnalysis Namespace


Lexer(TToken).AnalyzeAll Method

Lexer TToken AnalyzeAll Method NFX Class Library

If lexer supports lazy analysis, forces analysis of the whole source

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AnalyzeAll()
public void AnalyzeAll()
Public Sub AnalyzeAll
Public Sub AnalyzeAll
public:
virtual void AnalyzeAll() sealed
public:
virtual void AnalyzeAll() sealed
abstract AnalyzeAll : unit -> unit
override AnalyzeAll : unit -> unit
abstract AnalyzeAll : unit -> unit
override AnalyzeAll : unit -> unit

Implements

ILexer AnalyzeAll
See Also
Lexer TToken Class
Lexer TToken Members
NFX.CodeAnalysis Namespace


Lexer(TToken).DoLexingChunk Method

Lexer TToken DoLexingChunk Method NFX Class Library

Lexes more source and returns true when EOF has been reached. Depending on particular implementation, a chunk may contain more than one token. Tokens are added into m_Tokens

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract bool DoLexingChunk()
protected abstract bool DoLexingChunk()
Protected MustOverride Function DoLexingChunk As Boolean
Protected MustOverride Function DoLexingChunk As Boolean
protected:
virtual bool DoLexingChunk() abstract
protected:
virtual bool DoLexingChunk() abstract
abstract DoLexingChunk : unit -> bool
abstract DoLexingChunk : unit -> bool

Return Value

Type: Online Boolean
See Also
Lexer TToken Class
Lexer TToken Members
NFX.CodeAnalysis Namespace


Lexer(TToken).GetEnumerator Method

Lexer TToken GetEnumerator Method NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<TToken> GetEnumerator()
public IEnumerator<TToken> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of TToken)
Public Function GetEnumerator As IEnumerator(Of TToken)
public:
virtual IEnumerator<TToken>^ GetEnumerator() sealed
public:
virtual IEnumerator<TToken>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<'TToken>
override GetEnumerator : unit -> IEnumerator<'TToken>
abstract GetEnumerator : unit -> IEnumerator<'TToken>
override GetEnumerator : unit -> IEnumerator<'TToken>

Return Value

Type: Online IEnumerator TToken

Implements

Online IEnumerable T GetEnumerator
See Also
Lexer TToken Class
Lexer TToken Members
NFX.CodeAnalysis Namespace


Lexer(TToken).ToString Method

Lexer TToken ToString Method NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
Lexer TToken Class
Lexer TToken Members
NFX.CodeAnalysis Namespace


Lexer(TToken) Properties

Lexer TToken Properties NFX Class Library

The Lexer TToken type exposes the following members.
Properties
 | Name | Description
Public property | AllAnalyzed | Returns true when the whole input source has been analyzed. This property is always true for lexers that do not support lazy analysis
Public property | Context | Returns context that this processor operates under - an entity that retains state during analysis, such as: module compiler, project compiler, code unit translator etc. This entity may also contain compiler/parser/lexer options etc. (Inherited from CommonCodeProcessor.)
Public property | Language | Returns language that this processor is capable of processing (Inherited from CommonCodeProcessor.)
Public property | Messages | References message list that lexer emitts messages into. May be null (Inherited from CommonCodeProcessor.)
Public property | Source | References source code text that was lexed
Public property | SourceCodeReference | References source code that is processed (Inherited from SourceRefCommonCodeProcessor.)
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any lexing error is always thrown regardless of this parameter (Inherited from CommonCodeProcessor.)
Public property | Tokens | Returns tokenized source as indexable list. Accessing this property causes lexical analysis to complete on the whole source if it has not been completed yet
Public property | TokenStream | Enumerates Token stream - depending on implementation enumeration may do lexical analysis token-by-token or in chunks with every enumerator advance
Back to Top
See Also
Lexer TToken Class
NFX.CodeAnalysis Namespace


Lexer(TToken).AllAnalyzed Property

Lexer TToken AllAnalyzed Property NFX Class Library

Returns true when the whole input source has been analyzed. This property is always true for lexers that do not support lazy analysis

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool AllAnalyzed { get; }
public bool AllAnalyzed { get; }
Public ReadOnly Property AllAnalyzed As Boolean
    Get
Public ReadOnly Property AllAnalyzed As Boolean
    Get
public:
virtual property bool AllAnalyzed {
    bool get () sealed;
}
public:
virtual property bool AllAnalyzed {
    bool get () sealed;
}
abstract AllAnalyzed : bool with get
override AllAnalyzed : bool with get
abstract AllAnalyzed : bool with get
override AllAnalyzed : bool with get

Property Value

Type: Online Boolean

Implements

ILexer AllAnalyzed
See Also
Lexer TToken Class
Lexer TToken Members
NFX.CodeAnalysis Namespace


Lexer(TToken).Source Property

Lexer TToken Source Property NFX Class Library

References source code text that was lexed

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ISourceText Source { get; }
public ISourceText Source { get; }
Public ReadOnly Property Source As ISourceText
    Get
Public ReadOnly Property Source As ISourceText
    Get
public:
virtual property ISourceText^ Source {
    ISourceText^ get () sealed;
}
public:
virtual property ISourceText^ Source {
    ISourceText^ get () sealed;
}
abstract Source : ISourceText with get
override Source : ISourceText with get
abstract Source : ISourceText with get
override Source : ISourceText with get

Property Value

Type: ISourceText

Implements

ILexer Source
See Also
Lexer TToken Class
Lexer TToken Members
NFX.CodeAnalysis Namespace


Lexer(TToken).Tokens Property

Lexer TToken Tokens Property NFX Class Library

Returns tokenized source as indexable list. Accessing this property causes lexical analysis to complete on the whole source if it has not been completed yet

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Tokenized<TToken> Tokens { get; }
public Tokenized<TToken> Tokens { get; }
Public ReadOnly Property Tokens As Tokenized(Of TToken)
    Get
Public ReadOnly Property Tokens As Tokenized(Of TToken)
    Get
public:
property Tokenized<TToken>^ Tokens {
    Tokenized<TToken>^ get ();
}
public:
property Tokenized<TToken>^ Tokens {
    Tokenized<TToken>^ get ();
}
member Tokens : Tokenized<'TToken> with get
member Tokens : Tokenized<'TToken> with get

Property Value

Type: Tokenized TToken
See Also
Lexer TToken Class
Lexer TToken Members
NFX.CodeAnalysis Namespace


Lexer(TToken).TokenStream Property

Lexer TToken TokenStream Property NFX Class Library

Enumerates Token stream - depending on implementation enumeration may do lexical analysis token-by-token or in chunks with every enumerator advance

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Token> TokenStream { get; }
public IEnumerable<Token> TokenStream { get; }
Public ReadOnly Property TokenStream As IEnumerable(Of Token)
    Get
Public ReadOnly Property TokenStream As IEnumerable(Of Token)
    Get
public:
virtual property IEnumerable<Token^>^ TokenStream {
    IEnumerable<Token^>^ get () sealed;
}
public:
virtual property IEnumerable<Token^>^ TokenStream {
    IEnumerable<Token^>^ get () sealed;
}
abstract TokenStream : IEnumerable<Token> with get
override TokenStream : IEnumerable<Token> with get
abstract TokenStream : IEnumerable<Token> with get
override TokenStream : IEnumerable<Token> with get

Property Value

Type: Online IEnumerable Token

Implements

ILexer TokenStream
See Also
Lexer TToken Class
Lexer TToken Members
NFX.CodeAnalysis Namespace


Message Class

Message Class NFX Class Library

Represents a message emitted from code-analyzing entities such as lexers, parsers, semantic analyzers and compilers. Messages have severity type like warning, info or error etc.
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis Message

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Message
public sealed class Message
Public NotInheritable Class Message
Public NotInheritable Class Message
public ref class Message sealed
public ref class Message sealed
[<SealedAttribute>]
type Message =  class end
[<SealedAttribute>]
type Message =  class end
See Also
Message Members
NFX.CodeAnalysis Namespace


Message Members

Message Members NFX Class Library

The Message type exposes the following members.
Constructors
 | Name | Description
Public method | Message(SourceCodeRef, MessageType, Int32, ICodeProcessor) | Initializes a new instance of the Message class
Public method | Message(SourceCodeRef, MessageType, Int32, ICodeProcessor, SourcePosition) | Initializes a new instance of the Message class
Public method | Message(SourceCodeRef, MessageType, Int32, ICodeProcessor, SourcePosition, Token) | Initializes a new instance of the Message class
Public method | Message(SourceCodeRef, MessageType, Int32, ICodeProcessor, SourcePosition, Token, String) | Initializes a new instance of the Message class
Public method | Message(SourceCodeRef, MessageType, Int32, ICodeProcessor, SourcePosition, Token, String, Exception) | Initializes a new instance of the Message class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | AssociatedException |
Public field | Code |
Public field | From |
Public field | Position |
Public field | SourceCodeReference |
Public field | Text |
Public field | Token |
Public field | Type |
Back to Top
Properties
 | Name | Description
Public property | IsError | Indicates whether this message is an error message
Public property | IsInfo | Indicates whether this message is an info message
Public property | IsInternal | Indicates whether this message is an internal message
Public property | IsWarning | Indicates whether this message is a warning message
Back to Top
See Also
Message Class
NFX.CodeAnalysis Namespace


Message Constructor

Message Constructor NFX Class Library

Overload List
 | Name | Description
Public method | Message(SourceCodeRef, MessageType, Int32, ICodeProcessor) | Initializes a new instance of the Message class
Public method | Message(SourceCodeRef, MessageType, Int32, ICodeProcessor, SourcePosition) | Initializes a new instance of the Message class
Public method | Message(SourceCodeRef, MessageType, Int32, ICodeProcessor, SourcePosition, Token) | Initializes a new instance of the Message class
Public method | Message(SourceCodeRef, MessageType, Int32, ICodeProcessor, SourcePosition, Token, String) | Initializes a new instance of the Message class
Public method | Message(SourceCodeRef, MessageType, Int32, ICodeProcessor, SourcePosition, Token, String, Exception) | Initializes a new instance of the Message class
Back to Top
See Also
Message Class
Message Members
NFX.CodeAnalysis Namespace


Message Constructor (SourceCodeRef, MessageType, Int32, ICodeProcessor)

Message Constructor (SourceCodeRef, MessageType, Int32, ICodeProcessor) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Message class

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Message(
    SourceCodeRef srcRef,
    MessageType type,
    int code,
    ICodeProcessor from
)
public Message(
    SourceCodeRef srcRef,
    MessageType type,
    int code,
    ICodeProcessor from
)
Public Sub New (
    srcRef As SourceCodeRef,
    type As MessageType,
    code As Integer,
    from As ICodeProcessor
)
Public Sub New (
    srcRef As SourceCodeRef,
    type As MessageType,
    code As Integer,
    from As ICodeProcessor
)
public:
Message(
    SourceCodeRef srcRef,
    MessageType type,
    int code,
    ICodeProcessor^ from
)
public:
Message(
    SourceCodeRef srcRef,
    MessageType type,
    int code,
    ICodeProcessor^ from
)
new :
        srcRef : SourceCodeRef *
        type : MessageType *
        code : int *
        from : ICodeProcessor -> Message
new :
        srcRef : SourceCodeRef *
        type : MessageType *
        code : int *
        from : ICodeProcessor -> Message

Parameters

srcRef
Type: NFX.CodeAnalysis.Source SourceCodeRef
type
Type: NFX.CodeAnalysis MessageType
code
Type: Online System Int32
from
Type: NFX.CodeAnalysis ICodeProcessor
See Also
Message Class
Message Members
Message Overload
NFX.CodeAnalysis Namespace


Message Constructor (SourceCodeRef, MessageType, Int32, ICodeProcessor, SourcePosition)

Message Constructor (SourceCodeRef, MessageType, Int32, ICodeProcessor, SourcePosition) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Message class

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Message(
    SourceCodeRef srcRef,
    MessageType type,
    int code,
    ICodeProcessor from,
    SourcePosition position
)
public Message(
    SourceCodeRef srcRef,
    MessageType type,
    int code,
    ICodeProcessor from,
    SourcePosition position
)
Public Sub New (
    srcRef As SourceCodeRef,
    type As MessageType,
    code As Integer,
    from As ICodeProcessor,
    position As SourcePosition
)
Public Sub New (
    srcRef As SourceCodeRef,
    type As MessageType,
    code As Integer,
    from As ICodeProcessor,
    position As SourcePosition
)
public:
Message(
    SourceCodeRef srcRef,
    MessageType type,
    int code,
    ICodeProcessor^ from,
    SourcePosition position
)
public:
Message(
    SourceCodeRef srcRef,
    MessageType type,
    int code,
    ICodeProcessor^ from,
    SourcePosition position
)
new :
        srcRef : SourceCodeRef *
        type : MessageType *
        code : int *
        from : ICodeProcessor *
        position : SourcePosition -> Message
new :
        srcRef : SourceCodeRef *
        type : MessageType *
        code : int *
        from : ICodeProcessor *
        position : SourcePosition -> Message

Parameters

srcRef
Type: NFX.CodeAnalysis.Source SourceCodeRef
type
Type: NFX.CodeAnalysis MessageType
code
Type: Online System Int32
from
Type: NFX.CodeAnalysis ICodeProcessor
position
Type: NFX.CodeAnalysis.Source SourcePosition
See Also
Message Class
Message Members
Message Overload
NFX.CodeAnalysis Namespace


Message Constructor (SourceCodeRef, MessageType, Int32, ICodeProcessor, SourcePosition, Token)

Message Constructor (SourceCodeRef, MessageType, Int32, ICodeProcessor, SourcePosition, Token) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Message class

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Message(
    SourceCodeRef srcRef,
    MessageType type,
    int code,
    ICodeProcessor from,
    SourcePosition position,
    Token token
)
public Message(
    SourceCodeRef srcRef,
    MessageType type,
    int code,
    ICodeProcessor from,
    SourcePosition position,
    Token token
)
Public Sub New (
    srcRef As SourceCodeRef,
    type As MessageType,
    code As Integer,
    from As ICodeProcessor,
    position As SourcePosition,
    token As Token
)
Public Sub New (
    srcRef As SourceCodeRef,
    type As MessageType,
    code As Integer,
    from As ICodeProcessor,
    position As SourcePosition,
    token As Token
)
public:
Message(
    SourceCodeRef srcRef,
    MessageType type,
    int code,
    ICodeProcessor^ from,
    SourcePosition position,
    Token^ token
)
public:
Message(
    SourceCodeRef srcRef,
    MessageType type,
    int code,
    ICodeProcessor^ from,
    SourcePosition position,
    Token^ token
)
new :
        srcRef : SourceCodeRef *
        type : MessageType *
        code : int *
        from : ICodeProcessor *
        position : SourcePosition *
        token : Token -> Message
new :
        srcRef : SourceCodeRef *
        type : MessageType *
        code : int *
        from : ICodeProcessor *
        position : SourcePosition *
        token : Token -> Message

Parameters

srcRef
Type: NFX.CodeAnalysis.Source SourceCodeRef
type
Type: NFX.CodeAnalysis MessageType
code
Type: Online System Int32
from
Type: NFX.CodeAnalysis ICodeProcessor
position
Type: NFX.CodeAnalysis.Source SourcePosition
token
Type: NFX.CodeAnalysis Token
See Also
Message Class
Message Members
Message Overload
NFX.CodeAnalysis Namespace


Message Constructor (SourceCodeRef, MessageType, Int32, ICodeProcessor, SourcePosition, Token, String)

Message Constructor (SourceCodeRef, MessageType, Int32, ICodeProcessor, SourcePosition, Token, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Message class

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Message(
    SourceCodeRef srcRef,
    MessageType type,
    int code,
    ICodeProcessor from,
    SourcePosition position,
    Token token,
    string text
)
public Message(
    SourceCodeRef srcRef,
    MessageType type,
    int code,
    ICodeProcessor from,
    SourcePosition position,
    Token token,
    string text
)
Public Sub New (
    srcRef As SourceCodeRef,
    type As MessageType,
    code As Integer,
    from As ICodeProcessor,
    position As SourcePosition,
    token As Token,
    text As String
)
Public Sub New (
    srcRef As SourceCodeRef,
    type As MessageType,
    code As Integer,
    from As ICodeProcessor,
    position As SourcePosition,
    token As Token,
    text As String
)
public:
Message(
    SourceCodeRef srcRef,
    MessageType type,
    int code,
    ICodeProcessor^ from,
    SourcePosition position,
    Token^ token,
    String^ text
)
public:
Message(
    SourceCodeRef srcRef,
    MessageType type,
    int code,
    ICodeProcessor^ from,
    SourcePosition position,
    Token^ token,
    String^ text
)
new :
        srcRef : SourceCodeRef *
        type : MessageType *
        code : int *
        from : ICodeProcessor *
        position : SourcePosition *
        token : Token *
        text : string -> Message
new :
        srcRef : SourceCodeRef *
        type : MessageType *
        code : int *
        from : ICodeProcessor *
        position : SourcePosition *
        token : Token *
        text : string -> Message

Parameters

srcRef
Type: NFX.CodeAnalysis.Source SourceCodeRef
type
Type: NFX.CodeAnalysis MessageType
code
Type: Online System Int32
from
Type: NFX.CodeAnalysis ICodeProcessor
position
Type: NFX.CodeAnalysis.Source SourcePosition
token
Type: NFX.CodeAnalysis Token
text
Type: Online System String
See Also
Message Class
Message Members
Message Overload
NFX.CodeAnalysis Namespace


Message Constructor (SourceCodeRef, MessageType, Int32, ICodeProcessor, SourcePosition, Token, String, Exception)

Message Constructor (SourceCodeRef, MessageType, Int32, ICodeProcessor, SourcePosition, Token, String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Message class

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Message(
    SourceCodeRef srcRef,
    MessageType type,
    int code,
    ICodeProcessor from,
    SourcePosition position,
    Token token,
    string text,
    Exception exception
)
public Message(
    SourceCodeRef srcRef,
    MessageType type,
    int code,
    ICodeProcessor from,
    SourcePosition position,
    Token token,
    string text,
    Exception exception
)
Public Sub New (
    srcRef As SourceCodeRef,
    type As MessageType,
    code As Integer,
    from As ICodeProcessor,
    position As SourcePosition,
    token As Token,
    text As String,
    exception As Exception
)
Public Sub New (
    srcRef As SourceCodeRef,
    type As MessageType,
    code As Integer,
    from As ICodeProcessor,
    position As SourcePosition,
    token As Token,
    text As String,
    exception As Exception
)
public:
Message(
    SourceCodeRef srcRef,
    MessageType type,
    int code,
    ICodeProcessor^ from,
    SourcePosition position,
    Token^ token,
    String^ text,
    Exception^ exception
)
public:
Message(
    SourceCodeRef srcRef,
    MessageType type,
    int code,
    ICodeProcessor^ from,
    SourcePosition position,
    Token^ token,
    String^ text,
    Exception^ exception
)
new :
        srcRef : SourceCodeRef *
        type : MessageType *
        code : int *
        from : ICodeProcessor *
        position : SourcePosition *
        token : Token *
        text : string *
        exception : Exception -> Message
new :
        srcRef : SourceCodeRef *
        type : MessageType *
        code : int *
        from : ICodeProcessor *
        position : SourcePosition *
        token : Token *
        text : string *
        exception : Exception -> Message

Parameters

srcRef
Type: NFX.CodeAnalysis.Source SourceCodeRef
type
Type: NFX.CodeAnalysis MessageType
code
Type: Online System Int32
from
Type: NFX.CodeAnalysis ICodeProcessor
position
Type: NFX.CodeAnalysis.Source SourcePosition
token
Type: NFX.CodeAnalysis Token
text
Type: Online System String
exception
Type: Online System Exception
See Also
Message Class
Message Members
Message Overload
NFX.CodeAnalysis Namespace


Message Fields

Message Fields NFX Class Library

The Message type exposes the following members.
Fields
 | Name | Description
Public field | AssociatedException |
Public field | Code |
Public field | From |
Public field | Position |
Public field | SourceCodeReference |
Public field | Text |
Public field | Token |
Public field | Type |
Back to Top
See Also
Message Class
NFX.CodeAnalysis Namespace


Message.AssociatedException Field

Message AssociatedException Field NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Exception AssociatedException
public readonly Exception AssociatedException
Public ReadOnly AssociatedException As Exception
Public ReadOnly AssociatedException As Exception
public:
initonly Exception^ AssociatedException
public:
initonly Exception^ AssociatedException
val AssociatedException: Exception
val AssociatedException: Exception

Field Value

Type: Online Exception
See Also
Message Class
Message Members
NFX.CodeAnalysis Namespace


Message.Code Field

Message Code Field NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Code
public readonly int Code
Public ReadOnly Code As Integer
Public ReadOnly Code As Integer
public:
initonly int Code
public:
initonly int Code
val Code: int
val Code: int

Field Value

Type: Online Int32
See Also
Message Class
Message Members
NFX.CodeAnalysis Namespace


Message.From Field

Message From Field NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ICodeProcessor From
public readonly ICodeProcessor From
Public ReadOnly From As ICodeProcessor
Public ReadOnly From As ICodeProcessor
public:
initonly ICodeProcessor^ From
public:
initonly ICodeProcessor^ From
val From: ICodeProcessor
val From: ICodeProcessor

Field Value

Type: ICodeProcessor
See Also
Message Class
Message Members
NFX.CodeAnalysis Namespace


Message.Position Field

Message Position Field NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SourcePosition Position
public readonly SourcePosition Position
Public ReadOnly Position As SourcePosition
Public ReadOnly Position As SourcePosition
public:
initonly SourcePosition Position
public:
initonly SourcePosition Position
val Position: SourcePosition
val Position: SourcePosition

Field Value

Type: SourcePosition
See Also
Message Class
Message Members
NFX.CodeAnalysis Namespace


Message.SourceCodeReference Field

Message SourceCodeReference Field NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SourceCodeRef SourceCodeReference
public readonly SourceCodeRef SourceCodeReference
Public ReadOnly SourceCodeReference As SourceCodeRef
Public ReadOnly SourceCodeReference As SourceCodeRef
public:
initonly SourceCodeRef SourceCodeReference
public:
initonly SourceCodeRef SourceCodeReference
val SourceCodeReference: SourceCodeRef
val SourceCodeReference: SourceCodeRef

Field Value

Type: SourceCodeRef
See Also
Message Class
Message Members
NFX.CodeAnalysis Namespace


Message.Text Field

Message Text Field NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Text
public readonly string Text
Public ReadOnly Text As String
Public ReadOnly Text As String
public:
initonly String^ Text
public:
initonly String^ Text
val Text: string
val Text: string

Field Value

Type: Online String
See Also
Message Class
Message Members
NFX.CodeAnalysis Namespace


Message.Token Field

Message Token Field NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Token Token
public readonly Token Token
Public ReadOnly Token As Token
Public ReadOnly Token As Token
public:
initonly Token^ Token
public:
initonly Token^ Token
val Token: Token
val Token: Token

Field Value

Type: Token
See Also
Message Class
Message Members
NFX.CodeAnalysis Namespace


Message.Type Field

Message Type Field NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly MessageType Type
public readonly MessageType Type
Public ReadOnly Type As MessageType
Public ReadOnly Type As MessageType
public:
initonly MessageType Type
public:
initonly MessageType Type
val Type: MessageType
val Type: MessageType

Field Value

Type: MessageType
See Also
Message Class
Message Members
NFX.CodeAnalysis Namespace


Message Methods

Message Methods NFX Class Library

The Message type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Message Class
NFX.CodeAnalysis Namespace


Message.ToString Method

Message ToString Method NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
Message Class
Message Members
NFX.CodeAnalysis Namespace


Message Properties

Message Properties NFX Class Library

The Message type exposes the following members.
Properties
 | Name | Description
Public property | IsError | Indicates whether this message is an error message
Public property | IsInfo | Indicates whether this message is an info message
Public property | IsInternal | Indicates whether this message is an internal message
Public property | IsWarning | Indicates whether this message is a warning message
Back to Top
See Also
Message Class
NFX.CodeAnalysis Namespace


Message.IsError Property

Message IsError Property NFX Class Library

Indicates whether this message is an error message

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsError { get; }
public bool IsError { get; }
Public ReadOnly Property IsError As Boolean
    Get
Public ReadOnly Property IsError As Boolean
    Get
public:
property bool IsError {
    bool get ();
}
public:
property bool IsError {
    bool get ();
}
member IsError : bool with get
member IsError : bool with get

Property Value

Type: Online Boolean
See Also
Message Class
Message Members
NFX.CodeAnalysis Namespace


Message.IsInfo Property

Message IsInfo Property NFX Class Library

Indicates whether this message is an info message

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsInfo { get; }
public bool IsInfo { get; }
Public ReadOnly Property IsInfo As Boolean
    Get
Public ReadOnly Property IsInfo As Boolean
    Get
public:
property bool IsInfo {
    bool get ();
}
public:
property bool IsInfo {
    bool get ();
}
member IsInfo : bool with get
member IsInfo : bool with get

Property Value

Type: Online Boolean
See Also
Message Class
Message Members
NFX.CodeAnalysis Namespace


Message.IsInternal Property

Message IsInternal Property NFX Class Library

Indicates whether this message is an internal message

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsInternal { get; }
public bool IsInternal { get; }
Public ReadOnly Property IsInternal As Boolean
    Get
Public ReadOnly Property IsInternal As Boolean
    Get
public:
property bool IsInternal {
    bool get ();
}
public:
property bool IsInternal {
    bool get ();
}
member IsInternal : bool with get
member IsInternal : bool with get

Property Value

Type: Online Boolean
See Also
Message Class
Message Members
NFX.CodeAnalysis Namespace


Message.IsWarning Property

Message IsWarning Property NFX Class Library

Indicates whether this message is a warning message

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsWarning { get; }
public bool IsWarning { get; }
Public ReadOnly Property IsWarning As Boolean
    Get
Public ReadOnly Property IsWarning As Boolean
    Get
public:
property bool IsWarning {
    bool get ();
}
public:
property bool IsWarning {
    bool get ();
}
member IsWarning : bool with get
member IsWarning : bool with get

Property Value

Type: Online Boolean
See Also
Message Class
Message Members
NFX.CodeAnalysis Namespace


MessageList Class

MessageList Class NFX Class Library

Provides a list of messages, this class is not thread-safe
Inheritance Hierarchy
Online System Object
Online System.Collections.Generic List Message
NFX.CodeAnalysis MessageList

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MessageList : List<Message>
public class MessageList : List<Message>
Public Class MessageList
    Inherits List(Of Message)
Public Class MessageList
    Inherits List(Of Message)
public ref class MessageList : public List<Message^>
public ref class MessageList : public List<Message^>
type MessageList =
    class
        inherit List<Message>
    end
type MessageList =
    class
        inherit List<Message>
    end
See Also
MessageList Members
NFX.CodeAnalysis Namespace


MessageList Members

MessageList Members NFX Class Library

The MessageList type exposes the following members.
Constructors
 | Name | Description
Public method | MessageList | Initializes a new instance of the MessageList class
Back to Top
Methods
 | Name | Description
Public method | Add | Emits new message
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List Message .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List Message .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List Message .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Message .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Message .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List Message .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List Message .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List Message .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List Message .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Message .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Message .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List Message .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List Message .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Message .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Message .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Message .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Message .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List Message .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Message .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Message .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Message .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List Message .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List Message .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List Message .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Message .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Message .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Message .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List Message .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List Message .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Message .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Message .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Message .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List Message .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Message .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List Message .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List Message .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List Message .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List Message .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List Message .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List Message .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List Message .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List Message .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List Message .)
Public method | ToString | (Overrides Online Object ToString .)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List Message .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List Message .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List Message .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List Message .)
Public property | Errors | Enumerates all error messages
Public property | Infos | Enumerates all info messages
Public property | Internals | Enumerates all internal messages
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List Message .)
Public property | NotificationsSink |
Public property | Warnings | Enumerates all warning messages
Back to Top
See Also
MessageList Class
NFX.CodeAnalysis Namespace


MessageList Constructor

MessageList Constructor NFX Class Library

Initializes a new instance of the MessageList class

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageList()
public MessageList()
Public Sub New
Public Sub New
public:
MessageList()
public:
MessageList()
new : unit -> MessageList
new : unit -> MessageList
See Also
MessageList Class
MessageList Members
NFX.CodeAnalysis Namespace


MessageList Methods

MessageList Methods NFX Class Library

The MessageList type exposes the following members.
Methods
 | Name | Description
Public method | Add | Emits new message
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List Message .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List Message .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List Message .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Message .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Message .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List Message .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List Message .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List Message .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List Message .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Message .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Message .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List Message .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List Message .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Message .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Message .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Message .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Message .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List Message .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Message .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Message .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Message .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List Message .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List Message .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List Message .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Message .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Message .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Message .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List Message .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List Message .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Message .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Message .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Message .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List Message .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Message .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List Message .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List Message .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List Message .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List Message .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List Message .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List Message .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List Message .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List Message .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List Message .)
Public method | ToString | (Overrides Online Object ToString .)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List Message .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List Message .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MessageList Class
NFX.CodeAnalysis Namespace


MessageList.Add Method

MessageList Add Method NFX Class Library

Emits new message

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    Message message
)
public void Add(
    Message message
)
Public Sub Add (
    message As Message
)
Public Sub Add (
    message As Message
)
public:
void Add(
    Message^ message
)
public:
void Add(
    Message^ message
)
member Add :
        message : Message -> unit
member Add :
        message : Message -> unit

Parameters

message
Type: NFX.CodeAnalysis Message
See Also
MessageList Class
MessageList Members
NFX.CodeAnalysis Namespace


MessageList.ToString Method

MessageList ToString Method NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
MessageList Class
MessageList Members
NFX.CodeAnalysis Namespace


MessageList Properties

MessageList Properties NFX Class Library

The MessageList type exposes the following members.
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List Message .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List Message .)
Public property | Errors | Enumerates all error messages
Public property | Infos | Enumerates all info messages
Public property | Internals | Enumerates all internal messages
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List Message .)
Public property | NotificationsSink |
Public property | Warnings | Enumerates all warning messages
Back to Top
See Also
MessageList Class
NFX.CodeAnalysis Namespace


MessageList.Errors Property

MessageList Errors Property NFX Class Library

Enumerates all error messages

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Message> Errors { get; }
public IEnumerable<Message> Errors { get; }
Public ReadOnly Property Errors As IEnumerable(Of Message)
    Get
Public ReadOnly Property Errors As IEnumerable(Of Message)
    Get
public:
property IEnumerable<Message^>^ Errors {
    IEnumerable<Message^>^ get ();
}
public:
property IEnumerable<Message^>^ Errors {
    IEnumerable<Message^>^ get ();
}
member Errors : IEnumerable<Message> with get
member Errors : IEnumerable<Message> with get

Property Value

Type: Online IEnumerable Message
See Also
MessageList Class
MessageList Members
NFX.CodeAnalysis Namespace


MessageList.Infos Property

MessageList Infos Property NFX Class Library

Enumerates all info messages

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Message> Infos { get; }
public IEnumerable<Message> Infos { get; }
Public ReadOnly Property Infos As IEnumerable(Of Message)
    Get
Public ReadOnly Property Infos As IEnumerable(Of Message)
    Get
public:
property IEnumerable<Message^>^ Infos {
    IEnumerable<Message^>^ get ();
}
public:
property IEnumerable<Message^>^ Infos {
    IEnumerable<Message^>^ get ();
}
member Infos : IEnumerable<Message> with get
member Infos : IEnumerable<Message> with get

Property Value

Type: Online IEnumerable Message
See Also
MessageList Class
MessageList Members
NFX.CodeAnalysis Namespace


MessageList.Internals Property

MessageList Internals Property NFX Class Library

Enumerates all internal messages

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Message> Internals { get; }
public IEnumerable<Message> Internals { get; }
Public ReadOnly Property Internals As IEnumerable(Of Message)
    Get
Public ReadOnly Property Internals As IEnumerable(Of Message)
    Get
public:
property IEnumerable<Message^>^ Internals {
    IEnumerable<Message^>^ get ();
}
public:
property IEnumerable<Message^>^ Internals {
    IEnumerable<Message^>^ get ();
}
member Internals : IEnumerable<Message> with get
member Internals : IEnumerable<Message> with get

Property Value

Type: Online IEnumerable Message
See Also
MessageList Class
MessageList Members
NFX.CodeAnalysis Namespace


MessageList.NotificationsSink Property

MessageList NotificationsSink Property NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILanguageProcessorNotifications NotificationsSink { get; set; }
public ILanguageProcessorNotifications NotificationsSink { get; set; }
Public Property NotificationsSink As ILanguageProcessorNotifications
    Get
    Set
Public Property NotificationsSink As ILanguageProcessorNotifications
    Get
    Set
public:
property ILanguageProcessorNotifications^ NotificationsSink {
    ILanguageProcessorNotifications^ get ();
    void set (ILanguageProcessorNotifications^ value);
}
public:
property ILanguageProcessorNotifications^ NotificationsSink {
    ILanguageProcessorNotifications^ get ();
    void set (ILanguageProcessorNotifications^ value);
}
member NotificationsSink : ILanguageProcessorNotifications with get, set
member NotificationsSink : ILanguageProcessorNotifications with get, set

Property Value

Type: ILanguageProcessorNotifications
See Also
MessageList Class
MessageList Members
NFX.CodeAnalysis Namespace


MessageList.Warnings Property

MessageList Warnings Property NFX Class Library

Enumerates all warning messages

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Message> Warnings { get; }
public IEnumerable<Message> Warnings { get; }
Public ReadOnly Property Warnings As IEnumerable(Of Message)
    Get
Public ReadOnly Property Warnings As IEnumerable(Of Message)
    Get
public:
property IEnumerable<Message^>^ Warnings {
    IEnumerable<Message^>^ get ();
}
public:
property IEnumerable<Message^>^ Warnings {
    IEnumerable<Message^>^ get ();
}
member Warnings : IEnumerable<Message> with get
member Warnings : IEnumerable<Message> with get

Property Value

Type: Online IEnumerable Message
See Also
MessageList Class
MessageList Members
NFX.CodeAnalysis Namespace


MessageType Enumeration

MessageType Enumeration NFX Class Library

Message type like: Info, Warning, Error

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum MessageType
public enum MessageType
Public Enumeration MessageType
Public Enumeration MessageType
public enum class MessageType
public enum class MessageType
type MessageType
type MessageType
Members
Member name | Value | Description
Internal | 0 |
Info | 1000 |
Warning | 5000 |
Error | 1000000 |
InternalError | 10000000 |
See Also
NFX.CodeAnalysis Namespace


ObjectResultAnalysisContext(TObject) Class

ObjectResultAnalysisContext TObject Class NFX Class Library

A context that can hold analysis result as TObject. This class is useful for cases like dynamic language parsers (i.e. JSON)
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis CommonCodeProcessor
NFX.CodeAnalysis ObjectResultAnalysisContext TObject
NFX.CodeAnalysis.JSON JSONData
NFX.CodeAnalysis.Laconfig LaconfigData

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class ObjectResultAnalysisContext<TObject> : CommonCodeProcessor,
    IAnalysisContext, ICodeProcessor
where TObject : class
public abstract class ObjectResultAnalysisContext<TObject> : CommonCodeProcessor,
    IAnalysisContext, ICodeProcessor
where TObject : class
Public MustInherit Class ObjectResultAnalysisContext(Of TObject As Class)
    Inherits CommonCodeProcessor
    Implements IAnalysisContext, ICodeProcessor
Public MustInherit Class ObjectResultAnalysisContext(Of TObject As Class)
    Inherits CommonCodeProcessor
    Implements IAnalysisContext, ICodeProcessor
generic<typename TObject>
where TObject : ref class
public ref class ObjectResultAnalysisContext abstract : public CommonCodeProcessor,
    IAnalysisContext, ICodeProcessor
generic<typename TObject>
where TObject : ref class
public ref class ObjectResultAnalysisContext abstract : public CommonCodeProcessor,
    IAnalysisContext, ICodeProcessor
[<AbstractClassAttribute>]
type ObjectResultAnalysisContext<'TObject when 'TObject : not struct> =
    class
        inherit CommonCodeProcessor
        interface IAnalysisContext
        interface ICodeProcessor
    end
[<AbstractClassAttribute>]
type ObjectResultAnalysisContext<'TObject when 'TObject : not struct> =
    class
        inherit CommonCodeProcessor
        interface IAnalysisContext
        interface ICodeProcessor
    end
Type Parameters
TObject
See Also
ObjectResultAnalysisContext TObject Members
NFX.CodeAnalysis Namespace


ObjectResultAnalysisContext(TObject) Members

ObjectResultAnalysisContext TObject Members NFX Class Library

[This is preliminary documentation and is subject to change.]

The ObjectResultAnalysisContext TObject type exposes the following members.
Constructors
 | Name | Description
Protected method | ObjectResultAnalysisContext TObject | Initializes a new instance of the ObjectResultAnalysisContext TObject class
Back to Top
Methods
 | Name | Description
Protected method | EmitMessage | (Inherited from CommonCodeProcessor.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MessageCodeToString | Returns string representation of message code which is output by this processor (Inherited from CommonCodeProcessor.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_ResultObject |
Back to Top
Properties
 | Name | Description
Public property | Context | Returns context that this processor operates under - an entity that retains state during analysis, such as: module compiler, project compiler, code unit translator etc. This entity may also contain compiler/parser/lexer options etc. (Inherited from CommonCodeProcessor.)
Public property | Language | Returns language that this processor is capable of processing (Inherited from CommonCodeProcessor.)
Public property | Messages | References message list that lexer emitts messages into. May be null (Inherited from CommonCodeProcessor.)
Public property | ResultObject |
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any lexing error is always thrown regardless of this parameter (Inherited from CommonCodeProcessor.)
Back to Top
See Also
ObjectResultAnalysisContext TObject Class
NFX.CodeAnalysis Namespace


ObjectResultAnalysisContext(TObject) Constructor

ObjectResultAnalysisContext TObject Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ObjectResultAnalysisContext TObject class

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ObjectResultAnalysisContext(
    IAnalysisContext context,
    MessageList messages = null,
    bool throwErrors = false
)
protected ObjectResultAnalysisContext(
    IAnalysisContext context,
    MessageList messages = null,
    bool throwErrors = false
)
Protected Sub New (
    context As IAnalysisContext,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
Protected Sub New (
    context As IAnalysisContext,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
protected:
ObjectResultAnalysisContext(
    IAnalysisContext^ context,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
protected:
ObjectResultAnalysisContext(
    IAnalysisContext^ context,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
new :
        context : IAnalysisContext *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> ObjectResultAnalysisContext
new :
        context : IAnalysisContext *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> ObjectResultAnalysisContext

Parameters

context
Type: NFX.CodeAnalysis IAnalysisContext
messages (Optional)
Type: NFX.CodeAnalysis MessageList
throwErrors (Optional)
Type: Online System Boolean
See Also
ObjectResultAnalysisContext TObject Class
ObjectResultAnalysisContext TObject Members
NFX.CodeAnalysis Namespace


ObjectResultAnalysisContext(TObject) Fields

ObjectResultAnalysisContext TObject Fields NFX Class Library

The ObjectResultAnalysisContext TObject type exposes the following members.
Fields
 | Name | Description
Protected field | m_ResultObject |
Back to Top
See Also
ObjectResultAnalysisContext TObject Class
NFX.CodeAnalysis Namespace


ObjectResultAnalysisContext(TObject).m_ResultObject Field

ObjectResultAnalysisContext TObject m_ResultObject Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TObject m_ResultObject
protected TObject m_ResultObject
Protected m_ResultObject As TObject
Protected m_ResultObject As TObject
protected:
TObject m_ResultObject
protected:
TObject m_ResultObject
val mutable m_ResultObject: 'TObject
val mutable m_ResultObject: 'TObject

Field Value

Type: TObject
See Also
ObjectResultAnalysisContext TObject Class
ObjectResultAnalysisContext TObject Members
NFX.CodeAnalysis Namespace


ObjectResultAnalysisContext(TObject) Methods

ObjectResultAnalysisContext TObject Methods NFX Class Library

[This is preliminary documentation and is subject to change.]

The ObjectResultAnalysisContext TObject type exposes the following members.
Methods
 | Name | Description
Protected method | EmitMessage | (Inherited from CommonCodeProcessor.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MessageCodeToString | Returns string representation of message code which is output by this processor (Inherited from CommonCodeProcessor.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ObjectResultAnalysisContext TObject Class
NFX.CodeAnalysis Namespace


ObjectResultAnalysisContext(TObject) Properties

ObjectResultAnalysisContext TObject Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The ObjectResultAnalysisContext TObject type exposes the following members.
Properties
 | Name | Description
Public property | Context | Returns context that this processor operates under - an entity that retains state during analysis, such as: module compiler, project compiler, code unit translator etc. This entity may also contain compiler/parser/lexer options etc. (Inherited from CommonCodeProcessor.)
Public property | Language | Returns language that this processor is capable of processing (Inherited from CommonCodeProcessor.)
Public property | Messages | References message list that lexer emitts messages into. May be null (Inherited from CommonCodeProcessor.)
Public property | ResultObject |
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any lexing error is always thrown regardless of this parameter (Inherited from CommonCodeProcessor.)
Back to Top
See Also
ObjectResultAnalysisContext TObject Class
NFX.CodeAnalysis Namespace


ObjectResultAnalysisContext(TObject).ResultObject Property

ObjectResultAnalysisContext TObject ResultObject Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TObject ResultObject { get; }
public TObject ResultObject { get; }
Public ReadOnly Property ResultObject As TObject
    Get
Public ReadOnly Property ResultObject As TObject
    Get
public:
property TObject ResultObject {
    TObject get ();
}
public:
property TObject ResultObject {
    TObject get ();
}
member ResultObject : 'TObject with get
member ResultObject : 'TObject with get

Property Value

Type: TObject
See Also
ObjectResultAnalysisContext TObject Class
ObjectResultAnalysisContext TObject Members
NFX.CodeAnalysis Namespace


Parser(TLexer) Class

Parser TLexer Class NFX Class Library

Performs parsing of token streams provided by lexers
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis CommonCodeProcessor
NFX.CodeAnalysis Parser TLexer
NFX.CodeAnalysis.JSON JSONParser
NFX.CodeAnalysis.Laconfig LaconfigParser

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Parser<TLexer> : CommonCodeProcessor,
    IParser, ICodeProcessor
where TLexer : ILexer
public abstract class Parser<TLexer> : CommonCodeProcessor,
    IParser, ICodeProcessor
where TLexer : ILexer
Public MustInherit Class Parser(Of TLexer As ILexer)
    Inherits CommonCodeProcessor
    Implements IParser, ICodeProcessor
Public MustInherit Class Parser(Of TLexer As ILexer)
    Inherits CommonCodeProcessor
    Implements IParser, ICodeProcessor
generic<typename TLexer>
where TLexer : ILexer
public ref class Parser abstract : public CommonCodeProcessor,
    IParser, ICodeProcessor
generic<typename TLexer>
where TLexer : ILexer
public ref class Parser abstract : public CommonCodeProcessor,
    IParser, ICodeProcessor
[<AbstractClassAttribute>]
type Parser<'TLexer when 'TLexer : ILexer> =
    class
        inherit CommonCodeProcessor
        interface IParser
        interface ICodeProcessor
    end
[<AbstractClassAttribute>]
type Parser<'TLexer when 'TLexer : ILexer> =
    class
        inherit CommonCodeProcessor
        interface IParser
        interface ICodeProcessor
    end
Type Parameters
TLexer
See Also
Parser TLexer Members
NFX.CodeAnalysis Namespace


Parser(TLexer) Members

Parser TLexer Members NFX Class Library

The Parser TLexer type exposes the following members.
Constructors
 | Name | Description
Protected method | Parser TLexer | Initializes a new instance of the Parser TLexer class
Back to Top
Methods
 | Name | Description
Protected method | DoParse | Override to perform actual parsing
Protected method | EmitMessage | (Inherited from CommonCodeProcessor.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MessageCodeToString | Returns string representation of message code which is output by this processor (Inherited from CommonCodeProcessor.)
Public method | Parse | Performs parsing if it has not been performed yet
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Context | Returns context that this processor operates under - an entity that retains state during analysis, such as: module compiler, project compiler, code unit translator etc. This entity may also contain compiler/parser/lexer options etc. (Inherited from CommonCodeProcessor.)
Public property | HasParsed | Indicates whether Parse() already happened
Public property | Input | Returns lexers that feed this parser
Public property | Language | Returns language that this processor is capable of processing (Inherited from CommonCodeProcessor.)
Public property | Messages | References message list that lexer emitts messages into. May be null (Inherited from CommonCodeProcessor.)
Public property | SourceInput | Lists source lexers that supply token stream for parsing
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any lexing error is always thrown regardless of this parameter (Inherited from CommonCodeProcessor.)
Back to Top
See Also
Parser TLexer Class
NFX.CodeAnalysis Namespace


Parser(TLexer) Constructor

Parser TLexer Constructor NFX Class Library

Initializes a new instance of the Parser TLexer class

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Parser(
    IAnalysisContext context,
    IEnumerable<TLexer> input,
    MessageList messages = null,
    bool throwErrors = false
)
protected Parser(
    IAnalysisContext context,
    IEnumerable<TLexer> input,
    MessageList messages = null,
    bool throwErrors = false
)
Protected Sub New (
    context As IAnalysisContext,
    input As IEnumerable(Of TLexer),
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
Protected Sub New (
    context As IAnalysisContext,
    input As IEnumerable(Of TLexer),
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
protected:
Parser(
    IAnalysisContext^ context,
    IEnumerable<TLexer>^ input,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
protected:
Parser(
    IAnalysisContext^ context,
    IEnumerable<TLexer>^ input,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
new :
        context : IAnalysisContext *
        input : IEnumerable<'TLexer> *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> Parser
new :
        context : IAnalysisContext *
        input : IEnumerable<'TLexer> *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> Parser

Parameters

context
Type: NFX.CodeAnalysis IAnalysisContext
input
Type: Online System.Collections.Generic IEnumerable TLexer
messages (Optional)
Type: NFX.CodeAnalysis MessageList
throwErrors (Optional)
Type: Online System Boolean
See Also
Parser TLexer Class
Parser TLexer Members
NFX.CodeAnalysis Namespace


Parser(TLexer) Methods

Parser TLexer Methods NFX Class Library

The Parser TLexer type exposes the following members.
Methods
 | Name | Description
Protected method | DoParse | Override to perform actual parsing
Protected method | EmitMessage | (Inherited from CommonCodeProcessor.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MessageCodeToString | Returns string representation of message code which is output by this processor (Inherited from CommonCodeProcessor.)
Public method | Parse | Performs parsing if it has not been performed yet
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Parser TLexer Class
NFX.CodeAnalysis Namespace


Parser(TLexer).DoParse Method

Parser TLexer DoParse Method NFX Class Library

Override to perform actual parsing

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void DoParse()
protected abstract void DoParse()
Protected MustOverride Sub DoParse
Protected MustOverride Sub DoParse
protected:
virtual void DoParse() abstract
protected:
virtual void DoParse() abstract
abstract DoParse : unit -> unit
abstract DoParse : unit -> unit
See Also
Parser TLexer Class
Parser TLexer Members
NFX.CodeAnalysis Namespace


Parser(TLexer).Parse Method

Parser TLexer Parse Method NFX Class Library

Performs parsing if it has not been performed yet

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Parse()
public void Parse()
Public Sub Parse
Public Sub Parse
public:
virtual void Parse() sealed
public:
virtual void Parse() sealed
abstract Parse : unit -> unit
override Parse : unit -> unit
abstract Parse : unit -> unit
override Parse : unit -> unit

Implements

IParser Parse
See Also
Parser TLexer Class
Parser TLexer Members
NFX.CodeAnalysis Namespace


Parser(TLexer) Properties

Parser TLexer Properties NFX Class Library

The Parser TLexer type exposes the following members.
Properties
 | Name | Description
Public property | Context | Returns context that this processor operates under - an entity that retains state during analysis, such as: module compiler, project compiler, code unit translator etc. This entity may also contain compiler/parser/lexer options etc. (Inherited from CommonCodeProcessor.)
Public property | HasParsed | Indicates whether Parse() already happened
Public property | Input | Returns lexers that feed this parser
Public property | Language | Returns language that this processor is capable of processing (Inherited from CommonCodeProcessor.)
Public property | Messages | References message list that lexer emitts messages into. May be null (Inherited from CommonCodeProcessor.)
Public property | SourceInput | Lists source lexers that supply token stream for parsing
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any lexing error is always thrown regardless of this parameter (Inherited from CommonCodeProcessor.)
Back to Top
See Also
Parser TLexer Class
NFX.CodeAnalysis Namespace


Parser(TLexer).HasParsed Property

Parser TLexer HasParsed Property NFX Class Library

Indicates whether Parse() already happened

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasParsed { get; }
public bool HasParsed { get; }
Public ReadOnly Property HasParsed As Boolean
    Get
Public ReadOnly Property HasParsed As Boolean
    Get
public:
virtual property bool HasParsed {
    bool get () sealed;
}
public:
virtual property bool HasParsed {
    bool get () sealed;
}
abstract HasParsed : bool with get
override HasParsed : bool with get
abstract HasParsed : bool with get
override HasParsed : bool with get

Property Value

Type: Online Boolean

Implements

IParser HasParsed
See Also
Parser TLexer Class
Parser TLexer Members
NFX.CodeAnalysis Namespace


Parser(TLexer).Input Property

Parser TLexer Input Property NFX Class Library

Returns lexers that feed this parser

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<TLexer> Input { get; }
public IEnumerable<TLexer> Input { get; }
Public ReadOnly Property Input As IEnumerable(Of TLexer)
    Get
Public ReadOnly Property Input As IEnumerable(Of TLexer)
    Get
public:
property IEnumerable<TLexer>^ Input {
    IEnumerable<TLexer>^ get ();
}
public:
property IEnumerable<TLexer>^ Input {
    IEnumerable<TLexer>^ get ();
}
member Input : IEnumerable<'TLexer> with get
member Input : IEnumerable<'TLexer> with get

Property Value

Type: Online IEnumerable TLexer
See Also
Parser TLexer Class
Parser TLexer Members
NFX.CodeAnalysis Namespace


Parser(TLexer).SourceInput Property

Parser TLexer SourceInput Property NFX Class Library

Lists source lexers that supply token stream for parsing

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<ILexer> SourceInput { get; }
public IEnumerable<ILexer> SourceInput { get; }
Public ReadOnly Property SourceInput As IEnumerable(Of ILexer)
    Get
Public ReadOnly Property SourceInput As IEnumerable(Of ILexer)
    Get
public:
virtual property IEnumerable<ILexer^>^ SourceInput {
    IEnumerable<ILexer^>^ get () sealed;
}
public:
virtual property IEnumerable<ILexer^>^ SourceInput {
    IEnumerable<ILexer^>^ get () sealed;
}
abstract SourceInput : IEnumerable<ILexer> with get
override SourceInput : IEnumerable<ILexer> with get
abstract SourceInput : IEnumerable<ILexer> with get
override SourceInput : IEnumerable<ILexer> with get

Property Value

Type: Online IEnumerable ILexer

Implements

IParser SourceInput
See Also
Parser TLexer Class
Parser TLexer Members
NFX.CodeAnalysis Namespace


PatternSearch Class

PatternSearch Class NFX Class Library

Provides Token-pattern matching utilities
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis PatternSearch

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class PatternSearch
public static class PatternSearch
<ExtensionAttribute>
Public NotInheritable Class PatternSearch
<ExtensionAttribute>
Public NotInheritable Class PatternSearch
[ExtensionAttribute]
public ref class PatternSearch abstract sealed
[ExtensionAttribute]
public ref class PatternSearch abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PatternSearch =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PatternSearch =  class end
See Also
PatternSearch Members
NFX.CodeAnalysis Namespace


PatternSearch Members

PatternSearch Members NFX Class Library

The PatternSearch type exposes the following members.
Methods
Name | Description
DoUntilAny TToken (TToken, FSMI, Int32 ) | Performs FSM instruction unless token's type is any of the specified, then advances FSM
DoUntilAny TToken (TToken, FSMI, String ) | Performs FSM instruction unless token's text is any of the specified, then advances FSM
DoUntilAny TToken (TToken, FSMI, StringComparison, String ) | Performs FSM instruction unless token's text is any of the specified, then advances FSM
DoUntilAny TToken, TTokenType (TToken, FSMI, TTokenType ) | Performs FSM instruction unless token's type is any of the specified, then advances FSM
IsAnyOrAbort TToken (TToken, Int32 ) | Advances FSM when token's type is any of specified or aborts FSM
IsAnyOrAbort TToken (TToken, String ) | Advances FSM when token's text is any of specified or aborts FSM
IsAnyOrAbort TToken (TToken, StringComparison, String ) | Advances FSM when token's text is any of specified or aborts FSM
IsAnyOrAbort TToken, TTokenType (TToken, TTokenType ) | Advances FSM when token's type is any of specified or aborts FSM
LazyFSM TToken (IEnumerable TToken , LazyFSMPredicate TToken ) | Makes finite state machine fed from IEnumerable(Token) only considering primary language tokens
LazyFSM TToken (IEnumerable TToken , Boolean, LazyFSMPredicate TToken ) | Makes finite state machine fed from IEnumerable(Token)
LazyFSM TToken (IEnumerable TToken , Boolean, LazyFSMState TToken , LazyFSMPredicate TToken ) | Makes finite state machine fed from IEnumerable(Token)
LoopUntilAfterMatch TToken | Loops until token pattern match succeeds. This method matches using the same primary token filter as the parent match. Keeps state machine if match was found on the first token that follows the match
LoopUntilAny TToken (TToken, Int32 ) | Advances FSM when token's type is any of specified or loops FSM
LoopUntilAny TToken (TToken, String ) | Advances FSM when token's text is any of specified or loops FSM
LoopUntilAny TToken (TToken, StringComparison, String ) | Advances FSM when token's text is any of specified or loops FSM
LoopUntilAny TToken, TTokenType (TToken, TTokenType ) | Advances FSM when token's type is any of specified or loops FSM
LoopUntilMatch TToken (LazyFSMState TToken , LazyFSMPredicate TToken ) | Loops until token pattern match succeeds, considering only primary language tokens. Keeps state machine if match was found on the first matching token
LoopUntilMatch TToken (LazyFSMState TToken , Boolean, LazyFSMPredicate TToken ) | Loops until token pattern match succeeds, conditionaly considering only primary language tokens. Keeps state machine if match was found on the first matching token
LoopWhileAnyOrAbort TToken (TToken, Int32 ) | Loops FSM while token's type is any of the specified or aborts
LoopWhileAnyOrAbort TToken (TToken, String ) | Loops FSM while token's text is any of the specified or aborts
LoopWhileAnyOrAbort TToken (TToken, StringComparison, String ) | Loops FSM while token's text is any of the specified or aborts
LoopWhileAnyOrAbort TToken, TTokenType (TToken, TTokenType ) | Loops FSM while token's type is any of the specified or aborts
Skip TToken | Skips specified number of tokens by returning FSMI.Loop count times
TextIsAnyOf TToken (TToken, String ) | Returns true when token's text is any of specified
TextIsAnyOf TToken (TToken, StringComparison, String ) | Returns true when token's text is any of specified
TypeIsAnyOf TToken (TToken, Int32 ) | Returns true when token's type is any of the specified
TypeIsAnyOf TToken, TTokenType (TToken, TTokenType ) | Returns true when token's type is any of the specified
Back to Top
See Also
PatternSearch Class
NFX.CodeAnalysis Namespace


PatternSearch Methods

PatternSearch Methods NFX Class Library

The PatternSearch type exposes the following members.
Methods
Name | Description
DoUntilAny TToken (TToken, FSMI, Int32 ) | Performs FSM instruction unless token's type is any of the specified, then advances FSM
DoUntilAny TToken (TToken, FSMI, String ) | Performs FSM instruction unless token's text is any of the specified, then advances FSM
DoUntilAny TToken (TToken, FSMI, StringComparison, String ) | Performs FSM instruction unless token's text is any of the specified, then advances FSM
DoUntilAny TToken, TTokenType (TToken, FSMI, TTokenType ) | Performs FSM instruction unless token's type is any of the specified, then advances FSM
IsAnyOrAbort TToken (TToken, Int32 ) | Advances FSM when token's type is any of specified or aborts FSM
IsAnyOrAbort TToken (TToken, String ) | Advances FSM when token's text is any of specified or aborts FSM
IsAnyOrAbort TToken (TToken, StringComparison, String ) | Advances FSM when token's text is any of specified or aborts FSM
IsAnyOrAbort TToken, TTokenType (TToken, TTokenType ) | Advances FSM when token's type is any of specified or aborts FSM
LazyFSM TToken (IEnumerable TToken , LazyFSMPredicate TToken ) | Makes finite state machine fed from IEnumerable(Token) only considering primary language tokens
LazyFSM TToken (IEnumerable TToken , Boolean, LazyFSMPredicate TToken ) | Makes finite state machine fed from IEnumerable(Token)
LazyFSM TToken (IEnumerable TToken , Boolean, LazyFSMState TToken , LazyFSMPredicate TToken ) | Makes finite state machine fed from IEnumerable(Token)
LoopUntilAfterMatch TToken | Loops until token pattern match succeeds. This method matches using the same primary token filter as the parent match. Keeps state machine if match was found on the first token that follows the match
LoopUntilAny TToken (TToken, Int32 ) | Advances FSM when token's type is any of specified or loops FSM
LoopUntilAny TToken (TToken, String ) | Advances FSM when token's text is any of specified or loops FSM
LoopUntilAny TToken (TToken, StringComparison, String ) | Advances FSM when token's text is any of specified or loops FSM
LoopUntilAny TToken, TTokenType (TToken, TTokenType ) | Advances FSM when token's type is any of specified or loops FSM
LoopUntilMatch TToken (LazyFSMState TToken , LazyFSMPredicate TToken ) | Loops until token pattern match succeeds, considering only primary language tokens. Keeps state machine if match was found on the first matching token
LoopUntilMatch TToken (LazyFSMState TToken , Boolean, LazyFSMPredicate TToken ) | Loops until token pattern match succeeds, conditionaly considering only primary language tokens. Keeps state machine if match was found on the first matching token
LoopWhileAnyOrAbort TToken (TToken, Int32 ) | Loops FSM while token's type is any of the specified or aborts
LoopWhileAnyOrAbort TToken (TToken, String ) | Loops FSM while token's text is any of the specified or aborts
LoopWhileAnyOrAbort TToken (TToken, StringComparison, String ) | Loops FSM while token's text is any of the specified or aborts
LoopWhileAnyOrAbort TToken, TTokenType (TToken, TTokenType ) | Loops FSM while token's type is any of the specified or aborts
Skip TToken | Skips specified number of tokens by returning FSMI.Loop count times
TextIsAnyOf TToken (TToken, String ) | Returns true when token's text is any of specified
TextIsAnyOf TToken (TToken, StringComparison, String ) | Returns true when token's text is any of specified
TypeIsAnyOf TToken (TToken, Int32 ) | Returns true when token's type is any of the specified
TypeIsAnyOf TToken, TTokenType (TToken, TTokenType ) | Returns true when token's type is any of the specified
Back to Top
See Also
PatternSearch Class
NFX.CodeAnalysis Namespace


PatternSearch.DoUntilAny Method

PatternSearch DoUntilAny Method NFX Class Library

Overload List
Name | Description
DoUntilAny TToken (TToken, FSMI, Int32 ) | Performs FSM instruction unless token's type is any of the specified, then advances FSM
DoUntilAny TToken (TToken, FSMI, String ) | Performs FSM instruction unless token's text is any of the specified, then advances FSM
DoUntilAny TToken, TTokenType (TToken, FSMI, TTokenType ) | Performs FSM instruction unless token's type is any of the specified, then advances FSM
DoUntilAny TToken (TToken, FSMI, StringComparison, String ) | Performs FSM instruction unless token's text is any of the specified, then advances FSM
Back to Top
See Also
PatternSearch Class
PatternSearch Members
NFX.CodeAnalysis Namespace


PatternSearch.DoUntilAny(TToken) Method (TToken, FSMI, Int32[])

PatternSearch DoUntilAny TToken Method (TToken, FSMI, Int32 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Performs FSM instruction unless token's type is any of the specified, then advances FSM

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FSMI DoUntilAny<TToken>(
    this TToken token,
    FSMI instruction,
    params int[] types
)
where TToken : Token
public static FSMI DoUntilAny<TToken>(
    this TToken token,
    FSMI instruction,
    params int[] types
)
where TToken : Token
<ExtensionAttribute>
Public Shared Function DoUntilAny(Of TToken As Token) (
    token As TToken,
    instruction As FSMI,
    ParamArray types As Integer()
) As FSMI
<ExtensionAttribute>
Public Shared Function DoUntilAny(Of TToken As Token) (
    token As TToken,
    instruction As FSMI,
    ParamArray types As Integer()
) As FSMI
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI DoUntilAny(
    TToken token,
    FSMI instruction,
    ... array<int>^ types
)
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI DoUntilAny(
    TToken token,
    FSMI instruction,
    ... array<int>^ types
)
static member DoUntilAny :
        token : 'TToken *
        instruction : FSMI *
        types : int[] -> FSMI  when 'TToken : Token
static member DoUntilAny :
        token : 'TToken *
        instruction : FSMI *
        types : int[] -> FSMI  when 'TToken : Token

Parameters

token
Type: TToken
instruction
Type: NFX.CodeAnalysis FSMI
types
Type: Online System Int32
Type Parameters
TToken

Return Value

Type: FSMI

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
PatternSearch Class
PatternSearch Members
DoUntilAny Overload
NFX.CodeAnalysis Namespace


PatternSearch.DoUntilAny(TToken) Method (TToken, FSMI, String[])

PatternSearch DoUntilAny TToken Method (TToken, FSMI, String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Performs FSM instruction unless token's text is any of the specified, then advances FSM

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FSMI DoUntilAny<TToken>(
    this TToken token,
    FSMI instruction,
    params string[] texts
)
where TToken : Token
public static FSMI DoUntilAny<TToken>(
    this TToken token,
    FSMI instruction,
    params string[] texts
)
where TToken : Token
<ExtensionAttribute>
Public Shared Function DoUntilAny(Of TToken As Token) (
    token As TToken,
    instruction As FSMI,
    ParamArray texts As String()
) As FSMI
<ExtensionAttribute>
Public Shared Function DoUntilAny(Of TToken As Token) (
    token As TToken,
    instruction As FSMI,
    ParamArray texts As String()
) As FSMI
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI DoUntilAny(
    TToken token,
    FSMI instruction,
    ... array<String^>^ texts
)
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI DoUntilAny(
    TToken token,
    FSMI instruction,
    ... array<String^>^ texts
)
static member DoUntilAny :
        token : 'TToken *
        instruction : FSMI *
        texts : string[] -> FSMI  when 'TToken : Token
static member DoUntilAny :
        token : 'TToken *
        instruction : FSMI *
        texts : string[] -> FSMI  when 'TToken : Token

Parameters

token
Type: TToken
instruction
Type: NFX.CodeAnalysis FSMI
texts
Type: Online System String
Type Parameters
TToken

Return Value

Type: FSMI

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
PatternSearch Class
PatternSearch Members
DoUntilAny Overload
NFX.CodeAnalysis Namespace


PatternSearch.DoUntilAny(TToken, TTokenType) Method (TToken, FSMI, TTokenType[])

PatternSearch DoUntilAny TToken, TTokenType Method (TToken, FSMI, TTokenType ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Performs FSM instruction unless token's type is any of the specified, then advances FSM

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FSMI DoUntilAny<TToken, TTokenType>(
    this TToken token,
    FSMI instruction,
    params TTokenType[] types
)
where TToken : Token
where TTokenType : struct, new(), IConvertible
public static FSMI DoUntilAny<TToken, TTokenType>(
    this TToken token,
    FSMI instruction,
    params TTokenType[] types
)
where TToken : Token
where TTokenType : struct, new(), IConvertible
<ExtensionAttribute>
Public Shared Function DoUntilAny(Of TToken As Token, TTokenType As {Structure, New, IConvertible}) (
    token As TToken,
    instruction As FSMI,
    ParamArray types As TTokenType()
) As FSMI
<ExtensionAttribute>
Public Shared Function DoUntilAny(Of TToken As Token, TTokenType As {Structure, New, IConvertible}) (
    token As TToken,
    instruction As FSMI,
    ParamArray types As TTokenType()
) As FSMI
public:
[ExtensionAttribute]
generic<typename TToken, typename TTokenType>
where TToken : Token
where TTokenType : value class, gcnew(), IConvertible
static FSMI DoUntilAny(
    TToken token,
    FSMI instruction,
    ... array<TTokenType>^ types
)
public:
[ExtensionAttribute]
generic<typename TToken, typename TTokenType>
where TToken : Token
where TTokenType : value class, gcnew(), IConvertible
static FSMI DoUntilAny(
    TToken token,
    FSMI instruction,
    ... array<TTokenType>^ types
)
static member DoUntilAny :
        token : 'TToken *
        instruction : FSMI *
        types : 'TTokenType[] -> FSMI  when 'TToken : Token when 'TTokenType : struct, new() and IConvertible
static member DoUntilAny :
        token : 'TToken *
        instruction : FSMI *
        types : 'TTokenType[] -> FSMI  when 'TToken : Token when 'TTokenType : struct, new() and IConvertible

Parameters

token
Type: TToken
instruction
Type: NFX.CodeAnalysis FSMI
types
Type: TTokenType
Type Parameters
TToken
TTokenType

Return Value

Type: FSMI

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
PatternSearch Class
PatternSearch Members
DoUntilAny Overload
NFX.CodeAnalysis Namespace


PatternSearch.DoUntilAny(TToken) Method (TToken, FSMI, StringComparison, String[])

PatternSearch DoUntilAny TToken Method (TToken, FSMI, StringComparison, String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Performs FSM instruction unless token's text is any of the specified, then advances FSM

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FSMI DoUntilAny<TToken>(
    this TToken token,
    FSMI instruction,
    StringComparison comparison,
    params string[] texts
)
where TToken : Token
public static FSMI DoUntilAny<TToken>(
    this TToken token,
    FSMI instruction,
    StringComparison comparison,
    params string[] texts
)
where TToken : Token
<ExtensionAttribute>
Public Shared Function DoUntilAny(Of TToken As Token) (
    token As TToken,
    instruction As FSMI,
    comparison As StringComparison,
    ParamArray texts As String()
) As FSMI
<ExtensionAttribute>
Public Shared Function DoUntilAny(Of TToken As Token) (
    token As TToken,
    instruction As FSMI,
    comparison As StringComparison,
    ParamArray texts As String()
) As FSMI
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI DoUntilAny(
    TToken token,
    FSMI instruction,
    StringComparison comparison,
    ... array<String^>^ texts
)
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI DoUntilAny(
    TToken token,
    FSMI instruction,
    StringComparison comparison,
    ... array<String^>^ texts
)
static member DoUntilAny :
        token : 'TToken *
        instruction : FSMI *
        comparison : StringComparison *
        texts : string[] -> FSMI  when 'TToken : Token
static member DoUntilAny :
        token : 'TToken *
        instruction : FSMI *
        comparison : StringComparison *
        texts : string[] -> FSMI  when 'TToken : Token

Parameters

token
Type: TToken
instruction
Type: NFX.CodeAnalysis FSMI
comparison
Type: Online System StringComparison
texts
Type: Online System String
Type Parameters
TToken

Return Value

Type: FSMI

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
PatternSearch Class
PatternSearch Members
DoUntilAny Overload
NFX.CodeAnalysis Namespace


PatternSearch.IsAnyOrAbort Method

PatternSearch IsAnyOrAbort Method NFX Class Library

Overload List
Name | Description
IsAnyOrAbort TToken (TToken, Int32 ) | Advances FSM when token's type is any of specified or aborts FSM
IsAnyOrAbort TToken (TToken, String ) | Advances FSM when token's text is any of specified or aborts FSM
IsAnyOrAbort TToken, TTokenType (TToken, TTokenType ) | Advances FSM when token's type is any of specified or aborts FSM
IsAnyOrAbort TToken (TToken, StringComparison, String ) | Advances FSM when token's text is any of specified or aborts FSM
Back to Top
See Also
PatternSearch Class
PatternSearch Members
NFX.CodeAnalysis Namespace


PatternSearch.IsAnyOrAbort(TToken) Method (TToken, Int32[])

PatternSearch IsAnyOrAbort TToken Method (TToken, Int32 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Advances FSM when token's type is any of specified or aborts FSM

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FSMI IsAnyOrAbort<TToken>(
    this TToken token,
    params int[] types
)
where TToken : Token
public static FSMI IsAnyOrAbort<TToken>(
    this TToken token,
    params int[] types
)
where TToken : Token
<ExtensionAttribute>
Public Shared Function IsAnyOrAbort(Of TToken As Token) (
    token As TToken,
    ParamArray types As Integer()
) As FSMI
<ExtensionAttribute>
Public Shared Function IsAnyOrAbort(Of TToken As Token) (
    token As TToken,
    ParamArray types As Integer()
) As FSMI
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI IsAnyOrAbort(
    TToken token,
    ... array<int>^ types
)
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI IsAnyOrAbort(
    TToken token,
    ... array<int>^ types
)
static member IsAnyOrAbort :
        token : 'TToken *
        types : int[] -> FSMI  when 'TToken : Token
static member IsAnyOrAbort :
        token : 'TToken *
        types : int[] -> FSMI  when 'TToken : Token

Parameters

token
Type: TToken
types
Type: Online System Int32
Type Parameters
TToken

Return Value

Type: FSMI

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
PatternSearch Class
PatternSearch Members
IsAnyOrAbort Overload
NFX.CodeAnalysis Namespace


PatternSearch.IsAnyOrAbort(TToken) Method (TToken, String[])

PatternSearch IsAnyOrAbort TToken Method (TToken, String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Advances FSM when token's text is any of specified or aborts FSM

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FSMI IsAnyOrAbort<TToken>(
    this TToken token,
    params string[] texts
)
where TToken : Token
public static FSMI IsAnyOrAbort<TToken>(
    this TToken token,
    params string[] texts
)
where TToken : Token
<ExtensionAttribute>
Public Shared Function IsAnyOrAbort(Of TToken As Token) (
    token As TToken,
    ParamArray texts As String()
) As FSMI
<ExtensionAttribute>
Public Shared Function IsAnyOrAbort(Of TToken As Token) (
    token As TToken,
    ParamArray texts As String()
) As FSMI
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI IsAnyOrAbort(
    TToken token,
    ... array<String^>^ texts
)
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI IsAnyOrAbort(
    TToken token,
    ... array<String^>^ texts
)
static member IsAnyOrAbort :
        token : 'TToken *
        texts : string[] -> FSMI  when 'TToken : Token
static member IsAnyOrAbort :
        token : 'TToken *
        texts : string[] -> FSMI  when 'TToken : Token

Parameters

token
Type: TToken
texts
Type: Online System String
Type Parameters
TToken

Return Value

Type: FSMI

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
PatternSearch Class
PatternSearch Members
IsAnyOrAbort Overload
NFX.CodeAnalysis Namespace


PatternSearch.IsAnyOrAbort(TToken, TTokenType) Method (TToken, TTokenType[])

PatternSearch IsAnyOrAbort TToken, TTokenType Method (TToken, TTokenType ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Advances FSM when token's type is any of specified or aborts FSM

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FSMI IsAnyOrAbort<TToken, TTokenType>(
    this TToken token,
    params TTokenType[] types
)
where TToken : Token
where TTokenType : struct, new(), IConvertible
public static FSMI IsAnyOrAbort<TToken, TTokenType>(
    this TToken token,
    params TTokenType[] types
)
where TToken : Token
where TTokenType : struct, new(), IConvertible
<ExtensionAttribute>
Public Shared Function IsAnyOrAbort(Of TToken As Token, TTokenType As {Structure, New, IConvertible}) (
    token As TToken,
    ParamArray types As TTokenType()
) As FSMI
<ExtensionAttribute>
Public Shared Function IsAnyOrAbort(Of TToken As Token, TTokenType As {Structure, New, IConvertible}) (
    token As TToken,
    ParamArray types As TTokenType()
) As FSMI
public:
[ExtensionAttribute]
generic<typename TToken, typename TTokenType>
where TToken : Token
where TTokenType : value class, gcnew(), IConvertible
static FSMI IsAnyOrAbort(
    TToken token,
    ... array<TTokenType>^ types
)
public:
[ExtensionAttribute]
generic<typename TToken, typename TTokenType>
where TToken : Token
where TTokenType : value class, gcnew(), IConvertible
static FSMI IsAnyOrAbort(
    TToken token,
    ... array<TTokenType>^ types
)
static member IsAnyOrAbort :
        token : 'TToken *
        types : 'TTokenType[] -> FSMI  when 'TToken : Token when 'TTokenType : struct, new() and IConvertible
static member IsAnyOrAbort :
        token : 'TToken *
        types : 'TTokenType[] -> FSMI  when 'TToken : Token when 'TTokenType : struct, new() and IConvertible

Parameters

token
Type: TToken
types
Type: TTokenType
Type Parameters
TToken
TTokenType

Return Value

Type: FSMI

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
PatternSearch Class
PatternSearch Members
IsAnyOrAbort Overload
NFX.CodeAnalysis Namespace


PatternSearch.IsAnyOrAbort(TToken) Method (TToken, StringComparison, String[])

PatternSearch IsAnyOrAbort TToken Method (TToken, StringComparison, String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Advances FSM when token's text is any of specified or aborts FSM

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FSMI IsAnyOrAbort<TToken>(
    this TToken token,
    StringComparison comparison,
    params string[] texts
)
where TToken : Token
public static FSMI IsAnyOrAbort<TToken>(
    this TToken token,
    StringComparison comparison,
    params string[] texts
)
where TToken : Token
<ExtensionAttribute>
Public Shared Function IsAnyOrAbort(Of TToken As Token) (
    token As TToken,
    comparison As StringComparison,
    ParamArray texts As String()
) As FSMI
<ExtensionAttribute>
Public Shared Function IsAnyOrAbort(Of TToken As Token) (
    token As TToken,
    comparison As StringComparison,
    ParamArray texts As String()
) As FSMI
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI IsAnyOrAbort(
    TToken token,
    StringComparison comparison,
    ... array<String^>^ texts
)
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI IsAnyOrAbort(
    TToken token,
    StringComparison comparison,
    ... array<String^>^ texts
)
static member IsAnyOrAbort :
        token : 'TToken *
        comparison : StringComparison *
        texts : string[] -> FSMI  when 'TToken : Token
static member IsAnyOrAbort :
        token : 'TToken *
        comparison : StringComparison *
        texts : string[] -> FSMI  when 'TToken : Token

Parameters

token
Type: TToken
comparison
Type: Online System StringComparison
texts
Type: Online System String
Type Parameters
TToken

Return Value

Type: FSMI

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
PatternSearch Class
PatternSearch Members
IsAnyOrAbort Overload
NFX.CodeAnalysis Namespace


PatternSearch.LazyFSM Method

PatternSearch LazyFSM Method NFX Class Library

Overload List
Name | Description
LazyFSM TToken (IEnumerable TToken , LazyFSMPredicate TToken ) | Makes finite state machine fed from IEnumerable(Token) only considering primary language tokens
LazyFSM TToken (IEnumerable TToken , Boolean, LazyFSMPredicate TToken ) | Makes finite state machine fed from IEnumerable(Token)
LazyFSM TToken (IEnumerable TToken , Boolean, LazyFSMState TToken , LazyFSMPredicate TToken ) | Makes finite state machine fed from IEnumerable(Token)
Back to Top
See Also
PatternSearch Class
PatternSearch Members
NFX.CodeAnalysis Namespace


PatternSearch.LazyFSM(TToken) Method (IEnumerable(TToken), LazyFSMPredicate(TToken)[])

PatternSearch LazyFSM TToken Method (IEnumerable TToken , LazyFSMPredicate TToken ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Makes finite state machine fed from IEnumerable(Token) only considering primary language tokens

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TToken LazyFSM<TToken>(
    this IEnumerable<TToken> tokens,
    params LazyFSMPredicate<TToken>[] predicates
)
where TToken : Token
public static TToken LazyFSM<TToken>(
    this IEnumerable<TToken> tokens,
    params LazyFSMPredicate<TToken>[] predicates
)
where TToken : Token
<ExtensionAttribute>
Public Shared Function LazyFSM(Of TToken As Token) (
    tokens As IEnumerable(Of TToken),
    ParamArray predicates As LazyFSMPredicate(Of TToken)()
) As TToken
<ExtensionAttribute>
Public Shared Function LazyFSM(Of TToken As Token) (
    tokens As IEnumerable(Of TToken),
    ParamArray predicates As LazyFSMPredicate(Of TToken)()
) As TToken
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static TToken LazyFSM(
    IEnumerable<TToken>^ tokens,
    ... array<LazyFSMPredicate<TToken>^>^ predicates
)
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static TToken LazyFSM(
    IEnumerable<TToken>^ tokens,
    ... array<LazyFSMPredicate<TToken>^>^ predicates
)
static member LazyFSM :
        tokens : IEnumerable<'TToken> *
        predicates : LazyFSMPredicate<'TToken>[] -> 'TToken  when 'TToken : Token
static member LazyFSM :
        tokens : IEnumerable<'TToken> *
        predicates : LazyFSMPredicate<'TToken>[] -> 'TToken  when 'TToken : Token

Parameters

tokens
Type: Online System.Collections.Generic IEnumerable TToken
Token enumerable
predicates
Type: NFX.CodeAnalysis LazyFSMPredicate TToken
Predicates that supply machine state transition instructions
Type Parameters
TToken
Concrete language-typed token

Return Value

Type: TToken
Resulting token fetched by FSMI.Take instruction or null

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online IEnumerable TToken . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
PatternSearch Class
PatternSearch Members
LazyFSM Overload
NFX.CodeAnalysis Namespace


PatternSearch.LazyFSM(TToken) Method (IEnumerable(TToken), Boolean, LazyFSMPredicate(TToken)[])

PatternSearch LazyFSM TToken Method (IEnumerable TToken , Boolean, LazyFSMPredicate TToken ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Makes finite state machine fed from IEnumerable(Token)

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TToken LazyFSM<TToken>(
    this IEnumerable<TToken> tokens,
    bool onlyPrimary,
    params LazyFSMPredicate<TToken>[] predicates
)
where TToken : Token
public static TToken LazyFSM<TToken>(
    this IEnumerable<TToken> tokens,
    bool onlyPrimary,
    params LazyFSMPredicate<TToken>[] predicates
)
where TToken : Token
<ExtensionAttribute>
Public Shared Function LazyFSM(Of TToken As Token) (
    tokens As IEnumerable(Of TToken),
    onlyPrimary As Boolean,
    ParamArray predicates As LazyFSMPredicate(Of TToken)()
) As TToken
<ExtensionAttribute>
Public Shared Function LazyFSM(Of TToken As Token) (
    tokens As IEnumerable(Of TToken),
    onlyPrimary As Boolean,
    ParamArray predicates As LazyFSMPredicate(Of TToken)()
) As TToken
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static TToken LazyFSM(
    IEnumerable<TToken>^ tokens,
    bool onlyPrimary,
    ... array<LazyFSMPredicate<TToken>^>^ predicates
)
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static TToken LazyFSM(
    IEnumerable<TToken>^ tokens,
    bool onlyPrimary,
    ... array<LazyFSMPredicate<TToken>^>^ predicates
)
static member LazyFSM :
        tokens : IEnumerable<'TToken> *
        onlyPrimary : bool *
        predicates : LazyFSMPredicate<'TToken>[] -> 'TToken  when 'TToken : Token
static member LazyFSM :
        tokens : IEnumerable<'TToken> *
        onlyPrimary : bool *
        predicates : LazyFSMPredicate<'TToken>[] -> 'TToken  when 'TToken : Token

Parameters

tokens
Type: Online System.Collections.Generic IEnumerable TToken
Token enumerable
onlyPrimary
Type: Online System Boolean
Sets filter to consider only primary language tokens (skip comments, directives, etc.)
predicates
Type: NFX.CodeAnalysis LazyFSMPredicate TToken
Predicates that supply machine state transition instructions
Type Parameters
TToken
Concrete language-typed token

Return Value

Type: TToken
Resulting token fetched by FSMI.Take instruction or null

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online IEnumerable TToken . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
PatternSearch Class
PatternSearch Members
LazyFSM Overload
NFX.CodeAnalysis Namespace


PatternSearch.LazyFSM(TToken) Method (IEnumerable(TToken), Boolean, LazyFSMState(TToken), LazyFSMPredicate(TToken)[])

PatternSearch LazyFSM TToken Method (IEnumerable TToken , Boolean, LazyFSMState TToken , LazyFSMPredicate TToken ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Makes finite state machine fed from IEnumerable(Token)

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TToken LazyFSM<TToken>(
    this IEnumerable<TToken> tokens,
    bool onlyPrimary,
    ref LazyFSMState<TToken> state,
    params LazyFSMPredicate<TToken>[] predicates
)
where TToken : Token
public static TToken LazyFSM<TToken>(
    this IEnumerable<TToken> tokens,
    bool onlyPrimary,
    ref LazyFSMState<TToken> state,
    params LazyFSMPredicate<TToken>[] predicates
)
where TToken : Token
<ExtensionAttribute>
Public Shared Function LazyFSM(Of TToken As Token) (
    tokens As IEnumerable(Of TToken),
    onlyPrimary As Boolean,
    ByRef state As LazyFSMState(Of TToken),
    ParamArray predicates As LazyFSMPredicate(Of TToken)()
) As TToken
<ExtensionAttribute>
Public Shared Function LazyFSM(Of TToken As Token) (
    tokens As IEnumerable(Of TToken),
    onlyPrimary As Boolean,
    ByRef state As LazyFSMState(Of TToken),
    ParamArray predicates As LazyFSMPredicate(Of TToken)()
) As TToken
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static TToken LazyFSM(
    IEnumerable<TToken>^ tokens,
    bool onlyPrimary,
    LazyFSMState<TToken>^% state,
    ... array<LazyFSMPredicate<TToken>^>^ predicates
)
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static TToken LazyFSM(
    IEnumerable<TToken>^ tokens,
    bool onlyPrimary,
    LazyFSMState<TToken>^% state,
    ... array<LazyFSMPredicate<TToken>^>^ predicates
)
static member LazyFSM :
        tokens : IEnumerable<'TToken> *
        onlyPrimary : bool *
        state : LazyFSMState<'TToken> byref *
        predicates : LazyFSMPredicate<'TToken>[] -> 'TToken  when 'TToken : Token
static member LazyFSM :
        tokens : IEnumerable<'TToken> *
        onlyPrimary : bool *
        state : LazyFSMState<'TToken> byref *
        predicates : LazyFSMPredicate<'TToken>[] -> 'TToken  when 'TToken : Token

Parameters

tokens
Type: Online System.Collections.Generic IEnumerable TToken
Token enumerable
onlyPrimary
Type: Online System Boolean
Sets filter to consider only primary language tokens (skip comments, directives, etc.)
state
Type: NFX.CodeAnalysis LazyFSMState TToken
Machine's state which will be allocated if null passed
predicates
Type: NFX.CodeAnalysis LazyFSMPredicate TToken
Predicates that supply machine state transition instructions
Type Parameters
TToken
Concrete language-typed token

Return Value

Type: TToken
Resulting token fetched by FSMI.Take instruction or null

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online IEnumerable TToken . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
PatternSearch Class
PatternSearch Members
LazyFSM Overload
NFX.CodeAnalysis Namespace


PatternSearch.LoopUntilAfterMatch(TToken) Method

PatternSearch LoopUntilAfterMatch TToken Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Loops until token pattern match succeeds. This method matches using the same primary token filter as the parent match. Keeps state machine if match was found on the first token that follows the match

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FSMI LoopUntilAfterMatch<TToken>(
    this LazyFSMState<TToken> state,
    params LazyFSMPredicate<TToken>[] predicates
)
where TToken : Token
public static FSMI LoopUntilAfterMatch<TToken>(
    this LazyFSMState<TToken> state,
    params LazyFSMPredicate<TToken>[] predicates
)
where TToken : Token
<ExtensionAttribute>
Public Shared Function LoopUntilAfterMatch(Of TToken As Token) (
    state As LazyFSMState(Of TToken),
    ParamArray predicates As LazyFSMPredicate(Of TToken)()
) As FSMI
<ExtensionAttribute>
Public Shared Function LoopUntilAfterMatch(Of TToken As Token) (
    state As LazyFSMState(Of TToken),
    ParamArray predicates As LazyFSMPredicate(Of TToken)()
) As FSMI
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI LoopUntilAfterMatch(
    LazyFSMState<TToken>^ state,
    ... array<LazyFSMPredicate<TToken>^>^ predicates
)
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI LoopUntilAfterMatch(
    LazyFSMState<TToken>^ state,
    ... array<LazyFSMPredicate<TToken>^>^ predicates
)
static member LoopUntilAfterMatch :
        state : LazyFSMState<'TToken> *
        predicates : LazyFSMPredicate<'TToken>[] -> FSMI  when 'TToken : Token
static member LoopUntilAfterMatch :
        state : LazyFSMState<'TToken> *
        predicates : LazyFSMPredicate<'TToken>[] -> FSMI  when 'TToken : Token

Parameters

state
Type: NFX.CodeAnalysis LazyFSMState TToken
predicates
Type: NFX.CodeAnalysis LazyFSMPredicate TToken
Type Parameters
TToken

Return Value

Type: FSMI

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type LazyFSMState TToken . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
PatternSearch Class
PatternSearch Members
NFX.CodeAnalysis Namespace


PatternSearch.LoopUntilAny Method

PatternSearch LoopUntilAny Method NFX Class Library

Overload List
Name | Description
LoopUntilAny TToken (TToken, Int32 ) | Advances FSM when token's type is any of specified or loops FSM
LoopUntilAny TToken (TToken, String ) | Advances FSM when token's text is any of specified or loops FSM
LoopUntilAny TToken, TTokenType (TToken, TTokenType ) | Advances FSM when token's type is any of specified or loops FSM
LoopUntilAny TToken (TToken, StringComparison, String ) | Advances FSM when token's text is any of specified or loops FSM
Back to Top
See Also
PatternSearch Class
PatternSearch Members
NFX.CodeAnalysis Namespace


PatternSearch.LoopUntilAny(TToken) Method (TToken, Int32[])

PatternSearch LoopUntilAny TToken Method (TToken, Int32 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Advances FSM when token's type is any of specified or loops FSM

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FSMI LoopUntilAny<TToken>(
    this TToken token,
    params int[] types
)
where TToken : Token
public static FSMI LoopUntilAny<TToken>(
    this TToken token,
    params int[] types
)
where TToken : Token
<ExtensionAttribute>
Public Shared Function LoopUntilAny(Of TToken As Token) (
    token As TToken,
    ParamArray types As Integer()
) As FSMI
<ExtensionAttribute>
Public Shared Function LoopUntilAny(Of TToken As Token) (
    token As TToken,
    ParamArray types As Integer()
) As FSMI
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI LoopUntilAny(
    TToken token,
    ... array<int>^ types
)
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI LoopUntilAny(
    TToken token,
    ... array<int>^ types
)
static member LoopUntilAny :
        token : 'TToken *
        types : int[] -> FSMI  when 'TToken : Token
static member LoopUntilAny :
        token : 'TToken *
        types : int[] -> FSMI  when 'TToken : Token

Parameters

token
Type: TToken
types
Type: Online System Int32
Type Parameters
TToken

Return Value

Type: FSMI

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
PatternSearch Class
PatternSearch Members
LoopUntilAny Overload
NFX.CodeAnalysis Namespace


PatternSearch.LoopUntilAny(TToken) Method (TToken, String[])

PatternSearch LoopUntilAny TToken Method (TToken, String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Advances FSM when token's text is any of specified or loops FSM

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FSMI LoopUntilAny<TToken>(
    this TToken token,
    params string[] texts
)
where TToken : Token
public static FSMI LoopUntilAny<TToken>(
    this TToken token,
    params string[] texts
)
where TToken : Token
<ExtensionAttribute>
Public Shared Function LoopUntilAny(Of TToken As Token) (
    token As TToken,
    ParamArray texts As String()
) As FSMI
<ExtensionAttribute>
Public Shared Function LoopUntilAny(Of TToken As Token) (
    token As TToken,
    ParamArray texts As String()
) As FSMI
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI LoopUntilAny(
    TToken token,
    ... array<String^>^ texts
)
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI LoopUntilAny(
    TToken token,
    ... array<String^>^ texts
)
static member LoopUntilAny :
        token : 'TToken *
        texts : string[] -> FSMI  when 'TToken : Token
static member LoopUntilAny :
        token : 'TToken *
        texts : string[] -> FSMI  when 'TToken : Token

Parameters

token
Type: TToken
texts
Type: Online System String
Type Parameters
TToken

Return Value

Type: FSMI

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
PatternSearch Class
PatternSearch Members
LoopUntilAny Overload
NFX.CodeAnalysis Namespace


PatternSearch.LoopUntilAny(TToken, TTokenType) Method (TToken, TTokenType[])

PatternSearch LoopUntilAny TToken, TTokenType Method (TToken, TTokenType ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Advances FSM when token's type is any of specified or loops FSM

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FSMI LoopUntilAny<TToken, TTokenType>(
    this TToken token,
    params TTokenType[] types
)
where TToken : Token
where TTokenType : struct, new(), IConvertible
public static FSMI LoopUntilAny<TToken, TTokenType>(
    this TToken token,
    params TTokenType[] types
)
where TToken : Token
where TTokenType : struct, new(), IConvertible
<ExtensionAttribute>
Public Shared Function LoopUntilAny(Of TToken As Token, TTokenType As {Structure, New, IConvertible}) (
    token As TToken,
    ParamArray types As TTokenType()
) As FSMI
<ExtensionAttribute>
Public Shared Function LoopUntilAny(Of TToken As Token, TTokenType As {Structure, New, IConvertible}) (
    token As TToken,
    ParamArray types As TTokenType()
) As FSMI
public:
[ExtensionAttribute]
generic<typename TToken, typename TTokenType>
where TToken : Token
where TTokenType : value class, gcnew(), IConvertible
static FSMI LoopUntilAny(
    TToken token,
    ... array<TTokenType>^ types
)
public:
[ExtensionAttribute]
generic<typename TToken, typename TTokenType>
where TToken : Token
where TTokenType : value class, gcnew(), IConvertible
static FSMI LoopUntilAny(
    TToken token,
    ... array<TTokenType>^ types
)
static member LoopUntilAny :
        token : 'TToken *
        types : 'TTokenType[] -> FSMI  when 'TToken : Token when 'TTokenType : struct, new() and IConvertible
static member LoopUntilAny :
        token : 'TToken *
        types : 'TTokenType[] -> FSMI  when 'TToken : Token when 'TTokenType : struct, new() and IConvertible

Parameters

token
Type: TToken
types
Type: TTokenType
Type Parameters
TToken
TTokenType

Return Value

Type: FSMI

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
PatternSearch Class
PatternSearch Members
LoopUntilAny Overload
NFX.CodeAnalysis Namespace


PatternSearch.LoopUntilAny(TToken) Method (TToken, StringComparison, String[])

PatternSearch LoopUntilAny TToken Method (TToken, StringComparison, String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Advances FSM when token's text is any of specified or loops FSM

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FSMI LoopUntilAny<TToken>(
    this TToken token,
    StringComparison comparison,
    params string[] texts
)
where TToken : Token
public static FSMI LoopUntilAny<TToken>(
    this TToken token,
    StringComparison comparison,
    params string[] texts
)
where TToken : Token
<ExtensionAttribute>
Public Shared Function LoopUntilAny(Of TToken As Token) (
    token As TToken,
    comparison As StringComparison,
    ParamArray texts As String()
) As FSMI
<ExtensionAttribute>
Public Shared Function LoopUntilAny(Of TToken As Token) (
    token As TToken,
    comparison As StringComparison,
    ParamArray texts As String()
) As FSMI
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI LoopUntilAny(
    TToken token,
    StringComparison comparison,
    ... array<String^>^ texts
)
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI LoopUntilAny(
    TToken token,
    StringComparison comparison,
    ... array<String^>^ texts
)
static member LoopUntilAny :
        token : 'TToken *
        comparison : StringComparison *
        texts : string[] -> FSMI  when 'TToken : Token
static member LoopUntilAny :
        token : 'TToken *
        comparison : StringComparison *
        texts : string[] -> FSMI  when 'TToken : Token

Parameters

token
Type: TToken
comparison
Type: Online System StringComparison
texts
Type: Online System String
Type Parameters
TToken

Return Value

Type: FSMI

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
PatternSearch Class
PatternSearch Members
LoopUntilAny Overload
NFX.CodeAnalysis Namespace


PatternSearch.LoopUntilMatch Method

PatternSearch LoopUntilMatch Method NFX Class Library

Overload List
Name | Description
LoopUntilMatch TToken (LazyFSMState TToken , LazyFSMPredicate TToken ) | Loops until token pattern match succeeds, considering only primary language tokens. Keeps state machine if match was found on the first matching token
LoopUntilMatch TToken (LazyFSMState TToken , Boolean, LazyFSMPredicate TToken ) | Loops until token pattern match succeeds, conditionaly considering only primary language tokens. Keeps state machine if match was found on the first matching token
Back to Top
See Also
PatternSearch Class
PatternSearch Members
NFX.CodeAnalysis Namespace


PatternSearch.LoopUntilMatch(TToken) Method (LazyFSMState(TToken), LazyFSMPredicate(TToken)[])

PatternSearch LoopUntilMatch TToken Method (LazyFSMState TToken , LazyFSMPredicate TToken ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Loops until token pattern match succeeds, considering only primary language tokens. Keeps state machine if match was found on the first matching token

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FSMI LoopUntilMatch<TToken>(
    this LazyFSMState<TToken> state,
    params LazyFSMPredicate<TToken>[] predicates
)
where TToken : Token
public static FSMI LoopUntilMatch<TToken>(
    this LazyFSMState<TToken> state,
    params LazyFSMPredicate<TToken>[] predicates
)
where TToken : Token
<ExtensionAttribute>
Public Shared Function LoopUntilMatch(Of TToken As Token) (
    state As LazyFSMState(Of TToken),
    ParamArray predicates As LazyFSMPredicate(Of TToken)()
) As FSMI
<ExtensionAttribute>
Public Shared Function LoopUntilMatch(Of TToken As Token) (
    state As LazyFSMState(Of TToken),
    ParamArray predicates As LazyFSMPredicate(Of TToken)()
) As FSMI
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI LoopUntilMatch(
    LazyFSMState<TToken>^ state,
    ... array<LazyFSMPredicate<TToken>^>^ predicates
)
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI LoopUntilMatch(
    LazyFSMState<TToken>^ state,
    ... array<LazyFSMPredicate<TToken>^>^ predicates
)
static member LoopUntilMatch :
        state : LazyFSMState<'TToken> *
        predicates : LazyFSMPredicate<'TToken>[] -> FSMI  when 'TToken : Token
static member LoopUntilMatch :
        state : LazyFSMState<'TToken> *
        predicates : LazyFSMPredicate<'TToken>[] -> FSMI  when 'TToken : Token

Parameters

state
Type: NFX.CodeAnalysis LazyFSMState TToken
predicates
Type: NFX.CodeAnalysis LazyFSMPredicate TToken
Type Parameters
TToken

Return Value

Type: FSMI

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type LazyFSMState TToken . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
PatternSearch Class
PatternSearch Members
LoopUntilMatch Overload
NFX.CodeAnalysis Namespace


PatternSearch.LoopUntilMatch(TToken) Method (LazyFSMState(TToken), Boolean, LazyFSMPredicate(TToken)[])

PatternSearch LoopUntilMatch TToken Method (LazyFSMState TToken , Boolean, LazyFSMPredicate TToken ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Loops until token pattern match succeeds, conditionaly considering only primary language tokens. Keeps state machine if match was found on the first matching token

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FSMI LoopUntilMatch<TToken>(
    this LazyFSMState<TToken> state,
    bool onlyPrimary,
    params LazyFSMPredicate<TToken>[] predicates
)
where TToken : Token
public static FSMI LoopUntilMatch<TToken>(
    this LazyFSMState<TToken> state,
    bool onlyPrimary,
    params LazyFSMPredicate<TToken>[] predicates
)
where TToken : Token
<ExtensionAttribute>
Public Shared Function LoopUntilMatch(Of TToken As Token) (
    state As LazyFSMState(Of TToken),
    onlyPrimary As Boolean,
    ParamArray predicates As LazyFSMPredicate(Of TToken)()
) As FSMI
<ExtensionAttribute>
Public Shared Function LoopUntilMatch(Of TToken As Token) (
    state As LazyFSMState(Of TToken),
    onlyPrimary As Boolean,
    ParamArray predicates As LazyFSMPredicate(Of TToken)()
) As FSMI
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI LoopUntilMatch(
    LazyFSMState<TToken>^ state,
    bool onlyPrimary,
    ... array<LazyFSMPredicate<TToken>^>^ predicates
)
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI LoopUntilMatch(
    LazyFSMState<TToken>^ state,
    bool onlyPrimary,
    ... array<LazyFSMPredicate<TToken>^>^ predicates
)
static member LoopUntilMatch :
        state : LazyFSMState<'TToken> *
        onlyPrimary : bool *
        predicates : LazyFSMPredicate<'TToken>[] -> FSMI  when 'TToken : Token
static member LoopUntilMatch :
        state : LazyFSMState<'TToken> *
        onlyPrimary : bool *
        predicates : LazyFSMPredicate<'TToken>[] -> FSMI  when 'TToken : Token

Parameters

state
Type: NFX.CodeAnalysis LazyFSMState TToken
onlyPrimary
Type: Online System Boolean
predicates
Type: NFX.CodeAnalysis LazyFSMPredicate TToken
Type Parameters
TToken

Return Value

Type: FSMI

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type LazyFSMState TToken . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
PatternSearch Class
PatternSearch Members
LoopUntilMatch Overload
NFX.CodeAnalysis Namespace


PatternSearch.LoopWhileAnyOrAbort Method

PatternSearch LoopWhileAnyOrAbort Method NFX Class Library

Overload List
Name | Description
LoopWhileAnyOrAbort TToken (TToken, Int32 ) | Loops FSM while token's type is any of the specified or aborts
LoopWhileAnyOrAbort TToken (TToken, String ) | Loops FSM while token's text is any of the specified or aborts
LoopWhileAnyOrAbort TToken, TTokenType (TToken, TTokenType ) | Loops FSM while token's type is any of the specified or aborts
LoopWhileAnyOrAbort TToken (TToken, StringComparison, String ) | Loops FSM while token's text is any of the specified or aborts
Back to Top
See Also
PatternSearch Class
PatternSearch Members
NFX.CodeAnalysis Namespace


PatternSearch.LoopWhileAnyOrAbort(TToken) Method (TToken, Int32[])

PatternSearch LoopWhileAnyOrAbort TToken Method (TToken, Int32 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Loops FSM while token's type is any of the specified or aborts

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FSMI LoopWhileAnyOrAbort<TToken>(
    this TToken token,
    params int[] types
)
where TToken : Token
public static FSMI LoopWhileAnyOrAbort<TToken>(
    this TToken token,
    params int[] types
)
where TToken : Token
<ExtensionAttribute>
Public Shared Function LoopWhileAnyOrAbort(Of TToken As Token) (
    token As TToken,
    ParamArray types As Integer()
) As FSMI
<ExtensionAttribute>
Public Shared Function LoopWhileAnyOrAbort(Of TToken As Token) (
    token As TToken,
    ParamArray types As Integer()
) As FSMI
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI LoopWhileAnyOrAbort(
    TToken token,
    ... array<int>^ types
)
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI LoopWhileAnyOrAbort(
    TToken token,
    ... array<int>^ types
)
static member LoopWhileAnyOrAbort :
        token : 'TToken *
        types : int[] -> FSMI  when 'TToken : Token
static member LoopWhileAnyOrAbort :
        token : 'TToken *
        types : int[] -> FSMI  when 'TToken : Token

Parameters

token
Type: TToken
types
Type: Online System Int32
Type Parameters
TToken

Return Value

Type: FSMI

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
PatternSearch Class
PatternSearch Members
LoopWhileAnyOrAbort Overload
NFX.CodeAnalysis Namespace


PatternSearch.LoopWhileAnyOrAbort(TToken) Method (TToken, String[])

PatternSearch LoopWhileAnyOrAbort TToken Method (TToken, String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Loops FSM while token's text is any of the specified or aborts

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FSMI LoopWhileAnyOrAbort<TToken>(
    this TToken token,
    params string[] texts
)
where TToken : Token
public static FSMI LoopWhileAnyOrAbort<TToken>(
    this TToken token,
    params string[] texts
)
where TToken : Token
<ExtensionAttribute>
Public Shared Function LoopWhileAnyOrAbort(Of TToken As Token) (
    token As TToken,
    ParamArray texts As String()
) As FSMI
<ExtensionAttribute>
Public Shared Function LoopWhileAnyOrAbort(Of TToken As Token) (
    token As TToken,
    ParamArray texts As String()
) As FSMI
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI LoopWhileAnyOrAbort(
    TToken token,
    ... array<String^>^ texts
)
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI LoopWhileAnyOrAbort(
    TToken token,
    ... array<String^>^ texts
)
static member LoopWhileAnyOrAbort :
        token : 'TToken *
        texts : string[] -> FSMI  when 'TToken : Token
static member LoopWhileAnyOrAbort :
        token : 'TToken *
        texts : string[] -> FSMI  when 'TToken : Token

Parameters

token
Type: TToken
texts
Type: Online System String
Type Parameters
TToken

Return Value

Type: FSMI

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
PatternSearch Class
PatternSearch Members
LoopWhileAnyOrAbort Overload
NFX.CodeAnalysis Namespace


PatternSearch.LoopWhileAnyOrAbort(TToken, TTokenType) Method (TToken, TTokenType[])

PatternSearch LoopWhileAnyOrAbort TToken, TTokenType Method (TToken, TTokenType ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Loops FSM while token's type is any of the specified or aborts

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FSMI LoopWhileAnyOrAbort<TToken, TTokenType>(
    this TToken token,
    params TTokenType[] types
)
where TToken : Token
where TTokenType : struct, new(), IConvertible
public static FSMI LoopWhileAnyOrAbort<TToken, TTokenType>(
    this TToken token,
    params TTokenType[] types
)
where TToken : Token
where TTokenType : struct, new(), IConvertible
<ExtensionAttribute>
Public Shared Function LoopWhileAnyOrAbort(Of TToken As Token, TTokenType As {Structure, New, IConvertible}) (
    token As TToken,
    ParamArray types As TTokenType()
) As FSMI
<ExtensionAttribute>
Public Shared Function LoopWhileAnyOrAbort(Of TToken As Token, TTokenType As {Structure, New, IConvertible}) (
    token As TToken,
    ParamArray types As TTokenType()
) As FSMI
public:
[ExtensionAttribute]
generic<typename TToken, typename TTokenType>
where TToken : Token
where TTokenType : value class, gcnew(), IConvertible
static FSMI LoopWhileAnyOrAbort(
    TToken token,
    ... array<TTokenType>^ types
)
public:
[ExtensionAttribute]
generic<typename TToken, typename TTokenType>
where TToken : Token
where TTokenType : value class, gcnew(), IConvertible
static FSMI LoopWhileAnyOrAbort(
    TToken token,
    ... array<TTokenType>^ types
)
static member LoopWhileAnyOrAbort :
        token : 'TToken *
        types : 'TTokenType[] -> FSMI  when 'TToken : Token when 'TTokenType : struct, new() and IConvertible
static member LoopWhileAnyOrAbort :
        token : 'TToken *
        types : 'TTokenType[] -> FSMI  when 'TToken : Token when 'TTokenType : struct, new() and IConvertible

Parameters

token
Type: TToken
types
Type: TTokenType
Type Parameters
TToken
TTokenType

Return Value

Type: FSMI

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
PatternSearch Class
PatternSearch Members
LoopWhileAnyOrAbort Overload
NFX.CodeAnalysis Namespace


PatternSearch.LoopWhileAnyOrAbort(TToken) Method (TToken, StringComparison, String[])

PatternSearch LoopWhileAnyOrAbort TToken Method (TToken, StringComparison, String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Loops FSM while token's text is any of the specified or aborts

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FSMI LoopWhileAnyOrAbort<TToken>(
    this TToken token,
    StringComparison comparison,
    params string[] texts
)
where TToken : Token
public static FSMI LoopWhileAnyOrAbort<TToken>(
    this TToken token,
    StringComparison comparison,
    params string[] texts
)
where TToken : Token
<ExtensionAttribute>
Public Shared Function LoopWhileAnyOrAbort(Of TToken As Token) (
    token As TToken,
    comparison As StringComparison,
    ParamArray texts As String()
) As FSMI
<ExtensionAttribute>
Public Shared Function LoopWhileAnyOrAbort(Of TToken As Token) (
    token As TToken,
    comparison As StringComparison,
    ParamArray texts As String()
) As FSMI
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI LoopWhileAnyOrAbort(
    TToken token,
    StringComparison comparison,
    ... array<String^>^ texts
)
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI LoopWhileAnyOrAbort(
    TToken token,
    StringComparison comparison,
    ... array<String^>^ texts
)
static member LoopWhileAnyOrAbort :
        token : 'TToken *
        comparison : StringComparison *
        texts : string[] -> FSMI  when 'TToken : Token
static member LoopWhileAnyOrAbort :
        token : 'TToken *
        comparison : StringComparison *
        texts : string[] -> FSMI  when 'TToken : Token

Parameters

token
Type: TToken
comparison
Type: Online System StringComparison
texts
Type: Online System String
Type Parameters
TToken

Return Value

Type: FSMI

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
PatternSearch Class
PatternSearch Members
LoopWhileAnyOrAbort Overload
NFX.CodeAnalysis Namespace


PatternSearch.Skip(TToken) Method

PatternSearch Skip TToken Method NFX Class Library

Skips specified number of tokens by returning FSMI.Loop count times

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FSMI Skip<TToken>(
    this LazyFSMState<TToken> state,
    int count
)
where TToken : Token
public static FSMI Skip<TToken>(
    this LazyFSMState<TToken> state,
    int count
)
where TToken : Token
<ExtensionAttribute>
Public Shared Function Skip(Of TToken As Token) (
    state As LazyFSMState(Of TToken),
    count As Integer
) As FSMI
<ExtensionAttribute>
Public Shared Function Skip(Of TToken As Token) (
    state As LazyFSMState(Of TToken),
    count As Integer
) As FSMI
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI Skip(
    LazyFSMState<TToken>^ state,
    int count
)
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static FSMI Skip(
    LazyFSMState<TToken>^ state,
    int count
)
static member Skip :
        state : LazyFSMState<'TToken> *
        count : int -> FSMI  when 'TToken : Token
static member Skip :
        state : LazyFSMState<'TToken> *
        count : int -> FSMI  when 'TToken : Token

Parameters

state
Type: NFX.CodeAnalysis LazyFSMState TToken
count
Type: Online System Int32
Type Parameters
TToken

Return Value

Type: FSMI

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type LazyFSMState TToken . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
PatternSearch Class
PatternSearch Members
NFX.CodeAnalysis Namespace


PatternSearch.TextIsAnyOf Method

PatternSearch TextIsAnyOf Method NFX Class Library

Overload List
Name | Description
TextIsAnyOf TToken (TToken, String ) | Returns true when token's text is any of specified
TextIsAnyOf TToken (TToken, StringComparison, String ) | Returns true when token's text is any of specified
Back to Top
See Also
PatternSearch Class
PatternSearch Members
NFX.CodeAnalysis Namespace


PatternSearch.TextIsAnyOf(TToken) Method (TToken, String[])

PatternSearch TextIsAnyOf TToken Method (TToken, String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns true when token's text is any of specified

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool TextIsAnyOf<TToken>(
    this TToken token,
    params string[] texts
)
where TToken : Token
public static bool TextIsAnyOf<TToken>(
    this TToken token,
    params string[] texts
)
where TToken : Token
<ExtensionAttribute>
Public Shared Function TextIsAnyOf(Of TToken As Token) (
    token As TToken,
    ParamArray texts As String()
) As Boolean
<ExtensionAttribute>
Public Shared Function TextIsAnyOf(Of TToken As Token) (
    token As TToken,
    ParamArray texts As String()
) As Boolean
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static bool TextIsAnyOf(
    TToken token,
    ... array<String^>^ texts
)
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static bool TextIsAnyOf(
    TToken token,
    ... array<String^>^ texts
)
static member TextIsAnyOf :
        token : 'TToken *
        texts : string[] -> bool  when 'TToken : Token
static member TextIsAnyOf :
        token : 'TToken *
        texts : string[] -> bool  when 'TToken : Token

Parameters

token
Type: TToken
texts
Type: Online System String
Type Parameters
TToken

Return Value

Type: Online Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
PatternSearch Class
PatternSearch Members
TextIsAnyOf Overload
NFX.CodeAnalysis Namespace


PatternSearch.TextIsAnyOf(TToken) Method (TToken, StringComparison, String[])

PatternSearch TextIsAnyOf TToken Method (TToken, StringComparison, String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns true when token's text is any of specified

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool TextIsAnyOf<TToken>(
    this TToken token,
    StringComparison comparison,
    params string[] texts
)
where TToken : Token
public static bool TextIsAnyOf<TToken>(
    this TToken token,
    StringComparison comparison,
    params string[] texts
)
where TToken : Token
<ExtensionAttribute>
Public Shared Function TextIsAnyOf(Of TToken As Token) (
    token As TToken,
    comparison As StringComparison,
    ParamArray texts As String()
) As Boolean
<ExtensionAttribute>
Public Shared Function TextIsAnyOf(Of TToken As Token) (
    token As TToken,
    comparison As StringComparison,
    ParamArray texts As String()
) As Boolean
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static bool TextIsAnyOf(
    TToken token,
    StringComparison comparison,
    ... array<String^>^ texts
)
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static bool TextIsAnyOf(
    TToken token,
    StringComparison comparison,
    ... array<String^>^ texts
)
static member TextIsAnyOf :
        token : 'TToken *
        comparison : StringComparison *
        texts : string[] -> bool  when 'TToken : Token
static member TextIsAnyOf :
        token : 'TToken *
        comparison : StringComparison *
        texts : string[] -> bool  when 'TToken : Token

Parameters

token
Type: TToken
comparison
Type: Online System StringComparison
texts
Type: Online System String
Type Parameters
TToken

Return Value

Type: Online Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
PatternSearch Class
PatternSearch Members
TextIsAnyOf Overload
NFX.CodeAnalysis Namespace


PatternSearch.TypeIsAnyOf Method

PatternSearch TypeIsAnyOf Method NFX Class Library

Overload List
Name | Description
TypeIsAnyOf TToken (TToken, Int32 ) | Returns true when token's type is any of the specified
TypeIsAnyOf TToken, TTokenType (TToken, TTokenType ) | Returns true when token's type is any of the specified
Back to Top
See Also
PatternSearch Class
PatternSearch Members
NFX.CodeAnalysis Namespace


PatternSearch.TypeIsAnyOf(TToken) Method (TToken, Int32[])

PatternSearch TypeIsAnyOf TToken Method (TToken, Int32 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns true when token's type is any of the specified

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool TypeIsAnyOf<TToken>(
    this TToken token,
    params int[] types
)
where TToken : Token
public static bool TypeIsAnyOf<TToken>(
    this TToken token,
    params int[] types
)
where TToken : Token
<ExtensionAttribute>
Public Shared Function TypeIsAnyOf(Of TToken As Token) (
    token As TToken,
    ParamArray types As Integer()
) As Boolean
<ExtensionAttribute>
Public Shared Function TypeIsAnyOf(Of TToken As Token) (
    token As TToken,
    ParamArray types As Integer()
) As Boolean
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static bool TypeIsAnyOf(
    TToken token,
    ... array<int>^ types
)
public:
[ExtensionAttribute]
generic<typename TToken>
where TToken : Token
static bool TypeIsAnyOf(
    TToken token,
    ... array<int>^ types
)
static member TypeIsAnyOf :
        token : 'TToken *
        types : int[] -> bool  when 'TToken : Token
static member TypeIsAnyOf :
        token : 'TToken *
        types : int[] -> bool  when 'TToken : Token

Parameters

token
Type: TToken
types
Type: Online System Int32
Type Parameters
TToken

Return Value

Type: Online Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
PatternSearch Class
PatternSearch Members
TypeIsAnyOf Overload
NFX.CodeAnalysis Namespace


PatternSearch.TypeIsAnyOf(TToken, TTokenType) Method (TToken, TTokenType[])

PatternSearch TypeIsAnyOf TToken, TTokenType Method (TToken, TTokenType ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns true when token's type is any of the specified

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool TypeIsAnyOf<TToken, TTokenType>(
    this TToken token,
    params TTokenType[] types
)
where TToken : Token
where TTokenType : struct, new(), IConvertible
public static bool TypeIsAnyOf<TToken, TTokenType>(
    this TToken token,
    params TTokenType[] types
)
where TToken : Token
where TTokenType : struct, new(), IConvertible
<ExtensionAttribute>
Public Shared Function TypeIsAnyOf(Of TToken As Token, TTokenType As {Structure, New, IConvertible}) (
    token As TToken,
    ParamArray types As TTokenType()
) As Boolean
<ExtensionAttribute>
Public Shared Function TypeIsAnyOf(Of TToken As Token, TTokenType As {Structure, New, IConvertible}) (
    token As TToken,
    ParamArray types As TTokenType()
) As Boolean
public:
[ExtensionAttribute]
generic<typename TToken, typename TTokenType>
where TToken : Token
where TTokenType : value class, gcnew(), IConvertible
static bool TypeIsAnyOf(
    TToken token,
    ... array<TTokenType>^ types
)
public:
[ExtensionAttribute]
generic<typename TToken, typename TTokenType>
where TToken : Token
where TTokenType : value class, gcnew(), IConvertible
static bool TypeIsAnyOf(
    TToken token,
    ... array<TTokenType>^ types
)
static member TypeIsAnyOf :
        token : 'TToken *
        types : 'TTokenType[] -> bool  when 'TToken : Token when 'TTokenType : struct, new() and IConvertible
static member TypeIsAnyOf :
        token : 'TToken *
        types : 'TTokenType[] -> bool  when 'TToken : Token when 'TTokenType : struct, new() and IConvertible

Parameters

token
Type: TToken
types
Type: TTokenType
Type Parameters
TToken
TTokenType

Return Value

Type: Online Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
PatternSearch Class
PatternSearch Members
TypeIsAnyOf Overload
NFX.CodeAnalysis Namespace


SourceRefCommonCodeProcessor Class

SourceRefCommonCodeProcessor Class NFX Class Library

Provides base implementation for common code processors
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis CommonCodeProcessor
NFX.CodeAnalysis SourceRefCommonCodeProcessor
NFX.CodeAnalysis Lexer TToken

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class SourceRefCommonCodeProcessor : CommonCodeProcessor
public abstract class SourceRefCommonCodeProcessor : CommonCodeProcessor
Public MustInherit Class SourceRefCommonCodeProcessor
    Inherits CommonCodeProcessor
Public MustInherit Class SourceRefCommonCodeProcessor
    Inherits CommonCodeProcessor
public ref class SourceRefCommonCodeProcessor abstract : public CommonCodeProcessor
public ref class SourceRefCommonCodeProcessor abstract : public CommonCodeProcessor
[<AbstractClassAttribute>]
type SourceRefCommonCodeProcessor =
    class
        inherit CommonCodeProcessor
    end
[<AbstractClassAttribute>]
type SourceRefCommonCodeProcessor =
    class
        inherit CommonCodeProcessor
    end
See Also
SourceRefCommonCodeProcessor Members
NFX.CodeAnalysis Namespace


SourceRefCommonCodeProcessor Members

SourceRefCommonCodeProcessor Members NFX Class Library

The SourceRefCommonCodeProcessor type exposes the following members.
Constructors
 | Name | Description
Protected method | SourceRefCommonCodeProcessor | Initializes a new instance of the SourceRefCommonCodeProcessor class
Back to Top
Methods
 | Name | Description
Protected method | EmitMessage(MessageType, Int32, SourcePosition, Token, String, Exception) |
Protected method | EmitMessage(MessageType, Int32, SourceCodeRef, Nullable SourcePosition , Token, String, Exception) | (Inherited from CommonCodeProcessor.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MessageCodeToString | Returns string representation of message code which is output by this processor (Inherited from CommonCodeProcessor.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Context | Returns context that this processor operates under - an entity that retains state during analysis, such as: module compiler, project compiler, code unit translator etc. This entity may also contain compiler/parser/lexer options etc. (Inherited from CommonCodeProcessor.)
Public property | Language | Returns language that this processor is capable of processing (Inherited from CommonCodeProcessor.)
Public property | Messages | References message list that lexer emitts messages into. May be null (Inherited from CommonCodeProcessor.)
Public property | SourceCodeReference | References source code that is processed
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any lexing error is always thrown regardless of this parameter (Inherited from CommonCodeProcessor.)
Back to Top
See Also
SourceRefCommonCodeProcessor Class
NFX.CodeAnalysis Namespace


SourceRefCommonCodeProcessor Constructor

SourceRefCommonCodeProcessor Constructor NFX Class Library

Initializes a new instance of the SourceRefCommonCodeProcessor class

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected SourceRefCommonCodeProcessor(
    IAnalysisContext context,
    SourceCodeRef srcRef,
    MessageList messages = null,
    bool throwErrors = false
)
protected SourceRefCommonCodeProcessor(
    IAnalysisContext context,
    SourceCodeRef srcRef,
    MessageList messages = null,
    bool throwErrors = false
)
Protected Sub New (
    context As IAnalysisContext,
    srcRef As SourceCodeRef,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
Protected Sub New (
    context As IAnalysisContext,
    srcRef As SourceCodeRef,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
protected:
SourceRefCommonCodeProcessor(
    IAnalysisContext^ context,
    SourceCodeRef srcRef,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
protected:
SourceRefCommonCodeProcessor(
    IAnalysisContext^ context,
    SourceCodeRef srcRef,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
new :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> SourceRefCommonCodeProcessor
new :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> SourceRefCommonCodeProcessor

Parameters

context
Type: NFX.CodeAnalysis IAnalysisContext
srcRef
Type: NFX.CodeAnalysis.Source SourceCodeRef
messages (Optional)
Type: NFX.CodeAnalysis MessageList
throwErrors (Optional)
Type: Online System Boolean
See Also
SourceRefCommonCodeProcessor Class
SourceRefCommonCodeProcessor Members
NFX.CodeAnalysis Namespace


SourceRefCommonCodeProcessor Methods

SourceRefCommonCodeProcessor Methods NFX Class Library

The SourceRefCommonCodeProcessor type exposes the following members.
Methods
 | Name | Description
Protected method | EmitMessage(MessageType, Int32, SourcePosition, Token, String, Exception) |
Protected method | EmitMessage(MessageType, Int32, SourceCodeRef, Nullable SourcePosition , Token, String, Exception) | (Inherited from CommonCodeProcessor.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MessageCodeToString | Returns string representation of message code which is output by this processor (Inherited from CommonCodeProcessor.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SourceRefCommonCodeProcessor Class
NFX.CodeAnalysis Namespace


SourceRefCommonCodeProcessor.EmitMessage Method

SourceRefCommonCodeProcessor EmitMessage Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Protected method | EmitMessage(MessageType, Int32, SourcePosition, Token, String, Exception) |
Protected method | EmitMessage(MessageType, Int32, SourceCodeRef, Nullable SourcePosition , Token, String, Exception) | (Inherited from CommonCodeProcessor.)
Back to Top
See Also
SourceRefCommonCodeProcessor Class
SourceRefCommonCodeProcessor Members
NFX.CodeAnalysis Namespace


SourceRefCommonCodeProcessor.EmitMessage Method (MessageType, Int32, SourcePosition, Token, String, Exception)

SourceRefCommonCodeProcessor EmitMessage Method (MessageType, Int32, SourcePosition, Token, String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void EmitMessage(
    MessageType type,
    int code,
    SourcePosition position,
    Token token = null,
    string text = null,
    Exception exception = null
)
protected void EmitMessage(
    MessageType type,
    int code,
    SourcePosition position,
    Token token = null,
    string text = null,
    Exception exception = null
)
Protected Sub EmitMessage (
    type As MessageType,
    code As Integer,
    position As SourcePosition,
    Optional token As Token = Nothing,
    Optional text As String = Nothing,
    Optional exception As Exception = Nothing
)
Protected Sub EmitMessage (
    type As MessageType,
    code As Integer,
    position As SourcePosition,
    Optional token As Token = Nothing,
    Optional text As String = Nothing,
    Optional exception As Exception = Nothing
)
protected:
void EmitMessage(
    MessageType type,
    int code,
    SourcePosition position,
    Token^ token = nullptr,
    String^ text = nullptr,
    Exception^ exception = nullptr
)
protected:
void EmitMessage(
    MessageType type,
    int code,
    SourcePosition position,
    Token^ token = nullptr,
    String^ text = nullptr,
    Exception^ exception = nullptr
)
member EmitMessage :
        type : MessageType *
        code : int *
        position : SourcePosition *
        ?token : Token *
        ?text : string *
        ?exception : Exception
(* Defaults:
        let _token = defaultArg token null
        let _text = defaultArg text null
        let _exception = defaultArg exception null
*)
-> unit
member EmitMessage :
        type : MessageType *
        code : int *
        position : SourcePosition *
        ?token : Token *
        ?text : string *
        ?exception : Exception
(* Defaults:
        let _token = defaultArg token null
        let _text = defaultArg text null
        let _exception = defaultArg exception null
*)
-> unit

Parameters

type
Type: NFX.CodeAnalysis MessageType
code
Type: Online System Int32
position
Type: NFX.CodeAnalysis.Source SourcePosition
token (Optional)
Type: NFX.CodeAnalysis Token
text (Optional)
Type: Online System String
exception (Optional)
Type: Online System Exception
See Also
SourceRefCommonCodeProcessor Class
SourceRefCommonCodeProcessor Members
EmitMessage Overload
NFX.CodeAnalysis Namespace


SourceRefCommonCodeProcessor Properties

SourceRefCommonCodeProcessor Properties NFX Class Library

The SourceRefCommonCodeProcessor type exposes the following members.
Properties
 | Name | Description
Public property | Context | Returns context that this processor operates under - an entity that retains state during analysis, such as: module compiler, project compiler, code unit translator etc. This entity may also contain compiler/parser/lexer options etc. (Inherited from CommonCodeProcessor.)
Public property | Language | Returns language that this processor is capable of processing (Inherited from CommonCodeProcessor.)
Public property | Messages | References message list that lexer emitts messages into. May be null (Inherited from CommonCodeProcessor.)
Public property | SourceCodeReference | References source code that is processed
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any lexing error is always thrown regardless of this parameter (Inherited from CommonCodeProcessor.)
Back to Top
See Also
SourceRefCommonCodeProcessor Class
NFX.CodeAnalysis Namespace


SourceRefCommonCodeProcessor.SourceCodeReference Property

SourceRefCommonCodeProcessor SourceCodeReference Property NFX Class Library

[This is preliminary documentation and is subject to change.]

References source code that is processed

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SourceCodeRef SourceCodeReference { get; }
public SourceCodeRef SourceCodeReference { get; }
Public ReadOnly Property SourceCodeReference As SourceCodeRef
    Get
Public ReadOnly Property SourceCodeReference As SourceCodeRef
    Get
public:
virtual property SourceCodeRef SourceCodeReference {
    SourceCodeRef get () sealed;
}
public:
virtual property SourceCodeRef SourceCodeReference {
    SourceCodeRef get () sealed;
}
abstract SourceCodeReference : SourceCodeRef with get
override SourceCodeReference : SourceCodeRef with get
abstract SourceCodeReference : SourceCodeRef with get
override SourceCodeReference : SourceCodeRef with get

Property Value

Type: SourceCodeRef
See Also
SourceRefCommonCodeProcessor Class
SourceRefCommonCodeProcessor Members
NFX.CodeAnalysis Namespace


StringEscapeErrorException Class

StringEscapeErrorException Class NFX Class Library

Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.CodeAnalysis CodeAnalysisException
NFX.CodeAnalysis StringEscapeErrorException

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class StringEscapeErrorException : CodeAnalysisException
public class StringEscapeErrorException : CodeAnalysisException
Public Class StringEscapeErrorException
    Inherits CodeAnalysisException
Public Class StringEscapeErrorException
    Inherits CodeAnalysisException
public ref class StringEscapeErrorException : public CodeAnalysisException
public ref class StringEscapeErrorException : public CodeAnalysisException
type StringEscapeErrorException =
    class
        inherit CodeAnalysisException
    end
type StringEscapeErrorException =
    class
        inherit CodeAnalysisException
    end
See Also
StringEscapeErrorException Members
NFX.CodeAnalysis Namespace


StringEscapeErrorException Members

StringEscapeErrorException Members NFX Class Library

The StringEscapeErrorException type exposes the following members.
Constructors
 | Name | Description
Public method | StringEscapeErrorException | Initializes a new instance of the StringEscapeErrorException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | ErroredEscape |
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
StringEscapeErrorException Class
NFX.CodeAnalysis Namespace


StringEscapeErrorException Constructor

StringEscapeErrorException Constructor NFX Class Library

Initializes a new instance of the StringEscapeErrorException class

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StringEscapeErrorException(
    string escape
)
public StringEscapeErrorException(
    string escape
)
Public Sub New (
    escape As String
)
Public Sub New (
    escape As String
)
public:
StringEscapeErrorException(
    String^ escape
)
public:
StringEscapeErrorException(
    String^ escape
)
new :
        escape : string -> StringEscapeErrorException
new :
        escape : string -> StringEscapeErrorException

Parameters

escape
Type: Online System String
See Also
StringEscapeErrorException Class
StringEscapeErrorException Members
NFX.CodeAnalysis Namespace


StringEscapeErrorException Fields

StringEscapeErrorException Fields NFX Class Library

The StringEscapeErrorException type exposes the following members.
Fields
 | Name | Description
Public field | ErroredEscape |
Back to Top
See Also
StringEscapeErrorException Class
NFX.CodeAnalysis Namespace


StringEscapeErrorException.ErroredEscape Field

StringEscapeErrorException ErroredEscape Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string ErroredEscape
public readonly string ErroredEscape
Public ReadOnly ErroredEscape As String
Public ReadOnly ErroredEscape As String
public:
initonly String^ ErroredEscape
public:
initonly String^ ErroredEscape
val ErroredEscape: string
val ErroredEscape: string

Field Value

Type: Online String
See Also
StringEscapeErrorException Class
StringEscapeErrorException Members
NFX.CodeAnalysis Namespace


StringEscapeErrorException Methods

StringEscapeErrorException Methods NFX Class Library

The StringEscapeErrorException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
StringEscapeErrorException Class
NFX.CodeAnalysis Namespace


StringEscapeErrorException Properties

StringEscapeErrorException Properties NFX Class Library

The StringEscapeErrorException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
StringEscapeErrorException Class
NFX.CodeAnalysis Namespace


StringEscapeErrorException Events

StringEscapeErrorException Events NFX Class Library

The StringEscapeErrorException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
StringEscapeErrorException Class
NFX.CodeAnalysis Namespace


Token Class

Token Class NFX Class Library

Represents a lexical token of the language. This is an abstract class that particular language implementations must extend to define language-specific token types
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis Token
NFX.CodeAnalysis.CSharp CSToken
NFX.CodeAnalysis.JSON JSONToken
NFX.CodeAnalysis.Laconfig LaconfigToken

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Token
public abstract class Token
Public MustInherit Class Token
Public MustInherit Class Token
public ref class Token abstract
public ref class Token abstract
[<AbstractClassAttribute>]
type Token =  class end
[<AbstractClassAttribute>]
type Token =  class end
See Also
Token Members
NFX.CodeAnalysis Namespace


Token Members

Token Members NFX Class Library

The Token type exposes the following members.
Constructors
 | Name | Description
Public method | Token(ILexer, SourcePosition, SourcePosition, String) | Initializes a new instance of the Token class
Public method | Token(ILexer, SourcePosition, SourcePosition, String, Object) | Initializes a new instance of the Token class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | EndPosition |
Public field | Lexer |
Public field | StartPosition |
Public field | Text |
Public field | Value |
Back to Top
Properties
 | Name | Description
Public property | IsBOF | Indicates whether this token indicates an BEGINNING-OF-FILE condition
Public property | IsComment | Indicates whether this token represents a comment
Public property | IsDirective | Indicates whether this token represents a directive
Public property | IsEOF | Indicates whether this token indicates an END-OF-FILE condition
Public property | IsIdentifier | Indicates whether this token represents an identifier
Public property | IsKeyword | Indicates whether this token represents a language keyword
Public property | IsLiteral | Indicates whether this token represents a literal
Public property | IsNonLanguage | This property is needed due to the fact that language lexers may be used to analyze special supersets of regular language grammars i.e. for pattern matches, template parser etc. Code compilers may elect to throw errors when this property is true. Returns true for tokens that are not part of the valid language grammar, however they exist for other reasons, for example - for pattern capture match analysis, or for template processing
Public property | IsNumericLiteral | Indicates whether this token represents a literal, which is a numeric literal (i.e. int, double) This flag is useful for pattern searches that look for particular constant values in numbers (i.e. year = 2000)
Public property | IsOperator | Indicates whether this token represents an operator
Public property | IsPrimary | Returns true for tokens that are primary part of the language, not control, metadata, directive, comment etc... For example BOF,EOF markers are not primary part of the language, compiler directives, comments are not either. This property is useful for pattern searches, when comments and other non-primary tokens need to be quickly skipped
Public property | IsSymbol | Indicates whether this token represents a symbol
Public property | IsTextualLiteral | Indicates whether this token represents a literal, which is a string or a character sequence. This flag is useful for pattern searches that examine comments and strings for sub-patterns
Public property | Kind | Provides language-agnostic classification for token type
Public property | Language | Returns language that this token is a part of
Public property | OrdinalType | Returns token type as a grammar-agnostic ordinal
Back to Top
See Also
Token Class
NFX.CodeAnalysis Namespace


Token Constructor

Token Constructor NFX Class Library

Overload List
 | Name | Description
Public method | Token(ILexer, SourcePosition, SourcePosition, String) | Initializes a new instance of the Token class
Public method | Token(ILexer, SourcePosition, SourcePosition, String, Object) | Initializes a new instance of the Token class
Back to Top
See Also
Token Class
Token Members
NFX.CodeAnalysis Namespace


Token Constructor (ILexer, SourcePosition, SourcePosition, String)

Token Constructor (ILexer, SourcePosition, SourcePosition, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Token class

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Token(
    ILexer lexer,
    SourcePosition startPos,
    SourcePosition endPos,
    string text
)
public Token(
    ILexer lexer,
    SourcePosition startPos,
    SourcePosition endPos,
    string text
)
Public Sub New (
    lexer As ILexer,
    startPos As SourcePosition,
    endPos As SourcePosition,
    text As String
)
Public Sub New (
    lexer As ILexer,
    startPos As SourcePosition,
    endPos As SourcePosition,
    text As String
)
public:
Token(
    ILexer^ lexer,
    SourcePosition startPos,
    SourcePosition endPos,
    String^ text
)
public:
Token(
    ILexer^ lexer,
    SourcePosition startPos,
    SourcePosition endPos,
    String^ text
)
new :
        lexer : ILexer *
        startPos : SourcePosition *
        endPos : SourcePosition *
        text : string -> Token
new :
        lexer : ILexer *
        startPos : SourcePosition *
        endPos : SourcePosition *
        text : string -> Token

Parameters

lexer
Type: NFX.CodeAnalysis ILexer
startPos
Type: NFX.CodeAnalysis.Source SourcePosition
endPos
Type: NFX.CodeAnalysis.Source SourcePosition
text
Type: Online System String
See Also
Token Class
Token Members
Token Overload
NFX.CodeAnalysis Namespace


Token Constructor (ILexer, SourcePosition, SourcePosition, String, Object)

Token Constructor (ILexer, SourcePosition, SourcePosition, String, Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Token class

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Token(
    ILexer lexer,
    SourcePosition startPos,
    SourcePosition endPos,
    string text,
    Object value
)
public Token(
    ILexer lexer,
    SourcePosition startPos,
    SourcePosition endPos,
    string text,
    Object value
)
Public Sub New (
    lexer As ILexer,
    startPos As SourcePosition,
    endPos As SourcePosition,
    text As String,
    value As Object
)
Public Sub New (
    lexer As ILexer,
    startPos As SourcePosition,
    endPos As SourcePosition,
    text As String,
    value As Object
)
public:
Token(
    ILexer^ lexer,
    SourcePosition startPos,
    SourcePosition endPos,
    String^ text,
    Object^ value
)
public:
Token(
    ILexer^ lexer,
    SourcePosition startPos,
    SourcePosition endPos,
    String^ text,
    Object^ value
)
new :
        lexer : ILexer *
        startPos : SourcePosition *
        endPos : SourcePosition *
        text : string *
        value : Object -> Token
new :
        lexer : ILexer *
        startPos : SourcePosition *
        endPos : SourcePosition *
        text : string *
        value : Object -> Token

Parameters

lexer
Type: NFX.CodeAnalysis ILexer
startPos
Type: NFX.CodeAnalysis.Source SourcePosition
endPos
Type: NFX.CodeAnalysis.Source SourcePosition
text
Type: Online System String
value
Type: Online System Object
See Also
Token Class
Token Members
Token Overload
NFX.CodeAnalysis Namespace


Token Fields

Token Fields NFX Class Library

The Token type exposes the following members.
Fields
 | Name | Description
Public field | EndPosition |
Public field | Lexer |
Public field | StartPosition |
Public field | Text |
Public field | Value |
Back to Top
See Also
Token Class
NFX.CodeAnalysis Namespace


Token.EndPosition Field

Token EndPosition Field NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SourcePosition EndPosition
public readonly SourcePosition EndPosition
Public ReadOnly EndPosition As SourcePosition
Public ReadOnly EndPosition As SourcePosition
public:
initonly SourcePosition EndPosition
public:
initonly SourcePosition EndPosition
val EndPosition: SourcePosition
val EndPosition: SourcePosition

Field Value

Type: SourcePosition
See Also
Token Class
Token Members
NFX.CodeAnalysis Namespace


Token.Lexer Field

Token Lexer Field NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ILexer Lexer
public readonly ILexer Lexer
Public ReadOnly Lexer As ILexer
Public ReadOnly Lexer As ILexer
public:
initonly ILexer^ Lexer
public:
initonly ILexer^ Lexer
val Lexer: ILexer
val Lexer: ILexer

Field Value

Type: ILexer
See Also
Token Class
Token Members
NFX.CodeAnalysis Namespace


Token.StartPosition Field

Token StartPosition Field NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SourcePosition StartPosition
public readonly SourcePosition StartPosition
Public ReadOnly StartPosition As SourcePosition
Public ReadOnly StartPosition As SourcePosition
public:
initonly SourcePosition StartPosition
public:
initonly SourcePosition StartPosition
val StartPosition: SourcePosition
val StartPosition: SourcePosition

Field Value

Type: SourcePosition
See Also
Token Class
Token Members
NFX.CodeAnalysis Namespace


Token.Text Field

Token Text Field NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Text
public readonly string Text
Public ReadOnly Text As String
Public ReadOnly Text As String
public:
initonly String^ Text
public:
initonly String^ Text
val Text: string
val Text: string

Field Value

Type: Online String
See Also
Token Class
Token Members
NFX.CodeAnalysis Namespace


Token.Value Field

Token Value Field NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Object Value
public readonly Object Value
Public ReadOnly Value As Object
Public ReadOnly Value As Object
public:
initonly Object^ Value
public:
initonly Object^ Value
val Value: Object
val Value: Object

Field Value

Type: Online Object
See Also
Token Class
Token Members
NFX.CodeAnalysis Namespace


Token Methods

Token Methods NFX Class Library

The Token type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Token Class
NFX.CodeAnalysis Namespace


Token.ToString Method

Token ToString Method NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
Token Class
Token Members
NFX.CodeAnalysis Namespace


Token Properties

Token Properties NFX Class Library

The Token type exposes the following members.
Properties
 | Name | Description
Public property | IsBOF | Indicates whether this token indicates an BEGINNING-OF-FILE condition
Public property | IsComment | Indicates whether this token represents a comment
Public property | IsDirective | Indicates whether this token represents a directive
Public property | IsEOF | Indicates whether this token indicates an END-OF-FILE condition
Public property | IsIdentifier | Indicates whether this token represents an identifier
Public property | IsKeyword | Indicates whether this token represents a language keyword
Public property | IsLiteral | Indicates whether this token represents a literal
Public property | IsNonLanguage | This property is needed due to the fact that language lexers may be used to analyze special supersets of regular language grammars i.e. for pattern matches, template parser etc. Code compilers may elect to throw errors when this property is true. Returns true for tokens that are not part of the valid language grammar, however they exist for other reasons, for example - for pattern capture match analysis, or for template processing
Public property | IsNumericLiteral | Indicates whether this token represents a literal, which is a numeric literal (i.e. int, double) This flag is useful for pattern searches that look for particular constant values in numbers (i.e. year = 2000)
Public property | IsOperator | Indicates whether this token represents an operator
Public property | IsPrimary | Returns true for tokens that are primary part of the language, not control, metadata, directive, comment etc... For example BOF,EOF markers are not primary part of the language, compiler directives, comments are not either. This property is useful for pattern searches, when comments and other non-primary tokens need to be quickly skipped
Public property | IsSymbol | Indicates whether this token represents a symbol
Public property | IsTextualLiteral | Indicates whether this token represents a literal, which is a string or a character sequence. This flag is useful for pattern searches that examine comments and strings for sub-patterns
Public property | Kind | Provides language-agnostic classification for token type
Public property | Language | Returns language that this token is a part of
Public property | OrdinalType | Returns token type as a grammar-agnostic ordinal
Back to Top
See Also
Token Class
NFX.CodeAnalysis Namespace


Token.IsBOF Property

Token IsBOF Property NFX Class Library

Indicates whether this token indicates an BEGINNING-OF-FILE condition

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsBOF { get; }
public bool IsBOF { get; }
Public ReadOnly Property IsBOF As Boolean
    Get
Public ReadOnly Property IsBOF As Boolean
    Get
public:
property bool IsBOF {
    bool get ();
}
public:
property bool IsBOF {
    bool get ();
}
member IsBOF : bool with get
member IsBOF : bool with get

Property Value

Type: Online Boolean
See Also
Token Class
Token Members
NFX.CodeAnalysis Namespace


Token.IsComment Property

Token IsComment Property NFX Class Library

Indicates whether this token represents a comment

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsComment { get; }
public bool IsComment { get; }
Public ReadOnly Property IsComment As Boolean
    Get
Public ReadOnly Property IsComment As Boolean
    Get
public:
property bool IsComment {
    bool get ();
}
public:
property bool IsComment {
    bool get ();
}
member IsComment : bool with get
member IsComment : bool with get

Property Value

Type: Online Boolean
See Also
Token Class
Token Members
NFX.CodeAnalysis Namespace


Token.IsDirective Property

Token IsDirective Property NFX Class Library

Indicates whether this token represents a directive

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsDirective { get; }
public bool IsDirective { get; }
Public ReadOnly Property IsDirective As Boolean
    Get
Public ReadOnly Property IsDirective As Boolean
    Get
public:
property bool IsDirective {
    bool get ();
}
public:
property bool IsDirective {
    bool get ();
}
member IsDirective : bool with get
member IsDirective : bool with get

Property Value

Type: Online Boolean
See Also
Token Class
Token Members
NFX.CodeAnalysis Namespace


Token.IsEOF Property

Token IsEOF Property NFX Class Library

Indicates whether this token indicates an END-OF-FILE condition

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEOF { get; }
public bool IsEOF { get; }
Public ReadOnly Property IsEOF As Boolean
    Get
Public ReadOnly Property IsEOF As Boolean
    Get
public:
property bool IsEOF {
    bool get ();
}
public:
property bool IsEOF {
    bool get ();
}
member IsEOF : bool with get
member IsEOF : bool with get

Property Value

Type: Online Boolean
See Also
Token Class
Token Members
NFX.CodeAnalysis Namespace


Token.IsIdentifier Property

Token IsIdentifier Property NFX Class Library

Indicates whether this token represents an identifier

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsIdentifier { get; }
public bool IsIdentifier { get; }
Public ReadOnly Property IsIdentifier As Boolean
    Get
Public ReadOnly Property IsIdentifier As Boolean
    Get
public:
property bool IsIdentifier {
    bool get ();
}
public:
property bool IsIdentifier {
    bool get ();
}
member IsIdentifier : bool with get
member IsIdentifier : bool with get

Property Value

Type: Online Boolean
See Also
Token Class
Token Members
NFX.CodeAnalysis Namespace


Token.IsKeyword Property

Token IsKeyword Property NFX Class Library

Indicates whether this token represents a language keyword

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsKeyword { get; }
public bool IsKeyword { get; }
Public ReadOnly Property IsKeyword As Boolean
    Get
Public ReadOnly Property IsKeyword As Boolean
    Get
public:
property bool IsKeyword {
    bool get ();
}
public:
property bool IsKeyword {
    bool get ();
}
member IsKeyword : bool with get
member IsKeyword : bool with get

Property Value

Type: Online Boolean
See Also
Token Class
Token Members
NFX.CodeAnalysis Namespace


Token.IsLiteral Property

Token IsLiteral Property NFX Class Library

Indicates whether this token represents a literal

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsLiteral { get; }
public bool IsLiteral { get; }
Public ReadOnly Property IsLiteral As Boolean
    Get
Public ReadOnly Property IsLiteral As Boolean
    Get
public:
property bool IsLiteral {
    bool get ();
}
public:
property bool IsLiteral {
    bool get ();
}
member IsLiteral : bool with get
member IsLiteral : bool with get

Property Value

Type: Online Boolean
See Also
Token Class
Token Members
NFX.CodeAnalysis Namespace


Token.IsNonLanguage Property

Token IsNonLanguage Property NFX Class Library

This property is needed due to the fact that language lexers may be used to analyze special supersets of regular language grammars i.e. for pattern matches, template parser etc. Code compilers may elect to throw errors when this property is true. Returns true for tokens that are not part of the valid language grammar, however they exist for other reasons, for example - for pattern capture match analysis, or for template processing

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool IsNonLanguage { get; }
public abstract bool IsNonLanguage { get; }
Public MustOverride ReadOnly Property IsNonLanguage As Boolean
    Get
Public MustOverride ReadOnly Property IsNonLanguage As Boolean
    Get
public:
virtual property bool IsNonLanguage {
    bool get () abstract;
}
public:
virtual property bool IsNonLanguage {
    bool get () abstract;
}
abstract IsNonLanguage : bool with get
abstract IsNonLanguage : bool with get

Property Value

Type: Online Boolean
See Also
Token Class
Token Members
NFX.CodeAnalysis Namespace


Token.IsNumericLiteral Property

Token IsNumericLiteral Property NFX Class Library

Indicates whether this token represents a literal, which is a numeric literal (i.e. int, double) This flag is useful for pattern searches that look for particular constant values in numbers (i.e. year = 2000)

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool IsNumericLiteral { get; }
public abstract bool IsNumericLiteral { get; }
Public MustOverride ReadOnly Property IsNumericLiteral As Boolean
    Get
Public MustOverride ReadOnly Property IsNumericLiteral As Boolean
    Get
public:
virtual property bool IsNumericLiteral {
    bool get () abstract;
}
public:
virtual property bool IsNumericLiteral {
    bool get () abstract;
}
abstract IsNumericLiteral : bool with get
abstract IsNumericLiteral : bool with get

Property Value

Type: Online Boolean
See Also
Token Class
Token Members
NFX.CodeAnalysis Namespace


Token.IsOperator Property

Token IsOperator Property NFX Class Library

Indicates whether this token represents an operator

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsOperator { get; }
public bool IsOperator { get; }
Public ReadOnly Property IsOperator As Boolean
    Get
Public ReadOnly Property IsOperator As Boolean
    Get
public:
property bool IsOperator {
    bool get ();
}
public:
property bool IsOperator {
    bool get ();
}
member IsOperator : bool with get
member IsOperator : bool with get

Property Value

Type: Online Boolean
See Also
Token Class
Token Members
NFX.CodeAnalysis Namespace


Token.IsPrimary Property

Token IsPrimary Property NFX Class Library

Returns true for tokens that are primary part of the language, not control, metadata, directive, comment etc... For example BOF,EOF markers are not primary part of the language, compiler directives, comments are not either. This property is useful for pattern searches, when comments and other non-primary tokens need to be quickly skipped

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool IsPrimary { get; }
public abstract bool IsPrimary { get; }
Public MustOverride ReadOnly Property IsPrimary As Boolean
    Get
Public MustOverride ReadOnly Property IsPrimary As Boolean
    Get
public:
virtual property bool IsPrimary {
    bool get () abstract;
}
public:
virtual property bool IsPrimary {
    bool get () abstract;
}
abstract IsPrimary : bool with get
abstract IsPrimary : bool with get

Property Value

Type: Online Boolean
See Also
Token Class
Token Members
NFX.CodeAnalysis Namespace


Token.IsSymbol Property

Token IsSymbol Property NFX Class Library

Indicates whether this token represents a symbol

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsSymbol { get; }
public bool IsSymbol { get; }
Public ReadOnly Property IsSymbol As Boolean
    Get
Public ReadOnly Property IsSymbol As Boolean
    Get
public:
property bool IsSymbol {
    bool get ();
}
public:
property bool IsSymbol {
    bool get ();
}
member IsSymbol : bool with get
member IsSymbol : bool with get

Property Value

Type: Online Boolean
See Also
Token Class
Token Members
NFX.CodeAnalysis Namespace


Token.IsTextualLiteral Property

Token IsTextualLiteral Property NFX Class Library

Indicates whether this token represents a literal, which is a string or a character sequence. This flag is useful for pattern searches that examine comments and strings for sub-patterns

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool IsTextualLiteral { get; }
public abstract bool IsTextualLiteral { get; }
Public MustOverride ReadOnly Property IsTextualLiteral As Boolean
    Get
Public MustOverride ReadOnly Property IsTextualLiteral As Boolean
    Get
public:
virtual property bool IsTextualLiteral {
    bool get () abstract;
}
public:
virtual property bool IsTextualLiteral {
    bool get () abstract;
}
abstract IsTextualLiteral : bool with get
abstract IsTextualLiteral : bool with get

Property Value

Type: Online Boolean
See Also
Token Class
Token Members
NFX.CodeAnalysis Namespace


Token.Kind Property

Token Kind Property NFX Class Library

Provides language-agnostic classification for token type

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract TokenKind Kind { get; }
public abstract TokenKind Kind { get; }
Public MustOverride ReadOnly Property Kind As TokenKind
    Get
Public MustOverride ReadOnly Property Kind As TokenKind
    Get
public:
virtual property TokenKind Kind {
    TokenKind get () abstract;
}
public:
virtual property TokenKind Kind {
    TokenKind get () abstract;
}
abstract Kind : TokenKind with get
abstract Kind : TokenKind with get

Property Value

Type: TokenKind
See Also
Token Class
Token Members
NFX.CodeAnalysis Namespace


Token.Language Property

Token Language Property NFX Class Library

Returns language that this token is a part of

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Language Language { get; }
public abstract Language Language { get; }
Public MustOverride ReadOnly Property Language As Language
    Get
Public MustOverride ReadOnly Property Language As Language
    Get
public:
virtual property Language^ Language {
    Language^ get () abstract;
}
public:
virtual property Language^ Language {
    Language^ get () abstract;
}
abstract Language : Language with get
abstract Language : Language with get

Property Value

Type: Language
See Also
Token Class
Token Members
NFX.CodeAnalysis Namespace


Token.OrdinalType Property

Token OrdinalType Property NFX Class Library

Returns token type as a grammar-agnostic ordinal

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int OrdinalType { get; }
public abstract int OrdinalType { get; }
Public MustOverride ReadOnly Property OrdinalType As Integer
    Get
Public MustOverride ReadOnly Property OrdinalType As Integer
    Get
public:
virtual property int OrdinalType {
    int get () abstract;
}
public:
virtual property int OrdinalType {
    int get () abstract;
}
abstract OrdinalType : int with get
abstract OrdinalType : int with get

Property Value

Type: Online Int32
See Also
Token Class
Token Members
NFX.CodeAnalysis Namespace


Tokenized(TToken) Class

Tokenized TToken Class NFX Class Library

Provides read-only view over TokenList
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis Tokenized TToken

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Tokenized<TToken> : IEnumerable<TToken>,
    IEnumerable
where TToken : Token
public class Tokenized<TToken> : IEnumerable<TToken>,
    IEnumerable
where TToken : Token
Public Class Tokenized(Of TToken As Token)
    Implements IEnumerable(Of TToken), IEnumerable
Public Class Tokenized(Of TToken As Token)
    Implements IEnumerable(Of TToken), IEnumerable
generic<typename TToken>
where TToken : Token
public ref class Tokenized : IEnumerable<TToken>,
    IEnumerable
generic<typename TToken>
where TToken : Token
public ref class Tokenized : IEnumerable<TToken>,
    IEnumerable
type Tokenized<'TToken when 'TToken : Token> =
    class
        interface IEnumerable<'TToken>
        interface IEnumerable
    end
type Tokenized<'TToken when 'TToken : Token> =
    class
        interface IEnumerable<'TToken>
        interface IEnumerable
    end
Type Parameters
TToken
See Also
Tokenized TToken Members
NFX.CodeAnalysis Namespace


Tokenized(TToken) Members

Tokenized TToken Members NFX Class Library

The Tokenized TToken type exposes the following members.
Constructors
 | Name | Description
Public method | Tokenized TToken | Initializes a new instance of the Tokenized TToken class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable TToken | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct TToken, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax TToken, TComparand (Func TToken, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax TToken, TComparand (Func TToken, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin TToken, TComparand (Func TToken, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin TToken, TComparand (Func TToken, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault TToken | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach TToken (Action TToken ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach TToken (Action TToken, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | LazyFSM TToken ( LazyFSMPredicate TToken ) | Overloaded. Makes finite state machine fed from IEnumerable(Token) only considering primary language tokens (Defined by PatternSearch.)
Public Extension Method | LazyFSM TToken (Boolean, LazyFSMPredicate TToken ) | Overloaded. Makes finite state machine fed from IEnumerable(Token) (Defined by PatternSearch.)
Public Extension Method | LazyFSM TToken (Boolean, LazyFSMState TToken , LazyFSMPredicate TToken ) | Overloaded. Makes finite state machine fed from IEnumerable(Token) (Defined by PatternSearch.)
Public Extension Method | SkipLast TToken | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast TToken (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Count |
Public property | Item |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
Tokenized TToken Class
NFX.CodeAnalysis Namespace


Tokenized(TToken) Constructor

Tokenized TToken Constructor NFX Class Library

Initializes a new instance of the Tokenized TToken class

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Tokenized(
    TokenList<TToken> list
)
public Tokenized(
    TokenList<TToken> list
)
Public Sub New (
    list As TokenList(Of TToken)
)
Public Sub New (
    list As TokenList(Of TToken)
)
public:
Tokenized(
    TokenList<TToken>^ list
)
public:
Tokenized(
    TokenList<TToken>^ list
)
new :
        list : TokenList<'TToken> -> Tokenized
new :
        list : TokenList<'TToken> -> Tokenized

Parameters

list
Type: NFX.CodeAnalysis TokenList TToken
See Also
Tokenized TToken Class
Tokenized TToken Members
NFX.CodeAnalysis Namespace


Tokenized(TToken) Methods

Tokenized TToken Methods NFX Class Library

The Tokenized TToken type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable TToken | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct TToken, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax TToken, TComparand (Func TToken, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax TToken, TComparand (Func TToken, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin TToken, TComparand (Func TToken, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin TToken, TComparand (Func TToken, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault TToken | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach TToken (Action TToken ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach TToken (Action TToken, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | LazyFSM TToken ( LazyFSMPredicate TToken ) | Overloaded. Makes finite state machine fed from IEnumerable(Token) only considering primary language tokens (Defined by PatternSearch.)
Public Extension Method | LazyFSM TToken (Boolean, LazyFSMPredicate TToken ) | Overloaded. Makes finite state machine fed from IEnumerable(Token) (Defined by PatternSearch.)
Public Extension Method | LazyFSM TToken (Boolean, LazyFSMState TToken , LazyFSMPredicate TToken ) | Overloaded. Makes finite state machine fed from IEnumerable(Token) (Defined by PatternSearch.)
Public Extension Method | SkipLast TToken | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast TToken (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
Tokenized TToken Class
NFX.CodeAnalysis Namespace


Tokenized(TToken).IEnumerable.GetEnumerator Method

Tokenized TToken IEnumerable GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
Tokenized TToken Class
Tokenized TToken Members
NFX.CodeAnalysis Namespace


Tokenized(TToken).GetEnumerator Method

Tokenized TToken GetEnumerator Method NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<TToken> GetEnumerator()
public IEnumerator<TToken> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of TToken)
Public Function GetEnumerator As IEnumerator(Of TToken)
public:
virtual IEnumerator<TToken>^ GetEnumerator() sealed
public:
virtual IEnumerator<TToken>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<'TToken>
override GetEnumerator : unit -> IEnumerator<'TToken>
abstract GetEnumerator : unit -> IEnumerator<'TToken>
override GetEnumerator : unit -> IEnumerator<'TToken>

Return Value

Type: Online IEnumerator TToken

Implements

Online IEnumerable T GetEnumerator
See Also
Tokenized TToken Class
Tokenized TToken Members
NFX.CodeAnalysis Namespace


Tokenized(TToken).ToString Method

Tokenized TToken ToString Method NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
Tokenized TToken Class
Tokenized TToken Members
NFX.CodeAnalysis Namespace


Tokenized(TToken) Properties

Tokenized TToken Properties NFX Class Library

The Tokenized TToken type exposes the following members.
Properties
 | Name | Description
Public property | Count |
Public property | Item |
Back to Top
See Also
Tokenized TToken Class
NFX.CodeAnalysis Namespace


Tokenized(TToken).Count Property

Tokenized TToken Count Property NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
public:
property int Count {
    int get ();
}
member Count : int with get
member Count : int with get

Property Value

Type: Online Int32
See Also
Tokenized TToken Class
Tokenized TToken Members
NFX.CodeAnalysis Namespace


Tokenized(TToken).Item Property

Tokenized TToken Item Property NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TToken this[
    int idx
] { get; }
public TToken this[
    int idx
] { get; }
Public ReadOnly Default Property Item (
    idx As Integer
) As TToken
    Get
Public ReadOnly Default Property Item (
    idx As Integer
) As TToken
    Get
public:
property TToken default[int idx] {
    TToken get (int idx);
}
public:
property TToken default[int idx] {
    TToken get (int idx);
}
member Item : 'TToken with get
member Item : 'TToken with get

Parameters

idx
Type: Online System Int32

Property Value

Type: TToken
See Also
Tokenized TToken Class
Tokenized TToken Members
NFX.CodeAnalysis Namespace


TokenKind Enumeration

TokenKind Enumeration NFX Class Library

Provides language-agnostic token classification

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum TokenKind
public enum TokenKind
Public Enumeration TokenKind
Public Enumeration TokenKind
public enum class TokenKind
public enum class TokenKind
type TokenKind
type TokenKind
Members
Member name | Value | Description
Other | 0 |
BOF | 1 |
EOF | 2 |
Directive | 3 |
Comment | 4 |
Literal | 5 |
Identifier | 6 |
Keyword | 7 |
Operator | 8 |
Symbol | 9 |
See Also
NFX.CodeAnalysis Namespace


TokenList(TToken) Class

TokenList TToken Class NFX Class Library

A list of tokens
Inheritance Hierarchy
Online System Object
Online System.Collections.Generic List TToken
NFX.CodeAnalysis TokenList TToken

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TokenList<TToken> : List<TToken>
where TToken : Token
public class TokenList<TToken> : List<TToken>
where TToken : Token
Public Class TokenList(Of TToken As Token)
    Inherits List(Of TToken)
Public Class TokenList(Of TToken As Token)
    Inherits List(Of TToken)
generic<typename TToken>
where TToken : Token
public ref class TokenList : public List<TToken>
generic<typename TToken>
where TToken : Token
public ref class TokenList : public List<TToken>
type TokenList<'TToken when 'TToken : Token> =
    class
        inherit List<'TToken>
    end
type TokenList<'TToken when 'TToken : Token> =
    class
        inherit List<'TToken>
    end
Type Parameters
TToken
See Also
TokenList TToken Members
NFX.CodeAnalysis Namespace


TokenList(TToken) Members

TokenList TToken Members NFX Class Library

The TokenList TToken type exposes the following members.
Constructors
 | Name | Description
Public method | TokenList TToken | Initializes a new instance of the TokenList TToken class
Public method | TokenList TToken (IEnumerable TToken ) | Initializes a new instance of the TokenList TToken class
Back to Top
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List TToken .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List TToken .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List TToken .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List TToken .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List TToken .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List TToken .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List TToken .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List TToken .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List TToken .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List TToken .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List TToken .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List TToken .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List TToken .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List TToken .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List TToken .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List TToken .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List TToken .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List TToken .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List TToken .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List TToken .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List TToken .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List TToken .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List TToken .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List TToken .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List TToken .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List TToken .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List TToken .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List TToken .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List TToken .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List TToken .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List TToken .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List TToken .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List TToken .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List TToken .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List TToken .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List TToken .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List TToken .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List TToken .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List TToken .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List TToken .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List TToken .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List TToken .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List TToken .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List TToken .)
Public method | ToString | (Overrides Online Object ToString .)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List TToken .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List TToken .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List TToken .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List TToken .)
Public property | Item |
Back to Top
See Also
TokenList TToken Class
NFX.CodeAnalysis Namespace


TokenList(TToken) Constructor

TokenList TToken Constructor NFX Class Library

Overload List
 | Name | Description
Public method | TokenList TToken | Initializes a new instance of the TokenList TToken class
Public method | TokenList TToken (IEnumerable TToken ) | Initializes a new instance of the TokenList TToken class
Back to Top
See Also
TokenList TToken Class
TokenList TToken Members
NFX.CodeAnalysis Namespace


TokenList(TToken) Constructor

TokenList TToken Constructor NFX Class Library

Initializes a new instance of the TokenList TToken class

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TokenList()
public TokenList()
Public Sub New
Public Sub New
public:
TokenList()
public:
TokenList()
new : unit -> TokenList
new : unit -> TokenList
See Also
TokenList TToken Class
TokenList TToken Members
TokenList TToken Overload
NFX.CodeAnalysis Namespace


TokenList(TToken) Constructor (IEnumerable(TToken))

TokenList TToken Constructor (IEnumerable TToken ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TokenList TToken class

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TokenList(
    IEnumerable<TToken> other
)
public TokenList(
    IEnumerable<TToken> other
)
Public Sub New (
    other As IEnumerable(Of TToken)
)
Public Sub New (
    other As IEnumerable(Of TToken)
)
public:
TokenList(
    IEnumerable<TToken>^ other
)
public:
TokenList(
    IEnumerable<TToken>^ other
)
new :
        other : IEnumerable<'TToken> -> TokenList
new :
        other : IEnumerable<'TToken> -> TokenList

Parameters

other
Type: Online System.Collections.Generic IEnumerable TToken
See Also
TokenList TToken Class
TokenList TToken Members
TokenList TToken Overload
NFX.CodeAnalysis Namespace


TokenList(TToken) Methods

TokenList TToken Methods NFX Class Library

The TokenList TToken type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List TToken .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List TToken .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List TToken .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List TToken .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List TToken .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List TToken .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List TToken .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List TToken .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List TToken .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List TToken .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List TToken .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List TToken .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List TToken .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List TToken .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List TToken .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List TToken .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List TToken .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List TToken .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List TToken .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List TToken .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List TToken .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List TToken .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List TToken .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List TToken .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List TToken .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List TToken .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List TToken .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List TToken .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List TToken .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List TToken .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List TToken .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List TToken .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List TToken .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List TToken .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List TToken .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List TToken .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List TToken .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List TToken .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List TToken .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List TToken .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List TToken .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List TToken .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List TToken .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List TToken .)
Public method | ToString | (Overrides Online Object ToString .)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List TToken .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List TToken .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TokenList TToken Class
NFX.CodeAnalysis Namespace


TokenList(TToken).ToString Method

TokenList TToken ToString Method NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
TokenList TToken Class
TokenList TToken Members
NFX.CodeAnalysis Namespace


TokenList(TToken) Properties

TokenList TToken Properties NFX Class Library

The TokenList TToken type exposes the following members.
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List TToken .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List TToken .)
Public property | Item |
Back to Top
See Also
TokenList TToken Class
NFX.CodeAnalysis Namespace


TokenList(TToken).Item Property

TokenList TToken Item Property NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TToken this[
    int idx
] { get; }
public TToken this[
    int idx
] { get; }
Public ReadOnly Default Property Item (
    idx As Integer
) As TToken
    Get
Public ReadOnly Default Property Item (
    idx As Integer
) As TToken
    Get
public:
property TToken default[int idx] {
    TToken get (int idx);
}
public:
property TToken default[int idx] {
    TToken get (int idx);
}
member Item : 'TToken with get
member Item : 'TToken with get

Parameters

idx
Type: Online System Int32

Property Value

Type: TToken
See Also
TokenList TToken Class
TokenList TToken Members
NFX.CodeAnalysis Namespace


UnspecifiedLanguage Class

UnspecifiedLanguage Class NFX Class Library

Represents Unspecified unknown language
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis Language
NFX.CodeAnalysis UnspecifiedLanguage

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class UnspecifiedLanguage : Language
public sealed class UnspecifiedLanguage : Language
Public NotInheritable Class UnspecifiedLanguage
    Inherits Language
Public NotInheritable Class UnspecifiedLanguage
    Inherits Language
public ref class UnspecifiedLanguage sealed : public Language
public ref class UnspecifiedLanguage sealed : public Language
[<SealedAttribute>]
type UnspecifiedLanguage =
    class
        inherit Language
    end
[<SealedAttribute>]
type UnspecifiedLanguage =
    class
        inherit Language
    end
See Also
UnspecifiedLanguage Members
NFX.CodeAnalysis Namespace


UnspecifiedLanguage Members

UnspecifiedLanguage Members NFX Class Library

The UnspecifiedLanguage type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeLexer | (Overrides Language MakeLexer(IAnalysisContext, SourceCodeRef, ISourceText, MessageList, Boolean).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from Language.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
Instance |
Back to Top
Properties
 | Name | Description
Public property | Family | (Overrides Language Family.)
Public property | FileExtensions | (Overrides Language FileExtensions.)
Back to Top
See Also
UnspecifiedLanguage Class
NFX.CodeAnalysis Namespace


UnspecifiedLanguage Fields

UnspecifiedLanguage Fields NFX Class Library

The UnspecifiedLanguage type exposes the following members.
Fields
Name | Description
Instance |
Back to Top
See Also
UnspecifiedLanguage Class
NFX.CodeAnalysis Namespace


UnspecifiedLanguage.Instance Field

UnspecifiedLanguage Instance Field NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly UnspecifiedLanguage Instance
public static readonly UnspecifiedLanguage Instance
Public Shared ReadOnly Instance As UnspecifiedLanguage
Public Shared ReadOnly Instance As UnspecifiedLanguage
public:
static initonly UnspecifiedLanguage^ Instance
public:
static initonly UnspecifiedLanguage^ Instance
static val Instance: UnspecifiedLanguage
static val Instance: UnspecifiedLanguage

Field Value

Type: UnspecifiedLanguage
See Also
UnspecifiedLanguage Class
UnspecifiedLanguage Members
NFX.CodeAnalysis Namespace


UnspecifiedLanguage Methods

UnspecifiedLanguage Methods NFX Class Library

The UnspecifiedLanguage type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeLexer | (Overrides Language MakeLexer(IAnalysisContext, SourceCodeRef, ISourceText, MessageList, Boolean).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from Language.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
UnspecifiedLanguage Class
NFX.CodeAnalysis Namespace


UnspecifiedLanguage.MakeLexer Method

UnspecifiedLanguage MakeLexer Method NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ILexer MakeLexer(
    IAnalysisContext context,
    SourceCodeRef srcRef,
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
public override ILexer MakeLexer(
    IAnalysisContext context,
    SourceCodeRef srcRef,
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
Public Overrides Function MakeLexer (
    context As IAnalysisContext,
    srcRef As SourceCodeRef,
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
) As ILexer
Public Overrides Function MakeLexer (
    context As IAnalysisContext,
    srcRef As SourceCodeRef,
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
) As ILexer
public:
virtual ILexer^ MakeLexer(
    IAnalysisContext^ context,
    SourceCodeRef srcRef,
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
) override
public:
virtual ILexer^ MakeLexer(
    IAnalysisContext^ context,
    SourceCodeRef srcRef,
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
) override
abstract MakeLexer :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> ILexer
override MakeLexer :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> ILexer
abstract MakeLexer :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> ILexer
override MakeLexer :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> ILexer

Parameters

context
Type: NFX.CodeAnalysis IAnalysisContext
srcRef
Type: NFX.CodeAnalysis.Source SourceCodeRef
source
Type: NFX.CodeAnalysis.Source ISourceText
messages (Optional)
Type: NFX.CodeAnalysis MessageList
throwErrors (Optional)
Type: Online System Boolean

Return Value

Type: ILexer
See Also
UnspecifiedLanguage Class
UnspecifiedLanguage Members
NFX.CodeAnalysis Namespace


UnspecifiedLanguage Properties

UnspecifiedLanguage Properties NFX Class Library

The UnspecifiedLanguage type exposes the following members.
Properties
 | Name | Description
Public property | Family | (Overrides Language Family.)
Public property | FileExtensions | (Overrides Language FileExtensions.)
Back to Top
See Also
UnspecifiedLanguage Class
NFX.CodeAnalysis Namespace


UnspecifiedLanguage.Family Property

UnspecifiedLanguage Family Property NFX Class Library

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override LanguageFamily Family { get; }
public override LanguageFamily Family { get; }
Public Overrides ReadOnly Property Family As LanguageFamily
    Get
Public Overrides ReadOnly Property Family As LanguageFamily
    Get
public:
virtual property LanguageFamily Family {
    LanguageFamily get () override;
}
public:
virtual property LanguageFamily Family {
    LanguageFamily get () override;
}
abstract Family : LanguageFamily with get
override Family : LanguageFamily with get
abstract Family : LanguageFamily with get
override Family : LanguageFamily with get

Property Value

Type: LanguageFamily
See Also
UnspecifiedLanguage Class
UnspecifiedLanguage Members
NFX.CodeAnalysis Namespace


UnspecifiedLanguage.FileExtensions Property

UnspecifiedLanguage FileExtensions Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.CodeAnalysis
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IEnumerable<string> FileExtensions { get; }
public override IEnumerable<string> FileExtensions { get; }
Public Overrides ReadOnly Property FileExtensions As IEnumerable(Of String)
    Get
Public Overrides ReadOnly Property FileExtensions As IEnumerable(Of String)
    Get
public:
virtual property IEnumerable<String^>^ FileExtensions {
    IEnumerable<String^>^ get () override;
}
public:
virtual property IEnumerable<String^>^ FileExtensions {
    IEnumerable<String^>^ get () override;
}
abstract FileExtensions : IEnumerable<string> with get
override FileExtensions : IEnumerable<string> with get
abstract FileExtensions : IEnumerable<string> with get
override FileExtensions : IEnumerable<string> with get

Property Value

Type: Online IEnumerable Online String
See Also
UnspecifiedLanguage Class
UnspecifiedLanguage Members
NFX.CodeAnalysis Namespace


NFX.CodeAnalysis.CSharp Namespace

NFX.CodeAnalysis.CSharp Namespace NFX Class Library

Provides functions for working with C# syntax
Classes
 | Class | Description
Public class | CSIdentifiers | Identifier validation in a context of C# grammar
Public class | CSKeywords | Provides C# keyword resolution services, this class is thread safe
Public class | CSLanguage | Represents C# language
Public class | CSLexer | Performs lexical analysis on source supplied in C# syntax. This class supports lazy analysis that happens gradually as result tokens are consumed through IEnumerable interface.
Public class | CSNumbers | Provides C# number parsing
Public class | CSStrings | Provides C# string escape parsing
Public class | CSToken | Represents a C# token
Enumerations
 | Enumeration | Description
Public enumeration | CSMsgCode | Message codes for CSharp code processors
Public enumeration | CSTokenType | Denotes CSharp token types


CSIdentifiers Class

CSIdentifiers Class NFX Class Library

Identifier validation in a context of C# grammar
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis.CSharp CSIdentifiers

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class CSIdentifiers
public static class CSIdentifiers
Public NotInheritable Class CSIdentifiers
Public NotInheritable Class CSIdentifiers
public ref class CSIdentifiers abstract sealed
public ref class CSIdentifiers abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CSIdentifiers =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CSIdentifiers =  class end
See Also
CSIdentifiers Members
NFX.CodeAnalysis.CSharp Namespace


CSIdentifiers Members

CSIdentifiers Members NFX Class Library

The CSIdentifiers type exposes the following members.
Methods
Name | Description
Validate | Checks whether supplied string is a valid C# ident
ValidateChar | Checks whether supplied char is suitable for a part of C# id
ValidateDigit | Checks to see whether supplied char is a digit
Back to Top
See Also
CSIdentifiers Class
NFX.CodeAnalysis.CSharp Namespace


CSIdentifiers Methods

CSIdentifiers Methods NFX Class Library

The CSIdentifiers type exposes the following members.
Methods
Name | Description
Validate | Checks whether supplied string is a valid C# ident
ValidateChar | Checks whether supplied char is suitable for a part of C# id
ValidateDigit | Checks to see whether supplied char is a digit
Back to Top
See Also
CSIdentifiers Class
NFX.CodeAnalysis.CSharp Namespace


CSIdentifiers.Validate Method

CSIdentifiers Validate Method NFX Class Library

Checks whether supplied string is a valid C# ident

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool Validate(
    string id
)
public static bool Validate(
    string id
)
Public Shared Function Validate (
    id As String
) As Boolean
Public Shared Function Validate (
    id As String
) As Boolean
public:
static bool Validate(
    String^ id
)
public:
static bool Validate(
    String^ id
)
static member Validate :
        id : string -> bool
static member Validate :
        id : string -> bool

Parameters

id
Type: Online System String

Return Value

Type: Online Boolean
See Also
CSIdentifiers Class
CSIdentifiers Members
NFX.CodeAnalysis.CSharp Namespace


CSIdentifiers.ValidateChar Method

CSIdentifiers ValidateChar Method NFX Class Library

Checks whether supplied char is suitable for a part of C# id

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool ValidateChar(
    char c
)
public static bool ValidateChar(
    char c
)
Public Shared Function ValidateChar (
    c As Char
) As Boolean
Public Shared Function ValidateChar (
    c As Char
) As Boolean
public:
static bool ValidateChar(
    wchar_t c
)
public:
static bool ValidateChar(
    wchar_t c
)
static member ValidateChar :
        c : char -> bool
static member ValidateChar :
        c : char -> bool

Parameters

c
Type: Online System Char

Return Value

Type: Online Boolean
See Also
CSIdentifiers Class
CSIdentifiers Members
NFX.CodeAnalysis.CSharp Namespace


CSIdentifiers.ValidateDigit Method

CSIdentifiers ValidateDigit Method NFX Class Library

Checks to see whether supplied char is a digit

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool ValidateDigit(
    char c
)
public static bool ValidateDigit(
    char c
)
Public Shared Function ValidateDigit (
    c As Char
) As Boolean
Public Shared Function ValidateDigit (
    c As Char
) As Boolean
public:
static bool ValidateDigit(
    wchar_t c
)
public:
static bool ValidateDigit(
    wchar_t c
)
static member ValidateDigit :
        c : char -> bool
static member ValidateDigit :
        c : char -> bool

Parameters

c
Type: Online System Char

Return Value

Type: Online Boolean
See Also
CSIdentifiers Class
CSIdentifiers Members
NFX.CodeAnalysis.CSharp Namespace


CSKeywords Class

CSKeywords Class NFX Class Library

Provides C# keyword resolution services, this class is thread safe
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis.CSharp CSKeywords

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class CSKeywords
public static class CSKeywords
Public NotInheritable Class CSKeywords
Public NotInheritable Class CSKeywords
public ref class CSKeywords abstract sealed
public ref class CSKeywords abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CSKeywords =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CSKeywords =  class end
See Also
CSKeywords Members
NFX.CodeAnalysis.CSharp Namespace


CSKeywords Members

CSKeywords Members NFX Class Library

The CSKeywords type exposes the following members.
Methods
Name | Description
Resolve | Resolves a C# keyword - this method IS thread safe
Back to Top
See Also
CSKeywords Class
NFX.CodeAnalysis.CSharp Namespace


CSKeywords Methods

CSKeywords Methods NFX Class Library

The CSKeywords type exposes the following members.
Methods
Name | Description
Resolve | Resolves a C# keyword - this method IS thread safe
Back to Top
See Also
CSKeywords Class
NFX.CodeAnalysis.CSharp Namespace


CSKeywords.Resolve Method

CSKeywords Resolve Method NFX Class Library

Resolves a C# keyword - this method IS thread safe

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static CSTokenType Resolve(
    string str
)
public static CSTokenType Resolve(
    string str
)
Public Shared Function Resolve (
    str As String
) As CSTokenType
Public Shared Function Resolve (
    str As String
) As CSTokenType
public:
static CSTokenType Resolve(
    String^ str
)
public:
static CSTokenType Resolve(
    String^ str
)
static member Resolve :
        str : string -> CSTokenType
static member Resolve :
        str : string -> CSTokenType

Parameters

str
Type: Online System String

Return Value

Type: CSTokenType
See Also
CSKeywords Class
CSKeywords Members
NFX.CodeAnalysis.CSharp Namespace


CSLanguage Class

CSLanguage Class NFX Class Library

Represents C# language
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis Language
NFX.CodeAnalysis.CSharp CSLanguage

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class CSLanguage : Language
public sealed class CSLanguage : Language
Public NotInheritable Class CSLanguage
    Inherits Language
Public NotInheritable Class CSLanguage
    Inherits Language
public ref class CSLanguage sealed : public Language
public ref class CSLanguage sealed : public Language
[<SealedAttribute>]
type CSLanguage =
    class
        inherit Language
    end
[<SealedAttribute>]
type CSLanguage =
    class
        inherit Language
    end
See Also
CSLanguage Members
NFX.CodeAnalysis.CSharp Namespace


CSLanguage Members

CSLanguage Members NFX Class Library

The CSLanguage type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeLexer | (Overrides Language MakeLexer(IAnalysisContext, SourceCodeRef, ISourceText, MessageList, Boolean).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from Language.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
Instance |
Back to Top
Properties
 | Name | Description
Public property | Family | (Overrides Language Family.)
Public property | FileExtensions | (Overrides Language FileExtensions.)
Back to Top
See Also
CSLanguage Class
NFX.CodeAnalysis.CSharp Namespace


CSLanguage Fields

CSLanguage Fields NFX Class Library

The CSLanguage type exposes the following members.
Fields
Name | Description
Instance |
Back to Top
See Also
CSLanguage Class
NFX.CodeAnalysis.CSharp Namespace


CSLanguage.Instance Field

CSLanguage Instance Field NFX Class Library

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly CSLanguage Instance
public static readonly CSLanguage Instance
Public Shared ReadOnly Instance As CSLanguage
Public Shared ReadOnly Instance As CSLanguage
public:
static initonly CSLanguage^ Instance
public:
static initonly CSLanguage^ Instance
static val Instance: CSLanguage
static val Instance: CSLanguage

Field Value

Type: CSLanguage
See Also
CSLanguage Class
CSLanguage Members
NFX.CodeAnalysis.CSharp Namespace


CSLanguage Methods

CSLanguage Methods NFX Class Library

The CSLanguage type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeLexer | (Overrides Language MakeLexer(IAnalysisContext, SourceCodeRef, ISourceText, MessageList, Boolean).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from Language.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CSLanguage Class
NFX.CodeAnalysis.CSharp Namespace


CSLanguage.MakeLexer Method

CSLanguage MakeLexer Method NFX Class Library

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ILexer MakeLexer(
    IAnalysisContext context,
    SourceCodeRef srcRef,
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
public override ILexer MakeLexer(
    IAnalysisContext context,
    SourceCodeRef srcRef,
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
Public Overrides Function MakeLexer (
    context As IAnalysisContext,
    srcRef As SourceCodeRef,
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
) As ILexer
Public Overrides Function MakeLexer (
    context As IAnalysisContext,
    srcRef As SourceCodeRef,
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
) As ILexer
public:
virtual ILexer^ MakeLexer(
    IAnalysisContext^ context,
    SourceCodeRef srcRef,
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
) override
public:
virtual ILexer^ MakeLexer(
    IAnalysisContext^ context,
    SourceCodeRef srcRef,
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
) override
abstract MakeLexer :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> ILexer
override MakeLexer :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> ILexer
abstract MakeLexer :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> ILexer
override MakeLexer :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> ILexer

Parameters

context
Type: NFX.CodeAnalysis IAnalysisContext
srcRef
Type: NFX.CodeAnalysis.Source SourceCodeRef
source
Type: NFX.CodeAnalysis.Source ISourceText
messages (Optional)
Type: NFX.CodeAnalysis MessageList
throwErrors (Optional)
Type: Online System Boolean

Return Value

Type: ILexer
See Also
CSLanguage Class
CSLanguage Members
NFX.CodeAnalysis.CSharp Namespace


CSLanguage Properties

CSLanguage Properties NFX Class Library

The CSLanguage type exposes the following members.
Properties
 | Name | Description
Public property | Family | (Overrides Language Family.)
Public property | FileExtensions | (Overrides Language FileExtensions.)
Back to Top
See Also
CSLanguage Class
NFX.CodeAnalysis.CSharp Namespace


CSLanguage.Family Property

CSLanguage Family Property NFX Class Library

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override LanguageFamily Family { get; }
public override LanguageFamily Family { get; }
Public Overrides ReadOnly Property Family As LanguageFamily
    Get
Public Overrides ReadOnly Property Family As LanguageFamily
    Get
public:
virtual property LanguageFamily Family {
    LanguageFamily get () override;
}
public:
virtual property LanguageFamily Family {
    LanguageFamily get () override;
}
abstract Family : LanguageFamily with get
override Family : LanguageFamily with get
abstract Family : LanguageFamily with get
override Family : LanguageFamily with get

Property Value

Type: LanguageFamily
See Also
CSLanguage Class
CSLanguage Members
NFX.CodeAnalysis.CSharp Namespace


CSLanguage.FileExtensions Property

CSLanguage FileExtensions Property NFX Class Library

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IEnumerable<string> FileExtensions { get; }
public override IEnumerable<string> FileExtensions { get; }
Public Overrides ReadOnly Property FileExtensions As IEnumerable(Of String)
    Get
Public Overrides ReadOnly Property FileExtensions As IEnumerable(Of String)
    Get
public:
virtual property IEnumerable<String^>^ FileExtensions {
    IEnumerable<String^>^ get () override;
}
public:
virtual property IEnumerable<String^>^ FileExtensions {
    IEnumerable<String^>^ get () override;
}
abstract FileExtensions : IEnumerable<string> with get
override FileExtensions : IEnumerable<string> with get
abstract FileExtensions : IEnumerable<string> with get
override FileExtensions : IEnumerable<string> with get

Property Value

Type: Online IEnumerable Online String
See Also
CSLanguage Class
CSLanguage Members
NFX.CodeAnalysis.CSharp Namespace


CSLexer Class

CSLexer Class NFX Class Library

Performs lexical analysis on source supplied in C# syntax. This class supports lazy analysis that happens gradually as result tokens are consumed through IEnumerable interface.
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis CommonCodeProcessor
NFX.CodeAnalysis SourceRefCommonCodeProcessor
NFX.CodeAnalysis Lexer CSToken
NFX.CodeAnalysis.CSharp CSLexer

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class CSLexer : Lexer<CSToken>
public sealed class CSLexer : Lexer<CSToken>
Public NotInheritable Class CSLexer
    Inherits Lexer(Of CSToken)
Public NotInheritable Class CSLexer
    Inherits Lexer(Of CSToken)
public ref class CSLexer sealed : public Lexer<CSToken^>
public ref class CSLexer sealed : public Lexer<CSToken^>
[<SealedAttribute>]
type CSLexer =
    class
        inherit Lexer<CSToken>
    end
[<SealedAttribute>]
type CSLexer =
    class
        inherit Lexer<CSToken>
    end
See Also
CSLexer Members
NFX.CodeAnalysis.CSharp Namespace


CSLexer Members

CSLexer Members NFX Class Library

The CSLexer type exposes the following members.
Constructors
 | Name | Description
Public method | CSLexer(ISourceText, MessageList, Boolean) | Initializes a new instance of the CSLexer class
Public method | CSLexer(IAnalysisContext, SourceCodeRef, ISourceText, MessageList, Boolean) | Initializes a new instance of the CSLexer class
Back to Top
Methods
 | Name | Description
Public method | AnalyzeAll | If lexer supports lazy analysis, forces analysis of the whole source (Inherited from Lexer TToken .)
Protected method | DoLexingChunk | (Overrides Lexer TToken DoLexingChunk .)
Protected method | EmitMessage(MessageType, Int32, SourcePosition, Token, String, Exception) | (Inherited from SourceRefCommonCodeProcessor.)
Protected method | EmitMessage(MessageType, Int32, SourceCodeRef, Nullable SourcePosition , Token, String, Exception) | (Inherited from CommonCodeProcessor.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | (Inherited from Lexer TToken .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MessageCodeToString | (Overrides CommonCodeProcessor MessageCodeToString(Int32).)
Public method | ToString | (Inherited from Lexer TToken .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_AllAnalyzed | (Inherited from Lexer TToken .)
Protected field | m_Tokens | (Inherited from Lexer TToken .)
Back to Top
Properties
 | Name | Description
Public property | AllAnalyzed | Returns true when the whole input source has been analyzed. This property is always true for lexers that do not support lazy analysis (Inherited from Lexer TToken .)
Public property | Context | Returns context that this processor operates under - an entity that retains state during analysis, such as: module compiler, project compiler, code unit translator etc. This entity may also contain compiler/parser/lexer options etc. (Inherited from CommonCodeProcessor.)
Public property | Language | (Overrides CommonCodeProcessor Language.)
Public property | Messages | References message list that lexer emitts messages into. May be null (Inherited from CommonCodeProcessor.)
Public property | Source | References source code text that was lexed (Inherited from Lexer TToken .)
Public property | SourceCodeReference | References source code that is processed (Inherited from SourceRefCommonCodeProcessor.)
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any lexing error is always thrown regardless of this parameter (Inherited from CommonCodeProcessor.)
Public property | Tokens | Returns tokenized source as indexable list. Accessing this property causes lexical analysis to complete on the whole source if it has not been completed yet (Inherited from Lexer TToken .)
Public property | TokenStream | Enumerates Token stream - depending on implementation enumeration may do lexical analysis token-by-token or in chunks with every enumerator advance (Inherited from Lexer TToken .)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Lexer TToken .)
Back to Top
See Also
CSLexer Class
NFX.CodeAnalysis.CSharp Namespace


CSLexer Constructor

CSLexer Constructor NFX Class Library

Overload List
 | Name | Description
Public method | CSLexer(ISourceText, MessageList, Boolean) | Initializes a new instance of the CSLexer class
Public method | CSLexer(IAnalysisContext, SourceCodeRef, ISourceText, MessageList, Boolean) | Initializes a new instance of the CSLexer class
Back to Top
See Also
CSLexer Class
CSLexer Members
NFX.CodeAnalysis.CSharp Namespace


CSLexer Constructor (ISourceText, MessageList, Boolean)

CSLexer Constructor (ISourceText, MessageList, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CSLexer class

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CSLexer(
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
public CSLexer(
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
Public Sub New (
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
Public Sub New (
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
public:
CSLexer(
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
public:
CSLexer(
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
new :
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> CSLexer
new :
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> CSLexer

Parameters

source
Type: NFX.CodeAnalysis.Source ISourceText
messages (Optional)
Type: NFX.CodeAnalysis MessageList
throwErrors (Optional)
Type: Online System Boolean
See Also
CSLexer Class
CSLexer Members
CSLexer Overload
NFX.CodeAnalysis.CSharp Namespace


CSLexer Constructor (IAnalysisContext, SourceCodeRef, ISourceText, MessageList, Boolean)

CSLexer Constructor (IAnalysisContext, SourceCodeRef, ISourceText, MessageList, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CSLexer class

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CSLexer(
    IAnalysisContext context,
    SourceCodeRef srcRef,
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
public CSLexer(
    IAnalysisContext context,
    SourceCodeRef srcRef,
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
Public Sub New (
    context As IAnalysisContext,
    srcRef As SourceCodeRef,
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
Public Sub New (
    context As IAnalysisContext,
    srcRef As SourceCodeRef,
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
public:
CSLexer(
    IAnalysisContext^ context,
    SourceCodeRef srcRef,
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
public:
CSLexer(
    IAnalysisContext^ context,
    SourceCodeRef srcRef,
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
new :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> CSLexer
new :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> CSLexer

Parameters

context
Type: NFX.CodeAnalysis IAnalysisContext
srcRef
Type: NFX.CodeAnalysis.Source SourceCodeRef
source
Type: NFX.CodeAnalysis.Source ISourceText
messages (Optional)
Type: NFX.CodeAnalysis MessageList
throwErrors (Optional)
Type: Online System Boolean
See Also
CSLexer Class
CSLexer Members
CSLexer Overload
NFX.CodeAnalysis.CSharp Namespace


CSLexer Fields

CSLexer Fields NFX Class Library

The CSLexer type exposes the following members.
Fields
 | Name | Description
Protected field | m_AllAnalyzed | (Inherited from Lexer TToken .)
Protected field | m_Tokens | (Inherited from Lexer TToken .)
Back to Top
See Also
CSLexer Class
NFX.CodeAnalysis.CSharp Namespace


CSLexer Methods

CSLexer Methods NFX Class Library

The CSLexer type exposes the following members.
Methods
 | Name | Description
Public method | AnalyzeAll | If lexer supports lazy analysis, forces analysis of the whole source (Inherited from Lexer TToken .)
Protected method | DoLexingChunk | (Overrides Lexer TToken DoLexingChunk .)
Protected method | EmitMessage(MessageType, Int32, SourcePosition, Token, String, Exception) | (Inherited from SourceRefCommonCodeProcessor.)
Protected method | EmitMessage(MessageType, Int32, SourceCodeRef, Nullable SourcePosition , Token, String, Exception) | (Inherited from CommonCodeProcessor.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | (Inherited from Lexer TToken .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MessageCodeToString | (Overrides CommonCodeProcessor MessageCodeToString(Int32).)
Public method | ToString | (Inherited from Lexer TToken .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Lexer TToken .)
Back to Top
See Also
CSLexer Class
NFX.CodeAnalysis.CSharp Namespace


CSLexer.DoLexingChunk Method

CSLexer DoLexingChunk Method NFX Class Library

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool DoLexingChunk()
protected override bool DoLexingChunk()
Protected Overrides Function DoLexingChunk As Boolean
Protected Overrides Function DoLexingChunk As Boolean
protected:
virtual bool DoLexingChunk() override
protected:
virtual bool DoLexingChunk() override
abstract DoLexingChunk : unit -> bool
override DoLexingChunk : unit -> bool
abstract DoLexingChunk : unit -> bool
override DoLexingChunk : unit -> bool

Return Value

Type: Online Boolean
See Also
CSLexer Class
CSLexer Members
NFX.CodeAnalysis.CSharp Namespace


CSLexer.MessageCodeToString Method

CSLexer MessageCodeToString Method NFX Class Library

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string MessageCodeToString(
    int code
)
public override string MessageCodeToString(
    int code
)
Public Overrides Function MessageCodeToString (
    code As Integer
) As String
Public Overrides Function MessageCodeToString (
    code As Integer
) As String
public:
virtual String^ MessageCodeToString(
    int code
) override
public:
virtual String^ MessageCodeToString(
    int code
) override
abstract MessageCodeToString :
        code : int -> string
override MessageCodeToString :
        code : int -> string
abstract MessageCodeToString :
        code : int -> string
override MessageCodeToString :
        code : int -> string

Parameters

code
Type: Online System Int32

Return Value

Type: Online String

Implements

ICodeProcessor MessageCodeToString(Int32)
See Also
CSLexer Class
CSLexer Members
NFX.CodeAnalysis.CSharp Namespace


CSLexer Properties

CSLexer Properties NFX Class Library

The CSLexer type exposes the following members.
Properties
 | Name | Description
Public property | AllAnalyzed | Returns true when the whole input source has been analyzed. This property is always true for lexers that do not support lazy analysis (Inherited from Lexer TToken .)
Public property | Context | Returns context that this processor operates under - an entity that retains state during analysis, such as: module compiler, project compiler, code unit translator etc. This entity may also contain compiler/parser/lexer options etc. (Inherited from CommonCodeProcessor.)
Public property | Language | (Overrides CommonCodeProcessor Language.)
Public property | Messages | References message list that lexer emitts messages into. May be null (Inherited from CommonCodeProcessor.)
Public property | Source | References source code text that was lexed (Inherited from Lexer TToken .)
Public property | SourceCodeReference | References source code that is processed (Inherited from SourceRefCommonCodeProcessor.)
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any lexing error is always thrown regardless of this parameter (Inherited from CommonCodeProcessor.)
Public property | Tokens | Returns tokenized source as indexable list. Accessing this property causes lexical analysis to complete on the whole source if it has not been completed yet (Inherited from Lexer TToken .)
Public property | TokenStream | Enumerates Token stream - depending on implementation enumeration may do lexical analysis token-by-token or in chunks with every enumerator advance (Inherited from Lexer TToken .)
Back to Top
See Also
CSLexer Class
NFX.CodeAnalysis.CSharp Namespace


CSLexer.Language Property

CSLexer Language Property NFX Class Library

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Language Language { get; }
public override Language Language { get; }
Public Overrides ReadOnly Property Language As Language
    Get
Public Overrides ReadOnly Property Language As Language
    Get
public:
virtual property Language^ Language {
    Language^ get () override;
}
public:
virtual property Language^ Language {
    Language^ get () override;
}
abstract Language : Language with get
override Language : Language with get
abstract Language : Language with get
override Language : Language with get

Property Value

Type: Language

Implements

ICodeProcessor Language
See Also
CSLexer Class
CSLexer Members
NFX.CodeAnalysis.CSharp Namespace


CSMsgCode Enumeration

CSMsgCode Enumeration NFX Class Library

Message codes for CSharp code processors

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum CSMsgCode
public enum CSMsgCode
Public Enumeration CSMsgCode
Public Enumeration CSMsgCode
public enum class CSMsgCode
public enum class CSMsgCode
type CSMsgCode
type CSMsgCode
Members
Member name | Value | Description
INFOS | 0 |
WARNING | 100 |
ERRORS | 1000 |
eUnterminatedString | 1001 |
ePrematureEOF | 1002 |
eUnterminatedComment | 1003 |
eInvalidStringEscape | 1004 |
eValueTooBig | 1005 |
eInvalidIdentifier | 1006 |
eSyntaxError | 1007 |
See Also
NFX.CodeAnalysis.CSharp Namespace


CSNumbers Class

CSNumbers Class NFX Class Library

Provides C# number parsing
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis.CSharp CSNumbers

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class CSNumbers
public static class CSNumbers
Public NotInheritable Class CSNumbers
Public NotInheritable Class CSNumbers
public ref class CSNumbers abstract sealed
public ref class CSNumbers abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CSNumbers =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CSNumbers =  class end
See Also
CSNumbers Members
NFX.CodeAnalysis.CSharp Namespace


CSNumbers Members

CSNumbers Members NFX Class Library

The CSNumbers type exposes the following members.
Methods
Name | Description
Convert | Tries to convert string to number, returns null if conversion could not be made. Raises exception if operand is wider than specifier allows
Back to Top
Fields
Name | Description
S_DECIMAL |
S_DOUBLE |
S_FLOAT |
S_LONG |
S_UINT |
S_ULONG1 |
S_ULONG2 |
Back to Top
See Also
CSNumbers Class
NFX.CodeAnalysis.CSharp Namespace


CSNumbers Fields

CSNumbers Fields NFX Class Library

The CSNumbers type exposes the following members.
Fields
Name | Description
S_DECIMAL |
S_DOUBLE |
S_FLOAT |
S_LONG |
S_UINT |
S_ULONG1 |
S_ULONG2 |
Back to Top
See Also
CSNumbers Class
NFX.CodeAnalysis.CSharp Namespace


CSNumbers.S_DECIMAL Field

CSNumbers S_DECIMAL Field NFX Class Library

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string S_DECIMAL
public const string S_DECIMAL
Public Const S_DECIMAL As String
Public Const S_DECIMAL As String
public:
literal String^ S_DECIMAL
public:
literal String^ S_DECIMAL
static val mutable S_DECIMAL: string
static val mutable S_DECIMAL: string

Field Value

Type: Online String
See Also
CSNumbers Class
CSNumbers Members
NFX.CodeAnalysis.CSharp Namespace


CSNumbers.S_DOUBLE Field

CSNumbers S_DOUBLE Field NFX Class Library

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string S_DOUBLE
public const string S_DOUBLE
Public Const S_DOUBLE As String
Public Const S_DOUBLE As String
public:
literal String^ S_DOUBLE
public:
literal String^ S_DOUBLE
static val mutable S_DOUBLE: string
static val mutable S_DOUBLE: string

Field Value

Type: Online String
See Also
CSNumbers Class
CSNumbers Members
NFX.CodeAnalysis.CSharp Namespace


CSNumbers.S_FLOAT Field

CSNumbers S_FLOAT Field NFX Class Library

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string S_FLOAT
public const string S_FLOAT
Public Const S_FLOAT As String
Public Const S_FLOAT As String
public:
literal String^ S_FLOAT
public:
literal String^ S_FLOAT
static val mutable S_FLOAT: string
static val mutable S_FLOAT: string

Field Value

Type: Online String
See Also
CSNumbers Class
CSNumbers Members
NFX.CodeAnalysis.CSharp Namespace


CSNumbers.S_LONG Field

CSNumbers S_LONG Field NFX Class Library

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string S_LONG
public const string S_LONG
Public Const S_LONG As String
Public Const S_LONG As String
public:
literal String^ S_LONG
public:
literal String^ S_LONG
static val mutable S_LONG: string
static val mutable S_LONG: string

Field Value

Type: Online String
See Also
CSNumbers Class
CSNumbers Members
NFX.CodeAnalysis.CSharp Namespace


CSNumbers.S_UINT Field

CSNumbers S_UINT Field NFX Class Library

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string S_UINT
public const string S_UINT
Public Const S_UINT As String
Public Const S_UINT As String
public:
literal String^ S_UINT
public:
literal String^ S_UINT
static val mutable S_UINT: string
static val mutable S_UINT: string

Field Value

Type: Online String
See Also
CSNumbers Class
CSNumbers Members
NFX.CodeAnalysis.CSharp Namespace


CSNumbers.S_ULONG1 Field

CSNumbers S_ULONG1 Field NFX Class Library

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string S_ULONG1
public const string S_ULONG1
Public Const S_ULONG1 As String
Public Const S_ULONG1 As String
public:
literal String^ S_ULONG1
public:
literal String^ S_ULONG1
static val mutable S_ULONG1: string
static val mutable S_ULONG1: string

Field Value

Type: Online String
See Also
CSNumbers Class
CSNumbers Members
NFX.CodeAnalysis.CSharp Namespace


CSNumbers.S_ULONG2 Field

CSNumbers S_ULONG2 Field NFX Class Library

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string S_ULONG2
public const string S_ULONG2
Public Const S_ULONG2 As String
Public Const S_ULONG2 As String
public:
literal String^ S_ULONG2
public:
literal String^ S_ULONG2
static val mutable S_ULONG2: string
static val mutable S_ULONG2: string

Field Value

Type: Online String
See Also
CSNumbers Class
CSNumbers Members
NFX.CodeAnalysis.CSharp Namespace


CSNumbers Methods

CSNumbers Methods NFX Class Library

The CSNumbers type exposes the following members.
Methods
Name | Description
Convert | Tries to convert string to number, returns null if conversion could not be made. Raises exception if operand is wider than specifier allows
Back to Top
See Also
CSNumbers Class
NFX.CodeAnalysis.CSharp Namespace


CSNumbers.Convert Method

CSNumbers Convert Method NFX Class Library

Tries to convert string to number, returns null if conversion could not be made. Raises exception if operand is wider than specifier allows

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Object Convert(
    string str,
    out CSTokenType type
)
public static Object Convert(
    string str,
    out CSTokenType type
)
Public Shared Function Convert (
    str As String,
    <OutAttribute> ByRef type As CSTokenType
) As Object
Public Shared Function Convert (
    str As String,
    <OutAttribute> ByRef type As CSTokenType
) As Object
public:
static Object^ Convert(
    String^ str,
    [OutAttribute] CSTokenType% type
)
public:
static Object^ Convert(
    String^ str,
    [OutAttribute] CSTokenType% type
)
static member Convert :
        str : string *
        type : CSTokenType byref -> Object
static member Convert :
        str : string *
        type : CSTokenType byref -> Object

Parameters

str
Type: Online System String
type
Type: NFX.CodeAnalysis.CSharp CSTokenType

Return Value

Type: Online Object
See Also
CSNumbers Class
CSNumbers Members
NFX.CodeAnalysis.CSharp Namespace


CSStrings Class

CSStrings Class NFX Class Library

Provides C# string escape parsing
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis.CSharp CSStrings

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class CSStrings
public static class CSStrings
Public NotInheritable Class CSStrings
Public NotInheritable Class CSStrings
public ref class CSStrings abstract sealed
public ref class CSStrings abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CSStrings =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CSStrings =  class end
See Also
CSStrings Members
NFX.CodeAnalysis.CSharp Namespace


CSStrings Members

CSStrings Members NFX Class Library

The CSStrings type exposes the following members.
Methods
Name | Description
UnescapeString |
Back to Top
See Also
CSStrings Class
NFX.CodeAnalysis.CSharp Namespace


CSStrings Methods

CSStrings Methods NFX Class Library

The CSStrings type exposes the following members.
Methods
Name | Description
UnescapeString |
Back to Top
See Also
CSStrings Class
NFX.CodeAnalysis.CSharp Namespace


CSStrings.UnescapeString Method

CSStrings UnescapeString Method NFX Class Library

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string UnescapeString(
    string str
)
public static string UnescapeString(
    string str
)
Public Shared Function UnescapeString (
    str As String
) As String
Public Shared Function UnescapeString (
    str As String
) As String
public:
static String^ UnescapeString(
    String^ str
)
public:
static String^ UnescapeString(
    String^ str
)
static member UnescapeString :
        str : string -> string
static member UnescapeString :
        str : string -> string

Parameters

str
Type: Online System String

Return Value

Type: Online String
See Also
CSStrings Class
CSStrings Members
NFX.CodeAnalysis.CSharp Namespace


CSToken Class

CSToken Class NFX Class Library

Represents a C# token
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis Token
NFX.CodeAnalysis.CSharp CSToken

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CSToken : Token
public class CSToken : Token
Public Class CSToken
    Inherits Token
Public Class CSToken
    Inherits Token
public ref class CSToken : public Token
public ref class CSToken : public Token
type CSToken =
    class
        inherit Token
    end
type CSToken =
    class
        inherit Token
    end
See Also
CSToken Members
NFX.CodeAnalysis.CSharp Namespace


CSToken Members

CSToken Members NFX Class Library

The CSToken type exposes the following members.
Constructors
 | Name | Description
Public method | CSToken | Initializes a new instance of the CSToken class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Token ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | EndPosition | (Inherited from Token.)
Public field | Lexer | (Inherited from Token.)
Public field | StartPosition | (Inherited from Token.)
Public field | Text | (Inherited from Token.)
Public field | Type |
Public field | Value | (Inherited from Token.)
Back to Top
Properties
 | Name | Description
Public property | IsBOF | Indicates whether this token indicates an BEGINNING-OF-FILE condition (Inherited from Token.)
Public property | IsComment | Indicates whether this token represents a comment (Inherited from Token.)
Public property | IsDirective | Indicates whether this token represents a directive (Inherited from Token.)
Public property | IsEOF | Indicates whether this token indicates an END-OF-FILE condition (Inherited from Token.)
Public property | IsIdentifier | Indicates whether this token represents an identifier (Inherited from Token.)
Public property | IsKeyword | Indicates whether this token represents a language keyword (Inherited from Token.)
Public property | IsLiteral | Indicates whether this token represents a literal (Inherited from Token.)
Public property | IsNonLanguage | (Overrides Token IsNonLanguage.)
Public property | IsNumericLiteral | (Overrides Token IsNumericLiteral.)
Public property | IsOperator | Indicates whether this token represents an operator (Inherited from Token.)
Public property | IsPrimary | (Overrides Token IsPrimary.)
Public property | IsSymbol | Indicates whether this token represents a symbol (Inherited from Token.)
Public property | IsTextualLiteral | (Overrides Token IsTextualLiteral.)
Public property | Kind | (Overrides Token Kind.)
Public property | Language | (Overrides Token Language.)
Public property | OrdinalType | (Overrides Token OrdinalType.)
Back to Top
See Also
CSToken Class
NFX.CodeAnalysis.CSharp Namespace


CSToken Constructor

CSToken Constructor NFX Class Library

Initializes a new instance of the CSToken class

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CSToken(
    CSLexer lexer,
    CSTokenType type,
    SourcePosition startPos,
    SourcePosition endPos,
    string text,
    Object value = null
)
public CSToken(
    CSLexer lexer,
    CSTokenType type,
    SourcePosition startPos,
    SourcePosition endPos,
    string text,
    Object value = null
)
Public Sub New (
    lexer As CSLexer,
    type As CSTokenType,
    startPos As SourcePosition,
    endPos As SourcePosition,
    text As String,
    Optional value As Object = Nothing
)
Public Sub New (
    lexer As CSLexer,
    type As CSTokenType,
    startPos As SourcePosition,
    endPos As SourcePosition,
    text As String,
    Optional value As Object = Nothing
)
public:
CSToken(
    CSLexer^ lexer,
    CSTokenType type,
    SourcePosition startPos,
    SourcePosition endPos,
    String^ text,
    Object^ value = nullptr
)
public:
CSToken(
    CSLexer^ lexer,
    CSTokenType type,
    SourcePosition startPos,
    SourcePosition endPos,
    String^ text,
    Object^ value = nullptr
)
new :
        lexer : CSLexer *
        type : CSTokenType *
        startPos : SourcePosition *
        endPos : SourcePosition *
        text : string *
        ?value : Object
(* Defaults:
        let _value = defaultArg value null
*)
-> CSToken
new :
        lexer : CSLexer *
        type : CSTokenType *
        startPos : SourcePosition *
        endPos : SourcePosition *
        text : string *
        ?value : Object
(* Defaults:
        let _value = defaultArg value null
*)
-> CSToken

Parameters

lexer
Type: NFX.CodeAnalysis.CSharp CSLexer
type
Type: NFX.CodeAnalysis.CSharp CSTokenType
startPos
Type: NFX.CodeAnalysis.Source SourcePosition
endPos
Type: NFX.CodeAnalysis.Source SourcePosition
text
Type: Online System String
value (Optional)
Type: Online System Object
See Also
CSToken Class
CSToken Members
NFX.CodeAnalysis.CSharp Namespace


CSToken Fields

CSToken Fields NFX Class Library

The CSToken type exposes the following members.
Fields
 | Name | Description
Public field | EndPosition | (Inherited from Token.)
Public field | Lexer | (Inherited from Token.)
Public field | StartPosition | (Inherited from Token.)
Public field | Text | (Inherited from Token.)
Public field | Type |
Public field | Value | (Inherited from Token.)
Back to Top
See Also
CSToken Class
NFX.CodeAnalysis.CSharp Namespace


CSToken.Type Field

CSToken Type Field NFX Class Library

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly CSTokenType Type
public readonly CSTokenType Type
Public ReadOnly Type As CSTokenType
Public ReadOnly Type As CSTokenType
public:
initonly CSTokenType Type
public:
initonly CSTokenType Type
val Type: CSTokenType
val Type: CSTokenType

Field Value

Type: CSTokenType
See Also
CSToken Class
CSToken Members
NFX.CodeAnalysis.CSharp Namespace


CSToken Methods

CSToken Methods NFX Class Library

The CSToken type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Token ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CSToken Class
NFX.CodeAnalysis.CSharp Namespace


CSToken.ToString Method

CSToken ToString Method NFX Class Library

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
CSToken Class
CSToken Members
NFX.CodeAnalysis.CSharp Namespace


CSToken Properties

CSToken Properties NFX Class Library

The CSToken type exposes the following members.
Properties
 | Name | Description
Public property | IsBOF | Indicates whether this token indicates an BEGINNING-OF-FILE condition (Inherited from Token.)
Public property | IsComment | Indicates whether this token represents a comment (Inherited from Token.)
Public property | IsDirective | Indicates whether this token represents a directive (Inherited from Token.)
Public property | IsEOF | Indicates whether this token indicates an END-OF-FILE condition (Inherited from Token.)
Public property | IsIdentifier | Indicates whether this token represents an identifier (Inherited from Token.)
Public property | IsKeyword | Indicates whether this token represents a language keyword (Inherited from Token.)
Public property | IsLiteral | Indicates whether this token represents a literal (Inherited from Token.)
Public property | IsNonLanguage | (Overrides Token IsNonLanguage.)
Public property | IsNumericLiteral | (Overrides Token IsNumericLiteral.)
Public property | IsOperator | Indicates whether this token represents an operator (Inherited from Token.)
Public property | IsPrimary | (Overrides Token IsPrimary.)
Public property | IsSymbol | Indicates whether this token represents a symbol (Inherited from Token.)
Public property | IsTextualLiteral | (Overrides Token IsTextualLiteral.)
Public property | Kind | (Overrides Token Kind.)
Public property | Language | (Overrides Token Language.)
Public property | OrdinalType | (Overrides Token OrdinalType.)
Back to Top
See Also
CSToken Class
NFX.CodeAnalysis.CSharp Namespace


CSToken.IsNonLanguage Property

CSToken IsNonLanguage Property NFX Class Library

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsNonLanguage { get; }
public override bool IsNonLanguage { get; }
Public Overrides ReadOnly Property IsNonLanguage As Boolean
    Get
Public Overrides ReadOnly Property IsNonLanguage As Boolean
    Get
public:
virtual property bool IsNonLanguage {
    bool get () override;
}
public:
virtual property bool IsNonLanguage {
    bool get () override;
}
abstract IsNonLanguage : bool with get
override IsNonLanguage : bool with get
abstract IsNonLanguage : bool with get
override IsNonLanguage : bool with get

Property Value

Type: Online Boolean
See Also
CSToken Class
CSToken Members
NFX.CodeAnalysis.CSharp Namespace


CSToken.IsNumericLiteral Property

CSToken IsNumericLiteral Property NFX Class Library

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsNumericLiteral { get; }
public override bool IsNumericLiteral { get; }
Public Overrides ReadOnly Property IsNumericLiteral As Boolean
    Get
Public Overrides ReadOnly Property IsNumericLiteral As Boolean
    Get
public:
virtual property bool IsNumericLiteral {
    bool get () override;
}
public:
virtual property bool IsNumericLiteral {
    bool get () override;
}
abstract IsNumericLiteral : bool with get
override IsNumericLiteral : bool with get
abstract IsNumericLiteral : bool with get
override IsNumericLiteral : bool with get

Property Value

Type: Online Boolean
See Also
CSToken Class
CSToken Members
NFX.CodeAnalysis.CSharp Namespace


CSToken.IsPrimary Property

CSToken IsPrimary Property NFX Class Library

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsPrimary { get; }
public override bool IsPrimary { get; }
Public Overrides ReadOnly Property IsPrimary As Boolean
    Get
Public Overrides ReadOnly Property IsPrimary As Boolean
    Get
public:
virtual property bool IsPrimary {
    bool get () override;
}
public:
virtual property bool IsPrimary {
    bool get () override;
}
abstract IsPrimary : bool with get
override IsPrimary : bool with get
abstract IsPrimary : bool with get
override IsPrimary : bool with get

Property Value

Type: Online Boolean
See Also
CSToken Class
CSToken Members
NFX.CodeAnalysis.CSharp Namespace


CSToken.IsTextualLiteral Property

CSToken IsTextualLiteral Property NFX Class Library

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsTextualLiteral { get; }
public override bool IsTextualLiteral { get; }
Public Overrides ReadOnly Property IsTextualLiteral As Boolean
    Get
Public Overrides ReadOnly Property IsTextualLiteral As Boolean
    Get
public:
virtual property bool IsTextualLiteral {
    bool get () override;
}
public:
virtual property bool IsTextualLiteral {
    bool get () override;
}
abstract IsTextualLiteral : bool with get
override IsTextualLiteral : bool with get
abstract IsTextualLiteral : bool with get
override IsTextualLiteral : bool with get

Property Value

Type: Online Boolean
See Also
CSToken Class
CSToken Members
NFX.CodeAnalysis.CSharp Namespace


CSToken.Kind Property

CSToken Kind Property NFX Class Library

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TokenKind Kind { get; }
public override TokenKind Kind { get; }
Public Overrides ReadOnly Property Kind As TokenKind
    Get
Public Overrides ReadOnly Property Kind As TokenKind
    Get
public:
virtual property TokenKind Kind {
    TokenKind get () override;
}
public:
virtual property TokenKind Kind {
    TokenKind get () override;
}
abstract Kind : TokenKind with get
override Kind : TokenKind with get
abstract Kind : TokenKind with get
override Kind : TokenKind with get

Property Value

Type: TokenKind
See Also
CSToken Class
CSToken Members
NFX.CodeAnalysis.CSharp Namespace


CSToken.Language Property

CSToken Language Property NFX Class Library

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Language Language { get; }
public override Language Language { get; }
Public Overrides ReadOnly Property Language As Language
    Get
Public Overrides ReadOnly Property Language As Language
    Get
public:
virtual property Language^ Language {
    Language^ get () override;
}
public:
virtual property Language^ Language {
    Language^ get () override;
}
abstract Language : Language with get
override Language : Language with get
abstract Language : Language with get
override Language : Language with get

Property Value

Type: Language
See Also
CSToken Class
CSToken Members
NFX.CodeAnalysis.CSharp Namespace


CSToken.OrdinalType Property

CSToken OrdinalType Property NFX Class Library

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int OrdinalType { get; }
public override int OrdinalType { get; }
Public Overrides ReadOnly Property OrdinalType As Integer
    Get
Public Overrides ReadOnly Property OrdinalType As Integer
    Get
public:
virtual property int OrdinalType {
    int get () override;
}
public:
virtual property int OrdinalType {
    int get () override;
}
abstract OrdinalType : int with get
override OrdinalType : int with get
abstract OrdinalType : int with get
override OrdinalType : int with get

Property Value

Type: Online Int32
See Also
CSToken Class
CSToken Members
NFX.CodeAnalysis.CSharp Namespace


CSTokenType Enumeration

CSTokenType Enumeration NFX Class Library

Denotes CSharp token types

Namespace: NFX.CodeAnalysis.CSharp
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum CSTokenType
public enum CSTokenType
Public Enumeration CSTokenType
Public Enumeration CSTokenType
public enum class CSTokenType
public enum class CSTokenType
type CSTokenType
type CSTokenType
Members
Member name | Value | Description
tUnknown | 0 |
NONLANG_START | 1 |
tBOF | 2 |
tEOF | 3 |
tDirective | 4 |
NONLANG_END | 5 |
tComment | 6 |
tIdentifier | 7 |
SYMBOLS_START | 8 |
tTerminator | 9 |
tComma | 10 |
tColon | 11 |
tBraceOpen | 12 |
tBraceClose | 13 |
tBracketOpen | 14 |
tBracketClose | 15 |
tSqBracketOpen | 16 |
tSqBracketClose | 17 |
SYMBOLS_END | 18 |
OPERATORS_START | 19 |
tPlus | 20 |
tMinus | 21 |
tMul | 22 |
tDiv | 23 |
tMod | 24 |
tAnd | 25 |
tAndShort | 26 |
tOr | 27 |
tOrShort | 28 |
tXor | 29 |
tNot | 30 |
tBitNot | 31 |
tInc | 32 |
tDec | 33 |
tShl | 34 |
tShr | 35 |
tE | 36 |
tNE | 37 |
tL | 38 |
tG | 39 |
tLE | 40 |
tGE | 41 |
tAssign | 42 |
tPlusAssign | 43 |
tMinusAssign | 44 |
tMulAssign | 45 |
tDivAssign | 46 |
tModAssign | 47 |
tAndAssign | 48 |
tOrAssign | 49 |
tXorAssign | 50 |
tShlAssign | 51 |
tShrAssign | 52 |
tDot | 53 |
tAs | 54 |
tIs | 55 |
tNew | 56 |
tSizeOf | 57 |
tTypeOf | 58 |
tDeref | 59 |
tTernaryIf | 60 |
tNullCoalesce | 61 |
tLambda | 62 |
OPERATORS_END | 63 |
KEYWORDS_START | 64 |
tAbstract | 65 |
tBase | 66 |
tBreak | 67 |
tCase | 68 |
tCatch | 69 |
tChecked | 70 |
tClass | 71 |
tConst | 72 |
tContinue | 73 |
tDefault | 74 |
tDelegate | 75 |
tDo | 76 |
tElse | 77 |
tEnum | 78 |
tEvent | 79 |
tExplicit | 80 |
tExtern | 81 |
tFinally | 82 |
tFixed | 83 |
tFor | 84 |
tForeach | 85 |
tGoto | 86 |
tIf | 87 |
tImplicit | 88 |
tIn | 89 |
tInterface | 90 |
tLock | 91 |
tNamespace | 92 |
tOperator | 93 |
tOut | 94 |
tOverride | 95 |
tParams | 96 |
tPrivate | 97 |
tProtected | 98 |
tPublic | 99 |
tReadonly | 100 |
tRef | 101 |
tReturn | 102 |
tSealed | 103 |
tStackAlloc | 104 |
tStatic | 105 |
tStruct | 106 |
tSwitch | 107 |
tThis | 108 |
tThrow | 109 |
tTry | 110 |
tUnchecked | 111 |
tUnsafe | 112 |
tUsing | 113 |
tVar | 114 |
tVirtual | 115 |
tVolatile | 116 |
tVoid | 117 |
tWhile | 118 |
KEYWORDS_END | 119 |
TYPES_START | 120 |
tBool | 121 |
tByte | 122 |
tChar | 123 |
tDecimal | 124 |
tDouble | 125 |
tFloat | 126 |
tLong | 127 |
tObject | 128 |
tSByte | 129 |
tShort | 130 |
tString | 131 |
tInt | 132 |
tUInt | 133 |
tULong | 134 |
tUShort | 135 |
TYPES_END | 136 |
LITERALS_START | 137 |
NUMLITERALS_START | 138 |
tIntLiteral | 139 |
tLongIntLiteral | 140 |
tUIntLiteral | 141 |
tULongIntLiteral | 142 |
tFloatLiteral | 143 |
tDoubleLiteral | 144 |
tDecimalLiteral | 145 |
NUMLITERALS_END | 146 |
tNull | 147 |
tStringLiteral | 148 |
tTrue | 149 |
tFalse | 150 |
LITERALS_END | 151 |
See Also
NFX.CodeAnalysis.CSharp Namespace


NFX.CodeAnalysis.JSON Namespace

NFX.CodeAnalysis.JSON Namespace NFX Class Library

Provides functions for working with JSON syntax
Classes
 | Class | Description
Public class | JSONData | Represents JSONDataParser result
Public class | JSONIdentifiers | Identifier validation and other utilities in context of JSON grammar
Public class | JSONKeywords | Provides JSON keyword resolution services, this class is thread safe
Public class | JSONLanguage | Represents JSON language
Public class | JSONLexer | Performs lexical analysis on source supplied in JSON syntax. This class supports lazy analysis that happens gradually as result tokens are consumed through IEnumerable interface. NOTE: Although called JSON, this is really a JSON superset implementation that includes extra features: comments, directives, verbatim strings(start with $), ' or " string escapes, unquoted object key names
Public class | JSONNumbers |
Public class | JSONParser | Parses JSON lexer output into object graphs. NOTE: Although called JSON, this is really a JSON superset implementation that includes extra features: comments, directives, verbatim strings(start with $), ' or " string escapes, unquoted object key names
Public class | JSONPatternMatchAttribute | Base class for JSON pattern matching
Public class | JSONStrings | Provides JSON string escape parsing
Public class | JSONToken | Represents a token of JSON language
Enumerations
 | Enumeration | Description
Public enumeration | JSONMsgCode | Message codes for JSON code processors
Public enumeration | JSONTokenType | Denotes JSON token types. NOTE: Although called JSON, this is really a JSON superset implementation that includes extra features: comments, directives, verbatim strings(start with $), ' or " string escapes, unquoted object key names


JSONData Class

JSONData Class NFX Class Library

Represents JSONDataParser result
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis CommonCodeProcessor
NFX.CodeAnalysis ObjectResultAnalysisContext Online Object
NFX.CodeAnalysis.JSON JSONData

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class JSONData : ObjectResultAnalysisContext<Object>
public sealed class JSONData : ObjectResultAnalysisContext<Object>
Public NotInheritable Class JSONData
    Inherits ObjectResultAnalysisContext(Of Object)
Public NotInheritable Class JSONData
    Inherits ObjectResultAnalysisContext(Of Object)
public ref class JSONData sealed : public ObjectResultAnalysisContext<Object^>
public ref class JSONData sealed : public ObjectResultAnalysisContext<Object^>
[<SealedAttribute>]
type JSONData =
    class
        inherit ObjectResultAnalysisContext<Object>
    end
[<SealedAttribute>]
type JSONData =
    class
        inherit ObjectResultAnalysisContext<Object>
    end
See Also
JSONData Members
NFX.CodeAnalysis.JSON Namespace


JSONData Members

JSONData Members NFX Class Library

The JSONData type exposes the following members.
Constructors
 | Name | Description
Public method | JSONData | Initializes a new instance of the JSONData class
Back to Top
Methods
 | Name | Description
Protected method | EmitMessage | (Inherited from CommonCodeProcessor.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MessageCodeToString | (Overrides CommonCodeProcessor MessageCodeToString(Int32).)
Protected method | setData |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_ResultObject | (Inherited from ObjectResultAnalysisContext TObject .)
Back to Top
Properties
 | Name | Description
Public property | Context | Returns context that this processor operates under - an entity that retains state during analysis, such as: module compiler, project compiler, code unit translator etc. This entity may also contain compiler/parser/lexer options etc. (Inherited from CommonCodeProcessor.)
Public property | Language | (Overrides CommonCodeProcessor Language.)
Public property | Messages | References message list that lexer emitts messages into. May be null (Inherited from CommonCodeProcessor.)
Public property | ResultObject | (Inherited from ObjectResultAnalysisContext TObject .)
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any lexing error is always thrown regardless of this parameter (Inherited from CommonCodeProcessor.)
Back to Top
See Also
JSONData Class
NFX.CodeAnalysis.JSON Namespace


JSONData Constructor

JSONData Constructor NFX Class Library

Initializes a new instance of the JSONData class

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONData(
    IAnalysisContext context = null,
    MessageList messages = null,
    bool throwErrors = false
)
public JSONData(
    IAnalysisContext context = null,
    MessageList messages = null,
    bool throwErrors = false
)
Public Sub New (
    Optional context As IAnalysisContext = Nothing,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
Public Sub New (
    Optional context As IAnalysisContext = Nothing,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
public:
JSONData(
    IAnalysisContext^ context = nullptr,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
public:
JSONData(
    IAnalysisContext^ context = nullptr,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
new :
        ?context : IAnalysisContext *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _context = defaultArg context null
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> JSONData
new :
        ?context : IAnalysisContext *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _context = defaultArg context null
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> JSONData

Parameters

context (Optional)
Type: NFX.CodeAnalysis IAnalysisContext
messages (Optional)
Type: NFX.CodeAnalysis MessageList
throwErrors (Optional)
Type: Online System Boolean
See Also
JSONData Class
JSONData Members
NFX.CodeAnalysis.JSON Namespace


JSONData Fields

JSONData Fields NFX Class Library

The JSONData type exposes the following members.
Fields
 | Name | Description
Protected field | m_ResultObject | (Inherited from ObjectResultAnalysisContext TObject .)
Back to Top
See Also
JSONData Class
NFX.CodeAnalysis.JSON Namespace


JSONData Methods

JSONData Methods NFX Class Library

The JSONData type exposes the following members.
Methods
 | Name | Description
Protected method | EmitMessage | (Inherited from CommonCodeProcessor.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MessageCodeToString | (Overrides CommonCodeProcessor MessageCodeToString(Int32).)
Protected method | setData |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
JSONData Class
NFX.CodeAnalysis.JSON Namespace


JSONData.MessageCodeToString Method

JSONData MessageCodeToString Method NFX Class Library

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string MessageCodeToString(
    int code
)
public override string MessageCodeToString(
    int code
)
Public Overrides Function MessageCodeToString (
    code As Integer
) As String
Public Overrides Function MessageCodeToString (
    code As Integer
) As String
public:
virtual String^ MessageCodeToString(
    int code
) override
public:
virtual String^ MessageCodeToString(
    int code
) override
abstract MessageCodeToString :
        code : int -> string
override MessageCodeToString :
        code : int -> string
abstract MessageCodeToString :
        code : int -> string
override MessageCodeToString :
        code : int -> string

Parameters

code
Type: Online System Int32

Return Value

Type: Online String

Implements

ICodeProcessor MessageCodeToString(Int32)
See Also
JSONData Class
JSONData Members
NFX.CodeAnalysis.JSON Namespace


JSONData.setData Method

JSONData setData Method NFX Class Library

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void setData(
    Object data
)
internal void setData(
    Object data
)
Friend Sub setData (
    data As Object
)
Friend Sub setData (
    data As Object
)
internal:
void setData(
    Object^ data
)
internal:
void setData(
    Object^ data
)
internal member setData :
        data : Object -> unit
internal member setData :
        data : Object -> unit

Parameters

data
Type: Online System Object
See Also
JSONData Class
JSONData Members
NFX.CodeAnalysis.JSON Namespace


JSONData Properties

JSONData Properties NFX Class Library

The JSONData type exposes the following members.
Properties
 | Name | Description
Public property | Context | Returns context that this processor operates under - an entity that retains state during analysis, such as: module compiler, project compiler, code unit translator etc. This entity may also contain compiler/parser/lexer options etc. (Inherited from CommonCodeProcessor.)
Public property | Language | (Overrides CommonCodeProcessor Language.)
Public property | Messages | References message list that lexer emitts messages into. May be null (Inherited from CommonCodeProcessor.)
Public property | ResultObject | (Inherited from ObjectResultAnalysisContext TObject .)
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any lexing error is always thrown regardless of this parameter (Inherited from CommonCodeProcessor.)
Back to Top
See Also
JSONData Class
NFX.CodeAnalysis.JSON Namespace


JSONData.Language Property

JSONData Language Property NFX Class Library

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Language Language { get; }
public override Language Language { get; }
Public Overrides ReadOnly Property Language As Language
    Get
Public Overrides ReadOnly Property Language As Language
    Get
public:
virtual property Language^ Language {
    Language^ get () override;
}
public:
virtual property Language^ Language {
    Language^ get () override;
}
abstract Language : Language with get
override Language : Language with get
abstract Language : Language with get
override Language : Language with get

Property Value

Type: Language

Implements

ICodeProcessor Language
See Also
JSONData Class
JSONData Members
NFX.CodeAnalysis.JSON Namespace


JSONIdentifiers Class

JSONIdentifiers Class NFX Class Library

Identifier validation and other utilities in context of JSON grammar
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis.JSON JSONIdentifiers

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class JSONIdentifiers
public static class JSONIdentifiers
Public NotInheritable Class JSONIdentifiers
Public NotInheritable Class JSONIdentifiers
public ref class JSONIdentifiers abstract sealed
public ref class JSONIdentifiers abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type JSONIdentifiers =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type JSONIdentifiers =  class end
See Also
JSONIdentifiers Members
NFX.CodeAnalysis.JSON Namespace


JSONIdentifiers Members

JSONIdentifiers Members NFX Class Library

The JSONIdentifiers type exposes the following members.
Methods
Name | Description
Validate | Checks whether supplied string is a valid JSON grammar identifier
ValidateChar | Checks whether supplied char is suitable for a part of JSON identifier
ValidateDigit | Checks to see whether supplied char is a digit
Back to Top
See Also
JSONIdentifiers Class
NFX.CodeAnalysis.JSON Namespace


JSONIdentifiers Methods

JSONIdentifiers Methods NFX Class Library

The JSONIdentifiers type exposes the following members.
Methods
Name | Description
Validate | Checks whether supplied string is a valid JSON grammar identifier
ValidateChar | Checks whether supplied char is suitable for a part of JSON identifier
ValidateDigit | Checks to see whether supplied char is a digit
Back to Top
See Also
JSONIdentifiers Class
NFX.CodeAnalysis.JSON Namespace


JSONIdentifiers.Validate Method

JSONIdentifiers Validate Method NFX Class Library

Checks whether supplied string is a valid JSON grammar identifier

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool Validate(
    string id
)
public static bool Validate(
    string id
)
Public Shared Function Validate (
    id As String
) As Boolean
Public Shared Function Validate (
    id As String
) As Boolean
public:
static bool Validate(
    String^ id
)
public:
static bool Validate(
    String^ id
)
static member Validate :
        id : string -> bool
static member Validate :
        id : string -> bool

Parameters

id
Type: Online System String

Return Value

Type: Online Boolean
See Also
JSONIdentifiers Class
JSONIdentifiers Members
NFX.CodeAnalysis.JSON Namespace


JSONIdentifiers.ValidateChar Method

JSONIdentifiers ValidateChar Method NFX Class Library

Checks whether supplied char is suitable for a part of JSON identifier

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool ValidateChar(
    char c
)
public static bool ValidateChar(
    char c
)
Public Shared Function ValidateChar (
    c As Char
) As Boolean
Public Shared Function ValidateChar (
    c As Char
) As Boolean
public:
static bool ValidateChar(
    wchar_t c
)
public:
static bool ValidateChar(
    wchar_t c
)
static member ValidateChar :
        c : char -> bool
static member ValidateChar :
        c : char -> bool

Parameters

c
Type: Online System Char

Return Value

Type: Online Boolean
See Also
JSONIdentifiers Class
JSONIdentifiers Members
NFX.CodeAnalysis.JSON Namespace


JSONIdentifiers.ValidateDigit Method

JSONIdentifiers ValidateDigit Method NFX Class Library

Checks to see whether supplied char is a digit

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool ValidateDigit(
    char c
)
public static bool ValidateDigit(
    char c
)
Public Shared Function ValidateDigit (
    c As Char
) As Boolean
Public Shared Function ValidateDigit (
    c As Char
) As Boolean
public:
static bool ValidateDigit(
    wchar_t c
)
public:
static bool ValidateDigit(
    wchar_t c
)
static member ValidateDigit :
        c : char -> bool
static member ValidateDigit :
        c : char -> bool

Parameters

c
Type: Online System Char

Return Value

Type: Online Boolean
See Also
JSONIdentifiers Class
JSONIdentifiers Members
NFX.CodeAnalysis.JSON Namespace


JSONKeywords Class

JSONKeywords Class NFX Class Library

Provides JSON keyword resolution services, this class is thread safe
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis.JSON JSONKeywords

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class JSONKeywords
public static class JSONKeywords
Public NotInheritable Class JSONKeywords
Public NotInheritable Class JSONKeywords
public ref class JSONKeywords abstract sealed
public ref class JSONKeywords abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type JSONKeywords =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type JSONKeywords =  class end
See Also
JSONKeywords Members
NFX.CodeAnalysis.JSON Namespace


JSONKeywords Members

JSONKeywords Members NFX Class Library

The JSONKeywords type exposes the following members.
Methods
Name | Description
Resolve | Resolves a JSON keyword - this method IS thread safe
Back to Top
See Also
JSONKeywords Class
NFX.CodeAnalysis.JSON Namespace


JSONKeywords Methods

JSONKeywords Methods NFX Class Library

The JSONKeywords type exposes the following members.
Methods
Name | Description
Resolve | Resolves a JSON keyword - this method IS thread safe
Back to Top
See Also
JSONKeywords Class
NFX.CodeAnalysis.JSON Namespace


JSONKeywords.Resolve Method

JSONKeywords Resolve Method NFX Class Library

Resolves a JSON keyword - this method IS thread safe

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static JSONTokenType Resolve(
    string str
)
public static JSONTokenType Resolve(
    string str
)
Public Shared Function Resolve (
    str As String
) As JSONTokenType
Public Shared Function Resolve (
    str As String
) As JSONTokenType
public:
static JSONTokenType Resolve(
    String^ str
)
public:
static JSONTokenType Resolve(
    String^ str
)
static member Resolve :
        str : string -> JSONTokenType
static member Resolve :
        str : string -> JSONTokenType

Parameters

str
Type: Online System String

Return Value

Type: JSONTokenType
See Also
JSONKeywords Class
JSONKeywords Members
NFX.CodeAnalysis.JSON Namespace


JSONLanguage Class

JSONLanguage Class NFX Class Library

Represents JSON language
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis Language
NFX.CodeAnalysis.JSON JSONLanguage

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class JSONLanguage : Language
public sealed class JSONLanguage : Language
Public NotInheritable Class JSONLanguage
    Inherits Language
Public NotInheritable Class JSONLanguage
    Inherits Language
public ref class JSONLanguage sealed : public Language
public ref class JSONLanguage sealed : public Language
[<SealedAttribute>]
type JSONLanguage =
    class
        inherit Language
    end
[<SealedAttribute>]
type JSONLanguage =
    class
        inherit Language
    end
See Also
JSONLanguage Members
NFX.CodeAnalysis.JSON Namespace


JSONLanguage Members

JSONLanguage Members NFX Class Library

The JSONLanguage type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeLexer | (Overrides Language MakeLexer(IAnalysisContext, SourceCodeRef, ISourceText, MessageList, Boolean).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from Language.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
Instance |
Back to Top
Properties
 | Name | Description
Public property | Family | (Overrides Language Family.)
Public property | FileExtensions | (Overrides Language FileExtensions.)
Back to Top
See Also
JSONLanguage Class
NFX.CodeAnalysis.JSON Namespace


JSONLanguage Fields

JSONLanguage Fields NFX Class Library

The JSONLanguage type exposes the following members.
Fields
Name | Description
Instance |
Back to Top
See Also
JSONLanguage Class
NFX.CodeAnalysis.JSON Namespace


JSONLanguage.Instance Field

JSONLanguage Instance Field NFX Class Library

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly JSONLanguage Instance
public static readonly JSONLanguage Instance
Public Shared ReadOnly Instance As JSONLanguage
Public Shared ReadOnly Instance As JSONLanguage
public:
static initonly JSONLanguage^ Instance
public:
static initonly JSONLanguage^ Instance
static val Instance: JSONLanguage
static val Instance: JSONLanguage

Field Value

Type: JSONLanguage
See Also
JSONLanguage Class
JSONLanguage Members
NFX.CodeAnalysis.JSON Namespace


JSONLanguage Methods

JSONLanguage Methods NFX Class Library

The JSONLanguage type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeLexer | (Overrides Language MakeLexer(IAnalysisContext, SourceCodeRef, ISourceText, MessageList, Boolean).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from Language.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
JSONLanguage Class
NFX.CodeAnalysis.JSON Namespace


JSONLanguage.MakeLexer Method

JSONLanguage MakeLexer Method NFX Class Library

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ILexer MakeLexer(
    IAnalysisContext context,
    SourceCodeRef srcRef,
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
public override ILexer MakeLexer(
    IAnalysisContext context,
    SourceCodeRef srcRef,
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
Public Overrides Function MakeLexer (
    context As IAnalysisContext,
    srcRef As SourceCodeRef,
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
) As ILexer
Public Overrides Function MakeLexer (
    context As IAnalysisContext,
    srcRef As SourceCodeRef,
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
) As ILexer
public:
virtual ILexer^ MakeLexer(
    IAnalysisContext^ context,
    SourceCodeRef srcRef,
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
) override
public:
virtual ILexer^ MakeLexer(
    IAnalysisContext^ context,
    SourceCodeRef srcRef,
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
) override
abstract MakeLexer :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> ILexer
override MakeLexer :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> ILexer
abstract MakeLexer :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> ILexer
override MakeLexer :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> ILexer

Parameters

context
Type: NFX.CodeAnalysis IAnalysisContext
srcRef
Type: NFX.CodeAnalysis.Source SourceCodeRef
source
Type: NFX.CodeAnalysis.Source ISourceText
messages (Optional)
Type: NFX.CodeAnalysis MessageList
throwErrors (Optional)
Type: Online System Boolean

Return Value

Type: ILexer
See Also
JSONLanguage Class
JSONLanguage Members
NFX.CodeAnalysis.JSON Namespace


JSONLanguage Properties

JSONLanguage Properties NFX Class Library

The JSONLanguage type exposes the following members.
Properties
 | Name | Description
Public property | Family | (Overrides Language Family.)
Public property | FileExtensions | (Overrides Language FileExtensions.)
Back to Top
See Also
JSONLanguage Class
NFX.CodeAnalysis.JSON Namespace


JSONLanguage.Family Property

JSONLanguage Family Property NFX Class Library

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override LanguageFamily Family { get; }
public override LanguageFamily Family { get; }
Public Overrides ReadOnly Property Family As LanguageFamily
    Get
Public Overrides ReadOnly Property Family As LanguageFamily
    Get
public:
virtual property LanguageFamily Family {
    LanguageFamily get () override;
}
public:
virtual property LanguageFamily Family {
    LanguageFamily get () override;
}
abstract Family : LanguageFamily with get
override Family : LanguageFamily with get
abstract Family : LanguageFamily with get
override Family : LanguageFamily with get

Property Value

Type: LanguageFamily
See Also
JSONLanguage Class
JSONLanguage Members
NFX.CodeAnalysis.JSON Namespace


JSONLanguage.FileExtensions Property

JSONLanguage FileExtensions Property NFX Class Library

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IEnumerable<string> FileExtensions { get; }
public override IEnumerable<string> FileExtensions { get; }
Public Overrides ReadOnly Property FileExtensions As IEnumerable(Of String)
    Get
Public Overrides ReadOnly Property FileExtensions As IEnumerable(Of String)
    Get
public:
virtual property IEnumerable<String^>^ FileExtensions {
    IEnumerable<String^>^ get () override;
}
public:
virtual property IEnumerable<String^>^ FileExtensions {
    IEnumerable<String^>^ get () override;
}
abstract FileExtensions : IEnumerable<string> with get
override FileExtensions : IEnumerable<string> with get
abstract FileExtensions : IEnumerable<string> with get
override FileExtensions : IEnumerable<string> with get

Property Value

Type: Online IEnumerable Online String
See Also
JSONLanguage Class
JSONLanguage Members
NFX.CodeAnalysis.JSON Namespace


JSONLexer Class

JSONLexer Class NFX Class Library

Performs lexical analysis on source supplied in JSON syntax. This class supports lazy analysis that happens gradually as result tokens are consumed through IEnumerable interface. NOTE: Although called JSON, this is really a JSON superset implementation that includes extra features: comments, directives, verbatim strings(start with $), ' or " string escapes, unquoted object key names
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis CommonCodeProcessor
NFX.CodeAnalysis SourceRefCommonCodeProcessor
NFX.CodeAnalysis Lexer JSONToken
NFX.CodeAnalysis.JSON JSONLexer

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class JSONLexer : Lexer<JSONToken>
public sealed class JSONLexer : Lexer<JSONToken>
Public NotInheritable Class JSONLexer
    Inherits Lexer(Of JSONToken)
Public NotInheritable Class JSONLexer
    Inherits Lexer(Of JSONToken)
public ref class JSONLexer sealed : public Lexer<JSONToken^>
public ref class JSONLexer sealed : public Lexer<JSONToken^>
[<SealedAttribute>]
type JSONLexer =
    class
        inherit Lexer<JSONToken>
    end
[<SealedAttribute>]
type JSONLexer =
    class
        inherit Lexer<JSONToken>
    end
See Also
JSONLexer Members
NFX.CodeAnalysis.JSON Namespace


JSONLexer Members

JSONLexer Members NFX Class Library

The JSONLexer type exposes the following members.
Constructors
 | Name | Description
Public method | JSONLexer(ISourceText, MessageList, Boolean) | Initializes a new instance of the JSONLexer class
Public method | JSONLexer(IAnalysisContext, SourceCodeRef, ISourceText, MessageList, Boolean) | Initializes a new instance of the JSONLexer class
Back to Top
Methods
 | Name | Description
Public method | AnalyzeAll | If lexer supports lazy analysis, forces analysis of the whole source (Inherited from Lexer TToken .)
Protected method | DoLexingChunk | (Overrides Lexer TToken DoLexingChunk .)
Protected method | EmitMessage(MessageType, Int32, SourcePosition, Token, String, Exception) | (Inherited from SourceRefCommonCodeProcessor.)
Protected method | EmitMessage(MessageType, Int32, SourceCodeRef, Nullable SourcePosition , Token, String, Exception) | (Inherited from CommonCodeProcessor.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | (Inherited from Lexer TToken .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MessageCodeToString | (Overrides CommonCodeProcessor MessageCodeToString(Int32).)
Public method | ToString | (Inherited from Lexer TToken .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_AllAnalyzed | (Inherited from Lexer TToken .)
Protected field | m_Tokens | (Inherited from Lexer TToken .)
Back to Top
Properties
 | Name | Description
Public property | AllAnalyzed | Returns true when the whole input source has been analyzed. This property is always true for lexers that do not support lazy analysis (Inherited from Lexer TToken .)
Public property | Context | Returns context that this processor operates under - an entity that retains state during analysis, such as: module compiler, project compiler, code unit translator etc. This entity may also contain compiler/parser/lexer options etc. (Inherited from CommonCodeProcessor.)
Public property | Language | (Overrides CommonCodeProcessor Language.)
Public property | Messages | References message list that lexer emitts messages into. May be null (Inherited from CommonCodeProcessor.)
Public property | Source | References source code text that was lexed (Inherited from Lexer TToken .)
Public property | SourceCodeReference | References source code that is processed (Inherited from SourceRefCommonCodeProcessor.)
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any lexing error is always thrown regardless of this parameter (Inherited from CommonCodeProcessor.)
Public property | Tokens | Returns tokenized source as indexable list. Accessing this property causes lexical analysis to complete on the whole source if it has not been completed yet (Inherited from Lexer TToken .)
Public property | TokenStream | Enumerates Token stream - depending on implementation enumeration may do lexical analysis token-by-token or in chunks with every enumerator advance (Inherited from Lexer TToken .)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Lexer TToken .)
Back to Top
See Also
JSONLexer Class
NFX.CodeAnalysis.JSON Namespace


JSONLexer Constructor

JSONLexer Constructor NFX Class Library

Overload List
 | Name | Description
Public method | JSONLexer(ISourceText, MessageList, Boolean) | Initializes a new instance of the JSONLexer class
Public method | JSONLexer(IAnalysisContext, SourceCodeRef, ISourceText, MessageList, Boolean) | Initializes a new instance of the JSONLexer class
Back to Top
See Also
JSONLexer Class
JSONLexer Members
NFX.CodeAnalysis.JSON Namespace


JSONLexer Constructor (ISourceText, MessageList, Boolean)

JSONLexer Constructor (ISourceText, MessageList, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the JSONLexer class

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONLexer(
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
public JSONLexer(
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
Public Sub New (
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
Public Sub New (
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
public:
JSONLexer(
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
public:
JSONLexer(
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
new :
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> JSONLexer
new :
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> JSONLexer

Parameters

source
Type: NFX.CodeAnalysis.Source ISourceText
messages (Optional)
Type: NFX.CodeAnalysis MessageList
throwErrors (Optional)
Type: Online System Boolean
See Also
JSONLexer Class
JSONLexer Members
JSONLexer Overload
NFX.CodeAnalysis.JSON Namespace


JSONLexer Constructor (IAnalysisContext, SourceCodeRef, ISourceText, MessageList, Boolean)

JSONLexer Constructor (IAnalysisContext, SourceCodeRef, ISourceText, MessageList, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the JSONLexer class

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONLexer(
    IAnalysisContext context,
    SourceCodeRef srcRef,
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
public JSONLexer(
    IAnalysisContext context,
    SourceCodeRef srcRef,
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
Public Sub New (
    context As IAnalysisContext,
    srcRef As SourceCodeRef,
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
Public Sub New (
    context As IAnalysisContext,
    srcRef As SourceCodeRef,
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
public:
JSONLexer(
    IAnalysisContext^ context,
    SourceCodeRef srcRef,
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
public:
JSONLexer(
    IAnalysisContext^ context,
    SourceCodeRef srcRef,
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
new :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> JSONLexer
new :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> JSONLexer

Parameters

context
Type: NFX.CodeAnalysis IAnalysisContext
srcRef
Type: NFX.CodeAnalysis.Source SourceCodeRef
source
Type: NFX.CodeAnalysis.Source ISourceText
messages (Optional)
Type: NFX.CodeAnalysis MessageList
throwErrors (Optional)
Type: Online System Boolean
See Also
JSONLexer Class
JSONLexer Members
JSONLexer Overload
NFX.CodeAnalysis.JSON Namespace


JSONLexer Fields

JSONLexer Fields NFX Class Library

The JSONLexer type exposes the following members.
Fields
 | Name | Description
Protected field | m_AllAnalyzed | (Inherited from Lexer TToken .)
Protected field | m_Tokens | (Inherited from Lexer TToken .)
Back to Top
See Also
JSONLexer Class
NFX.CodeAnalysis.JSON Namespace


JSONLexer Methods

JSONLexer Methods NFX Class Library

The JSONLexer type exposes the following members.
Methods
 | Name | Description
Public method | AnalyzeAll | If lexer supports lazy analysis, forces analysis of the whole source (Inherited from Lexer TToken .)
Protected method | DoLexingChunk | (Overrides Lexer TToken DoLexingChunk .)
Protected method | EmitMessage(MessageType, Int32, SourcePosition, Token, String, Exception) | (Inherited from SourceRefCommonCodeProcessor.)
Protected method | EmitMessage(MessageType, Int32, SourceCodeRef, Nullable SourcePosition , Token, String, Exception) | (Inherited from CommonCodeProcessor.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | (Inherited from Lexer TToken .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MessageCodeToString | (Overrides CommonCodeProcessor MessageCodeToString(Int32).)
Public method | ToString | (Inherited from Lexer TToken .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Lexer TToken .)
Back to Top
See Also
JSONLexer Class
NFX.CodeAnalysis.JSON Namespace


JSONLexer.DoLexingChunk Method

JSONLexer DoLexingChunk Method NFX Class Library

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool DoLexingChunk()
protected override bool DoLexingChunk()
Protected Overrides Function DoLexingChunk As Boolean
Protected Overrides Function DoLexingChunk As Boolean
protected:
virtual bool DoLexingChunk() override
protected:
virtual bool DoLexingChunk() override
abstract DoLexingChunk : unit -> bool
override DoLexingChunk : unit -> bool
abstract DoLexingChunk : unit -> bool
override DoLexingChunk : unit -> bool

Return Value

Type: Online Boolean
See Also
JSONLexer Class
JSONLexer Members
NFX.CodeAnalysis.JSON Namespace


JSONLexer.MessageCodeToString Method

JSONLexer MessageCodeToString Method NFX Class Library

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string MessageCodeToString(
    int code
)
public override string MessageCodeToString(
    int code
)
Public Overrides Function MessageCodeToString (
    code As Integer
) As String
Public Overrides Function MessageCodeToString (
    code As Integer
) As String
public:
virtual String^ MessageCodeToString(
    int code
) override
public:
virtual String^ MessageCodeToString(
    int code
) override
abstract MessageCodeToString :
        code : int -> string
override MessageCodeToString :
        code : int -> string
abstract MessageCodeToString :
        code : int -> string
override MessageCodeToString :
        code : int -> string

Parameters

code
Type: Online System Int32

Return Value

Type: Online String

Implements

ICodeProcessor MessageCodeToString(Int32)
See Also
JSONLexer Class
JSONLexer Members
NFX.CodeAnalysis.JSON Namespace


JSONLexer Properties

JSONLexer Properties NFX Class Library

The JSONLexer type exposes the following members.
Properties
 | Name | Description
Public property | AllAnalyzed | Returns true when the whole input source has been analyzed. This property is always true for lexers that do not support lazy analysis (Inherited from Lexer TToken .)
Public property | Context | Returns context that this processor operates under - an entity that retains state during analysis, such as: module compiler, project compiler, code unit translator etc. This entity may also contain compiler/parser/lexer options etc. (Inherited from CommonCodeProcessor.)
Public property | Language | (Overrides CommonCodeProcessor Language.)
Public property | Messages | References message list that lexer emitts messages into. May be null (Inherited from CommonCodeProcessor.)
Public property | Source | References source code text that was lexed (Inherited from Lexer TToken .)
Public property | SourceCodeReference | References source code that is processed (Inherited from SourceRefCommonCodeProcessor.)
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any lexing error is always thrown regardless of this parameter (Inherited from CommonCodeProcessor.)
Public property | Tokens | Returns tokenized source as indexable list. Accessing this property causes lexical analysis to complete on the whole source if it has not been completed yet (Inherited from Lexer TToken .)
Public property | TokenStream | Enumerates Token stream - depending on implementation enumeration may do lexical analysis token-by-token or in chunks with every enumerator advance (Inherited from Lexer TToken .)
Back to Top
See Also
JSONLexer Class
NFX.CodeAnalysis.JSON Namespace


JSONLexer.Language Property

JSONLexer Language Property NFX Class Library

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Language Language { get; }
public override Language Language { get; }
Public Overrides ReadOnly Property Language As Language
    Get
Public Overrides ReadOnly Property Language As Language
    Get
public:
virtual property Language^ Language {
    Language^ get () override;
}
public:
virtual property Language^ Language {
    Language^ get () override;
}
abstract Language : Language with get
override Language : Language with get
abstract Language : Language with get
override Language : Language with get

Property Value

Type: Language

Implements

ICodeProcessor Language
See Also
JSONLexer Class
JSONLexer Members
NFX.CodeAnalysis.JSON Namespace


JSONMsgCode Enumeration

JSONMsgCode Enumeration NFX Class Library

Message codes for JSON code processors

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum JSONMsgCode
public enum JSONMsgCode
Public Enumeration JSONMsgCode
Public Enumeration JSONMsgCode
public enum class JSONMsgCode
public enum class JSONMsgCode
type JSONMsgCode
type JSONMsgCode
Members
Member name | Value | Description
INFOS | 0 |
WARNING | 100 |
ERRORS | 1000 |
eUnterminatedString | 1001 |
ePrematureEOF | 1002 |
eUnterminatedComment | 1003 |
eInvalidStringEscape | 1004 |
eValueTooBig | 1005 |
eInvalidIdentifier | 1006 |
eSyntaxError | 1007 |
eUnterminatedArray | 1008 |
eUnterminatedObject | 1009 |
eObjectKeyExpected | 1010 |
eColonOperatorExpected | 1011 |
eNumericLiteralExpectedAfterSignOperator | 1012 |
eDuplicateObjectKey | 1013 |
See Also
NFX.CodeAnalysis.JSON Namespace


JSONNumbers Class

JSONNumbers Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis.JSON JSONNumbers

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class JSONNumbers
public static class JSONNumbers
Public NotInheritable Class JSONNumbers
Public NotInheritable Class JSONNumbers
public ref class JSONNumbers abstract sealed
public ref class JSONNumbers abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type JSONNumbers =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type JSONNumbers =  class end
See Also
JSONNumbers Members
NFX.CodeAnalysis.JSON Namespace


JSONNumbers Members

JSONNumbers Members NFX Class Library

The JSONNumbers type exposes the following members.
Methods
Name | Description
Convert | Tries to convert string to number, returns null if conversion could not be made
Back to Top
See Also
JSONNumbers Class
NFX.CodeAnalysis.JSON Namespace


JSONNumbers Methods

JSONNumbers Methods NFX Class Library

The JSONNumbers type exposes the following members.
Methods
Name | Description
Convert | Tries to convert string to number, returns null if conversion could not be made
Back to Top
See Also
JSONNumbers Class
NFX.CodeAnalysis.JSON Namespace


JSONNumbers.Convert Method

JSONNumbers Convert Method NFX Class Library

Tries to convert string to number, returns null if conversion could not be made

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Object Convert(
    string str,
    out JSONTokenType type
)
public static Object Convert(
    string str,
    out JSONTokenType type
)
Public Shared Function Convert (
    str As String,
    <OutAttribute> ByRef type As JSONTokenType
) As Object
Public Shared Function Convert (
    str As String,
    <OutAttribute> ByRef type As JSONTokenType
) As Object
public:
static Object^ Convert(
    String^ str,
    [OutAttribute] JSONTokenType% type
)
public:
static Object^ Convert(
    String^ str,
    [OutAttribute] JSONTokenType% type
)
static member Convert :
        str : string *
        type : JSONTokenType byref -> Object
static member Convert :
        str : string *
        type : JSONTokenType byref -> Object

Parameters

str
Type: Online System String
type
Type: NFX.CodeAnalysis.JSON JSONTokenType

Return Value

Type: Online Object
See Also
JSONNumbers Class
JSONNumbers Members
NFX.CodeAnalysis.JSON Namespace


JSONParser Class

JSONParser Class NFX Class Library

Parses JSON lexer output into object graphs. NOTE: Although called JSON, this is really a JSON superset implementation that includes extra features: comments, directives, verbatim strings(start with $), ' or " string escapes, unquoted object key names
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis CommonCodeProcessor
NFX.CodeAnalysis Parser JSONLexer
NFX.CodeAnalysis.JSON JSONParser

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class JSONParser : Parser<JSONLexer>
public sealed class JSONParser : Parser<JSONLexer>
Public NotInheritable Class JSONParser
    Inherits Parser(Of JSONLexer)
Public NotInheritable Class JSONParser
    Inherits Parser(Of JSONLexer)
public ref class JSONParser sealed : public Parser<JSONLexer^>
public ref class JSONParser sealed : public Parser<JSONLexer^>
[<SealedAttribute>]
type JSONParser =
    class
        inherit Parser<JSONLexer>
    end
[<SealedAttribute>]
type JSONParser =
    class
        inherit Parser<JSONLexer>
    end
See Also
JSONParser Members
NFX.CodeAnalysis.JSON Namespace


JSONParser Members

JSONParser Members NFX Class Library

The JSONParser type exposes the following members.
Constructors
 | Name | Description
Public method | JSONParser(JSONLexer, MessageList, Boolean, Boolean) | Initializes a new instance of the JSONParser class
Public method | JSONParser(JSONData, JSONLexer, MessageList, Boolean, Boolean) | Initializes a new instance of the JSONParser class
Back to Top
Methods
 | Name | Description
Protected method | DoParse | (Overrides Parser TLexer DoParse .)
Protected method | EmitMessage | (Inherited from CommonCodeProcessor.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MessageCodeToString | (Overrides CommonCodeProcessor MessageCodeToString(Int32).)
Public method | Parse | Performs parsing if it has not been performed yet (Inherited from Parser TLexer .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Context | Returns context that this processor operates under - an entity that retains state during analysis, such as: module compiler, project compiler, code unit translator etc. This entity may also contain compiler/parser/lexer options etc. (Inherited from CommonCodeProcessor.)
Public property | HasParsed | Indicates whether Parse() already happened (Inherited from Parser TLexer .)
Public property | Input | Returns lexers that feed this parser (Inherited from Parser TLexer .)
Public property | Language | (Overrides CommonCodeProcessor Language.)
Public property | Lexer |
Public property | Messages | References message list that lexer emitts messages into. May be null (Inherited from CommonCodeProcessor.)
Public property | ResultContext |
Public property | SourceInput | Lists source lexers that supply token stream for parsing (Inherited from Parser TLexer .)
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any lexing error is always thrown regardless of this parameter (Inherited from CommonCodeProcessor.)
Back to Top
See Also
JSONParser Class
NFX.CodeAnalysis.JSON Namespace


JSONParser Constructor

JSONParser Constructor NFX Class Library

Overload List
 | Name | Description
Public method | JSONParser(JSONLexer, MessageList, Boolean, Boolean) | Initializes a new instance of the JSONParser class
Public method | JSONParser(JSONData, JSONLexer, MessageList, Boolean, Boolean) | Initializes a new instance of the JSONParser class
Back to Top
See Also
JSONParser Class
JSONParser Members
NFX.CodeAnalysis.JSON Namespace


JSONParser Constructor (JSONLexer, MessageList, Boolean, Boolean)

JSONParser Constructor (JSONLexer, MessageList, Boolean, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the JSONParser class

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONParser(
    JSONLexer input,
    MessageList messages = null,
    bool throwErrors = false,
    bool caseSensitiveMaps = true
)
public JSONParser(
    JSONLexer input,
    MessageList messages = null,
    bool throwErrors = false,
    bool caseSensitiveMaps = true
)
Public Sub New (
    input As JSONLexer,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false,
    Optional caseSensitiveMaps As Boolean = true
)
Public Sub New (
    input As JSONLexer,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false,
    Optional caseSensitiveMaps As Boolean = true
)
public:
JSONParser(
    JSONLexer^ input,
    MessageList^ messages = nullptr,
    bool throwErrors = false,
    bool caseSensitiveMaps = true
)
public:
JSONParser(
    JSONLexer^ input,
    MessageList^ messages = nullptr,
    bool throwErrors = false,
    bool caseSensitiveMaps = true
)
new :
        input : JSONLexer *
        ?messages : MessageList *
        ?throwErrors : bool *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> JSONParser
new :
        input : JSONLexer *
        ?messages : MessageList *
        ?throwErrors : bool *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> JSONParser

Parameters

input
Type: NFX.CodeAnalysis.JSON JSONLexer
messages (Optional)
Type: NFX.CodeAnalysis MessageList
throwErrors (Optional)
Type: Online System Boolean
caseSensitiveMaps (Optional)
Type: Online System Boolean
See Also
JSONParser Class
JSONParser Members
JSONParser Overload
NFX.CodeAnalysis.JSON Namespace


JSONParser Constructor (JSONData, JSONLexer, MessageList, Boolean, Boolean)

JSONParser Constructor (JSONData, JSONLexer, MessageList, Boolean, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the JSONParser class

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONParser(
    JSONData context,
    JSONLexer input,
    MessageList messages = null,
    bool throwErrors = false,
    bool caseSensitiveMaps = true
)
public JSONParser(
    JSONData context,
    JSONLexer input,
    MessageList messages = null,
    bool throwErrors = false,
    bool caseSensitiveMaps = true
)
Public Sub New (
    context As JSONData,
    input As JSONLexer,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false,
    Optional caseSensitiveMaps As Boolean = true
)
Public Sub New (
    context As JSONData,
    input As JSONLexer,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false,
    Optional caseSensitiveMaps As Boolean = true
)
public:
JSONParser(
    JSONData^ context,
    JSONLexer^ input,
    MessageList^ messages = nullptr,
    bool throwErrors = false,
    bool caseSensitiveMaps = true
)
public:
JSONParser(
    JSONData^ context,
    JSONLexer^ input,
    MessageList^ messages = nullptr,
    bool throwErrors = false,
    bool caseSensitiveMaps = true
)
new :
        context : JSONData *
        input : JSONLexer *
        ?messages : MessageList *
        ?throwErrors : bool *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> JSONParser
new :
        context : JSONData *
        input : JSONLexer *
        ?messages : MessageList *
        ?throwErrors : bool *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> JSONParser

Parameters

context
Type: NFX.CodeAnalysis.JSON JSONData
input
Type: NFX.CodeAnalysis.JSON JSONLexer
messages (Optional)
Type: NFX.CodeAnalysis MessageList
throwErrors (Optional)
Type: Online System Boolean
caseSensitiveMaps (Optional)
Type: Online System Boolean
See Also
JSONParser Class
JSONParser Members
JSONParser Overload
NFX.CodeAnalysis.JSON Namespace


JSONParser Methods

JSONParser Methods NFX Class Library

The JSONParser type exposes the following members.
Methods
 | Name | Description
Protected method | DoParse | (Overrides Parser TLexer DoParse .)
Protected method | EmitMessage | (Inherited from CommonCodeProcessor.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MessageCodeToString | (Overrides CommonCodeProcessor MessageCodeToString(Int32).)
Public method | Parse | Performs parsing if it has not been performed yet (Inherited from Parser TLexer .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
JSONParser Class
NFX.CodeAnalysis.JSON Namespace


JSONParser.DoParse Method

JSONParser DoParse Method NFX Class Library

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoParse()
protected override void DoParse()
Protected Overrides Sub DoParse
Protected Overrides Sub DoParse
protected:
virtual void DoParse() override
protected:
virtual void DoParse() override
abstract DoParse : unit -> unit
override DoParse : unit -> unit
abstract DoParse : unit -> unit
override DoParse : unit -> unit
See Also
JSONParser Class
JSONParser Members
NFX.CodeAnalysis.JSON Namespace


JSONParser.MessageCodeToString Method

JSONParser MessageCodeToString Method NFX Class Library

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string MessageCodeToString(
    int code
)
public override string MessageCodeToString(
    int code
)
Public Overrides Function MessageCodeToString (
    code As Integer
) As String
Public Overrides Function MessageCodeToString (
    code As Integer
) As String
public:
virtual String^ MessageCodeToString(
    int code
) override
public:
virtual String^ MessageCodeToString(
    int code
) override
abstract MessageCodeToString :
        code : int -> string
override MessageCodeToString :
        code : int -> string
abstract MessageCodeToString :
        code : int -> string
override MessageCodeToString :
        code : int -> string

Parameters

code
Type: Online System Int32

Return Value

Type: Online String

Implements

ICodeProcessor MessageCodeToString(Int32)
See Also
JSONParser Class
JSONParser Members
NFX.CodeAnalysis.JSON Namespace


JSONParser Properties

JSONParser Properties NFX Class Library

The JSONParser type exposes the following members.
Properties
 | Name | Description
Public property | Context | Returns context that this processor operates under - an entity that retains state during analysis, such as: module compiler, project compiler, code unit translator etc. This entity may also contain compiler/parser/lexer options etc. (Inherited from CommonCodeProcessor.)
Public property | HasParsed | Indicates whether Parse() already happened (Inherited from Parser TLexer .)
Public property | Input | Returns lexers that feed this parser (Inherited from Parser TLexer .)
Public property | Language | (Overrides CommonCodeProcessor Language.)
Public property | Lexer |
Public property | Messages | References message list that lexer emitts messages into. May be null (Inherited from CommonCodeProcessor.)
Public property | ResultContext |
Public property | SourceInput | Lists source lexers that supply token stream for parsing (Inherited from Parser TLexer .)
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any lexing error is always thrown regardless of this parameter (Inherited from CommonCodeProcessor.)
Back to Top
See Also
JSONParser Class
NFX.CodeAnalysis.JSON Namespace


JSONParser.Language Property

JSONParser Language Property NFX Class Library

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Language Language { get; }
public override Language Language { get; }
Public Overrides ReadOnly Property Language As Language
    Get
Public Overrides ReadOnly Property Language As Language
    Get
public:
virtual property Language^ Language {
    Language^ get () override;
}
public:
virtual property Language^ Language {
    Language^ get () override;
}
abstract Language : Language with get
override Language : Language with get
abstract Language : Language with get
override Language : Language with get

Property Value

Type: Language

Implements

ICodeProcessor Language
See Also
JSONParser Class
JSONParser Members
NFX.CodeAnalysis.JSON Namespace


JSONParser.Lexer Property

JSONParser Lexer Property NFX Class Library

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONLexer Lexer { get; }
public JSONLexer Lexer { get; }
Public ReadOnly Property Lexer As JSONLexer
    Get
Public ReadOnly Property Lexer As JSONLexer
    Get
public:
property JSONLexer^ Lexer {
    JSONLexer^ get ();
}
public:
property JSONLexer^ Lexer {
    JSONLexer^ get ();
}
member Lexer : JSONLexer with get
member Lexer : JSONLexer with get

Property Value

Type: JSONLexer
See Also
JSONParser Class
JSONParser Members
NFX.CodeAnalysis.JSON Namespace


JSONParser.ResultContext Property

JSONParser ResultContext Property NFX Class Library

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONData ResultContext { get; }
public JSONData ResultContext { get; }
Public ReadOnly Property ResultContext As JSONData
    Get
Public ReadOnly Property ResultContext As JSONData
    Get
public:
property JSONData^ ResultContext {
    JSONData^ get ();
}
public:
property JSONData^ ResultContext {
    JSONData^ get ();
}
member ResultContext : JSONData with get
member ResultContext : JSONData with get

Property Value

Type: JSONData
See Also
JSONParser Class
JSONParser Members
NFX.CodeAnalysis.JSON Namespace


JSONPatternMatchAttribute Class

JSONPatternMatchAttribute Class NFX Class Library

Base class for JSON pattern matching
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.CodeAnalysis.JSON JSONPatternMatchAttribute

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.All, AllowMultiple = true, Inherited = true)]
public abstract class JSONPatternMatchAttribute : Attribute
[AttributeUsageAttribute(AttributeTargets.All, AllowMultiple = true, Inherited = true)]
public abstract class JSONPatternMatchAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.All, AllowMultiple := true, Inherited := true)>
Public MustInherit Class JSONPatternMatchAttribute
    Inherits Attribute
<AttributeUsageAttribute(AttributeTargets.All, AllowMultiple := true, Inherited := true)>
Public MustInherit Class JSONPatternMatchAttribute
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::All, AllowMultiple = true, Inherited = true)]
public ref class JSONPatternMatchAttribute abstract : public Attribute
[AttributeUsageAttribute(AttributeTargets::All, AllowMultiple = true, Inherited = true)]
public ref class JSONPatternMatchAttribute abstract : public Attribute
[<AbstractClassAttribute>]
[<AttributeUsageAttribute(AttributeTargets.All, AllowMultiple = true, Inherited = true)>]
type JSONPatternMatchAttribute =
    class
        inherit Attribute
    end
[<AbstractClassAttribute>]
[<AttributeUsageAttribute(AttributeTargets.All, AllowMultiple = true, Inherited = true)>]
type JSONPatternMatchAttribute =
    class
        inherit Attribute
    end
See Also
JSONPatternMatchAttribute Members
NFX.CodeAnalysis.JSON Namespace


JSONPatternMatchAttribute Members

JSONPatternMatchAttribute Members NFX Class Library

The JSONPatternMatchAttribute type exposes the following members.
Constructors
 | Name | Description
Protected method | JSONPatternMatchAttribute | Initializes a new instance of the JSONPatternMatchAttribute class
Back to Top
Methods
 | Name | Description
 | Check | Checks all pattern match attributes against specified member info until first match found
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Public method | Match(JSONLexer) | Override to perform actual pattern matching, i.e. the one that uses FSM
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
JSONPatternMatchAttribute Class
NFX.CodeAnalysis.JSON Namespace


JSONPatternMatchAttribute Constructor

JSONPatternMatchAttribute Constructor NFX Class Library

Initializes a new instance of the JSONPatternMatchAttribute class

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected JSONPatternMatchAttribute()
protected JSONPatternMatchAttribute()
Protected Sub New
Protected Sub New
protected:
JSONPatternMatchAttribute()
protected:
JSONPatternMatchAttribute()
new : unit -> JSONPatternMatchAttribute
new : unit -> JSONPatternMatchAttribute
See Also
JSONPatternMatchAttribute Class
JSONPatternMatchAttribute Members
NFX.CodeAnalysis.JSON Namespace


JSONPatternMatchAttribute Methods

JSONPatternMatchAttribute Methods NFX Class Library

The JSONPatternMatchAttribute type exposes the following members.
Methods
 | Name | Description
 | Check | Checks all pattern match attributes against specified member info until first match found
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Public method | Match(JSONLexer) | Override to perform actual pattern matching, i.e. the one that uses FSM
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
JSONPatternMatchAttribute Class
NFX.CodeAnalysis.JSON Namespace


JSONPatternMatchAttribute.Check Method

JSONPatternMatchAttribute Check Method NFX Class Library

Checks all pattern match attributes against specified member info until first match found

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool Check(
    MemberInfo info,
    JSONLexer content
)
public static bool Check(
    MemberInfo info,
    JSONLexer content
)
Public Shared Function Check (
    info As MemberInfo,
    content As JSONLexer
) As Boolean
Public Shared Function Check (
    info As MemberInfo,
    content As JSONLexer
) As Boolean
public:
static bool Check(
    MemberInfo^ info,
    JSONLexer^ content
)
public:
static bool Check(
    MemberInfo^ info,
    JSONLexer^ content
)
static member Check :
        info : MemberInfo *
        content : JSONLexer -> bool
static member Check :
        info : MemberInfo *
        content : JSONLexer -> bool

Parameters

info
Type: Online System.Reflection MemberInfo
content
Type: NFX.CodeAnalysis.JSON JSONLexer

Return Value

Type: Online Boolean
See Also
JSONPatternMatchAttribute Class
JSONPatternMatchAttribute Members
NFX.CodeAnalysis.JSON Namespace


JSONPatternMatchAttribute.Match Method

JSONPatternMatchAttribute Match Method NFX Class Library

Overload List
 | Name | Description
Public method | Online Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Public method | Match(JSONLexer) | Override to perform actual pattern matching, i.e. the one that uses FSM
Back to Top
See Also
JSONPatternMatchAttribute Class
JSONPatternMatchAttribute Members
NFX.CodeAnalysis.JSON Namespace


JSONPatternMatchAttribute.Match Method (JSONLexer)

JSONPatternMatchAttribute Match Method (JSONLexer) NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to perform actual pattern matching, i.e. the one that uses FSM

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool Match(
    JSONLexer content
)
public abstract bool Match(
    JSONLexer content
)
Public MustOverride Function Match (
    content As JSONLexer
) As Boolean
Public MustOverride Function Match (
    content As JSONLexer
) As Boolean
public:
virtual bool Match(
    JSONLexer^ content
) abstract
public:
virtual bool Match(
    JSONLexer^ content
) abstract
abstract Match :
        content : JSONLexer -> bool
abstract Match :
        content : JSONLexer -> bool

Parameters

content
Type: NFX.CodeAnalysis.JSON JSONLexer

Return Value

Type: Online Boolean
See Also
JSONPatternMatchAttribute Class
JSONPatternMatchAttribute Members
Match Overload
NFX.CodeAnalysis.JSON Namespace


JSONPatternMatchAttribute Properties

JSONPatternMatchAttribute Properties NFX Class Library

The JSONPatternMatchAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
JSONPatternMatchAttribute Class
NFX.CodeAnalysis.JSON Namespace


JSONStrings Class

JSONStrings Class NFX Class Library

Provides JSON string escape parsing
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis.JSON JSONStrings

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class JSONStrings
public static class JSONStrings
Public NotInheritable Class JSONStrings
Public NotInheritable Class JSONStrings
public ref class JSONStrings abstract sealed
public ref class JSONStrings abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type JSONStrings =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type JSONStrings =  class end
See Also
JSONStrings Members
NFX.CodeAnalysis.JSON Namespace


JSONStrings Members

JSONStrings Members NFX Class Library

The JSONStrings type exposes the following members.
Methods
Name | Description
UnescapeString |
Back to Top
See Also
JSONStrings Class
NFX.CodeAnalysis.JSON Namespace


JSONStrings Methods

JSONStrings Methods NFX Class Library

The JSONStrings type exposes the following members.
Methods
Name | Description
UnescapeString |
Back to Top
See Also
JSONStrings Class
NFX.CodeAnalysis.JSON Namespace


JSONStrings.UnescapeString Method

JSONStrings UnescapeString Method NFX Class Library

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string UnescapeString(
    string str
)
public static string UnescapeString(
    string str
)
Public Shared Function UnescapeString (
    str As String
) As String
Public Shared Function UnescapeString (
    str As String
) As String
public:
static String^ UnescapeString(
    String^ str
)
public:
static String^ UnescapeString(
    String^ str
)
static member UnescapeString :
        str : string -> string
static member UnescapeString :
        str : string -> string

Parameters

str
Type: Online System String

Return Value

Type: Online String
See Also
JSONStrings Class
JSONStrings Members
NFX.CodeAnalysis.JSON Namespace


JSONToken Class

JSONToken Class NFX Class Library

Represents a token of JSON language
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis Token
NFX.CodeAnalysis.JSON JSONToken

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class JSONToken : Token
public class JSONToken : Token
Public Class JSONToken
    Inherits Token
Public Class JSONToken
    Inherits Token
public ref class JSONToken : public Token
public ref class JSONToken : public Token
type JSONToken =
    class
        inherit Token
    end
type JSONToken =
    class
        inherit Token
    end
See Also
JSONToken Members
NFX.CodeAnalysis.JSON Namespace


JSONToken Members

JSONToken Members NFX Class Library

The JSONToken type exposes the following members.
Constructors
 | Name | Description
Public method | JSONToken | Initializes a new instance of the JSONToken class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Token ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | EndPosition | (Inherited from Token.)
Public field | Lexer | (Inherited from Token.)
Public field | StartPosition | (Inherited from Token.)
Public field | Text | (Inherited from Token.)
Public field | Type |
Public field | Value | (Inherited from Token.)
Back to Top
Properties
 | Name | Description
Public property | IsBOF | Indicates whether this token indicates an BEGINNING-OF-FILE condition (Inherited from Token.)
Public property | IsComment | Indicates whether this token represents a comment (Inherited from Token.)
Public property | IsDirective | Indicates whether this token represents a directive (Inherited from Token.)
Public property | IsEOF | Indicates whether this token indicates an END-OF-FILE condition (Inherited from Token.)
Public property | IsIdentifier | Indicates whether this token represents an identifier (Inherited from Token.)
Public property | IsKeyword | Indicates whether this token represents a language keyword (Inherited from Token.)
Public property | IsLiteral | Indicates whether this token represents a literal (Inherited from Token.)
Public property | IsNonLanguage | (Overrides Token IsNonLanguage.)
Public property | IsNumericLiteral | (Overrides Token IsNumericLiteral.)
Public property | IsOperator | Indicates whether this token represents an operator (Inherited from Token.)
Public property | IsPrimary | (Overrides Token IsPrimary.)
Public property | IsSymbol | Indicates whether this token represents a symbol (Inherited from Token.)
Public property | IsTextualLiteral | (Overrides Token IsTextualLiteral.)
Public property | Kind | (Overrides Token Kind.)
Public property | Language | (Overrides Token Language.)
Public property | OrdinalType | (Overrides Token OrdinalType.)
Back to Top
See Also
JSONToken Class
NFX.CodeAnalysis.JSON Namespace


JSONToken Constructor

JSONToken Constructor NFX Class Library

Initializes a new instance of the JSONToken class

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONToken(
    JSONLexer lexer,
    JSONTokenType type,
    SourcePosition startPos,
    SourcePosition endPos,
    string text,
    Object value = null
)
public JSONToken(
    JSONLexer lexer,
    JSONTokenType type,
    SourcePosition startPos,
    SourcePosition endPos,
    string text,
    Object value = null
)
Public Sub New (
    lexer As JSONLexer,
    type As JSONTokenType,
    startPos As SourcePosition,
    endPos As SourcePosition,
    text As String,
    Optional value As Object = Nothing
)
Public Sub New (
    lexer As JSONLexer,
    type As JSONTokenType,
    startPos As SourcePosition,
    endPos As SourcePosition,
    text As String,
    Optional value As Object = Nothing
)
public:
JSONToken(
    JSONLexer^ lexer,
    JSONTokenType type,
    SourcePosition startPos,
    SourcePosition endPos,
    String^ text,
    Object^ value = nullptr
)
public:
JSONToken(
    JSONLexer^ lexer,
    JSONTokenType type,
    SourcePosition startPos,
    SourcePosition endPos,
    String^ text,
    Object^ value = nullptr
)
new :
        lexer : JSONLexer *
        type : JSONTokenType *
        startPos : SourcePosition *
        endPos : SourcePosition *
        text : string *
        ?value : Object
(* Defaults:
        let _value = defaultArg value null
*)
-> JSONToken
new :
        lexer : JSONLexer *
        type : JSONTokenType *
        startPos : SourcePosition *
        endPos : SourcePosition *
        text : string *
        ?value : Object
(* Defaults:
        let _value = defaultArg value null
*)
-> JSONToken

Parameters

lexer
Type: NFX.CodeAnalysis.JSON JSONLexer
type
Type: NFX.CodeAnalysis.JSON JSONTokenType
startPos
Type: NFX.CodeAnalysis.Source SourcePosition
endPos
Type: NFX.CodeAnalysis.Source SourcePosition
text
Type: Online System String
value (Optional)
Type: Online System Object
See Also
JSONToken Class
JSONToken Members
NFX.CodeAnalysis.JSON Namespace


JSONToken Fields

JSONToken Fields NFX Class Library

The JSONToken type exposes the following members.
Fields
 | Name | Description
Public field | EndPosition | (Inherited from Token.)
Public field | Lexer | (Inherited from Token.)
Public field | StartPosition | (Inherited from Token.)
Public field | Text | (Inherited from Token.)
Public field | Type |
Public field | Value | (Inherited from Token.)
Back to Top
See Also
JSONToken Class
NFX.CodeAnalysis.JSON Namespace


JSONToken.Type Field

JSONToken Type Field NFX Class Library

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly JSONTokenType Type
public readonly JSONTokenType Type
Public ReadOnly Type As JSONTokenType
Public ReadOnly Type As JSONTokenType
public:
initonly JSONTokenType Type
public:
initonly JSONTokenType Type
val Type: JSONTokenType
val Type: JSONTokenType

Field Value

Type: JSONTokenType
See Also
JSONToken Class
JSONToken Members
NFX.CodeAnalysis.JSON Namespace


JSONToken Methods

JSONToken Methods NFX Class Library

The JSONToken type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Token ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
JSONToken Class
NFX.CodeAnalysis.JSON Namespace


JSONToken.ToString Method

JSONToken ToString Method NFX Class Library

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
JSONToken Class
JSONToken Members
NFX.CodeAnalysis.JSON Namespace


JSONToken Properties

JSONToken Properties NFX Class Library

The JSONToken type exposes the following members.
Properties
 | Name | Description
Public property | IsBOF | Indicates whether this token indicates an BEGINNING-OF-FILE condition (Inherited from Token.)
Public property | IsComment | Indicates whether this token represents a comment (Inherited from Token.)
Public property | IsDirective | Indicates whether this token represents a directive (Inherited from Token.)
Public property | IsEOF | Indicates whether this token indicates an END-OF-FILE condition (Inherited from Token.)
Public property | IsIdentifier | Indicates whether this token represents an identifier (Inherited from Token.)
Public property | IsKeyword | Indicates whether this token represents a language keyword (Inherited from Token.)
Public property | IsLiteral | Indicates whether this token represents a literal (Inherited from Token.)
Public property | IsNonLanguage | (Overrides Token IsNonLanguage.)
Public property | IsNumericLiteral | (Overrides Token IsNumericLiteral.)
Public property | IsOperator | Indicates whether this token represents an operator (Inherited from Token.)
Public property | IsPrimary | (Overrides Token IsPrimary.)
Public property | IsSymbol | Indicates whether this token represents a symbol (Inherited from Token.)
Public property | IsTextualLiteral | (Overrides Token IsTextualLiteral.)
Public property | Kind | (Overrides Token Kind.)
Public property | Language | (Overrides Token Language.)
Public property | OrdinalType | (Overrides Token OrdinalType.)
Back to Top
See Also
JSONToken Class
NFX.CodeAnalysis.JSON Namespace


JSONToken.IsNonLanguage Property

JSONToken IsNonLanguage Property NFX Class Library

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsNonLanguage { get; }
public override bool IsNonLanguage { get; }
Public Overrides ReadOnly Property IsNonLanguage As Boolean
    Get
Public Overrides ReadOnly Property IsNonLanguage As Boolean
    Get
public:
virtual property bool IsNonLanguage {
    bool get () override;
}
public:
virtual property bool IsNonLanguage {
    bool get () override;
}
abstract IsNonLanguage : bool with get
override IsNonLanguage : bool with get
abstract IsNonLanguage : bool with get
override IsNonLanguage : bool with get

Property Value

Type: Online Boolean
See Also
JSONToken Class
JSONToken Members
NFX.CodeAnalysis.JSON Namespace


JSONToken.IsNumericLiteral Property

JSONToken IsNumericLiteral Property NFX Class Library

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsNumericLiteral { get; }
public override bool IsNumericLiteral { get; }
Public Overrides ReadOnly Property IsNumericLiteral As Boolean
    Get
Public Overrides ReadOnly Property IsNumericLiteral As Boolean
    Get
public:
virtual property bool IsNumericLiteral {
    bool get () override;
}
public:
virtual property bool IsNumericLiteral {
    bool get () override;
}
abstract IsNumericLiteral : bool with get
override IsNumericLiteral : bool with get
abstract IsNumericLiteral : bool with get
override IsNumericLiteral : bool with get

Property Value

Type: Online Boolean
See Also
JSONToken Class
JSONToken Members
NFX.CodeAnalysis.JSON Namespace


JSONToken.IsPrimary Property

JSONToken IsPrimary Property NFX Class Library

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsPrimary { get; }
public override bool IsPrimary { get; }
Public Overrides ReadOnly Property IsPrimary As Boolean
    Get
Public Overrides ReadOnly Property IsPrimary As Boolean
    Get
public:
virtual property bool IsPrimary {
    bool get () override;
}
public:
virtual property bool IsPrimary {
    bool get () override;
}
abstract IsPrimary : bool with get
override IsPrimary : bool with get
abstract IsPrimary : bool with get
override IsPrimary : bool with get

Property Value

Type: Online Boolean
See Also
JSONToken Class
JSONToken Members
NFX.CodeAnalysis.JSON Namespace


JSONToken.IsTextualLiteral Property

JSONToken IsTextualLiteral Property NFX Class Library

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsTextualLiteral { get; }
public override bool IsTextualLiteral { get; }
Public Overrides ReadOnly Property IsTextualLiteral As Boolean
    Get
Public Overrides ReadOnly Property IsTextualLiteral As Boolean
    Get
public:
virtual property bool IsTextualLiteral {
    bool get () override;
}
public:
virtual property bool IsTextualLiteral {
    bool get () override;
}
abstract IsTextualLiteral : bool with get
override IsTextualLiteral : bool with get
abstract IsTextualLiteral : bool with get
override IsTextualLiteral : bool with get

Property Value

Type: Online Boolean
See Also
JSONToken Class
JSONToken Members
NFX.CodeAnalysis.JSON Namespace


JSONToken.Kind Property

JSONToken Kind Property NFX Class Library

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TokenKind Kind { get; }
public override TokenKind Kind { get; }
Public Overrides ReadOnly Property Kind As TokenKind
    Get
Public Overrides ReadOnly Property Kind As TokenKind
    Get
public:
virtual property TokenKind Kind {
    TokenKind get () override;
}
public:
virtual property TokenKind Kind {
    TokenKind get () override;
}
abstract Kind : TokenKind with get
override Kind : TokenKind with get
abstract Kind : TokenKind with get
override Kind : TokenKind with get

Property Value

Type: TokenKind
See Also
JSONToken Class
JSONToken Members
NFX.CodeAnalysis.JSON Namespace


JSONToken.Language Property

JSONToken Language Property NFX Class Library

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Language Language { get; }
public override Language Language { get; }
Public Overrides ReadOnly Property Language As Language
    Get
Public Overrides ReadOnly Property Language As Language
    Get
public:
virtual property Language^ Language {
    Language^ get () override;
}
public:
virtual property Language^ Language {
    Language^ get () override;
}
abstract Language : Language with get
override Language : Language with get
abstract Language : Language with get
override Language : Language with get

Property Value

Type: Language
See Also
JSONToken Class
JSONToken Members
NFX.CodeAnalysis.JSON Namespace


JSONToken.OrdinalType Property

JSONToken OrdinalType Property NFX Class Library

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int OrdinalType { get; }
public override int OrdinalType { get; }
Public Overrides ReadOnly Property OrdinalType As Integer
    Get
Public Overrides ReadOnly Property OrdinalType As Integer
    Get
public:
virtual property int OrdinalType {
    int get () override;
}
public:
virtual property int OrdinalType {
    int get () override;
}
abstract OrdinalType : int with get
override OrdinalType : int with get
abstract OrdinalType : int with get
override OrdinalType : int with get

Property Value

Type: Online Int32
See Also
JSONToken Class
JSONToken Members
NFX.CodeAnalysis.JSON Namespace


JSONTokenType Enumeration

JSONTokenType Enumeration NFX Class Library

Denotes JSON token types. NOTE: Although called JSON, this is really a JSON superset implementation that includes extra features: comments, directives, verbatim strings(start with $), ' or " string escapes, unquoted object key names

Namespace: NFX.CodeAnalysis.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum JSONTokenType
public enum JSONTokenType
Public Enumeration JSONTokenType
Public Enumeration JSONTokenType
public enum class JSONTokenType
public enum class JSONTokenType
type JSONTokenType
type JSONTokenType
Members
Member name | Value | Description
tUnknown | 0 |
NONLANG_START | 1 |
tBOF | 2 |
tEOF | 3 |
tDirective | 4 |
NONLANG_END | 5 |
tComment | 6 |
SYMBOLS_START | 7 |
tComma | 8 |
tBraceOpen | 9 |
tBraceClose | 10 |
tSqBracketOpen | 11 |
tSqBracketClose | 12 |
tDot | 13 |
SYMBOLS_END | 14 |
tIdentifier | 15 |
tPlus | 16 |
tMinus | 17 |
tColon | 18 |
LITERALS_START | 19 |
NUMLITERALS_START | 20 |
tIntLiteral | 21 |
tLongIntLiteral | 22 |
tDoubleLiteral | 23 |
NUMLITERALS_END | 24 |
tStringLiteral | 25 |
tTrue | 26 |
tFalse | 27 |
tNull | 28 |
LITERALS_END | 29 |
See Also
NFX.CodeAnalysis.JSON Namespace


NFX.CodeAnalysis.Laconfig Namespace

NFX.CodeAnalysis.Laconfig Namespace NFX Class Library

Provides functions for working with Laconic Configuration syntax
Classes
 | Class | Description
Public class | LaconfigData | Represets laconfig parser result
Public class | LaconfigKeywords | Provides Laconfig keyword resolution services, this class is thread safe
Public class | LaconfigLanguage | Represents Laconic + Config = Laconfig terse configuration language
Public class | LaconfigLexer | Performs lexical analysis on source supplied in Laconfig syntax. This class supports lazy analysis that happens gradually as result tokens are consumed through IEnumerable interface.
Public class | LaconfigParser | Parses Laconfig lexer output into laconic configuration node graph
Public class | LaconfigToken | Represents a token of Laconfig language
Public class | LaconfigWriter | Writes Laconic Configuration into a stream or string
Public class | LaconfigWritingOptions | Specifies how Laconic configuration should be written as text. Use LaconfigWritingOptions.Compact or LaconfigWritingOptions.PrettyPrint static properties for typical options
Enumerations
 | Enumeration | Description
Public enumeration | LaconfigMsgCode | Message codes for Laconfig code processors
Public enumeration | LaconfigTokenType | Denotes Laconfig token types


LaconfigData Class

LaconfigData Class NFX Class Library

Represets laconfig parser result
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis CommonCodeProcessor
NFX.CodeAnalysis ObjectResultAnalysisContext LaconicConfiguration
NFX.CodeAnalysis.Laconfig LaconfigData

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class LaconfigData : ObjectResultAnalysisContext<LaconicConfiguration>
public sealed class LaconfigData : ObjectResultAnalysisContext<LaconicConfiguration>
Public NotInheritable Class LaconfigData
    Inherits ObjectResultAnalysisContext(Of LaconicConfiguration)
Public NotInheritable Class LaconfigData
    Inherits ObjectResultAnalysisContext(Of LaconicConfiguration)
public ref class LaconfigData sealed : public ObjectResultAnalysisContext<LaconicConfiguration^>
public ref class LaconfigData sealed : public ObjectResultAnalysisContext<LaconicConfiguration^>
[<SealedAttribute>]
type LaconfigData =
    class
        inherit ObjectResultAnalysisContext<LaconicConfiguration>
    end
[<SealedAttribute>]
type LaconfigData =
    class
        inherit ObjectResultAnalysisContext<LaconicConfiguration>
    end
See Also
LaconfigData Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigData Members

LaconfigData Members NFX Class Library

The LaconfigData type exposes the following members.
Constructors
 | Name | Description
Public method | LaconfigData | Initializes a new instance of the LaconfigData class
Back to Top
Methods
 | Name | Description
Protected method | EmitMessage | (Inherited from CommonCodeProcessor.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MessageCodeToString | (Overrides CommonCodeProcessor MessageCodeToString(Int32).)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_ResultObject | (Inherited from ObjectResultAnalysisContext TObject .)
Back to Top
Properties
 | Name | Description
Public property | Context | Returns context that this processor operates under - an entity that retains state during analysis, such as: module compiler, project compiler, code unit translator etc. This entity may also contain compiler/parser/lexer options etc. (Inherited from CommonCodeProcessor.)
Public property | Language | (Overrides CommonCodeProcessor Language.)
Public property | Messages | References message list that lexer emitts messages into. May be null (Inherited from CommonCodeProcessor.)
Public property | ResultObject | (Inherited from ObjectResultAnalysisContext TObject .)
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any lexing error is always thrown regardless of this parameter (Inherited from CommonCodeProcessor.)
Back to Top
See Also
LaconfigData Class
NFX.CodeAnalysis.Laconfig Namespace


LaconfigData Constructor

LaconfigData Constructor NFX Class Library

Initializes a new instance of the LaconfigData class

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LaconfigData(
    LaconicConfiguration configuration
)
public LaconfigData(
    LaconicConfiguration configuration
)
Public Sub New (
    configuration As LaconicConfiguration
)
Public Sub New (
    configuration As LaconicConfiguration
)
public:
LaconfigData(
    LaconicConfiguration^ configuration
)
public:
LaconfigData(
    LaconicConfiguration^ configuration
)
new :
        configuration : LaconicConfiguration -> LaconfigData
new :
        configuration : LaconicConfiguration -> LaconfigData

Parameters

configuration
Type: NFX.Environment LaconicConfiguration
See Also
LaconfigData Class
LaconfigData Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigData Fields

LaconfigData Fields NFX Class Library

The LaconfigData type exposes the following members.
Fields
 | Name | Description
Protected field | m_ResultObject | (Inherited from ObjectResultAnalysisContext TObject .)
Back to Top
See Also
LaconfigData Class
NFX.CodeAnalysis.Laconfig Namespace


LaconfigData Methods

LaconfigData Methods NFX Class Library

The LaconfigData type exposes the following members.
Methods
 | Name | Description
Protected method | EmitMessage | (Inherited from CommonCodeProcessor.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MessageCodeToString | (Overrides CommonCodeProcessor MessageCodeToString(Int32).)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LaconfigData Class
NFX.CodeAnalysis.Laconfig Namespace


LaconfigData.MessageCodeToString Method

LaconfigData MessageCodeToString Method NFX Class Library

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string MessageCodeToString(
    int code
)
public override string MessageCodeToString(
    int code
)
Public Overrides Function MessageCodeToString (
    code As Integer
) As String
Public Overrides Function MessageCodeToString (
    code As Integer
) As String
public:
virtual String^ MessageCodeToString(
    int code
) override
public:
virtual String^ MessageCodeToString(
    int code
) override
abstract MessageCodeToString :
        code : int -> string
override MessageCodeToString :
        code : int -> string
abstract MessageCodeToString :
        code : int -> string
override MessageCodeToString :
        code : int -> string

Parameters

code
Type: Online System Int32

Return Value

Type: Online String

Implements

ICodeProcessor MessageCodeToString(Int32)
See Also
LaconfigData Class
LaconfigData Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigData Properties

LaconfigData Properties NFX Class Library

The LaconfigData type exposes the following members.
Properties
 | Name | Description
Public property | Context | Returns context that this processor operates under - an entity that retains state during analysis, such as: module compiler, project compiler, code unit translator etc. This entity may also contain compiler/parser/lexer options etc. (Inherited from CommonCodeProcessor.)
Public property | Language | (Overrides CommonCodeProcessor Language.)
Public property | Messages | References message list that lexer emitts messages into. May be null (Inherited from CommonCodeProcessor.)
Public property | ResultObject | (Inherited from ObjectResultAnalysisContext TObject .)
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any lexing error is always thrown regardless of this parameter (Inherited from CommonCodeProcessor.)
Back to Top
See Also
LaconfigData Class
NFX.CodeAnalysis.Laconfig Namespace


LaconfigData.Language Property

LaconfigData Language Property NFX Class Library

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Language Language { get; }
public override Language Language { get; }
Public Overrides ReadOnly Property Language As Language
    Get
Public Overrides ReadOnly Property Language As Language
    Get
public:
virtual property Language^ Language {
    Language^ get () override;
}
public:
virtual property Language^ Language {
    Language^ get () override;
}
abstract Language : Language with get
override Language : Language with get
abstract Language : Language with get
override Language : Language with get

Property Value

Type: Language

Implements

ICodeProcessor Language
See Also
LaconfigData Class
LaconfigData Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigKeywords Class

LaconfigKeywords Class NFX Class Library

Provides Laconfig keyword resolution services, this class is thread safe
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis.Laconfig LaconfigKeywords

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class LaconfigKeywords
public static class LaconfigKeywords
Public NotInheritable Class LaconfigKeywords
Public NotInheritable Class LaconfigKeywords
public ref class LaconfigKeywords abstract sealed
public ref class LaconfigKeywords abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type LaconfigKeywords =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type LaconfigKeywords =  class end
See Also
LaconfigKeywords Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigKeywords Members

LaconfigKeywords Members NFX Class Library

The LaconfigKeywords type exposes the following members.
Methods
Name | Description
Resolve | Resolves a Laconfig keyword
Back to Top
See Also
LaconfigKeywords Class
NFX.CodeAnalysis.Laconfig Namespace


LaconfigKeywords Methods

LaconfigKeywords Methods NFX Class Library

The LaconfigKeywords type exposes the following members.
Methods
Name | Description
Resolve | Resolves a Laconfig keyword
Back to Top
See Also
LaconfigKeywords Class
NFX.CodeAnalysis.Laconfig Namespace


LaconfigKeywords.Resolve Method

LaconfigKeywords Resolve Method NFX Class Library

Resolves a Laconfig keyword

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static LaconfigTokenType Resolve(
    string str
)
public static LaconfigTokenType Resolve(
    string str
)
Public Shared Function Resolve (
    str As String
) As LaconfigTokenType
Public Shared Function Resolve (
    str As String
) As LaconfigTokenType
public:
static LaconfigTokenType Resolve(
    String^ str
)
public:
static LaconfigTokenType Resolve(
    String^ str
)
static member Resolve :
        str : string -> LaconfigTokenType
static member Resolve :
        str : string -> LaconfigTokenType

Parameters

str
Type: Online System String

Return Value

Type: LaconfigTokenType
See Also
LaconfigKeywords Class
LaconfigKeywords Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigLanguage Class

LaconfigLanguage Class NFX Class Library

Represents Laconic + Config = Laconfig terse configuration language
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis Language
NFX.CodeAnalysis.Laconfig LaconfigLanguage

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class LaconfigLanguage : Language
public sealed class LaconfigLanguage : Language
Public NotInheritable Class LaconfigLanguage
    Inherits Language
Public NotInheritable Class LaconfigLanguage
    Inherits Language
public ref class LaconfigLanguage sealed : public Language
public ref class LaconfigLanguage sealed : public Language
[<SealedAttribute>]
type LaconfigLanguage =
    class
        inherit Language
    end
[<SealedAttribute>]
type LaconfigLanguage =
    class
        inherit Language
    end
See Also
LaconfigLanguage Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigLanguage Members

LaconfigLanguage Members NFX Class Library

The LaconfigLanguage type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeLexer | (Overrides Language MakeLexer(IAnalysisContext, SourceCodeRef, ISourceText, MessageList, Boolean).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from Language.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
Instance |
Back to Top
Properties
 | Name | Description
Public property | Family | (Overrides Language Family.)
Public property | FileExtensions | (Overrides Language FileExtensions.)
Back to Top
See Also
LaconfigLanguage Class
NFX.CodeAnalysis.Laconfig Namespace


LaconfigLanguage Fields

LaconfigLanguage Fields NFX Class Library

The LaconfigLanguage type exposes the following members.
Fields
Name | Description
Instance |
Back to Top
See Also
LaconfigLanguage Class
NFX.CodeAnalysis.Laconfig Namespace


LaconfigLanguage.Instance Field

LaconfigLanguage Instance Field NFX Class Library

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly LaconfigLanguage Instance
public static readonly LaconfigLanguage Instance
Public Shared ReadOnly Instance As LaconfigLanguage
Public Shared ReadOnly Instance As LaconfigLanguage
public:
static initonly LaconfigLanguage^ Instance
public:
static initonly LaconfigLanguage^ Instance
static val Instance: LaconfigLanguage
static val Instance: LaconfigLanguage

Field Value

Type: LaconfigLanguage
See Also
LaconfigLanguage Class
LaconfigLanguage Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigLanguage Methods

LaconfigLanguage Methods NFX Class Library

The LaconfigLanguage type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeLexer | (Overrides Language MakeLexer(IAnalysisContext, SourceCodeRef, ISourceText, MessageList, Boolean).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from Language.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LaconfigLanguage Class
NFX.CodeAnalysis.Laconfig Namespace


LaconfigLanguage.MakeLexer Method

LaconfigLanguage MakeLexer Method NFX Class Library

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ILexer MakeLexer(
    IAnalysisContext context,
    SourceCodeRef srcRef,
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
public override ILexer MakeLexer(
    IAnalysisContext context,
    SourceCodeRef srcRef,
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
Public Overrides Function MakeLexer (
    context As IAnalysisContext,
    srcRef As SourceCodeRef,
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
) As ILexer
Public Overrides Function MakeLexer (
    context As IAnalysisContext,
    srcRef As SourceCodeRef,
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
) As ILexer
public:
virtual ILexer^ MakeLexer(
    IAnalysisContext^ context,
    SourceCodeRef srcRef,
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
) override
public:
virtual ILexer^ MakeLexer(
    IAnalysisContext^ context,
    SourceCodeRef srcRef,
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
) override
abstract MakeLexer :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> ILexer
override MakeLexer :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> ILexer
abstract MakeLexer :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> ILexer
override MakeLexer :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> ILexer

Parameters

context
Type: NFX.CodeAnalysis IAnalysisContext
srcRef
Type: NFX.CodeAnalysis.Source SourceCodeRef
source
Type: NFX.CodeAnalysis.Source ISourceText
messages (Optional)
Type: NFX.CodeAnalysis MessageList
throwErrors (Optional)
Type: Online System Boolean

Return Value

Type: ILexer
See Also
LaconfigLanguage Class
LaconfigLanguage Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigLanguage Properties

LaconfigLanguage Properties NFX Class Library

The LaconfigLanguage type exposes the following members.
Properties
 | Name | Description
Public property | Family | (Overrides Language Family.)
Public property | FileExtensions | (Overrides Language FileExtensions.)
Back to Top
See Also
LaconfigLanguage Class
NFX.CodeAnalysis.Laconfig Namespace


LaconfigLanguage.Family Property

LaconfigLanguage Family Property NFX Class Library

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override LanguageFamily Family { get; }
public override LanguageFamily Family { get; }
Public Overrides ReadOnly Property Family As LanguageFamily
    Get
Public Overrides ReadOnly Property Family As LanguageFamily
    Get
public:
virtual property LanguageFamily Family {
    LanguageFamily get () override;
}
public:
virtual property LanguageFamily Family {
    LanguageFamily get () override;
}
abstract Family : LanguageFamily with get
override Family : LanguageFamily with get
abstract Family : LanguageFamily with get
override Family : LanguageFamily with get

Property Value

Type: LanguageFamily
See Also
LaconfigLanguage Class
LaconfigLanguage Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigLanguage.FileExtensions Property

LaconfigLanguage FileExtensions Property NFX Class Library

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IEnumerable<string> FileExtensions { get; }
public override IEnumerable<string> FileExtensions { get; }
Public Overrides ReadOnly Property FileExtensions As IEnumerable(Of String)
    Get
Public Overrides ReadOnly Property FileExtensions As IEnumerable(Of String)
    Get
public:
virtual property IEnumerable<String^>^ FileExtensions {
    IEnumerable<String^>^ get () override;
}
public:
virtual property IEnumerable<String^>^ FileExtensions {
    IEnumerable<String^>^ get () override;
}
abstract FileExtensions : IEnumerable<string> with get
override FileExtensions : IEnumerable<string> with get
abstract FileExtensions : IEnumerable<string> with get
override FileExtensions : IEnumerable<string> with get

Property Value

Type: Online IEnumerable Online String
See Also
LaconfigLanguage Class
LaconfigLanguage Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigLexer Class

LaconfigLexer Class NFX Class Library

Performs lexical analysis on source supplied in Laconfig syntax. This class supports lazy analysis that happens gradually as result tokens are consumed through IEnumerable interface.
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis CommonCodeProcessor
NFX.CodeAnalysis SourceRefCommonCodeProcessor
NFX.CodeAnalysis Lexer LaconfigToken
NFX.CodeAnalysis.Laconfig LaconfigLexer

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class LaconfigLexer : Lexer<LaconfigToken>
public sealed class LaconfigLexer : Lexer<LaconfigToken>
Public NotInheritable Class LaconfigLexer
    Inherits Lexer(Of LaconfigToken)
Public NotInheritable Class LaconfigLexer
    Inherits Lexer(Of LaconfigToken)
public ref class LaconfigLexer sealed : public Lexer<LaconfigToken^>
public ref class LaconfigLexer sealed : public Lexer<LaconfigToken^>
[<SealedAttribute>]
type LaconfigLexer =
    class
        inherit Lexer<LaconfigToken>
    end
[<SealedAttribute>]
type LaconfigLexer =
    class
        inherit Lexer<LaconfigToken>
    end
See Also
LaconfigLexer Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigLexer Members

LaconfigLexer Members NFX Class Library

The LaconfigLexer type exposes the following members.
Constructors
 | Name | Description
Public method | LaconfigLexer(ISourceText, MessageList, Boolean) | Initializes a new instance of the LaconfigLexer class
Public method | LaconfigLexer(IAnalysisContext, SourceCodeRef, ISourceText, MessageList, Boolean) | Initializes a new instance of the LaconfigLexer class
Back to Top
Methods
 | Name | Description
Public method | AnalyzeAll | If lexer supports lazy analysis, forces analysis of the whole source (Inherited from Lexer TToken .)
Protected method | DoLexingChunk | (Overrides Lexer TToken DoLexingChunk .)
Protected method | EmitMessage(MessageType, Int32, SourcePosition, Token, String, Exception) | (Inherited from SourceRefCommonCodeProcessor.)
Protected method | EmitMessage(MessageType, Int32, SourceCodeRef, Nullable SourcePosition , Token, String, Exception) | (Inherited from CommonCodeProcessor.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | (Inherited from Lexer TToken .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MessageCodeToString | (Overrides CommonCodeProcessor MessageCodeToString(Int32).)
Public method | ToString | (Inherited from Lexer TToken .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_AllAnalyzed | (Inherited from Lexer TToken .)
Protected field | m_Tokens | (Inherited from Lexer TToken .)
Back to Top
Properties
 | Name | Description
Public property | AllAnalyzed | Returns true when the whole input source has been analyzed. This property is always true for lexers that do not support lazy analysis (Inherited from Lexer TToken .)
Public property | Context | Returns context that this processor operates under - an entity that retains state during analysis, such as: module compiler, project compiler, code unit translator etc. This entity may also contain compiler/parser/lexer options etc. (Inherited from CommonCodeProcessor.)
Public property | Language | (Overrides CommonCodeProcessor Language.)
Public property | Messages | References message list that lexer emitts messages into. May be null (Inherited from CommonCodeProcessor.)
Public property | Source | References source code text that was lexed (Inherited from Lexer TToken .)
Public property | SourceCodeReference | References source code that is processed (Inherited from SourceRefCommonCodeProcessor.)
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any lexing error is always thrown regardless of this parameter (Inherited from CommonCodeProcessor.)
Public property | Tokens | Returns tokenized source as indexable list. Accessing this property causes lexical analysis to complete on the whole source if it has not been completed yet (Inherited from Lexer TToken .)
Public property | TokenStream | Enumerates Token stream - depending on implementation enumeration may do lexical analysis token-by-token or in chunks with every enumerator advance (Inherited from Lexer TToken .)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Lexer TToken .)
Back to Top
See Also
LaconfigLexer Class
NFX.CodeAnalysis.Laconfig Namespace


LaconfigLexer Constructor

LaconfigLexer Constructor NFX Class Library

Overload List
 | Name | Description
Public method | LaconfigLexer(ISourceText, MessageList, Boolean) | Initializes a new instance of the LaconfigLexer class
Public method | LaconfigLexer(IAnalysisContext, SourceCodeRef, ISourceText, MessageList, Boolean) | Initializes a new instance of the LaconfigLexer class
Back to Top
See Also
LaconfigLexer Class
LaconfigLexer Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigLexer Constructor (ISourceText, MessageList, Boolean)

LaconfigLexer Constructor (ISourceText, MessageList, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LaconfigLexer class

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LaconfigLexer(
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
public LaconfigLexer(
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
Public Sub New (
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
Public Sub New (
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
public:
LaconfigLexer(
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
public:
LaconfigLexer(
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
new :
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> LaconfigLexer
new :
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> LaconfigLexer

Parameters

source
Type: NFX.CodeAnalysis.Source ISourceText
messages (Optional)
Type: NFX.CodeAnalysis MessageList
throwErrors (Optional)
Type: Online System Boolean
See Also
LaconfigLexer Class
LaconfigLexer Members
LaconfigLexer Overload
NFX.CodeAnalysis.Laconfig Namespace


LaconfigLexer Constructor (IAnalysisContext, SourceCodeRef, ISourceText, MessageList, Boolean)

LaconfigLexer Constructor (IAnalysisContext, SourceCodeRef, ISourceText, MessageList, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LaconfigLexer class

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LaconfigLexer(
    IAnalysisContext context,
    SourceCodeRef srcRef,
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
public LaconfigLexer(
    IAnalysisContext context,
    SourceCodeRef srcRef,
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
Public Sub New (
    context As IAnalysisContext,
    srcRef As SourceCodeRef,
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
Public Sub New (
    context As IAnalysisContext,
    srcRef As SourceCodeRef,
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
public:
LaconfigLexer(
    IAnalysisContext^ context,
    SourceCodeRef srcRef,
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
public:
LaconfigLexer(
    IAnalysisContext^ context,
    SourceCodeRef srcRef,
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
new :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> LaconfigLexer
new :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> LaconfigLexer

Parameters

context
Type: NFX.CodeAnalysis IAnalysisContext
srcRef
Type: NFX.CodeAnalysis.Source SourceCodeRef
source
Type: NFX.CodeAnalysis.Source ISourceText
messages (Optional)
Type: NFX.CodeAnalysis MessageList
throwErrors (Optional)
Type: Online System Boolean
See Also
LaconfigLexer Class
LaconfigLexer Members
LaconfigLexer Overload
NFX.CodeAnalysis.Laconfig Namespace


LaconfigLexer Fields

LaconfigLexer Fields NFX Class Library

The LaconfigLexer type exposes the following members.
Fields
 | Name | Description
Protected field | m_AllAnalyzed | (Inherited from Lexer TToken .)
Protected field | m_Tokens | (Inherited from Lexer TToken .)
Back to Top
See Also
LaconfigLexer Class
NFX.CodeAnalysis.Laconfig Namespace


LaconfigLexer Methods

LaconfigLexer Methods NFX Class Library

The LaconfigLexer type exposes the following members.
Methods
 | Name | Description
Public method | AnalyzeAll | If lexer supports lazy analysis, forces analysis of the whole source (Inherited from Lexer TToken .)
Protected method | DoLexingChunk | (Overrides Lexer TToken DoLexingChunk .)
Protected method | EmitMessage(MessageType, Int32, SourcePosition, Token, String, Exception) | (Inherited from SourceRefCommonCodeProcessor.)
Protected method | EmitMessage(MessageType, Int32, SourceCodeRef, Nullable SourcePosition , Token, String, Exception) | (Inherited from CommonCodeProcessor.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | (Inherited from Lexer TToken .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MessageCodeToString | (Overrides CommonCodeProcessor MessageCodeToString(Int32).)
Public method | ToString | (Inherited from Lexer TToken .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Lexer TToken .)
Back to Top
See Also
LaconfigLexer Class
NFX.CodeAnalysis.Laconfig Namespace


LaconfigLexer.DoLexingChunk Method

LaconfigLexer DoLexingChunk Method NFX Class Library

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool DoLexingChunk()
protected override bool DoLexingChunk()
Protected Overrides Function DoLexingChunk As Boolean
Protected Overrides Function DoLexingChunk As Boolean
protected:
virtual bool DoLexingChunk() override
protected:
virtual bool DoLexingChunk() override
abstract DoLexingChunk : unit -> bool
override DoLexingChunk : unit -> bool
abstract DoLexingChunk : unit -> bool
override DoLexingChunk : unit -> bool

Return Value

Type: Online Boolean
See Also
LaconfigLexer Class
LaconfigLexer Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigLexer.MessageCodeToString Method

LaconfigLexer MessageCodeToString Method NFX Class Library

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string MessageCodeToString(
    int code
)
public override string MessageCodeToString(
    int code
)
Public Overrides Function MessageCodeToString (
    code As Integer
) As String
Public Overrides Function MessageCodeToString (
    code As Integer
) As String
public:
virtual String^ MessageCodeToString(
    int code
) override
public:
virtual String^ MessageCodeToString(
    int code
) override
abstract MessageCodeToString :
        code : int -> string
override MessageCodeToString :
        code : int -> string
abstract MessageCodeToString :
        code : int -> string
override MessageCodeToString :
        code : int -> string

Parameters

code
Type: Online System Int32

Return Value

Type: Online String

Implements

ICodeProcessor MessageCodeToString(Int32)
See Also
LaconfigLexer Class
LaconfigLexer Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigLexer Properties

LaconfigLexer Properties NFX Class Library

The LaconfigLexer type exposes the following members.
Properties
 | Name | Description
Public property | AllAnalyzed | Returns true when the whole input source has been analyzed. This property is always true for lexers that do not support lazy analysis (Inherited from Lexer TToken .)
Public property | Context | Returns context that this processor operates under - an entity that retains state during analysis, such as: module compiler, project compiler, code unit translator etc. This entity may also contain compiler/parser/lexer options etc. (Inherited from CommonCodeProcessor.)
Public property | Language | (Overrides CommonCodeProcessor Language.)
Public property | Messages | References message list that lexer emitts messages into. May be null (Inherited from CommonCodeProcessor.)
Public property | Source | References source code text that was lexed (Inherited from Lexer TToken .)
Public property | SourceCodeReference | References source code that is processed (Inherited from SourceRefCommonCodeProcessor.)
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any lexing error is always thrown regardless of this parameter (Inherited from CommonCodeProcessor.)
Public property | Tokens | Returns tokenized source as indexable list. Accessing this property causes lexical analysis to complete on the whole source if it has not been completed yet (Inherited from Lexer TToken .)
Public property | TokenStream | Enumerates Token stream - depending on implementation enumeration may do lexical analysis token-by-token or in chunks with every enumerator advance (Inherited from Lexer TToken .)
Back to Top
See Also
LaconfigLexer Class
NFX.CodeAnalysis.Laconfig Namespace


LaconfigLexer.Language Property

LaconfigLexer Language Property NFX Class Library

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Language Language { get; }
public override Language Language { get; }
Public Overrides ReadOnly Property Language As Language
    Get
Public Overrides ReadOnly Property Language As Language
    Get
public:
virtual property Language^ Language {
    Language^ get () override;
}
public:
virtual property Language^ Language {
    Language^ get () override;
}
abstract Language : Language with get
override Language : Language with get
abstract Language : Language with get
override Language : Language with get

Property Value

Type: Language

Implements

ICodeProcessor Language
See Also
LaconfigLexer Class
LaconfigLexer Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigMsgCode Enumeration

LaconfigMsgCode Enumeration NFX Class Library

Message codes for Laconfig code processors

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum LaconfigMsgCode
public enum LaconfigMsgCode
Public Enumeration LaconfigMsgCode
Public Enumeration LaconfigMsgCode
public enum class LaconfigMsgCode
public enum class LaconfigMsgCode
type LaconfigMsgCode
type LaconfigMsgCode
Members
Member name | Value | Description
INFOS | 0 |
WARNING | 100 |
ERRORS | 1000 |
eUnterminatedString | 1001 |
ePrematureEOF | 1002 |
eUnterminatedComment | 1003 |
eInvalidStringEscape | 1004 |
eSectionNameExpected | 1005 |
eSectionOpenBraceExpected | 1006 |
eSectionOrAttributeNameExpected | 1007 |
eSectionOrAttributeValueExpected | 1008 |
eContentPastRootSection | 1009 |
eSyntaxError | 1010 |
See Also
NFX.CodeAnalysis.Laconfig Namespace


LaconfigParser Class

LaconfigParser Class NFX Class Library

Parses Laconfig lexer output into laconic configuration node graph
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis CommonCodeProcessor
NFX.CodeAnalysis Parser LaconfigLexer
NFX.CodeAnalysis.Laconfig LaconfigParser

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class LaconfigParser : Parser<LaconfigLexer>
public sealed class LaconfigParser : Parser<LaconfigLexer>
Public NotInheritable Class LaconfigParser
    Inherits Parser(Of LaconfigLexer)
Public NotInheritable Class LaconfigParser
    Inherits Parser(Of LaconfigLexer)
public ref class LaconfigParser sealed : public Parser<LaconfigLexer^>
public ref class LaconfigParser sealed : public Parser<LaconfigLexer^>
[<SealedAttribute>]
type LaconfigParser =
    class
        inherit Parser<LaconfigLexer>
    end
[<SealedAttribute>]
type LaconfigParser =
    class
        inherit Parser<LaconfigLexer>
    end
See Also
LaconfigParser Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigParser Members

LaconfigParser Members NFX Class Library

The LaconfigParser type exposes the following members.
Constructors
 | Name | Description
Public method | LaconfigParser | Initializes a new instance of the LaconfigParser class
Back to Top
Methods
 | Name | Description
Protected method | DoParse | (Overrides Parser TLexer DoParse .)
Protected method | EmitMessage | (Inherited from CommonCodeProcessor.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MessageCodeToString | (Overrides CommonCodeProcessor MessageCodeToString(Int32).)
Public method | Parse | Performs parsing if it has not been performed yet (Inherited from Parser TLexer .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Context | Returns context that this processor operates under - an entity that retains state during analysis, such as: module compiler, project compiler, code unit translator etc. This entity may also contain compiler/parser/lexer options etc. (Inherited from CommonCodeProcessor.)
Public property | HasParsed | Indicates whether Parse() already happened (Inherited from Parser TLexer .)
Public property | Input | Returns lexers that feed this parser (Inherited from Parser TLexer .)
Public property | Language | (Overrides CommonCodeProcessor Language.)
Public property | Lexer |
Public property | Messages | References message list that lexer emitts messages into. May be null (Inherited from CommonCodeProcessor.)
Public property | ResultContext |
Public property | SourceInput | Lists source lexers that supply token stream for parsing (Inherited from Parser TLexer .)
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any lexing error is always thrown regardless of this parameter (Inherited from CommonCodeProcessor.)
Back to Top
See Also
LaconfigParser Class
NFX.CodeAnalysis.Laconfig Namespace


LaconfigParser Constructor

LaconfigParser Constructor NFX Class Library

Initializes a new instance of the LaconfigParser class

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LaconfigParser(
    LaconfigData context,
    LaconfigLexer input,
    MessageList messages = null,
    bool throwErrors = false
)
public LaconfigParser(
    LaconfigData context,
    LaconfigLexer input,
    MessageList messages = null,
    bool throwErrors = false
)
Public Sub New (
    context As LaconfigData,
    input As LaconfigLexer,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
Public Sub New (
    context As LaconfigData,
    input As LaconfigLexer,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
)
public:
LaconfigParser(
    LaconfigData^ context,
    LaconfigLexer^ input,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
public:
LaconfigParser(
    LaconfigData^ context,
    LaconfigLexer^ input,
    MessageList^ messages = nullptr,
    bool throwErrors = false
)
new :
        context : LaconfigData *
        input : LaconfigLexer *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> LaconfigParser
new :
        context : LaconfigData *
        input : LaconfigLexer *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> LaconfigParser

Parameters

context
Type: NFX.CodeAnalysis.Laconfig LaconfigData
input
Type: NFX.CodeAnalysis.Laconfig LaconfigLexer
messages (Optional)
Type: NFX.CodeAnalysis MessageList
throwErrors (Optional)
Type: Online System Boolean
See Also
LaconfigParser Class
LaconfigParser Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigParser Methods

LaconfigParser Methods NFX Class Library

The LaconfigParser type exposes the following members.
Methods
 | Name | Description
Protected method | DoParse | (Overrides Parser TLexer DoParse .)
Protected method | EmitMessage | (Inherited from CommonCodeProcessor.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MessageCodeToString | (Overrides CommonCodeProcessor MessageCodeToString(Int32).)
Public method | Parse | Performs parsing if it has not been performed yet (Inherited from Parser TLexer .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LaconfigParser Class
NFX.CodeAnalysis.Laconfig Namespace


LaconfigParser.DoParse Method

LaconfigParser DoParse Method NFX Class Library

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoParse()
protected override void DoParse()
Protected Overrides Sub DoParse
Protected Overrides Sub DoParse
protected:
virtual void DoParse() override
protected:
virtual void DoParse() override
abstract DoParse : unit -> unit
override DoParse : unit -> unit
abstract DoParse : unit -> unit
override DoParse : unit -> unit
See Also
LaconfigParser Class
LaconfigParser Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigParser.MessageCodeToString Method

LaconfigParser MessageCodeToString Method NFX Class Library

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string MessageCodeToString(
    int code
)
public override string MessageCodeToString(
    int code
)
Public Overrides Function MessageCodeToString (
    code As Integer
) As String
Public Overrides Function MessageCodeToString (
    code As Integer
) As String
public:
virtual String^ MessageCodeToString(
    int code
) override
public:
virtual String^ MessageCodeToString(
    int code
) override
abstract MessageCodeToString :
        code : int -> string
override MessageCodeToString :
        code : int -> string
abstract MessageCodeToString :
        code : int -> string
override MessageCodeToString :
        code : int -> string

Parameters

code
Type: Online System Int32

Return Value

Type: Online String

Implements

ICodeProcessor MessageCodeToString(Int32)
See Also
LaconfigParser Class
LaconfigParser Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigParser Properties

LaconfigParser Properties NFX Class Library

The LaconfigParser type exposes the following members.
Properties
 | Name | Description
Public property | Context | Returns context that this processor operates under - an entity that retains state during analysis, such as: module compiler, project compiler, code unit translator etc. This entity may also contain compiler/parser/lexer options etc. (Inherited from CommonCodeProcessor.)
Public property | HasParsed | Indicates whether Parse() already happened (Inherited from Parser TLexer .)
Public property | Input | Returns lexers that feed this parser (Inherited from Parser TLexer .)
Public property | Language | (Overrides CommonCodeProcessor Language.)
Public property | Lexer |
Public property | Messages | References message list that lexer emitts messages into. May be null (Inherited from CommonCodeProcessor.)
Public property | ResultContext |
Public property | SourceInput | Lists source lexers that supply token stream for parsing (Inherited from Parser TLexer .)
Public property | ThrowErrors | When true, throws an exception on the first error even when MessageList is set. When MessageList is not set any lexing error is always thrown regardless of this parameter (Inherited from CommonCodeProcessor.)
Back to Top
See Also
LaconfigParser Class
NFX.CodeAnalysis.Laconfig Namespace


LaconfigParser.Language Property

LaconfigParser Language Property NFX Class Library

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Language Language { get; }
public override Language Language { get; }
Public Overrides ReadOnly Property Language As Language
    Get
Public Overrides ReadOnly Property Language As Language
    Get
public:
virtual property Language^ Language {
    Language^ get () override;
}
public:
virtual property Language^ Language {
    Language^ get () override;
}
abstract Language : Language with get
override Language : Language with get
abstract Language : Language with get
override Language : Language with get

Property Value

Type: Language

Implements

ICodeProcessor Language
See Also
LaconfigParser Class
LaconfigParser Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigParser.Lexer Property

LaconfigParser Lexer Property NFX Class Library

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LaconfigLexer Lexer { get; }
public LaconfigLexer Lexer { get; }
Public ReadOnly Property Lexer As LaconfigLexer
    Get
Public ReadOnly Property Lexer As LaconfigLexer
    Get
public:
property LaconfigLexer^ Lexer {
    LaconfigLexer^ get ();
}
public:
property LaconfigLexer^ Lexer {
    LaconfigLexer^ get ();
}
member Lexer : LaconfigLexer with get
member Lexer : LaconfigLexer with get

Property Value

Type: LaconfigLexer
See Also
LaconfigParser Class
LaconfigParser Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigParser.ResultContext Property

LaconfigParser ResultContext Property NFX Class Library

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LaconfigData ResultContext { get; }
public LaconfigData ResultContext { get; }
Public ReadOnly Property ResultContext As LaconfigData
    Get
Public ReadOnly Property ResultContext As LaconfigData
    Get
public:
property LaconfigData^ ResultContext {
    LaconfigData^ get ();
}
public:
property LaconfigData^ ResultContext {
    LaconfigData^ get ();
}
member ResultContext : LaconfigData with get
member ResultContext : LaconfigData with get

Property Value

Type: LaconfigData
See Also
LaconfigParser Class
LaconfigParser Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigToken Class

LaconfigToken Class NFX Class Library

Represents a token of Laconfig language
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis Token
NFX.CodeAnalysis.Laconfig LaconfigToken

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LaconfigToken : Token
public class LaconfigToken : Token
Public Class LaconfigToken
    Inherits Token
Public Class LaconfigToken
    Inherits Token
public ref class LaconfigToken : public Token
public ref class LaconfigToken : public Token
type LaconfigToken =
    class
        inherit Token
    end
type LaconfigToken =
    class
        inherit Token
    end
See Also
LaconfigToken Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigToken Members

LaconfigToken Members NFX Class Library

The LaconfigToken type exposes the following members.
Constructors
 | Name | Description
Public method | LaconfigToken | Initializes a new instance of the LaconfigToken class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Token ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | EndPosition | (Inherited from Token.)
Public field | Lexer | (Inherited from Token.)
Public field | StartPosition | (Inherited from Token.)
Public field | Text | (Inherited from Token.)
Public field | Type |
Public field | Value | (Inherited from Token.)
Back to Top
Properties
 | Name | Description
Public property | IsBOF | Indicates whether this token indicates an BEGINNING-OF-FILE condition (Inherited from Token.)
Public property | IsComment | Indicates whether this token represents a comment (Inherited from Token.)
Public property | IsDirective | Indicates whether this token represents a directive (Inherited from Token.)
Public property | IsEOF | Indicates whether this token indicates an END-OF-FILE condition (Inherited from Token.)
Public property | IsIdentifier | Indicates whether this token represents an identifier (Inherited from Token.)
Public property | IsKeyword | Indicates whether this token represents a language keyword (Inherited from Token.)
Public property | IsLiteral | Indicates whether this token represents a literal (Inherited from Token.)
Public property | IsNonLanguage | (Overrides Token IsNonLanguage.)
Public property | IsNumericLiteral | (Overrides Token IsNumericLiteral.)
Public property | IsOperator | Indicates whether this token represents an operator (Inherited from Token.)
Public property | IsPrimary | (Overrides Token IsPrimary.)
Public property | IsSymbol | Indicates whether this token represents a symbol (Inherited from Token.)
Public property | IsTextualLiteral | (Overrides Token IsTextualLiteral.)
Public property | Kind | (Overrides Token Kind.)
Public property | Language | (Overrides Token Language.)
Public property | OrdinalType | (Overrides Token OrdinalType.)
Back to Top
See Also
LaconfigToken Class
NFX.CodeAnalysis.Laconfig Namespace


LaconfigToken Constructor

LaconfigToken Constructor NFX Class Library

Initializes a new instance of the LaconfigToken class

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LaconfigToken(
    LaconfigLexer lexer,
    LaconfigTokenType type,
    SourcePosition startPos,
    SourcePosition endPos,
    string text,
    Object value = null
)
public LaconfigToken(
    LaconfigLexer lexer,
    LaconfigTokenType type,
    SourcePosition startPos,
    SourcePosition endPos,
    string text,
    Object value = null
)
Public Sub New (
    lexer As LaconfigLexer,
    type As LaconfigTokenType,
    startPos As SourcePosition,
    endPos As SourcePosition,
    text As String,
    Optional value As Object = Nothing
)
Public Sub New (
    lexer As LaconfigLexer,
    type As LaconfigTokenType,
    startPos As SourcePosition,
    endPos As SourcePosition,
    text As String,
    Optional value As Object = Nothing
)
public:
LaconfigToken(
    LaconfigLexer^ lexer,
    LaconfigTokenType type,
    SourcePosition startPos,
    SourcePosition endPos,
    String^ text,
    Object^ value = nullptr
)
public:
LaconfigToken(
    LaconfigLexer^ lexer,
    LaconfigTokenType type,
    SourcePosition startPos,
    SourcePosition endPos,
    String^ text,
    Object^ value = nullptr
)
new :
        lexer : LaconfigLexer *
        type : LaconfigTokenType *
        startPos : SourcePosition *
        endPos : SourcePosition *
        text : string *
        ?value : Object
(* Defaults:
        let _value = defaultArg value null
*)
-> LaconfigToken
new :
        lexer : LaconfigLexer *
        type : LaconfigTokenType *
        startPos : SourcePosition *
        endPos : SourcePosition *
        text : string *
        ?value : Object
(* Defaults:
        let _value = defaultArg value null
*)
-> LaconfigToken

Parameters

lexer
Type: NFX.CodeAnalysis.Laconfig LaconfigLexer
type
Type: NFX.CodeAnalysis.Laconfig LaconfigTokenType
startPos
Type: NFX.CodeAnalysis.Source SourcePosition
endPos
Type: NFX.CodeAnalysis.Source SourcePosition
text
Type: Online System String
value (Optional)
Type: Online System Object
See Also
LaconfigToken Class
LaconfigToken Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigToken Fields

LaconfigToken Fields NFX Class Library

The LaconfigToken type exposes the following members.
Fields
 | Name | Description
Public field | EndPosition | (Inherited from Token.)
Public field | Lexer | (Inherited from Token.)
Public field | StartPosition | (Inherited from Token.)
Public field | Text | (Inherited from Token.)
Public field | Type |
Public field | Value | (Inherited from Token.)
Back to Top
See Also
LaconfigToken Class
NFX.CodeAnalysis.Laconfig Namespace


LaconfigToken.Type Field

LaconfigToken Type Field NFX Class Library

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly LaconfigTokenType Type
public readonly LaconfigTokenType Type
Public ReadOnly Type As LaconfigTokenType
Public ReadOnly Type As LaconfigTokenType
public:
initonly LaconfigTokenType Type
public:
initonly LaconfigTokenType Type
val Type: LaconfigTokenType
val Type: LaconfigTokenType

Field Value

Type: LaconfigTokenType
See Also
LaconfigToken Class
LaconfigToken Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigToken Methods

LaconfigToken Methods NFX Class Library

The LaconfigToken type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Token ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LaconfigToken Class
NFX.CodeAnalysis.Laconfig Namespace


LaconfigToken.ToString Method

LaconfigToken ToString Method NFX Class Library

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
LaconfigToken Class
LaconfigToken Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigToken Properties

LaconfigToken Properties NFX Class Library

The LaconfigToken type exposes the following members.
Properties
 | Name | Description
Public property | IsBOF | Indicates whether this token indicates an BEGINNING-OF-FILE condition (Inherited from Token.)
Public property | IsComment | Indicates whether this token represents a comment (Inherited from Token.)
Public property | IsDirective | Indicates whether this token represents a directive (Inherited from Token.)
Public property | IsEOF | Indicates whether this token indicates an END-OF-FILE condition (Inherited from Token.)
Public property | IsIdentifier | Indicates whether this token represents an identifier (Inherited from Token.)
Public property | IsKeyword | Indicates whether this token represents a language keyword (Inherited from Token.)
Public property | IsLiteral | Indicates whether this token represents a literal (Inherited from Token.)
Public property | IsNonLanguage | (Overrides Token IsNonLanguage.)
Public property | IsNumericLiteral | (Overrides Token IsNumericLiteral.)
Public property | IsOperator | Indicates whether this token represents an operator (Inherited from Token.)
Public property | IsPrimary | (Overrides Token IsPrimary.)
Public property | IsSymbol | Indicates whether this token represents a symbol (Inherited from Token.)
Public property | IsTextualLiteral | (Overrides Token IsTextualLiteral.)
Public property | Kind | (Overrides Token Kind.)
Public property | Language | (Overrides Token Language.)
Public property | OrdinalType | (Overrides Token OrdinalType.)
Back to Top
See Also
LaconfigToken Class
NFX.CodeAnalysis.Laconfig Namespace


LaconfigToken.IsNonLanguage Property

LaconfigToken IsNonLanguage Property NFX Class Library

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsNonLanguage { get; }
public override bool IsNonLanguage { get; }
Public Overrides ReadOnly Property IsNonLanguage As Boolean
    Get
Public Overrides ReadOnly Property IsNonLanguage As Boolean
    Get
public:
virtual property bool IsNonLanguage {
    bool get () override;
}
public:
virtual property bool IsNonLanguage {
    bool get () override;
}
abstract IsNonLanguage : bool with get
override IsNonLanguage : bool with get
abstract IsNonLanguage : bool with get
override IsNonLanguage : bool with get

Property Value

Type: Online Boolean
See Also
LaconfigToken Class
LaconfigToken Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigToken.IsNumericLiteral Property

LaconfigToken IsNumericLiteral Property NFX Class Library

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsNumericLiteral { get; }
public override bool IsNumericLiteral { get; }
Public Overrides ReadOnly Property IsNumericLiteral As Boolean
    Get
Public Overrides ReadOnly Property IsNumericLiteral As Boolean
    Get
public:
virtual property bool IsNumericLiteral {
    bool get () override;
}
public:
virtual property bool IsNumericLiteral {
    bool get () override;
}
abstract IsNumericLiteral : bool with get
override IsNumericLiteral : bool with get
abstract IsNumericLiteral : bool with get
override IsNumericLiteral : bool with get

Property Value

Type: Online Boolean
See Also
LaconfigToken Class
LaconfigToken Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigToken.IsPrimary Property

LaconfigToken IsPrimary Property NFX Class Library

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsPrimary { get; }
public override bool IsPrimary { get; }
Public Overrides ReadOnly Property IsPrimary As Boolean
    Get
Public Overrides ReadOnly Property IsPrimary As Boolean
    Get
public:
virtual property bool IsPrimary {
    bool get () override;
}
public:
virtual property bool IsPrimary {
    bool get () override;
}
abstract IsPrimary : bool with get
override IsPrimary : bool with get
abstract IsPrimary : bool with get
override IsPrimary : bool with get

Property Value

Type: Online Boolean
See Also
LaconfigToken Class
LaconfigToken Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigToken.IsTextualLiteral Property

LaconfigToken IsTextualLiteral Property NFX Class Library

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsTextualLiteral { get; }
public override bool IsTextualLiteral { get; }
Public Overrides ReadOnly Property IsTextualLiteral As Boolean
    Get
Public Overrides ReadOnly Property IsTextualLiteral As Boolean
    Get
public:
virtual property bool IsTextualLiteral {
    bool get () override;
}
public:
virtual property bool IsTextualLiteral {
    bool get () override;
}
abstract IsTextualLiteral : bool with get
override IsTextualLiteral : bool with get
abstract IsTextualLiteral : bool with get
override IsTextualLiteral : bool with get

Property Value

Type: Online Boolean
See Also
LaconfigToken Class
LaconfigToken Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigToken.Kind Property

LaconfigToken Kind Property NFX Class Library

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TokenKind Kind { get; }
public override TokenKind Kind { get; }
Public Overrides ReadOnly Property Kind As TokenKind
    Get
Public Overrides ReadOnly Property Kind As TokenKind
    Get
public:
virtual property TokenKind Kind {
    TokenKind get () override;
}
public:
virtual property TokenKind Kind {
    TokenKind get () override;
}
abstract Kind : TokenKind with get
override Kind : TokenKind with get
abstract Kind : TokenKind with get
override Kind : TokenKind with get

Property Value

Type: TokenKind
See Also
LaconfigToken Class
LaconfigToken Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigToken.Language Property

LaconfigToken Language Property NFX Class Library

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Language Language { get; }
public override Language Language { get; }
Public Overrides ReadOnly Property Language As Language
    Get
Public Overrides ReadOnly Property Language As Language
    Get
public:
virtual property Language^ Language {
    Language^ get () override;
}
public:
virtual property Language^ Language {
    Language^ get () override;
}
abstract Language : Language with get
override Language : Language with get
abstract Language : Language with get
override Language : Language with get

Property Value

Type: Language
See Also
LaconfigToken Class
LaconfigToken Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigToken.OrdinalType Property

LaconfigToken OrdinalType Property NFX Class Library

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int OrdinalType { get; }
public override int OrdinalType { get; }
Public Overrides ReadOnly Property OrdinalType As Integer
    Get
Public Overrides ReadOnly Property OrdinalType As Integer
    Get
public:
virtual property int OrdinalType {
    int get () override;
}
public:
virtual property int OrdinalType {
    int get () override;
}
abstract OrdinalType : int with get
override OrdinalType : int with get
abstract OrdinalType : int with get
override OrdinalType : int with get

Property Value

Type: Online Int32
See Also
LaconfigToken Class
LaconfigToken Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigTokenType Enumeration

LaconfigTokenType Enumeration NFX Class Library

Denotes Laconfig token types

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum LaconfigTokenType
public enum LaconfigTokenType
Public Enumeration LaconfigTokenType
Public Enumeration LaconfigTokenType
public enum class LaconfigTokenType
public enum class LaconfigTokenType
type LaconfigTokenType
type LaconfigTokenType
Members
Member name | Value | Description
tUnknown | 0 |
NONLANG_START | 1 |
tBOF | 2 |
tEOF | 3 |
tDirective | 4 |
NONLANG_END | 5 |
tComment | 6 |
SYMBOLS_START | 7 |
tBraceOpen | 8 |
tBraceClose | 9 |
SYMBOLS_END | 10 |
tEQ | 11 |
tIdentifier | 12 |
LITERALS_START | 13 |
tStringLiteral | 14 |
LITERALS_END | 15 |
See Also
NFX.CodeAnalysis.Laconfig Namespace


LaconfigWriter Class

LaconfigWriter Class NFX Class Library

Writes Laconic Configuration into a stream or string
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis.Laconfig LaconfigWriter

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class LaconfigWriter
public static class LaconfigWriter
Public NotInheritable Class LaconfigWriter
Public NotInheritable Class LaconfigWriter
public ref class LaconfigWriter abstract sealed
public ref class LaconfigWriter abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type LaconfigWriter =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type LaconfigWriter =  class end
See Also
LaconfigWriter Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigWriter Members

LaconfigWriter Members NFX Class Library

The LaconfigWriter type exposes the following members.
Methods
Name | Description
Indent | Returns a padding string for specified level per set options
Write(Configuration, LaconfigWritingOptions) | Writes LaconicConfiguration data to the string
Write(IConfigSectionNode, LaconfigWritingOptions) | Writes LaconicConfiguration data to the string
Write(Configuration, StringBuilder, LaconfigWritingOptions) | Appends LaconicConfiguration data into the instance of StringBuilder
Write(IConfigSectionNode, StringBuilder, LaconfigWritingOptions) | Appends LaconicConfiguration data into the instance of StringBuilder
Write(Configuration, Stream, LaconfigWritingOptions, Encoding) | Writes LaconicConfiguration data to the stream
Write(IConfigSectionNode, Stream, LaconfigWritingOptions, Encoding) | Writes LaconicConfiguration data to the stream
Back to Top
See Also
LaconfigWriter Class
NFX.CodeAnalysis.Laconfig Namespace


LaconfigWriter Methods

LaconfigWriter Methods NFX Class Library

The LaconfigWriter type exposes the following members.
Methods
Name | Description
Indent | Returns a padding string for specified level per set options
Write(Configuration, LaconfigWritingOptions) | Writes LaconicConfiguration data to the string
Write(IConfigSectionNode, LaconfigWritingOptions) | Writes LaconicConfiguration data to the string
Write(Configuration, StringBuilder, LaconfigWritingOptions) | Appends LaconicConfiguration data into the instance of StringBuilder
Write(IConfigSectionNode, StringBuilder, LaconfigWritingOptions) | Appends LaconicConfiguration data into the instance of StringBuilder
Write(Configuration, Stream, LaconfigWritingOptions, Encoding) | Writes LaconicConfiguration data to the stream
Write(IConfigSectionNode, Stream, LaconfigWritingOptions, Encoding) | Writes LaconicConfiguration data to the stream
Back to Top
See Also
LaconfigWriter Class
NFX.CodeAnalysis.Laconfig Namespace


LaconfigWriter.Indent Method

LaconfigWriter Indent Method NFX Class Library

Returns a padding string for specified level per set options

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Indent(
    int level,
    LaconfigWritingOptions opt
)
public static string Indent(
    int level,
    LaconfigWritingOptions opt
)
Public Shared Function Indent (
    level As Integer,
    opt As LaconfigWritingOptions
) As String
Public Shared Function Indent (
    level As Integer,
    opt As LaconfigWritingOptions
) As String
public:
static String^ Indent(
    int level,
    LaconfigWritingOptions^ opt
)
public:
static String^ Indent(
    int level,
    LaconfigWritingOptions^ opt
)
static member Indent :
        level : int *
        opt : LaconfigWritingOptions -> string
static member Indent :
        level : int *
        opt : LaconfigWritingOptions -> string

Parameters

level
Type: Online System Int32
opt
Type: NFX.CodeAnalysis.Laconfig LaconfigWritingOptions

Return Value

Type: Online String
See Also
LaconfigWriter Class
LaconfigWriter Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigWriter.Write Method

LaconfigWriter Write Method NFX Class Library

Overload List
Name | Description
Write(Configuration, LaconfigWritingOptions) | Writes LaconicConfiguration data to the string
Write(IConfigSectionNode, LaconfigWritingOptions) | Writes LaconicConfiguration data to the string
Write(Configuration, StringBuilder, LaconfigWritingOptions) | Appends LaconicConfiguration data into the instance of StringBuilder
Write(IConfigSectionNode, StringBuilder, LaconfigWritingOptions) | Appends LaconicConfiguration data into the instance of StringBuilder
Write(Configuration, Stream, LaconfigWritingOptions, Encoding) | Writes LaconicConfiguration data to the stream
Write(IConfigSectionNode, Stream, LaconfigWritingOptions, Encoding) | Writes LaconicConfiguration data to the stream
Back to Top
See Also
LaconfigWriter Class
LaconfigWriter Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigWriter.Write Method (Configuration, LaconfigWritingOptions)

LaconfigWriter Write Method (Configuration, LaconfigWritingOptions) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes LaconicConfiguration data to the string

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Write(
    Configuration data,
    LaconfigWritingOptions options = null
)
public static string Write(
    Configuration data,
    LaconfigWritingOptions options = null
)
Public Shared Function Write (
    data As Configuration,
    Optional options As LaconfigWritingOptions = Nothing
) As String
Public Shared Function Write (
    data As Configuration,
    Optional options As LaconfigWritingOptions = Nothing
) As String
public:
static String^ Write(
    Configuration^ data,
    LaconfigWritingOptions^ options = nullptr
)
public:
static String^ Write(
    Configuration^ data,
    LaconfigWritingOptions^ options = nullptr
)
static member Write :
        data : Configuration *
        ?options : LaconfigWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> string
static member Write :
        data : Configuration *
        ?options : LaconfigWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> string

Parameters

data
Type: NFX.Environment Configuration
options (Optional)
Type: NFX.CodeAnalysis.Laconfig LaconfigWritingOptions

Return Value

Type: Online String
See Also
LaconfigWriter Class
LaconfigWriter Members
Write Overload
NFX.CodeAnalysis.Laconfig Namespace


LaconfigWriter.Write Method (IConfigSectionNode, LaconfigWritingOptions)

LaconfigWriter Write Method (IConfigSectionNode, LaconfigWritingOptions) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes LaconicConfiguration data to the string

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Write(
    IConfigSectionNode data,
    LaconfigWritingOptions options = null
)
public static string Write(
    IConfigSectionNode data,
    LaconfigWritingOptions options = null
)
Public Shared Function Write (
    data As IConfigSectionNode,
    Optional options As LaconfigWritingOptions = Nothing
) As String
Public Shared Function Write (
    data As IConfigSectionNode,
    Optional options As LaconfigWritingOptions = Nothing
) As String
public:
static String^ Write(
    IConfigSectionNode^ data,
    LaconfigWritingOptions^ options = nullptr
)
public:
static String^ Write(
    IConfigSectionNode^ data,
    LaconfigWritingOptions^ options = nullptr
)
static member Write :
        data : IConfigSectionNode *
        ?options : LaconfigWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> string
static member Write :
        data : IConfigSectionNode *
        ?options : LaconfigWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> string

Parameters

data
Type: NFX.Environment IConfigSectionNode
options (Optional)
Type: NFX.CodeAnalysis.Laconfig LaconfigWritingOptions

Return Value

Type: Online String
See Also
LaconfigWriter Class
LaconfigWriter Members
Write Overload
NFX.CodeAnalysis.Laconfig Namespace


LaconfigWriter.Write Method (Configuration, StringBuilder, LaconfigWritingOptions)

LaconfigWriter Write Method (Configuration, StringBuilder, LaconfigWritingOptions) NFX Class Library

[This is preliminary documentation and is subject to change.]

Appends LaconicConfiguration data into the instance of StringBuilder

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    Configuration data,
    StringBuilder sb,
    LaconfigWritingOptions options = null
)
public static void Write(
    Configuration data,
    StringBuilder sb,
    LaconfigWritingOptions options = null
)
Public Shared Sub Write (
    data As Configuration,
    sb As StringBuilder,
    Optional options As LaconfigWritingOptions = Nothing
)
Public Shared Sub Write (
    data As Configuration,
    sb As StringBuilder,
    Optional options As LaconfigWritingOptions = Nothing
)
public:
static void Write(
    Configuration^ data,
    StringBuilder^ sb,
    LaconfigWritingOptions^ options = nullptr
)
public:
static void Write(
    Configuration^ data,
    StringBuilder^ sb,
    LaconfigWritingOptions^ options = nullptr
)
static member Write :
        data : Configuration *
        sb : StringBuilder *
        ?options : LaconfigWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
static member Write :
        data : Configuration *
        sb : StringBuilder *
        ?options : LaconfigWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

data
Type: NFX.Environment Configuration
sb
Type: Online System.Text StringBuilder
options (Optional)
Type: NFX.CodeAnalysis.Laconfig LaconfigWritingOptions
See Also
LaconfigWriter Class
LaconfigWriter Members
Write Overload
NFX.CodeAnalysis.Laconfig Namespace


LaconfigWriter.Write Method (IConfigSectionNode, StringBuilder, LaconfigWritingOptions)

LaconfigWriter Write Method (IConfigSectionNode, StringBuilder, LaconfigWritingOptions) NFX Class Library

[This is preliminary documentation and is subject to change.]

Appends LaconicConfiguration data into the instance of StringBuilder

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    IConfigSectionNode data,
    StringBuilder sb,
    LaconfigWritingOptions options = null
)
public static void Write(
    IConfigSectionNode data,
    StringBuilder sb,
    LaconfigWritingOptions options = null
)
Public Shared Sub Write (
    data As IConfigSectionNode,
    sb As StringBuilder,
    Optional options As LaconfigWritingOptions = Nothing
)
Public Shared Sub Write (
    data As IConfigSectionNode,
    sb As StringBuilder,
    Optional options As LaconfigWritingOptions = Nothing
)
public:
static void Write(
    IConfigSectionNode^ data,
    StringBuilder^ sb,
    LaconfigWritingOptions^ options = nullptr
)
public:
static void Write(
    IConfigSectionNode^ data,
    StringBuilder^ sb,
    LaconfigWritingOptions^ options = nullptr
)
static member Write :
        data : IConfigSectionNode *
        sb : StringBuilder *
        ?options : LaconfigWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
static member Write :
        data : IConfigSectionNode *
        sb : StringBuilder *
        ?options : LaconfigWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

data
Type: NFX.Environment IConfigSectionNode
sb
Type: Online System.Text StringBuilder
options (Optional)
Type: NFX.CodeAnalysis.Laconfig LaconfigWritingOptions
See Also
LaconfigWriter Class
LaconfigWriter Members
Write Overload
NFX.CodeAnalysis.Laconfig Namespace


LaconfigWriter.Write Method (Configuration, Stream, LaconfigWritingOptions, Encoding)

LaconfigWriter Write Method (Configuration, Stream, LaconfigWritingOptions, Encoding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes LaconicConfiguration data to the stream

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    Configuration data,
    Stream stream,
    LaconfigWritingOptions options = null,
    Encoding encoding = null
)
public static void Write(
    Configuration data,
    Stream stream,
    LaconfigWritingOptions options = null,
    Encoding encoding = null
)
Public Shared Sub Write (
    data As Configuration,
    stream As Stream,
    Optional options As LaconfigWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing
)
Public Shared Sub Write (
    data As Configuration,
    stream As Stream,
    Optional options As LaconfigWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing
)
public:
static void Write(
    Configuration^ data,
    Stream^ stream,
    LaconfigWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr
)
public:
static void Write(
    Configuration^ data,
    Stream^ stream,
    LaconfigWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr
)
static member Write :
        data : Configuration *
        stream : Stream *
        ?options : LaconfigWritingOptions *
        ?encoding : Encoding
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
*)
-> unit
static member Write :
        data : Configuration *
        stream : Stream *
        ?options : LaconfigWritingOptions *
        ?encoding : Encoding
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
*)
-> unit

Parameters

data
Type: NFX.Environment Configuration
stream
Type: Online System.IO Stream
options (Optional)
Type: NFX.CodeAnalysis.Laconfig LaconfigWritingOptions
encoding (Optional)
Type: Online System.Text Encoding
See Also
LaconfigWriter Class
LaconfigWriter Members
Write Overload
NFX.CodeAnalysis.Laconfig Namespace


LaconfigWriter.Write Method (IConfigSectionNode, Stream, LaconfigWritingOptions, Encoding)

LaconfigWriter Write Method (IConfigSectionNode, Stream, LaconfigWritingOptions, Encoding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes LaconicConfiguration data to the stream

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    IConfigSectionNode data,
    Stream stream,
    LaconfigWritingOptions options = null,
    Encoding encoding = null
)
public static void Write(
    IConfigSectionNode data,
    Stream stream,
    LaconfigWritingOptions options = null,
    Encoding encoding = null
)
Public Shared Sub Write (
    data As IConfigSectionNode,
    stream As Stream,
    Optional options As LaconfigWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing
)
Public Shared Sub Write (
    data As IConfigSectionNode,
    stream As Stream,
    Optional options As LaconfigWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing
)
public:
static void Write(
    IConfigSectionNode^ data,
    Stream^ stream,
    LaconfigWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr
)
public:
static void Write(
    IConfigSectionNode^ data,
    Stream^ stream,
    LaconfigWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr
)
static member Write :
        data : IConfigSectionNode *
        stream : Stream *
        ?options : LaconfigWritingOptions *
        ?encoding : Encoding
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
*)
-> unit
static member Write :
        data : IConfigSectionNode *
        stream : Stream *
        ?options : LaconfigWritingOptions *
        ?encoding : Encoding
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
*)
-> unit

Parameters

data
Type: NFX.Environment IConfigSectionNode
stream
Type: Online System.IO Stream
options (Optional)
Type: NFX.CodeAnalysis.Laconfig LaconfigWritingOptions
encoding (Optional)
Type: Online System.Text Encoding
See Also
LaconfigWriter Class
LaconfigWriter Members
Write Overload
NFX.CodeAnalysis.Laconfig Namespace


LaconfigWritingOptions Class

LaconfigWritingOptions Class NFX Class Library

Specifies how Laconic configuration should be written as text. Use LaconfigWritingOptions.Compact or LaconfigWritingOptions.PrettyPrint static properties for typical options
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis.Laconfig LaconfigWritingOptions

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LaconfigWritingOptions : IConfigurable
public class LaconfigWritingOptions : IConfigurable
Public Class LaconfigWritingOptions
    Implements IConfigurable
Public Class LaconfigWritingOptions
    Implements IConfigurable
public ref class LaconfigWritingOptions : IConfigurable
public ref class LaconfigWritingOptions : IConfigurable
type LaconfigWritingOptions =
    class
        interface IConfigurable
    end
type LaconfigWritingOptions =
    class
        interface IConfigurable
    end
See Also
LaconfigWritingOptions Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigWritingOptions Members

LaconfigWritingOptions Members NFX Class Library

The LaconfigWritingOptions type exposes the following members.
Constructors
 | Name | Description
Public method | LaconfigWritingOptions | Initializes a new instance of the LaconfigWritingOptions class
Back to Top
Methods
 | Name | Description
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | AttributeLineBreak |
Public field | DontWriteRootSectionDeclaration | If true, does not write the very top node declaration: name, value and { }. The attributes are still written as usual. This is needed for storage conf in db where the root node is not needed to save space
Public field | IndentWidth |
Public field | SectionLineBreak |
Back to Top
Properties
Name | Description
Compact | Writes Laconfig without line breaks between members and no indenting. Suitable for data transmission
PrettyPrint | Writes Laconfig suitable for printing/screen display
Back to Top
See Also
LaconfigWritingOptions Class
NFX.CodeAnalysis.Laconfig Namespace


LaconfigWritingOptions Constructor

LaconfigWritingOptions Constructor NFX Class Library

Initializes a new instance of the LaconfigWritingOptions class

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LaconfigWritingOptions()
public LaconfigWritingOptions()
Public Sub New
Public Sub New
public:
LaconfigWritingOptions()
public:
LaconfigWritingOptions()
new : unit -> LaconfigWritingOptions
new : unit -> LaconfigWritingOptions
See Also
LaconfigWritingOptions Class
LaconfigWritingOptions Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigWritingOptions Fields

LaconfigWritingOptions Fields NFX Class Library

The LaconfigWritingOptions type exposes the following members.
Fields
 | Name | Description
Public field | AttributeLineBreak |
Public field | DontWriteRootSectionDeclaration | If true, does not write the very top node declaration: name, value and { }. The attributes are still written as usual. This is needed for storage conf in db where the root node is not needed to save space
Public field | IndentWidth |
Public field | SectionLineBreak |
Back to Top
See Also
LaconfigWritingOptions Class
NFX.CodeAnalysis.Laconfig Namespace


LaconfigWritingOptions.AttributeLineBreak Field

LaconfigWritingOptions AttributeLineBreak Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool AttributeLineBreak
[ConfigAttribute]
public bool AttributeLineBreak
<ConfigAttribute>
Public AttributeLineBreak As Boolean
<ConfigAttribute>
Public AttributeLineBreak As Boolean
public:
[ConfigAttribute]
bool AttributeLineBreak
public:
[ConfigAttribute]
bool AttributeLineBreak
[<ConfigAttribute>]
val mutable AttributeLineBreak: bool
[<ConfigAttribute>]
val mutable AttributeLineBreak: bool

Field Value

Type: Online Boolean
See Also
LaconfigWritingOptions Class
LaconfigWritingOptions Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigWritingOptions.DontWriteRootSectionDeclaration Field

LaconfigWritingOptions DontWriteRootSectionDeclaration Field NFX Class Library

[This is preliminary documentation and is subject to change.]

If true, does not write the very top node declaration: name, value and { }. The attributes are still written as usual. This is needed for storage conf in db where the root node is not needed to save space

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool DontWriteRootSectionDeclaration
[ConfigAttribute]
public bool DontWriteRootSectionDeclaration
<ConfigAttribute>
Public DontWriteRootSectionDeclaration As Boolean
<ConfigAttribute>
Public DontWriteRootSectionDeclaration As Boolean
public:
[ConfigAttribute]
bool DontWriteRootSectionDeclaration
public:
[ConfigAttribute]
bool DontWriteRootSectionDeclaration
[<ConfigAttribute>]
val mutable DontWriteRootSectionDeclaration: bool
[<ConfigAttribute>]
val mutable DontWriteRootSectionDeclaration: bool

Field Value

Type: Online Boolean
See Also
LaconfigWritingOptions Class
LaconfigWritingOptions Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigWritingOptions.IndentWidth Field

LaconfigWritingOptions IndentWidth Field NFX Class Library

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int IndentWidth
[ConfigAttribute]
public int IndentWidth
<ConfigAttribute>
Public IndentWidth As Integer
<ConfigAttribute>
Public IndentWidth As Integer
public:
[ConfigAttribute]
int IndentWidth
public:
[ConfigAttribute]
int IndentWidth
[<ConfigAttribute>]
val mutable IndentWidth: int
[<ConfigAttribute>]
val mutable IndentWidth: int

Field Value

Type: Online Int32
See Also
LaconfigWritingOptions Class
LaconfigWritingOptions Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigWritingOptions.SectionLineBreak Field

LaconfigWritingOptions SectionLineBreak Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool SectionLineBreak
[ConfigAttribute]
public bool SectionLineBreak
<ConfigAttribute>
Public SectionLineBreak As Boolean
<ConfigAttribute>
Public SectionLineBreak As Boolean
public:
[ConfigAttribute]
bool SectionLineBreak
public:
[ConfigAttribute]
bool SectionLineBreak
[<ConfigAttribute>]
val mutable SectionLineBreak: bool
[<ConfigAttribute>]
val mutable SectionLineBreak: bool

Field Value

Type: Online Boolean
See Also
LaconfigWritingOptions Class
LaconfigWritingOptions Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigWritingOptions Methods

LaconfigWritingOptions Methods NFX Class Library

The LaconfigWritingOptions type exposes the following members.
Methods
 | Name | Description
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LaconfigWritingOptions Class
NFX.CodeAnalysis.Laconfig Namespace


LaconfigWritingOptions.Configure Method

LaconfigWritingOptions Configure Method NFX Class Library

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode node
)
public void Configure(
    IConfigSectionNode node
)
Public Sub Configure (
    node As IConfigSectionNode
)
Public Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
LaconfigWritingOptions Class
LaconfigWritingOptions Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigWritingOptions Properties

LaconfigWritingOptions Properties NFX Class Library

The LaconfigWritingOptions type exposes the following members.
Properties
Name | Description
Compact | Writes Laconfig without line breaks between members and no indenting. Suitable for data transmission
PrettyPrint | Writes Laconfig suitable for printing/screen display
Back to Top
See Also
LaconfigWritingOptions Class
NFX.CodeAnalysis.Laconfig Namespace


LaconfigWritingOptions.Compact Property

LaconfigWritingOptions Compact Property NFX Class Library

Writes Laconfig without line breaks between members and no indenting. Suitable for data transmission

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static LaconfigWritingOptions Compact { get; }
public static LaconfigWritingOptions Compact { get; }
Public Shared ReadOnly Property Compact As LaconfigWritingOptions
    Get
Public Shared ReadOnly Property Compact As LaconfigWritingOptions
    Get
public:
static property LaconfigWritingOptions^ Compact {
    LaconfigWritingOptions^ get ();
}
public:
static property LaconfigWritingOptions^ Compact {
    LaconfigWritingOptions^ get ();
}
static member Compact : LaconfigWritingOptions with get
static member Compact : LaconfigWritingOptions with get

Property Value

Type: LaconfigWritingOptions
See Also
LaconfigWritingOptions Class
LaconfigWritingOptions Members
NFX.CodeAnalysis.Laconfig Namespace


LaconfigWritingOptions.PrettyPrint Property

LaconfigWritingOptions PrettyPrint Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes Laconfig suitable for printing/screen display

Namespace: NFX.CodeAnalysis.Laconfig
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static LaconfigWritingOptions PrettyPrint { get; }
public static LaconfigWritingOptions PrettyPrint { get; }
Public Shared ReadOnly Property PrettyPrint As LaconfigWritingOptions
    Get
Public Shared ReadOnly Property PrettyPrint As LaconfigWritingOptions
    Get
public:
static property LaconfigWritingOptions^ PrettyPrint {
    LaconfigWritingOptions^ get ();
}
public:
static property LaconfigWritingOptions^ PrettyPrint {
    LaconfigWritingOptions^ get ();
}
static member PrettyPrint : LaconfigWritingOptions with get
static member PrettyPrint : LaconfigWritingOptions with get

Property Value

Type: LaconfigWritingOptions
See Also
LaconfigWritingOptions Class
LaconfigWritingOptions Members
NFX.CodeAnalysis.Laconfig Namespace


NFX.CodeAnalysis.Source Namespace

NFX.CodeAnalysis.Source Namespace NFX Class Library

Provides functions for working with textual source code i.e. reading source form file, named memory buffer, project items and the like
Classes
 | Class | Description
Public class | FileNameList | Represents a list of file names
Public class | FileSource | Represents source code stored in a file
Public class | ListOfISourceText | Represents a list of strings used as source text
Public class | StreamSource | Represents source code stored in a stream
Public class | StringSource | Provides source code from string
Public class | StringSourceList | Represents a list of strings used as source text
Structures
 | Structure | Description
Public structure | SourceCodeRef | Represents a reference to the source code which may be named buffer or project source item (i.e. solution project item)
Public structure | SourcePosition | Represents position in source input
Public structure | SourceVector | Represents a pointer to the named source code and character position
Interfaces
 | Interface | Description
Public interface | ISourceText | Represents source code input text (usually text from file)


FileNameList Class

FileNameList Class NFX Class Library

Represents a list of file names
Inheritance Hierarchy
Online System Object
Online System.Collections.Generic List Online String
NFX.CodeAnalysis.Source FileNameList

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class FileNameList : List<string>
public class FileNameList : List<string>
Public Class FileNameList
    Inherits List(Of String)
Public Class FileNameList
    Inherits List(Of String)
public ref class FileNameList : public List<String^>
public ref class FileNameList : public List<String^>
type FileNameList =
    class
        inherit List<string>
    end
type FileNameList =
    class
        inherit List<string>
    end
See Also
FileNameList Members
NFX.CodeAnalysis.Source Namespace


FileNameList Members

FileNameList Members NFX Class Library

The FileNameList type exposes the following members.
Constructors
 | Name | Description
Public method | FileNameList | Initializes a new instance of the FileNameList class
Back to Top
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List Online String .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List Online String .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List Online String .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List Online String .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Online String .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Online String .)
Public method | CheckAllNames | Checks that all files exist
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List Online String .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List Online String .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List Online String .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List Online String .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Online String .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Online String .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List Online String .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List Online String .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Online String .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Online String .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Online String .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Online String .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List Online String .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Online String .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Online String .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Online String .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List Online String .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List Online String .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List Online String .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Online String .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Online String .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Online String .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List Online String .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List Online String .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Online String .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Online String .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Online String .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List Online String .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Online String .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List Online String .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List Online String .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List Online String .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List Online String .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List Online String .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List Online String .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List Online String .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List Online String .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List Online String .)
Public method | ToString | (Overrides Online Object ToString .)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List Online String .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List Online String .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List Online String .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List Online String .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List Online String .)
Back to Top
See Also
FileNameList Class
NFX.CodeAnalysis.Source Namespace


FileNameList Constructor

FileNameList Constructor NFX Class Library

Initializes a new instance of the FileNameList class

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileNameList()
public FileNameList()
Public Sub New
Public Sub New
public:
FileNameList()
public:
FileNameList()
new : unit -> FileNameList
new : unit -> FileNameList
See Also
FileNameList Class
FileNameList Members
NFX.CodeAnalysis.Source Namespace


FileNameList Methods

FileNameList Methods NFX Class Library

The FileNameList type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List Online String .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List Online String .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List Online String .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List Online String .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Online String .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Online String .)
Public method | CheckAllNames | Checks that all files exist
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List Online String .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List Online String .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List Online String .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List Online String .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Online String .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Online String .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List Online String .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List Online String .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Online String .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Online String .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Online String .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Online String .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List Online String .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Online String .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Online String .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Online String .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List Online String .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List Online String .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List Online String .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Online String .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Online String .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Online String .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List Online String .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List Online String .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Online String .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Online String .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Online String .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List Online String .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Online String .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List Online String .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List Online String .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List Online String .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List Online String .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List Online String .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List Online String .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List Online String .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List Online String .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List Online String .)
Public method | ToString | (Overrides Online Object ToString .)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List Online String .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List Online String .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
FileNameList Class
NFX.CodeAnalysis.Source Namespace


FileNameList.CheckAllNames Method

FileNameList CheckAllNames Method NFX Class Library

Checks that all files exist

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CheckAllNames()
public void CheckAllNames()
Public Sub CheckAllNames
Public Sub CheckAllNames
public:
void CheckAllNames()
public:
void CheckAllNames()
member CheckAllNames : unit -> unit
member CheckAllNames : unit -> unit
See Also
FileNameList Class
FileNameList Members
NFX.CodeAnalysis.Source Namespace


FileNameList.ToString Method

FileNameList ToString Method NFX Class Library

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
FileNameList Class
FileNameList Members
NFX.CodeAnalysis.Source Namespace


FileNameList Properties

FileNameList Properties NFX Class Library

The FileNameList type exposes the following members.
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List Online String .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List Online String .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List Online String .)
Back to Top
See Also
FileNameList Class
NFX.CodeAnalysis.Source Namespace


FileSource Class

FileSource Class NFX Class Library

Represents source code stored in a file
Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.IO TextReader
Online System.IO StreamReader
NFX.CodeAnalysis.Source FileSource

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class FileSource : StreamReader, ISourceText
public class FileSource : StreamReader, ISourceText
Public Class FileSource
    Inherits StreamReader
    Implements ISourceText
Public Class FileSource
    Inherits StreamReader
    Implements ISourceText
public ref class FileSource : public StreamReader,
    ISourceText
public ref class FileSource : public StreamReader,
    ISourceText
type FileSource =
    class
        inherit StreamReader
        interface ISourceText
    end
type FileSource =
    class
        inherit StreamReader
        interface ISourceText
    end
See Also
FileSource Members
NFX.CodeAnalysis.Source Namespace


FileSource Members

FileSource Members NFX Class Library

The FileSource type exposes the following members.
Constructors
 | Name | Description
Public method | FileSource(String) | Constructs file source infering source language from file extension
Public method | FileSource(Language, String) | Constructs file source with specified language ignoring file extension
Back to Top
Methods
 | Name | Description
Public method | Online Close | Closes the Online StreamReader object and the underlying stream, and releases any system resources associated with the reader. (Inherited from Online StreamReader.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online DiscardBufferedData | (Inherited from Online StreamReader.)
Public method | Online Dispose | Releases all resources used by the Online TextReader object. (Inherited from Online TextReader.)
Protected method | Online Dispose(Boolean) | (Inherited from Online StreamReader.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Public method | Online Peek | (Inherited from Online StreamReader.)
Public method | PeekChar |
Public method | Online Read | (Inherited from Online StreamReader.)
Public method | Online Read( Char , Int32, Int32) | (Inherited from Online StreamReader.)
Public method | ReadAsync | (Inherited from Online StreamReader.)
Public method | ReadBlock | (Inherited from Online StreamReader.)
Public method | ReadBlockAsync | (Inherited from Online StreamReader.)
Public method | ReadChar |
Public method | Online ReadLine | (Inherited from Online StreamReader.)
Public method | ReadLineAsync | (Inherited from Online StreamReader.)
Public method | Online ReadToEnd | (Inherited from Online StreamReader.)
Public method | ReadToEndAsync | (Inherited from Online StreamReader.)
Public method | Reset |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsCharEnumerable | (Defined by IOMiscUtils.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online BaseStream | (Inherited from Online StreamReader.)
Public property | Online CurrentEncoding | (Inherited from Online StreamReader.)
Public property | Online EndOfStream | (Inherited from Online StreamReader.)
Public property | EOF |
Public property | Language |
Public property | Name | Returns source's file name
Back to Top
See Also
FileSource Class
NFX.CodeAnalysis.Source Namespace


FileSource Constructor

FileSource Constructor NFX Class Library

Overload List
 | Name | Description
Public method | FileSource(String) | Constructs file source infering source language from file extension
Public method | FileSource(Language, String) | Constructs file source with specified language ignoring file extension
Back to Top
See Also
FileSource Class
FileSource Members
NFX.CodeAnalysis.Source Namespace


FileSource Constructor (String)

FileSource Constructor (String) NFX Class Library

Constructs file source infering source language from file extension

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSource(
    string fileName
)
public FileSource(
    string fileName
)
Public Sub New (
    fileName As String
)
Public Sub New (
    fileName As String
)
public:
FileSource(
    String^ fileName
)
public:
FileSource(
    String^ fileName
)
new :
        fileName : string -> FileSource
new :
        fileName : string -> FileSource

Parameters

fileName
Type: Online System String
See Also
FileSource Class
FileSource Members
FileSource Overload
NFX.CodeAnalysis.Source Namespace


FileSource Constructor (Language, String)

FileSource Constructor (Language, String) NFX Class Library

Constructs file source with specified language ignoring file extension

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSource(
    Language language,
    string fileName
)
public FileSource(
    Language language,
    string fileName
)
Public Sub New (
    language As Language,
    fileName As String
)
Public Sub New (
    language As Language,
    fileName As String
)
public:
FileSource(
    Language^ language,
    String^ fileName
)
public:
FileSource(
    Language^ language,
    String^ fileName
)
new :
        language : Language *
        fileName : string -> FileSource
new :
        language : Language *
        fileName : string -> FileSource

Parameters

language
Type: NFX.CodeAnalysis Language
fileName
Type: Online System String
See Also
FileSource Class
FileSource Members
FileSource Overload
NFX.CodeAnalysis.Source Namespace


FileSource Methods

FileSource Methods NFX Class Library

The FileSource type exposes the following members.
Methods
 | Name | Description
Public method | Online Close | Closes the Online StreamReader object and the underlying stream, and releases any system resources associated with the reader. (Inherited from Online StreamReader.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online DiscardBufferedData | (Inherited from Online StreamReader.)
Public method | Online Dispose | Releases all resources used by the Online TextReader object. (Inherited from Online TextReader.)
Protected method | Online Dispose(Boolean) | (Inherited from Online StreamReader.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Public method | Online Peek | (Inherited from Online StreamReader.)
Public method | PeekChar |
Public method | Online Read | (Inherited from Online StreamReader.)
Public method | Online Read( Char , Int32, Int32) | (Inherited from Online StreamReader.)
Public method | ReadAsync | (Inherited from Online StreamReader.)
Public method | ReadBlock | (Inherited from Online StreamReader.)
Public method | ReadBlockAsync | (Inherited from Online StreamReader.)
Public method | ReadChar |
Public method | Online ReadLine | (Inherited from Online StreamReader.)
Public method | ReadLineAsync | (Inherited from Online StreamReader.)
Public method | Online ReadToEnd | (Inherited from Online StreamReader.)
Public method | ReadToEndAsync | (Inherited from Online StreamReader.)
Public method | Reset |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsCharEnumerable | (Defined by IOMiscUtils.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
FileSource Class
NFX.CodeAnalysis.Source Namespace


FileSource.PeekChar Method

FileSource PeekChar Method NFX Class Library

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char PeekChar()
public char PeekChar()
Public Function PeekChar As Char
Public Function PeekChar As Char
public:
virtual wchar_t PeekChar() sealed
public:
virtual wchar_t PeekChar() sealed
abstract PeekChar : unit -> char
override PeekChar : unit -> char
abstract PeekChar : unit -> char
override PeekChar : unit -> char

Return Value

Type: Online Char

Implements

ISourceText PeekChar
See Also
FileSource Class
FileSource Members
NFX.CodeAnalysis.Source Namespace


FileSource.ReadChar Method

FileSource ReadChar Method NFX Class Library

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char ReadChar()
public char ReadChar()
Public Function ReadChar As Char
Public Function ReadChar As Char
public:
virtual wchar_t ReadChar() sealed
public:
virtual wchar_t ReadChar() sealed
abstract ReadChar : unit -> char
override ReadChar : unit -> char
abstract ReadChar : unit -> char
override ReadChar : unit -> char

Return Value

Type: Online Char

Implements

ISourceText ReadChar
See Also
FileSource Class
FileSource Members
NFX.CodeAnalysis.Source Namespace


FileSource.Reset Method

FileSource Reset Method NFX Class Library

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Reset()
public void Reset()
Public Sub Reset
Public Sub Reset
public:
virtual void Reset() sealed
public:
virtual void Reset() sealed
abstract Reset : unit -> unit
override Reset : unit -> unit
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

ISourceText Reset
See Also
FileSource Class
FileSource Members
NFX.CodeAnalysis.Source Namespace


FileSource Properties

FileSource Properties NFX Class Library

The FileSource type exposes the following members.
Properties
 | Name | Description
Public property | Online BaseStream | (Inherited from Online StreamReader.)
Public property | Online CurrentEncoding | (Inherited from Online StreamReader.)
Public property | Online EndOfStream | (Inherited from Online StreamReader.)
Public property | EOF |
Public property | Language |
Public property | Name | Returns source's file name
Back to Top
See Also
FileSource Class
NFX.CodeAnalysis.Source Namespace


FileSource.EOF Property

FileSource EOF Property NFX Class Library

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool EOF { get; }
public bool EOF { get; }
Public ReadOnly Property EOF As Boolean
    Get
Public ReadOnly Property EOF As Boolean
    Get
public:
virtual property bool EOF {
    bool get () sealed;
}
public:
virtual property bool EOF {
    bool get () sealed;
}
abstract EOF : bool with get
override EOF : bool with get
abstract EOF : bool with get
override EOF : bool with get

Property Value

Type: Online Boolean

Implements

ISourceText EOF
See Also
FileSource Class
FileSource Members
NFX.CodeAnalysis.Source Namespace


FileSource.Language Property

FileSource Language Property NFX Class Library

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Language Language { get; }
public Language Language { get; }
Public ReadOnly Property Language As Language
    Get
Public ReadOnly Property Language As Language
    Get
public:
virtual property Language^ Language {
    Language^ get () sealed;
}
public:
virtual property Language^ Language {
    Language^ get () sealed;
}
abstract Language : Language with get
override Language : Language with get
abstract Language : Language with get
override Language : Language with get

Property Value

Type: Language

Implements

ISourceText Language
See Also
FileSource Class
FileSource Members
NFX.CodeAnalysis.Source Namespace


FileSource.Name Property

FileSource Name Property NFX Class Library

Returns source's file name

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

ISourceText Name
See Also
FileSource Class
FileSource Members
NFX.CodeAnalysis.Source Namespace


ISourceText Interface

ISourceText Interface NFX Class Library

Represents source code input text (usually text from file)

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ISourceText
public interface ISourceText
Public Interface ISourceText
Public Interface ISourceText
public interface class ISourceText
public interface class ISourceText
type ISourceText =  interface end
type ISourceText =  interface end
See Also
ISourceText Members
NFX.CodeAnalysis.Source Namespace


ISourceText Members

ISourceText Members NFX Class Library

The ISourceText type exposes the following members.
Methods
 | Name | Description
Public method | PeekChar | Returns next char without advancing position
Public method | ReadChar | Returns next char and advances position
Public method | Reset | Resets source to beginning
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | EOF | Indicates whether last character has been read
Public property | Language | Indicates what language this source is supplied in
Public property | Name | Provides a meaningfull name to a source code
Back to Top
See Also
ISourceText Interface
NFX.CodeAnalysis.Source Namespace


ISourceText Methods

ISourceText Methods NFX Class Library

The ISourceText type exposes the following members.
Methods
 | Name | Description
Public method | PeekChar | Returns next char without advancing position
Public method | ReadChar | Returns next char and advances position
Public method | Reset | Resets source to beginning
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Back to Top
See Also
ISourceText Interface
NFX.CodeAnalysis.Source Namespace


ISourceText.PeekChar Method

ISourceText PeekChar Method NFX Class Library

Returns next char without advancing position

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
char PeekChar()
char PeekChar()
Function PeekChar As Char
Function PeekChar As Char
wchar_t PeekChar()
wchar_t PeekChar()
abstract PeekChar : unit -> char
abstract PeekChar : unit -> char

Return Value

Type: Online Char
See Also
ISourceText Interface
ISourceText Members
NFX.CodeAnalysis.Source Namespace


ISourceText.ReadChar Method

ISourceText ReadChar Method NFX Class Library

Returns next char and advances position

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
char ReadChar()
char ReadChar()
Function ReadChar As Char
Function ReadChar As Char
wchar_t ReadChar()
wchar_t ReadChar()
abstract ReadChar : unit -> char
abstract ReadChar : unit -> char

Return Value

Type: Online Char
See Also
ISourceText Interface
ISourceText Members
NFX.CodeAnalysis.Source Namespace


ISourceText.Reset Method

ISourceText Reset Method NFX Class Library

Resets source to beginning

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Reset()
void Reset()
Sub Reset
Sub Reset
void Reset()
void Reset()
abstract Reset : unit -> unit
abstract Reset : unit -> unit
See Also
ISourceText Interface
ISourceText Members
NFX.CodeAnalysis.Source Namespace


ISourceText Properties

ISourceText Properties NFX Class Library

The ISourceText type exposes the following members.
Properties
 | Name | Description
Public property | EOF | Indicates whether last character has been read
Public property | Language | Indicates what language this source is supplied in
Public property | Name | Provides a meaningfull name to a source code
Back to Top
See Also
ISourceText Interface
NFX.CodeAnalysis.Source Namespace


ISourceText.EOF Property

ISourceText EOF Property NFX Class Library

Indicates whether last character has been read

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool EOF { get; }
bool EOF { get; }
ReadOnly Property EOF As Boolean
    Get
ReadOnly Property EOF As Boolean
    Get
property bool EOF {
    bool get ();
}
property bool EOF {
    bool get ();
}
abstract EOF : bool with get
abstract EOF : bool with get

Property Value

Type: Online Boolean
See Also
ISourceText Interface
ISourceText Members
NFX.CodeAnalysis.Source Namespace


ISourceText.Language Property

ISourceText Language Property NFX Class Library

Indicates what language this source is supplied in

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Language Language { get; }
Language Language { get; }
ReadOnly Property Language As Language
    Get
ReadOnly Property Language As Language
    Get
property Language^ Language {
    Language^ get ();
}
property Language^ Language {
    Language^ get ();
}
abstract Language : Language with get
abstract Language : Language with get

Property Value

Type: Language
See Also
ISourceText Interface
ISourceText Members
NFX.CodeAnalysis.Source Namespace


ISourceText.Name Property

ISourceText Name Property NFX Class Library

Provides a meaningfull name to a source code

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Name { get; }
string Name { get; }
ReadOnly Property Name As String
    Get
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
property String^ Name {
    String^ get ();
}
abstract Name : string with get
abstract Name : string with get

Property Value

Type: Online String
See Also
ISourceText Interface
ISourceText Members
NFX.CodeAnalysis.Source Namespace


ListOfISourceText Class

ListOfISourceText Class NFX Class Library

Represents a list of strings used as source text
Inheritance Hierarchy
Online System Object
Online System.Collections.Generic List ISourceText
NFX.CodeAnalysis.Source ListOfISourceText

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ListOfISourceText : List<ISourceText>
public class ListOfISourceText : List<ISourceText>
Public Class ListOfISourceText
    Inherits List(Of ISourceText)
Public Class ListOfISourceText
    Inherits List(Of ISourceText)
public ref class ListOfISourceText : public List<ISourceText^>
public ref class ListOfISourceText : public List<ISourceText^>
type ListOfISourceText =
    class
        inherit List<ISourceText>
    end
type ListOfISourceText =
    class
        inherit List<ISourceText>
    end
See Also
ListOfISourceText Members
NFX.CodeAnalysis.Source Namespace


ListOfISourceText Members

ListOfISourceText Members NFX Class Library

The ListOfISourceText type exposes the following members.
Constructors
 | Name | Description
Public method | ListOfISourceText | Initializes a new instance of the ListOfISourceText class
Back to Top
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List ISourceText .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List ISourceText .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List ISourceText .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List ISourceText .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List ISourceText .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List ISourceText .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List ISourceText .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List ISourceText .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List ISourceText .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List ISourceText .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List ISourceText .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List ISourceText .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List ISourceText .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List ISourceText .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List ISourceText .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List ISourceText .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List ISourceText .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List ISourceText .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List ISourceText .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List ISourceText .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List ISourceText .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List ISourceText .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List ISourceText .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List ISourceText .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List ISourceText .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List ISourceText .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List ISourceText .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List ISourceText .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List ISourceText .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List ISourceText .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List ISourceText .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List ISourceText .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List ISourceText .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List ISourceText .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List ISourceText .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List ISourceText .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List ISourceText .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List ISourceText .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List ISourceText .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List ISourceText .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List ISourceText .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List ISourceText .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List ISourceText .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List ISourceText .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List ISourceText .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List ISourceText .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List ISourceText .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List ISourceText .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List ISourceText .)
Back to Top
See Also
ListOfISourceText Class
NFX.CodeAnalysis.Source Namespace


ListOfISourceText Constructor

ListOfISourceText Constructor NFX Class Library

Initializes a new instance of the ListOfISourceText class

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ListOfISourceText()
public ListOfISourceText()
Public Sub New
Public Sub New
public:
ListOfISourceText()
public:
ListOfISourceText()
new : unit -> ListOfISourceText
new : unit -> ListOfISourceText
See Also
ListOfISourceText Class
ListOfISourceText Members
NFX.CodeAnalysis.Source Namespace


ListOfISourceText Methods

ListOfISourceText Methods NFX Class Library

The ListOfISourceText type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List ISourceText .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List ISourceText .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List ISourceText .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List ISourceText .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List ISourceText .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List ISourceText .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List ISourceText .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List ISourceText .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List ISourceText .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List ISourceText .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List ISourceText .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List ISourceText .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List ISourceText .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List ISourceText .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List ISourceText .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List ISourceText .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List ISourceText .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List ISourceText .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List ISourceText .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List ISourceText .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List ISourceText .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List ISourceText .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List ISourceText .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List ISourceText .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List ISourceText .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List ISourceText .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List ISourceText .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List ISourceText .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List ISourceText .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List ISourceText .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List ISourceText .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List ISourceText .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List ISourceText .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List ISourceText .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List ISourceText .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List ISourceText .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List ISourceText .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List ISourceText .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List ISourceText .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List ISourceText .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List ISourceText .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List ISourceText .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List ISourceText .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List ISourceText .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List ISourceText .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List ISourceText .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ListOfISourceText Class
NFX.CodeAnalysis.Source Namespace


ListOfISourceText Properties

ListOfISourceText Properties NFX Class Library

The ListOfISourceText type exposes the following members.
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List ISourceText .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List ISourceText .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List ISourceText .)
Back to Top
See Also
ListOfISourceText Class
NFX.CodeAnalysis.Source Namespace


SourceCodeRef Structure

SourceCodeRef Structure NFX Class Library

Represents a reference to the source code which may be named buffer or project source item (i.e. solution project item)

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct SourceCodeRef
public struct SourceCodeRef
Public Structure SourceCodeRef
Public Structure SourceCodeRef
public value class SourceCodeRef
public value class SourceCodeRef
[<SealedAttribute>]
type SourceCodeRef =  struct end
[<SealedAttribute>]
type SourceCodeRef =  struct end
See Also
SourceCodeRef Members
NFX.CodeAnalysis.Source Namespace


SourceCodeRef Members

SourceCodeRef Members NFX Class Library

The SourceCodeRef type exposes the following members.
Constructors
 | Name | Description
Public method | SourceCodeRef(String) | Initializes a new instance of the SourceCodeRef class
Public method | SourceCodeRef(IProjectItem) | Initializes a new instance of the SourceCodeRef class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | ProjectItem | References project source item, this property may be null
Public field | SourceName | Provides name for the source, this property is set to ProjectItem.Name when IProjectItem is supplied in .ctor
Back to Top
See Also
SourceCodeRef Structure
NFX.CodeAnalysis.Source Namespace


SourceCodeRef Constructor

SourceCodeRef Constructor NFX Class Library

Overload List
 | Name | Description
Public method | SourceCodeRef(String) | Initializes a new instance of the SourceCodeRef class
Public method | SourceCodeRef(IProjectItem) | Initializes a new instance of the SourceCodeRef class
Back to Top
See Also
SourceCodeRef Structure
SourceCodeRef Members
NFX.CodeAnalysis.Source Namespace


SourceCodeRef Constructor (String)

SourceCodeRef Constructor (String) NFX Class Library

Initializes a new instance of the SourceCodeRef class

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SourceCodeRef(
    string srcName
)
public SourceCodeRef(
    string srcName
)
Public Sub New (
    srcName As String
)
Public Sub New (
    srcName As String
)
public:
SourceCodeRef(
    String^ srcName
)
public:
SourceCodeRef(
    String^ srcName
)
new :
        srcName : string -> SourceCodeRef
new :
        srcName : string -> SourceCodeRef

Parameters

srcName
Type: Online System String
See Also
SourceCodeRef Structure
SourceCodeRef Members
SourceCodeRef Overload
NFX.CodeAnalysis.Source Namespace


SourceCodeRef Constructor (IProjectItem)

SourceCodeRef Constructor (IProjectItem) NFX Class Library

Initializes a new instance of the SourceCodeRef class

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SourceCodeRef(
    IProjectItem srcItem
)
public SourceCodeRef(
    IProjectItem srcItem
)
Public Sub New (
    srcItem As IProjectItem
)
Public Sub New (
    srcItem As IProjectItem
)
public:
SourceCodeRef(
    IProjectItem^ srcItem
)
public:
SourceCodeRef(
    IProjectItem^ srcItem
)
new :
        srcItem : IProjectItem -> SourceCodeRef
new :
        srcItem : IProjectItem -> SourceCodeRef

Parameters

srcItem
Type: NFX.CodeAnalysis IProjectItem
See Also
SourceCodeRef Structure
SourceCodeRef Members
SourceCodeRef Overload
NFX.CodeAnalysis.Source Namespace


SourceCodeRef Fields

SourceCodeRef Fields NFX Class Library

The SourceCodeRef type exposes the following members.
Fields
 | Name | Description
Public field | ProjectItem | References project source item, this property may be null
Public field | SourceName | Provides name for the source, this property is set to ProjectItem.Name when IProjectItem is supplied in .ctor
Back to Top
See Also
SourceCodeRef Structure
NFX.CodeAnalysis.Source Namespace


SourceCodeRef.ProjectItem Field

SourceCodeRef ProjectItem Field NFX Class Library

References project source item, this property may be null

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly IProjectItem ProjectItem
public readonly IProjectItem ProjectItem
Public ReadOnly ProjectItem As IProjectItem
Public ReadOnly ProjectItem As IProjectItem
public:
initonly IProjectItem^ ProjectItem
public:
initonly IProjectItem^ ProjectItem
val ProjectItem: IProjectItem
val ProjectItem: IProjectItem

Field Value

Type: IProjectItem
See Also
SourceCodeRef Structure
SourceCodeRef Members
NFX.CodeAnalysis.Source Namespace


SourceCodeRef.SourceName Field

SourceCodeRef SourceName Field NFX Class Library

Provides name for the source, this property is set to ProjectItem.Name when IProjectItem is supplied in .ctor

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string SourceName
public readonly string SourceName
Public ReadOnly SourceName As String
Public ReadOnly SourceName As String
public:
initonly String^ SourceName
public:
initonly String^ SourceName
val SourceName: string
val SourceName: string

Field Value

Type: Online String
See Also
SourceCodeRef Structure
SourceCodeRef Members
NFX.CodeAnalysis.Source Namespace


SourceCodeRef Methods

SourceCodeRef Methods NFX Class Library

The SourceCodeRef type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SourceCodeRef Structure
NFX.CodeAnalysis.Source Namespace


SourceCodeRef.ToString Method

SourceCodeRef ToString Method NFX Class Library

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
SourceCodeRef Structure
SourceCodeRef Members
NFX.CodeAnalysis.Source Namespace


SourcePosition Structure

SourcePosition Structure NFX Class Library

Represents position in source input

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct SourcePosition
public struct SourcePosition
Public Structure SourcePosition
Public Structure SourcePosition
public value class SourcePosition
public value class SourcePosition
[<SealedAttribute>]
type SourcePosition =  struct end
[<SealedAttribute>]
type SourcePosition =  struct end
See Also
SourcePosition Members
NFX.CodeAnalysis.Source Namespace


SourcePosition Members

SourcePosition Members NFX Class Library

The SourcePosition type exposes the following members.
Constructors
 | Name | Description
Public method | SourcePosition | Initializes a new instance of the SourcePosition class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | CharNumber |
Public field | ColNumber |
Public field | LineNumber |
 | UNASSIGNED |
Back to Top
Properties
 | Name | Description
Public property | IsAssigned |
Back to Top
See Also
SourcePosition Structure
NFX.CodeAnalysis.Source Namespace


SourcePosition Constructor

SourcePosition Constructor NFX Class Library

Initializes a new instance of the SourcePosition class

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SourcePosition(
    int lineNum,
    int colNum,
    int charNum
)
public SourcePosition(
    int lineNum,
    int colNum,
    int charNum
)
Public Sub New (
    lineNum As Integer,
    colNum As Integer,
    charNum As Integer
)
Public Sub New (
    lineNum As Integer,
    colNum As Integer,
    charNum As Integer
)
public:
SourcePosition(
    int lineNum,
    int colNum,
    int charNum
)
public:
SourcePosition(
    int lineNum,
    int colNum,
    int charNum
)
new :
        lineNum : int *
        colNum : int *
        charNum : int -> SourcePosition
new :
        lineNum : int *
        colNum : int *
        charNum : int -> SourcePosition

Parameters

lineNum
Type: Online System Int32
colNum
Type: Online System Int32
charNum
Type: Online System Int32
See Also
SourcePosition Structure
SourcePosition Members
NFX.CodeAnalysis.Source Namespace


SourcePosition Fields

SourcePosition Fields NFX Class Library

The SourcePosition type exposes the following members.
Fields
 | Name | Description
Public field | CharNumber |
Public field | ColNumber |
Public field | LineNumber |
 | UNASSIGNED |
Back to Top
See Also
SourcePosition Structure
NFX.CodeAnalysis.Source Namespace


SourcePosition.CharNumber Field

SourcePosition CharNumber Field NFX Class Library

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int CharNumber
public readonly int CharNumber
Public ReadOnly CharNumber As Integer
Public ReadOnly CharNumber As Integer
public:
initonly int CharNumber
public:
initonly int CharNumber
val CharNumber: int
val CharNumber: int

Field Value

Type: Online Int32
See Also
SourcePosition Structure
SourcePosition Members
NFX.CodeAnalysis.Source Namespace


SourcePosition.ColNumber Field

SourcePosition ColNumber Field NFX Class Library

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int ColNumber
public readonly int ColNumber
Public ReadOnly ColNumber As Integer
Public ReadOnly ColNumber As Integer
public:
initonly int ColNumber
public:
initonly int ColNumber
val ColNumber: int
val ColNumber: int

Field Value

Type: Online Int32
See Also
SourcePosition Structure
SourcePosition Members
NFX.CodeAnalysis.Source Namespace


SourcePosition.LineNumber Field

SourcePosition LineNumber Field NFX Class Library

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int LineNumber
public readonly int LineNumber
Public ReadOnly LineNumber As Integer
Public ReadOnly LineNumber As Integer
public:
initonly int LineNumber
public:
initonly int LineNumber
val LineNumber: int
val LineNumber: int

Field Value

Type: Online Int32
See Also
SourcePosition Structure
SourcePosition Members
NFX.CodeAnalysis.Source Namespace


SourcePosition.UNASSIGNED Field

SourcePosition UNASSIGNED Field NFX Class Library

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly SourcePosition UNASSIGNED
public static readonly SourcePosition UNASSIGNED
Public Shared ReadOnly UNASSIGNED As SourcePosition
Public Shared ReadOnly UNASSIGNED As SourcePosition
public:
static initonly SourcePosition UNASSIGNED
public:
static initonly SourcePosition UNASSIGNED
static val UNASSIGNED: SourcePosition
static val UNASSIGNED: SourcePosition

Field Value

Type: SourcePosition
See Also
SourcePosition Structure
SourcePosition Members
NFX.CodeAnalysis.Source Namespace


SourcePosition Methods

SourcePosition Methods NFX Class Library

The SourcePosition type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SourcePosition Structure
NFX.CodeAnalysis.Source Namespace


SourcePosition.ToString Method

SourcePosition ToString Method NFX Class Library

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
SourcePosition Structure
SourcePosition Members
NFX.CodeAnalysis.Source Namespace


SourcePosition Properties

SourcePosition Properties NFX Class Library

The SourcePosition type exposes the following members.
Properties
 | Name | Description
Public property | IsAssigned |
Back to Top
See Also
SourcePosition Structure
NFX.CodeAnalysis.Source Namespace


SourcePosition.IsAssigned Property

SourcePosition IsAssigned Property NFX Class Library

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsAssigned { get; }
public bool IsAssigned { get; }
Public ReadOnly Property IsAssigned As Boolean
    Get
Public ReadOnly Property IsAssigned As Boolean
    Get
public:
property bool IsAssigned {
    bool get ();
}
public:
property bool IsAssigned {
    bool get ();
}
member IsAssigned : bool with get
member IsAssigned : bool with get

Property Value

Type: Online Boolean
See Also
SourcePosition Structure
SourcePosition Members
NFX.CodeAnalysis.Source Namespace


SourceVector Structure

SourceVector Structure NFX Class Library

Represents a pointer to the named source code and character position

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct SourceVector
public struct SourceVector
Public Structure SourceVector
Public Structure SourceVector
public value class SourceVector
public value class SourceVector
[<SealedAttribute>]
type SourceVector =  struct end
[<SealedAttribute>]
type SourceVector =  struct end
See Also
SourceVector Members
NFX.CodeAnalysis.Source Namespace


SourceVector Members

SourceVector Members NFX Class Library

The SourceVector type exposes the following members.
Constructors
 | Name | Description
Public method | SourceVector | Initializes a new instance of the SourceVector class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Position |
Public field | SourceName |
Back to Top
See Also
SourceVector Structure
NFX.CodeAnalysis.Source Namespace


SourceVector Constructor

SourceVector Constructor NFX Class Library

Initializes a new instance of the SourceVector class

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SourceVector(
    string srcName,
    SourcePosition position
)
public SourceVector(
    string srcName,
    SourcePosition position
)
Public Sub New (
    srcName As String,
    position As SourcePosition
)
Public Sub New (
    srcName As String,
    position As SourcePosition
)
public:
SourceVector(
    String^ srcName,
    SourcePosition position
)
public:
SourceVector(
    String^ srcName,
    SourcePosition position
)
new :
        srcName : string *
        position : SourcePosition -> SourceVector
new :
        srcName : string *
        position : SourcePosition -> SourceVector

Parameters

srcName
Type: Online System String
position
Type: NFX.CodeAnalysis.Source SourcePosition
See Also
SourceVector Structure
SourceVector Members
NFX.CodeAnalysis.Source Namespace


SourceVector Fields

SourceVector Fields NFX Class Library

The SourceVector type exposes the following members.
Fields
 | Name | Description
Public field | Position |
Public field | SourceName |
Back to Top
See Also
SourceVector Structure
NFX.CodeAnalysis.Source Namespace


SourceVector.Position Field

SourceVector Position Field NFX Class Library

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SourcePosition Position
public readonly SourcePosition Position
Public ReadOnly Position As SourcePosition
Public ReadOnly Position As SourcePosition
public:
initonly SourcePosition Position
public:
initonly SourcePosition Position
val Position: SourcePosition
val Position: SourcePosition

Field Value

Type: SourcePosition
See Also
SourceVector Structure
SourceVector Members
NFX.CodeAnalysis.Source Namespace


SourceVector.SourceName Field

SourceVector SourceName Field NFX Class Library

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string SourceName
public readonly string SourceName
Public ReadOnly SourceName As String
Public ReadOnly SourceName As String
public:
initonly String^ SourceName
public:
initonly String^ SourceName
val SourceName: string
val SourceName: string

Field Value

Type: Online String
See Also
SourceVector Structure
SourceVector Members
NFX.CodeAnalysis.Source Namespace


SourceVector Methods

SourceVector Methods NFX Class Library

The SourceVector type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SourceVector Structure
NFX.CodeAnalysis.Source Namespace


StreamSource Class

StreamSource Class NFX Class Library

Represents source code stored in a stream
Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.IO TextReader
Online System.IO StreamReader
NFX.CodeAnalysis.Source StreamSource

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class StreamSource : StreamReader,
    ISourceText
public class StreamSource : StreamReader,
    ISourceText
Public Class StreamSource
    Inherits StreamReader
    Implements ISourceText
Public Class StreamSource
    Inherits StreamReader
    Implements ISourceText
public ref class StreamSource : public StreamReader,
    ISourceText
public ref class StreamSource : public StreamReader,
    ISourceText
type StreamSource =
    class
        inherit StreamReader
        interface ISourceText
    end
type StreamSource =
    class
        inherit StreamReader
        interface ISourceText
    end
See Also
StreamSource Members
NFX.CodeAnalysis.Source Namespace


StreamSource Members

StreamSource Members NFX Class Library

The StreamSource type exposes the following members.
Constructors
 | Name | Description
Public method | StreamSource(Stream, Language, String) | Constructs stream source with specified language and default encoding
Public method | StreamSource(Stream, Encoding, Language, String) | Constructs stream source with specified language and encoding
Back to Top
Methods
 | Name | Description
Public method | Online Close | Closes the Online StreamReader object and the underlying stream, and releases any system resources associated with the reader. (Inherited from Online StreamReader.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online DiscardBufferedData | (Inherited from Online StreamReader.)
Public method | Online Dispose | Releases all resources used by the Online TextReader object. (Inherited from Online TextReader.)
Protected method | Online Dispose(Boolean) | (Inherited from Online StreamReader.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Public method | Online Peek | (Inherited from Online StreamReader.)
Public method | PeekChar |
Public method | Online Read | (Inherited from Online StreamReader.)
Public method | Online Read( Char , Int32, Int32) | (Inherited from Online StreamReader.)
Public method | ReadAsync | (Inherited from Online StreamReader.)
Public method | ReadBlock | (Inherited from Online StreamReader.)
Public method | ReadBlockAsync | (Inherited from Online StreamReader.)
Public method | ReadChar |
Public method | Online ReadLine | (Inherited from Online StreamReader.)
Public method | ReadLineAsync | (Inherited from Online StreamReader.)
Public method | Online ReadToEnd | (Inherited from Online StreamReader.)
Public method | ReadToEndAsync | (Inherited from Online StreamReader.)
Public method | Reset |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsCharEnumerable | (Defined by IOMiscUtils.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online BaseStream | (Inherited from Online StreamReader.)
Public property | Online CurrentEncoding | (Inherited from Online StreamReader.)
Public property | Online EndOfStream | (Inherited from Online StreamReader.)
Public property | EOF |
Public property | Language |
Public property | Name | Returns source's name
Back to Top
See Also
StreamSource Class
NFX.CodeAnalysis.Source Namespace


StreamSource Constructor

StreamSource Constructor NFX Class Library

Overload List
 | Name | Description
Public method | StreamSource(Stream, Language, String) | Constructs stream source with specified language and default encoding
Public method | StreamSource(Stream, Encoding, Language, String) | Constructs stream source with specified language and encoding
Back to Top
See Also
StreamSource Class
StreamSource Members
NFX.CodeAnalysis.Source Namespace


StreamSource Constructor (Stream, Language, String)

StreamSource Constructor (Stream, Language, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Constructs stream source with specified language and default encoding

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StreamSource(
    Stream stream,
    Language language,
    string name = null
)
public StreamSource(
    Stream stream,
    Language language,
    string name = null
)
Public Sub New (
    stream As Stream,
    language As Language,
    Optional name As String = Nothing
)
Public Sub New (
    stream As Stream,
    language As Language,
    Optional name As String = Nothing
)
public:
StreamSource(
    Stream^ stream,
    Language^ language,
    String^ name = nullptr
)
public:
StreamSource(
    Stream^ stream,
    Language^ language,
    String^ name = nullptr
)
new :
        stream : Stream *
        language : Language *
        ?name : string
(* Defaults:
        let _name = defaultArg name null
*)
-> StreamSource
new :
        stream : Stream *
        language : Language *
        ?name : string
(* Defaults:
        let _name = defaultArg name null
*)
-> StreamSource

Parameters

stream
Type: Online System.IO Stream
language
Type: NFX.CodeAnalysis Language
name (Optional)
Type: Online System String
See Also
StreamSource Class
StreamSource Members
StreamSource Overload
NFX.CodeAnalysis.Source Namespace


StreamSource Constructor (Stream, Encoding, Language, String)

StreamSource Constructor (Stream, Encoding, Language, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Constructs stream source with specified language and encoding

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StreamSource(
    Stream stream,
    Encoding encoding,
    Language language,
    string name = null
)
public StreamSource(
    Stream stream,
    Encoding encoding,
    Language language,
    string name = null
)
Public Sub New (
    stream As Stream,
    encoding As Encoding,
    language As Language,
    Optional name As String = Nothing
)
Public Sub New (
    stream As Stream,
    encoding As Encoding,
    language As Language,
    Optional name As String = Nothing
)
public:
StreamSource(
    Stream^ stream,
    Encoding^ encoding,
    Language^ language,
    String^ name = nullptr
)
public:
StreamSource(
    Stream^ stream,
    Encoding^ encoding,
    Language^ language,
    String^ name = nullptr
)
new :
        stream : Stream *
        encoding : Encoding *
        language : Language *
        ?name : string
(* Defaults:
        let _name = defaultArg name null
*)
-> StreamSource
new :
        stream : Stream *
        encoding : Encoding *
        language : Language *
        ?name : string
(* Defaults:
        let _name = defaultArg name null
*)
-> StreamSource

Parameters

stream
Type: Online System.IO Stream
encoding
Type: Online System.Text Encoding
language
Type: NFX.CodeAnalysis Language
name (Optional)
Type: Online System String
See Also
StreamSource Class
StreamSource Members
StreamSource Overload
NFX.CodeAnalysis.Source Namespace


StreamSource Methods

StreamSource Methods NFX Class Library

The StreamSource type exposes the following members.
Methods
 | Name | Description
Public method | Online Close | Closes the Online StreamReader object and the underlying stream, and releases any system resources associated with the reader. (Inherited from Online StreamReader.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Public method | Online DiscardBufferedData | (Inherited from Online StreamReader.)
Public method | Online Dispose | Releases all resources used by the Online TextReader object. (Inherited from Online TextReader.)
Protected method | Online Dispose(Boolean) | (Inherited from Online StreamReader.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Public method | Online Peek | (Inherited from Online StreamReader.)
Public method | PeekChar |
Public method | Online Read | (Inherited from Online StreamReader.)
Public method | Online Read( Char , Int32, Int32) | (Inherited from Online StreamReader.)
Public method | ReadAsync | (Inherited from Online StreamReader.)
Public method | ReadBlock | (Inherited from Online StreamReader.)
Public method | ReadBlockAsync | (Inherited from Online StreamReader.)
Public method | ReadChar |
Public method | Online ReadLine | (Inherited from Online StreamReader.)
Public method | ReadLineAsync | (Inherited from Online StreamReader.)
Public method | Online ReadToEnd | (Inherited from Online StreamReader.)
Public method | ReadToEndAsync | (Inherited from Online StreamReader.)
Public method | Reset |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsCharEnumerable | (Defined by IOMiscUtils.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
StreamSource Class
NFX.CodeAnalysis.Source Namespace


StreamSource.PeekChar Method

StreamSource PeekChar Method NFX Class Library

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char PeekChar()
public char PeekChar()
Public Function PeekChar As Char
Public Function PeekChar As Char
public:
virtual wchar_t PeekChar() sealed
public:
virtual wchar_t PeekChar() sealed
abstract PeekChar : unit -> char
override PeekChar : unit -> char
abstract PeekChar : unit -> char
override PeekChar : unit -> char

Return Value

Type: Online Char

Implements

ISourceText PeekChar
See Also
StreamSource Class
StreamSource Members
NFX.CodeAnalysis.Source Namespace


StreamSource.ReadChar Method

StreamSource ReadChar Method NFX Class Library

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char ReadChar()
public char ReadChar()
Public Function ReadChar As Char
Public Function ReadChar As Char
public:
virtual wchar_t ReadChar() sealed
public:
virtual wchar_t ReadChar() sealed
abstract ReadChar : unit -> char
override ReadChar : unit -> char
abstract ReadChar : unit -> char
override ReadChar : unit -> char

Return Value

Type: Online Char

Implements

ISourceText ReadChar
See Also
StreamSource Class
StreamSource Members
NFX.CodeAnalysis.Source Namespace


StreamSource.Reset Method

StreamSource Reset Method NFX Class Library

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Reset()
public void Reset()
Public Sub Reset
Public Sub Reset
public:
virtual void Reset() sealed
public:
virtual void Reset() sealed
abstract Reset : unit -> unit
override Reset : unit -> unit
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

ISourceText Reset
See Also
StreamSource Class
StreamSource Members
NFX.CodeAnalysis.Source Namespace


StreamSource Properties

StreamSource Properties NFX Class Library

The StreamSource type exposes the following members.
Properties
 | Name | Description
Public property | Online BaseStream | (Inherited from Online StreamReader.)
Public property | Online CurrentEncoding | (Inherited from Online StreamReader.)
Public property | Online EndOfStream | (Inherited from Online StreamReader.)
Public property | EOF |
Public property | Language |
Public property | Name | Returns source's name
Back to Top
See Also
StreamSource Class
NFX.CodeAnalysis.Source Namespace


StreamSource.EOF Property

StreamSource EOF Property NFX Class Library

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool EOF { get; }
public bool EOF { get; }
Public ReadOnly Property EOF As Boolean
    Get
Public ReadOnly Property EOF As Boolean
    Get
public:
virtual property bool EOF {
    bool get () sealed;
}
public:
virtual property bool EOF {
    bool get () sealed;
}
abstract EOF : bool with get
override EOF : bool with get
abstract EOF : bool with get
override EOF : bool with get

Property Value

Type: Online Boolean

Implements

ISourceText EOF
See Also
StreamSource Class
StreamSource Members
NFX.CodeAnalysis.Source Namespace


StreamSource.Language Property

StreamSource Language Property NFX Class Library

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Language Language { get; }
public Language Language { get; }
Public ReadOnly Property Language As Language
    Get
Public ReadOnly Property Language As Language
    Get
public:
virtual property Language^ Language {
    Language^ get () sealed;
}
public:
virtual property Language^ Language {
    Language^ get () sealed;
}
abstract Language : Language with get
override Language : Language with get
abstract Language : Language with get
override Language : Language with get

Property Value

Type: Language

Implements

ISourceText Language
See Also
StreamSource Class
StreamSource Members
NFX.CodeAnalysis.Source Namespace


StreamSource.Name Property

StreamSource Name Property NFX Class Library

Returns source's name

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

ISourceText Name
See Also
StreamSource Class
StreamSource Members
NFX.CodeAnalysis.Source Namespace


StringSource Class

StringSource Class NFX Class Library

Provides source code from string
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis.Source StringSource

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class StringSource : ISourceText
public class StringSource : ISourceText
Public Class StringSource
    Implements ISourceText
Public Class StringSource
    Implements ISourceText
public ref class StringSource : ISourceText
public ref class StringSource : ISourceText
type StringSource =
    class
        interface ISourceText
    end
type StringSource =
    class
        interface ISourceText
    end
See Also
StringSource Members
NFX.CodeAnalysis.Source Namespace


StringSource Members

StringSource Members NFX Class Library

The StringSource type exposes the following members.
Constructors
 | Name | Description
Public method | StringSource | Initializes a new instance of the StringSource class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PeekChar |
Public method | ReadChar |
Public method | Reset |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | EOF |
Public property | Language |
Public property | Name | Provides a handy way to name an otherwise-anonymous string source code, This property is like a "file name" only data is kept in a string
Back to Top
See Also
StringSource Class
NFX.CodeAnalysis.Source Namespace


StringSource Constructor

StringSource Constructor NFX Class Library

Initializes a new instance of the StringSource class

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StringSource(
    string source,
    Language language = null,
    string name = null
)
public StringSource(
    string source,
    Language language = null,
    string name = null
)
Public Sub New (
    source As String,
    Optional language As Language = Nothing,
    Optional name As String = Nothing
)
Public Sub New (
    source As String,
    Optional language As Language = Nothing,
    Optional name As String = Nothing
)
public:
StringSource(
    String^ source,
    Language^ language = nullptr,
    String^ name = nullptr
)
public:
StringSource(
    String^ source,
    Language^ language = nullptr,
    String^ name = nullptr
)
new :
        source : string *
        ?language : Language *
        ?name : string
(* Defaults:
        let _language = defaultArg language null
        let _name = defaultArg name null
*)
-> StringSource
new :
        source : string *
        ?language : Language *
        ?name : string
(* Defaults:
        let _language = defaultArg language null
        let _name = defaultArg name null
*)
-> StringSource

Parameters

source
Type: Online System String
language (Optional)
Type: NFX.CodeAnalysis Language
name (Optional)
Type: Online System String
See Also
StringSource Class
StringSource Members
NFX.CodeAnalysis.Source Namespace


StringSource Methods

StringSource Methods NFX Class Library

The StringSource type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PeekChar |
Public method | ReadChar |
Public method | Reset |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
StringSource Class
NFX.CodeAnalysis.Source Namespace


StringSource.PeekChar Method

StringSource PeekChar Method NFX Class Library

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char PeekChar()
public char PeekChar()
Public Function PeekChar As Char
Public Function PeekChar As Char
public:
virtual wchar_t PeekChar() sealed
public:
virtual wchar_t PeekChar() sealed
abstract PeekChar : unit -> char
override PeekChar : unit -> char
abstract PeekChar : unit -> char
override PeekChar : unit -> char

Return Value

Type: Online Char

Implements

ISourceText PeekChar
See Also
StringSource Class
StringSource Members
NFX.CodeAnalysis.Source Namespace


StringSource.ReadChar Method

StringSource ReadChar Method NFX Class Library

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char ReadChar()
public char ReadChar()
Public Function ReadChar As Char
Public Function ReadChar As Char
public:
virtual wchar_t ReadChar() sealed
public:
virtual wchar_t ReadChar() sealed
abstract ReadChar : unit -> char
override ReadChar : unit -> char
abstract ReadChar : unit -> char
override ReadChar : unit -> char

Return Value

Type: Online Char

Implements

ISourceText ReadChar
See Also
StringSource Class
StringSource Members
NFX.CodeAnalysis.Source Namespace


StringSource.Reset Method

StringSource Reset Method NFX Class Library

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Reset()
public void Reset()
Public Sub Reset
Public Sub Reset
public:
virtual void Reset() sealed
public:
virtual void Reset() sealed
abstract Reset : unit -> unit
override Reset : unit -> unit
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

ISourceText Reset
See Also
StringSource Class
StringSource Members
NFX.CodeAnalysis.Source Namespace


StringSource Properties

StringSource Properties NFX Class Library

The StringSource type exposes the following members.
Properties
 | Name | Description
Public property | EOF |
Public property | Language |
Public property | Name | Provides a handy way to name an otherwise-anonymous string source code, This property is like a "file name" only data is kept in a string
Back to Top
See Also
StringSource Class
NFX.CodeAnalysis.Source Namespace


StringSource.EOF Property

StringSource EOF Property NFX Class Library

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool EOF { get; }
public bool EOF { get; }
Public ReadOnly Property EOF As Boolean
    Get
Public ReadOnly Property EOF As Boolean
    Get
public:
virtual property bool EOF {
    bool get () sealed;
}
public:
virtual property bool EOF {
    bool get () sealed;
}
abstract EOF : bool with get
override EOF : bool with get
abstract EOF : bool with get
override EOF : bool with get

Property Value

Type: Online Boolean

Implements

ISourceText EOF
See Also
StringSource Class
StringSource Members
NFX.CodeAnalysis.Source Namespace


StringSource.Language Property

StringSource Language Property NFX Class Library

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Language Language { get; }
public Language Language { get; }
Public ReadOnly Property Language As Language
    Get
Public ReadOnly Property Language As Language
    Get
public:
virtual property Language^ Language {
    Language^ get () sealed;
}
public:
virtual property Language^ Language {
    Language^ get () sealed;
}
abstract Language : Language with get
override Language : Language with get
abstract Language : Language with get
override Language : Language with get

Property Value

Type: Language

Implements

ISourceText Language
See Also
StringSource Class
StringSource Members
NFX.CodeAnalysis.Source Namespace


StringSource.Name Property

StringSource Name Property NFX Class Library

Provides a handy way to name an otherwise-anonymous string source code, This property is like a "file name" only data is kept in a string

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

ISourceText Name
See Also
StringSource Class
StringSource Members
NFX.CodeAnalysis.Source Namespace


StringSourceList Class

StringSourceList Class NFX Class Library

Represents a list of strings used as source text
Inheritance Hierarchy
Online System Object
Online System.Collections.Generic List StringSource
NFX.CodeAnalysis.Source StringSourceList

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class StringSourceList : List<StringSource>
public class StringSourceList : List<StringSource>
Public Class StringSourceList
    Inherits List(Of StringSource)
Public Class StringSourceList
    Inherits List(Of StringSource)
public ref class StringSourceList : public List<StringSource^>
public ref class StringSourceList : public List<StringSource^>
type StringSourceList =
    class
        inherit List<StringSource>
    end
type StringSourceList =
    class
        inherit List<StringSource>
    end
See Also
StringSourceList Members
NFX.CodeAnalysis.Source Namespace


StringSourceList Members

StringSourceList Members NFX Class Library

The StringSourceList type exposes the following members.
Constructors
 | Name | Description
Public method | StringSourceList | Initializes a new instance of the StringSourceList class
Back to Top
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List StringSource .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List StringSource .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List StringSource .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List StringSource .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List StringSource .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List StringSource .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List StringSource .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List StringSource .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List StringSource .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List StringSource .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List StringSource .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List StringSource .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List StringSource .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List StringSource .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List StringSource .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List StringSource .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List StringSource .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List StringSource .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List StringSource .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List StringSource .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List StringSource .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List StringSource .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List StringSource .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List StringSource .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List StringSource .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List StringSource .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List StringSource .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List StringSource .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List StringSource .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List StringSource .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List StringSource .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List StringSource .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List StringSource .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List StringSource .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List StringSource .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List StringSource .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List StringSource .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List StringSource .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List StringSource .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List StringSource .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List StringSource .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List StringSource .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List StringSource .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List StringSource .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List StringSource .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List StringSource .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List StringSource .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List StringSource .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List StringSource .)
Back to Top
See Also
StringSourceList Class
NFX.CodeAnalysis.Source Namespace


StringSourceList Constructor

StringSourceList Constructor NFX Class Library

Initializes a new instance of the StringSourceList class

Namespace: NFX.CodeAnalysis.Source
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StringSourceList()
public StringSourceList()
Public Sub New
Public Sub New
public:
StringSourceList()
public:
StringSourceList()
new : unit -> StringSourceList
new : unit -> StringSourceList
See Also
StringSourceList Class
StringSourceList Members
NFX.CodeAnalysis.Source Namespace


StringSourceList Methods

StringSourceList Methods NFX Class Library

The StringSourceList type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List StringSource .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List StringSource .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List StringSource .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List StringSource .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List StringSource .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List StringSource .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List StringSource .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List StringSource .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List StringSource .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List StringSource .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List StringSource .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List StringSource .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List StringSource .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List StringSource .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List StringSource .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List StringSource .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List StringSource .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List StringSource .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List StringSource .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List StringSource .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List StringSource .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List StringSource .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List StringSource .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List StringSource .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List StringSource .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List StringSource .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List StringSource .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List StringSource .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List StringSource .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List StringSource .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List StringSource .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List StringSource .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List StringSource .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List StringSource .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List StringSource .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List StringSource .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List StringSource .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List StringSource .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List StringSource .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List StringSource .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List StringSource .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List StringSource .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List StringSource .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List StringSource .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List StringSource .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List StringSource .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
StringSourceList Class
NFX.CodeAnalysis.Source Namespace


StringSourceList Properties

StringSourceList Properties NFX Class Library

The StringSourceList type exposes the following members.
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List StringSource .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List StringSource .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List StringSource .)
Back to Top
See Also
StringSourceList Class
NFX.CodeAnalysis.Source Namespace


NFX.CodeAnalysis.XML Namespace

NFX.CodeAnalysis.XML Namespace NFX Class Library

Classes
 | Class | Description
Public class | XMLLanguage | Represents XML language


XMLLanguage Class

XMLLanguage Class NFX Class Library

Represents XML language
Inheritance Hierarchy
Online System Object
NFX.CodeAnalysis Language
NFX.CodeAnalysis.XML XMLLanguage

Namespace: NFX.CodeAnalysis.XML
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class XMLLanguage : Language
public sealed class XMLLanguage : Language
Public NotInheritable Class XMLLanguage
    Inherits Language
Public NotInheritable Class XMLLanguage
    Inherits Language
public ref class XMLLanguage sealed : public Language
public ref class XMLLanguage sealed : public Language
[<SealedAttribute>]
type XMLLanguage =
    class
        inherit Language
    end
[<SealedAttribute>]
type XMLLanguage =
    class
        inherit Language
    end
See Also
XMLLanguage Members
NFX.CodeAnalysis.XML Namespace


XMLLanguage Members

XMLLanguage Members NFX Class Library

The XMLLanguage type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeLexer | (Overrides Language MakeLexer(IAnalysisContext, SourceCodeRef, ISourceText, MessageList, Boolean).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from Language.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
Instance |
Back to Top
Properties
 | Name | Description
Public property | Family | (Overrides Language Family.)
Public property | FileExtensions | (Overrides Language FileExtensions.)
Back to Top
See Also
XMLLanguage Class
NFX.CodeAnalysis.XML Namespace


XMLLanguage Fields

XMLLanguage Fields NFX Class Library

The XMLLanguage type exposes the following members.
Fields
Name | Description
Instance |
Back to Top
See Also
XMLLanguage Class
NFX.CodeAnalysis.XML Namespace


XMLLanguage.Instance Field

XMLLanguage Instance Field NFX Class Library

Namespace: NFX.CodeAnalysis.XML
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly XMLLanguage Instance
public static readonly XMLLanguage Instance
Public Shared ReadOnly Instance As XMLLanguage
Public Shared ReadOnly Instance As XMLLanguage
public:
static initonly XMLLanguage^ Instance
public:
static initonly XMLLanguage^ Instance
static val Instance: XMLLanguage
static val Instance: XMLLanguage

Field Value

Type: XMLLanguage
See Also
XMLLanguage Class
XMLLanguage Members
NFX.CodeAnalysis.XML Namespace


XMLLanguage Methods

XMLLanguage Methods NFX Class Library

The XMLLanguage type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeLexer | (Overrides Language MakeLexer(IAnalysisContext, SourceCodeRef, ISourceText, MessageList, Boolean).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from Language.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
XMLLanguage Class
NFX.CodeAnalysis.XML Namespace


XMLLanguage.MakeLexer Method

XMLLanguage MakeLexer Method NFX Class Library

Namespace: NFX.CodeAnalysis.XML
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ILexer MakeLexer(
    IAnalysisContext context,
    SourceCodeRef srcRef,
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
public override ILexer MakeLexer(
    IAnalysisContext context,
    SourceCodeRef srcRef,
    ISourceText source,
    MessageList messages = null,
    bool throwErrors = false
)
Public Overrides Function MakeLexer (
    context As IAnalysisContext,
    srcRef As SourceCodeRef,
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
) As ILexer
Public Overrides Function MakeLexer (
    context As IAnalysisContext,
    srcRef As SourceCodeRef,
    source As ISourceText,
    Optional messages As MessageList = Nothing,
    Optional throwErrors As Boolean = false
) As ILexer
public:
virtual ILexer^ MakeLexer(
    IAnalysisContext^ context,
    SourceCodeRef srcRef,
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
) override
public:
virtual ILexer^ MakeLexer(
    IAnalysisContext^ context,
    SourceCodeRef srcRef,
    ISourceText^ source,
    MessageList^ messages = nullptr,
    bool throwErrors = false
) override
abstract MakeLexer :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> ILexer
override MakeLexer :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> ILexer
abstract MakeLexer :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> ILexer
override MakeLexer :
        context : IAnalysisContext *
        srcRef : SourceCodeRef *
        source : ISourceText *
        ?messages : MessageList *
        ?throwErrors : bool
(* Defaults:
        let _messages = defaultArg messages null
        let _throwErrors = defaultArg throwErrors false
*)
-> ILexer

Parameters

context
Type: NFX.CodeAnalysis IAnalysisContext
srcRef
Type: NFX.CodeAnalysis.Source SourceCodeRef
source
Type: NFX.CodeAnalysis.Source ISourceText
messages (Optional)
Type: NFX.CodeAnalysis MessageList
throwErrors (Optional)
Type: Online System Boolean

Return Value

Type: ILexer
See Also
XMLLanguage Class
XMLLanguage Members
NFX.CodeAnalysis.XML Namespace


XMLLanguage Properties

XMLLanguage Properties NFX Class Library

The XMLLanguage type exposes the following members.
Properties
 | Name | Description
Public property | Family | (Overrides Language Family.)
Public property | FileExtensions | (Overrides Language FileExtensions.)
Back to Top
See Also
XMLLanguage Class
NFX.CodeAnalysis.XML Namespace


XMLLanguage.Family Property

XMLLanguage Family Property NFX Class Library

Namespace: NFX.CodeAnalysis.XML
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override LanguageFamily Family { get; }
public override LanguageFamily Family { get; }
Public Overrides ReadOnly Property Family As LanguageFamily
    Get
Public Overrides ReadOnly Property Family As LanguageFamily
    Get
public:
virtual property LanguageFamily Family {
    LanguageFamily get () override;
}
public:
virtual property LanguageFamily Family {
    LanguageFamily get () override;
}
abstract Family : LanguageFamily with get
override Family : LanguageFamily with get
abstract Family : LanguageFamily with get
override Family : LanguageFamily with get

Property Value

Type: LanguageFamily
See Also
XMLLanguage Class
XMLLanguage Members
NFX.CodeAnalysis.XML Namespace


XMLLanguage.FileExtensions Property

XMLLanguage FileExtensions Property NFX Class Library

Namespace: NFX.CodeAnalysis.XML
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IEnumerable<string> FileExtensions { get; }
public override IEnumerable<string> FileExtensions { get; }
Public Overrides ReadOnly Property FileExtensions As IEnumerable(Of String)
    Get
Public Overrides ReadOnly Property FileExtensions As IEnumerable(Of String)
    Get
public:
virtual property IEnumerable<String^>^ FileExtensions {
    IEnumerable<String^>^ get () override;
}
public:
virtual property IEnumerable<String^>^ FileExtensions {
    IEnumerable<String^>^ get () override;
}
abstract FileExtensions : IEnumerable<string> with get
override FileExtensions : IEnumerable<string> with get
abstract FileExtensions : IEnumerable<string> with get
override FileExtensions : IEnumerable<string> with get

Property Value

Type: Online IEnumerable Online String
See Also
XMLLanguage Class
XMLLanguage Members
NFX.CodeAnalysis.XML Namespace


NFX.Collections Namespace

NFX.Collections Namespace NFX Class Library

Provides special purpose collections
Classes
 | Class | Description
Public class | BitList | Provides bit array with automatic resizing
Public class | BitMatrix2D | Provides an efficient access to a square 2D bit matrix accessible as boolean values
Public class | EventedCollectionBase TContext | Provides base implementation for some evented collections
Public class | EventedDictionary TKey, TValue, TContext | Represents a dictionary that rises events
Public class | EventedList TData, TContext | Represents list that rises change events
Public class | LookAheadEnumerable T |
Public class | LookAheadEnumerator T |
Public class | LookAheadExtensions |
Public class | Matrix2D T | Represents a two deminsional matrix of T. This class uses jagged arrays for internal implementation ensuring proper array sizing per matrix structure
Public class | Matrix2DBase T |
Public class | MatrixBase T | Provides base for various matrices
Public class | NamedInterlocked | Provides functionality similar to the Interlocked class executed over a named slot. All operations are THREAD-SAFE for calling concurrently. The name comparison is that of Registry's which is OrdinalIgnoreCase. This class was designed to better organize named counters incremented from different threads, i.e. this is needed to keep a count of calls to remote host identified by their names. This class is NOT designed for frequent additions/deletions of named slots, nor was it designed to keep millions of slots. Use it in cases when there are thousands at most slots and new slots appear infrequently. You must delete un-needed slots
Public class | NamedInterlocked TContext | Adds context to NamedInterlocked
Public class | StringMap | Efficeintly maps string -> string for serialization. Compared to Dictionary[string,string] this class yields 20%-50% better Slim serialization speed improvement and 5%-10% space improvement
Interfaces
 | Interface | Description
Public interface | ILookAheadEnumerable T |
Public interface | ILookAheadEnumerator T |
Delegates
 | Delegate | Description
Public delegate | EventedCollectionGetReadOnlyHandler TContext | Event handler for list changes
Public delegate | EventedDictionary TKey, TValue, TContext ChangeHandler |
Public delegate | EventedList TData, TContext ChangeHandler |
Enumerations
 | Enumeration | Description
Public enumeration | EventedDictionary TKey, TValue, TContext ChangeType | Describes changes in evented list
Public enumeration | EventedList TData, TContext ChangeType | Describes changes in evented list
Public enumeration | EventPhase | Specifies the phase of the event i.e. before/after


BitList Class

BitList Class NFX Class Library

Provides bit array with automatic resizing
Inheritance Hierarchy
Online System Object
NFX.Collections BitList

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class BitList : IEquatable<BitList>
public class BitList : IEquatable<BitList>
Public Class BitList
    Implements IEquatable(Of BitList)
Public Class BitList
    Implements IEquatable(Of BitList)
public ref class BitList : IEquatable<BitList^>
public ref class BitList : IEquatable<BitList^>
type BitList =
    class
        interface IEquatable<BitList>
    end
type BitList =
    class
        interface IEquatable<BitList>
    end
See Also
BitList Members
NFX.Collections Namespace


BitList Members

BitList Members NFX Class Library

The BitList type exposes the following members.
Constructors
 | Name | Description
Public method | BitList | Initializes a new instance of the BitList class
Back to Top
Methods
 | Name | Description
Public method | AppendBit |
Public method | AppendBitList |
Public method | AppendBits |
Public method | Online Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Equals(BitList) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetBytes |
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Public method | Xor |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ByteSize |
Public property | Item |
Public property | Size |
Back to Top
See Also
BitList Class
NFX.Collections Namespace


BitList Constructor

BitList Constructor NFX Class Library

Initializes a new instance of the BitList class

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BitList(
    int initSize = 0
)
public BitList(
    int initSize = 0
)
Public Sub New (
    Optional initSize As Integer = 0
)
Public Sub New (
    Optional initSize As Integer = 0
)
public:
BitList(
    int initSize = 0
)
public:
BitList(
    int initSize = 0
)
new :
        ?initSize : int
(* Defaults:
        let _initSize = defaultArg initSize 0
*)
-> BitList
new :
        ?initSize : int
(* Defaults:
        let _initSize = defaultArg initSize 0
*)
-> BitList

Parameters

initSize (Optional)
Type: Online System Int32
See Also
BitList Class
BitList Members
NFX.Collections Namespace


BitList Methods

BitList Methods NFX Class Library

The BitList type exposes the following members.
Methods
 | Name | Description
Public method | AppendBit |
Public method | AppendBitList |
Public method | AppendBits |
Public method | Online Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Equals(BitList) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetBytes |
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Public method | Xor |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BitList Class
NFX.Collections Namespace


BitList.AppendBit Method

BitList AppendBit Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AppendBit(
    bool bit
)
public void AppendBit(
    bool bit
)
Public Sub AppendBit (
    bit As Boolean
)
Public Sub AppendBit (
    bit As Boolean
)
public:
void AppendBit(
    bool bit
)
public:
void AppendBit(
    bool bit
)
member AppendBit :
        bit : bool -> unit
member AppendBit :
        bit : bool -> unit

Parameters

bit
Type: Online System Boolean
See Also
BitList Class
BitList Members
NFX.Collections Namespace


BitList.AppendBitList Method

BitList AppendBitList Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AppendBitList(
    BitList other
)
public void AppendBitList(
    BitList other
)
Public Sub AppendBitList (
    other As BitList
)
Public Sub AppendBitList (
    other As BitList
)
public:
void AppendBitList(
    BitList^ other
)
public:
void AppendBitList(
    BitList^ other
)
member AppendBitList :
        other : BitList -> unit
member AppendBitList :
        other : BitList -> unit

Parameters

other
Type: NFX.Collections BitList
See Also
BitList Class
BitList Members
NFX.Collections Namespace


BitList.AppendBits Method

BitList AppendBits Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AppendBits(
    int value,
    int numBits
)
public void AppendBits(
    int value,
    int numBits
)
Public Sub AppendBits (
    value As Integer,
    numBits As Integer
)
Public Sub AppendBits (
    value As Integer,
    numBits As Integer
)
public:
void AppendBits(
    int value,
    int numBits
)
public:
void AppendBits(
    int value,
    int numBits
)
member AppendBits :
        value : int *
        numBits : int -> unit
member AppendBits :
        value : int *
        numBits : int -> unit

Parameters

value
Type: Online System Int32
numBits
Type: Online System Int32
See Also
BitList Class
BitList Members
NFX.Collections Namespace


BitList.Equals Method

BitList Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Online Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Equals(BitList) |
Back to Top
See Also
BitList Class
BitList Members
NFX.Collections Namespace


BitList.Equals Method (BitList)

BitList Equals Method (BitList) NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    BitList otherObj
)
public bool Equals(
    BitList otherObj
)
Public Function Equals (
    otherObj As BitList
) As Boolean
Public Function Equals (
    otherObj As BitList
) As Boolean
public:
virtual bool Equals(
    BitList^ otherObj
) sealed
public:
virtual bool Equals(
    BitList^ otherObj
) sealed
abstract Equals :
        otherObj : BitList -> bool
override Equals :
        otherObj : BitList -> bool
abstract Equals :
        otherObj : BitList -> bool
override Equals :
        otherObj : BitList -> bool

Parameters

otherObj
Type: NFX.Collections BitList

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
BitList Class
BitList Members
Equals Overload
NFX.Collections Namespace


BitList.GetBytes Method

BitList GetBytes Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void GetBytes(
    byte[] buf,
    int bitOffset,
    int offset,
    int numBytes
)
public void GetBytes(
    byte[] buf,
    int bitOffset,
    int offset,
    int numBytes
)
Public Sub GetBytes (
    buf As Byte(),
    bitOffset As Integer,
    offset As Integer,
    numBytes As Integer
)
Public Sub GetBytes (
    buf As Byte(),
    bitOffset As Integer,
    offset As Integer,
    numBytes As Integer
)
public:
void GetBytes(
    array<unsigned char>^ buf,
    int bitOffset,
    int offset,
    int numBytes
)
public:
void GetBytes(
    array<unsigned char>^ buf,
    int bitOffset,
    int offset,
    int numBytes
)
member GetBytes :
        buf : byte[] *
        bitOffset : int *
        offset : int *
        numBytes : int -> unit
member GetBytes :
        buf : byte[] *
        bitOffset : int *
        offset : int *
        numBytes : int -> unit

Parameters

buf
Type: Online System Byte
bitOffset
Type: Online System Int32
offset
Type: Online System Int32
numBytes
Type: Online System Int32
See Also
BitList Class
BitList Members
NFX.Collections Namespace


BitList.GetHashCode Method

BitList GetHashCode Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
BitList Class
BitList Members
NFX.Collections Namespace


BitList.ToString Method

BitList ToString Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
BitList Class
BitList Members
NFX.Collections Namespace


BitList.Xor Method

BitList Xor Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Xor(
    BitList other
)
public void Xor(
    BitList other
)
Public Sub Xor (
    other As BitList
)
Public Sub Xor (
    other As BitList
)
public:
void Xor(
    BitList^ other
)
public:
void Xor(
    BitList^ other
)
member Xor :
        other : BitList -> unit
member Xor :
        other : BitList -> unit

Parameters

other
Type: NFX.Collections BitList
See Also
BitList Class
BitList Members
NFX.Collections Namespace


BitList Properties

BitList Properties NFX Class Library

The BitList type exposes the following members.
Properties
 | Name | Description
Public property | ByteSize |
Public property | Item |
Public property | Size |
Back to Top
See Also
BitList Class
NFX.Collections Namespace


BitList.ByteSize Property

BitList ByteSize Property NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ByteSize { get; }
public int ByteSize { get; }
Public ReadOnly Property ByteSize As Integer
    Get
Public ReadOnly Property ByteSize As Integer
    Get
public:
property int ByteSize {
    int get ();
}
public:
property int ByteSize {
    int get ();
}
member ByteSize : int with get
member ByteSize : int with get

Property Value

Type: Online Int32
See Also
BitList Class
BitList Members
NFX.Collections Namespace


BitList.Item Property

BitList Item Property NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool this[
    int i
] { get; set; }
public bool this[
    int i
] { get; set; }
Public Default Property Item (
    i As Integer
) As Boolean
    Get
    Set
Public Default Property Item (
    i As Integer
) As Boolean
    Get
    Set
public:
property bool default[int i] {
    bool get (int i);
    void set (int i, bool value);
}
public:
property bool default[int i] {
    bool get (int i);
    void set (int i, bool value);
}
member Item : bool with get, set
member Item : bool with get, set

Parameters

i
Type: Online System Int32

Property Value

Type: Online Boolean
See Also
BitList Class
BitList Members
NFX.Collections Namespace


BitList.Size Property

BitList Size Property NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Size { get; }
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
public:
property int Size {
    int get ();
}
member Size : int with get
member Size : int with get

Property Value

Type: Online Int32
See Also
BitList Class
BitList Members
NFX.Collections Namespace


BitMatrix2D Class

BitMatrix2D Class NFX Class Library

Provides an efficient access to a square 2D bit matrix accessible as boolean values
Inheritance Hierarchy
Online System Object
NFX.Collections MatrixBase Online Boolean
NFX.Collections Matrix2DBase Online Boolean
NFX.Collections BitMatrix2D

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class BitMatrix2D : Matrix2DBase<bool>
public class BitMatrix2D : Matrix2DBase<bool>
Public Class BitMatrix2D
    Inherits Matrix2DBase(Of Boolean)
Public Class BitMatrix2D
    Inherits Matrix2DBase(Of Boolean)
public ref class BitMatrix2D : public Matrix2DBase<bool>
public ref class BitMatrix2D : public Matrix2DBase<bool>
type BitMatrix2D =
    class
        inherit Matrix2DBase<bool>
    end
type BitMatrix2D =
    class
        inherit Matrix2DBase<bool>
    end
See Also
BitMatrix2D Members
NFX.Collections Namespace


BitMatrix2D Members

BitMatrix2D Members NFX Class Library

The BitMatrix2D type exposes the following members.
Constructors
 | Name | Description
Public method | BitMatrix2D(Int32) | Initializes a new instance of the BitMatrix2D class
Public method | BitMatrix2D(Int32, Int32) | Initializes a new instance of the BitMatrix2D class
Back to Top
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides MatrixBase T Equals(Object).)
Public method | Equals(MatrixBase T ) | (Inherited from MatrixBase T .)
Public method | FillSubArea | Fills homogeneous sub-area of this square with the specified value
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | (Inherited from MatrixBase T .)
Public method | GetHashCode | (Overrides MatrixBase T GetHashCode .)
Public method | GetLowerBound | (Inherited from Matrix2DBase T .)
Public method | GetMatrixEnumerator | (Inherited from Matrix2DBase T .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetUpperBound | (Inherited from Matrix2DBase T .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Matrix2DBase T ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Height | (Inherited from Matrix2DBase T .)
Public field | Width | (Inherited from Matrix2DBase T .)
Back to Top
Properties
 | Name | Description
Public property | Item | Provides access to bit values by X,Y matric coordinates (Overrides Matrix2DBase T Item Int32, Int32 .)
Public property | Rank | (Inherited from Matrix2DBase T .)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from MatrixBase T .)
Back to Top
See Also
BitMatrix2D Class
NFX.Collections Namespace


BitMatrix2D Constructor

BitMatrix2D Constructor NFX Class Library

Overload List
 | Name | Description
Public method | BitMatrix2D(Int32) | Initializes a new instance of the BitMatrix2D class
Public method | BitMatrix2D(Int32, Int32) | Initializes a new instance of the BitMatrix2D class
Back to Top
See Also
BitMatrix2D Class
BitMatrix2D Members
NFX.Collections Namespace


BitMatrix2D Constructor (Int32)

BitMatrix2D Constructor (Int32) NFX Class Library

Initializes a new instance of the BitMatrix2D class

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BitMatrix2D(
    int dimension
)
public BitMatrix2D(
    int dimension
)
Public Sub New (
    dimension As Integer
)
Public Sub New (
    dimension As Integer
)
public:
BitMatrix2D(
    int dimension
)
public:
BitMatrix2D(
    int dimension
)
new :
        dimension : int -> BitMatrix2D
new :
        dimension : int -> BitMatrix2D

Parameters

dimension
Type: Online System Int32
See Also
BitMatrix2D Class
BitMatrix2D Members
BitMatrix2D Overload
NFX.Collections Namespace


BitMatrix2D Constructor (Int32, Int32)

BitMatrix2D Constructor (Int32, Int32) NFX Class Library

Initializes a new instance of the BitMatrix2D class

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BitMatrix2D(
    int width,
    int height
)
public BitMatrix2D(
    int width,
    int height
)
Public Sub New (
    width As Integer,
    height As Integer
)
Public Sub New (
    width As Integer,
    height As Integer
)
public:
BitMatrix2D(
    int width,
    int height
)
public:
BitMatrix2D(
    int width,
    int height
)
new :
        width : int *
        height : int -> BitMatrix2D
new :
        width : int *
        height : int -> BitMatrix2D

Parameters

width
Type: Online System Int32
height
Type: Online System Int32
See Also
BitMatrix2D Class
BitMatrix2D Members
BitMatrix2D Overload
NFX.Collections Namespace


BitMatrix2D Fields

BitMatrix2D Fields NFX Class Library

The BitMatrix2D type exposes the following members.
Fields
 | Name | Description
Public field | Height | (Inherited from Matrix2DBase T .)
Public field | Width | (Inherited from Matrix2DBase T .)
Back to Top
See Also
BitMatrix2D Class
NFX.Collections Namespace


BitMatrix2D Methods

BitMatrix2D Methods NFX Class Library

The BitMatrix2D type exposes the following members.
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides MatrixBase T Equals(Object).)
Public method | Equals(MatrixBase T ) | (Inherited from MatrixBase T .)
Public method | FillSubArea | Fills homogeneous sub-area of this square with the specified value
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | (Inherited from MatrixBase T .)
Public method | GetHashCode | (Overrides MatrixBase T GetHashCode .)
Public method | GetLowerBound | (Inherited from Matrix2DBase T .)
Public method | GetMatrixEnumerator | (Inherited from Matrix2DBase T .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetUpperBound | (Inherited from Matrix2DBase T .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Matrix2DBase T ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from MatrixBase T .)
Back to Top
See Also
BitMatrix2D Class
NFX.Collections Namespace


BitMatrix2D.Equals Method

BitMatrix2D Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides MatrixBase T Equals(Object).)
Public method | Equals(MatrixBase T ) | (Inherited from MatrixBase T .)
Back to Top
See Also
BitMatrix2D Class
BitMatrix2D Members
NFX.Collections Namespace


BitMatrix2D.Equals Method (Object)

BitMatrix2D Equals Method (Object) NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object otherObj
)
public override bool Equals(
    Object otherObj
)
Public Overrides Function Equals (
    otherObj As Object
) As Boolean
Public Overrides Function Equals (
    otherObj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ otherObj
) override
public:
virtual bool Equals(
    Object^ otherObj
) override
abstract Equals :
        otherObj : Object -> bool
override Equals :
        otherObj : Object -> bool
abstract Equals :
        otherObj : Object -> bool
override Equals :
        otherObj : Object -> bool

Parameters

otherObj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
BitMatrix2D Class
BitMatrix2D Members
Equals Overload
NFX.Collections Namespace


BitMatrix2D.FillSubArea Method

BitMatrix2D FillSubArea Method NFX Class Library

Fills homogeneous sub-area of this square with the specified value

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void FillSubArea(
    int left,
    int top,
    int width,
    int height,
    bool value
)
public void FillSubArea(
    int left,
    int top,
    int width,
    int height,
    bool value
)
Public Sub FillSubArea (
    left As Integer,
    top As Integer,
    width As Integer,
    height As Integer,
    value As Boolean
)
Public Sub FillSubArea (
    left As Integer,
    top As Integer,
    width As Integer,
    height As Integer,
    value As Boolean
)
public:
void FillSubArea(
    int left,
    int top,
    int width,
    int height,
    bool value
)
public:
void FillSubArea(
    int left,
    int top,
    int width,
    int height,
    bool value
)
member FillSubArea :
        left : int *
        top : int *
        width : int *
        height : int *
        value : bool -> unit
member FillSubArea :
        left : int *
        top : int *
        width : int *
        height : int *
        value : bool -> unit

Parameters

left
Type: Online System Int32
top
Type: Online System Int32
width
Type: Online System Int32
height
Type: Online System Int32
value
Type: Online System Boolean
See Also
BitMatrix2D Class
BitMatrix2D Members
NFX.Collections Namespace


BitMatrix2D.GetHashCode Method

BitMatrix2D GetHashCode Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
BitMatrix2D Class
BitMatrix2D Members
NFX.Collections Namespace


BitMatrix2D.ToString Method

BitMatrix2D ToString Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
BitMatrix2D Class
BitMatrix2D Members
NFX.Collections Namespace


BitMatrix2D Properties

BitMatrix2D Properties NFX Class Library

The BitMatrix2D type exposes the following members.
Properties
 | Name | Description
Public property | Item | Provides access to bit values by X,Y matric coordinates (Overrides Matrix2DBase T Item Int32, Int32 .)
Public property | Rank | (Inherited from Matrix2DBase T .)
Back to Top
See Also
BitMatrix2D Class
NFX.Collections Namespace


BitMatrix2D.Item Property

BitMatrix2D Item Property NFX Class Library

Provides access to bit values by X,Y matric coordinates

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool this[
    int x,
    int y
] { get; set; }
public override bool this[
    int x,
    int y
] { get; set; }
Public Overrides Default Property Item (
    x As Integer,
    y As Integer
) As Boolean
    Get
    Set
Public Overrides Default Property Item (
    x As Integer,
    y As Integer
) As Boolean
    Get
    Set
public:
virtual property bool default[int x, int y] {
    bool get (int x, int y) override;
    void set (int x, int y, bool value) override;
}
public:
virtual property bool default[int x, int y] {
    bool get (int x, int y) override;
    void set (int x, int y, bool value) override;
}
abstract Item : bool with get, set
override Item : bool with get, set
abstract Item : bool with get, set
override Item : bool with get, set

Parameters

x
Type: Online System Int32
y
Type: Online System Int32

Property Value

Type: Online Boolean
See Also
BitMatrix2D Class
BitMatrix2D Members
NFX.Collections Namespace


EventedCollectionBase(TContext) Class

EventedCollectionBase TContext Class NFX Class Library

Provides base implementation for some evented collections
Inheritance Hierarchy
Online System Object
NFX.Collections EventedCollectionBase TContext
NFX.Collections EventedDictionary TKey, TValue, TContext
NFX.Collections EventedList TData, TContext

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class EventedCollectionBase<TContext>
public abstract class EventedCollectionBase<TContext>
Public MustInherit Class EventedCollectionBase(Of TContext)
Public MustInherit Class EventedCollectionBase(Of TContext)
generic<typename TContext>
public ref class EventedCollectionBase abstract
generic<typename TContext>
public ref class EventedCollectionBase abstract
[<AbstractClassAttribute>]
type EventedCollectionBase<'TContext> =  class end
[<AbstractClassAttribute>]
type EventedCollectionBase<'TContext> =  class end
Type Parameters
TContext
See Also
EventedCollectionBase TContext Members
NFX.Collections Namespace


EventedCollectionBase(TContext) Members

EventedCollectionBase TContext Members NFX Class Library

The EventedCollectionBase TContext type exposes the following members.
Constructors
 | Name | Description
Protected method | EventedCollectionBase TContext | Initializes a new instance of the EventedCollectionBase TContext class
Protected method | EventedCollectionBase TContext (TContext, Boolean) | Initializes a new instance of the EventedCollectionBase TContext class
Back to Top
Methods
 | Name | Description
Public method | CheckReadOnly |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | GetReadOnlyEvent |
Back to Top
Properties
 | Name | Description
Public property | Context | Context that this structure works in
Public property | ContextReadOnly | Returns true to indicate that Context property can not be set (was injected in .ctor only
Public property | IsReadOnly | Indicates whether collection can be modified
Back to Top
See Also
EventedCollectionBase TContext Class
NFX.Collections Namespace


EventedCollectionBase(TContext) Constructor

EventedCollectionBase TContext Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | EventedCollectionBase TContext | Initializes a new instance of the EventedCollectionBase TContext class
Protected method | EventedCollectionBase TContext (TContext, Boolean) | Initializes a new instance of the EventedCollectionBase TContext class
Back to Top
See Also
EventedCollectionBase TContext Class
EventedCollectionBase TContext Members
NFX.Collections Namespace


EventedCollectionBase(TContext) Constructor

EventedCollectionBase TContext Constructor NFX Class Library

Initializes a new instance of the EventedCollectionBase TContext class

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected EventedCollectionBase()
protected EventedCollectionBase()
Protected Sub New
Protected Sub New
protected:
EventedCollectionBase()
protected:
EventedCollectionBase()
new : unit -> EventedCollectionBase
new : unit -> EventedCollectionBase
See Also
EventedCollectionBase TContext Class
EventedCollectionBase TContext Members
EventedCollectionBase TContext Overload
NFX.Collections Namespace


EventedCollectionBase(TContext) Constructor (TContext, Boolean)

EventedCollectionBase TContext Constructor (TContext, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the EventedCollectionBase TContext class

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected EventedCollectionBase(
    TContext context,
    bool contextReadOnly
)
protected EventedCollectionBase(
    TContext context,
    bool contextReadOnly
)
Protected Sub New (
    context As TContext,
    contextReadOnly As Boolean
)
Protected Sub New (
    context As TContext,
    contextReadOnly As Boolean
)
protected:
EventedCollectionBase(
    TContext context,
    bool contextReadOnly
)
protected:
EventedCollectionBase(
    TContext context,
    bool contextReadOnly
)
new :
        context : 'TContext *
        contextReadOnly : bool -> EventedCollectionBase
new :
        context : 'TContext *
        contextReadOnly : bool -> EventedCollectionBase

Parameters

context
Type: TContext
contextReadOnly
Type: Online System Boolean
See Also
EventedCollectionBase TContext Class
EventedCollectionBase TContext Members
EventedCollectionBase TContext Overload
NFX.Collections Namespace


EventedCollectionBase(TContext) Fields

EventedCollectionBase TContext Fields NFX Class Library

The EventedCollectionBase TContext type exposes the following members.
Fields
 | Name | Description
Public field | GetReadOnlyEvent |
Back to Top
See Also
EventedCollectionBase TContext Class
NFX.Collections Namespace


EventedCollectionBase(TContext).GetReadOnlyEvent Field

EventedCollectionBase TContext GetReadOnlyEvent Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[NonSerializedAttribute]
public EventedCollectionGetReadOnlyHandler<TContext> GetReadOnlyEvent
[NonSerializedAttribute]
public EventedCollectionGetReadOnlyHandler<TContext> GetReadOnlyEvent
<NonSerializedAttribute>
Public GetReadOnlyEvent As EventedCollectionGetReadOnlyHandler(Of TContext)
<NonSerializedAttribute>
Public GetReadOnlyEvent As EventedCollectionGetReadOnlyHandler(Of TContext)
public:
[NonSerializedAttribute]
EventedCollectionGetReadOnlyHandler<TContext>^ GetReadOnlyEvent
public:
[NonSerializedAttribute]
EventedCollectionGetReadOnlyHandler<TContext>^ GetReadOnlyEvent
[<NonSerializedAttribute>]
val mutable GetReadOnlyEvent: EventedCollectionGetReadOnlyHandler<'TContext>
[<NonSerializedAttribute>]
val mutable GetReadOnlyEvent: EventedCollectionGetReadOnlyHandler<'TContext>

Field Value

Type: EventedCollectionGetReadOnlyHandler TContext
See Also
EventedCollectionBase TContext Class
EventedCollectionBase TContext Members
NFX.Collections Namespace


EventedCollectionBase(TContext) Methods

EventedCollectionBase TContext Methods NFX Class Library

The EventedCollectionBase TContext type exposes the following members.
Methods
 | Name | Description
Public method | CheckReadOnly |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
EventedCollectionBase TContext Class
NFX.Collections Namespace


EventedCollectionBase(TContext).CheckReadOnly Method

EventedCollectionBase TContext CheckReadOnly Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CheckReadOnly()
public void CheckReadOnly()
Public Sub CheckReadOnly
Public Sub CheckReadOnly
public:
void CheckReadOnly()
public:
void CheckReadOnly()
member CheckReadOnly : unit -> unit
member CheckReadOnly : unit -> unit
See Also
EventedCollectionBase TContext Class
EventedCollectionBase TContext Members
NFX.Collections Namespace


EventedCollectionBase(TContext) Properties

EventedCollectionBase TContext Properties NFX Class Library

The EventedCollectionBase TContext type exposes the following members.
Properties
 | Name | Description
Public property | Context | Context that this structure works in
Public property | ContextReadOnly | Returns true to indicate that Context property can not be set (was injected in .ctor only
Public property | IsReadOnly | Indicates whether collection can be modified
Back to Top
See Also
EventedCollectionBase TContext Class
NFX.Collections Namespace


EventedCollectionBase(TContext).Context Property

EventedCollectionBase TContext Context Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Context that this structure works in

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TContext Context { get; set; }
public TContext Context { get; set; }
Public Property Context As TContext
    Get
    Set
Public Property Context As TContext
    Get
    Set
public:
property TContext Context {
    TContext get ();
    void set (TContext value);
}
public:
property TContext Context {
    TContext get ();
    void set (TContext value);
}
member Context : 'TContext with get, set
member Context : 'TContext with get, set

Property Value

Type: TContext
See Also
EventedCollectionBase TContext Class
EventedCollectionBase TContext Members
NFX.Collections Namespace


EventedCollectionBase(TContext).ContextReadOnly Property

EventedCollectionBase TContext ContextReadOnly Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns true to indicate that Context property can not be set (was injected in .ctor only

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ContextReadOnly { get; }
public bool ContextReadOnly { get; }
Public ReadOnly Property ContextReadOnly As Boolean
    Get
Public ReadOnly Property ContextReadOnly As Boolean
    Get
public:
property bool ContextReadOnly {
    bool get ();
}
public:
property bool ContextReadOnly {
    bool get ();
}
member ContextReadOnly : bool with get
member ContextReadOnly : bool with get

Property Value

Type: Online Boolean
See Also
EventedCollectionBase TContext Class
EventedCollectionBase TContext Members
NFX.Collections Namespace


EventedCollectionBase(TContext).IsReadOnly Property

EventedCollectionBase TContext IsReadOnly Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Indicates whether collection can be modified

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsReadOnly { get; }
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get

Property Value

Type: Online Boolean
See Also
EventedCollectionBase TContext Class
EventedCollectionBase TContext Members
NFX.Collections Namespace


EventedCollectionGetReadOnlyHandler(TContext) Delegate

EventedCollectionGetReadOnlyHandler TContext Delegate NFX Class Library

[This is preliminary documentation and is subject to change.]

Event handler for list changes

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate bool EventedCollectionGetReadOnlyHandler<TContext>(
    EventedCollectionBase<TContext> collection
)
public delegate bool EventedCollectionGetReadOnlyHandler<TContext>(
    EventedCollectionBase<TContext> collection
)
Public Delegate Function EventedCollectionGetReadOnlyHandler(Of TContext) (
    collection As EventedCollectionBase(Of TContext)
) As Boolean
Public Delegate Function EventedCollectionGetReadOnlyHandler(Of TContext) (
    collection As EventedCollectionBase(Of TContext)
) As Boolean
generic<typename TContext>
public delegate bool EventedCollectionGetReadOnlyHandler(
    EventedCollectionBase<TContext>^ collection
)
generic<typename TContext>
public delegate bool EventedCollectionGetReadOnlyHandler(
    EventedCollectionBase<TContext>^ collection
)
type EventedCollectionGetReadOnlyHandler =
    delegate of
        collection : EventedCollectionBase<'TContext> -> bool
type EventedCollectionGetReadOnlyHandler =
    delegate of
        collection : EventedCollectionBase<'TContext> -> bool

Parameters

collection
Type: NFX.Collections EventedCollectionBase TContext
Type Parameters
TContext

Return Value

Type: Online Boolean
See Also
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext) Class

EventedDictionary TKey, TValue, TContext Class NFX Class Library

[This is preliminary documentation and is subject to change.]

Represents a dictionary that rises events
Inheritance Hierarchy
Online System Object
NFX.Collections EventedCollectionBase TContext
NFX.Collections EventedDictionary TKey, TValue, TContext

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class EventedDictionary<TKey, TValue, TContext> : EventedCollectionBase<TContext>,
    IDictionary<TKey, TValue>, ICollection<KeyValuePair<TKey, TValue>>,
    IEnumerable<KeyValuePair<TKey, TValue>>, IEnumerable
[SerializableAttribute]
public class EventedDictionary<TKey, TValue, TContext> : EventedCollectionBase<TContext>,
    IDictionary<TKey, TValue>, ICollection<KeyValuePair<TKey, TValue>>,
    IEnumerable<KeyValuePair<TKey, TValue>>, IEnumerable
<SerializableAttribute>
Public Class EventedDictionary(Of TKey, TValue, TContext)
    Inherits EventedCollectionBase(Of TContext)
    Implements IDictionary(Of TKey, TValue), ICollection(Of KeyValuePair(Of TKey, TValue)),
    IEnumerable(Of KeyValuePair(Of TKey, TValue)), IEnumerable
<SerializableAttribute>
Public Class EventedDictionary(Of TKey, TValue, TContext)
    Inherits EventedCollectionBase(Of TContext)
    Implements IDictionary(Of TKey, TValue), ICollection(Of KeyValuePair(Of TKey, TValue)),
    IEnumerable(Of KeyValuePair(Of TKey, TValue)), IEnumerable
[SerializableAttribute]
generic<typename TKey, typename TValue, typename TContext>
public ref class EventedDictionary : public EventedCollectionBase<TContext>,
    IDictionary<TKey, TValue>, ICollection<KeyValuePair<TKey, TValue>>,
    IEnumerable<KeyValuePair<TKey, TValue>>, IEnumerable
[SerializableAttribute]
generic<typename TKey, typename TValue, typename TContext>
public ref class EventedDictionary : public EventedCollectionBase<TContext>,
    IDictionary<TKey, TValue>, ICollection<KeyValuePair<TKey, TValue>>,
    IEnumerable<KeyValuePair<TKey, TValue>>, IEnumerable
[<SerializableAttribute>]
type EventedDictionary<'TKey, 'TValue, 'TContext> =
    class
        inherit EventedCollectionBase<'TContext>
        interface IDictionary<'TKey, 'TValue>
        interface ICollection<KeyValuePair<'TKey, 'TValue>>
        interface IEnumerable<KeyValuePair<'TKey, 'TValue>>
        interface IEnumerable
    end
[<SerializableAttribute>]
type EventedDictionary<'TKey, 'TValue, 'TContext> =
    class
        inherit EventedCollectionBase<'TContext>
        interface IDictionary<'TKey, 'TValue>
        interface ICollection<KeyValuePair<'TKey, 'TValue>>
        interface IEnumerable<KeyValuePair<'TKey, 'TValue>>
        interface IEnumerable
    end
Type Parameters
TKey
TValue
TContext
See Also
EventedDictionary TKey, TValue, TContext Members
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext) Members

EventedDictionary TKey, TValue, TContext Members NFX Class Library

[This is preliminary documentation and is subject to change.]

The EventedDictionary TKey, TValue, TContext type exposes the following members.
Constructors
 | Name | Description
Public method | EventedDictionary TKey, TValue, TContext | Initializes a new instance that is empty, has the default initial capacity, and uses the default equality comparer for the key type.
Public method | EventedDictionary TKey, TValue, TContext (TContext, Boolean) | Initializes a new instance that is empty, has the default initial capacity, and uses the default equality comparer for the key type.
Public method | EventedDictionary TKey, TValue, TContext (TContext, Boolean, IDictionary TKey, TValue ) | Initializes a new instance that contains elements copied from the specified IDictionary[TKey,TValue] and uses the default equality comparer for the key type.
Public method | EventedDictionary TKey, TValue, TContext (TContext, Boolean, IEqualityComparer TKey ) | Initializes a new instance that is empty, has the default initial capacity, and uses the specified IEqualityComparer[T].
Public method | EventedDictionary TKey, TValue, TContext (TContext, Boolean, Int32) | Initializes a new instance that is empty, has the specified initial capacity, and uses the default equality comparer for the key type.
Public method | EventedDictionary TKey, TValue, TContext (TContext, Boolean, IDictionary TKey, TValue , IEqualityComparer TKey ) | Initializes a new instance that contains elements copied from the specified IDictionary[TKey,TValue] and uses the specified IEqualityComparer[T].
Public method | EventedDictionary TKey, TValue, TContext (TContext, Boolean, Int32, IEqualityComparer TKey ) | Initializes a new instance of the Dictionary[TKey,TValue] class that is empty, has the specified initial capacity, and uses the specified IEqualityComparer[T]
Back to Top
Methods
 | Name | Description
Public method | Add(KeyValuePair TKey, TValue ) |
Public method | Add(TKey, TValue) |
Public method | CheckReadOnly | (Inherited from EventedCollectionBase TContext .)
Public method | Clear |
Public method | Contains |
Public method | ContainsKey |
Public method | CopyTo |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove(KeyValuePair TKey, TValue ) |
Public method | Remove(TKey) |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryGetValue |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable KeyValuePair TKey, TValue | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct KeyValuePair TKey, TValue , TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair TKey, TValue , TComparand (Func KeyValuePair TKey, TValue , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair TKey, TValue , TComparand (Func KeyValuePair TKey, TValue , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair TKey, TValue , TComparand (Func KeyValuePair TKey, TValue , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair TKey, TValue , TComparand (Func KeyValuePair TKey, TValue , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault KeyValuePair TKey, TValue | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair TKey, TValue (Action KeyValuePair TKey, TValue ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair TKey, TValue (Action KeyValuePair TKey, TValue , Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair TKey, TValue | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair TKey, TValue (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | ChangeEvent |
Public field | GetReadOnlyEvent | (Inherited from EventedCollectionBase TContext .)
Back to Top
Properties
 | Name | Description
Public property | Context | Context that this structure works in (Inherited from EventedCollectionBase TContext .)
Public property | ContextReadOnly | Returns true to indicate that Context property can not be set (was injected in .ctor only (Inherited from EventedCollectionBase TContext .)
Public property | Count |
Public property | IsReadOnly | Indicates whether collection can be modified (Inherited from EventedCollectionBase TContext .)
Public property | Item |
Public property | Keys |
Public property | Values |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
EventedDictionary TKey, TValue, TContext Class
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext) Constructor

EventedDictionary TKey, TValue, TContext Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public method | EventedDictionary TKey, TValue, TContext | Initializes a new instance that is empty, has the default initial capacity, and uses the default equality comparer for the key type.
Public method | EventedDictionary TKey, TValue, TContext (TContext, Boolean) | Initializes a new instance that is empty, has the default initial capacity, and uses the default equality comparer for the key type.
Public method | EventedDictionary TKey, TValue, TContext (TContext, Boolean, IDictionary TKey, TValue ) | Initializes a new instance that contains elements copied from the specified IDictionary[TKey,TValue] and uses the default equality comparer for the key type.
Public method | EventedDictionary TKey, TValue, TContext (TContext, Boolean, IEqualityComparer TKey ) | Initializes a new instance that is empty, has the default initial capacity, and uses the specified IEqualityComparer[T].
Public method | EventedDictionary TKey, TValue, TContext (TContext, Boolean, Int32) | Initializes a new instance that is empty, has the specified initial capacity, and uses the default equality comparer for the key type.
Public method | EventedDictionary TKey, TValue, TContext (TContext, Boolean, IDictionary TKey, TValue , IEqualityComparer TKey ) | Initializes a new instance that contains elements copied from the specified IDictionary[TKey,TValue] and uses the specified IEqualityComparer[T].
Public method | EventedDictionary TKey, TValue, TContext (TContext, Boolean, Int32, IEqualityComparer TKey ) | Initializes a new instance of the Dictionary[TKey,TValue] class that is empty, has the specified initial capacity, and uses the specified IEqualityComparer[T]
Back to Top
See Also
EventedDictionary TKey, TValue, TContext Class
EventedDictionary TKey, TValue, TContext Members
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext) Constructor

EventedDictionary TKey, TValue, TContext Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance that is empty, has the default initial capacity, and uses the default equality comparer for the key type.

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EventedDictionary()
public EventedDictionary()
Public Sub New
Public Sub New
public:
EventedDictionary()
public:
EventedDictionary()
new : unit -> EventedDictionary
new : unit -> EventedDictionary
See Also
EventedDictionary TKey, TValue, TContext Class
EventedDictionary TKey, TValue, TContext Members
EventedDictionary TKey, TValue, TContext Overload
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext) Constructor (TContext, Boolean)

EventedDictionary TKey, TValue, TContext Constructor (TContext, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance that is empty, has the default initial capacity, and uses the default equality comparer for the key type.

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EventedDictionary(
    TContext context,
    bool contextReadOnly
)
public EventedDictionary(
    TContext context,
    bool contextReadOnly
)
Public Sub New (
    context As TContext,
    contextReadOnly As Boolean
)
Public Sub New (
    context As TContext,
    contextReadOnly As Boolean
)
public:
EventedDictionary(
    TContext context,
    bool contextReadOnly
)
public:
EventedDictionary(
    TContext context,
    bool contextReadOnly
)
new :
        context : 'TContext *
        contextReadOnly : bool -> EventedDictionary
new :
        context : 'TContext *
        contextReadOnly : bool -> EventedDictionary

Parameters

context
Type: TContext
contextReadOnly
Type: Online System Boolean
See Also
EventedDictionary TKey, TValue, TContext Class
EventedDictionary TKey, TValue, TContext Members
EventedDictionary TKey, TValue, TContext Overload
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext) Constructor (TContext, Boolean, IDictionary(TKey, TValue))

EventedDictionary TKey, TValue, TContext Constructor (TContext, Boolean, IDictionary TKey, TValue ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance that contains elements copied from the specified IDictionary[TKey,TValue] and uses the default equality comparer for the key type.

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EventedDictionary(
    TContext context,
    bool contextReadOnly,
    IDictionary<TKey, TValue> dictionary
)
public EventedDictionary(
    TContext context,
    bool contextReadOnly,
    IDictionary<TKey, TValue> dictionary
)
Public Sub New (
    context As TContext,
    contextReadOnly As Boolean,
    dictionary As IDictionary(Of TKey, TValue)
)
Public Sub New (
    context As TContext,
    contextReadOnly As Boolean,
    dictionary As IDictionary(Of TKey, TValue)
)
public:
EventedDictionary(
    TContext context,
    bool contextReadOnly,
    IDictionary<TKey, TValue>^ dictionary
)
public:
EventedDictionary(
    TContext context,
    bool contextReadOnly,
    IDictionary<TKey, TValue>^ dictionary
)
new :
        context : 'TContext *
        contextReadOnly : bool *
        dictionary : IDictionary<'TKey, 'TValue> -> EventedDictionary
new :
        context : 'TContext *
        contextReadOnly : bool *
        dictionary : IDictionary<'TKey, 'TValue> -> EventedDictionary

Parameters

context
Type: TContext
contextReadOnly
Type: Online System Boolean
dictionary
Type: Online System.Collections.Generic IDictionary TKey, TValue
See Also
EventedDictionary TKey, TValue, TContext Class
EventedDictionary TKey, TValue, TContext Members
EventedDictionary TKey, TValue, TContext Overload
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext) Constructor (TContext, Boolean, IEqualityComparer(TKey))

EventedDictionary TKey, TValue, TContext Constructor (TContext, Boolean, IEqualityComparer TKey ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance that is empty, has the default initial capacity, and uses the specified IEqualityComparer[T].

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EventedDictionary(
    TContext context,
    bool contextReadOnly,
    IEqualityComparer<TKey> comparer
)
public EventedDictionary(
    TContext context,
    bool contextReadOnly,
    IEqualityComparer<TKey> comparer
)
Public Sub New (
    context As TContext,
    contextReadOnly As Boolean,
    comparer As IEqualityComparer(Of TKey)
)
Public Sub New (
    context As TContext,
    contextReadOnly As Boolean,
    comparer As IEqualityComparer(Of TKey)
)
public:
EventedDictionary(
    TContext context,
    bool contextReadOnly,
    IEqualityComparer<TKey>^ comparer
)
public:
EventedDictionary(
    TContext context,
    bool contextReadOnly,
    IEqualityComparer<TKey>^ comparer
)
new :
        context : 'TContext *
        contextReadOnly : bool *
        comparer : IEqualityComparer<'TKey> -> EventedDictionary
new :
        context : 'TContext *
        contextReadOnly : bool *
        comparer : IEqualityComparer<'TKey> -> EventedDictionary

Parameters

context
Type: TContext
contextReadOnly
Type: Online System Boolean
comparer
Type: Online System.Collections.Generic IEqualityComparer TKey
See Also
EventedDictionary TKey, TValue, TContext Class
EventedDictionary TKey, TValue, TContext Members
EventedDictionary TKey, TValue, TContext Overload
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext) Constructor (TContext, Boolean, Int32)

EventedDictionary TKey, TValue, TContext Constructor (TContext, Boolean, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance that is empty, has the specified initial capacity, and uses the default equality comparer for the key type.

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EventedDictionary(
    TContext context,
    bool contextReadOnly,
    int capacity
)
public EventedDictionary(
    TContext context,
    bool contextReadOnly,
    int capacity
)
Public Sub New (
    context As TContext,
    contextReadOnly As Boolean,
    capacity As Integer
)
Public Sub New (
    context As TContext,
    contextReadOnly As Boolean,
    capacity As Integer
)
public:
EventedDictionary(
    TContext context,
    bool contextReadOnly,
    int capacity
)
public:
EventedDictionary(
    TContext context,
    bool contextReadOnly,
    int capacity
)
new :
        context : 'TContext *
        contextReadOnly : bool *
        capacity : int -> EventedDictionary
new :
        context : 'TContext *
        contextReadOnly : bool *
        capacity : int -> EventedDictionary

Parameters

context
Type: TContext
contextReadOnly
Type: Online System Boolean
capacity
Type: Online System Int32
See Also
EventedDictionary TKey, TValue, TContext Class
EventedDictionary TKey, TValue, TContext Members
EventedDictionary TKey, TValue, TContext Overload
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext) Constructor (TContext, Boolean, IDictionary(TKey, TValue), IEqualityComparer(TKey))

EventedDictionary TKey, TValue, TContext Constructor (TContext, Boolean, IDictionary TKey, TValue , IEqualityComparer TKey ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance that contains elements copied from the specified IDictionary[TKey,TValue] and uses the specified IEqualityComparer[T].

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EventedDictionary(
    TContext context,
    bool contextReadOnly,
    IDictionary<TKey, TValue> dictionary,
    IEqualityComparer<TKey> comparer
)
public EventedDictionary(
    TContext context,
    bool contextReadOnly,
    IDictionary<TKey, TValue> dictionary,
    IEqualityComparer<TKey> comparer
)
Public Sub New (
    context As TContext,
    contextReadOnly As Boolean,
    dictionary As IDictionary(Of TKey, TValue),
    comparer As IEqualityComparer(Of TKey)
)
Public Sub New (
    context As TContext,
    contextReadOnly As Boolean,
    dictionary As IDictionary(Of TKey, TValue),
    comparer As IEqualityComparer(Of TKey)
)
public:
EventedDictionary(
    TContext context,
    bool contextReadOnly,
    IDictionary<TKey, TValue>^ dictionary,
    IEqualityComparer<TKey>^ comparer
)
public:
EventedDictionary(
    TContext context,
    bool contextReadOnly,
    IDictionary<TKey, TValue>^ dictionary,
    IEqualityComparer<TKey>^ comparer
)
new :
        context : 'TContext *
        contextReadOnly : bool *
        dictionary : IDictionary<'TKey, 'TValue> *
        comparer : IEqualityComparer<'TKey> -> EventedDictionary
new :
        context : 'TContext *
        contextReadOnly : bool *
        dictionary : IDictionary<'TKey, 'TValue> *
        comparer : IEqualityComparer<'TKey> -> EventedDictionary

Parameters

context
Type: TContext
contextReadOnly
Type: Online System Boolean
dictionary
Type: Online System.Collections.Generic IDictionary TKey, TValue
comparer
Type: Online System.Collections.Generic IEqualityComparer TKey
See Also
EventedDictionary TKey, TValue, TContext Class
EventedDictionary TKey, TValue, TContext Members
EventedDictionary TKey, TValue, TContext Overload
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext) Constructor (TContext, Boolean, Int32, IEqualityComparer(TKey))

EventedDictionary TKey, TValue, TContext Constructor (TContext, Boolean, Int32, IEqualityComparer TKey ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Dictionary[TKey,TValue] class that is empty, has the specified initial capacity, and uses the specified IEqualityComparer[T]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EventedDictionary(
    TContext context,
    bool contextReadOnly,
    int capacity,
    IEqualityComparer<TKey> comparer
)
public EventedDictionary(
    TContext context,
    bool contextReadOnly,
    int capacity,
    IEqualityComparer<TKey> comparer
)
Public Sub New (
    context As TContext,
    contextReadOnly As Boolean,
    capacity As Integer,
    comparer As IEqualityComparer(Of TKey)
)
Public Sub New (
    context As TContext,
    contextReadOnly As Boolean,
    capacity As Integer,
    comparer As IEqualityComparer(Of TKey)
)
public:
EventedDictionary(
    TContext context,
    bool contextReadOnly,
    int capacity,
    IEqualityComparer<TKey>^ comparer
)
public:
EventedDictionary(
    TContext context,
    bool contextReadOnly,
    int capacity,
    IEqualityComparer<TKey>^ comparer
)
new :
        context : 'TContext *
        contextReadOnly : bool *
        capacity : int *
        comparer : IEqualityComparer<'TKey> -> EventedDictionary
new :
        context : 'TContext *
        contextReadOnly : bool *
        capacity : int *
        comparer : IEqualityComparer<'TKey> -> EventedDictionary

Parameters

context
Type: TContext
contextReadOnly
Type: Online System Boolean
capacity
Type: Online System Int32
comparer
Type: Online System.Collections.Generic IEqualityComparer TKey
See Also
EventedDictionary TKey, TValue, TContext Class
EventedDictionary TKey, TValue, TContext Members
EventedDictionary TKey, TValue, TContext Overload
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext) Fields

EventedDictionary TKey, TValue, TContext Fields NFX Class Library

[This is preliminary documentation and is subject to change.]

The EventedDictionary TKey, TValue, TContext type exposes the following members.
Fields
 | Name | Description
Public field | ChangeEvent |
Public field | GetReadOnlyEvent | (Inherited from EventedCollectionBase TContext .)
Back to Top
See Also
EventedDictionary TKey, TValue, TContext Class
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext).ChangeEvent Field

EventedDictionary TKey, TValue, TContext ChangeEvent Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[NonSerializedAttribute]
public EventedDictionary<(Of <(<'TKey, TValue, TContext>)>)>..::..ChangeHandler ChangeEvent
[NonSerializedAttribute]
public EventedDictionary<(Of <(<'TKey, TValue, TContext>)>)>..::..ChangeHandler ChangeEvent
<NonSerializedAttribute>
Public ChangeEvent As EventedDictionary<(Of <(<'TKey, TValue, TContext>)>)>..::..ChangeHandler
<NonSerializedAttribute>
Public ChangeEvent As EventedDictionary<(Of <(<'TKey, TValue, TContext>)>)>..::..ChangeHandler
public:
[NonSerializedAttribute]
EventedDictionary<(Of <(<'TKey, TValue, TContext>)>)>..::..ChangeHandler^ ChangeEvent
public:
[NonSerializedAttribute]
EventedDictionary<(Of <(<'TKey, TValue, TContext>)>)>..::..ChangeHandler^ ChangeEvent
[<NonSerializedAttribute>]
val mutable ChangeEvent: EventedDictionary<(Of <(<'TKey, TValue, TContext>)>)>..::..ChangeHandler
[<NonSerializedAttribute>]
val mutable ChangeEvent: EventedDictionary<(Of <(<'TKey, TValue, TContext>)>)>..::..ChangeHandler

Field Value

Type: EventedDictionary TKey, TValue, TContext ChangeHandler
See Also
EventedDictionary TKey, TValue, TContext Class
EventedDictionary TKey, TValue, TContext Members
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext) Methods

EventedDictionary TKey, TValue, TContext Methods NFX Class Library

[This is preliminary documentation and is subject to change.]

The EventedDictionary TKey, TValue, TContext type exposes the following members.
Methods
 | Name | Description
Public method | Add(KeyValuePair TKey, TValue ) |
Public method | Add(TKey, TValue) |
Public method | CheckReadOnly | (Inherited from EventedCollectionBase TContext .)
Public method | Clear |
Public method | Contains |
Public method | ContainsKey |
Public method | CopyTo |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove(KeyValuePair TKey, TValue ) |
Public method | Remove(TKey) |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryGetValue |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable KeyValuePair TKey, TValue | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct KeyValuePair TKey, TValue , TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair TKey, TValue , TComparand (Func KeyValuePair TKey, TValue , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair TKey, TValue , TComparand (Func KeyValuePair TKey, TValue , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair TKey, TValue , TComparand (Func KeyValuePair TKey, TValue , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair TKey, TValue , TComparand (Func KeyValuePair TKey, TValue , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault KeyValuePair TKey, TValue | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair TKey, TValue (Action KeyValuePair TKey, TValue ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair TKey, TValue (Action KeyValuePair TKey, TValue , Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair TKey, TValue | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair TKey, TValue (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
EventedDictionary TKey, TValue, TContext Class
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext).IEnumerable.GetEnumerator Method

EventedDictionary TKey, TValue, TContext IEnumerable GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
EventedDictionary TKey, TValue, TContext Class
EventedDictionary TKey, TValue, TContext Members
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext).Add Method

EventedDictionary TKey, TValue, TContext Add Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public method | Add(KeyValuePair TKey, TValue ) |
Public method | Add(TKey, TValue) |
Back to Top
See Also
EventedDictionary TKey, TValue, TContext Class
EventedDictionary TKey, TValue, TContext Members
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext).Add Method (KeyValuePair(TKey, TValue))

EventedDictionary TKey, TValue, TContext Add Method (KeyValuePair TKey, TValue ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    KeyValuePair<TKey, TValue> item
)
public void Add(
    KeyValuePair<TKey, TValue> item
)
Public Sub Add (
    item As KeyValuePair(Of TKey, TValue)
)
Public Sub Add (
    item As KeyValuePair(Of TKey, TValue)
)
public:
virtual void Add(
    KeyValuePair<TKey, TValue> item
) sealed
public:
virtual void Add(
    KeyValuePair<TKey, TValue> item
) sealed
abstract Add :
        item : KeyValuePair<'TKey, 'TValue> -> unit
override Add :
        item : KeyValuePair<'TKey, 'TValue> -> unit
abstract Add :
        item : KeyValuePair<'TKey, 'TValue> -> unit
override Add :
        item : KeyValuePair<'TKey, 'TValue> -> unit

Parameters

item
Type: Online System.Collections.Generic KeyValuePair TKey, TValue

Implements

Online ICollection T Add(T)
See Also
EventedDictionary TKey, TValue, TContext Class
EventedDictionary TKey, TValue, TContext Members
Add Overload
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext).Add Method (TKey, TValue)

EventedDictionary TKey, TValue, TContext Add Method (TKey, TValue) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    TKey key,
    TValue value
)
public void Add(
    TKey key,
    TValue value
)
Public Sub Add (
    key As TKey,
    value As TValue
)
Public Sub Add (
    key As TKey,
    value As TValue
)
public:
virtual void Add(
    TKey key,
    TValue value
) sealed
public:
virtual void Add(
    TKey key,
    TValue value
) sealed
abstract Add :
        key : 'TKey *
        value : 'TValue -> unit
override Add :
        key : 'TKey *
        value : 'TValue -> unit
abstract Add :
        key : 'TKey *
        value : 'TValue -> unit
override Add :
        key : 'TKey *
        value : 'TValue -> unit

Parameters

key
Type: TKey
value
Type: TValue

Implements

Online IDictionary TKey, TValue Add(TKey, TValue)
See Also
EventedDictionary TKey, TValue, TContext Class
EventedDictionary TKey, TValue, TContext Members
Add Overload
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext).Clear Method

EventedDictionary TKey, TValue, TContext Clear Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
virtual void Clear() sealed
public:
virtual void Clear() sealed
abstract Clear : unit -> unit
override Clear : unit -> unit
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

Online ICollection T Clear
See Also
EventedDictionary TKey, TValue, TContext Class
EventedDictionary TKey, TValue, TContext Members
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext).Contains Method

EventedDictionary TKey, TValue, TContext Contains Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Contains(
    KeyValuePair<TKey, TValue> item
)
public bool Contains(
    KeyValuePair<TKey, TValue> item
)
Public Function Contains (
    item As KeyValuePair(Of TKey, TValue)
) As Boolean
Public Function Contains (
    item As KeyValuePair(Of TKey, TValue)
) As Boolean
public:
virtual bool Contains(
    KeyValuePair<TKey, TValue> item
) sealed
public:
virtual bool Contains(
    KeyValuePair<TKey, TValue> item
) sealed
abstract Contains :
        item : KeyValuePair<'TKey, 'TValue> -> bool
override Contains :
        item : KeyValuePair<'TKey, 'TValue> -> bool
abstract Contains :
        item : KeyValuePair<'TKey, 'TValue> -> bool
override Contains :
        item : KeyValuePair<'TKey, 'TValue> -> bool

Parameters

item
Type: Online System.Collections.Generic KeyValuePair TKey, TValue

Return Value

Type: Online Boolean

Implements

Online ICollection T Contains(T)
See Also
EventedDictionary TKey, TValue, TContext Class
EventedDictionary TKey, TValue, TContext Members
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext).ContainsKey Method

EventedDictionary TKey, TValue, TContext ContainsKey Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ContainsKey(
    TKey key
)
public bool ContainsKey(
    TKey key
)
Public Function ContainsKey (
    key As TKey
) As Boolean
Public Function ContainsKey (
    key As TKey
) As Boolean
public:
virtual bool ContainsKey(
    TKey key
) sealed
public:
virtual bool ContainsKey(
    TKey key
) sealed
abstract ContainsKey :
        key : 'TKey -> bool
override ContainsKey :
        key : 'TKey -> bool
abstract ContainsKey :
        key : 'TKey -> bool
override ContainsKey :
        key : 'TKey -> bool

Parameters

key
Type: TKey

Return Value

Type: Online Boolean

Implements

Online IDictionary TKey, TValue ContainsKey(TKey)
See Also
EventedDictionary TKey, TValue, TContext Class
EventedDictionary TKey, TValue, TContext Members
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext).CopyTo Method

EventedDictionary TKey, TValue, TContext CopyTo Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CopyTo(
    KeyValuePair<TKey, TValue>[] array,
    int arrayIndex
)
public void CopyTo(
    KeyValuePair<TKey, TValue>[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As KeyValuePair(Of TKey, TValue)(),
    arrayIndex As Integer
)
Public Sub CopyTo (
    array As KeyValuePair(Of TKey, TValue)(),
    arrayIndex As Integer
)
public:
virtual void CopyTo(
    array<KeyValuePair<TKey, TValue>>^ array,
    int arrayIndex
) sealed
public:
virtual void CopyTo(
    array<KeyValuePair<TKey, TValue>>^ array,
    int arrayIndex
) sealed
abstract CopyTo :
        array : KeyValuePair<'TKey, 'TValue>[] *
        arrayIndex : int -> unit
override CopyTo :
        array : KeyValuePair<'TKey, 'TValue>[] *
        arrayIndex : int -> unit
abstract CopyTo :
        array : KeyValuePair<'TKey, 'TValue>[] *
        arrayIndex : int -> unit
override CopyTo :
        array : KeyValuePair<'TKey, 'TValue>[] *
        arrayIndex : int -> unit

Parameters

array
Type: Online System.Collections.Generic KeyValuePair TKey, TValue
arrayIndex
Type: Online System Int32

Implements

Online ICollection T CopyTo( T , Int32)
See Also
EventedDictionary TKey, TValue, TContext Class
EventedDictionary TKey, TValue, TContext Members
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext).GetEnumerator Method

EventedDictionary TKey, TValue, TContext GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<KeyValuePair<TKey, TValue>> GetEnumerator()
public IEnumerator<KeyValuePair<TKey, TValue>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of TKey, TValue))
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of TKey, TValue))
public:
virtual IEnumerator<KeyValuePair<TKey, TValue>>^ GetEnumerator() sealed
public:
virtual IEnumerator<KeyValuePair<TKey, TValue>>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<'TKey, 'TValue>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<'TKey, 'TValue>>
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<'TKey, 'TValue>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<'TKey, 'TValue>>

Return Value

Type: Online IEnumerator Online KeyValuePair TKey, TValue

Implements

Online IEnumerable T GetEnumerator
See Also
EventedDictionary TKey, TValue, TContext Class
EventedDictionary TKey, TValue, TContext Members
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext).Remove Method

EventedDictionary TKey, TValue, TContext Remove Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public method | Remove(KeyValuePair TKey, TValue ) |
Public method | Remove(TKey) |
Back to Top
See Also
EventedDictionary TKey, TValue, TContext Class
EventedDictionary TKey, TValue, TContext Members
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext).Remove Method (KeyValuePair(TKey, TValue))

EventedDictionary TKey, TValue, TContext Remove Method (KeyValuePair TKey, TValue ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Remove(
    KeyValuePair<TKey, TValue> item
)
public bool Remove(
    KeyValuePair<TKey, TValue> item
)
Public Function Remove (
    item As KeyValuePair(Of TKey, TValue)
) As Boolean
Public Function Remove (
    item As KeyValuePair(Of TKey, TValue)
) As Boolean
public:
virtual bool Remove(
    KeyValuePair<TKey, TValue> item
) sealed
public:
virtual bool Remove(
    KeyValuePair<TKey, TValue> item
) sealed
abstract Remove :
        item : KeyValuePair<'TKey, 'TValue> -> bool
override Remove :
        item : KeyValuePair<'TKey, 'TValue> -> bool
abstract Remove :
        item : KeyValuePair<'TKey, 'TValue> -> bool
override Remove :
        item : KeyValuePair<'TKey, 'TValue> -> bool

Parameters

item
Type: Online System.Collections.Generic KeyValuePair TKey, TValue

Return Value

Type: Online Boolean

Implements

Online ICollection T Remove(T)
See Also
EventedDictionary TKey, TValue, TContext Class
EventedDictionary TKey, TValue, TContext Members
Remove Overload
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext).Remove Method (TKey)

EventedDictionary TKey, TValue, TContext Remove Method (TKey) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Remove(
    TKey key
)
public bool Remove(
    TKey key
)
Public Function Remove (
    key As TKey
) As Boolean
Public Function Remove (
    key As TKey
) As Boolean
public:
virtual bool Remove(
    TKey key
) sealed
public:
virtual bool Remove(
    TKey key
) sealed
abstract Remove :
        key : 'TKey -> bool
override Remove :
        key : 'TKey -> bool
abstract Remove :
        key : 'TKey -> bool
override Remove :
        key : 'TKey -> bool

Parameters

key
Type: TKey

Return Value

Type: Online Boolean

Implements

Online IDictionary TKey, TValue Remove(TKey)
See Also
EventedDictionary TKey, TValue, TContext Class
EventedDictionary TKey, TValue, TContext Members
Remove Overload
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext).TryGetValue Method

EventedDictionary TKey, TValue, TContext TryGetValue Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TryGetValue(
    TKey key,
    out TValue value
)
public bool TryGetValue(
    TKey key,
    out TValue value
)
Public Function TryGetValue (
    key As TKey,
    <OutAttribute> ByRef value As TValue
) As Boolean
Public Function TryGetValue (
    key As TKey,
    <OutAttribute> ByRef value As TValue
) As Boolean
public:
virtual bool TryGetValue(
    TKey key,
    [OutAttribute] TValue% value
) sealed
public:
virtual bool TryGetValue(
    TKey key,
    [OutAttribute] TValue% value
) sealed
abstract TryGetValue :
        key : 'TKey *
        value : 'TValue byref -> bool
override TryGetValue :
        key : 'TKey *
        value : 'TValue byref -> bool
abstract TryGetValue :
        key : 'TKey *
        value : 'TValue byref -> bool
override TryGetValue :
        key : 'TKey *
        value : 'TValue byref -> bool

Parameters

key
Type: TKey
value
Type: TValue

Return Value

Type: Online Boolean

Implements

Online IDictionary TKey, TValue TryGetValue(TKey, TValue )
See Also
EventedDictionary TKey, TValue, TContext Class
EventedDictionary TKey, TValue, TContext Members
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext) Properties

EventedDictionary TKey, TValue, TContext Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The EventedDictionary TKey, TValue, TContext type exposes the following members.
Properties
 | Name | Description
Public property | Context | Context that this structure works in (Inherited from EventedCollectionBase TContext .)
Public property | ContextReadOnly | Returns true to indicate that Context property can not be set (was injected in .ctor only (Inherited from EventedCollectionBase TContext .)
Public property | Count |
Public property | IsReadOnly | Indicates whether collection can be modified (Inherited from EventedCollectionBase TContext .)
Public property | Item |
Public property | Keys |
Public property | Values |
Back to Top
See Also
EventedDictionary TKey, TValue, TContext Class
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext).Count Property

EventedDictionary TKey, TValue, TContext Count Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
public:
virtual property int Count {
    int get () sealed;
}
abstract Count : int with get
override Count : int with get
abstract Count : int with get
override Count : int with get

Property Value

Type: Online Int32

Implements

Online ICollection T Count
See Also
EventedDictionary TKey, TValue, TContext Class
EventedDictionary TKey, TValue, TContext Members
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext).Item Property

EventedDictionary TKey, TValue, TContext Item Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TValue this[
    TKey key
] { get; set; }
public TValue this[
    TKey key
] { get; set; }
Public Default Property Item (
    key As TKey
) As TValue
    Get
    Set
Public Default Property Item (
    key As TKey
) As TValue
    Get
    Set
public:
virtual property TValue default[TKey key] {
    TValue get (TKey key) sealed;
    void set (TKey key, TValue value) sealed;
}
public:
virtual property TValue default[TKey key] {
    TValue get (TKey key) sealed;
    void set (TKey key, TValue value) sealed;
}
abstract Item : 'TValue with get, set
override Item : 'TValue with get, set
abstract Item : 'TValue with get, set
override Item : 'TValue with get, set

Parameters

key
Type: TKey

Property Value

Type: TValue

Implements

Online IDictionary TKey, TValue Item TKey
See Also
EventedDictionary TKey, TValue, TContext Class
EventedDictionary TKey, TValue, TContext Members
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext).Keys Property

EventedDictionary TKey, TValue, TContext Keys Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICollection<TKey> Keys { get; }
public ICollection<TKey> Keys { get; }
Public ReadOnly Property Keys As ICollection(Of TKey)
    Get
Public ReadOnly Property Keys As ICollection(Of TKey)
    Get
public:
virtual property ICollection<TKey>^ Keys {
    ICollection<TKey>^ get () sealed;
}
public:
virtual property ICollection<TKey>^ Keys {
    ICollection<TKey>^ get () sealed;
}
abstract Keys : ICollection<'TKey> with get
override Keys : ICollection<'TKey> with get
abstract Keys : ICollection<'TKey> with get
override Keys : ICollection<'TKey> with get

Property Value

Type: Online ICollection TKey

Implements

Online IDictionary TKey, TValue Keys
See Also
EventedDictionary TKey, TValue, TContext Class
EventedDictionary TKey, TValue, TContext Members
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext).Values Property

EventedDictionary TKey, TValue, TContext Values Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICollection<TValue> Values { get; }
public ICollection<TValue> Values { get; }
Public ReadOnly Property Values As ICollection(Of TValue)
    Get
Public ReadOnly Property Values As ICollection(Of TValue)
    Get
public:
virtual property ICollection<TValue>^ Values {
    ICollection<TValue>^ get () sealed;
}
public:
virtual property ICollection<TValue>^ Values {
    ICollection<TValue>^ get () sealed;
}
abstract Values : ICollection<'TValue> with get
override Values : ICollection<'TValue> with get
abstract Values : ICollection<'TValue> with get
override Values : ICollection<'TValue> with get

Property Value

Type: Online ICollection TValue

Implements

Online IDictionary TKey, TValue Values
See Also
EventedDictionary TKey, TValue, TContext Class
EventedDictionary TKey, TValue, TContext Members
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext).ChangeHandler Delegate

EventedDictionary TKey, TValue, TContext ChangeHandler Delegate NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void ChangeHandler(
    EventedDictionary<TKey, TValue, TContext> dictionary,
    EventedDictionary<(Of <(<'TKey, TValue, TContext>)>)>..::..ChangeType change,
    EventPhase phase,
    TKey key,
    TValue value
)
public delegate void ChangeHandler(
    EventedDictionary<TKey, TValue, TContext> dictionary,
    EventedDictionary<(Of <(<'TKey, TValue, TContext>)>)>..::..ChangeType change,
    EventPhase phase,
    TKey key,
    TValue value
)
Public Delegate Sub ChangeHandler (
    dictionary As EventedDictionary(Of TKey, TValue, TContext),
    change As EventedDictionary<(Of <(<'TKey, TValue, TContext>)>)>..::..ChangeType,
    phase As EventPhase,
    key As TKey,
    value As TValue
)
Public Delegate Sub ChangeHandler (
    dictionary As EventedDictionary(Of TKey, TValue, TContext),
    change As EventedDictionary<(Of <(<'TKey, TValue, TContext>)>)>..::..ChangeType,
    phase As EventPhase,
    key As TKey,
    value As TValue
)
public delegate void ChangeHandler(
    EventedDictionary<TKey, TValue, TContext>^ dictionary,
    EventedDictionary<(Of <(<'TKey, TValue, TContext>)>)>..::..ChangeType change,
    EventPhase phase,
    TKey key,
    TValue value
)
public delegate void ChangeHandler(
    EventedDictionary<TKey, TValue, TContext>^ dictionary,
    EventedDictionary<(Of <(<'TKey, TValue, TContext>)>)>..::..ChangeType change,
    EventPhase phase,
    TKey key,
    TValue value
)
type ChangeHandler =
    delegate of
        dictionary : EventedDictionary<'TKey, 'TValue, 'TContext> *
        change : EventedDictionary<(Of <(<'TKey, TValue, TContext>)>)>..::..ChangeType *
        phase : EventPhase *
        key : 'TKey *
        value : 'TValue -> unit
type ChangeHandler =
    delegate of
        dictionary : EventedDictionary<'TKey, 'TValue, 'TContext> *
        change : EventedDictionary<(Of <(<'TKey, TValue, TContext>)>)>..::..ChangeType *
        phase : EventPhase *
        key : 'TKey *
        value : 'TValue -> unit

Parameters

dictionary
Type: NFX.Collections EventedDictionary TKey, TValue, TContext
change
Type: NFX.Collections EventedDictionary TKey, TValue, TContext ChangeType
phase
Type: NFX.Collections EventPhase
key
Type: TKey
value
Type: TValue
See Also
NFX.Collections Namespace


EventedDictionary(TKey, TValue, TContext).ChangeType Enumeration

EventedDictionary TKey, TValue, TContext ChangeType Enumeration NFX Class Library

[This is preliminary documentation and is subject to change.]

Describes changes in evented list

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum ChangeType
public enum ChangeType
Public Enumeration ChangeType
Public Enumeration ChangeType
public enum class ChangeType
public enum class ChangeType
type ChangeType
type ChangeType
Members
Member name | Value | Description
Add | 0 |
Remove | 1 |
Set | 2 |
Clear | 3 |
See Also
NFX.Collections Namespace


EventedList(TData, TContext) Class

EventedList TData, TContext Class NFX Class Library

Represents list that rises change events
Inheritance Hierarchy
Online System Object
NFX.Collections EventedCollectionBase TContext
NFX.Collections EventedList TData, TContext

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class EventedList<TData, TContext> : EventedCollectionBase<TContext>,
    IList<TData>, ICollection<TData>, IEnumerable<TData>, IEnumerable
[SerializableAttribute]
public class EventedList<TData, TContext> : EventedCollectionBase<TContext>,
    IList<TData>, ICollection<TData>, IEnumerable<TData>, IEnumerable
<SerializableAttribute>
Public Class EventedList(Of TData, TContext)
    Inherits EventedCollectionBase(Of TContext)
    Implements IList(Of TData), ICollection(Of TData),
    IEnumerable(Of TData), IEnumerable
<SerializableAttribute>
Public Class EventedList(Of TData, TContext)
    Inherits EventedCollectionBase(Of TContext)
    Implements IList(Of TData), ICollection(Of TData),
    IEnumerable(Of TData), IEnumerable
[SerializableAttribute]
generic<typename TData, typename TContext>
public ref class EventedList : public EventedCollectionBase<TContext>,
    IList<TData>, ICollection<TData>, IEnumerable<TData>, IEnumerable
[SerializableAttribute]
generic<typename TData, typename TContext>
public ref class EventedList : public EventedCollectionBase<TContext>,
    IList<TData>, ICollection<TData>, IEnumerable<TData>, IEnumerable
[<SerializableAttribute>]
type EventedList<'TData, 'TContext> =
    class
        inherit EventedCollectionBase<'TContext>
        interface IList<'TData>
        interface ICollection<'TData>
        interface IEnumerable<'TData>
        interface IEnumerable
    end
[<SerializableAttribute>]
type EventedList<'TData, 'TContext> =
    class
        inherit EventedCollectionBase<'TContext>
        interface IList<'TData>
        interface ICollection<'TData>
        interface IEnumerable<'TData>
        interface IEnumerable
    end
Type Parameters
TData
TContext
See Also
EventedList TData, TContext Members
NFX.Collections Namespace


EventedList(TData, TContext) Members

EventedList TData, TContext Members NFX Class Library

The EventedList TData, TContext type exposes the following members.
Constructors
 | Name | Description
Public method | EventedList TData, TContext | Initializes a new instance that is empty and has the default initial capacity.
Public method | EventedList TData, TContext (TContext, Boolean) | Initializes a new instance that is empty and has the default initial capacity.
Public method | EventedList TData, TContext (TContext, Boolean, IEnumerable TData ) | Initializes a new instance that contains elements copied from the specified collection and has sufficient capacity to accommodate the number of elements copied.
Public method | EventedList TData, TContext (TContext, Boolean, Int32) | Initializes a new instance that is empty and has the specified initial capacity.
Back to Top
Methods
 | Name | Description
Public method | Add |
Public method | CheckReadOnly | (Inherited from EventedCollectionBase TContext .)
Public method | Clear |
Public method | Contains |
Public method | CopyTo |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IndexOf |
Public method | Insert |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove |
Public method | RemoveAt |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable TData | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct TData, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax TData, TComparand (Func TData, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax TData, TComparand (Func TData, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin TData, TComparand (Func TData, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin TData, TComparand (Func TData, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault TData | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach TData (Action TData ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach TData (Action TData, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast TData | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast TData (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | ChangeEvent |
Public field | GetReadOnlyEvent | (Inherited from EventedCollectionBase TContext .)
Back to Top
Properties
 | Name | Description
Public property | Context | Context that this structure works in (Inherited from EventedCollectionBase TContext .)
Public property | ContextReadOnly | Returns true to indicate that Context property can not be set (was injected in .ctor only (Inherited from EventedCollectionBase TContext .)
Public property | Count |
Public property | IsReadOnly | Indicates whether collection can be modified (Inherited from EventedCollectionBase TContext .)
Public property | Item |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
EventedList TData, TContext Class
NFX.Collections Namespace


EventedList(TData, TContext) Constructor

EventedList TData, TContext Constructor NFX Class Library

Overload List
 | Name | Description
Public method | EventedList TData, TContext | Initializes a new instance that is empty and has the default initial capacity.
Public method | EventedList TData, TContext (TContext, Boolean) | Initializes a new instance that is empty and has the default initial capacity.
Public method | EventedList TData, TContext (TContext, Boolean, IEnumerable TData ) | Initializes a new instance that contains elements copied from the specified collection and has sufficient capacity to accommodate the number of elements copied.
Public method | EventedList TData, TContext (TContext, Boolean, Int32) | Initializes a new instance that is empty and has the specified initial capacity.
Back to Top
See Also
EventedList TData, TContext Class
EventedList TData, TContext Members
NFX.Collections Namespace


EventedList(TData, TContext) Constructor

EventedList TData, TContext Constructor NFX Class Library

Initializes a new instance that is empty and has the default initial capacity.

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EventedList()
public EventedList()
Public Sub New
Public Sub New
public:
EventedList()
public:
EventedList()
new : unit -> EventedList
new : unit -> EventedList
See Also
EventedList TData, TContext Class
EventedList TData, TContext Members
EventedList TData, TContext Overload
NFX.Collections Namespace


EventedList(TData, TContext) Constructor (TContext, Boolean)

EventedList TData, TContext Constructor (TContext, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance that is empty and has the default initial capacity.

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EventedList(
    TContext context,
    bool contextReadOnly
)
public EventedList(
    TContext context,
    bool contextReadOnly
)
Public Sub New (
    context As TContext,
    contextReadOnly As Boolean
)
Public Sub New (
    context As TContext,
    contextReadOnly As Boolean
)
public:
EventedList(
    TContext context,
    bool contextReadOnly
)
public:
EventedList(
    TContext context,
    bool contextReadOnly
)
new :
        context : 'TContext *
        contextReadOnly : bool -> EventedList
new :
        context : 'TContext *
        contextReadOnly : bool -> EventedList

Parameters

context
Type: TContext
contextReadOnly
Type: Online System Boolean
See Also
EventedList TData, TContext Class
EventedList TData, TContext Members
EventedList TData, TContext Overload
NFX.Collections Namespace


EventedList(TData, TContext) Constructor (TContext, Boolean, IEnumerable(TData))

EventedList TData, TContext Constructor (TContext, Boolean, IEnumerable TData ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance that contains elements copied from the specified collection and has sufficient capacity to accommodate the number of elements copied.

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EventedList(
    TContext context,
    bool contextReadOnly,
    IEnumerable<TData> collection
)
public EventedList(
    TContext context,
    bool contextReadOnly,
    IEnumerable<TData> collection
)
Public Sub New (
    context As TContext,
    contextReadOnly As Boolean,
    collection As IEnumerable(Of TData)
)
Public Sub New (
    context As TContext,
    contextReadOnly As Boolean,
    collection As IEnumerable(Of TData)
)
public:
EventedList(
    TContext context,
    bool contextReadOnly,
    IEnumerable<TData>^ collection
)
public:
EventedList(
    TContext context,
    bool contextReadOnly,
    IEnumerable<TData>^ collection
)
new :
        context : 'TContext *
        contextReadOnly : bool *
        collection : IEnumerable<'TData> -> EventedList
new :
        context : 'TContext *
        contextReadOnly : bool *
        collection : IEnumerable<'TData> -> EventedList

Parameters

context
Type: TContext
contextReadOnly
Type: Online System Boolean
collection
Type: Online System.Collections.Generic IEnumerable TData
See Also
EventedList TData, TContext Class
EventedList TData, TContext Members
EventedList TData, TContext Overload
NFX.Collections Namespace


EventedList(TData, TContext) Constructor (TContext, Boolean, Int32)

EventedList TData, TContext Constructor (TContext, Boolean, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance that is empty and has the specified initial capacity.

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EventedList(
    TContext context,
    bool contextReadOnly,
    int capacity
)
public EventedList(
    TContext context,
    bool contextReadOnly,
    int capacity
)
Public Sub New (
    context As TContext,
    contextReadOnly As Boolean,
    capacity As Integer
)
Public Sub New (
    context As TContext,
    contextReadOnly As Boolean,
    capacity As Integer
)
public:
EventedList(
    TContext context,
    bool contextReadOnly,
    int capacity
)
public:
EventedList(
    TContext context,
    bool contextReadOnly,
    int capacity
)
new :
        context : 'TContext *
        contextReadOnly : bool *
        capacity : int -> EventedList
new :
        context : 'TContext *
        contextReadOnly : bool *
        capacity : int -> EventedList

Parameters

context
Type: TContext
contextReadOnly
Type: Online System Boolean
capacity
Type: Online System Int32
See Also
EventedList TData, TContext Class
EventedList TData, TContext Members
EventedList TData, TContext Overload
NFX.Collections Namespace


EventedList(TData, TContext) Fields

EventedList TData, TContext Fields NFX Class Library

The EventedList TData, TContext type exposes the following members.
Fields
 | Name | Description
Public field | ChangeEvent |
Public field | GetReadOnlyEvent | (Inherited from EventedCollectionBase TContext .)
Back to Top
See Also
EventedList TData, TContext Class
NFX.Collections Namespace


EventedList(TData, TContext).ChangeEvent Field

EventedList TData, TContext ChangeEvent Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[NonSerializedAttribute]
public EventedList<(Of <(<'TData, TContext>)>)>..::..ChangeHandler ChangeEvent
[NonSerializedAttribute]
public EventedList<(Of <(<'TData, TContext>)>)>..::..ChangeHandler ChangeEvent
<NonSerializedAttribute>
Public ChangeEvent As EventedList<(Of <(<'TData, TContext>)>)>..::..ChangeHandler
<NonSerializedAttribute>
Public ChangeEvent As EventedList<(Of <(<'TData, TContext>)>)>..::..ChangeHandler
public:
[NonSerializedAttribute]
EventedList<(Of <(<'TData, TContext>)>)>..::..ChangeHandler^ ChangeEvent
public:
[NonSerializedAttribute]
EventedList<(Of <(<'TData, TContext>)>)>..::..ChangeHandler^ ChangeEvent
[<NonSerializedAttribute>]
val mutable ChangeEvent: EventedList<(Of <(<'TData, TContext>)>)>..::..ChangeHandler
[<NonSerializedAttribute>]
val mutable ChangeEvent: EventedList<(Of <(<'TData, TContext>)>)>..::..ChangeHandler

Field Value

Type: EventedList TData, TContext ChangeHandler
See Also
EventedList TData, TContext Class
EventedList TData, TContext Members
NFX.Collections Namespace


EventedList(TData, TContext) Methods

EventedList TData, TContext Methods NFX Class Library

The EventedList TData, TContext type exposes the following members.
Methods
 | Name | Description
Public method | Add |
Public method | CheckReadOnly | (Inherited from EventedCollectionBase TContext .)
Public method | Clear |
Public method | Contains |
Public method | CopyTo |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IndexOf |
Public method | Insert |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove |
Public method | RemoveAt |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable TData | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct TData, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax TData, TComparand (Func TData, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax TData, TComparand (Func TData, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin TData, TComparand (Func TData, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin TData, TComparand (Func TData, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault TData | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach TData (Action TData ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach TData (Action TData, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast TData | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast TData (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
EventedList TData, TContext Class
NFX.Collections Namespace


EventedList(TData, TContext).IEnumerable.GetEnumerator Method

EventedList TData, TContext IEnumerable GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
EventedList TData, TContext Class
EventedList TData, TContext Members
NFX.Collections Namespace


EventedList(TData, TContext).Add Method

EventedList TData, TContext Add Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Add(
    TData item
)
public virtual void Add(
    TData item
)
Public Overridable Sub Add (
    item As TData
)
Public Overridable Sub Add (
    item As TData
)
public:
virtual void Add(
    TData item
)
public:
virtual void Add(
    TData item
)
abstract Add :
        item : 'TData -> unit
override Add :
        item : 'TData -> unit
abstract Add :
        item : 'TData -> unit
override Add :
        item : 'TData -> unit

Parameters

item
Type: TData

Implements

Online ICollection T Add(T)
See Also
EventedList TData, TContext Class
EventedList TData, TContext Members
NFX.Collections Namespace


EventedList(TData, TContext).Clear Method

EventedList TData, TContext Clear Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Clear()
public virtual void Clear()
Public Overridable Sub Clear
Public Overridable Sub Clear
public:
virtual void Clear()
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

Online ICollection T Clear
See Also
EventedList TData, TContext Class
EventedList TData, TContext Members
NFX.Collections Namespace


EventedList(TData, TContext).Contains Method

EventedList TData, TContext Contains Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Contains(
    TData item
)
public virtual bool Contains(
    TData item
)
Public Overridable Function Contains (
    item As TData
) As Boolean
Public Overridable Function Contains (
    item As TData
) As Boolean
public:
virtual bool Contains(
    TData item
)
public:
virtual bool Contains(
    TData item
)
abstract Contains :
        item : 'TData -> bool
override Contains :
        item : 'TData -> bool
abstract Contains :
        item : 'TData -> bool
override Contains :
        item : 'TData -> bool

Parameters

item
Type: TData

Return Value

Type: Online Boolean

Implements

Online ICollection T Contains(T)
See Also
EventedList TData, TContext Class
EventedList TData, TContext Members
NFX.Collections Namespace


EventedList(TData, TContext).CopyTo Method

EventedList TData, TContext CopyTo Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void CopyTo(
    TData[] array,
    int arrayIndex
)
public virtual void CopyTo(
    TData[] array,
    int arrayIndex
)
Public Overridable Sub CopyTo (
    array As TData(),
    arrayIndex As Integer
)
Public Overridable Sub CopyTo (
    array As TData(),
    arrayIndex As Integer
)
public:
virtual void CopyTo(
    array<TData>^ array,
    int arrayIndex
)
public:
virtual void CopyTo(
    array<TData>^ array,
    int arrayIndex
)
abstract CopyTo :
        array : 'TData[] *
        arrayIndex : int -> unit
override CopyTo :
        array : 'TData[] *
        arrayIndex : int -> unit
abstract CopyTo :
        array : 'TData[] *
        arrayIndex : int -> unit
override CopyTo :
        array : 'TData[] *
        arrayIndex : int -> unit

Parameters

array
Type: TData
arrayIndex
Type: Online System Int32

Implements

Online ICollection T CopyTo( T , Int32)
See Also
EventedList TData, TContext Class
EventedList TData, TContext Members
NFX.Collections Namespace


EventedList(TData, TContext).GetEnumerator Method

EventedList TData, TContext GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IEnumerator<TData> GetEnumerator()
public virtual IEnumerator<TData> GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator(Of TData)
Public Overridable Function GetEnumerator As IEnumerator(Of TData)
public:
virtual IEnumerator<TData>^ GetEnumerator()
public:
virtual IEnumerator<TData>^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator<'TData>
override GetEnumerator : unit -> IEnumerator<'TData>
abstract GetEnumerator : unit -> IEnumerator<'TData>
override GetEnumerator : unit -> IEnumerator<'TData>

Return Value

Type: Online IEnumerator TData

Implements

Online IEnumerable T GetEnumerator
See Also
EventedList TData, TContext Class
EventedList TData, TContext Members
NFX.Collections Namespace


EventedList(TData, TContext).IndexOf Method

EventedList TData, TContext IndexOf Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int IndexOf(
    TData item
)
public virtual int IndexOf(
    TData item
)
Public Overridable Function IndexOf (
    item As TData
) As Integer
Public Overridable Function IndexOf (
    item As TData
) As Integer
public:
virtual int IndexOf(
    TData item
)
public:
virtual int IndexOf(
    TData item
)
abstract IndexOf :
        item : 'TData -> int
override IndexOf :
        item : 'TData -> int
abstract IndexOf :
        item : 'TData -> int
override IndexOf :
        item : 'TData -> int

Parameters

item
Type: TData

Return Value

Type: Online Int32

Implements

Online IList T IndexOf(T)
See Also
EventedList TData, TContext Class
EventedList TData, TContext Members
NFX.Collections Namespace


EventedList(TData, TContext).Insert Method

EventedList TData, TContext Insert Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Insert(
    int index,
    TData item
)
public virtual void Insert(
    int index,
    TData item
)
Public Overridable Sub Insert (
    index As Integer,
    item As TData
)
Public Overridable Sub Insert (
    index As Integer,
    item As TData
)
public:
virtual void Insert(
    int index,
    TData item
)
public:
virtual void Insert(
    int index,
    TData item
)
abstract Insert :
        index : int *
        item : 'TData -> unit
override Insert :
        index : int *
        item : 'TData -> unit
abstract Insert :
        index : int *
        item : 'TData -> unit
override Insert :
        index : int *
        item : 'TData -> unit

Parameters

index
Type: Online System Int32
item
Type: TData

Implements

Online IList T Insert(Int32, T)
See Also
EventedList TData, TContext Class
EventedList TData, TContext Members
NFX.Collections Namespace


EventedList(TData, TContext).Remove Method

EventedList TData, TContext Remove Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Remove(
    TData item
)
public virtual bool Remove(
    TData item
)
Public Overridable Function Remove (
    item As TData
) As Boolean
Public Overridable Function Remove (
    item As TData
) As Boolean
public:
virtual bool Remove(
    TData item
)
public:
virtual bool Remove(
    TData item
)
abstract Remove :
        item : 'TData -> bool
override Remove :
        item : 'TData -> bool
abstract Remove :
        item : 'TData -> bool
override Remove :
        item : 'TData -> bool

Parameters

item
Type: TData

Return Value

Type: Online Boolean

Implements

Online ICollection T Remove(T)
See Also
EventedList TData, TContext Class
EventedList TData, TContext Members
NFX.Collections Namespace


EventedList(TData, TContext).RemoveAt Method

EventedList TData, TContext RemoveAt Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void RemoveAt(
    int index
)
public virtual void RemoveAt(
    int index
)
Public Overridable Sub RemoveAt (
    index As Integer
)
Public Overridable Sub RemoveAt (
    index As Integer
)
public:
virtual void RemoveAt(
    int index
)
public:
virtual void RemoveAt(
    int index
)
abstract RemoveAt :
        index : int -> unit
override RemoveAt :
        index : int -> unit
abstract RemoveAt :
        index : int -> unit
override RemoveAt :
        index : int -> unit

Parameters

index
Type: Online System Int32

Implements

Online IList T RemoveAt(Int32)
See Also
EventedList TData, TContext Class
EventedList TData, TContext Members
NFX.Collections Namespace


EventedList(TData, TContext) Properties

EventedList TData, TContext Properties NFX Class Library

The EventedList TData, TContext type exposes the following members.
Properties
 | Name | Description
Public property | Context | Context that this structure works in (Inherited from EventedCollectionBase TContext .)
Public property | ContextReadOnly | Returns true to indicate that Context property can not be set (was injected in .ctor only (Inherited from EventedCollectionBase TContext .)
Public property | Count |
Public property | IsReadOnly | Indicates whether collection can be modified (Inherited from EventedCollectionBase TContext .)
Public property | Item |
Back to Top
See Also
EventedList TData, TContext Class
NFX.Collections Namespace


EventedList(TData, TContext).Count Property

EventedList TData, TContext Count Property NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Count { get; }
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}
public:
virtual property int Count {
    int get ();
}
abstract Count : int with get
override Count : int with get
abstract Count : int with get
override Count : int with get

Property Value

Type: Online Int32

Implements

Online ICollection T Count
See Also
EventedList TData, TContext Class
EventedList TData, TContext Members
NFX.Collections Namespace


EventedList(TData, TContext).Item Property

EventedList TData, TContext Item Property NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual TData this[
    int index
] { get; set; }
public virtual TData this[
    int index
] { get; set; }
Public Overridable Default Property Item (
    index As Integer
) As TData
    Get
    Set
Public Overridable Default Property Item (
    index As Integer
) As TData
    Get
    Set
public:
virtual property TData default[int index] {
    TData get (int index);
    void set (int index, TData value);
}
public:
virtual property TData default[int index] {
    TData get (int index);
    void set (int index, TData value);
}
abstract Item : 'TData with get, set
override Item : 'TData with get, set
abstract Item : 'TData with get, set
override Item : 'TData with get, set

Parameters

index
Type: Online System Int32

Property Value

Type: TData

Implements

Online IList T Item Int32
See Also
EventedList TData, TContext Class
EventedList TData, TContext Members
NFX.Collections Namespace


EventedList(TData, TContext).ChangeHandler Delegate

EventedList TData, TContext ChangeHandler Delegate NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void ChangeHandler(
    EventedList<TData, TContext> list,
    EventedList<(Of <(<'TData, TContext>)>)>..::..ChangeType change,
    EventPhase phase,
    int idx,
    TData item
)
public delegate void ChangeHandler(
    EventedList<TData, TContext> list,
    EventedList<(Of <(<'TData, TContext>)>)>..::..ChangeType change,
    EventPhase phase,
    int idx,
    TData item
)
Public Delegate Sub ChangeHandler (
    list As EventedList(Of TData, TContext),
    change As EventedList<(Of <(<'TData, TContext>)>)>..::..ChangeType,
    phase As EventPhase,
    idx As Integer,
    item As TData
)
Public Delegate Sub ChangeHandler (
    list As EventedList(Of TData, TContext),
    change As EventedList<(Of <(<'TData, TContext>)>)>..::..ChangeType,
    phase As EventPhase,
    idx As Integer,
    item As TData
)
public delegate void ChangeHandler(
    EventedList<TData, TContext>^ list,
    EventedList<(Of <(<'TData, TContext>)>)>..::..ChangeType change,
    EventPhase phase,
    int idx,
    TData item
)
public delegate void ChangeHandler(
    EventedList<TData, TContext>^ list,
    EventedList<(Of <(<'TData, TContext>)>)>..::..ChangeType change,
    EventPhase phase,
    int idx,
    TData item
)
type ChangeHandler =
    delegate of
        list : EventedList<'TData, 'TContext> *
        change : EventedList<(Of <(<'TData, TContext>)>)>..::..ChangeType *
        phase : EventPhase *
        idx : int *
        item : 'TData -> unit
type ChangeHandler =
    delegate of
        list : EventedList<'TData, 'TContext> *
        change : EventedList<(Of <(<'TData, TContext>)>)>..::..ChangeType *
        phase : EventPhase *
        idx : int *
        item : 'TData -> unit

Parameters

list
Type: NFX.Collections EventedList TData, TContext
change
Type: NFX.Collections EventedList TData, TContext ChangeType
phase
Type: NFX.Collections EventPhase
idx
Type: Online System Int32
item
Type: TData
See Also
NFX.Collections Namespace


EventedList(TData, TContext).ChangeType Enumeration

EventedList TData, TContext ChangeType Enumeration NFX Class Library

[This is preliminary documentation and is subject to change.]

Describes changes in evented list

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum ChangeType
public enum ChangeType
Public Enumeration ChangeType
Public Enumeration ChangeType
public enum class ChangeType
public enum class ChangeType
type ChangeType
type ChangeType
Members
Member name | Value | Description
Insert | 0 |
RemoveAt | 1 |
Set | 2 |
Add | 3 |
Clear | 4 |
Remove | 5 |
See Also
NFX.Collections Namespace


EventPhase Enumeration

EventPhase Enumeration NFX Class Library

Specifies the phase of the event i.e. before/after

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum EventPhase
public enum EventPhase
Public Enumeration EventPhase
Public Enumeration EventPhase
public enum class EventPhase
public enum class EventPhase
type EventPhase
type EventPhase
Members
Member name | Value | Description
Before | 0 |
After | 1 |
See Also
NFX.Collections Namespace


ILookAheadEnumerable(T) Interface

ILookAheadEnumerable T Interface NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ILookAheadEnumerable<T> : IEnumerable<T>,
    IEnumerable
public interface ILookAheadEnumerable<T> : IEnumerable<T>,
    IEnumerable
Public Interface ILookAheadEnumerable(Of T)
    Inherits IEnumerable(Of T), IEnumerable
Public Interface ILookAheadEnumerable(Of T)
    Inherits IEnumerable(Of T), IEnumerable
generic<typename T>
public interface class ILookAheadEnumerable : IEnumerable<T>,
    IEnumerable
generic<typename T>
public interface class ILookAheadEnumerable : IEnumerable<T>,
    IEnumerable
type ILookAheadEnumerable<'T> =
    interface
        interface IEnumerable<'T>
        interface IEnumerable
    end
type ILookAheadEnumerable<'T> =
    interface
        interface IEnumerable<'T>
        interface IEnumerable
    end
Type Parameters
T
See Also
ILookAheadEnumerable T Members
NFX.Collections Namespace


ILookAheadEnumerable(T) Members

ILookAheadEnumerable T Members NFX Class Library

The ILookAheadEnumerable T type exposes the following members.
Methods
 | Name | Description
Public method | Online GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from Online IEnumerable T .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Online IEnumerable.)
Public method | GetLookAheadEnumerator |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsLookAheadEnumerable T | (Defined by LookAheadExtensions.)
Public Extension Method | Distinct T, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault T | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast T | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast T (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Back to Top
See Also
ILookAheadEnumerable T Interface
NFX.Collections Namespace


ILookAheadEnumerable(T) Methods

ILookAheadEnumerable T Methods NFX Class Library

The ILookAheadEnumerable T type exposes the following members.
Methods
 | Name | Description
Public method | Online GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from Online IEnumerable T .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Online IEnumerable.)
Public method | GetLookAheadEnumerator |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsLookAheadEnumerable T | (Defined by LookAheadExtensions.)
Public Extension Method | Distinct T, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault T | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast T | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast T (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Back to Top
See Also
ILookAheadEnumerable T Interface
NFX.Collections Namespace


ILookAheadEnumerable(T).GetLookAheadEnumerator Method

ILookAheadEnumerable T GetLookAheadEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ILookAheadEnumerator<T> GetLookAheadEnumerator()
ILookAheadEnumerator<T> GetLookAheadEnumerator()
Function GetLookAheadEnumerator As ILookAheadEnumerator(Of T)
Function GetLookAheadEnumerator As ILookAheadEnumerator(Of T)
ILookAheadEnumerator<T>^ GetLookAheadEnumerator()
ILookAheadEnumerator<T>^ GetLookAheadEnumerator()
abstract GetLookAheadEnumerator : unit -> ILookAheadEnumerator<'T>
abstract GetLookAheadEnumerator : unit -> ILookAheadEnumerator<'T>

Return Value

Type: ILookAheadEnumerator T
See Also
ILookAheadEnumerable T Interface
ILookAheadEnumerable T Members
NFX.Collections Namespace


ILookAheadEnumerator(T) Interface

ILookAheadEnumerator T Interface NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ILookAheadEnumerator<T> : IEnumerator<T>,
    IDisposable, IEnumerator
public interface ILookAheadEnumerator<T> : IEnumerator<T>,
    IDisposable, IEnumerator
Public Interface ILookAheadEnumerator(Of T)
    Inherits IEnumerator(Of T), IDisposable, IEnumerator
Public Interface ILookAheadEnumerator(Of T)
    Inherits IEnumerator(Of T), IDisposable, IEnumerator
generic<typename T>
public interface class ILookAheadEnumerator : IEnumerator<T>,
    IDisposable, IEnumerator
generic<typename T>
public interface class ILookAheadEnumerator : IEnumerator<T>,
    IDisposable, IEnumerator
type ILookAheadEnumerator<'T> =
    interface
        interface IEnumerator<'T>
        interface IDisposable
        interface IEnumerator
    end
type ILookAheadEnumerator<'T> =
    interface
        interface IEnumerator<'T>
        interface IDisposable
        interface IEnumerator
    end
Type Parameters
T
See Also
ILookAheadEnumerator T Members
NFX.Collections Namespace


ILookAheadEnumerator(T) Members

ILookAheadEnumerator T Members NFX Class Library

The ILookAheadEnumerator T type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | Online MoveNext | Advances the enumerator to the next element of the collection. (Inherited from Online IEnumerator.)
Public method | Online Reset | Sets the enumerator to its initial position, which is before the first element in the collection. (Inherited from Online IEnumerator.)
Back to Top
Properties
 | Name | Description
Public property | Online Current | Gets the element in the collection at the current position of the enumerator. (Inherited from Online IEnumerator T .)
Public property | Online Current | Gets the current element in the collection. (Inherited from Online IEnumerator.)
Public property | HasNext |
Public property | Next |
Back to Top
See Also
ILookAheadEnumerator T Interface
NFX.Collections Namespace


ILookAheadEnumerator(T) Methods

ILookAheadEnumerator T Methods NFX Class Library

The ILookAheadEnumerator T type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | Online MoveNext | Advances the enumerator to the next element of the collection. (Inherited from Online IEnumerator.)
Public method | Online Reset | Sets the enumerator to its initial position, which is before the first element in the collection. (Inherited from Online IEnumerator.)
Back to Top
See Also
ILookAheadEnumerator T Interface
NFX.Collections Namespace


ILookAheadEnumerator(T) Properties

ILookAheadEnumerator T Properties NFX Class Library

The ILookAheadEnumerator T type exposes the following members.
Properties
 | Name | Description
Public property | Online Current | Gets the element in the collection at the current position of the enumerator. (Inherited from Online IEnumerator T .)
Public property | Online Current | Gets the current element in the collection. (Inherited from Online IEnumerator.)
Public property | HasNext |
Public property | Next |
Back to Top
See Also
ILookAheadEnumerator T Interface
NFX.Collections Namespace


ILookAheadEnumerator(T).HasNext Property

ILookAheadEnumerator T HasNext Property NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool HasNext { get; }
bool HasNext { get; }
ReadOnly Property HasNext As Boolean
    Get
ReadOnly Property HasNext As Boolean
    Get
property bool HasNext {
    bool get ();
}
property bool HasNext {
    bool get ();
}
abstract HasNext : bool with get
abstract HasNext : bool with get

Property Value

Type: Online Boolean
See Also
ILookAheadEnumerator T Interface
ILookAheadEnumerator T Members
NFX.Collections Namespace


ILookAheadEnumerator(T).Next Property

ILookAheadEnumerator T Next Property NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
T Next { get; }
T Next { get; }
ReadOnly Property Next As T
    Get
ReadOnly Property Next As T
    Get
property T Next {
    T get ();
}
property T Next {
    T get ();
}
abstract Next : 'T with get
abstract Next : 'T with get

Property Value

Type: T
See Also
ILookAheadEnumerator T Interface
ILookAheadEnumerator T Members
NFX.Collections Namespace


LookAheadEnumerable(T) Class

LookAheadEnumerable T Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Collections LookAheadEnumerable T

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class LookAheadEnumerable<T> : ILookAheadEnumerable<T>,
    IEnumerable<T>, IEnumerable
public sealed class LookAheadEnumerable<T> : ILookAheadEnumerable<T>,
    IEnumerable<T>, IEnumerable
Public NotInheritable Class LookAheadEnumerable(Of T)
    Implements ILookAheadEnumerable(Of T), IEnumerable(Of T),
    IEnumerable
Public NotInheritable Class LookAheadEnumerable(Of T)
    Implements ILookAheadEnumerable(Of T), IEnumerable(Of T),
    IEnumerable
generic<typename T>
public ref class LookAheadEnumerable sealed : ILookAheadEnumerable<T>,
    IEnumerable<T>, IEnumerable
generic<typename T>
public ref class LookAheadEnumerable sealed : ILookAheadEnumerable<T>,
    IEnumerable<T>, IEnumerable
[<SealedAttribute>]
type LookAheadEnumerable<'T> =
    class
        interface ILookAheadEnumerable<'T>
        interface IEnumerable<'T>
        interface IEnumerable
    end
[<SealedAttribute>]
type LookAheadEnumerable<'T> =
    class
        interface ILookAheadEnumerable<'T>
        interface IEnumerable<'T>
        interface IEnumerable
    end
Type Parameters
T
See Also
LookAheadEnumerable T Members
NFX.Collections Namespace


LookAheadEnumerable(T) Members

LookAheadEnumerable T Members NFX Class Library

The LookAheadEnumerable T type exposes the following members.
Constructors
 | Name | Description
Public method | LookAheadEnumerable T | Initializes a new instance of the LookAheadEnumerable T class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetLookAheadEnumerator |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable T | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct T, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault T | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast T | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast T (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
LookAheadEnumerable T Class
NFX.Collections Namespace


LookAheadEnumerable(T) Constructor

LookAheadEnumerable T Constructor NFX Class Library

Initializes a new instance of the LookAheadEnumerable T class

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LookAheadEnumerable(
    IEnumerable<T> enumerable
)
public LookAheadEnumerable(
    IEnumerable<T> enumerable
)
Public Sub New (
    enumerable As IEnumerable(Of T)
)
Public Sub New (
    enumerable As IEnumerable(Of T)
)
public:
LookAheadEnumerable(
    IEnumerable<T>^ enumerable
)
public:
LookAheadEnumerable(
    IEnumerable<T>^ enumerable
)
new :
        enumerable : IEnumerable<'T> -> LookAheadEnumerable
new :
        enumerable : IEnumerable<'T> -> LookAheadEnumerable

Parameters

enumerable
Type: Online System.Collections.Generic IEnumerable T
See Also
LookAheadEnumerable T Class
LookAheadEnumerable T Members
NFX.Collections Namespace


LookAheadEnumerable(T) Methods

LookAheadEnumerable T Methods NFX Class Library

The LookAheadEnumerable T type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetLookAheadEnumerator |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable T | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct T, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault T | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast T | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast T (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
LookAheadEnumerable T Class
NFX.Collections Namespace


LookAheadEnumerable(T).IEnumerable.GetEnumerator Method

LookAheadEnumerable T IEnumerable GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
LookAheadEnumerable T Class
LookAheadEnumerable T Members
NFX.Collections Namespace


LookAheadEnumerable(T).GetEnumerator Method

LookAheadEnumerable T GetEnumerator Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<T> GetEnumerator()
public IEnumerator<T> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of T)
Public Function GetEnumerator As IEnumerator(Of T)
public:
virtual IEnumerator<T>^ GetEnumerator() sealed
public:
virtual IEnumerator<T>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<'T>
override GetEnumerator : unit -> IEnumerator<'T>
abstract GetEnumerator : unit -> IEnumerator<'T>
override GetEnumerator : unit -> IEnumerator<'T>

Return Value

Type: Online IEnumerator T

Implements

Online IEnumerable T GetEnumerator
See Also
LookAheadEnumerable T Class
LookAheadEnumerable T Members
NFX.Collections Namespace


LookAheadEnumerable(T).GetLookAheadEnumerator Method

LookAheadEnumerable T GetLookAheadEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ILookAheadEnumerator<T> GetLookAheadEnumerator()
public ILookAheadEnumerator<T> GetLookAheadEnumerator()
Public Function GetLookAheadEnumerator As ILookAheadEnumerator(Of T)
Public Function GetLookAheadEnumerator As ILookAheadEnumerator(Of T)
public:
virtual ILookAheadEnumerator<T>^ GetLookAheadEnumerator() sealed
public:
virtual ILookAheadEnumerator<T>^ GetLookAheadEnumerator() sealed
abstract GetLookAheadEnumerator : unit -> ILookAheadEnumerator<'T>
override GetLookAheadEnumerator : unit -> ILookAheadEnumerator<'T>
abstract GetLookAheadEnumerator : unit -> ILookAheadEnumerator<'T>
override GetLookAheadEnumerator : unit -> ILookAheadEnumerator<'T>

Return Value

Type: ILookAheadEnumerator T

Implements

ILookAheadEnumerable T GetLookAheadEnumerator
See Also
LookAheadEnumerable T Class
LookAheadEnumerable T Members
NFX.Collections Namespace


LookAheadEnumerator(T) Class

LookAheadEnumerator T Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Collections LookAheadEnumerator T

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class LookAheadEnumerator<T> : ILookAheadEnumerator<T>,
    IEnumerator<T>, IDisposable, IEnumerator
public sealed class LookAheadEnumerator<T> : ILookAheadEnumerator<T>,
    IEnumerator<T>, IDisposable, IEnumerator
Public NotInheritable Class LookAheadEnumerator(Of T)
    Implements ILookAheadEnumerator(Of T), IEnumerator(Of T),
    IDisposable, IEnumerator
Public NotInheritable Class LookAheadEnumerator(Of T)
    Implements ILookAheadEnumerator(Of T), IEnumerator(Of T),
    IDisposable, IEnumerator
generic<typename T>
public ref class LookAheadEnumerator sealed : ILookAheadEnumerator<T>,
    IEnumerator<T>, IDisposable, IEnumerator
generic<typename T>
public ref class LookAheadEnumerator sealed : ILookAheadEnumerator<T>,
    IEnumerator<T>, IDisposable, IEnumerator
[<SealedAttribute>]
type LookAheadEnumerator<'T> =
    class
        interface ILookAheadEnumerator<'T>
        interface IEnumerator<'T>
        interface IDisposable
        interface IEnumerator
    end
[<SealedAttribute>]
type LookAheadEnumerator<'T> =
    class
        interface ILookAheadEnumerator<'T>
        interface IEnumerator<'T>
        interface IDisposable
        interface IEnumerator
    end
Type Parameters
T
See Also
LookAheadEnumerator T Members
NFX.Collections Namespace


LookAheadEnumerator(T) Members

LookAheadEnumerator T Members NFX Class Library

The LookAheadEnumerator T type exposes the following members.
Constructors
 | Name | Description
Public method | LookAheadEnumerator T | Initializes a new instance of the LookAheadEnumerator T class
Back to Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the LookAheadEnumerator T
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MoveNext |
Public method | Reset |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Current |
Public property | HasNext |
Public property | Next |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerator Current |
Back to Top
See Also
LookAheadEnumerator T Class
NFX.Collections Namespace


LookAheadEnumerator(T) Constructor

LookAheadEnumerator T Constructor NFX Class Library

Initializes a new instance of the LookAheadEnumerator T class

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LookAheadEnumerator(
    IEnumerator<T> enumerator
)
public LookAheadEnumerator(
    IEnumerator<T> enumerator
)
Public Sub New (
    enumerator As IEnumerator(Of T)
)
Public Sub New (
    enumerator As IEnumerator(Of T)
)
public:
LookAheadEnumerator(
    IEnumerator<T>^ enumerator
)
public:
LookAheadEnumerator(
    IEnumerator<T>^ enumerator
)
new :
        enumerator : IEnumerator<'T> -> LookAheadEnumerator
new :
        enumerator : IEnumerator<'T> -> LookAheadEnumerator

Parameters

enumerator
Type: Online System.Collections.Generic IEnumerator T
See Also
LookAheadEnumerator T Class
LookAheadEnumerator T Members
NFX.Collections Namespace


LookAheadEnumerator(T) Methods

LookAheadEnumerator T Methods NFX Class Library

The LookAheadEnumerator T type exposes the following members.
Methods
 | Name | Description
Public method | Dispose |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MoveNext |
Public method | Reset |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LookAheadEnumerator T Class
NFX.Collections Namespace


LookAheadEnumerator(T).Dispose Method

LookAheadEnumerator T Dispose Method NFX Class Library

Releases all resources used by the LookAheadEnumerator T

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

Online IDisposable Dispose
See Also
LookAheadEnumerator T Class
LookAheadEnumerator T Members
NFX.Collections Namespace


LookAheadEnumerator(T).MoveNext Method

LookAheadEnumerator T MoveNext Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool MoveNext()
public bool MoveNext()
Public Function MoveNext As Boolean
Public Function MoveNext As Boolean
public:
virtual bool MoveNext() sealed
public:
virtual bool MoveNext() sealed
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Type: Online Boolean

Implements

Online IEnumerator MoveNext
See Also
LookAheadEnumerator T Class
LookAheadEnumerator T Members
NFX.Collections Namespace


LookAheadEnumerator(T).Reset Method

LookAheadEnumerator T Reset Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Reset()
public void Reset()
Public Sub Reset
Public Sub Reset
public:
virtual void Reset() sealed
public:
virtual void Reset() sealed
abstract Reset : unit -> unit
override Reset : unit -> unit
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

Online IEnumerator Reset
See Also
LookAheadEnumerator T Class
LookAheadEnumerator T Members
NFX.Collections Namespace


LookAheadEnumerator(T) Properties

LookAheadEnumerator T Properties NFX Class Library

The LookAheadEnumerator T type exposes the following members.
Properties
 | Name | Description
Public property | Current |
Public property | HasNext |
Public property | Next |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerator Current |
Back to Top
See Also
LookAheadEnumerator T Class
NFX.Collections Namespace


LookAheadEnumerator(T).IEnumerator.Current Property

LookAheadEnumerator T IEnumerator Current Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object IEnumerator.Current { get; }
Object IEnumerator.Current { get; }
Private ReadOnly Property Current As Object
    Implements IEnumerator.Current
    Get
Private ReadOnly Property Current As Object
    Implements IEnumerator.Current
    Get
private:
virtual property Object^ Current {
    Object^ get () sealed = IEnumerator::Current::get;
}
private:
virtual property Object^ Current {
    Object^ get () sealed = IEnumerator::Current::get;
}
private abstract Current : Object with get
private override Current : Object with get
private abstract Current : Object with get
private override Current : Object with get

Property Value

Type: Online Object

Implements

Online IEnumerator Current
See Also
LookAheadEnumerator T Class
LookAheadEnumerator T Members
NFX.Collections Namespace


LookAheadEnumerator(T).Current Property

LookAheadEnumerator T Current Property NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T Current { get; }
public T Current { get; }
Public ReadOnly Property Current As T
    Get
Public ReadOnly Property Current As T
    Get
public:
virtual property T Current {
    T get () sealed;
}
public:
virtual property T Current {
    T get () sealed;
}
abstract Current : 'T with get
override Current : 'T with get
abstract Current : 'T with get
override Current : 'T with get

Property Value

Type: T

Implements

Online IEnumerator T Current
See Also
LookAheadEnumerator T Class
LookAheadEnumerator T Members
NFX.Collections Namespace


LookAheadEnumerator(T).HasNext Property

LookAheadEnumerator T HasNext Property NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasNext { get; }
public bool HasNext { get; }
Public ReadOnly Property HasNext As Boolean
    Get
Public ReadOnly Property HasNext As Boolean
    Get
public:
virtual property bool HasNext {
    bool get () sealed;
}
public:
virtual property bool HasNext {
    bool get () sealed;
}
abstract HasNext : bool with get
override HasNext : bool with get
abstract HasNext : bool with get
override HasNext : bool with get

Property Value

Type: Online Boolean

Implements

ILookAheadEnumerator T HasNext
See Also
LookAheadEnumerator T Class
LookAheadEnumerator T Members
NFX.Collections Namespace


LookAheadEnumerator(T).Next Property

LookAheadEnumerator T Next Property NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T Next { get; }
public T Next { get; }
Public ReadOnly Property Next As T
    Get
Public ReadOnly Property Next As T
    Get
public:
virtual property T Next {
    T get () sealed;
}
public:
virtual property T Next {
    T get () sealed;
}
abstract Next : 'T with get
override Next : 'T with get
abstract Next : 'T with get
override Next : 'T with get

Property Value

Type: T

Implements

ILookAheadEnumerator T Next
See Also
LookAheadEnumerator T Class
LookAheadEnumerator T Members
NFX.Collections Namespace


LookAheadExtensions Class

LookAheadExtensions Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Collections LookAheadExtensions

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class LookAheadExtensions
public static class LookAheadExtensions
<ExtensionAttribute>
Public NotInheritable Class LookAheadExtensions
<ExtensionAttribute>
Public NotInheritable Class LookAheadExtensions
[ExtensionAttribute]
public ref class LookAheadExtensions abstract sealed
[ExtensionAttribute]
public ref class LookAheadExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type LookAheadExtensions =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type LookAheadExtensions =  class end
See Also
LookAheadExtensions Members
NFX.Collections Namespace


LookAheadExtensions Members

LookAheadExtensions Members NFX Class Library

The LookAheadExtensions type exposes the following members.
Methods
Name | Description
AsLookAheadEnumerable T |
Back to Top
See Also
LookAheadExtensions Class
NFX.Collections Namespace


LookAheadExtensions Methods

LookAheadExtensions Methods NFX Class Library

The LookAheadExtensions type exposes the following members.
Methods
Name | Description
AsLookAheadEnumerable T |
Back to Top
See Also
LookAheadExtensions Class
NFX.Collections Namespace


LookAheadExtensions.AsLookAheadEnumerable(T) Method

LookAheadExtensions AsLookAheadEnumerable T Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ILookAheadEnumerable<T> AsLookAheadEnumerable<T>(
    this IEnumerable<T> enumerable
)
public static ILookAheadEnumerable<T> AsLookAheadEnumerable<T>(
    this IEnumerable<T> enumerable
)
<ExtensionAttribute>
Public Shared Function AsLookAheadEnumerable(Of T) (
    enumerable As IEnumerable(Of T)
) As ILookAheadEnumerable(Of T)
<ExtensionAttribute>
Public Shared Function AsLookAheadEnumerable(Of T) (
    enumerable As IEnumerable(Of T)
) As ILookAheadEnumerable(Of T)
public:
[ExtensionAttribute]
generic<typename T>
static ILookAheadEnumerable<T>^ AsLookAheadEnumerable(
    IEnumerable<T>^ enumerable
)
public:
[ExtensionAttribute]
generic<typename T>
static ILookAheadEnumerable<T>^ AsLookAheadEnumerable(
    IEnumerable<T>^ enumerable
)
static member AsLookAheadEnumerable :
        enumerable : IEnumerable<'T> -> ILookAheadEnumerable<'T>
static member AsLookAheadEnumerable :
        enumerable : IEnumerable<'T> -> ILookAheadEnumerable<'T>

Parameters

enumerable
Type: Online System.Collections.Generic IEnumerable T
Type Parameters
T

Return Value

Type: ILookAheadEnumerable T

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online IEnumerable T . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
LookAheadExtensions Class
LookAheadExtensions Members
NFX.Collections Namespace


Matrix2D(T) Class

Matrix2D T Class NFX Class Library

Represents a two deminsional matrix of T. This class uses jagged arrays for internal implementation ensuring proper array sizing per matrix structure
Inheritance Hierarchy
Online System Object
NFX.Collections MatrixBase T
NFX.Collections Matrix2DBase T
NFX.Collections Matrix2D T
NFX.Media.TagCodes.QR QRMatrix

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Matrix2D<T> : Matrix2DBase<T>
public class Matrix2D<T> : Matrix2DBase<T>
Public Class Matrix2D(Of T)
    Inherits Matrix2DBase(Of T)
Public Class Matrix2D(Of T)
    Inherits Matrix2DBase(Of T)
generic<typename T>
public ref class Matrix2D : public Matrix2DBase<T>
generic<typename T>
public ref class Matrix2D : public Matrix2DBase<T>
type Matrix2D<'T> =
    class
        inherit Matrix2DBase<'T>
    end
type Matrix2D<'T> =
    class
        inherit Matrix2DBase<'T>
    end
Type Parameters
T
Any desired type
See Also
Matrix2D T Members
NFX.Collections Namespace


Matrix2D(T) Members

Matrix2D T Members NFX Class Library

The Matrix2D T type exposes the following members.
Constructors
 | Name | Description
Public method | Matrix2D T | Initializes a new instance of the Matrix2D T class
Back to Top
Methods
 | Name | Description
Public method | Equals(Object) | (Inherited from MatrixBase T .)
Public method | Equals(MatrixBase T ) | (Inherited from MatrixBase T .)
Public method | Fill |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | (Inherited from MatrixBase T .)
Public method | GetHashCode | (Inherited from MatrixBase T .)
Public method | GetLowerBound | (Inherited from Matrix2DBase T .)
Public method | GetMatrixEnumerator | (Inherited from Matrix2DBase T .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetUpperBound | (Inherited from Matrix2DBase T .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from Matrix2DBase T .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Array |
Public field | Height | (Inherited from Matrix2DBase T .)
Public field | Width | (Inherited from Matrix2DBase T .)
Back to Top
Properties
 | Name | Description
Public property | Item | (Overrides Matrix2DBase T Item Int32, Int32 .)
Public property | Rank | (Inherited from Matrix2DBase T .)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from MatrixBase T .)
Back to Top
See Also
Matrix2D T Class
NFX.Collections Namespace


Matrix2D(T) Constructor

Matrix2D T Constructor NFX Class Library

Initializes a new instance of the Matrix2D T class

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Matrix2D(
    int width,
    int height
)
public Matrix2D(
    int width,
    int height
)
Public Sub New (
    width As Integer,
    height As Integer
)
Public Sub New (
    width As Integer,
    height As Integer
)
public:
Matrix2D(
    int width,
    int height
)
public:
Matrix2D(
    int width,
    int height
)
new :
        width : int *
        height : int -> Matrix2D
new :
        width : int *
        height : int -> Matrix2D

Parameters

width
Type: Online System Int32
height
Type: Online System Int32
See Also
Matrix2D T Class
Matrix2D T Members
NFX.Collections Namespace


Matrix2D(T) Fields

Matrix2D T Fields NFX Class Library

The Matrix2D T type exposes the following members.
Fields
 | Name | Description
Public field | Array |
Public field | Height | (Inherited from Matrix2DBase T .)
Public field | Width | (Inherited from Matrix2DBase T .)
Back to Top
See Also
Matrix2D T Class
NFX.Collections Namespace


Matrix2D(T).Array Field

Matrix2D T Array Field NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly T[][] Array
public readonly T[][] Array
Public ReadOnly Array As T()()
Public ReadOnly Array As T()()
public:
initonly array<array<T>^>^ Array
public:
initonly array<array<T>^>^ Array
val Array: 'T[][]
val Array: 'T[][]

Field Value

Type: T
See Also
Matrix2D T Class
Matrix2D T Members
NFX.Collections Namespace


Matrix2D(T) Methods

Matrix2D T Methods NFX Class Library

The Matrix2D T type exposes the following members.
Methods
 | Name | Description
Public method | Equals(Object) | (Inherited from MatrixBase T .)
Public method | Equals(MatrixBase T ) | (Inherited from MatrixBase T .)
Public method | Fill |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | (Inherited from MatrixBase T .)
Public method | GetHashCode | (Inherited from MatrixBase T .)
Public method | GetLowerBound | (Inherited from Matrix2DBase T .)
Public method | GetMatrixEnumerator | (Inherited from Matrix2DBase T .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetUpperBound | (Inherited from Matrix2DBase T .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from Matrix2DBase T .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from MatrixBase T .)
Back to Top
See Also
Matrix2D T Class
NFX.Collections Namespace


Matrix2D(T).Fill Method

Matrix2D T Fill Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Fill(
    T value
)
public void Fill(
    T value
)
Public Sub Fill (
    value As T
)
Public Sub Fill (
    value As T
)
public:
void Fill(
    T value
)
public:
void Fill(
    T value
)
member Fill :
        value : 'T -> unit
member Fill :
        value : 'T -> unit

Parameters

value
Type: T
See Also
Matrix2D T Class
Matrix2D T Members
NFX.Collections Namespace


Matrix2D(T) Properties

Matrix2D T Properties NFX Class Library

The Matrix2D T type exposes the following members.
Properties
 | Name | Description
Public property | Item | (Overrides Matrix2DBase T Item Int32, Int32 .)
Public property | Rank | (Inherited from Matrix2DBase T .)
Back to Top
See Also
Matrix2D T Class
NFX.Collections Namespace


Matrix2D(T).Item Property

Matrix2D T Item Property NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override T this[
    int x,
    int y
] { get; set; }
public override T this[
    int x,
    int y
] { get; set; }
Public Overrides Default Property Item (
    x As Integer,
    y As Integer
) As T
    Get
    Set
Public Overrides Default Property Item (
    x As Integer,
    y As Integer
) As T
    Get
    Set
public:
virtual property T default[int x, int y] {
    T get (int x, int y) override;
    void set (int x, int y, T value) override;
}
public:
virtual property T default[int x, int y] {
    T get (int x, int y) override;
    void set (int x, int y, T value) override;
}
abstract Item : 'T with get, set
override Item : 'T with get, set
abstract Item : 'T with get, set
override Item : 'T with get, set

Parameters

x
Type: Online System Int32
y
Type: Online System Int32

Property Value

Type: T
See Also
Matrix2D T Class
Matrix2D T Members
NFX.Collections Namespace


Matrix2DBase(T) Class

Matrix2DBase T Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Collections MatrixBase T
NFX.Collections Matrix2DBase T
NFX.Collections BitMatrix2D
NFX.Collections Matrix2D T

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Matrix2DBase<T> : MatrixBase<T>
public abstract class Matrix2DBase<T> : MatrixBase<T>
Public MustInherit Class Matrix2DBase(Of T)
    Inherits MatrixBase(Of T)
Public MustInherit Class Matrix2DBase(Of T)
    Inherits MatrixBase(Of T)
generic<typename T>
public ref class Matrix2DBase abstract : public MatrixBase<T>
generic<typename T>
public ref class Matrix2DBase abstract : public MatrixBase<T>
[<AbstractClassAttribute>]
type Matrix2DBase<'T> =
    class
        inherit MatrixBase<'T>
    end
[<AbstractClassAttribute>]
type Matrix2DBase<'T> =
    class
        inherit MatrixBase<'T>
    end
Type Parameters
T
See Also
Matrix2DBase T Members
NFX.Collections Namespace


Matrix2DBase(T) Members

Matrix2DBase T Members NFX Class Library

The Matrix2DBase T type exposes the following members.
Constructors
 | Name | Description
Public method | Matrix2DBase T | Initializes a new instance of the Matrix2DBase T class
Back to Top
Methods
 | Name | Description
Public method | Equals(Object) | (Inherited from MatrixBase T .)
Public method | Equals(MatrixBase T ) | (Inherited from MatrixBase T .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | (Inherited from MatrixBase T .)
Public method | GetHashCode | (Inherited from MatrixBase T .)
Public method | GetLowerBound | (Overrides MatrixBase T GetLowerBound(Int32).)
Public method | GetMatrixEnumerator | (Overrides MatrixBase T GetMatrixEnumerator .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetUpperBound | (Overrides MatrixBase T GetUpperBound(Int32).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides MatrixBase T ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Height |
Public field | Width |
Back to Top
Properties
 | Name | Description
Public property | Item |
Public property | Rank | (Overrides MatrixBase T Rank.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from MatrixBase T .)
Back to Top
See Also
Matrix2DBase T Class
NFX.Collections Namespace


Matrix2DBase(T) Constructor

Matrix2DBase T Constructor NFX Class Library

Initializes a new instance of the Matrix2DBase T class

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Matrix2DBase(
    int width,
    int height
)
public Matrix2DBase(
    int width,
    int height
)
Public Sub New (
    width As Integer,
    height As Integer
)
Public Sub New (
    width As Integer,
    height As Integer
)
public:
Matrix2DBase(
    int width,
    int height
)
public:
Matrix2DBase(
    int width,
    int height
)
new :
        width : int *
        height : int -> Matrix2DBase
new :
        width : int *
        height : int -> Matrix2DBase

Parameters

width
Type: Online System Int32
height
Type: Online System Int32
See Also
Matrix2DBase T Class
Matrix2DBase T Members
NFX.Collections Namespace


Matrix2DBase(T) Fields

Matrix2DBase T Fields NFX Class Library

The Matrix2DBase T type exposes the following members.
Fields
 | Name | Description
Public field | Height |
Public field | Width |
Back to Top
See Also
Matrix2DBase T Class
NFX.Collections Namespace


Matrix2DBase(T).Height Field

Matrix2DBase T Height Field NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Height
public readonly int Height
Public ReadOnly Height As Integer
Public ReadOnly Height As Integer
public:
initonly int Height
public:
initonly int Height
val Height: int
val Height: int

Field Value

Type: Online Int32
See Also
Matrix2DBase T Class
Matrix2DBase T Members
NFX.Collections Namespace


Matrix2DBase(T).Width Field

Matrix2DBase T Width Field NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Width
public readonly int Width
Public ReadOnly Width As Integer
Public ReadOnly Width As Integer
public:
initonly int Width
public:
initonly int Width
val Width: int
val Width: int

Field Value

Type: Online Int32
See Also
Matrix2DBase T Class
Matrix2DBase T Members
NFX.Collections Namespace


Matrix2DBase(T) Methods

Matrix2DBase T Methods NFX Class Library

The Matrix2DBase T type exposes the following members.
Methods
 | Name | Description
Public method | Equals(Object) | (Inherited from MatrixBase T .)
Public method | Equals(MatrixBase T ) | (Inherited from MatrixBase T .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | (Inherited from MatrixBase T .)
Public method | GetHashCode | (Inherited from MatrixBase T .)
Public method | GetLowerBound | (Overrides MatrixBase T GetLowerBound(Int32).)
Public method | GetMatrixEnumerator | (Overrides MatrixBase T GetMatrixEnumerator .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetUpperBound | (Overrides MatrixBase T GetUpperBound(Int32).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides MatrixBase T ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from MatrixBase T .)
Back to Top
See Also
Matrix2DBase T Class
NFX.Collections Namespace


Matrix2DBase(T).GetLowerBound Method

Matrix2DBase T GetLowerBound Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetLowerBound(
    int dimension
)
public override int GetLowerBound(
    int dimension
)
Public Overrides Function GetLowerBound (
    dimension As Integer
) As Integer
Public Overrides Function GetLowerBound (
    dimension As Integer
) As Integer
public:
virtual int GetLowerBound(
    int dimension
) override
public:
virtual int GetLowerBound(
    int dimension
) override
abstract GetLowerBound :
        dimension : int -> int
override GetLowerBound :
        dimension : int -> int
abstract GetLowerBound :
        dimension : int -> int
override GetLowerBound :
        dimension : int -> int

Parameters

dimension
Type: Online System Int32

Return Value

Type: Online Int32
See Also
Matrix2DBase T Class
Matrix2DBase T Members
NFX.Collections Namespace


Matrix2DBase(T).GetMatrixEnumerator Method

Matrix2DBase T GetMatrixEnumerator Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IEnumerator<T> GetMatrixEnumerator()
public override IEnumerator<T> GetMatrixEnumerator()
Public Overrides Function GetMatrixEnumerator As IEnumerator(Of T)
Public Overrides Function GetMatrixEnumerator As IEnumerator(Of T)
public:
virtual IEnumerator<T>^ GetMatrixEnumerator() override
public:
virtual IEnumerator<T>^ GetMatrixEnumerator() override
abstract GetMatrixEnumerator : unit -> IEnumerator<'T>
override GetMatrixEnumerator : unit -> IEnumerator<'T>
abstract GetMatrixEnumerator : unit -> IEnumerator<'T>
override GetMatrixEnumerator : unit -> IEnumerator<'T>

Return Value

Type: Online IEnumerator T
See Also
Matrix2DBase T Class
Matrix2DBase T Members
NFX.Collections Namespace


Matrix2DBase(T).GetUpperBound Method

Matrix2DBase T GetUpperBound Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetUpperBound(
    int dimension
)
public override int GetUpperBound(
    int dimension
)
Public Overrides Function GetUpperBound (
    dimension As Integer
) As Integer
Public Overrides Function GetUpperBound (
    dimension As Integer
) As Integer
public:
virtual int GetUpperBound(
    int dimension
) override
public:
virtual int GetUpperBound(
    int dimension
) override
abstract GetUpperBound :
        dimension : int -> int
override GetUpperBound :
        dimension : int -> int
abstract GetUpperBound :
        dimension : int -> int
override GetUpperBound :
        dimension : int -> int

Parameters

dimension
Type: Online System Int32

Return Value

Type: Online Int32
See Also
Matrix2DBase T Class
Matrix2DBase T Members
NFX.Collections Namespace


Matrix2DBase(T).ToString Method

Matrix2DBase T ToString Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
Matrix2DBase T Class
Matrix2DBase T Members
NFX.Collections Namespace


Matrix2DBase(T) Properties

Matrix2DBase T Properties NFX Class Library

The Matrix2DBase T type exposes the following members.
Properties
 | Name | Description
Public property | Item |
Public property | Rank | (Overrides MatrixBase T Rank.)
Back to Top
See Also
Matrix2DBase T Class
NFX.Collections Namespace


Matrix2DBase(T).Item Property

Matrix2DBase T Item Property NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract T this[
    int x,
    int y
] { get; set; }
public abstract T this[
    int x,
    int y
] { get; set; }
Public MustOverride Default Property Item (
    x As Integer,
    y As Integer
) As T
    Get
    Set
Public MustOverride Default Property Item (
    x As Integer,
    y As Integer
) As T
    Get
    Set
public:
virtual property T default[int x, int y] {
    T get (int x, int y) abstract;
    void set (int x, int y, T value) abstract;
}
public:
virtual property T default[int x, int y] {
    T get (int x, int y) abstract;
    void set (int x, int y, T value) abstract;
}
abstract Item : 'T with get, set
abstract Item : 'T with get, set

Parameters

x
Type: Online System Int32
y
Type: Online System Int32

Property Value

Type: T
See Also
Matrix2DBase T Class
Matrix2DBase T Members
NFX.Collections Namespace


Matrix2DBase(T).Rank Property

Matrix2DBase T Rank Property NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Rank { get; }
public override int Rank { get; }
Public Overrides ReadOnly Property Rank As Integer
    Get
Public Overrides ReadOnly Property Rank As Integer
    Get
public:
virtual property int Rank {
    int get () override;
}
public:
virtual property int Rank {
    int get () override;
}
abstract Rank : int with get
override Rank : int with get
abstract Rank : int with get
override Rank : int with get

Property Value

Type: Online Int32
See Also
Matrix2DBase T Class
Matrix2DBase T Members
NFX.Collections Namespace


MatrixBase(T) Class

MatrixBase T Class NFX Class Library

Provides base for various matrices
Inheritance Hierarchy
Online System Object
NFX.Collections MatrixBase T
NFX.Collections Matrix2DBase T

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class MatrixBase<T> : IEnumerable<T>,
    IEnumerable, IEquatable<MatrixBase<T>>
public abstract class MatrixBase<T> : IEnumerable<T>,
    IEnumerable, IEquatable<MatrixBase<T>>
Public MustInherit Class MatrixBase(Of T)
    Implements IEnumerable(Of T), IEnumerable, IEquatable(Of MatrixBase(Of T))
Public MustInherit Class MatrixBase(Of T)
    Implements IEnumerable(Of T), IEnumerable, IEquatable(Of MatrixBase(Of T))
generic<typename T>
public ref class MatrixBase abstract : IEnumerable<T>,
    IEnumerable, IEquatable<MatrixBase<T>^>
generic<typename T>
public ref class MatrixBase abstract : IEnumerable<T>,
    IEnumerable, IEquatable<MatrixBase<T>^>
[<AbstractClassAttribute>]
type MatrixBase<'T> =
    class
        interface IEnumerable<'T>
        interface IEnumerable
        interface IEquatable<MatrixBase<'T>>
    end
[<AbstractClassAttribute>]
type MatrixBase<'T> =
    class
        interface IEnumerable<'T>
        interface IEnumerable
        interface IEquatable<MatrixBase<'T>>
    end
Type Parameters
T
See Also
MatrixBase T Members
NFX.Collections Namespace


MatrixBase(T) Members

MatrixBase T Members NFX Class Library

The MatrixBase T type exposes the following members.
Constructors
 | Name | Description
Protected method | MatrixBase T | Initializes a new instance of the MatrixBase T class
Back to Top
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online Object Equals(Object).)
Public method | Equals(MatrixBase T ) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | GetLowerBound |
Public method | GetMatrixEnumerator |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetUpperBound |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable T | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct T, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault T | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast T | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast T (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Rank |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
MatrixBase T Class
NFX.Collections Namespace


MatrixBase(T) Constructor

MatrixBase T Constructor NFX Class Library

Initializes a new instance of the MatrixBase T class

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MatrixBase()
protected MatrixBase()
Protected Sub New
Protected Sub New
protected:
MatrixBase()
protected:
MatrixBase()
new : unit -> MatrixBase
new : unit -> MatrixBase
See Also
MatrixBase T Class
MatrixBase T Members
NFX.Collections Namespace


MatrixBase(T) Methods

MatrixBase T Methods NFX Class Library

The MatrixBase T type exposes the following members.
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online Object Equals(Object).)
Public method | Equals(MatrixBase T ) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | GetLowerBound |
Public method | GetMatrixEnumerator |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetUpperBound |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable T | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct T, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin T, TComparand (Func T, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault T | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach T (Action T, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast T | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast T (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
MatrixBase T Class
NFX.Collections Namespace


MatrixBase(T).IEnumerable.GetEnumerator Method

MatrixBase T IEnumerable GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
MatrixBase T Class
MatrixBase T Members
NFX.Collections Namespace


MatrixBase(T).Equals Method

MatrixBase T Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides Online Object Equals(Object).)
Public method | Equals(MatrixBase T ) |
Back to Top
See Also
MatrixBase T Class
MatrixBase T Members
NFX.Collections Namespace


MatrixBase(T).Equals Method (Object)

MatrixBase T Equals Method (Object) NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
MatrixBase T Class
MatrixBase T Members
Equals Overload
NFX.Collections Namespace


MatrixBase(T).Equals Method (MatrixBase(T))

MatrixBase T Equals Method (MatrixBase T ) NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    MatrixBase<T> other
)
public bool Equals(
    MatrixBase<T> other
)
Public Function Equals (
    other As MatrixBase(Of T)
) As Boolean
Public Function Equals (
    other As MatrixBase(Of T)
) As Boolean
public:
virtual bool Equals(
    MatrixBase<T>^ other
) sealed
public:
virtual bool Equals(
    MatrixBase<T>^ other
) sealed
abstract Equals :
        other : MatrixBase<'T> -> bool
override Equals :
        other : MatrixBase<'T> -> bool
abstract Equals :
        other : MatrixBase<'T> -> bool
override Equals :
        other : MatrixBase<'T> -> bool

Parameters

other
Type: NFX.Collections MatrixBase T

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
MatrixBase T Class
MatrixBase T Members
Equals Overload
NFX.Collections Namespace


MatrixBase(T).GetEnumerator Method

MatrixBase T GetEnumerator Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<T> GetEnumerator()
public IEnumerator<T> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of T)
Public Function GetEnumerator As IEnumerator(Of T)
public:
virtual IEnumerator<T>^ GetEnumerator() sealed
public:
virtual IEnumerator<T>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<'T>
override GetEnumerator : unit -> IEnumerator<'T>
abstract GetEnumerator : unit -> IEnumerator<'T>
override GetEnumerator : unit -> IEnumerator<'T>

Return Value

Type: Online IEnumerator T

Implements

Online IEnumerable T GetEnumerator
See Also
MatrixBase T Class
MatrixBase T Members
NFX.Collections Namespace


MatrixBase(T).GetHashCode Method

MatrixBase T GetHashCode Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
MatrixBase T Class
MatrixBase T Members
NFX.Collections Namespace


MatrixBase(T).GetLowerBound Method

MatrixBase T GetLowerBound Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int GetLowerBound(
    int dimension
)
public abstract int GetLowerBound(
    int dimension
)
Public MustOverride Function GetLowerBound (
    dimension As Integer
) As Integer
Public MustOverride Function GetLowerBound (
    dimension As Integer
) As Integer
public:
virtual int GetLowerBound(
    int dimension
) abstract
public:
virtual int GetLowerBound(
    int dimension
) abstract
abstract GetLowerBound :
        dimension : int -> int
abstract GetLowerBound :
        dimension : int -> int

Parameters

dimension
Type: Online System Int32

Return Value

Type: Online Int32
See Also
MatrixBase T Class
MatrixBase T Members
NFX.Collections Namespace


MatrixBase(T).GetMatrixEnumerator Method

MatrixBase T GetMatrixEnumerator Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract IEnumerator<T> GetMatrixEnumerator()
public abstract IEnumerator<T> GetMatrixEnumerator()
Public MustOverride Function GetMatrixEnumerator As IEnumerator(Of T)
Public MustOverride Function GetMatrixEnumerator As IEnumerator(Of T)
public:
virtual IEnumerator<T>^ GetMatrixEnumerator() abstract
public:
virtual IEnumerator<T>^ GetMatrixEnumerator() abstract
abstract GetMatrixEnumerator : unit -> IEnumerator<'T>
abstract GetMatrixEnumerator : unit -> IEnumerator<'T>

Return Value

Type: Online IEnumerator T
See Also
MatrixBase T Class
MatrixBase T Members
NFX.Collections Namespace


MatrixBase(T).GetUpperBound Method

MatrixBase T GetUpperBound Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int GetUpperBound(
    int dimension
)
public abstract int GetUpperBound(
    int dimension
)
Public MustOverride Function GetUpperBound (
    dimension As Integer
) As Integer
Public MustOverride Function GetUpperBound (
    dimension As Integer
) As Integer
public:
virtual int GetUpperBound(
    int dimension
) abstract
public:
virtual int GetUpperBound(
    int dimension
) abstract
abstract GetUpperBound :
        dimension : int -> int
abstract GetUpperBound :
        dimension : int -> int

Parameters

dimension
Type: Online System Int32

Return Value

Type: Online Int32
See Also
MatrixBase T Class
MatrixBase T Members
NFX.Collections Namespace


MatrixBase(T).ToString Method

MatrixBase T ToString Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
MatrixBase T Class
MatrixBase T Members
NFX.Collections Namespace


MatrixBase(T) Properties

MatrixBase T Properties NFX Class Library

The MatrixBase T type exposes the following members.
Properties
 | Name | Description
Public property | Rank |
Back to Top
See Also
MatrixBase T Class
NFX.Collections Namespace


MatrixBase(T).Rank Property

MatrixBase T Rank Property NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int Rank { get; }
public abstract int Rank { get; }
Public MustOverride ReadOnly Property Rank As Integer
    Get
Public MustOverride ReadOnly Property Rank As Integer
    Get
public:
virtual property int Rank {
    int get () abstract;
}
public:
virtual property int Rank {
    int get () abstract;
}
abstract Rank : int with get
abstract Rank : int with get

Property Value

Type: Online Int32
See Also
MatrixBase T Class
MatrixBase T Members
NFX.Collections Namespace


NamedInterlocked Class

NamedInterlocked Class NFX Class Library

Provides functionality similar to the Interlocked class executed over a named slot. All operations are THREAD-SAFE for calling concurrently. The name comparison is that of Registry's which is OrdinalIgnoreCase. This class was designed to better organize named counters incremented from different threads, i.e. this is needed to keep a count of calls to remote host identified by their names. This class is NOT designed for frequent additions/deletions of named slots, nor was it designed to keep millions of slots. Use it in cases when there are thousands at most slots and new slots appear infrequently. You must delete un-needed slots
Inheritance Hierarchy
Online System Object
NFX.Collections NamedInterlocked
NFX.Collections NamedInterlocked TContext

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NamedInterlocked
public class NamedInterlocked
Public Class NamedInterlocked
Public Class NamedInterlocked
public ref class NamedInterlocked
public ref class NamedInterlocked
type NamedInterlocked =  class end
type NamedInterlocked =  class end
See Also
NamedInterlocked Members
NFX.Collections Namespace


NamedInterlocked Members

NamedInterlocked Members NFX Class Library

The NamedInterlocked type exposes the following members.
Constructors
 | Name | Description
Public method | NamedInterlocked | Initializes a new instance of the NamedInterlocked class
Back to Top
Methods
 | Name | Description
Public method | Add(Amount) |
Public method | Add(NamedInterlocked, Nullable Int64 ) | Adds slot snapshot from another source. Pass exchange to flip the existing slots to the exchanged value
Public method | AddLong |
Public method | Clear | Deletes all state for all slots
Public method | Clear(String) | Deletes all state for the named slot returning true if the slot was found and removed
Public method | DecrementLong |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExchangeLong | Captures the current value of a named long value and atomically sets it to the passed value
Public method | Exists | Returns true when the instance contains the named slot
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IncrementLong |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReadAtomicLong | Returns a 64-bit value, loaded as an atomic operation even on a 32bit platform
Public method | SnapshotAllAmounts | Enumerates all named amounts. This operation is thread-safe, and returns a snapshot of the instance taken at the time of the first call If exchange is specified, atomicaly flips the value of every slot
Public method | SnapshotAllLongs | Enumerates all named integers. This operation is thread-safe, and returns a snapshot of the instance taken at the time of the first call. If exchange is specified, atomicaly flips the value of every slot
Public method | SnapshotAllLongsInto TDatum | Records a snapshot of all longs converted into TDatum. The TDatum must have a public .ctor(string, long) or runtime exception is thrown (this is because C# does not have a contract/constraint for parameterized cosntructors)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | VolatileReadLong | Captures the current value of a named long value. If slot does not exist, creates it and captures the value (which may be non-zero even if the slot was just created)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | AllNames | Enumerates all slot names. This operation is thread-safe, and returns a snapshot of the instance taken at the time of the first call
Public property | Count | Returns the current number of named slots in the instance
Back to Top
See Also
NamedInterlocked Class
NFX.Collections Namespace


NamedInterlocked Constructor

NamedInterlocked Constructor NFX Class Library

Initializes a new instance of the NamedInterlocked class

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NamedInterlocked()
public NamedInterlocked()
Public Sub New
Public Sub New
public:
NamedInterlocked()
public:
NamedInterlocked()
new : unit -> NamedInterlocked
new : unit -> NamedInterlocked
See Also
NamedInterlocked Class
NamedInterlocked Members
NFX.Collections Namespace


NamedInterlocked Methods

NamedInterlocked Methods NFX Class Library

The NamedInterlocked type exposes the following members.
Methods
 | Name | Description
Public method | Add(Amount) |
Public method | Add(NamedInterlocked, Nullable Int64 ) | Adds slot snapshot from another source. Pass exchange to flip the existing slots to the exchanged value
Public method | AddLong |
Public method | Clear | Deletes all state for all slots
Public method | Clear(String) | Deletes all state for the named slot returning true if the slot was found and removed
Public method | DecrementLong |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExchangeLong | Captures the current value of a named long value and atomically sets it to the passed value
Public method | Exists | Returns true when the instance contains the named slot
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IncrementLong |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReadAtomicLong | Returns a 64-bit value, loaded as an atomic operation even on a 32bit platform
Public method | SnapshotAllAmounts | Enumerates all named amounts. This operation is thread-safe, and returns a snapshot of the instance taken at the time of the first call If exchange is specified, atomicaly flips the value of every slot
Public method | SnapshotAllLongs | Enumerates all named integers. This operation is thread-safe, and returns a snapshot of the instance taken at the time of the first call. If exchange is specified, atomicaly flips the value of every slot
Public method | SnapshotAllLongsInto TDatum | Records a snapshot of all longs converted into TDatum. The TDatum must have a public .ctor(string, long) or runtime exception is thrown (this is because C# does not have a contract/constraint for parameterized cosntructors)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | VolatileReadLong | Captures the current value of a named long value. If slot does not exist, creates it and captures the value (which may be non-zero even if the slot was just created)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NamedInterlocked Class
NFX.Collections Namespace


NamedInterlocked.Add Method

NamedInterlocked Add Method NFX Class Library

Overload List
 | Name | Description
Public method | Add(Amount) |
Public method | Add(NamedInterlocked, Nullable Int64 ) | Adds slot snapshot from another source. Pass exchange to flip the existing slots to the exchanged value
Back to Top
See Also
NamedInterlocked Class
NamedInterlocked Members
NFX.Collections Namespace


NamedInterlocked.Add Method (Amount)

NamedInterlocked Add Method (Amount) NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Amount Add(
    Amount arg
)
public Amount Add(
    Amount arg
)
Public Function Add (
    arg As Amount
) As Amount
Public Function Add (
    arg As Amount
) As Amount
public:
Amount Add(
    Amount arg
)
public:
Amount Add(
    Amount arg
)
member Add :
        arg : Amount -> Amount
member Add :
        arg : Amount -> Amount

Parameters

arg
Type: NFX.Financial Amount

Return Value

Type: Amount
See Also
NamedInterlocked Class
NamedInterlocked Members
Add Overload
NFX.Collections Namespace


NamedInterlocked.Add Method (NamedInterlocked, Nullable(Int64))

NamedInterlocked Add Method (NamedInterlocked, Nullable Int64 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Adds slot snapshot from another source. Pass exchange to flip the existing slots to the exchanged value

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    NamedInterlocked source,
    Nullable<long> exchangeSource = null
)
public void Add(
    NamedInterlocked source,
    Nullable<long> exchangeSource = null
)
Public Sub Add (
    source As NamedInterlocked,
    Optional exchangeSource As Nullable(Of Long) = Nothing
)
Public Sub Add (
    source As NamedInterlocked,
    Optional exchangeSource As Nullable(Of Long) = Nothing
)
public:
void Add(
    NamedInterlocked^ source,
    Nullable<long long> exchangeSource = nullptr
)
public:
void Add(
    NamedInterlocked^ source,
    Nullable<long long> exchangeSource = nullptr
)
member Add :
        source : NamedInterlocked *
        ?exchangeSource : Nullable<int64>
(* Defaults:
        let _exchangeSource = defaultArg exchangeSource null
*)
-> unit
member Add :
        source : NamedInterlocked *
        ?exchangeSource : Nullable<int64>
(* Defaults:
        let _exchangeSource = defaultArg exchangeSource null
*)
-> unit

Parameters

source
Type: NFX.Collections NamedInterlocked
exchangeSource (Optional)
Type: Online System Nullable Online Int64
See Also
NamedInterlocked Class
NamedInterlocked Members
Add Overload
NFX.Collections Namespace


NamedInterlocked.AddLong Method

NamedInterlocked AddLong Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long AddLong(
    string name,
    long arg
)
public long AddLong(
    string name,
    long arg
)
Public Function AddLong (
    name As String,
    arg As Long
) As Long
Public Function AddLong (
    name As String,
    arg As Long
) As Long
public:
long long AddLong(
    String^ name,
    long long arg
)
public:
long long AddLong(
    String^ name,
    long long arg
)
member AddLong :
        name : string *
        arg : int64 -> int64
member AddLong :
        name : string *
        arg : int64 -> int64

Parameters

name
Type: Online System String
arg
Type: Online System Int64

Return Value

Type: Online Int64
See Also
NamedInterlocked Class
NamedInterlocked Members
NFX.Collections Namespace


NamedInterlocked.Clear Method

NamedInterlocked Clear Method NFX Class Library

Overload List
 | Name | Description
Public method | Clear | Deletes all state for all slots
Public method | Clear(String) | Deletes all state for the named slot returning true if the slot was found and removed
Back to Top
See Also
NamedInterlocked Class
NamedInterlocked Members
NFX.Collections Namespace


NamedInterlocked.Clear Method

NamedInterlocked Clear Method NFX Class Library

Deletes all state for all slots

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
void Clear()
public:
void Clear()
member Clear : unit -> unit
member Clear : unit -> unit
See Also
NamedInterlocked Class
NamedInterlocked Members
Clear Overload
NFX.Collections Namespace


NamedInterlocked.Clear Method (String)

NamedInterlocked Clear Method (String) NFX Class Library

Deletes all state for the named slot returning true if the slot was found and removed

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Clear(
    string name
)
public bool Clear(
    string name
)
Public Function Clear (
    name As String
) As Boolean
Public Function Clear (
    name As String
) As Boolean
public:
bool Clear(
    String^ name
)
public:
bool Clear(
    String^ name
)
member Clear :
        name : string -> bool
member Clear :
        name : string -> bool

Parameters

name
Type: Online System String

Return Value

Type: Online Boolean
See Also
NamedInterlocked Class
NamedInterlocked Members
Clear Overload
NFX.Collections Namespace


NamedInterlocked.DecrementLong Method

NamedInterlocked DecrementLong Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long DecrementLong(
    string name
)
public long DecrementLong(
    string name
)
Public Function DecrementLong (
    name As String
) As Long
Public Function DecrementLong (
    name As String
) As Long
public:
long long DecrementLong(
    String^ name
)
public:
long long DecrementLong(
    String^ name
)
member DecrementLong :
        name : string -> int64
member DecrementLong :
        name : string -> int64

Parameters

name
Type: Online System String

Return Value

Type: Online Int64
See Also
NamedInterlocked Class
NamedInterlocked Members
NFX.Collections Namespace


NamedInterlocked.ExchangeLong Method

NamedInterlocked ExchangeLong Method NFX Class Library

Captures the current value of a named long value and atomically sets it to the passed value

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long ExchangeLong(
    string name,
    long value
)
public long ExchangeLong(
    string name,
    long value
)
Public Function ExchangeLong (
    name As String,
    value As Long
) As Long
Public Function ExchangeLong (
    name As String,
    value As Long
) As Long
public:
long long ExchangeLong(
    String^ name,
    long long value
)
public:
long long ExchangeLong(
    String^ name,
    long long value
)
member ExchangeLong :
        name : string *
        value : int64 -> int64
member ExchangeLong :
        name : string *
        value : int64 -> int64

Parameters

name
Type: Online System String
value
Type: Online System Int64

Return Value

Type: Online Int64
See Also
NamedInterlocked Class
NamedInterlocked Members
NFX.Collections Namespace


NamedInterlocked.Exists Method

NamedInterlocked Exists Method NFX Class Library

Returns true when the instance contains the named slot

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Exists(
    string name
)
public bool Exists(
    string name
)
Public Function Exists (
    name As String
) As Boolean
Public Function Exists (
    name As String
) As Boolean
public:
bool Exists(
    String^ name
)
public:
bool Exists(
    String^ name
)
member Exists :
        name : string -> bool
member Exists :
        name : string -> bool

Parameters

name
Type: Online System String

Return Value

Type: Online Boolean
See Also
NamedInterlocked Class
NamedInterlocked Members
NFX.Collections Namespace


NamedInterlocked.IncrementLong Method

NamedInterlocked IncrementLong Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long IncrementLong(
    string name
)
public long IncrementLong(
    string name
)
Public Function IncrementLong (
    name As String
) As Long
Public Function IncrementLong (
    name As String
) As Long
public:
long long IncrementLong(
    String^ name
)
public:
long long IncrementLong(
    String^ name
)
member IncrementLong :
        name : string -> int64
member IncrementLong :
        name : string -> int64

Parameters

name
Type: Online System String

Return Value

Type: Online Int64
See Also
NamedInterlocked Class
NamedInterlocked Members
NFX.Collections Namespace


NamedInterlocked.ReadAtomicLong Method

NamedInterlocked ReadAtomicLong Method NFX Class Library

Returns a 64-bit value, loaded as an atomic operation even on a 32bit platform

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long ReadAtomicLong(
    string name
)
public long ReadAtomicLong(
    string name
)
Public Function ReadAtomicLong (
    name As String
) As Long
Public Function ReadAtomicLong (
    name As String
) As Long
public:
long long ReadAtomicLong(
    String^ name
)
public:
long long ReadAtomicLong(
    String^ name
)
member ReadAtomicLong :
        name : string -> int64
member ReadAtomicLong :
        name : string -> int64

Parameters

name
Type: Online System String

Return Value

Type: Online Int64
See Also
NamedInterlocked Class
NamedInterlocked Members
NFX.Collections Namespace


NamedInterlocked.SnapshotAllAmounts Method

NamedInterlocked SnapshotAllAmounts Method NFX Class Library

Enumerates all named amounts. This operation is thread-safe, and returns a snapshot of the instance taken at the time of the first call If exchange is specified, atomicaly flips the value of every slot

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<KeyValuePair<string, Amount>> SnapshotAllAmounts(
    Nullable<decimal> exchange = null
)
public IEnumerable<KeyValuePair<string, Amount>> SnapshotAllAmounts(
    Nullable<decimal> exchange = null
)
Public Function SnapshotAllAmounts (
    Optional exchange As Nullable(Of Decimal) = Nothing
) As IEnumerable(Of KeyValuePair(Of String, Amount))
Public Function SnapshotAllAmounts (
    Optional exchange As Nullable(Of Decimal) = Nothing
) As IEnumerable(Of KeyValuePair(Of String, Amount))
public:
IEnumerable<KeyValuePair<String^, Amount>>^ SnapshotAllAmounts(
    Nullable<Decimal> exchange = nullptr
)
public:
IEnumerable<KeyValuePair<String^, Amount>>^ SnapshotAllAmounts(
    Nullable<Decimal> exchange = nullptr
)
member SnapshotAllAmounts :
        ?exchange : Nullable<decimal>
(* Defaults:
        let _exchange = defaultArg exchange null
*)
-> IEnumerable<KeyValuePair<string, Amount>>
member SnapshotAllAmounts :
        ?exchange : Nullable<decimal>
(* Defaults:
        let _exchange = defaultArg exchange null
*)
-> IEnumerable<KeyValuePair<string, Amount>>

Parameters

exchange (Optional)
Type: Online System Nullable Online Decimal

Return Value

Type: Online IEnumerable Online KeyValuePair Online String, Amount
See Also
NamedInterlocked Class
NamedInterlocked Members
NFX.Collections Namespace


NamedInterlocked.SnapshotAllLongs Method

NamedInterlocked SnapshotAllLongs Method NFX Class Library

Enumerates all named integers. This operation is thread-safe, and returns a snapshot of the instance taken at the time of the first call. If exchange is specified, atomicaly flips the value of every slot

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<KeyValuePair<string, long>> SnapshotAllLongs(
    Nullable<long> exchange = null
)
public IEnumerable<KeyValuePair<string, long>> SnapshotAllLongs(
    Nullable<long> exchange = null
)
Public Function SnapshotAllLongs (
    Optional exchange As Nullable(Of Long) = Nothing
) As IEnumerable(Of KeyValuePair(Of String, Long))
Public Function SnapshotAllLongs (
    Optional exchange As Nullable(Of Long) = Nothing
) As IEnumerable(Of KeyValuePair(Of String, Long))
public:
IEnumerable<KeyValuePair<String^, long long>>^ SnapshotAllLongs(
    Nullable<long long> exchange = nullptr
)
public:
IEnumerable<KeyValuePair<String^, long long>>^ SnapshotAllLongs(
    Nullable<long long> exchange = nullptr
)
member SnapshotAllLongs :
        ?exchange : Nullable<int64>
(* Defaults:
        let _exchange = defaultArg exchange null
*)
-> IEnumerable<KeyValuePair<string, int64>>
member SnapshotAllLongs :
        ?exchange : Nullable<int64>
(* Defaults:
        let _exchange = defaultArg exchange null
*)
-> IEnumerable<KeyValuePair<string, int64>>

Parameters

exchange (Optional)
Type: Online System Nullable Online Int64

Return Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Int64
See Also
NamedInterlocked Class
NamedInterlocked Members
NFX.Collections Namespace


NamedInterlocked.SnapshotAllLongsInto(TDatum) Method

NamedInterlocked SnapshotAllLongsInto TDatum Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Records a snapshot of all longs converted into TDatum. The TDatum must have a public .ctor(string, long) or runtime exception is thrown (this is because C# does not have a contract/constraint for parameterized cosntructors)

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SnapshotAllLongsInto<TDatum>(
    Nullable<long> exchange = null,
    IInstrumentation instrumentation = null
)
where TDatum : Datum
public void SnapshotAllLongsInto<TDatum>(
    Nullable<long> exchange = null,
    IInstrumentation instrumentation = null
)
where TDatum : Datum
Public Sub SnapshotAllLongsInto(Of TDatum As Datum) (
    Optional exchange As Nullable(Of Long) = Nothing,
    Optional instrumentation As IInstrumentation = Nothing
)
Public Sub SnapshotAllLongsInto(Of TDatum As Datum) (
    Optional exchange As Nullable(Of Long) = Nothing,
    Optional instrumentation As IInstrumentation = Nothing
)
public:
generic<typename TDatum>
where TDatum : Datum
void SnapshotAllLongsInto(
    Nullable<long long> exchange = nullptr,
    IInstrumentation^ instrumentation = nullptr
)
public:
generic<typename TDatum>
where TDatum : Datum
void SnapshotAllLongsInto(
    Nullable<long long> exchange = nullptr,
    IInstrumentation^ instrumentation = nullptr
)
member SnapshotAllLongsInto :
        ?exchange : Nullable<int64> *
        ?instrumentation : IInstrumentation
(* Defaults:
        let _exchange = defaultArg exchange null
        let _instrumentation = defaultArg instrumentation null
*)
-> unit  when 'TDatum : Datum
member SnapshotAllLongsInto :
        ?exchange : Nullable<int64> *
        ?instrumentation : IInstrumentation
(* Defaults:
        let _exchange = defaultArg exchange null
        let _instrumentation = defaultArg instrumentation null
*)
-> unit  when 'TDatum : Datum

Parameters

exchange (Optional)
Type: Online System Nullable Online Int64
instrumentation (Optional)
Type: NFX.Instrumentation IInstrumentation
Type Parameters
TDatum
See Also
NamedInterlocked Class
NamedInterlocked Members
NFX.Collections Namespace


NamedInterlocked.VolatileReadLong Method

NamedInterlocked VolatileReadLong Method NFX Class Library

Captures the current value of a named long value. If slot does not exist, creates it and captures the value (which may be non-zero even if the slot was just created)

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long VolatileReadLong(
    string name
)
public long VolatileReadLong(
    string name
)
Public Function VolatileReadLong (
    name As String
) As Long
Public Function VolatileReadLong (
    name As String
) As Long
public:
long long VolatileReadLong(
    String^ name
)
public:
long long VolatileReadLong(
    String^ name
)
member VolatileReadLong :
        name : string -> int64
member VolatileReadLong :
        name : string -> int64

Parameters

name
Type: Online System String

Return Value

Type: Online Int64
See Also
NamedInterlocked Class
NamedInterlocked Members
NFX.Collections Namespace


NamedInterlocked Properties

NamedInterlocked Properties NFX Class Library

The NamedInterlocked type exposes the following members.
Properties
 | Name | Description
Public property | AllNames | Enumerates all slot names. This operation is thread-safe, and returns a snapshot of the instance taken at the time of the first call
Public property | Count | Returns the current number of named slots in the instance
Back to Top
See Also
NamedInterlocked Class
NFX.Collections Namespace


NamedInterlocked.AllNames Property

NamedInterlocked AllNames Property NFX Class Library

Enumerates all slot names. This operation is thread-safe, and returns a snapshot of the instance taken at the time of the first call

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<string> AllNames { get; }
public IEnumerable<string> AllNames { get; }
Public ReadOnly Property AllNames As IEnumerable(Of String)
    Get
Public ReadOnly Property AllNames As IEnumerable(Of String)
    Get
public:
property IEnumerable<String^>^ AllNames {
    IEnumerable<String^>^ get ();
}
public:
property IEnumerable<String^>^ AllNames {
    IEnumerable<String^>^ get ();
}
member AllNames : IEnumerable<string> with get
member AllNames : IEnumerable<string> with get

Property Value

Type: Online IEnumerable Online String
See Also
NamedInterlocked Class
NamedInterlocked Members
NFX.Collections Namespace


NamedInterlocked.Count Property

NamedInterlocked Count Property NFX Class Library

Returns the current number of named slots in the instance

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
public:
property int Count {
    int get ();
}
member Count : int with get
member Count : int with get

Property Value

Type: Online Int32
See Also
NamedInterlocked Class
NamedInterlocked Members
NFX.Collections Namespace


NamedInterlocked(TContext) Class

NamedInterlocked TContext Class NFX Class Library

Adds context to NamedInterlocked
Inheritance Hierarchy
Online System Object
NFX.Collections NamedInterlocked
NFX.Collections NamedInterlocked TContext

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NamedInterlocked<TContext> : NamedInterlocked
public class NamedInterlocked<TContext> : NamedInterlocked
Public Class NamedInterlocked(Of TContext)
    Inherits NamedInterlocked
Public Class NamedInterlocked(Of TContext)
    Inherits NamedInterlocked
generic<typename TContext>
public ref class NamedInterlocked : public NamedInterlocked
generic<typename TContext>
public ref class NamedInterlocked : public NamedInterlocked
type NamedInterlocked<'TContext> =
    class
        inherit NamedInterlocked
    end
type NamedInterlocked<'TContext> =
    class
        inherit NamedInterlocked
    end
Type Parameters
TContext
See Also
NamedInterlocked TContext Members
NFX.Collections Namespace


NamedInterlocked(TContext) Members

NamedInterlocked TContext Members NFX Class Library

The NamedInterlocked TContext type exposes the following members.
Constructors
 | Name | Description
Public method | NamedInterlocked TContext | Initializes a new instance of the NamedInterlocked TContext class
Back to Top
Methods
 | Name | Description
Public method | Add(Amount) | (Inherited from NamedInterlocked.)
Public method | Add(NamedInterlocked, Nullable Int64 ) | Adds slot snapshot from another source. Pass exchange to flip the existing slots to the exchanged value (Inherited from NamedInterlocked.)
Public method | AddLong | (Inherited from NamedInterlocked.)
Public method | Clear | Deletes all state for all slots (Inherited from NamedInterlocked.)
Public method | Clear(String) | Deletes all state for the named slot returning true if the slot was found and removed (Inherited from NamedInterlocked.)
Public method | DecrementLong | (Inherited from NamedInterlocked.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExchangeLong | Captures the current value of a named long value and atomically sets it to the passed value (Inherited from NamedInterlocked.)
Public method | Exists | Returns true when the instance contains the named slot (Inherited from NamedInterlocked.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IncrementLong | (Inherited from NamedInterlocked.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReadAtomicLong | Returns a 64-bit value, loaded as an atomic operation even on a 32bit platform (Inherited from NamedInterlocked.)
Public method | SnapshotAllAmounts | Enumerates all named amounts. This operation is thread-safe, and returns a snapshot of the instance taken at the time of the first call If exchange is specified, atomicaly flips the value of every slot (Inherited from NamedInterlocked.)
Public method | SnapshotAllLongs | Enumerates all named integers. This operation is thread-safe, and returns a snapshot of the instance taken at the time of the first call. If exchange is specified, atomicaly flips the value of every slot (Inherited from NamedInterlocked.)
Public method | SnapshotAllLongsInto TDatum | Records a snapshot of all longs converted into TDatum. The TDatum must have a public .ctor(string, long) or runtime exception is thrown (this is because C# does not have a contract/constraint for parameterized cosntructors) (Inherited from NamedInterlocked.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | VolatileReadLong | Captures the current value of a named long value. If slot does not exist, creates it and captures the value (which may be non-zero even if the slot was just created) (Inherited from NamedInterlocked.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | AllNames | Enumerates all slot names. This operation is thread-safe, and returns a snapshot of the instance taken at the time of the first call (Inherited from NamedInterlocked.)
Public property | Context |
Public property | Count | Returns the current number of named slots in the instance (Inherited from NamedInterlocked.)
Back to Top
See Also
NamedInterlocked TContext Class
NFX.Collections Namespace


NamedInterlocked(TContext) Constructor

NamedInterlocked TContext Constructor NFX Class Library

Initializes a new instance of the NamedInterlocked TContext class

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NamedInterlocked()
public NamedInterlocked()
Public Sub New
Public Sub New
public:
NamedInterlocked()
public:
NamedInterlocked()
new : unit -> NamedInterlocked
new : unit -> NamedInterlocked
See Also
NamedInterlocked TContext Class
NamedInterlocked TContext Members
NFX.Collections Namespace


NamedInterlocked(TContext) Methods

NamedInterlocked TContext Methods NFX Class Library

The NamedInterlocked TContext type exposes the following members.
Methods
 | Name | Description
Public method | Add(Amount) | (Inherited from NamedInterlocked.)
Public method | Add(NamedInterlocked, Nullable Int64 ) | Adds slot snapshot from another source. Pass exchange to flip the existing slots to the exchanged value (Inherited from NamedInterlocked.)
Public method | AddLong | (Inherited from NamedInterlocked.)
Public method | Clear | Deletes all state for all slots (Inherited from NamedInterlocked.)
Public method | Clear(String) | Deletes all state for the named slot returning true if the slot was found and removed (Inherited from NamedInterlocked.)
Public method | DecrementLong | (Inherited from NamedInterlocked.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExchangeLong | Captures the current value of a named long value and atomically sets it to the passed value (Inherited from NamedInterlocked.)
Public method | Exists | Returns true when the instance contains the named slot (Inherited from NamedInterlocked.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IncrementLong | (Inherited from NamedInterlocked.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReadAtomicLong | Returns a 64-bit value, loaded as an atomic operation even on a 32bit platform (Inherited from NamedInterlocked.)
Public method | SnapshotAllAmounts | Enumerates all named amounts. This operation is thread-safe, and returns a snapshot of the instance taken at the time of the first call If exchange is specified, atomicaly flips the value of every slot (Inherited from NamedInterlocked.)
Public method | SnapshotAllLongs | Enumerates all named integers. This operation is thread-safe, and returns a snapshot of the instance taken at the time of the first call. If exchange is specified, atomicaly flips the value of every slot (Inherited from NamedInterlocked.)
Public method | SnapshotAllLongsInto TDatum | Records a snapshot of all longs converted into TDatum. The TDatum must have a public .ctor(string, long) or runtime exception is thrown (this is because C# does not have a contract/constraint for parameterized cosntructors) (Inherited from NamedInterlocked.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | VolatileReadLong | Captures the current value of a named long value. If slot does not exist, creates it and captures the value (which may be non-zero even if the slot was just created) (Inherited from NamedInterlocked.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NamedInterlocked TContext Class
NFX.Collections Namespace


NamedInterlocked(TContext) Properties

NamedInterlocked TContext Properties NFX Class Library

The NamedInterlocked TContext type exposes the following members.
Properties
 | Name | Description
Public property | AllNames | Enumerates all slot names. This operation is thread-safe, and returns a snapshot of the instance taken at the time of the first call (Inherited from NamedInterlocked.)
Public property | Context |
Public property | Count | Returns the current number of named slots in the instance (Inherited from NamedInterlocked.)
Back to Top
See Also
NamedInterlocked TContext Class
NFX.Collections Namespace


NamedInterlocked(TContext).Context Property

NamedInterlocked TContext Context Property NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TContext Context { get; set; }
public TContext Context { get; set; }
Public Property Context As TContext
    Get
    Set
Public Property Context As TContext
    Get
    Set
public:
property TContext Context {
    TContext get ();
    void set (TContext value);
}
public:
property TContext Context {
    TContext get ();
    void set (TContext value);
}
member Context : 'TContext with get, set
member Context : 'TContext with get, set

Property Value

Type: TContext
See Also
NamedInterlocked TContext Class
NamedInterlocked TContext Members
NFX.Collections Namespace


StringMap Class

StringMap Class NFX Class Library

Efficeintly maps string -> string for serialization. Compared to Dictionary[string,string] this class yields 20%-50% better Slim serialization speed improvement and 5%-10% space improvement
Inheritance Hierarchy
Online System Object
NFX.Collections StringMap

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class StringMap : IDictionary<string, string>,
    ICollection<KeyValuePair<string, string>>, IEnumerable<KeyValuePair<string, string>>,
    IEnumerable, IJSONWritable
[SerializableAttribute]
public sealed class StringMap : IDictionary<string, string>,
    ICollection<KeyValuePair<string, string>>, IEnumerable<KeyValuePair<string, string>>,
    IEnumerable, IJSONWritable
<SerializableAttribute>
Public NotInheritable Class StringMap
    Implements IDictionary(Of String, String),
    ICollection(Of KeyValuePair(Of String, String)), IEnumerable(Of KeyValuePair(Of String, String)),
    IEnumerable, IJSONWritable
<SerializableAttribute>
Public NotInheritable Class StringMap
    Implements IDictionary(Of String, String),
    ICollection(Of KeyValuePair(Of String, String)), IEnumerable(Of KeyValuePair(Of String, String)),
    IEnumerable, IJSONWritable
[SerializableAttribute]
public ref class StringMap sealed : IDictionary<String^, String^>,
    ICollection<KeyValuePair<String^, String^>>, IEnumerable<KeyValuePair<String^, String^>>,
    IEnumerable, IJSONWritable
[SerializableAttribute]
public ref class StringMap sealed : IDictionary<String^, String^>,
    ICollection<KeyValuePair<String^, String^>>, IEnumerable<KeyValuePair<String^, String^>>,
    IEnumerable, IJSONWritable
[<SealedAttribute>]
[<SerializableAttribute>]
type StringMap =
    class
        interface IDictionary<string, string>
        interface ICollection<KeyValuePair<string, string>>
        interface IEnumerable<KeyValuePair<string, string>>
        interface IEnumerable
        interface IJSONWritable
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type StringMap =
    class
        interface IDictionary<string, string>
        interface ICollection<KeyValuePair<string, string>>
        interface IEnumerable<KeyValuePair<string, string>>
        interface IEnumerable
        interface IJSONWritable
    end
See Also
StringMap Members
NFX.Collections Namespace


StringMap Members

StringMap Members NFX Class Library

The StringMap type exposes the following members.
Constructors
 | Name | Description
Public method | StringMap(Boolean) | Initializes a new instance of the StringMap class
Protected method | StringMap(Boolean, Dictionary String, String ) | Initializes a new instance of the StringMap class
Back to Top
Methods
 | Name | Description
Public method | Add(KeyValuePair String, String ) |
Public method | Add(String, String) |
Public method | Clear |
Public method | Contains |
Public method | ContainsKey |
Public method | CopyTo |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | MakeDictionary |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove(KeyValuePair String, String ) |
Public method | Remove(String) |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryGetValue |
Public method | WriteAsJSON |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable KeyValuePair String, String | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct KeyValuePair String, String , TKey | (Defined by CollectionUtils.)
Public Extension Method | FilterHeaders | (Defined by S3V4HttpHelpers.)
Public Extension Method | FirstMax KeyValuePair String, String , TComparand (Func KeyValuePair String, String , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair String, String , TComparand (Func KeyValuePair String, String , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair String, String , TComparand (Func KeyValuePair String, String , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair String, String , TComparand (Func KeyValuePair String, String , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault KeyValuePair String, String | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair String, String (Action KeyValuePair String, String ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair String, String (Action KeyValuePair String, String , Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair String, String | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair String, String (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | CaseSensitive |
Public property | Count |
Public property | IsReadOnly |
Public property | Item |
Public property | Keys |
Public property | Values |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
StringMap Class
NFX.Collections Namespace


StringMap Constructor

StringMap Constructor NFX Class Library

Overload List
 | Name | Description
Public method | StringMap(Boolean) | Initializes a new instance of the StringMap class
Protected method | StringMap(Boolean, Dictionary String, String ) | Initializes a new instance of the StringMap class
Back to Top
See Also
StringMap Class
StringMap Members
NFX.Collections Namespace


StringMap Constructor (Boolean)

StringMap Constructor (Boolean) NFX Class Library

Initializes a new instance of the StringMap class

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StringMap(
    bool senseCase = true
)
public StringMap(
    bool senseCase = true
)
Public Sub New (
    Optional senseCase As Boolean = true
)
Public Sub New (
    Optional senseCase As Boolean = true
)
public:
StringMap(
    bool senseCase = true
)
public:
StringMap(
    bool senseCase = true
)
new :
        ?senseCase : bool
(* Defaults:
        let _senseCase = defaultArg senseCase true
*)
-> StringMap
new :
        ?senseCase : bool
(* Defaults:
        let _senseCase = defaultArg senseCase true
*)
-> StringMap

Parameters

senseCase (Optional)
Type: Online System Boolean
See Also
StringMap Class
StringMap Members
StringMap Overload
NFX.Collections Namespace


StringMap Constructor (Boolean, Dictionary(String, String))

StringMap Constructor (Boolean, Dictionary String, String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the StringMap class

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal StringMap(
    bool senseCase,
    Dictionary<string, string> data
)
internal StringMap(
    bool senseCase,
    Dictionary<string, string> data
)
Friend Sub New (
    senseCase As Boolean,
    data As Dictionary(Of String, String)
)
Friend Sub New (
    senseCase As Boolean,
    data As Dictionary(Of String, String)
)
internal:
StringMap(
    bool senseCase,
    Dictionary<String^, String^>^ data
)
internal:
StringMap(
    bool senseCase,
    Dictionary<String^, String^>^ data
)
new :
        senseCase : bool *
        data : Dictionary<string, string> -> StringMap
new :
        senseCase : bool *
        data : Dictionary<string, string> -> StringMap

Parameters

senseCase
Type: Online System Boolean
data
Type: Online System.Collections.Generic Dictionary Online String, Online String
See Also
StringMap Class
StringMap Members
StringMap Overload
NFX.Collections Namespace


StringMap Methods

StringMap Methods NFX Class Library

The StringMap type exposes the following members.
Methods
 | Name | Description
Public method | Add(KeyValuePair String, String ) |
Public method | Add(String, String) |
Public method | Clear |
Public method | Contains |
Public method | ContainsKey |
Public method | CopyTo |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | MakeDictionary |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove(KeyValuePair String, String ) |
Public method | Remove(String) |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryGetValue |
Public method | WriteAsJSON |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable KeyValuePair String, String | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct KeyValuePair String, String , TKey | (Defined by CollectionUtils.)
Public Extension Method | FilterHeaders | (Defined by S3V4HttpHelpers.)
Public Extension Method | FirstMax KeyValuePair String, String , TComparand (Func KeyValuePair String, String , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair String, String , TComparand (Func KeyValuePair String, String , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair String, String , TComparand (Func KeyValuePair String, String , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair String, String , TComparand (Func KeyValuePair String, String , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault KeyValuePair String, String | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair String, String (Action KeyValuePair String, String ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair String, String (Action KeyValuePair String, String , Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair String, String | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair String, String (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
StringMap Class
NFX.Collections Namespace


StringMap.IEnumerable.GetEnumerator Method

StringMap IEnumerable GetEnumerator Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
StringMap Class
StringMap Members
NFX.Collections Namespace


StringMap.Add Method

StringMap Add Method NFX Class Library

Overload List
 | Name | Description
Public method | Add(KeyValuePair String, String ) |
Public method | Add(String, String) |
Back to Top
See Also
StringMap Class
StringMap Members
NFX.Collections Namespace


StringMap.Add Method (KeyValuePair(String, String))

StringMap Add Method (KeyValuePair String, String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    KeyValuePair<string, string> item
)
public void Add(
    KeyValuePair<string, string> item
)
Public Sub Add (
    item As KeyValuePair(Of String, String)
)
Public Sub Add (
    item As KeyValuePair(Of String, String)
)
public:
virtual void Add(
    KeyValuePair<String^, String^> item
) sealed
public:
virtual void Add(
    KeyValuePair<String^, String^> item
) sealed
abstract Add :
        item : KeyValuePair<string, string> -> unit
override Add :
        item : KeyValuePair<string, string> -> unit
abstract Add :
        item : KeyValuePair<string, string> -> unit
override Add :
        item : KeyValuePair<string, string> -> unit

Parameters

item
Type: Online System.Collections.Generic KeyValuePair Online String, Online String

Implements

Online ICollection T Add(T)
See Also
StringMap Class
StringMap Members
Add Overload
NFX.Collections Namespace


StringMap.Add Method (String, String)

StringMap Add Method (String, String) NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    string key,
    string value
)
public void Add(
    string key,
    string value
)
Public Sub Add (
    key As String,
    value As String
)
Public Sub Add (
    key As String,
    value As String
)
public:
virtual void Add(
    String^ key,
    String^ value
) sealed
public:
virtual void Add(
    String^ key,
    String^ value
) sealed
abstract Add :
        key : string *
        value : string -> unit
override Add :
        key : string *
        value : string -> unit
abstract Add :
        key : string *
        value : string -> unit
override Add :
        key : string *
        value : string -> unit

Parameters

key
Type: Online System String
value
Type: Online System String

Implements

Online IDictionary TKey, TValue Add(TKey, TValue)
See Also
StringMap Class
StringMap Members
Add Overload
NFX.Collections Namespace


StringMap.Clear Method

StringMap Clear Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
virtual void Clear() sealed
public:
virtual void Clear() sealed
abstract Clear : unit -> unit
override Clear : unit -> unit
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

Online ICollection T Clear
See Also
StringMap Class
StringMap Members
NFX.Collections Namespace


StringMap.Contains Method

StringMap Contains Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Contains(
    KeyValuePair<string, string> item
)
public bool Contains(
    KeyValuePair<string, string> item
)
Public Function Contains (
    item As KeyValuePair(Of String, String)
) As Boolean
Public Function Contains (
    item As KeyValuePair(Of String, String)
) As Boolean
public:
virtual bool Contains(
    KeyValuePair<String^, String^> item
) sealed
public:
virtual bool Contains(
    KeyValuePair<String^, String^> item
) sealed
abstract Contains :
        item : KeyValuePair<string, string> -> bool
override Contains :
        item : KeyValuePair<string, string> -> bool
abstract Contains :
        item : KeyValuePair<string, string> -> bool
override Contains :
        item : KeyValuePair<string, string> -> bool

Parameters

item
Type: Online System.Collections.Generic KeyValuePair Online String, Online String

Return Value

Type: Online Boolean

Implements

Online ICollection T Contains(T)
See Also
StringMap Class
StringMap Members
NFX.Collections Namespace


StringMap.ContainsKey Method

StringMap ContainsKey Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ContainsKey(
    string key
)
public bool ContainsKey(
    string key
)
Public Function ContainsKey (
    key As String
) As Boolean
Public Function ContainsKey (
    key As String
) As Boolean
public:
virtual bool ContainsKey(
    String^ key
) sealed
public:
virtual bool ContainsKey(
    String^ key
) sealed
abstract ContainsKey :
        key : string -> bool
override ContainsKey :
        key : string -> bool
abstract ContainsKey :
        key : string -> bool
override ContainsKey :
        key : string -> bool

Parameters

key
Type: Online System String

Return Value

Type: Online Boolean

Implements

Online IDictionary TKey, TValue ContainsKey(TKey)
See Also
StringMap Class
StringMap Members
NFX.Collections Namespace


StringMap.CopyTo Method

StringMap CopyTo Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CopyTo(
    KeyValuePair<string, string>[] array,
    int arrayIndex
)
public void CopyTo(
    KeyValuePair<string, string>[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As KeyValuePair(Of String, String)(),
    arrayIndex As Integer
)
Public Sub CopyTo (
    array As KeyValuePair(Of String, String)(),
    arrayIndex As Integer
)
public:
virtual void CopyTo(
    array<KeyValuePair<String^, String^>>^ array,
    int arrayIndex
) sealed
public:
virtual void CopyTo(
    array<KeyValuePair<String^, String^>>^ array,
    int arrayIndex
) sealed
abstract CopyTo :
        array : KeyValuePair<string, string>[] *
        arrayIndex : int -> unit
override CopyTo :
        array : KeyValuePair<string, string>[] *
        arrayIndex : int -> unit
abstract CopyTo :
        array : KeyValuePair<string, string>[] *
        arrayIndex : int -> unit
override CopyTo :
        array : KeyValuePair<string, string>[] *
        arrayIndex : int -> unit

Parameters

array
Type: Online System.Collections.Generic KeyValuePair Online String, Online String
arrayIndex
Type: Online System Int32

Implements

Online ICollection T CopyTo( T , Int32)
See Also
StringMap Class
StringMap Members
NFX.Collections Namespace


StringMap.GetEnumerator Method

StringMap GetEnumerator Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<KeyValuePair<string, string>> GetEnumerator()
public IEnumerator<KeyValuePair<string, string>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of String, String))
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of String, String))
public:
virtual IEnumerator<KeyValuePair<String^, String^>>^ GetEnumerator() sealed
public:
virtual IEnumerator<KeyValuePair<String^, String^>>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<string, string>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<string, string>>
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<string, string>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<string, string>>

Return Value

Type: Online IEnumerator Online KeyValuePair Online String, Online String

Implements

Online IEnumerable T GetEnumerator
See Also
StringMap Class
StringMap Members
NFX.Collections Namespace


StringMap.MakeDictionary Method

StringMap MakeDictionary Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static Dictionary<string, string> MakeDictionary(
    bool senseCase
)
internal static Dictionary<string, string> MakeDictionary(
    bool senseCase
)
Friend Shared Function MakeDictionary (
    senseCase As Boolean
) As Dictionary(Of String, String)
Friend Shared Function MakeDictionary (
    senseCase As Boolean
) As Dictionary(Of String, String)
internal:
static Dictionary<String^, String^>^ MakeDictionary(
    bool senseCase
)
internal:
static Dictionary<String^, String^>^ MakeDictionary(
    bool senseCase
)
internal static member MakeDictionary :
        senseCase : bool -> Dictionary<string, string>
internal static member MakeDictionary :
        senseCase : bool -> Dictionary<string, string>

Parameters

senseCase
Type: Online System Boolean

Return Value

Type: Online Dictionary Online String, Online String
See Also
StringMap Class
StringMap Members
NFX.Collections Namespace


StringMap.Remove Method

StringMap Remove Method NFX Class Library

Overload List
 | Name | Description
Public method | Remove(KeyValuePair String, String ) |
Public method | Remove(String) |
Back to Top
See Also
StringMap Class
StringMap Members
NFX.Collections Namespace


StringMap.Remove Method (KeyValuePair(String, String))

StringMap Remove Method (KeyValuePair String, String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Remove(
    KeyValuePair<string, string> item
)
public bool Remove(
    KeyValuePair<string, string> item
)
Public Function Remove (
    item As KeyValuePair(Of String, String)
) As Boolean
Public Function Remove (
    item As KeyValuePair(Of String, String)
) As Boolean
public:
virtual bool Remove(
    KeyValuePair<String^, String^> item
) sealed
public:
virtual bool Remove(
    KeyValuePair<String^, String^> item
) sealed
abstract Remove :
        item : KeyValuePair<string, string> -> bool
override Remove :
        item : KeyValuePair<string, string> -> bool
abstract Remove :
        item : KeyValuePair<string, string> -> bool
override Remove :
        item : KeyValuePair<string, string> -> bool

Parameters

item
Type: Online System.Collections.Generic KeyValuePair Online String, Online String

Return Value

Type: Online Boolean

Implements

Online ICollection T Remove(T)
See Also
StringMap Class
StringMap Members
Remove Overload
NFX.Collections Namespace


StringMap.Remove Method (String)

StringMap Remove Method (String) NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Remove(
    string key
)
public bool Remove(
    string key
)
Public Function Remove (
    key As String
) As Boolean
Public Function Remove (
    key As String
) As Boolean
public:
virtual bool Remove(
    String^ key
) sealed
public:
virtual bool Remove(
    String^ key
) sealed
abstract Remove :
        key : string -> bool
override Remove :
        key : string -> bool
abstract Remove :
        key : string -> bool
override Remove :
        key : string -> bool

Parameters

key
Type: Online System String

Return Value

Type: Online Boolean

Implements

Online IDictionary TKey, TValue Remove(TKey)
See Also
StringMap Class
StringMap Members
Remove Overload
NFX.Collections Namespace


StringMap.TryGetValue Method

StringMap TryGetValue Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TryGetValue(
    string key,
    out string value
)
public bool TryGetValue(
    string key,
    out string value
)
Public Function TryGetValue (
    key As String,
    <OutAttribute> ByRef value As String
) As Boolean
Public Function TryGetValue (
    key As String,
    <OutAttribute> ByRef value As String
) As Boolean
public:
virtual bool TryGetValue(
    String^ key,
    [OutAttribute] String^% value
) sealed
public:
virtual bool TryGetValue(
    String^ key,
    [OutAttribute] String^% value
) sealed
abstract TryGetValue :
        key : string *
        value : string byref -> bool
override TryGetValue :
        key : string *
        value : string byref -> bool
abstract TryGetValue :
        key : string *
        value : string byref -> bool
override TryGetValue :
        key : string *
        value : string byref -> bool

Parameters

key
Type: Online System String
value
Type: Online System String

Return Value

Type: Online Boolean

Implements

Online IDictionary TKey, TValue TryGetValue(TKey, TValue )
See Also
StringMap Class
StringMap Members
NFX.Collections Namespace


StringMap.WriteAsJSON Method

StringMap WriteAsJSON Method NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
nestingLevel
Type: Online System Int32
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Implements

IJSONWritable WriteAsJSON(TextWriter, Int32, JSONWritingOptions)
See Also
StringMap Class
StringMap Members
NFX.Collections Namespace


StringMap Properties

StringMap Properties NFX Class Library

The StringMap type exposes the following members.
Properties
 | Name | Description
Public property | CaseSensitive |
Public property | Count |
Public property | IsReadOnly |
Public property | Item |
Public property | Keys |
Public property | Values |
Back to Top
See Also
StringMap Class
NFX.Collections Namespace


StringMap.CaseSensitive Property

StringMap CaseSensitive Property NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool CaseSensitive { get; }
public bool CaseSensitive { get; }
Public ReadOnly Property CaseSensitive As Boolean
    Get
Public ReadOnly Property CaseSensitive As Boolean
    Get
public:
property bool CaseSensitive {
    bool get ();
}
public:
property bool CaseSensitive {
    bool get ();
}
member CaseSensitive : bool with get
member CaseSensitive : bool with get

Property Value

Type: Online Boolean
See Also
StringMap Class
StringMap Members
NFX.Collections Namespace


StringMap.Count Property

StringMap Count Property NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
public:
virtual property int Count {
    int get () sealed;
}
abstract Count : int with get
override Count : int with get
abstract Count : int with get
override Count : int with get

Property Value

Type: Online Int32

Implements

Online ICollection T Count
See Also
StringMap Class
StringMap Members
NFX.Collections Namespace


StringMap.IsReadOnly Property

StringMap IsReadOnly Property NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsReadOnly { get; }
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get

Property Value

Type: Online Boolean

Implements

Online ICollection T IsReadOnly
See Also
StringMap Class
StringMap Members
NFX.Collections Namespace


StringMap.Item Property

StringMap Item Property NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string this[
    string key
] { get; set; }
public string this[
    string key
] { get; set; }
Public Default Property Item (
    key As String
) As String
    Get
    Set
Public Default Property Item (
    key As String
) As String
    Get
    Set
public:
virtual property String^ default[String^ key] {
    String^ get (String^ key) sealed;
    void set (String^ key, String^ value) sealed;
}
public:
virtual property String^ default[String^ key] {
    String^ get (String^ key) sealed;
    void set (String^ key, String^ value) sealed;
}
abstract Item : string with get, set
override Item : string with get, set
abstract Item : string with get, set
override Item : string with get, set

Parameters

key
Type: Online System String

Property Value

Type: Online String

Implements

Online IDictionary TKey, TValue Item TKey
See Also
StringMap Class
StringMap Members
NFX.Collections Namespace


StringMap.Keys Property

StringMap Keys Property NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICollection<string> Keys { get; }
public ICollection<string> Keys { get; }
Public ReadOnly Property Keys As ICollection(Of String)
    Get
Public ReadOnly Property Keys As ICollection(Of String)
    Get
public:
virtual property ICollection<String^>^ Keys {
    ICollection<String^>^ get () sealed;
}
public:
virtual property ICollection<String^>^ Keys {
    ICollection<String^>^ get () sealed;
}
abstract Keys : ICollection<string> with get
override Keys : ICollection<string> with get
abstract Keys : ICollection<string> with get
override Keys : ICollection<string> with get

Property Value

Type: Online ICollection Online String

Implements

Online IDictionary TKey, TValue Keys
See Also
StringMap Class
StringMap Members
NFX.Collections Namespace


StringMap.Values Property

StringMap Values Property NFX Class Library

Namespace: NFX.Collections
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICollection<string> Values { get; }
public ICollection<string> Values { get; }
Public ReadOnly Property Values As ICollection(Of String)
    Get
Public ReadOnly Property Values As ICollection(Of String)
    Get
public:
virtual property ICollection<String^>^ Values {
    ICollection<String^>^ get () sealed;
}
public:
virtual property ICollection<String^>^ Values {
    ICollection<String^>^ get () sealed;
}
abstract Values : ICollection<string> with get
override Values : ICollection<string> with get
abstract Values : ICollection<string> with get
override Values : ICollection<string> with get

Property Value

Type: Online ICollection Online String

Implements

Online IDictionary TKey, TValue Values
See Also
StringMap Class
StringMap Members
NFX.Collections Namespace


NFX.DataAccess Namespace

NFX.DataAccess Namespace NFX Class Library

Facilitates data access tasks
Classes
 | Class | Description
Public class | DataAccessException | Thrown by data access classes
Public class | NameValueDataStoreKey | Defines dictionary of string/object pairs used for key matching, where string dictionary key represents column name in storage and value is an object for the key
Public class | NOPDataStore | Represents data store that does not do anything
Structures
 | Structure | Description
Public structure | ConsecutiveUniqueSequenceIDs | Represents a starting ID along with the number of consecutive generated IDs of the sequence
Public structure | CounterDataStoreKey | Represents a key (key field) used in databases that identify entities with BIGINT identity/autoinc columns
Interfaces
 | Interface | Description
Public interface | IDataStore | Represents a store that can save and retrieve data
Public interface | IDataStoreImplementation | Represents a store that can save and retrieve data
Public interface | IDataStoreKey | Decorator interface for entities used to uniquely identify entities in a store
Public interface | IGDIDProvider | Represents an entity that provides unique Global Distributed IDs (GDIDs) via named sequences. Note: GDID.Zero is never returned as it indicates the absence of a value
Public interface | ISequenceInfo | Provides basic information about a named sequence. Warning!!! This class represents informational-only data which CAN NOT be used for real identification
Public interface | IUniqueSequenceProvider | Represents an entity that provides unique identifiers via named sequences
Enumerations
 | Enumeration | Description
Public enumeration | CharCase | Types of char casing
Public enumeration | KeyViolationKind | Specifies the sub-type of key violation
Public enumeration | StoreFlag | Determines whether entity should be loaded/stored from/to storage
Public enumeration | StoreLogLevel | Defines log level for DataStores


CharCase Enumeration

CharCase Enumeration NFX Class Library

Types of char casing

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum CharCase
public enum CharCase
Public Enumeration CharCase
Public Enumeration CharCase
public enum class CharCase
public enum class CharCase
type CharCase
type CharCase
Members
Member name | Value | Description
AsIs | 0 | The string remains as-is
Upper | 1 | The string is converted to upper case
Lower | 2 | The string is converted to lower case
Caps | 3 | The first and subsequent chars after space or '.' are capitalized, the rest left intact
CapsNorm | 4 | The first and subsequent chars after space or '.' are capitalized, the rest is lower-cased
See Also
NFX.DataAccess Namespace


ConsecutiveUniqueSequenceIDs Structure

ConsecutiveUniqueSequenceIDs Structure NFX Class Library

Represents a starting ID along with the number of consecutive generated IDs of the sequence

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct ConsecutiveUniqueSequenceIDs
public struct ConsecutiveUniqueSequenceIDs
Public Structure ConsecutiveUniqueSequenceIDs
Public Structure ConsecutiveUniqueSequenceIDs
public value class ConsecutiveUniqueSequenceIDs
public value class ConsecutiveUniqueSequenceIDs
[<SealedAttribute>]
type ConsecutiveUniqueSequenceIDs =  struct end
[<SealedAttribute>]
type ConsecutiveUniqueSequenceIDs =  struct end
See Also
ConsecutiveUniqueSequenceIDs Members
NFX.DataAccess Namespace


ConsecutiveUniqueSequenceIDs Members

ConsecutiveUniqueSequenceIDs Members NFX Class Library

The ConsecutiveUniqueSequenceIDs type exposes the following members.
Constructors
 | Name | Description
Public method | ConsecutiveUniqueSequenceIDs | Initializes a new instance of the ConsecutiveUniqueSequenceIDs class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Count |
Public field | StartInclusive |
Back to Top
See Also
ConsecutiveUniqueSequenceIDs Structure
NFX.DataAccess Namespace


ConsecutiveUniqueSequenceIDs Constructor

ConsecutiveUniqueSequenceIDs Constructor NFX Class Library

Initializes a new instance of the ConsecutiveUniqueSequenceIDs class

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConsecutiveUniqueSequenceIDs(
    ulong startInclusive,
    int count
)
public ConsecutiveUniqueSequenceIDs(
    ulong startInclusive,
    int count
)
Public Sub New (
    startInclusive As ULong,
    count As Integer
)
Public Sub New (
    startInclusive As ULong,
    count As Integer
)
public:
ConsecutiveUniqueSequenceIDs(
    unsigned long long startInclusive,
    int count
)
public:
ConsecutiveUniqueSequenceIDs(
    unsigned long long startInclusive,
    int count
)
new :
        startInclusive : uint64 *
        count : int -> ConsecutiveUniqueSequenceIDs
new :
        startInclusive : uint64 *
        count : int -> ConsecutiveUniqueSequenceIDs

Parameters

startInclusive
Type: Online System UInt64
count
Type: Online System Int32
See Also
ConsecutiveUniqueSequenceIDs Structure
ConsecutiveUniqueSequenceIDs Members
NFX.DataAccess Namespace


ConsecutiveUniqueSequenceIDs Fields

ConsecutiveUniqueSequenceIDs Fields NFX Class Library

The ConsecutiveUniqueSequenceIDs type exposes the following members.
Fields
 | Name | Description
Public field | Count |
Public field | StartInclusive |
Back to Top
See Also
ConsecutiveUniqueSequenceIDs Structure
NFX.DataAccess Namespace


ConsecutiveUniqueSequenceIDs.Count Field

ConsecutiveUniqueSequenceIDs Count Field NFX Class Library

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Count
public readonly int Count
Public ReadOnly Count As Integer
Public ReadOnly Count As Integer
public:
initonly int Count
public:
initonly int Count
val Count: int
val Count: int

Field Value

Type: Online Int32
See Also
ConsecutiveUniqueSequenceIDs Structure
ConsecutiveUniqueSequenceIDs Members
NFX.DataAccess Namespace


ConsecutiveUniqueSequenceIDs.StartInclusive Field

ConsecutiveUniqueSequenceIDs StartInclusive Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ulong StartInclusive
public readonly ulong StartInclusive
Public ReadOnly StartInclusive As ULong
Public ReadOnly StartInclusive As ULong
public:
initonly unsigned long long StartInclusive
public:
initonly unsigned long long StartInclusive
val StartInclusive: uint64
val StartInclusive: uint64

Field Value

Type: Online UInt64
See Also
ConsecutiveUniqueSequenceIDs Structure
ConsecutiveUniqueSequenceIDs Members
NFX.DataAccess Namespace


ConsecutiveUniqueSequenceIDs Methods

ConsecutiveUniqueSequenceIDs Methods NFX Class Library

The ConsecutiveUniqueSequenceIDs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ConsecutiveUniqueSequenceIDs Structure
NFX.DataAccess Namespace


CounterDataStoreKey Structure

CounterDataStoreKey Structure NFX Class Library

Represents a key (key field) used in databases that identify entities with BIGINT identity/autoinc columns

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public struct CounterDataStoreKey : IDataStoreKey
[SerializableAttribute]
public struct CounterDataStoreKey : IDataStoreKey
<SerializableAttribute>
Public Structure CounterDataStoreKey
    Implements IDataStoreKey
<SerializableAttribute>
Public Structure CounterDataStoreKey
    Implements IDataStoreKey
[SerializableAttribute]
public value class CounterDataStoreKey : IDataStoreKey
[SerializableAttribute]
public value class CounterDataStoreKey : IDataStoreKey
[<SealedAttribute>]
[<SerializableAttribute>]
type CounterDataStoreKey =
    struct
        interface IDataStoreKey
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type CounterDataStoreKey =
    struct
        interface IDataStoreKey
    end
See Also
CounterDataStoreKey Members
NFX.DataAccess Namespace


CounterDataStoreKey Members

CounterDataStoreKey Members NFX Class Library

The CounterDataStoreKey type exposes the following members.
Constructors
 | Name | Description
Public method | CounterDataStoreKey | Initializes a new instance of the CounterDataStoreKey class
Back to Top
Methods
 | Name | Description
Public method | Equals | (Overrides Online ValueType Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Counter |
Back to Top
See Also
CounterDataStoreKey Structure
NFX.DataAccess Namespace


CounterDataStoreKey Constructor

CounterDataStoreKey Constructor NFX Class Library

Initializes a new instance of the CounterDataStoreKey class

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CounterDataStoreKey(
    long value
)
public CounterDataStoreKey(
    long value
)
Public Sub New (
    value As Long
)
Public Sub New (
    value As Long
)
public:
CounterDataStoreKey(
    long long value
)
public:
CounterDataStoreKey(
    long long value
)
new :
        value : int64 -> CounterDataStoreKey
new :
        value : int64 -> CounterDataStoreKey

Parameters

value
Type: Online System Int64
See Also
CounterDataStoreKey Structure
CounterDataStoreKey Members
NFX.DataAccess Namespace


CounterDataStoreKey Fields

CounterDataStoreKey Fields NFX Class Library

The CounterDataStoreKey type exposes the following members.
Fields
 | Name | Description
Public field | Counter |
Back to Top
See Also
CounterDataStoreKey Structure
NFX.DataAccess Namespace


CounterDataStoreKey.Counter Field

CounterDataStoreKey Counter Field NFX Class Library

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly long Counter
public readonly long Counter
Public ReadOnly Counter As Long
Public ReadOnly Counter As Long
public:
initonly long long Counter
public:
initonly long long Counter
val Counter: int64
val Counter: int64

Field Value

Type: Online Int64
See Also
CounterDataStoreKey Structure
CounterDataStoreKey Members
NFX.DataAccess Namespace


CounterDataStoreKey Methods

CounterDataStoreKey Methods NFX Class Library

The CounterDataStoreKey type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online ValueType Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CounterDataStoreKey Structure
NFX.DataAccess Namespace


CounterDataStoreKey.Equals Method

CounterDataStoreKey Equals Method NFX Class Library

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
CounterDataStoreKey Structure
CounterDataStoreKey Members
NFX.DataAccess Namespace


CounterDataStoreKey.GetHashCode Method

CounterDataStoreKey GetHashCode Method NFX Class Library

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
CounterDataStoreKey Structure
CounterDataStoreKey Members
NFX.DataAccess Namespace


CounterDataStoreKey.ToString Method

CounterDataStoreKey ToString Method NFX Class Library

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
CounterDataStoreKey Structure
CounterDataStoreKey Members
NFX.DataAccess Namespace


DataAccessException Class

DataAccessException Class NFX Class Library

Thrown by data access classes
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.DataAccess DataAccessException
NFX.DataAccess.CRUD CRUDException
NFX.DataAccess.Distributed DistributedDataAccessException
NFX.DataAccess.Erlang ErlDataAccessException
NFX.DataAccess.MongoDB MongoDBDataAccessException
NFX.DataAccess.MySQL MySQLDataAccessException

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class DataAccessException : NFXException
[SerializableAttribute]
public class DataAccessException : NFXException
<SerializableAttribute>
Public Class DataAccessException
    Inherits NFXException
<SerializableAttribute>
Public Class DataAccessException
    Inherits NFXException
[SerializableAttribute]
public ref class DataAccessException : public NFXException
[SerializableAttribute]
public ref class DataAccessException : public NFXException
[<SerializableAttribute>]
type DataAccessException =
    class
        inherit NFXException
    end
[<SerializableAttribute>]
type DataAccessException =
    class
        inherit NFXException
    end
See Also
DataAccessException Members
NFX.DataAccess Namespace


DataAccessException Members

DataAccessException Members NFX Class Library

The DataAccessException type exposes the following members.
Constructors
 | Name | Description
Public method | DataAccessException | Initializes a new instance of the DataAccessException class
Public method | DataAccessException(String) | Initializes a new instance of the DataAccessException class
Protected method | DataAccessException(SerializationInfo, StreamingContext) | Initializes a new instance of the DataAccessException class
Public method | DataAccessException(String, Exception) | Initializes a new instance of the DataAccessException class
Public method | DataAccessException(String, KeyViolationKind, String) | Initializes a new instance of the DataAccessException class
Public method | DataAccessException(String, Exception, KeyViolationKind, String) | Initializes a new instance of the DataAccessException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception
Public field | KeyViolationKind | Spcifies the sub-type of key violation
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
DataAccessException Class
NFX.DataAccess Namespace


DataAccessException Constructor

DataAccessException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | DataAccessException | Initializes a new instance of the DataAccessException class
Public method | DataAccessException(String) | Initializes a new instance of the DataAccessException class
Protected method | DataAccessException(SerializationInfo, StreamingContext) | Initializes a new instance of the DataAccessException class
Public method | DataAccessException(String, Exception) | Initializes a new instance of the DataAccessException class
Public method | DataAccessException(String, KeyViolationKind, String) | Initializes a new instance of the DataAccessException class
Public method | DataAccessException(String, Exception, KeyViolationKind, String) | Initializes a new instance of the DataAccessException class
Back to Top
See Also
DataAccessException Class
DataAccessException Members
NFX.DataAccess Namespace


DataAccessException Constructor

DataAccessException Constructor NFX Class Library

Initializes a new instance of the DataAccessException class

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DataAccessException()
public DataAccessException()
Public Sub New
Public Sub New
public:
DataAccessException()
public:
DataAccessException()
new : unit -> DataAccessException
new : unit -> DataAccessException
See Also
DataAccessException Class
DataAccessException Members
DataAccessException Overload
NFX.DataAccess Namespace


DataAccessException Constructor (String)

DataAccessException Constructor (String) NFX Class Library

Initializes a new instance of the DataAccessException class

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DataAccessException(
    string message
)
public DataAccessException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
DataAccessException(
    String^ message
)
public:
DataAccessException(
    String^ message
)
new :
        message : string -> DataAccessException
new :
        message : string -> DataAccessException

Parameters

message
Type: Online System String
See Also
DataAccessException Class
DataAccessException Members
DataAccessException Overload
NFX.DataAccess Namespace


DataAccessException Constructor (SerializationInfo, StreamingContext)

DataAccessException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DataAccessException class

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected DataAccessException(
    SerializationInfo info,
    StreamingContext context
)
protected DataAccessException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
DataAccessException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
DataAccessException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DataAccessException
new :
        info : SerializationInfo *
        context : StreamingContext -> DataAccessException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
DataAccessException Class
DataAccessException Members
DataAccessException Overload
NFX.DataAccess Namespace


DataAccessException Constructor (String, Exception)

DataAccessException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DataAccessException class

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DataAccessException(
    string message,
    Exception inner
)
public DataAccessException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
DataAccessException(
    String^ message,
    Exception^ inner
)
public:
DataAccessException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> DataAccessException
new :
        message : string *
        inner : Exception -> DataAccessException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
DataAccessException Class
DataAccessException Members
DataAccessException Overload
NFX.DataAccess Namespace


DataAccessException Constructor (String, KeyViolationKind, String)

DataAccessException Constructor (String, KeyViolationKind, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DataAccessException class

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DataAccessException(
    string message,
    KeyViolationKind kvKind,
    string keyViolation
)
public DataAccessException(
    string message,
    KeyViolationKind kvKind,
    string keyViolation
)
Public Sub New (
    message As String,
    kvKind As KeyViolationKind,
    keyViolation As String
)
Public Sub New (
    message As String,
    kvKind As KeyViolationKind,
    keyViolation As String
)
public:
DataAccessException(
    String^ message,
    KeyViolationKind kvKind,
    String^ keyViolation
)
public:
DataAccessException(
    String^ message,
    KeyViolationKind kvKind,
    String^ keyViolation
)
new :
        message : string *
        kvKind : KeyViolationKind *
        keyViolation : string -> DataAccessException
new :
        message : string *
        kvKind : KeyViolationKind *
        keyViolation : string -> DataAccessException

Parameters

message
Type: Online System String
kvKind
Type: NFX.DataAccess KeyViolationKind
keyViolation
Type: Online System String
See Also
DataAccessException Class
DataAccessException Members
DataAccessException Overload
NFX.DataAccess Namespace


DataAccessException Constructor (String, Exception, KeyViolationKind, String)

DataAccessException Constructor (String, Exception, KeyViolationKind, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DataAccessException class

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DataAccessException(
    string message,
    Exception inner,
    KeyViolationKind kvKind,
    string keyViolation
)
public DataAccessException(
    string message,
    Exception inner,
    KeyViolationKind kvKind,
    string keyViolation
)
Public Sub New (
    message As String,
    inner As Exception,
    kvKind As KeyViolationKind,
    keyViolation As String
)
Public Sub New (
    message As String,
    inner As Exception,
    kvKind As KeyViolationKind,
    keyViolation As String
)
public:
DataAccessException(
    String^ message,
    Exception^ inner,
    KeyViolationKind kvKind,
    String^ keyViolation
)
public:
DataAccessException(
    String^ message,
    Exception^ inner,
    KeyViolationKind kvKind,
    String^ keyViolation
)
new :
        message : string *
        inner : Exception *
        kvKind : KeyViolationKind *
        keyViolation : string -> DataAccessException
new :
        message : string *
        inner : Exception *
        kvKind : KeyViolationKind *
        keyViolation : string -> DataAccessException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
kvKind
Type: NFX.DataAccess KeyViolationKind
keyViolation
Type: Online System String
See Also
DataAccessException Class
DataAccessException Members
DataAccessException Overload
NFX.DataAccess Namespace


DataAccessException Fields

DataAccessException Fields NFX Class Library

The DataAccessException type exposes the following members.
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception
Public field | KeyViolationKind | Spcifies the sub-type of key violation
Back to Top
See Also
DataAccessException Class
NFX.DataAccess Namespace


DataAccessException.KeyViolation Field

DataAccessException KeyViolation Field NFX Class Library

Provides the name of entity/index/field that was violated and resulted in this exception

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string KeyViolation
public readonly string KeyViolation
Public ReadOnly KeyViolation As String
Public ReadOnly KeyViolation As String
public:
initonly String^ KeyViolation
public:
initonly String^ KeyViolation
val KeyViolation: string
val KeyViolation: string

Field Value

Type: Online String
See Also
DataAccessException Class
DataAccessException Members
NFX.DataAccess Namespace


DataAccessException.KeyViolationKind Field

DataAccessException KeyViolationKind Field NFX Class Library

Spcifies the sub-type of key violation

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly KeyViolationKind KeyViolationKind
public readonly KeyViolationKind KeyViolationKind
Public ReadOnly KeyViolationKind As KeyViolationKind
Public ReadOnly KeyViolationKind As KeyViolationKind
public:
initonly KeyViolationKind KeyViolationKind
public:
initonly KeyViolationKind KeyViolationKind
val KeyViolationKind: KeyViolationKind
val KeyViolationKind: KeyViolationKind

Field Value

Type: KeyViolationKind
See Also
DataAccessException Class
DataAccessException Members
NFX.DataAccess Namespace


DataAccessException Methods

DataAccessException Methods NFX Class Library

The DataAccessException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
DataAccessException Class
NFX.DataAccess Namespace


DataAccessException Properties

DataAccessException Properties NFX Class Library

The DataAccessException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
DataAccessException Class
NFX.DataAccess Namespace


DataAccessException Events

DataAccessException Events NFX Class Library

The DataAccessException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
DataAccessException Class
NFX.DataAccess Namespace


IDataStore Interface

IDataStore Interface NFX Class Library

Represents a store that can save and retrieve data

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IDataStore : IApplicationComponent,
    IDisposable
public interface IDataStore : IApplicationComponent,
    IDisposable
Public Interface IDataStore
    Inherits IApplicationComponent, IDisposable
Public Interface IDataStore
    Inherits IApplicationComponent, IDisposable
public interface class IDataStore : IApplicationComponent,
    IDisposable
public interface class IDataStore : IApplicationComponent,
    IDisposable
type IDataStore =
    interface
        interface IApplicationComponent
        interface IDisposable
    end
type IDataStore =
    interface
        interface IApplicationComponent
        interface IDisposable
    end
See Also
IDataStore Members
NFX.DataAccess Namespace


IDataStore Members

IDataStore Members NFX Class Library

The IDataStore type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | TestConnection | Tests connection and throws an exception if connection could not be established
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | TargetName | Returns the name of the underlying store technology, i.e. "ORACLE". This property is used by some metadata-based validation logic which is target-dependent
Back to Top
See Also
IDataStore Interface
NFX.DataAccess Namespace


IDataStore Methods

IDataStore Methods NFX Class Library

The IDataStore type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | TestConnection | Tests connection and throws an exception if connection could not be established
Back to Top
See Also
IDataStore Interface
NFX.DataAccess Namespace


IDataStore.TestConnection Method

IDataStore TestConnection Method NFX Class Library

Tests connection and throws an exception if connection could not be established

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void TestConnection()
void TestConnection()
Sub TestConnection
Sub TestConnection
void TestConnection()
void TestConnection()
abstract TestConnection : unit -> unit
abstract TestConnection : unit -> unit
See Also
IDataStore Interface
IDataStore Members
NFX.DataAccess Namespace


IDataStore Properties

IDataStore Properties NFX Class Library

The IDataStore type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | TargetName | Returns the name of the underlying store technology, i.e. "ORACLE". This property is used by some metadata-based validation logic which is target-dependent
Back to Top
See Also
IDataStore Interface
NFX.DataAccess Namespace


IDataStore.TargetName Property

IDataStore TargetName Property NFX Class Library

Returns the name of the underlying store technology, i.e. "ORACLE". This property is used by some metadata-based validation logic which is target-dependent

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string TargetName { get; }
string TargetName { get; }
ReadOnly Property TargetName As String
    Get
ReadOnly Property TargetName As String
    Get
property String^ TargetName {
    String^ get ();
}
property String^ TargetName {
    String^ get ();
}
abstract TargetName : string with get
abstract TargetName : string with get

Property Value

Type: Online String
See Also
IDataStore Interface
IDataStore Members
NFX.DataAccess Namespace


IDataStoreImplementation Interface

IDataStoreImplementation Interface NFX Class Library

Represents a store that can save and retrieve data

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IDataStoreImplementation : IDataStore,
    IApplicationComponent, IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
public interface IDataStoreImplementation : IDataStore,
    IApplicationComponent, IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
Public Interface IDataStoreImplementation
    Inherits IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
Public Interface IDataStoreImplementation
    Inherits IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
public interface class IDataStoreImplementation : IDataStore,
    IApplicationComponent, IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
public interface class IDataStoreImplementation : IDataStore,
    IApplicationComponent, IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
type IDataStoreImplementation =
    interface
        interface IDataStore
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
type IDataStoreImplementation =
    interface
        interface IDataStore
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
IDataStoreImplementation Members
NFX.DataAccess Namespace


IDataStoreImplementation Members

IDataStoreImplementation Members NFX Class Library

The IDataStoreImplementation type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Public method | TestConnection | Tests connection and throws an exception if connection could not be established (Inherited from IDataStore.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | LogLevel | Defines log level for data stores
Public property | TargetName | Returns the name of the underlying store technology, i.e. "ORACLE". This property is used by some metadata-based validation logic which is target-dependent (Inherited from IDataStore.)
Back to Top
See Also
IDataStoreImplementation Interface
NFX.DataAccess Namespace


IDataStoreImplementation Methods

IDataStoreImplementation Methods NFX Class Library

The IDataStoreImplementation type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Public method | TestConnection | Tests connection and throws an exception if connection could not be established (Inherited from IDataStore.)
Back to Top
See Also
IDataStoreImplementation Interface
NFX.DataAccess Namespace


IDataStoreImplementation Properties

IDataStoreImplementation Properties NFX Class Library

The IDataStoreImplementation type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | LogLevel | Defines log level for data stores
Public property | TargetName | Returns the name of the underlying store technology, i.e. "ORACLE". This property is used by some metadata-based validation logic which is target-dependent (Inherited from IDataStore.)
Back to Top
See Also
IDataStoreImplementation Interface
NFX.DataAccess Namespace


IDataStoreImplementation.LogLevel Property

IDataStoreImplementation LogLevel Property NFX Class Library

Defines log level for data stores

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
StoreLogLevel LogLevel { get; set; }
StoreLogLevel LogLevel { get; set; }
Property LogLevel As StoreLogLevel
    Get
    Set
Property LogLevel As StoreLogLevel
    Get
    Set
property StoreLogLevel LogLevel {
    StoreLogLevel get ();
    void set (StoreLogLevel value);
}
property StoreLogLevel LogLevel {
    StoreLogLevel get ();
    void set (StoreLogLevel value);
}
abstract LogLevel : StoreLogLevel with get, set
abstract LogLevel : StoreLogLevel with get, set

Property Value

Type: StoreLogLevel
See Also
IDataStoreImplementation Interface
IDataStoreImplementation Members
NFX.DataAccess Namespace


IDataStoreKey Interface

IDataStoreKey Interface NFX Class Library

Decorator interface for entities used to uniquely identify entities in a store

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IDataStoreKey
public interface IDataStoreKey
Public Interface IDataStoreKey
Public Interface IDataStoreKey
public interface class IDataStoreKey
public interface class IDataStoreKey
type IDataStoreKey =  interface end
type IDataStoreKey =  interface end
See Also
NFX.DataAccess Namespace


IGDIDProvider Interface

IGDIDProvider Interface NFX Class Library

Represents an entity that provides unique Global Distributed IDs (GDIDs) via named sequences. Note: GDID.Zero is never returned as it indicates the absence of a value

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IGDIDProvider : IUniqueSequenceProvider,
    INamed
public interface IGDIDProvider : IUniqueSequenceProvider,
    INamed
Public Interface IGDIDProvider
    Inherits IUniqueSequenceProvider, INamed
Public Interface IGDIDProvider
    Inherits IUniqueSequenceProvider, INamed
public interface class IGDIDProvider : IUniqueSequenceProvider,
    INamed
public interface class IGDIDProvider : IUniqueSequenceProvider,
    INamed
type IGDIDProvider =
    interface
        interface IUniqueSequenceProvider
        interface INamed
    end
type IGDIDProvider =
    interface
        interface IUniqueSequenceProvider
        interface INamed
    end
See Also
IGDIDProvider Members
NFX.DataAccess Namespace


IGDIDProvider Members

IGDIDProvider Members NFX Class Library

The IGDIDProvider type exposes the following members.
Methods
 | Name | Description
Public method | GenerateOneGDID | Generates Globally-Unique distributed ID (GDID) for the supplied sequence name. Note: do not confuse with block pre-allocation, which is an internal optimization. Even if 100 IDs are pre-allocated the method returns one unique GDID
Public method | GenerateOneSequenceID | Generates one ID for the supplied sequence name. Note: do not confuse with block pre-allocation, which is an internal optimization. Even if 100 IDs are pre-allocated the method returns one unique ID (Inherited from IUniqueSequenceProvider.)
Public method | GetSequenceInfos | Returns sequnce information enumerable for all sequences in the named scope (Inherited from IUniqueSequenceProvider.)
Public method | TryGenerateManyConsecutiveGDIDs | Tries to generate many consecutive Globally-Unique distributed ID (GDID) from the same authority for the supplied sequence name. If the reserved block gets exhausted, then the returned ID array length may be less than requested
Public method | TryGenerateManyConsecutiveSequenceIDs | Tries to generate many consecutive IDs. If the reserved block gets exhausted, then the returned ID count may be less than requested. (Inherited from IUniqueSequenceProvider.)
Back to Top
Properties
 | Name | Description
Public property | Name | (Inherited from INamed.)
Public property | SequenceScopeNames | Returns the list of all scope names in the instance (Inherited from IUniqueSequenceProvider.)
Public property | TestingAuthorityNode | Gets/sets Authority Glue Node for testing. It can only be set once in the testing app container init before the first call to Generate is made. When this setting is set then any cluster authority nodes which would have been normally used will be completely bypassed during block allocation
Back to Top
See Also
IGDIDProvider Interface
NFX.DataAccess Namespace


IGDIDProvider Methods

IGDIDProvider Methods NFX Class Library

The IGDIDProvider type exposes the following members.
Methods
 | Name | Description
Public method | GenerateOneGDID | Generates Globally-Unique distributed ID (GDID) for the supplied sequence name. Note: do not confuse with block pre-allocation, which is an internal optimization. Even if 100 IDs are pre-allocated the method returns one unique GDID
Public method | GenerateOneSequenceID | Generates one ID for the supplied sequence name. Note: do not confuse with block pre-allocation, which is an internal optimization. Even if 100 IDs are pre-allocated the method returns one unique ID (Inherited from IUniqueSequenceProvider.)
Public method | GetSequenceInfos | Returns sequnce information enumerable for all sequences in the named scope (Inherited from IUniqueSequenceProvider.)
Public method | TryGenerateManyConsecutiveGDIDs | Tries to generate many consecutive Globally-Unique distributed ID (GDID) from the same authority for the supplied sequence name. If the reserved block gets exhausted, then the returned ID array length may be less than requested
Public method | TryGenerateManyConsecutiveSequenceIDs | Tries to generate many consecutive IDs. If the reserved block gets exhausted, then the returned ID count may be less than requested. (Inherited from IUniqueSequenceProvider.)
Back to Top
See Also
IGDIDProvider Interface
NFX.DataAccess Namespace


IGDIDProvider.GenerateOneGDID Method

IGDIDProvider GenerateOneGDID Method NFX Class Library

Generates Globally-Unique distributed ID (GDID) for the supplied sequence name. Note: do not confuse with block pre-allocation, which is an internal optimization. Even if 100 IDs are pre-allocated the method returns one unique GDID

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GDID GenerateOneGDID(
    string scopeName,
    string sequenceName,
    int blockSize = 0,
    Nullable<ulong> vicinity = 1152921504606846975,
    bool noLWM = false
)
GDID GenerateOneGDID(
    string scopeName,
    string sequenceName,
    int blockSize = 0,
    Nullable<ulong> vicinity = 1152921504606846975,
    bool noLWM = false
)
Function GenerateOneGDID (
    scopeName As String,
    sequenceName As String,
    Optional blockSize As Integer = 0,
    Optional vicinity As Nullable(Of ULong) = 1152921504606846975,
    Optional noLWM As Boolean = false
) As GDID
Function GenerateOneGDID (
    scopeName As String,
    sequenceName As String,
    Optional blockSize As Integer = 0,
    Optional vicinity As Nullable(Of ULong) = 1152921504606846975,
    Optional noLWM As Boolean = false
) As GDID
GDID GenerateOneGDID(
    String^ scopeName,
    String^ sequenceName,
    int blockSize = 0,
    Nullable<unsigned long long> vicinity = 1152921504606846975,
    bool noLWM = false
)
GDID GenerateOneGDID(
    String^ scopeName,
    String^ sequenceName,
    int blockSize = 0,
    Nullable<unsigned long long> vicinity = 1152921504606846975,
    bool noLWM = false
)
abstract GenerateOneGDID :
        scopeName : string *
        sequenceName : string *
        ?blockSize : int *
        ?vicinity : Nullable<uint64> *
        ?noLWM : bool
(* Defaults:
        let _blockSize = defaultArg blockSize 0
        let _vicinity = defaultArg vicinity 1152921504606846975
        let _noLWM = defaultArg noLWM false
*)
-> GDID
abstract GenerateOneGDID :
        scopeName : string *
        sequenceName : string *
        ?blockSize : int *
        ?vicinity : Nullable<uint64> *
        ?noLWM : bool
(* Defaults:
        let _blockSize = defaultArg blockSize 0
        let _vicinity = defaultArg vicinity 1152921504606846975
        let _noLWM = defaultArg noLWM false
*)
-> GDID

Parameters

scopeName
Type: Online System String
The name of scope where sequences are kept
sequenceName
Type: Online System String
The name of sequence within the scope for which ID to be obtained
blockSize (Optional)
Type: Online System Int32
If >0 specifies how many sequence values to pre-allocate, otherwise provider would use its default setting
vicinity (Optional)
Type: Online System Nullable Online UInt64
The location on ID counter scale, the authority may disregard this parameter
noLWM (Optional)
Type: Online System Boolean
When true, does not start async fetch of the next ID block while the current block reaches low-water-mark. This may not be desired in some short-lived processes. The provider may disregard this flag

Return Value

Type: GDID
The GDID instance
See Also
IGDIDProvider Interface
IGDIDProvider Members
NFX.DataAccess Namespace


IGDIDProvider.TryGenerateManyConsecutiveGDIDs Method

IGDIDProvider TryGenerateManyConsecutiveGDIDs Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Tries to generate many consecutive Globally-Unique distributed ID (GDID) from the same authority for the supplied sequence name. If the reserved block gets exhausted, then the returned ID array length may be less than requested

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GDID[] TryGenerateManyConsecutiveGDIDs(
    string scopeName,
    string sequenceName,
    int gdidCount,
    Nullable<ulong> vicinity = 1152921504606846975,
    bool noLWM = false
)
GDID[] TryGenerateManyConsecutiveGDIDs(
    string scopeName,
    string sequenceName,
    int gdidCount,
    Nullable<ulong> vicinity = 1152921504606846975,
    bool noLWM = false
)
Function TryGenerateManyConsecutiveGDIDs (
    scopeName As String,
    sequenceName As String,
    gdidCount As Integer,
    Optional vicinity As Nullable(Of ULong) = 1152921504606846975,
    Optional noLWM As Boolean = false
) As GDID()
Function TryGenerateManyConsecutiveGDIDs (
    scopeName As String,
    sequenceName As String,
    gdidCount As Integer,
    Optional vicinity As Nullable(Of ULong) = 1152921504606846975,
    Optional noLWM As Boolean = false
) As GDID()
array<GDID>^ TryGenerateManyConsecutiveGDIDs(
    String^ scopeName,
    String^ sequenceName,
    int gdidCount,
    Nullable<unsigned long long> vicinity = 1152921504606846975,
    bool noLWM = false
)
array<GDID>^ TryGenerateManyConsecutiveGDIDs(
    String^ scopeName,
    String^ sequenceName,
    int gdidCount,
    Nullable<unsigned long long> vicinity = 1152921504606846975,
    bool noLWM = false
)
abstract TryGenerateManyConsecutiveGDIDs :
        scopeName : string *
        sequenceName : string *
        gdidCount : int *
        ?vicinity : Nullable<uint64> *
        ?noLWM : bool
(* Defaults:
        let _vicinity = defaultArg vicinity 1152921504606846975
        let _noLWM = defaultArg noLWM false
*)
-> GDID[]
abstract TryGenerateManyConsecutiveGDIDs :
        scopeName : string *
        sequenceName : string *
        gdidCount : int *
        ?vicinity : Nullable<uint64> *
        ?noLWM : bool
(* Defaults:
        let _vicinity = defaultArg vicinity 1152921504606846975
        let _noLWM = defaultArg noLWM false
*)
-> GDID[]

Parameters

scopeName
Type: Online System String
The name of scope where sequences are kept
sequenceName
Type: Online System String
The name of sequence within the scope for which ID to be obtained
gdidCount
Type: Online System Int32
How many Consecutive GDIDs from the same authority should the system try to reserve
vicinity (Optional)
Type: Online System Nullable Online UInt64
The location on ID counter scale, the authority may disregard this parameter
noLWM (Optional)
Type: Online System Boolean
When true, does not start async fetch of the next ID block while the current block reaches low-water-mark. This may not be desired in some short-lived processes. The provider may disregard this flag

Return Value

Type: GDID
The GDID[] instance which may have less elements than requested by gdidCount
See Also
IGDIDProvider Interface
IGDIDProvider Members
NFX.DataAccess Namespace


IGDIDProvider Properties

IGDIDProvider Properties NFX Class Library

The IGDIDProvider type exposes the following members.
Properties
 | Name | Description
Public property | Name | (Inherited from INamed.)
Public property | SequenceScopeNames | Returns the list of all scope names in the instance (Inherited from IUniqueSequenceProvider.)
Public property | TestingAuthorityNode | Gets/sets Authority Glue Node for testing. It can only be set once in the testing app container init before the first call to Generate is made. When this setting is set then any cluster authority nodes which would have been normally used will be completely bypassed during block allocation
Back to Top
See Also
IGDIDProvider Interface
NFX.DataAccess Namespace


IGDIDProvider.TestingAuthorityNode Property

IGDIDProvider TestingAuthorityNode Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets/sets Authority Glue Node for testing. It can only be set once in the testing app container init before the first call to Generate is made. When this setting is set then any cluster authority nodes which would have been normally used will be completely bypassed during block allocation

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string TestingAuthorityNode { get; set; }
string TestingAuthorityNode { get; set; }
Property TestingAuthorityNode As String
    Get
    Set
Property TestingAuthorityNode As String
    Get
    Set
property String^ TestingAuthorityNode {
    String^ get ();
    void set (String^ value);
}
property String^ TestingAuthorityNode {
    String^ get ();
    void set (String^ value);
}
abstract TestingAuthorityNode : string with get, set
abstract TestingAuthorityNode : string with get, set

Property Value

Type: Online String
See Also
IGDIDProvider Interface
IGDIDProvider Members
NFX.DataAccess Namespace


ISequenceInfo Interface

ISequenceInfo Interface NFX Class Library

Provides basic information about a named sequence. Warning!!! This class represents informational-only data which CAN NOT be used for real identification

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ISequenceInfo : INamed
public interface ISequenceInfo : INamed
Public Interface ISequenceInfo
    Inherits INamed
Public Interface ISequenceInfo
    Inherits INamed
public interface class ISequenceInfo : INamed
public interface class ISequenceInfo : INamed
type ISequenceInfo =
    interface
        interface INamed
    end
type ISequenceInfo =
    interface
        interface INamed
    end
See Also
ISequenceInfo Members
NFX.DataAccess Namespace


ISequenceInfo Members

ISequenceInfo Members NFX Class Library

The ISequenceInfo type exposes the following members.
Properties
 | Name | Description
Public property | ApproximateCurrentValue | Approximate current ID. This CAN NOT be used to obtain real ID, just the info
Public property | Era | Current Era in which the IDs are generated. This CAN NOT be used to obtain real ID, just the info
Public property | IssuerName | The name of issuing authority
Public property | IssueUTCDate | Time stamp of issue
Public property | Name | (Inherited from INamed.)
Public property | RemainingPreallocation | Remaining IDs from the preallocated count
Public property | TotalPreallocation | The size of block (if any) that was pre-allocated (instead of generating IDs every time)
Back to Top
See Also
ISequenceInfo Interface
NFX.DataAccess Namespace


ISequenceInfo Properties

ISequenceInfo Properties NFX Class Library

The ISequenceInfo type exposes the following members.
Properties
 | Name | Description
Public property | ApproximateCurrentValue | Approximate current ID. This CAN NOT be used to obtain real ID, just the info
Public property | Era | Current Era in which the IDs are generated. This CAN NOT be used to obtain real ID, just the info
Public property | IssuerName | The name of issuing authority
Public property | IssueUTCDate | Time stamp of issue
Public property | Name | (Inherited from INamed.)
Public property | RemainingPreallocation | Remaining IDs from the preallocated count
Public property | TotalPreallocation | The size of block (if any) that was pre-allocated (instead of generating IDs every time)
Back to Top
See Also
ISequenceInfo Interface
NFX.DataAccess Namespace


ISequenceInfo.ApproximateCurrentValue Property

ISequenceInfo ApproximateCurrentValue Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Approximate current ID. This CAN NOT be used to obtain real ID, just the info

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ulong ApproximateCurrentValue { get; }
ulong ApproximateCurrentValue { get; }
ReadOnly Property ApproximateCurrentValue As ULong
    Get
ReadOnly Property ApproximateCurrentValue As ULong
    Get
property unsigned long long ApproximateCurrentValue {
    unsigned long long get ();
}
property unsigned long long ApproximateCurrentValue {
    unsigned long long get ();
}
abstract ApproximateCurrentValue : uint64 with get
abstract ApproximateCurrentValue : uint64 with get

Property Value

Type: Online UInt64
See Also
ISequenceInfo Interface
ISequenceInfo Members
NFX.DataAccess Namespace


ISequenceInfo.Era Property

ISequenceInfo Era Property NFX Class Library

Current Era in which the IDs are generated. This CAN NOT be used to obtain real ID, just the info

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
uint Era { get; }
uint Era { get; }
ReadOnly Property Era As UInteger
    Get
ReadOnly Property Era As UInteger
    Get
property unsigned int Era {
    unsigned int get ();
}
property unsigned int Era {
    unsigned int get ();
}
abstract Era : uint32 with get
abstract Era : uint32 with get

Property Value

Type: Online UInt32
See Also
ISequenceInfo Interface
ISequenceInfo Members
NFX.DataAccess Namespace


ISequenceInfo.IssuerName Property

ISequenceInfo IssuerName Property NFX Class Library

The name of issuing authority

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string IssuerName { get; }
string IssuerName { get; }
ReadOnly Property IssuerName As String
    Get
ReadOnly Property IssuerName As String
    Get
property String^ IssuerName {
    String^ get ();
}
property String^ IssuerName {
    String^ get ();
}
abstract IssuerName : string with get
abstract IssuerName : string with get

Property Value

Type: Online String
See Also
ISequenceInfo Interface
ISequenceInfo Members
NFX.DataAccess Namespace


ISequenceInfo.IssueUTCDate Property

ISequenceInfo IssueUTCDate Property NFX Class Library

Time stamp of issue

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
DateTime IssueUTCDate { get; }
DateTime IssueUTCDate { get; }
ReadOnly Property IssueUTCDate As DateTime
    Get
ReadOnly Property IssueUTCDate As DateTime
    Get
property DateTime IssueUTCDate {
    DateTime get ();
}
property DateTime IssueUTCDate {
    DateTime get ();
}
abstract IssueUTCDate : DateTime with get
abstract IssueUTCDate : DateTime with get

Property Value

Type: Online DateTime
See Also
ISequenceInfo Interface
ISequenceInfo Members
NFX.DataAccess Namespace


ISequenceInfo.RemainingPreallocation Property

ISequenceInfo RemainingPreallocation Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Remaining IDs from the preallocated count

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int RemainingPreallocation { get; }
int RemainingPreallocation { get; }
ReadOnly Property RemainingPreallocation As Integer
    Get
ReadOnly Property RemainingPreallocation As Integer
    Get
property int RemainingPreallocation {
    int get ();
}
property int RemainingPreallocation {
    int get ();
}
abstract RemainingPreallocation : int with get
abstract RemainingPreallocation : int with get

Property Value

Type: Online Int32
See Also
ISequenceInfo Interface
ISequenceInfo Members
NFX.DataAccess Namespace


ISequenceInfo.TotalPreallocation Property

ISequenceInfo TotalPreallocation Property NFX Class Library

The size of block (if any) that was pre-allocated (instead of generating IDs every time)

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int TotalPreallocation { get; }
int TotalPreallocation { get; }
ReadOnly Property TotalPreallocation As Integer
    Get
ReadOnly Property TotalPreallocation As Integer
    Get
property int TotalPreallocation {
    int get ();
}
property int TotalPreallocation {
    int get ();
}
abstract TotalPreallocation : int with get
abstract TotalPreallocation : int with get

Property Value

Type: Online Int32
See Also
ISequenceInfo Interface
ISequenceInfo Members
NFX.DataAccess Namespace


IUniqueSequenceProvider Interface

IUniqueSequenceProvider Interface NFX Class Library

Represents an entity that provides unique identifiers via named sequences

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IUniqueSequenceProvider : INamed
public interface IUniqueSequenceProvider : INamed
Public Interface IUniqueSequenceProvider
    Inherits INamed
Public Interface IUniqueSequenceProvider
    Inherits INamed
public interface class IUniqueSequenceProvider : INamed
public interface class IUniqueSequenceProvider : INamed
type IUniqueSequenceProvider =
    interface
        interface INamed
    end
type IUniqueSequenceProvider =
    interface
        interface INamed
    end
See Also
IUniqueSequenceProvider Members
NFX.DataAccess Namespace


IUniqueSequenceProvider Members

IUniqueSequenceProvider Members NFX Class Library

The IUniqueSequenceProvider type exposes the following members.
Methods
 | Name | Description
Public method | GenerateOneSequenceID | Generates one ID for the supplied sequence name. Note: do not confuse with block pre-allocation, which is an internal optimization. Even if 100 IDs are pre-allocated the method returns one unique ID
Public method | GetSequenceInfos | Returns sequnce information enumerable for all sequences in the named scope
Public method | TryGenerateManyConsecutiveSequenceIDs | Tries to generate many consecutive IDs. If the reserved block gets exhausted, then the returned ID count may be less than requested.
Back to Top
Properties
 | Name | Description
Public property | Name | (Inherited from INamed.)
Public property | SequenceScopeNames | Returns the list of all scope names in the instance
Back to Top
See Also
IUniqueSequenceProvider Interface
NFX.DataAccess Namespace


IUniqueSequenceProvider Methods

IUniqueSequenceProvider Methods NFX Class Library

The IUniqueSequenceProvider type exposes the following members.
Methods
 | Name | Description
Public method | GenerateOneSequenceID | Generates one ID for the supplied sequence name. Note: do not confuse with block pre-allocation, which is an internal optimization. Even if 100 IDs are pre-allocated the method returns one unique ID
Public method | GetSequenceInfos | Returns sequnce information enumerable for all sequences in the named scope
Public method | TryGenerateManyConsecutiveSequenceIDs | Tries to generate many consecutive IDs. If the reserved block gets exhausted, then the returned ID count may be less than requested.
Back to Top
See Also
IUniqueSequenceProvider Interface
NFX.DataAccess Namespace


IUniqueSequenceProvider.GenerateOneSequenceID Method

IUniqueSequenceProvider GenerateOneSequenceID Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Generates one ID for the supplied sequence name. Note: do not confuse with block pre-allocation, which is an internal optimization. Even if 100 IDs are pre-allocated the method returns one unique ID

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ulong GenerateOneSequenceID(
    string scopeName,
    string sequenceName,
    int blockSize = 0,
    Nullable<ulong> vicinity = 18446744073709551615,
    bool noLWM = false
)
ulong GenerateOneSequenceID(
    string scopeName,
    string sequenceName,
    int blockSize = 0,
    Nullable<ulong> vicinity = 18446744073709551615,
    bool noLWM = false
)
Function GenerateOneSequenceID (
    scopeName As String,
    sequenceName As String,
    Optional blockSize As Integer = 0,
    Optional vicinity As Nullable(Of ULong) = 18446744073709551615,
    Optional noLWM As Boolean = false
) As ULong
Function GenerateOneSequenceID (
    scopeName As String,
    sequenceName As String,
    Optional blockSize As Integer = 0,
    Optional vicinity As Nullable(Of ULong) = 18446744073709551615,
    Optional noLWM As Boolean = false
) As ULong
unsigned long long GenerateOneSequenceID(
    String^ scopeName,
    String^ sequenceName,
    int blockSize = 0,
    Nullable<unsigned long long> vicinity = 18446744073709551615,
    bool noLWM = false
)
unsigned long long GenerateOneSequenceID(
    String^ scopeName,
    String^ sequenceName,
    int blockSize = 0,
    Nullable<unsigned long long> vicinity = 18446744073709551615,
    bool noLWM = false
)
abstract GenerateOneSequenceID :
        scopeName : string *
        sequenceName : string *
        ?blockSize : int *
        ?vicinity : Nullable<uint64> *
        ?noLWM : bool
(* Defaults:
        let _blockSize = defaultArg blockSize 0
        let _vicinity = defaultArg vicinity 18446744073709551615
        let _noLWM = defaultArg noLWM false
*)
-> uint64
abstract GenerateOneSequenceID :
        scopeName : string *
        sequenceName : string *
        ?blockSize : int *
        ?vicinity : Nullable<uint64> *
        ?noLWM : bool
(* Defaults:
        let _blockSize = defaultArg blockSize 0
        let _vicinity = defaultArg vicinity 18446744073709551615
        let _noLWM = defaultArg noLWM false
*)
-> uint64

Parameters

scopeName
Type: Online System String
The name of scope where sequences are kept
sequenceName
Type: Online System String
The name of sequence within the scope for which ID to be obtained
blockSize (Optional)
Type: Online System Int32
If >0 specifies how many sequence values to pre-allocate, otherwise provider would use its default setting
vicinity (Optional)
Type: Online System Nullable Online UInt64
The location on ID counter scale, the issuing authority may disregard this parameter
noLWM (Optional)
Type: Online System Boolean
When true, does not start async fetch of the next ID block while the current block reaches low-water-mark. This may not be desired in some short-lived processes. The provider may disregard this flag

Return Value

Type: Online UInt64
The new ULONG sequence value
See Also
IUniqueSequenceProvider Interface
IUniqueSequenceProvider Members
NFX.DataAccess Namespace


IUniqueSequenceProvider.GetSequenceInfos Method

IUniqueSequenceProvider GetSequenceInfos Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns sequnce information enumerable for all sequences in the named scope

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<ISequenceInfo> GetSequenceInfos(
    string scopeName
)
IEnumerable<ISequenceInfo> GetSequenceInfos(
    string scopeName
)
Function GetSequenceInfos (
    scopeName As String
) As IEnumerable(Of ISequenceInfo)
Function GetSequenceInfos (
    scopeName As String
) As IEnumerable(Of ISequenceInfo)
IEnumerable<ISequenceInfo^>^ GetSequenceInfos(
    String^ scopeName
)
IEnumerable<ISequenceInfo^>^ GetSequenceInfos(
    String^ scopeName
)
abstract GetSequenceInfos :
        scopeName : string -> IEnumerable<ISequenceInfo>
abstract GetSequenceInfos :
        scopeName : string -> IEnumerable<ISequenceInfo>

Parameters

scopeName
Type: Online System String

Return Value

Type: Online IEnumerable ISequenceInfo
See Also
IUniqueSequenceProvider Interface
IUniqueSequenceProvider Members
NFX.DataAccess Namespace


IUniqueSequenceProvider.TryGenerateManyConsecutiveSequenceIDs Method

IUniqueSequenceProvider TryGenerateManyConsecutiveSequenceIDs Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Tries to generate many consecutive IDs. If the reserved block gets exhausted, then the returned ID count may be less than requested.

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ConsecutiveUniqueSequenceIDs TryGenerateManyConsecutiveSequenceIDs(
    string scopeName,
    string sequenceName,
    int idCount,
    Nullable<ulong> vicinity = 18446744073709551615,
    bool noLWM = false
)
ConsecutiveUniqueSequenceIDs TryGenerateManyConsecutiveSequenceIDs(
    string scopeName,
    string sequenceName,
    int idCount,
    Nullable<ulong> vicinity = 18446744073709551615,
    bool noLWM = false
)
Function TryGenerateManyConsecutiveSequenceIDs (
    scopeName As String,
    sequenceName As String,
    idCount As Integer,
    Optional vicinity As Nullable(Of ULong) = 18446744073709551615,
    Optional noLWM As Boolean = false
) As ConsecutiveUniqueSequenceIDs
Function TryGenerateManyConsecutiveSequenceIDs (
    scopeName As String,
    sequenceName As String,
    idCount As Integer,
    Optional vicinity As Nullable(Of ULong) = 18446744073709551615,
    Optional noLWM As Boolean = false
) As ConsecutiveUniqueSequenceIDs
ConsecutiveUniqueSequenceIDs TryGenerateManyConsecutiveSequenceIDs(
    String^ scopeName,
    String^ sequenceName,
    int idCount,
    Nullable<unsigned long long> vicinity = 18446744073709551615,
    bool noLWM = false
)
ConsecutiveUniqueSequenceIDs TryGenerateManyConsecutiveSequenceIDs(
    String^ scopeName,
    String^ sequenceName,
    int idCount,
    Nullable<unsigned long long> vicinity = 18446744073709551615,
    bool noLWM = false
)
abstract TryGenerateManyConsecutiveSequenceIDs :
        scopeName : string *
        sequenceName : string *
        idCount : int *
        ?vicinity : Nullable<uint64> *
        ?noLWM : bool
(* Defaults:
        let _vicinity = defaultArg vicinity 18446744073709551615
        let _noLWM = defaultArg noLWM false
*)
-> ConsecutiveUniqueSequenceIDs
abstract TryGenerateManyConsecutiveSequenceIDs :
        scopeName : string *
        sequenceName : string *
        idCount : int *
        ?vicinity : Nullable<uint64> *
        ?noLWM : bool
(* Defaults:
        let _vicinity = defaultArg vicinity 18446744073709551615
        let _noLWM = defaultArg noLWM false
*)
-> ConsecutiveUniqueSequenceIDs

Parameters

scopeName
Type: Online System String
The name of scope where sequences are kept
sequenceName
Type: Online System String
The name of sequence within the scope for which ID to be obtained
idCount
Type: Online System Int32
How many Consecutive IDs should the system try to reserve
vicinity (Optional)
Type: Online System Nullable Online UInt64
The location on ID counter scale, the issuing authority may disregard this parameter
noLWM (Optional)
Type: Online System Boolean
When true, does not start async fetch of the next ID block while the current block reaches low-water-mark. This may not be desired in some short-lived processes. The provider may disregard this flag

Return Value

Type: ConsecutiveUniqueSequenceIDs
The first uniqueID along with the number of Consecutive IDs that the system could allocate which can be less than requested number of IDs
See Also
IUniqueSequenceProvider Interface
IUniqueSequenceProvider Members
NFX.DataAccess Namespace


IUniqueSequenceProvider Properties

IUniqueSequenceProvider Properties NFX Class Library

The IUniqueSequenceProvider type exposes the following members.
Properties
 | Name | Description
Public property | Name | (Inherited from INamed.)
Public property | SequenceScopeNames | Returns the list of all scope names in the instance
Back to Top
See Also
IUniqueSequenceProvider Interface
NFX.DataAccess Namespace


IUniqueSequenceProvider.SequenceScopeNames Property

IUniqueSequenceProvider SequenceScopeNames Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns the list of all scope names in the instance

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<string> SequenceScopeNames { get; }
IEnumerable<string> SequenceScopeNames { get; }
ReadOnly Property SequenceScopeNames As IEnumerable(Of String)
    Get
ReadOnly Property SequenceScopeNames As IEnumerable(Of String)
    Get
property IEnumerable<String^>^ SequenceScopeNames {
    IEnumerable<String^>^ get ();
}
property IEnumerable<String^>^ SequenceScopeNames {
    IEnumerable<String^>^ get ();
}
abstract SequenceScopeNames : IEnumerable<string> with get
abstract SequenceScopeNames : IEnumerable<string> with get

Property Value

Type: Online IEnumerable Online String
See Also
IUniqueSequenceProvider Interface
IUniqueSequenceProvider Members
NFX.DataAccess Namespace


KeyViolationKind Enumeration

KeyViolationKind Enumeration NFX Class Library

Specifies the sub-type of key violation

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum KeyViolationKind
public enum KeyViolationKind
Public Enumeration KeyViolationKind
Public Enumeration KeyViolationKind
public enum class KeyViolationKind
public enum class KeyViolationKind
type KeyViolationKind
type KeyViolationKind
Members
Member name | Value | Description
Unspecified | 0 |
Primary | 1 |
Secondary | 2 |
See Also
NFX.DataAccess Namespace


NameValueDataStoreKey Class

NameValueDataStoreKey Class NFX Class Library

Defines dictionary of string/object pairs used for key matching, where string dictionary key represents column name in storage and value is an object for the key
Inheritance Hierarchy
Online System Object
Online System.Collections.Generic Dictionary Online String, Online Object
NFX.DataAccess NameValueDataStoreKey

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class NameValueDataStoreKey : Dictionary<string, Object>,
    IDataStoreKey
[SerializableAttribute]
public sealed class NameValueDataStoreKey : Dictionary<string, Object>,
    IDataStoreKey
<SerializableAttribute>
Public NotInheritable Class NameValueDataStoreKey
    Inherits Dictionary(Of String, Object)
    Implements IDataStoreKey
<SerializableAttribute>
Public NotInheritable Class NameValueDataStoreKey
    Inherits Dictionary(Of String, Object)
    Implements IDataStoreKey
[SerializableAttribute]
public ref class NameValueDataStoreKey sealed : public Dictionary<String^, Object^>,
    IDataStoreKey
[SerializableAttribute]
public ref class NameValueDataStoreKey sealed : public Dictionary<String^, Object^>,
    IDataStoreKey
[<SealedAttribute>]
[<SerializableAttribute>]
type NameValueDataStoreKey =
    class
        inherit Dictionary<string, Object>
        interface IDataStoreKey
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type NameValueDataStoreKey =
    class
        inherit Dictionary<string, Object>
        interface IDataStoreKey
    end
See Also
NameValueDataStoreKey Members
NFX.DataAccess Namespace


NameValueDataStoreKey Members

NameValueDataStoreKey Members NFX Class Library

The NameValueDataStoreKey type exposes the following members.
Constructors
 | Name | Description
Public method | NameValueDataStoreKey | Initializes a new instance of the NameValueDataStoreKey class
Public method | NameValueDataStoreKey( Object ) | Initializes a new instance of the NameValueDataStoreKey class
Public method | NameValueDataStoreKey(SerializationInfo, StreamingContext) | Initializes a new instance of the NameValueDataStoreKey class
Back to Top
Methods
 | Name | Description
Public method | Online Add | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online Clear | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online ContainsKey | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online ContainsValue | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online Dictionary TKey, TValue instance. (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online Remove | (Inherited from Online Dictionary Online String, Online Object .)
Public method | ToString | (Overrides Online Object ToString .)
Public method | Online TryGetValue | (Inherited from Online Dictionary Online String, Online Object .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online Comparer | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Online Count | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Online Item | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Online Keys | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Online Values | (Inherited from Online Dictionary Online String, Online Object .)
Back to Top
See Also
NameValueDataStoreKey Class
NFX.DataAccess Namespace


NameValueDataStoreKey Constructor

NameValueDataStoreKey Constructor NFX Class Library

Overload List
 | Name | Description
Public method | NameValueDataStoreKey | Initializes a new instance of the NameValueDataStoreKey class
Public method | NameValueDataStoreKey( Object ) | Initializes a new instance of the NameValueDataStoreKey class
Public method | NameValueDataStoreKey(SerializationInfo, StreamingContext) | Initializes a new instance of the NameValueDataStoreKey class
Back to Top
See Also
NameValueDataStoreKey Class
NameValueDataStoreKey Members
NFX.DataAccess Namespace


NameValueDataStoreKey Constructor

NameValueDataStoreKey Constructor NFX Class Library

Initializes a new instance of the NameValueDataStoreKey class

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NameValueDataStoreKey()
public NameValueDataStoreKey()
Public Sub New
Public Sub New
public:
NameValueDataStoreKey()
public:
NameValueDataStoreKey()
new : unit -> NameValueDataStoreKey
new : unit -> NameValueDataStoreKey
See Also
NameValueDataStoreKey Class
NameValueDataStoreKey Members
NameValueDataStoreKey Overload
NFX.DataAccess Namespace


NameValueDataStoreKey Constructor (Object[])

NameValueDataStoreKey Constructor ( Object ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NameValueDataStoreKey class

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NameValueDataStoreKey(
    params Object[] pairs
)
public NameValueDataStoreKey(
    params Object[] pairs
)
Public Sub New (
    ParamArray pairs As Object()
)
Public Sub New (
    ParamArray pairs As Object()
)
public:
NameValueDataStoreKey(
    ... array<Object^>^ pairs
)
public:
NameValueDataStoreKey(
    ... array<Object^>^ pairs
)
new :
        pairs : Object[] -> NameValueDataStoreKey
new :
        pairs : Object[] -> NameValueDataStoreKey

Parameters

pairs
Type: Online System Object
See Also
NameValueDataStoreKey Class
NameValueDataStoreKey Members
NameValueDataStoreKey Overload
NFX.DataAccess Namespace


NameValueDataStoreKey Constructor (SerializationInfo, StreamingContext)

NameValueDataStoreKey Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NameValueDataStoreKey class

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NameValueDataStoreKey(
    SerializationInfo info,
    StreamingContext context
)
public NameValueDataStoreKey(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
NameValueDataStoreKey(
    SerializationInfo^ info,
    StreamingContext context
)
public:
NameValueDataStoreKey(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> NameValueDataStoreKey
new :
        info : SerializationInfo *
        context : StreamingContext -> NameValueDataStoreKey

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
NameValueDataStoreKey Class
NameValueDataStoreKey Members
NameValueDataStoreKey Overload
NFX.DataAccess Namespace


NameValueDataStoreKey Methods

NameValueDataStoreKey Methods NFX Class Library

The NameValueDataStoreKey type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online Clear | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online ContainsKey | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online ContainsValue | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online Dictionary TKey, TValue instance. (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online Remove | (Inherited from Online Dictionary Online String, Online Object .)
Public method | ToString | (Overrides Online Object ToString .)
Public method | Online TryGetValue | (Inherited from Online Dictionary Online String, Online Object .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NameValueDataStoreKey Class
NFX.DataAccess Namespace


NameValueDataStoreKey.ToString Method

NameValueDataStoreKey ToString Method NFX Class Library

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
NameValueDataStoreKey Class
NameValueDataStoreKey Members
NFX.DataAccess Namespace


NameValueDataStoreKey Properties

NameValueDataStoreKey Properties NFX Class Library

The NameValueDataStoreKey type exposes the following members.
Properties
 | Name | Description
Public property | Online Comparer | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Online Count | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Online Item | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Online Keys | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Online Values | (Inherited from Online Dictionary Online String, Online Object .)
Back to Top
See Also
NameValueDataStoreKey Class
NFX.DataAccess Namespace


NOPDataStore Class

NOPDataStore Class NFX Class Library

Represents data store that does not do anything
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.DataAccess NOPDataStore

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class NOPDataStore : ApplicationComponent,
    IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
public sealed class NOPDataStore : ApplicationComponent,
    IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
Public NotInheritable Class NOPDataStore
    Inherits ApplicationComponent
    Implements IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
Public NotInheritable Class NOPDataStore
    Inherits ApplicationComponent
    Implements IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
public ref class NOPDataStore sealed : public ApplicationComponent,
    IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
public ref class NOPDataStore sealed : public ApplicationComponent,
    IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
[<SealedAttribute>]
type NOPDataStore =
    class
        inherit ApplicationComponent
        interface IDataStoreImplementation
        interface IDataStore
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
[<SealedAttribute>]
type NOPDataStore =
    class
        inherit ApplicationComponent
        interface IDataStoreImplementation
        interface IDataStore
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
NOPDataStore Members
NFX.DataAccess Namespace


NOPDataStore Members

NOPDataStore Members NFX Class Library

The NOPDataStore type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | Configure |
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter |
Public method | ExternalParametersForGroups |
Public method | ExternalSetParameter |
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | TestConnection |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters |
 | Instance | Returns a singlelton instance of the data store that does not do anything
Public property | InstrumentationEnabled |
Public property | LogLevel |
Public property | TargetName |
Back to Top
See Also
NOPDataStore Class
NFX.DataAccess Namespace


NOPDataStore Methods

NOPDataStore Methods NFX Class Library

The NOPDataStore type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | Configure |
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter |
Public method | ExternalParametersForGroups |
Public method | ExternalSetParameter |
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | TestConnection |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NOPDataStore Class
NFX.DataAccess Namespace


NOPDataStore.Configure Method

NOPDataStore Configure Method NFX Class Library

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode node
)
public void Configure(
    IConfigSectionNode node
)
Public Sub Configure (
    node As IConfigSectionNode
)
Public Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
NOPDataStore Class
NOPDataStore Members
NFX.DataAccess Namespace


NOPDataStore.ExternalGetParameter Method

NOPDataStore ExternalGetParameter Method NFX Class Library

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
public bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
Public Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
Public Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
) sealed
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
) sealed
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalGetParameter(String, Object , String )
See Also
NOPDataStore Class
NOPDataStore Members
NFX.DataAccess Namespace


NOPDataStore.ExternalParametersForGroups Method

NOPDataStore ExternalParametersForGroups Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
public IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
Public Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
Public Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
) sealed
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
) sealed
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>

Parameters

groups
Type: Online System String

Return Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParametersForGroups( String )
See Also
NOPDataStore Class
NOPDataStore Members
NFX.DataAccess Namespace


NOPDataStore.ExternalSetParameter Method

NOPDataStore ExternalSetParameter Method NFX Class Library

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
public bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
Public Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
Public Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
) sealed
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
) sealed
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalSetParameter(String, Object, String )
See Also
NOPDataStore Class
NOPDataStore Members
NFX.DataAccess Namespace


NOPDataStore.TestConnection Method

NOPDataStore TestConnection Method NFX Class Library

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void TestConnection()
public void TestConnection()
Public Sub TestConnection
Public Sub TestConnection
public:
virtual void TestConnection() sealed
public:
virtual void TestConnection() sealed
abstract TestConnection : unit -> unit
override TestConnection : unit -> unit
abstract TestConnection : unit -> unit
override TestConnection : unit -> unit

Implements

IDataStore TestConnection
See Also
NOPDataStore Class
NOPDataStore Members
NFX.DataAccess Namespace


NOPDataStore Properties

NOPDataStore Properties NFX Class Library

The NOPDataStore type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters |
 | Instance | Returns a singlelton instance of the data store that does not do anything
Public property | InstrumentationEnabled |
Public property | LogLevel |
Public property | TargetName |
Back to Top
See Also
NOPDataStore Class
NFX.DataAccess Namespace


NOPDataStore.ExternalParameters Property

NOPDataStore ExternalParameters Property NFX Class Library

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
public IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
Public ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
Public ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get () sealed;
}
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get () sealed;
}
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get

Property Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParameters
See Also
NOPDataStore Class
NOPDataStore Members
NFX.DataAccess Namespace


NOPDataStore.Instance Property

NOPDataStore Instance Property NFX Class Library

Returns a singlelton instance of the data store that does not do anything

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NOPDataStore Instance { get; }
public static NOPDataStore Instance { get; }
Public Shared ReadOnly Property Instance As NOPDataStore
    Get
Public Shared ReadOnly Property Instance As NOPDataStore
    Get
public:
static property NOPDataStore^ Instance {
    NOPDataStore^ get ();
}
public:
static property NOPDataStore^ Instance {
    NOPDataStore^ get ();
}
static member Instance : NOPDataStore with get
static member Instance : NOPDataStore with get

Property Value

Type: NOPDataStore
See Also
NOPDataStore Class
NOPDataStore Members
NFX.DataAccess Namespace


NOPDataStore.InstrumentationEnabled Property

NOPDataStore InstrumentationEnabled Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool InstrumentationEnabled { get; set; }
public bool InstrumentationEnabled { get; set; }
Public Property InstrumentationEnabled As Boolean
    Get
    Set
Public Property InstrumentationEnabled As Boolean
    Get
    Set
public:
virtual property bool InstrumentationEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool InstrumentationEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract InstrumentationEnabled : bool with get, set
override InstrumentationEnabled : bool with get, set
abstract InstrumentationEnabled : bool with get, set
override InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentable InstrumentationEnabled
See Also
NOPDataStore Class
NOPDataStore Members
NFX.DataAccess Namespace


NOPDataStore.LogLevel Property

NOPDataStore LogLevel Property NFX Class Library

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StoreLogLevel LogLevel { get; set; }
public StoreLogLevel LogLevel { get; set; }
Public Property LogLevel As StoreLogLevel
    Get
    Set
Public Property LogLevel As StoreLogLevel
    Get
    Set
public:
virtual property StoreLogLevel LogLevel {
    StoreLogLevel get () sealed;
    void set (StoreLogLevel value) sealed;
}
public:
virtual property StoreLogLevel LogLevel {
    StoreLogLevel get () sealed;
    void set (StoreLogLevel value) sealed;
}
abstract LogLevel : StoreLogLevel with get, set
override LogLevel : StoreLogLevel with get, set
abstract LogLevel : StoreLogLevel with get, set
override LogLevel : StoreLogLevel with get, set

Property Value

Type: StoreLogLevel

Implements

IDataStoreImplementation LogLevel
See Also
NOPDataStore Class
NOPDataStore Members
NFX.DataAccess Namespace


NOPDataStore.TargetName Property

NOPDataStore TargetName Property NFX Class Library

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string TargetName { get; }
public string TargetName { get; }
Public ReadOnly Property TargetName As String
    Get
Public ReadOnly Property TargetName As String
    Get
public:
virtual property String^ TargetName {
    String^ get () sealed;
}
public:
virtual property String^ TargetName {
    String^ get () sealed;
}
abstract TargetName : string with get
override TargetName : string with get
abstract TargetName : string with get
override TargetName : string with get

Property Value

Type: Online String

Implements

IDataStore TargetName
See Also
NOPDataStore Class
NOPDataStore Members
NFX.DataAccess Namespace


StoreFlag Enumeration

StoreFlag Enumeration NFX Class Library

Determines whether entity should be loaded/stored from/to storage

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum StoreFlag
public enum StoreFlag
Public Enumeration StoreFlag
Public Enumeration StoreFlag
public enum class StoreFlag
public enum class StoreFlag
type StoreFlag
type StoreFlag
Members
Member name | Value | Description
LoadAndStore | 0 |
OnlyLoad | 1 |
OnlyStore | 2 |
None | 3 |
See Also
NFX.DataAccess Namespace


StoreLogLevel Enumeration

StoreLogLevel Enumeration NFX Class Library

Defines log level for DataStores

Namespace: NFX.DataAccess
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum StoreLogLevel
public enum StoreLogLevel
Public Enumeration StoreLogLevel
Public Enumeration StoreLogLevel
public enum class StoreLogLevel
public enum class StoreLogLevel
type StoreLogLevel
type StoreLogLevel
Members
Member name | Value | Description
None | 0 |
Debug | 1 |
Trace | 2 |
See Also
NFX.DataAccess Namespace


NFX.DataAccess.Cache Namespace

NFX.DataAccess.Cache Namespace NFX Class Library

Provides efficient caching options
Classes
 | Class | Description
Public class | Bucketed | Abstraction of an item that can be placed in hashing bucket
Public class | CacheRec | Stores cached item (such as a business object) along with additional caching information about it. The instance of this class gets reused for the same Key, so Key is immutable field. The instance of this class is returned by table.Get(key...) so the calling thread may see different Value property with time as it may be dynamically changed by some other thread (the newer value for the same Key)
Public class | CacheStore | Represents an efficient in-memory cache of expiring optionally-prioritized objects. This class is higly optimized for caching of business objects in data store implementations and does not guarantee that all hash collisions are handled, that is - some data may be overridden. The implementation relies on 2 stage hashing, where the second collision replaces the existing item with the colliding one if items are equal in their priorities. The degree of collisions is controlled by 'bucketSize' and 'recPerPage' parameters that are passed to the store per table, so basically the tables are capped at a certain size and can not change (bucketSize*recPerPage). The lookup implementation is 100% lock-free, whereas the degree of mutability-related locking is controlled by 'lockCount' per table. This class is thread safe for reading and writing cache items, however it does not guarantee instant read/write consistency between threads.
Public class | ComplexKeyHashingStrategy | Provides hashing strategy for keys that are not scalar uint64. This is a companion class for CacheStore which only understands uint64 as keys for efficiency purposes. One may extend this class to implement custom resolution of complex keys into uint64 hashes and provide collision handling. The base implementation uses object.GetHashCode() with chaining for collision resolution
Protected class | Page | A composite item that stores collection of CacheRecs and can be placed into a hashing bucket
Public class | Table | Represents a table that stores cached items identified by keys
Public class | TableOptions | Provides config options for cache tables
Enumerations
 | Enumeration | Description
Public enumeration | TableCapacity | Provides cache table capacity classifications


Bucketed Class

Bucketed Class NFX Class Library

Abstraction of an item that can be placed in hashing bucket
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.DataAccess.Cache Bucketed
NFX.DataAccess.Cache CacheRec
NFX.DataAccess.Cache Page

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Bucketed : DisposableObject
public abstract class Bucketed : DisposableObject
Public MustInherit Class Bucketed
    Inherits DisposableObject
Public MustInherit Class Bucketed
    Inherits DisposableObject
public ref class Bucketed abstract : public DisposableObject
public ref class Bucketed abstract : public DisposableObject
[<AbstractClassAttribute>]
type Bucketed =
    class
        inherit DisposableObject
    end
[<AbstractClassAttribute>]
type Bucketed =
    class
        inherit DisposableObject
    end
See Also
Bucketed Members
NFX.DataAccess.Cache Namespace


Bucketed Members

Bucketed Members NFX Class Library

The Bucketed type exposes the following members.
Constructors
 | Name | Description
Protected method | Bucketed | Initializes a new instance of the Bucketed class
Back to Top
Methods
 | Name | Description
Protected method | Destructor | Override this method to do actual destructor work (Inherited from DisposableObject.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Back to Top
See Also
Bucketed Class
NFX.DataAccess.Cache Namespace


Bucketed Constructor

Bucketed Constructor NFX Class Library

Initializes a new instance of the Bucketed class

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Bucketed()
protected Bucketed()
Protected Sub New
Protected Sub New
protected:
Bucketed()
protected:
Bucketed()
new : unit -> Bucketed
new : unit -> Bucketed
See Also
Bucketed Class
Bucketed Members
NFX.DataAccess.Cache Namespace


Bucketed Methods

Bucketed Methods NFX Class Library

The Bucketed type exposes the following members.
Methods
 | Name | Description
Protected method | Destructor | Override this method to do actual destructor work (Inherited from DisposableObject.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Bucketed Class
NFX.DataAccess.Cache Namespace


Bucketed Properties

Bucketed Properties NFX Class Library

The Bucketed type exposes the following members.
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Back to Top
See Also
Bucketed Class
NFX.DataAccess.Cache Namespace


CacheRec Class

CacheRec Class NFX Class Library

Stores cached item (such as a business object) along with additional caching information about it. The instance of this class gets reused for the same Key, so Key is immutable field. The instance of this class is returned by table.Get(key...) so the calling thread may see different Value property with time as it may be dynamically changed by some other thread (the newer value for the same Key)
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.DataAccess.Cache Bucketed
NFX.DataAccess.Cache CacheRec

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class CacheRec : Bucketed
public sealed class CacheRec : Bucketed
Public NotInheritable Class CacheRec
    Inherits Bucketed
Public NotInheritable Class CacheRec
    Inherits Bucketed
public ref class CacheRec sealed : public Bucketed
public ref class CacheRec sealed : public Bucketed
[<SealedAttribute>]
type CacheRec =
    class
        inherit Bucketed
    end
[<SealedAttribute>]
type CacheRec =
    class
        inherit Bucketed
    end
See Also
CacheRec Members
NFX.DataAccess.Cache Namespace


CacheRec Members

CacheRec Members NFX Class Library

The CacheRec type exposes the following members.
Constructors
 | Name | Description
Protected method | CacheRec | Initializes a new instance of the CacheRec class
Back to Top
Methods
 | Name | Description
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReuseCTOR | Used as a "constructor" that reuses this class instance to lessen GC burden
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | ValueAs T | Returns typecasted value
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Key | Key is immutable because CacheRec is returned by table.Get(key)
Protected field | m_AbsoluteExpirationUTC |
Protected field | m_AgeSec |
Protected field | m_CreateDate |
Protected field | m_HitCount |
Protected field | m_MaxAgeSec |
Protected field | m_Priority |
Protected field | m_Value |
Public field | Metadata | Stores arbitrary information about this item
Back to Top
Properties
 | Name | Description
Public property | AbsoluteExpirationUTC | Returns absolute expiration timestamp for this item or null
Public property | AgeSec | Returns an approximate age of the item in seconds - an interval since this item was put into the store for the last time
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | HitCount | Returns how many times this cache item was hit (resulted in successfull read)
Public property | MaxAgeSec | Returns positive integer that specifies the maximum lifespan duration for this item expressed in seconds, or zero. Zero is returned when this item does not have specific lifespan defined and will be evicted from cache per lifespan specified on the table level: Table.MaxAgeSec (default)
Public property | Priority | Returns an integer value that dictates item priority relative to other items in the same table. Priorities play a role during cache collision as an item with higher priority is not going to be replaced by an item with lower priority
Public property | Value | Returns the value - a reference to cached item such as a business object
Back to Top
See Also
CacheRec Class
NFX.DataAccess.Cache Namespace


CacheRec Constructor

CacheRec Constructor NFX Class Library

Initializes a new instance of the CacheRec class

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CacheRec(
    ulong key,
    Object data,
    int maxAgeSec,
    int priority,
    Nullable<DateTime> absoluteExpirationUTC
)
internal CacheRec(
    ulong key,
    Object data,
    int maxAgeSec,
    int priority,
    Nullable<DateTime> absoluteExpirationUTC
)
Friend Sub New (
    key As ULong,
    data As Object,
    maxAgeSec As Integer,
    priority As Integer,
    absoluteExpirationUTC As Nullable(Of DateTime)
)
Friend Sub New (
    key As ULong,
    data As Object,
    maxAgeSec As Integer,
    priority As Integer,
    absoluteExpirationUTC As Nullable(Of DateTime)
)
internal:
CacheRec(
    unsigned long long key,
    Object^ data,
    int maxAgeSec,
    int priority,
    Nullable<DateTime> absoluteExpirationUTC
)
internal:
CacheRec(
    unsigned long long key,
    Object^ data,
    int maxAgeSec,
    int priority,
    Nullable<DateTime> absoluteExpirationUTC
)
new :
        key : uint64 *
        data : Object *
        maxAgeSec : int *
        priority : int *
        absoluteExpirationUTC : Nullable<DateTime> -> CacheRec
new :
        key : uint64 *
        data : Object *
        maxAgeSec : int *
        priority : int *
        absoluteExpirationUTC : Nullable<DateTime> -> CacheRec

Parameters

key
Type: Online System UInt64
data
Type: Online System Object
maxAgeSec
Type: Online System Int32
priority
Type: Online System Int32
absoluteExpirationUTC
Type: Online System Nullable Online DateTime
See Also
CacheRec Class
CacheRec Members
NFX.DataAccess.Cache Namespace


CacheRec Fields

CacheRec Fields NFX Class Library

The CacheRec type exposes the following members.
Fields
 | Name | Description
Public field | Key | Key is immutable because CacheRec is returned by table.Get(key)
Protected field | m_AbsoluteExpirationUTC |
Protected field | m_AgeSec |
Protected field | m_CreateDate |
Protected field | m_HitCount |
Protected field | m_MaxAgeSec |
Protected field | m_Priority |
Protected field | m_Value |
Public field | Metadata | Stores arbitrary information about this item
Back to Top
See Also
CacheRec Class
NFX.DataAccess.Cache Namespace


CacheRec.Key Field

CacheRec Key Field NFX Class Library

Key is immutable because CacheRec is returned by table.Get(key)

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ulong Key
public readonly ulong Key
Public ReadOnly Key As ULong
Public ReadOnly Key As ULong
public:
initonly unsigned long long Key
public:
initonly unsigned long long Key
val Key: uint64
val Key: uint64

Field Value

Type: Online UInt64
See Also
CacheRec Class
CacheRec Members
NFX.DataAccess.Cache Namespace


CacheRec.m_AbsoluteExpirationUTC Field

CacheRec m_AbsoluteExpirationUTC Field NFX Class Library

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Nullable<DateTime> m_AbsoluteExpirationUTC
internal Nullable<DateTime> m_AbsoluteExpirationUTC
Friend m_AbsoluteExpirationUTC As Nullable(Of DateTime)
Friend m_AbsoluteExpirationUTC As Nullable(Of DateTime)
internal:
Nullable<DateTime> m_AbsoluteExpirationUTC
internal:
Nullable<DateTime> m_AbsoluteExpirationUTC
val mutable internal m_AbsoluteExpirationUTC: Nullable<DateTime>
val mutable internal m_AbsoluteExpirationUTC: Nullable<DateTime>

Field Value

Type: Online Nullable Online DateTime
See Also
CacheRec Class
CacheRec Members
NFX.DataAccess.Cache Namespace


CacheRec.m_AgeSec Field

CacheRec m_AgeSec Field NFX Class Library

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int m_AgeSec
internal int m_AgeSec
Friend m_AgeSec As Integer
Friend m_AgeSec As Integer
internal:
int m_AgeSec
internal:
int m_AgeSec
val mutable internal m_AgeSec: int
val mutable internal m_AgeSec: int

Field Value

Type: Online Int32
See Also
CacheRec Class
CacheRec Members
NFX.DataAccess.Cache Namespace


CacheRec.m_CreateDate Field

CacheRec m_CreateDate Field NFX Class Library

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal DateTime m_CreateDate
internal DateTime m_CreateDate
Friend m_CreateDate As DateTime
Friend m_CreateDate As DateTime
internal:
DateTime m_CreateDate
internal:
DateTime m_CreateDate
val mutable internal m_CreateDate: DateTime
val mutable internal m_CreateDate: DateTime

Field Value

Type: Online DateTime
See Also
CacheRec Class
CacheRec Members
NFX.DataAccess.Cache Namespace


CacheRec.m_HitCount Field

CacheRec m_HitCount Field NFX Class Library

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int m_HitCount
internal int m_HitCount
Friend m_HitCount As Integer
Friend m_HitCount As Integer
internal:
int m_HitCount
internal:
int m_HitCount
val mutable internal m_HitCount: int
val mutable internal m_HitCount: int

Field Value

Type: Online Int32
See Also
CacheRec Class
CacheRec Members
NFX.DataAccess.Cache Namespace


CacheRec.m_MaxAgeSec Field

CacheRec m_MaxAgeSec Field NFX Class Library

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int m_MaxAgeSec
internal int m_MaxAgeSec
Friend m_MaxAgeSec As Integer
Friend m_MaxAgeSec As Integer
internal:
int m_MaxAgeSec
internal:
int m_MaxAgeSec
val mutable internal m_MaxAgeSec: int
val mutable internal m_MaxAgeSec: int

Field Value

Type: Online Int32
See Also
CacheRec Class
CacheRec Members
NFX.DataAccess.Cache Namespace


CacheRec.m_Priority Field

CacheRec m_Priority Field NFX Class Library

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int m_Priority
internal int m_Priority
Friend m_Priority As Integer
Friend m_Priority As Integer
internal:
int m_Priority
internal:
int m_Priority
val mutable internal m_Priority: int
val mutable internal m_Priority: int

Field Value

Type: Online Int32
See Also
CacheRec Class
CacheRec Members
NFX.DataAccess.Cache Namespace


CacheRec.m_Value Field

CacheRec m_Value Field NFX Class Library

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Object m_Value
internal Object m_Value
Friend m_Value As Object
Friend m_Value As Object
internal:
Object^ m_Value
internal:
Object^ m_Value
val mutable internal m_Value: Object
val mutable internal m_Value: Object

Field Value

Type: Online Object
See Also
CacheRec Class
CacheRec Members
NFX.DataAccess.Cache Namespace


CacheRec.Metadata Field

CacheRec Metadata Field NFX Class Library

Stores arbitrary information about this item

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Metadata
public Object Metadata
Public Metadata As Object
Public Metadata As Object
public:
Object^ Metadata
public:
Object^ Metadata
val mutable Metadata: Object
val mutable Metadata: Object

Field Value

Type: Online Object
See Also
CacheRec Class
CacheRec Members
NFX.DataAccess.Cache Namespace


CacheRec Methods

CacheRec Methods NFX Class Library

The CacheRec type exposes the following members.
Methods
 | Name | Description
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReuseCTOR | Used as a "constructor" that reuses this class instance to lessen GC burden
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | ValueAs T | Returns typecasted value
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CacheRec Class
NFX.DataAccess.Cache Namespace


CacheRec.Destructor Method

CacheRec Destructor Method NFX Class Library

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
CacheRec Class
CacheRec Members
NFX.DataAccess.Cache Namespace


CacheRec.ReuseCTOR Method

CacheRec ReuseCTOR Method NFX Class Library

Used as a "constructor" that reuses this class instance to lessen GC burden

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void ReuseCTOR(
    Object data,
    int maxAgeSec,
    int priority,
    Nullable<DateTime> absoluteExpirationUTC
)
internal void ReuseCTOR(
    Object data,
    int maxAgeSec,
    int priority,
    Nullable<DateTime> absoluteExpirationUTC
)
Friend Sub ReuseCTOR (
    data As Object,
    maxAgeSec As Integer,
    priority As Integer,
    absoluteExpirationUTC As Nullable(Of DateTime)
)
Friend Sub ReuseCTOR (
    data As Object,
    maxAgeSec As Integer,
    priority As Integer,
    absoluteExpirationUTC As Nullable(Of DateTime)
)
internal:
void ReuseCTOR(
    Object^ data,
    int maxAgeSec,
    int priority,
    Nullable<DateTime> absoluteExpirationUTC
)
internal:
void ReuseCTOR(
    Object^ data,
    int maxAgeSec,
    int priority,
    Nullable<DateTime> absoluteExpirationUTC
)
internal member ReuseCTOR :
        data : Object *
        maxAgeSec : int *
        priority : int *
        absoluteExpirationUTC : Nullable<DateTime> -> unit
internal member ReuseCTOR :
        data : Object *
        maxAgeSec : int *
        priority : int *
        absoluteExpirationUTC : Nullable<DateTime> -> unit

Parameters

data
Type: Online System Object
maxAgeSec
Type: Online System Int32
priority
Type: Online System Int32
absoluteExpirationUTC
Type: Online System Nullable Online DateTime
See Also
CacheRec Class
CacheRec Members
NFX.DataAccess.Cache Namespace


CacheRec.ValueAs(T) Method

CacheRec ValueAs T Method NFX Class Library

Returns typecasted value

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T ValueAs<T>()
public T ValueAs<T>()
Public Function ValueAs(Of T) As T
Public Function ValueAs(Of T) As T
public:
generic<typename T>
T ValueAs()
public:
generic<typename T>
T ValueAs()
member ValueAs : unit -> 'T
member ValueAs : unit -> 'T
Type Parameters
T

Return Value

Type: T
See Also
CacheRec Class
CacheRec Members
NFX.DataAccess.Cache Namespace


CacheRec Properties

CacheRec Properties NFX Class Library

The CacheRec type exposes the following members.
Properties
 | Name | Description
Public property | AbsoluteExpirationUTC | Returns absolute expiration timestamp for this item or null
Public property | AgeSec | Returns an approximate age of the item in seconds - an interval since this item was put into the store for the last time
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | HitCount | Returns how many times this cache item was hit (resulted in successfull read)
Public property | MaxAgeSec | Returns positive integer that specifies the maximum lifespan duration for this item expressed in seconds, or zero. Zero is returned when this item does not have specific lifespan defined and will be evicted from cache per lifespan specified on the table level: Table.MaxAgeSec (default)
Public property | Priority | Returns an integer value that dictates item priority relative to other items in the same table. Priorities play a role during cache collision as an item with higher priority is not going to be replaced by an item with lower priority
Public property | Value | Returns the value - a reference to cached item such as a business object
Back to Top
See Also
CacheRec Class
NFX.DataAccess.Cache Namespace


CacheRec.AbsoluteExpirationUTC Property

CacheRec AbsoluteExpirationUTC Property NFX Class Library

Returns absolute expiration timestamp for this item or null

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> AbsoluteExpirationUTC { get; }
public Nullable<DateTime> AbsoluteExpirationUTC { get; }
Public ReadOnly Property AbsoluteExpirationUTC As Nullable(Of DateTime)
    Get
Public ReadOnly Property AbsoluteExpirationUTC As Nullable(Of DateTime)
    Get
public:
property Nullable<DateTime> AbsoluteExpirationUTC {
    Nullable<DateTime> get ();
}
public:
property Nullable<DateTime> AbsoluteExpirationUTC {
    Nullable<DateTime> get ();
}
member AbsoluteExpirationUTC : Nullable<DateTime> with get
member AbsoluteExpirationUTC : Nullable<DateTime> with get

Property Value

Type: Online Nullable Online DateTime
See Also
CacheRec Class
CacheRec Members
NFX.DataAccess.Cache Namespace


CacheRec.AgeSec Property

CacheRec AgeSec Property NFX Class Library

Returns an approximate age of the item in seconds - an interval since this item was put into the store for the last time

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int AgeSec { get; }
public int AgeSec { get; }
Public ReadOnly Property AgeSec As Integer
    Get
Public ReadOnly Property AgeSec As Integer
    Get
public:
property int AgeSec {
    int get ();
}
public:
property int AgeSec {
    int get ();
}
member AgeSec : int with get
member AgeSec : int with get

Property Value

Type: Online Int32
See Also
CacheRec Class
CacheRec Members
NFX.DataAccess.Cache Namespace


CacheRec.HitCount Property

CacheRec HitCount Property NFX Class Library

Returns how many times this cache item was hit (resulted in successfull read)

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int HitCount { get; }
public int HitCount { get; }
Public ReadOnly Property HitCount As Integer
    Get
Public ReadOnly Property HitCount As Integer
    Get
public:
property int HitCount {
    int get ();
}
public:
property int HitCount {
    int get ();
}
member HitCount : int with get
member HitCount : int with get

Property Value

Type: Online Int32
See Also
CacheRec Class
CacheRec Members
NFX.DataAccess.Cache Namespace


CacheRec.MaxAgeSec Property

CacheRec MaxAgeSec Property NFX Class Library

Returns positive integer that specifies the maximum lifespan duration for this item expressed in seconds, or zero. Zero is returned when this item does not have specific lifespan defined and will be evicted from cache per lifespan specified on the table level: Table.MaxAgeSec (default)

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MaxAgeSec { get; }
public int MaxAgeSec { get; }
Public ReadOnly Property MaxAgeSec As Integer
    Get
Public ReadOnly Property MaxAgeSec As Integer
    Get
public:
property int MaxAgeSec {
    int get ();
}
public:
property int MaxAgeSec {
    int get ();
}
member MaxAgeSec : int with get
member MaxAgeSec : int with get

Property Value

Type: Online Int32
See Also
CacheRec Class
CacheRec Members
NFX.DataAccess.Cache Namespace


CacheRec.Priority Property

CacheRec Priority Property NFX Class Library

Returns an integer value that dictates item priority relative to other items in the same table. Priorities play a role during cache collision as an item with higher priority is not going to be replaced by an item with lower priority

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Priority { get; }
public int Priority { get; }
Public ReadOnly Property Priority As Integer
    Get
Public ReadOnly Property Priority As Integer
    Get
public:
property int Priority {
    int get ();
}
public:
property int Priority {
    int get ();
}
member Priority : int with get
member Priority : int with get

Property Value

Type: Online Int32
See Also
CacheRec Class
CacheRec Members
NFX.DataAccess.Cache Namespace


CacheRec.Value Property

CacheRec Value Property NFX Class Library

Returns the value - a reference to cached item such as a business object

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Value { get; }
public Object Value { get; }
Public ReadOnly Property Value As Object
    Get
Public ReadOnly Property Value As Object
    Get
public:
property Object^ Value {
    Object^ get ();
}
public:
property Object^ Value {
    Object^ get ();
}
member Value : Object with get
member Value : Object with get

Property Value

Type: Online Object
See Also
CacheRec Class
CacheRec Members
NFX.DataAccess.Cache Namespace


CacheStore Class

CacheStore Class NFX Class Library

Represents an efficient in-memory cache of expiring optionally-prioritized objects. This class is higly optimized for caching of business objects in data store implementations and does not guarantee that all hash collisions are handled, that is - some data may be overridden. The implementation relies on 2 stage hashing, where the second collision replaces the existing item with the colliding one if items are equal in their priorities. The degree of collisions is controlled by 'bucketSize' and 'recPerPage' parameters that are passed to the store per table, so basically the tables are capped at a certain size and can not change (bucketSize*recPerPage). The lookup implementation is 100% lock-free, whereas the degree of mutability-related locking is controlled by 'lockCount' per table. This class is thread safe for reading and writing cache items, however it does not guarantee instant read/write consistency between threads.
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.DataAccess.Cache CacheStore

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class CacheStore : ApplicationComponent,
    INamed, IConfigurable, IInstrumentable, IExternallyParameterized
public sealed class CacheStore : ApplicationComponent,
    INamed, IConfigurable, IInstrumentable, IExternallyParameterized
Public NotInheritable Class CacheStore
    Inherits ApplicationComponent
    Implements INamed, IConfigurable, IInstrumentable, IExternallyParameterized
Public NotInheritable Class CacheStore
    Inherits ApplicationComponent
    Implements INamed, IConfigurable, IInstrumentable, IExternallyParameterized
public ref class CacheStore sealed : public ApplicationComponent,
    INamed, IConfigurable, IInstrumentable, IExternallyParameterized
public ref class CacheStore sealed : public ApplicationComponent,
    INamed, IConfigurable, IInstrumentable, IExternallyParameterized
[<SealedAttribute>]
type CacheStore =
    class
        inherit ApplicationComponent
        interface INamed
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
[<SealedAttribute>]
type CacheStore =
    class
        inherit ApplicationComponent
        interface INamed
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
Remarks
Perfomance testing of this class vs. System.Runtime.Caching.MemoryCache storing a typical database record identified by a long key: NFX is 2.5-5 times faster for concurrent reads and takes 20% less ram. NFX is 1.3-2.5 times faster for writes
See Also
CacheStore Members
NFX.DataAccess.Cache Namespace


CacheStore Members

CacheStore Members NFX Class Library

The CacheStore type exposes the following members.
Constructors
 | Name | Description
Public method | CacheStore | Initializes a new instance of the CacheStore class
Public method | CacheStore(String) | Initializes a new instance of the CacheStore class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | Configure | Configures store from node, if node==null then store will be configured by named node of 'app/cache/store[name=X]' path, if such path is not found the store tries to find 'app/cache/store[!name]' (node without name)
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | DropTable | Drops table by name returning true if it was found and removed
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | log |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_CACHE_SECTION |
CONFIG_STORE_SECTION |
CONFIG_TABLE_SECTION |
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Count | Returns total number of records in all tables in the store
Public property | DefaultTableOptions | Sets default options for a table which is not found in TableOptions collection. If this property is null then every table assumes the set of constant values defined in Table class
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component
Public property | InstrumentationEnabled | When true, emits instrumentation messages
Protected property | isRunning |
Public property | Item String | Returns a table by its name creating its' instance if such table is not in the set. Table names are case-insensitive
Public property | Item String, UInt64 | Returns a cached record from named table identified by the key or null if this item was not found
Public property | Name | Returns store name which can be used to identify stores in registries and instrumentation/telemetry outputs
Public property | ParallelSweep | When enabled, uses parallel execution while sweeping tables, otherwise sweeps sequentially (default behavior)
Public property | TableOptions | Returns table options - used for table creation
Public property | Tables | Returns all tables that this store currently contains
Back to Top
See Also
CacheStore Class
NFX.DataAccess.Cache Namespace


CacheStore Constructor

CacheStore Constructor NFX Class Library

Overload List
 | Name | Description
Public method | CacheStore | Initializes a new instance of the CacheStore class
Public method | CacheStore(String) | Initializes a new instance of the CacheStore class
Back to Top
See Also
CacheStore Class
CacheStore Members
NFX.DataAccess.Cache Namespace


CacheStore Constructor

CacheStore Constructor NFX Class Library

Initializes a new instance of the CacheStore class

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CacheStore()
public CacheStore()
Public Sub New
Public Sub New
public:
CacheStore()
public:
CacheStore()
new : unit -> CacheStore
new : unit -> CacheStore
See Also
CacheStore Class
CacheStore Members
CacheStore Overload
NFX.DataAccess.Cache Namespace


CacheStore Constructor (String)

CacheStore Constructor (String) NFX Class Library

Initializes a new instance of the CacheStore class

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CacheStore(
    string name
)
public CacheStore(
    string name
)
Public Sub New (
    name As String
)
Public Sub New (
    name As String
)
public:
CacheStore(
    String^ name
)
public:
CacheStore(
    String^ name
)
new :
        name : string -> CacheStore
new :
        name : string -> CacheStore

Parameters

name
Type: Online System String
See Also
CacheStore Class
CacheStore Members
CacheStore Overload
NFX.DataAccess.Cache Namespace


CacheStore Fields

CacheStore Fields NFX Class Library

The CacheStore type exposes the following members.
Fields
Name | Description
CONFIG_CACHE_SECTION |
CONFIG_STORE_SECTION |
CONFIG_TABLE_SECTION |
Back to Top
See Also
CacheStore Class
NFX.DataAccess.Cache Namespace


CacheStore.CONFIG_CACHE_SECTION Field

CacheStore CONFIG_CACHE_SECTION Field NFX Class Library

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CACHE_SECTION
public const string CONFIG_CACHE_SECTION
Public Const CONFIG_CACHE_SECTION As String
Public Const CONFIG_CACHE_SECTION As String
public:
literal String^ CONFIG_CACHE_SECTION
public:
literal String^ CONFIG_CACHE_SECTION
static val mutable CONFIG_CACHE_SECTION: string
static val mutable CONFIG_CACHE_SECTION: string

Field Value

Type: Online String
See Also
CacheStore Class
CacheStore Members
NFX.DataAccess.Cache Namespace


CacheStore.CONFIG_STORE_SECTION Field

CacheStore CONFIG_STORE_SECTION Field NFX Class Library

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_STORE_SECTION
public const string CONFIG_STORE_SECTION
Public Const CONFIG_STORE_SECTION As String
Public Const CONFIG_STORE_SECTION As String
public:
literal String^ CONFIG_STORE_SECTION
public:
literal String^ CONFIG_STORE_SECTION
static val mutable CONFIG_STORE_SECTION: string
static val mutable CONFIG_STORE_SECTION: string

Field Value

Type: Online String
See Also
CacheStore Class
CacheStore Members
NFX.DataAccess.Cache Namespace


CacheStore.CONFIG_TABLE_SECTION Field

CacheStore CONFIG_TABLE_SECTION Field NFX Class Library

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_TABLE_SECTION
public const string CONFIG_TABLE_SECTION
Public Const CONFIG_TABLE_SECTION As String
Public Const CONFIG_TABLE_SECTION As String
public:
literal String^ CONFIG_TABLE_SECTION
public:
literal String^ CONFIG_TABLE_SECTION
static val mutable CONFIG_TABLE_SECTION: string
static val mutable CONFIG_TABLE_SECTION: string

Field Value

Type: Online String
See Also
CacheStore Class
CacheStore Members
NFX.DataAccess.Cache Namespace


CacheStore Methods

CacheStore Methods NFX Class Library

The CacheStore type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | Configure | Configures store from node, if node==null then store will be configured by named node of 'app/cache/store[name=X]' path, if such path is not found the store tries to find 'app/cache/store[!name]' (node without name)
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | DropTable | Drops table by name returning true if it was found and removed
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | log |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CacheStore Class
NFX.DataAccess.Cache Namespace


CacheStore.Configure Method

CacheStore Configure Method NFX Class Library

Configures store from node, if node==null then store will be configured by named node of 'app/cache/store[name=X]' path, if such path is not found the store tries to find 'app/cache/store[!name]' (node without name)

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode node
)
public void Configure(
    IConfigSectionNode node
)
Public Sub Configure (
    node As IConfigSectionNode
)
Public Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
CacheStore Class
CacheStore Members
NFX.DataAccess.Cache Namespace


CacheStore.Destructor Method

CacheStore Destructor Method NFX Class Library

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
CacheStore Class
CacheStore Members
NFX.DataAccess.Cache Namespace


CacheStore.DropTable Method

CacheStore DropTable Method NFX Class Library

Drops table by name returning true if it was found and removed

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool DropTable(
    string name
)
public bool DropTable(
    string name
)
Public Function DropTable (
    name As String
) As Boolean
Public Function DropTable (
    name As String
) As Boolean
public:
bool DropTable(
    String^ name
)
public:
bool DropTable(
    String^ name
)
member DropTable :
        name : string -> bool
member DropTable :
        name : string -> bool

Parameters

name
Type: Online System String

Return Value

Type: Online Boolean
See Also
CacheStore Class
CacheStore Members
NFX.DataAccess.Cache Namespace


CacheStore.ExternalGetParameter Method

CacheStore ExternalGetParameter Method NFX Class Library

Gets external parameter value returning true if parameter was found

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
public bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
Public Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
Public Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
) sealed
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
) sealed
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalGetParameter(String, Object , String )
See Also
CacheStore Class
CacheStore Members
NFX.DataAccess.Cache Namespace


CacheStore.ExternalParametersForGroups Method

CacheStore ExternalParametersForGroups Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns named parameters that can be used to control this component

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
public IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
Public Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
Public Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
) sealed
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
) sealed
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>

Parameters

groups
Type: Online System String

Return Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParametersForGroups( String )
See Also
CacheStore Class
CacheStore Members
NFX.DataAccess.Cache Namespace


CacheStore.ExternalSetParameter Method

CacheStore ExternalSetParameter Method NFX Class Library

Sets external parameter value returning true if parameter was found and set

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
public bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
Public Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
Public Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
) sealed
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
) sealed
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalSetParameter(String, Object, String )
See Also
CacheStore Class
CacheStore Members
NFX.DataAccess.Cache Namespace


CacheStore.log Method

CacheStore log Method NFX Class Library

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void log(
    MessageType type,
    string message,
    Exception error = null,
    string parameters = null
)
internal void log(
    MessageType type,
    string message,
    Exception error = null,
    string parameters = null
)
Friend Sub log (
    type As MessageType,
    message As String,
    Optional error As Exception = Nothing,
    Optional parameters As String = Nothing
)
Friend Sub log (
    type As MessageType,
    message As String,
    Optional error As Exception = Nothing,
    Optional parameters As String = Nothing
)
internal:
void log(
    MessageType type,
    String^ message,
    Exception^ error = nullptr,
    String^ parameters = nullptr
)
internal:
void log(
    MessageType type,
    String^ message,
    Exception^ error = nullptr,
    String^ parameters = nullptr
)
internal member log :
        type : MessageType *
        message : string *
        ?error : Exception *
        ?parameters : string
(* Defaults:
        let _error = defaultArg error null
        let _parameters = defaultArg parameters null
*)
-> unit
internal member log :
        type : MessageType *
        message : string *
        ?error : Exception *
        ?parameters : string
(* Defaults:
        let _error = defaultArg error null
        let _parameters = defaultArg parameters null
*)
-> unit

Parameters

type
Type: NFX.Log MessageType
message
Type: Online System String
error (Optional)
Type: Online System Exception
parameters (Optional)
Type: Online System String
See Also
CacheStore Class
CacheStore Members
NFX.DataAccess.Cache Namespace


CacheStore Properties

CacheStore Properties NFX Class Library

The CacheStore type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Count | Returns total number of records in all tables in the store
Public property | DefaultTableOptions | Sets default options for a table which is not found in TableOptions collection. If this property is null then every table assumes the set of constant values defined in Table class
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component
Public property | InstrumentationEnabled | When true, emits instrumentation messages
Protected property | isRunning |
Public property | Item String | Returns a table by its name creating its' instance if such table is not in the set. Table names are case-insensitive
Public property | Item String, UInt64 | Returns a cached record from named table identified by the key or null if this item was not found
Public property | Name | Returns store name which can be used to identify stores in registries and instrumentation/telemetry outputs
Public property | ParallelSweep | When enabled, uses parallel execution while sweeping tables, otherwise sweeps sequentially (default behavior)
Public property | TableOptions | Returns table options - used for table creation
Public property | Tables | Returns all tables that this store currently contains
Back to Top
See Also
CacheStore Class
NFX.DataAccess.Cache Namespace


CacheStore.Count Property

CacheStore Count Property NFX Class Library

Returns total number of records in all tables in the store

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
public:
property int Count {
    int get ();
}
member Count : int with get
member Count : int with get

Property Value

Type: Online Int32
See Also
CacheStore Class
CacheStore Members
NFX.DataAccess.Cache Namespace


CacheStore.DefaultTableOptions Property

CacheStore DefaultTableOptions Property NFX Class Library

Sets default options for a table which is not found in TableOptions collection. If this property is null then every table assumes the set of constant values defined in Table class

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TableOptions DefaultTableOptions { get; set; }
public TableOptions DefaultTableOptions { get; set; }
Public Property DefaultTableOptions As TableOptions
    Get
    Set
Public Property DefaultTableOptions As TableOptions
    Get
    Set
public:
property TableOptions^ DefaultTableOptions {
    TableOptions^ get ();
    void set (TableOptions^ value);
}
public:
property TableOptions^ DefaultTableOptions {
    TableOptions^ get ();
    void set (TableOptions^ value);
}
member DefaultTableOptions : TableOptions with get, set
member DefaultTableOptions : TableOptions with get, set

Property Value

Type: TableOptions
See Also
CacheStore Class
CacheStore Members
NFX.DataAccess.Cache Namespace


CacheStore.ExternalParameters Property

CacheStore ExternalParameters Property NFX Class Library

Returns named parameters that can be used to control this component

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
public IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
Public ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
Public ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get () sealed;
}
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get () sealed;
}
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get

Property Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParameters
See Also
CacheStore Class
CacheStore Members
NFX.DataAccess.Cache Namespace


CacheStore.InstrumentationEnabled Property

CacheStore InstrumentationEnabled Property NFX Class Library

When true, emits instrumentation messages

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute]
public bool InstrumentationEnabled { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute]
public bool InstrumentationEnabled { get; set; }
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute>
Public Property InstrumentationEnabled As Boolean
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute>
Public Property InstrumentationEnabled As Boolean
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute]
virtual property bool InstrumentationEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute]
virtual property bool InstrumentationEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute>]
abstract InstrumentationEnabled : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute>]
override InstrumentationEnabled : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute>]
abstract InstrumentationEnabled : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute>]
override InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentable InstrumentationEnabled
See Also
CacheStore Class
CacheStore Members
NFX.DataAccess.Cache Namespace


CacheStore.isRunning Property

CacheStore isRunning Property NFX Class Library

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal bool isRunning { get; }
internal bool isRunning { get; }
Friend ReadOnly Property isRunning As Boolean
    Get
Friend ReadOnly Property isRunning As Boolean
    Get
internal:
property bool isRunning {
    bool get ();
}
internal:
property bool isRunning {
    bool get ();
}
internal member isRunning : bool with get
internal member isRunning : bool with get

Property Value

Type: Online Boolean
See Also
CacheStore Class
CacheStore Members
NFX.DataAccess.Cache Namespace


CacheStore.Item Property

CacheStore Item Property NFX Class Library

Overload List
 | Name | Description
Public property | Item String | Returns a table by its name creating its' instance if such table is not in the set. Table names are case-insensitive
Public property | Item String, UInt64 | Returns a cached record from named table identified by the key or null if this item was not found
Back to Top
See Also
CacheStore Class
CacheStore Members
NFX.DataAccess.Cache Namespace


CacheStore.Item Property (String)

CacheStore Item Property (String) NFX Class Library

Returns a table by its name creating its' instance if such table is not in the set. Table names are case-insensitive

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Table this[
    string table
] { get; }
public Table this[
    string table
] { get; }
Public ReadOnly Default Property Item (
    table As String
) As Table
    Get
Public ReadOnly Default Property Item (
    table As String
) As Table
    Get
public:
property Table^ default[String^ table] {
    Table^ get (String^ table);
}
public:
property Table^ default[String^ table] {
    Table^ get (String^ table);
}
member Item : Table with get
member Item : Table with get

Parameters

table
Type: Online System String

Property Value

Type: Table
See Also
CacheStore Class
CacheStore Members
Item Overload
NFX.DataAccess.Cache Namespace


CacheStore.Item Property (String, UInt64)

CacheStore Item Property (String, UInt64) NFX Class Library

Returns a cached record from named table identified by the key or null if this item was not found

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CacheRec this[
    string table,
    ulong key
] { get; }
public CacheRec this[
    string table,
    ulong key
] { get; }
Public ReadOnly Default Property Item (
    table As String,
    key As ULong
) As CacheRec
    Get
Public ReadOnly Default Property Item (
    table As String,
    key As ULong
) As CacheRec
    Get
public:
property CacheRec^ default[String^ table, unsigned long long key] {
    CacheRec^ get (String^ table, unsigned long long key);
}
public:
property CacheRec^ default[String^ table, unsigned long long key] {
    CacheRec^ get (String^ table, unsigned long long key);
}
member Item : CacheRec with get
member Item : CacheRec with get

Parameters

table
Type: Online System String
key
Type: Online System UInt64

Property Value

Type: CacheRec
See Also
CacheStore Class
CacheStore Members
Item Overload
NFX.DataAccess.Cache Namespace


CacheStore.Name Property

CacheStore Name Property NFX Class Library

Returns store name which can be used to identify stores in registries and instrumentation/telemetry outputs

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
CacheStore Class
CacheStore Members
NFX.DataAccess.Cache Namespace


CacheStore.ParallelSweep Property

CacheStore ParallelSweep Property NFX Class Library

When enabled, uses parallel execution while sweeping tables, otherwise sweeps sequentially (default behavior)

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public bool ParallelSweep { get; set; }
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public bool ParallelSweep { get; set; }
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property ParallelSweep As Boolean
    Get
    Set
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property ParallelSweep As Boolean
    Get
    Set
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property bool ParallelSweep {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property bool ParallelSweep {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
member ParallelSweep : bool with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
member ParallelSweep : bool with get, set

Property Value

Type: Online Boolean
See Also
CacheStore Class
CacheStore Members
NFX.DataAccess.Cache Namespace


CacheStore.TableOptions Property

CacheStore TableOptions Property NFX Class Library

Returns table options - used for table creation

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Registry<TableOptions> TableOptions { get; }
public Registry<TableOptions> TableOptions { get; }
Public ReadOnly Property TableOptions As Registry(Of TableOptions)
    Get
Public ReadOnly Property TableOptions As Registry(Of TableOptions)
    Get
public:
property Registry<TableOptions^>^ TableOptions {
    Registry<TableOptions^>^ get ();
}
public:
property Registry<TableOptions^>^ TableOptions {
    Registry<TableOptions^>^ get ();
}
member TableOptions : Registry<TableOptions> with get
member TableOptions : Registry<TableOptions> with get

Property Value

Type: Registry TableOptions
See Also
CacheStore Class
CacheStore Members
NFX.DataAccess.Cache Namespace


CacheStore.Tables Property

CacheStore Tables Property NFX Class Library

Returns all tables that this store currently contains

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<Table> Tables { get; }
public IRegistry<Table> Tables { get; }
Public ReadOnly Property Tables As IRegistry(Of Table)
    Get
Public ReadOnly Property Tables As IRegistry(Of Table)
    Get
public:
property IRegistry<Table^>^ Tables {
    IRegistry<Table^>^ get ();
}
public:
property IRegistry<Table^>^ Tables {
    IRegistry<Table^>^ get ();
}
member Tables : IRegistry<Table> with get
member Tables : IRegistry<Table> with get

Property Value

Type: IRegistry Table
See Also
CacheStore Class
CacheStore Members
NFX.DataAccess.Cache Namespace


ComplexKeyHashingStrategy Class

ComplexKeyHashingStrategy Class NFX Class Library

Provides hashing strategy for keys that are not scalar uint64. This is a companion class for CacheStore which only understands uint64 as keys for efficiency purposes. One may extend this class to implement custom resolution of complex keys into uint64 hashes and provide collision handling. The base implementation uses object.GetHashCode() with chaining for collision resolution
Inheritance Hierarchy
Online System Object
NFX.DataAccess.Cache ComplexKeyHashingStrategy

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ComplexKeyHashingStrategy
public class ComplexKeyHashingStrategy
Public Class ComplexKeyHashingStrategy
Public Class ComplexKeyHashingStrategy
public ref class ComplexKeyHashingStrategy
public ref class ComplexKeyHashingStrategy
type ComplexKeyHashingStrategy =  class end
type ComplexKeyHashingStrategy =  class end
See Also
ComplexKeyHashingStrategy Members
NFX.DataAccess.Cache Namespace


ComplexKeyHashingStrategy Members

ComplexKeyHashingStrategy Members NFX Class Library

The ComplexKeyHashingStrategy type exposes the following members.
Constructors
 | Name | Description
Public method | ComplexKeyHashingStrategy | Initializes a new instance of the ComplexKeyHashingStrategy class
Back to Top
Methods
 | Name | Description
Public method | ComplexKeyToCacheKey | Override to convert complex object to uint64 key. The default implementation returns DefaultComplexKeyToCacheKey(key)
 | DefaultComplexKeyToCacheKey | Default implementation that converts complex object to uint64 key. The default implementation returns the hashcode of the object unless the key is string in which case it calls DefaultStringKeyToCacheKey() or IULongHashProvider(GDID and parcels). The function is not deterministic due to the use of .GetHashCode() that may change between release for some objects (depends on object implementation), so the returned value should not be persisted
 | DefaultStringKeyToCacheKey | Provides default implementation for converting string keys into uint64 hash. This functions provides the best selectivity for strings that are 8 chars long or less. The function is NOT deterministic as it uses .GetHashCode(), so the returned value should not be persisted
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get | Override to get a value keyed on a non-uint64 scalar from cache. Returns null when item does not exist
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Put | Override to put a value keyed on a non-uint64 scalar into cache. Returns table.Put() result
Public method | Remove | Override to remove an item keyed on a non-uint64 scalar from cache. Returns true if remove found and removed item from table
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | MAX_CACHE_CHAIN_LENGTH | How many times hash will be adjusted while chaining
Public field | Store | References cachestore that this strategy works with
Back to Top
See Also
ComplexKeyHashingStrategy Class
NFX.DataAccess.Cache Namespace


ComplexKeyHashingStrategy Constructor

ComplexKeyHashingStrategy Constructor NFX Class Library

Initializes a new instance of the ComplexKeyHashingStrategy class

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ComplexKeyHashingStrategy(
    CacheStore store
)
public ComplexKeyHashingStrategy(
    CacheStore store
)
Public Sub New (
    store As CacheStore
)
Public Sub New (
    store As CacheStore
)
public:
ComplexKeyHashingStrategy(
    CacheStore^ store
)
public:
ComplexKeyHashingStrategy(
    CacheStore^ store
)
new :
        store : CacheStore -> ComplexKeyHashingStrategy
new :
        store : CacheStore -> ComplexKeyHashingStrategy

Parameters

store
Type: NFX.DataAccess.Cache CacheStore
See Also
ComplexKeyHashingStrategy Class
ComplexKeyHashingStrategy Members
NFX.DataAccess.Cache Namespace


ComplexKeyHashingStrategy Fields

ComplexKeyHashingStrategy Fields NFX Class Library

The ComplexKeyHashingStrategy type exposes the following members.
Fields
 | Name | Description
 | MAX_CACHE_CHAIN_LENGTH | How many times hash will be adjusted while chaining
Public field | Store | References cachestore that this strategy works with
Back to Top
See Also
ComplexKeyHashingStrategy Class
NFX.DataAccess.Cache Namespace


ComplexKeyHashingStrategy.MAX_CACHE_CHAIN_LENGTH Field

ComplexKeyHashingStrategy MAX_CACHE_CHAIN_LENGTH Field NFX Class Library

[This is preliminary documentation and is subject to change.]

How many times hash will be adjusted while chaining

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_CACHE_CHAIN_LENGTH
public const int MAX_CACHE_CHAIN_LENGTH
Public Const MAX_CACHE_CHAIN_LENGTH As Integer
Public Const MAX_CACHE_CHAIN_LENGTH As Integer
public:
literal int MAX_CACHE_CHAIN_LENGTH
public:
literal int MAX_CACHE_CHAIN_LENGTH
static val mutable MAX_CACHE_CHAIN_LENGTH: int
static val mutable MAX_CACHE_CHAIN_LENGTH: int

Field Value

Type: Online Int32
See Also
ComplexKeyHashingStrategy Class
ComplexKeyHashingStrategy Members
NFX.DataAccess.Cache Namespace


ComplexKeyHashingStrategy.Store Field

ComplexKeyHashingStrategy Store Field NFX Class Library

References cachestore that this strategy works with

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly CacheStore Store
public readonly CacheStore Store
Public ReadOnly Store As CacheStore
Public ReadOnly Store As CacheStore
public:
initonly CacheStore^ Store
public:
initonly CacheStore^ Store
val Store: CacheStore
val Store: CacheStore

Field Value

Type: CacheStore
See Also
ComplexKeyHashingStrategy Class
ComplexKeyHashingStrategy Members
NFX.DataAccess.Cache Namespace


ComplexKeyHashingStrategy Methods

ComplexKeyHashingStrategy Methods NFX Class Library

The ComplexKeyHashingStrategy type exposes the following members.
Methods
 | Name | Description
Public method | ComplexKeyToCacheKey | Override to convert complex object to uint64 key. The default implementation returns DefaultComplexKeyToCacheKey(key)
 | DefaultComplexKeyToCacheKey | Default implementation that converts complex object to uint64 key. The default implementation returns the hashcode of the object unless the key is string in which case it calls DefaultStringKeyToCacheKey() or IULongHashProvider(GDID and parcels). The function is not deterministic due to the use of .GetHashCode() that may change between release for some objects (depends on object implementation), so the returned value should not be persisted
 | DefaultStringKeyToCacheKey | Provides default implementation for converting string keys into uint64 hash. This functions provides the best selectivity for strings that are 8 chars long or less. The function is NOT deterministic as it uses .GetHashCode(), so the returned value should not be persisted
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get | Override to get a value keyed on a non-uint64 scalar from cache. Returns null when item does not exist
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Put | Override to put a value keyed on a non-uint64 scalar into cache. Returns table.Put() result
Public method | Remove | Override to remove an item keyed on a non-uint64 scalar from cache. Returns true if remove found and removed item from table
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ComplexKeyHashingStrategy Class
NFX.DataAccess.Cache Namespace


ComplexKeyHashingStrategy.ComplexKeyToCacheKey Method

ComplexKeyHashingStrategy ComplexKeyToCacheKey Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to convert complex object to uint64 key. The default implementation returns DefaultComplexKeyToCacheKey(key)

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual ulong ComplexKeyToCacheKey(
    Object key
)
public virtual ulong ComplexKeyToCacheKey(
    Object key
)
Public Overridable Function ComplexKeyToCacheKey (
    key As Object
) As ULong
Public Overridable Function ComplexKeyToCacheKey (
    key As Object
) As ULong
public:
virtual unsigned long long ComplexKeyToCacheKey(
    Object^ key
)
public:
virtual unsigned long long ComplexKeyToCacheKey(
    Object^ key
)
abstract ComplexKeyToCacheKey :
        key : Object -> uint64
override ComplexKeyToCacheKey :
        key : Object -> uint64
abstract ComplexKeyToCacheKey :
        key : Object -> uint64
override ComplexKeyToCacheKey :
        key : Object -> uint64

Parameters

key
Type: Online System Object

Return Value

Type: Online UInt64
See Also
ComplexKeyHashingStrategy Class
ComplexKeyHashingStrategy Members
NFX.DataAccess.Cache Namespace


ComplexKeyHashingStrategy.DefaultComplexKeyToCacheKey Method

ComplexKeyHashingStrategy DefaultComplexKeyToCacheKey Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Default implementation that converts complex object to uint64 key. The default implementation returns the hashcode of the object unless the key is string in which case it calls DefaultStringKeyToCacheKey() or IULongHashProvider(GDID and parcels). The function is not deterministic due to the use of .GetHashCode() that may change between release for some objects (depends on object implementation), so the returned value should not be persisted

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ulong DefaultComplexKeyToCacheKey(
    Object key
)
public static ulong DefaultComplexKeyToCacheKey(
    Object key
)
Public Shared Function DefaultComplexKeyToCacheKey (
    key As Object
) As ULong
Public Shared Function DefaultComplexKeyToCacheKey (
    key As Object
) As ULong
public:
static unsigned long long DefaultComplexKeyToCacheKey(
    Object^ key
)
public:
static unsigned long long DefaultComplexKeyToCacheKey(
    Object^ key
)
static member DefaultComplexKeyToCacheKey :
        key : Object -> uint64
static member DefaultComplexKeyToCacheKey :
        key : Object -> uint64

Parameters

key
Type: Online System Object

Return Value

Type: Online UInt64
See Also
ComplexKeyHashingStrategy Class
ComplexKeyHashingStrategy Members
NFX.DataAccess.Cache Namespace


ComplexKeyHashingStrategy.DefaultStringKeyToCacheKey Method

ComplexKeyHashingStrategy DefaultStringKeyToCacheKey Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Provides default implementation for converting string keys into uint64 hash. This functions provides the best selectivity for strings that are 8 chars long or less. The function is NOT deterministic as it uses .GetHashCode(), so the returned value should not be persisted

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ulong DefaultStringKeyToCacheKey(
    string key
)
public static ulong DefaultStringKeyToCacheKey(
    string key
)
Public Shared Function DefaultStringKeyToCacheKey (
    key As String
) As ULong
Public Shared Function DefaultStringKeyToCacheKey (
    key As String
) As ULong
public:
static unsigned long long DefaultStringKeyToCacheKey(
    String^ key
)
public:
static unsigned long long DefaultStringKeyToCacheKey(
    String^ key
)
static member DefaultStringKeyToCacheKey :
        key : string -> uint64
static member DefaultStringKeyToCacheKey :
        key : string -> uint64

Parameters

key
Type: Online System String

Return Value

Type: Online UInt64
See Also
ComplexKeyHashingStrategy Class
ComplexKeyHashingStrategy Members
NFX.DataAccess.Cache Namespace


ComplexKeyHashingStrategy.Get Method

ComplexKeyHashingStrategy Get Method NFX Class Library

Override to get a value keyed on a non-uint64 scalar from cache. Returns null when item does not exist

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object Get(
    string tableName,
    Object key,
    int ageSec = 0
)
public virtual Object Get(
    string tableName,
    Object key,
    int ageSec = 0
)
Public Overridable Function Get (
    tableName As String,
    key As Object,
    Optional ageSec As Integer = 0
) As Object
Public Overridable Function Get (
    tableName As String,
    key As Object,
    Optional ageSec As Integer = 0
) As Object
public:
virtual Object^ Get(
    String^ tableName,
    Object^ key,
    int ageSec = 0
)
public:
virtual Object^ Get(
    String^ tableName,
    Object^ key,
    int ageSec = 0
)
abstract Get :
        tableName : string *
        key : Object *
        ?ageSec : int
(* Defaults:
        let _ageSec = defaultArg ageSec 0
*)
-> Object
override Get :
        tableName : string *
        key : Object *
        ?ageSec : int
(* Defaults:
        let _ageSec = defaultArg ageSec 0
*)
-> Object
abstract Get :
        tableName : string *
        key : Object *
        ?ageSec : int
(* Defaults:
        let _ageSec = defaultArg ageSec 0
*)
-> Object
override Get :
        tableName : string *
        key : Object *
        ?ageSec : int
(* Defaults:
        let _ageSec = defaultArg ageSec 0
*)
-> Object

Parameters

tableName
Type: Online System String
key
Type: Online System Object
ageSec (Optional)
Type: Online System Int32

Return Value

Type: Online Object
See Also
ComplexKeyHashingStrategy Class
ComplexKeyHashingStrategy Members
NFX.DataAccess.Cache Namespace


ComplexKeyHashingStrategy.Put Method

ComplexKeyHashingStrategy Put Method NFX Class Library

Override to put a value keyed on a non-uint64 scalar into cache. Returns table.Put() result

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Put(
    string tableName,
    Object key,
    Object value,
    int maxAgeSec = 0,
    int priority = 0,
    Nullable<DateTime> absoluteExpirationUTC = null
)
public virtual bool Put(
    string tableName,
    Object key,
    Object value,
    int maxAgeSec = 0,
    int priority = 0,
    Nullable<DateTime> absoluteExpirationUTC = null
)
Public Overridable Function Put (
    tableName As String,
    key As Object,
    value As Object,
    Optional maxAgeSec As Integer = 0,
    Optional priority As Integer = 0,
    Optional absoluteExpirationUTC As Nullable(Of DateTime) = Nothing
) As Boolean
Public Overridable Function Put (
    tableName As String,
    key As Object,
    value As Object,
    Optional maxAgeSec As Integer = 0,
    Optional priority As Integer = 0,
    Optional absoluteExpirationUTC As Nullable(Of DateTime) = Nothing
) As Boolean
public:
virtual bool Put(
    String^ tableName,
    Object^ key,
    Object^ value,
    int maxAgeSec = 0,
    int priority = 0,
    Nullable<DateTime> absoluteExpirationUTC = nullptr
)
public:
virtual bool Put(
    String^ tableName,
    Object^ key,
    Object^ value,
    int maxAgeSec = 0,
    int priority = 0,
    Nullable<DateTime> absoluteExpirationUTC = nullptr
)
abstract Put :
        tableName : string *
        key : Object *
        value : Object *
        ?maxAgeSec : int *
        ?priority : int *
        ?absoluteExpirationUTC : Nullable<DateTime>
(* Defaults:
        let _maxAgeSec = defaultArg maxAgeSec 0
        let _priority = defaultArg priority 0
        let _absoluteExpirationUTC = defaultArg absoluteExpirationUTC null
*)
-> bool
override Put :
        tableName : string *
        key : Object *
        value : Object *
        ?maxAgeSec : int *
        ?priority : int *
        ?absoluteExpirationUTC : Nullable<DateTime>
(* Defaults:
        let _maxAgeSec = defaultArg maxAgeSec 0
        let _priority = defaultArg priority 0
        let _absoluteExpirationUTC = defaultArg absoluteExpirationUTC null
*)
-> bool
abstract Put :
        tableName : string *
        key : Object *
        value : Object *
        ?maxAgeSec : int *
        ?priority : int *
        ?absoluteExpirationUTC : Nullable<DateTime>
(* Defaults:
        let _maxAgeSec = defaultArg maxAgeSec 0
        let _priority = defaultArg priority 0
        let _absoluteExpirationUTC = defaultArg absoluteExpirationUTC null
*)
-> bool
override Put :
        tableName : string *
        key : Object *
        value : Object *
        ?maxAgeSec : int *
        ?priority : int *
        ?absoluteExpirationUTC : Nullable<DateTime>
(* Defaults:
        let _maxAgeSec = defaultArg maxAgeSec 0
        let _priority = defaultArg priority 0
        let _absoluteExpirationUTC = defaultArg absoluteExpirationUTC null
*)
-> bool

Parameters

tableName
Type: Online System String
key
Type: Online System Object
value
Type: Online System Object
maxAgeSec (Optional)
Type: Online System Int32
priority (Optional)
Type: Online System Int32
absoluteExpirationUTC (Optional)
Type: Online System Nullable Online DateTime

Return Value

Type: Online Boolean
See Also
ComplexKeyHashingStrategy Class
ComplexKeyHashingStrategy Members
NFX.DataAccess.Cache Namespace


ComplexKeyHashingStrategy.Remove Method

ComplexKeyHashingStrategy Remove Method NFX Class Library

Override to remove an item keyed on a non-uint64 scalar from cache. Returns true if remove found and removed item from table

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Remove(
    string tableName,
    Object key
)
public virtual bool Remove(
    string tableName,
    Object key
)
Public Overridable Function Remove (
    tableName As String,
    key As Object
) As Boolean
Public Overridable Function Remove (
    tableName As String,
    key As Object
) As Boolean
public:
virtual bool Remove(
    String^ tableName,
    Object^ key
)
public:
virtual bool Remove(
    String^ tableName,
    Object^ key
)
abstract Remove :
        tableName : string *
        key : Object -> bool
override Remove :
        tableName : string *
        key : Object -> bool
abstract Remove :
        tableName : string *
        key : Object -> bool
override Remove :
        tableName : string *
        key : Object -> bool

Parameters

tableName
Type: Online System String
key
Type: Online System Object

Return Value

Type: Online Boolean
See Also
ComplexKeyHashingStrategy Class
ComplexKeyHashingStrategy Members
NFX.DataAccess.Cache Namespace


Page Class

Page Class NFX Class Library

A composite item that stores collection of CacheRecs and can be placed into a hashing bucket
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.DataAccess.Cache Bucketed
NFX.DataAccess.Cache Page

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal sealed class Page : Bucketed
internal sealed class Page : Bucketed
Friend NotInheritable Class Page
    Inherits Bucketed
Friend NotInheritable Class Page
    Inherits Bucketed
internal ref class Page sealed : public Bucketed
internal ref class Page sealed : public Bucketed
[<SealedAttribute>]
type Page =
    class
        inherit Bucketed
    end
[<SealedAttribute>]
type Page =
    class
        inherit Bucketed
    end
See Also
Page Members
NFX.DataAccess.Cache Namespace


Page Members

Page Members NFX Class Library

The Page type exposes the following members.
Constructors
 | Name | Description
Protected method | Page | Initializes a new instance of the Page class
Back to Top
Methods
 | Name | Description
Protected method | Destructor | Override this method to do actual destructor work (Inherited from DisposableObject.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Records |
Back to Top
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Back to Top
See Also
Page Class
NFX.DataAccess.Cache Namespace


Page Constructor

Page Constructor NFX Class Library

Initializes a new instance of the Page class

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Page(
    int recPerPage
)
internal Page(
    int recPerPage
)
Friend Sub New (
    recPerPage As Integer
)
Friend Sub New (
    recPerPage As Integer
)
internal:
Page(
    int recPerPage
)
internal:
Page(
    int recPerPage
)
new :
        recPerPage : int -> Page
new :
        recPerPage : int -> Page

Parameters

recPerPage
Type: Online System Int32
See Also
Page Class
Page Members
NFX.DataAccess.Cache Namespace


Page Fields

Page Fields NFX Class Library

The Page type exposes the following members.
Fields
 | Name | Description
Protected field | m_Records |
Back to Top
See Also
Page Class
NFX.DataAccess.Cache Namespace


Page.m_Records Field

Page m_Records Field NFX Class Library

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CacheRec[] m_Records
internal CacheRec[] m_Records
Friend m_Records As CacheRec()
Friend m_Records As CacheRec()
internal:
array<CacheRec^>^ m_Records
internal:
array<CacheRec^>^ m_Records
val mutable internal m_Records: CacheRec[]
val mutable internal m_Records: CacheRec[]

Field Value

Type: CacheRec
See Also
Page Class
Page Members
NFX.DataAccess.Cache Namespace


Page Methods

Page Methods NFX Class Library

The Page type exposes the following members.
Methods
 | Name | Description
Protected method | Destructor | Override this method to do actual destructor work (Inherited from DisposableObject.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Page Class
NFX.DataAccess.Cache Namespace


Page Properties

Page Properties NFX Class Library

The Page type exposes the following members.
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Back to Top
See Also
Page Class
NFX.DataAccess.Cache Namespace


Table Class

Table Class NFX Class Library

Represents a table that stores cached items identified by keys
Inheritance Hierarchy
Online System Object
NFX.DataAccess.Cache Table

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Table : INamed
public sealed class Table : INamed
Public NotInheritable Class Table
    Implements INamed
Public NotInheritable Class Table
    Implements INamed
public ref class Table sealed : INamed
public ref class Table sealed : INamed
[<SealedAttribute>]
type Table =
    class
        interface INamed
    end
[<SealedAttribute>]
type Table =
    class
        interface INamed
    end
See Also
Table Members
NFX.DataAccess.Cache Namespace


Table Members

Table Members NFX Class Library

The Table type exposes the following members.
Constructors
 | Name | Description
Protected method | Table | Initializes a new instance of the Table class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get | Retrieves an item from this table by key where item age is less or equal to requested, or null if it does not exist
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetOrPut TContext | Retrieves an item from this table by key where item age is less or equal to requested, or calls the itemFactory function and inserts the value in the store
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Put(UInt64, Object, Int32, Int32, Nullable DateTime ) | Puts a key-identified item into this table. If item with such key is already in this table then replaces it and returns false, returns true otherwise
Public method | Put(UInt64, Object, CacheRec , Int32, Int32, Nullable DateTime ) | Puts a key-identified item into this table. If item with such key is already in this table then replaces it and returns false, returns true otherwise
Public method | Remove | Removes a key-identified item from the named table returning true when item was deleted or false when item was not found
Protected method | Sweep |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | BUCKET_COUNT_DEFAULT |
 | MAX_AGE_SEC_DEFAULT |
 | MAX_AGE_SEC_MINIMUM |
 | REC_PER_PAGE_DEFAULT |
Protected field | stat_ComplexHitCount | how many complex key hits - get was called
Protected field | stat_ComplexMissCount | how many complex key misses - get was called
Protected field | stat_HitCount | how many hits - get was called
Protected field | stat_LastTime |
Protected field | stat_MissCount | how many misses - get was called
Protected field | stat_PutCollisionCount | how many times new value overrode existing because of collision
Protected field | stat_PutCount | how many times put was called
Protected field | stat_PutInsertCount | how many times new value successfully inserted without collision
Protected field | stat_PutPageCreateCount | how many times bucket collision occured that resulted in page creation
Protected field | stat_PutPriorityPreventedCollisionCount | how many times priority prevented collision
Protected field | stat_PutReplaceCount | how many times new value successfully replaced existing one (by the same key) without collision
Protected field | stat_RemoveHitCount | how many records have been found and removed
Protected field | stat_RemoveMissCount | how many records have been sought to be removed but were not found
Protected field | stat_RemovePageCount | how many pages have been deleted, a page gets deleted when there are no records stored in it
Protected field | stat_SweepPageCount | how many pages swept
Protected field | stat_SweepRemoveCount | how many records removed by sweep
Protected field | stat_SweepTableCount | how many times swept
Protected field | stat_ValueFactoryCount | how many times factory called from GetOrPut
Back to Top
Properties
 | Name | Description
Public property | BucketCount | Returns how many slots/buckets are pre-allocated per table, the higher the number the more memory will be reserved at table construction time, every slot is a reference (4 bytes on 32bit systems, 8 bytes on 64bit). For optimal performance this number should be around 75% of total record count stored in the table (table load factor).
Public property | BucketPageLoadFactor | Returns the ratio of how many buckets are loaded with pages vs. bucket count
Public property | Capacity | Returns the maximum number of items that this table can hold at any given time given that no items will have any key hash collisions
Public property | Count | Returns item count in the table
Public property | LockCount | Returns how many locks can be used for thread coordination during table changes
Public property | MaxAgeSec | Gets/sets maximum age of items in the table expressed in seconds. After this age is exceeded, the system will delete entries. The system does not guarantee that items will expire right on time, however it does guarantee that items will be available for at least this long.
Public property | Name | Returns table name which is a unique string within the cache store
Public property | PageCount | Returns page count in the table
Public property | ParallelSweep | When enabled, uses parallel execution while sweeping table buckets, otherwise sweeps sequentially (default behavior)
Public property | RecPerPage | Returns how many slots are pre-allocated per table's bucket(page) when more than one item produces hash collision. The higher the number, the more primary hash collisions can be accomodated by re-hashing on pages (secondary hash table within primary buckets)
Public property | StatComplexHitCount | Returns hit count stats for using complex keys
Public property | StatComplexMissCount | Returns miss count stats for using complex keys
Public property | StatHitCount | Returns hit count stats
Public property | StatMissCount | Returns miss count stats
Public property | Store | Returns the store instance that this table is a part of
Back to Top
See Also
Table Class
NFX.DataAccess.Cache Namespace


Table Constructor

Table Constructor NFX Class Library

Initializes a new instance of the Table class

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Table(
    CacheStore store,
    string name,
    TableOptions opt
)
internal Table(
    CacheStore store,
    string name,
    TableOptions opt
)
Friend Sub New (
    store As CacheStore,
    name As String,
    opt As TableOptions
)
Friend Sub New (
    store As CacheStore,
    name As String,
    opt As TableOptions
)
internal:
Table(
    CacheStore^ store,
    String^ name,
    TableOptions^ opt
)
internal:
Table(
    CacheStore^ store,
    String^ name,
    TableOptions^ opt
)
new :
        store : CacheStore *
        name : string *
        opt : TableOptions -> Table
new :
        store : CacheStore *
        name : string *
        opt : TableOptions -> Table

Parameters

store
Type: NFX.DataAccess.Cache CacheStore
name
Type: Online System String
opt
Type: NFX.DataAccess.Cache TableOptions
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table Fields

Table Fields NFX Class Library

The Table type exposes the following members.
Fields
 | Name | Description
 | BUCKET_COUNT_DEFAULT |
 | MAX_AGE_SEC_DEFAULT |
 | MAX_AGE_SEC_MINIMUM |
 | REC_PER_PAGE_DEFAULT |
Protected field | stat_ComplexHitCount | how many complex key hits - get was called
Protected field | stat_ComplexMissCount | how many complex key misses - get was called
Protected field | stat_HitCount | how many hits - get was called
Protected field | stat_LastTime |
Protected field | stat_MissCount | how many misses - get was called
Protected field | stat_PutCollisionCount | how many times new value overrode existing because of collision
Protected field | stat_PutCount | how many times put was called
Protected field | stat_PutInsertCount | how many times new value successfully inserted without collision
Protected field | stat_PutPageCreateCount | how many times bucket collision occured that resulted in page creation
Protected field | stat_PutPriorityPreventedCollisionCount | how many times priority prevented collision
Protected field | stat_PutReplaceCount | how many times new value successfully replaced existing one (by the same key) without collision
Protected field | stat_RemoveHitCount | how many records have been found and removed
Protected field | stat_RemoveMissCount | how many records have been sought to be removed but were not found
Protected field | stat_RemovePageCount | how many pages have been deleted, a page gets deleted when there are no records stored in it
Protected field | stat_SweepPageCount | how many pages swept
Protected field | stat_SweepRemoveCount | how many records removed by sweep
Protected field | stat_SweepTableCount | how many times swept
Protected field | stat_ValueFactoryCount | how many times factory called from GetOrPut
Back to Top
See Also
Table Class
NFX.DataAccess.Cache Namespace


Table.BUCKET_COUNT_DEFAULT Field

Table BUCKET_COUNT_DEFAULT Field NFX Class Library

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int BUCKET_COUNT_DEFAULT
public const int BUCKET_COUNT_DEFAULT
Public Const BUCKET_COUNT_DEFAULT As Integer
Public Const BUCKET_COUNT_DEFAULT As Integer
public:
literal int BUCKET_COUNT_DEFAULT
public:
literal int BUCKET_COUNT_DEFAULT
static val mutable BUCKET_COUNT_DEFAULT: int
static val mutable BUCKET_COUNT_DEFAULT: int

Field Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.MAX_AGE_SEC_DEFAULT Field

Table MAX_AGE_SEC_DEFAULT Field NFX Class Library

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_AGE_SEC_DEFAULT
public const int MAX_AGE_SEC_DEFAULT
Public Const MAX_AGE_SEC_DEFAULT As Integer
Public Const MAX_AGE_SEC_DEFAULT As Integer
public:
literal int MAX_AGE_SEC_DEFAULT
public:
literal int MAX_AGE_SEC_DEFAULT
static val mutable MAX_AGE_SEC_DEFAULT: int
static val mutable MAX_AGE_SEC_DEFAULT: int

Field Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.MAX_AGE_SEC_MINIMUM Field

Table MAX_AGE_SEC_MINIMUM Field NFX Class Library

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_AGE_SEC_MINIMUM
public const int MAX_AGE_SEC_MINIMUM
Public Const MAX_AGE_SEC_MINIMUM As Integer
Public Const MAX_AGE_SEC_MINIMUM As Integer
public:
literal int MAX_AGE_SEC_MINIMUM
public:
literal int MAX_AGE_SEC_MINIMUM
static val mutable MAX_AGE_SEC_MINIMUM: int
static val mutable MAX_AGE_SEC_MINIMUM: int

Field Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.REC_PER_PAGE_DEFAULT Field

Table REC_PER_PAGE_DEFAULT Field NFX Class Library

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int REC_PER_PAGE_DEFAULT
public const int REC_PER_PAGE_DEFAULT
Public Const REC_PER_PAGE_DEFAULT As Integer
Public Const REC_PER_PAGE_DEFAULT As Integer
public:
literal int REC_PER_PAGE_DEFAULT
public:
literal int REC_PER_PAGE_DEFAULT
static val mutable REC_PER_PAGE_DEFAULT: int
static val mutable REC_PER_PAGE_DEFAULT: int

Field Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.stat_ComplexHitCount Field

Table stat_ComplexHitCount Field NFX Class Library

how many complex key hits - get was called

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int stat_ComplexHitCount
internal int stat_ComplexHitCount
Friend stat_ComplexHitCount As Integer
Friend stat_ComplexHitCount As Integer
internal:
int stat_ComplexHitCount
internal:
int stat_ComplexHitCount
val mutable internal stat_ComplexHitCount: int
val mutable internal stat_ComplexHitCount: int

Field Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.stat_ComplexMissCount Field

Table stat_ComplexMissCount Field NFX Class Library

how many complex key misses - get was called

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int stat_ComplexMissCount
internal int stat_ComplexMissCount
Friend stat_ComplexMissCount As Integer
Friend stat_ComplexMissCount As Integer
internal:
int stat_ComplexMissCount
internal:
int stat_ComplexMissCount
val mutable internal stat_ComplexMissCount: int
val mutable internal stat_ComplexMissCount: int

Field Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.stat_HitCount Field

Table stat_HitCount Field NFX Class Library

how many hits - get was called

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int stat_HitCount
internal int stat_HitCount
Friend stat_HitCount As Integer
Friend stat_HitCount As Integer
internal:
int stat_HitCount
internal:
int stat_HitCount
val mutable internal stat_HitCount: int
val mutable internal stat_HitCount: int

Field Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.stat_LastTime Field

Table stat_LastTime Field NFX Class Library

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int stat_LastTime
internal int stat_LastTime
Friend stat_LastTime As Integer
Friend stat_LastTime As Integer
internal:
int stat_LastTime
internal:
int stat_LastTime
val mutable internal stat_LastTime: int
val mutable internal stat_LastTime: int

Field Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.stat_MissCount Field

Table stat_MissCount Field NFX Class Library

how many misses - get was called

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int stat_MissCount
internal int stat_MissCount
Friend stat_MissCount As Integer
Friend stat_MissCount As Integer
internal:
int stat_MissCount
internal:
int stat_MissCount
val mutable internal stat_MissCount: int
val mutable internal stat_MissCount: int

Field Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.stat_PutCollisionCount Field

Table stat_PutCollisionCount Field NFX Class Library

how many times new value overrode existing because of collision

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int stat_PutCollisionCount
internal int stat_PutCollisionCount
Friend stat_PutCollisionCount As Integer
Friend stat_PutCollisionCount As Integer
internal:
int stat_PutCollisionCount
internal:
int stat_PutCollisionCount
val mutable internal stat_PutCollisionCount: int
val mutable internal stat_PutCollisionCount: int

Field Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.stat_PutCount Field

Table stat_PutCount Field NFX Class Library

how many times put was called

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int stat_PutCount
internal int stat_PutCount
Friend stat_PutCount As Integer
Friend stat_PutCount As Integer
internal:
int stat_PutCount
internal:
int stat_PutCount
val mutable internal stat_PutCount: int
val mutable internal stat_PutCount: int

Field Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.stat_PutInsertCount Field

Table stat_PutInsertCount Field NFX Class Library

how many times new value successfully inserted without collision

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int stat_PutInsertCount
internal int stat_PutInsertCount
Friend stat_PutInsertCount As Integer
Friend stat_PutInsertCount As Integer
internal:
int stat_PutInsertCount
internal:
int stat_PutInsertCount
val mutable internal stat_PutInsertCount: int
val mutable internal stat_PutInsertCount: int

Field Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.stat_PutPageCreateCount Field

Table stat_PutPageCreateCount Field NFX Class Library

how many times bucket collision occured that resulted in page creation

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int stat_PutPageCreateCount
internal int stat_PutPageCreateCount
Friend stat_PutPageCreateCount As Integer
Friend stat_PutPageCreateCount As Integer
internal:
int stat_PutPageCreateCount
internal:
int stat_PutPageCreateCount
val mutable internal stat_PutPageCreateCount: int
val mutable internal stat_PutPageCreateCount: int

Field Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.stat_PutPriorityPreventedCollisionCount Field

Table stat_PutPriorityPreventedCollisionCount Field NFX Class Library

[This is preliminary documentation and is subject to change.]

how many times priority prevented collision

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int stat_PutPriorityPreventedCollisionCount
internal int stat_PutPriorityPreventedCollisionCount
Friend stat_PutPriorityPreventedCollisionCount As Integer
Friend stat_PutPriorityPreventedCollisionCount As Integer
internal:
int stat_PutPriorityPreventedCollisionCount
internal:
int stat_PutPriorityPreventedCollisionCount
val mutable internal stat_PutPriorityPreventedCollisionCount: int
val mutable internal stat_PutPriorityPreventedCollisionCount: int

Field Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.stat_PutReplaceCount Field

Table stat_PutReplaceCount Field NFX Class Library

how many times new value successfully replaced existing one (by the same key) without collision

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int stat_PutReplaceCount
internal int stat_PutReplaceCount
Friend stat_PutReplaceCount As Integer
Friend stat_PutReplaceCount As Integer
internal:
int stat_PutReplaceCount
internal:
int stat_PutReplaceCount
val mutable internal stat_PutReplaceCount: int
val mutable internal stat_PutReplaceCount: int

Field Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.stat_RemoveHitCount Field

Table stat_RemoveHitCount Field NFX Class Library

how many records have been found and removed

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int stat_RemoveHitCount
internal int stat_RemoveHitCount
Friend stat_RemoveHitCount As Integer
Friend stat_RemoveHitCount As Integer
internal:
int stat_RemoveHitCount
internal:
int stat_RemoveHitCount
val mutable internal stat_RemoveHitCount: int
val mutable internal stat_RemoveHitCount: int

Field Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.stat_RemoveMissCount Field

Table stat_RemoveMissCount Field NFX Class Library

how many records have been sought to be removed but were not found

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int stat_RemoveMissCount
internal int stat_RemoveMissCount
Friend stat_RemoveMissCount As Integer
Friend stat_RemoveMissCount As Integer
internal:
int stat_RemoveMissCount
internal:
int stat_RemoveMissCount
val mutable internal stat_RemoveMissCount: int
val mutable internal stat_RemoveMissCount: int

Field Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.stat_RemovePageCount Field

Table stat_RemovePageCount Field NFX Class Library

how many pages have been deleted, a page gets deleted when there are no records stored in it

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int stat_RemovePageCount
internal int stat_RemovePageCount
Friend stat_RemovePageCount As Integer
Friend stat_RemovePageCount As Integer
internal:
int stat_RemovePageCount
internal:
int stat_RemovePageCount
val mutable internal stat_RemovePageCount: int
val mutable internal stat_RemovePageCount: int

Field Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.stat_SweepPageCount Field

Table stat_SweepPageCount Field NFX Class Library

how many pages swept

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int stat_SweepPageCount
internal int stat_SweepPageCount
Friend stat_SweepPageCount As Integer
Friend stat_SweepPageCount As Integer
internal:
int stat_SweepPageCount
internal:
int stat_SweepPageCount
val mutable internal stat_SweepPageCount: int
val mutable internal stat_SweepPageCount: int

Field Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.stat_SweepRemoveCount Field

Table stat_SweepRemoveCount Field NFX Class Library

how many records removed by sweep

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int stat_SweepRemoveCount
internal int stat_SweepRemoveCount
Friend stat_SweepRemoveCount As Integer
Friend stat_SweepRemoveCount As Integer
internal:
int stat_SweepRemoveCount
internal:
int stat_SweepRemoveCount
val mutable internal stat_SweepRemoveCount: int
val mutable internal stat_SweepRemoveCount: int

Field Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.stat_SweepTableCount Field

Table stat_SweepTableCount Field NFX Class Library

how many times swept

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int stat_SweepTableCount
internal int stat_SweepTableCount
Friend stat_SweepTableCount As Integer
Friend stat_SweepTableCount As Integer
internal:
int stat_SweepTableCount
internal:
int stat_SweepTableCount
val mutable internal stat_SweepTableCount: int
val mutable internal stat_SweepTableCount: int

Field Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.stat_ValueFactoryCount Field

Table stat_ValueFactoryCount Field NFX Class Library

how many times factory called from GetOrPut

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int stat_ValueFactoryCount
internal int stat_ValueFactoryCount
Friend stat_ValueFactoryCount As Integer
Friend stat_ValueFactoryCount As Integer
internal:
int stat_ValueFactoryCount
internal:
int stat_ValueFactoryCount
val mutable internal stat_ValueFactoryCount: int
val mutable internal stat_ValueFactoryCount: int

Field Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table Methods

Table Methods NFX Class Library

The Table type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get | Retrieves an item from this table by key where item age is less or equal to requested, or null if it does not exist
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetOrPut TContext | Retrieves an item from this table by key where item age is less or equal to requested, or calls the itemFactory function and inserts the value in the store
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Put(UInt64, Object, Int32, Int32, Nullable DateTime ) | Puts a key-identified item into this table. If item with such key is already in this table then replaces it and returns false, returns true otherwise
Public method | Put(UInt64, Object, CacheRec , Int32, Int32, Nullable DateTime ) | Puts a key-identified item into this table. If item with such key is already in this table then replaces it and returns false, returns true otherwise
Public method | Remove | Removes a key-identified item from the named table returning true when item was deleted or false when item was not found
Protected method | Sweep |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Table Class
NFX.DataAccess.Cache Namespace


Table.Get Method

Table Get Method NFX Class Library

Retrieves an item from this table by key where item age is less or equal to requested, or null if it does not exist

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CacheRec Get(
    ulong key,
    int ageSec = 0
)
public CacheRec Get(
    ulong key,
    int ageSec = 0
)
Public Function Get (
    key As ULong,
    Optional ageSec As Integer = 0
) As CacheRec
Public Function Get (
    key As ULong,
    Optional ageSec As Integer = 0
) As CacheRec
public:
CacheRec^ Get(
    unsigned long long key,
    int ageSec = 0
)
public:
CacheRec^ Get(
    unsigned long long key,
    int ageSec = 0
)
member Get :
        key : uint64 *
        ?ageSec : int
(* Defaults:
        let _ageSec = defaultArg ageSec 0
*)
-> CacheRec
member Get :
        key : uint64 *
        ?ageSec : int
(* Defaults:
        let _ageSec = defaultArg ageSec 0
*)
-> CacheRec

Parameters

key
Type: Online System UInt64
Item key
ageSec (Optional)
Type: Online System Int32
Age of item in seconds, or 0 for any age

Return Value

Type: CacheRec
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.GetOrPut(TContext) Method

Table GetOrPut TContext Method NFX Class Library

Retrieves an item from this table by key where item age is less or equal to requested, or calls the itemFactory function and inserts the value in the store

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CacheRec GetOrPut<TContext>(
    ulong key,
    Func<string, ulong, TContext, Object> valueFactory,
    TContext factoryContext = null,
    int ageSec = 0,
    int putMaxAgeSec = 0,
    int putPriority = 0,
    Nullable<DateTime> putAbsoluteExpirationUTC = null
)
public CacheRec GetOrPut<TContext>(
    ulong key,
    Func<string, ulong, TContext, Object> valueFactory,
    TContext factoryContext = null,
    int ageSec = 0,
    int putMaxAgeSec = 0,
    int putPriority = 0,
    Nullable<DateTime> putAbsoluteExpirationUTC = null
)
Public Function GetOrPut(Of TContext) (
    key As ULong,
    valueFactory As Func(Of String, ULong, TContext, Object),
    Optional factoryContext As TContext = Nothing,
    Optional ageSec As Integer = 0,
    Optional putMaxAgeSec As Integer = 0,
    Optional putPriority As Integer = 0,
    Optional putAbsoluteExpirationUTC As Nullable(Of DateTime) = Nothing
) As CacheRec
Public Function GetOrPut(Of TContext) (
    key As ULong,
    valueFactory As Func(Of String, ULong, TContext, Object),
    Optional factoryContext As TContext = Nothing,
    Optional ageSec As Integer = 0,
    Optional putMaxAgeSec As Integer = 0,
    Optional putPriority As Integer = 0,
    Optional putAbsoluteExpirationUTC As Nullable(Of DateTime) = Nothing
) As CacheRec
public:
generic<typename TContext>
CacheRec^ GetOrPut(
    unsigned long long key,
    Func<String^, unsigned long long, TContext, Object^>^ valueFactory,
    TContext factoryContext = nullptr,
    int ageSec = 0,
    int putMaxAgeSec = 0,
    int putPriority = 0,
    Nullable<DateTime> putAbsoluteExpirationUTC = nullptr
)
public:
generic<typename TContext>
CacheRec^ GetOrPut(
    unsigned long long key,
    Func<String^, unsigned long long, TContext, Object^>^ valueFactory,
    TContext factoryContext = nullptr,
    int ageSec = 0,
    int putMaxAgeSec = 0,
    int putPriority = 0,
    Nullable<DateTime> putAbsoluteExpirationUTC = nullptr
)
member GetOrPut :
        key : uint64 *
        valueFactory : Func<string, uint64, 'TContext, Object> *
        ?factoryContext : 'TContext *
        ?ageSec : int *
        ?putMaxAgeSec : int *
        ?putPriority : int *
        ?putAbsoluteExpirationUTC : Nullable<DateTime>
(* Defaults:
        let _factoryContext = defaultArg factoryContext null
        let _ageSec = defaultArg ageSec 0
        let _putMaxAgeSec = defaultArg putMaxAgeSec 0
        let _putPriority = defaultArg putPriority 0
        let _putAbsoluteExpirationUTC = defaultArg putAbsoluteExpirationUTC null
*)
-> CacheRec
member GetOrPut :
        key : uint64 *
        valueFactory : Func<string, uint64, 'TContext, Object> *
        ?factoryContext : 'TContext *
        ?ageSec : int *
        ?putMaxAgeSec : int *
        ?putPriority : int *
        ?putAbsoluteExpirationUTC : Nullable<DateTime>
(* Defaults:
        let _factoryContext = defaultArg factoryContext null
        let _ageSec = defaultArg ageSec 0
        let _putMaxAgeSec = defaultArg putMaxAgeSec 0
        let _putPriority = defaultArg putPriority 0
        let _putAbsoluteExpirationUTC = defaultArg putAbsoluteExpirationUTC null
*)
-> CacheRec

Parameters

key
Type: Online System UInt64
Item key
valueFactory
Type: Online System Func Online String, Online UInt64, TContext, Online Object
A function that returns new value for the specified tableName, key, and context
factoryContext (Optional)
Type: TContext
An object to pass into the factory function if it gets invoked
ageSec (Optional)
Type: Online System Int32
Age of item in seconds, or 0 for any age
putMaxAgeSec (Optional)
Type: Online System Int32
MaxAge for item if Put is called
putPriority (Optional)
Type: Online System Int32
Priority for item if Put is called
putAbsoluteExpirationUTC (Optional)
Type: Online System Nullable Online DateTime
Absolute expiration UTC timestamp for item if Put is called
Type Parameters
TContext
A type of item factory context

Return Value

Type: CacheRec
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.Put Method

Table Put Method NFX Class Library

Overload List
 | Name | Description
Public method | Put(UInt64, Object, Int32, Int32, Nullable DateTime ) | Puts a key-identified item into this table. If item with such key is already in this table then replaces it and returns false, returns true otherwise
Public method | Put(UInt64, Object, CacheRec , Int32, Int32, Nullable DateTime ) | Puts a key-identified item into this table. If item with such key is already in this table then replaces it and returns false, returns true otherwise
Back to Top
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.Put Method (UInt64, Object, Int32, Int32, Nullable(DateTime))

Table Put Method (UInt64, Object, Int32, Int32, Nullable DateTime ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Puts a key-identified item into this table. If item with such key is already in this table then replaces it and returns false, returns true otherwise

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Put(
    ulong key,
    Object value,
    int maxAgeSec = 0,
    int priority = 0,
    Nullable<DateTime> absoluteExpirationUTC = null
)
public bool Put(
    ulong key,
    Object value,
    int maxAgeSec = 0,
    int priority = 0,
    Nullable<DateTime> absoluteExpirationUTC = null
)
Public Function Put (
    key As ULong,
    value As Object,
    Optional maxAgeSec As Integer = 0,
    Optional priority As Integer = 0,
    Optional absoluteExpirationUTC As Nullable(Of DateTime) = Nothing
) As Boolean
Public Function Put (
    key As ULong,
    value As Object,
    Optional maxAgeSec As Integer = 0,
    Optional priority As Integer = 0,
    Optional absoluteExpirationUTC As Nullable(Of DateTime) = Nothing
) As Boolean
public:
bool Put(
    unsigned long long key,
    Object^ value,
    int maxAgeSec = 0,
    int priority = 0,
    Nullable<DateTime> absoluteExpirationUTC = nullptr
)
public:
bool Put(
    unsigned long long key,
    Object^ value,
    int maxAgeSec = 0,
    int priority = 0,
    Nullable<DateTime> absoluteExpirationUTC = nullptr
)
member Put :
        key : uint64 *
        value : Object *
        ?maxAgeSec : int *
        ?priority : int *
        ?absoluteExpirationUTC : Nullable<DateTime>
(* Defaults:
        let _maxAgeSec = defaultArg maxAgeSec 0
        let _priority = defaultArg priority 0
        let _absoluteExpirationUTC = defaultArg absoluteExpirationUTC null
*)
-> bool
member Put :
        key : uint64 *
        value : Object *
        ?maxAgeSec : int *
        ?priority : int *
        ?absoluteExpirationUTC : Nullable<DateTime>
(* Defaults:
        let _maxAgeSec = defaultArg maxAgeSec 0
        let _priority = defaultArg priority 0
        let _absoluteExpirationUTC = defaultArg absoluteExpirationUTC null
*)
-> bool

Parameters

key
Type: Online System UInt64
Item's unique key
value
Type: Online System Object
Item
maxAgeSec (Optional)
Type: Online System Int32
For how long will the item exist in cache before it gets swept out. Pass 0 to use table-level setting (default)
priority (Optional)
Type: Online System Int32
Items priority relative to others in the table used during collision resolution, 0 = default
absoluteExpirationUTC (Optional)
Type: Online System Nullable Online DateTime
Sets absolute UTC time stamp when item should be swept out of cache, null is default

Return Value

Type: Online Boolean
See Also
Table Class
Table Members
Put Overload
NFX.DataAccess.Cache Namespace


Table.Put Method (UInt64, Object, CacheRec, Int32, Int32, Nullable(DateTime))

Table Put Method (UInt64, Object, CacheRec , Int32, Int32, Nullable DateTime ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Puts a key-identified item into this table. If item with such key is already in this table then replaces it and returns false, returns true otherwise

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Put(
    ulong key,
    Object value,
    out CacheRec rec,
    int maxAgeSec = 0,
    int priority = 0,
    Nullable<DateTime> absoluteExpirationUTC = null
)
public bool Put(
    ulong key,
    Object value,
    out CacheRec rec,
    int maxAgeSec = 0,
    int priority = 0,
    Nullable<DateTime> absoluteExpirationUTC = null
)
Public Function Put (
    key As ULong,
    value As Object,
    <OutAttribute> ByRef rec As CacheRec,
    Optional maxAgeSec As Integer = 0,
    Optional priority As Integer = 0,
    Optional absoluteExpirationUTC As Nullable(Of DateTime) = Nothing
) As Boolean
Public Function Put (
    key As ULong,
    value As Object,
    <OutAttribute> ByRef rec As CacheRec,
    Optional maxAgeSec As Integer = 0,
    Optional priority As Integer = 0,
    Optional absoluteExpirationUTC As Nullable(Of DateTime) = Nothing
) As Boolean
public:
bool Put(
    unsigned long long key,
    Object^ value,
    [OutAttribute] CacheRec^% rec,
    int maxAgeSec = 0,
    int priority = 0,
    Nullable<DateTime> absoluteExpirationUTC = nullptr
)
public:
bool Put(
    unsigned long long key,
    Object^ value,
    [OutAttribute] CacheRec^% rec,
    int maxAgeSec = 0,
    int priority = 0,
    Nullable<DateTime> absoluteExpirationUTC = nullptr
)
member Put :
        key : uint64 *
        value : Object *
        rec : CacheRec byref *
        ?maxAgeSec : int *
        ?priority : int *
        ?absoluteExpirationUTC : Nullable<DateTime>
(* Defaults:
        let _maxAgeSec = defaultArg maxAgeSec 0
        let _priority = defaultArg priority 0
        let _absoluteExpirationUTC = defaultArg absoluteExpirationUTC null
*)
-> bool
member Put :
        key : uint64 *
        value : Object *
        rec : CacheRec byref *
        ?maxAgeSec : int *
        ?priority : int *
        ?absoluteExpirationUTC : Nullable<DateTime>
(* Defaults:
        let _maxAgeSec = defaultArg maxAgeSec 0
        let _priority = defaultArg priority 0
        let _absoluteExpirationUTC = defaultArg absoluteExpirationUTC null
*)
-> bool

Parameters

key
Type: Online System UInt64
Item's unique key
value
Type: Online System Object
Item
rec
Type: NFX.DataAccess.Cache CacheRec
Returns new or existing CacheRec
maxAgeSec (Optional)
Type: Online System Int32
For how long will the item exist in cache before it gets swept out. Pass 0 to use table-level setting (default)
priority (Optional)
Type: Online System Int32
Items priority relative to others in the table used during collision resolution, 0 = default
absoluteExpirationUTC (Optional)
Type: Online System Nullable Online DateTime
Sets absolute UTC time stamp when item should be swept out of cache, null is default

Return Value

Type: Online Boolean
See Also
Table Class
Table Members
Put Overload
NFX.DataAccess.Cache Namespace


Table.Remove Method

Table Remove Method NFX Class Library

Removes a key-identified item from the named table returning true when item was deleted or false when item was not found

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Remove(
    ulong key
)
public bool Remove(
    ulong key
)
Public Function Remove (
    key As ULong
) As Boolean
Public Function Remove (
    key As ULong
) As Boolean
public:
bool Remove(
    unsigned long long key
)
public:
bool Remove(
    unsigned long long key
)
member Remove :
        key : uint64 -> bool
member Remove :
        key : uint64 -> bool

Parameters

key
Type: Online System UInt64

Return Value

Type: Online Boolean
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.Sweep Method

Table Sweep Method NFX Class Library

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Sweep()
internal void Sweep()
Friend Sub Sweep
Friend Sub Sweep
internal:
void Sweep()
internal:
void Sweep()
internal member Sweep : unit -> unit
internal member Sweep : unit -> unit
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table Properties

Table Properties NFX Class Library

The Table type exposes the following members.
Properties
 | Name | Description
Public property | BucketCount | Returns how many slots/buckets are pre-allocated per table, the higher the number the more memory will be reserved at table construction time, every slot is a reference (4 bytes on 32bit systems, 8 bytes on 64bit). For optimal performance this number should be around 75% of total record count stored in the table (table load factor).
Public property | BucketPageLoadFactor | Returns the ratio of how many buckets are loaded with pages vs. bucket count
Public property | Capacity | Returns the maximum number of items that this table can hold at any given time given that no items will have any key hash collisions
Public property | Count | Returns item count in the table
Public property | LockCount | Returns how many locks can be used for thread coordination during table changes
Public property | MaxAgeSec | Gets/sets maximum age of items in the table expressed in seconds. After this age is exceeded, the system will delete entries. The system does not guarantee that items will expire right on time, however it does guarantee that items will be available for at least this long.
Public property | Name | Returns table name which is a unique string within the cache store
Public property | PageCount | Returns page count in the table
Public property | ParallelSweep | When enabled, uses parallel execution while sweeping table buckets, otherwise sweeps sequentially (default behavior)
Public property | RecPerPage | Returns how many slots are pre-allocated per table's bucket(page) when more than one item produces hash collision. The higher the number, the more primary hash collisions can be accomodated by re-hashing on pages (secondary hash table within primary buckets)
Public property | StatComplexHitCount | Returns hit count stats for using complex keys
Public property | StatComplexMissCount | Returns miss count stats for using complex keys
Public property | StatHitCount | Returns hit count stats
Public property | StatMissCount | Returns miss count stats
Public property | Store | Returns the store instance that this table is a part of
Back to Top
See Also
Table Class
NFX.DataAccess.Cache Namespace


Table.BucketCount Property

Table BucketCount Property NFX Class Library

Returns how many slots/buckets are pre-allocated per table, the higher the number the more memory will be reserved at table construction time, every slot is a reference (4 bytes on 32bit systems, 8 bytes on 64bit). For optimal performance this number should be around 75% of total record count stored in the table (table load factor).

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int BucketCount { get; }
public int BucketCount { get; }
Public ReadOnly Property BucketCount As Integer
    Get
Public ReadOnly Property BucketCount As Integer
    Get
public:
property int BucketCount {
    int get ();
}
public:
property int BucketCount {
    int get ();
}
member BucketCount : int with get
member BucketCount : int with get

Property Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.BucketPageLoadFactor Property

Table BucketPageLoadFactor Property NFX Class Library

Returns the ratio of how many buckets are loaded with pages vs. bucket count

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double BucketPageLoadFactor { get; }
public double BucketPageLoadFactor { get; }
Public ReadOnly Property BucketPageLoadFactor As Double
    Get
Public ReadOnly Property BucketPageLoadFactor As Double
    Get
public:
property double BucketPageLoadFactor {
    double get ();
}
public:
property double BucketPageLoadFactor {
    double get ();
}
member BucketPageLoadFactor : float with get
member BucketPageLoadFactor : float with get

Property Value

Type: Online Double
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.Capacity Property

Table Capacity Property NFX Class Library

Returns the maximum number of items that this table can hold at any given time given that no items will have any key hash collisions

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Capacity { get; }
public int Capacity { get; }
Public ReadOnly Property Capacity As Integer
    Get
Public ReadOnly Property Capacity As Integer
    Get
public:
property int Capacity {
    int get ();
}
public:
property int Capacity {
    int get ();
}
member Capacity : int with get
member Capacity : int with get

Property Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.Count Property

Table Count Property NFX Class Library

Returns item count in the table

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
public:
property int Count {
    int get ();
}
member Count : int with get
member Count : int with get

Property Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.LockCount Property

Table LockCount Property NFX Class Library

Returns how many locks can be used for thread coordination during table changes

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int LockCount { get; }
public int LockCount { get; }
Public ReadOnly Property LockCount As Integer
    Get
Public ReadOnly Property LockCount As Integer
    Get
public:
property int LockCount {
    int get ();
}
public:
property int LockCount {
    int get ();
}
member LockCount : int with get
member LockCount : int with get

Property Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.MaxAgeSec Property

Table MaxAgeSec Property NFX Class Library

Gets/sets maximum age of items in the table expressed in seconds. After this age is exceeded, the system will delete entries. The system does not guarantee that items will expire right on time, however it does guarantee that items will be available for at least this long.

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MaxAgeSec { get; set; }
public int MaxAgeSec { get; set; }
Public Property MaxAgeSec As Integer
    Get
    Set
Public Property MaxAgeSec As Integer
    Get
    Set
public:
property int MaxAgeSec {
    int get ();
    void set (int value);
}
public:
property int MaxAgeSec {
    int get ();
    void set (int value);
}
member MaxAgeSec : int with get, set
member MaxAgeSec : int with get, set

Property Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.Name Property

Table Name Property NFX Class Library

Returns table name which is a unique string within the cache store

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.PageCount Property

Table PageCount Property NFX Class Library

Returns page count in the table

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int PageCount { get; }
public int PageCount { get; }
Public ReadOnly Property PageCount As Integer
    Get
Public ReadOnly Property PageCount As Integer
    Get
public:
property int PageCount {
    int get ();
}
public:
property int PageCount {
    int get ();
}
member PageCount : int with get
member PageCount : int with get

Property Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.ParallelSweep Property

Table ParallelSweep Property NFX Class Library

When enabled, uses parallel execution while sweeping table buckets, otherwise sweeps sequentially (default behavior)

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ParallelSweep { get; set; }
public bool ParallelSweep { get; set; }
Public Property ParallelSweep As Boolean
    Get
    Set
Public Property ParallelSweep As Boolean
    Get
    Set
public:
property bool ParallelSweep {
    bool get ();
    void set (bool value);
}
public:
property bool ParallelSweep {
    bool get ();
    void set (bool value);
}
member ParallelSweep : bool with get, set
member ParallelSweep : bool with get, set

Property Value

Type: Online Boolean
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.RecPerPage Property

Table RecPerPage Property NFX Class Library

Returns how many slots are pre-allocated per table's bucket(page) when more than one item produces hash collision. The higher the number, the more primary hash collisions can be accomodated by re-hashing on pages (secondary hash table within primary buckets)

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int RecPerPage { get; }
public int RecPerPage { get; }
Public ReadOnly Property RecPerPage As Integer
    Get
Public ReadOnly Property RecPerPage As Integer
    Get
public:
property int RecPerPage {
    int get ();
}
public:
property int RecPerPage {
    int get ();
}
member RecPerPage : int with get
member RecPerPage : int with get

Property Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.StatComplexHitCount Property

Table StatComplexHitCount Property NFX Class Library

Returns hit count stats for using complex keys

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int StatComplexHitCount { get; }
public int StatComplexHitCount { get; }
Public ReadOnly Property StatComplexHitCount As Integer
    Get
Public ReadOnly Property StatComplexHitCount As Integer
    Get
public:
property int StatComplexHitCount {
    int get ();
}
public:
property int StatComplexHitCount {
    int get ();
}
member StatComplexHitCount : int with get
member StatComplexHitCount : int with get

Property Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.StatComplexMissCount Property

Table StatComplexMissCount Property NFX Class Library

Returns miss count stats for using complex keys

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int StatComplexMissCount { get; }
public int StatComplexMissCount { get; }
Public ReadOnly Property StatComplexMissCount As Integer
    Get
Public ReadOnly Property StatComplexMissCount As Integer
    Get
public:
property int StatComplexMissCount {
    int get ();
}
public:
property int StatComplexMissCount {
    int get ();
}
member StatComplexMissCount : int with get
member StatComplexMissCount : int with get

Property Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.StatHitCount Property

Table StatHitCount Property NFX Class Library

Returns hit count stats

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int StatHitCount { get; }
public int StatHitCount { get; }
Public ReadOnly Property StatHitCount As Integer
    Get
Public ReadOnly Property StatHitCount As Integer
    Get
public:
property int StatHitCount {
    int get ();
}
public:
property int StatHitCount {
    int get ();
}
member StatHitCount : int with get
member StatHitCount : int with get

Property Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.StatMissCount Property

Table StatMissCount Property NFX Class Library

Returns miss count stats

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int StatMissCount { get; }
public int StatMissCount { get; }
Public ReadOnly Property StatMissCount As Integer
    Get
Public ReadOnly Property StatMissCount As Integer
    Get
public:
property int StatMissCount {
    int get ();
}
public:
property int StatMissCount {
    int get ();
}
member StatMissCount : int with get
member StatMissCount : int with get

Property Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


Table.Store Property

Table Store Property NFX Class Library

Returns the store instance that this table is a part of

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CacheStore Store { get; }
public CacheStore Store { get; }
Public ReadOnly Property Store As CacheStore
    Get
Public ReadOnly Property Store As CacheStore
    Get
public:
property CacheStore^ Store {
    CacheStore^ get ();
}
public:
property CacheStore^ Store {
    CacheStore^ get ();
}
member Store : CacheStore with get
member Store : CacheStore with get

Property Value

Type: CacheStore
See Also
Table Class
Table Members
NFX.DataAccess.Cache Namespace


TableCapacity Enumeration

TableCapacity Enumeration NFX Class Library

Provides cache table capacity classifications

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum TableCapacity
public enum TableCapacity
Public Enumeration TableCapacity
Public Enumeration TableCapacity
public enum class TableCapacity
public enum class TableCapacity
type TableCapacity
type TableCapacity
Members
Member name | Value | Description
Default | 0 | 25,111 * 7 = 175,777 items * 64(8/ptr + 40/cache rec + 12/obj over) = 11.25 Mb just for storing empty cache items
Large | 1 | 753,001 * 7 = 5,271,007 items * 64(8/ptr + 40/cache rec + 12/obj over) = 337.3 Mb just for storing empty cache items
XLarge | 2 | 3,337,333 * 7 = 23,361,331 items * 64(8/ptr + 40/cache rec + 12/obj over) = 1.39 Gb just for storing empty cache items
See Also
NFX.DataAccess.Cache Namespace


TableOptions Class

TableOptions Class NFX Class Library

Provides config options for cache tables
Inheritance Hierarchy
Online System Object
NFX.DataAccess.Cache TableOptions

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class TableOptions : INamed,
    IConfigurable
public sealed class TableOptions : INamed,
    IConfigurable
Public NotInheritable Class TableOptions
    Implements INamed, IConfigurable
Public NotInheritable Class TableOptions
    Implements INamed, IConfigurable
public ref class TableOptions sealed : INamed,
    IConfigurable
public ref class TableOptions sealed : INamed,
    IConfigurable
[<SealedAttribute>]
type TableOptions =
    class
        interface INamed
        interface IConfigurable
    end
[<SealedAttribute>]
type TableOptions =
    class
        interface INamed
        interface IConfigurable
    end
See Also
TableOptions Members
NFX.DataAccess.Cache Namespace


TableOptions Members

TableOptions Members NFX Class Library

The TableOptions type exposes the following members.
Constructors
 | Name | Description
Protected method | TableOptions | Initializes a new instance of the TableOptions class
Public method | TableOptions(String, TableCapacity, Int32, Int32, Boolean) | Initializes a new instance of the TableOptions class
Public method | TableOptions(String, Int32, Int32, Int32, Int32, Boolean) | Initializes a new instance of the TableOptions class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | BucketCount |
Public property | LockCount |
Public property | MaxAgeSec |
Public property | Name |
Public property | ParallelSweep |
Public property | RecPerPage |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IConfigurable Configure |
Back to Top
See Also
TableOptions Class
NFX.DataAccess.Cache Namespace


TableOptions Constructor

TableOptions Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | TableOptions | Initializes a new instance of the TableOptions class
Public method | TableOptions(String, TableCapacity, Int32, Int32, Boolean) | Initializes a new instance of the TableOptions class
Public method | TableOptions(String, Int32, Int32, Int32, Int32, Boolean) | Initializes a new instance of the TableOptions class
Back to Top
See Also
TableOptions Class
TableOptions Members
NFX.DataAccess.Cache Namespace


TableOptions Constructor

TableOptions Constructor NFX Class Library

Initializes a new instance of the TableOptions class

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal TableOptions()
internal TableOptions()
Friend Sub New
Friend Sub New
internal:
TableOptions()
internal:
TableOptions()
new : unit -> TableOptions
new : unit -> TableOptions
See Also
TableOptions Class
TableOptions Members
TableOptions Overload
NFX.DataAccess.Cache Namespace


TableOptions Constructor (String, TableCapacity, Int32, Int32, Boolean)

TableOptions Constructor (String, TableCapacity, Int32, Int32, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TableOptions class

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TableOptions(
    string name,
    TableCapacity capacity,
    int lockCount = 0,
    int maxAgeSec = 0,
    bool parallelSweep = false
)
public TableOptions(
    string name,
    TableCapacity capacity,
    int lockCount = 0,
    int maxAgeSec = 0,
    bool parallelSweep = false
)
Public Sub New (
    name As String,
    capacity As TableCapacity,
    Optional lockCount As Integer = 0,
    Optional maxAgeSec As Integer = 0,
    Optional parallelSweep As Boolean = false
)
Public Sub New (
    name As String,
    capacity As TableCapacity,
    Optional lockCount As Integer = 0,
    Optional maxAgeSec As Integer = 0,
    Optional parallelSweep As Boolean = false
)
public:
TableOptions(
    String^ name,
    TableCapacity capacity,
    int lockCount = 0,
    int maxAgeSec = 0,
    bool parallelSweep = false
)
public:
TableOptions(
    String^ name,
    TableCapacity capacity,
    int lockCount = 0,
    int maxAgeSec = 0,
    bool parallelSweep = false
)
new :
        name : string *
        capacity : TableCapacity *
        ?lockCount : int *
        ?maxAgeSec : int *
        ?parallelSweep : bool
(* Defaults:
        let _lockCount = defaultArg lockCount 0
        let _maxAgeSec = defaultArg maxAgeSec 0
        let _parallelSweep = defaultArg parallelSweep false
*)
-> TableOptions
new :
        name : string *
        capacity : TableCapacity *
        ?lockCount : int *
        ?maxAgeSec : int *
        ?parallelSweep : bool
(* Defaults:
        let _lockCount = defaultArg lockCount 0
        let _maxAgeSec = defaultArg maxAgeSec 0
        let _parallelSweep = defaultArg parallelSweep false
*)
-> TableOptions

Parameters

name
Type: Online System String
capacity
Type: NFX.DataAccess.Cache TableCapacity
lockCount (Optional)
Type: Online System Int32
maxAgeSec (Optional)
Type: Online System Int32
parallelSweep (Optional)
Type: Online System Boolean
See Also
TableOptions Class
TableOptions Members
TableOptions Overload
NFX.DataAccess.Cache Namespace


TableOptions Constructor (String, Int32, Int32, Int32, Int32, Boolean)

TableOptions Constructor (String, Int32, Int32, Int32, Int32, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TableOptions class

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TableOptions(
    string name,
    int bucketCount,
    int recPerPage,
    int lockCount = 0,
    int maxAgeSec = 0,
    bool parallelSweep = false
)
public TableOptions(
    string name,
    int bucketCount,
    int recPerPage,
    int lockCount = 0,
    int maxAgeSec = 0,
    bool parallelSweep = false
)
Public Sub New (
    name As String,
    bucketCount As Integer,
    recPerPage As Integer,
    Optional lockCount As Integer = 0,
    Optional maxAgeSec As Integer = 0,
    Optional parallelSweep As Boolean = false
)
Public Sub New (
    name As String,
    bucketCount As Integer,
    recPerPage As Integer,
    Optional lockCount As Integer = 0,
    Optional maxAgeSec As Integer = 0,
    Optional parallelSweep As Boolean = false
)
public:
TableOptions(
    String^ name,
    int bucketCount,
    int recPerPage,
    int lockCount = 0,
    int maxAgeSec = 0,
    bool parallelSweep = false
)
public:
TableOptions(
    String^ name,
    int bucketCount,
    int recPerPage,
    int lockCount = 0,
    int maxAgeSec = 0,
    bool parallelSweep = false
)
new :
        name : string *
        bucketCount : int *
        recPerPage : int *
        ?lockCount : int *
        ?maxAgeSec : int *
        ?parallelSweep : bool
(* Defaults:
        let _lockCount = defaultArg lockCount 0
        let _maxAgeSec = defaultArg maxAgeSec 0
        let _parallelSweep = defaultArg parallelSweep false
*)
-> TableOptions
new :
        name : string *
        bucketCount : int *
        recPerPage : int *
        ?lockCount : int *
        ?maxAgeSec : int *
        ?parallelSweep : bool
(* Defaults:
        let _lockCount = defaultArg lockCount 0
        let _maxAgeSec = defaultArg maxAgeSec 0
        let _parallelSweep = defaultArg parallelSweep false
*)
-> TableOptions

Parameters

name
Type: Online System String
bucketCount
Type: Online System Int32
recPerPage
Type: Online System Int32
lockCount (Optional)
Type: Online System Int32
maxAgeSec (Optional)
Type: Online System Int32
parallelSweep (Optional)
Type: Online System Boolean
See Also
TableOptions Class
TableOptions Members
TableOptions Overload
NFX.DataAccess.Cache Namespace


TableOptions Methods

TableOptions Methods NFX Class Library

The TableOptions type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IConfigurable Configure |
Back to Top
See Also
TableOptions Class
NFX.DataAccess.Cache Namespace


TableOptions.IConfigurable.Configure Method

TableOptions IConfigurable Configure Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void IConfigurable.Configure(
    IConfigSectionNode node
)
void IConfigurable.Configure(
    IConfigSectionNode node
)
Private Sub Configure (
    node As IConfigSectionNode
) Implements IConfigurable.Configure
Private Sub Configure (
    node As IConfigSectionNode
) Implements IConfigurable.Configure
private:
virtual void Configure(
    IConfigSectionNode^ node
) sealed = IConfigurable::Configure
private:
virtual void Configure(
    IConfigSectionNode^ node
) sealed = IConfigurable::Configure
private abstract Configure :
        node : IConfigSectionNode -> unit
private override Configure :
        node : IConfigSectionNode -> unit
private abstract Configure :
        node : IConfigSectionNode -> unit
private override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
TableOptions Class
TableOptions Members
NFX.DataAccess.Cache Namespace


TableOptions Properties

TableOptions Properties NFX Class Library

The TableOptions type exposes the following members.
Properties
 | Name | Description
Public property | BucketCount |
Public property | LockCount |
Public property | MaxAgeSec |
Public property | Name |
Public property | ParallelSweep |
Public property | RecPerPage |
Back to Top
See Also
TableOptions Class
NFX.DataAccess.Cache Namespace


TableOptions.BucketCount Property

TableOptions BucketCount Property NFX Class Library

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int BucketCount { get; }
public int BucketCount { get; }
Public ReadOnly Property BucketCount As Integer
    Get
Public ReadOnly Property BucketCount As Integer
    Get
public:
property int BucketCount {
    int get ();
}
public:
property int BucketCount {
    int get ();
}
member BucketCount : int with get
member BucketCount : int with get

Property Value

Type: Online Int32
See Also
TableOptions Class
TableOptions Members
NFX.DataAccess.Cache Namespace


TableOptions.LockCount Property

TableOptions LockCount Property NFX Class Library

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int LockCount { get; }
public int LockCount { get; }
Public ReadOnly Property LockCount As Integer
    Get
Public ReadOnly Property LockCount As Integer
    Get
public:
property int LockCount {
    int get ();
}
public:
property int LockCount {
    int get ();
}
member LockCount : int with get
member LockCount : int with get

Property Value

Type: Online Int32
See Also
TableOptions Class
TableOptions Members
NFX.DataAccess.Cache Namespace


TableOptions.MaxAgeSec Property

TableOptions MaxAgeSec Property NFX Class Library

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MaxAgeSec { get; }
public int MaxAgeSec { get; }
Public ReadOnly Property MaxAgeSec As Integer
    Get
Public ReadOnly Property MaxAgeSec As Integer
    Get
public:
property int MaxAgeSec {
    int get ();
}
public:
property int MaxAgeSec {
    int get ();
}
member MaxAgeSec : int with get
member MaxAgeSec : int with get

Property Value

Type: Online Int32
See Also
TableOptions Class
TableOptions Members
NFX.DataAccess.Cache Namespace


TableOptions.Name Property

TableOptions Name Property NFX Class Library

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
TableOptions Class
TableOptions Members
NFX.DataAccess.Cache Namespace


TableOptions.ParallelSweep Property

TableOptions ParallelSweep Property NFX Class Library

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ParallelSweep { get; }
public bool ParallelSweep { get; }
Public ReadOnly Property ParallelSweep As Boolean
    Get
Public ReadOnly Property ParallelSweep As Boolean
    Get
public:
property bool ParallelSweep {
    bool get ();
}
public:
property bool ParallelSweep {
    bool get ();
}
member ParallelSweep : bool with get
member ParallelSweep : bool with get

Property Value

Type: Online Boolean
See Also
TableOptions Class
TableOptions Members
NFX.DataAccess.Cache Namespace


TableOptions.RecPerPage Property

TableOptions RecPerPage Property NFX Class Library

Namespace: NFX.DataAccess.Cache
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int RecPerPage { get; }
public int RecPerPage { get; }
Public ReadOnly Property RecPerPage As Integer
    Get
Public ReadOnly Property RecPerPage As Integer
    Get
public:
property int RecPerPage {
    int get ();
}
public:
property int RecPerPage {
    int get ();
}
member RecPerPage : int with get
member RecPerPage : int with get

Property Value

Type: Online Int32
See Also
TableOptions Class
TableOptions Members
NFX.DataAccess.Cache Namespace


NFX.DataAccess.Cache.Instrumentation Namespace

NFX.DataAccess.Cache.Instrumentation Namespace NFX Class Library

[This is preliminary documentation and is subject to change.]

Defines instrumentation gauges and events for caching engine
Classes
 | Class | Description
Public class | BucketPageLoadFactor | Provides the ratio of how many buckets are loaded with pages vs. bucket count
Public class | CacheDoubleGauge | Provides base for cache double gauges
Public class | CacheLongGauge | Provides base for cache long gauges
Public class | HitCount | How many times Get() resulted in cache hit
Public class | MissCount | How many times Get() resulted in cache miss
Public class | PageCount | Provides page count in the instance
Public class | PutCollisionCount | How many times a call to Put() resulted in new value overriding existing because of collision (old value lost)
Public class | PutCount | How many times Put() was called
Public class | PutInsertCount | How many times a call to Put() resulted in insert
Public class | PutPageCreateCount | How many times a call to Put() resulted in bucket collision that created a page
Public class | PutPriorityPreventedCollisionCount | How many times a call to Put() could have resulted in new value overriding existing one because of collision, however the situation was prevented because existing item had higher priority than the newer one
Public class | PutReplaceCount | How many times a call to Put() resulted in relacement of existing item by key without collision
Public class | RecordCount | Provides record count in the instance
Public class | RemoveHitCount | How many records have been found and removed
Public class | RemoveMissCount | How many records have been sought to be removed but were not found
Public class | RemovePageCount | How many pages have been deleted, a page gets deleted when there are no records stored in it
Public class | SweepPageCount | How many pages swept
Public class | SweepRemoveCount | How many records removed by sweep
Public class | SweepTableCount | How many times tables were swept
Public class | ValueFactoryCount | How many times factory func was called from GetOrPut()


BucketPageLoadFactor Class

BucketPageLoadFactor Class NFX Class Library

Provides the ratio of how many buckets are loaded with pages vs. bucket count
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation DoubleGauge
NFX.DataAccess.Cache.Instrumentation CacheDoubleGauge
NFX.DataAccess.Cache.Instrumentation BucketPageLoadFactor

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class BucketPageLoadFactor : CacheDoubleGauge
[SerializableAttribute]
public class BucketPageLoadFactor : CacheDoubleGauge
<SerializableAttribute>
Public Class BucketPageLoadFactor
    Inherits CacheDoubleGauge
<SerializableAttribute>
Public Class BucketPageLoadFactor
    Inherits CacheDoubleGauge
[SerializableAttribute]
public ref class BucketPageLoadFactor : public CacheDoubleGauge
[SerializableAttribute]
public ref class BucketPageLoadFactor : public CacheDoubleGauge
[<SerializableAttribute>]
type BucketPageLoadFactor =
    class
        inherit CacheDoubleGauge
    end
[<SerializableAttribute>]
type BucketPageLoadFactor =
    class
        inherit CacheDoubleGauge
    end
See Also
BucketPageLoadFactor Members
NFX.DataAccess.Cache.Instrumentation Namespace


BucketPageLoadFactor Members

BucketPageLoadFactor Members NFX Class Library

The BucketPageLoadFactor type exposes the following members.
Constructors
 | Name | Description
Protected method | BucketPageLoadFactor | Initializes a new instance of the BucketPageLoadFactor class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from DoubleGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from DoubleGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from DoubleGauge.)
Public property | ValueAsObject | (Inherited from DoubleGauge.)
Public property | ValueUnitName | (Overrides DoubleGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
BucketPageLoadFactor Class
NFX.DataAccess.Cache.Instrumentation Namespace


BucketPageLoadFactor Constructor

BucketPageLoadFactor Constructor NFX Class Library

Initializes a new instance of the BucketPageLoadFactor class

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal BucketPageLoadFactor(
    string src,
    double value
)
internal BucketPageLoadFactor(
    string src,
    double value
)
Friend Sub New (
    src As String,
    value As Double
)
Friend Sub New (
    src As String,
    value As Double
)
internal:
BucketPageLoadFactor(
    String^ src,
    double value
)
internal:
BucketPageLoadFactor(
    String^ src,
    double value
)
new :
        src : string *
        value : float -> BucketPageLoadFactor
new :
        src : string *
        value : float -> BucketPageLoadFactor

Parameters

src
Type: Online System String
value
Type: Online System Double
See Also
BucketPageLoadFactor Class
BucketPageLoadFactor Members
NFX.DataAccess.Cache.Instrumentation Namespace


BucketPageLoadFactor Fields

BucketPageLoadFactor Fields NFX Class Library

The BucketPageLoadFactor type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
BucketPageLoadFactor Class
NFX.DataAccess.Cache.Instrumentation Namespace


BucketPageLoadFactor Methods

BucketPageLoadFactor Methods NFX Class Library

The BucketPageLoadFactor type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from DoubleGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from DoubleGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BucketPageLoadFactor Class
NFX.DataAccess.Cache.Instrumentation Namespace


BucketPageLoadFactor.MakeAggregateInstance Method

BucketPageLoadFactor MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
BucketPageLoadFactor Class
BucketPageLoadFactor Members
NFX.DataAccess.Cache.Instrumentation Namespace


BucketPageLoadFactor Properties

BucketPageLoadFactor Properties NFX Class Library

The BucketPageLoadFactor type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from DoubleGauge.)
Public property | ValueAsObject | (Inherited from DoubleGauge.)
Public property | ValueUnitName | (Overrides DoubleGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
BucketPageLoadFactor Class
NFX.DataAccess.Cache.Instrumentation Namespace


BucketPageLoadFactor.Description Property

BucketPageLoadFactor Description Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
BucketPageLoadFactor Class
BucketPageLoadFactor Members
NFX.DataAccess.Cache.Instrumentation Namespace


BucketPageLoadFactor.ValueUnitName Property

BucketPageLoadFactor ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
BucketPageLoadFactor Class
BucketPageLoadFactor Members
NFX.DataAccess.Cache.Instrumentation Namespace


CacheDoubleGauge Class

CacheDoubleGauge Class NFX Class Library

Provides base for cache double gauges
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation DoubleGauge
NFX.DataAccess.Cache.Instrumentation CacheDoubleGauge
NFX.DataAccess.Cache.Instrumentation BucketPageLoadFactor

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class CacheDoubleGauge : DoubleGauge,
    ICacheInstrument, IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public abstract class CacheDoubleGauge : DoubleGauge,
    ICacheInstrument, IMemoryInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public MustInherit Class CacheDoubleGauge
    Inherits DoubleGauge
    Implements ICacheInstrument, IMemoryInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public MustInherit Class CacheDoubleGauge
    Inherits DoubleGauge
    Implements ICacheInstrument, IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class CacheDoubleGauge abstract : public DoubleGauge,
    ICacheInstrument, IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class CacheDoubleGauge abstract : public DoubleGauge,
    ICacheInstrument, IMemoryInstrument, IOperationClass, IInstrumentClass
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type CacheDoubleGauge =
    class
        inherit DoubleGauge
        interface ICacheInstrument
        interface IMemoryInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type CacheDoubleGauge =
    class
        inherit DoubleGauge
        interface ICacheInstrument
        interface IMemoryInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
CacheDoubleGauge Members
NFX.DataAccess.Cache.Instrumentation Namespace


CacheDoubleGauge Members

CacheDoubleGauge Members NFX Class Library

The CacheDoubleGauge type exposes the following members.
Constructors
 | Name | Description
Protected method | CacheDoubleGauge | Initializes a new instance of the CacheDoubleGauge class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from DoubleGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from DoubleGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from DoubleGauge.)
Public property | ValueAsObject | (Inherited from DoubleGauge.)
Public property | ValueUnitName | (Inherited from DoubleGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheDoubleGauge Class
NFX.DataAccess.Cache.Instrumentation Namespace


CacheDoubleGauge Constructor

CacheDoubleGauge Constructor NFX Class Library

Initializes a new instance of the CacheDoubleGauge class

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CacheDoubleGauge(
    string src,
    double value
)
protected CacheDoubleGauge(
    string src,
    double value
)
Protected Sub New (
    src As String,
    value As Double
)
Protected Sub New (
    src As String,
    value As Double
)
protected:
CacheDoubleGauge(
    String^ src,
    double value
)
protected:
CacheDoubleGauge(
    String^ src,
    double value
)
new :
        src : string *
        value : float -> CacheDoubleGauge
new :
        src : string *
        value : float -> CacheDoubleGauge

Parameters

src
Type: Online System String
value
Type: Online System Double
See Also
CacheDoubleGauge Class
CacheDoubleGauge Members
NFX.DataAccess.Cache.Instrumentation Namespace


CacheDoubleGauge Fields

CacheDoubleGauge Fields NFX Class Library

The CacheDoubleGauge type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
CacheDoubleGauge Class
NFX.DataAccess.Cache.Instrumentation Namespace


CacheDoubleGauge Methods

CacheDoubleGauge Methods NFX Class Library

The CacheDoubleGauge type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from DoubleGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from DoubleGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CacheDoubleGauge Class
NFX.DataAccess.Cache.Instrumentation Namespace


CacheDoubleGauge Properties

CacheDoubleGauge Properties NFX Class Library

The CacheDoubleGauge type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from DoubleGauge.)
Public property | ValueAsObject | (Inherited from DoubleGauge.)
Public property | ValueUnitName | (Inherited from DoubleGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheDoubleGauge Class
NFX.DataAccess.Cache.Instrumentation Namespace


CacheLongGauge Class

CacheLongGauge Class NFX Class Library

Provides base for cache long gauges
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.DataAccess.Cache.Instrumentation CacheLongGauge
NFX.DataAccess.Cache.Instrumentation HitCount
NFX.DataAccess.Cache.Instrumentation MissCount
NFX.DataAccess.Cache.Instrumentation PageCount
NFX.DataAccess.Cache.Instrumentation PutCollisionCount
NFX.DataAccess.Cache.Instrumentation PutCount
NFX.DataAccess.Cache.Instrumentation PutInsertCount
NFX.DataAccess.Cache.Instrumentation PutPageCreateCount
NFX.DataAccess.Cache.Instrumentation PutPriorityPreventedCollisionCount
NFX.DataAccess.Cache.Instrumentation PutReplaceCount
NFX.DataAccess.Cache.Instrumentation RecordCount
NFX.DataAccess.Cache.Instrumentation RemoveHitCount
NFX.DataAccess.Cache.Instrumentation RemoveMissCount
NFX.DataAccess.Cache.Instrumentation RemovePageCount
NFX.DataAccess.Cache.Instrumentation SweepPageCount
NFX.DataAccess.Cache.Instrumentation SweepRemoveCount
NFX.DataAccess.Cache.Instrumentation SweepTableCount
NFX.DataAccess.Cache.Instrumentation ValueFactoryCount

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class CacheLongGauge : LongGauge,
    ICacheInstrument, IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public abstract class CacheLongGauge : LongGauge,
    ICacheInstrument, IMemoryInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public MustInherit Class CacheLongGauge
    Inherits LongGauge
    Implements ICacheInstrument, IMemoryInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public MustInherit Class CacheLongGauge
    Inherits LongGauge
    Implements ICacheInstrument, IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class CacheLongGauge abstract : public LongGauge,
    ICacheInstrument, IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class CacheLongGauge abstract : public LongGauge,
    ICacheInstrument, IMemoryInstrument, IOperationClass, IInstrumentClass
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type CacheLongGauge =
    class
        inherit LongGauge
        interface ICacheInstrument
        interface IMemoryInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type CacheLongGauge =
    class
        inherit LongGauge
        interface ICacheInstrument
        interface IMemoryInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
CacheLongGauge Members
NFX.DataAccess.Cache.Instrumentation Namespace


CacheLongGauge Members

CacheLongGauge Members NFX Class Library

The CacheLongGauge type exposes the following members.
Constructors
 | Name | Description
Protected method | CacheLongGauge | Initializes a new instance of the CacheLongGauge class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Inherited from LongGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheLongGauge Class
NFX.DataAccess.Cache.Instrumentation Namespace


CacheLongGauge Constructor

CacheLongGauge Constructor NFX Class Library

Initializes a new instance of the CacheLongGauge class

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CacheLongGauge(
    string src,
    long value
)
protected CacheLongGauge(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
CacheLongGauge(
    String^ src,
    long long value
)
protected:
CacheLongGauge(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> CacheLongGauge
new :
        src : string *
        value : int64 -> CacheLongGauge

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
CacheLongGauge Class
CacheLongGauge Members
NFX.DataAccess.Cache.Instrumentation Namespace


CacheLongGauge Fields

CacheLongGauge Fields NFX Class Library

The CacheLongGauge type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
CacheLongGauge Class
NFX.DataAccess.Cache.Instrumentation Namespace


CacheLongGauge Methods

CacheLongGauge Methods NFX Class Library

The CacheLongGauge type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CacheLongGauge Class
NFX.DataAccess.Cache.Instrumentation Namespace


CacheLongGauge Properties

CacheLongGauge Properties NFX Class Library

The CacheLongGauge type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Inherited from LongGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CacheLongGauge Class
NFX.DataAccess.Cache.Instrumentation Namespace


HitCount Class

HitCount Class NFX Class Library

How many times Get() resulted in cache hit
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.DataAccess.Cache.Instrumentation CacheLongGauge
NFX.DataAccess.Cache.Instrumentation HitCount

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class HitCount : CacheLongGauge
[SerializableAttribute]
public class HitCount : CacheLongGauge
<SerializableAttribute>
Public Class HitCount
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class HitCount
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class HitCount : public CacheLongGauge
[SerializableAttribute]
public ref class HitCount : public CacheLongGauge
[<SerializableAttribute>]
type HitCount =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type HitCount =
    class
        inherit CacheLongGauge
    end
See Also
HitCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


HitCount Members

HitCount Members NFX Class Library

The HitCount type exposes the following members.
Constructors
 | Name | Description
Protected method | HitCount | Initializes a new instance of the HitCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
HitCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


HitCount Constructor

HitCount Constructor NFX Class Library

Initializes a new instance of the HitCount class

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal HitCount(
    string src,
    long value
)
internal HitCount(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
HitCount(
    String^ src,
    long long value
)
internal:
HitCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> HitCount
new :
        src : string *
        value : int64 -> HitCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
HitCount Class
HitCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


HitCount Fields

HitCount Fields NFX Class Library

The HitCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
HitCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


HitCount Methods

HitCount Methods NFX Class Library

The HitCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
HitCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


HitCount.MakeAggregateInstance Method

HitCount MakeAggregateInstance Method NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
HitCount Class
HitCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


HitCount Properties

HitCount Properties NFX Class Library

The HitCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
HitCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


HitCount.Description Property

HitCount Description Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
HitCount Class
HitCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


HitCount.ValueUnitName Property

HitCount ValueUnitName Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
HitCount Class
HitCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


MissCount Class

MissCount Class NFX Class Library

How many times Get() resulted in cache miss
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.DataAccess.Cache.Instrumentation CacheLongGauge
NFX.DataAccess.Cache.Instrumentation MissCount

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MissCount : CacheLongGauge
[SerializableAttribute]
public class MissCount : CacheLongGauge
<SerializableAttribute>
Public Class MissCount
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class MissCount
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class MissCount : public CacheLongGauge
[SerializableAttribute]
public ref class MissCount : public CacheLongGauge
[<SerializableAttribute>]
type MissCount =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type MissCount =
    class
        inherit CacheLongGauge
    end
See Also
MissCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


MissCount Members

MissCount Members NFX Class Library

The MissCount type exposes the following members.
Constructors
 | Name | Description
Protected method | MissCount | Initializes a new instance of the MissCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
MissCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


MissCount Constructor

MissCount Constructor NFX Class Library

Initializes a new instance of the MissCount class

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal MissCount(
    string src,
    long value
)
internal MissCount(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
MissCount(
    String^ src,
    long long value
)
internal:
MissCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> MissCount
new :
        src : string *
        value : int64 -> MissCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
MissCount Class
MissCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


MissCount Fields

MissCount Fields NFX Class Library

The MissCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
MissCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


MissCount Methods

MissCount Methods NFX Class Library

The MissCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MissCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


MissCount.MakeAggregateInstance Method

MissCount MakeAggregateInstance Method NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
MissCount Class
MissCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


MissCount Properties

MissCount Properties NFX Class Library

The MissCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
MissCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


MissCount.Description Property

MissCount Description Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
MissCount Class
MissCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


MissCount.ValueUnitName Property

MissCount ValueUnitName Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
MissCount Class
MissCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PageCount Class

PageCount Class NFX Class Library

Provides page count in the instance
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.DataAccess.Cache.Instrumentation CacheLongGauge
NFX.DataAccess.Cache.Instrumentation PageCount

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PageCount : CacheLongGauge
[SerializableAttribute]
public class PageCount : CacheLongGauge
<SerializableAttribute>
Public Class PageCount
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class PageCount
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class PageCount : public CacheLongGauge
[SerializableAttribute]
public ref class PageCount : public CacheLongGauge
[<SerializableAttribute>]
type PageCount =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type PageCount =
    class
        inherit CacheLongGauge
    end
See Also
PageCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PageCount Members

PageCount Members NFX Class Library

The PageCount type exposes the following members.
Constructors
 | Name | Description
Protected method | PageCount | Initializes a new instance of the PageCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
PageCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PageCount Constructor

PageCount Constructor NFX Class Library

Initializes a new instance of the PageCount class

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal PageCount(
    string src,
    long value
)
internal PageCount(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
PageCount(
    String^ src,
    long long value
)
internal:
PageCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> PageCount
new :
        src : string *
        value : int64 -> PageCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
PageCount Class
PageCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PageCount Fields

PageCount Fields NFX Class Library

The PageCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
PageCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PageCount Methods

PageCount Methods NFX Class Library

The PageCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PageCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PageCount.MakeAggregateInstance Method

PageCount MakeAggregateInstance Method NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
PageCount Class
PageCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PageCount Properties

PageCount Properties NFX Class Library

The PageCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
PageCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PageCount.Description Property

PageCount Description Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
PageCount Class
PageCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PageCount.ValueUnitName Property

PageCount ValueUnitName Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
PageCount Class
PageCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutCollisionCount Class

PutCollisionCount Class NFX Class Library

How many times a call to Put() resulted in new value overriding existing because of collision (old value lost)
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.DataAccess.Cache.Instrumentation CacheLongGauge
NFX.DataAccess.Cache.Instrumentation PutCollisionCount

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PutCollisionCount : CacheLongGauge
[SerializableAttribute]
public class PutCollisionCount : CacheLongGauge
<SerializableAttribute>
Public Class PutCollisionCount
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class PutCollisionCount
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class PutCollisionCount : public CacheLongGauge
[SerializableAttribute]
public ref class PutCollisionCount : public CacheLongGauge
[<SerializableAttribute>]
type PutCollisionCount =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type PutCollisionCount =
    class
        inherit CacheLongGauge
    end
See Also
PutCollisionCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutCollisionCount Members

PutCollisionCount Members NFX Class Library

The PutCollisionCount type exposes the following members.
Constructors
 | Name | Description
Protected method | PutCollisionCount | Initializes a new instance of the PutCollisionCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
PutCollisionCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PutCollisionCount Constructor

PutCollisionCount Constructor NFX Class Library

Initializes a new instance of the PutCollisionCount class

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal PutCollisionCount(
    string src,
    long value
)
internal PutCollisionCount(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
PutCollisionCount(
    String^ src,
    long long value
)
internal:
PutCollisionCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> PutCollisionCount
new :
        src : string *
        value : int64 -> PutCollisionCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
PutCollisionCount Class
PutCollisionCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutCollisionCount Fields

PutCollisionCount Fields NFX Class Library

The PutCollisionCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
PutCollisionCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PutCollisionCount Methods

PutCollisionCount Methods NFX Class Library

The PutCollisionCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PutCollisionCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PutCollisionCount.MakeAggregateInstance Method

PutCollisionCount MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
PutCollisionCount Class
PutCollisionCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutCollisionCount Properties

PutCollisionCount Properties NFX Class Library

The PutCollisionCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
PutCollisionCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PutCollisionCount.Description Property

PutCollisionCount Description Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
PutCollisionCount Class
PutCollisionCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutCollisionCount.ValueUnitName Property

PutCollisionCount ValueUnitName Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
PutCollisionCount Class
PutCollisionCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutCount Class

PutCount Class NFX Class Library

How many times Put() was called
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.DataAccess.Cache.Instrumentation CacheLongGauge
NFX.DataAccess.Cache.Instrumentation PutCount

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PutCount : CacheLongGauge
[SerializableAttribute]
public class PutCount : CacheLongGauge
<SerializableAttribute>
Public Class PutCount
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class PutCount
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class PutCount : public CacheLongGauge
[SerializableAttribute]
public ref class PutCount : public CacheLongGauge
[<SerializableAttribute>]
type PutCount =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type PutCount =
    class
        inherit CacheLongGauge
    end
See Also
PutCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutCount Members

PutCount Members NFX Class Library

The PutCount type exposes the following members.
Constructors
 | Name | Description
Protected method | PutCount | Initializes a new instance of the PutCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
PutCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PutCount Constructor

PutCount Constructor NFX Class Library

Initializes a new instance of the PutCount class

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal PutCount(
    string src,
    long value
)
internal PutCount(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
PutCount(
    String^ src,
    long long value
)
internal:
PutCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> PutCount
new :
        src : string *
        value : int64 -> PutCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
PutCount Class
PutCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutCount Fields

PutCount Fields NFX Class Library

The PutCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
PutCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PutCount Methods

PutCount Methods NFX Class Library

The PutCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PutCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PutCount.MakeAggregateInstance Method

PutCount MakeAggregateInstance Method NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
PutCount Class
PutCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutCount Properties

PutCount Properties NFX Class Library

The PutCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
PutCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PutCount.Description Property

PutCount Description Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
PutCount Class
PutCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutCount.ValueUnitName Property

PutCount ValueUnitName Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
PutCount Class
PutCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutInsertCount Class

PutInsertCount Class NFX Class Library

How many times a call to Put() resulted in insert
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.DataAccess.Cache.Instrumentation CacheLongGauge
NFX.DataAccess.Cache.Instrumentation PutInsertCount

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PutInsertCount : CacheLongGauge
[SerializableAttribute]
public class PutInsertCount : CacheLongGauge
<SerializableAttribute>
Public Class PutInsertCount
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class PutInsertCount
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class PutInsertCount : public CacheLongGauge
[SerializableAttribute]
public ref class PutInsertCount : public CacheLongGauge
[<SerializableAttribute>]
type PutInsertCount =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type PutInsertCount =
    class
        inherit CacheLongGauge
    end
See Also
PutInsertCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutInsertCount Members

PutInsertCount Members NFX Class Library

The PutInsertCount type exposes the following members.
Constructors
 | Name | Description
Protected method | PutInsertCount | Initializes a new instance of the PutInsertCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
PutInsertCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PutInsertCount Constructor

PutInsertCount Constructor NFX Class Library

Initializes a new instance of the PutInsertCount class

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal PutInsertCount(
    string src,
    long value
)
internal PutInsertCount(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
PutInsertCount(
    String^ src,
    long long value
)
internal:
PutInsertCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> PutInsertCount
new :
        src : string *
        value : int64 -> PutInsertCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
PutInsertCount Class
PutInsertCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutInsertCount Fields

PutInsertCount Fields NFX Class Library

The PutInsertCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
PutInsertCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PutInsertCount Methods

PutInsertCount Methods NFX Class Library

The PutInsertCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PutInsertCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PutInsertCount.MakeAggregateInstance Method

PutInsertCount MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
PutInsertCount Class
PutInsertCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutInsertCount Properties

PutInsertCount Properties NFX Class Library

The PutInsertCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
PutInsertCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PutInsertCount.Description Property

PutInsertCount Description Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
PutInsertCount Class
PutInsertCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutInsertCount.ValueUnitName Property

PutInsertCount ValueUnitName Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
PutInsertCount Class
PutInsertCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutPageCreateCount Class

PutPageCreateCount Class NFX Class Library

How many times a call to Put() resulted in bucket collision that created a page
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.DataAccess.Cache.Instrumentation CacheLongGauge
NFX.DataAccess.Cache.Instrumentation PutPageCreateCount

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PutPageCreateCount : CacheLongGauge
[SerializableAttribute]
public class PutPageCreateCount : CacheLongGauge
<SerializableAttribute>
Public Class PutPageCreateCount
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class PutPageCreateCount
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class PutPageCreateCount : public CacheLongGauge
[SerializableAttribute]
public ref class PutPageCreateCount : public CacheLongGauge
[<SerializableAttribute>]
type PutPageCreateCount =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type PutPageCreateCount =
    class
        inherit CacheLongGauge
    end
See Also
PutPageCreateCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutPageCreateCount Members

PutPageCreateCount Members NFX Class Library

The PutPageCreateCount type exposes the following members.
Constructors
 | Name | Description
Protected method | PutPageCreateCount | Initializes a new instance of the PutPageCreateCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
PutPageCreateCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PutPageCreateCount Constructor

PutPageCreateCount Constructor NFX Class Library

Initializes a new instance of the PutPageCreateCount class

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal PutPageCreateCount(
    string src,
    long value
)
internal PutPageCreateCount(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
PutPageCreateCount(
    String^ src,
    long long value
)
internal:
PutPageCreateCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> PutPageCreateCount
new :
        src : string *
        value : int64 -> PutPageCreateCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
PutPageCreateCount Class
PutPageCreateCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutPageCreateCount Fields

PutPageCreateCount Fields NFX Class Library

The PutPageCreateCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
PutPageCreateCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PutPageCreateCount Methods

PutPageCreateCount Methods NFX Class Library

The PutPageCreateCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PutPageCreateCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PutPageCreateCount.MakeAggregateInstance Method

PutPageCreateCount MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
PutPageCreateCount Class
PutPageCreateCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutPageCreateCount Properties

PutPageCreateCount Properties NFX Class Library

The PutPageCreateCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
PutPageCreateCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PutPageCreateCount.Description Property

PutPageCreateCount Description Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
PutPageCreateCount Class
PutPageCreateCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutPageCreateCount.ValueUnitName Property

PutPageCreateCount ValueUnitName Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
PutPageCreateCount Class
PutPageCreateCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutPriorityPreventedCollisionCount Class

PutPriorityPreventedCollisionCount Class NFX Class Library

How many times a call to Put() could have resulted in new value overriding existing one because of collision, however the situation was prevented because existing item had higher priority than the newer one
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.DataAccess.Cache.Instrumentation CacheLongGauge
NFX.DataAccess.Cache.Instrumentation PutPriorityPreventedCollisionCount

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PutPriorityPreventedCollisionCount : CacheLongGauge
[SerializableAttribute]
public class PutPriorityPreventedCollisionCount : CacheLongGauge
<SerializableAttribute>
Public Class PutPriorityPreventedCollisionCount
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class PutPriorityPreventedCollisionCount
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class PutPriorityPreventedCollisionCount : public CacheLongGauge
[SerializableAttribute]
public ref class PutPriorityPreventedCollisionCount : public CacheLongGauge
[<SerializableAttribute>]
type PutPriorityPreventedCollisionCount =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type PutPriorityPreventedCollisionCount =
    class
        inherit CacheLongGauge
    end
See Also
PutPriorityPreventedCollisionCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutPriorityPreventedCollisionCount Members

PutPriorityPreventedCollisionCount Members NFX Class Library

The PutPriorityPreventedCollisionCount type exposes the following members.
Constructors
 | Name | Description
Protected method | PutPriorityPreventedCollisionCount | Initializes a new instance of the PutPriorityPreventedCollisionCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
PutPriorityPreventedCollisionCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PutPriorityPreventedCollisionCount Constructor

PutPriorityPreventedCollisionCount Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PutPriorityPreventedCollisionCount class

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal PutPriorityPreventedCollisionCount(
    string src,
    long value
)
internal PutPriorityPreventedCollisionCount(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
PutPriorityPreventedCollisionCount(
    String^ src,
    long long value
)
internal:
PutPriorityPreventedCollisionCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> PutPriorityPreventedCollisionCount
new :
        src : string *
        value : int64 -> PutPriorityPreventedCollisionCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
PutPriorityPreventedCollisionCount Class
PutPriorityPreventedCollisionCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutPriorityPreventedCollisionCount Fields

PutPriorityPreventedCollisionCount Fields NFX Class Library

The PutPriorityPreventedCollisionCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
PutPriorityPreventedCollisionCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PutPriorityPreventedCollisionCount Methods

PutPriorityPreventedCollisionCount Methods NFX Class Library

The PutPriorityPreventedCollisionCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PutPriorityPreventedCollisionCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PutPriorityPreventedCollisionCount.MakeAggregateInstance Method

PutPriorityPreventedCollisionCount MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
PutPriorityPreventedCollisionCount Class
PutPriorityPreventedCollisionCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutPriorityPreventedCollisionCount Properties

PutPriorityPreventedCollisionCount Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The PutPriorityPreventedCollisionCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
PutPriorityPreventedCollisionCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PutPriorityPreventedCollisionCount.Description Property

PutPriorityPreventedCollisionCount Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
PutPriorityPreventedCollisionCount Class
PutPriorityPreventedCollisionCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutPriorityPreventedCollisionCount.ValueUnitName Property

PutPriorityPreventedCollisionCount ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
PutPriorityPreventedCollisionCount Class
PutPriorityPreventedCollisionCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutReplaceCount Class

PutReplaceCount Class NFX Class Library

How many times a call to Put() resulted in relacement of existing item by key without collision
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.DataAccess.Cache.Instrumentation CacheLongGauge
NFX.DataAccess.Cache.Instrumentation PutReplaceCount

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PutReplaceCount : CacheLongGauge
[SerializableAttribute]
public class PutReplaceCount : CacheLongGauge
<SerializableAttribute>
Public Class PutReplaceCount
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class PutReplaceCount
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class PutReplaceCount : public CacheLongGauge
[SerializableAttribute]
public ref class PutReplaceCount : public CacheLongGauge
[<SerializableAttribute>]
type PutReplaceCount =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type PutReplaceCount =
    class
        inherit CacheLongGauge
    end
See Also
PutReplaceCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutReplaceCount Members

PutReplaceCount Members NFX Class Library

The PutReplaceCount type exposes the following members.
Constructors
 | Name | Description
Protected method | PutReplaceCount | Initializes a new instance of the PutReplaceCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
PutReplaceCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PutReplaceCount Constructor

PutReplaceCount Constructor NFX Class Library

Initializes a new instance of the PutReplaceCount class

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal PutReplaceCount(
    string src,
    long value
)
internal PutReplaceCount(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
PutReplaceCount(
    String^ src,
    long long value
)
internal:
PutReplaceCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> PutReplaceCount
new :
        src : string *
        value : int64 -> PutReplaceCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
PutReplaceCount Class
PutReplaceCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutReplaceCount Fields

PutReplaceCount Fields NFX Class Library

The PutReplaceCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
PutReplaceCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PutReplaceCount Methods

PutReplaceCount Methods NFX Class Library

The PutReplaceCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PutReplaceCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PutReplaceCount.MakeAggregateInstance Method

PutReplaceCount MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
PutReplaceCount Class
PutReplaceCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutReplaceCount Properties

PutReplaceCount Properties NFX Class Library

The PutReplaceCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
PutReplaceCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


PutReplaceCount.Description Property

PutReplaceCount Description Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
PutReplaceCount Class
PutReplaceCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


PutReplaceCount.ValueUnitName Property

PutReplaceCount ValueUnitName Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
PutReplaceCount Class
PutReplaceCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


RecordCount Class

RecordCount Class NFX Class Library

Provides record count in the instance
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.DataAccess.Cache.Instrumentation CacheLongGauge
NFX.DataAccess.Cache.Instrumentation RecordCount

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class RecordCount : CacheLongGauge
[SerializableAttribute]
public class RecordCount : CacheLongGauge
<SerializableAttribute>
Public Class RecordCount
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class RecordCount
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class RecordCount : public CacheLongGauge
[SerializableAttribute]
public ref class RecordCount : public CacheLongGauge
[<SerializableAttribute>]
type RecordCount =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type RecordCount =
    class
        inherit CacheLongGauge
    end
See Also
RecordCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


RecordCount Members

RecordCount Members NFX Class Library

The RecordCount type exposes the following members.
Constructors
 | Name | Description
Protected method | RecordCount | Initializes a new instance of the RecordCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
RecordCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


RecordCount Constructor

RecordCount Constructor NFX Class Library

Initializes a new instance of the RecordCount class

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal RecordCount(
    string src,
    long value
)
internal RecordCount(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
RecordCount(
    String^ src,
    long long value
)
internal:
RecordCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> RecordCount
new :
        src : string *
        value : int64 -> RecordCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
RecordCount Class
RecordCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


RecordCount Fields

RecordCount Fields NFX Class Library

The RecordCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
RecordCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


RecordCount Methods

RecordCount Methods NFX Class Library

The RecordCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
RecordCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


RecordCount.MakeAggregateInstance Method

RecordCount MakeAggregateInstance Method NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
RecordCount Class
RecordCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


RecordCount Properties

RecordCount Properties NFX Class Library

The RecordCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
RecordCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


RecordCount.Description Property

RecordCount Description Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
RecordCount Class
RecordCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


RecordCount.ValueUnitName Property

RecordCount ValueUnitName Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
RecordCount Class
RecordCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


RemoveHitCount Class

RemoveHitCount Class NFX Class Library

How many records have been found and removed
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.DataAccess.Cache.Instrumentation CacheLongGauge
NFX.DataAccess.Cache.Instrumentation RemoveHitCount

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class RemoveHitCount : CacheLongGauge
[SerializableAttribute]
public class RemoveHitCount : CacheLongGauge
<SerializableAttribute>
Public Class RemoveHitCount
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class RemoveHitCount
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class RemoveHitCount : public CacheLongGauge
[SerializableAttribute]
public ref class RemoveHitCount : public CacheLongGauge
[<SerializableAttribute>]
type RemoveHitCount =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type RemoveHitCount =
    class
        inherit CacheLongGauge
    end
See Also
RemoveHitCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


RemoveHitCount Members

RemoveHitCount Members NFX Class Library

The RemoveHitCount type exposes the following members.
Constructors
 | Name | Description
Protected method | RemoveHitCount | Initializes a new instance of the RemoveHitCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
RemoveHitCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


RemoveHitCount Constructor

RemoveHitCount Constructor NFX Class Library

Initializes a new instance of the RemoveHitCount class

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal RemoveHitCount(
    string src,
    long value
)
internal RemoveHitCount(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
RemoveHitCount(
    String^ src,
    long long value
)
internal:
RemoveHitCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> RemoveHitCount
new :
        src : string *
        value : int64 -> RemoveHitCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
RemoveHitCount Class
RemoveHitCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


RemoveHitCount Fields

RemoveHitCount Fields NFX Class Library

The RemoveHitCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
RemoveHitCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


RemoveHitCount Methods

RemoveHitCount Methods NFX Class Library

The RemoveHitCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
RemoveHitCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


RemoveHitCount.MakeAggregateInstance Method

RemoveHitCount MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
RemoveHitCount Class
RemoveHitCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


RemoveHitCount Properties

RemoveHitCount Properties NFX Class Library

The RemoveHitCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
RemoveHitCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


RemoveHitCount.Description Property

RemoveHitCount Description Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
RemoveHitCount Class
RemoveHitCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


RemoveHitCount.ValueUnitName Property

RemoveHitCount ValueUnitName Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
RemoveHitCount Class
RemoveHitCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


RemoveMissCount Class

RemoveMissCount Class NFX Class Library

How many records have been sought to be removed but were not found
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.DataAccess.Cache.Instrumentation CacheLongGauge
NFX.DataAccess.Cache.Instrumentation RemoveMissCount

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class RemoveMissCount : CacheLongGauge
[SerializableAttribute]
public class RemoveMissCount : CacheLongGauge
<SerializableAttribute>
Public Class RemoveMissCount
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class RemoveMissCount
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class RemoveMissCount : public CacheLongGauge
[SerializableAttribute]
public ref class RemoveMissCount : public CacheLongGauge
[<SerializableAttribute>]
type RemoveMissCount =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type RemoveMissCount =
    class
        inherit CacheLongGauge
    end
See Also
RemoveMissCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


RemoveMissCount Members

RemoveMissCount Members NFX Class Library

The RemoveMissCount type exposes the following members.
Constructors
 | Name | Description
Protected method | RemoveMissCount | Initializes a new instance of the RemoveMissCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
RemoveMissCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


RemoveMissCount Constructor

RemoveMissCount Constructor NFX Class Library

Initializes a new instance of the RemoveMissCount class

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal RemoveMissCount(
    string src,
    long value
)
internal RemoveMissCount(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
RemoveMissCount(
    String^ src,
    long long value
)
internal:
RemoveMissCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> RemoveMissCount
new :
        src : string *
        value : int64 -> RemoveMissCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
RemoveMissCount Class
RemoveMissCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


RemoveMissCount Fields

RemoveMissCount Fields NFX Class Library

The RemoveMissCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
RemoveMissCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


RemoveMissCount Methods

RemoveMissCount Methods NFX Class Library

The RemoveMissCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
RemoveMissCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


RemoveMissCount.MakeAggregateInstance Method

RemoveMissCount MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
RemoveMissCount Class
RemoveMissCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


RemoveMissCount Properties

RemoveMissCount Properties NFX Class Library

The RemoveMissCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
RemoveMissCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


RemoveMissCount.Description Property

RemoveMissCount Description Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
RemoveMissCount Class
RemoveMissCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


RemoveMissCount.ValueUnitName Property

RemoveMissCount ValueUnitName Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
RemoveMissCount Class
RemoveMissCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


RemovePageCount Class

RemovePageCount Class NFX Class Library

How many pages have been deleted, a page gets deleted when there are no records stored in it
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.DataAccess.Cache.Instrumentation CacheLongGauge
NFX.DataAccess.Cache.Instrumentation RemovePageCount

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class RemovePageCount : CacheLongGauge
[SerializableAttribute]
public class RemovePageCount : CacheLongGauge
<SerializableAttribute>
Public Class RemovePageCount
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class RemovePageCount
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class RemovePageCount : public CacheLongGauge
[SerializableAttribute]
public ref class RemovePageCount : public CacheLongGauge
[<SerializableAttribute>]
type RemovePageCount =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type RemovePageCount =
    class
        inherit CacheLongGauge
    end
See Also
RemovePageCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


RemovePageCount Members

RemovePageCount Members NFX Class Library

The RemovePageCount type exposes the following members.
Constructors
 | Name | Description
Protected method | RemovePageCount | Initializes a new instance of the RemovePageCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
RemovePageCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


RemovePageCount Constructor

RemovePageCount Constructor NFX Class Library

Initializes a new instance of the RemovePageCount class

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal RemovePageCount(
    string src,
    long value
)
internal RemovePageCount(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
RemovePageCount(
    String^ src,
    long long value
)
internal:
RemovePageCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> RemovePageCount
new :
        src : string *
        value : int64 -> RemovePageCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
RemovePageCount Class
RemovePageCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


RemovePageCount Fields

RemovePageCount Fields NFX Class Library

The RemovePageCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
RemovePageCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


RemovePageCount Methods

RemovePageCount Methods NFX Class Library

The RemovePageCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
RemovePageCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


RemovePageCount.MakeAggregateInstance Method

RemovePageCount MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
RemovePageCount Class
RemovePageCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


RemovePageCount Properties

RemovePageCount Properties NFX Class Library

The RemovePageCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
RemovePageCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


RemovePageCount.Description Property

RemovePageCount Description Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
RemovePageCount Class
RemovePageCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


RemovePageCount.ValueUnitName Property

RemovePageCount ValueUnitName Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
RemovePageCount Class
RemovePageCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


SweepPageCount Class

SweepPageCount Class NFX Class Library

How many pages swept
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.DataAccess.Cache.Instrumentation CacheLongGauge
NFX.DataAccess.Cache.Instrumentation SweepPageCount

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SweepPageCount : CacheLongGauge
[SerializableAttribute]
public class SweepPageCount : CacheLongGauge
<SerializableAttribute>
Public Class SweepPageCount
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class SweepPageCount
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class SweepPageCount : public CacheLongGauge
[SerializableAttribute]
public ref class SweepPageCount : public CacheLongGauge
[<SerializableAttribute>]
type SweepPageCount =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type SweepPageCount =
    class
        inherit CacheLongGauge
    end
See Also
SweepPageCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


SweepPageCount Members

SweepPageCount Members NFX Class Library

The SweepPageCount type exposes the following members.
Constructors
 | Name | Description
Protected method | SweepPageCount | Initializes a new instance of the SweepPageCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
SweepPageCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


SweepPageCount Constructor

SweepPageCount Constructor NFX Class Library

Initializes a new instance of the SweepPageCount class

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal SweepPageCount(
    string src,
    long value
)
internal SweepPageCount(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
SweepPageCount(
    String^ src,
    long long value
)
internal:
SweepPageCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> SweepPageCount
new :
        src : string *
        value : int64 -> SweepPageCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
SweepPageCount Class
SweepPageCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


SweepPageCount Fields

SweepPageCount Fields NFX Class Library

The SweepPageCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
SweepPageCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


SweepPageCount Methods

SweepPageCount Methods NFX Class Library

The SweepPageCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SweepPageCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


SweepPageCount.MakeAggregateInstance Method

SweepPageCount MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
SweepPageCount Class
SweepPageCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


SweepPageCount Properties

SweepPageCount Properties NFX Class Library

The SweepPageCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
SweepPageCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


SweepPageCount.Description Property

SweepPageCount Description Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
SweepPageCount Class
SweepPageCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


SweepPageCount.ValueUnitName Property

SweepPageCount ValueUnitName Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
SweepPageCount Class
SweepPageCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


SweepRemoveCount Class

SweepRemoveCount Class NFX Class Library

How many records removed by sweep
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.DataAccess.Cache.Instrumentation CacheLongGauge
NFX.DataAccess.Cache.Instrumentation SweepRemoveCount

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SweepRemoveCount : CacheLongGauge
[SerializableAttribute]
public class SweepRemoveCount : CacheLongGauge
<SerializableAttribute>
Public Class SweepRemoveCount
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class SweepRemoveCount
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class SweepRemoveCount : public CacheLongGauge
[SerializableAttribute]
public ref class SweepRemoveCount : public CacheLongGauge
[<SerializableAttribute>]
type SweepRemoveCount =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type SweepRemoveCount =
    class
        inherit CacheLongGauge
    end
See Also
SweepRemoveCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


SweepRemoveCount Members

SweepRemoveCount Members NFX Class Library

The SweepRemoveCount type exposes the following members.
Constructors
 | Name | Description
Protected method | SweepRemoveCount | Initializes a new instance of the SweepRemoveCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
SweepRemoveCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


SweepRemoveCount Constructor

SweepRemoveCount Constructor NFX Class Library

Initializes a new instance of the SweepRemoveCount class

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal SweepRemoveCount(
    string src,
    long value
)
internal SweepRemoveCount(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
SweepRemoveCount(
    String^ src,
    long long value
)
internal:
SweepRemoveCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> SweepRemoveCount
new :
        src : string *
        value : int64 -> SweepRemoveCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
SweepRemoveCount Class
SweepRemoveCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


SweepRemoveCount Fields

SweepRemoveCount Fields NFX Class Library

The SweepRemoveCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
SweepRemoveCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


SweepRemoveCount Methods

SweepRemoveCount Methods NFX Class Library

The SweepRemoveCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SweepRemoveCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


SweepRemoveCount.MakeAggregateInstance Method

SweepRemoveCount MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
SweepRemoveCount Class
SweepRemoveCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


SweepRemoveCount Properties

SweepRemoveCount Properties NFX Class Library

The SweepRemoveCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
SweepRemoveCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


SweepRemoveCount.Description Property

SweepRemoveCount Description Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
SweepRemoveCount Class
SweepRemoveCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


SweepRemoveCount.ValueUnitName Property

SweepRemoveCount ValueUnitName Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
SweepRemoveCount Class
SweepRemoveCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


SweepTableCount Class

SweepTableCount Class NFX Class Library

How many times tables were swept
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.DataAccess.Cache.Instrumentation CacheLongGauge
NFX.DataAccess.Cache.Instrumentation SweepTableCount

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SweepTableCount : CacheLongGauge
[SerializableAttribute]
public class SweepTableCount : CacheLongGauge
<SerializableAttribute>
Public Class SweepTableCount
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class SweepTableCount
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class SweepTableCount : public CacheLongGauge
[SerializableAttribute]
public ref class SweepTableCount : public CacheLongGauge
[<SerializableAttribute>]
type SweepTableCount =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type SweepTableCount =
    class
        inherit CacheLongGauge
    end
See Also
SweepTableCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


SweepTableCount Members

SweepTableCount Members NFX Class Library

The SweepTableCount type exposes the following members.
Constructors
 | Name | Description
Protected method | SweepTableCount | Initializes a new instance of the SweepTableCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
SweepTableCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


SweepTableCount Constructor

SweepTableCount Constructor NFX Class Library

Initializes a new instance of the SweepTableCount class

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal SweepTableCount(
    string src,
    long value
)
internal SweepTableCount(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
SweepTableCount(
    String^ src,
    long long value
)
internal:
SweepTableCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> SweepTableCount
new :
        src : string *
        value : int64 -> SweepTableCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
SweepTableCount Class
SweepTableCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


SweepTableCount Fields

SweepTableCount Fields NFX Class Library

The SweepTableCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
SweepTableCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


SweepTableCount Methods

SweepTableCount Methods NFX Class Library

The SweepTableCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SweepTableCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


SweepTableCount.MakeAggregateInstance Method

SweepTableCount MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
SweepTableCount Class
SweepTableCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


SweepTableCount Properties

SweepTableCount Properties NFX Class Library

The SweepTableCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
SweepTableCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


SweepTableCount.Description Property

SweepTableCount Description Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
SweepTableCount Class
SweepTableCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


SweepTableCount.ValueUnitName Property

SweepTableCount ValueUnitName Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
SweepTableCount Class
SweepTableCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


ValueFactoryCount Class

ValueFactoryCount Class NFX Class Library

How many times factory func was called from GetOrPut()
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.DataAccess.Cache.Instrumentation CacheLongGauge
NFX.DataAccess.Cache.Instrumentation ValueFactoryCount

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ValueFactoryCount : CacheLongGauge
[SerializableAttribute]
public class ValueFactoryCount : CacheLongGauge
<SerializableAttribute>
Public Class ValueFactoryCount
    Inherits CacheLongGauge
<SerializableAttribute>
Public Class ValueFactoryCount
    Inherits CacheLongGauge
[SerializableAttribute]
public ref class ValueFactoryCount : public CacheLongGauge
[SerializableAttribute]
public ref class ValueFactoryCount : public CacheLongGauge
[<SerializableAttribute>]
type ValueFactoryCount =
    class
        inherit CacheLongGauge
    end
[<SerializableAttribute>]
type ValueFactoryCount =
    class
        inherit CacheLongGauge
    end
See Also
ValueFactoryCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


ValueFactoryCount Members

ValueFactoryCount Members NFX Class Library

The ValueFactoryCount type exposes the following members.
Constructors
 | Name | Description
Protected method | ValueFactoryCount | Initializes a new instance of the ValueFactoryCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ValueFactoryCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


ValueFactoryCount Constructor

ValueFactoryCount Constructor NFX Class Library

Initializes a new instance of the ValueFactoryCount class

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ValueFactoryCount(
    string src,
    long value
)
internal ValueFactoryCount(
    string src,
    long value
)
Friend Sub New (
    src As String,
    value As Long
)
Friend Sub New (
    src As String,
    value As Long
)
internal:
ValueFactoryCount(
    String^ src,
    long long value
)
internal:
ValueFactoryCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ValueFactoryCount
new :
        src : string *
        value : int64 -> ValueFactoryCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ValueFactoryCount Class
ValueFactoryCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


ValueFactoryCount Fields

ValueFactoryCount Fields NFX Class Library

The ValueFactoryCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ValueFactoryCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


ValueFactoryCount Methods

ValueFactoryCount Methods NFX Class Library

The ValueFactoryCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ValueFactoryCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


ValueFactoryCount.MakeAggregateInstance Method

ValueFactoryCount MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ValueFactoryCount Class
ValueFactoryCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


ValueFactoryCount Properties

ValueFactoryCount Properties NFX Class Library

The ValueFactoryCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ValueFactoryCount Class
NFX.DataAccess.Cache.Instrumentation Namespace


ValueFactoryCount.Description Property

ValueFactoryCount Description Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ValueFactoryCount Class
ValueFactoryCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


ValueFactoryCount.ValueUnitName Property

ValueFactoryCount ValueUnitName Property NFX Class Library

Namespace: NFX.DataAccess.Cache.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ValueFactoryCount Class
ValueFactoryCount Members
NFX.DataAccess.Cache.Instrumentation Namespace


NFX.DataAccess.CRUD Namespace

NFX.DataAccess.CRUD Namespace NFX Class Library

Facilitates working with SQL and NoSQL backends on the level of records, rowsets, tables and queries
Classes
 | Class | Description
Public class | AmorphousDynamicRow | Represents a row of data which has a schema only known at run-time that also implements IAmorphousData interface that allows this row to store "extra" data that does not comply with the current schema. Dynamic rows store data in object[] internally, providing better flexibility(ability to define schema at runtime) than TypedRows at the expense of performance. This class is not sealed so implementors may override configuration persistence
Public class | AmorphousTypedRow | Represents a type-safe row of data when schema is known at compile-time that also implements IAmorphousData interface that allows this row to store "extra" data that does not comply with the current schema. Typed rows store data in instance fields, providing better performance and schema definition compile-time checking than DynamicRows at the expense of inability to define schema at runtime
Public class | CRUDException | Thrown by CRUD data access classes
Public class | CRUDFieldValidationException | Thrown by CRUD data access classes when field validation does not pass
Public class | CRUDOperationCallContext | Establishes a thead-static context which surrounds CRUD operations. You can derive your own classes, the .ctor must be chained. The context can be nested. A call to .ctor must be balanced with .Dispose(). This is needed to pass some out-of-band information in some special cases to CRUD operations without changing the caller interface, i.e. to swap database connection string. This class IS NOT THREAD SAFE, so in cases of async operations, the context captures extra parameters ONLY for initial ASYNC INVOCATION, that is- a true ASYNC implementation must pass the reference along the task execution line (in which case the object may be already Disposed but usable for property access
Public class | CRUDQueryHandler | Represents an entity that can execute a query. The implementation may be called by multiple threads and must be safe
Public class | CRUDQueryHandler TStore | Represents an entity that can execute a query. The implementation may be called by multiple threads and must be safe
Public class | CRUDRowValidationException | Thrown by CRUD data access classes when field validation does not pass
Public class | CRUDTransaction | Represents an abstract base for CRUDTransactions that perform particular backend CRUD work in overriden classes
Public class | CRUDValidationException | Thrown by CRUD data access classes when validation does not pass
Public class | Cursor | Represents a buffer-less unidicrectional reader that binds IEnumerable(Row) and the backend resource (such as SQLReader or other object which is internal to the backend). The cursor is NOT thread-safe and must be disposed properly by closing all resources associated with it. Only one iteration (one call to GetEnumerator) is possible
Protected class | Cursor enumerator |
Public class | DynamicRow | Represents a row of data which has a schema only known at run-time. Dynamic rows store data in object[] internally, providing better flexibility(ability to define schema at runtime) than TypedRows at the expense of performance. This class is not sealed so implementors may override configuration persistence
Public class | FieldAttribute | Provides information about table schema that this typed row is a part of
Public class | FormModel | Represents a "model" (in MVC terms) of a data-entry form. Form models are statically typed - contain fields and can contain "extra amorphous" data
Public class | JSONMappings | Facilitates mapping of CRUD/CLR types/values to JSON and back to CLR/CRUD
Public class | NotImplementedCRUDDataStore |
Public class | Query | Defines a query sent into ICRUDDataStore implementor to retrieve data. A Query is a named bag of paremeters where every parameter has a name and the value.
Public class | Query Param | Represents a CRUD query parameter
Public class | Query TResultRow | Generic version of Query
Public class | QueryResolver | Infrastructure class - not for app developers. Resolves Query objects into query handlers. Query names are case-insensitive. This class is thread-safe
Public class | QuerySource | Represents query source code with pre-processed pragmas
Public class | QuerySource ColumnDef | Provides column definition in QuerySource
Public class | Row | Base class for any CRUD row. This class has two direct subtypes - DynamicRow and TypedRow. Rows are NOT THREAD SAFE by definition
Public class | RowEqualityComparer | Checks for reference equality. Use RowEqualityComparer.Instance
Public class | Rowset | Implements a rowset that supports row change logging and CRUD operations. Rowsets are not optimal for data replication as they perform linear search which is slow, however Rowset class supports sorting. In contrast, Tables are kind of rowsets that keep data pre-sorted by key thus facilitating quick searching
Public class | RowsetBase | Provides base for rowset implementation. Rowsets are mutable lists of rows where all rows must have the same schema, however a rowset may contain a mix of dynamic and typed rows as long as they have the same schema. Rowsets are not thread-safe
Public class | Schema | Describes a schema for rows: TypedRows and DynamicRows. DynamicRows are "shaped" in memory from schema, whereas, TypedRows define schema. Schema for Typedrows is cached in static dictionary for speed
Public class | Schema FieldDef | Provides a definition for a single field of a row
Public class | Table | Implements a master table. Tables are rowsets that are pre-sorted by keys. They are used in scenarios when in-memory data replication is needed. A table supports efficient FindKey() operation but does not support sorting. This class is not thread-safe.
Public class | TableAttribute | Provides information about table schema that this row is a part of
Public class | TargetedAttribute | Provides a base for attributes which ar targeted for particular techlology (i.e. "ORACLE")
Public class | TypedRow | Represents a type-safe row of data when schema is known at compile-time. Typed rows store data in instance fields, providing better performance and schema definition compile-time checking than DynamicRows at the expense of inability to define schema at runtime
Public class | UniqueSequenceAttribute | Provides information for unique sequence gen: scope and name
Structures
 | Structure | Description
Public structure | CacheParams | Implements ICacheParams - supplied caching parameters
Protected structure | iListReadOnly |
Public structure | RowChange | Describes row modification
Interfaces
 | Interface | Description
Public interface | IAmorphousData | Denotes an entity, which is typically a row-derivative, that has extra data fields that are not defined by particular schema and get represented as {name:value} map instead (schema-less data). This interface is usually implemented by rows that support version changing between releases, i.e. when structured storage (such as Mongo DB) stores more fields than are currently declared in the row the extra fields will be placed in the AmorphousData collection. This interface also provides hook BeforeSave()/AfterLoad() that allow for transforms between Amorphous and "hard-schema" data models
Public interface | ICacheParams | Supplies caching params
Public interface | ICRUDDataStore | Represents a DataStore that supports CRUD operations
Public interface | ICRUDDataStoreImplementation |
Public interface | ICRUDOperations | Describes an entity that performs single (not in transaction/batch)CRUD operations
Public interface | ICRUDQueryExecutionContext | Represents a context (such as Sql Server connection + transaction scope, or Hadoop connect string etc.) for query execution. This is a marker interface implemented by particular providers
Public interface | ICRUDQueryResolver | Represents a class that resolves Query into suitable handler that can execute it
Public interface | ICRUDTransactionOperations | Describes an entity that performs single (not in transaction/batch)CRUD operations
Public interface | IValidatable | Denotes an entity that supports validation
Delegates
 | Delegate | Description
Public delegate | FieldFilterFunc | Provides filter predicate for CRUD operations. Return true to include the specified field
Public delegate | SetFieldFunc | Injects function that tries to set field value. May elect to skip the set and return false to indicate failure(instead of throwing exception)
Enumerations
 | Enumeration | Description
Public enumeration | CRUDDataStoreType | Denotes types of CRUD stores
Public enumeration | DataKind | Provides hint/classification for field textual data
Public enumeration | FormMode | Denotes form modes: unspecified | insert | edit
Public enumeration | RowChangeType | Describes what kind of modification was done
Public enumeration | TransactionDisposeBehavior | Specifies how transaction scope behaves on scope exit
Public enumeration | TransactionStatus | Denotes transaction statuses


AmorphousDynamicRow Class

AmorphousDynamicRow Class NFX Class Library

Represents a row of data which has a schema only known at run-time that also implements IAmorphousData interface that allows this row to store "extra" data that does not comply with the current schema. Dynamic rows store data in object[] internally, providing better flexibility(ability to define schema at runtime) than TypedRows at the expense of performance. This class is not sealed so implementors may override configuration persistence
Inheritance Hierarchy
Online System Object
NFX.DataAccess.CRUD Row
NFX.DataAccess.CRUD DynamicRow
NFX.DataAccess.CRUD AmorphousDynamicRow

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class AmorphousDynamicRow : DynamicRow,
    IAmorphousData
[SerializableAttribute]
public class AmorphousDynamicRow : DynamicRow,
    IAmorphousData
<SerializableAttribute>
Public Class AmorphousDynamicRow
    Inherits DynamicRow
    Implements IAmorphousData
<SerializableAttribute>
Public Class AmorphousDynamicRow
    Inherits DynamicRow
    Implements IAmorphousData
[SerializableAttribute]
public ref class AmorphousDynamicRow : public DynamicRow,
    IAmorphousData
[SerializableAttribute]
public ref class AmorphousDynamicRow : public DynamicRow,
    IAmorphousData
[<SerializableAttribute>]
type AmorphousDynamicRow =
    class
        inherit DynamicRow
        interface IAmorphousData
    end
[<SerializableAttribute>]
type AmorphousDynamicRow =
    class
        inherit DynamicRow
        interface IAmorphousData
    end
See Also
AmorphousDynamicRow Members
NFX.DataAccess.CRUD Namespace


AmorphousDynamicRow Members

AmorphousDynamicRow Members NFX Class Library

The AmorphousDynamicRow type exposes the following members.
Constructors
 | Name | Description
Public method | AmorphousDynamicRow | Initializes a new instance of the AmorphousDynamicRow class
Back to Top
Methods
 | Name | Description
Protected method | __ctor | Developers do not call, lazily injects the statr of this object, this is needed for speed and other optimizations (Inherited from DynamicRow.)
Public method | AfterLoad | Invoked to allow the row to hydrate its fields/state from AmorphousData bag. For example, this may be used to reconstruct some temporary object state that is not stored as a part of established business schema. The operation is performed per particular targetName (name of physical backend). Simply put, this method allows business code to "specify what to do after object gets loaded from THE PARTICULAR TARGET backend store". An example: suppose current MongoDB collection stores 3 fields for name, and we want to collapse First/Last/Middle name fields into one field. If we change rowschema then it will only contain 1 field which is not present in the database, however those 'older' fields will get populated into AmorphousData giving us an option to merge older 3 fields into 1 within AfterLoad() implementation
Public method | ApplyDefaultFieldValues | Writes default values specified in schema into fields. Pass overwrite=true to force defaults over non-null existing values (false by default) (Inherited from Row.)
Public method | BeforeSave | Invoked to allow the row to transform its state into AmorphousData bag. For example, this may be usefull to store extra data that is not a part of established business schema. The operation is performed per particular targetName (name of physical backend). Simply put, this method allows business code to "specify what to do before object gets saved in THE PARTICULAR TARGET backend store"
Protected method | CheckMinMax | (Inherited from Row.)
Public method | Configure | In base class applies Config attribute. Useful for typed rows (Inherited from Row.)
Public method | ConvertFieldValueToDef | Converts field value to the type specified by Schema.FieldDef. For example converts GDID->ulong or ulong->GDID. This method can be overridden to perform custom handling of types, for example one can assign bool field as "Si" that would convert to TRUE. This method is called by SetFieldValue(...) before assigning actual field buffer (Inherited from Row.)
Public method | CopyFields | Copies fields from this row into another row/form. Note: this is shallow copy, as field values for complex types are just copied over (Inherited from Row.)
Public method | Equals(Object) | Object override - sealed. Override Equals(row) instead (Inherited from Row.)
Public method | Equals(Row) | Override to perform custom row equality comparison. Default implementation equates rows using their key fields (Inherited from Row.)
Protected method | FilterJSONSerializerField | Override to filter-out some fields from serialization to JSON, or change field values. Return name null to indicate that field should be filtered-out(excluded from serialization to JSON) (Inherited from Row.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetClientFieldDef | Override to perform dynamic substitute of field def for the specified field. This method is used by client ui/scaffolding to extract dynamic definition for a field (i.e. field description, requirement, value list etc.) as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original field def, you can return a substituted field def per particular business logic (Inherited from Row.)
Public method | GetClientFieldValue | Override to perform dynamic substitute of field value for the specified field. This method is used by client ui/scaffolding to extract field values for a field as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original GetFieldValue(fdef), you can return a substituted field value per particular business logic (Inherited from Row.)
Public method | GetClientFieldValueList | Override to perform dynamic lookup of field value list for the specified field. This method is used by client ui/scaffolding to extract dynamic lookup values as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. This is a simplified version of GetClientFieldDef (Inherited from Row.)
Public method | GetDataStoreKey | Returns values for fields that represent row's primary key (Inherited from Row.)
Public method | GetDisplayFieldValue(Int32, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute (Inherited from Row.)
Public method | GetDisplayFieldValue(String, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute (Inherited from Row.)
Public method | GetEnumerator | (Inherited from Row.)
Public method | GetFieldValue | (Inherited from DynamicRow.)
Public method | GetFieldValueDescription(Int32, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema (Inherited from Row.)
Public method | GetFieldValueDescription(String, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema (Inherited from Row.)
Public method | GetHashCode | Object override - gets hash code from key fields (Inherited from Row.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PersistConfiguration | The base class does not implement this method. Override to persist row fields into config node (Inherited from Row.)
Public method | SetFieldValue | (Inherited from DynamicRow.)
Public method | SimpleFilterPredicate | Returns true if this row satisfies simple filter - it contains the supplied filter string. The filter pattern may start or end with "*" char that denotes a wildcard. A wildcard is permitted on both sides of the filter value (Inherited from Row.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Validate | Performs validation of data in the row returning exception object that provides description in cases when validation does not pass. Validation is performed not targeting any particular backend (Inherited from Row.)
Public method | Validate(String) | Validates row using row schema and supplied field definitions. Override to perform custom validations, i.e. TypeRows may directly access properties and write some validation type-safe code The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from Row.)
Public method | ValidateField(String, Schema FieldDef) | Validates row field using Schema.FieldDef settings. This method is invoked by base Validate() implementation. The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from Row.)
Public method | ValidateField(String, String) | Validates row field by name. Shortcut to ValidateField(Schema.FieldDef) (Inherited from Row.)
Public method | WriteAsJSON | Writes row as JSON either as an array or map depending on JSONWritingOptions.RowsAsMap setting. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class (Inherited from Row.)
Back to Top
Extension Methods
Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method ToErlObject Overloaded.
Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(ErlTypeOrder, Boolean) Overloaded.
Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(String, String, Boolean) Overloaded.
Convert Row to a hierarchical term that corresponds to the row's schema. The Erlang term is in the form:
View Colorized Copy to Clipboard Print
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
(Defined by ErlSchemaUtils.)
Public Extension Method ToJSON(JSONWritingOptions) Overloaded.
Serializes object into JSON string
(Defined by JSONExtensions.)
Public Extension Method ToJSON(TextWriter, JSONWritingOptions) Overloaded.
Serializes object into JSON format using provided TextWriter
(Defined by JSONExtensions.)
Public Extension Method ToJSON(Stream, JSONWritingOptions, Encoding) Overloaded.
Serializes object into JSON format using provided stream and optional encoding
(Defined by JSONExtensions.)
Public Extension Method Update
Convert an Erlang hierarchical term representing a schema to a Row.
(Defined by ErlSchemaUtils.)
Back to Top
Properties
 | Name | Description
Public property | AmorphousData | Returns data that does not comply with known schema (dynamic data). The field names are NOT case-sensitive
Public property | AmorphousDataEnabled | True by default for rows
Public property | Data | Provides access to raw array of values that this row contains (Inherited from DynamicRow.)
Public property | Item Int32 | Gets/sets field values by positional index(Order) (Inherited from Row.)
Public property | Item String | Gets/sets field values by name (Inherited from Row.)
Public property | Schema | References a schema for a table that this row is a part of (Inherited from DynamicRow.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Row.)
Back to Top
See Also
AmorphousDynamicRow Class
NFX.DataAccess.CRUD Namespace


AmorphousDynamicRow Constructor

AmorphousDynamicRow Constructor NFX Class Library

Initializes a new instance of the AmorphousDynamicRow class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AmorphousDynamicRow(
    Schema schema
)
public AmorphousDynamicRow(
    Schema schema
)
Public Sub New (
    schema As Schema
)
Public Sub New (
    schema As Schema
)
public:
AmorphousDynamicRow(
    Schema^ schema
)
public:
AmorphousDynamicRow(
    Schema^ schema
)
new :
        schema : Schema -> AmorphousDynamicRow
new :
        schema : Schema -> AmorphousDynamicRow

Parameters

schema
Type: NFX.DataAccess.CRUD Schema
See Also
AmorphousDynamicRow Class
AmorphousDynamicRow Members
NFX.DataAccess.CRUD Namespace


AmorphousDynamicRow Methods

AmorphousDynamicRow Methods NFX Class Library

The AmorphousDynamicRow type exposes the following members.
Methods
 | Name | Description
Protected method | __ctor | Developers do not call, lazily injects the statr of this object, this is needed for speed and other optimizations (Inherited from DynamicRow.)
Public method | AfterLoad | Invoked to allow the row to hydrate its fields/state from AmorphousData bag. For example, this may be used to reconstruct some temporary object state that is not stored as a part of established business schema. The operation is performed per particular targetName (name of physical backend). Simply put, this method allows business code to "specify what to do after object gets loaded from THE PARTICULAR TARGET backend store". An example: suppose current MongoDB collection stores 3 fields for name, and we want to collapse First/Last/Middle name fields into one field. If we change rowschema then it will only contain 1 field which is not present in the database, however those 'older' fields will get populated into AmorphousData giving us an option to merge older 3 fields into 1 within AfterLoad() implementation
Public method | ApplyDefaultFieldValues | Writes default values specified in schema into fields. Pass overwrite=true to force defaults over non-null existing values (false by default) (Inherited from Row.)
Public method | BeforeSave | Invoked to allow the row to transform its state into AmorphousData bag. For example, this may be usefull to store extra data that is not a part of established business schema. The operation is performed per particular targetName (name of physical backend). Simply put, this method allows business code to "specify what to do before object gets saved in THE PARTICULAR TARGET backend store"
Protected method | CheckMinMax | (Inherited from Row.)
Public method | Configure | In base class applies Config attribute. Useful for typed rows (Inherited from Row.)
Public method | ConvertFieldValueToDef | Converts field value to the type specified by Schema.FieldDef. For example converts GDID->ulong or ulong->GDID. This method can be overridden to perform custom handling of types, for example one can assign bool field as "Si" that would convert to TRUE. This method is called by SetFieldValue(...) before assigning actual field buffer (Inherited from Row.)
Public method | CopyFields | Copies fields from this row into another row/form. Note: this is shallow copy, as field values for complex types are just copied over (Inherited from Row.)
Public method | Equals(Object) | Object override - sealed. Override Equals(row) instead (Inherited from Row.)
Public method | Equals(Row) | Override to perform custom row equality comparison. Default implementation equates rows using their key fields (Inherited from Row.)
Protected method | FilterJSONSerializerField | Override to filter-out some fields from serialization to JSON, or change field values. Return name null to indicate that field should be filtered-out(excluded from serialization to JSON) (Inherited from Row.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetClientFieldDef | Override to perform dynamic substitute of field def for the specified field. This method is used by client ui/scaffolding to extract dynamic definition for a field (i.e. field description, requirement, value list etc.) as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original field def, you can return a substituted field def per particular business logic (Inherited from Row.)
Public method | GetClientFieldValue | Override to perform dynamic substitute of field value for the specified field. This method is used by client ui/scaffolding to extract field values for a field as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original GetFieldValue(fdef), you can return a substituted field value per particular business logic (Inherited from Row.)
Public method | GetClientFieldValueList | Override to perform dynamic lookup of field value list for the specified field. This method is used by client ui/scaffolding to extract dynamic lookup values as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. This is a simplified version of GetClientFieldDef (Inherited from Row.)
Public method | GetDataStoreKey | Returns values for fields that represent row's primary key (Inherited from Row.)
Public method | GetDisplayFieldValue(Int32, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute (Inherited from Row.)
Public method | GetDisplayFieldValue(String, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute (Inherited from Row.)
Public method | GetEnumerator | (Inherited from Row.)
Public method | GetFieldValue | (Inherited from DynamicRow.)
Public method | GetFieldValueDescription(Int32, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema (Inherited from Row.)
Public method | GetFieldValueDescription(String, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema (Inherited from Row.)
Public method | GetHashCode | Object override - gets hash code from key fields (Inherited from Row.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PersistConfiguration | The base class does not implement this method. Override to persist row fields into config node (Inherited from Row.)
Public method | SetFieldValue | (Inherited from DynamicRow.)
Public method | SimpleFilterPredicate | Returns true if this row satisfies simple filter - it contains the supplied filter string. The filter pattern may start or end with "*" char that denotes a wildcard. A wildcard is permitted on both sides of the filter value (Inherited from Row.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Validate | Performs validation of data in the row returning exception object that provides description in cases when validation does not pass. Validation is performed not targeting any particular backend (Inherited from Row.)
Public method | Validate(String) | Validates row using row schema and supplied field definitions. Override to perform custom validations, i.e. TypeRows may directly access properties and write some validation type-safe code The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from Row.)
Public method | ValidateField(String, Schema FieldDef) | Validates row field using Schema.FieldDef settings. This method is invoked by base Validate() implementation. The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from Row.)
Public method | ValidateField(String, String) | Validates row field by name. Shortcut to ValidateField(Schema.FieldDef) (Inherited from Row.)
Public method | WriteAsJSON | Writes row as JSON either as an array or map depending on JSONWritingOptions.RowsAsMap setting. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class (Inherited from Row.)
Back to Top
Extension Methods
Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method ToErlObject Overloaded.
Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(ErlTypeOrder, Boolean) Overloaded.
Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(String, String, Boolean) Overloaded.
Convert Row to a hierarchical term that corresponds to the row's schema. The Erlang term is in the form:
View Colorized Copy to Clipboard Print
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
(Defined by ErlSchemaUtils.)
Public Extension Method ToJSON(JSONWritingOptions) Overloaded.
Serializes object into JSON string
(Defined by JSONExtensions.)
Public Extension Method ToJSON(TextWriter, JSONWritingOptions) Overloaded.
Serializes object into JSON format using provided TextWriter
(Defined by JSONExtensions.)
Public Extension Method ToJSON(Stream, JSONWritingOptions, Encoding) Overloaded.
Serializes object into JSON format using provided stream and optional encoding
(Defined by JSONExtensions.)
Public Extension Method Update
Convert an Erlang hierarchical term representing a schema to a Row.
(Defined by ErlSchemaUtils.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Row.)
Back to Top
See Also
AmorphousDynamicRow Class
NFX.DataAccess.CRUD Namespace


AmorphousDynamicRow.AfterLoad Method

AmorphousDynamicRow AfterLoad Method NFX Class Library

Invoked to allow the row to hydrate its fields/state from AmorphousData bag. For example, this may be used to reconstruct some temporary object state that is not stored as a part of established business schema. The operation is performed per particular targetName (name of physical backend). Simply put, this method allows business code to "specify what to do after object gets loaded from THE PARTICULAR TARGET backend store". An example: suppose current MongoDB collection stores 3 fields for name, and we want to collapse First/Last/Middle name fields into one field. If we change rowschema then it will only contain 1 field which is not present in the database, however those 'older' fields will get populated into AmorphousData giving us an option to merge older 3 fields into 1 within AfterLoad() implementation

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void AfterLoad(
    string targetName
)
public virtual void AfterLoad(
    string targetName
)
Public Overridable Sub AfterLoad (
    targetName As String
)
Public Overridable Sub AfterLoad (
    targetName As String
)
public:
virtual void AfterLoad(
    String^ targetName
)
public:
virtual void AfterLoad(
    String^ targetName
)
abstract AfterLoad :
        targetName : string -> unit
override AfterLoad :
        targetName : string -> unit
abstract AfterLoad :
        targetName : string -> unit
override AfterLoad :
        targetName : string -> unit

Parameters

targetName
Type: Online System String

Implements

IAmorphousData AfterLoad(String)
See Also
AmorphousDynamicRow Class
AmorphousDynamicRow Members
NFX.DataAccess.CRUD Namespace


AmorphousDynamicRow.BeforeSave Method

AmorphousDynamicRow BeforeSave Method NFX Class Library

Invoked to allow the row to transform its state into AmorphousData bag. For example, this may be usefull to store extra data that is not a part of established business schema. The operation is performed per particular targetName (name of physical backend). Simply put, this method allows business code to "specify what to do before object gets saved in THE PARTICULAR TARGET backend store"

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void BeforeSave(
    string targetName
)
public virtual void BeforeSave(
    string targetName
)
Public Overridable Sub BeforeSave (
    targetName As String
)
Public Overridable Sub BeforeSave (
    targetName As String
)
public:
virtual void BeforeSave(
    String^ targetName
)
public:
virtual void BeforeSave(
    String^ targetName
)
abstract BeforeSave :
        targetName : string -> unit
override BeforeSave :
        targetName : string -> unit
abstract BeforeSave :
        targetName : string -> unit
override BeforeSave :
        targetName : string -> unit

Parameters

targetName
Type: Online System String

Implements

IAmorphousData BeforeSave(String)
See Also
AmorphousDynamicRow Class
AmorphousDynamicRow Members
NFX.DataAccess.CRUD Namespace


AmorphousDynamicRow Properties

AmorphousDynamicRow Properties NFX Class Library

The AmorphousDynamicRow type exposes the following members.
Properties
 | Name | Description
Public property | AmorphousData | Returns data that does not comply with known schema (dynamic data). The field names are NOT case-sensitive
Public property | AmorphousDataEnabled | True by default for rows
Public property | Data | Provides access to raw array of values that this row contains (Inherited from DynamicRow.)
Public property | Item Int32 | Gets/sets field values by positional index(Order) (Inherited from Row.)
Public property | Item String | Gets/sets field values by name (Inherited from Row.)
Public property | Schema | References a schema for a table that this row is a part of (Inherited from DynamicRow.)
Back to Top
See Also
AmorphousDynamicRow Class
NFX.DataAccess.CRUD Namespace


AmorphousDynamicRow.AmorphousData Property

AmorphousDynamicRow AmorphousData Property NFX Class Library

Returns data that does not comply with known schema (dynamic data). The field names are NOT case-sensitive

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<string, Object> AmorphousData { get; }
public IDictionary<string, Object> AmorphousData { get; }
Public ReadOnly Property AmorphousData As IDictionary(Of String, Object)
    Get
Public ReadOnly Property AmorphousData As IDictionary(Of String, Object)
    Get
public:
virtual property IDictionary<String^, Object^>^ AmorphousData {
    IDictionary<String^, Object^>^ get () sealed;
}
public:
virtual property IDictionary<String^, Object^>^ AmorphousData {
    IDictionary<String^, Object^>^ get () sealed;
}
abstract AmorphousData : IDictionary<string, Object> with get
override AmorphousData : IDictionary<string, Object> with get
abstract AmorphousData : IDictionary<string, Object> with get
override AmorphousData : IDictionary<string, Object> with get

Property Value

Type: Online IDictionary Online String, Online Object

Implements

IAmorphousData AmorphousData
See Also
AmorphousDynamicRow Class
AmorphousDynamicRow Members
NFX.DataAccess.CRUD Namespace


AmorphousDynamicRow.AmorphousDataEnabled Property

AmorphousDynamicRow AmorphousDataEnabled Property NFX Class Library

[This is preliminary documentation and is subject to change.]

True by default for rows

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool AmorphousDataEnabled { get; }
public virtual bool AmorphousDataEnabled { get; }
Public Overridable ReadOnly Property AmorphousDataEnabled As Boolean
    Get
Public Overridable ReadOnly Property AmorphousDataEnabled As Boolean
    Get
public:
virtual property bool AmorphousDataEnabled {
    bool get ();
}
public:
virtual property bool AmorphousDataEnabled {
    bool get ();
}
abstract AmorphousDataEnabled : bool with get
override AmorphousDataEnabled : bool with get
abstract AmorphousDataEnabled : bool with get
override AmorphousDataEnabled : bool with get

Property Value

Type: Online Boolean

Implements

IAmorphousData AmorphousDataEnabled
See Also
AmorphousDynamicRow Class
AmorphousDynamicRow Members
NFX.DataAccess.CRUD Namespace


AmorphousTypedRow Class

AmorphousTypedRow Class NFX Class Library

Represents a type-safe row of data when schema is known at compile-time that also implements IAmorphousData interface that allows this row to store "extra" data that does not comply with the current schema. Typed rows store data in instance fields, providing better performance and schema definition compile-time checking than DynamicRows at the expense of inability to define schema at runtime
Inheritance Hierarchy
Online System Object
NFX.DataAccess.CRUD Row
NFX.DataAccess.CRUD TypedRow
NFX.DataAccess.CRUD AmorphousTypedRow
NFX.DataAccess.CRUD FormModel

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class AmorphousTypedRow : TypedRow,
    IAmorphousData
[SerializableAttribute]
public abstract class AmorphousTypedRow : TypedRow,
    IAmorphousData
<SerializableAttribute>
Public MustInherit Class AmorphousTypedRow
    Inherits TypedRow
    Implements IAmorphousData
<SerializableAttribute>
Public MustInherit Class AmorphousTypedRow
    Inherits TypedRow
    Implements IAmorphousData
[SerializableAttribute]
public ref class AmorphousTypedRow abstract : public TypedRow,
    IAmorphousData
[SerializableAttribute]
public ref class AmorphousTypedRow abstract : public TypedRow,
    IAmorphousData
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type AmorphousTypedRow =
    class
        inherit TypedRow
        interface IAmorphousData
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type AmorphousTypedRow =
    class
        inherit TypedRow
        interface IAmorphousData
    end
See Also
AmorphousTypedRow Members
NFX.DataAccess.CRUD Namespace


AmorphousTypedRow Members

AmorphousTypedRow Members NFX Class Library

The AmorphousTypedRow type exposes the following members.
Constructors
 | Name | Description
Protected method | AmorphousTypedRow | Initializes a new instance of the AmorphousTypedRow class
Back to Top
Methods
 | Name | Description
Public method | AfterLoad | Invoked to allow the row to hydrate its fields/state from AmorphousData bag. For example, this may be used to reconstruct some temporary object state that is not stored as a part of established business schema. The operation is performed per particular targetName (name of physical backend). Simply put, this method allows business code to "specify what to do after object gets loaded from THE PARTICULAR TARGET backend store". An example: suppose current MongoDB collection stores 3 fields for name, and we want to collapse First/Last/Middle name fields into one field. If we change rowschema then it will only contain 1 field which is not present in the database, however those 'older' fields will get populated into AmorphousData giving us an option to merge older 3 fields into 1 within AfterLoad() implementation
Public method | ApplyDefaultFieldValues | Writes default values specified in schema into fields. Pass overwrite=true to force defaults over non-null existing values (false by default) (Inherited from Row.)
Public method | BeforeSave | Invoked to allow the row to transform its state into AmorphousData bag. For example, this may be usefull to store extra data that is not a part of established business schema. The operation is performed per particular targetName (name of physical backend). Simply put, this method allows business code to "specify what to do before object gets saved in THE PARTICULAR TARGET backend store"
Protected method | CheckMinMax | (Inherited from Row.)
Public method | Configure | In base class applies Config attribute. Useful for typed rows (Inherited from Row.)
Public method | ConvertFieldValueToDef | Converts field value to the type specified by Schema.FieldDef. For example converts GDID->ulong or ulong->GDID. This method can be overridden to perform custom handling of types, for example one can assign bool field as "Si" that would convert to TRUE. This method is called by SetFieldValue(...) before assigning actual field buffer (Inherited from Row.)
Public method | CopyFields | Copies fields from this row into another row/form. Note: this is shallow copy, as field values for complex types are just copied over (Inherited from Row.)
Public method | Equals(Object) | Object override - sealed. Override Equals(row) instead (Inherited from Row.)
Public method | Equals(Row) | Override to perform custom row equality comparison. Default implementation equates rows using their key fields (Inherited from Row.)
Protected method | FilterJSONSerializerField | Override to filter-out some fields from serialization to JSON, or change field values. Return name null to indicate that field should be filtered-out(excluded from serialization to JSON) (Inherited from Row.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetClientFieldDef | Override to perform dynamic substitute of field def for the specified field. This method is used by client ui/scaffolding to extract dynamic definition for a field (i.e. field description, requirement, value list etc.) as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original field def, you can return a substituted field def per particular business logic (Inherited from Row.)
Public method | GetClientFieldValue | Override to perform dynamic substitute of field value for the specified field. This method is used by client ui/scaffolding to extract field values for a field as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original GetFieldValue(fdef), you can return a substituted field value per particular business logic (Inherited from Row.)
Public method | GetClientFieldValueList | Override to perform dynamic lookup of field value list for the specified field. This method is used by client ui/scaffolding to extract dynamic lookup values as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. This is a simplified version of GetClientFieldDef (Inherited from Row.)
Public method | GetDataStoreKey | Returns values for fields that represent row's primary key (Inherited from Row.)
Public method | GetDisplayFieldValue(Int32, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute (Inherited from Row.)
Public method | GetDisplayFieldValue(String, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute (Inherited from Row.)
Public method | GetEnumerator | (Inherited from Row.)
Public method | GetFieldValue | (Inherited from TypedRow.)
Public method | GetFieldValueDescription(Int32, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema (Inherited from Row.)
Public method | GetFieldValueDescription(String, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema (Inherited from Row.)
Public method | GetHashCode | Object override - gets hash code from key fields (Inherited from Row.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PersistConfiguration | The base class does not implement this method. Override to persist row fields into config node (Inherited from Row.)
Public method | SetFieldValue | (Inherited from TypedRow.)
Public method | SimpleFilterPredicate | Returns true if this row satisfies simple filter - it contains the supplied filter string. The filter pattern may start or end with "*" char that denotes a wildcard. A wildcard is permitted on both sides of the filter value (Inherited from Row.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Validate | Performs validation of data in the row returning exception object that provides description in cases when validation does not pass. Validation is performed not targeting any particular backend (Inherited from Row.)
Public method | Validate(String) | Validates row using row schema and supplied field definitions. Override to perform custom validations, i.e. TypeRows may directly access properties and write some validation type-safe code The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from Row.)
Public method | ValidateField(String, Schema FieldDef) | Validates row field using Schema.FieldDef settings. This method is invoked by base Validate() implementation. The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from Row.)
Public method | ValidateField(String, String) | Validates row field by name. Shortcut to ValidateField(Schema.FieldDef) (Inherited from Row.)
Public method | WriteAsJSON | Writes row as JSON either as an array or map depending on JSONWritingOptions.RowsAsMap setting. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class (Inherited from Row.)
Back to Top
Extension Methods
Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method ToErlObject Overloaded.
Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(ErlTypeOrder, Boolean) Overloaded.
Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(String, String, Boolean) Overloaded.
Convert Row to a hierarchical term that corresponds to the row's schema. The Erlang term is in the form:
View Colorized Copy to Clipboard Print
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
(Defined by ErlSchemaUtils.)
Public Extension Method ToJSON(JSONWritingOptions) Overloaded.
Serializes object into JSON string
(Defined by JSONExtensions.)
Public Extension Method ToJSON(TextWriter, JSONWritingOptions) Overloaded.
Serializes object into JSON format using provided TextWriter
(Defined by JSONExtensions.)
Public Extension Method ToJSON(Stream, JSONWritingOptions, Encoding) Overloaded.
Serializes object into JSON format using provided stream and optional encoding
(Defined by JSONExtensions.)
Public Extension Method Update
Convert an Erlang hierarchical term representing a schema to a Row.
(Defined by ErlSchemaUtils.)
Back to Top
Properties
 | Name | Description
Public property | AmorphousData | Returns data that does not comply with known schema (dynamic data). The field names are NOT case-sensitive
Public property | AmorphousDataEnabled | True by default for rows
Public property | Item Int32 | Gets/sets field values by positional index(Order) (Inherited from Row.)
Public property | Item String | Gets/sets field values by name (Inherited from Row.)
Public property | Schema | References a schema for a table that this row is a part of (Inherited from TypedRow.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Row.)
Back to Top
See Also
AmorphousTypedRow Class
NFX.DataAccess.CRUD Namespace


AmorphousTypedRow Constructor

AmorphousTypedRow Constructor NFX Class Library

Initializes a new instance of the AmorphousTypedRow class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected AmorphousTypedRow()
protected AmorphousTypedRow()
Protected Sub New
Protected Sub New
protected:
AmorphousTypedRow()
protected:
AmorphousTypedRow()
new : unit -> AmorphousTypedRow
new : unit -> AmorphousTypedRow
See Also
AmorphousTypedRow Class
AmorphousTypedRow Members
NFX.DataAccess.CRUD Namespace


AmorphousTypedRow Methods

AmorphousTypedRow Methods NFX Class Library

The AmorphousTypedRow type exposes the following members.
Methods
 | Name | Description
Public method | AfterLoad | Invoked to allow the row to hydrate its fields/state from AmorphousData bag. For example, this may be used to reconstruct some temporary object state that is not stored as a part of established business schema. The operation is performed per particular targetName (name of physical backend). Simply put, this method allows business code to "specify what to do after object gets loaded from THE PARTICULAR TARGET backend store". An example: suppose current MongoDB collection stores 3 fields for name, and we want to collapse First/Last/Middle name fields into one field. If we change rowschema then it will only contain 1 field which is not present in the database, however those 'older' fields will get populated into AmorphousData giving us an option to merge older 3 fields into 1 within AfterLoad() implementation
Public method | ApplyDefaultFieldValues | Writes default values specified in schema into fields. Pass overwrite=true to force defaults over non-null existing values (false by default) (Inherited from Row.)
Public method | BeforeSave | Invoked to allow the row to transform its state into AmorphousData bag. For example, this may be usefull to store extra data that is not a part of established business schema. The operation is performed per particular targetName (name of physical backend). Simply put, this method allows business code to "specify what to do before object gets saved in THE PARTICULAR TARGET backend store"
Protected method | CheckMinMax | (Inherited from Row.)
Public method | Configure | In base class applies Config attribute. Useful for typed rows (Inherited from Row.)
Public method | ConvertFieldValueToDef | Converts field value to the type specified by Schema.FieldDef. For example converts GDID->ulong or ulong->GDID. This method can be overridden to perform custom handling of types, for example one can assign bool field as "Si" that would convert to TRUE. This method is called by SetFieldValue(...) before assigning actual field buffer (Inherited from Row.)
Public method | CopyFields | Copies fields from this row into another row/form. Note: this is shallow copy, as field values for complex types are just copied over (Inherited from Row.)
Public method | Equals(Object) | Object override - sealed. Override Equals(row) instead (Inherited from Row.)
Public method | Equals(Row) | Override to perform custom row equality comparison. Default implementation equates rows using their key fields (Inherited from Row.)
Protected method | FilterJSONSerializerField | Override to filter-out some fields from serialization to JSON, or change field values. Return name null to indicate that field should be filtered-out(excluded from serialization to JSON) (Inherited from Row.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetClientFieldDef | Override to perform dynamic substitute of field def for the specified field. This method is used by client ui/scaffolding to extract dynamic definition for a field (i.e. field description, requirement, value list etc.) as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original field def, you can return a substituted field def per particular business logic (Inherited from Row.)
Public method | GetClientFieldValue | Override to perform dynamic substitute of field value for the specified field. This method is used by client ui/scaffolding to extract field values for a field as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original GetFieldValue(fdef), you can return a substituted field value per particular business logic (Inherited from Row.)
Public method | GetClientFieldValueList | Override to perform dynamic lookup of field value list for the specified field. This method is used by client ui/scaffolding to extract dynamic lookup values as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. This is a simplified version of GetClientFieldDef (Inherited from Row.)
Public method | GetDataStoreKey | Returns values for fields that represent row's primary key (Inherited from Row.)
Public method | GetDisplayFieldValue(Int32, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute (Inherited from Row.)
Public method | GetDisplayFieldValue(String, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute (Inherited from Row.)
Public method | GetEnumerator | (Inherited from Row.)
Public method | GetFieldValue | (Inherited from TypedRow.)
Public method | GetFieldValueDescription(Int32, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema (Inherited from Row.)
Public method | GetFieldValueDescription(String, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema (Inherited from Row.)
Public method | GetHashCode | Object override - gets hash code from key fields (Inherited from Row.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PersistConfiguration | The base class does not implement this method. Override to persist row fields into config node (Inherited from Row.)
Public method | SetFieldValue | (Inherited from TypedRow.)
Public method | SimpleFilterPredicate | Returns true if this row satisfies simple filter - it contains the supplied filter string. The filter pattern may start or end with "*" char that denotes a wildcard. A wildcard is permitted on both sides of the filter value (Inherited from Row.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Validate | Performs validation of data in the row returning exception object that provides description in cases when validation does not pass. Validation is performed not targeting any particular backend (Inherited from Row.)
Public method | Validate(String) | Validates row using row schema and supplied field definitions. Override to perform custom validations, i.e. TypeRows may directly access properties and write some validation type-safe code The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from Row.)
Public method | ValidateField(String, Schema FieldDef) | Validates row field using Schema.FieldDef settings. This method is invoked by base Validate() implementation. The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from Row.)
Public method | ValidateField(String, String) | Validates row field by name. Shortcut to ValidateField(Schema.FieldDef) (Inherited from Row.)
Public method | WriteAsJSON | Writes row as JSON either as an array or map depending on JSONWritingOptions.RowsAsMap setting. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class (Inherited from Row.)
Back to Top
Extension Methods
Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method ToErlObject Overloaded.
Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(ErlTypeOrder, Boolean) Overloaded.
Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(String, String, Boolean) Overloaded.
Convert Row to a hierarchical term that corresponds to the row's schema. The Erlang term is in the form:
View Colorized Copy to Clipboard Print
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
(Defined by ErlSchemaUtils.)
Public Extension Method ToJSON(JSONWritingOptions) Overloaded.
Serializes object into JSON string
(Defined by JSONExtensions.)
Public Extension Method ToJSON(TextWriter, JSONWritingOptions) Overloaded.
Serializes object into JSON format using provided TextWriter
(Defined by JSONExtensions.)
Public Extension Method ToJSON(Stream, JSONWritingOptions, Encoding) Overloaded.
Serializes object into JSON format using provided stream and optional encoding
(Defined by JSONExtensions.)
Public Extension Method Update
Convert an Erlang hierarchical term representing a schema to a Row.
(Defined by ErlSchemaUtils.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Row.)
Back to Top
See Also
AmorphousTypedRow Class
NFX.DataAccess.CRUD Namespace


AmorphousTypedRow.AfterLoad Method

AmorphousTypedRow AfterLoad Method NFX Class Library

Invoked to allow the row to hydrate its fields/state from AmorphousData bag. For example, this may be used to reconstruct some temporary object state that is not stored as a part of established business schema. The operation is performed per particular targetName (name of physical backend). Simply put, this method allows business code to "specify what to do after object gets loaded from THE PARTICULAR TARGET backend store". An example: suppose current MongoDB collection stores 3 fields for name, and we want to collapse First/Last/Middle name fields into one field. If we change rowschema then it will only contain 1 field which is not present in the database, however those 'older' fields will get populated into AmorphousData giving us an option to merge older 3 fields into 1 within AfterLoad() implementation

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void AfterLoad(
    string targetName
)
public virtual void AfterLoad(
    string targetName
)
Public Overridable Sub AfterLoad (
    targetName As String
)
Public Overridable Sub AfterLoad (
    targetName As String
)
public:
virtual void AfterLoad(
    String^ targetName
)
public:
virtual void AfterLoad(
    String^ targetName
)
abstract AfterLoad :
        targetName : string -> unit
override AfterLoad :
        targetName : string -> unit
abstract AfterLoad :
        targetName : string -> unit
override AfterLoad :
        targetName : string -> unit

Parameters

targetName
Type: Online System String

Implements

IAmorphousData AfterLoad(String)
See Also
AmorphousTypedRow Class
AmorphousTypedRow Members
NFX.DataAccess.CRUD Namespace


AmorphousTypedRow.BeforeSave Method

AmorphousTypedRow BeforeSave Method NFX Class Library

Invoked to allow the row to transform its state into AmorphousData bag. For example, this may be usefull to store extra data that is not a part of established business schema. The operation is performed per particular targetName (name of physical backend). Simply put, this method allows business code to "specify what to do before object gets saved in THE PARTICULAR TARGET backend store"

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void BeforeSave(
    string targetName
)
public virtual void BeforeSave(
    string targetName
)
Public Overridable Sub BeforeSave (
    targetName As String
)
Public Overridable Sub BeforeSave (
    targetName As String
)
public:
virtual void BeforeSave(
    String^ targetName
)
public:
virtual void BeforeSave(
    String^ targetName
)
abstract BeforeSave :
        targetName : string -> unit
override BeforeSave :
        targetName : string -> unit
abstract BeforeSave :
        targetName : string -> unit
override BeforeSave :
        targetName : string -> unit

Parameters

targetName
Type: Online System String

Implements

IAmorphousData BeforeSave(String)
See Also
AmorphousTypedRow Class
AmorphousTypedRow Members
NFX.DataAccess.CRUD Namespace


AmorphousTypedRow Properties

AmorphousTypedRow Properties NFX Class Library

The AmorphousTypedRow type exposes the following members.
Properties
 | Name | Description
Public property | AmorphousData | Returns data that does not comply with known schema (dynamic data). The field names are NOT case-sensitive
Public property | AmorphousDataEnabled | True by default for rows
Public property | Item Int32 | Gets/sets field values by positional index(Order) (Inherited from Row.)
Public property | Item String | Gets/sets field values by name (Inherited from Row.)
Public property | Schema | References a schema for a table that this row is a part of (Inherited from TypedRow.)
Back to Top
See Also
AmorphousTypedRow Class
NFX.DataAccess.CRUD Namespace


AmorphousTypedRow.AmorphousData Property

AmorphousTypedRow AmorphousData Property NFX Class Library

Returns data that does not comply with known schema (dynamic data). The field names are NOT case-sensitive

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<string, Object> AmorphousData { get; }
public IDictionary<string, Object> AmorphousData { get; }
Public ReadOnly Property AmorphousData As IDictionary(Of String, Object)
    Get
Public ReadOnly Property AmorphousData As IDictionary(Of String, Object)
    Get
public:
virtual property IDictionary<String^, Object^>^ AmorphousData {
    IDictionary<String^, Object^>^ get () sealed;
}
public:
virtual property IDictionary<String^, Object^>^ AmorphousData {
    IDictionary<String^, Object^>^ get () sealed;
}
abstract AmorphousData : IDictionary<string, Object> with get
override AmorphousData : IDictionary<string, Object> with get
abstract AmorphousData : IDictionary<string, Object> with get
override AmorphousData : IDictionary<string, Object> with get

Property Value

Type: Online IDictionary Online String, Online Object

Implements

IAmorphousData AmorphousData
See Also
AmorphousTypedRow Class
AmorphousTypedRow Members
NFX.DataAccess.CRUD Namespace


AmorphousTypedRow.AmorphousDataEnabled Property

AmorphousTypedRow AmorphousDataEnabled Property NFX Class Library

[This is preliminary documentation and is subject to change.]

True by default for rows

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool AmorphousDataEnabled { get; }
public virtual bool AmorphousDataEnabled { get; }
Public Overridable ReadOnly Property AmorphousDataEnabled As Boolean
    Get
Public Overridable ReadOnly Property AmorphousDataEnabled As Boolean
    Get
public:
virtual property bool AmorphousDataEnabled {
    bool get ();
}
public:
virtual property bool AmorphousDataEnabled {
    bool get ();
}
abstract AmorphousDataEnabled : bool with get
override AmorphousDataEnabled : bool with get
abstract AmorphousDataEnabled : bool with get
override AmorphousDataEnabled : bool with get

Property Value

Type: Online Boolean

Implements

IAmorphousData AmorphousDataEnabled
See Also
AmorphousTypedRow Class
AmorphousTypedRow Members
NFX.DataAccess.CRUD Namespace


CacheParams Structure

CacheParams Structure NFX Class Library

Implements ICacheParams - supplied caching parameters

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct CacheParams : ICacheParams
public struct CacheParams : ICacheParams
Public Structure CacheParams
    Implements ICacheParams
Public Structure CacheParams
    Implements ICacheParams
public value class CacheParams : ICacheParams
public value class CacheParams : ICacheParams
[<SealedAttribute>]
type CacheParams =
    struct
        interface ICacheParams
    end
[<SealedAttribute>]
type CacheParams =
    struct
        interface ICacheParams
    end
See Also
CacheParams Members
NFX.DataAccess.CRUD Namespace


CacheParams Members

CacheParams Members NFX Class Library

The CacheParams type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | ReadFreshWriteSec | Cache params with no read but write caching interval and priority
 | ReadWriteSec | Cache params with the same read/write interval
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | CacheAbsentData | When true would cache the instance of AbsentData to signify the absence of data in the backend for key
 | DefaultCache | CacheParams that use cache's default
 | NoCache | CacheParams that dont use cache
 | OneMinute | CacheParams that uses one minute for sensitive data (i.e. user account-related data)
Public property | ReadCacheMaxAgeSec | If greater than 0 then would allow reading a cached result for up-to the specified number of seconds. If =0 uses cache's default span. Less than 0 does not try to read from cache
Public property | WriteCacheMaxAgeSec | If greater than 0 then writes to cache with the expiration. If =0 uses cache's default life span. Less than 0 does not write to cache
Public property | WriteCachePriority | Relative cache priority which is used when WriteCacheMaxAgeSec>=0
Back to Top
See Also
CacheParams Structure
NFX.DataAccess.CRUD Namespace


CacheParams Methods

CacheParams Methods NFX Class Library

The CacheParams type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | ReadFreshWriteSec | Cache params with no read but write caching interval and priority
 | ReadWriteSec | Cache params with the same read/write interval
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CacheParams Structure
NFX.DataAccess.CRUD Namespace


CacheParams.ReadFreshWriteSec Method

CacheParams ReadFreshWriteSec Method NFX Class Library

Cache params with no read but write caching interval and priority

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static CacheParams ReadFreshWriteSec(
    int sec,
    int priority = 0
)
public static CacheParams ReadFreshWriteSec(
    int sec,
    int priority = 0
)
Public Shared Function ReadFreshWriteSec (
    sec As Integer,
    Optional priority As Integer = 0
) As CacheParams
Public Shared Function ReadFreshWriteSec (
    sec As Integer,
    Optional priority As Integer = 0
) As CacheParams
public:
static CacheParams ReadFreshWriteSec(
    int sec,
    int priority = 0
)
public:
static CacheParams ReadFreshWriteSec(
    int sec,
    int priority = 0
)
static member ReadFreshWriteSec :
        sec : int *
        ?priority : int
(* Defaults:
        let _priority = defaultArg priority 0
*)
-> CacheParams
static member ReadFreshWriteSec :
        sec : int *
        ?priority : int
(* Defaults:
        let _priority = defaultArg priority 0
*)
-> CacheParams

Parameters

sec
Type: Online System Int32
priority (Optional)
Type: Online System Int32

Return Value

Type: CacheParams
See Also
CacheParams Structure
CacheParams Members
NFX.DataAccess.CRUD Namespace


CacheParams.ReadWriteSec Method

CacheParams ReadWriteSec Method NFX Class Library

Cache params with the same read/write interval

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static CacheParams ReadWriteSec(
    int sec,
    int priority = 0
)
public static CacheParams ReadWriteSec(
    int sec,
    int priority = 0
)
Public Shared Function ReadWriteSec (
    sec As Integer,
    Optional priority As Integer = 0
) As CacheParams
Public Shared Function ReadWriteSec (
    sec As Integer,
    Optional priority As Integer = 0
) As CacheParams
public:
static CacheParams ReadWriteSec(
    int sec,
    int priority = 0
)
public:
static CacheParams ReadWriteSec(
    int sec,
    int priority = 0
)
static member ReadWriteSec :
        sec : int *
        ?priority : int
(* Defaults:
        let _priority = defaultArg priority 0
*)
-> CacheParams
static member ReadWriteSec :
        sec : int *
        ?priority : int
(* Defaults:
        let _priority = defaultArg priority 0
*)
-> CacheParams

Parameters

sec
Type: Online System Int32
priority (Optional)
Type: Online System Int32

Return Value

Type: CacheParams
See Also
CacheParams Structure
CacheParams Members
NFX.DataAccess.CRUD Namespace


CacheParams Properties

CacheParams Properties NFX Class Library

The CacheParams type exposes the following members.
Properties
 | Name | Description
Public property | CacheAbsentData | When true would cache the instance of AbsentData to signify the absence of data in the backend for key
 | DefaultCache | CacheParams that use cache's default
 | NoCache | CacheParams that dont use cache
 | OneMinute | CacheParams that uses one minute for sensitive data (i.e. user account-related data)
Public property | ReadCacheMaxAgeSec | If greater than 0 then would allow reading a cached result for up-to the specified number of seconds. If =0 uses cache's default span. Less than 0 does not try to read from cache
Public property | WriteCacheMaxAgeSec | If greater than 0 then writes to cache with the expiration. If =0 uses cache's default life span. Less than 0 does not write to cache
Public property | WriteCachePriority | Relative cache priority which is used when WriteCacheMaxAgeSec>=0
Back to Top
See Also
CacheParams Structure
NFX.DataAccess.CRUD Namespace


CacheParams.CacheAbsentData Property

CacheParams CacheAbsentData Property NFX Class Library

When true would cache the instance of AbsentData to signify the absence of data in the backend for key

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool CacheAbsentData { get; set; }
public bool CacheAbsentData { get; set; }
Public Property CacheAbsentData As Boolean
    Get
    Set
Public Property CacheAbsentData As Boolean
    Get
    Set
public:
virtual property bool CacheAbsentData {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool CacheAbsentData {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract CacheAbsentData : bool with get, set
override CacheAbsentData : bool with get, set
abstract CacheAbsentData : bool with get, set
override CacheAbsentData : bool with get, set

Property Value

Type: Online Boolean

Implements

ICacheParams CacheAbsentData
See Also
CacheParams Structure
CacheParams Members
NFX.DataAccess.CRUD Namespace


CacheParams.DefaultCache Property

CacheParams DefaultCache Property NFX Class Library

CacheParams that use cache's default

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static CacheParams DefaultCache { get; }
public static CacheParams DefaultCache { get; }
Public Shared ReadOnly Property DefaultCache As CacheParams
    Get
Public Shared ReadOnly Property DefaultCache As CacheParams
    Get
public:
static property CacheParams DefaultCache {
    CacheParams get ();
}
public:
static property CacheParams DefaultCache {
    CacheParams get ();
}
static member DefaultCache : CacheParams with get
static member DefaultCache : CacheParams with get

Property Value

Type: CacheParams
See Also
CacheParams Structure
CacheParams Members
NFX.DataAccess.CRUD Namespace


CacheParams.NoCache Property

CacheParams NoCache Property NFX Class Library

CacheParams that dont use cache

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static CacheParams NoCache { get; }
public static CacheParams NoCache { get; }
Public Shared ReadOnly Property NoCache As CacheParams
    Get
Public Shared ReadOnly Property NoCache As CacheParams
    Get
public:
static property CacheParams NoCache {
    CacheParams get ();
}
public:
static property CacheParams NoCache {
    CacheParams get ();
}
static member NoCache : CacheParams with get
static member NoCache : CacheParams with get

Property Value

Type: CacheParams
See Also
CacheParams Structure
CacheParams Members
NFX.DataAccess.CRUD Namespace


CacheParams.OneMinute Property

CacheParams OneMinute Property NFX Class Library

CacheParams that uses one minute for sensitive data (i.e. user account-related data)

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static CacheParams OneMinute { get; }
public static CacheParams OneMinute { get; }
Public Shared ReadOnly Property OneMinute As CacheParams
    Get
Public Shared ReadOnly Property OneMinute As CacheParams
    Get
public:
static property CacheParams OneMinute {
    CacheParams get ();
}
public:
static property CacheParams OneMinute {
    CacheParams get ();
}
static member OneMinute : CacheParams with get
static member OneMinute : CacheParams with get

Property Value

Type: CacheParams
See Also
CacheParams Structure
CacheParams Members
NFX.DataAccess.CRUD Namespace


CacheParams.ReadCacheMaxAgeSec Property

CacheParams ReadCacheMaxAgeSec Property NFX Class Library

If greater than 0 then would allow reading a cached result for up-to the specified number of seconds. If =0 uses cache's default span. Less than 0 does not try to read from cache

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ReadCacheMaxAgeSec { get; set; }
public int ReadCacheMaxAgeSec { get; set; }
Public Property ReadCacheMaxAgeSec As Integer
    Get
    Set
Public Property ReadCacheMaxAgeSec As Integer
    Get
    Set
public:
virtual property int ReadCacheMaxAgeSec {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int ReadCacheMaxAgeSec {
    int get () sealed;
    void set (int value) sealed;
}
abstract ReadCacheMaxAgeSec : int with get, set
override ReadCacheMaxAgeSec : int with get, set
abstract ReadCacheMaxAgeSec : int with get, set
override ReadCacheMaxAgeSec : int with get, set

Property Value

Type: Online Int32

Implements

ICacheParams ReadCacheMaxAgeSec
See Also
CacheParams Structure
CacheParams Members
NFX.DataAccess.CRUD Namespace


CacheParams.WriteCacheMaxAgeSec Property

CacheParams WriteCacheMaxAgeSec Property NFX Class Library

If greater than 0 then writes to cache with the expiration. If =0 uses cache's default life span. Less than 0 does not write to cache

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int WriteCacheMaxAgeSec { get; set; }
public int WriteCacheMaxAgeSec { get; set; }
Public Property WriteCacheMaxAgeSec As Integer
    Get
    Set
Public Property WriteCacheMaxAgeSec As Integer
    Get
    Set
public:
virtual property int WriteCacheMaxAgeSec {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int WriteCacheMaxAgeSec {
    int get () sealed;
    void set (int value) sealed;
}
abstract WriteCacheMaxAgeSec : int with get, set
override WriteCacheMaxAgeSec : int with get, set
abstract WriteCacheMaxAgeSec : int with get, set
override WriteCacheMaxAgeSec : int with get, set

Property Value

Type: Online Int32

Implements

ICacheParams WriteCacheMaxAgeSec
See Also
CacheParams Structure
CacheParams Members
NFX.DataAccess.CRUD Namespace


CacheParams.WriteCachePriority Property

CacheParams WriteCachePriority Property NFX Class Library

Relative cache priority which is used when WriteCacheMaxAgeSec>=0

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int WriteCachePriority { get; set; }
public int WriteCachePriority { get; set; }
Public Property WriteCachePriority As Integer
    Get
    Set
Public Property WriteCachePriority As Integer
    Get
    Set
public:
virtual property int WriteCachePriority {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int WriteCachePriority {
    int get () sealed;
    void set (int value) sealed;
}
abstract WriteCachePriority : int with get, set
override WriteCachePriority : int with get, set
abstract WriteCachePriority : int with get, set
override WriteCachePriority : int with get, set

Property Value

Type: Online Int32

Implements

ICacheParams WriteCachePriority
See Also
CacheParams Structure
CacheParams Members
NFX.DataAccess.CRUD Namespace


CRUDDataStoreType Enumeration

CRUDDataStoreType Enumeration NFX Class Library

Denotes types of CRUD stores

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum CRUDDataStoreType
public enum CRUDDataStoreType
Public Enumeration CRUDDataStoreType
Public Enumeration CRUDDataStoreType
public enum class CRUDDataStoreType
public enum class CRUDDataStoreType
type CRUDDataStoreType
type CRUDDataStoreType
Members
Member name | Value | Description
Relational | 0 |
Document | 1 |
KeyValue | 2 |
Hybrid | 3 |
See Also
NFX.DataAccess.CRUD Namespace


CRUDException Class

CRUDException Class NFX Class Library

Thrown by CRUD data access classes
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.DataAccess DataAccessException
NFX.DataAccess.CRUD CRUDException
NFX.DataAccess.CRUD CRUDValidationException
NFX.DataAccess.CRUD.Subscriptions InvalidSubscriptionRequestException

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CRUDException : DataAccessException
[SerializableAttribute]
public class CRUDException : DataAccessException
<SerializableAttribute>
Public Class CRUDException
    Inherits DataAccessException
<SerializableAttribute>
Public Class CRUDException
    Inherits DataAccessException
[SerializableAttribute]
public ref class CRUDException : public DataAccessException
[SerializableAttribute]
public ref class CRUDException : public DataAccessException
[<SerializableAttribute>]
type CRUDException =
    class
        inherit DataAccessException
    end
[<SerializableAttribute>]
type CRUDException =
    class
        inherit DataAccessException
    end
See Also
CRUDException Members
NFX.DataAccess.CRUD Namespace


CRUDException Members

CRUDException Members NFX Class Library

The CRUDException type exposes the following members.
Constructors
 | Name | Description
Public method | CRUDException | Initializes a new instance of the CRUDException class
Public method | CRUDException(String) | Initializes a new instance of the CRUDException class
Protected method | CRUDException(SerializationInfo, StreamingContext) | Initializes a new instance of the CRUDException class
Public method | CRUDException(String, Exception) | Initializes a new instance of the CRUDException class
Public method | CRUDException(String, KeyViolationKind, String) | Initializes a new instance of the CRUDException class
Public method | CRUDException(String, Exception, KeyViolationKind, String) | Initializes a new instance of the CRUDException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
CRUDException Class
NFX.DataAccess.CRUD Namespace


CRUDException Constructor

CRUDException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | CRUDException | Initializes a new instance of the CRUDException class
Public method | CRUDException(String) | Initializes a new instance of the CRUDException class
Protected method | CRUDException(SerializationInfo, StreamingContext) | Initializes a new instance of the CRUDException class
Public method | CRUDException(String, Exception) | Initializes a new instance of the CRUDException class
Public method | CRUDException(String, KeyViolationKind, String) | Initializes a new instance of the CRUDException class
Public method | CRUDException(String, Exception, KeyViolationKind, String) | Initializes a new instance of the CRUDException class
Back to Top
See Also
CRUDException Class
CRUDException Members
NFX.DataAccess.CRUD Namespace


CRUDException Constructor

CRUDException Constructor NFX Class Library

Initializes a new instance of the CRUDException class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDException()
public CRUDException()
Public Sub New
Public Sub New
public:
CRUDException()
public:
CRUDException()
new : unit -> CRUDException
new : unit -> CRUDException
See Also
CRUDException Class
CRUDException Members
CRUDException Overload
NFX.DataAccess.CRUD Namespace


CRUDException Constructor (String)

CRUDException Constructor (String) NFX Class Library

Initializes a new instance of the CRUDException class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDException(
    string message
)
public CRUDException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
CRUDException(
    String^ message
)
public:
CRUDException(
    String^ message
)
new :
        message : string -> CRUDException
new :
        message : string -> CRUDException

Parameters

message
Type: Online System String
See Also
CRUDException Class
CRUDException Members
CRUDException Overload
NFX.DataAccess.CRUD Namespace


CRUDException Constructor (SerializationInfo, StreamingContext)

CRUDException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CRUDException class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CRUDException(
    SerializationInfo info,
    StreamingContext context
)
protected CRUDException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
CRUDException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
CRUDException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> CRUDException
new :
        info : SerializationInfo *
        context : StreamingContext -> CRUDException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
CRUDException Class
CRUDException Members
CRUDException Overload
NFX.DataAccess.CRUD Namespace


CRUDException Constructor (String, Exception)

CRUDException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CRUDException class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDException(
    string message,
    Exception inner
)
public CRUDException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
CRUDException(
    String^ message,
    Exception^ inner
)
public:
CRUDException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> CRUDException
new :
        message : string *
        inner : Exception -> CRUDException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
CRUDException Class
CRUDException Members
CRUDException Overload
NFX.DataAccess.CRUD Namespace


CRUDException Constructor (String, KeyViolationKind, String)

CRUDException Constructor (String, KeyViolationKind, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CRUDException class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDException(
    string message,
    KeyViolationKind kvKind,
    string keyViolation
)
public CRUDException(
    string message,
    KeyViolationKind kvKind,
    string keyViolation
)
Public Sub New (
    message As String,
    kvKind As KeyViolationKind,
    keyViolation As String
)
Public Sub New (
    message As String,
    kvKind As KeyViolationKind,
    keyViolation As String
)
public:
CRUDException(
    String^ message,
    KeyViolationKind kvKind,
    String^ keyViolation
)
public:
CRUDException(
    String^ message,
    KeyViolationKind kvKind,
    String^ keyViolation
)
new :
        message : string *
        kvKind : KeyViolationKind *
        keyViolation : string -> CRUDException
new :
        message : string *
        kvKind : KeyViolationKind *
        keyViolation : string -> CRUDException

Parameters

message
Type: Online System String
kvKind
Type: NFX.DataAccess KeyViolationKind
keyViolation
Type: Online System String
See Also
CRUDException Class
CRUDException Members
CRUDException Overload
NFX.DataAccess.CRUD Namespace


CRUDException Constructor (String, Exception, KeyViolationKind, String)

CRUDException Constructor (String, Exception, KeyViolationKind, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CRUDException class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDException(
    string message,
    Exception inner,
    KeyViolationKind kvKind,
    string keyViolation
)
public CRUDException(
    string message,
    Exception inner,
    KeyViolationKind kvKind,
    string keyViolation
)
Public Sub New (
    message As String,
    inner As Exception,
    kvKind As KeyViolationKind,
    keyViolation As String
)
Public Sub New (
    message As String,
    inner As Exception,
    kvKind As KeyViolationKind,
    keyViolation As String
)
public:
CRUDException(
    String^ message,
    Exception^ inner,
    KeyViolationKind kvKind,
    String^ keyViolation
)
public:
CRUDException(
    String^ message,
    Exception^ inner,
    KeyViolationKind kvKind,
    String^ keyViolation
)
new :
        message : string *
        inner : Exception *
        kvKind : KeyViolationKind *
        keyViolation : string -> CRUDException
new :
        message : string *
        inner : Exception *
        kvKind : KeyViolationKind *
        keyViolation : string -> CRUDException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
kvKind
Type: NFX.DataAccess KeyViolationKind
keyViolation
Type: Online System String
See Also
CRUDException Class
CRUDException Members
CRUDException Overload
NFX.DataAccess.CRUD Namespace


CRUDException Fields

CRUDException Fields NFX Class Library

The CRUDException type exposes the following members.
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
See Also
CRUDException Class
NFX.DataAccess.CRUD Namespace


CRUDException Methods

CRUDException Methods NFX Class Library

The CRUDException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
CRUDException Class
NFX.DataAccess.CRUD Namespace


CRUDException Properties

CRUDException Properties NFX Class Library

The CRUDException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
CRUDException Class
NFX.DataAccess.CRUD Namespace


CRUDException Events

CRUDException Events NFX Class Library

The CRUDException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
CRUDException Class
NFX.DataAccess.CRUD Namespace


CRUDFieldValidationException Class

CRUDFieldValidationException Class NFX Class Library

Thrown by CRUD data access classes when field validation does not pass
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.DataAccess DataAccessException
NFX.DataAccess.CRUD CRUDException
NFX.DataAccess.CRUD CRUDValidationException
NFX.DataAccess.CRUD CRUDFieldValidationException

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CRUDFieldValidationException : CRUDValidationException
[SerializableAttribute]
public class CRUDFieldValidationException : CRUDValidationException
<SerializableAttribute>
Public Class CRUDFieldValidationException
    Inherits CRUDValidationException
<SerializableAttribute>
Public Class CRUDFieldValidationException
    Inherits CRUDValidationException
[SerializableAttribute]
public ref class CRUDFieldValidationException : public CRUDValidationException
[SerializableAttribute]
public ref class CRUDFieldValidationException : public CRUDValidationException
[<SerializableAttribute>]
type CRUDFieldValidationException =
    class
        inherit CRUDValidationException
    end
[<SerializableAttribute>]
type CRUDFieldValidationException =
    class
        inherit CRUDValidationException
    end
See Also
CRUDFieldValidationException Members
NFX.DataAccess.CRUD Namespace


CRUDFieldValidationException Members

CRUDFieldValidationException Members NFX Class Library

The CRUDFieldValidationException type exposes the following members.
Constructors
 | Name | Description
Protected method | CRUDFieldValidationException(SerializationInfo, StreamingContext) | Initializes a new instance of the CRUDFieldValidationException class
Public method | CRUDFieldValidationException(String, String) | Initializes a new instance of the CRUDFieldValidationException class
Public method | CRUDFieldValidationException(String, String, String) | Initializes a new instance of the CRUDFieldValidationException class
Public method | CRUDFieldValidationException(Row, String, String) | Initializes a new instance of the CRUDFieldValidationException class
Public method | CRUDFieldValidationException(String, String, String, Exception) | Initializes a new instance of the CRUDFieldValidationException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | ClientMessage |
Public field | FieldName |
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Public field | SchemaName |
 | WHAT |
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
CRUDFieldValidationException Class
NFX.DataAccess.CRUD Namespace


CRUDFieldValidationException Constructor

CRUDFieldValidationException Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | CRUDFieldValidationException(SerializationInfo, StreamingContext) | Initializes a new instance of the CRUDFieldValidationException class
Public method | CRUDFieldValidationException(String, String) | Initializes a new instance of the CRUDFieldValidationException class
Public method | CRUDFieldValidationException(String, String, String) | Initializes a new instance of the CRUDFieldValidationException class
Public method | CRUDFieldValidationException(Row, String, String) | Initializes a new instance of the CRUDFieldValidationException class
Public method | CRUDFieldValidationException(String, String, String, Exception) | Initializes a new instance of the CRUDFieldValidationException class
Back to Top
See Also
CRUDFieldValidationException Class
CRUDFieldValidationException Members
NFX.DataAccess.CRUD Namespace


CRUDFieldValidationException Constructor (SerializationInfo, StreamingContext)

CRUDFieldValidationException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CRUDFieldValidationException class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CRUDFieldValidationException(
    SerializationInfo info,
    StreamingContext context
)
protected CRUDFieldValidationException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
CRUDFieldValidationException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
CRUDFieldValidationException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> CRUDFieldValidationException
new :
        info : SerializationInfo *
        context : StreamingContext -> CRUDFieldValidationException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
CRUDFieldValidationException Class
CRUDFieldValidationException Members
CRUDFieldValidationException Overload
NFX.DataAccess.CRUD Namespace


CRUDFieldValidationException Constructor (String, String)

CRUDFieldValidationException Constructor (String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CRUDFieldValidationException class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDFieldValidationException(
    string schemaName,
    string fieldName
)
public CRUDFieldValidationException(
    string schemaName,
    string fieldName
)
Public Sub New (
    schemaName As String,
    fieldName As String
)
Public Sub New (
    schemaName As String,
    fieldName As String
)
public:
CRUDFieldValidationException(
    String^ schemaName,
    String^ fieldName
)
public:
CRUDFieldValidationException(
    String^ schemaName,
    String^ fieldName
)
new :
        schemaName : string *
        fieldName : string -> CRUDFieldValidationException
new :
        schemaName : string *
        fieldName : string -> CRUDFieldValidationException

Parameters

schemaName
Type: Online System String
fieldName
Type: Online System String
See Also
CRUDFieldValidationException Class
CRUDFieldValidationException Members
CRUDFieldValidationException Overload
NFX.DataAccess.CRUD Namespace


CRUDFieldValidationException Constructor (String, String, String)

CRUDFieldValidationException Constructor (String, String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CRUDFieldValidationException class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDFieldValidationException(
    string schemaName,
    string fieldName,
    string message
)
public CRUDFieldValidationException(
    string schemaName,
    string fieldName,
    string message
)
Public Sub New (
    schemaName As String,
    fieldName As String,
    message As String
)
Public Sub New (
    schemaName As String,
    fieldName As String,
    message As String
)
public:
CRUDFieldValidationException(
    String^ schemaName,
    String^ fieldName,
    String^ message
)
public:
CRUDFieldValidationException(
    String^ schemaName,
    String^ fieldName,
    String^ message
)
new :
        schemaName : string *
        fieldName : string *
        message : string -> CRUDFieldValidationException
new :
        schemaName : string *
        fieldName : string *
        message : string -> CRUDFieldValidationException

Parameters

schemaName
Type: Online System String
fieldName
Type: Online System String
message
Type: Online System String
See Also
CRUDFieldValidationException Class
CRUDFieldValidationException Members
CRUDFieldValidationException Overload
NFX.DataAccess.CRUD Namespace


CRUDFieldValidationException Constructor (Row, String, String)

CRUDFieldValidationException Constructor (Row, String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CRUDFieldValidationException class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDFieldValidationException(
    Row row,
    string fieldName,
    string message
)
public CRUDFieldValidationException(
    Row row,
    string fieldName,
    string message
)
Public Sub New (
    row As Row,
    fieldName As String,
    message As String
)
Public Sub New (
    row As Row,
    fieldName As String,
    message As String
)
public:
CRUDFieldValidationException(
    Row^ row,
    String^ fieldName,
    String^ message
)
public:
CRUDFieldValidationException(
    Row^ row,
    String^ fieldName,
    String^ message
)
new :
        row : Row *
        fieldName : string *
        message : string -> CRUDFieldValidationException
new :
        row : Row *
        fieldName : string *
        message : string -> CRUDFieldValidationException

Parameters

row
Type: NFX.DataAccess.CRUD Row
fieldName
Type: Online System String
message
Type: Online System String
See Also
CRUDFieldValidationException Class
CRUDFieldValidationException Members
CRUDFieldValidationException Overload
NFX.DataAccess.CRUD Namespace


CRUDFieldValidationException Constructor (String, String, String, Exception)

CRUDFieldValidationException Constructor (String, String, String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CRUDFieldValidationException class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDFieldValidationException(
    string schemaName,
    string fieldName,
    string message,
    Exception inner
)
public CRUDFieldValidationException(
    string schemaName,
    string fieldName,
    string message,
    Exception inner
)
Public Sub New (
    schemaName As String,
    fieldName As String,
    message As String,
    inner As Exception
)
Public Sub New (
    schemaName As String,
    fieldName As String,
    message As String,
    inner As Exception
)
public:
CRUDFieldValidationException(
    String^ schemaName,
    String^ fieldName,
    String^ message,
    Exception^ inner
)
public:
CRUDFieldValidationException(
    String^ schemaName,
    String^ fieldName,
    String^ message,
    Exception^ inner
)
new :
        schemaName : string *
        fieldName : string *
        message : string *
        inner : Exception -> CRUDFieldValidationException
new :
        schemaName : string *
        fieldName : string *
        message : string *
        inner : Exception -> CRUDFieldValidationException

Parameters

schemaName
Type: Online System String
fieldName
Type: Online System String
message
Type: Online System String
inner
Type: Online System Exception
See Also
CRUDFieldValidationException Class
CRUDFieldValidationException Members
CRUDFieldValidationException Overload
NFX.DataAccess.CRUD Namespace


CRUDFieldValidationException Fields

CRUDFieldValidationException Fields NFX Class Library

The CRUDFieldValidationException type exposes the following members.
Fields
 | Name | Description
Public field | ClientMessage |
Public field | FieldName |
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Public field | SchemaName |
 | WHAT |
Back to Top
See Also
CRUDFieldValidationException Class
NFX.DataAccess.CRUD Namespace


CRUDFieldValidationException.ClientMessage Field

CRUDFieldValidationException ClientMessage Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string ClientMessage
public readonly string ClientMessage
Public ReadOnly ClientMessage As String
Public ReadOnly ClientMessage As String
public:
initonly String^ ClientMessage
public:
initonly String^ ClientMessage
val ClientMessage: string
val ClientMessage: string

Field Value

Type: Online String
See Also
CRUDFieldValidationException Class
CRUDFieldValidationException Members
NFX.DataAccess.CRUD Namespace


CRUDFieldValidationException.FieldName Field

CRUDFieldValidationException FieldName Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string FieldName
public readonly string FieldName
Public ReadOnly FieldName As String
Public ReadOnly FieldName As String
public:
initonly String^ FieldName
public:
initonly String^ FieldName
val FieldName: string
val FieldName: string

Field Value

Type: Online String
See Also
CRUDFieldValidationException Class
CRUDFieldValidationException Members
NFX.DataAccess.CRUD Namespace


CRUDFieldValidationException.SchemaName Field

CRUDFieldValidationException SchemaName Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string SchemaName
public readonly string SchemaName
Public ReadOnly SchemaName As String
Public ReadOnly SchemaName As String
public:
initonly String^ SchemaName
public:
initonly String^ SchemaName
val SchemaName: string
val SchemaName: string

Field Value

Type: Online String
See Also
CRUDFieldValidationException Class
CRUDFieldValidationException Members
NFX.DataAccess.CRUD Namespace


CRUDFieldValidationException.WHAT Field

CRUDFieldValidationException WHAT Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string WHAT
public const string WHAT
Public Const WHAT As String
Public Const WHAT As String
public:
literal String^ WHAT
public:
literal String^ WHAT
static val mutable WHAT: string
static val mutable WHAT: string

Field Value

Type: Online String
See Also
CRUDFieldValidationException Class
CRUDFieldValidationException Members
NFX.DataAccess.CRUD Namespace


CRUDFieldValidationException Methods

CRUDFieldValidationException Methods NFX Class Library

The CRUDFieldValidationException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
CRUDFieldValidationException Class
NFX.DataAccess.CRUD Namespace


CRUDFieldValidationException Properties

CRUDFieldValidationException Properties NFX Class Library

The CRUDFieldValidationException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
CRUDFieldValidationException Class
NFX.DataAccess.CRUD Namespace


CRUDFieldValidationException Events

CRUDFieldValidationException Events NFX Class Library

The CRUDFieldValidationException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
CRUDFieldValidationException Class
NFX.DataAccess.CRUD Namespace


CRUDOperationCallContext Class

CRUDOperationCallContext Class NFX Class Library

Establishes a thead-static context which surrounds CRUD operations. You can derive your own classes, the .ctor must be chained. The context can be nested. A call to .ctor must be balanced with .Dispose(). This is needed to pass some out-of-band information in some special cases to CRUD operations without changing the caller interface, i.e. to swap database connection string. This class IS NOT THREAD SAFE, so in cases of async operations, the context captures extra parameters ONLY for initial ASYNC INVOCATION, that is- a true ASYNC implementation must pass the reference along the task execution line (in which case the object may be already Disposed but usable for property access
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.DataAccess.CRUD CRUDOperationCallContext

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CRUDOperationCallContext : DisposableObject
public class CRUDOperationCallContext : DisposableObject
Public Class CRUDOperationCallContext
    Inherits DisposableObject
Public Class CRUDOperationCallContext
    Inherits DisposableObject
public ref class CRUDOperationCallContext : public DisposableObject
public ref class CRUDOperationCallContext : public DisposableObject
type CRUDOperationCallContext =
    class
        inherit DisposableObject
    end
type CRUDOperationCallContext =
    class
        inherit DisposableObject
    end
See Also
CRUDOperationCallContext Members
NFX.DataAccess.CRUD Namespace


CRUDOperationCallContext Members

CRUDOperationCallContext Members NFX Class Library

The CRUDOperationCallContext type exposes the following members.
Constructors
 | Name | Description
Public method | CRUDOperationCallContext | Initializes a new instance of the CRUDOperationCallContext class
Back to Top
Methods
 | Name | Description
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ConnectString | Used to override store's default database connection string
 | Current | Returns the current set CRUDOperationCallContext or null
Public property | DatabaseName | Used to override store's default database name - used by some stores, others take db name form connect string
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Back to Top
See Also
CRUDOperationCallContext Class
NFX.DataAccess.CRUD Namespace


CRUDOperationCallContext Constructor

CRUDOperationCallContext Constructor NFX Class Library

Initializes a new instance of the CRUDOperationCallContext class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDOperationCallContext()
public CRUDOperationCallContext()
Public Sub New
Public Sub New
public:
CRUDOperationCallContext()
public:
CRUDOperationCallContext()
new : unit -> CRUDOperationCallContext
new : unit -> CRUDOperationCallContext
See Also
CRUDOperationCallContext Class
CRUDOperationCallContext Members
NFX.DataAccess.CRUD Namespace


CRUDOperationCallContext Methods

CRUDOperationCallContext Methods NFX Class Library

The CRUDOperationCallContext type exposes the following members.
Methods
 | Name | Description
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CRUDOperationCallContext Class
NFX.DataAccess.CRUD Namespace


CRUDOperationCallContext.Destructor Method

CRUDOperationCallContext Destructor Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
CRUDOperationCallContext Class
CRUDOperationCallContext Members
NFX.DataAccess.CRUD Namespace


CRUDOperationCallContext Properties

CRUDOperationCallContext Properties NFX Class Library

The CRUDOperationCallContext type exposes the following members.
Properties
 | Name | Description
Public property | ConnectString | Used to override store's default database connection string
 | Current | Returns the current set CRUDOperationCallContext or null
Public property | DatabaseName | Used to override store's default database name - used by some stores, others take db name form connect string
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Back to Top
See Also
CRUDOperationCallContext Class
NFX.DataAccess.CRUD Namespace


CRUDOperationCallContext.ConnectString Property

CRUDOperationCallContext ConnectString Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Used to override store's default database connection string

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ConnectString { get; set; }
public string ConnectString { get; set; }
Public Property ConnectString As String
    Get
    Set
Public Property ConnectString As String
    Get
    Set
public:
property String^ ConnectString {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ConnectString {
    String^ get ();
    void set (String^ value);
}
member ConnectString : string with get, set
member ConnectString : string with get, set

Property Value

Type: Online String
See Also
CRUDOperationCallContext Class
CRUDOperationCallContext Members
NFX.DataAccess.CRUD Namespace


CRUDOperationCallContext.Current Property

CRUDOperationCallContext Current Property NFX Class Library

Returns the current set CRUDOperationCallContext or null

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static CRUDOperationCallContext Current { get; }
public static CRUDOperationCallContext Current { get; }
Public Shared ReadOnly Property Current As CRUDOperationCallContext
    Get
Public Shared ReadOnly Property Current As CRUDOperationCallContext
    Get
public:
static property CRUDOperationCallContext^ Current {
    CRUDOperationCallContext^ get ();
}
public:
static property CRUDOperationCallContext^ Current {
    CRUDOperationCallContext^ get ();
}
static member Current : CRUDOperationCallContext with get
static member Current : CRUDOperationCallContext with get

Property Value

Type: CRUDOperationCallContext
See Also
CRUDOperationCallContext Class
CRUDOperationCallContext Members
NFX.DataAccess.CRUD Namespace


CRUDOperationCallContext.DatabaseName Property

CRUDOperationCallContext DatabaseName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Used to override store's default database name - used by some stores, others take db name form connect string

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DatabaseName { get; set; }
public string DatabaseName { get; set; }
Public Property DatabaseName As String
    Get
    Set
Public Property DatabaseName As String
    Get
    Set
public:
property String^ DatabaseName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ DatabaseName {
    String^ get ();
    void set (String^ value);
}
member DatabaseName : string with get, set
member DatabaseName : string with get, set

Property Value

Type: Online String
See Also
CRUDOperationCallContext Class
CRUDOperationCallContext Members
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler Class

CRUDQueryHandler Class NFX Class Library

Represents an entity that can execute a query. The implementation may be called by multiple threads and must be safe
Inheritance Hierarchy
Online System Object
NFX.DataAccess.CRUD CRUDQueryHandler
NFX.DataAccess.CRUD CRUDQueryHandler TStore

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class CRUDQueryHandler : INamed
public abstract class CRUDQueryHandler : INamed
Public MustInherit Class CRUDQueryHandler
    Implements INamed
Public MustInherit Class CRUDQueryHandler
    Implements INamed
public ref class CRUDQueryHandler abstract : INamed
public ref class CRUDQueryHandler abstract : INamed
[<AbstractClassAttribute>]
type CRUDQueryHandler =
    class
        interface INamed
    end
[<AbstractClassAttribute>]
type CRUDQueryHandler =
    class
        interface INamed
    end
See Also
CRUDQueryHandler Members
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler Members

CRUDQueryHandler Members NFX Class Library

The CRUDQueryHandler type exposes the following members.
Constructors
 | Name | Description
Protected method | CRUDQueryHandler(ICRUDDataStore, QuerySource) | Initializes a new instance of the CRUDQueryHandler class
Protected method | CRUDQueryHandler(ICRUDDataStore, String) | Initializes a new instance of the CRUDQueryHandler class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Execute | Executes query. The implementation may be called by multiple threads and must be safe
Public method | ExecuteAsync | Executes query. The implementation may be called by multiple threads and must be safe
Public method | ExecuteWithoutFetch | Executes query that dows not return results. The implementation may be called by multiple threads and must be safe. Returns rows affected
Public method | ExecuteWithoutFetchAsync | Executes query that dows not return results. The implementation may be called by multiple threads and must be safe. Returns rows affected
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSchema | Executes query without fetching any data but schema. The implementation may be called by multiple threads and must be safe
Public method | GetSchemaAsync | Executes query without fetching any data but schema. The implementation may be called by multiple threads and must be safe
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenCursor | Executes query into Cursor. The implementation may be called by multiple threads and must be safe
Public method | OpenCursorAsync | Executes query into Cursor. The implementation may be called by multiple threads and must be safe
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | Source |
Back to Top
Properties
 | Name | Description
Public property | Name | Returns query name that this handler handles
Public property | Store | Store instance that handler is under
Back to Top
See Also
CRUDQueryHandler Class
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler Constructor

CRUDQueryHandler Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | CRUDQueryHandler(ICRUDDataStore, QuerySource) | Initializes a new instance of the CRUDQueryHandler class
Protected method | CRUDQueryHandler(ICRUDDataStore, String) | Initializes a new instance of the CRUDQueryHandler class
Back to Top
See Also
CRUDQueryHandler Class
CRUDQueryHandler Members
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler Constructor (ICRUDDataStore, QuerySource)

CRUDQueryHandler Constructor (ICRUDDataStore, QuerySource) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CRUDQueryHandler class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CRUDQueryHandler(
    ICRUDDataStore store,
    QuerySource source
)
protected CRUDQueryHandler(
    ICRUDDataStore store,
    QuerySource source
)
Protected Sub New (
    store As ICRUDDataStore,
    source As QuerySource
)
Protected Sub New (
    store As ICRUDDataStore,
    source As QuerySource
)
protected:
CRUDQueryHandler(
    ICRUDDataStore^ store,
    QuerySource^ source
)
protected:
CRUDQueryHandler(
    ICRUDDataStore^ store,
    QuerySource^ source
)
new :
        store : ICRUDDataStore *
        source : QuerySource -> CRUDQueryHandler
new :
        store : ICRUDDataStore *
        source : QuerySource -> CRUDQueryHandler

Parameters

store
Type: NFX.DataAccess.CRUD ICRUDDataStore
source
Type: NFX.DataAccess.CRUD QuerySource
See Also
CRUDQueryHandler Class
CRUDQueryHandler Members
CRUDQueryHandler Overload
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler Constructor (ICRUDDataStore, String)

CRUDQueryHandler Constructor (ICRUDDataStore, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CRUDQueryHandler class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CRUDQueryHandler(
    ICRUDDataStore store,
    string name
)
protected CRUDQueryHandler(
    ICRUDDataStore store,
    string name
)
Protected Sub New (
    store As ICRUDDataStore,
    name As String
)
Protected Sub New (
    store As ICRUDDataStore,
    name As String
)
protected:
CRUDQueryHandler(
    ICRUDDataStore^ store,
    String^ name
)
protected:
CRUDQueryHandler(
    ICRUDDataStore^ store,
    String^ name
)
new :
        store : ICRUDDataStore *
        name : string -> CRUDQueryHandler
new :
        store : ICRUDDataStore *
        name : string -> CRUDQueryHandler

Parameters

store
Type: NFX.DataAccess.CRUD ICRUDDataStore
name
Type: Online System String
See Also
CRUDQueryHandler Class
CRUDQueryHandler Members
CRUDQueryHandler Overload
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler Fields

CRUDQueryHandler Fields NFX Class Library

The CRUDQueryHandler type exposes the following members.
Fields
 | Name | Description
Protected field | Source |
Back to Top
See Also
CRUDQueryHandler Class
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler.Source Field

CRUDQueryHandler Source Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected readonly QuerySource Source
protected readonly QuerySource Source
Protected ReadOnly Source As QuerySource
Protected ReadOnly Source As QuerySource
protected:
initonly QuerySource^ Source
protected:
initonly QuerySource^ Source
val Source: QuerySource
val Source: QuerySource

Field Value

Type: QuerySource
See Also
CRUDQueryHandler Class
CRUDQueryHandler Members
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler Methods

CRUDQueryHandler Methods NFX Class Library

The CRUDQueryHandler type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Execute | Executes query. The implementation may be called by multiple threads and must be safe
Public method | ExecuteAsync | Executes query. The implementation may be called by multiple threads and must be safe
Public method | ExecuteWithoutFetch | Executes query that dows not return results. The implementation may be called by multiple threads and must be safe. Returns rows affected
Public method | ExecuteWithoutFetchAsync | Executes query that dows not return results. The implementation may be called by multiple threads and must be safe. Returns rows affected
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSchema | Executes query without fetching any data but schema. The implementation may be called by multiple threads and must be safe
Public method | GetSchemaAsync | Executes query without fetching any data but schema. The implementation may be called by multiple threads and must be safe
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenCursor | Executes query into Cursor. The implementation may be called by multiple threads and must be safe
Public method | OpenCursorAsync | Executes query into Cursor. The implementation may be called by multiple threads and must be safe
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CRUDQueryHandler Class
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler.Execute Method

CRUDQueryHandler Execute Method NFX Class Library

Executes query. The implementation may be called by multiple threads and must be safe

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract RowsetBase Execute(
    ICRUDQueryExecutionContext context,
    Query query,
    bool oneRow = false
)
public abstract RowsetBase Execute(
    ICRUDQueryExecutionContext context,
    Query query,
    bool oneRow = false
)
Public MustOverride Function Execute (
    context As ICRUDQueryExecutionContext,
    query As Query,
    Optional oneRow As Boolean = false
) As RowsetBase
Public MustOverride Function Execute (
    context As ICRUDQueryExecutionContext,
    query As Query,
    Optional oneRow As Boolean = false
) As RowsetBase
public:
virtual RowsetBase^ Execute(
    ICRUDQueryExecutionContext^ context,
    Query^ query,
    bool oneRow = false
) abstract
public:
virtual RowsetBase^ Execute(
    ICRUDQueryExecutionContext^ context,
    Query^ query,
    bool oneRow = false
) abstract
abstract Execute :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> RowsetBase
abstract Execute :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> RowsetBase

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query
oneRow (Optional)
Type: Online System Boolean

Return Value

Type: RowsetBase
See Also
CRUDQueryHandler Class
CRUDQueryHandler Members
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler.ExecuteAsync Method

CRUDQueryHandler ExecuteAsync Method NFX Class Library

Executes query. The implementation may be called by multiple threads and must be safe

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Task<RowsetBase> ExecuteAsync(
    ICRUDQueryExecutionContext context,
    Query query,
    bool oneRow = false
)
public abstract Task<RowsetBase> ExecuteAsync(
    ICRUDQueryExecutionContext context,
    Query query,
    bool oneRow = false
)
Public MustOverride Function ExecuteAsync (
    context As ICRUDQueryExecutionContext,
    query As Query,
    Optional oneRow As Boolean = false
) As Task(Of RowsetBase)
Public MustOverride Function ExecuteAsync (
    context As ICRUDQueryExecutionContext,
    query As Query,
    Optional oneRow As Boolean = false
) As Task(Of RowsetBase)
public:
virtual Task<RowsetBase^>^ ExecuteAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query,
    bool oneRow = false
) abstract
public:
virtual Task<RowsetBase^>^ ExecuteAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query,
    bool oneRow = false
) abstract
abstract ExecuteAsync :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> Task<RowsetBase>
abstract ExecuteAsync :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> Task<RowsetBase>

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query
oneRow (Optional)
Type: Online System Boolean

Return Value

Type: Online Task RowsetBase
See Also
CRUDQueryHandler Class
CRUDQueryHandler Members
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler.ExecuteWithoutFetch Method

CRUDQueryHandler ExecuteWithoutFetch Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Executes query that dows not return results. The implementation may be called by multiple threads and must be safe. Returns rows affected

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int ExecuteWithoutFetch(
    ICRUDQueryExecutionContext context,
    Query query
)
public abstract int ExecuteWithoutFetch(
    ICRUDQueryExecutionContext context,
    Query query
)
Public MustOverride Function ExecuteWithoutFetch (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Integer
Public MustOverride Function ExecuteWithoutFetch (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Integer
public:
virtual int ExecuteWithoutFetch(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) abstract
public:
virtual int ExecuteWithoutFetch(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) abstract
abstract ExecuteWithoutFetch :
        context : ICRUDQueryExecutionContext *
        query : Query -> int
abstract ExecuteWithoutFetch :
        context : ICRUDQueryExecutionContext *
        query : Query -> int

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Int32
See Also
CRUDQueryHandler Class
CRUDQueryHandler Members
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler.ExecuteWithoutFetchAsync Method

CRUDQueryHandler ExecuteWithoutFetchAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Executes query that dows not return results. The implementation may be called by multiple threads and must be safe. Returns rows affected

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Task<int> ExecuteWithoutFetchAsync(
    ICRUDQueryExecutionContext context,
    Query query
)
public abstract Task<int> ExecuteWithoutFetchAsync(
    ICRUDQueryExecutionContext context,
    Query query
)
Public MustOverride Function ExecuteWithoutFetchAsync (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Task(Of Integer)
Public MustOverride Function ExecuteWithoutFetchAsync (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Task(Of Integer)
public:
virtual Task<int>^ ExecuteWithoutFetchAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) abstract
public:
virtual Task<int>^ ExecuteWithoutFetchAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) abstract
abstract ExecuteWithoutFetchAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<int>
abstract ExecuteWithoutFetchAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<int>

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Online Int32
See Also
CRUDQueryHandler Class
CRUDQueryHandler Members
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler.GetSchema Method

CRUDQueryHandler GetSchema Method NFX Class Library

Executes query without fetching any data but schema. The implementation may be called by multiple threads and must be safe

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Schema GetSchema(
    ICRUDQueryExecutionContext context,
    Query query
)
public abstract Schema GetSchema(
    ICRUDQueryExecutionContext context,
    Query query
)
Public MustOverride Function GetSchema (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Schema
Public MustOverride Function GetSchema (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Schema
public:
virtual Schema^ GetSchema(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) abstract
public:
virtual Schema^ GetSchema(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) abstract
abstract GetSchema :
        context : ICRUDQueryExecutionContext *
        query : Query -> Schema
abstract GetSchema :
        context : ICRUDQueryExecutionContext *
        query : Query -> Schema

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Schema
See Also
CRUDQueryHandler Class
CRUDQueryHandler Members
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler.GetSchemaAsync Method

CRUDQueryHandler GetSchemaAsync Method NFX Class Library

Executes query without fetching any data but schema. The implementation may be called by multiple threads and must be safe

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Task<Schema> GetSchemaAsync(
    ICRUDQueryExecutionContext context,
    Query query
)
public abstract Task<Schema> GetSchemaAsync(
    ICRUDQueryExecutionContext context,
    Query query
)
Public MustOverride Function GetSchemaAsync (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Task(Of Schema)
Public MustOverride Function GetSchemaAsync (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Task(Of Schema)
public:
virtual Task<Schema^>^ GetSchemaAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) abstract
public:
virtual Task<Schema^>^ GetSchemaAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) abstract
abstract GetSchemaAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Schema>
abstract GetSchemaAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Schema>

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Schema
See Also
CRUDQueryHandler Class
CRUDQueryHandler Members
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler.OpenCursor Method

CRUDQueryHandler OpenCursor Method NFX Class Library

Executes query into Cursor. The implementation may be called by multiple threads and must be safe

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Cursor OpenCursor(
    ICRUDQueryExecutionContext context,
    Query query
)
public abstract Cursor OpenCursor(
    ICRUDQueryExecutionContext context,
    Query query
)
Public MustOverride Function OpenCursor (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Cursor
Public MustOverride Function OpenCursor (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Cursor
public:
virtual Cursor^ OpenCursor(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) abstract
public:
virtual Cursor^ OpenCursor(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) abstract
abstract OpenCursor :
        context : ICRUDQueryExecutionContext *
        query : Query -> Cursor
abstract OpenCursor :
        context : ICRUDQueryExecutionContext *
        query : Query -> Cursor

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Cursor
See Also
CRUDQueryHandler Class
CRUDQueryHandler Members
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler.OpenCursorAsync Method

CRUDQueryHandler OpenCursorAsync Method NFX Class Library

Executes query into Cursor. The implementation may be called by multiple threads and must be safe

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Task<Cursor> OpenCursorAsync(
    ICRUDQueryExecutionContext context,
    Query query
)
public abstract Task<Cursor> OpenCursorAsync(
    ICRUDQueryExecutionContext context,
    Query query
)
Public MustOverride Function OpenCursorAsync (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Task(Of Cursor)
Public MustOverride Function OpenCursorAsync (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Task(Of Cursor)
public:
virtual Task<Cursor^>^ OpenCursorAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) abstract
public:
virtual Task<Cursor^>^ OpenCursorAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) abstract
abstract OpenCursorAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Cursor>
abstract OpenCursorAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Cursor>

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Cursor
See Also
CRUDQueryHandler Class
CRUDQueryHandler Members
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler Properties

CRUDQueryHandler Properties NFX Class Library

The CRUDQueryHandler type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns query name that this handler handles
Public property | Store | Store instance that handler is under
Back to Top
See Also
CRUDQueryHandler Class
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler.Name Property

CRUDQueryHandler Name Property NFX Class Library

Returns query name that this handler handles

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
CRUDQueryHandler Class
CRUDQueryHandler Members
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler.Store Property

CRUDQueryHandler Store Property NFX Class Library

Store instance that handler is under

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICRUDDataStore Store { get; }
public ICRUDDataStore Store { get; }
Public ReadOnly Property Store As ICRUDDataStore
    Get
Public ReadOnly Property Store As ICRUDDataStore
    Get
public:
property ICRUDDataStore^ Store {
    ICRUDDataStore^ get ();
}
public:
property ICRUDDataStore^ Store {
    ICRUDDataStore^ get ();
}
member Store : ICRUDDataStore with get
member Store : ICRUDDataStore with get

Property Value

Type: ICRUDDataStore
See Also
CRUDQueryHandler Class
CRUDQueryHandler Members
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler(TStore) Class

CRUDQueryHandler TStore Class NFX Class Library

Represents an entity that can execute a query. The implementation may be called by multiple threads and must be safe
Inheritance Hierarchy
Online System Object
NFX.DataAccess.CRUD CRUDQueryHandler
NFX.DataAccess.CRUD CRUDQueryHandler TStore
NFX.DataAccess.Erlang ErlCRUDScriptQueryHandler
NFX.DataAccess.MongoDB MongoDBCRUDQueryHandlerBase
NFX.DataAccess.MySQL MySQLCRUDScriptQueryHandler

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class CRUDQueryHandler<TStore> : CRUDQueryHandler
where TStore : ICRUDDataStore
public abstract class CRUDQueryHandler<TStore> : CRUDQueryHandler
where TStore : ICRUDDataStore
Public MustInherit Class CRUDQueryHandler(Of TStore As ICRUDDataStore)
    Inherits CRUDQueryHandler
Public MustInherit Class CRUDQueryHandler(Of TStore As ICRUDDataStore)
    Inherits CRUDQueryHandler
generic<typename TStore>
where TStore : ICRUDDataStore
public ref class CRUDQueryHandler abstract : public CRUDQueryHandler
generic<typename TStore>
where TStore : ICRUDDataStore
public ref class CRUDQueryHandler abstract : public CRUDQueryHandler
[<AbstractClassAttribute>]
type CRUDQueryHandler<'TStore when 'TStore : ICRUDDataStore> =
    class
        inherit CRUDQueryHandler
    end
[<AbstractClassAttribute>]
type CRUDQueryHandler<'TStore when 'TStore : ICRUDDataStore> =
    class
        inherit CRUDQueryHandler
    end
Type Parameters
TStore
See Also
CRUDQueryHandler TStore Members
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler(TStore) Members

CRUDQueryHandler TStore Members NFX Class Library

The CRUDQueryHandler TStore type exposes the following members.
Constructors
 | Name | Description
Protected method | CRUDQueryHandler TStore (TStore, QuerySource) | Initializes a new instance of the CRUDQueryHandler TStore class
Protected method | CRUDQueryHandler TStore (TStore, String) | Initializes a new instance of the CRUDQueryHandler TStore class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Execute | Executes query. The implementation may be called by multiple threads and must be safe (Inherited from CRUDQueryHandler.)
Public method | ExecuteAsync | Executes query. The implementation may be called by multiple threads and must be safe (Inherited from CRUDQueryHandler.)
Public method | ExecuteWithoutFetch | Executes query that dows not return results. The implementation may be called by multiple threads and must be safe. Returns rows affected (Inherited from CRUDQueryHandler.)
Public method | ExecuteWithoutFetchAsync | Executes query that dows not return results. The implementation may be called by multiple threads and must be safe. Returns rows affected (Inherited from CRUDQueryHandler.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSchema | Executes query without fetching any data but schema. The implementation may be called by multiple threads and must be safe (Inherited from CRUDQueryHandler.)
Public method | GetSchemaAsync | Executes query without fetching any data but schema. The implementation may be called by multiple threads and must be safe (Inherited from CRUDQueryHandler.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenCursor | Executes query into Cursor. The implementation may be called by multiple threads and must be safe (Inherited from CRUDQueryHandler.)
Public method | OpenCursorAsync | Executes query into Cursor. The implementation may be called by multiple threads and must be safe (Inherited from CRUDQueryHandler.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | Source | (Inherited from CRUDQueryHandler.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns query name that this handler handles (Inherited from CRUDQueryHandler.)
Public property | Store | Store instance that handler is under
Back to Top
See Also
CRUDQueryHandler TStore Class
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler(TStore) Constructor

CRUDQueryHandler TStore Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | CRUDQueryHandler TStore (TStore, QuerySource) | Initializes a new instance of the CRUDQueryHandler TStore class
Protected method | CRUDQueryHandler TStore (TStore, String) | Initializes a new instance of the CRUDQueryHandler TStore class
Back to Top
See Also
CRUDQueryHandler TStore Class
CRUDQueryHandler TStore Members
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler(TStore) Constructor (TStore, QuerySource)

CRUDQueryHandler TStore Constructor (TStore, QuerySource) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CRUDQueryHandler TStore class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CRUDQueryHandler(
    TStore store,
    QuerySource source
)
protected CRUDQueryHandler(
    TStore store,
    QuerySource source
)
Protected Sub New (
    store As TStore,
    source As QuerySource
)
Protected Sub New (
    store As TStore,
    source As QuerySource
)
protected:
CRUDQueryHandler(
    TStore store,
    QuerySource^ source
)
protected:
CRUDQueryHandler(
    TStore store,
    QuerySource^ source
)
new :
        store : 'TStore *
        source : QuerySource -> CRUDQueryHandler
new :
        store : 'TStore *
        source : QuerySource -> CRUDQueryHandler

Parameters

store
Type: TStore
source
Type: NFX.DataAccess.CRUD QuerySource
See Also
CRUDQueryHandler TStore Class
CRUDQueryHandler TStore Members
CRUDQueryHandler TStore Overload
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler(TStore) Constructor (TStore, String)

CRUDQueryHandler TStore Constructor (TStore, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CRUDQueryHandler TStore class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CRUDQueryHandler(
    TStore store,
    string name
)
protected CRUDQueryHandler(
    TStore store,
    string name
)
Protected Sub New (
    store As TStore,
    name As String
)
Protected Sub New (
    store As TStore,
    name As String
)
protected:
CRUDQueryHandler(
    TStore store,
    String^ name
)
protected:
CRUDQueryHandler(
    TStore store,
    String^ name
)
new :
        store : 'TStore *
        name : string -> CRUDQueryHandler
new :
        store : 'TStore *
        name : string -> CRUDQueryHandler

Parameters

store
Type: TStore
name
Type: Online System String
See Also
CRUDQueryHandler TStore Class
CRUDQueryHandler TStore Members
CRUDQueryHandler TStore Overload
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler(TStore) Fields

CRUDQueryHandler TStore Fields NFX Class Library

The CRUDQueryHandler TStore type exposes the following members.
Fields
 | Name | Description
Protected field | Source | (Inherited from CRUDQueryHandler.)
Back to Top
See Also
CRUDQueryHandler TStore Class
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler(TStore) Methods

CRUDQueryHandler TStore Methods NFX Class Library

The CRUDQueryHandler TStore type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Execute | Executes query. The implementation may be called by multiple threads and must be safe (Inherited from CRUDQueryHandler.)
Public method | ExecuteAsync | Executes query. The implementation may be called by multiple threads and must be safe (Inherited from CRUDQueryHandler.)
Public method | ExecuteWithoutFetch | Executes query that dows not return results. The implementation may be called by multiple threads and must be safe. Returns rows affected (Inherited from CRUDQueryHandler.)
Public method | ExecuteWithoutFetchAsync | Executes query that dows not return results. The implementation may be called by multiple threads and must be safe. Returns rows affected (Inherited from CRUDQueryHandler.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSchema | Executes query without fetching any data but schema. The implementation may be called by multiple threads and must be safe (Inherited from CRUDQueryHandler.)
Public method | GetSchemaAsync | Executes query without fetching any data but schema. The implementation may be called by multiple threads and must be safe (Inherited from CRUDQueryHandler.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenCursor | Executes query into Cursor. The implementation may be called by multiple threads and must be safe (Inherited from CRUDQueryHandler.)
Public method | OpenCursorAsync | Executes query into Cursor. The implementation may be called by multiple threads and must be safe (Inherited from CRUDQueryHandler.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CRUDQueryHandler TStore Class
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler(TStore) Properties

CRUDQueryHandler TStore Properties NFX Class Library

The CRUDQueryHandler TStore type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns query name that this handler handles (Inherited from CRUDQueryHandler.)
Public property | Store | Store instance that handler is under
Back to Top
See Also
CRUDQueryHandler TStore Class
NFX.DataAccess.CRUD Namespace


CRUDQueryHandler(TStore).Store Property

CRUDQueryHandler TStore Store Property NFX Class Library

Store instance that handler is under

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TStore Store { get; }
public TStore Store { get; }
Public ReadOnly Property Store As TStore
    Get
Public ReadOnly Property Store As TStore
    Get
public:
property TStore Store {
    TStore get ();
}
public:
property TStore Store {
    TStore get ();
}
member Store : 'TStore with get
member Store : 'TStore with get

Property Value

Type: TStore
See Also
CRUDQueryHandler TStore Class
CRUDQueryHandler TStore Members
NFX.DataAccess.CRUD Namespace


CRUDRowValidationException Class

CRUDRowValidationException Class NFX Class Library

Thrown by CRUD data access classes when field validation does not pass
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.DataAccess DataAccessException
NFX.DataAccess.CRUD CRUDException
NFX.DataAccess.CRUD CRUDValidationException
NFX.DataAccess.CRUD CRUDRowValidationException

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CRUDRowValidationException : CRUDValidationException
[SerializableAttribute]
public class CRUDRowValidationException : CRUDValidationException
<SerializableAttribute>
Public Class CRUDRowValidationException
    Inherits CRUDValidationException
<SerializableAttribute>
Public Class CRUDRowValidationException
    Inherits CRUDValidationException
[SerializableAttribute]
public ref class CRUDRowValidationException : public CRUDValidationException
[SerializableAttribute]
public ref class CRUDRowValidationException : public CRUDValidationException
[<SerializableAttribute>]
type CRUDRowValidationException =
    class
        inherit CRUDValidationException
    end
[<SerializableAttribute>]
type CRUDRowValidationException =
    class
        inherit CRUDValidationException
    end
See Also
CRUDRowValidationException Members
NFX.DataAccess.CRUD Namespace


CRUDRowValidationException Members

CRUDRowValidationException Members NFX Class Library

The CRUDRowValidationException type exposes the following members.
Constructors
 | Name | Description
Public method | CRUDRowValidationException(String) | Initializes a new instance of the CRUDRowValidationException class
Protected method | CRUDRowValidationException(SerializationInfo, StreamingContext) | Initializes a new instance of the CRUDRowValidationException class
Public method | CRUDRowValidationException(String, String) | Initializes a new instance of the CRUDRowValidationException class
Public method | CRUDRowValidationException(String, String, Exception) | Initializes a new instance of the CRUDRowValidationException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Public field | SchemaName |
 | WHAT |
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
CRUDRowValidationException Class
NFX.DataAccess.CRUD Namespace


CRUDRowValidationException Constructor

CRUDRowValidationException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | CRUDRowValidationException(String) | Initializes a new instance of the CRUDRowValidationException class
Protected method | CRUDRowValidationException(SerializationInfo, StreamingContext) | Initializes a new instance of the CRUDRowValidationException class
Public method | CRUDRowValidationException(String, String) | Initializes a new instance of the CRUDRowValidationException class
Public method | CRUDRowValidationException(String, String, Exception) | Initializes a new instance of the CRUDRowValidationException class
Back to Top
See Also
CRUDRowValidationException Class
CRUDRowValidationException Members
NFX.DataAccess.CRUD Namespace


CRUDRowValidationException Constructor (String)

CRUDRowValidationException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CRUDRowValidationException class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDRowValidationException(
    string schemaName
)
public CRUDRowValidationException(
    string schemaName
)
Public Sub New (
    schemaName As String
)
Public Sub New (
    schemaName As String
)
public:
CRUDRowValidationException(
    String^ schemaName
)
public:
CRUDRowValidationException(
    String^ schemaName
)
new :
        schemaName : string -> CRUDRowValidationException
new :
        schemaName : string -> CRUDRowValidationException

Parameters

schemaName
Type: Online System String
See Also
CRUDRowValidationException Class
CRUDRowValidationException Members
CRUDRowValidationException Overload
NFX.DataAccess.CRUD Namespace


CRUDRowValidationException Constructor (SerializationInfo, StreamingContext)

CRUDRowValidationException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CRUDRowValidationException class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CRUDRowValidationException(
    SerializationInfo info,
    StreamingContext context
)
protected CRUDRowValidationException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
CRUDRowValidationException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
CRUDRowValidationException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> CRUDRowValidationException
new :
        info : SerializationInfo *
        context : StreamingContext -> CRUDRowValidationException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
CRUDRowValidationException Class
CRUDRowValidationException Members
CRUDRowValidationException Overload
NFX.DataAccess.CRUD Namespace


CRUDRowValidationException Constructor (String, String)

CRUDRowValidationException Constructor (String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CRUDRowValidationException class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDRowValidationException(
    string schemaName,
    string message
)
public CRUDRowValidationException(
    string schemaName,
    string message
)
Public Sub New (
    schemaName As String,
    message As String
)
Public Sub New (
    schemaName As String,
    message As String
)
public:
CRUDRowValidationException(
    String^ schemaName,
    String^ message
)
public:
CRUDRowValidationException(
    String^ schemaName,
    String^ message
)
new :
        schemaName : string *
        message : string -> CRUDRowValidationException
new :
        schemaName : string *
        message : string -> CRUDRowValidationException

Parameters

schemaName
Type: Online System String
message
Type: Online System String
See Also
CRUDRowValidationException Class
CRUDRowValidationException Members
CRUDRowValidationException Overload
NFX.DataAccess.CRUD Namespace


CRUDRowValidationException Constructor (String, String, Exception)

CRUDRowValidationException Constructor (String, String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CRUDRowValidationException class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDRowValidationException(
    string schemaName,
    string message,
    Exception inner
)
public CRUDRowValidationException(
    string schemaName,
    string message,
    Exception inner
)
Public Sub New (
    schemaName As String,
    message As String,
    inner As Exception
)
Public Sub New (
    schemaName As String,
    message As String,
    inner As Exception
)
public:
CRUDRowValidationException(
    String^ schemaName,
    String^ message,
    Exception^ inner
)
public:
CRUDRowValidationException(
    String^ schemaName,
    String^ message,
    Exception^ inner
)
new :
        schemaName : string *
        message : string *
        inner : Exception -> CRUDRowValidationException
new :
        schemaName : string *
        message : string *
        inner : Exception -> CRUDRowValidationException

Parameters

schemaName
Type: Online System String
message
Type: Online System String
inner
Type: Online System Exception
See Also
CRUDRowValidationException Class
CRUDRowValidationException Members
CRUDRowValidationException Overload
NFX.DataAccess.CRUD Namespace


CRUDRowValidationException Fields

CRUDRowValidationException Fields NFX Class Library

The CRUDRowValidationException type exposes the following members.
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Public field | SchemaName |
 | WHAT |
Back to Top
See Also
CRUDRowValidationException Class
NFX.DataAccess.CRUD Namespace


CRUDRowValidationException.SchemaName Field

CRUDRowValidationException SchemaName Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string SchemaName
public readonly string SchemaName
Public ReadOnly SchemaName As String
Public ReadOnly SchemaName As String
public:
initonly String^ SchemaName
public:
initonly String^ SchemaName
val SchemaName: string
val SchemaName: string

Field Value

Type: Online String
See Also
CRUDRowValidationException Class
CRUDRowValidationException Members
NFX.DataAccess.CRUD Namespace


CRUDRowValidationException.WHAT Field

CRUDRowValidationException WHAT Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string WHAT
public const string WHAT
Public Const WHAT As String
Public Const WHAT As String
public:
literal String^ WHAT
public:
literal String^ WHAT
static val mutable WHAT: string
static val mutable WHAT: string

Field Value

Type: Online String
See Also
CRUDRowValidationException Class
CRUDRowValidationException Members
NFX.DataAccess.CRUD Namespace


CRUDRowValidationException Methods

CRUDRowValidationException Methods NFX Class Library

The CRUDRowValidationException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
CRUDRowValidationException Class
NFX.DataAccess.CRUD Namespace


CRUDRowValidationException Properties

CRUDRowValidationException Properties NFX Class Library

The CRUDRowValidationException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
CRUDRowValidationException Class
NFX.DataAccess.CRUD Namespace


CRUDRowValidationException Events

CRUDRowValidationException Events NFX Class Library

The CRUDRowValidationException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
CRUDRowValidationException Class
NFX.DataAccess.CRUD Namespace


CRUDTransaction Class

CRUDTransaction Class NFX Class Library

Represents an abstract base for CRUDTransactions that perform particular backend CRUD work in overriden classes
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.DataAccess.CRUD CRUDTransaction
NFX.DataAccess.MySQL MySQLCRUDTransaction

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class CRUDTransaction : DisposableObject,
    ICRUDOperations
public abstract class CRUDTransaction : DisposableObject,
    ICRUDOperations
Public MustInherit Class CRUDTransaction
    Inherits DisposableObject
    Implements ICRUDOperations
Public MustInherit Class CRUDTransaction
    Inherits DisposableObject
    Implements ICRUDOperations
public ref class CRUDTransaction abstract : public DisposableObject,
    ICRUDOperations
public ref class CRUDTransaction abstract : public DisposableObject,
    ICRUDOperations
[<AbstractClassAttribute>]
type CRUDTransaction =
    class
        inherit DisposableObject
        interface ICRUDOperations
    end
[<AbstractClassAttribute>]
type CRUDTransaction =
    class
        inherit DisposableObject
        interface ICRUDOperations
    end
See Also
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction Members

CRUDTransaction Members NFX Class Library

The CRUDTransaction type exposes the following members.
Constructors
 | Name | Description
Protected method | CRUDTransaction | Initializes a new instance of the CRUDTransaction class
Back to Top
Methods
 | Name | Description
Protected method | CheckOpenStatus |
Public method | Commit |
Public method | Delete |
Public method | DeleteAsync |
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoCommit |
Protected method | DoDelete |
Protected method | DoDeleteAsync |
Protected method | DoExecuteWithoutFetch |
Protected method | DoExecuteWithoutFetchAsync |
Protected method | DoGetSchema |
Protected method | DoGetSchemaAsync |
Protected method | DoInsert |
Protected method | DoInsertAsync |
Protected method | DoLoad |
Protected method | DoLoadAsync |
Protected method | DoOpenCursor |
Protected method | DoOpenCursorAsync |
Protected method | DoRollback |
Protected method | DoSave |
Protected method | DoSaveAsync |
Protected method | DoUpdate |
Protected method | DoUpdateAsync |
Protected method | DoUpsert |
Protected method | DoUpsertAsync |
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExecuteWithoutFetch |
Public method | ExecuteWithoutFetchAsync |
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSchema |
Public method | GetSchemaAsync |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Insert |
Public method | InsertAsync |
Public method | Load |
Public method | LoadAsync |
Public method | LoadOneRow |
Public method | LoadOneRowAsync |
Public method | LoadOneRowset |
Public method | LoadOneRowsetAsync |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenCursor |
Public method | OpenCursorAsync |
Public method | Rollback |
Public method | Save |
Public method | SaveAsync |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Update |
Public method | UpdateAsync |
Public method | Upsert |
Public method | UpsertAsync |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | LoadEnumerable TRow | Loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadEnumerableAsync TRow | Async version - loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadRow TRow | Loads one row cast per Query(T) or null (Defined by DataUtils.)
Public Extension Method | LoadRowAsync TRow | Async version - loads one row cast per Query(T) or null (Defined by DataUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Store |
Back to Top
Properties
 | Name | Description
Public property | DataStore | References the store instance that started this transaction
Public property | DisposeBehavior | Specifies how transaction should be finalized on dispose: comitted or rolledback if it is still open
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Status | Returns current transaction status
Public property | SupportsTrueAsynchrony | Returns true when backend supports true asynchronous operations, such as the ones that do not create extra threads/empty tasks
Back to Top
See Also
CRUDTransaction Class
NFX.DataAccess.CRUD Namespace


CRUDTransaction Constructor

CRUDTransaction Constructor NFX Class Library

Initializes a new instance of the CRUDTransaction class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CRUDTransaction(
    ICRUDDataStoreImplementation store,
    TransactionDisposeBehavior disposeBehavior = TransactionDisposeBehavior.CommitOnDispose
)
protected CRUDTransaction(
    ICRUDDataStoreImplementation store,
    TransactionDisposeBehavior disposeBehavior = TransactionDisposeBehavior.CommitOnDispose
)
Protected Sub New (
    store As ICRUDDataStoreImplementation,
    Optional disposeBehavior As TransactionDisposeBehavior = TransactionDisposeBehavior.CommitOnDispose
)
Protected Sub New (
    store As ICRUDDataStoreImplementation,
    Optional disposeBehavior As TransactionDisposeBehavior = TransactionDisposeBehavior.CommitOnDispose
)
protected:
CRUDTransaction(
    ICRUDDataStoreImplementation^ store,
    TransactionDisposeBehavior disposeBehavior = TransactionDisposeBehavior::CommitOnDispose
)
protected:
CRUDTransaction(
    ICRUDDataStoreImplementation^ store,
    TransactionDisposeBehavior disposeBehavior = TransactionDisposeBehavior::CommitOnDispose
)
new :
        store : ICRUDDataStoreImplementation *
        ?disposeBehavior : TransactionDisposeBehavior
(* Defaults:
        let _disposeBehavior = defaultArg disposeBehavior TransactionDisposeBehavior.CommitOnDispose
*)
-> CRUDTransaction
new :
        store : ICRUDDataStoreImplementation *
        ?disposeBehavior : TransactionDisposeBehavior
(* Defaults:
        let _disposeBehavior = defaultArg disposeBehavior TransactionDisposeBehavior.CommitOnDispose
*)
-> CRUDTransaction

Parameters

store
Type: NFX.DataAccess.CRUD ICRUDDataStoreImplementation
disposeBehavior (Optional)
Type: NFX.DataAccess.CRUD TransactionDisposeBehavior
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction Fields

CRUDTransaction Fields NFX Class Library

The CRUDTransaction type exposes the following members.
Fields
 | Name | Description
Protected field | m_Store |
Back to Top
See Also
CRUDTransaction Class
NFX.DataAccess.CRUD Namespace


CRUDTransaction.m_Store Field

CRUDTransaction m_Store Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ICRUDDataStoreImplementation m_Store
protected ICRUDDataStoreImplementation m_Store
Protected m_Store As ICRUDDataStoreImplementation
Protected m_Store As ICRUDDataStoreImplementation
protected:
ICRUDDataStoreImplementation^ m_Store
protected:
ICRUDDataStoreImplementation^ m_Store
val mutable m_Store: ICRUDDataStoreImplementation
val mutable m_Store: ICRUDDataStoreImplementation

Field Value

Type: ICRUDDataStoreImplementation
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction Methods

CRUDTransaction Methods NFX Class Library

The CRUDTransaction type exposes the following members.
Methods
 | Name | Description
Protected method | CheckOpenStatus |
Public method | Commit |
Public method | Delete |
Public method | DeleteAsync |
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoCommit |
Protected method | DoDelete |
Protected method | DoDeleteAsync |
Protected method | DoExecuteWithoutFetch |
Protected method | DoExecuteWithoutFetchAsync |
Protected method | DoGetSchema |
Protected method | DoGetSchemaAsync |
Protected method | DoInsert |
Protected method | DoInsertAsync |
Protected method | DoLoad |
Protected method | DoLoadAsync |
Protected method | DoOpenCursor |
Protected method | DoOpenCursorAsync |
Protected method | DoRollback |
Protected method | DoSave |
Protected method | DoSaveAsync |
Protected method | DoUpdate |
Protected method | DoUpdateAsync |
Protected method | DoUpsert |
Protected method | DoUpsertAsync |
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExecuteWithoutFetch |
Public method | ExecuteWithoutFetchAsync |
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSchema |
Public method | GetSchemaAsync |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Insert |
Public method | InsertAsync |
Public method | Load |
Public method | LoadAsync |
Public method | LoadOneRow |
Public method | LoadOneRowAsync |
Public method | LoadOneRowset |
Public method | LoadOneRowsetAsync |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenCursor |
Public method | OpenCursorAsync |
Public method | Rollback |
Public method | Save |
Public method | SaveAsync |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Update |
Public method | UpdateAsync |
Public method | Upsert |
Public method | UpsertAsync |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | LoadEnumerable TRow | Loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadEnumerableAsync TRow | Async version - loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadRow TRow | Loads one row cast per Query(T) or null (Defined by DataUtils.)
Public Extension Method | LoadRowAsync TRow | Async version - loads one row cast per Query(T) or null (Defined by DataUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CRUDTransaction Class
NFX.DataAccess.CRUD Namespace


CRUDTransaction.CheckOpenStatus Method

CRUDTransaction CheckOpenStatus Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void CheckOpenStatus(
    string operation
)
protected void CheckOpenStatus(
    string operation
)
Protected Sub CheckOpenStatus (
    operation As String
)
Protected Sub CheckOpenStatus (
    operation As String
)
protected:
void CheckOpenStatus(
    String^ operation
)
protected:
void CheckOpenStatus(
    String^ operation
)
member CheckOpenStatus :
        operation : string -> unit
member CheckOpenStatus :
        operation : string -> unit

Parameters

operation
Type: Online System String
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.Commit Method

CRUDTransaction Commit Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Commit()
public void Commit()
Public Sub Commit
Public Sub Commit
public:
void Commit()
public:
void Commit()
member Commit : unit -> unit
member Commit : unit -> unit
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.Delete Method

CRUDTransaction Delete Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Delete(
    Row row,
    IDataStoreKey key = null
)
public int Delete(
    Row row,
    IDataStoreKey key = null
)
Public Function Delete (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Integer
Public Function Delete (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Integer
public:
virtual int Delete(
    Row^ row,
    IDataStoreKey^ key = nullptr
) sealed
public:
virtual int Delete(
    Row^ row,
    IDataStoreKey^ key = nullptr
) sealed
abstract Delete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int
override Delete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int
abstract Delete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int
override Delete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey

Return Value

Type: Online Int32

Implements

ICRUDOperations Delete(Row, IDataStoreKey)
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.DeleteAsync Method

CRUDTransaction DeleteAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<int> DeleteAsync(
    Row row,
    IDataStoreKey key = null
)
public Task<int> DeleteAsync(
    Row row,
    IDataStoreKey key = null
)
Public Function DeleteAsync (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Task(Of Integer)
Public Function DeleteAsync (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Task(Of Integer)
public:
virtual Task<int>^ DeleteAsync(
    Row^ row,
    IDataStoreKey^ key = nullptr
) sealed
public:
virtual Task<int>^ DeleteAsync(
    Row^ row,
    IDataStoreKey^ key = nullptr
) sealed
abstract DeleteAsync :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> Task<int>
override DeleteAsync :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> Task<int>
abstract DeleteAsync :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> Task<int>
override DeleteAsync :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations DeleteAsync(Row, IDataStoreKey)
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.Destructor Method

CRUDTransaction Destructor Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.DoCommit Method

CRUDTransaction DoCommit Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void DoCommit()
protected abstract void DoCommit()
Protected MustOverride Sub DoCommit
Protected MustOverride Sub DoCommit
protected:
virtual void DoCommit() abstract
protected:
virtual void DoCommit() abstract
abstract DoCommit : unit -> unit
abstract DoCommit : unit -> unit
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.DoDelete Method

CRUDTransaction DoDelete Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract int DoDelete(
    Row row,
    IDataStoreKey key
)
protected abstract int DoDelete(
    Row row,
    IDataStoreKey key
)
Protected MustOverride Function DoDelete (
    row As Row,
    key As IDataStoreKey
) As Integer
Protected MustOverride Function DoDelete (
    row As Row,
    key As IDataStoreKey
) As Integer
protected:
virtual int DoDelete(
    Row^ row,
    IDataStoreKey^ key
) abstract
protected:
virtual int DoDelete(
    Row^ row,
    IDataStoreKey^ key
) abstract
abstract DoDelete :
        row : Row *
        key : IDataStoreKey -> int
abstract DoDelete :
        row : Row *
        key : IDataStoreKey -> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
key
Type: NFX.DataAccess IDataStoreKey

Return Value

Type: Online Int32
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.DoDeleteAsync Method

CRUDTransaction DoDeleteAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract Task<int> DoDeleteAsync(
    Row row,
    IDataStoreKey key
)
protected abstract Task<int> DoDeleteAsync(
    Row row,
    IDataStoreKey key
)
Protected MustOverride Function DoDeleteAsync (
    row As Row,
    key As IDataStoreKey
) As Task(Of Integer)
Protected MustOverride Function DoDeleteAsync (
    row As Row,
    key As IDataStoreKey
) As Task(Of Integer)
protected:
virtual Task<int>^ DoDeleteAsync(
    Row^ row,
    IDataStoreKey^ key
) abstract
protected:
virtual Task<int>^ DoDeleteAsync(
    Row^ row,
    IDataStoreKey^ key
) abstract
abstract DoDeleteAsync :
        row : Row *
        key : IDataStoreKey -> Task<int>
abstract DoDeleteAsync :
        row : Row *
        key : IDataStoreKey -> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
key
Type: NFX.DataAccess IDataStoreKey

Return Value

Type: Online Task Online Int32
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.DoExecuteWithoutFetch Method

CRUDTransaction DoExecuteWithoutFetch Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract int DoExecuteWithoutFetch(
    params Query[] queries
)
protected abstract int DoExecuteWithoutFetch(
    params Query[] queries
)
Protected MustOverride Function DoExecuteWithoutFetch (
    ParamArray queries As Query()
) As Integer
Protected MustOverride Function DoExecuteWithoutFetch (
    ParamArray queries As Query()
) As Integer
protected:
virtual int DoExecuteWithoutFetch(
    ... array<Query^>^ queries
) abstract
protected:
virtual int DoExecuteWithoutFetch(
    ... array<Query^>^ queries
) abstract
abstract DoExecuteWithoutFetch :
        queries : Query[] -> int
abstract DoExecuteWithoutFetch :
        queries : Query[] -> int

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Int32
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.DoExecuteWithoutFetchAsync Method

CRUDTransaction DoExecuteWithoutFetchAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract Task<int> DoExecuteWithoutFetchAsync(
    params Query[] queries
)
protected abstract Task<int> DoExecuteWithoutFetchAsync(
    params Query[] queries
)
Protected MustOverride Function DoExecuteWithoutFetchAsync (
    ParamArray queries As Query()
) As Task(Of Integer)
Protected MustOverride Function DoExecuteWithoutFetchAsync (
    ParamArray queries As Query()
) As Task(Of Integer)
protected:
virtual Task<int>^ DoExecuteWithoutFetchAsync(
    ... array<Query^>^ queries
) abstract
protected:
virtual Task<int>^ DoExecuteWithoutFetchAsync(
    ... array<Query^>^ queries
) abstract
abstract DoExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>
abstract DoExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Online Int32
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.DoGetSchema Method

CRUDTransaction DoGetSchema Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract Schema DoGetSchema(
    Query query
)
protected abstract Schema DoGetSchema(
    Query query
)
Protected MustOverride Function DoGetSchema (
    query As Query
) As Schema
Protected MustOverride Function DoGetSchema (
    query As Query
) As Schema
protected:
virtual Schema^ DoGetSchema(
    Query^ query
) abstract
protected:
virtual Schema^ DoGetSchema(
    Query^ query
) abstract
abstract DoGetSchema :
        query : Query -> Schema
abstract DoGetSchema :
        query : Query -> Schema

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Schema
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.DoGetSchemaAsync Method

CRUDTransaction DoGetSchemaAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract Task<Schema> DoGetSchemaAsync(
    Query query
)
protected abstract Task<Schema> DoGetSchemaAsync(
    Query query
)
Protected MustOverride Function DoGetSchemaAsync (
    query As Query
) As Task(Of Schema)
Protected MustOverride Function DoGetSchemaAsync (
    query As Query
) As Task(Of Schema)
protected:
virtual Task<Schema^>^ DoGetSchemaAsync(
    Query^ query
) abstract
protected:
virtual Task<Schema^>^ DoGetSchemaAsync(
    Query^ query
) abstract
abstract DoGetSchemaAsync :
        query : Query -> Task<Schema>
abstract DoGetSchemaAsync :
        query : Query -> Task<Schema>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Schema
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.DoInsert Method

CRUDTransaction DoInsert Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract int DoInsert(
    Row row,
    FieldFilterFunc filter = null
)
protected abstract int DoInsert(
    Row row,
    FieldFilterFunc filter = null
)
Protected MustOverride Function DoInsert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Protected MustOverride Function DoInsert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
protected:
virtual int DoInsert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) abstract
protected:
virtual int DoInsert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) abstract
abstract DoInsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
abstract DoInsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.DoInsertAsync Method

CRUDTransaction DoInsertAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract Task<int> DoInsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
protected abstract Task<int> DoInsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
Protected MustOverride Function DoInsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
Protected MustOverride Function DoInsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
protected:
virtual Task<int>^ DoInsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) abstract
protected:
virtual Task<int>^ DoInsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) abstract
abstract DoInsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
abstract DoInsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Task Online Int32
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.DoLoad Method

CRUDTransaction DoLoad Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract List<RowsetBase> DoLoad(
    bool oneRow,
    params Query[] queries
)
protected abstract List<RowsetBase> DoLoad(
    bool oneRow,
    params Query[] queries
)
Protected MustOverride Function DoLoad (
    oneRow As Boolean,
    ParamArray queries As Query()
) As List(Of RowsetBase)
Protected MustOverride Function DoLoad (
    oneRow As Boolean,
    ParamArray queries As Query()
) As List(Of RowsetBase)
protected:
virtual List<RowsetBase^>^ DoLoad(
    bool oneRow,
    ... array<Query^>^ queries
) abstract
protected:
virtual List<RowsetBase^>^ DoLoad(
    bool oneRow,
    ... array<Query^>^ queries
) abstract
abstract DoLoad :
        oneRow : bool *
        queries : Query[] -> List<RowsetBase>
abstract DoLoad :
        oneRow : bool *
        queries : Query[] -> List<RowsetBase>

Parameters

oneRow
Type: Online System Boolean
queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online List RowsetBase
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.DoLoadAsync Method

CRUDTransaction DoLoadAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract Task<List<RowsetBase>> DoLoadAsync(
    bool oneRow,
    params Query[] queries
)
protected abstract Task<List<RowsetBase>> DoLoadAsync(
    bool oneRow,
    params Query[] queries
)
Protected MustOverride Function DoLoadAsync (
    oneRow As Boolean,
    ParamArray queries As Query()
) As Task(Of List(Of RowsetBase))
Protected MustOverride Function DoLoadAsync (
    oneRow As Boolean,
    ParamArray queries As Query()
) As Task(Of List(Of RowsetBase))
protected:
virtual Task<List<RowsetBase^>^>^ DoLoadAsync(
    bool oneRow,
    ... array<Query^>^ queries
) abstract
protected:
virtual Task<List<RowsetBase^>^>^ DoLoadAsync(
    bool oneRow,
    ... array<Query^>^ queries
) abstract
abstract DoLoadAsync :
        oneRow : bool *
        queries : Query[] -> Task<List<RowsetBase>>
abstract DoLoadAsync :
        oneRow : bool *
        queries : Query[] -> Task<List<RowsetBase>>

Parameters

oneRow
Type: Online System Boolean
queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Online List RowsetBase
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.DoOpenCursor Method

CRUDTransaction DoOpenCursor Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract Cursor DoOpenCursor(
    Query query
)
protected abstract Cursor DoOpenCursor(
    Query query
)
Protected MustOverride Function DoOpenCursor (
    query As Query
) As Cursor
Protected MustOverride Function DoOpenCursor (
    query As Query
) As Cursor
protected:
virtual Cursor^ DoOpenCursor(
    Query^ query
) abstract
protected:
virtual Cursor^ DoOpenCursor(
    Query^ query
) abstract
abstract DoOpenCursor :
        query : Query -> Cursor
abstract DoOpenCursor :
        query : Query -> Cursor

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Cursor
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.DoOpenCursorAsync Method

CRUDTransaction DoOpenCursorAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract Task<Cursor> DoOpenCursorAsync(
    Query query
)
protected abstract Task<Cursor> DoOpenCursorAsync(
    Query query
)
Protected MustOverride Function DoOpenCursorAsync (
    query As Query
) As Task(Of Cursor)
Protected MustOverride Function DoOpenCursorAsync (
    query As Query
) As Task(Of Cursor)
protected:
virtual Task<Cursor^>^ DoOpenCursorAsync(
    Query^ query
) abstract
protected:
virtual Task<Cursor^>^ DoOpenCursorAsync(
    Query^ query
) abstract
abstract DoOpenCursorAsync :
        query : Query -> Task<Cursor>
abstract DoOpenCursorAsync :
        query : Query -> Task<Cursor>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Cursor
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.DoRollback Method

CRUDTransaction DoRollback Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void DoRollback()
protected abstract void DoRollback()
Protected MustOverride Sub DoRollback
Protected MustOverride Sub DoRollback
protected:
virtual void DoRollback() abstract
protected:
virtual void DoRollback() abstract
abstract DoRollback : unit -> unit
abstract DoRollback : unit -> unit
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.DoSave Method

CRUDTransaction DoSave Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract int DoSave(
    params RowsetBase[] tables
)
protected abstract int DoSave(
    params RowsetBase[] tables
)
Protected MustOverride Function DoSave (
    ParamArray tables As RowsetBase()
) As Integer
Protected MustOverride Function DoSave (
    ParamArray tables As RowsetBase()
) As Integer
protected:
virtual int DoSave(
    ... array<RowsetBase^>^ tables
) abstract
protected:
virtual int DoSave(
    ... array<RowsetBase^>^ tables
) abstract
abstract DoSave :
        tables : RowsetBase[] -> int
abstract DoSave :
        tables : RowsetBase[] -> int

Parameters

tables
Type: NFX.DataAccess.CRUD RowsetBase

Return Value

Type: Online Int32
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.DoSaveAsync Method

CRUDTransaction DoSaveAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract Task<int> DoSaveAsync(
    params RowsetBase[] tables
)
protected abstract Task<int> DoSaveAsync(
    params RowsetBase[] tables
)
Protected MustOverride Function DoSaveAsync (
    ParamArray tables As RowsetBase()
) As Task(Of Integer)
Protected MustOverride Function DoSaveAsync (
    ParamArray tables As RowsetBase()
) As Task(Of Integer)
protected:
virtual Task<int>^ DoSaveAsync(
    ... array<RowsetBase^>^ tables
) abstract
protected:
virtual Task<int>^ DoSaveAsync(
    ... array<RowsetBase^>^ tables
) abstract
abstract DoSaveAsync :
        tables : RowsetBase[] -> Task<int>
abstract DoSaveAsync :
        tables : RowsetBase[] -> Task<int>

Parameters

tables
Type: NFX.DataAccess.CRUD RowsetBase

Return Value

Type: Online Task Online Int32
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.DoUpdate Method

CRUDTransaction DoUpdate Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract int DoUpdate(
    Row row,
    IDataStoreKey key,
    FieldFilterFunc filter = null
)
protected abstract int DoUpdate(
    Row row,
    IDataStoreKey key,
    FieldFilterFunc filter = null
)
Protected MustOverride Function DoUpdate (
    row As Row,
    key As IDataStoreKey,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Protected MustOverride Function DoUpdate (
    row As Row,
    key As IDataStoreKey,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
protected:
virtual int DoUpdate(
    Row^ row,
    IDataStoreKey^ key,
    FieldFilterFunc^ filter = nullptr
) abstract
protected:
virtual int DoUpdate(
    Row^ row,
    IDataStoreKey^ key,
    FieldFilterFunc^ filter = nullptr
) abstract
abstract DoUpdate :
        row : Row *
        key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
abstract DoUpdate :
        row : Row *
        key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
key
Type: NFX.DataAccess IDataStoreKey
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.DoUpdateAsync Method

CRUDTransaction DoUpdateAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract Task<int> DoUpdateAsync(
    Row row,
    IDataStoreKey key,
    FieldFilterFunc filter = null
)
protected abstract Task<int> DoUpdateAsync(
    Row row,
    IDataStoreKey key,
    FieldFilterFunc filter = null
)
Protected MustOverride Function DoUpdateAsync (
    row As Row,
    key As IDataStoreKey,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
Protected MustOverride Function DoUpdateAsync (
    row As Row,
    key As IDataStoreKey,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
protected:
virtual Task<int>^ DoUpdateAsync(
    Row^ row,
    IDataStoreKey^ key,
    FieldFilterFunc^ filter = nullptr
) abstract
protected:
virtual Task<int>^ DoUpdateAsync(
    Row^ row,
    IDataStoreKey^ key,
    FieldFilterFunc^ filter = nullptr
) abstract
abstract DoUpdateAsync :
        row : Row *
        key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
abstract DoUpdateAsync :
        row : Row *
        key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
key
Type: NFX.DataAccess IDataStoreKey
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Task Online Int32
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.DoUpsert Method

CRUDTransaction DoUpsert Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract int DoUpsert(
    Row row,
    FieldFilterFunc filter = null
)
protected abstract int DoUpsert(
    Row row,
    FieldFilterFunc filter = null
)
Protected MustOverride Function DoUpsert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Protected MustOverride Function DoUpsert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
protected:
virtual int DoUpsert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) abstract
protected:
virtual int DoUpsert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) abstract
abstract DoUpsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
abstract DoUpsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.DoUpsertAsync Method

CRUDTransaction DoUpsertAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract Task<int> DoUpsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
protected abstract Task<int> DoUpsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
Protected MustOverride Function DoUpsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
Protected MustOverride Function DoUpsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
protected:
virtual Task<int>^ DoUpsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) abstract
protected:
virtual Task<int>^ DoUpsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) abstract
abstract DoUpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
abstract DoUpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Task Online Int32
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.ExecuteWithoutFetch Method

CRUDTransaction ExecuteWithoutFetch Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ExecuteWithoutFetch(
    params Query[] queries
)
public int ExecuteWithoutFetch(
    params Query[] queries
)
Public Function ExecuteWithoutFetch (
    ParamArray queries As Query()
) As Integer
Public Function ExecuteWithoutFetch (
    ParamArray queries As Query()
) As Integer
public:
virtual int ExecuteWithoutFetch(
    ... array<Query^>^ queries
) sealed
public:
virtual int ExecuteWithoutFetch(
    ... array<Query^>^ queries
) sealed
abstract ExecuteWithoutFetch :
        queries : Query[] -> int
override ExecuteWithoutFetch :
        queries : Query[] -> int
abstract ExecuteWithoutFetch :
        queries : Query[] -> int
override ExecuteWithoutFetch :
        queries : Query[] -> int

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Int32

Implements

ICRUDOperations ExecuteWithoutFetch( Query )
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.ExecuteWithoutFetchAsync Method

CRUDTransaction ExecuteWithoutFetchAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<int> ExecuteWithoutFetchAsync(
    params Query[] queries
)
public Task<int> ExecuteWithoutFetchAsync(
    params Query[] queries
)
Public Function ExecuteWithoutFetchAsync (
    ParamArray queries As Query()
) As Task(Of Integer)
Public Function ExecuteWithoutFetchAsync (
    ParamArray queries As Query()
) As Task(Of Integer)
public:
virtual Task<int>^ ExecuteWithoutFetchAsync(
    ... array<Query^>^ queries
) sealed
public:
virtual Task<int>^ ExecuteWithoutFetchAsync(
    ... array<Query^>^ queries
) sealed
abstract ExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>
override ExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>
abstract ExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>
override ExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations ExecuteWithoutFetchAsync( Query )
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.GetSchema Method

CRUDTransaction GetSchema Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Schema GetSchema(
    Query query
)
public Schema GetSchema(
    Query query
)
Public Function GetSchema (
    query As Query
) As Schema
Public Function GetSchema (
    query As Query
) As Schema
public:
virtual Schema^ GetSchema(
    Query^ query
) sealed
public:
virtual Schema^ GetSchema(
    Query^ query
) sealed
abstract GetSchema :
        query : Query -> Schema
override GetSchema :
        query : Query -> Schema
abstract GetSchema :
        query : Query -> Schema
override GetSchema :
        query : Query -> Schema

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Schema

Implements

ICRUDOperations GetSchema(Query)
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.GetSchemaAsync Method

CRUDTransaction GetSchemaAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<Schema> GetSchemaAsync(
    Query query
)
public Task<Schema> GetSchemaAsync(
    Query query
)
Public Function GetSchemaAsync (
    query As Query
) As Task(Of Schema)
Public Function GetSchemaAsync (
    query As Query
) As Task(Of Schema)
public:
virtual Task<Schema^>^ GetSchemaAsync(
    Query^ query
) sealed
public:
virtual Task<Schema^>^ GetSchemaAsync(
    Query^ query
) sealed
abstract GetSchemaAsync :
        query : Query -> Task<Schema>
override GetSchemaAsync :
        query : Query -> Task<Schema>
abstract GetSchemaAsync :
        query : Query -> Task<Schema>
override GetSchemaAsync :
        query : Query -> Task<Schema>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Schema

Implements

ICRUDOperations GetSchemaAsync(Query)
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.Insert Method

CRUDTransaction Insert Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Insert(
    Row row,
    FieldFilterFunc filter = null
)
public int Insert(
    Row row,
    FieldFilterFunc filter = null
)
Public Function Insert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Public Function Insert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
public:
virtual int Insert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) sealed
public:
virtual int Insert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) sealed
abstract Insert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override Insert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
abstract Insert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override Insert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32

Implements

ICRUDOperations Insert(Row, FieldFilterFunc)
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.InsertAsync Method

CRUDTransaction InsertAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<int> InsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
public Task<int> InsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
Public Function InsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
Public Function InsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
public:
virtual Task<int>^ InsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) sealed
public:
virtual Task<int>^ InsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) sealed
abstract InsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
override InsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
abstract InsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
override InsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations InsertAsync(Row, FieldFilterFunc)
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.Load Method

CRUDTransaction Load Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<RowsetBase> Load(
    params Query[] queries
)
public List<RowsetBase> Load(
    params Query[] queries
)
Public Function Load (
    ParamArray queries As Query()
) As List(Of RowsetBase)
Public Function Load (
    ParamArray queries As Query()
) As List(Of RowsetBase)
public:
virtual List<RowsetBase^>^ Load(
    ... array<Query^>^ queries
) sealed
public:
virtual List<RowsetBase^>^ Load(
    ... array<Query^>^ queries
) sealed
abstract Load :
        queries : Query[] -> List<RowsetBase>
override Load :
        queries : Query[] -> List<RowsetBase>
abstract Load :
        queries : Query[] -> List<RowsetBase>
override Load :
        queries : Query[] -> List<RowsetBase>

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online List RowsetBase

Implements

ICRUDOperations Load( Query )
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.LoadAsync Method

CRUDTransaction LoadAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<List<RowsetBase>> LoadAsync(
    params Query[] queries
)
public Task<List<RowsetBase>> LoadAsync(
    params Query[] queries
)
Public Function LoadAsync (
    ParamArray queries As Query()
) As Task(Of List(Of RowsetBase))
Public Function LoadAsync (
    ParamArray queries As Query()
) As Task(Of List(Of RowsetBase))
public:
virtual Task<List<RowsetBase^>^>^ LoadAsync(
    ... array<Query^>^ queries
) sealed
public:
virtual Task<List<RowsetBase^>^>^ LoadAsync(
    ... array<Query^>^ queries
) sealed
abstract LoadAsync :
        queries : Query[] -> Task<List<RowsetBase>>
override LoadAsync :
        queries : Query[] -> Task<List<RowsetBase>>
abstract LoadAsync :
        queries : Query[] -> Task<List<RowsetBase>>
override LoadAsync :
        queries : Query[] -> Task<List<RowsetBase>>

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Online List RowsetBase

Implements

ICRUDOperations LoadAsync( Query )
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.LoadOneRow Method

CRUDTransaction LoadOneRow Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Row LoadOneRow(
    Query query
)
public Row LoadOneRow(
    Query query
)
Public Function LoadOneRow (
    query As Query
) As Row
Public Function LoadOneRow (
    query As Query
) As Row
public:
virtual Row^ LoadOneRow(
    Query^ query
) sealed
public:
virtual Row^ LoadOneRow(
    Query^ query
) sealed
abstract LoadOneRow :
        query : Query -> Row
override LoadOneRow :
        query : Query -> Row
abstract LoadOneRow :
        query : Query -> Row
override LoadOneRow :
        query : Query -> Row

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Row

Implements

ICRUDOperations LoadOneRow(Query)
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.LoadOneRowAsync Method

CRUDTransaction LoadOneRowAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<Row> LoadOneRowAsync(
    Query query
)
public Task<Row> LoadOneRowAsync(
    Query query
)
Public Function LoadOneRowAsync (
    query As Query
) As Task(Of Row)
Public Function LoadOneRowAsync (
    query As Query
) As Task(Of Row)
public:
virtual Task<Row^>^ LoadOneRowAsync(
    Query^ query
) sealed
public:
virtual Task<Row^>^ LoadOneRowAsync(
    Query^ query
) sealed
abstract LoadOneRowAsync :
        query : Query -> Task<Row>
override LoadOneRowAsync :
        query : Query -> Task<Row>
abstract LoadOneRowAsync :
        query : Query -> Task<Row>
override LoadOneRowAsync :
        query : Query -> Task<Row>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Row

Implements

ICRUDOperations LoadOneRowAsync(Query)
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.LoadOneRowset Method

CRUDTransaction LoadOneRowset Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RowsetBase LoadOneRowset(
    Query query
)
public RowsetBase LoadOneRowset(
    Query query
)
Public Function LoadOneRowset (
    query As Query
) As RowsetBase
Public Function LoadOneRowset (
    query As Query
) As RowsetBase
public:
virtual RowsetBase^ LoadOneRowset(
    Query^ query
) sealed
public:
virtual RowsetBase^ LoadOneRowset(
    Query^ query
) sealed
abstract LoadOneRowset :
        query : Query -> RowsetBase
override LoadOneRowset :
        query : Query -> RowsetBase
abstract LoadOneRowset :
        query : Query -> RowsetBase
override LoadOneRowset :
        query : Query -> RowsetBase

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: RowsetBase

Implements

ICRUDOperations LoadOneRowset(Query)
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.LoadOneRowsetAsync Method

CRUDTransaction LoadOneRowsetAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<RowsetBase> LoadOneRowsetAsync(
    Query query
)
public Task<RowsetBase> LoadOneRowsetAsync(
    Query query
)
Public Function LoadOneRowsetAsync (
    query As Query
) As Task(Of RowsetBase)
Public Function LoadOneRowsetAsync (
    query As Query
) As Task(Of RowsetBase)
public:
virtual Task<RowsetBase^>^ LoadOneRowsetAsync(
    Query^ query
) sealed
public:
virtual Task<RowsetBase^>^ LoadOneRowsetAsync(
    Query^ query
) sealed
abstract LoadOneRowsetAsync :
        query : Query -> Task<RowsetBase>
override LoadOneRowsetAsync :
        query : Query -> Task<RowsetBase>
abstract LoadOneRowsetAsync :
        query : Query -> Task<RowsetBase>
override LoadOneRowsetAsync :
        query : Query -> Task<RowsetBase>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task RowsetBase

Implements

ICRUDOperations LoadOneRowsetAsync(Query)
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.OpenCursor Method

CRUDTransaction OpenCursor Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Cursor OpenCursor(
    Query query
)
public Cursor OpenCursor(
    Query query
)
Public Function OpenCursor (
    query As Query
) As Cursor
Public Function OpenCursor (
    query As Query
) As Cursor
public:
virtual Cursor^ OpenCursor(
    Query^ query
) sealed
public:
virtual Cursor^ OpenCursor(
    Query^ query
) sealed
abstract OpenCursor :
        query : Query -> Cursor
override OpenCursor :
        query : Query -> Cursor
abstract OpenCursor :
        query : Query -> Cursor
override OpenCursor :
        query : Query -> Cursor

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Cursor

Implements

ICRUDOperations OpenCursor(Query)
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.OpenCursorAsync Method

CRUDTransaction OpenCursorAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<Cursor> OpenCursorAsync(
    Query query
)
public Task<Cursor> OpenCursorAsync(
    Query query
)
Public Function OpenCursorAsync (
    query As Query
) As Task(Of Cursor)
Public Function OpenCursorAsync (
    query As Query
) As Task(Of Cursor)
public:
virtual Task<Cursor^>^ OpenCursorAsync(
    Query^ query
) sealed
public:
virtual Task<Cursor^>^ OpenCursorAsync(
    Query^ query
) sealed
abstract OpenCursorAsync :
        query : Query -> Task<Cursor>
override OpenCursorAsync :
        query : Query -> Task<Cursor>
abstract OpenCursorAsync :
        query : Query -> Task<Cursor>
override OpenCursorAsync :
        query : Query -> Task<Cursor>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Cursor

Implements

ICRUDOperations OpenCursorAsync(Query)
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.Rollback Method

CRUDTransaction Rollback Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Rollback()
public void Rollback()
Public Sub Rollback
Public Sub Rollback
public:
void Rollback()
public:
void Rollback()
member Rollback : unit -> unit
member Rollback : unit -> unit
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.Save Method

CRUDTransaction Save Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Save(
    params RowsetBase[] tables
)
public int Save(
    params RowsetBase[] tables
)
Public Function Save (
    ParamArray tables As RowsetBase()
) As Integer
Public Function Save (
    ParamArray tables As RowsetBase()
) As Integer
public:
virtual int Save(
    ... array<RowsetBase^>^ tables
) sealed
public:
virtual int Save(
    ... array<RowsetBase^>^ tables
) sealed
abstract Save :
        tables : RowsetBase[] -> int
override Save :
        tables : RowsetBase[] -> int
abstract Save :
        tables : RowsetBase[] -> int
override Save :
        tables : RowsetBase[] -> int

Parameters

tables
Type: NFX.DataAccess.CRUD RowsetBase

Return Value

Type: Online Int32

Implements

ICRUDOperations Save( RowsetBase )
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.SaveAsync Method

CRUDTransaction SaveAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<int> SaveAsync(
    params RowsetBase[] tables
)
public Task<int> SaveAsync(
    params RowsetBase[] tables
)
Public Function SaveAsync (
    ParamArray tables As RowsetBase()
) As Task(Of Integer)
Public Function SaveAsync (
    ParamArray tables As RowsetBase()
) As Task(Of Integer)
public:
virtual Task<int>^ SaveAsync(
    ... array<RowsetBase^>^ tables
) sealed
public:
virtual Task<int>^ SaveAsync(
    ... array<RowsetBase^>^ tables
) sealed
abstract SaveAsync :
        tables : RowsetBase[] -> Task<int>
override SaveAsync :
        tables : RowsetBase[] -> Task<int>
abstract SaveAsync :
        tables : RowsetBase[] -> Task<int>
override SaveAsync :
        tables : RowsetBase[] -> Task<int>

Parameters

tables
Type: NFX.DataAccess.CRUD RowsetBase

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations SaveAsync( RowsetBase )
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.Update Method

CRUDTransaction Update Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Update(
    Row row,
    IDataStoreKey key = null,
    FieldFilterFunc filter = null
)
public int Update(
    Row row,
    IDataStoreKey key = null,
    FieldFilterFunc filter = null
)
Public Function Update (
    row As Row,
    Optional key As IDataStoreKey = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Public Function Update (
    row As Row,
    Optional key As IDataStoreKey = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
public:
virtual int Update(
    Row^ row,
    IDataStoreKey^ key = nullptr,
    FieldFilterFunc^ filter = nullptr
) sealed
public:
virtual int Update(
    Row^ row,
    IDataStoreKey^ key = nullptr,
    FieldFilterFunc^ filter = nullptr
) sealed
abstract Update :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> int
override Update :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> int
abstract Update :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> int
override Update :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32

Implements

ICRUDOperations Update(Row, IDataStoreKey, FieldFilterFunc)
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.UpdateAsync Method

CRUDTransaction UpdateAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<int> UpdateAsync(
    Row row,
    IDataStoreKey key = null,
    FieldFilterFunc filter = null
)
public Task<int> UpdateAsync(
    Row row,
    IDataStoreKey key = null,
    FieldFilterFunc filter = null
)
Public Function UpdateAsync (
    row As Row,
    Optional key As IDataStoreKey = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
Public Function UpdateAsync (
    row As Row,
    Optional key As IDataStoreKey = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
public:
virtual Task<int>^ UpdateAsync(
    Row^ row,
    IDataStoreKey^ key = nullptr,
    FieldFilterFunc^ filter = nullptr
) sealed
public:
virtual Task<int>^ UpdateAsync(
    Row^ row,
    IDataStoreKey^ key = nullptr,
    FieldFilterFunc^ filter = nullptr
) sealed
abstract UpdateAsync :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> Task<int>
override UpdateAsync :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> Task<int>
abstract UpdateAsync :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> Task<int>
override UpdateAsync :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations UpdateAsync(Row, IDataStoreKey, FieldFilterFunc)
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.Upsert Method

CRUDTransaction Upsert Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Upsert(
    Row row,
    FieldFilterFunc filter = null
)
public int Upsert(
    Row row,
    FieldFilterFunc filter = null
)
Public Function Upsert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Public Function Upsert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
public:
virtual int Upsert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) sealed
public:
virtual int Upsert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) sealed
abstract Upsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override Upsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
abstract Upsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override Upsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32

Implements

ICRUDOperations Upsert(Row, FieldFilterFunc)
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.UpsertAsync Method

CRUDTransaction UpsertAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<int> UpsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
public Task<int> UpsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
Public Function UpsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
Public Function UpsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
public:
virtual Task<int>^ UpsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) sealed
public:
virtual Task<int>^ UpsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) sealed
abstract UpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
override UpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
abstract UpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
override UpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations UpsertAsync(Row, FieldFilterFunc)
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction Properties

CRUDTransaction Properties NFX Class Library

The CRUDTransaction type exposes the following members.
Properties
 | Name | Description
Public property | DataStore | References the store instance that started this transaction
Public property | DisposeBehavior | Specifies how transaction should be finalized on dispose: comitted or rolledback if it is still open
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Status | Returns current transaction status
Public property | SupportsTrueAsynchrony | Returns true when backend supports true asynchronous operations, such as the ones that do not create extra threads/empty tasks
Back to Top
See Also
CRUDTransaction Class
NFX.DataAccess.CRUD Namespace


CRUDTransaction.DataStore Property

CRUDTransaction DataStore Property NFX Class Library

References the store instance that started this transaction

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICRUDDataStore DataStore { get; }
public ICRUDDataStore DataStore { get; }
Public ReadOnly Property DataStore As ICRUDDataStore
    Get
Public ReadOnly Property DataStore As ICRUDDataStore
    Get
public:
property ICRUDDataStore^ DataStore {
    ICRUDDataStore^ get ();
}
public:
property ICRUDDataStore^ DataStore {
    ICRUDDataStore^ get ();
}
member DataStore : ICRUDDataStore with get
member DataStore : ICRUDDataStore with get

Property Value

Type: ICRUDDataStore
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.DisposeBehavior Property

CRUDTransaction DisposeBehavior Property NFX Class Library

Specifies how transaction should be finalized on dispose: comitted or rolledback if it is still open

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TransactionDisposeBehavior DisposeBehavior { get; }
public TransactionDisposeBehavior DisposeBehavior { get; }
Public ReadOnly Property DisposeBehavior As TransactionDisposeBehavior
    Get
Public ReadOnly Property DisposeBehavior As TransactionDisposeBehavior
    Get
public:
property TransactionDisposeBehavior DisposeBehavior {
    TransactionDisposeBehavior get ();
}
public:
property TransactionDisposeBehavior DisposeBehavior {
    TransactionDisposeBehavior get ();
}
member DisposeBehavior : TransactionDisposeBehavior with get
member DisposeBehavior : TransactionDisposeBehavior with get

Property Value

Type: TransactionDisposeBehavior
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.Status Property

CRUDTransaction Status Property NFX Class Library

Returns current transaction status

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TransactionStatus Status { get; }
public TransactionStatus Status { get; }
Public ReadOnly Property Status As TransactionStatus
    Get
Public ReadOnly Property Status As TransactionStatus
    Get
public:
property TransactionStatus Status {
    TransactionStatus get ();
}
public:
property TransactionStatus Status {
    TransactionStatus get ();
}
member Status : TransactionStatus with get
member Status : TransactionStatus with get

Property Value

Type: TransactionStatus
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDTransaction.SupportsTrueAsynchrony Property

CRUDTransaction SupportsTrueAsynchrony Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns true when backend supports true asynchronous operations, such as the ones that do not create extra threads/empty tasks

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsTrueAsynchrony { get; }
public bool SupportsTrueAsynchrony { get; }
Public ReadOnly Property SupportsTrueAsynchrony As Boolean
    Get
Public ReadOnly Property SupportsTrueAsynchrony As Boolean
    Get
public:
virtual property bool SupportsTrueAsynchrony {
    bool get () sealed;
}
public:
virtual property bool SupportsTrueAsynchrony {
    bool get () sealed;
}
abstract SupportsTrueAsynchrony : bool with get
override SupportsTrueAsynchrony : bool with get
abstract SupportsTrueAsynchrony : bool with get
override SupportsTrueAsynchrony : bool with get

Property Value

Type: Online Boolean

Implements

ICRUDOperations SupportsTrueAsynchrony
See Also
CRUDTransaction Class
CRUDTransaction Members
NFX.DataAccess.CRUD Namespace


CRUDValidationException Class

CRUDValidationException Class NFX Class Library

Thrown by CRUD data access classes when validation does not pass
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.DataAccess DataAccessException
NFX.DataAccess.CRUD CRUDException
NFX.DataAccess.CRUD CRUDValidationException
NFX.DataAccess.CRUD CRUDFieldValidationException
NFX.DataAccess.CRUD CRUDRowValidationException

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CRUDValidationException : CRUDException
[SerializableAttribute]
public class CRUDValidationException : CRUDException
<SerializableAttribute>
Public Class CRUDValidationException
    Inherits CRUDException
<SerializableAttribute>
Public Class CRUDValidationException
    Inherits CRUDException
[SerializableAttribute]
public ref class CRUDValidationException : public CRUDException
[SerializableAttribute]
public ref class CRUDValidationException : public CRUDException
[<SerializableAttribute>]
type CRUDValidationException =
    class
        inherit CRUDException
    end
[<SerializableAttribute>]
type CRUDValidationException =
    class
        inherit CRUDException
    end
See Also
CRUDValidationException Members
NFX.DataAccess.CRUD Namespace


CRUDValidationException Members

CRUDValidationException Members NFX Class Library

The CRUDValidationException type exposes the following members.
Constructors
 | Name | Description
Public method | CRUDValidationException | Initializes a new instance of the CRUDValidationException class
Public method | CRUDValidationException(String) | Initializes a new instance of the CRUDValidationException class
Protected method | CRUDValidationException(SerializationInfo, StreamingContext) | Initializes a new instance of the CRUDValidationException class
Public method | CRUDValidationException(String, Exception) | Initializes a new instance of the CRUDValidationException class
Public method | CRUDValidationException(String, KeyViolationKind, String) | Initializes a new instance of the CRUDValidationException class
Public method | CRUDValidationException(String, Exception, KeyViolationKind, String) | Initializes a new instance of the CRUDValidationException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
CRUDValidationException Class
NFX.DataAccess.CRUD Namespace


CRUDValidationException Constructor

CRUDValidationException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | CRUDValidationException | Initializes a new instance of the CRUDValidationException class
Public method | CRUDValidationException(String) | Initializes a new instance of the CRUDValidationException class
Protected method | CRUDValidationException(SerializationInfo, StreamingContext) | Initializes a new instance of the CRUDValidationException class
Public method | CRUDValidationException(String, Exception) | Initializes a new instance of the CRUDValidationException class
Public method | CRUDValidationException(String, KeyViolationKind, String) | Initializes a new instance of the CRUDValidationException class
Public method | CRUDValidationException(String, Exception, KeyViolationKind, String) | Initializes a new instance of the CRUDValidationException class
Back to Top
See Also
CRUDValidationException Class
CRUDValidationException Members
NFX.DataAccess.CRUD Namespace


CRUDValidationException Constructor

CRUDValidationException Constructor NFX Class Library

Initializes a new instance of the CRUDValidationException class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDValidationException()
public CRUDValidationException()
Public Sub New
Public Sub New
public:
CRUDValidationException()
public:
CRUDValidationException()
new : unit -> CRUDValidationException
new : unit -> CRUDValidationException
See Also
CRUDValidationException Class
CRUDValidationException Members
CRUDValidationException Overload
NFX.DataAccess.CRUD Namespace


CRUDValidationException Constructor (String)

CRUDValidationException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CRUDValidationException class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDValidationException(
    string message
)
public CRUDValidationException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
CRUDValidationException(
    String^ message
)
public:
CRUDValidationException(
    String^ message
)
new :
        message : string -> CRUDValidationException
new :
        message : string -> CRUDValidationException

Parameters

message
Type: Online System String
See Also
CRUDValidationException Class
CRUDValidationException Members
CRUDValidationException Overload
NFX.DataAccess.CRUD Namespace


CRUDValidationException Constructor (SerializationInfo, StreamingContext)

CRUDValidationException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CRUDValidationException class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CRUDValidationException(
    SerializationInfo info,
    StreamingContext context
)
protected CRUDValidationException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
CRUDValidationException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
CRUDValidationException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> CRUDValidationException
new :
        info : SerializationInfo *
        context : StreamingContext -> CRUDValidationException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
CRUDValidationException Class
CRUDValidationException Members
CRUDValidationException Overload
NFX.DataAccess.CRUD Namespace


CRUDValidationException Constructor (String, Exception)

CRUDValidationException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CRUDValidationException class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDValidationException(
    string message,
    Exception inner
)
public CRUDValidationException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
CRUDValidationException(
    String^ message,
    Exception^ inner
)
public:
CRUDValidationException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> CRUDValidationException
new :
        message : string *
        inner : Exception -> CRUDValidationException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
CRUDValidationException Class
CRUDValidationException Members
CRUDValidationException Overload
NFX.DataAccess.CRUD Namespace


CRUDValidationException Constructor (String, KeyViolationKind, String)

CRUDValidationException Constructor (String, KeyViolationKind, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CRUDValidationException class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDValidationException(
    string message,
    KeyViolationKind kvKind,
    string keyViolation
)
public CRUDValidationException(
    string message,
    KeyViolationKind kvKind,
    string keyViolation
)
Public Sub New (
    message As String,
    kvKind As KeyViolationKind,
    keyViolation As String
)
Public Sub New (
    message As String,
    kvKind As KeyViolationKind,
    keyViolation As String
)
public:
CRUDValidationException(
    String^ message,
    KeyViolationKind kvKind,
    String^ keyViolation
)
public:
CRUDValidationException(
    String^ message,
    KeyViolationKind kvKind,
    String^ keyViolation
)
new :
        message : string *
        kvKind : KeyViolationKind *
        keyViolation : string -> CRUDValidationException
new :
        message : string *
        kvKind : KeyViolationKind *
        keyViolation : string -> CRUDValidationException

Parameters

message
Type: Online System String
kvKind
Type: NFX.DataAccess KeyViolationKind
keyViolation
Type: Online System String
See Also
CRUDValidationException Class
CRUDValidationException Members
CRUDValidationException Overload
NFX.DataAccess.CRUD Namespace


CRUDValidationException Constructor (String, Exception, KeyViolationKind, String)

CRUDValidationException Constructor (String, Exception, KeyViolationKind, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CRUDValidationException class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDValidationException(
    string message,
    Exception inner,
    KeyViolationKind kvKind,
    string keyViolation
)
public CRUDValidationException(
    string message,
    Exception inner,
    KeyViolationKind kvKind,
    string keyViolation
)
Public Sub New (
    message As String,
    inner As Exception,
    kvKind As KeyViolationKind,
    keyViolation As String
)
Public Sub New (
    message As String,
    inner As Exception,
    kvKind As KeyViolationKind,
    keyViolation As String
)
public:
CRUDValidationException(
    String^ message,
    Exception^ inner,
    KeyViolationKind kvKind,
    String^ keyViolation
)
public:
CRUDValidationException(
    String^ message,
    Exception^ inner,
    KeyViolationKind kvKind,
    String^ keyViolation
)
new :
        message : string *
        inner : Exception *
        kvKind : KeyViolationKind *
        keyViolation : string -> CRUDValidationException
new :
        message : string *
        inner : Exception *
        kvKind : KeyViolationKind *
        keyViolation : string -> CRUDValidationException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
kvKind
Type: NFX.DataAccess KeyViolationKind
keyViolation
Type: Online System String
See Also
CRUDValidationException Class
CRUDValidationException Members
CRUDValidationException Overload
NFX.DataAccess.CRUD Namespace


CRUDValidationException Fields

CRUDValidationException Fields NFX Class Library

The CRUDValidationException type exposes the following members.
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
See Also
CRUDValidationException Class
NFX.DataAccess.CRUD Namespace


CRUDValidationException Methods

CRUDValidationException Methods NFX Class Library

The CRUDValidationException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
CRUDValidationException Class
NFX.DataAccess.CRUD Namespace


CRUDValidationException Properties

CRUDValidationException Properties NFX Class Library

The CRUDValidationException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
CRUDValidationException Class
NFX.DataAccess.CRUD Namespace


CRUDValidationException Events

CRUDValidationException Events NFX Class Library

The CRUDValidationException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
CRUDValidationException Class
NFX.DataAccess.CRUD Namespace


Cursor Class

Cursor Class NFX Class Library

Represents a buffer-less unidicrectional reader that binds IEnumerable(Row) and the backend resource (such as SQLReader or other object which is internal to the backend). The cursor is NOT thread-safe and must be disposed properly by closing all resources associated with it. Only one iteration (one call to GetEnumerator) is possible
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.DataAccess.CRUD Cursor
NFX.DataAccess.MongoDB MongoDBCursor
NFX.DataAccess.MySQL MySQLCursor

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Cursor : DisposableObject,
    IEnumerable<Row>, IEnumerable
public abstract class Cursor : DisposableObject,
    IEnumerable<Row>, IEnumerable
Public MustInherit Class Cursor
    Inherits DisposableObject
    Implements IEnumerable(Of Row), IEnumerable
Public MustInherit Class Cursor
    Inherits DisposableObject
    Implements IEnumerable(Of Row), IEnumerable
public ref class Cursor abstract : public DisposableObject,
    IEnumerable<Row^>, IEnumerable
public ref class Cursor abstract : public DisposableObject,
    IEnumerable<Row^>, IEnumerable
[<AbstractClassAttribute>]
type Cursor =
    class
        inherit DisposableObject
        interface IEnumerable<Row>
        interface IEnumerable
    end
[<AbstractClassAttribute>]
type Cursor =
    class
        inherit DisposableObject
        interface IEnumerable<Row>
        interface IEnumerable
    end
See Also
Cursor Members
NFX.DataAccess.CRUD Namespace


Cursor Members

Cursor Members NFX Class Library

The Cursor type exposes the following members.
Constructors
 | Name | Description
Protected method | Cursor | This method is not inteded to be called by application developers
Back to Top
Methods
 | Name | Description
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnumerableOf TRow | Casts enumerable of rows (such as rowset) to the specified row type, returning empty enumerable if the source is null (Defined by DataUtils.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable Row | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct Row, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax Row, TComparand (Func Row, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax Row, TComparand (Func Row, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin Row, TComparand (Func Row, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin Row, TComparand (Func Row, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault Row | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach Row (Action Row ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach Row (Action Row, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast Row | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast Row (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Enumerator |
Protected field | m_Source |
Back to Top
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
Cursor Class
NFX.DataAccess.CRUD Namespace


Cursor Constructor

Cursor Constructor NFX Class Library

This method is not inteded to be called by application developers

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Cursor(
    IEnumerable<Row> source
)
protected Cursor(
    IEnumerable<Row> source
)
Protected Sub New (
    source As IEnumerable(Of Row)
)
Protected Sub New (
    source As IEnumerable(Of Row)
)
protected:
Cursor(
    IEnumerable<Row^>^ source
)
protected:
Cursor(
    IEnumerable<Row^>^ source
)
new :
        source : IEnumerable<Row> -> Cursor
new :
        source : IEnumerable<Row> -> Cursor

Parameters

source
Type: Online System.Collections.Generic IEnumerable Row
See Also
Cursor Class
Cursor Members
NFX.DataAccess.CRUD Namespace


Cursor Fields

Cursor Fields NFX Class Library

The Cursor type exposes the following members.
Fields
 | Name | Description
Protected field | m_Enumerator |
Protected field | m_Source |
Back to Top
See Also
Cursor Class
NFX.DataAccess.CRUD Namespace


Cursor.m_Enumerator Field

Cursor m_Enumerator Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Cursor..::..enumerator m_Enumerator
protected Cursor..::..enumerator m_Enumerator
Protected m_Enumerator As Cursor..::..enumerator
Protected m_Enumerator As Cursor..::..enumerator
protected:
Cursor..::..enumerator^ m_Enumerator
protected:
Cursor..::..enumerator^ m_Enumerator
val mutable m_Enumerator: Cursor..::..enumerator
val mutable m_Enumerator: Cursor..::..enumerator

Field Value

Type: Cursor enumerator
See Also
Cursor Class
Cursor Members
NFX.DataAccess.CRUD Namespace


Cursor.m_Source Field

Cursor m_Source Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IEnumerable<Row> m_Source
protected IEnumerable<Row> m_Source
Protected m_Source As IEnumerable(Of Row)
Protected m_Source As IEnumerable(Of Row)
protected:
IEnumerable<Row^>^ m_Source
protected:
IEnumerable<Row^>^ m_Source
val mutable m_Source: IEnumerable<Row>
val mutable m_Source: IEnumerable<Row>

Field Value

Type: Online IEnumerable Row
See Also
Cursor Class
Cursor Members
NFX.DataAccess.CRUD Namespace


Cursor Methods

Cursor Methods NFX Class Library

The Cursor type exposes the following members.
Methods
 | Name | Description
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnumerableOf TRow | Casts enumerable of rows (such as rowset) to the specified row type, returning empty enumerable if the source is null (Defined by DataUtils.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable Row | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct Row, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax Row, TComparand (Func Row, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax Row, TComparand (Func Row, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin Row, TComparand (Func Row, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin Row, TComparand (Func Row, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault Row | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach Row (Action Row ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach Row (Action Row, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast Row | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast Row (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
Cursor Class
NFX.DataAccess.CRUD Namespace


Cursor.IEnumerable.GetEnumerator Method

Cursor IEnumerable GetEnumerator Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
Cursor Class
Cursor Members
NFX.DataAccess.CRUD Namespace


Cursor.Destructor Method

Cursor Destructor Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
Cursor Class
Cursor Members
NFX.DataAccess.CRUD Namespace


Cursor.GetEnumerator Method

Cursor GetEnumerator Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IEnumerator<Row> GetEnumerator()
public virtual IEnumerator<Row> GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator(Of Row)
Public Overridable Function GetEnumerator As IEnumerator(Of Row)
public:
virtual IEnumerator<Row^>^ GetEnumerator()
public:
virtual IEnumerator<Row^>^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator<Row>
override GetEnumerator : unit -> IEnumerator<Row>
abstract GetEnumerator : unit -> IEnumerator<Row>
override GetEnumerator : unit -> IEnumerator<Row>

Return Value

Type: Online IEnumerator Row

Implements

Online IEnumerable T GetEnumerator
See Also
Cursor Class
Cursor Members
NFX.DataAccess.CRUD Namespace


Cursor Properties

Cursor Properties NFX Class Library

The Cursor type exposes the following members.
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Back to Top
See Also
Cursor Class
NFX.DataAccess.CRUD Namespace


Cursor.enumerator Class

Cursor enumerator Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.DataAccess.CRUD Cursor enumerator

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected class enumerator : IEnumerator<Row>,
    IDisposable, IEnumerator
protected class enumerator : IEnumerator<Row>,
    IDisposable, IEnumerator
Protected Class enumerator
    Implements IEnumerator(Of Row), IDisposable,
    IEnumerator
Protected Class enumerator
    Implements IEnumerator(Of Row), IDisposable,
    IEnumerator
protected ref class enumerator : IEnumerator<Row^>,
    IDisposable, IEnumerator
protected ref class enumerator : IEnumerator<Row^>,
    IDisposable, IEnumerator
type enumerator =
    class
        interface IEnumerator<Row>
        interface IDisposable
        interface IEnumerator
    end
type enumerator =
    class
        interface IEnumerator<Row>
        interface IDisposable
        interface IEnumerator
    end
See Also
Cursor enumerator Members
NFX.DataAccess.CRUD Namespace


Cursor.enumerator Members

Cursor enumerator Members NFX Class Library

The Cursor enumerator type exposes the following members.
Constructors
 | Name | Description
Protected method | Cursor enumerator | Initializes a new instance of the Cursor enumerator class
Back to Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the Cursor enumerator
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MoveNext |
Public method | Reset |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Current |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerator Current |
Back to Top
See Also
Cursor enumerator Class
NFX.DataAccess.CRUD Namespace


Cursor.enumerator Constructor

Cursor enumerator Constructor NFX Class Library

Initializes a new instance of the Cursor enumerator class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal enumerator(
    Cursor cursor,
    IEnumerator<Row> original
)
internal enumerator(
    Cursor cursor,
    IEnumerator<Row> original
)
Friend Sub New (
    cursor As Cursor,
    original As IEnumerator(Of Row)
)
Friend Sub New (
    cursor As Cursor,
    original As IEnumerator(Of Row)
)
internal:
enumerator(
    Cursor^ cursor,
    IEnumerator<Row^>^ original
)
internal:
enumerator(
    Cursor^ cursor,
    IEnumerator<Row^>^ original
)
new :
        cursor : Cursor *
        original : IEnumerator<Row> -> enumerator
new :
        cursor : Cursor *
        original : IEnumerator<Row> -> enumerator

Parameters

cursor
Type: NFX.DataAccess.CRUD Cursor
original
Type: Online System.Collections.Generic IEnumerator Row
See Also
Cursor enumerator Class
Cursor enumerator Members
NFX.DataAccess.CRUD Namespace


Cursor.enumerator Methods

Cursor enumerator Methods NFX Class Library

The Cursor enumerator type exposes the following members.
Methods
 | Name | Description
Public method | Dispose |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MoveNext |
Public method | Reset |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Cursor enumerator Class
NFX.DataAccess.CRUD Namespace


Cursor.enumerator.Dispose Method

Cursor enumerator Dispose Method NFX Class Library

Releases all resources used by the Cursor enumerator

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

Online IDisposable Dispose
See Also
Cursor enumerator Class
Cursor enumerator Members
NFX.DataAccess.CRUD Namespace


Cursor.enumerator.MoveNext Method

Cursor enumerator MoveNext Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool MoveNext()
public bool MoveNext()
Public Function MoveNext As Boolean
Public Function MoveNext As Boolean
public:
virtual bool MoveNext() sealed
public:
virtual bool MoveNext() sealed
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Type: Online Boolean

Implements

Online IEnumerator MoveNext
See Also
Cursor enumerator Class
Cursor enumerator Members
NFX.DataAccess.CRUD Namespace


Cursor.enumerator.Reset Method

Cursor enumerator Reset Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Reset()
public void Reset()
Public Sub Reset
Public Sub Reset
public:
virtual void Reset() sealed
public:
virtual void Reset() sealed
abstract Reset : unit -> unit
override Reset : unit -> unit
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

Online IEnumerator Reset
See Also
Cursor enumerator Class
Cursor enumerator Members
NFX.DataAccess.CRUD Namespace


Cursor.enumerator Properties

Cursor enumerator Properties NFX Class Library

The Cursor enumerator type exposes the following members.
Properties
 | Name | Description
Public property | Current |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerator Current |
Back to Top
See Also
Cursor enumerator Class
NFX.DataAccess.CRUD Namespace


Cursor.enumerator.IEnumerator.Current Property

Cursor enumerator IEnumerator Current Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object IEnumerator.Current { get; }
Object IEnumerator.Current { get; }
Private ReadOnly Property Current As Object
    Implements IEnumerator.Current
    Get
Private ReadOnly Property Current As Object
    Implements IEnumerator.Current
    Get
private:
virtual property Object^ Current {
    Object^ get () sealed = IEnumerator::Current::get;
}
private:
virtual property Object^ Current {
    Object^ get () sealed = IEnumerator::Current::get;
}
private abstract Current : Object with get
private override Current : Object with get
private abstract Current : Object with get
private override Current : Object with get

Property Value

Type: Online Object

Implements

Online IEnumerator Current
See Also
Cursor enumerator Class
Cursor enumerator Members
NFX.DataAccess.CRUD Namespace


Cursor.enumerator.Current Property

Cursor enumerator Current Property NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Row Current { get; }
public Row Current { get; }
Public ReadOnly Property Current As Row
    Get
Public ReadOnly Property Current As Row
    Get
public:
virtual property Row^ Current {
    Row^ get () sealed;
}
public:
virtual property Row^ Current {
    Row^ get () sealed;
}
abstract Current : Row with get
override Current : Row with get
abstract Current : Row with get
override Current : Row with get

Property Value

Type: Row

Implements

Online IEnumerator T Current
See Also
Cursor enumerator Class
Cursor enumerator Members
NFX.DataAccess.CRUD Namespace


DataKind Enumeration

DataKind Enumeration NFX Class Library

Provides hint/classification for field textual data

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum DataKind
public enum DataKind
Public Enumeration DataKind
Public Enumeration DataKind
public enum class DataKind
public enum class DataKind
type DataKind
type DataKind
Members
Member name | Value | Description
Text | 0 |
ScreenName | 1 |
Color | 2 |
Date | 3 |
DateTime | 4 |
DateTimeLocal | 5 |
EMail | 6 |
Month | 7 |
Number | 8 |
Range | 9 |
Search | 10 |
Telephone | 11 |
Time | 12 |
Url | 13 |
Week | 14 |
See Also
NFX.DataAccess.CRUD Namespace


DynamicRow Class

DynamicRow Class NFX Class Library

Represents a row of data which has a schema only known at run-time. Dynamic rows store data in object[] internally, providing better flexibility(ability to define schema at runtime) than TypedRows at the expense of performance. This class is not sealed so implementors may override configuration persistence
Inheritance Hierarchy
Online System Object
NFX.DataAccess.CRUD Row
NFX.DataAccess.CRUD DynamicRow
NFX.DataAccess.CRUD AmorphousDynamicRow
NFX.Wave.Client Record

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class DynamicRow : Row
[SerializableAttribute]
public class DynamicRow : Row
<SerializableAttribute>
Public Class DynamicRow
    Inherits Row
<SerializableAttribute>
Public Class DynamicRow
    Inherits Row
[SerializableAttribute]
public ref class DynamicRow : public Row
[SerializableAttribute]
public ref class DynamicRow : public Row
[<SerializableAttribute>]
type DynamicRow =
    class
        inherit Row
    end
[<SerializableAttribute>]
type DynamicRow =
    class
        inherit Row
    end
See Also
DynamicRow Members
NFX.DataAccess.CRUD Namespace


DynamicRow Members

DynamicRow Members NFX Class Library

The DynamicRow type exposes the following members.
Constructors
 | Name | Description
Protected method | DynamicRow | Initializes a new instance of the DynamicRow class
Public method | DynamicRow(Schema) | Initializes a new instance of the DynamicRow class
Back to Top
Methods
 | Name | Description
Protected method | __ctor | Developers do not call, lazily injects the statr of this object, this is needed for speed and other optimizations
Public method | ApplyDefaultFieldValues | Writes default values specified in schema into fields. Pass overwrite=true to force defaults over non-null existing values (false by default) (Inherited from Row.)
Protected method | CheckMinMax | (Inherited from Row.)
Public method | Configure | In base class applies Config attribute. Useful for typed rows (Inherited from Row.)
Public method | ConvertFieldValueToDef | Converts field value to the type specified by Schema.FieldDef. For example converts GDID->ulong or ulong->GDID. This method can be overridden to perform custom handling of types, for example one can assign bool field as "Si" that would convert to TRUE. This method is called by SetFieldValue(...) before assigning actual field buffer (Inherited from Row.)
Public method | CopyFields | Copies fields from this row into another row/form. Note: this is shallow copy, as field values for complex types are just copied over (Inherited from Row.)
Public method | Equals(Object) | Object override - sealed. Override Equals(row) instead (Inherited from Row.)
Public method | Equals(Row) | Override to perform custom row equality comparison. Default implementation equates rows using their key fields (Inherited from Row.)
Protected method | FilterJSONSerializerField | Override to filter-out some fields from serialization to JSON, or change field values. Return name null to indicate that field should be filtered-out(excluded from serialization to JSON) (Inherited from Row.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetClientFieldDef | Override to perform dynamic substitute of field def for the specified field. This method is used by client ui/scaffolding to extract dynamic definition for a field (i.e. field description, requirement, value list etc.) as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original field def, you can return a substituted field def per particular business logic (Inherited from Row.)
Public method | GetClientFieldValue | Override to perform dynamic substitute of field value for the specified field. This method is used by client ui/scaffolding to extract field values for a field as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original GetFieldValue(fdef), you can return a substituted field value per particular business logic (Inherited from Row.)
Public method | GetClientFieldValueList | Override to perform dynamic lookup of field value list for the specified field. This method is used by client ui/scaffolding to extract dynamic lookup values as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. This is a simplified version of GetClientFieldDef (Inherited from Row.)
Public method | GetDataStoreKey | Returns values for fields that represent row's primary key (Inherited from Row.)
Public method | GetDisplayFieldValue(Int32, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute (Inherited from Row.)
Public method | GetDisplayFieldValue(String, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute (Inherited from Row.)
Public method | GetEnumerator | (Inherited from Row.)
Public method | GetFieldValue | (Overrides Row GetFieldValue(Schema FieldDef).)
Public method | GetFieldValueDescription(Int32, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema (Inherited from Row.)
Public method | GetFieldValueDescription(String, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema (Inherited from Row.)
Public method | GetHashCode | Object override - gets hash code from key fields (Inherited from Row.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PersistConfiguration | The base class does not implement this method. Override to persist row fields into config node (Inherited from Row.)
Public method | SetFieldValue | (Overrides Row SetFieldValue(Schema FieldDef, Object).)
Public method | SimpleFilterPredicate | Returns true if this row satisfies simple filter - it contains the supplied filter string. The filter pattern may start or end with "*" char that denotes a wildcard. A wildcard is permitted on both sides of the filter value (Inherited from Row.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Validate | Performs validation of data in the row returning exception object that provides description in cases when validation does not pass. Validation is performed not targeting any particular backend (Inherited from Row.)
Public method | Validate(String) | Validates row using row schema and supplied field definitions. Override to perform custom validations, i.e. TypeRows may directly access properties and write some validation type-safe code The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from Row.)
Public method | ValidateField(String, Schema FieldDef) | Validates row field using Schema.FieldDef settings. This method is invoked by base Validate() implementation. The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from Row.)
Public method | ValidateField(String, String) | Validates row field by name. Shortcut to ValidateField(Schema.FieldDef) (Inherited from Row.)
Public method | WriteAsJSON | Writes row as JSON either as an array or map depending on JSONWritingOptions.RowsAsMap setting. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class (Inherited from Row.)
Back to Top
Extension Methods
Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method ToErlObject Overloaded.
Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(ErlTypeOrder, Boolean) Overloaded.
Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(String, String, Boolean) Overloaded.
Convert Row to a hierarchical term that corresponds to the row's schema. The Erlang term is in the form:
View Colorized Copy to Clipboard Print
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
(Defined by ErlSchemaUtils.)
Public Extension Method ToJSON(JSONWritingOptions) Overloaded.
Serializes object into JSON string
(Defined by JSONExtensions.)
Public Extension Method ToJSON(TextWriter, JSONWritingOptions) Overloaded.
Serializes object into JSON format using provided TextWriter
(Defined by JSONExtensions.)
Public Extension Method ToJSON(Stream, JSONWritingOptions, Encoding) Overloaded.
Serializes object into JSON format using provided stream and optional encoding
(Defined by JSONExtensions.)
Public Extension Method Update
Convert an Erlang hierarchical term representing a schema to a Row.
(Defined by ErlSchemaUtils.)
Back to Top
Properties
 | Name | Description
Public property | Data | Provides access to raw array of values that this row contains
Public property | Item Int32 | Gets/sets field values by positional index(Order) (Inherited from Row.)
Public property | Item String | Gets/sets field values by name (Inherited from Row.)
Public property | Schema | References a schema for a table that this row is a part of (Overrides Row Schema.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Row.)
Back to Top
See Also
DynamicRow Class
NFX.DataAccess.CRUD Namespace


DynamicRow Constructor

DynamicRow Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | DynamicRow | Initializes a new instance of the DynamicRow class
Public method | DynamicRow(Schema) | Initializes a new instance of the DynamicRow class
Back to Top
See Also
DynamicRow Class
DynamicRow Members
NFX.DataAccess.CRUD Namespace


DynamicRow Constructor

DynamicRow Constructor NFX Class Library

Initializes a new instance of the DynamicRow class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected DynamicRow()
protected DynamicRow()
Protected Sub New
Protected Sub New
protected:
DynamicRow()
protected:
DynamicRow()
new : unit -> DynamicRow
new : unit -> DynamicRow
See Also
DynamicRow Class
DynamicRow Members
DynamicRow Overload
NFX.DataAccess.CRUD Namespace


DynamicRow Constructor (Schema)

DynamicRow Constructor (Schema) NFX Class Library

Initializes a new instance of the DynamicRow class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DynamicRow(
    Schema schema
)
public DynamicRow(
    Schema schema
)
Public Sub New (
    schema As Schema
)
Public Sub New (
    schema As Schema
)
public:
DynamicRow(
    Schema^ schema
)
public:
DynamicRow(
    Schema^ schema
)
new :
        schema : Schema -> DynamicRow
new :
        schema : Schema -> DynamicRow

Parameters

schema
Type: NFX.DataAccess.CRUD Schema
See Also
DynamicRow Class
DynamicRow Members
DynamicRow Overload
NFX.DataAccess.CRUD Namespace


DynamicRow Methods

DynamicRow Methods NFX Class Library

The DynamicRow type exposes the following members.
Methods
 | Name | Description
Protected method | __ctor | Developers do not call, lazily injects the statr of this object, this is needed for speed and other optimizations
Public method | ApplyDefaultFieldValues | Writes default values specified in schema into fields. Pass overwrite=true to force defaults over non-null existing values (false by default) (Inherited from Row.)
Protected method | CheckMinMax | (Inherited from Row.)
Public method | Configure | In base class applies Config attribute. Useful for typed rows (Inherited from Row.)
Public method | ConvertFieldValueToDef | Converts field value to the type specified by Schema.FieldDef. For example converts GDID->ulong or ulong->GDID. This method can be overridden to perform custom handling of types, for example one can assign bool field as "Si" that would convert to TRUE. This method is called by SetFieldValue(...) before assigning actual field buffer (Inherited from Row.)
Public method | CopyFields | Copies fields from this row into another row/form. Note: this is shallow copy, as field values for complex types are just copied over (Inherited from Row.)
Public method | Equals(Object) | Object override - sealed. Override Equals(row) instead (Inherited from Row.)
Public method | Equals(Row) | Override to perform custom row equality comparison. Default implementation equates rows using their key fields (Inherited from Row.)
Protected method | FilterJSONSerializerField | Override to filter-out some fields from serialization to JSON, or change field values. Return name null to indicate that field should be filtered-out(excluded from serialization to JSON) (Inherited from Row.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetClientFieldDef | Override to perform dynamic substitute of field def for the specified field. This method is used by client ui/scaffolding to extract dynamic definition for a field (i.e. field description, requirement, value list etc.) as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original field def, you can return a substituted field def per particular business logic (Inherited from Row.)
Public method | GetClientFieldValue | Override to perform dynamic substitute of field value for the specified field. This method is used by client ui/scaffolding to extract field values for a field as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original GetFieldValue(fdef), you can return a substituted field value per particular business logic (Inherited from Row.)
Public method | GetClientFieldValueList | Override to perform dynamic lookup of field value list for the specified field. This method is used by client ui/scaffolding to extract dynamic lookup values as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. This is a simplified version of GetClientFieldDef (Inherited from Row.)
Public method | GetDataStoreKey | Returns values for fields that represent row's primary key (Inherited from Row.)
Public method | GetDisplayFieldValue(Int32, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute (Inherited from Row.)
Public method | GetDisplayFieldValue(String, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute (Inherited from Row.)
Public method | GetEnumerator | (Inherited from Row.)
Public method | GetFieldValue | (Overrides Row GetFieldValue(Schema FieldDef).)
Public method | GetFieldValueDescription(Int32, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema (Inherited from Row.)
Public method | GetFieldValueDescription(String, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema (Inherited from Row.)
Public method | GetHashCode | Object override - gets hash code from key fields (Inherited from Row.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PersistConfiguration | The base class does not implement this method. Override to persist row fields into config node (Inherited from Row.)
Public method | SetFieldValue | (Overrides Row SetFieldValue(Schema FieldDef, Object).)
Public method | SimpleFilterPredicate | Returns true if this row satisfies simple filter - it contains the supplied filter string. The filter pattern may start or end with "*" char that denotes a wildcard. A wildcard is permitted on both sides of the filter value (Inherited from Row.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Validate | Performs validation of data in the row returning exception object that provides description in cases when validation does not pass. Validation is performed not targeting any particular backend (Inherited from Row.)
Public method | Validate(String) | Validates row using row schema and supplied field definitions. Override to perform custom validations, i.e. TypeRows may directly access properties and write some validation type-safe code The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from Row.)
Public method | ValidateField(String, Schema FieldDef) | Validates row field using Schema.FieldDef settings. This method is invoked by base Validate() implementation. The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from Row.)
Public method | ValidateField(String, String) | Validates row field by name. Shortcut to ValidateField(Schema.FieldDef) (Inherited from Row.)
Public method | WriteAsJSON | Writes row as JSON either as an array or map depending on JSONWritingOptions.RowsAsMap setting. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class (Inherited from Row.)
Back to Top
Extension Methods
Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method ToErlObject Overloaded.
Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(ErlTypeOrder, Boolean) Overloaded.
Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(String, String, Boolean) Overloaded.
Convert Row to a hierarchical term that corresponds to the row's schema. The Erlang term is in the form:
View Colorized Copy to Clipboard Print
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
(Defined by ErlSchemaUtils.)
Public Extension Method ToJSON(JSONWritingOptions) Overloaded.
Serializes object into JSON string
(Defined by JSONExtensions.)
Public Extension Method ToJSON(TextWriter, JSONWritingOptions) Overloaded.
Serializes object into JSON format using provided TextWriter
(Defined by JSONExtensions.)
Public Extension Method ToJSON(Stream, JSONWritingOptions, Encoding) Overloaded.
Serializes object into JSON format using provided stream and optional encoding
(Defined by JSONExtensions.)
Public Extension Method Update
Convert an Erlang hierarchical term representing a schema to a Row.
(Defined by ErlSchemaUtils.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Row.)
Back to Top
See Also
DynamicRow Class
NFX.DataAccess.CRUD Namespace


DynamicRow.__ctor Method

DynamicRow __ctor Method NFX Class Library

Developers do not call, lazily injects the statr of this object, this is needed for speed and other optimizations

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void __ctor(
    Schema schema
)
internal void __ctor(
    Schema schema
)
Friend Sub __ctor (
    schema As Schema
)
Friend Sub __ctor (
    schema As Schema
)
internal:
void __ctor(
    Schema^ schema
)
internal:
void __ctor(
    Schema^ schema
)
internal member __ctor :
        schema : Schema -> unit
internal member __ctor :
        schema : Schema -> unit

Parameters

schema
Type: NFX.DataAccess.CRUD Schema
See Also
DynamicRow Class
DynamicRow Members
NFX.DataAccess.CRUD Namespace


DynamicRow.GetFieldValue Method

DynamicRow GetFieldValue Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object GetFieldValue(
    Schema..::..FieldDef fdef
)
public override Object GetFieldValue(
    Schema..::..FieldDef fdef
)
Public Overrides Function GetFieldValue (
    fdef As Schema..::..FieldDef
) As Object
Public Overrides Function GetFieldValue (
    fdef As Schema..::..FieldDef
) As Object
public:
virtual Object^ GetFieldValue(
    Schema..::..FieldDef^ fdef
) override
public:
virtual Object^ GetFieldValue(
    Schema..::..FieldDef^ fdef
) override
abstract GetFieldValue :
        fdef : Schema..::..FieldDef -> Object
override GetFieldValue :
        fdef : Schema..::..FieldDef -> Object
abstract GetFieldValue :
        fdef : Schema..::..FieldDef -> Object
override GetFieldValue :
        fdef : Schema..::..FieldDef -> Object

Parameters

fdef
Type: NFX.DataAccess.CRUD Schema FieldDef

Return Value

Type: Online Object
See Also
DynamicRow Class
DynamicRow Members
NFX.DataAccess.CRUD Namespace


DynamicRow.SetFieldValue Method

DynamicRow SetFieldValue Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetFieldValue(
    Schema..::..FieldDef fdef,
    Object value
)
public override void SetFieldValue(
    Schema..::..FieldDef fdef,
    Object value
)
Public Overrides Sub SetFieldValue (
    fdef As Schema..::..FieldDef,
    value As Object
)
Public Overrides Sub SetFieldValue (
    fdef As Schema..::..FieldDef,
    value As Object
)
public:
virtual void SetFieldValue(
    Schema..::..FieldDef^ fdef,
    Object^ value
) override
public:
virtual void SetFieldValue(
    Schema..::..FieldDef^ fdef,
    Object^ value
) override
abstract SetFieldValue :
        fdef : Schema..::..FieldDef *
        value : Object -> unit
override SetFieldValue :
        fdef : Schema..::..FieldDef *
        value : Object -> unit
abstract SetFieldValue :
        fdef : Schema..::..FieldDef *
        value : Object -> unit
override SetFieldValue :
        fdef : Schema..::..FieldDef *
        value : Object -> unit

Parameters

fdef
Type: NFX.DataAccess.CRUD Schema FieldDef
value
Type: Online System Object
See Also
DynamicRow Class
DynamicRow Members
NFX.DataAccess.CRUD Namespace


DynamicRow Properties

DynamicRow Properties NFX Class Library

The DynamicRow type exposes the following members.
Properties
 | Name | Description
Public property | Data | Provides access to raw array of values that this row contains
Public property | Item Int32 | Gets/sets field values by positional index(Order) (Inherited from Row.)
Public property | Item String | Gets/sets field values by name (Inherited from Row.)
Public property | Schema | References a schema for a table that this row is a part of (Overrides Row Schema.)
Back to Top
See Also
DynamicRow Class
NFX.DataAccess.CRUD Namespace


DynamicRow.Data Property

DynamicRow Data Property NFX Class Library

Provides access to raw array of values that this row contains

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object[] Data { get; }
public Object[] Data { get; }
Public ReadOnly Property Data As Object()
    Get
Public ReadOnly Property Data As Object()
    Get
public:
property array<Object^>^ Data {
    array<Object^>^ get ();
}
public:
property array<Object^>^ Data {
    array<Object^>^ get ();
}
member Data : Object[] with get
member Data : Object[] with get

Property Value

Type: Online Object
See Also
DynamicRow Class
DynamicRow Members
NFX.DataAccess.CRUD Namespace


DynamicRow.Schema Property

DynamicRow Schema Property NFX Class Library

References a schema for a table that this row is a part of

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Schema Schema { get; }
public override Schema Schema { get; }
Public Overrides ReadOnly Property Schema As Schema
    Get
Public Overrides ReadOnly Property Schema As Schema
    Get
public:
virtual property Schema^ Schema {
    Schema^ get () override;
}
public:
virtual property Schema^ Schema {
    Schema^ get () override;
}
abstract Schema : Schema with get
override Schema : Schema with get
abstract Schema : Schema with get
override Schema : Schema with get

Property Value

Type: Schema
See Also
DynamicRow Class
DynamicRow Members
NFX.DataAccess.CRUD Namespace


FieldAttribute Class

FieldAttribute Class NFX Class Library

Provides information about table schema that this typed row is a part of
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.DataAccess.CRUD TargetedAttribute
NFX.DataAccess.CRUD FieldAttribute

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
[AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = true, Inherited = false)]
public sealed class FieldAttribute : TargetedAttribute
[SerializableAttribute]
[AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = true, Inherited = false)]
public sealed class FieldAttribute : TargetedAttribute
<SerializableAttribute>
<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple := true, Inherited := false)>
Public NotInheritable Class FieldAttribute
    Inherits TargetedAttribute
<SerializableAttribute>
<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple := true, Inherited := false)>
Public NotInheritable Class FieldAttribute
    Inherits TargetedAttribute
[SerializableAttribute]
[AttributeUsageAttribute(AttributeTargets::Property, AllowMultiple = true, Inherited = false)]
public ref class FieldAttribute sealed : public TargetedAttribute
[SerializableAttribute]
[AttributeUsageAttribute(AttributeTargets::Property, AllowMultiple = true, Inherited = false)]
public ref class FieldAttribute sealed : public TargetedAttribute
[<SealedAttribute>]
[<SerializableAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = true, Inherited = false)>]
type FieldAttribute =
    class
        inherit TargetedAttribute
    end
[<SealedAttribute>]
[<SerializableAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = true, Inherited = false)>]
type FieldAttribute =
    class
        inherit TargetedAttribute
    end
See Also
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldAttribute Members

FieldAttribute Members NFX Class Library

The FieldAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | FieldAttribute(Type) | Initializes a new instance of the FieldAttribute class
Public method | FieldAttribute(JSONDataMap, String, StoreFlag, Boolean, DataKind, Boolean, Boolean, Object, Object, Object, Int32, Int32, CharCase, String, String, String, String, Boolean, String, String, String) | Used for injection of pre-parsed value list
Public method | FieldAttribute(String, StoreFlag, Boolean, DataKind, Boolean, Boolean, String, Object, Object, Object, Int32, Int32, CharCase, String, String, String, String, Boolean, String, String, String, Boolean) | Initializes a new instance of the FieldAttribute class
Public method | FieldAttribute(Type, String, String, Object, Object, Object, Object, Object, String, Object, Object, Object, Object, Object, Object, String, String, String, String, Object, String, String, String, Object) | Initializes a new instance of the FieldAttribute class
Back to Top
Methods
 | Name | Description
Public method | Equals | (Overrides Online Attribute Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Attribute GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ParseValueList | Returns a ValueList parsed into key values as: val1: descr1,val2: desc2...
 | ParseValueListString | Returns a string parsed into key values as: val1: descr1,val2: desc2...
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | BackendName | Provides an overriden name for this field
Public field | BackendType | Provides an overriden type for this field in backend, i.e. CLR string may be stored as ErlPid in erlang
Public field | CharCase | Controls character casing of textual fields
Public field | CloneFromRowType | When set, points to a Typed-Row derivative that is used as a full clone
Public field | Default | Provides default value
Public field | Description | Provides description
Public field | DisplayFormat | Display format string or null
Public field | FormatDescription | Description for regular expression used for field format validation if set
Public field | FormatRegExp | Regular expression used for field format validation if set
Public field | IsArow | True if this field definition is used by Arow serializer
Public field | Key | Determines whether this field is a part of the primary key
Public field | Kind | Provides hint/classification for textual field data
Protected field | m_MetadataContent | (Inherited from TargetedAttribute.)
Public field | Max | Provides high-bound validation check
Public field | MaxLength | Imposes a limit on maximum amount of characters in a textual field
Public field | Min | Provides low-bound validation check
Public field | MinLength | Imposes a limit on minimum amount of characters in a textual field
Public field | NonUI | If true indicates that this field is ignored when generating UI and ignored when UI supplies the value to the server. Pass true to protect server-only structures from being modified by client
Public field | Required | Determines whether the field must have data
Public field | StoreFlag | Determines whether field should be loaded/stored from/to storage
Public field | TargetName | Returns the name of target, i.e. the name of database engine i.e. "ORACLE11g" or "MySQL" (Inherited from TargetedAttribute.)
Public field | ValueList | Returns a ";/,/|"-delimited list of permitted field values - used for lookup validation
Public field | Visible | Determines whether the field is shown to user (i.e. as a grid column)
Back to Top
Properties
 | Name | Description
Public property | HasValueList | Returns true if the value list is set or internal JSONDataMap is set
Public property | Metadata | Returns structured metadata or null if there is no metadata defined (Inherited from TargetedAttribute.)
Public property | MetadataContent | Returns metadata content string in Laconic format or null. Root not is not specified. I.e.: 'a=1 b=true c{...}' (Inherited from TargetedAttribute.)
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
FieldAttribute Class
NFX.DataAccess.CRUD Namespace


FieldAttribute Constructor

FieldAttribute Constructor NFX Class Library

Overload List
 | Name | Description
Public method | FieldAttribute(Type) | Initializes a new instance of the FieldAttribute class
Public method | FieldAttribute(JSONDataMap, String, StoreFlag, Boolean, DataKind, Boolean, Boolean, Object, Object, Object, Int32, Int32, CharCase, String, String, String, String, Boolean, String, String, String) | Used for injection of pre-parsed value list
Public method | FieldAttribute(String, StoreFlag, Boolean, DataKind, Boolean, Boolean, String, Object, Object, Object, Int32, Int32, CharCase, String, String, String, String, Boolean, String, String, String, Boolean) | Initializes a new instance of the FieldAttribute class
Public method | FieldAttribute(Type, String, String, Object, Object, Object, Object, Object, String, Object, Object, Object, Object, Object, Object, String, String, String, String, Object, String, String, String, Object) | Initializes a new instance of the FieldAttribute class
Back to Top
See Also
FieldAttribute Class
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldAttribute Constructor (Type)

FieldAttribute Constructor (Type) NFX Class Library

Initializes a new instance of the FieldAttribute class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldAttribute(
    Type cloneFromRowType
)
public FieldAttribute(
    Type cloneFromRowType
)
Public Sub New (
    cloneFromRowType As Type
)
Public Sub New (
    cloneFromRowType As Type
)
public:
FieldAttribute(
    Type^ cloneFromRowType
)
public:
FieldAttribute(
    Type^ cloneFromRowType
)
new :
        cloneFromRowType : Type -> FieldAttribute
new :
        cloneFromRowType : Type -> FieldAttribute

Parameters

cloneFromRowType
Type: Online System Type
See Also
FieldAttribute Class
FieldAttribute Members
FieldAttribute Overload
NFX.DataAccess.CRUD Namespace


FieldAttribute Constructor (JSONDataMap, String, StoreFlag, Boolean, DataKind, Boolean, Boolean, Object, Object, Object, Int32, Int32, CharCase, String, String, String, String, Boolean, String, String, String)

FieldAttribute Constructor (JSONDataMap, String, StoreFlag, Boolean, DataKind, Boolean, Boolean, Object, Object, Object, Int32, Int32, CharCase, String, String, String, String, Boolean, String, String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Used for injection of pre-parsed value list

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldAttribute(
    JSONDataMap valueList,
    string targetName = "*",
    StoreFlag storeFlag = StoreFlag.LoadAndStore,
    bool key = false,
    DataKind kind = DataKind.Text,
    bool required = false,
    bool visible = true,
    Object dflt = null,
    Object min = null,
    Object max = null,
    int minLength = 0,
    int maxLength = 0,
    CharCase charCase = CharCase.AsIs,
    string backendName = null,
    string backendType = null,
    string description = null,
    string metadata = null,
    bool nonUI = false,
    string formatRegExp = null,
    string formatDescr = null,
    string displayFormat = null
)
public FieldAttribute(
    JSONDataMap valueList,
    string targetName = "*",
    StoreFlag storeFlag = StoreFlag.LoadAndStore,
    bool key = false,
    DataKind kind = DataKind.Text,
    bool required = false,
    bool visible = true,
    Object dflt = null,
    Object min = null,
    Object max = null,
    int minLength = 0,
    int maxLength = 0,
    CharCase charCase = CharCase.AsIs,
    string backendName = null,
    string backendType = null,
    string description = null,
    string metadata = null,
    bool nonUI = false,
    string formatRegExp = null,
    string formatDescr = null,
    string displayFormat = null
)
Public Sub New (
    valueList As JSONDataMap,
    Optional targetName As String = "*",
    Optional storeFlag As StoreFlag = StoreFlag.LoadAndStore,
    Optional key As Boolean = false,
    Optional kind As DataKind = DataKind.Text,
    Optional required As Boolean = false,
    Optional visible As Boolean = true,
    Optional dflt As Object = Nothing,
    Optional min As Object = Nothing,
    Optional max As Object = Nothing,
    Optional minLength As Integer = 0,
    Optional maxLength As Integer = 0,
    Optional charCase As CharCase = CharCase.AsIs,
    Optional backendName As String = Nothing,
    Optional backendType As String = Nothing,
    Optional description As String = Nothing,
    Optional metadata As String = Nothing,
    Optional nonUI As Boolean = false,
    Optional formatRegExp As String = Nothing,
    Optional formatDescr As String = Nothing,
    Optional displayFormat As String = Nothing
)
Public Sub New (
    valueList As JSONDataMap,
    Optional targetName As String = "*",
    Optional storeFlag As StoreFlag = StoreFlag.LoadAndStore,
    Optional key As Boolean = false,
    Optional kind As DataKind = DataKind.Text,
    Optional required As Boolean = false,
    Optional visible As Boolean = true,
    Optional dflt As Object = Nothing,
    Optional min As Object = Nothing,
    Optional max As Object = Nothing,
    Optional minLength As Integer = 0,
    Optional maxLength As Integer = 0,
    Optional charCase As CharCase = CharCase.AsIs,
    Optional backendName As String = Nothing,
    Optional backendType As String = Nothing,
    Optional description As String = Nothing,
    Optional metadata As String = Nothing,
    Optional nonUI As Boolean = false,
    Optional formatRegExp As String = Nothing,
    Optional formatDescr As String = Nothing,
    Optional displayFormat As String = Nothing
)
public:
FieldAttribute(
    JSONDataMap^ valueList,
    String^ targetName = L"*",
    StoreFlag storeFlag = StoreFlag::LoadAndStore,
    bool key = false,
    DataKind kind = DataKind::Text,
    bool required = false,
    bool visible = true,
    Object^ dflt = nullptr,
    Object^ min = nullptr,
    Object^ max = nullptr,
    int minLength = 0,
    int maxLength = 0,
    CharCase charCase = CharCase::AsIs,
    String^ backendName = nullptr,
    String^ backendType = nullptr,
    String^ description = nullptr,
    String^ metadata = nullptr,
    bool nonUI = false,
    String^ formatRegExp = nullptr,
    String^ formatDescr = nullptr,
    String^ displayFormat = nullptr
)
public:
FieldAttribute(
    JSONDataMap^ valueList,
    String^ targetName = L"*",
    StoreFlag storeFlag = StoreFlag::LoadAndStore,
    bool key = false,
    DataKind kind = DataKind::Text,
    bool required = false,
    bool visible = true,
    Object^ dflt = nullptr,
    Object^ min = nullptr,
    Object^ max = nullptr,
    int minLength = 0,
    int maxLength = 0,
    CharCase charCase = CharCase::AsIs,
    String^ backendName = nullptr,
    String^ backendType = nullptr,
    String^ description = nullptr,
    String^ metadata = nullptr,
    bool nonUI = false,
    String^ formatRegExp = nullptr,
    String^ formatDescr = nullptr,
    String^ displayFormat = nullptr
)
new :
        valueList : JSONDataMap *
        ?targetName : string *
        ?storeFlag : StoreFlag *
        ?key : bool *
        ?kind : DataKind *
        ?required : bool *
        ?visible : bool *
        ?dflt : Object *
        ?min : Object *
        ?max : Object *
        ?minLength : int *
        ?maxLength : int *
        ?charCase : CharCase *
        ?backendName : string *
        ?backendType : string *
        ?description : string *
        ?metadata : string *
        ?nonUI : bool *
        ?formatRegExp : string *
        ?formatDescr : string *
        ?displayFormat : string
(* Defaults:
        let _targetName = defaultArg targetName "*"
        let _storeFlag = defaultArg storeFlag StoreFlag.LoadAndStore
        let _key = defaultArg key false
        let _kind = defaultArg kind DataKind.Text
        let _required = defaultArg required false
        let _visible = defaultArg visible true
        let _dflt = defaultArg dflt null
        let _min = defaultArg min null
        let _max = defaultArg max null
        let _minLength = defaultArg minLength 0
        let _maxLength = defaultArg maxLength 0
        let _charCase = defaultArg charCase CharCase.AsIs
        let _backendName = defaultArg backendName null
        let _backendType = defaultArg backendType null
        let _description = defaultArg description null
        let _metadata = defaultArg metadata null
        let _nonUI = defaultArg nonUI false
        let _formatRegExp = defaultArg formatRegExp null
        let _formatDescr = defaultArg formatDescr null
        let _displayFormat = defaultArg displayFormat null
*)
-> FieldAttribute
new :
        valueList : JSONDataMap *
        ?targetName : string *
        ?storeFlag : StoreFlag *
        ?key : bool *
        ?kind : DataKind *
        ?required : bool *
        ?visible : bool *
        ?dflt : Object *
        ?min : Object *
        ?max : Object *
        ?minLength : int *
        ?maxLength : int *
        ?charCase : CharCase *
        ?backendName : string *
        ?backendType : string *
        ?description : string *
        ?metadata : string *
        ?nonUI : bool *
        ?formatRegExp : string *
        ?formatDescr : string *
        ?displayFormat : string
(* Defaults:
        let _targetName = defaultArg targetName "*"
        let _storeFlag = defaultArg storeFlag StoreFlag.LoadAndStore
        let _key = defaultArg key false
        let _kind = defaultArg kind DataKind.Text
        let _required = defaultArg required false
        let _visible = defaultArg visible true
        let _dflt = defaultArg dflt null
        let _min = defaultArg min null
        let _max = defaultArg max null
        let _minLength = defaultArg minLength 0
        let _maxLength = defaultArg maxLength 0
        let _charCase = defaultArg charCase CharCase.AsIs
        let _backendName = defaultArg backendName null
        let _backendType = defaultArg backendType null
        let _description = defaultArg description null
        let _metadata = defaultArg metadata null
        let _nonUI = defaultArg nonUI false
        let _formatRegExp = defaultArg formatRegExp null
        let _formatDescr = defaultArg formatDescr null
        let _displayFormat = defaultArg displayFormat null
*)
-> FieldAttribute

Parameters

valueList
Type: NFX.Serialization.JSON JSONDataMap
targetName (Optional)
Type: Online System String
storeFlag (Optional)
Type: NFX.DataAccess StoreFlag
key (Optional)
Type: Online System Boolean
kind (Optional)
Type: NFX.DataAccess.CRUD DataKind
required (Optional)
Type: Online System Boolean
visible (Optional)
Type: Online System Boolean
dflt (Optional)
Type: Online System Object
min (Optional)
Type: Online System Object
max (Optional)
Type: Online System Object
minLength (Optional)
Type: Online System Int32
maxLength (Optional)
Type: Online System Int32
charCase (Optional)
Type: NFX.DataAccess CharCase
backendName (Optional)
Type: Online System String
backendType (Optional)
Type: Online System String
description (Optional)
Type: Online System String
metadata (Optional)
Type: Online System String
nonUI (Optional)
Type: Online System Boolean
formatRegExp (Optional)
Type: Online System String
formatDescr (Optional)
Type: Online System String
displayFormat (Optional)
Type: Online System String
See Also
FieldAttribute Class
FieldAttribute Members
FieldAttribute Overload
NFX.DataAccess.CRUD Namespace


FieldAttribute Constructor (String, StoreFlag, Boolean, DataKind, Boolean, Boolean, String, Object, Object, Object, Int32, Int32, CharCase, String, String, String, String, Boolean, String, String, String, Boolean)

FieldAttribute Constructor (String, StoreFlag, Boolean, DataKind, Boolean, Boolean, String, Object, Object, Object, Int32, Int32, CharCase, String, String, String, String, Boolean, String, String, String, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FieldAttribute class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldAttribute(
    string targetName = "*",
    StoreFlag storeFlag = StoreFlag.LoadAndStore,
    bool key = false,
    DataKind kind = DataKind.Text,
    bool required = false,
    bool visible = true,
    string valueList = null,
    Object dflt = null,
    Object min = null,
    Object max = null,
    int minLength = 0,
    int maxLength = 0,
    CharCase charCase = CharCase.AsIs,
    string backendName = null,
    string backendType = null,
    string description = null,
    string metadata = null,
    bool nonUI = false,
    string formatRegExp = null,
    string formatDescr = null,
    string displayFormat = null,
    bool isArow = false
)
public FieldAttribute(
    string targetName = "*",
    StoreFlag storeFlag = StoreFlag.LoadAndStore,
    bool key = false,
    DataKind kind = DataKind.Text,
    bool required = false,
    bool visible = true,
    string valueList = null,
    Object dflt = null,
    Object min = null,
    Object max = null,
    int minLength = 0,
    int maxLength = 0,
    CharCase charCase = CharCase.AsIs,
    string backendName = null,
    string backendType = null,
    string description = null,
    string metadata = null,
    bool nonUI = false,
    string formatRegExp = null,
    string formatDescr = null,
    string displayFormat = null,
    bool isArow = false
)
Public Sub New (
    Optional targetName As String = "*",
    Optional storeFlag As StoreFlag = StoreFlag.LoadAndStore,
    Optional key As Boolean = false,
    Optional kind As DataKind = DataKind.Text,
    Optional required As Boolean = false,
    Optional visible As Boolean = true,
    Optional valueList As String = Nothing,
    Optional dflt As Object = Nothing,
    Optional min As Object = Nothing,
    Optional max As Object = Nothing,
    Optional minLength As Integer = 0,
    Optional maxLength As Integer = 0,
    Optional charCase As CharCase = CharCase.AsIs,
    Optional backendName As String = Nothing,
    Optional backendType As String = Nothing,
    Optional description As String = Nothing,
    Optional metadata As String = Nothing,
    Optional nonUI As Boolean = false,
    Optional formatRegExp As String = Nothing,
    Optional formatDescr As String = Nothing,
    Optional displayFormat As String = Nothing,
    Optional isArow As Boolean = false
)
Public Sub New (
    Optional targetName As String = "*",
    Optional storeFlag As StoreFlag = StoreFlag.LoadAndStore,
    Optional key As Boolean = false,
    Optional kind As DataKind = DataKind.Text,
    Optional required As Boolean = false,
    Optional visible As Boolean = true,
    Optional valueList As String = Nothing,
    Optional dflt As Object = Nothing,
    Optional min As Object = Nothing,
    Optional max As Object = Nothing,
    Optional minLength As Integer = 0,
    Optional maxLength As Integer = 0,
    Optional charCase As CharCase = CharCase.AsIs,
    Optional backendName As String = Nothing,
    Optional backendType As String = Nothing,
    Optional description As String = Nothing,
    Optional metadata As String = Nothing,
    Optional nonUI As Boolean = false,
    Optional formatRegExp As String = Nothing,
    Optional formatDescr As String = Nothing,
    Optional displayFormat As String = Nothing,
    Optional isArow As Boolean = false
)
public:
FieldAttribute(
    String^ targetName = L"*",
    StoreFlag storeFlag = StoreFlag::LoadAndStore,
    bool key = false,
    DataKind kind = DataKind::Text,
    bool required = false,
    bool visible = true,
    String^ valueList = nullptr,
    Object^ dflt = nullptr,
    Object^ min = nullptr,
    Object^ max = nullptr,
    int minLength = 0,
    int maxLength = 0,
    CharCase charCase = CharCase::AsIs,
    String^ backendName = nullptr,
    String^ backendType = nullptr,
    String^ description = nullptr,
    String^ metadata = nullptr,
    bool nonUI = false,
    String^ formatRegExp = nullptr,
    String^ formatDescr = nullptr,
    String^ displayFormat = nullptr,
    bool isArow = false
)
public:
FieldAttribute(
    String^ targetName = L"*",
    StoreFlag storeFlag = StoreFlag::LoadAndStore,
    bool key = false,
    DataKind kind = DataKind::Text,
    bool required = false,
    bool visible = true,
    String^ valueList = nullptr,
    Object^ dflt = nullptr,
    Object^ min = nullptr,
    Object^ max = nullptr,
    int minLength = 0,
    int maxLength = 0,
    CharCase charCase = CharCase::AsIs,
    String^ backendName = nullptr,
    String^ backendType = nullptr,
    String^ description = nullptr,
    String^ metadata = nullptr,
    bool nonUI = false,
    String^ formatRegExp = nullptr,
    String^ formatDescr = nullptr,
    String^ displayFormat = nullptr,
    bool isArow = false
)
new :
        ?targetName : string *
        ?storeFlag : StoreFlag *
        ?key : bool *
        ?kind : DataKind *
        ?required : bool *
        ?visible : bool *
        ?valueList : string *
        ?dflt : Object *
        ?min : Object *
        ?max : Object *
        ?minLength : int *
        ?maxLength : int *
        ?charCase : CharCase *
        ?backendName : string *
        ?backendType : string *
        ?description : string *
        ?metadata : string *
        ?nonUI : bool *
        ?formatRegExp : string *
        ?formatDescr : string *
        ?displayFormat : string *
        ?isArow : bool
(* Defaults:
        let _targetName = defaultArg targetName "*"
        let _storeFlag = defaultArg storeFlag StoreFlag.LoadAndStore
        let _key = defaultArg key false
        let _kind = defaultArg kind DataKind.Text
        let _required = defaultArg required false
        let _visible = defaultArg visible true
        let _valueList = defaultArg valueList null
        let _dflt = defaultArg dflt null
        let _min = defaultArg min null
        let _max = defaultArg max null
        let _minLength = defaultArg minLength 0
        let _maxLength = defaultArg maxLength 0
        let _charCase = defaultArg charCase CharCase.AsIs
        let _backendName = defaultArg backendName null
        let _backendType = defaultArg backendType null
        let _description = defaultArg description null
        let _metadata = defaultArg metadata null
        let _nonUI = defaultArg nonUI false
        let _formatRegExp = defaultArg formatRegExp null
        let _formatDescr = defaultArg formatDescr null
        let _displayFormat = defaultArg displayFormat null
        let _isArow = defaultArg isArow false
*)
-> FieldAttribute
new :
        ?targetName : string *
        ?storeFlag : StoreFlag *
        ?key : bool *
        ?kind : DataKind *
        ?required : bool *
        ?visible : bool *
        ?valueList : string *
        ?dflt : Object *
        ?min : Object *
        ?max : Object *
        ?minLength : int *
        ?maxLength : int *
        ?charCase : CharCase *
        ?backendName : string *
        ?backendType : string *
        ?description : string *
        ?metadata : string *
        ?nonUI : bool *
        ?formatRegExp : string *
        ?formatDescr : string *
        ?displayFormat : string *
        ?isArow : bool
(* Defaults:
        let _targetName = defaultArg targetName "*"
        let _storeFlag = defaultArg storeFlag StoreFlag.LoadAndStore
        let _key = defaultArg key false
        let _kind = defaultArg kind DataKind.Text
        let _required = defaultArg required false
        let _visible = defaultArg visible true
        let _valueList = defaultArg valueList null
        let _dflt = defaultArg dflt null
        let _min = defaultArg min null
        let _max = defaultArg max null
        let _minLength = defaultArg minLength 0
        let _maxLength = defaultArg maxLength 0
        let _charCase = defaultArg charCase CharCase.AsIs
        let _backendName = defaultArg backendName null
        let _backendType = defaultArg backendType null
        let _description = defaultArg description null
        let _metadata = defaultArg metadata null
        let _nonUI = defaultArg nonUI false
        let _formatRegExp = defaultArg formatRegExp null
        let _formatDescr = defaultArg formatDescr null
        let _displayFormat = defaultArg displayFormat null
        let _isArow = defaultArg isArow false
*)
-> FieldAttribute

Parameters

targetName (Optional)
Type: Online System String
storeFlag (Optional)
Type: NFX.DataAccess StoreFlag
key (Optional)
Type: Online System Boolean
kind (Optional)
Type: NFX.DataAccess.CRUD DataKind
required (Optional)
Type: Online System Boolean
visible (Optional)
Type: Online System Boolean
valueList (Optional)
Type: Online System String
dflt (Optional)
Type: Online System Object
min (Optional)
Type: Online System Object
max (Optional)
Type: Online System Object
minLength (Optional)
Type: Online System Int32
maxLength (Optional)
Type: Online System Int32
charCase (Optional)
Type: NFX.DataAccess CharCase
backendName (Optional)
Type: Online System String
backendType (Optional)
Type: Online System String
description (Optional)
Type: Online System String
metadata (Optional)
Type: Online System String
nonUI (Optional)
Type: Online System Boolean
formatRegExp (Optional)
Type: Online System String
formatDescr (Optional)
Type: Online System String
displayFormat (Optional)
Type: Online System String
isArow (Optional)
Type: Online System Boolean
See Also
FieldAttribute Class
FieldAttribute Members
FieldAttribute Overload
NFX.DataAccess.CRUD Namespace


FieldAttribute Constructor (Type, String, String, Object, Object, Object, Object, Object, String, Object, Object, Object, Object, Object, Object, String, String, String, String, Object, String, String, String, Object)

FieldAttribute Constructor (Type, String, String, Object, Object, Object, Object, Object, String, Object, Object, Object, Object, Object, Object, String, String, String, String, Object, String, String, String, Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FieldAttribute class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldAttribute(
    Type protoType,
    string protoFieldName,
    string targetName = "*",
    Object storeFlag = null,
    Object key = null,
    Object kind = null,
    Object required = null,
    Object visible = null,
    string valueList = null,
    Object dflt = null,
    Object min = null,
    Object max = null,
    Object minLength = null,
    Object maxLength = null,
    Object charCase = null,
    string backendName = null,
    string backendType = null,
    string description = null,
    string metadata = null,
    Object nonUI = null,
    string formatRegExp = null,
    string formatDescr = null,
    string displayFormat = null,
    Object isArow = null
)
public FieldAttribute(
    Type protoType,
    string protoFieldName,
    string targetName = "*",
    Object storeFlag = null,
    Object key = null,
    Object kind = null,
    Object required = null,
    Object visible = null,
    string valueList = null,
    Object dflt = null,
    Object min = null,
    Object max = null,
    Object minLength = null,
    Object maxLength = null,
    Object charCase = null,
    string backendName = null,
    string backendType = null,
    string description = null,
    string metadata = null,
    Object nonUI = null,
    string formatRegExp = null,
    string formatDescr = null,
    string displayFormat = null,
    Object isArow = null
)
Public Sub New (
    protoType As Type,
    protoFieldName As String,
    Optional targetName As String = "*",
    Optional storeFlag As Object = Nothing,
    Optional key As Object = Nothing,
    Optional kind As Object = Nothing,
    Optional required As Object = Nothing,
    Optional visible As Object = Nothing,
    Optional valueList As String = Nothing,
    Optional dflt As Object = Nothing,
    Optional min As Object = Nothing,
    Optional max As Object = Nothing,
    Optional minLength As Object = Nothing,
    Optional maxLength As Object = Nothing,
    Optional charCase As Object = Nothing,
    Optional backendName As String = Nothing,
    Optional backendType As String = Nothing,
    Optional description As String = Nothing,
    Optional metadata As String = Nothing,
    Optional nonUI As Object = Nothing,
    Optional formatRegExp As String = Nothing,
    Optional formatDescr As String = Nothing,
    Optional displayFormat As String = Nothing,
    Optional isArow As Object = Nothing
)
Public Sub New (
    protoType As Type,
    protoFieldName As String,
    Optional targetName As String = "*",
    Optional storeFlag As Object = Nothing,
    Optional key As Object = Nothing,
    Optional kind As Object = Nothing,
    Optional required As Object = Nothing,
    Optional visible As Object = Nothing,
    Optional valueList As String = Nothing,
    Optional dflt As Object = Nothing,
    Optional min As Object = Nothing,
    Optional max As Object = Nothing,
    Optional minLength As Object = Nothing,
    Optional maxLength As Object = Nothing,
    Optional charCase As Object = Nothing,
    Optional backendName As String = Nothing,
    Optional backendType As String = Nothing,
    Optional description As String = Nothing,
    Optional metadata As String = Nothing,
    Optional nonUI As Object = Nothing,
    Optional formatRegExp As String = Nothing,
    Optional formatDescr As String = Nothing,
    Optional displayFormat As String = Nothing,
    Optional isArow As Object = Nothing
)
public:
FieldAttribute(
    Type^ protoType,
    String^ protoFieldName,
    String^ targetName = L"*",
    Object^ storeFlag = nullptr,
    Object^ key = nullptr,
    Object^ kind = nullptr,
    Object^ required = nullptr,
    Object^ visible = nullptr,
    String^ valueList = nullptr,
    Object^ dflt = nullptr,
    Object^ min = nullptr,
    Object^ max = nullptr,
    Object^ minLength = nullptr,
    Object^ maxLength = nullptr,
    Object^ charCase = nullptr,
    String^ backendName = nullptr,
    String^ backendType = nullptr,
    String^ description = nullptr,
    String^ metadata = nullptr,
    Object^ nonUI = nullptr,
    String^ formatRegExp = nullptr,
    String^ formatDescr = nullptr,
    String^ displayFormat = nullptr,
    Object^ isArow = nullptr
)
public:
FieldAttribute(
    Type^ protoType,
    String^ protoFieldName,
    String^ targetName = L"*",
    Object^ storeFlag = nullptr,
    Object^ key = nullptr,
    Object^ kind = nullptr,
    Object^ required = nullptr,
    Object^ visible = nullptr,
    String^ valueList = nullptr,
    Object^ dflt = nullptr,
    Object^ min = nullptr,
    Object^ max = nullptr,
    Object^ minLength = nullptr,
    Object^ maxLength = nullptr,
    Object^ charCase = nullptr,
    String^ backendName = nullptr,
    String^ backendType = nullptr,
    String^ description = nullptr,
    String^ metadata = nullptr,
    Object^ nonUI = nullptr,
    String^ formatRegExp = nullptr,
    String^ formatDescr = nullptr,
    String^ displayFormat = nullptr,
    Object^ isArow = nullptr
)
new :
        protoType : Type *
        protoFieldName : string *
        ?targetName : string *
        ?storeFlag : Object *
        ?key : Object *
        ?kind : Object *
        ?required : Object *
        ?visible : Object *
        ?valueList : string *
        ?dflt : Object *
        ?min : Object *
        ?max : Object *
        ?minLength : Object *
        ?maxLength : Object *
        ?charCase : Object *
        ?backendName : string *
        ?backendType : string *
        ?description : string *
        ?metadata : string *
        ?nonUI : Object *
        ?formatRegExp : string *
        ?formatDescr : string *
        ?displayFormat : string *
        ?isArow : Object
(* Defaults:
        let _targetName = defaultArg targetName "*"
        let _storeFlag = defaultArg storeFlag null
        let _key = defaultArg key null
        let _kind = defaultArg kind null
        let _required = defaultArg required null
        let _visible = defaultArg visible null
        let _valueList = defaultArg valueList null
        let _dflt = defaultArg dflt null
        let _min = defaultArg min null
        let _max = defaultArg max null
        let _minLength = defaultArg minLength null
        let _maxLength = defaultArg maxLength null
        let _charCase = defaultArg charCase null
        let _backendName = defaultArg backendName null
        let _backendType = defaultArg backendType null
        let _description = defaultArg description null
        let _metadata = defaultArg metadata null
        let _nonUI = defaultArg nonUI null
        let _formatRegExp = defaultArg formatRegExp null
        let _formatDescr = defaultArg formatDescr null
        let _displayFormat = defaultArg displayFormat null
        let _isArow = defaultArg isArow null
*)
-> FieldAttribute
new :
        protoType : Type *
        protoFieldName : string *
        ?targetName : string *
        ?storeFlag : Object *
        ?key : Object *
        ?kind : Object *
        ?required : Object *
        ?visible : Object *
        ?valueList : string *
        ?dflt : Object *
        ?min : Object *
        ?max : Object *
        ?minLength : Object *
        ?maxLength : Object *
        ?charCase : Object *
        ?backendName : string *
        ?backendType : string *
        ?description : string *
        ?metadata : string *
        ?nonUI : Object *
        ?formatRegExp : string *
        ?formatDescr : string *
        ?displayFormat : string *
        ?isArow : Object
(* Defaults:
        let _targetName = defaultArg targetName "*"
        let _storeFlag = defaultArg storeFlag null
        let _key = defaultArg key null
        let _kind = defaultArg kind null
        let _required = defaultArg required null
        let _visible = defaultArg visible null
        let _valueList = defaultArg valueList null
        let _dflt = defaultArg dflt null
        let _min = defaultArg min null
        let _max = defaultArg max null
        let _minLength = defaultArg minLength null
        let _maxLength = defaultArg maxLength null
        let _charCase = defaultArg charCase null
        let _backendName = defaultArg backendName null
        let _backendType = defaultArg backendType null
        let _description = defaultArg description null
        let _metadata = defaultArg metadata null
        let _nonUI = defaultArg nonUI null
        let _formatRegExp = defaultArg formatRegExp null
        let _formatDescr = defaultArg formatDescr null
        let _displayFormat = defaultArg displayFormat null
        let _isArow = defaultArg isArow null
*)
-> FieldAttribute

Parameters

protoType
Type: Online System Type
protoFieldName
Type: Online System String
targetName (Optional)
Type: Online System String
storeFlag (Optional)
Type: Online System Object
key (Optional)
Type: Online System Object
kind (Optional)
Type: Online System Object
required (Optional)
Type: Online System Object
visible (Optional)
Type: Online System Object
valueList (Optional)
Type: Online System String
dflt (Optional)
Type: Online System Object
min (Optional)
Type: Online System Object
max (Optional)
Type: Online System Object
minLength (Optional)
Type: Online System Object
maxLength (Optional)
Type: Online System Object
charCase (Optional)
Type: Online System Object
backendName (Optional)
Type: Online System String
backendType (Optional)
Type: Online System String
description (Optional)
Type: Online System String
metadata (Optional)
Type: Online System String
nonUI (Optional)
Type: Online System Object
formatRegExp (Optional)
Type: Online System String
formatDescr (Optional)
Type: Online System String
displayFormat (Optional)
Type: Online System String
isArow (Optional)
Type: Online System Object
See Also
FieldAttribute Class
FieldAttribute Members
FieldAttribute Overload
NFX.DataAccess.CRUD Namespace


FieldAttribute Fields

FieldAttribute Fields NFX Class Library

The FieldAttribute type exposes the following members.
Fields
 | Name | Description
Public field | BackendName | Provides an overriden name for this field
Public field | BackendType | Provides an overriden type for this field in backend, i.e. CLR string may be stored as ErlPid in erlang
Public field | CharCase | Controls character casing of textual fields
Public field | CloneFromRowType | When set, points to a Typed-Row derivative that is used as a full clone
Public field | Default | Provides default value
Public field | Description | Provides description
Public field | DisplayFormat | Display format string or null
Public field | FormatDescription | Description for regular expression used for field format validation if set
Public field | FormatRegExp | Regular expression used for field format validation if set
Public field | IsArow | True if this field definition is used by Arow serializer
Public field | Key | Determines whether this field is a part of the primary key
Public field | Kind | Provides hint/classification for textual field data
Protected field | m_MetadataContent | (Inherited from TargetedAttribute.)
Public field | Max | Provides high-bound validation check
Public field | MaxLength | Imposes a limit on maximum amount of characters in a textual field
Public field | Min | Provides low-bound validation check
Public field | MinLength | Imposes a limit on minimum amount of characters in a textual field
Public field | NonUI | If true indicates that this field is ignored when generating UI and ignored when UI supplies the value to the server. Pass true to protect server-only structures from being modified by client
Public field | Required | Determines whether the field must have data
Public field | StoreFlag | Determines whether field should be loaded/stored from/to storage
Public field | TargetName | Returns the name of target, i.e. the name of database engine i.e. "ORACLE11g" or "MySQL" (Inherited from TargetedAttribute.)
Public field | ValueList | Returns a ";/,/|"-delimited list of permitted field values - used for lookup validation
Public field | Visible | Determines whether the field is shown to user (i.e. as a grid column)
Back to Top
See Also
FieldAttribute Class
NFX.DataAccess.CRUD Namespace


FieldAttribute.BackendName Field

FieldAttribute BackendName Field NFX Class Library

Provides an overriden name for this field

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string BackendName
public readonly string BackendName
Public ReadOnly BackendName As String
Public ReadOnly BackendName As String
public:
initonly String^ BackendName
public:
initonly String^ BackendName
val BackendName: string
val BackendName: string

Field Value

Type: Online String
See Also
FieldAttribute Class
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldAttribute.BackendType Field

FieldAttribute BackendType Field NFX Class Library

Provides an overriden type for this field in backend, i.e. CLR string may be stored as ErlPid in erlang

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string BackendType
public readonly string BackendType
Public ReadOnly BackendType As String
Public ReadOnly BackendType As String
public:
initonly String^ BackendType
public:
initonly String^ BackendType
val BackendType: string
val BackendType: string

Field Value

Type: Online String
See Also
FieldAttribute Class
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldAttribute.CharCase Field

FieldAttribute CharCase Field NFX Class Library

Controls character casing of textual fields

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly CharCase CharCase
public readonly CharCase CharCase
Public ReadOnly CharCase As CharCase
Public ReadOnly CharCase As CharCase
public:
initonly CharCase CharCase
public:
initonly CharCase CharCase
val CharCase: CharCase
val CharCase: CharCase

Field Value

Type: CharCase
See Also
FieldAttribute Class
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldAttribute.CloneFromRowType Field

FieldAttribute CloneFromRowType Field NFX Class Library

When set, points to a Typed-Row derivative that is used as a full clone

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Type CloneFromRowType
public readonly Type CloneFromRowType
Public ReadOnly CloneFromRowType As Type
Public ReadOnly CloneFromRowType As Type
public:
initonly Type^ CloneFromRowType
public:
initonly Type^ CloneFromRowType
val CloneFromRowType: Type
val CloneFromRowType: Type

Field Value

Type: Online Type
See Also
FieldAttribute Class
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldAttribute.Default Field

FieldAttribute Default Field NFX Class Library

Provides default value

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Object Default
public readonly Object Default
Public ReadOnly Default As Object
Public ReadOnly Default As Object
public:
initonly Object^ Default
public:
initonly Object^ Default
val Default: Object
val Default: Object

Field Value

Type: Online Object
See Also
FieldAttribute Class
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldAttribute.Description Field

FieldAttribute Description Field NFX Class Library

Provides description

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Description
public readonly string Description
Public ReadOnly Description As String
Public ReadOnly Description As String
public:
initonly String^ Description
public:
initonly String^ Description
val Description: string
val Description: string

Field Value

Type: Online String
See Also
FieldAttribute Class
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldAttribute.DisplayFormat Field

FieldAttribute DisplayFormat Field NFX Class Library

Display format string or null

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string DisplayFormat
public readonly string DisplayFormat
Public ReadOnly DisplayFormat As String
Public ReadOnly DisplayFormat As String
public:
initonly String^ DisplayFormat
public:
initonly String^ DisplayFormat
val DisplayFormat: string
val DisplayFormat: string

Field Value

Type: Online String
See Also
FieldAttribute Class
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldAttribute.FormatDescription Field

FieldAttribute FormatDescription Field NFX Class Library

Description for regular expression used for field format validation if set

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string FormatDescription
public readonly string FormatDescription
Public ReadOnly FormatDescription As String
Public ReadOnly FormatDescription As String
public:
initonly String^ FormatDescription
public:
initonly String^ FormatDescription
val FormatDescription: string
val FormatDescription: string

Field Value

Type: Online String
See Also
FieldAttribute Class
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldAttribute.FormatRegExp Field

FieldAttribute FormatRegExp Field NFX Class Library

Regular expression used for field format validation if set

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string FormatRegExp
public readonly string FormatRegExp
Public ReadOnly FormatRegExp As String
Public ReadOnly FormatRegExp As String
public:
initonly String^ FormatRegExp
public:
initonly String^ FormatRegExp
val FormatRegExp: string
val FormatRegExp: string

Field Value

Type: Online String
See Also
FieldAttribute Class
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldAttribute.IsArow Field

FieldAttribute IsArow Field NFX Class Library

True if this field definition is used by Arow serializer

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool IsArow
public readonly bool IsArow
Public ReadOnly IsArow As Boolean
Public ReadOnly IsArow As Boolean
public:
initonly bool IsArow
public:
initonly bool IsArow
val IsArow: bool
val IsArow: bool

Field Value

Type: Online Boolean
See Also
FieldAttribute Class
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldAttribute.Key Field

FieldAttribute Key Field NFX Class Library

Determines whether this field is a part of the primary key

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool Key
public readonly bool Key
Public ReadOnly Key As Boolean
Public ReadOnly Key As Boolean
public:
initonly bool Key
public:
initonly bool Key
val Key: bool
val Key: bool

Field Value

Type: Online Boolean
See Also
FieldAttribute Class
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldAttribute.Kind Field

FieldAttribute Kind Field NFX Class Library

Provides hint/classification for textual field data

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly DataKind Kind
public readonly DataKind Kind
Public ReadOnly Kind As DataKind
Public ReadOnly Kind As DataKind
public:
initonly DataKind Kind
public:
initonly DataKind Kind
val Kind: DataKind
val Kind: DataKind

Field Value

Type: DataKind
See Also
FieldAttribute Class
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldAttribute.Max Field

FieldAttribute Max Field NFX Class Library

Provides high-bound validation check

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Object Max
public readonly Object Max
Public ReadOnly Max As Object
Public ReadOnly Max As Object
public:
initonly Object^ Max
public:
initonly Object^ Max
val Max: Object
val Max: Object

Field Value

Type: Online Object
See Also
FieldAttribute Class
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldAttribute.MaxLength Field

FieldAttribute MaxLength Field NFX Class Library

Imposes a limit on maximum amount of characters in a textual field

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int MaxLength
public readonly int MaxLength
Public ReadOnly MaxLength As Integer
Public ReadOnly MaxLength As Integer
public:
initonly int MaxLength
public:
initonly int MaxLength
val MaxLength: int
val MaxLength: int

Field Value

Type: Online Int32
See Also
FieldAttribute Class
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldAttribute.Min Field

FieldAttribute Min Field NFX Class Library

Provides low-bound validation check

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Object Min
public readonly Object Min
Public ReadOnly Min As Object
Public ReadOnly Min As Object
public:
initonly Object^ Min
public:
initonly Object^ Min
val Min: Object
val Min: Object

Field Value

Type: Online Object
See Also
FieldAttribute Class
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldAttribute.MinLength Field

FieldAttribute MinLength Field NFX Class Library

Imposes a limit on minimum amount of characters in a textual field

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int MinLength
public readonly int MinLength
Public ReadOnly MinLength As Integer
Public ReadOnly MinLength As Integer
public:
initonly int MinLength
public:
initonly int MinLength
val MinLength: int
val MinLength: int

Field Value

Type: Online Int32
See Also
FieldAttribute Class
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldAttribute.NonUI Field

FieldAttribute NonUI Field NFX Class Library

If true indicates that this field is ignored when generating UI and ignored when UI supplies the value to the server. Pass true to protect server-only structures from being modified by client

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool NonUI
public readonly bool NonUI
Public ReadOnly NonUI As Boolean
Public ReadOnly NonUI As Boolean
public:
initonly bool NonUI
public:
initonly bool NonUI
val NonUI: bool
val NonUI: bool

Field Value

Type: Online Boolean
See Also
FieldAttribute Class
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldAttribute.Required Field

FieldAttribute Required Field NFX Class Library

Determines whether the field must have data

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool Required
public readonly bool Required
Public ReadOnly Required As Boolean
Public ReadOnly Required As Boolean
public:
initonly bool Required
public:
initonly bool Required
val Required: bool
val Required: bool

Field Value

Type: Online Boolean
See Also
FieldAttribute Class
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldAttribute.StoreFlag Field

FieldAttribute StoreFlag Field NFX Class Library

Determines whether field should be loaded/stored from/to storage

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly StoreFlag StoreFlag
public readonly StoreFlag StoreFlag
Public ReadOnly StoreFlag As StoreFlag
Public ReadOnly StoreFlag As StoreFlag
public:
initonly StoreFlag StoreFlag
public:
initonly StoreFlag StoreFlag
val StoreFlag: StoreFlag
val StoreFlag: StoreFlag

Field Value

Type: StoreFlag
See Also
FieldAttribute Class
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldAttribute.ValueList Field

FieldAttribute ValueList Field NFX Class Library

Returns a ";/,/|"-delimited list of permitted field values - used for lookup validation

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string ValueList
public readonly string ValueList
Public ReadOnly ValueList As String
Public ReadOnly ValueList As String
public:
initonly String^ ValueList
public:
initonly String^ ValueList
val ValueList: string
val ValueList: string

Field Value

Type: Online String
See Also
FieldAttribute Class
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldAttribute.Visible Field

FieldAttribute Visible Field NFX Class Library

Determines whether the field is shown to user (i.e. as a grid column)

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool Visible
public readonly bool Visible
Public ReadOnly Visible As Boolean
Public ReadOnly Visible As Boolean
public:
initonly bool Visible
public:
initonly bool Visible
val Visible: bool
val Visible: bool

Field Value

Type: Online Boolean
See Also
FieldAttribute Class
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldAttribute Methods

FieldAttribute Methods NFX Class Library

The FieldAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online Attribute Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Attribute GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ParseValueList | Returns a ValueList parsed into key values as: val1: descr1,val2: desc2...
 | ParseValueListString | Returns a string parsed into key values as: val1: descr1,val2: desc2...
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
FieldAttribute Class
NFX.DataAccess.CRUD Namespace


FieldAttribute.Equals Method

FieldAttribute Equals Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
FieldAttribute Class
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldAttribute.GetHashCode Method

FieldAttribute GetHashCode Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
FieldAttribute Class
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldAttribute.ParseValueList Method

FieldAttribute ParseValueList Method NFX Class Library

Returns a ValueList parsed into key values as: val1: descr1,val2: desc2...

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDataMap ParseValueList(
    bool caseSensitiveKeys = false
)
public JSONDataMap ParseValueList(
    bool caseSensitiveKeys = false
)
Public Function ParseValueList (
    Optional caseSensitiveKeys As Boolean = false
) As JSONDataMap
Public Function ParseValueList (
    Optional caseSensitiveKeys As Boolean = false
) As JSONDataMap
public:
JSONDataMap^ ParseValueList(
    bool caseSensitiveKeys = false
)
public:
JSONDataMap^ ParseValueList(
    bool caseSensitiveKeys = false
)
member ParseValueList :
        ?caseSensitiveKeys : bool
(* Defaults:
        let _caseSensitiveKeys = defaultArg caseSensitiveKeys false
*)
-> JSONDataMap
member ParseValueList :
        ?caseSensitiveKeys : bool
(* Defaults:
        let _caseSensitiveKeys = defaultArg caseSensitiveKeys false
*)
-> JSONDataMap

Parameters

caseSensitiveKeys (Optional)
Type: Online System Boolean

Return Value

Type: JSONDataMap
See Also
FieldAttribute Class
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldAttribute.ParseValueListString Method

FieldAttribute ParseValueListString Method NFX Class Library

Returns a string parsed into key values as: val1: descr1,val2: desc2...

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static JSONDataMap ParseValueListString(
    string valueList,
    bool caseSensitiveKeys = false
)
public static JSONDataMap ParseValueListString(
    string valueList,
    bool caseSensitiveKeys = false
)
Public Shared Function ParseValueListString (
    valueList As String,
    Optional caseSensitiveKeys As Boolean = false
) As JSONDataMap
Public Shared Function ParseValueListString (
    valueList As String,
    Optional caseSensitiveKeys As Boolean = false
) As JSONDataMap
public:
static JSONDataMap^ ParseValueListString(
    String^ valueList,
    bool caseSensitiveKeys = false
)
public:
static JSONDataMap^ ParseValueListString(
    String^ valueList,
    bool caseSensitiveKeys = false
)
static member ParseValueListString :
        valueList : string *
        ?caseSensitiveKeys : bool
(* Defaults:
        let _caseSensitiveKeys = defaultArg caseSensitiveKeys false
*)
-> JSONDataMap
static member ParseValueListString :
        valueList : string *
        ?caseSensitiveKeys : bool
(* Defaults:
        let _caseSensitiveKeys = defaultArg caseSensitiveKeys false
*)
-> JSONDataMap

Parameters

valueList
Type: Online System String
caseSensitiveKeys (Optional)
Type: Online System Boolean

Return Value

Type: JSONDataMap
See Also
FieldAttribute Class
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldAttribute Properties

FieldAttribute Properties NFX Class Library

The FieldAttribute type exposes the following members.
Properties
 | Name | Description
Public property | HasValueList | Returns true if the value list is set or internal JSONDataMap is set
Public property | Metadata | Returns structured metadata or null if there is no metadata defined (Inherited from TargetedAttribute.)
Public property | MetadataContent | Returns metadata content string in Laconic format or null. Root not is not specified. I.e.: 'a=1 b=true c{...}' (Inherited from TargetedAttribute.)
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
FieldAttribute Class
NFX.DataAccess.CRUD Namespace


FieldAttribute.HasValueList Property

FieldAttribute HasValueList Property NFX Class Library

Returns true if the value list is set or internal JSONDataMap is set

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasValueList { get; }
public bool HasValueList { get; }
Public ReadOnly Property HasValueList As Boolean
    Get
Public ReadOnly Property HasValueList As Boolean
    Get
public:
property bool HasValueList {
    bool get ();
}
public:
property bool HasValueList {
    bool get ();
}
member HasValueList : bool with get
member HasValueList : bool with get

Property Value

Type: Online Boolean
See Also
FieldAttribute Class
FieldAttribute Members
NFX.DataAccess.CRUD Namespace


FieldFilterFunc Delegate

FieldFilterFunc Delegate NFX Class Library

Provides filter predicate for CRUD operations. Return true to include the specified field

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate bool FieldFilterFunc(
    Row row,
    IDataStoreKey key,
    Schema..::..FieldDef fdef
)
public delegate bool FieldFilterFunc(
    Row row,
    IDataStoreKey key,
    Schema..::..FieldDef fdef
)
Public Delegate Function FieldFilterFunc (
    row As Row,
    key As IDataStoreKey,
    fdef As Schema..::..FieldDef
) As Boolean
Public Delegate Function FieldFilterFunc (
    row As Row,
    key As IDataStoreKey,
    fdef As Schema..::..FieldDef
) As Boolean
public delegate bool FieldFilterFunc(
    Row^ row,
    IDataStoreKey^ key,
    Schema..::..FieldDef^ fdef
)
public delegate bool FieldFilterFunc(
    Row^ row,
    IDataStoreKey^ key,
    Schema..::..FieldDef^ fdef
)
type FieldFilterFunc =
    delegate of
        row : Row *
        key : IDataStoreKey *
        fdef : Schema..::..FieldDef -> bool
type FieldFilterFunc =
    delegate of
        row : Row *
        key : IDataStoreKey *
        fdef : Schema..::..FieldDef -> bool

Parameters

row
Type: NFX.DataAccess.CRUD Row
Row instance that filetring is performed on
key
Type: NFX.DataAccess IDataStoreKey
If not null, the override key passed to Update() (if any)
fdef
Type: NFX.DataAccess.CRUD Schema FieldDef
A field that filtering is done for

Return Value

Type: Online Boolean
See Also
NFX.DataAccess.CRUD Namespace


FormMode Enumeration

FormMode Enumeration NFX Class Library

Denotes form modes: unspecified | insert | edit

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum FormMode
public enum FormMode
Public Enumeration FormMode
Public Enumeration FormMode
public enum class FormMode
public enum class FormMode
type FormMode
type FormMode
Members
Member name | Value | Description
Unspecified | 0 |
Insert | 1 |
Edit | 2 |
See Also
NFX.DataAccess.CRUD Namespace


FormModel Class

FormModel Class NFX Class Library

Represents a "model" (in MVC terms) of a data-entry form. Form models are statically typed - contain fields and can contain "extra amorphous" data
Inheritance Hierarchy
Online System Object
NFX.DataAccess.CRUD Row
NFX.DataAccess.CRUD TypedRow
NFX.DataAccess.CRUD AmorphousTypedRow
NFX.DataAccess.CRUD FormModel

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class FormModel : AmorphousTypedRow
[SerializableAttribute]
public abstract class FormModel : AmorphousTypedRow
<SerializableAttribute>
Public MustInherit Class FormModel
    Inherits AmorphousTypedRow
<SerializableAttribute>
Public MustInherit Class FormModel
    Inherits AmorphousTypedRow
[SerializableAttribute]
public ref class FormModel abstract : public AmorphousTypedRow
[SerializableAttribute]
public ref class FormModel abstract : public AmorphousTypedRow
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type FormModel =
    class
        inherit AmorphousTypedRow
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type FormModel =
    class
        inherit AmorphousTypedRow
    end
See Also
FormModel Members
NFX.DataAccess.CRUD Namespace


FormModel Members

FormModel Members NFX Class Library

The FormModel type exposes the following members.
Constructors
 | Name | Description
Protected method | FormModel | Initializes a new instance of the FormModel class
Back to Top
Methods
 | Name | Description
Public method | AfterLoad | Invoked to allow the row to hydrate its fields/state from AmorphousData bag. For example, this may be used to reconstruct some temporary object state that is not stored as a part of established business schema. The operation is performed per particular targetName (name of physical backend). Simply put, this method allows business code to "specify what to do after object gets loaded from THE PARTICULAR TARGET backend store". An example: suppose current MongoDB collection stores 3 fields for name, and we want to collapse First/Last/Middle name fields into one field. If we change rowschema then it will only contain 1 field which is not present in the database, however those 'older' fields will get populated into AmorphousData giving us an option to merge older 3 fields into 1 within AfterLoad() implementation (Inherited from AmorphousTypedRow.)
Public method | ApplyDefaultFieldValues | Writes default values specified in schema into fields. Pass overwrite=true to force defaults over non-null existing values (false by default) (Inherited from Row.)
Public method | BeforeSave | Invoked to allow the row to transform its state into AmorphousData bag. For example, this may be usefull to store extra data that is not a part of established business schema. The operation is performed per particular targetName (name of physical backend). Simply put, this method allows business code to "specify what to do before object gets saved in THE PARTICULAR TARGET backend store" (Inherited from AmorphousTypedRow.)
Protected method | CheckMinMax | (Inherited from Row.)
Public method | Configure | In base class applies Config attribute. Useful for typed rows (Inherited from Row.)
Public method | ConvertFieldValueToDef | Converts field value to the type specified by Schema.FieldDef. For example converts GDID->ulong or ulong->GDID. This method can be overridden to perform custom handling of types, for example one can assign bool field as "Si" that would convert to TRUE. This method is called by SetFieldValue(...) before assigning actual field buffer (Inherited from Row.)
Public method | CopyFields | Copies fields from this row into another row/form. Note: this is shallow copy, as field values for complex types are just copied over (Inherited from Row.)
Protected method | DoSave | Override to save model into data store. Return "predictable" exception (such as key violation) as a value instead of throwing. Throw only in "un-predictable" cases (such as DB connection is down, not enough space etc...). Return extra result obtained during save i.e. a db-assigned auto-inc field
Public method | Equals(Object) | Object override - sealed. Override Equals(row) instead (Inherited from Row.)
Public method | Equals(Row) | Override to perform custom row equality comparison. Default implementation equates rows using their key fields (Inherited from Row.)
Protected method | FilterJSONSerializerField | Override to filter-out some fields from serialization to JSON, or change field values. Return name null to indicate that field should be filtered-out(excluded from serialization to JSON) (Inherited from Row.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetClientFieldDef | Override to perform dynamic substitute of field def for the specified field. This method is used by client ui/scaffolding to extract dynamic definition for a field (i.e. field description, requirement, value list etc.) as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original field def, you can return a substituted field def per particular business logic (Inherited from Row.)
Public method | GetClientFieldValue | Override to perform dynamic substitute of field value for the specified field. This method is used by client ui/scaffolding to extract field values for a field as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original GetFieldValue(fdef), you can return a substituted field value per particular business logic (Inherited from Row.)
Public method | GetClientFieldValueList | Override to perform dynamic lookup of field value list for the specified field. This method is used by client ui/scaffolding to extract dynamic lookup values as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. This is a simplified version of GetClientFieldDef (Inherited from Row.)
Public method | GetDataStoreKey | Returns values for fields that represent row's primary key (Inherited from Row.)
Public method | GetDisplayFieldValue(Int32, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute (Inherited from Row.)
Public method | GetDisplayFieldValue(String, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute (Inherited from Row.)
Public method | GetEnumerator | (Inherited from Row.)
Public method | GetFieldValue | (Inherited from TypedRow.)
Public method | GetFieldValueDescription(Int32, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema (Inherited from Row.)
Public method | GetFieldValueDescription(String, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema (Inherited from Row.)
Public method | GetHashCode | Object override - gets hash code from key fields (Inherited from Row.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PersistConfiguration | The base class does not implement this method. Override to persist row fields into config node (Inherited from Row.)
Public method | Save(Object ) | Saves form into data store. The form is validated first and validation error is returned which indicates that save did not succeed due to validation error/s. The core implementation is in DoSave() that can also abort by either returning execption when predictable failure happens on save (i.e. key violation). Other exceptions are thrown. Returns extra result obtained during save i.e. a db-assigned auto-inc field
Public method | Save TSaveResult (TSaveResult ) | Saves form into data store. The form is validated first and validation error is returned which indicates that save did not succeed due to validation error/s. The core implementation is in DoSave() that can also abort by either returning execption when predictable failure happens on save (i.e. key violation). Other exceptions are thrown. Returns extra result obtained during save i.e. a db-assigned auto-inc field
Public method | SetFieldValue | (Inherited from TypedRow.)
Public method | SetRoundtripBagFromJSONString | If non null or empty parses JSON content and sets the RoundtripBag
Public method | SimpleFilterPredicate | Returns true if this row satisfies simple filter - it contains the supplied filter string. The filter pattern may start or end with "*" char that denotes a wildcard. A wildcard is permitted on both sides of the filter value (Inherited from Row.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Validate | Performs validation of data in the row returning exception object that provides description in cases when validation does not pass. Validation is performed not targeting any particular backend (Inherited from Row.)
Public method | Validate(String) | Validates row using row schema and supplied field definitions. Override to perform custom validations, i.e. TypeRows may directly access properties and write some validation type-safe code The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from Row.)
Public method | ValidateField(String, Schema FieldDef) | Validates row field using Schema.FieldDef settings. This method is invoked by base Validate() implementation. The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from Row.)
Public method | ValidateField(String, String) | Validates row field by name. Shortcut to ValidateField(Schema.FieldDef) (Inherited from Row.)
Public method | WriteAsJSON | Writes row as JSON either as an array or map depending on JSONWritingOptions.RowsAsMap setting. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class (Inherited from Row.)
Back to Top
Extension Methods
Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method ToErlObject Overloaded.
Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(ErlTypeOrder, Boolean) Overloaded.
Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(String, String, Boolean) Overloaded.
Convert Row to a hierarchical term that corresponds to the row's schema. The Erlang term is in the form:
View Colorized Copy to Clipboard Print
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
(Defined by ErlSchemaUtils.)
Public Extension Method ToJSON(JSONWritingOptions) Overloaded.
Serializes object into JSON string
(Defined by JSONExtensions.)
Public Extension Method ToJSON(TextWriter, JSONWritingOptions) Overloaded.
Serializes object into JSON format using provided TextWriter
(Defined by JSONExtensions.)
Public Extension Method ToJSON(Stream, JSONWritingOptions, Encoding) Overloaded.
Serializes object into JSON format using provided stream and optional encoding
(Defined by JSONExtensions.)
Public Extension Method Update
Convert an Erlang hierarchical term representing a schema to a Row.
(Defined by ErlSchemaUtils.)
Back to Top
Fields
 | Name | Description
Public field | CSRFToken | Gets/sets CSRF token
Public field | FormMode | Gets/sets form mode - unspecified|insert|edit. This field may be queried by validate and save, i.e. Validate may perform extra cross checks on Insert - i.e. check whether some other user is already registered with the specified email in this form etc.
 | JSON_CSRF_PROPERTY |
 | JSON_MODE_PROPERTY |
 | JSON_ROUNDTRIP_PROPERTY |
Back to Top
Properties
 | Name | Description
Public property | AmorphousData | Returns data that does not comply with known schema (dynamic data). The field names are NOT case-sensitive (Inherited from AmorphousTypedRow.)
Public property | AmorphousDataEnabled | False by default for forms, safer for web. For example, no injection of un-inteded fields can be done via web form post (Overrides AmorphousTypedRow AmorphousDataEnabled.)
Public property | DataStoreTargetName | Returns the name of data store target obtained from App.DataStore by default. Override to supply a different name. This property is used for validation
Public property | HasRoundtripBag | True if RoundtripBag is allocated
Public property | Item Int32 | Gets/sets field values by positional index(Order) (Inherited from Row.)
Public property | Item String | Gets/sets field values by name (Inherited from Row.)
Public property | RoundtripBag | Returns lazily-allocated RoundtripBag. Use HasRoundtripBag to see if it is allocated not to allocate on get
Public property | Schema | References a schema for a table that this row is a part of (Inherited from TypedRow.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Row.)
Back to Top
See Also
FormModel Class
NFX.DataAccess.CRUD Namespace


FormModel Constructor

FormModel Constructor NFX Class Library

Initializes a new instance of the FormModel class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FormModel()
protected FormModel()
Protected Sub New
Protected Sub New
protected:
FormModel()
protected:
FormModel()
new : unit -> FormModel
new : unit -> FormModel
See Also
FormModel Class
FormModel Members
NFX.DataAccess.CRUD Namespace


FormModel Fields

FormModel Fields NFX Class Library

The FormModel type exposes the following members.
Fields
 | Name | Description
Public field | CSRFToken | Gets/sets CSRF token
Public field | FormMode | Gets/sets form mode - unspecified|insert|edit. This field may be queried by validate and save, i.e. Validate may perform extra cross checks on Insert - i.e. check whether some other user is already registered with the specified email in this form etc.
 | JSON_CSRF_PROPERTY |
 | JSON_MODE_PROPERTY |
 | JSON_ROUNDTRIP_PROPERTY |
Back to Top
See Also
FormModel Class
NFX.DataAccess.CRUD Namespace


FormModel.CSRFToken Field

FormModel CSRFToken Field NFX Class Library

Gets/sets CSRF token

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CSRFToken
public string CSRFToken
Public CSRFToken As String
Public CSRFToken As String
public:
String^ CSRFToken
public:
String^ CSRFToken
val mutable CSRFToken: string
val mutable CSRFToken: string

Field Value

Type: Online String
See Also
FormModel Class
FormModel Members
NFX.DataAccess.CRUD Namespace


FormModel.FormMode Field

FormModel FormMode Field NFX Class Library

Gets/sets form mode - unspecified|insert|edit. This field may be queried by validate and save, i.e. Validate may perform extra cross checks on Insert - i.e. check whether some other user is already registered with the specified email in this form etc.

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FormMode FormMode
public FormMode FormMode
Public FormMode As FormMode
Public FormMode As FormMode
public:
FormMode FormMode
public:
FormMode FormMode
val mutable FormMode: FormMode
val mutable FormMode: FormMode

Field Value

Type: FormMode
See Also
FormModel Class
FormModel Members
NFX.DataAccess.CRUD Namespace


FormModel.JSON_CSRF_PROPERTY Field

FormModel JSON_CSRF_PROPERTY Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string JSON_CSRF_PROPERTY
public const string JSON_CSRF_PROPERTY
Public Const JSON_CSRF_PROPERTY As String
Public Const JSON_CSRF_PROPERTY As String
public:
literal String^ JSON_CSRF_PROPERTY
public:
literal String^ JSON_CSRF_PROPERTY
static val mutable JSON_CSRF_PROPERTY: string
static val mutable JSON_CSRF_PROPERTY: string

Field Value

Type: Online String
See Also
FormModel Class
FormModel Members
NFX.DataAccess.CRUD Namespace


FormModel.JSON_MODE_PROPERTY Field

FormModel JSON_MODE_PROPERTY Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string JSON_MODE_PROPERTY
public const string JSON_MODE_PROPERTY
Public Const JSON_MODE_PROPERTY As String
Public Const JSON_MODE_PROPERTY As String
public:
literal String^ JSON_MODE_PROPERTY
public:
literal String^ JSON_MODE_PROPERTY
static val mutable JSON_MODE_PROPERTY: string
static val mutable JSON_MODE_PROPERTY: string

Field Value

Type: Online String
See Also
FormModel Class
FormModel Members
NFX.DataAccess.CRUD Namespace


FormModel.JSON_ROUNDTRIP_PROPERTY Field

FormModel JSON_ROUNDTRIP_PROPERTY Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string JSON_ROUNDTRIP_PROPERTY
public const string JSON_ROUNDTRIP_PROPERTY
Public Const JSON_ROUNDTRIP_PROPERTY As String
Public Const JSON_ROUNDTRIP_PROPERTY As String
public:
literal String^ JSON_ROUNDTRIP_PROPERTY
public:
literal String^ JSON_ROUNDTRIP_PROPERTY
static val mutable JSON_ROUNDTRIP_PROPERTY: string
static val mutable JSON_ROUNDTRIP_PROPERTY: string

Field Value

Type: Online String
See Also
FormModel Class
FormModel Members
NFX.DataAccess.CRUD Namespace


FormModel Methods

FormModel Methods NFX Class Library

The FormModel type exposes the following members.
Methods
 | Name | Description
Public method | AfterLoad | Invoked to allow the row to hydrate its fields/state from AmorphousData bag. For example, this may be used to reconstruct some temporary object state that is not stored as a part of established business schema. The operation is performed per particular targetName (name of physical backend). Simply put, this method allows business code to "specify what to do after object gets loaded from THE PARTICULAR TARGET backend store". An example: suppose current MongoDB collection stores 3 fields for name, and we want to collapse First/Last/Middle name fields into one field. If we change rowschema then it will only contain 1 field which is not present in the database, however those 'older' fields will get populated into AmorphousData giving us an option to merge older 3 fields into 1 within AfterLoad() implementation (Inherited from AmorphousTypedRow.)
Public method | ApplyDefaultFieldValues | Writes default values specified in schema into fields. Pass overwrite=true to force defaults over non-null existing values (false by default) (Inherited from Row.)
Public method | BeforeSave | Invoked to allow the row to transform its state into AmorphousData bag. For example, this may be usefull to store extra data that is not a part of established business schema. The operation is performed per particular targetName (name of physical backend). Simply put, this method allows business code to "specify what to do before object gets saved in THE PARTICULAR TARGET backend store" (Inherited from AmorphousTypedRow.)
Protected method | CheckMinMax | (Inherited from Row.)
Public method | Configure | In base class applies Config attribute. Useful for typed rows (Inherited from Row.)
Public method | ConvertFieldValueToDef | Converts field value to the type specified by Schema.FieldDef. For example converts GDID->ulong or ulong->GDID. This method can be overridden to perform custom handling of types, for example one can assign bool field as "Si" that would convert to TRUE. This method is called by SetFieldValue(...) before assigning actual field buffer (Inherited from Row.)
Public method | CopyFields | Copies fields from this row into another row/form. Note: this is shallow copy, as field values for complex types are just copied over (Inherited from Row.)
Protected method | DoSave | Override to save model into data store. Return "predictable" exception (such as key violation) as a value instead of throwing. Throw only in "un-predictable" cases (such as DB connection is down, not enough space etc...). Return extra result obtained during save i.e. a db-assigned auto-inc field
Public method | Equals(Object) | Object override - sealed. Override Equals(row) instead (Inherited from Row.)
Public method | Equals(Row) | Override to perform custom row equality comparison. Default implementation equates rows using their key fields (Inherited from Row.)
Protected method | FilterJSONSerializerField | Override to filter-out some fields from serialization to JSON, or change field values. Return name null to indicate that field should be filtered-out(excluded from serialization to JSON) (Inherited from Row.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetClientFieldDef | Override to perform dynamic substitute of field def for the specified field. This method is used by client ui/scaffolding to extract dynamic definition for a field (i.e. field description, requirement, value list etc.) as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original field def, you can return a substituted field def per particular business logic (Inherited from Row.)
Public method | GetClientFieldValue | Override to perform dynamic substitute of field value for the specified field. This method is used by client ui/scaffolding to extract field values for a field as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original GetFieldValue(fdef), you can return a substituted field value per particular business logic (Inherited from Row.)
Public method | GetClientFieldValueList | Override to perform dynamic lookup of field value list for the specified field. This method is used by client ui/scaffolding to extract dynamic lookup values as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. This is a simplified version of GetClientFieldDef (Inherited from Row.)
Public method | GetDataStoreKey | Returns values for fields that represent row's primary key (Inherited from Row.)
Public method | GetDisplayFieldValue(Int32, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute (Inherited from Row.)
Public method | GetDisplayFieldValue(String, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute (Inherited from Row.)
Public method | GetEnumerator | (Inherited from Row.)
Public method | GetFieldValue | (Inherited from TypedRow.)
Public method | GetFieldValueDescription(Int32, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema (Inherited from Row.)
Public method | GetFieldValueDescription(String, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema (Inherited from Row.)
Public method | GetHashCode | Object override - gets hash code from key fields (Inherited from Row.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PersistConfiguration | The base class does not implement this method. Override to persist row fields into config node (Inherited from Row.)
Public method | Save(Object ) | Saves form into data store. The form is validated first and validation error is returned which indicates that save did not succeed due to validation error/s. The core implementation is in DoSave() that can also abort by either returning execption when predictable failure happens on save (i.e. key violation). Other exceptions are thrown. Returns extra result obtained during save i.e. a db-assigned auto-inc field
Public method | Save TSaveResult (TSaveResult ) | Saves form into data store. The form is validated first and validation error is returned which indicates that save did not succeed due to validation error/s. The core implementation is in DoSave() that can also abort by either returning execption when predictable failure happens on save (i.e. key violation). Other exceptions are thrown. Returns extra result obtained during save i.e. a db-assigned auto-inc field
Public method | SetFieldValue | (Inherited from TypedRow.)
Public method | SetRoundtripBagFromJSONString | If non null or empty parses JSON content and sets the RoundtripBag
Public method | SimpleFilterPredicate | Returns true if this row satisfies simple filter - it contains the supplied filter string. The filter pattern may start or end with "*" char that denotes a wildcard. A wildcard is permitted on both sides of the filter value (Inherited from Row.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Validate | Performs validation of data in the row returning exception object that provides description in cases when validation does not pass. Validation is performed not targeting any particular backend (Inherited from Row.)
Public method | Validate(String) | Validates row using row schema and supplied field definitions. Override to perform custom validations, i.e. TypeRows may directly access properties and write some validation type-safe code The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from Row.)
Public method | ValidateField(String, Schema FieldDef) | Validates row field using Schema.FieldDef settings. This method is invoked by base Validate() implementation. The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from Row.)
Public method | ValidateField(String, String) | Validates row field by name. Shortcut to ValidateField(Schema.FieldDef) (Inherited from Row.)
Public method | WriteAsJSON | Writes row as JSON either as an array or map depending on JSONWritingOptions.RowsAsMap setting. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class (Inherited from Row.)
Back to Top
Extension Methods
Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method ToErlObject Overloaded.
Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(ErlTypeOrder, Boolean) Overloaded.
Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(String, String, Boolean) Overloaded.
Convert Row to a hierarchical term that corresponds to the row's schema. The Erlang term is in the form:
View Colorized Copy to Clipboard Print
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
(Defined by ErlSchemaUtils.)
Public Extension Method ToJSON(JSONWritingOptions) Overloaded.
Serializes object into JSON string
(Defined by JSONExtensions.)
Public Extension Method ToJSON(TextWriter, JSONWritingOptions) Overloaded.
Serializes object into JSON format using provided TextWriter
(Defined by JSONExtensions.)
Public Extension Method ToJSON(Stream, JSONWritingOptions, Encoding) Overloaded.
Serializes object into JSON format using provided stream and optional encoding
(Defined by JSONExtensions.)
Public Extension Method Update
Convert an Erlang hierarchical term representing a schema to a Row.
(Defined by ErlSchemaUtils.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Row.)
Back to Top
See Also
FormModel Class
NFX.DataAccess.CRUD Namespace


FormModel.DoSave Method

FormModel DoSave Method NFX Class Library

Override to save model into data store. Return "predictable" exception (such as key violation) as a value instead of throwing. Throw only in "un-predictable" cases (such as DB connection is down, not enough space etc...). Return extra result obtained during save i.e. a db-assigned auto-inc field

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract Exception DoSave(
    out Object saveResult
)
protected abstract Exception DoSave(
    out Object saveResult
)
Protected MustOverride Function DoSave (
    <OutAttribute> ByRef saveResult As Object
) As Exception
Protected MustOverride Function DoSave (
    <OutAttribute> ByRef saveResult As Object
) As Exception
protected:
virtual Exception^ DoSave(
    [OutAttribute] Object^% saveResult
) abstract
protected:
virtual Exception^ DoSave(
    [OutAttribute] Object^% saveResult
) abstract
abstract DoSave :
        saveResult : Object byref -> Exception
abstract DoSave :
        saveResult : Object byref -> Exception

Parameters

saveResult
Type: Online System Object

Return Value

Type: Online Exception
See Also
FormModel Class
FormModel Members
NFX.DataAccess.CRUD Namespace


FormModel.Save Method

FormModel Save Method NFX Class Library

Overload List
 | Name | Description
Public method | Save(Object ) | Saves form into data store. The form is validated first and validation error is returned which indicates that save did not succeed due to validation error/s. The core implementation is in DoSave() that can also abort by either returning execption when predictable failure happens on save (i.e. key violation). Other exceptions are thrown. Returns extra result obtained during save i.e. a db-assigned auto-inc field
Public method | Save TSaveResult (TSaveResult ) | Saves form into data store. The form is validated first and validation error is returned which indicates that save did not succeed due to validation error/s. The core implementation is in DoSave() that can also abort by either returning execption when predictable failure happens on save (i.e. key violation). Other exceptions are thrown. Returns extra result obtained during save i.e. a db-assigned auto-inc field
Back to Top
See Also
FormModel Class
FormModel Members
NFX.DataAccess.CRUD Namespace


FormModel.Save Method (Object)

FormModel Save Method (Object ) NFX Class Library

Saves form into data store. The form is validated first and validation error is returned which indicates that save did not succeed due to validation error/s. The core implementation is in DoSave() that can also abort by either returning execption when predictable failure happens on save (i.e. key violation). Other exceptions are thrown. Returns extra result obtained during save i.e. a db-assigned auto-inc field

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Exception Save(
    out Object saveResult
)
public virtual Exception Save(
    out Object saveResult
)
Public Overridable Function Save (
    <OutAttribute> ByRef saveResult As Object
) As Exception
Public Overridable Function Save (
    <OutAttribute> ByRef saveResult As Object
) As Exception
public:
virtual Exception^ Save(
    [OutAttribute] Object^% saveResult
)
public:
virtual Exception^ Save(
    [OutAttribute] Object^% saveResult
)
abstract Save :
        saveResult : Object byref -> Exception
override Save :
        saveResult : Object byref -> Exception
abstract Save :
        saveResult : Object byref -> Exception
override Save :
        saveResult : Object byref -> Exception

Parameters

saveResult
Type: Online System Object

Return Value

Type: Online Exception
See Also
FormModel Class
FormModel Members
Save Overload
NFX.DataAccess.CRUD Namespace


FormModel.Save(TSaveResult) Method (TSaveResult)

FormModel Save TSaveResult Method (TSaveResult ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Saves form into data store. The form is validated first and validation error is returned which indicates that save did not succeed due to validation error/s. The core implementation is in DoSave() that can also abort by either returning execption when predictable failure happens on save (i.e. key violation). Other exceptions are thrown. Returns extra result obtained during save i.e. a db-assigned auto-inc field

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Exception Save<TSaveResult>(
    out TSaveResult saveResult
)
public virtual Exception Save<TSaveResult>(
    out TSaveResult saveResult
)
Public Overridable Function Save(Of TSaveResult) (
    <OutAttribute> ByRef saveResult As TSaveResult
) As Exception
Public Overridable Function Save(Of TSaveResult) (
    <OutAttribute> ByRef saveResult As TSaveResult
) As Exception
public:
generic<typename TSaveResult>
virtual Exception^ Save(
    [OutAttribute] TSaveResult% saveResult
)
public:
generic<typename TSaveResult>
virtual Exception^ Save(
    [OutAttribute] TSaveResult% saveResult
)
abstract Save :
        saveResult : 'TSaveResult byref -> Exception
override Save :
        saveResult : 'TSaveResult byref -> Exception
abstract Save :
        saveResult : 'TSaveResult byref -> Exception
override Save :
        saveResult : 'TSaveResult byref -> Exception

Parameters

saveResult
Type: TSaveResult
Type Parameters
TSaveResult

Return Value

Type: Online Exception
See Also
FormModel Class
FormModel Members
Save Overload
NFX.DataAccess.CRUD Namespace


FormModel.SetRoundtripBagFromJSONString Method

FormModel SetRoundtripBagFromJSONString Method NFX Class Library

[This is preliminary documentation and is subject to change.]

If non null or empty parses JSON content and sets the RoundtripBag

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetRoundtripBagFromJSONString(
    string content
)
public void SetRoundtripBagFromJSONString(
    string content
)
Public Sub SetRoundtripBagFromJSONString (
    content As String
)
Public Sub SetRoundtripBagFromJSONString (
    content As String
)
public:
void SetRoundtripBagFromJSONString(
    String^ content
)
public:
void SetRoundtripBagFromJSONString(
    String^ content
)
member SetRoundtripBagFromJSONString :
        content : string -> unit
member SetRoundtripBagFromJSONString :
        content : string -> unit

Parameters

content
Type: Online System String
See Also
FormModel Class
FormModel Members
NFX.DataAccess.CRUD Namespace


FormModel Properties

FormModel Properties NFX Class Library

The FormModel type exposes the following members.
Properties
 | Name | Description
Public property | AmorphousData | Returns data that does not comply with known schema (dynamic data). The field names are NOT case-sensitive (Inherited from AmorphousTypedRow.)
Public property | AmorphousDataEnabled | False by default for forms, safer for web. For example, no injection of un-inteded fields can be done via web form post (Overrides AmorphousTypedRow AmorphousDataEnabled.)
Public property | DataStoreTargetName | Returns the name of data store target obtained from App.DataStore by default. Override to supply a different name. This property is used for validation
Public property | HasRoundtripBag | True if RoundtripBag is allocated
Public property | Item Int32 | Gets/sets field values by positional index(Order) (Inherited from Row.)
Public property | Item String | Gets/sets field values by name (Inherited from Row.)
Public property | RoundtripBag | Returns lazily-allocated RoundtripBag. Use HasRoundtripBag to see if it is allocated not to allocate on get
Public property | Schema | References a schema for a table that this row is a part of (Inherited from TypedRow.)
Back to Top
See Also
FormModel Class
NFX.DataAccess.CRUD Namespace


FormModel.AmorphousDataEnabled Property

FormModel AmorphousDataEnabled Property NFX Class Library

False by default for forms, safer for web. For example, no injection of un-inteded fields can be done via web form post

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool AmorphousDataEnabled { get; }
public override bool AmorphousDataEnabled { get; }
Public Overrides ReadOnly Property AmorphousDataEnabled As Boolean
    Get
Public Overrides ReadOnly Property AmorphousDataEnabled As Boolean
    Get
public:
virtual property bool AmorphousDataEnabled {
    bool get () override;
}
public:
virtual property bool AmorphousDataEnabled {
    bool get () override;
}
abstract AmorphousDataEnabled : bool with get
override AmorphousDataEnabled : bool with get
abstract AmorphousDataEnabled : bool with get
override AmorphousDataEnabled : bool with get

Property Value

Type: Online Boolean

Implements

IAmorphousData AmorphousDataEnabled
See Also
FormModel Class
FormModel Members
NFX.DataAccess.CRUD Namespace


FormModel.DataStoreTargetName Property

FormModel DataStoreTargetName Property NFX Class Library

Returns the name of data store target obtained from App.DataStore by default. Override to supply a different name. This property is used for validation

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string DataStoreTargetName { get; }
public virtual string DataStoreTargetName { get; }
Public Overridable ReadOnly Property DataStoreTargetName As String
    Get
Public Overridable ReadOnly Property DataStoreTargetName As String
    Get
public:
virtual property String^ DataStoreTargetName {
    String^ get ();
}
public:
virtual property String^ DataStoreTargetName {
    String^ get ();
}
abstract DataStoreTargetName : string with get
override DataStoreTargetName : string with get
abstract DataStoreTargetName : string with get
override DataStoreTargetName : string with get

Property Value

Type: Online String
See Also
FormModel Class
FormModel Members
NFX.DataAccess.CRUD Namespace


FormModel.HasRoundtripBag Property

FormModel HasRoundtripBag Property NFX Class Library

True if RoundtripBag is allocated

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasRoundtripBag { get; }
public bool HasRoundtripBag { get; }
Public ReadOnly Property HasRoundtripBag As Boolean
    Get
Public ReadOnly Property HasRoundtripBag As Boolean
    Get
public:
property bool HasRoundtripBag {
    bool get ();
}
public:
property bool HasRoundtripBag {
    bool get ();
}
member HasRoundtripBag : bool with get
member HasRoundtripBag : bool with get

Property Value

Type: Online Boolean
See Also
FormModel Class
FormModel Members
NFX.DataAccess.CRUD Namespace


FormModel.RoundtripBag Property

FormModel RoundtripBag Property NFX Class Library

Returns lazily-allocated RoundtripBag. Use HasRoundtripBag to see if it is allocated not to allocate on get

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDataMap RoundtripBag { get; }
public JSONDataMap RoundtripBag { get; }
Public ReadOnly Property RoundtripBag As JSONDataMap
    Get
Public ReadOnly Property RoundtripBag As JSONDataMap
    Get
public:
property JSONDataMap^ RoundtripBag {
    JSONDataMap^ get ();
}
public:
property JSONDataMap^ RoundtripBag {
    JSONDataMap^ get ();
}
member RoundtripBag : JSONDataMap with get
member RoundtripBag : JSONDataMap with get

Property Value

Type: JSONDataMap
See Also
FormModel Class
FormModel Members
NFX.DataAccess.CRUD Namespace


IAmorphousData Interface

IAmorphousData Interface NFX Class Library

Denotes an entity, which is typically a row-derivative, that has extra data fields that are not defined by particular schema and get represented as {name:value} map instead (schema-less data). This interface is usually implemented by rows that support version changing between releases, i.e. when structured storage (such as Mongo DB) stores more fields than are currently declared in the row the extra fields will be placed in the AmorphousData collection. This interface also provides hook BeforeSave()/AfterLoad() that allow for transforms between Amorphous and "hard-schema" data models

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IAmorphousData
public interface IAmorphousData
Public Interface IAmorphousData
Public Interface IAmorphousData
public interface class IAmorphousData
public interface class IAmorphousData
type IAmorphousData =  interface end
type IAmorphousData =  interface end
See Also
IAmorphousData Members
NFX.DataAccess.CRUD Namespace


IAmorphousData Members

IAmorphousData Members NFX Class Library

The IAmorphousData type exposes the following members.
Methods
 | Name | Description
Public method | AfterLoad | Invoked to allow the entity (such as a row) to hydrate its fields/state from AmorphousData bag. For example, this may be used to reconstruct some temporary object state that is not stored as a part of established business schema. The operation is performed per particular targetName (name of physical backend). Simply put, this method allows business code to "specify what to do after object gets loaded from THE PARTICULAR TARGET backend store". An example: suppose current MongoDB collection stores 3 fields for name, and we want to collapse First/Last/Middle name fields into one field. If we change rowschema then it will only contain 1 field which is not present in the database, however those 'older' fields will get populated into AmorphousData giving us an option to merge older 3 fields into 1 within AfterLoad() implementation
Public method | BeforeSave | Invoked to allow the entity (such as a row) to transform its state into AmorphousData bag. For example, this may be usefull to store extra data that is not a part of established business schema. The operation is performed per particular targetName (name of physical backend). Simply put, this method allows business code to "specify what to do before object gets saved in THE PARTICULAR TARGET backend store"
Back to Top
Properties
 | Name | Description
Public property | AmorphousData | Returns data that does not comply with known schema (dynamic data). The field names are NOT case-sensitive
Public property | AmorphousDataEnabled | When true, enabled amorphous data behaviour, i.e. copying of amorphous data between rows. When false, the amorphous data is ignored as-if the type did not implement this interface This is needed for security, i.e. on the web returning false will prevent injection via posted forms
Back to Top
See Also
IAmorphousData Interface
NFX.DataAccess.CRUD Namespace


IAmorphousData Methods

IAmorphousData Methods NFX Class Library

The IAmorphousData type exposes the following members.
Methods
 | Name | Description
Public method | AfterLoad | Invoked to allow the entity (such as a row) to hydrate its fields/state from AmorphousData bag. For example, this may be used to reconstruct some temporary object state that is not stored as a part of established business schema. The operation is performed per particular targetName (name of physical backend). Simply put, this method allows business code to "specify what to do after object gets loaded from THE PARTICULAR TARGET backend store". An example: suppose current MongoDB collection stores 3 fields for name, and we want to collapse First/Last/Middle name fields into one field. If we change rowschema then it will only contain 1 field which is not present in the database, however those 'older' fields will get populated into AmorphousData giving us an option to merge older 3 fields into 1 within AfterLoad() implementation
Public method | BeforeSave | Invoked to allow the entity (such as a row) to transform its state into AmorphousData bag. For example, this may be usefull to store extra data that is not a part of established business schema. The operation is performed per particular targetName (name of physical backend). Simply put, this method allows business code to "specify what to do before object gets saved in THE PARTICULAR TARGET backend store"
Back to Top
See Also
IAmorphousData Interface
NFX.DataAccess.CRUD Namespace


IAmorphousData.AfterLoad Method

IAmorphousData AfterLoad Method NFX Class Library

Invoked to allow the entity (such as a row) to hydrate its fields/state from AmorphousData bag. For example, this may be used to reconstruct some temporary object state that is not stored as a part of established business schema. The operation is performed per particular targetName (name of physical backend). Simply put, this method allows business code to "specify what to do after object gets loaded from THE PARTICULAR TARGET backend store". An example: suppose current MongoDB collection stores 3 fields for name, and we want to collapse First/Last/Middle name fields into one field. If we change rowschema then it will only contain 1 field which is not present in the database, however those 'older' fields will get populated into AmorphousData giving us an option to merge older 3 fields into 1 within AfterLoad() implementation

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void AfterLoad(
    string targetName
)
void AfterLoad(
    string targetName
)
Sub AfterLoad (
    targetName As String
)
Sub AfterLoad (
    targetName As String
)
void AfterLoad(
    String^ targetName
)
void AfterLoad(
    String^ targetName
)
abstract AfterLoad :
        targetName : string -> unit
abstract AfterLoad :
        targetName : string -> unit

Parameters

targetName
Type: Online System String
See Also
IAmorphousData Interface
IAmorphousData Members
NFX.DataAccess.CRUD Namespace


IAmorphousData.BeforeSave Method

IAmorphousData BeforeSave Method NFX Class Library

Invoked to allow the entity (such as a row) to transform its state into AmorphousData bag. For example, this may be usefull to store extra data that is not a part of established business schema. The operation is performed per particular targetName (name of physical backend). Simply put, this method allows business code to "specify what to do before object gets saved in THE PARTICULAR TARGET backend store"

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void BeforeSave(
    string targetName
)
void BeforeSave(
    string targetName
)
Sub BeforeSave (
    targetName As String
)
Sub BeforeSave (
    targetName As String
)
void BeforeSave(
    String^ targetName
)
void BeforeSave(
    String^ targetName
)
abstract BeforeSave :
        targetName : string -> unit
abstract BeforeSave :
        targetName : string -> unit

Parameters

targetName
Type: Online System String
See Also
IAmorphousData Interface
IAmorphousData Members
NFX.DataAccess.CRUD Namespace


IAmorphousData Properties

IAmorphousData Properties NFX Class Library

The IAmorphousData type exposes the following members.
Properties
 | Name | Description
Public property | AmorphousData | Returns data that does not comply with known schema (dynamic data). The field names are NOT case-sensitive
Public property | AmorphousDataEnabled | When true, enabled amorphous data behaviour, i.e. copying of amorphous data between rows. When false, the amorphous data is ignored as-if the type did not implement this interface This is needed for security, i.e. on the web returning false will prevent injection via posted forms
Back to Top
See Also
IAmorphousData Interface
NFX.DataAccess.CRUD Namespace


IAmorphousData.AmorphousData Property

IAmorphousData AmorphousData Property NFX Class Library

Returns data that does not comply with known schema (dynamic data). The field names are NOT case-sensitive

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IDictionary<string, Object> AmorphousData { get; }
IDictionary<string, Object> AmorphousData { get; }
ReadOnly Property AmorphousData As IDictionary(Of String, Object)
    Get
ReadOnly Property AmorphousData As IDictionary(Of String, Object)
    Get
property IDictionary<String^, Object^>^ AmorphousData {
    IDictionary<String^, Object^>^ get ();
}
property IDictionary<String^, Object^>^ AmorphousData {
    IDictionary<String^, Object^>^ get ();
}
abstract AmorphousData : IDictionary<string, Object> with get
abstract AmorphousData : IDictionary<string, Object> with get

Property Value

Type: Online IDictionary Online String, Online Object
See Also
IAmorphousData Interface
IAmorphousData Members
NFX.DataAccess.CRUD Namespace


IAmorphousData.AmorphousDataEnabled Property

IAmorphousData AmorphousDataEnabled Property NFX Class Library

[This is preliminary documentation and is subject to change.]

When true, enabled amorphous data behaviour, i.e. copying of amorphous data between rows. When false, the amorphous data is ignored as-if the type did not implement this interface This is needed for security, i.e. on the web returning false will prevent injection via posted forms

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool AmorphousDataEnabled { get; }
bool AmorphousDataEnabled { get; }
ReadOnly Property AmorphousDataEnabled As Boolean
    Get
ReadOnly Property AmorphousDataEnabled As Boolean
    Get
property bool AmorphousDataEnabled {
    bool get ();
}
property bool AmorphousDataEnabled {
    bool get ();
}
abstract AmorphousDataEnabled : bool with get
abstract AmorphousDataEnabled : bool with get

Property Value

Type: Online Boolean
See Also
IAmorphousData Interface
IAmorphousData Members
NFX.DataAccess.CRUD Namespace


ICacheParams Interface

ICacheParams Interface NFX Class Library

Supplies caching params

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ICacheParams
public interface ICacheParams
Public Interface ICacheParams
Public Interface ICacheParams
public interface class ICacheParams
public interface class ICacheParams
type ICacheParams =  interface end
type ICacheParams =  interface end
See Also
ICacheParams Members
NFX.DataAccess.CRUD Namespace


ICacheParams Members

ICacheParams Members NFX Class Library

The ICacheParams type exposes the following members.
Properties
 | Name | Description
Public property | CacheAbsentData | When true would cache the instance of AbsentData to signify the absence of data in the backend for key
Public property | ReadCacheMaxAgeSec | If greater than 0 then would allow reading a cached result for up-to the specified number of seconds. If =0 uses cache's default span. Less than 0 does not try to read from cache
Public property | WriteCacheMaxAgeSec | If greater than 0 then writes to cache with the expiration. If =0 uses cache's default life span. Less than 0 does not write to cache
Public property | WriteCachePriority | Relative cache priority which is used when WriteCacheMaxAgeSec>=0
Back to Top
See Also
ICacheParams Interface
NFX.DataAccess.CRUD Namespace


ICacheParams Properties

ICacheParams Properties NFX Class Library

The ICacheParams type exposes the following members.
Properties
 | Name | Description
Public property | CacheAbsentData | When true would cache the instance of AbsentData to signify the absence of data in the backend for key
Public property | ReadCacheMaxAgeSec | If greater than 0 then would allow reading a cached result for up-to the specified number of seconds. If =0 uses cache's default span. Less than 0 does not try to read from cache
Public property | WriteCacheMaxAgeSec | If greater than 0 then writes to cache with the expiration. If =0 uses cache's default life span. Less than 0 does not write to cache
Public property | WriteCachePriority | Relative cache priority which is used when WriteCacheMaxAgeSec>=0
Back to Top
See Also
ICacheParams Interface
NFX.DataAccess.CRUD Namespace


ICacheParams.CacheAbsentData Property

ICacheParams CacheAbsentData Property NFX Class Library

When true would cache the instance of AbsentData to signify the absence of data in the backend for key

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool CacheAbsentData { get; }
bool CacheAbsentData { get; }
ReadOnly Property CacheAbsentData As Boolean
    Get
ReadOnly Property CacheAbsentData As Boolean
    Get
property bool CacheAbsentData {
    bool get ();
}
property bool CacheAbsentData {
    bool get ();
}
abstract CacheAbsentData : bool with get
abstract CacheAbsentData : bool with get

Property Value

Type: Online Boolean
See Also
ICacheParams Interface
ICacheParams Members
NFX.DataAccess.CRUD Namespace


ICacheParams.ReadCacheMaxAgeSec Property

ICacheParams ReadCacheMaxAgeSec Property NFX Class Library

If greater than 0 then would allow reading a cached result for up-to the specified number of seconds. If =0 uses cache's default span. Less than 0 does not try to read from cache

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int ReadCacheMaxAgeSec { get; }
int ReadCacheMaxAgeSec { get; }
ReadOnly Property ReadCacheMaxAgeSec As Integer
    Get
ReadOnly Property ReadCacheMaxAgeSec As Integer
    Get
property int ReadCacheMaxAgeSec {
    int get ();
}
property int ReadCacheMaxAgeSec {
    int get ();
}
abstract ReadCacheMaxAgeSec : int with get
abstract ReadCacheMaxAgeSec : int with get

Property Value

Type: Online Int32
See Also
ICacheParams Interface
ICacheParams Members
NFX.DataAccess.CRUD Namespace


ICacheParams.WriteCacheMaxAgeSec Property

ICacheParams WriteCacheMaxAgeSec Property NFX Class Library

If greater than 0 then writes to cache with the expiration. If =0 uses cache's default life span. Less than 0 does not write to cache

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int WriteCacheMaxAgeSec { get; }
int WriteCacheMaxAgeSec { get; }
ReadOnly Property WriteCacheMaxAgeSec As Integer
    Get
ReadOnly Property WriteCacheMaxAgeSec As Integer
    Get
property int WriteCacheMaxAgeSec {
    int get ();
}
property int WriteCacheMaxAgeSec {
    int get ();
}
abstract WriteCacheMaxAgeSec : int with get
abstract WriteCacheMaxAgeSec : int with get

Property Value

Type: Online Int32
See Also
ICacheParams Interface
ICacheParams Members
NFX.DataAccess.CRUD Namespace


ICacheParams.WriteCachePriority Property

ICacheParams WriteCachePriority Property NFX Class Library

Relative cache priority which is used when WriteCacheMaxAgeSec>=0

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int WriteCachePriority { get; }
int WriteCachePriority { get; }
ReadOnly Property WriteCachePriority As Integer
    Get
ReadOnly Property WriteCachePriority As Integer
    Get
property int WriteCachePriority {
    int get ();
}
property int WriteCachePriority {
    int get ();
}
abstract WriteCachePriority : int with get
abstract WriteCachePriority : int with get

Property Value

Type: Online Int32
See Also
ICacheParams Interface
ICacheParams Members
NFX.DataAccess.CRUD Namespace


ICRUDDataStore Interface

ICRUDDataStore Interface NFX Class Library

Represents a DataStore that supports CRUD operations

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ICRUDDataStore : ICRUDOperations,
    ICRUDTransactionOperations
public interface ICRUDDataStore : ICRUDOperations,
    ICRUDTransactionOperations
Public Interface ICRUDDataStore
    Inherits ICRUDOperations, ICRUDTransactionOperations
Public Interface ICRUDDataStore
    Inherits ICRUDOperations, ICRUDTransactionOperations
public interface class ICRUDDataStore : ICRUDOperations,
    ICRUDTransactionOperations
public interface class ICRUDDataStore : ICRUDOperations,
    ICRUDTransactionOperations
type ICRUDDataStore =
    interface
        interface ICRUDOperations
        interface ICRUDTransactionOperations
    end
type ICRUDDataStore =
    interface
        interface ICRUDOperations
        interface ICRUDTransactionOperations
    end
See Also
ICRUDDataStore Members
NFX.DataAccess.CRUD Namespace


ICRUDDataStore Members

ICRUDDataStore Members NFX Class Library

The ICRUDDataStore type exposes the following members.
Methods
 | Name | Description
Public method | BeginTransaction | Returns a transaction object for backend. Even if backend does not support transactions internally, CRUDTransactions save changes into the store on commit only (Inherited from ICRUDTransactionOperations.)
Public method | BeginTransactionAsync | Returns a transaction object for backend. Even if backend does not support transactions internally, CRUDTransactions save changes into the store on commit only (Inherited from ICRUDTransactionOperations.)
Public method | Delete | (Inherited from ICRUDOperations.)
Public method | DeleteAsync | (Inherited from ICRUDOperations.)
Public method | ExecuteWithoutFetch | (Inherited from ICRUDOperations.)
Public method | ExecuteWithoutFetchAsync | (Inherited from ICRUDOperations.)
Public method | GetSchema | (Inherited from ICRUDOperations.)
Public method | GetSchemaAsync | (Inherited from ICRUDOperations.)
Public method | Insert | (Inherited from ICRUDOperations.)
Public method | InsertAsync | (Inherited from ICRUDOperations.)
Public method | Load | (Inherited from ICRUDOperations.)
Public method | LoadAsync | (Inherited from ICRUDOperations.)
Public method | LoadOneRow | (Inherited from ICRUDOperations.)
Public method | LoadOneRowAsync | (Inherited from ICRUDOperations.)
Public method | LoadOneRowset | (Inherited from ICRUDOperations.)
Public method | LoadOneRowsetAsync | (Inherited from ICRUDOperations.)
Public method | OpenCursor | (Inherited from ICRUDOperations.)
Public method | OpenCursorAsync | (Inherited from ICRUDOperations.)
Public method | Save | (Inherited from ICRUDOperations.)
Public method | SaveAsync | (Inherited from ICRUDOperations.)
Public method | Update | (Inherited from ICRUDOperations.)
Public method | UpdateAsync | (Inherited from ICRUDOperations.)
Public method | Upsert | (Inherited from ICRUDOperations.)
Public method | UpsertAsync | (Inherited from ICRUDOperations.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | LoadEnumerable TRow | Loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadEnumerableAsync TRow | Async version - loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadRow TRow | Loads one row cast per Query(T) or null (Defined by DataUtils.)
Public Extension Method | LoadRowAsync TRow | Async version - loads one row cast per Query(T) or null (Defined by DataUtils.)
Back to Top
Properties
 | Name | Description
Public property | QueryResolver | Reolver that turns query into handler
Public property | ScriptFileSuffix | Returns default script file suffix, which some providers may use to locate script files i.e. for MySql: ".my.sql" which gets added to script files like so: name.[suffix].[script ext (i.e. sql)]. This name should uniquely identify the provider
Public property | StoreType | Provides classification for the underlying store
Public property | SupportsTransactions | Returns true when backend supports transactions. Even if false returned, CRUDDatastore supports CRUDTransaction return from BeginTransaction() in which case statements may not be sent to destination until a call to Commit() (Inherited from ICRUDTransactionOperations.)
Public property | SupportsTrueAsynchrony | Returns true when backend supports true asynchronous operations, such as the ones that do not create extra threads/empty tasks (Inherited from ICRUDOperations.)
Back to Top
See Also
ICRUDDataStore Interface
NFX.DataAccess.CRUD Namespace


ICRUDDataStore Methods

ICRUDDataStore Methods NFX Class Library

The ICRUDDataStore type exposes the following members.
Methods
 | Name | Description
Public method | BeginTransaction | Returns a transaction object for backend. Even if backend does not support transactions internally, CRUDTransactions save changes into the store on commit only (Inherited from ICRUDTransactionOperations.)
Public method | BeginTransactionAsync | Returns a transaction object for backend. Even if backend does not support transactions internally, CRUDTransactions save changes into the store on commit only (Inherited from ICRUDTransactionOperations.)
Public method | Delete | (Inherited from ICRUDOperations.)
Public method | DeleteAsync | (Inherited from ICRUDOperations.)
Public method | ExecuteWithoutFetch | (Inherited from ICRUDOperations.)
Public method | ExecuteWithoutFetchAsync | (Inherited from ICRUDOperations.)
Public method | GetSchema | (Inherited from ICRUDOperations.)
Public method | GetSchemaAsync | (Inherited from ICRUDOperations.)
Public method | Insert | (Inherited from ICRUDOperations.)
Public method | InsertAsync | (Inherited from ICRUDOperations.)
Public method | Load | (Inherited from ICRUDOperations.)
Public method | LoadAsync | (Inherited from ICRUDOperations.)
Public method | LoadOneRow | (Inherited from ICRUDOperations.)
Public method | LoadOneRowAsync | (Inherited from ICRUDOperations.)
Public method | LoadOneRowset | (Inherited from ICRUDOperations.)
Public method | LoadOneRowsetAsync | (Inherited from ICRUDOperations.)
Public method | OpenCursor | (Inherited from ICRUDOperations.)
Public method | OpenCursorAsync | (Inherited from ICRUDOperations.)
Public method | Save | (Inherited from ICRUDOperations.)
Public method | SaveAsync | (Inherited from ICRUDOperations.)
Public method | Update | (Inherited from ICRUDOperations.)
Public method | UpdateAsync | (Inherited from ICRUDOperations.)
Public method | Upsert | (Inherited from ICRUDOperations.)
Public method | UpsertAsync | (Inherited from ICRUDOperations.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | LoadEnumerable TRow | Loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadEnumerableAsync TRow | Async version - loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadRow TRow | Loads one row cast per Query(T) or null (Defined by DataUtils.)
Public Extension Method | LoadRowAsync TRow | Async version - loads one row cast per Query(T) or null (Defined by DataUtils.)
Back to Top
See Also
ICRUDDataStore Interface
NFX.DataAccess.CRUD Namespace


ICRUDDataStore Properties

ICRUDDataStore Properties NFX Class Library

The ICRUDDataStore type exposes the following members.
Properties
 | Name | Description
Public property | QueryResolver | Reolver that turns query into handler
Public property | ScriptFileSuffix | Returns default script file suffix, which some providers may use to locate script files i.e. for MySql: ".my.sql" which gets added to script files like so: name.[suffix].[script ext (i.e. sql)]. This name should uniquely identify the provider
Public property | StoreType | Provides classification for the underlying store
Public property | SupportsTransactions | Returns true when backend supports transactions. Even if false returned, CRUDDatastore supports CRUDTransaction return from BeginTransaction() in which case statements may not be sent to destination until a call to Commit() (Inherited from ICRUDTransactionOperations.)
Public property | SupportsTrueAsynchrony | Returns true when backend supports true asynchronous operations, such as the ones that do not create extra threads/empty tasks (Inherited from ICRUDOperations.)
Back to Top
See Also
ICRUDDataStore Interface
NFX.DataAccess.CRUD Namespace


ICRUDDataStore.QueryResolver Property

ICRUDDataStore QueryResolver Property NFX Class Library

Reolver that turns query into handler

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ICRUDQueryResolver QueryResolver { get; }
ICRUDQueryResolver QueryResolver { get; }
ReadOnly Property QueryResolver As ICRUDQueryResolver
    Get
ReadOnly Property QueryResolver As ICRUDQueryResolver
    Get
property ICRUDQueryResolver^ QueryResolver {
    ICRUDQueryResolver^ get ();
}
property ICRUDQueryResolver^ QueryResolver {
    ICRUDQueryResolver^ get ();
}
abstract QueryResolver : ICRUDQueryResolver with get
abstract QueryResolver : ICRUDQueryResolver with get

Property Value

Type: ICRUDQueryResolver
See Also
ICRUDDataStore Interface
ICRUDDataStore Members
NFX.DataAccess.CRUD Namespace


ICRUDDataStore.ScriptFileSuffix Property

ICRUDDataStore ScriptFileSuffix Property NFX Class Library

Returns default script file suffix, which some providers may use to locate script files i.e. for MySql: ".my.sql" which gets added to script files like so: name.[suffix].[script ext (i.e. sql)]. This name should uniquely identify the provider

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string ScriptFileSuffix { get; }
string ScriptFileSuffix { get; }
ReadOnly Property ScriptFileSuffix As String
    Get
ReadOnly Property ScriptFileSuffix As String
    Get
property String^ ScriptFileSuffix {
    String^ get ();
}
property String^ ScriptFileSuffix {
    String^ get ();
}
abstract ScriptFileSuffix : string with get
abstract ScriptFileSuffix : string with get

Property Value

Type: Online String
See Also
ICRUDDataStore Interface
ICRUDDataStore Members
NFX.DataAccess.CRUD Namespace


ICRUDDataStore.StoreType Property

ICRUDDataStore StoreType Property NFX Class Library

Provides classification for the underlying store

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
CRUDDataStoreType StoreType { get; }
CRUDDataStoreType StoreType { get; }
ReadOnly Property StoreType As CRUDDataStoreType
    Get
ReadOnly Property StoreType As CRUDDataStoreType
    Get
property CRUDDataStoreType StoreType {
    CRUDDataStoreType get ();
}
property CRUDDataStoreType StoreType {
    CRUDDataStoreType get ();
}
abstract StoreType : CRUDDataStoreType with get
abstract StoreType : CRUDDataStoreType with get

Property Value

Type: CRUDDataStoreType
See Also
ICRUDDataStore Interface
ICRUDDataStore Members
NFX.DataAccess.CRUD Namespace


ICRUDDataStoreImplementation Interface

ICRUDDataStoreImplementation Interface NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ICRUDDataStoreImplementation : ICRUDDataStore,
    ICRUDOperations, ICRUDTransactionOperations, IDataStoreImplementation, IDataStore, IApplicationComponent,
    IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
public interface ICRUDDataStoreImplementation : ICRUDDataStore,
    ICRUDOperations, ICRUDTransactionOperations, IDataStoreImplementation, IDataStore, IApplicationComponent,
    IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
Public Interface ICRUDDataStoreImplementation
    Inherits ICRUDDataStore, ICRUDOperations, ICRUDTransactionOperations, IDataStoreImplementation,
    IDataStore, IApplicationComponent, IDisposable, IConfigurable, IInstrumentable,
    IExternallyParameterized
Public Interface ICRUDDataStoreImplementation
    Inherits ICRUDDataStore, ICRUDOperations, ICRUDTransactionOperations, IDataStoreImplementation,
    IDataStore, IApplicationComponent, IDisposable, IConfigurable, IInstrumentable,
    IExternallyParameterized
public interface class ICRUDDataStoreImplementation : ICRUDDataStore,
    ICRUDOperations, ICRUDTransactionOperations, IDataStoreImplementation, IDataStore, IApplicationComponent,
    IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
public interface class ICRUDDataStoreImplementation : ICRUDDataStore,
    ICRUDOperations, ICRUDTransactionOperations, IDataStoreImplementation, IDataStore, IApplicationComponent,
    IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
type ICRUDDataStoreImplementation =
    interface
        interface ICRUDDataStore
        interface ICRUDOperations
        interface ICRUDTransactionOperations
        interface IDataStoreImplementation
        interface IDataStore
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
type ICRUDDataStoreImplementation =
    interface
        interface ICRUDDataStore
        interface ICRUDOperations
        interface ICRUDTransactionOperations
        interface IDataStoreImplementation
        interface IDataStore
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
ICRUDDataStoreImplementation Members
NFX.DataAccess.CRUD Namespace


ICRUDDataStoreImplementation Members

ICRUDDataStoreImplementation Members NFX Class Library

The ICRUDDataStoreImplementation type exposes the following members.
Methods
 | Name | Description
Public method | BeginTransaction | Returns a transaction object for backend. Even if backend does not support transactions internally, CRUDTransactions save changes into the store on commit only (Inherited from ICRUDTransactionOperations.)
Public method | BeginTransactionAsync | Returns a transaction object for backend. Even if backend does not support transactions internally, CRUDTransactions save changes into the store on commit only (Inherited from ICRUDTransactionOperations.)
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Delete | (Inherited from ICRUDOperations.)
Public method | DeleteAsync | (Inherited from ICRUDOperations.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | ExecuteWithoutFetch | (Inherited from ICRUDOperations.)
Public method | ExecuteWithoutFetchAsync | (Inherited from ICRUDOperations.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Public method | GetSchema | (Inherited from ICRUDOperations.)
Public method | GetSchemaAsync | (Inherited from ICRUDOperations.)
Public method | Insert | (Inherited from ICRUDOperations.)
Public method | InsertAsync | (Inherited from ICRUDOperations.)
Public method | Load | (Inherited from ICRUDOperations.)
Public method | LoadAsync | (Inherited from ICRUDOperations.)
Public method | LoadOneRow | (Inherited from ICRUDOperations.)
Public method | LoadOneRowAsync | (Inherited from ICRUDOperations.)
Public method | LoadOneRowset | (Inherited from ICRUDOperations.)
Public method | LoadOneRowsetAsync | (Inherited from ICRUDOperations.)
Public method | MakeScriptQueryHandler |
Public method | OpenCursor | (Inherited from ICRUDOperations.)
Public method | OpenCursorAsync | (Inherited from ICRUDOperations.)
Public method | Save | (Inherited from ICRUDOperations.)
Public method | SaveAsync | (Inherited from ICRUDOperations.)
Public method | TestConnection | Tests connection and throws an exception if connection could not be established (Inherited from IDataStore.)
Public method | Update | (Inherited from ICRUDOperations.)
Public method | UpdateAsync | (Inherited from ICRUDOperations.)
Public method | Upsert | (Inherited from ICRUDOperations.)
Public method | UpsertAsync | (Inherited from ICRUDOperations.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | LoadEnumerable TRow | Loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadEnumerableAsync TRow | Async version - loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadRow TRow | Loads one row cast per Query(T) or null (Defined by DataUtils.)
Public Extension Method | LoadRowAsync TRow | Async version - loads one row cast per Query(T) or null (Defined by DataUtils.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | LogLevel | Defines log level for data stores (Inherited from IDataStoreImplementation.)
Public property | QueryResolver | Reolver that turns query into handler (Inherited from ICRUDDataStore.)
Public property | ScriptFileSuffix | Returns default script file suffix, which some providers may use to locate script files i.e. for MySql: ".my.sql" which gets added to script files like so: name.[suffix].[script ext (i.e. sql)]. This name should uniquely identify the provider (Inherited from ICRUDDataStore.)
Public property | StoreType | Provides classification for the underlying store (Inherited from ICRUDDataStore.)
Public property | SupportsTransactions | Returns true when backend supports transactions. Even if false returned, CRUDDatastore supports CRUDTransaction return from BeginTransaction() in which case statements may not be sent to destination until a call to Commit() (Inherited from ICRUDTransactionOperations.)
Public property | SupportsTrueAsynchrony | Returns true when backend supports true asynchronous operations, such as the ones that do not create extra threads/empty tasks (Inherited from ICRUDOperations.)
Public property | TargetName | Returns the name of the underlying store technology, i.e. "ORACLE". This property is used by some metadata-based validation logic which is target-dependent (Inherited from IDataStore.)
Back to Top
See Also
ICRUDDataStoreImplementation Interface
NFX.DataAccess.CRUD Namespace


ICRUDDataStoreImplementation Methods

ICRUDDataStoreImplementation Methods NFX Class Library

The ICRUDDataStoreImplementation type exposes the following members.
Methods
 | Name | Description
Public method | BeginTransaction | Returns a transaction object for backend. Even if backend does not support transactions internally, CRUDTransactions save changes into the store on commit only (Inherited from ICRUDTransactionOperations.)
Public method | BeginTransactionAsync | Returns a transaction object for backend. Even if backend does not support transactions internally, CRUDTransactions save changes into the store on commit only (Inherited from ICRUDTransactionOperations.)
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Delete | (Inherited from ICRUDOperations.)
Public method | DeleteAsync | (Inherited from ICRUDOperations.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | ExecuteWithoutFetch | (Inherited from ICRUDOperations.)
Public method | ExecuteWithoutFetchAsync | (Inherited from ICRUDOperations.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Public method | GetSchema | (Inherited from ICRUDOperations.)
Public method | GetSchemaAsync | (Inherited from ICRUDOperations.)
Public method | Insert | (Inherited from ICRUDOperations.)
Public method | InsertAsync | (Inherited from ICRUDOperations.)
Public method | Load | (Inherited from ICRUDOperations.)
Public method | LoadAsync | (Inherited from ICRUDOperations.)
Public method | LoadOneRow | (Inherited from ICRUDOperations.)
Public method | LoadOneRowAsync | (Inherited from ICRUDOperations.)
Public method | LoadOneRowset | (Inherited from ICRUDOperations.)
Public method | LoadOneRowsetAsync | (Inherited from ICRUDOperations.)
Public method | MakeScriptQueryHandler |
Public method | OpenCursor | (Inherited from ICRUDOperations.)
Public method | OpenCursorAsync | (Inherited from ICRUDOperations.)
Public method | Save | (Inherited from ICRUDOperations.)
Public method | SaveAsync | (Inherited from ICRUDOperations.)
Public method | TestConnection | Tests connection and throws an exception if connection could not be established (Inherited from IDataStore.)
Public method | Update | (Inherited from ICRUDOperations.)
Public method | UpdateAsync | (Inherited from ICRUDOperations.)
Public method | Upsert | (Inherited from ICRUDOperations.)
Public method | UpsertAsync | (Inherited from ICRUDOperations.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | LoadEnumerable TRow | Loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadEnumerableAsync TRow | Async version - loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadRow TRow | Loads one row cast per Query(T) or null (Defined by DataUtils.)
Public Extension Method | LoadRowAsync TRow | Async version - loads one row cast per Query(T) or null (Defined by DataUtils.)
Back to Top
See Also
ICRUDDataStoreImplementation Interface
NFX.DataAccess.CRUD Namespace


ICRUDDataStoreImplementation.MakeScriptQueryHandler Method

ICRUDDataStoreImplementation MakeScriptQueryHandler Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
CRUDQueryHandler MakeScriptQueryHandler(
    QuerySource querySource
)
CRUDQueryHandler MakeScriptQueryHandler(
    QuerySource querySource
)
Function MakeScriptQueryHandler (
    querySource As QuerySource
) As CRUDQueryHandler
Function MakeScriptQueryHandler (
    querySource As QuerySource
) As CRUDQueryHandler
CRUDQueryHandler^ MakeScriptQueryHandler(
    QuerySource^ querySource
)
CRUDQueryHandler^ MakeScriptQueryHandler(
    QuerySource^ querySource
)
abstract MakeScriptQueryHandler :
        querySource : QuerySource -> CRUDQueryHandler
abstract MakeScriptQueryHandler :
        querySource : QuerySource -> CRUDQueryHandler

Parameters

querySource
Type: NFX.DataAccess.CRUD QuerySource

Return Value

Type: CRUDQueryHandler
See Also
ICRUDDataStoreImplementation Interface
ICRUDDataStoreImplementation Members
NFX.DataAccess.CRUD Namespace


ICRUDDataStoreImplementation Properties

ICRUDDataStoreImplementation Properties NFX Class Library

The ICRUDDataStoreImplementation type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | LogLevel | Defines log level for data stores (Inherited from IDataStoreImplementation.)
Public property | QueryResolver | Reolver that turns query into handler (Inherited from ICRUDDataStore.)
Public property | ScriptFileSuffix | Returns default script file suffix, which some providers may use to locate script files i.e. for MySql: ".my.sql" which gets added to script files like so: name.[suffix].[script ext (i.e. sql)]. This name should uniquely identify the provider (Inherited from ICRUDDataStore.)
Public property | StoreType | Provides classification for the underlying store (Inherited from ICRUDDataStore.)
Public property | SupportsTransactions | Returns true when backend supports transactions. Even if false returned, CRUDDatastore supports CRUDTransaction return from BeginTransaction() in which case statements may not be sent to destination until a call to Commit() (Inherited from ICRUDTransactionOperations.)
Public property | SupportsTrueAsynchrony | Returns true when backend supports true asynchronous operations, such as the ones that do not create extra threads/empty tasks (Inherited from ICRUDOperations.)
Public property | TargetName | Returns the name of the underlying store technology, i.e. "ORACLE". This property is used by some metadata-based validation logic which is target-dependent (Inherited from IDataStore.)
Back to Top
See Also
ICRUDDataStoreImplementation Interface
NFX.DataAccess.CRUD Namespace


ICRUDOperations Interface

ICRUDOperations Interface NFX Class Library

Describes an entity that performs single (not in transaction/batch)CRUD operations

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ICRUDOperations
public interface ICRUDOperations
Public Interface ICRUDOperations
Public Interface ICRUDOperations
public interface class ICRUDOperations
public interface class ICRUDOperations
type ICRUDOperations =  interface end
type ICRUDOperations =  interface end
See Also
ICRUDOperations Members
NFX.DataAccess.CRUD Namespace


ICRUDOperations Members

ICRUDOperations Members NFX Class Library

The ICRUDOperations type exposes the following members.
Methods
 | Name | Description
Public method | Delete |
Public method | DeleteAsync |
Public method | ExecuteWithoutFetch |
Public method | ExecuteWithoutFetchAsync |
Public method | GetSchema |
Public method | GetSchemaAsync |
Public method | Insert |
Public method | InsertAsync |
Public method | Load |
Public method | LoadAsync |
Public method | LoadOneRow |
Public method | LoadOneRowAsync |
Public method | LoadOneRowset |
Public method | LoadOneRowsetAsync |
Public method | OpenCursor |
Public method | OpenCursorAsync |
Public method | Save |
Public method | SaveAsync |
Public method | Update |
Public method | UpdateAsync |
Public method | Upsert |
Public method | UpsertAsync |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | LoadEnumerable TRow | Loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadEnumerableAsync TRow | Async version - loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadRow TRow | Loads one row cast per Query(T) or null (Defined by DataUtils.)
Public Extension Method | LoadRowAsync TRow | Async version - loads one row cast per Query(T) or null (Defined by DataUtils.)
Back to Top
Properties
 | Name | Description
Public property | SupportsTrueAsynchrony | Returns true when backend supports true asynchronous operations, such as the ones that do not create extra threads/empty tasks
Back to Top
See Also
ICRUDOperations Interface
NFX.DataAccess.CRUD Namespace


ICRUDOperations Methods

ICRUDOperations Methods NFX Class Library

The ICRUDOperations type exposes the following members.
Methods
 | Name | Description
Public method | Delete |
Public method | DeleteAsync |
Public method | ExecuteWithoutFetch |
Public method | ExecuteWithoutFetchAsync |
Public method | GetSchema |
Public method | GetSchemaAsync |
Public method | Insert |
Public method | InsertAsync |
Public method | Load |
Public method | LoadAsync |
Public method | LoadOneRow |
Public method | LoadOneRowAsync |
Public method | LoadOneRowset |
Public method | LoadOneRowsetAsync |
Public method | OpenCursor |
Public method | OpenCursorAsync |
Public method | Save |
Public method | SaveAsync |
Public method | Update |
Public method | UpdateAsync |
Public method | Upsert |
Public method | UpsertAsync |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | LoadEnumerable TRow | Loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadEnumerableAsync TRow | Async version - loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadRow TRow | Loads one row cast per Query(T) or null (Defined by DataUtils.)
Public Extension Method | LoadRowAsync TRow | Async version - loads one row cast per Query(T) or null (Defined by DataUtils.)
Back to Top
See Also
ICRUDOperations Interface
NFX.DataAccess.CRUD Namespace


ICRUDOperations.Delete Method

ICRUDOperations Delete Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int Delete(
    Row row,
    IDataStoreKey key = null
)
int Delete(
    Row row,
    IDataStoreKey key = null
)
Function Delete (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Integer
Function Delete (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Integer
int Delete(
    Row^ row,
    IDataStoreKey^ key = nullptr
)
int Delete(
    Row^ row,
    IDataStoreKey^ key = nullptr
)
abstract Delete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int
abstract Delete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey

Return Value

Type: Online Int32
See Also
ICRUDOperations Interface
ICRUDOperations Members
NFX.DataAccess.CRUD Namespace


ICRUDOperations.DeleteAsync Method

ICRUDOperations DeleteAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Task<int> DeleteAsync(
    Row row,
    IDataStoreKey key = null
)
Task<int> DeleteAsync(
    Row row,
    IDataStoreKey key = null
)
Function DeleteAsync (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Task(Of Integer)
Function DeleteAsync (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Task(Of Integer)
Task<int>^ DeleteAsync(
    Row^ row,
    IDataStoreKey^ key = nullptr
)
Task<int>^ DeleteAsync(
    Row^ row,
    IDataStoreKey^ key = nullptr
)
abstract DeleteAsync :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> Task<int>
abstract DeleteAsync :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey

Return Value

Type: Online Task Online Int32
See Also
ICRUDOperations Interface
ICRUDOperations Members
NFX.DataAccess.CRUD Namespace


ICRUDOperations.ExecuteWithoutFetch Method

ICRUDOperations ExecuteWithoutFetch Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int ExecuteWithoutFetch(
    params Query[] queries
)
int ExecuteWithoutFetch(
    params Query[] queries
)
Function ExecuteWithoutFetch (
    ParamArray queries As Query()
) As Integer
Function ExecuteWithoutFetch (
    ParamArray queries As Query()
) As Integer
int ExecuteWithoutFetch(
    ... array<Query^>^ queries
)
int ExecuteWithoutFetch(
    ... array<Query^>^ queries
)
abstract ExecuteWithoutFetch :
        queries : Query[] -> int
abstract ExecuteWithoutFetch :
        queries : Query[] -> int

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Int32
See Also
ICRUDOperations Interface
ICRUDOperations Members
NFX.DataAccess.CRUD Namespace


ICRUDOperations.ExecuteWithoutFetchAsync Method

ICRUDOperations ExecuteWithoutFetchAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Task<int> ExecuteWithoutFetchAsync(
    params Query[] queries
)
Task<int> ExecuteWithoutFetchAsync(
    params Query[] queries
)
Function ExecuteWithoutFetchAsync (
    ParamArray queries As Query()
) As Task(Of Integer)
Function ExecuteWithoutFetchAsync (
    ParamArray queries As Query()
) As Task(Of Integer)
Task<int>^ ExecuteWithoutFetchAsync(
    ... array<Query^>^ queries
)
Task<int>^ ExecuteWithoutFetchAsync(
    ... array<Query^>^ queries
)
abstract ExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>
abstract ExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Online Int32
See Also
ICRUDOperations Interface
ICRUDOperations Members
NFX.DataAccess.CRUD Namespace


ICRUDOperations.GetSchema Method

ICRUDOperations GetSchema Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Schema GetSchema(
    Query query
)
Schema GetSchema(
    Query query
)
Function GetSchema (
    query As Query
) As Schema
Function GetSchema (
    query As Query
) As Schema
Schema^ GetSchema(
    Query^ query
)
Schema^ GetSchema(
    Query^ query
)
abstract GetSchema :
        query : Query -> Schema
abstract GetSchema :
        query : Query -> Schema

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Schema
See Also
ICRUDOperations Interface
ICRUDOperations Members
NFX.DataAccess.CRUD Namespace


ICRUDOperations.GetSchemaAsync Method

ICRUDOperations GetSchemaAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Task<Schema> GetSchemaAsync(
    Query query
)
Task<Schema> GetSchemaAsync(
    Query query
)
Function GetSchemaAsync (
    query As Query
) As Task(Of Schema)
Function GetSchemaAsync (
    query As Query
) As Task(Of Schema)
Task<Schema^>^ GetSchemaAsync(
    Query^ query
)
Task<Schema^>^ GetSchemaAsync(
    Query^ query
)
abstract GetSchemaAsync :
        query : Query -> Task<Schema>
abstract GetSchemaAsync :
        query : Query -> Task<Schema>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Schema
See Also
ICRUDOperations Interface
ICRUDOperations Members
NFX.DataAccess.CRUD Namespace


ICRUDOperations.Insert Method

ICRUDOperations Insert Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int Insert(
    Row row,
    FieldFilterFunc filter = null
)
int Insert(
    Row row,
    FieldFilterFunc filter = null
)
Function Insert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Function Insert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
int Insert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
int Insert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
abstract Insert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
abstract Insert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32
See Also
ICRUDOperations Interface
ICRUDOperations Members
NFX.DataAccess.CRUD Namespace


ICRUDOperations.InsertAsync Method

ICRUDOperations InsertAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Task<int> InsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
Task<int> InsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
Function InsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
Function InsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
Task<int>^ InsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
Task<int>^ InsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
abstract InsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
abstract InsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Task Online Int32
See Also
ICRUDOperations Interface
ICRUDOperations Members
NFX.DataAccess.CRUD Namespace


ICRUDOperations.Load Method

ICRUDOperations Load Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
List<RowsetBase> Load(
    params Query[] queries
)
List<RowsetBase> Load(
    params Query[] queries
)
Function Load (
    ParamArray queries As Query()
) As List(Of RowsetBase)
Function Load (
    ParamArray queries As Query()
) As List(Of RowsetBase)
List<RowsetBase^>^ Load(
    ... array<Query^>^ queries
)
List<RowsetBase^>^ Load(
    ... array<Query^>^ queries
)
abstract Load :
        queries : Query[] -> List<RowsetBase>
abstract Load :
        queries : Query[] -> List<RowsetBase>

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online List RowsetBase
See Also
ICRUDOperations Interface
ICRUDOperations Members
NFX.DataAccess.CRUD Namespace


ICRUDOperations.LoadAsync Method

ICRUDOperations LoadAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Task<List<RowsetBase>> LoadAsync(
    params Query[] queries
)
Task<List<RowsetBase>> LoadAsync(
    params Query[] queries
)
Function LoadAsync (
    ParamArray queries As Query()
) As Task(Of List(Of RowsetBase))
Function LoadAsync (
    ParamArray queries As Query()
) As Task(Of List(Of RowsetBase))
Task<List<RowsetBase^>^>^ LoadAsync(
    ... array<Query^>^ queries
)
Task<List<RowsetBase^>^>^ LoadAsync(
    ... array<Query^>^ queries
)
abstract LoadAsync :
        queries : Query[] -> Task<List<RowsetBase>>
abstract LoadAsync :
        queries : Query[] -> Task<List<RowsetBase>>

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Online List RowsetBase
See Also
ICRUDOperations Interface
ICRUDOperations Members
NFX.DataAccess.CRUD Namespace


ICRUDOperations.LoadOneRow Method

ICRUDOperations LoadOneRow Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Row LoadOneRow(
    Query query
)
Row LoadOneRow(
    Query query
)
Function LoadOneRow (
    query As Query
) As Row
Function LoadOneRow (
    query As Query
) As Row
Row^ LoadOneRow(
    Query^ query
)
Row^ LoadOneRow(
    Query^ query
)
abstract LoadOneRow :
        query : Query -> Row
abstract LoadOneRow :
        query : Query -> Row

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Row
See Also
ICRUDOperations Interface
ICRUDOperations Members
NFX.DataAccess.CRUD Namespace


ICRUDOperations.LoadOneRowAsync Method

ICRUDOperations LoadOneRowAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Task<Row> LoadOneRowAsync(
    Query query
)
Task<Row> LoadOneRowAsync(
    Query query
)
Function LoadOneRowAsync (
    query As Query
) As Task(Of Row)
Function LoadOneRowAsync (
    query As Query
) As Task(Of Row)
Task<Row^>^ LoadOneRowAsync(
    Query^ query
)
Task<Row^>^ LoadOneRowAsync(
    Query^ query
)
abstract LoadOneRowAsync :
        query : Query -> Task<Row>
abstract LoadOneRowAsync :
        query : Query -> Task<Row>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Row
See Also
ICRUDOperations Interface
ICRUDOperations Members
NFX.DataAccess.CRUD Namespace


ICRUDOperations.LoadOneRowset Method

ICRUDOperations LoadOneRowset Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
RowsetBase LoadOneRowset(
    Query query
)
RowsetBase LoadOneRowset(
    Query query
)
Function LoadOneRowset (
    query As Query
) As RowsetBase
Function LoadOneRowset (
    query As Query
) As RowsetBase
RowsetBase^ LoadOneRowset(
    Query^ query
)
RowsetBase^ LoadOneRowset(
    Query^ query
)
abstract LoadOneRowset :
        query : Query -> RowsetBase
abstract LoadOneRowset :
        query : Query -> RowsetBase

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: RowsetBase
See Also
ICRUDOperations Interface
ICRUDOperations Members
NFX.DataAccess.CRUD Namespace


ICRUDOperations.LoadOneRowsetAsync Method

ICRUDOperations LoadOneRowsetAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Task<RowsetBase> LoadOneRowsetAsync(
    Query query
)
Task<RowsetBase> LoadOneRowsetAsync(
    Query query
)
Function LoadOneRowsetAsync (
    query As Query
) As Task(Of RowsetBase)
Function LoadOneRowsetAsync (
    query As Query
) As Task(Of RowsetBase)
Task<RowsetBase^>^ LoadOneRowsetAsync(
    Query^ query
)
Task<RowsetBase^>^ LoadOneRowsetAsync(
    Query^ query
)
abstract LoadOneRowsetAsync :
        query : Query -> Task<RowsetBase>
abstract LoadOneRowsetAsync :
        query : Query -> Task<RowsetBase>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task RowsetBase
See Also
ICRUDOperations Interface
ICRUDOperations Members
NFX.DataAccess.CRUD Namespace


ICRUDOperations.OpenCursor Method

ICRUDOperations OpenCursor Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Cursor OpenCursor(
    Query query
)
Cursor OpenCursor(
    Query query
)
Function OpenCursor (
    query As Query
) As Cursor
Function OpenCursor (
    query As Query
) As Cursor
Cursor^ OpenCursor(
    Query^ query
)
Cursor^ OpenCursor(
    Query^ query
)
abstract OpenCursor :
        query : Query -> Cursor
abstract OpenCursor :
        query : Query -> Cursor

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Cursor
See Also
ICRUDOperations Interface
ICRUDOperations Members
NFX.DataAccess.CRUD Namespace


ICRUDOperations.OpenCursorAsync Method

ICRUDOperations OpenCursorAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Task<Cursor> OpenCursorAsync(
    Query query
)
Task<Cursor> OpenCursorAsync(
    Query query
)
Function OpenCursorAsync (
    query As Query
) As Task(Of Cursor)
Function OpenCursorAsync (
    query As Query
) As Task(Of Cursor)
Task<Cursor^>^ OpenCursorAsync(
    Query^ query
)
Task<Cursor^>^ OpenCursorAsync(
    Query^ query
)
abstract OpenCursorAsync :
        query : Query -> Task<Cursor>
abstract OpenCursorAsync :
        query : Query -> Task<Cursor>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Cursor
See Also
ICRUDOperations Interface
ICRUDOperations Members
NFX.DataAccess.CRUD Namespace


ICRUDOperations.Save Method

ICRUDOperations Save Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int Save(
    params RowsetBase[] rowsets
)
int Save(
    params RowsetBase[] rowsets
)
Function Save (
    ParamArray rowsets As RowsetBase()
) As Integer
Function Save (
    ParamArray rowsets As RowsetBase()
) As Integer
int Save(
    ... array<RowsetBase^>^ rowsets
)
int Save(
    ... array<RowsetBase^>^ rowsets
)
abstract Save :
        rowsets : RowsetBase[] -> int
abstract Save :
        rowsets : RowsetBase[] -> int

Parameters

rowsets
Type: NFX.DataAccess.CRUD RowsetBase

Return Value

Type: Online Int32
See Also
ICRUDOperations Interface
ICRUDOperations Members
NFX.DataAccess.CRUD Namespace


ICRUDOperations.SaveAsync Method

ICRUDOperations SaveAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Task<int> SaveAsync(
    params RowsetBase[] rowsets
)
Task<int> SaveAsync(
    params RowsetBase[] rowsets
)
Function SaveAsync (
    ParamArray rowsets As RowsetBase()
) As Task(Of Integer)
Function SaveAsync (
    ParamArray rowsets As RowsetBase()
) As Task(Of Integer)
Task<int>^ SaveAsync(
    ... array<RowsetBase^>^ rowsets
)
Task<int>^ SaveAsync(
    ... array<RowsetBase^>^ rowsets
)
abstract SaveAsync :
        rowsets : RowsetBase[] -> Task<int>
abstract SaveAsync :
        rowsets : RowsetBase[] -> Task<int>

Parameters

rowsets
Type: NFX.DataAccess.CRUD RowsetBase

Return Value

Type: Online Task Online Int32
See Also
ICRUDOperations Interface
ICRUDOperations Members
NFX.DataAccess.CRUD Namespace


ICRUDOperations.Update Method

ICRUDOperations Update Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int Update(
    Row row,
    IDataStoreKey key = null,
    FieldFilterFunc filter = null
)
int Update(
    Row row,
    IDataStoreKey key = null,
    FieldFilterFunc filter = null
)
Function Update (
    row As Row,
    Optional key As IDataStoreKey = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Function Update (
    row As Row,
    Optional key As IDataStoreKey = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
int Update(
    Row^ row,
    IDataStoreKey^ key = nullptr,
    FieldFilterFunc^ filter = nullptr
)
int Update(
    Row^ row,
    IDataStoreKey^ key = nullptr,
    FieldFilterFunc^ filter = nullptr
)
abstract Update :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> int
abstract Update :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32
See Also
ICRUDOperations Interface
ICRUDOperations Members
NFX.DataAccess.CRUD Namespace


ICRUDOperations.UpdateAsync Method

ICRUDOperations UpdateAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Task<int> UpdateAsync(
    Row row,
    IDataStoreKey key = null,
    FieldFilterFunc filter = null
)
Task<int> UpdateAsync(
    Row row,
    IDataStoreKey key = null,
    FieldFilterFunc filter = null
)
Function UpdateAsync (
    row As Row,
    Optional key As IDataStoreKey = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
Function UpdateAsync (
    row As Row,
    Optional key As IDataStoreKey = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
Task<int>^ UpdateAsync(
    Row^ row,
    IDataStoreKey^ key = nullptr,
    FieldFilterFunc^ filter = nullptr
)
Task<int>^ UpdateAsync(
    Row^ row,
    IDataStoreKey^ key = nullptr,
    FieldFilterFunc^ filter = nullptr
)
abstract UpdateAsync :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> Task<int>
abstract UpdateAsync :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Task Online Int32
See Also
ICRUDOperations Interface
ICRUDOperations Members
NFX.DataAccess.CRUD Namespace


ICRUDOperations.Upsert Method

ICRUDOperations Upsert Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int Upsert(
    Row row,
    FieldFilterFunc filter = null
)
int Upsert(
    Row row,
    FieldFilterFunc filter = null
)
Function Upsert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Function Upsert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
int Upsert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
int Upsert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
abstract Upsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
abstract Upsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32
See Also
ICRUDOperations Interface
ICRUDOperations Members
NFX.DataAccess.CRUD Namespace


ICRUDOperations.UpsertAsync Method

ICRUDOperations UpsertAsync Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Task<int> UpsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
Task<int> UpsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
Function UpsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
Function UpsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
Task<int>^ UpsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
Task<int>^ UpsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
abstract UpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
abstract UpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Task Online Int32
See Also
ICRUDOperations Interface
ICRUDOperations Members
NFX.DataAccess.CRUD Namespace


ICRUDOperations Properties

ICRUDOperations Properties NFX Class Library

The ICRUDOperations type exposes the following members.
Properties
 | Name | Description
Public property | SupportsTrueAsynchrony | Returns true when backend supports true asynchronous operations, such as the ones that do not create extra threads/empty tasks
Back to Top
See Also
ICRUDOperations Interface
NFX.DataAccess.CRUD Namespace


ICRUDOperations.SupportsTrueAsynchrony Property

ICRUDOperations SupportsTrueAsynchrony Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns true when backend supports true asynchronous operations, such as the ones that do not create extra threads/empty tasks

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool SupportsTrueAsynchrony { get; }
bool SupportsTrueAsynchrony { get; }
ReadOnly Property SupportsTrueAsynchrony As Boolean
    Get
ReadOnly Property SupportsTrueAsynchrony As Boolean
    Get
property bool SupportsTrueAsynchrony {
    bool get ();
}
property bool SupportsTrueAsynchrony {
    bool get ();
}
abstract SupportsTrueAsynchrony : bool with get
abstract SupportsTrueAsynchrony : bool with get

Property Value

Type: Online Boolean
See Also
ICRUDOperations Interface
ICRUDOperations Members
NFX.DataAccess.CRUD Namespace


ICRUDQueryExecutionContext Interface

ICRUDQueryExecutionContext Interface NFX Class Library

Represents a context (such as Sql Server connection + transaction scope, or Hadoop connect string etc.) for query execution. This is a marker interface implemented by particular providers

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ICRUDQueryExecutionContext
public interface ICRUDQueryExecutionContext
Public Interface ICRUDQueryExecutionContext
Public Interface ICRUDQueryExecutionContext
public interface class ICRUDQueryExecutionContext
public interface class ICRUDQueryExecutionContext
type ICRUDQueryExecutionContext =  interface end
type ICRUDQueryExecutionContext =  interface end
See Also
NFX.DataAccess.CRUD Namespace


ICRUDQueryResolver Interface

ICRUDQueryResolver Interface NFX Class Library

Represents a class that resolves Query into suitable handler that can execute it

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ICRUDQueryResolver : IConfigurable
public interface ICRUDQueryResolver : IConfigurable
Public Interface ICRUDQueryResolver
    Inherits IConfigurable
Public Interface ICRUDQueryResolver
    Inherits IConfigurable
public interface class ICRUDQueryResolver : IConfigurable
public interface class ICRUDQueryResolver : IConfigurable
type ICRUDQueryResolver =
    interface
        interface IConfigurable
    end
type ICRUDQueryResolver =
    interface
        interface IConfigurable
    end
See Also
ICRUDQueryResolver Members
NFX.DataAccess.CRUD Namespace


ICRUDQueryResolver Members

ICRUDQueryResolver Members NFX Class Library

The ICRUDQueryResolver type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | RegisterHandlerLocation | Registers handler location. The Resolver must be not started yet. This method is NOT thread safe
Public method | Resolve | Retrieves a handler for supplied query. The implementation must be thread-safe
Public method | UnregisterHandlerLocation | Unregisters handler location returning true if it was found and removed. The Resolve must be not started yet. This method is NOT thread safe
Back to Top
Properties
 | Name | Description
Public property | HandlerLocations |
Public property | Handlers |
Public property | ScriptAssembly |
Back to Top
See Also
ICRUDQueryResolver Interface
NFX.DataAccess.CRUD Namespace


ICRUDQueryResolver Methods

ICRUDQueryResolver Methods NFX Class Library

The ICRUDQueryResolver type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | RegisterHandlerLocation | Registers handler location. The Resolver must be not started yet. This method is NOT thread safe
Public method | Resolve | Retrieves a handler for supplied query. The implementation must be thread-safe
Public method | UnregisterHandlerLocation | Unregisters handler location returning true if it was found and removed. The Resolve must be not started yet. This method is NOT thread safe
Back to Top
See Also
ICRUDQueryResolver Interface
NFX.DataAccess.CRUD Namespace


ICRUDQueryResolver.RegisterHandlerLocation Method

ICRUDQueryResolver RegisterHandlerLocation Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Registers handler location. The Resolver must be not started yet. This method is NOT thread safe

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void RegisterHandlerLocation(
    string location
)
void RegisterHandlerLocation(
    string location
)
Sub RegisterHandlerLocation (
    location As String
)
Sub RegisterHandlerLocation (
    location As String
)
void RegisterHandlerLocation(
    String^ location
)
void RegisterHandlerLocation(
    String^ location
)
abstract RegisterHandlerLocation :
        location : string -> unit
abstract RegisterHandlerLocation :
        location : string -> unit

Parameters

location
Type: Online System String
See Also
ICRUDQueryResolver Interface
ICRUDQueryResolver Members
NFX.DataAccess.CRUD Namespace


ICRUDQueryResolver.Resolve Method

ICRUDQueryResolver Resolve Method NFX Class Library

Retrieves a handler for supplied query. The implementation must be thread-safe

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
CRUDQueryHandler Resolve(
    Query query
)
CRUDQueryHandler Resolve(
    Query query
)
Function Resolve (
    query As Query
) As CRUDQueryHandler
Function Resolve (
    query As Query
) As CRUDQueryHandler
CRUDQueryHandler^ Resolve(
    Query^ query
)
CRUDQueryHandler^ Resolve(
    Query^ query
)
abstract Resolve :
        query : Query -> CRUDQueryHandler
abstract Resolve :
        query : Query -> CRUDQueryHandler

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: CRUDQueryHandler
See Also
ICRUDQueryResolver Interface
ICRUDQueryResolver Members
NFX.DataAccess.CRUD Namespace


ICRUDQueryResolver.UnregisterHandlerLocation Method

ICRUDQueryResolver UnregisterHandlerLocation Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Unregisters handler location returning true if it was found and removed. The Resolve must be not started yet. This method is NOT thread safe

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool UnregisterHandlerLocation(
    string location
)
bool UnregisterHandlerLocation(
    string location
)
Function UnregisterHandlerLocation (
    location As String
) As Boolean
Function UnregisterHandlerLocation (
    location As String
) As Boolean
bool UnregisterHandlerLocation(
    String^ location
)
bool UnregisterHandlerLocation(
    String^ location
)
abstract UnregisterHandlerLocation :
        location : string -> bool
abstract UnregisterHandlerLocation :
        location : string -> bool

Parameters

location
Type: Online System String

Return Value

Type: Online Boolean
See Also
ICRUDQueryResolver Interface
ICRUDQueryResolver Members
NFX.DataAccess.CRUD Namespace


ICRUDQueryResolver Properties

ICRUDQueryResolver Properties NFX Class Library

The ICRUDQueryResolver type exposes the following members.
Properties
 | Name | Description
Public property | HandlerLocations |
Public property | Handlers |
Public property | ScriptAssembly |
Back to Top
See Also
ICRUDQueryResolver Interface
NFX.DataAccess.CRUD Namespace


ICRUDQueryResolver.HandlerLocations Property

ICRUDQueryResolver HandlerLocations Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IList<string> HandlerLocations { get; }
IList<string> HandlerLocations { get; }
ReadOnly Property HandlerLocations As IList(Of String)
    Get
ReadOnly Property HandlerLocations As IList(Of String)
    Get
property IList<String^>^ HandlerLocations {
    IList<String^>^ get ();
}
property IList<String^>^ HandlerLocations {
    IList<String^>^ get ();
}
abstract HandlerLocations : IList<string> with get
abstract HandlerLocations : IList<string> with get

Property Value

Type: Online IList Online String
See Also
ICRUDQueryResolver Interface
ICRUDQueryResolver Members
NFX.DataAccess.CRUD Namespace


ICRUDQueryResolver.Handlers Property

ICRUDQueryResolver Handlers Property NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IRegistry<CRUDQueryHandler> Handlers { get; }
IRegistry<CRUDQueryHandler> Handlers { get; }
ReadOnly Property Handlers As IRegistry(Of CRUDQueryHandler)
    Get
ReadOnly Property Handlers As IRegistry(Of CRUDQueryHandler)
    Get
property IRegistry<CRUDQueryHandler^>^ Handlers {
    IRegistry<CRUDQueryHandler^>^ get ();
}
property IRegistry<CRUDQueryHandler^>^ Handlers {
    IRegistry<CRUDQueryHandler^>^ get ();
}
abstract Handlers : IRegistry<CRUDQueryHandler> with get
abstract Handlers : IRegistry<CRUDQueryHandler> with get

Property Value

Type: IRegistry CRUDQueryHandler
See Also
ICRUDQueryResolver Interface
ICRUDQueryResolver Members
NFX.DataAccess.CRUD Namespace


ICRUDQueryResolver.ScriptAssembly Property

ICRUDQueryResolver ScriptAssembly Property NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string ScriptAssembly { get; set; }
string ScriptAssembly { get; set; }
Property ScriptAssembly As String
    Get
    Set
Property ScriptAssembly As String
    Get
    Set
property String^ ScriptAssembly {
    String^ get ();
    void set (String^ value);
}
property String^ ScriptAssembly {
    String^ get ();
    void set (String^ value);
}
abstract ScriptAssembly : string with get, set
abstract ScriptAssembly : string with get, set

Property Value

Type: Online String
See Also
ICRUDQueryResolver Interface
ICRUDQueryResolver Members
NFX.DataAccess.CRUD Namespace


ICRUDTransactionOperations Interface

ICRUDTransactionOperations Interface NFX Class Library

Describes an entity that performs single (not in transaction/batch)CRUD operations

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ICRUDTransactionOperations
public interface ICRUDTransactionOperations
Public Interface ICRUDTransactionOperations
Public Interface ICRUDTransactionOperations
public interface class ICRUDTransactionOperations
public interface class ICRUDTransactionOperations
type ICRUDTransactionOperations =  interface end
type ICRUDTransactionOperations =  interface end
See Also
ICRUDTransactionOperations Members
NFX.DataAccess.CRUD Namespace


ICRUDTransactionOperations Members

ICRUDTransactionOperations Members NFX Class Library

The ICRUDTransactionOperations type exposes the following members.
Methods
 | Name | Description
Public method | BeginTransaction | Returns a transaction object for backend. Even if backend does not support transactions internally, CRUDTransactions save changes into the store on commit only
Public method | BeginTransactionAsync | Returns a transaction object for backend. Even if backend does not support transactions internally, CRUDTransactions save changes into the store on commit only
Back to Top
Properties
 | Name | Description
Public property | SupportsTransactions | Returns true when backend supports transactions. Even if false returned, CRUDDatastore supports CRUDTransaction return from BeginTransaction() in which case statements may not be sent to destination until a call to Commit()
Back to Top
See Also
ICRUDTransactionOperations Interface
NFX.DataAccess.CRUD Namespace


ICRUDTransactionOperations Methods

ICRUDTransactionOperations Methods NFX Class Library

The ICRUDTransactionOperations type exposes the following members.
Methods
 | Name | Description
Public method | BeginTransaction | Returns a transaction object for backend. Even if backend does not support transactions internally, CRUDTransactions save changes into the store on commit only
Public method | BeginTransactionAsync | Returns a transaction object for backend. Even if backend does not support transactions internally, CRUDTransactions save changes into the store on commit only
Back to Top
See Also
ICRUDTransactionOperations Interface
NFX.DataAccess.CRUD Namespace


ICRUDTransactionOperations.BeginTransaction Method

ICRUDTransactionOperations BeginTransaction Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns a transaction object for backend. Even if backend does not support transactions internally, CRUDTransactions save changes into the store on commit only

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
CRUDTransaction BeginTransaction(
    IsolationLevel iso = IsolationLevel.ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior.CommitOnDispose
)
CRUDTransaction BeginTransaction(
    IsolationLevel iso = IsolationLevel.ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior.CommitOnDispose
)
Function BeginTransaction (
    Optional iso As IsolationLevel = IsolationLevel.ReadCommitted,
    Optional behavior As TransactionDisposeBehavior = TransactionDisposeBehavior.CommitOnDispose
) As CRUDTransaction
Function BeginTransaction (
    Optional iso As IsolationLevel = IsolationLevel.ReadCommitted,
    Optional behavior As TransactionDisposeBehavior = TransactionDisposeBehavior.CommitOnDispose
) As CRUDTransaction
CRUDTransaction^ BeginTransaction(
    IsolationLevel iso = IsolationLevel::ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior::CommitOnDispose
)
CRUDTransaction^ BeginTransaction(
    IsolationLevel iso = IsolationLevel::ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior::CommitOnDispose
)
abstract BeginTransaction :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> CRUDTransaction
abstract BeginTransaction :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> CRUDTransaction

Parameters

iso (Optional)
Type: Online System.Data IsolationLevel
behavior (Optional)
Type: NFX.DataAccess.CRUD TransactionDisposeBehavior

Return Value

Type: CRUDTransaction
See Also
ICRUDTransactionOperations Interface
ICRUDTransactionOperations Members
NFX.DataAccess.CRUD Namespace


ICRUDTransactionOperations.BeginTransactionAsync Method

ICRUDTransactionOperations BeginTransactionAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns a transaction object for backend. Even if backend does not support transactions internally, CRUDTransactions save changes into the store on commit only

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Task<CRUDTransaction> BeginTransactionAsync(
    IsolationLevel iso = IsolationLevel.ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior.CommitOnDispose
)
Task<CRUDTransaction> BeginTransactionAsync(
    IsolationLevel iso = IsolationLevel.ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior.CommitOnDispose
)
Function BeginTransactionAsync (
    Optional iso As IsolationLevel = IsolationLevel.ReadCommitted,
    Optional behavior As TransactionDisposeBehavior = TransactionDisposeBehavior.CommitOnDispose
) As Task(Of CRUDTransaction)
Function BeginTransactionAsync (
    Optional iso As IsolationLevel = IsolationLevel.ReadCommitted,
    Optional behavior As TransactionDisposeBehavior = TransactionDisposeBehavior.CommitOnDispose
) As Task(Of CRUDTransaction)
Task<CRUDTransaction^>^ BeginTransactionAsync(
    IsolationLevel iso = IsolationLevel::ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior::CommitOnDispose
)
Task<CRUDTransaction^>^ BeginTransactionAsync(
    IsolationLevel iso = IsolationLevel::ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior::CommitOnDispose
)
abstract BeginTransactionAsync :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> Task<CRUDTransaction>
abstract BeginTransactionAsync :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> Task<CRUDTransaction>

Parameters

iso (Optional)
Type: Online System.Data IsolationLevel
behavior (Optional)
Type: NFX.DataAccess.CRUD TransactionDisposeBehavior

Return Value

Type: Online Task CRUDTransaction
See Also
ICRUDTransactionOperations Interface
ICRUDTransactionOperations Members
NFX.DataAccess.CRUD Namespace


ICRUDTransactionOperations Properties

ICRUDTransactionOperations Properties NFX Class Library

The ICRUDTransactionOperations type exposes the following members.
Properties
 | Name | Description
Public property | SupportsTransactions | Returns true when backend supports transactions. Even if false returned, CRUDDatastore supports CRUDTransaction return from BeginTransaction() in which case statements may not be sent to destination until a call to Commit()
Back to Top
See Also
ICRUDTransactionOperations Interface
NFX.DataAccess.CRUD Namespace


ICRUDTransactionOperations.SupportsTransactions Property

ICRUDTransactionOperations SupportsTransactions Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns true when backend supports transactions. Even if false returned, CRUDDatastore supports CRUDTransaction return from BeginTransaction() in which case statements may not be sent to destination until a call to Commit()

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool SupportsTransactions { get; }
bool SupportsTransactions { get; }
ReadOnly Property SupportsTransactions As Boolean
    Get
ReadOnly Property SupportsTransactions As Boolean
    Get
property bool SupportsTransactions {
    bool get ();
}
property bool SupportsTransactions {
    bool get ();
}
abstract SupportsTransactions : bool with get
abstract SupportsTransactions : bool with get

Property Value

Type: Online Boolean
See Also
ICRUDTransactionOperations Interface
ICRUDTransactionOperations Members
NFX.DataAccess.CRUD Namespace


iListReadOnly Structure

iListReadOnly Structure NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal struct iListReadOnly : IList,
    ICollection, IEnumerable
internal struct iListReadOnly : IList,
    ICollection, IEnumerable
Friend Structure iListReadOnly
    Implements IList, ICollection, IEnumerable
Friend Structure iListReadOnly
    Implements IList, ICollection, IEnumerable
internal value class iListReadOnly : IList,
    ICollection, IEnumerable
internal value class iListReadOnly : IList,
    ICollection, IEnumerable
[<SealedAttribute>]
type iListReadOnly =
    struct
        interface IList
        interface ICollection
        interface IEnumerable
    end
[<SealedAttribute>]
type iListReadOnly =
    struct
        interface IList
        interface ICollection
        interface IEnumerable
    end
See Also
iListReadOnly Members
NFX.DataAccess.CRUD Namespace


iListReadOnly Members

iListReadOnly Members NFX Class Library

The iListReadOnly type exposes the following members.
Constructors
 | Name | Description
Public method | iListReadOnly | Initializes a new instance of the iListReadOnly class
Back to Top
Methods
 | Name | Description
Public method | Add |
Public method | Clear |
Public method | Contains |
Public method | CopyTo |
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IndexOf |
Public method | Insert |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove |
Public method | RemoveAt |
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Count |
Public property | IsFixedSize |
Public property | IsReadOnly |
Public property | IsSynchronized |
Public property | Item |
Public property | SyncRoot |
Back to Top
See Also
iListReadOnly Structure
NFX.DataAccess.CRUD Namespace


iListReadOnly Constructor

iListReadOnly Constructor NFX Class Library

Initializes a new instance of the iListReadOnly class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public iListReadOnly(
    List<Row> data
)
public iListReadOnly(
    List<Row> data
)
Public Sub New (
    data As List(Of Row)
)
Public Sub New (
    data As List(Of Row)
)
public:
iListReadOnly(
    List<Row^>^ data
)
public:
iListReadOnly(
    List<Row^>^ data
)
new :
        data : List<Row> -> iListReadOnly
new :
        data : List<Row> -> iListReadOnly

Parameters

data
Type: Online System.Collections.Generic List Row
See Also
iListReadOnly Structure
iListReadOnly Members
NFX.DataAccess.CRUD Namespace


iListReadOnly Methods

iListReadOnly Methods NFX Class Library

The iListReadOnly type exposes the following members.
Methods
 | Name | Description
Public method | Add |
Public method | Clear |
Public method | Contains |
Public method | CopyTo |
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IndexOf |
Public method | Insert |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove |
Public method | RemoveAt |
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
iListReadOnly Structure
NFX.DataAccess.CRUD Namespace


iListReadOnly.Add Method

iListReadOnly Add Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Add(
    Object value
)
public int Add(
    Object value
)
Public Function Add (
    value As Object
) As Integer
Public Function Add (
    value As Object
) As Integer
public:
virtual int Add(
    Object^ value
) sealed
public:
virtual int Add(
    Object^ value
) sealed
abstract Add :
        value : Object -> int
override Add :
        value : Object -> int
abstract Add :
        value : Object -> int
override Add :
        value : Object -> int

Parameters

value
Type: Online System Object

Return Value

Type: Online Int32

Implements

Online IList Add(Object)
See Also
iListReadOnly Structure
iListReadOnly Members
NFX.DataAccess.CRUD Namespace


iListReadOnly.Clear Method

iListReadOnly Clear Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
virtual void Clear() sealed
public:
virtual void Clear() sealed
abstract Clear : unit -> unit
override Clear : unit -> unit
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

Online IList Clear
See Also
iListReadOnly Structure
iListReadOnly Members
NFX.DataAccess.CRUD Namespace


iListReadOnly.Contains Method

iListReadOnly Contains Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Contains(
    Object value
)
public bool Contains(
    Object value
)
Public Function Contains (
    value As Object
) As Boolean
Public Function Contains (
    value As Object
) As Boolean
public:
virtual bool Contains(
    Object^ value
) sealed
public:
virtual bool Contains(
    Object^ value
) sealed
abstract Contains :
        value : Object -> bool
override Contains :
        value : Object -> bool
abstract Contains :
        value : Object -> bool
override Contains :
        value : Object -> bool

Parameters

value
Type: Online System Object

Return Value

Type: Online Boolean

Implements

Online IList Contains(Object)
See Also
iListReadOnly Structure
iListReadOnly Members
NFX.DataAccess.CRUD Namespace


iListReadOnly.CopyTo Method

iListReadOnly CopyTo Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CopyTo(
    Array array,
    int index
)
public void CopyTo(
    Array array,
    int index
)
Public Sub CopyTo (
    array As Array,
    index As Integer
)
Public Sub CopyTo (
    array As Array,
    index As Integer
)
public:
virtual void CopyTo(
    Array^ array,
    int index
) sealed
public:
virtual void CopyTo(
    Array^ array,
    int index
) sealed
abstract CopyTo :
        array : Array *
        index : int -> unit
override CopyTo :
        array : Array *
        index : int -> unit
abstract CopyTo :
        array : Array *
        index : int -> unit
override CopyTo :
        array : Array *
        index : int -> unit

Parameters

array
Type: Online System Array
index
Type: Online System Int32

Implements

Online ICollection CopyTo(Array, Int32)
See Also
iListReadOnly Structure
iListReadOnly Members
NFX.DataAccess.CRUD Namespace


iListReadOnly.GetEnumerator Method

iListReadOnly GetEnumerator Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator GetEnumerator()
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed
public:
virtual IEnumerator^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
iListReadOnly Structure
iListReadOnly Members
NFX.DataAccess.CRUD Namespace


iListReadOnly.IndexOf Method

iListReadOnly IndexOf Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int IndexOf(
    Object value
)
public int IndexOf(
    Object value
)
Public Function IndexOf (
    value As Object
) As Integer
Public Function IndexOf (
    value As Object
) As Integer
public:
virtual int IndexOf(
    Object^ value
) sealed
public:
virtual int IndexOf(
    Object^ value
) sealed
abstract IndexOf :
        value : Object -> int
override IndexOf :
        value : Object -> int
abstract IndexOf :
        value : Object -> int
override IndexOf :
        value : Object -> int

Parameters

value
Type: Online System Object

Return Value

Type: Online Int32

Implements

Online IList IndexOf(Object)
See Also
iListReadOnly Structure
iListReadOnly Members
NFX.DataAccess.CRUD Namespace


iListReadOnly.Insert Method

iListReadOnly Insert Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Insert(
    int index,
    Object value
)
public void Insert(
    int index,
    Object value
)
Public Sub Insert (
    index As Integer,
    value As Object
)
Public Sub Insert (
    index As Integer,
    value As Object
)
public:
virtual void Insert(
    int index,
    Object^ value
) sealed
public:
virtual void Insert(
    int index,
    Object^ value
) sealed
abstract Insert :
        index : int *
        value : Object -> unit
override Insert :
        index : int *
        value : Object -> unit
abstract Insert :
        index : int *
        value : Object -> unit
override Insert :
        index : int *
        value : Object -> unit

Parameters

index
Type: Online System Int32
value
Type: Online System Object

Implements

Online IList Insert(Int32, Object)
See Also
iListReadOnly Structure
iListReadOnly Members
NFX.DataAccess.CRUD Namespace


iListReadOnly.Remove Method

iListReadOnly Remove Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Remove(
    Object value
)
public void Remove(
    Object value
)
Public Sub Remove (
    value As Object
)
Public Sub Remove (
    value As Object
)
public:
virtual void Remove(
    Object^ value
) sealed
public:
virtual void Remove(
    Object^ value
) sealed
abstract Remove :
        value : Object -> unit
override Remove :
        value : Object -> unit
abstract Remove :
        value : Object -> unit
override Remove :
        value : Object -> unit

Parameters

value
Type: Online System Object

Implements

Online IList Remove(Object)
See Also
iListReadOnly Structure
iListReadOnly Members
NFX.DataAccess.CRUD Namespace


iListReadOnly.RemoveAt Method

iListReadOnly RemoveAt Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RemoveAt(
    int index
)
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)
Public Sub RemoveAt (
    index As Integer
)
public:
virtual void RemoveAt(
    int index
) sealed
public:
virtual void RemoveAt(
    int index
) sealed
abstract RemoveAt :
        index : int -> unit
override RemoveAt :
        index : int -> unit
abstract RemoveAt :
        index : int -> unit
override RemoveAt :
        index : int -> unit

Parameters

index
Type: Online System Int32

Implements

Online IList RemoveAt(Int32)
See Also
iListReadOnly Structure
iListReadOnly Members
NFX.DataAccess.CRUD Namespace


iListReadOnly Properties

iListReadOnly Properties NFX Class Library

The iListReadOnly type exposes the following members.
Properties
 | Name | Description
Public property | Count |
Public property | IsFixedSize |
Public property | IsReadOnly |
Public property | IsSynchronized |
Public property | Item |
Public property | SyncRoot |
Back to Top
See Also
iListReadOnly Structure
NFX.DataAccess.CRUD Namespace


iListReadOnly.Count Property

iListReadOnly Count Property NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
public:
virtual property int Count {
    int get () sealed;
}
abstract Count : int with get
override Count : int with get
abstract Count : int with get
override Count : int with get

Property Value

Type: Online Int32

Implements

Online ICollection Count
See Also
iListReadOnly Structure
iListReadOnly Members
NFX.DataAccess.CRUD Namespace


iListReadOnly.IsFixedSize Property

iListReadOnly IsFixedSize Property NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsFixedSize { get; }
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
virtual property bool IsFixedSize {
    bool get () sealed;
}
public:
virtual property bool IsFixedSize {
    bool get () sealed;
}
abstract IsFixedSize : bool with get
override IsFixedSize : bool with get
abstract IsFixedSize : bool with get
override IsFixedSize : bool with get

Property Value

Type: Online Boolean

Implements

Online IList IsFixedSize
See Also
iListReadOnly Structure
iListReadOnly Members
NFX.DataAccess.CRUD Namespace


iListReadOnly.IsReadOnly Property

iListReadOnly IsReadOnly Property NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsReadOnly { get; }
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get

Property Value

Type: Online Boolean

Implements

Online IList IsReadOnly
See Also
iListReadOnly Structure
iListReadOnly Members
NFX.DataAccess.CRUD Namespace


iListReadOnly.IsSynchronized Property

iListReadOnly IsSynchronized Property NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsSynchronized { get; }
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
virtual property bool IsSynchronized {
    bool get () sealed;
}
public:
virtual property bool IsSynchronized {
    bool get () sealed;
}
abstract IsSynchronized : bool with get
override IsSynchronized : bool with get
abstract IsSynchronized : bool with get
override IsSynchronized : bool with get

Property Value

Type: Online Boolean

Implements

Online ICollection IsSynchronized
See Also
iListReadOnly Structure
iListReadOnly Members
NFX.DataAccess.CRUD Namespace


iListReadOnly.Item Property

iListReadOnly Item Property NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object this[
    int index
] { get; set; }
public Object this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As Object
    Get
    Set
Public Default Property Item (
    index As Integer
) As Object
    Get
    Set
public:
virtual property Object^ default[int index] {
    Object^ get (int index) sealed;
    void set (int index, Object^ value) sealed;
}
public:
virtual property Object^ default[int index] {
    Object^ get (int index) sealed;
    void set (int index, Object^ value) sealed;
}
abstract Item : Object with get, set
override Item : Object with get, set
abstract Item : Object with get, set
override Item : Object with get, set

Parameters

index
Type: Online System Int32

Property Value

Type: Online Object

Implements

Online IList Item Int32
See Also
iListReadOnly Structure
iListReadOnly Members
NFX.DataAccess.CRUD Namespace


iListReadOnly.SyncRoot Property

iListReadOnly SyncRoot Property NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object SyncRoot { get; }
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
Public ReadOnly Property SyncRoot As Object
    Get
public:
virtual property Object^ SyncRoot {
    Object^ get () sealed;
}
public:
virtual property Object^ SyncRoot {
    Object^ get () sealed;
}
abstract SyncRoot : Object with get
override SyncRoot : Object with get
abstract SyncRoot : Object with get
override SyncRoot : Object with get

Property Value

Type: Online Object

Implements

Online ICollection SyncRoot
See Also
iListReadOnly Structure
iListReadOnly Members
NFX.DataAccess.CRUD Namespace


IValidatable Interface

IValidatable Interface NFX Class Library

Denotes an entity that supports validation

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IValidatable
public interface IValidatable
Public Interface IValidatable
Public Interface IValidatable
public interface class IValidatable
public interface class IValidatable
type IValidatable =  interface end
type IValidatable =  interface end
See Also
IValidatable Members
NFX.DataAccess.CRUD Namespace


IValidatable Members

IValidatable Members NFX Class Library

The IValidatable type exposes the following members.
Methods
 | Name | Description
Public method | Validate | Validates entity state per particular named target, for performance reasons returns validation exception (instead of throwing)
Back to Top
See Also
IValidatable Interface
NFX.DataAccess.CRUD Namespace


IValidatable Methods

IValidatable Methods NFX Class Library

The IValidatable type exposes the following members.
Methods
 | Name | Description
Public method | Validate | Validates entity state per particular named target, for performance reasons returns validation exception (instead of throwing)
Back to Top
See Also
IValidatable Interface
NFX.DataAccess.CRUD Namespace


IValidatable.Validate Method

IValidatable Validate Method NFX Class Library

Validates entity state per particular named target, for performance reasons returns validation exception (instead of throwing)

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Exception Validate(
    string targetName
)
Exception Validate(
    string targetName
)
Function Validate (
    targetName As String
) As Exception
Function Validate (
    targetName As String
) As Exception
Exception^ Validate(
    String^ targetName
)
Exception^ Validate(
    String^ targetName
)
abstract Validate :
        targetName : string -> Exception
abstract Validate :
        targetName : string -> Exception

Parameters

targetName
Type: Online System String

Return Value

Type: Online Exception
See Also
IValidatable Interface
IValidatable Members
NFX.DataAccess.CRUD Namespace


JSONMappings Class

JSONMappings Class NFX Class Library

Facilitates mapping of CRUD/CLR types/values to JSON and back to CLR/CRUD
Inheritance Hierarchy
Online System Object
NFX.DataAccess.CRUD JSONMappings

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class JSONMappings
public static class JSONMappings
Public NotInheritable Class JSONMappings
Public NotInheritable Class JSONMappings
public ref class JSONMappings abstract sealed
public ref class JSONMappings abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type JSONMappings =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type JSONMappings =  class end
See Also
JSONMappings Members
NFX.DataAccess.CRUD Namespace


JSONMappings Members

JSONMappings Members NFX Class Library

The JSONMappings type exposes the following members.
Methods
Name | Description
MapCLRTypeToJSON |
MapJSONTypeToCLR |
Back to Top
Fields
Name | Description
JTP_ARRAY |
JTP_MAP |
JTP_OBJECT |
JTP_STRING |
Back to Top
See Also
JSONMappings Class
NFX.DataAccess.CRUD Namespace


JSONMappings Fields

JSONMappings Fields NFX Class Library

The JSONMappings type exposes the following members.
Fields
Name | Description
JTP_ARRAY |
JTP_MAP |
JTP_OBJECT |
JTP_STRING |
Back to Top
See Also
JSONMappings Class
NFX.DataAccess.CRUD Namespace


JSONMappings.JTP_ARRAY Field

JSONMappings JTP_ARRAY Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string JTP_ARRAY
public const string JTP_ARRAY
Public Const JTP_ARRAY As String
Public Const JTP_ARRAY As String
public:
literal String^ JTP_ARRAY
public:
literal String^ JTP_ARRAY
static val mutable JTP_ARRAY: string
static val mutable JTP_ARRAY: string

Field Value

Type: Online String
See Also
JSONMappings Class
JSONMappings Members
NFX.DataAccess.CRUD Namespace


JSONMappings.JTP_MAP Field

JSONMappings JTP_MAP Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string JTP_MAP
public const string JTP_MAP
Public Const JTP_MAP As String
Public Const JTP_MAP As String
public:
literal String^ JTP_MAP
public:
literal String^ JTP_MAP
static val mutable JTP_MAP: string
static val mutable JTP_MAP: string

Field Value

Type: Online String
See Also
JSONMappings Class
JSONMappings Members
NFX.DataAccess.CRUD Namespace


JSONMappings.JTP_OBJECT Field

JSONMappings JTP_OBJECT Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string JTP_OBJECT
public const string JTP_OBJECT
Public Const JTP_OBJECT As String
Public Const JTP_OBJECT As String
public:
literal String^ JTP_OBJECT
public:
literal String^ JTP_OBJECT
static val mutable JTP_OBJECT: string
static val mutable JTP_OBJECT: string

Field Value

Type: Online String
See Also
JSONMappings Class
JSONMappings Members
NFX.DataAccess.CRUD Namespace


JSONMappings.JTP_STRING Field

JSONMappings JTP_STRING Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string JTP_STRING
public const string JTP_STRING
Public Const JTP_STRING As String
Public Const JTP_STRING As String
public:
literal String^ JTP_STRING
public:
literal String^ JTP_STRING
static val mutable JTP_STRING: string
static val mutable JTP_STRING: string

Field Value

Type: Online String
See Also
JSONMappings Class
JSONMappings Members
NFX.DataAccess.CRUD Namespace


JSONMappings Methods

JSONMappings Methods NFX Class Library

The JSONMappings type exposes the following members.
Methods
Name | Description
MapCLRTypeToJSON |
MapJSONTypeToCLR |
Back to Top
See Also
JSONMappings Class
NFX.DataAccess.CRUD Namespace


JSONMappings.MapCLRTypeToJSON Method

JSONMappings MapCLRTypeToJSON Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string MapCLRTypeToJSON(
    Type type,
    out bool isNullable
)
public static string MapCLRTypeToJSON(
    Type type,
    out bool isNullable
)
Public Shared Function MapCLRTypeToJSON (
    type As Type,
    <OutAttribute> ByRef isNullable As Boolean
) As String
Public Shared Function MapCLRTypeToJSON (
    type As Type,
    <OutAttribute> ByRef isNullable As Boolean
) As String
public:
static String^ MapCLRTypeToJSON(
    Type^ type,
    [OutAttribute] bool% isNullable
)
public:
static String^ MapCLRTypeToJSON(
    Type^ type,
    [OutAttribute] bool% isNullable
)
static member MapCLRTypeToJSON :
        type : Type *
        isNullable : bool byref -> string
static member MapCLRTypeToJSON :
        type : Type *
        isNullable : bool byref -> string

Parameters

type
Type: Online System Type
isNullable
Type: Online System Boolean

Return Value

Type: Online String
See Also
JSONMappings Class
JSONMappings Members
NFX.DataAccess.CRUD Namespace


JSONMappings.MapJSONTypeToCLR Method

JSONMappings MapJSONTypeToCLR Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Type MapJSONTypeToCLR(
    string type,
    bool isNullable
)
public static Type MapJSONTypeToCLR(
    string type,
    bool isNullable
)
Public Shared Function MapJSONTypeToCLR (
    type As String,
    isNullable As Boolean
) As Type
Public Shared Function MapJSONTypeToCLR (
    type As String,
    isNullable As Boolean
) As Type
public:
static Type^ MapJSONTypeToCLR(
    String^ type,
    bool isNullable
)
public:
static Type^ MapJSONTypeToCLR(
    String^ type,
    bool isNullable
)
static member MapJSONTypeToCLR :
        type : string *
        isNullable : bool -> Type
static member MapJSONTypeToCLR :
        type : string *
        isNullable : bool -> Type

Parameters

type
Type: Online System String
isNullable
Type: Online System Boolean

Return Value

Type: Online Type
See Also
JSONMappings Class
JSONMappings Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore Class

NotImplementedCRUDDataStore Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.DataAccess.CRUD NotImplementedCRUDDataStore

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class NotImplementedCRUDDataStore : ICRUDDataStoreImplementation,
    ICRUDDataStore, ICRUDOperations, ICRUDTransactionOperations, IDataStoreImplementation, IDataStore,
    IApplicationComponent, IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
public sealed class NotImplementedCRUDDataStore : ICRUDDataStoreImplementation,
    ICRUDDataStore, ICRUDOperations, ICRUDTransactionOperations, IDataStoreImplementation, IDataStore,
    IApplicationComponent, IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
Public NotInheritable Class NotImplementedCRUDDataStore
    Implements ICRUDDataStoreImplementation, ICRUDDataStore, ICRUDOperations, ICRUDTransactionOperations,
    IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
Public NotInheritable Class NotImplementedCRUDDataStore
    Implements ICRUDDataStoreImplementation, ICRUDDataStore, ICRUDOperations, ICRUDTransactionOperations,
    IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
public ref class NotImplementedCRUDDataStore sealed : ICRUDDataStoreImplementation,
    ICRUDDataStore, ICRUDOperations, ICRUDTransactionOperations, IDataStoreImplementation, IDataStore,
    IApplicationComponent, IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
public ref class NotImplementedCRUDDataStore sealed : ICRUDDataStoreImplementation,
    ICRUDDataStore, ICRUDOperations, ICRUDTransactionOperations, IDataStoreImplementation, IDataStore,
    IApplicationComponent, IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
[<SealedAttribute>]
type NotImplementedCRUDDataStore =
    class
        interface ICRUDDataStoreImplementation
        interface ICRUDDataStore
        interface ICRUDOperations
        interface ICRUDTransactionOperations
        interface IDataStoreImplementation
        interface IDataStore
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
[<SealedAttribute>]
type NotImplementedCRUDDataStore =
    class
        interface ICRUDDataStoreImplementation
        interface ICRUDDataStore
        interface ICRUDOperations
        interface ICRUDTransactionOperations
        interface IDataStoreImplementation
        interface IDataStore
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore Members

NotImplementedCRUDDataStore Members NFX Class Library

The NotImplementedCRUDDataStore type exposes the following members.
Constructors
 | Name | Description
Public method | NotImplementedCRUDDataStore | Initializes a new instance of the NotImplementedCRUDDataStore class
Back to Top
Methods
 | Name | Description
Public method | BeginTransaction |
Public method | BeginTransactionAsync |
Public method | Configure |
Public method | Delete |
Public method | DeleteAsync |
Public method | Dispose | Releases all resources used by the NotImplementedCRUDDataStore
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExecuteWithoutFetch |
Public method | ExecuteWithoutFetchAsync |
Public method | ExternalGetParameter |
Public method | ExternalParametersForGroups |
Public method | ExternalSetParameter |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSchema |
Public method | GetSchemaAsync |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Insert |
Public method | InsertAsync |
Public method | Load |
Public method | LoadAsync |
Public method | LoadOneRow |
Public method | LoadOneRowAsync |
Public method | LoadOneRowset |
Public method | LoadOneRowsetAsync |
Public method | MakeScriptQueryHandler |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenCursor |
Public method | OpenCursorAsync |
Public method | Save |
Public method | SaveAsync |
Public method | TestConnection |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Update |
Public method | UpdateAsync |
Public method | Upsert |
Public method | UpsertAsync |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | LoadEnumerable TRow | Loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadEnumerableAsync TRow | Async version - loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadRow TRow | Loads one row cast per Query(T) or null (Defined by DataUtils.)
Public Extension Method | LoadRowAsync TRow | Async version - loads one row cast per Query(T) or null (Defined by DataUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName |
Public property | ComponentDirector |
Public property | ComponentSID |
Public property | ExternalParameters |
Public property | InstrumentationEnabled |
Public property | LogLevel |
Public property | QueryResolver |
Public property | ScriptFileSuffix |
Public property | StoreType |
Public property | SupportsTransactions |
Public property | SupportsTrueAsynchrony |
Public property | TargetName |
Back to Top
See Also
NotImplementedCRUDDataStore Class
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore Constructor

NotImplementedCRUDDataStore Constructor NFX Class Library

Initializes a new instance of the NotImplementedCRUDDataStore class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NotImplementedCRUDDataStore()
public NotImplementedCRUDDataStore()
Public Sub New
Public Sub New
public:
NotImplementedCRUDDataStore()
public:
NotImplementedCRUDDataStore()
new : unit -> NotImplementedCRUDDataStore
new : unit -> NotImplementedCRUDDataStore
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore Methods

NotImplementedCRUDDataStore Methods NFX Class Library

The NotImplementedCRUDDataStore type exposes the following members.
Methods
 | Name | Description
Public method | BeginTransaction |
Public method | BeginTransactionAsync |
Public method | Configure |
Public method | Delete |
Public method | DeleteAsync |
Public method | Dispose |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExecuteWithoutFetch |
Public method | ExecuteWithoutFetchAsync |
Public method | ExternalGetParameter |
Public method | ExternalParametersForGroups |
Public method | ExternalSetParameter |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSchema |
Public method | GetSchemaAsync |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Insert |
Public method | InsertAsync |
Public method | Load |
Public method | LoadAsync |
Public method | LoadOneRow |
Public method | LoadOneRowAsync |
Public method | LoadOneRowset |
Public method | LoadOneRowsetAsync |
Public method | MakeScriptQueryHandler |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenCursor |
Public method | OpenCursorAsync |
Public method | Save |
Public method | SaveAsync |
Public method | TestConnection |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Update |
Public method | UpdateAsync |
Public method | Upsert |
Public method | UpsertAsync |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | LoadEnumerable TRow | Loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadEnumerableAsync TRow | Async version - loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadRow TRow | Loads one row cast per Query(T) or null (Defined by DataUtils.)
Public Extension Method | LoadRowAsync TRow | Async version - loads one row cast per Query(T) or null (Defined by DataUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NotImplementedCRUDDataStore Class
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.BeginTransaction Method

NotImplementedCRUDDataStore BeginTransaction Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDTransaction BeginTransaction(
    IsolationLevel iso = IsolationLevel.ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior.CommitOnDispose
)
public CRUDTransaction BeginTransaction(
    IsolationLevel iso = IsolationLevel.ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior.CommitOnDispose
)
Public Function BeginTransaction (
    Optional iso As IsolationLevel = IsolationLevel.ReadCommitted,
    Optional behavior As TransactionDisposeBehavior = TransactionDisposeBehavior.CommitOnDispose
) As CRUDTransaction
Public Function BeginTransaction (
    Optional iso As IsolationLevel = IsolationLevel.ReadCommitted,
    Optional behavior As TransactionDisposeBehavior = TransactionDisposeBehavior.CommitOnDispose
) As CRUDTransaction
public:
virtual CRUDTransaction^ BeginTransaction(
    IsolationLevel iso = IsolationLevel::ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior::CommitOnDispose
) sealed
public:
virtual CRUDTransaction^ BeginTransaction(
    IsolationLevel iso = IsolationLevel::ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior::CommitOnDispose
) sealed
abstract BeginTransaction :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> CRUDTransaction
override BeginTransaction :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> CRUDTransaction
abstract BeginTransaction :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> CRUDTransaction
override BeginTransaction :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> CRUDTransaction

Parameters

iso (Optional)
Type: Online System.Data IsolationLevel
behavior (Optional)
Type: NFX.DataAccess.CRUD TransactionDisposeBehavior

Return Value

Type: CRUDTransaction

Implements

ICRUDTransactionOperations BeginTransaction(IsolationLevel, TransactionDisposeBehavior)
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.BeginTransactionAsync Method

NotImplementedCRUDDataStore BeginTransactionAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<CRUDTransaction> BeginTransactionAsync(
    IsolationLevel iso = IsolationLevel.ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior.CommitOnDispose
)
public Task<CRUDTransaction> BeginTransactionAsync(
    IsolationLevel iso = IsolationLevel.ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior.CommitOnDispose
)
Public Function BeginTransactionAsync (
    Optional iso As IsolationLevel = IsolationLevel.ReadCommitted,
    Optional behavior As TransactionDisposeBehavior = TransactionDisposeBehavior.CommitOnDispose
) As Task(Of CRUDTransaction)
Public Function BeginTransactionAsync (
    Optional iso As IsolationLevel = IsolationLevel.ReadCommitted,
    Optional behavior As TransactionDisposeBehavior = TransactionDisposeBehavior.CommitOnDispose
) As Task(Of CRUDTransaction)
public:
virtual Task<CRUDTransaction^>^ BeginTransactionAsync(
    IsolationLevel iso = IsolationLevel::ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior::CommitOnDispose
) sealed
public:
virtual Task<CRUDTransaction^>^ BeginTransactionAsync(
    IsolationLevel iso = IsolationLevel::ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior::CommitOnDispose
) sealed
abstract BeginTransactionAsync :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> Task<CRUDTransaction>
override BeginTransactionAsync :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> Task<CRUDTransaction>
abstract BeginTransactionAsync :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> Task<CRUDTransaction>
override BeginTransactionAsync :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> Task<CRUDTransaction>

Parameters

iso (Optional)
Type: Online System.Data IsolationLevel
behavior (Optional)
Type: NFX.DataAccess.CRUD TransactionDisposeBehavior

Return Value

Type: Online Task CRUDTransaction

Implements

ICRUDTransactionOperations BeginTransactionAsync(IsolationLevel, TransactionDisposeBehavior)
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.Configure Method

NotImplementedCRUDDataStore Configure Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode node
)
public void Configure(
    IConfigSectionNode node
)
Public Sub Configure (
    node As IConfigSectionNode
)
Public Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.Delete Method

NotImplementedCRUDDataStore Delete Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Delete(
    Row row,
    IDataStoreKey key = null
)
public int Delete(
    Row row,
    IDataStoreKey key = null
)
Public Function Delete (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Integer
Public Function Delete (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Integer
public:
virtual int Delete(
    Row^ row,
    IDataStoreKey^ key = nullptr
) sealed
public:
virtual int Delete(
    Row^ row,
    IDataStoreKey^ key = nullptr
) sealed
abstract Delete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int
override Delete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int
abstract Delete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int
override Delete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey

Return Value

Type: Online Int32

Implements

ICRUDOperations Delete(Row, IDataStoreKey)
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.DeleteAsync Method

NotImplementedCRUDDataStore DeleteAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<int> DeleteAsync(
    Row row,
    IDataStoreKey key = null
)
public Task<int> DeleteAsync(
    Row row,
    IDataStoreKey key = null
)
Public Function DeleteAsync (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Task(Of Integer)
Public Function DeleteAsync (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Task(Of Integer)
public:
virtual Task<int>^ DeleteAsync(
    Row^ row,
    IDataStoreKey^ key = nullptr
) sealed
public:
virtual Task<int>^ DeleteAsync(
    Row^ row,
    IDataStoreKey^ key = nullptr
) sealed
abstract DeleteAsync :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> Task<int>
override DeleteAsync :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> Task<int>
abstract DeleteAsync :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> Task<int>
override DeleteAsync :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations DeleteAsync(Row, IDataStoreKey)
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.Dispose Method

NotImplementedCRUDDataStore Dispose Method NFX Class Library

Releases all resources used by the NotImplementedCRUDDataStore

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

Online IDisposable Dispose
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.ExecuteWithoutFetch Method

NotImplementedCRUDDataStore ExecuteWithoutFetch Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ExecuteWithoutFetch(
    params Query[] queries
)
public int ExecuteWithoutFetch(
    params Query[] queries
)
Public Function ExecuteWithoutFetch (
    ParamArray queries As Query()
) As Integer
Public Function ExecuteWithoutFetch (
    ParamArray queries As Query()
) As Integer
public:
virtual int ExecuteWithoutFetch(
    ... array<Query^>^ queries
) sealed
public:
virtual int ExecuteWithoutFetch(
    ... array<Query^>^ queries
) sealed
abstract ExecuteWithoutFetch :
        queries : Query[] -> int
override ExecuteWithoutFetch :
        queries : Query[] -> int
abstract ExecuteWithoutFetch :
        queries : Query[] -> int
override ExecuteWithoutFetch :
        queries : Query[] -> int

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Int32

Implements

ICRUDOperations ExecuteWithoutFetch( Query )
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.ExecuteWithoutFetchAsync Method

NotImplementedCRUDDataStore ExecuteWithoutFetchAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<int> ExecuteWithoutFetchAsync(
    params Query[] queries
)
public Task<int> ExecuteWithoutFetchAsync(
    params Query[] queries
)
Public Function ExecuteWithoutFetchAsync (
    ParamArray queries As Query()
) As Task(Of Integer)
Public Function ExecuteWithoutFetchAsync (
    ParamArray queries As Query()
) As Task(Of Integer)
public:
virtual Task<int>^ ExecuteWithoutFetchAsync(
    ... array<Query^>^ queries
) sealed
public:
virtual Task<int>^ ExecuteWithoutFetchAsync(
    ... array<Query^>^ queries
) sealed
abstract ExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>
override ExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>
abstract ExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>
override ExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations ExecuteWithoutFetchAsync( Query )
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.ExternalGetParameter Method

NotImplementedCRUDDataStore ExternalGetParameter Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
public bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
Public Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
Public Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
) sealed
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
) sealed
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalGetParameter(String, Object , String )
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.ExternalParametersForGroups Method

NotImplementedCRUDDataStore ExternalParametersForGroups Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
public IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
Public Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
Public Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
) sealed
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
) sealed
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>

Parameters

groups
Type: Online System String

Return Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParametersForGroups( String )
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.ExternalSetParameter Method

NotImplementedCRUDDataStore ExternalSetParameter Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
public bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
Public Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
Public Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
) sealed
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
) sealed
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalSetParameter(String, Object, String )
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.GetSchema Method

NotImplementedCRUDDataStore GetSchema Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Schema GetSchema(
    Query query
)
public Schema GetSchema(
    Query query
)
Public Function GetSchema (
    query As Query
) As Schema
Public Function GetSchema (
    query As Query
) As Schema
public:
virtual Schema^ GetSchema(
    Query^ query
) sealed
public:
virtual Schema^ GetSchema(
    Query^ query
) sealed
abstract GetSchema :
        query : Query -> Schema
override GetSchema :
        query : Query -> Schema
abstract GetSchema :
        query : Query -> Schema
override GetSchema :
        query : Query -> Schema

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Schema

Implements

ICRUDOperations GetSchema(Query)
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.GetSchemaAsync Method

NotImplementedCRUDDataStore GetSchemaAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<Schema> GetSchemaAsync(
    Query query
)
public Task<Schema> GetSchemaAsync(
    Query query
)
Public Function GetSchemaAsync (
    query As Query
) As Task(Of Schema)
Public Function GetSchemaAsync (
    query As Query
) As Task(Of Schema)
public:
virtual Task<Schema^>^ GetSchemaAsync(
    Query^ query
) sealed
public:
virtual Task<Schema^>^ GetSchemaAsync(
    Query^ query
) sealed
abstract GetSchemaAsync :
        query : Query -> Task<Schema>
override GetSchemaAsync :
        query : Query -> Task<Schema>
abstract GetSchemaAsync :
        query : Query -> Task<Schema>
override GetSchemaAsync :
        query : Query -> Task<Schema>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Schema

Implements

ICRUDOperations GetSchemaAsync(Query)
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.Insert Method

NotImplementedCRUDDataStore Insert Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Insert(
    Row row,
    FieldFilterFunc filter = null
)
public int Insert(
    Row row,
    FieldFilterFunc filter = null
)
Public Function Insert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Public Function Insert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
public:
virtual int Insert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) sealed
public:
virtual int Insert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) sealed
abstract Insert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override Insert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
abstract Insert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override Insert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32

Implements

ICRUDOperations Insert(Row, FieldFilterFunc)
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.InsertAsync Method

NotImplementedCRUDDataStore InsertAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<int> InsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
public Task<int> InsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
Public Function InsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
Public Function InsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
public:
virtual Task<int>^ InsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) sealed
public:
virtual Task<int>^ InsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) sealed
abstract InsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
override InsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
abstract InsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
override InsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations InsertAsync(Row, FieldFilterFunc)
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.Load Method

NotImplementedCRUDDataStore Load Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<RowsetBase> Load(
    params Query[] queries
)
public List<RowsetBase> Load(
    params Query[] queries
)
Public Function Load (
    ParamArray queries As Query()
) As List(Of RowsetBase)
Public Function Load (
    ParamArray queries As Query()
) As List(Of RowsetBase)
public:
virtual List<RowsetBase^>^ Load(
    ... array<Query^>^ queries
) sealed
public:
virtual List<RowsetBase^>^ Load(
    ... array<Query^>^ queries
) sealed
abstract Load :
        queries : Query[] -> List<RowsetBase>
override Load :
        queries : Query[] -> List<RowsetBase>
abstract Load :
        queries : Query[] -> List<RowsetBase>
override Load :
        queries : Query[] -> List<RowsetBase>

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online List RowsetBase

Implements

ICRUDOperations Load( Query )
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.LoadAsync Method

NotImplementedCRUDDataStore LoadAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<List<RowsetBase>> LoadAsync(
    params Query[] queries
)
public Task<List<RowsetBase>> LoadAsync(
    params Query[] queries
)
Public Function LoadAsync (
    ParamArray queries As Query()
) As Task(Of List(Of RowsetBase))
Public Function LoadAsync (
    ParamArray queries As Query()
) As Task(Of List(Of RowsetBase))
public:
virtual Task<List<RowsetBase^>^>^ LoadAsync(
    ... array<Query^>^ queries
) sealed
public:
virtual Task<List<RowsetBase^>^>^ LoadAsync(
    ... array<Query^>^ queries
) sealed
abstract LoadAsync :
        queries : Query[] -> Task<List<RowsetBase>>
override LoadAsync :
        queries : Query[] -> Task<List<RowsetBase>>
abstract LoadAsync :
        queries : Query[] -> Task<List<RowsetBase>>
override LoadAsync :
        queries : Query[] -> Task<List<RowsetBase>>

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Online List RowsetBase

Implements

ICRUDOperations LoadAsync( Query )
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.LoadOneRow Method

NotImplementedCRUDDataStore LoadOneRow Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Row LoadOneRow(
    Query query
)
public Row LoadOneRow(
    Query query
)
Public Function LoadOneRow (
    query As Query
) As Row
Public Function LoadOneRow (
    query As Query
) As Row
public:
virtual Row^ LoadOneRow(
    Query^ query
) sealed
public:
virtual Row^ LoadOneRow(
    Query^ query
) sealed
abstract LoadOneRow :
        query : Query -> Row
override LoadOneRow :
        query : Query -> Row
abstract LoadOneRow :
        query : Query -> Row
override LoadOneRow :
        query : Query -> Row

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Row

Implements

ICRUDOperations LoadOneRow(Query)
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.LoadOneRowAsync Method

NotImplementedCRUDDataStore LoadOneRowAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<Row> LoadOneRowAsync(
    Query query
)
public Task<Row> LoadOneRowAsync(
    Query query
)
Public Function LoadOneRowAsync (
    query As Query
) As Task(Of Row)
Public Function LoadOneRowAsync (
    query As Query
) As Task(Of Row)
public:
virtual Task<Row^>^ LoadOneRowAsync(
    Query^ query
) sealed
public:
virtual Task<Row^>^ LoadOneRowAsync(
    Query^ query
) sealed
abstract LoadOneRowAsync :
        query : Query -> Task<Row>
override LoadOneRowAsync :
        query : Query -> Task<Row>
abstract LoadOneRowAsync :
        query : Query -> Task<Row>
override LoadOneRowAsync :
        query : Query -> Task<Row>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Row

Implements

ICRUDOperations LoadOneRowAsync(Query)
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.LoadOneRowset Method

NotImplementedCRUDDataStore LoadOneRowset Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RowsetBase LoadOneRowset(
    Query query
)
public RowsetBase LoadOneRowset(
    Query query
)
Public Function LoadOneRowset (
    query As Query
) As RowsetBase
Public Function LoadOneRowset (
    query As Query
) As RowsetBase
public:
virtual RowsetBase^ LoadOneRowset(
    Query^ query
) sealed
public:
virtual RowsetBase^ LoadOneRowset(
    Query^ query
) sealed
abstract LoadOneRowset :
        query : Query -> RowsetBase
override LoadOneRowset :
        query : Query -> RowsetBase
abstract LoadOneRowset :
        query : Query -> RowsetBase
override LoadOneRowset :
        query : Query -> RowsetBase

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: RowsetBase

Implements

ICRUDOperations LoadOneRowset(Query)
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.LoadOneRowsetAsync Method

NotImplementedCRUDDataStore LoadOneRowsetAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<RowsetBase> LoadOneRowsetAsync(
    Query query
)
public Task<RowsetBase> LoadOneRowsetAsync(
    Query query
)
Public Function LoadOneRowsetAsync (
    query As Query
) As Task(Of RowsetBase)
Public Function LoadOneRowsetAsync (
    query As Query
) As Task(Of RowsetBase)
public:
virtual Task<RowsetBase^>^ LoadOneRowsetAsync(
    Query^ query
) sealed
public:
virtual Task<RowsetBase^>^ LoadOneRowsetAsync(
    Query^ query
) sealed
abstract LoadOneRowsetAsync :
        query : Query -> Task<RowsetBase>
override LoadOneRowsetAsync :
        query : Query -> Task<RowsetBase>
abstract LoadOneRowsetAsync :
        query : Query -> Task<RowsetBase>
override LoadOneRowsetAsync :
        query : Query -> Task<RowsetBase>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task RowsetBase

Implements

ICRUDOperations LoadOneRowsetAsync(Query)
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.MakeScriptQueryHandler Method

NotImplementedCRUDDataStore MakeScriptQueryHandler Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDQueryHandler MakeScriptQueryHandler(
    QuerySource querySource
)
public CRUDQueryHandler MakeScriptQueryHandler(
    QuerySource querySource
)
Public Function MakeScriptQueryHandler (
    querySource As QuerySource
) As CRUDQueryHandler
Public Function MakeScriptQueryHandler (
    querySource As QuerySource
) As CRUDQueryHandler
public:
virtual CRUDQueryHandler^ MakeScriptQueryHandler(
    QuerySource^ querySource
) sealed
public:
virtual CRUDQueryHandler^ MakeScriptQueryHandler(
    QuerySource^ querySource
) sealed
abstract MakeScriptQueryHandler :
        querySource : QuerySource -> CRUDQueryHandler
override MakeScriptQueryHandler :
        querySource : QuerySource -> CRUDQueryHandler
abstract MakeScriptQueryHandler :
        querySource : QuerySource -> CRUDQueryHandler
override MakeScriptQueryHandler :
        querySource : QuerySource -> CRUDQueryHandler

Parameters

querySource
Type: NFX.DataAccess.CRUD QuerySource

Return Value

Type: CRUDQueryHandler

Implements

ICRUDDataStoreImplementation MakeScriptQueryHandler(QuerySource)
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.OpenCursor Method

NotImplementedCRUDDataStore OpenCursor Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Cursor OpenCursor(
    Query query
)
public Cursor OpenCursor(
    Query query
)
Public Function OpenCursor (
    query As Query
) As Cursor
Public Function OpenCursor (
    query As Query
) As Cursor
public:
virtual Cursor^ OpenCursor(
    Query^ query
) sealed
public:
virtual Cursor^ OpenCursor(
    Query^ query
) sealed
abstract OpenCursor :
        query : Query -> Cursor
override OpenCursor :
        query : Query -> Cursor
abstract OpenCursor :
        query : Query -> Cursor
override OpenCursor :
        query : Query -> Cursor

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Cursor

Implements

ICRUDOperations OpenCursor(Query)
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.OpenCursorAsync Method

NotImplementedCRUDDataStore OpenCursorAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<Cursor> OpenCursorAsync(
    Query query
)
public Task<Cursor> OpenCursorAsync(
    Query query
)
Public Function OpenCursorAsync (
    query As Query
) As Task(Of Cursor)
Public Function OpenCursorAsync (
    query As Query
) As Task(Of Cursor)
public:
virtual Task<Cursor^>^ OpenCursorAsync(
    Query^ query
) sealed
public:
virtual Task<Cursor^>^ OpenCursorAsync(
    Query^ query
) sealed
abstract OpenCursorAsync :
        query : Query -> Task<Cursor>
override OpenCursorAsync :
        query : Query -> Task<Cursor>
abstract OpenCursorAsync :
        query : Query -> Task<Cursor>
override OpenCursorAsync :
        query : Query -> Task<Cursor>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Cursor

Implements

ICRUDOperations OpenCursorAsync(Query)
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.Save Method

NotImplementedCRUDDataStore Save Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Save(
    params RowsetBase[] rowsets
)
public int Save(
    params RowsetBase[] rowsets
)
Public Function Save (
    ParamArray rowsets As RowsetBase()
) As Integer
Public Function Save (
    ParamArray rowsets As RowsetBase()
) As Integer
public:
virtual int Save(
    ... array<RowsetBase^>^ rowsets
) sealed
public:
virtual int Save(
    ... array<RowsetBase^>^ rowsets
) sealed
abstract Save :
        rowsets : RowsetBase[] -> int
override Save :
        rowsets : RowsetBase[] -> int
abstract Save :
        rowsets : RowsetBase[] -> int
override Save :
        rowsets : RowsetBase[] -> int

Parameters

rowsets
Type: NFX.DataAccess.CRUD RowsetBase

Return Value

Type: Online Int32

Implements

ICRUDOperations Save( RowsetBase )
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.SaveAsync Method

NotImplementedCRUDDataStore SaveAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<int> SaveAsync(
    params RowsetBase[] rowsets
)
public Task<int> SaveAsync(
    params RowsetBase[] rowsets
)
Public Function SaveAsync (
    ParamArray rowsets As RowsetBase()
) As Task(Of Integer)
Public Function SaveAsync (
    ParamArray rowsets As RowsetBase()
) As Task(Of Integer)
public:
virtual Task<int>^ SaveAsync(
    ... array<RowsetBase^>^ rowsets
) sealed
public:
virtual Task<int>^ SaveAsync(
    ... array<RowsetBase^>^ rowsets
) sealed
abstract SaveAsync :
        rowsets : RowsetBase[] -> Task<int>
override SaveAsync :
        rowsets : RowsetBase[] -> Task<int>
abstract SaveAsync :
        rowsets : RowsetBase[] -> Task<int>
override SaveAsync :
        rowsets : RowsetBase[] -> Task<int>

Parameters

rowsets
Type: NFX.DataAccess.CRUD RowsetBase

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations SaveAsync( RowsetBase )
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.TestConnection Method

NotImplementedCRUDDataStore TestConnection Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void TestConnection()
public void TestConnection()
Public Sub TestConnection
Public Sub TestConnection
public:
virtual void TestConnection() sealed
public:
virtual void TestConnection() sealed
abstract TestConnection : unit -> unit
override TestConnection : unit -> unit
abstract TestConnection : unit -> unit
override TestConnection : unit -> unit

Implements

IDataStore TestConnection
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.Update Method

NotImplementedCRUDDataStore Update Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Update(
    Row row,
    IDataStoreKey key = null,
    FieldFilterFunc filter = null
)
public int Update(
    Row row,
    IDataStoreKey key = null,
    FieldFilterFunc filter = null
)
Public Function Update (
    row As Row,
    Optional key As IDataStoreKey = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Public Function Update (
    row As Row,
    Optional key As IDataStoreKey = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
public:
virtual int Update(
    Row^ row,
    IDataStoreKey^ key = nullptr,
    FieldFilterFunc^ filter = nullptr
) sealed
public:
virtual int Update(
    Row^ row,
    IDataStoreKey^ key = nullptr,
    FieldFilterFunc^ filter = nullptr
) sealed
abstract Update :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> int
override Update :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> int
abstract Update :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> int
override Update :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32

Implements

ICRUDOperations Update(Row, IDataStoreKey, FieldFilterFunc)
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.UpdateAsync Method

NotImplementedCRUDDataStore UpdateAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<int> UpdateAsync(
    Row row,
    IDataStoreKey key = null,
    FieldFilterFunc filter = null
)
public Task<int> UpdateAsync(
    Row row,
    IDataStoreKey key = null,
    FieldFilterFunc filter = null
)
Public Function UpdateAsync (
    row As Row,
    Optional key As IDataStoreKey = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
Public Function UpdateAsync (
    row As Row,
    Optional key As IDataStoreKey = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
public:
virtual Task<int>^ UpdateAsync(
    Row^ row,
    IDataStoreKey^ key = nullptr,
    FieldFilterFunc^ filter = nullptr
) sealed
public:
virtual Task<int>^ UpdateAsync(
    Row^ row,
    IDataStoreKey^ key = nullptr,
    FieldFilterFunc^ filter = nullptr
) sealed
abstract UpdateAsync :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> Task<int>
override UpdateAsync :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> Task<int>
abstract UpdateAsync :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> Task<int>
override UpdateAsync :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations UpdateAsync(Row, IDataStoreKey, FieldFilterFunc)
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.Upsert Method

NotImplementedCRUDDataStore Upsert Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Upsert(
    Row row,
    FieldFilterFunc filter = null
)
public int Upsert(
    Row row,
    FieldFilterFunc filter = null
)
Public Function Upsert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Public Function Upsert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
public:
virtual int Upsert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) sealed
public:
virtual int Upsert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) sealed
abstract Upsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override Upsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
abstract Upsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override Upsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32

Implements

ICRUDOperations Upsert(Row, FieldFilterFunc)
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.UpsertAsync Method

NotImplementedCRUDDataStore UpsertAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<int> UpsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
public Task<int> UpsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
Public Function UpsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
Public Function UpsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
public:
virtual Task<int>^ UpsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) sealed
public:
virtual Task<int>^ UpsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) sealed
abstract UpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
override UpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
abstract UpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
override UpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations UpsertAsync(Row, FieldFilterFunc)
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore Properties

NotImplementedCRUDDataStore Properties NFX Class Library

The NotImplementedCRUDDataStore type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName |
Public property | ComponentDirector |
Public property | ComponentSID |
Public property | ExternalParameters |
Public property | InstrumentationEnabled |
Public property | LogLevel |
Public property | QueryResolver |
Public property | ScriptFileSuffix |
Public property | StoreType |
Public property | SupportsTransactions |
Public property | SupportsTrueAsynchrony |
Public property | TargetName |
Back to Top
See Also
NotImplementedCRUDDataStore Class
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.ComponentCommonName Property

NotImplementedCRUDDataStore ComponentCommonName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ComponentCommonName { get; }
public string ComponentCommonName { get; }
Public ReadOnly Property ComponentCommonName As String
    Get
Public ReadOnly Property ComponentCommonName As String
    Get
public:
virtual property String^ ComponentCommonName {
    String^ get () sealed;
}
public:
virtual property String^ ComponentCommonName {
    String^ get () sealed;
}
abstract ComponentCommonName : string with get
override ComponentCommonName : string with get
abstract ComponentCommonName : string with get
override ComponentCommonName : string with get

Property Value

Type: Online String

Implements

IApplicationComponent ComponentCommonName
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.ComponentDirector Property

NotImplementedCRUDDataStore ComponentDirector Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object ComponentDirector { get; }
public Object ComponentDirector { get; }
Public ReadOnly Property ComponentDirector As Object
    Get
Public ReadOnly Property ComponentDirector As Object
    Get
public:
virtual property Object^ ComponentDirector {
    Object^ get () sealed;
}
public:
virtual property Object^ ComponentDirector {
    Object^ get () sealed;
}
abstract ComponentDirector : Object with get
override ComponentDirector : Object with get
abstract ComponentDirector : Object with get
override ComponentDirector : Object with get

Property Value

Type: Online Object

Implements

IApplicationComponent ComponentDirector
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.ComponentSID Property

NotImplementedCRUDDataStore ComponentSID Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong ComponentSID { get; }
public ulong ComponentSID { get; }
Public ReadOnly Property ComponentSID As ULong
    Get
Public ReadOnly Property ComponentSID As ULong
    Get
public:
virtual property unsigned long long ComponentSID {
    unsigned long long get () sealed;
}
public:
virtual property unsigned long long ComponentSID {
    unsigned long long get () sealed;
}
abstract ComponentSID : uint64 with get
override ComponentSID : uint64 with get
abstract ComponentSID : uint64 with get
override ComponentSID : uint64 with get

Property Value

Type: Online UInt64

Implements

IApplicationComponent ComponentSID
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.ExternalParameters Property

NotImplementedCRUDDataStore ExternalParameters Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
public IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
Public ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
Public ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get () sealed;
}
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get () sealed;
}
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get

Property Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParameters
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.InstrumentationEnabled Property

NotImplementedCRUDDataStore InstrumentationEnabled Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool InstrumentationEnabled { get; set; }
public bool InstrumentationEnabled { get; set; }
Public Property InstrumentationEnabled As Boolean
    Get
    Set
Public Property InstrumentationEnabled As Boolean
    Get
    Set
public:
virtual property bool InstrumentationEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool InstrumentationEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract InstrumentationEnabled : bool with get, set
override InstrumentationEnabled : bool with get, set
abstract InstrumentationEnabled : bool with get, set
override InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentable InstrumentationEnabled
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.LogLevel Property

NotImplementedCRUDDataStore LogLevel Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StoreLogLevel LogLevel { get; set; }
public StoreLogLevel LogLevel { get; set; }
Public Property LogLevel As StoreLogLevel
    Get
    Set
Public Property LogLevel As StoreLogLevel
    Get
    Set
public:
virtual property StoreLogLevel LogLevel {
    StoreLogLevel get () sealed;
    void set (StoreLogLevel value) sealed;
}
public:
virtual property StoreLogLevel LogLevel {
    StoreLogLevel get () sealed;
    void set (StoreLogLevel value) sealed;
}
abstract LogLevel : StoreLogLevel with get, set
override LogLevel : StoreLogLevel with get, set
abstract LogLevel : StoreLogLevel with get, set
override LogLevel : StoreLogLevel with get, set

Property Value

Type: StoreLogLevel

Implements

IDataStoreImplementation LogLevel
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.QueryResolver Property

NotImplementedCRUDDataStore QueryResolver Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICRUDQueryResolver QueryResolver { get; }
public ICRUDQueryResolver QueryResolver { get; }
Public ReadOnly Property QueryResolver As ICRUDQueryResolver
    Get
Public ReadOnly Property QueryResolver As ICRUDQueryResolver
    Get
public:
virtual property ICRUDQueryResolver^ QueryResolver {
    ICRUDQueryResolver^ get () sealed;
}
public:
virtual property ICRUDQueryResolver^ QueryResolver {
    ICRUDQueryResolver^ get () sealed;
}
abstract QueryResolver : ICRUDQueryResolver with get
override QueryResolver : ICRUDQueryResolver with get
abstract QueryResolver : ICRUDQueryResolver with get
override QueryResolver : ICRUDQueryResolver with get

Property Value

Type: ICRUDQueryResolver

Implements

ICRUDDataStore QueryResolver
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.ScriptFileSuffix Property

NotImplementedCRUDDataStore ScriptFileSuffix Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ScriptFileSuffix { get; }
public string ScriptFileSuffix { get; }
Public ReadOnly Property ScriptFileSuffix As String
    Get
Public ReadOnly Property ScriptFileSuffix As String
    Get
public:
virtual property String^ ScriptFileSuffix {
    String^ get () sealed;
}
public:
virtual property String^ ScriptFileSuffix {
    String^ get () sealed;
}
abstract ScriptFileSuffix : string with get
override ScriptFileSuffix : string with get
abstract ScriptFileSuffix : string with get
override ScriptFileSuffix : string with get

Property Value

Type: Online String

Implements

ICRUDDataStore ScriptFileSuffix
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.StoreType Property

NotImplementedCRUDDataStore StoreType Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDDataStoreType StoreType { get; }
public CRUDDataStoreType StoreType { get; }
Public ReadOnly Property StoreType As CRUDDataStoreType
    Get
Public ReadOnly Property StoreType As CRUDDataStoreType
    Get
public:
virtual property CRUDDataStoreType StoreType {
    CRUDDataStoreType get () sealed;
}
public:
virtual property CRUDDataStoreType StoreType {
    CRUDDataStoreType get () sealed;
}
abstract StoreType : CRUDDataStoreType with get
override StoreType : CRUDDataStoreType with get
abstract StoreType : CRUDDataStoreType with get
override StoreType : CRUDDataStoreType with get

Property Value

Type: CRUDDataStoreType

Implements

ICRUDDataStore StoreType
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.SupportsTransactions Property

NotImplementedCRUDDataStore SupportsTransactions Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsTransactions { get; }
public bool SupportsTransactions { get; }
Public ReadOnly Property SupportsTransactions As Boolean
    Get
Public ReadOnly Property SupportsTransactions As Boolean
    Get
public:
virtual property bool SupportsTransactions {
    bool get () sealed;
}
public:
virtual property bool SupportsTransactions {
    bool get () sealed;
}
abstract SupportsTransactions : bool with get
override SupportsTransactions : bool with get
abstract SupportsTransactions : bool with get
override SupportsTransactions : bool with get

Property Value

Type: Online Boolean

Implements

ICRUDTransactionOperations SupportsTransactions
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.SupportsTrueAsynchrony Property

NotImplementedCRUDDataStore SupportsTrueAsynchrony Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsTrueAsynchrony { get; }
public bool SupportsTrueAsynchrony { get; }
Public ReadOnly Property SupportsTrueAsynchrony As Boolean
    Get
Public ReadOnly Property SupportsTrueAsynchrony As Boolean
    Get
public:
virtual property bool SupportsTrueAsynchrony {
    bool get () sealed;
}
public:
virtual property bool SupportsTrueAsynchrony {
    bool get () sealed;
}
abstract SupportsTrueAsynchrony : bool with get
override SupportsTrueAsynchrony : bool with get
abstract SupportsTrueAsynchrony : bool with get
override SupportsTrueAsynchrony : bool with get

Property Value

Type: Online Boolean

Implements

ICRUDOperations SupportsTrueAsynchrony
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


NotImplementedCRUDDataStore.TargetName Property

NotImplementedCRUDDataStore TargetName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string TargetName { get; }
public string TargetName { get; }
Public ReadOnly Property TargetName As String
    Get
Public ReadOnly Property TargetName As String
    Get
public:
virtual property String^ TargetName {
    String^ get () sealed;
}
public:
virtual property String^ TargetName {
    String^ get () sealed;
}
abstract TargetName : string with get
override TargetName : string with get
abstract TargetName : string with get
override TargetName : string with get

Property Value

Type: Online String

Implements

IDataStore TargetName
See Also
NotImplementedCRUDDataStore Class
NotImplementedCRUDDataStore Members
NFX.DataAccess.CRUD Namespace


Query Class

Query Class NFX Class Library

Defines a query sent into ICRUDDataStore implementor to retrieve data. A Query is a named bag of paremeters where every parameter has a name and the value.
Inheritance Hierarchy
Online System Object
Online System.Collections.Generic List Query Param
NFX.DataAccess.CRUD Query
NFX.DataAccess.CRUD Query TResultRow

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class Query : List<Query..::..Param>,
    IParameters, INamed, ICacheParams
[SerializableAttribute]
public class Query : List<Query..::..Param>,
    IParameters, INamed, ICacheParams
<SerializableAttribute>
Public Class Query
    Inherits List(Of Query..::..Param)
    Implements IParameters, INamed, ICacheParams
<SerializableAttribute>
Public Class Query
    Inherits List(Of Query..::..Param)
    Implements IParameters, INamed, ICacheParams
[SerializableAttribute]
public ref class Query : public List<Query..::..Param^>,
    IParameters, INamed, ICacheParams
[SerializableAttribute]
public ref class Query : public List<Query..::..Param^>,
    IParameters, INamed, ICacheParams
[<SerializableAttribute>]
type Query =
    class
        inherit List<Query..::..Param>
        interface IParameters
        interface INamed
        interface ICacheParams
    end
[<SerializableAttribute>]
type Query =
    class
        inherit List<Query..::..Param>
        interface IParameters
        interface INamed
        interface ICacheParams
    end
Remarks
Keep in mind that a particular datastore implementation may have to deal with hybrid distributed backends where different tables get stored in different repositories (different architectures i.e. NoSQL, HDFS, and some RDB SQL all in different locations), consequently one can not make assumption about writing SQLs of any kind in business code - that is what CRUD concept is for as it abstracts this into provider implementation. Architectural note: unlike Hibernate, LinqTo* and the like, the NFX.CRUD architecture purposely does not allow developers to write query scripts in higher-language like C#. This is because translation of such a high-level language abstraction into highly optimized SQL/(and or other script) per particular backend is impossible because such language can not incapsulate the optimization features of all possible data backends (i.e. ORACLE vs MongoDB vs Redis vs Files in HDFS). CRUD queries need to support selects from tables with millions of rows, or reads from collections with millions of documents, or parse millions of lines from files stored in Hadooop servers, thus every particular provider for every particular business app must expose custom-written queries by name. Those queries are usually highly optimized for particular platform (i.e. using db-specific hints, common table subexpressions, groupping sets etc.). Also, a provider may elect to SELECT * from a table named like Query object, when a hand-written script with such name is not found
See Also
Query Members
NFX.DataAccess.CRUD Namespace


Query Members

Query Members NFX Class Library

The Query type exposes the following members.
Constructors
 | Name | Description
Public method | Query(String, IDataStoreKey, Type) | Initializes a new instance of the Query class
Public method | Query(String, Type, Dictionary String, Object ) | Initializes a new instance of the Query class
Public method | Query(Nullable Guid , String, IDataStoreKey, Type) | Initializes a new instance of the Query class
Public method | Query(Nullable Guid , String, Type, Dictionary String, Object ) | Initializes a new instance of the Query class
Back to Top
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List Query Param .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List Query Param .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List Query Param .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List Query Param .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Query Param .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Query Param .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List Query Param .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List Query Param .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List Query Param .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List Query Param .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Query Param .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Query Param .)
Public method | Equals | (Overrides Online Object Equals(Object).)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List Query Param .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Query Param .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Query Param .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Query Param .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Query Param .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Query Param .)
Public method | FindParamByName |
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List Query Param .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List Query Param .)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List Query Param .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Query Param .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Query Param .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List Query Param .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List Query Param .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Query Param .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Query Param .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ParamByName |
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List Query Param .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Query Param .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List Query Param .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List Query Param .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List Query Param .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List Query Param .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List Query Param .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List Query Param .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List Query Param .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List Query Param .)
Public method | ToString | (Overrides Online Object ToString .)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List Query Param .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List Query Param .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | AllParameters |
Public property | CacheAbsentData | When true would cache the instance of AbsentData to signify the absence of data in the backend for key
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List Query Param .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List Query Param .)
Public property | Extra | Returns extra parameters that provider may need to render the query. May be null
Public property | Identity | Returns the identity of this instance, that is - an ID that UNIQUELY identifies the instance of this query including all of the names, parameters, values. This is needed for Equality comparison and cache lookup. The identity is either generated by .ctor or supplied to it if it is cached (i.e. in a user session)
Public property | Online Item Int32 | Gets or sets the element at the specified index. (Inherited from Online List Query Param .)
Public property | Item String | Returns parameter by its name or null
Public property | Name | Returns Query name, providers use it to locate SQL/scripts particular to backend implementation that they represent. QueryResolver resolves query by its name into ICRUDQueryHandler. Name is case-insensitive
Public property | ReadCacheMaxAgeSec | If greater than 0 then would allow reading a cached result for up-to the specified number of seconds. If =0 uses cache's default span. Less than 0 does not try to read from cache
Public property | ResultRowType | Returns a type of result row requested in .ctor which is always a TypedRow derivative type, or null if no particular type was requested
Public property | StoreKey | Returns the key if one was passed in .ctor when key is set the parameters are ignored
Public property | WriteCacheMaxAgeSec | If greater than 0 then writes to cache with the expiration. If =0 uses cache's default life span. Less than 0 does not write to cache
Public property | WriteCachePriority | Relative cache priority which is used when WriteCacheMaxAgeSec>=0
Back to Top
See Also
Query Class
NFX.DataAccess.CRUD Namespace


Query Constructor

Query Constructor NFX Class Library

Overload List
 | Name | Description
Public method | Query(String, IDataStoreKey, Type) | Initializes a new instance of the Query class
Public method | Query(String, Type, Dictionary String, Object ) | Initializes a new instance of the Query class
Public method | Query(Nullable Guid , String, IDataStoreKey, Type) | Initializes a new instance of the Query class
Public method | Query(Nullable Guid , String, Type, Dictionary String, Object ) | Initializes a new instance of the Query class
Back to Top
See Also
Query Class
Query Members
NFX.DataAccess.CRUD Namespace


Query Constructor (String, IDataStoreKey, Type)

Query Constructor (String, IDataStoreKey, Type) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Query class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Query(
    string name,
    IDataStoreKey key,
    Type resultRowType = null
)
public Query(
    string name,
    IDataStoreKey key,
    Type resultRowType = null
)
Public Sub New (
    name As String,
    key As IDataStoreKey,
    Optional resultRowType As Type = Nothing
)
Public Sub New (
    name As String,
    key As IDataStoreKey,
    Optional resultRowType As Type = Nothing
)
public:
Query(
    String^ name,
    IDataStoreKey^ key,
    Type^ resultRowType = nullptr
)
public:
Query(
    String^ name,
    IDataStoreKey^ key,
    Type^ resultRowType = nullptr
)
new :
        name : string *
        key : IDataStoreKey *
        ?resultRowType : Type
(* Defaults:
        let _resultRowType = defaultArg resultRowType null
*)
-> Query
new :
        name : string *
        key : IDataStoreKey *
        ?resultRowType : Type
(* Defaults:
        let _resultRowType = defaultArg resultRowType null
*)
-> Query

Parameters

name
Type: Online System String
key
Type: NFX.DataAccess IDataStoreKey
resultRowType (Optional)
Type: Online System Type
See Also
Query Class
Query Members
Query Overload
NFX.DataAccess.CRUD Namespace


Query Constructor (String, Type, Dictionary(String, Object))

Query Constructor (String, Type, Dictionary String, Object ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Query class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Query(
    string name,
    Type resultRowType = null,
    Dictionary<string, Object> extra = null
)
public Query(
    string name,
    Type resultRowType = null,
    Dictionary<string, Object> extra = null
)
Public Sub New (
    name As String,
    Optional resultRowType As Type = Nothing,
    Optional extra As Dictionary(Of String, Object) = Nothing
)
Public Sub New (
    name As String,
    Optional resultRowType As Type = Nothing,
    Optional extra As Dictionary(Of String, Object) = Nothing
)
public:
Query(
    String^ name,
    Type^ resultRowType = nullptr,
    Dictionary<String^, Object^>^ extra = nullptr
)
public:
Query(
    String^ name,
    Type^ resultRowType = nullptr,
    Dictionary<String^, Object^>^ extra = nullptr
)
new :
        name : string *
        ?resultRowType : Type *
        ?extra : Dictionary<string, Object>
(* Defaults:
        let _resultRowType = defaultArg resultRowType null
        let _extra = defaultArg extra null
*)
-> Query
new :
        name : string *
        ?resultRowType : Type *
        ?extra : Dictionary<string, Object>
(* Defaults:
        let _resultRowType = defaultArg resultRowType null
        let _extra = defaultArg extra null
*)
-> Query

Parameters

name
Type: Online System String
resultRowType (Optional)
Type: Online System Type
extra (Optional)
Type: Online System.Collections.Generic Dictionary Online String, Online Object
See Also
Query Class
Query Members
Query Overload
NFX.DataAccess.CRUD Namespace


Query Constructor (Nullable(Guid), String, IDataStoreKey, Type)

Query Constructor (Nullable Guid , String, IDataStoreKey, Type) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Query class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Query(
    Nullable<Guid> identity,
    string name,
    IDataStoreKey key,
    Type resultRowType = null
)
public Query(
    Nullable<Guid> identity,
    string name,
    IDataStoreKey key,
    Type resultRowType = null
)
Public Sub New (
    identity As Nullable(Of Guid),
    name As String,
    key As IDataStoreKey,
    Optional resultRowType As Type = Nothing
)
Public Sub New (
    identity As Nullable(Of Guid),
    name As String,
    key As IDataStoreKey,
    Optional resultRowType As Type = Nothing
)
public:
Query(
    Nullable<Guid> identity,
    String^ name,
    IDataStoreKey^ key,
    Type^ resultRowType = nullptr
)
public:
Query(
    Nullable<Guid> identity,
    String^ name,
    IDataStoreKey^ key,
    Type^ resultRowType = nullptr
)
new :
        identity : Nullable<Guid> *
        name : string *
        key : IDataStoreKey *
        ?resultRowType : Type
(* Defaults:
        let _resultRowType = defaultArg resultRowType null
*)
-> Query
new :
        identity : Nullable<Guid> *
        name : string *
        key : IDataStoreKey *
        ?resultRowType : Type
(* Defaults:
        let _resultRowType = defaultArg resultRowType null
*)
-> Query

Parameters

identity
Type: Online System Nullable Online Guid
name
Type: Online System String
key
Type: NFX.DataAccess IDataStoreKey
resultRowType (Optional)
Type: Online System Type
See Also
Query Class
Query Members
Query Overload
NFX.DataAccess.CRUD Namespace


Query Constructor (Nullable(Guid), String, Type, Dictionary(String, Object))

Query Constructor (Nullable Guid , String, Type, Dictionary String, Object ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Query class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Query(
    Nullable<Guid> identity,
    string name,
    Type resultRowType = null,
    Dictionary<string, Object> extra = null
)
public Query(
    Nullable<Guid> identity,
    string name,
    Type resultRowType = null,
    Dictionary<string, Object> extra = null
)
Public Sub New (
    identity As Nullable(Of Guid),
    name As String,
    Optional resultRowType As Type = Nothing,
    Optional extra As Dictionary(Of String, Object) = Nothing
)
Public Sub New (
    identity As Nullable(Of Guid),
    name As String,
    Optional resultRowType As Type = Nothing,
    Optional extra As Dictionary(Of String, Object) = Nothing
)
public:
Query(
    Nullable<Guid> identity,
    String^ name,
    Type^ resultRowType = nullptr,
    Dictionary<String^, Object^>^ extra = nullptr
)
public:
Query(
    Nullable<Guid> identity,
    String^ name,
    Type^ resultRowType = nullptr,
    Dictionary<String^, Object^>^ extra = nullptr
)
new :
        identity : Nullable<Guid> *
        name : string *
        ?resultRowType : Type *
        ?extra : Dictionary<string, Object>
(* Defaults:
        let _resultRowType = defaultArg resultRowType null
        let _extra = defaultArg extra null
*)
-> Query
new :
        identity : Nullable<Guid> *
        name : string *
        ?resultRowType : Type *
        ?extra : Dictionary<string, Object>
(* Defaults:
        let _resultRowType = defaultArg resultRowType null
        let _extra = defaultArg extra null
*)
-> Query

Parameters

identity
Type: Online System Nullable Online Guid
name
Type: Online System String
resultRowType (Optional)
Type: Online System Type
extra (Optional)
Type: Online System.Collections.Generic Dictionary Online String, Online Object
See Also
Query Class
Query Members
Query Overload
NFX.DataAccess.CRUD Namespace


Query Methods

Query Methods NFX Class Library

The Query type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List Query Param .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List Query Param .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List Query Param .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List Query Param .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Query Param .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Query Param .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List Query Param .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List Query Param .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List Query Param .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List Query Param .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Query Param .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Query Param .)
Public method | Equals | (Overrides Online Object Equals(Object).)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List Query Param .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Query Param .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Query Param .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Query Param .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Query Param .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Query Param .)
Public method | FindParamByName |
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List Query Param .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List Query Param .)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List Query Param .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Query Param .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Query Param .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List Query Param .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List Query Param .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Query Param .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Query Param .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ParamByName |
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List Query Param .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Query Param .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List Query Param .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List Query Param .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List Query Param .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List Query Param .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List Query Param .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List Query Param .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List Query Param .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List Query Param .)
Public method | ToString | (Overrides Online Object ToString .)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List Query Param .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List Query Param .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Query Class
NFX.DataAccess.CRUD Namespace


Query.Equals Method

Query Equals Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
Query Class
Query Members
NFX.DataAccess.CRUD Namespace


Query.FindParamByName Method

Query FindParamByName Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IParameter FindParamByName(
    string name
)
public IParameter FindParamByName(
    string name
)
Public Function FindParamByName (
    name As String
) As IParameter
Public Function FindParamByName (
    name As String
) As IParameter
public:
virtual IParameter^ FindParamByName(
    String^ name
) sealed
public:
virtual IParameter^ FindParamByName(
    String^ name
) sealed
abstract FindParamByName :
        name : string -> IParameter
override FindParamByName :
        name : string -> IParameter
abstract FindParamByName :
        name : string -> IParameter
override FindParamByName :
        name : string -> IParameter

Parameters

name
Type: Online System String

Return Value

Type: IParameter

Implements

IParameters FindParamByName(String)
See Also
Query Class
Query Members
NFX.DataAccess.CRUD Namespace


Query.GetHashCode Method

Query GetHashCode Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
Query Class
Query Members
NFX.DataAccess.CRUD Namespace


Query.ParamByName Method

Query ParamByName Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IParameter ParamByName(
    string name
)
public IParameter ParamByName(
    string name
)
Public Function ParamByName (
    name As String
) As IParameter
Public Function ParamByName (
    name As String
) As IParameter
public:
virtual IParameter^ ParamByName(
    String^ name
) sealed
public:
virtual IParameter^ ParamByName(
    String^ name
) sealed
abstract ParamByName :
        name : string -> IParameter
override ParamByName :
        name : string -> IParameter
abstract ParamByName :
        name : string -> IParameter
override ParamByName :
        name : string -> IParameter

Parameters

name
Type: Online System String

Return Value

Type: IParameter

Implements

IParameters ParamByName(String)
See Also
Query Class
Query Members
NFX.DataAccess.CRUD Namespace


Query.ToString Method

Query ToString Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
Query Class
Query Members
NFX.DataAccess.CRUD Namespace


Query Properties

Query Properties NFX Class Library

The Query type exposes the following members.
Properties
 | Name | Description
Public property | AllParameters |
Public property | CacheAbsentData | When true would cache the instance of AbsentData to signify the absence of data in the backend for key
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List Query Param .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List Query Param .)
Public property | Extra | Returns extra parameters that provider may need to render the query. May be null
Public property | Identity | Returns the identity of this instance, that is - an ID that UNIQUELY identifies the instance of this query including all of the names, parameters, values. This is needed for Equality comparison and cache lookup. The identity is either generated by .ctor or supplied to it if it is cached (i.e. in a user session)
Public property | Online Item Int32 | Gets or sets the element at the specified index. (Inherited from Online List Query Param .)
Public property | Item String | Returns parameter by its name or null
Public property | Name | Returns Query name, providers use it to locate SQL/scripts particular to backend implementation that they represent. QueryResolver resolves query by its name into ICRUDQueryHandler. Name is case-insensitive
Public property | ReadCacheMaxAgeSec | If greater than 0 then would allow reading a cached result for up-to the specified number of seconds. If =0 uses cache's default span. Less than 0 does not try to read from cache
Public property | ResultRowType | Returns a type of result row requested in .ctor which is always a TypedRow derivative type, or null if no particular type was requested
Public property | StoreKey | Returns the key if one was passed in .ctor when key is set the parameters are ignored
Public property | WriteCacheMaxAgeSec | If greater than 0 then writes to cache with the expiration. If =0 uses cache's default life span. Less than 0 does not write to cache
Public property | WriteCachePriority | Relative cache priority which is used when WriteCacheMaxAgeSec>=0
Back to Top
See Also
Query Class
NFX.DataAccess.CRUD Namespace


Query.AllParameters Property

Query AllParameters Property NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<IParameter> AllParameters { get; }
public IEnumerable<IParameter> AllParameters { get; }
Public ReadOnly Property AllParameters As IEnumerable(Of IParameter)
    Get
Public ReadOnly Property AllParameters As IEnumerable(Of IParameter)
    Get
public:
virtual property IEnumerable<IParameter^>^ AllParameters {
    IEnumerable<IParameter^>^ get () sealed;
}
public:
virtual property IEnumerable<IParameter^>^ AllParameters {
    IEnumerable<IParameter^>^ get () sealed;
}
abstract AllParameters : IEnumerable<IParameter> with get
override AllParameters : IEnumerable<IParameter> with get
abstract AllParameters : IEnumerable<IParameter> with get
override AllParameters : IEnumerable<IParameter> with get

Property Value

Type: Online IEnumerable IParameter

Implements

IParameters AllParameters
See Also
Query Class
Query Members
NFX.DataAccess.CRUD Namespace


Query.CacheAbsentData Property

Query CacheAbsentData Property NFX Class Library

When true would cache the instance of AbsentData to signify the absence of data in the backend for key

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool CacheAbsentData { get; set; }
public bool CacheAbsentData { get; set; }
Public Property CacheAbsentData As Boolean
    Get
    Set
Public Property CacheAbsentData As Boolean
    Get
    Set
public:
virtual property bool CacheAbsentData {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool CacheAbsentData {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract CacheAbsentData : bool with get, set
override CacheAbsentData : bool with get, set
abstract CacheAbsentData : bool with get, set
override CacheAbsentData : bool with get, set

Property Value

Type: Online Boolean

Implements

ICacheParams CacheAbsentData
See Also
Query Class
Query Members
NFX.DataAccess.CRUD Namespace


Query.Extra Property

Query Extra Property NFX Class Library

Returns extra parameters that provider may need to render the query. May be null

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Dictionary<string, Object> Extra { get; }
public Dictionary<string, Object> Extra { get; }
Public ReadOnly Property Extra As Dictionary(Of String, Object)
    Get
Public ReadOnly Property Extra As Dictionary(Of String, Object)
    Get
public:
property Dictionary<String^, Object^>^ Extra {
    Dictionary<String^, Object^>^ get ();
}
public:
property Dictionary<String^, Object^>^ Extra {
    Dictionary<String^, Object^>^ get ();
}
member Extra : Dictionary<string, Object> with get
member Extra : Dictionary<string, Object> with get

Property Value

Type: Online Dictionary Online String, Online Object
See Also
Query Class
Query Members
NFX.DataAccess.CRUD Namespace


Query.Identity Property

Query Identity Property NFX Class Library

Returns the identity of this instance, that is - an ID that UNIQUELY identifies the instance of this query including all of the names, parameters, values. This is needed for Equality comparison and cache lookup. The identity is either generated by .ctor or supplied to it if it is cached (i.e. in a user session)

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid Identity { get; }
public Guid Identity { get; }
Public ReadOnly Property Identity As Guid
    Get
Public ReadOnly Property Identity As Guid
    Get
public:
property Guid Identity {
    Guid get ();
}
public:
property Guid Identity {
    Guid get ();
}
member Identity : Guid with get
member Identity : Guid with get

Property Value

Type: Online Guid
See Also
Query Class
Query Members
NFX.DataAccess.CRUD Namespace


Query.Item Property

Query Item Property NFX Class Library

Overload List
 | Name | Description
Public property | Online Item Int32 | Gets or sets the element at the specified index. (Inherited from Online List Query Param .)
Public property | Item String | Returns parameter by its name or null
Back to Top
See Also
Query Class
Query Members
NFX.DataAccess.CRUD Namespace


Query.Item Property (String)

Query Item Property (String) NFX Class Library

Returns parameter by its name or null

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Query..::..Param this[
    string name
] { get; }
public Query..::..Param this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As Query..::..Param
    Get
Public ReadOnly Default Property Item (
    name As String
) As Query..::..Param
    Get
public:
property Query..::..Param^ default[String^ name] {
    Query..::..Param^ get (String^ name);
}
public:
property Query..::..Param^ default[String^ name] {
    Query..::..Param^ get (String^ name);
}
member Item : Query..::..Param with get
member Item : Query..::..Param with get

Parameters

name
Type: Online System String

Property Value

Type: Query Param
See Also
Query Class
Query Members
Item Overload
NFX.DataAccess.CRUD Namespace


Query.Name Property

Query Name Property NFX Class Library

Returns Query name, providers use it to locate SQL/scripts particular to backend implementation that they represent. QueryResolver resolves query by its name into ICRUDQueryHandler. Name is case-insensitive

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
Query Class
Query Members
NFX.DataAccess.CRUD Namespace


Query.ReadCacheMaxAgeSec Property

Query ReadCacheMaxAgeSec Property NFX Class Library

If greater than 0 then would allow reading a cached result for up-to the specified number of seconds. If =0 uses cache's default span. Less than 0 does not try to read from cache

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ReadCacheMaxAgeSec { get; set; }
public int ReadCacheMaxAgeSec { get; set; }
Public Property ReadCacheMaxAgeSec As Integer
    Get
    Set
Public Property ReadCacheMaxAgeSec As Integer
    Get
    Set
public:
virtual property int ReadCacheMaxAgeSec {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int ReadCacheMaxAgeSec {
    int get () sealed;
    void set (int value) sealed;
}
abstract ReadCacheMaxAgeSec : int with get, set
override ReadCacheMaxAgeSec : int with get, set
abstract ReadCacheMaxAgeSec : int with get, set
override ReadCacheMaxAgeSec : int with get, set

Property Value

Type: Online Int32

Implements

ICacheParams ReadCacheMaxAgeSec
See Also
Query Class
Query Members
NFX.DataAccess.CRUD Namespace


Query.ResultRowType Property

Query ResultRowType Property NFX Class Library

Returns a type of result row requested in .ctor which is always a TypedRow derivative type, or null if no particular type was requested

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Type ResultRowType { get; }
public Type ResultRowType { get; }
Public ReadOnly Property ResultRowType As Type
    Get
Public ReadOnly Property ResultRowType As Type
    Get
public:
property Type^ ResultRowType {
    Type^ get ();
}
public:
property Type^ ResultRowType {
    Type^ get ();
}
member ResultRowType : Type with get
member ResultRowType : Type with get

Property Value

Type: Online Type
See Also
Query Class
Query Members
NFX.DataAccess.CRUD Namespace


Query.StoreKey Property

Query StoreKey Property NFX Class Library

Returns the key if one was passed in .ctor when key is set the parameters are ignored

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDataStoreKey StoreKey { get; }
public IDataStoreKey StoreKey { get; }
Public ReadOnly Property StoreKey As IDataStoreKey
    Get
Public ReadOnly Property StoreKey As IDataStoreKey
    Get
public:
property IDataStoreKey^ StoreKey {
    IDataStoreKey^ get ();
}
public:
property IDataStoreKey^ StoreKey {
    IDataStoreKey^ get ();
}
member StoreKey : IDataStoreKey with get
member StoreKey : IDataStoreKey with get

Property Value

Type: IDataStoreKey
See Also
Query Class
Query Members
NFX.DataAccess.CRUD Namespace


Query.WriteCacheMaxAgeSec Property

Query WriteCacheMaxAgeSec Property NFX Class Library

If greater than 0 then writes to cache with the expiration. If =0 uses cache's default life span. Less than 0 does not write to cache

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int WriteCacheMaxAgeSec { get; set; }
public int WriteCacheMaxAgeSec { get; set; }
Public Property WriteCacheMaxAgeSec As Integer
    Get
    Set
Public Property WriteCacheMaxAgeSec As Integer
    Get
    Set
public:
virtual property int WriteCacheMaxAgeSec {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int WriteCacheMaxAgeSec {
    int get () sealed;
    void set (int value) sealed;
}
abstract WriteCacheMaxAgeSec : int with get, set
override WriteCacheMaxAgeSec : int with get, set
abstract WriteCacheMaxAgeSec : int with get, set
override WriteCacheMaxAgeSec : int with get, set

Property Value

Type: Online Int32

Implements

ICacheParams WriteCacheMaxAgeSec
See Also
Query Class
Query Members
NFX.DataAccess.CRUD Namespace


Query.WriteCachePriority Property

Query WriteCachePriority Property NFX Class Library

Relative cache priority which is used when WriteCacheMaxAgeSec>=0

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int WriteCachePriority { get; set; }
public int WriteCachePriority { get; set; }
Public Property WriteCachePriority As Integer
    Get
    Set
Public Property WriteCachePriority As Integer
    Get
    Set
public:
virtual property int WriteCachePriority {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int WriteCachePriority {
    int get () sealed;
    void set (int value) sealed;
}
abstract WriteCachePriority : int with get, set
override WriteCachePriority : int with get, set
abstract WriteCachePriority : int with get, set
override WriteCachePriority : int with get, set

Property Value

Type: Online Int32

Implements

ICacheParams WriteCachePriority
See Also
Query Class
Query Members
NFX.DataAccess.CRUD Namespace


Query.Param Class

Query Param Class NFX Class Library

Represents a CRUD query parameter
Inheritance Hierarchy
Online System Object
NFX.DataAccess.CRUD Query Param

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class Param : IParameter,
    INamed
[SerializableAttribute]
public sealed class Param : IParameter,
    INamed
<SerializableAttribute>
Public NotInheritable Class Param
    Implements IParameter, INamed
<SerializableAttribute>
Public NotInheritable Class Param
    Implements IParameter, INamed
[SerializableAttribute]
public ref class Param sealed : IParameter,
    INamed
[SerializableAttribute]
public ref class Param sealed : IParameter,
    INamed
[<SealedAttribute>]
[<SerializableAttribute>]
type Param =
    class
        interface IParameter
        interface INamed
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type Param =
    class
        interface IParameter
        interface INamed
    end
See Also
Query Param Members
NFX.DataAccess.CRUD Namespace


Query.Param Members

Query Param Members NFX Class Library

The Query Param type exposes the following members.
Constructors
 | Name | Description
Public method | Query Param | Initializes a new instance of the Query Param class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | HasValue |
Public property | IsInput |
Public property | Name |
Public property | Value |
Back to Top
See Also
Query Param Class
NFX.DataAccess.CRUD Namespace


Query.Param Constructor

Query Param Constructor NFX Class Library

Initializes a new instance of the Query Param class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Param(
    string name,
    Object value = null
)
public Param(
    string name,
    Object value = null
)
Public Sub New (
    name As String,
    Optional value As Object = Nothing
)
Public Sub New (
    name As String,
    Optional value As Object = Nothing
)
public:
Param(
    String^ name,
    Object^ value = nullptr
)
public:
Param(
    String^ name,
    Object^ value = nullptr
)
new :
        name : string *
        ?value : Object
(* Defaults:
        let _value = defaultArg value null
*)
-> Param
new :
        name : string *
        ?value : Object
(* Defaults:
        let _value = defaultArg value null
*)
-> Param

Parameters

name
Type: Online System String
value (Optional)
Type: Online System Object
See Also
Query Param Class
Query Param Members
NFX.DataAccess.CRUD Namespace


Query.Param Methods

Query Param Methods NFX Class Library

The Query Param type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Query Param Class
NFX.DataAccess.CRUD Namespace


Query.Param Properties

Query Param Properties NFX Class Library

The Query Param type exposes the following members.
Properties
 | Name | Description
Public property | HasValue |
Public property | IsInput |
Public property | Name |
Public property | Value |
Back to Top
See Also
Query Param Class
NFX.DataAccess.CRUD Namespace


Query.Param.HasValue Property

Query Param HasValue Property NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasValue { get; }
public bool HasValue { get; }
Public ReadOnly Property HasValue As Boolean
    Get
Public ReadOnly Property HasValue As Boolean
    Get
public:
virtual property bool HasValue {
    bool get () sealed;
}
public:
virtual property bool HasValue {
    bool get () sealed;
}
abstract HasValue : bool with get
override HasValue : bool with get
abstract HasValue : bool with get
override HasValue : bool with get

Property Value

Type: Online Boolean

Implements

IParameter HasValue
See Also
Query Param Class
Query Param Members
NFX.DataAccess.CRUD Namespace


Query.Param.IsInput Property

Query Param IsInput Property NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsInput { get; }
public bool IsInput { get; }
Public ReadOnly Property IsInput As Boolean
    Get
Public ReadOnly Property IsInput As Boolean
    Get
public:
virtual property bool IsInput {
    bool get () sealed;
}
public:
virtual property bool IsInput {
    bool get () sealed;
}
abstract IsInput : bool with get
override IsInput : bool with get
abstract IsInput : bool with get
override IsInput : bool with get

Property Value

Type: Online Boolean

Implements

IParameter IsInput
See Also
Query Param Class
Query Param Members
NFX.DataAccess.CRUD Namespace


Query.Param.Name Property

Query Param Name Property NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
Query Param Class
Query Param Members
NFX.DataAccess.CRUD Namespace


Query.Param.Value Property

Query Param Value Property NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Value { get; }
public Object Value { get; }
Public ReadOnly Property Value As Object
    Get
Public ReadOnly Property Value As Object
    Get
public:
virtual property Object^ Value {
    Object^ get () sealed;
}
public:
virtual property Object^ Value {
    Object^ get () sealed;
}
abstract Value : Object with get
override Value : Object with get
abstract Value : Object with get
override Value : Object with get

Property Value

Type: Online Object

Implements

IParameter Value
See Also
Query Param Class
Query Param Members
NFX.DataAccess.CRUD Namespace


Query(TResultRow) Class

Query TResultRow Class NFX Class Library

Generic version of Query
Inheritance Hierarchy
Online System Object
Online System.Collections.Generic List Query Param
NFX.DataAccess.CRUD Query
NFX.DataAccess.CRUD Query TResultRow

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class Query<TResultRow> : Query
where TResultRow : Row
[SerializableAttribute]
public sealed class Query<TResultRow> : Query
where TResultRow : Row
<SerializableAttribute>
Public NotInheritable Class Query(Of TResultRow As Row)
    Inherits Query
<SerializableAttribute>
Public NotInheritable Class Query(Of TResultRow As Row)
    Inherits Query
[SerializableAttribute]
generic<typename TResultRow>
where TResultRow : Row
public ref class Query sealed : public Query
[SerializableAttribute]
generic<typename TResultRow>
where TResultRow : Row
public ref class Query sealed : public Query
[<SealedAttribute>]
[<SerializableAttribute>]
type Query<'TResultRow when 'TResultRow : Row> =
    class
        inherit Query
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type Query<'TResultRow when 'TResultRow : Row> =
    class
        inherit Query
    end
Type Parameters
TResultRow
Type of resulting rows
See Also
Query TResultRow Members
NFX.DataAccess.CRUD Namespace


Query(TResultRow) Members

Query TResultRow Members NFX Class Library

The Query TResultRow type exposes the following members.
Constructors
 | Name | Description
Public method | Query TResultRow (String, IDataStoreKey) | Initializes a new instance of the Query TResultRow class
Public method | Query TResultRow (String, Dictionary String, Object ) | Initializes a new instance of the Query TResultRow class
Public method | Query TResultRow (Nullable Guid , String, IDataStoreKey) | Initializes a new instance of the Query TResultRow class
Public method | Query TResultRow (Nullable Guid , String, Dictionary String, Object ) | Initializes a new instance of the Query TResultRow class
Back to Top
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List Query Param .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List Query Param .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List Query Param .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List Query Param .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Query Param .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Query Param .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List Query Param .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List Query Param .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List Query Param .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List Query Param .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Query Param .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Query Param .)
Public method | Equals | (Inherited from Query.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List Query Param .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Query Param .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Query Param .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Query Param .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Query Param .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Query Param .)
Public method | FindParamByName | (Inherited from Query.)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List Query Param .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List Query Param .)
Public method | GetHashCode | (Inherited from Query.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List Query Param .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Query Param .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Query Param .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List Query Param .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List Query Param .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Query Param .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Query Param .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ParamByName | (Inherited from Query.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List Query Param .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Query Param .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List Query Param .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List Query Param .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List Query Param .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List Query Param .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List Query Param .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List Query Param .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List Query Param .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List Query Param .)
Public method | ToString | (Inherited from Query.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List Query Param .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List Query Param .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | AllParameters | (Inherited from Query.)
Public property | CacheAbsentData | When true would cache the instance of AbsentData to signify the absence of data in the backend for key (Inherited from Query.)
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List Query Param .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List Query Param .)
Public property | Extra | Returns extra parameters that provider may need to render the query. May be null (Inherited from Query.)
Public property | Identity | Returns the identity of this instance, that is - an ID that UNIQUELY identifies the instance of this query including all of the names, parameters, values. This is needed for Equality comparison and cache lookup. The identity is either generated by .ctor or supplied to it if it is cached (i.e. in a user session) (Inherited from Query.)
Public property | Item String | Returns parameter by its name or null (Inherited from Query.)
Public property | Online Item Int32 | Gets or sets the element at the specified index. (Inherited from Online List Query Param .)
Public property | Name | Returns Query name, providers use it to locate SQL/scripts particular to backend implementation that they represent. QueryResolver resolves query by its name into ICRUDQueryHandler. Name is case-insensitive (Inherited from Query.)
Public property | ReadCacheMaxAgeSec | If greater than 0 then would allow reading a cached result for up-to the specified number of seconds. If =0 uses cache's default span. Less than 0 does not try to read from cache (Inherited from Query.)
Public property | ResultRowType | Returns a type of result row requested in .ctor which is always a TypedRow derivative type, or null if no particular type was requested (Inherited from Query.)
Public property | StoreKey | Returns the key if one was passed in .ctor when key is set the parameters are ignored (Inherited from Query.)
Public property | WriteCacheMaxAgeSec | If greater than 0 then writes to cache with the expiration. If =0 uses cache's default life span. Less than 0 does not write to cache (Inherited from Query.)
Public property | WriteCachePriority | Relative cache priority which is used when WriteCacheMaxAgeSec>=0 (Inherited from Query.)
Back to Top
See Also
Query TResultRow Class
NFX.DataAccess.CRUD Namespace


Query(TResultRow) Constructor

Query TResultRow Constructor NFX Class Library

Overload List
 | Name | Description
Public method | Query TResultRow (String, IDataStoreKey) | Initializes a new instance of the Query TResultRow class
Public method | Query TResultRow (String, Dictionary String, Object ) | Initializes a new instance of the Query TResultRow class
Public method | Query TResultRow (Nullable Guid , String, IDataStoreKey) | Initializes a new instance of the Query TResultRow class
Public method | Query TResultRow (Nullable Guid , String, Dictionary String, Object ) | Initializes a new instance of the Query TResultRow class
Back to Top
See Also
Query TResultRow Class
Query TResultRow Members
NFX.DataAccess.CRUD Namespace


Query(TResultRow) Constructor (String, IDataStoreKey)

Query TResultRow Constructor (String, IDataStoreKey) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Query TResultRow class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Query(
    string name,
    IDataStoreKey key
)
public Query(
    string name,
    IDataStoreKey key
)
Public Sub New (
    name As String,
    key As IDataStoreKey
)
Public Sub New (
    name As String,
    key As IDataStoreKey
)
public:
Query(
    String^ name,
    IDataStoreKey^ key
)
public:
Query(
    String^ name,
    IDataStoreKey^ key
)
new :
        name : string *
        key : IDataStoreKey -> Query
new :
        name : string *
        key : IDataStoreKey -> Query

Parameters

name
Type: Online System String
key
Type: NFX.DataAccess IDataStoreKey
See Also
Query TResultRow Class
Query TResultRow Members
Query TResultRow Overload
NFX.DataAccess.CRUD Namespace


Query(TResultRow) Constructor (String, Dictionary(String, Object))

Query TResultRow Constructor (String, Dictionary String, Object ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Query TResultRow class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Query(
    string name,
    Dictionary<string, Object> extra = null
)
public Query(
    string name,
    Dictionary<string, Object> extra = null
)
Public Sub New (
    name As String,
    Optional extra As Dictionary(Of String, Object) = Nothing
)
Public Sub New (
    name As String,
    Optional extra As Dictionary(Of String, Object) = Nothing
)
public:
Query(
    String^ name,
    Dictionary<String^, Object^>^ extra = nullptr
)
public:
Query(
    String^ name,
    Dictionary<String^, Object^>^ extra = nullptr
)
new :
        name : string *
        ?extra : Dictionary<string, Object>
(* Defaults:
        let _extra = defaultArg extra null
*)
-> Query
new :
        name : string *
        ?extra : Dictionary<string, Object>
(* Defaults:
        let _extra = defaultArg extra null
*)
-> Query

Parameters

name
Type: Online System String
extra (Optional)
Type: Online System.Collections.Generic Dictionary Online String, Online Object
See Also
Query TResultRow Class
Query TResultRow Members
Query TResultRow Overload
NFX.DataAccess.CRUD Namespace


Query(TResultRow) Constructor (Nullable(Guid), String, IDataStoreKey)

Query TResultRow Constructor (Nullable Guid , String, IDataStoreKey) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Query TResultRow class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Query(
    Nullable<Guid> identity,
    string name,
    IDataStoreKey key
)
public Query(
    Nullable<Guid> identity,
    string name,
    IDataStoreKey key
)
Public Sub New (
    identity As Nullable(Of Guid),
    name As String,
    key As IDataStoreKey
)
Public Sub New (
    identity As Nullable(Of Guid),
    name As String,
    key As IDataStoreKey
)
public:
Query(
    Nullable<Guid> identity,
    String^ name,
    IDataStoreKey^ key
)
public:
Query(
    Nullable<Guid> identity,
    String^ name,
    IDataStoreKey^ key
)
new :
        identity : Nullable<Guid> *
        name : string *
        key : IDataStoreKey -> Query
new :
        identity : Nullable<Guid> *
        name : string *
        key : IDataStoreKey -> Query

Parameters

identity
Type: Online System Nullable Online Guid
name
Type: Online System String
key
Type: NFX.DataAccess IDataStoreKey
See Also
Query TResultRow Class
Query TResultRow Members
Query TResultRow Overload
NFX.DataAccess.CRUD Namespace


Query(TResultRow) Constructor (Nullable(Guid), String, Dictionary(String, Object))

Query TResultRow Constructor (Nullable Guid , String, Dictionary String, Object ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Query TResultRow class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Query(
    Nullable<Guid> identity,
    string name,
    Dictionary<string, Object> extra = null
)
public Query(
    Nullable<Guid> identity,
    string name,
    Dictionary<string, Object> extra = null
)
Public Sub New (
    identity As Nullable(Of Guid),
    name As String,
    Optional extra As Dictionary(Of String, Object) = Nothing
)
Public Sub New (
    identity As Nullable(Of Guid),
    name As String,
    Optional extra As Dictionary(Of String, Object) = Nothing
)
public:
Query(
    Nullable<Guid> identity,
    String^ name,
    Dictionary<String^, Object^>^ extra = nullptr
)
public:
Query(
    Nullable<Guid> identity,
    String^ name,
    Dictionary<String^, Object^>^ extra = nullptr
)
new :
        identity : Nullable<Guid> *
        name : string *
        ?extra : Dictionary<string, Object>
(* Defaults:
        let _extra = defaultArg extra null
*)
-> Query
new :
        identity : Nullable<Guid> *
        name : string *
        ?extra : Dictionary<string, Object>
(* Defaults:
        let _extra = defaultArg extra null
*)
-> Query

Parameters

identity
Type: Online System Nullable Online Guid
name
Type: Online System String
extra (Optional)
Type: Online System.Collections.Generic Dictionary Online String, Online Object
See Also
Query TResultRow Class
Query TResultRow Members
Query TResultRow Overload
NFX.DataAccess.CRUD Namespace


Query(TResultRow) Methods

Query TResultRow Methods NFX Class Library

The Query TResultRow type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List Query Param .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List Query Param .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List Query Param .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List Query Param .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Query Param .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Query Param .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List Query Param .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List Query Param .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List Query Param .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List Query Param .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Query Param .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Query Param .)
Public method | Equals | (Inherited from Query.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List Query Param .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Query Param .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Query Param .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Query Param .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Query Param .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Query Param .)
Public method | FindParamByName | (Inherited from Query.)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List Query Param .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List Query Param .)
Public method | GetHashCode | (Inherited from Query.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List Query Param .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Query Param .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Query Param .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List Query Param .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List Query Param .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Query Param .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Query Param .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ParamByName | (Inherited from Query.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List Query Param .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Query Param .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List Query Param .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List Query Param .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List Query Param .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List Query Param .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List Query Param .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List Query Param .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List Query Param .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List Query Param .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List Query Param .)
Public method | ToString | (Inherited from Query.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List Query Param .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List Query Param .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Query TResultRow Class
NFX.DataAccess.CRUD Namespace


Query(TResultRow) Properties

Query TResultRow Properties NFX Class Library

The Query TResultRow type exposes the following members.
Properties
 | Name | Description
Public property | AllParameters | (Inherited from Query.)
Public property | CacheAbsentData | When true would cache the instance of AbsentData to signify the absence of data in the backend for key (Inherited from Query.)
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List Query Param .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List Query Param .)
Public property | Extra | Returns extra parameters that provider may need to render the query. May be null (Inherited from Query.)
Public property | Identity | Returns the identity of this instance, that is - an ID that UNIQUELY identifies the instance of this query including all of the names, parameters, values. This is needed for Equality comparison and cache lookup. The identity is either generated by .ctor or supplied to it if it is cached (i.e. in a user session) (Inherited from Query.)
Public property | Item String | Returns parameter by its name or null (Inherited from Query.)
Public property | Online Item Int32 | Gets or sets the element at the specified index. (Inherited from Online List Query Param .)
Public property | Name | Returns Query name, providers use it to locate SQL/scripts particular to backend implementation that they represent. QueryResolver resolves query by its name into ICRUDQueryHandler. Name is case-insensitive (Inherited from Query.)
Public property | ReadCacheMaxAgeSec | If greater than 0 then would allow reading a cached result for up-to the specified number of seconds. If =0 uses cache's default span. Less than 0 does not try to read from cache (Inherited from Query.)
Public property | ResultRowType | Returns a type of result row requested in .ctor which is always a TypedRow derivative type, or null if no particular type was requested (Inherited from Query.)
Public property | StoreKey | Returns the key if one was passed in .ctor when key is set the parameters are ignored (Inherited from Query.)
Public property | WriteCacheMaxAgeSec | If greater than 0 then writes to cache with the expiration. If =0 uses cache's default life span. Less than 0 does not write to cache (Inherited from Query.)
Public property | WriteCachePriority | Relative cache priority which is used when WriteCacheMaxAgeSec>=0 (Inherited from Query.)
Back to Top
See Also
Query TResultRow Class
NFX.DataAccess.CRUD Namespace


QueryResolver Class

QueryResolver Class NFX Class Library

Infrastructure class - not for app developers. Resolves Query objects into query handlers. Query names are case-insensitive. This class is thread-safe
Inheritance Hierarchy
Online System Object
NFX.DataAccess.CRUD QueryResolver

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class QueryResolver : ICRUDQueryResolver,
    IConfigurable
public sealed class QueryResolver : ICRUDQueryResolver,
    IConfigurable
Public NotInheritable Class QueryResolver
    Implements ICRUDQueryResolver, IConfigurable
Public NotInheritable Class QueryResolver
    Implements ICRUDQueryResolver, IConfigurable
public ref class QueryResolver sealed : ICRUDQueryResolver,
    IConfigurable
public ref class QueryResolver sealed : ICRUDQueryResolver,
    IConfigurable
[<SealedAttribute>]
type QueryResolver =
    class
        interface ICRUDQueryResolver
        interface IConfigurable
    end
[<SealedAttribute>]
type QueryResolver =
    class
        interface ICRUDQueryResolver
        interface IConfigurable
    end
See Also
QueryResolver Members
NFX.DataAccess.CRUD Namespace


QueryResolver Members

QueryResolver Members NFX Class Library

The QueryResolver type exposes the following members.
Constructors
 | Name | Description
Public method | QueryResolver | Initializes a new instance of the QueryResolver class
Back to Top
Methods
 | Name | Description
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegisterHandlerLocation | Registers handler location. The Resolver must be not started yet. This method is NOT thread safe
Public method | Resolve |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UnregisterHandlerLocation | Unregisters handler location returning true if it was found and removed. The Resolve must be not started yet. This method is NOT thread safe
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_HANDLER_LOCATION_SECTION |
CONFIG_NS_ATTR |
CONFIG_QUERY_RESOLVER_SECTION |
CONFIG_SCRIPT_ASM_ATTR |
Back to Top
Properties
 | Name | Description
Public property | HandlerLocations |
Public property | Handlers |
Public property | ScriptAssembly | Gets sets name of assembly that query scripts resolve from
Back to Top
See Also
QueryResolver Class
NFX.DataAccess.CRUD Namespace


QueryResolver Constructor

QueryResolver Constructor NFX Class Library

Initializes a new instance of the QueryResolver class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public QueryResolver(
    ICRUDDataStoreImplementation dataStore
)
public QueryResolver(
    ICRUDDataStoreImplementation dataStore
)
Public Sub New (
    dataStore As ICRUDDataStoreImplementation
)
Public Sub New (
    dataStore As ICRUDDataStoreImplementation
)
public:
QueryResolver(
    ICRUDDataStoreImplementation^ dataStore
)
public:
QueryResolver(
    ICRUDDataStoreImplementation^ dataStore
)
new :
        dataStore : ICRUDDataStoreImplementation -> QueryResolver
new :
        dataStore : ICRUDDataStoreImplementation -> QueryResolver

Parameters

dataStore
Type: NFX.DataAccess.CRUD ICRUDDataStoreImplementation
See Also
QueryResolver Class
QueryResolver Members
NFX.DataAccess.CRUD Namespace


QueryResolver Fields

QueryResolver Fields NFX Class Library

The QueryResolver type exposes the following members.
Fields
Name | Description
CONFIG_HANDLER_LOCATION_SECTION |
CONFIG_NS_ATTR |
CONFIG_QUERY_RESOLVER_SECTION |
CONFIG_SCRIPT_ASM_ATTR |
Back to Top
See Also
QueryResolver Class
NFX.DataAccess.CRUD Namespace


QueryResolver.CONFIG_HANDLER_LOCATION_SECTION Field

QueryResolver CONFIG_HANDLER_LOCATION_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_HANDLER_LOCATION_SECTION
public const string CONFIG_HANDLER_LOCATION_SECTION
Public Const CONFIG_HANDLER_LOCATION_SECTION As String
Public Const CONFIG_HANDLER_LOCATION_SECTION As String
public:
literal String^ CONFIG_HANDLER_LOCATION_SECTION
public:
literal String^ CONFIG_HANDLER_LOCATION_SECTION
static val mutable CONFIG_HANDLER_LOCATION_SECTION: string
static val mutable CONFIG_HANDLER_LOCATION_SECTION: string

Field Value

Type: Online String
See Also
QueryResolver Class
QueryResolver Members
NFX.DataAccess.CRUD Namespace


QueryResolver.CONFIG_NS_ATTR Field

QueryResolver CONFIG_NS_ATTR Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_NS_ATTR
public const string CONFIG_NS_ATTR
Public Const CONFIG_NS_ATTR As String
Public Const CONFIG_NS_ATTR As String
public:
literal String^ CONFIG_NS_ATTR
public:
literal String^ CONFIG_NS_ATTR
static val mutable CONFIG_NS_ATTR: string
static val mutable CONFIG_NS_ATTR: string

Field Value

Type: Online String
See Also
QueryResolver Class
QueryResolver Members
NFX.DataAccess.CRUD Namespace


QueryResolver.CONFIG_QUERY_RESOLVER_SECTION Field

QueryResolver CONFIG_QUERY_RESOLVER_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_QUERY_RESOLVER_SECTION
public const string CONFIG_QUERY_RESOLVER_SECTION
Public Const CONFIG_QUERY_RESOLVER_SECTION As String
Public Const CONFIG_QUERY_RESOLVER_SECTION As String
public:
literal String^ CONFIG_QUERY_RESOLVER_SECTION
public:
literal String^ CONFIG_QUERY_RESOLVER_SECTION
static val mutable CONFIG_QUERY_RESOLVER_SECTION: string
static val mutable CONFIG_QUERY_RESOLVER_SECTION: string

Field Value

Type: Online String
See Also
QueryResolver Class
QueryResolver Members
NFX.DataAccess.CRUD Namespace


QueryResolver.CONFIG_SCRIPT_ASM_ATTR Field

QueryResolver CONFIG_SCRIPT_ASM_ATTR Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SCRIPT_ASM_ATTR
public const string CONFIG_SCRIPT_ASM_ATTR
Public Const CONFIG_SCRIPT_ASM_ATTR As String
Public Const CONFIG_SCRIPT_ASM_ATTR As String
public:
literal String^ CONFIG_SCRIPT_ASM_ATTR
public:
literal String^ CONFIG_SCRIPT_ASM_ATTR
static val mutable CONFIG_SCRIPT_ASM_ATTR: string
static val mutable CONFIG_SCRIPT_ASM_ATTR: string

Field Value

Type: Online String
See Also
QueryResolver Class
QueryResolver Members
NFX.DataAccess.CRUD Namespace


QueryResolver Methods

QueryResolver Methods NFX Class Library

The QueryResolver type exposes the following members.
Methods
 | Name | Description
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegisterHandlerLocation | Registers handler location. The Resolver must be not started yet. This method is NOT thread safe
Public method | Resolve |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UnregisterHandlerLocation | Unregisters handler location returning true if it was found and removed. The Resolve must be not started yet. This method is NOT thread safe
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
QueryResolver Class
NFX.DataAccess.CRUD Namespace


QueryResolver.Configure Method

QueryResolver Configure Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode node
)
public void Configure(
    IConfigSectionNode node
)
Public Sub Configure (
    node As IConfigSectionNode
)
Public Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
QueryResolver Class
QueryResolver Members
NFX.DataAccess.CRUD Namespace


QueryResolver.RegisterHandlerLocation Method

QueryResolver RegisterHandlerLocation Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Registers handler location. The Resolver must be not started yet. This method is NOT thread safe

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RegisterHandlerLocation(
    string location
)
public void RegisterHandlerLocation(
    string location
)
Public Sub RegisterHandlerLocation (
    location As String
)
Public Sub RegisterHandlerLocation (
    location As String
)
public:
virtual void RegisterHandlerLocation(
    String^ location
) sealed
public:
virtual void RegisterHandlerLocation(
    String^ location
) sealed
abstract RegisterHandlerLocation :
        location : string -> unit
override RegisterHandlerLocation :
        location : string -> unit
abstract RegisterHandlerLocation :
        location : string -> unit
override RegisterHandlerLocation :
        location : string -> unit

Parameters

location
Type: Online System String

Implements

ICRUDQueryResolver RegisterHandlerLocation(String)
See Also
QueryResolver Class
QueryResolver Members
NFX.DataAccess.CRUD Namespace


QueryResolver.Resolve Method

QueryResolver Resolve Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDQueryHandler Resolve(
    Query query
)
public CRUDQueryHandler Resolve(
    Query query
)
Public Function Resolve (
    query As Query
) As CRUDQueryHandler
Public Function Resolve (
    query As Query
) As CRUDQueryHandler
public:
virtual CRUDQueryHandler^ Resolve(
    Query^ query
) sealed
public:
virtual CRUDQueryHandler^ Resolve(
    Query^ query
) sealed
abstract Resolve :
        query : Query -> CRUDQueryHandler
override Resolve :
        query : Query -> CRUDQueryHandler
abstract Resolve :
        query : Query -> CRUDQueryHandler
override Resolve :
        query : Query -> CRUDQueryHandler

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: CRUDQueryHandler

Implements

ICRUDQueryResolver Resolve(Query)
See Also
QueryResolver Class
QueryResolver Members
NFX.DataAccess.CRUD Namespace


QueryResolver.UnregisterHandlerLocation Method

QueryResolver UnregisterHandlerLocation Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Unregisters handler location returning true if it was found and removed. The Resolve must be not started yet. This method is NOT thread safe

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool UnregisterHandlerLocation(
    string location
)
public bool UnregisterHandlerLocation(
    string location
)
Public Function UnregisterHandlerLocation (
    location As String
) As Boolean
Public Function UnregisterHandlerLocation (
    location As String
) As Boolean
public:
virtual bool UnregisterHandlerLocation(
    String^ location
) sealed
public:
virtual bool UnregisterHandlerLocation(
    String^ location
) sealed
abstract UnregisterHandlerLocation :
        location : string -> bool
override UnregisterHandlerLocation :
        location : string -> bool
abstract UnregisterHandlerLocation :
        location : string -> bool
override UnregisterHandlerLocation :
        location : string -> bool

Parameters

location
Type: Online System String

Return Value

Type: Online Boolean

Implements

ICRUDQueryResolver UnregisterHandlerLocation(String)
See Also
QueryResolver Class
QueryResolver Members
NFX.DataAccess.CRUD Namespace


QueryResolver Properties

QueryResolver Properties NFX Class Library

The QueryResolver type exposes the following members.
Properties
 | Name | Description
Public property | HandlerLocations |
Public property | Handlers |
Public property | ScriptAssembly | Gets sets name of assembly that query scripts resolve from
Back to Top
See Also
QueryResolver Class
NFX.DataAccess.CRUD Namespace


QueryResolver.HandlerLocations Property

QueryResolver HandlerLocations Property NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IList<string> HandlerLocations { get; }
public IList<string> HandlerLocations { get; }
Public ReadOnly Property HandlerLocations As IList(Of String)
    Get
Public ReadOnly Property HandlerLocations As IList(Of String)
    Get
public:
virtual property IList<String^>^ HandlerLocations {
    IList<String^>^ get () sealed;
}
public:
virtual property IList<String^>^ HandlerLocations {
    IList<String^>^ get () sealed;
}
abstract HandlerLocations : IList<string> with get
override HandlerLocations : IList<string> with get
abstract HandlerLocations : IList<string> with get
override HandlerLocations : IList<string> with get

Property Value

Type: Online IList Online String

Implements

ICRUDQueryResolver HandlerLocations
See Also
QueryResolver Class
QueryResolver Members
NFX.DataAccess.CRUD Namespace


QueryResolver.Handlers Property

QueryResolver Handlers Property NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<CRUDQueryHandler> Handlers { get; }
public IRegistry<CRUDQueryHandler> Handlers { get; }
Public ReadOnly Property Handlers As IRegistry(Of CRUDQueryHandler)
    Get
Public ReadOnly Property Handlers As IRegistry(Of CRUDQueryHandler)
    Get
public:
virtual property IRegistry<CRUDQueryHandler^>^ Handlers {
    IRegistry<CRUDQueryHandler^>^ get () sealed;
}
public:
virtual property IRegistry<CRUDQueryHandler^>^ Handlers {
    IRegistry<CRUDQueryHandler^>^ get () sealed;
}
abstract Handlers : IRegistry<CRUDQueryHandler> with get
override Handlers : IRegistry<CRUDQueryHandler> with get
abstract Handlers : IRegistry<CRUDQueryHandler> with get
override Handlers : IRegistry<CRUDQueryHandler> with get

Property Value

Type: IRegistry CRUDQueryHandler

Implements

ICRUDQueryResolver Handlers
See Also
QueryResolver Class
QueryResolver Members
NFX.DataAccess.CRUD Namespace


QueryResolver.ScriptAssembly Property

QueryResolver ScriptAssembly Property NFX Class Library

Gets sets name of assembly that query scripts resolve from

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ScriptAssembly { get; set; }
public string ScriptAssembly { get; set; }
Public Property ScriptAssembly As String
    Get
    Set
Public Property ScriptAssembly As String
    Get
    Set
public:
virtual property String^ ScriptAssembly {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ ScriptAssembly {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract ScriptAssembly : string with get, set
override ScriptAssembly : string with get, set
abstract ScriptAssembly : string with get, set
override ScriptAssembly : string with get, set

Property Value

Type: Online String

Implements

ICRUDQueryResolver ScriptAssembly
See Also
QueryResolver Class
QueryResolver Members
NFX.DataAccess.CRUD Namespace


QuerySource Class

QuerySource Class NFX Class Library

Represents query source code with pre-processed pragmas
Inheritance Hierarchy
Online System Object
NFX.DataAccess.CRUD QuerySource

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class QuerySource : INamed
public sealed class QuerySource : INamed
Public NotInheritable Class QuerySource
    Implements INamed
Public NotInheritable Class QuerySource
    Implements INamed
public ref class QuerySource sealed : INamed
public ref class QuerySource sealed : INamed
[<SealedAttribute>]
type QuerySource =
    class
        interface INamed
    end
[<SealedAttribute>]
type QuerySource =
    class
        interface INamed
    end
Examples
#pragma modify=tbl_patient key=counter,ssn ignore=doctor_phone,doctor_id load= store= @last_name=lname @first_name=fname .doctor_id=This is description for column select t1.ssn, t1.lname as last_name, t1.fname as first_name, t1.c_doctor, t2.phone as doctor_phone, t2.NPI as doctor_id from tbl_patient t1 left outer join tbl_doctor t2 on t1.c_doctor = t2.counter where t1.lname like ?LN
See Also
QuerySource Members
NFX.DataAccess.CRUD Namespace


QuerySource Members

QuerySource Members NFX Class Library

The QuerySource type exposes the following members.
Constructors
 | Name | Description
Public method | QuerySource | Initializes a new instance of the QuerySource class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
COLUMN_ALIAS_PREFIX |
COLUMN_DESCRIPTION_PREFIX |
COLUMN_IGNORE_SECTION |
COLUMN_INVISIBLE_SECTION |
COLUMN_KEY_SECTION |
COLUMN_LOAD_SECTION |
COLUMN_REQUIRED_SECTION |
COLUMN_STORE_SECTION |
PRAGMA |
TABLE_MODIFY_SECTION |
Back to Top
Properties
 | Name | Description
Public property | ColumnDefs | Returns column definitions defined by #pragma
Public property | HasPragma | Returns true when #pragma was defined in source
Public property | ModifyTarget | Returns modification target (table name to insert/update/delete against) if query is not read-only
Public property | Name | Rerurns name of query source
Public property | OriginalSource | Returns original source of query including pragma text (if any)
Public property | ReadOnly | Returns true when pragma does not specify any modification target (table name to insert/update/delete against)
Public property | StatementSource | Returns source of query excluding pragma text (if any was present in the original)
Back to Top
See Also
QuerySource Class
NFX.DataAccess.CRUD Namespace


QuerySource Constructor

QuerySource Constructor NFX Class Library

Initializes a new instance of the QuerySource class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public QuerySource(
    string name,
    string source
)
public QuerySource(
    string name,
    string source
)
Public Sub New (
    name As String,
    source As String
)
Public Sub New (
    name As String,
    source As String
)
public:
QuerySource(
    String^ name,
    String^ source
)
public:
QuerySource(
    String^ name,
    String^ source
)
new :
        name : string *
        source : string -> QuerySource
new :
        name : string *
        source : string -> QuerySource

Parameters

name
Type: Online System String
source
Type: Online System String
See Also
QuerySource Class
QuerySource Members
NFX.DataAccess.CRUD Namespace


QuerySource Fields

QuerySource Fields NFX Class Library

The QuerySource type exposes the following members.
Fields
Name | Description
COLUMN_ALIAS_PREFIX |
COLUMN_DESCRIPTION_PREFIX |
COLUMN_IGNORE_SECTION |
COLUMN_INVISIBLE_SECTION |
COLUMN_KEY_SECTION |
COLUMN_LOAD_SECTION |
COLUMN_REQUIRED_SECTION |
COLUMN_STORE_SECTION |
PRAGMA |
TABLE_MODIFY_SECTION |
Back to Top
See Also
QuerySource Class
NFX.DataAccess.CRUD Namespace


QuerySource.COLUMN_ALIAS_PREFIX Field

QuerySource COLUMN_ALIAS_PREFIX Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string COLUMN_ALIAS_PREFIX
public const string COLUMN_ALIAS_PREFIX
Public Const COLUMN_ALIAS_PREFIX As String
Public Const COLUMN_ALIAS_PREFIX As String
public:
literal String^ COLUMN_ALIAS_PREFIX
public:
literal String^ COLUMN_ALIAS_PREFIX
static val mutable COLUMN_ALIAS_PREFIX: string
static val mutable COLUMN_ALIAS_PREFIX: string

Field Value

Type: Online String
See Also
QuerySource Class
QuerySource Members
NFX.DataAccess.CRUD Namespace


QuerySource.COLUMN_DESCRIPTION_PREFIX Field

QuerySource COLUMN_DESCRIPTION_PREFIX Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string COLUMN_DESCRIPTION_PREFIX
public const string COLUMN_DESCRIPTION_PREFIX
Public Const COLUMN_DESCRIPTION_PREFIX As String
Public Const COLUMN_DESCRIPTION_PREFIX As String
public:
literal String^ COLUMN_DESCRIPTION_PREFIX
public:
literal String^ COLUMN_DESCRIPTION_PREFIX
static val mutable COLUMN_DESCRIPTION_PREFIX: string
static val mutable COLUMN_DESCRIPTION_PREFIX: string

Field Value

Type: Online String
See Also
QuerySource Class
QuerySource Members
NFX.DataAccess.CRUD Namespace


QuerySource.COLUMN_IGNORE_SECTION Field

QuerySource COLUMN_IGNORE_SECTION Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string COLUMN_IGNORE_SECTION
public const string COLUMN_IGNORE_SECTION
Public Const COLUMN_IGNORE_SECTION As String
Public Const COLUMN_IGNORE_SECTION As String
public:
literal String^ COLUMN_IGNORE_SECTION
public:
literal String^ COLUMN_IGNORE_SECTION
static val mutable COLUMN_IGNORE_SECTION: string
static val mutable COLUMN_IGNORE_SECTION: string

Field Value

Type: Online String
See Also
QuerySource Class
QuerySource Members
NFX.DataAccess.CRUD Namespace


QuerySource.COLUMN_INVISIBLE_SECTION Field

QuerySource COLUMN_INVISIBLE_SECTION Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string COLUMN_INVISIBLE_SECTION
public const string COLUMN_INVISIBLE_SECTION
Public Const COLUMN_INVISIBLE_SECTION As String
Public Const COLUMN_INVISIBLE_SECTION As String
public:
literal String^ COLUMN_INVISIBLE_SECTION
public:
literal String^ COLUMN_INVISIBLE_SECTION
static val mutable COLUMN_INVISIBLE_SECTION: string
static val mutable COLUMN_INVISIBLE_SECTION: string

Field Value

Type: Online String
See Also
QuerySource Class
QuerySource Members
NFX.DataAccess.CRUD Namespace


QuerySource.COLUMN_KEY_SECTION Field

QuerySource COLUMN_KEY_SECTION Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string COLUMN_KEY_SECTION
public const string COLUMN_KEY_SECTION
Public Const COLUMN_KEY_SECTION As String
Public Const COLUMN_KEY_SECTION As String
public:
literal String^ COLUMN_KEY_SECTION
public:
literal String^ COLUMN_KEY_SECTION
static val mutable COLUMN_KEY_SECTION: string
static val mutable COLUMN_KEY_SECTION: string

Field Value

Type: Online String
See Also
QuerySource Class
QuerySource Members
NFX.DataAccess.CRUD Namespace


QuerySource.COLUMN_LOAD_SECTION Field

QuerySource COLUMN_LOAD_SECTION Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string COLUMN_LOAD_SECTION
public const string COLUMN_LOAD_SECTION
Public Const COLUMN_LOAD_SECTION As String
Public Const COLUMN_LOAD_SECTION As String
public:
literal String^ COLUMN_LOAD_SECTION
public:
literal String^ COLUMN_LOAD_SECTION
static val mutable COLUMN_LOAD_SECTION: string
static val mutable COLUMN_LOAD_SECTION: string

Field Value

Type: Online String
See Also
QuerySource Class
QuerySource Members
NFX.DataAccess.CRUD Namespace


QuerySource.COLUMN_REQUIRED_SECTION Field

QuerySource COLUMN_REQUIRED_SECTION Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string COLUMN_REQUIRED_SECTION
public const string COLUMN_REQUIRED_SECTION
Public Const COLUMN_REQUIRED_SECTION As String
Public Const COLUMN_REQUIRED_SECTION As String
public:
literal String^ COLUMN_REQUIRED_SECTION
public:
literal String^ COLUMN_REQUIRED_SECTION
static val mutable COLUMN_REQUIRED_SECTION: string
static val mutable COLUMN_REQUIRED_SECTION: string

Field Value

Type: Online String
See Also
QuerySource Class
QuerySource Members
NFX.DataAccess.CRUD Namespace


QuerySource.COLUMN_STORE_SECTION Field

QuerySource COLUMN_STORE_SECTION Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string COLUMN_STORE_SECTION
public const string COLUMN_STORE_SECTION
Public Const COLUMN_STORE_SECTION As String
Public Const COLUMN_STORE_SECTION As String
public:
literal String^ COLUMN_STORE_SECTION
public:
literal String^ COLUMN_STORE_SECTION
static val mutable COLUMN_STORE_SECTION: string
static val mutable COLUMN_STORE_SECTION: string

Field Value

Type: Online String
See Also
QuerySource Class
QuerySource Members
NFX.DataAccess.CRUD Namespace


QuerySource.PRAGMA Field

QuerySource PRAGMA Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PRAGMA
public const string PRAGMA
Public Const PRAGMA As String
Public Const PRAGMA As String
public:
literal String^ PRAGMA
public:
literal String^ PRAGMA
static val mutable PRAGMA: string
static val mutable PRAGMA: string

Field Value

Type: Online String
See Also
QuerySource Class
QuerySource Members
NFX.DataAccess.CRUD Namespace


QuerySource.TABLE_MODIFY_SECTION Field

QuerySource TABLE_MODIFY_SECTION Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string TABLE_MODIFY_SECTION
public const string TABLE_MODIFY_SECTION
Public Const TABLE_MODIFY_SECTION As String
Public Const TABLE_MODIFY_SECTION As String
public:
literal String^ TABLE_MODIFY_SECTION
public:
literal String^ TABLE_MODIFY_SECTION
static val mutable TABLE_MODIFY_SECTION: string
static val mutable TABLE_MODIFY_SECTION: string

Field Value

Type: Online String
See Also
QuerySource Class
QuerySource Members
NFX.DataAccess.CRUD Namespace


QuerySource Methods

QuerySource Methods NFX Class Library

The QuerySource type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
QuerySource Class
NFX.DataAccess.CRUD Namespace


QuerySource Properties

QuerySource Properties NFX Class Library

The QuerySource type exposes the following members.
Properties
 | Name | Description
Public property | ColumnDefs | Returns column definitions defined by #pragma
Public property | HasPragma | Returns true when #pragma was defined in source
Public property | ModifyTarget | Returns modification target (table name to insert/update/delete against) if query is not read-only
Public property | Name | Rerurns name of query source
Public property | OriginalSource | Returns original source of query including pragma text (if any)
Public property | ReadOnly | Returns true when pragma does not specify any modification target (table name to insert/update/delete against)
Public property | StatementSource | Returns source of query excluding pragma text (if any was present in the original)
Back to Top
See Also
QuerySource Class
NFX.DataAccess.CRUD Namespace


QuerySource.ColumnDefs Property

QuerySource ColumnDefs Property NFX Class Library

Returns column definitions defined by #pragma

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<QuerySource..::..ColumnDef> ColumnDefs { get; }
public IRegistry<QuerySource..::..ColumnDef> ColumnDefs { get; }
Public ReadOnly Property ColumnDefs As IRegistry(Of QuerySource..::..ColumnDef)
    Get
Public ReadOnly Property ColumnDefs As IRegistry(Of QuerySource..::..ColumnDef)
    Get
public:
property IRegistry<QuerySource..::..ColumnDef^>^ ColumnDefs {
    IRegistry<QuerySource..::..ColumnDef^>^ get ();
}
public:
property IRegistry<QuerySource..::..ColumnDef^>^ ColumnDefs {
    IRegistry<QuerySource..::..ColumnDef^>^ get ();
}
member ColumnDefs : IRegistry<QuerySource..::..ColumnDef> with get
member ColumnDefs : IRegistry<QuerySource..::..ColumnDef> with get

Property Value

Type: IRegistry QuerySource ColumnDef
See Also
QuerySource Class
QuerySource Members
NFX.DataAccess.CRUD Namespace


QuerySource.HasPragma Property

QuerySource HasPragma Property NFX Class Library

Returns true when #pragma was defined in source

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasPragma { get; }
public bool HasPragma { get; }
Public ReadOnly Property HasPragma As Boolean
    Get
Public ReadOnly Property HasPragma As Boolean
    Get
public:
property bool HasPragma {
    bool get ();
}
public:
property bool HasPragma {
    bool get ();
}
member HasPragma : bool with get
member HasPragma : bool with get

Property Value

Type: Online Boolean
See Also
QuerySource Class
QuerySource Members
NFX.DataAccess.CRUD Namespace


QuerySource.ModifyTarget Property

QuerySource ModifyTarget Property NFX Class Library

Returns modification target (table name to insert/update/delete against) if query is not read-only

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ModifyTarget { get; }
public string ModifyTarget { get; }
Public ReadOnly Property ModifyTarget As String
    Get
Public ReadOnly Property ModifyTarget As String
    Get
public:
property String^ ModifyTarget {
    String^ get ();
}
public:
property String^ ModifyTarget {
    String^ get ();
}
member ModifyTarget : string with get
member ModifyTarget : string with get

Property Value

Type: Online String
See Also
QuerySource Class
QuerySource Members
NFX.DataAccess.CRUD Namespace


QuerySource.Name Property

QuerySource Name Property NFX Class Library

Rerurns name of query source

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
QuerySource Class
QuerySource Members
NFX.DataAccess.CRUD Namespace


QuerySource.OriginalSource Property

QuerySource OriginalSource Property NFX Class Library

Returns original source of query including pragma text (if any)

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string OriginalSource { get; }
public string OriginalSource { get; }
Public ReadOnly Property OriginalSource As String
    Get
Public ReadOnly Property OriginalSource As String
    Get
public:
property String^ OriginalSource {
    String^ get ();
}
public:
property String^ OriginalSource {
    String^ get ();
}
member OriginalSource : string with get
member OriginalSource : string with get

Property Value

Type: Online String
See Also
QuerySource Class
QuerySource Members
NFX.DataAccess.CRUD Namespace


QuerySource.ReadOnly Property

QuerySource ReadOnly Property NFX Class Library

Returns true when pragma does not specify any modification target (table name to insert/update/delete against)

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ReadOnly { get; }
public bool ReadOnly { get; }
Public ReadOnly Property ReadOnly As Boolean
    Get
Public ReadOnly Property ReadOnly As Boolean
    Get
public:
property bool ReadOnly {
    bool get ();
}
public:
property bool ReadOnly {
    bool get ();
}
member ReadOnly : bool with get
member ReadOnly : bool with get

Property Value

Type: Online Boolean
See Also
QuerySource Class
QuerySource Members
NFX.DataAccess.CRUD Namespace


QuerySource.StatementSource Property

QuerySource StatementSource Property NFX Class Library

Returns source of query excluding pragma text (if any was present in the original)

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string StatementSource { get; }
public string StatementSource { get; }
Public ReadOnly Property StatementSource As String
    Get
Public ReadOnly Property StatementSource As String
    Get
public:
property String^ StatementSource {
    String^ get ();
}
public:
property String^ StatementSource {
    String^ get ();
}
member StatementSource : string with get
member StatementSource : string with get

Property Value

Type: Online String
See Also
QuerySource Class
QuerySource Members
NFX.DataAccess.CRUD Namespace


QuerySource.ColumnDef Class

QuerySource ColumnDef Class NFX Class Library

Provides column definition in QuerySource
Inheritance Hierarchy
Online System Object
NFX.DataAccess.CRUD QuerySource ColumnDef

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ColumnDef : INamed
public class ColumnDef : INamed
Public Class ColumnDef
    Implements INamed
Public Class ColumnDef
    Implements INamed
public ref class ColumnDef : INamed
public ref class ColumnDef : INamed
type ColumnDef =
    class
        interface INamed
    end
type ColumnDef =
    class
        interface INamed
    end
See Also
QuerySource ColumnDef Members
NFX.DataAccess.CRUD Namespace


QuerySource.ColumnDef Members

QuerySource ColumnDef Members NFX Class Library

The QuerySource ColumnDef type exposes the following members.
Constructors
 | Name | Description
Protected method | QuerySource ColumnDef | Initializes a new instance of the QuerySource ColumnDef class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | BackendName |
Public property | Description |
Public property | Key |
Public property | Name |
Public property | Required |
Public property | StoreFlag |
Public property | Visible |
Back to Top
See Also
QuerySource ColumnDef Class
NFX.DataAccess.CRUD Namespace


QuerySource.ColumnDef Constructor

QuerySource ColumnDef Constructor NFX Class Library

Initializes a new instance of the QuerySource ColumnDef class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ColumnDef(
    string name
)
internal ColumnDef(
    string name
)
Friend Sub New (
    name As String
)
Friend Sub New (
    name As String
)
internal:
ColumnDef(
    String^ name
)
internal:
ColumnDef(
    String^ name
)
new :
        name : string -> ColumnDef
new :
        name : string -> ColumnDef

Parameters

name
Type: Online System String
See Also
QuerySource ColumnDef Class
QuerySource ColumnDef Members
NFX.DataAccess.CRUD Namespace


QuerySource.ColumnDef Methods

QuerySource ColumnDef Methods NFX Class Library

The QuerySource ColumnDef type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
QuerySource ColumnDef Class
NFX.DataAccess.CRUD Namespace


QuerySource.ColumnDef Properties

QuerySource ColumnDef Properties NFX Class Library

The QuerySource ColumnDef type exposes the following members.
Properties
 | Name | Description
Public property | BackendName |
Public property | Description |
Public property | Key |
Public property | Name |
Public property | Required |
Public property | StoreFlag |
Public property | Visible |
Back to Top
See Also
QuerySource ColumnDef Class
NFX.DataAccess.CRUD Namespace


QuerySource.ColumnDef.BackendName Property

QuerySource ColumnDef BackendName Property NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string BackendName { get; internal set; }
public string BackendName { get; internal set; }
Public Property BackendName As String
    Get
    Friend Set
Public Property BackendName As String
    Get
    Friend Set
public:
property String^ BackendName {
    String^ get ();
    internal: void set (String^ value);
}
public:
property String^ BackendName {
    String^ get ();
    internal: void set (String^ value);
}
member BackendName : string with get, internal set
member BackendName : string with get, internal set

Property Value

Type: Online String
See Also
QuerySource ColumnDef Class
QuerySource ColumnDef Members
NFX.DataAccess.CRUD Namespace


QuerySource.ColumnDef.Description Property

QuerySource ColumnDef Description Property NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Description { get; internal set; }
public string Description { get; internal set; }
Public Property Description As String
    Get
    Friend Set
Public Property Description As String
    Get
    Friend Set
public:
property String^ Description {
    String^ get ();
    internal: void set (String^ value);
}
public:
property String^ Description {
    String^ get ();
    internal: void set (String^ value);
}
member Description : string with get, internal set
member Description : string with get, internal set

Property Value

Type: Online String
See Also
QuerySource ColumnDef Class
QuerySource ColumnDef Members
NFX.DataAccess.CRUD Namespace


QuerySource.ColumnDef.Key Property

QuerySource ColumnDef Key Property NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Key { get; internal set; }
public bool Key { get; internal set; }
Public Property Key As Boolean
    Get
    Friend Set
Public Property Key As Boolean
    Get
    Friend Set
public:
property bool Key {
    bool get ();
    internal: void set (bool value);
}
public:
property bool Key {
    bool get ();
    internal: void set (bool value);
}
member Key : bool with get, internal set
member Key : bool with get, internal set

Property Value

Type: Online Boolean
See Also
QuerySource ColumnDef Class
QuerySource ColumnDef Members
NFX.DataAccess.CRUD Namespace


QuerySource.ColumnDef.Name Property

QuerySource ColumnDef Name Property NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
QuerySource ColumnDef Class
QuerySource ColumnDef Members
NFX.DataAccess.CRUD Namespace


QuerySource.ColumnDef.Required Property

QuerySource ColumnDef Required Property NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Required { get; internal set; }
public bool Required { get; internal set; }
Public Property Required As Boolean
    Get
    Friend Set
Public Property Required As Boolean
    Get
    Friend Set
public:
property bool Required {
    bool get ();
    internal: void set (bool value);
}
public:
property bool Required {
    bool get ();
    internal: void set (bool value);
}
member Required : bool with get, internal set
member Required : bool with get, internal set

Property Value

Type: Online Boolean
See Also
QuerySource ColumnDef Class
QuerySource ColumnDef Members
NFX.DataAccess.CRUD Namespace


QuerySource.ColumnDef.StoreFlag Property

QuerySource ColumnDef StoreFlag Property NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StoreFlag StoreFlag { get; internal set; }
public StoreFlag StoreFlag { get; internal set; }
Public Property StoreFlag As StoreFlag
    Get
    Friend Set
Public Property StoreFlag As StoreFlag
    Get
    Friend Set
public:
property StoreFlag StoreFlag {
    StoreFlag get ();
    internal: void set (StoreFlag value);
}
public:
property StoreFlag StoreFlag {
    StoreFlag get ();
    internal: void set (StoreFlag value);
}
member StoreFlag : StoreFlag with get, internal set
member StoreFlag : StoreFlag with get, internal set

Property Value

Type: StoreFlag
See Also
QuerySource ColumnDef Class
QuerySource ColumnDef Members
NFX.DataAccess.CRUD Namespace


QuerySource.ColumnDef.Visible Property

QuerySource ColumnDef Visible Property NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Visible { get; internal set; }
public bool Visible { get; internal set; }
Public Property Visible As Boolean
    Get
    Friend Set
Public Property Visible As Boolean
    Get
    Friend Set
public:
property bool Visible {
    bool get ();
    internal: void set (bool value);
}
public:
property bool Visible {
    bool get ();
    internal: void set (bool value);
}
member Visible : bool with get, internal set
member Visible : bool with get, internal set

Property Value

Type: Online Boolean
See Also
QuerySource ColumnDef Class
QuerySource ColumnDef Members
NFX.DataAccess.CRUD Namespace


Row Class

Row Class NFX Class Library

Base class for any CRUD row. This class has two direct subtypes - DynamicRow and TypedRow. Rows are NOT THREAD SAFE by definition
Inheritance Hierarchy
Online System Object
NFX.DataAccess.CRUD Row
NFX.DataAccess.CRUD DynamicRow
NFX.DataAccess.CRUD TypedRow

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class Row : IConfigurable,
    IConfigurationPersistent, IEquatable<Row>, IEnumerable<Object>,
    IEnumerable, IValidatable, IJSONWritable
[SerializableAttribute]
public abstract class Row : IConfigurable,
    IConfigurationPersistent, IEquatable<Row>, IEnumerable<Object>,
    IEnumerable, IValidatable, IJSONWritable
<SerializableAttribute>
Public MustInherit Class Row
    Implements IConfigurable, IConfigurationPersistent, IEquatable(Of Row),
    IEnumerable(Of Object), IEnumerable, IValidatable, IJSONWritable
<SerializableAttribute>
Public MustInherit Class Row
    Implements IConfigurable, IConfigurationPersistent, IEquatable(Of Row),
    IEnumerable(Of Object), IEnumerable, IValidatable, IJSONWritable
[SerializableAttribute]
public ref class Row abstract : IConfigurable,
    IConfigurationPersistent, IEquatable<Row^>, IEnumerable<Object^>,
    IEnumerable, IValidatable, IJSONWritable
[SerializableAttribute]
public ref class Row abstract : IConfigurable,
    IConfigurationPersistent, IEquatable<Row^>, IEnumerable<Object^>,
    IEnumerable, IValidatable, IJSONWritable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type Row =
    class
        interface IConfigurable
        interface IConfigurationPersistent
        interface IEquatable<Row>
        interface IEnumerable<Object>
        interface IEnumerable
        interface IValidatable
        interface IJSONWritable
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type Row =
    class
        interface IConfigurable
        interface IConfigurationPersistent
        interface IEquatable<Row>
        interface IEnumerable<Object>
        interface IEnumerable
        interface IValidatable
        interface IJSONWritable
    end
See Also
Row Members
NFX.DataAccess.CRUD Namespace


Row Members

Row Members NFX Class Library

The Row type exposes the following members.
Constructors
 | Name | Description
Protected method | Row | Initializes a new instance of the Row class
Back to Top
Methods
 | Name | Description
Public method | ApplyDefaultFieldValues | Writes default values specified in schema into fields. Pass overwrite=true to force defaults over non-null existing values (false by default)
Protected method | CheckMinMax |
Public method | Configure | In base class applies Config attribute. Useful for typed rows
Public method | ConvertFieldValueToDef | Converts field value to the type specified by Schema.FieldDef. For example converts GDID->ulong or ulong->GDID. This method can be overridden to perform custom handling of types, for example one can assign bool field as "Si" that would convert to TRUE. This method is called by SetFieldValue(...) before assigning actual field buffer
Public method | CopyFields | Copies fields from this row into another row/form. Note: this is shallow copy, as field values for complex types are just copied over
Public method | Equals(Object) | Object override - sealed. Override Equals(row) instead (Overrides Online Object Equals(Object).)
Public method | Equals(Row) | Override to perform custom row equality comparison. Default implementation equates rows using their key fields
Protected method | FilterJSONSerializerField | Override to filter-out some fields from serialization to JSON, or change field values. Return name null to indicate that field should be filtered-out(excluded from serialization to JSON)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetClientFieldDef | Override to perform dynamic substitute of field def for the specified field. This method is used by client ui/scaffolding to extract dynamic definition for a field (i.e. field description, requirement, value list etc.) as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original field def, you can return a substituted field def per particular business logic
Public method | GetClientFieldValue | Override to perform dynamic substitute of field value for the specified field. This method is used by client ui/scaffolding to extract field values for a field as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original GetFieldValue(fdef), you can return a substituted field value per particular business logic
Public method | GetClientFieldValueList | Override to perform dynamic lookup of field value list for the specified field. This method is used by client ui/scaffolding to extract dynamic lookup values as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. This is a simplified version of GetClientFieldDef
Public method | GetDataStoreKey | Returns values for fields that represent row's primary key
Public method | GetDisplayFieldValue(Int32, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute
Public method | GetDisplayFieldValue(String, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute
Public method | GetEnumerator |
Public method | GetFieldValue | Gets value of the field, for typerows it accesses property using reflection; for dynamic rows it reads data from row buffer array using field index(order)
Public method | GetFieldValueDescription(Int32, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema
Public method | GetFieldValueDescription(String, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema
Public method | GetHashCode | Object override - gets hash code from key fields (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | MakeRow | Factory method that makes an appropriate row type.For performance purposes, this method does not check passed type for Row-derivation and returns null instead if type was invalid
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PersistConfiguration | The base class does not implement this method. Override to persist row fields into config node
Public method | SetFieldValue | Sets value of the field, for typerows it accesses property using reflection; for dynamic rows it sets data into row buffer array using field index(order)
Public method | SimpleFilterPredicate | Returns true if this row satisfies simple filter - it contains the supplied filter string. The filter pattern may start or end with "*" char that denotes a wildcard. A wildcard is permitted on both sides of the filter value
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
 | TryFillFromJSON | Tries to fill the row with data returning true if field count matched
Public method | Validate | Performs validation of data in the row returning exception object that provides description in cases when validation does not pass. Validation is performed not targeting any particular backend
Public method | Validate(String) | Validates row using row schema and supplied field definitions. Override to perform custom validations, i.e. TypeRows may directly access properties and write some validation type-safe code The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated
Public method | ValidateField(String, Schema FieldDef) | Validates row field using Schema.FieldDef settings. This method is invoked by base Validate() implementation. The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated
Public method | ValidateField(String, String) | Validates row field by name. Shortcut to ValidateField(Schema.FieldDef)
Public method | WriteAsJSON | Writes row as JSON either as an array or map depending on JSONWritingOptions.RowsAsMap setting. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class
Back to Top
Extension Methods
Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable Object | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct Object, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax Object, TComparand (Func Object, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax Object, TComparand (Func Object, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin Object, TComparand (Func Object, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin Object, TComparand (Func Object, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method FirstOrAnyOrDefault Object
Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null)
(Defined by CollectionUtils.)
Public Extension Method ForEach Object (Action Object ) Overloaded.
Runs some method over each element of src sequence
(Defined by CollectionUtils.)
Public Extension Method ForEach Object (Action Object, Int32 ) Overloaded.
Runs some method over each element of src sequence
(Defined by CollectionUtils.)
Public Extension Method SkipLast Object Overloaded.
Takes all elements except for last element from the given source
(Defined by CollectionUtils.)
Public Extension Method SkipLast Object (Int32) Overloaded.
Takes all but last N elements from the source
(Defined by CollectionUtils.)
Public Extension Method ToErlObject Overloaded.
Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(ErlTypeOrder, Boolean) Overloaded.
Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(String, String, Boolean) Overloaded.
Convert Row to a hierarchical term that corresponds to the row's schema. The Erlang term is in the form:
View Colorized Copy to Clipboard Print
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
(Defined by ErlSchemaUtils.)
Public Extension Method ToJSON(JSONWritingOptions) Overloaded.
Serializes object into JSON string
(Defined by JSONExtensions.)
Public Extension Method ToJSON(TextWriter, JSONWritingOptions) Overloaded.
Serializes object into JSON format using provided TextWriter
(Defined by JSONExtensions.)
Public Extension Method ToJSON(Stream, JSONWritingOptions, Encoding) Overloaded.
Serializes object into JSON format using provided stream and optional encoding
(Defined by JSONExtensions.)
Public Extension Method Update
Convert an Erlang hierarchical term representing a schema to a Row.
(Defined by ErlSchemaUtils.)
Back to Top
Properties
 | Name | Description
Public property | Item Int32 | Gets/sets field values by positional index(Order)
Public property | Item String | Gets/sets field values by name
Public property | Schema | References a schema for a table that this row is part of
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
Row Class
NFX.DataAccess.CRUD Namespace


Row Constructor

Row Constructor NFX Class Library

Initializes a new instance of the Row class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Row()
protected Row()
Protected Sub New
Protected Sub New
protected:
Row()
protected:
Row()
new : unit -> Row
new : unit -> Row
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


Row Methods

Row Methods NFX Class Library

The Row type exposes the following members.
Methods
 | Name | Description
Public method | ApplyDefaultFieldValues | Writes default values specified in schema into fields. Pass overwrite=true to force defaults over non-null existing values (false by default)
Protected method | CheckMinMax |
Public method | Configure | In base class applies Config attribute. Useful for typed rows
Public method | ConvertFieldValueToDef | Converts field value to the type specified by Schema.FieldDef. For example converts GDID->ulong or ulong->GDID. This method can be overridden to perform custom handling of types, for example one can assign bool field as "Si" that would convert to TRUE. This method is called by SetFieldValue(...) before assigning actual field buffer
Public method | CopyFields | Copies fields from this row into another row/form. Note: this is shallow copy, as field values for complex types are just copied over
Public method | Equals(Object) | Object override - sealed. Override Equals(row) instead (Overrides Online Object Equals(Object).)
Public method | Equals(Row) | Override to perform custom row equality comparison. Default implementation equates rows using their key fields
Protected method | FilterJSONSerializerField | Override to filter-out some fields from serialization to JSON, or change field values. Return name null to indicate that field should be filtered-out(excluded from serialization to JSON)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetClientFieldDef | Override to perform dynamic substitute of field def for the specified field. This method is used by client ui/scaffolding to extract dynamic definition for a field (i.e. field description, requirement, value list etc.) as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original field def, you can return a substituted field def per particular business logic
Public method | GetClientFieldValue | Override to perform dynamic substitute of field value for the specified field. This method is used by client ui/scaffolding to extract field values for a field as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original GetFieldValue(fdef), you can return a substituted field value per particular business logic
Public method | GetClientFieldValueList | Override to perform dynamic lookup of field value list for the specified field. This method is used by client ui/scaffolding to extract dynamic lookup values as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. This is a simplified version of GetClientFieldDef
Public method | GetDataStoreKey | Returns values for fields that represent row's primary key
Public method | GetDisplayFieldValue(Int32, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute
Public method | GetDisplayFieldValue(String, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute
Public method | GetEnumerator |
Public method | GetFieldValue | Gets value of the field, for typerows it accesses property using reflection; for dynamic rows it reads data from row buffer array using field index(order)
Public method | GetFieldValueDescription(Int32, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema
Public method | GetFieldValueDescription(String, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema
Public method | GetHashCode | Object override - gets hash code from key fields (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | MakeRow | Factory method that makes an appropriate row type.For performance purposes, this method does not check passed type for Row-derivation and returns null instead if type was invalid
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PersistConfiguration | The base class does not implement this method. Override to persist row fields into config node
Public method | SetFieldValue | Sets value of the field, for typerows it accesses property using reflection; for dynamic rows it sets data into row buffer array using field index(order)
Public method | SimpleFilterPredicate | Returns true if this row satisfies simple filter - it contains the supplied filter string. The filter pattern may start or end with "*" char that denotes a wildcard. A wildcard is permitted on both sides of the filter value
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
 | TryFillFromJSON | Tries to fill the row with data returning true if field count matched
Public method | Validate | Performs validation of data in the row returning exception object that provides description in cases when validation does not pass. Validation is performed not targeting any particular backend
Public method | Validate(String) | Validates row using row schema and supplied field definitions. Override to perform custom validations, i.e. TypeRows may directly access properties and write some validation type-safe code The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated
Public method | ValidateField(String, Schema FieldDef) | Validates row field using Schema.FieldDef settings. This method is invoked by base Validate() implementation. The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated
Public method | ValidateField(String, String) | Validates row field by name. Shortcut to ValidateField(Schema.FieldDef)
Public method | WriteAsJSON | Writes row as JSON either as an array or map depending on JSONWritingOptions.RowsAsMap setting. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class
Back to Top
Extension Methods
Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable Object | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct Object, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax Object, TComparand (Func Object, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax Object, TComparand (Func Object, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin Object, TComparand (Func Object, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin Object, TComparand (Func Object, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method FirstOrAnyOrDefault Object
Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null)
(Defined by CollectionUtils.)
Public Extension Method ForEach Object (Action Object ) Overloaded.
Runs some method over each element of src sequence
(Defined by CollectionUtils.)
Public Extension Method ForEach Object (Action Object, Int32 ) Overloaded.
Runs some method over each element of src sequence
(Defined by CollectionUtils.)
Public Extension Method SkipLast Object Overloaded.
Takes all elements except for last element from the given source
(Defined by CollectionUtils.)
Public Extension Method SkipLast Object (Int32) Overloaded.
Takes all but last N elements from the source
(Defined by CollectionUtils.)
Public Extension Method ToErlObject Overloaded.
Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(ErlTypeOrder, Boolean) Overloaded.
Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(String, String, Boolean) Overloaded.
Convert Row to a hierarchical term that corresponds to the row's schema. The Erlang term is in the form:
View Colorized Copy to Clipboard Print
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
(Defined by ErlSchemaUtils.)
Public Extension Method ToJSON(JSONWritingOptions) Overloaded.
Serializes object into JSON string
(Defined by JSONExtensions.)
Public Extension Method ToJSON(TextWriter, JSONWritingOptions) Overloaded.
Serializes object into JSON format using provided TextWriter
(Defined by JSONExtensions.)
Public Extension Method ToJSON(Stream, JSONWritingOptions, Encoding) Overloaded.
Serializes object into JSON format using provided stream and optional encoding
(Defined by JSONExtensions.)
Public Extension Method Update
Convert an Erlang hierarchical term representing a schema to a Row.
(Defined by ErlSchemaUtils.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
Row Class
NFX.DataAccess.CRUD Namespace


Row.IEnumerable.GetEnumerator Method

Row IEnumerable GetEnumerator Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


Row.ApplyDefaultFieldValues Method

Row ApplyDefaultFieldValues Method NFX Class Library

Writes default values specified in schema into fields. Pass overwrite=true to force defaults over non-null existing values (false by default)

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ApplyDefaultFieldValues(
    string targetName = null,
    bool overwrite = false
)
public void ApplyDefaultFieldValues(
    string targetName = null,
    bool overwrite = false
)
Public Sub ApplyDefaultFieldValues (
    Optional targetName As String = Nothing,
    Optional overwrite As Boolean = false
)
Public Sub ApplyDefaultFieldValues (
    Optional targetName As String = Nothing,
    Optional overwrite As Boolean = false
)
public:
void ApplyDefaultFieldValues(
    String^ targetName = nullptr,
    bool overwrite = false
)
public:
void ApplyDefaultFieldValues(
    String^ targetName = nullptr,
    bool overwrite = false
)
member ApplyDefaultFieldValues :
        ?targetName : string *
        ?overwrite : bool
(* Defaults:
        let _targetName = defaultArg targetName null
        let _overwrite = defaultArg overwrite false
*)
-> unit
member ApplyDefaultFieldValues :
        ?targetName : string *
        ?overwrite : bool
(* Defaults:
        let _targetName = defaultArg targetName null
        let _overwrite = defaultArg overwrite false
*)
-> unit

Parameters

targetName (Optional)
Type: Online System String
overwrite (Optional)
Type: Online System Boolean
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


Row.CheckMinMax Method

Row CheckMinMax Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Exception CheckMinMax(
    FieldAttribute atr,
    string fName,
    IComparable val
)
protected Exception CheckMinMax(
    FieldAttribute atr,
    string fName,
    IComparable val
)
Protected Function CheckMinMax (
    atr As FieldAttribute,
    fName As String,
    val As IComparable
) As Exception
Protected Function CheckMinMax (
    atr As FieldAttribute,
    fName As String,
    val As IComparable
) As Exception
protected:
Exception^ CheckMinMax(
    FieldAttribute^ atr,
    String^ fName,
    IComparable^ val
)
protected:
Exception^ CheckMinMax(
    FieldAttribute^ atr,
    String^ fName,
    IComparable^ val
)
member CheckMinMax :
        atr : FieldAttribute *
        fName : string *
        val : IComparable -> Exception
member CheckMinMax :
        atr : FieldAttribute *
        fName : string *
        val : IComparable -> Exception

Parameters

atr
Type: NFX.DataAccess.CRUD FieldAttribute
fName
Type: Online System String
val
Type: Online System IComparable

Return Value

Type: Online Exception
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


Row.Configure Method

Row Configure Method NFX Class Library

In base class applies Config attribute. Useful for typed rows

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Configure(
    IConfigSectionNode node
)
public virtual void Configure(
    IConfigSectionNode node
)
Public Overridable Sub Configure (
    node As IConfigSectionNode
)
Public Overridable Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
)
public:
virtual void Configure(
    IConfigSectionNode^ node
)
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


Row.ConvertFieldValueToDef Method

Row ConvertFieldValueToDef Method NFX Class Library

Converts field value to the type specified by Schema.FieldDef. For example converts GDID->ulong or ulong->GDID. This method can be overridden to perform custom handling of types, for example one can assign bool field as "Si" that would convert to TRUE. This method is called by SetFieldValue(...) before assigning actual field buffer

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object ConvertFieldValueToDef(
    Schema..::..FieldDef fdef,
    Object value
)
public virtual Object ConvertFieldValueToDef(
    Schema..::..FieldDef fdef,
    Object value
)
Public Overridable Function ConvertFieldValueToDef (
    fdef As Schema..::..FieldDef,
    value As Object
) As Object
Public Overridable Function ConvertFieldValueToDef (
    fdef As Schema..::..FieldDef,
    value As Object
) As Object
public:
virtual Object^ ConvertFieldValueToDef(
    Schema..::..FieldDef^ fdef,
    Object^ value
)
public:
virtual Object^ ConvertFieldValueToDef(
    Schema..::..FieldDef^ fdef,
    Object^ value
)
abstract ConvertFieldValueToDef :
        fdef : Schema..::..FieldDef *
        value : Object -> Object
override ConvertFieldValueToDef :
        fdef : Schema..::..FieldDef *
        value : Object -> Object
abstract ConvertFieldValueToDef :
        fdef : Schema..::..FieldDef *
        value : Object -> Object
override ConvertFieldValueToDef :
        fdef : Schema..::..FieldDef *
        value : Object -> Object

Parameters

fdef
Type: NFX.DataAccess.CRUD Schema FieldDef
Field being converted
value
Type: Online System Object
Value to convert

Return Value

Type: Online Object
Converted value before assignment to field buffer
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


Row.CopyFields Method

Row CopyFields Method NFX Class Library

Copies fields from this row into another row/form. Note: this is shallow copy, as field values for complex types are just copied over

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CopyFields(
    Row other,
    bool includeAmorphousData = true,
    bool invokeAmorphousAfterLoad = true,
    Func<string, Schema..::..FieldDef, bool> fieldFilter = null,
    Func<string, string, bool> amorphousFieldFilter = null
)
public void CopyFields(
    Row other,
    bool includeAmorphousData = true,
    bool invokeAmorphousAfterLoad = true,
    Func<string, Schema..::..FieldDef, bool> fieldFilter = null,
    Func<string, string, bool> amorphousFieldFilter = null
)
Public Sub CopyFields (
    other As Row,
    Optional includeAmorphousData As Boolean = true,
    Optional invokeAmorphousAfterLoad As Boolean = true,
    Optional fieldFilter As Func(Of String, Schema..::..FieldDef, Boolean) = Nothing,
    Optional amorphousFieldFilter As Func(Of String, String, Boolean) = Nothing
)
Public Sub CopyFields (
    other As Row,
    Optional includeAmorphousData As Boolean = true,
    Optional invokeAmorphousAfterLoad As Boolean = true,
    Optional fieldFilter As Func(Of String, Schema..::..FieldDef, Boolean) = Nothing,
    Optional amorphousFieldFilter As Func(Of String, String, Boolean) = Nothing
)
public:
void CopyFields(
    Row^ other,
    bool includeAmorphousData = true,
    bool invokeAmorphousAfterLoad = true,
    Func<String^, Schema..::..FieldDef^, bool>^ fieldFilter = nullptr,
    Func<String^, String^, bool>^ amorphousFieldFilter = nullptr
)
public:
void CopyFields(
    Row^ other,
    bool includeAmorphousData = true,
    bool invokeAmorphousAfterLoad = true,
    Func<String^, Schema..::..FieldDef^, bool>^ fieldFilter = nullptr,
    Func<String^, String^, bool>^ amorphousFieldFilter = nullptr
)
member CopyFields :
        other : Row *
        ?includeAmorphousData : bool *
        ?invokeAmorphousAfterLoad : bool *
        ?fieldFilter : Func<string, Schema..::..FieldDef, bool> *
        ?amorphousFieldFilter : Func<string, string, bool>
(* Defaults:
        let _includeAmorphousData = defaultArg includeAmorphousData true
        let _invokeAmorphousAfterLoad = defaultArg invokeAmorphousAfterLoad true
        let _fieldFilter = defaultArg fieldFilter null
        let _amorphousFieldFilter = defaultArg amorphousFieldFilter null
*)
-> unit
member CopyFields :
        other : Row *
        ?includeAmorphousData : bool *
        ?invokeAmorphousAfterLoad : bool *
        ?fieldFilter : Func<string, Schema..::..FieldDef, bool> *
        ?amorphousFieldFilter : Func<string, string, bool>
(* Defaults:
        let _includeAmorphousData = defaultArg includeAmorphousData true
        let _invokeAmorphousAfterLoad = defaultArg invokeAmorphousAfterLoad true
        let _fieldFilter = defaultArg fieldFilter null
        let _amorphousFieldFilter = defaultArg amorphousFieldFilter null
*)
-> unit

Parameters

other
Type: NFX.DataAccess.CRUD Row
includeAmorphousData (Optional)
Type: Online System Boolean
invokeAmorphousAfterLoad (Optional)
Type: Online System Boolean
fieldFilter (Optional)
Type: Online System Func Online String, Schema FieldDef, Online Boolean
amorphousFieldFilter (Optional)
Type: Online System Func Online String, Online String, Online Boolean
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


Row.Equals Method

Row Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | Object override - sealed. Override Equals(row) instead (Overrides Online Object Equals(Object).)
Public method | Equals(Row) | Override to perform custom row equality comparison. Default implementation equates rows using their key fields
Back to Top
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


Row.Equals Method (Object)

Row Equals Method (Object) NFX Class Library

Object override - sealed. Override Equals(row) instead

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override sealed bool Equals(
    Object obj
)
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
Public Overrides NotOverridable Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
public:
virtual bool Equals(
    Object^ obj
) override sealed
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
Row Class
Row Members
Equals Overload
NFX.DataAccess.CRUD Namespace


Row.Equals Method (Row)

Row Equals Method (Row) NFX Class Library

Override to perform custom row equality comparison. Default implementation equates rows using their key fields

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Equals(
    Row other
)
public virtual bool Equals(
    Row other
)
Public Overridable Function Equals (
    other As Row
) As Boolean
Public Overridable Function Equals (
    other As Row
) As Boolean
public:
virtual bool Equals(
    Row^ other
)
public:
virtual bool Equals(
    Row^ other
)
abstract Equals :
        other : Row -> bool
override Equals :
        other : Row -> bool
abstract Equals :
        other : Row -> bool
override Equals :
        other : Row -> bool

Parameters

other
Type: NFX.DataAccess.CRUD Row

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
Row Class
Row Members
Equals Overload
NFX.DataAccess.CRUD Namespace


Row.FilterJSONSerializerField Method

Row FilterJSONSerializerField Method NFX Class Library

Override to filter-out some fields from serialization to JSON, or change field values. Return name null to indicate that field should be filtered-out(excluded from serialization to JSON)

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Object FilterJSONSerializerField(
    Schema..::..FieldDef def,
    JSONWritingOptions options,
    out string name
)
protected virtual Object FilterJSONSerializerField(
    Schema..::..FieldDef def,
    JSONWritingOptions options,
    out string name
)
Protected Overridable Function FilterJSONSerializerField (
    def As Schema..::..FieldDef,
    options As JSONWritingOptions,
    <OutAttribute> ByRef name As String
) As Object
Protected Overridable Function FilterJSONSerializerField (
    def As Schema..::..FieldDef,
    options As JSONWritingOptions,
    <OutAttribute> ByRef name As String
) As Object
protected:
virtual Object^ FilterJSONSerializerField(
    Schema..::..FieldDef^ def,
    JSONWritingOptions^ options,
    [OutAttribute] String^% name
)
protected:
virtual Object^ FilterJSONSerializerField(
    Schema..::..FieldDef^ def,
    JSONWritingOptions^ options,
    [OutAttribute] String^% name
)
abstract FilterJSONSerializerField :
        def : Schema..::..FieldDef *
        options : JSONWritingOptions *
        name : string byref -> Object
override FilterJSONSerializerField :
        def : Schema..::..FieldDef *
        options : JSONWritingOptions *
        name : string byref -> Object
abstract FilterJSONSerializerField :
        def : Schema..::..FieldDef *
        options : JSONWritingOptions *
        name : string byref -> Object
override FilterJSONSerializerField :
        def : Schema..::..FieldDef *
        options : JSONWritingOptions *
        name : string byref -> Object

Parameters

def
Type: NFX.DataAccess.CRUD Schema FieldDef
options
Type: NFX.Serialization.JSON JSONWritingOptions
name
Type: Online System String

Return Value

Type: Online Object
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


Row.GetClientFieldDef Method

Row GetClientFieldDef Method NFX Class Library

Override to perform dynamic substitute of field def for the specified field. This method is used by client ui/scaffolding to extract dynamic definition for a field (i.e. field description, requirement, value list etc.) as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original field def, you can return a substituted field def per particular business logic

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Schema..::..FieldDef GetClientFieldDef(
    Object callerContext,
    Schema..::..FieldDef fdef,
    string targetName,
    string isoLang
)
public virtual Schema..::..FieldDef GetClientFieldDef(
    Object callerContext,
    Schema..::..FieldDef fdef,
    string targetName,
    string isoLang
)
Public Overridable Function GetClientFieldDef (
    callerContext As Object,
    fdef As Schema..::..FieldDef,
    targetName As String,
    isoLang As String
) As Schema..::..FieldDef
Public Overridable Function GetClientFieldDef (
    callerContext As Object,
    fdef As Schema..::..FieldDef,
    targetName As String,
    isoLang As String
) As Schema..::..FieldDef
public:
virtual Schema..::..FieldDef^ GetClientFieldDef(
    Object^ callerContext,
    Schema..::..FieldDef^ fdef,
    String^ targetName,
    String^ isoLang
)
public:
virtual Schema..::..FieldDef^ GetClientFieldDef(
    Object^ callerContext,
    Schema..::..FieldDef^ fdef,
    String^ targetName,
    String^ isoLang
)
abstract GetClientFieldDef :
        callerContext : Object *
        fdef : Schema..::..FieldDef *
        targetName : string *
        isoLang : string -> Schema..::..FieldDef
override GetClientFieldDef :
        callerContext : Object *
        fdef : Schema..::..FieldDef *
        targetName : string *
        isoLang : string -> Schema..::..FieldDef
abstract GetClientFieldDef :
        callerContext : Object *
        fdef : Schema..::..FieldDef *
        targetName : string *
        isoLang : string -> Schema..::..FieldDef
override GetClientFieldDef :
        callerContext : Object *
        fdef : Schema..::..FieldDef *
        targetName : string *
        isoLang : string -> Schema..::..FieldDef

Parameters

callerContext
Type: Online System Object
fdef
Type: NFX.DataAccess.CRUD Schema FieldDef
targetName
Type: Online System String
isoLang
Type: Online System String

Return Value

Type: Schema FieldDef
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


Row.GetClientFieldValue Method

Row GetClientFieldValue Method NFX Class Library

Override to perform dynamic substitute of field value for the specified field. This method is used by client ui/scaffolding to extract field values for a field as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original GetFieldValue(fdef), you can return a substituted field value per particular business logic

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object GetClientFieldValue(
    Object callerContext,
    Schema..::..FieldDef fdef,
    string targetName,
    string isoLang
)
public virtual Object GetClientFieldValue(
    Object callerContext,
    Schema..::..FieldDef fdef,
    string targetName,
    string isoLang
)
Public Overridable Function GetClientFieldValue (
    callerContext As Object,
    fdef As Schema..::..FieldDef,
    targetName As String,
    isoLang As String
) As Object
Public Overridable Function GetClientFieldValue (
    callerContext As Object,
    fdef As Schema..::..FieldDef,
    targetName As String,
    isoLang As String
) As Object
public:
virtual Object^ GetClientFieldValue(
    Object^ callerContext,
    Schema..::..FieldDef^ fdef,
    String^ targetName,
    String^ isoLang
)
public:
virtual Object^ GetClientFieldValue(
    Object^ callerContext,
    Schema..::..FieldDef^ fdef,
    String^ targetName,
    String^ isoLang
)
abstract GetClientFieldValue :
        callerContext : Object *
        fdef : Schema..::..FieldDef *
        targetName : string *
        isoLang : string -> Object
override GetClientFieldValue :
        callerContext : Object *
        fdef : Schema..::..FieldDef *
        targetName : string *
        isoLang : string -> Object
abstract GetClientFieldValue :
        callerContext : Object *
        fdef : Schema..::..FieldDef *
        targetName : string *
        isoLang : string -> Object
override GetClientFieldValue :
        callerContext : Object *
        fdef : Schema..::..FieldDef *
        targetName : string *
        isoLang : string -> Object

Parameters

callerContext
Type: Online System Object
fdef
Type: NFX.DataAccess.CRUD Schema FieldDef
targetName
Type: Online System String
isoLang
Type: Online System String

Return Value

Type: Online Object
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


Row.GetClientFieldValueList Method

Row GetClientFieldValueList Method NFX Class Library

Override to perform dynamic lookup of field value list for the specified field. This method is used by client ui/scaffolding to extract dynamic lookup values as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. This is a simplified version of GetClientFieldDef

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual JSONDataMap GetClientFieldValueList(
    Object callerContext,
    Schema..::..FieldDef fdef,
    string targetName,
    string isoLang
)
public virtual JSONDataMap GetClientFieldValueList(
    Object callerContext,
    Schema..::..FieldDef fdef,
    string targetName,
    string isoLang
)
Public Overridable Function GetClientFieldValueList (
    callerContext As Object,
    fdef As Schema..::..FieldDef,
    targetName As String,
    isoLang As String
) As JSONDataMap
Public Overridable Function GetClientFieldValueList (
    callerContext As Object,
    fdef As Schema..::..FieldDef,
    targetName As String,
    isoLang As String
) As JSONDataMap
public:
virtual JSONDataMap^ GetClientFieldValueList(
    Object^ callerContext,
    Schema..::..FieldDef^ fdef,
    String^ targetName,
    String^ isoLang
)
public:
virtual JSONDataMap^ GetClientFieldValueList(
    Object^ callerContext,
    Schema..::..FieldDef^ fdef,
    String^ targetName,
    String^ isoLang
)
abstract GetClientFieldValueList :
        callerContext : Object *
        fdef : Schema..::..FieldDef *
        targetName : string *
        isoLang : string -> JSONDataMap
override GetClientFieldValueList :
        callerContext : Object *
        fdef : Schema..::..FieldDef *
        targetName : string *
        isoLang : string -> JSONDataMap
abstract GetClientFieldValueList :
        callerContext : Object *
        fdef : Schema..::..FieldDef *
        targetName : string *
        isoLang : string -> JSONDataMap
override GetClientFieldValueList :
        callerContext : Object *
        fdef : Schema..::..FieldDef *
        targetName : string *
        isoLang : string -> JSONDataMap

Parameters

callerContext
Type: Online System Object
fdef
Type: NFX.DataAccess.CRUD Schema FieldDef
targetName
Type: Online System String
isoLang
Type: Online System String

Return Value

Type: JSONDataMap
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


Row.GetDataStoreKey Method

Row GetDataStoreKey Method NFX Class Library

Returns values for fields that represent row's primary key

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDataStoreKey GetDataStoreKey(
    string targetName = null
)
public IDataStoreKey GetDataStoreKey(
    string targetName = null
)
Public Function GetDataStoreKey (
    Optional targetName As String = Nothing
) As IDataStoreKey
Public Function GetDataStoreKey (
    Optional targetName As String = Nothing
) As IDataStoreKey
public:
IDataStoreKey^ GetDataStoreKey(
    String^ targetName = nullptr
)
public:
IDataStoreKey^ GetDataStoreKey(
    String^ targetName = nullptr
)
member GetDataStoreKey :
        ?targetName : string
(* Defaults:
        let _targetName = defaultArg targetName null
*)
-> IDataStoreKey
member GetDataStoreKey :
        ?targetName : string
(* Defaults:
        let _targetName = defaultArg targetName null
*)
-> IDataStoreKey

Parameters

targetName (Optional)
Type: Online System String

Return Value

Type: IDataStoreKey
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


Row.GetDisplayFieldValue Method

Row GetDisplayFieldValue Method NFX Class Library

Overload List
 | Name | Description
Public method | GetDisplayFieldValue(Int32, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute
Public method | GetDisplayFieldValue(String, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute
Back to Top
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


Row.GetDisplayFieldValue Method (Int32, String, Func(Object, Object))

Row GetDisplayFieldValue Method (Int32, String, Func Object, Object ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns field value as string formatted per target DisplayFormat attribute

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetDisplayFieldValue(
    int fieldIndex,
    string targetName = null,
    Func<Object, Object> transform = null
)
public string GetDisplayFieldValue(
    int fieldIndex,
    string targetName = null,
    Func<Object, Object> transform = null
)
Public Function GetDisplayFieldValue (
    fieldIndex As Integer,
    Optional targetName As String = Nothing,
    Optional transform As Func(Of Object, Object) = Nothing
) As String
Public Function GetDisplayFieldValue (
    fieldIndex As Integer,
    Optional targetName As String = Nothing,
    Optional transform As Func(Of Object, Object) = Nothing
) As String
public:
String^ GetDisplayFieldValue(
    int fieldIndex,
    String^ targetName = nullptr,
    Func<Object^, Object^>^ transform = nullptr
)
public:
String^ GetDisplayFieldValue(
    int fieldIndex,
    String^ targetName = nullptr,
    Func<Object^, Object^>^ transform = nullptr
)
member GetDisplayFieldValue :
        fieldIndex : int *
        ?targetName : string *
        ?transform : Func<Object, Object>
(* Defaults:
        let _targetName = defaultArg targetName null
        let _transform = defaultArg transform null
*)
-> string
member GetDisplayFieldValue :
        fieldIndex : int *
        ?targetName : string *
        ?transform : Func<Object, Object>
(* Defaults:
        let _targetName = defaultArg targetName null
        let _transform = defaultArg transform null
*)
-> string

Parameters

fieldIndex
Type: Online System Int32
targetName (Optional)
Type: Online System String
transform (Optional)
Type: Online System Func Online Object, Online Object

Return Value

Type: Online String
See Also
Row Class
Row Members
GetDisplayFieldValue Overload
NFX.DataAccess.CRUD Namespace


Row.GetDisplayFieldValue Method (String, String, Func(Object, Object))

Row GetDisplayFieldValue Method (String, String, Func Object, Object ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns field value as string formatted per target DisplayFormat attribute

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetDisplayFieldValue(
    string fieldName,
    string targetName = null,
    Func<Object, Object> transform = null
)
public string GetDisplayFieldValue(
    string fieldName,
    string targetName = null,
    Func<Object, Object> transform = null
)
Public Function GetDisplayFieldValue (
    fieldName As String,
    Optional targetName As String = Nothing,
    Optional transform As Func(Of Object, Object) = Nothing
) As String
Public Function GetDisplayFieldValue (
    fieldName As String,
    Optional targetName As String = Nothing,
    Optional transform As Func(Of Object, Object) = Nothing
) As String
public:
String^ GetDisplayFieldValue(
    String^ fieldName,
    String^ targetName = nullptr,
    Func<Object^, Object^>^ transform = nullptr
)
public:
String^ GetDisplayFieldValue(
    String^ fieldName,
    String^ targetName = nullptr,
    Func<Object^, Object^>^ transform = nullptr
)
member GetDisplayFieldValue :
        fieldName : string *
        ?targetName : string *
        ?transform : Func<Object, Object>
(* Defaults:
        let _targetName = defaultArg targetName null
        let _transform = defaultArg transform null
*)
-> string
member GetDisplayFieldValue :
        fieldName : string *
        ?targetName : string *
        ?transform : Func<Object, Object>
(* Defaults:
        let _targetName = defaultArg targetName null
        let _transform = defaultArg transform null
*)
-> string

Parameters

fieldName
Type: Online System String
targetName (Optional)
Type: Online System String
transform (Optional)
Type: Online System Func Online Object, Online Object

Return Value

Type: Online String
See Also
Row Class
Row Members
GetDisplayFieldValue Overload
NFX.DataAccess.CRUD Namespace


Row.GetEnumerator Method

Row GetEnumerator Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<Object> GetEnumerator()
public IEnumerator<Object> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of Object)
Public Function GetEnumerator As IEnumerator(Of Object)
public:
virtual IEnumerator<Object^>^ GetEnumerator() sealed
public:
virtual IEnumerator<Object^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<Object>
override GetEnumerator : unit -> IEnumerator<Object>
abstract GetEnumerator : unit -> IEnumerator<Object>
override GetEnumerator : unit -> IEnumerator<Object>

Return Value

Type: Online IEnumerator Online Object

Implements

Online IEnumerable T GetEnumerator
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


Row.GetFieldValue Method

Row GetFieldValue Method NFX Class Library

Gets value of the field, for typerows it accesses property using reflection; for dynamic rows it reads data from row buffer array using field index(order)

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Object GetFieldValue(
    Schema..::..FieldDef fdef
)
public abstract Object GetFieldValue(
    Schema..::..FieldDef fdef
)
Public MustOverride Function GetFieldValue (
    fdef As Schema..::..FieldDef
) As Object
Public MustOverride Function GetFieldValue (
    fdef As Schema..::..FieldDef
) As Object
public:
virtual Object^ GetFieldValue(
    Schema..::..FieldDef^ fdef
) abstract
public:
virtual Object^ GetFieldValue(
    Schema..::..FieldDef^ fdef
) abstract
abstract GetFieldValue :
        fdef : Schema..::..FieldDef -> Object
abstract GetFieldValue :
        fdef : Schema..::..FieldDef -> Object

Parameters

fdef
Type: NFX.DataAccess.CRUD Schema FieldDef

Return Value

Type: Online Object
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


Row.GetFieldValueDescription Method

Row GetFieldValueDescription Method NFX Class Library

Overload List
 | Name | Description
Public method | GetFieldValueDescription(Int32, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema
Public method | GetFieldValueDescription(String, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema
Back to Top
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


Row.GetFieldValueDescription Method (Int32, String, Boolean)

Row GetFieldValueDescription Method (Int32, String, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

For fields with ValueList returns value's description per specified targeted schema

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetFieldValueDescription(
    int fieldIndex,
    string targetName = null,
    bool caseSensitiveKeys = false
)
public string GetFieldValueDescription(
    int fieldIndex,
    string targetName = null,
    bool caseSensitiveKeys = false
)
Public Function GetFieldValueDescription (
    fieldIndex As Integer,
    Optional targetName As String = Nothing,
    Optional caseSensitiveKeys As Boolean = false
) As String
Public Function GetFieldValueDescription (
    fieldIndex As Integer,
    Optional targetName As String = Nothing,
    Optional caseSensitiveKeys As Boolean = false
) As String
public:
String^ GetFieldValueDescription(
    int fieldIndex,
    String^ targetName = nullptr,
    bool caseSensitiveKeys = false
)
public:
String^ GetFieldValueDescription(
    int fieldIndex,
    String^ targetName = nullptr,
    bool caseSensitiveKeys = false
)
member GetFieldValueDescription :
        fieldIndex : int *
        ?targetName : string *
        ?caseSensitiveKeys : bool
(* Defaults:
        let _targetName = defaultArg targetName null
        let _caseSensitiveKeys = defaultArg caseSensitiveKeys false
*)
-> string
member GetFieldValueDescription :
        fieldIndex : int *
        ?targetName : string *
        ?caseSensitiveKeys : bool
(* Defaults:
        let _targetName = defaultArg targetName null
        let _caseSensitiveKeys = defaultArg caseSensitiveKeys false
*)
-> string

Parameters

fieldIndex
Type: Online System Int32
targetName (Optional)
Type: Online System String
caseSensitiveKeys (Optional)
Type: Online System Boolean

Return Value

Type: Online String
See Also
Row Class
Row Members
GetFieldValueDescription Overload
NFX.DataAccess.CRUD Namespace


Row.GetFieldValueDescription Method (String, String, Boolean)

Row GetFieldValueDescription Method (String, String, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

For fields with ValueList returns value's description per specified targeted schema

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetFieldValueDescription(
    string fieldName,
    string targetName = null,
    bool caseSensitiveKeys = false
)
public string GetFieldValueDescription(
    string fieldName,
    string targetName = null,
    bool caseSensitiveKeys = false
)
Public Function GetFieldValueDescription (
    fieldName As String,
    Optional targetName As String = Nothing,
    Optional caseSensitiveKeys As Boolean = false
) As String
Public Function GetFieldValueDescription (
    fieldName As String,
    Optional targetName As String = Nothing,
    Optional caseSensitiveKeys As Boolean = false
) As String
public:
String^ GetFieldValueDescription(
    String^ fieldName,
    String^ targetName = nullptr,
    bool caseSensitiveKeys = false
)
public:
String^ GetFieldValueDescription(
    String^ fieldName,
    String^ targetName = nullptr,
    bool caseSensitiveKeys = false
)
member GetFieldValueDescription :
        fieldName : string *
        ?targetName : string *
        ?caseSensitiveKeys : bool
(* Defaults:
        let _targetName = defaultArg targetName null
        let _caseSensitiveKeys = defaultArg caseSensitiveKeys false
*)
-> string
member GetFieldValueDescription :
        fieldName : string *
        ?targetName : string *
        ?caseSensitiveKeys : bool
(* Defaults:
        let _targetName = defaultArg targetName null
        let _caseSensitiveKeys = defaultArg caseSensitiveKeys false
*)
-> string

Parameters

fieldName
Type: Online System String
targetName (Optional)
Type: Online System String
caseSensitiveKeys (Optional)
Type: Online System Boolean

Return Value

Type: Online String
See Also
Row Class
Row Members
GetFieldValueDescription Overload
NFX.DataAccess.CRUD Namespace


Row.GetHashCode Method

Row GetHashCode Method NFX Class Library

Object override - gets hash code from key fields

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


Row.MakeRow Method

Row MakeRow Method NFX Class Library

Factory method that makes an appropriate row type.For performance purposes, this method does not check passed type for Row-derivation and returns null instead if type was invalid

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Row MakeRow(
    Schema schema,
    Type tRow = null
)
public static Row MakeRow(
    Schema schema,
    Type tRow = null
)
Public Shared Function MakeRow (
    schema As Schema,
    Optional tRow As Type = Nothing
) As Row
Public Shared Function MakeRow (
    schema As Schema,
    Optional tRow As Type = Nothing
) As Row
public:
static Row^ MakeRow(
    Schema^ schema,
    Type^ tRow = nullptr
)
public:
static Row^ MakeRow(
    Schema^ schema,
    Type^ tRow = nullptr
)
static member MakeRow :
        schema : Schema *
        ?tRow : Type
(* Defaults:
        let _tRow = defaultArg tRow null
*)
-> Row
static member MakeRow :
        schema : Schema *
        ?tRow : Type
(* Defaults:
        let _tRow = defaultArg tRow null
*)
-> Row

Parameters

schema
Type: NFX.DataAccess.CRUD Schema
Schema, which is used for creation of DynamicRows and their derivatives
tRow (Optional)
Type: Online System Type
A type of row to create, if the type is TypedRow-descending then a parameterless .ctor is called, otherwise a type must have a .ctor that takes schema as a sole argument

Return Value

Type: Row
Row instance or null if wrong type was passed. For performance purposes, this method does not check passed type for Row-derivation and returns null instead if type was invalid
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


Row.PersistConfiguration Method

Row PersistConfiguration Method NFX Class Library

The base class does not implement this method. Override to persist row fields into config node

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void PersistConfiguration(
    ConfigSectionNode node
)
public virtual void PersistConfiguration(
    ConfigSectionNode node
)
Public Overridable Sub PersistConfiguration (
    node As ConfigSectionNode
)
Public Overridable Sub PersistConfiguration (
    node As ConfigSectionNode
)
public:
virtual void PersistConfiguration(
    ConfigSectionNode^ node
)
public:
virtual void PersistConfiguration(
    ConfigSectionNode^ node
)
abstract PersistConfiguration :
        node : ConfigSectionNode -> unit
override PersistConfiguration :
        node : ConfigSectionNode -> unit
abstract PersistConfiguration :
        node : ConfigSectionNode -> unit
override PersistConfiguration :
        node : ConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment ConfigSectionNode

Implements

IConfigurationPersistent PersistConfiguration(ConfigSectionNode)
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


Row.SetFieldValue Method

Row SetFieldValue Method NFX Class Library

Sets value of the field, for typerows it accesses property using reflection; for dynamic rows it sets data into row buffer array using field index(order)

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void SetFieldValue(
    Schema..::..FieldDef fdef,
    Object value
)
public abstract void SetFieldValue(
    Schema..::..FieldDef fdef,
    Object value
)
Public MustOverride Sub SetFieldValue (
    fdef As Schema..::..FieldDef,
    value As Object
)
Public MustOverride Sub SetFieldValue (
    fdef As Schema..::..FieldDef,
    value As Object
)
public:
virtual void SetFieldValue(
    Schema..::..FieldDef^ fdef,
    Object^ value
) abstract
public:
virtual void SetFieldValue(
    Schema..::..FieldDef^ fdef,
    Object^ value
) abstract
abstract SetFieldValue :
        fdef : Schema..::..FieldDef *
        value : Object -> unit
abstract SetFieldValue :
        fdef : Schema..::..FieldDef *
        value : Object -> unit

Parameters

fdef
Type: NFX.DataAccess.CRUD Schema FieldDef
value
Type: Online System Object
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


Row.SimpleFilterPredicate Method

Row SimpleFilterPredicate Method NFX Class Library

Returns true if this row satisfies simple filter - it contains the supplied filter string. The filter pattern may start or end with "*" char that denotes a wildcard. A wildcard is permitted on both sides of the filter value

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SimpleFilterPredicate(
    string filter,
    bool caseSensitive = false
)
public bool SimpleFilterPredicate(
    string filter,
    bool caseSensitive = false
)
Public Function SimpleFilterPredicate (
    filter As String,
    Optional caseSensitive As Boolean = false
) As Boolean
Public Function SimpleFilterPredicate (
    filter As String,
    Optional caseSensitive As Boolean = false
) As Boolean
public:
bool SimpleFilterPredicate(
    String^ filter,
    bool caseSensitive = false
)
public:
bool SimpleFilterPredicate(
    String^ filter,
    bool caseSensitive = false
)
member SimpleFilterPredicate :
        filter : string *
        ?caseSensitive : bool
(* Defaults:
        let _caseSensitive = defaultArg caseSensitive false
*)
-> bool
member SimpleFilterPredicate :
        filter : string *
        ?caseSensitive : bool
(* Defaults:
        let _caseSensitive = defaultArg caseSensitive false
*)
-> bool

Parameters

filter
Type: Online System String
caseSensitive (Optional)
Type: Online System Boolean

Return Value

Type: Online Boolean
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


Row.TryFillFromJSON Method

Row TryFillFromJSON Method NFX Class Library

Tries to fill the row with data returning true if field count matched

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool TryFillFromJSON(
    Row row,
    IJSONDataObject jsonData,
    SetFieldFunc setFieldFunc = null
)
public static bool TryFillFromJSON(
    Row row,
    IJSONDataObject jsonData,
    SetFieldFunc setFieldFunc = null
)
Public Shared Function TryFillFromJSON (
    row As Row,
    jsonData As IJSONDataObject,
    Optional setFieldFunc As SetFieldFunc = Nothing
) As Boolean
Public Shared Function TryFillFromJSON (
    row As Row,
    jsonData As IJSONDataObject,
    Optional setFieldFunc As SetFieldFunc = Nothing
) As Boolean
public:
static bool TryFillFromJSON(
    Row^ row,
    IJSONDataObject^ jsonData,
    SetFieldFunc^ setFieldFunc = nullptr
)
public:
static bool TryFillFromJSON(
    Row^ row,
    IJSONDataObject^ jsonData,
    SetFieldFunc^ setFieldFunc = nullptr
)
static member TryFillFromJSON :
        row : Row *
        jsonData : IJSONDataObject *
        ?setFieldFunc : SetFieldFunc
(* Defaults:
        let _setFieldFunc = defaultArg setFieldFunc null
*)
-> bool
static member TryFillFromJSON :
        row : Row *
        jsonData : IJSONDataObject *
        ?setFieldFunc : SetFieldFunc
(* Defaults:
        let _setFieldFunc = defaultArg setFieldFunc null
*)
-> bool

Parameters

row
Type: NFX.DataAccess.CRUD Row
jsonData
Type: NFX.Serialization.JSON IJSONDataObject
setFieldFunc (Optional)
Type: NFX.DataAccess.CRUD SetFieldFunc

Return Value

Type: Online Boolean
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


Row.Validate Method

Row Validate Method NFX Class Library

Overload List
 | Name | Description
Public method | Validate | Performs validation of data in the row returning exception object that provides description in cases when validation does not pass. Validation is performed not targeting any particular backend
Public method | Validate(String) | Validates row using row schema and supplied field definitions. Override to perform custom validations, i.e. TypeRows may directly access properties and write some validation type-safe code The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated
Back to Top
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


Row.Validate Method

Row Validate Method NFX Class Library

Performs validation of data in the row returning exception object that provides description in cases when validation does not pass. Validation is performed not targeting any particular backend

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Exception Validate()
public virtual Exception Validate()
Public Overridable Function Validate As Exception
Public Overridable Function Validate As Exception
public:
virtual Exception^ Validate()
public:
virtual Exception^ Validate()
abstract Validate : unit -> Exception
override Validate : unit -> Exception
abstract Validate : unit -> Exception
override Validate : unit -> Exception

Return Value

Type: Online Exception
See Also
Row Class
Row Members
Validate Overload
NFX.DataAccess.CRUD Namespace


Row.Validate Method (String)

Row Validate Method (String) NFX Class Library

Validates row using row schema and supplied field definitions. Override to perform custom validations, i.e. TypeRows may directly access properties and write some validation type-safe code The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Exception Validate(
    string targetName
)
public virtual Exception Validate(
    string targetName
)
Public Overridable Function Validate (
    targetName As String
) As Exception
Public Overridable Function Validate (
    targetName As String
) As Exception
public:
virtual Exception^ Validate(
    String^ targetName
)
public:
virtual Exception^ Validate(
    String^ targetName
)
abstract Validate :
        targetName : string -> Exception
override Validate :
        targetName : string -> Exception
abstract Validate :
        targetName : string -> Exception
override Validate :
        targetName : string -> Exception

Parameters

targetName
Type: Online System String

Return Value

Type: Online Exception

Implements

IValidatable Validate(String)
See Also
Row Class
Row Members
Validate Overload
NFX.DataAccess.CRUD Namespace


Row.ValidateField Method

Row ValidateField Method NFX Class Library

Overload List
 | Name | Description
Public method | ValidateField(String, Schema FieldDef) | Validates row field using Schema.FieldDef settings. This method is invoked by base Validate() implementation. The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated
Public method | ValidateField(String, String) | Validates row field by name. Shortcut to ValidateField(Schema.FieldDef)
Back to Top
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


Row.ValidateField Method (String, Schema.FieldDef)

Row ValidateField Method (String, Schema FieldDef) NFX Class Library

[This is preliminary documentation and is subject to change.]

Validates row field using Schema.FieldDef settings. This method is invoked by base Validate() implementation. The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Exception ValidateField(
    string targetName,
    Schema..::..FieldDef fdef
)
public virtual Exception ValidateField(
    string targetName,
    Schema..::..FieldDef fdef
)
Public Overridable Function ValidateField (
    targetName As String,
    fdef As Schema..::..FieldDef
) As Exception
Public Overridable Function ValidateField (
    targetName As String,
    fdef As Schema..::..FieldDef
) As Exception
public:
virtual Exception^ ValidateField(
    String^ targetName,
    Schema..::..FieldDef^ fdef
)
public:
virtual Exception^ ValidateField(
    String^ targetName,
    Schema..::..FieldDef^ fdef
)
abstract ValidateField :
        targetName : string *
        fdef : Schema..::..FieldDef -> Exception
override ValidateField :
        targetName : string *
        fdef : Schema..::..FieldDef -> Exception
abstract ValidateField :
        targetName : string *
        fdef : Schema..::..FieldDef -> Exception
override ValidateField :
        targetName : string *
        fdef : Schema..::..FieldDef -> Exception

Parameters

targetName
Type: Online System String
fdef
Type: NFX.DataAccess.CRUD Schema FieldDef

Return Value

Type: Online Exception
See Also
Row Class
Row Members
ValidateField Overload
NFX.DataAccess.CRUD Namespace


Row.ValidateField Method (String, String)

Row ValidateField Method (String, String) NFX Class Library

Validates row field by name. Shortcut to ValidateField(Schema.FieldDef)

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Exception ValidateField(
    string targetName,
    string fname
)
public Exception ValidateField(
    string targetName,
    string fname
)
Public Function ValidateField (
    targetName As String,
    fname As String
) As Exception
Public Function ValidateField (
    targetName As String,
    fname As String
) As Exception
public:
Exception^ ValidateField(
    String^ targetName,
    String^ fname
)
public:
Exception^ ValidateField(
    String^ targetName,
    String^ fname
)
member ValidateField :
        targetName : string *
        fname : string -> Exception
member ValidateField :
        targetName : string *
        fname : string -> Exception

Parameters

targetName
Type: Online System String
fname
Type: Online System String

Return Value

Type: Online Exception
See Also
Row Class
Row Members
ValidateField Overload
NFX.DataAccess.CRUD Namespace


Row.WriteAsJSON Method

Row WriteAsJSON Method NFX Class Library

Writes row as JSON either as an array or map depending on JSONWritingOptions.RowsAsMap setting. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
nestingLevel
Type: Online System Int32
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Implements

IJSONWritable WriteAsJSON(TextWriter, Int32, JSONWritingOptions)
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


Row Properties

Row Properties NFX Class Library

The Row type exposes the following members.
Properties
 | Name | Description
Public property | Item Int32 | Gets/sets field values by positional index(Order)
Public property | Item String | Gets/sets field values by name
Public property | Schema | References a schema for a table that this row is part of
Back to Top
See Also
Row Class
NFX.DataAccess.CRUD Namespace


Row.Item Property

Row Item Property NFX Class Library

Overload List
 | Name | Description
Public property | Item Int32 | Gets/sets field values by positional index(Order)
Public property | Item String | Gets/sets field values by name
Back to Top
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


Row.Item Property (Int32)

Row Item Property (Int32) NFX Class Library

Gets/sets field values by positional index(Order)

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object this[
    int fieldIdx
] { get; set; }
public Object this[
    int fieldIdx
] { get; set; }
Public Default Property Item (
    fieldIdx As Integer
) As Object
    Get
    Set
Public Default Property Item (
    fieldIdx As Integer
) As Object
    Get
    Set
public:
property Object^ default[int fieldIdx] {
    Object^ get (int fieldIdx);
    void set (int fieldIdx, Object^ value);
}
public:
property Object^ default[int fieldIdx] {
    Object^ get (int fieldIdx);
    void set (int fieldIdx, Object^ value);
}
member Item : Object with get, set
member Item : Object with get, set

Parameters

fieldIdx
Type: Online System Int32

Property Value

Type: Online Object
See Also
Row Class
Row Members
Item Overload
NFX.DataAccess.CRUD Namespace


Row.Item Property (String)

Row Item Property (String) NFX Class Library

Gets/sets field values by name

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object this[
    string fieldName
] { get; set; }
public Object this[
    string fieldName
] { get; set; }
Public Default Property Item (
    fieldName As String
) As Object
    Get
    Set
Public Default Property Item (
    fieldName As String
) As Object
    Get
    Set
public:
property Object^ default[String^ fieldName] {
    Object^ get (String^ fieldName);
    void set (String^ fieldName, Object^ value);
}
public:
property Object^ default[String^ fieldName] {
    Object^ get (String^ fieldName);
    void set (String^ fieldName, Object^ value);
}
member Item : Object with get, set
member Item : Object with get, set

Parameters

fieldName
Type: Online System String

Property Value

Type: Online Object
See Also
Row Class
Row Members
Item Overload
NFX.DataAccess.CRUD Namespace


Row.Schema Property

Row Schema Property NFX Class Library

References a schema for a table that this row is part of

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Schema Schema { get; }
public abstract Schema Schema { get; }
Public MustOverride ReadOnly Property Schema As Schema
    Get
Public MustOverride ReadOnly Property Schema As Schema
    Get
public:
virtual property Schema^ Schema {
    Schema^ get () abstract;
}
public:
virtual property Schema^ Schema {
    Schema^ get () abstract;
}
abstract Schema : Schema with get
abstract Schema : Schema with get

Property Value

Type: Schema
See Also
Row Class
Row Members
NFX.DataAccess.CRUD Namespace


RowChange Structure

RowChange Structure NFX Class Library

Describes row modification

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct RowChange
public struct RowChange
Public Structure RowChange
Public Structure RowChange
public value class RowChange
public value class RowChange
[<SealedAttribute>]
type RowChange =  struct end
[<SealedAttribute>]
type RowChange =  struct end
See Also
RowChange Members
NFX.DataAccess.CRUD Namespace


RowChange Members

RowChange Members NFX Class Library

The RowChange type exposes the following members.
Constructors
 | Name | Description
Public method | RowChange | Initializes a new instance of the RowChange class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | ChangeType |
Public field | Key |
Public field | Row |
Back to Top
See Also
RowChange Structure
NFX.DataAccess.CRUD Namespace


RowChange Constructor

RowChange Constructor NFX Class Library

Initializes a new instance of the RowChange class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RowChange(
    RowChangeType type,
    Row row,
    IDataStoreKey key
)
public RowChange(
    RowChangeType type,
    Row row,
    IDataStoreKey key
)
Public Sub New (
    type As RowChangeType,
    row As Row,
    key As IDataStoreKey
)
Public Sub New (
    type As RowChangeType,
    row As Row,
    key As IDataStoreKey
)
public:
RowChange(
    RowChangeType type,
    Row^ row,
    IDataStoreKey^ key
)
public:
RowChange(
    RowChangeType type,
    Row^ row,
    IDataStoreKey^ key
)
new :
        type : RowChangeType *
        row : Row *
        key : IDataStoreKey -> RowChange
new :
        type : RowChangeType *
        row : Row *
        key : IDataStoreKey -> RowChange

Parameters

type
Type: NFX.DataAccess.CRUD RowChangeType
row
Type: NFX.DataAccess.CRUD Row
key
Type: NFX.DataAccess IDataStoreKey
See Also
RowChange Structure
RowChange Members
NFX.DataAccess.CRUD Namespace


RowChange Fields

RowChange Fields NFX Class Library

The RowChange type exposes the following members.
Fields
 | Name | Description
Public field | ChangeType |
Public field | Key |
Public field | Row |
Back to Top
See Also
RowChange Structure
NFX.DataAccess.CRUD Namespace


RowChange.ChangeType Field

RowChange ChangeType Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly RowChangeType ChangeType
public readonly RowChangeType ChangeType
Public ReadOnly ChangeType As RowChangeType
Public ReadOnly ChangeType As RowChangeType
public:
initonly RowChangeType ChangeType
public:
initonly RowChangeType ChangeType
val ChangeType: RowChangeType
val ChangeType: RowChangeType

Field Value

Type: RowChangeType
See Also
RowChange Structure
RowChange Members
NFX.DataAccess.CRUD Namespace


RowChange.Key Field

RowChange Key Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly IDataStoreKey Key
public readonly IDataStoreKey Key
Public ReadOnly Key As IDataStoreKey
Public ReadOnly Key As IDataStoreKey
public:
initonly IDataStoreKey^ Key
public:
initonly IDataStoreKey^ Key
val Key: IDataStoreKey
val Key: IDataStoreKey

Field Value

Type: IDataStoreKey
See Also
RowChange Structure
RowChange Members
NFX.DataAccess.CRUD Namespace


RowChange.Row Field

RowChange Row Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Row Row
public readonly Row Row
Public ReadOnly Row As Row
Public ReadOnly Row As Row
public:
initonly Row^ Row
public:
initonly Row^ Row
val Row: Row
val Row: Row

Field Value

Type: Row
See Also
RowChange Structure
RowChange Members
NFX.DataAccess.CRUD Namespace


RowChange Methods

RowChange Methods NFX Class Library

The RowChange type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
RowChange Structure
NFX.DataAccess.CRUD Namespace


RowChangeType Enumeration

RowChangeType Enumeration NFX Class Library

Describes what kind of modification was done

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum RowChangeType
public enum RowChangeType
Public Enumeration RowChangeType
Public Enumeration RowChangeType
public enum class RowChangeType
public enum class RowChangeType
type RowChangeType
type RowChangeType
Members
Member name | Value | Description
Insert | 0 |
Upsert | 1 |
Update | 2 |
Delete | 3 |
See Also
NFX.DataAccess.CRUD Namespace


RowEqualityComparer Class

RowEqualityComparer Class NFX Class Library

Checks for reference equality. Use RowEqualityComparer.Instance
Inheritance Hierarchy
Online System Object
Online System.Collections.Generic EqualityComparer Row
NFX.DataAccess.CRUD RowEqualityComparer

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class RowEqualityComparer : EqualityComparer<Row>
public sealed class RowEqualityComparer : EqualityComparer<Row>
Public NotInheritable Class RowEqualityComparer
    Inherits EqualityComparer(Of Row)
Public NotInheritable Class RowEqualityComparer
    Inherits EqualityComparer(Of Row)
public ref class RowEqualityComparer sealed : public EqualityComparer<Row^>
public ref class RowEqualityComparer sealed : public EqualityComparer<Row^>
[<SealedAttribute>]
type RowEqualityComparer =
    class
        inherit EqualityComparer<Row>
    end
[<SealedAttribute>]
type RowEqualityComparer =
    class
        inherit EqualityComparer<Row>
    end
See Also
RowEqualityComparer Members
NFX.DataAccess.CRUD Namespace


RowEqualityComparer Members

RowEqualityComparer Members NFX Class Library

The RowEqualityComparer type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Equals(Row, Row) | (Overrides Online EqualityComparer T Equals(T, T).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetHashCode(Row) | (Overrides Online EqualityComparer T GetHashCode(T).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
Name | Description
Instance |
Back to Top
See Also
RowEqualityComparer Class
NFX.DataAccess.CRUD Namespace


RowEqualityComparer Methods

RowEqualityComparer Methods NFX Class Library

The RowEqualityComparer type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Equals(Row, Row) | (Overrides Online EqualityComparer T Equals(T, T).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetHashCode(Row) | (Overrides Online EqualityComparer T GetHashCode(T).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
RowEqualityComparer Class
NFX.DataAccess.CRUD Namespace


RowEqualityComparer.Equals Method

RowEqualityComparer Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Online Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Equals(Row, Row) | (Overrides Online EqualityComparer T Equals(T, T).)
Back to Top
See Also
RowEqualityComparer Class
RowEqualityComparer Members
NFX.DataAccess.CRUD Namespace


RowEqualityComparer.Equals Method (Row, Row)

RowEqualityComparer Equals Method (Row, Row) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Row x,
    Row y
)
public override bool Equals(
    Row x,
    Row y
)
Public Overrides Function Equals (
    x As Row,
    y As Row
) As Boolean
Public Overrides Function Equals (
    x As Row,
    y As Row
) As Boolean
public:
virtual bool Equals(
    Row^ x,
    Row^ y
) override
public:
virtual bool Equals(
    Row^ x,
    Row^ y
) override
abstract Equals :
        x : Row *
        y : Row -> bool
override Equals :
        x : Row *
        y : Row -> bool
abstract Equals :
        x : Row *
        y : Row -> bool
override Equals :
        x : Row *
        y : Row -> bool

Parameters

x
Type: NFX.DataAccess.CRUD Row
y
Type: NFX.DataAccess.CRUD Row

Return Value

Type: Online Boolean

Implements

Online IEqualityComparer T Equals(T, T)
See Also
RowEqualityComparer Class
RowEqualityComparer Members
Equals Overload
NFX.DataAccess.CRUD Namespace


RowEqualityComparer.GetHashCode Method

RowEqualityComparer GetHashCode Method NFX Class Library

Overload List
 | Name | Description
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetHashCode(Row) | (Overrides Online EqualityComparer T GetHashCode(T).)
Back to Top
See Also
RowEqualityComparer Class
RowEqualityComparer Members
NFX.DataAccess.CRUD Namespace


RowEqualityComparer.GetHashCode Method (Row)

RowEqualityComparer GetHashCode Method (Row) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode(
    Row row
)
public override int GetHashCode(
    Row row
)
Public Overrides Function GetHashCode (
    row As Row
) As Integer
Public Overrides Function GetHashCode (
    row As Row
) As Integer
public:
virtual int GetHashCode(
    Row^ row
) override
public:
virtual int GetHashCode(
    Row^ row
) override
abstract GetHashCode :
        row : Row -> int
override GetHashCode :
        row : Row -> int
abstract GetHashCode :
        row : Row -> int
override GetHashCode :
        row : Row -> int

Parameters

row
Type: NFX.DataAccess.CRUD Row

Return Value

Type: Online Int32

Implements

Online IEqualityComparer T GetHashCode(T)
See Also
RowEqualityComparer Class
RowEqualityComparer Members
GetHashCode Overload
NFX.DataAccess.CRUD Namespace


RowEqualityComparer Properties

RowEqualityComparer Properties NFX Class Library

The RowEqualityComparer type exposes the following members.
Properties
Name | Description
Instance |
Back to Top
See Also
RowEqualityComparer Class
NFX.DataAccess.CRUD Namespace


RowEqualityComparer.Instance Property

RowEqualityComparer Instance Property NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static RowEqualityComparer Instance { get; }
public static RowEqualityComparer Instance { get; }
Public Shared ReadOnly Property Instance As RowEqualityComparer
    Get
Public Shared ReadOnly Property Instance As RowEqualityComparer
    Get
public:
static property RowEqualityComparer^ Instance {
    RowEqualityComparer^ get ();
}
public:
static property RowEqualityComparer^ Instance {
    RowEqualityComparer^ get ();
}
static member Instance : RowEqualityComparer with get
static member Instance : RowEqualityComparer with get

Property Value

Type: RowEqualityComparer
See Also
RowEqualityComparer Class
RowEqualityComparer Members
NFX.DataAccess.CRUD Namespace


Rowset Class

Rowset Class NFX Class Library

Implements a rowset that supports row change logging and CRUD operations. Rowsets are not optimal for data replication as they perform linear search which is slow, however Rowset class supports sorting. In contrast, Tables are kind of rowsets that keep data pre-sorted by key thus facilitating quick searching
Inheritance Hierarchy
Online System Object
NFX.DataAccess.CRUD RowsetBase
NFX.DataAccess.CRUD Rowset

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class Rowset : RowsetBase
[SerializableAttribute]
public class Rowset : RowsetBase
<SerializableAttribute>
Public Class Rowset
    Inherits RowsetBase
<SerializableAttribute>
Public Class Rowset
    Inherits RowsetBase
[SerializableAttribute]
public ref class Rowset : public RowsetBase
[SerializableAttribute]
public ref class Rowset : public RowsetBase
[<SerializableAttribute>]
type Rowset =
    class
        inherit RowsetBase
    end
[<SerializableAttribute>]
type Rowset =
    class
        inherit RowsetBase
    end
See Also
Rowset Members
NFX.DataAccess.CRUD Namespace


Rowset Members

Rowset Members NFX Class Library

The Rowset type exposes the following members.
Constructors
 | Name | Description
Public method | Rowset(Schema) | Creates an empty rowset
Public method | Rowset(RowsetBase, Func Row, Boolean ) | Creates a shallow copy from another rowset, optionally applying a filter
Back to Top
Methods
 | Name | Description
Public method | Add | Inserts a row (Inherited from RowsetBase.)
Protected method | Check | Checks argument for being non-null and of the same schema with this rowset (Inherited from RowsetBase.)
Public method | Clear | Purges table (Inherited from RowsetBase.)
Public method | Compare | (Overrides RowsetBase Compare(Row, Row).)
Public method | Contains | (Inherited from RowsetBase.)
Public method | CopyTo | (Inherited from RowsetBase.)
Public method | Delete( Object ) | Tries to find a row with the same set of key fields in this table and if found, deletes it and returns its index, otherwise -1 (Inherited from RowsetBase.)
Public method | Delete(Row, IDataStoreKey) | Tries to find a row with the same set of key fields in this table and if found, deletes it and returns its index, otherwise -1 (Inherited from RowsetBase.)
Public method | DeleteAll | Deletes all rows from table. This method is similar to Purge() but does logging (when enabled) (Inherited from RowsetBase.)
Protected method | DoDelete | Tries to find a row with the same set of key fields in this table and if found, deletes it and returns its index, otherwise -1 (Inherited from RowsetBase.)
Protected method | DoInsert | (Overrides RowsetBase DoInsert(Row).)
Protected method | DoUpdate | Tries to find a row with the same set of key fields in this table and if found, replaces it and returns its index, otherwise returns -1 (Inherited from RowsetBase.)
Protected method | DoUpsert | Tries to find a row with the same set of key fields in this table and if found, replaces it and returns true, otherwise inserts the row (if schemas match) and returns false. Optionally pass updateWhere condition that may check whether update needs to be performed (Inherited from RowsetBase.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FindByKey( Object ) | Tries to find a row by specified keyset and returns it or null if not found. This method does not perform well on Rowsets instances as a rowset is unordered list which does linear search. In contrast, Tables are always ordered and perform binary search instead (Inherited from RowsetBase.)
Public method | FindByKey(Row) | Tries to find a row by specified keyset and returns it or null if not found (Inherited from RowsetBase.)
Public method | FindByKey(Row, Func Row, Boolean ) | Tries to find a row by specified keyset and extra WHERE clause and returns it or null if not found. This method does not perform well on Rowsets instances as a rowset is unordered list which does linear search. In contrast, Tables are always ordered and perform binary search instead (Inherited from RowsetBase.)
Public method | FindByKey(Func Row, Boolean , Object ) | Tries to find a row by specified keyset and extra WHERE clause and returns it or null if not found (Inherited from RowsetBase.)
Public method | GetChangeAt | Retrievs a change by index or null if index is out of bounds or changes are not logged (Inherited from RowsetBase.)
Public method | GetEnumerator | (Inherited from RowsetBase.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IndexOf | (Inherited from RowsetBase.)
Public method | Insert(Row) | Inserts the row. Returns insertion index (Inherited from RowsetBase.)
Public method | Insert(Int32, Row) | Inserts row at index (Inherited from RowsetBase.)
Public method | KeyRowFromValues | Creates key row out of field values for keys (Inherited from RowsetBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Purge | Deletes all rows from table without logging the deleted modifications even when LogModifications=true (Inherited from RowsetBase.)
Public method | PurgeChanges | Clears modifications accumulated by this instance (Inherited from RowsetBase.)
Public method | Remove | Performs row delete (Inherited from RowsetBase.)
Public method | RemoveAt | Deletes row (Inherited from RowsetBase.)
Protected method | SearchForRow | Provides rowsearching. Override to do binary search in sorted rowsets (Inherited from RowsetBase.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Update | Updates the row, Returns the row index or -1 (Inherited from RowsetBase.)
Public method | Upsert | Tries to find a row for update and if found, updates it and returns true, otherwise inserts the row (if schemas match) and returns false. Optionally pass updateWhere condition that may check whether update needs to be performed (Inherited from RowsetBase.)
Public method | Validate | Validates all rows in this rowset. Override to perform custom validations. The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from RowsetBase.)
Public method | WriteAsJSON | Writes rowset as JSON including schema information. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class (Inherited from RowsetBase.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Changes | (Inherited from RowsetBase.)
Protected field | m_List | (Inherited from RowsetBase.)
Protected field | m_Schema | (Inherited from RowsetBase.)
Protected field | m_SortFieldList |
Back to Top
Properties
 | Name | Description
Public property | AsReadonlyIList | Returns data as non-generic readonly IList (Inherited from RowsetBase.)
Public property | ChangeCount | Returns a count of accumulated modifications performed on the rowset, or zero when no modifications have been made or LogModifications = false (Inherited from RowsetBase.)
Public property | Changes | Returns accumulated modifications performed on the rowset, or empty enumerator if no modifications have been made or LogModifications = false (Inherited from RowsetBase.)
Public property | Context | Provides dynamic view of rowset's data context - attributes applicable to the whole rowset (Inherited from RowsetBase.)
Public property | ContextMap | Provides dynamic view as JSONDataMap of rowset's data context - attributes applicable to the whole rowset (Inherited from RowsetBase.)
Public property | Count | Returns row count in this rowset (Inherited from RowsetBase.)
Public property | InstanceGUID | Returns globaly-unique instance ID. This ID is useful as a key for storing rowsets in object stores and posting data back from web client to server. (Inherited from RowsetBase.)
Public property | IsReadOnly | (Inherited from RowsetBase.)
Public property | Item | This method performs update on set (Inherited from RowsetBase.)
Public property | LogChanges | Gets/Sets whether this rowset keeps track of all modifications done to it. This property must be set to true to be able to save changes into ICRUDDataStore (Inherited from RowsetBase.)
Public property | Schema | Returns a schema for rows that this rowset contains (Inherited from RowsetBase.)
Public property | SortDefinition | Sort definition is a comma-separated field name list where every field may optionally be prefixed with `+` for ascending or `-` for descending sort order specifier. Example: "FirstName,-DOB"
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from RowsetBase.)
Back to Top
See Also
Rowset Class
NFX.DataAccess.CRUD Namespace


Rowset Constructor

Rowset Constructor NFX Class Library

Overload List
 | Name | Description
Public method | Rowset(Schema) | Creates an empty rowset
Public method | Rowset(RowsetBase, Func Row, Boolean ) | Creates a shallow copy from another rowset, optionally applying a filter
Back to Top
See Also
Rowset Class
Rowset Members
NFX.DataAccess.CRUD Namespace


Rowset Constructor (Schema)

Rowset Constructor (Schema) NFX Class Library

Creates an empty rowset

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Rowset(
    Schema schema
)
public Rowset(
    Schema schema
)
Public Sub New (
    schema As Schema
)
Public Sub New (
    schema As Schema
)
public:
Rowset(
    Schema^ schema
)
public:
Rowset(
    Schema^ schema
)
new :
        schema : Schema -> Rowset
new :
        schema : Schema -> Rowset

Parameters

schema
Type: NFX.DataAccess.CRUD Schema
See Also
Rowset Class
Rowset Members
Rowset Overload
NFX.DataAccess.CRUD Namespace


Rowset Constructor (RowsetBase, Func(Row, Boolean))

Rowset Constructor (RowsetBase, Func Row, Boolean ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates a shallow copy from another rowset, optionally applying a filter

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Rowset(
    RowsetBase other,
    Func<Row, bool> filter = null
)
public Rowset(
    RowsetBase other,
    Func<Row, bool> filter = null
)
Public Sub New (
    other As RowsetBase,
    Optional filter As Func(Of Row, Boolean) = Nothing
)
Public Sub New (
    other As RowsetBase,
    Optional filter As Func(Of Row, Boolean) = Nothing
)
public:
Rowset(
    RowsetBase^ other,
    Func<Row^, bool>^ filter = nullptr
)
public:
Rowset(
    RowsetBase^ other,
    Func<Row^, bool>^ filter = nullptr
)
new :
        other : RowsetBase *
        ?filter : Func<Row, bool>
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Rowset
new :
        other : RowsetBase *
        ?filter : Func<Row, bool>
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Rowset

Parameters

other
Type: NFX.DataAccess.CRUD RowsetBase
filter (Optional)
Type: Online System Func Row, Online Boolean
See Also
Rowset Class
Rowset Members
Rowset Overload
NFX.DataAccess.CRUD Namespace


Rowset Fields

Rowset Fields NFX Class Library

The Rowset type exposes the following members.
Fields
 | Name | Description
Protected field | m_Changes | (Inherited from RowsetBase.)
Protected field | m_List | (Inherited from RowsetBase.)
Protected field | m_Schema | (Inherited from RowsetBase.)
Protected field | m_SortFieldList |
Back to Top
See Also
Rowset Class
NFX.DataAccess.CRUD Namespace


Rowset.m_SortFieldList Field

Rowset m_SortFieldList Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal List<string> m_SortFieldList
internal List<string> m_SortFieldList
Friend m_SortFieldList As List(Of String)
Friend m_SortFieldList As List(Of String)
internal:
List<String^>^ m_SortFieldList
internal:
List<String^>^ m_SortFieldList
val mutable internal m_SortFieldList: List<string>
val mutable internal m_SortFieldList: List<string>

Field Value

Type: Online List Online String
See Also
Rowset Class
Rowset Members
NFX.DataAccess.CRUD Namespace


Rowset Methods

Rowset Methods NFX Class Library

The Rowset type exposes the following members.
Methods
 | Name | Description
Public method | Add | Inserts a row (Inherited from RowsetBase.)
Protected method | Check | Checks argument for being non-null and of the same schema with this rowset (Inherited from RowsetBase.)
Public method | Clear | Purges table (Inherited from RowsetBase.)
Public method | Compare | (Overrides RowsetBase Compare(Row, Row).)
Public method | Contains | (Inherited from RowsetBase.)
Public method | CopyTo | (Inherited from RowsetBase.)
Public method | Delete( Object ) | Tries to find a row with the same set of key fields in this table and if found, deletes it and returns its index, otherwise -1 (Inherited from RowsetBase.)
Public method | Delete(Row, IDataStoreKey) | Tries to find a row with the same set of key fields in this table and if found, deletes it and returns its index, otherwise -1 (Inherited from RowsetBase.)
Public method | DeleteAll | Deletes all rows from table. This method is similar to Purge() but does logging (when enabled) (Inherited from RowsetBase.)
Protected method | DoDelete | Tries to find a row with the same set of key fields in this table and if found, deletes it and returns its index, otherwise -1 (Inherited from RowsetBase.)
Protected method | DoInsert | (Overrides RowsetBase DoInsert(Row).)
Protected method | DoUpdate | Tries to find a row with the same set of key fields in this table and if found, replaces it and returns its index, otherwise returns -1 (Inherited from RowsetBase.)
Protected method | DoUpsert | Tries to find a row with the same set of key fields in this table and if found, replaces it and returns true, otherwise inserts the row (if schemas match) and returns false. Optionally pass updateWhere condition that may check whether update needs to be performed (Inherited from RowsetBase.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FindByKey( Object ) | Tries to find a row by specified keyset and returns it or null if not found. This method does not perform well on Rowsets instances as a rowset is unordered list which does linear search. In contrast, Tables are always ordered and perform binary search instead (Inherited from RowsetBase.)
Public method | FindByKey(Row) | Tries to find a row by specified keyset and returns it or null if not found (Inherited from RowsetBase.)
Public method | FindByKey(Row, Func Row, Boolean ) | Tries to find a row by specified keyset and extra WHERE clause and returns it or null if not found. This method does not perform well on Rowsets instances as a rowset is unordered list which does linear search. In contrast, Tables are always ordered and perform binary search instead (Inherited from RowsetBase.)
Public method | FindByKey(Func Row, Boolean , Object ) | Tries to find a row by specified keyset and extra WHERE clause and returns it or null if not found (Inherited from RowsetBase.)
Public method | GetChangeAt | Retrievs a change by index or null if index is out of bounds or changes are not logged (Inherited from RowsetBase.)
Public method | GetEnumerator | (Inherited from RowsetBase.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IndexOf | (Inherited from RowsetBase.)
Public method | Insert(Row) | Inserts the row. Returns insertion index (Inherited from RowsetBase.)
Public method | Insert(Int32, Row) | Inserts row at index (Inherited from RowsetBase.)
Public method | KeyRowFromValues | Creates key row out of field values for keys (Inherited from RowsetBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Purge | Deletes all rows from table without logging the deleted modifications even when LogModifications=true (Inherited from RowsetBase.)
Public method | PurgeChanges | Clears modifications accumulated by this instance (Inherited from RowsetBase.)
Public method | Remove | Performs row delete (Inherited from RowsetBase.)
Public method | RemoveAt | Deletes row (Inherited from RowsetBase.)
Protected method | SearchForRow | Provides rowsearching. Override to do binary search in sorted rowsets (Inherited from RowsetBase.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Update | Updates the row, Returns the row index or -1 (Inherited from RowsetBase.)
Public method | Upsert | Tries to find a row for update and if found, updates it and returns true, otherwise inserts the row (if schemas match) and returns false. Optionally pass updateWhere condition that may check whether update needs to be performed (Inherited from RowsetBase.)
Public method | Validate | Validates all rows in this rowset. Override to perform custom validations. The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from RowsetBase.)
Public method | WriteAsJSON | Writes rowset as JSON including schema information. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class (Inherited from RowsetBase.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from RowsetBase.)
Back to Top
See Also
Rowset Class
NFX.DataAccess.CRUD Namespace


Rowset.Compare Method

Rowset Compare Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Compare(
    Row rowA,
    Row rowB
)
public override int Compare(
    Row rowA,
    Row rowB
)
Public Overrides Function Compare (
    rowA As Row,
    rowB As Row
) As Integer
Public Overrides Function Compare (
    rowA As Row,
    rowB As Row
) As Integer
public:
virtual int Compare(
    Row^ rowA,
    Row^ rowB
) override
public:
virtual int Compare(
    Row^ rowA,
    Row^ rowB
) override
abstract Compare :
        rowA : Row *
        rowB : Row -> int
override Compare :
        rowA : Row *
        rowB : Row -> int
abstract Compare :
        rowA : Row *
        rowB : Row -> int
override Compare :
        rowA : Row *
        rowB : Row -> int

Parameters

rowA
Type: NFX.DataAccess.CRUD Row
rowB
Type: NFX.DataAccess.CRUD Row

Return Value

Type: Online Int32

Implements

Online IComparer T Compare(T, T)
See Also
Rowset Class
Rowset Members
NFX.DataAccess.CRUD Namespace


Rowset.DoInsert Method

Rowset DoInsert Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override int DoInsert(
    Row row
)
protected override int DoInsert(
    Row row
)
Protected Overrides Function DoInsert (
    row As Row
) As Integer
Protected Overrides Function DoInsert (
    row As Row
) As Integer
protected:
virtual int DoInsert(
    Row^ row
) override
protected:
virtual int DoInsert(
    Row^ row
) override
abstract DoInsert :
        row : Row -> int
override DoInsert :
        row : Row -> int
abstract DoInsert :
        row : Row -> int
override DoInsert :
        row : Row -> int

Parameters

row
Type: NFX.DataAccess.CRUD Row

Return Value

Type: Online Int32
See Also
Rowset Class
Rowset Members
NFX.DataAccess.CRUD Namespace


Rowset Properties

Rowset Properties NFX Class Library

The Rowset type exposes the following members.
Properties
 | Name | Description
Public property | AsReadonlyIList | Returns data as non-generic readonly IList (Inherited from RowsetBase.)
Public property | ChangeCount | Returns a count of accumulated modifications performed on the rowset, or zero when no modifications have been made or LogModifications = false (Inherited from RowsetBase.)
Public property | Changes | Returns accumulated modifications performed on the rowset, or empty enumerator if no modifications have been made or LogModifications = false (Inherited from RowsetBase.)
Public property | Context | Provides dynamic view of rowset's data context - attributes applicable to the whole rowset (Inherited from RowsetBase.)
Public property | ContextMap | Provides dynamic view as JSONDataMap of rowset's data context - attributes applicable to the whole rowset (Inherited from RowsetBase.)
Public property | Count | Returns row count in this rowset (Inherited from RowsetBase.)
Public property | InstanceGUID | Returns globaly-unique instance ID. This ID is useful as a key for storing rowsets in object stores and posting data back from web client to server. (Inherited from RowsetBase.)
Public property | IsReadOnly | (Inherited from RowsetBase.)
Public property | Item | This method performs update on set (Inherited from RowsetBase.)
Public property | LogChanges | Gets/Sets whether this rowset keeps track of all modifications done to it. This property must be set to true to be able to save changes into ICRUDDataStore (Inherited from RowsetBase.)
Public property | Schema | Returns a schema for rows that this rowset contains (Inherited from RowsetBase.)
Public property | SortDefinition | Sort definition is a comma-separated field name list where every field may optionally be prefixed with `+` for ascending or `-` for descending sort order specifier. Example: "FirstName,-DOB"
Back to Top
See Also
Rowset Class
NFX.DataAccess.CRUD Namespace


Rowset.SortDefinition Property

Rowset SortDefinition Property NFX Class Library

Sort definition is a comma-separated field name list where every field may optionally be prefixed with `+` for ascending or `-` for descending sort order specifier. Example: "FirstName,-DOB"

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SortDefinition { get; set; }
public string SortDefinition { get; set; }
Public Property SortDefinition As String
    Get
    Set
Public Property SortDefinition As String
    Get
    Set
public:
property String^ SortDefinition {
    String^ get ();
    void set (String^ value);
}
public:
property String^ SortDefinition {
    String^ get ();
    void set (String^ value);
}
member SortDefinition : string with get, set
member SortDefinition : string with get, set

Property Value

Type: Online String
See Also
Rowset Class
Rowset Members
NFX.DataAccess.CRUD Namespace


RowsetBase Class

RowsetBase Class NFX Class Library

Provides base for rowset implementation. Rowsets are mutable lists of rows where all rows must have the same schema, however a rowset may contain a mix of dynamic and typed rows as long as they have the same schema. Rowsets are not thread-safe
Inheritance Hierarchy
Online System Object
NFX.DataAccess.CRUD RowsetBase
NFX.DataAccess.CRUD Rowset
NFX.DataAccess.CRUD Table

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class RowsetBase : IList<Row>,
    ICollection<Row>, IEnumerable<Row>, IEnumerable,
    IComparer<Row>, IJSONWritable, IValidatable
[SerializableAttribute]
public abstract class RowsetBase : IList<Row>,
    ICollection<Row>, IEnumerable<Row>, IEnumerable,
    IComparer<Row>, IJSONWritable, IValidatable
<SerializableAttribute>
Public MustInherit Class RowsetBase
    Implements IList(Of Row), ICollection(Of Row),
    IEnumerable(Of Row), IEnumerable, IComparer(Of Row),
    IJSONWritable, IValidatable
<SerializableAttribute>
Public MustInherit Class RowsetBase
    Implements IList(Of Row), ICollection(Of Row),
    IEnumerable(Of Row), IEnumerable, IComparer(Of Row),
    IJSONWritable, IValidatable
[SerializableAttribute]
public ref class RowsetBase abstract : IList<Row^>,
    ICollection<Row^>, IEnumerable<Row^>, IEnumerable,
    IComparer<Row^>, IJSONWritable, IValidatable
[SerializableAttribute]
public ref class RowsetBase abstract : IList<Row^>,
    ICollection<Row^>, IEnumerable<Row^>, IEnumerable,
    IComparer<Row^>, IJSONWritable, IValidatable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type RowsetBase =
    class
        interface IList<Row>
        interface ICollection<Row>
        interface IEnumerable<Row>
        interface IEnumerable
        interface IComparer<Row>
        interface IJSONWritable
        interface IValidatable
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type RowsetBase =
    class
        interface IList<Row>
        interface ICollection<Row>
        interface IEnumerable<Row>
        interface IEnumerable
        interface IComparer<Row>
        interface IJSONWritable
        interface IValidatable
    end
See Also
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase Members

RowsetBase Members NFX Class Library

The RowsetBase type exposes the following members.
Constructors
 | Name | Description
Protected method | RowsetBase | Creates an empty rowset
Back to Top
Methods
 | Name | Description
Public method | Add | Inserts a row
Protected method | Check | Checks argument for being non-null and of the same schema with this rowset
Public method | Clear | Purges table
Public method | Compare | Compares two rows
Public method | Contains |
Public method | CopyTo |
Public method | Delete( Object ) | Tries to find a row with the same set of key fields in this table and if found, deletes it and returns its index, otherwise -1
Public method | Delete(Row, IDataStoreKey) | Tries to find a row with the same set of key fields in this table and if found, deletes it and returns its index, otherwise -1
Public method | DeleteAll | Deletes all rows from table. This method is similar to Purge() but does logging (when enabled)
Protected method | DoDelete | Tries to find a row with the same set of key fields in this table and if found, deletes it and returns its index, otherwise -1
Protected method | DoInsert | Tries to insert a row. If another row with the same set of key fields already in the table returns -1, otherwise returns insertion index
Protected method | DoUpdate | Tries to find a row with the same set of key fields in this table and if found, replaces it and returns its index, otherwise returns -1
Protected method | DoUpsert | Tries to find a row with the same set of key fields in this table and if found, replaces it and returns true, otherwise inserts the row (if schemas match) and returns false. Optionally pass updateWhere condition that may check whether update needs to be performed
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FindByKey( Object ) | Tries to find a row by specified keyset and returns it or null if not found. This method does not perform well on Rowsets instances as a rowset is unordered list which does linear search. In contrast, Tables are always ordered and perform binary search instead
Public method | FindByKey(Row) | Tries to find a row by specified keyset and returns it or null if not found
Public method | FindByKey(Row, Func Row, Boolean ) | Tries to find a row by specified keyset and extra WHERE clause and returns it or null if not found. This method does not perform well on Rowsets instances as a rowset is unordered list which does linear search. In contrast, Tables are always ordered and perform binary search instead
Public method | FindByKey(Func Row, Boolean , Object ) | Tries to find a row by specified keyset and extra WHERE clause and returns it or null if not found
 | FromJSON(String, Boolean, Boolean) | Reads either Table or Rowset from JSON created by WriteAsJSON. Metadata must be present
 | FromJSON(JSONDataMap, Boolean, Boolean) | Reads either Table or Rowset from JSON created by WriteAsJSON. Metadata must be present
 | FromJSON(JSONDataMap, Boolean , Boolean, Boolean, SetFieldFunc) | Reads either Table or Rowset from JSON created by WriteAsJSON. Metadata must be present. allMatched==false when some data did not match schema (i.e. too little fields or extra fields supplied)
 | FromJSON T (String, RowsetBase , SetFieldFunc) | Reads either Table or Rowset from JSON created by WriteAsJSON.
 | FromJSON T (JSONDataMap, RowsetBase , SetFieldFunc) | Reads either Table or Rowset from JSON created by WriteAsJSON.
Public method | GetChangeAt | Retrievs a change by index or null if index is out of bounds or changes are not logged
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IndexOf |
Public method | Insert(Row) | Inserts the row. Returns insertion index
Public method | Insert(Int32, Row) | Inserts row at index
Public method | KeyRowFromValues | Creates key row out of field values for keys
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Purge | Deletes all rows from table without logging the deleted modifications even when LogModifications=true
Public method | PurgeChanges | Clears modifications accumulated by this instance
Public method | Remove | Performs row delete
Public method | RemoveAt | Deletes row
Protected method | SearchForRow | Provides rowsearching. Override to do binary search in sorted rowsets
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Update | Updates the row, Returns the row index or -1
Public method | Upsert | Tries to find a row for update and if found, updates it and returns true, otherwise inserts the row (if schemas match) and returns false. Optionally pass updateWhere condition that may check whether update needs to be performed
Public method | Validate | Validates all rows in this rowset. Override to perform custom validations. The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated
Public method | WriteAsJSON | Writes rowset as JSON including schema information. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnumerableOf TRow | Casts enumerable of rows (such as rowset) to the specified row type, returning empty enumerable if the source is null (Defined by DataUtils.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable Row | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct Row, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax Row, TComparand (Func Row, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax Row, TComparand (Func Row, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin Row, TComparand (Func Row, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin Row, TComparand (Func Row, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault Row | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach Row (Action Row ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach Row (Action Row, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast Row | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast Row (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Changes |
Protected field | m_List |
Protected field | m_Schema |
Back to Top
Properties
 | Name | Description
Public property | AsReadonlyIList | Returns data as non-generic readonly IList
Public property | ChangeCount | Returns a count of accumulated modifications performed on the rowset, or zero when no modifications have been made or LogModifications = false
Public property | Changes | Returns accumulated modifications performed on the rowset, or empty enumerator if no modifications have been made or LogModifications = false
Public property | Context | Provides dynamic view of rowset's data context - attributes applicable to the whole rowset
Public property | ContextMap | Provides dynamic view as JSONDataMap of rowset's data context - attributes applicable to the whole rowset
Public property | Count | Returns row count in this rowset
Public property | InstanceGUID | Returns globaly-unique instance ID. This ID is useful as a key for storing rowsets in object stores and posting data back from web client to server.
Public property | IsReadOnly |
Public property | Item | This method performs update on set
Public property | LogChanges | Gets/Sets whether this rowset keeps track of all modifications done to it. This property must be set to true to be able to save changes into ICRUDDataStore
Public property | Schema | Returns a schema for rows that this rowset contains
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
RowsetBase Class
NFX.DataAccess.CRUD Namespace


RowsetBase Constructor

RowsetBase Constructor NFX Class Library

Creates an empty rowset

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected RowsetBase(
    Schema schema
)
protected RowsetBase(
    Schema schema
)
Protected Sub New (
    schema As Schema
)
Protected Sub New (
    schema As Schema
)
protected:
RowsetBase(
    Schema^ schema
)
protected:
RowsetBase(
    Schema^ schema
)
new :
        schema : Schema -> RowsetBase
new :
        schema : Schema -> RowsetBase

Parameters

schema
Type: NFX.DataAccess.CRUD Schema
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase Fields

RowsetBase Fields NFX Class Library

The RowsetBase type exposes the following members.
Fields
 | Name | Description
Protected field | m_Changes |
Protected field | m_List |
Protected field | m_Schema |
Back to Top
See Also
RowsetBase Class
NFX.DataAccess.CRUD Namespace


RowsetBase.m_Changes Field

RowsetBase m_Changes Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal List<RowChange> m_Changes
internal List<RowChange> m_Changes
Friend m_Changes As List(Of RowChange)
Friend m_Changes As List(Of RowChange)
internal:
List<RowChange>^ m_Changes
internal:
List<RowChange>^ m_Changes
val mutable internal m_Changes: List<RowChange>
val mutable internal m_Changes: List<RowChange>

Field Value

Type: Online List RowChange
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.m_List Field

RowsetBase m_List Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal List<Row> m_List
internal List<Row> m_List
Friend m_List As List(Of Row)
Friend m_List As List(Of Row)
internal:
List<Row^>^ m_List
internal:
List<Row^>^ m_List
val mutable internal m_List: List<Row>
val mutable internal m_List: List<Row>

Field Value

Type: Online List Row
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.m_Schema Field

RowsetBase m_Schema Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Schema m_Schema
protected Schema m_Schema
Protected m_Schema As Schema
Protected m_Schema As Schema
protected:
Schema^ m_Schema
protected:
Schema^ m_Schema
val mutable m_Schema: Schema
val mutable m_Schema: Schema

Field Value

Type: Schema
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase Methods

RowsetBase Methods NFX Class Library

The RowsetBase type exposes the following members.
Methods
 | Name | Description
Public method | Add | Inserts a row
Protected method | Check | Checks argument for being non-null and of the same schema with this rowset
Public method | Clear | Purges table
Public method | Compare | Compares two rows
Public method | Contains |
Public method | CopyTo |
Public method | Delete( Object ) | Tries to find a row with the same set of key fields in this table and if found, deletes it and returns its index, otherwise -1
Public method | Delete(Row, IDataStoreKey) | Tries to find a row with the same set of key fields in this table and if found, deletes it and returns its index, otherwise -1
Public method | DeleteAll | Deletes all rows from table. This method is similar to Purge() but does logging (when enabled)
Protected method | DoDelete | Tries to find a row with the same set of key fields in this table and if found, deletes it and returns its index, otherwise -1
Protected method | DoInsert | Tries to insert a row. If another row with the same set of key fields already in the table returns -1, otherwise returns insertion index
Protected method | DoUpdate | Tries to find a row with the same set of key fields in this table and if found, replaces it and returns its index, otherwise returns -1
Protected method | DoUpsert | Tries to find a row with the same set of key fields in this table and if found, replaces it and returns true, otherwise inserts the row (if schemas match) and returns false. Optionally pass updateWhere condition that may check whether update needs to be performed
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FindByKey( Object ) | Tries to find a row by specified keyset and returns it or null if not found. This method does not perform well on Rowsets instances as a rowset is unordered list which does linear search. In contrast, Tables are always ordered and perform binary search instead
Public method | FindByKey(Row) | Tries to find a row by specified keyset and returns it or null if not found
Public method | FindByKey(Row, Func Row, Boolean ) | Tries to find a row by specified keyset and extra WHERE clause and returns it or null if not found. This method does not perform well on Rowsets instances as a rowset is unordered list which does linear search. In contrast, Tables are always ordered and perform binary search instead
Public method | FindByKey(Func Row, Boolean , Object ) | Tries to find a row by specified keyset and extra WHERE clause and returns it or null if not found
 | FromJSON(String, Boolean, Boolean) | Reads either Table or Rowset from JSON created by WriteAsJSON. Metadata must be present
 | FromJSON(JSONDataMap, Boolean, Boolean) | Reads either Table or Rowset from JSON created by WriteAsJSON. Metadata must be present
 | FromJSON(JSONDataMap, Boolean , Boolean, Boolean, SetFieldFunc) | Reads either Table or Rowset from JSON created by WriteAsJSON. Metadata must be present. allMatched==false when some data did not match schema (i.e. too little fields or extra fields supplied)
 | FromJSON T (String, RowsetBase , SetFieldFunc) | Reads either Table or Rowset from JSON created by WriteAsJSON.
 | FromJSON T (JSONDataMap, RowsetBase , SetFieldFunc) | Reads either Table or Rowset from JSON created by WriteAsJSON.
Public method | GetChangeAt | Retrievs a change by index or null if index is out of bounds or changes are not logged
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IndexOf |
Public method | Insert(Row) | Inserts the row. Returns insertion index
Public method | Insert(Int32, Row) | Inserts row at index
Public method | KeyRowFromValues | Creates key row out of field values for keys
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Purge | Deletes all rows from table without logging the deleted modifications even when LogModifications=true
Public method | PurgeChanges | Clears modifications accumulated by this instance
Public method | Remove | Performs row delete
Public method | RemoveAt | Deletes row
Protected method | SearchForRow | Provides rowsearching. Override to do binary search in sorted rowsets
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Update | Updates the row, Returns the row index or -1
Public method | Upsert | Tries to find a row for update and if found, updates it and returns true, otherwise inserts the row (if schemas match) and returns false. Optionally pass updateWhere condition that may check whether update needs to be performed
Public method | Validate | Validates all rows in this rowset. Override to perform custom validations. The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated
Public method | WriteAsJSON | Writes rowset as JSON including schema information. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnumerableOf TRow | Casts enumerable of rows (such as rowset) to the specified row type, returning empty enumerable if the source is null (Defined by DataUtils.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable Row | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct Row, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax Row, TComparand (Func Row, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax Row, TComparand (Func Row, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin Row, TComparand (Func Row, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin Row, TComparand (Func Row, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault Row | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach Row (Action Row ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach Row (Action Row, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast Row | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast Row (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
RowsetBase Class
NFX.DataAccess.CRUD Namespace


RowsetBase.IEnumerable.GetEnumerator Method

RowsetBase IEnumerable GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.Add Method

RowsetBase Add Method NFX Class Library

Inserts a row

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    Row row
)
public void Add(
    Row row
)
Public Sub Add (
    row As Row
)
Public Sub Add (
    row As Row
)
public:
virtual void Add(
    Row^ row
) sealed
public:
virtual void Add(
    Row^ row
) sealed
abstract Add :
        row : Row -> unit
override Add :
        row : Row -> unit
abstract Add :
        row : Row -> unit
override Add :
        row : Row -> unit

Parameters

row
Type: NFX.DataAccess.CRUD Row

Implements

Online ICollection T Add(T)
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.Check Method

RowsetBase Check Method NFX Class Library

Checks argument for being non-null and of the same schema with this rowset

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void Check(
    Row row
)
protected void Check(
    Row row
)
Protected Sub Check (
    row As Row
)
Protected Sub Check (
    row As Row
)
protected:
void Check(
    Row^ row
)
protected:
void Check(
    Row^ row
)
member Check :
        row : Row -> unit
member Check :
        row : Row -> unit

Parameters

row
Type: NFX.DataAccess.CRUD Row
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.Clear Method

RowsetBase Clear Method NFX Class Library

Purges table

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
virtual void Clear() sealed
public:
virtual void Clear() sealed
abstract Clear : unit -> unit
override Clear : unit -> unit
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

Online ICollection T Clear
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.Compare Method

RowsetBase Compare Method NFX Class Library

Compares two rows

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int Compare(
    Row rowA,
    Row rowB
)
public abstract int Compare(
    Row rowA,
    Row rowB
)
Public MustOverride Function Compare (
    rowA As Row,
    rowB As Row
) As Integer
Public MustOverride Function Compare (
    rowA As Row,
    rowB As Row
) As Integer
public:
virtual int Compare(
    Row^ rowA,
    Row^ rowB
) abstract
public:
virtual int Compare(
    Row^ rowA,
    Row^ rowB
) abstract
abstract Compare :
        rowA : Row *
        rowB : Row -> int
abstract Compare :
        rowA : Row *
        rowB : Row -> int

Parameters

rowA
Type: NFX.DataAccess.CRUD Row
rowB
Type: NFX.DataAccess.CRUD Row

Return Value

Type: Online Int32

Implements

Online IComparer T Compare(T, T)
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.Contains Method

RowsetBase Contains Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Contains(
    Row row
)
public bool Contains(
    Row row
)
Public Function Contains (
    row As Row
) As Boolean
Public Function Contains (
    row As Row
) As Boolean
public:
virtual bool Contains(
    Row^ row
) sealed
public:
virtual bool Contains(
    Row^ row
) sealed
abstract Contains :
        row : Row -> bool
override Contains :
        row : Row -> bool
abstract Contains :
        row : Row -> bool
override Contains :
        row : Row -> bool

Parameters

row
Type: NFX.DataAccess.CRUD Row

Return Value

Type: Online Boolean

Implements

Online ICollection T Contains(T)
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.CopyTo Method

RowsetBase CopyTo Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CopyTo(
    Row[] array,
    int arrayIndex
)
public void CopyTo(
    Row[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As Row(),
    arrayIndex As Integer
)
Public Sub CopyTo (
    array As Row(),
    arrayIndex As Integer
)
public:
virtual void CopyTo(
    array<Row^>^ array,
    int arrayIndex
) sealed
public:
virtual void CopyTo(
    array<Row^>^ array,
    int arrayIndex
) sealed
abstract CopyTo :
        array : Row[] *
        arrayIndex : int -> unit
override CopyTo :
        array : Row[] *
        arrayIndex : int -> unit
abstract CopyTo :
        array : Row[] *
        arrayIndex : int -> unit
override CopyTo :
        array : Row[] *
        arrayIndex : int -> unit

Parameters

array
Type: NFX.DataAccess.CRUD Row
arrayIndex
Type: Online System Int32

Implements

Online ICollection T CopyTo( T , Int32)
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.Delete Method

RowsetBase Delete Method NFX Class Library

Overload List
 | Name | Description
Public method | Delete( Object ) | Tries to find a row with the same set of key fields in this table and if found, deletes it and returns its index, otherwise -1
Public method | Delete(Row, IDataStoreKey) | Tries to find a row with the same set of key fields in this table and if found, deletes it and returns its index, otherwise -1
Back to Top
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.Delete Method (Object[])

RowsetBase Delete Method ( Object ) NFX Class Library

Tries to find a row with the same set of key fields in this table and if found, deletes it and returns its index, otherwise -1

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Delete(
    params Object[] keys
)
public int Delete(
    params Object[] keys
)
Public Function Delete (
    ParamArray keys As Object()
) As Integer
Public Function Delete (
    ParamArray keys As Object()
) As Integer
public:
int Delete(
    ... array<Object^>^ keys
)
public:
int Delete(
    ... array<Object^>^ keys
)
member Delete :
        keys : Object[] -> int
member Delete :
        keys : Object[] -> int

Parameters

keys
Type: Online System Object

Return Value

Type: Online Int32
See Also
RowsetBase Class
RowsetBase Members
Delete Overload
NFX.DataAccess.CRUD Namespace


RowsetBase.Delete Method (Row, IDataStoreKey)

RowsetBase Delete Method (Row, IDataStoreKey) NFX Class Library

[This is preliminary documentation and is subject to change.]

Tries to find a row with the same set of key fields in this table and if found, deletes it and returns its index, otherwise -1

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Delete(
    Row row,
    IDataStoreKey key = null
)
public int Delete(
    Row row,
    IDataStoreKey key = null
)
Public Function Delete (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Integer
Public Function Delete (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Integer
public:
int Delete(
    Row^ row,
    IDataStoreKey^ key = nullptr
)
public:
int Delete(
    Row^ row,
    IDataStoreKey^ key = nullptr
)
member Delete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int
member Delete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey

Return Value

Type: Online Int32
See Also
RowsetBase Class
RowsetBase Members
Delete Overload
NFX.DataAccess.CRUD Namespace


RowsetBase.DeleteAll Method

RowsetBase DeleteAll Method NFX Class Library

Deletes all rows from table. This method is similar to Purge() but does logging (when enabled)

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DeleteAll()
public void DeleteAll()
Public Sub DeleteAll
Public Sub DeleteAll
public:
void DeleteAll()
public:
void DeleteAll()
member DeleteAll : unit -> unit
member DeleteAll : unit -> unit
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.DoDelete Method

RowsetBase DoDelete Method NFX Class Library

Tries to find a row with the same set of key fields in this table and if found, deletes it and returns its index, otherwise -1

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual int DoDelete(
    Row row,
    IDataStoreKey key = null
)
protected virtual int DoDelete(
    Row row,
    IDataStoreKey key = null
)
Protected Overridable Function DoDelete (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Integer
Protected Overridable Function DoDelete (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Integer
protected:
virtual int DoDelete(
    Row^ row,
    IDataStoreKey^ key = nullptr
)
protected:
virtual int DoDelete(
    Row^ row,
    IDataStoreKey^ key = nullptr
)
abstract DoDelete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int
override DoDelete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int
abstract DoDelete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int
override DoDelete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey

Return Value

Type: Online Int32
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.DoInsert Method

RowsetBase DoInsert Method NFX Class Library

Tries to insert a row. If another row with the same set of key fields already in the table returns -1, otherwise returns insertion index

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual int DoInsert(
    Row row
)
protected virtual int DoInsert(
    Row row
)
Protected Overridable Function DoInsert (
    row As Row
) As Integer
Protected Overridable Function DoInsert (
    row As Row
) As Integer
protected:
virtual int DoInsert(
    Row^ row
)
protected:
virtual int DoInsert(
    Row^ row
)
abstract DoInsert :
        row : Row -> int
override DoInsert :
        row : Row -> int
abstract DoInsert :
        row : Row -> int
override DoInsert :
        row : Row -> int

Parameters

row
Type: NFX.DataAccess.CRUD Row

Return Value

Type: Online Int32
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.DoUpdate Method

RowsetBase DoUpdate Method NFX Class Library

Tries to find a row with the same set of key fields in this table and if found, replaces it and returns its index, otherwise returns -1

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual int DoUpdate(
    Row row,
    IDataStoreKey key = null
)
protected virtual int DoUpdate(
    Row row,
    IDataStoreKey key = null
)
Protected Overridable Function DoUpdate (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Integer
Protected Overridable Function DoUpdate (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Integer
protected:
virtual int DoUpdate(
    Row^ row,
    IDataStoreKey^ key = nullptr
)
protected:
virtual int DoUpdate(
    Row^ row,
    IDataStoreKey^ key = nullptr
)
abstract DoUpdate :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int
override DoUpdate :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int
abstract DoUpdate :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int
override DoUpdate :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey

Return Value

Type: Online Int32
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.DoUpsert Method

RowsetBase DoUpsert Method NFX Class Library

Tries to find a row with the same set of key fields in this table and if found, replaces it and returns true, otherwise inserts the row (if schemas match) and returns false. Optionally pass updateWhere condition that may check whether update needs to be performed

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool DoUpsert(
    Row row,
    Func<Row, bool> updateWhere
)
protected virtual bool DoUpsert(
    Row row,
    Func<Row, bool> updateWhere
)
Protected Overridable Function DoUpsert (
    row As Row,
    updateWhere As Func(Of Row, Boolean)
) As Boolean
Protected Overridable Function DoUpsert (
    row As Row,
    updateWhere As Func(Of Row, Boolean)
) As Boolean
protected:
virtual bool DoUpsert(
    Row^ row,
    Func<Row^, bool>^ updateWhere
)
protected:
virtual bool DoUpsert(
    Row^ row,
    Func<Row^, bool>^ updateWhere
)
abstract DoUpsert :
        row : Row *
        updateWhere : Func<Row, bool> -> bool
override DoUpsert :
        row : Row *
        updateWhere : Func<Row, bool> -> bool
abstract DoUpsert :
        row : Row *
        updateWhere : Func<Row, bool> -> bool
override DoUpsert :
        row : Row *
        updateWhere : Func<Row, bool> -> bool

Parameters

row
Type: NFX.DataAccess.CRUD Row
updateWhere
Type: Online System Func Row, Online Boolean

Return Value

Type: Online Boolean
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.FindByKey Method

RowsetBase FindByKey Method NFX Class Library

Overload List
 | Name | Description
Public method | FindByKey( Object ) | Tries to find a row by specified keyset and returns it or null if not found. This method does not perform well on Rowsets instances as a rowset is unordered list which does linear search. In contrast, Tables are always ordered and perform binary search instead
Public method | FindByKey(Row) | Tries to find a row by specified keyset and returns it or null if not found
Public method | FindByKey(Row, Func Row, Boolean ) | Tries to find a row by specified keyset and extra WHERE clause and returns it or null if not found. This method does not perform well on Rowsets instances as a rowset is unordered list which does linear search. In contrast, Tables are always ordered and perform binary search instead
Public method | FindByKey(Func Row, Boolean , Object ) | Tries to find a row by specified keyset and extra WHERE clause and returns it or null if not found
Back to Top
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.FindByKey Method (Object[])

RowsetBase FindByKey Method ( Object ) NFX Class Library

Tries to find a row by specified keyset and returns it or null if not found. This method does not perform well on Rowsets instances as a rowset is unordered list which does linear search. In contrast, Tables are always ordered and perform binary search instead

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Row FindByKey(
    params Object[] keys
)
public Row FindByKey(
    params Object[] keys
)
Public Function FindByKey (
    ParamArray keys As Object()
) As Row
Public Function FindByKey (
    ParamArray keys As Object()
) As Row
public:
Row^ FindByKey(
    ... array<Object^>^ keys
)
public:
Row^ FindByKey(
    ... array<Object^>^ keys
)
member FindByKey :
        keys : Object[] -> Row
member FindByKey :
        keys : Object[] -> Row

Parameters

keys
Type: Online System Object

Return Value

Type: Row
See Also
RowsetBase Class
RowsetBase Members
FindByKey Overload
NFX.DataAccess.CRUD Namespace


RowsetBase.FindByKey Method (Row)

RowsetBase FindByKey Method (Row) NFX Class Library

Tries to find a row by specified keyset and returns it or null if not found

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Row FindByKey(
    Row keyRow
)
public Row FindByKey(
    Row keyRow
)
Public Function FindByKey (
    keyRow As Row
) As Row
Public Function FindByKey (
    keyRow As Row
) As Row
public:
Row^ FindByKey(
    Row^ keyRow
)
public:
Row^ FindByKey(
    Row^ keyRow
)
member FindByKey :
        keyRow : Row -> Row
member FindByKey :
        keyRow : Row -> Row

Parameters

keyRow
Type: NFX.DataAccess.CRUD Row

Return Value

Type: Row
See Also
RowsetBase Class
RowsetBase Members
FindByKey Overload
NFX.DataAccess.CRUD Namespace


RowsetBase.FindByKey Method (Row, Func(Row, Boolean))

RowsetBase FindByKey Method (Row, Func Row, Boolean ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Tries to find a row by specified keyset and extra WHERE clause and returns it or null if not found. This method does not perform well on Rowsets instances as a rowset is unordered list which does linear search. In contrast, Tables are always ordered and perform binary search instead

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Row FindByKey(
    Row row,
    Func<Row, bool> extraWhere
)
public Row FindByKey(
    Row row,
    Func<Row, bool> extraWhere
)
Public Function FindByKey (
    row As Row,
    extraWhere As Func(Of Row, Boolean)
) As Row
Public Function FindByKey (
    row As Row,
    extraWhere As Func(Of Row, Boolean)
) As Row
public:
Row^ FindByKey(
    Row^ row,
    Func<Row^, bool>^ extraWhere
)
public:
Row^ FindByKey(
    Row^ row,
    Func<Row^, bool>^ extraWhere
)
member FindByKey :
        row : Row *
        extraWhere : Func<Row, bool> -> Row
member FindByKey :
        row : Row *
        extraWhere : Func<Row, bool> -> Row

Parameters

row
Type: NFX.DataAccess.CRUD Row
extraWhere
Type: Online System Func Row, Online Boolean

Return Value

Type: Row
See Also
RowsetBase Class
RowsetBase Members
FindByKey Overload
NFX.DataAccess.CRUD Namespace


RowsetBase.FindByKey Method (Func(Row, Boolean), Object[])

RowsetBase FindByKey Method (Func Row, Boolean , Object ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Tries to find a row by specified keyset and extra WHERE clause and returns it or null if not found

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Row FindByKey(
    Func<Row, bool> extraWhere,
    params Object[] keys
)
public Row FindByKey(
    Func<Row, bool> extraWhere,
    params Object[] keys
)
Public Function FindByKey (
    extraWhere As Func(Of Row, Boolean),
    ParamArray keys As Object()
) As Row
Public Function FindByKey (
    extraWhere As Func(Of Row, Boolean),
    ParamArray keys As Object()
) As Row
public:
Row^ FindByKey(
    Func<Row^, bool>^ extraWhere,
    ... array<Object^>^ keys
)
public:
Row^ FindByKey(
    Func<Row^, bool>^ extraWhere,
    ... array<Object^>^ keys
)
member FindByKey :
        extraWhere : Func<Row, bool> *
        keys : Object[] -> Row
member FindByKey :
        extraWhere : Func<Row, bool> *
        keys : Object[] -> Row

Parameters

extraWhere
Type: Online System Func Row, Online Boolean
keys
Type: Online System Object

Return Value

Type: Row
See Also
RowsetBase Class
RowsetBase Members
FindByKey Overload
NFX.DataAccess.CRUD Namespace


RowsetBase.FromJSON Method

RowsetBase FromJSON Method NFX Class Library

Overload List
Name | Description
FromJSON T (String, RowsetBase , SetFieldFunc) | Reads either Table or Rowset from JSON created by WriteAsJSON.
FromJSON(String, Boolean, Boolean) | Reads either Table or Rowset from JSON created by WriteAsJSON. Metadata must be present
FromJSON T (JSONDataMap, RowsetBase , SetFieldFunc) | Reads either Table or Rowset from JSON created by WriteAsJSON.
FromJSON(JSONDataMap, Boolean, Boolean) | Reads either Table or Rowset from JSON created by WriteAsJSON. Metadata must be present
FromJSON(JSONDataMap, Boolean , Boolean, Boolean, SetFieldFunc) | Reads either Table or Rowset from JSON created by WriteAsJSON. Metadata must be present. allMatched==false when some data did not match schema (i.e. too little fields or extra fields supplied)
Back to Top
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.FromJSON(T) Method (String, RowsetBase, SetFieldFunc)

RowsetBase FromJSON T Method (String, RowsetBase , SetFieldFunc) NFX Class Library

[This is preliminary documentation and is subject to change.]

Reads either Table or Rowset from JSON created by WriteAsJSON.

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int FromJSON<T>(
    string json,
    ref RowsetBase result,
    SetFieldFunc setFieldFunc = null
)
where T : new(), TypedRow
public static int FromJSON<T>(
    string json,
    ref RowsetBase result,
    SetFieldFunc setFieldFunc = null
)
where T : new(), TypedRow
Public Shared Function FromJSON(Of T As {New, TypedRow}) (
    json As String,
    ByRef result As RowsetBase,
    Optional setFieldFunc As SetFieldFunc = Nothing
) As Integer
Public Shared Function FromJSON(Of T As {New, TypedRow}) (
    json As String,
    ByRef result As RowsetBase,
    Optional setFieldFunc As SetFieldFunc = Nothing
) As Integer
public:
generic<typename T>
where T : gcnew(), TypedRow
static int FromJSON(
    String^ json,
    RowsetBase^% result,
    SetFieldFunc^ setFieldFunc = nullptr
)
public:
generic<typename T>
where T : gcnew(), TypedRow
static int FromJSON(
    String^ json,
    RowsetBase^% result,
    SetFieldFunc^ setFieldFunc = nullptr
)
static member FromJSON :
        json : string *
        result : RowsetBase byref *
        ?setFieldFunc : SetFieldFunc
(* Defaults:
        let _setFieldFunc = defaultArg setFieldFunc null
*)
-> int  when 'T : new() and TypedRow
static member FromJSON :
        json : string *
        result : RowsetBase byref *
        ?setFieldFunc : SetFieldFunc
(* Defaults:
        let _setFieldFunc = defaultArg setFieldFunc null
*)
-> int  when 'T : new() and TypedRow

Parameters

json
Type: Online System String
result
Type: NFX.DataAccess.CRUD RowsetBase
setFieldFunc (Optional)
Type: NFX.DataAccess.CRUD SetFieldFunc
Type Parameters
T

Return Value

Type: Online Int32
Total number of rows found in JSON. If this number is less than result.Count, then not all rows matched the schema of the resulting rowset.
Remarks
The schema of "result" must match the schema of the typed row T. It's the responsibility of the caller to clear the "result" prior to calling this function - the function appends rows to existing rowset.
See Also
RowsetBase Class
RowsetBase Members
FromJSON Overload
NFX.DataAccess.CRUD Namespace


RowsetBase.FromJSON Method (String, Boolean, Boolean)

RowsetBase FromJSON Method (String, Boolean, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Reads either Table or Rowset from JSON created by WriteAsJSON. Metadata must be present

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static RowsetBase FromJSON(
    string json,
    bool schemaOnly = false,
    bool readOnlySchema = false
)
public static RowsetBase FromJSON(
    string json,
    bool schemaOnly = false,
    bool readOnlySchema = false
)
Public Shared Function FromJSON (
    json As String,
    Optional schemaOnly As Boolean = false,
    Optional readOnlySchema As Boolean = false
) As RowsetBase
Public Shared Function FromJSON (
    json As String,
    Optional schemaOnly As Boolean = false,
    Optional readOnlySchema As Boolean = false
) As RowsetBase
public:
static RowsetBase^ FromJSON(
    String^ json,
    bool schemaOnly = false,
    bool readOnlySchema = false
)
public:
static RowsetBase^ FromJSON(
    String^ json,
    bool schemaOnly = false,
    bool readOnlySchema = false
)
static member FromJSON :
        json : string *
        ?schemaOnly : bool *
        ?readOnlySchema : bool
(* Defaults:
        let _schemaOnly = defaultArg schemaOnly false
        let _readOnlySchema = defaultArg readOnlySchema false
*)
-> RowsetBase
static member FromJSON :
        json : string *
        ?schemaOnly : bool *
        ?readOnlySchema : bool
(* Defaults:
        let _schemaOnly = defaultArg schemaOnly false
        let _readOnlySchema = defaultArg readOnlySchema false
*)
-> RowsetBase

Parameters

json
Type: Online System String
schemaOnly (Optional)
Type: Online System Boolean
readOnlySchema (Optional)
Type: Online System Boolean

Return Value

Type: RowsetBase
See Also
RowsetBase Class
RowsetBase Members
FromJSON Overload
NFX.DataAccess.CRUD Namespace


RowsetBase.FromJSON(T) Method (JSONDataMap, RowsetBase, SetFieldFunc)

RowsetBase FromJSON T Method (JSONDataMap, RowsetBase , SetFieldFunc) NFX Class Library

[This is preliminary documentation and is subject to change.]

Reads either Table or Rowset from JSON created by WriteAsJSON.

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int FromJSON<T>(
    JSONDataMap jsonMap,
    ref RowsetBase result,
    SetFieldFunc setFieldFunc = null
)
where T : new(), TypedRow
public static int FromJSON<T>(
    JSONDataMap jsonMap,
    ref RowsetBase result,
    SetFieldFunc setFieldFunc = null
)
where T : new(), TypedRow
Public Shared Function FromJSON(Of T As {New, TypedRow}) (
    jsonMap As JSONDataMap,
    ByRef result As RowsetBase,
    Optional setFieldFunc As SetFieldFunc = Nothing
) As Integer
Public Shared Function FromJSON(Of T As {New, TypedRow}) (
    jsonMap As JSONDataMap,
    ByRef result As RowsetBase,
    Optional setFieldFunc As SetFieldFunc = Nothing
) As Integer
public:
generic<typename T>
where T : gcnew(), TypedRow
static int FromJSON(
    JSONDataMap^ jsonMap,
    RowsetBase^% result,
    SetFieldFunc^ setFieldFunc = nullptr
)
public:
generic<typename T>
where T : gcnew(), TypedRow
static int FromJSON(
    JSONDataMap^ jsonMap,
    RowsetBase^% result,
    SetFieldFunc^ setFieldFunc = nullptr
)
static member FromJSON :
        jsonMap : JSONDataMap *
        result : RowsetBase byref *
        ?setFieldFunc : SetFieldFunc
(* Defaults:
        let _setFieldFunc = defaultArg setFieldFunc null
*)
-> int  when 'T : new() and TypedRow
static member FromJSON :
        jsonMap : JSONDataMap *
        result : RowsetBase byref *
        ?setFieldFunc : SetFieldFunc
(* Defaults:
        let _setFieldFunc = defaultArg setFieldFunc null
*)
-> int  when 'T : new() and TypedRow

Parameters

jsonMap
Type: NFX.Serialization.JSON JSONDataMap
result
Type: NFX.DataAccess.CRUD RowsetBase
setFieldFunc (Optional)
Type: NFX.DataAccess.CRUD SetFieldFunc
Type Parameters
T

Return Value

Type: Online Int32
Total number of rows found in JSON. If this number is less than result.Count, then not all rows matched the schema of the resulting rowset.
Remarks
The schema of "result" must match the schema of the typed row T. It's the responsibility of the caller to clear the "result" prior to calling this function - the function appends rows to existing rowset.
See Also
RowsetBase Class
RowsetBase Members
FromJSON Overload
NFX.DataAccess.CRUD Namespace


RowsetBase.FromJSON Method (JSONDataMap, Boolean, Boolean)

RowsetBase FromJSON Method (JSONDataMap, Boolean, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Reads either Table or Rowset from JSON created by WriteAsJSON. Metadata must be present

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static RowsetBase FromJSON(
    JSONDataMap jsonMap,
    bool schemaOnly = false,
    bool readOnlySchema = false
)
public static RowsetBase FromJSON(
    JSONDataMap jsonMap,
    bool schemaOnly = false,
    bool readOnlySchema = false
)
Public Shared Function FromJSON (
    jsonMap As JSONDataMap,
    Optional schemaOnly As Boolean = false,
    Optional readOnlySchema As Boolean = false
) As RowsetBase
Public Shared Function FromJSON (
    jsonMap As JSONDataMap,
    Optional schemaOnly As Boolean = false,
    Optional readOnlySchema As Boolean = false
) As RowsetBase
public:
static RowsetBase^ FromJSON(
    JSONDataMap^ jsonMap,
    bool schemaOnly = false,
    bool readOnlySchema = false
)
public:
static RowsetBase^ FromJSON(
    JSONDataMap^ jsonMap,
    bool schemaOnly = false,
    bool readOnlySchema = false
)
static member FromJSON :
        jsonMap : JSONDataMap *
        ?schemaOnly : bool *
        ?readOnlySchema : bool
(* Defaults:
        let _schemaOnly = defaultArg schemaOnly false
        let _readOnlySchema = defaultArg readOnlySchema false
*)
-> RowsetBase
static member FromJSON :
        jsonMap : JSONDataMap *
        ?schemaOnly : bool *
        ?readOnlySchema : bool
(* Defaults:
        let _schemaOnly = defaultArg schemaOnly false
        let _readOnlySchema = defaultArg readOnlySchema false
*)
-> RowsetBase

Parameters

jsonMap
Type: NFX.Serialization.JSON JSONDataMap
schemaOnly (Optional)
Type: Online System Boolean
readOnlySchema (Optional)
Type: Online System Boolean

Return Value

Type: RowsetBase
See Also
RowsetBase Class
RowsetBase Members
FromJSON Overload
NFX.DataAccess.CRUD Namespace


RowsetBase.FromJSON Method (JSONDataMap, Boolean, Boolean, Boolean, SetFieldFunc)

RowsetBase FromJSON Method (JSONDataMap, Boolean , Boolean, Boolean, SetFieldFunc) NFX Class Library

[This is preliminary documentation and is subject to change.]

Reads either Table or Rowset from JSON created by WriteAsJSON. Metadata must be present. allMatched==false when some data did not match schema (i.e. too little fields or extra fields supplied)

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static RowsetBase FromJSON(
    JSONDataMap jsonMap,
    out bool allMatched,
    bool schemaOnly = false,
    bool readOnlySchema = false,
    SetFieldFunc setFieldFunc = null
)
public static RowsetBase FromJSON(
    JSONDataMap jsonMap,
    out bool allMatched,
    bool schemaOnly = false,
    bool readOnlySchema = false,
    SetFieldFunc setFieldFunc = null
)
Public Shared Function FromJSON (
    jsonMap As JSONDataMap,
    <OutAttribute> ByRef allMatched As Boolean,
    Optional schemaOnly As Boolean = false,
    Optional readOnlySchema As Boolean = false,
    Optional setFieldFunc As SetFieldFunc = Nothing
) As RowsetBase
Public Shared Function FromJSON (
    jsonMap As JSONDataMap,
    <OutAttribute> ByRef allMatched As Boolean,
    Optional schemaOnly As Boolean = false,
    Optional readOnlySchema As Boolean = false,
    Optional setFieldFunc As SetFieldFunc = Nothing
) As RowsetBase
public:
static RowsetBase^ FromJSON(
    JSONDataMap^ jsonMap,
    [OutAttribute] bool% allMatched,
    bool schemaOnly = false,
    bool readOnlySchema = false,
    SetFieldFunc^ setFieldFunc = nullptr
)
public:
static RowsetBase^ FromJSON(
    JSONDataMap^ jsonMap,
    [OutAttribute] bool% allMatched,
    bool schemaOnly = false,
    bool readOnlySchema = false,
    SetFieldFunc^ setFieldFunc = nullptr
)
static member FromJSON :
        jsonMap : JSONDataMap *
        allMatched : bool byref *
        ?schemaOnly : bool *
        ?readOnlySchema : bool *
        ?setFieldFunc : SetFieldFunc
(* Defaults:
        let _schemaOnly = defaultArg schemaOnly false
        let _readOnlySchema = defaultArg readOnlySchema false
        let _setFieldFunc = defaultArg setFieldFunc null
*)
-> RowsetBase
static member FromJSON :
        jsonMap : JSONDataMap *
        allMatched : bool byref *
        ?schemaOnly : bool *
        ?readOnlySchema : bool *
        ?setFieldFunc : SetFieldFunc
(* Defaults:
        let _schemaOnly = defaultArg schemaOnly false
        let _readOnlySchema = defaultArg readOnlySchema false
        let _setFieldFunc = defaultArg setFieldFunc null
*)
-> RowsetBase

Parameters

jsonMap
Type: NFX.Serialization.JSON JSONDataMap
allMatched
Type: Online System Boolean
schemaOnly (Optional)
Type: Online System Boolean
readOnlySchema (Optional)
Type: Online System Boolean
setFieldFunc (Optional)
Type: NFX.DataAccess.CRUD SetFieldFunc

Return Value

Type: RowsetBase
See Also
RowsetBase Class
RowsetBase Members
FromJSON Overload
NFX.DataAccess.CRUD Namespace


RowsetBase.GetChangeAt Method

RowsetBase GetChangeAt Method NFX Class Library

Retrievs a change by index or null if index is out of bounds or changes are not logged

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<RowChange> GetChangeAt(
    int idx
)
public Nullable<RowChange> GetChangeAt(
    int idx
)
Public Function GetChangeAt (
    idx As Integer
) As Nullable(Of RowChange)
Public Function GetChangeAt (
    idx As Integer
) As Nullable(Of RowChange)
public:
Nullable<RowChange> GetChangeAt(
    int idx
)
public:
Nullable<RowChange> GetChangeAt(
    int idx
)
member GetChangeAt :
        idx : int -> Nullable<RowChange>
member GetChangeAt :
        idx : int -> Nullable<RowChange>

Parameters

idx
Type: Online System Int32

Return Value

Type: Online Nullable RowChange
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.GetEnumerator Method

RowsetBase GetEnumerator Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<Row> GetEnumerator()
public IEnumerator<Row> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of Row)
Public Function GetEnumerator As IEnumerator(Of Row)
public:
virtual IEnumerator<Row^>^ GetEnumerator() sealed
public:
virtual IEnumerator<Row^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<Row>
override GetEnumerator : unit -> IEnumerator<Row>
abstract GetEnumerator : unit -> IEnumerator<Row>
override GetEnumerator : unit -> IEnumerator<Row>

Return Value

Type: Online IEnumerator Row

Implements

Online IEnumerable T GetEnumerator
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.IndexOf Method

RowsetBase IndexOf Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int IndexOf(
    Row row
)
public int IndexOf(
    Row row
)
Public Function IndexOf (
    row As Row
) As Integer
Public Function IndexOf (
    row As Row
) As Integer
public:
virtual int IndexOf(
    Row^ row
) sealed
public:
virtual int IndexOf(
    Row^ row
) sealed
abstract IndexOf :
        row : Row -> int
override IndexOf :
        row : Row -> int
abstract IndexOf :
        row : Row -> int
override IndexOf :
        row : Row -> int

Parameters

row
Type: NFX.DataAccess.CRUD Row

Return Value

Type: Online Int32

Implements

Online IList T IndexOf(T)
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.Insert Method

RowsetBase Insert Method NFX Class Library

Overload List
 | Name | Description
Public method | Insert(Row) | Inserts the row. Returns insertion index
Public method | Insert(Int32, Row) | Inserts row at index
Back to Top
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.Insert Method (Row)

RowsetBase Insert Method (Row) NFX Class Library

Inserts the row. Returns insertion index

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Insert(
    Row row
)
public int Insert(
    Row row
)
Public Function Insert (
    row As Row
) As Integer
Public Function Insert (
    row As Row
) As Integer
public:
int Insert(
    Row^ row
)
public:
int Insert(
    Row^ row
)
member Insert :
        row : Row -> int
member Insert :
        row : Row -> int

Parameters

row
Type: NFX.DataAccess.CRUD Row

Return Value

Type: Online Int32
See Also
RowsetBase Class
RowsetBase Members
Insert Overload
NFX.DataAccess.CRUD Namespace


RowsetBase.Insert Method (Int32, Row)

RowsetBase Insert Method (Int32, Row) NFX Class Library

Inserts row at index

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Insert(
    int index,
    Row row
)
public virtual void Insert(
    int index,
    Row row
)
Public Overridable Sub Insert (
    index As Integer,
    row As Row
)
Public Overridable Sub Insert (
    index As Integer,
    row As Row
)
public:
virtual void Insert(
    int index,
    Row^ row
)
public:
virtual void Insert(
    int index,
    Row^ row
)
abstract Insert :
        index : int *
        row : Row -> unit
override Insert :
        index : int *
        row : Row -> unit
abstract Insert :
        index : int *
        row : Row -> unit
override Insert :
        index : int *
        row : Row -> unit

Parameters

index
Type: Online System Int32
row
Type: NFX.DataAccess.CRUD Row

Implements

Online IList T Insert(Int32, T)
See Also
RowsetBase Class
RowsetBase Members
Insert Overload
NFX.DataAccess.CRUD Namespace


RowsetBase.KeyRowFromValues Method

RowsetBase KeyRowFromValues Method NFX Class Library

Creates key row out of field values for keys

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Row KeyRowFromValues(
    params Object[] keys
)
public Row KeyRowFromValues(
    params Object[] keys
)
Public Function KeyRowFromValues (
    ParamArray keys As Object()
) As Row
Public Function KeyRowFromValues (
    ParamArray keys As Object()
) As Row
public:
Row^ KeyRowFromValues(
    ... array<Object^>^ keys
)
public:
Row^ KeyRowFromValues(
    ... array<Object^>^ keys
)
member KeyRowFromValues :
        keys : Object[] -> Row
member KeyRowFromValues :
        keys : Object[] -> Row

Parameters

keys
Type: Online System Object

Return Value

Type: Row
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.Purge Method

RowsetBase Purge Method NFX Class Library

Deletes all rows from table without logging the deleted modifications even when LogModifications=true

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Purge()
public void Purge()
Public Sub Purge
Public Sub Purge
public:
void Purge()
public:
void Purge()
member Purge : unit -> unit
member Purge : unit -> unit
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.PurgeChanges Method

RowsetBase PurgeChanges Method NFX Class Library

Clears modifications accumulated by this instance

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void PurgeChanges()
public void PurgeChanges()
Public Sub PurgeChanges
Public Sub PurgeChanges
public:
void PurgeChanges()
public:
void PurgeChanges()
member PurgeChanges : unit -> unit
member PurgeChanges : unit -> unit
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.Remove Method

RowsetBase Remove Method NFX Class Library

Performs row delete

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Remove(
    Row item
)
public bool Remove(
    Row item
)
Public Function Remove (
    item As Row
) As Boolean
Public Function Remove (
    item As Row
) As Boolean
public:
virtual bool Remove(
    Row^ item
) sealed
public:
virtual bool Remove(
    Row^ item
) sealed
abstract Remove :
        item : Row -> bool
override Remove :
        item : Row -> bool
abstract Remove :
        item : Row -> bool
override Remove :
        item : Row -> bool

Parameters

item
Type: NFX.DataAccess.CRUD Row

Return Value

Type: Online Boolean

Implements

Online ICollection T Remove(T)
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.RemoveAt Method

RowsetBase RemoveAt Method NFX Class Library

Deletes row

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RemoveAt(
    int index
)
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)
Public Sub RemoveAt (
    index As Integer
)
public:
virtual void RemoveAt(
    int index
) sealed
public:
virtual void RemoveAt(
    int index
) sealed
abstract RemoveAt :
        index : int -> unit
override RemoveAt :
        index : int -> unit
abstract RemoveAt :
        index : int -> unit
override RemoveAt :
        index : int -> unit

Parameters

index
Type: Online System Int32

Implements

Online IList T RemoveAt(Int32)
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.SearchForRow Method

RowsetBase SearchForRow Method NFX Class Library

Provides rowsearching. Override to do binary search in sorted rowsets

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual int SearchForRow(
    Row row,
    out int index
)
protected virtual int SearchForRow(
    Row row,
    out int index
)
Protected Overridable Function SearchForRow (
    row As Row,
    <OutAttribute> ByRef index As Integer
) As Integer
Protected Overridable Function SearchForRow (
    row As Row,
    <OutAttribute> ByRef index As Integer
) As Integer
protected:
virtual int SearchForRow(
    Row^ row,
    [OutAttribute] int% index
)
protected:
virtual int SearchForRow(
    Row^ row,
    [OutAttribute] int% index
)
abstract SearchForRow :
        row : Row *
        index : int byref -> int
override SearchForRow :
        row : Row *
        index : int byref -> int
abstract SearchForRow :
        row : Row *
        index : int byref -> int
override SearchForRow :
        row : Row *
        index : int byref -> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
A row to search for
index
Type: Online System Int32
An index where search collapsed without finding the match. Used for sorted insertions

Return Value

Type: Online Int32
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.Update Method

RowsetBase Update Method NFX Class Library

Updates the row, Returns the row index or -1

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Update(
    Row row,
    IDataStoreKey key = null
)
public int Update(
    Row row,
    IDataStoreKey key = null
)
Public Function Update (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Integer
Public Function Update (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Integer
public:
int Update(
    Row^ row,
    IDataStoreKey^ key = nullptr
)
public:
int Update(
    Row^ row,
    IDataStoreKey^ key = nullptr
)
member Update :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int
member Update :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey

Return Value

Type: Online Int32
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.Upsert Method

RowsetBase Upsert Method NFX Class Library

Tries to find a row for update and if found, updates it and returns true, otherwise inserts the row (if schemas match) and returns false. Optionally pass updateWhere condition that may check whether update needs to be performed

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Upsert(
    Row row,
    Func<Row, bool> updateWhere = null
)
public bool Upsert(
    Row row,
    Func<Row, bool> updateWhere = null
)
Public Function Upsert (
    row As Row,
    Optional updateWhere As Func(Of Row, Boolean) = Nothing
) As Boolean
Public Function Upsert (
    row As Row,
    Optional updateWhere As Func(Of Row, Boolean) = Nothing
) As Boolean
public:
bool Upsert(
    Row^ row,
    Func<Row^, bool>^ updateWhere = nullptr
)
public:
bool Upsert(
    Row^ row,
    Func<Row^, bool>^ updateWhere = nullptr
)
member Upsert :
        row : Row *
        ?updateWhere : Func<Row, bool>
(* Defaults:
        let _updateWhere = defaultArg updateWhere null
*)
-> bool
member Upsert :
        row : Row *
        ?updateWhere : Func<Row, bool>
(* Defaults:
        let _updateWhere = defaultArg updateWhere null
*)
-> bool

Parameters

row
Type: NFX.DataAccess.CRUD Row
updateWhere (Optional)
Type: Online System Func Row, Online Boolean

Return Value

Type: Online Boolean
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.Validate Method

RowsetBase Validate Method NFX Class Library

Validates all rows in this rowset. Override to perform custom validations. The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Exception Validate(
    string targetName
)
public virtual Exception Validate(
    string targetName
)
Public Overridable Function Validate (
    targetName As String
) As Exception
Public Overridable Function Validate (
    targetName As String
) As Exception
public:
virtual Exception^ Validate(
    String^ targetName
)
public:
virtual Exception^ Validate(
    String^ targetName
)
abstract Validate :
        targetName : string -> Exception
override Validate :
        targetName : string -> Exception
abstract Validate :
        targetName : string -> Exception
override Validate :
        targetName : string -> Exception

Parameters

targetName
Type: Online System String

Return Value

Type: Online Exception

Implements

IValidatable Validate(String)
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.WriteAsJSON Method

RowsetBase WriteAsJSON Method NFX Class Library

Writes rowset as JSON including schema information. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
nestingLevel
Type: Online System Int32
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Implements

IJSONWritable WriteAsJSON(TextWriter, Int32, JSONWritingOptions)
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase Properties

RowsetBase Properties NFX Class Library

The RowsetBase type exposes the following members.
Properties
 | Name | Description
Public property | AsReadonlyIList | Returns data as non-generic readonly IList
Public property | ChangeCount | Returns a count of accumulated modifications performed on the rowset, or zero when no modifications have been made or LogModifications = false
Public property | Changes | Returns accumulated modifications performed on the rowset, or empty enumerator if no modifications have been made or LogModifications = false
Public property | Context | Provides dynamic view of rowset's data context - attributes applicable to the whole rowset
Public property | ContextMap | Provides dynamic view as JSONDataMap of rowset's data context - attributes applicable to the whole rowset
Public property | Count | Returns row count in this rowset
Public property | InstanceGUID | Returns globaly-unique instance ID. This ID is useful as a key for storing rowsets in object stores and posting data back from web client to server.
Public property | IsReadOnly |
Public property | Item | This method performs update on set
Public property | LogChanges | Gets/Sets whether this rowset keeps track of all modifications done to it. This property must be set to true to be able to save changes into ICRUDDataStore
Public property | Schema | Returns a schema for rows that this rowset contains
Back to Top
See Also
RowsetBase Class
NFX.DataAccess.CRUD Namespace


RowsetBase.AsReadonlyIList Property

RowsetBase AsReadonlyIList Property NFX Class Library

Returns data as non-generic readonly IList

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IList AsReadonlyIList { get; }
public IList AsReadonlyIList { get; }
Public ReadOnly Property AsReadonlyIList As IList
    Get
Public ReadOnly Property AsReadonlyIList As IList
    Get
public:
property IList^ AsReadonlyIList {
    IList^ get ();
}
public:
property IList^ AsReadonlyIList {
    IList^ get ();
}
member AsReadonlyIList : IList with get
member AsReadonlyIList : IList with get

Property Value

Type: Online IList
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.ChangeCount Property

RowsetBase ChangeCount Property NFX Class Library

Returns a count of accumulated modifications performed on the rowset, or zero when no modifications have been made or LogModifications = false

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ChangeCount { get; }
public int ChangeCount { get; }
Public ReadOnly Property ChangeCount As Integer
    Get
Public ReadOnly Property ChangeCount As Integer
    Get
public:
property int ChangeCount {
    int get ();
}
public:
property int ChangeCount {
    int get ();
}
member ChangeCount : int with get
member ChangeCount : int with get

Property Value

Type: Online Int32
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.Changes Property

RowsetBase Changes Property NFX Class Library

Returns accumulated modifications performed on the rowset, or empty enumerator if no modifications have been made or LogModifications = false

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<RowChange> Changes { get; }
public IEnumerable<RowChange> Changes { get; }
Public ReadOnly Property Changes As IEnumerable(Of RowChange)
    Get
Public ReadOnly Property Changes As IEnumerable(Of RowChange)
    Get
public:
property IEnumerable<RowChange>^ Changes {
    IEnumerable<RowChange>^ get ();
}
public:
property IEnumerable<RowChange>^ Changes {
    IEnumerable<RowChange>^ get ();
}
member Changes : IEnumerable<RowChange> with get
member Changes : IEnumerable<RowChange> with get

Property Value

Type: Online IEnumerable RowChange
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.Context Property

RowsetBase Context Property NFX Class Library

Provides dynamic view of rowset's data context - attributes applicable to the whole rowset

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Context { get; }
public Object Context { get; }
Public ReadOnly Property Context As Object
    Get
Public ReadOnly Property Context As Object
    Get
public:
property Object^ Context {
    Object^ get ();
}
public:
property Object^ Context {
    Object^ get ();
}
member Context : Object with get
member Context : Object with get

Property Value

Type: Online Object
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.ContextMap Property

RowsetBase ContextMap Property NFX Class Library

Provides dynamic view as JSONDataMap of rowset's data context - attributes applicable to the whole rowset

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDataMap ContextMap { get; }
public JSONDataMap ContextMap { get; }
Public ReadOnly Property ContextMap As JSONDataMap
    Get
Public ReadOnly Property ContextMap As JSONDataMap
    Get
public:
property JSONDataMap^ ContextMap {
    JSONDataMap^ get ();
}
public:
property JSONDataMap^ ContextMap {
    JSONDataMap^ get ();
}
member ContextMap : JSONDataMap with get
member ContextMap : JSONDataMap with get

Property Value

Type: JSONDataMap
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.Count Property

RowsetBase Count Property NFX Class Library

Returns row count in this rowset

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
public:
virtual property int Count {
    int get () sealed;
}
abstract Count : int with get
override Count : int with get
abstract Count : int with get
override Count : int with get

Property Value

Type: Online Int32

Implements

Online ICollection T Count
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.InstanceGUID Property

RowsetBase InstanceGUID Property NFX Class Library

Returns globaly-unique instance ID. This ID is useful as a key for storing rowsets in object stores and posting data back from web client to server.

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid InstanceGUID { get; }
public Guid InstanceGUID { get; }
Public ReadOnly Property InstanceGUID As Guid
    Get
Public ReadOnly Property InstanceGUID As Guid
    Get
public:
property Guid InstanceGUID {
    Guid get ();
}
public:
property Guid InstanceGUID {
    Guid get ();
}
member InstanceGUID : Guid with get
member InstanceGUID : Guid with get

Property Value

Type: Online Guid
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.IsReadOnly Property

RowsetBase IsReadOnly Property NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsReadOnly { get; }
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get

Property Value

Type: Online Boolean

Implements

Online ICollection T IsReadOnly
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.Item Property

RowsetBase Item Property NFX Class Library

This method performs update on set

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Row this[
    int index
] { get; set; }
public virtual Row this[
    int index
] { get; set; }
Public Overridable Default Property Item (
    index As Integer
) As Row
    Get
    Set
Public Overridable Default Property Item (
    index As Integer
) As Row
    Get
    Set
public:
virtual property Row^ default[int index] {
    Row^ get (int index);
    void set (int index, Row^ value);
}
public:
virtual property Row^ default[int index] {
    Row^ get (int index);
    void set (int index, Row^ value);
}
abstract Item : Row with get, set
override Item : Row with get, set
abstract Item : Row with get, set
override Item : Row with get, set

Parameters

index
Type: Online System Int32

Property Value

Type: Row

Implements

Online IList T Item Int32
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.LogChanges Property

RowsetBase LogChanges Property NFX Class Library

Gets/Sets whether this rowset keeps track of all modifications done to it. This property must be set to true to be able to save changes into ICRUDDataStore

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool LogChanges { get; set; }
public bool LogChanges { get; set; }
Public Property LogChanges As Boolean
    Get
    Set
Public Property LogChanges As Boolean
    Get
    Set
public:
property bool LogChanges {
    bool get ();
    void set (bool value);
}
public:
property bool LogChanges {
    bool get ();
    void set (bool value);
}
member LogChanges : bool with get, set
member LogChanges : bool with get, set

Property Value

Type: Online Boolean
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


RowsetBase.Schema Property

RowsetBase Schema Property NFX Class Library

Returns a schema for rows that this rowset contains

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Schema Schema { get; }
public Schema Schema { get; }
Public ReadOnly Property Schema As Schema
    Get
Public ReadOnly Property Schema As Schema
    Get
public:
property Schema^ Schema {
    Schema^ get ();
}
public:
property Schema^ Schema {
    Schema^ get ();
}
member Schema : Schema with get
member Schema : Schema with get

Property Value

Type: Schema
See Also
RowsetBase Class
RowsetBase Members
NFX.DataAccess.CRUD Namespace


Schema Class

Schema Class NFX Class Library

Describes a schema for rows: TypedRows and DynamicRows. DynamicRows are "shaped" in memory from schema, whereas, TypedRows define schema. Schema for Typedrows is cached in static dictionary for speed
Inheritance Hierarchy
Online System Object
NFX.DataAccess.CRUD Schema

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class Schema : INamed,
    IEnumerable<Schema..::..FieldDef>, IEnumerable, IJSONWritable
[SerializableAttribute]
public sealed class Schema : INamed,
    IEnumerable<Schema..::..FieldDef>, IEnumerable, IJSONWritable
<SerializableAttribute>
Public NotInheritable Class Schema
    Implements INamed, IEnumerable(Of Schema..::..FieldDef),
    IEnumerable, IJSONWritable
<SerializableAttribute>
Public NotInheritable Class Schema
    Implements INamed, IEnumerable(Of Schema..::..FieldDef),
    IEnumerable, IJSONWritable
[SerializableAttribute]
public ref class Schema sealed : INamed,
    IEnumerable<Schema..::..FieldDef^>, IEnumerable, IJSONWritable
[SerializableAttribute]
public ref class Schema sealed : INamed,
    IEnumerable<Schema..::..FieldDef^>, IEnumerable, IJSONWritable
[<SealedAttribute>]
[<SerializableAttribute>]
type Schema =
    class
        interface INamed
        interface IEnumerable<Schema..::..FieldDef>
        interface IEnumerable
        interface IJSONWritable
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type Schema =
    class
        interface INamed
        interface IEnumerable<Schema..::..FieldDef>
        interface IEnumerable
        interface IJSONWritable
    end
See Also
Schema Members
NFX.DataAccess.CRUD Namespace


Schema Members

Schema Members NFX Class Library

The Schema type exposes the following members.
Constructors
 | Name | Description
Public method | Schema(String, Schema FieldDef ) | Initializes a new instance of the Schema class
Public method | Schema(String, Boolean, Schema FieldDef ) | Initializes a new instance of the Schema class
Public method | Schema(String, Boolean, IEnumerable Schema FieldDef , IEnumerable TableAttribute ) | Initializes a new instance of the Schema class
Public method | Schema(String, Boolean, IEnumerable TableAttribute , Schema FieldDef ) | Initializes a new instance of the Schema class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | FromJSON(String, Boolean) |
 | FromJSON(JSONDataMap, Boolean) |
Public method | GetEnumerator |
Public method | GetFieldDefByIndex | Finds fielddef by name or throws if name is not found
Public method | GetFieldDefByName | Finds fielddef by name or throws if name is not found
 | GetFieldMembers | Gets all property members of TypedRow that are tagged as [Field]
 | GetForTypedRow(Type) | Returns schema instance for the TypedRow instance by fetching schema object from cache or creating it if it has not been cached yet
 | GetForTypedRow(TypedRow) | Returns schema instance for the TypedRow instance by fetching schema object from cache or creating it if it has not been cached yet
 | GetForTypedRow TRow | Returns schema instance for the TypedRow instance by fetching schema object from cache or creating it if it has not been cached yet
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetKeyFieldDefsForTarget | Returns FieldDefs in their order within rows that are declared as key fields for particular target
Public method | GetTableAttrForTarget | Returns a TableAttribute that matches the supplied targetName, or if one was not defined then returns TableAttribute which matches any target or null
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsEquivalentTo | Performs logical equivalence testing of two schemas
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Public method | WriteAsJSON | Writes schema as JSON. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable Schema FieldDef | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct Schema FieldDef, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax Schema FieldDef, TComparand (Func Schema FieldDef, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax Schema FieldDef, TComparand (Func Schema FieldDef, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin Schema FieldDef, TComparand (Func Schema FieldDef, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin Schema FieldDef, TComparand (Func Schema FieldDef, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault Schema FieldDef | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach Schema FieldDef (Action Schema FieldDef ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach Schema FieldDef (Action Schema FieldDef, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast Schema FieldDef | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast Schema FieldDef (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
EXTRA_SUPPORTS_DELETE_ATTR |
EXTRA_SUPPORTS_INSERT_ATTR |
EXTRA_SUPPORTS_UPDATE_ATTR |
Back to Top
Properties
 | Name | Description
Public property | AnyTargetKeyFieldDefs | Returns FieldDefs in their order within rows that are declared as key fields in ANY_TARGET
Public property | AnyVisibleFieldDefs | Returns FieldDefs in their order within rows as
Public property | ExtraData | Returns Extra data that may be associated with schema by various providers. The field is lazily allocated
Public property | FieldCount | Returns field count
Public property | FieldDefs | Returns FieldDefs in their order within rows that this schema describes
Public property | Item Int32 | Returns a field definition by a positional index within the row
Public property | Item String | Returns a field definition by a unique case-insensitive field name within schema
Public property | Name | For TypedRows, returns a unique fully-qualified row type name, whichs is the global identifier of this schema instance
Public property | ReadOnly | Specifies that target that this schema represents (i.e. db table) is not updatable so DataStore will not be able to save row changes made in ram
 | SchemaEquivalenceEqualityComparer | Returns an instance of IEqualityComparer(Schema) that performs logical equivalence testing
Public property | TableAttrs | Returns table-level attributes
Public property | TypedRowType | Returns a type of TypedRow if schema was created for TypedRow, or null
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
Schema Class
NFX.DataAccess.CRUD Namespace


Schema Constructor

Schema Constructor NFX Class Library

Overload List
 | Name | Description
Public method | Schema(String, Schema FieldDef ) | Initializes a new instance of the Schema class
Public method | Schema(String, Boolean, Schema FieldDef ) | Initializes a new instance of the Schema class
Public method | Schema(String, Boolean, IEnumerable Schema FieldDef , IEnumerable TableAttribute ) | Initializes a new instance of the Schema class
Public method | Schema(String, Boolean, IEnumerable TableAttribute , Schema FieldDef ) | Initializes a new instance of the Schema class
Back to Top
See Also
Schema Class
Schema Members
NFX.DataAccess.CRUD Namespace


Schema Constructor (String, Schema.FieldDef[])

Schema Constructor (String, Schema FieldDef ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Schema class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Schema(
    string name,
    params Schema..::..FieldDef[] fieldDefs
)
public Schema(
    string name,
    params Schema..::..FieldDef[] fieldDefs
)
Public Sub New (
    name As String,
    ParamArray fieldDefs As Schema..::..FieldDef()
)
Public Sub New (
    name As String,
    ParamArray fieldDefs As Schema..::..FieldDef()
)
public:
Schema(
    String^ name,
    ... array<Schema..::..FieldDef^>^ fieldDefs
)
public:
Schema(
    String^ name,
    ... array<Schema..::..FieldDef^>^ fieldDefs
)
new :
        name : string *
        fieldDefs : Schema..::..FieldDef[] -> Schema
new :
        name : string *
        fieldDefs : Schema..::..FieldDef[] -> Schema

Parameters

name
Type: Online System String
fieldDefs
Type: NFX.DataAccess.CRUD Schema FieldDef
See Also
Schema Class
Schema Members
Schema Overload
NFX.DataAccess.CRUD Namespace


Schema Constructor (String, Boolean, Schema.FieldDef[])

Schema Constructor (String, Boolean, Schema FieldDef ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Schema class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Schema(
    string name,
    bool readOnly,
    params Schema..::..FieldDef[] fieldDefs
)
public Schema(
    string name,
    bool readOnly,
    params Schema..::..FieldDef[] fieldDefs
)
Public Sub New (
    name As String,
    readOnly As Boolean,
    ParamArray fieldDefs As Schema..::..FieldDef()
)
Public Sub New (
    name As String,
    readOnly As Boolean,
    ParamArray fieldDefs As Schema..::..FieldDef()
)
public:
Schema(
    String^ name,
    bool readOnly,
    ... array<Schema..::..FieldDef^>^ fieldDefs
)
public:
Schema(
    String^ name,
    bool readOnly,
    ... array<Schema..::..FieldDef^>^ fieldDefs
)
new :
        name : string *
        readOnly : bool *
        fieldDefs : Schema..::..FieldDef[] -> Schema
new :
        name : string *
        readOnly : bool *
        fieldDefs : Schema..::..FieldDef[] -> Schema

Parameters

name
Type: Online System String
readOnly
Type: Online System Boolean
fieldDefs
Type: NFX.DataAccess.CRUD Schema FieldDef
See Also
Schema Class
Schema Members
Schema Overload
NFX.DataAccess.CRUD Namespace


Schema Constructor (String, Boolean, IEnumerable(Schema.FieldDef), IEnumerable(TableAttribute))

Schema Constructor (String, Boolean, IEnumerable Schema FieldDef , IEnumerable TableAttribute ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Schema class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Schema(
    string name,
    bool readOnly,
    IEnumerable<Schema..::..FieldDef> fieldDefs,
    IEnumerable<TableAttribute> tableAttributes = null
)
public Schema(
    string name,
    bool readOnly,
    IEnumerable<Schema..::..FieldDef> fieldDefs,
    IEnumerable<TableAttribute> tableAttributes = null
)
Public Sub New (
    name As String,
    readOnly As Boolean,
    fieldDefs As IEnumerable(Of Schema..::..FieldDef),
    Optional tableAttributes As IEnumerable(Of TableAttribute) = Nothing
)
Public Sub New (
    name As String,
    readOnly As Boolean,
    fieldDefs As IEnumerable(Of Schema..::..FieldDef),
    Optional tableAttributes As IEnumerable(Of TableAttribute) = Nothing
)
public:
Schema(
    String^ name,
    bool readOnly,
    IEnumerable<Schema..::..FieldDef^>^ fieldDefs,
    IEnumerable<TableAttribute^>^ tableAttributes = nullptr
)
public:
Schema(
    String^ name,
    bool readOnly,
    IEnumerable<Schema..::..FieldDef^>^ fieldDefs,
    IEnumerable<TableAttribute^>^ tableAttributes = nullptr
)
new :
        name : string *
        readOnly : bool *
        fieldDefs : IEnumerable<Schema..::..FieldDef> *
        ?tableAttributes : IEnumerable<TableAttribute>
(* Defaults:
        let _tableAttributes = defaultArg tableAttributes null
*)
-> Schema
new :
        name : string *
        readOnly : bool *
        fieldDefs : IEnumerable<Schema..::..FieldDef> *
        ?tableAttributes : IEnumerable<TableAttribute>
(* Defaults:
        let _tableAttributes = defaultArg tableAttributes null
*)
-> Schema

Parameters

name
Type: Online System String
readOnly
Type: Online System Boolean
fieldDefs
Type: Online System.Collections.Generic IEnumerable Schema FieldDef
tableAttributes (Optional)
Type: Online System.Collections.Generic IEnumerable TableAttribute
See Also
Schema Class
Schema Members
Schema Overload
NFX.DataAccess.CRUD Namespace


Schema Constructor (String, Boolean, IEnumerable(TableAttribute), Schema.FieldDef[])

Schema Constructor (String, Boolean, IEnumerable TableAttribute , Schema FieldDef ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Schema class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Schema(
    string name,
    bool readOnly,
    IEnumerable<TableAttribute> tableAttributes,
    params Schema..::..FieldDef[] fieldDefs
)
public Schema(
    string name,
    bool readOnly,
    IEnumerable<TableAttribute> tableAttributes,
    params Schema..::..FieldDef[] fieldDefs
)
Public Sub New (
    name As String,
    readOnly As Boolean,
    tableAttributes As IEnumerable(Of TableAttribute),
    ParamArray fieldDefs As Schema..::..FieldDef()
)
Public Sub New (
    name As String,
    readOnly As Boolean,
    tableAttributes As IEnumerable(Of TableAttribute),
    ParamArray fieldDefs As Schema..::..FieldDef()
)
public:
Schema(
    String^ name,
    bool readOnly,
    IEnumerable<TableAttribute^>^ tableAttributes,
    ... array<Schema..::..FieldDef^>^ fieldDefs
)
public:
Schema(
    String^ name,
    bool readOnly,
    IEnumerable<TableAttribute^>^ tableAttributes,
    ... array<Schema..::..FieldDef^>^ fieldDefs
)
new :
        name : string *
        readOnly : bool *
        tableAttributes : IEnumerable<TableAttribute> *
        fieldDefs : Schema..::..FieldDef[] -> Schema
new :
        name : string *
        readOnly : bool *
        tableAttributes : IEnumerable<TableAttribute> *
        fieldDefs : Schema..::..FieldDef[] -> Schema

Parameters

name
Type: Online System String
readOnly
Type: Online System Boolean
tableAttributes
Type: Online System.Collections.Generic IEnumerable TableAttribute
fieldDefs
Type: NFX.DataAccess.CRUD Schema FieldDef
See Also
Schema Class
Schema Members
Schema Overload
NFX.DataAccess.CRUD Namespace


Schema Fields

Schema Fields NFX Class Library

The Schema type exposes the following members.
Fields
Name | Description
EXTRA_SUPPORTS_DELETE_ATTR |
EXTRA_SUPPORTS_INSERT_ATTR |
EXTRA_SUPPORTS_UPDATE_ATTR |
Back to Top
See Also
Schema Class
NFX.DataAccess.CRUD Namespace


Schema.EXTRA_SUPPORTS_DELETE_ATTR Field

Schema EXTRA_SUPPORTS_DELETE_ATTR Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string EXTRA_SUPPORTS_DELETE_ATTR
public const string EXTRA_SUPPORTS_DELETE_ATTR
Public Const EXTRA_SUPPORTS_DELETE_ATTR As String
Public Const EXTRA_SUPPORTS_DELETE_ATTR As String
public:
literal String^ EXTRA_SUPPORTS_DELETE_ATTR
public:
literal String^ EXTRA_SUPPORTS_DELETE_ATTR
static val mutable EXTRA_SUPPORTS_DELETE_ATTR: string
static val mutable EXTRA_SUPPORTS_DELETE_ATTR: string

Field Value

Type: Online String
See Also
Schema Class
Schema Members
NFX.DataAccess.CRUD Namespace


Schema.EXTRA_SUPPORTS_INSERT_ATTR Field

Schema EXTRA_SUPPORTS_INSERT_ATTR Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string EXTRA_SUPPORTS_INSERT_ATTR
public const string EXTRA_SUPPORTS_INSERT_ATTR
Public Const EXTRA_SUPPORTS_INSERT_ATTR As String
Public Const EXTRA_SUPPORTS_INSERT_ATTR As String
public:
literal String^ EXTRA_SUPPORTS_INSERT_ATTR
public:
literal String^ EXTRA_SUPPORTS_INSERT_ATTR
static val mutable EXTRA_SUPPORTS_INSERT_ATTR: string
static val mutable EXTRA_SUPPORTS_INSERT_ATTR: string

Field Value

Type: Online String
See Also
Schema Class
Schema Members
NFX.DataAccess.CRUD Namespace


Schema.EXTRA_SUPPORTS_UPDATE_ATTR Field

Schema EXTRA_SUPPORTS_UPDATE_ATTR Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string EXTRA_SUPPORTS_UPDATE_ATTR
public const string EXTRA_SUPPORTS_UPDATE_ATTR
Public Const EXTRA_SUPPORTS_UPDATE_ATTR As String
Public Const EXTRA_SUPPORTS_UPDATE_ATTR As String
public:
literal String^ EXTRA_SUPPORTS_UPDATE_ATTR
public:
literal String^ EXTRA_SUPPORTS_UPDATE_ATTR
static val mutable EXTRA_SUPPORTS_UPDATE_ATTR: string
static val mutable EXTRA_SUPPORTS_UPDATE_ATTR: string

Field Value

Type: Online String
See Also
Schema Class
Schema Members
NFX.DataAccess.CRUD Namespace


Schema Methods

Schema Methods NFX Class Library

The Schema type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | FromJSON(String, Boolean) |
 | FromJSON(JSONDataMap, Boolean) |
Public method | GetEnumerator |
Public method | GetFieldDefByIndex | Finds fielddef by name or throws if name is not found
Public method | GetFieldDefByName | Finds fielddef by name or throws if name is not found
 | GetFieldMembers | Gets all property members of TypedRow that are tagged as [Field]
 | GetForTypedRow(Type) | Returns schema instance for the TypedRow instance by fetching schema object from cache or creating it if it has not been cached yet
 | GetForTypedRow(TypedRow) | Returns schema instance for the TypedRow instance by fetching schema object from cache or creating it if it has not been cached yet
 | GetForTypedRow TRow | Returns schema instance for the TypedRow instance by fetching schema object from cache or creating it if it has not been cached yet
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetKeyFieldDefsForTarget | Returns FieldDefs in their order within rows that are declared as key fields for particular target
Public method | GetTableAttrForTarget | Returns a TableAttribute that matches the supplied targetName, or if one was not defined then returns TableAttribute which matches any target or null
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsEquivalentTo | Performs logical equivalence testing of two schemas
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Public method | WriteAsJSON | Writes schema as JSON. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable Schema FieldDef | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct Schema FieldDef, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax Schema FieldDef, TComparand (Func Schema FieldDef, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax Schema FieldDef, TComparand (Func Schema FieldDef, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin Schema FieldDef, TComparand (Func Schema FieldDef, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin Schema FieldDef, TComparand (Func Schema FieldDef, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault Schema FieldDef | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach Schema FieldDef (Action Schema FieldDef ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach Schema FieldDef (Action Schema FieldDef, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast Schema FieldDef | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast Schema FieldDef (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
Schema Class
NFX.DataAccess.CRUD Namespace


Schema.IEnumerable.GetEnumerator Method

Schema IEnumerable GetEnumerator Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
Schema Class
Schema Members
NFX.DataAccess.CRUD Namespace


Schema.FromJSON Method

Schema FromJSON Method NFX Class Library

Overload List
Name | Description
FromJSON(String, Boolean) |
FromJSON(JSONDataMap, Boolean) |
Back to Top
See Also
Schema Class
Schema Members
NFX.DataAccess.CRUD Namespace


Schema.FromJSON Method (String, Boolean)

Schema FromJSON Method (String, Boolean) NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Schema FromJSON(
    string json,
    bool readOnly = false
)
public static Schema FromJSON(
    string json,
    bool readOnly = false
)
Public Shared Function FromJSON (
    json As String,
    Optional readOnly As Boolean = false
) As Schema
Public Shared Function FromJSON (
    json As String,
    Optional readOnly As Boolean = false
) As Schema
public:
static Schema^ FromJSON(
    String^ json,
    bool readOnly = false
)
public:
static Schema^ FromJSON(
    String^ json,
    bool readOnly = false
)
static member FromJSON :
        json : string *
        ?readOnly : bool
(* Defaults:
        let _readOnly = defaultArg readOnly false
*)
-> Schema
static member FromJSON :
        json : string *
        ?readOnly : bool
(* Defaults:
        let _readOnly = defaultArg readOnly false
*)
-> Schema

Parameters

json
Type: Online System String
readOnly (Optional)
Type: Online System Boolean

Return Value

Type: Schema
See Also
Schema Class
Schema Members
FromJSON Overload
NFX.DataAccess.CRUD Namespace


Schema.FromJSON Method (JSONDataMap, Boolean)

Schema FromJSON Method (JSONDataMap, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Schema FromJSON(
    JSONDataMap map,
    bool readOnly = false
)
public static Schema FromJSON(
    JSONDataMap map,
    bool readOnly = false
)
Public Shared Function FromJSON (
    map As JSONDataMap,
    Optional readOnly As Boolean = false
) As Schema
Public Shared Function FromJSON (
    map As JSONDataMap,
    Optional readOnly As Boolean = false
) As Schema
public:
static Schema^ FromJSON(
    JSONDataMap^ map,
    bool readOnly = false
)
public:
static Schema^ FromJSON(
    JSONDataMap^ map,
    bool readOnly = false
)
static member FromJSON :
        map : JSONDataMap *
        ?readOnly : bool
(* Defaults:
        let _readOnly = defaultArg readOnly false
*)
-> Schema
static member FromJSON :
        map : JSONDataMap *
        ?readOnly : bool
(* Defaults:
        let _readOnly = defaultArg readOnly false
*)
-> Schema

Parameters

map
Type: NFX.Serialization.JSON JSONDataMap
readOnly (Optional)
Type: Online System Boolean

Return Value

Type: Schema
See Also
Schema Class
Schema Members
FromJSON Overload
NFX.DataAccess.CRUD Namespace


Schema.GetEnumerator Method

Schema GetEnumerator Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<Schema..::..FieldDef> GetEnumerator()
public IEnumerator<Schema..::..FieldDef> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of Schema..::..FieldDef)
Public Function GetEnumerator As IEnumerator(Of Schema..::..FieldDef)
public:
virtual IEnumerator<Schema..::..FieldDef^>^ GetEnumerator() sealed
public:
virtual IEnumerator<Schema..::..FieldDef^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<Schema..::..FieldDef>
override GetEnumerator : unit -> IEnumerator<Schema..::..FieldDef>
abstract GetEnumerator : unit -> IEnumerator<Schema..::..FieldDef>
override GetEnumerator : unit -> IEnumerator<Schema..::..FieldDef>

Return Value

Type: Online IEnumerator Schema FieldDef

Implements

Online IEnumerable T GetEnumerator
See Also
Schema Class
Schema Members
NFX.DataAccess.CRUD Namespace


Schema.GetFieldDefByIndex Method

Schema GetFieldDefByIndex Method NFX Class Library

Finds fielddef by name or throws if name is not found

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Schema..::..FieldDef GetFieldDefByIndex(
    int index
)
public Schema..::..FieldDef GetFieldDefByIndex(
    int index
)
Public Function GetFieldDefByIndex (
    index As Integer
) As Schema..::..FieldDef
Public Function GetFieldDefByIndex (
    index As Integer
) As Schema..::..FieldDef
public:
Schema..::..FieldDef^ GetFieldDefByIndex(
    int index
)
public:
Schema..::..FieldDef^ GetFieldDefByIndex(
    int index
)
member GetFieldDefByIndex :
        index : int -> Schema..::..FieldDef
member GetFieldDefByIndex :
        index : int -> Schema..::..FieldDef

Parameters

index
Type: Online System Int32

Return Value

Type: Schema FieldDef
See Also
Schema Class
Schema Members
NFX.DataAccess.CRUD Namespace


Schema.GetFieldDefByName Method

Schema GetFieldDefByName Method NFX Class Library

Finds fielddef by name or throws if name is not found

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Schema..::..FieldDef GetFieldDefByName(
    string fieldName
)
public Schema..::..FieldDef GetFieldDefByName(
    string fieldName
)
Public Function GetFieldDefByName (
    fieldName As String
) As Schema..::..FieldDef
Public Function GetFieldDefByName (
    fieldName As String
) As Schema..::..FieldDef
public:
Schema..::..FieldDef^ GetFieldDefByName(
    String^ fieldName
)
public:
Schema..::..FieldDef^ GetFieldDefByName(
    String^ fieldName
)
member GetFieldDefByName :
        fieldName : string -> Schema..::..FieldDef
member GetFieldDefByName :
        fieldName : string -> Schema..::..FieldDef

Parameters

fieldName
Type: Online System String

Return Value

Type: Schema FieldDef
See Also
Schema Class
Schema Members
NFX.DataAccess.CRUD Namespace


Schema.GetFieldMembers Method

Schema GetFieldMembers Method NFX Class Library

Gets all property members of TypedRow that are tagged as [Field]

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<PropertyInfo> GetFieldMembers(
    Type type
)
public static IEnumerable<PropertyInfo> GetFieldMembers(
    Type type
)
Public Shared Function GetFieldMembers (
    type As Type
) As IEnumerable(Of PropertyInfo)
Public Shared Function GetFieldMembers (
    type As Type
) As IEnumerable(Of PropertyInfo)
public:
static IEnumerable<PropertyInfo^>^ GetFieldMembers(
    Type^ type
)
public:
static IEnumerable<PropertyInfo^>^ GetFieldMembers(
    Type^ type
)
static member GetFieldMembers :
        type : Type -> IEnumerable<PropertyInfo>
static member GetFieldMembers :
        type : Type -> IEnumerable<PropertyInfo>

Parameters

type
Type: Online System Type

Return Value

Type: Online IEnumerable Online PropertyInfo
See Also
Schema Class
Schema Members
NFX.DataAccess.CRUD Namespace


Schema.GetForTypedRow Method

Schema GetForTypedRow Method NFX Class Library

Overload List
Name | Description
GetForTypedRow TRow | Returns schema instance for the TypedRow instance by fetching schema object from cache or creating it if it has not been cached yet
GetForTypedRow(Type) | Returns schema instance for the TypedRow instance by fetching schema object from cache or creating it if it has not been cached yet
GetForTypedRow(TypedRow) | Returns schema instance for the TypedRow instance by fetching schema object from cache or creating it if it has not been cached yet
Back to Top
See Also
Schema Class
Schema Members
NFX.DataAccess.CRUD Namespace


Schema.GetForTypedRow(TRow) Method

Schema GetForTypedRow TRow Method NFX Class Library

Returns schema instance for the TypedRow instance by fetching schema object from cache or creating it if it has not been cached yet

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Schema GetForTypedRow<TRow>()
where TRow : TypedRow
public static Schema GetForTypedRow<TRow>()
where TRow : TypedRow
Public Shared Function GetForTypedRow(Of TRow As TypedRow) As Schema
Public Shared Function GetForTypedRow(Of TRow As TypedRow) As Schema
public:
generic<typename TRow>
where TRow : TypedRow
static Schema^ GetForTypedRow()
public:
generic<typename TRow>
where TRow : TypedRow
static Schema^ GetForTypedRow()
static member GetForTypedRow : unit -> Schema  when 'TRow : TypedRow
static member GetForTypedRow : unit -> Schema  when 'TRow : TypedRow
Type Parameters
TRow

Return Value

Type: Schema
See Also
Schema Class
Schema Members
GetForTypedRow Overload
NFX.DataAccess.CRUD Namespace


Schema.GetForTypedRow Method (Type)

Schema GetForTypedRow Method (Type) NFX Class Library

Returns schema instance for the TypedRow instance by fetching schema object from cache or creating it if it has not been cached yet

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Schema GetForTypedRow(
    Type trow
)
public static Schema GetForTypedRow(
    Type trow
)
Public Shared Function GetForTypedRow (
    trow As Type
) As Schema
Public Shared Function GetForTypedRow (
    trow As Type
) As Schema
public:
static Schema^ GetForTypedRow(
    Type^ trow
)
public:
static Schema^ GetForTypedRow(
    Type^ trow
)
static member GetForTypedRow :
        trow : Type -> Schema
static member GetForTypedRow :
        trow : Type -> Schema

Parameters

trow
Type: Online System Type

Return Value

Type: Schema
See Also
Schema Class
Schema Members
GetForTypedRow Overload
NFX.DataAccess.CRUD Namespace


Schema.GetForTypedRow Method (TypedRow)

Schema GetForTypedRow Method (TypedRow) NFX Class Library

Returns schema instance for the TypedRow instance by fetching schema object from cache or creating it if it has not been cached yet

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Schema GetForTypedRow(
    TypedRow row
)
public static Schema GetForTypedRow(
    TypedRow row
)
Public Shared Function GetForTypedRow (
    row As TypedRow
) As Schema
Public Shared Function GetForTypedRow (
    row As TypedRow
) As Schema
public:
static Schema^ GetForTypedRow(
    TypedRow^ row
)
public:
static Schema^ GetForTypedRow(
    TypedRow^ row
)
static member GetForTypedRow :
        row : TypedRow -> Schema
static member GetForTypedRow :
        row : TypedRow -> Schema

Parameters

row
Type: NFX.DataAccess.CRUD TypedRow

Return Value

Type: Schema
See Also
Schema Class
Schema Members
GetForTypedRow Overload
NFX.DataAccess.CRUD Namespace


Schema.GetKeyFieldDefsForTarget Method

Schema GetKeyFieldDefsForTarget Method NFX Class Library

Returns FieldDefs in their order within rows that are declared as key fields for particular target

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Schema..::..FieldDef> GetKeyFieldDefsForTarget(
    string targetName
)
public IEnumerable<Schema..::..FieldDef> GetKeyFieldDefsForTarget(
    string targetName
)
Public Function GetKeyFieldDefsForTarget (
    targetName As String
) As IEnumerable(Of Schema..::..FieldDef)
Public Function GetKeyFieldDefsForTarget (
    targetName As String
) As IEnumerable(Of Schema..::..FieldDef)
public:
IEnumerable<Schema..::..FieldDef^>^ GetKeyFieldDefsForTarget(
    String^ targetName
)
public:
IEnumerable<Schema..::..FieldDef^>^ GetKeyFieldDefsForTarget(
    String^ targetName
)
member GetKeyFieldDefsForTarget :
        targetName : string -> IEnumerable<Schema..::..FieldDef>
member GetKeyFieldDefsForTarget :
        targetName : string -> IEnumerable<Schema..::..FieldDef>

Parameters

targetName
Type: Online System String

Return Value

Type: Online IEnumerable Schema FieldDef
See Also
Schema Class
Schema Members
NFX.DataAccess.CRUD Namespace


Schema.GetTableAttrForTarget Method

Schema GetTableAttrForTarget Method NFX Class Library

Returns a TableAttribute that matches the supplied targetName, or if one was not defined then returns TableAttribute which matches any target or null

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TableAttribute GetTableAttrForTarget(
    string targetName
)
public TableAttribute GetTableAttrForTarget(
    string targetName
)
Public Function GetTableAttrForTarget (
    targetName As String
) As TableAttribute
Public Function GetTableAttrForTarget (
    targetName As String
) As TableAttribute
public:
TableAttribute^ GetTableAttrForTarget(
    String^ targetName
)
public:
TableAttribute^ GetTableAttrForTarget(
    String^ targetName
)
member GetTableAttrForTarget :
        targetName : string -> TableAttribute
member GetTableAttrForTarget :
        targetName : string -> TableAttribute

Parameters

targetName
Type: Online System String

Return Value

Type: TableAttribute
See Also
Schema Class
Schema Members
NFX.DataAccess.CRUD Namespace


Schema.IsEquivalentTo Method

Schema IsEquivalentTo Method NFX Class Library

Performs logical equivalence testing of two schemas

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEquivalentTo(
    Schema other,
    bool compareNames = true
)
public bool IsEquivalentTo(
    Schema other,
    bool compareNames = true
)
Public Function IsEquivalentTo (
    other As Schema,
    Optional compareNames As Boolean = true
) As Boolean
Public Function IsEquivalentTo (
    other As Schema,
    Optional compareNames As Boolean = true
) As Boolean
public:
bool IsEquivalentTo(
    Schema^ other,
    bool compareNames = true
)
public:
bool IsEquivalentTo(
    Schema^ other,
    bool compareNames = true
)
member IsEquivalentTo :
        other : Schema *
        ?compareNames : bool
(* Defaults:
        let _compareNames = defaultArg compareNames true
*)
-> bool
member IsEquivalentTo :
        other : Schema *
        ?compareNames : bool
(* Defaults:
        let _compareNames = defaultArg compareNames true
*)
-> bool

Parameters

other
Type: NFX.DataAccess.CRUD Schema
compareNames (Optional)
Type: Online System Boolean

Return Value

Type: Online Boolean
See Also
Schema Class
Schema Members
NFX.DataAccess.CRUD Namespace


Schema.ToString Method

Schema ToString Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
Schema Class
Schema Members
NFX.DataAccess.CRUD Namespace


Schema.WriteAsJSON Method

Schema WriteAsJSON Method NFX Class Library

Writes schema as JSON. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
nestingLevel
Type: Online System Int32
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Implements

IJSONWritable WriteAsJSON(TextWriter, Int32, JSONWritingOptions)
See Also
Schema Class
Schema Members
NFX.DataAccess.CRUD Namespace


Schema Properties

Schema Properties NFX Class Library

The Schema type exposes the following members.
Properties
 | Name | Description
Public property | AnyTargetKeyFieldDefs | Returns FieldDefs in their order within rows that are declared as key fields in ANY_TARGET
Public property | AnyVisibleFieldDefs | Returns FieldDefs in their order within rows as
Public property | ExtraData | Returns Extra data that may be associated with schema by various providers. The field is lazily allocated
Public property | FieldCount | Returns field count
Public property | FieldDefs | Returns FieldDefs in their order within rows that this schema describes
Public property | Item Int32 | Returns a field definition by a positional index within the row
Public property | Item String | Returns a field definition by a unique case-insensitive field name within schema
Public property | Name | For TypedRows, returns a unique fully-qualified row type name, whichs is the global identifier of this schema instance
Public property | ReadOnly | Specifies that target that this schema represents (i.e. db table) is not updatable so DataStore will not be able to save row changes made in ram
 | SchemaEquivalenceEqualityComparer | Returns an instance of IEqualityComparer(Schema) that performs logical equivalence testing
Public property | TableAttrs | Returns table-level attributes
Public property | TypedRowType | Returns a type of TypedRow if schema was created for TypedRow, or null
Back to Top
See Also
Schema Class
NFX.DataAccess.CRUD Namespace


Schema.AnyTargetKeyFieldDefs Property

Schema AnyTargetKeyFieldDefs Property NFX Class Library

Returns FieldDefs in their order within rows that are declared as key fields in ANY_TARGET

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Schema..::..FieldDef> AnyTargetKeyFieldDefs { get; }
public IEnumerable<Schema..::..FieldDef> AnyTargetKeyFieldDefs { get; }
Public ReadOnly Property AnyTargetKeyFieldDefs As IEnumerable(Of Schema..::..FieldDef)
    Get
Public ReadOnly Property AnyTargetKeyFieldDefs As IEnumerable(Of Schema..::..FieldDef)
    Get
public:
property IEnumerable<Schema..::..FieldDef^>^ AnyTargetKeyFieldDefs {
    IEnumerable<Schema..::..FieldDef^>^ get ();
}
public:
property IEnumerable<Schema..::..FieldDef^>^ AnyTargetKeyFieldDefs {
    IEnumerable<Schema..::..FieldDef^>^ get ();
}
member AnyTargetKeyFieldDefs : IEnumerable<Schema..::..FieldDef> with get
member AnyTargetKeyFieldDefs : IEnumerable<Schema..::..FieldDef> with get

Property Value

Type: Online IEnumerable Schema FieldDef
See Also
Schema Class
Schema Members
NFX.DataAccess.CRUD Namespace


Schema.AnyVisibleFieldDefs Property

Schema AnyVisibleFieldDefs Property NFX Class Library

Returns FieldDefs in their order within rows as

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Schema..::..FieldDef> AnyVisibleFieldDefs { get; }
public IEnumerable<Schema..::..FieldDef> AnyVisibleFieldDefs { get; }
Public ReadOnly Property AnyVisibleFieldDefs As IEnumerable(Of Schema..::..FieldDef)
    Get
Public ReadOnly Property AnyVisibleFieldDefs As IEnumerable(Of Schema..::..FieldDef)
    Get
public:
property IEnumerable<Schema..::..FieldDef^>^ AnyVisibleFieldDefs {
    IEnumerable<Schema..::..FieldDef^>^ get ();
}
public:
property IEnumerable<Schema..::..FieldDef^>^ AnyVisibleFieldDefs {
    IEnumerable<Schema..::..FieldDef^>^ get ();
}
member AnyVisibleFieldDefs : IEnumerable<Schema..::..FieldDef> with get
member AnyVisibleFieldDefs : IEnumerable<Schema..::..FieldDef> with get

Property Value

Type: Online IEnumerable Schema FieldDef
See Also
Schema Class
Schema Members
NFX.DataAccess.CRUD Namespace


Schema.ExtraData Property

Schema ExtraData Property NFX Class Library

Returns Extra data that may be associated with schema by various providers. The field is lazily allocated

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDataMap ExtraData { get; }
public JSONDataMap ExtraData { get; }
Public ReadOnly Property ExtraData As JSONDataMap
    Get
Public ReadOnly Property ExtraData As JSONDataMap
    Get
public:
property JSONDataMap^ ExtraData {
    JSONDataMap^ get ();
}
public:
property JSONDataMap^ ExtraData {
    JSONDataMap^ get ();
}
member ExtraData : JSONDataMap with get
member ExtraData : JSONDataMap with get

Property Value

Type: JSONDataMap
See Also
Schema Class
Schema Members
NFX.DataAccess.CRUD Namespace


Schema.FieldCount Property

Schema FieldCount Property NFX Class Library

Returns field count

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int FieldCount { get; }
public int FieldCount { get; }
Public ReadOnly Property FieldCount As Integer
    Get
Public ReadOnly Property FieldCount As Integer
    Get
public:
property int FieldCount {
    int get ();
}
public:
property int FieldCount {
    int get ();
}
member FieldCount : int with get
member FieldCount : int with get

Property Value

Type: Online Int32
See Also
Schema Class
Schema Members
NFX.DataAccess.CRUD Namespace


Schema.FieldDefs Property

Schema FieldDefs Property NFX Class Library

Returns FieldDefs in their order within rows that this schema describes

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Schema..::..FieldDef> FieldDefs { get; }
public IEnumerable<Schema..::..FieldDef> FieldDefs { get; }
Public ReadOnly Property FieldDefs As IEnumerable(Of Schema..::..FieldDef)
    Get
Public ReadOnly Property FieldDefs As IEnumerable(Of Schema..::..FieldDef)
    Get
public:
property IEnumerable<Schema..::..FieldDef^>^ FieldDefs {
    IEnumerable<Schema..::..FieldDef^>^ get ();
}
public:
property IEnumerable<Schema..::..FieldDef^>^ FieldDefs {
    IEnumerable<Schema..::..FieldDef^>^ get ();
}
member FieldDefs : IEnumerable<Schema..::..FieldDef> with get
member FieldDefs : IEnumerable<Schema..::..FieldDef> with get

Property Value

Type: Online IEnumerable Schema FieldDef
See Also
Schema Class
Schema Members
NFX.DataAccess.CRUD Namespace


Schema.Item Property

Schema Item Property NFX Class Library

Overload List
 | Name | Description
Public property | Item Int32 | Returns a field definition by a positional index within the row
Public property | Item String | Returns a field definition by a unique case-insensitive field name within schema
Back to Top
See Also
Schema Class
Schema Members
NFX.DataAccess.CRUD Namespace


Schema.Item Property (Int32)

Schema Item Property (Int32) NFX Class Library

Returns a field definition by a positional index within the row

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Schema..::..FieldDef this[
    int index
] { get; }
public Schema..::..FieldDef this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Schema..::..FieldDef
    Get
Public ReadOnly Default Property Item (
    index As Integer
) As Schema..::..FieldDef
    Get
public:
property Schema..::..FieldDef^ default[int index] {
    Schema..::..FieldDef^ get (int index);
}
public:
property Schema..::..FieldDef^ default[int index] {
    Schema..::..FieldDef^ get (int index);
}
member Item : Schema..::..FieldDef with get
member Item : Schema..::..FieldDef with get

Parameters

index
Type: Online System Int32

Property Value

Type: Schema FieldDef
See Also
Schema Class
Schema Members
Item Overload
NFX.DataAccess.CRUD Namespace


Schema.Item Property (String)

Schema Item Property (String) NFX Class Library

Returns a field definition by a unique case-insensitive field name within schema

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Schema..::..FieldDef this[
    string name
] { get; }
public Schema..::..FieldDef this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As Schema..::..FieldDef
    Get
Public ReadOnly Default Property Item (
    name As String
) As Schema..::..FieldDef
    Get
public:
property Schema..::..FieldDef^ default[String^ name] {
    Schema..::..FieldDef^ get (String^ name);
}
public:
property Schema..::..FieldDef^ default[String^ name] {
    Schema..::..FieldDef^ get (String^ name);
}
member Item : Schema..::..FieldDef with get
member Item : Schema..::..FieldDef with get

Parameters

name
Type: Online System String

Property Value

Type: Schema FieldDef
See Also
Schema Class
Schema Members
Item Overload
NFX.DataAccess.CRUD Namespace


Schema.Name Property

Schema Name Property NFX Class Library

For TypedRows, returns a unique fully-qualified row type name, whichs is the global identifier of this schema instance

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
Schema Class
Schema Members
NFX.DataAccess.CRUD Namespace


Schema.ReadOnly Property

Schema ReadOnly Property NFX Class Library

Specifies that target that this schema represents (i.e. db table) is not updatable so DataStore will not be able to save row changes made in ram

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ReadOnly { get; }
public bool ReadOnly { get; }
Public ReadOnly Property ReadOnly As Boolean
    Get
Public ReadOnly Property ReadOnly As Boolean
    Get
public:
property bool ReadOnly {
    bool get ();
}
public:
property bool ReadOnly {
    bool get ();
}
member ReadOnly : bool with get
member ReadOnly : bool with get

Property Value

Type: Online Boolean
See Also
Schema Class
Schema Members
NFX.DataAccess.CRUD Namespace


Schema.SchemaEquivalenceEqualityComparer Property

Schema SchemaEquivalenceEqualityComparer Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns an instance of IEqualityComparer(Schema) that performs logical equivalence testing

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEqualityComparer<Schema> SchemaEquivalenceEqualityComparer { get; }
public static IEqualityComparer<Schema> SchemaEquivalenceEqualityComparer { get; }
Public Shared ReadOnly Property SchemaEquivalenceEqualityComparer As IEqualityComparer(Of Schema)
    Get
Public Shared ReadOnly Property SchemaEquivalenceEqualityComparer As IEqualityComparer(Of Schema)
    Get
public:
static property IEqualityComparer<Schema^>^ SchemaEquivalenceEqualityComparer {
    IEqualityComparer<Schema^>^ get ();
}
public:
static property IEqualityComparer<Schema^>^ SchemaEquivalenceEqualityComparer {
    IEqualityComparer<Schema^>^ get ();
}
static member SchemaEquivalenceEqualityComparer : IEqualityComparer<Schema> with get
static member SchemaEquivalenceEqualityComparer : IEqualityComparer<Schema> with get

Property Value

Type: Online IEqualityComparer Schema
See Also
Schema Class
Schema Members
NFX.DataAccess.CRUD Namespace


Schema.TableAttrs Property

Schema TableAttrs Property NFX Class Library

Returns table-level attributes

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<TableAttribute> TableAttrs { get; }
public IEnumerable<TableAttribute> TableAttrs { get; }
Public ReadOnly Property TableAttrs As IEnumerable(Of TableAttribute)
    Get
Public ReadOnly Property TableAttrs As IEnumerable(Of TableAttribute)
    Get
public:
property IEnumerable<TableAttribute^>^ TableAttrs {
    IEnumerable<TableAttribute^>^ get ();
}
public:
property IEnumerable<TableAttribute^>^ TableAttrs {
    IEnumerable<TableAttribute^>^ get ();
}
member TableAttrs : IEnumerable<TableAttribute> with get
member TableAttrs : IEnumerable<TableAttribute> with get

Property Value

Type: Online IEnumerable TableAttribute
See Also
Schema Class
Schema Members
NFX.DataAccess.CRUD Namespace


Schema.TypedRowType Property

Schema TypedRowType Property NFX Class Library

Returns a type of TypedRow if schema was created for TypedRow, or null

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Type TypedRowType { get; }
public Type TypedRowType { get; }
Public ReadOnly Property TypedRowType As Type
    Get
Public ReadOnly Property TypedRowType As Type
    Get
public:
property Type^ TypedRowType {
    Type^ get ();
}
public:
property Type^ TypedRowType {
    Type^ get ();
}
member TypedRowType : Type with get
member TypedRowType : Type with get

Property Value

Type: Online Type
See Also
Schema Class
Schema Members
NFX.DataAccess.CRUD Namespace


Schema.FieldDef Class

Schema FieldDef Class NFX Class Library

Provides a definition for a single field of a row
Inheritance Hierarchy
Online System Object
NFX.DataAccess.CRUD Schema FieldDef

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class FieldDef : INamed,
    IOrdered, ISerializable, IJSONWritable
[SerializableAttribute]
public sealed class FieldDef : INamed,
    IOrdered, ISerializable, IJSONWritable
<SerializableAttribute>
Public NotInheritable Class FieldDef
    Implements INamed, IOrdered, ISerializable, IJSONWritable
<SerializableAttribute>
Public NotInheritable Class FieldDef
    Implements INamed, IOrdered, ISerializable, IJSONWritable
[SerializableAttribute]
public ref class FieldDef sealed : INamed,
    IOrdered, ISerializable, IJSONWritable
[SerializableAttribute]
public ref class FieldDef sealed : INamed,
    IOrdered, ISerializable, IJSONWritable
[<SealedAttribute>]
[<SerializableAttribute>]
type FieldDef =
    class
        interface INamed
        interface IOrdered
        interface ISerializable
        interface IJSONWritable
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type FieldDef =
    class
        interface INamed
        interface IOrdered
        interface ISerializable
        interface IJSONWritable
    end
See Also
Schema FieldDef Members
NFX.DataAccess.CRUD Namespace


Schema.FieldDef Members

Schema FieldDef Members NFX Class Library

The Schema FieldDef type exposes the following members.
Constructors
 | Name | Description
Protected method | Schema FieldDef(SerializationInfo, StreamingContext) | Initializes a new instance of the Schema FieldDef class
Public method | Schema FieldDef(String, Type, FieldAttribute) | Initializes a new instance of the Schema FieldDef class
Public method | Schema FieldDef(String, Type, QuerySource ColumnDef) | Initializes a new instance of the Schema FieldDef class
Public method | Schema FieldDef(String, Type, IEnumerable FieldAttribute ) | Initializes a new instance of the Schema FieldDef class
Protected method | Schema FieldDef(String, Int32, Type, IEnumerable FieldAttribute , PropertyInfo) | Initializes a new instance of the Schema FieldDef class
Back to Top
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetBackendNameForTarget(String) | Returns the name of the field in backend that was possibly overriden for a particular target
Public method | GetBackendNameForTarget(String, FieldAttribute ) | Returns the name of the field in backend that was possibly overriden for a particular target along with store flag
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | GetObjectData |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Public method | ValueDescription | For fields with ValueList returns value's description per specified schema
Public method | WriteAsJSON | Writes fielddef as JSON. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Order |
Back to Top
Properties
 | Name | Description
Public property | AnyTargetKey | Returns true when this field is attributed as being a key field in an attribute that targets ANY_TARGET
Public property | AnyVisible | Returns true when this field is attributed as being a visible in any of the targeted attribute
Public property | Attrs | Returns field attributes
Public property | Description | Returns description from field attribute or parses it from field name
Public property | Item | Returns a FieldAttribute that matches the supplied targetName, or if one was not defined then returns FieldAttribute which matches any target or null
Public property | MemberInfo | For TypedRow-descendants returns a PropertyInfo object for the underlying property
Public property | Name | Returns the name of the field
Public property | NonNullableType | For nullable value types returns the field type regardless of nullability, it is the type argument of Nullable struct; For reference types returns the same type as Type property
Public property | NonUI | Returns true when at least one attribute was marked as NonUI - meaning that this field must not be serialized-to/deserialized-from client UI
Public property | Order | Gets absolute field order index in a row
Public property | Type | Returns the field type
Back to Top
See Also
Schema FieldDef Class
NFX.DataAccess.CRUD Namespace


Schema.FieldDef Constructor

Schema FieldDef Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | Schema FieldDef(SerializationInfo, StreamingContext) | Initializes a new instance of the Schema FieldDef class
Public method | Schema FieldDef(String, Type, FieldAttribute) | Initializes a new instance of the Schema FieldDef class
Public method | Schema FieldDef(String, Type, QuerySource ColumnDef) | Initializes a new instance of the Schema FieldDef class
Public method | Schema FieldDef(String, Type, IEnumerable FieldAttribute ) | Initializes a new instance of the Schema FieldDef class
Protected method | Schema FieldDef(String, Int32, Type, IEnumerable FieldAttribute , PropertyInfo) | Initializes a new instance of the Schema FieldDef class
Back to Top
See Also
Schema FieldDef Class
Schema FieldDef Members
NFX.DataAccess.CRUD Namespace


Schema.FieldDef Constructor (SerializationInfo, StreamingContext)

Schema FieldDef Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Schema FieldDef class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal FieldDef(
    SerializationInfo info,
    StreamingContext context
)
internal FieldDef(
    SerializationInfo info,
    StreamingContext context
)
Friend Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Friend Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
internal:
FieldDef(
    SerializationInfo^ info,
    StreamingContext context
)
internal:
FieldDef(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FieldDef
new :
        info : SerializationInfo *
        context : StreamingContext -> FieldDef

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
Schema FieldDef Class
Schema FieldDef Members
Schema FieldDef Overload
NFX.DataAccess.CRUD Namespace


Schema.FieldDef Constructor (String, Type, FieldAttribute)

Schema FieldDef Constructor (String, Type, FieldAttribute) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Schema FieldDef class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldDef(
    string name,
    Type type,
    FieldAttribute attr
)
public FieldDef(
    string name,
    Type type,
    FieldAttribute attr
)
Public Sub New (
    name As String,
    type As Type,
    attr As FieldAttribute
)
Public Sub New (
    name As String,
    type As Type,
    attr As FieldAttribute
)
public:
FieldDef(
    String^ name,
    Type^ type,
    FieldAttribute^ attr
)
public:
FieldDef(
    String^ name,
    Type^ type,
    FieldAttribute^ attr
)
new :
        name : string *
        type : Type *
        attr : FieldAttribute -> FieldDef
new :
        name : string *
        type : Type *
        attr : FieldAttribute -> FieldDef

Parameters

name
Type: Online System String
type
Type: Online System Type
attr
Type: NFX.DataAccess.CRUD FieldAttribute
See Also
Schema FieldDef Class
Schema FieldDef Members
Schema FieldDef Overload
NFX.DataAccess.CRUD Namespace


Schema.FieldDef Constructor (String, Type, QuerySource.ColumnDef)

Schema FieldDef Constructor (String, Type, QuerySource ColumnDef) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Schema FieldDef class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldDef(
    string name,
    Type type,
    QuerySource..::..ColumnDef columnDef
)
public FieldDef(
    string name,
    Type type,
    QuerySource..::..ColumnDef columnDef
)
Public Sub New (
    name As String,
    type As Type,
    columnDef As QuerySource..::..ColumnDef
)
Public Sub New (
    name As String,
    type As Type,
    columnDef As QuerySource..::..ColumnDef
)
public:
FieldDef(
    String^ name,
    Type^ type,
    QuerySource..::..ColumnDef^ columnDef
)
public:
FieldDef(
    String^ name,
    Type^ type,
    QuerySource..::..ColumnDef^ columnDef
)
new :
        name : string *
        type : Type *
        columnDef : QuerySource..::..ColumnDef -> FieldDef
new :
        name : string *
        type : Type *
        columnDef : QuerySource..::..ColumnDef -> FieldDef

Parameters

name
Type: Online System String
type
Type: Online System Type
columnDef
Type: NFX.DataAccess.CRUD QuerySource ColumnDef
See Also
Schema FieldDef Class
Schema FieldDef Members
Schema FieldDef Overload
NFX.DataAccess.CRUD Namespace


Schema.FieldDef Constructor (String, Type, IEnumerable(FieldAttribute))

Schema FieldDef Constructor (String, Type, IEnumerable FieldAttribute ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Schema FieldDef class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldDef(
    string name,
    Type type,
    IEnumerable<FieldAttribute> attrs
)
public FieldDef(
    string name,
    Type type,
    IEnumerable<FieldAttribute> attrs
)
Public Sub New (
    name As String,
    type As Type,
    attrs As IEnumerable(Of FieldAttribute)
)
Public Sub New (
    name As String,
    type As Type,
    attrs As IEnumerable(Of FieldAttribute)
)
public:
FieldDef(
    String^ name,
    Type^ type,
    IEnumerable<FieldAttribute^>^ attrs
)
public:
FieldDef(
    String^ name,
    Type^ type,
    IEnumerable<FieldAttribute^>^ attrs
)
new :
        name : string *
        type : Type *
        attrs : IEnumerable<FieldAttribute> -> FieldDef
new :
        name : string *
        type : Type *
        attrs : IEnumerable<FieldAttribute> -> FieldDef

Parameters

name
Type: Online System String
type
Type: Online System Type
attrs
Type: Online System.Collections.Generic IEnumerable FieldAttribute
See Also
Schema FieldDef Class
Schema FieldDef Members
Schema FieldDef Overload
NFX.DataAccess.CRUD Namespace


Schema.FieldDef Constructor (String, Int32, Type, IEnumerable(FieldAttribute), PropertyInfo)

Schema FieldDef Constructor (String, Int32, Type, IEnumerable FieldAttribute , PropertyInfo) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Schema FieldDef class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal FieldDef(
    string name,
    int order,
    Type type,
    IEnumerable<FieldAttribute> attrs,
    PropertyInfo memberInfo = null
)
internal FieldDef(
    string name,
    int order,
    Type type,
    IEnumerable<FieldAttribute> attrs,
    PropertyInfo memberInfo = null
)
Friend Sub New (
    name As String,
    order As Integer,
    type As Type,
    attrs As IEnumerable(Of FieldAttribute),
    Optional memberInfo As PropertyInfo = Nothing
)
Friend Sub New (
    name As String,
    order As Integer,
    type As Type,
    attrs As IEnumerable(Of FieldAttribute),
    Optional memberInfo As PropertyInfo = Nothing
)
internal:
FieldDef(
    String^ name,
    int order,
    Type^ type,
    IEnumerable<FieldAttribute^>^ attrs,
    PropertyInfo^ memberInfo = nullptr
)
internal:
FieldDef(
    String^ name,
    int order,
    Type^ type,
    IEnumerable<FieldAttribute^>^ attrs,
    PropertyInfo^ memberInfo = nullptr
)
new :
        name : string *
        order : int *
        type : Type *
        attrs : IEnumerable<FieldAttribute> *
        ?memberInfo : PropertyInfo
(* Defaults:
        let _memberInfo = defaultArg memberInfo null
*)
-> FieldDef
new :
        name : string *
        order : int *
        type : Type *
        attrs : IEnumerable<FieldAttribute> *
        ?memberInfo : PropertyInfo
(* Defaults:
        let _memberInfo = defaultArg memberInfo null
*)
-> FieldDef

Parameters

name
Type: Online System String
order
Type: Online System Int32
type
Type: Online System Type
attrs
Type: Online System.Collections.Generic IEnumerable FieldAttribute
memberInfo (Optional)
Type: Online System.Reflection PropertyInfo
See Also
Schema FieldDef Class
Schema FieldDef Members
Schema FieldDef Overload
NFX.DataAccess.CRUD Namespace


Schema.FieldDef Fields

Schema FieldDef Fields NFX Class Library

The Schema FieldDef type exposes the following members.
Fields
 | Name | Description
Protected field | m_Order |
Back to Top
See Also
Schema FieldDef Class
NFX.DataAccess.CRUD Namespace


Schema.FieldDef.m_Order Field

Schema FieldDef m_Order Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int m_Order
internal int m_Order
Friend m_Order As Integer
Friend m_Order As Integer
internal:
int m_Order
internal:
int m_Order
val mutable internal m_Order: int
val mutable internal m_Order: int

Field Value

Type: Online Int32
See Also
Schema FieldDef Class
Schema FieldDef Members
NFX.DataAccess.CRUD Namespace


Schema.FieldDef Methods

Schema FieldDef Methods NFX Class Library

The Schema FieldDef type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetBackendNameForTarget(String) | Returns the name of the field in backend that was possibly overriden for a particular target
Public method | GetBackendNameForTarget(String, FieldAttribute ) | Returns the name of the field in backend that was possibly overriden for a particular target along with store flag
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | GetObjectData |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Public method | ValueDescription | For fields with ValueList returns value's description per specified schema
Public method | WriteAsJSON | Writes fielddef as JSON. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Schema FieldDef Class
NFX.DataAccess.CRUD Namespace


Schema.FieldDef.Equals Method

Schema FieldDef Equals Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
Schema FieldDef Class
Schema FieldDef Members
NFX.DataAccess.CRUD Namespace


Schema.FieldDef.GetBackendNameForTarget Method

Schema FieldDef GetBackendNameForTarget Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public method | GetBackendNameForTarget(String) | Returns the name of the field in backend that was possibly overriden for a particular target
Public method | GetBackendNameForTarget(String, FieldAttribute ) | Returns the name of the field in backend that was possibly overriden for a particular target along with store flag
Back to Top
See Also
Schema FieldDef Class
Schema FieldDef Members
NFX.DataAccess.CRUD Namespace


Schema.FieldDef.GetBackendNameForTarget Method (String)

Schema FieldDef GetBackendNameForTarget Method (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns the name of the field in backend that was possibly overriden for a particular target

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetBackendNameForTarget(
    string targetName
)
public string GetBackendNameForTarget(
    string targetName
)
Public Function GetBackendNameForTarget (
    targetName As String
) As String
Public Function GetBackendNameForTarget (
    targetName As String
) As String
public:
String^ GetBackendNameForTarget(
    String^ targetName
)
public:
String^ GetBackendNameForTarget(
    String^ targetName
)
member GetBackendNameForTarget :
        targetName : string -> string
member GetBackendNameForTarget :
        targetName : string -> string

Parameters

targetName
Type: Online System String

Return Value

Type: Online String
See Also
Schema FieldDef Class
Schema FieldDef Members
GetBackendNameForTarget Overload
NFX.DataAccess.CRUD Namespace


Schema.FieldDef.GetBackendNameForTarget Method (String, FieldAttribute)

Schema FieldDef GetBackendNameForTarget Method (String, FieldAttribute ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns the name of the field in backend that was possibly overriden for a particular target along with store flag

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetBackendNameForTarget(
    string targetName,
    out FieldAttribute attr
)
public string GetBackendNameForTarget(
    string targetName,
    out FieldAttribute attr
)
Public Function GetBackendNameForTarget (
    targetName As String,
    <OutAttribute> ByRef attr As FieldAttribute
) As String
Public Function GetBackendNameForTarget (
    targetName As String,
    <OutAttribute> ByRef attr As FieldAttribute
) As String
public:
String^ GetBackendNameForTarget(
    String^ targetName,
    [OutAttribute] FieldAttribute^% attr
)
public:
String^ GetBackendNameForTarget(
    String^ targetName,
    [OutAttribute] FieldAttribute^% attr
)
member GetBackendNameForTarget :
        targetName : string *
        attr : FieldAttribute byref -> string
member GetBackendNameForTarget :
        targetName : string *
        attr : FieldAttribute byref -> string

Parameters

targetName
Type: Online System String
attr
Type: NFX.DataAccess.CRUD FieldAttribute

Return Value

Type: Online String
See Also
Schema FieldDef Class
Schema FieldDef Members
GetBackendNameForTarget Overload
NFX.DataAccess.CRUD Namespace


Schema.FieldDef.GetHashCode Method

Schema FieldDef GetHashCode Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
Schema FieldDef Class
Schema FieldDef Members
NFX.DataAccess.CRUD Namespace


Schema.FieldDef.GetObjectData Method

Schema FieldDef GetObjectData Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext

Implements

Online ISerializable GetObjectData(SerializationInfo, StreamingContext)
See Also
Schema FieldDef Class
Schema FieldDef Members
NFX.DataAccess.CRUD Namespace


Schema.FieldDef.ToString Method

Schema FieldDef ToString Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
Schema FieldDef Class
Schema FieldDef Members
NFX.DataAccess.CRUD Namespace


Schema.FieldDef.ValueDescription Method

Schema FieldDef ValueDescription Method NFX Class Library

For fields with ValueList returns value's description per specified schema

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ValueDescription(
    Object fieldValue,
    string target = null,
    bool caseSensitiveKeys = false
)
public string ValueDescription(
    Object fieldValue,
    string target = null,
    bool caseSensitiveKeys = false
)
Public Function ValueDescription (
    fieldValue As Object,
    Optional target As String = Nothing,
    Optional caseSensitiveKeys As Boolean = false
) As String
Public Function ValueDescription (
    fieldValue As Object,
    Optional target As String = Nothing,
    Optional caseSensitiveKeys As Boolean = false
) As String
public:
String^ ValueDescription(
    Object^ fieldValue,
    String^ target = nullptr,
    bool caseSensitiveKeys = false
)
public:
String^ ValueDescription(
    Object^ fieldValue,
    String^ target = nullptr,
    bool caseSensitiveKeys = false
)
member ValueDescription :
        fieldValue : Object *
        ?target : string *
        ?caseSensitiveKeys : bool
(* Defaults:
        let _target = defaultArg target null
        let _caseSensitiveKeys = defaultArg caseSensitiveKeys false
*)
-> string
member ValueDescription :
        fieldValue : Object *
        ?target : string *
        ?caseSensitiveKeys : bool
(* Defaults:
        let _target = defaultArg target null
        let _caseSensitiveKeys = defaultArg caseSensitiveKeys false
*)
-> string

Parameters

fieldValue
Type: Online System Object
target (Optional)
Type: Online System String
caseSensitiveKeys (Optional)
Type: Online System Boolean

Return Value

Type: Online String
See Also
Schema FieldDef Class
Schema FieldDef Members
NFX.DataAccess.CRUD Namespace


Schema.FieldDef.WriteAsJSON Method

Schema FieldDef WriteAsJSON Method NFX Class Library

Writes fielddef as JSON. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
nestingLevel
Type: Online System Int32
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Implements

IJSONWritable WriteAsJSON(TextWriter, Int32, JSONWritingOptions)
See Also
Schema FieldDef Class
Schema FieldDef Members
NFX.DataAccess.CRUD Namespace


Schema.FieldDef Properties

Schema FieldDef Properties NFX Class Library

The Schema FieldDef type exposes the following members.
Properties
 | Name | Description
Public property | AnyTargetKey | Returns true when this field is attributed as being a key field in an attribute that targets ANY_TARGET
Public property | AnyVisible | Returns true when this field is attributed as being a visible in any of the targeted attribute
Public property | Attrs | Returns field attributes
Public property | Description | Returns description from field attribute or parses it from field name
Public property | Item | Returns a FieldAttribute that matches the supplied targetName, or if one was not defined then returns FieldAttribute which matches any target or null
Public property | MemberInfo | For TypedRow-descendants returns a PropertyInfo object for the underlying property
Public property | Name | Returns the name of the field
Public property | NonNullableType | For nullable value types returns the field type regardless of nullability, it is the type argument of Nullable struct; For reference types returns the same type as Type property
Public property | NonUI | Returns true when at least one attribute was marked as NonUI - meaning that this field must not be serialized-to/deserialized-from client UI
Public property | Order | Gets absolute field order index in a row
Public property | Type | Returns the field type
Back to Top
See Also
Schema FieldDef Class
NFX.DataAccess.CRUD Namespace


Schema.FieldDef.AnyTargetKey Property

Schema FieldDef AnyTargetKey Property NFX Class Library

Returns true when this field is attributed as being a key field in an attribute that targets ANY_TARGET

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool AnyTargetKey { get; }
public bool AnyTargetKey { get; }
Public ReadOnly Property AnyTargetKey As Boolean
    Get
Public ReadOnly Property AnyTargetKey As Boolean
    Get
public:
property bool AnyTargetKey {
    bool get ();
}
public:
property bool AnyTargetKey {
    bool get ();
}
member AnyTargetKey : bool with get
member AnyTargetKey : bool with get

Property Value

Type: Online Boolean
See Also
Schema FieldDef Class
Schema FieldDef Members
NFX.DataAccess.CRUD Namespace


Schema.FieldDef.AnyVisible Property

Schema FieldDef AnyVisible Property NFX Class Library

Returns true when this field is attributed as being a visible in any of the targeted attribute

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool AnyVisible { get; }
public bool AnyVisible { get; }
Public ReadOnly Property AnyVisible As Boolean
    Get
Public ReadOnly Property AnyVisible As Boolean
    Get
public:
property bool AnyVisible {
    bool get ();
}
public:
property bool AnyVisible {
    bool get ();
}
member AnyVisible : bool with get
member AnyVisible : bool with get

Property Value

Type: Online Boolean
See Also
Schema FieldDef Class
Schema FieldDef Members
NFX.DataAccess.CRUD Namespace


Schema.FieldDef.Attrs Property

Schema FieldDef Attrs Property NFX Class Library

Returns field attributes

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<FieldAttribute> Attrs { get; }
public IEnumerable<FieldAttribute> Attrs { get; }
Public ReadOnly Property Attrs As IEnumerable(Of FieldAttribute)
    Get
Public ReadOnly Property Attrs As IEnumerable(Of FieldAttribute)
    Get
public:
property IEnumerable<FieldAttribute^>^ Attrs {
    IEnumerable<FieldAttribute^>^ get ();
}
public:
property IEnumerable<FieldAttribute^>^ Attrs {
    IEnumerable<FieldAttribute^>^ get ();
}
member Attrs : IEnumerable<FieldAttribute> with get
member Attrs : IEnumerable<FieldAttribute> with get

Property Value

Type: Online IEnumerable FieldAttribute
See Also
Schema FieldDef Class
Schema FieldDef Members
NFX.DataAccess.CRUD Namespace


Schema.FieldDef.Description Property

Schema FieldDef Description Property NFX Class Library

Returns description from field attribute or parses it from field name

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Description { get; }
public string Description { get; }
Public ReadOnly Property Description As String
    Get
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
public:
property String^ Description {
    String^ get ();
}
member Description : string with get
member Description : string with get

Property Value

Type: Online String
See Also
Schema FieldDef Class
Schema FieldDef Members
NFX.DataAccess.CRUD Namespace


Schema.FieldDef.Item Property

Schema FieldDef Item Property NFX Class Library

Returns a FieldAttribute that matches the supplied targetName, or if one was not defined then returns FieldAttribute which matches any target or null

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FieldAttribute this[
    string targetName
] { get; }
public FieldAttribute this[
    string targetName
] { get; }
Public ReadOnly Default Property Item (
    targetName As String
) As FieldAttribute
    Get
Public ReadOnly Default Property Item (
    targetName As String
) As FieldAttribute
    Get
public:
property FieldAttribute^ default[String^ targetName] {
    FieldAttribute^ get (String^ targetName);
}
public:
property FieldAttribute^ default[String^ targetName] {
    FieldAttribute^ get (String^ targetName);
}
member Item : FieldAttribute with get
member Item : FieldAttribute with get

Parameters

targetName
Type: Online System String

Property Value

Type: FieldAttribute
See Also
Schema FieldDef Class
Schema FieldDef Members
NFX.DataAccess.CRUD Namespace


Schema.FieldDef.MemberInfo Property

Schema FieldDef MemberInfo Property NFX Class Library

For TypedRow-descendants returns a PropertyInfo object for the underlying property

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PropertyInfo MemberInfo { get; }
public PropertyInfo MemberInfo { get; }
Public ReadOnly Property MemberInfo As PropertyInfo
    Get
Public ReadOnly Property MemberInfo As PropertyInfo
    Get
public:
property PropertyInfo^ MemberInfo {
    PropertyInfo^ get ();
}
public:
property PropertyInfo^ MemberInfo {
    PropertyInfo^ get ();
}
member MemberInfo : PropertyInfo with get
member MemberInfo : PropertyInfo with get

Property Value

Type: Online PropertyInfo
See Also
Schema FieldDef Class
Schema FieldDef Members
NFX.DataAccess.CRUD Namespace


Schema.FieldDef.Name Property

Schema FieldDef Name Property NFX Class Library

Returns the name of the field

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
Schema FieldDef Class
Schema FieldDef Members
NFX.DataAccess.CRUD Namespace


Schema.FieldDef.NonNullableType Property

Schema FieldDef NonNullableType Property NFX Class Library

For nullable value types returns the field type regardless of nullability, it is the type argument of Nullable struct; For reference types returns the same type as Type property

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Type NonNullableType { get; }
public Type NonNullableType { get; }
Public ReadOnly Property NonNullableType As Type
    Get
Public ReadOnly Property NonNullableType As Type
    Get
public:
property Type^ NonNullableType {
    Type^ get ();
}
public:
property Type^ NonNullableType {
    Type^ get ();
}
member NonNullableType : Type with get
member NonNullableType : Type with get

Property Value

Type: Online Type
See Also
Schema FieldDef Class
Schema FieldDef Members
NFX.DataAccess.CRUD Namespace


Schema.FieldDef.NonUI Property

Schema FieldDef NonUI Property NFX Class Library

Returns true when at least one attribute was marked as NonUI - meaning that this field must not be serialized-to/deserialized-from client UI

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool NonUI { get; }
public bool NonUI { get; }
Public ReadOnly Property NonUI As Boolean
    Get
Public ReadOnly Property NonUI As Boolean
    Get
public:
property bool NonUI {
    bool get ();
}
public:
property bool NonUI {
    bool get ();
}
member NonUI : bool with get
member NonUI : bool with get

Property Value

Type: Online Boolean
See Also
Schema FieldDef Class
Schema FieldDef Members
NFX.DataAccess.CRUD Namespace


Schema.FieldDef.Order Property

Schema FieldDef Order Property NFX Class Library

Gets absolute field order index in a row

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Order { get; }
public int Order { get; }
Public ReadOnly Property Order As Integer
    Get
Public ReadOnly Property Order As Integer
    Get
public:
virtual property int Order {
    int get () sealed;
}
public:
virtual property int Order {
    int get () sealed;
}
abstract Order : int with get
override Order : int with get
abstract Order : int with get
override Order : int with get

Property Value

Type: Online Int32

Implements

IOrdered Order
See Also
Schema FieldDef Class
Schema FieldDef Members
NFX.DataAccess.CRUD Namespace


Schema.FieldDef.Type Property

Schema FieldDef Type Property NFX Class Library

Returns the field type

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Type Type { get; }
public Type Type { get; }
Public ReadOnly Property Type As Type
    Get
Public ReadOnly Property Type As Type
    Get
public:
property Type^ Type {
    Type^ get ();
}
public:
property Type^ Type {
    Type^ get ();
}
member Type : Type with get
member Type : Type with get

Property Value

Type: Online Type
See Also
Schema FieldDef Class
Schema FieldDef Members
NFX.DataAccess.CRUD Namespace


SetFieldFunc Delegate

SetFieldFunc Delegate NFX Class Library

Injects function that tries to set field value. May elect to skip the set and return false to indicate failure(instead of throwing exception)

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate bool SetFieldFunc(
    Row row,
    Schema..::..FieldDef fdef,
    Object val
)
public delegate bool SetFieldFunc(
    Row row,
    Schema..::..FieldDef fdef,
    Object val
)
Public Delegate Function SetFieldFunc (
    row As Row,
    fdef As Schema..::..FieldDef,
    val As Object
) As Boolean
Public Delegate Function SetFieldFunc (
    row As Row,
    fdef As Schema..::..FieldDef,
    val As Object
) As Boolean
public delegate bool SetFieldFunc(
    Row^ row,
    Schema..::..FieldDef^ fdef,
    Object^ val
)
public delegate bool SetFieldFunc(
    Row^ row,
    Schema..::..FieldDef^ fdef,
    Object^ val
)
type SetFieldFunc =
    delegate of
        row : Row *
        fdef : Schema..::..FieldDef *
        val : Object -> bool
type SetFieldFunc =
    delegate of
        row : Row *
        fdef : Schema..::..FieldDef *
        val : Object -> bool

Parameters

row
Type: NFX.DataAccess.CRUD Row
fdef
Type: NFX.DataAccess.CRUD Schema FieldDef
val
Type: Online System Object

Return Value

Type: Online Boolean
See Also
NFX.DataAccess.CRUD Namespace


Table Class

Table Class NFX Class Library

Implements a master table. Tables are rowsets that are pre-sorted by keys. They are used in scenarios when in-memory data replication is needed. A table supports efficient FindKey() operation but does not support sorting. This class is not thread-safe.
Inheritance Hierarchy
Online System Object
NFX.DataAccess.CRUD RowsetBase
NFX.DataAccess.CRUD Table

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class Table : RowsetBase
[SerializableAttribute]
public class Table : RowsetBase
<SerializableAttribute>
Public Class Table
    Inherits RowsetBase
<SerializableAttribute>
Public Class Table
    Inherits RowsetBase
[SerializableAttribute]
public ref class Table : public RowsetBase
[SerializableAttribute]
public ref class Table : public RowsetBase
[<SerializableAttribute>]
type Table =
    class
        inherit RowsetBase
    end
[<SerializableAttribute>]
type Table =
    class
        inherit RowsetBase
    end
See Also
Table Members
NFX.DataAccess.CRUD Namespace


Table Members

Table Members NFX Class Library

The Table type exposes the following members.
Constructors
 | Name | Description
Public method | Table(Schema) | Creates an empty table
Public method | Table(Rowset, Func Row, Boolean ) | Creates a shallow copy from another rowset resorting data per schema key definition, optionally applying a filter
Public method | Table(Table, Func Row, Boolean ) | Creates a shallow copy from another table, optionally applying a filter
Back to Top
Methods
 | Name | Description
Public method | Add | Inserts a row (Inherited from RowsetBase.)
Protected method | Check | Checks argument for being non-null and of the same schema with this rowset (Inherited from RowsetBase.)
Public method | Clear | Purges table (Inherited from RowsetBase.)
Public method | Compare | Compares two rows based on their key fields. Always compares in ascending direction (Overrides RowsetBase Compare(Row, Row).)
 | CompareRows | Compares two rows based on their key fields. Always compares in ascending direction
Public method | Contains | (Inherited from RowsetBase.)
Public method | CopyTo | (Inherited from RowsetBase.)
Public method | Delete( Object ) | Tries to find a row with the same set of key fields in this table and if found, deletes it and returns its index, otherwise -1 (Inherited from RowsetBase.)
Public method | Delete(Row, IDataStoreKey) | Tries to find a row with the same set of key fields in this table and if found, deletes it and returns its index, otherwise -1 (Inherited from RowsetBase.)
Public method | DeleteAll | Deletes all rows from table. This method is similar to Purge() but does logging (when enabled) (Inherited from RowsetBase.)
Protected method | DoDelete | Tries to find a row with the same set of key fields in this table and if found, deletes it and returns its index, otherwise -1 (Inherited from RowsetBase.)
Protected method | DoInsert | Tries to insert a row. If another row with the same set of key fields already in the table returns -1, otherwise returns insertion index (Inherited from RowsetBase.)
Protected method | DoUpdate | Tries to find a row with the same set of key fields in this table and if found, replaces it and returns its index, otherwise returns -1 (Inherited from RowsetBase.)
Protected method | DoUpsert | Tries to find a row with the same set of key fields in this table and if found, replaces it and returns true, otherwise inserts the row (if schemas match) and returns false. Optionally pass updateWhere condition that may check whether update needs to be performed (Inherited from RowsetBase.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FindByKey( Object ) | Tries to find a row by specified keyset and returns it or null if not found. This method does not perform well on Rowsets instances as a rowset is unordered list which does linear search. In contrast, Tables are always ordered and perform binary search instead (Inherited from RowsetBase.)
Public method | FindByKey(Row) | Tries to find a row by specified keyset and returns it or null if not found (Inherited from RowsetBase.)
Public method | FindByKey(Row, Func Row, Boolean ) | Tries to find a row by specified keyset and extra WHERE clause and returns it or null if not found. This method does not perform well on Rowsets instances as a rowset is unordered list which does linear search. In contrast, Tables are always ordered and perform binary search instead (Inherited from RowsetBase.)
Public method | FindByKey(Func Row, Boolean , Object ) | Tries to find a row by specified keyset and extra WHERE clause and returns it or null if not found (Inherited from RowsetBase.)
Public method | GetChangeAt | Retrievs a change by index or null if index is out of bounds or changes are not logged (Inherited from RowsetBase.)
Public method | GetEnumerator | (Inherited from RowsetBase.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IndexOf | (Inherited from RowsetBase.)
Public method | Insert(Row) | Inserts the row. Returns insertion index (Inherited from RowsetBase.)
Public method | Insert(Int32, Row) | This is IList member implementation, index is ignored (Overrides RowsetBase Insert(Int32, Row).)
Public method | KeyRowFromValues | Creates key row out of field values for keys (Inherited from RowsetBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Purge | Deletes all rows from table without logging the deleted modifications even when LogModifications=true (Inherited from RowsetBase.)
Public method | PurgeChanges | Clears modifications accumulated by this instance (Inherited from RowsetBase.)
Public method | Remove | Performs row delete (Inherited from RowsetBase.)
Public method | RemoveAt | Deletes row (Inherited from RowsetBase.)
Protected method | SearchForRow | Performs binary search on a sorted table (Overrides RowsetBase SearchForRow(Row, Int32 ).)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Update | Updates the row, Returns the row index or -1 (Inherited from RowsetBase.)
Public method | Upsert | Tries to find a row for update and if found, updates it and returns true, otherwise inserts the row (if schemas match) and returns false. Optionally pass updateWhere condition that may check whether update needs to be performed (Inherited from RowsetBase.)
Public method | Validate | Validates all rows in this rowset. Override to perform custom validations. The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from RowsetBase.)
Public method | WriteAsJSON | Writes rowset as JSON including schema information. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class (Inherited from RowsetBase.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Changes | (Inherited from RowsetBase.)
Protected field | m_List | (Inherited from RowsetBase.)
Protected field | m_Schema | (Inherited from RowsetBase.)
Back to Top
Properties
 | Name | Description
Public property | AsReadonlyIList | Returns data as non-generic readonly IList (Inherited from RowsetBase.)
Public property | ChangeCount | Returns a count of accumulated modifications performed on the rowset, or zero when no modifications have been made or LogModifications = false (Inherited from RowsetBase.)
Public property | Changes | Returns accumulated modifications performed on the rowset, or empty enumerator if no modifications have been made or LogModifications = false (Inherited from RowsetBase.)
Public property | Context | Provides dynamic view of rowset's data context - attributes applicable to the whole rowset (Inherited from RowsetBase.)
Public property | ContextMap | Provides dynamic view as JSONDataMap of rowset's data context - attributes applicable to the whole rowset (Inherited from RowsetBase.)
Public property | Count | Returns row count in this rowset (Inherited from RowsetBase.)
Public property | InstanceGUID | Returns globaly-unique instance ID. This ID is useful as a key for storing rowsets in object stores and posting data back from web client to server. (Inherited from RowsetBase.)
Public property | IsReadOnly | (Inherited from RowsetBase.)
Public property | Item | This method does not support setting rows in table (Overrides RowsetBase Item Int32 .)
Public property | LogChanges | Gets/Sets whether this rowset keeps track of all modifications done to it. This property must be set to true to be able to save changes into ICRUDDataStore (Inherited from RowsetBase.)
Public property | Schema | Returns a schema for rows that this rowset contains (Inherited from RowsetBase.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from RowsetBase.)
Back to Top
See Also
Table Class
NFX.DataAccess.CRUD Namespace


Table Constructor

Table Constructor NFX Class Library

Overload List
 | Name | Description
Public method | Table(Schema) | Creates an empty table
Public method | Table(Rowset, Func Row, Boolean ) | Creates a shallow copy from another rowset resorting data per schema key definition, optionally applying a filter
Public method | Table(Table, Func Row, Boolean ) | Creates a shallow copy from another table, optionally applying a filter
Back to Top
See Also
Table Class
Table Members
NFX.DataAccess.CRUD Namespace


Table Constructor (Schema)

Table Constructor (Schema) NFX Class Library

Creates an empty table

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Table(
    Schema schema
)
public Table(
    Schema schema
)
Public Sub New (
    schema As Schema
)
Public Sub New (
    schema As Schema
)
public:
Table(
    Schema^ schema
)
public:
Table(
    Schema^ schema
)
new :
        schema : Schema -> Table
new :
        schema : Schema -> Table

Parameters

schema
Type: NFX.DataAccess.CRUD Schema
See Also
Table Class
Table Members
Table Overload
NFX.DataAccess.CRUD Namespace


Table Constructor (Rowset, Func(Row, Boolean))

Table Constructor (Rowset, Func Row, Boolean ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates a shallow copy from another rowset resorting data per schema key definition, optionally applying a filter

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Table(
    Rowset other,
    Func<Row, bool> filter = null
)
public Table(
    Rowset other,
    Func<Row, bool> filter = null
)
Public Sub New (
    other As Rowset,
    Optional filter As Func(Of Row, Boolean) = Nothing
)
Public Sub New (
    other As Rowset,
    Optional filter As Func(Of Row, Boolean) = Nothing
)
public:
Table(
    Rowset^ other,
    Func<Row^, bool>^ filter = nullptr
)
public:
Table(
    Rowset^ other,
    Func<Row^, bool>^ filter = nullptr
)
new :
        other : Rowset *
        ?filter : Func<Row, bool>
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Table
new :
        other : Rowset *
        ?filter : Func<Row, bool>
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Table

Parameters

other
Type: NFX.DataAccess.CRUD Rowset
filter (Optional)
Type: Online System Func Row, Online Boolean
See Also
Table Class
Table Members
Table Overload
NFX.DataAccess.CRUD Namespace


Table Constructor (Table, Func(Row, Boolean))

Table Constructor (Table, Func Row, Boolean ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates a shallow copy from another table, optionally applying a filter

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Table(
    Table other,
    Func<Row, bool> filter = null
)
public Table(
    Table other,
    Func<Row, bool> filter = null
)
Public Sub New (
    other As Table,
    Optional filter As Func(Of Row, Boolean) = Nothing
)
Public Sub New (
    other As Table,
    Optional filter As Func(Of Row, Boolean) = Nothing
)
public:
Table(
    Table^ other,
    Func<Row^, bool>^ filter = nullptr
)
public:
Table(
    Table^ other,
    Func<Row^, bool>^ filter = nullptr
)
new :
        other : Table *
        ?filter : Func<Row, bool>
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Table
new :
        other : Table *
        ?filter : Func<Row, bool>
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Table

Parameters

other
Type: NFX.DataAccess.CRUD Table
filter (Optional)
Type: Online System Func Row, Online Boolean
See Also
Table Class
Table Members
Table Overload
NFX.DataAccess.CRUD Namespace


Table Fields

Table Fields NFX Class Library

The Table type exposes the following members.
Fields
 | Name | Description
Protected field | m_Changes | (Inherited from RowsetBase.)
Protected field | m_List | (Inherited from RowsetBase.)
Protected field | m_Schema | (Inherited from RowsetBase.)
Back to Top
See Also
Table Class
NFX.DataAccess.CRUD Namespace


Table Methods

Table Methods NFX Class Library

The Table type exposes the following members.
Methods
 | Name | Description
Public method | Add | Inserts a row (Inherited from RowsetBase.)
Protected method | Check | Checks argument for being non-null and of the same schema with this rowset (Inherited from RowsetBase.)
Public method | Clear | Purges table (Inherited from RowsetBase.)
Public method | Compare | Compares two rows based on their key fields. Always compares in ascending direction (Overrides RowsetBase Compare(Row, Row).)
 | CompareRows | Compares two rows based on their key fields. Always compares in ascending direction
Public method | Contains | (Inherited from RowsetBase.)
Public method | CopyTo | (Inherited from RowsetBase.)
Public method | Delete( Object ) | Tries to find a row with the same set of key fields in this table and if found, deletes it and returns its index, otherwise -1 (Inherited from RowsetBase.)
Public method | Delete(Row, IDataStoreKey) | Tries to find a row with the same set of key fields in this table and if found, deletes it and returns its index, otherwise -1 (Inherited from RowsetBase.)
Public method | DeleteAll | Deletes all rows from table. This method is similar to Purge() but does logging (when enabled) (Inherited from RowsetBase.)
Protected method | DoDelete | Tries to find a row with the same set of key fields in this table and if found, deletes it and returns its index, otherwise -1 (Inherited from RowsetBase.)
Protected method | DoInsert | Tries to insert a row. If another row with the same set of key fields already in the table returns -1, otherwise returns insertion index (Inherited from RowsetBase.)
Protected method | DoUpdate | Tries to find a row with the same set of key fields in this table and if found, replaces it and returns its index, otherwise returns -1 (Inherited from RowsetBase.)
Protected method | DoUpsert | Tries to find a row with the same set of key fields in this table and if found, replaces it and returns true, otherwise inserts the row (if schemas match) and returns false. Optionally pass updateWhere condition that may check whether update needs to be performed (Inherited from RowsetBase.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FindByKey( Object ) | Tries to find a row by specified keyset and returns it or null if not found. This method does not perform well on Rowsets instances as a rowset is unordered list which does linear search. In contrast, Tables are always ordered and perform binary search instead (Inherited from RowsetBase.)
Public method | FindByKey(Row) | Tries to find a row by specified keyset and returns it or null if not found (Inherited from RowsetBase.)
Public method | FindByKey(Row, Func Row, Boolean ) | Tries to find a row by specified keyset and extra WHERE clause and returns it or null if not found. This method does not perform well on Rowsets instances as a rowset is unordered list which does linear search. In contrast, Tables are always ordered and perform binary search instead (Inherited from RowsetBase.)
Public method | FindByKey(Func Row, Boolean , Object ) | Tries to find a row by specified keyset and extra WHERE clause and returns it or null if not found (Inherited from RowsetBase.)
Public method | GetChangeAt | Retrievs a change by index or null if index is out of bounds or changes are not logged (Inherited from RowsetBase.)
Public method | GetEnumerator | (Inherited from RowsetBase.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IndexOf | (Inherited from RowsetBase.)
Public method | Insert(Row) | Inserts the row. Returns insertion index (Inherited from RowsetBase.)
Public method | Insert(Int32, Row) | This is IList member implementation, index is ignored (Overrides RowsetBase Insert(Int32, Row).)
Public method | KeyRowFromValues | Creates key row out of field values for keys (Inherited from RowsetBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Purge | Deletes all rows from table without logging the deleted modifications even when LogModifications=true (Inherited from RowsetBase.)
Public method | PurgeChanges | Clears modifications accumulated by this instance (Inherited from RowsetBase.)
Public method | Remove | Performs row delete (Inherited from RowsetBase.)
Public method | RemoveAt | Deletes row (Inherited from RowsetBase.)
Protected method | SearchForRow | Performs binary search on a sorted table (Overrides RowsetBase SearchForRow(Row, Int32 ).)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Update | Updates the row, Returns the row index or -1 (Inherited from RowsetBase.)
Public method | Upsert | Tries to find a row for update and if found, updates it and returns true, otherwise inserts the row (if schemas match) and returns false. Optionally pass updateWhere condition that may check whether update needs to be performed (Inherited from RowsetBase.)
Public method | Validate | Validates all rows in this rowset. Override to perform custom validations. The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from RowsetBase.)
Public method | WriteAsJSON | Writes rowset as JSON including schema information. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class (Inherited from RowsetBase.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from RowsetBase.)
Back to Top
See Also
Table Class
NFX.DataAccess.CRUD Namespace


Table.Compare Method

Table Compare Method NFX Class Library

Compares two rows based on their key fields. Always compares in ascending direction

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Compare(
    Row rowA,
    Row rowB
)
public override int Compare(
    Row rowA,
    Row rowB
)
Public Overrides Function Compare (
    rowA As Row,
    rowB As Row
) As Integer
Public Overrides Function Compare (
    rowA As Row,
    rowB As Row
) As Integer
public:
virtual int Compare(
    Row^ rowA,
    Row^ rowB
) override
public:
virtual int Compare(
    Row^ rowA,
    Row^ rowB
) override
abstract Compare :
        rowA : Row *
        rowB : Row -> int
override Compare :
        rowA : Row *
        rowB : Row -> int
abstract Compare :
        rowA : Row *
        rowB : Row -> int
override Compare :
        rowA : Row *
        rowB : Row -> int

Parameters

rowA
Type: NFX.DataAccess.CRUD Row
rowB
Type: NFX.DataAccess.CRUD Row

Return Value

Type: Online Int32

Implements

Online IComparer T Compare(T, T)
See Also
Table Class
Table Members
NFX.DataAccess.CRUD Namespace


Table.CompareRows Method

Table CompareRows Method NFX Class Library

Compares two rows based on their key fields. Always compares in ascending direction

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int CompareRows(
    Schema schema,
    Row rowA,
    Row rowB
)
public static int CompareRows(
    Schema schema,
    Row rowA,
    Row rowB
)
Public Shared Function CompareRows (
    schema As Schema,
    rowA As Row,
    rowB As Row
) As Integer
Public Shared Function CompareRows (
    schema As Schema,
    rowA As Row,
    rowB As Row
) As Integer
public:
static int CompareRows(
    Schema^ schema,
    Row^ rowA,
    Row^ rowB
)
public:
static int CompareRows(
    Schema^ schema,
    Row^ rowA,
    Row^ rowB
)
static member CompareRows :
        schema : Schema *
        rowA : Row *
        rowB : Row -> int
static member CompareRows :
        schema : Schema *
        rowA : Row *
        rowB : Row -> int

Parameters

schema
Type: NFX.DataAccess.CRUD Schema
rowA
Type: NFX.DataAccess.CRUD Row
rowB
Type: NFX.DataAccess.CRUD Row

Return Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.CRUD Namespace


Table.Insert Method

Table Insert Method NFX Class Library

Overload List
 | Name | Description
Public method | Insert(Row) | Inserts the row. Returns insertion index (Inherited from RowsetBase.)
Public method | Insert(Int32, Row) | This is IList member implementation, index is ignored (Overrides RowsetBase Insert(Int32, Row).)
Back to Top
See Also
Table Class
Table Members
NFX.DataAccess.CRUD Namespace


Table.Insert Method (Int32, Row)

Table Insert Method (Int32, Row) NFX Class Library

This is IList member implementation, index is ignored

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Insert(
    int index,
    Row item
)
public override void Insert(
    int index,
    Row item
)
Public Overrides Sub Insert (
    index As Integer,
    item As Row
)
Public Overrides Sub Insert (
    index As Integer,
    item As Row
)
public:
virtual void Insert(
    int index,
    Row^ item
) override
public:
virtual void Insert(
    int index,
    Row^ item
) override
abstract Insert :
        index : int *
        item : Row -> unit
override Insert :
        index : int *
        item : Row -> unit
abstract Insert :
        index : int *
        item : Row -> unit
override Insert :
        index : int *
        item : Row -> unit

Parameters

index
Type: Online System Int32
item
Type: NFX.DataAccess.CRUD Row

Implements

Online IList T Insert(Int32, T)
See Also
Table Class
Table Members
Insert Overload
NFX.DataAccess.CRUD Namespace


Table.SearchForRow Method

Table SearchForRow Method NFX Class Library

Performs binary search on a sorted table

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override int SearchForRow(
    Row row,
    out int index
)
protected override int SearchForRow(
    Row row,
    out int index
)
Protected Overrides Function SearchForRow (
    row As Row,
    <OutAttribute> ByRef index As Integer
) As Integer
Protected Overrides Function SearchForRow (
    row As Row,
    <OutAttribute> ByRef index As Integer
) As Integer
protected:
virtual int SearchForRow(
    Row^ row,
    [OutAttribute] int% index
) override
protected:
virtual int SearchForRow(
    Row^ row,
    [OutAttribute] int% index
) override
abstract SearchForRow :
        row : Row *
        index : int byref -> int
override SearchForRow :
        row : Row *
        index : int byref -> int
abstract SearchForRow :
        row : Row *
        index : int byref -> int
override SearchForRow :
        row : Row *
        index : int byref -> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
index
Type: Online System Int32

Return Value

Type: Online Int32
See Also
Table Class
Table Members
NFX.DataAccess.CRUD Namespace


Table Properties

Table Properties NFX Class Library

The Table type exposes the following members.
Properties
 | Name | Description
Public property | AsReadonlyIList | Returns data as non-generic readonly IList (Inherited from RowsetBase.)
Public property | ChangeCount | Returns a count of accumulated modifications performed on the rowset, or zero when no modifications have been made or LogModifications = false (Inherited from RowsetBase.)
Public property | Changes | Returns accumulated modifications performed on the rowset, or empty enumerator if no modifications have been made or LogModifications = false (Inherited from RowsetBase.)
Public property | Context | Provides dynamic view of rowset's data context - attributes applicable to the whole rowset (Inherited from RowsetBase.)
Public property | ContextMap | Provides dynamic view as JSONDataMap of rowset's data context - attributes applicable to the whole rowset (Inherited from RowsetBase.)
Public property | Count | Returns row count in this rowset (Inherited from RowsetBase.)
Public property | InstanceGUID | Returns globaly-unique instance ID. This ID is useful as a key for storing rowsets in object stores and posting data back from web client to server. (Inherited from RowsetBase.)
Public property | IsReadOnly | (Inherited from RowsetBase.)
Public property | Item | This method does not support setting rows in table (Overrides RowsetBase Item Int32 .)
Public property | LogChanges | Gets/Sets whether this rowset keeps track of all modifications done to it. This property must be set to true to be able to save changes into ICRUDDataStore (Inherited from RowsetBase.)
Public property | Schema | Returns a schema for rows that this rowset contains (Inherited from RowsetBase.)
Back to Top
See Also
Table Class
NFX.DataAccess.CRUD Namespace


Table.Item Property

Table Item Property NFX Class Library

This method does not support setting rows in table

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Row this[
    int index
] { get; set; }
public override Row this[
    int index
] { get; set; }
Public Overrides Default Property Item (
    index As Integer
) As Row
    Get
    Set
Public Overrides Default Property Item (
    index As Integer
) As Row
    Get
    Set
public:
virtual property Row^ default[int index] {
    Row^ get (int index) override;
    void set (int index, Row^ value) override;
}
public:
virtual property Row^ default[int index] {
    Row^ get (int index) override;
    void set (int index, Row^ value) override;
}
abstract Item : Row with get, set
override Item : Row with get, set
abstract Item : Row with get, set
override Item : Row with get, set

Parameters

index
Type: Online System Int32

Property Value

Type: Row

Implements

Online IList T Item Int32
See Also
Table Class
Table Members
NFX.DataAccess.CRUD Namespace


TableAttribute Class

TableAttribute Class NFX Class Library

Provides information about table schema that this row is a part of
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.DataAccess.CRUD TargetedAttribute
NFX.DataAccess.CRUD TableAttribute

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = true, Inherited = false)]
public sealed class TableAttribute : TargetedAttribute
[SerializableAttribute]
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = true, Inherited = false)]
public sealed class TableAttribute : TargetedAttribute
<SerializableAttribute>
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := true, Inherited := false)>
Public NotInheritable Class TableAttribute
    Inherits TargetedAttribute
<SerializableAttribute>
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := true, Inherited := false)>
Public NotInheritable Class TableAttribute
    Inherits TargetedAttribute
[SerializableAttribute]
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = true, Inherited = false)]
public ref class TableAttribute sealed : public TargetedAttribute
[SerializableAttribute]
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = true, Inherited = false)]
public ref class TableAttribute sealed : public TargetedAttribute
[<SealedAttribute>]
[<SerializableAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = true, Inherited = false)>]
type TableAttribute =
    class
        inherit TargetedAttribute
    end
[<SealedAttribute>]
[<SerializableAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = true, Inherited = false)>]
type TableAttribute =
    class
        inherit TargetedAttribute
    end
See Also
TableAttribute Members
NFX.DataAccess.CRUD Namespace


TableAttribute Members

TableAttribute Members NFX Class Library

The TableAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | TableAttribute | Initializes a new instance of the TableAttribute class
Back to Top
Methods
 | Name | Description
Public method | Equals | (Overrides Online Attribute Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Attribute GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Immutable | Indicates whether the data represented by the decorated instance can only be created (and possibly deleted) but can not change(no update). This attribute allows some backends to perform some optimizations (such as better failover data handling and caching) as any version of the data that could be found is valid and the latest
Protected field | m_MetadataContent | (Inherited from TargetedAttribute.)
Public field | Name | Returns the name of schema that decorated class represents, i.e. the name of database table i.e. "TBL_PERSON". This value is set so datastore implementation can use it instead of inferring table name from declaring class name
Public field | TargetName | Returns the name of target, i.e. the name of database engine i.e. "ORACLE11g" or "MySQL" (Inherited from TargetedAttribute.)
Back to Top
Properties
 | Name | Description
Public property | Metadata | Returns structured metadata or null if there is no metadata defined (Inherited from TargetedAttribute.)
Public property | MetadataContent | Returns metadata content string in Laconic format or null. Root not is not specified. I.e.: 'a=1 b=true c{...}' (Inherited from TargetedAttribute.)
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
TableAttribute Class
NFX.DataAccess.CRUD Namespace


TableAttribute Constructor

TableAttribute Constructor NFX Class Library

Initializes a new instance of the TableAttribute class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TableAttribute(
    string targetName = null,
    string name = null,
    bool immutable = false,
    string metadata = null
)
public TableAttribute(
    string targetName = null,
    string name = null,
    bool immutable = false,
    string metadata = null
)
Public Sub New (
    Optional targetName As String = Nothing,
    Optional name As String = Nothing,
    Optional immutable As Boolean = false,
    Optional metadata As String = Nothing
)
Public Sub New (
    Optional targetName As String = Nothing,
    Optional name As String = Nothing,
    Optional immutable As Boolean = false,
    Optional metadata As String = Nothing
)
public:
TableAttribute(
    String^ targetName = nullptr,
    String^ name = nullptr,
    bool immutable = false,
    String^ metadata = nullptr
)
public:
TableAttribute(
    String^ targetName = nullptr,
    String^ name = nullptr,
    bool immutable = false,
    String^ metadata = nullptr
)
new :
        ?targetName : string *
        ?name : string *
        ?immutable : bool *
        ?metadata : string
(* Defaults:
        let _targetName = defaultArg targetName null
        let _name = defaultArg name null
        let _immutable = defaultArg immutable false
        let _metadata = defaultArg metadata null
*)
-> TableAttribute
new :
        ?targetName : string *
        ?name : string *
        ?immutable : bool *
        ?metadata : string
(* Defaults:
        let _targetName = defaultArg targetName null
        let _name = defaultArg name null
        let _immutable = defaultArg immutable false
        let _metadata = defaultArg metadata null
*)
-> TableAttribute

Parameters

targetName (Optional)
Type: Online System String
name (Optional)
Type: Online System String
immutable (Optional)
Type: Online System Boolean
metadata (Optional)
Type: Online System String
See Also
TableAttribute Class
TableAttribute Members
NFX.DataAccess.CRUD Namespace


TableAttribute Fields

TableAttribute Fields NFX Class Library

The TableAttribute type exposes the following members.
Fields
 | Name | Description
Public field | Immutable | Indicates whether the data represented by the decorated instance can only be created (and possibly deleted) but can not change(no update). This attribute allows some backends to perform some optimizations (such as better failover data handling and caching) as any version of the data that could be found is valid and the latest
Protected field | m_MetadataContent | (Inherited from TargetedAttribute.)
Public field | Name | Returns the name of schema that decorated class represents, i.e. the name of database table i.e. "TBL_PERSON". This value is set so datastore implementation can use it instead of inferring table name from declaring class name
Public field | TargetName | Returns the name of target, i.e. the name of database engine i.e. "ORACLE11g" or "MySQL" (Inherited from TargetedAttribute.)
Back to Top
See Also
TableAttribute Class
NFX.DataAccess.CRUD Namespace


TableAttribute.Immutable Field

TableAttribute Immutable Field NFX Class Library

Indicates whether the data represented by the decorated instance can only be created (and possibly deleted) but can not change(no update). This attribute allows some backends to perform some optimizations (such as better failover data handling and caching) as any version of the data that could be found is valid and the latest

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool Immutable
public readonly bool Immutable
Public ReadOnly Immutable As Boolean
Public ReadOnly Immutable As Boolean
public:
initonly bool Immutable
public:
initonly bool Immutable
val Immutable: bool
val Immutable: bool

Field Value

Type: Online Boolean
See Also
TableAttribute Class
TableAttribute Members
NFX.DataAccess.CRUD Namespace


TableAttribute.Name Field

TableAttribute Name Field NFX Class Library

Returns the name of schema that decorated class represents, i.e. the name of database table i.e. "TBL_PERSON". This value is set so datastore implementation can use it instead of inferring table name from declaring class name

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Name
public readonly string Name
Public ReadOnly Name As String
Public ReadOnly Name As String
public:
initonly String^ Name
public:
initonly String^ Name
val Name: string
val Name: string

Field Value

Type: Online String
See Also
TableAttribute Class
TableAttribute Members
NFX.DataAccess.CRUD Namespace


TableAttribute Methods

TableAttribute Methods NFX Class Library

The TableAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online Attribute Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Attribute GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TableAttribute Class
NFX.DataAccess.CRUD Namespace


TableAttribute.Equals Method

TableAttribute Equals Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
TableAttribute Class
TableAttribute Members
NFX.DataAccess.CRUD Namespace


TableAttribute.GetHashCode Method

TableAttribute GetHashCode Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
TableAttribute Class
TableAttribute Members
NFX.DataAccess.CRUD Namespace


TableAttribute Properties

TableAttribute Properties NFX Class Library

The TableAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Metadata | Returns structured metadata or null if there is no metadata defined (Inherited from TargetedAttribute.)
Public property | MetadataContent | Returns metadata content string in Laconic format or null. Root not is not specified. I.e.: 'a=1 b=true c{...}' (Inherited from TargetedAttribute.)
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
TableAttribute Class
NFX.DataAccess.CRUD Namespace


TargetedAttribute Class

TargetedAttribute Class NFX Class Library

Provides a base for attributes which ar targeted for particular techlology (i.e. "ORACLE")
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.DataAccess.CRUD TargetedAttribute
NFX.DataAccess.CRUD FieldAttribute
NFX.DataAccess.CRUD TableAttribute

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class TargetedAttribute : Attribute
[SerializableAttribute]
public abstract class TargetedAttribute : Attribute
<SerializableAttribute>
Public MustInherit Class TargetedAttribute
    Inherits Attribute
<SerializableAttribute>
Public MustInherit Class TargetedAttribute
    Inherits Attribute
[SerializableAttribute]
public ref class TargetedAttribute abstract : public Attribute
[SerializableAttribute]
public ref class TargetedAttribute abstract : public Attribute
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type TargetedAttribute =
    class
        inherit Attribute
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type TargetedAttribute =
    class
        inherit Attribute
    end
See Also
TargetedAttribute Members
NFX.DataAccess.CRUD Namespace


TargetedAttribute Members

TargetedAttribute Members NFX Class Library

The TargetedAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | TargetedAttribute | Initializes a new instance of the TargetedAttribute class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | ParseMetadataContent | Parses content with or without root node
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | ANY_TARGET |
Protected field | m_MetadataContent |
Public field | TargetName | Returns the name of target, i.e. the name of database engine i.e. "ORACLE11g" or "MySQL"
Back to Top
Properties
 | Name | Description
Public property | Metadata | Returns structured metadata or null if there is no metadata defined
Public property | MetadataContent | Returns metadata content string in Laconic format or null. Root not is not specified. I.e.: 'a=1 b=true c{...}'
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
TargetedAttribute Class
NFX.DataAccess.CRUD Namespace


TargetedAttribute Constructor

TargetedAttribute Constructor NFX Class Library

Initializes a new instance of the TargetedAttribute class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TargetedAttribute(
    string targetName,
    string metadata
)
public TargetedAttribute(
    string targetName,
    string metadata
)
Public Sub New (
    targetName As String,
    metadata As String
)
Public Sub New (
    targetName As String,
    metadata As String
)
public:
TargetedAttribute(
    String^ targetName,
    String^ metadata
)
public:
TargetedAttribute(
    String^ targetName,
    String^ metadata
)
new :
        targetName : string *
        metadata : string -> TargetedAttribute
new :
        targetName : string *
        metadata : string -> TargetedAttribute

Parameters

targetName
Type: Online System String
metadata
Type: Online System String
See Also
TargetedAttribute Class
TargetedAttribute Members
NFX.DataAccess.CRUD Namespace


TargetedAttribute Fields

TargetedAttribute Fields NFX Class Library

The TargetedAttribute type exposes the following members.
Fields
 | Name | Description
 | ANY_TARGET |
Protected field | m_MetadataContent |
Public field | TargetName | Returns the name of target, i.e. the name of database engine i.e. "ORACLE11g" or "MySQL"
Back to Top
See Also
TargetedAttribute Class
NFX.DataAccess.CRUD Namespace


TargetedAttribute.ANY_TARGET Field

TargetedAttribute ANY_TARGET Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ANY_TARGET
public const string ANY_TARGET
Public Const ANY_TARGET As String
Public Const ANY_TARGET As String
public:
literal String^ ANY_TARGET
public:
literal String^ ANY_TARGET
static val mutable ANY_TARGET: string
static val mutable ANY_TARGET: string

Field Value

Type: Online String
See Also
TargetedAttribute Class
TargetedAttribute Members
NFX.DataAccess.CRUD Namespace


TargetedAttribute.m_MetadataContent Field

TargetedAttribute m_MetadataContent Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected string m_MetadataContent
protected string m_MetadataContent
Protected m_MetadataContent As String
Protected m_MetadataContent As String
protected:
String^ m_MetadataContent
protected:
String^ m_MetadataContent
val mutable m_MetadataContent: string
val mutable m_MetadataContent: string

Field Value

Type: Online String
See Also
TargetedAttribute Class
TargetedAttribute Members
NFX.DataAccess.CRUD Namespace


TargetedAttribute.TargetName Field

TargetedAttribute TargetName Field NFX Class Library

Returns the name of target, i.e. the name of database engine i.e. "ORACLE11g" or "MySQL"

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string TargetName
public readonly string TargetName
Public ReadOnly TargetName As String
Public ReadOnly TargetName As String
public:
initonly String^ TargetName
public:
initonly String^ TargetName
val TargetName: string
val TargetName: string

Field Value

Type: Online String
See Also
TargetedAttribute Class
TargetedAttribute Members
NFX.DataAccess.CRUD Namespace


TargetedAttribute Methods

TargetedAttribute Methods NFX Class Library

The TargetedAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | ParseMetadataContent | Parses content with or without root node
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TargetedAttribute Class
NFX.DataAccess.CRUD Namespace


TargetedAttribute.ParseMetadataContent Method

TargetedAttribute ParseMetadataContent Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Parses content with or without root node

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ConfigSectionNode ParseMetadataContent(
    string content
)
public static ConfigSectionNode ParseMetadataContent(
    string content
)
Public Shared Function ParseMetadataContent (
    content As String
) As ConfigSectionNode
Public Shared Function ParseMetadataContent (
    content As String
) As ConfigSectionNode
public:
static ConfigSectionNode^ ParseMetadataContent(
    String^ content
)
public:
static ConfigSectionNode^ ParseMetadataContent(
    String^ content
)
static member ParseMetadataContent :
        content : string -> ConfigSectionNode
static member ParseMetadataContent :
        content : string -> ConfigSectionNode

Parameters

content
Type: Online System String

Return Value

Type: ConfigSectionNode
See Also
TargetedAttribute Class
TargetedAttribute Members
NFX.DataAccess.CRUD Namespace


TargetedAttribute Properties

TargetedAttribute Properties NFX Class Library

The TargetedAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Metadata | Returns structured metadata or null if there is no metadata defined
Public property | MetadataContent | Returns metadata content string in Laconic format or null. Root not is not specified. I.e.: 'a=1 b=true c{...}'
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
TargetedAttribute Class
NFX.DataAccess.CRUD Namespace


TargetedAttribute.Metadata Property

TargetedAttribute Metadata Property NFX Class Library

Returns structured metadata or null if there is no metadata defined

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IConfigSectionNode Metadata { get; }
public IConfigSectionNode Metadata { get; }
Public ReadOnly Property Metadata As IConfigSectionNode
    Get
Public ReadOnly Property Metadata As IConfigSectionNode
    Get
public:
property IConfigSectionNode^ Metadata {
    IConfigSectionNode^ get ();
}
public:
property IConfigSectionNode^ Metadata {
    IConfigSectionNode^ get ();
}
member Metadata : IConfigSectionNode with get
member Metadata : IConfigSectionNode with get

Property Value

Type: IConfigSectionNode
See Also
TargetedAttribute Class
TargetedAttribute Members
NFX.DataAccess.CRUD Namespace


TargetedAttribute.MetadataContent Property

TargetedAttribute MetadataContent Property NFX Class Library

Returns metadata content string in Laconic format or null. Root not is not specified. I.e.: 'a=1 b=true c{...}'

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MetadataContent { get; }
public string MetadataContent { get; }
Public ReadOnly Property MetadataContent As String
    Get
Public ReadOnly Property MetadataContent As String
    Get
public:
property String^ MetadataContent {
    String^ get ();
}
public:
property String^ MetadataContent {
    String^ get ();
}
member MetadataContent : string with get
member MetadataContent : string with get

Property Value

Type: Online String
See Also
TargetedAttribute Class
TargetedAttribute Members
NFX.DataAccess.CRUD Namespace


TransactionDisposeBehavior Enumeration

TransactionDisposeBehavior Enumeration NFX Class Library

Specifies how transaction scope behaves on scope exit

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum TransactionDisposeBehavior
public enum TransactionDisposeBehavior
Public Enumeration TransactionDisposeBehavior
Public Enumeration TransactionDisposeBehavior
public enum class TransactionDisposeBehavior
public enum class TransactionDisposeBehavior
type TransactionDisposeBehavior
type TransactionDisposeBehavior
Members
Member name | Value | Description
CommitOnDispose | 0 |
RollbackOnDispose | 1 |
See Also
NFX.DataAccess.CRUD Namespace


TransactionStatus Enumeration

TransactionStatus Enumeration NFX Class Library

Denotes transaction statuses

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum TransactionStatus
public enum TransactionStatus
Public Enumeration TransactionStatus
Public Enumeration TransactionStatus
public enum class TransactionStatus
public enum class TransactionStatus
type TransactionStatus
type TransactionStatus
Members
Member name | Value | Description
Open | 0 |
Comitted | 1 |
RolledBack | 2 |
See Also
NFX.DataAccess.CRUD Namespace


TypedRow Class

TypedRow Class NFX Class Library

Represents a type-safe row of data when schema is known at compile-time. Typed rows store data in instance fields, providing better performance and schema definition compile-time checking than DynamicRows at the expense of inability to define schema at runtime
Inheritance Hierarchy
Online System Object
NFX.DataAccess.CRUD Row
NFX.DataAccess.CRUD TypedRow
NFX.DataAccess.CRUD AmorphousTypedRow

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class TypedRow : Row
[SerializableAttribute]
public abstract class TypedRow : Row
<SerializableAttribute>
Public MustInherit Class TypedRow
    Inherits Row
<SerializableAttribute>
Public MustInherit Class TypedRow
    Inherits Row
[SerializableAttribute]
public ref class TypedRow abstract : public Row
[SerializableAttribute]
public ref class TypedRow abstract : public Row
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type TypedRow =
    class
        inherit Row
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type TypedRow =
    class
        inherit Row
    end
See Also
TypedRow Members
NFX.DataAccess.CRUD Namespace


TypedRow Members

TypedRow Members NFX Class Library

The TypedRow type exposes the following members.
Constructors
 | Name | Description
Protected method | TypedRow | Initializes a new instance of the TypedRow class
Back to Top
Methods
 | Name | Description
Public method | ApplyDefaultFieldValues | Writes default values specified in schema into fields. Pass overwrite=true to force defaults over non-null existing values (false by default) (Inherited from Row.)
Protected method | CheckMinMax | (Inherited from Row.)
Public method | Configure | In base class applies Config attribute. Useful for typed rows (Inherited from Row.)
Public method | ConvertFieldValueToDef | Converts field value to the type specified by Schema.FieldDef. For example converts GDID->ulong or ulong->GDID. This method can be overridden to perform custom handling of types, for example one can assign bool field as "Si" that would convert to TRUE. This method is called by SetFieldValue(...) before assigning actual field buffer (Inherited from Row.)
Public method | CopyFields | Copies fields from this row into another row/form. Note: this is shallow copy, as field values for complex types are just copied over (Inherited from Row.)
Public method | Equals(Object) | Object override - sealed. Override Equals(row) instead (Inherited from Row.)
Public method | Equals(Row) | Override to perform custom row equality comparison. Default implementation equates rows using their key fields (Inherited from Row.)
Protected method | FilterJSONSerializerField | Override to filter-out some fields from serialization to JSON, or change field values. Return name null to indicate that field should be filtered-out(excluded from serialization to JSON) (Inherited from Row.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetClientFieldDef | Override to perform dynamic substitute of field def for the specified field. This method is used by client ui/scaffolding to extract dynamic definition for a field (i.e. field description, requirement, value list etc.) as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original field def, you can return a substituted field def per particular business logic (Inherited from Row.)
Public method | GetClientFieldValue | Override to perform dynamic substitute of field value for the specified field. This method is used by client ui/scaffolding to extract field values for a field as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original GetFieldValue(fdef), you can return a substituted field value per particular business logic (Inherited from Row.)
Public method | GetClientFieldValueList | Override to perform dynamic lookup of field value list for the specified field. This method is used by client ui/scaffolding to extract dynamic lookup values as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. This is a simplified version of GetClientFieldDef (Inherited from Row.)
Public method | GetDataStoreKey | Returns values for fields that represent row's primary key (Inherited from Row.)
Public method | GetDisplayFieldValue(Int32, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute (Inherited from Row.)
Public method | GetDisplayFieldValue(String, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute (Inherited from Row.)
Public method | GetEnumerator | (Inherited from Row.)
Public method | GetFieldValue | (Overrides Row GetFieldValue(Schema FieldDef).)
Public method | GetFieldValueDescription(Int32, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema (Inherited from Row.)
Public method | GetFieldValueDescription(String, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema (Inherited from Row.)
Public method | GetHashCode | Object override - gets hash code from key fields (Inherited from Row.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PersistConfiguration | The base class does not implement this method. Override to persist row fields into config node (Inherited from Row.)
Public method | SetFieldValue | (Overrides Row SetFieldValue(Schema FieldDef, Object).)
Public method | SimpleFilterPredicate | Returns true if this row satisfies simple filter - it contains the supplied filter string. The filter pattern may start or end with "*" char that denotes a wildcard. A wildcard is permitted on both sides of the filter value (Inherited from Row.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Validate | Performs validation of data in the row returning exception object that provides description in cases when validation does not pass. Validation is performed not targeting any particular backend (Inherited from Row.)
Public method | Validate(String) | Validates row using row schema and supplied field definitions. Override to perform custom validations, i.e. TypeRows may directly access properties and write some validation type-safe code The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from Row.)
Public method | ValidateField(String, Schema FieldDef) | Validates row field using Schema.FieldDef settings. This method is invoked by base Validate() implementation. The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from Row.)
Public method | ValidateField(String, String) | Validates row field by name. Shortcut to ValidateField(Schema.FieldDef) (Inherited from Row.)
Public method | WriteAsJSON | Writes row as JSON either as an array or map depending on JSONWritingOptions.RowsAsMap setting. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class (Inherited from Row.)
Back to Top
Extension Methods
Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method ToErlObject Overloaded.
Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(ErlTypeOrder, Boolean) Overloaded.
Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(String, String, Boolean) Overloaded.
Convert Row to a hierarchical term that corresponds to the row's schema. The Erlang term is in the form:
View Colorized Copy to Clipboard Print
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
(Defined by ErlSchemaUtils.)
Public Extension Method ToJSON(JSONWritingOptions) Overloaded.
Serializes object into JSON string
(Defined by JSONExtensions.)
Public Extension Method ToJSON(TextWriter, JSONWritingOptions) Overloaded.
Serializes object into JSON format using provided TextWriter
(Defined by JSONExtensions.)
Public Extension Method ToJSON(Stream, JSONWritingOptions, Encoding) Overloaded.
Serializes object into JSON format using provided stream and optional encoding
(Defined by JSONExtensions.)
Public Extension Method Update
Convert an Erlang hierarchical term representing a schema to a Row.
(Defined by ErlSchemaUtils.)
Back to Top
Properties
 | Name | Description
Public property | Item Int32 | Gets/sets field values by positional index(Order) (Inherited from Row.)
Public property | Item String | Gets/sets field values by name (Inherited from Row.)
Public property | Schema | References a schema for a table that this row is a part of (Overrides Row Schema.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Row.)
Back to Top
See Also
TypedRow Class
NFX.DataAccess.CRUD Namespace


TypedRow Constructor

TypedRow Constructor NFX Class Library

Initializes a new instance of the TypedRow class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TypedRow()
protected TypedRow()
Protected Sub New
Protected Sub New
protected:
TypedRow()
protected:
TypedRow()
new : unit -> TypedRow
new : unit -> TypedRow
See Also
TypedRow Class
TypedRow Members
NFX.DataAccess.CRUD Namespace


TypedRow Methods

TypedRow Methods NFX Class Library

The TypedRow type exposes the following members.
Methods
 | Name | Description
Public method | ApplyDefaultFieldValues | Writes default values specified in schema into fields. Pass overwrite=true to force defaults over non-null existing values (false by default) (Inherited from Row.)
Protected method | CheckMinMax | (Inherited from Row.)
Public method | Configure | In base class applies Config attribute. Useful for typed rows (Inherited from Row.)
Public method | ConvertFieldValueToDef | Converts field value to the type specified by Schema.FieldDef. For example converts GDID->ulong or ulong->GDID. This method can be overridden to perform custom handling of types, for example one can assign bool field as "Si" that would convert to TRUE. This method is called by SetFieldValue(...) before assigning actual field buffer (Inherited from Row.)
Public method | CopyFields | Copies fields from this row into another row/form. Note: this is shallow copy, as field values for complex types are just copied over (Inherited from Row.)
Public method | Equals(Object) | Object override - sealed. Override Equals(row) instead (Inherited from Row.)
Public method | Equals(Row) | Override to perform custom row equality comparison. Default implementation equates rows using their key fields (Inherited from Row.)
Protected method | FilterJSONSerializerField | Override to filter-out some fields from serialization to JSON, or change field values. Return name null to indicate that field should be filtered-out(excluded from serialization to JSON) (Inherited from Row.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetClientFieldDef | Override to perform dynamic substitute of field def for the specified field. This method is used by client ui/scaffolding to extract dynamic definition for a field (i.e. field description, requirement, value list etc.) as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original field def, you can return a substituted field def per particular business logic (Inherited from Row.)
Public method | GetClientFieldValue | Override to perform dynamic substitute of field value for the specified field. This method is used by client ui/scaffolding to extract field values for a field as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. The default implementation returns the original GetFieldValue(fdef), you can return a substituted field value per particular business logic (Inherited from Row.)
Public method | GetClientFieldValueList | Override to perform dynamic lookup of field value list for the specified field. This method is used by client ui/scaffolding to extract dynamic lookup values as dictated by business logic. This method IS NOT used by row validation, only by client that feeds from row's metadata. This is a simplified version of GetClientFieldDef (Inherited from Row.)
Public method | GetDataStoreKey | Returns values for fields that represent row's primary key (Inherited from Row.)
Public method | GetDisplayFieldValue(Int32, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute (Inherited from Row.)
Public method | GetDisplayFieldValue(String, String, Func Object, Object ) | Returns field value as string formatted per target DisplayFormat attribute (Inherited from Row.)
Public method | GetEnumerator | (Inherited from Row.)
Public method | GetFieldValue | (Overrides Row GetFieldValue(Schema FieldDef).)
Public method | GetFieldValueDescription(Int32, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema (Inherited from Row.)
Public method | GetFieldValueDescription(String, String, Boolean) | For fields with ValueList returns value's description per specified targeted schema (Inherited from Row.)
Public method | GetHashCode | Object override - gets hash code from key fields (Inherited from Row.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PersistConfiguration | The base class does not implement this method. Override to persist row fields into config node (Inherited from Row.)
Public method | SetFieldValue | (Overrides Row SetFieldValue(Schema FieldDef, Object).)
Public method | SimpleFilterPredicate | Returns true if this row satisfies simple filter - it contains the supplied filter string. The filter pattern may start or end with "*" char that denotes a wildcard. A wildcard is permitted on both sides of the filter value (Inherited from Row.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Validate | Performs validation of data in the row returning exception object that provides description in cases when validation does not pass. Validation is performed not targeting any particular backend (Inherited from Row.)
Public method | Validate(String) | Validates row using row schema and supplied field definitions. Override to perform custom validations, i.e. TypeRows may directly access properties and write some validation type-safe code The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from Row.)
Public method | ValidateField(String, Schema FieldDef) | Validates row field using Schema.FieldDef settings. This method is invoked by base Validate() implementation. The method is not expected to throw exception in case of failed validation, rather return exception instance because throwing exception really hampers validation performance when many rows need to be validated (Inherited from Row.)
Public method | ValidateField(String, String) | Validates row field by name. Shortcut to ValidateField(Schema.FieldDef) (Inherited from Row.)
Public method | WriteAsJSON | Writes row as JSON either as an array or map depending on JSONWritingOptions.RowsAsMap setting. Do not call this method directly, instead call rowset.ToJSON() or use JSONWriter class (Inherited from Row.)
Back to Top
Extension Methods
Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method ToErlObject Overloaded.
Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(ErlTypeOrder, Boolean) Overloaded.
Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible
(Defined by ErlObject.)
Public Extension Method ToErlObject(String, String, Boolean) Overloaded.
Convert Row to a hierarchical term that corresponds to the row's schema. The Erlang term is in the form:
View Colorized Copy to Clipboard Print
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
(Defined by ErlSchemaUtils.)
Public Extension Method ToJSON(JSONWritingOptions) Overloaded.
Serializes object into JSON string
(Defined by JSONExtensions.)
Public Extension Method ToJSON(TextWriter, JSONWritingOptions) Overloaded.
Serializes object into JSON format using provided TextWriter
(Defined by JSONExtensions.)
Public Extension Method ToJSON(Stream, JSONWritingOptions, Encoding) Overloaded.
Serializes object into JSON format using provided stream and optional encoding
(Defined by JSONExtensions.)
Public Extension Method Update
Convert an Erlang hierarchical term representing a schema to a Row.
(Defined by ErlSchemaUtils.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Row.)
Back to Top
See Also
TypedRow Class
NFX.DataAccess.CRUD Namespace


TypedRow.GetFieldValue Method

TypedRow GetFieldValue Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object GetFieldValue(
    Schema..::..FieldDef fdef
)
public override Object GetFieldValue(
    Schema..::..FieldDef fdef
)
Public Overrides Function GetFieldValue (
    fdef As Schema..::..FieldDef
) As Object
Public Overrides Function GetFieldValue (
    fdef As Schema..::..FieldDef
) As Object
public:
virtual Object^ GetFieldValue(
    Schema..::..FieldDef^ fdef
) override
public:
virtual Object^ GetFieldValue(
    Schema..::..FieldDef^ fdef
) override
abstract GetFieldValue :
        fdef : Schema..::..FieldDef -> Object
override GetFieldValue :
        fdef : Schema..::..FieldDef -> Object
abstract GetFieldValue :
        fdef : Schema..::..FieldDef -> Object
override GetFieldValue :
        fdef : Schema..::..FieldDef -> Object

Parameters

fdef
Type: NFX.DataAccess.CRUD Schema FieldDef

Return Value

Type: Online Object
See Also
TypedRow Class
TypedRow Members
NFX.DataAccess.CRUD Namespace


TypedRow.SetFieldValue Method

TypedRow SetFieldValue Method NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetFieldValue(
    Schema..::..FieldDef fdef,
    Object value
)
public override void SetFieldValue(
    Schema..::..FieldDef fdef,
    Object value
)
Public Overrides Sub SetFieldValue (
    fdef As Schema..::..FieldDef,
    value As Object
)
Public Overrides Sub SetFieldValue (
    fdef As Schema..::..FieldDef,
    value As Object
)
public:
virtual void SetFieldValue(
    Schema..::..FieldDef^ fdef,
    Object^ value
) override
public:
virtual void SetFieldValue(
    Schema..::..FieldDef^ fdef,
    Object^ value
) override
abstract SetFieldValue :
        fdef : Schema..::..FieldDef *
        value : Object -> unit
override SetFieldValue :
        fdef : Schema..::..FieldDef *
        value : Object -> unit
abstract SetFieldValue :
        fdef : Schema..::..FieldDef *
        value : Object -> unit
override SetFieldValue :
        fdef : Schema..::..FieldDef *
        value : Object -> unit

Parameters

fdef
Type: NFX.DataAccess.CRUD Schema FieldDef
value
Type: Online System Object
See Also
TypedRow Class
TypedRow Members
NFX.DataAccess.CRUD Namespace


TypedRow Properties

TypedRow Properties NFX Class Library

The TypedRow type exposes the following members.
Properties
 | Name | Description
Public property | Item Int32 | Gets/sets field values by positional index(Order) (Inherited from Row.)
Public property | Item String | Gets/sets field values by name (Inherited from Row.)
Public property | Schema | References a schema for a table that this row is a part of (Overrides Row Schema.)
Back to Top
See Also
TypedRow Class
NFX.DataAccess.CRUD Namespace


TypedRow.Schema Property

TypedRow Schema Property NFX Class Library

References a schema for a table that this row is a part of

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override sealed Schema Schema { get; }
public override sealed Schema Schema { get; }
Public Overrides NotOverridable ReadOnly Property Schema As Schema
    Get
Public Overrides NotOverridable ReadOnly Property Schema As Schema
    Get
public:
virtual property Schema^ Schema {
    Schema^ get () override sealed;
}
public:
virtual property Schema^ Schema {
    Schema^ get () override sealed;
}
abstract Schema : Schema with get
override Schema : Schema with get
abstract Schema : Schema with get
override Schema : Schema with get

Property Value

Type: Schema
See Also
TypedRow Class
TypedRow Members
NFX.DataAccess.CRUD Namespace


UniqueSequenceAttribute Class

UniqueSequenceAttribute Class NFX Class Library

Provides information for unique sequence gen: scope and name
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.DataAccess.CRUD UniqueSequenceAttribute

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false, Inherited = false)]
public class UniqueSequenceAttribute : Attribute
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false, Inherited = false)]
public class UniqueSequenceAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := false, Inherited := false)>
Public Class UniqueSequenceAttribute
    Inherits Attribute
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := false, Inherited := false)>
Public Class UniqueSequenceAttribute
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = false, Inherited = false)]
public ref class UniqueSequenceAttribute : public Attribute
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = false, Inherited = false)]
public ref class UniqueSequenceAttribute : public Attribute
[<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false, Inherited = false)>]
type UniqueSequenceAttribute =
    class
        inherit Attribute
    end
[<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false, Inherited = false)>]
type UniqueSequenceAttribute =
    class
        inherit Attribute
    end
See Also
UniqueSequenceAttribute Members
NFX.DataAccess.CRUD Namespace


UniqueSequenceAttribute Members

UniqueSequenceAttribute Members NFX Class Library

The UniqueSequenceAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | UniqueSequenceAttribute(String) | Initializes a new instance of the UniqueSequenceAttribute class
Public method | UniqueSequenceAttribute(Type) | Initializes a new instance of the UniqueSequenceAttribute class
Public method | UniqueSequenceAttribute(String, String) | Initializes a new instance of the UniqueSequenceAttribute class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | GetForRowType | Returns UniqueSequenceAttribute or null for row type
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Prototype |
Public field | Scope |
Public field | Sequence |
Back to Top
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
UniqueSequenceAttribute Class
NFX.DataAccess.CRUD Namespace


UniqueSequenceAttribute Constructor

UniqueSequenceAttribute Constructor NFX Class Library

Overload List
 | Name | Description
Public method | UniqueSequenceAttribute(String) | Initializes a new instance of the UniqueSequenceAttribute class
Public method | UniqueSequenceAttribute(Type) | Initializes a new instance of the UniqueSequenceAttribute class
Public method | UniqueSequenceAttribute(String, String) | Initializes a new instance of the UniqueSequenceAttribute class
Back to Top
See Also
UniqueSequenceAttribute Class
UniqueSequenceAttribute Members
NFX.DataAccess.CRUD Namespace


UniqueSequenceAttribute Constructor (String)

UniqueSequenceAttribute Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the UniqueSequenceAttribute class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public UniqueSequenceAttribute(
    string scope
)
public UniqueSequenceAttribute(
    string scope
)
Public Sub New (
    scope As String
)
Public Sub New (
    scope As String
)
public:
UniqueSequenceAttribute(
    String^ scope
)
public:
UniqueSequenceAttribute(
    String^ scope
)
new :
        scope : string -> UniqueSequenceAttribute
new :
        scope : string -> UniqueSequenceAttribute

Parameters

scope
Type: Online System String
See Also
UniqueSequenceAttribute Class
UniqueSequenceAttribute Members
UniqueSequenceAttribute Overload
NFX.DataAccess.CRUD Namespace


UniqueSequenceAttribute Constructor (Type)

UniqueSequenceAttribute Constructor (Type) NFX Class Library

Initializes a new instance of the UniqueSequenceAttribute class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public UniqueSequenceAttribute(
    Type protoRow
)
public UniqueSequenceAttribute(
    Type protoRow
)
Public Sub New (
    protoRow As Type
)
Public Sub New (
    protoRow As Type
)
public:
UniqueSequenceAttribute(
    Type^ protoRow
)
public:
UniqueSequenceAttribute(
    Type^ protoRow
)
new :
        protoRow : Type -> UniqueSequenceAttribute
new :
        protoRow : Type -> UniqueSequenceAttribute

Parameters

protoRow
Type: Online System Type
See Also
UniqueSequenceAttribute Class
UniqueSequenceAttribute Members
UniqueSequenceAttribute Overload
NFX.DataAccess.CRUD Namespace


UniqueSequenceAttribute Constructor (String, String)

UniqueSequenceAttribute Constructor (String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the UniqueSequenceAttribute class

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public UniqueSequenceAttribute(
    string scope,
    string sequence
)
public UniqueSequenceAttribute(
    string scope,
    string sequence
)
Public Sub New (
    scope As String,
    sequence As String
)
Public Sub New (
    scope As String,
    sequence As String
)
public:
UniqueSequenceAttribute(
    String^ scope,
    String^ sequence
)
public:
UniqueSequenceAttribute(
    String^ scope,
    String^ sequence
)
new :
        scope : string *
        sequence : string -> UniqueSequenceAttribute
new :
        scope : string *
        sequence : string -> UniqueSequenceAttribute

Parameters

scope
Type: Online System String
sequence
Type: Online System String
See Also
UniqueSequenceAttribute Class
UniqueSequenceAttribute Members
UniqueSequenceAttribute Overload
NFX.DataAccess.CRUD Namespace


UniqueSequenceAttribute Fields

UniqueSequenceAttribute Fields NFX Class Library

The UniqueSequenceAttribute type exposes the following members.
Fields
 | Name | Description
Public field | Prototype |
Public field | Scope |
Public field | Sequence |
Back to Top
See Also
UniqueSequenceAttribute Class
NFX.DataAccess.CRUD Namespace


UniqueSequenceAttribute.Prototype Field

UniqueSequenceAttribute Prototype Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly UniqueSequenceAttribute Prototype
public readonly UniqueSequenceAttribute Prototype
Public ReadOnly Prototype As UniqueSequenceAttribute
Public ReadOnly Prototype As UniqueSequenceAttribute
public:
initonly UniqueSequenceAttribute^ Prototype
public:
initonly UniqueSequenceAttribute^ Prototype
val Prototype: UniqueSequenceAttribute
val Prototype: UniqueSequenceAttribute

Field Value

Type: UniqueSequenceAttribute
See Also
UniqueSequenceAttribute Class
UniqueSequenceAttribute Members
NFX.DataAccess.CRUD Namespace


UniqueSequenceAttribute.Scope Field

UniqueSequenceAttribute Scope Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Scope
public readonly string Scope
Public ReadOnly Scope As String
Public ReadOnly Scope As String
public:
initonly String^ Scope
public:
initonly String^ Scope
val Scope: string
val Scope: string

Field Value

Type: Online String
See Also
UniqueSequenceAttribute Class
UniqueSequenceAttribute Members
NFX.DataAccess.CRUD Namespace


UniqueSequenceAttribute.Sequence Field

UniqueSequenceAttribute Sequence Field NFX Class Library

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Sequence
public readonly string Sequence
Public ReadOnly Sequence As String
Public ReadOnly Sequence As String
public:
initonly String^ Sequence
public:
initonly String^ Sequence
val Sequence: string
val Sequence: string

Field Value

Type: Online String
See Also
UniqueSequenceAttribute Class
UniqueSequenceAttribute Members
NFX.DataAccess.CRUD Namespace


UniqueSequenceAttribute Methods

UniqueSequenceAttribute Methods NFX Class Library

The UniqueSequenceAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | GetForRowType | Returns UniqueSequenceAttribute or null for row type
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
UniqueSequenceAttribute Class
NFX.DataAccess.CRUD Namespace


UniqueSequenceAttribute.GetForRowType Method

UniqueSequenceAttribute GetForRowType Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns UniqueSequenceAttribute or null for row type

Namespace: NFX.DataAccess.CRUD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static UniqueSequenceAttribute GetForRowType(
    Type tRow
)
public static UniqueSequenceAttribute GetForRowType(
    Type tRow
)
Public Shared Function GetForRowType (
    tRow As Type
) As UniqueSequenceAttribute
Public Shared Function GetForRowType (
    tRow As Type
) As UniqueSequenceAttribute
public:
static UniqueSequenceAttribute^ GetForRowType(
    Type^ tRow
)
public:
static UniqueSequenceAttribute^ GetForRowType(
    Type^ tRow
)
static member GetForRowType :
        tRow : Type -> UniqueSequenceAttribute
static member GetForRowType :
        tRow : Type -> UniqueSequenceAttribute

Parameters

tRow
Type: Online System Type

Return Value

Type: UniqueSequenceAttribute
See Also
UniqueSequenceAttribute Class
UniqueSequenceAttribute Members
NFX.DataAccess.CRUD Namespace


UniqueSequenceAttribute Properties

UniqueSequenceAttribute Properties NFX Class Library

The UniqueSequenceAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
UniqueSequenceAttribute Class
NFX.DataAccess.CRUD Namespace


NFX.DataAccess.CRUD.Subscriptions Namespace

NFX.DataAccess.CRUD.Subscriptions Namespace NFX Class Library

[This is preliminary documentation and is subject to change.]

Classes
 | Class | Description
Public class | InvalidSubscriptionRequestException | Thrown by provider to indicate that such a subscribtion can not be established in principle, i.e. you may have passed a zero size of populus group, the server may respond with this error to indicate the principal error in request
Public class | Mailbox | Represents CRUD row data recipient
Public class | Subscription | Represents a subscription to the CRUD Data. Call Dispose() to terminate the subscription.
Public class | SubscriptionAppComponent | Base type for externally parametrized app components that are used throughout Subscription implementation
Structures
 | Structure | Description
Public structure | CRUDSubscriptionEvent | Describes row modification
Public structure | DataTimeStamp | Represents a microsecond interval since UNIX epoch start. This struct is used to tag incoming subscription data, so upon re-subscription the client may tell the server where to start sync from
Interfaces
 | Interface | Description
Public interface | ICRUDSubscriptionStore | Describes a CRUD store that can send ROW data via an established subscriptions into local recipients. Subscriptions are really stateless, they do not capture the data, however the Recipients do. Recipients can either support pull (caller has to fetch data), or reactive (calling delegate) modes
Public interface | ICRUDSubscriptionStoreImplementation |
Delegates
 | Delegate | Description
Public delegate | SubscriptionReceiptEventHandler | Describes event handlers that get called when data arrives
Enumerations
 | Enumeration | Description
Public enumeration | CRUDSubscriptionEvent EventType | Describes what kind of modification was done


CRUDSubscriptionEvent Structure

CRUDSubscriptionEvent Structure NFX Class Library

Describes row modification

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct CRUDSubscriptionEvent
public struct CRUDSubscriptionEvent
Public Structure CRUDSubscriptionEvent
Public Structure CRUDSubscriptionEvent
public value class CRUDSubscriptionEvent
public value class CRUDSubscriptionEvent
[<SealedAttribute>]
type CRUDSubscriptionEvent =  struct end
[<SealedAttribute>]
type CRUDSubscriptionEvent =  struct end
See Also
CRUDSubscriptionEvent Members
NFX.DataAccess.CRUD.Subscriptions Namespace


CRUDSubscriptionEvent Members

CRUDSubscriptionEvent Members NFX Class Library

The CRUDSubscriptionEvent type exposes the following members.
Constructors
 | Name | Description
Public method | CRUDSubscriptionEvent | Initializes a new instance of the CRUDSubscriptionEvent class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Row |
Public field | Schema |
Public field | Type |
Public field | Version |
Back to Top
See Also
CRUDSubscriptionEvent Structure
NFX.DataAccess.CRUD.Subscriptions Namespace


CRUDSubscriptionEvent Constructor

CRUDSubscriptionEvent Constructor NFX Class Library

Initializes a new instance of the CRUDSubscriptionEvent class

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDSubscriptionEvent(
    CRUDSubscriptionEvent..::..EventType type,
    Schema schema,
    Row row,
    DataTimeStamp version
)
public CRUDSubscriptionEvent(
    CRUDSubscriptionEvent..::..EventType type,
    Schema schema,
    Row row,
    DataTimeStamp version
)
Public Sub New (
    type As CRUDSubscriptionEvent..::..EventType,
    schema As Schema,
    row As Row,
    version As DataTimeStamp
)
Public Sub New (
    type As CRUDSubscriptionEvent..::..EventType,
    schema As Schema,
    row As Row,
    version As DataTimeStamp
)
public:
CRUDSubscriptionEvent(
    CRUDSubscriptionEvent..::..EventType type,
    Schema^ schema,
    Row^ row,
    DataTimeStamp version
)
public:
CRUDSubscriptionEvent(
    CRUDSubscriptionEvent..::..EventType type,
    Schema^ schema,
    Row^ row,
    DataTimeStamp version
)
new :
        type : CRUDSubscriptionEvent..::..EventType *
        schema : Schema *
        row : Row *
        version : DataTimeStamp -> CRUDSubscriptionEvent
new :
        type : CRUDSubscriptionEvent..::..EventType *
        schema : Schema *
        row : Row *
        version : DataTimeStamp -> CRUDSubscriptionEvent

Parameters

type
Type: NFX.DataAccess.CRUD.Subscriptions CRUDSubscriptionEvent EventType
schema
Type: NFX.DataAccess.CRUD Schema
row
Type: NFX.DataAccess.CRUD Row
version
Type: NFX.DataAccess.CRUD.Subscriptions DataTimeStamp
See Also
CRUDSubscriptionEvent Structure
CRUDSubscriptionEvent Members
NFX.DataAccess.CRUD.Subscriptions Namespace


CRUDSubscriptionEvent Fields

CRUDSubscriptionEvent Fields NFX Class Library

The CRUDSubscriptionEvent type exposes the following members.
Fields
 | Name | Description
Public field | Row |
Public field | Schema |
Public field | Type |
Public field | Version |
Back to Top
See Also
CRUDSubscriptionEvent Structure
NFX.DataAccess.CRUD.Subscriptions Namespace


CRUDSubscriptionEvent.Row Field

CRUDSubscriptionEvent Row Field NFX Class Library

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Row Row
public readonly Row Row
Public ReadOnly Row As Row
Public ReadOnly Row As Row
public:
initonly Row^ Row
public:
initonly Row^ Row
val Row: Row
val Row: Row

Field Value

Type: Row
See Also
CRUDSubscriptionEvent Structure
CRUDSubscriptionEvent Members
NFX.DataAccess.CRUD.Subscriptions Namespace


CRUDSubscriptionEvent.Schema Field

CRUDSubscriptionEvent Schema Field NFX Class Library

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Schema Schema
public readonly Schema Schema
Public ReadOnly Schema As Schema
Public ReadOnly Schema As Schema
public:
initonly Schema^ Schema
public:
initonly Schema^ Schema
val Schema: Schema
val Schema: Schema

Field Value

Type: Schema
See Also
CRUDSubscriptionEvent Structure
CRUDSubscriptionEvent Members
NFX.DataAccess.CRUD.Subscriptions Namespace


CRUDSubscriptionEvent.Type Field

CRUDSubscriptionEvent Type Field NFX Class Library

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly CRUDSubscriptionEvent..::..EventType Type
public readonly CRUDSubscriptionEvent..::..EventType Type
Public ReadOnly Type As CRUDSubscriptionEvent..::..EventType
Public ReadOnly Type As CRUDSubscriptionEvent..::..EventType
public:
initonly CRUDSubscriptionEvent..::..EventType Type
public:
initonly CRUDSubscriptionEvent..::..EventType Type
val Type: CRUDSubscriptionEvent..::..EventType
val Type: CRUDSubscriptionEvent..::..EventType

Field Value

Type: CRUDSubscriptionEvent EventType
See Also
CRUDSubscriptionEvent Structure
CRUDSubscriptionEvent Members
NFX.DataAccess.CRUD.Subscriptions Namespace


CRUDSubscriptionEvent.Version Field

CRUDSubscriptionEvent Version Field NFX Class Library

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly DataTimeStamp Version
public readonly DataTimeStamp Version
Public ReadOnly Version As DataTimeStamp
Public ReadOnly Version As DataTimeStamp
public:
initonly DataTimeStamp Version
public:
initonly DataTimeStamp Version
val Version: DataTimeStamp
val Version: DataTimeStamp

Field Value

Type: DataTimeStamp
See Also
CRUDSubscriptionEvent Structure
CRUDSubscriptionEvent Members
NFX.DataAccess.CRUD.Subscriptions Namespace


CRUDSubscriptionEvent Methods

CRUDSubscriptionEvent Methods NFX Class Library

The CRUDSubscriptionEvent type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CRUDSubscriptionEvent Structure
NFX.DataAccess.CRUD.Subscriptions Namespace


CRUDSubscriptionEvent.EventType Enumeration

CRUDSubscriptionEvent EventType Enumeration NFX Class Library

[This is preliminary documentation and is subject to change.]

Describes what kind of modification was done

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum EventType
public enum EventType
Public Enumeration EventType
Public Enumeration EventType
public enum class EventType
public enum class EventType
type EventType
type EventType
Members
Member name | Value | Description
RowInsert | 0 |
RowUpsert | 1 |
RowUpdate | 2 |
RowDelete | 3 |
TableCreate | 4 |
TableClear | 5 |
TableDrop | 6 |
See Also
NFX.DataAccess.CRUD.Subscriptions Namespace


DataTimeStamp Structure

DataTimeStamp Structure NFX Class Library

Represents a microsecond interval since UNIX epoch start. This struct is used to tag incoming subscription data, so upon re-subscription the client may tell the server where to start sync from

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct DataTimeStamp
public struct DataTimeStamp
Public Structure DataTimeStamp
Public Structure DataTimeStamp
public value class DataTimeStamp
public value class DataTimeStamp
[<SealedAttribute>]
type DataTimeStamp =  struct end
[<SealedAttribute>]
type DataTimeStamp =  struct end
See Also
DataTimeStamp Members
NFX.DataAccess.CRUD.Subscriptions Namespace


DataTimeStamp Members

DataTimeStamp Members NFX Class Library

The DataTimeStamp type exposes the following members.
Constructors
 | Name | Description
Public method | DataTimeStamp | Initializes a new instance of the DataTimeStamp class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Microseconds |
Back to Top
Properties
 | Name | Description
Public property | TimeStampUTC |
Back to Top
See Also
DataTimeStamp Structure
NFX.DataAccess.CRUD.Subscriptions Namespace


DataTimeStamp Constructor

DataTimeStamp Constructor NFX Class Library

Initializes a new instance of the DataTimeStamp class

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DataTimeStamp(
    long microseconds
)
public DataTimeStamp(
    long microseconds
)
Public Sub New (
    microseconds As Long
)
Public Sub New (
    microseconds As Long
)
public:
DataTimeStamp(
    long long microseconds
)
public:
DataTimeStamp(
    long long microseconds
)
new :
        microseconds : int64 -> DataTimeStamp
new :
        microseconds : int64 -> DataTimeStamp

Parameters

microseconds
Type: Online System Int64
See Also
DataTimeStamp Structure
DataTimeStamp Members
NFX.DataAccess.CRUD.Subscriptions Namespace


DataTimeStamp Fields

DataTimeStamp Fields NFX Class Library

The DataTimeStamp type exposes the following members.
Fields
 | Name | Description
Public field | Microseconds |
Back to Top
See Also
DataTimeStamp Structure
NFX.DataAccess.CRUD.Subscriptions Namespace


DataTimeStamp.Microseconds Field

DataTimeStamp Microseconds Field NFX Class Library

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly long Microseconds
public readonly long Microseconds
Public ReadOnly Microseconds As Long
Public ReadOnly Microseconds As Long
public:
initonly long long Microseconds
public:
initonly long long Microseconds
val Microseconds: int64
val Microseconds: int64

Field Value

Type: Online Int64
See Also
DataTimeStamp Structure
DataTimeStamp Members
NFX.DataAccess.CRUD.Subscriptions Namespace


DataTimeStamp Methods

DataTimeStamp Methods NFX Class Library

The DataTimeStamp type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
DataTimeStamp Structure
NFX.DataAccess.CRUD.Subscriptions Namespace


DataTimeStamp Properties

DataTimeStamp Properties NFX Class Library

The DataTimeStamp type exposes the following members.
Properties
 | Name | Description
Public property | TimeStampUTC |
Back to Top
See Also
DataTimeStamp Structure
NFX.DataAccess.CRUD.Subscriptions Namespace


DataTimeStamp.TimeStampUTC Property

DataTimeStamp TimeStampUTC Property NFX Class Library

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime TimeStampUTC { get; }
public DateTime TimeStampUTC { get; }
Public ReadOnly Property TimeStampUTC As DateTime
    Get
Public ReadOnly Property TimeStampUTC As DateTime
    Get
public:
property DateTime TimeStampUTC {
    DateTime get ();
}
public:
property DateTime TimeStampUTC {
    DateTime get ();
}
member TimeStampUTC : DateTime with get
member TimeStampUTC : DateTime with get

Property Value

Type: Online DateTime
See Also
DataTimeStamp Structure
DataTimeStamp Members
NFX.DataAccess.CRUD.Subscriptions Namespace


ICRUDSubscriptionStore Interface

ICRUDSubscriptionStore Interface NFX Class Library

Describes a CRUD store that can send ROW data via an established subscriptions into local recipients. Subscriptions are really stateless, they do not capture the data, however the Recipients do. Recipients can either support pull (caller has to fetch data), or reactive (calling delegate) modes

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ICRUDSubscriptionStore : IDataStore,
    IApplicationComponent, IDisposable
public interface ICRUDSubscriptionStore : IDataStore,
    IApplicationComponent, IDisposable
Public Interface ICRUDSubscriptionStore
    Inherits IDataStore, IApplicationComponent, IDisposable
Public Interface ICRUDSubscriptionStore
    Inherits IDataStore, IApplicationComponent, IDisposable
public interface class ICRUDSubscriptionStore : IDataStore,
    IApplicationComponent, IDisposable
public interface class ICRUDSubscriptionStore : IDataStore,
    IApplicationComponent, IDisposable
type ICRUDSubscriptionStore =
    interface
        interface IDataStore
        interface IApplicationComponent
        interface IDisposable
    end
type ICRUDSubscriptionStore =
    interface
        interface IDataStore
        interface IApplicationComponent
        interface IDisposable
    end
See Also
ICRUDSubscriptionStore Members
NFX.DataAccess.CRUD.Subscriptions Namespace


ICRUDSubscriptionStore Members

ICRUDSubscriptionStore Members NFX Class Library

The ICRUDSubscriptionStore type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | OpenMailbox | Returns existing mailbox by name (case-insensitive) or creates a new named mailbox
Public method | Subscribe | Subscribes the local recipient to the remote data store by executing a Query. The subscription ends by calling a .Dispose()
Public method | TestConnection | Tests connection and throws an exception if connection could not be established (Inherited from IDataStore.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | Mailboxes | Returns registry of all mailboxes
Public property | Subscriptions | Returns registry of all active subscriptions
Public property | TargetName | Returns the name of the underlying store technology, i.e. "ORACLE". This property is used by some metadata-based validation logic which is target-dependent (Inherited from IDataStore.)
Back to Top
See Also
ICRUDSubscriptionStore Interface
NFX.DataAccess.CRUD.Subscriptions Namespace


ICRUDSubscriptionStore Methods

ICRUDSubscriptionStore Methods NFX Class Library

The ICRUDSubscriptionStore type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | OpenMailbox | Returns existing mailbox by name (case-insensitive) or creates a new named mailbox
Public method | Subscribe | Subscribes the local recipient to the remote data store by executing a Query. The subscription ends by calling a .Dispose()
Public method | TestConnection | Tests connection and throws an exception if connection could not be established (Inherited from IDataStore.)
Back to Top
See Also
ICRUDSubscriptionStore Interface
NFX.DataAccess.CRUD.Subscriptions Namespace


ICRUDSubscriptionStore.OpenMailbox Method

ICRUDSubscriptionStore OpenMailbox Method NFX Class Library

Returns existing mailbox by name (case-insensitive) or creates a new named mailbox

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Mailbox OpenMailbox(
    string name
)
Mailbox OpenMailbox(
    string name
)
Function OpenMailbox (
    name As String
) As Mailbox
Function OpenMailbox (
    name As String
) As Mailbox
Mailbox^ OpenMailbox(
    String^ name
)
Mailbox^ OpenMailbox(
    String^ name
)
abstract OpenMailbox :
        name : string -> Mailbox
abstract OpenMailbox :
        name : string -> Mailbox

Parameters

name
Type: Online System String

Return Value

Type: Mailbox
See Also
ICRUDSubscriptionStore Interface
ICRUDSubscriptionStore Members
NFX.DataAccess.CRUD.Subscriptions Namespace


ICRUDSubscriptionStore.Subscribe Method

ICRUDSubscriptionStore Subscribe Method NFX Class Library

Subscribes the local recipient to the remote data store by executing a Query. The subscription ends by calling a .Dispose()

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Subscription Subscribe(
    string name,
    Query query,
    Mailbox recipient,
    Object correlate = null
)
Subscription Subscribe(
    string name,
    Query query,
    Mailbox recipient,
    Object correlate = null
)
Function Subscribe (
    name As String,
    query As Query,
    recipient As Mailbox,
    Optional correlate As Object = Nothing
) As Subscription
Function Subscribe (
    name As String,
    query As Query,
    recipient As Mailbox,
    Optional correlate As Object = Nothing
) As Subscription
Subscription^ Subscribe(
    String^ name,
    Query^ query,
    Mailbox^ recipient,
    Object^ correlate = nullptr
)
Subscription^ Subscribe(
    String^ name,
    Query^ query,
    Mailbox^ recipient,
    Object^ correlate = nullptr
)
abstract Subscribe :
        name : string *
        query : Query *
        recipient : Mailbox *
        ?correlate : Object
(* Defaults:
        let _correlate = defaultArg correlate null
*)
-> Subscription
abstract Subscribe :
        name : string *
        query : Query *
        recipient : Mailbox *
        ?correlate : Object
(* Defaults:
        let _correlate = defaultArg correlate null
*)
-> Subscription

Parameters

name
Type: Online System String
The store-wide-unique subscription name
query
Type: NFX.DataAccess.CRUD Query
The query that informs the remote store what data to send back
recipient
Type: NFX.DataAccess.CRUD.Subscriptions Mailbox
The local Recipient which will receive remote data
correlate (Optional)
Type: Online System Object
Adhock correlation object

Return Value

Type: Subscription
The subscription. It may be ended by calling .Dispose()
See Also
ICRUDSubscriptionStore Interface
ICRUDSubscriptionStore Members
NFX.DataAccess.CRUD.Subscriptions Namespace


ICRUDSubscriptionStore Properties

ICRUDSubscriptionStore Properties NFX Class Library

The ICRUDSubscriptionStore type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | Mailboxes | Returns registry of all mailboxes
Public property | Subscriptions | Returns registry of all active subscriptions
Public property | TargetName | Returns the name of the underlying store technology, i.e. "ORACLE". This property is used by some metadata-based validation logic which is target-dependent (Inherited from IDataStore.)
Back to Top
See Also
ICRUDSubscriptionStore Interface
NFX.DataAccess.CRUD.Subscriptions Namespace


ICRUDSubscriptionStore.Mailboxes Property

ICRUDSubscriptionStore Mailboxes Property NFX Class Library

Returns registry of all mailboxes

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IRegistry<Mailbox> Mailboxes { get; }
IRegistry<Mailbox> Mailboxes { get; }
ReadOnly Property Mailboxes As IRegistry(Of Mailbox)
    Get
ReadOnly Property Mailboxes As IRegistry(Of Mailbox)
    Get
property IRegistry<Mailbox^>^ Mailboxes {
    IRegistry<Mailbox^>^ get ();
}
property IRegistry<Mailbox^>^ Mailboxes {
    IRegistry<Mailbox^>^ get ();
}
abstract Mailboxes : IRegistry<Mailbox> with get
abstract Mailboxes : IRegistry<Mailbox> with get

Property Value

Type: IRegistry Mailbox
See Also
ICRUDSubscriptionStore Interface
ICRUDSubscriptionStore Members
NFX.DataAccess.CRUD.Subscriptions Namespace


ICRUDSubscriptionStore.Subscriptions Property

ICRUDSubscriptionStore Subscriptions Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns registry of all active subscriptions

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IRegistry<Subscription> Subscriptions { get; }
IRegistry<Subscription> Subscriptions { get; }
ReadOnly Property Subscriptions As IRegistry(Of Subscription)
    Get
ReadOnly Property Subscriptions As IRegistry(Of Subscription)
    Get
property IRegistry<Subscription^>^ Subscriptions {
    IRegistry<Subscription^>^ get ();
}
property IRegistry<Subscription^>^ Subscriptions {
    IRegistry<Subscription^>^ get ();
}
abstract Subscriptions : IRegistry<Subscription> with get
abstract Subscriptions : IRegistry<Subscription> with get

Property Value

Type: IRegistry Subscription
See Also
ICRUDSubscriptionStore Interface
ICRUDSubscriptionStore Members
NFX.DataAccess.CRUD.Subscriptions Namespace


ICRUDSubscriptionStoreImplementation Interface

ICRUDSubscriptionStoreImplementation Interface NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ICRUDSubscriptionStoreImplementation : ICRUDSubscriptionStore,
    IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
public interface ICRUDSubscriptionStoreImplementation : ICRUDSubscriptionStore,
    IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
Public Interface ICRUDSubscriptionStoreImplementation
    Inherits ICRUDSubscriptionStore, IDataStoreImplementation, IDataStore, IApplicationComponent,
    IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
Public Interface ICRUDSubscriptionStoreImplementation
    Inherits ICRUDSubscriptionStore, IDataStoreImplementation, IDataStore, IApplicationComponent,
    IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
public interface class ICRUDSubscriptionStoreImplementation : ICRUDSubscriptionStore,
    IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
public interface class ICRUDSubscriptionStoreImplementation : ICRUDSubscriptionStore,
    IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
type ICRUDSubscriptionStoreImplementation =
    interface
        interface ICRUDSubscriptionStore
        interface IDataStoreImplementation
        interface IDataStore
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
type ICRUDSubscriptionStoreImplementation =
    interface
        interface ICRUDSubscriptionStore
        interface IDataStoreImplementation
        interface IDataStore
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
ICRUDSubscriptionStoreImplementation Members
NFX.DataAccess.CRUD.Subscriptions Namespace


ICRUDSubscriptionStoreImplementation Members

ICRUDSubscriptionStoreImplementation Members NFX Class Library

[This is preliminary documentation and is subject to change.]

The ICRUDSubscriptionStoreImplementation type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Public method | OpenMailbox | Returns existing mailbox by name (case-insensitive) or creates a new named mailbox (Inherited from ICRUDSubscriptionStore.)
Public method | Subscribe | Subscribes the local recipient to the remote data store by executing a Query. The subscription ends by calling a .Dispose() (Inherited from ICRUDSubscriptionStore.)
Public method | TestConnection | Tests connection and throws an exception if connection could not be established (Inherited from IDataStore.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | LogLevel | Defines log level for data stores (Inherited from IDataStoreImplementation.)
Public property | Mailboxes | Returns registry of all mailboxes (Inherited from ICRUDSubscriptionStore.)
Public property | Subscriptions | Returns registry of all active subscriptions (Inherited from ICRUDSubscriptionStore.)
Public property | TargetName | Returns the name of the underlying store technology, i.e. "ORACLE". This property is used by some metadata-based validation logic which is target-dependent (Inherited from IDataStore.)
Back to Top
See Also
ICRUDSubscriptionStoreImplementation Interface
NFX.DataAccess.CRUD.Subscriptions Namespace


ICRUDSubscriptionStoreImplementation Methods

ICRUDSubscriptionStoreImplementation Methods NFX Class Library

[This is preliminary documentation and is subject to change.]

The ICRUDSubscriptionStoreImplementation type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Public method | OpenMailbox | Returns existing mailbox by name (case-insensitive) or creates a new named mailbox (Inherited from ICRUDSubscriptionStore.)
Public method | Subscribe | Subscribes the local recipient to the remote data store by executing a Query. The subscription ends by calling a .Dispose() (Inherited from ICRUDSubscriptionStore.)
Public method | TestConnection | Tests connection and throws an exception if connection could not be established (Inherited from IDataStore.)
Back to Top
See Also
ICRUDSubscriptionStoreImplementation Interface
NFX.DataAccess.CRUD.Subscriptions Namespace


ICRUDSubscriptionStoreImplementation Properties

ICRUDSubscriptionStoreImplementation Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The ICRUDSubscriptionStoreImplementation type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | LogLevel | Defines log level for data stores (Inherited from IDataStoreImplementation.)
Public property | Mailboxes | Returns registry of all mailboxes (Inherited from ICRUDSubscriptionStore.)
Public property | Subscriptions | Returns registry of all active subscriptions (Inherited from ICRUDSubscriptionStore.)
Public property | TargetName | Returns the name of the underlying store technology, i.e. "ORACLE". This property is used by some metadata-based validation logic which is target-dependent (Inherited from IDataStore.)
Back to Top
See Also
ICRUDSubscriptionStoreImplementation Interface
NFX.DataAccess.CRUD.Subscriptions Namespace


InvalidSubscriptionRequestException Class

InvalidSubscriptionRequestException Class NFX Class Library

Thrown by provider to indicate that such a subscribtion can not be established in principle, i.e. you may have passed a zero size of populus group, the server may respond with this error to indicate the principal error in request
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.DataAccess DataAccessException
NFX.DataAccess.CRUD CRUDException
NFX.DataAccess.CRUD.Subscriptions InvalidSubscriptionRequestException

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class InvalidSubscriptionRequestException : CRUDException
public class InvalidSubscriptionRequestException : CRUDException
Public Class InvalidSubscriptionRequestException
    Inherits CRUDException
Public Class InvalidSubscriptionRequestException
    Inherits CRUDException
public ref class InvalidSubscriptionRequestException : public CRUDException
public ref class InvalidSubscriptionRequestException : public CRUDException
type InvalidSubscriptionRequestException =
    class
        inherit CRUDException
    end
type InvalidSubscriptionRequestException =
    class
        inherit CRUDException
    end
See Also
InvalidSubscriptionRequestException Members
NFX.DataAccess.CRUD.Subscriptions Namespace


InvalidSubscriptionRequestException Members

InvalidSubscriptionRequestException Members NFX Class Library

[This is preliminary documentation and is subject to change.]

The InvalidSubscriptionRequestException type exposes the following members.
Constructors
 | Name | Description
Protected method | InvalidSubscriptionRequestException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidSubscriptionRequestException class
Public method | InvalidSubscriptionRequestException(String, Exception) | Initializes a new instance of the InvalidSubscriptionRequestException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
InvalidSubscriptionRequestException Class
NFX.DataAccess.CRUD.Subscriptions Namespace


InvalidSubscriptionRequestException Constructor

InvalidSubscriptionRequestException Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Protected method | InvalidSubscriptionRequestException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidSubscriptionRequestException class
Public method | InvalidSubscriptionRequestException(String, Exception) | Initializes a new instance of the InvalidSubscriptionRequestException class
Back to Top
See Also
InvalidSubscriptionRequestException Class
InvalidSubscriptionRequestException Members
NFX.DataAccess.CRUD.Subscriptions Namespace


InvalidSubscriptionRequestException Constructor (SerializationInfo, StreamingContext)

InvalidSubscriptionRequestException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the InvalidSubscriptionRequestException class

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected InvalidSubscriptionRequestException(
    SerializationInfo info,
    StreamingContext context
)
protected InvalidSubscriptionRequestException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
InvalidSubscriptionRequestException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
InvalidSubscriptionRequestException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> InvalidSubscriptionRequestException
new :
        info : SerializationInfo *
        context : StreamingContext -> InvalidSubscriptionRequestException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
InvalidSubscriptionRequestException Class
InvalidSubscriptionRequestException Members
InvalidSubscriptionRequestException Overload
NFX.DataAccess.CRUD.Subscriptions Namespace


InvalidSubscriptionRequestException Constructor (String, Exception)

InvalidSubscriptionRequestException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the InvalidSubscriptionRequestException class

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InvalidSubscriptionRequestException(
    string message,
    Exception inner
)
public InvalidSubscriptionRequestException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
InvalidSubscriptionRequestException(
    String^ message,
    Exception^ inner
)
public:
InvalidSubscriptionRequestException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> InvalidSubscriptionRequestException
new :
        message : string *
        inner : Exception -> InvalidSubscriptionRequestException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
InvalidSubscriptionRequestException Class
InvalidSubscriptionRequestException Members
InvalidSubscriptionRequestException Overload
NFX.DataAccess.CRUD.Subscriptions Namespace


InvalidSubscriptionRequestException Fields

InvalidSubscriptionRequestException Fields NFX Class Library

The InvalidSubscriptionRequestException type exposes the following members.
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
See Also
InvalidSubscriptionRequestException Class
NFX.DataAccess.CRUD.Subscriptions Namespace


InvalidSubscriptionRequestException Methods

InvalidSubscriptionRequestException Methods NFX Class Library

[This is preliminary documentation and is subject to change.]

The InvalidSubscriptionRequestException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
InvalidSubscriptionRequestException Class
NFX.DataAccess.CRUD.Subscriptions Namespace


InvalidSubscriptionRequestException Properties

InvalidSubscriptionRequestException Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The InvalidSubscriptionRequestException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
InvalidSubscriptionRequestException Class
NFX.DataAccess.CRUD.Subscriptions Namespace


InvalidSubscriptionRequestException Events

InvalidSubscriptionRequestException Events NFX Class Library

The InvalidSubscriptionRequestException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
InvalidSubscriptionRequestException Class
NFX.DataAccess.CRUD.Subscriptions Namespace


Mailbox Class

Mailbox Class NFX Class Library

Represents CRUD row data recipient
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.DataAccess.CRUD.Subscriptions SubscriptionAppComponent
NFX.DataAccess.CRUD.Subscriptions Mailbox
NFX.DataAccess.Erlang ErlCRUDMailbox

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Mailbox : SubscriptionAppComponent, INamed
public class Mailbox : SubscriptionAppComponent, INamed
Public Class Mailbox
    Inherits SubscriptionAppComponent
    Implements INamed
Public Class Mailbox
    Inherits SubscriptionAppComponent
    Implements INamed
public ref class Mailbox : public SubscriptionAppComponent,
    INamed
public ref class Mailbox : public SubscriptionAppComponent,
    INamed
type Mailbox =
    class
        inherit SubscriptionAppComponent
        interface INamed
    end
type Mailbox =
    class
        inherit SubscriptionAppComponent
        interface INamed
    end
See Also
Mailbox Members
NFX.DataAccess.CRUD.Subscriptions Namespace


Mailbox Members

Mailbox Members NFX Class Library

The Mailbox type exposes the following members.
Constructors
 | Name | Description
Protected method | Mailbox | Initializes a new instance of the Mailbox class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | Deliver | Delivers data to the mailbox. This method is called by subscription
Public method | DeliverError |
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from SubscriptionAppComponent.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from SubscriptionAppComponent.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from SubscriptionAppComponent.)
Public method | FetchBuffered | Tries to take the specified number of samples in chronological order
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnReceipt |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | BufferCapacity |
Public property | Buffered | Returns all buffered data in chronological order
Public property | BufferedCount | Returns how much is currently buffered
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from SubscriptionAppComponent.)
Public property | Name |
Public property | Store |
Public property | Subscriptions |
Back to Top
Events
 | Name | Description
Public event | Receipt |
Back to Top
See Also
Mailbox Class
NFX.DataAccess.CRUD.Subscriptions Namespace


Mailbox Constructor

Mailbox Constructor NFX Class Library

Initializes a new instance of the Mailbox class

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal Mailbox(
    ICRUDSubscriptionStoreImplementation store,
    string name
)
protected internal Mailbox(
    ICRUDSubscriptionStoreImplementation store,
    string name
)
Protected Friend Sub New (
    store As ICRUDSubscriptionStoreImplementation,
    name As String
)
Protected Friend Sub New (
    store As ICRUDSubscriptionStoreImplementation,
    name As String
)
protected public:
Mailbox(
    ICRUDSubscriptionStoreImplementation^ store,
    String^ name
)
protected public:
Mailbox(
    ICRUDSubscriptionStoreImplementation^ store,
    String^ name
)
new :
        store : ICRUDSubscriptionStoreImplementation *
        name : string -> Mailbox
new :
        store : ICRUDSubscriptionStoreImplementation *
        name : string -> Mailbox

Parameters

store
Type: NFX.DataAccess.CRUD.Subscriptions ICRUDSubscriptionStoreImplementation
name
Type: Online System String
See Also
Mailbox Class
Mailbox Members
NFX.DataAccess.CRUD.Subscriptions Namespace


Mailbox Methods

Mailbox Methods NFX Class Library

The Mailbox type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | Deliver | Delivers data to the mailbox. This method is called by subscription
Public method | DeliverError |
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from SubscriptionAppComponent.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from SubscriptionAppComponent.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from SubscriptionAppComponent.)
Public method | FetchBuffered | Tries to take the specified number of samples in chronological order
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnReceipt |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Mailbox Class
NFX.DataAccess.CRUD.Subscriptions Namespace


Mailbox.Deliver Method

Mailbox Deliver Method NFX Class Library

Delivers data to the mailbox. This method is called by subscription

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Deliver(
    Subscription subscription,
    CRUDSubscriptionEvent data
)
public bool Deliver(
    Subscription subscription,
    CRUDSubscriptionEvent data
)
Public Function Deliver (
    subscription As Subscription,
    data As CRUDSubscriptionEvent
) As Boolean
Public Function Deliver (
    subscription As Subscription,
    data As CRUDSubscriptionEvent
) As Boolean
public:
bool Deliver(
    Subscription^ subscription,
    CRUDSubscriptionEvent data
)
public:
bool Deliver(
    Subscription^ subscription,
    CRUDSubscriptionEvent data
)
member Deliver :
        subscription : Subscription *
        data : CRUDSubscriptionEvent -> bool
member Deliver :
        subscription : Subscription *
        data : CRUDSubscriptionEvent -> bool

Parameters

subscription
Type: NFX.DataAccess.CRUD.Subscriptions Subscription
data
Type: NFX.DataAccess.CRUD.Subscriptions CRUDSubscriptionEvent

Return Value

Type: Online Boolean
See Also
Mailbox Class
Mailbox Members
NFX.DataAccess.CRUD.Subscriptions Namespace


Mailbox.DeliverError Method

Mailbox DeliverError Method NFX Class Library

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool DeliverError(
    Subscription subscription,
    Exception error
)
public bool DeliverError(
    Subscription subscription,
    Exception error
)
Public Function DeliverError (
    subscription As Subscription,
    error As Exception
) As Boolean
Public Function DeliverError (
    subscription As Subscription,
    error As Exception
) As Boolean
public:
bool DeliverError(
    Subscription^ subscription,
    Exception^ error
)
public:
bool DeliverError(
    Subscription^ subscription,
    Exception^ error
)
member DeliverError :
        subscription : Subscription *
        error : Exception -> bool
member DeliverError :
        subscription : Subscription *
        error : Exception -> bool

Parameters

subscription
Type: NFX.DataAccess.CRUD.Subscriptions Subscription
error
Type: Online System Exception

Return Value

Type: Online Boolean
See Also
Mailbox Class
Mailbox Members
NFX.DataAccess.CRUD.Subscriptions Namespace


Mailbox.Destructor Method

Mailbox Destructor Method NFX Class Library

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
Mailbox Class
Mailbox Members
NFX.DataAccess.CRUD.Subscriptions Namespace


Mailbox.FetchBuffered Method

Mailbox FetchBuffered Method NFX Class Library

Tries to take the specified number of samples in chronological order

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<CRUDSubscriptionEvent> FetchBuffered(
    int count,
    bool keep = false
)
public List<CRUDSubscriptionEvent> FetchBuffered(
    int count,
    bool keep = false
)
Public Function FetchBuffered (
    count As Integer,
    Optional keep As Boolean = false
) As List(Of CRUDSubscriptionEvent)
Public Function FetchBuffered (
    count As Integer,
    Optional keep As Boolean = false
) As List(Of CRUDSubscriptionEvent)
public:
List<CRUDSubscriptionEvent>^ FetchBuffered(
    int count,
    bool keep = false
)
public:
List<CRUDSubscriptionEvent>^ FetchBuffered(
    int count,
    bool keep = false
)
member FetchBuffered :
        count : int *
        ?keep : bool
(* Defaults:
        let _keep = defaultArg keep false
*)
-> List<CRUDSubscriptionEvent>
member FetchBuffered :
        count : int *
        ?keep : bool
(* Defaults:
        let _keep = defaultArg keep false
*)
-> List<CRUDSubscriptionEvent>

Parameters

count
Type: Online System Int32
keep (Optional)
Type: Online System Boolean

Return Value

Type: Online List CRUDSubscriptionEvent
See Also
Mailbox Class
Mailbox Members
NFX.DataAccess.CRUD.Subscriptions Namespace


Mailbox.OnReceipt Method

Mailbox OnReceipt Method NFX Class Library

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void OnReceipt(
    Subscription subscription,
    CRUDSubscriptionEvent data,
    Exception error
)
protected virtual void OnReceipt(
    Subscription subscription,
    CRUDSubscriptionEvent data,
    Exception error
)
Protected Overridable Sub OnReceipt (
    subscription As Subscription,
    data As CRUDSubscriptionEvent,
    error As Exception
)
Protected Overridable Sub OnReceipt (
    subscription As Subscription,
    data As CRUDSubscriptionEvent,
    error As Exception
)
protected:
virtual void OnReceipt(
    Subscription^ subscription,
    CRUDSubscriptionEvent data,
    Exception^ error
)
protected:
virtual void OnReceipt(
    Subscription^ subscription,
    CRUDSubscriptionEvent data,
    Exception^ error
)
abstract OnReceipt :
        subscription : Subscription *
        data : CRUDSubscriptionEvent *
        error : Exception -> unit
override OnReceipt :
        subscription : Subscription *
        data : CRUDSubscriptionEvent *
        error : Exception -> unit
abstract OnReceipt :
        subscription : Subscription *
        data : CRUDSubscriptionEvent *
        error : Exception -> unit
override OnReceipt :
        subscription : Subscription *
        data : CRUDSubscriptionEvent *
        error : Exception -> unit

Parameters

subscription
Type: NFX.DataAccess.CRUD.Subscriptions Subscription
data
Type: NFX.DataAccess.CRUD.Subscriptions CRUDSubscriptionEvent
error
Type: Online System Exception
See Also
Mailbox Class
Mailbox Members
NFX.DataAccess.CRUD.Subscriptions Namespace


Mailbox Properties

Mailbox Properties NFX Class Library

The Mailbox type exposes the following members.
Properties
 | Name | Description
Public property | BufferCapacity |
Public property | Buffered | Returns all buffered data in chronological order
Public property | BufferedCount | Returns how much is currently buffered
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from SubscriptionAppComponent.)
Public property | Name |
Public property | Store |
Public property | Subscriptions |
Back to Top
See Also
Mailbox Class
NFX.DataAccess.CRUD.Subscriptions Namespace


Mailbox.BufferCapacity Property

Mailbox BufferCapacity Property NFX Class Library

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
public int BufferCapacity { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
public int BufferCapacity { get; set; }
<ExternalParameterAttribute(New String() { ... })>
Public Property BufferCapacity As Integer
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
Public Property BufferCapacity As Integer
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property int BufferCapacity {
    int get ();
    void set (int value);
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property int BufferCapacity {
    int get ();
    void set (int value);
}
[<ExternalParameterAttribute(new string[] { ... })>]
member BufferCapacity : int with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
member BufferCapacity : int with get, set

Property Value

Type: Online Int32
See Also
Mailbox Class
Mailbox Members
NFX.DataAccess.CRUD.Subscriptions Namespace


Mailbox.Buffered Property

Mailbox Buffered Property NFX Class Library

Returns all buffered data in chronological order

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDSubscriptionEvent[] Buffered { get; }
public CRUDSubscriptionEvent[] Buffered { get; }
Public ReadOnly Property Buffered As CRUDSubscriptionEvent()
    Get
Public ReadOnly Property Buffered As CRUDSubscriptionEvent()
    Get
public:
property array<CRUDSubscriptionEvent>^ Buffered {
    array<CRUDSubscriptionEvent>^ get ();
}
public:
property array<CRUDSubscriptionEvent>^ Buffered {
    array<CRUDSubscriptionEvent>^ get ();
}
member Buffered : CRUDSubscriptionEvent[] with get
member Buffered : CRUDSubscriptionEvent[] with get

Property Value

Type: CRUDSubscriptionEvent
See Also
Mailbox Class
Mailbox Members
NFX.DataAccess.CRUD.Subscriptions Namespace


Mailbox.BufferedCount Property

Mailbox BufferedCount Property NFX Class Library

Returns how much is currently buffered

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int BufferedCount { get; }
public int BufferedCount { get; }
Public ReadOnly Property BufferedCount As Integer
    Get
Public ReadOnly Property BufferedCount As Integer
    Get
public:
property int BufferedCount {
    int get ();
}
public:
property int BufferedCount {
    int get ();
}
member BufferedCount : int with get
member BufferedCount : int with get

Property Value

Type: Online Int32
See Also
Mailbox Class
Mailbox Members
NFX.DataAccess.CRUD.Subscriptions Namespace


Mailbox.Name Property

Mailbox Name Property NFX Class Library

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
Mailbox Class
Mailbox Members
NFX.DataAccess.CRUD.Subscriptions Namespace


Mailbox.Store Property

Mailbox Store Property NFX Class Library

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICRUDSubscriptionStore Store { get; }
public ICRUDSubscriptionStore Store { get; }
Public ReadOnly Property Store As ICRUDSubscriptionStore
    Get
Public ReadOnly Property Store As ICRUDSubscriptionStore
    Get
public:
property ICRUDSubscriptionStore^ Store {
    ICRUDSubscriptionStore^ get ();
}
public:
property ICRUDSubscriptionStore^ Store {
    ICRUDSubscriptionStore^ get ();
}
member Store : ICRUDSubscriptionStore with get
member Store : ICRUDSubscriptionStore with get

Property Value

Type: ICRUDSubscriptionStore
See Also
Mailbox Class
Mailbox Members
NFX.DataAccess.CRUD.Subscriptions Namespace


Mailbox.Subscriptions Property

Mailbox Subscriptions Property NFX Class Library

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<Subscription> Subscriptions { get; }
public IRegistry<Subscription> Subscriptions { get; }
Public ReadOnly Property Subscriptions As IRegistry(Of Subscription)
    Get
Public ReadOnly Property Subscriptions As IRegistry(Of Subscription)
    Get
public:
property IRegistry<Subscription^>^ Subscriptions {
    IRegistry<Subscription^>^ get ();
}
public:
property IRegistry<Subscription^>^ Subscriptions {
    IRegistry<Subscription^>^ get ();
}
member Subscriptions : IRegistry<Subscription> with get
member Subscriptions : IRegistry<Subscription> with get

Property Value

Type: IRegistry Subscription
See Also
Mailbox Class
Mailbox Members
NFX.DataAccess.CRUD.Subscriptions Namespace


Mailbox Events

Mailbox Events NFX Class Library

The Mailbox type exposes the following members.
Events
 | Name | Description
Public event | Receipt |
Back to Top
See Also
Mailbox Class
NFX.DataAccess.CRUD.Subscriptions Namespace


Mailbox.Receipt Event

Mailbox Receipt Event NFX Class Library

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event SubscriptionReceiptEventHandler Receipt
public event SubscriptionReceiptEventHandler Receipt
Public Event Receipt As SubscriptionReceiptEventHandler
Public Event Receipt As SubscriptionReceiptEventHandler
public:
 event SubscriptionReceiptEventHandler^ Receipt {
    void add (SubscriptionReceiptEventHandler^ value);
    void remove (SubscriptionReceiptEventHandler^ value);
}
public:
 event SubscriptionReceiptEventHandler^ Receipt {
    void add (SubscriptionReceiptEventHandler^ value);
    void remove (SubscriptionReceiptEventHandler^ value);
}
member Receipt : IEvent<SubscriptionReceiptEventHandler,
    EventArgs>
member Receipt : IEvent<SubscriptionReceiptEventHandler,
    EventArgs>

Value

Type: NFX.DataAccess.CRUD.Subscriptions SubscriptionReceiptEventHandler
See Also
Mailbox Class
Mailbox Members
NFX.DataAccess.CRUD.Subscriptions Namespace


Subscription Class

Subscription Class NFX Class Library

Represents a subscription to the CRUD Data. Call Dispose() to terminate the subscription.
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.DataAccess.CRUD.Subscriptions SubscriptionAppComponent
NFX.DataAccess.CRUD.Subscriptions Subscription
NFX.DataAccess.Erlang ErlCRUDSubscription

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Subscription : SubscriptionAppComponent,
    INamed
public abstract class Subscription : SubscriptionAppComponent,
    INamed
Public MustInherit Class Subscription
    Inherits SubscriptionAppComponent
    Implements INamed
Public MustInherit Class Subscription
    Inherits SubscriptionAppComponent
    Implements INamed
public ref class Subscription abstract : public SubscriptionAppComponent,
    INamed
public ref class Subscription abstract : public SubscriptionAppComponent,
    INamed
[<AbstractClassAttribute>]
type Subscription =
    class
        inherit SubscriptionAppComponent
        interface INamed
    end
[<AbstractClassAttribute>]
type Subscription =
    class
        inherit SubscriptionAppComponent
        interface INamed
    end
See Also
Subscription Members
NFX.DataAccess.CRUD.Subscriptions Namespace


Subscription Members

Subscription Members NFX Class Library

The Subscription type exposes the following members.
Constructors
 | Name | Description
Protected method | Subscription | Initializes a new instance of the Subscription class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from SubscriptionAppComponent.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from SubscriptionAppComponent.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from SubscriptionAppComponent.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | HasLoaded | Call after subscription has been initialized
Protected method | Invalidate | Called by descendants to invalidate this subscription
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Correlate | Allows to attach arbtrary bject for correlation
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from SubscriptionAppComponent.)
Public property | InvalidSubscriptionException | If this property is not null then this subscription is !IsValid
Public property | IsLoaded |
Public property | IsValid | Returns false when this subscription experienced InvalidSubscriptionException
Public property | Mailbox |
Public property | Name |
Public property | Query |
Public property | Store |
Back to Top
See Also
Subscription Class
NFX.DataAccess.CRUD.Subscriptions Namespace


Subscription Constructor

Subscription Constructor NFX Class Library

Initializes a new instance of the Subscription class

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Subscription(
    ICRUDSubscriptionStoreImplementation store,
    string name,
    Query query,
    Mailbox mailbox,
    Object correlate
)
protected Subscription(
    ICRUDSubscriptionStoreImplementation store,
    string name,
    Query query,
    Mailbox mailbox,
    Object correlate
)
Protected Sub New (
    store As ICRUDSubscriptionStoreImplementation,
    name As String,
    query As Query,
    mailbox As Mailbox,
    correlate As Object
)
Protected Sub New (
    store As ICRUDSubscriptionStoreImplementation,
    name As String,
    query As Query,
    mailbox As Mailbox,
    correlate As Object
)
protected:
Subscription(
    ICRUDSubscriptionStoreImplementation^ store,
    String^ name,
    Query^ query,
    Mailbox^ mailbox,
    Object^ correlate
)
protected:
Subscription(
    ICRUDSubscriptionStoreImplementation^ store,
    String^ name,
    Query^ query,
    Mailbox^ mailbox,
    Object^ correlate
)
new :
        store : ICRUDSubscriptionStoreImplementation *
        name : string *
        query : Query *
        mailbox : Mailbox *
        correlate : Object -> Subscription
new :
        store : ICRUDSubscriptionStoreImplementation *
        name : string *
        query : Query *
        mailbox : Mailbox *
        correlate : Object -> Subscription

Parameters

store
Type: NFX.DataAccess.CRUD.Subscriptions ICRUDSubscriptionStoreImplementation
name
Type: Online System String
query
Type: NFX.DataAccess.CRUD Query
mailbox
Type: NFX.DataAccess.CRUD.Subscriptions Mailbox
correlate
Type: Online System Object
See Also
Subscription Class
Subscription Members
NFX.DataAccess.CRUD.Subscriptions Namespace


Subscription Methods

Subscription Methods NFX Class Library

The Subscription type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from SubscriptionAppComponent.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from SubscriptionAppComponent.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from SubscriptionAppComponent.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | HasLoaded | Call after subscription has been initialized
Protected method | Invalidate | Called by descendants to invalidate this subscription
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Subscription Class
NFX.DataAccess.CRUD.Subscriptions Namespace


Subscription.Destructor Method

Subscription Destructor Method NFX Class Library

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
Subscription Class
Subscription Members
NFX.DataAccess.CRUD.Subscriptions Namespace


Subscription.HasLoaded Method

Subscription HasLoaded Method NFX Class Library

Call after subscription has been initialized

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void HasLoaded()
protected void HasLoaded()
Protected Sub HasLoaded
Protected Sub HasLoaded
protected:
void HasLoaded()
protected:
void HasLoaded()
member HasLoaded : unit -> unit
member HasLoaded : unit -> unit
See Also
Subscription Class
Subscription Members
NFX.DataAccess.CRUD.Subscriptions Namespace


Subscription.Invalidate Method

Subscription Invalidate Method NFX Class Library

Called by descendants to invalidate this subscription

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void Invalidate(
    InvalidSubscriptionRequestException error
)
protected void Invalidate(
    InvalidSubscriptionRequestException error
)
Protected Sub Invalidate (
    error As InvalidSubscriptionRequestException
)
Protected Sub Invalidate (
    error As InvalidSubscriptionRequestException
)
protected:
void Invalidate(
    InvalidSubscriptionRequestException^ error
)
protected:
void Invalidate(
    InvalidSubscriptionRequestException^ error
)
member Invalidate :
        error : InvalidSubscriptionRequestException -> unit
member Invalidate :
        error : InvalidSubscriptionRequestException -> unit

Parameters

error
Type: NFX.DataAccess.CRUD.Subscriptions InvalidSubscriptionRequestException
See Also
Subscription Class
Subscription Members
NFX.DataAccess.CRUD.Subscriptions Namespace


Subscription Properties

Subscription Properties NFX Class Library

The Subscription type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Correlate | Allows to attach arbtrary bject for correlation
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from SubscriptionAppComponent.)
Public property | InvalidSubscriptionException | If this property is not null then this subscription is !IsValid
Public property | IsLoaded |
Public property | IsValid | Returns false when this subscription experienced InvalidSubscriptionException
Public property | Mailbox |
Public property | Name |
Public property | Query |
Public property | Store |
Back to Top
See Also
Subscription Class
NFX.DataAccess.CRUD.Subscriptions Namespace


Subscription.Correlate Property

Subscription Correlate Property NFX Class Library

Allows to attach arbtrary bject for correlation

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Correlate { get; set; }
public Object Correlate { get; set; }
Public Property Correlate As Object
    Get
    Set
Public Property Correlate As Object
    Get
    Set
public:
property Object^ Correlate {
    Object^ get ();
    void set (Object^ value);
}
public:
property Object^ Correlate {
    Object^ get ();
    void set (Object^ value);
}
member Correlate : Object with get, set
member Correlate : Object with get, set

Property Value

Type: Online Object
See Also
Subscription Class
Subscription Members
NFX.DataAccess.CRUD.Subscriptions Namespace


Subscription.InvalidSubscriptionException Property

Subscription InvalidSubscriptionException Property NFX Class Library

[This is preliminary documentation and is subject to change.]

If this property is not null then this subscription is !IsValid

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InvalidSubscriptionRequestException InvalidSubscriptionException { get; }
public InvalidSubscriptionRequestException InvalidSubscriptionException { get; }
Public ReadOnly Property InvalidSubscriptionException As InvalidSubscriptionRequestException
    Get
Public ReadOnly Property InvalidSubscriptionException As InvalidSubscriptionRequestException
    Get
public:
property InvalidSubscriptionRequestException^ InvalidSubscriptionException {
    InvalidSubscriptionRequestException^ get ();
}
public:
property InvalidSubscriptionRequestException^ InvalidSubscriptionException {
    InvalidSubscriptionRequestException^ get ();
}
member InvalidSubscriptionException : InvalidSubscriptionRequestException with get
member InvalidSubscriptionException : InvalidSubscriptionRequestException with get

Property Value

Type: InvalidSubscriptionRequestException
See Also
Subscription Class
Subscription Members
NFX.DataAccess.CRUD.Subscriptions Namespace


Subscription.IsLoaded Property

Subscription IsLoaded Property NFX Class Library

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsLoaded { get; }
public bool IsLoaded { get; }
Public ReadOnly Property IsLoaded As Boolean
    Get
Public ReadOnly Property IsLoaded As Boolean
    Get
public:
property bool IsLoaded {
    bool get ();
}
public:
property bool IsLoaded {
    bool get ();
}
member IsLoaded : bool with get
member IsLoaded : bool with get

Property Value

Type: Online Boolean
See Also
Subscription Class
Subscription Members
NFX.DataAccess.CRUD.Subscriptions Namespace


Subscription.IsValid Property

Subscription IsValid Property NFX Class Library

Returns false when this subscription experienced InvalidSubscriptionException

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsValid { get; }
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get
Public ReadOnly Property IsValid As Boolean
    Get
public:
property bool IsValid {
    bool get ();
}
public:
property bool IsValid {
    bool get ();
}
member IsValid : bool with get
member IsValid : bool with get

Property Value

Type: Online Boolean
See Also
Subscription Class
Subscription Members
NFX.DataAccess.CRUD.Subscriptions Namespace


Subscription.Mailbox Property

Subscription Mailbox Property NFX Class Library

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Mailbox Mailbox { get; }
public Mailbox Mailbox { get; }
Public ReadOnly Property Mailbox As Mailbox
    Get
Public ReadOnly Property Mailbox As Mailbox
    Get
public:
property Mailbox^ Mailbox {
    Mailbox^ get ();
}
public:
property Mailbox^ Mailbox {
    Mailbox^ get ();
}
member Mailbox : Mailbox with get
member Mailbox : Mailbox with get

Property Value

Type: Mailbox
See Also
Subscription Class
Subscription Members
NFX.DataAccess.CRUD.Subscriptions Namespace


Subscription.Name Property

Subscription Name Property NFX Class Library

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
Subscription Class
Subscription Members
NFX.DataAccess.CRUD.Subscriptions Namespace


Subscription.Query Property

Subscription Query Property NFX Class Library

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Query Query { get; }
public Query Query { get; }
Public ReadOnly Property Query As Query
    Get
Public ReadOnly Property Query As Query
    Get
public:
property Query^ Query {
    Query^ get ();
}
public:
property Query^ Query {
    Query^ get ();
}
member Query : Query with get
member Query : Query with get

Property Value

Type: Query
See Also
Subscription Class
Subscription Members
NFX.DataAccess.CRUD.Subscriptions Namespace


Subscription.Store Property

Subscription Store Property NFX Class Library

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICRUDSubscriptionStore Store { get; }
public ICRUDSubscriptionStore Store { get; }
Public ReadOnly Property Store As ICRUDSubscriptionStore
    Get
Public ReadOnly Property Store As ICRUDSubscriptionStore
    Get
public:
property ICRUDSubscriptionStore^ Store {
    ICRUDSubscriptionStore^ get ();
}
public:
property ICRUDSubscriptionStore^ Store {
    ICRUDSubscriptionStore^ get ();
}
member Store : ICRUDSubscriptionStore with get
member Store : ICRUDSubscriptionStore with get

Property Value

Type: ICRUDSubscriptionStore
See Also
Subscription Class
Subscription Members
NFX.DataAccess.CRUD.Subscriptions Namespace


SubscriptionAppComponent Class

SubscriptionAppComponent Class NFX Class Library

Base type for externally parametrized app components that are used throughout Subscription implementation
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.DataAccess.CRUD.Subscriptions SubscriptionAppComponent
NFX.DataAccess.CRUD.Subscriptions Mailbox
NFX.DataAccess.CRUD.Subscriptions Subscription

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class SubscriptionAppComponent : ApplicationComponent,
    IExternallyParameterized
public abstract class SubscriptionAppComponent : ApplicationComponent,
    IExternallyParameterized
Public MustInherit Class SubscriptionAppComponent
    Inherits ApplicationComponent
    Implements IExternallyParameterized
Public MustInherit Class SubscriptionAppComponent
    Inherits ApplicationComponent
    Implements IExternallyParameterized
public ref class SubscriptionAppComponent abstract : public ApplicationComponent,
    IExternallyParameterized
public ref class SubscriptionAppComponent abstract : public ApplicationComponent,
    IExternallyParameterized
[<AbstractClassAttribute>]
type SubscriptionAppComponent =
    class
        inherit ApplicationComponent
        interface IExternallyParameterized
    end
[<AbstractClassAttribute>]
type SubscriptionAppComponent =
    class
        inherit ApplicationComponent
        interface IExternallyParameterized
    end
See Also
SubscriptionAppComponent Members
NFX.DataAccess.CRUD.Subscriptions Namespace


SubscriptionAppComponent Members

SubscriptionAppComponent Members NFX Class Library

The SubscriptionAppComponent type exposes the following members.
Constructors
 | Name | Description
Protected method | SubscriptionAppComponent | Initializes a new instance of the SubscriptionAppComponent class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component
Back to Top
See Also
SubscriptionAppComponent Class
NFX.DataAccess.CRUD.Subscriptions Namespace


SubscriptionAppComponent Constructor

SubscriptionAppComponent Constructor NFX Class Library

Initializes a new instance of the SubscriptionAppComponent class

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected SubscriptionAppComponent(
    Object director
)
protected SubscriptionAppComponent(
    Object director
)
Protected Sub New (
    director As Object
)
Protected Sub New (
    director As Object
)
protected:
SubscriptionAppComponent(
    Object^ director
)
protected:
SubscriptionAppComponent(
    Object^ director
)
new :
        director : Object -> SubscriptionAppComponent
new :
        director : Object -> SubscriptionAppComponent

Parameters

director
Type: Online System Object
See Also
SubscriptionAppComponent Class
SubscriptionAppComponent Members
NFX.DataAccess.CRUD.Subscriptions Namespace


SubscriptionAppComponent Methods

SubscriptionAppComponent Methods NFX Class Library

The SubscriptionAppComponent type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SubscriptionAppComponent Class
NFX.DataAccess.CRUD.Subscriptions Namespace


SubscriptionAppComponent.ExternalGetParameter Method

SubscriptionAppComponent ExternalGetParameter Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets external parameter value returning true if parameter was found

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
public virtual bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
Public Overridable Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
Public Overridable Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
)
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
)
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalGetParameter(String, Object , String )
See Also
SubscriptionAppComponent Class
SubscriptionAppComponent Members
NFX.DataAccess.CRUD.Subscriptions Namespace


SubscriptionAppComponent.ExternalParametersForGroups Method

SubscriptionAppComponent ExternalParametersForGroups Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns named parameters that can be used to control this component

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
public virtual IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
Public Overridable Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
Public Overridable Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
)
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
)
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>

Parameters

groups
Type: Online System String

Return Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParametersForGroups( String )
See Also
SubscriptionAppComponent Class
SubscriptionAppComponent Members
NFX.DataAccess.CRUD.Subscriptions Namespace


SubscriptionAppComponent.ExternalSetParameter Method

SubscriptionAppComponent ExternalSetParameter Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Sets external parameter value returning true if parameter was found and set

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
public virtual bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
Public Overridable Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
Public Overridable Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
)
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
)
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalSetParameter(String, Object, String )
See Also
SubscriptionAppComponent Class
SubscriptionAppComponent Members
NFX.DataAccess.CRUD.Subscriptions Namespace


SubscriptionAppComponent Properties

SubscriptionAppComponent Properties NFX Class Library

The SubscriptionAppComponent type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component
Back to Top
See Also
SubscriptionAppComponent Class
NFX.DataAccess.CRUD.Subscriptions Namespace


SubscriptionAppComponent.ExternalParameters Property

SubscriptionAppComponent ExternalParameters Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns named parameters that can be used to control this component

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
public virtual IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
Public Overridable ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
Public Overridable ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get ();
}
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get ();
}
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get

Property Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParameters
See Also
SubscriptionAppComponent Class
SubscriptionAppComponent Members
NFX.DataAccess.CRUD.Subscriptions Namespace


SubscriptionReceiptEventHandler Delegate

SubscriptionReceiptEventHandler Delegate NFX Class Library

Describes event handlers that get called when data arrives

Namespace: NFX.DataAccess.CRUD.Subscriptions
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void SubscriptionReceiptEventHandler(
    Subscription subscription,
    Mailbox recipient,
    CRUDSubscriptionEvent data,
    Exception error
)
public delegate void SubscriptionReceiptEventHandler(
    Subscription subscription,
    Mailbox recipient,
    CRUDSubscriptionEvent data,
    Exception error
)
Public Delegate Sub SubscriptionReceiptEventHandler (
    subscription As Subscription,
    recipient As Mailbox,
    data As CRUDSubscriptionEvent,
    error As Exception
)
Public Delegate Sub SubscriptionReceiptEventHandler (
    subscription As Subscription,
    recipient As Mailbox,
    data As CRUDSubscriptionEvent,
    error As Exception
)
public delegate void SubscriptionReceiptEventHandler(
    Subscription^ subscription,
    Mailbox^ recipient,
    CRUDSubscriptionEvent data,
    Exception^ error
)
public delegate void SubscriptionReceiptEventHandler(
    Subscription^ subscription,
    Mailbox^ recipient,
    CRUDSubscriptionEvent data,
    Exception^ error
)
type SubscriptionReceiptEventHandler =
    delegate of
        subscription : Subscription *
        recipient : Mailbox *
        data : CRUDSubscriptionEvent *
        error : Exception -> unit
type SubscriptionReceiptEventHandler =
    delegate of
        subscription : Subscription *
        recipient : Mailbox *
        data : CRUDSubscriptionEvent *
        error : Exception -> unit

Parameters

subscription
Type: NFX.DataAccess.CRUD.Subscriptions Subscription
recipient
Type: NFX.DataAccess.CRUD.Subscriptions Mailbox
data
Type: NFX.DataAccess.CRUD.Subscriptions CRUDSubscriptionEvent
error
Type: Online System Exception
See Also
NFX.DataAccess.CRUD.Subscriptions Namespace


NFX.DataAccess.Distributed Namespace

NFX.DataAccess.Distributed Namespace NFX Class Library

Facilitates working with large-scale distributed database systems like the ones used by Google, Facebook, Twitter et. al.
Classes
Class Description
Public class Command
Defines a command sent into an IDistributedDataStore implementor to retrieve or change(if supported) data. A Command is a named bag of paremeters where every parameter has a name and a value. Every command has a unique Identity(GUID) which represents a token of the whole command state (name, type,all params). The identity is used for quick lookup/caching. The identity may be supplied externally as business code may map certain parameters into GUID and later reuse the same GUID to retrieve the cached command result, for example a web server app may cache command "GetPurchases(user=123, year=2015, month=3)" under session key "MY_PURCHASES_201503" to later retrieve a cached (if available) command results from the DB layer, this way the DB server does not have to store the whole commands with all params as the cache key (which would have been slow to compare and would have induced GC pressure). Warning: DO NOT CACHE command identity value on a client (i.e. web page) in an un-encrypted state, as this is a security flaw
Public class Command Param
Represents a distributed command parameter
Public class DataParcelAttribute
Decorates Pacel-derivative classes specifying distributed data store options. Unlike the CRUD family of metadata attributes this attributed is NOT TARGETABLE on purpose beacause different sharding definitions would have affected the properties of the parcel which could have been very complex to maintain/account for. So, every parcel has ONLY ONE set opf metadata definition. In case when different parcel definitions needed a new parcel type should be created which can reuse the payload - this is much easier to implement (two parcels) than targeting within the same parcel. Table mappings are targetable
Public class DistributedDataAccessException
Thrown by distributed data access classes
Public class DistributedDataParcelSerializationException
Thrown by distributed data access classes when parcel serialization problems happen
Public class GDIDRangeComparer
Compares GDID regardless of authority. This is useful for range checking, when authorities generating GDIDs in the same range should be disregarded. Use GDIDRangeComparer.Instance. Only relative range comparison can be made. The Equality returned by this comparer can not be relied upon for GDID comparison as it disregards authority. Equality can only be tested for range comparison.
Public class NullCommandResult
Represents a result of command that is absent. This is needed to distinguish from null reference
Public class Parcel
Describes a data parcel - a piece of logically-grouped data that gets fetched from/comitted into a distributed backend system. Parcels represent an atomic unit of change, a changeset that gets replicated between failover hosts. Every parcel has a Payload property that stores business data of interest that the parcel contains. This class is not thread-safe. Use DeepClone() to create 100% copies for working in multiple threads. This particular class serves as a very base for all Parcel implementations
Public class Parcel TPayload
Describes a data parcel - a piece of logically-grouped data that gets fetched from/comitted into a distributed backend system. Parcels represent an atomic unit of change, a changeset that gets replicated between failover hosts. Every parcel has a Payload property that stores business data of interest that the parcel contains. This class is not thread-safe. This particular class serves as a very base for distributed data store implementations
Public class ParcelSealValidationException
Thrown by Parcel.Seal() method trying to ensure parcel consistency before it gets sealed
Public class ParcelValidationException
Thrown by distributed data access classes to indicate some data validation error
Structures
Structure Description
Public structure CachePolicyData
Holds data per IParcelCachePolicy contract
Public structure GDID
Represents a Global Distributed ID key (key field) used in distributed databases that identify entities with a combination of unsigned 32 bit integer 'Era' and unsigned 64 bit integer 'ID'. The first 32 bit integer is an 'era' in which the 'ID' (64 bit) was created, consequently a GDID is a 12 byte = 96 bit integer that can hold 2^96 = 79,228,162,514,264,337,593,543,950,336 combinations. The ID consists of two segments: 4 bit authority + 60 bits counter. Authority segment occupies the most significant 4 bits of uint64, so the system may efficiently query the data store to identify the highest stored ID value in a range. Authorities identify one of 16 possible ID generation sources in the global distributed system, therefore ID duplications are not possible between authorities. Within a single era, GDID structure may identify 2^60 = 1,152,921,504,606,846,976(per authority) * 16(authorities) = 2^64 = 18,446,744,073,709,551,616 total combinations. Because of such a large number of combinations supported by GDID.ID alone (having the same Era), some systems may always use Era=0 and only store the ID part (i.e. as UNSIGNED BIGINT in SQL datastores). Note GDID.Zero is never returned by generators as it represents the absence of a value
Public structure GDIDSymbol
Represents a tuple of GDID and its symbolic representation (framework usualy uses an ELink as symbolic representation). This struct is needed to pass GDID along with its ELink representation together. Keep in mind that string poses a GC load, so this stuct is not suitable for beiing used as a pile cache key
Public structure ShardingPointer
Contains information about sharding parcel type and ID which is used to calculate the physical location of parcel data
Public structure TargetTableMapping
Provides information about targetname->table name, sequence name(and possibly other) mappings
Interfaces
 | Interface | Description
Public interface | IArea | Provides information about an area of a bank schema. This information does not depend on a particular bank instance, as it is common for all banks that implement the same schema. Area provides configuration information for parcels that it can store. Every instance of this (interface-implementer) class has a corresponding IAreaInstance instance that stores information for every particular bank, i.e. what distribution policies are applied (such as sharding) to the parcels stored in this area
Public interface | IAreaInstance | Represents data for a concrete instance of schema area within banks, this depends on a concrete bank instance (unlike it's complementary part IArea)
Public interface | IBank | Provides abstraction for Global Database Bank instance
Public interface | ICachePolicy |
Public interface | IDistributedDataStore | Represents a data store that works with large distributed systems that support OLTP-style processing and provide data querying, caching, partitioning/sharding, failover and replication. These systems are designed to handle billions of rows that need to be accessed by millions of active concurrent users, so the design is specific to this model that scales horizontally. There is no need to use this technology for medium and smaller data stores as it imposes specific requirements on how application is written/interacts with the backend system. This technology is based on the idea of Parcels - an atomic unit of data change. Parcels get replicated between hosts for failover and performance reasons. Note: NFX library does not provide the implementation for this technology, only marker interfaces so developers can plan for distributed backends in future
Public interface | IDistributedDataStoreImplementation |
Public interface | IDistributedStableHashProvider | Denotes entities that provide ULONG STABLE hash code for use in a distributed (large scale) system. This is needed primarily for cluster/large datasets to properly compute 64bit sharding addresses and to differentiate from GetHashCode() that returns 32 bits unstable hash for local object location in hashtables. DO not confuse with object.GetHashCode() which is un-suitable for long-term persistence
Public interface | IReplicatable | Denotes a distributed entity that can be replicated to a different location/site/instance. Normally only Parcel and its derivatives should implement this interface
Public interface | IReplicationVersionInfo |
Public interface | ISchema | Provides information about schema of data store banks. Schema defines areas of the bank, where every area defines what parcel types can be stored. Each bank implements only one bank schema
Public interface | IShardingPointerProvider | Denotes an entity which provides a sharding parcel type along with sharding ID (ShardingPointer) that can be used to determine data location via conversion of this id into physical shard #(particular server) that this entity represents
Enumerations
 | Enumeration | Description
Public enumeration | DataCaching | Stipulates where data gets cached
Public enumeration | DataVeracity | Stipulates levels of data fidality, the higher the level - the more accurately verified data is provided
Public enumeration | ParcelState | Represents data parcel states - creating, modifying, sealed


CachePolicyData Structure

CachePolicyData Structure NFX Class Library

Holds data per IParcelCachePolicy contract

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct CachePolicyData : ICachePolicy
public struct CachePolicyData : ICachePolicy
Public Structure CachePolicyData
    Implements ICachePolicy
Public Structure CachePolicyData
    Implements ICachePolicy
public value class CachePolicyData : ICachePolicy
public value class CachePolicyData : ICachePolicy
[<SealedAttribute>]
type CachePolicyData =
    struct
        interface ICachePolicy
    end
[<SealedAttribute>]
type CachePolicyData =
    struct
        interface ICachePolicy
    end
See Also
CachePolicyData Members
NFX.DataAccess.Distributed Namespace


CachePolicyData Members

CachePolicyData Members NFX Class Library

The CachePolicyData type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | CacheAbsoluteExpirationUTC |
Public property | CachePriority |
Public property | CacheReadMaxAgeSec |
Public property | CacheTableName |
Public property | CacheWriteMaxAgeSec |
Back to Top
See Also
CachePolicyData Structure
NFX.DataAccess.Distributed Namespace


CachePolicyData Methods

CachePolicyData Methods NFX Class Library

The CachePolicyData type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CachePolicyData Structure
NFX.DataAccess.Distributed Namespace


CachePolicyData Properties

CachePolicyData Properties NFX Class Library

The CachePolicyData type exposes the following members.
Properties
 | Name | Description
Public property | CacheAbsoluteExpirationUTC |
Public property | CachePriority |
Public property | CacheReadMaxAgeSec |
Public property | CacheTableName |
Public property | CacheWriteMaxAgeSec |
Back to Top
See Also
CachePolicyData Structure
NFX.DataAccess.Distributed Namespace


CachePolicyData.CacheAbsoluteExpirationUTC Property

CachePolicyData CacheAbsoluteExpirationUTC Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> CacheAbsoluteExpirationUTC { get; internal set; }
public Nullable<DateTime> CacheAbsoluteExpirationUTC { get; internal set; }
Public Property CacheAbsoluteExpirationUTC As Nullable(Of DateTime)
    Get
    Friend Set
Public Property CacheAbsoluteExpirationUTC As Nullable(Of DateTime)
    Get
    Friend Set
public:
virtual property Nullable<DateTime> CacheAbsoluteExpirationUTC {
    Nullable<DateTime> get () sealed;
    internal: void set (Nullable<DateTime> value) sealed;
}
public:
virtual property Nullable<DateTime> CacheAbsoluteExpirationUTC {
    Nullable<DateTime> get () sealed;
    internal: void set (Nullable<DateTime> value) sealed;
}
abstract CacheAbsoluteExpirationUTC : Nullable<DateTime> with get, internal set
override CacheAbsoluteExpirationUTC : Nullable<DateTime> with get, internal set
abstract CacheAbsoluteExpirationUTC : Nullable<DateTime> with get, internal set
override CacheAbsoluteExpirationUTC : Nullable<DateTime> with get, internal set

Property Value

Type: Online Nullable Online DateTime

Implements

ICachePolicy CacheAbsoluteExpirationUTC
See Also
CachePolicyData Structure
CachePolicyData Members
NFX.DataAccess.Distributed Namespace


CachePolicyData.CachePriority Property

CachePolicyData CachePriority Property NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<int> CachePriority { get; internal set; }
public Nullable<int> CachePriority { get; internal set; }
Public Property CachePriority As Nullable(Of Integer)
    Get
    Friend Set
Public Property CachePriority As Nullable(Of Integer)
    Get
    Friend Set
public:
virtual property Nullable<int> CachePriority {
    Nullable<int> get () sealed;
    internal: void set (Nullable<int> value) sealed;
}
public:
virtual property Nullable<int> CachePriority {
    Nullable<int> get () sealed;
    internal: void set (Nullable<int> value) sealed;
}
abstract CachePriority : Nullable<int> with get, internal set
override CachePriority : Nullable<int> with get, internal set
abstract CachePriority : Nullable<int> with get, internal set
override CachePriority : Nullable<int> with get, internal set

Property Value

Type: Online Nullable Online Int32

Implements

ICachePolicy CachePriority
See Also
CachePolicyData Structure
CachePolicyData Members
NFX.DataAccess.Distributed Namespace


CachePolicyData.CacheReadMaxAgeSec Property

CachePolicyData CacheReadMaxAgeSec Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<int> CacheReadMaxAgeSec { get; internal set; }
public Nullable<int> CacheReadMaxAgeSec { get; internal set; }
Public Property CacheReadMaxAgeSec As Nullable(Of Integer)
    Get
    Friend Set
Public Property CacheReadMaxAgeSec As Nullable(Of Integer)
    Get
    Friend Set
public:
virtual property Nullable<int> CacheReadMaxAgeSec {
    Nullable<int> get () sealed;
    internal: void set (Nullable<int> value) sealed;
}
public:
virtual property Nullable<int> CacheReadMaxAgeSec {
    Nullable<int> get () sealed;
    internal: void set (Nullable<int> value) sealed;
}
abstract CacheReadMaxAgeSec : Nullable<int> with get, internal set
override CacheReadMaxAgeSec : Nullable<int> with get, internal set
abstract CacheReadMaxAgeSec : Nullable<int> with get, internal set
override CacheReadMaxAgeSec : Nullable<int> with get, internal set

Property Value

Type: Online Nullable Online Int32

Implements

ICachePolicy CacheReadMaxAgeSec
See Also
CachePolicyData Structure
CachePolicyData Members
NFX.DataAccess.Distributed Namespace


CachePolicyData.CacheTableName Property

CachePolicyData CacheTableName Property NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CacheTableName { get; internal set; }
public string CacheTableName { get; internal set; }
Public Property CacheTableName As String
    Get
    Friend Set
Public Property CacheTableName As String
    Get
    Friend Set
public:
virtual property String^ CacheTableName {
    String^ get () sealed;
    internal: void set (String^ value) sealed;
}
public:
virtual property String^ CacheTableName {
    String^ get () sealed;
    internal: void set (String^ value) sealed;
}
abstract CacheTableName : string with get, internal set
override CacheTableName : string with get, internal set
abstract CacheTableName : string with get, internal set
override CacheTableName : string with get, internal set

Property Value

Type: Online String

Implements

ICachePolicy CacheTableName
See Also
CachePolicyData Structure
CachePolicyData Members
NFX.DataAccess.Distributed Namespace


CachePolicyData.CacheWriteMaxAgeSec Property

CachePolicyData CacheWriteMaxAgeSec Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<int> CacheWriteMaxAgeSec { get; internal set; }
public Nullable<int> CacheWriteMaxAgeSec { get; internal set; }
Public Property CacheWriteMaxAgeSec As Nullable(Of Integer)
    Get
    Friend Set
Public Property CacheWriteMaxAgeSec As Nullable(Of Integer)
    Get
    Friend Set
public:
virtual property Nullable<int> CacheWriteMaxAgeSec {
    Nullable<int> get () sealed;
    internal: void set (Nullable<int> value) sealed;
}
public:
virtual property Nullable<int> CacheWriteMaxAgeSec {
    Nullable<int> get () sealed;
    internal: void set (Nullable<int> value) sealed;
}
abstract CacheWriteMaxAgeSec : Nullable<int> with get, internal set
override CacheWriteMaxAgeSec : Nullable<int> with get, internal set
abstract CacheWriteMaxAgeSec : Nullable<int> with get, internal set
override CacheWriteMaxAgeSec : Nullable<int> with get, internal set

Property Value

Type: Online Nullable Online Int32

Implements

ICachePolicy CacheWriteMaxAgeSec
See Also
CachePolicyData Structure
CachePolicyData Members
NFX.DataAccess.Distributed Namespace


Command Class

Command Class NFX Class Library

Defines a command sent into an IDistributedDataStore implementor to retrieve or change(if supported) data. A Command is a named bag of paremeters where every parameter has a name and a value. Every command has a unique Identity(GUID) which represents a token of the whole command state (name, type,all params). The identity is used for quick lookup/caching. The identity may be supplied externally as business code may map certain parameters into GUID and later reuse the same GUID to retrieve the cached command result, for example a web server app may cache command "GetPurchases(user=123, year=2015, month=3)" under session key "MY_PURCHASES_201503" to later retrieve a cached (if available) command results from the DB layer, this way the DB server does not have to store the whole commands with all params as the cache key (which would have been slow to compare and would have induced GC pressure). Warning: DO NOT CACHE command identity value on a client (i.e. web page) in an un-encrypted state, as this is a security flaw
Inheritance Hierarchy
Online System Object
Online System.Collections.Generic List Command Param
NFX.DataAccess.Distributed Command

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class Command : List<Command..::..Param>,
    INamed, IShardingPointerProvider, ICachePolicy
[SerializableAttribute]
public class Command : List<Command..::..Param>,
    INamed, IShardingPointerProvider, ICachePolicy
<SerializableAttribute>
Public Class Command
    Inherits List(Of Command..::..Param)
    Implements INamed, IShardingPointerProvider, ICachePolicy
<SerializableAttribute>
Public Class Command
    Inherits List(Of Command..::..Param)
    Implements INamed, IShardingPointerProvider, ICachePolicy
[SerializableAttribute]
public ref class Command : public List<Command..::..Param^>,
    INamed, IShardingPointerProvider, ICachePolicy
[SerializableAttribute]
public ref class Command : public List<Command..::..Param^>,
    INamed, IShardingPointerProvider, ICachePolicy
[<SerializableAttribute>]
type Command =
    class
        inherit List<Command..::..Param>
        interface INamed
        interface IShardingPointerProvider
        interface ICachePolicy
    end
[<SerializableAttribute>]
type Command =
    class
        inherit List<Command..::..Param>
        interface INamed
        interface IShardingPointerProvider
        interface ICachePolicy
    end
See Also
Command Members
NFX.DataAccess.Distributed Namespace


Command Members

Command Members NFX Class Library

The Command type exposes the following members.
Constructors
 | Name | Description
Public method | Command(Nullable Guid , String, Command Param ) | Initializes a new instance of the Command class
Public method | Command(Nullable Guid , String, Parcel, Command Param ) | Initializes a new instance of the Command class
Public method | Command(Nullable Guid , String, ShardingPointer, Command Param ) | Initializes a new instance of the Command class
Back to Top
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List Command Param .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List Command Param .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List Command Param .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List Command Param .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Command Param .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Command Param .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List Command Param .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List Command Param .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List Command Param .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List Command Param .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Command Param .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Command Param .)
Public method | Equals | (Overrides Online Object Equals(Object).)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List Command Param .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List Command Param .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Command Param .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Command Param .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Command Param .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Command Param .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List Command Param .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Command Param .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Command Param .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Command Param .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List Command Param .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List Command Param .)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List Command Param .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Command Param .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Command Param .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Command Param .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List Command Param .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List Command Param .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Command Param .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Command Param .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Command Param .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List Command Param .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Command Param .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List Command Param .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List Command Param .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List Command Param .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List Command Param .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List Command Param .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List Command Param .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List Command Param .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List Command Param .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List Command Param .)
Public method | ToString | (Overrides Online Object ToString .)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List Command Param .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List Command Param .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | CacheAbsoluteExpirationUTC | Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a different absolute cache expiration UTC timestamp for this command data that may depend on particular command state (i.e. field values).
Public property | CachePriority | Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a relative cache priority of this command data that may depend on particular command state (i.e. param values).
Public property | CacheReadMaxAgeSec | Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a value for maximum validity span of cached command data that may depend on particular command state (i.e. param values).
Public property | CacheWriteMaxAgeSec | Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a value for maximum length of this isntance stay in cache that may depend on particular command state (i.e. param values)
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List Command Param .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List Command Param .)
Public property | Identity | Returns the identity of this instance, that is - an ID that UNIQUELY identifies the instance of this command including all of the names, parameters, values. This is needed for Equality comparison and cache lookup. The identity is either generated by .ctor or supplied to it if it is cached (i.e. in a user session)
Public property | Online Item Int32 | Gets or sets the element at the specified index. (Inherited from Online List Command Param .)
Public property | Item String | Returns parameter by its name or null
Public property | Name | Returns Command name, providers use it to locate modules particular to backend implementation that they represent
Public property | ShardingPointer | Returns the ShardingPointer for this command
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICachePolicy CacheTableName | Implements IParcelCachePolicy contract. The implementation returns null for commands
Back to Top
See Also
Command Class
NFX.DataAccess.Distributed Namespace


Command Constructor

Command Constructor NFX Class Library

Overload List
 | Name | Description
Public method | Command(Nullable Guid , String, Command Param ) | Initializes a new instance of the Command class
Public method | Command(Nullable Guid , String, Parcel, Command Param ) | Initializes a new instance of the Command class
Public method | Command(Nullable Guid , String, ShardingPointer, Command Param ) | Initializes a new instance of the Command class
Back to Top
See Also
Command Class
Command Members
NFX.DataAccess.Distributed Namespace


Command Constructor (Nullable(Guid), String, Command.Param[])

Command Constructor (Nullable Guid , String, Command Param ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Command class

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Command(
    Nullable<Guid> identity,
    string name,
    params Command..::..Param[] pars
)
public Command(
    Nullable<Guid> identity,
    string name,
    params Command..::..Param[] pars
)
Public Sub New (
    identity As Nullable(Of Guid),
    name As String,
    ParamArray pars As Command..::..Param()
)
Public Sub New (
    identity As Nullable(Of Guid),
    name As String,
    ParamArray pars As Command..::..Param()
)
public:
Command(
    Nullable<Guid> identity,
    String^ name,
    ... array<Command..::..Param^>^ pars
)
public:
Command(
    Nullable<Guid> identity,
    String^ name,
    ... array<Command..::..Param^>^ pars
)
new :
        identity : Nullable<Guid> *
        name : string *
        pars : Command..::..Param[] -> Command
new :
        identity : Nullable<Guid> *
        name : string *
        pars : Command..::..Param[] -> Command

Parameters

identity
Type: Online System Nullable Online Guid
name
Type: Online System String
pars
Type: NFX.DataAccess.Distributed Command Param
See Also
Command Class
Command Members
Command Overload
NFX.DataAccess.Distributed Namespace


Command Constructor (Nullable(Guid), String, Parcel, Command.Param[])

Command Constructor (Nullable Guid , String, Parcel, Command Param ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Command class

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Command(
    Nullable<Guid> identity,
    string name,
    Parcel shardingParcel,
    params Command..::..Param[] pars
)
public Command(
    Nullable<Guid> identity,
    string name,
    Parcel shardingParcel,
    params Command..::..Param[] pars
)
Public Sub New (
    identity As Nullable(Of Guid),
    name As String,
    shardingParcel As Parcel,
    ParamArray pars As Command..::..Param()
)
Public Sub New (
    identity As Nullable(Of Guid),
    name As String,
    shardingParcel As Parcel,
    ParamArray pars As Command..::..Param()
)
public:
Command(
    Nullable<Guid> identity,
    String^ name,
    Parcel^ shardingParcel,
    ... array<Command..::..Param^>^ pars
)
public:
Command(
    Nullable<Guid> identity,
    String^ name,
    Parcel^ shardingParcel,
    ... array<Command..::..Param^>^ pars
)
new :
        identity : Nullable<Guid> *
        name : string *
        shardingParcel : Parcel *
        pars : Command..::..Param[] -> Command
new :
        identity : Nullable<Guid> *
        name : string *
        shardingParcel : Parcel *
        pars : Command..::..Param[] -> Command

Parameters

identity
Type: Online System Nullable Online Guid
name
Type: Online System String
shardingParcel
Type: NFX.DataAccess.Distributed Parcel
pars
Type: NFX.DataAccess.Distributed Command Param
See Also
Command Class
Command Members
Command Overload
NFX.DataAccess.Distributed Namespace


Command Constructor (Nullable(Guid), String, ShardingPointer, Command.Param[])

Command Constructor (Nullable Guid , String, ShardingPointer, Command Param ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Command class

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Command(
    Nullable<Guid> identity,
    string name,
    ShardingPointer shardingPtr,
    params Command..::..Param[] pars
)
public Command(
    Nullable<Guid> identity,
    string name,
    ShardingPointer shardingPtr,
    params Command..::..Param[] pars
)
Public Sub New (
    identity As Nullable(Of Guid),
    name As String,
    shardingPtr As ShardingPointer,
    ParamArray pars As Command..::..Param()
)
Public Sub New (
    identity As Nullable(Of Guid),
    name As String,
    shardingPtr As ShardingPointer,
    ParamArray pars As Command..::..Param()
)
public:
Command(
    Nullable<Guid> identity,
    String^ name,
    ShardingPointer shardingPtr,
    ... array<Command..::..Param^>^ pars
)
public:
Command(
    Nullable<Guid> identity,
    String^ name,
    ShardingPointer shardingPtr,
    ... array<Command..::..Param^>^ pars
)
new :
        identity : Nullable<Guid> *
        name : string *
        shardingPtr : ShardingPointer *
        pars : Command..::..Param[] -> Command
new :
        identity : Nullable<Guid> *
        name : string *
        shardingPtr : ShardingPointer *
        pars : Command..::..Param[] -> Command

Parameters

identity
Type: Online System Nullable Online Guid
name
Type: Online System String
shardingPtr
Type: NFX.DataAccess.Distributed ShardingPointer
pars
Type: NFX.DataAccess.Distributed Command Param
See Also
Command Class
Command Members
Command Overload
NFX.DataAccess.Distributed Namespace


Command Methods

Command Methods NFX Class Library

The Command type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List Command Param .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List Command Param .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List Command Param .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List Command Param .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Command Param .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Command Param .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List Command Param .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List Command Param .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List Command Param .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List Command Param .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Command Param .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Command Param .)
Public method | Equals | (Overrides Online Object Equals(Object).)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List Command Param .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List Command Param .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Command Param .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Command Param .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Command Param .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Command Param .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List Command Param .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Command Param .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Command Param .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Command Param .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List Command Param .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List Command Param .)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List Command Param .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Command Param .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Command Param .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Command Param .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List Command Param .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List Command Param .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Command Param .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Command Param .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Command Param .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List Command Param .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Command Param .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List Command Param .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List Command Param .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List Command Param .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List Command Param .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List Command Param .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List Command Param .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List Command Param .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List Command Param .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List Command Param .)
Public method | ToString | (Overrides Online Object ToString .)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List Command Param .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List Command Param .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Command Class
NFX.DataAccess.Distributed Namespace


Command.Equals Method

Command Equals Method NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
Command Class
Command Members
NFX.DataAccess.Distributed Namespace


Command.GetHashCode Method

Command GetHashCode Method NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
Command Class
Command Members
NFX.DataAccess.Distributed Namespace


Command.ToString Method

Command ToString Method NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
Command Class
Command Members
NFX.DataAccess.Distributed Namespace


Command Properties

Command Properties NFX Class Library

The Command type exposes the following members.
Properties
 | Name | Description
Public property | CacheAbsoluteExpirationUTC | Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a different absolute cache expiration UTC timestamp for this command data that may depend on particular command state (i.e. field values).
Public property | CachePriority | Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a relative cache priority of this command data that may depend on particular command state (i.e. param values).
Public property | CacheReadMaxAgeSec | Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a value for maximum validity span of cached command data that may depend on particular command state (i.e. param values).
Public property | CacheWriteMaxAgeSec | Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a value for maximum length of this isntance stay in cache that may depend on particular command state (i.e. param values)
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List Command Param .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List Command Param .)
Public property | Identity | Returns the identity of this instance, that is - an ID that UNIQUELY identifies the instance of this command including all of the names, parameters, values. This is needed for Equality comparison and cache lookup. The identity is either generated by .ctor or supplied to it if it is cached (i.e. in a user session)
Public property | Online Item Int32 | Gets or sets the element at the specified index. (Inherited from Online List Command Param .)
Public property | Item String | Returns parameter by its name or null
Public property | Name | Returns Command name, providers use it to locate modules particular to backend implementation that they represent
Public property | ShardingPointer | Returns the ShardingPointer for this command
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICachePolicy CacheTableName | Implements IParcelCachePolicy contract. The implementation returns null for commands
Back to Top
See Also
Command Class
NFX.DataAccess.Distributed Namespace


Command.CacheAbsoluteExpirationUTC Property

Command CacheAbsoluteExpirationUTC Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a different absolute cache expiration UTC timestamp for this command data that may depend on particular command state (i.e. field values).

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> CacheAbsoluteExpirationUTC { get; }
public Nullable<DateTime> CacheAbsoluteExpirationUTC { get; }
Public ReadOnly Property CacheAbsoluteExpirationUTC As Nullable(Of DateTime)
    Get
Public ReadOnly Property CacheAbsoluteExpirationUTC As Nullable(Of DateTime)
    Get
public:
virtual property Nullable<DateTime> CacheAbsoluteExpirationUTC {
    Nullable<DateTime> get () sealed;
}
public:
virtual property Nullable<DateTime> CacheAbsoluteExpirationUTC {
    Nullable<DateTime> get () sealed;
}
abstract CacheAbsoluteExpirationUTC : Nullable<DateTime> with get
override CacheAbsoluteExpirationUTC : Nullable<DateTime> with get
abstract CacheAbsoluteExpirationUTC : Nullable<DateTime> with get
override CacheAbsoluteExpirationUTC : Nullable<DateTime> with get

Property Value

Type: Online Nullable Online DateTime

Implements

ICachePolicy CacheAbsoluteExpirationUTC
See Also
Command Class
Command Members
NFX.DataAccess.Distributed Namespace


Command.CachePriority Property

Command CachePriority Property NFX Class Library

Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a relative cache priority of this command data that may depend on particular command state (i.e. param values).

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Nullable<int> CachePriority { get; }
public virtual Nullable<int> CachePriority { get; }
Public Overridable ReadOnly Property CachePriority As Nullable(Of Integer)
    Get
Public Overridable ReadOnly Property CachePriority As Nullable(Of Integer)
    Get
public:
virtual property Nullable<int> CachePriority {
    Nullable<int> get ();
}
public:
virtual property Nullable<int> CachePriority {
    Nullable<int> get ();
}
abstract CachePriority : Nullable<int> with get
override CachePriority : Nullable<int> with get
abstract CachePriority : Nullable<int> with get
override CachePriority : Nullable<int> with get

Property Value

Type: Online Nullable Online Int32

Implements

ICachePolicy CachePriority
See Also
Command Class
Command Members
NFX.DataAccess.Distributed Namespace


Command.CacheReadMaxAgeSec Property

Command CacheReadMaxAgeSec Property NFX Class Library

Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a value for maximum validity span of cached command data that may depend on particular command state (i.e. param values).

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Nullable<int> CacheReadMaxAgeSec { get; }
public virtual Nullable<int> CacheReadMaxAgeSec { get; }
Public Overridable ReadOnly Property CacheReadMaxAgeSec As Nullable(Of Integer)
    Get
Public Overridable ReadOnly Property CacheReadMaxAgeSec As Nullable(Of Integer)
    Get
public:
virtual property Nullable<int> CacheReadMaxAgeSec {
    Nullable<int> get ();
}
public:
virtual property Nullable<int> CacheReadMaxAgeSec {
    Nullable<int> get ();
}
abstract CacheReadMaxAgeSec : Nullable<int> with get
override CacheReadMaxAgeSec : Nullable<int> with get
abstract CacheReadMaxAgeSec : Nullable<int> with get
override CacheReadMaxAgeSec : Nullable<int> with get

Property Value

Type: Online Nullable Online Int32

Implements

ICachePolicy CacheReadMaxAgeSec
See Also
Command Class
Command Members
NFX.DataAccess.Distributed Namespace


Command.CacheWriteMaxAgeSec Property

Command CacheWriteMaxAgeSec Property NFX Class Library

Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a value for maximum length of this isntance stay in cache that may depend on particular command state (i.e. param values)

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Nullable<int> CacheWriteMaxAgeSec { get; }
public virtual Nullable<int> CacheWriteMaxAgeSec { get; }
Public Overridable ReadOnly Property CacheWriteMaxAgeSec As Nullable(Of Integer)
    Get
Public Overridable ReadOnly Property CacheWriteMaxAgeSec As Nullable(Of Integer)
    Get
public:
virtual property Nullable<int> CacheWriteMaxAgeSec {
    Nullable<int> get ();
}
public:
virtual property Nullable<int> CacheWriteMaxAgeSec {
    Nullable<int> get ();
}
abstract CacheWriteMaxAgeSec : Nullable<int> with get
override CacheWriteMaxAgeSec : Nullable<int> with get
abstract CacheWriteMaxAgeSec : Nullable<int> with get
override CacheWriteMaxAgeSec : Nullable<int> with get

Property Value

Type: Online Nullable Online Int32

Implements

ICachePolicy CacheWriteMaxAgeSec
See Also
Command Class
Command Members
NFX.DataAccess.Distributed Namespace


Command.ICachePolicy.CacheTableName Property

Command ICachePolicy CacheTableName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Implements IParcelCachePolicy contract. The implementation returns null for commands

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string ICachePolicy.CacheTableName { get; }
string ICachePolicy.CacheTableName { get; }
Private ReadOnly Property CacheTableName As String
    Implements ICachePolicy.CacheTableName
    Get
Private ReadOnly Property CacheTableName As String
    Implements ICachePolicy.CacheTableName
    Get
private:
virtual property String^ CacheTableName {
    String^ get () sealed = ICachePolicy::CacheTableName::get;
}
private:
virtual property String^ CacheTableName {
    String^ get () sealed = ICachePolicy::CacheTableName::get;
}
private abstract CacheTableName : string with get
private override CacheTableName : string with get
private abstract CacheTableName : string with get
private override CacheTableName : string with get

Property Value

Type: Online String

Implements

ICachePolicy CacheTableName
See Also
Command Class
Command Members
NFX.DataAccess.Distributed Namespace


Command.Identity Property

Command Identity Property NFX Class Library

Returns the identity of this instance, that is - an ID that UNIQUELY identifies the instance of this command including all of the names, parameters, values. This is needed for Equality comparison and cache lookup. The identity is either generated by .ctor or supplied to it if it is cached (i.e. in a user session)

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid Identity { get; }
public Guid Identity { get; }
Public ReadOnly Property Identity As Guid
    Get
Public ReadOnly Property Identity As Guid
    Get
public:
property Guid Identity {
    Guid get ();
}
public:
property Guid Identity {
    Guid get ();
}
member Identity : Guid with get
member Identity : Guid with get

Property Value

Type: Online Guid
See Also
Command Class
Command Members
NFX.DataAccess.Distributed Namespace


Command.Item Property

Command Item Property NFX Class Library

Overload List
 | Name | Description
Public property | Online Item Int32 | Gets or sets the element at the specified index. (Inherited from Online List Command Param .)
Public property | Item String | Returns parameter by its name or null
Back to Top
See Also
Command Class
Command Members
NFX.DataAccess.Distributed Namespace


Command.Item Property (String)

Command Item Property (String) NFX Class Library

Returns parameter by its name or null

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Command..::..Param this[
    string name
] { get; }
public Command..::..Param this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As Command..::..Param
    Get
Public ReadOnly Default Property Item (
    name As String
) As Command..::..Param
    Get
public:
property Command..::..Param^ default[String^ name] {
    Command..::..Param^ get (String^ name);
}
public:
property Command..::..Param^ default[String^ name] {
    Command..::..Param^ get (String^ name);
}
member Item : Command..::..Param with get
member Item : Command..::..Param with get

Parameters

name
Type: Online System String

Property Value

Type: Command Param
See Also
Command Class
Command Members
Item Overload
NFX.DataAccess.Distributed Namespace


Command.Name Property

Command Name Property NFX Class Library

Returns Command name, providers use it to locate modules particular to backend implementation that they represent

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Name { get; }
public virtual string Name { get; }
Public Overridable ReadOnly Property Name As String
    Get
Public Overridable ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get ();
}
public:
virtual property String^ Name {
    String^ get ();
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
Command Class
Command Members
NFX.DataAccess.Distributed Namespace


Command.ShardingPointer Property

Command ShardingPointer Property NFX Class Library

Returns the ShardingPointer for this command

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual ShardingPointer ShardingPointer { get; }
public virtual ShardingPointer ShardingPointer { get; }
Public Overridable ReadOnly Property ShardingPointer As ShardingPointer
    Get
Public Overridable ReadOnly Property ShardingPointer As ShardingPointer
    Get
public:
virtual property ShardingPointer ShardingPointer {
    ShardingPointer get ();
}
public:
virtual property ShardingPointer ShardingPointer {
    ShardingPointer get ();
}
abstract ShardingPointer : ShardingPointer with get
override ShardingPointer : ShardingPointer with get
abstract ShardingPointer : ShardingPointer with get
override ShardingPointer : ShardingPointer with get

Property Value

Type: ShardingPointer

Implements

IShardingPointerProvider ShardingPointer
See Also
Command Class
Command Members
NFX.DataAccess.Distributed Namespace


Command.Param Class

Command Param Class NFX Class Library

Represents a distributed command parameter
Inheritance Hierarchy
Online System Object
NFX.DataAccess.Distributed Command Param

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class Param
[SerializableAttribute]
public sealed class Param
<SerializableAttribute>
Public NotInheritable Class Param
<SerializableAttribute>
Public NotInheritable Class Param
[SerializableAttribute]
public ref class Param sealed
[SerializableAttribute]
public ref class Param sealed
[<SealedAttribute>]
[<SerializableAttribute>]
type Param =  class end
[<SealedAttribute>]
[<SerializableAttribute>]
type Param =  class end
See Also
Command Param Members
NFX.DataAccess.Distributed Namespace


Command.Param Members

Command Param Members NFX Class Library

The Command Param type exposes the following members.
Constructors
 | Name | Description
Public method | Command Param | Initializes a new instance of the Command Param class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Name |
Public field | Value |
Back to Top
See Also
Command Param Class
NFX.DataAccess.Distributed Namespace


Command.Param Constructor

Command Param Constructor NFX Class Library

Initializes a new instance of the Command Param class

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Param(
    string name,
    Object value = null
)
public Param(
    string name,
    Object value = null
)
Public Sub New (
    name As String,
    Optional value As Object = Nothing
)
Public Sub New (
    name As String,
    Optional value As Object = Nothing
)
public:
Param(
    String^ name,
    Object^ value = nullptr
)
public:
Param(
    String^ name,
    Object^ value = nullptr
)
new :
        name : string *
        ?value : Object
(* Defaults:
        let _value = defaultArg value null
*)
-> Param
new :
        name : string *
        ?value : Object
(* Defaults:
        let _value = defaultArg value null
*)
-> Param

Parameters

name
Type: Online System String
value (Optional)
Type: Online System Object
See Also
Command Param Class
Command Param Members
NFX.DataAccess.Distributed Namespace


Command.Param Fields

Command Param Fields NFX Class Library

The Command Param type exposes the following members.
Fields
 | Name | Description
Public field | Name |
Public field | Value |
Back to Top
See Also
Command Param Class
NFX.DataAccess.Distributed Namespace


Command.Param.Name Field

Command Param Name Field NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Name
public readonly string Name
Public ReadOnly Name As String
Public ReadOnly Name As String
public:
initonly String^ Name
public:
initonly String^ Name
val Name: string
val Name: string

Field Value

Type: Online String
See Also
Command Param Class
Command Param Members
NFX.DataAccess.Distributed Namespace


Command.Param.Value Field

Command Param Value Field NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Object Value
public readonly Object Value
Public ReadOnly Value As Object
Public ReadOnly Value As Object
public:
initonly Object^ Value
public:
initonly Object^ Value
val Value: Object
val Value: Object

Field Value

Type: Online Object
See Also
Command Param Class
Command Param Members
NFX.DataAccess.Distributed Namespace


Command.Param Methods

Command Param Methods NFX Class Library

The Command Param type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Command Param Class
NFX.DataAccess.Distributed Namespace


Command.Param.ToString Method

Command Param ToString Method NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
Command Param Class
Command Param Members
NFX.DataAccess.Distributed Namespace


DataCaching Enumeration

DataCaching Enumeration NFX Class Library

Stipulates where data gets cached

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum DataCaching
public enum DataCaching
Public Enumeration DataCaching
Public Enumeration DataCaching
public enum class DataCaching
public enum class DataCaching
type DataCaching
type DataCaching
Members
Member name | Value | Description
None | -1 | Does not get cached
LatestData | 0 | Gets cached on the level where data is always accurate and never gets stale, i.e. in the BDB server that reflects most recent changes (can not get out of date)
Everywhere | 1 | Gets cached everywhere including system tiers where data can get stale
See Also
NFX.DataAccess.Distributed Namespace


DataParcelAttribute Class

DataParcelAttribute Class NFX Class Library

Decorates Pacel-derivative classes specifying distributed data store options. Unlike the CRUD family of metadata attributes this attributed is NOT TARGETABLE on purpose beacause different sharding definitions would have affected the properties of the parcel which could have been very complex to maintain/account for. So, every parcel has ONLY ONE set opf metadata definition. In case when different parcel definitions needed a new parcel type should be created which can reuse the payload - this is much easier to implement (two parcels) than targeting within the same parcel. Table mappings are targetable
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.DataAccess.Distributed DataParcelAttribute

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false, Inherited = false)]
public sealed class DataParcelAttribute : Attribute,
    ICachePolicy
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false, Inherited = false)]
public sealed class DataParcelAttribute : Attribute,
    ICachePolicy
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := false, Inherited := false)>
Public NotInheritable Class DataParcelAttribute
    Inherits Attribute
    Implements ICachePolicy
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := false, Inherited := false)>
Public NotInheritable Class DataParcelAttribute
    Inherits Attribute
    Implements ICachePolicy
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = false, Inherited = false)]
public ref class DataParcelAttribute sealed : public Attribute,
    ICachePolicy
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = false, Inherited = false)]
public ref class DataParcelAttribute sealed : public Attribute,
    ICachePolicy
[<SealedAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false, Inherited = false)>]
type DataParcelAttribute =
    class
        inherit Attribute
        interface ICachePolicy
    end
[<SealedAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false, Inherited = false)>]
type DataParcelAttribute =
    class
        inherit Attribute
        interface ICachePolicy
    end
See Also
DataParcelAttribute Members
NFX.DataAccess.Distributed Namespace


DataParcelAttribute Members

DataParcelAttribute Members NFX Class Library

The DataParcelAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | DataParcelAttribute | Initializes a new instance of the DataParcelAttribute class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
 | GetParcelAttr | Returns DataParcelAttribute for a parcel type. Use Parcel.MetadataAttribute to obtain the attribute instance polymorphically for instance. If parcel is not decorated by the attribute then exception is thrown
 | getParcelAttrCore |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | AreaName | Specifies the Areaname - the logical subdivision in the store where parcels reside within the schema(see SchemaName): i.e. 'commonClinicalData'. Depending on a particular store setup this logical name may or may not represent physical servers/locations in the store. Every store implementation maps logical paths to physical servers and/or shards. This feature provides very high degree of distributed database design flexibility, as some parcels may represent common/dictionary data that does not need to be sharded, whereas others may represent purely transactional high-volume data that needs to be sharded. The value is required and is always specified or exception is thrown in .ctor
Public property | CacheAbsoluteExpirationUTC | This property can not be set on the attribute level and always returns null
Public property | CachePriority | Specifies the relative cache priority of this parcel This property acts as a default, the runtime first checks parcel instance properties then reverts to this attribute
Public property | CacheReadMaxAgeSec | Specifies the maximum age of parcel instance in cache to be suitable for reading This property acts as a default, the runtime first checks parcel instance properties then reverts to this attribute
Public property | CacheTableName | Specifies the name of the cache table for this parcel This property acts as a default, the runtime first checks parcel instance properties then reverts to this attribute
Public property | CacheWriteMaxAgeSec | Specifies for how long should this parcel be cached in RAM after a write (after a saved change). This property acts as a default, the runtime first checks parcel instance properties then reverts to this attribute
Public property | ReplicationChannel | Specifies the name of the replication channel used to pump data between servers/data centers/locations
Public property | SchemaName | Specifies the name for logical schema that parcel decorated by this attribute belongs to. The exact location within the data store is detailed further with AreaName property. The value is required and is always specified or exception is thrown in .ctor
Public property | ShardingParcel | Specifies the type of Parcel that is used for sharding. By default this parameter is null, so parcels are sharded on their own instance types, however there are cases when a parcel overrides ShardingID and specifies ShardingParcel type via this member so it gets stored along with the specified parcel
Public property | SupportsMerge | Returns true if parcel supports merge with other versions. Server may merge multiple parcel versions to resolve versioning conflict. Default implementation returns false
Public property | TableMappings | Returns mappins of target->table attributes. Pass in [DataParcel(targetTableMappings = "targetName1=tableName1{atr1=v1 atr2=v2...} targetName2=tableName2{atr1=v1 atr2=v2...}...")];
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
DataParcelAttribute Class
NFX.DataAccess.Distributed Namespace


DataParcelAttribute Constructor

DataParcelAttribute Constructor NFX Class Library

Initializes a new instance of the DataParcelAttribute class

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DataParcelAttribute(
    string schemaName,
    string areaName,
    bool supportsMerge = false,
    Type shardingParcel = null,
    string replicationChannel = null,
    string cacheTableName = null,
    int cacheWriteMaxAgeSec = -1,
    int cacheReadMaxAgeSec = -1,
    int cachePriority = -1,
    string targetTableMappings = null
)
public DataParcelAttribute(
    string schemaName,
    string areaName,
    bool supportsMerge = false,
    Type shardingParcel = null,
    string replicationChannel = null,
    string cacheTableName = null,
    int cacheWriteMaxAgeSec = -1,
    int cacheReadMaxAgeSec = -1,
    int cachePriority = -1,
    string targetTableMappings = null
)
Public Sub New (
    schemaName As String,
    areaName As String,
    Optional supportsMerge As Boolean = false,
    Optional shardingParcel As Type = Nothing,
    Optional replicationChannel As String = Nothing,
    Optional cacheTableName As String = Nothing,
    Optional cacheWriteMaxAgeSec As Integer = -1,
    Optional cacheReadMaxAgeSec As Integer = -1,
    Optional cachePriority As Integer = -1,
    Optional targetTableMappings As String = Nothing
)
Public Sub New (
    schemaName As String,
    areaName As String,
    Optional supportsMerge As Boolean = false,
    Optional shardingParcel As Type = Nothing,
    Optional replicationChannel As String = Nothing,
    Optional cacheTableName As String = Nothing,
    Optional cacheWriteMaxAgeSec As Integer = -1,
    Optional cacheReadMaxAgeSec As Integer = -1,
    Optional cachePriority As Integer = -1,
    Optional targetTableMappings As String = Nothing
)
public:
DataParcelAttribute(
    String^ schemaName,
    String^ areaName,
    bool supportsMerge = false,
    Type^ shardingParcel = nullptr,
    String^ replicationChannel = nullptr,
    String^ cacheTableName = nullptr,
    int cacheWriteMaxAgeSec = -1,
    int cacheReadMaxAgeSec = -1,
    int cachePriority = -1,
    String^ targetTableMappings = nullptr
)
public:
DataParcelAttribute(
    String^ schemaName,
    String^ areaName,
    bool supportsMerge = false,
    Type^ shardingParcel = nullptr,
    String^ replicationChannel = nullptr,
    String^ cacheTableName = nullptr,
    int cacheWriteMaxAgeSec = -1,
    int cacheReadMaxAgeSec = -1,
    int cachePriority = -1,
    String^ targetTableMappings = nullptr
)
new :
        schemaName : string *
        areaName : string *
        ?supportsMerge : bool *
        ?shardingParcel : Type *
        ?replicationChannel : string *
        ?cacheTableName : string *
        ?cacheWriteMaxAgeSec : int *
        ?cacheReadMaxAgeSec : int *
        ?cachePriority : int *
        ?targetTableMappings : string
(* Defaults:
        let _supportsMerge = defaultArg supportsMerge false
        let _shardingParcel = defaultArg shardingParcel null
        let _replicationChannel = defaultArg replicationChannel null
        let _cacheTableName = defaultArg cacheTableName null
        let _cacheWriteMaxAgeSec = defaultArg cacheWriteMaxAgeSec -1
        let _cacheReadMaxAgeSec = defaultArg cacheReadMaxAgeSec -1
        let _cachePriority = defaultArg cachePriority -1
        let _targetTableMappings = defaultArg targetTableMappings null
*)
-> DataParcelAttribute
new :
        schemaName : string *
        areaName : string *
        ?supportsMerge : bool *
        ?shardingParcel : Type *
        ?replicationChannel : string *
        ?cacheTableName : string *
        ?cacheWriteMaxAgeSec : int *
        ?cacheReadMaxAgeSec : int *
        ?cachePriority : int *
        ?targetTableMappings : string
(* Defaults:
        let _supportsMerge = defaultArg supportsMerge false
        let _shardingParcel = defaultArg shardingParcel null
        let _replicationChannel = defaultArg replicationChannel null
        let _cacheTableName = defaultArg cacheTableName null
        let _cacheWriteMaxAgeSec = defaultArg cacheWriteMaxAgeSec -1
        let _cacheReadMaxAgeSec = defaultArg cacheReadMaxAgeSec -1
        let _cachePriority = defaultArg cachePriority -1
        let _targetTableMappings = defaultArg targetTableMappings null
*)
-> DataParcelAttribute

Parameters

schemaName
Type: Online System String
areaName
Type: Online System String
supportsMerge (Optional)
Type: Online System Boolean
shardingParcel (Optional)
Type: Online System Type
replicationChannel (Optional)
Type: Online System String
cacheTableName (Optional)
Type: Online System String
cacheWriteMaxAgeSec (Optional)
Type: Online System Int32
cacheReadMaxAgeSec (Optional)
Type: Online System Int32
cachePriority (Optional)
Type: Online System Int32
targetTableMappings (Optional)
Type: Online System String
See Also
DataParcelAttribute Class
DataParcelAttribute Members
NFX.DataAccess.Distributed Namespace


DataParcelAttribute Methods

DataParcelAttribute Methods NFX Class Library

The DataParcelAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
 | GetParcelAttr | Returns DataParcelAttribute for a parcel type. Use Parcel.MetadataAttribute to obtain the attribute instance polymorphically for instance. If parcel is not decorated by the attribute then exception is thrown
 | getParcelAttrCore |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
DataParcelAttribute Class
NFX.DataAccess.Distributed Namespace


DataParcelAttribute.GetParcelAttr Method

DataParcelAttribute GetParcelAttr Method NFX Class Library

Returns DataParcelAttribute for a parcel type. Use Parcel.MetadataAttribute to obtain the attribute instance polymorphically for instance. If parcel is not decorated by the attribute then exception is thrown

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DataParcelAttribute GetParcelAttr(
    Type tparcel
)
public static DataParcelAttribute GetParcelAttr(
    Type tparcel
)
Public Shared Function GetParcelAttr (
    tparcel As Type
) As DataParcelAttribute
Public Shared Function GetParcelAttr (
    tparcel As Type
) As DataParcelAttribute
public:
static DataParcelAttribute^ GetParcelAttr(
    Type^ tparcel
)
public:
static DataParcelAttribute^ GetParcelAttr(
    Type^ tparcel
)
static member GetParcelAttr :
        tparcel : Type -> DataParcelAttribute
static member GetParcelAttr :
        tparcel : Type -> DataParcelAttribute

Parameters

tparcel
Type: Online System Type

Return Value

Type: DataParcelAttribute
See Also
DataParcelAttribute Class
DataParcelAttribute Members
NFX.DataAccess.Distributed Namespace


DataParcelAttribute.getParcelAttrCore Method

DataParcelAttribute getParcelAttrCore Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static DataParcelAttribute getParcelAttrCore(
    Type tparcel
)
internal static DataParcelAttribute getParcelAttrCore(
    Type tparcel
)
Friend Shared Function getParcelAttrCore (
    tparcel As Type
) As DataParcelAttribute
Friend Shared Function getParcelAttrCore (
    tparcel As Type
) As DataParcelAttribute
internal:
static DataParcelAttribute^ getParcelAttrCore(
    Type^ tparcel
)
internal:
static DataParcelAttribute^ getParcelAttrCore(
    Type^ tparcel
)
internal static member getParcelAttrCore :
        tparcel : Type -> DataParcelAttribute
internal static member getParcelAttrCore :
        tparcel : Type -> DataParcelAttribute

Parameters

tparcel
Type: Online System Type

Return Value

Type: DataParcelAttribute
See Also
DataParcelAttribute Class
DataParcelAttribute Members
NFX.DataAccess.Distributed Namespace


DataParcelAttribute Properties

DataParcelAttribute Properties NFX Class Library

The DataParcelAttribute type exposes the following members.
Properties
 | Name | Description
Public property | AreaName | Specifies the Areaname - the logical subdivision in the store where parcels reside within the schema(see SchemaName): i.e. 'commonClinicalData'. Depending on a particular store setup this logical name may or may not represent physical servers/locations in the store. Every store implementation maps logical paths to physical servers and/or shards. This feature provides very high degree of distributed database design flexibility, as some parcels may represent common/dictionary data that does not need to be sharded, whereas others may represent purely transactional high-volume data that needs to be sharded. The value is required and is always specified or exception is thrown in .ctor
Public property | CacheAbsoluteExpirationUTC | This property can not be set on the attribute level and always returns null
Public property | CachePriority | Specifies the relative cache priority of this parcel This property acts as a default, the runtime first checks parcel instance properties then reverts to this attribute
Public property | CacheReadMaxAgeSec | Specifies the maximum age of parcel instance in cache to be suitable for reading This property acts as a default, the runtime first checks parcel instance properties then reverts to this attribute
Public property | CacheTableName | Specifies the name of the cache table for this parcel This property acts as a default, the runtime first checks parcel instance properties then reverts to this attribute
Public property | CacheWriteMaxAgeSec | Specifies for how long should this parcel be cached in RAM after a write (after a saved change). This property acts as a default, the runtime first checks parcel instance properties then reverts to this attribute
Public property | ReplicationChannel | Specifies the name of the replication channel used to pump data between servers/data centers/locations
Public property | SchemaName | Specifies the name for logical schema that parcel decorated by this attribute belongs to. The exact location within the data store is detailed further with AreaName property. The value is required and is always specified or exception is thrown in .ctor
Public property | ShardingParcel | Specifies the type of Parcel that is used for sharding. By default this parameter is null, so parcels are sharded on their own instance types, however there are cases when a parcel overrides ShardingID and specifies ShardingParcel type via this member so it gets stored along with the specified parcel
Public property | SupportsMerge | Returns true if parcel supports merge with other versions. Server may merge multiple parcel versions to resolve versioning conflict. Default implementation returns false
Public property | TableMappings | Returns mappins of target->table attributes. Pass in [DataParcel(targetTableMappings = "targetName1=tableName1{atr1=v1 atr2=v2...} targetName2=tableName2{atr1=v1 atr2=v2...}...")];
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
DataParcelAttribute Class
NFX.DataAccess.Distributed Namespace


DataParcelAttribute.AreaName Property

DataParcelAttribute AreaName Property NFX Class Library

Specifies the Areaname - the logical subdivision in the store where parcels reside within the schema(see SchemaName): i.e. 'commonClinicalData'. Depending on a particular store setup this logical name may or may not represent physical servers/locations in the store. Every store implementation maps logical paths to physical servers and/or shards. This feature provides very high degree of distributed database design flexibility, as some parcels may represent common/dictionary data that does not need to be sharded, whereas others may represent purely transactional high-volume data that needs to be sharded. The value is required and is always specified or exception is thrown in .ctor

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AreaName { get; private set; }
public string AreaName { get; private set; }
Public Property AreaName As String
    Get
    Private Set
Public Property AreaName As String
    Get
    Private Set
public:
property String^ AreaName {
    String^ get ();
    private: void set (String^ value);
}
public:
property String^ AreaName {
    String^ get ();
    private: void set (String^ value);
}
member AreaName : string with get, private set
member AreaName : string with get, private set

Property Value

Type: Online String
Remarks
Keep in mind that in a distributed database system various parcels may be stored not only in different locations, be optionally sharded, and even be stored in different back-end technologies (i.e. NoSQL/RDBMS/flat files)
See Also
DataParcelAttribute Class
DataParcelAttribute Members
NFX.DataAccess.Distributed Namespace


DataParcelAttribute.CacheAbsoluteExpirationUTC Property

DataParcelAttribute CacheAbsoluteExpirationUTC Property NFX Class Library

[This is preliminary documentation and is subject to change.]

This property can not be set on the attribute level and always returns null

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> CacheAbsoluteExpirationUTC { get; }
public Nullable<DateTime> CacheAbsoluteExpirationUTC { get; }
Public ReadOnly Property CacheAbsoluteExpirationUTC As Nullable(Of DateTime)
    Get
Public ReadOnly Property CacheAbsoluteExpirationUTC As Nullable(Of DateTime)
    Get
public:
virtual property Nullable<DateTime> CacheAbsoluteExpirationUTC {
    Nullable<DateTime> get () sealed;
}
public:
virtual property Nullable<DateTime> CacheAbsoluteExpirationUTC {
    Nullable<DateTime> get () sealed;
}
abstract CacheAbsoluteExpirationUTC : Nullable<DateTime> with get
override CacheAbsoluteExpirationUTC : Nullable<DateTime> with get
abstract CacheAbsoluteExpirationUTC : Nullable<DateTime> with get
override CacheAbsoluteExpirationUTC : Nullable<DateTime> with get

Property Value

Type: Online Nullable Online DateTime

Implements

ICachePolicy CacheAbsoluteExpirationUTC
See Also
DataParcelAttribute Class
DataParcelAttribute Members
NFX.DataAccess.Distributed Namespace


DataParcelAttribute.CachePriority Property

DataParcelAttribute CachePriority Property NFX Class Library

Specifies the relative cache priority of this parcel This property acts as a default, the runtime first checks parcel instance properties then reverts to this attribute

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<int> CachePriority { get; private set; }
public Nullable<int> CachePriority { get; private set; }
Public Property CachePriority As Nullable(Of Integer)
    Get
    Private Set
Public Property CachePriority As Nullable(Of Integer)
    Get
    Private Set
public:
virtual property Nullable<int> CachePriority {
    Nullable<int> get () sealed;
    private: void set (Nullable<int> value) sealed;
}
public:
virtual property Nullable<int> CachePriority {
    Nullable<int> get () sealed;
    private: void set (Nullable<int> value) sealed;
}
abstract CachePriority : Nullable<int> with get, private set
override CachePriority : Nullable<int> with get, private set
abstract CachePriority : Nullable<int> with get, private set
override CachePriority : Nullable<int> with get, private set

Property Value

Type: Online Nullable Online Int32

Implements

ICachePolicy CachePriority
See Also
DataParcelAttribute Class
DataParcelAttribute Members
NFX.DataAccess.Distributed Namespace


DataParcelAttribute.CacheReadMaxAgeSec Property

DataParcelAttribute CacheReadMaxAgeSec Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Specifies the maximum age of parcel instance in cache to be suitable for reading This property acts as a default, the runtime first checks parcel instance properties then reverts to this attribute

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<int> CacheReadMaxAgeSec { get; private set; }
public Nullable<int> CacheReadMaxAgeSec { get; private set; }
Public Property CacheReadMaxAgeSec As Nullable(Of Integer)
    Get
    Private Set
Public Property CacheReadMaxAgeSec As Nullable(Of Integer)
    Get
    Private Set
public:
virtual property Nullable<int> CacheReadMaxAgeSec {
    Nullable<int> get () sealed;
    private: void set (Nullable<int> value) sealed;
}
public:
virtual property Nullable<int> CacheReadMaxAgeSec {
    Nullable<int> get () sealed;
    private: void set (Nullable<int> value) sealed;
}
abstract CacheReadMaxAgeSec : Nullable<int> with get, private set
override CacheReadMaxAgeSec : Nullable<int> with get, private set
abstract CacheReadMaxAgeSec : Nullable<int> with get, private set
override CacheReadMaxAgeSec : Nullable<int> with get, private set

Property Value

Type: Online Nullable Online Int32

Implements

ICachePolicy CacheReadMaxAgeSec
See Also
DataParcelAttribute Class
DataParcelAttribute Members
NFX.DataAccess.Distributed Namespace


DataParcelAttribute.CacheTableName Property

DataParcelAttribute CacheTableName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Specifies the name of the cache table for this parcel This property acts as a default, the runtime first checks parcel instance properties then reverts to this attribute

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CacheTableName { get; private set; }
public string CacheTableName { get; private set; }
Public Property CacheTableName As String
    Get
    Private Set
Public Property CacheTableName As String
    Get
    Private Set
public:
virtual property String^ CacheTableName {
    String^ get () sealed;
    private: void set (String^ value) sealed;
}
public:
virtual property String^ CacheTableName {
    String^ get () sealed;
    private: void set (String^ value) sealed;
}
abstract CacheTableName : string with get, private set
override CacheTableName : string with get, private set
abstract CacheTableName : string with get, private set
override CacheTableName : string with get, private set

Property Value

Type: Online String

Implements

ICachePolicy CacheTableName
See Also
DataParcelAttribute Class
DataParcelAttribute Members
NFX.DataAccess.Distributed Namespace


DataParcelAttribute.CacheWriteMaxAgeSec Property

DataParcelAttribute CacheWriteMaxAgeSec Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Specifies for how long should this parcel be cached in RAM after a write (after a saved change). This property acts as a default, the runtime first checks parcel instance properties then reverts to this attribute

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<int> CacheWriteMaxAgeSec { get; private set; }
public Nullable<int> CacheWriteMaxAgeSec { get; private set; }
Public Property CacheWriteMaxAgeSec As Nullable(Of Integer)
    Get
    Private Set
Public Property CacheWriteMaxAgeSec As Nullable(Of Integer)
    Get
    Private Set
public:
virtual property Nullable<int> CacheWriteMaxAgeSec {
    Nullable<int> get () sealed;
    private: void set (Nullable<int> value) sealed;
}
public:
virtual property Nullable<int> CacheWriteMaxAgeSec {
    Nullable<int> get () sealed;
    private: void set (Nullable<int> value) sealed;
}
abstract CacheWriteMaxAgeSec : Nullable<int> with get, private set
override CacheWriteMaxAgeSec : Nullable<int> with get, private set
abstract CacheWriteMaxAgeSec : Nullable<int> with get, private set
override CacheWriteMaxAgeSec : Nullable<int> with get, private set

Property Value

Type: Online Nullable Online Int32

Implements

ICachePolicy CacheWriteMaxAgeSec
See Also
DataParcelAttribute Class
DataParcelAttribute Members
NFX.DataAccess.Distributed Namespace


DataParcelAttribute.ReplicationChannel Property

DataParcelAttribute ReplicationChannel Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Specifies the name of the replication channel used to pump data between servers/data centers/locations

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ReplicationChannel { get; private set; }
public string ReplicationChannel { get; private set; }
Public Property ReplicationChannel As String
    Get
    Private Set
Public Property ReplicationChannel As String
    Get
    Private Set
public:
property String^ ReplicationChannel {
    String^ get ();
    private: void set (String^ value);
}
public:
property String^ ReplicationChannel {
    String^ get ();
    private: void set (String^ value);
}
member ReplicationChannel : string with get, private set
member ReplicationChannel : string with get, private set

Property Value

Type: Online String
See Also
DataParcelAttribute Class
DataParcelAttribute Members
NFX.DataAccess.Distributed Namespace


DataParcelAttribute.SchemaName Property

DataParcelAttribute SchemaName Property NFX Class Library

Specifies the name for logical schema that parcel decorated by this attribute belongs to. The exact location within the data store is detailed further with AreaName property. The value is required and is always specified or exception is thrown in .ctor

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SchemaName { get; private set; }
public string SchemaName { get; private set; }
Public Property SchemaName As String
    Get
    Private Set
Public Property SchemaName As String
    Get
    Private Set
public:
property String^ SchemaName {
    String^ get ();
    private: void set (String^ value);
}
public:
property String^ SchemaName {
    String^ get ();
    private: void set (String^ value);
}
member SchemaName : string with get, private set
member SchemaName : string with get, private set

Property Value

Type: Online String
See Also
DataParcelAttribute Class
DataParcelAttribute Members
NFX.DataAccess.Distributed Namespace


DataParcelAttribute.ShardingParcel Property

DataParcelAttribute ShardingParcel Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Specifies the type of Parcel that is used for sharding. By default this parameter is null, so parcels are sharded on their own instance types, however there are cases when a parcel overrides ShardingID and specifies ShardingParcel type via this member so it gets stored along with the specified parcel

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Type ShardingParcel { get; private set; }
public Type ShardingParcel { get; private set; }
Public Property ShardingParcel As Type
    Get
    Private Set
Public Property ShardingParcel As Type
    Get
    Private Set
public:
property Type^ ShardingParcel {
    Type^ get ();
    private: void set (Type^ value);
}
public:
property Type^ ShardingParcel {
    Type^ get ();
    private: void set (Type^ value);
}
member ShardingParcel : Type with get, private set
member ShardingParcel : Type with get, private set

Property Value

Type: Online Type
See Also
DataParcelAttribute Class
DataParcelAttribute Members
NFX.DataAccess.Distributed Namespace


DataParcelAttribute.SupportsMerge Property

DataParcelAttribute SupportsMerge Property NFX Class Library

Returns true if parcel supports merge with other versions. Server may merge multiple parcel versions to resolve versioning conflict. Default implementation returns false

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsMerge { get; private set; }
public bool SupportsMerge { get; private set; }
Public Property SupportsMerge As Boolean
    Get
    Private Set
Public Property SupportsMerge As Boolean
    Get
    Private Set
public:
property bool SupportsMerge {
    bool get ();
    private: void set (bool value);
}
public:
property bool SupportsMerge {
    bool get ();
    private: void set (bool value);
}
member SupportsMerge : bool with get, private set
member SupportsMerge : bool with get, private set

Property Value

Type: Online Boolean
See Also
DataParcelAttribute Class
DataParcelAttribute Members
NFX.DataAccess.Distributed Namespace


DataParcelAttribute.TableMappings Property

DataParcelAttribute TableMappings Property NFX Class Library

Returns mappins of target->table attributes. Pass in [DataParcel(targetTableMappings = "targetName1=tableName1{atr1=v1 atr2=v2...} targetName2=tableName2{atr1=v1 atr2=v2...}...")];

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<TargetTableMapping> TableMappings { get; }
public IRegistry<TargetTableMapping> TableMappings { get; }
Public ReadOnly Property TableMappings As IRegistry(Of TargetTableMapping)
    Get
Public ReadOnly Property TableMappings As IRegistry(Of TargetTableMapping)
    Get
public:
property IRegistry<TargetTableMapping>^ TableMappings {
    IRegistry<TargetTableMapping>^ get ();
}
public:
property IRegistry<TargetTableMapping>^ TableMappings {
    IRegistry<TargetTableMapping>^ get ();
}
member TableMappings : IRegistry<TargetTableMapping> with get
member TableMappings : IRegistry<TargetTableMapping> with get

Property Value

Type: IRegistry TargetTableMapping
See Also
DataParcelAttribute Class
DataParcelAttribute Members
NFX.DataAccess.Distributed Namespace


DataVeracity Enumeration

DataVeracity Enumeration NFX Class Library

Stipulates levels of data fidality, the higher the level - the more accurately verified data is provided

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum DataVeracity
public enum DataVeracity
Public Enumeration DataVeracity
Public Enumeration DataVeracity
public enum class DataVeracity
public enum class DataVeracity
type DataVeracity
type DataVeracity
Members
Member name | Value | Description
Maximum | 0 | The highest level of data accuracy - the backend will compare data from multiple storage mediums/devices to calculate the most accurate/latest data. This mode is the slowest among the others
BackedUp | 1 | The backend will return the data which is stored in more than one device/medium
Any | 2 | The backend will return the fist available data as soon as it finds it. This mode is the fastest however it may return data that has since been overwritten in some other storage devices/mediums. This mode may be used in cases when performance is paramount but 100% data accuracy is not really needed, i.e. when showing message/forum post comments on a social web site
See Also
NFX.DataAccess.Distributed Namespace


DistributedDataAccessException Class

DistributedDataAccessException Class NFX Class Library

Thrown by distributed data access classes
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.DataAccess DataAccessException
NFX.DataAccess.Distributed DistributedDataAccessException
NFX.DataAccess.Distributed DistributedDataParcelSerializationException
NFX.DataAccess.Distributed ParcelValidationException

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class DistributedDataAccessException : DataAccessException
[SerializableAttribute]
public class DistributedDataAccessException : DataAccessException
<SerializableAttribute>
Public Class DistributedDataAccessException
    Inherits DataAccessException
<SerializableAttribute>
Public Class DistributedDataAccessException
    Inherits DataAccessException
[SerializableAttribute]
public ref class DistributedDataAccessException : public DataAccessException
[SerializableAttribute]
public ref class DistributedDataAccessException : public DataAccessException
[<SerializableAttribute>]
type DistributedDataAccessException =
    class
        inherit DataAccessException
    end
[<SerializableAttribute>]
type DistributedDataAccessException =
    class
        inherit DataAccessException
    end
See Also
DistributedDataAccessException Members
NFX.DataAccess.Distributed Namespace


DistributedDataAccessException Members

DistributedDataAccessException Members NFX Class Library

The DistributedDataAccessException type exposes the following members.
Constructors
 | Name | Description
Public method | DistributedDataAccessException | Initializes a new instance of the DistributedDataAccessException class
Public method | DistributedDataAccessException(String) | Initializes a new instance of the DistributedDataAccessException class
Protected method | DistributedDataAccessException(SerializationInfo, StreamingContext) | Initializes a new instance of the DistributedDataAccessException class
Public method | DistributedDataAccessException(String, Exception) | Initializes a new instance of the DistributedDataAccessException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
DistributedDataAccessException Class
NFX.DataAccess.Distributed Namespace


DistributedDataAccessException Constructor

DistributedDataAccessException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | DistributedDataAccessException | Initializes a new instance of the DistributedDataAccessException class
Public method | DistributedDataAccessException(String) | Initializes a new instance of the DistributedDataAccessException class
Protected method | DistributedDataAccessException(SerializationInfo, StreamingContext) | Initializes a new instance of the DistributedDataAccessException class
Public method | DistributedDataAccessException(String, Exception) | Initializes a new instance of the DistributedDataAccessException class
Back to Top
See Also
DistributedDataAccessException Class
DistributedDataAccessException Members
NFX.DataAccess.Distributed Namespace


DistributedDataAccessException Constructor

DistributedDataAccessException Constructor NFX Class Library

Initializes a new instance of the DistributedDataAccessException class

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DistributedDataAccessException()
public DistributedDataAccessException()
Public Sub New
Public Sub New
public:
DistributedDataAccessException()
public:
DistributedDataAccessException()
new : unit -> DistributedDataAccessException
new : unit -> DistributedDataAccessException
See Also
DistributedDataAccessException Class
DistributedDataAccessException Members
DistributedDataAccessException Overload
NFX.DataAccess.Distributed Namespace


DistributedDataAccessException Constructor (String)

DistributedDataAccessException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DistributedDataAccessException class

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DistributedDataAccessException(
    string message
)
public DistributedDataAccessException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
DistributedDataAccessException(
    String^ message
)
public:
DistributedDataAccessException(
    String^ message
)
new :
        message : string -> DistributedDataAccessException
new :
        message : string -> DistributedDataAccessException

Parameters

message
Type: Online System String
See Also
DistributedDataAccessException Class
DistributedDataAccessException Members
DistributedDataAccessException Overload
NFX.DataAccess.Distributed Namespace


DistributedDataAccessException Constructor (SerializationInfo, StreamingContext)

DistributedDataAccessException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DistributedDataAccessException class

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected DistributedDataAccessException(
    SerializationInfo info,
    StreamingContext context
)
protected DistributedDataAccessException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
DistributedDataAccessException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
DistributedDataAccessException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DistributedDataAccessException
new :
        info : SerializationInfo *
        context : StreamingContext -> DistributedDataAccessException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
DistributedDataAccessException Class
DistributedDataAccessException Members
DistributedDataAccessException Overload
NFX.DataAccess.Distributed Namespace


DistributedDataAccessException Constructor (String, Exception)

DistributedDataAccessException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DistributedDataAccessException class

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DistributedDataAccessException(
    string message,
    Exception inner
)
public DistributedDataAccessException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
DistributedDataAccessException(
    String^ message,
    Exception^ inner
)
public:
DistributedDataAccessException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> DistributedDataAccessException
new :
        message : string *
        inner : Exception -> DistributedDataAccessException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
DistributedDataAccessException Class
DistributedDataAccessException Members
DistributedDataAccessException Overload
NFX.DataAccess.Distributed Namespace


DistributedDataAccessException Fields

DistributedDataAccessException Fields NFX Class Library

The DistributedDataAccessException type exposes the following members.
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
See Also
DistributedDataAccessException Class
NFX.DataAccess.Distributed Namespace


DistributedDataAccessException Methods

DistributedDataAccessException Methods NFX Class Library

The DistributedDataAccessException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
DistributedDataAccessException Class
NFX.DataAccess.Distributed Namespace


DistributedDataAccessException Properties

DistributedDataAccessException Properties NFX Class Library

The DistributedDataAccessException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
DistributedDataAccessException Class
NFX.DataAccess.Distributed Namespace


DistributedDataAccessException Events

DistributedDataAccessException Events NFX Class Library

The DistributedDataAccessException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
DistributedDataAccessException Class
NFX.DataAccess.Distributed Namespace


DistributedDataParcelSerializationException Class

DistributedDataParcelSerializationException Class NFX Class Library

[This is preliminary documentation and is subject to change.]

Thrown by distributed data access classes when parcel serialization problems happen
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.DataAccess DataAccessException
NFX.DataAccess.Distributed DistributedDataAccessException
NFX.DataAccess.Distributed DistributedDataParcelSerializationException

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class DistributedDataParcelSerializationException : DistributedDataAccessException
[SerializableAttribute]
public class DistributedDataParcelSerializationException : DistributedDataAccessException
<SerializableAttribute>
Public Class DistributedDataParcelSerializationException
    Inherits DistributedDataAccessException
<SerializableAttribute>
Public Class DistributedDataParcelSerializationException
    Inherits DistributedDataAccessException
[SerializableAttribute]
public ref class DistributedDataParcelSerializationException : public DistributedDataAccessException
[SerializableAttribute]
public ref class DistributedDataParcelSerializationException : public DistributedDataAccessException
[<SerializableAttribute>]
type DistributedDataParcelSerializationException =
    class
        inherit DistributedDataAccessException
    end
[<SerializableAttribute>]
type DistributedDataParcelSerializationException =
    class
        inherit DistributedDataAccessException
    end
See Also
DistributedDataParcelSerializationException Members
NFX.DataAccess.Distributed Namespace


DistributedDataParcelSerializationException Members

DistributedDataParcelSerializationException Members NFX Class Library

[This is preliminary documentation and is subject to change.]

The DistributedDataParcelSerializationException type exposes the following members.
Constructors
 | Name | Description
Public method | DistributedDataParcelSerializationException | Initializes a new instance of the DistributedDataParcelSerializationException class
Public method | DistributedDataParcelSerializationException(String) | Initializes a new instance of the DistributedDataParcelSerializationException class
Protected method | DistributedDataParcelSerializationException(SerializationInfo, StreamingContext) | Initializes a new instance of the DistributedDataParcelSerializationException class
Public method | DistributedDataParcelSerializationException(String, Exception) | Initializes a new instance of the DistributedDataParcelSerializationException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
DistributedDataParcelSerializationException Class
NFX.DataAccess.Distributed Namespace


DistributedDataParcelSerializationException Constructor

DistributedDataParcelSerializationException Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public method | DistributedDataParcelSerializationException | Initializes a new instance of the DistributedDataParcelSerializationException class
Public method | DistributedDataParcelSerializationException(String) | Initializes a new instance of the DistributedDataParcelSerializationException class
Protected method | DistributedDataParcelSerializationException(SerializationInfo, StreamingContext) | Initializes a new instance of the DistributedDataParcelSerializationException class
Public method | DistributedDataParcelSerializationException(String, Exception) | Initializes a new instance of the DistributedDataParcelSerializationException class
Back to Top
See Also
DistributedDataParcelSerializationException Class
DistributedDataParcelSerializationException Members
NFX.DataAccess.Distributed Namespace


DistributedDataParcelSerializationException Constructor

DistributedDataParcelSerializationException Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DistributedDataParcelSerializationException class

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DistributedDataParcelSerializationException()
public DistributedDataParcelSerializationException()
Public Sub New
Public Sub New
public:
DistributedDataParcelSerializationException()
public:
DistributedDataParcelSerializationException()
new : unit -> DistributedDataParcelSerializationException
new : unit -> DistributedDataParcelSerializationException
See Also
DistributedDataParcelSerializationException Class
DistributedDataParcelSerializationException Members
DistributedDataParcelSerializationException Overload
NFX.DataAccess.Distributed Namespace


DistributedDataParcelSerializationException Constructor (String)

DistributedDataParcelSerializationException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DistributedDataParcelSerializationException class

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DistributedDataParcelSerializationException(
    string message
)
public DistributedDataParcelSerializationException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
DistributedDataParcelSerializationException(
    String^ message
)
public:
DistributedDataParcelSerializationException(
    String^ message
)
new :
        message : string -> DistributedDataParcelSerializationException
new :
        message : string -> DistributedDataParcelSerializationException

Parameters

message
Type: Online System String
See Also
DistributedDataParcelSerializationException Class
DistributedDataParcelSerializationException Members
DistributedDataParcelSerializationException Overload
NFX.DataAccess.Distributed Namespace


DistributedDataParcelSerializationException Constructor (SerializationInfo, StreamingContext)

DistributedDataParcelSerializationException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DistributedDataParcelSerializationException class

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected DistributedDataParcelSerializationException(
    SerializationInfo info,
    StreamingContext context
)
protected DistributedDataParcelSerializationException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
DistributedDataParcelSerializationException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
DistributedDataParcelSerializationException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DistributedDataParcelSerializationException
new :
        info : SerializationInfo *
        context : StreamingContext -> DistributedDataParcelSerializationException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
DistributedDataParcelSerializationException Class
DistributedDataParcelSerializationException Members
DistributedDataParcelSerializationException Overload
NFX.DataAccess.Distributed Namespace


DistributedDataParcelSerializationException Constructor (String, Exception)

DistributedDataParcelSerializationException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DistributedDataParcelSerializationException class

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DistributedDataParcelSerializationException(
    string message,
    Exception inner
)
public DistributedDataParcelSerializationException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
DistributedDataParcelSerializationException(
    String^ message,
    Exception^ inner
)
public:
DistributedDataParcelSerializationException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> DistributedDataParcelSerializationException
new :
        message : string *
        inner : Exception -> DistributedDataParcelSerializationException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
DistributedDataParcelSerializationException Class
DistributedDataParcelSerializationException Members
DistributedDataParcelSerializationException Overload
NFX.DataAccess.Distributed Namespace


DistributedDataParcelSerializationException Fields

DistributedDataParcelSerializationException Fields NFX Class Library

[This is preliminary documentation and is subject to change.]

The DistributedDataParcelSerializationException type exposes the following members.
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
See Also
DistributedDataParcelSerializationException Class
NFX.DataAccess.Distributed Namespace


DistributedDataParcelSerializationException Methods

DistributedDataParcelSerializationException Methods NFX Class Library

[This is preliminary documentation and is subject to change.]

The DistributedDataParcelSerializationException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
DistributedDataParcelSerializationException Class
NFX.DataAccess.Distributed Namespace


DistributedDataParcelSerializationException Properties

DistributedDataParcelSerializationException Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The DistributedDataParcelSerializationException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
DistributedDataParcelSerializationException Class
NFX.DataAccess.Distributed Namespace


DistributedDataParcelSerializationException Events

DistributedDataParcelSerializationException Events NFX Class Library

[This is preliminary documentation and is subject to change.]

The DistributedDataParcelSerializationException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
DistributedDataParcelSerializationException Class
NFX.DataAccess.Distributed Namespace


GDID Structure

GDID Structure NFX Class Library

Represents a Global Distributed ID key (key field) used in distributed databases that identify entities with a combination of unsigned 32 bit integer 'Era' and unsigned 64 bit integer 'ID'. The first 32 bit integer is an 'era' in which the 'ID' (64 bit) was created, consequently a GDID is a 12 byte = 96 bit integer that can hold 2^96 = 79,228,162,514,264,337,593,543,950,336 combinations. The ID consists of two segments: 4 bit authority + 60 bits counter. Authority segment occupies the most significant 4 bits of uint64, so the system may efficiently query the data store to identify the highest stored ID value in a range. Authorities identify one of 16 possible ID generation sources in the global distributed system, therefore ID duplications are not possible between authorities. Within a single era, GDID structure may identify 2^60 = 1,152,921,504,606,846,976(per authority) * 16(authorities) = 2^64 = 18,446,744,073,709,551,616 total combinations. Because of such a large number of combinations supported by GDID.ID alone (having the same Era), some systems may always use Era=0 and only store the ID part (i.e. as UNSIGNED BIGINT in SQL datastores). Note GDID.Zero is never returned by generators as it represents the absence of a value

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public struct GDID : IDataStoreKey, IComparable<GDID>,
    IEquatable<GDID>, IComparable, IJSONWritable, IDistributedStableHashProvider
[SerializableAttribute]
public struct GDID : IDataStoreKey, IComparable<GDID>,
    IEquatable<GDID>, IComparable, IJSONWritable, IDistributedStableHashProvider
<SerializableAttribute>
Public Structure GDID
    Implements IDataStoreKey, IComparable(Of GDID),
    IEquatable(Of GDID), IComparable, IJSONWritable, IDistributedStableHashProvider
<SerializableAttribute>
Public Structure GDID
    Implements IDataStoreKey, IComparable(Of GDID),
    IEquatable(Of GDID), IComparable, IJSONWritable, IDistributedStableHashProvider
[SerializableAttribute]
public value class GDID : IDataStoreKey, IComparable<GDID>,
    IEquatable<GDID>, IComparable, IJSONWritable, IDistributedStableHashProvider
[SerializableAttribute]
public value class GDID : IDataStoreKey, IComparable<GDID>,
    IEquatable<GDID>, IComparable, IJSONWritable, IDistributedStableHashProvider
[<SealedAttribute>]
[<SerializableAttribute>]
type GDID =
    struct
        interface IDataStoreKey
        interface IComparable<GDID>
        interface IEquatable<GDID>
        interface IComparable
        interface IJSONWritable
        interface IDistributedStableHashProvider
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type GDID =
    struct
        interface IDataStoreKey
        interface IComparable<GDID>
        interface IEquatable<GDID>
        interface IComparable
        interface IJSONWritable
        interface IDistributedStableHashProvider
    end
See Also
GDID Members
NFX.DataAccess.Distributed Namespace


GDID Members

GDID Members NFX Class Library

The GDID type exposes the following members.
Constructors
 | Name | Description
Public method | GDID( Byte , Int32) | Initializes a new instance of the GDID class
Public method | GDID(UInt32, UInt64) | Initializes a new instance of the GDID class
Public method | GDID(UInt32, Int32, UInt64) | Initializes a new instance of the GDID class
Back to Top
Methods
 | Name | Description
Public method | CompareTo(Object) |
Public method | CompareTo(GDID) |
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(GDID) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDistributedStableHash |
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Parse |
Public method | ToHexString |
Public method | ToString | (Overrides Online ValueType ToString .)
 | TryParse(String, GDID ) |
 | TryParse(String, Nullable GDID ) |
Public method | WriteAsJSON |
Back to Top
Operators
Name | Description
Equality |
GreaterThan |
GreaterThanOrEqual |
Inequality |
LessThan |
LessThanOrEqual |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | AUTHORITY_MASK |
 | AUTHORITY_MAX | Provides maximum value for authority segment
 | COUNTER_MASK |
 | COUNTER_MAX | Provides maximum value for counter segment
Public field | Era |
Public field | ID |
 | Zero | Zero GDID singleton
Back to Top
Properties
 | Name | Description
Public property | Authority | Returns the 0..15 index of the authority that issued this ID
Public property | Bytes | Returns the GDID buffer as BigEndian Era:ID tuple
Public property | Counter | Returns the 60 bits of counter segment of this id (without athority segment upper 4 bits)
Public property | IsZero | True is this instance is invalid - represents 0:0:0
Back to Top
See Also
GDID Structure
NFX.DataAccess.Distributed Namespace


GDID Constructor

GDID Constructor NFX Class Library

Overload List
 | Name | Description
Public method | GDID( Byte , Int32) | Initializes a new instance of the GDID class
Public method | GDID(UInt32, UInt64) | Initializes a new instance of the GDID class
Public method | GDID(UInt32, Int32, UInt64) | Initializes a new instance of the GDID class
Back to Top
See Also
GDID Structure
GDID Members
NFX.DataAccess.Distributed Namespace


GDID Constructor (Byte[], Int32)

GDID Constructor ( Byte , Int32) NFX Class Library

Initializes a new instance of the GDID class

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GDID(
    byte[] bytes,
    int startIdx = 0
)
public GDID(
    byte[] bytes,
    int startIdx = 0
)
Public Sub New (
    bytes As Byte(),
    Optional startIdx As Integer = 0
)
Public Sub New (
    bytes As Byte(),
    Optional startIdx As Integer = 0
)
public:
GDID(
    array<unsigned char>^ bytes,
    int startIdx = 0
)
public:
GDID(
    array<unsigned char>^ bytes,
    int startIdx = 0
)
new :
        bytes : byte[] *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> GDID
new :
        bytes : byte[] *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> GDID

Parameters

bytes
Type: Online System Byte
startIdx (Optional)
Type: Online System Int32
See Also
GDID Structure
GDID Members
GDID Overload
NFX.DataAccess.Distributed Namespace


GDID Constructor (UInt32, UInt64)

GDID Constructor (UInt32, UInt64) NFX Class Library

Initializes a new instance of the GDID class

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GDID(
    uint era,
    ulong id
)
public GDID(
    uint era,
    ulong id
)
Public Sub New (
    era As UInteger,
    id As ULong
)
Public Sub New (
    era As UInteger,
    id As ULong
)
public:
GDID(
    unsigned int era,
    unsigned long long id
)
public:
GDID(
    unsigned int era,
    unsigned long long id
)
new :
        era : uint32 *
        id : uint64 -> GDID
new :
        era : uint32 *
        id : uint64 -> GDID

Parameters

era
Type: Online System UInt32
id
Type: Online System UInt64
See Also
GDID Structure
GDID Members
GDID Overload
NFX.DataAccess.Distributed Namespace


GDID Constructor (UInt32, Int32, UInt64)

GDID Constructor (UInt32, Int32, UInt64) NFX Class Library

Initializes a new instance of the GDID class

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GDID(
    uint era,
    int authority,
    ulong counter
)
public GDID(
    uint era,
    int authority,
    ulong counter
)
Public Sub New (
    era As UInteger,
    authority As Integer,
    counter As ULong
)
Public Sub New (
    era As UInteger,
    authority As Integer,
    counter As ULong
)
public:
GDID(
    unsigned int era,
    int authority,
    unsigned long long counter
)
public:
GDID(
    unsigned int era,
    int authority,
    unsigned long long counter
)
new :
        era : uint32 *
        authority : int *
        counter : uint64 -> GDID
new :
        era : uint32 *
        authority : int *
        counter : uint64 -> GDID

Parameters

era
Type: Online System UInt32
authority
Type: Online System Int32
counter
Type: Online System UInt64
See Also
GDID Structure
GDID Members
GDID Overload
NFX.DataAccess.Distributed Namespace


GDID Fields

GDID Fields NFX Class Library

The GDID type exposes the following members.
Fields
 | Name | Description
 | AUTHORITY_MASK |
 | AUTHORITY_MAX | Provides maximum value for authority segment
 | COUNTER_MASK |
 | COUNTER_MAX | Provides maximum value for counter segment
Public field | Era |
Public field | ID |
 | Zero | Zero GDID singleton
Back to Top
See Also
GDID Structure
NFX.DataAccess.Distributed Namespace


GDID.AUTHORITY_MASK Field

GDID AUTHORITY_MASK Field NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const ulong AUTHORITY_MASK
public const ulong AUTHORITY_MASK
Public Const AUTHORITY_MASK As ULong
Public Const AUTHORITY_MASK As ULong
public:
literal unsigned long long AUTHORITY_MASK
public:
literal unsigned long long AUTHORITY_MASK
static val mutable AUTHORITY_MASK: uint64
static val mutable AUTHORITY_MASK: uint64

Field Value

Type: Online UInt64
See Also
GDID Structure
GDID Members
NFX.DataAccess.Distributed Namespace


GDID.AUTHORITY_MAX Field

GDID AUTHORITY_MAX Field NFX Class Library

Provides maximum value for authority segment

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int AUTHORITY_MAX
public const int AUTHORITY_MAX
Public Const AUTHORITY_MAX As Integer
Public Const AUTHORITY_MAX As Integer
public:
literal int AUTHORITY_MAX
public:
literal int AUTHORITY_MAX
static val mutable AUTHORITY_MAX: int
static val mutable AUTHORITY_MAX: int

Field Value

Type: Online Int32
See Also
GDID Structure
GDID Members
NFX.DataAccess.Distributed Namespace


GDID.COUNTER_MASK Field

GDID COUNTER_MASK Field NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const ulong COUNTER_MASK
public const ulong COUNTER_MASK
Public Const COUNTER_MASK As ULong
Public Const COUNTER_MASK As ULong
public:
literal unsigned long long COUNTER_MASK
public:
literal unsigned long long COUNTER_MASK
static val mutable COUNTER_MASK: uint64
static val mutable COUNTER_MASK: uint64

Field Value

Type: Online UInt64
See Also
GDID Structure
GDID Members
NFX.DataAccess.Distributed Namespace


GDID.COUNTER_MAX Field

GDID COUNTER_MAX Field NFX Class Library

Provides maximum value for counter segment

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const ulong COUNTER_MAX
public const ulong COUNTER_MAX
Public Const COUNTER_MAX As ULong
Public Const COUNTER_MAX As ULong
public:
literal unsigned long long COUNTER_MAX
public:
literal unsigned long long COUNTER_MAX
static val mutable COUNTER_MAX: uint64
static val mutable COUNTER_MAX: uint64

Field Value

Type: Online UInt64
See Also
GDID Structure
GDID Members
NFX.DataAccess.Distributed Namespace


GDID.Era Field

GDID Era Field NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly uint Era
public readonly uint Era
Public ReadOnly Era As UInteger
Public ReadOnly Era As UInteger
public:
initonly unsigned int Era
public:
initonly unsigned int Era
val Era: uint32
val Era: uint32

Field Value

Type: Online UInt32
See Also
GDID Structure
GDID Members
NFX.DataAccess.Distributed Namespace


GDID.ID Field

GDID ID Field NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ulong ID
public readonly ulong ID
Public ReadOnly ID As ULong
Public ReadOnly ID As ULong
public:
initonly unsigned long long ID
public:
initonly unsigned long long ID
val ID: uint64
val ID: uint64

Field Value

Type: Online UInt64
See Also
GDID Structure
GDID Members
NFX.DataAccess.Distributed Namespace


GDID.Zero Field

GDID Zero Field NFX Class Library

Zero GDID singleton

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly GDID Zero
public static readonly GDID Zero
Public Shared ReadOnly Zero As GDID
Public Shared ReadOnly Zero As GDID
public:
static initonly GDID Zero
public:
static initonly GDID Zero
static val Zero: GDID
static val Zero: GDID

Field Value

Type: GDID
See Also
GDID Structure
GDID Members
NFX.DataAccess.Distributed Namespace


GDID Methods

GDID Methods NFX Class Library

The GDID type exposes the following members.
Methods
 | Name | Description
Public method | CompareTo(Object) |
Public method | CompareTo(GDID) |
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(GDID) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDistributedStableHash |
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Parse |
Public method | ToHexString |
Public method | ToString | (Overrides Online ValueType ToString .)
 | TryParse(String, GDID ) |
 | TryParse(String, Nullable GDID ) |
Public method | WriteAsJSON |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GDID Structure
NFX.DataAccess.Distributed Namespace


GDID.CompareTo Method

GDID CompareTo Method NFX Class Library

Overload List
 | Name | Description
Public method | CompareTo(Object) |
Public method | CompareTo(GDID) |
Back to Top
See Also
GDID Structure
GDID Members
NFX.DataAccess.Distributed Namespace


GDID.CompareTo Method (Object)

GDID CompareTo Method (Object) NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    Object obj
)
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
Public Function CompareTo (
    obj As Object
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
public:
virtual int CompareTo(
    Object^ obj
) sealed
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int

Parameters

obj
Type: Online System Object

Return Value

Type: Online Int32

Implements

Online IComparable CompareTo(Object)
See Also
GDID Structure
GDID Members
CompareTo Overload
NFX.DataAccess.Distributed Namespace


GDID.CompareTo Method (GDID)

GDID CompareTo Method (GDID) NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    GDID other
)
public int CompareTo(
    GDID other
)
Public Function CompareTo (
    other As GDID
) As Integer
Public Function CompareTo (
    other As GDID
) As Integer
public:
virtual int CompareTo(
    GDID other
) sealed
public:
virtual int CompareTo(
    GDID other
) sealed
abstract CompareTo :
        other : GDID -> int
override CompareTo :
        other : GDID -> int
abstract CompareTo :
        other : GDID -> int
override CompareTo :
        other : GDID -> int

Parameters

other
Type: NFX.DataAccess.Distributed GDID

Return Value

Type: Online Int32

Implements

Online IComparable T CompareTo(T)
See Also
GDID Structure
GDID Members
CompareTo Overload
NFX.DataAccess.Distributed Namespace


GDID.Equals Method

GDID Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(GDID) |
Back to Top
See Also
GDID Structure
GDID Members
NFX.DataAccess.Distributed Namespace


GDID.Equals Method (Object)

GDID Equals Method (Object) NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
GDID Structure
GDID Members
Equals Overload
NFX.DataAccess.Distributed Namespace


GDID.Equals Method (GDID)

GDID Equals Method (GDID) NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    GDID other
)
public bool Equals(
    GDID other
)
Public Function Equals (
    other As GDID
) As Boolean
Public Function Equals (
    other As GDID
) As Boolean
public:
virtual bool Equals(
    GDID other
) sealed
public:
virtual bool Equals(
    GDID other
) sealed
abstract Equals :
        other : GDID -> bool
override Equals :
        other : GDID -> bool
abstract Equals :
        other : GDID -> bool
override Equals :
        other : GDID -> bool

Parameters

other
Type: NFX.DataAccess.Distributed GDID

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
GDID Structure
GDID Members
Equals Overload
NFX.DataAccess.Distributed Namespace


GDID.GetDistributedStableHash Method

GDID GetDistributedStableHash Method NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong GetDistributedStableHash()
public ulong GetDistributedStableHash()
Public Function GetDistributedStableHash As ULong
Public Function GetDistributedStableHash As ULong
public:
virtual unsigned long long GetDistributedStableHash() sealed
public:
virtual unsigned long long GetDistributedStableHash() sealed
abstract GetDistributedStableHash : unit -> uint64
override GetDistributedStableHash : unit -> uint64
abstract GetDistributedStableHash : unit -> uint64
override GetDistributedStableHash : unit -> uint64

Return Value

Type: Online UInt64

Implements

IDistributedStableHashProvider GetDistributedStableHash
See Also
GDID Structure
GDID Members
NFX.DataAccess.Distributed Namespace


GDID.GetHashCode Method

GDID GetHashCode Method NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
GDID Structure
GDID Members
NFX.DataAccess.Distributed Namespace


GDID.Parse Method

GDID Parse Method NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static GDID Parse(
    string str
)
public static GDID Parse(
    string str
)
Public Shared Function Parse (
    str As String
) As GDID
Public Shared Function Parse (
    str As String
) As GDID
public:
static GDID Parse(
    String^ str
)
public:
static GDID Parse(
    String^ str
)
static member Parse :
        str : string -> GDID
static member Parse :
        str : string -> GDID

Parameters

str
Type: Online System String

Return Value

Type: GDID
See Also
GDID Structure
GDID Members
NFX.DataAccess.Distributed Namespace


GDID.ToHexString Method

GDID ToHexString Method NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ToHexString()
public string ToHexString()
Public Function ToHexString As String
Public Function ToHexString As String
public:
String^ ToHexString()
public:
String^ ToHexString()
member ToHexString : unit -> string
member ToHexString : unit -> string

Return Value

Type: Online String
See Also
GDID Structure
GDID Members
NFX.DataAccess.Distributed Namespace


GDID.ToString Method

GDID ToString Method NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
GDID Structure
GDID Members
NFX.DataAccess.Distributed Namespace


GDID.TryParse Method

GDID TryParse Method NFX Class Library

Overload List
Name | Description
TryParse(String, GDID ) |
TryParse(String, Nullable GDID ) |
Back to Top
See Also
GDID Structure
GDID Members
NFX.DataAccess.Distributed Namespace


GDID.TryParse Method (String, GDID)

GDID TryParse Method (String, GDID ) NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool TryParse(
    string str,
    out GDID gdid
)
public static bool TryParse(
    string str,
    out GDID gdid
)
Public Shared Function TryParse (
    str As String,
    <OutAttribute> ByRef gdid As GDID
) As Boolean
Public Shared Function TryParse (
    str As String,
    <OutAttribute> ByRef gdid As GDID
) As Boolean
public:
static bool TryParse(
    String^ str,
    [OutAttribute] GDID% gdid
)
public:
static bool TryParse(
    String^ str,
    [OutAttribute] GDID% gdid
)
static member TryParse :
        str : string *
        gdid : GDID byref -> bool
static member TryParse :
        str : string *
        gdid : GDID byref -> bool

Parameters

str
Type: Online System String
gdid
Type: NFX.DataAccess.Distributed GDID

Return Value

Type: Online Boolean
See Also
GDID Structure
GDID Members
TryParse Overload
NFX.DataAccess.Distributed Namespace


GDID.TryParse Method (String, Nullable(GDID))

GDID TryParse Method (String, Nullable GDID ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool TryParse(
    string str,
    out Nullable<GDID> gdid
)
public static bool TryParse(
    string str,
    out Nullable<GDID> gdid
)
Public Shared Function TryParse (
    str As String,
    <OutAttribute> ByRef gdid As Nullable(Of GDID)
) As Boolean
Public Shared Function TryParse (
    str As String,
    <OutAttribute> ByRef gdid As Nullable(Of GDID)
) As Boolean
public:
static bool TryParse(
    String^ str,
    [OutAttribute] Nullable<GDID>% gdid
)
public:
static bool TryParse(
    String^ str,
    [OutAttribute] Nullable<GDID>% gdid
)
static member TryParse :
        str : string *
        gdid : Nullable<GDID> byref -> bool
static member TryParse :
        str : string *
        gdid : Nullable<GDID> byref -> bool

Parameters

str
Type: Online System String
gdid
Type: Online System Nullable GDID

Return Value

Type: Online Boolean
See Also
GDID Structure
GDID Members
TryParse Overload
NFX.DataAccess.Distributed Namespace


GDID.WriteAsJSON Method

GDID WriteAsJSON Method NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
nestingLevel
Type: Online System Int32
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Implements

IJSONWritable WriteAsJSON(TextWriter, Int32, JSONWritingOptions)
See Also
GDID Structure
GDID Members
NFX.DataAccess.Distributed Namespace


GDID Operators

GDID Operators NFX Class Library

The GDID type exposes the following members.
Operators
Name | Description
Equality |
GreaterThan |
GreaterThanOrEqual |
Inequality |
LessThan |
LessThanOrEqual |
Back to Top
See Also
GDID Structure
NFX.DataAccess.Distributed Namespace


GDID.Equality Operator

GDID Equality Operator NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    GDID x,
    GDID y
)
public static bool operator ==(
    GDID x,
    GDID y
)
Public Shared Operator = (
    x As GDID,
    y As GDID
) As Boolean
Public Shared Operator = (
    x As GDID,
    y As GDID
) As Boolean
public:
static bool operator ==(
    GDID x,
    GDID y
)
public:
static bool operator ==(
    GDID x,
    GDID y
)
static let inline (=)
        x : GDID *
        y : GDID  : bool
static let inline (=)
        x : GDID *
        y : GDID  : bool

Parameters

x
Type: NFX.DataAccess.Distributed GDID
y
Type: NFX.DataAccess.Distributed GDID

Return Value

Type: Online Boolean
See Also
GDID Structure
GDID Members
NFX.DataAccess.Distributed Namespace


GDID.GreaterThan Operator

GDID GreaterThan Operator NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator >(
    GDID x,
    GDID y
)
public static bool operator >(
    GDID x,
    GDID y
)
Public Shared Operator > (
    x As GDID,
    y As GDID
) As Boolean
Public Shared Operator > (
    x As GDID,
    y As GDID
) As Boolean
public:
static bool operator >(
    GDID x,
    GDID y
)
public:
static bool operator >(
    GDID x,
    GDID y
)
static let inline (>)
        x : GDID *
        y : GDID  : bool
static let inline (>)
        x : GDID *
        y : GDID  : bool

Parameters

x
Type: NFX.DataAccess.Distributed GDID
y
Type: NFX.DataAccess.Distributed GDID

Return Value

Type: Online Boolean
See Also
GDID Structure
GDID Members
NFX.DataAccess.Distributed Namespace


GDID.GreaterThanOrEqual Operator

GDID GreaterThanOrEqual Operator NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator >=(
    GDID x,
    GDID y
)
public static bool operator >=(
    GDID x,
    GDID y
)
Public Shared Operator >= (
    x As GDID,
    y As GDID
) As Boolean
Public Shared Operator >= (
    x As GDID,
    y As GDID
) As Boolean
public:
static bool operator >=(
    GDID x,
    GDID y
)
public:
static bool operator >=(
    GDID x,
    GDID y
)
static let inline (>=)
        x : GDID *
        y : GDID  : bool
static let inline (>=)
        x : GDID *
        y : GDID  : bool

Parameters

x
Type: NFX.DataAccess.Distributed GDID
y
Type: NFX.DataAccess.Distributed GDID

Return Value

Type: Online Boolean
See Also
GDID Structure
GDID Members
NFX.DataAccess.Distributed Namespace


GDID.Inequality Operator

GDID Inequality Operator NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    GDID x,
    GDID y
)
public static bool operator !=(
    GDID x,
    GDID y
)
Public Shared Operator <> (
    x As GDID,
    y As GDID
) As Boolean
Public Shared Operator <> (
    x As GDID,
    y As GDID
) As Boolean
public:
static bool operator !=(
    GDID x,
    GDID y
)
public:
static bool operator !=(
    GDID x,
    GDID y
)
static let inline (<>)
        x : GDID *
        y : GDID  : bool
static let inline (<>)
        x : GDID *
        y : GDID  : bool

Parameters

x
Type: NFX.DataAccess.Distributed GDID
y
Type: NFX.DataAccess.Distributed GDID

Return Value

Type: Online Boolean
See Also
GDID Structure
GDID Members
NFX.DataAccess.Distributed Namespace


GDID.LessThan Operator

GDID LessThan Operator NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator <(
    GDID x,
    GDID y
)
public static bool operator <(
    GDID x,
    GDID y
)
Public Shared Operator < (
    x As GDID,
    y As GDID
) As Boolean
Public Shared Operator < (
    x As GDID,
    y As GDID
) As Boolean
public:
static bool operator <(
    GDID x,
    GDID y
)
public:
static bool operator <(
    GDID x,
    GDID y
)
static let inline (<)
        x : GDID *
        y : GDID  : bool
static let inline (<)
        x : GDID *
        y : GDID  : bool

Parameters

x
Type: NFX.DataAccess.Distributed GDID
y
Type: NFX.DataAccess.Distributed GDID

Return Value

Type: Online Boolean
See Also
GDID Structure
GDID Members
NFX.DataAccess.Distributed Namespace


GDID.LessThanOrEqual Operator

GDID LessThanOrEqual Operator NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator <=(
    GDID x,
    GDID y
)
public static bool operator <=(
    GDID x,
    GDID y
)
Public Shared Operator <= (
    x As GDID,
    y As GDID
) As Boolean
Public Shared Operator <= (
    x As GDID,
    y As GDID
) As Boolean
public:
static bool operator <=(
    GDID x,
    GDID y
)
public:
static bool operator <=(
    GDID x,
    GDID y
)
static let inline (<=)
        x : GDID *
        y : GDID  : bool
static let inline (<=)
        x : GDID *
        y : GDID  : bool

Parameters

x
Type: NFX.DataAccess.Distributed GDID
y
Type: NFX.DataAccess.Distributed GDID

Return Value

Type: Online Boolean
See Also
GDID Structure
GDID Members
NFX.DataAccess.Distributed Namespace


GDID Properties

GDID Properties NFX Class Library

The GDID type exposes the following members.
Properties
 | Name | Description
Public property | Authority | Returns the 0..15 index of the authority that issued this ID
Public property | Bytes | Returns the GDID buffer as BigEndian Era:ID tuple
Public property | Counter | Returns the 60 bits of counter segment of this id (without athority segment upper 4 bits)
Public property | IsZero | True is this instance is invalid - represents 0:0:0
Back to Top
See Also
GDID Structure
NFX.DataAccess.Distributed Namespace


GDID.Authority Property

GDID Authority Property NFX Class Library

Returns the 0..15 index of the authority that issued this ID

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Authority { get; }
public int Authority { get; }
Public ReadOnly Property Authority As Integer
    Get
Public ReadOnly Property Authority As Integer
    Get
public:
property int Authority {
    int get ();
}
public:
property int Authority {
    int get ();
}
member Authority : int with get
member Authority : int with get

Property Value

Type: Online Int32
See Also
GDID Structure
GDID Members
NFX.DataAccess.Distributed Namespace


GDID.Bytes Property

GDID Bytes Property NFX Class Library

Returns the GDID buffer as BigEndian Era:ID tuple

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] Bytes { get; }
public byte[] Bytes { get; }
Public ReadOnly Property Bytes As Byte()
    Get
Public ReadOnly Property Bytes As Byte()
    Get
public:
property array<unsigned char>^ Bytes {
    array<unsigned char>^ get ();
}
public:
property array<unsigned char>^ Bytes {
    array<unsigned char>^ get ();
}
member Bytes : byte[] with get
member Bytes : byte[] with get

Property Value

Type: Online Byte
See Also
GDID Structure
GDID Members
NFX.DataAccess.Distributed Namespace


GDID.Counter Property

GDID Counter Property NFX Class Library

Returns the 60 bits of counter segment of this id (without athority segment upper 4 bits)

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong Counter { get; }
public ulong Counter { get; }
Public ReadOnly Property Counter As ULong
    Get
Public ReadOnly Property Counter As ULong
    Get
public:
property unsigned long long Counter {
    unsigned long long get ();
}
public:
property unsigned long long Counter {
    unsigned long long get ();
}
member Counter : uint64 with get
member Counter : uint64 with get

Property Value

Type: Online UInt64
See Also
GDID Structure
GDID Members
NFX.DataAccess.Distributed Namespace


GDID.IsZero Property

GDID IsZero Property NFX Class Library

True is this instance is invalid - represents 0:0:0

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsZero { get; }
public bool IsZero { get; }
Public ReadOnly Property IsZero As Boolean
    Get
Public ReadOnly Property IsZero As Boolean
    Get
public:
property bool IsZero {
    bool get ();
}
public:
property bool IsZero {
    bool get ();
}
member IsZero : bool with get
member IsZero : bool with get

Property Value

Type: Online Boolean
See Also
GDID Structure
GDID Members
NFX.DataAccess.Distributed Namespace


GDIDRangeComparer Class

GDIDRangeComparer Class NFX Class Library

Compares GDID regardless of authority. This is useful for range checking, when authorities generating GDIDs in the same range should be disregarded. Use GDIDRangeComparer.Instance. Only relative range comparison can be made. The Equality returned by this comparer can not be relied upon for GDID comparison as it disregards authority. Equality can only be tested for range comparison.
Inheritance Hierarchy
Online System Object
NFX.DataAccess.Distributed GDIDRangeComparer

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GDIDRangeComparer : IComparer<GDID>
public class GDIDRangeComparer : IComparer<GDID>
Public Class GDIDRangeComparer
    Implements IComparer(Of GDID)
Public Class GDIDRangeComparer
    Implements IComparer(Of GDID)
public ref class GDIDRangeComparer : IComparer<GDID>
public ref class GDIDRangeComparer : IComparer<GDID>
type GDIDRangeComparer =
    class
        interface IComparer<GDID>
    end
type GDIDRangeComparer =
    class
        interface IComparer<GDID>
    end
See Also
GDIDRangeComparer Members
NFX.DataAccess.Distributed Namespace


GDIDRangeComparer Members

GDIDRangeComparer Members NFX Class Library

The GDIDRangeComparer type exposes the following members.
Methods
 | Name | Description
Public method | Compare |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
Instance |
Back to Top
See Also
GDIDRangeComparer Class
NFX.DataAccess.Distributed Namespace


GDIDRangeComparer Fields

GDIDRangeComparer Fields NFX Class Library

The GDIDRangeComparer type exposes the following members.
Fields
Name | Description
Instance |
Back to Top
See Also
GDIDRangeComparer Class
NFX.DataAccess.Distributed Namespace


GDIDRangeComparer.Instance Field

GDIDRangeComparer Instance Field NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly GDIDRangeComparer Instance
public static readonly GDIDRangeComparer Instance
Public Shared ReadOnly Instance As GDIDRangeComparer
Public Shared ReadOnly Instance As GDIDRangeComparer
public:
static initonly GDIDRangeComparer^ Instance
public:
static initonly GDIDRangeComparer^ Instance
static val Instance: GDIDRangeComparer
static val Instance: GDIDRangeComparer

Field Value

Type: GDIDRangeComparer
See Also
GDIDRangeComparer Class
GDIDRangeComparer Members
NFX.DataAccess.Distributed Namespace


GDIDRangeComparer Methods

GDIDRangeComparer Methods NFX Class Library

The GDIDRangeComparer type exposes the following members.
Methods
 | Name | Description
Public method | Compare |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GDIDRangeComparer Class
NFX.DataAccess.Distributed Namespace


GDIDRangeComparer.Compare Method

GDIDRangeComparer Compare Method NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Compare(
    GDID x,
    GDID y
)
public int Compare(
    GDID x,
    GDID y
)
Public Function Compare (
    x As GDID,
    y As GDID
) As Integer
Public Function Compare (
    x As GDID,
    y As GDID
) As Integer
public:
virtual int Compare(
    GDID x,
    GDID y
) sealed
public:
virtual int Compare(
    GDID x,
    GDID y
) sealed
abstract Compare :
        x : GDID *
        y : GDID -> int
override Compare :
        x : GDID *
        y : GDID -> int
abstract Compare :
        x : GDID *
        y : GDID -> int
override Compare :
        x : GDID *
        y : GDID -> int

Parameters

x
Type: NFX.DataAccess.Distributed GDID
y
Type: NFX.DataAccess.Distributed GDID

Return Value

Type: Online Int32

Implements

Online IComparer T Compare(T, T)
See Also
GDIDRangeComparer Class
GDIDRangeComparer Members
NFX.DataAccess.Distributed Namespace


GDIDSymbol Structure

GDIDSymbol Structure NFX Class Library

Represents a tuple of GDID and its symbolic representation (framework usualy uses an ELink as symbolic representation). This struct is needed to pass GDID along with its ELink representation together. Keep in mind that string poses a GC load, so this stuct is not suitable for beiing used as a pile cache key

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public struct GDIDSymbol : IEquatable<GDIDSymbol>
[SerializableAttribute]
public struct GDIDSymbol : IEquatable<GDIDSymbol>
<SerializableAttribute>
Public Structure GDIDSymbol
    Implements IEquatable(Of GDIDSymbol)
<SerializableAttribute>
Public Structure GDIDSymbol
    Implements IEquatable(Of GDIDSymbol)
[SerializableAttribute]
public value class GDIDSymbol : IEquatable<GDIDSymbol>
[SerializableAttribute]
public value class GDIDSymbol : IEquatable<GDIDSymbol>
[<SealedAttribute>]
[<SerializableAttribute>]
type GDIDSymbol =
    struct
        interface IEquatable<GDIDSymbol>
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type GDIDSymbol =
    struct
        interface IEquatable<GDIDSymbol>
    end
See Also
GDIDSymbol Members
NFX.DataAccess.Distributed Namespace


GDIDSymbol Members

GDIDSymbol Members NFX Class Library

The GDIDSymbol type exposes the following members.
Constructors
 | Name | Description
Public method | GDIDSymbol | Initializes a new instance of the GDIDSymbol class
Back to Top
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(GDIDSymbol) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | GDID |
Public field | Symbol |
Back to Top
Properties
 | Name | Description
Public property | IsZero |
Back to Top
See Also
GDIDSymbol Structure
NFX.DataAccess.Distributed Namespace


GDIDSymbol Constructor

GDIDSymbol Constructor NFX Class Library

Initializes a new instance of the GDIDSymbol class

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GDIDSymbol(
    GDID gdid,
    string symbol
)
public GDIDSymbol(
    GDID gdid,
    string symbol
)
Public Sub New (
    gdid As GDID,
    symbol As String
)
Public Sub New (
    gdid As GDID,
    symbol As String
)
public:
GDIDSymbol(
    GDID gdid,
    String^ symbol
)
public:
GDIDSymbol(
    GDID gdid,
    String^ symbol
)
new :
        gdid : GDID *
        symbol : string -> GDIDSymbol
new :
        gdid : GDID *
        symbol : string -> GDIDSymbol

Parameters

gdid
Type: NFX.DataAccess.Distributed GDID
symbol
Type: Online System String
See Also
GDIDSymbol Structure
GDIDSymbol Members
NFX.DataAccess.Distributed Namespace


GDIDSymbol Fields

GDIDSymbol Fields NFX Class Library

The GDIDSymbol type exposes the following members.
Fields
 | Name | Description
Public field | GDID |
Public field | Symbol |
Back to Top
See Also
GDIDSymbol Structure
NFX.DataAccess.Distributed Namespace


GDIDSymbol.GDID Field

GDIDSymbol GDID Field NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly GDID GDID
public readonly GDID GDID
Public ReadOnly GDID As GDID
Public ReadOnly GDID As GDID
public:
initonly GDID GDID
public:
initonly GDID GDID
val GDID: GDID
val GDID: GDID

Field Value

Type: GDID
See Also
GDIDSymbol Structure
GDIDSymbol Members
NFX.DataAccess.Distributed Namespace


GDIDSymbol.Symbol Field

GDIDSymbol Symbol Field NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Symbol
public readonly string Symbol
Public ReadOnly Symbol As String
Public ReadOnly Symbol As String
public:
initonly String^ Symbol
public:
initonly String^ Symbol
val Symbol: string
val Symbol: string

Field Value

Type: Online String
See Also
GDIDSymbol Structure
GDIDSymbol Members
NFX.DataAccess.Distributed Namespace


GDIDSymbol Methods

GDIDSymbol Methods NFX Class Library

The GDIDSymbol type exposes the following members.
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(GDIDSymbol) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GDIDSymbol Structure
NFX.DataAccess.Distributed Namespace


GDIDSymbol.Equals Method

GDIDSymbol Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(GDIDSymbol) |
Back to Top
See Also
GDIDSymbol Structure
GDIDSymbol Members
NFX.DataAccess.Distributed Namespace


GDIDSymbol.Equals Method (Object)

GDIDSymbol Equals Method (Object) NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
GDIDSymbol Structure
GDIDSymbol Members
Equals Overload
NFX.DataAccess.Distributed Namespace


GDIDSymbol.Equals Method (GDIDSymbol)

GDIDSymbol Equals Method (GDIDSymbol) NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    GDIDSymbol other
)
public bool Equals(
    GDIDSymbol other
)
Public Function Equals (
    other As GDIDSymbol
) As Boolean
Public Function Equals (
    other As GDIDSymbol
) As Boolean
public:
virtual bool Equals(
    GDIDSymbol other
) sealed
public:
virtual bool Equals(
    GDIDSymbol other
) sealed
abstract Equals :
        other : GDIDSymbol -> bool
override Equals :
        other : GDIDSymbol -> bool
abstract Equals :
        other : GDIDSymbol -> bool
override Equals :
        other : GDIDSymbol -> bool

Parameters

other
Type: NFX.DataAccess.Distributed GDIDSymbol

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
GDIDSymbol Structure
GDIDSymbol Members
Equals Overload
NFX.DataAccess.Distributed Namespace


GDIDSymbol.GetHashCode Method

GDIDSymbol GetHashCode Method NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
GDIDSymbol Structure
GDIDSymbol Members
NFX.DataAccess.Distributed Namespace


GDIDSymbol.ToString Method

GDIDSymbol ToString Method NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
GDIDSymbol Structure
GDIDSymbol Members
NFX.DataAccess.Distributed Namespace


GDIDSymbol Properties

GDIDSymbol Properties NFX Class Library

The GDIDSymbol type exposes the following members.
Properties
 | Name | Description
Public property | IsZero |
Back to Top
See Also
GDIDSymbol Structure
NFX.DataAccess.Distributed Namespace


GDIDSymbol.IsZero Property

GDIDSymbol IsZero Property NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsZero { get; }
public bool IsZero { get; }
Public ReadOnly Property IsZero As Boolean
    Get
Public ReadOnly Property IsZero As Boolean
    Get
public:
property bool IsZero {
    bool get ();
}
public:
property bool IsZero {
    bool get ();
}
member IsZero : bool with get
member IsZero : bool with get

Property Value

Type: Online Boolean
See Also
GDIDSymbol Structure
GDIDSymbol Members
NFX.DataAccess.Distributed Namespace


IArea Interface

IArea Interface NFX Class Library

Provides information about an area of a bank schema. This information does not depend on a particular bank instance, as it is common for all banks that implement the same schema. Area provides configuration information for parcels that it can store. Every instance of this (interface-implementer) class has a corresponding IAreaInstance instance that stores information for every particular bank, i.e. what distribution policies are applied (such as sharding) to the parcels stored in this area

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IArea : INamed
public interface IArea : INamed
Public Interface IArea
    Inherits INamed
Public Interface IArea
    Inherits INamed
public interface class IArea : INamed
public interface class IArea : INamed
type IArea =
    interface
        interface INamed
    end
type IArea =
    interface
        interface INamed
    end
See Also
IArea Members
NFX.DataAccess.Distributed Namespace


IArea Members

IArea Members NFX Class Library

The IArea type exposes the following members.
Properties
 | Name | Description
Public property | Description | Returns area description
Public property | DeviceType | Returns the type of device driver that loads/stores data
Public property | Name | (Inherited from INamed.)
Public property | Schema | Returns schema that this area is in
Back to Top
See Also
IArea Interface
NFX.DataAccess.Distributed Namespace


IArea Properties

IArea Properties NFX Class Library

The IArea type exposes the following members.
Properties
 | Name | Description
Public property | Description | Returns area description
Public property | DeviceType | Returns the type of device driver that loads/stores data
Public property | Name | (Inherited from INamed.)
Public property | Schema | Returns schema that this area is in
Back to Top
See Also
IArea Interface
NFX.DataAccess.Distributed Namespace


IArea.Description Property

IArea Description Property NFX Class Library

Returns area description

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Description { get; }
string Description { get; }
ReadOnly Property Description As String
    Get
ReadOnly Property Description As String
    Get
property String^ Description {
    String^ get ();
}
property String^ Description {
    String^ get ();
}
abstract Description : string with get
abstract Description : string with get

Property Value

Type: Online String
See Also
IArea Interface
IArea Members
NFX.DataAccess.Distributed Namespace


IArea.DeviceType Property

IArea DeviceType Property NFX Class Library

Returns the type of device driver that loads/stores data

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Type DeviceType { get; }
Type DeviceType { get; }
ReadOnly Property DeviceType As Type
    Get
ReadOnly Property DeviceType As Type
    Get
property Type^ DeviceType {
    Type^ get ();
}
property Type^ DeviceType {
    Type^ get ();
}
abstract DeviceType : Type with get
abstract DeviceType : Type with get

Property Value

Type: Online Type
See Also
IArea Interface
IArea Members
NFX.DataAccess.Distributed Namespace


IArea.Schema Property

IArea Schema Property NFX Class Library

Returns schema that this area is in

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ISchema Schema { get; }
ISchema Schema { get; }
ReadOnly Property Schema As ISchema
    Get
ReadOnly Property Schema As ISchema
    Get
property ISchema^ Schema {
    ISchema^ get ();
}
property ISchema^ Schema {
    ISchema^ get ();
}
abstract Schema : ISchema with get
abstract Schema : ISchema with get

Property Value

Type: ISchema
See Also
IArea Interface
IArea Members
NFX.DataAccess.Distributed Namespace


IAreaInstance Interface

IAreaInstance Interface NFX Class Library

Represents data for a concrete instance of schema area within banks, this depends on a concrete bank instance (unlike it's complementary part IArea)

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IAreaInstance : INamed
public interface IAreaInstance : INamed
Public Interface IAreaInstance
    Inherits INamed
Public Interface IAreaInstance
    Inherits INamed
public interface class IAreaInstance : INamed
public interface class IAreaInstance : INamed
type IAreaInstance =
    interface
        interface INamed
    end
type IAreaInstance =
    interface
        interface INamed
    end
See Also
IAreaInstance Members
NFX.DataAccess.Distributed Namespace


IAreaInstance Members

IAreaInstance Members NFX Class Library

The IAreaInstance type exposes the following members.
Properties
 | Name | Description
Public property | Area | Returns schema area that this bank area represents - a prototype of this instance
Public property | Bank | Returns bank instance that this area is in
Public property | Name | (Inherited from INamed.)
Back to Top
See Also
IAreaInstance Interface
NFX.DataAccess.Distributed Namespace


IAreaInstance Properties

IAreaInstance Properties NFX Class Library

The IAreaInstance type exposes the following members.
Properties
 | Name | Description
Public property | Area | Returns schema area that this bank area represents - a prototype of this instance
Public property | Bank | Returns bank instance that this area is in
Public property | Name | (Inherited from INamed.)
Back to Top
See Also
IAreaInstance Interface
NFX.DataAccess.Distributed Namespace


IAreaInstance.Area Property

IAreaInstance Area Property NFX Class Library

Returns schema area that this bank area represents - a prototype of this instance

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IArea Area { get; }
IArea Area { get; }
ReadOnly Property Area As IArea
    Get
ReadOnly Property Area As IArea
    Get
property IArea^ Area {
    IArea^ get ();
}
property IArea^ Area {
    IArea^ get ();
}
abstract Area : IArea with get
abstract Area : IArea with get

Property Value

Type: IArea
See Also
IAreaInstance Interface
IAreaInstance Members
NFX.DataAccess.Distributed Namespace


IAreaInstance.Bank Property

IAreaInstance Bank Property NFX Class Library

Returns bank instance that this area is in

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IBank Bank { get; }
IBank Bank { get; }
ReadOnly Property Bank As IBank
    Get
ReadOnly Property Bank As IBank
    Get
property IBank^ Bank {
    IBank^ get ();
}
property IBank^ Bank {
    IBank^ get ();
}
abstract Bank : IBank with get
abstract Bank : IBank with get

Property Value

Type: IBank
See Also
IAreaInstance Interface
IAreaInstance Members
NFX.DataAccess.Distributed Namespace


IBank Interface

IBank Interface NFX Class Library

Provides abstraction for Global Database Bank instance

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IBank : INamed
public interface IBank : INamed
Public Interface IBank
    Inherits INamed
Public Interface IBank
    Inherits INamed
public interface class IBank : INamed
public interface class IBank : INamed
type IBank =
    interface
        interface INamed
    end
type IBank =
    interface
        interface INamed
    end
See Also
IBank Members
NFX.DataAccess.Distributed Namespace


IBank Members

IBank Members NFX Class Library

The IBank type exposes the following members.
Methods
 | Name | Description
Public method | GenerateReplicationVersionInfo | Generates version replication information for the parcel instance which is being sealed
Public method | GetDescription | Returns database description for the specific culture. This method is needed because end users may need to see the description of the database instance in their native language
Public method | Load(Type, GDID, Object, DataVeracity, DataCaching, Nullable Int32 , ISession) | Loads parcel by fetching it from the bank backened by its primary id
Public method | Load T (GDID, Object, DataVeracity, DataCaching, Nullable Int32 , ISession) | Loads parcel by fetching it from the bank backened by its primary id
Public method | LoadAsync(Type, GDID, Object, DataVeracity, DataCaching, Nullable Int32 , ISession) | Async version: Loads parcel by fetching it from the bank backened by its primary id
Public method | LoadAsync T (GDID, Object, DataVeracity, DataCaching, Nullable Int32 , ISession) | Async version: Loads parcel by fetching it from the bank backened by its primary id
Public method | ObjectToShardingID | Returns ULONG for an object so any object (i.e. a string) may be used as a sharding key. Suppose a string needs to be used for sharding, this method translates a string into a 64 bit hash expressed as ulong
Public method | Query | Loads result object by executing a query command in the bank backend fetching necessary parcels/records/documents and aggregating the result. The query may return parcel/s that can be modified and saved back into the store
Public method | QueryAsync | Async version: Loads result object by executing a query command in the bank backend fetching necessary parcels/records/documents and aggregating the result. The query may return parcel/s that can be modified and saved back into the store
Public method | Remove(Type, GDID, Object, ISession) | Removes the parcel from the bank returning true if parcel was found and removed
Public method | Remove T (GDID, Object, ISession) | Removes the parcel from the bank returning true if parcel was found and removed
Public method | RemoveAsync(Type, GDID, Object, ISession) | Async version: Removes the parcel from the bank returning true if parcel was found and removed
Public method | RemoveAsync T (GDID, Object, ISession) | Async version: Removes the parcel from the bank returning true if parcel was found and removed
Public method | Save | Saves/sends the parcel into this bank
Public method | SaveAsync | Async version: Saves/sends the parcel into this bank
Back to Top
Properties
 | Name | Description
Public property | Areas | Returns registry of named bank schema area instances
Public property | DataStore | References data store that this data bank is a part of
Public property | Description | Returns database description
Public property | IDGenerator | Returns sequence provider that generates unique identifiers in the store
Public property | Name | (Inherited from INamed.)
Public property | Schema | Returns the schema that this bank implements
Back to Top
See Also
IBank Interface
NFX.DataAccess.Distributed Namespace


IBank Methods

IBank Methods NFX Class Library

The IBank type exposes the following members.
Methods
 | Name | Description
Public method | GenerateReplicationVersionInfo | Generates version replication information for the parcel instance which is being sealed
Public method | GetDescription | Returns database description for the specific culture. This method is needed because end users may need to see the description of the database instance in their native language
Public method | Load(Type, GDID, Object, DataVeracity, DataCaching, Nullable Int32 , ISession) | Loads parcel by fetching it from the bank backened by its primary id
Public method | Load T (GDID, Object, DataVeracity, DataCaching, Nullable Int32 , ISession) | Loads parcel by fetching it from the bank backened by its primary id
Public method | LoadAsync(Type, GDID, Object, DataVeracity, DataCaching, Nullable Int32 , ISession) | Async version: Loads parcel by fetching it from the bank backened by its primary id
Public method | LoadAsync T (GDID, Object, DataVeracity, DataCaching, Nullable Int32 , ISession) | Async version: Loads parcel by fetching it from the bank backened by its primary id
Public method | ObjectToShardingID | Returns ULONG for an object so any object (i.e. a string) may be used as a sharding key. Suppose a string needs to be used for sharding, this method translates a string into a 64 bit hash expressed as ulong
Public method | Query | Loads result object by executing a query command in the bank backend fetching necessary parcels/records/documents and aggregating the result. The query may return parcel/s that can be modified and saved back into the store
Public method | QueryAsync | Async version: Loads result object by executing a query command in the bank backend fetching necessary parcels/records/documents and aggregating the result. The query may return parcel/s that can be modified and saved back into the store
Public method | Remove(Type, GDID, Object, ISession) | Removes the parcel from the bank returning true if parcel was found and removed
Public method | Remove T (GDID, Object, ISession) | Removes the parcel from the bank returning true if parcel was found and removed
Public method | RemoveAsync(Type, GDID, Object, ISession) | Async version: Removes the parcel from the bank returning true if parcel was found and removed
Public method | RemoveAsync T (GDID, Object, ISession) | Async version: Removes the parcel from the bank returning true if parcel was found and removed
Public method | Save | Saves/sends the parcel into this bank
Public method | SaveAsync | Async version: Saves/sends the parcel into this bank
Back to Top
See Also
IBank Interface
NFX.DataAccess.Distributed Namespace


IBank.GenerateReplicationVersionInfo Method

IBank GenerateReplicationVersionInfo Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Generates version replication information for the parcel instance which is being sealed

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IReplicationVersionInfo GenerateReplicationVersionInfo(
    Parcel parcel
)
IReplicationVersionInfo GenerateReplicationVersionInfo(
    Parcel parcel
)
Function GenerateReplicationVersionInfo (
    parcel As Parcel
) As IReplicationVersionInfo
Function GenerateReplicationVersionInfo (
    parcel As Parcel
) As IReplicationVersionInfo
IReplicationVersionInfo^ GenerateReplicationVersionInfo(
    Parcel^ parcel
)
IReplicationVersionInfo^ GenerateReplicationVersionInfo(
    Parcel^ parcel
)
abstract GenerateReplicationVersionInfo :
        parcel : Parcel -> IReplicationVersionInfo
abstract GenerateReplicationVersionInfo :
        parcel : Parcel -> IReplicationVersionInfo

Parameters

parcel
Type: NFX.DataAccess.Distributed Parcel

Return Value

Type: IReplicationVersionInfo
See Also
IBank Interface
IBank Members
NFX.DataAccess.Distributed Namespace


IBank.GetDescription Method

IBank GetDescription Method NFX Class Library

Returns database description for the specific culture. This method is needed because end users may need to see the description of the database instance in their native language

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string GetDescription(
    string culture
)
string GetDescription(
    string culture
)
Function GetDescription (
    culture As String
) As String
Function GetDescription (
    culture As String
) As String
String^ GetDescription(
    String^ culture
)
String^ GetDescription(
    String^ culture
)
abstract GetDescription :
        culture : string -> string
abstract GetDescription :
        culture : string -> string

Parameters

culture
Type: Online System String

Return Value

Type: Online String
See Also
IBank Interface
IBank Members
NFX.DataAccess.Distributed Namespace


IBank.Load Method

IBank Load Method NFX Class Library

Overload List
 | Name | Description
Public method | Load T (GDID, Object, DataVeracity, DataCaching, Nullable Int32 , ISession) | Loads parcel by fetching it from the bank backened by its primary id
Public method | Load(Type, GDID, Object, DataVeracity, DataCaching, Nullable Int32 , ISession) | Loads parcel by fetching it from the bank backened by its primary id
Back to Top
See Also
IBank Interface
IBank Members
NFX.DataAccess.Distributed Namespace


IBank.Load(T) Method (GDID, Object, DataVeracity, DataCaching, Nullable(Int32), ISession)

IBank Load T Method (GDID, Object, DataVeracity, DataCaching, Nullable Int32 , ISession) NFX Class Library

[This is preliminary documentation and is subject to change.]

Loads parcel by fetching it from the bank backened by its primary id

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
T Load<T>(
    GDID id,
    Object shardingID = null,
    DataVeracity veracity = DataVeracity.Maximum,
    DataCaching cacheOpt = DataCaching.LatestData,
    Nullable<int> cacheMaxAgeSec = null,
    ISession session = null
)
where T : Parcel
T Load<T>(
    GDID id,
    Object shardingID = null,
    DataVeracity veracity = DataVeracity.Maximum,
    DataCaching cacheOpt = DataCaching.LatestData,
    Nullable<int> cacheMaxAgeSec = null,
    ISession session = null
)
where T : Parcel
Function Load(Of T As Parcel) (
    id As GDID,
    Optional shardingID As Object = Nothing,
    Optional veracity As DataVeracity = DataVeracity.Maximum,
    Optional cacheOpt As DataCaching = DataCaching.LatestData,
    Optional cacheMaxAgeSec As Nullable(Of Integer) = Nothing,
    Optional session As ISession = Nothing
) As T
Function Load(Of T As Parcel) (
    id As GDID,
    Optional shardingID As Object = Nothing,
    Optional veracity As DataVeracity = DataVeracity.Maximum,
    Optional cacheOpt As DataCaching = DataCaching.LatestData,
    Optional cacheMaxAgeSec As Nullable(Of Integer) = Nothing,
    Optional session As ISession = Nothing
) As T
generic<typename T>
where T : Parcel
T Load(
    GDID id,
    Object^ shardingID = nullptr,
    DataVeracity veracity = DataVeracity::Maximum,
    DataCaching cacheOpt = DataCaching::LatestData,
    Nullable<int> cacheMaxAgeSec = nullptr,
    ISession^ session = nullptr
)
generic<typename T>
where T : Parcel
T Load(
    GDID id,
    Object^ shardingID = nullptr,
    DataVeracity veracity = DataVeracity::Maximum,
    DataCaching cacheOpt = DataCaching::LatestData,
    Nullable<int> cacheMaxAgeSec = nullptr,
    ISession^ session = nullptr
)
abstract Load :
        id : GDID *
        ?shardingID : Object *
        ?veracity : DataVeracity *
        ?cacheOpt : DataCaching *
        ?cacheMaxAgeSec : Nullable<int> *
        ?session : ISession
(* Defaults:
        let _shardingID = defaultArg shardingID null
        let _veracity = defaultArg veracity DataVeracity.Maximum
        let _cacheOpt = defaultArg cacheOpt DataCaching.LatestData
        let _cacheMaxAgeSec = defaultArg cacheMaxAgeSec null
        let _session = defaultArg session null
*)
-> 'T  when 'T : Parcel
abstract Load :
        id : GDID *
        ?shardingID : Object *
        ?veracity : DataVeracity *
        ?cacheOpt : DataCaching *
        ?cacheMaxAgeSec : Nullable<int> *
        ?session : ISession
(* Defaults:
        let _shardingID = defaultArg shardingID null
        let _veracity = defaultArg veracity DataVeracity.Maximum
        let _cacheOpt = defaultArg cacheOpt DataCaching.LatestData
        let _cacheMaxAgeSec = defaultArg cacheMaxAgeSec null
        let _session = defaultArg session null
*)
-> 'T  when 'T : Parcel

Parameters

id
Type: NFX.DataAccess.Distributed GDID
The unique GDID of the parcel
shardingID (Optional)
Type: Online System Object
The ID of the entity used for sharding, i.e. a message may use ID of the item that the message relates to, so messages get sharded in the same location as their "parent" record. The parcel type T specifies the DataParcelAttirbute.GetParcelAttr(typeof(T)).ShardingParcel
veracity (Optional)
Type: NFX.DataAccess.Distributed DataVeracity
The level of data veracity
cacheOpt (Optional)
Type: NFX.DataAccess.Distributed DataCaching
The cache control options
cacheMaxAgeSec (Optional)
Type: Online System Nullable Online Int32
The maximum acceptable age of cached instance, cached data will be re-queried from backend if it is older
session (Optional)
Type: NFX.ApplicationModel ISession
User session, if null session will be taken from execution context. The session may be needed for policy filtering
Type Parameters
T

Return Value

Type: T
See Also
IBank Interface
IBank Members
Load Overload
NFX.DataAccess.Distributed Namespace


IBank.Load Method (Type, GDID, Object, DataVeracity, DataCaching, Nullable(Int32), ISession)

IBank Load Method (Type, GDID, Object, DataVeracity, DataCaching, Nullable Int32 , ISession) NFX Class Library

[This is preliminary documentation and is subject to change.]

Loads parcel by fetching it from the bank backened by its primary id

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Parcel Load(
    Type tParcel,
    GDID id,
    Object shardingID = null,
    DataVeracity veracity = DataVeracity.Maximum,
    DataCaching cacheOpt = DataCaching.LatestData,
    Nullable<int> cacheMaxAgeSec = null,
    ISession session = null
)
Parcel Load(
    Type tParcel,
    GDID id,
    Object shardingID = null,
    DataVeracity veracity = DataVeracity.Maximum,
    DataCaching cacheOpt = DataCaching.LatestData,
    Nullable<int> cacheMaxAgeSec = null,
    ISession session = null
)
Function Load (
    tParcel As Type,
    id As GDID,
    Optional shardingID As Object = Nothing,
    Optional veracity As DataVeracity = DataVeracity.Maximum,
    Optional cacheOpt As DataCaching = DataCaching.LatestData,
    Optional cacheMaxAgeSec As Nullable(Of Integer) = Nothing,
    Optional session As ISession = Nothing
) As Parcel
Function Load (
    tParcel As Type,
    id As GDID,
    Optional shardingID As Object = Nothing,
    Optional veracity As DataVeracity = DataVeracity.Maximum,
    Optional cacheOpt As DataCaching = DataCaching.LatestData,
    Optional cacheMaxAgeSec As Nullable(Of Integer) = Nothing,
    Optional session As ISession = Nothing
) As Parcel
Parcel^ Load(
    Type^ tParcel,
    GDID id,
    Object^ shardingID = nullptr,
    DataVeracity veracity = DataVeracity::Maximum,
    DataCaching cacheOpt = DataCaching::LatestData,
    Nullable<int> cacheMaxAgeSec = nullptr,
    ISession^ session = nullptr
)
Parcel^ Load(
    Type^ tParcel,
    GDID id,
    Object^ shardingID = nullptr,
    DataVeracity veracity = DataVeracity::Maximum,
    DataCaching cacheOpt = DataCaching::LatestData,
    Nullable<int> cacheMaxAgeSec = nullptr,
    ISession^ session = nullptr
)
abstract Load :
        tParcel : Type *
        id : GDID *
        ?shardingID : Object *
        ?veracity : DataVeracity *
        ?cacheOpt : DataCaching *
        ?cacheMaxAgeSec : Nullable<int> *
        ?session : ISession
(* Defaults:
        let _shardingID = defaultArg shardingID null
        let _veracity = defaultArg veracity DataVeracity.Maximum
        let _cacheOpt = defaultArg cacheOpt DataCaching.LatestData
        let _cacheMaxAgeSec = defaultArg cacheMaxAgeSec null
        let _session = defaultArg session null
*)
-> Parcel
abstract Load :
        tParcel : Type *
        id : GDID *
        ?shardingID : Object *
        ?veracity : DataVeracity *
        ?cacheOpt : DataCaching *
        ?cacheMaxAgeSec : Nullable<int> *
        ?session : ISession
(* Defaults:
        let _shardingID = defaultArg shardingID null
        let _veracity = defaultArg veracity DataVeracity.Maximum
        let _cacheOpt = defaultArg cacheOpt DataCaching.LatestData
        let _cacheMaxAgeSec = defaultArg cacheMaxAgeSec null
        let _session = defaultArg session null
*)
-> Parcel

Parameters

tParcel
Type: Online System Type
Parcel type to load
id
Type: NFX.DataAccess.Distributed GDID
The unique GDID of the parcel
shardingID (Optional)
Type: Online System Object
The ID of the entity used for sharding, i.e. a message may use ID of the item that the message relates to, so messages get sharded in the same location as their "parent" record. The parcel type T specifies the DataParcelAttirbute.GetParcelAttr(typeof(T)).ShardingParcel
veracity (Optional)
Type: NFX.DataAccess.Distributed DataVeracity
The level of data veracity
cacheOpt (Optional)
Type: NFX.DataAccess.Distributed DataCaching
The cache control options
cacheMaxAgeSec (Optional)
Type: Online System Nullable Online Int32
The maximum acceptable age of cached instance, cached data will be re-queried from backend if it is older
session (Optional)
Type: NFX.ApplicationModel ISession
User session, if null session will be taken from execution context. The session may be needed for policy filtering

Return Value

Type: Parcel
See Also
IBank Interface
IBank Members
Load Overload
NFX.DataAccess.Distributed Namespace


IBank.LoadAsync Method

IBank LoadAsync Method NFX Class Library

Overload List
 | Name | Description
Public method | LoadAsync T (GDID, Object, DataVeracity, DataCaching, Nullable Int32 , ISession) | Async version: Loads parcel by fetching it from the bank backened by its primary id
Public method | LoadAsync(Type, GDID, Object, DataVeracity, DataCaching, Nullable Int32 , ISession) | Async version: Loads parcel by fetching it from the bank backened by its primary id
Back to Top
See Also
IBank Interface
IBank Members
NFX.DataAccess.Distributed Namespace


IBank.LoadAsync(T) Method (GDID, Object, DataVeracity, DataCaching, Nullable(Int32), ISession)

IBank LoadAsync T Method (GDID, Object, DataVeracity, DataCaching, Nullable Int32 , ISession) NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version: Loads parcel by fetching it from the bank backened by its primary id

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Task<T> LoadAsync<T>(
    GDID id,
    Object shardingID = null,
    DataVeracity veracity = DataVeracity.Maximum,
    DataCaching cacheOpt = DataCaching.LatestData,
    Nullable<int> cacheMaxAgeSec = null,
    ISession session = null
)
where T : Parcel
Task<T> LoadAsync<T>(
    GDID id,
    Object shardingID = null,
    DataVeracity veracity = DataVeracity.Maximum,
    DataCaching cacheOpt = DataCaching.LatestData,
    Nullable<int> cacheMaxAgeSec = null,
    ISession session = null
)
where T : Parcel
Function LoadAsync(Of T As Parcel) (
    id As GDID,
    Optional shardingID As Object = Nothing,
    Optional veracity As DataVeracity = DataVeracity.Maximum,
    Optional cacheOpt As DataCaching = DataCaching.LatestData,
    Optional cacheMaxAgeSec As Nullable(Of Integer) = Nothing,
    Optional session As ISession = Nothing
) As Task(Of T)
Function LoadAsync(Of T As Parcel) (
    id As GDID,
    Optional shardingID As Object = Nothing,
    Optional veracity As DataVeracity = DataVeracity.Maximum,
    Optional cacheOpt As DataCaching = DataCaching.LatestData,
    Optional cacheMaxAgeSec As Nullable(Of Integer) = Nothing,
    Optional session As ISession = Nothing
) As Task(Of T)
generic<typename T>
where T : Parcel
Task<T>^ LoadAsync(
    GDID id,
    Object^ shardingID = nullptr,
    DataVeracity veracity = DataVeracity::Maximum,
    DataCaching cacheOpt = DataCaching::LatestData,
    Nullable<int> cacheMaxAgeSec = nullptr,
    ISession^ session = nullptr
)
generic<typename T>
where T : Parcel
Task<T>^ LoadAsync(
    GDID id,
    Object^ shardingID = nullptr,
    DataVeracity veracity = DataVeracity::Maximum,
    DataCaching cacheOpt = DataCaching::LatestData,
    Nullable<int> cacheMaxAgeSec = nullptr,
    ISession^ session = nullptr
)
abstract LoadAsync :
        id : GDID *
        ?shardingID : Object *
        ?veracity : DataVeracity *
        ?cacheOpt : DataCaching *
        ?cacheMaxAgeSec : Nullable<int> *
        ?session : ISession
(* Defaults:
        let _shardingID = defaultArg shardingID null
        let _veracity = defaultArg veracity DataVeracity.Maximum
        let _cacheOpt = defaultArg cacheOpt DataCaching.LatestData
        let _cacheMaxAgeSec = defaultArg cacheMaxAgeSec null
        let _session = defaultArg session null
*)
-> Task<'T>  when 'T : Parcel
abstract LoadAsync :
        id : GDID *
        ?shardingID : Object *
        ?veracity : DataVeracity *
        ?cacheOpt : DataCaching *
        ?cacheMaxAgeSec : Nullable<int> *
        ?session : ISession
(* Defaults:
        let _shardingID = defaultArg shardingID null
        let _veracity = defaultArg veracity DataVeracity.Maximum
        let _cacheOpt = defaultArg cacheOpt DataCaching.LatestData
        let _cacheMaxAgeSec = defaultArg cacheMaxAgeSec null
        let _session = defaultArg session null
*)
-> Task<'T>  when 'T : Parcel

Parameters

id
Type: NFX.DataAccess.Distributed GDID
The unique GDID of the parcel
shardingID (Optional)
Type: Online System Object
The ID of the entity used for sharding, i.e. a message may use ID of the item that the message relates to, so messages get sharded in the same location as their "parent" record. The parcel type T specifies the DataParcelAttirbute.GetParcelAttr(typeof(T)).ShardingParcel
veracity (Optional)
Type: NFX.DataAccess.Distributed DataVeracity
The level of data veracity
cacheOpt (Optional)
Type: NFX.DataAccess.Distributed DataCaching
The cache control options
cacheMaxAgeSec (Optional)
Type: Online System Nullable Online Int32
The maximum acceptable age of cached instance, cached data will be re-queried from backend if it is older
session (Optional)
Type: NFX.ApplicationModel ISession
User session, if null session will be taken from execution context. The session may be needed for policy filtering
Type Parameters
T

Return Value

Type: Online Task T
See Also
IBank Interface
IBank Members
LoadAsync Overload
NFX.DataAccess.Distributed Namespace


IBank.LoadAsync Method (Type, GDID, Object, DataVeracity, DataCaching, Nullable(Int32), ISession)

IBank LoadAsync Method (Type, GDID, Object, DataVeracity, DataCaching, Nullable Int32 , ISession) NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version: Loads parcel by fetching it from the bank backened by its primary id

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Task<Parcel> LoadAsync(
    Type tParcel,
    GDID id,
    Object shardingID = null,
    DataVeracity veracity = DataVeracity.Maximum,
    DataCaching cacheOpt = DataCaching.LatestData,
    Nullable<int> cacheMaxAgeSec = null,
    ISession session = null
)
Task<Parcel> LoadAsync(
    Type tParcel,
    GDID id,
    Object shardingID = null,
    DataVeracity veracity = DataVeracity.Maximum,
    DataCaching cacheOpt = DataCaching.LatestData,
    Nullable<int> cacheMaxAgeSec = null,
    ISession session = null
)
Function LoadAsync (
    tParcel As Type,
    id As GDID,
    Optional shardingID As Object = Nothing,
    Optional veracity As DataVeracity = DataVeracity.Maximum,
    Optional cacheOpt As DataCaching = DataCaching.LatestData,
    Optional cacheMaxAgeSec As Nullable(Of Integer) = Nothing,
    Optional session As ISession = Nothing
) As Task(Of Parcel)
Function LoadAsync (
    tParcel As Type,
    id As GDID,
    Optional shardingID As Object = Nothing,
    Optional veracity As DataVeracity = DataVeracity.Maximum,
    Optional cacheOpt As DataCaching = DataCaching.LatestData,
    Optional cacheMaxAgeSec As Nullable(Of Integer) = Nothing,
    Optional session As ISession = Nothing
) As Task(Of Parcel)
Task<Parcel^>^ LoadAsync(
    Type^ tParcel,
    GDID id,
    Object^ shardingID = nullptr,
    DataVeracity veracity = DataVeracity::Maximum,
    DataCaching cacheOpt = DataCaching::LatestData,
    Nullable<int> cacheMaxAgeSec = nullptr,
    ISession^ session = nullptr
)
Task<Parcel^>^ LoadAsync(
    Type^ tParcel,
    GDID id,
    Object^ shardingID = nullptr,
    DataVeracity veracity = DataVeracity::Maximum,
    DataCaching cacheOpt = DataCaching::LatestData,
    Nullable<int> cacheMaxAgeSec = nullptr,
    ISession^ session = nullptr
)
abstract LoadAsync :
        tParcel : Type *
        id : GDID *
        ?shardingID : Object *
        ?veracity : DataVeracity *
        ?cacheOpt : DataCaching *
        ?cacheMaxAgeSec : Nullable<int> *
        ?session : ISession
(* Defaults:
        let _shardingID = defaultArg shardingID null
        let _veracity = defaultArg veracity DataVeracity.Maximum
        let _cacheOpt = defaultArg cacheOpt DataCaching.LatestData
        let _cacheMaxAgeSec = defaultArg cacheMaxAgeSec null
        let _session = defaultArg session null
*)
-> Task<Parcel>
abstract LoadAsync :
        tParcel : Type *
        id : GDID *
        ?shardingID : Object *
        ?veracity : DataVeracity *
        ?cacheOpt : DataCaching *
        ?cacheMaxAgeSec : Nullable<int> *
        ?session : ISession
(* Defaults:
        let _shardingID = defaultArg shardingID null
        let _veracity = defaultArg veracity DataVeracity.Maximum
        let _cacheOpt = defaultArg cacheOpt DataCaching.LatestData
        let _cacheMaxAgeSec = defaultArg cacheMaxAgeSec null
        let _session = defaultArg session null
*)
-> Task<Parcel>

Parameters

tParcel
Type: Online System Type
Parcel type to load
id
Type: NFX.DataAccess.Distributed GDID
The unique GDID of the parcel
shardingID (Optional)
Type: Online System Object
The ID of the entity used for sharding, i.e. a message may use ID of the item that the message relates to, so messages get sharded in the same location as their "parent" record. The parcel type T specifies the DataParcelAttirbute.GetParcelAttr(typeof(T)).ShardingParcel
veracity (Optional)
Type: NFX.DataAccess.Distributed DataVeracity
The level of data veracity
cacheOpt (Optional)
Type: NFX.DataAccess.Distributed DataCaching
The cache control options
cacheMaxAgeSec (Optional)
Type: Online System Nullable Online Int32
The maximum acceptable age of cached instance, cached data will be re-queried from backend if it is older
session (Optional)
Type: NFX.ApplicationModel ISession
User session, if null session will be taken from execution context. The session may be needed for policy filtering

Return Value

Type: Online Task Parcel
See Also
IBank Interface
IBank Members
LoadAsync Overload
NFX.DataAccess.Distributed Namespace


IBank.ObjectToShardingID Method

IBank ObjectToShardingID Method NFX Class Library

Returns ULONG for an object so any object (i.e. a string) may be used as a sharding key. Suppose a string needs to be used for sharding, this method translates a string into a 64 bit hash expressed as ulong

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ulong ObjectToShardingID(
    Object key
)
ulong ObjectToShardingID(
    Object key
)
Function ObjectToShardingID (
    key As Object
) As ULong
Function ObjectToShardingID (
    key As Object
) As ULong
unsigned long long ObjectToShardingID(
    Object^ key
)
unsigned long long ObjectToShardingID(
    Object^ key
)
abstract ObjectToShardingID :
        key : Object -> uint64
abstract ObjectToShardingID :
        key : Object -> uint64

Parameters

key
Type: Online System Object
An object used for sharding ID translation

Return Value

Type: Online UInt64
UInt64 that represents the sharding ID
See Also
IBank Interface
IBank Members
NFX.DataAccess.Distributed Namespace


IBank.Query Method

IBank Query Method NFX Class Library

Loads result object by executing a query command in the bank backend fetching necessary parcels/records/documents and aggregating the result. The query may return parcel/s that can be modified and saved back into the store

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object Query(
    Command command,
    DataVeracity veracity = DataVeracity.Maximum,
    DataCaching cacheOpt = DataCaching.LatestData,
    Nullable<int> cacheMaxAgeSec = null,
    ISession session = null
)
Object Query(
    Command command,
    DataVeracity veracity = DataVeracity.Maximum,
    DataCaching cacheOpt = DataCaching.LatestData,
    Nullable<int> cacheMaxAgeSec = null,
    ISession session = null
)
Function Query (
    command As Command,
    Optional veracity As DataVeracity = DataVeracity.Maximum,
    Optional cacheOpt As DataCaching = DataCaching.LatestData,
    Optional cacheMaxAgeSec As Nullable(Of Integer) = Nothing,
    Optional session As ISession = Nothing
) As Object
Function Query (
    command As Command,
    Optional veracity As DataVeracity = DataVeracity.Maximum,
    Optional cacheOpt As DataCaching = DataCaching.LatestData,
    Optional cacheMaxAgeSec As Nullable(Of Integer) = Nothing,
    Optional session As ISession = Nothing
) As Object
Object^ Query(
    Command^ command,
    DataVeracity veracity = DataVeracity::Maximum,
    DataCaching cacheOpt = DataCaching::LatestData,
    Nullable<int> cacheMaxAgeSec = nullptr,
    ISession^ session = nullptr
)
Object^ Query(
    Command^ command,
    DataVeracity veracity = DataVeracity::Maximum,
    DataCaching cacheOpt = DataCaching::LatestData,
    Nullable<int> cacheMaxAgeSec = nullptr,
    ISession^ session = nullptr
)
abstract Query :
        command : Command *
        ?veracity : DataVeracity *
        ?cacheOpt : DataCaching *
        ?cacheMaxAgeSec : Nullable<int> *
        ?session : ISession
(* Defaults:
        let _veracity = defaultArg veracity DataVeracity.Maximum
        let _cacheOpt = defaultArg cacheOpt DataCaching.LatestData
        let _cacheMaxAgeSec = defaultArg cacheMaxAgeSec null
        let _session = defaultArg session null
*)
-> Object
abstract Query :
        command : Command *
        ?veracity : DataVeracity *
        ?cacheOpt : DataCaching *
        ?cacheMaxAgeSec : Nullable<int> *
        ?session : ISession
(* Defaults:
        let _veracity = defaultArg veracity DataVeracity.Maximum
        let _cacheOpt = defaultArg cacheOpt DataCaching.LatestData
        let _cacheMaxAgeSec = defaultArg cacheMaxAgeSec null
        let _session = defaultArg session null
*)
-> Object

Parameters

command
Type: NFX.DataAccess.Distributed Command
The command object that contains command name and parameters to query the datastore
veracity (Optional)
Type: NFX.DataAccess.Distributed DataVeracity
The level of data veracity
cacheOpt (Optional)
Type: NFX.DataAccess.Distributed DataCaching
The cache control options
cacheMaxAgeSec (Optional)
Type: Online System Nullable Online Int32
The maximum acceptable age of cached instance, cached data will be re-queried from backend if it is older
session (Optional)
Type: NFX.ApplicationModel ISession
User session, if null session will be taken from execution context. The session may be needed for policy filtering

Return Value

Type: Online Object
See Also
IBank Interface
IBank Members
NFX.DataAccess.Distributed Namespace


IBank.QueryAsync Method

IBank QueryAsync Method NFX Class Library

Async version: Loads result object by executing a query command in the bank backend fetching necessary parcels/records/documents and aggregating the result. The query may return parcel/s that can be modified and saved back into the store

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Task<Object> QueryAsync(
    Command command,
    DataVeracity veracity = DataVeracity.Maximum,
    DataCaching cacheOpt = DataCaching.LatestData,
    Nullable<int> cacheMaxAgeSec = null,
    ISession session = null
)
Task<Object> QueryAsync(
    Command command,
    DataVeracity veracity = DataVeracity.Maximum,
    DataCaching cacheOpt = DataCaching.LatestData,
    Nullable<int> cacheMaxAgeSec = null,
    ISession session = null
)
Function QueryAsync (
    command As Command,
    Optional veracity As DataVeracity = DataVeracity.Maximum,
    Optional cacheOpt As DataCaching = DataCaching.LatestData,
    Optional cacheMaxAgeSec As Nullable(Of Integer) = Nothing,
    Optional session As ISession = Nothing
) As Task(Of Object)
Function QueryAsync (
    command As Command,
    Optional veracity As DataVeracity = DataVeracity.Maximum,
    Optional cacheOpt As DataCaching = DataCaching.LatestData,
    Optional cacheMaxAgeSec As Nullable(Of Integer) = Nothing,
    Optional session As ISession = Nothing
) As Task(Of Object)
Task<Object^>^ QueryAsync(
    Command^ command,
    DataVeracity veracity = DataVeracity::Maximum,
    DataCaching cacheOpt = DataCaching::LatestData,
    Nullable<int> cacheMaxAgeSec = nullptr,
    ISession^ session = nullptr
)
Task<Object^>^ QueryAsync(
    Command^ command,
    DataVeracity veracity = DataVeracity::Maximum,
    DataCaching cacheOpt = DataCaching::LatestData,
    Nullable<int> cacheMaxAgeSec = nullptr,
    ISession^ session = nullptr
)
abstract QueryAsync :
        command : Command *
        ?veracity : DataVeracity *
        ?cacheOpt : DataCaching *
        ?cacheMaxAgeSec : Nullable<int> *
        ?session : ISession
(* Defaults:
        let _veracity = defaultArg veracity DataVeracity.Maximum
        let _cacheOpt = defaultArg cacheOpt DataCaching.LatestData
        let _cacheMaxAgeSec = defaultArg cacheMaxAgeSec null
        let _session = defaultArg session null
*)
-> Task<Object>
abstract QueryAsync :
        command : Command *
        ?veracity : DataVeracity *
        ?cacheOpt : DataCaching *
        ?cacheMaxAgeSec : Nullable<int> *
        ?session : ISession
(* Defaults:
        let _veracity = defaultArg veracity DataVeracity.Maximum
        let _cacheOpt = defaultArg cacheOpt DataCaching.LatestData
        let _cacheMaxAgeSec = defaultArg cacheMaxAgeSec null
        let _session = defaultArg session null
*)
-> Task<Object>

Parameters

command
Type: NFX.DataAccess.Distributed Command
The command object that contains command name and parameters to query the datastore
veracity (Optional)
Type: NFX.DataAccess.Distributed DataVeracity
The level of data veracity
cacheOpt (Optional)
Type: NFX.DataAccess.Distributed DataCaching
The cache control options
cacheMaxAgeSec (Optional)
Type: Online System Nullable Online Int32
The maximum acceptable age of cached instance, cached data will be re-queried from backend if it is older
session (Optional)
Type: NFX.ApplicationModel ISession
User session, if null session will be taken from execution context. The session may be needed for policy filtering

Return Value

Type: Online Task Online Object
See Also
IBank Interface
IBank Members
NFX.DataAccess.Distributed Namespace


IBank.Remove Method

IBank Remove Method NFX Class Library

Overload List
 | Name | Description
Public method | Remove T (GDID, Object, ISession) | Removes the parcel from the bank returning true if parcel was found and removed
Public method | Remove(Type, GDID, Object, ISession) | Removes the parcel from the bank returning true if parcel was found and removed
Back to Top
See Also
IBank Interface
IBank Members
NFX.DataAccess.Distributed Namespace


IBank.Remove(T) Method (GDID, Object, ISession)

IBank Remove T Method (GDID, Object, ISession) NFX Class Library

[This is preliminary documentation and is subject to change.]

Removes the parcel from the bank returning true if parcel was found and removed

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Remove<T>(
    GDID id,
    Object shardingID = null,
    ISession session = null
)
where T : Parcel
bool Remove<T>(
    GDID id,
    Object shardingID = null,
    ISession session = null
)
where T : Parcel
Function Remove(Of T As Parcel) (
    id As GDID,
    Optional shardingID As Object = Nothing,
    Optional session As ISession = Nothing
) As Boolean
Function Remove(Of T As Parcel) (
    id As GDID,
    Optional shardingID As Object = Nothing,
    Optional session As ISession = Nothing
) As Boolean
generic<typename T>
where T : Parcel
bool Remove(
    GDID id,
    Object^ shardingID = nullptr,
    ISession^ session = nullptr
)
generic<typename T>
where T : Parcel
bool Remove(
    GDID id,
    Object^ shardingID = nullptr,
    ISession^ session = nullptr
)
abstract Remove :
        id : GDID *
        ?shardingID : Object *
        ?session : ISession
(* Defaults:
        let _shardingID = defaultArg shardingID null
        let _session = defaultArg session null
*)
-> bool  when 'T : Parcel
abstract Remove :
        id : GDID *
        ?shardingID : Object *
        ?session : ISession
(* Defaults:
        let _shardingID = defaultArg shardingID null
        let _session = defaultArg session null
*)
-> bool  when 'T : Parcel

Parameters

id
Type: NFX.DataAccess.Distributed GDID
The unique GDID of the parcel
shardingID (Optional)
Type: Online System Object
The ID of the entity used for sharding, i.e. a message may use ID of the item that the message relates to, so messages get sharded in the same location as their "parent" record. The parcel type T specifies the DataParcelAttirbute.ShardingParcel
session (Optional)
Type: NFX.ApplicationModel ISession
User session, if null session will be taken from execution context. The session may be needed for policy filtering
Type Parameters
T

Return Value

Type: Online Boolean
See Also
IBank Interface
IBank Members
Remove Overload
NFX.DataAccess.Distributed Namespace


IBank.Remove Method (Type, GDID, Object, ISession)

IBank Remove Method (Type, GDID, Object, ISession) NFX Class Library

[This is preliminary documentation and is subject to change.]

Removes the parcel from the bank returning true if parcel was found and removed

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Remove(
    Type tParcel,
    GDID id,
    Object shardingID = null,
    ISession session = null
)
bool Remove(
    Type tParcel,
    GDID id,
    Object shardingID = null,
    ISession session = null
)
Function Remove (
    tParcel As Type,
    id As GDID,
    Optional shardingID As Object = Nothing,
    Optional session As ISession = Nothing
) As Boolean
Function Remove (
    tParcel As Type,
    id As GDID,
    Optional shardingID As Object = Nothing,
    Optional session As ISession = Nothing
) As Boolean
bool Remove(
    Type^ tParcel,
    GDID id,
    Object^ shardingID = nullptr,
    ISession^ session = nullptr
)
bool Remove(
    Type^ tParcel,
    GDID id,
    Object^ shardingID = nullptr,
    ISession^ session = nullptr
)
abstract Remove :
        tParcel : Type *
        id : GDID *
        ?shardingID : Object *
        ?session : ISession
(* Defaults:
        let _shardingID = defaultArg shardingID null
        let _session = defaultArg session null
*)
-> bool
abstract Remove :
        tParcel : Type *
        id : GDID *
        ?shardingID : Object *
        ?session : ISession
(* Defaults:
        let _shardingID = defaultArg shardingID null
        let _session = defaultArg session null
*)
-> bool

Parameters

tParcel
Type: Online System Type
Type of parcel to remove
id
Type: NFX.DataAccess.Distributed GDID
The unique GDID of the parcel
shardingID (Optional)
Type: Online System Object
The ID of the entity used for sharding, i.e. a message may use ID of the item that the message relates to, so messages get sharded in the same location as their "parent" record. The parcel type T specifies the DataParcelAttirbute.ShardingParcel
session (Optional)
Type: NFX.ApplicationModel ISession
User session, if null session will be taken from execution context. The session may be needed for policy filtering

Return Value

Type: Online Boolean
See Also
IBank Interface
IBank Members
Remove Overload
NFX.DataAccess.Distributed Namespace


IBank.RemoveAsync Method

IBank RemoveAsync Method NFX Class Library

Overload List
 | Name | Description
Public method | RemoveAsync T (GDID, Object, ISession) | Async version: Removes the parcel from the bank returning true if parcel was found and removed
Public method | RemoveAsync(Type, GDID, Object, ISession) | Async version: Removes the parcel from the bank returning true if parcel was found and removed
Back to Top
See Also
IBank Interface
IBank Members
NFX.DataAccess.Distributed Namespace


IBank.RemoveAsync(T) Method (GDID, Object, ISession)

IBank RemoveAsync T Method (GDID, Object, ISession) NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version: Removes the parcel from the bank returning true if parcel was found and removed

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Task<bool> RemoveAsync<T>(
    GDID id,
    Object shardingID = null,
    ISession session = null
)
where T : Parcel
Task<bool> RemoveAsync<T>(
    GDID id,
    Object shardingID = null,
    ISession session = null
)
where T : Parcel
Function RemoveAsync(Of T As Parcel) (
    id As GDID,
    Optional shardingID As Object = Nothing,
    Optional session As ISession = Nothing
) As Task(Of Boolean)
Function RemoveAsync(Of T As Parcel) (
    id As GDID,
    Optional shardingID As Object = Nothing,
    Optional session As ISession = Nothing
) As Task(Of Boolean)
generic<typename T>
where T : Parcel
Task<bool>^ RemoveAsync(
    GDID id,
    Object^ shardingID = nullptr,
    ISession^ session = nullptr
)
generic<typename T>
where T : Parcel
Task<bool>^ RemoveAsync(
    GDID id,
    Object^ shardingID = nullptr,
    ISession^ session = nullptr
)
abstract RemoveAsync :
        id : GDID *
        ?shardingID : Object *
        ?session : ISession
(* Defaults:
        let _shardingID = defaultArg shardingID null
        let _session = defaultArg session null
*)
-> Task<bool>  when 'T : Parcel
abstract RemoveAsync :
        id : GDID *
        ?shardingID : Object *
        ?session : ISession
(* Defaults:
        let _shardingID = defaultArg shardingID null
        let _session = defaultArg session null
*)
-> Task<bool>  when 'T : Parcel

Parameters

id
Type: NFX.DataAccess.Distributed GDID
The unique GDID of the parcel
shardingID (Optional)
Type: Online System Object
The ID of the entity used for sharding, i.e. a message may use ID of the item that the message relates to, so messages get sharded in the same location as their "parent" record. The parcel type T specifies the DataParcelAttirbute.ShardingParcel
session (Optional)
Type: NFX.ApplicationModel ISession
User session, if null session will be taken from execution context. The session may be needed for policy filtering
Type Parameters
T

Return Value

Type: Online Task Online Boolean
See Also
IBank Interface
IBank Members
RemoveAsync Overload
NFX.DataAccess.Distributed Namespace


IBank.RemoveAsync Method (Type, GDID, Object, ISession)

IBank RemoveAsync Method (Type, GDID, Object, ISession) NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version: Removes the parcel from the bank returning true if parcel was found and removed

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Task<bool> RemoveAsync(
    Type tParcel,
    GDID id,
    Object shardingID = null,
    ISession session = null
)
Task<bool> RemoveAsync(
    Type tParcel,
    GDID id,
    Object shardingID = null,
    ISession session = null
)
Function RemoveAsync (
    tParcel As Type,
    id As GDID,
    Optional shardingID As Object = Nothing,
    Optional session As ISession = Nothing
) As Task(Of Boolean)
Function RemoveAsync (
    tParcel As Type,
    id As GDID,
    Optional shardingID As Object = Nothing,
    Optional session As ISession = Nothing
) As Task(Of Boolean)
Task<bool>^ RemoveAsync(
    Type^ tParcel,
    GDID id,
    Object^ shardingID = nullptr,
    ISession^ session = nullptr
)
Task<bool>^ RemoveAsync(
    Type^ tParcel,
    GDID id,
    Object^ shardingID = nullptr,
    ISession^ session = nullptr
)
abstract RemoveAsync :
        tParcel : Type *
        id : GDID *
        ?shardingID : Object *
        ?session : ISession
(* Defaults:
        let _shardingID = defaultArg shardingID null
        let _session = defaultArg session null
*)
-> Task<bool>
abstract RemoveAsync :
        tParcel : Type *
        id : GDID *
        ?shardingID : Object *
        ?session : ISession
(* Defaults:
        let _shardingID = defaultArg shardingID null
        let _session = defaultArg session null
*)
-> Task<bool>

Parameters

tParcel
Type: Online System Type
Type of parcel to remove
id
Type: NFX.DataAccess.Distributed GDID
The unique GDID of the parcel
shardingID (Optional)
Type: Online System Object
The ID of the entity used for sharding, i.e. a message may use ID of the item that the message relates to, so messages get sharded in the same location as their "parent" record. The parcel type T specifies the DataParcelAttirbute.ShardingParcel
session (Optional)
Type: NFX.ApplicationModel ISession
User session, if null session will be taken from execution context. The session may be needed for policy filtering

Return Value

Type: Online Task Online Boolean
See Also
IBank Interface
IBank Members
RemoveAsync Overload
NFX.DataAccess.Distributed Namespace


IBank.Save Method

IBank Save Method NFX Class Library

Saves/sends the parcel into this bank

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Save(
    Parcel parcel,
    DataCaching cacheOpt = DataCaching.Everywhere,
    Nullable<int> cachePriority = null,
    Nullable<int> cacheMaxAgeSec = null,
    Nullable<DateTime> cacheAbsoluteExpirationUTC = null,
    ISession session = null
)
void Save(
    Parcel parcel,
    DataCaching cacheOpt = DataCaching.Everywhere,
    Nullable<int> cachePriority = null,
    Nullable<int> cacheMaxAgeSec = null,
    Nullable<DateTime> cacheAbsoluteExpirationUTC = null,
    ISession session = null
)
Sub Save (
    parcel As Parcel,
    Optional cacheOpt As DataCaching = DataCaching.Everywhere,
    Optional cachePriority As Nullable(Of Integer) = Nothing,
    Optional cacheMaxAgeSec As Nullable(Of Integer) = Nothing,
    Optional cacheAbsoluteExpirationUTC As Nullable(Of DateTime) = Nothing,
    Optional session As ISession = Nothing
)
Sub Save (
    parcel As Parcel,
    Optional cacheOpt As DataCaching = DataCaching.Everywhere,
    Optional cachePriority As Nullable(Of Integer) = Nothing,
    Optional cacheMaxAgeSec As Nullable(Of Integer) = Nothing,
    Optional cacheAbsoluteExpirationUTC As Nullable(Of DateTime) = Nothing,
    Optional session As ISession = Nothing
)
void Save(
    Parcel^ parcel,
    DataCaching cacheOpt = DataCaching::Everywhere,
    Nullable<int> cachePriority = nullptr,
    Nullable<int> cacheMaxAgeSec = nullptr,
    Nullable<DateTime> cacheAbsoluteExpirationUTC = nullptr,
    ISession^ session = nullptr
)
void Save(
    Parcel^ parcel,
    DataCaching cacheOpt = DataCaching::Everywhere,
    Nullable<int> cachePriority = nullptr,
    Nullable<int> cacheMaxAgeSec = nullptr,
    Nullable<DateTime> cacheAbsoluteExpirationUTC = nullptr,
    ISession^ session = nullptr
)
abstract Save :
        parcel : Parcel *
        ?cacheOpt : DataCaching *
        ?cachePriority : Nullable<int> *
        ?cacheMaxAgeSec : Nullable<int> *
        ?cacheAbsoluteExpirationUTC : Nullable<DateTime> *
        ?session : ISession
(* Defaults:
        let _cacheOpt = defaultArg cacheOpt DataCaching.Everywhere
        let _cachePriority = defaultArg cachePriority null
        let _cacheMaxAgeSec = defaultArg cacheMaxAgeSec null
        let _cacheAbsoluteExpirationUTC = defaultArg cacheAbsoluteExpirationUTC null
        let _session = defaultArg session null
*)
-> unit
abstract Save :
        parcel : Parcel *
        ?cacheOpt : DataCaching *
        ?cachePriority : Nullable<int> *
        ?cacheMaxAgeSec : Nullable<int> *
        ?cacheAbsoluteExpirationUTC : Nullable<DateTime> *
        ?session : ISession
(* Defaults:
        let _cacheOpt = defaultArg cacheOpt DataCaching.Everywhere
        let _cachePriority = defaultArg cachePriority null
        let _cacheMaxAgeSec = defaultArg cacheMaxAgeSec null
        let _cacheAbsoluteExpirationUTC = defaultArg cacheAbsoluteExpirationUTC null
        let _session = defaultArg session null
*)
-> unit

Parameters

parcel
Type: NFX.DataAccess.Distributed Parcel
parcel instance to save
cacheOpt (Optional)
Type: NFX.DataAccess.Distributed DataCaching
The cache control options
cachePriority (Optional)
Type: Online System Nullable Online Int32
The relative priority of the item in cache. If null is passed then the value is obtained from the parcel instance
cacheMaxAgeSec (Optional)
Type: Online System Nullable Online Int32
Specifies the duration of parcel lifespan in cache devices. If null is passed then the value is obtained from the parcel instance
cacheAbsoluteExpirationUTC (Optional)
Type: Online System Nullable Online DateTime
Specifies absolute expiration time for this parcel instance in cache. If null is passed then the value is obtained from the parcel instance
session (Optional)
Type: NFX.ApplicationModel ISession
User session, if null session will be taken from execution context. The session may be needed for policy filtering
See Also
IBank Interface
IBank Members
NFX.DataAccess.Distributed Namespace


IBank.SaveAsync Method

IBank SaveAsync Method NFX Class Library

Async version: Saves/sends the parcel into this bank

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Task SaveAsync(
    Parcel parcel,
    DataCaching cacheOpt = DataCaching.Everywhere,
    Nullable<int> cachePriority = null,
    Nullable<int> cacheMaxAgeSec = null,
    Nullable<DateTime> cacheAbsoluteExpirationUTC = null,
    ISession session = null
)
Task SaveAsync(
    Parcel parcel,
    DataCaching cacheOpt = DataCaching.Everywhere,
    Nullable<int> cachePriority = null,
    Nullable<int> cacheMaxAgeSec = null,
    Nullable<DateTime> cacheAbsoluteExpirationUTC = null,
    ISession session = null
)
Function SaveAsync (
    parcel As Parcel,
    Optional cacheOpt As DataCaching = DataCaching.Everywhere,
    Optional cachePriority As Nullable(Of Integer) = Nothing,
    Optional cacheMaxAgeSec As Nullable(Of Integer) = Nothing,
    Optional cacheAbsoluteExpirationUTC As Nullable(Of DateTime) = Nothing,
    Optional session As ISession = Nothing
) As Task
Function SaveAsync (
    parcel As Parcel,
    Optional cacheOpt As DataCaching = DataCaching.Everywhere,
    Optional cachePriority As Nullable(Of Integer) = Nothing,
    Optional cacheMaxAgeSec As Nullable(Of Integer) = Nothing,
    Optional cacheAbsoluteExpirationUTC As Nullable(Of DateTime) = Nothing,
    Optional session As ISession = Nothing
) As Task
Task^ SaveAsync(
    Parcel^ parcel,
    DataCaching cacheOpt = DataCaching::Everywhere,
    Nullable<int> cachePriority = nullptr,
    Nullable<int> cacheMaxAgeSec = nullptr,
    Nullable<DateTime> cacheAbsoluteExpirationUTC = nullptr,
    ISession^ session = nullptr
)
Task^ SaveAsync(
    Parcel^ parcel,
    DataCaching cacheOpt = DataCaching::Everywhere,
    Nullable<int> cachePriority = nullptr,
    Nullable<int> cacheMaxAgeSec = nullptr,
    Nullable<DateTime> cacheAbsoluteExpirationUTC = nullptr,
    ISession^ session = nullptr
)
abstract SaveAsync :
        parcel : Parcel *
        ?cacheOpt : DataCaching *
        ?cachePriority : Nullable<int> *
        ?cacheMaxAgeSec : Nullable<int> *
        ?cacheAbsoluteExpirationUTC : Nullable<DateTime> *
        ?session : ISession
(* Defaults:
        let _cacheOpt = defaultArg cacheOpt DataCaching.Everywhere
        let _cachePriority = defaultArg cachePriority null
        let _cacheMaxAgeSec = defaultArg cacheMaxAgeSec null
        let _cacheAbsoluteExpirationUTC = defaultArg cacheAbsoluteExpirationUTC null
        let _session = defaultArg session null
*)
-> Task
abstract SaveAsync :
        parcel : Parcel *
        ?cacheOpt : DataCaching *
        ?cachePriority : Nullable<int> *
        ?cacheMaxAgeSec : Nullable<int> *
        ?cacheAbsoluteExpirationUTC : Nullable<DateTime> *
        ?session : ISession
(* Defaults:
        let _cacheOpt = defaultArg cacheOpt DataCaching.Everywhere
        let _cachePriority = defaultArg cachePriority null
        let _cacheMaxAgeSec = defaultArg cacheMaxAgeSec null
        let _cacheAbsoluteExpirationUTC = defaultArg cacheAbsoluteExpirationUTC null
        let _session = defaultArg session null
*)
-> Task

Parameters

parcel
Type: NFX.DataAccess.Distributed Parcel
parcel instance to save
cacheOpt (Optional)
Type: NFX.DataAccess.Distributed DataCaching
The cache control options
cachePriority (Optional)
Type: Online System Nullable Online Int32
The relative priority of the item in cache. If null is passed then the value is obtained from the parcel instance
cacheMaxAgeSec (Optional)
Type: Online System Nullable Online Int32
Specifies the duration of parcel lifespan in cache devices. If null is passed then the value is obtained from the parcel instance
cacheAbsoluteExpirationUTC (Optional)
Type: Online System Nullable Online DateTime
Specifies absolute expiration time for this parcel instance in cache. If null is passed then the value is obtained from the parcel instance
session (Optional)
Type: NFX.ApplicationModel ISession
User session, if null session will be taken from execution context. The session may be needed for policy filtering

Return Value

Type: Online Task
See Also
IBank Interface
IBank Members
NFX.DataAccess.Distributed Namespace


IBank Properties

IBank Properties NFX Class Library

The IBank type exposes the following members.
Properties
 | Name | Description
Public property | Areas | Returns registry of named bank schema area instances
Public property | DataStore | References data store that this data bank is a part of
Public property | Description | Returns database description
Public property | IDGenerator | Returns sequence provider that generates unique identifiers in the store
Public property | Name | (Inherited from INamed.)
Public property | Schema | Returns the schema that this bank implements
Back to Top
See Also
IBank Interface
NFX.DataAccess.Distributed Namespace


IBank.Areas Property

IBank Areas Property NFX Class Library

Returns registry of named bank schema area instances

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IRegistry<IAreaInstance> Areas { get; }
IRegistry<IAreaInstance> Areas { get; }
ReadOnly Property Areas As IRegistry(Of IAreaInstance)
    Get
ReadOnly Property Areas As IRegistry(Of IAreaInstance)
    Get
property IRegistry<IAreaInstance^>^ Areas {
    IRegistry<IAreaInstance^>^ get ();
}
property IRegistry<IAreaInstance^>^ Areas {
    IRegistry<IAreaInstance^>^ get ();
}
abstract Areas : IRegistry<IAreaInstance> with get
abstract Areas : IRegistry<IAreaInstance> with get

Property Value

Type: IRegistry IAreaInstance
See Also
IBank Interface
IBank Members
NFX.DataAccess.Distributed Namespace


IBank.DataStore Property

IBank DataStore Property NFX Class Library

References data store that this data bank is a part of

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IDistributedDataStore DataStore { get; }
IDistributedDataStore DataStore { get; }
ReadOnly Property DataStore As IDistributedDataStore
    Get
ReadOnly Property DataStore As IDistributedDataStore
    Get
property IDistributedDataStore^ DataStore {
    IDistributedDataStore^ get ();
}
property IDistributedDataStore^ DataStore {
    IDistributedDataStore^ get ();
}
abstract DataStore : IDistributedDataStore with get
abstract DataStore : IDistributedDataStore with get

Property Value

Type: IDistributedDataStore
See Also
IBank Interface
IBank Members
NFX.DataAccess.Distributed Namespace


IBank.Description Property

IBank Description Property NFX Class Library

Returns database description

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Description { get; }
string Description { get; }
ReadOnly Property Description As String
    Get
ReadOnly Property Description As String
    Get
property String^ Description {
    String^ get ();
}
property String^ Description {
    String^ get ();
}
abstract Description : string with get
abstract Description : string with get

Property Value

Type: Online String
See Also
IBank Interface
IBank Members
NFX.DataAccess.Distributed Namespace


IBank.IDGenerator Property

IBank IDGenerator Property NFX Class Library

Returns sequence provider that generates unique identifiers in the store

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IGDIDProvider IDGenerator { get; }
IGDIDProvider IDGenerator { get; }
ReadOnly Property IDGenerator As IGDIDProvider
    Get
ReadOnly Property IDGenerator As IGDIDProvider
    Get
property IGDIDProvider^ IDGenerator {
    IGDIDProvider^ get ();
}
property IGDIDProvider^ IDGenerator {
    IGDIDProvider^ get ();
}
abstract IDGenerator : IGDIDProvider with get
abstract IDGenerator : IGDIDProvider with get

Property Value

Type: IGDIDProvider
See Also
IBank Interface
IBank Members
NFX.DataAccess.Distributed Namespace


IBank.Schema Property

IBank Schema Property NFX Class Library

Returns the schema that this bank implements

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ISchema Schema { get; }
ISchema Schema { get; }
ReadOnly Property Schema As ISchema
    Get
ReadOnly Property Schema As ISchema
    Get
property ISchema^ Schema {
    ISchema^ get ();
}
property ISchema^ Schema {
    ISchema^ get ();
}
abstract Schema : ISchema with get
abstract Schema : ISchema with get

Property Value

Type: ISchema
See Also
IBank Interface
IBank Members
NFX.DataAccess.Distributed Namespace


ICachePolicy Interface

ICachePolicy Interface NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ICachePolicy
public interface ICachePolicy
Public Interface ICachePolicy
Public Interface ICachePolicy
public interface class ICachePolicy
public interface class ICachePolicy
type ICachePolicy =  interface end
type ICachePolicy =  interface end
See Also
ICachePolicy Members
NFX.DataAccess.Distributed Namespace


ICachePolicy Members

ICachePolicy Members NFX Class Library

The ICachePolicy type exposes the following members.
Properties
 | Name | Description
Public property | CacheAbsoluteExpirationUTC | Specifies the absolute time when items expires in cache
Public property | CachePriority | Specifies the relative cache priority of this parcel
Public property | CacheReadMaxAgeSec | Specifies the maximum age of parcel instance in cache to be suitable for reading
Public property | CacheTableName | Specifies the name of cache table
Public property | CacheWriteMaxAgeSec | Specifies for how long should this parcel be cached in RAM after a write (after a parcel gets saved).
Back to Top
See Also
ICachePolicy Interface
NFX.DataAccess.Distributed Namespace


ICachePolicy Properties

ICachePolicy Properties NFX Class Library

The ICachePolicy type exposes the following members.
Properties
 | Name | Description
Public property | CacheAbsoluteExpirationUTC | Specifies the absolute time when items expires in cache
Public property | CachePriority | Specifies the relative cache priority of this parcel
Public property | CacheReadMaxAgeSec | Specifies the maximum age of parcel instance in cache to be suitable for reading
Public property | CacheTableName | Specifies the name of cache table
Public property | CacheWriteMaxAgeSec | Specifies for how long should this parcel be cached in RAM after a write (after a parcel gets saved).
Back to Top
See Also
ICachePolicy Interface
NFX.DataAccess.Distributed Namespace


ICachePolicy.CacheAbsoluteExpirationUTC Property

ICachePolicy CacheAbsoluteExpirationUTC Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Specifies the absolute time when items expires in cache

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Nullable<DateTime> CacheAbsoluteExpirationUTC { get; }
Nullable<DateTime> CacheAbsoluteExpirationUTC { get; }
ReadOnly Property CacheAbsoluteExpirationUTC As Nullable(Of DateTime)
    Get
ReadOnly Property CacheAbsoluteExpirationUTC As Nullable(Of DateTime)
    Get
property Nullable<DateTime> CacheAbsoluteExpirationUTC {
    Nullable<DateTime> get ();
}
property Nullable<DateTime> CacheAbsoluteExpirationUTC {
    Nullable<DateTime> get ();
}
abstract CacheAbsoluteExpirationUTC : Nullable<DateTime> with get
abstract CacheAbsoluteExpirationUTC : Nullable<DateTime> with get

Property Value

Type: Online Nullable Online DateTime
See Also
ICachePolicy Interface
ICachePolicy Members
NFX.DataAccess.Distributed Namespace


ICachePolicy.CachePriority Property

ICachePolicy CachePriority Property NFX Class Library

Specifies the relative cache priority of this parcel

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Nullable<int> CachePriority { get; }
Nullable<int> CachePriority { get; }
ReadOnly Property CachePriority As Nullable(Of Integer)
    Get
ReadOnly Property CachePriority As Nullable(Of Integer)
    Get
property Nullable<int> CachePriority {
    Nullable<int> get ();
}
property Nullable<int> CachePriority {
    Nullable<int> get ();
}
abstract CachePriority : Nullable<int> with get
abstract CachePriority : Nullable<int> with get

Property Value

Type: Online Nullable Online Int32
See Also
ICachePolicy Interface
ICachePolicy Members
NFX.DataAccess.Distributed Namespace


ICachePolicy.CacheReadMaxAgeSec Property

ICachePolicy CacheReadMaxAgeSec Property NFX Class Library

Specifies the maximum age of parcel instance in cache to be suitable for reading

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Nullable<int> CacheReadMaxAgeSec { get; }
Nullable<int> CacheReadMaxAgeSec { get; }
ReadOnly Property CacheReadMaxAgeSec As Nullable(Of Integer)
    Get
ReadOnly Property CacheReadMaxAgeSec As Nullable(Of Integer)
    Get
property Nullable<int> CacheReadMaxAgeSec {
    Nullable<int> get ();
}
property Nullable<int> CacheReadMaxAgeSec {
    Nullable<int> get ();
}
abstract CacheReadMaxAgeSec : Nullable<int> with get
abstract CacheReadMaxAgeSec : Nullable<int> with get

Property Value

Type: Online Nullable Online Int32
See Also
ICachePolicy Interface
ICachePolicy Members
NFX.DataAccess.Distributed Namespace


ICachePolicy.CacheTableName Property

ICachePolicy CacheTableName Property NFX Class Library

Specifies the name of cache table

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string CacheTableName { get; }
string CacheTableName { get; }
ReadOnly Property CacheTableName As String
    Get
ReadOnly Property CacheTableName As String
    Get
property String^ CacheTableName {
    String^ get ();
}
property String^ CacheTableName {
    String^ get ();
}
abstract CacheTableName : string with get
abstract CacheTableName : string with get

Property Value

Type: Online String
See Also
ICachePolicy Interface
ICachePolicy Members
NFX.DataAccess.Distributed Namespace


ICachePolicy.CacheWriteMaxAgeSec Property

ICachePolicy CacheWriteMaxAgeSec Property NFX Class Library

Specifies for how long should this parcel be cached in RAM after a write (after a parcel gets saved).

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Nullable<int> CacheWriteMaxAgeSec { get; }
Nullable<int> CacheWriteMaxAgeSec { get; }
ReadOnly Property CacheWriteMaxAgeSec As Nullable(Of Integer)
    Get
ReadOnly Property CacheWriteMaxAgeSec As Nullable(Of Integer)
    Get
property Nullable<int> CacheWriteMaxAgeSec {
    Nullable<int> get ();
}
property Nullable<int> CacheWriteMaxAgeSec {
    Nullable<int> get ();
}
abstract CacheWriteMaxAgeSec : Nullable<int> with get
abstract CacheWriteMaxAgeSec : Nullable<int> with get

Property Value

Type: Online Nullable Online Int32
See Also
ICachePolicy Interface
ICachePolicy Members
NFX.DataAccess.Distributed Namespace


IDistributedDataStore Interface

IDistributedDataStore Interface NFX Class Library

Represents a data store that works with large distributed systems that support OLTP-style processing and provide data querying, caching, partitioning/sharding, failover and replication. These systems are designed to handle billions of rows that need to be accessed by millions of active concurrent users, so the design is specific to this model that scales horizontally. There is no need to use this technology for medium and smaller data stores as it imposes specific requirements on how application is written/interacts with the backend system. This technology is based on the idea of Parcels - an atomic unit of data change. Parcels get replicated between hosts for failover and performance reasons. Note: NFX library does not provide the implementation for this technology, only marker interfaces so developers can plan for distributed backends in future

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IDistributedDataStore : IDataStore,
    IApplicationComponent, IDisposable
public interface IDistributedDataStore : IDataStore,
    IApplicationComponent, IDisposable
Public Interface IDistributedDataStore
    Inherits IDataStore, IApplicationComponent, IDisposable
Public Interface IDistributedDataStore
    Inherits IDataStore, IApplicationComponent, IDisposable
public interface class IDistributedDataStore : IDataStore,
    IApplicationComponent, IDisposable
public interface class IDistributedDataStore : IDataStore,
    IApplicationComponent, IDisposable
type IDistributedDataStore =
    interface
        interface IDataStore
        interface IApplicationComponent
        interface IDisposable
    end
type IDistributedDataStore =
    interface
        interface IDataStore
        interface IApplicationComponent
        interface IDisposable
    end
Remarks
The structure of distributed data store: +------------------------------------------------------------------------------------------------------------+ | Data Store | | +-------------------------------------------------------------------------+ +---------------------+ | | | Bank = N 1 (Schema A) | | Bank = N 2 | | | | +----------+ +--------------------------------------------------------+ | | (Schema A) | | | | | Area | + Area "UserData" | | ... | | | | | | "common" | +-----------+-----------+-----------+-----------+--------+ | | | | | | | | + Shard 1 | Shard 2 | Shard 3 | Shard 4 | | | | | | | +----------+ | | | | | | +---------------------+ | | | +-----------+ | | | | +---------------------+ | | | +----------------------+ | +-----------+ | | | Bank = N X | | | | |Area "clinicalData" | | | | | | | (Schema B) | | | | | /doctors | | | | | | ... | | | | | | /codes | | | | | | | | | | | | /diagnoses | | | +-----------+ | | | | | | +----------------------+ | | | +---------------------+ | | | +-----------+ | | | +-------------------------------------------------------------------------+ | +------------------------------------------------------------------------------------------------------------+ Distributed data stores hold single or multiple named data banks instances: Bank = global data bank name, a named instance of a distributed database. Banks are logical isolation containers in large datasets. Store implementations may use it for physical isolation as well. Every bank implements a particular schema - a structure suitable for some business purpose. A store may support multiple schemas, but every particular database bank implements only one schema. Named instances of database banks with the same schema may be used to house data for different clients or environments. Bank name example: "PROD-Data", "DEV-Data", "EnterpriseA", "CustomerX" etc. Every Bank is further broken down by Areas that can be accessed/addressed by their names. Areas contain shards that partition large volumes of data horizontally, they define how data is partitioned and where it is stored
See Also
IDistributedDataStore Members
NFX.DataAccess.Distributed Namespace


IDistributedDataStore Members

IDistributedDataStore Members NFX Class Library

The IDistributedDataStore type exposes the following members.
Methods
 | Name | Description
Public method | BankNames | Returns names of database bank instances in the store that implement the specified schema
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | GetBank | Returns Bank object by name within schema
Public method | TestConnection | Tests connection and throws an exception if connection could not be established (Inherited from IDataStore.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | SchemaNames | Returns names of database bank schemas supported by the store. Every bank implements a particular schema
Public property | TargetName | Returns the name of the underlying store technology, i.e. "ORACLE". This property is used by some metadata-based validation logic which is target-dependent (Inherited from IDataStore.)
Back to Top
See Also
IDistributedDataStore Interface
NFX.DataAccess.Distributed Namespace


IDistributedDataStore Methods

IDistributedDataStore Methods NFX Class Library

The IDistributedDataStore type exposes the following members.
Methods
 | Name | Description
Public method | BankNames | Returns names of database bank instances in the store that implement the specified schema
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | GetBank | Returns Bank object by name within schema
Public method | TestConnection | Tests connection and throws an exception if connection could not be established (Inherited from IDataStore.)
Back to Top
See Also
IDistributedDataStore Interface
NFX.DataAccess.Distributed Namespace


IDistributedDataStore.BankNames Method

IDistributedDataStore BankNames Method NFX Class Library

Returns names of database bank instances in the store that implement the specified schema

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<string> BankNames(
    string schemaName
)
IEnumerable<string> BankNames(
    string schemaName
)
Function BankNames (
    schemaName As String
) As IEnumerable(Of String)
Function BankNames (
    schemaName As String
) As IEnumerable(Of String)
IEnumerable<String^>^ BankNames(
    String^ schemaName
)
IEnumerable<String^>^ BankNames(
    String^ schemaName
)
abstract BankNames :
        schemaName : string -> IEnumerable<string>
abstract BankNames :
        schemaName : string -> IEnumerable<string>

Parameters

schemaName
Type: Online System String

Return Value

Type: Online IEnumerable Online String
See Also
IDistributedDataStore Interface
IDistributedDataStore Members
NFX.DataAccess.Distributed Namespace


IDistributedDataStore.GetBank Method

IDistributedDataStore GetBank Method NFX Class Library

Returns Bank object by name within schema

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IBank GetBank(
    string schemaName,
    string name
)
IBank GetBank(
    string schemaName,
    string name
)
Function GetBank (
    schemaName As String,
    name As String
) As IBank
Function GetBank (
    schemaName As String,
    name As String
) As IBank
IBank^ GetBank(
    String^ schemaName,
    String^ name
)
IBank^ GetBank(
    String^ schemaName,
    String^ name
)
abstract GetBank :
        schemaName : string *
        name : string -> IBank
abstract GetBank :
        schemaName : string *
        name : string -> IBank

Parameters

schemaName
Type: Online System String
name
Type: Online System String

Return Value

Type: IBank
See Also
IDistributedDataStore Interface
IDistributedDataStore Members
NFX.DataAccess.Distributed Namespace


IDistributedDataStore Properties

IDistributedDataStore Properties NFX Class Library

The IDistributedDataStore type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | SchemaNames | Returns names of database bank schemas supported by the store. Every bank implements a particular schema
Public property | TargetName | Returns the name of the underlying store technology, i.e. "ORACLE". This property is used by some metadata-based validation logic which is target-dependent (Inherited from IDataStore.)
Back to Top
See Also
IDistributedDataStore Interface
NFX.DataAccess.Distributed Namespace


IDistributedDataStore.SchemaNames Property

IDistributedDataStore SchemaNames Property NFX Class Library

Returns names of database bank schemas supported by the store. Every bank implements a particular schema

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<string> SchemaNames { get; }
IEnumerable<string> SchemaNames { get; }
ReadOnly Property SchemaNames As IEnumerable(Of String)
    Get
ReadOnly Property SchemaNames As IEnumerable(Of String)
    Get
property IEnumerable<String^>^ SchemaNames {
    IEnumerable<String^>^ get ();
}
property IEnumerable<String^>^ SchemaNames {
    IEnumerable<String^>^ get ();
}
abstract SchemaNames : IEnumerable<string> with get
abstract SchemaNames : IEnumerable<string> with get

Property Value

Type: Online IEnumerable Online String
See Also
IDistributedDataStore Interface
IDistributedDataStore Members
NFX.DataAccess.Distributed Namespace


IDistributedDataStoreImplementation Interface

IDistributedDataStoreImplementation Interface NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IDistributedDataStoreImplementation : IDistributedDataStore,
    IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
public interface IDistributedDataStoreImplementation : IDistributedDataStore,
    IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
Public Interface IDistributedDataStoreImplementation
    Inherits IDistributedDataStore, IDataStoreImplementation, IDataStore, IApplicationComponent,
    IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
Public Interface IDistributedDataStoreImplementation
    Inherits IDistributedDataStore, IDataStoreImplementation, IDataStore, IApplicationComponent,
    IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
public interface class IDistributedDataStoreImplementation : IDistributedDataStore,
    IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
public interface class IDistributedDataStoreImplementation : IDistributedDataStore,
    IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
type IDistributedDataStoreImplementation =
    interface
        interface IDistributedDataStore
        interface IDataStoreImplementation
        interface IDataStore
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
type IDistributedDataStoreImplementation =
    interface
        interface IDistributedDataStore
        interface IDataStoreImplementation
        interface IDataStore
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
IDistributedDataStoreImplementation Members
NFX.DataAccess.Distributed Namespace


IDistributedDataStoreImplementation Members

IDistributedDataStoreImplementation Members NFX Class Library

[This is preliminary documentation and is subject to change.]

The IDistributedDataStoreImplementation type exposes the following members.
Methods
 | Name | Description
Public method | BankNames | Returns names of database bank instances in the store that implement the specified schema (Inherited from IDistributedDataStore.)
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Public method | GetBank | Returns Bank object by name within schema (Inherited from IDistributedDataStore.)
Public method | TestConnection | Tests connection and throws an exception if connection could not be established (Inherited from IDataStore.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | LogLevel | Defines log level for data stores (Inherited from IDataStoreImplementation.)
Public property | SchemaNames | Returns names of database bank schemas supported by the store. Every bank implements a particular schema (Inherited from IDistributedDataStore.)
Public property | TargetName | Returns the name of the underlying store technology, i.e. "ORACLE". This property is used by some metadata-based validation logic which is target-dependent (Inherited from IDataStore.)
Back to Top
See Also
IDistributedDataStoreImplementation Interface
NFX.DataAccess.Distributed Namespace


IDistributedDataStoreImplementation Methods

IDistributedDataStoreImplementation Methods NFX Class Library

[This is preliminary documentation and is subject to change.]

The IDistributedDataStoreImplementation type exposes the following members.
Methods
 | Name | Description
Public method | BankNames | Returns names of database bank instances in the store that implement the specified schema (Inherited from IDistributedDataStore.)
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Public method | GetBank | Returns Bank object by name within schema (Inherited from IDistributedDataStore.)
Public method | TestConnection | Tests connection and throws an exception if connection could not be established (Inherited from IDataStore.)
Back to Top
See Also
IDistributedDataStoreImplementation Interface
NFX.DataAccess.Distributed Namespace


IDistributedDataStoreImplementation Properties

IDistributedDataStoreImplementation Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The IDistributedDataStoreImplementation type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | LogLevel | Defines log level for data stores (Inherited from IDataStoreImplementation.)
Public property | SchemaNames | Returns names of database bank schemas supported by the store. Every bank implements a particular schema (Inherited from IDistributedDataStore.)
Public property | TargetName | Returns the name of the underlying store technology, i.e. "ORACLE". This property is used by some metadata-based validation logic which is target-dependent (Inherited from IDataStore.)
Back to Top
See Also
IDistributedDataStoreImplementation Interface
NFX.DataAccess.Distributed Namespace


IDistributedStableHashProvider Interface

IDistributedStableHashProvider Interface NFX Class Library

Denotes entities that provide ULONG STABLE hash code for use in a distributed (large scale) system. This is needed primarily for cluster/large datasets to properly compute 64bit sharding addresses and to differentiate from GetHashCode() that returns 32 bits unstable hash for local object location in hashtables. DO not confuse with object.GetHashCode() which is un-suitable for long-term persistence

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IDistributedStableHashProvider
public interface IDistributedStableHashProvider
Public Interface IDistributedStableHashProvider
Public Interface IDistributedStableHashProvider
public interface class IDistributedStableHashProvider
public interface class IDistributedStableHashProvider
type IDistributedStableHashProvider =  interface end
type IDistributedStableHashProvider =  interface end
See Also
IDistributedStableHashProvider Members
NFX.DataAccess.Distributed Namespace


IDistributedStableHashProvider Members

IDistributedStableHashProvider Members NFX Class Library

The IDistributedStableHashProvider type exposes the following members.
Methods
 | Name | Description
Public method | GetDistributedStableHash | Provides 64 bit STABLE hash suitable for distributed system application. This hash may NOT depend on platform as it is used for storage. Warning! DO NOT CALL object.GetHashCode() as it may not be suitable for storage
Back to Top
See Also
IDistributedStableHashProvider Interface
NFX.DataAccess.Distributed Namespace


IDistributedStableHashProvider Methods

IDistributedStableHashProvider Methods NFX Class Library

The IDistributedStableHashProvider type exposes the following members.
Methods
 | Name | Description
Public method | GetDistributedStableHash | Provides 64 bit STABLE hash suitable for distributed system application. This hash may NOT depend on platform as it is used for storage. Warning! DO NOT CALL object.GetHashCode() as it may not be suitable for storage
Back to Top
See Also
IDistributedStableHashProvider Interface
NFX.DataAccess.Distributed Namespace


IDistributedStableHashProvider.GetDistributedStableHash Method

IDistributedStableHashProvider GetDistributedStableHash Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Provides 64 bit STABLE hash suitable for distributed system application. This hash may NOT depend on platform as it is used for storage. Warning! DO NOT CALL object.GetHashCode() as it may not be suitable for storage

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ulong GetDistributedStableHash()
ulong GetDistributedStableHash()
Function GetDistributedStableHash As ULong
Function GetDistributedStableHash As ULong
unsigned long long GetDistributedStableHash()
unsigned long long GetDistributedStableHash()
abstract GetDistributedStableHash : unit -> uint64
abstract GetDistributedStableHash : unit -> uint64

Return Value

Type: Online UInt64
See Also
IDistributedStableHashProvider Interface
IDistributedStableHashProvider Members
NFX.DataAccess.Distributed Namespace


IReplicatable Interface

IReplicatable Interface NFX Class Library

Denotes a distributed entity that can be replicated to a different location/site/instance. Normally only Parcel and its derivatives should implement this interface

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IReplicatable
public interface IReplicatable
Public Interface IReplicatable
Public Interface IReplicatable
public interface class IReplicatable
public interface class IReplicatable
type IReplicatable =  interface end
type IReplicatable =  interface end
See Also
IReplicatable Members
NFX.DataAccess.Distributed Namespace


IReplicatable Members

IReplicatable Members NFX Class Library

The IReplicatable type exposes the following members.
Properties
 | Name | Description
Public property | ReplicationPriority | Returns the relative priority of replication, where 0=highest priority
Public property | ReplicationVersionInfo | Provides the information about this version of data that this isntance represents. Usually this object contains the name of the user who made a change, server/cluster node ID and/or machine name
Back to Top
See Also
IReplicatable Interface
NFX.DataAccess.Distributed Namespace


IReplicatable Properties

IReplicatable Properties NFX Class Library

The IReplicatable type exposes the following members.
Properties
 | Name | Description
Public property | ReplicationPriority | Returns the relative priority of replication, where 0=highest priority
Public property | ReplicationVersionInfo | Provides the information about this version of data that this isntance represents. Usually this object contains the name of the user who made a change, server/cluster node ID and/or machine name
Back to Top
See Also
IReplicatable Interface
NFX.DataAccess.Distributed Namespace


IReplicatable.ReplicationPriority Property

IReplicatable ReplicationPriority Property NFX Class Library

Returns the relative priority of replication, where 0=highest priority

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int ReplicationPriority { get; }
int ReplicationPriority { get; }
ReadOnly Property ReplicationPriority As Integer
    Get
ReadOnly Property ReplicationPriority As Integer
    Get
property int ReplicationPriority {
    int get ();
}
property int ReplicationPriority {
    int get ();
}
abstract ReplicationPriority : int with get
abstract ReplicationPriority : int with get

Property Value

Type: Online Int32
See Also
IReplicatable Interface
IReplicatable Members
NFX.DataAccess.Distributed Namespace


IReplicatable.ReplicationVersionInfo Property

IReplicatable ReplicationVersionInfo Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Provides the information about this version of data that this isntance represents. Usually this object contains the name of the user who made a change, server/cluster node ID and/or machine name

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IReplicationVersionInfo ReplicationVersionInfo { get; }
IReplicationVersionInfo ReplicationVersionInfo { get; }
ReadOnly Property ReplicationVersionInfo As IReplicationVersionInfo
    Get
ReadOnly Property ReplicationVersionInfo As IReplicationVersionInfo
    Get
property IReplicationVersionInfo^ ReplicationVersionInfo {
    IReplicationVersionInfo^ get ();
}
property IReplicationVersionInfo^ ReplicationVersionInfo {
    IReplicationVersionInfo^ get ();
}
abstract ReplicationVersionInfo : IReplicationVersionInfo with get
abstract ReplicationVersionInfo : IReplicationVersionInfo with get

Property Value

Type: IReplicationVersionInfo
See Also
IReplicatable Interface
IReplicatable Members
NFX.DataAccess.Distributed Namespace


IReplicationVersionInfo Interface

IReplicationVersionInfo Interface NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IReplicationVersionInfo : IComparable
public interface IReplicationVersionInfo : IComparable
Public Interface IReplicationVersionInfo
    Inherits IComparable
Public Interface IReplicationVersionInfo
    Inherits IComparable
public interface class IReplicationVersionInfo : IComparable
public interface class IReplicationVersionInfo : IComparable
type IReplicationVersionInfo =
    interface
        interface IComparable
    end
type IReplicationVersionInfo =
    interface
        interface IComparable
    end
See Also
IReplicationVersionInfo Members
NFX.DataAccess.Distributed Namespace


IReplicationVersionInfo Members

IReplicationVersionInfo Members NFX Class Library

The IReplicationVersionInfo type exposes the following members.
Methods
 | Name | Description
Public method | Online CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from Online IComparable.)
Back to Top
Properties
 | Name | Description
Public property | VersionDeleted | Returns true for items that have been marked for deletion
Public property | VersionUTCTimestamp | Provides a UTC timestamp for this version - when last change was made
Back to Top
See Also
IReplicationVersionInfo Interface
NFX.DataAccess.Distributed Namespace


IReplicationVersionInfo Methods

IReplicationVersionInfo Methods NFX Class Library

The IReplicationVersionInfo type exposes the following members.
Methods
 | Name | Description
Public method | Online CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from Online IComparable.)
Back to Top
See Also
IReplicationVersionInfo Interface
NFX.DataAccess.Distributed Namespace


IReplicationVersionInfo Properties

IReplicationVersionInfo Properties NFX Class Library

The IReplicationVersionInfo type exposes the following members.
Properties
 | Name | Description
Public property | VersionDeleted | Returns true for items that have been marked for deletion
Public property | VersionUTCTimestamp | Provides a UTC timestamp for this version - when last change was made
Back to Top
See Also
IReplicationVersionInfo Interface
NFX.DataAccess.Distributed Namespace


IReplicationVersionInfo.VersionDeleted Property

IReplicationVersionInfo VersionDeleted Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns true for items that have been marked for deletion

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool VersionDeleted { get; }
bool VersionDeleted { get; }
ReadOnly Property VersionDeleted As Boolean
    Get
ReadOnly Property VersionDeleted As Boolean
    Get
property bool VersionDeleted {
    bool get ();
}
property bool VersionDeleted {
    bool get ();
}
abstract VersionDeleted : bool with get
abstract VersionDeleted : bool with get

Property Value

Type: Online Boolean
See Also
IReplicationVersionInfo Interface
IReplicationVersionInfo Members
NFX.DataAccess.Distributed Namespace


IReplicationVersionInfo.VersionUTCTimestamp Property

IReplicationVersionInfo VersionUTCTimestamp Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Provides a UTC timestamp for this version - when last change was made

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
DateTime VersionUTCTimestamp { get; }
DateTime VersionUTCTimestamp { get; }
ReadOnly Property VersionUTCTimestamp As DateTime
    Get
ReadOnly Property VersionUTCTimestamp As DateTime
    Get
property DateTime VersionUTCTimestamp {
    DateTime get ();
}
property DateTime VersionUTCTimestamp {
    DateTime get ();
}
abstract VersionUTCTimestamp : DateTime with get
abstract VersionUTCTimestamp : DateTime with get

Property Value

Type: Online DateTime
See Also
IReplicationVersionInfo Interface
IReplicationVersionInfo Members
NFX.DataAccess.Distributed Namespace


ISchema Interface

ISchema Interface NFX Class Library

Provides information about schema of data store banks. Schema defines areas of the bank, where every area defines what parcel types can be stored. Each bank implements only one bank schema

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ISchema : INamed
public interface ISchema : INamed
Public Interface ISchema
    Inherits INamed
Public Interface ISchema
    Inherits INamed
public interface class ISchema : INamed
public interface class ISchema : INamed
type ISchema =
    interface
        interface INamed
    end
type ISchema =
    interface
        interface INamed
    end
See Also
ISchema Members
NFX.DataAccess.Distributed Namespace


ISchema Members

ISchema Members NFX Class Library

The ISchema type exposes the following members.
Properties
 | Name | Description
Public property | Areas | Returns registry of named schema areas
Public property | DataStore | References data store that this schema is a part of
Public property | Name | (Inherited from INamed.)
Public property | TargetSuffix | Returns target name suffix which is added at the end. This allows for detailed targeting of metadata for particular schema. In most cases this property returns null which means no specific schema targeting
Back to Top
See Also
ISchema Interface
NFX.DataAccess.Distributed Namespace


ISchema Properties

ISchema Properties NFX Class Library

The ISchema type exposes the following members.
Properties
 | Name | Description
Public property | Areas | Returns registry of named schema areas
Public property | DataStore | References data store that this schema is a part of
Public property | Name | (Inherited from INamed.)
Public property | TargetSuffix | Returns target name suffix which is added at the end. This allows for detailed targeting of metadata for particular schema. In most cases this property returns null which means no specific schema targeting
Back to Top
See Also
ISchema Interface
NFX.DataAccess.Distributed Namespace


ISchema.Areas Property

ISchema Areas Property NFX Class Library

Returns registry of named schema areas

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IRegistry<IArea> Areas { get; }
IRegistry<IArea> Areas { get; }
ReadOnly Property Areas As IRegistry(Of IArea)
    Get
ReadOnly Property Areas As IRegistry(Of IArea)
    Get
property IRegistry<IArea^>^ Areas {
    IRegistry<IArea^>^ get ();
}
property IRegistry<IArea^>^ Areas {
    IRegistry<IArea^>^ get ();
}
abstract Areas : IRegistry<IArea> with get
abstract Areas : IRegistry<IArea> with get

Property Value

Type: IRegistry IArea
See Also
ISchema Interface
ISchema Members
NFX.DataAccess.Distributed Namespace


ISchema.DataStore Property

ISchema DataStore Property NFX Class Library

References data store that this schema is a part of

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IDistributedDataStore DataStore { get; }
IDistributedDataStore DataStore { get; }
ReadOnly Property DataStore As IDistributedDataStore
    Get
ReadOnly Property DataStore As IDistributedDataStore
    Get
property IDistributedDataStore^ DataStore {
    IDistributedDataStore^ get ();
}
property IDistributedDataStore^ DataStore {
    IDistributedDataStore^ get ();
}
abstract DataStore : IDistributedDataStore with get
abstract DataStore : IDistributedDataStore with get

Property Value

Type: IDistributedDataStore
See Also
ISchema Interface
ISchema Members
NFX.DataAccess.Distributed Namespace


ISchema.TargetSuffix Property

ISchema TargetSuffix Property NFX Class Library

Returns target name suffix which is added at the end. This allows for detailed targeting of metadata for particular schema. In most cases this property returns null which means no specific schema targeting

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string TargetSuffix { get; }
string TargetSuffix { get; }
ReadOnly Property TargetSuffix As String
    Get
ReadOnly Property TargetSuffix As String
    Get
property String^ TargetSuffix {
    String^ get ();
}
property String^ TargetSuffix {
    String^ get ();
}
abstract TargetSuffix : string with get
abstract TargetSuffix : string with get

Property Value

Type: Online String
See Also
ISchema Interface
ISchema Members
NFX.DataAccess.Distributed Namespace


IShardingPointerProvider Interface

IShardingPointerProvider Interface NFX Class Library

Denotes an entity which provides a sharding parcel type along with sharding ID (ShardingPointer) that can be used to determine data location via conversion of this id into physical shard #(particular server) that this entity represents

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IShardingPointerProvider
public interface IShardingPointerProvider
Public Interface IShardingPointerProvider
Public Interface IShardingPointerProvider
public interface class IShardingPointerProvider
public interface class IShardingPointerProvider
type IShardingPointerProvider =  interface end
type IShardingPointerProvider =  interface end
See Also
IShardingPointerProvider Members
NFX.DataAccess.Distributed Namespace


IShardingPointerProvider Members

IShardingPointerProvider Members NFX Class Library

The IShardingPointerProvider type exposes the following members.
Properties
 | Name | Description
Public property | ShardingPointer | Returns the parcel type and ID used for sharding. This pointer is converted into physical shard # (particular server) where data represented by this entity resides. WARNING! The ShardingPointer is immutable during the lifecycle of the entity. See Parcel.ShardingPointer
Back to Top
See Also
IShardingPointerProvider Interface
NFX.DataAccess.Distributed Namespace


IShardingPointerProvider Properties

IShardingPointerProvider Properties NFX Class Library

The IShardingPointerProvider type exposes the following members.
Properties
 | Name | Description
Public property | ShardingPointer | Returns the parcel type and ID used for sharding. This pointer is converted into physical shard # (particular server) where data represented by this entity resides. WARNING! The ShardingPointer is immutable during the lifecycle of the entity. See Parcel.ShardingPointer
Back to Top
See Also
IShardingPointerProvider Interface
NFX.DataAccess.Distributed Namespace


IShardingPointerProvider.ShardingPointer Property

IShardingPointerProvider ShardingPointer Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns the parcel type and ID used for sharding. This pointer is converted into physical shard # (particular server) where data represented by this entity resides. WARNING! The ShardingPointer is immutable during the lifecycle of the entity. See Parcel.ShardingPointer

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ShardingPointer ShardingPointer { get; }
ShardingPointer ShardingPointer { get; }
ReadOnly Property ShardingPointer As ShardingPointer
    Get
ReadOnly Property ShardingPointer As ShardingPointer
    Get
property ShardingPointer ShardingPointer {
    ShardingPointer get ();
}
property ShardingPointer ShardingPointer {
    ShardingPointer get ();
}
abstract ShardingPointer : ShardingPointer with get
abstract ShardingPointer : ShardingPointer with get

Property Value

Type: ShardingPointer
See Also
IShardingPointerProvider Interface
IShardingPointerProvider Members
NFX.DataAccess.Distributed Namespace


NullCommandResult Class

NullCommandResult Class NFX Class Library

Represents a result of command that is absent. This is needed to distinguish from null reference
Inheritance Hierarchy
Online System Object
NFX.DataAccess.Distributed NullCommandResult

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class NullCommandResult
public sealed class NullCommandResult
Public NotInheritable Class NullCommandResult
Public NotInheritable Class NullCommandResult
public ref class NullCommandResult sealed
public ref class NullCommandResult sealed
[<SealedAttribute>]
type NullCommandResult =  class end
[<SealedAttribute>]
type NullCommandResult =  class end
See Also
NullCommandResult Members
NFX.DataAccess.Distributed Namespace


NullCommandResult Members

NullCommandResult Members NFX Class Library

The NullCommandResult type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
Instance |
Back to Top
See Also
NullCommandResult Class
NFX.DataAccess.Distributed Namespace


NullCommandResult Fields

NullCommandResult Fields NFX Class Library

The NullCommandResult type exposes the following members.
Fields
Name | Description
Instance |
Back to Top
See Also
NullCommandResult Class
NFX.DataAccess.Distributed Namespace


NullCommandResult.Instance Field

NullCommandResult Instance Field NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly NullCommandResult Instance
public static readonly NullCommandResult Instance
Public Shared ReadOnly Instance As NullCommandResult
Public Shared ReadOnly Instance As NullCommandResult
public:
static initonly NullCommandResult^ Instance
public:
static initonly NullCommandResult^ Instance
static val Instance: NullCommandResult
static val Instance: NullCommandResult

Field Value

Type: NullCommandResult
See Also
NullCommandResult Class
NullCommandResult Members
NFX.DataAccess.Distributed Namespace


NullCommandResult Methods

NullCommandResult Methods NFX Class Library

The NullCommandResult type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NullCommandResult Class
NFX.DataAccess.Distributed Namespace


NullCommandResult.Equals Method

NullCommandResult Equals Method NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
NullCommandResult Class
NullCommandResult Members
NFX.DataAccess.Distributed Namespace


NullCommandResult.GetHashCode Method

NullCommandResult GetHashCode Method NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
NullCommandResult Class
NullCommandResult Members
NFX.DataAccess.Distributed Namespace


NullCommandResult.ToString Method

NullCommandResult ToString Method NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
NullCommandResult Class
NullCommandResult Members
NFX.DataAccess.Distributed Namespace


Parcel Class

Parcel Class NFX Class Library

Describes a data parcel - a piece of logically-grouped data that gets fetched from/comitted into a distributed backend system. Parcels represent an atomic unit of change, a changeset that gets replicated between failover hosts. Every parcel has a Payload property that stores business data of interest that the parcel contains. This class is not thread-safe. Use DeepClone() to create 100% copies for working in multiple threads. This particular class serves as a very base for all Parcel implementations
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.DataAccess.Distributed Parcel
NFX.DataAccess.Distributed Parcel TPayload

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class Parcel : DisposableObject,
    IReplicatable, ICachePolicy, IDistributedStableHashProvider, IShardingPointerProvider
[SerializableAttribute]
public abstract class Parcel : DisposableObject,
    IReplicatable, ICachePolicy, IDistributedStableHashProvider, IShardingPointerProvider
<SerializableAttribute>
Public MustInherit Class Parcel
    Inherits DisposableObject
    Implements IReplicatable, ICachePolicy, IDistributedStableHashProvider, IShardingPointerProvider
<SerializableAttribute>
Public MustInherit Class Parcel
    Inherits DisposableObject
    Implements IReplicatable, ICachePolicy, IDistributedStableHashProvider, IShardingPointerProvider
[SerializableAttribute]
public ref class Parcel abstract : public DisposableObject,
    IReplicatable, ICachePolicy, IDistributedStableHashProvider, IShardingPointerProvider
[SerializableAttribute]
public ref class Parcel abstract : public DisposableObject,
    IReplicatable, ICachePolicy, IDistributedStableHashProvider, IShardingPointerProvider
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type Parcel =
    class
        inherit DisposableObject
        interface IReplicatable
        interface ICachePolicy
        interface IDistributedStableHashProvider
        interface IShardingPointerProvider
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type Parcel =
    class
        inherit DisposableObject
        interface IReplicatable
        interface ICachePolicy
        interface IDistributedStableHashProvider
        interface IShardingPointerProvider
    end
See Also
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel Members

Parcel Members NFX Class Library

The Parcel type exposes the following members.
Constructors
 | Name | Description
Protected method | Parcel | Used for serialization
Protected method | Parcel(Object) | This ctor is never public, used with __ctor__injectID
Protected method | Parcel(GDID, Object) | Called when creating new Parcel instances by the original author. The new instance is in 'ParcelState.Creating' state
Protected method | Parcel(GDID, Object, IReplicationVersionInfo) | Called by device to load parcel from storage. The new instance is in 'ParcelState.Sealed' state. Business logic devs - do not call
Back to Top
Methods
 | Name | Description
Protected method | __ctor__injectID | Internal framework method, developers: never call
Public method | DeepClone | Duplicates this parcel by doing a complete deep-clone of its state via serialization. This method is useful for making copies of the same parcel for different threads as it is thread-safe while no other thread mutates the instance, however Parcel instances are NOT THREAD-SAFE for parallel changes. The existing parcel MUST be SEALED (otherwise it can not be serialized). This method is also used before a call to Open() if parcel needs to be "un-opened" the cloned instance may be reverted to
Protected method | Destructor | Override this method to do actual destructor work (Inherited from DisposableObject.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoMerge | Override to merge other parcels into this one. Return true if merge changed the payload. See Merge(). This implementation throws an exception
Protected method | DoOpen | Override to perform actions when parcel is unsealed (opened) for modification
Protected method | DoSeal | Override to seal the parcel instance, i.e. generate some calculated fields. The version information is already generated by the time this method is called
Protected method | DoValidate | Override to perform parcel/payload validation after modification. Add validation exceptions into m_ValidationExceptions field. Use bank for cross-checks (i.e. may run queries to check consistency)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Equals | Tests for parcel equality based on the same type and GDID value (Overrides Online Object Equals(Object).)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetDistributedStableHash |
Public method | GetHashCode | Generates hash code based on parcel type and GDID value (Overrides Online Object GetHashCode .)
 | GetParcelCacheTableName | Obtains parcel cache name from either it's associated DataParcelAttribute or if not defined, from parcel type full name
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Merge | Merges other parcel instances into this one. A parcel type may support merging (when DataParcel attribute SupportsMerge is set to true) of data from other parcels/versions into this instance. This parcel must not be sealed as merge may change the payload in which case TRUE is returned. The parcel needs to be sealed again after the change. If a call to this method returns false, then nothing was changed as this instance already contains the latest data/could not be merged. Merging is used for version conflict resolution: servers check if the type of the updated parcel instance SupportsMerge, then if it does, Opens parcel and calls this method passing other versions in question to this method. The framework does not impose a limit on the supplied parcel types, however most of the parcel types support merge only with the same-typed parcel instances. IMPORTANT: The ordering of parcel versions is not guaranteed.
Public method | Open | Opens parcel for modification. Parcel must be in the Sealed state for this call and must not be ReadOnly. Once open for modification, a parcel can not be "UnOpened", only Seal()-ed. This is because there is no way to track whether some part of payload object has changed by the calling code. Use DeepClone() before calling Open to retain a copy of Sealed parcel to revert to the cloned instance instead
Public method | Seal | Seal parcel after modification May call this method on parcels in either Creating or Modifying states. Bank is used to create the ReplicationVersionInfo which is depends on store/bank implementation. Parcels can replicate only within stores/technologies that have sealed them
Public method | ToString | (Overrides Online Object ToString .)
Public method | Validate | Performs validation of the data. Does not throw but populates validation exceptions if data is not valid. Bank context may be used to run sub-queries during consistency/crosschecks May call this method on parcels in either Creating or Modifying states
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | DEFAULT_REPLICATION_PRIORITY | Default priority of replication
Protected field | m_ValidationExceptions |
 | STANDARD_KNOWN_SERIALIZER_TYPES | Defines well-known frequently used types for slim serializer compression
Back to Top
Properties
Name Description
Public property CacheAbsoluteExpirationUTC
Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a different absolute cache expiration UTC timestamp for this parcel that may depend on particular parcel payload state (i.e. field values).
Public property CachePriority
Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a relative cache priority of this parcel that may depend on particular parcel payload state (i.e. field values).
Public property CacheReadMaxAgeSec
Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a value for maximum validity span of cached parcel that may depend on particular parcel payload state (i.e. field values). This property may be used to obtain a value before parcel is re-read from the store
Public property CacheWriteMaxAgeSec
Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a value for maximum length of this isntance stay in cache that may depend on particular parcel payload state (i.e. field values)
Public property Disposed
Indicates whether this object was already disposed - the Dispose() has finished
(Inherited from DisposableObject.)
Public property DisposeStarted
Indicates whether this object Dispose() has been called and dispose started but not finished yet
(Inherited from DisposableObject.)
Public property EffectiveCachePolicy
Returns effective cache policy the one that is calculated from attribute and overidden by the instance
Public property GDID
Returns GDID for data that this parcel represents
Public property MetadataAttribute
Returns DataParcelAttribute that describes this parcel. Every parcel MUST be decorated by the DataParcel attribute
Public property NewlySealed
Returns true when parcel was just sealed after a call to Open or .ctor/create. Datastore may check this flag and disallow saving of parcel instances that have not changed
Public property Payload
Returns payload of this parcel. This may be null for deleted parcels (VersionDeleted). WARNING!!! Although parcels do not allow to set Payload property if they are sealed, one can still mutate/modify the payload object graph even on a sealed parcel instance, i.e. one may write:
View Colorized Copy to Clipboard Print
mySealedParcel.Payload.DueDates.Add(DateTime.Now) (given DueDates of type List(DateTime))
mySealedParcel.Payload.DueDates.Add(DateTime.Now) (given DueDates of type List(DateTime))
. This case is considered to be a bug in the calling-code. The framework has no way of preventing such an inadvertent behavior as there is no way to intercept a mutation via transitive or direct references/functors in an object graph referenced by Payload property because payload type does not impose (and should not) any constraints on what can be a payload. In Aum language we will use static type checker that will detect possible property access via Payload BEFORE calling Open()
Public property ReadOnly
Indicates whether the data may be altered. ReadOnly parcels can not be Opened after that have been Sealed by their creator
Public property ReplicationPriority
Returns replication priority, override to make replication priority dependent on instance, i.e. a user profile data for a celebrity user may need to have higher replication rate. The lower value indicates the higher priority
Public property ReplicationVersionInfo
Implements IReplicatable interface
Public property ShardingID
Returns the ShardingID used for sharding, default implementation returns this parcel type and GDID. Override to return another sharding key, i.e. a social comment msg may use parent item (that the msg relates to) ID as the shard key so msgs are co-located with related items. Use CompositeShardingID to return multiple values. IMPORTANT!!! ShardingID must return an immutable value, the one that CAN NOT be changed during parcel payload life
Public property ShardingPointer
Returns the ShardingPointer(type:ID) used for sharding, default implementation returns this parcel type and GDID. Override ShardingID property to return another sharding key, i.e. a social comment msg may use parent item (that the msg relates to) ID as the shard key so msgs are co-located with related items. Use CompositeShardingID to return multiple values. IMPORTANT!!! ShardingPointer must return an immutable value, the one that CAN NOT be changed during parcel payload life
Public property State
Returns the state of the parcel: Creating|Modifying|Sealed
Public property ValidationExceptions
Returns validation exceptions - populated by a call to Validate
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICachePolicy CacheTableName | Implements IParcelCachePolicy contract. The implementation returns null for parcel.
Back to Top
See Also
Parcel Class
NFX.DataAccess.Distributed Namespace


Parcel Constructor

Parcel Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | Parcel | Used for serialization
Protected method | Parcel(Object) | This ctor is never public, used with __ctor__injectID
Protected method | Parcel(GDID, Object) | Called when creating new Parcel instances by the original author. The new instance is in 'ParcelState.Creating' state
Protected method | Parcel(GDID, Object, IReplicationVersionInfo) | Called by device to load parcel from storage. The new instance is in 'ParcelState.Sealed' state. Business logic devs - do not call
Back to Top
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel Constructor

Parcel Constructor NFX Class Library

Used for serialization

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Parcel()
protected Parcel()
Protected Sub New
Protected Sub New
protected:
Parcel()
protected:
Parcel()
new : unit -> Parcel
new : unit -> Parcel
See Also
Parcel Class
Parcel Members
Parcel Overload
NFX.DataAccess.Distributed Namespace


Parcel Constructor (Object)

Parcel Constructor (Object) NFX Class Library

This ctor is never public, used with __ctor__injectID

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Parcel(
    Object payload
)
protected Parcel(
    Object payload
)
Protected Sub New (
    payload As Object
)
Protected Sub New (
    payload As Object
)
protected:
Parcel(
    Object^ payload
)
protected:
Parcel(
    Object^ payload
)
new :
        payload : Object -> Parcel
new :
        payload : Object -> Parcel

Parameters

payload
Type: Online System Object
See Also
Parcel Class
Parcel Members
Parcel Overload
NFX.DataAccess.Distributed Namespace


Parcel Constructor (GDID, Object)

Parcel Constructor (GDID, Object) NFX Class Library

Called when creating new Parcel instances by the original author. The new instance is in 'ParcelState.Creating' state

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Parcel(
    GDID id,
    Object payload
)
protected Parcel(
    GDID id,
    Object payload
)
Protected Sub New (
    id As GDID,
    payload As Object
)
Protected Sub New (
    id As GDID,
    payload As Object
)
protected:
Parcel(
    GDID id,
    Object^ payload
)
protected:
Parcel(
    GDID id,
    Object^ payload
)
new :
        id : GDID *
        payload : Object -> Parcel
new :
        id : GDID *
        payload : Object -> Parcel

Parameters

id
Type: NFX.DataAccess.Distributed GDID
payload
Type: Online System Object
See Also
Parcel Class
Parcel Members
Parcel Overload
NFX.DataAccess.Distributed Namespace


Parcel Constructor (GDID, Object, IReplicationVersionInfo)

Parcel Constructor (GDID, Object, IReplicationVersionInfo) NFX Class Library

[This is preliminary documentation and is subject to change.]

Called by device to load parcel from storage. The new instance is in 'ParcelState.Sealed' state. Business logic devs - do not call

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Parcel(
    GDID id,
    Object payload,
    IReplicationVersionInfo versInfo
)
protected Parcel(
    GDID id,
    Object payload,
    IReplicationVersionInfo versInfo
)
Protected Sub New (
    id As GDID,
    payload As Object,
    versInfo As IReplicationVersionInfo
)
Protected Sub New (
    id As GDID,
    payload As Object,
    versInfo As IReplicationVersionInfo
)
protected:
Parcel(
    GDID id,
    Object^ payload,
    IReplicationVersionInfo^ versInfo
)
protected:
Parcel(
    GDID id,
    Object^ payload,
    IReplicationVersionInfo^ versInfo
)
new :
        id : GDID *
        payload : Object *
        versInfo : IReplicationVersionInfo -> Parcel
new :
        id : GDID *
        payload : Object *
        versInfo : IReplicationVersionInfo -> Parcel

Parameters

id
Type: NFX.DataAccess.Distributed GDID
payload
Type: Online System Object
versInfo
Type: NFX.DataAccess.Distributed IReplicationVersionInfo
See Also
Parcel Class
Parcel Members
Parcel Overload
NFX.DataAccess.Distributed Namespace


Parcel Fields

Parcel Fields NFX Class Library

The Parcel type exposes the following members.
Fields
 | Name | Description
 | DEFAULT_REPLICATION_PRIORITY | Default priority of replication
Protected field | m_ValidationExceptions |
 | STANDARD_KNOWN_SERIALIZER_TYPES | Defines well-known frequently used types for slim serializer compression
Back to Top
See Also
Parcel Class
NFX.DataAccess.Distributed Namespace


Parcel.DEFAULT_REPLICATION_PRIORITY Field

Parcel DEFAULT_REPLICATION_PRIORITY Field NFX Class Library

Default priority of replication

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int DEFAULT_REPLICATION_PRIORITY
public static int DEFAULT_REPLICATION_PRIORITY
Public Shared DEFAULT_REPLICATION_PRIORITY As Integer
Public Shared DEFAULT_REPLICATION_PRIORITY As Integer
public:
static int DEFAULT_REPLICATION_PRIORITY
public:
static int DEFAULT_REPLICATION_PRIORITY
static val mutable DEFAULT_REPLICATION_PRIORITY: int
static val mutable DEFAULT_REPLICATION_PRIORITY: int

Field Value

Type: Online Int32
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.m_ValidationExceptions Field

Parcel m_ValidationExceptions Field NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[NonSerializedAttribute]
protected List<Exception> m_ValidationExceptions
[NonSerializedAttribute]
protected List<Exception> m_ValidationExceptions
<NonSerializedAttribute>
Protected m_ValidationExceptions As List(Of Exception)
<NonSerializedAttribute>
Protected m_ValidationExceptions As List(Of Exception)
protected:
[NonSerializedAttribute]
List<Exception^>^ m_ValidationExceptions
protected:
[NonSerializedAttribute]
List<Exception^>^ m_ValidationExceptions
[<NonSerializedAttribute>]
val mutable m_ValidationExceptions: List<Exception>
[<NonSerializedAttribute>]
val mutable m_ValidationExceptions: List<Exception>

Field Value

Type: Online List Online Exception
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.STANDARD_KNOWN_SERIALIZER_TYPES Field

Parcel STANDARD_KNOWN_SERIALIZER_TYPES Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Defines well-known frequently used types for slim serializer compression

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly TypeRegistry STANDARD_KNOWN_SERIALIZER_TYPES
public static readonly TypeRegistry STANDARD_KNOWN_SERIALIZER_TYPES
Public Shared ReadOnly STANDARD_KNOWN_SERIALIZER_TYPES As TypeRegistry
Public Shared ReadOnly STANDARD_KNOWN_SERIALIZER_TYPES As TypeRegistry
public:
static initonly TypeRegistry^ STANDARD_KNOWN_SERIALIZER_TYPES
public:
static initonly TypeRegistry^ STANDARD_KNOWN_SERIALIZER_TYPES
static val STANDARD_KNOWN_SERIALIZER_TYPES: TypeRegistry
static val STANDARD_KNOWN_SERIALIZER_TYPES: TypeRegistry

Field Value

Type: TypeRegistry
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel Methods

Parcel Methods NFX Class Library

The Parcel type exposes the following members.
Methods
 | Name | Description
Protected method | __ctor__injectID | Internal framework method, developers: never call
Public method | DeepClone | Duplicates this parcel by doing a complete deep-clone of its state via serialization. This method is useful for making copies of the same parcel for different threads as it is thread-safe while no other thread mutates the instance, however Parcel instances are NOT THREAD-SAFE for parallel changes. The existing parcel MUST be SEALED (otherwise it can not be serialized). This method is also used before a call to Open() if parcel needs to be "un-opened" the cloned instance may be reverted to
Protected method | Destructor | Override this method to do actual destructor work (Inherited from DisposableObject.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoMerge | Override to merge other parcels into this one. Return true if merge changed the payload. See Merge(). This implementation throws an exception
Protected method | DoOpen | Override to perform actions when parcel is unsealed (opened) for modification
Protected method | DoSeal | Override to seal the parcel instance, i.e. generate some calculated fields. The version information is already generated by the time this method is called
Protected method | DoValidate | Override to perform parcel/payload validation after modification. Add validation exceptions into m_ValidationExceptions field. Use bank for cross-checks (i.e. may run queries to check consistency)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Equals | Tests for parcel equality based on the same type and GDID value (Overrides Online Object Equals(Object).)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetDistributedStableHash |
Public method | GetHashCode | Generates hash code based on parcel type and GDID value (Overrides Online Object GetHashCode .)
 | GetParcelCacheTableName | Obtains parcel cache name from either it's associated DataParcelAttribute or if not defined, from parcel type full name
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Merge | Merges other parcel instances into this one. A parcel type may support merging (when DataParcel attribute SupportsMerge is set to true) of data from other parcels/versions into this instance. This parcel must not be sealed as merge may change the payload in which case TRUE is returned. The parcel needs to be sealed again after the change. If a call to this method returns false, then nothing was changed as this instance already contains the latest data/could not be merged. Merging is used for version conflict resolution: servers check if the type of the updated parcel instance SupportsMerge, then if it does, Opens parcel and calls this method passing other versions in question to this method. The framework does not impose a limit on the supplied parcel types, however most of the parcel types support merge only with the same-typed parcel instances. IMPORTANT: The ordering of parcel versions is not guaranteed.
Public method | Open | Opens parcel for modification. Parcel must be in the Sealed state for this call and must not be ReadOnly. Once open for modification, a parcel can not be "UnOpened", only Seal()-ed. This is because there is no way to track whether some part of payload object has changed by the calling code. Use DeepClone() before calling Open to retain a copy of Sealed parcel to revert to the cloned instance instead
Public method | Seal | Seal parcel after modification May call this method on parcels in either Creating or Modifying states. Bank is used to create the ReplicationVersionInfo which is depends on store/bank implementation. Parcels can replicate only within stores/technologies that have sealed them
Public method | ToString | (Overrides Online Object ToString .)
Public method | Validate | Performs validation of the data. Does not throw but populates validation exceptions if data is not valid. Bank context may be used to run sub-queries during consistency/crosschecks May call this method on parcels in either Creating or Modifying states
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Parcel Class
NFX.DataAccess.Distributed Namespace


Parcel.__ctor__injectID Method

Parcel __ctor__injectID Method NFX Class Library

Internal framework method, developers: never call

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void __ctor__injectID(
    GDID id
)
protected void __ctor__injectID(
    GDID id
)
Protected Sub __ctor__injectID (
    id As GDID
)
Protected Sub __ctor__injectID (
    id As GDID
)
protected:
void __ctor__injectID(
    GDID id
)
protected:
void __ctor__injectID(
    GDID id
)
member __ctor__injectID :
        id : GDID -> unit
member __ctor__injectID :
        id : GDID -> unit

Parameters

id
Type: NFX.DataAccess.Distributed GDID
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.DeepClone Method

Parcel DeepClone Method NFX Class Library

Duplicates this parcel by doing a complete deep-clone of its state via serialization. This method is useful for making copies of the same parcel for different threads as it is thread-safe while no other thread mutates the instance, however Parcel instances are NOT THREAD-SAFE for parallel changes. The existing parcel MUST be SEALED (otherwise it can not be serialized). This method is also used before a call to Open() if parcel needs to be "un-opened" the cloned instance may be reverted to

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Parcel DeepClone()
public Parcel DeepClone()
Public Function DeepClone As Parcel
Public Function DeepClone As Parcel
public:
Parcel^ DeepClone()
public:
Parcel^ DeepClone()
member DeepClone : unit -> Parcel
member DeepClone : unit -> Parcel

Return Value

Type: Parcel
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.DoMerge Method

Parcel DoMerge Method NFX Class Library

Override to merge other parcels into this one. Return true if merge changed the payload. See Merge(). This implementation throws an exception

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool DoMerge(
    IEnumerable<Parcel> others
)
protected virtual bool DoMerge(
    IEnumerable<Parcel> others
)
Protected Overridable Function DoMerge (
    others As IEnumerable(Of Parcel)
) As Boolean
Protected Overridable Function DoMerge (
    others As IEnumerable(Of Parcel)
) As Boolean
protected:
virtual bool DoMerge(
    IEnumerable<Parcel^>^ others
)
protected:
virtual bool DoMerge(
    IEnumerable<Parcel^>^ others
)
abstract DoMerge :
        others : IEnumerable<Parcel> -> bool
override DoMerge :
        others : IEnumerable<Parcel> -> bool
abstract DoMerge :
        others : IEnumerable<Parcel> -> bool
override DoMerge :
        others : IEnumerable<Parcel> -> bool

Parameters

others
Type: Online System.Collections.Generic IEnumerable Parcel

Return Value

Type: Online Boolean
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.DoOpen Method

Parcel DoOpen Method NFX Class Library

Override to perform actions when parcel is unsealed (opened) for modification

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoOpen()
protected virtual void DoOpen()
Protected Overridable Sub DoOpen
Protected Overridable Sub DoOpen
protected:
virtual void DoOpen()
protected:
virtual void DoOpen()
abstract DoOpen : unit -> unit
override DoOpen : unit -> unit
abstract DoOpen : unit -> unit
override DoOpen : unit -> unit
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.DoSeal Method

Parcel DoSeal Method NFX Class Library

Override to seal the parcel instance, i.e. generate some calculated fields. The version information is already generated by the time this method is called

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoSeal(
    IBank bank
)
protected virtual void DoSeal(
    IBank bank
)
Protected Overridable Sub DoSeal (
    bank As IBank
)
Protected Overridable Sub DoSeal (
    bank As IBank
)
protected:
virtual void DoSeal(
    IBank^ bank
)
protected:
virtual void DoSeal(
    IBank^ bank
)
abstract DoSeal :
        bank : IBank -> unit
override DoSeal :
        bank : IBank -> unit
abstract DoSeal :
        bank : IBank -> unit
override DoSeal :
        bank : IBank -> unit

Parameters

bank
Type: NFX.DataAccess.Distributed IBank
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.DoValidate Method

Parcel DoValidate Method NFX Class Library

Override to perform parcel/payload validation after modification. Add validation exceptions into m_ValidationExceptions field. Use bank for cross-checks (i.e. may run queries to check consistency)

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void DoValidate(
    IBank bank
)
protected abstract void DoValidate(
    IBank bank
)
Protected MustOverride Sub DoValidate (
    bank As IBank
)
Protected MustOverride Sub DoValidate (
    bank As IBank
)
protected:
virtual void DoValidate(
    IBank^ bank
) abstract
protected:
virtual void DoValidate(
    IBank^ bank
) abstract
abstract DoValidate :
        bank : IBank -> unit
abstract DoValidate :
        bank : IBank -> unit

Parameters

bank
Type: NFX.DataAccess.Distributed IBank
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.Equals Method

Parcel Equals Method NFX Class Library

Tests for parcel equality based on the same type and GDID value

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.GetDistributedStableHash Method

Parcel GetDistributedStableHash Method NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong GetDistributedStableHash()
public ulong GetDistributedStableHash()
Public Function GetDistributedStableHash As ULong
Public Function GetDistributedStableHash As ULong
public:
virtual unsigned long long GetDistributedStableHash() sealed
public:
virtual unsigned long long GetDistributedStableHash() sealed
abstract GetDistributedStableHash : unit -> uint64
override GetDistributedStableHash : unit -> uint64
abstract GetDistributedStableHash : unit -> uint64
override GetDistributedStableHash : unit -> uint64

Return Value

Type: Online UInt64

Implements

IDistributedStableHashProvider GetDistributedStableHash
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.GetHashCode Method

Parcel GetHashCode Method NFX Class Library

Generates hash code based on parcel type and GDID value

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.GetParcelCacheTableName Method

Parcel GetParcelCacheTableName Method NFX Class Library

Obtains parcel cache name from either it's associated DataParcelAttribute or if not defined, from parcel type full name

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetParcelCacheTableName(
    Type tparcel
)
public static string GetParcelCacheTableName(
    Type tparcel
)
Public Shared Function GetParcelCacheTableName (
    tparcel As Type
) As String
Public Shared Function GetParcelCacheTableName (
    tparcel As Type
) As String
public:
static String^ GetParcelCacheTableName(
    Type^ tparcel
)
public:
static String^ GetParcelCacheTableName(
    Type^ tparcel
)
static member GetParcelCacheTableName :
        tparcel : Type -> string
static member GetParcelCacheTableName :
        tparcel : Type -> string

Parameters

tparcel
Type: Online System Type

Return Value

Type: Online String
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.Merge Method

Parcel Merge Method NFX Class Library

Merges other parcel instances into this one. A parcel type may support merging (when DataParcel attribute SupportsMerge is set to true) of data from other parcels/versions into this instance. This parcel must not be sealed as merge may change the payload in which case TRUE is returned. The parcel needs to be sealed again after the change. If a call to this method returns false, then nothing was changed as this instance already contains the latest data/could not be merged. Merging is used for version conflict resolution: servers check if the type of the updated parcel instance SupportsMerge, then if it does, Opens parcel and calls this method passing other versions in question to this method. The framework does not impose a limit on the supplied parcel types, however most of the parcel types support merge only with the same-typed parcel instances. IMPORTANT: The ordering of parcel versions is not guaranteed.

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Merge(
    IEnumerable<Parcel> others
)
public bool Merge(
    IEnumerable<Parcel> others
)
Public Function Merge (
    others As IEnumerable(Of Parcel)
) As Boolean
Public Function Merge (
    others As IEnumerable(Of Parcel)
) As Boolean
public:
bool Merge(
    IEnumerable<Parcel^>^ others
)
public:
bool Merge(
    IEnumerable<Parcel^>^ others
)
member Merge :
        others : IEnumerable<Parcel> -> bool
member Merge :
        others : IEnumerable<Parcel> -> bool

Parameters

others
Type: Online System.Collections.Generic IEnumerable Parcel
Other parcel versions/data

Return Value

Type: Online Boolean
True if Merge() generated newer version/changed payload. False when Merge did not/could not change existing parcel
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.Open Method

Parcel Open Method NFX Class Library

Opens parcel for modification. Parcel must be in the Sealed state for this call and must not be ReadOnly. Once open for modification, a parcel can not be "UnOpened", only Seal()-ed. This is because there is no way to track whether some part of payload object has changed by the calling code. Use DeepClone() before calling Open to retain a copy of Sealed parcel to revert to the cloned instance instead

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Open()
public void Open()
Public Sub Open
Public Sub Open
public:
void Open()
public:
void Open()
member Open : unit -> unit
member Open : unit -> unit
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.Seal Method

Parcel Seal Method NFX Class Library

Seal parcel after modification May call this method on parcels in either Creating or Modifying states. Bank is used to create the ReplicationVersionInfo which is depends on store/bank implementation. Parcels can replicate only within stores/technologies that have sealed them

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Seal(
    IBank bank
)
public void Seal(
    IBank bank
)
Public Sub Seal (
    bank As IBank
)
Public Sub Seal (
    bank As IBank
)
public:
void Seal(
    IBank^ bank
)
public:
void Seal(
    IBank^ bank
)
member Seal :
        bank : IBank -> unit
member Seal :
        bank : IBank -> unit

Parameters

bank
Type: NFX.DataAccess.Distributed IBank
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.ToString Method

Parcel ToString Method NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.Validate Method

Parcel Validate Method NFX Class Library

Performs validation of the data. Does not throw but populates validation exceptions if data is not valid. Bank context may be used to run sub-queries during consistency/crosschecks May call this method on parcels in either Creating or Modifying states

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Validate(
    IBank bank
)
public void Validate(
    IBank bank
)
Public Sub Validate (
    bank As IBank
)
Public Sub Validate (
    bank As IBank
)
public:
void Validate(
    IBank^ bank
)
public:
void Validate(
    IBank^ bank
)
member Validate :
        bank : IBank -> unit
member Validate :
        bank : IBank -> unit

Parameters

bank
Type: NFX.DataAccess.Distributed IBank
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel Properties

Parcel Properties NFX Class Library

The Parcel type exposes the following members.
Properties
Name Description
Public property CacheAbsoluteExpirationUTC
Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a different absolute cache expiration UTC timestamp for this parcel that may depend on particular parcel payload state (i.e. field values).
Public property CachePriority
Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a relative cache priority of this parcel that may depend on particular parcel payload state (i.e. field values).
Public property CacheReadMaxAgeSec
Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a value for maximum validity span of cached parcel that may depend on particular parcel payload state (i.e. field values). This property may be used to obtain a value before parcel is re-read from the store
Public property CacheWriteMaxAgeSec
Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a value for maximum length of this isntance stay in cache that may depend on particular parcel payload state (i.e. field values)
Public property Disposed
Indicates whether this object was already disposed - the Dispose() has finished
(Inherited from DisposableObject.)
Public property DisposeStarted
Indicates whether this object Dispose() has been called and dispose started but not finished yet
(Inherited from DisposableObject.)
Public property EffectiveCachePolicy
Returns effective cache policy the one that is calculated from attribute and overidden by the instance
Public property GDID
Returns GDID for data that this parcel represents
Public property MetadataAttribute
Returns DataParcelAttribute that describes this parcel. Every parcel MUST be decorated by the DataParcel attribute
Public property NewlySealed
Returns true when parcel was just sealed after a call to Open or .ctor/create. Datastore may check this flag and disallow saving of parcel instances that have not changed
Public property Payload
Returns payload of this parcel. This may be null for deleted parcels (VersionDeleted). WARNING!!! Although parcels do not allow to set Payload property if they are sealed, one can still mutate/modify the payload object graph even on a sealed parcel instance, i.e. one may write:
View Colorized Copy to Clipboard Print
mySealedParcel.Payload.DueDates.Add(DateTime.Now) (given DueDates of type List(DateTime))
mySealedParcel.Payload.DueDates.Add(DateTime.Now) (given DueDates of type List(DateTime))
. This case is considered to be a bug in the calling-code. The framework has no way of preventing such an inadvertent behavior as there is no way to intercept a mutation via transitive or direct references/functors in an object graph referenced by Payload property because payload type does not impose (and should not) any constraints on what can be a payload. In Aum language we will use static type checker that will detect possible property access via Payload BEFORE calling Open()
Public property ReadOnly
Indicates whether the data may be altered. ReadOnly parcels can not be Opened after that have been Sealed by their creator
Public property ReplicationPriority
Returns replication priority, override to make replication priority dependent on instance, i.e. a user profile data for a celebrity user may need to have higher replication rate. The lower value indicates the higher priority
Public property ReplicationVersionInfo
Implements IReplicatable interface
Public property ShardingID
Returns the ShardingID used for sharding, default implementation returns this parcel type and GDID. Override to return another sharding key, i.e. a social comment msg may use parent item (that the msg relates to) ID as the shard key so msgs are co-located with related items. Use CompositeShardingID to return multiple values. IMPORTANT!!! ShardingID must return an immutable value, the one that CAN NOT be changed during parcel payload life
Public property ShardingPointer
Returns the ShardingPointer(type:ID) used for sharding, default implementation returns this parcel type and GDID. Override ShardingID property to return another sharding key, i.e. a social comment msg may use parent item (that the msg relates to) ID as the shard key so msgs are co-located with related items. Use CompositeShardingID to return multiple values. IMPORTANT!!! ShardingPointer must return an immutable value, the one that CAN NOT be changed during parcel payload life
Public property State
Returns the state of the parcel: Creating|Modifying|Sealed
Public property ValidationExceptions
Returns validation exceptions - populated by a call to Validate
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICachePolicy CacheTableName | Implements IParcelCachePolicy contract. The implementation returns null for parcel.
Back to Top
See Also
Parcel Class
NFX.DataAccess.Distributed Namespace


Parcel.CacheAbsoluteExpirationUTC Property

Parcel CacheAbsoluteExpirationUTC Property NFX Class Library

Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a different absolute cache expiration UTC timestamp for this parcel that may depend on particular parcel payload state (i.e. field values).

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> CacheAbsoluteExpirationUTC { get; }
public Nullable<DateTime> CacheAbsoluteExpirationUTC { get; }
Public ReadOnly Property CacheAbsoluteExpirationUTC As Nullable(Of DateTime)
    Get
Public ReadOnly Property CacheAbsoluteExpirationUTC As Nullable(Of DateTime)
    Get
public:
virtual property Nullable<DateTime> CacheAbsoluteExpirationUTC {
    Nullable<DateTime> get () sealed;
}
public:
virtual property Nullable<DateTime> CacheAbsoluteExpirationUTC {
    Nullable<DateTime> get () sealed;
}
abstract CacheAbsoluteExpirationUTC : Nullable<DateTime> with get
override CacheAbsoluteExpirationUTC : Nullable<DateTime> with get
abstract CacheAbsoluteExpirationUTC : Nullable<DateTime> with get
override CacheAbsoluteExpirationUTC : Nullable<DateTime> with get

Property Value

Type: Online Nullable Online DateTime

Implements

ICachePolicy CacheAbsoluteExpirationUTC
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.CachePriority Property

Parcel CachePriority Property NFX Class Library

Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a relative cache priority of this parcel that may depend on particular parcel payload state (i.e. field values).

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Nullable<int> CachePriority { get; }
public virtual Nullable<int> CachePriority { get; }
Public Overridable ReadOnly Property CachePriority As Nullable(Of Integer)
    Get
Public Overridable ReadOnly Property CachePriority As Nullable(Of Integer)
    Get
public:
virtual property Nullable<int> CachePriority {
    Nullable<int> get ();
}
public:
virtual property Nullable<int> CachePriority {
    Nullable<int> get ();
}
abstract CachePriority : Nullable<int> with get
override CachePriority : Nullable<int> with get
abstract CachePriority : Nullable<int> with get
override CachePriority : Nullable<int> with get

Property Value

Type: Online Nullable Online Int32

Implements

ICachePolicy CachePriority
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.CacheReadMaxAgeSec Property

Parcel CacheReadMaxAgeSec Property NFX Class Library

Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a value for maximum validity span of cached parcel that may depend on particular parcel payload state (i.e. field values). This property may be used to obtain a value before parcel is re-read from the store

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Nullable<int> CacheReadMaxAgeSec { get; }
public virtual Nullable<int> CacheReadMaxAgeSec { get; }
Public Overridable ReadOnly Property CacheReadMaxAgeSec As Nullable(Of Integer)
    Get
Public Overridable ReadOnly Property CacheReadMaxAgeSec As Nullable(Of Integer)
    Get
public:
virtual property Nullable<int> CacheReadMaxAgeSec {
    Nullable<int> get ();
}
public:
virtual property Nullable<int> CacheReadMaxAgeSec {
    Nullable<int> get ();
}
abstract CacheReadMaxAgeSec : Nullable<int> with get
override CacheReadMaxAgeSec : Nullable<int> with get
abstract CacheReadMaxAgeSec : Nullable<int> with get
override CacheReadMaxAgeSec : Nullable<int> with get

Property Value

Type: Online Nullable Online Int32

Implements

ICachePolicy CacheReadMaxAgeSec
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.CacheWriteMaxAgeSec Property

Parcel CacheWriteMaxAgeSec Property NFX Class Library

Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a value for maximum length of this isntance stay in cache that may depend on particular parcel payload state (i.e. field values)

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Nullable<int> CacheWriteMaxAgeSec { get; }
public virtual Nullable<int> CacheWriteMaxAgeSec { get; }
Public Overridable ReadOnly Property CacheWriteMaxAgeSec As Nullable(Of Integer)
    Get
Public Overridable ReadOnly Property CacheWriteMaxAgeSec As Nullable(Of Integer)
    Get
public:
virtual property Nullable<int> CacheWriteMaxAgeSec {
    Nullable<int> get ();
}
public:
virtual property Nullable<int> CacheWriteMaxAgeSec {
    Nullable<int> get ();
}
abstract CacheWriteMaxAgeSec : Nullable<int> with get
override CacheWriteMaxAgeSec : Nullable<int> with get
abstract CacheWriteMaxAgeSec : Nullable<int> with get
override CacheWriteMaxAgeSec : Nullable<int> with get

Property Value

Type: Online Nullable Online Int32

Implements

ICachePolicy CacheWriteMaxAgeSec
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.EffectiveCachePolicy Property

Parcel EffectiveCachePolicy Property NFX Class Library

Returns effective cache policy the one that is calculated from attribute and overidden by the instance

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICachePolicy EffectiveCachePolicy { get; }
public ICachePolicy EffectiveCachePolicy { get; }
Public ReadOnly Property EffectiveCachePolicy As ICachePolicy
    Get
Public ReadOnly Property EffectiveCachePolicy As ICachePolicy
    Get
public:
property ICachePolicy^ EffectiveCachePolicy {
    ICachePolicy^ get ();
}
public:
property ICachePolicy^ EffectiveCachePolicy {
    ICachePolicy^ get ();
}
member EffectiveCachePolicy : ICachePolicy with get
member EffectiveCachePolicy : ICachePolicy with get

Property Value

Type: ICachePolicy
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.GDID Property

Parcel GDID Property NFX Class Library

Returns GDID for data that this parcel represents

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GDID GDID { get; }
public GDID GDID { get; }
Public ReadOnly Property GDID As GDID
    Get
Public ReadOnly Property GDID As GDID
    Get
public:
property GDID GDID {
    GDID get ();
}
public:
property GDID GDID {
    GDID get ();
}
member GDID : GDID with get
member GDID : GDID with get

Property Value

Type: GDID
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.ICachePolicy.CacheTableName Property

Parcel ICachePolicy CacheTableName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Implements IParcelCachePolicy contract. The implementation returns null for parcel.

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string ICachePolicy.CacheTableName { get; }
string ICachePolicy.CacheTableName { get; }
Private ReadOnly Property CacheTableName As String
    Implements ICachePolicy.CacheTableName
    Get
Private ReadOnly Property CacheTableName As String
    Implements ICachePolicy.CacheTableName
    Get
private:
virtual property String^ CacheTableName {
    String^ get () sealed = ICachePolicy::CacheTableName::get;
}
private:
virtual property String^ CacheTableName {
    String^ get () sealed = ICachePolicy::CacheTableName::get;
}
private abstract CacheTableName : string with get
private override CacheTableName : string with get
private abstract CacheTableName : string with get
private override CacheTableName : string with get

Property Value

Type: Online String

Implements

ICachePolicy CacheTableName
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.MetadataAttribute Property

Parcel MetadataAttribute Property NFX Class Library

Returns DataParcelAttribute that describes this parcel. Every parcel MUST be decorated by the DataParcel attribute

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DataParcelAttribute MetadataAttribute { get; }
public DataParcelAttribute MetadataAttribute { get; }
Public ReadOnly Property MetadataAttribute As DataParcelAttribute
    Get
Public ReadOnly Property MetadataAttribute As DataParcelAttribute
    Get
public:
property DataParcelAttribute^ MetadataAttribute {
    DataParcelAttribute^ get ();
}
public:
property DataParcelAttribute^ MetadataAttribute {
    DataParcelAttribute^ get ();
}
member MetadataAttribute : DataParcelAttribute with get
member MetadataAttribute : DataParcelAttribute with get

Property Value

Type: DataParcelAttribute
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.NewlySealed Property

Parcel NewlySealed Property NFX Class Library

Returns true when parcel was just sealed after a call to Open or .ctor/create. Datastore may check this flag and disallow saving of parcel instances that have not changed

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool NewlySealed { get; }
public bool NewlySealed { get; }
Public ReadOnly Property NewlySealed As Boolean
    Get
Public ReadOnly Property NewlySealed As Boolean
    Get
public:
property bool NewlySealed {
    bool get ();
}
public:
property bool NewlySealed {
    bool get ();
}
member NewlySealed : bool with get
member NewlySealed : bool with get

Property Value

Type: Online Boolean
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.Payload Property

Parcel Payload Property NFX Class Library

Returns payload of this parcel. This may be null for deleted parcels (VersionDeleted). WARNING!!! Although parcels do not allow to set Payload property if they are sealed, one can still mutate/modify the payload object graph even on a sealed parcel instance, i.e. one may write:
View Colorized Copy to Clipboard Print
mySealedParcel.Payload.DueDates.Add(DateTime.Now) (given DueDates of type List(DateTime))
mySealedParcel.Payload.DueDates.Add(DateTime.Now) (given DueDates of type List(DateTime))
. This case is considered to be a bug in the calling-code. The framework has no way of preventing such an inadvertent behavior as there is no way to intercept a mutation via transitive or direct references/functors in an object graph referenced by Payload property because payload type does not impose (and should not) any constraints on what can be a payload. In Aum language we will use static type checker that will detect possible property access via Payload BEFORE calling Open()

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Payload { get; }
public Object Payload { get; }
Public ReadOnly Property Payload As Object
    Get
Public ReadOnly Property Payload As Object
    Get
public:
property Object^ Payload {
    Object^ get ();
}
public:
property Object^ Payload {
    Object^ get ();
}
member Payload : Object with get
member Payload : Object with get

Property Value

Type: Online Object
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.ReadOnly Property

Parcel ReadOnly Property NFX Class Library

Indicates whether the data may be altered. ReadOnly parcels can not be Opened after that have been Sealed by their creator

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool ReadOnly { get; }
public abstract bool ReadOnly { get; }
Public MustOverride ReadOnly Property ReadOnly As Boolean
    Get
Public MustOverride ReadOnly Property ReadOnly As Boolean
    Get
public:
virtual property bool ReadOnly {
    bool get () abstract;
}
public:
virtual property bool ReadOnly {
    bool get () abstract;
}
abstract ReadOnly : bool with get
abstract ReadOnly : bool with get

Property Value

Type: Online Boolean
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.ReplicationPriority Property

Parcel ReplicationPriority Property NFX Class Library

Returns replication priority, override to make replication priority dependent on instance, i.e. a user profile data for a celebrity user may need to have higher replication rate. The lower value indicates the higher priority

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int ReplicationPriority { get; }
public virtual int ReplicationPriority { get; }
Public Overridable ReadOnly Property ReplicationPriority As Integer
    Get
Public Overridable ReadOnly Property ReplicationPriority As Integer
    Get
public:
virtual property int ReplicationPriority {
    int get ();
}
public:
virtual property int ReplicationPriority {
    int get ();
}
abstract ReplicationPriority : int with get
override ReplicationPriority : int with get
abstract ReplicationPriority : int with get
override ReplicationPriority : int with get

Property Value

Type: Online Int32

Implements

IReplicatable ReplicationPriority
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.ReplicationVersionInfo Property

Parcel ReplicationVersionInfo Property NFX Class Library

Implements IReplicatable interface

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IReplicationVersionInfo ReplicationVersionInfo { get; }
public IReplicationVersionInfo ReplicationVersionInfo { get; }
Public ReadOnly Property ReplicationVersionInfo As IReplicationVersionInfo
    Get
Public ReadOnly Property ReplicationVersionInfo As IReplicationVersionInfo
    Get
public:
virtual property IReplicationVersionInfo^ ReplicationVersionInfo {
    IReplicationVersionInfo^ get () sealed;
}
public:
virtual property IReplicationVersionInfo^ ReplicationVersionInfo {
    IReplicationVersionInfo^ get () sealed;
}
abstract ReplicationVersionInfo : IReplicationVersionInfo with get
override ReplicationVersionInfo : IReplicationVersionInfo with get
abstract ReplicationVersionInfo : IReplicationVersionInfo with get
override ReplicationVersionInfo : IReplicationVersionInfo with get

Property Value

Type: IReplicationVersionInfo

Implements

IReplicatable ReplicationVersionInfo
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.ShardingID Property

Parcel ShardingID Property NFX Class Library

Returns the ShardingID used for sharding, default implementation returns this parcel type and GDID. Override to return another sharding key, i.e. a social comment msg may use parent item (that the msg relates to) ID as the shard key so msgs are co-located with related items. Use CompositeShardingID to return multiple values. IMPORTANT!!! ShardingID must return an immutable value, the one that CAN NOT be changed during parcel payload life

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object ShardingID { get; }
public virtual Object ShardingID { get; }
Public Overridable ReadOnly Property ShardingID As Object
    Get
Public Overridable ReadOnly Property ShardingID As Object
    Get
public:
virtual property Object^ ShardingID {
    Object^ get ();
}
public:
virtual property Object^ ShardingID {
    Object^ get ();
}
abstract ShardingID : Object with get
override ShardingID : Object with get
abstract ShardingID : Object with get
override ShardingID : Object with get

Property Value

Type: Online Object
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.ShardingPointer Property

Parcel ShardingPointer Property NFX Class Library

Returns the ShardingPointer(type:ID) used for sharding, default implementation returns this parcel type and GDID. Override ShardingID property to return another sharding key, i.e. a social comment msg may use parent item (that the msg relates to) ID as the shard key so msgs are co-located with related items. Use CompositeShardingID to return multiple values. IMPORTANT!!! ShardingPointer must return an immutable value, the one that CAN NOT be changed during parcel payload life

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ShardingPointer ShardingPointer { get; }
public ShardingPointer ShardingPointer { get; }
Public ReadOnly Property ShardingPointer As ShardingPointer
    Get
Public ReadOnly Property ShardingPointer As ShardingPointer
    Get
public:
virtual property ShardingPointer ShardingPointer {
    ShardingPointer get () sealed;
}
public:
virtual property ShardingPointer ShardingPointer {
    ShardingPointer get () sealed;
}
abstract ShardingPointer : ShardingPointer with get
override ShardingPointer : ShardingPointer with get
abstract ShardingPointer : ShardingPointer with get
override ShardingPointer : ShardingPointer with get

Property Value

Type: ShardingPointer

Implements

IShardingPointerProvider ShardingPointer
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.State Property

Parcel State Property NFX Class Library

Returns the state of the parcel: Creating|Modifying|Sealed

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ParcelState State { get; }
public ParcelState State { get; }
Public ReadOnly Property State As ParcelState
    Get
Public ReadOnly Property State As ParcelState
    Get
public:
property ParcelState State {
    ParcelState get ();
}
public:
property ParcelState State {
    ParcelState get ();
}
member State : ParcelState with get
member State : ParcelState with get

Property Value

Type: ParcelState
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel.ValidationExceptions Property

Parcel ValidationExceptions Property NFX Class Library

Returns validation exceptions - populated by a call to Validate

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Exception> ValidationExceptions { get; }
public IEnumerable<Exception> ValidationExceptions { get; }
Public ReadOnly Property ValidationExceptions As IEnumerable(Of Exception)
    Get
Public ReadOnly Property ValidationExceptions As IEnumerable(Of Exception)
    Get
public:
property IEnumerable<Exception^>^ ValidationExceptions {
    IEnumerable<Exception^>^ get ();
}
public:
property IEnumerable<Exception^>^ ValidationExceptions {
    IEnumerable<Exception^>^ get ();
}
member ValidationExceptions : IEnumerable<Exception> with get
member ValidationExceptions : IEnumerable<Exception> with get

Property Value

Type: Online IEnumerable Online Exception
See Also
Parcel Class
Parcel Members
NFX.DataAccess.Distributed Namespace


Parcel(TPayload) Class

Parcel TPayload Class NFX Class Library

Describes a data parcel - a piece of logically-grouped data that gets fetched from/comitted into a distributed backend system. Parcels represent an atomic unit of change, a changeset that gets replicated between failover hosts. Every parcel has a Payload property that stores business data of interest that the parcel contains. This class is not thread-safe. This particular class serves as a very base for distributed data store implementations
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.DataAccess.Distributed Parcel
NFX.DataAccess.Distributed Parcel TPayload

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class Parcel<TPayload> : Parcel
where TPayload : class
[SerializableAttribute]
public abstract class Parcel<TPayload> : Parcel
where TPayload : class
<SerializableAttribute>
Public MustInherit Class Parcel(Of TPayload As Class)
    Inherits Parcel
<SerializableAttribute>
Public MustInherit Class Parcel(Of TPayload As Class)
    Inherits Parcel
[SerializableAttribute]
generic<typename TPayload>
where TPayload : ref class
public ref class Parcel abstract : public Parcel
[SerializableAttribute]
generic<typename TPayload>
where TPayload : ref class
public ref class Parcel abstract : public Parcel
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type Parcel<'TPayload when 'TPayload : not struct> =
    class
        inherit Parcel
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type Parcel<'TPayload when 'TPayload : not struct> =
    class
        inherit Parcel
    end
Type Parameters
TPayload
Type of payload that parcel carries
See Also
Parcel TPayload Members
NFX.DataAccess.Distributed Namespace


Parcel(TPayload) Members

Parcel TPayload Members NFX Class Library

The Parcel TPayload type exposes the following members.
Constructors
 | Name | Description
Protected method | Parcel TPayload | Used for serialization
Protected method | Parcel TPayload (TPayload) | This ctor is never public, used with __ctor__injectID
Protected method | Parcel TPayload (GDID, TPayload) | Initializes a new instance of the Parcel TPayload class
Protected method | Parcel TPayload (GDID, TPayload, IReplicationVersionInfo) | Initializes a new instance of the Parcel TPayload class
Back to Top
Methods
 | Name | Description
Protected method | __ctor__injectID | Internal framework method, developers: never call (Inherited from Parcel.)
Public method | DeepClone | Duplicates this parcel by doing a complete deep-clone of its state via serialization. This method is useful for making copies of the same parcel for different threads as it is thread-safe while no other thread mutates the instance, however Parcel instances are NOT THREAD-SAFE for parallel changes. The existing parcel MUST be SEALED (otherwise it can not be serialized). This method is also used before a call to Open() if parcel needs to be "un-opened" the cloned instance may be reverted to (Inherited from Parcel.)
Protected method | Destructor | Override this method to do actual destructor work (Inherited from DisposableObject.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoMerge | Override to merge other parcels into this one. Return true if merge changed the payload. See Merge(). This implementation throws an exception (Inherited from Parcel.)
Protected method | DoOpen | Override to perform actions when parcel is unsealed (opened) for modification (Inherited from Parcel.)
Protected method | DoSeal | Override to seal the parcel instance, i.e. generate some calculated fields. The version information is already generated by the time this method is called (Inherited from Parcel.)
Protected method | DoValidate | Override to perform parcel/payload validation after modification. Add validation exceptions into m_ValidationExceptions field. Use bank for cross-checks (i.e. may run queries to check consistency) (Inherited from Parcel.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Equals | Tests for parcel equality based on the same type and GDID value (Inherited from Parcel.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetDistributedStableHash | (Inherited from Parcel.)
Public method | GetHashCode | Generates hash code based on parcel type and GDID value (Inherited from Parcel.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Merge | Merges other parcel instances into this one. A parcel type may support merging (when DataParcel attribute SupportsMerge is set to true) of data from other parcels/versions into this instance. This parcel must not be sealed as merge may change the payload in which case TRUE is returned. The parcel needs to be sealed again after the change. If a call to this method returns false, then nothing was changed as this instance already contains the latest data/could not be merged. Merging is used for version conflict resolution: servers check if the type of the updated parcel instance SupportsMerge, then if it does, Opens parcel and calls this method passing other versions in question to this method. The framework does not impose a limit on the supplied parcel types, however most of the parcel types support merge only with the same-typed parcel instances. IMPORTANT: The ordering of parcel versions is not guaranteed. (Inherited from Parcel.)
Public method | Open | Opens parcel for modification. Parcel must be in the Sealed state for this call and must not be ReadOnly. Once open for modification, a parcel can not be "UnOpened", only Seal()-ed. This is because there is no way to track whether some part of payload object has changed by the calling code. Use DeepClone() before calling Open to retain a copy of Sealed parcel to revert to the cloned instance instead (Inherited from Parcel.)
Public method | Seal | Seal parcel after modification May call this method on parcels in either Creating or Modifying states. Bank is used to create the ReplicationVersionInfo which is depends on store/bank implementation. Parcels can replicate only within stores/technologies that have sealed them (Inherited from Parcel.)
Public method | ToString | (Inherited from Parcel.)
Public method | Validate | Performs validation of the data. Does not throw but populates validation exceptions if data is not valid. Bank context may be used to run sub-queries during consistency/crosschecks May call this method on parcels in either Creating or Modifying states (Inherited from Parcel.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_ValidationExceptions | (Inherited from Parcel.)
Back to Top
Properties
 | Name | Description
Public property | CacheAbsoluteExpirationUTC | Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a different absolute cache expiration UTC timestamp for this parcel that may depend on particular parcel payload state (i.e. field values). (Inherited from Parcel.)
Public property | CachePriority | Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a relative cache priority of this parcel that may depend on particular parcel payload state (i.e. field values). (Inherited from Parcel.)
Public property | CacheReadMaxAgeSec | Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a value for maximum validity span of cached parcel that may depend on particular parcel payload state (i.e. field values). This property may be used to obtain a value before parcel is re-read from the store (Inherited from Parcel.)
Public property | CacheWriteMaxAgeSec | Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a value for maximum length of this isntance stay in cache that may depend on particular parcel payload state (i.e. field values) (Inherited from Parcel.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EffectiveCachePolicy | Returns effective cache policy the one that is calculated from attribute and overidden by the instance (Inherited from Parcel.)
Public property | GDID | Returns GDID for data that this parcel represents (Inherited from Parcel.)
Public property | MetadataAttribute | Returns DataParcelAttribute that describes this parcel. Every parcel MUST be decorated by the DataParcel attribute (Inherited from Parcel.)
Public property | NewlySealed | Returns true when parcel was just sealed after a call to Open or .ctor/create. Datastore may check this flag and disallow saving of parcel instances that have not changed (Inherited from Parcel.)
Public property | Payload | Returns payload of this parcel. May be null for deleted parcels (VersionDeleted)
Public property | ReadOnly | Indicates whether the data may be altered. ReadOnly parcels can not be Opened after that have been Sealed by their creator (Inherited from Parcel.)
Public property | ReplicationPriority | Returns replication priority, override to make replication priority dependent on instance, i.e. a user profile data for a celebrity user may need to have higher replication rate. The lower value indicates the higher priority (Inherited from Parcel.)
Public property | ReplicationVersionInfo | Implements IReplicatable interface (Inherited from Parcel.)
Public property | ShardingID | Returns the ShardingID used for sharding, default implementation returns this parcel type and GDID. Override to return another sharding key, i.e. a social comment msg may use parent item (that the msg relates to) ID as the shard key so msgs are co-located with related items. Use CompositeShardingID to return multiple values. IMPORTANT!!! ShardingID must return an immutable value, the one that CAN NOT be changed during parcel payload life (Inherited from Parcel.)
Public property | ShardingPointer | Returns the ShardingPointer(type:ID) used for sharding, default implementation returns this parcel type and GDID. Override ShardingID property to return another sharding key, i.e. a social comment msg may use parent item (that the msg relates to) ID as the shard key so msgs are co-located with related items. Use CompositeShardingID to return multiple values. IMPORTANT!!! ShardingPointer must return an immutable value, the one that CAN NOT be changed during parcel payload life (Inherited from Parcel.)
Public property | State | Returns the state of the parcel: Creating|Modifying|Sealed (Inherited from Parcel.)
Public property | ValidationExceptions | Returns validation exceptions - populated by a call to Validate (Inherited from Parcel.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICachePolicy CacheTableName | Implements IParcelCachePolicy contract. The implementation returns null for parcel. (Inherited from Parcel.)
Back to Top
See Also
Parcel TPayload Class
NFX.DataAccess.Distributed Namespace


Parcel(TPayload) Constructor

Parcel TPayload Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | Parcel TPayload | Used for serialization
Protected method | Parcel TPayload (TPayload) | This ctor is never public, used with __ctor__injectID
Protected method | Parcel TPayload (GDID, TPayload) | Initializes a new instance of the Parcel TPayload class
Protected method | Parcel TPayload (GDID, TPayload, IReplicationVersionInfo) | Initializes a new instance of the Parcel TPayload class
Back to Top
See Also
Parcel TPayload Class
Parcel TPayload Members
NFX.DataAccess.Distributed Namespace


Parcel(TPayload) Constructor

Parcel TPayload Constructor NFX Class Library

Used for serialization

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Parcel()
protected Parcel()
Protected Sub New
Protected Sub New
protected:
Parcel()
protected:
Parcel()
new : unit -> Parcel
new : unit -> Parcel
See Also
Parcel TPayload Class
Parcel TPayload Members
Parcel TPayload Overload
NFX.DataAccess.Distributed Namespace


Parcel(TPayload) Constructor (TPayload)

Parcel TPayload Constructor (TPayload) NFX Class Library

This ctor is never public, used with __ctor__injectID

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Parcel(
    TPayload payload
)
protected Parcel(
    TPayload payload
)
Protected Sub New (
    payload As TPayload
)
Protected Sub New (
    payload As TPayload
)
protected:
Parcel(
    TPayload payload
)
protected:
Parcel(
    TPayload payload
)
new :
        payload : 'TPayload -> Parcel
new :
        payload : 'TPayload -> Parcel

Parameters

payload
Type: TPayload
See Also
Parcel TPayload Class
Parcel TPayload Members
Parcel TPayload Overload
NFX.DataAccess.Distributed Namespace


Parcel(TPayload) Constructor (GDID, TPayload)

Parcel TPayload Constructor (GDID, TPayload) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Parcel TPayload class

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Parcel(
    GDID id,
    TPayload payload
)
protected Parcel(
    GDID id,
    TPayload payload
)
Protected Sub New (
    id As GDID,
    payload As TPayload
)
Protected Sub New (
    id As GDID,
    payload As TPayload
)
protected:
Parcel(
    GDID id,
    TPayload payload
)
protected:
Parcel(
    GDID id,
    TPayload payload
)
new :
        id : GDID *
        payload : 'TPayload -> Parcel
new :
        id : GDID *
        payload : 'TPayload -> Parcel

Parameters

id
Type: NFX.DataAccess.Distributed GDID
payload
Type: TPayload
See Also
Parcel TPayload Class
Parcel TPayload Members
Parcel TPayload Overload
NFX.DataAccess.Distributed Namespace


Parcel(TPayload) Constructor (GDID, TPayload, IReplicationVersionInfo)

Parcel TPayload Constructor (GDID, TPayload, IReplicationVersionInfo) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Parcel TPayload class

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Parcel(
    GDID id,
    TPayload payload,
    IReplicationVersionInfo versInfo
)
protected Parcel(
    GDID id,
    TPayload payload,
    IReplicationVersionInfo versInfo
)
Protected Sub New (
    id As GDID,
    payload As TPayload,
    versInfo As IReplicationVersionInfo
)
Protected Sub New (
    id As GDID,
    payload As TPayload,
    versInfo As IReplicationVersionInfo
)
protected:
Parcel(
    GDID id,
    TPayload payload,
    IReplicationVersionInfo^ versInfo
)
protected:
Parcel(
    GDID id,
    TPayload payload,
    IReplicationVersionInfo^ versInfo
)
new :
        id : GDID *
        payload : 'TPayload *
        versInfo : IReplicationVersionInfo -> Parcel
new :
        id : GDID *
        payload : 'TPayload *
        versInfo : IReplicationVersionInfo -> Parcel

Parameters

id
Type: NFX.DataAccess.Distributed GDID
payload
Type: TPayload
versInfo
Type: NFX.DataAccess.Distributed IReplicationVersionInfo
See Also
Parcel TPayload Class
Parcel TPayload Members
Parcel TPayload Overload
NFX.DataAccess.Distributed Namespace


Parcel(TPayload) Fields

Parcel TPayload Fields NFX Class Library

The Parcel TPayload type exposes the following members.
Fields
 | Name | Description
Protected field | m_ValidationExceptions | (Inherited from Parcel.)
Back to Top
See Also
Parcel TPayload Class
NFX.DataAccess.Distributed Namespace


Parcel(TPayload) Methods

Parcel TPayload Methods NFX Class Library

The Parcel TPayload type exposes the following members.
Methods
 | Name | Description
Protected method | __ctor__injectID | Internal framework method, developers: never call (Inherited from Parcel.)
Public method | DeepClone | Duplicates this parcel by doing a complete deep-clone of its state via serialization. This method is useful for making copies of the same parcel for different threads as it is thread-safe while no other thread mutates the instance, however Parcel instances are NOT THREAD-SAFE for parallel changes. The existing parcel MUST be SEALED (otherwise it can not be serialized). This method is also used before a call to Open() if parcel needs to be "un-opened" the cloned instance may be reverted to (Inherited from Parcel.)
Protected method | Destructor | Override this method to do actual destructor work (Inherited from DisposableObject.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoMerge | Override to merge other parcels into this one. Return true if merge changed the payload. See Merge(). This implementation throws an exception (Inherited from Parcel.)
Protected method | DoOpen | Override to perform actions when parcel is unsealed (opened) for modification (Inherited from Parcel.)
Protected method | DoSeal | Override to seal the parcel instance, i.e. generate some calculated fields. The version information is already generated by the time this method is called (Inherited from Parcel.)
Protected method | DoValidate | Override to perform parcel/payload validation after modification. Add validation exceptions into m_ValidationExceptions field. Use bank for cross-checks (i.e. may run queries to check consistency) (Inherited from Parcel.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Equals | Tests for parcel equality based on the same type and GDID value (Inherited from Parcel.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetDistributedStableHash | (Inherited from Parcel.)
Public method | GetHashCode | Generates hash code based on parcel type and GDID value (Inherited from Parcel.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Merge | Merges other parcel instances into this one. A parcel type may support merging (when DataParcel attribute SupportsMerge is set to true) of data from other parcels/versions into this instance. This parcel must not be sealed as merge may change the payload in which case TRUE is returned. The parcel needs to be sealed again after the change. If a call to this method returns false, then nothing was changed as this instance already contains the latest data/could not be merged. Merging is used for version conflict resolution: servers check if the type of the updated parcel instance SupportsMerge, then if it does, Opens parcel and calls this method passing other versions in question to this method. The framework does not impose a limit on the supplied parcel types, however most of the parcel types support merge only with the same-typed parcel instances. IMPORTANT: The ordering of parcel versions is not guaranteed. (Inherited from Parcel.)
Public method | Open | Opens parcel for modification. Parcel must be in the Sealed state for this call and must not be ReadOnly. Once open for modification, a parcel can not be "UnOpened", only Seal()-ed. This is because there is no way to track whether some part of payload object has changed by the calling code. Use DeepClone() before calling Open to retain a copy of Sealed parcel to revert to the cloned instance instead (Inherited from Parcel.)
Public method | Seal | Seal parcel after modification May call this method on parcels in either Creating or Modifying states. Bank is used to create the ReplicationVersionInfo which is depends on store/bank implementation. Parcels can replicate only within stores/technologies that have sealed them (Inherited from Parcel.)
Public method | ToString | (Inherited from Parcel.)
Public method | Validate | Performs validation of the data. Does not throw but populates validation exceptions if data is not valid. Bank context may be used to run sub-queries during consistency/crosschecks May call this method on parcels in either Creating or Modifying states (Inherited from Parcel.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Parcel TPayload Class
NFX.DataAccess.Distributed Namespace


Parcel(TPayload) Properties

Parcel TPayload Properties NFX Class Library

The Parcel TPayload type exposes the following members.
Properties
 | Name | Description
Public property | CacheAbsoluteExpirationUTC | Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a different absolute cache expiration UTC timestamp for this parcel that may depend on particular parcel payload state (i.e. field values). (Inherited from Parcel.)
Public property | CachePriority | Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a relative cache priority of this parcel that may depend on particular parcel payload state (i.e. field values). (Inherited from Parcel.)
Public property | CacheReadMaxAgeSec | Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a value for maximum validity span of cached parcel that may depend on particular parcel payload state (i.e. field values). This property may be used to obtain a value before parcel is re-read from the store (Inherited from Parcel.)
Public property | CacheWriteMaxAgeSec | Implements IParcelCachePolicy contract. The default implementation returns null. Override to supply a value for maximum length of this isntance stay in cache that may depend on particular parcel payload state (i.e. field values) (Inherited from Parcel.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EffectiveCachePolicy | Returns effective cache policy the one that is calculated from attribute and overidden by the instance (Inherited from Parcel.)
Public property | GDID | Returns GDID for data that this parcel represents (Inherited from Parcel.)
Public property | MetadataAttribute | Returns DataParcelAttribute that describes this parcel. Every parcel MUST be decorated by the DataParcel attribute (Inherited from Parcel.)
Public property | NewlySealed | Returns true when parcel was just sealed after a call to Open or .ctor/create. Datastore may check this flag and disallow saving of parcel instances that have not changed (Inherited from Parcel.)
Public property | Payload | Returns payload of this parcel. May be null for deleted parcels (VersionDeleted)
Public property | ReadOnly | Indicates whether the data may be altered. ReadOnly parcels can not be Opened after that have been Sealed by their creator (Inherited from Parcel.)
Public property | ReplicationPriority | Returns replication priority, override to make replication priority dependent on instance, i.e. a user profile data for a celebrity user may need to have higher replication rate. The lower value indicates the higher priority (Inherited from Parcel.)
Public property | ReplicationVersionInfo | Implements IReplicatable interface (Inherited from Parcel.)
Public property | ShardingID | Returns the ShardingID used for sharding, default implementation returns this parcel type and GDID. Override to return another sharding key, i.e. a social comment msg may use parent item (that the msg relates to) ID as the shard key so msgs are co-located with related items. Use CompositeShardingID to return multiple values. IMPORTANT!!! ShardingID must return an immutable value, the one that CAN NOT be changed during parcel payload life (Inherited from Parcel.)
Public property | ShardingPointer | Returns the ShardingPointer(type:ID) used for sharding, default implementation returns this parcel type and GDID. Override ShardingID property to return another sharding key, i.e. a social comment msg may use parent item (that the msg relates to) ID as the shard key so msgs are co-located with related items. Use CompositeShardingID to return multiple values. IMPORTANT!!! ShardingPointer must return an immutable value, the one that CAN NOT be changed during parcel payload life (Inherited from Parcel.)
Public property | State | Returns the state of the parcel: Creating|Modifying|Sealed (Inherited from Parcel.)
Public property | ValidationExceptions | Returns validation exceptions - populated by a call to Validate (Inherited from Parcel.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICachePolicy CacheTableName | Implements IParcelCachePolicy contract. The implementation returns null for parcel. (Inherited from Parcel.)
Back to Top
See Also
Parcel TPayload Class
NFX.DataAccess.Distributed Namespace


Parcel(TPayload).Payload Property

Parcel TPayload Payload Property NFX Class Library

Returns payload of this parcel. May be null for deleted parcels (VersionDeleted)

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TPayload Payload { get; }
public TPayload Payload { get; }
Public ReadOnly Property Payload As TPayload
    Get
Public ReadOnly Property Payload As TPayload
    Get
public:
property TPayload Payload {
    TPayload get ();
}
public:
property TPayload Payload {
    TPayload get ();
}
member Payload : 'TPayload with get
member Payload : 'TPayload with get

Property Value

Type: TPayload
See Also
Parcel TPayload Class
Parcel TPayload Members
NFX.DataAccess.Distributed Namespace


ParcelSealValidationException Class

ParcelSealValidationException Class NFX Class Library

Thrown by Parcel.Seal() method trying to ensure parcel consistency before it gets sealed
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.DataAccess DataAccessException
NFX.DataAccess.Distributed DistributedDataAccessException
NFX.DataAccess.Distributed ParcelValidationException
NFX.DataAccess.Distributed ParcelSealValidationException

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ParcelSealValidationException : ParcelValidationException
[SerializableAttribute]
public class ParcelSealValidationException : ParcelValidationException
<SerializableAttribute>
Public Class ParcelSealValidationException
    Inherits ParcelValidationException
<SerializableAttribute>
Public Class ParcelSealValidationException
    Inherits ParcelValidationException
[SerializableAttribute]
public ref class ParcelSealValidationException : public ParcelValidationException
[SerializableAttribute]
public ref class ParcelSealValidationException : public ParcelValidationException
[<SerializableAttribute>]
type ParcelSealValidationException =
    class
        inherit ParcelValidationException
    end
[<SerializableAttribute>]
type ParcelSealValidationException =
    class
        inherit ParcelValidationException
    end
See Also
ParcelSealValidationException Members
NFX.DataAccess.Distributed Namespace


ParcelSealValidationException Members

ParcelSealValidationException Members NFX Class Library

The ParcelSealValidationException type exposes the following members.
Constructors
 | Name | Description
Protected method | ParcelSealValidationException | Initializes a new instance of the ParcelSealValidationException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | ForErrors |
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ParcelSealValidationException Class
NFX.DataAccess.Distributed Namespace


ParcelSealValidationException Constructor

ParcelSealValidationException Constructor NFX Class Library

Initializes a new instance of the ParcelSealValidationException class

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ParcelSealValidationException(
    SerializationInfo info,
    StreamingContext context
)
protected ParcelSealValidationException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
ParcelSealValidationException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
ParcelSealValidationException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ParcelSealValidationException
new :
        info : SerializationInfo *
        context : StreamingContext -> ParcelSealValidationException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
ParcelSealValidationException Class
ParcelSealValidationException Members
NFX.DataAccess.Distributed Namespace


ParcelSealValidationException Fields

ParcelSealValidationException Fields NFX Class Library

The ParcelSealValidationException type exposes the following members.
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
See Also
ParcelSealValidationException Class
NFX.DataAccess.Distributed Namespace


ParcelSealValidationException Methods

ParcelSealValidationException Methods NFX Class Library

The ParcelSealValidationException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | ForErrors |
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
ParcelSealValidationException Class
NFX.DataAccess.Distributed Namespace


ParcelSealValidationException.ForErrors Method

ParcelSealValidationException ForErrors Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ParcelSealValidationException ForErrors(
    string parcelName,
    IEnumerable<Exception> errors
)
public static ParcelSealValidationException ForErrors(
    string parcelName,
    IEnumerable<Exception> errors
)
Public Shared Function ForErrors (
    parcelName As String,
    errors As IEnumerable(Of Exception)
) As ParcelSealValidationException
Public Shared Function ForErrors (
    parcelName As String,
    errors As IEnumerable(Of Exception)
) As ParcelSealValidationException
public:
static ParcelSealValidationException^ ForErrors(
    String^ parcelName,
    IEnumerable<Exception^>^ errors
)
public:
static ParcelSealValidationException^ ForErrors(
    String^ parcelName,
    IEnumerable<Exception^>^ errors
)
static member ForErrors :
        parcelName : string *
        errors : IEnumerable<Exception> -> ParcelSealValidationException
static member ForErrors :
        parcelName : string *
        errors : IEnumerable<Exception> -> ParcelSealValidationException

Parameters

parcelName
Type: Online System String
errors
Type: Online System.Collections.Generic IEnumerable Online Exception

Return Value

Type: ParcelSealValidationException
See Also
ParcelSealValidationException Class
ParcelSealValidationException Members
NFX.DataAccess.Distributed Namespace


ParcelSealValidationException Properties

ParcelSealValidationException Properties NFX Class Library

The ParcelSealValidationException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
ParcelSealValidationException Class
NFX.DataAccess.Distributed Namespace


ParcelSealValidationException Events

ParcelSealValidationException Events NFX Class Library

The ParcelSealValidationException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ParcelSealValidationException Class
NFX.DataAccess.Distributed Namespace


ParcelState Enumeration

ParcelState Enumeration NFX Class Library

Represents data parcel states - creating, modifying, sealed

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum ParcelState
public enum ParcelState
Public Enumeration ParcelState
Public Enumeration ParcelState
public enum class ParcelState
public enum class ParcelState
type ParcelState
type ParcelState
Members
Member name | Value | Description
Sealed | 0 |
Creating | 1 |
Modifying | 2 |
See Also
NFX.DataAccess.Distributed Namespace


ParcelValidationException Class

ParcelValidationException Class NFX Class Library

Thrown by distributed data access classes to indicate some data validation error
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.DataAccess DataAccessException
NFX.DataAccess.Distributed DistributedDataAccessException
NFX.DataAccess.Distributed ParcelValidationException
NFX.DataAccess.Distributed ParcelSealValidationException

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ParcelValidationException : DistributedDataAccessException
[SerializableAttribute]
public class ParcelValidationException : DistributedDataAccessException
<SerializableAttribute>
Public Class ParcelValidationException
    Inherits DistributedDataAccessException
<SerializableAttribute>
Public Class ParcelValidationException
    Inherits DistributedDataAccessException
[SerializableAttribute]
public ref class ParcelValidationException : public DistributedDataAccessException
[SerializableAttribute]
public ref class ParcelValidationException : public DistributedDataAccessException
[<SerializableAttribute>]
type ParcelValidationException =
    class
        inherit DistributedDataAccessException
    end
[<SerializableAttribute>]
type ParcelValidationException =
    class
        inherit DistributedDataAccessException
    end
See Also
ParcelValidationException Members
NFX.DataAccess.Distributed Namespace


ParcelValidationException Members

ParcelValidationException Members NFX Class Library

The ParcelValidationException type exposes the following members.
Constructors
 | Name | Description
Public method | ParcelValidationException | Initializes a new instance of the ParcelValidationException class
Public method | ParcelValidationException(String) | Initializes a new instance of the ParcelValidationException class
Protected method | ParcelValidationException(SerializationInfo, StreamingContext) | Initializes a new instance of the ParcelValidationException class
Public method | ParcelValidationException(String, Exception) | Initializes a new instance of the ParcelValidationException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ParcelValidationException Class
NFX.DataAccess.Distributed Namespace


ParcelValidationException Constructor

ParcelValidationException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ParcelValidationException | Initializes a new instance of the ParcelValidationException class
Public method | ParcelValidationException(String) | Initializes a new instance of the ParcelValidationException class
Protected method | ParcelValidationException(SerializationInfo, StreamingContext) | Initializes a new instance of the ParcelValidationException class
Public method | ParcelValidationException(String, Exception) | Initializes a new instance of the ParcelValidationException class
Back to Top
See Also
ParcelValidationException Class
ParcelValidationException Members
NFX.DataAccess.Distributed Namespace


ParcelValidationException Constructor

ParcelValidationException Constructor NFX Class Library

Initializes a new instance of the ParcelValidationException class

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ParcelValidationException()
public ParcelValidationException()
Public Sub New
Public Sub New
public:
ParcelValidationException()
public:
ParcelValidationException()
new : unit -> ParcelValidationException
new : unit -> ParcelValidationException
See Also
ParcelValidationException Class
ParcelValidationException Members
ParcelValidationException Overload
NFX.DataAccess.Distributed Namespace


ParcelValidationException Constructor (String)

ParcelValidationException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ParcelValidationException class

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ParcelValidationException(
    string message
)
public ParcelValidationException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
ParcelValidationException(
    String^ message
)
public:
ParcelValidationException(
    String^ message
)
new :
        message : string -> ParcelValidationException
new :
        message : string -> ParcelValidationException

Parameters

message
Type: Online System String
See Also
ParcelValidationException Class
ParcelValidationException Members
ParcelValidationException Overload
NFX.DataAccess.Distributed Namespace


ParcelValidationException Constructor (SerializationInfo, StreamingContext)

ParcelValidationException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ParcelValidationException class

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ParcelValidationException(
    SerializationInfo info,
    StreamingContext context
)
protected ParcelValidationException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
ParcelValidationException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
ParcelValidationException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ParcelValidationException
new :
        info : SerializationInfo *
        context : StreamingContext -> ParcelValidationException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
ParcelValidationException Class
ParcelValidationException Members
ParcelValidationException Overload
NFX.DataAccess.Distributed Namespace


ParcelValidationException Constructor (String, Exception)

ParcelValidationException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ParcelValidationException class

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ParcelValidationException(
    string message,
    Exception inner
)
public ParcelValidationException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
ParcelValidationException(
    String^ message,
    Exception^ inner
)
public:
ParcelValidationException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> ParcelValidationException
new :
        message : string *
        inner : Exception -> ParcelValidationException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
ParcelValidationException Class
ParcelValidationException Members
ParcelValidationException Overload
NFX.DataAccess.Distributed Namespace


ParcelValidationException Fields

ParcelValidationException Fields NFX Class Library

The ParcelValidationException type exposes the following members.
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
See Also
ParcelValidationException Class
NFX.DataAccess.Distributed Namespace


ParcelValidationException Methods

ParcelValidationException Methods NFX Class Library

The ParcelValidationException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
ParcelValidationException Class
NFX.DataAccess.Distributed Namespace


ParcelValidationException Properties

ParcelValidationException Properties NFX Class Library

The ParcelValidationException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
ParcelValidationException Class
NFX.DataAccess.Distributed Namespace


ParcelValidationException Events

ParcelValidationException Events NFX Class Library

The ParcelValidationException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ParcelValidationException Class
NFX.DataAccess.Distributed Namespace


ShardingPointer Structure

ShardingPointer Structure NFX Class Library

Contains information about sharding parcel type and ID which is used to calculate the physical location of parcel data

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct ShardingPointer
public struct ShardingPointer
Public Structure ShardingPointer
Public Structure ShardingPointer
public value class ShardingPointer
public value class ShardingPointer
[<SealedAttribute>]
type ShardingPointer =  struct end
[<SealedAttribute>]
type ShardingPointer =  struct end
See Also
ShardingPointer Members
NFX.DataAccess.Distributed Namespace


ShardingPointer Members

ShardingPointer Members NFX Class Library

The ShardingPointer type exposes the following members.
Constructors
 | Name | Description
Public method | ShardingPointer | Initializes a new instance of the ShardingPointer class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | ID |
Public field | ParcelType |
Back to Top
Properties
 | Name | Description
Public property | IsAssigned |
Back to Top
See Also
ShardingPointer Structure
NFX.DataAccess.Distributed Namespace


ShardingPointer Constructor

ShardingPointer Constructor NFX Class Library

Initializes a new instance of the ShardingPointer class

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ShardingPointer(
    Type tParcel,
    Object id
)
public ShardingPointer(
    Type tParcel,
    Object id
)
Public Sub New (
    tParcel As Type,
    id As Object
)
Public Sub New (
    tParcel As Type,
    id As Object
)
public:
ShardingPointer(
    Type^ tParcel,
    Object^ id
)
public:
ShardingPointer(
    Type^ tParcel,
    Object^ id
)
new :
        tParcel : Type *
        id : Object -> ShardingPointer
new :
        tParcel : Type *
        id : Object -> ShardingPointer

Parameters

tParcel
Type: Online System Type
id
Type: Online System Object
See Also
ShardingPointer Structure
ShardingPointer Members
NFX.DataAccess.Distributed Namespace


ShardingPointer Fields

ShardingPointer Fields NFX Class Library

The ShardingPointer type exposes the following members.
Fields
 | Name | Description
Public field | ID |
Public field | ParcelType |
Back to Top
See Also
ShardingPointer Structure
NFX.DataAccess.Distributed Namespace


ShardingPointer.ID Field

ShardingPointer ID Field NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Object ID
public readonly Object ID
Public ReadOnly ID As Object
Public ReadOnly ID As Object
public:
initonly Object^ ID
public:
initonly Object^ ID
val ID: Object
val ID: Object

Field Value

Type: Online Object
See Also
ShardingPointer Structure
ShardingPointer Members
NFX.DataAccess.Distributed Namespace


ShardingPointer.ParcelType Field

ShardingPointer ParcelType Field NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Type ParcelType
public readonly Type ParcelType
Public ReadOnly ParcelType As Type
Public ReadOnly ParcelType As Type
public:
initonly Type^ ParcelType
public:
initonly Type^ ParcelType
val ParcelType: Type
val ParcelType: Type

Field Value

Type: Online Type
See Also
ShardingPointer Structure
ShardingPointer Members
NFX.DataAccess.Distributed Namespace


ShardingPointer Methods

ShardingPointer Methods NFX Class Library

The ShardingPointer type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ShardingPointer Structure
NFX.DataAccess.Distributed Namespace


ShardingPointer.ToString Method

ShardingPointer ToString Method NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
ShardingPointer Structure
ShardingPointer Members
NFX.DataAccess.Distributed Namespace


ShardingPointer Properties

ShardingPointer Properties NFX Class Library

The ShardingPointer type exposes the following members.
Properties
 | Name | Description
Public property | IsAssigned |
Back to Top
See Also
ShardingPointer Structure
NFX.DataAccess.Distributed Namespace


ShardingPointer.IsAssigned Property

ShardingPointer IsAssigned Property NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsAssigned { get; }
public bool IsAssigned { get; }
Public ReadOnly Property IsAssigned As Boolean
    Get
Public ReadOnly Property IsAssigned As Boolean
    Get
public:
property bool IsAssigned {
    bool get ();
}
public:
property bool IsAssigned {
    bool get ();
}
member IsAssigned : bool with get
member IsAssigned : bool with get

Property Value

Type: Online Boolean
See Also
ShardingPointer Structure
ShardingPointer Members
NFX.DataAccess.Distributed Namespace


TargetTableMapping Structure

TargetTableMapping Structure NFX Class Library

Provides information about targetname->table name, sequence name(and possibly other) mappings

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct TargetTableMapping : INamed
public struct TargetTableMapping : INamed
Public Structure TargetTableMapping
    Implements INamed
Public Structure TargetTableMapping
    Implements INamed
public value class TargetTableMapping : INamed
public value class TargetTableMapping : INamed
[<SealedAttribute>]
type TargetTableMapping =
    struct
        interface INamed
    end
[<SealedAttribute>]
type TargetTableMapping =
    struct
        interface INamed
    end
See Also
TargetTableMapping Members
NFX.DataAccess.Distributed Namespace


TargetTableMapping Members

TargetTableMapping Members NFX Class Library

The TargetTableMapping type exposes the following members.
Constructors
 | Name | Description
Public method | TargetTableMapping | Initializes a new instance of the TargetTableMapping class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_GDID_SEQUENCE_NAME_ATTR |
Back to Top
Properties
 | Name | Description
Public property | GDIDSequenceName |
Public property | Name |
Public property | TableName |
Back to Top
See Also
TargetTableMapping Structure
NFX.DataAccess.Distributed Namespace


TargetTableMapping Constructor

TargetTableMapping Constructor NFX Class Library

Initializes a new instance of the TargetTableMapping class

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TargetTableMapping(
    IConfigSectionNode node
)
public TargetTableMapping(
    IConfigSectionNode node
)
Public Sub New (
    node As IConfigSectionNode
)
Public Sub New (
    node As IConfigSectionNode
)
public:
TargetTableMapping(
    IConfigSectionNode^ node
)
public:
TargetTableMapping(
    IConfigSectionNode^ node
)
new :
        node : IConfigSectionNode -> TargetTableMapping
new :
        node : IConfigSectionNode -> TargetTableMapping

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
TargetTableMapping Structure
TargetTableMapping Members
NFX.DataAccess.Distributed Namespace


TargetTableMapping Fields

TargetTableMapping Fields NFX Class Library

The TargetTableMapping type exposes the following members.
Fields
Name | Description
CONFIG_GDID_SEQUENCE_NAME_ATTR |
Back to Top
See Also
TargetTableMapping Structure
NFX.DataAccess.Distributed Namespace


TargetTableMapping.CONFIG_GDID_SEQUENCE_NAME_ATTR Field

TargetTableMapping CONFIG_GDID_SEQUENCE_NAME_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_GDID_SEQUENCE_NAME_ATTR
public const string CONFIG_GDID_SEQUENCE_NAME_ATTR
Public Const CONFIG_GDID_SEQUENCE_NAME_ATTR As String
Public Const CONFIG_GDID_SEQUENCE_NAME_ATTR As String
public:
literal String^ CONFIG_GDID_SEQUENCE_NAME_ATTR
public:
literal String^ CONFIG_GDID_SEQUENCE_NAME_ATTR
static val mutable CONFIG_GDID_SEQUENCE_NAME_ATTR: string
static val mutable CONFIG_GDID_SEQUENCE_NAME_ATTR: string

Field Value

Type: Online String
See Also
TargetTableMapping Structure
TargetTableMapping Members
NFX.DataAccess.Distributed Namespace


TargetTableMapping Methods

TargetTableMapping Methods NFX Class Library

The TargetTableMapping type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TargetTableMapping Structure
NFX.DataAccess.Distributed Namespace


TargetTableMapping Properties

TargetTableMapping Properties NFX Class Library

The TargetTableMapping type exposes the following members.
Properties
 | Name | Description
Public property | GDIDSequenceName |
Public property | Name |
Public property | TableName |
Back to Top
See Also
TargetTableMapping Structure
NFX.DataAccess.Distributed Namespace


TargetTableMapping.GDIDSequenceName Property

TargetTableMapping GDIDSequenceName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GDIDSequenceName { get; }
public string GDIDSequenceName { get; }
Public ReadOnly Property GDIDSequenceName As String
    Get
Public ReadOnly Property GDIDSequenceName As String
    Get
public:
property String^ GDIDSequenceName {
    String^ get ();
}
public:
property String^ GDIDSequenceName {
    String^ get ();
}
member GDIDSequenceName : string with get
member GDIDSequenceName : string with get

Property Value

Type: Online String
See Also
TargetTableMapping Structure
TargetTableMapping Members
NFX.DataAccess.Distributed Namespace


TargetTableMapping.Name Property

TargetTableMapping Name Property NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
TargetTableMapping Structure
TargetTableMapping Members
NFX.DataAccess.Distributed Namespace


TargetTableMapping.TableName Property

TargetTableMapping TableName Property NFX Class Library

Namespace: NFX.DataAccess.Distributed
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string TableName { get; }
public string TableName { get; }
Public ReadOnly Property TableName As String
    Get
Public ReadOnly Property TableName As String
    Get
public:
property String^ TableName {
    String^ get ();
}
public:
property String^ TableName {
    String^ get ();
}
member TableName : string with get
member TableName : string with get

Property Value

Type: Online String
See Also
TargetTableMapping Structure
TargetTableMapping Members
NFX.DataAccess.Distributed Namespace


NFX.DataAccess.Erlang Namespace

NFX.DataAccess.Erlang Namespace NFX Class Library

Classes
 | Class | Description
Public class | ErlCRUDMailbox | Implements mailboxes that receive data from Erlang CRUD data stores
Public class | ErlCRUDScriptQueryHandler | Executes Erlang CRUD script-based queries
Public class | ErlCRUDSubscription | Implements subscriptions to Erlang CRUD data stores
Public class | ErlDataAccessException | Thrown by Erlang data access classes
Public class | ErlDataStore | Represents a CRUD data store that uses Erlang backend
Public class | ErlServerSchemaChangedException | Thrown by Erlang data schema map when server has changed schema. The client needs to restart or kill all cached data and refetch schema
Public class | SchemaMap | Maps Erlang schemas -> CRUD and CRUD -> Erlang
Structures
 | Structure | Description
Public structure | ErlCRUDQueryExecutionContext | Provides query execution environment in Erlang context


ErlCRUDMailbox Class

ErlCRUDMailbox Class NFX Class Library

Implements mailboxes that receive data from Erlang CRUD data stores
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.DataAccess.CRUD.Subscriptions SubscriptionAppComponent
NFX.DataAccess.CRUD.Subscriptions Mailbox
NFX.DataAccess.Erlang ErlCRUDMailbox

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ErlCRUDMailbox : Mailbox
public class ErlCRUDMailbox : Mailbox
Public Class ErlCRUDMailbox
    Inherits Mailbox
Public Class ErlCRUDMailbox
    Inherits Mailbox
public ref class ErlCRUDMailbox : public Mailbox
public ref class ErlCRUDMailbox : public Mailbox
type ErlCRUDMailbox =
    class
        inherit Mailbox
    end
type ErlCRUDMailbox =
    class
        inherit Mailbox
    end
See Also
ErlCRUDMailbox Members
NFX.DataAccess.Erlang Namespace


ErlCRUDMailbox Members

ErlCRUDMailbox Members NFX Class Library

The ErlCRUDMailbox type exposes the following members.
Constructors
 | Name | Description
Protected method | ErlCRUDMailbox | Initializes a new instance of the ErlCRUDMailbox class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | Deliver | Delivers data to the mailbox. This method is called by subscription (Inherited from Mailbox.)
Public method | DeliverError | (Inherited from Mailbox.)
Protected method | Destructor | (Inherited from Mailbox.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from SubscriptionAppComponent.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from SubscriptionAppComponent.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from SubscriptionAppComponent.)
Public method | FetchBuffered | Tries to take the specified number of samples in chronological order (Inherited from Mailbox.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnReceipt | (Inherited from Mailbox.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | BufferCapacity | (Inherited from Mailbox.)
Public property | Buffered | Returns all buffered data in chronological order (Inherited from Mailbox.)
Public property | BufferedCount | Returns how much is currently buffered (Inherited from Mailbox.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from SubscriptionAppComponent.)
Public property | Name | (Inherited from Mailbox.)
Public property | Store | (Inherited from Mailbox.)
Public property | Subscriptions | (Inherited from Mailbox.)
Back to Top
Events
 | Name | Description
Public event | Receipt | (Inherited from Mailbox.)
Back to Top
See Also
ErlCRUDMailbox Class
NFX.DataAccess.Erlang Namespace


ErlCRUDMailbox Constructor

ErlCRUDMailbox Constructor NFX Class Library

Initializes a new instance of the ErlCRUDMailbox class

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ErlCRUDMailbox(
    ErlDataStore store,
    string name
)
internal ErlCRUDMailbox(
    ErlDataStore store,
    string name
)
Friend Sub New (
    store As ErlDataStore,
    name As String
)
Friend Sub New (
    store As ErlDataStore,
    name As String
)
internal:
ErlCRUDMailbox(
    ErlDataStore^ store,
    String^ name
)
internal:
ErlCRUDMailbox(
    ErlDataStore^ store,
    String^ name
)
new :
        store : ErlDataStore *
        name : string -> ErlCRUDMailbox
new :
        store : ErlDataStore *
        name : string -> ErlCRUDMailbox

Parameters

store
Type: NFX.DataAccess.Erlang ErlDataStore
name
Type: Online System String
See Also
ErlCRUDMailbox Class
ErlCRUDMailbox Members
NFX.DataAccess.Erlang Namespace


ErlCRUDMailbox Methods

ErlCRUDMailbox Methods NFX Class Library

The ErlCRUDMailbox type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | Deliver | Delivers data to the mailbox. This method is called by subscription (Inherited from Mailbox.)
Public method | DeliverError | (Inherited from Mailbox.)
Protected method | Destructor | (Inherited from Mailbox.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from SubscriptionAppComponent.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from SubscriptionAppComponent.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from SubscriptionAppComponent.)
Public method | FetchBuffered | Tries to take the specified number of samples in chronological order (Inherited from Mailbox.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnReceipt | (Inherited from Mailbox.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ErlCRUDMailbox Class
NFX.DataAccess.Erlang Namespace


ErlCRUDMailbox Properties

ErlCRUDMailbox Properties NFX Class Library

The ErlCRUDMailbox type exposes the following members.
Properties
 | Name | Description
Public property | BufferCapacity | (Inherited from Mailbox.)
Public property | Buffered | Returns all buffered data in chronological order (Inherited from Mailbox.)
Public property | BufferedCount | Returns how much is currently buffered (Inherited from Mailbox.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from SubscriptionAppComponent.)
Public property | Name | (Inherited from Mailbox.)
Public property | Store | (Inherited from Mailbox.)
Public property | Subscriptions | (Inherited from Mailbox.)
Back to Top
See Also
ErlCRUDMailbox Class
NFX.DataAccess.Erlang Namespace


ErlCRUDMailbox Events

ErlCRUDMailbox Events NFX Class Library

The ErlCRUDMailbox type exposes the following members.
Events
 | Name | Description
Public event | Receipt | (Inherited from Mailbox.)
Back to Top
See Also
ErlCRUDMailbox Class
NFX.DataAccess.Erlang Namespace


ErlCRUDQueryExecutionContext Structure

ErlCRUDQueryExecutionContext Structure NFX Class Library

Provides query execution environment in Erlang context

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct ErlCRUDQueryExecutionContext : ICRUDQueryExecutionContext
public struct ErlCRUDQueryExecutionContext : ICRUDQueryExecutionContext
Public Structure ErlCRUDQueryExecutionContext
    Implements ICRUDQueryExecutionContext
Public Structure ErlCRUDQueryExecutionContext
    Implements ICRUDQueryExecutionContext
public value class ErlCRUDQueryExecutionContext : ICRUDQueryExecutionContext
public value class ErlCRUDQueryExecutionContext : ICRUDQueryExecutionContext
[<SealedAttribute>]
type ErlCRUDQueryExecutionContext =
    struct
        interface ICRUDQueryExecutionContext
    end
[<SealedAttribute>]
type ErlCRUDQueryExecutionContext =
    struct
        interface ICRUDQueryExecutionContext
    end
See Also
ErlCRUDQueryExecutionContext Members
NFX.DataAccess.Erlang Namespace


ErlCRUDQueryExecutionContext Members

ErlCRUDQueryExecutionContext Members NFX Class Library

The ErlCRUDQueryExecutionContext type exposes the following members.
Constructors
 | Name | Description
Public method | ErlCRUDQueryExecutionContext | Initializes a new instance of the ErlCRUDQueryExecutionContext class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | DataStore |
Public field | ErlMailBox |
Public field | SubscriptionTimestamp |
Back to Top
See Also
ErlCRUDQueryExecutionContext Structure
NFX.DataAccess.Erlang Namespace


ErlCRUDQueryExecutionContext Constructor

ErlCRUDQueryExecutionContext Constructor NFX Class Library

Initializes a new instance of the ErlCRUDQueryExecutionContext class

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlCRUDQueryExecutionContext(
    ErlDataStore store,
    ErlMbox erlMBox = null,
    Nullable<DataTimeStamp> ts = null
)
public ErlCRUDQueryExecutionContext(
    ErlDataStore store,
    ErlMbox erlMBox = null,
    Nullable<DataTimeStamp> ts = null
)
Public Sub New (
    store As ErlDataStore,
    Optional erlMBox As ErlMbox = Nothing,
    Optional ts As Nullable(Of DataTimeStamp) = Nothing
)
Public Sub New (
    store As ErlDataStore,
    Optional erlMBox As ErlMbox = Nothing,
    Optional ts As Nullable(Of DataTimeStamp) = Nothing
)
public:
ErlCRUDQueryExecutionContext(
    ErlDataStore^ store,
    ErlMbox^ erlMBox = nullptr,
    Nullable<DataTimeStamp> ts = nullptr
)
public:
ErlCRUDQueryExecutionContext(
    ErlDataStore^ store,
    ErlMbox^ erlMBox = nullptr,
    Nullable<DataTimeStamp> ts = nullptr
)
new :
        store : ErlDataStore *
        ?erlMBox : ErlMbox *
        ?ts : Nullable<DataTimeStamp>
(* Defaults:
        let _erlMBox = defaultArg erlMBox null
        let _ts = defaultArg ts null
*)
-> ErlCRUDQueryExecutionContext
new :
        store : ErlDataStore *
        ?erlMBox : ErlMbox *
        ?ts : Nullable<DataTimeStamp>
(* Defaults:
        let _erlMBox = defaultArg erlMBox null
        let _ts = defaultArg ts null
*)
-> ErlCRUDQueryExecutionContext

Parameters

store
Type: NFX.DataAccess.Erlang ErlDataStore
erlMBox (Optional)
Type: NFX.Erlang ErlMbox
ts (Optional)
Type: Online System Nullable DataTimeStamp
See Also
ErlCRUDQueryExecutionContext Structure
ErlCRUDQueryExecutionContext Members
NFX.DataAccess.Erlang Namespace


ErlCRUDQueryExecutionContext Fields

ErlCRUDQueryExecutionContext Fields NFX Class Library

The ErlCRUDQueryExecutionContext type exposes the following members.
Fields
 | Name | Description
Public field | DataStore |
Public field | ErlMailBox |
Public field | SubscriptionTimestamp |
Back to Top
See Also
ErlCRUDQueryExecutionContext Structure
NFX.DataAccess.Erlang Namespace


ErlCRUDQueryExecutionContext.DataStore Field

ErlCRUDQueryExecutionContext DataStore Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ErlDataStore DataStore
public readonly ErlDataStore DataStore
Public ReadOnly DataStore As ErlDataStore
Public ReadOnly DataStore As ErlDataStore
public:
initonly ErlDataStore^ DataStore
public:
initonly ErlDataStore^ DataStore
val DataStore: ErlDataStore
val DataStore: ErlDataStore

Field Value

Type: ErlDataStore
See Also
ErlCRUDQueryExecutionContext Structure
ErlCRUDQueryExecutionContext Members
NFX.DataAccess.Erlang Namespace


ErlCRUDQueryExecutionContext.ErlMailBox Field

ErlCRUDQueryExecutionContext ErlMailBox Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ErlMbox ErlMailBox
public readonly ErlMbox ErlMailBox
Public ReadOnly ErlMailBox As ErlMbox
Public ReadOnly ErlMailBox As ErlMbox
public:
initonly ErlMbox^ ErlMailBox
public:
initonly ErlMbox^ ErlMailBox
val ErlMailBox: ErlMbox
val ErlMailBox: ErlMbox

Field Value

Type: ErlMbox
See Also
ErlCRUDQueryExecutionContext Structure
ErlCRUDQueryExecutionContext Members
NFX.DataAccess.Erlang Namespace


ErlCRUDQueryExecutionContext.SubscriptionTimestamp Field

ErlCRUDQueryExecutionContext SubscriptionTimestamp Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Nullable<DataTimeStamp> SubscriptionTimestamp
public readonly Nullable<DataTimeStamp> SubscriptionTimestamp
Public ReadOnly SubscriptionTimestamp As Nullable(Of DataTimeStamp)
Public ReadOnly SubscriptionTimestamp As Nullable(Of DataTimeStamp)
public:
initonly Nullable<DataTimeStamp> SubscriptionTimestamp
public:
initonly Nullable<DataTimeStamp> SubscriptionTimestamp
val SubscriptionTimestamp: Nullable<DataTimeStamp>
val SubscriptionTimestamp: Nullable<DataTimeStamp>

Field Value

Type: Online Nullable DataTimeStamp
See Also
ErlCRUDQueryExecutionContext Structure
ErlCRUDQueryExecutionContext Members
NFX.DataAccess.Erlang Namespace


ErlCRUDQueryExecutionContext Methods

ErlCRUDQueryExecutionContext Methods NFX Class Library

The ErlCRUDQueryExecutionContext type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ErlCRUDQueryExecutionContext Structure
NFX.DataAccess.Erlang Namespace


ErlCRUDScriptQueryHandler Class

ErlCRUDScriptQueryHandler Class NFX Class Library

Executes Erlang CRUD script-based queries
Inheritance Hierarchy
Online System Object
NFX.DataAccess.CRUD CRUDQueryHandler
NFX.DataAccess.CRUD CRUDQueryHandler ErlDataStore
NFX.DataAccess.Erlang ErlCRUDScriptQueryHandler

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ErlCRUDScriptQueryHandler : CRUDQueryHandler<ErlDataStore>
public sealed class ErlCRUDScriptQueryHandler : CRUDQueryHandler<ErlDataStore>
Public NotInheritable Class ErlCRUDScriptQueryHandler
    Inherits CRUDQueryHandler(Of ErlDataStore)
Public NotInheritable Class ErlCRUDScriptQueryHandler
    Inherits CRUDQueryHandler(Of ErlDataStore)
public ref class ErlCRUDScriptQueryHandler sealed : public CRUDQueryHandler<ErlDataStore^>
public ref class ErlCRUDScriptQueryHandler sealed : public CRUDQueryHandler<ErlDataStore^>
[<SealedAttribute>]
type ErlCRUDScriptQueryHandler =
    class
        inherit CRUDQueryHandler<ErlDataStore>
    end
[<SealedAttribute>]
type ErlCRUDScriptQueryHandler =
    class
        inherit CRUDQueryHandler<ErlDataStore>
    end
See Also
ErlCRUDScriptQueryHandler Members
NFX.DataAccess.Erlang Namespace


ErlCRUDScriptQueryHandler Members

ErlCRUDScriptQueryHandler Members NFX Class Library

The ErlCRUDScriptQueryHandler type exposes the following members.
Constructors
 | Name | Description
Public method | ErlCRUDScriptQueryHandler | Initializes a new instance of the ErlCRUDScriptQueryHandler class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Execute | (Overrides CRUDQueryHandler Execute(ICRUDQueryExecutionContext, Query, Boolean).)
Public method | ExecuteAsync | (Overrides CRUDQueryHandler ExecuteAsync(ICRUDQueryExecutionContext, Query, Boolean).)
Public method | ExecuteWithoutFetch | (Overrides CRUDQueryHandler ExecuteWithoutFetch(ICRUDQueryExecutionContext, Query).)
Public method | ExecuteWithoutFetchAsync | (Overrides CRUDQueryHandler ExecuteWithoutFetchAsync(ICRUDQueryExecutionContext, Query).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSchema | (Overrides CRUDQueryHandler GetSchema(ICRUDQueryExecutionContext, Query).)
Public method | GetSchemaAsync | (Overrides CRUDQueryHandler GetSchemaAsync(ICRUDQueryExecutionContext, Query).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenCursor | (Overrides CRUDQueryHandler OpenCursor(ICRUDQueryExecutionContext, Query).)
Public method | OpenCursorAsync | (Overrides CRUDQueryHandler OpenCursorAsync(ICRUDQueryExecutionContext, Query).)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | ATOM_Code |
 | ATOM_Msg |
 | ATOM_ReqID |
 | ATOM_Rows |
 | ATOM_SchemaID |
 | ATOM_Subscriber |
 | ATOM_Timestamp |
 | EXECUTE_ERROR_PATTERN |
 | EXECUTE_OK_PATTERN |
 | EXECUTE_SUBSCRIBE_ERROR_PATTERN |
 | EXECUTE_SUBSCRIBE_OK_PATTERN |
 | INVALID_SUBSCRIPTION_REQUEST_EXCEPTION |
Protected field | Source | (Inherited from CRUDQueryHandler.)
Back to Top
Properties
 | Name | Description
Public property | ErlStore |
Public property | Name | Returns query name that this handler handles (Inherited from CRUDQueryHandler.)
Public property | Store | Store instance that handler is under (Inherited from CRUDQueryHandler TStore .)
Back to Top
See Also
ErlCRUDScriptQueryHandler Class
NFX.DataAccess.Erlang Namespace


ErlCRUDScriptQueryHandler Constructor

ErlCRUDScriptQueryHandler Constructor NFX Class Library

Initializes a new instance of the ErlCRUDScriptQueryHandler class

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlCRUDScriptQueryHandler(
    ErlDataStore store,
    QuerySource source
)
public ErlCRUDScriptQueryHandler(
    ErlDataStore store,
    QuerySource source
)
Public Sub New (
    store As ErlDataStore,
    source As QuerySource
)
Public Sub New (
    store As ErlDataStore,
    source As QuerySource
)
public:
ErlCRUDScriptQueryHandler(
    ErlDataStore^ store,
    QuerySource^ source
)
public:
ErlCRUDScriptQueryHandler(
    ErlDataStore^ store,
    QuerySource^ source
)
new :
        store : ErlDataStore *
        source : QuerySource -> ErlCRUDScriptQueryHandler
new :
        store : ErlDataStore *
        source : QuerySource -> ErlCRUDScriptQueryHandler

Parameters

store
Type: NFX.DataAccess.Erlang ErlDataStore
source
Type: NFX.DataAccess.CRUD QuerySource
See Also
ErlCRUDScriptQueryHandler Class
ErlCRUDScriptQueryHandler Members
NFX.DataAccess.Erlang Namespace


ErlCRUDScriptQueryHandler Fields

ErlCRUDScriptQueryHandler Fields NFX Class Library

The ErlCRUDScriptQueryHandler type exposes the following members.
Fields
 | Name | Description
 | ATOM_Code |
 | ATOM_Msg |
 | ATOM_ReqID |
 | ATOM_Rows |
 | ATOM_SchemaID |
 | ATOM_Subscriber |
 | ATOM_Timestamp |
 | EXECUTE_ERROR_PATTERN |
 | EXECUTE_OK_PATTERN |
 | EXECUTE_SUBSCRIBE_ERROR_PATTERN |
 | EXECUTE_SUBSCRIBE_OK_PATTERN |
 | INVALID_SUBSCRIPTION_REQUEST_EXCEPTION |
Protected field | Source | (Inherited from CRUDQueryHandler.)
Back to Top
See Also
ErlCRUDScriptQueryHandler Class
NFX.DataAccess.Erlang Namespace


ErlCRUDScriptQueryHandler.ATOM_Code Field

ErlCRUDScriptQueryHandler ATOM_Code Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ErlAtom ATOM_Code
public static readonly ErlAtom ATOM_Code
Public Shared ReadOnly ATOM_Code As ErlAtom
Public Shared ReadOnly ATOM_Code As ErlAtom
public:
static initonly ErlAtom ATOM_Code
public:
static initonly ErlAtom ATOM_Code
static val ATOM_Code: ErlAtom
static val ATOM_Code: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlCRUDScriptQueryHandler Class
ErlCRUDScriptQueryHandler Members
NFX.DataAccess.Erlang Namespace


ErlCRUDScriptQueryHandler.ATOM_Msg Field

ErlCRUDScriptQueryHandler ATOM_Msg Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ErlAtom ATOM_Msg
public static readonly ErlAtom ATOM_Msg
Public Shared ReadOnly ATOM_Msg As ErlAtom
Public Shared ReadOnly ATOM_Msg As ErlAtom
public:
static initonly ErlAtom ATOM_Msg
public:
static initonly ErlAtom ATOM_Msg
static val ATOM_Msg: ErlAtom
static val ATOM_Msg: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlCRUDScriptQueryHandler Class
ErlCRUDScriptQueryHandler Members
NFX.DataAccess.Erlang Namespace


ErlCRUDScriptQueryHandler.ATOM_ReqID Field

ErlCRUDScriptQueryHandler ATOM_ReqID Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ErlAtom ATOM_ReqID
public static readonly ErlAtom ATOM_ReqID
Public Shared ReadOnly ATOM_ReqID As ErlAtom
Public Shared ReadOnly ATOM_ReqID As ErlAtom
public:
static initonly ErlAtom ATOM_ReqID
public:
static initonly ErlAtom ATOM_ReqID
static val ATOM_ReqID: ErlAtom
static val ATOM_ReqID: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlCRUDScriptQueryHandler Class
ErlCRUDScriptQueryHandler Members
NFX.DataAccess.Erlang Namespace


ErlCRUDScriptQueryHandler.ATOM_Rows Field

ErlCRUDScriptQueryHandler ATOM_Rows Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ErlAtom ATOM_Rows
public static readonly ErlAtom ATOM_Rows
Public Shared ReadOnly ATOM_Rows As ErlAtom
Public Shared ReadOnly ATOM_Rows As ErlAtom
public:
static initonly ErlAtom ATOM_Rows
public:
static initonly ErlAtom ATOM_Rows
static val ATOM_Rows: ErlAtom
static val ATOM_Rows: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlCRUDScriptQueryHandler Class
ErlCRUDScriptQueryHandler Members
NFX.DataAccess.Erlang Namespace


ErlCRUDScriptQueryHandler.ATOM_SchemaID Field

ErlCRUDScriptQueryHandler ATOM_SchemaID Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ErlAtom ATOM_SchemaID
public static readonly ErlAtom ATOM_SchemaID
Public Shared ReadOnly ATOM_SchemaID As ErlAtom
Public Shared ReadOnly ATOM_SchemaID As ErlAtom
public:
static initonly ErlAtom ATOM_SchemaID
public:
static initonly ErlAtom ATOM_SchemaID
static val ATOM_SchemaID: ErlAtom
static val ATOM_SchemaID: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlCRUDScriptQueryHandler Class
ErlCRUDScriptQueryHandler Members
NFX.DataAccess.Erlang Namespace


ErlCRUDScriptQueryHandler.ATOM_Subscriber Field

ErlCRUDScriptQueryHandler ATOM_Subscriber Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ErlAtom ATOM_Subscriber
public static readonly ErlAtom ATOM_Subscriber
Public Shared ReadOnly ATOM_Subscriber As ErlAtom
Public Shared ReadOnly ATOM_Subscriber As ErlAtom
public:
static initonly ErlAtom ATOM_Subscriber
public:
static initonly ErlAtom ATOM_Subscriber
static val ATOM_Subscriber: ErlAtom
static val ATOM_Subscriber: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlCRUDScriptQueryHandler Class
ErlCRUDScriptQueryHandler Members
NFX.DataAccess.Erlang Namespace


ErlCRUDScriptQueryHandler.ATOM_Timestamp Field

ErlCRUDScriptQueryHandler ATOM_Timestamp Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ErlAtom ATOM_Timestamp
public static readonly ErlAtom ATOM_Timestamp
Public Shared ReadOnly ATOM_Timestamp As ErlAtom
Public Shared ReadOnly ATOM_Timestamp As ErlAtom
public:
static initonly ErlAtom ATOM_Timestamp
public:
static initonly ErlAtom ATOM_Timestamp
static val ATOM_Timestamp: ErlAtom
static val ATOM_Timestamp: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlCRUDScriptQueryHandler Class
ErlCRUDScriptQueryHandler Members
NFX.DataAccess.Erlang Namespace


ErlCRUDScriptQueryHandler.EXECUTE_ERROR_PATTERN Field

ErlCRUDScriptQueryHandler EXECUTE_ERROR_PATTERN Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly IErlObject EXECUTE_ERROR_PATTERN
public static readonly IErlObject EXECUTE_ERROR_PATTERN
Public Shared ReadOnly EXECUTE_ERROR_PATTERN As IErlObject
Public Shared ReadOnly EXECUTE_ERROR_PATTERN As IErlObject
public:
static initonly IErlObject^ EXECUTE_ERROR_PATTERN
public:
static initonly IErlObject^ EXECUTE_ERROR_PATTERN
static val EXECUTE_ERROR_PATTERN: IErlObject
static val EXECUTE_ERROR_PATTERN: IErlObject

Field Value

Type: IErlObject
See Also
ErlCRUDScriptQueryHandler Class
ErlCRUDScriptQueryHandler Members
NFX.DataAccess.Erlang Namespace


ErlCRUDScriptQueryHandler.EXECUTE_OK_PATTERN Field

ErlCRUDScriptQueryHandler EXECUTE_OK_PATTERN Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly IErlObject EXECUTE_OK_PATTERN
public static readonly IErlObject EXECUTE_OK_PATTERN
Public Shared ReadOnly EXECUTE_OK_PATTERN As IErlObject
Public Shared ReadOnly EXECUTE_OK_PATTERN As IErlObject
public:
static initonly IErlObject^ EXECUTE_OK_PATTERN
public:
static initonly IErlObject^ EXECUTE_OK_PATTERN
static val EXECUTE_OK_PATTERN: IErlObject
static val EXECUTE_OK_PATTERN: IErlObject

Field Value

Type: IErlObject
See Also
ErlCRUDScriptQueryHandler Class
ErlCRUDScriptQueryHandler Members
NFX.DataAccess.Erlang Namespace


ErlCRUDScriptQueryHandler.EXECUTE_SUBSCRIBE_ERROR_PATTERN Field

ErlCRUDScriptQueryHandler EXECUTE_SUBSCRIBE_ERROR_PATTERN Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly IErlObject EXECUTE_SUBSCRIBE_ERROR_PATTERN
public static readonly IErlObject EXECUTE_SUBSCRIBE_ERROR_PATTERN
Public Shared ReadOnly EXECUTE_SUBSCRIBE_ERROR_PATTERN As IErlObject
Public Shared ReadOnly EXECUTE_SUBSCRIBE_ERROR_PATTERN As IErlObject
public:
static initonly IErlObject^ EXECUTE_SUBSCRIBE_ERROR_PATTERN
public:
static initonly IErlObject^ EXECUTE_SUBSCRIBE_ERROR_PATTERN
static val EXECUTE_SUBSCRIBE_ERROR_PATTERN: IErlObject
static val EXECUTE_SUBSCRIBE_ERROR_PATTERN: IErlObject

Field Value

Type: IErlObject
See Also
ErlCRUDScriptQueryHandler Class
ErlCRUDScriptQueryHandler Members
NFX.DataAccess.Erlang Namespace


ErlCRUDScriptQueryHandler.EXECUTE_SUBSCRIBE_OK_PATTERN Field

ErlCRUDScriptQueryHandler EXECUTE_SUBSCRIBE_OK_PATTERN Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly IErlObject EXECUTE_SUBSCRIBE_OK_PATTERN
public static readonly IErlObject EXECUTE_SUBSCRIBE_OK_PATTERN
Public Shared ReadOnly EXECUTE_SUBSCRIBE_OK_PATTERN As IErlObject
Public Shared ReadOnly EXECUTE_SUBSCRIBE_OK_PATTERN As IErlObject
public:
static initonly IErlObject^ EXECUTE_SUBSCRIBE_OK_PATTERN
public:
static initonly IErlObject^ EXECUTE_SUBSCRIBE_OK_PATTERN
static val EXECUTE_SUBSCRIBE_OK_PATTERN: IErlObject
static val EXECUTE_SUBSCRIBE_OK_PATTERN: IErlObject

Field Value

Type: IErlObject
See Also
ErlCRUDScriptQueryHandler Class
ErlCRUDScriptQueryHandler Members
NFX.DataAccess.Erlang Namespace


ErlCRUDScriptQueryHandler.INVALID_SUBSCRIPTION_REQUEST_EXCEPTION Field

ErlCRUDScriptQueryHandler INVALID_SUBSCRIPTION_REQUEST_EXCEPTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int INVALID_SUBSCRIPTION_REQUEST_EXCEPTION
public const int INVALID_SUBSCRIPTION_REQUEST_EXCEPTION
Public Const INVALID_SUBSCRIPTION_REQUEST_EXCEPTION As Integer
Public Const INVALID_SUBSCRIPTION_REQUEST_EXCEPTION As Integer
public:
literal int INVALID_SUBSCRIPTION_REQUEST_EXCEPTION
public:
literal int INVALID_SUBSCRIPTION_REQUEST_EXCEPTION
static val mutable INVALID_SUBSCRIPTION_REQUEST_EXCEPTION: int
static val mutable INVALID_SUBSCRIPTION_REQUEST_EXCEPTION: int

Field Value

Type: Online Int32
See Also
ErlCRUDScriptQueryHandler Class
ErlCRUDScriptQueryHandler Members
NFX.DataAccess.Erlang Namespace


ErlCRUDScriptQueryHandler Methods

ErlCRUDScriptQueryHandler Methods NFX Class Library

The ErlCRUDScriptQueryHandler type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Execute | (Overrides CRUDQueryHandler Execute(ICRUDQueryExecutionContext, Query, Boolean).)
Public method | ExecuteAsync | (Overrides CRUDQueryHandler ExecuteAsync(ICRUDQueryExecutionContext, Query, Boolean).)
Public method | ExecuteWithoutFetch | (Overrides CRUDQueryHandler ExecuteWithoutFetch(ICRUDQueryExecutionContext, Query).)
Public method | ExecuteWithoutFetchAsync | (Overrides CRUDQueryHandler ExecuteWithoutFetchAsync(ICRUDQueryExecutionContext, Query).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSchema | (Overrides CRUDQueryHandler GetSchema(ICRUDQueryExecutionContext, Query).)
Public method | GetSchemaAsync | (Overrides CRUDQueryHandler GetSchemaAsync(ICRUDQueryExecutionContext, Query).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenCursor | (Overrides CRUDQueryHandler OpenCursor(ICRUDQueryExecutionContext, Query).)
Public method | OpenCursorAsync | (Overrides CRUDQueryHandler OpenCursorAsync(ICRUDQueryExecutionContext, Query).)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ErlCRUDScriptQueryHandler Class
NFX.DataAccess.Erlang Namespace


ErlCRUDScriptQueryHandler.Execute Method

ErlCRUDScriptQueryHandler Execute Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override RowsetBase Execute(
    ICRUDQueryExecutionContext context,
    Query query,
    bool oneRow = false
)
public override RowsetBase Execute(
    ICRUDQueryExecutionContext context,
    Query query,
    bool oneRow = false
)
Public Overrides Function Execute (
    context As ICRUDQueryExecutionContext,
    query As Query,
    Optional oneRow As Boolean = false
) As RowsetBase
Public Overrides Function Execute (
    context As ICRUDQueryExecutionContext,
    query As Query,
    Optional oneRow As Boolean = false
) As RowsetBase
public:
virtual RowsetBase^ Execute(
    ICRUDQueryExecutionContext^ context,
    Query^ query,
    bool oneRow = false
) override
public:
virtual RowsetBase^ Execute(
    ICRUDQueryExecutionContext^ context,
    Query^ query,
    bool oneRow = false
) override
abstract Execute :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> RowsetBase
override Execute :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> RowsetBase
abstract Execute :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> RowsetBase
override Execute :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> RowsetBase

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query
oneRow (Optional)
Type: Online System Boolean

Return Value

Type: RowsetBase
See Also
ErlCRUDScriptQueryHandler Class
ErlCRUDScriptQueryHandler Members
NFX.DataAccess.Erlang Namespace


ErlCRUDScriptQueryHandler.ExecuteAsync Method

ErlCRUDScriptQueryHandler ExecuteAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Task<RowsetBase> ExecuteAsync(
    ICRUDQueryExecutionContext context,
    Query query,
    bool oneRow = false
)
public override Task<RowsetBase> ExecuteAsync(
    ICRUDQueryExecutionContext context,
    Query query,
    bool oneRow = false
)
Public Overrides Function ExecuteAsync (
    context As ICRUDQueryExecutionContext,
    query As Query,
    Optional oneRow As Boolean = false
) As Task(Of RowsetBase)
Public Overrides Function ExecuteAsync (
    context As ICRUDQueryExecutionContext,
    query As Query,
    Optional oneRow As Boolean = false
) As Task(Of RowsetBase)
public:
virtual Task<RowsetBase^>^ ExecuteAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query,
    bool oneRow = false
) override
public:
virtual Task<RowsetBase^>^ ExecuteAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query,
    bool oneRow = false
) override
abstract ExecuteAsync :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> Task<RowsetBase>
override ExecuteAsync :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> Task<RowsetBase>
abstract ExecuteAsync :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> Task<RowsetBase>
override ExecuteAsync :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> Task<RowsetBase>

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query
oneRow (Optional)
Type: Online System Boolean

Return Value

Type: Online Task RowsetBase
See Also
ErlCRUDScriptQueryHandler Class
ErlCRUDScriptQueryHandler Members
NFX.DataAccess.Erlang Namespace


ErlCRUDScriptQueryHandler.ExecuteWithoutFetch Method

ErlCRUDScriptQueryHandler ExecuteWithoutFetch Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int ExecuteWithoutFetch(
    ICRUDQueryExecutionContext context,
    Query query
)
public override int ExecuteWithoutFetch(
    ICRUDQueryExecutionContext context,
    Query query
)
Public Overrides Function ExecuteWithoutFetch (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Integer
Public Overrides Function ExecuteWithoutFetch (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Integer
public:
virtual int ExecuteWithoutFetch(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
public:
virtual int ExecuteWithoutFetch(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
abstract ExecuteWithoutFetch :
        context : ICRUDQueryExecutionContext *
        query : Query -> int
override ExecuteWithoutFetch :
        context : ICRUDQueryExecutionContext *
        query : Query -> int
abstract ExecuteWithoutFetch :
        context : ICRUDQueryExecutionContext *
        query : Query -> int
override ExecuteWithoutFetch :
        context : ICRUDQueryExecutionContext *
        query : Query -> int

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Int32
See Also
ErlCRUDScriptQueryHandler Class
ErlCRUDScriptQueryHandler Members
NFX.DataAccess.Erlang Namespace


ErlCRUDScriptQueryHandler.ExecuteWithoutFetchAsync Method

ErlCRUDScriptQueryHandler ExecuteWithoutFetchAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Task<int> ExecuteWithoutFetchAsync(
    ICRUDQueryExecutionContext context,
    Query query
)
public override Task<int> ExecuteWithoutFetchAsync(
    ICRUDQueryExecutionContext context,
    Query query
)
Public Overrides Function ExecuteWithoutFetchAsync (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Task(Of Integer)
Public Overrides Function ExecuteWithoutFetchAsync (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Task(Of Integer)
public:
virtual Task<int>^ ExecuteWithoutFetchAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
public:
virtual Task<int>^ ExecuteWithoutFetchAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
abstract ExecuteWithoutFetchAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<int>
override ExecuteWithoutFetchAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<int>
abstract ExecuteWithoutFetchAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<int>
override ExecuteWithoutFetchAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<int>

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Online Int32
See Also
ErlCRUDScriptQueryHandler Class
ErlCRUDScriptQueryHandler Members
NFX.DataAccess.Erlang Namespace


ErlCRUDScriptQueryHandler.GetSchema Method

ErlCRUDScriptQueryHandler GetSchema Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Schema GetSchema(
    ICRUDQueryExecutionContext context,
    Query query
)
public override Schema GetSchema(
    ICRUDQueryExecutionContext context,
    Query query
)
Public Overrides Function GetSchema (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Schema
Public Overrides Function GetSchema (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Schema
public:
virtual Schema^ GetSchema(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
public:
virtual Schema^ GetSchema(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
abstract GetSchema :
        context : ICRUDQueryExecutionContext *
        query : Query -> Schema
override GetSchema :
        context : ICRUDQueryExecutionContext *
        query : Query -> Schema
abstract GetSchema :
        context : ICRUDQueryExecutionContext *
        query : Query -> Schema
override GetSchema :
        context : ICRUDQueryExecutionContext *
        query : Query -> Schema

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Schema
See Also
ErlCRUDScriptQueryHandler Class
ErlCRUDScriptQueryHandler Members
NFX.DataAccess.Erlang Namespace


ErlCRUDScriptQueryHandler.GetSchemaAsync Method

ErlCRUDScriptQueryHandler GetSchemaAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Task<Schema> GetSchemaAsync(
    ICRUDQueryExecutionContext context,
    Query query
)
public override Task<Schema> GetSchemaAsync(
    ICRUDQueryExecutionContext context,
    Query query
)
Public Overrides Function GetSchemaAsync (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Task(Of Schema)
Public Overrides Function GetSchemaAsync (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Task(Of Schema)
public:
virtual Task<Schema^>^ GetSchemaAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
public:
virtual Task<Schema^>^ GetSchemaAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
abstract GetSchemaAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Schema>
override GetSchemaAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Schema>
abstract GetSchemaAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Schema>
override GetSchemaAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Schema>

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Schema
See Also
ErlCRUDScriptQueryHandler Class
ErlCRUDScriptQueryHandler Members
NFX.DataAccess.Erlang Namespace


ErlCRUDScriptQueryHandler.OpenCursor Method

ErlCRUDScriptQueryHandler OpenCursor Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Cursor OpenCursor(
    ICRUDQueryExecutionContext context,
    Query query
)
public override Cursor OpenCursor(
    ICRUDQueryExecutionContext context,
    Query query
)
Public Overrides Function OpenCursor (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Cursor
Public Overrides Function OpenCursor (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Cursor
public:
virtual Cursor^ OpenCursor(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
public:
virtual Cursor^ OpenCursor(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
abstract OpenCursor :
        context : ICRUDQueryExecutionContext *
        query : Query -> Cursor
override OpenCursor :
        context : ICRUDQueryExecutionContext *
        query : Query -> Cursor
abstract OpenCursor :
        context : ICRUDQueryExecutionContext *
        query : Query -> Cursor
override OpenCursor :
        context : ICRUDQueryExecutionContext *
        query : Query -> Cursor

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Cursor
See Also
ErlCRUDScriptQueryHandler Class
ErlCRUDScriptQueryHandler Members
NFX.DataAccess.Erlang Namespace


ErlCRUDScriptQueryHandler.OpenCursorAsync Method

ErlCRUDScriptQueryHandler OpenCursorAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Task<Cursor> OpenCursorAsync(
    ICRUDQueryExecutionContext context,
    Query query
)
public override Task<Cursor> OpenCursorAsync(
    ICRUDQueryExecutionContext context,
    Query query
)
Public Overrides Function OpenCursorAsync (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Task(Of Cursor)
Public Overrides Function OpenCursorAsync (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Task(Of Cursor)
public:
virtual Task<Cursor^>^ OpenCursorAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
public:
virtual Task<Cursor^>^ OpenCursorAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
abstract OpenCursorAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Cursor>
override OpenCursorAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Cursor>
abstract OpenCursorAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Cursor>
override OpenCursorAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Cursor>

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Cursor
See Also
ErlCRUDScriptQueryHandler Class
ErlCRUDScriptQueryHandler Members
NFX.DataAccess.Erlang Namespace


ErlCRUDScriptQueryHandler Properties

ErlCRUDScriptQueryHandler Properties NFX Class Library

The ErlCRUDScriptQueryHandler type exposes the following members.
Properties
 | Name | Description
Public property | ErlStore |
Public property | Name | Returns query name that this handler handles (Inherited from CRUDQueryHandler.)
Public property | Store | Store instance that handler is under (Inherited from CRUDQueryHandler TStore .)
Back to Top
See Also
ErlCRUDScriptQueryHandler Class
NFX.DataAccess.Erlang Namespace


ErlCRUDScriptQueryHandler.ErlStore Property

ErlCRUDScriptQueryHandler ErlStore Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlDataStore ErlStore { get; }
public ErlDataStore ErlStore { get; }
Public ReadOnly Property ErlStore As ErlDataStore
    Get
Public ReadOnly Property ErlStore As ErlDataStore
    Get
public:
property ErlDataStore^ ErlStore {
    ErlDataStore^ get ();
}
public:
property ErlDataStore^ ErlStore {
    ErlDataStore^ get ();
}
member ErlStore : ErlDataStore with get
member ErlStore : ErlDataStore with get

Property Value

Type: ErlDataStore
See Also
ErlCRUDScriptQueryHandler Class
ErlCRUDScriptQueryHandler Members
NFX.DataAccess.Erlang Namespace


ErlCRUDSubscription Class

ErlCRUDSubscription Class NFX Class Library

Implements subscriptions to Erlang CRUD data stores
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.DataAccess.CRUD.Subscriptions SubscriptionAppComponent
NFX.DataAccess.CRUD.Subscriptions Subscription
NFX.DataAccess.Erlang ErlCRUDSubscription

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ErlCRUDSubscription : Subscription
public class ErlCRUDSubscription : Subscription
Public Class ErlCRUDSubscription
    Inherits Subscription
Public Class ErlCRUDSubscription
    Inherits Subscription
public ref class ErlCRUDSubscription : public Subscription
public ref class ErlCRUDSubscription : public Subscription
type ErlCRUDSubscription =
    class
        inherit Subscription
    end
type ErlCRUDSubscription =
    class
        inherit Subscription
    end
See Also
ErlCRUDSubscription Members
NFX.DataAccess.Erlang Namespace


ErlCRUDSubscription Members

ErlCRUDSubscription Members NFX Class Library

The ErlCRUDSubscription type exposes the following members.
Constructors
 | Name | Description
Protected method | ErlCRUDSubscription | Initializes a new instance of the ErlCRUDSubscription class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Overrides Subscription Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from SubscriptionAppComponent.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from SubscriptionAppComponent.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from SubscriptionAppComponent.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | HasLoaded | Call after subscription has been initialized (Inherited from Subscription.)
Protected method | Invalidate | Called by descendants to invalidate this subscription (Inherited from Subscription.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Subscribe |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_ErlBox |
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Correlate | Allows to attach arbtrary bject for correlation (Inherited from Subscription.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from SubscriptionAppComponent.)
Public property | InvalidSubscriptionException | If this property is not null then this subscription is !IsValid (Inherited from Subscription.)
Public property | IsLoaded | (Inherited from Subscription.)
Public property | IsValid | Returns false when this subscription experienced InvalidSubscriptionException (Inherited from Subscription.)
Public property | Mailbox | (Inherited from Subscription.)
Public property | Name | (Inherited from Subscription.)
Public property | Query | (Inherited from Subscription.)
Public property | Store | (Inherited from Subscription.)
Back to Top
See Also
ErlCRUDSubscription Class
NFX.DataAccess.Erlang Namespace


ErlCRUDSubscription Constructor

ErlCRUDSubscription Constructor NFX Class Library

Initializes a new instance of the ErlCRUDSubscription class

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ErlCRUDSubscription(
    ErlDataStore store,
    string name,
    Query query,
    Mailbox recipient,
    Object correlate = null
)
internal ErlCRUDSubscription(
    ErlDataStore store,
    string name,
    Query query,
    Mailbox recipient,
    Object correlate = null
)
Friend Sub New (
    store As ErlDataStore,
    name As String,
    query As Query,
    recipient As Mailbox,
    Optional correlate As Object = Nothing
)
Friend Sub New (
    store As ErlDataStore,
    name As String,
    query As Query,
    recipient As Mailbox,
    Optional correlate As Object = Nothing
)
internal:
ErlCRUDSubscription(
    ErlDataStore^ store,
    String^ name,
    Query^ query,
    Mailbox^ recipient,
    Object^ correlate = nullptr
)
internal:
ErlCRUDSubscription(
    ErlDataStore^ store,
    String^ name,
    Query^ query,
    Mailbox^ recipient,
    Object^ correlate = nullptr
)
new :
        store : ErlDataStore *
        name : string *
        query : Query *
        recipient : Mailbox *
        ?correlate : Object
(* Defaults:
        let _correlate = defaultArg correlate null
*)
-> ErlCRUDSubscription
new :
        store : ErlDataStore *
        name : string *
        query : Query *
        recipient : Mailbox *
        ?correlate : Object
(* Defaults:
        let _correlate = defaultArg correlate null
*)
-> ErlCRUDSubscription

Parameters

store
Type: NFX.DataAccess.Erlang ErlDataStore
name
Type: Online System String
query
Type: NFX.DataAccess.CRUD Query
recipient
Type: NFX.DataAccess.CRUD.Subscriptions Mailbox
correlate (Optional)
Type: Online System Object
See Also
ErlCRUDSubscription Class
ErlCRUDSubscription Members
NFX.DataAccess.Erlang Namespace


ErlCRUDSubscription Fields

ErlCRUDSubscription Fields NFX Class Library

The ErlCRUDSubscription type exposes the following members.
Fields
 | Name | Description
Protected field | m_ErlBox |
Back to Top
See Also
ErlCRUDSubscription Class
NFX.DataAccess.Erlang Namespace


ErlCRUDSubscription.m_ErlBox Field

ErlCRUDSubscription m_ErlBox Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ErlMbox m_ErlBox
internal ErlMbox m_ErlBox
Friend m_ErlBox As ErlMbox
Friend m_ErlBox As ErlMbox
internal:
ErlMbox^ m_ErlBox
internal:
ErlMbox^ m_ErlBox
val mutable internal m_ErlBox: ErlMbox
val mutable internal m_ErlBox: ErlMbox

Field Value

Type: ErlMbox
See Also
ErlCRUDSubscription Class
ErlCRUDSubscription Members
NFX.DataAccess.Erlang Namespace


ErlCRUDSubscription Methods

ErlCRUDSubscription Methods NFX Class Library

The ErlCRUDSubscription type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Overrides Subscription Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from SubscriptionAppComponent.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from SubscriptionAppComponent.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from SubscriptionAppComponent.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | HasLoaded | Call after subscription has been initialized (Inherited from Subscription.)
Protected method | Invalidate | Called by descendants to invalidate this subscription (Inherited from Subscription.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Subscribe |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ErlCRUDSubscription Class
NFX.DataAccess.Erlang Namespace


ErlCRUDSubscription.Destructor Method

ErlCRUDSubscription Destructor Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
ErlCRUDSubscription Class
ErlCRUDSubscription Members
NFX.DataAccess.Erlang Namespace


ErlCRUDSubscription.Subscribe Method

ErlCRUDSubscription Subscribe Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Subscribe()
internal void Subscribe()
Friend Sub Subscribe
Friend Sub Subscribe
internal:
void Subscribe()
internal:
void Subscribe()
internal member Subscribe : unit -> unit
internal member Subscribe : unit -> unit
See Also
ErlCRUDSubscription Class
ErlCRUDSubscription Members
NFX.DataAccess.Erlang Namespace


ErlCRUDSubscription Properties

ErlCRUDSubscription Properties NFX Class Library

The ErlCRUDSubscription type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Correlate | Allows to attach arbtrary bject for correlation (Inherited from Subscription.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from SubscriptionAppComponent.)
Public property | InvalidSubscriptionException | If this property is not null then this subscription is !IsValid (Inherited from Subscription.)
Public property | IsLoaded | (Inherited from Subscription.)
Public property | IsValid | Returns false when this subscription experienced InvalidSubscriptionException (Inherited from Subscription.)
Public property | Mailbox | (Inherited from Subscription.)
Public property | Name | (Inherited from Subscription.)
Public property | Query | (Inherited from Subscription.)
Public property | Store | (Inherited from Subscription.)
Back to Top
See Also
ErlCRUDSubscription Class
NFX.DataAccess.Erlang Namespace


ErlDataAccessException Class

ErlDataAccessException Class NFX Class Library

Thrown by Erlang data access classes
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.DataAccess DataAccessException
NFX.DataAccess.Erlang ErlDataAccessException
NFX.DataAccess.Erlang ErlServerSchemaChangedException

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ErlDataAccessException : DataAccessException
[SerializableAttribute]
public class ErlDataAccessException : DataAccessException
<SerializableAttribute>
Public Class ErlDataAccessException
    Inherits DataAccessException
<SerializableAttribute>
Public Class ErlDataAccessException
    Inherits DataAccessException
[SerializableAttribute]
public ref class ErlDataAccessException : public DataAccessException
[SerializableAttribute]
public ref class ErlDataAccessException : public DataAccessException
[<SerializableAttribute>]
type ErlDataAccessException =
    class
        inherit DataAccessException
    end
[<SerializableAttribute>]
type ErlDataAccessException =
    class
        inherit DataAccessException
    end
See Also
ErlDataAccessException Members
NFX.DataAccess.Erlang Namespace


ErlDataAccessException Members

ErlDataAccessException Members NFX Class Library

The ErlDataAccessException type exposes the following members.
Constructors
 | Name | Description
Public method | ErlDataAccessException | Initializes a new instance of the ErlDataAccessException class
Public method | ErlDataAccessException(String) | Initializes a new instance of the ErlDataAccessException class
Protected method | ErlDataAccessException(SerializationInfo, StreamingContext) | Initializes a new instance of the ErlDataAccessException class
Public method | ErlDataAccessException(String, Exception) | Initializes a new instance of the ErlDataAccessException class
Public method | ErlDataAccessException(String, KeyViolationKind, String) | Initializes a new instance of the ErlDataAccessException class
Public method | ErlDataAccessException(String, Exception, KeyViolationKind, String) | Initializes a new instance of the ErlDataAccessException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ErlDataAccessException Class
NFX.DataAccess.Erlang Namespace


ErlDataAccessException Constructor

ErlDataAccessException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ErlDataAccessException | Initializes a new instance of the ErlDataAccessException class
Public method | ErlDataAccessException(String) | Initializes a new instance of the ErlDataAccessException class
Protected method | ErlDataAccessException(SerializationInfo, StreamingContext) | Initializes a new instance of the ErlDataAccessException class
Public method | ErlDataAccessException(String, Exception) | Initializes a new instance of the ErlDataAccessException class
Public method | ErlDataAccessException(String, KeyViolationKind, String) | Initializes a new instance of the ErlDataAccessException class
Public method | ErlDataAccessException(String, Exception, KeyViolationKind, String) | Initializes a new instance of the ErlDataAccessException class
Back to Top
See Also
ErlDataAccessException Class
ErlDataAccessException Members
NFX.DataAccess.Erlang Namespace


ErlDataAccessException Constructor

ErlDataAccessException Constructor NFX Class Library

Initializes a new instance of the ErlDataAccessException class

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlDataAccessException()
public ErlDataAccessException()
Public Sub New
Public Sub New
public:
ErlDataAccessException()
public:
ErlDataAccessException()
new : unit -> ErlDataAccessException
new : unit -> ErlDataAccessException
See Also
ErlDataAccessException Class
ErlDataAccessException Members
ErlDataAccessException Overload
NFX.DataAccess.Erlang Namespace


ErlDataAccessException Constructor (String)

ErlDataAccessException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlDataAccessException class

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlDataAccessException(
    string message
)
public ErlDataAccessException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
ErlDataAccessException(
    String^ message
)
public:
ErlDataAccessException(
    String^ message
)
new :
        message : string -> ErlDataAccessException
new :
        message : string -> ErlDataAccessException

Parameters

message
Type: Online System String
See Also
ErlDataAccessException Class
ErlDataAccessException Members
ErlDataAccessException Overload
NFX.DataAccess.Erlang Namespace


ErlDataAccessException Constructor (SerializationInfo, StreamingContext)

ErlDataAccessException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlDataAccessException class

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ErlDataAccessException(
    SerializationInfo info,
    StreamingContext context
)
protected ErlDataAccessException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
ErlDataAccessException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
ErlDataAccessException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ErlDataAccessException
new :
        info : SerializationInfo *
        context : StreamingContext -> ErlDataAccessException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
ErlDataAccessException Class
ErlDataAccessException Members
ErlDataAccessException Overload
NFX.DataAccess.Erlang Namespace


ErlDataAccessException Constructor (String, Exception)

ErlDataAccessException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlDataAccessException class

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlDataAccessException(
    string message,
    Exception inner
)
public ErlDataAccessException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
ErlDataAccessException(
    String^ message,
    Exception^ inner
)
public:
ErlDataAccessException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> ErlDataAccessException
new :
        message : string *
        inner : Exception -> ErlDataAccessException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
ErlDataAccessException Class
ErlDataAccessException Members
ErlDataAccessException Overload
NFX.DataAccess.Erlang Namespace


ErlDataAccessException Constructor (String, KeyViolationKind, String)

ErlDataAccessException Constructor (String, KeyViolationKind, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlDataAccessException class

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlDataAccessException(
    string message,
    KeyViolationKind kvKind,
    string keyViolation
)
public ErlDataAccessException(
    string message,
    KeyViolationKind kvKind,
    string keyViolation
)
Public Sub New (
    message As String,
    kvKind As KeyViolationKind,
    keyViolation As String
)
Public Sub New (
    message As String,
    kvKind As KeyViolationKind,
    keyViolation As String
)
public:
ErlDataAccessException(
    String^ message,
    KeyViolationKind kvKind,
    String^ keyViolation
)
public:
ErlDataAccessException(
    String^ message,
    KeyViolationKind kvKind,
    String^ keyViolation
)
new :
        message : string *
        kvKind : KeyViolationKind *
        keyViolation : string -> ErlDataAccessException
new :
        message : string *
        kvKind : KeyViolationKind *
        keyViolation : string -> ErlDataAccessException

Parameters

message
Type: Online System String
kvKind
Type: NFX.DataAccess KeyViolationKind
keyViolation
Type: Online System String
See Also
ErlDataAccessException Class
ErlDataAccessException Members
ErlDataAccessException Overload
NFX.DataAccess.Erlang Namespace


ErlDataAccessException Constructor (String, Exception, KeyViolationKind, String)

ErlDataAccessException Constructor (String, Exception, KeyViolationKind, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlDataAccessException class

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlDataAccessException(
    string message,
    Exception inner,
    KeyViolationKind kvKind,
    string keyViolation
)
public ErlDataAccessException(
    string message,
    Exception inner,
    KeyViolationKind kvKind,
    string keyViolation
)
Public Sub New (
    message As String,
    inner As Exception,
    kvKind As KeyViolationKind,
    keyViolation As String
)
Public Sub New (
    message As String,
    inner As Exception,
    kvKind As KeyViolationKind,
    keyViolation As String
)
public:
ErlDataAccessException(
    String^ message,
    Exception^ inner,
    KeyViolationKind kvKind,
    String^ keyViolation
)
public:
ErlDataAccessException(
    String^ message,
    Exception^ inner,
    KeyViolationKind kvKind,
    String^ keyViolation
)
new :
        message : string *
        inner : Exception *
        kvKind : KeyViolationKind *
        keyViolation : string -> ErlDataAccessException
new :
        message : string *
        inner : Exception *
        kvKind : KeyViolationKind *
        keyViolation : string -> ErlDataAccessException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
kvKind
Type: NFX.DataAccess KeyViolationKind
keyViolation
Type: Online System String
See Also
ErlDataAccessException Class
ErlDataAccessException Members
ErlDataAccessException Overload
NFX.DataAccess.Erlang Namespace


ErlDataAccessException Fields

ErlDataAccessException Fields NFX Class Library

The ErlDataAccessException type exposes the following members.
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
See Also
ErlDataAccessException Class
NFX.DataAccess.Erlang Namespace


ErlDataAccessException Methods

ErlDataAccessException Methods NFX Class Library

The ErlDataAccessException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
ErlDataAccessException Class
NFX.DataAccess.Erlang Namespace


ErlDataAccessException Properties

ErlDataAccessException Properties NFX Class Library

The ErlDataAccessException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
ErlDataAccessException Class
NFX.DataAccess.Erlang Namespace


ErlDataAccessException Events

ErlDataAccessException Events NFX Class Library

The ErlDataAccessException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ErlDataAccessException Class
NFX.DataAccess.Erlang Namespace


ErlDataStore Class

ErlDataStore Class NFX Class Library

Represents a CRUD data store that uses Erlang backend
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service Online Object
NFX.ServiceModel ServiceWithInstrumentationBase Online Object
NFX.DataAccess.Erlang ErlDataStore

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ErlDataStore : ServiceWithInstrumentationBase<Object>,
    ICRUDDataStoreImplementation, ICRUDDataStore, ICRUDOperations, ICRUDTransactionOperations, ICRUDSubscriptionStoreImplementation,
    ICRUDSubscriptionStore, IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
public class ErlDataStore : ServiceWithInstrumentationBase<Object>,
    ICRUDDataStoreImplementation, ICRUDDataStore, ICRUDOperations, ICRUDTransactionOperations, ICRUDSubscriptionStoreImplementation,
    ICRUDSubscriptionStore, IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
Public Class ErlDataStore
    Inherits ServiceWithInstrumentationBase(Of Object)
    Implements ICRUDDataStoreImplementation, ICRUDDataStore, ICRUDOperations, ICRUDTransactionOperations,
    ICRUDSubscriptionStoreImplementation, ICRUDSubscriptionStore, IDataStoreImplementation, IDataStore, IApplicationComponent,
    IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
Public Class ErlDataStore
    Inherits ServiceWithInstrumentationBase(Of Object)
    Implements ICRUDDataStoreImplementation, ICRUDDataStore, ICRUDOperations, ICRUDTransactionOperations,
    ICRUDSubscriptionStoreImplementation, ICRUDSubscriptionStore, IDataStoreImplementation, IDataStore, IApplicationComponent,
    IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
public ref class ErlDataStore : public ServiceWithInstrumentationBase<Object^>,
    ICRUDDataStoreImplementation, ICRUDDataStore, ICRUDOperations, ICRUDTransactionOperations, ICRUDSubscriptionStoreImplementation,
    ICRUDSubscriptionStore, IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
public ref class ErlDataStore : public ServiceWithInstrumentationBase<Object^>,
    ICRUDDataStoreImplementation, ICRUDDataStore, ICRUDOperations, ICRUDTransactionOperations, ICRUDSubscriptionStoreImplementation,
    ICRUDSubscriptionStore, IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
type ErlDataStore =
    class
        inherit ServiceWithInstrumentationBase<Object>
        interface ICRUDDataStoreImplementation
        interface ICRUDDataStore
        interface ICRUDOperations
        interface ICRUDTransactionOperations
        interface ICRUDSubscriptionStoreImplementation
        interface ICRUDSubscriptionStore
        interface IDataStoreImplementation
        interface IDataStore
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
type ErlDataStore =
    class
        inherit ServiceWithInstrumentationBase<Object>
        interface ICRUDDataStoreImplementation
        interface ICRUDDataStore
        interface ICRUDOperations
        interface ICRUDTransactionOperations
        interface ICRUDSubscriptionStoreImplementation
        interface ICRUDSubscriptionStore
        interface IDataStoreImplementation
        interface IDataStore
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore Members

ErlDataStore Members NFX Class Library

The ErlDataStore type exposes the following members.
Constructors
 | Name | Description
Public method | ErlDataStore | Initializes a new instance of the ErlDataStore class
Public method | ErlDataStore(Object) | Initializes a new instance of the ErlDataStore class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | BeginTransaction |
Public method | BeginTransactionAsync |
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | CRUDWrite |
Protected method | DecompressBytes |
Protected method | DecompressString |
Public method | Delete |
Public method | DeleteAsync |
Protected method | Destructor | (Overrides Service Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | ExecuteRPC |
Public method | ExecuteWithoutFetch |
Public method | ExecuteWithoutFetchAsync |
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSchema |
Public method | GetSchemaAsync |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Insert |
Public method | InsertAsync |
Public method | Load |
Public method | LoadAsync |
Public method | LoadOneRow |
Public method | LoadOneRowAsync |
Public method | LoadOneRowset |
Public method | LoadOneRowsetAsync |
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | MakeMailbox |
Public method | MakeScriptQueryHandler |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenCursor |
Public method | OpenCursorAsync |
Public method | OpenMailbox |
Public method | Save |
Public method | SaveAsync |
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Subscribe |
Public method | TestConnection |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | Update |
Public method | UpdateAsync |
Public method | Upsert |
Public method | UpsertAsync |
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | LoadEnumerable TRow | Loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadEnumerableAsync TRow | Async version - loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadRow TRow | Loads one row cast per Query(T) or null (Defined by DataUtils.)
Public Extension Method | LoadRowAsync TRow | Async version - loads one row cast per Query(T) or null (Defined by DataUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
AFFECTED |
BONJOUR_OK_PATTERN |
CRUD_WRITE_OK_PATTERN |
DEFAULT_RPC_TIMEOUT_MS |
DEFAULT_TARGET_NAME |
ENCODING |
ERL_FILE_SUFFIX |
NFX_BONJOUR_FUN |
NFX_CRUD_MOD |
NFX_DELETE_FUN |
NFX_RPC_FUN |
NFX_SUBSCRIBE_FUN |
NFX_WRITE_FUN |
SCHEMA_CONTENT |
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | CallTimeoutMs |
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | InstrumentationEnabled | (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | LocalName | Shortcut to ErlApp.Node name
Public property | LogLevel |
Public property | Mailboxes |
Protected property | Map | Returns the map lazily obtaining it when needed
Public property | Name | Provides textual name for the service (Inherited from Service.)
Protected property | NextRequestID | Generates nest sequential request ID
Public property | QueryResolver |
Public property | RemoteCookie |
Public property | RemoteName |
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | ScriptFileSuffix |
Public property | Status | Current service status (Inherited from Service.)
Public property | StoreType |
Public property | Subscriptions |
Public property | SupportsTransactions |
Public property | SupportsTrueAsynchrony |
Public property | TargetName |
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
ErlDataStore Class
NFX.DataAccess.Erlang Namespace


ErlDataStore Constructor

ErlDataStore Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ErlDataStore | Initializes a new instance of the ErlDataStore class
Public method | ErlDataStore(Object) | Initializes a new instance of the ErlDataStore class
Back to Top
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore Constructor

ErlDataStore Constructor NFX Class Library

Initializes a new instance of the ErlDataStore class

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlDataStore()
public ErlDataStore()
Public Sub New
Public Sub New
public:
ErlDataStore()
public:
ErlDataStore()
new : unit -> ErlDataStore
new : unit -> ErlDataStore
See Also
ErlDataStore Class
ErlDataStore Members
ErlDataStore Overload
NFX.DataAccess.Erlang Namespace


ErlDataStore Constructor (Object)

ErlDataStore Constructor (Object) NFX Class Library

Initializes a new instance of the ErlDataStore class

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlDataStore(
    Object director
)
public ErlDataStore(
    Object director
)
Public Sub New (
    director As Object
)
Public Sub New (
    director As Object
)
public:
ErlDataStore(
    Object^ director
)
public:
ErlDataStore(
    Object^ director
)
new :
        director : Object -> ErlDataStore
new :
        director : Object -> ErlDataStore

Parameters

director
Type: Online System Object
See Also
ErlDataStore Class
ErlDataStore Members
ErlDataStore Overload
NFX.DataAccess.Erlang Namespace


ErlDataStore Fields

ErlDataStore Fields NFX Class Library

The ErlDataStore type exposes the following members.
Fields
Name | Description
AFFECTED |
BONJOUR_OK_PATTERN |
CRUD_WRITE_OK_PATTERN |
DEFAULT_RPC_TIMEOUT_MS |
DEFAULT_TARGET_NAME |
ENCODING |
ERL_FILE_SUFFIX |
NFX_BONJOUR_FUN |
NFX_CRUD_MOD |
NFX_DELETE_FUN |
NFX_RPC_FUN |
NFX_SUBSCRIBE_FUN |
NFX_WRITE_FUN |
SCHEMA_CONTENT |
Back to Top
See Also
ErlDataStore Class
NFX.DataAccess.Erlang Namespace


ErlDataStore.AFFECTED Field

ErlDataStore AFFECTED Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ErlAtom AFFECTED
public static readonly ErlAtom AFFECTED
Public Shared ReadOnly AFFECTED As ErlAtom
Public Shared ReadOnly AFFECTED As ErlAtom
public:
static initonly ErlAtom AFFECTED
public:
static initonly ErlAtom AFFECTED
static val AFFECTED: ErlAtom
static val AFFECTED: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.BONJOUR_OK_PATTERN Field

ErlDataStore BONJOUR_OK_PATTERN Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly IErlObject BONJOUR_OK_PATTERN
public static readonly IErlObject BONJOUR_OK_PATTERN
Public Shared ReadOnly BONJOUR_OK_PATTERN As IErlObject
Public Shared ReadOnly BONJOUR_OK_PATTERN As IErlObject
public:
static initonly IErlObject^ BONJOUR_OK_PATTERN
public:
static initonly IErlObject^ BONJOUR_OK_PATTERN
static val BONJOUR_OK_PATTERN: IErlObject
static val BONJOUR_OK_PATTERN: IErlObject

Field Value

Type: IErlObject
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.CRUD_WRITE_OK_PATTERN Field

ErlDataStore CRUD_WRITE_OK_PATTERN Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly IErlObject CRUD_WRITE_OK_PATTERN
public static readonly IErlObject CRUD_WRITE_OK_PATTERN
Public Shared ReadOnly CRUD_WRITE_OK_PATTERN As IErlObject
Public Shared ReadOnly CRUD_WRITE_OK_PATTERN As IErlObject
public:
static initonly IErlObject^ CRUD_WRITE_OK_PATTERN
public:
static initonly IErlObject^ CRUD_WRITE_OK_PATTERN
static val CRUD_WRITE_OK_PATTERN: IErlObject
static val CRUD_WRITE_OK_PATTERN: IErlObject

Field Value

Type: IErlObject
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.DEFAULT_RPC_TIMEOUT_MS Field

ErlDataStore DEFAULT_RPC_TIMEOUT_MS Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_RPC_TIMEOUT_MS
public const int DEFAULT_RPC_TIMEOUT_MS
Public Const DEFAULT_RPC_TIMEOUT_MS As Integer
Public Const DEFAULT_RPC_TIMEOUT_MS As Integer
public:
literal int DEFAULT_RPC_TIMEOUT_MS
public:
literal int DEFAULT_RPC_TIMEOUT_MS
static val mutable DEFAULT_RPC_TIMEOUT_MS: int
static val mutable DEFAULT_RPC_TIMEOUT_MS: int

Field Value

Type: Online Int32
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.DEFAULT_TARGET_NAME Field

ErlDataStore DEFAULT_TARGET_NAME Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_TARGET_NAME
public const string DEFAULT_TARGET_NAME
Public Const DEFAULT_TARGET_NAME As String
Public Const DEFAULT_TARGET_NAME As String
public:
literal String^ DEFAULT_TARGET_NAME
public:
literal String^ DEFAULT_TARGET_NAME
static val mutable DEFAULT_TARGET_NAME: string
static val mutable DEFAULT_TARGET_NAME: string

Field Value

Type: Online String
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.ENCODING Field

ErlDataStore ENCODING Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ErlAtom ENCODING
public static readonly ErlAtom ENCODING
Public Shared ReadOnly ENCODING As ErlAtom
Public Shared ReadOnly ENCODING As ErlAtom
public:
static initonly ErlAtom ENCODING
public:
static initonly ErlAtom ENCODING
static val ENCODING: ErlAtom
static val ENCODING: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.ERL_FILE_SUFFIX Field

ErlDataStore ERL_FILE_SUFFIX Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_FILE_SUFFIX
public const string ERL_FILE_SUFFIX
Public Const ERL_FILE_SUFFIX As String
Public Const ERL_FILE_SUFFIX As String
public:
literal String^ ERL_FILE_SUFFIX
public:
literal String^ ERL_FILE_SUFFIX
static val mutable ERL_FILE_SUFFIX: string
static val mutable ERL_FILE_SUFFIX: string

Field Value

Type: Online String
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.NFX_BONJOUR_FUN Field

ErlDataStore NFX_BONJOUR_FUN Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ErlAtom NFX_BONJOUR_FUN
public static readonly ErlAtom NFX_BONJOUR_FUN
Public Shared ReadOnly NFX_BONJOUR_FUN As ErlAtom
Public Shared ReadOnly NFX_BONJOUR_FUN As ErlAtom
public:
static initonly ErlAtom NFX_BONJOUR_FUN
public:
static initonly ErlAtom NFX_BONJOUR_FUN
static val NFX_BONJOUR_FUN: ErlAtom
static val NFX_BONJOUR_FUN: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.NFX_CRUD_MOD Field

ErlDataStore NFX_CRUD_MOD Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ErlAtom NFX_CRUD_MOD
public static readonly ErlAtom NFX_CRUD_MOD
Public Shared ReadOnly NFX_CRUD_MOD As ErlAtom
Public Shared ReadOnly NFX_CRUD_MOD As ErlAtom
public:
static initonly ErlAtom NFX_CRUD_MOD
public:
static initonly ErlAtom NFX_CRUD_MOD
static val NFX_CRUD_MOD: ErlAtom
static val NFX_CRUD_MOD: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.NFX_DELETE_FUN Field

ErlDataStore NFX_DELETE_FUN Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ErlAtom NFX_DELETE_FUN
public static readonly ErlAtom NFX_DELETE_FUN
Public Shared ReadOnly NFX_DELETE_FUN As ErlAtom
Public Shared ReadOnly NFX_DELETE_FUN As ErlAtom
public:
static initonly ErlAtom NFX_DELETE_FUN
public:
static initonly ErlAtom NFX_DELETE_FUN
static val NFX_DELETE_FUN: ErlAtom
static val NFX_DELETE_FUN: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.NFX_RPC_FUN Field

ErlDataStore NFX_RPC_FUN Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ErlAtom NFX_RPC_FUN
public static readonly ErlAtom NFX_RPC_FUN
Public Shared ReadOnly NFX_RPC_FUN As ErlAtom
Public Shared ReadOnly NFX_RPC_FUN As ErlAtom
public:
static initonly ErlAtom NFX_RPC_FUN
public:
static initonly ErlAtom NFX_RPC_FUN
static val NFX_RPC_FUN: ErlAtom
static val NFX_RPC_FUN: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.NFX_SUBSCRIBE_FUN Field

ErlDataStore NFX_SUBSCRIBE_FUN Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ErlAtom NFX_SUBSCRIBE_FUN
public static readonly ErlAtom NFX_SUBSCRIBE_FUN
Public Shared ReadOnly NFX_SUBSCRIBE_FUN As ErlAtom
Public Shared ReadOnly NFX_SUBSCRIBE_FUN As ErlAtom
public:
static initonly ErlAtom NFX_SUBSCRIBE_FUN
public:
static initonly ErlAtom NFX_SUBSCRIBE_FUN
static val NFX_SUBSCRIBE_FUN: ErlAtom
static val NFX_SUBSCRIBE_FUN: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.NFX_WRITE_FUN Field

ErlDataStore NFX_WRITE_FUN Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ErlAtom NFX_WRITE_FUN
public static readonly ErlAtom NFX_WRITE_FUN
Public Shared ReadOnly NFX_WRITE_FUN As ErlAtom
Public Shared ReadOnly NFX_WRITE_FUN As ErlAtom
public:
static initonly ErlAtom NFX_WRITE_FUN
public:
static initonly ErlAtom NFX_WRITE_FUN
static val NFX_WRITE_FUN: ErlAtom
static val NFX_WRITE_FUN: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.SCHEMA_CONTENT Field

ErlDataStore SCHEMA_CONTENT Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ErlAtom SCHEMA_CONTENT
public static readonly ErlAtom SCHEMA_CONTENT
Public Shared ReadOnly SCHEMA_CONTENT As ErlAtom
Public Shared ReadOnly SCHEMA_CONTENT As ErlAtom
public:
static initonly ErlAtom SCHEMA_CONTENT
public:
static initonly ErlAtom SCHEMA_CONTENT
static val SCHEMA_CONTENT: ErlAtom
static val SCHEMA_CONTENT: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore Methods

ErlDataStore Methods NFX Class Library

The ErlDataStore type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | BeginTransaction |
Public method | BeginTransactionAsync |
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | CRUDWrite |
Protected method | DecompressBytes |
Protected method | DecompressString |
Public method | Delete |
Public method | DeleteAsync |
Protected method | Destructor | (Overrides Service Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | ExecuteRPC |
Public method | ExecuteWithoutFetch |
Public method | ExecuteWithoutFetchAsync |
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSchema |
Public method | GetSchemaAsync |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Insert |
Public method | InsertAsync |
Public method | Load |
Public method | LoadAsync |
Public method | LoadOneRow |
Public method | LoadOneRowAsync |
Public method | LoadOneRowset |
Public method | LoadOneRowsetAsync |
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | MakeMailbox |
Public method | MakeScriptQueryHandler |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenCursor |
Public method | OpenCursorAsync |
Public method | OpenMailbox |
Public method | Save |
Public method | SaveAsync |
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Subscribe |
Public method | TestConnection |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | Update |
Public method | UpdateAsync |
Public method | Upsert |
Public method | UpsertAsync |
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | LoadEnumerable TRow | Loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadEnumerableAsync TRow | Async version - loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadRow TRow | Loads one row cast per Query(T) or null (Defined by DataUtils.)
Public Extension Method | LoadRowAsync TRow | Async version - loads one row cast per Query(T) or null (Defined by DataUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ErlDataStore Class
NFX.DataAccess.Erlang Namespace


ErlDataStore.BeginTransaction Method

ErlDataStore BeginTransaction Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual CRUDTransaction BeginTransaction(
    IsolationLevel iso = IsolationLevel.ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior.CommitOnDispose
)
public virtual CRUDTransaction BeginTransaction(
    IsolationLevel iso = IsolationLevel.ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior.CommitOnDispose
)
Public Overridable Function BeginTransaction (
    Optional iso As IsolationLevel = IsolationLevel.ReadCommitted,
    Optional behavior As TransactionDisposeBehavior = TransactionDisposeBehavior.CommitOnDispose
) As CRUDTransaction
Public Overridable Function BeginTransaction (
    Optional iso As IsolationLevel = IsolationLevel.ReadCommitted,
    Optional behavior As TransactionDisposeBehavior = TransactionDisposeBehavior.CommitOnDispose
) As CRUDTransaction
public:
virtual CRUDTransaction^ BeginTransaction(
    IsolationLevel iso = IsolationLevel::ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior::CommitOnDispose
)
public:
virtual CRUDTransaction^ BeginTransaction(
    IsolationLevel iso = IsolationLevel::ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior::CommitOnDispose
)
abstract BeginTransaction :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> CRUDTransaction
override BeginTransaction :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> CRUDTransaction
abstract BeginTransaction :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> CRUDTransaction
override BeginTransaction :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> CRUDTransaction

Parameters

iso (Optional)
Type: Online System.Data IsolationLevel
behavior (Optional)
Type: NFX.DataAccess.CRUD TransactionDisposeBehavior

Return Value

Type: CRUDTransaction

Implements

ICRUDTransactionOperations BeginTransaction(IsolationLevel, TransactionDisposeBehavior)
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.BeginTransactionAsync Method

ErlDataStore BeginTransactionAsync Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Task<CRUDTransaction> BeginTransactionAsync(
    IsolationLevel iso = IsolationLevel.ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior.CommitOnDispose
)
public virtual Task<CRUDTransaction> BeginTransactionAsync(
    IsolationLevel iso = IsolationLevel.ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior.CommitOnDispose
)
Public Overridable Function BeginTransactionAsync (
    Optional iso As IsolationLevel = IsolationLevel.ReadCommitted,
    Optional behavior As TransactionDisposeBehavior = TransactionDisposeBehavior.CommitOnDispose
) As Task(Of CRUDTransaction)
Public Overridable Function BeginTransactionAsync (
    Optional iso As IsolationLevel = IsolationLevel.ReadCommitted,
    Optional behavior As TransactionDisposeBehavior = TransactionDisposeBehavior.CommitOnDispose
) As Task(Of CRUDTransaction)
public:
virtual Task<CRUDTransaction^>^ BeginTransactionAsync(
    IsolationLevel iso = IsolationLevel::ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior::CommitOnDispose
)
public:
virtual Task<CRUDTransaction^>^ BeginTransactionAsync(
    IsolationLevel iso = IsolationLevel::ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior::CommitOnDispose
)
abstract BeginTransactionAsync :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> Task<CRUDTransaction>
override BeginTransactionAsync :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> Task<CRUDTransaction>
abstract BeginTransactionAsync :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> Task<CRUDTransaction>
override BeginTransactionAsync :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> Task<CRUDTransaction>

Parameters

iso (Optional)
Type: Online System.Data IsolationLevel
behavior (Optional)
Type: NFX.DataAccess.CRUD TransactionDisposeBehavior

Return Value

Type: Online Task CRUDTransaction

Implements

ICRUDTransactionOperations BeginTransactionAsync(IsolationLevel, TransactionDisposeBehavior)
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.CRUDWrite Method

ErlDataStore CRUDWrite Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual int CRUDWrite(
    Row row,
    bool delete = false
)
protected virtual int CRUDWrite(
    Row row,
    bool delete = false
)
Protected Overridable Function CRUDWrite (
    row As Row,
    Optional delete As Boolean = false
) As Integer
Protected Overridable Function CRUDWrite (
    row As Row,
    Optional delete As Boolean = false
) As Integer
protected:
virtual int CRUDWrite(
    Row^ row,
    bool delete = false
)
protected:
virtual int CRUDWrite(
    Row^ row,
    bool delete = false
)
abstract CRUDWrite :
        row : Row *
        ?delete : bool
(* Defaults:
        let _delete = defaultArg delete false
*)
-> int
override CRUDWrite :
        row : Row *
        ?delete : bool
(* Defaults:
        let _delete = defaultArg delete false
*)
-> int
abstract CRUDWrite :
        row : Row *
        ?delete : bool
(* Defaults:
        let _delete = defaultArg delete false
*)
-> int
override CRUDWrite :
        row : Row *
        ?delete : bool
(* Defaults:
        let _delete = defaultArg delete false
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
delete (Optional)
Type: Online System Boolean

Return Value

Type: Online Int32
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.DecompressBytes Method

ErlDataStore DecompressBytes Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal byte[] DecompressBytes(
    byte[] data
)
protected internal byte[] DecompressBytes(
    byte[] data
)
Protected Friend Function DecompressBytes (
    data As Byte()
) As Byte()
Protected Friend Function DecompressBytes (
    data As Byte()
) As Byte()
protected public:
array<unsigned char>^ DecompressBytes(
    array<unsigned char>^ data
)
protected public:
array<unsigned char>^ DecompressBytes(
    array<unsigned char>^ data
)
member DecompressBytes :
        data : byte[] -> byte[]
member DecompressBytes :
        data : byte[] -> byte[]

Parameters

data
Type: Online System Byte

Return Value

Type: Online Byte
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.DecompressString Method

ErlDataStore DecompressString Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal string DecompressString(
    byte[] data
)
protected internal string DecompressString(
    byte[] data
)
Protected Friend Function DecompressString (
    data As Byte()
) As String
Protected Friend Function DecompressString (
    data As Byte()
) As String
protected public:
String^ DecompressString(
    array<unsigned char>^ data
)
protected public:
String^ DecompressString(
    array<unsigned char>^ data
)
member DecompressString :
        data : byte[] -> string
member DecompressString :
        data : byte[] -> string

Parameters

data
Type: Online System Byte

Return Value

Type: Online String
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.Delete Method

ErlDataStore Delete Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Delete(
    Row row,
    IDataStoreKey key = null
)
public virtual int Delete(
    Row row,
    IDataStoreKey key = null
)
Public Overridable Function Delete (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Integer
Public Overridable Function Delete (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Integer
public:
virtual int Delete(
    Row^ row,
    IDataStoreKey^ key = nullptr
)
public:
virtual int Delete(
    Row^ row,
    IDataStoreKey^ key = nullptr
)
abstract Delete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int
override Delete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int
abstract Delete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int
override Delete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey

Return Value

Type: Online Int32

Implements

ICRUDOperations Delete(Row, IDataStoreKey)
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.DeleteAsync Method

ErlDataStore DeleteAsync Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Task<int> DeleteAsync(
    Row row,
    IDataStoreKey key = null
)
public virtual Task<int> DeleteAsync(
    Row row,
    IDataStoreKey key = null
)
Public Overridable Function DeleteAsync (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Task(Of Integer)
Public Overridable Function DeleteAsync (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Task(Of Integer)
public:
virtual Task<int>^ DeleteAsync(
    Row^ row,
    IDataStoreKey^ key = nullptr
)
public:
virtual Task<int>^ DeleteAsync(
    Row^ row,
    IDataStoreKey^ key = nullptr
)
abstract DeleteAsync :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> Task<int>
override DeleteAsync :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> Task<int>
abstract DeleteAsync :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> Task<int>
override DeleteAsync :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations DeleteAsync(Row, IDataStoreKey)
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.Destructor Method

ErlDataStore Destructor Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.DoSignalStop Method

ErlDataStore DoSignalStop Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSignalStop()
protected override void DoSignalStop()
Protected Overrides Sub DoSignalStop
Protected Overrides Sub DoSignalStop
protected:
virtual void DoSignalStop() override
protected:
virtual void DoSignalStop() override
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.DoStart Method

ErlDataStore DoStart Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.DoWaitForCompleteStop Method

ErlDataStore DoWaitForCompleteStop Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.ExecuteRPC Method

ErlDataStore ExecuteRPC Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal IErlObject ExecuteRPC(
    ErlAtom module,
    ErlAtom func,
    ErlList args,
    ErlMbox mbox = null
)
protected internal IErlObject ExecuteRPC(
    ErlAtom module,
    ErlAtom func,
    ErlList args,
    ErlMbox mbox = null
)
Protected Friend Function ExecuteRPC (
    module As ErlAtom,
    func As ErlAtom,
    args As ErlList,
    Optional mbox As ErlMbox = Nothing
) As IErlObject
Protected Friend Function ExecuteRPC (
    module As ErlAtom,
    func As ErlAtom,
    args As ErlList,
    Optional mbox As ErlMbox = Nothing
) As IErlObject
protected public:
IErlObject^ ExecuteRPC(
    ErlAtom module,
    ErlAtom func,
    ErlList^ args,
    ErlMbox^ mbox = nullptr
)
protected public:
IErlObject^ ExecuteRPC(
    ErlAtom module,
    ErlAtom func,
    ErlList^ args,
    ErlMbox^ mbox = nullptr
)
member ExecuteRPC :
        module : ErlAtom *
        func : ErlAtom *
        args : ErlList *
        ?mbox : ErlMbox
(* Defaults:
        let _mbox = defaultArg mbox null
*)
-> IErlObject
member ExecuteRPC :
        module : ErlAtom *
        func : ErlAtom *
        args : ErlList *
        ?mbox : ErlMbox
(* Defaults:
        let _mbox = defaultArg mbox null
*)
-> IErlObject

Parameters

module
Type: NFX.Erlang ErlAtom
func
Type: NFX.Erlang ErlAtom
args
Type: NFX.Erlang ErlList
mbox (Optional)
Type: NFX.Erlang ErlMbox

Return Value

Type: IErlObject
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.ExecuteWithoutFetch Method

ErlDataStore ExecuteWithoutFetch Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int ExecuteWithoutFetch(
    params Query[] queries
)
public virtual int ExecuteWithoutFetch(
    params Query[] queries
)
Public Overridable Function ExecuteWithoutFetch (
    ParamArray queries As Query()
) As Integer
Public Overridable Function ExecuteWithoutFetch (
    ParamArray queries As Query()
) As Integer
public:
virtual int ExecuteWithoutFetch(
    ... array<Query^>^ queries
)
public:
virtual int ExecuteWithoutFetch(
    ... array<Query^>^ queries
)
abstract ExecuteWithoutFetch :
        queries : Query[] -> int
override ExecuteWithoutFetch :
        queries : Query[] -> int
abstract ExecuteWithoutFetch :
        queries : Query[] -> int
override ExecuteWithoutFetch :
        queries : Query[] -> int

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Int32

Implements

ICRUDOperations ExecuteWithoutFetch( Query )
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.ExecuteWithoutFetchAsync Method

ErlDataStore ExecuteWithoutFetchAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Task<int> ExecuteWithoutFetchAsync(
    params Query[] queries
)
public virtual Task<int> ExecuteWithoutFetchAsync(
    params Query[] queries
)
Public Overridable Function ExecuteWithoutFetchAsync (
    ParamArray queries As Query()
) As Task(Of Integer)
Public Overridable Function ExecuteWithoutFetchAsync (
    ParamArray queries As Query()
) As Task(Of Integer)
public:
virtual Task<int>^ ExecuteWithoutFetchAsync(
    ... array<Query^>^ queries
)
public:
virtual Task<int>^ ExecuteWithoutFetchAsync(
    ... array<Query^>^ queries
)
abstract ExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>
override ExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>
abstract ExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>
override ExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations ExecuteWithoutFetchAsync( Query )
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.GetSchema Method

ErlDataStore GetSchema Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Schema GetSchema(
    Query query
)
public Schema GetSchema(
    Query query
)
Public Function GetSchema (
    query As Query
) As Schema
Public Function GetSchema (
    query As Query
) As Schema
public:
virtual Schema^ GetSchema(
    Query^ query
) sealed
public:
virtual Schema^ GetSchema(
    Query^ query
) sealed
abstract GetSchema :
        query : Query -> Schema
override GetSchema :
        query : Query -> Schema
abstract GetSchema :
        query : Query -> Schema
override GetSchema :
        query : Query -> Schema

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Schema

Implements

ICRUDOperations GetSchema(Query)
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.GetSchemaAsync Method

ErlDataStore GetSchemaAsync Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<Schema> GetSchemaAsync(
    Query query
)
public Task<Schema> GetSchemaAsync(
    Query query
)
Public Function GetSchemaAsync (
    query As Query
) As Task(Of Schema)
Public Function GetSchemaAsync (
    query As Query
) As Task(Of Schema)
public:
virtual Task<Schema^>^ GetSchemaAsync(
    Query^ query
) sealed
public:
virtual Task<Schema^>^ GetSchemaAsync(
    Query^ query
) sealed
abstract GetSchemaAsync :
        query : Query -> Task<Schema>
override GetSchemaAsync :
        query : Query -> Task<Schema>
abstract GetSchemaAsync :
        query : Query -> Task<Schema>
override GetSchemaAsync :
        query : Query -> Task<Schema>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Schema

Implements

ICRUDOperations GetSchemaAsync(Query)
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.Insert Method

ErlDataStore Insert Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Insert(
    Row row,
    FieldFilterFunc filter = null
)
public virtual int Insert(
    Row row,
    FieldFilterFunc filter = null
)
Public Overridable Function Insert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Public Overridable Function Insert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
public:
virtual int Insert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
public:
virtual int Insert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
abstract Insert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override Insert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
abstract Insert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override Insert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32

Implements

ICRUDOperations Insert(Row, FieldFilterFunc)
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.InsertAsync Method

ErlDataStore InsertAsync Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Task<int> InsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
public virtual Task<int> InsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
Public Overridable Function InsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
Public Overridable Function InsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
public:
virtual Task<int>^ InsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
public:
virtual Task<int>^ InsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
abstract InsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
override InsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
abstract InsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
override InsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations InsertAsync(Row, FieldFilterFunc)
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.Load Method

ErlDataStore Load Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual List<RowsetBase> Load(
    params Query[] queries
)
public virtual List<RowsetBase> Load(
    params Query[] queries
)
Public Overridable Function Load (
    ParamArray queries As Query()
) As List(Of RowsetBase)
Public Overridable Function Load (
    ParamArray queries As Query()
) As List(Of RowsetBase)
public:
virtual List<RowsetBase^>^ Load(
    ... array<Query^>^ queries
)
public:
virtual List<RowsetBase^>^ Load(
    ... array<Query^>^ queries
)
abstract Load :
        queries : Query[] -> List<RowsetBase>
override Load :
        queries : Query[] -> List<RowsetBase>
abstract Load :
        queries : Query[] -> List<RowsetBase>
override Load :
        queries : Query[] -> List<RowsetBase>

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online List RowsetBase

Implements

ICRUDOperations Load( Query )
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.LoadAsync Method

ErlDataStore LoadAsync Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Task<List<RowsetBase>> LoadAsync(
    params Query[] queries
)
public virtual Task<List<RowsetBase>> LoadAsync(
    params Query[] queries
)
Public Overridable Function LoadAsync (
    ParamArray queries As Query()
) As Task(Of List(Of RowsetBase))
Public Overridable Function LoadAsync (
    ParamArray queries As Query()
) As Task(Of List(Of RowsetBase))
public:
virtual Task<List<RowsetBase^>^>^ LoadAsync(
    ... array<Query^>^ queries
)
public:
virtual Task<List<RowsetBase^>^>^ LoadAsync(
    ... array<Query^>^ queries
)
abstract LoadAsync :
        queries : Query[] -> Task<List<RowsetBase>>
override LoadAsync :
        queries : Query[] -> Task<List<RowsetBase>>
abstract LoadAsync :
        queries : Query[] -> Task<List<RowsetBase>>
override LoadAsync :
        queries : Query[] -> Task<List<RowsetBase>>

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Online List RowsetBase

Implements

ICRUDOperations LoadAsync( Query )
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.LoadOneRow Method

ErlDataStore LoadOneRow Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Row LoadOneRow(
    Query query
)
public virtual Row LoadOneRow(
    Query query
)
Public Overridable Function LoadOneRow (
    query As Query
) As Row
Public Overridable Function LoadOneRow (
    query As Query
) As Row
public:
virtual Row^ LoadOneRow(
    Query^ query
)
public:
virtual Row^ LoadOneRow(
    Query^ query
)
abstract LoadOneRow :
        query : Query -> Row
override LoadOneRow :
        query : Query -> Row
abstract LoadOneRow :
        query : Query -> Row
override LoadOneRow :
        query : Query -> Row

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Row

Implements

ICRUDOperations LoadOneRow(Query)
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.LoadOneRowAsync Method

ErlDataStore LoadOneRowAsync Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Task<Row> LoadOneRowAsync(
    Query query
)
public virtual Task<Row> LoadOneRowAsync(
    Query query
)
Public Overridable Function LoadOneRowAsync (
    query As Query
) As Task(Of Row)
Public Overridable Function LoadOneRowAsync (
    query As Query
) As Task(Of Row)
public:
virtual Task<Row^>^ LoadOneRowAsync(
    Query^ query
)
public:
virtual Task<Row^>^ LoadOneRowAsync(
    Query^ query
)
abstract LoadOneRowAsync :
        query : Query -> Task<Row>
override LoadOneRowAsync :
        query : Query -> Task<Row>
abstract LoadOneRowAsync :
        query : Query -> Task<Row>
override LoadOneRowAsync :
        query : Query -> Task<Row>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Row

Implements

ICRUDOperations LoadOneRowAsync(Query)
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.LoadOneRowset Method

ErlDataStore LoadOneRowset Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual RowsetBase LoadOneRowset(
    Query query
)
public virtual RowsetBase LoadOneRowset(
    Query query
)
Public Overridable Function LoadOneRowset (
    query As Query
) As RowsetBase
Public Overridable Function LoadOneRowset (
    query As Query
) As RowsetBase
public:
virtual RowsetBase^ LoadOneRowset(
    Query^ query
)
public:
virtual RowsetBase^ LoadOneRowset(
    Query^ query
)
abstract LoadOneRowset :
        query : Query -> RowsetBase
override LoadOneRowset :
        query : Query -> RowsetBase
abstract LoadOneRowset :
        query : Query -> RowsetBase
override LoadOneRowset :
        query : Query -> RowsetBase

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: RowsetBase

Implements

ICRUDOperations LoadOneRowset(Query)
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.LoadOneRowsetAsync Method

ErlDataStore LoadOneRowsetAsync Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Task<RowsetBase> LoadOneRowsetAsync(
    Query query
)
public virtual Task<RowsetBase> LoadOneRowsetAsync(
    Query query
)
Public Overridable Function LoadOneRowsetAsync (
    query As Query
) As Task(Of RowsetBase)
Public Overridable Function LoadOneRowsetAsync (
    query As Query
) As Task(Of RowsetBase)
public:
virtual Task<RowsetBase^>^ LoadOneRowsetAsync(
    Query^ query
)
public:
virtual Task<RowsetBase^>^ LoadOneRowsetAsync(
    Query^ query
)
abstract LoadOneRowsetAsync :
        query : Query -> Task<RowsetBase>
override LoadOneRowsetAsync :
        query : Query -> Task<RowsetBase>
abstract LoadOneRowsetAsync :
        query : Query -> Task<RowsetBase>
override LoadOneRowsetAsync :
        query : Query -> Task<RowsetBase>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task RowsetBase

Implements

ICRUDOperations LoadOneRowsetAsync(Query)
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.MakeMailbox Method

ErlDataStore MakeMailbox Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ErlMbox MakeMailbox(
    string name = null
)
internal ErlMbox MakeMailbox(
    string name = null
)
Friend Function MakeMailbox (
    Optional name As String = Nothing
) As ErlMbox
Friend Function MakeMailbox (
    Optional name As String = Nothing
) As ErlMbox
internal:
ErlMbox^ MakeMailbox(
    String^ name = nullptr
)
internal:
ErlMbox^ MakeMailbox(
    String^ name = nullptr
)
internal member MakeMailbox :
        ?name : string
(* Defaults:
        let _name = defaultArg name null
*)
-> ErlMbox
internal member MakeMailbox :
        ?name : string
(* Defaults:
        let _name = defaultArg name null
*)
-> ErlMbox

Parameters

name (Optional)
Type: Online System String

Return Value

Type: ErlMbox
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.MakeScriptQueryHandler Method

ErlDataStore MakeScriptQueryHandler Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDQueryHandler MakeScriptQueryHandler(
    QuerySource querySource
)
public CRUDQueryHandler MakeScriptQueryHandler(
    QuerySource querySource
)
Public Function MakeScriptQueryHandler (
    querySource As QuerySource
) As CRUDQueryHandler
Public Function MakeScriptQueryHandler (
    querySource As QuerySource
) As CRUDQueryHandler
public:
virtual CRUDQueryHandler^ MakeScriptQueryHandler(
    QuerySource^ querySource
) sealed
public:
virtual CRUDQueryHandler^ MakeScriptQueryHandler(
    QuerySource^ querySource
) sealed
abstract MakeScriptQueryHandler :
        querySource : QuerySource -> CRUDQueryHandler
override MakeScriptQueryHandler :
        querySource : QuerySource -> CRUDQueryHandler
abstract MakeScriptQueryHandler :
        querySource : QuerySource -> CRUDQueryHandler
override MakeScriptQueryHandler :
        querySource : QuerySource -> CRUDQueryHandler

Parameters

querySource
Type: NFX.DataAccess.CRUD QuerySource

Return Value

Type: CRUDQueryHandler

Implements

ICRUDDataStoreImplementation MakeScriptQueryHandler(QuerySource)
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.OpenCursor Method

ErlDataStore OpenCursor Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Cursor OpenCursor(
    Query query
)
public Cursor OpenCursor(
    Query query
)
Public Function OpenCursor (
    query As Query
) As Cursor
Public Function OpenCursor (
    query As Query
) As Cursor
public:
virtual Cursor^ OpenCursor(
    Query^ query
) sealed
public:
virtual Cursor^ OpenCursor(
    Query^ query
) sealed
abstract OpenCursor :
        query : Query -> Cursor
override OpenCursor :
        query : Query -> Cursor
abstract OpenCursor :
        query : Query -> Cursor
override OpenCursor :
        query : Query -> Cursor

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Cursor

Implements

ICRUDOperations OpenCursor(Query)
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.OpenCursorAsync Method

ErlDataStore OpenCursorAsync Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<Cursor> OpenCursorAsync(
    Query query
)
public Task<Cursor> OpenCursorAsync(
    Query query
)
Public Function OpenCursorAsync (
    query As Query
) As Task(Of Cursor)
Public Function OpenCursorAsync (
    query As Query
) As Task(Of Cursor)
public:
virtual Task<Cursor^>^ OpenCursorAsync(
    Query^ query
) sealed
public:
virtual Task<Cursor^>^ OpenCursorAsync(
    Query^ query
) sealed
abstract OpenCursorAsync :
        query : Query -> Task<Cursor>
override OpenCursorAsync :
        query : Query -> Task<Cursor>
abstract OpenCursorAsync :
        query : Query -> Task<Cursor>
override OpenCursorAsync :
        query : Query -> Task<Cursor>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Cursor

Implements

ICRUDOperations OpenCursorAsync(Query)
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.OpenMailbox Method

ErlDataStore OpenMailbox Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Mailbox OpenMailbox(
    string name
)
public Mailbox OpenMailbox(
    string name
)
Public Function OpenMailbox (
    name As String
) As Mailbox
Public Function OpenMailbox (
    name As String
) As Mailbox
public:
virtual Mailbox^ OpenMailbox(
    String^ name
) sealed
public:
virtual Mailbox^ OpenMailbox(
    String^ name
) sealed
abstract OpenMailbox :
        name : string -> Mailbox
override OpenMailbox :
        name : string -> Mailbox
abstract OpenMailbox :
        name : string -> Mailbox
override OpenMailbox :
        name : string -> Mailbox

Parameters

name
Type: Online System String

Return Value

Type: Mailbox

Implements

ICRUDSubscriptionStore OpenMailbox(String)
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.Save Method

ErlDataStore Save Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Save(
    params RowsetBase[] rowsets
)
public virtual int Save(
    params RowsetBase[] rowsets
)
Public Overridable Function Save (
    ParamArray rowsets As RowsetBase()
) As Integer
Public Overridable Function Save (
    ParamArray rowsets As RowsetBase()
) As Integer
public:
virtual int Save(
    ... array<RowsetBase^>^ rowsets
)
public:
virtual int Save(
    ... array<RowsetBase^>^ rowsets
)
abstract Save :
        rowsets : RowsetBase[] -> int
override Save :
        rowsets : RowsetBase[] -> int
abstract Save :
        rowsets : RowsetBase[] -> int
override Save :
        rowsets : RowsetBase[] -> int

Parameters

rowsets
Type: NFX.DataAccess.CRUD RowsetBase

Return Value

Type: Online Int32

Implements

ICRUDOperations Save( RowsetBase )
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.SaveAsync Method

ErlDataStore SaveAsync Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Task<int> SaveAsync(
    params RowsetBase[] rowsets
)
public virtual Task<int> SaveAsync(
    params RowsetBase[] rowsets
)
Public Overridable Function SaveAsync (
    ParamArray rowsets As RowsetBase()
) As Task(Of Integer)
Public Overridable Function SaveAsync (
    ParamArray rowsets As RowsetBase()
) As Task(Of Integer)
public:
virtual Task<int>^ SaveAsync(
    ... array<RowsetBase^>^ rowsets
)
public:
virtual Task<int>^ SaveAsync(
    ... array<RowsetBase^>^ rowsets
)
abstract SaveAsync :
        rowsets : RowsetBase[] -> Task<int>
override SaveAsync :
        rowsets : RowsetBase[] -> Task<int>
abstract SaveAsync :
        rowsets : RowsetBase[] -> Task<int>
override SaveAsync :
        rowsets : RowsetBase[] -> Task<int>

Parameters

rowsets
Type: NFX.DataAccess.CRUD RowsetBase

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations SaveAsync( RowsetBase )
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.Subscribe Method

ErlDataStore Subscribe Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Subscription Subscribe(
    string name,
    Query query,
    Mailbox recipient,
    Object correlate = null
)
public Subscription Subscribe(
    string name,
    Query query,
    Mailbox recipient,
    Object correlate = null
)
Public Function Subscribe (
    name As String,
    query As Query,
    recipient As Mailbox,
    Optional correlate As Object = Nothing
) As Subscription
Public Function Subscribe (
    name As String,
    query As Query,
    recipient As Mailbox,
    Optional correlate As Object = Nothing
) As Subscription
public:
virtual Subscription^ Subscribe(
    String^ name,
    Query^ query,
    Mailbox^ recipient,
    Object^ correlate = nullptr
) sealed
public:
virtual Subscription^ Subscribe(
    String^ name,
    Query^ query,
    Mailbox^ recipient,
    Object^ correlate = nullptr
) sealed
abstract Subscribe :
        name : string *
        query : Query *
        recipient : Mailbox *
        ?correlate : Object
(* Defaults:
        let _correlate = defaultArg correlate null
*)
-> Subscription
override Subscribe :
        name : string *
        query : Query *
        recipient : Mailbox *
        ?correlate : Object
(* Defaults:
        let _correlate = defaultArg correlate null
*)
-> Subscription
abstract Subscribe :
        name : string *
        query : Query *
        recipient : Mailbox *
        ?correlate : Object
(* Defaults:
        let _correlate = defaultArg correlate null
*)
-> Subscription
override Subscribe :
        name : string *
        query : Query *
        recipient : Mailbox *
        ?correlate : Object
(* Defaults:
        let _correlate = defaultArg correlate null
*)
-> Subscription

Parameters

name
Type: Online System String
query
Type: NFX.DataAccess.CRUD Query
recipient
Type: NFX.DataAccess.CRUD.Subscriptions Mailbox
correlate (Optional)
Type: Online System Object

Return Value

Type: Subscription

Implements

ICRUDSubscriptionStore Subscribe(String, Query, Mailbox, Object)
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.TestConnection Method

ErlDataStore TestConnection Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void TestConnection()
public void TestConnection()
Public Sub TestConnection
Public Sub TestConnection
public:
virtual void TestConnection() sealed
public:
virtual void TestConnection() sealed
abstract TestConnection : unit -> unit
override TestConnection : unit -> unit
abstract TestConnection : unit -> unit
override TestConnection : unit -> unit

Implements

IDataStore TestConnection
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.Update Method

ErlDataStore Update Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Update(
    Row row,
    IDataStoreKey key = null,
    FieldFilterFunc filter = null
)
public virtual int Update(
    Row row,
    IDataStoreKey key = null,
    FieldFilterFunc filter = null
)
Public Overridable Function Update (
    row As Row,
    Optional key As IDataStoreKey = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Public Overridable Function Update (
    row As Row,
    Optional key As IDataStoreKey = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
public:
virtual int Update(
    Row^ row,
    IDataStoreKey^ key = nullptr,
    FieldFilterFunc^ filter = nullptr
)
public:
virtual int Update(
    Row^ row,
    IDataStoreKey^ key = nullptr,
    FieldFilterFunc^ filter = nullptr
)
abstract Update :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> int
override Update :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> int
abstract Update :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> int
override Update :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32

Implements

ICRUDOperations Update(Row, IDataStoreKey, FieldFilterFunc)
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.UpdateAsync Method

ErlDataStore UpdateAsync Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Task<int> UpdateAsync(
    Row row,
    IDataStoreKey key = null,
    FieldFilterFunc filter = null
)
public virtual Task<int> UpdateAsync(
    Row row,
    IDataStoreKey key = null,
    FieldFilterFunc filter = null
)
Public Overridable Function UpdateAsync (
    row As Row,
    Optional key As IDataStoreKey = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
Public Overridable Function UpdateAsync (
    row As Row,
    Optional key As IDataStoreKey = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
public:
virtual Task<int>^ UpdateAsync(
    Row^ row,
    IDataStoreKey^ key = nullptr,
    FieldFilterFunc^ filter = nullptr
)
public:
virtual Task<int>^ UpdateAsync(
    Row^ row,
    IDataStoreKey^ key = nullptr,
    FieldFilterFunc^ filter = nullptr
)
abstract UpdateAsync :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> Task<int>
override UpdateAsync :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> Task<int>
abstract UpdateAsync :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> Task<int>
override UpdateAsync :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations UpdateAsync(Row, IDataStoreKey, FieldFilterFunc)
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.Upsert Method

ErlDataStore Upsert Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Upsert(
    Row row,
    FieldFilterFunc filter = null
)
public virtual int Upsert(
    Row row,
    FieldFilterFunc filter = null
)
Public Overridable Function Upsert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Public Overridable Function Upsert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
public:
virtual int Upsert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
public:
virtual int Upsert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
abstract Upsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override Upsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
abstract Upsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override Upsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32

Implements

ICRUDOperations Upsert(Row, FieldFilterFunc)
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.UpsertAsync Method

ErlDataStore UpsertAsync Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Task<int> UpsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
public virtual Task<int> UpsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
Public Overridable Function UpsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
Public Overridable Function UpsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
public:
virtual Task<int>^ UpsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
public:
virtual Task<int>^ UpsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
abstract UpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
override UpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
abstract UpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
override UpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations UpsertAsync(Row, FieldFilterFunc)
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore Properties

ErlDataStore Properties NFX Class Library

The ErlDataStore type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | CallTimeoutMs |
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | InstrumentationEnabled | (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | LocalName | Shortcut to ErlApp.Node name
Public property | LogLevel |
Public property | Mailboxes |
Protected property | Map | Returns the map lazily obtaining it when needed
Public property | Name | Provides textual name for the service (Inherited from Service.)
Protected property | NextRequestID | Generates nest sequential request ID
Public property | QueryResolver |
Public property | RemoteCookie |
Public property | RemoteName |
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | ScriptFileSuffix |
Public property | Status | Current service status (Inherited from Service.)
Public property | StoreType |
Public property | Subscriptions |
Public property | SupportsTransactions |
Public property | SupportsTrueAsynchrony |
Public property | TargetName |
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
ErlDataStore Class
NFX.DataAccess.Erlang Namespace


ErlDataStore.CallTimeoutMs Property

ErlDataStore CallTimeoutMs Property NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int CallTimeoutMs { get; set; }
[ConfigAttribute]
public int CallTimeoutMs { get; set; }
<ConfigAttribute>
Public Property CallTimeoutMs As Integer
    Get
    Set
<ConfigAttribute>
Public Property CallTimeoutMs As Integer
    Get
    Set
public:
[ConfigAttribute]
property int CallTimeoutMs {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute]
property int CallTimeoutMs {
    int get ();
    void set (int value);
}
[<ConfigAttribute>]
member CallTimeoutMs : int with get, set
[<ConfigAttribute>]
member CallTimeoutMs : int with get, set

Property Value

Type: Online Int32
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.InstrumentationEnabled Property

ErlDataStore InstrumentationEnabled Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(new string[] { ... })]
public override bool InstrumentationEnabled { get; set; }
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(new string[] { ... })]
public override bool InstrumentationEnabled { get; set; }
<ConfigAttribute(Default := false)>
<ExternalParameterAttribute(New String() { ... })>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
<ConfigAttribute(Default := false)>
<ExternalParameterAttribute(New String() { ... })>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
public:
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
public:
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
abstract InstrumentationEnabled : bool with get, set
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
override InstrumentationEnabled : bool with get, set
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
abstract InstrumentationEnabled : bool with get, set
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
override InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentable InstrumentationEnabled
IInstrumentable InstrumentationEnabled
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.LocalName Property

ErlDataStore LocalName Property NFX Class Library

Shortcut to ErlApp.Node name

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string LocalName { get; }
public string LocalName { get; }
Public ReadOnly Property LocalName As String
    Get
Public ReadOnly Property LocalName As String
    Get
public:
property String^ LocalName {
    String^ get ();
}
public:
property String^ LocalName {
    String^ get ();
}
member LocalName : string with get
member LocalName : string with get

Property Value

Type: Online String
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.LogLevel Property

ErlDataStore LogLevel Property NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public StoreLogLevel LogLevel { get; set; }
[ConfigAttribute]
public StoreLogLevel LogLevel { get; set; }
<ConfigAttribute>
Public Property LogLevel As StoreLogLevel
    Get
    Set
<ConfigAttribute>
Public Property LogLevel As StoreLogLevel
    Get
    Set
public:
[ConfigAttribute]
virtual property StoreLogLevel LogLevel {
    StoreLogLevel get () sealed;
    void set (StoreLogLevel value) sealed;
}
public:
[ConfigAttribute]
virtual property StoreLogLevel LogLevel {
    StoreLogLevel get () sealed;
    void set (StoreLogLevel value) sealed;
}
[<ConfigAttribute>]
abstract LogLevel : StoreLogLevel with get, set
[<ConfigAttribute>]
override LogLevel : StoreLogLevel with get, set
[<ConfigAttribute>]
abstract LogLevel : StoreLogLevel with get, set
[<ConfigAttribute>]
override LogLevel : StoreLogLevel with get, set

Property Value

Type: StoreLogLevel

Implements

IDataStoreImplementation LogLevel
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.Mailboxes Property

ErlDataStore Mailboxes Property NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<Mailbox> Mailboxes { get; }
public IRegistry<Mailbox> Mailboxes { get; }
Public ReadOnly Property Mailboxes As IRegistry(Of Mailbox)
    Get
Public ReadOnly Property Mailboxes As IRegistry(Of Mailbox)
    Get
public:
virtual property IRegistry<Mailbox^>^ Mailboxes {
    IRegistry<Mailbox^>^ get () sealed;
}
public:
virtual property IRegistry<Mailbox^>^ Mailboxes {
    IRegistry<Mailbox^>^ get () sealed;
}
abstract Mailboxes : IRegistry<Mailbox> with get
override Mailboxes : IRegistry<Mailbox> with get
abstract Mailboxes : IRegistry<Mailbox> with get
override Mailboxes : IRegistry<Mailbox> with get

Property Value

Type: IRegistry Mailbox

Implements

ICRUDSubscriptionStore Mailboxes
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.Map Property

ErlDataStore Map Property NFX Class Library

Returns the map lazily obtaining it when needed

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal SchemaMap Map { get; }
protected internal SchemaMap Map { get; }
Protected Friend ReadOnly Property Map As SchemaMap
    Get
Protected Friend ReadOnly Property Map As SchemaMap
    Get
protected public:
property SchemaMap^ Map {
    SchemaMap^ get ();
}
protected public:
property SchemaMap^ Map {
    SchemaMap^ get ();
}
member Map : SchemaMap with get
member Map : SchemaMap with get

Property Value

Type: SchemaMap
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.NextRequestID Property

ErlDataStore NextRequestID Property NFX Class Library

Generates nest sequential request ID

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal int NextRequestID { get; }
protected internal int NextRequestID { get; }
Protected Friend ReadOnly Property NextRequestID As Integer
    Get
Protected Friend ReadOnly Property NextRequestID As Integer
    Get
protected public:
property int NextRequestID {
    int get ();
}
protected public:
property int NextRequestID {
    int get ();
}
member NextRequestID : int with get
member NextRequestID : int with get

Property Value

Type: Online Int32
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.QueryResolver Property

ErlDataStore QueryResolver Property NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICRUDQueryResolver QueryResolver { get; }
public ICRUDQueryResolver QueryResolver { get; }
Public ReadOnly Property QueryResolver As ICRUDQueryResolver
    Get
Public ReadOnly Property QueryResolver As ICRUDQueryResolver
    Get
public:
virtual property ICRUDQueryResolver^ QueryResolver {
    ICRUDQueryResolver^ get () sealed;
}
public:
virtual property ICRUDQueryResolver^ QueryResolver {
    ICRUDQueryResolver^ get () sealed;
}
abstract QueryResolver : ICRUDQueryResolver with get
override QueryResolver : ICRUDQueryResolver with get
abstract QueryResolver : ICRUDQueryResolver with get
override QueryResolver : ICRUDQueryResolver with get

Property Value

Type: ICRUDQueryResolver

Implements

ICRUDDataStore QueryResolver
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.RemoteCookie Property

ErlDataStore RemoteCookie Property NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string RemoteCookie { get; set; }
[ConfigAttribute]
public string RemoteCookie { get; set; }
<ConfigAttribute>
Public Property RemoteCookie As String
    Get
    Set
<ConfigAttribute>
Public Property RemoteCookie As String
    Get
    Set
public:
[ConfigAttribute]
property String^ RemoteCookie {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ RemoteCookie {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member RemoteCookie : string with get, set
[<ConfigAttribute>]
member RemoteCookie : string with get, set

Property Value

Type: Online String
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.RemoteName Property

ErlDataStore RemoteName Property NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string RemoteName { get; set; }
[ConfigAttribute]
public string RemoteName { get; set; }
<ConfigAttribute>
Public Property RemoteName As String
    Get
    Set
<ConfigAttribute>
Public Property RemoteName As String
    Get
    Set
public:
[ConfigAttribute]
property String^ RemoteName {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ RemoteName {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member RemoteName : string with get, set
[<ConfigAttribute>]
member RemoteName : string with get, set

Property Value

Type: Online String
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.ScriptFileSuffix Property

ErlDataStore ScriptFileSuffix Property NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ScriptFileSuffix { get; }
public string ScriptFileSuffix { get; }
Public ReadOnly Property ScriptFileSuffix As String
    Get
Public ReadOnly Property ScriptFileSuffix As String
    Get
public:
virtual property String^ ScriptFileSuffix {
    String^ get () sealed;
}
public:
virtual property String^ ScriptFileSuffix {
    String^ get () sealed;
}
abstract ScriptFileSuffix : string with get
override ScriptFileSuffix : string with get
abstract ScriptFileSuffix : string with get
override ScriptFileSuffix : string with get

Property Value

Type: Online String

Implements

ICRUDDataStore ScriptFileSuffix
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.StoreType Property

ErlDataStore StoreType Property NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDDataStoreType StoreType { get; }
public CRUDDataStoreType StoreType { get; }
Public ReadOnly Property StoreType As CRUDDataStoreType
    Get
Public ReadOnly Property StoreType As CRUDDataStoreType
    Get
public:
virtual property CRUDDataStoreType StoreType {
    CRUDDataStoreType get () sealed;
}
public:
virtual property CRUDDataStoreType StoreType {
    CRUDDataStoreType get () sealed;
}
abstract StoreType : CRUDDataStoreType with get
override StoreType : CRUDDataStoreType with get
abstract StoreType : CRUDDataStoreType with get
override StoreType : CRUDDataStoreType with get

Property Value

Type: CRUDDataStoreType

Implements

ICRUDDataStore StoreType
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.Subscriptions Property

ErlDataStore Subscriptions Property NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<Subscription> Subscriptions { get; }
public IRegistry<Subscription> Subscriptions { get; }
Public ReadOnly Property Subscriptions As IRegistry(Of Subscription)
    Get
Public ReadOnly Property Subscriptions As IRegistry(Of Subscription)
    Get
public:
virtual property IRegistry<Subscription^>^ Subscriptions {
    IRegistry<Subscription^>^ get () sealed;
}
public:
virtual property IRegistry<Subscription^>^ Subscriptions {
    IRegistry<Subscription^>^ get () sealed;
}
abstract Subscriptions : IRegistry<Subscription> with get
override Subscriptions : IRegistry<Subscription> with get
abstract Subscriptions : IRegistry<Subscription> with get
override Subscriptions : IRegistry<Subscription> with get

Property Value

Type: IRegistry Subscription

Implements

ICRUDSubscriptionStore Subscriptions
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.SupportsTransactions Property

ErlDataStore SupportsTransactions Property NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsTransactions { get; }
public bool SupportsTransactions { get; }
Public ReadOnly Property SupportsTransactions As Boolean
    Get
Public ReadOnly Property SupportsTransactions As Boolean
    Get
public:
virtual property bool SupportsTransactions {
    bool get () sealed;
}
public:
virtual property bool SupportsTransactions {
    bool get () sealed;
}
abstract SupportsTransactions : bool with get
override SupportsTransactions : bool with get
abstract SupportsTransactions : bool with get
override SupportsTransactions : bool with get

Property Value

Type: Online Boolean

Implements

ICRUDTransactionOperations SupportsTransactions
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.SupportsTrueAsynchrony Property

ErlDataStore SupportsTrueAsynchrony Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsTrueAsynchrony { get; }
public bool SupportsTrueAsynchrony { get; }
Public ReadOnly Property SupportsTrueAsynchrony As Boolean
    Get
Public ReadOnly Property SupportsTrueAsynchrony As Boolean
    Get
public:
virtual property bool SupportsTrueAsynchrony {
    bool get () sealed;
}
public:
virtual property bool SupportsTrueAsynchrony {
    bool get () sealed;
}
abstract SupportsTrueAsynchrony : bool with get
override SupportsTrueAsynchrony : bool with get
abstract SupportsTrueAsynchrony : bool with get
override SupportsTrueAsynchrony : bool with get

Property Value

Type: Online Boolean

Implements

ICRUDOperations SupportsTrueAsynchrony
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlDataStore.TargetName Property

ErlDataStore TargetName Property NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string TargetName { get; set; }
[ConfigAttribute]
public string TargetName { get; set; }
<ConfigAttribute>
Public Property TargetName As String
    Get
    Set
<ConfigAttribute>
Public Property TargetName As String
    Get
    Set
public:
[ConfigAttribute]
virtual property String^ TargetName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
[ConfigAttribute]
virtual property String^ TargetName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
[<ConfigAttribute>]
abstract TargetName : string with get, set
[<ConfigAttribute>]
override TargetName : string with get, set
[<ConfigAttribute>]
abstract TargetName : string with get, set
[<ConfigAttribute>]
override TargetName : string with get, set

Property Value

Type: Online String

Implements

IDataStore TargetName
See Also
ErlDataStore Class
ErlDataStore Members
NFX.DataAccess.Erlang Namespace


ErlServerSchemaChangedException Class

ErlServerSchemaChangedException Class NFX Class Library

Thrown by Erlang data schema map when server has changed schema. The client needs to restart or kill all cached data and refetch schema
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.DataAccess DataAccessException
NFX.DataAccess.Erlang ErlDataAccessException
NFX.DataAccess.Erlang ErlServerSchemaChangedException

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ErlServerSchemaChangedException : ErlDataAccessException
[SerializableAttribute]
public class ErlServerSchemaChangedException : ErlDataAccessException
<SerializableAttribute>
Public Class ErlServerSchemaChangedException
    Inherits ErlDataAccessException
<SerializableAttribute>
Public Class ErlServerSchemaChangedException
    Inherits ErlDataAccessException
[SerializableAttribute]
public ref class ErlServerSchemaChangedException : public ErlDataAccessException
[SerializableAttribute]
public ref class ErlServerSchemaChangedException : public ErlDataAccessException
[<SerializableAttribute>]
type ErlServerSchemaChangedException =
    class
        inherit ErlDataAccessException
    end
[<SerializableAttribute>]
type ErlServerSchemaChangedException =
    class
        inherit ErlDataAccessException
    end
See Also
ErlServerSchemaChangedException Members
NFX.DataAccess.Erlang Namespace


ErlServerSchemaChangedException Members

ErlServerSchemaChangedException Members NFX Class Library

The ErlServerSchemaChangedException type exposes the following members.
Constructors
 | Name | Description
Public method | ErlServerSchemaChangedException | Initializes a new instance of the ErlServerSchemaChangedException class
Protected method | ErlServerSchemaChangedException(SerializationInfo, StreamingContext) | Initializes a new instance of the ErlServerSchemaChangedException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ErlServerSchemaChangedException Class
NFX.DataAccess.Erlang Namespace


ErlServerSchemaChangedException Constructor

ErlServerSchemaChangedException Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public method | ErlServerSchemaChangedException | Initializes a new instance of the ErlServerSchemaChangedException class
Protected method | ErlServerSchemaChangedException(SerializationInfo, StreamingContext) | Initializes a new instance of the ErlServerSchemaChangedException class
Back to Top
See Also
ErlServerSchemaChangedException Class
ErlServerSchemaChangedException Members
NFX.DataAccess.Erlang Namespace


ErlServerSchemaChangedException Constructor

ErlServerSchemaChangedException Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlServerSchemaChangedException class

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlServerSchemaChangedException()
public ErlServerSchemaChangedException()
Public Sub New
Public Sub New
public:
ErlServerSchemaChangedException()
public:
ErlServerSchemaChangedException()
new : unit -> ErlServerSchemaChangedException
new : unit -> ErlServerSchemaChangedException
See Also
ErlServerSchemaChangedException Class
ErlServerSchemaChangedException Members
ErlServerSchemaChangedException Overload
NFX.DataAccess.Erlang Namespace


ErlServerSchemaChangedException Constructor (SerializationInfo, StreamingContext)

ErlServerSchemaChangedException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlServerSchemaChangedException class

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ErlServerSchemaChangedException(
    SerializationInfo info,
    StreamingContext context
)
protected ErlServerSchemaChangedException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
ErlServerSchemaChangedException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
ErlServerSchemaChangedException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ErlServerSchemaChangedException
new :
        info : SerializationInfo *
        context : StreamingContext -> ErlServerSchemaChangedException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
ErlServerSchemaChangedException Class
ErlServerSchemaChangedException Members
ErlServerSchemaChangedException Overload
NFX.DataAccess.Erlang Namespace


ErlServerSchemaChangedException Fields

ErlServerSchemaChangedException Fields NFX Class Library

The ErlServerSchemaChangedException type exposes the following members.
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
See Also
ErlServerSchemaChangedException Class
NFX.DataAccess.Erlang Namespace


ErlServerSchemaChangedException Methods

ErlServerSchemaChangedException Methods NFX Class Library

The ErlServerSchemaChangedException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
ErlServerSchemaChangedException Class
NFX.DataAccess.Erlang Namespace


ErlServerSchemaChangedException Properties

ErlServerSchemaChangedException Properties NFX Class Library

The ErlServerSchemaChangedException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
ErlServerSchemaChangedException Class
NFX.DataAccess.Erlang Namespace


ErlServerSchemaChangedException Events

ErlServerSchemaChangedException Events NFX Class Library

The ErlServerSchemaChangedException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ErlServerSchemaChangedException Class
NFX.DataAccess.Erlang Namespace


SchemaMap Class

SchemaMap Class NFX Class Library

Maps Erlang schemas -> CRUD and CRUD -> Erlang
Inheritance Hierarchy
Online System Object
NFX.DataAccess.Erlang SchemaMap

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SchemaMap
public class SchemaMap
Public Class SchemaMap
Public Class SchemaMap
public ref class SchemaMap
public ref class SchemaMap
type SchemaMap =  class end
type SchemaMap =  class end
See Also
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap Members

SchemaMap Members NFX Class Library

The SchemaMap type exposes the following members.
Constructors
 | Name | Description
Public method | SchemaMap | Initializes a new instance of the SchemaMap class
Back to Top
Methods
 | Name | Description
 | ClrToErlValue |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ErlCRUDResponseToRowset | Converts ErlCRUD response to CLR CRUD rowset
 | ErlSchemaToCRUDSchema |
 | ErlToClrValue |
Public method | ErlTupleToRow | Maps ErlRow to CLR row supplied by schema, either Dynamic or TypedRow
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetCRUDSchemaForName |
Public method | GetErlSchemaSection | Returns config section for named erl schema or null
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RowToErlTuple | Converts CLR row data into ErlTuple
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | _NeedReconnect |
 | CONFIG_CASE_ATTR |
 | CONFIG_CODE_ATTR |
 | CONFIG_DEFAULT_ATTR |
 | CONFIG_DELETE_ATTR |
 | CONFIG_DESCR_ATTR |
 | CONFIG_DISPLAY_ATTR |
 | CONFIG_DISPLAY_FORMAT_ATTR |
 | CONFIG_FIELD_SECTION |
 | CONFIG_FORMAT_ATTR |
 | CONFIG_FORMAT_DESCR_ATTR |
 | CONFIG_INSERT_ATTR |
 | CONFIG_KEY_ATTR |
 | CONFIG_LEN_ATTR |
 | CONFIG_MAX_ATTR |
 | CONFIG_MIN_ATTR |
 | CONFIG_REQUIRED_ATTR |
 | CONFIG_SCHEMA_SECTION |
 | CONFIG_TITLE_ATTR |
 | CONFIG_TYPE_ATTR |
 | CONFIG_UPDATE_ATTR |
 | CONFIG_VALUE_SECTION |
 | CONFIG_VISIBLE_ATTR |
Back to Top
Properties
 | Name | Description
Public property | ErlSchemaSections | Enumerates all Erl schemas
Public property | OriginalXMLContent |
Public property | Store |
Back to Top
See Also
SchemaMap Class
NFX.DataAccess.Erlang Namespace


SchemaMap Constructor

SchemaMap Constructor NFX Class Library

Initializes a new instance of the SchemaMap class

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SchemaMap(
    ErlDataStore store,
    string xmlContent
)
public SchemaMap(
    ErlDataStore store,
    string xmlContent
)
Public Sub New (
    store As ErlDataStore,
    xmlContent As String
)
Public Sub New (
    store As ErlDataStore,
    xmlContent As String
)
public:
SchemaMap(
    ErlDataStore^ store,
    String^ xmlContent
)
public:
SchemaMap(
    ErlDataStore^ store,
    String^ xmlContent
)
new :
        store : ErlDataStore *
        xmlContent : string -> SchemaMap
new :
        store : ErlDataStore *
        xmlContent : string -> SchemaMap

Parameters

store
Type: NFX.DataAccess.Erlang ErlDataStore
xmlContent
Type: Online System String
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap Fields

SchemaMap Fields NFX Class Library

The SchemaMap type exposes the following members.
Fields
 | Name | Description
Protected field | _NeedReconnect |
 | CONFIG_CASE_ATTR |
 | CONFIG_CODE_ATTR |
 | CONFIG_DEFAULT_ATTR |
 | CONFIG_DELETE_ATTR |
 | CONFIG_DESCR_ATTR |
 | CONFIG_DISPLAY_ATTR |
 | CONFIG_DISPLAY_FORMAT_ATTR |
 | CONFIG_FIELD_SECTION |
 | CONFIG_FORMAT_ATTR |
 | CONFIG_FORMAT_DESCR_ATTR |
 | CONFIG_INSERT_ATTR |
 | CONFIG_KEY_ATTR |
 | CONFIG_LEN_ATTR |
 | CONFIG_MAX_ATTR |
 | CONFIG_MIN_ATTR |
 | CONFIG_REQUIRED_ATTR |
 | CONFIG_SCHEMA_SECTION |
 | CONFIG_TITLE_ATTR |
 | CONFIG_TYPE_ATTR |
 | CONFIG_UPDATE_ATTR |
 | CONFIG_VALUE_SECTION |
 | CONFIG_VISIBLE_ATTR |
Back to Top
See Also
SchemaMap Class
NFX.DataAccess.Erlang Namespace


SchemaMap._NeedReconnect Field

SchemaMap _NeedReconnect Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal bool _NeedReconnect
internal bool _NeedReconnect
Friend _NeedReconnect As Boolean
Friend _NeedReconnect As Boolean
internal:
bool _NeedReconnect
internal:
bool _NeedReconnect
val mutable internal _NeedReconnect: bool
val mutable internal _NeedReconnect: bool

Field Value

Type: Online Boolean
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.CONFIG_CASE_ATTR Field

SchemaMap CONFIG_CASE_ATTR Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CASE_ATTR
public const string CONFIG_CASE_ATTR
Public Const CONFIG_CASE_ATTR As String
Public Const CONFIG_CASE_ATTR As String
public:
literal String^ CONFIG_CASE_ATTR
public:
literal String^ CONFIG_CASE_ATTR
static val mutable CONFIG_CASE_ATTR: string
static val mutable CONFIG_CASE_ATTR: string

Field Value

Type: Online String
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.CONFIG_CODE_ATTR Field

SchemaMap CONFIG_CODE_ATTR Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CODE_ATTR
public const string CONFIG_CODE_ATTR
Public Const CONFIG_CODE_ATTR As String
Public Const CONFIG_CODE_ATTR As String
public:
literal String^ CONFIG_CODE_ATTR
public:
literal String^ CONFIG_CODE_ATTR
static val mutable CONFIG_CODE_ATTR: string
static val mutable CONFIG_CODE_ATTR: string

Field Value

Type: Online String
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.CONFIG_DEFAULT_ATTR Field

SchemaMap CONFIG_DEFAULT_ATTR Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_DEFAULT_ATTR
public const string CONFIG_DEFAULT_ATTR
Public Const CONFIG_DEFAULT_ATTR As String
Public Const CONFIG_DEFAULT_ATTR As String
public:
literal String^ CONFIG_DEFAULT_ATTR
public:
literal String^ CONFIG_DEFAULT_ATTR
static val mutable CONFIG_DEFAULT_ATTR: string
static val mutable CONFIG_DEFAULT_ATTR: string

Field Value

Type: Online String
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.CONFIG_DELETE_ATTR Field

SchemaMap CONFIG_DELETE_ATTR Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_DELETE_ATTR
public const string CONFIG_DELETE_ATTR
Public Const CONFIG_DELETE_ATTR As String
Public Const CONFIG_DELETE_ATTR As String
public:
literal String^ CONFIG_DELETE_ATTR
public:
literal String^ CONFIG_DELETE_ATTR
static val mutable CONFIG_DELETE_ATTR: string
static val mutable CONFIG_DELETE_ATTR: string

Field Value

Type: Online String
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.CONFIG_DESCR_ATTR Field

SchemaMap CONFIG_DESCR_ATTR Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_DESCR_ATTR
public const string CONFIG_DESCR_ATTR
Public Const CONFIG_DESCR_ATTR As String
Public Const CONFIG_DESCR_ATTR As String
public:
literal String^ CONFIG_DESCR_ATTR
public:
literal String^ CONFIG_DESCR_ATTR
static val mutable CONFIG_DESCR_ATTR: string
static val mutable CONFIG_DESCR_ATTR: string

Field Value

Type: Online String
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.CONFIG_DISPLAY_ATTR Field

SchemaMap CONFIG_DISPLAY_ATTR Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_DISPLAY_ATTR
public const string CONFIG_DISPLAY_ATTR
Public Const CONFIG_DISPLAY_ATTR As String
Public Const CONFIG_DISPLAY_ATTR As String
public:
literal String^ CONFIG_DISPLAY_ATTR
public:
literal String^ CONFIG_DISPLAY_ATTR
static val mutable CONFIG_DISPLAY_ATTR: string
static val mutable CONFIG_DISPLAY_ATTR: string

Field Value

Type: Online String
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.CONFIG_DISPLAY_FORMAT_ATTR Field

SchemaMap CONFIG_DISPLAY_FORMAT_ATTR Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_DISPLAY_FORMAT_ATTR
public const string CONFIG_DISPLAY_FORMAT_ATTR
Public Const CONFIG_DISPLAY_FORMAT_ATTR As String
Public Const CONFIG_DISPLAY_FORMAT_ATTR As String
public:
literal String^ CONFIG_DISPLAY_FORMAT_ATTR
public:
literal String^ CONFIG_DISPLAY_FORMAT_ATTR
static val mutable CONFIG_DISPLAY_FORMAT_ATTR: string
static val mutable CONFIG_DISPLAY_FORMAT_ATTR: string

Field Value

Type: Online String
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.CONFIG_FIELD_SECTION Field

SchemaMap CONFIG_FIELD_SECTION Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_FIELD_SECTION
public const string CONFIG_FIELD_SECTION
Public Const CONFIG_FIELD_SECTION As String
Public Const CONFIG_FIELD_SECTION As String
public:
literal String^ CONFIG_FIELD_SECTION
public:
literal String^ CONFIG_FIELD_SECTION
static val mutable CONFIG_FIELD_SECTION: string
static val mutable CONFIG_FIELD_SECTION: string

Field Value

Type: Online String
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.CONFIG_FORMAT_ATTR Field

SchemaMap CONFIG_FORMAT_ATTR Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_FORMAT_ATTR
public const string CONFIG_FORMAT_ATTR
Public Const CONFIG_FORMAT_ATTR As String
Public Const CONFIG_FORMAT_ATTR As String
public:
literal String^ CONFIG_FORMAT_ATTR
public:
literal String^ CONFIG_FORMAT_ATTR
static val mutable CONFIG_FORMAT_ATTR: string
static val mutable CONFIG_FORMAT_ATTR: string

Field Value

Type: Online String
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.CONFIG_FORMAT_DESCR_ATTR Field

SchemaMap CONFIG_FORMAT_DESCR_ATTR Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_FORMAT_DESCR_ATTR
public const string CONFIG_FORMAT_DESCR_ATTR
Public Const CONFIG_FORMAT_DESCR_ATTR As String
Public Const CONFIG_FORMAT_DESCR_ATTR As String
public:
literal String^ CONFIG_FORMAT_DESCR_ATTR
public:
literal String^ CONFIG_FORMAT_DESCR_ATTR
static val mutable CONFIG_FORMAT_DESCR_ATTR: string
static val mutable CONFIG_FORMAT_DESCR_ATTR: string

Field Value

Type: Online String
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.CONFIG_INSERT_ATTR Field

SchemaMap CONFIG_INSERT_ATTR Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_INSERT_ATTR
public const string CONFIG_INSERT_ATTR
Public Const CONFIG_INSERT_ATTR As String
Public Const CONFIG_INSERT_ATTR As String
public:
literal String^ CONFIG_INSERT_ATTR
public:
literal String^ CONFIG_INSERT_ATTR
static val mutable CONFIG_INSERT_ATTR: string
static val mutable CONFIG_INSERT_ATTR: string

Field Value

Type: Online String
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.CONFIG_KEY_ATTR Field

SchemaMap CONFIG_KEY_ATTR Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_KEY_ATTR
public const string CONFIG_KEY_ATTR
Public Const CONFIG_KEY_ATTR As String
Public Const CONFIG_KEY_ATTR As String
public:
literal String^ CONFIG_KEY_ATTR
public:
literal String^ CONFIG_KEY_ATTR
static val mutable CONFIG_KEY_ATTR: string
static val mutable CONFIG_KEY_ATTR: string

Field Value

Type: Online String
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.CONFIG_LEN_ATTR Field

SchemaMap CONFIG_LEN_ATTR Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_LEN_ATTR
public const string CONFIG_LEN_ATTR
Public Const CONFIG_LEN_ATTR As String
Public Const CONFIG_LEN_ATTR As String
public:
literal String^ CONFIG_LEN_ATTR
public:
literal String^ CONFIG_LEN_ATTR
static val mutable CONFIG_LEN_ATTR: string
static val mutable CONFIG_LEN_ATTR: string

Field Value

Type: Online String
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.CONFIG_MAX_ATTR Field

SchemaMap CONFIG_MAX_ATTR Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_MAX_ATTR
public const string CONFIG_MAX_ATTR
Public Const CONFIG_MAX_ATTR As String
Public Const CONFIG_MAX_ATTR As String
public:
literal String^ CONFIG_MAX_ATTR
public:
literal String^ CONFIG_MAX_ATTR
static val mutable CONFIG_MAX_ATTR: string
static val mutable CONFIG_MAX_ATTR: string

Field Value

Type: Online String
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.CONFIG_MIN_ATTR Field

SchemaMap CONFIG_MIN_ATTR Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_MIN_ATTR
public const string CONFIG_MIN_ATTR
Public Const CONFIG_MIN_ATTR As String
Public Const CONFIG_MIN_ATTR As String
public:
literal String^ CONFIG_MIN_ATTR
public:
literal String^ CONFIG_MIN_ATTR
static val mutable CONFIG_MIN_ATTR: string
static val mutable CONFIG_MIN_ATTR: string

Field Value

Type: Online String
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.CONFIG_REQUIRED_ATTR Field

SchemaMap CONFIG_REQUIRED_ATTR Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_REQUIRED_ATTR
public const string CONFIG_REQUIRED_ATTR
Public Const CONFIG_REQUIRED_ATTR As String
Public Const CONFIG_REQUIRED_ATTR As String
public:
literal String^ CONFIG_REQUIRED_ATTR
public:
literal String^ CONFIG_REQUIRED_ATTR
static val mutable CONFIG_REQUIRED_ATTR: string
static val mutable CONFIG_REQUIRED_ATTR: string

Field Value

Type: Online String
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.CONFIG_SCHEMA_SECTION Field

SchemaMap CONFIG_SCHEMA_SECTION Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SCHEMA_SECTION
public const string CONFIG_SCHEMA_SECTION
Public Const CONFIG_SCHEMA_SECTION As String
Public Const CONFIG_SCHEMA_SECTION As String
public:
literal String^ CONFIG_SCHEMA_SECTION
public:
literal String^ CONFIG_SCHEMA_SECTION
static val mutable CONFIG_SCHEMA_SECTION: string
static val mutable CONFIG_SCHEMA_SECTION: string

Field Value

Type: Online String
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.CONFIG_TITLE_ATTR Field

SchemaMap CONFIG_TITLE_ATTR Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_TITLE_ATTR
public const string CONFIG_TITLE_ATTR
Public Const CONFIG_TITLE_ATTR As String
Public Const CONFIG_TITLE_ATTR As String
public:
literal String^ CONFIG_TITLE_ATTR
public:
literal String^ CONFIG_TITLE_ATTR
static val mutable CONFIG_TITLE_ATTR: string
static val mutable CONFIG_TITLE_ATTR: string

Field Value

Type: Online String
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.CONFIG_TYPE_ATTR Field

SchemaMap CONFIG_TYPE_ATTR Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_TYPE_ATTR
public const string CONFIG_TYPE_ATTR
Public Const CONFIG_TYPE_ATTR As String
Public Const CONFIG_TYPE_ATTR As String
public:
literal String^ CONFIG_TYPE_ATTR
public:
literal String^ CONFIG_TYPE_ATTR
static val mutable CONFIG_TYPE_ATTR: string
static val mutable CONFIG_TYPE_ATTR: string

Field Value

Type: Online String
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.CONFIG_UPDATE_ATTR Field

SchemaMap CONFIG_UPDATE_ATTR Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_UPDATE_ATTR
public const string CONFIG_UPDATE_ATTR
Public Const CONFIG_UPDATE_ATTR As String
Public Const CONFIG_UPDATE_ATTR As String
public:
literal String^ CONFIG_UPDATE_ATTR
public:
literal String^ CONFIG_UPDATE_ATTR
static val mutable CONFIG_UPDATE_ATTR: string
static val mutable CONFIG_UPDATE_ATTR: string

Field Value

Type: Online String
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.CONFIG_VALUE_SECTION Field

SchemaMap CONFIG_VALUE_SECTION Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_VALUE_SECTION
public const string CONFIG_VALUE_SECTION
Public Const CONFIG_VALUE_SECTION As String
Public Const CONFIG_VALUE_SECTION As String
public:
literal String^ CONFIG_VALUE_SECTION
public:
literal String^ CONFIG_VALUE_SECTION
static val mutable CONFIG_VALUE_SECTION: string
static val mutable CONFIG_VALUE_SECTION: string

Field Value

Type: Online String
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.CONFIG_VISIBLE_ATTR Field

SchemaMap CONFIG_VISIBLE_ATTR Field NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_VISIBLE_ATTR
public const string CONFIG_VISIBLE_ATTR
Public Const CONFIG_VISIBLE_ATTR As String
Public Const CONFIG_VISIBLE_ATTR As String
public:
literal String^ CONFIG_VISIBLE_ATTR
public:
literal String^ CONFIG_VISIBLE_ATTR
static val mutable CONFIG_VISIBLE_ATTR: string
static val mutable CONFIG_VISIBLE_ATTR: string

Field Value

Type: Online String
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap Methods

SchemaMap Methods NFX Class Library

The SchemaMap type exposes the following members.
Methods
 | Name | Description
 | ClrToErlValue |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ErlCRUDResponseToRowset | Converts ErlCRUD response to CLR CRUD rowset
 | ErlSchemaToCRUDSchema |
 | ErlToClrValue |
Public method | ErlTupleToRow | Maps ErlRow to CLR row supplied by schema, either Dynamic or TypedRow
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetCRUDSchemaForName |
Public method | GetErlSchemaSection | Returns config section for named erl schema or null
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RowToErlTuple | Converts CLR row data into ErlTuple
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SchemaMap Class
NFX.DataAccess.Erlang Namespace


SchemaMap.ClrToErlValue Method

SchemaMap ClrToErlValue Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static IErlObject ClrToErlValue(
    string dataType,
    Object clrValue
)
internal static IErlObject ClrToErlValue(
    string dataType,
    Object clrValue
)
Friend Shared Function ClrToErlValue (
    dataType As String,
    clrValue As Object
) As IErlObject
Friend Shared Function ClrToErlValue (
    dataType As String,
    clrValue As Object
) As IErlObject
internal:
static IErlObject^ ClrToErlValue(
    String^ dataType,
    Object^ clrValue
)
internal:
static IErlObject^ ClrToErlValue(
    String^ dataType,
    Object^ clrValue
)
internal static member ClrToErlValue :
        dataType : string *
        clrValue : Object -> IErlObject
internal static member ClrToErlValue :
        dataType : string *
        clrValue : Object -> IErlObject

Parameters

dataType
Type: Online System String
clrValue
Type: Online System Object

Return Value

Type: IErlObject
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.ErlCRUDResponseToRowset Method

SchemaMap ErlCRUDResponseToRowset Method NFX Class Library

Converts ErlCRUD response to CLR CRUD rowset

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RowsetBase ErlCRUDResponseToRowset(
    string schemaName,
    ErlList erlData,
    Type tRow = null
)
public RowsetBase ErlCRUDResponseToRowset(
    string schemaName,
    ErlList erlData,
    Type tRow = null
)
Public Function ErlCRUDResponseToRowset (
    schemaName As String,
    erlData As ErlList,
    Optional tRow As Type = Nothing
) As RowsetBase
Public Function ErlCRUDResponseToRowset (
    schemaName As String,
    erlData As ErlList,
    Optional tRow As Type = Nothing
) As RowsetBase
public:
RowsetBase^ ErlCRUDResponseToRowset(
    String^ schemaName,
    ErlList^ erlData,
    Type^ tRow = nullptr
)
public:
RowsetBase^ ErlCRUDResponseToRowset(
    String^ schemaName,
    ErlList^ erlData,
    Type^ tRow = nullptr
)
member ErlCRUDResponseToRowset :
        schemaName : string *
        erlData : ErlList *
        ?tRow : Type
(* Defaults:
        let _tRow = defaultArg tRow null
*)
-> RowsetBase
member ErlCRUDResponseToRowset :
        schemaName : string *
        erlData : ErlList *
        ?tRow : Type
(* Defaults:
        let _tRow = defaultArg tRow null
*)
-> RowsetBase

Parameters

schemaName
Type: Online System String
erlData
Type: NFX.Erlang ErlList
tRow (Optional)
Type: Online System Type

Return Value

Type: RowsetBase
Remarks
An Example data packet is field defs as speced in schema: "tca_jaba": has two field in PK [ {tca_jaba, {1234, tav}, "User is cool", true}, {tca_jaba, {2344, zap}, "A bird wants to drink", false}, {tca_jaba, {8944, tav}, "Have you seen this?", false} ] "aaa": has one field in PK - notice no tuple in key [ {aaa, 1234, tav, "User is cool", true}, {aaa, 2344, zap, "A bird wants to drink", false}, {aaa, 8944, tav, "Have you seen this?", false} ]
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.ErlSchemaToCRUDSchema Method

SchemaMap ErlSchemaToCRUDSchema Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Schema ErlSchemaToCRUDSchema(
    string name,
    IConfigSectionNode erlSect
)
public static Schema ErlSchemaToCRUDSchema(
    string name,
    IConfigSectionNode erlSect
)
Public Shared Function ErlSchemaToCRUDSchema (
    name As String,
    erlSect As IConfigSectionNode
) As Schema
Public Shared Function ErlSchemaToCRUDSchema (
    name As String,
    erlSect As IConfigSectionNode
) As Schema
public:
static Schema^ ErlSchemaToCRUDSchema(
    String^ name,
    IConfigSectionNode^ erlSect
)
public:
static Schema^ ErlSchemaToCRUDSchema(
    String^ name,
    IConfigSectionNode^ erlSect
)
static member ErlSchemaToCRUDSchema :
        name : string *
        erlSect : IConfigSectionNode -> Schema
static member ErlSchemaToCRUDSchema :
        name : string *
        erlSect : IConfigSectionNode -> Schema

Parameters

name
Type: Online System String
erlSect
Type: NFX.Environment IConfigSectionNode

Return Value

Type: Schema
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.ErlToClrValue Method

SchemaMap ErlToClrValue Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static Object ErlToClrValue(
    IErlObject erlValue,
    Schema schema,
    Schema..::..FieldDef fdef,
    string targetName = null,
    IErlObject outerTerm = null
)
internal static Object ErlToClrValue(
    IErlObject erlValue,
    Schema schema,
    Schema..::..FieldDef fdef,
    string targetName = null,
    IErlObject outerTerm = null
)
Friend Shared Function ErlToClrValue (
    erlValue As IErlObject,
    schema As Schema,
    fdef As Schema..::..FieldDef,
    Optional targetName As String = Nothing,
    Optional outerTerm As IErlObject = Nothing
) As Object
Friend Shared Function ErlToClrValue (
    erlValue As IErlObject,
    schema As Schema,
    fdef As Schema..::..FieldDef,
    Optional targetName As String = Nothing,
    Optional outerTerm As IErlObject = Nothing
) As Object
internal:
static Object^ ErlToClrValue(
    IErlObject^ erlValue,
    Schema^ schema,
    Schema..::..FieldDef^ fdef,
    String^ targetName = nullptr,
    IErlObject^ outerTerm = nullptr
)
internal:
static Object^ ErlToClrValue(
    IErlObject^ erlValue,
    Schema^ schema,
    Schema..::..FieldDef^ fdef,
    String^ targetName = nullptr,
    IErlObject^ outerTerm = nullptr
)
internal static member ErlToClrValue :
        erlValue : IErlObject *
        schema : Schema *
        fdef : Schema..::..FieldDef *
        ?targetName : string *
        ?outerTerm : IErlObject
(* Defaults:
        let _targetName = defaultArg targetName null
        let _outerTerm = defaultArg outerTerm null
*)
-> Object
internal static member ErlToClrValue :
        erlValue : IErlObject *
        schema : Schema *
        fdef : Schema..::..FieldDef *
        ?targetName : string *
        ?outerTerm : IErlObject
(* Defaults:
        let _targetName = defaultArg targetName null
        let _outerTerm = defaultArg outerTerm null
*)
-> Object

Parameters

erlValue
Type: NFX.Erlang IErlObject
schema
Type: NFX.DataAccess.CRUD Schema
fdef
Type: NFX.DataAccess.CRUD Schema FieldDef
targetName (Optional)
Type: Online System String
outerTerm (Optional)
Type: NFX.Erlang IErlObject

Return Value

Type: Online Object
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.ErlTupleToRow Method

SchemaMap ErlTupleToRow Method NFX Class Library

Maps ErlRow to CLR row supplied by schema, either Dynamic or TypedRow

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Row ErlTupleToRow(
    string schemaName,
    ErlTuple tuple,
    Schema schema
)
public Row ErlTupleToRow(
    string schemaName,
    ErlTuple tuple,
    Schema schema
)
Public Function ErlTupleToRow (
    schemaName As String,
    tuple As ErlTuple,
    schema As Schema
) As Row
Public Function ErlTupleToRow (
    schemaName As String,
    tuple As ErlTuple,
    schema As Schema
) As Row
public:
Row^ ErlTupleToRow(
    String^ schemaName,
    ErlTuple^ tuple,
    Schema^ schema
)
public:
Row^ ErlTupleToRow(
    String^ schemaName,
    ErlTuple^ tuple,
    Schema^ schema
)
member ErlTupleToRow :
        schemaName : string *
        tuple : ErlTuple *
        schema : Schema -> Row
member ErlTupleToRow :
        schemaName : string *
        tuple : ErlTuple *
        schema : Schema -> Row

Parameters

schemaName
Type: Online System String
tuple
Type: NFX.Erlang ErlTuple
schema
Type: NFX.DataAccess.CRUD Schema

Return Value

Type: Row
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.GetCRUDSchemaForName Method

SchemaMap GetCRUDSchemaForName Method NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Schema GetCRUDSchemaForName(
    string name
)
public Schema GetCRUDSchemaForName(
    string name
)
Public Function GetCRUDSchemaForName (
    name As String
) As Schema
Public Function GetCRUDSchemaForName (
    name As String
) As Schema
public:
Schema^ GetCRUDSchemaForName(
    String^ name
)
public:
Schema^ GetCRUDSchemaForName(
    String^ name
)
member GetCRUDSchemaForName :
        name : string -> Schema
member GetCRUDSchemaForName :
        name : string -> Schema

Parameters

name
Type: Online System String

Return Value

Type: Schema
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.GetErlSchemaSection Method

SchemaMap GetErlSchemaSection Method NFX Class Library

Returns config section for named erl schema or null

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IConfigSectionNode GetErlSchemaSection(
    string name
)
public IConfigSectionNode GetErlSchemaSection(
    string name
)
Public Function GetErlSchemaSection (
    name As String
) As IConfigSectionNode
Public Function GetErlSchemaSection (
    name As String
) As IConfigSectionNode
public:
IConfigSectionNode^ GetErlSchemaSection(
    String^ name
)
public:
IConfigSectionNode^ GetErlSchemaSection(
    String^ name
)
member GetErlSchemaSection :
        name : string -> IConfigSectionNode
member GetErlSchemaSection :
        name : string -> IConfigSectionNode

Parameters

name
Type: Online System String

Return Value

Type: IConfigSectionNode
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.RowToErlTuple Method

SchemaMap RowToErlTuple Method NFX Class Library

Converts CLR row data into ErlTuple

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTuple RowToErlTuple(
    Row row,
    bool keysOnly = false
)
public ErlTuple RowToErlTuple(
    Row row,
    bool keysOnly = false
)
Public Function RowToErlTuple (
    row As Row,
    Optional keysOnly As Boolean = false
) As ErlTuple
Public Function RowToErlTuple (
    row As Row,
    Optional keysOnly As Boolean = false
) As ErlTuple
public:
ErlTuple^ RowToErlTuple(
    Row^ row,
    bool keysOnly = false
)
public:
ErlTuple^ RowToErlTuple(
    Row^ row,
    bool keysOnly = false
)
member RowToErlTuple :
        row : Row *
        ?keysOnly : bool
(* Defaults:
        let _keysOnly = defaultArg keysOnly false
*)
-> ErlTuple
member RowToErlTuple :
        row : Row *
        ?keysOnly : bool
(* Defaults:
        let _keysOnly = defaultArg keysOnly false
*)
-> ErlTuple

Parameters

row
Type: NFX.DataAccess.CRUD Row
keysOnly (Optional)
Type: Online System Boolean

Return Value

Type: ErlTuple
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap Properties

SchemaMap Properties NFX Class Library

The SchemaMap type exposes the following members.
Properties
 | Name | Description
Public property | ErlSchemaSections | Enumerates all Erl schemas
Public property | OriginalXMLContent |
Public property | Store |
Back to Top
See Also
SchemaMap Class
NFX.DataAccess.Erlang Namespace


SchemaMap.ErlSchemaSections Property

SchemaMap ErlSchemaSections Property NFX Class Library

Enumerates all Erl schemas

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<IConfigSectionNode> ErlSchemaSections { get; }
public IEnumerable<IConfigSectionNode> ErlSchemaSections { get; }
Public ReadOnly Property ErlSchemaSections As IEnumerable(Of IConfigSectionNode)
    Get
Public ReadOnly Property ErlSchemaSections As IEnumerable(Of IConfigSectionNode)
    Get
public:
property IEnumerable<IConfigSectionNode^>^ ErlSchemaSections {
    IEnumerable<IConfigSectionNode^>^ get ();
}
public:
property IEnumerable<IConfigSectionNode^>^ ErlSchemaSections {
    IEnumerable<IConfigSectionNode^>^ get ();
}
member ErlSchemaSections : IEnumerable<IConfigSectionNode> with get
member ErlSchemaSections : IEnumerable<IConfigSectionNode> with get

Property Value

Type: Online IEnumerable IConfigSectionNode
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.OriginalXMLContent Property

SchemaMap OriginalXMLContent Property NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string OriginalXMLContent { get; }
public string OriginalXMLContent { get; }
Public ReadOnly Property OriginalXMLContent As String
    Get
Public ReadOnly Property OriginalXMLContent As String
    Get
public:
property String^ OriginalXMLContent {
    String^ get ();
}
public:
property String^ OriginalXMLContent {
    String^ get ();
}
member OriginalXMLContent : string with get
member OriginalXMLContent : string with get

Property Value

Type: Online String
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


SchemaMap.Store Property

SchemaMap Store Property NFX Class Library

Namespace: NFX.DataAccess.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlDataStore Store { get; }
public ErlDataStore Store { get; }
Public ReadOnly Property Store As ErlDataStore
    Get
Public ReadOnly Property Store As ErlDataStore
    Get
public:
property ErlDataStore^ Store {
    ErlDataStore^ get ();
}
public:
property ErlDataStore^ Store {
    ErlDataStore^ get ();
}
member Store : ErlDataStore with get
member Store : ErlDataStore with get

Property Value

Type: ErlDataStore
See Also
SchemaMap Class
SchemaMap Members
NFX.DataAccess.Erlang Namespace


NFX.DataAccess.MongoDB Namespace

NFX.DataAccess.MongoDB Namespace NFX Class Library

Provides NFX data access apis for MongoDB
Classes
Class | Description
Public class MongoDBCRUDQueryHandlerBase
A base for ICRUDQueryHandler-derivatives for mongo
Public class MongoDBCRUDScriptQueryHandler
Executes MongoDB CRUD script-based queries
Public class | MongoDBCursor
Public class MongoDBDataAccessException
Thrown by MongoDB data access classes
Public class MongoDBDataStore
Implements MongoDB general data store that supports CRUD operations. This class IS thread-safe load/save/delete operations
Public class MongoDBDataStoreBase
Implements MongoDB store base functionality Connect string takes form of:
View Colorized Copy to Clipboard Print
mongo{server="mongo://localhost:27017" db="myDB"}
mongo{server="mongo://localhost:27017" db="myDB"}
Public class MongoDBLogMessageDataStore
Implements a store that sends log messages into MongoDB
Protected class | StringConsts
Structures
 | Structure | Description
Public structure | MongoDBCRUDQueryExecutionContext | Provides query execution environment in MongoDB database context


MongoDBCRUDQueryExecutionContext Structure

MongoDBCRUDQueryExecutionContext Structure NFX Class Library

Provides query execution environment in MongoDB database context

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct MongoDBCRUDQueryExecutionContext : ICRUDQueryExecutionContext
public struct MongoDBCRUDQueryExecutionContext : ICRUDQueryExecutionContext
Public Structure MongoDBCRUDQueryExecutionContext
    Implements ICRUDQueryExecutionContext
Public Structure MongoDBCRUDQueryExecutionContext
    Implements ICRUDQueryExecutionContext
public value class MongoDBCRUDQueryExecutionContext : ICRUDQueryExecutionContext
public value class MongoDBCRUDQueryExecutionContext : ICRUDQueryExecutionContext
[<SealedAttribute>]
type MongoDBCRUDQueryExecutionContext =
    struct
        interface ICRUDQueryExecutionContext
    end
[<SealedAttribute>]
type MongoDBCRUDQueryExecutionContext =
    struct
        interface ICRUDQueryExecutionContext
    end
See Also
MongoDBCRUDQueryExecutionContext Members
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDQueryExecutionContext Members

MongoDBCRUDQueryExecutionContext Members NFX Class Library

The MongoDBCRUDQueryExecutionContext type exposes the following members.
Constructors
 | Name | Description
Public method | MongoDBCRUDQueryExecutionContext | Initializes a new instance of the MongoDBCRUDQueryExecutionContext class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Database |
Public field | DataStore |
Back to Top
See Also
MongoDBCRUDQueryExecutionContext Structure
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDQueryExecutionContext Constructor

MongoDBCRUDQueryExecutionContext Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MongoDBCRUDQueryExecutionContext class

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBCRUDQueryExecutionContext(
    MongoDBDataStore store,
    Database db
)
public MongoDBCRUDQueryExecutionContext(
    MongoDBDataStore store,
    Database db
)
Public Sub New (
    store As MongoDBDataStore,
    db As Database
)
Public Sub New (
    store As MongoDBDataStore,
    db As Database
)
public:
MongoDBCRUDQueryExecutionContext(
    MongoDBDataStore^ store,
    Database^ db
)
public:
MongoDBCRUDQueryExecutionContext(
    MongoDBDataStore^ store,
    Database^ db
)
new :
        store : MongoDBDataStore *
        db : Database -> MongoDBCRUDQueryExecutionContext
new :
        store : MongoDBDataStore *
        db : Database -> MongoDBCRUDQueryExecutionContext

Parameters

store
Type: NFX.DataAccess.MongoDB MongoDBDataStore
db
Type: NFX.DataAccess.MongoDB.Connector Database
See Also
MongoDBCRUDQueryExecutionContext Structure
MongoDBCRUDQueryExecutionContext Members
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDQueryExecutionContext Fields

MongoDBCRUDQueryExecutionContext Fields NFX Class Library

The MongoDBCRUDQueryExecutionContext type exposes the following members.
Fields
 | Name | Description
Public field | Database |
Public field | DataStore |
Back to Top
See Also
MongoDBCRUDQueryExecutionContext Structure
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDQueryExecutionContext.Database Field

MongoDBCRUDQueryExecutionContext Database Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Database Database
public readonly Database Database
Public ReadOnly Database As Database
Public ReadOnly Database As Database
public:
initonly Database^ Database
public:
initonly Database^ Database
val Database: Database
val Database: Database

Field Value

Type: Database
See Also
MongoDBCRUDQueryExecutionContext Structure
MongoDBCRUDQueryExecutionContext Members
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDQueryExecutionContext.DataStore Field

MongoDBCRUDQueryExecutionContext DataStore Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly MongoDBDataStore DataStore
public readonly MongoDBDataStore DataStore
Public ReadOnly DataStore As MongoDBDataStore
Public ReadOnly DataStore As MongoDBDataStore
public:
initonly MongoDBDataStore^ DataStore
public:
initonly MongoDBDataStore^ DataStore
val DataStore: MongoDBDataStore
val DataStore: MongoDBDataStore

Field Value

Type: MongoDBDataStore
See Also
MongoDBCRUDQueryExecutionContext Structure
MongoDBCRUDQueryExecutionContext Members
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDQueryExecutionContext Methods

MongoDBCRUDQueryExecutionContext Methods NFX Class Library

The MongoDBCRUDQueryExecutionContext type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MongoDBCRUDQueryExecutionContext Structure
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDQueryHandlerBase Class

MongoDBCRUDQueryHandlerBase Class NFX Class Library

A base for ICRUDQueryHandler-derivatives for mongo
Inheritance Hierarchy
Online System Object
NFX.DataAccess.CRUD CRUDQueryHandler
NFX.DataAccess.CRUD CRUDQueryHandler MongoDBDataStore
NFX.DataAccess.MongoDB MongoDBCRUDQueryHandlerBase
NFX.DataAccess.MongoDB MongoDBCRUDScriptQueryHandler

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class MongoDBCRUDQueryHandlerBase : CRUDQueryHandler<MongoDBDataStore>
public abstract class MongoDBCRUDQueryHandlerBase : CRUDQueryHandler<MongoDBDataStore>
Public MustInherit Class MongoDBCRUDQueryHandlerBase
    Inherits CRUDQueryHandler(Of MongoDBDataStore)
Public MustInherit Class MongoDBCRUDQueryHandlerBase
    Inherits CRUDQueryHandler(Of MongoDBDataStore)
public ref class MongoDBCRUDQueryHandlerBase abstract : public CRUDQueryHandler<MongoDBDataStore^>
public ref class MongoDBCRUDQueryHandlerBase abstract : public CRUDQueryHandler<MongoDBDataStore^>
[<AbstractClassAttribute>]
type MongoDBCRUDQueryHandlerBase =
    class
        inherit CRUDQueryHandler<MongoDBDataStore>
    end
[<AbstractClassAttribute>]
type MongoDBCRUDQueryHandlerBase =
    class
        inherit CRUDQueryHandler<MongoDBDataStore>
    end
See Also
MongoDBCRUDQueryHandlerBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDQueryHandlerBase Members

MongoDBCRUDQueryHandlerBase Members NFX Class Library

The MongoDBCRUDQueryHandlerBase type exposes the following members.
Constructors
 | Name | Description
Public method | MongoDBCRUDQueryHandlerBase(MongoDBDataStore, QuerySource) | Initializes a new instance of the MongoDBCRUDQueryHandlerBase class
Public method | MongoDBCRUDQueryHandlerBase(MongoDBDataStore, String) | Initializes a new instance of the MongoDBCRUDQueryHandlerBase class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Execute | (Overrides CRUDQueryHandler Execute(ICRUDQueryExecutionContext, Query, Boolean).)
Public method | ExecuteAsync | (Overrides CRUDQueryHandler ExecuteAsync(ICRUDQueryExecutionContext, Query, Boolean).)
Public method | ExecuteWithoutFetch | (Overrides CRUDQueryHandler ExecuteWithoutFetch(ICRUDQueryExecutionContext, Query).)
Public method | ExecuteWithoutFetchAsync | (Overrides CRUDQueryHandler ExecuteWithoutFetchAsync(ICRUDQueryExecutionContext, Query).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSchema | (Overrides CRUDQueryHandler GetSchema(ICRUDQueryExecutionContext, Query).)
Public method | GetSchemaAsync | (Overrides CRUDQueryHandler GetSchemaAsync(ICRUDQueryExecutionContext, Query).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeQuery(Query, QuerySource) |
Public method | MakeQuery(Database, Query, QuerySource, Collection ) |
Protected method | MapBSONArrayToRowset |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenCursor | (Overrides CRUDQueryHandler OpenCursor(ICRUDQueryExecutionContext, Query).)
Public method | OpenCursorAsync | (Overrides CRUDQueryHandler OpenCursorAsync(ICRUDQueryExecutionContext, Query).)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | Source | (Inherited from CRUDQueryHandler.)
Back to Top
Properties
 | Name | Description
Public property | Converter |
Public property | Name | Returns query name that this handler handles (Inherited from CRUDQueryHandler.)
Public property | Store | Store instance that handler is under (Inherited from CRUDQueryHandler TStore .)
Back to Top
See Also
MongoDBCRUDQueryHandlerBase Class
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDQueryHandlerBase Constructor

MongoDBCRUDQueryHandlerBase Constructor NFX Class Library

Overload List
 | Name | Description
Public method | MongoDBCRUDQueryHandlerBase(MongoDBDataStore, QuerySource) | Initializes a new instance of the MongoDBCRUDQueryHandlerBase class
Public method | MongoDBCRUDQueryHandlerBase(MongoDBDataStore, String) | Initializes a new instance of the MongoDBCRUDQueryHandlerBase class
Back to Top
See Also
MongoDBCRUDQueryHandlerBase Class
MongoDBCRUDQueryHandlerBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDQueryHandlerBase Constructor (MongoDBDataStore, QuerySource)

MongoDBCRUDQueryHandlerBase Constructor (MongoDBDataStore, QuerySource) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MongoDBCRUDQueryHandlerBase class

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBCRUDQueryHandlerBase(
    MongoDBDataStore store,
    QuerySource source
)
public MongoDBCRUDQueryHandlerBase(
    MongoDBDataStore store,
    QuerySource source
)
Public Sub New (
    store As MongoDBDataStore,
    source As QuerySource
)
Public Sub New (
    store As MongoDBDataStore,
    source As QuerySource
)
public:
MongoDBCRUDQueryHandlerBase(
    MongoDBDataStore^ store,
    QuerySource^ source
)
public:
MongoDBCRUDQueryHandlerBase(
    MongoDBDataStore^ store,
    QuerySource^ source
)
new :
        store : MongoDBDataStore *
        source : QuerySource -> MongoDBCRUDQueryHandlerBase
new :
        store : MongoDBDataStore *
        source : QuerySource -> MongoDBCRUDQueryHandlerBase

Parameters

store
Type: NFX.DataAccess.MongoDB MongoDBDataStore
source
Type: NFX.DataAccess.CRUD QuerySource
See Also
MongoDBCRUDQueryHandlerBase Class
MongoDBCRUDQueryHandlerBase Members
MongoDBCRUDQueryHandlerBase Overload
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDQueryHandlerBase Constructor (MongoDBDataStore, String)

MongoDBCRUDQueryHandlerBase Constructor (MongoDBDataStore, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MongoDBCRUDQueryHandlerBase class

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBCRUDQueryHandlerBase(
    MongoDBDataStore store,
    string name
)
public MongoDBCRUDQueryHandlerBase(
    MongoDBDataStore store,
    string name
)
Public Sub New (
    store As MongoDBDataStore,
    name As String
)
Public Sub New (
    store As MongoDBDataStore,
    name As String
)
public:
MongoDBCRUDQueryHandlerBase(
    MongoDBDataStore^ store,
    String^ name
)
public:
MongoDBCRUDQueryHandlerBase(
    MongoDBDataStore^ store,
    String^ name
)
new :
        store : MongoDBDataStore *
        name : string -> MongoDBCRUDQueryHandlerBase
new :
        store : MongoDBDataStore *
        name : string -> MongoDBCRUDQueryHandlerBase

Parameters

store
Type: NFX.DataAccess.MongoDB MongoDBDataStore
name
Type: Online System String
See Also
MongoDBCRUDQueryHandlerBase Class
MongoDBCRUDQueryHandlerBase Members
MongoDBCRUDQueryHandlerBase Overload
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDQueryHandlerBase Fields

MongoDBCRUDQueryHandlerBase Fields NFX Class Library

The MongoDBCRUDQueryHandlerBase type exposes the following members.
Fields
 | Name | Description
Protected field | Source | (Inherited from CRUDQueryHandler.)
Back to Top
See Also
MongoDBCRUDQueryHandlerBase Class
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDQueryHandlerBase Methods

MongoDBCRUDQueryHandlerBase Methods NFX Class Library

The MongoDBCRUDQueryHandlerBase type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Execute | (Overrides CRUDQueryHandler Execute(ICRUDQueryExecutionContext, Query, Boolean).)
Public method | ExecuteAsync | (Overrides CRUDQueryHandler ExecuteAsync(ICRUDQueryExecutionContext, Query, Boolean).)
Public method | ExecuteWithoutFetch | (Overrides CRUDQueryHandler ExecuteWithoutFetch(ICRUDQueryExecutionContext, Query).)
Public method | ExecuteWithoutFetchAsync | (Overrides CRUDQueryHandler ExecuteWithoutFetchAsync(ICRUDQueryExecutionContext, Query).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSchema | (Overrides CRUDQueryHandler GetSchema(ICRUDQueryExecutionContext, Query).)
Public method | GetSchemaAsync | (Overrides CRUDQueryHandler GetSchemaAsync(ICRUDQueryExecutionContext, Query).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeQuery(Query, QuerySource) |
Public method | MakeQuery(Database, Query, QuerySource, Collection ) |
Protected method | MapBSONArrayToRowset |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenCursor | (Overrides CRUDQueryHandler OpenCursor(ICRUDQueryExecutionContext, Query).)
Public method | OpenCursorAsync | (Overrides CRUDQueryHandler OpenCursorAsync(ICRUDQueryExecutionContext, Query).)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MongoDBCRUDQueryHandlerBase Class
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDQueryHandlerBase.Execute Method

MongoDBCRUDQueryHandlerBase Execute Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override RowsetBase Execute(
    ICRUDQueryExecutionContext context,
    Query query,
    bool oneRow = false
)
public override RowsetBase Execute(
    ICRUDQueryExecutionContext context,
    Query query,
    bool oneRow = false
)
Public Overrides Function Execute (
    context As ICRUDQueryExecutionContext,
    query As Query,
    Optional oneRow As Boolean = false
) As RowsetBase
Public Overrides Function Execute (
    context As ICRUDQueryExecutionContext,
    query As Query,
    Optional oneRow As Boolean = false
) As RowsetBase
public:
virtual RowsetBase^ Execute(
    ICRUDQueryExecutionContext^ context,
    Query^ query,
    bool oneRow = false
) override
public:
virtual RowsetBase^ Execute(
    ICRUDQueryExecutionContext^ context,
    Query^ query,
    bool oneRow = false
) override
abstract Execute :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> RowsetBase
override Execute :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> RowsetBase
abstract Execute :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> RowsetBase
override Execute :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> RowsetBase

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query
oneRow (Optional)
Type: Online System Boolean

Return Value

Type: RowsetBase
See Also
MongoDBCRUDQueryHandlerBase Class
MongoDBCRUDQueryHandlerBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDQueryHandlerBase.ExecuteAsync Method

MongoDBCRUDQueryHandlerBase ExecuteAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Task<RowsetBase> ExecuteAsync(
    ICRUDQueryExecutionContext context,
    Query query,
    bool oneRow = false
)
public override Task<RowsetBase> ExecuteAsync(
    ICRUDQueryExecutionContext context,
    Query query,
    bool oneRow = false
)
Public Overrides Function ExecuteAsync (
    context As ICRUDQueryExecutionContext,
    query As Query,
    Optional oneRow As Boolean = false
) As Task(Of RowsetBase)
Public Overrides Function ExecuteAsync (
    context As ICRUDQueryExecutionContext,
    query As Query,
    Optional oneRow As Boolean = false
) As Task(Of RowsetBase)
public:
virtual Task<RowsetBase^>^ ExecuteAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query,
    bool oneRow = false
) override
public:
virtual Task<RowsetBase^>^ ExecuteAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query,
    bool oneRow = false
) override
abstract ExecuteAsync :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> Task<RowsetBase>
override ExecuteAsync :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> Task<RowsetBase>
abstract ExecuteAsync :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> Task<RowsetBase>
override ExecuteAsync :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> Task<RowsetBase>

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query
oneRow (Optional)
Type: Online System Boolean

Return Value

Type: Online Task RowsetBase
See Also
MongoDBCRUDQueryHandlerBase Class
MongoDBCRUDQueryHandlerBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDQueryHandlerBase.ExecuteWithoutFetch Method

MongoDBCRUDQueryHandlerBase ExecuteWithoutFetch Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int ExecuteWithoutFetch(
    ICRUDQueryExecutionContext context,
    Query query
)
public override int ExecuteWithoutFetch(
    ICRUDQueryExecutionContext context,
    Query query
)
Public Overrides Function ExecuteWithoutFetch (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Integer
Public Overrides Function ExecuteWithoutFetch (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Integer
public:
virtual int ExecuteWithoutFetch(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
public:
virtual int ExecuteWithoutFetch(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
abstract ExecuteWithoutFetch :
        context : ICRUDQueryExecutionContext *
        query : Query -> int
override ExecuteWithoutFetch :
        context : ICRUDQueryExecutionContext *
        query : Query -> int
abstract ExecuteWithoutFetch :
        context : ICRUDQueryExecutionContext *
        query : Query -> int
override ExecuteWithoutFetch :
        context : ICRUDQueryExecutionContext *
        query : Query -> int

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Int32
See Also
MongoDBCRUDQueryHandlerBase Class
MongoDBCRUDQueryHandlerBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDQueryHandlerBase.ExecuteWithoutFetchAsync Method

MongoDBCRUDQueryHandlerBase ExecuteWithoutFetchAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Task<int> ExecuteWithoutFetchAsync(
    ICRUDQueryExecutionContext context,
    Query query
)
public override Task<int> ExecuteWithoutFetchAsync(
    ICRUDQueryExecutionContext context,
    Query query
)
Public Overrides Function ExecuteWithoutFetchAsync (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Task(Of Integer)
Public Overrides Function ExecuteWithoutFetchAsync (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Task(Of Integer)
public:
virtual Task<int>^ ExecuteWithoutFetchAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
public:
virtual Task<int>^ ExecuteWithoutFetchAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
abstract ExecuteWithoutFetchAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<int>
override ExecuteWithoutFetchAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<int>
abstract ExecuteWithoutFetchAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<int>
override ExecuteWithoutFetchAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<int>

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Online Int32
See Also
MongoDBCRUDQueryHandlerBase Class
MongoDBCRUDQueryHandlerBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDQueryHandlerBase.GetSchema Method

MongoDBCRUDQueryHandlerBase GetSchema Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Schema GetSchema(
    ICRUDQueryExecutionContext context,
    Query query
)
public override Schema GetSchema(
    ICRUDQueryExecutionContext context,
    Query query
)
Public Overrides Function GetSchema (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Schema
Public Overrides Function GetSchema (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Schema
public:
virtual Schema^ GetSchema(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
public:
virtual Schema^ GetSchema(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
abstract GetSchema :
        context : ICRUDQueryExecutionContext *
        query : Query -> Schema
override GetSchema :
        context : ICRUDQueryExecutionContext *
        query : Query -> Schema
abstract GetSchema :
        context : ICRUDQueryExecutionContext *
        query : Query -> Schema
override GetSchema :
        context : ICRUDQueryExecutionContext *
        query : Query -> Schema

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Schema
See Also
MongoDBCRUDQueryHandlerBase Class
MongoDBCRUDQueryHandlerBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDQueryHandlerBase.GetSchemaAsync Method

MongoDBCRUDQueryHandlerBase GetSchemaAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Task<Schema> GetSchemaAsync(
    ICRUDQueryExecutionContext context,
    Query query
)
public override Task<Schema> GetSchemaAsync(
    ICRUDQueryExecutionContext context,
    Query query
)
Public Overrides Function GetSchemaAsync (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Task(Of Schema)
Public Overrides Function GetSchemaAsync (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Task(Of Schema)
public:
virtual Task<Schema^>^ GetSchemaAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
public:
virtual Task<Schema^>^ GetSchemaAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
abstract GetSchemaAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Schema>
override GetSchemaAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Schema>
abstract GetSchemaAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Schema>
override GetSchemaAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Schema>

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Schema
See Also
MongoDBCRUDQueryHandlerBase Class
MongoDBCRUDQueryHandlerBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDQueryHandlerBase.MakeQuery Method

MongoDBCRUDQueryHandlerBase MakeQuery Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public method | MakeQuery(Query, QuerySource) |
Public method | MakeQuery(Database, Query, QuerySource, Collection ) |
Back to Top
See Also
MongoDBCRUDQueryHandlerBase Class
MongoDBCRUDQueryHandlerBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDQueryHandlerBase.MakeQuery Method (Query, QuerySource)

MongoDBCRUDQueryHandlerBase MakeQuery Method (Query, QuerySource) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Query MakeQuery(
    Query query,
    QuerySource source
)
public Query MakeQuery(
    Query query,
    QuerySource source
)
Public Function MakeQuery (
    query As Query,
    source As QuerySource
) As Query
Public Function MakeQuery (
    query As Query,
    source As QuerySource
) As Query
public:
Query^ MakeQuery(
    Query^ query,
    QuerySource^ source
)
public:
Query^ MakeQuery(
    Query^ query,
    QuerySource^ source
)
member MakeQuery :
        query : Query *
        source : QuerySource -> Query
member MakeQuery :
        query : Query *
        source : QuerySource -> Query

Parameters

query
Type: NFX.DataAccess.CRUD Query
source
Type: NFX.DataAccess.CRUD QuerySource

Return Value

Type: Query
See Also
MongoDBCRUDQueryHandlerBase Class
MongoDBCRUDQueryHandlerBase Members
MakeQuery Overload
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDQueryHandlerBase.MakeQuery Method (Database, Query, QuerySource, Collection)

MongoDBCRUDQueryHandlerBase MakeQuery Method (Database, Query, QuerySource, Collection ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Query MakeQuery(
    Database db,
    Query query,
    QuerySource source,
    out Collection collection
)
public Query MakeQuery(
    Database db,
    Query query,
    QuerySource source,
    out Collection collection
)
Public Function MakeQuery (
    db As Database,
    query As Query,
    source As QuerySource,
    <OutAttribute> ByRef collection As Collection
) As Query
Public Function MakeQuery (
    db As Database,
    query As Query,
    source As QuerySource,
    <OutAttribute> ByRef collection As Collection
) As Query
public:
Query^ MakeQuery(
    Database^ db,
    Query^ query,
    QuerySource^ source,
    [OutAttribute] Collection^% collection
)
public:
Query^ MakeQuery(
    Database^ db,
    Query^ query,
    QuerySource^ source,
    [OutAttribute] Collection^% collection
)
member MakeQuery :
        db : Database *
        query : Query *
        source : QuerySource *
        collection : Collection byref -> Query
member MakeQuery :
        db : Database *
        query : Query *
        source : QuerySource *
        collection : Collection byref -> Query

Parameters

db
Type: NFX.DataAccess.MongoDB.Connector Database
query
Type: NFX.DataAccess.CRUD Query
source
Type: NFX.DataAccess.CRUD QuerySource
collection
Type: NFX.DataAccess.MongoDB.Connector Collection

Return Value

Type: Query
See Also
MongoDBCRUDQueryHandlerBase Class
MongoDBCRUDQueryHandlerBase Members
MakeQuery Overload
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDQueryHandlerBase.MapBSONArrayToRowset Method

MongoDBCRUDQueryHandlerBase MapBSONArrayToRowset Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Rowset MapBSONArrayToRowset(
    BSONArrayElement rowsetData,
    Type rtp
)
protected Rowset MapBSONArrayToRowset(
    BSONArrayElement rowsetData,
    Type rtp
)
Protected Function MapBSONArrayToRowset (
    rowsetData As BSONArrayElement,
    rtp As Type
) As Rowset
Protected Function MapBSONArrayToRowset (
    rowsetData As BSONArrayElement,
    rtp As Type
) As Rowset
protected:
Rowset^ MapBSONArrayToRowset(
    BSONArrayElement^ rowsetData,
    Type^ rtp
)
protected:
Rowset^ MapBSONArrayToRowset(
    BSONArrayElement^ rowsetData,
    Type^ rtp
)
member MapBSONArrayToRowset :
        rowsetData : BSONArrayElement *
        rtp : Type -> Rowset
member MapBSONArrayToRowset :
        rowsetData : BSONArrayElement *
        rtp : Type -> Rowset

Parameters

rowsetData
Type: NFX.Serialization.BSON BSONArrayElement
rtp
Type: Online System Type

Return Value

Type: Rowset
See Also
MongoDBCRUDQueryHandlerBase Class
MongoDBCRUDQueryHandlerBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDQueryHandlerBase.OpenCursor Method

MongoDBCRUDQueryHandlerBase OpenCursor Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Cursor OpenCursor(
    ICRUDQueryExecutionContext context,
    Query query
)
public override Cursor OpenCursor(
    ICRUDQueryExecutionContext context,
    Query query
)
Public Overrides Function OpenCursor (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Cursor
Public Overrides Function OpenCursor (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Cursor
public:
virtual Cursor^ OpenCursor(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
public:
virtual Cursor^ OpenCursor(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
abstract OpenCursor :
        context : ICRUDQueryExecutionContext *
        query : Query -> Cursor
override OpenCursor :
        context : ICRUDQueryExecutionContext *
        query : Query -> Cursor
abstract OpenCursor :
        context : ICRUDQueryExecutionContext *
        query : Query -> Cursor
override OpenCursor :
        context : ICRUDQueryExecutionContext *
        query : Query -> Cursor

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Cursor
See Also
MongoDBCRUDQueryHandlerBase Class
MongoDBCRUDQueryHandlerBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDQueryHandlerBase.OpenCursorAsync Method

MongoDBCRUDQueryHandlerBase OpenCursorAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Task<Cursor> OpenCursorAsync(
    ICRUDQueryExecutionContext context,
    Query query
)
public override Task<Cursor> OpenCursorAsync(
    ICRUDQueryExecutionContext context,
    Query query
)
Public Overrides Function OpenCursorAsync (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Task(Of Cursor)
Public Overrides Function OpenCursorAsync (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Task(Of Cursor)
public:
virtual Task<Cursor^>^ OpenCursorAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
public:
virtual Task<Cursor^>^ OpenCursorAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
abstract OpenCursorAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Cursor>
override OpenCursorAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Cursor>
abstract OpenCursorAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Cursor>
override OpenCursorAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Cursor>

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Cursor
See Also
MongoDBCRUDQueryHandlerBase Class
MongoDBCRUDQueryHandlerBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDQueryHandlerBase Properties

MongoDBCRUDQueryHandlerBase Properties NFX Class Library

The MongoDBCRUDQueryHandlerBase type exposes the following members.
Properties
 | Name | Description
Public property | Converter |
Public property | Name | Returns query name that this handler handles (Inherited from CRUDQueryHandler.)
Public property | Store | Store instance that handler is under (Inherited from CRUDQueryHandler TStore .)
Back to Top
See Also
MongoDBCRUDQueryHandlerBase Class
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDQueryHandlerBase.Converter Property

MongoDBCRUDQueryHandlerBase Converter Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RowConverter Converter { get; }
public RowConverter Converter { get; }
Public ReadOnly Property Converter As RowConverter
    Get
Public ReadOnly Property Converter As RowConverter
    Get
public:
property RowConverter^ Converter {
    RowConverter^ get ();
}
public:
property RowConverter^ Converter {
    RowConverter^ get ();
}
member Converter : RowConverter with get
member Converter : RowConverter with get

Property Value

Type: RowConverter
See Also
MongoDBCRUDQueryHandlerBase Class
MongoDBCRUDQueryHandlerBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDScriptQueryHandler Class

MongoDBCRUDScriptQueryHandler Class NFX Class Library

Executes MongoDB CRUD script-based queries
Inheritance Hierarchy
Online System Object
NFX.DataAccess.CRUD CRUDQueryHandler
NFX.DataAccess.CRUD CRUDQueryHandler MongoDBDataStore
NFX.DataAccess.MongoDB MongoDBCRUDQueryHandlerBase
NFX.DataAccess.MongoDB MongoDBCRUDScriptQueryHandler

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class MongoDBCRUDScriptQueryHandler : MongoDBCRUDQueryHandlerBase
public sealed class MongoDBCRUDScriptQueryHandler : MongoDBCRUDQueryHandlerBase
Public NotInheritable Class MongoDBCRUDScriptQueryHandler
    Inherits MongoDBCRUDQueryHandlerBase
Public NotInheritable Class MongoDBCRUDScriptQueryHandler
    Inherits MongoDBCRUDQueryHandlerBase
public ref class MongoDBCRUDScriptQueryHandler sealed : public MongoDBCRUDQueryHandlerBase
public ref class MongoDBCRUDScriptQueryHandler sealed : public MongoDBCRUDQueryHandlerBase
[<SealedAttribute>]
type MongoDBCRUDScriptQueryHandler =
    class
        inherit MongoDBCRUDQueryHandlerBase
    end
[<SealedAttribute>]
type MongoDBCRUDScriptQueryHandler =
    class
        inherit MongoDBCRUDQueryHandlerBase
    end
See Also
MongoDBCRUDScriptQueryHandler Members
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDScriptQueryHandler Members

MongoDBCRUDScriptQueryHandler Members NFX Class Library

The MongoDBCRUDScriptQueryHandler type exposes the following members.
Constructors
 | Name | Description
Public method | MongoDBCRUDScriptQueryHandler | Initializes a new instance of the MongoDBCRUDScriptQueryHandler class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Execute | (Overrides MongoDBCRUDQueryHandlerBase Execute(ICRUDQueryExecutionContext, Query, Boolean).)
Public method | ExecuteAsync | (Inherited from MongoDBCRUDQueryHandlerBase.)
Public method | ExecuteWithoutFetch | (Overrides MongoDBCRUDQueryHandlerBase ExecuteWithoutFetch(ICRUDQueryExecutionContext, Query).)
Public method | ExecuteWithoutFetchAsync | (Inherited from MongoDBCRUDQueryHandlerBase.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSchema | (Overrides MongoDBCRUDQueryHandlerBase GetSchema(ICRUDQueryExecutionContext, Query).)
Public method | GetSchemaAsync | (Inherited from MongoDBCRUDQueryHandlerBase.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeQuery(Query, QuerySource) | (Inherited from MongoDBCRUDQueryHandlerBase.)
Public method | MakeQuery(Database, Query, QuerySource, Collection ) | (Inherited from MongoDBCRUDQueryHandlerBase.)
Protected method | MapBSONArrayToRowset | (Inherited from MongoDBCRUDQueryHandlerBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenCursor | (Overrides MongoDBCRUDQueryHandlerBase OpenCursor(ICRUDQueryExecutionContext, Query).)
Public method | OpenCursorAsync | (Inherited from MongoDBCRUDQueryHandlerBase.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | QUERY_PARAM_FETCH_BY |
 | QUERY_PARAM_FETCH_LIMIT |
 | QUERY_PARAM_SKIP_COUNT |
Protected field | Source | (Inherited from CRUDQueryHandler.)
Back to Top
Properties
 | Name | Description
Public property | Converter | (Inherited from MongoDBCRUDQueryHandlerBase.)
Public property | Name | Returns query name that this handler handles (Inherited from CRUDQueryHandler.)
Public property | Store | Store instance that handler is under (Inherited from CRUDQueryHandler TStore .)
Back to Top
See Also
MongoDBCRUDScriptQueryHandler Class
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDScriptQueryHandler Constructor

MongoDBCRUDScriptQueryHandler Constructor NFX Class Library

Initializes a new instance of the MongoDBCRUDScriptQueryHandler class

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBCRUDScriptQueryHandler(
    MongoDBDataStore store,
    QuerySource source
)
public MongoDBCRUDScriptQueryHandler(
    MongoDBDataStore store,
    QuerySource source
)
Public Sub New (
    store As MongoDBDataStore,
    source As QuerySource
)
Public Sub New (
    store As MongoDBDataStore,
    source As QuerySource
)
public:
MongoDBCRUDScriptQueryHandler(
    MongoDBDataStore^ store,
    QuerySource^ source
)
public:
MongoDBCRUDScriptQueryHandler(
    MongoDBDataStore^ store,
    QuerySource^ source
)
new :
        store : MongoDBDataStore *
        source : QuerySource -> MongoDBCRUDScriptQueryHandler
new :
        store : MongoDBDataStore *
        source : QuerySource -> MongoDBCRUDScriptQueryHandler

Parameters

store
Type: NFX.DataAccess.MongoDB MongoDBDataStore
source
Type: NFX.DataAccess.CRUD QuerySource
See Also
MongoDBCRUDScriptQueryHandler Class
MongoDBCRUDScriptQueryHandler Members
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDScriptQueryHandler Fields

MongoDBCRUDScriptQueryHandler Fields NFX Class Library

The MongoDBCRUDScriptQueryHandler type exposes the following members.
Fields
 | Name | Description
 | QUERY_PARAM_FETCH_BY |
 | QUERY_PARAM_FETCH_LIMIT |
 | QUERY_PARAM_SKIP_COUNT |
Protected field | Source | (Inherited from CRUDQueryHandler.)
Back to Top
See Also
MongoDBCRUDScriptQueryHandler Class
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDScriptQueryHandler.QUERY_PARAM_FETCH_BY Field

MongoDBCRUDScriptQueryHandler QUERY_PARAM_FETCH_BY Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string QUERY_PARAM_FETCH_BY
public const string QUERY_PARAM_FETCH_BY
Public Const QUERY_PARAM_FETCH_BY As String
Public Const QUERY_PARAM_FETCH_BY As String
public:
literal String^ QUERY_PARAM_FETCH_BY
public:
literal String^ QUERY_PARAM_FETCH_BY
static val mutable QUERY_PARAM_FETCH_BY: string
static val mutable QUERY_PARAM_FETCH_BY: string

Field Value

Type: Online String
See Also
MongoDBCRUDScriptQueryHandler Class
MongoDBCRUDScriptQueryHandler Members
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDScriptQueryHandler.QUERY_PARAM_FETCH_LIMIT Field

MongoDBCRUDScriptQueryHandler QUERY_PARAM_FETCH_LIMIT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string QUERY_PARAM_FETCH_LIMIT
public const string QUERY_PARAM_FETCH_LIMIT
Public Const QUERY_PARAM_FETCH_LIMIT As String
Public Const QUERY_PARAM_FETCH_LIMIT As String
public:
literal String^ QUERY_PARAM_FETCH_LIMIT
public:
literal String^ QUERY_PARAM_FETCH_LIMIT
static val mutable QUERY_PARAM_FETCH_LIMIT: string
static val mutable QUERY_PARAM_FETCH_LIMIT: string

Field Value

Type: Online String
See Also
MongoDBCRUDScriptQueryHandler Class
MongoDBCRUDScriptQueryHandler Members
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDScriptQueryHandler.QUERY_PARAM_SKIP_COUNT Field

MongoDBCRUDScriptQueryHandler QUERY_PARAM_SKIP_COUNT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string QUERY_PARAM_SKIP_COUNT
public const string QUERY_PARAM_SKIP_COUNT
Public Const QUERY_PARAM_SKIP_COUNT As String
Public Const QUERY_PARAM_SKIP_COUNT As String
public:
literal String^ QUERY_PARAM_SKIP_COUNT
public:
literal String^ QUERY_PARAM_SKIP_COUNT
static val mutable QUERY_PARAM_SKIP_COUNT: string
static val mutable QUERY_PARAM_SKIP_COUNT: string

Field Value

Type: Online String
See Also
MongoDBCRUDScriptQueryHandler Class
MongoDBCRUDScriptQueryHandler Members
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDScriptQueryHandler Methods

MongoDBCRUDScriptQueryHandler Methods NFX Class Library

The MongoDBCRUDScriptQueryHandler type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Execute | (Overrides MongoDBCRUDQueryHandlerBase Execute(ICRUDQueryExecutionContext, Query, Boolean).)
Public method | ExecuteAsync | (Inherited from MongoDBCRUDQueryHandlerBase.)
Public method | ExecuteWithoutFetch | (Overrides MongoDBCRUDQueryHandlerBase ExecuteWithoutFetch(ICRUDQueryExecutionContext, Query).)
Public method | ExecuteWithoutFetchAsync | (Inherited from MongoDBCRUDQueryHandlerBase.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSchema | (Overrides MongoDBCRUDQueryHandlerBase GetSchema(ICRUDQueryExecutionContext, Query).)
Public method | GetSchemaAsync | (Inherited from MongoDBCRUDQueryHandlerBase.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeQuery(Query, QuerySource) | (Inherited from MongoDBCRUDQueryHandlerBase.)
Public method | MakeQuery(Database, Query, QuerySource, Collection ) | (Inherited from MongoDBCRUDQueryHandlerBase.)
Protected method | MapBSONArrayToRowset | (Inherited from MongoDBCRUDQueryHandlerBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenCursor | (Overrides MongoDBCRUDQueryHandlerBase OpenCursor(ICRUDQueryExecutionContext, Query).)
Public method | OpenCursorAsync | (Inherited from MongoDBCRUDQueryHandlerBase.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MongoDBCRUDScriptQueryHandler Class
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDScriptQueryHandler.Execute Method

MongoDBCRUDScriptQueryHandler Execute Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override RowsetBase Execute(
    ICRUDQueryExecutionContext context,
    Query query,
    bool oneRow = false
)
public override RowsetBase Execute(
    ICRUDQueryExecutionContext context,
    Query query,
    bool oneRow = false
)
Public Overrides Function Execute (
    context As ICRUDQueryExecutionContext,
    query As Query,
    Optional oneRow As Boolean = false
) As RowsetBase
Public Overrides Function Execute (
    context As ICRUDQueryExecutionContext,
    query As Query,
    Optional oneRow As Boolean = false
) As RowsetBase
public:
virtual RowsetBase^ Execute(
    ICRUDQueryExecutionContext^ context,
    Query^ query,
    bool oneRow = false
) override
public:
virtual RowsetBase^ Execute(
    ICRUDQueryExecutionContext^ context,
    Query^ query,
    bool oneRow = false
) override
abstract Execute :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> RowsetBase
override Execute :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> RowsetBase
abstract Execute :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> RowsetBase
override Execute :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> RowsetBase

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query
oneRow (Optional)
Type: Online System Boolean

Return Value

Type: RowsetBase
See Also
MongoDBCRUDScriptQueryHandler Class
MongoDBCRUDScriptQueryHandler Members
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDScriptQueryHandler.ExecuteWithoutFetch Method

MongoDBCRUDScriptQueryHandler ExecuteWithoutFetch Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int ExecuteWithoutFetch(
    ICRUDQueryExecutionContext context,
    Query query
)
public override int ExecuteWithoutFetch(
    ICRUDQueryExecutionContext context,
    Query query
)
Public Overrides Function ExecuteWithoutFetch (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Integer
Public Overrides Function ExecuteWithoutFetch (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Integer
public:
virtual int ExecuteWithoutFetch(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
public:
virtual int ExecuteWithoutFetch(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
abstract ExecuteWithoutFetch :
        context : ICRUDQueryExecutionContext *
        query : Query -> int
override ExecuteWithoutFetch :
        context : ICRUDQueryExecutionContext *
        query : Query -> int
abstract ExecuteWithoutFetch :
        context : ICRUDQueryExecutionContext *
        query : Query -> int
override ExecuteWithoutFetch :
        context : ICRUDQueryExecutionContext *
        query : Query -> int

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Int32
See Also
MongoDBCRUDScriptQueryHandler Class
MongoDBCRUDScriptQueryHandler Members
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDScriptQueryHandler.GetSchema Method

MongoDBCRUDScriptQueryHandler GetSchema Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Schema GetSchema(
    ICRUDQueryExecutionContext context,
    Query query
)
public override Schema GetSchema(
    ICRUDQueryExecutionContext context,
    Query query
)
Public Overrides Function GetSchema (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Schema
Public Overrides Function GetSchema (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Schema
public:
virtual Schema^ GetSchema(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
public:
virtual Schema^ GetSchema(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
abstract GetSchema :
        context : ICRUDQueryExecutionContext *
        query : Query -> Schema
override GetSchema :
        context : ICRUDQueryExecutionContext *
        query : Query -> Schema
abstract GetSchema :
        context : ICRUDQueryExecutionContext *
        query : Query -> Schema
override GetSchema :
        context : ICRUDQueryExecutionContext *
        query : Query -> Schema

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Schema
See Also
MongoDBCRUDScriptQueryHandler Class
MongoDBCRUDScriptQueryHandler Members
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDScriptQueryHandler.OpenCursor Method

MongoDBCRUDScriptQueryHandler OpenCursor Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Cursor OpenCursor(
    ICRUDQueryExecutionContext context,
    Query query
)
public override Cursor OpenCursor(
    ICRUDQueryExecutionContext context,
    Query query
)
Public Overrides Function OpenCursor (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Cursor
Public Overrides Function OpenCursor (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Cursor
public:
virtual Cursor^ OpenCursor(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
public:
virtual Cursor^ OpenCursor(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
abstract OpenCursor :
        context : ICRUDQueryExecutionContext *
        query : Query -> Cursor
override OpenCursor :
        context : ICRUDQueryExecutionContext *
        query : Query -> Cursor
abstract OpenCursor :
        context : ICRUDQueryExecutionContext *
        query : Query -> Cursor
override OpenCursor :
        context : ICRUDQueryExecutionContext *
        query : Query -> Cursor

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Cursor
See Also
MongoDBCRUDScriptQueryHandler Class
MongoDBCRUDScriptQueryHandler Members
NFX.DataAccess.MongoDB Namespace


MongoDBCRUDScriptQueryHandler Properties

MongoDBCRUDScriptQueryHandler Properties NFX Class Library

The MongoDBCRUDScriptQueryHandler type exposes the following members.
Properties
 | Name | Description
Public property | Converter | (Inherited from MongoDBCRUDQueryHandlerBase.)
Public property | Name | Returns query name that this handler handles (Inherited from CRUDQueryHandler.)
Public property | Store | Store instance that handler is under (Inherited from CRUDQueryHandler TStore .)
Back to Top
See Also
MongoDBCRUDScriptQueryHandler Class
NFX.DataAccess.MongoDB Namespace


MongoDBCursor Class

MongoDBCursor Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.DataAccess.CRUD Cursor
NFX.DataAccess.MongoDB MongoDBCursor

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class MongoDBCursor : Cursor
public sealed class MongoDBCursor : Cursor
Public NotInheritable Class MongoDBCursor
    Inherits Cursor
Public NotInheritable Class MongoDBCursor
    Inherits Cursor
public ref class MongoDBCursor sealed : public Cursor
public ref class MongoDBCursor sealed : public Cursor
[<SealedAttribute>]
type MongoDBCursor =
    class
        inherit Cursor
    end
[<SealedAttribute>]
type MongoDBCursor =
    class
        inherit Cursor
    end
See Also
MongoDBCursor Members
NFX.DataAccess.MongoDB Namespace


MongoDBCursor Members

MongoDBCursor Members NFX Class Library

The MongoDBCursor type exposes the following members.
Constructors
 | Name | Description
Protected method | MongoDBCursor | Initializes a new instance of the MongoDBCursor class
Back to Top
Methods
 | Name | Description
Protected method | Destructor | (Overrides Cursor Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetEnumerator | (Inherited from Cursor.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Enumerator | (Inherited from Cursor.)
Protected field | m_Source | (Inherited from Cursor.)
Back to Top
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Cursor.)
Back to Top
See Also
MongoDBCursor Class
NFX.DataAccess.MongoDB Namespace


MongoDBCursor Constructor

MongoDBCursor Constructor NFX Class Library

Initializes a new instance of the MongoDBCursor class

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal MongoDBCursor(
    Cursor cursor,
    IEnumerable<Row> source
)
internal MongoDBCursor(
    Cursor cursor,
    IEnumerable<Row> source
)
Friend Sub New (
    cursor As Cursor,
    source As IEnumerable(Of Row)
)
Friend Sub New (
    cursor As Cursor,
    source As IEnumerable(Of Row)
)
internal:
MongoDBCursor(
    Cursor^ cursor,
    IEnumerable<Row^>^ source
)
internal:
MongoDBCursor(
    Cursor^ cursor,
    IEnumerable<Row^>^ source
)
new :
        cursor : Cursor *
        source : IEnumerable<Row> -> MongoDBCursor
new :
        cursor : Cursor *
        source : IEnumerable<Row> -> MongoDBCursor

Parameters

cursor
Type: NFX.DataAccess.MongoDB.Connector Cursor
source
Type: Online System.Collections.Generic IEnumerable Row
See Also
MongoDBCursor Class
MongoDBCursor Members
NFX.DataAccess.MongoDB Namespace


MongoDBCursor Fields

MongoDBCursor Fields NFX Class Library

The MongoDBCursor type exposes the following members.
Fields
 | Name | Description
Protected field | m_Enumerator | (Inherited from Cursor.)
Protected field | m_Source | (Inherited from Cursor.)
Back to Top
See Also
MongoDBCursor Class
NFX.DataAccess.MongoDB Namespace


MongoDBCursor Methods

MongoDBCursor Methods NFX Class Library

The MongoDBCursor type exposes the following members.
Methods
 | Name | Description
Protected method | Destructor | (Overrides Cursor Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetEnumerator | (Inherited from Cursor.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Cursor.)
Back to Top
See Also
MongoDBCursor Class
NFX.DataAccess.MongoDB Namespace


MongoDBCursor.Destructor Method

MongoDBCursor Destructor Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
MongoDBCursor Class
MongoDBCursor Members
NFX.DataAccess.MongoDB Namespace


MongoDBCursor Properties

MongoDBCursor Properties NFX Class Library

The MongoDBCursor type exposes the following members.
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Back to Top
See Also
MongoDBCursor Class
NFX.DataAccess.MongoDB Namespace


MongoDBDataAccessException Class

MongoDBDataAccessException Class NFX Class Library

Thrown by MongoDB data access classes
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.DataAccess DataAccessException
NFX.DataAccess.MongoDB MongoDBDataAccessException
NFX.DataAccess.MongoDB.Connector MongoDBConnectorException

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MongoDBDataAccessException : DataAccessException
[SerializableAttribute]
public class MongoDBDataAccessException : DataAccessException
<SerializableAttribute>
Public Class MongoDBDataAccessException
    Inherits DataAccessException
<SerializableAttribute>
Public Class MongoDBDataAccessException
    Inherits DataAccessException
[SerializableAttribute]
public ref class MongoDBDataAccessException : public DataAccessException
[SerializableAttribute]
public ref class MongoDBDataAccessException : public DataAccessException
[<SerializableAttribute>]
type MongoDBDataAccessException =
    class
        inherit DataAccessException
    end
[<SerializableAttribute>]
type MongoDBDataAccessException =
    class
        inherit DataAccessException
    end
See Also
MongoDBDataAccessException Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataAccessException Members

MongoDBDataAccessException Members NFX Class Library

The MongoDBDataAccessException type exposes the following members.
Constructors
 | Name | Description
Public method | MongoDBDataAccessException | Initializes a new instance of the MongoDBDataAccessException class
Public method | MongoDBDataAccessException(String) | Initializes a new instance of the MongoDBDataAccessException class
Protected method | MongoDBDataAccessException(SerializationInfo, StreamingContext) | Initializes a new instance of the MongoDBDataAccessException class
Public method | MongoDBDataAccessException(String, Exception) | Initializes a new instance of the MongoDBDataAccessException class
Public method | MongoDBDataAccessException(String, KeyViolationKind, String) | Initializes a new instance of the MongoDBDataAccessException class
Public method | MongoDBDataAccessException(String, Exception, KeyViolationKind, String) | Initializes a new instance of the MongoDBDataAccessException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
MongoDBDataAccessException Class
NFX.DataAccess.MongoDB Namespace


MongoDBDataAccessException Constructor

MongoDBDataAccessException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | MongoDBDataAccessException | Initializes a new instance of the MongoDBDataAccessException class
Public method | MongoDBDataAccessException(String) | Initializes a new instance of the MongoDBDataAccessException class
Protected method | MongoDBDataAccessException(SerializationInfo, StreamingContext) | Initializes a new instance of the MongoDBDataAccessException class
Public method | MongoDBDataAccessException(String, Exception) | Initializes a new instance of the MongoDBDataAccessException class
Public method | MongoDBDataAccessException(String, KeyViolationKind, String) | Initializes a new instance of the MongoDBDataAccessException class
Public method | MongoDBDataAccessException(String, Exception, KeyViolationKind, String) | Initializes a new instance of the MongoDBDataAccessException class
Back to Top
See Also
MongoDBDataAccessException Class
MongoDBDataAccessException Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataAccessException Constructor

MongoDBDataAccessException Constructor NFX Class Library

Initializes a new instance of the MongoDBDataAccessException class

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBDataAccessException()
public MongoDBDataAccessException()
Public Sub New
Public Sub New
public:
MongoDBDataAccessException()
public:
MongoDBDataAccessException()
new : unit -> MongoDBDataAccessException
new : unit -> MongoDBDataAccessException
See Also
MongoDBDataAccessException Class
MongoDBDataAccessException Members
MongoDBDataAccessException Overload
NFX.DataAccess.MongoDB Namespace


MongoDBDataAccessException Constructor (String)

MongoDBDataAccessException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MongoDBDataAccessException class

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBDataAccessException(
    string message
)
public MongoDBDataAccessException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
MongoDBDataAccessException(
    String^ message
)
public:
MongoDBDataAccessException(
    String^ message
)
new :
        message : string -> MongoDBDataAccessException
new :
        message : string -> MongoDBDataAccessException

Parameters

message
Type: Online System String
See Also
MongoDBDataAccessException Class
MongoDBDataAccessException Members
MongoDBDataAccessException Overload
NFX.DataAccess.MongoDB Namespace


MongoDBDataAccessException Constructor (SerializationInfo, StreamingContext)

MongoDBDataAccessException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MongoDBDataAccessException class

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MongoDBDataAccessException(
    SerializationInfo info,
    StreamingContext context
)
protected MongoDBDataAccessException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
MongoDBDataAccessException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
MongoDBDataAccessException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> MongoDBDataAccessException
new :
        info : SerializationInfo *
        context : StreamingContext -> MongoDBDataAccessException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
MongoDBDataAccessException Class
MongoDBDataAccessException Members
MongoDBDataAccessException Overload
NFX.DataAccess.MongoDB Namespace


MongoDBDataAccessException Constructor (String, Exception)

MongoDBDataAccessException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MongoDBDataAccessException class

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBDataAccessException(
    string message,
    Exception inner
)
public MongoDBDataAccessException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
MongoDBDataAccessException(
    String^ message,
    Exception^ inner
)
public:
MongoDBDataAccessException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> MongoDBDataAccessException
new :
        message : string *
        inner : Exception -> MongoDBDataAccessException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
MongoDBDataAccessException Class
MongoDBDataAccessException Members
MongoDBDataAccessException Overload
NFX.DataAccess.MongoDB Namespace


MongoDBDataAccessException Constructor (String, KeyViolationKind, String)

MongoDBDataAccessException Constructor (String, KeyViolationKind, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MongoDBDataAccessException class

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBDataAccessException(
    string message,
    KeyViolationKind kvKind,
    string keyViolation
)
public MongoDBDataAccessException(
    string message,
    KeyViolationKind kvKind,
    string keyViolation
)
Public Sub New (
    message As String,
    kvKind As KeyViolationKind,
    keyViolation As String
)
Public Sub New (
    message As String,
    kvKind As KeyViolationKind,
    keyViolation As String
)
public:
MongoDBDataAccessException(
    String^ message,
    KeyViolationKind kvKind,
    String^ keyViolation
)
public:
MongoDBDataAccessException(
    String^ message,
    KeyViolationKind kvKind,
    String^ keyViolation
)
new :
        message : string *
        kvKind : KeyViolationKind *
        keyViolation : string -> MongoDBDataAccessException
new :
        message : string *
        kvKind : KeyViolationKind *
        keyViolation : string -> MongoDBDataAccessException

Parameters

message
Type: Online System String
kvKind
Type: NFX.DataAccess KeyViolationKind
keyViolation
Type: Online System String
See Also
MongoDBDataAccessException Class
MongoDBDataAccessException Members
MongoDBDataAccessException Overload
NFX.DataAccess.MongoDB Namespace


MongoDBDataAccessException Constructor (String, Exception, KeyViolationKind, String)

MongoDBDataAccessException Constructor (String, Exception, KeyViolationKind, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MongoDBDataAccessException class

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBDataAccessException(
    string message,
    Exception inner,
    KeyViolationKind kvKind,
    string keyViolation
)
public MongoDBDataAccessException(
    string message,
    Exception inner,
    KeyViolationKind kvKind,
    string keyViolation
)
Public Sub New (
    message As String,
    inner As Exception,
    kvKind As KeyViolationKind,
    keyViolation As String
)
Public Sub New (
    message As String,
    inner As Exception,
    kvKind As KeyViolationKind,
    keyViolation As String
)
public:
MongoDBDataAccessException(
    String^ message,
    Exception^ inner,
    KeyViolationKind kvKind,
    String^ keyViolation
)
public:
MongoDBDataAccessException(
    String^ message,
    Exception^ inner,
    KeyViolationKind kvKind,
    String^ keyViolation
)
new :
        message : string *
        inner : Exception *
        kvKind : KeyViolationKind *
        keyViolation : string -> MongoDBDataAccessException
new :
        message : string *
        inner : Exception *
        kvKind : KeyViolationKind *
        keyViolation : string -> MongoDBDataAccessException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
kvKind
Type: NFX.DataAccess KeyViolationKind
keyViolation
Type: Online System String
See Also
MongoDBDataAccessException Class
MongoDBDataAccessException Members
MongoDBDataAccessException Overload
NFX.DataAccess.MongoDB Namespace


MongoDBDataAccessException Fields

MongoDBDataAccessException Fields NFX Class Library

The MongoDBDataAccessException type exposes the following members.
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
See Also
MongoDBDataAccessException Class
NFX.DataAccess.MongoDB Namespace


MongoDBDataAccessException Methods

MongoDBDataAccessException Methods NFX Class Library

The MongoDBDataAccessException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
MongoDBDataAccessException Class
NFX.DataAccess.MongoDB Namespace


MongoDBDataAccessException Properties

MongoDBDataAccessException Properties NFX Class Library

The MongoDBDataAccessException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
MongoDBDataAccessException Class
NFX.DataAccess.MongoDB Namespace


MongoDBDataAccessException Events

MongoDBDataAccessException Events NFX Class Library

The MongoDBDataAccessException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
MongoDBDataAccessException Class
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore Class

MongoDBDataStore Class NFX Class Library

Implements MongoDB general data store that supports CRUD operations. This class IS thread-safe load/save/delete operations
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.DataAccess.MongoDB MongoDBDataStoreBase
NFX.DataAccess.MongoDB MongoDBDataStore

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MongoDBDataStore : MongoDBDataStoreBase,
    ICRUDDataStoreImplementation, ICRUDDataStore, ICRUDOperations, ICRUDTransactionOperations, IDataStoreImplementation,
    IDataStore, IApplicationComponent, IDisposable, IConfigurable, IInstrumentable,
    IExternallyParameterized
public class MongoDBDataStore : MongoDBDataStoreBase,
    ICRUDDataStoreImplementation, ICRUDDataStore, ICRUDOperations, ICRUDTransactionOperations, IDataStoreImplementation,
    IDataStore, IApplicationComponent, IDisposable, IConfigurable, IInstrumentable,
    IExternallyParameterized
Public Class MongoDBDataStore
    Inherits MongoDBDataStoreBase
    Implements ICRUDDataStoreImplementation, ICRUDDataStore, ICRUDOperations, ICRUDTransactionOperations,
    IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
Public Class MongoDBDataStore
    Inherits MongoDBDataStoreBase
    Implements ICRUDDataStoreImplementation, ICRUDDataStore, ICRUDOperations, ICRUDTransactionOperations,
    IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
public ref class MongoDBDataStore : public MongoDBDataStoreBase,
    ICRUDDataStoreImplementation, ICRUDDataStore, ICRUDOperations, ICRUDTransactionOperations, IDataStoreImplementation,
    IDataStore, IApplicationComponent, IDisposable, IConfigurable, IInstrumentable,
    IExternallyParameterized
public ref class MongoDBDataStore : public MongoDBDataStoreBase,
    ICRUDDataStoreImplementation, ICRUDDataStore, ICRUDOperations, ICRUDTransactionOperations, IDataStoreImplementation,
    IDataStore, IApplicationComponent, IDisposable, IConfigurable, IInstrumentable,
    IExternallyParameterized
type MongoDBDataStore =
    class
        inherit MongoDBDataStoreBase
        interface ICRUDDataStoreImplementation
        interface ICRUDDataStore
        interface ICRUDOperations
        interface ICRUDTransactionOperations
        interface IDataStoreImplementation
        interface IDataStore
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
type MongoDBDataStore =
    class
        inherit MongoDBDataStoreBase
        interface ICRUDDataStoreImplementation
        interface ICRUDDataStore
        interface ICRUDOperations
        interface ICRUDTransactionOperations
        interface IDataStoreImplementation
        interface IDataStore
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore Members

MongoDBDataStore Members NFX Class Library

The MongoDBDataStore type exposes the following members.
Constructors
 | Name | Description
Public method | MongoDBDataStore | Initializes a new instance of the MongoDBDataStore class
Public method | MongoDBDataStore(String, String) | Initializes a new instance of the MongoDBDataStore class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | BeginTransaction |
Public method | BeginTransactionAsync |
Public method | Configure | (Overrides MongoDBDataStoreBase Configure(IConfigSectionNode).)
Public method | Delete |
Public method | DeleteAsync |
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoDelete |
Protected method | DoInsert |
Protected method | DoUpdate |
Protected method | DoUpsert |
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExecuteWithoutFetch |
Public method | ExecuteWithoutFetchAsync |
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from MongoDBDataStoreBase.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from MongoDBDataStoreBase.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from MongoDBDataStoreBase.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetCollectionName |
Protected method | GetDatabase | Gets appropriate database. It does not need to be disposed (Inherited from MongoDBDataStoreBase.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSchema |
Public method | GetSchemaAsync |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Insert |
Public method | InsertAsync |
Public method | Load |
Public method | LoadAsync |
Public method | LoadOneRow |
Public method | LoadOneRowAsync |
Public method | LoadOneRowset |
Public method | LoadOneRowsetAsync |
Public method | MakeScriptQueryHandler |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenCursor |
Public method | OpenCursorAsync |
Public method | Save |
Public method | SaveAsync |
Public method | TestConnection | (Inherited from MongoDBDataStoreBase.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Update |
Public method | UpdateAsync |
Public method | Upsert |
Public method | UpsertAsync |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | LoadEnumerable TRow | Loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadEnumerableAsync TRow | Async version - loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadRow TRow | Loads one row cast per Query(T) or null (Defined by DataUtils.)
Public Extension Method | LoadRowAsync TRow | Async version - loads one row cast per Query(T) or null (Defined by DataUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
SCRIPT_FILE_SUFFIX |
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | ConnectString | Get/Sets MongoDB database connection string (Inherited from MongoDBDataStoreBase.)
Public property | Converter |
Public property | DatabaseName | Get/Sets MongoDB database name (Inherited from MongoDBDataStoreBase.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from MongoDBDataStoreBase.)
Public property | InstrumentationEnabled | (Inherited from MongoDBDataStoreBase.)
Public property | LogLevel | (Inherited from MongoDBDataStoreBase.)
Public property | Name | (Inherited from MongoDBDataStoreBase.)
Public property | QueryResolver |
Public property | ScriptFileSuffix |
Public property | StoreType |
Public property | SupportsTransactions |
Public property | SupportsTrueAsynchrony |
Public property | TargetName | (Inherited from MongoDBDataStoreBase.)
Back to Top
See Also
MongoDBDataStore Class
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore Constructor

MongoDBDataStore Constructor NFX Class Library

Overload List
 | Name | Description
Public method | MongoDBDataStore | Initializes a new instance of the MongoDBDataStore class
Public method | MongoDBDataStore(String, String) | Initializes a new instance of the MongoDBDataStore class
Back to Top
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore Constructor

MongoDBDataStore Constructor NFX Class Library

Initializes a new instance of the MongoDBDataStore class

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBDataStore()
public MongoDBDataStore()
Public Sub New
Public Sub New
public:
MongoDBDataStore()
public:
MongoDBDataStore()
new : unit -> MongoDBDataStore
new : unit -> MongoDBDataStore
See Also
MongoDBDataStore Class
MongoDBDataStore Members
MongoDBDataStore Overload
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore Constructor (String, String)

MongoDBDataStore Constructor (String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MongoDBDataStore class

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBDataStore(
    string connectString,
    string dbName
)
public MongoDBDataStore(
    string connectString,
    string dbName
)
Public Sub New (
    connectString As String,
    dbName As String
)
Public Sub New (
    connectString As String,
    dbName As String
)
public:
MongoDBDataStore(
    String^ connectString,
    String^ dbName
)
public:
MongoDBDataStore(
    String^ connectString,
    String^ dbName
)
new :
        connectString : string *
        dbName : string -> MongoDBDataStore
new :
        connectString : string *
        dbName : string -> MongoDBDataStore

Parameters

connectString
Type: Online System String
dbName
Type: Online System String
See Also
MongoDBDataStore Class
MongoDBDataStore Members
MongoDBDataStore Overload
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore Fields

MongoDBDataStore Fields NFX Class Library

The MongoDBDataStore type exposes the following members.
Fields
Name | Description
SCRIPT_FILE_SUFFIX |
Back to Top
See Also
MongoDBDataStore Class
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.SCRIPT_FILE_SUFFIX Field

MongoDBDataStore SCRIPT_FILE_SUFFIX Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SCRIPT_FILE_SUFFIX
public const string SCRIPT_FILE_SUFFIX
Public Const SCRIPT_FILE_SUFFIX As String
Public Const SCRIPT_FILE_SUFFIX As String
public:
literal String^ SCRIPT_FILE_SUFFIX
public:
literal String^ SCRIPT_FILE_SUFFIX
static val mutable SCRIPT_FILE_SUFFIX: string
static val mutable SCRIPT_FILE_SUFFIX: string

Field Value

Type: Online String
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore Methods

MongoDBDataStore Methods NFX Class Library

The MongoDBDataStore type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | BeginTransaction |
Public method | BeginTransactionAsync |
Public method | Configure | (Overrides MongoDBDataStoreBase Configure(IConfigSectionNode).)
Public method | Delete |
Public method | DeleteAsync |
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoDelete |
Protected method | DoInsert |
Protected method | DoUpdate |
Protected method | DoUpsert |
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExecuteWithoutFetch |
Public method | ExecuteWithoutFetchAsync |
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from MongoDBDataStoreBase.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from MongoDBDataStoreBase.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from MongoDBDataStoreBase.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetCollectionName |
Protected method | GetDatabase | Gets appropriate database. It does not need to be disposed (Inherited from MongoDBDataStoreBase.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSchema |
Public method | GetSchemaAsync |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Insert |
Public method | InsertAsync |
Public method | Load |
Public method | LoadAsync |
Public method | LoadOneRow |
Public method | LoadOneRowAsync |
Public method | LoadOneRowset |
Public method | LoadOneRowsetAsync |
Public method | MakeScriptQueryHandler |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenCursor |
Public method | OpenCursorAsync |
Public method | Save |
Public method | SaveAsync |
Public method | TestConnection | (Inherited from MongoDBDataStoreBase.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Update |
Public method | UpdateAsync |
Public method | Upsert |
Public method | UpsertAsync |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | LoadEnumerable TRow | Loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadEnumerableAsync TRow | Async version - loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadRow TRow | Loads one row cast per Query(T) or null (Defined by DataUtils.)
Public Extension Method | LoadRowAsync TRow | Async version - loads one row cast per Query(T) or null (Defined by DataUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MongoDBDataStore Class
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.BeginTransaction Method

MongoDBDataStore BeginTransaction Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual CRUDTransaction BeginTransaction(
    IsolationLevel iso = IsolationLevel.ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior.CommitOnDispose
)
public virtual CRUDTransaction BeginTransaction(
    IsolationLevel iso = IsolationLevel.ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior.CommitOnDispose
)
Public Overridable Function BeginTransaction (
    Optional iso As IsolationLevel = IsolationLevel.ReadCommitted,
    Optional behavior As TransactionDisposeBehavior = TransactionDisposeBehavior.CommitOnDispose
) As CRUDTransaction
Public Overridable Function BeginTransaction (
    Optional iso As IsolationLevel = IsolationLevel.ReadCommitted,
    Optional behavior As TransactionDisposeBehavior = TransactionDisposeBehavior.CommitOnDispose
) As CRUDTransaction
public:
virtual CRUDTransaction^ BeginTransaction(
    IsolationLevel iso = IsolationLevel::ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior::CommitOnDispose
)
public:
virtual CRUDTransaction^ BeginTransaction(
    IsolationLevel iso = IsolationLevel::ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior::CommitOnDispose
)
abstract BeginTransaction :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> CRUDTransaction
override BeginTransaction :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> CRUDTransaction
abstract BeginTransaction :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> CRUDTransaction
override BeginTransaction :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> CRUDTransaction

Parameters

iso (Optional)
Type: Online System.Data IsolationLevel
behavior (Optional)
Type: NFX.DataAccess.CRUD TransactionDisposeBehavior

Return Value

Type: CRUDTransaction

Implements

ICRUDTransactionOperations BeginTransaction(IsolationLevel, TransactionDisposeBehavior)
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.BeginTransactionAsync Method

MongoDBDataStore BeginTransactionAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Task<CRUDTransaction> BeginTransactionAsync(
    IsolationLevel iso = IsolationLevel.ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior.CommitOnDispose
)
public virtual Task<CRUDTransaction> BeginTransactionAsync(
    IsolationLevel iso = IsolationLevel.ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior.CommitOnDispose
)
Public Overridable Function BeginTransactionAsync (
    Optional iso As IsolationLevel = IsolationLevel.ReadCommitted,
    Optional behavior As TransactionDisposeBehavior = TransactionDisposeBehavior.CommitOnDispose
) As Task(Of CRUDTransaction)
Public Overridable Function BeginTransactionAsync (
    Optional iso As IsolationLevel = IsolationLevel.ReadCommitted,
    Optional behavior As TransactionDisposeBehavior = TransactionDisposeBehavior.CommitOnDispose
) As Task(Of CRUDTransaction)
public:
virtual Task<CRUDTransaction^>^ BeginTransactionAsync(
    IsolationLevel iso = IsolationLevel::ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior::CommitOnDispose
)
public:
virtual Task<CRUDTransaction^>^ BeginTransactionAsync(
    IsolationLevel iso = IsolationLevel::ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior::CommitOnDispose
)
abstract BeginTransactionAsync :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> Task<CRUDTransaction>
override BeginTransactionAsync :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> Task<CRUDTransaction>
abstract BeginTransactionAsync :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> Task<CRUDTransaction>
override BeginTransactionAsync :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> Task<CRUDTransaction>

Parameters

iso (Optional)
Type: Online System.Data IsolationLevel
behavior (Optional)
Type: NFX.DataAccess.CRUD TransactionDisposeBehavior

Return Value

Type: Online Task CRUDTransaction

Implements

ICRUDTransactionOperations BeginTransactionAsync(IsolationLevel, TransactionDisposeBehavior)
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.Configure Method

MongoDBDataStore Configure Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Configure(
    IConfigSectionNode node
)
public override void Configure(
    IConfigSectionNode node
)
Public Overrides Sub Configure (
    node As IConfigSectionNode
)
Public Overrides Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) override
public:
virtual void Configure(
    IConfigSectionNode^ node
) override
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
IConfigurable Configure(IConfigSectionNode)
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.Delete Method

MongoDBDataStore Delete Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Delete(
    Row row,
    IDataStoreKey key = null
)
public int Delete(
    Row row,
    IDataStoreKey key = null
)
Public Function Delete (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Integer
Public Function Delete (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Integer
public:
virtual int Delete(
    Row^ row,
    IDataStoreKey^ key = nullptr
) sealed
public:
virtual int Delete(
    Row^ row,
    IDataStoreKey^ key = nullptr
) sealed
abstract Delete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int
override Delete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int
abstract Delete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int
override Delete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey

Return Value

Type: Online Int32

Implements

ICRUDOperations Delete(Row, IDataStoreKey)
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.DeleteAsync Method

MongoDBDataStore DeleteAsync Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Task<int> DeleteAsync(
    Row row,
    IDataStoreKey key = null
)
public virtual Task<int> DeleteAsync(
    Row row,
    IDataStoreKey key = null
)
Public Overridable Function DeleteAsync (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Task(Of Integer)
Public Overridable Function DeleteAsync (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Task(Of Integer)
public:
virtual Task<int>^ DeleteAsync(
    Row^ row,
    IDataStoreKey^ key = nullptr
)
public:
virtual Task<int>^ DeleteAsync(
    Row^ row,
    IDataStoreKey^ key = nullptr
)
abstract DeleteAsync :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> Task<int>
override DeleteAsync :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> Task<int>
abstract DeleteAsync :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> Task<int>
override DeleteAsync :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations DeleteAsync(Row, IDataStoreKey)
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.DoDelete Method

MongoDBDataStore DoDelete Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual int DoDelete(
    Database db,
    Row row,
    IDataStoreKey key
)
protected virtual int DoDelete(
    Database db,
    Row row,
    IDataStoreKey key
)
Protected Overridable Function DoDelete (
    db As Database,
    row As Row,
    key As IDataStoreKey
) As Integer
Protected Overridable Function DoDelete (
    db As Database,
    row As Row,
    key As IDataStoreKey
) As Integer
protected:
virtual int DoDelete(
    Database^ db,
    Row^ row,
    IDataStoreKey^ key
)
protected:
virtual int DoDelete(
    Database^ db,
    Row^ row,
    IDataStoreKey^ key
)
abstract DoDelete :
        db : Database *
        row : Row *
        key : IDataStoreKey -> int
override DoDelete :
        db : Database *
        row : Row *
        key : IDataStoreKey -> int
abstract DoDelete :
        db : Database *
        row : Row *
        key : IDataStoreKey -> int
override DoDelete :
        db : Database *
        row : Row *
        key : IDataStoreKey -> int

Parameters

db
Type: NFX.DataAccess.MongoDB.Connector Database
row
Type: NFX.DataAccess.CRUD Row
key
Type: NFX.DataAccess IDataStoreKey

Return Value

Type: Online Int32
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.DoInsert Method

MongoDBDataStore DoInsert Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual int DoInsert(
    Database db,
    Row row,
    FieldFilterFunc filter = null
)
protected virtual int DoInsert(
    Database db,
    Row row,
    FieldFilterFunc filter = null
)
Protected Overridable Function DoInsert (
    db As Database,
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Protected Overridable Function DoInsert (
    db As Database,
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
protected:
virtual int DoInsert(
    Database^ db,
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
protected:
virtual int DoInsert(
    Database^ db,
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
abstract DoInsert :
        db : Database *
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override DoInsert :
        db : Database *
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
abstract DoInsert :
        db : Database *
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override DoInsert :
        db : Database *
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int

Parameters

db
Type: NFX.DataAccess.MongoDB.Connector Database
row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.DoUpdate Method

MongoDBDataStore DoUpdate Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual int DoUpdate(
    Database db,
    Row row,
    IDataStoreKey key,
    FieldFilterFunc filter = null
)
protected virtual int DoUpdate(
    Database db,
    Row row,
    IDataStoreKey key,
    FieldFilterFunc filter = null
)
Protected Overridable Function DoUpdate (
    db As Database,
    row As Row,
    key As IDataStoreKey,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Protected Overridable Function DoUpdate (
    db As Database,
    row As Row,
    key As IDataStoreKey,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
protected:
virtual int DoUpdate(
    Database^ db,
    Row^ row,
    IDataStoreKey^ key,
    FieldFilterFunc^ filter = nullptr
)
protected:
virtual int DoUpdate(
    Database^ db,
    Row^ row,
    IDataStoreKey^ key,
    FieldFilterFunc^ filter = nullptr
)
abstract DoUpdate :
        db : Database *
        row : Row *
        key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override DoUpdate :
        db : Database *
        row : Row *
        key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
abstract DoUpdate :
        db : Database *
        row : Row *
        key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override DoUpdate :
        db : Database *
        row : Row *
        key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int

Parameters

db
Type: NFX.DataAccess.MongoDB.Connector Database
row
Type: NFX.DataAccess.CRUD Row
key
Type: NFX.DataAccess IDataStoreKey
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.DoUpsert Method

MongoDBDataStore DoUpsert Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual int DoUpsert(
    Database db,
    Row row,
    FieldFilterFunc filter = null
)
protected virtual int DoUpsert(
    Database db,
    Row row,
    FieldFilterFunc filter = null
)
Protected Overridable Function DoUpsert (
    db As Database,
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Protected Overridable Function DoUpsert (
    db As Database,
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
protected:
virtual int DoUpsert(
    Database^ db,
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
protected:
virtual int DoUpsert(
    Database^ db,
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
abstract DoUpsert :
        db : Database *
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override DoUpsert :
        db : Database *
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
abstract DoUpsert :
        db : Database *
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override DoUpsert :
        db : Database *
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int

Parameters

db
Type: NFX.DataAccess.MongoDB.Connector Database
row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.ExecuteWithoutFetch Method

MongoDBDataStore ExecuteWithoutFetch Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int ExecuteWithoutFetch(
    params Query[] queries
)
public virtual int ExecuteWithoutFetch(
    params Query[] queries
)
Public Overridable Function ExecuteWithoutFetch (
    ParamArray queries As Query()
) As Integer
Public Overridable Function ExecuteWithoutFetch (
    ParamArray queries As Query()
) As Integer
public:
virtual int ExecuteWithoutFetch(
    ... array<Query^>^ queries
)
public:
virtual int ExecuteWithoutFetch(
    ... array<Query^>^ queries
)
abstract ExecuteWithoutFetch :
        queries : Query[] -> int
override ExecuteWithoutFetch :
        queries : Query[] -> int
abstract ExecuteWithoutFetch :
        queries : Query[] -> int
override ExecuteWithoutFetch :
        queries : Query[] -> int

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Int32

Implements

ICRUDOperations ExecuteWithoutFetch( Query )
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.ExecuteWithoutFetchAsync Method

MongoDBDataStore ExecuteWithoutFetchAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Task<int> ExecuteWithoutFetchAsync(
    params Query[] queries
)
public virtual Task<int> ExecuteWithoutFetchAsync(
    params Query[] queries
)
Public Overridable Function ExecuteWithoutFetchAsync (
    ParamArray queries As Query()
) As Task(Of Integer)
Public Overridable Function ExecuteWithoutFetchAsync (
    ParamArray queries As Query()
) As Task(Of Integer)
public:
virtual Task<int>^ ExecuteWithoutFetchAsync(
    ... array<Query^>^ queries
)
public:
virtual Task<int>^ ExecuteWithoutFetchAsync(
    ... array<Query^>^ queries
)
abstract ExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>
override ExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>
abstract ExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>
override ExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations ExecuteWithoutFetchAsync( Query )
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.GetCollectionName Method

MongoDBDataStore GetCollectionName Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal string GetCollectionName(
    Schema schema
)
protected internal string GetCollectionName(
    Schema schema
)
Protected Friend Function GetCollectionName (
    schema As Schema
) As String
Protected Friend Function GetCollectionName (
    schema As Schema
) As String
protected public:
String^ GetCollectionName(
    Schema^ schema
)
protected public:
String^ GetCollectionName(
    Schema^ schema
)
member GetCollectionName :
        schema : Schema -> string
member GetCollectionName :
        schema : Schema -> string

Parameters

schema
Type: NFX.DataAccess.CRUD Schema

Return Value

Type: Online String
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.GetSchema Method

MongoDBDataStore GetSchema Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Schema GetSchema(
    Query query
)
public virtual Schema GetSchema(
    Query query
)
Public Overridable Function GetSchema (
    query As Query
) As Schema
Public Overridable Function GetSchema (
    query As Query
) As Schema
public:
virtual Schema^ GetSchema(
    Query^ query
)
public:
virtual Schema^ GetSchema(
    Query^ query
)
abstract GetSchema :
        query : Query -> Schema
override GetSchema :
        query : Query -> Schema
abstract GetSchema :
        query : Query -> Schema
override GetSchema :
        query : Query -> Schema

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Schema

Implements

ICRUDOperations GetSchema(Query)
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.GetSchemaAsync Method

MongoDBDataStore GetSchemaAsync Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Task<Schema> GetSchemaAsync(
    Query query
)
public virtual Task<Schema> GetSchemaAsync(
    Query query
)
Public Overridable Function GetSchemaAsync (
    query As Query
) As Task(Of Schema)
Public Overridable Function GetSchemaAsync (
    query As Query
) As Task(Of Schema)
public:
virtual Task<Schema^>^ GetSchemaAsync(
    Query^ query
)
public:
virtual Task<Schema^>^ GetSchemaAsync(
    Query^ query
)
abstract GetSchemaAsync :
        query : Query -> Task<Schema>
override GetSchemaAsync :
        query : Query -> Task<Schema>
abstract GetSchemaAsync :
        query : Query -> Task<Schema>
override GetSchemaAsync :
        query : Query -> Task<Schema>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Schema

Implements

ICRUDOperations GetSchemaAsync(Query)
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.Insert Method

MongoDBDataStore Insert Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Insert(
    Row row,
    FieldFilterFunc filter = null
)
public virtual int Insert(
    Row row,
    FieldFilterFunc filter = null
)
Public Overridable Function Insert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Public Overridable Function Insert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
public:
virtual int Insert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
public:
virtual int Insert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
abstract Insert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override Insert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
abstract Insert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override Insert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32

Implements

ICRUDOperations Insert(Row, FieldFilterFunc)
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.InsertAsync Method

MongoDBDataStore InsertAsync Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Task<int> InsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
public virtual Task<int> InsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
Public Overridable Function InsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
Public Overridable Function InsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
public:
virtual Task<int>^ InsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
public:
virtual Task<int>^ InsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
abstract InsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
override InsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
abstract InsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
override InsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations InsertAsync(Row, FieldFilterFunc)
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.Load Method

MongoDBDataStore Load Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual List<RowsetBase> Load(
    params Query[] queries
)
public virtual List<RowsetBase> Load(
    params Query[] queries
)
Public Overridable Function Load (
    ParamArray queries As Query()
) As List(Of RowsetBase)
Public Overridable Function Load (
    ParamArray queries As Query()
) As List(Of RowsetBase)
public:
virtual List<RowsetBase^>^ Load(
    ... array<Query^>^ queries
)
public:
virtual List<RowsetBase^>^ Load(
    ... array<Query^>^ queries
)
abstract Load :
        queries : Query[] -> List<RowsetBase>
override Load :
        queries : Query[] -> List<RowsetBase>
abstract Load :
        queries : Query[] -> List<RowsetBase>
override Load :
        queries : Query[] -> List<RowsetBase>

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online List RowsetBase

Implements

ICRUDOperations Load( Query )
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.LoadAsync Method

MongoDBDataStore LoadAsync Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Task<List<RowsetBase>> LoadAsync(
    params Query[] queries
)
public virtual Task<List<RowsetBase>> LoadAsync(
    params Query[] queries
)
Public Overridable Function LoadAsync (
    ParamArray queries As Query()
) As Task(Of List(Of RowsetBase))
Public Overridable Function LoadAsync (
    ParamArray queries As Query()
) As Task(Of List(Of RowsetBase))
public:
virtual Task<List<RowsetBase^>^>^ LoadAsync(
    ... array<Query^>^ queries
)
public:
virtual Task<List<RowsetBase^>^>^ LoadAsync(
    ... array<Query^>^ queries
)
abstract LoadAsync :
        queries : Query[] -> Task<List<RowsetBase>>
override LoadAsync :
        queries : Query[] -> Task<List<RowsetBase>>
abstract LoadAsync :
        queries : Query[] -> Task<List<RowsetBase>>
override LoadAsync :
        queries : Query[] -> Task<List<RowsetBase>>

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Online List RowsetBase

Implements

ICRUDOperations LoadAsync( Query )
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.LoadOneRow Method

MongoDBDataStore LoadOneRow Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Row LoadOneRow(
    Query query
)
public virtual Row LoadOneRow(
    Query query
)
Public Overridable Function LoadOneRow (
    query As Query
) As Row
Public Overridable Function LoadOneRow (
    query As Query
) As Row
public:
virtual Row^ LoadOneRow(
    Query^ query
)
public:
virtual Row^ LoadOneRow(
    Query^ query
)
abstract LoadOneRow :
        query : Query -> Row
override LoadOneRow :
        query : Query -> Row
abstract LoadOneRow :
        query : Query -> Row
override LoadOneRow :
        query : Query -> Row

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Row

Implements

ICRUDOperations LoadOneRow(Query)
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.LoadOneRowAsync Method

MongoDBDataStore LoadOneRowAsync Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Task<Row> LoadOneRowAsync(
    Query query
)
public virtual Task<Row> LoadOneRowAsync(
    Query query
)
Public Overridable Function LoadOneRowAsync (
    query As Query
) As Task(Of Row)
Public Overridable Function LoadOneRowAsync (
    query As Query
) As Task(Of Row)
public:
virtual Task<Row^>^ LoadOneRowAsync(
    Query^ query
)
public:
virtual Task<Row^>^ LoadOneRowAsync(
    Query^ query
)
abstract LoadOneRowAsync :
        query : Query -> Task<Row>
override LoadOneRowAsync :
        query : Query -> Task<Row>
abstract LoadOneRowAsync :
        query : Query -> Task<Row>
override LoadOneRowAsync :
        query : Query -> Task<Row>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Row

Implements

ICRUDOperations LoadOneRowAsync(Query)
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.LoadOneRowset Method

MongoDBDataStore LoadOneRowset Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual RowsetBase LoadOneRowset(
    Query query
)
public virtual RowsetBase LoadOneRowset(
    Query query
)
Public Overridable Function LoadOneRowset (
    query As Query
) As RowsetBase
Public Overridable Function LoadOneRowset (
    query As Query
) As RowsetBase
public:
virtual RowsetBase^ LoadOneRowset(
    Query^ query
)
public:
virtual RowsetBase^ LoadOneRowset(
    Query^ query
)
abstract LoadOneRowset :
        query : Query -> RowsetBase
override LoadOneRowset :
        query : Query -> RowsetBase
abstract LoadOneRowset :
        query : Query -> RowsetBase
override LoadOneRowset :
        query : Query -> RowsetBase

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: RowsetBase

Implements

ICRUDOperations LoadOneRowset(Query)
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.LoadOneRowsetAsync Method

MongoDBDataStore LoadOneRowsetAsync Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Task<RowsetBase> LoadOneRowsetAsync(
    Query query
)
public virtual Task<RowsetBase> LoadOneRowsetAsync(
    Query query
)
Public Overridable Function LoadOneRowsetAsync (
    query As Query
) As Task(Of RowsetBase)
Public Overridable Function LoadOneRowsetAsync (
    query As Query
) As Task(Of RowsetBase)
public:
virtual Task<RowsetBase^>^ LoadOneRowsetAsync(
    Query^ query
)
public:
virtual Task<RowsetBase^>^ LoadOneRowsetAsync(
    Query^ query
)
abstract LoadOneRowsetAsync :
        query : Query -> Task<RowsetBase>
override LoadOneRowsetAsync :
        query : Query -> Task<RowsetBase>
abstract LoadOneRowsetAsync :
        query : Query -> Task<RowsetBase>
override LoadOneRowsetAsync :
        query : Query -> Task<RowsetBase>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task RowsetBase

Implements

ICRUDOperations LoadOneRowsetAsync(Query)
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.MakeScriptQueryHandler Method

MongoDBDataStore MakeScriptQueryHandler Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDQueryHandler MakeScriptQueryHandler(
    QuerySource querySource
)
public CRUDQueryHandler MakeScriptQueryHandler(
    QuerySource querySource
)
Public Function MakeScriptQueryHandler (
    querySource As QuerySource
) As CRUDQueryHandler
Public Function MakeScriptQueryHandler (
    querySource As QuerySource
) As CRUDQueryHandler
public:
virtual CRUDQueryHandler^ MakeScriptQueryHandler(
    QuerySource^ querySource
) sealed
public:
virtual CRUDQueryHandler^ MakeScriptQueryHandler(
    QuerySource^ querySource
) sealed
abstract MakeScriptQueryHandler :
        querySource : QuerySource -> CRUDQueryHandler
override MakeScriptQueryHandler :
        querySource : QuerySource -> CRUDQueryHandler
abstract MakeScriptQueryHandler :
        querySource : QuerySource -> CRUDQueryHandler
override MakeScriptQueryHandler :
        querySource : QuerySource -> CRUDQueryHandler

Parameters

querySource
Type: NFX.DataAccess.CRUD QuerySource

Return Value

Type: CRUDQueryHandler

Implements

ICRUDDataStoreImplementation MakeScriptQueryHandler(QuerySource)
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.OpenCursor Method

MongoDBDataStore OpenCursor Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Cursor OpenCursor(
    Query query
)
public virtual Cursor OpenCursor(
    Query query
)
Public Overridable Function OpenCursor (
    query As Query
) As Cursor
Public Overridable Function OpenCursor (
    query As Query
) As Cursor
public:
virtual Cursor^ OpenCursor(
    Query^ query
)
public:
virtual Cursor^ OpenCursor(
    Query^ query
)
abstract OpenCursor :
        query : Query -> Cursor
override OpenCursor :
        query : Query -> Cursor
abstract OpenCursor :
        query : Query -> Cursor
override OpenCursor :
        query : Query -> Cursor

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Cursor

Implements

ICRUDOperations OpenCursor(Query)
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.OpenCursorAsync Method

MongoDBDataStore OpenCursorAsync Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Task<Cursor> OpenCursorAsync(
    Query query
)
public virtual Task<Cursor> OpenCursorAsync(
    Query query
)
Public Overridable Function OpenCursorAsync (
    query As Query
) As Task(Of Cursor)
Public Overridable Function OpenCursorAsync (
    query As Query
) As Task(Of Cursor)
public:
virtual Task<Cursor^>^ OpenCursorAsync(
    Query^ query
)
public:
virtual Task<Cursor^>^ OpenCursorAsync(
    Query^ query
)
abstract OpenCursorAsync :
        query : Query -> Task<Cursor>
override OpenCursorAsync :
        query : Query -> Task<Cursor>
abstract OpenCursorAsync :
        query : Query -> Task<Cursor>
override OpenCursorAsync :
        query : Query -> Task<Cursor>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Cursor

Implements

ICRUDOperations OpenCursorAsync(Query)
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.Save Method

MongoDBDataStore Save Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Save(
    params RowsetBase[] rowsets
)
public virtual int Save(
    params RowsetBase[] rowsets
)
Public Overridable Function Save (
    ParamArray rowsets As RowsetBase()
) As Integer
Public Overridable Function Save (
    ParamArray rowsets As RowsetBase()
) As Integer
public:
virtual int Save(
    ... array<RowsetBase^>^ rowsets
)
public:
virtual int Save(
    ... array<RowsetBase^>^ rowsets
)
abstract Save :
        rowsets : RowsetBase[] -> int
override Save :
        rowsets : RowsetBase[] -> int
abstract Save :
        rowsets : RowsetBase[] -> int
override Save :
        rowsets : RowsetBase[] -> int

Parameters

rowsets
Type: NFX.DataAccess.CRUD RowsetBase

Return Value

Type: Online Int32

Implements

ICRUDOperations Save( RowsetBase )
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.SaveAsync Method

MongoDBDataStore SaveAsync Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Task<int> SaveAsync(
    params RowsetBase[] rowsets
)
public virtual Task<int> SaveAsync(
    params RowsetBase[] rowsets
)
Public Overridable Function SaveAsync (
    ParamArray rowsets As RowsetBase()
) As Task(Of Integer)
Public Overridable Function SaveAsync (
    ParamArray rowsets As RowsetBase()
) As Task(Of Integer)
public:
virtual Task<int>^ SaveAsync(
    ... array<RowsetBase^>^ rowsets
)
public:
virtual Task<int>^ SaveAsync(
    ... array<RowsetBase^>^ rowsets
)
abstract SaveAsync :
        rowsets : RowsetBase[] -> Task<int>
override SaveAsync :
        rowsets : RowsetBase[] -> Task<int>
abstract SaveAsync :
        rowsets : RowsetBase[] -> Task<int>
override SaveAsync :
        rowsets : RowsetBase[] -> Task<int>

Parameters

rowsets
Type: NFX.DataAccess.CRUD RowsetBase

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations SaveAsync( RowsetBase )
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.Update Method

MongoDBDataStore Update Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Update(
    Row row,
    IDataStoreKey key = null,
    FieldFilterFunc filter = null
)
public virtual int Update(
    Row row,
    IDataStoreKey key = null,
    FieldFilterFunc filter = null
)
Public Overridable Function Update (
    row As Row,
    Optional key As IDataStoreKey = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Public Overridable Function Update (
    row As Row,
    Optional key As IDataStoreKey = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
public:
virtual int Update(
    Row^ row,
    IDataStoreKey^ key = nullptr,
    FieldFilterFunc^ filter = nullptr
)
public:
virtual int Update(
    Row^ row,
    IDataStoreKey^ key = nullptr,
    FieldFilterFunc^ filter = nullptr
)
abstract Update :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> int
override Update :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> int
abstract Update :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> int
override Update :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32

Implements

ICRUDOperations Update(Row, IDataStoreKey, FieldFilterFunc)
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.UpdateAsync Method

MongoDBDataStore UpdateAsync Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Task<int> UpdateAsync(
    Row row,
    IDataStoreKey key = null,
    FieldFilterFunc filter = null
)
public virtual Task<int> UpdateAsync(
    Row row,
    IDataStoreKey key = null,
    FieldFilterFunc filter = null
)
Public Overridable Function UpdateAsync (
    row As Row,
    Optional key As IDataStoreKey = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
Public Overridable Function UpdateAsync (
    row As Row,
    Optional key As IDataStoreKey = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
public:
virtual Task<int>^ UpdateAsync(
    Row^ row,
    IDataStoreKey^ key = nullptr,
    FieldFilterFunc^ filter = nullptr
)
public:
virtual Task<int>^ UpdateAsync(
    Row^ row,
    IDataStoreKey^ key = nullptr,
    FieldFilterFunc^ filter = nullptr
)
abstract UpdateAsync :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> Task<int>
override UpdateAsync :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> Task<int>
abstract UpdateAsync :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> Task<int>
override UpdateAsync :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations UpdateAsync(Row, IDataStoreKey, FieldFilterFunc)
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.Upsert Method

MongoDBDataStore Upsert Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Upsert(
    Row row,
    FieldFilterFunc filter = null
)
public virtual int Upsert(
    Row row,
    FieldFilterFunc filter = null
)
Public Overridable Function Upsert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Public Overridable Function Upsert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
public:
virtual int Upsert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
public:
virtual int Upsert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
abstract Upsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override Upsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
abstract Upsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override Upsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32

Implements

ICRUDOperations Upsert(Row, FieldFilterFunc)
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.UpsertAsync Method

MongoDBDataStore UpsertAsync Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Task<int> UpsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
public virtual Task<int> UpsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
Public Overridable Function UpsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
Public Overridable Function UpsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
public:
virtual Task<int>^ UpsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
public:
virtual Task<int>^ UpsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
abstract UpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
override UpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
abstract UpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
override UpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations UpsertAsync(Row, FieldFilterFunc)
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore Properties

MongoDBDataStore Properties NFX Class Library

The MongoDBDataStore type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | ConnectString | Get/Sets MongoDB database connection string (Inherited from MongoDBDataStoreBase.)
Public property | Converter |
Public property | DatabaseName | Get/Sets MongoDB database name (Inherited from MongoDBDataStoreBase.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from MongoDBDataStoreBase.)
Public property | InstrumentationEnabled | (Inherited from MongoDBDataStoreBase.)
Public property | LogLevel | (Inherited from MongoDBDataStoreBase.)
Public property | Name | (Inherited from MongoDBDataStoreBase.)
Public property | QueryResolver |
Public property | ScriptFileSuffix |
Public property | StoreType |
Public property | SupportsTransactions |
Public property | SupportsTrueAsynchrony |
Public property | TargetName | (Inherited from MongoDBDataStoreBase.)
Back to Top
See Also
MongoDBDataStore Class
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.Converter Property

MongoDBDataStore Converter Property NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RowConverter Converter { get; }
public RowConverter Converter { get; }
Public ReadOnly Property Converter As RowConverter
    Get
Public ReadOnly Property Converter As RowConverter
    Get
public:
property RowConverter^ Converter {
    RowConverter^ get ();
}
public:
property RowConverter^ Converter {
    RowConverter^ get ();
}
member Converter : RowConverter with get
member Converter : RowConverter with get

Property Value

Type: RowConverter
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.QueryResolver Property

MongoDBDataStore QueryResolver Property NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICRUDQueryResolver QueryResolver { get; }
public ICRUDQueryResolver QueryResolver { get; }
Public ReadOnly Property QueryResolver As ICRUDQueryResolver
    Get
Public ReadOnly Property QueryResolver As ICRUDQueryResolver
    Get
public:
virtual property ICRUDQueryResolver^ QueryResolver {
    ICRUDQueryResolver^ get () sealed;
}
public:
virtual property ICRUDQueryResolver^ QueryResolver {
    ICRUDQueryResolver^ get () sealed;
}
abstract QueryResolver : ICRUDQueryResolver with get
override QueryResolver : ICRUDQueryResolver with get
abstract QueryResolver : ICRUDQueryResolver with get
override QueryResolver : ICRUDQueryResolver with get

Property Value

Type: ICRUDQueryResolver

Implements

ICRUDDataStore QueryResolver
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.ScriptFileSuffix Property

MongoDBDataStore ScriptFileSuffix Property NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string ScriptFileSuffix { get; }
public virtual string ScriptFileSuffix { get; }
Public Overridable ReadOnly Property ScriptFileSuffix As String
    Get
Public Overridable ReadOnly Property ScriptFileSuffix As String
    Get
public:
virtual property String^ ScriptFileSuffix {
    String^ get ();
}
public:
virtual property String^ ScriptFileSuffix {
    String^ get ();
}
abstract ScriptFileSuffix : string with get
override ScriptFileSuffix : string with get
abstract ScriptFileSuffix : string with get
override ScriptFileSuffix : string with get

Property Value

Type: Online String

Implements

ICRUDDataStore ScriptFileSuffix
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.StoreType Property

MongoDBDataStore StoreType Property NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual CRUDDataStoreType StoreType { get; }
public virtual CRUDDataStoreType StoreType { get; }
Public Overridable ReadOnly Property StoreType As CRUDDataStoreType
    Get
Public Overridable ReadOnly Property StoreType As CRUDDataStoreType
    Get
public:
virtual property CRUDDataStoreType StoreType {
    CRUDDataStoreType get ();
}
public:
virtual property CRUDDataStoreType StoreType {
    CRUDDataStoreType get ();
}
abstract StoreType : CRUDDataStoreType with get
override StoreType : CRUDDataStoreType with get
abstract StoreType : CRUDDataStoreType with get
override StoreType : CRUDDataStoreType with get

Property Value

Type: CRUDDataStoreType

Implements

ICRUDDataStore StoreType
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.SupportsTransactions Property

MongoDBDataStore SupportsTransactions Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool SupportsTransactions { get; }
public virtual bool SupportsTransactions { get; }
Public Overridable ReadOnly Property SupportsTransactions As Boolean
    Get
Public Overridable ReadOnly Property SupportsTransactions As Boolean
    Get
public:
virtual property bool SupportsTransactions {
    bool get ();
}
public:
virtual property bool SupportsTransactions {
    bool get ();
}
abstract SupportsTransactions : bool with get
override SupportsTransactions : bool with get
abstract SupportsTransactions : bool with get
override SupportsTransactions : bool with get

Property Value

Type: Online Boolean

Implements

ICRUDTransactionOperations SupportsTransactions
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStore.SupportsTrueAsynchrony Property

MongoDBDataStore SupportsTrueAsynchrony Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool SupportsTrueAsynchrony { get; }
public virtual bool SupportsTrueAsynchrony { get; }
Public Overridable ReadOnly Property SupportsTrueAsynchrony As Boolean
    Get
Public Overridable ReadOnly Property SupportsTrueAsynchrony As Boolean
    Get
public:
virtual property bool SupportsTrueAsynchrony {
    bool get ();
}
public:
virtual property bool SupportsTrueAsynchrony {
    bool get ();
}
abstract SupportsTrueAsynchrony : bool with get
override SupportsTrueAsynchrony : bool with get
abstract SupportsTrueAsynchrony : bool with get
override SupportsTrueAsynchrony : bool with get

Property Value

Type: Online Boolean

Implements

ICRUDOperations SupportsTrueAsynchrony
See Also
MongoDBDataStore Class
MongoDBDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStoreBase Class

MongoDBDataStoreBase Class NFX Class Library

Implements MongoDB store base functionality Connect string takes form of:
View Colorized Copy to Clipboard Print
mongo{server="mongo://localhost:27017" db="myDB"}
mongo{server="mongo://localhost:27017" db="myDB"}
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.DataAccess.MongoDB MongoDBDataStoreBase
NFX.DataAccess.MongoDB MongoDBDataStore
NFX.DataAccess.MongoDB MongoDBLogMessageDataStore

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class MongoDBDataStoreBase : ApplicationComponent,
    IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
public abstract class MongoDBDataStoreBase : ApplicationComponent,
    IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
Public MustInherit Class MongoDBDataStoreBase
    Inherits ApplicationComponent
    Implements IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
Public MustInherit Class MongoDBDataStoreBase
    Inherits ApplicationComponent
    Implements IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
public ref class MongoDBDataStoreBase abstract : public ApplicationComponent,
    IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
public ref class MongoDBDataStoreBase abstract : public ApplicationComponent,
    IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
[<AbstractClassAttribute>]
type MongoDBDataStoreBase =
    class
        inherit ApplicationComponent
        interface IDataStoreImplementation
        interface IDataStore
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
[<AbstractClassAttribute>]
type MongoDBDataStoreBase =
    class
        inherit ApplicationComponent
        interface IDataStoreImplementation
        interface IDataStore
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
MongoDBDataStoreBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStoreBase Members

MongoDBDataStoreBase Members NFX Class Library

The MongoDBDataStoreBase type exposes the following members.
Constructors
 | Name | Description
Protected method | MongoDBDataStoreBase | Initializes a new instance of the MongoDBDataStoreBase class
Protected method | MongoDBDataStoreBase(String, String) | Initializes a new instance of the MongoDBDataStoreBase class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | Configure |
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetDatabase | Gets appropriate database. It does not need to be disposed
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | TestConnection |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | ConnectString | Get/Sets MongoDB database connection string
Public property | DatabaseName | Get/Sets MongoDB database name
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component
Public property | InstrumentationEnabled |
Public property | LogLevel |
Public property | Name |
Public property | TargetName |
Back to Top
See Also
MongoDBDataStoreBase Class
NFX.DataAccess.MongoDB Namespace


MongoDBDataStoreBase Constructor

MongoDBDataStoreBase Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | MongoDBDataStoreBase | Initializes a new instance of the MongoDBDataStoreBase class
Protected method | MongoDBDataStoreBase(String, String) | Initializes a new instance of the MongoDBDataStoreBase class
Back to Top
See Also
MongoDBDataStoreBase Class
MongoDBDataStoreBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStoreBase Constructor

MongoDBDataStoreBase Constructor NFX Class Library

Initializes a new instance of the MongoDBDataStoreBase class

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MongoDBDataStoreBase()
protected MongoDBDataStoreBase()
Protected Sub New
Protected Sub New
protected:
MongoDBDataStoreBase()
protected:
MongoDBDataStoreBase()
new : unit -> MongoDBDataStoreBase
new : unit -> MongoDBDataStoreBase
See Also
MongoDBDataStoreBase Class
MongoDBDataStoreBase Members
MongoDBDataStoreBase Overload
NFX.DataAccess.MongoDB Namespace


MongoDBDataStoreBase Constructor (String, String)

MongoDBDataStoreBase Constructor (String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MongoDBDataStoreBase class

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MongoDBDataStoreBase(
    string connectString,
    string dbName
)
protected MongoDBDataStoreBase(
    string connectString,
    string dbName
)
Protected Sub New (
    connectString As String,
    dbName As String
)
Protected Sub New (
    connectString As String,
    dbName As String
)
protected:
MongoDBDataStoreBase(
    String^ connectString,
    String^ dbName
)
protected:
MongoDBDataStoreBase(
    String^ connectString,
    String^ dbName
)
new :
        connectString : string *
        dbName : string -> MongoDBDataStoreBase
new :
        connectString : string *
        dbName : string -> MongoDBDataStoreBase

Parameters

connectString
Type: Online System String
dbName
Type: Online System String
See Also
MongoDBDataStoreBase Class
MongoDBDataStoreBase Members
MongoDBDataStoreBase Overload
NFX.DataAccess.MongoDB Namespace


MongoDBDataStoreBase Methods

MongoDBDataStoreBase Methods NFX Class Library

The MongoDBDataStoreBase type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | Configure |
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetDatabase | Gets appropriate database. It does not need to be disposed
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | TestConnection |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MongoDBDataStoreBase Class
NFX.DataAccess.MongoDB Namespace


MongoDBDataStoreBase.Configure Method

MongoDBDataStoreBase Configure Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Configure(
    IConfigSectionNode node
)
public virtual void Configure(
    IConfigSectionNode node
)
Public Overridable Sub Configure (
    node As IConfigSectionNode
)
Public Overridable Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
)
public:
virtual void Configure(
    IConfigSectionNode^ node
)
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
MongoDBDataStoreBase Class
MongoDBDataStoreBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStoreBase.ExternalGetParameter Method

MongoDBDataStoreBase ExternalGetParameter Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets external parameter value returning true if parameter was found

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
public bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
Public Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
Public Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
) sealed
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
) sealed
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalGetParameter(String, Object , String )
See Also
MongoDBDataStoreBase Class
MongoDBDataStoreBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStoreBase.ExternalParametersForGroups Method

MongoDBDataStoreBase ExternalParametersForGroups Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns named parameters that can be used to control this component

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
public IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
Public Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
Public Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
) sealed
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
) sealed
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>

Parameters

groups
Type: Online System String

Return Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParametersForGroups( String )
See Also
MongoDBDataStoreBase Class
MongoDBDataStoreBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStoreBase.ExternalSetParameter Method

MongoDBDataStoreBase ExternalSetParameter Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Sets external parameter value returning true if parameter was found and set

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
public bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
Public Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
Public Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
) sealed
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
) sealed
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalSetParameter(String, Object, String )
See Also
MongoDBDataStoreBase Class
MongoDBDataStoreBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStoreBase.GetDatabase Method

MongoDBDataStoreBase GetDatabase Method NFX Class Library

Gets appropriate database. It does not need to be disposed

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Database GetDatabase()
protected Database GetDatabase()
Protected Function GetDatabase As Database
Protected Function GetDatabase As Database
protected:
Database^ GetDatabase()
protected:
Database^ GetDatabase()
member GetDatabase : unit -> Database
member GetDatabase : unit -> Database

Return Value

Type: Database
See Also
MongoDBDataStoreBase Class
MongoDBDataStoreBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStoreBase.TestConnection Method

MongoDBDataStoreBase TestConnection Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void TestConnection()
public void TestConnection()
Public Sub TestConnection
Public Sub TestConnection
public:
virtual void TestConnection() sealed
public:
virtual void TestConnection() sealed
abstract TestConnection : unit -> unit
override TestConnection : unit -> unit
abstract TestConnection : unit -> unit
override TestConnection : unit -> unit

Implements

IDataStore TestConnection
See Also
MongoDBDataStoreBase Class
MongoDBDataStoreBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStoreBase Properties

MongoDBDataStoreBase Properties NFX Class Library

The MongoDBDataStoreBase type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | ConnectString | Get/Sets MongoDB database connection string
Public property | DatabaseName | Get/Sets MongoDB database name
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component
Public property | InstrumentationEnabled |
Public property | LogLevel |
Public property | Name |
Public property | TargetName |
Back to Top
See Also
MongoDBDataStoreBase Class
NFX.DataAccess.MongoDB Namespace


MongoDBDataStoreBase.ConnectString Property

MongoDBDataStoreBase ConnectString Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Get/Sets MongoDB database connection string

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$connect-string")]
public string ConnectString { get; set; }
[ConfigAttribute("$connect-string")]
public string ConnectString { get; set; }
<ConfigAttribute("$connect-string")>
Public Property ConnectString As String
    Get
    Set
<ConfigAttribute("$connect-string")>
Public Property ConnectString As String
    Get
    Set
public:
[ConfigAttribute(L"$connect-string")]
property String^ ConnectString {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute(L"$connect-string")]
property String^ ConnectString {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute("$connect-string")>]
member ConnectString : string with get, set
[<ConfigAttribute("$connect-string")>]
member ConnectString : string with get, set

Property Value

Type: Online String
See Also
MongoDBDataStoreBase Class
MongoDBDataStoreBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStoreBase.DatabaseName Property

MongoDBDataStoreBase DatabaseName Property NFX Class Library

Get/Sets MongoDB database name

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$db-name")]
public string DatabaseName { get; set; }
[ConfigAttribute("$db-name")]
public string DatabaseName { get; set; }
<ConfigAttribute("$db-name")>
Public Property DatabaseName As String
    Get
    Set
<ConfigAttribute("$db-name")>
Public Property DatabaseName As String
    Get
    Set
public:
[ConfigAttribute(L"$db-name")]
property String^ DatabaseName {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute(L"$db-name")]
property String^ DatabaseName {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute("$db-name")>]
member DatabaseName : string with get, set
[<ConfigAttribute("$db-name")>]
member DatabaseName : string with get, set

Property Value

Type: Online String
See Also
MongoDBDataStoreBase Class
MongoDBDataStoreBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStoreBase.ExternalParameters Property

MongoDBDataStoreBase ExternalParameters Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns named parameters that can be used to control this component

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
public IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
Public ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
Public ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get () sealed;
}
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get () sealed;
}
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get

Property Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParameters
See Also
MongoDBDataStoreBase Class
MongoDBDataStoreBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStoreBase.InstrumentationEnabled Property

MongoDBDataStoreBase InstrumentationEnabled Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(new string[] { ... })]
public bool InstrumentationEnabled { get; set; }
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(new string[] { ... })]
public bool InstrumentationEnabled { get; set; }
<ConfigAttribute(Default := false)>
<ExternalParameterAttribute(New String() { ... })>
Public Property InstrumentationEnabled As Boolean
    Get
    Set
<ConfigAttribute(Default := false)>
<ExternalParameterAttribute(New String() { ... })>
Public Property InstrumentationEnabled As Boolean
    Get
    Set
public:
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property bool InstrumentationEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property bool InstrumentationEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
abstract InstrumentationEnabled : bool with get, set
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
override InstrumentationEnabled : bool with get, set
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
abstract InstrumentationEnabled : bool with get, set
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
override InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentable InstrumentationEnabled
See Also
MongoDBDataStoreBase Class
MongoDBDataStoreBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStoreBase.LogLevel Property

MongoDBDataStoreBase LogLevel Property NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public StoreLogLevel LogLevel { get; set; }
[ConfigAttribute]
public StoreLogLevel LogLevel { get; set; }
<ConfigAttribute>
Public Property LogLevel As StoreLogLevel
    Get
    Set
<ConfigAttribute>
Public Property LogLevel As StoreLogLevel
    Get
    Set
public:
[ConfigAttribute]
virtual property StoreLogLevel LogLevel {
    StoreLogLevel get () sealed;
    void set (StoreLogLevel value) sealed;
}
public:
[ConfigAttribute]
virtual property StoreLogLevel LogLevel {
    StoreLogLevel get () sealed;
    void set (StoreLogLevel value) sealed;
}
[<ConfigAttribute>]
abstract LogLevel : StoreLogLevel with get, set
[<ConfigAttribute>]
override LogLevel : StoreLogLevel with get, set
[<ConfigAttribute>]
abstract LogLevel : StoreLogLevel with get, set
[<ConfigAttribute>]
override LogLevel : StoreLogLevel with get, set

Property Value

Type: StoreLogLevel

Implements

IDataStoreImplementation LogLevel
See Also
MongoDBDataStoreBase Class
MongoDBDataStoreBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStoreBase.Name Property

MongoDBDataStoreBase Name Property NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
public:
property String^ Name {
    String^ get ();
}
member Name : string with get
member Name : string with get

Property Value

Type: Online String
See Also
MongoDBDataStoreBase Class
MongoDBDataStoreBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBDataStoreBase.TargetName Property

MongoDBDataStoreBase TargetName Property NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string TargetName { get; set; }
[ConfigAttribute]
public string TargetName { get; set; }
<ConfigAttribute>
Public Property TargetName As String
    Get
    Set
<ConfigAttribute>
Public Property TargetName As String
    Get
    Set
public:
[ConfigAttribute]
virtual property String^ TargetName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
[ConfigAttribute]
virtual property String^ TargetName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
[<ConfigAttribute>]
abstract TargetName : string with get, set
[<ConfigAttribute>]
override TargetName : string with get, set
[<ConfigAttribute>]
abstract TargetName : string with get, set
[<ConfigAttribute>]
override TargetName : string with get, set

Property Value

Type: Online String

Implements

IDataStore TargetName
See Also
MongoDBDataStoreBase Class
MongoDBDataStoreBase Members
NFX.DataAccess.MongoDB Namespace


MongoDBLogMessageDataStore Class

MongoDBLogMessageDataStore Class NFX Class Library

Implements a store that sends log messages into MongoDB
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.DataAccess.MongoDB MongoDBDataStoreBase
NFX.DataAccess.MongoDB MongoDBLogMessageDataStore

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MongoDBLogMessageDataStore : MongoDBDataStoreBase
public class MongoDBLogMessageDataStore : MongoDBDataStoreBase
Public Class MongoDBLogMessageDataStore
    Inherits MongoDBDataStoreBase
Public Class MongoDBLogMessageDataStore
    Inherits MongoDBDataStoreBase
public ref class MongoDBLogMessageDataStore : public MongoDBDataStoreBase
public ref class MongoDBLogMessageDataStore : public MongoDBDataStoreBase
type MongoDBLogMessageDataStore =
    class
        inherit MongoDBDataStoreBase
    end
type MongoDBLogMessageDataStore =
    class
        inherit MongoDBDataStoreBase
    end
See Also
MongoDBLogMessageDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBLogMessageDataStore Members

MongoDBLogMessageDataStore Members NFX Class Library

The MongoDBLogMessageDataStore type exposes the following members.
Constructors
 | Name | Description
Public method | MongoDBLogMessageDataStore | Initializes a new instance of the MongoDBLogMessageDataStore class
Public method | MongoDBLogMessageDataStore(String, String, String) | Initializes a new instance of the MongoDBLogMessageDataStore class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | Configure | (Inherited from MongoDBDataStoreBase.)
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from MongoDBDataStoreBase.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from MongoDBDataStoreBase.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from MongoDBDataStoreBase.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetDatabase | Gets appropriate database. It does not need to be disposed (Inherited from MongoDBDataStoreBase.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SendMessage | Inserts log message into MongoDB
Public method | TestConnection | (Inherited from MongoDBDataStoreBase.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_COLLECTION_NAME_DEFAULT |
Back to Top
Properties
 | Name | Description
Public property | CollectionName | Gets/sets collection name used for logging
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | ConnectString | Get/Sets MongoDB database connection string (Inherited from MongoDBDataStoreBase.)
Public property | DatabaseName | Get/Sets MongoDB database name (Inherited from MongoDBDataStoreBase.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from MongoDBDataStoreBase.)
Public property | InstrumentationEnabled | (Inherited from MongoDBDataStoreBase.)
Public property | LogLevel | (Inherited from MongoDBDataStoreBase.)
Public property | Name | (Inherited from MongoDBDataStoreBase.)
Public property | TargetName | (Inherited from MongoDBDataStoreBase.)
Back to Top
See Also
MongoDBLogMessageDataStore Class
NFX.DataAccess.MongoDB Namespace


MongoDBLogMessageDataStore Constructor

MongoDBLogMessageDataStore Constructor NFX Class Library

Overload List
 | Name | Description
Public method | MongoDBLogMessageDataStore | Initializes a new instance of the MongoDBLogMessageDataStore class
Public method | MongoDBLogMessageDataStore(String, String, String) | Initializes a new instance of the MongoDBLogMessageDataStore class
Back to Top
See Also
MongoDBLogMessageDataStore Class
MongoDBLogMessageDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBLogMessageDataStore Constructor

MongoDBLogMessageDataStore Constructor NFX Class Library

Initializes a new instance of the MongoDBLogMessageDataStore class

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBLogMessageDataStore()
public MongoDBLogMessageDataStore()
Public Sub New
Public Sub New
public:
MongoDBLogMessageDataStore()
public:
MongoDBLogMessageDataStore()
new : unit -> MongoDBLogMessageDataStore
new : unit -> MongoDBLogMessageDataStore
See Also
MongoDBLogMessageDataStore Class
MongoDBLogMessageDataStore Members
MongoDBLogMessageDataStore Overload
NFX.DataAccess.MongoDB Namespace


MongoDBLogMessageDataStore Constructor (String, String, String)

MongoDBLogMessageDataStore Constructor (String, String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MongoDBLogMessageDataStore class

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBLogMessageDataStore(
    string connectString,
    string dbName,
    string collectionName
)
public MongoDBLogMessageDataStore(
    string connectString,
    string dbName,
    string collectionName
)
Public Sub New (
    connectString As String,
    dbName As String,
    collectionName As String
)
Public Sub New (
    connectString As String,
    dbName As String,
    collectionName As String
)
public:
MongoDBLogMessageDataStore(
    String^ connectString,
    String^ dbName,
    String^ collectionName
)
public:
MongoDBLogMessageDataStore(
    String^ connectString,
    String^ dbName,
    String^ collectionName
)
new :
        connectString : string *
        dbName : string *
        collectionName : string -> MongoDBLogMessageDataStore
new :
        connectString : string *
        dbName : string *
        collectionName : string -> MongoDBLogMessageDataStore

Parameters

connectString
Type: Online System String
dbName
Type: Online System String
collectionName
Type: Online System String
See Also
MongoDBLogMessageDataStore Class
MongoDBLogMessageDataStore Members
MongoDBLogMessageDataStore Overload
NFX.DataAccess.MongoDB Namespace


MongoDBLogMessageDataStore Fields

MongoDBLogMessageDataStore Fields NFX Class Library

The MongoDBLogMessageDataStore type exposes the following members.
Fields
Name | Description
CONFIG_COLLECTION_NAME_DEFAULT |
Back to Top
See Also
MongoDBLogMessageDataStore Class
NFX.DataAccess.MongoDB Namespace


MongoDBLogMessageDataStore.CONFIG_COLLECTION_NAME_DEFAULT Field

MongoDBLogMessageDataStore CONFIG_COLLECTION_NAME_DEFAULT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_COLLECTION_NAME_DEFAULT
public const string CONFIG_COLLECTION_NAME_DEFAULT
Public Const CONFIG_COLLECTION_NAME_DEFAULT As String
Public Const CONFIG_COLLECTION_NAME_DEFAULT As String
public:
literal String^ CONFIG_COLLECTION_NAME_DEFAULT
public:
literal String^ CONFIG_COLLECTION_NAME_DEFAULT
static val mutable CONFIG_COLLECTION_NAME_DEFAULT: string
static val mutable CONFIG_COLLECTION_NAME_DEFAULT: string

Field Value

Type: Online String
See Also
MongoDBLogMessageDataStore Class
MongoDBLogMessageDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBLogMessageDataStore Methods

MongoDBLogMessageDataStore Methods NFX Class Library

The MongoDBLogMessageDataStore type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | Configure | (Inherited from MongoDBDataStoreBase.)
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from MongoDBDataStoreBase.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from MongoDBDataStoreBase.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from MongoDBDataStoreBase.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetDatabase | Gets appropriate database. It does not need to be disposed (Inherited from MongoDBDataStoreBase.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SendMessage | Inserts log message into MongoDB
Public method | TestConnection | (Inherited from MongoDBDataStoreBase.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MongoDBLogMessageDataStore Class
NFX.DataAccess.MongoDB Namespace


MongoDBLogMessageDataStore.SendMessage Method

MongoDBLogMessageDataStore SendMessage Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Inserts log message into MongoDB

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SendMessage(
    Message msg
)
public void SendMessage(
    Message msg
)
Public Sub SendMessage (
    msg As Message
)
Public Sub SendMessage (
    msg As Message
)
public:
void SendMessage(
    Message^ msg
)
public:
void SendMessage(
    Message^ msg
)
member SendMessage :
        msg : Message -> unit
member SendMessage :
        msg : Message -> unit

Parameters

msg
Type: NFX.Log Message
See Also
MongoDBLogMessageDataStore Class
MongoDBLogMessageDataStore Members
NFX.DataAccess.MongoDB Namespace


MongoDBLogMessageDataStore Properties

MongoDBLogMessageDataStore Properties NFX Class Library

The MongoDBLogMessageDataStore type exposes the following members.
Properties
 | Name | Description
Public property | CollectionName | Gets/sets collection name used for logging
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | ConnectString | Get/Sets MongoDB database connection string (Inherited from MongoDBDataStoreBase.)
Public property | DatabaseName | Get/Sets MongoDB database name (Inherited from MongoDBDataStoreBase.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from MongoDBDataStoreBase.)
Public property | InstrumentationEnabled | (Inherited from MongoDBDataStoreBase.)
Public property | LogLevel | (Inherited from MongoDBDataStoreBase.)
Public property | Name | (Inherited from MongoDBDataStoreBase.)
Public property | TargetName | (Inherited from MongoDBDataStoreBase.)
Back to Top
See Also
MongoDBLogMessageDataStore Class
NFX.DataAccess.MongoDB Namespace


MongoDBLogMessageDataStore.CollectionName Property

MongoDBLogMessageDataStore CollectionName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets/sets collection name used for logging

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$collection")]
public string CollectionName { get; set; }
[ConfigAttribute("$collection")]
public string CollectionName { get; set; }
<ConfigAttribute("$collection")>
Public Property CollectionName As String
    Get
    Set
<ConfigAttribute("$collection")>
Public Property CollectionName As String
    Get
    Set
public:
[ConfigAttribute(L"$collection")]
property String^ CollectionName {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute(L"$collection")]
property String^ CollectionName {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute("$collection")>]
member CollectionName : string with get, set
[<ConfigAttribute("$collection")>]
member CollectionName : string with get, set

Property Value

Type: Online String
See Also
MongoDBLogMessageDataStore Class
MongoDBLogMessageDataStore Members
NFX.DataAccess.MongoDB Namespace


StringConsts Class

StringConsts Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.DataAccess.MongoDB StringConsts

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static class StringConsts
internal static class StringConsts
Friend NotInheritable Class StringConsts
Friend NotInheritable Class StringConsts
internal ref class StringConsts abstract sealed
internal ref class StringConsts abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StringConsts =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StringConsts =  class end
See Also
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts Members

StringConsts Members NFX Class Library

The StringConsts type exposes the following members.
Fields
Name | Description
ARGUMENT_ERROR |
BUFFER_LONGER_THAN_ALLOWED_ERROR |
CLR_BSON_CONVERSION_REFERENCE_CYCLE_ERROR |
CLR_BSON_CONVERSION_TYPE_NOT_SUPPORTED_ERROR |
COLLECTION_DOES_NOT_EXIST_ERROR |
CONNECTION_EXISTING_ACQUISITION_ERROR |
CONNECTION_STRING_INVALID_ERROR |
CONNECTION_STRING_NULL_OR_EMPTY_ERROR |
CONNECTION_TEST_FAILED_ERROR |
CURSOR_ENUM_ALREADY_STARTED_ERROR |
DECIMAL_OUT_OF_RANGE_ERROR |
GDID_BUFFER_ERROR |
KEY_SUPPORT_ERROR |
LOADING_ENTITY_NOT_FOUND_ERROR |
OP_CRUD_ERROR |
OP_NOT_SUPPORTED_ERROR |
OP_ROW_NO_PK_ID_ERROR |
PROTO_COUNT_REPLY_ERROR |
PROTO_LIST_COLLECTIONS_REPLY_ERROR |
PROTO_PING_REPLY_ERROR |
PROTO_READ_CRUD_RESPONSE_ERROR |
PROTO_READ_OP_REPLY_ERROR |
PROTO_REPLY_DOC_COUNT_EXCEED_LIMIT_ERROR |
PROTO_RUN_COMMAND_REPLY_ERROR |
PROTO_SERVER_REPLIED_WITH_NO_DOCUMENTS_ERROR |
PROTO_SOCKET_READ_EXCEED_LIMIT_ERROR |
PROTO_SOCKET_WRITE_EXCEED_LIMIT_ERROR |
QUERY_FINISH_STATEMENT_COMPILE_ERROR |
QUERY_MODIFY_TARGET_MISSING_ERROR |
QUERY_START_STATEMENT_COMPILE_ERROR |
SERVER_CURSOR_NOT_FOUND_ERROR |
SERVER_OPERATION_RETURNED_ERROR |
SERVER_QUERY_FAILURE_ERROR |
UNSUPPORTED_BSON_TYPE_ERROR |
Back to Top
See Also
StringConsts Class
NFX.DataAccess.MongoDB Namespace


StringConsts Fields

StringConsts Fields NFX Class Library

The StringConsts type exposes the following members.
Fields
Name | Description
ARGUMENT_ERROR |
BUFFER_LONGER_THAN_ALLOWED_ERROR |
CLR_BSON_CONVERSION_REFERENCE_CYCLE_ERROR |
CLR_BSON_CONVERSION_TYPE_NOT_SUPPORTED_ERROR |
COLLECTION_DOES_NOT_EXIST_ERROR |
CONNECTION_EXISTING_ACQUISITION_ERROR |
CONNECTION_STRING_INVALID_ERROR |
CONNECTION_STRING_NULL_OR_EMPTY_ERROR |
CONNECTION_TEST_FAILED_ERROR |
CURSOR_ENUM_ALREADY_STARTED_ERROR |
DECIMAL_OUT_OF_RANGE_ERROR |
GDID_BUFFER_ERROR |
KEY_SUPPORT_ERROR |
LOADING_ENTITY_NOT_FOUND_ERROR |
OP_CRUD_ERROR |
OP_NOT_SUPPORTED_ERROR |
OP_ROW_NO_PK_ID_ERROR |
PROTO_COUNT_REPLY_ERROR |
PROTO_LIST_COLLECTIONS_REPLY_ERROR |
PROTO_PING_REPLY_ERROR |
PROTO_READ_CRUD_RESPONSE_ERROR |
PROTO_READ_OP_REPLY_ERROR |
PROTO_REPLY_DOC_COUNT_EXCEED_LIMIT_ERROR |
PROTO_RUN_COMMAND_REPLY_ERROR |
PROTO_SERVER_REPLIED_WITH_NO_DOCUMENTS_ERROR |
PROTO_SOCKET_READ_EXCEED_LIMIT_ERROR |
PROTO_SOCKET_WRITE_EXCEED_LIMIT_ERROR |
QUERY_FINISH_STATEMENT_COMPILE_ERROR |
QUERY_MODIFY_TARGET_MISSING_ERROR |
QUERY_START_STATEMENT_COMPILE_ERROR |
SERVER_CURSOR_NOT_FOUND_ERROR |
SERVER_OPERATION_RETURNED_ERROR |
SERVER_QUERY_FAILURE_ERROR |
UNSUPPORTED_BSON_TYPE_ERROR |
Back to Top
See Also
StringConsts Class
NFX.DataAccess.MongoDB Namespace


StringConsts.ARGUMENT_ERROR Field

StringConsts ARGUMENT_ERROR Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ARGUMENT_ERROR
public const string ARGUMENT_ERROR
Public Const ARGUMENT_ERROR As String
Public Const ARGUMENT_ERROR As String
public:
literal String^ ARGUMENT_ERROR
public:
literal String^ ARGUMENT_ERROR
static val mutable ARGUMENT_ERROR: string
static val mutable ARGUMENT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.BUFFER_LONGER_THAN_ALLOWED_ERROR Field

StringConsts BUFFER_LONGER_THAN_ALLOWED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BUFFER_LONGER_THAN_ALLOWED_ERROR
public const string BUFFER_LONGER_THAN_ALLOWED_ERROR
Public Const BUFFER_LONGER_THAN_ALLOWED_ERROR As String
Public Const BUFFER_LONGER_THAN_ALLOWED_ERROR As String
public:
literal String^ BUFFER_LONGER_THAN_ALLOWED_ERROR
public:
literal String^ BUFFER_LONGER_THAN_ALLOWED_ERROR
static val mutable BUFFER_LONGER_THAN_ALLOWED_ERROR: string
static val mutable BUFFER_LONGER_THAN_ALLOWED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.CLR_BSON_CONVERSION_REFERENCE_CYCLE_ERROR Field

StringConsts CLR_BSON_CONVERSION_REFERENCE_CYCLE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CLR_BSON_CONVERSION_REFERENCE_CYCLE_ERROR
public const string CLR_BSON_CONVERSION_REFERENCE_CYCLE_ERROR
Public Const CLR_BSON_CONVERSION_REFERENCE_CYCLE_ERROR As String
Public Const CLR_BSON_CONVERSION_REFERENCE_CYCLE_ERROR As String
public:
literal String^ CLR_BSON_CONVERSION_REFERENCE_CYCLE_ERROR
public:
literal String^ CLR_BSON_CONVERSION_REFERENCE_CYCLE_ERROR
static val mutable CLR_BSON_CONVERSION_REFERENCE_CYCLE_ERROR: string
static val mutable CLR_BSON_CONVERSION_REFERENCE_CYCLE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.CLR_BSON_CONVERSION_TYPE_NOT_SUPPORTED_ERROR Field

StringConsts CLR_BSON_CONVERSION_TYPE_NOT_SUPPORTED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CLR_BSON_CONVERSION_TYPE_NOT_SUPPORTED_ERROR
public const string CLR_BSON_CONVERSION_TYPE_NOT_SUPPORTED_ERROR
Public Const CLR_BSON_CONVERSION_TYPE_NOT_SUPPORTED_ERROR As String
Public Const CLR_BSON_CONVERSION_TYPE_NOT_SUPPORTED_ERROR As String
public:
literal String^ CLR_BSON_CONVERSION_TYPE_NOT_SUPPORTED_ERROR
public:
literal String^ CLR_BSON_CONVERSION_TYPE_NOT_SUPPORTED_ERROR
static val mutable CLR_BSON_CONVERSION_TYPE_NOT_SUPPORTED_ERROR: string
static val mutable CLR_BSON_CONVERSION_TYPE_NOT_SUPPORTED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.COLLECTION_DOES_NOT_EXIST_ERROR Field

StringConsts COLLECTION_DOES_NOT_EXIST_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string COLLECTION_DOES_NOT_EXIST_ERROR
public const string COLLECTION_DOES_NOT_EXIST_ERROR
Public Const COLLECTION_DOES_NOT_EXIST_ERROR As String
Public Const COLLECTION_DOES_NOT_EXIST_ERROR As String
public:
literal String^ COLLECTION_DOES_NOT_EXIST_ERROR
public:
literal String^ COLLECTION_DOES_NOT_EXIST_ERROR
static val mutable COLLECTION_DOES_NOT_EXIST_ERROR: string
static val mutable COLLECTION_DOES_NOT_EXIST_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.CONNECTION_EXISTING_ACQUISITION_ERROR Field

StringConsts CONNECTION_EXISTING_ACQUISITION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONNECTION_EXISTING_ACQUISITION_ERROR
public const string CONNECTION_EXISTING_ACQUISITION_ERROR
Public Const CONNECTION_EXISTING_ACQUISITION_ERROR As String
Public Const CONNECTION_EXISTING_ACQUISITION_ERROR As String
public:
literal String^ CONNECTION_EXISTING_ACQUISITION_ERROR
public:
literal String^ CONNECTION_EXISTING_ACQUISITION_ERROR
static val mutable CONNECTION_EXISTING_ACQUISITION_ERROR: string
static val mutable CONNECTION_EXISTING_ACQUISITION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.CONNECTION_STRING_INVALID_ERROR Field

StringConsts CONNECTION_STRING_INVALID_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONNECTION_STRING_INVALID_ERROR
public const string CONNECTION_STRING_INVALID_ERROR
Public Const CONNECTION_STRING_INVALID_ERROR As String
Public Const CONNECTION_STRING_INVALID_ERROR As String
public:
literal String^ CONNECTION_STRING_INVALID_ERROR
public:
literal String^ CONNECTION_STRING_INVALID_ERROR
static val mutable CONNECTION_STRING_INVALID_ERROR: string
static val mutable CONNECTION_STRING_INVALID_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.CONNECTION_STRING_NULL_OR_EMPTY_ERROR Field

StringConsts CONNECTION_STRING_NULL_OR_EMPTY_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONNECTION_STRING_NULL_OR_EMPTY_ERROR
public const string CONNECTION_STRING_NULL_OR_EMPTY_ERROR
Public Const CONNECTION_STRING_NULL_OR_EMPTY_ERROR As String
Public Const CONNECTION_STRING_NULL_OR_EMPTY_ERROR As String
public:
literal String^ CONNECTION_STRING_NULL_OR_EMPTY_ERROR
public:
literal String^ CONNECTION_STRING_NULL_OR_EMPTY_ERROR
static val mutable CONNECTION_STRING_NULL_OR_EMPTY_ERROR: string
static val mutable CONNECTION_STRING_NULL_OR_EMPTY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.CONNECTION_TEST_FAILED_ERROR Field

StringConsts CONNECTION_TEST_FAILED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONNECTION_TEST_FAILED_ERROR
public const string CONNECTION_TEST_FAILED_ERROR
Public Const CONNECTION_TEST_FAILED_ERROR As String
Public Const CONNECTION_TEST_FAILED_ERROR As String
public:
literal String^ CONNECTION_TEST_FAILED_ERROR
public:
literal String^ CONNECTION_TEST_FAILED_ERROR
static val mutable CONNECTION_TEST_FAILED_ERROR: string
static val mutable CONNECTION_TEST_FAILED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.CURSOR_ENUM_ALREADY_STARTED_ERROR Field

StringConsts CURSOR_ENUM_ALREADY_STARTED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CURSOR_ENUM_ALREADY_STARTED_ERROR
public const string CURSOR_ENUM_ALREADY_STARTED_ERROR
Public Const CURSOR_ENUM_ALREADY_STARTED_ERROR As String
Public Const CURSOR_ENUM_ALREADY_STARTED_ERROR As String
public:
literal String^ CURSOR_ENUM_ALREADY_STARTED_ERROR
public:
literal String^ CURSOR_ENUM_ALREADY_STARTED_ERROR
static val mutable CURSOR_ENUM_ALREADY_STARTED_ERROR: string
static val mutable CURSOR_ENUM_ALREADY_STARTED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.DECIMAL_OUT_OF_RANGE_ERROR Field

StringConsts DECIMAL_OUT_OF_RANGE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DECIMAL_OUT_OF_RANGE_ERROR
public const string DECIMAL_OUT_OF_RANGE_ERROR
Public Const DECIMAL_OUT_OF_RANGE_ERROR As String
Public Const DECIMAL_OUT_OF_RANGE_ERROR As String
public:
literal String^ DECIMAL_OUT_OF_RANGE_ERROR
public:
literal String^ DECIMAL_OUT_OF_RANGE_ERROR
static val mutable DECIMAL_OUT_OF_RANGE_ERROR: string
static val mutable DECIMAL_OUT_OF_RANGE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.GDID_BUFFER_ERROR Field

StringConsts GDID_BUFFER_ERROR Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GDID_BUFFER_ERROR
public const string GDID_BUFFER_ERROR
Public Const GDID_BUFFER_ERROR As String
Public Const GDID_BUFFER_ERROR As String
public:
literal String^ GDID_BUFFER_ERROR
public:
literal String^ GDID_BUFFER_ERROR
static val mutable GDID_BUFFER_ERROR: string
static val mutable GDID_BUFFER_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.KEY_SUPPORT_ERROR Field

StringConsts KEY_SUPPORT_ERROR Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string KEY_SUPPORT_ERROR
public const string KEY_SUPPORT_ERROR
Public Const KEY_SUPPORT_ERROR As String
Public Const KEY_SUPPORT_ERROR As String
public:
literal String^ KEY_SUPPORT_ERROR
public:
literal String^ KEY_SUPPORT_ERROR
static val mutable KEY_SUPPORT_ERROR: string
static val mutable KEY_SUPPORT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.LOADING_ENTITY_NOT_FOUND_ERROR Field

StringConsts LOADING_ENTITY_NOT_FOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string LOADING_ENTITY_NOT_FOUND_ERROR
public const string LOADING_ENTITY_NOT_FOUND_ERROR
Public Const LOADING_ENTITY_NOT_FOUND_ERROR As String
Public Const LOADING_ENTITY_NOT_FOUND_ERROR As String
public:
literal String^ LOADING_ENTITY_NOT_FOUND_ERROR
public:
literal String^ LOADING_ENTITY_NOT_FOUND_ERROR
static val mutable LOADING_ENTITY_NOT_FOUND_ERROR: string
static val mutable LOADING_ENTITY_NOT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.OP_CRUD_ERROR Field

StringConsts OP_CRUD_ERROR Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string OP_CRUD_ERROR
public const string OP_CRUD_ERROR
Public Const OP_CRUD_ERROR As String
Public Const OP_CRUD_ERROR As String
public:
literal String^ OP_CRUD_ERROR
public:
literal String^ OP_CRUD_ERROR
static val mutable OP_CRUD_ERROR: string
static val mutable OP_CRUD_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.OP_NOT_SUPPORTED_ERROR Field

StringConsts OP_NOT_SUPPORTED_ERROR Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string OP_NOT_SUPPORTED_ERROR
public const string OP_NOT_SUPPORTED_ERROR
Public Const OP_NOT_SUPPORTED_ERROR As String
Public Const OP_NOT_SUPPORTED_ERROR As String
public:
literal String^ OP_NOT_SUPPORTED_ERROR
public:
literal String^ OP_NOT_SUPPORTED_ERROR
static val mutable OP_NOT_SUPPORTED_ERROR: string
static val mutable OP_NOT_SUPPORTED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.OP_ROW_NO_PK_ID_ERROR Field

StringConsts OP_ROW_NO_PK_ID_ERROR Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string OP_ROW_NO_PK_ID_ERROR
public const string OP_ROW_NO_PK_ID_ERROR
Public Const OP_ROW_NO_PK_ID_ERROR As String
Public Const OP_ROW_NO_PK_ID_ERROR As String
public:
literal String^ OP_ROW_NO_PK_ID_ERROR
public:
literal String^ OP_ROW_NO_PK_ID_ERROR
static val mutable OP_ROW_NO_PK_ID_ERROR: string
static val mutable OP_ROW_NO_PK_ID_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.PROTO_COUNT_REPLY_ERROR Field

StringConsts PROTO_COUNT_REPLY_ERROR Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PROTO_COUNT_REPLY_ERROR
public const string PROTO_COUNT_REPLY_ERROR
Public Const PROTO_COUNT_REPLY_ERROR As String
Public Const PROTO_COUNT_REPLY_ERROR As String
public:
literal String^ PROTO_COUNT_REPLY_ERROR
public:
literal String^ PROTO_COUNT_REPLY_ERROR
static val mutable PROTO_COUNT_REPLY_ERROR: string
static val mutable PROTO_COUNT_REPLY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.PROTO_LIST_COLLECTIONS_REPLY_ERROR Field

StringConsts PROTO_LIST_COLLECTIONS_REPLY_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PROTO_LIST_COLLECTIONS_REPLY_ERROR
public const string PROTO_LIST_COLLECTIONS_REPLY_ERROR
Public Const PROTO_LIST_COLLECTIONS_REPLY_ERROR As String
Public Const PROTO_LIST_COLLECTIONS_REPLY_ERROR As String
public:
literal String^ PROTO_LIST_COLLECTIONS_REPLY_ERROR
public:
literal String^ PROTO_LIST_COLLECTIONS_REPLY_ERROR
static val mutable PROTO_LIST_COLLECTIONS_REPLY_ERROR: string
static val mutable PROTO_LIST_COLLECTIONS_REPLY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.PROTO_PING_REPLY_ERROR Field

StringConsts PROTO_PING_REPLY_ERROR Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PROTO_PING_REPLY_ERROR
public const string PROTO_PING_REPLY_ERROR
Public Const PROTO_PING_REPLY_ERROR As String
Public Const PROTO_PING_REPLY_ERROR As String
public:
literal String^ PROTO_PING_REPLY_ERROR
public:
literal String^ PROTO_PING_REPLY_ERROR
static val mutable PROTO_PING_REPLY_ERROR: string
static val mutable PROTO_PING_REPLY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.PROTO_READ_CRUD_RESPONSE_ERROR Field

StringConsts PROTO_READ_CRUD_RESPONSE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PROTO_READ_CRUD_RESPONSE_ERROR
public const string PROTO_READ_CRUD_RESPONSE_ERROR
Public Const PROTO_READ_CRUD_RESPONSE_ERROR As String
Public Const PROTO_READ_CRUD_RESPONSE_ERROR As String
public:
literal String^ PROTO_READ_CRUD_RESPONSE_ERROR
public:
literal String^ PROTO_READ_CRUD_RESPONSE_ERROR
static val mutable PROTO_READ_CRUD_RESPONSE_ERROR: string
static val mutable PROTO_READ_CRUD_RESPONSE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.PROTO_READ_OP_REPLY_ERROR Field

StringConsts PROTO_READ_OP_REPLY_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PROTO_READ_OP_REPLY_ERROR
public const string PROTO_READ_OP_REPLY_ERROR
Public Const PROTO_READ_OP_REPLY_ERROR As String
Public Const PROTO_READ_OP_REPLY_ERROR As String
public:
literal String^ PROTO_READ_OP_REPLY_ERROR
public:
literal String^ PROTO_READ_OP_REPLY_ERROR
static val mutable PROTO_READ_OP_REPLY_ERROR: string
static val mutable PROTO_READ_OP_REPLY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.PROTO_REPLY_DOC_COUNT_EXCEED_LIMIT_ERROR Field

StringConsts PROTO_REPLY_DOC_COUNT_EXCEED_LIMIT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PROTO_REPLY_DOC_COUNT_EXCEED_LIMIT_ERROR
public const string PROTO_REPLY_DOC_COUNT_EXCEED_LIMIT_ERROR
Public Const PROTO_REPLY_DOC_COUNT_EXCEED_LIMIT_ERROR As String
Public Const PROTO_REPLY_DOC_COUNT_EXCEED_LIMIT_ERROR As String
public:
literal String^ PROTO_REPLY_DOC_COUNT_EXCEED_LIMIT_ERROR
public:
literal String^ PROTO_REPLY_DOC_COUNT_EXCEED_LIMIT_ERROR
static val mutable PROTO_REPLY_DOC_COUNT_EXCEED_LIMIT_ERROR: string
static val mutable PROTO_REPLY_DOC_COUNT_EXCEED_LIMIT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.PROTO_RUN_COMMAND_REPLY_ERROR Field

StringConsts PROTO_RUN_COMMAND_REPLY_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PROTO_RUN_COMMAND_REPLY_ERROR
public const string PROTO_RUN_COMMAND_REPLY_ERROR
Public Const PROTO_RUN_COMMAND_REPLY_ERROR As String
Public Const PROTO_RUN_COMMAND_REPLY_ERROR As String
public:
literal String^ PROTO_RUN_COMMAND_REPLY_ERROR
public:
literal String^ PROTO_RUN_COMMAND_REPLY_ERROR
static val mutable PROTO_RUN_COMMAND_REPLY_ERROR: string
static val mutable PROTO_RUN_COMMAND_REPLY_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.PROTO_SERVER_REPLIED_WITH_NO_DOCUMENTS_ERROR Field

StringConsts PROTO_SERVER_REPLIED_WITH_NO_DOCUMENTS_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PROTO_SERVER_REPLIED_WITH_NO_DOCUMENTS_ERROR
public const string PROTO_SERVER_REPLIED_WITH_NO_DOCUMENTS_ERROR
Public Const PROTO_SERVER_REPLIED_WITH_NO_DOCUMENTS_ERROR As String
Public Const PROTO_SERVER_REPLIED_WITH_NO_DOCUMENTS_ERROR As String
public:
literal String^ PROTO_SERVER_REPLIED_WITH_NO_DOCUMENTS_ERROR
public:
literal String^ PROTO_SERVER_REPLIED_WITH_NO_DOCUMENTS_ERROR
static val mutable PROTO_SERVER_REPLIED_WITH_NO_DOCUMENTS_ERROR: string
static val mutable PROTO_SERVER_REPLIED_WITH_NO_DOCUMENTS_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.PROTO_SOCKET_READ_EXCEED_LIMIT_ERROR Field

StringConsts PROTO_SOCKET_READ_EXCEED_LIMIT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PROTO_SOCKET_READ_EXCEED_LIMIT_ERROR
public const string PROTO_SOCKET_READ_EXCEED_LIMIT_ERROR
Public Const PROTO_SOCKET_READ_EXCEED_LIMIT_ERROR As String
Public Const PROTO_SOCKET_READ_EXCEED_LIMIT_ERROR As String
public:
literal String^ PROTO_SOCKET_READ_EXCEED_LIMIT_ERROR
public:
literal String^ PROTO_SOCKET_READ_EXCEED_LIMIT_ERROR
static val mutable PROTO_SOCKET_READ_EXCEED_LIMIT_ERROR: string
static val mutable PROTO_SOCKET_READ_EXCEED_LIMIT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.PROTO_SOCKET_WRITE_EXCEED_LIMIT_ERROR Field

StringConsts PROTO_SOCKET_WRITE_EXCEED_LIMIT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PROTO_SOCKET_WRITE_EXCEED_LIMIT_ERROR
public const string PROTO_SOCKET_WRITE_EXCEED_LIMIT_ERROR
Public Const PROTO_SOCKET_WRITE_EXCEED_LIMIT_ERROR As String
Public Const PROTO_SOCKET_WRITE_EXCEED_LIMIT_ERROR As String
public:
literal String^ PROTO_SOCKET_WRITE_EXCEED_LIMIT_ERROR
public:
literal String^ PROTO_SOCKET_WRITE_EXCEED_LIMIT_ERROR
static val mutable PROTO_SOCKET_WRITE_EXCEED_LIMIT_ERROR: string
static val mutable PROTO_SOCKET_WRITE_EXCEED_LIMIT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.QUERY_FINISH_STATEMENT_COMPILE_ERROR Field

StringConsts QUERY_FINISH_STATEMENT_COMPILE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string QUERY_FINISH_STATEMENT_COMPILE_ERROR
public const string QUERY_FINISH_STATEMENT_COMPILE_ERROR
Public Const QUERY_FINISH_STATEMENT_COMPILE_ERROR As String
Public Const QUERY_FINISH_STATEMENT_COMPILE_ERROR As String
public:
literal String^ QUERY_FINISH_STATEMENT_COMPILE_ERROR
public:
literal String^ QUERY_FINISH_STATEMENT_COMPILE_ERROR
static val mutable QUERY_FINISH_STATEMENT_COMPILE_ERROR: string
static val mutable QUERY_FINISH_STATEMENT_COMPILE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.QUERY_MODIFY_TARGET_MISSING_ERROR Field

StringConsts QUERY_MODIFY_TARGET_MISSING_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string QUERY_MODIFY_TARGET_MISSING_ERROR
public const string QUERY_MODIFY_TARGET_MISSING_ERROR
Public Const QUERY_MODIFY_TARGET_MISSING_ERROR As String
Public Const QUERY_MODIFY_TARGET_MISSING_ERROR As String
public:
literal String^ QUERY_MODIFY_TARGET_MISSING_ERROR
public:
literal String^ QUERY_MODIFY_TARGET_MISSING_ERROR
static val mutable QUERY_MODIFY_TARGET_MISSING_ERROR: string
static val mutable QUERY_MODIFY_TARGET_MISSING_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.QUERY_START_STATEMENT_COMPILE_ERROR Field

StringConsts QUERY_START_STATEMENT_COMPILE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string QUERY_START_STATEMENT_COMPILE_ERROR
public const string QUERY_START_STATEMENT_COMPILE_ERROR
Public Const QUERY_START_STATEMENT_COMPILE_ERROR As String
Public Const QUERY_START_STATEMENT_COMPILE_ERROR As String
public:
literal String^ QUERY_START_STATEMENT_COMPILE_ERROR
public:
literal String^ QUERY_START_STATEMENT_COMPILE_ERROR
static val mutable QUERY_START_STATEMENT_COMPILE_ERROR: string
static val mutable QUERY_START_STATEMENT_COMPILE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.SERVER_CURSOR_NOT_FOUND_ERROR Field

StringConsts SERVER_CURSOR_NOT_FOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SERVER_CURSOR_NOT_FOUND_ERROR
public const string SERVER_CURSOR_NOT_FOUND_ERROR
Public Const SERVER_CURSOR_NOT_FOUND_ERROR As String
Public Const SERVER_CURSOR_NOT_FOUND_ERROR As String
public:
literal String^ SERVER_CURSOR_NOT_FOUND_ERROR
public:
literal String^ SERVER_CURSOR_NOT_FOUND_ERROR
static val mutable SERVER_CURSOR_NOT_FOUND_ERROR: string
static val mutable SERVER_CURSOR_NOT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.SERVER_OPERATION_RETURNED_ERROR Field

StringConsts SERVER_OPERATION_RETURNED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SERVER_OPERATION_RETURNED_ERROR
public const string SERVER_OPERATION_RETURNED_ERROR
Public Const SERVER_OPERATION_RETURNED_ERROR As String
Public Const SERVER_OPERATION_RETURNED_ERROR As String
public:
literal String^ SERVER_OPERATION_RETURNED_ERROR
public:
literal String^ SERVER_OPERATION_RETURNED_ERROR
static val mutable SERVER_OPERATION_RETURNED_ERROR: string
static val mutable SERVER_OPERATION_RETURNED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.SERVER_QUERY_FAILURE_ERROR Field

StringConsts SERVER_QUERY_FAILURE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SERVER_QUERY_FAILURE_ERROR
public const string SERVER_QUERY_FAILURE_ERROR
Public Const SERVER_QUERY_FAILURE_ERROR As String
Public Const SERVER_QUERY_FAILURE_ERROR As String
public:
literal String^ SERVER_QUERY_FAILURE_ERROR
public:
literal String^ SERVER_QUERY_FAILURE_ERROR
static val mutable SERVER_QUERY_FAILURE_ERROR: string
static val mutable SERVER_QUERY_FAILURE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


StringConsts.UNSUPPORTED_BSON_TYPE_ERROR Field

StringConsts UNSUPPORTED_BSON_TYPE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNSUPPORTED_BSON_TYPE_ERROR
public const string UNSUPPORTED_BSON_TYPE_ERROR
Public Const UNSUPPORTED_BSON_TYPE_ERROR As String
Public Const UNSUPPORTED_BSON_TYPE_ERROR As String
public:
literal String^ UNSUPPORTED_BSON_TYPE_ERROR
public:
literal String^ UNSUPPORTED_BSON_TYPE_ERROR
static val mutable UNSUPPORTED_BSON_TYPE_ERROR: string
static val mutable UNSUPPORTED_BSON_TYPE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MongoDB Namespace


NFX.DataAccess.MongoDB.Connector Namespace

NFX.DataAccess.MongoDB.Connector Namespace NFX Class Library

Classes
 | Class | Description
Public class | Collection | Represents MongoDB collections which allows to execute queries and perform CRUD operations
Public class | Connection | Represent a connection to MongoDB server. Normally developers should not work with this class directly as connections are managed by the Client. This class is not thread safe and must be Acquired first before sending data
Public class | Cursor | Represents a UNIDIRECTIONAL SINGLE-pass (no buffering) cursor returned by the Find(query) command. The cursor needs to be closed by calling Dispose() if the eof has not been reached OR it will auto-close on EOF. The cursor may be enumerated only once. It is NOT thread-safe
Public class | Database | Represents an instance of MongoDB database
Public class | MongoClient | The central facade for working with MongoDB. The technology was tested against Mongo DB 3.0.6. The NFX MongoDB connector is purposely created for specific needs. It does not support: Mongo security, sharding and replication
Public class | MongoDBConnectorException | Thrown by MongoDB data access classes
Public class | MongoDBConnectorProtocolException | Thrown by MongoDB data access classes related to protocol
Public class | MongoDBConnectorServerException | Thrown by MongoDB data access classes related to server errors
Public class | MongoDBQueryException | Thrown in case of query compile error
Protected class | Protocol | This class uses static methods on purpose to avoid allocations
Public class | Query | Represents a query document sent to MongoDB
Public class | ServerNode | Manages connections to the same server
Public class | Update | Represents an update document sent to MongoDB
Structures
 | Structure | Description
Public structure | CRUDResult | Returned by CRUD operations from the server, contains information about total docs affected and write errors. The caller needs to inspect the TotalDocumentsAffected and WriteErrors to handle error conditions
Public structure | CRUDUpsertInfo | Provides information about an upserted document
Public structure | CRUDWriteError | Provides information about document write error
Public structure | DeleteEntry | Pairs necessary information for deletes: query + limit flag
Public structure | Protocol ReplyData |
Public structure | UpdateEntry | Pairs necessary information for updates: query, update documents along with upsert and multi flags
Enumerations
 | Enumeration | Description
Public enumeration | DeleteLimit | Denotes limits for deletion: None=Everything or One
Public enumeration | Protocol QueryFlags |
Public enumeration | Protocol ResponseFlags |
Public enumeration | WriteConcern | Defines data safety modes http://docs.mongodb.org/manual/core/write-concern/


Collection Class

Collection Class NFX Class Library

Represents MongoDB collections which allows to execute queries and perform CRUD operations
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.DataAccess.MongoDB.Connector Collection

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Collection : DisposableObject,
    INamed
public sealed class Collection : DisposableObject,
    INamed
Public NotInheritable Class Collection
    Inherits DisposableObject
    Implements INamed
Public NotInheritable Class Collection
    Inherits DisposableObject
    Implements INamed
public ref class Collection sealed : public DisposableObject,
    INamed
public ref class Collection sealed : public DisposableObject,
    INamed
[<SealedAttribute>]
type Collection =
    class
        inherit DisposableObject
        interface INamed
    end
[<SealedAttribute>]
type Collection =
    class
        inherit DisposableObject
        interface INamed
    end
See Also
Collection Members
NFX.DataAccess.MongoDB.Connector Namespace


Collection Members

Collection Members NFX Class Library

The Collection type exposes the following members.
Constructors
 | Name | Description
Protected method | Collection | Initializes a new instance of the Collection class
Back to Top
Methods
 | Name | Description
Public method | Count | Performs server-side count over cursor
Public method | Delete | Deletes documents from the server. Inspect CRUDResult for write errors and docs affected/matched
Public method | DeleteOne | Deletes 1 document from the server. Inspect CRUDResult for write errors and docs affected/matched
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | Drop | Drops the collection from the server with all of its data and disposes the Collection object
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Find | Finds all documents that match the supplied query, optionally skipping some. Fetches only fetchBy at once, then lazily fetches via cursor
Public method | FindAndFetchAll | Finds all documents that match the supplied query, optionally skipping some. Fetches and returns all documents as a list. Be careful not to fetch too many
Public method | FindOne | Finds a document that satisfied query or null
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Insert | Inserts documents on the server. Inspect CRUDResult for write errors and docs affected/matched
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Save | Updates or inserts 1 document on the server. Inspect CRUDResult for write errors and docs affected/matched
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Update | Updates documents on the server. Inspect CRUDResult for write errors and docs affected/matched
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_FullNameCStringBuffer |
Back to Top
Properties
 | Name | Description
Public property | Database |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | FullName | Returns full name of this collection: database.collection
Public property | Name |
Public property | Server |
Back to Top
See Also
Collection Class
NFX.DataAccess.MongoDB.Connector Namespace


Collection Constructor

Collection Constructor NFX Class Library

Initializes a new instance of the Collection class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Collection(
    Database database,
    string name
)
internal Collection(
    Database database,
    string name
)
Friend Sub New (
    database As Database,
    name As String
)
Friend Sub New (
    database As Database,
    name As String
)
internal:
Collection(
    Database^ database,
    String^ name
)
internal:
Collection(
    Database^ database,
    String^ name
)
new :
        database : Database *
        name : string -> Collection
new :
        database : Database *
        name : string -> Collection

Parameters

database
Type: NFX.DataAccess.MongoDB.Connector Database
name
Type: Online System String
See Also
Collection Class
Collection Members
NFX.DataAccess.MongoDB.Connector Namespace


Collection Fields

Collection Fields NFX Class Library

The Collection type exposes the following members.
Fields
 | Name | Description
Protected field | m_FullNameCStringBuffer |
Back to Top
See Also
Collection Class
NFX.DataAccess.MongoDB.Connector Namespace


Collection.m_FullNameCStringBuffer Field

Collection m_FullNameCStringBuffer Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal readonly byte[] m_FullNameCStringBuffer
internal readonly byte[] m_FullNameCStringBuffer
Friend ReadOnly m_FullNameCStringBuffer As Byte()
Friend ReadOnly m_FullNameCStringBuffer As Byte()
internal:
initonly array<unsigned char>^ m_FullNameCStringBuffer
internal:
initonly array<unsigned char>^ m_FullNameCStringBuffer
val internal m_FullNameCStringBuffer: byte[]
val internal m_FullNameCStringBuffer: byte[]

Field Value

Type: Online Byte
See Also
Collection Class
Collection Members
NFX.DataAccess.MongoDB.Connector Namespace


Collection Methods

Collection Methods NFX Class Library

The Collection type exposes the following members.
Methods
 | Name | Description
Public method | Count | Performs server-side count over cursor
Public method | Delete | Deletes documents from the server. Inspect CRUDResult for write errors and docs affected/matched
Public method | DeleteOne | Deletes 1 document from the server. Inspect CRUDResult for write errors and docs affected/matched
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | Drop | Drops the collection from the server with all of its data and disposes the Collection object
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Find | Finds all documents that match the supplied query, optionally skipping some. Fetches only fetchBy at once, then lazily fetches via cursor
Public method | FindAndFetchAll | Finds all documents that match the supplied query, optionally skipping some. Fetches and returns all documents as a list. Be careful not to fetch too many
Public method | FindOne | Finds a document that satisfied query or null
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Insert | Inserts documents on the server. Inspect CRUDResult for write errors and docs affected/matched
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Save | Updates or inserts 1 document on the server. Inspect CRUDResult for write errors and docs affected/matched
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Update | Updates documents on the server. Inspect CRUDResult for write errors and docs affected/matched
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Collection Class
NFX.DataAccess.MongoDB.Connector Namespace


Collection.Count Method

Collection Count Method NFX Class Library

Performs server-side count over cursor

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long Count(
    Query query = null,
    int limit = -1,
    int skip = -1,
    Object hint = null
)
public long Count(
    Query query = null,
    int limit = -1,
    int skip = -1,
    Object hint = null
)
Public Function Count (
    Optional query As Query = Nothing,
    Optional limit As Integer = -1,
    Optional skip As Integer = -1,
    Optional hint As Object = Nothing
) As Long
Public Function Count (
    Optional query As Query = Nothing,
    Optional limit As Integer = -1,
    Optional skip As Integer = -1,
    Optional hint As Object = Nothing
) As Long
public:
long long Count(
    Query^ query = nullptr,
    int limit = -1,
    int skip = -1,
    Object^ hint = nullptr
)
public:
long long Count(
    Query^ query = nullptr,
    int limit = -1,
    int skip = -1,
    Object^ hint = nullptr
)
member Count :
        ?query : Query *
        ?limit : int *
        ?skip : int *
        ?hint : Object
(* Defaults:
        let _query = defaultArg query null
        let _limit = defaultArg limit -1
        let _skip = defaultArg skip -1
        let _hint = defaultArg hint null
*)
-> int64
member Count :
        ?query : Query *
        ?limit : int *
        ?skip : int *
        ?hint : Object
(* Defaults:
        let _query = defaultArg query null
        let _limit = defaultArg limit -1
        let _skip = defaultArg skip -1
        let _hint = defaultArg hint null
*)
-> int64

Parameters

query (Optional)
Type: NFX.DataAccess.MongoDB.Connector Query
Optional. A query that selects which documents to count in a collection
limit (Optional)
Type: Online System Int32
Optional. The maximum number of matching documents to return
skip (Optional)
Type: Online System Int32
Optional. The number of matching documents to skip before returning results
hint (Optional)
Type: Online System Object
Optional. The index to use. Specify either the index name as a string or the index specification document.

Return Value

Type: Online Int64
Count
See Also
Collection Class
Collection Members
NFX.DataAccess.MongoDB.Connector Namespace


Collection.Delete Method

Collection Delete Method NFX Class Library

Deletes documents from the server. Inspect CRUDResult for write errors and docs affected/matched

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDResult Delete(
    params DeleteEntry[] deletes
)
public CRUDResult Delete(
    params DeleteEntry[] deletes
)
Public Function Delete (
    ParamArray deletes As DeleteEntry()
) As CRUDResult
Public Function Delete (
    ParamArray deletes As DeleteEntry()
) As CRUDResult
public:
CRUDResult Delete(
    ... array<DeleteEntry>^ deletes
)
public:
CRUDResult Delete(
    ... array<DeleteEntry>^ deletes
)
member Delete :
        deletes : DeleteEntry[] -> CRUDResult
member Delete :
        deletes : DeleteEntry[] -> CRUDResult

Parameters

deletes
Type: NFX.DataAccess.MongoDB.Connector DeleteEntry

Return Value

Type: CRUDResult
See Also
Collection Class
Collection Members
NFX.DataAccess.MongoDB.Connector Namespace


Collection.DeleteOne Method

Collection DeleteOne Method NFX Class Library

Deletes 1 document from the server. Inspect CRUDResult for write errors and docs affected/matched

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDResult DeleteOne(
    Query query
)
public CRUDResult DeleteOne(
    Query query
)
Public Function DeleteOne (
    query As Query
) As CRUDResult
Public Function DeleteOne (
    query As Query
) As CRUDResult
public:
CRUDResult DeleteOne(
    Query^ query
)
public:
CRUDResult DeleteOne(
    Query^ query
)
member DeleteOne :
        query : Query -> CRUDResult
member DeleteOne :
        query : Query -> CRUDResult

Parameters

query
Type: NFX.DataAccess.MongoDB.Connector Query

Return Value

Type: CRUDResult
See Also
Collection Class
Collection Members
NFX.DataAccess.MongoDB.Connector Namespace


Collection.Destructor Method

Collection Destructor Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
Collection Class
Collection Members
NFX.DataAccess.MongoDB.Connector Namespace


Collection.Drop Method

Collection Drop Method NFX Class Library

Drops the collection from the server with all of its data and disposes the Collection object

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Drop()
public void Drop()
Public Sub Drop
Public Sub Drop
public:
void Drop()
public:
void Drop()
member Drop : unit -> unit
member Drop : unit -> unit
See Also
Collection Class
Collection Members
NFX.DataAccess.MongoDB.Connector Namespace


Collection.Find Method

Collection Find Method NFX Class Library

Finds all documents that match the supplied query, optionally skipping some. Fetches only fetchBy at once, then lazily fetches via cursor

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Cursor Find(
    Query query,
    int skipCount = 0,
    int fetchBy = 0,
    BSONDocument selector = null
)
public Cursor Find(
    Query query,
    int skipCount = 0,
    int fetchBy = 0,
    BSONDocument selector = null
)
Public Function Find (
    query As Query,
    Optional skipCount As Integer = 0,
    Optional fetchBy As Integer = 0,
    Optional selector As BSONDocument = Nothing
) As Cursor
Public Function Find (
    query As Query,
    Optional skipCount As Integer = 0,
    Optional fetchBy As Integer = 0,
    Optional selector As BSONDocument = Nothing
) As Cursor
public:
Cursor^ Find(
    Query^ query,
    int skipCount = 0,
    int fetchBy = 0,
    BSONDocument^ selector = nullptr
)
public:
Cursor^ Find(
    Query^ query,
    int skipCount = 0,
    int fetchBy = 0,
    BSONDocument^ selector = nullptr
)
member Find :
        query : Query *
        ?skipCount : int *
        ?fetchBy : int *
        ?selector : BSONDocument
(* Defaults:
        let _skipCount = defaultArg skipCount 0
        let _fetchBy = defaultArg fetchBy 0
        let _selector = defaultArg selector null
*)
-> Cursor
member Find :
        query : Query *
        ?skipCount : int *
        ?fetchBy : int *
        ?selector : BSONDocument
(* Defaults:
        let _skipCount = defaultArg skipCount 0
        let _fetchBy = defaultArg fetchBy 0
        let _selector = defaultArg selector null
*)
-> Cursor

Parameters

query
Type: NFX.DataAccess.MongoDB.Connector Query
Query to match against
skipCount (Optional)
Type: Online System Int32
How many document sto skip at the beginning
fetchBy (Optional)
Type: Online System Int32
The size of fetch block
selector (Optional)
Type: NFX.Serialization.BSON BSONDocument
Optional field mapping document like: {"field_name": 1}

Return Value

Type: Cursor
An iterable cursor
See Also
Collection Class
Collection Members
NFX.DataAccess.MongoDB.Connector Namespace


Collection.FindAndFetchAll Method

Collection FindAndFetchAll Method NFX Class Library

Finds all documents that match the supplied query, optionally skipping some. Fetches and returns all documents as a list. Be careful not to fetch too many

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<BSONDocument> FindAndFetchAll(
    Query query,
    int skipCount = 0,
    int cursorFetchLimit = 0,
    int fetchBy = 0,
    BSONDocument selector = null
)
public List<BSONDocument> FindAndFetchAll(
    Query query,
    int skipCount = 0,
    int cursorFetchLimit = 0,
    int fetchBy = 0,
    BSONDocument selector = null
)
Public Function FindAndFetchAll (
    query As Query,
    Optional skipCount As Integer = 0,
    Optional cursorFetchLimit As Integer = 0,
    Optional fetchBy As Integer = 0,
    Optional selector As BSONDocument = Nothing
) As List(Of BSONDocument)
Public Function FindAndFetchAll (
    query As Query,
    Optional skipCount As Integer = 0,
    Optional cursorFetchLimit As Integer = 0,
    Optional fetchBy As Integer = 0,
    Optional selector As BSONDocument = Nothing
) As List(Of BSONDocument)
public:
List<BSONDocument^>^ FindAndFetchAll(
    Query^ query,
    int skipCount = 0,
    int cursorFetchLimit = 0,
    int fetchBy = 0,
    BSONDocument^ selector = nullptr
)
public:
List<BSONDocument^>^ FindAndFetchAll(
    Query^ query,
    int skipCount = 0,
    int cursorFetchLimit = 0,
    int fetchBy = 0,
    BSONDocument^ selector = nullptr
)
member FindAndFetchAll :
        query : Query *
        ?skipCount : int *
        ?cursorFetchLimit : int *
        ?fetchBy : int *
        ?selector : BSONDocument
(* Defaults:
        let _skipCount = defaultArg skipCount 0
        let _cursorFetchLimit = defaultArg cursorFetchLimit 0
        let _fetchBy = defaultArg fetchBy 0
        let _selector = defaultArg selector null
*)
-> List<BSONDocument>
member FindAndFetchAll :
        query : Query *
        ?skipCount : int *
        ?cursorFetchLimit : int *
        ?fetchBy : int *
        ?selector : BSONDocument
(* Defaults:
        let _skipCount = defaultArg skipCount 0
        let _cursorFetchLimit = defaultArg cursorFetchLimit 0
        let _fetchBy = defaultArg fetchBy 0
        let _selector = defaultArg selector null
*)
-> List<BSONDocument>

Parameters

query
Type: NFX.DataAccess.MongoDB.Connector Query
Query to match against
skipCount (Optional)
Type: Online System Int32
How many documents to skip at the beginning
cursorFetchLimit (Optional)
Type: Online System Int32
Impose a limit on total number of fetched docs
fetchBy (Optional)
Type: Online System Int32
Size of fetch block
selector (Optional)
Type: NFX.Serialization.BSON BSONDocument
Optional field mapping document like: {"field_name": 1}

Return Value

Type: Online List BSONDocument
A list of documents (may be empty)
See Also
Collection Class
Collection Members
NFX.DataAccess.MongoDB.Connector Namespace


Collection.FindOne Method

Collection FindOne Method NFX Class Library

Finds a document that satisfied query or null

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONDocument FindOne(
    Query query,
    BSONDocument selector = null
)
public BSONDocument FindOne(
    Query query,
    BSONDocument selector = null
)
Public Function FindOne (
    query As Query,
    Optional selector As BSONDocument = Nothing
) As BSONDocument
Public Function FindOne (
    query As Query,
    Optional selector As BSONDocument = Nothing
) As BSONDocument
public:
BSONDocument^ FindOne(
    Query^ query,
    BSONDocument^ selector = nullptr
)
public:
BSONDocument^ FindOne(
    Query^ query,
    BSONDocument^ selector = nullptr
)
member FindOne :
        query : Query *
        ?selector : BSONDocument
(* Defaults:
        let _selector = defaultArg selector null
*)
-> BSONDocument
member FindOne :
        query : Query *
        ?selector : BSONDocument
(* Defaults:
        let _selector = defaultArg selector null
*)
-> BSONDocument

Parameters

query
Type: NFX.DataAccess.MongoDB.Connector Query
selector (Optional)
Type: NFX.Serialization.BSON BSONDocument

Return Value

Type: BSONDocument
See Also
Collection Class
Collection Members
NFX.DataAccess.MongoDB.Connector Namespace


Collection.Insert Method

Collection Insert Method NFX Class Library

Inserts documents on the server. Inspect CRUDResult for write errors and docs affected/matched

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDResult Insert(
    params BSONDocument[] documents
)
public CRUDResult Insert(
    params BSONDocument[] documents
)
Public Function Insert (
    ParamArray documents As BSONDocument()
) As CRUDResult
Public Function Insert (
    ParamArray documents As BSONDocument()
) As CRUDResult
public:
CRUDResult Insert(
    ... array<BSONDocument^>^ documents
)
public:
CRUDResult Insert(
    ... array<BSONDocument^>^ documents
)
member Insert :
        documents : BSONDocument[] -> CRUDResult
member Insert :
        documents : BSONDocument[] -> CRUDResult

Parameters

documents
Type: NFX.Serialization.BSON BSONDocument

Return Value

Type: CRUDResult
See Also
Collection Class
Collection Members
NFX.DataAccess.MongoDB.Connector Namespace


Collection.Save Method

Collection Save Method NFX Class Library

Updates or inserts 1 document on the server. Inspect CRUDResult for write errors and docs affected/matched

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDResult Save(
    BSONDocument document
)
public CRUDResult Save(
    BSONDocument document
)
Public Function Save (
    document As BSONDocument
) As CRUDResult
Public Function Save (
    document As BSONDocument
) As CRUDResult
public:
CRUDResult Save(
    BSONDocument^ document
)
public:
CRUDResult Save(
    BSONDocument^ document
)
member Save :
        document : BSONDocument -> CRUDResult
member Save :
        document : BSONDocument -> CRUDResult

Parameters

document
Type: NFX.Serialization.BSON BSONDocument

Return Value

Type: CRUDResult
See Also
Collection Class
Collection Members
NFX.DataAccess.MongoDB.Connector Namespace


Collection.Update Method

Collection Update Method NFX Class Library

Updates documents on the server. Inspect CRUDResult for write errors and docs affected/matched

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDResult Update(
    params UpdateEntry[] updates
)
public CRUDResult Update(
    params UpdateEntry[] updates
)
Public Function Update (
    ParamArray updates As UpdateEntry()
) As CRUDResult
Public Function Update (
    ParamArray updates As UpdateEntry()
) As CRUDResult
public:
CRUDResult Update(
    ... array<UpdateEntry>^ updates
)
public:
CRUDResult Update(
    ... array<UpdateEntry>^ updates
)
member Update :
        updates : UpdateEntry[] -> CRUDResult
member Update :
        updates : UpdateEntry[] -> CRUDResult

Parameters

updates
Type: NFX.DataAccess.MongoDB.Connector UpdateEntry

Return Value

Type: CRUDResult
See Also
Collection Class
Collection Members
NFX.DataAccess.MongoDB.Connector Namespace


Collection Properties

Collection Properties NFX Class Library

The Collection type exposes the following members.
Properties
 | Name | Description
Public property | Database |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | FullName | Returns full name of this collection: database.collection
Public property | Name |
Public property | Server |
Back to Top
See Also
Collection Class
NFX.DataAccess.MongoDB.Connector Namespace


Collection.Database Property

Collection Database Property NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Database Database { get; }
public Database Database { get; }
Public ReadOnly Property Database As Database
    Get
Public ReadOnly Property Database As Database
    Get
public:
property Database^ Database {
    Database^ get ();
}
public:
property Database^ Database {
    Database^ get ();
}
member Database : Database with get
member Database : Database with get

Property Value

Type: Database
See Also
Collection Class
Collection Members
NFX.DataAccess.MongoDB.Connector Namespace


Collection.FullName Property

Collection FullName Property NFX Class Library

Returns full name of this collection: database.collection

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string FullName { get; }
public string FullName { get; }
Public ReadOnly Property FullName As String
    Get
Public ReadOnly Property FullName As String
    Get
public:
property String^ FullName {
    String^ get ();
}
public:
property String^ FullName {
    String^ get ();
}
member FullName : string with get
member FullName : string with get

Property Value

Type: Online String
See Also
Collection Class
Collection Members
NFX.DataAccess.MongoDB.Connector Namespace


Collection.Name Property

Collection Name Property NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
Collection Class
Collection Members
NFX.DataAccess.MongoDB.Connector Namespace


Collection.Server Property

Collection Server Property NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerNode Server { get; }
public ServerNode Server { get; }
Public ReadOnly Property Server As ServerNode
    Get
Public ReadOnly Property Server As ServerNode
    Get
public:
property ServerNode^ Server {
    ServerNode^ get ();
}
public:
property ServerNode^ Server {
    ServerNode^ get ();
}
member Server : ServerNode with get
member Server : ServerNode with get

Property Value

Type: ServerNode
See Also
Collection Class
Collection Members
NFX.DataAccess.MongoDB.Connector Namespace


Connection Class

Connection Class NFX Class Library

Represent a connection to MongoDB server. Normally developers should not work with this class directly as connections are managed by the Client. This class is not thread safe and must be Acquired first before sending data
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.DataAccess.MongoDB.Connector Connection

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Connection : ApplicationComponent
public sealed class Connection : ApplicationComponent
Public NotInheritable Class Connection
    Inherits ApplicationComponent
Public NotInheritable Class Connection
    Inherits ApplicationComponent
public ref class Connection sealed : public ApplicationComponent
public ref class Connection sealed : public ApplicationComponent
[<SealedAttribute>]
type Connection =
    class
        inherit ApplicationComponent
    end
[<SealedAttribute>]
type Connection =
    class
        inherit ApplicationComponent
    end
See Also
Connection Members
NFX.DataAccess.MongoDB.Connector Namespace


Connection Members

Connection Members NFX Class Library

The Connection type exposes the following members.
Constructors
 | Name | Description
Protected method | Connection | Initializes a new instance of the Connection class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Count |
Protected method | Delete |
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | Drop |
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | Find |
Protected method | FindOne |
Protected method | GetCollectionNames |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Protected method | GetMore |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Insert |
Protected method | KillCursor |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Ping |
Protected method | Release | Releases the connection that has been acquired before
Protected method | RunCommand |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | TryAcquire | Returns true when the instance was able to get acquired by the calling thread for the exclusive use
Protected method | Update |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | DEFAUL_LOCAL_NODE |
 | DEFAULT_LOCAL_MONGO_HOST |
 | DEFAULT_MONGO_BINDING |
 | DEFAULT_MONGO_PORT |
Protected field | m_ExpirationStartUTC |
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExpirationStartUTC | Returns when the connection started to expire for its inactivity or null
Public property | IsAcquired |
Public property | Server |
Back to Top
See Also
Connection Class
NFX.DataAccess.MongoDB.Connector Namespace


Connection Constructor

Connection Constructor NFX Class Library

Initializes a new instance of the Connection class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Connection(
    ServerNode server
)
internal Connection(
    ServerNode server
)
Friend Sub New (
    server As ServerNode
)
Friend Sub New (
    server As ServerNode
)
internal:
Connection(
    ServerNode^ server
)
internal:
Connection(
    ServerNode^ server
)
new :
        server : ServerNode -> Connection
new :
        server : ServerNode -> Connection

Parameters

server
Type: NFX.DataAccess.MongoDB.Connector ServerNode
See Also
Connection Class
Connection Members
NFX.DataAccess.MongoDB.Connector Namespace


Connection Fields

Connection Fields NFX Class Library

The Connection type exposes the following members.
Fields
 | Name | Description
 | DEFAUL_LOCAL_NODE |
 | DEFAULT_LOCAL_MONGO_HOST |
 | DEFAULT_MONGO_BINDING |
 | DEFAULT_MONGO_PORT |
Protected field | m_ExpirationStartUTC |
Back to Top
See Also
Connection Class
NFX.DataAccess.MongoDB.Connector Namespace


Connection.DEFAUL_LOCAL_NODE Field

Connection DEFAUL_LOCAL_NODE Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Node DEFAUL_LOCAL_NODE
public static readonly Node DEFAUL_LOCAL_NODE
Public Shared ReadOnly DEFAUL_LOCAL_NODE As Node
Public Shared ReadOnly DEFAUL_LOCAL_NODE As Node
public:
static initonly Node DEFAUL_LOCAL_NODE
public:
static initonly Node DEFAUL_LOCAL_NODE
static val DEFAUL_LOCAL_NODE: Node
static val DEFAUL_LOCAL_NODE: Node

Field Value

Type: Node
See Also
Connection Class
Connection Members
NFX.DataAccess.MongoDB.Connector Namespace


Connection.DEFAULT_LOCAL_MONGO_HOST Field

Connection DEFAULT_LOCAL_MONGO_HOST Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_LOCAL_MONGO_HOST
public const string DEFAULT_LOCAL_MONGO_HOST
Public Const DEFAULT_LOCAL_MONGO_HOST As String
Public Const DEFAULT_LOCAL_MONGO_HOST As String
public:
literal String^ DEFAULT_LOCAL_MONGO_HOST
public:
literal String^ DEFAULT_LOCAL_MONGO_HOST
static val mutable DEFAULT_LOCAL_MONGO_HOST: string
static val mutable DEFAULT_LOCAL_MONGO_HOST: string

Field Value

Type: Online String
See Also
Connection Class
Connection Members
NFX.DataAccess.MongoDB.Connector Namespace


Connection.DEFAULT_MONGO_BINDING Field

Connection DEFAULT_MONGO_BINDING Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_MONGO_BINDING
public const string DEFAULT_MONGO_BINDING
Public Const DEFAULT_MONGO_BINDING As String
Public Const DEFAULT_MONGO_BINDING As String
public:
literal String^ DEFAULT_MONGO_BINDING
public:
literal String^ DEFAULT_MONGO_BINDING
static val mutable DEFAULT_MONGO_BINDING: string
static val mutable DEFAULT_MONGO_BINDING: string

Field Value

Type: Online String
See Also
Connection Class
Connection Members
NFX.DataAccess.MongoDB.Connector Namespace


Connection.DEFAULT_MONGO_PORT Field

Connection DEFAULT_MONGO_PORT Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_MONGO_PORT
public const int DEFAULT_MONGO_PORT
Public Const DEFAULT_MONGO_PORT As Integer
Public Const DEFAULT_MONGO_PORT As Integer
public:
literal int DEFAULT_MONGO_PORT
public:
literal int DEFAULT_MONGO_PORT
static val mutable DEFAULT_MONGO_PORT: int
static val mutable DEFAULT_MONGO_PORT: int

Field Value

Type: Online Int32
See Also
Connection Class
Connection Members
NFX.DataAccess.MongoDB.Connector Namespace


Connection.m_ExpirationStartUTC Field

Connection m_ExpirationStartUTC Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Nullable<DateTime> m_ExpirationStartUTC
internal Nullable<DateTime> m_ExpirationStartUTC
Friend m_ExpirationStartUTC As Nullable(Of DateTime)
Friend m_ExpirationStartUTC As Nullable(Of DateTime)
internal:
Nullable<DateTime> m_ExpirationStartUTC
internal:
Nullable<DateTime> m_ExpirationStartUTC
val mutable internal m_ExpirationStartUTC: Nullable<DateTime>
val mutable internal m_ExpirationStartUTC: Nullable<DateTime>

Field Value

Type: Online Nullable Online DateTime
See Also
Connection Class
Connection Members
NFX.DataAccess.MongoDB.Connector Namespace


Connection Methods

Connection Methods NFX Class Library

The Connection type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Count |
Protected method | Delete |
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | Drop |
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | Find |
Protected method | FindOne |
Protected method | GetCollectionNames |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Protected method | GetMore |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Insert |
Protected method | KillCursor |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Ping |
Protected method | Release | Releases the connection that has been acquired before
Protected method | RunCommand |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | TryAcquire | Returns true when the instance was able to get acquired by the calling thread for the exclusive use
Protected method | Update |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Connection Class
NFX.DataAccess.MongoDB.Connector Namespace


Connection.Count Method

Connection Count Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal long Count(
    int requestID,
    Collection collection,
    Query query = null,
    int limit = -1,
    int skip = -1,
    Object hint = null
)
internal long Count(
    int requestID,
    Collection collection,
    Query query = null,
    int limit = -1,
    int skip = -1,
    Object hint = null
)
Friend Function Count (
    requestID As Integer,
    collection As Collection,
    Optional query As Query = Nothing,
    Optional limit As Integer = -1,
    Optional skip As Integer = -1,
    Optional hint As Object = Nothing
) As Long
Friend Function Count (
    requestID As Integer,
    collection As Collection,
    Optional query As Query = Nothing,
    Optional limit As Integer = -1,
    Optional skip As Integer = -1,
    Optional hint As Object = Nothing
) As Long
internal:
long long Count(
    int requestID,
    Collection^ collection,
    Query^ query = nullptr,
    int limit = -1,
    int skip = -1,
    Object^ hint = nullptr
)
internal:
long long Count(
    int requestID,
    Collection^ collection,
    Query^ query = nullptr,
    int limit = -1,
    int skip = -1,
    Object^ hint = nullptr
)
internal member Count :
        requestID : int *
        collection : Collection *
        ?query : Query *
        ?limit : int *
        ?skip : int *
        ?hint : Object
(* Defaults:
        let _query = defaultArg query null
        let _limit = defaultArg limit -1
        let _skip = defaultArg skip -1
        let _hint = defaultArg hint null
*)
-> int64
internal member Count :
        requestID : int *
        collection : Collection *
        ?query : Query *
        ?limit : int *
        ?skip : int *
        ?hint : Object
(* Defaults:
        let _query = defaultArg query null
        let _limit = defaultArg limit -1
        let _skip = defaultArg skip -1
        let _hint = defaultArg hint null
*)
-> int64

Parameters

requestID
Type: Online System Int32
collection
Type: NFX.DataAccess.MongoDB.Connector Collection
query (Optional)
Type: NFX.DataAccess.MongoDB.Connector Query
limit (Optional)
Type: Online System Int32
skip (Optional)
Type: Online System Int32
hint (Optional)
Type: Online System Object

Return Value

Type: Online Int64
See Also
Connection Class
Connection Members
NFX.DataAccess.MongoDB.Connector Namespace


Connection.Delete Method

Connection Delete Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CRUDResult Delete(
    int requestID,
    Collection collection,
    DeleteEntry[] deletes
)
internal CRUDResult Delete(
    int requestID,
    Collection collection,
    DeleteEntry[] deletes
)
Friend Function Delete (
    requestID As Integer,
    collection As Collection,
    deletes As DeleteEntry()
) As CRUDResult
Friend Function Delete (
    requestID As Integer,
    collection As Collection,
    deletes As DeleteEntry()
) As CRUDResult
internal:
CRUDResult Delete(
    int requestID,
    Collection^ collection,
    array<DeleteEntry>^ deletes
)
internal:
CRUDResult Delete(
    int requestID,
    Collection^ collection,
    array<DeleteEntry>^ deletes
)
internal member Delete :
        requestID : int *
        collection : Collection *
        deletes : DeleteEntry[] -> CRUDResult
internal member Delete :
        requestID : int *
        collection : Collection *
        deletes : DeleteEntry[] -> CRUDResult

Parameters

requestID
Type: Online System Int32
collection
Type: NFX.DataAccess.MongoDB.Connector Collection
deletes
Type: NFX.DataAccess.MongoDB.Connector DeleteEntry

Return Value

Type: CRUDResult
See Also
Connection Class
Connection Members
NFX.DataAccess.MongoDB.Connector Namespace


Connection.Destructor Method

Connection Destructor Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
Connection Class
Connection Members
NFX.DataAccess.MongoDB.Connector Namespace


Connection.Drop Method

Connection Drop Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Drop(
    int requestID,
    Collection collection
)
internal void Drop(
    int requestID,
    Collection collection
)
Friend Sub Drop (
    requestID As Integer,
    collection As Collection
)
Friend Sub Drop (
    requestID As Integer,
    collection As Collection
)
internal:
void Drop(
    int requestID,
    Collection^ collection
)
internal:
void Drop(
    int requestID,
    Collection^ collection
)
internal member Drop :
        requestID : int *
        collection : Collection -> unit
internal member Drop :
        requestID : int *
        collection : Collection -> unit

Parameters

requestID
Type: Online System Int32
collection
Type: NFX.DataAccess.MongoDB.Connector Collection
See Also
Connection Class
Connection Members
NFX.DataAccess.MongoDB.Connector Namespace


Connection.Find Method

Connection Find Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Cursor Find(
    int requestID,
    Collection collection,
    Query query,
    BSONDocument selector,
    int skipCount,
    int fetchBy
)
internal Cursor Find(
    int requestID,
    Collection collection,
    Query query,
    BSONDocument selector,
    int skipCount,
    int fetchBy
)
Friend Function Find (
    requestID As Integer,
    collection As Collection,
    query As Query,
    selector As BSONDocument,
    skipCount As Integer,
    fetchBy As Integer
) As Cursor
Friend Function Find (
    requestID As Integer,
    collection As Collection,
    query As Query,
    selector As BSONDocument,
    skipCount As Integer,
    fetchBy As Integer
) As Cursor
internal:
Cursor^ Find(
    int requestID,
    Collection^ collection,
    Query^ query,
    BSONDocument^ selector,
    int skipCount,
    int fetchBy
)
internal:
Cursor^ Find(
    int requestID,
    Collection^ collection,
    Query^ query,
    BSONDocument^ selector,
    int skipCount,
    int fetchBy
)
internal member Find :
        requestID : int *
        collection : Collection *
        query : Query *
        selector : BSONDocument *
        skipCount : int *
        fetchBy : int -> Cursor
internal member Find :
        requestID : int *
        collection : Collection *
        query : Query *
        selector : BSONDocument *
        skipCount : int *
        fetchBy : int -> Cursor

Parameters

requestID
Type: Online System Int32
collection
Type: NFX.DataAccess.MongoDB.Connector Collection
query
Type: NFX.DataAccess.MongoDB.Connector Query
selector
Type: NFX.Serialization.BSON BSONDocument
skipCount
Type: Online System Int32
fetchBy
Type: Online System Int32

Return Value

Type: Cursor
See Also
Connection Class
Connection Members
NFX.DataAccess.MongoDB.Connector Namespace


Connection.FindOne Method

Connection FindOne Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal BSONDocument FindOne(
    int requestID,
    Collection collection,
    Query query,
    BSONDocument selector
)
internal BSONDocument FindOne(
    int requestID,
    Collection collection,
    Query query,
    BSONDocument selector
)
Friend Function FindOne (
    requestID As Integer,
    collection As Collection,
    query As Query,
    selector As BSONDocument
) As BSONDocument
Friend Function FindOne (
    requestID As Integer,
    collection As Collection,
    query As Query,
    selector As BSONDocument
) As BSONDocument
internal:
BSONDocument^ FindOne(
    int requestID,
    Collection^ collection,
    Query^ query,
    BSONDocument^ selector
)
internal:
BSONDocument^ FindOne(
    int requestID,
    Collection^ collection,
    Query^ query,
    BSONDocument^ selector
)
internal member FindOne :
        requestID : int *
        collection : Collection *
        query : Query *
        selector : BSONDocument -> BSONDocument
internal member FindOne :
        requestID : int *
        collection : Collection *
        query : Query *
        selector : BSONDocument -> BSONDocument

Parameters

requestID
Type: Online System Int32
collection
Type: NFX.DataAccess.MongoDB.Connector Collection
query
Type: NFX.DataAccess.MongoDB.Connector Query
selector
Type: NFX.Serialization.BSON BSONDocument

Return Value

Type: BSONDocument
See Also
Connection Class
Connection Members
NFX.DataAccess.MongoDB.Connector Namespace


Connection.GetCollectionNames Method

Connection GetCollectionNames Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal string[] GetCollectionNames(
    int requestID,
    Database db
)
internal string[] GetCollectionNames(
    int requestID,
    Database db
)
Friend Function GetCollectionNames (
    requestID As Integer,
    db As Database
) As String()
Friend Function GetCollectionNames (
    requestID As Integer,
    db As Database
) As String()
internal:
array<String^>^ GetCollectionNames(
    int requestID,
    Database^ db
)
internal:
array<String^>^ GetCollectionNames(
    int requestID,
    Database^ db
)
internal member GetCollectionNames :
        requestID : int *
        db : Database -> string[]
internal member GetCollectionNames :
        requestID : int *
        db : Database -> string[]

Parameters

requestID
Type: Online System Int32
db
Type: NFX.DataAccess.MongoDB.Connector Database

Return Value

Type: Online String
See Also
Connection Class
Connection Members
NFX.DataAccess.MongoDB.Connector Namespace


Connection.GetMore Method

Connection GetMore Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal BSONDocument[] GetMore(
    int requestID,
    Cursor cursor
)
internal BSONDocument[] GetMore(
    int requestID,
    Cursor cursor
)
Friend Function GetMore (
    requestID As Integer,
    cursor As Cursor
) As BSONDocument()
Friend Function GetMore (
    requestID As Integer,
    cursor As Cursor
) As BSONDocument()
internal:
array<BSONDocument^>^ GetMore(
    int requestID,
    Cursor^ cursor
)
internal:
array<BSONDocument^>^ GetMore(
    int requestID,
    Cursor^ cursor
)
internal member GetMore :
        requestID : int *
        cursor : Cursor -> BSONDocument[]
internal member GetMore :
        requestID : int *
        cursor : Cursor -> BSONDocument[]

Parameters

requestID
Type: Online System Int32
cursor
Type: NFX.DataAccess.MongoDB.Connector Cursor

Return Value

Type: BSONDocument
See Also
Connection Class
Connection Members
NFX.DataAccess.MongoDB.Connector Namespace


Connection.Insert Method

Connection Insert Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CRUDResult Insert(
    int requestID,
    Collection collection,
    BSONDocument[] data
)
internal CRUDResult Insert(
    int requestID,
    Collection collection,
    BSONDocument[] data
)
Friend Function Insert (
    requestID As Integer,
    collection As Collection,
    data As BSONDocument()
) As CRUDResult
Friend Function Insert (
    requestID As Integer,
    collection As Collection,
    data As BSONDocument()
) As CRUDResult
internal:
CRUDResult Insert(
    int requestID,
    Collection^ collection,
    array<BSONDocument^>^ data
)
internal:
CRUDResult Insert(
    int requestID,
    Collection^ collection,
    array<BSONDocument^>^ data
)
internal member Insert :
        requestID : int *
        collection : Collection *
        data : BSONDocument[] -> CRUDResult
internal member Insert :
        requestID : int *
        collection : Collection *
        data : BSONDocument[] -> CRUDResult

Parameters

requestID
Type: Online System Int32
collection
Type: NFX.DataAccess.MongoDB.Connector Collection
data
Type: NFX.Serialization.BSON BSONDocument

Return Value

Type: CRUDResult
See Also
Connection Class
Connection Members
NFX.DataAccess.MongoDB.Connector Namespace


Connection.KillCursor Method

Connection KillCursor Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void KillCursor(
    int requestID,
    Cursor[] cursors
)
internal void KillCursor(
    int requestID,
    Cursor[] cursors
)
Friend Sub KillCursor (
    requestID As Integer,
    cursors As Cursor()
)
Friend Sub KillCursor (
    requestID As Integer,
    cursors As Cursor()
)
internal:
void KillCursor(
    int requestID,
    array<Cursor^>^ cursors
)
internal:
void KillCursor(
    int requestID,
    array<Cursor^>^ cursors
)
internal member KillCursor :
        requestID : int *
        cursors : Cursor[] -> unit
internal member KillCursor :
        requestID : int *
        cursors : Cursor[] -> unit

Parameters

requestID
Type: Online System Int32
cursors
Type: NFX.DataAccess.MongoDB.Connector Cursor
See Also
Connection Class
Connection Members
NFX.DataAccess.MongoDB.Connector Namespace


Connection.Ping Method

Connection Ping Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Ping(
    int requestID,
    Database db
)
internal void Ping(
    int requestID,
    Database db
)
Friend Sub Ping (
    requestID As Integer,
    db As Database
)
Friend Sub Ping (
    requestID As Integer,
    db As Database
)
internal:
void Ping(
    int requestID,
    Database^ db
)
internal:
void Ping(
    int requestID,
    Database^ db
)
internal member Ping :
        requestID : int *
        db : Database -> unit
internal member Ping :
        requestID : int *
        db : Database -> unit

Parameters

requestID
Type: Online System Int32
db
Type: NFX.DataAccess.MongoDB.Connector Database
See Also
Connection Class
Connection Members
NFX.DataAccess.MongoDB.Connector Namespace


Connection.Release Method

Connection Release Method NFX Class Library

Releases the connection that has been acquired before

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Release(
    bool callFromManager = false
)
internal void Release(
    bool callFromManager = false
)
Friend Sub Release (
    Optional callFromManager As Boolean = false
)
Friend Sub Release (
    Optional callFromManager As Boolean = false
)
internal:
void Release(
    bool callFromManager = false
)
internal:
void Release(
    bool callFromManager = false
)
internal member Release :
        ?callFromManager : bool
(* Defaults:
        let _callFromManager = defaultArg callFromManager false
*)
-> unit
internal member Release :
        ?callFromManager : bool
(* Defaults:
        let _callFromManager = defaultArg callFromManager false
*)
-> unit

Parameters

callFromManager (Optional)
Type: Online System Boolean
See Also
Connection Class
Connection Members
NFX.DataAccess.MongoDB.Connector Namespace


Connection.RunCommand Method

Connection RunCommand Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal BSONDocument RunCommand(
    int requestID,
    Database database,
    BSONDocument command
)
internal BSONDocument RunCommand(
    int requestID,
    Database database,
    BSONDocument command
)
Friend Function RunCommand (
    requestID As Integer,
    database As Database,
    command As BSONDocument
) As BSONDocument
Friend Function RunCommand (
    requestID As Integer,
    database As Database,
    command As BSONDocument
) As BSONDocument
internal:
BSONDocument^ RunCommand(
    int requestID,
    Database^ database,
    BSONDocument^ command
)
internal:
BSONDocument^ RunCommand(
    int requestID,
    Database^ database,
    BSONDocument^ command
)
internal member RunCommand :
        requestID : int *
        database : Database *
        command : BSONDocument -> BSONDocument
internal member RunCommand :
        requestID : int *
        database : Database *
        command : BSONDocument -> BSONDocument

Parameters

requestID
Type: Online System Int32
database
Type: NFX.DataAccess.MongoDB.Connector Database
command
Type: NFX.Serialization.BSON BSONDocument

Return Value

Type: BSONDocument
See Also
Connection Class
Connection Members
NFX.DataAccess.MongoDB.Connector Namespace


Connection.TryAcquire Method

Connection TryAcquire Method NFX Class Library

Returns true when the instance was able to get acquired by the calling thread for the exclusive use

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal bool TryAcquire()
internal bool TryAcquire()
Friend Function TryAcquire As Boolean
Friend Function TryAcquire As Boolean
internal:
bool TryAcquire()
internal:
bool TryAcquire()
internal member TryAcquire : unit -> bool
internal member TryAcquire : unit -> bool

Return Value

Type: Online Boolean
See Also
Connection Class
Connection Members
NFX.DataAccess.MongoDB.Connector Namespace


Connection.Update Method

Connection Update Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CRUDResult Update(
    int requestID,
    Collection collection,
    UpdateEntry[] updates
)
internal CRUDResult Update(
    int requestID,
    Collection collection,
    UpdateEntry[] updates
)
Friend Function Update (
    requestID As Integer,
    collection As Collection,
    updates As UpdateEntry()
) As CRUDResult
Friend Function Update (
    requestID As Integer,
    collection As Collection,
    updates As UpdateEntry()
) As CRUDResult
internal:
CRUDResult Update(
    int requestID,
    Collection^ collection,
    array<UpdateEntry>^ updates
)
internal:
CRUDResult Update(
    int requestID,
    Collection^ collection,
    array<UpdateEntry>^ updates
)
internal member Update :
        requestID : int *
        collection : Collection *
        updates : UpdateEntry[] -> CRUDResult
internal member Update :
        requestID : int *
        collection : Collection *
        updates : UpdateEntry[] -> CRUDResult

Parameters

requestID
Type: Online System Int32
collection
Type: NFX.DataAccess.MongoDB.Connector Collection
updates
Type: NFX.DataAccess.MongoDB.Connector UpdateEntry

Return Value

Type: CRUDResult
See Also
Connection Class
Connection Members
NFX.DataAccess.MongoDB.Connector Namespace


Connection Properties

Connection Properties NFX Class Library

The Connection type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExpirationStartUTC | Returns when the connection started to expire for its inactivity or null
Public property | IsAcquired |
Public property | Server |
Back to Top
See Also
Connection Class
NFX.DataAccess.MongoDB.Connector Namespace


Connection.ExpirationStartUTC Property

Connection ExpirationStartUTC Property NFX Class Library

Returns when the connection started to expire for its inactivity or null

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> ExpirationStartUTC { get; }
public Nullable<DateTime> ExpirationStartUTC { get; }
Public ReadOnly Property ExpirationStartUTC As Nullable(Of DateTime)
    Get
Public ReadOnly Property ExpirationStartUTC As Nullable(Of DateTime)
    Get
public:
property Nullable<DateTime> ExpirationStartUTC {
    Nullable<DateTime> get ();
}
public:
property Nullable<DateTime> ExpirationStartUTC {
    Nullable<DateTime> get ();
}
member ExpirationStartUTC : Nullable<DateTime> with get
member ExpirationStartUTC : Nullable<DateTime> with get

Property Value

Type: Online Nullable Online DateTime
See Also
Connection Class
Connection Members
NFX.DataAccess.MongoDB.Connector Namespace


Connection.IsAcquired Property

Connection IsAcquired Property NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsAcquired { get; }
public bool IsAcquired { get; }
Public ReadOnly Property IsAcquired As Boolean
    Get
Public ReadOnly Property IsAcquired As Boolean
    Get
public:
property bool IsAcquired {
    bool get ();
}
public:
property bool IsAcquired {
    bool get ();
}
member IsAcquired : bool with get
member IsAcquired : bool with get

Property Value

Type: Online Boolean
See Also
Connection Class
Connection Members
NFX.DataAccess.MongoDB.Connector Namespace


Connection.Server Property

Connection Server Property NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerNode Server { get; }
public ServerNode Server { get; }
Public ReadOnly Property Server As ServerNode
    Get
Public ReadOnly Property Server As ServerNode
    Get
public:
property ServerNode^ Server {
    ServerNode^ get ();
}
public:
property ServerNode^ Server {
    ServerNode^ get ();
}
member Server : ServerNode with get
member Server : ServerNode with get

Property Value

Type: ServerNode
See Also
Connection Class
Connection Members
NFX.DataAccess.MongoDB.Connector Namespace


CRUDResult Structure

CRUDResult Structure NFX Class Library

Returned by CRUD operations from the server, contains information about total docs affected and write errors. The caller needs to inspect the TotalDocumentsAffected and WriteErrors to handle error conditions

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct CRUDResult
public struct CRUDResult
Public Structure CRUDResult
Public Structure CRUDResult
public value class CRUDResult
public value class CRUDResult
[<SealedAttribute>]
type CRUDResult =  struct end
[<SealedAttribute>]
type CRUDResult =  struct end
See Also
CRUDResult Members
NFX.DataAccess.MongoDB.Connector Namespace


CRUDResult Members

CRUDResult Members NFX Class Library

The CRUDResult type exposes the following members.
Constructors
 | Name | Description
Protected method | CRUDResult | Initializes a new instance of the CRUDResult class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | TotalDocumentsAffected | This field contains the aggregated number of documents successfully matched (n) by the entire write command. This includes the number of documents inserted, upserted, updated, and deleted. We do not report on the individual number of documents affected by each batch item. If the application would wish so, then the application should issue one-item batches.
Public field | TotalDocumentsUpdatedAffected | Optional field, with a positive numeric type or zero. Zero is the default value. This field is only and always present for batch updates. nModified is the physical number of documents affected by an update, while TotalDocumentsMatched is the logical number of documents matched by the update's query.
Public field | Upserted | NULL or for every batch document that was upserted
Public field | WriteErrors | NULL or For every batch write that had an error, there is one entry in the array describing the error
Back to Top
See Also
CRUDResult Structure
NFX.DataAccess.MongoDB.Connector Namespace


CRUDResult Constructor

CRUDResult Constructor NFX Class Library

Initializes a new instance of the CRUDResult class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CRUDResult(
    int n,
    int nModified,
    CRUDWriteError[] wErrors,
    CRUDUpsertInfo[] upserted
)
internal CRUDResult(
    int n,
    int nModified,
    CRUDWriteError[] wErrors,
    CRUDUpsertInfo[] upserted
)
Friend Sub New (
    n As Integer,
    nModified As Integer,
    wErrors As CRUDWriteError(),
    upserted As CRUDUpsertInfo()
)
Friend Sub New (
    n As Integer,
    nModified As Integer,
    wErrors As CRUDWriteError(),
    upserted As CRUDUpsertInfo()
)
internal:
CRUDResult(
    int n,
    int nModified,
    array<CRUDWriteError>^ wErrors,
    array<CRUDUpsertInfo>^ upserted
)
internal:
CRUDResult(
    int n,
    int nModified,
    array<CRUDWriteError>^ wErrors,
    array<CRUDUpsertInfo>^ upserted
)
new :
        n : int *
        nModified : int *
        wErrors : CRUDWriteError[] *
        upserted : CRUDUpsertInfo[] -> CRUDResult
new :
        n : int *
        nModified : int *
        wErrors : CRUDWriteError[] *
        upserted : CRUDUpsertInfo[] -> CRUDResult

Parameters

n
Type: Online System Int32
nModified
Type: Online System Int32
wErrors
Type: NFX.DataAccess.MongoDB.Connector CRUDWriteError
upserted
Type: NFX.DataAccess.MongoDB.Connector CRUDUpsertInfo
See Also
CRUDResult Structure
CRUDResult Members
NFX.DataAccess.MongoDB.Connector Namespace


CRUDResult Fields

CRUDResult Fields NFX Class Library

The CRUDResult type exposes the following members.
Fields
 | Name | Description
Public field | TotalDocumentsAffected | This field contains the aggregated number of documents successfully matched (n) by the entire write command. This includes the number of documents inserted, upserted, updated, and deleted. We do not report on the individual number of documents affected by each batch item. If the application would wish so, then the application should issue one-item batches.
Public field | TotalDocumentsUpdatedAffected | Optional field, with a positive numeric type or zero. Zero is the default value. This field is only and always present for batch updates. nModified is the physical number of documents affected by an update, while TotalDocumentsMatched is the logical number of documents matched by the update's query.
Public field | Upserted | NULL or for every batch document that was upserted
Public field | WriteErrors | NULL or For every batch write that had an error, there is one entry in the array describing the error
Back to Top
See Also
CRUDResult Structure
NFX.DataAccess.MongoDB.Connector Namespace


CRUDResult.TotalDocumentsAffected Field

CRUDResult TotalDocumentsAffected Field NFX Class Library

This field contains the aggregated number of documents successfully matched (n) by the entire write command. This includes the number of documents inserted, upserted, updated, and deleted. We do not report on the individual number of documents affected by each batch item. If the application would wish so, then the application should issue one-item batches.

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int TotalDocumentsAffected
public readonly int TotalDocumentsAffected
Public ReadOnly TotalDocumentsAffected As Integer
Public ReadOnly TotalDocumentsAffected As Integer
public:
initonly int TotalDocumentsAffected
public:
initonly int TotalDocumentsAffected
val TotalDocumentsAffected: int
val TotalDocumentsAffected: int

Field Value

Type: Online Int32
See Also
CRUDResult Structure
CRUDResult Members
NFX.DataAccess.MongoDB.Connector Namespace


CRUDResult.TotalDocumentsUpdatedAffected Field

CRUDResult TotalDocumentsUpdatedAffected Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Optional field, with a positive numeric type or zero. Zero is the default value. This field is only and always present for batch updates. nModified is the physical number of documents affected by an update, while TotalDocumentsMatched is the logical number of documents matched by the update's query.

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int TotalDocumentsUpdatedAffected
public readonly int TotalDocumentsUpdatedAffected
Public ReadOnly TotalDocumentsUpdatedAffected As Integer
Public ReadOnly TotalDocumentsUpdatedAffected As Integer
public:
initonly int TotalDocumentsUpdatedAffected
public:
initonly int TotalDocumentsUpdatedAffected
val TotalDocumentsUpdatedAffected: int
val TotalDocumentsUpdatedAffected: int

Field Value

Type: Online Int32
See Also
CRUDResult Structure
CRUDResult Members
NFX.DataAccess.MongoDB.Connector Namespace


CRUDResult.Upserted Field

CRUDResult Upserted Field NFX Class Library

NULL or for every batch document that was upserted

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly CRUDUpsertInfo[] Upserted
public readonly CRUDUpsertInfo[] Upserted
Public ReadOnly Upserted As CRUDUpsertInfo()
Public ReadOnly Upserted As CRUDUpsertInfo()
public:
initonly array<CRUDUpsertInfo>^ Upserted
public:
initonly array<CRUDUpsertInfo>^ Upserted
val Upserted: CRUDUpsertInfo[]
val Upserted: CRUDUpsertInfo[]

Field Value

Type: CRUDUpsertInfo
See Also
CRUDResult Structure
CRUDResult Members
NFX.DataAccess.MongoDB.Connector Namespace


CRUDResult.WriteErrors Field

CRUDResult WriteErrors Field NFX Class Library

NULL or For every batch write that had an error, there is one entry in the array describing the error

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly CRUDWriteError[] WriteErrors
public readonly CRUDWriteError[] WriteErrors
Public ReadOnly WriteErrors As CRUDWriteError()
Public ReadOnly WriteErrors As CRUDWriteError()
public:
initonly array<CRUDWriteError>^ WriteErrors
public:
initonly array<CRUDWriteError>^ WriteErrors
val WriteErrors: CRUDWriteError[]
val WriteErrors: CRUDWriteError[]

Field Value

Type: CRUDWriteError
See Also
CRUDResult Structure
CRUDResult Members
NFX.DataAccess.MongoDB.Connector Namespace


CRUDResult Methods

CRUDResult Methods NFX Class Library

The CRUDResult type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CRUDResult Structure
NFX.DataAccess.MongoDB.Connector Namespace


CRUDUpsertInfo Structure

CRUDUpsertInfo Structure NFX Class Library

Provides information about an upserted document

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct CRUDUpsertInfo
public struct CRUDUpsertInfo
Public Structure CRUDUpsertInfo
Public Structure CRUDUpsertInfo
public value class CRUDUpsertInfo
public value class CRUDUpsertInfo
[<SealedAttribute>]
type CRUDUpsertInfo =  struct end
[<SealedAttribute>]
type CRUDUpsertInfo =  struct end
See Also
CRUDUpsertInfo Members
NFX.DataAccess.MongoDB.Connector Namespace


CRUDUpsertInfo Members

CRUDUpsertInfo Members NFX Class Library

The CRUDUpsertInfo type exposes the following members.
Constructors
 | Name | Description
Protected method | CRUDUpsertInfo | Initializes a new instance of the CRUDUpsertInfo class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | ID | _ID value assigned by an upsert
Public field | Index | Index of the document in the batch
Back to Top
See Also
CRUDUpsertInfo Structure
NFX.DataAccess.MongoDB.Connector Namespace


CRUDUpsertInfo Constructor

CRUDUpsertInfo Constructor NFX Class Library

Initializes a new instance of the CRUDUpsertInfo class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CRUDUpsertInfo(
    int idx,
    Object id
)
internal CRUDUpsertInfo(
    int idx,
    Object id
)
Friend Sub New (
    idx As Integer,
    id As Object
)
Friend Sub New (
    idx As Integer,
    id As Object
)
internal:
CRUDUpsertInfo(
    int idx,
    Object^ id
)
internal:
CRUDUpsertInfo(
    int idx,
    Object^ id
)
new :
        idx : int *
        id : Object -> CRUDUpsertInfo
new :
        idx : int *
        id : Object -> CRUDUpsertInfo

Parameters

idx
Type: Online System Int32
id
Type: Online System Object
See Also
CRUDUpsertInfo Structure
CRUDUpsertInfo Members
NFX.DataAccess.MongoDB.Connector Namespace


CRUDUpsertInfo Fields

CRUDUpsertInfo Fields NFX Class Library

The CRUDUpsertInfo type exposes the following members.
Fields
 | Name | Description
Public field | ID | _ID value assigned by an upsert
Public field | Index | Index of the document in the batch
Back to Top
See Also
CRUDUpsertInfo Structure
NFX.DataAccess.MongoDB.Connector Namespace


CRUDUpsertInfo.ID Field

CRUDUpsertInfo ID Field NFX Class Library

_ID value assigned by an upsert

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Object ID
public readonly Object ID
Public ReadOnly ID As Object
Public ReadOnly ID As Object
public:
initonly Object^ ID
public:
initonly Object^ ID
val ID: Object
val ID: Object

Field Value

Type: Online Object
See Also
CRUDUpsertInfo Structure
CRUDUpsertInfo Members
NFX.DataAccess.MongoDB.Connector Namespace


CRUDUpsertInfo.Index Field

CRUDUpsertInfo Index Field NFX Class Library

Index of the document in the batch

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Index
public readonly int Index
Public ReadOnly Index As Integer
Public ReadOnly Index As Integer
public:
initonly int Index
public:
initonly int Index
val Index: int
val Index: int

Field Value

Type: Online Int32
See Also
CRUDUpsertInfo Structure
CRUDUpsertInfo Members
NFX.DataAccess.MongoDB.Connector Namespace


CRUDUpsertInfo Methods

CRUDUpsertInfo Methods NFX Class Library

The CRUDUpsertInfo type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CRUDUpsertInfo Structure
NFX.DataAccess.MongoDB.Connector Namespace


CRUDWriteError Structure

CRUDWriteError Structure NFX Class Library

Provides information about document write error

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct CRUDWriteError
public struct CRUDWriteError
Public Structure CRUDWriteError
Public Structure CRUDWriteError
public value class CRUDWriteError
public value class CRUDWriteError
[<SealedAttribute>]
type CRUDWriteError =  struct end
[<SealedAttribute>]
type CRUDWriteError =  struct end
See Also
CRUDWriteError Members
NFX.DataAccess.MongoDB.Connector Namespace


CRUDWriteError Members

CRUDWriteError Members NFX Class Library

The CRUDWriteError type exposes the following members.
Constructors
 | Name | Description
Protected method | CRUDWriteError | Initializes a new instance of the CRUDWriteError class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Code | Mandatory field with integer format. Contains a numeric code corresponding to a certain type of error
Public field | Index | WRITE ERROR ONLY, The index of the erroneous batch item relative to request batch order. Batch items indexes start with 0
Public field | Info | Optional field, with a BSONObj format. This field contains structured information about an error that can be processed programmatically. For example, if a request returns with a shard version error, we may report the proper shard version as a sub-field here. For another example, if a write concern timeout occurred, the information previously reported on wtimeout would be reported here. The format of this field depends on the code above
Public field | Message | Mandatory field, containing a human-readable version of the error.
Back to Top
See Also
CRUDWriteError Structure
NFX.DataAccess.MongoDB.Connector Namespace


CRUDWriteError Constructor

CRUDWriteError Constructor NFX Class Library

Initializes a new instance of the CRUDWriteError class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CRUDWriteError(
    int idx,
    int code,
    string msg,
    Object info
)
internal CRUDWriteError(
    int idx,
    int code,
    string msg,
    Object info
)
Friend Sub New (
    idx As Integer,
    code As Integer,
    msg As String,
    info As Object
)
Friend Sub New (
    idx As Integer,
    code As Integer,
    msg As String,
    info As Object
)
internal:
CRUDWriteError(
    int idx,
    int code,
    String^ msg,
    Object^ info
)
internal:
CRUDWriteError(
    int idx,
    int code,
    String^ msg,
    Object^ info
)
new :
        idx : int *
        code : int *
        msg : string *
        info : Object -> CRUDWriteError
new :
        idx : int *
        code : int *
        msg : string *
        info : Object -> CRUDWriteError

Parameters

idx
Type: Online System Int32
code
Type: Online System Int32
msg
Type: Online System String
info
Type: Online System Object
See Also
CRUDWriteError Structure
CRUDWriteError Members
NFX.DataAccess.MongoDB.Connector Namespace


CRUDWriteError Fields

CRUDWriteError Fields NFX Class Library

The CRUDWriteError type exposes the following members.
Fields
 | Name | Description
Public field | Code | Mandatory field with integer format. Contains a numeric code corresponding to a certain type of error
Public field | Index | WRITE ERROR ONLY, The index of the erroneous batch item relative to request batch order. Batch items indexes start with 0
Public field | Info | Optional field, with a BSONObj format. This field contains structured information about an error that can be processed programmatically. For example, if a request returns with a shard version error, we may report the proper shard version as a sub-field here. For another example, if a write concern timeout occurred, the information previously reported on wtimeout would be reported here. The format of this field depends on the code above
Public field | Message | Mandatory field, containing a human-readable version of the error.
Back to Top
See Also
CRUDWriteError Structure
NFX.DataAccess.MongoDB.Connector Namespace


CRUDWriteError.Code Field

CRUDWriteError Code Field NFX Class Library

Mandatory field with integer format. Contains a numeric code corresponding to a certain type of error

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Code
public readonly int Code
Public ReadOnly Code As Integer
Public ReadOnly Code As Integer
public:
initonly int Code
public:
initonly int Code
val Code: int
val Code: int

Field Value

Type: Online Int32
See Also
CRUDWriteError Structure
CRUDWriteError Members
NFX.DataAccess.MongoDB.Connector Namespace


CRUDWriteError.Index Field

CRUDWriteError Index Field NFX Class Library

WRITE ERROR ONLY, The index of the erroneous batch item relative to request batch order. Batch items indexes start with 0

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Index
public readonly int Index
Public ReadOnly Index As Integer
Public ReadOnly Index As Integer
public:
initonly int Index
public:
initonly int Index
val Index: int
val Index: int

Field Value

Type: Online Int32
See Also
CRUDWriteError Structure
CRUDWriteError Members
NFX.DataAccess.MongoDB.Connector Namespace


CRUDWriteError.Info Field

CRUDWriteError Info Field NFX Class Library

Optional field, with a BSONObj format. This field contains structured information about an error that can be processed programmatically. For example, if a request returns with a shard version error, we may report the proper shard version as a sub-field here. For another example, if a write concern timeout occurred, the information previously reported on wtimeout would be reported here. The format of this field depends on the code above

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Object Info
public readonly Object Info
Public ReadOnly Info As Object
Public ReadOnly Info As Object
public:
initonly Object^ Info
public:
initonly Object^ Info
val Info: Object
val Info: Object

Field Value

Type: Online Object
See Also
CRUDWriteError Structure
CRUDWriteError Members
NFX.DataAccess.MongoDB.Connector Namespace


CRUDWriteError.Message Field

CRUDWriteError Message Field NFX Class Library

Mandatory field, containing a human-readable version of the error.

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Message
public readonly string Message
Public ReadOnly Message As String
Public ReadOnly Message As String
public:
initonly String^ Message
public:
initonly String^ Message
val Message: string
val Message: string

Field Value

Type: Online String
See Also
CRUDWriteError Structure
CRUDWriteError Members
NFX.DataAccess.MongoDB.Connector Namespace


CRUDWriteError Methods

CRUDWriteError Methods NFX Class Library

The CRUDWriteError type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CRUDWriteError Structure
NFX.DataAccess.MongoDB.Connector Namespace


Cursor Class

Cursor Class NFX Class Library

Represents a UNIDIRECTIONAL SINGLE-pass (no buffering) cursor returned by the Find(query) command. The cursor needs to be closed by calling Dispose() if the eof has not been reached OR it will auto-close on EOF. The cursor may be enumerated only once. It is NOT thread-safe
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.DataAccess.MongoDB.Connector Cursor

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Cursor : DisposableObject,
    IEnumerable<BSONDocument>, IEnumerable, IEnumerator<BSONDocument>,
    IDisposable, IEnumerator
public sealed class Cursor : DisposableObject,
    IEnumerable<BSONDocument>, IEnumerable, IEnumerator<BSONDocument>,
    IDisposable, IEnumerator
Public NotInheritable Class Cursor
    Inherits DisposableObject
    Implements IEnumerable(Of BSONDocument), IEnumerable,
    IEnumerator(Of BSONDocument), IDisposable, IEnumerator
Public NotInheritable Class Cursor
    Inherits DisposableObject
    Implements IEnumerable(Of BSONDocument), IEnumerable,
    IEnumerator(Of BSONDocument), IDisposable, IEnumerator
public ref class Cursor sealed : public DisposableObject,
    IEnumerable<BSONDocument^>, IEnumerable, IEnumerator<BSONDocument^>,
    IDisposable, IEnumerator
public ref class Cursor sealed : public DisposableObject,
    IEnumerable<BSONDocument^>, IEnumerable, IEnumerator<BSONDocument^>,
    IDisposable, IEnumerator
[<SealedAttribute>]
type Cursor =
    class
        inherit DisposableObject
        interface IEnumerable<BSONDocument>
        interface IEnumerable
        interface IEnumerator<BSONDocument>
        interface IDisposable
        interface IEnumerator
    end
[<SealedAttribute>]
type Cursor =
    class
        inherit DisposableObject
        interface IEnumerable<BSONDocument>
        interface IEnumerable
        interface IEnumerator<BSONDocument>
        interface IDisposable
        interface IEnumerator
    end
See Also
Cursor Members
NFX.DataAccess.MongoDB.Connector Namespace


Cursor Members

Cursor Members NFX Class Library

The Cursor type exposes the following members.
Constructors
 | Name | Description
Protected method | Cursor | Initializes a new instance of the Cursor class
Back to Top
Methods
 | Name | Description
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MoveNext |
Public method | Reset |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable BSONDocument | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct BSONDocument, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax BSONDocument, TComparand (Func BSONDocument, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax BSONDocument, TComparand (Func BSONDocument, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin BSONDocument, TComparand (Func BSONDocument, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin BSONDocument, TComparand (Func BSONDocument, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault BSONDocument | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach BSONDocument (Action BSONDocument ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach BSONDocument (Action BSONDocument, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast BSONDocument | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast BSONDocument (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
DEFAULT_FETCH_BY |
Back to Top
Properties
 | Name | Description
Public property | Collection | Collection that cursor is open against
Public property | Current |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EOF | True if EOF has been reached
Public property | FetchBy | Gets/sets the size of GET_MORE fetch
Public property | ID | Server-supplied cursor ID
Public property | Query | Query that was sent to the server and resulted in this cursor
Public property | Selector | Optional selector that was issued with Query or NULL
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerator Current |
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
Cursor Class
NFX.DataAccess.MongoDB.Connector Namespace


Cursor Constructor

Cursor Constructor NFX Class Library

Initializes a new instance of the Cursor class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Cursor(
    long id,
    Collection collection,
    Query query,
    BSONDocument selector,
    BSONDocument[] initialData
)
internal Cursor(
    long id,
    Collection collection,
    Query query,
    BSONDocument selector,
    BSONDocument[] initialData
)
Friend Sub New (
    id As Long,
    collection As Collection,
    query As Query,
    selector As BSONDocument,
    initialData As BSONDocument()
)
Friend Sub New (
    id As Long,
    collection As Collection,
    query As Query,
    selector As BSONDocument,
    initialData As BSONDocument()
)
internal:
Cursor(
    long long id,
    Collection^ collection,
    Query^ query,
    BSONDocument^ selector,
    array<BSONDocument^>^ initialData
)
internal:
Cursor(
    long long id,
    Collection^ collection,
    Query^ query,
    BSONDocument^ selector,
    array<BSONDocument^>^ initialData
)
new :
        id : int64 *
        collection : Collection *
        query : Query *
        selector : BSONDocument *
        initialData : BSONDocument[] -> Cursor
new :
        id : int64 *
        collection : Collection *
        query : Query *
        selector : BSONDocument *
        initialData : BSONDocument[] -> Cursor

Parameters

id
Type: Online System Int64
collection
Type: NFX.DataAccess.MongoDB.Connector Collection
query
Type: NFX.DataAccess.MongoDB.Connector Query
selector
Type: NFX.Serialization.BSON BSONDocument
initialData
Type: NFX.Serialization.BSON BSONDocument
See Also
Cursor Class
Cursor Members
NFX.DataAccess.MongoDB.Connector Namespace


Cursor Fields

Cursor Fields NFX Class Library

The Cursor type exposes the following members.
Fields
Name | Description
DEFAULT_FETCH_BY |
Back to Top
See Also
Cursor Class
NFX.DataAccess.MongoDB.Connector Namespace


Cursor.DEFAULT_FETCH_BY Field

Cursor DEFAULT_FETCH_BY Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_FETCH_BY
public const int DEFAULT_FETCH_BY
Public Const DEFAULT_FETCH_BY As Integer
Public Const DEFAULT_FETCH_BY As Integer
public:
literal int DEFAULT_FETCH_BY
public:
literal int DEFAULT_FETCH_BY
static val mutable DEFAULT_FETCH_BY: int
static val mutable DEFAULT_FETCH_BY: int

Field Value

Type: Online Int32
See Also
Cursor Class
Cursor Members
NFX.DataAccess.MongoDB.Connector Namespace


Cursor Methods

Cursor Methods NFX Class Library

The Cursor type exposes the following members.
Methods
 | Name | Description
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MoveNext |
Public method | Reset |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable BSONDocument | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct BSONDocument, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax BSONDocument, TComparand (Func BSONDocument, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax BSONDocument, TComparand (Func BSONDocument, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin BSONDocument, TComparand (Func BSONDocument, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin BSONDocument, TComparand (Func BSONDocument, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault BSONDocument | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach BSONDocument (Action BSONDocument ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach BSONDocument (Action BSONDocument, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast BSONDocument | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast BSONDocument (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
Cursor Class
NFX.DataAccess.MongoDB.Connector Namespace


Cursor.IEnumerable.GetEnumerator Method

Cursor IEnumerable GetEnumerator Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
Cursor Class
Cursor Members
NFX.DataAccess.MongoDB.Connector Namespace


Cursor.Destructor Method

Cursor Destructor Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
Cursor Class
Cursor Members
NFX.DataAccess.MongoDB.Connector Namespace


Cursor.GetEnumerator Method

Cursor GetEnumerator Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<BSONDocument> GetEnumerator()
public IEnumerator<BSONDocument> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of BSONDocument)
Public Function GetEnumerator As IEnumerator(Of BSONDocument)
public:
virtual IEnumerator<BSONDocument^>^ GetEnumerator() sealed
public:
virtual IEnumerator<BSONDocument^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<BSONDocument>
override GetEnumerator : unit -> IEnumerator<BSONDocument>
abstract GetEnumerator : unit -> IEnumerator<BSONDocument>
override GetEnumerator : unit -> IEnumerator<BSONDocument>

Return Value

Type: Online IEnumerator BSONDocument

Implements

Online IEnumerable T GetEnumerator
See Also
Cursor Class
Cursor Members
NFX.DataAccess.MongoDB.Connector Namespace


Cursor.MoveNext Method

Cursor MoveNext Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool MoveNext()
public bool MoveNext()
Public Function MoveNext As Boolean
Public Function MoveNext As Boolean
public:
virtual bool MoveNext() sealed
public:
virtual bool MoveNext() sealed
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Type: Online Boolean

Implements

Online IEnumerator MoveNext
See Also
Cursor Class
Cursor Members
NFX.DataAccess.MongoDB.Connector Namespace


Cursor.Reset Method

Cursor Reset Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Reset()
public void Reset()
Public Sub Reset
Public Sub Reset
public:
virtual void Reset() sealed
public:
virtual void Reset() sealed
abstract Reset : unit -> unit
override Reset : unit -> unit
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

Online IEnumerator Reset
See Also
Cursor Class
Cursor Members
NFX.DataAccess.MongoDB.Connector Namespace


Cursor Properties

Cursor Properties NFX Class Library

The Cursor type exposes the following members.
Properties
 | Name | Description
Public property | Collection | Collection that cursor is open against
Public property | Current |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EOF | True if EOF has been reached
Public property | FetchBy | Gets/sets the size of GET_MORE fetch
Public property | ID | Server-supplied cursor ID
Public property | Query | Query that was sent to the server and resulted in this cursor
Public property | Selector | Optional selector that was issued with Query or NULL
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerator Current |
Back to Top
See Also
Cursor Class
NFX.DataAccess.MongoDB.Connector Namespace


Cursor.IEnumerator.Current Property

Cursor IEnumerator Current Property NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object IEnumerator.Current { get; }
Object IEnumerator.Current { get; }
Private ReadOnly Property Current As Object
    Implements IEnumerator.Current
    Get
Private ReadOnly Property Current As Object
    Implements IEnumerator.Current
    Get
private:
virtual property Object^ Current {
    Object^ get () sealed = IEnumerator::Current::get;
}
private:
virtual property Object^ Current {
    Object^ get () sealed = IEnumerator::Current::get;
}
private abstract Current : Object with get
private override Current : Object with get
private abstract Current : Object with get
private override Current : Object with get

Property Value

Type: Online Object

Implements

Online IEnumerator Current
See Also
Cursor Class
Cursor Members
NFX.DataAccess.MongoDB.Connector Namespace


Cursor.Collection Property

Cursor Collection Property NFX Class Library

Collection that cursor is open against

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Collection Collection { get; }
public Collection Collection { get; }
Public ReadOnly Property Collection As Collection
    Get
Public ReadOnly Property Collection As Collection
    Get
public:
property Collection^ Collection {
    Collection^ get ();
}
public:
property Collection^ Collection {
    Collection^ get ();
}
member Collection : Collection with get
member Collection : Collection with get

Property Value

Type: Collection
See Also
Cursor Class
Cursor Members
NFX.DataAccess.MongoDB.Connector Namespace


Cursor.Current Property

Cursor Current Property NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONDocument Current { get; }
public BSONDocument Current { get; }
Public ReadOnly Property Current As BSONDocument
    Get
Public ReadOnly Property Current As BSONDocument
    Get
public:
virtual property BSONDocument^ Current {
    BSONDocument^ get () sealed;
}
public:
virtual property BSONDocument^ Current {
    BSONDocument^ get () sealed;
}
abstract Current : BSONDocument with get
override Current : BSONDocument with get
abstract Current : BSONDocument with get
override Current : BSONDocument with get

Property Value

Type: BSONDocument

Implements

Online IEnumerator T Current
See Also
Cursor Class
Cursor Members
NFX.DataAccess.MongoDB.Connector Namespace


Cursor.EOF Property

Cursor EOF Property NFX Class Library

True if EOF has been reached

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool EOF { get; }
public bool EOF { get; }
Public ReadOnly Property EOF As Boolean
    Get
Public ReadOnly Property EOF As Boolean
    Get
public:
property bool EOF {
    bool get ();
}
public:
property bool EOF {
    bool get ();
}
member EOF : bool with get
member EOF : bool with get

Property Value

Type: Online Boolean
See Also
Cursor Class
Cursor Members
NFX.DataAccess.MongoDB.Connector Namespace


Cursor.FetchBy Property

Cursor FetchBy Property NFX Class Library

Gets/sets the size of GET_MORE fetch

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int FetchBy { get; set; }
public int FetchBy { get; set; }
Public Property FetchBy As Integer
    Get
    Set
Public Property FetchBy As Integer
    Get
    Set
public:
property int FetchBy {
    int get ();
    void set (int value);
}
public:
property int FetchBy {
    int get ();
    void set (int value);
}
member FetchBy : int with get, set
member FetchBy : int with get, set

Property Value

Type: Online Int32
See Also
Cursor Class
Cursor Members
NFX.DataAccess.MongoDB.Connector Namespace


Cursor.ID Property

Cursor ID Property NFX Class Library

Server-supplied cursor ID

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long ID { get; }
public long ID { get; }
Public ReadOnly Property ID As Long
    Get
Public ReadOnly Property ID As Long
    Get
public:
property long long ID {
    long long get ();
}
public:
property long long ID {
    long long get ();
}
member ID : int64 with get
member ID : int64 with get

Property Value

Type: Online Int64
See Also
Cursor Class
Cursor Members
NFX.DataAccess.MongoDB.Connector Namespace


Cursor.Query Property

Cursor Query Property NFX Class Library

Query that was sent to the server and resulted in this cursor

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Query Query { get; }
public Query Query { get; }
Public ReadOnly Property Query As Query
    Get
Public ReadOnly Property Query As Query
    Get
public:
property Query^ Query {
    Query^ get ();
}
public:
property Query^ Query {
    Query^ get ();
}
member Query : Query with get
member Query : Query with get

Property Value

Type: Query
See Also
Cursor Class
Cursor Members
NFX.DataAccess.MongoDB.Connector Namespace


Cursor.Selector Property

Cursor Selector Property NFX Class Library

Optional selector that was issued with Query or NULL

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONDocument Selector { get; }
public BSONDocument Selector { get; }
Public ReadOnly Property Selector As BSONDocument
    Get
Public ReadOnly Property Selector As BSONDocument
    Get
public:
property BSONDocument^ Selector {
    BSONDocument^ get ();
}
public:
property BSONDocument^ Selector {
    BSONDocument^ get ();
}
member Selector : BSONDocument with get
member Selector : BSONDocument with get

Property Value

Type: BSONDocument
See Also
Cursor Class
Cursor Members
NFX.DataAccess.MongoDB.Connector Namespace


Database Class

Database Class NFX Class Library

Represents an instance of MongoDB database
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.DataAccess.MongoDB.Connector Database

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Database : DisposableObject,
    INamed
public sealed class Database : DisposableObject,
    INamed
Public NotInheritable Class Database
    Inherits DisposableObject
    Implements INamed
Public NotInheritable Class Database
    Inherits DisposableObject
    Implements INamed
public ref class Database sealed : public DisposableObject,
    INamed
public ref class Database sealed : public DisposableObject,
    INamed
[<SealedAttribute>]
type Database =
    class
        inherit DisposableObject
        interface INamed
    end
[<SealedAttribute>]
type Database =
    class
        inherit DisposableObject
        interface INamed
    end
See Also
Database Members
NFX.DataAccess.MongoDB.Connector Namespace


Database Members

Database Members NFX Class Library

The Database type exposes the following members.
Constructors
 | Name | Description
Protected method | Database | Initializes a new instance of the Database class
Back to Top
Methods
 | Name | Description
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetCollectionNames | Returns the names of collections in this database
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Ping | Executes a NOP command that round-trips from the server
Public method | RunCommand | Runs database-level command. Does not perform any error checks beyond network traffic req/resp passing
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_CMD_NameCStringBuffer |
Protected field | m_Collections |
Back to Top
Properties
 | Name | Description
Public property | Collections | Returns mounted collections
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Item | Returns an existing collection or creates a new one
Public property | Name |
Protected property | NextRequestID | Generates request ID unique per server node
Public property | Server |
Back to Top
See Also
Database Class
NFX.DataAccess.MongoDB.Connector Namespace


Database Constructor

Database Constructor NFX Class Library

Initializes a new instance of the Database class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Database(
    ServerNode server,
    string name
)
internal Database(
    ServerNode server,
    string name
)
Friend Sub New (
    server As ServerNode,
    name As String
)
Friend Sub New (
    server As ServerNode,
    name As String
)
internal:
Database(
    ServerNode^ server,
    String^ name
)
internal:
Database(
    ServerNode^ server,
    String^ name
)
new :
        server : ServerNode *
        name : string -> Database
new :
        server : ServerNode *
        name : string -> Database

Parameters

server
Type: NFX.DataAccess.MongoDB.Connector ServerNode
name
Type: Online System String
See Also
Database Class
Database Members
NFX.DataAccess.MongoDB.Connector Namespace


Database Fields

Database Fields NFX Class Library

The Database type exposes the following members.
Fields
 | Name | Description
Protected field | m_CMD_NameCStringBuffer |
Protected field | m_Collections |
Back to Top
See Also
Database Class
NFX.DataAccess.MongoDB.Connector Namespace


Database.m_CMD_NameCStringBuffer Field

Database m_CMD_NameCStringBuffer Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal readonly byte[] m_CMD_NameCStringBuffer
internal readonly byte[] m_CMD_NameCStringBuffer
Friend ReadOnly m_CMD_NameCStringBuffer As Byte()
Friend ReadOnly m_CMD_NameCStringBuffer As Byte()
internal:
initonly array<unsigned char>^ m_CMD_NameCStringBuffer
internal:
initonly array<unsigned char>^ m_CMD_NameCStringBuffer
val internal m_CMD_NameCStringBuffer: byte[]
val internal m_CMD_NameCStringBuffer: byte[]

Field Value

Type: Online Byte
See Also
Database Class
Database Members
NFX.DataAccess.MongoDB.Connector Namespace


Database.m_Collections Field

Database m_Collections Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Registry<Collection> m_Collections
internal Registry<Collection> m_Collections
Friend m_Collections As Registry(Of Collection)
Friend m_Collections As Registry(Of Collection)
internal:
Registry<Collection^>^ m_Collections
internal:
Registry<Collection^>^ m_Collections
val mutable internal m_Collections: Registry<Collection>
val mutable internal m_Collections: Registry<Collection>

Field Value

Type: Registry Collection
See Also
Database Class
Database Members
NFX.DataAccess.MongoDB.Connector Namespace


Database Methods

Database Methods NFX Class Library

The Database type exposes the following members.
Methods
 | Name | Description
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetCollectionNames | Returns the names of collections in this database
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Ping | Executes a NOP command that round-trips from the server
Public method | RunCommand | Runs database-level command. Does not perform any error checks beyond network traffic req/resp passing
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Database Class
NFX.DataAccess.MongoDB.Connector Namespace


Database.Destructor Method

Database Destructor Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
Database Class
Database Members
NFX.DataAccess.MongoDB.Connector Namespace


Database.GetCollectionNames Method

Database GetCollectionNames Method NFX Class Library

Returns the names of collections in this database

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string[] GetCollectionNames()
public string[] GetCollectionNames()
Public Function GetCollectionNames As String()
Public Function GetCollectionNames As String()
public:
array<String^>^ GetCollectionNames()
public:
array<String^>^ GetCollectionNames()
member GetCollectionNames : unit -> string[]
member GetCollectionNames : unit -> string[]

Return Value

Type: Online String
See Also
Database Class
Database Members
NFX.DataAccess.MongoDB.Connector Namespace


Database.Ping Method

Database Ping Method NFX Class Library

Executes a NOP command that round-trips from the server

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Ping()
public void Ping()
Public Sub Ping
Public Sub Ping
public:
void Ping()
public:
void Ping()
member Ping : unit -> unit
member Ping : unit -> unit
See Also
Database Class
Database Members
NFX.DataAccess.MongoDB.Connector Namespace


Database.RunCommand Method

Database RunCommand Method NFX Class Library

Runs database-level command. Does not perform any error checks beyond network traffic req/resp passing

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONDocument RunCommand(
    BSONDocument command
)
public BSONDocument RunCommand(
    BSONDocument command
)
Public Function RunCommand (
    command As BSONDocument
) As BSONDocument
Public Function RunCommand (
    command As BSONDocument
) As BSONDocument
public:
BSONDocument^ RunCommand(
    BSONDocument^ command
)
public:
BSONDocument^ RunCommand(
    BSONDocument^ command
)
member RunCommand :
        command : BSONDocument -> BSONDocument
member RunCommand :
        command : BSONDocument -> BSONDocument

Parameters

command
Type: NFX.Serialization.BSON BSONDocument

Return Value

Type: BSONDocument
See Also
Database Class
Database Members
NFX.DataAccess.MongoDB.Connector Namespace


Database Properties

Database Properties NFX Class Library

The Database type exposes the following members.
Properties
 | Name | Description
Public property | Collections | Returns mounted collections
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Item | Returns an existing collection or creates a new one
Public property | Name |
Protected property | NextRequestID | Generates request ID unique per server node
Public property | Server |
Back to Top
See Also
Database Class
NFX.DataAccess.MongoDB.Connector Namespace


Database.Collections Property

Database Collections Property NFX Class Library

Returns mounted collections

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<Collection> Collections { get; }
public IRegistry<Collection> Collections { get; }
Public ReadOnly Property Collections As IRegistry(Of Collection)
    Get
Public ReadOnly Property Collections As IRegistry(Of Collection)
    Get
public:
property IRegistry<Collection^>^ Collections {
    IRegistry<Collection^>^ get ();
}
public:
property IRegistry<Collection^>^ Collections {
    IRegistry<Collection^>^ get ();
}
member Collections : IRegistry<Collection> with get
member Collections : IRegistry<Collection> with get

Property Value

Type: IRegistry Collection
See Also
Database Class
Database Members
NFX.DataAccess.MongoDB.Connector Namespace


Database.Item Property

Database Item Property NFX Class Library

Returns an existing collection or creates a new one

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Collection this[
    string name
] { get; }
public Collection this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As Collection
    Get
Public ReadOnly Default Property Item (
    name As String
) As Collection
    Get
public:
property Collection^ default[String^ name] {
    Collection^ get (String^ name);
}
public:
property Collection^ default[String^ name] {
    Collection^ get (String^ name);
}
member Item : Collection with get
member Item : Collection with get

Parameters

name
Type: Online System String

Property Value

Type: Collection
See Also
Database Class
Database Members
NFX.DataAccess.MongoDB.Connector Namespace


Database.Name Property

Database Name Property NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
Database Class
Database Members
NFX.DataAccess.MongoDB.Connector Namespace


Database.NextRequestID Property

Database NextRequestID Property NFX Class Library

Generates request ID unique per server node

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int NextRequestID { get; }
internal int NextRequestID { get; }
Friend ReadOnly Property NextRequestID As Integer
    Get
Friend ReadOnly Property NextRequestID As Integer
    Get
internal:
property int NextRequestID {
    int get ();
}
internal:
property int NextRequestID {
    int get ();
}
internal member NextRequestID : int with get
internal member NextRequestID : int with get

Property Value

Type: Online Int32
See Also
Database Class
Database Members
NFX.DataAccess.MongoDB.Connector Namespace


Database.Server Property

Database Server Property NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerNode Server { get; }
public ServerNode Server { get; }
Public ReadOnly Property Server As ServerNode
    Get
Public ReadOnly Property Server As ServerNode
    Get
public:
property ServerNode^ Server {
    ServerNode^ get ();
}
public:
property ServerNode^ Server {
    ServerNode^ get ();
}
member Server : ServerNode with get
member Server : ServerNode with get

Property Value

Type: ServerNode
See Also
Database Class
Database Members
NFX.DataAccess.MongoDB.Connector Namespace


DeleteEntry Structure

DeleteEntry Structure NFX Class Library

Pairs necessary information for deletes: query + limit flag

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct DeleteEntry
public struct DeleteEntry
Public Structure DeleteEntry
Public Structure DeleteEntry
public value class DeleteEntry
public value class DeleteEntry
[<SealedAttribute>]
type DeleteEntry =  struct end
[<SealedAttribute>]
type DeleteEntry =  struct end
See Also
DeleteEntry Members
NFX.DataAccess.MongoDB.Connector Namespace


DeleteEntry Members

DeleteEntry Members NFX Class Library

The DeleteEntry type exposes the following members.
Constructors
 | Name | Description
Public method | DeleteEntry | Initializes a new instance of the DeleteEntry class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Limit |
Public field | Query |
Back to Top
See Also
DeleteEntry Structure
NFX.DataAccess.MongoDB.Connector Namespace


DeleteEntry Constructor

DeleteEntry Constructor NFX Class Library

Initializes a new instance of the DeleteEntry class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DeleteEntry(
    BSONDocument query,
    DeleteLimit limit
)
public DeleteEntry(
    BSONDocument query,
    DeleteLimit limit
)
Public Sub New (
    query As BSONDocument,
    limit As DeleteLimit
)
Public Sub New (
    query As BSONDocument,
    limit As DeleteLimit
)
public:
DeleteEntry(
    BSONDocument^ query,
    DeleteLimit limit
)
public:
DeleteEntry(
    BSONDocument^ query,
    DeleteLimit limit
)
new :
        query : BSONDocument *
        limit : DeleteLimit -> DeleteEntry
new :
        query : BSONDocument *
        limit : DeleteLimit -> DeleteEntry

Parameters

query
Type: NFX.Serialization.BSON BSONDocument
limit
Type: NFX.DataAccess.MongoDB.Connector DeleteLimit
See Also
DeleteEntry Structure
DeleteEntry Members
NFX.DataAccess.MongoDB.Connector Namespace


DeleteEntry Fields

DeleteEntry Fields NFX Class Library

The DeleteEntry type exposes the following members.
Fields
 | Name | Description
Public field | Limit |
Public field | Query |
Back to Top
See Also
DeleteEntry Structure
NFX.DataAccess.MongoDB.Connector Namespace


DeleteEntry.Limit Field

DeleteEntry Limit Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly DeleteLimit Limit
public readonly DeleteLimit Limit
Public ReadOnly Limit As DeleteLimit
Public ReadOnly Limit As DeleteLimit
public:
initonly DeleteLimit Limit
public:
initonly DeleteLimit Limit
val Limit: DeleteLimit
val Limit: DeleteLimit

Field Value

Type: DeleteLimit
See Also
DeleteEntry Structure
DeleteEntry Members
NFX.DataAccess.MongoDB.Connector Namespace


DeleteEntry.Query Field

DeleteEntry Query Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly BSONDocument Query
public readonly BSONDocument Query
Public ReadOnly Query As BSONDocument
Public ReadOnly Query As BSONDocument
public:
initonly BSONDocument^ Query
public:
initonly BSONDocument^ Query
val Query: BSONDocument
val Query: BSONDocument

Field Value

Type: BSONDocument
See Also
DeleteEntry Structure
DeleteEntry Members
NFX.DataAccess.MongoDB.Connector Namespace


DeleteEntry Methods

DeleteEntry Methods NFX Class Library

The DeleteEntry type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
DeleteEntry Structure
NFX.DataAccess.MongoDB.Connector Namespace


DeleteLimit Enumeration

DeleteLimit Enumeration NFX Class Library

Denotes limits for deletion: None=Everything or One

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum DeleteLimit
public enum DeleteLimit
Public Enumeration DeleteLimit
Public Enumeration DeleteLimit
public enum class DeleteLimit
public enum class DeleteLimit
type DeleteLimit
type DeleteLimit
Members
Member name | Value | Description
None | 0 | Everything that matches will be deleted
OnlyFirstMatch | 1 | Only the first matching document will be deleted
See Also
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient Class

MongoClient Class NFX Class Library

The central facade for working with MongoDB. The technology was tested against Mongo DB 3.0.6. The NFX MongoDB connector is purposely created for specific needs. It does not support: Mongo security, sharding and replication
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.DataAccess.MongoDB.Connector MongoClient

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class MongoClient : ApplicationComponent,
    IConfigurable, IInstrumentable, IExternallyParameterized, IApplicationFinishNotifiable, INamed
public sealed class MongoClient : ApplicationComponent,
    IConfigurable, IInstrumentable, IExternallyParameterized, IApplicationFinishNotifiable, INamed
Public NotInheritable Class MongoClient
    Inherits ApplicationComponent
    Implements IConfigurable, IInstrumentable, IExternallyParameterized, IApplicationFinishNotifiable,
    INamed
Public NotInheritable Class MongoClient
    Inherits ApplicationComponent
    Implements IConfigurable, IInstrumentable, IExternallyParameterized, IApplicationFinishNotifiable,
    INamed
public ref class MongoClient sealed : public ApplicationComponent,
    IConfigurable, IInstrumentable, IExternallyParameterized, IApplicationFinishNotifiable, INamed
public ref class MongoClient sealed : public ApplicationComponent,
    IConfigurable, IInstrumentable, IExternallyParameterized, IApplicationFinishNotifiable, INamed
[<SealedAttribute>]
type MongoClient =
    class
        inherit ApplicationComponent
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
        interface IApplicationFinishNotifiable
        interface INamed
    end
[<SealedAttribute>]
type MongoClient =
    class
        inherit ApplicationComponent
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
        interface IApplicationFinishNotifiable
        interface INamed
    end
See Also
MongoClient Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient Members

MongoClient Members NFX Class Library

The MongoClient type exposes the following members.
Constructors
 | Name | Description
Public method | MongoClient | Creates a new instance of client. For most applications it is sufficient to use the default singleton instance Client.Instance
Back to Top
Methods
Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method Configure
Sets config root. If this method is never called then configuration is done of the App.CONFIG_MONGO_CLIENT_SECTION section
DatabaseFromConnectString
Return a Database instance per supplied connection string in the following form:
View Colorized Copy to Clipboard Print
mongo{server="mongo://localhost:27017" db="myDB"}
mongo{server="mongo://localhost:27017" db="myDB"}
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method Dispose
Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead
(Inherited from DisposableObject.)
Public method EnsureObjectNotDisposed
Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called
(Inherited from DisposableObject.)
Public method Online Equals
Determines whether the specified object is equal to the current object.
(Inherited from Online Object.)
Public method | ExternalGetParameter
Public method | ExternalParametersForGroups
Public method | ExternalSetParameter
Protected method | Finalize | (Inherited from DisposableObject.)
Public method Online GetHashCode
Serves as the default hash function.
(Inherited from Online Object.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | CONFIG_CS_DB_ATTR |
 | CONFIG_CS_ROOT_SECTION |
 | CONFIG_CS_SERVER_ATTR |
 | CONFIG_MONGO_CLIENT_SECTION |
Protected field | m_Servers |
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | ConfigRoot | Returns the config root of the client that was set by the last call to Configure() or App.CONFIG_MONGO_CLIENT_SECTION (which may be non-existent)
Public property | DefaultLocalServer | Returns ServerNode for local server on a default port
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters |
 | Instance | Retrurns the default instance of the Client, lazily crating it on the first access
Public property | InstrumentationEnabled |
Public property | Item | Returns an existing server node or creates a new one
Public property | Name |
Public property | Servers | Returns all connected servers
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IApplicationFinishNotifiable ApplicationFinishAfterCleanup |
Explicit interface implemetation | IApplicationFinishNotifiable ApplicationFinishBeforeCleanup |
Back to Top
See Also
MongoClient Class
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient Constructor

MongoClient Constructor NFX Class Library

Creates a new instance of client. For most applications it is sufficient to use the default singleton instance Client.Instance

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoClient(
    string name
)
public MongoClient(
    string name
)
Public Sub New (
    name As String
)
Public Sub New (
    name As String
)
public:
MongoClient(
    String^ name
)
public:
MongoClient(
    String^ name
)
new :
        name : string -> MongoClient
new :
        name : string -> MongoClient

Parameters

name
Type: Online System String
See Also
MongoClient Class
MongoClient Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient Fields

MongoClient Fields NFX Class Library

The MongoClient type exposes the following members.
Fields
 | Name | Description
 | CONFIG_CS_DB_ATTR |
 | CONFIG_CS_ROOT_SECTION |
 | CONFIG_CS_SERVER_ATTR |
 | CONFIG_MONGO_CLIENT_SECTION |
Protected field | m_Servers |
Back to Top
See Also
MongoClient Class
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient.CONFIG_CS_DB_ATTR Field

MongoClient CONFIG_CS_DB_ATTR Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CS_DB_ATTR
public const string CONFIG_CS_DB_ATTR
Public Const CONFIG_CS_DB_ATTR As String
Public Const CONFIG_CS_DB_ATTR As String
public:
literal String^ CONFIG_CS_DB_ATTR
public:
literal String^ CONFIG_CS_DB_ATTR
static val mutable CONFIG_CS_DB_ATTR: string
static val mutable CONFIG_CS_DB_ATTR: string

Field Value

Type: Online String
See Also
MongoClient Class
MongoClient Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient.CONFIG_CS_ROOT_SECTION Field

MongoClient CONFIG_CS_ROOT_SECTION Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CS_ROOT_SECTION
public const string CONFIG_CS_ROOT_SECTION
Public Const CONFIG_CS_ROOT_SECTION As String
Public Const CONFIG_CS_ROOT_SECTION As String
public:
literal String^ CONFIG_CS_ROOT_SECTION
public:
literal String^ CONFIG_CS_ROOT_SECTION
static val mutable CONFIG_CS_ROOT_SECTION: string
static val mutable CONFIG_CS_ROOT_SECTION: string

Field Value

Type: Online String
See Also
MongoClient Class
MongoClient Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient.CONFIG_CS_SERVER_ATTR Field

MongoClient CONFIG_CS_SERVER_ATTR Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CS_SERVER_ATTR
public const string CONFIG_CS_SERVER_ATTR
Public Const CONFIG_CS_SERVER_ATTR As String
Public Const CONFIG_CS_SERVER_ATTR As String
public:
literal String^ CONFIG_CS_SERVER_ATTR
public:
literal String^ CONFIG_CS_SERVER_ATTR
static val mutable CONFIG_CS_SERVER_ATTR: string
static val mutable CONFIG_CS_SERVER_ATTR: string

Field Value

Type: Online String
See Also
MongoClient Class
MongoClient Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient.CONFIG_MONGO_CLIENT_SECTION Field

MongoClient CONFIG_MONGO_CLIENT_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_MONGO_CLIENT_SECTION
public const string CONFIG_MONGO_CLIENT_SECTION
Public Const CONFIG_MONGO_CLIENT_SECTION As String
Public Const CONFIG_MONGO_CLIENT_SECTION As String
public:
literal String^ CONFIG_MONGO_CLIENT_SECTION
public:
literal String^ CONFIG_MONGO_CLIENT_SECTION
static val mutable CONFIG_MONGO_CLIENT_SECTION: string
static val mutable CONFIG_MONGO_CLIENT_SECTION: string

Field Value

Type: Online String
See Also
MongoClient Class
MongoClient Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient.m_Servers Field

MongoClient m_Servers Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Registry<ServerNode> m_Servers
internal Registry<ServerNode> m_Servers
Friend m_Servers As Registry(Of ServerNode)
Friend m_Servers As Registry(Of ServerNode)
internal:
Registry<ServerNode^>^ m_Servers
internal:
Registry<ServerNode^>^ m_Servers
val mutable internal m_Servers: Registry<ServerNode>
val mutable internal m_Servers: Registry<ServerNode>

Field Value

Type: Registry ServerNode
See Also
MongoClient Class
MongoClient Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient Methods

MongoClient Methods NFX Class Library

The MongoClient type exposes the following members.
Methods
Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method Configure
Sets config root. If this method is never called then configuration is done of the App.CONFIG_MONGO_CLIENT_SECTION section
DatabaseFromConnectString
Return a Database instance per supplied connection string in the following form:
View Colorized Copy to Clipboard Print
mongo{server="mongo://localhost:27017" db="myDB"}
mongo{server="mongo://localhost:27017" db="myDB"}
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method Dispose
Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead
(Inherited from DisposableObject.)
Public method EnsureObjectNotDisposed
Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called
(Inherited from DisposableObject.)
Public method Online Equals
Determines whether the specified object is equal to the current object.
(Inherited from Online Object.)
Public method | ExternalGetParameter
Public method | ExternalParametersForGroups
Public method | ExternalSetParameter
Protected method | Finalize | (Inherited from DisposableObject.)
Public method Online GetHashCode
Serves as the default hash function.
(Inherited from Online Object.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IApplicationFinishNotifiable ApplicationFinishAfterCleanup |
Explicit interface implemetation | IApplicationFinishNotifiable ApplicationFinishBeforeCleanup |
Back to Top
See Also
MongoClient Class
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient.Configure Method

MongoClient Configure Method NFX Class Library

Sets config root. If this method is never called then configuration is done of the App.CONFIG_MONGO_CLIENT_SECTION section

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode node
)
public void Configure(
    IConfigSectionNode node
)
Public Sub Configure (
    node As IConfigSectionNode
)
Public Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
MongoClient Class
MongoClient Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient.DatabaseFromConnectString Method

MongoClient DatabaseFromConnectString Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Return a Database instance per supplied connection string in the following form:
View Colorized Copy to Clipboard Print
mongo{server="mongo://localhost:27017" db="myDB"}
mongo{server="mongo://localhost:27017" db="myDB"}

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Database DatabaseFromConnectString(
    string cString
)
public static Database DatabaseFromConnectString(
    string cString
)
Public Shared Function DatabaseFromConnectString (
    cString As String
) As Database
Public Shared Function DatabaseFromConnectString (
    cString As String
) As Database
public:
static Database^ DatabaseFromConnectString(
    String^ cString
)
public:
static Database^ DatabaseFromConnectString(
    String^ cString
)
static member DatabaseFromConnectString :
        cString : string -> Database
static member DatabaseFromConnectString :
        cString : string -> Database

Parameters

cString
Type: Online System String

Return Value

Type: Database
See Also
MongoClient Class
MongoClient Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient.Destructor Method

MongoClient Destructor Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
MongoClient Class
MongoClient Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient.ExternalGetParameter Method

MongoClient ExternalGetParameter Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
public bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
Public Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
Public Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
) sealed
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
) sealed
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalGetParameter(String, Object , String )
See Also
MongoClient Class
MongoClient Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient.ExternalParametersForGroups Method

MongoClient ExternalParametersForGroups Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
public IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
Public Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
Public Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
) sealed
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
) sealed
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>

Parameters

groups
Type: Online System String

Return Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParametersForGroups( String )
See Also
MongoClient Class
MongoClient Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient.ExternalSetParameter Method

MongoClient ExternalSetParameter Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
public bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
Public Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
Public Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
) sealed
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
) sealed
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalSetParameter(String, Object, String )
See Also
MongoClient Class
MongoClient Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient.IApplicationFinishNotifiable.ApplicationFinishAfterCleanup Method

MongoClient IApplicationFinishNotifiable ApplicationFinishAfterCleanup Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void IApplicationFinishNotifiable.ApplicationFinishAfterCleanup(
    IApplication application
)
void IApplicationFinishNotifiable.ApplicationFinishAfterCleanup(
    IApplication application
)
Private Sub ApplicationFinishAfterCleanup (
    application As IApplication
) Implements IApplicationFinishNotifiable.ApplicationFinishAfterCleanup
Private Sub ApplicationFinishAfterCleanup (
    application As IApplication
) Implements IApplicationFinishNotifiable.ApplicationFinishAfterCleanup
private:
virtual void ApplicationFinishAfterCleanup(
    IApplication^ application
) sealed = IApplicationFinishNotifiable::ApplicationFinishAfterCleanup
private:
virtual void ApplicationFinishAfterCleanup(
    IApplication^ application
) sealed = IApplicationFinishNotifiable::ApplicationFinishAfterCleanup
private abstract ApplicationFinishAfterCleanup :
        application : IApplication -> unit
private override ApplicationFinishAfterCleanup :
        application : IApplication -> unit
private abstract ApplicationFinishAfterCleanup :
        application : IApplication -> unit
private override ApplicationFinishAfterCleanup :
        application : IApplication -> unit

Parameters

application
Type: NFX.ApplicationModel IApplication

Implements

IApplicationFinishNotifiable ApplicationFinishAfterCleanup(IApplication)
See Also
MongoClient Class
MongoClient Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient.IApplicationFinishNotifiable.ApplicationFinishBeforeCleanup Method

MongoClient IApplicationFinishNotifiable ApplicationFinishBeforeCleanup Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void IApplicationFinishNotifiable.ApplicationFinishBeforeCleanup(
    IApplication application
)
void IApplicationFinishNotifiable.ApplicationFinishBeforeCleanup(
    IApplication application
)
Private Sub ApplicationFinishBeforeCleanup (
    application As IApplication
) Implements IApplicationFinishNotifiable.ApplicationFinishBeforeCleanup
Private Sub ApplicationFinishBeforeCleanup (
    application As IApplication
) Implements IApplicationFinishNotifiable.ApplicationFinishBeforeCleanup
private:
virtual void ApplicationFinishBeforeCleanup(
    IApplication^ application
) sealed = IApplicationFinishNotifiable::ApplicationFinishBeforeCleanup
private:
virtual void ApplicationFinishBeforeCleanup(
    IApplication^ application
) sealed = IApplicationFinishNotifiable::ApplicationFinishBeforeCleanup
private abstract ApplicationFinishBeforeCleanup :
        application : IApplication -> unit
private override ApplicationFinishBeforeCleanup :
        application : IApplication -> unit
private abstract ApplicationFinishBeforeCleanup :
        application : IApplication -> unit
private override ApplicationFinishBeforeCleanup :
        application : IApplication -> unit

Parameters

application
Type: NFX.ApplicationModel IApplication

Implements

IApplicationFinishNotifiable ApplicationFinishBeforeCleanup(IApplication)
See Also
MongoClient Class
MongoClient Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient.ToString Method

MongoClient ToString Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
MongoClient Class
MongoClient Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient Properties

MongoClient Properties NFX Class Library

The MongoClient type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | ConfigRoot | Returns the config root of the client that was set by the last call to Configure() or App.CONFIG_MONGO_CLIENT_SECTION (which may be non-existent)
Public property | DefaultLocalServer | Returns ServerNode for local server on a default port
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters |
 | Instance | Retrurns the default instance of the Client, lazily crating it on the first access
Public property | InstrumentationEnabled |
Public property | Item | Returns an existing server node or creates a new one
Public property | Name |
Public property | Servers | Returns all connected servers
Back to Top
See Also
MongoClient Class
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient.ConfigRoot Property

MongoClient ConfigRoot Property NFX Class Library

Returns the config root of the client that was set by the last call to Configure() or App.CONFIG_MONGO_CLIENT_SECTION (which may be non-existent)

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IConfigSectionNode ConfigRoot { get; }
public IConfigSectionNode ConfigRoot { get; }
Public ReadOnly Property ConfigRoot As IConfigSectionNode
    Get
Public ReadOnly Property ConfigRoot As IConfigSectionNode
    Get
public:
property IConfigSectionNode^ ConfigRoot {
    IConfigSectionNode^ get ();
}
public:
property IConfigSectionNode^ ConfigRoot {
    IConfigSectionNode^ get ();
}
member ConfigRoot : IConfigSectionNode with get
member ConfigRoot : IConfigSectionNode with get

Property Value

Type: IConfigSectionNode
See Also
MongoClient Class
MongoClient Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient.DefaultLocalServer Property

MongoClient DefaultLocalServer Property NFX Class Library

Returns ServerNode for local server on a default port

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerNode DefaultLocalServer { get; }
public ServerNode DefaultLocalServer { get; }
Public ReadOnly Property DefaultLocalServer As ServerNode
    Get
Public ReadOnly Property DefaultLocalServer As ServerNode
    Get
public:
property ServerNode^ DefaultLocalServer {
    ServerNode^ get ();
}
public:
property ServerNode^ DefaultLocalServer {
    ServerNode^ get ();
}
member DefaultLocalServer : ServerNode with get
member DefaultLocalServer : ServerNode with get

Property Value

Type: ServerNode
See Also
MongoClient Class
MongoClient Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient.ExternalParameters Property

MongoClient ExternalParameters Property NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
public IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
Public ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
Public ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get () sealed;
}
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get () sealed;
}
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get

Property Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParameters
See Also
MongoClient Class
MongoClient Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient.Instance Property

MongoClient Instance Property NFX Class Library

Retrurns the default instance of the Client, lazily crating it on the first access

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static MongoClient Instance { get; }
public static MongoClient Instance { get; }
Public Shared ReadOnly Property Instance As MongoClient
    Get
Public Shared ReadOnly Property Instance As MongoClient
    Get
public:
static property MongoClient^ Instance {
    MongoClient^ get ();
}
public:
static property MongoClient^ Instance {
    MongoClient^ get ();
}
static member Instance : MongoClient with get
static member Instance : MongoClient with get

Property Value

Type: MongoClient
See Also
MongoClient Class
MongoClient Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient.InstrumentationEnabled Property

MongoClient InstrumentationEnabled Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool InstrumentationEnabled { get; set; }
[ConfigAttribute]
public bool InstrumentationEnabled { get; set; }
<ConfigAttribute>
Public Property InstrumentationEnabled As Boolean
    Get
    Set
<ConfigAttribute>
Public Property InstrumentationEnabled As Boolean
    Get
    Set
public:
[ConfigAttribute]
virtual property bool InstrumentationEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
[ConfigAttribute]
virtual property bool InstrumentationEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
[<ConfigAttribute>]
abstract InstrumentationEnabled : bool with get, set
[<ConfigAttribute>]
override InstrumentationEnabled : bool with get, set
[<ConfigAttribute>]
abstract InstrumentationEnabled : bool with get, set
[<ConfigAttribute>]
override InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentable InstrumentationEnabled
See Also
MongoClient Class
MongoClient Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient.Item Property

MongoClient Item Property NFX Class Library

Returns an existing server node or creates a new one

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerNode this[
    Node node
] { get; }
public ServerNode this[
    Node node
] { get; }
Public ReadOnly Default Property Item (
    node As Node
) As ServerNode
    Get
Public ReadOnly Default Property Item (
    node As Node
) As ServerNode
    Get
public:
property ServerNode^ default[Node node] {
    ServerNode^ get (Node node);
}
public:
property ServerNode^ default[Node node] {
    ServerNode^ get (Node node);
}
member Item : ServerNode with get
member Item : ServerNode with get

Parameters

node
Type: NFX.Glue Node

Property Value

Type: ServerNode
See Also
MongoClient Class
MongoClient Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient.Name Property

MongoClient Name Property NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
MongoClient Class
MongoClient Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoClient.Servers Property

MongoClient Servers Property NFX Class Library

Returns all connected servers

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<ServerNode> Servers { get; }
public IRegistry<ServerNode> Servers { get; }
Public ReadOnly Property Servers As IRegistry(Of ServerNode)
    Get
Public ReadOnly Property Servers As IRegistry(Of ServerNode)
    Get
public:
property IRegistry<ServerNode^>^ Servers {
    IRegistry<ServerNode^>^ get ();
}
public:
property IRegistry<ServerNode^>^ Servers {
    IRegistry<ServerNode^>^ get ();
}
member Servers : IRegistry<ServerNode> with get
member Servers : IRegistry<ServerNode> with get

Property Value

Type: IRegistry ServerNode
See Also
MongoClient Class
MongoClient Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorException Class

MongoDBConnectorException Class NFX Class Library

Thrown by MongoDB data access classes
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.DataAccess DataAccessException
NFX.DataAccess.MongoDB MongoDBDataAccessException
NFX.DataAccess.MongoDB.Connector MongoDBConnectorException
NFX.DataAccess.MongoDB.Connector MongoDBConnectorProtocolException
NFX.DataAccess.MongoDB.Connector MongoDBConnectorServerException
NFX.DataAccess.MongoDB.Connector MongoDBQueryException

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MongoDBConnectorException : MongoDBDataAccessException
[SerializableAttribute]
public class MongoDBConnectorException : MongoDBDataAccessException
<SerializableAttribute>
Public Class MongoDBConnectorException
    Inherits MongoDBDataAccessException
<SerializableAttribute>
Public Class MongoDBConnectorException
    Inherits MongoDBDataAccessException
[SerializableAttribute]
public ref class MongoDBConnectorException : public MongoDBDataAccessException
[SerializableAttribute]
public ref class MongoDBConnectorException : public MongoDBDataAccessException
[<SerializableAttribute>]
type MongoDBConnectorException =
    class
        inherit MongoDBDataAccessException
    end
[<SerializableAttribute>]
type MongoDBConnectorException =
    class
        inherit MongoDBDataAccessException
    end
See Also
MongoDBConnectorException Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorException Members

MongoDBConnectorException Members NFX Class Library

The MongoDBConnectorException type exposes the following members.
Constructors
 | Name | Description
Public method | MongoDBConnectorException | Initializes a new instance of the MongoDBConnectorException class
Public method | MongoDBConnectorException(String) | Initializes a new instance of the MongoDBConnectorException class
Protected method | MongoDBConnectorException(SerializationInfo, StreamingContext) | Initializes a new instance of the MongoDBConnectorException class
Public method | MongoDBConnectorException(String, Exception) | Initializes a new instance of the MongoDBConnectorException class
Public method | MongoDBConnectorException(String, KeyViolationKind, String) | Initializes a new instance of the MongoDBConnectorException class
Public method | MongoDBConnectorException(String, Exception, KeyViolationKind, String) | Initializes a new instance of the MongoDBConnectorException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
MongoDBConnectorException Class
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorException Constructor

MongoDBConnectorException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | MongoDBConnectorException | Initializes a new instance of the MongoDBConnectorException class
Public method | MongoDBConnectorException(String) | Initializes a new instance of the MongoDBConnectorException class
Protected method | MongoDBConnectorException(SerializationInfo, StreamingContext) | Initializes a new instance of the MongoDBConnectorException class
Public method | MongoDBConnectorException(String, Exception) | Initializes a new instance of the MongoDBConnectorException class
Public method | MongoDBConnectorException(String, KeyViolationKind, String) | Initializes a new instance of the MongoDBConnectorException class
Public method | MongoDBConnectorException(String, Exception, KeyViolationKind, String) | Initializes a new instance of the MongoDBConnectorException class
Back to Top
See Also
MongoDBConnectorException Class
MongoDBConnectorException Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorException Constructor

MongoDBConnectorException Constructor NFX Class Library

Initializes a new instance of the MongoDBConnectorException class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBConnectorException()
public MongoDBConnectorException()
Public Sub New
Public Sub New
public:
MongoDBConnectorException()
public:
MongoDBConnectorException()
new : unit -> MongoDBConnectorException
new : unit -> MongoDBConnectorException
See Also
MongoDBConnectorException Class
MongoDBConnectorException Members
MongoDBConnectorException Overload
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorException Constructor (String)

MongoDBConnectorException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MongoDBConnectorException class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBConnectorException(
    string message
)
public MongoDBConnectorException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
MongoDBConnectorException(
    String^ message
)
public:
MongoDBConnectorException(
    String^ message
)
new :
        message : string -> MongoDBConnectorException
new :
        message : string -> MongoDBConnectorException

Parameters

message
Type: Online System String
See Also
MongoDBConnectorException Class
MongoDBConnectorException Members
MongoDBConnectorException Overload
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorException Constructor (SerializationInfo, StreamingContext)

MongoDBConnectorException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MongoDBConnectorException class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MongoDBConnectorException(
    SerializationInfo info,
    StreamingContext context
)
protected MongoDBConnectorException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
MongoDBConnectorException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
MongoDBConnectorException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> MongoDBConnectorException
new :
        info : SerializationInfo *
        context : StreamingContext -> MongoDBConnectorException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
MongoDBConnectorException Class
MongoDBConnectorException Members
MongoDBConnectorException Overload
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorException Constructor (String, Exception)

MongoDBConnectorException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MongoDBConnectorException class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBConnectorException(
    string message,
    Exception inner
)
public MongoDBConnectorException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
MongoDBConnectorException(
    String^ message,
    Exception^ inner
)
public:
MongoDBConnectorException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> MongoDBConnectorException
new :
        message : string *
        inner : Exception -> MongoDBConnectorException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
MongoDBConnectorException Class
MongoDBConnectorException Members
MongoDBConnectorException Overload
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorException Constructor (String, KeyViolationKind, String)

MongoDBConnectorException Constructor (String, KeyViolationKind, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MongoDBConnectorException class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBConnectorException(
    string message,
    KeyViolationKind kvKind,
    string keyViolation
)
public MongoDBConnectorException(
    string message,
    KeyViolationKind kvKind,
    string keyViolation
)
Public Sub New (
    message As String,
    kvKind As KeyViolationKind,
    keyViolation As String
)
Public Sub New (
    message As String,
    kvKind As KeyViolationKind,
    keyViolation As String
)
public:
MongoDBConnectorException(
    String^ message,
    KeyViolationKind kvKind,
    String^ keyViolation
)
public:
MongoDBConnectorException(
    String^ message,
    KeyViolationKind kvKind,
    String^ keyViolation
)
new :
        message : string *
        kvKind : KeyViolationKind *
        keyViolation : string -> MongoDBConnectorException
new :
        message : string *
        kvKind : KeyViolationKind *
        keyViolation : string -> MongoDBConnectorException

Parameters

message
Type: Online System String
kvKind
Type: NFX.DataAccess KeyViolationKind
keyViolation
Type: Online System String
See Also
MongoDBConnectorException Class
MongoDBConnectorException Members
MongoDBConnectorException Overload
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorException Constructor (String, Exception, KeyViolationKind, String)

MongoDBConnectorException Constructor (String, Exception, KeyViolationKind, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MongoDBConnectorException class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBConnectorException(
    string message,
    Exception inner,
    KeyViolationKind kvKind,
    string keyViolation
)
public MongoDBConnectorException(
    string message,
    Exception inner,
    KeyViolationKind kvKind,
    string keyViolation
)
Public Sub New (
    message As String,
    inner As Exception,
    kvKind As KeyViolationKind,
    keyViolation As String
)
Public Sub New (
    message As String,
    inner As Exception,
    kvKind As KeyViolationKind,
    keyViolation As String
)
public:
MongoDBConnectorException(
    String^ message,
    Exception^ inner,
    KeyViolationKind kvKind,
    String^ keyViolation
)
public:
MongoDBConnectorException(
    String^ message,
    Exception^ inner,
    KeyViolationKind kvKind,
    String^ keyViolation
)
new :
        message : string *
        inner : Exception *
        kvKind : KeyViolationKind *
        keyViolation : string -> MongoDBConnectorException
new :
        message : string *
        inner : Exception *
        kvKind : KeyViolationKind *
        keyViolation : string -> MongoDBConnectorException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
kvKind
Type: NFX.DataAccess KeyViolationKind
keyViolation
Type: Online System String
See Also
MongoDBConnectorException Class
MongoDBConnectorException Members
MongoDBConnectorException Overload
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorException Fields

MongoDBConnectorException Fields NFX Class Library

The MongoDBConnectorException type exposes the following members.
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
See Also
MongoDBConnectorException Class
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorException Methods

MongoDBConnectorException Methods NFX Class Library

The MongoDBConnectorException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
MongoDBConnectorException Class
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorException Properties

MongoDBConnectorException Properties NFX Class Library

The MongoDBConnectorException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
MongoDBConnectorException Class
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorException Events

MongoDBConnectorException Events NFX Class Library

The MongoDBConnectorException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
MongoDBConnectorException Class
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorProtocolException Class

MongoDBConnectorProtocolException Class NFX Class Library

Thrown by MongoDB data access classes related to protocol
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.DataAccess DataAccessException
NFX.DataAccess.MongoDB MongoDBDataAccessException
NFX.DataAccess.MongoDB.Connector MongoDBConnectorException
NFX.DataAccess.MongoDB.Connector MongoDBConnectorProtocolException

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MongoDBConnectorProtocolException : MongoDBConnectorException
[SerializableAttribute]
public class MongoDBConnectorProtocolException : MongoDBConnectorException
<SerializableAttribute>
Public Class MongoDBConnectorProtocolException
    Inherits MongoDBConnectorException
<SerializableAttribute>
Public Class MongoDBConnectorProtocolException
    Inherits MongoDBConnectorException
[SerializableAttribute]
public ref class MongoDBConnectorProtocolException : public MongoDBConnectorException
[SerializableAttribute]
public ref class MongoDBConnectorProtocolException : public MongoDBConnectorException
[<SerializableAttribute>]
type MongoDBConnectorProtocolException =
    class
        inherit MongoDBConnectorException
    end
[<SerializableAttribute>]
type MongoDBConnectorProtocolException =
    class
        inherit MongoDBConnectorException
    end
See Also
MongoDBConnectorProtocolException Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorProtocolException Members

MongoDBConnectorProtocolException Members NFX Class Library

The MongoDBConnectorProtocolException type exposes the following members.
Constructors
 | Name | Description
Public method | MongoDBConnectorProtocolException | Initializes a new instance of the MongoDBConnectorProtocolException class
Public method | MongoDBConnectorProtocolException(String) | Initializes a new instance of the MongoDBConnectorProtocolException class
Protected method | MongoDBConnectorProtocolException(SerializationInfo, StreamingContext) | Initializes a new instance of the MongoDBConnectorProtocolException class
Public method | MongoDBConnectorProtocolException(String, Exception) | Initializes a new instance of the MongoDBConnectorProtocolException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
MongoDBConnectorProtocolException Class
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorProtocolException Constructor

MongoDBConnectorProtocolException Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public method | MongoDBConnectorProtocolException | Initializes a new instance of the MongoDBConnectorProtocolException class
Public method | MongoDBConnectorProtocolException(String) | Initializes a new instance of the MongoDBConnectorProtocolException class
Protected method | MongoDBConnectorProtocolException(SerializationInfo, StreamingContext) | Initializes a new instance of the MongoDBConnectorProtocolException class
Public method | MongoDBConnectorProtocolException(String, Exception) | Initializes a new instance of the MongoDBConnectorProtocolException class
Back to Top
See Also
MongoDBConnectorProtocolException Class
MongoDBConnectorProtocolException Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorProtocolException Constructor

MongoDBConnectorProtocolException Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MongoDBConnectorProtocolException class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBConnectorProtocolException()
public MongoDBConnectorProtocolException()
Public Sub New
Public Sub New
public:
MongoDBConnectorProtocolException()
public:
MongoDBConnectorProtocolException()
new : unit -> MongoDBConnectorProtocolException
new : unit -> MongoDBConnectorProtocolException
See Also
MongoDBConnectorProtocolException Class
MongoDBConnectorProtocolException Members
MongoDBConnectorProtocolException Overload
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorProtocolException Constructor (String)

MongoDBConnectorProtocolException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MongoDBConnectorProtocolException class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBConnectorProtocolException(
    string message
)
public MongoDBConnectorProtocolException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
MongoDBConnectorProtocolException(
    String^ message
)
public:
MongoDBConnectorProtocolException(
    String^ message
)
new :
        message : string -> MongoDBConnectorProtocolException
new :
        message : string -> MongoDBConnectorProtocolException

Parameters

message
Type: Online System String
See Also
MongoDBConnectorProtocolException Class
MongoDBConnectorProtocolException Members
MongoDBConnectorProtocolException Overload
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorProtocolException Constructor (SerializationInfo, StreamingContext)

MongoDBConnectorProtocolException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MongoDBConnectorProtocolException class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MongoDBConnectorProtocolException(
    SerializationInfo info,
    StreamingContext context
)
protected MongoDBConnectorProtocolException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
MongoDBConnectorProtocolException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
MongoDBConnectorProtocolException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> MongoDBConnectorProtocolException
new :
        info : SerializationInfo *
        context : StreamingContext -> MongoDBConnectorProtocolException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
MongoDBConnectorProtocolException Class
MongoDBConnectorProtocolException Members
MongoDBConnectorProtocolException Overload
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorProtocolException Constructor (String, Exception)

MongoDBConnectorProtocolException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MongoDBConnectorProtocolException class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBConnectorProtocolException(
    string message,
    Exception inner
)
public MongoDBConnectorProtocolException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
MongoDBConnectorProtocolException(
    String^ message,
    Exception^ inner
)
public:
MongoDBConnectorProtocolException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> MongoDBConnectorProtocolException
new :
        message : string *
        inner : Exception -> MongoDBConnectorProtocolException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
MongoDBConnectorProtocolException Class
MongoDBConnectorProtocolException Members
MongoDBConnectorProtocolException Overload
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorProtocolException Fields

MongoDBConnectorProtocolException Fields NFX Class Library

The MongoDBConnectorProtocolException type exposes the following members.
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
See Also
MongoDBConnectorProtocolException Class
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorProtocolException Methods

MongoDBConnectorProtocolException Methods NFX Class Library

The MongoDBConnectorProtocolException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
MongoDBConnectorProtocolException Class
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorProtocolException Properties

MongoDBConnectorProtocolException Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The MongoDBConnectorProtocolException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
MongoDBConnectorProtocolException Class
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorProtocolException Events

MongoDBConnectorProtocolException Events NFX Class Library

The MongoDBConnectorProtocolException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
MongoDBConnectorProtocolException Class
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorServerException Class

MongoDBConnectorServerException Class NFX Class Library

Thrown by MongoDB data access classes related to server errors
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.DataAccess DataAccessException
NFX.DataAccess.MongoDB MongoDBDataAccessException
NFX.DataAccess.MongoDB.Connector MongoDBConnectorException
NFX.DataAccess.MongoDB.Connector MongoDBConnectorServerException

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MongoDBConnectorServerException : MongoDBConnectorException
[SerializableAttribute]
public class MongoDBConnectorServerException : MongoDBConnectorException
<SerializableAttribute>
Public Class MongoDBConnectorServerException
    Inherits MongoDBConnectorException
<SerializableAttribute>
Public Class MongoDBConnectorServerException
    Inherits MongoDBConnectorException
[SerializableAttribute]
public ref class MongoDBConnectorServerException : public MongoDBConnectorException
[SerializableAttribute]
public ref class MongoDBConnectorServerException : public MongoDBConnectorException
[<SerializableAttribute>]
type MongoDBConnectorServerException =
    class
        inherit MongoDBConnectorException
    end
[<SerializableAttribute>]
type MongoDBConnectorServerException =
    class
        inherit MongoDBConnectorException
    end
See Also
MongoDBConnectorServerException Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorServerException Members

MongoDBConnectorServerException Members NFX Class Library

The MongoDBConnectorServerException type exposes the following members.
Constructors
 | Name | Description
Public method | MongoDBConnectorServerException | Initializes a new instance of the MongoDBConnectorServerException class
Public method | MongoDBConnectorServerException(String) | Initializes a new instance of the MongoDBConnectorServerException class
Protected method | MongoDBConnectorServerException(SerializationInfo, StreamingContext) | Initializes a new instance of the MongoDBConnectorServerException class
Public method | MongoDBConnectorServerException(String, Exception) | Initializes a new instance of the MongoDBConnectorServerException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
MongoDBConnectorServerException Class
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorServerException Constructor

MongoDBConnectorServerException Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public method | MongoDBConnectorServerException | Initializes a new instance of the MongoDBConnectorServerException class
Public method | MongoDBConnectorServerException(String) | Initializes a new instance of the MongoDBConnectorServerException class
Protected method | MongoDBConnectorServerException(SerializationInfo, StreamingContext) | Initializes a new instance of the MongoDBConnectorServerException class
Public method | MongoDBConnectorServerException(String, Exception) | Initializes a new instance of the MongoDBConnectorServerException class
Back to Top
See Also
MongoDBConnectorServerException Class
MongoDBConnectorServerException Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorServerException Constructor

MongoDBConnectorServerException Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MongoDBConnectorServerException class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBConnectorServerException()
public MongoDBConnectorServerException()
Public Sub New
Public Sub New
public:
MongoDBConnectorServerException()
public:
MongoDBConnectorServerException()
new : unit -> MongoDBConnectorServerException
new : unit -> MongoDBConnectorServerException
See Also
MongoDBConnectorServerException Class
MongoDBConnectorServerException Members
MongoDBConnectorServerException Overload
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorServerException Constructor (String)

MongoDBConnectorServerException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MongoDBConnectorServerException class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBConnectorServerException(
    string message
)
public MongoDBConnectorServerException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
MongoDBConnectorServerException(
    String^ message
)
public:
MongoDBConnectorServerException(
    String^ message
)
new :
        message : string -> MongoDBConnectorServerException
new :
        message : string -> MongoDBConnectorServerException

Parameters

message
Type: Online System String
See Also
MongoDBConnectorServerException Class
MongoDBConnectorServerException Members
MongoDBConnectorServerException Overload
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorServerException Constructor (SerializationInfo, StreamingContext)

MongoDBConnectorServerException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MongoDBConnectorServerException class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MongoDBConnectorServerException(
    SerializationInfo info,
    StreamingContext context
)
protected MongoDBConnectorServerException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
MongoDBConnectorServerException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
MongoDBConnectorServerException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> MongoDBConnectorServerException
new :
        info : SerializationInfo *
        context : StreamingContext -> MongoDBConnectorServerException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
MongoDBConnectorServerException Class
MongoDBConnectorServerException Members
MongoDBConnectorServerException Overload
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorServerException Constructor (String, Exception)

MongoDBConnectorServerException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MongoDBConnectorServerException class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBConnectorServerException(
    string message,
    Exception inner
)
public MongoDBConnectorServerException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
MongoDBConnectorServerException(
    String^ message,
    Exception^ inner
)
public:
MongoDBConnectorServerException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> MongoDBConnectorServerException
new :
        message : string *
        inner : Exception -> MongoDBConnectorServerException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
MongoDBConnectorServerException Class
MongoDBConnectorServerException Members
MongoDBConnectorServerException Overload
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorServerException Fields

MongoDBConnectorServerException Fields NFX Class Library

The MongoDBConnectorServerException type exposes the following members.
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
See Also
MongoDBConnectorServerException Class
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorServerException Methods

MongoDBConnectorServerException Methods NFX Class Library

The MongoDBConnectorServerException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
MongoDBConnectorServerException Class
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorServerException Properties

MongoDBConnectorServerException Properties NFX Class Library

The MongoDBConnectorServerException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
MongoDBConnectorServerException Class
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBConnectorServerException Events

MongoDBConnectorServerException Events NFX Class Library

The MongoDBConnectorServerException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
MongoDBConnectorServerException Class
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBQueryException Class

MongoDBQueryException Class NFX Class Library

Thrown in case of query compile error
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.DataAccess DataAccessException
NFX.DataAccess.MongoDB MongoDBDataAccessException
NFX.DataAccess.MongoDB.Connector MongoDBConnectorException
NFX.DataAccess.MongoDB.Connector MongoDBQueryException

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MongoDBQueryException : MongoDBConnectorException
[SerializableAttribute]
public class MongoDBQueryException : MongoDBConnectorException
<SerializableAttribute>
Public Class MongoDBQueryException
    Inherits MongoDBConnectorException
<SerializableAttribute>
Public Class MongoDBQueryException
    Inherits MongoDBConnectorException
[SerializableAttribute]
public ref class MongoDBQueryException : public MongoDBConnectorException
[SerializableAttribute]
public ref class MongoDBQueryException : public MongoDBConnectorException
[<SerializableAttribute>]
type MongoDBQueryException =
    class
        inherit MongoDBConnectorException
    end
[<SerializableAttribute>]
type MongoDBQueryException =
    class
        inherit MongoDBConnectorException
    end
See Also
MongoDBQueryException Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBQueryException Members

MongoDBQueryException Members NFX Class Library

The MongoDBQueryException type exposes the following members.
Constructors
 | Name | Description
Public method | MongoDBQueryException | Initializes a new instance of the MongoDBQueryException class
Public method | MongoDBQueryException(String) | Initializes a new instance of the MongoDBQueryException class
Protected method | MongoDBQueryException(SerializationInfo, StreamingContext) | Initializes a new instance of the MongoDBQueryException class
Public method | MongoDBQueryException(String, Exception) | Initializes a new instance of the MongoDBQueryException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
MongoDBQueryException Class
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBQueryException Constructor

MongoDBQueryException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | MongoDBQueryException | Initializes a new instance of the MongoDBQueryException class
Public method | MongoDBQueryException(String) | Initializes a new instance of the MongoDBQueryException class
Protected method | MongoDBQueryException(SerializationInfo, StreamingContext) | Initializes a new instance of the MongoDBQueryException class
Public method | MongoDBQueryException(String, Exception) | Initializes a new instance of the MongoDBQueryException class
Back to Top
See Also
MongoDBQueryException Class
MongoDBQueryException Members
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBQueryException Constructor

MongoDBQueryException Constructor NFX Class Library

Initializes a new instance of the MongoDBQueryException class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBQueryException()
public MongoDBQueryException()
Public Sub New
Public Sub New
public:
MongoDBQueryException()
public:
MongoDBQueryException()
new : unit -> MongoDBQueryException
new : unit -> MongoDBQueryException
See Also
MongoDBQueryException Class
MongoDBQueryException Members
MongoDBQueryException Overload
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBQueryException Constructor (String)

MongoDBQueryException Constructor (String) NFX Class Library

Initializes a new instance of the MongoDBQueryException class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBQueryException(
    string message
)
public MongoDBQueryException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
MongoDBQueryException(
    String^ message
)
public:
MongoDBQueryException(
    String^ message
)
new :
        message : string -> MongoDBQueryException
new :
        message : string -> MongoDBQueryException

Parameters

message
Type: Online System String
See Also
MongoDBQueryException Class
MongoDBQueryException Members
MongoDBQueryException Overload
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBQueryException Constructor (SerializationInfo, StreamingContext)

MongoDBQueryException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MongoDBQueryException class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MongoDBQueryException(
    SerializationInfo info,
    StreamingContext context
)
protected MongoDBQueryException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
MongoDBQueryException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
MongoDBQueryException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> MongoDBQueryException
new :
        info : SerializationInfo *
        context : StreamingContext -> MongoDBQueryException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
MongoDBQueryException Class
MongoDBQueryException Members
MongoDBQueryException Overload
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBQueryException Constructor (String, Exception)

MongoDBQueryException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MongoDBQueryException class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBQueryException(
    string message,
    Exception inner
)
public MongoDBQueryException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
MongoDBQueryException(
    String^ message,
    Exception^ inner
)
public:
MongoDBQueryException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> MongoDBQueryException
new :
        message : string *
        inner : Exception -> MongoDBQueryException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
MongoDBQueryException Class
MongoDBQueryException Members
MongoDBQueryException Overload
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBQueryException Fields

MongoDBQueryException Fields NFX Class Library

The MongoDBQueryException type exposes the following members.
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
See Also
MongoDBQueryException Class
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBQueryException Methods

MongoDBQueryException Methods NFX Class Library

The MongoDBQueryException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
MongoDBQueryException Class
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBQueryException Properties

MongoDBQueryException Properties NFX Class Library

The MongoDBQueryException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
MongoDBQueryException Class
NFX.DataAccess.MongoDB.Connector Namespace


MongoDBQueryException Events

MongoDBQueryException Events NFX Class Library

The MongoDBQueryException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
MongoDBQueryException Class
NFX.DataAccess.MongoDB.Connector Namespace


Protocol Class

Protocol Class NFX Class Library

This class uses static methods on purpose to avoid allocations
Inheritance Hierarchy
Online System Object
NFX.DataAccess.MongoDB.Connector Protocol

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static class Protocol
internal static class Protocol
Friend NotInheritable Class Protocol
Friend NotInheritable Class Protocol
internal ref class Protocol abstract sealed
internal ref class Protocol abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Protocol =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Protocol =  class end
See Also
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol Members

Protocol Members NFX Class Library

The Protocol type exposes the following members.
Methods
Name | Description
CheckReplyDataForErrors |
IsOKReplyDoc |
Read_CRUD_Response |
Read_REPLY | Reads OP_REPLY but does not interpret it
Write_COUNT |
Write_DELETE |
Write_DROP |
Write_GET_MORE |
Write_INSERT |
Write_KILL_CURSORS(Stream, Int32, Cursor ) |
Write_KILL_CURSORS(Stream, Int32, Int64 ) |
Write_LIST_COLLECTIONS |
Write_PING |
Write_QUERY |
Write_RUN_COMMAND |
Write_UPDATE |
Back to Top
Fields
Name | Description
_ID |
BSON_SIZE_LIMIT |
COMMAND_COLLECTION |
MAX_DOC_COUNT_LIMIT |
OP_DELETE |
OP_GET_MORE |
OP_INSERT |
OP_KILL_CURSORS |
OP_MSG |
OP_QUERY |
OP_REPLY |
OP_UPDATE |
RESERVED |
SET |
STD_HDR_LEN |
Back to Top
See Also
Protocol Class
NFX.DataAccess.MongoDB.Connector Namespace


Protocol Fields

Protocol Fields NFX Class Library

The Protocol type exposes the following members.
Fields
Name | Description
_ID |
BSON_SIZE_LIMIT |
COMMAND_COLLECTION |
MAX_DOC_COUNT_LIMIT |
OP_DELETE |
OP_GET_MORE |
OP_INSERT |
OP_KILL_CURSORS |
OP_MSG |
OP_QUERY |
OP_REPLY |
OP_UPDATE |
RESERVED |
SET |
STD_HDR_LEN |
Back to Top
See Also
Protocol Class
NFX.DataAccess.MongoDB.Connector Namespace


Protocol._ID Field

Protocol _ID Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string _ID
public const string _ID
Public Const _ID As String
Public Const _ID As String
public:
literal String^ _ID
public:
literal String^ _ID
static val mutable _ID: string
static val mutable _ID: string

Field Value

Type: Online String
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.BSON_SIZE_LIMIT Field

Protocol BSON_SIZE_LIMIT Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int BSON_SIZE_LIMIT
public const int BSON_SIZE_LIMIT
Public Const BSON_SIZE_LIMIT As Integer
Public Const BSON_SIZE_LIMIT As Integer
public:
literal int BSON_SIZE_LIMIT
public:
literal int BSON_SIZE_LIMIT
static val mutable BSON_SIZE_LIMIT: int
static val mutable BSON_SIZE_LIMIT: int

Field Value

Type: Online Int32
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.COMMAND_COLLECTION Field

Protocol COMMAND_COLLECTION Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string COMMAND_COLLECTION
public const string COMMAND_COLLECTION
Public Const COMMAND_COLLECTION As String
Public Const COMMAND_COLLECTION As String
public:
literal String^ COMMAND_COLLECTION
public:
literal String^ COMMAND_COLLECTION
static val mutable COMMAND_COLLECTION: string
static val mutable COMMAND_COLLECTION: string

Field Value

Type: Online String
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.MAX_DOC_COUNT_LIMIT Field

Protocol MAX_DOC_COUNT_LIMIT Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_DOC_COUNT_LIMIT
public const int MAX_DOC_COUNT_LIMIT
Public Const MAX_DOC_COUNT_LIMIT As Integer
Public Const MAX_DOC_COUNT_LIMIT As Integer
public:
literal int MAX_DOC_COUNT_LIMIT
public:
literal int MAX_DOC_COUNT_LIMIT
static val mutable MAX_DOC_COUNT_LIMIT: int
static val mutable MAX_DOC_COUNT_LIMIT: int

Field Value

Type: Online Int32
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.OP_DELETE Field

Protocol OP_DELETE Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int OP_DELETE
public const int OP_DELETE
Public Const OP_DELETE As Integer
Public Const OP_DELETE As Integer
public:
literal int OP_DELETE
public:
literal int OP_DELETE
static val mutable OP_DELETE: int
static val mutable OP_DELETE: int

Field Value

Type: Online Int32
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.OP_GET_MORE Field

Protocol OP_GET_MORE Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int OP_GET_MORE
public const int OP_GET_MORE
Public Const OP_GET_MORE As Integer
Public Const OP_GET_MORE As Integer
public:
literal int OP_GET_MORE
public:
literal int OP_GET_MORE
static val mutable OP_GET_MORE: int
static val mutable OP_GET_MORE: int

Field Value

Type: Online Int32
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.OP_INSERT Field

Protocol OP_INSERT Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int OP_INSERT
public const int OP_INSERT
Public Const OP_INSERT As Integer
Public Const OP_INSERT As Integer
public:
literal int OP_INSERT
public:
literal int OP_INSERT
static val mutable OP_INSERT: int
static val mutable OP_INSERT: int

Field Value

Type: Online Int32
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.OP_KILL_CURSORS Field

Protocol OP_KILL_CURSORS Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int OP_KILL_CURSORS
public const int OP_KILL_CURSORS
Public Const OP_KILL_CURSORS As Integer
Public Const OP_KILL_CURSORS As Integer
public:
literal int OP_KILL_CURSORS
public:
literal int OP_KILL_CURSORS
static val mutable OP_KILL_CURSORS: int
static val mutable OP_KILL_CURSORS: int

Field Value

Type: Online Int32
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.OP_MSG Field

Protocol OP_MSG Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int OP_MSG
public const int OP_MSG
Public Const OP_MSG As Integer
Public Const OP_MSG As Integer
public:
literal int OP_MSG
public:
literal int OP_MSG
static val mutable OP_MSG: int
static val mutable OP_MSG: int

Field Value

Type: Online Int32
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.OP_QUERY Field

Protocol OP_QUERY Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int OP_QUERY
public const int OP_QUERY
Public Const OP_QUERY As Integer
Public Const OP_QUERY As Integer
public:
literal int OP_QUERY
public:
literal int OP_QUERY
static val mutable OP_QUERY: int
static val mutable OP_QUERY: int

Field Value

Type: Online Int32
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.OP_REPLY Field

Protocol OP_REPLY Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int OP_REPLY
public const int OP_REPLY
Public Const OP_REPLY As Integer
Public Const OP_REPLY As Integer
public:
literal int OP_REPLY
public:
literal int OP_REPLY
static val mutable OP_REPLY: int
static val mutable OP_REPLY: int

Field Value

Type: Online Int32
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.OP_UPDATE Field

Protocol OP_UPDATE Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int OP_UPDATE
public const int OP_UPDATE
Public Const OP_UPDATE As Integer
Public Const OP_UPDATE As Integer
public:
literal int OP_UPDATE
public:
literal int OP_UPDATE
static val mutable OP_UPDATE: int
static val mutable OP_UPDATE: int

Field Value

Type: Online Int32
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.RESERVED Field

Protocol RESERVED Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int RESERVED
public const int RESERVED
Public Const RESERVED As Integer
Public Const RESERVED As Integer
public:
literal int RESERVED
public:
literal int RESERVED
static val mutable RESERVED: int
static val mutable RESERVED: int

Field Value

Type: Online Int32
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.SET Field

Protocol SET Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SET
public const string SET
Public Const SET As String
Public Const SET As String
public:
literal String^ SET
public:
literal String^ SET
static val mutable SET: string
static val mutable SET: string

Field Value

Type: Online String
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.STD_HDR_LEN Field

Protocol STD_HDR_LEN Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int STD_HDR_LEN
public const int STD_HDR_LEN
Public Const STD_HDR_LEN As Integer
Public Const STD_HDR_LEN As Integer
public:
literal int STD_HDR_LEN
public:
literal int STD_HDR_LEN
static val mutable STD_HDR_LEN: int
static val mutable STD_HDR_LEN: int

Field Value

Type: Online Int32
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol Methods

Protocol Methods NFX Class Library

The Protocol type exposes the following members.
Methods
Name | Description
CheckReplyDataForErrors |
IsOKReplyDoc |
Read_CRUD_Response |
Read_REPLY | Reads OP_REPLY but does not interpret it
Write_COUNT |
Write_DELETE |
Write_DROP |
Write_GET_MORE |
Write_INSERT |
Write_KILL_CURSORS(Stream, Int32, Cursor ) |
Write_KILL_CURSORS(Stream, Int32, Int64 ) |
Write_LIST_COLLECTIONS |
Write_PING |
Write_QUERY |
Write_RUN_COMMAND |
Write_UPDATE |
Back to Top
See Also
Protocol Class
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.CheckReplyDataForErrors Method

Protocol CheckReplyDataForErrors Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void CheckReplyDataForErrors(
    Protocol..::..ReplyData reply
)
public static void CheckReplyDataForErrors(
    Protocol..::..ReplyData reply
)
Public Shared Sub CheckReplyDataForErrors (
    reply As Protocol..::..ReplyData
)
Public Shared Sub CheckReplyDataForErrors (
    reply As Protocol..::..ReplyData
)
public:
static void CheckReplyDataForErrors(
    Protocol..::..ReplyData reply
)
public:
static void CheckReplyDataForErrors(
    Protocol..::..ReplyData reply
)
static member CheckReplyDataForErrors :
        reply : Protocol..::..ReplyData -> unit
static member CheckReplyDataForErrors :
        reply : Protocol..::..ReplyData -> unit

Parameters

reply
Type: NFX.DataAccess.MongoDB.Connector Protocol ReplyData
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.IsOKReplyDoc Method

Protocol IsOKReplyDoc Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsOKReplyDoc(
    Protocol..::..ReplyData reply
)
public static bool IsOKReplyDoc(
    Protocol..::..ReplyData reply
)
Public Shared Function IsOKReplyDoc (
    reply As Protocol..::..ReplyData
) As Boolean
Public Shared Function IsOKReplyDoc (
    reply As Protocol..::..ReplyData
) As Boolean
public:
static bool IsOKReplyDoc(
    Protocol..::..ReplyData reply
)
public:
static bool IsOKReplyDoc(
    Protocol..::..ReplyData reply
)
static member IsOKReplyDoc :
        reply : Protocol..::..ReplyData -> bool
static member IsOKReplyDoc :
        reply : Protocol..::..ReplyData -> bool

Parameters

reply
Type: NFX.DataAccess.MongoDB.Connector Protocol ReplyData

Return Value

Type: Online Boolean
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.Read_CRUD_Response Method

Protocol Read_CRUD_Response Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static CRUDResult Read_CRUD_Response(
    string operation,
    Stream stream
)
public static CRUDResult Read_CRUD_Response(
    string operation,
    Stream stream
)
Public Shared Function Read_CRUD_Response (
    operation As String,
    stream As Stream
) As CRUDResult
Public Shared Function Read_CRUD_Response (
    operation As String,
    stream As Stream
) As CRUDResult
public:
static CRUDResult Read_CRUD_Response(
    String^ operation,
    Stream^ stream
)
public:
static CRUDResult Read_CRUD_Response(
    String^ operation,
    Stream^ stream
)
static member Read_CRUD_Response :
        operation : string *
        stream : Stream -> CRUDResult
static member Read_CRUD_Response :
        operation : string *
        stream : Stream -> CRUDResult

Parameters

operation
Type: Online System String
stream
Type: Online System.IO Stream

Return Value

Type: CRUDResult
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.Read_REPLY Method

Protocol Read_REPLY Method NFX Class Library

Reads OP_REPLY but does not interpret it

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Protocol..::..ReplyData Read_REPLY(
    Stream stream
)
public static Protocol..::..ReplyData Read_REPLY(
    Stream stream
)
Public Shared Function Read_REPLY (
    stream As Stream
) As Protocol..::..ReplyData
Public Shared Function Read_REPLY (
    stream As Stream
) As Protocol..::..ReplyData
public:
static Protocol..::..ReplyData Read_REPLY(
    Stream^ stream
)
public:
static Protocol..::..ReplyData Read_REPLY(
    Stream^ stream
)
static member Read_REPLY :
        stream : Stream -> Protocol..::..ReplyData
static member Read_REPLY :
        stream : Stream -> Protocol..::..ReplyData

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Protocol ReplyData
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.Write_COUNT Method

Protocol Write_COUNT Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Write_COUNT(
    Stream stream,
    int requestID,
    Collection collection,
    Query query,
    int limit,
    int skip,
    Object hint
)
public static int Write_COUNT(
    Stream stream,
    int requestID,
    Collection collection,
    Query query,
    int limit,
    int skip,
    Object hint
)
Public Shared Function Write_COUNT (
    stream As Stream,
    requestID As Integer,
    collection As Collection,
    query As Query,
    limit As Integer,
    skip As Integer,
    hint As Object
) As Integer
Public Shared Function Write_COUNT (
    stream As Stream,
    requestID As Integer,
    collection As Collection,
    query As Query,
    limit As Integer,
    skip As Integer,
    hint As Object
) As Integer
public:
static int Write_COUNT(
    Stream^ stream,
    int requestID,
    Collection^ collection,
    Query^ query,
    int limit,
    int skip,
    Object^ hint
)
public:
static int Write_COUNT(
    Stream^ stream,
    int requestID,
    Collection^ collection,
    Query^ query,
    int limit,
    int skip,
    Object^ hint
)
static member Write_COUNT :
        stream : Stream *
        requestID : int *
        collection : Collection *
        query : Query *
        limit : int *
        skip : int *
        hint : Object -> int
static member Write_COUNT :
        stream : Stream *
        requestID : int *
        collection : Collection *
        query : Query *
        limit : int *
        skip : int *
        hint : Object -> int

Parameters

stream
Type: Online System.IO Stream
requestID
Type: Online System Int32
collection
Type: NFX.DataAccess.MongoDB.Connector Collection
query
Type: NFX.DataAccess.MongoDB.Connector Query
limit
Type: Online System Int32
skip
Type: Online System Int32
hint
Type: Online System Object

Return Value

Type: Online Int32
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.Write_DELETE Method

Protocol Write_DELETE Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Write_DELETE(
    Stream stream,
    int requestID,
    Collection collection,
    DeleteEntry[] deletes
)
public static int Write_DELETE(
    Stream stream,
    int requestID,
    Collection collection,
    DeleteEntry[] deletes
)
Public Shared Function Write_DELETE (
    stream As Stream,
    requestID As Integer,
    collection As Collection,
    deletes As DeleteEntry()
) As Integer
Public Shared Function Write_DELETE (
    stream As Stream,
    requestID As Integer,
    collection As Collection,
    deletes As DeleteEntry()
) As Integer
public:
static int Write_DELETE(
    Stream^ stream,
    int requestID,
    Collection^ collection,
    array<DeleteEntry>^ deletes
)
public:
static int Write_DELETE(
    Stream^ stream,
    int requestID,
    Collection^ collection,
    array<DeleteEntry>^ deletes
)
static member Write_DELETE :
        stream : Stream *
        requestID : int *
        collection : Collection *
        deletes : DeleteEntry[] -> int
static member Write_DELETE :
        stream : Stream *
        requestID : int *
        collection : Collection *
        deletes : DeleteEntry[] -> int

Parameters

stream
Type: Online System.IO Stream
requestID
Type: Online System Int32
collection
Type: NFX.DataAccess.MongoDB.Connector Collection
deletes
Type: NFX.DataAccess.MongoDB.Connector DeleteEntry

Return Value

Type: Online Int32
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.Write_DROP Method

Protocol Write_DROP Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Write_DROP(
    Stream stream,
    int requestID,
    Collection collection
)
public static int Write_DROP(
    Stream stream,
    int requestID,
    Collection collection
)
Public Shared Function Write_DROP (
    stream As Stream,
    requestID As Integer,
    collection As Collection
) As Integer
Public Shared Function Write_DROP (
    stream As Stream,
    requestID As Integer,
    collection As Collection
) As Integer
public:
static int Write_DROP(
    Stream^ stream,
    int requestID,
    Collection^ collection
)
public:
static int Write_DROP(
    Stream^ stream,
    int requestID,
    Collection^ collection
)
static member Write_DROP :
        stream : Stream *
        requestID : int *
        collection : Collection -> int
static member Write_DROP :
        stream : Stream *
        requestID : int *
        collection : Collection -> int

Parameters

stream
Type: Online System.IO Stream
requestID
Type: Online System Int32
collection
Type: NFX.DataAccess.MongoDB.Connector Collection

Return Value

Type: Online Int32
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.Write_GET_MORE Method

Protocol Write_GET_MORE Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Write_GET_MORE(
    Stream stream,
    int requestID,
    Collection collection,
    Cursor cursor
)
public static int Write_GET_MORE(
    Stream stream,
    int requestID,
    Collection collection,
    Cursor cursor
)
Public Shared Function Write_GET_MORE (
    stream As Stream,
    requestID As Integer,
    collection As Collection,
    cursor As Cursor
) As Integer
Public Shared Function Write_GET_MORE (
    stream As Stream,
    requestID As Integer,
    collection As Collection,
    cursor As Cursor
) As Integer
public:
static int Write_GET_MORE(
    Stream^ stream,
    int requestID,
    Collection^ collection,
    Cursor^ cursor
)
public:
static int Write_GET_MORE(
    Stream^ stream,
    int requestID,
    Collection^ collection,
    Cursor^ cursor
)
static member Write_GET_MORE :
        stream : Stream *
        requestID : int *
        collection : Collection *
        cursor : Cursor -> int
static member Write_GET_MORE :
        stream : Stream *
        requestID : int *
        collection : Collection *
        cursor : Cursor -> int

Parameters

stream
Type: Online System.IO Stream
requestID
Type: Online System Int32
collection
Type: NFX.DataAccess.MongoDB.Connector Collection
cursor
Type: NFX.DataAccess.MongoDB.Connector Cursor

Return Value

Type: Online Int32
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.Write_INSERT Method

Protocol Write_INSERT Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Write_INSERT(
    Stream stream,
    int requestID,
    Collection collection,
    BSONDocument[] data
)
public static int Write_INSERT(
    Stream stream,
    int requestID,
    Collection collection,
    BSONDocument[] data
)
Public Shared Function Write_INSERT (
    stream As Stream,
    requestID As Integer,
    collection As Collection,
    data As BSONDocument()
) As Integer
Public Shared Function Write_INSERT (
    stream As Stream,
    requestID As Integer,
    collection As Collection,
    data As BSONDocument()
) As Integer
public:
static int Write_INSERT(
    Stream^ stream,
    int requestID,
    Collection^ collection,
    array<BSONDocument^>^ data
)
public:
static int Write_INSERT(
    Stream^ stream,
    int requestID,
    Collection^ collection,
    array<BSONDocument^>^ data
)
static member Write_INSERT :
        stream : Stream *
        requestID : int *
        collection : Collection *
        data : BSONDocument[] -> int
static member Write_INSERT :
        stream : Stream *
        requestID : int *
        collection : Collection *
        data : BSONDocument[] -> int

Parameters

stream
Type: Online System.IO Stream
requestID
Type: Online System Int32
collection
Type: NFX.DataAccess.MongoDB.Connector Collection
data
Type: NFX.Serialization.BSON BSONDocument

Return Value

Type: Online Int32
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.Write_KILL_CURSORS Method

Protocol Write_KILL_CURSORS Method NFX Class Library

Overload List
Name | Description
Write_KILL_CURSORS(Stream, Int32, Cursor ) |
Write_KILL_CURSORS(Stream, Int32, Int64 ) |
Back to Top
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.Write_KILL_CURSORS Method (Stream, Int32, Cursor[])

Protocol Write_KILL_CURSORS Method (Stream, Int32, Cursor ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Write_KILL_CURSORS(
    Stream stream,
    int requestID,
    Cursor[] cursors
)
public static int Write_KILL_CURSORS(
    Stream stream,
    int requestID,
    Cursor[] cursors
)
Public Shared Function Write_KILL_CURSORS (
    stream As Stream,
    requestID As Integer,
    cursors As Cursor()
) As Integer
Public Shared Function Write_KILL_CURSORS (
    stream As Stream,
    requestID As Integer,
    cursors As Cursor()
) As Integer
public:
static int Write_KILL_CURSORS(
    Stream^ stream,
    int requestID,
    array<Cursor^>^ cursors
)
public:
static int Write_KILL_CURSORS(
    Stream^ stream,
    int requestID,
    array<Cursor^>^ cursors
)
static member Write_KILL_CURSORS :
        stream : Stream *
        requestID : int *
        cursors : Cursor[] -> int
static member Write_KILL_CURSORS :
        stream : Stream *
        requestID : int *
        cursors : Cursor[] -> int

Parameters

stream
Type: Online System.IO Stream
requestID
Type: Online System Int32
cursors
Type: NFX.DataAccess.MongoDB.Connector Cursor

Return Value

Type: Online Int32
See Also
Protocol Class
Protocol Members
Write_KILL_CURSORS Overload
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.Write_KILL_CURSORS Method (Stream, Int32, Int64[])

Protocol Write_KILL_CURSORS Method (Stream, Int32, Int64 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Write_KILL_CURSORS(
    Stream stream,
    int requestID,
    long[] cursorIDs
)
public static int Write_KILL_CURSORS(
    Stream stream,
    int requestID,
    long[] cursorIDs
)
Public Shared Function Write_KILL_CURSORS (
    stream As Stream,
    requestID As Integer,
    cursorIDs As Long()
) As Integer
Public Shared Function Write_KILL_CURSORS (
    stream As Stream,
    requestID As Integer,
    cursorIDs As Long()
) As Integer
public:
static int Write_KILL_CURSORS(
    Stream^ stream,
    int requestID,
    array<long long>^ cursorIDs
)
public:
static int Write_KILL_CURSORS(
    Stream^ stream,
    int requestID,
    array<long long>^ cursorIDs
)
static member Write_KILL_CURSORS :
        stream : Stream *
        requestID : int *
        cursorIDs : int64[] -> int
static member Write_KILL_CURSORS :
        stream : Stream *
        requestID : int *
        cursorIDs : int64[] -> int

Parameters

stream
Type: Online System.IO Stream
requestID
Type: Online System Int32
cursorIDs
Type: Online System Int64

Return Value

Type: Online Int32
See Also
Protocol Class
Protocol Members
Write_KILL_CURSORS Overload
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.Write_LIST_COLLECTIONS Method

Protocol Write_LIST_COLLECTIONS Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Write_LIST_COLLECTIONS(
    Stream stream,
    int requestID,
    Database db
)
public static int Write_LIST_COLLECTIONS(
    Stream stream,
    int requestID,
    Database db
)
Public Shared Function Write_LIST_COLLECTIONS (
    stream As Stream,
    requestID As Integer,
    db As Database
) As Integer
Public Shared Function Write_LIST_COLLECTIONS (
    stream As Stream,
    requestID As Integer,
    db As Database
) As Integer
public:
static int Write_LIST_COLLECTIONS(
    Stream^ stream,
    int requestID,
    Database^ db
)
public:
static int Write_LIST_COLLECTIONS(
    Stream^ stream,
    int requestID,
    Database^ db
)
static member Write_LIST_COLLECTIONS :
        stream : Stream *
        requestID : int *
        db : Database -> int
static member Write_LIST_COLLECTIONS :
        stream : Stream *
        requestID : int *
        db : Database -> int

Parameters

stream
Type: Online System.IO Stream
requestID
Type: Online System Int32
db
Type: NFX.DataAccess.MongoDB.Connector Database

Return Value

Type: Online Int32
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.Write_PING Method

Protocol Write_PING Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Write_PING(
    Stream stream,
    int requestID,
    Database db
)
public static int Write_PING(
    Stream stream,
    int requestID,
    Database db
)
Public Shared Function Write_PING (
    stream As Stream,
    requestID As Integer,
    db As Database
) As Integer
Public Shared Function Write_PING (
    stream As Stream,
    requestID As Integer,
    db As Database
) As Integer
public:
static int Write_PING(
    Stream^ stream,
    int requestID,
    Database^ db
)
public:
static int Write_PING(
    Stream^ stream,
    int requestID,
    Database^ db
)
static member Write_PING :
        stream : Stream *
        requestID : int *
        db : Database -> int
static member Write_PING :
        stream : Stream *
        requestID : int *
        db : Database -> int

Parameters

stream
Type: Online System.IO Stream
requestID
Type: Online System Int32
db
Type: NFX.DataAccess.MongoDB.Connector Database

Return Value

Type: Online Int32
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.Write_QUERY Method

Protocol Write_QUERY Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Write_QUERY(
    Stream stream,
    int requestID,
    Database db,
    Collection collection,
    Protocol..::..QueryFlags flags,
    int numberToSkip,
    int numberToReturn,
    BSONDocument query,
    BSONDocument selector
)
public static int Write_QUERY(
    Stream stream,
    int requestID,
    Database db,
    Collection collection,
    Protocol..::..QueryFlags flags,
    int numberToSkip,
    int numberToReturn,
    BSONDocument query,
    BSONDocument selector
)
Public Shared Function Write_QUERY (
    stream As Stream,
    requestID As Integer,
    db As Database,
    collection As Collection,
    flags As Protocol..::..QueryFlags,
    numberToSkip As Integer,
    numberToReturn As Integer,
    query As BSONDocument,
    selector As BSONDocument
) As Integer
Public Shared Function Write_QUERY (
    stream As Stream,
    requestID As Integer,
    db As Database,
    collection As Collection,
    flags As Protocol..::..QueryFlags,
    numberToSkip As Integer,
    numberToReturn As Integer,
    query As BSONDocument,
    selector As BSONDocument
) As Integer
public:
static int Write_QUERY(
    Stream^ stream,
    int requestID,
    Database^ db,
    Collection^ collection,
    Protocol..::..QueryFlags flags,
    int numberToSkip,
    int numberToReturn,
    BSONDocument^ query,
    BSONDocument^ selector
)
public:
static int Write_QUERY(
    Stream^ stream,
    int requestID,
    Database^ db,
    Collection^ collection,
    Protocol..::..QueryFlags flags,
    int numberToSkip,
    int numberToReturn,
    BSONDocument^ query,
    BSONDocument^ selector
)
static member Write_QUERY :
        stream : Stream *
        requestID : int *
        db : Database *
        collection : Collection *
        flags : Protocol..::..QueryFlags *
        numberToSkip : int *
        numberToReturn : int *
        query : BSONDocument *
        selector : BSONDocument -> int
static member Write_QUERY :
        stream : Stream *
        requestID : int *
        db : Database *
        collection : Collection *
        flags : Protocol..::..QueryFlags *
        numberToSkip : int *
        numberToReturn : int *
        query : BSONDocument *
        selector : BSONDocument -> int

Parameters

stream
Type: Online System.IO Stream
requestID
Type: Online System Int32
db
Type: NFX.DataAccess.MongoDB.Connector Database
collection
Type: NFX.DataAccess.MongoDB.Connector Collection
flags
Type: NFX.DataAccess.MongoDB.Connector Protocol QueryFlags
numberToSkip
Type: Online System Int32
numberToReturn
Type: Online System Int32
query
Type: NFX.Serialization.BSON BSONDocument
selector
Type: NFX.Serialization.BSON BSONDocument

Return Value

Type: Online Int32
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.Write_RUN_COMMAND Method

Protocol Write_RUN_COMMAND Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Write_RUN_COMMAND(
    Stream stream,
    int requestID,
    Database db,
    BSONDocument command
)
public static int Write_RUN_COMMAND(
    Stream stream,
    int requestID,
    Database db,
    BSONDocument command
)
Public Shared Function Write_RUN_COMMAND (
    stream As Stream,
    requestID As Integer,
    db As Database,
    command As BSONDocument
) As Integer
Public Shared Function Write_RUN_COMMAND (
    stream As Stream,
    requestID As Integer,
    db As Database,
    command As BSONDocument
) As Integer
public:
static int Write_RUN_COMMAND(
    Stream^ stream,
    int requestID,
    Database^ db,
    BSONDocument^ command
)
public:
static int Write_RUN_COMMAND(
    Stream^ stream,
    int requestID,
    Database^ db,
    BSONDocument^ command
)
static member Write_RUN_COMMAND :
        stream : Stream *
        requestID : int *
        db : Database *
        command : BSONDocument -> int
static member Write_RUN_COMMAND :
        stream : Stream *
        requestID : int *
        db : Database *
        command : BSONDocument -> int

Parameters

stream
Type: Online System.IO Stream
requestID
Type: Online System Int32
db
Type: NFX.DataAccess.MongoDB.Connector Database
command
Type: NFX.Serialization.BSON BSONDocument

Return Value

Type: Online Int32
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.Write_UPDATE Method

Protocol Write_UPDATE Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Write_UPDATE(
    Stream stream,
    int requestID,
    Collection collection,
    UpdateEntry[] updates
)
public static int Write_UPDATE(
    Stream stream,
    int requestID,
    Collection collection,
    UpdateEntry[] updates
)
Public Shared Function Write_UPDATE (
    stream As Stream,
    requestID As Integer,
    collection As Collection,
    updates As UpdateEntry()
) As Integer
Public Shared Function Write_UPDATE (
    stream As Stream,
    requestID As Integer,
    collection As Collection,
    updates As UpdateEntry()
) As Integer
public:
static int Write_UPDATE(
    Stream^ stream,
    int requestID,
    Collection^ collection,
    array<UpdateEntry>^ updates
)
public:
static int Write_UPDATE(
    Stream^ stream,
    int requestID,
    Collection^ collection,
    array<UpdateEntry>^ updates
)
static member Write_UPDATE :
        stream : Stream *
        requestID : int *
        collection : Collection *
        updates : UpdateEntry[] -> int
static member Write_UPDATE :
        stream : Stream *
        requestID : int *
        collection : Collection *
        updates : UpdateEntry[] -> int

Parameters

stream
Type: Online System.IO Stream
requestID
Type: Online System Int32
collection
Type: NFX.DataAccess.MongoDB.Connector Collection
updates
Type: NFX.DataAccess.MongoDB.Connector UpdateEntry

Return Value

Type: Online Int32
See Also
Protocol Class
Protocol Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.QueryFlags Enumeration

Protocol QueryFlags Enumeration NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[FlagsAttribute]
public enum QueryFlags
[FlagsAttribute]
public enum QueryFlags
<FlagsAttribute>
Public Enumeration QueryFlags
<FlagsAttribute>
Public Enumeration QueryFlags
[FlagsAttribute]
public enum class QueryFlags
[FlagsAttribute]
public enum class QueryFlags
[<FlagsAttribute>]
type QueryFlags
[<FlagsAttribute>]
type QueryFlags
Members
Member name | Value | Description
None | 0 |
TailableCursor | 1 |
SlaveOk | 2 |
OplogReplay | 4 |
NoCursorTimeout | 8 |
AwaitData | 16 |
Exhaust | 32 |
Partial | 64 |
See Also
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.ReplyData Structure

Protocol ReplyData Structure NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct ReplyData
public struct ReplyData
Public Structure ReplyData
Public Structure ReplyData
public value class ReplyData
public value class ReplyData
[<SealedAttribute>]
type ReplyData =  struct end
[<SealedAttribute>]
type ReplyData =  struct end
See Also
Protocol ReplyData Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.ReplyData Members

Protocol ReplyData Members NFX Class Library

The Protocol ReplyData type exposes the following members.
Constructors
 | Name | Description
Public method | Protocol ReplyData | Initializes a new instance of the Protocol ReplyData class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | CursorID |
Public field | Documents |
Public field | Flags |
Public field | HDR_RequestID |
Public field | HDR_ResponseTo |
Public field | StartingFrom |
Back to Top
See Also
Protocol ReplyData Structure
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.ReplyData Constructor

Protocol ReplyData Constructor NFX Class Library

Initializes a new instance of the Protocol ReplyData class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ReplyData(
    int hdrReqID,
    int hdrRespTo,
    Protocol..::..ResponseFlags flags,
    long cursorID,
    int startingFrom,
    BSONDocument[] docs
)
public ReplyData(
    int hdrReqID,
    int hdrRespTo,
    Protocol..::..ResponseFlags flags,
    long cursorID,
    int startingFrom,
    BSONDocument[] docs
)
Public Sub New (
    hdrReqID As Integer,
    hdrRespTo As Integer,
    flags As Protocol..::..ResponseFlags,
    cursorID As Long,
    startingFrom As Integer,
    docs As BSONDocument()
)
Public Sub New (
    hdrReqID As Integer,
    hdrRespTo As Integer,
    flags As Protocol..::..ResponseFlags,
    cursorID As Long,
    startingFrom As Integer,
    docs As BSONDocument()
)
public:
ReplyData(
    int hdrReqID,
    int hdrRespTo,
    Protocol..::..ResponseFlags flags,
    long long cursorID,
    int startingFrom,
    array<BSONDocument^>^ docs
)
public:
ReplyData(
    int hdrReqID,
    int hdrRespTo,
    Protocol..::..ResponseFlags flags,
    long long cursorID,
    int startingFrom,
    array<BSONDocument^>^ docs
)
new :
        hdrReqID : int *
        hdrRespTo : int *
        flags : Protocol..::..ResponseFlags *
        cursorID : int64 *
        startingFrom : int *
        docs : BSONDocument[] -> ReplyData
new :
        hdrReqID : int *
        hdrRespTo : int *
        flags : Protocol..::..ResponseFlags *
        cursorID : int64 *
        startingFrom : int *
        docs : BSONDocument[] -> ReplyData

Parameters

hdrReqID
Type: Online System Int32
hdrRespTo
Type: Online System Int32
flags
Type: NFX.DataAccess.MongoDB.Connector Protocol ResponseFlags
cursorID
Type: Online System Int64
startingFrom
Type: Online System Int32
docs
Type: NFX.Serialization.BSON BSONDocument
See Also
Protocol ReplyData Structure
Protocol ReplyData Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.ReplyData Fields

Protocol ReplyData Fields NFX Class Library

The Protocol ReplyData type exposes the following members.
Fields
 | Name | Description
Public field | CursorID |
Public field | Documents |
Public field | Flags |
Public field | HDR_RequestID |
Public field | HDR_ResponseTo |
Public field | StartingFrom |
Back to Top
See Also
Protocol ReplyData Structure
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.ReplyData.CursorID Field

Protocol ReplyData CursorID Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly long CursorID
public readonly long CursorID
Public ReadOnly CursorID As Long
Public ReadOnly CursorID As Long
public:
initonly long long CursorID
public:
initonly long long CursorID
val CursorID: int64
val CursorID: int64

Field Value

Type: Online Int64
See Also
Protocol ReplyData Structure
Protocol ReplyData Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.ReplyData.Documents Field

Protocol ReplyData Documents Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly BSONDocument[] Documents
public readonly BSONDocument[] Documents
Public ReadOnly Documents As BSONDocument()
Public ReadOnly Documents As BSONDocument()
public:
initonly array<BSONDocument^>^ Documents
public:
initonly array<BSONDocument^>^ Documents
val Documents: BSONDocument[]
val Documents: BSONDocument[]

Field Value

Type: BSONDocument
See Also
Protocol ReplyData Structure
Protocol ReplyData Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.ReplyData.Flags Field

Protocol ReplyData Flags Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Protocol..::..ResponseFlags Flags
public readonly Protocol..::..ResponseFlags Flags
Public ReadOnly Flags As Protocol..::..ResponseFlags
Public ReadOnly Flags As Protocol..::..ResponseFlags
public:
initonly Protocol..::..ResponseFlags Flags
public:
initonly Protocol..::..ResponseFlags Flags
val Flags: Protocol..::..ResponseFlags
val Flags: Protocol..::..ResponseFlags

Field Value

Type: Protocol ResponseFlags
See Also
Protocol ReplyData Structure
Protocol ReplyData Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.ReplyData.HDR_RequestID Field

Protocol ReplyData HDR_RequestID Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int HDR_RequestID
public readonly int HDR_RequestID
Public ReadOnly HDR_RequestID As Integer
Public ReadOnly HDR_RequestID As Integer
public:
initonly int HDR_RequestID
public:
initonly int HDR_RequestID
val HDR_RequestID: int
val HDR_RequestID: int

Field Value

Type: Online Int32
See Also
Protocol ReplyData Structure
Protocol ReplyData Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.ReplyData.HDR_ResponseTo Field

Protocol ReplyData HDR_ResponseTo Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int HDR_ResponseTo
public readonly int HDR_ResponseTo
Public ReadOnly HDR_ResponseTo As Integer
Public ReadOnly HDR_ResponseTo As Integer
public:
initonly int HDR_ResponseTo
public:
initonly int HDR_ResponseTo
val HDR_ResponseTo: int
val HDR_ResponseTo: int

Field Value

Type: Online Int32
See Also
Protocol ReplyData Structure
Protocol ReplyData Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.ReplyData.StartingFrom Field

Protocol ReplyData StartingFrom Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int StartingFrom
public readonly int StartingFrom
Public ReadOnly StartingFrom As Integer
Public ReadOnly StartingFrom As Integer
public:
initonly int StartingFrom
public:
initonly int StartingFrom
val StartingFrom: int
val StartingFrom: int

Field Value

Type: Online Int32
See Also
Protocol ReplyData Structure
Protocol ReplyData Members
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.ReplyData Methods

Protocol ReplyData Methods NFX Class Library

The Protocol ReplyData type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Protocol ReplyData Structure
NFX.DataAccess.MongoDB.Connector Namespace


Protocol.ResponseFlags Enumeration

Protocol ResponseFlags Enumeration NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[FlagsAttribute]
public enum ResponseFlags
[FlagsAttribute]
public enum ResponseFlags
<FlagsAttribute>
Public Enumeration ResponseFlags
<FlagsAttribute>
Public Enumeration ResponseFlags
[FlagsAttribute]
public enum class ResponseFlags
[FlagsAttribute]
public enum class ResponseFlags
[<FlagsAttribute>]
type ResponseFlags
[<FlagsAttribute>]
type ResponseFlags
Members
Member name | Value | Description
None | 0 |
CursorNotFound | 1 | Set when getMore is called but the cursor id is not valid at the server. Returned with zero results.
QueryFailure | 2 | Set when query failed. Results consist of one document containing an “$err” field describing the failure.
ShardConfigStale | 4 | Drivers should ignore this. Only mongos will ever see this set, in which case, it needs to update config from the server.
AwaitCapable | 8 | Set when the server supports the AwaitData Query option. If it doesn’t, a client should sleep a little between getMore’s of a Tailable cursor. Mongod version 1.6 supports AwaitData and thus always sets AwaitCapable.
See Also
NFX.DataAccess.MongoDB.Connector Namespace


Query Class

Query Class NFX Class Library

Represents a query document sent to MongoDB
Inheritance Hierarchy
Online System Object
NFX.Serialization.BSON BSONDocument
NFX.DataAccess.MongoDB.Connector Query

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Query : BSONDocument
public class Query : BSONDocument
Public Class Query
    Inherits BSONDocument
Public Class Query
    Inherits BSONDocument
public ref class Query : public BSONDocument
public ref class Query : public BSONDocument
type Query =
    class
        inherit BSONDocument
    end
type Query =
    class
        inherit BSONDocument
    end
See Also
Query Members
NFX.DataAccess.MongoDB.Connector Namespace


Query Members

Query Members NFX Class Library

The Query type exposes the following members.
Constructors
 | Name | Description
Public method | Query | Initializes a new instance of the Query class
Public method | Query(Stream) | Initializes a new instance of the Query class
Public method | Query(String, Boolean, TemplateArg ) | Creates an instance of the query from JSON template with parameters populated from args optionally caching the template internal representation. Do not cache templates that change often
Back to Top
Methods
 | Name | Description
Public method | Delete | Deletes an element by name returning true if it was found and deleted (Inherited from BSONDocument.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Calculates the BSON binary size of this document expressed in bytes (Inherited from BSONDocument.)
Public method | GetEnumerator | (Inherited from BSONDocument.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | ID_EQ_BYTE_ARRAY |
 | ID_EQ_GDID |
 | ID_EQ_Int32(Int32) |
 | ID_EQ_Int32(Int64) |
 | ID_EQ_String |
Public method | IndexOfName | Returns index of named BSONElement or -1 if it does not exist (Inherited from BSONDocument.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Set(BSONElement, Int32) | Inserts BSONElement into document (Inherited from BSONDocument.)
Public method | Set(BSONElement, Boolean , Int32) | Inserts BSONElement into document (Inherited from BSONDocument.)
Public method | ToString | (Inherited from BSONDocument.)
Public method | WriteAsBSON | Serializes this document into BSON-format stream (Inherited from BSONDocument.)
Protected method | WriteAsBSONCore | (Inherited from BSONDocument.)
Public method | WriteAsBSONToNewArray | Serializes BSON document to byte[] (Inherited from BSONDocument.)
Public method | WriteAsJSON | Serializes this dosument into a TextWriter - this method is used by JSON serializer(JSONWriter) (Inherited from BSONDocument.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
_ID |
PROJECTION_ROOT |
Back to Top
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONDocument.)
Public property | Count | Returns the number of BSONElements in this document (Inherited from BSONDocument.)
Public property | Item Int32 | Returns BSONElement by index or null if index is out of bounds (Inherited from BSONDocument.)
Public property | Item String | Returns BSONElement by name or null if not found (Inherited from BSONDocument.)
Public property | ProjectionSelector | Gets/sets projection document which should be embedded in query with '$NFX-QUERY-PROJECTION' see the PROJECTION_ROOT constant https://docs.mongodb.com/manual/tutorial/project-fields-from-query-results
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from BSONDocument.)
Back to Top
See Also
Query Class
NFX.DataAccess.MongoDB.Connector Namespace


Query Constructor

Query Constructor NFX Class Library

Overload List
 | Name | Description
Public method | Query | Initializes a new instance of the Query class
Public method | Query(Stream) | Initializes a new instance of the Query class
Public method | Query(String, Boolean, TemplateArg ) | Creates an instance of the query from JSON template with parameters populated from args optionally caching the template internal representation. Do not cache templates that change often
Back to Top
See Also
Query Class
Query Members
NFX.DataAccess.MongoDB.Connector Namespace


Query Constructor

Query Constructor NFX Class Library

Initializes a new instance of the Query class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Query()
public Query()
Public Sub New
Public Sub New
public:
Query()
public:
Query()
new : unit -> Query
new : unit -> Query
See Also
Query Class
Query Members
Query Overload
NFX.DataAccess.MongoDB.Connector Namespace


Query Constructor (Stream)

Query Constructor (Stream) NFX Class Library

Initializes a new instance of the Query class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Query(
    Stream stream
)
public Query(
    Stream stream
)
Public Sub New (
    stream As Stream
)
Public Sub New (
    stream As Stream
)
public:
Query(
    Stream^ stream
)
public:
Query(
    Stream^ stream
)
new :
        stream : Stream -> Query
new :
        stream : Stream -> Query

Parameters

stream
Type: Online System.IO Stream
See Also
Query Class
Query Members
Query Overload
NFX.DataAccess.MongoDB.Connector Namespace


Query Constructor (String, Boolean, TemplateArg[])

Query Constructor (String, Boolean, TemplateArg ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates an instance of the query from JSON template with parameters populated from args optionally caching the template internal representation. Do not cache templates that change often

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Query(
    string template,
    bool cacheTemplate,
    params TemplateArg[] args
)
public Query(
    string template,
    bool cacheTemplate,
    params TemplateArg[] args
)
Public Sub New (
    template As String,
    cacheTemplate As Boolean,
    ParamArray args As TemplateArg()
)
Public Sub New (
    template As String,
    cacheTemplate As Boolean,
    ParamArray args As TemplateArg()
)
public:
Query(
    String^ template,
    bool cacheTemplate,
    ... array<TemplateArg>^ args
)
public:
Query(
    String^ template,
    bool cacheTemplate,
    ... array<TemplateArg>^ args
)
new :
        template : string *
        cacheTemplate : bool *
        args : TemplateArg[] -> Query
new :
        template : string *
        cacheTemplate : bool *
        args : TemplateArg[] -> Query

Parameters

template
Type: Online System String
cacheTemplate
Type: Online System Boolean
args
Type: NFX.Serialization.BSON TemplateArg
See Also
Query Class
Query Members
Query Overload
NFX.DataAccess.MongoDB.Connector Namespace


Query Fields

Query Fields NFX Class Library

The Query type exposes the following members.
Fields
Name | Description
_ID |
PROJECTION_ROOT |
Back to Top
See Also
Query Class
NFX.DataAccess.MongoDB.Connector Namespace


Query._ID Field

Query _ID Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string _ID
public const string _ID
Public Const _ID As String
Public Const _ID As String
public:
literal String^ _ID
public:
literal String^ _ID
static val mutable _ID: string
static val mutable _ID: string

Field Value

Type: Online String
See Also
Query Class
Query Members
NFX.DataAccess.MongoDB.Connector Namespace


Query.PROJECTION_ROOT Field

Query PROJECTION_ROOT Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PROJECTION_ROOT
public const string PROJECTION_ROOT
Public Const PROJECTION_ROOT As String
Public Const PROJECTION_ROOT As String
public:
literal String^ PROJECTION_ROOT
public:
literal String^ PROJECTION_ROOT
static val mutable PROJECTION_ROOT: string
static val mutable PROJECTION_ROOT: string

Field Value

Type: Online String
See Also
Query Class
Query Members
NFX.DataAccess.MongoDB.Connector Namespace


Query Methods

Query Methods NFX Class Library

The Query type exposes the following members.
Methods
 | Name | Description
Public method | Delete | Deletes an element by name returning true if it was found and deleted (Inherited from BSONDocument.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Calculates the BSON binary size of this document expressed in bytes (Inherited from BSONDocument.)
Public method | GetEnumerator | (Inherited from BSONDocument.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | ID_EQ_BYTE_ARRAY |
 | ID_EQ_GDID |
 | ID_EQ_Int32(Int32) |
 | ID_EQ_Int32(Int64) |
 | ID_EQ_String |
Public method | IndexOfName | Returns index of named BSONElement or -1 if it does not exist (Inherited from BSONDocument.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Set(BSONElement, Int32) | Inserts BSONElement into document (Inherited from BSONDocument.)
Public method | Set(BSONElement, Boolean , Int32) | Inserts BSONElement into document (Inherited from BSONDocument.)
Public method | ToString | (Inherited from BSONDocument.)
Public method | WriteAsBSON | Serializes this document into BSON-format stream (Inherited from BSONDocument.)
Protected method | WriteAsBSONCore | (Inherited from BSONDocument.)
Public method | WriteAsBSONToNewArray | Serializes BSON document to byte[] (Inherited from BSONDocument.)
Public method | WriteAsJSON | Serializes this dosument into a TextWriter - this method is used by JSON serializer(JSONWriter) (Inherited from BSONDocument.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from BSONDocument.)
Back to Top
See Also
Query Class
NFX.DataAccess.MongoDB.Connector Namespace


Query.ID_EQ_BYTE_ARRAY Method

Query ID_EQ_BYTE_ARRAY Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Query ID_EQ_BYTE_ARRAY(
    byte[] id
)
public static Query ID_EQ_BYTE_ARRAY(
    byte[] id
)
Public Shared Function ID_EQ_BYTE_ARRAY (
    id As Byte()
) As Query
Public Shared Function ID_EQ_BYTE_ARRAY (
    id As Byte()
) As Query
public:
static Query^ ID_EQ_BYTE_ARRAY(
    array<unsigned char>^ id
)
public:
static Query^ ID_EQ_BYTE_ARRAY(
    array<unsigned char>^ id
)
static member ID_EQ_BYTE_ARRAY :
        id : byte[] -> Query
static member ID_EQ_BYTE_ARRAY :
        id : byte[] -> Query

Parameters

id
Type: Online System Byte

Return Value

Type: Query
See Also
Query Class
Query Members
NFX.DataAccess.MongoDB.Connector Namespace


Query.ID_EQ_GDID Method

Query ID_EQ_GDID Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Query ID_EQ_GDID(
    GDID id
)
public static Query ID_EQ_GDID(
    GDID id
)
Public Shared Function ID_EQ_GDID (
    id As GDID
) As Query
Public Shared Function ID_EQ_GDID (
    id As GDID
) As Query
public:
static Query^ ID_EQ_GDID(
    GDID id
)
public:
static Query^ ID_EQ_GDID(
    GDID id
)
static member ID_EQ_GDID :
        id : GDID -> Query
static member ID_EQ_GDID :
        id : GDID -> Query

Parameters

id
Type: NFX.DataAccess.Distributed GDID

Return Value

Type: Query
See Also
Query Class
Query Members
NFX.DataAccess.MongoDB.Connector Namespace


Query.ID_EQ_Int32 Method

Query ID_EQ_Int32 Method NFX Class Library

Overload List
Name | Description
ID_EQ_Int32(Int32) |
ID_EQ_Int32(Int64) |
Back to Top
See Also
Query Class
Query Members
NFX.DataAccess.MongoDB.Connector Namespace


Query.ID_EQ_Int32 Method (Int32)

Query ID_EQ_Int32 Method (Int32) NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Query ID_EQ_Int32(
    int id
)
public static Query ID_EQ_Int32(
    int id
)
Public Shared Function ID_EQ_Int32 (
    id As Integer
) As Query
Public Shared Function ID_EQ_Int32 (
    id As Integer
) As Query
public:
static Query^ ID_EQ_Int32(
    int id
)
public:
static Query^ ID_EQ_Int32(
    int id
)
static member ID_EQ_Int32 :
        id : int -> Query
static member ID_EQ_Int32 :
        id : int -> Query

Parameters

id
Type: Online System Int32

Return Value

Type: Query
See Also
Query Class
Query Members
ID_EQ_Int32 Overload
NFX.DataAccess.MongoDB.Connector Namespace


Query.ID_EQ_Int32 Method (Int64)

Query ID_EQ_Int32 Method (Int64) NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Query ID_EQ_Int32(
    long id
)
public static Query ID_EQ_Int32(
    long id
)
Public Shared Function ID_EQ_Int32 (
    id As Long
) As Query
Public Shared Function ID_EQ_Int32 (
    id As Long
) As Query
public:
static Query^ ID_EQ_Int32(
    long long id
)
public:
static Query^ ID_EQ_Int32(
    long long id
)
static member ID_EQ_Int32 :
        id : int64 -> Query
static member ID_EQ_Int32 :
        id : int64 -> Query

Parameters

id
Type: Online System Int64

Return Value

Type: Query
See Also
Query Class
Query Members
ID_EQ_Int32 Overload
NFX.DataAccess.MongoDB.Connector Namespace


Query.ID_EQ_String Method

Query ID_EQ_String Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Query ID_EQ_String(
    string id
)
public static Query ID_EQ_String(
    string id
)
Public Shared Function ID_EQ_String (
    id As String
) As Query
Public Shared Function ID_EQ_String (
    id As String
) As Query
public:
static Query^ ID_EQ_String(
    String^ id
)
public:
static Query^ ID_EQ_String(
    String^ id
)
static member ID_EQ_String :
        id : string -> Query
static member ID_EQ_String :
        id : string -> Query

Parameters

id
Type: Online System String

Return Value

Type: Query
See Also
Query Class
Query Members
NFX.DataAccess.MongoDB.Connector Namespace


Query Properties

Query Properties NFX Class Library

The Query type exposes the following members.
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONDocument.)
Public property | Count | Returns the number of BSONElements in this document (Inherited from BSONDocument.)
Public property | Item Int32 | Returns BSONElement by index or null if index is out of bounds (Inherited from BSONDocument.)
Public property | Item String | Returns BSONElement by name or null if not found (Inherited from BSONDocument.)
Public property | ProjectionSelector | Gets/sets projection document which should be embedded in query with '$NFX-QUERY-PROJECTION' see the PROJECTION_ROOT constant https://docs.mongodb.com/manual/tutorial/project-fields-from-query-results
Back to Top
See Also
Query Class
NFX.DataAccess.MongoDB.Connector Namespace


Query.ProjectionSelector Property

Query ProjectionSelector Property NFX Class Library

Gets/sets projection document which should be embedded in query with '$NFX-QUERY-PROJECTION' see the PROJECTION_ROOT constant https://docs.mongodb.com/manual/tutorial/project-fields-from-query-results

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONDocument ProjectionSelector { get; set; }
public BSONDocument ProjectionSelector { get; set; }
Public Property ProjectionSelector As BSONDocument
    Get
    Set
Public Property ProjectionSelector As BSONDocument
    Get
    Set
public:
property BSONDocument^ ProjectionSelector {
    BSONDocument^ get ();
    void set (BSONDocument^ value);
}
public:
property BSONDocument^ ProjectionSelector {
    BSONDocument^ get ();
    void set (BSONDocument^ value);
}
member ProjectionSelector : BSONDocument with get, set
member ProjectionSelector : BSONDocument with get, set

Property Value

Type: BSONDocument
See Also
Query Class
Query Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode Class

ServerNode Class NFX Class Library

Manages connections to the same server
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.DataAccess.MongoDB.Connector ServerNode

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ServerNode : ApplicationComponent,
    INamed
public sealed class ServerNode : ApplicationComponent,
    INamed
Public NotInheritable Class ServerNode
    Inherits ApplicationComponent
    Implements INamed
Public NotInheritable Class ServerNode
    Inherits ApplicationComponent
    Implements INamed
public ref class ServerNode sealed : public ApplicationComponent,
    INamed
public ref class ServerNode sealed : public ApplicationComponent,
    INamed
[<SealedAttribute>]
type ServerNode =
    class
        inherit ApplicationComponent
        interface INamed
    end
[<SealedAttribute>]
type ServerNode =
    class
        inherit ApplicationComponent
        interface INamed
    end
See Also
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode Members

ServerNode Members NFX Class Library

The ServerNode type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerNode | Initializes a new instance of the ServerNode class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AcquireConnection |
Public method | CloseAllConnections | Closes all connections. Waits untill all closed if wait==true, otherwise tries to close what it can
Protected method | closeExistingConnection |
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | ManagerVisit | Periodically invoked by the client to do management work, like close expired connections
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | RegisterCursor |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | CONFIG_SERVER_SECTION |
 | DEFAULT_IDLE_TIMEOUT_SEC |
 | DEFAULT_RCV_BUFFER_SIZE |
 | DEFAULT_RCV_TIMEOUT |
 | DEFAULT_SND_BUFFER_SIZE |
 | DEFAULT_SND_TIMEOUT |
Protected field | m_Databases |
 | MAX_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT |
 | MAX_EXISTING_ACQUISITION_TIMEOUT_MS_MAX |
 | MAX_EXISTING_ACQUISITION_TIMEOUT_MS_MIN |
 | MIN_IDLE_TIMEOUT_SEC |
Back to Top
Properties
 | Name | Description
Public property | Client | References client that this node is under
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Databases | Returns mounted databases
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | IdleConnectionTimeoutSec |
Public property | Item | Returns an existing database or creates a new one
Public property | MaxConnections | When greater than zero, imposes a limit on the open connection count
Public property | MaxExistingAcquisitionTimeoutMs | Imposes a timeout for system trying to get an existing connection instance per remote address.
Public property | Name |
Protected property | NextRequestID | Generates request ID unique per server node
Public property | Node |
Public property | SocketReceiveBufferSize |
Public property | SocketReceiveTimeout |
Public property | SocketSendBufferSize |
Public property | SocketSendTimeout |
Public property | WriteConcern |
Back to Top
See Also
ServerNode Class
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode Constructor

ServerNode Constructor NFX Class Library

Initializes a new instance of the ServerNode class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ServerNode(
    MongoClient client,
    Node node
)
internal ServerNode(
    MongoClient client,
    Node node
)
Friend Sub New (
    client As MongoClient,
    node As Node
)
Friend Sub New (
    client As MongoClient,
    node As Node
)
internal:
ServerNode(
    MongoClient^ client,
    Node node
)
internal:
ServerNode(
    MongoClient^ client,
    Node node
)
new :
        client : MongoClient *
        node : Node -> ServerNode
new :
        client : MongoClient *
        node : Node -> ServerNode

Parameters

client
Type: NFX.DataAccess.MongoDB.Connector MongoClient
node
Type: NFX.Glue Node
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode Fields

ServerNode Fields NFX Class Library

The ServerNode type exposes the following members.
Fields
 | Name | Description
 | CONFIG_SERVER_SECTION |
 | DEFAULT_IDLE_TIMEOUT_SEC |
 | DEFAULT_RCV_BUFFER_SIZE |
 | DEFAULT_RCV_TIMEOUT |
 | DEFAULT_SND_BUFFER_SIZE |
 | DEFAULT_SND_TIMEOUT |
Protected field | m_Databases |
 | MAX_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT |
 | MAX_EXISTING_ACQUISITION_TIMEOUT_MS_MAX |
 | MAX_EXISTING_ACQUISITION_TIMEOUT_MS_MIN |
 | MIN_IDLE_TIMEOUT_SEC |
Back to Top
See Also
ServerNode Class
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.CONFIG_SERVER_SECTION Field

ServerNode CONFIG_SERVER_SECTION Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SERVER_SECTION
public const string CONFIG_SERVER_SECTION
Public Const CONFIG_SERVER_SECTION As String
Public Const CONFIG_SERVER_SECTION As String
public:
literal String^ CONFIG_SERVER_SECTION
public:
literal String^ CONFIG_SERVER_SECTION
static val mutable CONFIG_SERVER_SECTION: string
static val mutable CONFIG_SERVER_SECTION: string

Field Value

Type: Online String
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.DEFAULT_IDLE_TIMEOUT_SEC Field

ServerNode DEFAULT_IDLE_TIMEOUT_SEC Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_IDLE_TIMEOUT_SEC
public const int DEFAULT_IDLE_TIMEOUT_SEC
Public Const DEFAULT_IDLE_TIMEOUT_SEC As Integer
Public Const DEFAULT_IDLE_TIMEOUT_SEC As Integer
public:
literal int DEFAULT_IDLE_TIMEOUT_SEC
public:
literal int DEFAULT_IDLE_TIMEOUT_SEC
static val mutable DEFAULT_IDLE_TIMEOUT_SEC: int
static val mutable DEFAULT_IDLE_TIMEOUT_SEC: int

Field Value

Type: Online Int32
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.DEFAULT_RCV_BUFFER_SIZE Field

ServerNode DEFAULT_RCV_BUFFER_SIZE Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_RCV_BUFFER_SIZE
public const int DEFAULT_RCV_BUFFER_SIZE
Public Const DEFAULT_RCV_BUFFER_SIZE As Integer
Public Const DEFAULT_RCV_BUFFER_SIZE As Integer
public:
literal int DEFAULT_RCV_BUFFER_SIZE
public:
literal int DEFAULT_RCV_BUFFER_SIZE
static val mutable DEFAULT_RCV_BUFFER_SIZE: int
static val mutable DEFAULT_RCV_BUFFER_SIZE: int

Field Value

Type: Online Int32
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.DEFAULT_RCV_TIMEOUT Field

ServerNode DEFAULT_RCV_TIMEOUT Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_RCV_TIMEOUT
public const int DEFAULT_RCV_TIMEOUT
Public Const DEFAULT_RCV_TIMEOUT As Integer
Public Const DEFAULT_RCV_TIMEOUT As Integer
public:
literal int DEFAULT_RCV_TIMEOUT
public:
literal int DEFAULT_RCV_TIMEOUT
static val mutable DEFAULT_RCV_TIMEOUT: int
static val mutable DEFAULT_RCV_TIMEOUT: int

Field Value

Type: Online Int32
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.DEFAULT_SND_BUFFER_SIZE Field

ServerNode DEFAULT_SND_BUFFER_SIZE Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_SND_BUFFER_SIZE
public const int DEFAULT_SND_BUFFER_SIZE
Public Const DEFAULT_SND_BUFFER_SIZE As Integer
Public Const DEFAULT_SND_BUFFER_SIZE As Integer
public:
literal int DEFAULT_SND_BUFFER_SIZE
public:
literal int DEFAULT_SND_BUFFER_SIZE
static val mutable DEFAULT_SND_BUFFER_SIZE: int
static val mutable DEFAULT_SND_BUFFER_SIZE: int

Field Value

Type: Online Int32
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.DEFAULT_SND_TIMEOUT Field

ServerNode DEFAULT_SND_TIMEOUT Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_SND_TIMEOUT
public const int DEFAULT_SND_TIMEOUT
Public Const DEFAULT_SND_TIMEOUT As Integer
Public Const DEFAULT_SND_TIMEOUT As Integer
public:
literal int DEFAULT_SND_TIMEOUT
public:
literal int DEFAULT_SND_TIMEOUT
static val mutable DEFAULT_SND_TIMEOUT: int
static val mutable DEFAULT_SND_TIMEOUT: int

Field Value

Type: Online Int32
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.m_Databases Field

ServerNode m_Databases Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Registry<Database> m_Databases
internal Registry<Database> m_Databases
Friend m_Databases As Registry(Of Database)
Friend m_Databases As Registry(Of Database)
internal:
Registry<Database^>^ m_Databases
internal:
Registry<Database^>^ m_Databases
val mutable internal m_Databases: Registry<Database>
val mutable internal m_Databases: Registry<Database>

Field Value

Type: Registry Database
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.MAX_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT Field

ServerNode MAX_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT
public const int MAX_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT
Public Const MAX_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT As Integer
Public Const MAX_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT As Integer
public:
literal int MAX_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT
public:
literal int MAX_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT
static val mutable MAX_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT: int
static val mutable MAX_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT: int

Field Value

Type: Online Int32
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.MAX_EXISTING_ACQUISITION_TIMEOUT_MS_MAX Field

ServerNode MAX_EXISTING_ACQUISITION_TIMEOUT_MS_MAX Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_EXISTING_ACQUISITION_TIMEOUT_MS_MAX
public const int MAX_EXISTING_ACQUISITION_TIMEOUT_MS_MAX
Public Const MAX_EXISTING_ACQUISITION_TIMEOUT_MS_MAX As Integer
Public Const MAX_EXISTING_ACQUISITION_TIMEOUT_MS_MAX As Integer
public:
literal int MAX_EXISTING_ACQUISITION_TIMEOUT_MS_MAX
public:
literal int MAX_EXISTING_ACQUISITION_TIMEOUT_MS_MAX
static val mutable MAX_EXISTING_ACQUISITION_TIMEOUT_MS_MAX: int
static val mutable MAX_EXISTING_ACQUISITION_TIMEOUT_MS_MAX: int

Field Value

Type: Online Int32
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.MAX_EXISTING_ACQUISITION_TIMEOUT_MS_MIN Field

ServerNode MAX_EXISTING_ACQUISITION_TIMEOUT_MS_MIN Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_EXISTING_ACQUISITION_TIMEOUT_MS_MIN
public const int MAX_EXISTING_ACQUISITION_TIMEOUT_MS_MIN
Public Const MAX_EXISTING_ACQUISITION_TIMEOUT_MS_MIN As Integer
Public Const MAX_EXISTING_ACQUISITION_TIMEOUT_MS_MIN As Integer
public:
literal int MAX_EXISTING_ACQUISITION_TIMEOUT_MS_MIN
public:
literal int MAX_EXISTING_ACQUISITION_TIMEOUT_MS_MIN
static val mutable MAX_EXISTING_ACQUISITION_TIMEOUT_MS_MIN: int
static val mutable MAX_EXISTING_ACQUISITION_TIMEOUT_MS_MIN: int

Field Value

Type: Online Int32
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.MIN_IDLE_TIMEOUT_SEC Field

ServerNode MIN_IDLE_TIMEOUT_SEC Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MIN_IDLE_TIMEOUT_SEC
public const int MIN_IDLE_TIMEOUT_SEC
Public Const MIN_IDLE_TIMEOUT_SEC As Integer
Public Const MIN_IDLE_TIMEOUT_SEC As Integer
public:
literal int MIN_IDLE_TIMEOUT_SEC
public:
literal int MIN_IDLE_TIMEOUT_SEC
static val mutable MIN_IDLE_TIMEOUT_SEC: int
static val mutable MIN_IDLE_TIMEOUT_SEC: int

Field Value

Type: Online Int32
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode Methods

ServerNode Methods NFX Class Library

The ServerNode type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AcquireConnection |
Public method | CloseAllConnections | Closes all connections. Waits untill all closed if wait==true, otherwise tries to close what it can
Protected method | closeExistingConnection |
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | ManagerVisit | Periodically invoked by the client to do management work, like close expired connections
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | RegisterCursor |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerNode Class
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.AcquireConnection Method

ServerNode AcquireConnection Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Connection AcquireConnection()
internal Connection AcquireConnection()
Friend Function AcquireConnection As Connection
Friend Function AcquireConnection As Connection
internal:
Connection^ AcquireConnection()
internal:
Connection^ AcquireConnection()
internal member AcquireConnection : unit -> Connection
internal member AcquireConnection : unit -> Connection

Return Value

Type: Connection
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.CloseAllConnections Method

ServerNode CloseAllConnections Method NFX Class Library

Closes all connections. Waits untill all closed if wait==true, otherwise tries to close what it can

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CloseAllConnections(
    bool wait
)
public void CloseAllConnections(
    bool wait
)
Public Sub CloseAllConnections (
    wait As Boolean
)
Public Sub CloseAllConnections (
    wait As Boolean
)
public:
void CloseAllConnections(
    bool wait
)
public:
void CloseAllConnections(
    bool wait
)
member CloseAllConnections :
        wait : bool -> unit
member CloseAllConnections :
        wait : bool -> unit

Parameters

wait
Type: Online System Boolean
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.closeExistingConnection Method

ServerNode closeExistingConnection Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void closeExistingConnection(
    Connection cnn
)
internal void closeExistingConnection(
    Connection cnn
)
Friend Sub closeExistingConnection (
    cnn As Connection
)
Friend Sub closeExistingConnection (
    cnn As Connection
)
internal:
void closeExistingConnection(
    Connection^ cnn
)
internal:
void closeExistingConnection(
    Connection^ cnn
)
internal member closeExistingConnection :
        cnn : Connection -> unit
internal member closeExistingConnection :
        cnn : Connection -> unit

Parameters

cnn
Type: NFX.DataAccess.MongoDB.Connector Connection
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.Destructor Method

ServerNode Destructor Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.ManagerVisit Method

ServerNode ManagerVisit Method NFX Class Library

Periodically invoked by the client to do management work, like close expired connections

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void ManagerVisit()
internal void ManagerVisit()
Friend Sub ManagerVisit
Friend Sub ManagerVisit
internal:
void ManagerVisit()
internal:
void ManagerVisit()
internal member ManagerVisit : unit -> unit
internal member ManagerVisit : unit -> unit
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.RegisterCursor Method

ServerNode RegisterCursor Method NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void RegisterCursor(
    Cursor cursor
)
internal void RegisterCursor(
    Cursor cursor
)
Friend Sub RegisterCursor (
    cursor As Cursor
)
Friend Sub RegisterCursor (
    cursor As Cursor
)
internal:
void RegisterCursor(
    Cursor^ cursor
)
internal:
void RegisterCursor(
    Cursor^ cursor
)
internal member RegisterCursor :
        cursor : Cursor -> unit
internal member RegisterCursor :
        cursor : Cursor -> unit

Parameters

cursor
Type: NFX.DataAccess.MongoDB.Connector Cursor
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode Properties

ServerNode Properties NFX Class Library

The ServerNode type exposes the following members.
Properties
 | Name | Description
Public property | Client | References client that this node is under
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Databases | Returns mounted databases
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | IdleConnectionTimeoutSec |
Public property | Item | Returns an existing database or creates a new one
Public property | MaxConnections | When greater than zero, imposes a limit on the open connection count
Public property | MaxExistingAcquisitionTimeoutMs | Imposes a timeout for system trying to get an existing connection instance per remote address.
Public property | Name |
Protected property | NextRequestID | Generates request ID unique per server node
Public property | Node |
Public property | SocketReceiveBufferSize |
Public property | SocketReceiveTimeout |
Public property | SocketSendBufferSize |
Public property | SocketSendTimeout |
Public property | WriteConcern |
Back to Top
See Also
ServerNode Class
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.Client Property

ServerNode Client Property NFX Class Library

References client that this node is under

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoClient Client { get; }
public MongoClient Client { get; }
Public ReadOnly Property Client As MongoClient
    Get
Public ReadOnly Property Client As MongoClient
    Get
public:
property MongoClient^ Client {
    MongoClient^ get ();
}
public:
property MongoClient^ Client {
    MongoClient^ get ();
}
member Client : MongoClient with get
member Client : MongoClient with get

Property Value

Type: MongoClient
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.Databases Property

ServerNode Databases Property NFX Class Library

Returns mounted databases

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<Database> Databases { get; }
public IRegistry<Database> Databases { get; }
Public ReadOnly Property Databases As IRegistry(Of Database)
    Get
Public ReadOnly Property Databases As IRegistry(Of Database)
    Get
public:
property IRegistry<Database^>^ Databases {
    IRegistry<Database^>^ get ();
}
public:
property IRegistry<Database^>^ Databases {
    IRegistry<Database^>^ get ();
}
member Databases : IRegistry<Database> with get
member Databases : IRegistry<Database> with get

Property Value

Type: IRegistry Database
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.IdleConnectionTimeoutSec Property

ServerNode IdleConnectionTimeoutSec Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int IdleConnectionTimeoutSec { get; set; }
[ConfigAttribute]
public int IdleConnectionTimeoutSec { get; set; }
<ConfigAttribute>
Public Property IdleConnectionTimeoutSec As Integer
    Get
    Set
<ConfigAttribute>
Public Property IdleConnectionTimeoutSec As Integer
    Get
    Set
public:
[ConfigAttribute]
property int IdleConnectionTimeoutSec {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute]
property int IdleConnectionTimeoutSec {
    int get ();
    void set (int value);
}
[<ConfigAttribute>]
member IdleConnectionTimeoutSec : int with get, set
[<ConfigAttribute>]
member IdleConnectionTimeoutSec : int with get, set

Property Value

Type: Online Int32
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.Item Property

ServerNode Item Property NFX Class Library

Returns an existing database or creates a new one

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Database this[
    string name
] { get; }
public Database this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As Database
    Get
Public ReadOnly Default Property Item (
    name As String
) As Database
    Get
public:
property Database^ default[String^ name] {
    Database^ get (String^ name);
}
public:
property Database^ default[String^ name] {
    Database^ get (String^ name);
}
member Item : Database with get
member Item : Database with get

Parameters

name
Type: Online System String

Property Value

Type: Database
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.MaxConnections Property

ServerNode MaxConnections Property NFX Class Library

When greater than zero, imposes a limit on the open connection count

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int MaxConnections { get; set; }
[ConfigAttribute]
public int MaxConnections { get; set; }
<ConfigAttribute>
Public Property MaxConnections As Integer
    Get
    Set
<ConfigAttribute>
Public Property MaxConnections As Integer
    Get
    Set
public:
[ConfigAttribute]
property int MaxConnections {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute]
property int MaxConnections {
    int get ();
    void set (int value);
}
[<ConfigAttribute>]
member MaxConnections : int with get, set
[<ConfigAttribute>]
member MaxConnections : int with get, set

Property Value

Type: Online Int32
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.MaxExistingAcquisitionTimeoutMs Property

ServerNode MaxExistingAcquisitionTimeoutMs Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Imposes a timeout for system trying to get an existing connection instance per remote address.

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int MaxExistingAcquisitionTimeoutMs { get; set; }
[ConfigAttribute]
public int MaxExistingAcquisitionTimeoutMs { get; set; }
<ConfigAttribute>
Public Property MaxExistingAcquisitionTimeoutMs As Integer
    Get
    Set
<ConfigAttribute>
Public Property MaxExistingAcquisitionTimeoutMs As Integer
    Get
    Set
public:
[ConfigAttribute]
property int MaxExistingAcquisitionTimeoutMs {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute]
property int MaxExistingAcquisitionTimeoutMs {
    int get ();
    void set (int value);
}
[<ConfigAttribute>]
member MaxExistingAcquisitionTimeoutMs : int with get, set
[<ConfigAttribute>]
member MaxExistingAcquisitionTimeoutMs : int with get, set

Property Value

Type: Online Int32
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.Name Property

ServerNode Name Property NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.NextRequestID Property

ServerNode NextRequestID Property NFX Class Library

Generates request ID unique per server node

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int NextRequestID { get; }
internal int NextRequestID { get; }
Friend ReadOnly Property NextRequestID As Integer
    Get
Friend ReadOnly Property NextRequestID As Integer
    Get
internal:
property int NextRequestID {
    int get ();
}
internal:
property int NextRequestID {
    int get ();
}
internal member NextRequestID : int with get
internal member NextRequestID : int with get

Property Value

Type: Online Int32
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.Node Property

ServerNode Node Property NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Node Node { get; }
public Node Node { get; }
Public ReadOnly Property Node As Node
    Get
Public ReadOnly Property Node As Node
    Get
public:
property Node Node {
    Node get ();
}
public:
property Node Node {
    Node get ();
}
member Node : Node with get
member Node : Node with get

Property Value

Type: Node
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.SocketReceiveBufferSize Property

ServerNode SocketReceiveBufferSize Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int SocketReceiveBufferSize { get; set; }
[ConfigAttribute]
public int SocketReceiveBufferSize { get; set; }
<ConfigAttribute>
Public Property SocketReceiveBufferSize As Integer
    Get
    Set
<ConfigAttribute>
Public Property SocketReceiveBufferSize As Integer
    Get
    Set
public:
[ConfigAttribute]
property int SocketReceiveBufferSize {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute]
property int SocketReceiveBufferSize {
    int get ();
    void set (int value);
}
[<ConfigAttribute>]
member SocketReceiveBufferSize : int with get, set
[<ConfigAttribute>]
member SocketReceiveBufferSize : int with get, set

Property Value

Type: Online Int32
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.SocketReceiveTimeout Property

ServerNode SocketReceiveTimeout Property NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int SocketReceiveTimeout { get; set; }
[ConfigAttribute]
public int SocketReceiveTimeout { get; set; }
<ConfigAttribute>
Public Property SocketReceiveTimeout As Integer
    Get
    Set
<ConfigAttribute>
Public Property SocketReceiveTimeout As Integer
    Get
    Set
public:
[ConfigAttribute]
property int SocketReceiveTimeout {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute]
property int SocketReceiveTimeout {
    int get ();
    void set (int value);
}
[<ConfigAttribute>]
member SocketReceiveTimeout : int with get, set
[<ConfigAttribute>]
member SocketReceiveTimeout : int with get, set

Property Value

Type: Online Int32
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.SocketSendBufferSize Property

ServerNode SocketSendBufferSize Property NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int SocketSendBufferSize { get; set; }
[ConfigAttribute]
public int SocketSendBufferSize { get; set; }
<ConfigAttribute>
Public Property SocketSendBufferSize As Integer
    Get
    Set
<ConfigAttribute>
Public Property SocketSendBufferSize As Integer
    Get
    Set
public:
[ConfigAttribute]
property int SocketSendBufferSize {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute]
property int SocketSendBufferSize {
    int get ();
    void set (int value);
}
[<ConfigAttribute>]
member SocketSendBufferSize : int with get, set
[<ConfigAttribute>]
member SocketSendBufferSize : int with get, set

Property Value

Type: Online Int32
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.SocketSendTimeout Property

ServerNode SocketSendTimeout Property NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int SocketSendTimeout { get; set; }
[ConfigAttribute]
public int SocketSendTimeout { get; set; }
<ConfigAttribute>
Public Property SocketSendTimeout As Integer
    Get
    Set
<ConfigAttribute>
Public Property SocketSendTimeout As Integer
    Get
    Set
public:
[ConfigAttribute]
property int SocketSendTimeout {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute]
property int SocketSendTimeout {
    int get ();
    void set (int value);
}
[<ConfigAttribute>]
member SocketSendTimeout : int with get, set
[<ConfigAttribute>]
member SocketSendTimeout : int with get, set

Property Value

Type: Online Int32
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


ServerNode.WriteConcern Property

ServerNode WriteConcern Property NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public WriteConcern WriteConcern { get; set; }
[ConfigAttribute]
public WriteConcern WriteConcern { get; set; }
<ConfigAttribute>
Public Property WriteConcern As WriteConcern
    Get
    Set
<ConfigAttribute>
Public Property WriteConcern As WriteConcern
    Get
    Set
public:
[ConfigAttribute]
property WriteConcern WriteConcern {
    WriteConcern get ();
    void set (WriteConcern value);
}
public:
[ConfigAttribute]
property WriteConcern WriteConcern {
    WriteConcern get ();
    void set (WriteConcern value);
}
[<ConfigAttribute>]
member WriteConcern : WriteConcern with get, set
[<ConfigAttribute>]
member WriteConcern : WriteConcern with get, set

Property Value

Type: WriteConcern
See Also
ServerNode Class
ServerNode Members
NFX.DataAccess.MongoDB.Connector Namespace


Update Class

Update Class NFX Class Library

Represents an update document sent to MongoDB
Inheritance Hierarchy
Online System Object
NFX.Serialization.BSON BSONDocument
NFX.DataAccess.MongoDB.Connector Update

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Update : BSONDocument
public class Update : BSONDocument
Public Class Update
    Inherits BSONDocument
Public Class Update
    Inherits BSONDocument
public ref class Update : public BSONDocument
public ref class Update : public BSONDocument
type Update =
    class
        inherit BSONDocument
    end
type Update =
    class
        inherit BSONDocument
    end
See Also
Update Members
NFX.DataAccess.MongoDB.Connector Namespace


Update Members

Update Members NFX Class Library

The Update type exposes the following members.
Constructors
 | Name | Description
Public method | Update | Initializes a new instance of the Update class
Public method | Update(Stream) | Initializes a new instance of the Update class
Public method | Update(String, Boolean, TemplateArg ) | Creates an instance of the update from JSON template with parameters populated from args optionally caching the template internal representation. Do not cache templates that change often
Back to Top
Methods
 | Name | Description
Public method | Delete | Deletes an element by name returning true if it was found and deleted (Inherited from BSONDocument.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Calculates the BSON binary size of this document expressed in bytes (Inherited from BSONDocument.)
Public method | GetEnumerator | (Inherited from BSONDocument.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IndexOfName | Returns index of named BSONElement or -1 if it does not exist (Inherited from BSONDocument.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Set(BSONElement, Int32) | Inserts BSONElement into document (Inherited from BSONDocument.)
Public method | Set(BSONElement, Boolean , Int32) | Inserts BSONElement into document (Inherited from BSONDocument.)
Public method | ToString | (Inherited from BSONDocument.)
Public method | WriteAsBSON | Serializes this document into BSON-format stream (Inherited from BSONDocument.)
Protected method | WriteAsBSONCore | (Inherited from BSONDocument.)
Public method | WriteAsBSONToNewArray | Serializes BSON document to byte[] (Inherited from BSONDocument.)
Public method | WriteAsJSON | Serializes this dosument into a TextWriter - this method is used by JSON serializer(JSONWriter) (Inherited from BSONDocument.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONDocument.)
Public property | Count | Returns the number of BSONElements in this document (Inherited from BSONDocument.)
Public property | Item Int32 | Returns BSONElement by index or null if index is out of bounds (Inherited from BSONDocument.)
Public property | Item String | Returns BSONElement by name or null if not found (Inherited from BSONDocument.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from BSONDocument.)
Back to Top
See Also
Update Class
NFX.DataAccess.MongoDB.Connector Namespace


Update Constructor

Update Constructor NFX Class Library

Overload List
 | Name | Description
Public method | Update | Initializes a new instance of the Update class
Public method | Update(Stream) | Initializes a new instance of the Update class
Public method | Update(String, Boolean, TemplateArg ) | Creates an instance of the update from JSON template with parameters populated from args optionally caching the template internal representation. Do not cache templates that change often
Back to Top
See Also
Update Class
Update Members
NFX.DataAccess.MongoDB.Connector Namespace


Update Constructor

Update Constructor NFX Class Library

Initializes a new instance of the Update class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Update()
public Update()
Public Sub New
Public Sub New
public:
Update()
public:
Update()
new : unit -> Update
new : unit -> Update
See Also
Update Class
Update Members
Update Overload
NFX.DataAccess.MongoDB.Connector Namespace


Update Constructor (Stream)

Update Constructor (Stream) NFX Class Library

Initializes a new instance of the Update class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Update(
    Stream stream
)
public Update(
    Stream stream
)
Public Sub New (
    stream As Stream
)
Public Sub New (
    stream As Stream
)
public:
Update(
    Stream^ stream
)
public:
Update(
    Stream^ stream
)
new :
        stream : Stream -> Update
new :
        stream : Stream -> Update

Parameters

stream
Type: Online System.IO Stream
See Also
Update Class
Update Members
Update Overload
NFX.DataAccess.MongoDB.Connector Namespace


Update Constructor (String, Boolean, TemplateArg[])

Update Constructor (String, Boolean, TemplateArg ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates an instance of the update from JSON template with parameters populated from args optionally caching the template internal representation. Do not cache templates that change often

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Update(
    string template,
    bool cacheTemplate,
    params TemplateArg[] args
)
public Update(
    string template,
    bool cacheTemplate,
    params TemplateArg[] args
)
Public Sub New (
    template As String,
    cacheTemplate As Boolean,
    ParamArray args As TemplateArg()
)
Public Sub New (
    template As String,
    cacheTemplate As Boolean,
    ParamArray args As TemplateArg()
)
public:
Update(
    String^ template,
    bool cacheTemplate,
    ... array<TemplateArg>^ args
)
public:
Update(
    String^ template,
    bool cacheTemplate,
    ... array<TemplateArg>^ args
)
new :
        template : string *
        cacheTemplate : bool *
        args : TemplateArg[] -> Update
new :
        template : string *
        cacheTemplate : bool *
        args : TemplateArg[] -> Update

Parameters

template
Type: Online System String
cacheTemplate
Type: Online System Boolean
args
Type: NFX.Serialization.BSON TemplateArg
See Also
Update Class
Update Members
Update Overload
NFX.DataAccess.MongoDB.Connector Namespace


Update Methods

Update Methods NFX Class Library

The Update type exposes the following members.
Methods
 | Name | Description
Public method | Delete | Deletes an element by name returning true if it was found and deleted (Inherited from BSONDocument.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Calculates the BSON binary size of this document expressed in bytes (Inherited from BSONDocument.)
Public method | GetEnumerator | (Inherited from BSONDocument.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IndexOfName | Returns index of named BSONElement or -1 if it does not exist (Inherited from BSONDocument.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Set(BSONElement, Int32) | Inserts BSONElement into document (Inherited from BSONDocument.)
Public method | Set(BSONElement, Boolean , Int32) | Inserts BSONElement into document (Inherited from BSONDocument.)
Public method | ToString | (Inherited from BSONDocument.)
Public method | WriteAsBSON | Serializes this document into BSON-format stream (Inherited from BSONDocument.)
Protected method | WriteAsBSONCore | (Inherited from BSONDocument.)
Public method | WriteAsBSONToNewArray | Serializes BSON document to byte[] (Inherited from BSONDocument.)
Public method | WriteAsJSON | Serializes this dosument into a TextWriter - this method is used by JSON serializer(JSONWriter) (Inherited from BSONDocument.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from BSONDocument.)
Back to Top
See Also
Update Class
NFX.DataAccess.MongoDB.Connector Namespace


Update Properties

Update Properties NFX Class Library

The Update type exposes the following members.
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONDocument.)
Public property | Count | Returns the number of BSONElements in this document (Inherited from BSONDocument.)
Public property | Item Int32 | Returns BSONElement by index or null if index is out of bounds (Inherited from BSONDocument.)
Public property | Item String | Returns BSONElement by name or null if not found (Inherited from BSONDocument.)
Back to Top
See Also
Update Class
NFX.DataAccess.MongoDB.Connector Namespace


UpdateEntry Structure

UpdateEntry Structure NFX Class Library

Pairs necessary information for updates: query, update documents along with upsert and multi flags

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct UpdateEntry
public struct UpdateEntry
Public Structure UpdateEntry
Public Structure UpdateEntry
public value class UpdateEntry
public value class UpdateEntry
[<SealedAttribute>]
type UpdateEntry =  struct end
[<SealedAttribute>]
type UpdateEntry =  struct end
See Also
UpdateEntry Members
NFX.DataAccess.MongoDB.Connector Namespace


UpdateEntry Members

UpdateEntry Members NFX Class Library

The UpdateEntry type exposes the following members.
Constructors
 | Name | Description
Public method | UpdateEntry | Initializes a new instance of the UpdateEntry class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Multi |
Public field | Query |
Public field | Update |
Public field | Upsert |
Back to Top
See Also
UpdateEntry Structure
NFX.DataAccess.MongoDB.Connector Namespace


UpdateEntry Constructor

UpdateEntry Constructor NFX Class Library

Initializes a new instance of the UpdateEntry class

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public UpdateEntry(
    BSONDocument query,
    BSONDocument update,
    bool multi,
    bool upsert
)
public UpdateEntry(
    BSONDocument query,
    BSONDocument update,
    bool multi,
    bool upsert
)
Public Sub New (
    query As BSONDocument,
    update As BSONDocument,
    multi As Boolean,
    upsert As Boolean
)
Public Sub New (
    query As BSONDocument,
    update As BSONDocument,
    multi As Boolean,
    upsert As Boolean
)
public:
UpdateEntry(
    BSONDocument^ query,
    BSONDocument^ update,
    bool multi,
    bool upsert
)
public:
UpdateEntry(
    BSONDocument^ query,
    BSONDocument^ update,
    bool multi,
    bool upsert
)
new :
        query : BSONDocument *
        update : BSONDocument *
        multi : bool *
        upsert : bool -> UpdateEntry
new :
        query : BSONDocument *
        update : BSONDocument *
        multi : bool *
        upsert : bool -> UpdateEntry

Parameters

query
Type: NFX.Serialization.BSON BSONDocument
update
Type: NFX.Serialization.BSON BSONDocument
multi
Type: Online System Boolean
upsert
Type: Online System Boolean
See Also
UpdateEntry Structure
UpdateEntry Members
NFX.DataAccess.MongoDB.Connector Namespace


UpdateEntry Fields

UpdateEntry Fields NFX Class Library

The UpdateEntry type exposes the following members.
Fields
 | Name | Description
Public field | Multi |
Public field | Query |
Public field | Update |
Public field | Upsert |
Back to Top
See Also
UpdateEntry Structure
NFX.DataAccess.MongoDB.Connector Namespace


UpdateEntry.Multi Field

UpdateEntry Multi Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool Multi
public readonly bool Multi
Public ReadOnly Multi As Boolean
Public ReadOnly Multi As Boolean
public:
initonly bool Multi
public:
initonly bool Multi
val Multi: bool
val Multi: bool

Field Value

Type: Online Boolean
See Also
UpdateEntry Structure
UpdateEntry Members
NFX.DataAccess.MongoDB.Connector Namespace


UpdateEntry.Query Field

UpdateEntry Query Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly BSONDocument Query
public readonly BSONDocument Query
Public ReadOnly Query As BSONDocument
Public ReadOnly Query As BSONDocument
public:
initonly BSONDocument^ Query
public:
initonly BSONDocument^ Query
val Query: BSONDocument
val Query: BSONDocument

Field Value

Type: BSONDocument
See Also
UpdateEntry Structure
UpdateEntry Members
NFX.DataAccess.MongoDB.Connector Namespace


UpdateEntry.Update Field

UpdateEntry Update Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly BSONDocument Update
public readonly BSONDocument Update
Public ReadOnly Update As BSONDocument
Public ReadOnly Update As BSONDocument
public:
initonly BSONDocument^ Update
public:
initonly BSONDocument^ Update
val Update: BSONDocument
val Update: BSONDocument

Field Value

Type: BSONDocument
See Also
UpdateEntry Structure
UpdateEntry Members
NFX.DataAccess.MongoDB.Connector Namespace


UpdateEntry.Upsert Field

UpdateEntry Upsert Field NFX Class Library

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool Upsert
public readonly bool Upsert
Public ReadOnly Upsert As Boolean
Public ReadOnly Upsert As Boolean
public:
initonly bool Upsert
public:
initonly bool Upsert
val Upsert: bool
val Upsert: bool

Field Value

Type: Online Boolean
See Also
UpdateEntry Structure
UpdateEntry Members
NFX.DataAccess.MongoDB.Connector Namespace


UpdateEntry Methods

UpdateEntry Methods NFX Class Library

The UpdateEntry type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
UpdateEntry Structure
NFX.DataAccess.MongoDB.Connector Namespace


WriteConcern Enumeration

WriteConcern Enumeration NFX Class Library

Defines data safety modes http://docs.mongodb.org/manual/core/write-concern/

Namespace: NFX.DataAccess.MongoDB.Connector
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum WriteConcern
public enum WriteConcern
Public Enumeration WriteConcern
Public Enumeration WriteConcern
public enum class WriteConcern
public enum class WriteConcern
type WriteConcern
type WriteConcern
Members
Member name | Value | Description
Unacknowledged | -1 |
Acknowledged | 0 |
Journaled | 1 |
See Also
NFX.DataAccess.MongoDB.Connector Namespace


NFX.DataAccess.MySQL Namespace

NFX.DataAccess.MySQL Namespace NFX Class Library

Provides NFX data access apis for MySQL
Classes
 | Class | Description
Protected class | CRUDGenerator |
Public class | GeneratorUtils | Facilitates various SQL-construction and logging tasks
Public class | MySQLCRUDScriptQueryHandler | Executes MySql CRUD script-based queries
Public class | MySQLCRUDTransaction | Represents MySQL CRUD transaction
Public class | MySQLCursor |
Public class | MySQLDataAccessException | Thrown by MySQL data access classes
Public class | MySQLDataStore | Implements MySQL general data store that auto-generates SQLs for record models and supports CRUD operations. This class IS thread-safe load/save/delete operations
Public class | MySQLDataStoreBase | Implements MySQL store base functionality
Protected class | StringConsts |
Structures
 | Structure | Description
Public structure | MySQLCRUDQueryExecutionContext | Provides query execution environment in MySql context


CRUDGenerator Class

CRUDGenerator Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.DataAccess.MySQL CRUDGenerator

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static class CRUDGenerator
internal static class CRUDGenerator
Friend NotInheritable Class CRUDGenerator
Friend NotInheritable Class CRUDGenerator
internal ref class CRUDGenerator abstract sealed
internal ref class CRUDGenerator abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CRUDGenerator =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CRUDGenerator =  class end
See Also
CRUDGenerator Members
NFX.DataAccess.MySQL Namespace


CRUDGenerator Members

CRUDGenerator Members NFX Class Library

The CRUDGenerator type exposes the following members.
Methods
Name | Description
CLRValueToDB |
ConvertParameters |
CRUDDelete |
CRUDInsert |
CRUDUpdate |
CRUDUpsert |
KeyViolationName |
Back to Top
See Also
CRUDGenerator Class
NFX.DataAccess.MySQL Namespace


CRUDGenerator Methods

CRUDGenerator Methods NFX Class Library

The CRUDGenerator type exposes the following members.
Methods
Name | Description
CLRValueToDB |
ConvertParameters |
CRUDDelete |
CRUDInsert |
CRUDUpdate |
CRUDUpsert |
KeyViolationName |
Back to Top
See Also
CRUDGenerator Class
NFX.DataAccess.MySQL Namespace


CRUDGenerator.CLRValueToDB Method

CRUDGenerator CLRValueToDB Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static Object CLRValueToDB(
    MySQLDataStoreBase store,
    Object value,
    out Nullable<MySqlDbType> convertedDbType
)
internal static Object CLRValueToDB(
    MySQLDataStoreBase store,
    Object value,
    out Nullable<MySqlDbType> convertedDbType
)
Friend Shared Function CLRValueToDB (
    store As MySQLDataStoreBase,
    value As Object,
    <OutAttribute> ByRef convertedDbType As Nullable(Of MySqlDbType)
) As Object
Friend Shared Function CLRValueToDB (
    store As MySQLDataStoreBase,
    value As Object,
    <OutAttribute> ByRef convertedDbType As Nullable(Of MySqlDbType)
) As Object
internal:
static Object^ CLRValueToDB(
    MySQLDataStoreBase^ store,
    Object^ value,
    [OutAttribute] Nullable<MySqlDbType>% convertedDbType
)
internal:
static Object^ CLRValueToDB(
    MySQLDataStoreBase^ store,
    Object^ value,
    [OutAttribute] Nullable<MySqlDbType>% convertedDbType
)
internal static member CLRValueToDB :
        store : MySQLDataStoreBase *
        value : Object *
        convertedDbType : Nullable<MySqlDbType> byref -> Object
internal static member CLRValueToDB :
        store : MySQLDataStoreBase *
        value : Object *
        convertedDbType : Nullable<MySqlDbType> byref -> Object

Parameters

store
Type: NFX.DataAccess.MySQL MySQLDataStoreBase
value
Type: Online System Object
convertedDbType
Type: Online System Nullable MySqlDbType

Return Value

Type: Online Object
See Also
CRUDGenerator Class
CRUDGenerator Members
NFX.DataAccess.MySQL Namespace


CRUDGenerator.ConvertParameters Method

CRUDGenerator ConvertParameters Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static void ConvertParameters(
    MySQLDataStoreBase store,
    MySqlParameterCollection pars
)
internal static void ConvertParameters(
    MySQLDataStoreBase store,
    MySqlParameterCollection pars
)
Friend Shared Sub ConvertParameters (
    store As MySQLDataStoreBase,
    pars As MySqlParameterCollection
)
Friend Shared Sub ConvertParameters (
    store As MySQLDataStoreBase,
    pars As MySqlParameterCollection
)
internal:
static void ConvertParameters(
    MySQLDataStoreBase^ store,
    MySqlParameterCollection^ pars
)
internal:
static void ConvertParameters(
    MySQLDataStoreBase^ store,
    MySqlParameterCollection^ pars
)
internal static member ConvertParameters :
        store : MySQLDataStoreBase *
        pars : MySqlParameterCollection -> unit
internal static member ConvertParameters :
        store : MySQLDataStoreBase *
        pars : MySqlParameterCollection -> unit

Parameters

store
Type: NFX.DataAccess.MySQL MySQLDataStoreBase
pars
Type: MySqlParameterCollection
See Also
CRUDGenerator Class
CRUDGenerator Members
NFX.DataAccess.MySQL Namespace


CRUDGenerator.CRUDDelete Method

CRUDGenerator CRUDDelete Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int CRUDDelete(
    MySQLDataStoreBase store,
    MySqlConnection cnn,
    MySqlTransaction trans,
    Row row,
    IDataStoreKey key
)
public static int CRUDDelete(
    MySQLDataStoreBase store,
    MySqlConnection cnn,
    MySqlTransaction trans,
    Row row,
    IDataStoreKey key
)
Public Shared Function CRUDDelete (
    store As MySQLDataStoreBase,
    cnn As MySqlConnection,
    trans As MySqlTransaction,
    row As Row,
    key As IDataStoreKey
) As Integer
Public Shared Function CRUDDelete (
    store As MySQLDataStoreBase,
    cnn As MySqlConnection,
    trans As MySqlTransaction,
    row As Row,
    key As IDataStoreKey
) As Integer
public:
static int CRUDDelete(
    MySQLDataStoreBase^ store,
    MySqlConnection^ cnn,
    MySqlTransaction^ trans,
    Row^ row,
    IDataStoreKey^ key
)
public:
static int CRUDDelete(
    MySQLDataStoreBase^ store,
    MySqlConnection^ cnn,
    MySqlTransaction^ trans,
    Row^ row,
    IDataStoreKey^ key
)
static member CRUDDelete :
        store : MySQLDataStoreBase *
        cnn : MySqlConnection *
        trans : MySqlTransaction *
        row : Row *
        key : IDataStoreKey -> int
static member CRUDDelete :
        store : MySQLDataStoreBase *
        cnn : MySqlConnection *
        trans : MySqlTransaction *
        row : Row *
        key : IDataStoreKey -> int

Parameters

store
Type: NFX.DataAccess.MySQL MySQLDataStoreBase
cnn
Type: MySqlConnection
trans
Type: MySqlTransaction
row
Type: NFX.DataAccess.CRUD Row
key
Type: NFX.DataAccess IDataStoreKey

Return Value

Type: Online Int32
See Also
CRUDGenerator Class
CRUDGenerator Members
NFX.DataAccess.MySQL Namespace


CRUDGenerator.CRUDInsert Method

CRUDGenerator CRUDInsert Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int CRUDInsert(
    MySQLDataStoreBase store,
    MySqlConnection cnn,
    MySqlTransaction trans,
    Row row,
    FieldFilterFunc filter
)
public static int CRUDInsert(
    MySQLDataStoreBase store,
    MySqlConnection cnn,
    MySqlTransaction trans,
    Row row,
    FieldFilterFunc filter
)
Public Shared Function CRUDInsert (
    store As MySQLDataStoreBase,
    cnn As MySqlConnection,
    trans As MySqlTransaction,
    row As Row,
    filter As FieldFilterFunc
) As Integer
Public Shared Function CRUDInsert (
    store As MySQLDataStoreBase,
    cnn As MySqlConnection,
    trans As MySqlTransaction,
    row As Row,
    filter As FieldFilterFunc
) As Integer
public:
static int CRUDInsert(
    MySQLDataStoreBase^ store,
    MySqlConnection^ cnn,
    MySqlTransaction^ trans,
    Row^ row,
    FieldFilterFunc^ filter
)
public:
static int CRUDInsert(
    MySQLDataStoreBase^ store,
    MySqlConnection^ cnn,
    MySqlTransaction^ trans,
    Row^ row,
    FieldFilterFunc^ filter
)
static member CRUDInsert :
        store : MySQLDataStoreBase *
        cnn : MySqlConnection *
        trans : MySqlTransaction *
        row : Row *
        filter : FieldFilterFunc -> int
static member CRUDInsert :
        store : MySQLDataStoreBase *
        cnn : MySqlConnection *
        trans : MySqlTransaction *
        row : Row *
        filter : FieldFilterFunc -> int

Parameters

store
Type: NFX.DataAccess.MySQL MySQLDataStoreBase
cnn
Type: MySqlConnection
trans
Type: MySqlTransaction
row
Type: NFX.DataAccess.CRUD Row
filter
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32
See Also
CRUDGenerator Class
CRUDGenerator Members
NFX.DataAccess.MySQL Namespace


CRUDGenerator.CRUDUpdate Method

CRUDGenerator CRUDUpdate Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int CRUDUpdate(
    MySQLDataStoreBase store,
    MySqlConnection cnn,
    MySqlTransaction trans,
    Row row,
    IDataStoreKey key,
    FieldFilterFunc filter
)
public static int CRUDUpdate(
    MySQLDataStoreBase store,
    MySqlConnection cnn,
    MySqlTransaction trans,
    Row row,
    IDataStoreKey key,
    FieldFilterFunc filter
)
Public Shared Function CRUDUpdate (
    store As MySQLDataStoreBase,
    cnn As MySqlConnection,
    trans As MySqlTransaction,
    row As Row,
    key As IDataStoreKey,
    filter As FieldFilterFunc
) As Integer
Public Shared Function CRUDUpdate (
    store As MySQLDataStoreBase,
    cnn As MySqlConnection,
    trans As MySqlTransaction,
    row As Row,
    key As IDataStoreKey,
    filter As FieldFilterFunc
) As Integer
public:
static int CRUDUpdate(
    MySQLDataStoreBase^ store,
    MySqlConnection^ cnn,
    MySqlTransaction^ trans,
    Row^ row,
    IDataStoreKey^ key,
    FieldFilterFunc^ filter
)
public:
static int CRUDUpdate(
    MySQLDataStoreBase^ store,
    MySqlConnection^ cnn,
    MySqlTransaction^ trans,
    Row^ row,
    IDataStoreKey^ key,
    FieldFilterFunc^ filter
)
static member CRUDUpdate :
        store : MySQLDataStoreBase *
        cnn : MySqlConnection *
        trans : MySqlTransaction *
        row : Row *
        key : IDataStoreKey *
        filter : FieldFilterFunc -> int
static member CRUDUpdate :
        store : MySQLDataStoreBase *
        cnn : MySqlConnection *
        trans : MySqlTransaction *
        row : Row *
        key : IDataStoreKey *
        filter : FieldFilterFunc -> int

Parameters

store
Type: NFX.DataAccess.MySQL MySQLDataStoreBase
cnn
Type: MySqlConnection
trans
Type: MySqlTransaction
row
Type: NFX.DataAccess.CRUD Row
key
Type: NFX.DataAccess IDataStoreKey
filter
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32
See Also
CRUDGenerator Class
CRUDGenerator Members
NFX.DataAccess.MySQL Namespace


CRUDGenerator.CRUDUpsert Method

CRUDGenerator CRUDUpsert Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int CRUDUpsert(
    MySQLDataStoreBase store,
    MySqlConnection cnn,
    MySqlTransaction trans,
    Row row,
    FieldFilterFunc filter
)
public static int CRUDUpsert(
    MySQLDataStoreBase store,
    MySqlConnection cnn,
    MySqlTransaction trans,
    Row row,
    FieldFilterFunc filter
)
Public Shared Function CRUDUpsert (
    store As MySQLDataStoreBase,
    cnn As MySqlConnection,
    trans As MySqlTransaction,
    row As Row,
    filter As FieldFilterFunc
) As Integer
Public Shared Function CRUDUpsert (
    store As MySQLDataStoreBase,
    cnn As MySqlConnection,
    trans As MySqlTransaction,
    row As Row,
    filter As FieldFilterFunc
) As Integer
public:
static int CRUDUpsert(
    MySQLDataStoreBase^ store,
    MySqlConnection^ cnn,
    MySqlTransaction^ trans,
    Row^ row,
    FieldFilterFunc^ filter
)
public:
static int CRUDUpsert(
    MySQLDataStoreBase^ store,
    MySqlConnection^ cnn,
    MySqlTransaction^ trans,
    Row^ row,
    FieldFilterFunc^ filter
)
static member CRUDUpsert :
        store : MySQLDataStoreBase *
        cnn : MySqlConnection *
        trans : MySqlTransaction *
        row : Row *
        filter : FieldFilterFunc -> int
static member CRUDUpsert :
        store : MySQLDataStoreBase *
        cnn : MySqlConnection *
        trans : MySqlTransaction *
        row : Row *
        filter : FieldFilterFunc -> int

Parameters

store
Type: NFX.DataAccess.MySQL MySQLDataStoreBase
cnn
Type: MySqlConnection
trans
Type: MySqlTransaction
row
Type: NFX.DataAccess.CRUD Row
filter
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32
See Also
CRUDGenerator Class
CRUDGenerator Members
NFX.DataAccess.MySQL Namespace


CRUDGenerator.KeyViolationName Method

CRUDGenerator KeyViolationName Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static string KeyViolationName(
    Exception error
)
internal static string KeyViolationName(
    Exception error
)
Friend Shared Function KeyViolationName (
    error As Exception
) As String
Friend Shared Function KeyViolationName (
    error As Exception
) As String
internal:
static String^ KeyViolationName(
    Exception^ error
)
internal:
static String^ KeyViolationName(
    Exception^ error
)
internal static member KeyViolationName :
        error : Exception -> string
internal static member KeyViolationName :
        error : Exception -> string

Parameters

error
Type: Online System Exception

Return Value

Type: Online String
See Also
CRUDGenerator Class
CRUDGenerator Members
NFX.DataAccess.MySQL Namespace


GeneratorUtils Class

GeneratorUtils Class NFX Class Library

Facilitates various SQL-construction and logging tasks
Inheritance Hierarchy
Online System Object
NFX.DataAccess.MySQL GeneratorUtils

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class GeneratorUtils
public static class GeneratorUtils
Public NotInheritable Class GeneratorUtils
Public NotInheritable Class GeneratorUtils
public ref class GeneratorUtils abstract sealed
public ref class GeneratorUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GeneratorUtils =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GeneratorUtils =  class end
See Also
GeneratorUtils Members
NFX.DataAccess.MySQL Namespace


GeneratorUtils Members

GeneratorUtils Members NFX Class Library

The GeneratorUtils type exposes the following members.
Methods
Name | Description
HasFieldInNamedKey |
KeyToWhere |
LogCommand |
Back to Top
See Also
GeneratorUtils Class
NFX.DataAccess.MySQL Namespace


GeneratorUtils Methods

GeneratorUtils Methods NFX Class Library

The GeneratorUtils type exposes the following members.
Methods
Name | Description
HasFieldInNamedKey |
KeyToWhere |
LogCommand |
Back to Top
See Also
GeneratorUtils Class
NFX.DataAccess.MySQL Namespace


GeneratorUtils.HasFieldInNamedKey Method

GeneratorUtils HasFieldInNamedKey Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool HasFieldInNamedKey(
    string fieldName,
    IDataStoreKey key
)
public static bool HasFieldInNamedKey(
    string fieldName,
    IDataStoreKey key
)
Public Shared Function HasFieldInNamedKey (
    fieldName As String,
    key As IDataStoreKey
) As Boolean
Public Shared Function HasFieldInNamedKey (
    fieldName As String,
    key As IDataStoreKey
) As Boolean
public:
static bool HasFieldInNamedKey(
    String^ fieldName,
    IDataStoreKey^ key
)
public:
static bool HasFieldInNamedKey(
    String^ fieldName,
    IDataStoreKey^ key
)
static member HasFieldInNamedKey :
        fieldName : string *
        key : IDataStoreKey -> bool
static member HasFieldInNamedKey :
        fieldName : string *
        key : IDataStoreKey -> bool

Parameters

fieldName
Type: Online System String
key
Type: NFX.DataAccess IDataStoreKey

Return Value

Type: Online Boolean
See Also
GeneratorUtils Class
GeneratorUtils Members
NFX.DataAccess.MySQL Namespace


GeneratorUtils.KeyToWhere Method

GeneratorUtils KeyToWhere Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string KeyToWhere(
    IDataStoreKey key,
    MySqlParameterCollection parameters
)
public static string KeyToWhere(
    IDataStoreKey key,
    MySqlParameterCollection parameters
)
Public Shared Function KeyToWhere (
    key As IDataStoreKey,
    parameters As MySqlParameterCollection
) As String
Public Shared Function KeyToWhere (
    key As IDataStoreKey,
    parameters As MySqlParameterCollection
) As String
public:
static String^ KeyToWhere(
    IDataStoreKey^ key,
    MySqlParameterCollection^ parameters
)
public:
static String^ KeyToWhere(
    IDataStoreKey^ key,
    MySqlParameterCollection^ parameters
)
static member KeyToWhere :
        key : IDataStoreKey *
        parameters : MySqlParameterCollection -> string
static member KeyToWhere :
        key : IDataStoreKey *
        parameters : MySqlParameterCollection -> string

Parameters

key
Type: NFX.DataAccess IDataStoreKey
parameters
Type: MySqlParameterCollection

Return Value

Type: Online String
See Also
GeneratorUtils Class
GeneratorUtils Members
NFX.DataAccess.MySQL Namespace


GeneratorUtils.LogCommand Method

GeneratorUtils LogCommand Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void LogCommand(
    StoreLogLevel level,
    string from,
    MySqlCommand cmd,
    Exception error
)
public static void LogCommand(
    StoreLogLevel level,
    string from,
    MySqlCommand cmd,
    Exception error
)
Public Shared Sub LogCommand (
    level As StoreLogLevel,
    from As String,
    cmd As MySqlCommand,
    error As Exception
)
Public Shared Sub LogCommand (
    level As StoreLogLevel,
    from As String,
    cmd As MySqlCommand,
    error As Exception
)
public:
static void LogCommand(
    StoreLogLevel level,
    String^ from,
    MySqlCommand^ cmd,
    Exception^ error
)
public:
static void LogCommand(
    StoreLogLevel level,
    String^ from,
    MySqlCommand^ cmd,
    Exception^ error
)
static member LogCommand :
        level : StoreLogLevel *
        from : string *
        cmd : MySqlCommand *
        error : Exception -> unit
static member LogCommand :
        level : StoreLogLevel *
        from : string *
        cmd : MySqlCommand *
        error : Exception -> unit

Parameters

level
Type: NFX.DataAccess StoreLogLevel
from
Type: Online System String
cmd
Type: MySqlCommand
error
Type: Online System Exception
See Also
GeneratorUtils Class
GeneratorUtils Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDQueryExecutionContext Structure

MySQLCRUDQueryExecutionContext Structure NFX Class Library

Provides query execution environment in MySql context

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct MySQLCRUDQueryExecutionContext : ICRUDQueryExecutionContext
public struct MySQLCRUDQueryExecutionContext : ICRUDQueryExecutionContext
Public Structure MySQLCRUDQueryExecutionContext
    Implements ICRUDQueryExecutionContext
Public Structure MySQLCRUDQueryExecutionContext
    Implements ICRUDQueryExecutionContext
public value class MySQLCRUDQueryExecutionContext : ICRUDQueryExecutionContext
public value class MySQLCRUDQueryExecutionContext : ICRUDQueryExecutionContext
[<SealedAttribute>]
type MySQLCRUDQueryExecutionContext =
    struct
        interface ICRUDQueryExecutionContext
    end
[<SealedAttribute>]
type MySQLCRUDQueryExecutionContext =
    struct
        interface ICRUDQueryExecutionContext
    end
See Also
MySQLCRUDQueryExecutionContext Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDQueryExecutionContext Members

MySQLCRUDQueryExecutionContext Members NFX Class Library

The MySQLCRUDQueryExecutionContext type exposes the following members.
Constructors
 | Name | Description
Public method | MySQLCRUDQueryExecutionContext | Initializes a new instance of the MySQLCRUDQueryExecutionContext class
Back to Top
Methods
 | Name | Description
Public method | CLRValueToDB | Based on store settings, converts CLR value to MySQL-acceptable value, i.e. GDID -> BYTE[].
Public method | ConvertParameters | Based on store settings, converts query parameters into MySQL-acceptable values, i.e. GDID -> BYTe[]. This function is not idempotent
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Connection |
Public field | DataStore |
Public field | Transaction |
Back to Top
See Also
MySQLCRUDQueryExecutionContext Structure
NFX.DataAccess.MySQL Namespace


MySQLCRUDQueryExecutionContext Constructor

MySQLCRUDQueryExecutionContext Constructor NFX Class Library

Initializes a new instance of the MySQLCRUDQueryExecutionContext class

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MySQLCRUDQueryExecutionContext(
    MySQLDataStoreBase store,
    MySqlConnection cnn,
    MySqlTransaction trans
)
public MySQLCRUDQueryExecutionContext(
    MySQLDataStoreBase store,
    MySqlConnection cnn,
    MySqlTransaction trans
)
Public Sub New (
    store As MySQLDataStoreBase,
    cnn As MySqlConnection,
    trans As MySqlTransaction
)
Public Sub New (
    store As MySQLDataStoreBase,
    cnn As MySqlConnection,
    trans As MySqlTransaction
)
public:
MySQLCRUDQueryExecutionContext(
    MySQLDataStoreBase^ store,
    MySqlConnection^ cnn,
    MySqlTransaction^ trans
)
public:
MySQLCRUDQueryExecutionContext(
    MySQLDataStoreBase^ store,
    MySqlConnection^ cnn,
    MySqlTransaction^ trans
)
new :
        store : MySQLDataStoreBase *
        cnn : MySqlConnection *
        trans : MySqlTransaction -> MySQLCRUDQueryExecutionContext
new :
        store : MySQLDataStoreBase *
        cnn : MySqlConnection *
        trans : MySqlTransaction -> MySQLCRUDQueryExecutionContext

Parameters

store
Type: NFX.DataAccess.MySQL MySQLDataStoreBase
cnn
Type: MySqlConnection
trans
Type: MySqlTransaction
See Also
MySQLCRUDQueryExecutionContext Structure
MySQLCRUDQueryExecutionContext Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDQueryExecutionContext Fields

MySQLCRUDQueryExecutionContext Fields NFX Class Library

The MySQLCRUDQueryExecutionContext type exposes the following members.
Fields
 | Name | Description
Public field | Connection |
Public field | DataStore |
Public field | Transaction |
Back to Top
See Also
MySQLCRUDQueryExecutionContext Structure
NFX.DataAccess.MySQL Namespace


MySQLCRUDQueryExecutionContext.Connection Field

MySQLCRUDQueryExecutionContext Connection Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly MySqlConnection Connection
public readonly MySqlConnection Connection
Public ReadOnly Connection As MySqlConnection
Public ReadOnly Connection As MySqlConnection
public:
initonly MySqlConnection^ Connection
public:
initonly MySqlConnection^ Connection
val Connection: MySqlConnection
val Connection: MySqlConnection

Field Value

Type: MySqlConnection
See Also
MySQLCRUDQueryExecutionContext Structure
MySQLCRUDQueryExecutionContext Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDQueryExecutionContext.DataStore Field

MySQLCRUDQueryExecutionContext DataStore Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly MySQLDataStoreBase DataStore
public readonly MySQLDataStoreBase DataStore
Public ReadOnly DataStore As MySQLDataStoreBase
Public ReadOnly DataStore As MySQLDataStoreBase
public:
initonly MySQLDataStoreBase^ DataStore
public:
initonly MySQLDataStoreBase^ DataStore
val DataStore: MySQLDataStoreBase
val DataStore: MySQLDataStoreBase

Field Value

Type: MySQLDataStoreBase
See Also
MySQLCRUDQueryExecutionContext Structure
MySQLCRUDQueryExecutionContext Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDQueryExecutionContext.Transaction Field

MySQLCRUDQueryExecutionContext Transaction Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly MySqlTransaction Transaction
public readonly MySqlTransaction Transaction
Public ReadOnly Transaction As MySqlTransaction
Public ReadOnly Transaction As MySqlTransaction
public:
initonly MySqlTransaction^ Transaction
public:
initonly MySqlTransaction^ Transaction
val Transaction: MySqlTransaction
val Transaction: MySqlTransaction

Field Value

Type: MySqlTransaction
See Also
MySQLCRUDQueryExecutionContext Structure
MySQLCRUDQueryExecutionContext Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDQueryExecutionContext Methods

MySQLCRUDQueryExecutionContext Methods NFX Class Library

The MySQLCRUDQueryExecutionContext type exposes the following members.
Methods
 | Name | Description
Public method | CLRValueToDB | Based on store settings, converts CLR value to MySQL-acceptable value, i.e. GDID -> BYTE[].
Public method | ConvertParameters | Based on store settings, converts query parameters into MySQL-acceptable values, i.e. GDID -> BYTe[]. This function is not idempotent
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MySQLCRUDQueryExecutionContext Structure
NFX.DataAccess.MySQL Namespace


MySQLCRUDQueryExecutionContext.CLRValueToDB Method

MySQLCRUDQueryExecutionContext CLRValueToDB Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Based on store settings, converts CLR value to MySQL-acceptable value, i.e. GDID -> BYTE[].

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object CLRValueToDB(
    MySQLDataStoreBase store,
    Object value,
    out Nullable<MySqlDbType> convertedDbType
)
public Object CLRValueToDB(
    MySQLDataStoreBase store,
    Object value,
    out Nullable<MySqlDbType> convertedDbType
)
Public Function CLRValueToDB (
    store As MySQLDataStoreBase,
    value As Object,
    <OutAttribute> ByRef convertedDbType As Nullable(Of MySqlDbType)
) As Object
Public Function CLRValueToDB (
    store As MySQLDataStoreBase,
    value As Object,
    <OutAttribute> ByRef convertedDbType As Nullable(Of MySqlDbType)
) As Object
public:
Object^ CLRValueToDB(
    MySQLDataStoreBase^ store,
    Object^ value,
    [OutAttribute] Nullable<MySqlDbType>% convertedDbType
)
public:
Object^ CLRValueToDB(
    MySQLDataStoreBase^ store,
    Object^ value,
    [OutAttribute] Nullable<MySqlDbType>% convertedDbType
)
member CLRValueToDB :
        store : MySQLDataStoreBase *
        value : Object *
        convertedDbType : Nullable<MySqlDbType> byref -> Object
member CLRValueToDB :
        store : MySQLDataStoreBase *
        value : Object *
        convertedDbType : Nullable<MySqlDbType> byref -> Object

Parameters

store
Type: NFX.DataAccess.MySQL MySQLDataStoreBase
value
Type: Online System Object
convertedDbType
Type: Online System Nullable MySqlDbType

Return Value

Type: Online Object
See Also
MySQLCRUDQueryExecutionContext Structure
MySQLCRUDQueryExecutionContext Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDQueryExecutionContext.ConvertParameters Method

MySQLCRUDQueryExecutionContext ConvertParameters Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Based on store settings, converts query parameters into MySQL-acceptable values, i.e. GDID -> BYTe[]. This function is not idempotent

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ConvertParameters(
    MySqlParameterCollection pars
)
public void ConvertParameters(
    MySqlParameterCollection pars
)
Public Sub ConvertParameters (
    pars As MySqlParameterCollection
)
Public Sub ConvertParameters (
    pars As MySqlParameterCollection
)
public:
void ConvertParameters(
    MySqlParameterCollection^ pars
)
public:
void ConvertParameters(
    MySqlParameterCollection^ pars
)
member ConvertParameters :
        pars : MySqlParameterCollection -> unit
member ConvertParameters :
        pars : MySqlParameterCollection -> unit

Parameters

pars
Type: MySqlParameterCollection
See Also
MySQLCRUDQueryExecutionContext Structure
MySQLCRUDQueryExecutionContext Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDScriptQueryHandler Class

MySQLCRUDScriptQueryHandler Class NFX Class Library

Executes MySql CRUD script-based queries
Inheritance Hierarchy
Online System Object
NFX.DataAccess.CRUD CRUDQueryHandler
NFX.DataAccess.CRUD CRUDQueryHandler MySQLDataStore
NFX.DataAccess.MySQL MySQLCRUDScriptQueryHandler

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class MySQLCRUDScriptQueryHandler : CRUDQueryHandler<MySQLDataStore>
public sealed class MySQLCRUDScriptQueryHandler : CRUDQueryHandler<MySQLDataStore>
Public NotInheritable Class MySQLCRUDScriptQueryHandler
    Inherits CRUDQueryHandler(Of MySQLDataStore)
Public NotInheritable Class MySQLCRUDScriptQueryHandler
    Inherits CRUDQueryHandler(Of MySQLDataStore)
public ref class MySQLCRUDScriptQueryHandler sealed : public CRUDQueryHandler<MySQLDataStore^>
public ref class MySQLCRUDScriptQueryHandler sealed : public CRUDQueryHandler<MySQLDataStore^>
[<SealedAttribute>]
type MySQLCRUDScriptQueryHandler =
    class
        inherit CRUDQueryHandler<MySQLDataStore>
    end
[<SealedAttribute>]
type MySQLCRUDScriptQueryHandler =
    class
        inherit CRUDQueryHandler<MySQLDataStore>
    end
See Also
MySQLCRUDScriptQueryHandler Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDScriptQueryHandler Members

MySQLCRUDScriptQueryHandler Members NFX Class Library

The MySQLCRUDScriptQueryHandler type exposes the following members.
Constructors
 | Name | Description
Public method | MySQLCRUDScriptQueryHandler | Initializes a new instance of the MySQLCRUDScriptQueryHandler class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Execute | (Overrides CRUDQueryHandler Execute(ICRUDQueryExecutionContext, Query, Boolean).)
Public method | ExecuteAsync | (Overrides CRUDQueryHandler ExecuteAsync(ICRUDQueryExecutionContext, Query, Boolean).)
Public method | ExecuteWithoutFetch | (Overrides CRUDQueryHandler ExecuteWithoutFetch(ICRUDQueryExecutionContext, Query).)
Public method | ExecuteWithoutFetchAsync | (Overrides CRUDQueryHandler ExecuteWithoutFetchAsync(ICRUDQueryExecutionContext, Query).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSchema | (Overrides CRUDQueryHandler GetSchema(ICRUDQueryExecutionContext, Query).)
Public method | GetSchemaAsync | (Overrides CRUDQueryHandler GetSchemaAsync(ICRUDQueryExecutionContext, Query).)
 | GetSchemaForQuery | Gets schema from reader taking Query.ResultRowType in consideration
 | GetSchemaFromReader | Gets CRUD schema from MySqlReader per particular QuerySource. If source is null then all columns from reader are copied. Note: this code was purposely made provider specific because other providers may treat some nuances differently
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenCursor | (Overrides CRUDQueryHandler OpenCursor(ICRUDQueryExecutionContext, Query).)
Public method | OpenCursorAsync | (Overrides CRUDQueryHandler OpenCursorAsync(ICRUDQueryExecutionContext, Query).)
Public method | PopulateParameters | Populates MySqlCommand with parameters from CRUD Query object Note: this code was purposely made provider specific because other providers may treat some nuances differently
 | PopulateRow | Reads data from reader into rowset. the reader is NOT disposed
 | PopulateRowset | Reads data from reader into rowset. the reader is NOT disposed
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | Source | (Inherited from CRUDQueryHandler.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns query name that this handler handles (Inherited from CRUDQueryHandler.)
Public property | Store | Store instance that handler is under (Inherited from CRUDQueryHandler TStore .)
Back to Top
See Also
MySQLCRUDScriptQueryHandler Class
NFX.DataAccess.MySQL Namespace


MySQLCRUDScriptQueryHandler Constructor

MySQLCRUDScriptQueryHandler Constructor NFX Class Library

Initializes a new instance of the MySQLCRUDScriptQueryHandler class

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MySQLCRUDScriptQueryHandler(
    MySQLDataStore store,
    QuerySource source
)
public MySQLCRUDScriptQueryHandler(
    MySQLDataStore store,
    QuerySource source
)
Public Sub New (
    store As MySQLDataStore,
    source As QuerySource
)
Public Sub New (
    store As MySQLDataStore,
    source As QuerySource
)
public:
MySQLCRUDScriptQueryHandler(
    MySQLDataStore^ store,
    QuerySource^ source
)
public:
MySQLCRUDScriptQueryHandler(
    MySQLDataStore^ store,
    QuerySource^ source
)
new :
        store : MySQLDataStore *
        source : QuerySource -> MySQLCRUDScriptQueryHandler
new :
        store : MySQLDataStore *
        source : QuerySource -> MySQLCRUDScriptQueryHandler

Parameters

store
Type: NFX.DataAccess.MySQL MySQLDataStore
source
Type: NFX.DataAccess.CRUD QuerySource
See Also
MySQLCRUDScriptQueryHandler Class
MySQLCRUDScriptQueryHandler Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDScriptQueryHandler Fields

MySQLCRUDScriptQueryHandler Fields NFX Class Library

The MySQLCRUDScriptQueryHandler type exposes the following members.
Fields
 | Name | Description
Protected field | Source | (Inherited from CRUDQueryHandler.)
Back to Top
See Also
MySQLCRUDScriptQueryHandler Class
NFX.DataAccess.MySQL Namespace


MySQLCRUDScriptQueryHandler Methods

MySQLCRUDScriptQueryHandler Methods NFX Class Library

The MySQLCRUDScriptQueryHandler type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Execute | (Overrides CRUDQueryHandler Execute(ICRUDQueryExecutionContext, Query, Boolean).)
Public method | ExecuteAsync | (Overrides CRUDQueryHandler ExecuteAsync(ICRUDQueryExecutionContext, Query, Boolean).)
Public method | ExecuteWithoutFetch | (Overrides CRUDQueryHandler ExecuteWithoutFetch(ICRUDQueryExecutionContext, Query).)
Public method | ExecuteWithoutFetchAsync | (Overrides CRUDQueryHandler ExecuteWithoutFetchAsync(ICRUDQueryExecutionContext, Query).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSchema | (Overrides CRUDQueryHandler GetSchema(ICRUDQueryExecutionContext, Query).)
Public method | GetSchemaAsync | (Overrides CRUDQueryHandler GetSchemaAsync(ICRUDQueryExecutionContext, Query).)
 | GetSchemaForQuery | Gets schema from reader taking Query.ResultRowType in consideration
 | GetSchemaFromReader | Gets CRUD schema from MySqlReader per particular QuerySource. If source is null then all columns from reader are copied. Note: this code was purposely made provider specific because other providers may treat some nuances differently
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenCursor | (Overrides CRUDQueryHandler OpenCursor(ICRUDQueryExecutionContext, Query).)
Public method | OpenCursorAsync | (Overrides CRUDQueryHandler OpenCursorAsync(ICRUDQueryExecutionContext, Query).)
Public method | PopulateParameters | Populates MySqlCommand with parameters from CRUD Query object Note: this code was purposely made provider specific because other providers may treat some nuances differently
 | PopulateRow | Reads data from reader into rowset. the reader is NOT disposed
 | PopulateRowset | Reads data from reader into rowset. the reader is NOT disposed
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MySQLCRUDScriptQueryHandler Class
NFX.DataAccess.MySQL Namespace


MySQLCRUDScriptQueryHandler.Execute Method

MySQLCRUDScriptQueryHandler Execute Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override RowsetBase Execute(
    ICRUDQueryExecutionContext context,
    Query query,
    bool oneRow = false
)
public override RowsetBase Execute(
    ICRUDQueryExecutionContext context,
    Query query,
    bool oneRow = false
)
Public Overrides Function Execute (
    context As ICRUDQueryExecutionContext,
    query As Query,
    Optional oneRow As Boolean = false
) As RowsetBase
Public Overrides Function Execute (
    context As ICRUDQueryExecutionContext,
    query As Query,
    Optional oneRow As Boolean = false
) As RowsetBase
public:
virtual RowsetBase^ Execute(
    ICRUDQueryExecutionContext^ context,
    Query^ query,
    bool oneRow = false
) override
public:
virtual RowsetBase^ Execute(
    ICRUDQueryExecutionContext^ context,
    Query^ query,
    bool oneRow = false
) override
abstract Execute :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> RowsetBase
override Execute :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> RowsetBase
abstract Execute :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> RowsetBase
override Execute :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> RowsetBase

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query
oneRow (Optional)
Type: Online System Boolean

Return Value

Type: RowsetBase
See Also
MySQLCRUDScriptQueryHandler Class
MySQLCRUDScriptQueryHandler Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDScriptQueryHandler.ExecuteAsync Method

MySQLCRUDScriptQueryHandler ExecuteAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Task<RowsetBase> ExecuteAsync(
    ICRUDQueryExecutionContext context,
    Query query,
    bool oneRow = false
)
public override Task<RowsetBase> ExecuteAsync(
    ICRUDQueryExecutionContext context,
    Query query,
    bool oneRow = false
)
Public Overrides Function ExecuteAsync (
    context As ICRUDQueryExecutionContext,
    query As Query,
    Optional oneRow As Boolean = false
) As Task(Of RowsetBase)
Public Overrides Function ExecuteAsync (
    context As ICRUDQueryExecutionContext,
    query As Query,
    Optional oneRow As Boolean = false
) As Task(Of RowsetBase)
public:
virtual Task<RowsetBase^>^ ExecuteAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query,
    bool oneRow = false
) override
public:
virtual Task<RowsetBase^>^ ExecuteAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query,
    bool oneRow = false
) override
abstract ExecuteAsync :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> Task<RowsetBase>
override ExecuteAsync :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> Task<RowsetBase>
abstract ExecuteAsync :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> Task<RowsetBase>
override ExecuteAsync :
        context : ICRUDQueryExecutionContext *
        query : Query *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> Task<RowsetBase>

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query
oneRow (Optional)
Type: Online System Boolean

Return Value

Type: Online Task RowsetBase
See Also
MySQLCRUDScriptQueryHandler Class
MySQLCRUDScriptQueryHandler Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDScriptQueryHandler.ExecuteWithoutFetch Method

MySQLCRUDScriptQueryHandler ExecuteWithoutFetch Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int ExecuteWithoutFetch(
    ICRUDQueryExecutionContext context,
    Query query
)
public override int ExecuteWithoutFetch(
    ICRUDQueryExecutionContext context,
    Query query
)
Public Overrides Function ExecuteWithoutFetch (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Integer
Public Overrides Function ExecuteWithoutFetch (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Integer
public:
virtual int ExecuteWithoutFetch(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
public:
virtual int ExecuteWithoutFetch(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
abstract ExecuteWithoutFetch :
        context : ICRUDQueryExecutionContext *
        query : Query -> int
override ExecuteWithoutFetch :
        context : ICRUDQueryExecutionContext *
        query : Query -> int
abstract ExecuteWithoutFetch :
        context : ICRUDQueryExecutionContext *
        query : Query -> int
override ExecuteWithoutFetch :
        context : ICRUDQueryExecutionContext *
        query : Query -> int

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Int32
See Also
MySQLCRUDScriptQueryHandler Class
MySQLCRUDScriptQueryHandler Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDScriptQueryHandler.ExecuteWithoutFetchAsync Method

MySQLCRUDScriptQueryHandler ExecuteWithoutFetchAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Task<int> ExecuteWithoutFetchAsync(
    ICRUDQueryExecutionContext context,
    Query query
)
public override Task<int> ExecuteWithoutFetchAsync(
    ICRUDQueryExecutionContext context,
    Query query
)
Public Overrides Function ExecuteWithoutFetchAsync (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Task(Of Integer)
Public Overrides Function ExecuteWithoutFetchAsync (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Task(Of Integer)
public:
virtual Task<int>^ ExecuteWithoutFetchAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
public:
virtual Task<int>^ ExecuteWithoutFetchAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
abstract ExecuteWithoutFetchAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<int>
override ExecuteWithoutFetchAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<int>
abstract ExecuteWithoutFetchAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<int>
override ExecuteWithoutFetchAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<int>

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Online Int32
See Also
MySQLCRUDScriptQueryHandler Class
MySQLCRUDScriptQueryHandler Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDScriptQueryHandler.GetSchema Method

MySQLCRUDScriptQueryHandler GetSchema Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Schema GetSchema(
    ICRUDQueryExecutionContext context,
    Query query
)
public override Schema GetSchema(
    ICRUDQueryExecutionContext context,
    Query query
)
Public Overrides Function GetSchema (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Schema
Public Overrides Function GetSchema (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Schema
public:
virtual Schema^ GetSchema(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
public:
virtual Schema^ GetSchema(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
abstract GetSchema :
        context : ICRUDQueryExecutionContext *
        query : Query -> Schema
override GetSchema :
        context : ICRUDQueryExecutionContext *
        query : Query -> Schema
abstract GetSchema :
        context : ICRUDQueryExecutionContext *
        query : Query -> Schema
override GetSchema :
        context : ICRUDQueryExecutionContext *
        query : Query -> Schema

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Schema
See Also
MySQLCRUDScriptQueryHandler Class
MySQLCRUDScriptQueryHandler Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDScriptQueryHandler.GetSchemaAsync Method

MySQLCRUDScriptQueryHandler GetSchemaAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Task<Schema> GetSchemaAsync(
    ICRUDQueryExecutionContext context,
    Query query
)
public override Task<Schema> GetSchemaAsync(
    ICRUDQueryExecutionContext context,
    Query query
)
Public Overrides Function GetSchemaAsync (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Task(Of Schema)
Public Overrides Function GetSchemaAsync (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Task(Of Schema)
public:
virtual Task<Schema^>^ GetSchemaAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
public:
virtual Task<Schema^>^ GetSchemaAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
abstract GetSchemaAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Schema>
override GetSchemaAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Schema>
abstract GetSchemaAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Schema>
override GetSchemaAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Schema>

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Schema
See Also
MySQLCRUDScriptQueryHandler Class
MySQLCRUDScriptQueryHandler Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDScriptQueryHandler.GetSchemaForQuery Method

MySQLCRUDScriptQueryHandler GetSchemaForQuery Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets schema from reader taking Query.ResultRowType in consideration

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Schema GetSchemaForQuery(
    string target,
    Query query,
    MySqlDataReader reader,
    QuerySource qSource,
    out Schema..::..FieldDef[] toLoad
)
public static Schema GetSchemaForQuery(
    string target,
    Query query,
    MySqlDataReader reader,
    QuerySource qSource,
    out Schema..::..FieldDef[] toLoad
)
Public Shared Function GetSchemaForQuery (
    target As String,
    query As Query,
    reader As MySqlDataReader,
    qSource As QuerySource,
    <OutAttribute> ByRef toLoad As Schema..::..FieldDef()
) As Schema
Public Shared Function GetSchemaForQuery (
    target As String,
    query As Query,
    reader As MySqlDataReader,
    qSource As QuerySource,
    <OutAttribute> ByRef toLoad As Schema..::..FieldDef()
) As Schema
public:
static Schema^ GetSchemaForQuery(
    String^ target,
    Query^ query,
    MySqlDataReader^ reader,
    QuerySource^ qSource,
    [OutAttribute] array<Schema..::..FieldDef^>^% toLoad
)
public:
static Schema^ GetSchemaForQuery(
    String^ target,
    Query^ query,
    MySqlDataReader^ reader,
    QuerySource^ qSource,
    [OutAttribute] array<Schema..::..FieldDef^>^% toLoad
)
static member GetSchemaForQuery :
        target : string *
        query : Query *
        reader : MySqlDataReader *
        qSource : QuerySource *
        toLoad : Schema..::..FieldDef[] byref -> Schema
static member GetSchemaForQuery :
        target : string *
        query : Query *
        reader : MySqlDataReader *
        qSource : QuerySource *
        toLoad : Schema..::..FieldDef[] byref -> Schema

Parameters

target
Type: Online System String
query
Type: NFX.DataAccess.CRUD Query
reader
Type: MySqlDataReader
qSource
Type: NFX.DataAccess.CRUD QuerySource
toLoad
Type: NFX.DataAccess.CRUD Schema FieldDef

Return Value

Type: Schema
See Also
MySQLCRUDScriptQueryHandler Class
MySQLCRUDScriptQueryHandler Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDScriptQueryHandler.GetSchemaFromReader Method

MySQLCRUDScriptQueryHandler GetSchemaFromReader Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets CRUD schema from MySqlReader per particular QuerySource. If source is null then all columns from reader are copied. Note: this code was purposely made provider specific because other providers may treat some nuances differently

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Schema GetSchemaFromReader(
    string name,
    QuerySource source,
    MySqlDataReader reader
)
public static Schema GetSchemaFromReader(
    string name,
    QuerySource source,
    MySqlDataReader reader
)
Public Shared Function GetSchemaFromReader (
    name As String,
    source As QuerySource,
    reader As MySqlDataReader
) As Schema
Public Shared Function GetSchemaFromReader (
    name As String,
    source As QuerySource,
    reader As MySqlDataReader
) As Schema
public:
static Schema^ GetSchemaFromReader(
    String^ name,
    QuerySource^ source,
    MySqlDataReader^ reader
)
public:
static Schema^ GetSchemaFromReader(
    String^ name,
    QuerySource^ source,
    MySqlDataReader^ reader
)
static member GetSchemaFromReader :
        name : string *
        source : QuerySource *
        reader : MySqlDataReader -> Schema
static member GetSchemaFromReader :
        name : string *
        source : QuerySource *
        reader : MySqlDataReader -> Schema

Parameters

name
Type: Online System String
source
Type: NFX.DataAccess.CRUD QuerySource
reader
Type: MySqlDataReader

Return Value

Type: Schema
See Also
MySQLCRUDScriptQueryHandler Class
MySQLCRUDScriptQueryHandler Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDScriptQueryHandler.OpenCursor Method

MySQLCRUDScriptQueryHandler OpenCursor Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Cursor OpenCursor(
    ICRUDQueryExecutionContext context,
    Query query
)
public override Cursor OpenCursor(
    ICRUDQueryExecutionContext context,
    Query query
)
Public Overrides Function OpenCursor (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Cursor
Public Overrides Function OpenCursor (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Cursor
public:
virtual Cursor^ OpenCursor(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
public:
virtual Cursor^ OpenCursor(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
abstract OpenCursor :
        context : ICRUDQueryExecutionContext *
        query : Query -> Cursor
override OpenCursor :
        context : ICRUDQueryExecutionContext *
        query : Query -> Cursor
abstract OpenCursor :
        context : ICRUDQueryExecutionContext *
        query : Query -> Cursor
override OpenCursor :
        context : ICRUDQueryExecutionContext *
        query : Query -> Cursor

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Cursor
See Also
MySQLCRUDScriptQueryHandler Class
MySQLCRUDScriptQueryHandler Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDScriptQueryHandler.OpenCursorAsync Method

MySQLCRUDScriptQueryHandler OpenCursorAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Task<Cursor> OpenCursorAsync(
    ICRUDQueryExecutionContext context,
    Query query
)
public override Task<Cursor> OpenCursorAsync(
    ICRUDQueryExecutionContext context,
    Query query
)
Public Overrides Function OpenCursorAsync (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Task(Of Cursor)
Public Overrides Function OpenCursorAsync (
    context As ICRUDQueryExecutionContext,
    query As Query
) As Task(Of Cursor)
public:
virtual Task<Cursor^>^ OpenCursorAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
public:
virtual Task<Cursor^>^ OpenCursorAsync(
    ICRUDQueryExecutionContext^ context,
    Query^ query
) override
abstract OpenCursorAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Cursor>
override OpenCursorAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Cursor>
abstract OpenCursorAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Cursor>
override OpenCursorAsync :
        context : ICRUDQueryExecutionContext *
        query : Query -> Task<Cursor>

Parameters

context
Type: NFX.DataAccess.CRUD ICRUDQueryExecutionContext
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Cursor
See Also
MySQLCRUDScriptQueryHandler Class
MySQLCRUDScriptQueryHandler Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDScriptQueryHandler.PopulateParameters Method

MySQLCRUDScriptQueryHandler PopulateParameters Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Populates MySqlCommand with parameters from CRUD Query object Note: this code was purposely made provider specific because other providers may treat some nuances differently

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void PopulateParameters(
    MySqlCommand cmd,
    Query query
)
public void PopulateParameters(
    MySqlCommand cmd,
    Query query
)
Public Sub PopulateParameters (
    cmd As MySqlCommand,
    query As Query
)
Public Sub PopulateParameters (
    cmd As MySqlCommand,
    query As Query
)
public:
void PopulateParameters(
    MySqlCommand^ cmd,
    Query^ query
)
public:
void PopulateParameters(
    MySqlCommand^ cmd,
    Query^ query
)
member PopulateParameters :
        cmd : MySqlCommand *
        query : Query -> unit
member PopulateParameters :
        cmd : MySqlCommand *
        query : Query -> unit

Parameters

cmd
Type: MySqlCommand
query
Type: NFX.DataAccess.CRUD Query
See Also
MySQLCRUDScriptQueryHandler Class
MySQLCRUDScriptQueryHandler Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDScriptQueryHandler.PopulateRow Method

MySQLCRUDScriptQueryHandler PopulateRow Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Reads data from reader into rowset. the reader is NOT disposed

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Row PopulateRow(
    MySQLCRUDQueryExecutionContext context,
    Type tRow,
    Schema schema,
    Schema..::..FieldDef[] toLoad,
    MySqlDataReader reader
)
public static Row PopulateRow(
    MySQLCRUDQueryExecutionContext context,
    Type tRow,
    Schema schema,
    Schema..::..FieldDef[] toLoad,
    MySqlDataReader reader
)
Public Shared Function PopulateRow (
    context As MySQLCRUDQueryExecutionContext,
    tRow As Type,
    schema As Schema,
    toLoad As Schema..::..FieldDef(),
    reader As MySqlDataReader
) As Row
Public Shared Function PopulateRow (
    context As MySQLCRUDQueryExecutionContext,
    tRow As Type,
    schema As Schema,
    toLoad As Schema..::..FieldDef(),
    reader As MySqlDataReader
) As Row
public:
static Row^ PopulateRow(
    MySQLCRUDQueryExecutionContext context,
    Type^ tRow,
    Schema^ schema,
    array<Schema..::..FieldDef^>^ toLoad,
    MySqlDataReader^ reader
)
public:
static Row^ PopulateRow(
    MySQLCRUDQueryExecutionContext context,
    Type^ tRow,
    Schema^ schema,
    array<Schema..::..FieldDef^>^ toLoad,
    MySqlDataReader^ reader
)
static member PopulateRow :
        context : MySQLCRUDQueryExecutionContext *
        tRow : Type *
        schema : Schema *
        toLoad : Schema..::..FieldDef[] *
        reader : MySqlDataReader -> Row
static member PopulateRow :
        context : MySQLCRUDQueryExecutionContext *
        tRow : Type *
        schema : Schema *
        toLoad : Schema..::..FieldDef[] *
        reader : MySqlDataReader -> Row

Parameters

context
Type: NFX.DataAccess.MySQL MySQLCRUDQueryExecutionContext
tRow
Type: Online System Type
schema
Type: NFX.DataAccess.CRUD Schema
toLoad
Type: NFX.DataAccess.CRUD Schema FieldDef
reader
Type: MySqlDataReader

Return Value

Type: Row
See Also
MySQLCRUDScriptQueryHandler Class
MySQLCRUDScriptQueryHandler Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDScriptQueryHandler.PopulateRowset Method

MySQLCRUDScriptQueryHandler PopulateRowset Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Reads data from reader into rowset. the reader is NOT disposed

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Rowset PopulateRowset(
    MySQLCRUDQueryExecutionContext context,
    MySqlDataReader reader,
    string target,
    Query query,
    QuerySource qSource,
    bool oneRow
)
public static Rowset PopulateRowset(
    MySQLCRUDQueryExecutionContext context,
    MySqlDataReader reader,
    string target,
    Query query,
    QuerySource qSource,
    bool oneRow
)
Public Shared Function PopulateRowset (
    context As MySQLCRUDQueryExecutionContext,
    reader As MySqlDataReader,
    target As String,
    query As Query,
    qSource As QuerySource,
    oneRow As Boolean
) As Rowset
Public Shared Function PopulateRowset (
    context As MySQLCRUDQueryExecutionContext,
    reader As MySqlDataReader,
    target As String,
    query As Query,
    qSource As QuerySource,
    oneRow As Boolean
) As Rowset
public:
static Rowset^ PopulateRowset(
    MySQLCRUDQueryExecutionContext context,
    MySqlDataReader^ reader,
    String^ target,
    Query^ query,
    QuerySource^ qSource,
    bool oneRow
)
public:
static Rowset^ PopulateRowset(
    MySQLCRUDQueryExecutionContext context,
    MySqlDataReader^ reader,
    String^ target,
    Query^ query,
    QuerySource^ qSource,
    bool oneRow
)
static member PopulateRowset :
        context : MySQLCRUDQueryExecutionContext *
        reader : MySqlDataReader *
        target : string *
        query : Query *
        qSource : QuerySource *
        oneRow : bool -> Rowset
static member PopulateRowset :
        context : MySQLCRUDQueryExecutionContext *
        reader : MySqlDataReader *
        target : string *
        query : Query *
        qSource : QuerySource *
        oneRow : bool -> Rowset

Parameters

context
Type: NFX.DataAccess.MySQL MySQLCRUDQueryExecutionContext
reader
Type: MySqlDataReader
target
Type: Online System String
query
Type: NFX.DataAccess.CRUD Query
qSource
Type: NFX.DataAccess.CRUD QuerySource
oneRow
Type: Online System Boolean

Return Value

Type: Rowset
See Also
MySQLCRUDScriptQueryHandler Class
MySQLCRUDScriptQueryHandler Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDScriptQueryHandler Properties

MySQLCRUDScriptQueryHandler Properties NFX Class Library

The MySQLCRUDScriptQueryHandler type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns query name that this handler handles (Inherited from CRUDQueryHandler.)
Public property | Store | Store instance that handler is under (Inherited from CRUDQueryHandler TStore .)
Back to Top
See Also
MySQLCRUDScriptQueryHandler Class
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction Class

MySQLCRUDTransaction Class NFX Class Library

Represents MySQL CRUD transaction
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.DataAccess.CRUD CRUDTransaction
NFX.DataAccess.MySQL MySQLCRUDTransaction

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class MySQLCRUDTransaction : CRUDTransaction
public sealed class MySQLCRUDTransaction : CRUDTransaction
Public NotInheritable Class MySQLCRUDTransaction
    Inherits CRUDTransaction
Public NotInheritable Class MySQLCRUDTransaction
    Inherits CRUDTransaction
public ref class MySQLCRUDTransaction sealed : public CRUDTransaction
public ref class MySQLCRUDTransaction sealed : public CRUDTransaction
[<SealedAttribute>]
type MySQLCRUDTransaction =
    class
        inherit CRUDTransaction
    end
[<SealedAttribute>]
type MySQLCRUDTransaction =
    class
        inherit CRUDTransaction
    end
See Also
MySQLCRUDTransaction Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction Members

MySQLCRUDTransaction Members NFX Class Library

The MySQLCRUDTransaction type exposes the following members.
Constructors
 | Name | Description
Protected method | MySQLCRUDTransaction | Initializes a new instance of the MySQLCRUDTransaction class
Back to Top
Methods
 | Name | Description
Protected method | CheckOpenStatus | (Inherited from CRUDTransaction.)
Public method | Commit | (Inherited from CRUDTransaction.)
Public method | Delete | (Inherited from CRUDTransaction.)
Public method | DeleteAsync | (Inherited from CRUDTransaction.)
Protected method | Destructor | (Overrides CRUDTransaction Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoCommit | (Overrides CRUDTransaction DoCommit .)
Protected method | DoDelete | (Overrides CRUDTransaction DoDelete(Row, IDataStoreKey).)
Protected method | DoDeleteAsync | (Overrides CRUDTransaction DoDeleteAsync(Row, IDataStoreKey).)
Protected method | DoExecuteWithoutFetch | (Overrides CRUDTransaction DoExecuteWithoutFetch( Query ).)
Protected method | DoExecuteWithoutFetchAsync | (Overrides CRUDTransaction DoExecuteWithoutFetchAsync( Query ).)
Protected method | DoGetSchema | (Overrides CRUDTransaction DoGetSchema(Query).)
Protected method | DoGetSchemaAsync | (Overrides CRUDTransaction DoGetSchemaAsync(Query).)
Protected method | DoInsert | (Overrides CRUDTransaction DoInsert(Row, FieldFilterFunc).)
Protected method | DoInsertAsync | (Overrides CRUDTransaction DoInsertAsync(Row, FieldFilterFunc).)
Protected method | DoLoad | (Overrides CRUDTransaction DoLoad(Boolean, Query ).)
Protected method | DoLoadAsync | (Overrides CRUDTransaction DoLoadAsync(Boolean, Query ).)
Protected method | DoOpenCursor | (Overrides CRUDTransaction DoOpenCursor(Query).)
Protected method | DoOpenCursorAsync | (Overrides CRUDTransaction DoOpenCursorAsync(Query).)
Protected method | DoRollback | (Overrides CRUDTransaction DoRollback .)
Protected method | DoSave | (Overrides CRUDTransaction DoSave( RowsetBase ).)
Protected method | DoSaveAsync | (Overrides CRUDTransaction DoSaveAsync( RowsetBase ).)
Protected method | DoUpdate | (Overrides CRUDTransaction DoUpdate(Row, IDataStoreKey, FieldFilterFunc).)
Protected method | DoUpdateAsync | (Overrides CRUDTransaction DoUpdateAsync(Row, IDataStoreKey, FieldFilterFunc).)
Protected method | DoUpsert | (Overrides CRUDTransaction DoUpsert(Row, FieldFilterFunc).)
Protected method | DoUpsertAsync | (Overrides CRUDTransaction DoUpsertAsync(Row, FieldFilterFunc).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExecuteWithoutFetch | (Inherited from CRUDTransaction.)
Public method | ExecuteWithoutFetchAsync | (Inherited from CRUDTransaction.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSchema | (Inherited from CRUDTransaction.)
Public method | GetSchemaAsync | (Inherited from CRUDTransaction.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Insert | (Inherited from CRUDTransaction.)
Public method | InsertAsync | (Inherited from CRUDTransaction.)
Public method | Load | (Inherited from CRUDTransaction.)
Public method | LoadAsync | (Inherited from CRUDTransaction.)
Public method | LoadOneRow | (Inherited from CRUDTransaction.)
Public method | LoadOneRowAsync | (Inherited from CRUDTransaction.)
Public method | LoadOneRowset | (Inherited from CRUDTransaction.)
Public method | LoadOneRowsetAsync | (Inherited from CRUDTransaction.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenCursor | (Inherited from CRUDTransaction.)
Public method | OpenCursorAsync | (Inherited from CRUDTransaction.)
Public method | Rollback | (Inherited from CRUDTransaction.)
Public method | Save | (Inherited from CRUDTransaction.)
Public method | SaveAsync | (Inherited from CRUDTransaction.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Update | (Inherited from CRUDTransaction.)
Public method | UpdateAsync | (Inherited from CRUDTransaction.)
Public method | Upsert | (Inherited from CRUDTransaction.)
Public method | UpsertAsync | (Inherited from CRUDTransaction.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Store | (Inherited from CRUDTransaction.)
Back to Top
Properties
 | Name | Description
Public property | Connection | Returns the underlying MySQL connection that this transaction works through
Public property | DataStore | References the store instance that started this transaction (Inherited from CRUDTransaction.)
Public property | DisposeBehavior | Specifies how transaction should be finalized on dispose: comitted or rolledback if it is still open (Inherited from CRUDTransaction.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Status | Returns current transaction status (Inherited from CRUDTransaction.)
Protected property | Store |
Public property | SupportsTrueAsynchrony | Returns true when backend supports true asynchronous operations, such as the ones that do not create extra threads/empty tasks (Inherited from CRUDTransaction.)
Public property | Transaction | Returns the underlying MySQL transaction that this instance represents. Do not call Commit/Rollback method on this property directly
Back to Top
See Also
MySQLCRUDTransaction Class
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction Constructor

MySQLCRUDTransaction Constructor NFX Class Library

Initializes a new instance of the MySQLCRUDTransaction class

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal MySQLCRUDTransaction(
    MySQLDataStore store,
    MySqlConnection cnn,
    IsolationLevel iso,
    TransactionDisposeBehavior disposeBehavior
)
internal MySQLCRUDTransaction(
    MySQLDataStore store,
    MySqlConnection cnn,
    IsolationLevel iso,
    TransactionDisposeBehavior disposeBehavior
)
Friend Sub New (
    store As MySQLDataStore,
    cnn As MySqlConnection,
    iso As IsolationLevel,
    disposeBehavior As TransactionDisposeBehavior
)
Friend Sub New (
    store As MySQLDataStore,
    cnn As MySqlConnection,
    iso As IsolationLevel,
    disposeBehavior As TransactionDisposeBehavior
)
internal:
MySQLCRUDTransaction(
    MySQLDataStore^ store,
    MySqlConnection^ cnn,
    IsolationLevel iso,
    TransactionDisposeBehavior disposeBehavior
)
internal:
MySQLCRUDTransaction(
    MySQLDataStore^ store,
    MySqlConnection^ cnn,
    IsolationLevel iso,
    TransactionDisposeBehavior disposeBehavior
)
new :
        store : MySQLDataStore *
        cnn : MySqlConnection *
        iso : IsolationLevel *
        disposeBehavior : TransactionDisposeBehavior -> MySQLCRUDTransaction
new :
        store : MySQLDataStore *
        cnn : MySqlConnection *
        iso : IsolationLevel *
        disposeBehavior : TransactionDisposeBehavior -> MySQLCRUDTransaction

Parameters

store
Type: NFX.DataAccess.MySQL MySQLDataStore
cnn
Type: MySqlConnection
iso
Type: Online System.Data IsolationLevel
disposeBehavior
Type: NFX.DataAccess.CRUD TransactionDisposeBehavior
See Also
MySQLCRUDTransaction Class
MySQLCRUDTransaction Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction Fields

MySQLCRUDTransaction Fields NFX Class Library

The MySQLCRUDTransaction type exposes the following members.
Fields
 | Name | Description
Protected field | m_Store | (Inherited from CRUDTransaction.)
Back to Top
See Also
MySQLCRUDTransaction Class
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction Methods

MySQLCRUDTransaction Methods NFX Class Library

The MySQLCRUDTransaction type exposes the following members.
Methods
 | Name | Description
Protected method | CheckOpenStatus | (Inherited from CRUDTransaction.)
Public method | Commit | (Inherited from CRUDTransaction.)
Public method | Delete | (Inherited from CRUDTransaction.)
Public method | DeleteAsync | (Inherited from CRUDTransaction.)
Protected method | Destructor | (Overrides CRUDTransaction Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoCommit | (Overrides CRUDTransaction DoCommit .)
Protected method | DoDelete | (Overrides CRUDTransaction DoDelete(Row, IDataStoreKey).)
Protected method | DoDeleteAsync | (Overrides CRUDTransaction DoDeleteAsync(Row, IDataStoreKey).)
Protected method | DoExecuteWithoutFetch | (Overrides CRUDTransaction DoExecuteWithoutFetch( Query ).)
Protected method | DoExecuteWithoutFetchAsync | (Overrides CRUDTransaction DoExecuteWithoutFetchAsync( Query ).)
Protected method | DoGetSchema | (Overrides CRUDTransaction DoGetSchema(Query).)
Protected method | DoGetSchemaAsync | (Overrides CRUDTransaction DoGetSchemaAsync(Query).)
Protected method | DoInsert | (Overrides CRUDTransaction DoInsert(Row, FieldFilterFunc).)
Protected method | DoInsertAsync | (Overrides CRUDTransaction DoInsertAsync(Row, FieldFilterFunc).)
Protected method | DoLoad | (Overrides CRUDTransaction DoLoad(Boolean, Query ).)
Protected method | DoLoadAsync | (Overrides CRUDTransaction DoLoadAsync(Boolean, Query ).)
Protected method | DoOpenCursor | (Overrides CRUDTransaction DoOpenCursor(Query).)
Protected method | DoOpenCursorAsync | (Overrides CRUDTransaction DoOpenCursorAsync(Query).)
Protected method | DoRollback | (Overrides CRUDTransaction DoRollback .)
Protected method | DoSave | (Overrides CRUDTransaction DoSave( RowsetBase ).)
Protected method | DoSaveAsync | (Overrides CRUDTransaction DoSaveAsync( RowsetBase ).)
Protected method | DoUpdate | (Overrides CRUDTransaction DoUpdate(Row, IDataStoreKey, FieldFilterFunc).)
Protected method | DoUpdateAsync | (Overrides CRUDTransaction DoUpdateAsync(Row, IDataStoreKey, FieldFilterFunc).)
Protected method | DoUpsert | (Overrides CRUDTransaction DoUpsert(Row, FieldFilterFunc).)
Protected method | DoUpsertAsync | (Overrides CRUDTransaction DoUpsertAsync(Row, FieldFilterFunc).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExecuteWithoutFetch | (Inherited from CRUDTransaction.)
Public method | ExecuteWithoutFetchAsync | (Inherited from CRUDTransaction.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSchema | (Inherited from CRUDTransaction.)
Public method | GetSchemaAsync | (Inherited from CRUDTransaction.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Insert | (Inherited from CRUDTransaction.)
Public method | InsertAsync | (Inherited from CRUDTransaction.)
Public method | Load | (Inherited from CRUDTransaction.)
Public method | LoadAsync | (Inherited from CRUDTransaction.)
Public method | LoadOneRow | (Inherited from CRUDTransaction.)
Public method | LoadOneRowAsync | (Inherited from CRUDTransaction.)
Public method | LoadOneRowset | (Inherited from CRUDTransaction.)
Public method | LoadOneRowsetAsync | (Inherited from CRUDTransaction.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenCursor | (Inherited from CRUDTransaction.)
Public method | OpenCursorAsync | (Inherited from CRUDTransaction.)
Public method | Rollback | (Inherited from CRUDTransaction.)
Public method | Save | (Inherited from CRUDTransaction.)
Public method | SaveAsync | (Inherited from CRUDTransaction.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Update | (Inherited from CRUDTransaction.)
Public method | UpdateAsync | (Inherited from CRUDTransaction.)
Public method | Upsert | (Inherited from CRUDTransaction.)
Public method | UpsertAsync | (Inherited from CRUDTransaction.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MySQLCRUDTransaction Class
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction.Destructor Method

MySQLCRUDTransaction Destructor Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
MySQLCRUDTransaction Class
MySQLCRUDTransaction Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction.DoCommit Method

MySQLCRUDTransaction DoCommit Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoCommit()
protected override void DoCommit()
Protected Overrides Sub DoCommit
Protected Overrides Sub DoCommit
protected:
virtual void DoCommit() override
protected:
virtual void DoCommit() override
abstract DoCommit : unit -> unit
override DoCommit : unit -> unit
abstract DoCommit : unit -> unit
override DoCommit : unit -> unit
See Also
MySQLCRUDTransaction Class
MySQLCRUDTransaction Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction.DoDelete Method

MySQLCRUDTransaction DoDelete Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override int DoDelete(
    Row row,
    IDataStoreKey key
)
protected override int DoDelete(
    Row row,
    IDataStoreKey key
)
Protected Overrides Function DoDelete (
    row As Row,
    key As IDataStoreKey
) As Integer
Protected Overrides Function DoDelete (
    row As Row,
    key As IDataStoreKey
) As Integer
protected:
virtual int DoDelete(
    Row^ row,
    IDataStoreKey^ key
) override
protected:
virtual int DoDelete(
    Row^ row,
    IDataStoreKey^ key
) override
abstract DoDelete :
        row : Row *
        key : IDataStoreKey -> int
override DoDelete :
        row : Row *
        key : IDataStoreKey -> int
abstract DoDelete :
        row : Row *
        key : IDataStoreKey -> int
override DoDelete :
        row : Row *
        key : IDataStoreKey -> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
key
Type: NFX.DataAccess IDataStoreKey

Return Value

Type: Online Int32
See Also
MySQLCRUDTransaction Class
MySQLCRUDTransaction Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction.DoDeleteAsync Method

MySQLCRUDTransaction DoDeleteAsync Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Task<int> DoDeleteAsync(
    Row row,
    IDataStoreKey key
)
protected override Task<int> DoDeleteAsync(
    Row row,
    IDataStoreKey key
)
Protected Overrides Function DoDeleteAsync (
    row As Row,
    key As IDataStoreKey
) As Task(Of Integer)
Protected Overrides Function DoDeleteAsync (
    row As Row,
    key As IDataStoreKey
) As Task(Of Integer)
protected:
virtual Task<int>^ DoDeleteAsync(
    Row^ row,
    IDataStoreKey^ key
) override
protected:
virtual Task<int>^ DoDeleteAsync(
    Row^ row,
    IDataStoreKey^ key
) override
abstract DoDeleteAsync :
        row : Row *
        key : IDataStoreKey -> Task<int>
override DoDeleteAsync :
        row : Row *
        key : IDataStoreKey -> Task<int>
abstract DoDeleteAsync :
        row : Row *
        key : IDataStoreKey -> Task<int>
override DoDeleteAsync :
        row : Row *
        key : IDataStoreKey -> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
key
Type: NFX.DataAccess IDataStoreKey

Return Value

Type: Online Task Online Int32
See Also
MySQLCRUDTransaction Class
MySQLCRUDTransaction Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction.DoExecuteWithoutFetch Method

MySQLCRUDTransaction DoExecuteWithoutFetch Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override int DoExecuteWithoutFetch(
    params Query[] queries
)
protected override int DoExecuteWithoutFetch(
    params Query[] queries
)
Protected Overrides Function DoExecuteWithoutFetch (
    ParamArray queries As Query()
) As Integer
Protected Overrides Function DoExecuteWithoutFetch (
    ParamArray queries As Query()
) As Integer
protected:
virtual int DoExecuteWithoutFetch(
    ... array<Query^>^ queries
) override
protected:
virtual int DoExecuteWithoutFetch(
    ... array<Query^>^ queries
) override
abstract DoExecuteWithoutFetch :
        queries : Query[] -> int
override DoExecuteWithoutFetch :
        queries : Query[] -> int
abstract DoExecuteWithoutFetch :
        queries : Query[] -> int
override DoExecuteWithoutFetch :
        queries : Query[] -> int

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Int32
See Also
MySQLCRUDTransaction Class
MySQLCRUDTransaction Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction.DoExecuteWithoutFetchAsync Method

MySQLCRUDTransaction DoExecuteWithoutFetchAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Task<int> DoExecuteWithoutFetchAsync(
    params Query[] queries
)
protected override Task<int> DoExecuteWithoutFetchAsync(
    params Query[] queries
)
Protected Overrides Function DoExecuteWithoutFetchAsync (
    ParamArray queries As Query()
) As Task(Of Integer)
Protected Overrides Function DoExecuteWithoutFetchAsync (
    ParamArray queries As Query()
) As Task(Of Integer)
protected:
virtual Task<int>^ DoExecuteWithoutFetchAsync(
    ... array<Query^>^ queries
) override
protected:
virtual Task<int>^ DoExecuteWithoutFetchAsync(
    ... array<Query^>^ queries
) override
abstract DoExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>
override DoExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>
abstract DoExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>
override DoExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Online Int32
See Also
MySQLCRUDTransaction Class
MySQLCRUDTransaction Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction.DoGetSchema Method

MySQLCRUDTransaction DoGetSchema Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Schema DoGetSchema(
    Query query
)
protected override Schema DoGetSchema(
    Query query
)
Protected Overrides Function DoGetSchema (
    query As Query
) As Schema
Protected Overrides Function DoGetSchema (
    query As Query
) As Schema
protected:
virtual Schema^ DoGetSchema(
    Query^ query
) override
protected:
virtual Schema^ DoGetSchema(
    Query^ query
) override
abstract DoGetSchema :
        query : Query -> Schema
override DoGetSchema :
        query : Query -> Schema
abstract DoGetSchema :
        query : Query -> Schema
override DoGetSchema :
        query : Query -> Schema

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Schema
See Also
MySQLCRUDTransaction Class
MySQLCRUDTransaction Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction.DoGetSchemaAsync Method

MySQLCRUDTransaction DoGetSchemaAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Task<Schema> DoGetSchemaAsync(
    Query query
)
protected override Task<Schema> DoGetSchemaAsync(
    Query query
)
Protected Overrides Function DoGetSchemaAsync (
    query As Query
) As Task(Of Schema)
Protected Overrides Function DoGetSchemaAsync (
    query As Query
) As Task(Of Schema)
protected:
virtual Task<Schema^>^ DoGetSchemaAsync(
    Query^ query
) override
protected:
virtual Task<Schema^>^ DoGetSchemaAsync(
    Query^ query
) override
abstract DoGetSchemaAsync :
        query : Query -> Task<Schema>
override DoGetSchemaAsync :
        query : Query -> Task<Schema>
abstract DoGetSchemaAsync :
        query : Query -> Task<Schema>
override DoGetSchemaAsync :
        query : Query -> Task<Schema>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Schema
See Also
MySQLCRUDTransaction Class
MySQLCRUDTransaction Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction.DoInsert Method

MySQLCRUDTransaction DoInsert Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override int DoInsert(
    Row row,
    FieldFilterFunc filter = null
)
protected override int DoInsert(
    Row row,
    FieldFilterFunc filter = null
)
Protected Overrides Function DoInsert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Protected Overrides Function DoInsert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
protected:
virtual int DoInsert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) override
protected:
virtual int DoInsert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) override
abstract DoInsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override DoInsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
abstract DoInsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override DoInsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32
See Also
MySQLCRUDTransaction Class
MySQLCRUDTransaction Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction.DoInsertAsync Method

MySQLCRUDTransaction DoInsertAsync Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Task<int> DoInsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
protected override Task<int> DoInsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
Protected Overrides Function DoInsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
Protected Overrides Function DoInsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
protected:
virtual Task<int>^ DoInsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) override
protected:
virtual Task<int>^ DoInsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) override
abstract DoInsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
override DoInsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
abstract DoInsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
override DoInsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Task Online Int32
See Also
MySQLCRUDTransaction Class
MySQLCRUDTransaction Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction.DoLoad Method

MySQLCRUDTransaction DoLoad Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override List<RowsetBase> DoLoad(
    bool oneRow,
    params Query[] queries
)
protected override List<RowsetBase> DoLoad(
    bool oneRow,
    params Query[] queries
)
Protected Overrides Function DoLoad (
    oneRow As Boolean,
    ParamArray queries As Query()
) As List(Of RowsetBase)
Protected Overrides Function DoLoad (
    oneRow As Boolean,
    ParamArray queries As Query()
) As List(Of RowsetBase)
protected:
virtual List<RowsetBase^>^ DoLoad(
    bool oneRow,
    ... array<Query^>^ queries
) override
protected:
virtual List<RowsetBase^>^ DoLoad(
    bool oneRow,
    ... array<Query^>^ queries
) override
abstract DoLoad :
        oneRow : bool *
        queries : Query[] -> List<RowsetBase>
override DoLoad :
        oneRow : bool *
        queries : Query[] -> List<RowsetBase>
abstract DoLoad :
        oneRow : bool *
        queries : Query[] -> List<RowsetBase>
override DoLoad :
        oneRow : bool *
        queries : Query[] -> List<RowsetBase>

Parameters

oneRow
Type: Online System Boolean
queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online List RowsetBase
See Also
MySQLCRUDTransaction Class
MySQLCRUDTransaction Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction.DoLoadAsync Method

MySQLCRUDTransaction DoLoadAsync Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Task<List<RowsetBase>> DoLoadAsync(
    bool oneRow,
    params Query[] queries
)
protected override Task<List<RowsetBase>> DoLoadAsync(
    bool oneRow,
    params Query[] queries
)
Protected Overrides Function DoLoadAsync (
    oneRow As Boolean,
    ParamArray queries As Query()
) As Task(Of List(Of RowsetBase))
Protected Overrides Function DoLoadAsync (
    oneRow As Boolean,
    ParamArray queries As Query()
) As Task(Of List(Of RowsetBase))
protected:
virtual Task<List<RowsetBase^>^>^ DoLoadAsync(
    bool oneRow,
    ... array<Query^>^ queries
) override
protected:
virtual Task<List<RowsetBase^>^>^ DoLoadAsync(
    bool oneRow,
    ... array<Query^>^ queries
) override
abstract DoLoadAsync :
        oneRow : bool *
        queries : Query[] -> Task<List<RowsetBase>>
override DoLoadAsync :
        oneRow : bool *
        queries : Query[] -> Task<List<RowsetBase>>
abstract DoLoadAsync :
        oneRow : bool *
        queries : Query[] -> Task<List<RowsetBase>>
override DoLoadAsync :
        oneRow : bool *
        queries : Query[] -> Task<List<RowsetBase>>

Parameters

oneRow
Type: Online System Boolean
queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Online List RowsetBase
See Also
MySQLCRUDTransaction Class
MySQLCRUDTransaction Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction.DoOpenCursor Method

MySQLCRUDTransaction DoOpenCursor Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Cursor DoOpenCursor(
    Query query
)
protected override Cursor DoOpenCursor(
    Query query
)
Protected Overrides Function DoOpenCursor (
    query As Query
) As Cursor
Protected Overrides Function DoOpenCursor (
    query As Query
) As Cursor
protected:
virtual Cursor^ DoOpenCursor(
    Query^ query
) override
protected:
virtual Cursor^ DoOpenCursor(
    Query^ query
) override
abstract DoOpenCursor :
        query : Query -> Cursor
override DoOpenCursor :
        query : Query -> Cursor
abstract DoOpenCursor :
        query : Query -> Cursor
override DoOpenCursor :
        query : Query -> Cursor

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Cursor
See Also
MySQLCRUDTransaction Class
MySQLCRUDTransaction Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction.DoOpenCursorAsync Method

MySQLCRUDTransaction DoOpenCursorAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Task<Cursor> DoOpenCursorAsync(
    Query query
)
protected override Task<Cursor> DoOpenCursorAsync(
    Query query
)
Protected Overrides Function DoOpenCursorAsync (
    query As Query
) As Task(Of Cursor)
Protected Overrides Function DoOpenCursorAsync (
    query As Query
) As Task(Of Cursor)
protected:
virtual Task<Cursor^>^ DoOpenCursorAsync(
    Query^ query
) override
protected:
virtual Task<Cursor^>^ DoOpenCursorAsync(
    Query^ query
) override
abstract DoOpenCursorAsync :
        query : Query -> Task<Cursor>
override DoOpenCursorAsync :
        query : Query -> Task<Cursor>
abstract DoOpenCursorAsync :
        query : Query -> Task<Cursor>
override DoOpenCursorAsync :
        query : Query -> Task<Cursor>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Cursor
See Also
MySQLCRUDTransaction Class
MySQLCRUDTransaction Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction.DoRollback Method

MySQLCRUDTransaction DoRollback Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoRollback()
protected override void DoRollback()
Protected Overrides Sub DoRollback
Protected Overrides Sub DoRollback
protected:
virtual void DoRollback() override
protected:
virtual void DoRollback() override
abstract DoRollback : unit -> unit
override DoRollback : unit -> unit
abstract DoRollback : unit -> unit
override DoRollback : unit -> unit
See Also
MySQLCRUDTransaction Class
MySQLCRUDTransaction Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction.DoSave Method

MySQLCRUDTransaction DoSave Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override int DoSave(
    params RowsetBase[] rowsets
)
protected override int DoSave(
    params RowsetBase[] rowsets
)
Protected Overrides Function DoSave (
    ParamArray rowsets As RowsetBase()
) As Integer
Protected Overrides Function DoSave (
    ParamArray rowsets As RowsetBase()
) As Integer
protected:
virtual int DoSave(
    ... array<RowsetBase^>^ rowsets
) override
protected:
virtual int DoSave(
    ... array<RowsetBase^>^ rowsets
) override
abstract DoSave :
        rowsets : RowsetBase[] -> int
override DoSave :
        rowsets : RowsetBase[] -> int
abstract DoSave :
        rowsets : RowsetBase[] -> int
override DoSave :
        rowsets : RowsetBase[] -> int

Parameters

rowsets
Type: NFX.DataAccess.CRUD RowsetBase

Return Value

Type: Online Int32
See Also
MySQLCRUDTransaction Class
MySQLCRUDTransaction Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction.DoSaveAsync Method

MySQLCRUDTransaction DoSaveAsync Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Task<int> DoSaveAsync(
    params RowsetBase[] rowsets
)
protected override Task<int> DoSaveAsync(
    params RowsetBase[] rowsets
)
Protected Overrides Function DoSaveAsync (
    ParamArray rowsets As RowsetBase()
) As Task(Of Integer)
Protected Overrides Function DoSaveAsync (
    ParamArray rowsets As RowsetBase()
) As Task(Of Integer)
protected:
virtual Task<int>^ DoSaveAsync(
    ... array<RowsetBase^>^ rowsets
) override
protected:
virtual Task<int>^ DoSaveAsync(
    ... array<RowsetBase^>^ rowsets
) override
abstract DoSaveAsync :
        rowsets : RowsetBase[] -> Task<int>
override DoSaveAsync :
        rowsets : RowsetBase[] -> Task<int>
abstract DoSaveAsync :
        rowsets : RowsetBase[] -> Task<int>
override DoSaveAsync :
        rowsets : RowsetBase[] -> Task<int>

Parameters

rowsets
Type: NFX.DataAccess.CRUD RowsetBase

Return Value

Type: Online Task Online Int32
See Also
MySQLCRUDTransaction Class
MySQLCRUDTransaction Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction.DoUpdate Method

MySQLCRUDTransaction DoUpdate Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override int DoUpdate(
    Row row,
    IDataStoreKey key,
    FieldFilterFunc filter = null
)
protected override int DoUpdate(
    Row row,
    IDataStoreKey key,
    FieldFilterFunc filter = null
)
Protected Overrides Function DoUpdate (
    row As Row,
    key As IDataStoreKey,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Protected Overrides Function DoUpdate (
    row As Row,
    key As IDataStoreKey,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
protected:
virtual int DoUpdate(
    Row^ row,
    IDataStoreKey^ key,
    FieldFilterFunc^ filter = nullptr
) override
protected:
virtual int DoUpdate(
    Row^ row,
    IDataStoreKey^ key,
    FieldFilterFunc^ filter = nullptr
) override
abstract DoUpdate :
        row : Row *
        key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override DoUpdate :
        row : Row *
        key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
abstract DoUpdate :
        row : Row *
        key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override DoUpdate :
        row : Row *
        key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
key
Type: NFX.DataAccess IDataStoreKey
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32
See Also
MySQLCRUDTransaction Class
MySQLCRUDTransaction Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction.DoUpdateAsync Method

MySQLCRUDTransaction DoUpdateAsync Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Task<int> DoUpdateAsync(
    Row row,
    IDataStoreKey key,
    FieldFilterFunc filter = null
)
protected override Task<int> DoUpdateAsync(
    Row row,
    IDataStoreKey key,
    FieldFilterFunc filter = null
)
Protected Overrides Function DoUpdateAsync (
    row As Row,
    key As IDataStoreKey,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
Protected Overrides Function DoUpdateAsync (
    row As Row,
    key As IDataStoreKey,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
protected:
virtual Task<int>^ DoUpdateAsync(
    Row^ row,
    IDataStoreKey^ key,
    FieldFilterFunc^ filter = nullptr
) override
protected:
virtual Task<int>^ DoUpdateAsync(
    Row^ row,
    IDataStoreKey^ key,
    FieldFilterFunc^ filter = nullptr
) override
abstract DoUpdateAsync :
        row : Row *
        key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
override DoUpdateAsync :
        row : Row *
        key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
abstract DoUpdateAsync :
        row : Row *
        key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
override DoUpdateAsync :
        row : Row *
        key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
key
Type: NFX.DataAccess IDataStoreKey
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Task Online Int32
See Also
MySQLCRUDTransaction Class
MySQLCRUDTransaction Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction.DoUpsert Method

MySQLCRUDTransaction DoUpsert Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override int DoUpsert(
    Row row,
    FieldFilterFunc filter = null
)
protected override int DoUpsert(
    Row row,
    FieldFilterFunc filter = null
)
Protected Overrides Function DoUpsert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Protected Overrides Function DoUpsert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
protected:
virtual int DoUpsert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) override
protected:
virtual int DoUpsert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) override
abstract DoUpsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override DoUpsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
abstract DoUpsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override DoUpsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32
See Also
MySQLCRUDTransaction Class
MySQLCRUDTransaction Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction.DoUpsertAsync Method

MySQLCRUDTransaction DoUpsertAsync Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Task<int> DoUpsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
protected override Task<int> DoUpsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
Protected Overrides Function DoUpsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
Protected Overrides Function DoUpsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
protected:
virtual Task<int>^ DoUpsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) override
protected:
virtual Task<int>^ DoUpsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) override
abstract DoUpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
override DoUpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
abstract DoUpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
override DoUpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Task Online Int32
See Also
MySQLCRUDTransaction Class
MySQLCRUDTransaction Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction Properties

MySQLCRUDTransaction Properties NFX Class Library

The MySQLCRUDTransaction type exposes the following members.
Properties
 | Name | Description
Public property | Connection | Returns the underlying MySQL connection that this transaction works through
Public property | DataStore | References the store instance that started this transaction (Inherited from CRUDTransaction.)
Public property | DisposeBehavior | Specifies how transaction should be finalized on dispose: comitted or rolledback if it is still open (Inherited from CRUDTransaction.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Status | Returns current transaction status (Inherited from CRUDTransaction.)
Protected property | Store |
Public property | SupportsTrueAsynchrony | Returns true when backend supports true asynchronous operations, such as the ones that do not create extra threads/empty tasks (Inherited from CRUDTransaction.)
Public property | Transaction | Returns the underlying MySQL transaction that this instance represents. Do not call Commit/Rollback method on this property directly
Back to Top
See Also
MySQLCRUDTransaction Class
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction.Connection Property

MySQLCRUDTransaction Connection Property NFX Class Library

Returns the underlying MySQL connection that this transaction works through

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MySqlConnection Connection { get; }
public MySqlConnection Connection { get; }
Public ReadOnly Property Connection As MySqlConnection
    Get
Public ReadOnly Property Connection As MySqlConnection
    Get
public:
property MySqlConnection^ Connection {
    MySqlConnection^ get ();
}
public:
property MySqlConnection^ Connection {
    MySqlConnection^ get ();
}
member Connection : MySqlConnection with get
member Connection : MySqlConnection with get

Property Value

Type: MySqlConnection
See Also
MySQLCRUDTransaction Class
MySQLCRUDTransaction Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction.Store Property

MySQLCRUDTransaction Store Property NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal MySQLDataStore Store { get; }
internal MySQLDataStore Store { get; }
Friend ReadOnly Property Store As MySQLDataStore
    Get
Friend ReadOnly Property Store As MySQLDataStore
    Get
internal:
property MySQLDataStore^ Store {
    MySQLDataStore^ get ();
}
internal:
property MySQLDataStore^ Store {
    MySQLDataStore^ get ();
}
internal member Store : MySQLDataStore with get
internal member Store : MySQLDataStore with get

Property Value

Type: MySQLDataStore
See Also
MySQLCRUDTransaction Class
MySQLCRUDTransaction Members
NFX.DataAccess.MySQL Namespace


MySQLCRUDTransaction.Transaction Property

MySQLCRUDTransaction Transaction Property NFX Class Library

Returns the underlying MySQL transaction that this instance represents. Do not call Commit/Rollback method on this property directly

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MySqlTransaction Transaction { get; }
public MySqlTransaction Transaction { get; }
Public ReadOnly Property Transaction As MySqlTransaction
    Get
Public ReadOnly Property Transaction As MySqlTransaction
    Get
public:
property MySqlTransaction^ Transaction {
    MySqlTransaction^ get ();
}
public:
property MySqlTransaction^ Transaction {
    MySqlTransaction^ get ();
}
member Transaction : MySqlTransaction with get
member Transaction : MySqlTransaction with get

Property Value

Type: MySqlTransaction
See Also
MySQLCRUDTransaction Class
MySQLCRUDTransaction Members
NFX.DataAccess.MySQL Namespace


MySQLCursor Class

MySQLCursor Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.DataAccess.CRUD Cursor
NFX.DataAccess.MySQL MySQLCursor

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class MySQLCursor : Cursor
public sealed class MySQLCursor : Cursor
Public NotInheritable Class MySQLCursor
    Inherits Cursor
Public NotInheritable Class MySQLCursor
    Inherits Cursor
public ref class MySQLCursor sealed : public Cursor
public ref class MySQLCursor sealed : public Cursor
[<SealedAttribute>]
type MySQLCursor =
    class
        inherit Cursor
    end
[<SealedAttribute>]
type MySQLCursor =
    class
        inherit Cursor
    end
See Also
MySQLCursor Members
NFX.DataAccess.MySQL Namespace


MySQLCursor Members

MySQLCursor Members NFX Class Library

The MySQLCursor type exposes the following members.
Constructors
 | Name | Description
Protected method | MySQLCursor | Initializes a new instance of the MySQLCursor class
Back to Top
Methods
 | Name | Description
Protected method | Destructor | (Overrides Cursor Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetEnumerator | (Inherited from Cursor.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Enumerator | (Inherited from Cursor.)
Protected field | m_Source | (Inherited from Cursor.)
Back to Top
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Cursor.)
Back to Top
See Also
MySQLCursor Class
NFX.DataAccess.MySQL Namespace


MySQLCursor Constructor

MySQLCursor Constructor NFX Class Library

Initializes a new instance of the MySQLCursor class

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal MySQLCursor(
    MySQLCRUDQueryExecutionContext context,
    MySqlCommand command,
    MySqlDataReader reader,
    IEnumerable<Row> source
)
internal MySQLCursor(
    MySQLCRUDQueryExecutionContext context,
    MySqlCommand command,
    MySqlDataReader reader,
    IEnumerable<Row> source
)
Friend Sub New (
    context As MySQLCRUDQueryExecutionContext,
    command As MySqlCommand,
    reader As MySqlDataReader,
    source As IEnumerable(Of Row)
)
Friend Sub New (
    context As MySQLCRUDQueryExecutionContext,
    command As MySqlCommand,
    reader As MySqlDataReader,
    source As IEnumerable(Of Row)
)
internal:
MySQLCursor(
    MySQLCRUDQueryExecutionContext context,
    MySqlCommand^ command,
    MySqlDataReader^ reader,
    IEnumerable<Row^>^ source
)
internal:
MySQLCursor(
    MySQLCRUDQueryExecutionContext context,
    MySqlCommand^ command,
    MySqlDataReader^ reader,
    IEnumerable<Row^>^ source
)
new :
        context : MySQLCRUDQueryExecutionContext *
        command : MySqlCommand *
        reader : MySqlDataReader *
        source : IEnumerable<Row> -> MySQLCursor
new :
        context : MySQLCRUDQueryExecutionContext *
        command : MySqlCommand *
        reader : MySqlDataReader *
        source : IEnumerable<Row> -> MySQLCursor

Parameters

context
Type: NFX.DataAccess.MySQL MySQLCRUDQueryExecutionContext
command
Type: MySqlCommand
reader
Type: MySqlDataReader
source
Type: Online System.Collections.Generic IEnumerable Row
See Also
MySQLCursor Class
MySQLCursor Members
NFX.DataAccess.MySQL Namespace


MySQLCursor Fields

MySQLCursor Fields NFX Class Library

The MySQLCursor type exposes the following members.
Fields
 | Name | Description
Protected field | m_Enumerator | (Inherited from Cursor.)
Protected field | m_Source | (Inherited from Cursor.)
Back to Top
See Also
MySQLCursor Class
NFX.DataAccess.MySQL Namespace


MySQLCursor Methods

MySQLCursor Methods NFX Class Library

The MySQLCursor type exposes the following members.
Methods
 | Name | Description
Protected method | Destructor | (Overrides Cursor Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetEnumerator | (Inherited from Cursor.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Cursor.)
Back to Top
See Also
MySQLCursor Class
NFX.DataAccess.MySQL Namespace


MySQLCursor.Destructor Method

MySQLCursor Destructor Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
MySQLCursor Class
MySQLCursor Members
NFX.DataAccess.MySQL Namespace


MySQLCursor Properties

MySQLCursor Properties NFX Class Library

The MySQLCursor type exposes the following members.
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Back to Top
See Also
MySQLCursor Class
NFX.DataAccess.MySQL Namespace


MySQLDataAccessException Class

MySQLDataAccessException Class NFX Class Library

Thrown by MySQL data access classes
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.DataAccess DataAccessException
NFX.DataAccess.MySQL MySQLDataAccessException

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MySQLDataAccessException : DataAccessException
[SerializableAttribute]
public class MySQLDataAccessException : DataAccessException
<SerializableAttribute>
Public Class MySQLDataAccessException
    Inherits DataAccessException
<SerializableAttribute>
Public Class MySQLDataAccessException
    Inherits DataAccessException
[SerializableAttribute]
public ref class MySQLDataAccessException : public DataAccessException
[SerializableAttribute]
public ref class MySQLDataAccessException : public DataAccessException
[<SerializableAttribute>]
type MySQLDataAccessException =
    class
        inherit DataAccessException
    end
[<SerializableAttribute>]
type MySQLDataAccessException =
    class
        inherit DataAccessException
    end
See Also
MySQLDataAccessException Members
NFX.DataAccess.MySQL Namespace


MySQLDataAccessException Members

MySQLDataAccessException Members NFX Class Library

The MySQLDataAccessException type exposes the following members.
Constructors
 | Name | Description
Public method | MySQLDataAccessException | Initializes a new instance of the MySQLDataAccessException class
Public method | MySQLDataAccessException(String) | Initializes a new instance of the MySQLDataAccessException class
Protected method | MySQLDataAccessException(SerializationInfo, StreamingContext) | Initializes a new instance of the MySQLDataAccessException class
Public method | MySQLDataAccessException(String, Exception) | Initializes a new instance of the MySQLDataAccessException class
Public method | MySQLDataAccessException(String, KeyViolationKind, String) | Initializes a new instance of the MySQLDataAccessException class
Public method | MySQLDataAccessException(String, Exception, KeyViolationKind, String) | Initializes a new instance of the MySQLDataAccessException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
MySQLDataAccessException Class
NFX.DataAccess.MySQL Namespace


MySQLDataAccessException Constructor

MySQLDataAccessException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | MySQLDataAccessException | Initializes a new instance of the MySQLDataAccessException class
Public method | MySQLDataAccessException(String) | Initializes a new instance of the MySQLDataAccessException class
Protected method | MySQLDataAccessException(SerializationInfo, StreamingContext) | Initializes a new instance of the MySQLDataAccessException class
Public method | MySQLDataAccessException(String, Exception) | Initializes a new instance of the MySQLDataAccessException class
Public method | MySQLDataAccessException(String, KeyViolationKind, String) | Initializes a new instance of the MySQLDataAccessException class
Public method | MySQLDataAccessException(String, Exception, KeyViolationKind, String) | Initializes a new instance of the MySQLDataAccessException class
Back to Top
See Also
MySQLDataAccessException Class
MySQLDataAccessException Members
NFX.DataAccess.MySQL Namespace


MySQLDataAccessException Constructor

MySQLDataAccessException Constructor NFX Class Library

Initializes a new instance of the MySQLDataAccessException class

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MySQLDataAccessException()
public MySQLDataAccessException()
Public Sub New
Public Sub New
public:
MySQLDataAccessException()
public:
MySQLDataAccessException()
new : unit -> MySQLDataAccessException
new : unit -> MySQLDataAccessException
See Also
MySQLDataAccessException Class
MySQLDataAccessException Members
MySQLDataAccessException Overload
NFX.DataAccess.MySQL Namespace


MySQLDataAccessException Constructor (String)

MySQLDataAccessException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MySQLDataAccessException class

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MySQLDataAccessException(
    string message
)
public MySQLDataAccessException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
MySQLDataAccessException(
    String^ message
)
public:
MySQLDataAccessException(
    String^ message
)
new :
        message : string -> MySQLDataAccessException
new :
        message : string -> MySQLDataAccessException

Parameters

message
Type: Online System String
See Also
MySQLDataAccessException Class
MySQLDataAccessException Members
MySQLDataAccessException Overload
NFX.DataAccess.MySQL Namespace


MySQLDataAccessException Constructor (SerializationInfo, StreamingContext)

MySQLDataAccessException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MySQLDataAccessException class

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MySQLDataAccessException(
    SerializationInfo info,
    StreamingContext context
)
protected MySQLDataAccessException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
MySQLDataAccessException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
MySQLDataAccessException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> MySQLDataAccessException
new :
        info : SerializationInfo *
        context : StreamingContext -> MySQLDataAccessException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
MySQLDataAccessException Class
MySQLDataAccessException Members
MySQLDataAccessException Overload
NFX.DataAccess.MySQL Namespace


MySQLDataAccessException Constructor (String, Exception)

MySQLDataAccessException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MySQLDataAccessException class

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MySQLDataAccessException(
    string message,
    Exception inner
)
public MySQLDataAccessException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
MySQLDataAccessException(
    String^ message,
    Exception^ inner
)
public:
MySQLDataAccessException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> MySQLDataAccessException
new :
        message : string *
        inner : Exception -> MySQLDataAccessException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
MySQLDataAccessException Class
MySQLDataAccessException Members
MySQLDataAccessException Overload
NFX.DataAccess.MySQL Namespace


MySQLDataAccessException Constructor (String, KeyViolationKind, String)

MySQLDataAccessException Constructor (String, KeyViolationKind, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MySQLDataAccessException class

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MySQLDataAccessException(
    string message,
    KeyViolationKind kvKind,
    string keyViolation
)
public MySQLDataAccessException(
    string message,
    KeyViolationKind kvKind,
    string keyViolation
)
Public Sub New (
    message As String,
    kvKind As KeyViolationKind,
    keyViolation As String
)
Public Sub New (
    message As String,
    kvKind As KeyViolationKind,
    keyViolation As String
)
public:
MySQLDataAccessException(
    String^ message,
    KeyViolationKind kvKind,
    String^ keyViolation
)
public:
MySQLDataAccessException(
    String^ message,
    KeyViolationKind kvKind,
    String^ keyViolation
)
new :
        message : string *
        kvKind : KeyViolationKind *
        keyViolation : string -> MySQLDataAccessException
new :
        message : string *
        kvKind : KeyViolationKind *
        keyViolation : string -> MySQLDataAccessException

Parameters

message
Type: Online System String
kvKind
Type: NFX.DataAccess KeyViolationKind
keyViolation
Type: Online System String
See Also
MySQLDataAccessException Class
MySQLDataAccessException Members
MySQLDataAccessException Overload
NFX.DataAccess.MySQL Namespace


MySQLDataAccessException Constructor (String, Exception, KeyViolationKind, String)

MySQLDataAccessException Constructor (String, Exception, KeyViolationKind, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MySQLDataAccessException class

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MySQLDataAccessException(
    string message,
    Exception inner,
    KeyViolationKind kvKind,
    string keyViolation
)
public MySQLDataAccessException(
    string message,
    Exception inner,
    KeyViolationKind kvKind,
    string keyViolation
)
Public Sub New (
    message As String,
    inner As Exception,
    kvKind As KeyViolationKind,
    keyViolation As String
)
Public Sub New (
    message As String,
    inner As Exception,
    kvKind As KeyViolationKind,
    keyViolation As String
)
public:
MySQLDataAccessException(
    String^ message,
    Exception^ inner,
    KeyViolationKind kvKind,
    String^ keyViolation
)
public:
MySQLDataAccessException(
    String^ message,
    Exception^ inner,
    KeyViolationKind kvKind,
    String^ keyViolation
)
new :
        message : string *
        inner : Exception *
        kvKind : KeyViolationKind *
        keyViolation : string -> MySQLDataAccessException
new :
        message : string *
        inner : Exception *
        kvKind : KeyViolationKind *
        keyViolation : string -> MySQLDataAccessException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
kvKind
Type: NFX.DataAccess KeyViolationKind
keyViolation
Type: Online System String
See Also
MySQLDataAccessException Class
MySQLDataAccessException Members
MySQLDataAccessException Overload
NFX.DataAccess.MySQL Namespace


MySQLDataAccessException Fields

MySQLDataAccessException Fields NFX Class Library

The MySQLDataAccessException type exposes the following members.
Fields
 | Name | Description
Public field | KeyViolation | Provides the name of entity/index/field that was violated and resulted in this exception (Inherited from DataAccessException.)
Public field | KeyViolationKind | Spcifies the sub-type of key violation (Inherited from DataAccessException.)
Back to Top
See Also
MySQLDataAccessException Class
NFX.DataAccess.MySQL Namespace


MySQLDataAccessException Methods

MySQLDataAccessException Methods NFX Class Library

The MySQLDataAccessException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
MySQLDataAccessException Class
NFX.DataAccess.MySQL Namespace


MySQLDataAccessException Properties

MySQLDataAccessException Properties NFX Class Library

The MySQLDataAccessException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
MySQLDataAccessException Class
NFX.DataAccess.MySQL Namespace


MySQLDataAccessException Events

MySQLDataAccessException Events NFX Class Library

The MySQLDataAccessException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
MySQLDataAccessException Class
NFX.DataAccess.MySQL Namespace


MySQLDataStore Class

MySQLDataStore Class NFX Class Library

Implements MySQL general data store that auto-generates SQLs for record models and supports CRUD operations. This class IS thread-safe load/save/delete operations
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.DataAccess.MySQL MySQLDataStoreBase
NFX.DataAccess.MySQL MySQLDataStore

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MySQLDataStore : MySQLDataStoreBase,
    ICRUDDataStoreImplementation, ICRUDDataStore, ICRUDOperations, ICRUDTransactionOperations, IDataStoreImplementation,
    IDataStore, IApplicationComponent, IDisposable, IConfigurable, IInstrumentable,
    IExternallyParameterized
public class MySQLDataStore : MySQLDataStoreBase,
    ICRUDDataStoreImplementation, ICRUDDataStore, ICRUDOperations, ICRUDTransactionOperations, IDataStoreImplementation,
    IDataStore, IApplicationComponent, IDisposable, IConfigurable, IInstrumentable,
    IExternallyParameterized
Public Class MySQLDataStore
    Inherits MySQLDataStoreBase
    Implements ICRUDDataStoreImplementation, ICRUDDataStore, ICRUDOperations, ICRUDTransactionOperations,
    IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
Public Class MySQLDataStore
    Inherits MySQLDataStoreBase
    Implements ICRUDDataStoreImplementation, ICRUDDataStore, ICRUDOperations, ICRUDTransactionOperations,
    IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
public ref class MySQLDataStore : public MySQLDataStoreBase,
    ICRUDDataStoreImplementation, ICRUDDataStore, ICRUDOperations, ICRUDTransactionOperations, IDataStoreImplementation,
    IDataStore, IApplicationComponent, IDisposable, IConfigurable, IInstrumentable,
    IExternallyParameterized
public ref class MySQLDataStore : public MySQLDataStoreBase,
    ICRUDDataStoreImplementation, ICRUDDataStore, ICRUDOperations, ICRUDTransactionOperations, IDataStoreImplementation,
    IDataStore, IApplicationComponent, IDisposable, IConfigurable, IInstrumentable,
    IExternallyParameterized
type MySQLDataStore =
    class
        inherit MySQLDataStoreBase
        interface ICRUDDataStoreImplementation
        interface ICRUDDataStore
        interface ICRUDOperations
        interface ICRUDTransactionOperations
        interface IDataStoreImplementation
        interface IDataStore
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
type MySQLDataStore =
    class
        inherit MySQLDataStoreBase
        interface ICRUDDataStoreImplementation
        interface ICRUDDataStore
        interface ICRUDOperations
        interface ICRUDTransactionOperations
        interface IDataStoreImplementation
        interface IDataStore
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore Members

MySQLDataStore Members NFX Class Library

The MySQLDataStore type exposes the following members.
Constructors
 | Name | Description
Public method | MySQLDataStore | Initializes a new instance of the MySQLDataStore class
Public method | MySQLDataStore(String) | Initializes a new instance of the MySQLDataStore class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | BeginTransaction |
Public method | BeginTransactionAsync |
Public method | Configure | (Overrides MySQLDataStoreBase Configure(IConfigSectionNode).)
Public method | Delete |
Public method | DeleteAsync |
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoDelete | Performs CRUD row deletion. Override to do custom deletion
Protected method | DoExecuteWithoutFetch | Performs CRUD execution of queries that do not return result set. Override to do custom Query interpretation
Protected method | DoGetSchema | Performs CRUD load without fetching data only returning schema. Override to do custom Query interpretation
Protected method | DoInsert | Performs CRUD row insert. Override to do custom insertion
Protected method | DoLoad | Performs CRUD load. Override to do custom Query interpretation
Protected method | DoOpenCursor | Performs CRUD load. Override to do custom Query interpretation
Protected method | DoSave | Performs CRUD batch save. Override to do custom batch saving
Protected method | DoUpdate | Performs CRUD row update. Override to do custom update
Protected method | DoUpsert | Performs CRUD row upsert. Override to do custom upsertion
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExecuteWithoutFetch |
Public method | ExecuteWithoutFetchAsync |
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from MySQLDataStoreBase.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from MySQLDataStoreBase.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from MySQLDataStoreBase.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetConnection | Allocates MySQL connection (Inherited from MySQLDataStoreBase.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSchema |
Public method | GetSchemaAsync |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Insert |
Public method | InsertAsync |
Public method | Load |
Public method | LoadAsync |
Public method | LoadOneRow |
Public method | LoadOneRowAsync |
Public method | LoadOneRowset |
Public method | LoadOneRowsetAsync |
Public method | MakeScriptQueryHandler |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenCursor |
Public method | OpenCursorAsync |
Public method | Save |
Public method | SaveAsync |
Public method | TestConnection | (Inherited from MySQLDataStoreBase.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Update |
Public method | UpdateAsync |
Public method | Upsert |
Public method | UpsertAsync |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | LoadEnumerable TRow | Loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadEnumerableAsync TRow | Async version - loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadRow TRow | Loads one row cast per Query(T) or null (Defined by DataUtils.)
Public Extension Method | LoadRowAsync TRow | Async version - loads one row cast per Query(T) or null (Defined by DataUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
SCRIPT_FILE_SUFFIX |
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | ConnectString | Get/Sets MySql database connection string (Inherited from MySQLDataStoreBase.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from MySQLDataStoreBase.)
Public property | FullGDIDS | When true (default) writes gdid as byte[](era+id), false - uses ulong ID only (Inherited from MySQLDataStoreBase.)
Public property | InstrumentationEnabled | (Inherited from MySQLDataStoreBase.)
Public property | LogLevel | (Inherited from MySQLDataStoreBase.)
Public property | Name | (Inherited from MySQLDataStoreBase.)
Public property | QueryResolver |
Public property | ScriptFileSuffix |
Public property | StoreType |
Public property | StringBool | When true commits boolean values as StringForTrue/StringForFalse instead of bool values. True by default (Inherited from MySQLDataStoreBase.)
Public property | StringForFalse | (Inherited from MySQLDataStoreBase.)
Public property | StringForTrue | (Inherited from MySQLDataStoreBase.)
Public property | SupportsTransactions |
Public property | SupportsTrueAsynchrony |
Public property | TargetName | (Inherited from MySQLDataStoreBase.)
Back to Top
See Also
MySQLDataStore Class
NFX.DataAccess.MySQL Namespace


MySQLDataStore Constructor

MySQLDataStore Constructor NFX Class Library

Overload List
 | Name | Description
Public method | MySQLDataStore | Initializes a new instance of the MySQLDataStore class
Public method | MySQLDataStore(String) | Initializes a new instance of the MySQLDataStore class
Back to Top
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore Constructor

MySQLDataStore Constructor NFX Class Library

Initializes a new instance of the MySQLDataStore class

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MySQLDataStore()
public MySQLDataStore()
Public Sub New
Public Sub New
public:
MySQLDataStore()
public:
MySQLDataStore()
new : unit -> MySQLDataStore
new : unit -> MySQLDataStore
See Also
MySQLDataStore Class
MySQLDataStore Members
MySQLDataStore Overload
NFX.DataAccess.MySQL Namespace


MySQLDataStore Constructor (String)

MySQLDataStore Constructor (String) NFX Class Library

Initializes a new instance of the MySQLDataStore class

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MySQLDataStore(
    string connectString
)
public MySQLDataStore(
    string connectString
)
Public Sub New (
    connectString As String
)
Public Sub New (
    connectString As String
)
public:
MySQLDataStore(
    String^ connectString
)
public:
MySQLDataStore(
    String^ connectString
)
new :
        connectString : string -> MySQLDataStore
new :
        connectString : string -> MySQLDataStore

Parameters

connectString
Type: Online System String
See Also
MySQLDataStore Class
MySQLDataStore Members
MySQLDataStore Overload
NFX.DataAccess.MySQL Namespace


MySQLDataStore Fields

MySQLDataStore Fields NFX Class Library

The MySQLDataStore type exposes the following members.
Fields
Name | Description
SCRIPT_FILE_SUFFIX |
Back to Top
See Also
MySQLDataStore Class
NFX.DataAccess.MySQL Namespace


MySQLDataStore.SCRIPT_FILE_SUFFIX Field

MySQLDataStore SCRIPT_FILE_SUFFIX Field NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SCRIPT_FILE_SUFFIX
public const string SCRIPT_FILE_SUFFIX
Public Const SCRIPT_FILE_SUFFIX As String
Public Const SCRIPT_FILE_SUFFIX As String
public:
literal String^ SCRIPT_FILE_SUFFIX
public:
literal String^ SCRIPT_FILE_SUFFIX
static val mutable SCRIPT_FILE_SUFFIX: string
static val mutable SCRIPT_FILE_SUFFIX: string

Field Value

Type: Online String
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore Methods

MySQLDataStore Methods NFX Class Library

The MySQLDataStore type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | BeginTransaction |
Public method | BeginTransactionAsync |
Public method | Configure | (Overrides MySQLDataStoreBase Configure(IConfigSectionNode).)
Public method | Delete |
Public method | DeleteAsync |
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoDelete | Performs CRUD row deletion. Override to do custom deletion
Protected method | DoExecuteWithoutFetch | Performs CRUD execution of queries that do not return result set. Override to do custom Query interpretation
Protected method | DoGetSchema | Performs CRUD load without fetching data only returning schema. Override to do custom Query interpretation
Protected method | DoInsert | Performs CRUD row insert. Override to do custom insertion
Protected method | DoLoad | Performs CRUD load. Override to do custom Query interpretation
Protected method | DoOpenCursor | Performs CRUD load. Override to do custom Query interpretation
Protected method | DoSave | Performs CRUD batch save. Override to do custom batch saving
Protected method | DoUpdate | Performs CRUD row update. Override to do custom update
Protected method | DoUpsert | Performs CRUD row upsert. Override to do custom upsertion
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExecuteWithoutFetch |
Public method | ExecuteWithoutFetchAsync |
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from MySQLDataStoreBase.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from MySQLDataStoreBase.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from MySQLDataStoreBase.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetConnection | Allocates MySQL connection (Inherited from MySQLDataStoreBase.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSchema |
Public method | GetSchemaAsync |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Insert |
Public method | InsertAsync |
Public method | Load |
Public method | LoadAsync |
Public method | LoadOneRow |
Public method | LoadOneRowAsync |
Public method | LoadOneRowset |
Public method | LoadOneRowsetAsync |
Public method | MakeScriptQueryHandler |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OpenCursor |
Public method | OpenCursorAsync |
Public method | Save |
Public method | SaveAsync |
Public method | TestConnection | (Inherited from MySQLDataStoreBase.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Update |
Public method | UpdateAsync |
Public method | Upsert |
Public method | UpsertAsync |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | LoadEnumerable TRow | Loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadEnumerableAsync TRow | Async version - loads rowset with rows cast per Query(T) or empty enum (Defined by DataUtils.)
Public Extension Method | LoadRow TRow | Loads one row cast per Query(T) or null (Defined by DataUtils.)
Public Extension Method | LoadRowAsync TRow | Async version - loads one row cast per Query(T) or null (Defined by DataUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MySQLDataStore Class
NFX.DataAccess.MySQL Namespace


MySQLDataStore.BeginTransaction Method

MySQLDataStore BeginTransaction Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDTransaction BeginTransaction(
    IsolationLevel iso = IsolationLevel.ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior.CommitOnDispose
)
public CRUDTransaction BeginTransaction(
    IsolationLevel iso = IsolationLevel.ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior.CommitOnDispose
)
Public Function BeginTransaction (
    Optional iso As IsolationLevel = IsolationLevel.ReadCommitted,
    Optional behavior As TransactionDisposeBehavior = TransactionDisposeBehavior.CommitOnDispose
) As CRUDTransaction
Public Function BeginTransaction (
    Optional iso As IsolationLevel = IsolationLevel.ReadCommitted,
    Optional behavior As TransactionDisposeBehavior = TransactionDisposeBehavior.CommitOnDispose
) As CRUDTransaction
public:
virtual CRUDTransaction^ BeginTransaction(
    IsolationLevel iso = IsolationLevel::ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior::CommitOnDispose
) sealed
public:
virtual CRUDTransaction^ BeginTransaction(
    IsolationLevel iso = IsolationLevel::ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior::CommitOnDispose
) sealed
abstract BeginTransaction :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> CRUDTransaction
override BeginTransaction :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> CRUDTransaction
abstract BeginTransaction :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> CRUDTransaction
override BeginTransaction :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> CRUDTransaction

Parameters

iso (Optional)
Type: Online System.Data IsolationLevel
behavior (Optional)
Type: NFX.DataAccess.CRUD TransactionDisposeBehavior

Return Value

Type: CRUDTransaction

Implements

ICRUDTransactionOperations BeginTransaction(IsolationLevel, TransactionDisposeBehavior)
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.BeginTransactionAsync Method

MySQLDataStore BeginTransactionAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<CRUDTransaction> BeginTransactionAsync(
    IsolationLevel iso = IsolationLevel.ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior.CommitOnDispose
)
public Task<CRUDTransaction> BeginTransactionAsync(
    IsolationLevel iso = IsolationLevel.ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior.CommitOnDispose
)
Public Function BeginTransactionAsync (
    Optional iso As IsolationLevel = IsolationLevel.ReadCommitted,
    Optional behavior As TransactionDisposeBehavior = TransactionDisposeBehavior.CommitOnDispose
) As Task(Of CRUDTransaction)
Public Function BeginTransactionAsync (
    Optional iso As IsolationLevel = IsolationLevel.ReadCommitted,
    Optional behavior As TransactionDisposeBehavior = TransactionDisposeBehavior.CommitOnDispose
) As Task(Of CRUDTransaction)
public:
virtual Task<CRUDTransaction^>^ BeginTransactionAsync(
    IsolationLevel iso = IsolationLevel::ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior::CommitOnDispose
) sealed
public:
virtual Task<CRUDTransaction^>^ BeginTransactionAsync(
    IsolationLevel iso = IsolationLevel::ReadCommitted,
    TransactionDisposeBehavior behavior = TransactionDisposeBehavior::CommitOnDispose
) sealed
abstract BeginTransactionAsync :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> Task<CRUDTransaction>
override BeginTransactionAsync :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> Task<CRUDTransaction>
abstract BeginTransactionAsync :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> Task<CRUDTransaction>
override BeginTransactionAsync :
        ?iso : IsolationLevel *
        ?behavior : TransactionDisposeBehavior
(* Defaults:
        let _iso = defaultArg iso IsolationLevel.ReadCommitted
        let _behavior = defaultArg behavior TransactionDisposeBehavior.CommitOnDispose
*)
-> Task<CRUDTransaction>

Parameters

iso (Optional)
Type: Online System.Data IsolationLevel
behavior (Optional)
Type: NFX.DataAccess.CRUD TransactionDisposeBehavior

Return Value

Type: Online Task CRUDTransaction

Implements

ICRUDTransactionOperations BeginTransactionAsync(IsolationLevel, TransactionDisposeBehavior)
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.Configure Method

MySQLDataStore Configure Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Configure(
    IConfigSectionNode node
)
public override void Configure(
    IConfigSectionNode node
)
Public Overrides Sub Configure (
    node As IConfigSectionNode
)
Public Overrides Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) override
public:
virtual void Configure(
    IConfigSectionNode^ node
) override
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
IConfigurable Configure(IConfigSectionNode)
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.Delete Method

MySQLDataStore Delete Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Delete(
    Row row,
    IDataStoreKey key = null
)
public int Delete(
    Row row,
    IDataStoreKey key = null
)
Public Function Delete (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Integer
Public Function Delete (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Integer
public:
virtual int Delete(
    Row^ row,
    IDataStoreKey^ key = nullptr
) sealed
public:
virtual int Delete(
    Row^ row,
    IDataStoreKey^ key = nullptr
) sealed
abstract Delete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int
override Delete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int
abstract Delete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int
override Delete :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey

Return Value

Type: Online Int32

Implements

ICRUDOperations Delete(Row, IDataStoreKey)
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.DeleteAsync Method

MySQLDataStore DeleteAsync Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<int> DeleteAsync(
    Row row,
    IDataStoreKey key = null
)
public Task<int> DeleteAsync(
    Row row,
    IDataStoreKey key = null
)
Public Function DeleteAsync (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Task(Of Integer)
Public Function DeleteAsync (
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Task(Of Integer)
public:
virtual Task<int>^ DeleteAsync(
    Row^ row,
    IDataStoreKey^ key = nullptr
) sealed
public:
virtual Task<int>^ DeleteAsync(
    Row^ row,
    IDataStoreKey^ key = nullptr
) sealed
abstract DeleteAsync :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> Task<int>
override DeleteAsync :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> Task<int>
abstract DeleteAsync :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> Task<int>
override DeleteAsync :
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations DeleteAsync(Row, IDataStoreKey)
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.DoDelete Method

MySQLDataStore DoDelete Method NFX Class Library

Performs CRUD row deletion. Override to do custom deletion

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual int DoDelete(
    MySqlConnection cnn,
    MySqlTransaction transaction,
    Row row,
    IDataStoreKey key = null
)
protected internal virtual int DoDelete(
    MySqlConnection cnn,
    MySqlTransaction transaction,
    Row row,
    IDataStoreKey key = null
)
Protected Friend Overridable Function DoDelete (
    cnn As MySqlConnection,
    transaction As MySqlTransaction,
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Integer
Protected Friend Overridable Function DoDelete (
    cnn As MySqlConnection,
    transaction As MySqlTransaction,
    row As Row,
    Optional key As IDataStoreKey = Nothing
) As Integer
protected public:
virtual int DoDelete(
    MySqlConnection^ cnn,
    MySqlTransaction^ transaction,
    Row^ row,
    IDataStoreKey^ key = nullptr
)
protected public:
virtual int DoDelete(
    MySqlConnection^ cnn,
    MySqlTransaction^ transaction,
    Row^ row,
    IDataStoreKey^ key = nullptr
)
abstract DoDelete :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int
override DoDelete :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int
abstract DoDelete :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int
override DoDelete :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        row : Row *
        ?key : IDataStoreKey
(* Defaults:
        let _key = defaultArg key null
*)
-> int

Parameters

cnn
Type: MySqlConnection
transaction
Type: MySqlTransaction
row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey

Return Value

Type: Online Int32
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.DoExecuteWithoutFetch Method

MySQLDataStore DoExecuteWithoutFetch Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Performs CRUD execution of queries that do not return result set. Override to do custom Query interpretation

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual int DoExecuteWithoutFetch(
    MySqlConnection cnn,
    MySqlTransaction transaction,
    Query[] queries
)
protected internal virtual int DoExecuteWithoutFetch(
    MySqlConnection cnn,
    MySqlTransaction transaction,
    Query[] queries
)
Protected Friend Overridable Function DoExecuteWithoutFetch (
    cnn As MySqlConnection,
    transaction As MySqlTransaction,
    queries As Query()
) As Integer
Protected Friend Overridable Function DoExecuteWithoutFetch (
    cnn As MySqlConnection,
    transaction As MySqlTransaction,
    queries As Query()
) As Integer
protected public:
virtual int DoExecuteWithoutFetch(
    MySqlConnection^ cnn,
    MySqlTransaction^ transaction,
    array<Query^>^ queries
)
protected public:
virtual int DoExecuteWithoutFetch(
    MySqlConnection^ cnn,
    MySqlTransaction^ transaction,
    array<Query^>^ queries
)
abstract DoExecuteWithoutFetch :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        queries : Query[] -> int
override DoExecuteWithoutFetch :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        queries : Query[] -> int
abstract DoExecuteWithoutFetch :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        queries : Query[] -> int
override DoExecuteWithoutFetch :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        queries : Query[] -> int

Parameters

cnn
Type: MySqlConnection
transaction
Type: MySqlTransaction
queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Int32
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.DoGetSchema Method

MySQLDataStore DoGetSchema Method NFX Class Library

Performs CRUD load without fetching data only returning schema. Override to do custom Query interpretation

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Schema DoGetSchema(
    MySqlConnection cnn,
    MySqlTransaction transaction,
    Query query
)
protected internal virtual Schema DoGetSchema(
    MySqlConnection cnn,
    MySqlTransaction transaction,
    Query query
)
Protected Friend Overridable Function DoGetSchema (
    cnn As MySqlConnection,
    transaction As MySqlTransaction,
    query As Query
) As Schema
Protected Friend Overridable Function DoGetSchema (
    cnn As MySqlConnection,
    transaction As MySqlTransaction,
    query As Query
) As Schema
protected public:
virtual Schema^ DoGetSchema(
    MySqlConnection^ cnn,
    MySqlTransaction^ transaction,
    Query^ query
)
protected public:
virtual Schema^ DoGetSchema(
    MySqlConnection^ cnn,
    MySqlTransaction^ transaction,
    Query^ query
)
abstract DoGetSchema :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        query : Query -> Schema
override DoGetSchema :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        query : Query -> Schema
abstract DoGetSchema :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        query : Query -> Schema
override DoGetSchema :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        query : Query -> Schema

Parameters

cnn
Type: MySqlConnection
transaction
Type: MySqlTransaction
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Schema
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.DoInsert Method

MySQLDataStore DoInsert Method NFX Class Library

Performs CRUD row insert. Override to do custom insertion

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual int DoInsert(
    MySqlConnection cnn,
    MySqlTransaction transaction,
    Row row,
    FieldFilterFunc filter = null
)
protected internal virtual int DoInsert(
    MySqlConnection cnn,
    MySqlTransaction transaction,
    Row row,
    FieldFilterFunc filter = null
)
Protected Friend Overridable Function DoInsert (
    cnn As MySqlConnection,
    transaction As MySqlTransaction,
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Protected Friend Overridable Function DoInsert (
    cnn As MySqlConnection,
    transaction As MySqlTransaction,
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
protected public:
virtual int DoInsert(
    MySqlConnection^ cnn,
    MySqlTransaction^ transaction,
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
protected public:
virtual int DoInsert(
    MySqlConnection^ cnn,
    MySqlTransaction^ transaction,
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
abstract DoInsert :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override DoInsert :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
abstract DoInsert :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override DoInsert :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int

Parameters

cnn
Type: MySqlConnection
transaction
Type: MySqlTransaction
row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.DoLoad Method

MySQLDataStore DoLoad Method NFX Class Library

Performs CRUD load. Override to do custom Query interpretation

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual List<RowsetBase> DoLoad(
    MySqlConnection cnn,
    MySqlTransaction transaction,
    Query[] queries,
    bool oneRow = false
)
protected internal virtual List<RowsetBase> DoLoad(
    MySqlConnection cnn,
    MySqlTransaction transaction,
    Query[] queries,
    bool oneRow = false
)
Protected Friend Overridable Function DoLoad (
    cnn As MySqlConnection,
    transaction As MySqlTransaction,
    queries As Query(),
    Optional oneRow As Boolean = false
) As List(Of RowsetBase)
Protected Friend Overridable Function DoLoad (
    cnn As MySqlConnection,
    transaction As MySqlTransaction,
    queries As Query(),
    Optional oneRow As Boolean = false
) As List(Of RowsetBase)
protected public:
virtual List<RowsetBase^>^ DoLoad(
    MySqlConnection^ cnn,
    MySqlTransaction^ transaction,
    array<Query^>^ queries,
    bool oneRow = false
)
protected public:
virtual List<RowsetBase^>^ DoLoad(
    MySqlConnection^ cnn,
    MySqlTransaction^ transaction,
    array<Query^>^ queries,
    bool oneRow = false
)
abstract DoLoad :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        queries : Query[] *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> List<RowsetBase>
override DoLoad :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        queries : Query[] *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> List<RowsetBase>
abstract DoLoad :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        queries : Query[] *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> List<RowsetBase>
override DoLoad :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        queries : Query[] *
        ?oneRow : bool
(* Defaults:
        let _oneRow = defaultArg oneRow false
*)
-> List<RowsetBase>

Parameters

cnn
Type: MySqlConnection
transaction
Type: MySqlTransaction
queries
Type: NFX.DataAccess.CRUD Query
oneRow (Optional)
Type: Online System Boolean

Return Value

Type: Online List RowsetBase
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.DoOpenCursor Method

MySQLDataStore DoOpenCursor Method NFX Class Library

Performs CRUD load. Override to do custom Query interpretation

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Cursor DoOpenCursor(
    MySqlConnection cnn,
    MySqlTransaction transaction,
    Query query
)
protected internal virtual Cursor DoOpenCursor(
    MySqlConnection cnn,
    MySqlTransaction transaction,
    Query query
)
Protected Friend Overridable Function DoOpenCursor (
    cnn As MySqlConnection,
    transaction As MySqlTransaction,
    query As Query
) As Cursor
Protected Friend Overridable Function DoOpenCursor (
    cnn As MySqlConnection,
    transaction As MySqlTransaction,
    query As Query
) As Cursor
protected public:
virtual Cursor^ DoOpenCursor(
    MySqlConnection^ cnn,
    MySqlTransaction^ transaction,
    Query^ query
)
protected public:
virtual Cursor^ DoOpenCursor(
    MySqlConnection^ cnn,
    MySqlTransaction^ transaction,
    Query^ query
)
abstract DoOpenCursor :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        query : Query -> Cursor
override DoOpenCursor :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        query : Query -> Cursor
abstract DoOpenCursor :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        query : Query -> Cursor
override DoOpenCursor :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        query : Query -> Cursor

Parameters

cnn
Type: MySqlConnection
transaction
Type: MySqlTransaction
query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Cursor
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.DoSave Method

MySQLDataStore DoSave Method NFX Class Library

Performs CRUD batch save. Override to do custom batch saving

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual int DoSave(
    MySqlConnection cnn,
    MySqlTransaction transaction,
    RowsetBase[] rowsets
)
protected internal virtual int DoSave(
    MySqlConnection cnn,
    MySqlTransaction transaction,
    RowsetBase[] rowsets
)
Protected Friend Overridable Function DoSave (
    cnn As MySqlConnection,
    transaction As MySqlTransaction,
    rowsets As RowsetBase()
) As Integer
Protected Friend Overridable Function DoSave (
    cnn As MySqlConnection,
    transaction As MySqlTransaction,
    rowsets As RowsetBase()
) As Integer
protected public:
virtual int DoSave(
    MySqlConnection^ cnn,
    MySqlTransaction^ transaction,
    array<RowsetBase^>^ rowsets
)
protected public:
virtual int DoSave(
    MySqlConnection^ cnn,
    MySqlTransaction^ transaction,
    array<RowsetBase^>^ rowsets
)
abstract DoSave :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        rowsets : RowsetBase[] -> int
override DoSave :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        rowsets : RowsetBase[] -> int
abstract DoSave :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        rowsets : RowsetBase[] -> int
override DoSave :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        rowsets : RowsetBase[] -> int

Parameters

cnn
Type: MySqlConnection
transaction
Type: MySqlTransaction
rowsets
Type: NFX.DataAccess.CRUD RowsetBase

Return Value

Type: Online Int32
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.DoUpdate Method

MySQLDataStore DoUpdate Method NFX Class Library

Performs CRUD row update. Override to do custom update

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual int DoUpdate(
    MySqlConnection cnn,
    MySqlTransaction transaction,
    Row row,
    IDataStoreKey key = null,
    FieldFilterFunc filter = null
)
protected internal virtual int DoUpdate(
    MySqlConnection cnn,
    MySqlTransaction transaction,
    Row row,
    IDataStoreKey key = null,
    FieldFilterFunc filter = null
)
Protected Friend Overridable Function DoUpdate (
    cnn As MySqlConnection,
    transaction As MySqlTransaction,
    row As Row,
    Optional key As IDataStoreKey = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Protected Friend Overridable Function DoUpdate (
    cnn As MySqlConnection,
    transaction As MySqlTransaction,
    row As Row,
    Optional key As IDataStoreKey = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
protected public:
virtual int DoUpdate(
    MySqlConnection^ cnn,
    MySqlTransaction^ transaction,
    Row^ row,
    IDataStoreKey^ key = nullptr,
    FieldFilterFunc^ filter = nullptr
)
protected public:
virtual int DoUpdate(
    MySqlConnection^ cnn,
    MySqlTransaction^ transaction,
    Row^ row,
    IDataStoreKey^ key = nullptr,
    FieldFilterFunc^ filter = nullptr
)
abstract DoUpdate :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> int
override DoUpdate :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> int
abstract DoUpdate :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> int
override DoUpdate :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> int

Parameters

cnn
Type: MySqlConnection
transaction
Type: MySqlTransaction
row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.DoUpsert Method

MySQLDataStore DoUpsert Method NFX Class Library

Performs CRUD row upsert. Override to do custom upsertion

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual int DoUpsert(
    MySqlConnection cnn,
    MySqlTransaction transaction,
    Row row,
    FieldFilterFunc filter = null
)
protected internal virtual int DoUpsert(
    MySqlConnection cnn,
    MySqlTransaction transaction,
    Row row,
    FieldFilterFunc filter = null
)
Protected Friend Overridable Function DoUpsert (
    cnn As MySqlConnection,
    transaction As MySqlTransaction,
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Protected Friend Overridable Function DoUpsert (
    cnn As MySqlConnection,
    transaction As MySqlTransaction,
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
protected public:
virtual int DoUpsert(
    MySqlConnection^ cnn,
    MySqlTransaction^ transaction,
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
protected public:
virtual int DoUpsert(
    MySqlConnection^ cnn,
    MySqlTransaction^ transaction,
    Row^ row,
    FieldFilterFunc^ filter = nullptr
)
abstract DoUpsert :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override DoUpsert :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
abstract DoUpsert :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override DoUpsert :
        cnn : MySqlConnection *
        transaction : MySqlTransaction *
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int

Parameters

cnn
Type: MySqlConnection
transaction
Type: MySqlTransaction
row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.ExecuteWithoutFetch Method

MySQLDataStore ExecuteWithoutFetch Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ExecuteWithoutFetch(
    params Query[] queries
)
public int ExecuteWithoutFetch(
    params Query[] queries
)
Public Function ExecuteWithoutFetch (
    ParamArray queries As Query()
) As Integer
Public Function ExecuteWithoutFetch (
    ParamArray queries As Query()
) As Integer
public:
virtual int ExecuteWithoutFetch(
    ... array<Query^>^ queries
) sealed
public:
virtual int ExecuteWithoutFetch(
    ... array<Query^>^ queries
) sealed
abstract ExecuteWithoutFetch :
        queries : Query[] -> int
override ExecuteWithoutFetch :
        queries : Query[] -> int
abstract ExecuteWithoutFetch :
        queries : Query[] -> int
override ExecuteWithoutFetch :
        queries : Query[] -> int

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Int32

Implements

ICRUDOperations ExecuteWithoutFetch( Query )
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.ExecuteWithoutFetchAsync Method

MySQLDataStore ExecuteWithoutFetchAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<int> ExecuteWithoutFetchAsync(
    params Query[] queries
)
public Task<int> ExecuteWithoutFetchAsync(
    params Query[] queries
)
Public Function ExecuteWithoutFetchAsync (
    ParamArray queries As Query()
) As Task(Of Integer)
Public Function ExecuteWithoutFetchAsync (
    ParamArray queries As Query()
) As Task(Of Integer)
public:
virtual Task<int>^ ExecuteWithoutFetchAsync(
    ... array<Query^>^ queries
) sealed
public:
virtual Task<int>^ ExecuteWithoutFetchAsync(
    ... array<Query^>^ queries
) sealed
abstract ExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>
override ExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>
abstract ExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>
override ExecuteWithoutFetchAsync :
        queries : Query[] -> Task<int>

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations ExecuteWithoutFetchAsync( Query )
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.GetSchema Method

MySQLDataStore GetSchema Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Schema GetSchema(
    Query query
)
public Schema GetSchema(
    Query query
)
Public Function GetSchema (
    query As Query
) As Schema
Public Function GetSchema (
    query As Query
) As Schema
public:
virtual Schema^ GetSchema(
    Query^ query
) sealed
public:
virtual Schema^ GetSchema(
    Query^ query
) sealed
abstract GetSchema :
        query : Query -> Schema
override GetSchema :
        query : Query -> Schema
abstract GetSchema :
        query : Query -> Schema
override GetSchema :
        query : Query -> Schema

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Schema

Implements

ICRUDOperations GetSchema(Query)
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.GetSchemaAsync Method

MySQLDataStore GetSchemaAsync Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<Schema> GetSchemaAsync(
    Query query
)
public Task<Schema> GetSchemaAsync(
    Query query
)
Public Function GetSchemaAsync (
    query As Query
) As Task(Of Schema)
Public Function GetSchemaAsync (
    query As Query
) As Task(Of Schema)
public:
virtual Task<Schema^>^ GetSchemaAsync(
    Query^ query
) sealed
public:
virtual Task<Schema^>^ GetSchemaAsync(
    Query^ query
) sealed
abstract GetSchemaAsync :
        query : Query -> Task<Schema>
override GetSchemaAsync :
        query : Query -> Task<Schema>
abstract GetSchemaAsync :
        query : Query -> Task<Schema>
override GetSchemaAsync :
        query : Query -> Task<Schema>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Schema

Implements

ICRUDOperations GetSchemaAsync(Query)
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.Insert Method

MySQLDataStore Insert Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Insert(
    Row row,
    FieldFilterFunc filter = null
)
public int Insert(
    Row row,
    FieldFilterFunc filter = null
)
Public Function Insert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Public Function Insert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
public:
virtual int Insert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) sealed
public:
virtual int Insert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) sealed
abstract Insert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override Insert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
abstract Insert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override Insert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32

Implements

ICRUDOperations Insert(Row, FieldFilterFunc)
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.InsertAsync Method

MySQLDataStore InsertAsync Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<int> InsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
public Task<int> InsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
Public Function InsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
Public Function InsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
public:
virtual Task<int>^ InsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) sealed
public:
virtual Task<int>^ InsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) sealed
abstract InsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
override InsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
abstract InsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
override InsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations InsertAsync(Row, FieldFilterFunc)
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.Load Method

MySQLDataStore Load Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<RowsetBase> Load(
    params Query[] queries
)
public List<RowsetBase> Load(
    params Query[] queries
)
Public Function Load (
    ParamArray queries As Query()
) As List(Of RowsetBase)
Public Function Load (
    ParamArray queries As Query()
) As List(Of RowsetBase)
public:
virtual List<RowsetBase^>^ Load(
    ... array<Query^>^ queries
) sealed
public:
virtual List<RowsetBase^>^ Load(
    ... array<Query^>^ queries
) sealed
abstract Load :
        queries : Query[] -> List<RowsetBase>
override Load :
        queries : Query[] -> List<RowsetBase>
abstract Load :
        queries : Query[] -> List<RowsetBase>
override Load :
        queries : Query[] -> List<RowsetBase>

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online List RowsetBase

Implements

ICRUDOperations Load( Query )
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.LoadAsync Method

MySQLDataStore LoadAsync Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<List<RowsetBase>> LoadAsync(
    params Query[] queries
)
public Task<List<RowsetBase>> LoadAsync(
    params Query[] queries
)
Public Function LoadAsync (
    ParamArray queries As Query()
) As Task(Of List(Of RowsetBase))
Public Function LoadAsync (
    ParamArray queries As Query()
) As Task(Of List(Of RowsetBase))
public:
virtual Task<List<RowsetBase^>^>^ LoadAsync(
    ... array<Query^>^ queries
) sealed
public:
virtual Task<List<RowsetBase^>^>^ LoadAsync(
    ... array<Query^>^ queries
) sealed
abstract LoadAsync :
        queries : Query[] -> Task<List<RowsetBase>>
override LoadAsync :
        queries : Query[] -> Task<List<RowsetBase>>
abstract LoadAsync :
        queries : Query[] -> Task<List<RowsetBase>>
override LoadAsync :
        queries : Query[] -> Task<List<RowsetBase>>

Parameters

queries
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Online List RowsetBase

Implements

ICRUDOperations LoadAsync( Query )
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.LoadOneRow Method

MySQLDataStore LoadOneRow Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Row LoadOneRow(
    Query query
)
public Row LoadOneRow(
    Query query
)
Public Function LoadOneRow (
    query As Query
) As Row
Public Function LoadOneRow (
    query As Query
) As Row
public:
virtual Row^ LoadOneRow(
    Query^ query
) sealed
public:
virtual Row^ LoadOneRow(
    Query^ query
) sealed
abstract LoadOneRow :
        query : Query -> Row
override LoadOneRow :
        query : Query -> Row
abstract LoadOneRow :
        query : Query -> Row
override LoadOneRow :
        query : Query -> Row

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Row

Implements

ICRUDOperations LoadOneRow(Query)
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.LoadOneRowAsync Method

MySQLDataStore LoadOneRowAsync Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<Row> LoadOneRowAsync(
    Query query
)
public Task<Row> LoadOneRowAsync(
    Query query
)
Public Function LoadOneRowAsync (
    query As Query
) As Task(Of Row)
Public Function LoadOneRowAsync (
    query As Query
) As Task(Of Row)
public:
virtual Task<Row^>^ LoadOneRowAsync(
    Query^ query
) sealed
public:
virtual Task<Row^>^ LoadOneRowAsync(
    Query^ query
) sealed
abstract LoadOneRowAsync :
        query : Query -> Task<Row>
override LoadOneRowAsync :
        query : Query -> Task<Row>
abstract LoadOneRowAsync :
        query : Query -> Task<Row>
override LoadOneRowAsync :
        query : Query -> Task<Row>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Row

Implements

ICRUDOperations LoadOneRowAsync(Query)
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.LoadOneRowset Method

MySQLDataStore LoadOneRowset Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RowsetBase LoadOneRowset(
    Query query
)
public RowsetBase LoadOneRowset(
    Query query
)
Public Function LoadOneRowset (
    query As Query
) As RowsetBase
Public Function LoadOneRowset (
    query As Query
) As RowsetBase
public:
virtual RowsetBase^ LoadOneRowset(
    Query^ query
) sealed
public:
virtual RowsetBase^ LoadOneRowset(
    Query^ query
) sealed
abstract LoadOneRowset :
        query : Query -> RowsetBase
override LoadOneRowset :
        query : Query -> RowsetBase
abstract LoadOneRowset :
        query : Query -> RowsetBase
override LoadOneRowset :
        query : Query -> RowsetBase

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: RowsetBase

Implements

ICRUDOperations LoadOneRowset(Query)
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.LoadOneRowsetAsync Method

MySQLDataStore LoadOneRowsetAsync Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<RowsetBase> LoadOneRowsetAsync(
    Query query
)
public Task<RowsetBase> LoadOneRowsetAsync(
    Query query
)
Public Function LoadOneRowsetAsync (
    query As Query
) As Task(Of RowsetBase)
Public Function LoadOneRowsetAsync (
    query As Query
) As Task(Of RowsetBase)
public:
virtual Task<RowsetBase^>^ LoadOneRowsetAsync(
    Query^ query
) sealed
public:
virtual Task<RowsetBase^>^ LoadOneRowsetAsync(
    Query^ query
) sealed
abstract LoadOneRowsetAsync :
        query : Query -> Task<RowsetBase>
override LoadOneRowsetAsync :
        query : Query -> Task<RowsetBase>
abstract LoadOneRowsetAsync :
        query : Query -> Task<RowsetBase>
override LoadOneRowsetAsync :
        query : Query -> Task<RowsetBase>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task RowsetBase

Implements

ICRUDOperations LoadOneRowsetAsync(Query)
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.MakeScriptQueryHandler Method

MySQLDataStore MakeScriptQueryHandler Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDQueryHandler MakeScriptQueryHandler(
    QuerySource querySource
)
public CRUDQueryHandler MakeScriptQueryHandler(
    QuerySource querySource
)
Public Function MakeScriptQueryHandler (
    querySource As QuerySource
) As CRUDQueryHandler
Public Function MakeScriptQueryHandler (
    querySource As QuerySource
) As CRUDQueryHandler
public:
virtual CRUDQueryHandler^ MakeScriptQueryHandler(
    QuerySource^ querySource
) sealed
public:
virtual CRUDQueryHandler^ MakeScriptQueryHandler(
    QuerySource^ querySource
) sealed
abstract MakeScriptQueryHandler :
        querySource : QuerySource -> CRUDQueryHandler
override MakeScriptQueryHandler :
        querySource : QuerySource -> CRUDQueryHandler
abstract MakeScriptQueryHandler :
        querySource : QuerySource -> CRUDQueryHandler
override MakeScriptQueryHandler :
        querySource : QuerySource -> CRUDQueryHandler

Parameters

querySource
Type: NFX.DataAccess.CRUD QuerySource

Return Value

Type: CRUDQueryHandler

Implements

ICRUDDataStoreImplementation MakeScriptQueryHandler(QuerySource)
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.OpenCursor Method

MySQLDataStore OpenCursor Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Cursor OpenCursor(
    Query query
)
public Cursor OpenCursor(
    Query query
)
Public Function OpenCursor (
    query As Query
) As Cursor
Public Function OpenCursor (
    query As Query
) As Cursor
public:
virtual Cursor^ OpenCursor(
    Query^ query
) sealed
public:
virtual Cursor^ OpenCursor(
    Query^ query
) sealed
abstract OpenCursor :
        query : Query -> Cursor
override OpenCursor :
        query : Query -> Cursor
abstract OpenCursor :
        query : Query -> Cursor
override OpenCursor :
        query : Query -> Cursor

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Cursor

Implements

ICRUDOperations OpenCursor(Query)
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.OpenCursorAsync Method

MySQLDataStore OpenCursorAsync Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<Cursor> OpenCursorAsync(
    Query query
)
public Task<Cursor> OpenCursorAsync(
    Query query
)
Public Function OpenCursorAsync (
    query As Query
) As Task(Of Cursor)
Public Function OpenCursorAsync (
    query As Query
) As Task(Of Cursor)
public:
virtual Task<Cursor^>^ OpenCursorAsync(
    Query^ query
) sealed
public:
virtual Task<Cursor^>^ OpenCursorAsync(
    Query^ query
) sealed
abstract OpenCursorAsync :
        query : Query -> Task<Cursor>
override OpenCursorAsync :
        query : Query -> Task<Cursor>
abstract OpenCursorAsync :
        query : Query -> Task<Cursor>
override OpenCursorAsync :
        query : Query -> Task<Cursor>

Parameters

query
Type: NFX.DataAccess.CRUD Query

Return Value

Type: Online Task Cursor

Implements

ICRUDOperations OpenCursorAsync(Query)
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.Save Method

MySQLDataStore Save Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Save(
    params RowsetBase[] rowsets
)
public int Save(
    params RowsetBase[] rowsets
)
Public Function Save (
    ParamArray rowsets As RowsetBase()
) As Integer
Public Function Save (
    ParamArray rowsets As RowsetBase()
) As Integer
public:
virtual int Save(
    ... array<RowsetBase^>^ rowsets
) sealed
public:
virtual int Save(
    ... array<RowsetBase^>^ rowsets
) sealed
abstract Save :
        rowsets : RowsetBase[] -> int
override Save :
        rowsets : RowsetBase[] -> int
abstract Save :
        rowsets : RowsetBase[] -> int
override Save :
        rowsets : RowsetBase[] -> int

Parameters

rowsets
Type: NFX.DataAccess.CRUD RowsetBase

Return Value

Type: Online Int32

Implements

ICRUDOperations Save( RowsetBase )
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.SaveAsync Method

MySQLDataStore SaveAsync Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<int> SaveAsync(
    params RowsetBase[] rowsets
)
public Task<int> SaveAsync(
    params RowsetBase[] rowsets
)
Public Function SaveAsync (
    ParamArray rowsets As RowsetBase()
) As Task(Of Integer)
Public Function SaveAsync (
    ParamArray rowsets As RowsetBase()
) As Task(Of Integer)
public:
virtual Task<int>^ SaveAsync(
    ... array<RowsetBase^>^ rowsets
) sealed
public:
virtual Task<int>^ SaveAsync(
    ... array<RowsetBase^>^ rowsets
) sealed
abstract SaveAsync :
        rowsets : RowsetBase[] -> Task<int>
override SaveAsync :
        rowsets : RowsetBase[] -> Task<int>
abstract SaveAsync :
        rowsets : RowsetBase[] -> Task<int>
override SaveAsync :
        rowsets : RowsetBase[] -> Task<int>

Parameters

rowsets
Type: NFX.DataAccess.CRUD RowsetBase

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations SaveAsync( RowsetBase )
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.Update Method

MySQLDataStore Update Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Update(
    Row row,
    IDataStoreKey key = null,
    FieldFilterFunc filter = null
)
public int Update(
    Row row,
    IDataStoreKey key = null,
    FieldFilterFunc filter = null
)
Public Function Update (
    row As Row,
    Optional key As IDataStoreKey = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Public Function Update (
    row As Row,
    Optional key As IDataStoreKey = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
public:
virtual int Update(
    Row^ row,
    IDataStoreKey^ key = nullptr,
    FieldFilterFunc^ filter = nullptr
) sealed
public:
virtual int Update(
    Row^ row,
    IDataStoreKey^ key = nullptr,
    FieldFilterFunc^ filter = nullptr
) sealed
abstract Update :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> int
override Update :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> int
abstract Update :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> int
override Update :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32

Implements

ICRUDOperations Update(Row, IDataStoreKey, FieldFilterFunc)
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.UpdateAsync Method

MySQLDataStore UpdateAsync Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<int> UpdateAsync(
    Row row,
    IDataStoreKey key = null,
    FieldFilterFunc filter = null
)
public Task<int> UpdateAsync(
    Row row,
    IDataStoreKey key = null,
    FieldFilterFunc filter = null
)
Public Function UpdateAsync (
    row As Row,
    Optional key As IDataStoreKey = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
Public Function UpdateAsync (
    row As Row,
    Optional key As IDataStoreKey = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
public:
virtual Task<int>^ UpdateAsync(
    Row^ row,
    IDataStoreKey^ key = nullptr,
    FieldFilterFunc^ filter = nullptr
) sealed
public:
virtual Task<int>^ UpdateAsync(
    Row^ row,
    IDataStoreKey^ key = nullptr,
    FieldFilterFunc^ filter = nullptr
) sealed
abstract UpdateAsync :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> Task<int>
override UpdateAsync :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> Task<int>
abstract UpdateAsync :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> Task<int>
override UpdateAsync :
        row : Row *
        ?key : IDataStoreKey *
        ?filter : FieldFilterFunc
(* Defaults:
        let _key = defaultArg key null
        let _filter = defaultArg filter null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
key (Optional)
Type: NFX.DataAccess IDataStoreKey
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations UpdateAsync(Row, IDataStoreKey, FieldFilterFunc)
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.Upsert Method

MySQLDataStore Upsert Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Upsert(
    Row row,
    FieldFilterFunc filter = null
)
public int Upsert(
    Row row,
    FieldFilterFunc filter = null
)
Public Function Upsert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
Public Function Upsert (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Integer
public:
virtual int Upsert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) sealed
public:
virtual int Upsert(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) sealed
abstract Upsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override Upsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
abstract Upsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int
override Upsert :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> int

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Int32

Implements

ICRUDOperations Upsert(Row, FieldFilterFunc)
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.UpsertAsync Method

MySQLDataStore UpsertAsync Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<int> UpsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
public Task<int> UpsertAsync(
    Row row,
    FieldFilterFunc filter = null
)
Public Function UpsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
Public Function UpsertAsync (
    row As Row,
    Optional filter As FieldFilterFunc = Nothing
) As Task(Of Integer)
public:
virtual Task<int>^ UpsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) sealed
public:
virtual Task<int>^ UpsertAsync(
    Row^ row,
    FieldFilterFunc^ filter = nullptr
) sealed
abstract UpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
override UpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
abstract UpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>
override UpsertAsync :
        row : Row *
        ?filter : FieldFilterFunc
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Task<int>

Parameters

row
Type: NFX.DataAccess.CRUD Row
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Task Online Int32

Implements

ICRUDOperations UpsertAsync(Row, FieldFilterFunc)
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore Properties

MySQLDataStore Properties NFX Class Library

The MySQLDataStore type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | ConnectString | Get/Sets MySql database connection string (Inherited from MySQLDataStoreBase.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from MySQLDataStoreBase.)
Public property | FullGDIDS | When true (default) writes gdid as byte[](era+id), false - uses ulong ID only (Inherited from MySQLDataStoreBase.)
Public property | InstrumentationEnabled | (Inherited from MySQLDataStoreBase.)
Public property | LogLevel | (Inherited from MySQLDataStoreBase.)
Public property | Name | (Inherited from MySQLDataStoreBase.)
Public property | QueryResolver |
Public property | ScriptFileSuffix |
Public property | StoreType |
Public property | StringBool | When true commits boolean values as StringForTrue/StringForFalse instead of bool values. True by default (Inherited from MySQLDataStoreBase.)
Public property | StringForFalse | (Inherited from MySQLDataStoreBase.)
Public property | StringForTrue | (Inherited from MySQLDataStoreBase.)
Public property | SupportsTransactions |
Public property | SupportsTrueAsynchrony |
Public property | TargetName | (Inherited from MySQLDataStoreBase.)
Back to Top
See Also
MySQLDataStore Class
NFX.DataAccess.MySQL Namespace


MySQLDataStore.QueryResolver Property

MySQLDataStore QueryResolver Property NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ICRUDQueryResolver QueryResolver { get; }
public ICRUDQueryResolver QueryResolver { get; }
Public ReadOnly Property QueryResolver As ICRUDQueryResolver
    Get
Public ReadOnly Property QueryResolver As ICRUDQueryResolver
    Get
public:
virtual property ICRUDQueryResolver^ QueryResolver {
    ICRUDQueryResolver^ get () sealed;
}
public:
virtual property ICRUDQueryResolver^ QueryResolver {
    ICRUDQueryResolver^ get () sealed;
}
abstract QueryResolver : ICRUDQueryResolver with get
override QueryResolver : ICRUDQueryResolver with get
abstract QueryResolver : ICRUDQueryResolver with get
override QueryResolver : ICRUDQueryResolver with get

Property Value

Type: ICRUDQueryResolver

Implements

ICRUDDataStore QueryResolver
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.ScriptFileSuffix Property

MySQLDataStore ScriptFileSuffix Property NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ScriptFileSuffix { get; }
public string ScriptFileSuffix { get; }
Public ReadOnly Property ScriptFileSuffix As String
    Get
Public ReadOnly Property ScriptFileSuffix As String
    Get
public:
virtual property String^ ScriptFileSuffix {
    String^ get () sealed;
}
public:
virtual property String^ ScriptFileSuffix {
    String^ get () sealed;
}
abstract ScriptFileSuffix : string with get
override ScriptFileSuffix : string with get
abstract ScriptFileSuffix : string with get
override ScriptFileSuffix : string with get

Property Value

Type: Online String

Implements

ICRUDDataStore ScriptFileSuffix
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.StoreType Property

MySQLDataStore StoreType Property NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CRUDDataStoreType StoreType { get; }
public CRUDDataStoreType StoreType { get; }
Public ReadOnly Property StoreType As CRUDDataStoreType
    Get
Public ReadOnly Property StoreType As CRUDDataStoreType
    Get
public:
virtual property CRUDDataStoreType StoreType {
    CRUDDataStoreType get () sealed;
}
public:
virtual property CRUDDataStoreType StoreType {
    CRUDDataStoreType get () sealed;
}
abstract StoreType : CRUDDataStoreType with get
override StoreType : CRUDDataStoreType with get
abstract StoreType : CRUDDataStoreType with get
override StoreType : CRUDDataStoreType with get

Property Value

Type: CRUDDataStoreType

Implements

ICRUDDataStore StoreType
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.SupportsTransactions Property

MySQLDataStore SupportsTransactions Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsTransactions { get; }
public bool SupportsTransactions { get; }
Public ReadOnly Property SupportsTransactions As Boolean
    Get
Public ReadOnly Property SupportsTransactions As Boolean
    Get
public:
virtual property bool SupportsTransactions {
    bool get () sealed;
}
public:
virtual property bool SupportsTransactions {
    bool get () sealed;
}
abstract SupportsTransactions : bool with get
override SupportsTransactions : bool with get
abstract SupportsTransactions : bool with get
override SupportsTransactions : bool with get

Property Value

Type: Online Boolean

Implements

ICRUDTransactionOperations SupportsTransactions
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStore.SupportsTrueAsynchrony Property

MySQLDataStore SupportsTrueAsynchrony Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsTrueAsynchrony { get; }
public bool SupportsTrueAsynchrony { get; }
Public ReadOnly Property SupportsTrueAsynchrony As Boolean
    Get
Public ReadOnly Property SupportsTrueAsynchrony As Boolean
    Get
public:
virtual property bool SupportsTrueAsynchrony {
    bool get () sealed;
}
public:
virtual property bool SupportsTrueAsynchrony {
    bool get () sealed;
}
abstract SupportsTrueAsynchrony : bool with get
override SupportsTrueAsynchrony : bool with get
abstract SupportsTrueAsynchrony : bool with get
override SupportsTrueAsynchrony : bool with get

Property Value

Type: Online Boolean

Implements

ICRUDOperations SupportsTrueAsynchrony
See Also
MySQLDataStore Class
MySQLDataStore Members
NFX.DataAccess.MySQL Namespace


MySQLDataStoreBase Class

MySQLDataStoreBase Class NFX Class Library

Implements MySQL store base functionality
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.DataAccess.MySQL MySQLDataStoreBase
NFX.DataAccess.MySQL MySQLDataStore

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class MySQLDataStoreBase : ApplicationComponent,
    IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
public abstract class MySQLDataStoreBase : ApplicationComponent,
    IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
Public MustInherit Class MySQLDataStoreBase
    Inherits ApplicationComponent
    Implements IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
Public MustInherit Class MySQLDataStoreBase
    Inherits ApplicationComponent
    Implements IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
public ref class MySQLDataStoreBase abstract : public ApplicationComponent,
    IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
public ref class MySQLDataStoreBase abstract : public ApplicationComponent,
    IDataStoreImplementation, IDataStore, IApplicationComponent, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
[<AbstractClassAttribute>]
type MySQLDataStoreBase =
    class
        inherit ApplicationComponent
        interface IDataStoreImplementation
        interface IDataStore
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
[<AbstractClassAttribute>]
type MySQLDataStoreBase =
    class
        inherit ApplicationComponent
        interface IDataStoreImplementation
        interface IDataStore
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
MySQLDataStoreBase Members
NFX.DataAccess.MySQL Namespace


MySQLDataStoreBase Members

MySQLDataStoreBase Members NFX Class Library

The MySQLDataStoreBase type exposes the following members.
Constructors
 | Name | Description
Protected method | MySQLDataStoreBase | Initializes a new instance of the MySQLDataStoreBase class
Protected method | MySQLDataStoreBase(String) | Initializes a new instance of the MySQLDataStoreBase class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | Configure |
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetConnection | Allocates MySQL connection
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | TestConnection |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
STR_FOR_FALSE |
STR_FOR_TRUE |
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | ConnectString | Get/Sets MySql database connection string
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component
Public property | FullGDIDS | When true (default) writes gdid as byte[](era+id), false - uses ulong ID only
Public property | InstrumentationEnabled |
Public property | LogLevel |
Public property | Name |
Public property | StringBool | When true commits boolean values as StringForTrue/StringForFalse instead of bool values. True by default
Public property | StringForFalse |
Public property | StringForTrue |
Public property | TargetName |
Back to Top
See Also
MySQLDataStoreBase Class
NFX.DataAccess.MySQL Namespace


MySQLDataStoreBase Constructor

MySQLDataStoreBase Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | MySQLDataStoreBase | Initializes a new instance of the MySQLDataStoreBase class
Protected method | MySQLDataStoreBase(String) | Initializes a new instance of the MySQLDataStoreBase class
Back to Top
See Also
MySQLDataStoreBase Class
MySQLDataStoreBase Members
NFX.DataAccess.MySQL Namespace


MySQLDataStoreBase Constructor

MySQLDataStoreBase Constructor NFX Class Library

Initializes a new instance of the MySQLDataStoreBase class

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MySQLDataStoreBase()
protected MySQLDataStoreBase()
Protected Sub New
Protected Sub New
protected:
MySQLDataStoreBase()
protected:
MySQLDataStoreBase()
new : unit -> MySQLDataStoreBase
new : unit -> MySQLDataStoreBase
See Also
MySQLDataStoreBase Class
MySQLDataStoreBase Members
MySQLDataStoreBase Overload
NFX.DataAccess.MySQL Namespace


MySQLDataStoreBase Constructor (String)

MySQLDataStoreBase Constructor (String) NFX Class Library

Initializes a new instance of the MySQLDataStoreBase class

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MySQLDataStoreBase(
    string connectString
)
protected MySQLDataStoreBase(
    string connectString
)
Protected Sub New (
    connectString As String
)
Protected Sub New (
    connectString As String
)
protected:
MySQLDataStoreBase(
    String^ connectString
)
protected:
MySQLDataStoreBase(
    String^ connectString
)
new :
        connectString : string -> MySQLDataStoreBase
new :
        connectString : string -> MySQLDataStoreBase

Parameters

connectString
Type: Online System String
See Also
MySQLDataStoreBase Class
MySQLDataStoreBase Members
MySQLDataStoreBase Overload
NFX.DataAccess.MySQL Namespace


MySQLDataStoreBase Fields

MySQLDataStoreBase Fields NFX Class Library

The MySQLDataStoreBase type exposes the following members.
Fields
Name | Description
STR_FOR_FALSE |
STR_FOR_TRUE |
Back to Top
See Also
MySQLDataStoreBase Class
NFX.DataAccess.MySQL Namespace


MySQLDataStoreBase.STR_FOR_FALSE Field

MySQLDataStoreBase STR_FOR_FALSE Field NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string STR_FOR_FALSE
public const string STR_FOR_FALSE
Public Const STR_FOR_FALSE As String
Public Const STR_FOR_FALSE As String
public:
literal String^ STR_FOR_FALSE
public:
literal String^ STR_FOR_FALSE
static val mutable STR_FOR_FALSE: string
static val mutable STR_FOR_FALSE: string

Field Value

Type: Online String
See Also
MySQLDataStoreBase Class
MySQLDataStoreBase Members
NFX.DataAccess.MySQL Namespace


MySQLDataStoreBase.STR_FOR_TRUE Field

MySQLDataStoreBase STR_FOR_TRUE Field NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string STR_FOR_TRUE
public const string STR_FOR_TRUE
Public Const STR_FOR_TRUE As String
Public Const STR_FOR_TRUE As String
public:
literal String^ STR_FOR_TRUE
public:
literal String^ STR_FOR_TRUE
static val mutable STR_FOR_TRUE: string
static val mutable STR_FOR_TRUE: string

Field Value

Type: Online String
See Also
MySQLDataStoreBase Class
MySQLDataStoreBase Members
NFX.DataAccess.MySQL Namespace


MySQLDataStoreBase Methods

MySQLDataStoreBase Methods NFX Class Library

The MySQLDataStoreBase type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | Configure |
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetConnection | Allocates MySQL connection
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | TestConnection |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MySQLDataStoreBase Class
NFX.DataAccess.MySQL Namespace


MySQLDataStoreBase.Configure Method

MySQLDataStoreBase Configure Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Configure(
    IConfigSectionNode node
)
public virtual void Configure(
    IConfigSectionNode node
)
Public Overridable Sub Configure (
    node As IConfigSectionNode
)
Public Overridable Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
)
public:
virtual void Configure(
    IConfigSectionNode^ node
)
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
MySQLDataStoreBase Class
MySQLDataStoreBase Members
NFX.DataAccess.MySQL Namespace


MySQLDataStoreBase.ExternalGetParameter Method

MySQLDataStoreBase ExternalGetParameter Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets external parameter value returning true if parameter was found

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
public bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
Public Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
Public Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
) sealed
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
) sealed
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalGetParameter(String, Object , String )
See Also
MySQLDataStoreBase Class
MySQLDataStoreBase Members
NFX.DataAccess.MySQL Namespace


MySQLDataStoreBase.ExternalParametersForGroups Method

MySQLDataStoreBase ExternalParametersForGroups Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns named parameters that can be used to control this component

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
public IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
Public Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
Public Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
) sealed
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
) sealed
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>

Parameters

groups
Type: Online System String

Return Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParametersForGroups( String )
See Also
MySQLDataStoreBase Class
MySQLDataStoreBase Members
NFX.DataAccess.MySQL Namespace


MySQLDataStoreBase.ExternalSetParameter Method

MySQLDataStoreBase ExternalSetParameter Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Sets external parameter value returning true if parameter was found and set

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
public bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
Public Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
Public Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
) sealed
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
) sealed
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalSetParameter(String, Object, String )
See Also
MySQLDataStoreBase Class
MySQLDataStoreBase Members
NFX.DataAccess.MySQL Namespace


MySQLDataStoreBase.GetConnection Method

MySQLDataStoreBase GetConnection Method NFX Class Library

Allocates MySQL connection

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MySqlConnection GetConnection()
protected MySqlConnection GetConnection()
Protected Function GetConnection As MySqlConnection
Protected Function GetConnection As MySqlConnection
protected:
MySqlConnection^ GetConnection()
protected:
MySqlConnection^ GetConnection()
member GetConnection : unit -> MySqlConnection
member GetConnection : unit -> MySqlConnection

Return Value

Type: MySqlConnection
See Also
MySQLDataStoreBase Class
MySQLDataStoreBase Members
NFX.DataAccess.MySQL Namespace


MySQLDataStoreBase.TestConnection Method

MySQLDataStoreBase TestConnection Method NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void TestConnection()
public void TestConnection()
Public Sub TestConnection
Public Sub TestConnection
public:
virtual void TestConnection() sealed
public:
virtual void TestConnection() sealed
abstract TestConnection : unit -> unit
override TestConnection : unit -> unit
abstract TestConnection : unit -> unit
override TestConnection : unit -> unit

Implements

IDataStore TestConnection
See Also
MySQLDataStoreBase Class
MySQLDataStoreBase Members
NFX.DataAccess.MySQL Namespace


MySQLDataStoreBase Properties

MySQLDataStoreBase Properties NFX Class Library

The MySQLDataStoreBase type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | ConnectString | Get/Sets MySql database connection string
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component
Public property | FullGDIDS | When true (default) writes gdid as byte[](era+id), false - uses ulong ID only
Public property | InstrumentationEnabled |
Public property | LogLevel |
Public property | Name |
Public property | StringBool | When true commits boolean values as StringForTrue/StringForFalse instead of bool values. True by default
Public property | StringForFalse |
Public property | StringForTrue |
Public property | TargetName |
Back to Top
See Also
MySQLDataStoreBase Class
NFX.DataAccess.MySQL Namespace


MySQLDataStoreBase.ConnectString Property

MySQLDataStoreBase ConnectString Property NFX Class Library

Get/Sets MySql database connection string

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string ConnectString { get; set; }
[ConfigAttribute]
public string ConnectString { get; set; }
<ConfigAttribute>
Public Property ConnectString As String
    Get
    Set
<ConfigAttribute>
Public Property ConnectString As String
    Get
    Set
public:
[ConfigAttribute]
property String^ ConnectString {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ ConnectString {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member ConnectString : string with get, set
[<ConfigAttribute>]
member ConnectString : string with get, set

Property Value

Type: Online String
See Also
MySQLDataStoreBase Class
MySQLDataStoreBase Members
NFX.DataAccess.MySQL Namespace


MySQLDataStoreBase.ExternalParameters Property

MySQLDataStoreBase ExternalParameters Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns named parameters that can be used to control this component

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
public IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
Public ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
Public ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get () sealed;
}
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get () sealed;
}
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get

Property Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParameters
See Also
MySQLDataStoreBase Class
MySQLDataStoreBase Members
NFX.DataAccess.MySQL Namespace


MySQLDataStoreBase.FullGDIDS Property

MySQLDataStoreBase FullGDIDS Property NFX Class Library

When true (default) writes gdid as byte[](era+id), false - uses ulong ID only

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(Default = true)]
public bool FullGDIDS { get; set; }
[ConfigAttribute(Default = true)]
public bool FullGDIDS { get; set; }
<ConfigAttribute(Default := true)>
Public Property FullGDIDS As Boolean
    Get
    Set
<ConfigAttribute(Default := true)>
Public Property FullGDIDS As Boolean
    Get
    Set
public:
[ConfigAttribute(Default = true)]
property bool FullGDIDS {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute(Default = true)]
property bool FullGDIDS {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute(Default = true)>]
member FullGDIDS : bool with get, set
[<ConfigAttribute(Default = true)>]
member FullGDIDS : bool with get, set

Property Value

Type: Online Boolean
See Also
MySQLDataStoreBase Class
MySQLDataStoreBase Members
NFX.DataAccess.MySQL Namespace


MySQLDataStoreBase.InstrumentationEnabled Property

MySQLDataStoreBase InstrumentationEnabled Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute(Default = false)]
public bool InstrumentationEnabled { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute(Default = false)]
public bool InstrumentationEnabled { get; set; }
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute(Default := false)>
Public Property InstrumentationEnabled As Boolean
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute(Default := false)>
Public Property InstrumentationEnabled As Boolean
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(Default = false)]
virtual property bool InstrumentationEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(Default = false)]
virtual property bool InstrumentationEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
abstract InstrumentationEnabled : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
override InstrumentationEnabled : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
abstract InstrumentationEnabled : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
override InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentable InstrumentationEnabled
See Also
MySQLDataStoreBase Class
MySQLDataStoreBase Members
NFX.DataAccess.MySQL Namespace


MySQLDataStoreBase.LogLevel Property

MySQLDataStoreBase LogLevel Property NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public StoreLogLevel LogLevel { get; set; }
[ConfigAttribute]
public StoreLogLevel LogLevel { get; set; }
<ConfigAttribute>
Public Property LogLevel As StoreLogLevel
    Get
    Set
<ConfigAttribute>
Public Property LogLevel As StoreLogLevel
    Get
    Set
public:
[ConfigAttribute]
virtual property StoreLogLevel LogLevel {
    StoreLogLevel get () sealed;
    void set (StoreLogLevel value) sealed;
}
public:
[ConfigAttribute]
virtual property StoreLogLevel LogLevel {
    StoreLogLevel get () sealed;
    void set (StoreLogLevel value) sealed;
}
[<ConfigAttribute>]
abstract LogLevel : StoreLogLevel with get, set
[<ConfigAttribute>]
override LogLevel : StoreLogLevel with get, set
[<ConfigAttribute>]
abstract LogLevel : StoreLogLevel with get, set
[<ConfigAttribute>]
override LogLevel : StoreLogLevel with get, set

Property Value

Type: StoreLogLevel

Implements

IDataStoreImplementation LogLevel
See Also
MySQLDataStoreBase Class
MySQLDataStoreBase Members
NFX.DataAccess.MySQL Namespace


MySQLDataStoreBase.Name Property

MySQLDataStoreBase Name Property NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
public:
property String^ Name {
    String^ get ();
}
member Name : string with get
member Name : string with get

Property Value

Type: Online String
See Also
MySQLDataStoreBase Class
MySQLDataStoreBase Members
NFX.DataAccess.MySQL Namespace


MySQLDataStoreBase.StringBool Property

MySQLDataStoreBase StringBool Property NFX Class Library

When true commits boolean values as StringForTrue/StringForFalse instead of bool values. True by default

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(Default = true)]
public bool StringBool { get; set; }
[ConfigAttribute(Default = true)]
public bool StringBool { get; set; }
<ConfigAttribute(Default := true)>
Public Property StringBool As Boolean
    Get
    Set
<ConfigAttribute(Default := true)>
Public Property StringBool As Boolean
    Get
    Set
public:
[ConfigAttribute(Default = true)]
property bool StringBool {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute(Default = true)]
property bool StringBool {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute(Default = true)>]
member StringBool : bool with get, set
[<ConfigAttribute(Default = true)>]
member StringBool : bool with get, set

Property Value

Type: Online Boolean
See Also
MySQLDataStoreBase Class
MySQLDataStoreBase Members
NFX.DataAccess.MySQL Namespace


MySQLDataStoreBase.StringForFalse Property

MySQLDataStoreBase StringForFalse Property NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(Default = "F")]
public string StringForFalse { get; set; }
[ConfigAttribute(Default = "F")]
public string StringForFalse { get; set; }
<ConfigAttribute(Default := "F")>
Public Property StringForFalse As String
    Get
    Set
<ConfigAttribute(Default := "F")>
Public Property StringForFalse As String
    Get
    Set
public:
[ConfigAttribute(Default = L"F")]
property String^ StringForFalse {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute(Default = L"F")]
property String^ StringForFalse {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute(Default = "F")>]
member StringForFalse : string with get, set
[<ConfigAttribute(Default = "F")>]
member StringForFalse : string with get, set

Property Value

Type: Online String
See Also
MySQLDataStoreBase Class
MySQLDataStoreBase Members
NFX.DataAccess.MySQL Namespace


MySQLDataStoreBase.StringForTrue Property

MySQLDataStoreBase StringForTrue Property NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(Default = "T")]
public string StringForTrue { get; set; }
[ConfigAttribute(Default = "T")]
public string StringForTrue { get; set; }
<ConfigAttribute(Default := "T")>
Public Property StringForTrue As String
    Get
    Set
<ConfigAttribute(Default := "T")>
Public Property StringForTrue As String
    Get
    Set
public:
[ConfigAttribute(Default = L"T")]
property String^ StringForTrue {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute(Default = L"T")]
property String^ StringForTrue {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute(Default = "T")>]
member StringForTrue : string with get, set
[<ConfigAttribute(Default = "T")>]
member StringForTrue : string with get, set

Property Value

Type: Online String
See Also
MySQLDataStoreBase Class
MySQLDataStoreBase Members
NFX.DataAccess.MySQL Namespace


MySQLDataStoreBase.TargetName Property

MySQLDataStoreBase TargetName Property NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string TargetName { get; set; }
[ConfigAttribute]
public string TargetName { get; set; }
<ConfigAttribute>
Public Property TargetName As String
    Get
    Set
<ConfigAttribute>
Public Property TargetName As String
    Get
    Set
public:
[ConfigAttribute]
virtual property String^ TargetName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
[ConfigAttribute]
virtual property String^ TargetName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
[<ConfigAttribute>]
abstract TargetName : string with get, set
[<ConfigAttribute>]
override TargetName : string with get, set
[<ConfigAttribute>]
abstract TargetName : string with get, set
[<ConfigAttribute>]
override TargetName : string with get, set

Property Value

Type: Online String

Implements

IDataStore TargetName
See Also
MySQLDataStoreBase Class
MySQLDataStoreBase Members
NFX.DataAccess.MySQL Namespace


StringConsts Class

StringConsts Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.DataAccess.MySQL StringConsts

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static class StringConsts
internal static class StringConsts
Friend NotInheritable Class StringConsts
Friend NotInheritable Class StringConsts
internal ref class StringConsts abstract sealed
internal ref class StringConsts abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StringConsts =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StringConsts =  class end
See Also
StringConsts Members
NFX.DataAccess.MySQL Namespace


StringConsts Members

StringConsts Members NFX Class Library

The StringConsts type exposes the following members.
Fields
Name | Description
BROAD_UPDATE_ERROR |
CONNECTION_TEST_FAILED_ERROR |
CRUD_READONLY_SCHEMA_ERROR |
CRUD_STATEMENT_EXECUTION_ERROR |
EXECUTE_WITHOUT_FETCH_ERROR |
GET_SCHEMA_ERROR |
INVALID_KEY_TYPE_ERROR |
KEY_UNAVAILABLE_ERROR |
LOAD_ERROR |
LOAD_NO_SELECT_COLUMNS_ERROR |
LOADING_ENTITY_NOT_FOUND_ERROR |
MODEL_INVALID_STATE_ERROR |
MODEL_TYPE_NOT_RECORD_ERROR |
MODEL_TYPE_UNKNOWN_ERROR |
NO_ROWS_AFFECTED_ERROR |
OPEN_CURSOR_ERROR |
RECORD_TABLE_NAME_ERROR |
SQL_STATEMENT_FAILED_ERROR |
Back to Top
See Also
StringConsts Class
NFX.DataAccess.MySQL Namespace


StringConsts Fields

StringConsts Fields NFX Class Library

The StringConsts type exposes the following members.
Fields
Name | Description
BROAD_UPDATE_ERROR |
CONNECTION_TEST_FAILED_ERROR |
CRUD_READONLY_SCHEMA_ERROR |
CRUD_STATEMENT_EXECUTION_ERROR |
EXECUTE_WITHOUT_FETCH_ERROR |
GET_SCHEMA_ERROR |
INVALID_KEY_TYPE_ERROR |
KEY_UNAVAILABLE_ERROR |
LOAD_ERROR |
LOAD_NO_SELECT_COLUMNS_ERROR |
LOADING_ENTITY_NOT_FOUND_ERROR |
MODEL_INVALID_STATE_ERROR |
MODEL_TYPE_NOT_RECORD_ERROR |
MODEL_TYPE_UNKNOWN_ERROR |
NO_ROWS_AFFECTED_ERROR |
OPEN_CURSOR_ERROR |
RECORD_TABLE_NAME_ERROR |
SQL_STATEMENT_FAILED_ERROR |
Back to Top
See Also
StringConsts Class
NFX.DataAccess.MySQL Namespace


StringConsts.BROAD_UPDATE_ERROR Field

StringConsts BROAD_UPDATE_ERROR Field NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BROAD_UPDATE_ERROR
public const string BROAD_UPDATE_ERROR
Public Const BROAD_UPDATE_ERROR As String
Public Const BROAD_UPDATE_ERROR As String
public:
literal String^ BROAD_UPDATE_ERROR
public:
literal String^ BROAD_UPDATE_ERROR
static val mutable BROAD_UPDATE_ERROR: string
static val mutable BROAD_UPDATE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MySQL Namespace


StringConsts.CONNECTION_TEST_FAILED_ERROR Field

StringConsts CONNECTION_TEST_FAILED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONNECTION_TEST_FAILED_ERROR
public const string CONNECTION_TEST_FAILED_ERROR
Public Const CONNECTION_TEST_FAILED_ERROR As String
Public Const CONNECTION_TEST_FAILED_ERROR As String
public:
literal String^ CONNECTION_TEST_FAILED_ERROR
public:
literal String^ CONNECTION_TEST_FAILED_ERROR
static val mutable CONNECTION_TEST_FAILED_ERROR: string
static val mutable CONNECTION_TEST_FAILED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MySQL Namespace


StringConsts.CRUD_READONLY_SCHEMA_ERROR Field

StringConsts CRUD_READONLY_SCHEMA_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_READONLY_SCHEMA_ERROR
public const string CRUD_READONLY_SCHEMA_ERROR
Public Const CRUD_READONLY_SCHEMA_ERROR As String
Public Const CRUD_READONLY_SCHEMA_ERROR As String
public:
literal String^ CRUD_READONLY_SCHEMA_ERROR
public:
literal String^ CRUD_READONLY_SCHEMA_ERROR
static val mutable CRUD_READONLY_SCHEMA_ERROR: string
static val mutable CRUD_READONLY_SCHEMA_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MySQL Namespace


StringConsts.CRUD_STATEMENT_EXECUTION_ERROR Field

StringConsts CRUD_STATEMENT_EXECUTION_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CRUD_STATEMENT_EXECUTION_ERROR
public const string CRUD_STATEMENT_EXECUTION_ERROR
Public Const CRUD_STATEMENT_EXECUTION_ERROR As String
Public Const CRUD_STATEMENT_EXECUTION_ERROR As String
public:
literal String^ CRUD_STATEMENT_EXECUTION_ERROR
public:
literal String^ CRUD_STATEMENT_EXECUTION_ERROR
static val mutable CRUD_STATEMENT_EXECUTION_ERROR: string
static val mutable CRUD_STATEMENT_EXECUTION_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MySQL Namespace


StringConsts.EXECUTE_WITHOUT_FETCH_ERROR Field

StringConsts EXECUTE_WITHOUT_FETCH_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string EXECUTE_WITHOUT_FETCH_ERROR
public const string EXECUTE_WITHOUT_FETCH_ERROR
Public Const EXECUTE_WITHOUT_FETCH_ERROR As String
Public Const EXECUTE_WITHOUT_FETCH_ERROR As String
public:
literal String^ EXECUTE_WITHOUT_FETCH_ERROR
public:
literal String^ EXECUTE_WITHOUT_FETCH_ERROR
static val mutable EXECUTE_WITHOUT_FETCH_ERROR: string
static val mutable EXECUTE_WITHOUT_FETCH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MySQL Namespace


StringConsts.GET_SCHEMA_ERROR Field

StringConsts GET_SCHEMA_ERROR Field NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string GET_SCHEMA_ERROR
public const string GET_SCHEMA_ERROR
Public Const GET_SCHEMA_ERROR As String
Public Const GET_SCHEMA_ERROR As String
public:
literal String^ GET_SCHEMA_ERROR
public:
literal String^ GET_SCHEMA_ERROR
static val mutable GET_SCHEMA_ERROR: string
static val mutable GET_SCHEMA_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MySQL Namespace


StringConsts.INVALID_KEY_TYPE_ERROR Field

StringConsts INVALID_KEY_TYPE_ERROR Field NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string INVALID_KEY_TYPE_ERROR
public const string INVALID_KEY_TYPE_ERROR
Public Const INVALID_KEY_TYPE_ERROR As String
Public Const INVALID_KEY_TYPE_ERROR As String
public:
literal String^ INVALID_KEY_TYPE_ERROR
public:
literal String^ INVALID_KEY_TYPE_ERROR
static val mutable INVALID_KEY_TYPE_ERROR: string
static val mutable INVALID_KEY_TYPE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MySQL Namespace


StringConsts.KEY_UNAVAILABLE_ERROR Field

StringConsts KEY_UNAVAILABLE_ERROR Field NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string KEY_UNAVAILABLE_ERROR
public const string KEY_UNAVAILABLE_ERROR
Public Const KEY_UNAVAILABLE_ERROR As String
Public Const KEY_UNAVAILABLE_ERROR As String
public:
literal String^ KEY_UNAVAILABLE_ERROR
public:
literal String^ KEY_UNAVAILABLE_ERROR
static val mutable KEY_UNAVAILABLE_ERROR: string
static val mutable KEY_UNAVAILABLE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MySQL Namespace


StringConsts.LOAD_ERROR Field

StringConsts LOAD_ERROR Field NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string LOAD_ERROR
public const string LOAD_ERROR
Public Const LOAD_ERROR As String
Public Const LOAD_ERROR As String
public:
literal String^ LOAD_ERROR
public:
literal String^ LOAD_ERROR
static val mutable LOAD_ERROR: string
static val mutable LOAD_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MySQL Namespace


StringConsts.LOAD_NO_SELECT_COLUMNS_ERROR Field

StringConsts LOAD_NO_SELECT_COLUMNS_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string LOAD_NO_SELECT_COLUMNS_ERROR
public const string LOAD_NO_SELECT_COLUMNS_ERROR
Public Const LOAD_NO_SELECT_COLUMNS_ERROR As String
Public Const LOAD_NO_SELECT_COLUMNS_ERROR As String
public:
literal String^ LOAD_NO_SELECT_COLUMNS_ERROR
public:
literal String^ LOAD_NO_SELECT_COLUMNS_ERROR
static val mutable LOAD_NO_SELECT_COLUMNS_ERROR: string
static val mutable LOAD_NO_SELECT_COLUMNS_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MySQL Namespace


StringConsts.LOADING_ENTITY_NOT_FOUND_ERROR Field

StringConsts LOADING_ENTITY_NOT_FOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string LOADING_ENTITY_NOT_FOUND_ERROR
public const string LOADING_ENTITY_NOT_FOUND_ERROR
Public Const LOADING_ENTITY_NOT_FOUND_ERROR As String
Public Const LOADING_ENTITY_NOT_FOUND_ERROR As String
public:
literal String^ LOADING_ENTITY_NOT_FOUND_ERROR
public:
literal String^ LOADING_ENTITY_NOT_FOUND_ERROR
static val mutable LOADING_ENTITY_NOT_FOUND_ERROR: string
static val mutable LOADING_ENTITY_NOT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MySQL Namespace


StringConsts.MODEL_INVALID_STATE_ERROR Field

StringConsts MODEL_INVALID_STATE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MODEL_INVALID_STATE_ERROR
public const string MODEL_INVALID_STATE_ERROR
Public Const MODEL_INVALID_STATE_ERROR As String
Public Const MODEL_INVALID_STATE_ERROR As String
public:
literal String^ MODEL_INVALID_STATE_ERROR
public:
literal String^ MODEL_INVALID_STATE_ERROR
static val mutable MODEL_INVALID_STATE_ERROR: string
static val mutable MODEL_INVALID_STATE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MySQL Namespace


StringConsts.MODEL_TYPE_NOT_RECORD_ERROR Field

StringConsts MODEL_TYPE_NOT_RECORD_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MODEL_TYPE_NOT_RECORD_ERROR
public const string MODEL_TYPE_NOT_RECORD_ERROR
Public Const MODEL_TYPE_NOT_RECORD_ERROR As String
Public Const MODEL_TYPE_NOT_RECORD_ERROR As String
public:
literal String^ MODEL_TYPE_NOT_RECORD_ERROR
public:
literal String^ MODEL_TYPE_NOT_RECORD_ERROR
static val mutable MODEL_TYPE_NOT_RECORD_ERROR: string
static val mutable MODEL_TYPE_NOT_RECORD_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MySQL Namespace


StringConsts.MODEL_TYPE_UNKNOWN_ERROR Field

StringConsts MODEL_TYPE_UNKNOWN_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MODEL_TYPE_UNKNOWN_ERROR
public const string MODEL_TYPE_UNKNOWN_ERROR
Public Const MODEL_TYPE_UNKNOWN_ERROR As String
Public Const MODEL_TYPE_UNKNOWN_ERROR As String
public:
literal String^ MODEL_TYPE_UNKNOWN_ERROR
public:
literal String^ MODEL_TYPE_UNKNOWN_ERROR
static val mutable MODEL_TYPE_UNKNOWN_ERROR: string
static val mutable MODEL_TYPE_UNKNOWN_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MySQL Namespace


StringConsts.NO_ROWS_AFFECTED_ERROR Field

StringConsts NO_ROWS_AFFECTED_ERROR Field NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string NO_ROWS_AFFECTED_ERROR
public const string NO_ROWS_AFFECTED_ERROR
Public Const NO_ROWS_AFFECTED_ERROR As String
Public Const NO_ROWS_AFFECTED_ERROR As String
public:
literal String^ NO_ROWS_AFFECTED_ERROR
public:
literal String^ NO_ROWS_AFFECTED_ERROR
static val mutable NO_ROWS_AFFECTED_ERROR: string
static val mutable NO_ROWS_AFFECTED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MySQL Namespace


StringConsts.OPEN_CURSOR_ERROR Field

StringConsts OPEN_CURSOR_ERROR Field NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string OPEN_CURSOR_ERROR
public const string OPEN_CURSOR_ERROR
Public Const OPEN_CURSOR_ERROR As String
Public Const OPEN_CURSOR_ERROR As String
public:
literal String^ OPEN_CURSOR_ERROR
public:
literal String^ OPEN_CURSOR_ERROR
static val mutable OPEN_CURSOR_ERROR: string
static val mutable OPEN_CURSOR_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MySQL Namespace


StringConsts.RECORD_TABLE_NAME_ERROR Field

StringConsts RECORD_TABLE_NAME_ERROR Field NFX Class Library

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string RECORD_TABLE_NAME_ERROR
public const string RECORD_TABLE_NAME_ERROR
Public Const RECORD_TABLE_NAME_ERROR As String
Public Const RECORD_TABLE_NAME_ERROR As String
public:
literal String^ RECORD_TABLE_NAME_ERROR
public:
literal String^ RECORD_TABLE_NAME_ERROR
static val mutable RECORD_TABLE_NAME_ERROR: string
static val mutable RECORD_TABLE_NAME_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MySQL Namespace


StringConsts.SQL_STATEMENT_FAILED_ERROR Field

StringConsts SQL_STATEMENT_FAILED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.DataAccess.MySQL
Assembly: NFX.MySQL (in NFX.MySQL.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SQL_STATEMENT_FAILED_ERROR
public const string SQL_STATEMENT_FAILED_ERROR
Public Const SQL_STATEMENT_FAILED_ERROR As String
Public Const SQL_STATEMENT_FAILED_ERROR As String
public:
literal String^ SQL_STATEMENT_FAILED_ERROR
public:
literal String^ SQL_STATEMENT_FAILED_ERROR
static val mutable SQL_STATEMENT_FAILED_ERROR: string
static val mutable SQL_STATEMENT_FAILED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.DataAccess.MySQL Namespace


NFX.Environment Namespace

NFX.Environment Namespace NFX Class Library

Provides configuration and environment-related(i.e. environment variables, command-line parser) classes
Classes
 | Class | Description
Public class | Behavior | Represents a piece of logic that can be applied to different entities declaratively as attribute or through configuration. Behaviors are a form of inversion-of-control that allows to configure entities by code which itself can be injected by name from configuration. Behaviors are a form of aspect-oriented programming as they allow to proclaim certain "behavior" that knows how to implement itself on various application components (i.e. some behavior may inject Glue message inspector or log destination). Behaviors can be used to enforce policies by performing pre-run checks and throw exceptions if certain required providers are not injected/configured
Public class | BehaviorApplyException | Thrown by Behavior class to indicate behavior apply error
Public class | BuildInformation | Retrieves build information encapsulated into a module in the form of an embedded resource
Public class | CommandArgsConfiguration | Provides implementation of configuration based on arguments supplied from command line which is "string[]". Arguments start with either "/" or "-" prefix. If any argument is not prefixed then it is written as an auto-named attribute node of the root with its value set, otherwise a section (under root) with argument's name is created. Any argument may have options. Any option may either consist of name or name value pair delimited by "=". Argument options are written as attribute nodes of their corresponding sections. If option value specified without name (without "=") then option is auto-named
Public class | ConfigAttribute | Specifies how to apply configuration values to classes/fields/props
Public class | ConfigAttrNode | Represents an attribute of a attribute node
Protected class | ConfigAttrNodeList |
Public class | ConfigException | Configuration-related exception
Public class | ConfigMacroContextAttribute | Decorates classes or structs that act as a context object for macro evaluation - passed as context parameter to MacroRunner.Run(...context) method
Public class | ConfigNode | Provides configuration node abstraction for section and attribute nodes. This class is thread-safe
Public class | ConfigNodeEqualityComparer | Performs deep structural comparison of IConfigNodes
Public class | ConfigSectionNode | Represents configuration section node. This class is thread safe
Protected class | ConfigSectionNodeList |
Public class | ConfigStringBuilder | Facilitates the creation/building of strings from existing strings or configuration vectors. This is used for example to build DB connect strings from host names that need to be resolved via an external system
Public class | Configuration | Provides top-level configuration abstraction
Public class | DefaultMacroRunner | Provides default implementation for configuration variable macros. NOTE: When serialized a new instance is created which will not equal by reference to static.Instance property
Public class | FactoryUtils | Provides helper methods for dynamic object creation and configuration
Public class | FileConfiguration | Provides file-based configuration base object used for concrete implementations such as XML or INI file base configurations
Public class | JSONConfiguration | Provides implementation of configuration based on a classic JSON content
Public class | LaconicConfiguration | Provides implementation of configuration based on Laconic content format
Public class | MemoryConfiguration | Implements configuration that can not be persisted/loaded anywhere - just stored in memory
Public class | NodeOverrideRules | Contains node override rule definitions such as override specifier names and values. This class is used for merging/override of configurations/nodes
Public class | ScriptRunner | Executes configuration scripts which are embedded in configuration
Public class | Vars | Allows for simple ad-hoc environment var passing to configuration
Public class | WindowsEnvironmentVariableResolver | Resolves variables using Windows environment variables. NOTE: When serialized a new instance is created which will not equal by reference to static.Instance property
Public class | XMLConfiguration | Provides implementation of configuration based on a classic XML content
Interfaces
 | Interface | Description
Public interface | IConfigAttrNode | Represents a read-only attribute of a attribute node
Public interface | IConfigNode | Provides read-only configuration node abstraction for section and attribute nodes
Public interface | IConfigNodeProvider | Represents an entity that provides config node. It is primarily used for includes
Public interface | IConfigSectionNode | Provides read-only configuration section node abstraction
Public interface | IConfigSettings | Represents an entity that provides a type-safe access to configuration settings that come from Configuration nodes. This class obviates the need for navigation between config nodes on every property get and facilitates faster access to some config parameters that need to be gotten efficiently, as they are now kept cached in RAM in native format (i.e. DateTime vs. string) as fields. Usually classes that implement this interface are singleton and they get registered with the application using IApplication.RegisterConfigSettings() method. Warning: the implementation must be thread-safe and allow property getters to keep reading while ConfigChanged() notification happens
Public interface | IConfigStringBuilder | Denotes objects that can build a string (i.e. a database connection string) from the configured state/properties. This is used for example to build DB connect strings from host names that need to be resolved via an external system
Public interface | IConfigurable | Designates entities that may be configured
Public interface | IConfigurationPersistent | Designates entities that may persist their parameters/state in configuration
Public interface | IEnvironmentVariableResolver | Represents an entity that can resolve variables
Public interface | IMacroRunner | Represents an entity that runs config var macros
Enumerations
 | Enumeration | Description
Public enumeration | OverrideSpec | Override specifications that dictate what to do when another node supplies entity with the same name


Behavior Class

Behavior Class NFX Class Library

Represents a piece of logic that can be applied to different entities declaratively as attribute or through configuration. Behaviors are a form of inversion-of-control that allows to configure entities by code which itself can be injected by name from configuration. Behaviors are a form of aspect-oriented programming as they allow to proclaim certain "behavior" that knows how to implement itself on various application components (i.e. some behavior may inject Glue message inspector or log destination). Behaviors can be used to enforce policies by performing pre-run checks and throw exceptions if certain required providers are not injected/configured
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.Environment Behavior

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.Class, Inherited = true, AllowMultiple = false)]
public abstract class Behavior : Attribute,
    IConfigurable
[AttributeUsageAttribute(AttributeTargets.Class, Inherited = true, AllowMultiple = false)]
public abstract class Behavior : Attribute,
    IConfigurable
<AttributeUsageAttribute(AttributeTargets.Class, Inherited := true, AllowMultiple := false)>
Public MustInherit Class Behavior
    Inherits Attribute
    Implements IConfigurable
<AttributeUsageAttribute(AttributeTargets.Class, Inherited := true, AllowMultiple := false)>
Public MustInherit Class Behavior
    Inherits Attribute
    Implements IConfigurable
[AttributeUsageAttribute(AttributeTargets::Class, Inherited = true, AllowMultiple = false)]
public ref class Behavior abstract : public Attribute,
    IConfigurable
[AttributeUsageAttribute(AttributeTargets::Class, Inherited = true, AllowMultiple = false)]
public ref class Behavior abstract : public Attribute,
    IConfigurable
[<AbstractClassAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Class, Inherited = true, AllowMultiple = false)>]
type Behavior =
    class
        inherit Attribute
        interface IConfigurable
    end
[<AbstractClassAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Class, Inherited = true, AllowMultiple = false)>]
type Behavior =
    class
        inherit Attribute
        interface IConfigurable
    end
See Also
Behavior Members
NFX.Environment Namespace


Behavior Members

Behavior Members NFX Class Library

The Behavior type exposes the following members.
Constructors
 | Name | Description
Protected method | Behavior | Initializes a new instance of the Behavior class
Protected method | Behavior(Int32) | Initializes a new instance of the Behavior class
Back to Top
Methods
 | Name | Description
Public method | Apply | Override to apply particular behavior to the target
 | ApplyBehaviorAttributes | Applies behaviors as declared using attributes on target isntance's type
 | ApplyConfiguredBehaviors | Applies behaviors to instance as configured from config section node
Public method | Configure |
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_BEHAVIOR_SECTION |
CONFIG_BEHAVIORS_SECTION |
CONFIG_CASCADE_ATTR |
Back to Top
Properties
 | Name | Description
Public property | Cascade | Returns true when this instance was configured to cascade down the configuration tree - applied to child items
Public property | Order | Returns application order
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
Behavior Class
NFX.Environment Namespace


Behavior Constructor

Behavior Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | Behavior | Initializes a new instance of the Behavior class
Protected method | Behavior(Int32) | Initializes a new instance of the Behavior class
Back to Top
See Also
Behavior Class
Behavior Members
NFX.Environment Namespace


Behavior Constructor

Behavior Constructor NFX Class Library

Initializes a new instance of the Behavior class

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Behavior()
protected Behavior()
Protected Sub New
Protected Sub New
protected:
Behavior()
protected:
Behavior()
new : unit -> Behavior
new : unit -> Behavior
See Also
Behavior Class
Behavior Members
Behavior Overload
NFX.Environment Namespace


Behavior Constructor (Int32)

Behavior Constructor (Int32) NFX Class Library

Initializes a new instance of the Behavior class

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Behavior(
    int order
)
protected Behavior(
    int order
)
Protected Sub New (
    order As Integer
)
Protected Sub New (
    order As Integer
)
protected:
Behavior(
    int order
)
protected:
Behavior(
    int order
)
new :
        order : int -> Behavior
new :
        order : int -> Behavior

Parameters

order
Type: Online System Int32
See Also
Behavior Class
Behavior Members
Behavior Overload
NFX.Environment Namespace


Behavior Fields

Behavior Fields NFX Class Library

The Behavior type exposes the following members.
Fields
Name | Description
CONFIG_BEHAVIOR_SECTION |
CONFIG_BEHAVIORS_SECTION |
CONFIG_CASCADE_ATTR |
Back to Top
See Also
Behavior Class
NFX.Environment Namespace


Behavior.CONFIG_BEHAVIOR_SECTION Field

Behavior CONFIG_BEHAVIOR_SECTION Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_BEHAVIOR_SECTION
public const string CONFIG_BEHAVIOR_SECTION
Public Const CONFIG_BEHAVIOR_SECTION As String
Public Const CONFIG_BEHAVIOR_SECTION As String
public:
literal String^ CONFIG_BEHAVIOR_SECTION
public:
literal String^ CONFIG_BEHAVIOR_SECTION
static val mutable CONFIG_BEHAVIOR_SECTION: string
static val mutable CONFIG_BEHAVIOR_SECTION: string

Field Value

Type: Online String
See Also
Behavior Class
Behavior Members
NFX.Environment Namespace


Behavior.CONFIG_BEHAVIORS_SECTION Field

Behavior CONFIG_BEHAVIORS_SECTION Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_BEHAVIORS_SECTION
public const string CONFIG_BEHAVIORS_SECTION
Public Const CONFIG_BEHAVIORS_SECTION As String
Public Const CONFIG_BEHAVIORS_SECTION As String
public:
literal String^ CONFIG_BEHAVIORS_SECTION
public:
literal String^ CONFIG_BEHAVIORS_SECTION
static val mutable CONFIG_BEHAVIORS_SECTION: string
static val mutable CONFIG_BEHAVIORS_SECTION: string

Field Value

Type: Online String
See Also
Behavior Class
Behavior Members
NFX.Environment Namespace


Behavior.CONFIG_CASCADE_ATTR Field

Behavior CONFIG_CASCADE_ATTR Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CASCADE_ATTR
public const string CONFIG_CASCADE_ATTR
Public Const CONFIG_CASCADE_ATTR As String
Public Const CONFIG_CASCADE_ATTR As String
public:
literal String^ CONFIG_CASCADE_ATTR
public:
literal String^ CONFIG_CASCADE_ATTR
static val mutable CONFIG_CASCADE_ATTR: string
static val mutable CONFIG_CASCADE_ATTR: string

Field Value

Type: Online String
See Also
Behavior Class
Behavior Members
NFX.Environment Namespace


Behavior Methods

Behavior Methods NFX Class Library

The Behavior type exposes the following members.
Methods
 | Name | Description
Public method | Apply | Override to apply particular behavior to the target
 | ApplyBehaviorAttributes | Applies behaviors as declared using attributes on target isntance's type
 | ApplyConfiguredBehaviors | Applies behaviors to instance as configured from config section node
Public method | Configure |
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Behavior Class
NFX.Environment Namespace


Behavior.Apply Method

Behavior Apply Method NFX Class Library

Override to apply particular behavior to the target

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Apply(
    Object target
)
public abstract void Apply(
    Object target
)
Public MustOverride Sub Apply (
    target As Object
)
Public MustOverride Sub Apply (
    target As Object
)
public:
virtual void Apply(
    Object^ target
) abstract
public:
virtual void Apply(
    Object^ target
) abstract
abstract Apply :
        target : Object -> unit
abstract Apply :
        target : Object -> unit

Parameters

target
Type: Online System Object
See Also
Behavior Class
Behavior Members
NFX.Environment Namespace


Behavior.ApplyBehaviorAttributes Method

Behavior ApplyBehaviorAttributes Method NFX Class Library

Applies behaviors as declared using attributes on target isntance's type

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ApplyBehaviorAttributes(
    Object target
)
public static void ApplyBehaviorAttributes(
    Object target
)
Public Shared Sub ApplyBehaviorAttributes (
    target As Object
)
Public Shared Sub ApplyBehaviorAttributes (
    target As Object
)
public:
static void ApplyBehaviorAttributes(
    Object^ target
)
public:
static void ApplyBehaviorAttributes(
    Object^ target
)
static member ApplyBehaviorAttributes :
        target : Object -> unit
static member ApplyBehaviorAttributes :
        target : Object -> unit

Parameters

target
Type: Online System Object
See Also
Behavior Class
Behavior Members
NFX.Environment Namespace


Behavior.ApplyConfiguredBehaviors Method

Behavior ApplyConfiguredBehaviors Method NFX Class Library

Applies behaviors to instance as configured from config section node

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ApplyConfiguredBehaviors(
    Object target,
    IConfigSectionNode node
)
public static void ApplyConfiguredBehaviors(
    Object target,
    IConfigSectionNode node
)
Public Shared Sub ApplyConfiguredBehaviors (
    target As Object,
    node As IConfigSectionNode
)
Public Shared Sub ApplyConfiguredBehaviors (
    target As Object,
    node As IConfigSectionNode
)
public:
static void ApplyConfiguredBehaviors(
    Object^ target,
    IConfigSectionNode^ node
)
public:
static void ApplyConfiguredBehaviors(
    Object^ target,
    IConfigSectionNode^ node
)
static member ApplyConfiguredBehaviors :
        target : Object *
        node : IConfigSectionNode -> unit
static member ApplyConfiguredBehaviors :
        target : Object *
        node : IConfigSectionNode -> unit

Parameters

target
Type: Online System Object
node
Type: NFX.Environment IConfigSectionNode
See Also
Behavior Class
Behavior Members
NFX.Environment Namespace


Behavior.Configure Method

Behavior Configure Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Configure(
    IConfigSectionNode node
)
public virtual void Configure(
    IConfigSectionNode node
)
Public Overridable Sub Configure (
    node As IConfigSectionNode
)
Public Overridable Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
)
public:
virtual void Configure(
    IConfigSectionNode^ node
)
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
Behavior Class
Behavior Members
NFX.Environment Namespace


Behavior Properties

Behavior Properties NFX Class Library

The Behavior type exposes the following members.
Properties
 | Name | Description
Public property | Cascade | Returns true when this instance was configured to cascade down the configuration tree - applied to child items
Public property | Order | Returns application order
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
Behavior Class
NFX.Environment Namespace


Behavior.Cascade Property

Behavior Cascade Property NFX Class Library

Returns true when this instance was configured to cascade down the configuration tree - applied to child items

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Cascade { get; }
public bool Cascade { get; }
Public ReadOnly Property Cascade As Boolean
    Get
Public ReadOnly Property Cascade As Boolean
    Get
public:
property bool Cascade {
    bool get ();
}
public:
property bool Cascade {
    bool get ();
}
member Cascade : bool with get
member Cascade : bool with get

Property Value

Type: Online Boolean
See Also
Behavior Class
Behavior Members
NFX.Environment Namespace


Behavior.Order Property

Behavior Order Property NFX Class Library

Returns application order

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Order { get; }
public int Order { get; }
Public ReadOnly Property Order As Integer
    Get
Public ReadOnly Property Order As Integer
    Get
public:
property int Order {
    int get ();
}
public:
property int Order {
    int get ();
}
member Order : int with get
member Order : int with get

Property Value

Type: Online Int32
See Also
Behavior Class
Behavior Members
NFX.Environment Namespace


BehaviorApplyException Class

BehaviorApplyException Class NFX Class Library

Thrown by Behavior class to indicate behavior apply error
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Environment ConfigException
NFX.Environment BehaviorApplyException

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class BehaviorApplyException : ConfigException
[SerializableAttribute]
public sealed class BehaviorApplyException : ConfigException
<SerializableAttribute>
Public NotInheritable Class BehaviorApplyException
    Inherits ConfigException
<SerializableAttribute>
Public NotInheritable Class BehaviorApplyException
    Inherits ConfigException
[SerializableAttribute]
public ref class BehaviorApplyException sealed : public ConfigException
[SerializableAttribute]
public ref class BehaviorApplyException sealed : public ConfigException
[<SealedAttribute>]
[<SerializableAttribute>]
type BehaviorApplyException =
    class
        inherit ConfigException
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type BehaviorApplyException =
    class
        inherit ConfigException
    end
See Also
BehaviorApplyException Members
NFX.Environment Namespace


BehaviorApplyException Members

BehaviorApplyException Members NFX Class Library

The BehaviorApplyException type exposes the following members.
Constructors
 | Name | Description
Public method | BehaviorApplyException | Initializes a new instance of the BehaviorApplyException class
Public method | BehaviorApplyException(SerializationInfo, StreamingContext) | Initializes a new instance of the BehaviorApplyException class
Public method | BehaviorApplyException(String, Exception) | Initializes a new instance of the BehaviorApplyException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
BehaviorApplyException Class
NFX.Environment Namespace


BehaviorApplyException Constructor

BehaviorApplyException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | BehaviorApplyException | Initializes a new instance of the BehaviorApplyException class
Public method | BehaviorApplyException(SerializationInfo, StreamingContext) | Initializes a new instance of the BehaviorApplyException class
Public method | BehaviorApplyException(String, Exception) | Initializes a new instance of the BehaviorApplyException class
Back to Top
See Also
BehaviorApplyException Class
BehaviorApplyException Members
NFX.Environment Namespace


BehaviorApplyException Constructor

BehaviorApplyException Constructor NFX Class Library

Initializes a new instance of the BehaviorApplyException class

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BehaviorApplyException()
public BehaviorApplyException()
Public Sub New
Public Sub New
public:
BehaviorApplyException()
public:
BehaviorApplyException()
new : unit -> BehaviorApplyException
new : unit -> BehaviorApplyException
See Also
BehaviorApplyException Class
BehaviorApplyException Members
BehaviorApplyException Overload
NFX.Environment Namespace


BehaviorApplyException Constructor (SerializationInfo, StreamingContext)

BehaviorApplyException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BehaviorApplyException class

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BehaviorApplyException(
    SerializationInfo info,
    StreamingContext context
)
public BehaviorApplyException(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
BehaviorApplyException(
    SerializationInfo^ info,
    StreamingContext context
)
public:
BehaviorApplyException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> BehaviorApplyException
new :
        info : SerializationInfo *
        context : StreamingContext -> BehaviorApplyException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
BehaviorApplyException Class
BehaviorApplyException Members
BehaviorApplyException Overload
NFX.Environment Namespace


BehaviorApplyException Constructor (String, Exception)

BehaviorApplyException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BehaviorApplyException class

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BehaviorApplyException(
    string message,
    Exception inner
)
public BehaviorApplyException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
BehaviorApplyException(
    String^ message,
    Exception^ inner
)
public:
BehaviorApplyException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> BehaviorApplyException
new :
        message : string *
        inner : Exception -> BehaviorApplyException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
BehaviorApplyException Class
BehaviorApplyException Members
BehaviorApplyException Overload
NFX.Environment Namespace


BehaviorApplyException Methods

BehaviorApplyException Methods NFX Class Library

The BehaviorApplyException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
BehaviorApplyException Class
NFX.Environment Namespace


BehaviorApplyException Properties

BehaviorApplyException Properties NFX Class Library

The BehaviorApplyException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
BehaviorApplyException Class
NFX.Environment Namespace


BehaviorApplyException Events

BehaviorApplyException Events NFX Class Library

The BehaviorApplyException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
BehaviorApplyException Class
NFX.Environment Namespace


BuildInformation Class

BuildInformation Class NFX Class Library

Retrieves build information encapsulated into a module in the form of an embedded resource
Inheritance Hierarchy
Online System Object
NFX.Environment BuildInformation

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class BuildInformation
[SerializableAttribute]
public class BuildInformation
<SerializableAttribute>
Public Class BuildInformation
<SerializableAttribute>
Public Class BuildInformation
[SerializableAttribute]
public ref class BuildInformation
[SerializableAttribute]
public ref class BuildInformation
[<SerializableAttribute>]
type BuildInformation =  class end
[<SerializableAttribute>]
type BuildInformation =  class end
See Also
BuildInformation Members
NFX.Environment Namespace


BuildInformation Members

BuildInformation Members NFX Class Library

The BuildInformation type exposes the following members.
Constructors
 | Name | Description
Public method | BuildInformation | Creates and instance of BuildInformation class from the specified resource path in particular assembly. If assembly is null then BuildInformation for the whole framework is returned. If Path is null then the first found BUILD info resource is used from the specified assembly
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
BUILD_INFO_RESOURCE |
FRAMEWORK_BUILD_INFO_PATH |
Back to Top
Properties
 | Name | Description
Public property | AssemblyName | Rertuns assembly name that this information was obtained from
Public property | BuildSeed | Returns random number assigned to a build. It is NOT guaranteed to be unique
Public property | Computer | A name of the computer that performed build
Public property | DateStampUTC | Date and time stamp when build was performed
 | ForFramework | Return framework build information
Public property | OS | OS name
Public property | OSVer | OS version name
Public property | User | a name of user that build session was logged under
Back to Top
See Also
BuildInformation Class
NFX.Environment Namespace


BuildInformation Constructor

BuildInformation Constructor NFX Class Library

Creates and instance of BuildInformation class from the specified resource path in particular assembly. If assembly is null then BuildInformation for the whole framework is returned. If Path is null then the first found BUILD info resource is used from the specified assembly

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BuildInformation(
    Assembly assembly,
    string path = null,
    bool throwError = true
)
public BuildInformation(
    Assembly assembly,
    string path = null,
    bool throwError = true
)
Public Sub New (
    assembly As Assembly,
    Optional path As String = Nothing,
    Optional throwError As Boolean = true
)
Public Sub New (
    assembly As Assembly,
    Optional path As String = Nothing,
    Optional throwError As Boolean = true
)
public:
BuildInformation(
    Assembly^ assembly,
    String^ path = nullptr,
    bool throwError = true
)
public:
BuildInformation(
    Assembly^ assembly,
    String^ path = nullptr,
    bool throwError = true
)
new :
        assembly : Assembly *
        ?path : string *
        ?throwError : bool
(* Defaults:
        let _path = defaultArg path null
        let _throwError = defaultArg throwError true
*)
-> BuildInformation
new :
        assembly : Assembly *
        ?path : string *
        ?throwError : bool
(* Defaults:
        let _path = defaultArg path null
        let _throwError = defaultArg throwError true
*)
-> BuildInformation

Parameters

assembly
Type: Online System.Reflection Assembly
path (Optional)
Type: Online System String
throwError (Optional)
Type: Online System Boolean
See Also
BuildInformation Class
BuildInformation Members
NFX.Environment Namespace


BuildInformation Fields

BuildInformation Fields NFX Class Library

The BuildInformation type exposes the following members.
Fields
Name | Description
BUILD_INFO_RESOURCE |
FRAMEWORK_BUILD_INFO_PATH |
Back to Top
See Also
BuildInformation Class
NFX.Environment Namespace


BuildInformation.BUILD_INFO_RESOURCE Field

BuildInformation BUILD_INFO_RESOURCE Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BUILD_INFO_RESOURCE
public const string BUILD_INFO_RESOURCE
Public Const BUILD_INFO_RESOURCE As String
Public Const BUILD_INFO_RESOURCE As String
public:
literal String^ BUILD_INFO_RESOURCE
public:
literal String^ BUILD_INFO_RESOURCE
static val mutable BUILD_INFO_RESOURCE: string
static val mutable BUILD_INFO_RESOURCE: string

Field Value

Type: Online String
See Also
BuildInformation Class
BuildInformation Members
NFX.Environment Namespace


BuildInformation.FRAMEWORK_BUILD_INFO_PATH Field

BuildInformation FRAMEWORK_BUILD_INFO_PATH Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FRAMEWORK_BUILD_INFO_PATH
public const string FRAMEWORK_BUILD_INFO_PATH
Public Const FRAMEWORK_BUILD_INFO_PATH As String
Public Const FRAMEWORK_BUILD_INFO_PATH As String
public:
literal String^ FRAMEWORK_BUILD_INFO_PATH
public:
literal String^ FRAMEWORK_BUILD_INFO_PATH
static val mutable FRAMEWORK_BUILD_INFO_PATH: string
static val mutable FRAMEWORK_BUILD_INFO_PATH: string

Field Value

Type: Online String
See Also
BuildInformation Class
BuildInformation Members
NFX.Environment Namespace


BuildInformation Methods

BuildInformation Methods NFX Class Library

The BuildInformation type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BuildInformation Class
NFX.Environment Namespace


BuildInformation.ToString Method

BuildInformation ToString Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
BuildInformation Class
BuildInformation Members
NFX.Environment Namespace


BuildInformation Properties

BuildInformation Properties NFX Class Library

The BuildInformation type exposes the following members.
Properties
 | Name | Description
Public property | AssemblyName | Rertuns assembly name that this information was obtained from
Public property | BuildSeed | Returns random number assigned to a build. It is NOT guaranteed to be unique
Public property | Computer | A name of the computer that performed build
Public property | DateStampUTC | Date and time stamp when build was performed
 | ForFramework | Return framework build information
Public property | OS | OS name
Public property | OSVer | OS version name
Public property | User | a name of user that build session was logged under
Back to Top
See Also
BuildInformation Class
NFX.Environment Namespace


BuildInformation.AssemblyName Property

BuildInformation AssemblyName Property NFX Class Library

Rertuns assembly name that this information was obtained from

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AssemblyName { get; }
public string AssemblyName { get; }
Public ReadOnly Property AssemblyName As String
    Get
Public ReadOnly Property AssemblyName As String
    Get
public:
property String^ AssemblyName {
    String^ get ();
}
public:
property String^ AssemblyName {
    String^ get ();
}
member AssemblyName : string with get
member AssemblyName : string with get

Property Value

Type: Online String
See Also
BuildInformation Class
BuildInformation Members
NFX.Environment Namespace


BuildInformation.BuildSeed Property

BuildInformation BuildSeed Property NFX Class Library

Returns random number assigned to a build. It is NOT guaranteed to be unique

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int BuildSeed { get; }
public int BuildSeed { get; }
Public ReadOnly Property BuildSeed As Integer
    Get
Public ReadOnly Property BuildSeed As Integer
    Get
public:
property int BuildSeed {
    int get ();
}
public:
property int BuildSeed {
    int get ();
}
member BuildSeed : int with get
member BuildSeed : int with get

Property Value

Type: Online Int32
See Also
BuildInformation Class
BuildInformation Members
NFX.Environment Namespace


BuildInformation.Computer Property

BuildInformation Computer Property NFX Class Library

A name of the computer that performed build

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Computer { get; }
public string Computer { get; }
Public ReadOnly Property Computer As String
    Get
Public ReadOnly Property Computer As String
    Get
public:
property String^ Computer {
    String^ get ();
}
public:
property String^ Computer {
    String^ get ();
}
member Computer : string with get
member Computer : string with get

Property Value

Type: Online String
See Also
BuildInformation Class
BuildInformation Members
NFX.Environment Namespace


BuildInformation.DateStampUTC Property

BuildInformation DateStampUTC Property NFX Class Library

Date and time stamp when build was performed

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime DateStampUTC { get; }
public DateTime DateStampUTC { get; }
Public ReadOnly Property DateStampUTC As DateTime
    Get
Public ReadOnly Property DateStampUTC As DateTime
    Get
public:
property DateTime DateStampUTC {
    DateTime get ();
}
public:
property DateTime DateStampUTC {
    DateTime get ();
}
member DateStampUTC : DateTime with get
member DateStampUTC : DateTime with get

Property Value

Type: Online DateTime
See Also
BuildInformation Class
BuildInformation Members
NFX.Environment Namespace


BuildInformation.ForFramework Property

BuildInformation ForFramework Property NFX Class Library

Return framework build information

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static BuildInformation ForFramework { get; }
public static BuildInformation ForFramework { get; }
Public Shared ReadOnly Property ForFramework As BuildInformation
    Get
Public Shared ReadOnly Property ForFramework As BuildInformation
    Get
public:
static property BuildInformation^ ForFramework {
    BuildInformation^ get ();
}
public:
static property BuildInformation^ ForFramework {
    BuildInformation^ get ();
}
static member ForFramework : BuildInformation with get
static member ForFramework : BuildInformation with get

Property Value

Type: BuildInformation
See Also
BuildInformation Class
BuildInformation Members
NFX.Environment Namespace


BuildInformation.OS Property

BuildInformation OS Property NFX Class Library

OS name

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string OS { get; }
public string OS { get; }
Public ReadOnly Property OS As String
    Get
Public ReadOnly Property OS As String
    Get
public:
property String^ OS {
    String^ get ();
}
public:
property String^ OS {
    String^ get ();
}
member OS : string with get
member OS : string with get

Property Value

Type: Online String
See Also
BuildInformation Class
BuildInformation Members
NFX.Environment Namespace


BuildInformation.OSVer Property

BuildInformation OSVer Property NFX Class Library

OS version name

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string OSVer { get; }
public string OSVer { get; }
Public ReadOnly Property OSVer As String
    Get
Public ReadOnly Property OSVer As String
    Get
public:
property String^ OSVer {
    String^ get ();
}
public:
property String^ OSVer {
    String^ get ();
}
member OSVer : string with get
member OSVer : string with get

Property Value

Type: Online String
See Also
BuildInformation Class
BuildInformation Members
NFX.Environment Namespace


BuildInformation.User Property

BuildInformation User Property NFX Class Library

a name of user that build session was logged under

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string User { get; }
public string User { get; }
Public ReadOnly Property User As String
    Get
Public ReadOnly Property User As String
    Get
public:
property String^ User {
    String^ get ();
}
public:
property String^ User {
    String^ get ();
}
member User : string with get
member User : string with get

Property Value

Type: Online String
See Also
BuildInformation Class
BuildInformation Members
NFX.Environment Namespace


CommandArgsConfiguration Class

CommandArgsConfiguration Class NFX Class Library

Provides implementation of configuration based on arguments supplied from command line which is "string[]". Arguments start with either "/" or "-" prefix. If any argument is not prefixed then it is written as an auto-named attribute node of the root with its value set, otherwise a section (under root) with argument's name is created. Any argument may have options. Any option may either consist of name or name value pair delimited by "=". Argument options are written as attribute nodes of their corresponding sections. If option value specified without name (without "=") then option is auto-named
Inheritance Hierarchy
Online System Object
NFX.Environment Configuration
NFX.Environment CommandArgsConfiguration

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CommandArgsConfiguration : Configuration
[SerializableAttribute]
public class CommandArgsConfiguration : Configuration
<SerializableAttribute>
Public Class CommandArgsConfiguration
    Inherits Configuration
<SerializableAttribute>
Public Class CommandArgsConfiguration
    Inherits Configuration
[SerializableAttribute]
public ref class CommandArgsConfiguration : public Configuration
[SerializableAttribute]
public ref class CommandArgsConfiguration : public Configuration
[<SerializableAttribute>]
type CommandArgsConfiguration =
    class
        inherit Configuration
    end
[<SerializableAttribute>]
type CommandArgsConfiguration =
    class
        inherit Configuration
    end
Examples
Given command line:
View Colorized Copy to Clipboard Print
c:\>dosomething.exe "c:\input.file" "d:\output.file" -compress level=100 method=zip -shadow fast -large
c:\>dosomething.exe "c:\input.file" "d:\output.file" -compress level=100 method=zip -shadow fast -large
View Colorized Copy to Clipboard Print
[args ?1="c:\input.file" ?2="c:\output.file"]
  [compress level="100" method="zip"]
  [shadow ?1="fast"]
  [large]
[args ?1="c:\input.file" ?2="c:\output.file"]
  [compress level="100" method="zip"]
  [shadow ?1="fast"]
  [large]
View Colorized Copy to Clipboard Print
var conf = new CmdArgsConfiguration(args);
var inFile = conf.Root.AttrByIndex(0).ValueAsString(DEFAULT_INPUT_FILE);
var outFile = conf.Root.AttrByIndex(1).ValueAsString(DEFAULT_OUTPUT_FILE);
.....
 if (conf.Root["large"].Exists) .......
.....
var level = conf.Root["compress"].AttrByName("level").ValueAsInt(DEFAULT_COMPRESSION_LEVEL);
.....
var conf = new CmdArgsConfiguration(args);
var inFile = conf.Root.AttrByIndex(0).ValueAsString(DEFAULT_INPUT_FILE);
var outFile = conf.Root.AttrByIndex(1).ValueAsString(DEFAULT_OUTPUT_FILE);
.....
 if (conf.Root["large"].Exists) .......
.....
var level = conf.Root["compress"].AttrByName("level").ValueAsInt(DEFAULT_COMPRESSION_LEVEL);
.....
The following configuration object will be created from the supplied args: Use args:
See Also
CommandArgsConfiguration Members
NFX.Environment Namespace


CommandArgsConfiguration Members

CommandArgsConfiguration Members NFX Class Library

The CommandArgsConfiguration type exposes the following members.
Constructors
 | Name | Description
Public method | CommandArgsConfiguration( String ) | Creates an instance of the new configuration parsed from command line arguments
Public method | CommandArgsConfiguration( String , Boolean) | Creates an instance of the new configuration parsed from command line arguments
Back to Top
Methods
 | Name | Description
Protected method | AdjustNodeName | Override to perform transforms on node names so they become suitable for particular configuration type (Inherited from Configuration.)
Public method | CheckAndAdjustNodeName | Checks node name for aptitude for particular configuration type. For example, XML configuration does not allow nodes with spaces or separator chars. When StrictNames is set to true and value is not appropriate then exception is thrown (Inherited from Configuration.)
Public method | Clone(Configuration) | Creates a deep copy of this configuration into newInstance which was allocated externally (Inherited from Configuration.)
Public method | Clone T | Creates a deep copy of this configuration into new instance of T (Inherited from Configuration.)
Public method | Create | Creates new configuration - creates new configuration root with optional name parameter (Inherited from Configuration.)
Public method | CreateFromMerge | Creates new configuration from ordered merge result of two other nodes - base and override which can be from different configurations (Inherited from Configuration.)
Public method | CreateFromNode | Creates new configuration from other node, which may belong to a different configuration instance (Inherited from Configuration.)
Public method | Destroy | Erases all config data (Inherited from Configuration.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Include | Completely replaces this node with another node tree, positioning the new tree in the place of local node. Existing node is deleted after this operation completes, in its place child nodes from other node are inserted preserving their existing order. Attributes of other node get merged into parent of existing node (Inherited from Configuration.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Refresh | Re-reads configuration from source (Inherited from Configuration.)
Public method | ResolveEnvironmentVar | Resolves variable name into its value (Inherited from Configuration.)
Public method | RunMacro | Runs macro and returns its value (Inherited from Configuration.)
Public method | Save | Saves configuration to source (Inherited from Configuration.)
Public method | ToConfigurationJSONDataMap | Returns this config as JSON data map suitable for making JSONConfiguration (Inherited from Configuration.)
Public method | ToLaconicFile | Serializes configuration tree into Laconic format and writes it into a file (Inherited from Configuration.)
Public method | ToLaconicStream | Serializes configuration tree into Laconic format and writes it into stream (Inherited from Configuration.)
Public method | ToLaconicString | Serializes configuration tree into Laconic format and returns it as a string (Inherited from Configuration.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | ARG_PREFIX_DASH |
 | ARG_PREFIX_SLASH |
Protected field | m_EmptyAttrNode | (Inherited from Configuration.)
Protected field | m_EmptySectionNode | (Inherited from Configuration.)
Protected field | m_Root | (Inherited from Configuration.)
 | OPTION_EQ |
 | ROOT_NODE_NAME |
Back to Top
Properties
 | Name | Description
Public property | Arguments | Returns arguments array that this configuration was parsed from
Public property | ContentView | Primarily used for debugging - returns the content of the configuration as text in the pretty-printed Laconic format (Inherited from Configuration.)
Public property | EmptyAttr | References a special instance of an empty attribute node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist (Inherited from Configuration.)
Public property | EmptySection | References a special instance of an empty section node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist (Inherited from Configuration.)
Public property | EnvironmentVarResolver | References variable resolver. If this property is not set then default Windows environment var resolver is used (Inherited from Configuration.)
Public property | InhibitSlashArg | When true, disregards '/' as an argument delimiter
Public property | IsReadOnly | Indicates whether configuration is readonly or may be modified and saved (Overrides Configuration IsReadOnly.)
Public property | MacroRunner | References macro runner. If this property is not set then default macro runner is used (Inherited from Configuration.)
Public property | MacroRunnerContext | Gets/sets an object passed by the framework into MacroRunner.Run() method. This property is auto-set for classes decorated with [ConfigMacroContext] attribute (Inherited from Configuration.)
Public property | Root | Accesses root section configuration node (Inherited from Configuration.)
Public property | StrictNames | Determines whether exception is thrown when configuration node name contains inappropriate chars for particular configuration type. For example, for XMLConfiguration node names may not have spaces and other separator chars. When StrictNames is false then particular configurations may replace incompatible chars in node names with neutral ones (i.e. "my value"->"my-value" in case of XMLConfiguration). (Inherited from Configuration.)
Public property | Variable_END | Variable end tag (Inherited from Configuration.)
Public property | Variable_ENV_MOD | Variable environment modifier (Inherited from Configuration.)
Public property | Variable_ESCAPE | Variable escape tag (Inherited from Configuration.)
Public property | Variable_MACRO_START | Variable get clause modifier (Inherited from Configuration.)
Public property | Variable_PATH_MOD | Variable path modifier (Inherited from Configuration.)
Public property | Variable_START | Variable start tag (Inherited from Configuration.)
Back to Top
See Also
CommandArgsConfiguration Class
NFX.Environment Namespace


CommandArgsConfiguration Constructor

CommandArgsConfiguration Constructor NFX Class Library

Overload List
 | Name | Description
Public method | CommandArgsConfiguration( String ) | Creates an instance of the new configuration parsed from command line arguments
Public method | CommandArgsConfiguration( String , Boolean) | Creates an instance of the new configuration parsed from command line arguments
Back to Top
See Also
CommandArgsConfiguration Class
CommandArgsConfiguration Members
NFX.Environment Namespace


CommandArgsConfiguration Constructor (String[])

CommandArgsConfiguration Constructor ( String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates an instance of the new configuration parsed from command line arguments

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CommandArgsConfiguration(
    string[] args
)
public CommandArgsConfiguration(
    string[] args
)
Public Sub New (
    args As String()
)
Public Sub New (
    args As String()
)
public:
CommandArgsConfiguration(
    array<String^>^ args
)
public:
CommandArgsConfiguration(
    array<String^>^ args
)
new :
        args : string[] -> CommandArgsConfiguration
new :
        args : string[] -> CommandArgsConfiguration

Parameters

args
Type: Online System String
See Also
CommandArgsConfiguration Class
CommandArgsConfiguration Members
CommandArgsConfiguration Overload
NFX.Environment Namespace


CommandArgsConfiguration Constructor (String[], Boolean)

CommandArgsConfiguration Constructor ( String , Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates an instance of the new configuration parsed from command line arguments

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CommandArgsConfiguration(
    string[] args,
    bool inhibitSlashArg
)
public CommandArgsConfiguration(
    string[] args,
    bool inhibitSlashArg
)
Public Sub New (
    args As String(),
    inhibitSlashArg As Boolean
)
Public Sub New (
    args As String(),
    inhibitSlashArg As Boolean
)
public:
CommandArgsConfiguration(
    array<String^>^ args,
    bool inhibitSlashArg
)
public:
CommandArgsConfiguration(
    array<String^>^ args,
    bool inhibitSlashArg
)
new :
        args : string[] *
        inhibitSlashArg : bool -> CommandArgsConfiguration
new :
        args : string[] *
        inhibitSlashArg : bool -> CommandArgsConfiguration

Parameters

args
Type: Online System String
inhibitSlashArg
Type: Online System Boolean
See Also
CommandArgsConfiguration Class
CommandArgsConfiguration Members
CommandArgsConfiguration Overload
NFX.Environment Namespace


CommandArgsConfiguration Fields

CommandArgsConfiguration Fields NFX Class Library

The CommandArgsConfiguration type exposes the following members.
Fields
 | Name | Description
 | ARG_PREFIX_DASH |
 | ARG_PREFIX_SLASH |
Protected field | m_EmptyAttrNode | (Inherited from Configuration.)
Protected field | m_EmptySectionNode | (Inherited from Configuration.)
Protected field | m_Root | (Inherited from Configuration.)
 | OPTION_EQ |
 | ROOT_NODE_NAME |
Back to Top
See Also
CommandArgsConfiguration Class
NFX.Environment Namespace


CommandArgsConfiguration.ARG_PREFIX_DASH Field

CommandArgsConfiguration ARG_PREFIX_DASH Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ARG_PREFIX_DASH
public const string ARG_PREFIX_DASH
Public Const ARG_PREFIX_DASH As String
Public Const ARG_PREFIX_DASH As String
public:
literal String^ ARG_PREFIX_DASH
public:
literal String^ ARG_PREFIX_DASH
static val mutable ARG_PREFIX_DASH: string
static val mutable ARG_PREFIX_DASH: string

Field Value

Type: Online String
See Also
CommandArgsConfiguration Class
CommandArgsConfiguration Members
NFX.Environment Namespace


CommandArgsConfiguration.ARG_PREFIX_SLASH Field

CommandArgsConfiguration ARG_PREFIX_SLASH Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ARG_PREFIX_SLASH
public const string ARG_PREFIX_SLASH
Public Const ARG_PREFIX_SLASH As String
Public Const ARG_PREFIX_SLASH As String
public:
literal String^ ARG_PREFIX_SLASH
public:
literal String^ ARG_PREFIX_SLASH
static val mutable ARG_PREFIX_SLASH: string
static val mutable ARG_PREFIX_SLASH: string

Field Value

Type: Online String
See Also
CommandArgsConfiguration Class
CommandArgsConfiguration Members
NFX.Environment Namespace


CommandArgsConfiguration.OPTION_EQ Field

CommandArgsConfiguration OPTION_EQ Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const char OPTION_EQ
public const char OPTION_EQ
Public Const OPTION_EQ As Char
Public Const OPTION_EQ As Char
public:
literal wchar_t OPTION_EQ
public:
literal wchar_t OPTION_EQ
static val mutable OPTION_EQ: char
static val mutable OPTION_EQ: char

Field Value

Type: Online Char
See Also
CommandArgsConfiguration Class
CommandArgsConfiguration Members
NFX.Environment Namespace


CommandArgsConfiguration.ROOT_NODE_NAME Field

CommandArgsConfiguration ROOT_NODE_NAME Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ROOT_NODE_NAME
public const string ROOT_NODE_NAME
Public Const ROOT_NODE_NAME As String
Public Const ROOT_NODE_NAME As String
public:
literal String^ ROOT_NODE_NAME
public:
literal String^ ROOT_NODE_NAME
static val mutable ROOT_NODE_NAME: string
static val mutable ROOT_NODE_NAME: string

Field Value

Type: Online String
See Also
CommandArgsConfiguration Class
CommandArgsConfiguration Members
NFX.Environment Namespace


CommandArgsConfiguration Methods

CommandArgsConfiguration Methods NFX Class Library

The CommandArgsConfiguration type exposes the following members.
Methods
 | Name | Description
Protected method | AdjustNodeName | Override to perform transforms on node names so they become suitable for particular configuration type (Inherited from Configuration.)
Public method | CheckAndAdjustNodeName | Checks node name for aptitude for particular configuration type. For example, XML configuration does not allow nodes with spaces or separator chars. When StrictNames is set to true and value is not appropriate then exception is thrown (Inherited from Configuration.)
Public method | Clone(Configuration) | Creates a deep copy of this configuration into newInstance which was allocated externally (Inherited from Configuration.)
Public method | Clone T | Creates a deep copy of this configuration into new instance of T (Inherited from Configuration.)
Public method | Create | Creates new configuration - creates new configuration root with optional name parameter (Inherited from Configuration.)
Public method | CreateFromMerge | Creates new configuration from ordered merge result of two other nodes - base and override which can be from different configurations (Inherited from Configuration.)
Public method | CreateFromNode | Creates new configuration from other node, which may belong to a different configuration instance (Inherited from Configuration.)
Public method | Destroy | Erases all config data (Inherited from Configuration.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Include | Completely replaces this node with another node tree, positioning the new tree in the place of local node. Existing node is deleted after this operation completes, in its place child nodes from other node are inserted preserving their existing order. Attributes of other node get merged into parent of existing node (Inherited from Configuration.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Refresh | Re-reads configuration from source (Inherited from Configuration.)
Public method | ResolveEnvironmentVar | Resolves variable name into its value (Inherited from Configuration.)
Public method | RunMacro | Runs macro and returns its value (Inherited from Configuration.)
Public method | Save | Saves configuration to source (Inherited from Configuration.)
Public method | ToConfigurationJSONDataMap | Returns this config as JSON data map suitable for making JSONConfiguration (Inherited from Configuration.)
Public method | ToLaconicFile | Serializes configuration tree into Laconic format and writes it into a file (Inherited from Configuration.)
Public method | ToLaconicStream | Serializes configuration tree into Laconic format and writes it into stream (Inherited from Configuration.)
Public method | ToLaconicString | Serializes configuration tree into Laconic format and returns it as a string (Inherited from Configuration.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CommandArgsConfiguration Class
NFX.Environment Namespace


CommandArgsConfiguration Properties

CommandArgsConfiguration Properties NFX Class Library

The CommandArgsConfiguration type exposes the following members.
Properties
 | Name | Description
Public property | Arguments | Returns arguments array that this configuration was parsed from
Public property | ContentView | Primarily used for debugging - returns the content of the configuration as text in the pretty-printed Laconic format (Inherited from Configuration.)
Public property | EmptyAttr | References a special instance of an empty attribute node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist (Inherited from Configuration.)
Public property | EmptySection | References a special instance of an empty section node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist (Inherited from Configuration.)
Public property | EnvironmentVarResolver | References variable resolver. If this property is not set then default Windows environment var resolver is used (Inherited from Configuration.)
Public property | InhibitSlashArg | When true, disregards '/' as an argument delimiter
Public property | IsReadOnly | Indicates whether configuration is readonly or may be modified and saved (Overrides Configuration IsReadOnly.)
Public property | MacroRunner | References macro runner. If this property is not set then default macro runner is used (Inherited from Configuration.)
Public property | MacroRunnerContext | Gets/sets an object passed by the framework into MacroRunner.Run() method. This property is auto-set for classes decorated with [ConfigMacroContext] attribute (Inherited from Configuration.)
Public property | Root | Accesses root section configuration node (Inherited from Configuration.)
Public property | StrictNames | Determines whether exception is thrown when configuration node name contains inappropriate chars for particular configuration type. For example, for XMLConfiguration node names may not have spaces and other separator chars. When StrictNames is false then particular configurations may replace incompatible chars in node names with neutral ones (i.e. "my value"->"my-value" in case of XMLConfiguration). (Inherited from Configuration.)
Public property | Variable_END | Variable end tag (Inherited from Configuration.)
Public property | Variable_ENV_MOD | Variable environment modifier (Inherited from Configuration.)
Public property | Variable_ESCAPE | Variable escape tag (Inherited from Configuration.)
Public property | Variable_MACRO_START | Variable get clause modifier (Inherited from Configuration.)
Public property | Variable_PATH_MOD | Variable path modifier (Inherited from Configuration.)
Public property | Variable_START | Variable start tag (Inherited from Configuration.)
Back to Top
See Also
CommandArgsConfiguration Class
NFX.Environment Namespace


CommandArgsConfiguration.Arguments Property

CommandArgsConfiguration Arguments Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns arguments array that this configuration was parsed from

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string[] Arguments { get; }
public string[] Arguments { get; }
Public ReadOnly Property Arguments As String()
    Get
Public ReadOnly Property Arguments As String()
    Get
public:
property array<String^>^ Arguments {
    array<String^>^ get ();
}
public:
property array<String^>^ Arguments {
    array<String^>^ get ();
}
member Arguments : string[] with get
member Arguments : string[] with get

Property Value

Type: Online String
See Also
CommandArgsConfiguration Class
CommandArgsConfiguration Members
NFX.Environment Namespace


CommandArgsConfiguration.InhibitSlashArg Property

CommandArgsConfiguration InhibitSlashArg Property NFX Class Library

[This is preliminary documentation and is subject to change.]

When true, disregards '/' as an argument delimiter

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool InhibitSlashArg { get; }
public bool InhibitSlashArg { get; }
Public ReadOnly Property InhibitSlashArg As Boolean
    Get
Public ReadOnly Property InhibitSlashArg As Boolean
    Get
public:
property bool InhibitSlashArg {
    bool get ();
}
public:
property bool InhibitSlashArg {
    bool get ();
}
member InhibitSlashArg : bool with get
member InhibitSlashArg : bool with get

Property Value

Type: Online Boolean
See Also
CommandArgsConfiguration Class
CommandArgsConfiguration Members
NFX.Environment Namespace


CommandArgsConfiguration.IsReadOnly Property

CommandArgsConfiguration IsReadOnly Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Indicates whether configuration is readonly or may be modified and saved

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsReadOnly { get; }
public override bool IsReadOnly { get; }
Public Overrides ReadOnly Property IsReadOnly As Boolean
    Get
Public Overrides ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get () override;
}
public:
virtual property bool IsReadOnly {
    bool get () override;
}
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get

Property Value

Type: Online Boolean
See Also
CommandArgsConfiguration Class
CommandArgsConfiguration Members
NFX.Environment Namespace


ConfigAttribute Class

ConfigAttribute Class NFX Class Library

Specifies how to apply configuration values to classes/fields/props
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.Environment ConfigAttribute

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Struct|AttributeTargets.Property|AttributeTargets.Field, Inherited = true,
    AllowMultiple = false)]
public class ConfigAttribute : Attribute
[AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Struct|AttributeTargets.Property|AttributeTargets.Field, Inherited = true,
    AllowMultiple = false)]
public class ConfigAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Class Or AttributeTargets.Struct Or AttributeTargets.Property Or AttributeTargets.Field, Inherited := true,
    AllowMultiple := false)>
Public Class ConfigAttribute
    Inherits Attribute
<AttributeUsageAttribute(AttributeTargets.Class Or AttributeTargets.Struct Or AttributeTargets.Property Or AttributeTargets.Field, Inherited := true,
    AllowMultiple := false)>
Public Class ConfigAttribute
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Class|AttributeTargets::Struct|AttributeTargets::Property|AttributeTargets::Field, Inherited = true,
    AllowMultiple = false)]
public ref class ConfigAttribute : public Attribute
[AttributeUsageAttribute(AttributeTargets::Class|AttributeTargets::Struct|AttributeTargets::Property|AttributeTargets::Field, Inherited = true,
    AllowMultiple = false)]
public ref class ConfigAttribute : public Attribute
[<AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Struct|AttributeTargets.Property|AttributeTargets.Field, Inherited = true,
    AllowMultiple = false)>]
type ConfigAttribute =
    class
        inherit Attribute
    end
[<AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Struct|AttributeTargets.Property|AttributeTargets.Field, Inherited = true,
    AllowMultiple = false)>]
type ConfigAttribute =
    class
        inherit Attribute
    end
See Also
ConfigAttribute Members
NFX.Environment Namespace


ConfigAttribute Members

ConfigAttribute Members NFX Class Library

The ConfigAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | ConfigAttribute | Decorates members so that path is defaulted from member's name with prepended '$' attribute symbol
Public method | ConfigAttribute(String) | Decorates members that will be configured from supplied path
Public method | ConfigAttribute(String, Object) | Decorates members that will be configured from supplied path and defaulted in case the supplied path does not resolve to existing node
Back to Top
Methods
 | Name | Description
 | Apply(Object, IConfigSectionNode) | Applies config values to fields/properties as specified by config attributes
 | Apply T (T, IConfigSectionNode) | Applies config values to fields/properties as specified by config attributes
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | GetConfigPathsForMember | Generates 2 attribute paths for named member. This first path is just the member name converted to lower case. The seconfd path is "OR"ed with the first one and is taken from member name where all case transitions are prefixed with "-". For private fields 'm_' and 's_' prefixes are removed
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Default | Default value used when configuration does not specify any other value
Public property | Path | String path of configuration source i.e. 'log/machine-name'. Path is relative to item root
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Public property | Verbatim | Takes verbatim value if true
Back to Top
See Also
ConfigAttribute Class
NFX.Environment Namespace


ConfigAttribute Constructor

ConfigAttribute Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ConfigAttribute | Decorates members so that path is defaulted from member's name with prepended '$' attribute symbol
Public method | ConfigAttribute(String) | Decorates members that will be configured from supplied path
Public method | ConfigAttribute(String, Object) | Decorates members that will be configured from supplied path and defaulted in case the supplied path does not resolve to existing node
Back to Top
See Also
ConfigAttribute Class
ConfigAttribute Members
NFX.Environment Namespace


ConfigAttribute Constructor

ConfigAttribute Constructor NFX Class Library

Decorates members so that path is defaulted from member's name with prepended '$' attribute symbol

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigAttribute()
public ConfigAttribute()
Public Sub New
Public Sub New
public:
ConfigAttribute()
public:
ConfigAttribute()
new : unit -> ConfigAttribute
new : unit -> ConfigAttribute
See Also
ConfigAttribute Class
ConfigAttribute Members
ConfigAttribute Overload
NFX.Environment Namespace


ConfigAttribute Constructor (String)

ConfigAttribute Constructor (String) NFX Class Library

Decorates members that will be configured from supplied path

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigAttribute(
    string path
)
public ConfigAttribute(
    string path
)
Public Sub New (
    path As String
)
Public Sub New (
    path As String
)
public:
ConfigAttribute(
    String^ path
)
public:
ConfigAttribute(
    String^ path
)
new :
        path : string -> ConfigAttribute
new :
        path : string -> ConfigAttribute

Parameters

path
Type: Online System String
See Also
ConfigAttribute Class
ConfigAttribute Members
ConfigAttribute Overload
NFX.Environment Namespace


ConfigAttribute Constructor (String, Object)

ConfigAttribute Constructor (String, Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Decorates members that will be configured from supplied path and defaulted in case the supplied path does not resolve to existing node

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigAttribute(
    string path,
    Object defaultValue
)
public ConfigAttribute(
    string path,
    Object defaultValue
)
Public Sub New (
    path As String,
    defaultValue As Object
)
Public Sub New (
    path As String,
    defaultValue As Object
)
public:
ConfigAttribute(
    String^ path,
    Object^ defaultValue
)
public:
ConfigAttribute(
    String^ path,
    Object^ defaultValue
)
new :
        path : string *
        defaultValue : Object -> ConfigAttribute
new :
        path : string *
        defaultValue : Object -> ConfigAttribute

Parameters

path
Type: Online System String
defaultValue
Type: Online System Object
See Also
ConfigAttribute Class
ConfigAttribute Members
ConfigAttribute Overload
NFX.Environment Namespace


ConfigAttribute Methods

ConfigAttribute Methods NFX Class Library

The ConfigAttribute type exposes the following members.
Methods
 | Name | Description
 | Apply(Object, IConfigSectionNode) | Applies config values to fields/properties as specified by config attributes
 | Apply T (T, IConfigSectionNode) | Applies config values to fields/properties as specified by config attributes
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | GetConfigPathsForMember | Generates 2 attribute paths for named member. This first path is just the member name converted to lower case. The seconfd path is "OR"ed with the first one and is taken from member name where all case transitions are prefixed with "-". For private fields 'm_' and 's_' prefixes are removed
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ConfigAttribute Class
NFX.Environment Namespace


ConfigAttribute.Apply Method

ConfigAttribute Apply Method NFX Class Library

Overload List
Name | Description
Apply(Object, IConfigSectionNode) | Applies config values to fields/properties as specified by config attributes
Apply T (T, IConfigSectionNode) | Applies config values to fields/properties as specified by config attributes
Back to Top
See Also
ConfigAttribute Class
ConfigAttribute Members
NFX.Environment Namespace


ConfigAttribute.Apply Method (Object, IConfigSectionNode)

ConfigAttribute Apply Method (Object, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Applies config values to fields/properties as specified by config attributes

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Object Apply(
    Object entity,
    IConfigSectionNode node
)
public static Object Apply(
    Object entity,
    IConfigSectionNode node
)
Public Shared Function Apply (
    entity As Object,
    node As IConfigSectionNode
) As Object
Public Shared Function Apply (
    entity As Object,
    node As IConfigSectionNode
) As Object
public:
static Object^ Apply(
    Object^ entity,
    IConfigSectionNode^ node
)
public:
static Object^ Apply(
    Object^ entity,
    IConfigSectionNode^ node
)
static member Apply :
        entity : Object *
        node : IConfigSectionNode -> Object
static member Apply :
        entity : Object *
        node : IConfigSectionNode -> Object

Parameters

entity
Type: Online System Object
node
Type: NFX.Environment IConfigSectionNode

Return Value

Type: Online Object
See Also
ConfigAttribute Class
ConfigAttribute Members
Apply Overload
NFX.Environment Namespace


ConfigAttribute.Apply(T) Method (T, IConfigSectionNode)

ConfigAttribute Apply T Method (T, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Applies config values to fields/properties as specified by config attributes

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static T Apply<T>(
    T entity,
    IConfigSectionNode node
)
public static T Apply<T>(
    T entity,
    IConfigSectionNode node
)
Public Shared Function Apply(Of T) (
    entity As T,
    node As IConfigSectionNode
) As T
Public Shared Function Apply(Of T) (
    entity As T,
    node As IConfigSectionNode
) As T
public:
generic<typename T>
static T Apply(
    T entity,
    IConfigSectionNode^ node
)
public:
generic<typename T>
static T Apply(
    T entity,
    IConfigSectionNode^ node
)
static member Apply :
        entity : 'T *
        node : IConfigSectionNode -> 'T
static member Apply :
        entity : 'T *
        node : IConfigSectionNode -> 'T

Parameters

entity
Type: T
node
Type: NFX.Environment IConfigSectionNode
Type Parameters
T

Return Value

Type: T
See Also
ConfigAttribute Class
ConfigAttribute Members
Apply Overload
NFX.Environment Namespace


ConfigAttribute.GetConfigPathsForMember Method

ConfigAttribute GetConfigPathsForMember Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Generates 2 attribute paths for named member. This first path is just the member name converted to lower case. The seconfd path is "OR"ed with the first one and is taken from member name where all case transitions are prefixed with "-". For private fields 'm_' and 's_' prefixes are removed

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetConfigPathsForMember(
    MemberInfo member
)
public static string GetConfigPathsForMember(
    MemberInfo member
)
Public Shared Function GetConfigPathsForMember (
    member As MemberInfo
) As String
Public Shared Function GetConfigPathsForMember (
    member As MemberInfo
) As String
public:
static String^ GetConfigPathsForMember(
    MemberInfo^ member
)
public:
static String^ GetConfigPathsForMember(
    MemberInfo^ member
)
static member GetConfigPathsForMember :
        member : MemberInfo -> string
static member GetConfigPathsForMember :
        member : MemberInfo -> string

Parameters

member
Type: Online System.Reflection MemberInfo

Return Value

Type: Online String
See Also
ConfigAttribute Class
ConfigAttribute Members
NFX.Environment Namespace


ConfigAttribute Properties

ConfigAttribute Properties NFX Class Library

The ConfigAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Default | Default value used when configuration does not specify any other value
Public property | Path | String path of configuration source i.e. 'log/machine-name'. Path is relative to item root
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Public property | Verbatim | Takes verbatim value if true
Back to Top
See Also
ConfigAttribute Class
NFX.Environment Namespace


ConfigAttribute.Default Property

ConfigAttribute Default Property NFX Class Library

Default value used when configuration does not specify any other value

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Default { get; set; }
public Object Default { get; set; }
Public Property Default As Object
    Get
    Set
Public Property Default As Object
    Get
    Set
public:
property Object^ Default {
    Object^ get ();
    void set (Object^ value);
}
public:
property Object^ Default {
    Object^ get ();
    void set (Object^ value);
}
member Default : Object with get, set
member Default : Object with get, set

Property Value

Type: Online Object
See Also
ConfigAttribute Class
ConfigAttribute Members
NFX.Environment Namespace


ConfigAttribute.Path Property

ConfigAttribute Path Property NFX Class Library

String path of configuration source i.e. 'log/machine-name'. Path is relative to item root

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Path { get; set; }
public string Path { get; set; }
Public Property Path As String
    Get
    Set
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
member Path : string with get, set
member Path : string with get, set

Property Value

Type: Online String
See Also
ConfigAttribute Class
ConfigAttribute Members
NFX.Environment Namespace


ConfigAttribute.Verbatim Property

ConfigAttribute Verbatim Property NFX Class Library

Takes verbatim value if true

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Verbatim { get; set; }
public bool Verbatim { get; set; }
Public Property Verbatim As Boolean
    Get
    Set
Public Property Verbatim As Boolean
    Get
    Set
public:
property bool Verbatim {
    bool get ();
    void set (bool value);
}
public:
property bool Verbatim {
    bool get ();
    void set (bool value);
}
member Verbatim : bool with get, set
member Verbatim : bool with get, set

Property Value

Type: Online Boolean
See Also
ConfigAttribute Class
ConfigAttribute Members
NFX.Environment Namespace


ConfigAttrNode Class

ConfigAttrNode Class NFX Class Library

Represents an attribute of a attribute node
Inheritance Hierarchy
Online System Object
NFX.Environment ConfigNode
NFX.Environment ConfigAttrNode

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class ConfigAttrNode : ConfigNode,
    IConfigAttrNode, IConfigNode, INamed
[SerializableAttribute]
public sealed class ConfigAttrNode : ConfigNode,
    IConfigAttrNode, IConfigNode, INamed
<SerializableAttribute>
Public NotInheritable Class ConfigAttrNode
    Inherits ConfigNode
    Implements IConfigAttrNode, IConfigNode, INamed
<SerializableAttribute>
Public NotInheritable Class ConfigAttrNode
    Inherits ConfigNode
    Implements IConfigAttrNode, IConfigNode, INamed
[SerializableAttribute]
public ref class ConfigAttrNode sealed : public ConfigNode,
    IConfigAttrNode, IConfigNode, INamed
[SerializableAttribute]
public ref class ConfigAttrNode sealed : public ConfigNode,
    IConfigAttrNode, IConfigNode, INamed
[<SealedAttribute>]
[<SerializableAttribute>]
type ConfigAttrNode =
    class
        inherit ConfigNode
        interface IConfigAttrNode
        interface IConfigNode
        interface INamed
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type ConfigAttrNode =
    class
        inherit ConfigNode
        interface IConfigAttrNode
        interface IConfigNode
        interface INamed
    end
See Also
ConfigAttrNode Members
NFX.Environment Namespace


ConfigAttrNode Members

ConfigAttrNode Members NFX Class Library

The ConfigAttrNode type exposes the following members.
Constructors
 | Name | Description
Protected method | ConfigAttrNode(Configuration, ConfigSectionNode) | Initializes a new instance of the ConfigAttrNode class
Protected method | ConfigAttrNode(Configuration, ConfigSectionNode, IConfigAttrNode) | Initializes a new instance of the ConfigAttrNode class
Protected method | ConfigAttrNode(Configuration, ConfigSectionNode, String, String) | Initializes a new instance of the ConfigAttrNode class
Back to Top
Methods
 | Name | Description
Protected method | checkCanModify | (Inherited from ConfigNode.)
Public method | Delete | Deletes this attribute from its parent (Overrides ConfigNode Delete .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsSameName(String) | Returns true when another name is the same as this node's name per case-insensitive culture-neutral comparison (Inherited from ConfigNode.)
Public method | IsSameName(IConfigNode) | Returns true when another node has the same name as this one per case-insensitive culture-neutral comparison (Inherited from ConfigNode.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ResetModified | Resets modification flag (Inherited from ConfigNode.)
Public method | ToString | (Inherited from ConfigNode.)
Public method | ValueAsBool | (Inherited from ConfigNode.)
Public method | ValueAsByte | (Inherited from ConfigNode.)
Public method | ValueAsByteArray | (Inherited from ConfigNode.)
Public method | ValueAsDateTime | (Inherited from ConfigNode.)
Public method | ValueAsDecimal | (Inherited from ConfigNode.)
Public method | ValueAsDouble | (Inherited from ConfigNode.)
Public method | ValueAsEnum TEnum | (Inherited from ConfigNode.)
Public method | ValueAsFloat | (Inherited from ConfigNode.)
Public method | ValueAsGDID | (Inherited from ConfigNode.)
Public method | ValueAsGUID | (Inherited from ConfigNode.)
Public method | ValueAsInt | (Inherited from ConfigNode.)
Public method | ValueAsLong | (Inherited from ConfigNode.)
Public method | ValueAsNullableBool | (Inherited from ConfigNode.)
Public method | ValueAsNullableByte | (Inherited from ConfigNode.)
Public method | ValueAsNullableDateTime | (Inherited from ConfigNode.)
Public method | ValueAsNullableDecimal | (Inherited from ConfigNode.)
Public method | ValueAsNullableDouble | (Inherited from ConfigNode.)
Public method | ValueAsNullableEnum TEnum | (Inherited from ConfigNode.)
Public method | ValueAsNullableFloat | (Inherited from ConfigNode.)
Public method | ValueAsNullableGDID | (Inherited from ConfigNode.)
Public method | ValueAsNullableGUID | (Inherited from ConfigNode.)
Public method | ValueAsNullableInt | (Inherited from ConfigNode.)
Public method | ValueAsNullableLong | (Inherited from ConfigNode.)
Public method | ValueAsNullableSByte | (Inherited from ConfigNode.)
Public method | ValueAsNullableShort | (Inherited from ConfigNode.)
Public method | ValueAsNullableTimeSpan | (Inherited from ConfigNode.)
Public method | ValueAsNullableUInt | (Inherited from ConfigNode.)
Public method | ValueAsNullableULong | (Inherited from ConfigNode.)
Public method | ValueAsNullableUShort | (Inherited from ConfigNode.)
Public method | ValueAsSByte | (Inherited from ConfigNode.)
Public method | ValueAsShort | (Inherited from ConfigNode.)
Public method | ValueAsString | (Inherited from ConfigNode.)
Public method | ValueAsTimeSpan | (Inherited from ConfigNode.)
Public method | ValueAsType | Tries to get value as specified type or throws if it can not be converted (Inherited from ConfigNode.)
Public method | ValueAsUInt | (Inherited from ConfigNode.)
Public method | ValueAsULong | (Inherited from ConfigNode.)
Public method | ValueAsUShort | (Inherited from ConfigNode.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | __Empty | (Inherited from ConfigNode.)
Protected field | m_Configuration | (Inherited from ConfigNode.)
Protected field | m_Modified | (Inherited from ConfigNode.)
Back to Top
Properties
 | Name | Description
Public property | Configuration | References configuration this node is under (Inherited from ConfigNode.)
Public property | EvaluatedValue | Returns null or value of this node with all variables evaluated (Inherited from ConfigNode.)
Public property | Exists | Determines whether this node really exists in configuration or is just a sentinel empty node (Inherited from ConfigNode.)
Public property | Modified | Indicates whether a node was modified (Inherited from ConfigNode.)
Public property | Name | Retrieves node name (Inherited from ConfigNode.)
Public property | Parent | References parent node or Empty if this node has no parent (Inherited from ConfigNode.)
Public property | RootPath | Returns path from root to this node (Inherited from ConfigNode.)
Public property | Value | Retrieves node value or null. The value getter performs evaluation of variables, while setter sets the value verbatim (Inherited from ConfigNode.)
Public property | VerbatimValue | Returns verbatim (without variable evaluation) node value or null (Inherited from ConfigNode.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IConfigNode Parent | References parent node (Inherited from ConfigNode.)
Explicit interface implemetation | IConfigNode RootPath | (Inherited from ConfigNode.)
Back to Top
See Also
ConfigAttrNode Class
NFX.Environment Namespace


ConfigAttrNode Constructor

ConfigAttrNode Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | ConfigAttrNode(Configuration, ConfigSectionNode) | Initializes a new instance of the ConfigAttrNode class
Protected method | ConfigAttrNode(Configuration, ConfigSectionNode, IConfigAttrNode) | Initializes a new instance of the ConfigAttrNode class
Protected method | ConfigAttrNode(Configuration, ConfigSectionNode, String, String) | Initializes a new instance of the ConfigAttrNode class
Back to Top
See Also
ConfigAttrNode Class
ConfigAttrNode Members
NFX.Environment Namespace


ConfigAttrNode Constructor (Configuration, ConfigSectionNode)

ConfigAttrNode Constructor (Configuration, ConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConfigAttrNode class

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ConfigAttrNode(
    Configuration conf,
    ConfigSectionNode parent
)
internal ConfigAttrNode(
    Configuration conf,
    ConfigSectionNode parent
)
Friend Sub New (
    conf As Configuration,
    parent As ConfigSectionNode
)
Friend Sub New (
    conf As Configuration,
    parent As ConfigSectionNode
)
internal:
ConfigAttrNode(
    Configuration^ conf,
    ConfigSectionNode^ parent
)
internal:
ConfigAttrNode(
    Configuration^ conf,
    ConfigSectionNode^ parent
)
new :
        conf : Configuration *
        parent : ConfigSectionNode -> ConfigAttrNode
new :
        conf : Configuration *
        parent : ConfigSectionNode -> ConfigAttrNode

Parameters

conf
Type: NFX.Environment Configuration
parent
Type: NFX.Environment ConfigSectionNode
See Also
ConfigAttrNode Class
ConfigAttrNode Members
ConfigAttrNode Overload
NFX.Environment Namespace


ConfigAttrNode Constructor (Configuration, ConfigSectionNode, IConfigAttrNode)

ConfigAttrNode Constructor (Configuration, ConfigSectionNode, IConfigAttrNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConfigAttrNode class

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ConfigAttrNode(
    Configuration conf,
    ConfigSectionNode parent,
    IConfigAttrNode clone
)
internal ConfigAttrNode(
    Configuration conf,
    ConfigSectionNode parent,
    IConfigAttrNode clone
)
Friend Sub New (
    conf As Configuration,
    parent As ConfigSectionNode,
    clone As IConfigAttrNode
)
Friend Sub New (
    conf As Configuration,
    parent As ConfigSectionNode,
    clone As IConfigAttrNode
)
internal:
ConfigAttrNode(
    Configuration^ conf,
    ConfigSectionNode^ parent,
    IConfigAttrNode^ clone
)
internal:
ConfigAttrNode(
    Configuration^ conf,
    ConfigSectionNode^ parent,
    IConfigAttrNode^ clone
)
new :
        conf : Configuration *
        parent : ConfigSectionNode *
        clone : IConfigAttrNode -> ConfigAttrNode
new :
        conf : Configuration *
        parent : ConfigSectionNode *
        clone : IConfigAttrNode -> ConfigAttrNode

Parameters

conf
Type: NFX.Environment Configuration
parent
Type: NFX.Environment ConfigSectionNode
clone
Type: NFX.Environment IConfigAttrNode
See Also
ConfigAttrNode Class
ConfigAttrNode Members
ConfigAttrNode Overload
NFX.Environment Namespace


ConfigAttrNode Constructor (Configuration, ConfigSectionNode, String, String)

ConfigAttrNode Constructor (Configuration, ConfigSectionNode, String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConfigAttrNode class

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ConfigAttrNode(
    Configuration conf,
    ConfigSectionNode parent,
    string name,
    string value
)
internal ConfigAttrNode(
    Configuration conf,
    ConfigSectionNode parent,
    string name,
    string value
)
Friend Sub New (
    conf As Configuration,
    parent As ConfigSectionNode,
    name As String,
    value As String
)
Friend Sub New (
    conf As Configuration,
    parent As ConfigSectionNode,
    name As String,
    value As String
)
internal:
ConfigAttrNode(
    Configuration^ conf,
    ConfigSectionNode^ parent,
    String^ name,
    String^ value
)
internal:
ConfigAttrNode(
    Configuration^ conf,
    ConfigSectionNode^ parent,
    String^ name,
    String^ value
)
new :
        conf : Configuration *
        parent : ConfigSectionNode *
        name : string *
        value : string -> ConfigAttrNode
new :
        conf : Configuration *
        parent : ConfigSectionNode *
        name : string *
        value : string -> ConfigAttrNode

Parameters

conf
Type: NFX.Environment Configuration
parent
Type: NFX.Environment ConfigSectionNode
name
Type: Online System String
value
Type: Online System String
See Also
ConfigAttrNode Class
ConfigAttrNode Members
ConfigAttrNode Overload
NFX.Environment Namespace


ConfigAttrNode Fields

ConfigAttrNode Fields NFX Class Library

The ConfigAttrNode type exposes the following members.
Fields
 | Name | Description
Protected field | __Empty | (Inherited from ConfigNode.)
Protected field | m_Configuration | (Inherited from ConfigNode.)
Protected field | m_Modified | (Inherited from ConfigNode.)
Back to Top
See Also
ConfigAttrNode Class
NFX.Environment Namespace


ConfigAttrNode Methods

ConfigAttrNode Methods NFX Class Library

The ConfigAttrNode type exposes the following members.
Methods
 | Name | Description
Protected method | checkCanModify | (Inherited from ConfigNode.)
Public method | Delete | Deletes this attribute from its parent (Overrides ConfigNode Delete .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsSameName(String) | Returns true when another name is the same as this node's name per case-insensitive culture-neutral comparison (Inherited from ConfigNode.)
Public method | IsSameName(IConfigNode) | Returns true when another node has the same name as this one per case-insensitive culture-neutral comparison (Inherited from ConfigNode.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ResetModified | Resets modification flag (Inherited from ConfigNode.)
Public method | ToString | (Inherited from ConfigNode.)
Public method | ValueAsBool | (Inherited from ConfigNode.)
Public method | ValueAsByte | (Inherited from ConfigNode.)
Public method | ValueAsByteArray | (Inherited from ConfigNode.)
Public method | ValueAsDateTime | (Inherited from ConfigNode.)
Public method | ValueAsDecimal | (Inherited from ConfigNode.)
Public method | ValueAsDouble | (Inherited from ConfigNode.)
Public method | ValueAsEnum TEnum | (Inherited from ConfigNode.)
Public method | ValueAsFloat | (Inherited from ConfigNode.)
Public method | ValueAsGDID | (Inherited from ConfigNode.)
Public method | ValueAsGUID | (Inherited from ConfigNode.)
Public method | ValueAsInt | (Inherited from ConfigNode.)
Public method | ValueAsLong | (Inherited from ConfigNode.)
Public method | ValueAsNullableBool | (Inherited from ConfigNode.)
Public method | ValueAsNullableByte | (Inherited from ConfigNode.)
Public method | ValueAsNullableDateTime | (Inherited from ConfigNode.)
Public method | ValueAsNullableDecimal | (Inherited from ConfigNode.)
Public method | ValueAsNullableDouble | (Inherited from ConfigNode.)
Public method | ValueAsNullableEnum TEnum | (Inherited from ConfigNode.)
Public method | ValueAsNullableFloat | (Inherited from ConfigNode.)
Public method | ValueAsNullableGDID | (Inherited from ConfigNode.)
Public method | ValueAsNullableGUID | (Inherited from ConfigNode.)
Public method | ValueAsNullableInt | (Inherited from ConfigNode.)
Public method | ValueAsNullableLong | (Inherited from ConfigNode.)
Public method | ValueAsNullableSByte | (Inherited from ConfigNode.)
Public method | ValueAsNullableShort | (Inherited from ConfigNode.)
Public method | ValueAsNullableTimeSpan | (Inherited from ConfigNode.)
Public method | ValueAsNullableUInt | (Inherited from ConfigNode.)
Public method | ValueAsNullableULong | (Inherited from ConfigNode.)
Public method | ValueAsNullableUShort | (Inherited from ConfigNode.)
Public method | ValueAsSByte | (Inherited from ConfigNode.)
Public method | ValueAsShort | (Inherited from ConfigNode.)
Public method | ValueAsString | (Inherited from ConfigNode.)
Public method | ValueAsTimeSpan | (Inherited from ConfigNode.)
Public method | ValueAsType | Tries to get value as specified type or throws if it can not be converted (Inherited from ConfigNode.)
Public method | ValueAsUInt | (Inherited from ConfigNode.)
Public method | ValueAsULong | (Inherited from ConfigNode.)
Public method | ValueAsUShort | (Inherited from ConfigNode.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ConfigAttrNode Class
NFX.Environment Namespace


ConfigAttrNode.Delete Method

ConfigAttrNode Delete Method NFX Class Library

Deletes this attribute from its parent

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Delete()
public override void Delete()
Public Overrides Sub Delete
Public Overrides Sub Delete
public:
virtual void Delete() override
public:
virtual void Delete() override
abstract Delete : unit -> unit
override Delete : unit -> unit
abstract Delete : unit -> unit
override Delete : unit -> unit
See Also
ConfigAttrNode Class
ConfigAttrNode Members
NFX.Environment Namespace


ConfigAttrNode Properties

ConfigAttrNode Properties NFX Class Library

The ConfigAttrNode type exposes the following members.
Properties
 | Name | Description
Public property | Configuration | References configuration this node is under (Inherited from ConfigNode.)
Public property | EvaluatedValue | Returns null or value of this node with all variables evaluated (Inherited from ConfigNode.)
Public property | Exists | Determines whether this node really exists in configuration or is just a sentinel empty node (Inherited from ConfigNode.)
Public property | Modified | Indicates whether a node was modified (Inherited from ConfigNode.)
Public property | Name | Retrieves node name (Inherited from ConfigNode.)
Public property | Parent | References parent node or Empty if this node has no parent (Inherited from ConfigNode.)
Public property | RootPath | Returns path from root to this node (Inherited from ConfigNode.)
Public property | Value | Retrieves node value or null. The value getter performs evaluation of variables, while setter sets the value verbatim (Inherited from ConfigNode.)
Public property | VerbatimValue | Returns verbatim (without variable evaluation) node value or null (Inherited from ConfigNode.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IConfigNode Parent | References parent node (Inherited from ConfigNode.)
Explicit interface implemetation | IConfigNode RootPath | (Inherited from ConfigNode.)
Back to Top
See Also
ConfigAttrNode Class
NFX.Environment Namespace


ConfigAttrNodeList Class

ConfigAttrNodeList Class NFX Class Library

Inheritance Hierarchy
Online System Object
Online System.Collections.Generic List ConfigAttrNode
NFX.Environment ConfigAttrNodeList

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
internal class ConfigAttrNodeList : List<ConfigAttrNode>
[SerializableAttribute]
internal class ConfigAttrNodeList : List<ConfigAttrNode>
<SerializableAttribute>
Friend Class ConfigAttrNodeList
    Inherits List(Of ConfigAttrNode)
<SerializableAttribute>
Friend Class ConfigAttrNodeList
    Inherits List(Of ConfigAttrNode)
[SerializableAttribute]
internal ref class ConfigAttrNodeList : public List<ConfigAttrNode^>
[SerializableAttribute]
internal ref class ConfigAttrNodeList : public List<ConfigAttrNode^>
[<SerializableAttribute>]
type ConfigAttrNodeList =
    class
        inherit List<ConfigAttrNode>
    end
[<SerializableAttribute>]
type ConfigAttrNodeList =
    class
        inherit List<ConfigAttrNode>
    end
See Also
ConfigAttrNodeList Members
NFX.Environment Namespace


ConfigAttrNodeList Members

ConfigAttrNodeList Members NFX Class Library

The ConfigAttrNodeList type exposes the following members.
Constructors
 | Name | Description
Public method | ConfigAttrNodeList | Initializes a new instance of the ConfigAttrNodeList class
Back to Top
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List ConfigAttrNode .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List ConfigAttrNode .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List ConfigAttrNode .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List ConfigAttrNode .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List ConfigAttrNode .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List ConfigAttrNode .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List ConfigAttrNode .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List ConfigAttrNode .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List ConfigAttrNode .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List ConfigAttrNode .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List ConfigAttrNode .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List ConfigAttrNode .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List ConfigAttrNode .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List ConfigAttrNode .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List ConfigAttrNode .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List ConfigAttrNode .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List ConfigAttrNode .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List ConfigAttrNode .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List ConfigAttrNode .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List ConfigAttrNode .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List ConfigAttrNode .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List ConfigAttrNode .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List ConfigAttrNode .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List ConfigAttrNode .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List ConfigAttrNode .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List ConfigAttrNode .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List ConfigAttrNode .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List ConfigAttrNode .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List ConfigAttrNode .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List ConfigAttrNode .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List ConfigAttrNode .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List ConfigAttrNode .)
Back to Top
See Also
ConfigAttrNodeList Class
NFX.Environment Namespace


ConfigAttrNodeList Constructor

ConfigAttrNodeList Constructor NFX Class Library

Initializes a new instance of the ConfigAttrNodeList class

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigAttrNodeList()
public ConfigAttrNodeList()
Public Sub New
Public Sub New
public:
ConfigAttrNodeList()
public:
ConfigAttrNodeList()
new : unit -> ConfigAttrNodeList
new : unit -> ConfigAttrNodeList
See Also
ConfigAttrNodeList Class
ConfigAttrNodeList Members
NFX.Environment Namespace


ConfigAttrNodeList Methods

ConfigAttrNodeList Methods NFX Class Library

The ConfigAttrNodeList type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List ConfigAttrNode .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List ConfigAttrNode .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List ConfigAttrNode .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List ConfigAttrNode .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List ConfigAttrNode .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List ConfigAttrNode .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List ConfigAttrNode .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List ConfigAttrNode .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List ConfigAttrNode .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List ConfigAttrNode .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List ConfigAttrNode .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List ConfigAttrNode .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List ConfigAttrNode .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List ConfigAttrNode .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List ConfigAttrNode .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List ConfigAttrNode .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List ConfigAttrNode .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List ConfigAttrNode .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List ConfigAttrNode .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List ConfigAttrNode .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List ConfigAttrNode .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List ConfigAttrNode .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List ConfigAttrNode .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List ConfigAttrNode .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List ConfigAttrNode .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List ConfigAttrNode .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List ConfigAttrNode .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List ConfigAttrNode .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List ConfigAttrNode .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List ConfigAttrNode .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ConfigAttrNodeList Class
NFX.Environment Namespace


ConfigAttrNodeList Properties

ConfigAttrNodeList Properties NFX Class Library

The ConfigAttrNodeList type exposes the following members.
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List ConfigAttrNode .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List ConfigAttrNode .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List ConfigAttrNode .)
Back to Top
See Also
ConfigAttrNodeList Class
NFX.Environment Namespace


ConfigException Class

ConfigException Class NFX Class Library

Configuration-related exception
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Environment ConfigException
NFX.Environment BehaviorApplyException

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ConfigException : NFXException
[SerializableAttribute]
public class ConfigException : NFXException
<SerializableAttribute>
Public Class ConfigException
    Inherits NFXException
<SerializableAttribute>
Public Class ConfigException
    Inherits NFXException
[SerializableAttribute]
public ref class ConfigException : public NFXException
[SerializableAttribute]
public ref class ConfigException : public NFXException
[<SerializableAttribute>]
type ConfigException =
    class
        inherit NFXException
    end
[<SerializableAttribute>]
type ConfigException =
    class
        inherit NFXException
    end
See Also
ConfigException Members
NFX.Environment Namespace


ConfigException Members

ConfigException Members NFX Class Library

The ConfigException type exposes the following members.
Constructors
 | Name | Description
Public method | ConfigException | Initializes a new instance of the ConfigException class
Public method | ConfigException(String) | Initializes a new instance of the ConfigException class
Protected method | ConfigException(SerializationInfo, StreamingContext) | Initializes a new instance of the ConfigException class
Public method | ConfigException(String, Exception) | Initializes a new instance of the ConfigException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ConfigException Class
NFX.Environment Namespace


ConfigException Constructor

ConfigException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ConfigException | Initializes a new instance of the ConfigException class
Public method | ConfigException(String) | Initializes a new instance of the ConfigException class
Protected method | ConfigException(SerializationInfo, StreamingContext) | Initializes a new instance of the ConfigException class
Public method | ConfigException(String, Exception) | Initializes a new instance of the ConfigException class
Back to Top
See Also
ConfigException Class
ConfigException Members
NFX.Environment Namespace


ConfigException Constructor

ConfigException Constructor NFX Class Library

Initializes a new instance of the ConfigException class

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigException()
public ConfigException()
Public Sub New
Public Sub New
public:
ConfigException()
public:
ConfigException()
new : unit -> ConfigException
new : unit -> ConfigException
See Also
ConfigException Class
ConfigException Members
ConfigException Overload
NFX.Environment Namespace


ConfigException Constructor (String)

ConfigException Constructor (String) NFX Class Library

Initializes a new instance of the ConfigException class

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigException(
    string message
)
public ConfigException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
ConfigException(
    String^ message
)
public:
ConfigException(
    String^ message
)
new :
        message : string -> ConfigException
new :
        message : string -> ConfigException

Parameters

message
Type: Online System String
See Also
ConfigException Class
ConfigException Members
ConfigException Overload
NFX.Environment Namespace


ConfigException Constructor (SerializationInfo, StreamingContext)

ConfigException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConfigException class

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ConfigException(
    SerializationInfo info,
    StreamingContext context
)
protected ConfigException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
ConfigException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
ConfigException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigException
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
ConfigException Class
ConfigException Members
ConfigException Overload
NFX.Environment Namespace


ConfigException Constructor (String, Exception)

ConfigException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConfigException class

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigException(
    string message,
    Exception inner
)
public ConfigException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
ConfigException(
    String^ message,
    Exception^ inner
)
public:
ConfigException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> ConfigException
new :
        message : string *
        inner : Exception -> ConfigException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
ConfigException Class
ConfigException Members
ConfigException Overload
NFX.Environment Namespace


ConfigException Methods

ConfigException Methods NFX Class Library

The ConfigException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
ConfigException Class
NFX.Environment Namespace


ConfigException Properties

ConfigException Properties NFX Class Library

The ConfigException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
ConfigException Class
NFX.Environment Namespace


ConfigException Events

ConfigException Events NFX Class Library

The ConfigException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ConfigException Class
NFX.Environment Namespace


ConfigMacroContextAttribute Class

ConfigMacroContextAttribute Class NFX Class Library

Decorates classes or structs that act as a context object for macro evaluation - passed as context parameter to MacroRunner.Run(...context) method
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.Environment ConfigMacroContextAttribute

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Struct, Inherited = true,
    AllowMultiple = false)]
public class ConfigMacroContextAttribute : Attribute
[AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Struct, Inherited = true,
    AllowMultiple = false)]
public class ConfigMacroContextAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Class Or AttributeTargets.Struct, Inherited := true,
    AllowMultiple := false)>
Public Class ConfigMacroContextAttribute
    Inherits Attribute
<AttributeUsageAttribute(AttributeTargets.Class Or AttributeTargets.Struct, Inherited := true,
    AllowMultiple := false)>
Public Class ConfigMacroContextAttribute
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Class|AttributeTargets::Struct, Inherited = true,
    AllowMultiple = false)]
public ref class ConfigMacroContextAttribute : public Attribute
[AttributeUsageAttribute(AttributeTargets::Class|AttributeTargets::Struct, Inherited = true,
    AllowMultiple = false)]
public ref class ConfigMacroContextAttribute : public Attribute
[<AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Struct, Inherited = true,
    AllowMultiple = false)>]
type ConfigMacroContextAttribute =
    class
        inherit Attribute
    end
[<AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Struct, Inherited = true,
    AllowMultiple = false)>]
type ConfigMacroContextAttribute =
    class
        inherit Attribute
    end
See Also
ConfigMacroContextAttribute Members
NFX.Environment Namespace


ConfigMacroContextAttribute Members

ConfigMacroContextAttribute Members NFX Class Library

The ConfigMacroContextAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | ConfigMacroContextAttribute | Initializes a new instance of the ConfigMacroContextAttribute class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
ConfigMacroContextAttribute Class
NFX.Environment Namespace


ConfigMacroContextAttribute Constructor

ConfigMacroContextAttribute Constructor NFX Class Library

Initializes a new instance of the ConfigMacroContextAttribute class

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigMacroContextAttribute()
public ConfigMacroContextAttribute()
Public Sub New
Public Sub New
public:
ConfigMacroContextAttribute()
public:
ConfigMacroContextAttribute()
new : unit -> ConfigMacroContextAttribute
new : unit -> ConfigMacroContextAttribute
See Also
ConfigMacroContextAttribute Class
ConfigMacroContextAttribute Members
NFX.Environment Namespace


ConfigMacroContextAttribute Methods

ConfigMacroContextAttribute Methods NFX Class Library

The ConfigMacroContextAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ConfigMacroContextAttribute Class
NFX.Environment Namespace


ConfigMacroContextAttribute Properties

ConfigMacroContextAttribute Properties NFX Class Library

The ConfigMacroContextAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
ConfigMacroContextAttribute Class
NFX.Environment Namespace


ConfigNode Class

ConfigNode Class NFX Class Library

Provides configuration node abstraction for section and attribute nodes. This class is thread-safe
Inheritance Hierarchy
Online System Object
NFX.Environment ConfigNode
NFX.Environment ConfigAttrNode
NFX.Environment ConfigSectionNode

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class ConfigNode : IConfigNode,
    INamed
[SerializableAttribute]
public abstract class ConfigNode : IConfigNode,
    INamed
<SerializableAttribute>
Public MustInherit Class ConfigNode
    Implements IConfigNode, INamed
<SerializableAttribute>
Public MustInherit Class ConfigNode
    Implements IConfigNode, INamed
[SerializableAttribute]
public ref class ConfigNode abstract : IConfigNode,
    INamed
[SerializableAttribute]
public ref class ConfigNode abstract : IConfigNode,
    INamed
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ConfigNode =
    class
        interface IConfigNode
        interface INamed
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ConfigNode =
    class
        interface IConfigNode
        interface INamed
    end
See Also
ConfigNode Members
NFX.Environment Namespace


ConfigNode Members

ConfigNode Members NFX Class Library

The ConfigNode type exposes the following members.
Constructors
 | Name | Description
Protected method | ConfigNode(Configuration, ConfigSectionNode) | Initializes a new instance of the ConfigNode class
Protected method | ConfigNode(Configuration, ConfigSectionNode, IConfigNode) | Creates new node by cloning other node from this or another configuration
Protected method | ConfigNode(Configuration, ConfigSectionNode, String, String) | Initializes a new instance of the ConfigNode class
Back to Top
Methods
 | Name | Description
Protected method | checkCanModify |
Public method | Delete |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsSameName(String) | Returns true when another name is the same as this node's name per case-insensitive culture-neutral comparison
Public method | IsSameName(IConfigNode) | Returns true when another node has the same name as this one per case-insensitive culture-neutral comparison
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ResetModified | Resets modification flag
Public method | ToString | (Overrides Online Object ToString .)
Public method | ValueAsBool |
Public method | ValueAsByte |
Public method | ValueAsByteArray |
Public method | ValueAsDateTime |
Public method | ValueAsDecimal |
Public method | ValueAsDouble |
Public method | ValueAsEnum TEnum |
Public method | ValueAsFloat |
Public method | ValueAsGDID |
Public method | ValueAsGUID |
Public method | ValueAsInt |
Public method | ValueAsLong |
Public method | ValueAsNullableBool |
Public method | ValueAsNullableByte |
Public method | ValueAsNullableDateTime |
Public method | ValueAsNullableDecimal |
Public method | ValueAsNullableDouble |
Public method | ValueAsNullableEnum TEnum |
Public method | ValueAsNullableFloat |
Public method | ValueAsNullableGDID |
Public method | ValueAsNullableGUID |
Public method | ValueAsNullableInt |
Public method | ValueAsNullableLong |
Public method | ValueAsNullableSByte |
Public method | ValueAsNullableShort |
Public method | ValueAsNullableTimeSpan |
Public method | ValueAsNullableUInt |
Public method | ValueAsNullableULong |
Public method | ValueAsNullableUShort |
Public method | ValueAsSByte |
Public method | ValueAsShort |
Public method | ValueAsString |
Public method | ValueAsTimeSpan |
Public method | ValueAsType | Tries to get value as specified type or throws if it can not be converted
Public method | ValueAsUInt |
Public method | ValueAsULong |
Public method | ValueAsUShort |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | __Empty |
Protected field | m_Configuration |
Protected field | m_Modified |
Back to Top
Properties
 | Name | Description
Public property | Configuration | References configuration this node is under
Public property | EvaluatedValue | Returns null or value of this node with all variables evaluated
Public property | Exists | Determines whether this node really exists in configuration or is just a sentinel empty node
Public property | Modified | Indicates whether a node was modified
Public property | Name | Retrieves node name
Public property | Parent | References parent node or Empty if this node has no parent
Public property | RootPath | Returns path from root to this node
Public property | Value | Retrieves node value or null. The value getter performs evaluation of variables, while setter sets the value verbatim
Public property | VerbatimValue | Returns verbatim (without variable evaluation) node value or null
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IConfigNode Parent | References parent node
Explicit interface implemetation | IConfigNode RootPath |
Back to Top
See Also
ConfigNode Class
NFX.Environment Namespace


ConfigNode Constructor

ConfigNode Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | ConfigNode(Configuration, ConfigSectionNode) | Initializes a new instance of the ConfigNode class
Protected method | ConfigNode(Configuration, ConfigSectionNode, IConfigNode) | Creates new node by cloning other node from this or another configuration
Protected method | ConfigNode(Configuration, ConfigSectionNode, String, String) | Initializes a new instance of the ConfigNode class
Back to Top
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode Constructor (Configuration, ConfigSectionNode)

ConfigNode Constructor (Configuration, ConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConfigNode class

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ConfigNode(
    Configuration conf,
    ConfigSectionNode parent
)
protected ConfigNode(
    Configuration conf,
    ConfigSectionNode parent
)
Protected Sub New (
    conf As Configuration,
    parent As ConfigSectionNode
)
Protected Sub New (
    conf As Configuration,
    parent As ConfigSectionNode
)
protected:
ConfigNode(
    Configuration^ conf,
    ConfigSectionNode^ parent
)
protected:
ConfigNode(
    Configuration^ conf,
    ConfigSectionNode^ parent
)
new :
        conf : Configuration *
        parent : ConfigSectionNode -> ConfigNode
new :
        conf : Configuration *
        parent : ConfigSectionNode -> ConfigNode

Parameters

conf
Type: NFX.Environment Configuration
parent
Type: NFX.Environment ConfigSectionNode
See Also
ConfigNode Class
ConfigNode Members
ConfigNode Overload
NFX.Environment Namespace


ConfigNode Constructor (Configuration, ConfigSectionNode, IConfigNode)

ConfigNode Constructor (Configuration, ConfigSectionNode, IConfigNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates new node by cloning other node from this or another configuration

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ConfigNode(
    Configuration conf,
    ConfigSectionNode parent,
    IConfigNode clone
)
protected ConfigNode(
    Configuration conf,
    ConfigSectionNode parent,
    IConfigNode clone
)
Protected Sub New (
    conf As Configuration,
    parent As ConfigSectionNode,
    clone As IConfigNode
)
Protected Sub New (
    conf As Configuration,
    parent As ConfigSectionNode,
    clone As IConfigNode
)
protected:
ConfigNode(
    Configuration^ conf,
    ConfigSectionNode^ parent,
    IConfigNode^ clone
)
protected:
ConfigNode(
    Configuration^ conf,
    ConfigSectionNode^ parent,
    IConfigNode^ clone
)
new :
        conf : Configuration *
        parent : ConfigSectionNode *
        clone : IConfigNode -> ConfigNode
new :
        conf : Configuration *
        parent : ConfigSectionNode *
        clone : IConfigNode -> ConfigNode

Parameters

conf
Type: NFX.Environment Configuration
parent
Type: NFX.Environment ConfigSectionNode
clone
Type: NFX.Environment IConfigNode
See Also
ConfigNode Class
ConfigNode Members
ConfigNode Overload
NFX.Environment Namespace


ConfigNode Constructor (Configuration, ConfigSectionNode, String, String)

ConfigNode Constructor (Configuration, ConfigSectionNode, String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConfigNode class

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ConfigNode(
    Configuration conf,
    ConfigSectionNode parent,
    string name,
    string value
)
protected ConfigNode(
    Configuration conf,
    ConfigSectionNode parent,
    string name,
    string value
)
Protected Sub New (
    conf As Configuration,
    parent As ConfigSectionNode,
    name As String,
    value As String
)
Protected Sub New (
    conf As Configuration,
    parent As ConfigSectionNode,
    name As String,
    value As String
)
protected:
ConfigNode(
    Configuration^ conf,
    ConfigSectionNode^ parent,
    String^ name,
    String^ value
)
protected:
ConfigNode(
    Configuration^ conf,
    ConfigSectionNode^ parent,
    String^ name,
    String^ value
)
new :
        conf : Configuration *
        parent : ConfigSectionNode *
        name : string *
        value : string -> ConfigNode
new :
        conf : Configuration *
        parent : ConfigSectionNode *
        name : string *
        value : string -> ConfigNode

Parameters

conf
Type: NFX.Environment Configuration
parent
Type: NFX.Environment ConfigSectionNode
name
Type: Online System String
value
Type: Online System String
See Also
ConfigNode Class
ConfigNode Members
ConfigNode Overload
NFX.Environment Namespace


ConfigNode Fields

ConfigNode Fields NFX Class Library

The ConfigNode type exposes the following members.
Fields
 | Name | Description
Protected field | __Empty |
Protected field | m_Configuration |
Protected field | m_Modified |
Back to Top
See Also
ConfigNode Class
NFX.Environment Namespace


ConfigNode.__Empty Field

ConfigNode __Empty Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal bool __Empty
internal bool __Empty
Friend __Empty As Boolean
Friend __Empty As Boolean
internal:
bool __Empty
internal:
bool __Empty
val mutable internal __Empty: bool
val mutable internal __Empty: bool

Field Value

Type: Online Boolean
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.m_Configuration Field

ConfigNode m_Configuration Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Configuration m_Configuration
protected Configuration m_Configuration
Protected m_Configuration As Configuration
Protected m_Configuration As Configuration
protected:
Configuration^ m_Configuration
protected:
Configuration^ m_Configuration
val mutable m_Configuration: Configuration
val mutable m_Configuration: Configuration

Field Value

Type: Configuration
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.m_Modified Field

ConfigNode m_Modified Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal bool m_Modified
protected internal bool m_Modified
Protected Friend m_Modified As Boolean
Protected Friend m_Modified As Boolean
protected public:
bool m_Modified
protected public:
bool m_Modified
val mutable m_Modified: bool
val mutable m_Modified: bool

Field Value

Type: Online Boolean
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode Methods

ConfigNode Methods NFX Class Library

The ConfigNode type exposes the following members.
Methods
 | Name | Description
Protected method | checkCanModify |
Public method | Delete |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsSameName(String) | Returns true when another name is the same as this node's name per case-insensitive culture-neutral comparison
Public method | IsSameName(IConfigNode) | Returns true when another node has the same name as this one per case-insensitive culture-neutral comparison
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ResetModified | Resets modification flag
Public method | ToString | (Overrides Online Object ToString .)
Public method | ValueAsBool |
Public method | ValueAsByte |
Public method | ValueAsByteArray |
Public method | ValueAsDateTime |
Public method | ValueAsDecimal |
Public method | ValueAsDouble |
Public method | ValueAsEnum TEnum |
Public method | ValueAsFloat |
Public method | ValueAsGDID |
Public method | ValueAsGUID |
Public method | ValueAsInt |
Public method | ValueAsLong |
Public method | ValueAsNullableBool |
Public method | ValueAsNullableByte |
Public method | ValueAsNullableDateTime |
Public method | ValueAsNullableDecimal |
Public method | ValueAsNullableDouble |
Public method | ValueAsNullableEnum TEnum |
Public method | ValueAsNullableFloat |
Public method | ValueAsNullableGDID |
Public method | ValueAsNullableGUID |
Public method | ValueAsNullableInt |
Public method | ValueAsNullableLong |
Public method | ValueAsNullableSByte |
Public method | ValueAsNullableShort |
Public method | ValueAsNullableTimeSpan |
Public method | ValueAsNullableUInt |
Public method | ValueAsNullableULong |
Public method | ValueAsNullableUShort |
Public method | ValueAsSByte |
Public method | ValueAsShort |
Public method | ValueAsString |
Public method | ValueAsTimeSpan |
Public method | ValueAsType | Tries to get value as specified type or throws if it can not be converted
Public method | ValueAsUInt |
Public method | ValueAsULong |
Public method | ValueAsUShort |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ConfigNode Class
NFX.Environment Namespace


ConfigNode.checkCanModify Method

ConfigNode checkCanModify Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void checkCanModify()
internal void checkCanModify()
Friend Sub checkCanModify
Friend Sub checkCanModify
internal:
void checkCanModify()
internal:
void checkCanModify()
internal member checkCanModify : unit -> unit
internal member checkCanModify : unit -> unit
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.Delete Method

ConfigNode Delete Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Delete()
public abstract void Delete()
Public MustOverride Sub Delete
Public MustOverride Sub Delete
public:
virtual void Delete() abstract
public:
virtual void Delete() abstract
abstract Delete : unit -> unit
abstract Delete : unit -> unit
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.IsSameName Method

ConfigNode IsSameName Method NFX Class Library

Overload List
 | Name | Description
Public method | IsSameName(String) | Returns true when another name is the same as this node's name per case-insensitive culture-neutral comparison
Public method | IsSameName(IConfigNode) | Returns true when another node has the same name as this one per case-insensitive culture-neutral comparison
Back to Top
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.IsSameName Method (String)

ConfigNode IsSameName Method (String) NFX Class Library

Returns true when another name is the same as this node's name per case-insensitive culture-neutral comparison

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsSameName(
    string other
)
public bool IsSameName(
    string other
)
Public Function IsSameName (
    other As String
) As Boolean
Public Function IsSameName (
    other As String
) As Boolean
public:
virtual bool IsSameName(
    String^ other
) sealed
public:
virtual bool IsSameName(
    String^ other
) sealed
abstract IsSameName :
        other : string -> bool
override IsSameName :
        other : string -> bool
abstract IsSameName :
        other : string -> bool
override IsSameName :
        other : string -> bool

Parameters

other
Type: Online System String

Return Value

Type: Online Boolean

Implements

IConfigNode IsSameName(String)
See Also
ConfigNode Class
ConfigNode Members
IsSameName Overload
NFX.Environment Namespace


ConfigNode.IsSameName Method (IConfigNode)

ConfigNode IsSameName Method (IConfigNode) NFX Class Library

Returns true when another node has the same name as this one per case-insensitive culture-neutral comparison

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsSameName(
    IConfigNode other
)
public bool IsSameName(
    IConfigNode other
)
Public Function IsSameName (
    other As IConfigNode
) As Boolean
Public Function IsSameName (
    other As IConfigNode
) As Boolean
public:
virtual bool IsSameName(
    IConfigNode^ other
) sealed
public:
virtual bool IsSameName(
    IConfigNode^ other
) sealed
abstract IsSameName :
        other : IConfigNode -> bool
override IsSameName :
        other : IConfigNode -> bool
abstract IsSameName :
        other : IConfigNode -> bool
override IsSameName :
        other : IConfigNode -> bool

Parameters

other
Type: NFX.Environment IConfigNode

Return Value

Type: Online Boolean

Implements

IConfigNode IsSameName(IConfigNode)
See Also
ConfigNode Class
ConfigNode Members
IsSameName Overload
NFX.Environment Namespace


ConfigNode.ResetModified Method

ConfigNode ResetModified Method NFX Class Library

Resets modification flag

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void ResetModified()
public virtual void ResetModified()
Public Overridable Sub ResetModified
Public Overridable Sub ResetModified
public:
virtual void ResetModified()
public:
virtual void ResetModified()
abstract ResetModified : unit -> unit
override ResetModified : unit -> unit
abstract ResetModified : unit -> unit
override ResetModified : unit -> unit
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ToString Method

ConfigNode ToString Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsBool Method

ConfigNode ValueAsBool Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ValueAsBool(
    bool dflt = false,
    bool verbatim = false
)
public bool ValueAsBool(
    bool dflt = false,
    bool verbatim = false
)
Public Function ValueAsBool (
    Optional dflt As Boolean = false,
    Optional verbatim As Boolean = false
) As Boolean
Public Function ValueAsBool (
    Optional dflt As Boolean = false,
    Optional verbatim As Boolean = false
) As Boolean
public:
virtual bool ValueAsBool(
    bool dflt = false,
    bool verbatim = false
) sealed
public:
virtual bool ValueAsBool(
    bool dflt = false,
    bool verbatim = false
) sealed
abstract ValueAsBool :
        ?dflt : bool *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt false
        let _verbatim = defaultArg verbatim false
*)
-> bool
override ValueAsBool :
        ?dflt : bool *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt false
        let _verbatim = defaultArg verbatim false
*)
-> bool
abstract ValueAsBool :
        ?dflt : bool *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt false
        let _verbatim = defaultArg verbatim false
*)
-> bool
override ValueAsBool :
        ?dflt : bool *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt false
        let _verbatim = defaultArg verbatim false
*)
-> bool

Parameters

dflt (Optional)
Type: Online System Boolean
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Boolean

Implements

IConfigNode ValueAsBool(Boolean, Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsByte Method

ConfigNode ValueAsByte Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte ValueAsByte(
    byte dflt = 0,
    bool verbatim = false
)
public byte ValueAsByte(
    byte dflt = 0,
    bool verbatim = false
)
Public Function ValueAsByte (
    Optional dflt As Byte = 0,
    Optional verbatim As Boolean = false
) As Byte
Public Function ValueAsByte (
    Optional dflt As Byte = 0,
    Optional verbatim As Boolean = false
) As Byte
public:
virtual unsigned char ValueAsByte(
    unsigned char dflt = 0,
    bool verbatim = false
) sealed
public:
virtual unsigned char ValueAsByte(
    unsigned char dflt = 0,
    bool verbatim = false
) sealed
abstract ValueAsByte :
        ?dflt : byte *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> byte
override ValueAsByte :
        ?dflt : byte *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> byte
abstract ValueAsByte :
        ?dflt : byte *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> byte
override ValueAsByte :
        ?dflt : byte *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> byte

Parameters

dflt (Optional)
Type: Online System Byte
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Byte

Implements

IConfigNode ValueAsByte(Byte, Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsByteArray Method

ConfigNode ValueAsByteArray Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] ValueAsByteArray(
    byte[] dflt = null,
    bool verbatim = false
)
public byte[] ValueAsByteArray(
    byte[] dflt = null,
    bool verbatim = false
)
Public Function ValueAsByteArray (
    Optional dflt As Byte() = Nothing,
    Optional verbatim As Boolean = false
) As Byte()
Public Function ValueAsByteArray (
    Optional dflt As Byte() = Nothing,
    Optional verbatim As Boolean = false
) As Byte()
public:
virtual array<unsigned char>^ ValueAsByteArray(
    array<unsigned char>^ dflt = nullptr,
    bool verbatim = false
) sealed
public:
virtual array<unsigned char>^ ValueAsByteArray(
    array<unsigned char>^ dflt = nullptr,
    bool verbatim = false
) sealed
abstract ValueAsByteArray :
        ?dflt : byte[] *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> byte[]
override ValueAsByteArray :
        ?dflt : byte[] *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> byte[]
abstract ValueAsByteArray :
        ?dflt : byte[] *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> byte[]
override ValueAsByteArray :
        ?dflt : byte[] *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> byte[]

Parameters

dflt (Optional)
Type: Online System Byte
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Byte

Implements

IConfigNode ValueAsByteArray( Byte , Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsDateTime Method

ConfigNode ValueAsDateTime Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime ValueAsDateTime(
    DateTime dflt,
    bool verbatim = false
)
public DateTime ValueAsDateTime(
    DateTime dflt,
    bool verbatim = false
)
Public Function ValueAsDateTime (
    dflt As DateTime,
    Optional verbatim As Boolean = false
) As DateTime
Public Function ValueAsDateTime (
    dflt As DateTime,
    Optional verbatim As Boolean = false
) As DateTime
public:
virtual DateTime ValueAsDateTime(
    DateTime dflt,
    bool verbatim = false
) sealed
public:
virtual DateTime ValueAsDateTime(
    DateTime dflt,
    bool verbatim = false
) sealed
abstract ValueAsDateTime :
        dflt : DateTime *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> DateTime
override ValueAsDateTime :
        dflt : DateTime *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> DateTime
abstract ValueAsDateTime :
        dflt : DateTime *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> DateTime
override ValueAsDateTime :
        dflt : DateTime *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> DateTime

Parameters

dflt
Type: Online System DateTime
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online DateTime

Implements

IConfigNode ValueAsDateTime(DateTime, Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsDecimal Method

ConfigNode ValueAsDecimal Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal ValueAsDecimal(
    [OptionalAttribute] decimal dflt,
    bool verbatim = false
)
public decimal ValueAsDecimal(
    [OptionalAttribute] decimal dflt,
    bool verbatim = false
)
Public Function ValueAsDecimal (
    <OptionalAttribute> dflt As Decimal,
    Optional verbatim As Boolean = false
) As Decimal
Public Function ValueAsDecimal (
    <OptionalAttribute> dflt As Decimal,
    Optional verbatim As Boolean = false
) As Decimal
public:
virtual Decimal ValueAsDecimal(
    [OptionalAttribute] Decimal dflt,
    bool verbatim = false
) sealed
public:
virtual Decimal ValueAsDecimal(
    [OptionalAttribute] Decimal dflt,
    bool verbatim = false
) sealed
abstract ValueAsDecimal :
        [<OptionalAttribute>] dflt : decimal *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> decimal
override ValueAsDecimal :
        [<OptionalAttribute>] dflt : decimal *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> decimal
abstract ValueAsDecimal :
        [<OptionalAttribute>] dflt : decimal *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> decimal
override ValueAsDecimal :
        [<OptionalAttribute>] dflt : decimal *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> decimal

Parameters

dflt (Optional)
Type: Online System Decimal
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Decimal

Implements

IConfigNode ValueAsDecimal(Decimal, Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsDouble Method

ConfigNode ValueAsDouble Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double ValueAsDouble(
    double dflt = 0,
    bool verbatim = false
)
public double ValueAsDouble(
    double dflt = 0,
    bool verbatim = false
)
Public Function ValueAsDouble (
    Optional dflt As Double = 0,
    Optional verbatim As Boolean = false
) As Double
Public Function ValueAsDouble (
    Optional dflt As Double = 0,
    Optional verbatim As Boolean = false
) As Double
public:
virtual double ValueAsDouble(
    double dflt = 0,
    bool verbatim = false
) sealed
public:
virtual double ValueAsDouble(
    double dflt = 0,
    bool verbatim = false
) sealed
abstract ValueAsDouble :
        ?dflt : float *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> float
override ValueAsDouble :
        ?dflt : float *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> float
abstract ValueAsDouble :
        ?dflt : float *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> float
override ValueAsDouble :
        ?dflt : float *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> float

Parameters

dflt (Optional)
Type: Online System Double
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Double

Implements

IConfigNode ValueAsDouble(Double, Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsEnum(TEnum) Method

ConfigNode ValueAsEnum TEnum Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TEnum ValueAsEnum<TEnum>(
    TEnum dflt = null,
    bool verbatim = false
)
where TEnum : struct, new()
public TEnum ValueAsEnum<TEnum>(
    TEnum dflt = null,
    bool verbatim = false
)
where TEnum : struct, new()
Public Function ValueAsEnum(Of TEnum As {Structure, New}) (
    Optional dflt As TEnum = Nothing,
    Optional verbatim As Boolean = false
) As TEnum
Public Function ValueAsEnum(Of TEnum As {Structure, New}) (
    Optional dflt As TEnum = Nothing,
    Optional verbatim As Boolean = false
) As TEnum
public:
generic<typename TEnum>
where TEnum : value class, gcnew()
virtual TEnum ValueAsEnum(
    TEnum dflt = nullptr,
    bool verbatim = false
) sealed
public:
generic<typename TEnum>
where TEnum : value class, gcnew()
virtual TEnum ValueAsEnum(
    TEnum dflt = nullptr,
    bool verbatim = false
) sealed
abstract ValueAsEnum :
        ?dflt : 'TEnum *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> 'TEnum  when 'TEnum : struct, new()
override ValueAsEnum :
        ?dflt : 'TEnum *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> 'TEnum  when 'TEnum : struct, new()
abstract ValueAsEnum :
        ?dflt : 'TEnum *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> 'TEnum  when 'TEnum : struct, new()
override ValueAsEnum :
        ?dflt : 'TEnum *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> 'TEnum  when 'TEnum : struct, new()

Parameters

dflt (Optional)
Type: TEnum
verbatim (Optional)
Type: Online System Boolean
Type Parameters
TEnum

Return Value

Type: TEnum

Implements

IConfigNode ValueAsEnum TEnum (TEnum, Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsFloat Method

ConfigNode ValueAsFloat Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float ValueAsFloat(
    float dflt = 0f,
    bool verbatim = false
)
public float ValueAsFloat(
    float dflt = 0f,
    bool verbatim = false
)
Public Function ValueAsFloat (
    Optional dflt As Single = 0F,
    Optional verbatim As Boolean = false
) As Single
Public Function ValueAsFloat (
    Optional dflt As Single = 0F,
    Optional verbatim As Boolean = false
) As Single
public:
virtual float ValueAsFloat(
    float dflt = 0f,
    bool verbatim = false
) sealed
public:
virtual float ValueAsFloat(
    float dflt = 0f,
    bool verbatim = false
) sealed
abstract ValueAsFloat :
        ?dflt : float32 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0f
        let _verbatim = defaultArg verbatim false
*)
-> float32
override ValueAsFloat :
        ?dflt : float32 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0f
        let _verbatim = defaultArg verbatim false
*)
-> float32
abstract ValueAsFloat :
        ?dflt : float32 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0f
        let _verbatim = defaultArg verbatim false
*)
-> float32
override ValueAsFloat :
        ?dflt : float32 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0f
        let _verbatim = defaultArg verbatim false
*)
-> float32

Parameters

dflt (Optional)
Type: Online System Single
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Single

Implements

IConfigNode ValueAsFloat(Single, Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsGDID Method

ConfigNode ValueAsGDID Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GDID ValueAsGDID(
    GDID dflt,
    bool verbatim = false
)
public GDID ValueAsGDID(
    GDID dflt,
    bool verbatim = false
)
Public Function ValueAsGDID (
    dflt As GDID,
    Optional verbatim As Boolean = false
) As GDID
Public Function ValueAsGDID (
    dflt As GDID,
    Optional verbatim As Boolean = false
) As GDID
public:
virtual GDID ValueAsGDID(
    GDID dflt,
    bool verbatim = false
) sealed
public:
virtual GDID ValueAsGDID(
    GDID dflt,
    bool verbatim = false
) sealed
abstract ValueAsGDID :
        dflt : GDID *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> GDID
override ValueAsGDID :
        dflt : GDID *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> GDID
abstract ValueAsGDID :
        dflt : GDID *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> GDID
override ValueAsGDID :
        dflt : GDID *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> GDID

Parameters

dflt
Type: NFX.DataAccess.Distributed GDID
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: GDID

Implements

IConfigNode ValueAsGDID(GDID, Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsGUID Method

ConfigNode ValueAsGUID Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid ValueAsGUID(
    Guid dflt,
    bool verbatim = false
)
public Guid ValueAsGUID(
    Guid dflt,
    bool verbatim = false
)
Public Function ValueAsGUID (
    dflt As Guid,
    Optional verbatim As Boolean = false
) As Guid
Public Function ValueAsGUID (
    dflt As Guid,
    Optional verbatim As Boolean = false
) As Guid
public:
virtual Guid ValueAsGUID(
    Guid dflt,
    bool verbatim = false
) sealed
public:
virtual Guid ValueAsGUID(
    Guid dflt,
    bool verbatim = false
) sealed
abstract ValueAsGUID :
        dflt : Guid *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> Guid
override ValueAsGUID :
        dflt : Guid *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> Guid
abstract ValueAsGUID :
        dflt : Guid *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> Guid
override ValueAsGUID :
        dflt : Guid *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> Guid

Parameters

dflt
Type: Online System Guid
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Guid

Implements

IConfigNode ValueAsGUID(Guid, Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsInt Method

ConfigNode ValueAsInt Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ValueAsInt(
    int dflt = 0,
    bool verbatim = false
)
public int ValueAsInt(
    int dflt = 0,
    bool verbatim = false
)
Public Function ValueAsInt (
    Optional dflt As Integer = 0,
    Optional verbatim As Boolean = false
) As Integer
Public Function ValueAsInt (
    Optional dflt As Integer = 0,
    Optional verbatim As Boolean = false
) As Integer
public:
virtual int ValueAsInt(
    int dflt = 0,
    bool verbatim = false
) sealed
public:
virtual int ValueAsInt(
    int dflt = 0,
    bool verbatim = false
) sealed
abstract ValueAsInt :
        ?dflt : int *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> int
override ValueAsInt :
        ?dflt : int *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> int
abstract ValueAsInt :
        ?dflt : int *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> int
override ValueAsInt :
        ?dflt : int *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> int

Parameters

dflt (Optional)
Type: Online System Int32
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Int32

Implements

IConfigNode ValueAsInt(Int32, Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsLong Method

ConfigNode ValueAsLong Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long ValueAsLong(
    long dflt = 0,
    bool verbatim = false
)
public long ValueAsLong(
    long dflt = 0,
    bool verbatim = false
)
Public Function ValueAsLong (
    Optional dflt As Long = 0,
    Optional verbatim As Boolean = false
) As Long
Public Function ValueAsLong (
    Optional dflt As Long = 0,
    Optional verbatim As Boolean = false
) As Long
public:
virtual long long ValueAsLong(
    long long dflt = 0,
    bool verbatim = false
) sealed
public:
virtual long long ValueAsLong(
    long long dflt = 0,
    bool verbatim = false
) sealed
abstract ValueAsLong :
        ?dflt : int64 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> int64
override ValueAsLong :
        ?dflt : int64 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> int64
abstract ValueAsLong :
        ?dflt : int64 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> int64
override ValueAsLong :
        ?dflt : int64 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> int64

Parameters

dflt (Optional)
Type: Online System Int64
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Int64

Implements

IConfigNode ValueAsLong(Int64, Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsNullableBool Method

ConfigNode ValueAsNullableBool Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<bool> ValueAsNullableBool(
    Nullable<bool> dflt = false,
    bool verbatim = false
)
public Nullable<bool> ValueAsNullableBool(
    Nullable<bool> dflt = false,
    bool verbatim = false
)
Public Function ValueAsNullableBool (
    Optional dflt As Nullable(Of Boolean) = false,
    Optional verbatim As Boolean = false
) As Nullable(Of Boolean)
Public Function ValueAsNullableBool (
    Optional dflt As Nullable(Of Boolean) = false,
    Optional verbatim As Boolean = false
) As Nullable(Of Boolean)
public:
virtual Nullable<bool> ValueAsNullableBool(
    Nullable<bool> dflt = false,
    bool verbatim = false
) sealed
public:
virtual Nullable<bool> ValueAsNullableBool(
    Nullable<bool> dflt = false,
    bool verbatim = false
) sealed
abstract ValueAsNullableBool :
        ?dflt : Nullable<bool> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt false
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<bool>
override ValueAsNullableBool :
        ?dflt : Nullable<bool> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt false
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<bool>
abstract ValueAsNullableBool :
        ?dflt : Nullable<bool> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt false
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<bool>
override ValueAsNullableBool :
        ?dflt : Nullable<bool> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt false
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<bool>

Parameters

dflt (Optional)
Type: Online System Nullable Online Boolean
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online Boolean

Implements

IConfigNode ValueAsNullableBool(Nullable Boolean , Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsNullableByte Method

ConfigNode ValueAsNullableByte Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<byte> ValueAsNullableByte(
    Nullable<byte> dflt = 0,
    bool verbatim = false
)
public Nullable<byte> ValueAsNullableByte(
    Nullable<byte> dflt = 0,
    bool verbatim = false
)
Public Function ValueAsNullableByte (
    Optional dflt As Nullable(Of Byte) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of Byte)
Public Function ValueAsNullableByte (
    Optional dflt As Nullable(Of Byte) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of Byte)
public:
virtual Nullable<unsigned char> ValueAsNullableByte(
    Nullable<unsigned char> dflt = 0,
    bool verbatim = false
) sealed
public:
virtual Nullable<unsigned char> ValueAsNullableByte(
    Nullable<unsigned char> dflt = 0,
    bool verbatim = false
) sealed
abstract ValueAsNullableByte :
        ?dflt : Nullable<byte> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<byte>
override ValueAsNullableByte :
        ?dflt : Nullable<byte> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<byte>
abstract ValueAsNullableByte :
        ?dflt : Nullable<byte> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<byte>
override ValueAsNullableByte :
        ?dflt : Nullable<byte> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<byte>

Parameters

dflt (Optional)
Type: Online System Nullable Online Byte
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online Byte

Implements

IConfigNode ValueAsNullableByte(Nullable Byte , Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsNullableDateTime Method

ConfigNode ValueAsNullableDateTime Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> ValueAsNullableDateTime(
    Nullable<DateTime> dflt = null,
    bool verbatim = false
)
public Nullable<DateTime> ValueAsNullableDateTime(
    Nullable<DateTime> dflt = null,
    bool verbatim = false
)
Public Function ValueAsNullableDateTime (
    Optional dflt As Nullable(Of DateTime) = Nothing,
    Optional verbatim As Boolean = false
) As Nullable(Of DateTime)
Public Function ValueAsNullableDateTime (
    Optional dflt As Nullable(Of DateTime) = Nothing,
    Optional verbatim As Boolean = false
) As Nullable(Of DateTime)
public:
virtual Nullable<DateTime> ValueAsNullableDateTime(
    Nullable<DateTime> dflt = nullptr,
    bool verbatim = false
) sealed
public:
virtual Nullable<DateTime> ValueAsNullableDateTime(
    Nullable<DateTime> dflt = nullptr,
    bool verbatim = false
) sealed
abstract ValueAsNullableDateTime :
        ?dflt : Nullable<DateTime> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<DateTime>
override ValueAsNullableDateTime :
        ?dflt : Nullable<DateTime> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<DateTime>
abstract ValueAsNullableDateTime :
        ?dflt : Nullable<DateTime> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<DateTime>
override ValueAsNullableDateTime :
        ?dflt : Nullable<DateTime> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<DateTime>

Parameters

dflt (Optional)
Type: Online System Nullable Online DateTime
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online DateTime

Implements

IConfigNode ValueAsNullableDateTime(Nullable DateTime , Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsNullableDecimal Method

ConfigNode ValueAsNullableDecimal Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<decimal> ValueAsNullableDecimal(
    [OptionalAttribute] Nullable<decimal> dflt,
    bool verbatim = false
)
public Nullable<decimal> ValueAsNullableDecimal(
    [OptionalAttribute] Nullable<decimal> dflt,
    bool verbatim = false
)
Public Function ValueAsNullableDecimal (
    <OptionalAttribute> dflt As Nullable(Of Decimal),
    Optional verbatim As Boolean = false
) As Nullable(Of Decimal)
Public Function ValueAsNullableDecimal (
    <OptionalAttribute> dflt As Nullable(Of Decimal),
    Optional verbatim As Boolean = false
) As Nullable(Of Decimal)
public:
virtual Nullable<Decimal> ValueAsNullableDecimal(
    [OptionalAttribute] Nullable<Decimal> dflt,
    bool verbatim = false
) sealed
public:
virtual Nullable<Decimal> ValueAsNullableDecimal(
    [OptionalAttribute] Nullable<Decimal> dflt,
    bool verbatim = false
) sealed
abstract ValueAsNullableDecimal :
        [<OptionalAttribute>] dflt : Nullable<decimal> *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<decimal>
override ValueAsNullableDecimal :
        [<OptionalAttribute>] dflt : Nullable<decimal> *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<decimal>
abstract ValueAsNullableDecimal :
        [<OptionalAttribute>] dflt : Nullable<decimal> *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<decimal>
override ValueAsNullableDecimal :
        [<OptionalAttribute>] dflt : Nullable<decimal> *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<decimal>

Parameters

dflt (Optional)
Type: Online System Nullable Online Decimal
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online Decimal

Implements

IConfigNode ValueAsNullableDecimal(Nullable Decimal , Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsNullableDouble Method

ConfigNode ValueAsNullableDouble Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<double> ValueAsNullableDouble(
    Nullable<double> dflt = 0,
    bool verbatim = false
)
public Nullable<double> ValueAsNullableDouble(
    Nullable<double> dflt = 0,
    bool verbatim = false
)
Public Function ValueAsNullableDouble (
    Optional dflt As Nullable(Of Double) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of Double)
Public Function ValueAsNullableDouble (
    Optional dflt As Nullable(Of Double) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of Double)
public:
virtual Nullable<double> ValueAsNullableDouble(
    Nullable<double> dflt = 0,
    bool verbatim = false
) sealed
public:
virtual Nullable<double> ValueAsNullableDouble(
    Nullable<double> dflt = 0,
    bool verbatim = false
) sealed
abstract ValueAsNullableDouble :
        ?dflt : Nullable<float> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<float>
override ValueAsNullableDouble :
        ?dflt : Nullable<float> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<float>
abstract ValueAsNullableDouble :
        ?dflt : Nullable<float> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<float>
override ValueAsNullableDouble :
        ?dflt : Nullable<float> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<float>

Parameters

dflt (Optional)
Type: Online System Nullable Online Double
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online Double

Implements

IConfigNode ValueAsNullableDouble(Nullable Double , Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsNullableEnum(TEnum) Method

ConfigNode ValueAsNullableEnum TEnum Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<TEnum> ValueAsNullableEnum<TEnum>(
    Nullable<TEnum> dflt = null,
    bool verbatim = false
)
where TEnum : struct, new()
public Nullable<TEnum> ValueAsNullableEnum<TEnum>(
    Nullable<TEnum> dflt = null,
    bool verbatim = false
)
where TEnum : struct, new()
Public Function ValueAsNullableEnum(Of TEnum As {Structure, New}) (
    Optional dflt As Nullable(Of TEnum) = Nothing,
    Optional verbatim As Boolean = false
) As Nullable(Of TEnum)
Public Function ValueAsNullableEnum(Of TEnum As {Structure, New}) (
    Optional dflt As Nullable(Of TEnum) = Nothing,
    Optional verbatim As Boolean = false
) As Nullable(Of TEnum)
public:
generic<typename TEnum>
where TEnum : value class, gcnew()
virtual Nullable<TEnum> ValueAsNullableEnum(
    Nullable<TEnum> dflt = nullptr,
    bool verbatim = false
) sealed
public:
generic<typename TEnum>
where TEnum : value class, gcnew()
virtual Nullable<TEnum> ValueAsNullableEnum(
    Nullable<TEnum> dflt = nullptr,
    bool verbatim = false
) sealed
abstract ValueAsNullableEnum :
        ?dflt : Nullable<'TEnum> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<'TEnum>  when 'TEnum : struct, new()
override ValueAsNullableEnum :
        ?dflt : Nullable<'TEnum> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<'TEnum>  when 'TEnum : struct, new()
abstract ValueAsNullableEnum :
        ?dflt : Nullable<'TEnum> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<'TEnum>  when 'TEnum : struct, new()
override ValueAsNullableEnum :
        ?dflt : Nullable<'TEnum> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<'TEnum>  when 'TEnum : struct, new()

Parameters

dflt (Optional)
Type: Online System Nullable TEnum
verbatim (Optional)
Type: Online System Boolean
Type Parameters
TEnum

Return Value

Type: Online Nullable TEnum

Implements

IConfigNode ValueAsNullableEnum TEnum (Nullable TEnum , Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsNullableFloat Method

ConfigNode ValueAsNullableFloat Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<float> ValueAsNullableFloat(
    Nullable<float> dflt = 0f,
    bool verbatim = false
)
public Nullable<float> ValueAsNullableFloat(
    Nullable<float> dflt = 0f,
    bool verbatim = false
)
Public Function ValueAsNullableFloat (
    Optional dflt As Nullable(Of Single) = 0F,
    Optional verbatim As Boolean = false
) As Nullable(Of Single)
Public Function ValueAsNullableFloat (
    Optional dflt As Nullable(Of Single) = 0F,
    Optional verbatim As Boolean = false
) As Nullable(Of Single)
public:
virtual Nullable<float> ValueAsNullableFloat(
    Nullable<float> dflt = 0f,
    bool verbatim = false
) sealed
public:
virtual Nullable<float> ValueAsNullableFloat(
    Nullable<float> dflt = 0f,
    bool verbatim = false
) sealed
abstract ValueAsNullableFloat :
        ?dflt : Nullable<float32> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0f
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<float32>
override ValueAsNullableFloat :
        ?dflt : Nullable<float32> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0f
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<float32>
abstract ValueAsNullableFloat :
        ?dflt : Nullable<float32> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0f
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<float32>
override ValueAsNullableFloat :
        ?dflt : Nullable<float32> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0f
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<float32>

Parameters

dflt (Optional)
Type: Online System Nullable Online Single
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online Single

Implements

IConfigNode ValueAsNullableFloat(Nullable Single , Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsNullableGDID Method

ConfigNode ValueAsNullableGDID Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<GDID> ValueAsNullableGDID(
    Nullable<GDID> dflt = null,
    bool verbatim = false
)
public Nullable<GDID> ValueAsNullableGDID(
    Nullable<GDID> dflt = null,
    bool verbatim = false
)
Public Function ValueAsNullableGDID (
    Optional dflt As Nullable(Of GDID) = Nothing,
    Optional verbatim As Boolean = false
) As Nullable(Of GDID)
Public Function ValueAsNullableGDID (
    Optional dflt As Nullable(Of GDID) = Nothing,
    Optional verbatim As Boolean = false
) As Nullable(Of GDID)
public:
virtual Nullable<GDID> ValueAsNullableGDID(
    Nullable<GDID> dflt = nullptr,
    bool verbatim = false
) sealed
public:
virtual Nullable<GDID> ValueAsNullableGDID(
    Nullable<GDID> dflt = nullptr,
    bool verbatim = false
) sealed
abstract ValueAsNullableGDID :
        ?dflt : Nullable<GDID> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<GDID>
override ValueAsNullableGDID :
        ?dflt : Nullable<GDID> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<GDID>
abstract ValueAsNullableGDID :
        ?dflt : Nullable<GDID> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<GDID>
override ValueAsNullableGDID :
        ?dflt : Nullable<GDID> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<GDID>

Parameters

dflt (Optional)
Type: Online System Nullable GDID
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable GDID

Implements

IConfigNode ValueAsNullableGDID(Nullable GDID , Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsNullableGUID Method

ConfigNode ValueAsNullableGUID Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<Guid> ValueAsNullableGUID(
    Nullable<Guid> dflt = null,
    bool verbatim = false
)
public Nullable<Guid> ValueAsNullableGUID(
    Nullable<Guid> dflt = null,
    bool verbatim = false
)
Public Function ValueAsNullableGUID (
    Optional dflt As Nullable(Of Guid) = Nothing,
    Optional verbatim As Boolean = false
) As Nullable(Of Guid)
Public Function ValueAsNullableGUID (
    Optional dflt As Nullable(Of Guid) = Nothing,
    Optional verbatim As Boolean = false
) As Nullable(Of Guid)
public:
virtual Nullable<Guid> ValueAsNullableGUID(
    Nullable<Guid> dflt = nullptr,
    bool verbatim = false
) sealed
public:
virtual Nullable<Guid> ValueAsNullableGUID(
    Nullable<Guid> dflt = nullptr,
    bool verbatim = false
) sealed
abstract ValueAsNullableGUID :
        ?dflt : Nullable<Guid> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<Guid>
override ValueAsNullableGUID :
        ?dflt : Nullable<Guid> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<Guid>
abstract ValueAsNullableGUID :
        ?dflt : Nullable<Guid> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<Guid>
override ValueAsNullableGUID :
        ?dflt : Nullable<Guid> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<Guid>

Parameters

dflt (Optional)
Type: Online System Nullable Online Guid
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online Guid

Implements

IConfigNode ValueAsNullableGUID(Nullable Guid , Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsNullableInt Method

ConfigNode ValueAsNullableInt Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<int> ValueAsNullableInt(
    Nullable<int> dflt = 0,
    bool verbatim = false
)
public Nullable<int> ValueAsNullableInt(
    Nullable<int> dflt = 0,
    bool verbatim = false
)
Public Function ValueAsNullableInt (
    Optional dflt As Nullable(Of Integer) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of Integer)
Public Function ValueAsNullableInt (
    Optional dflt As Nullable(Of Integer) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of Integer)
public:
virtual Nullable<int> ValueAsNullableInt(
    Nullable<int> dflt = 0,
    bool verbatim = false
) sealed
public:
virtual Nullable<int> ValueAsNullableInt(
    Nullable<int> dflt = 0,
    bool verbatim = false
) sealed
abstract ValueAsNullableInt :
        ?dflt : Nullable<int> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<int>
override ValueAsNullableInt :
        ?dflt : Nullable<int> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<int>
abstract ValueAsNullableInt :
        ?dflt : Nullable<int> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<int>
override ValueAsNullableInt :
        ?dflt : Nullable<int> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<int>

Parameters

dflt (Optional)
Type: Online System Nullable Online Int32
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online Int32

Implements

IConfigNode ValueAsNullableInt(Nullable Int32 , Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsNullableLong Method

ConfigNode ValueAsNullableLong Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<long> ValueAsNullableLong(
    Nullable<long> dflt = 0,
    bool verbatim = false
)
public Nullable<long> ValueAsNullableLong(
    Nullable<long> dflt = 0,
    bool verbatim = false
)
Public Function ValueAsNullableLong (
    Optional dflt As Nullable(Of Long) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of Long)
Public Function ValueAsNullableLong (
    Optional dflt As Nullable(Of Long) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of Long)
public:
virtual Nullable<long long> ValueAsNullableLong(
    Nullable<long long> dflt = 0,
    bool verbatim = false
) sealed
public:
virtual Nullable<long long> ValueAsNullableLong(
    Nullable<long long> dflt = 0,
    bool verbatim = false
) sealed
abstract ValueAsNullableLong :
        ?dflt : Nullable<int64> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<int64>
override ValueAsNullableLong :
        ?dflt : Nullable<int64> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<int64>
abstract ValueAsNullableLong :
        ?dflt : Nullable<int64> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<int64>
override ValueAsNullableLong :
        ?dflt : Nullable<int64> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<int64>

Parameters

dflt (Optional)
Type: Online System Nullable Online Int64
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online Int64

Implements

IConfigNode ValueAsNullableLong(Nullable Int64 , Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsNullableSByte Method

ConfigNode ValueAsNullableSByte Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<sbyte> ValueAsNullableSByte(
    Nullable<sbyte> dflt = 0,
    bool verbatim = false
)
public Nullable<sbyte> ValueAsNullableSByte(
    Nullable<sbyte> dflt = 0,
    bool verbatim = false
)
Public Function ValueAsNullableSByte (
    Optional dflt As Nullable(Of SByte) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of SByte)
Public Function ValueAsNullableSByte (
    Optional dflt As Nullable(Of SByte) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of SByte)
public:
virtual Nullable<signed char> ValueAsNullableSByte(
    Nullable<signed char> dflt = 0,
    bool verbatim = false
) sealed
public:
virtual Nullable<signed char> ValueAsNullableSByte(
    Nullable<signed char> dflt = 0,
    bool verbatim = false
) sealed
abstract ValueAsNullableSByte :
        ?dflt : Nullable<sbyte> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<sbyte>
override ValueAsNullableSByte :
        ?dflt : Nullable<sbyte> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<sbyte>
abstract ValueAsNullableSByte :
        ?dflt : Nullable<sbyte> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<sbyte>
override ValueAsNullableSByte :
        ?dflt : Nullable<sbyte> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<sbyte>

Parameters

dflt (Optional)
Type: Online System Nullable Online SByte
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online SByte

Implements

IConfigNode ValueAsNullableSByte(Nullable SByte , Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsNullableShort Method

ConfigNode ValueAsNullableShort Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<short> ValueAsNullableShort(
    Nullable<short> dflt = 0,
    bool verbatim = false
)
public Nullable<short> ValueAsNullableShort(
    Nullable<short> dflt = 0,
    bool verbatim = false
)
Public Function ValueAsNullableShort (
    Optional dflt As Nullable(Of Short) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of Short)
Public Function ValueAsNullableShort (
    Optional dflt As Nullable(Of Short) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of Short)
public:
virtual Nullable<short> ValueAsNullableShort(
    Nullable<short> dflt = 0,
    bool verbatim = false
) sealed
public:
virtual Nullable<short> ValueAsNullableShort(
    Nullable<short> dflt = 0,
    bool verbatim = false
) sealed
abstract ValueAsNullableShort :
        ?dflt : Nullable<int16> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<int16>
override ValueAsNullableShort :
        ?dflt : Nullable<int16> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<int16>
abstract ValueAsNullableShort :
        ?dflt : Nullable<int16> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<int16>
override ValueAsNullableShort :
        ?dflt : Nullable<int16> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<int16>

Parameters

dflt (Optional)
Type: Online System Nullable Online Int16
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online Int16

Implements

IConfigNode ValueAsNullableShort(Nullable Int16 , Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsNullableTimeSpan Method

ConfigNode ValueAsNullableTimeSpan Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<TimeSpan> ValueAsNullableTimeSpan(
    Nullable<TimeSpan> dflt = null,
    bool verbatim = false
)
public Nullable<TimeSpan> ValueAsNullableTimeSpan(
    Nullable<TimeSpan> dflt = null,
    bool verbatim = false
)
Public Function ValueAsNullableTimeSpan (
    Optional dflt As Nullable(Of TimeSpan) = Nothing,
    Optional verbatim As Boolean = false
) As Nullable(Of TimeSpan)
Public Function ValueAsNullableTimeSpan (
    Optional dflt As Nullable(Of TimeSpan) = Nothing,
    Optional verbatim As Boolean = false
) As Nullable(Of TimeSpan)
public:
virtual Nullable<TimeSpan> ValueAsNullableTimeSpan(
    Nullable<TimeSpan> dflt = nullptr,
    bool verbatim = false
) sealed
public:
virtual Nullable<TimeSpan> ValueAsNullableTimeSpan(
    Nullable<TimeSpan> dflt = nullptr,
    bool verbatim = false
) sealed
abstract ValueAsNullableTimeSpan :
        ?dflt : Nullable<TimeSpan> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<TimeSpan>
override ValueAsNullableTimeSpan :
        ?dflt : Nullable<TimeSpan> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<TimeSpan>
abstract ValueAsNullableTimeSpan :
        ?dflt : Nullable<TimeSpan> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<TimeSpan>
override ValueAsNullableTimeSpan :
        ?dflt : Nullable<TimeSpan> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<TimeSpan>

Parameters

dflt (Optional)
Type: Online System Nullable Online TimeSpan
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online TimeSpan

Implements

IConfigNode ValueAsNullableTimeSpan(Nullable TimeSpan , Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsNullableUInt Method

ConfigNode ValueAsNullableUInt Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<uint> ValueAsNullableUInt(
    Nullable<uint> dflt = 0,
    bool verbatim = false
)
public Nullable<uint> ValueAsNullableUInt(
    Nullable<uint> dflt = 0,
    bool verbatim = false
)
Public Function ValueAsNullableUInt (
    Optional dflt As Nullable(Of UInteger) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of UInteger)
Public Function ValueAsNullableUInt (
    Optional dflt As Nullable(Of UInteger) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of UInteger)
public:
virtual Nullable<unsigned int> ValueAsNullableUInt(
    Nullable<unsigned int> dflt = 0,
    bool verbatim = false
) sealed
public:
virtual Nullable<unsigned int> ValueAsNullableUInt(
    Nullable<unsigned int> dflt = 0,
    bool verbatim = false
) sealed
abstract ValueAsNullableUInt :
        ?dflt : Nullable<uint32> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<uint32>
override ValueAsNullableUInt :
        ?dflt : Nullable<uint32> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<uint32>
abstract ValueAsNullableUInt :
        ?dflt : Nullable<uint32> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<uint32>
override ValueAsNullableUInt :
        ?dflt : Nullable<uint32> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<uint32>

Parameters

dflt (Optional)
Type: Online System Nullable Online UInt32
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online UInt32

Implements

IConfigNode ValueAsNullableUInt(Nullable UInt32 , Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsNullableULong Method

ConfigNode ValueAsNullableULong Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<ulong> ValueAsNullableULong(
    Nullable<ulong> dflt = 0,
    bool verbatim = false
)
public Nullable<ulong> ValueAsNullableULong(
    Nullable<ulong> dflt = 0,
    bool verbatim = false
)
Public Function ValueAsNullableULong (
    Optional dflt As Nullable(Of ULong) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of ULong)
Public Function ValueAsNullableULong (
    Optional dflt As Nullable(Of ULong) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of ULong)
public:
virtual Nullable<unsigned long long> ValueAsNullableULong(
    Nullable<unsigned long long> dflt = 0,
    bool verbatim = false
) sealed
public:
virtual Nullable<unsigned long long> ValueAsNullableULong(
    Nullable<unsigned long long> dflt = 0,
    bool verbatim = false
) sealed
abstract ValueAsNullableULong :
        ?dflt : Nullable<uint64> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<uint64>
override ValueAsNullableULong :
        ?dflt : Nullable<uint64> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<uint64>
abstract ValueAsNullableULong :
        ?dflt : Nullable<uint64> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<uint64>
override ValueAsNullableULong :
        ?dflt : Nullable<uint64> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<uint64>

Parameters

dflt (Optional)
Type: Online System Nullable Online UInt64
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online UInt64

Implements

IConfigNode ValueAsNullableULong(Nullable UInt64 , Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsNullableUShort Method

ConfigNode ValueAsNullableUShort Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<ushort> ValueAsNullableUShort(
    Nullable<ushort> dflt = 0,
    bool verbatim = false
)
public Nullable<ushort> ValueAsNullableUShort(
    Nullable<ushort> dflt = 0,
    bool verbatim = false
)
Public Function ValueAsNullableUShort (
    Optional dflt As Nullable(Of UShort) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of UShort)
Public Function ValueAsNullableUShort (
    Optional dflt As Nullable(Of UShort) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of UShort)
public:
virtual Nullable<unsigned short> ValueAsNullableUShort(
    Nullable<unsigned short> dflt = 0,
    bool verbatim = false
) sealed
public:
virtual Nullable<unsigned short> ValueAsNullableUShort(
    Nullable<unsigned short> dflt = 0,
    bool verbatim = false
) sealed
abstract ValueAsNullableUShort :
        ?dflt : Nullable<uint16> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<uint16>
override ValueAsNullableUShort :
        ?dflt : Nullable<uint16> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<uint16>
abstract ValueAsNullableUShort :
        ?dflt : Nullable<uint16> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<uint16>
override ValueAsNullableUShort :
        ?dflt : Nullable<uint16> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<uint16>

Parameters

dflt (Optional)
Type: Online System Nullable Online UInt16
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online UInt16

Implements

IConfigNode ValueAsNullableUShort(Nullable UInt16 , Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsSByte Method

ConfigNode ValueAsSByte Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sbyte ValueAsSByte(
    sbyte dflt = 0,
    bool verbatim = false
)
public sbyte ValueAsSByte(
    sbyte dflt = 0,
    bool verbatim = false
)
Public Function ValueAsSByte (
    Optional dflt As SByte = 0,
    Optional verbatim As Boolean = false
) As SByte
Public Function ValueAsSByte (
    Optional dflt As SByte = 0,
    Optional verbatim As Boolean = false
) As SByte
public:
virtual signed char ValueAsSByte(
    signed char dflt = 0,
    bool verbatim = false
) sealed
public:
virtual signed char ValueAsSByte(
    signed char dflt = 0,
    bool verbatim = false
) sealed
abstract ValueAsSByte :
        ?dflt : sbyte *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> sbyte
override ValueAsSByte :
        ?dflt : sbyte *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> sbyte
abstract ValueAsSByte :
        ?dflt : sbyte *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> sbyte
override ValueAsSByte :
        ?dflt : sbyte *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> sbyte

Parameters

dflt (Optional)
Type: Online System SByte
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online SByte

Implements

IConfigNode ValueAsSByte(SByte, Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsShort Method

ConfigNode ValueAsShort Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public short ValueAsShort(
    short dflt = 0,
    bool verbatim = false
)
public short ValueAsShort(
    short dflt = 0,
    bool verbatim = false
)
Public Function ValueAsShort (
    Optional dflt As Short = 0,
    Optional verbatim As Boolean = false
) As Short
Public Function ValueAsShort (
    Optional dflt As Short = 0,
    Optional verbatim As Boolean = false
) As Short
public:
virtual short ValueAsShort(
    short dflt = 0,
    bool verbatim = false
) sealed
public:
virtual short ValueAsShort(
    short dflt = 0,
    bool verbatim = false
) sealed
abstract ValueAsShort :
        ?dflt : int16 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> int16
override ValueAsShort :
        ?dflt : int16 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> int16
abstract ValueAsShort :
        ?dflt : int16 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> int16
override ValueAsShort :
        ?dflt : int16 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> int16

Parameters

dflt (Optional)
Type: Online System Int16
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Int16

Implements

IConfigNode ValueAsShort(Int16, Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsString Method

ConfigNode ValueAsString Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ValueAsString(
    string dflt = null,
    bool verbatim = false
)
public string ValueAsString(
    string dflt = null,
    bool verbatim = false
)
Public Function ValueAsString (
    Optional dflt As String = Nothing,
    Optional verbatim As Boolean = false
) As String
Public Function ValueAsString (
    Optional dflt As String = Nothing,
    Optional verbatim As Boolean = false
) As String
public:
virtual String^ ValueAsString(
    String^ dflt = nullptr,
    bool verbatim = false
) sealed
public:
virtual String^ ValueAsString(
    String^ dflt = nullptr,
    bool verbatim = false
) sealed
abstract ValueAsString :
        ?dflt : string *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> string
override ValueAsString :
        ?dflt : string *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> string
abstract ValueAsString :
        ?dflt : string *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> string
override ValueAsString :
        ?dflt : string *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> string

Parameters

dflt (Optional)
Type: Online System String
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online String

Implements

IConfigNode ValueAsString(String, Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsTimeSpan Method

ConfigNode ValueAsTimeSpan Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpan ValueAsTimeSpan(
    TimeSpan dflt,
    bool verbatim = false
)
public TimeSpan ValueAsTimeSpan(
    TimeSpan dflt,
    bool verbatim = false
)
Public Function ValueAsTimeSpan (
    dflt As TimeSpan,
    Optional verbatim As Boolean = false
) As TimeSpan
Public Function ValueAsTimeSpan (
    dflt As TimeSpan,
    Optional verbatim As Boolean = false
) As TimeSpan
public:
virtual TimeSpan ValueAsTimeSpan(
    TimeSpan dflt,
    bool verbatim = false
) sealed
public:
virtual TimeSpan ValueAsTimeSpan(
    TimeSpan dflt,
    bool verbatim = false
) sealed
abstract ValueAsTimeSpan :
        dflt : TimeSpan *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> TimeSpan
override ValueAsTimeSpan :
        dflt : TimeSpan *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> TimeSpan
abstract ValueAsTimeSpan :
        dflt : TimeSpan *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> TimeSpan
override ValueAsTimeSpan :
        dflt : TimeSpan *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> TimeSpan

Parameters

dflt
Type: Online System TimeSpan
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online TimeSpan

Implements

IConfigNode ValueAsTimeSpan(TimeSpan, Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsType Method

ConfigNode ValueAsType Method NFX Class Library

Tries to get value as specified type or throws if it can not be converted

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object ValueAsType(
    Type tp,
    bool verbatim = false,
    bool strict = true
)
public Object ValueAsType(
    Type tp,
    bool verbatim = false,
    bool strict = true
)
Public Function ValueAsType (
    tp As Type,
    Optional verbatim As Boolean = false,
    Optional strict As Boolean = true
) As Object
Public Function ValueAsType (
    tp As Type,
    Optional verbatim As Boolean = false,
    Optional strict As Boolean = true
) As Object
public:
virtual Object^ ValueAsType(
    Type^ tp,
    bool verbatim = false,
    bool strict = true
) sealed
public:
virtual Object^ ValueAsType(
    Type^ tp,
    bool verbatim = false,
    bool strict = true
) sealed
abstract ValueAsType :
        tp : Type *
        ?verbatim : bool *
        ?strict : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
        let _strict = defaultArg strict true
*)
-> Object
override ValueAsType :
        tp : Type *
        ?verbatim : bool *
        ?strict : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
        let _strict = defaultArg strict true
*)
-> Object
abstract ValueAsType :
        tp : Type *
        ?verbatim : bool *
        ?strict : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
        let _strict = defaultArg strict true
*)
-> Object
override ValueAsType :
        tp : Type *
        ?verbatim : bool *
        ?strict : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
        let _strict = defaultArg strict true
*)
-> Object

Parameters

tp
Type: Online System Type
verbatim (Optional)
Type: Online System Boolean
strict (Optional)
Type: Online System Boolean

Return Value

Type: Online Object

Implements

IConfigNode ValueAsType(Type, Boolean, Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsUInt Method

ConfigNode ValueAsUInt Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint ValueAsUInt(
    uint dflt = 0,
    bool verbatim = false
)
public uint ValueAsUInt(
    uint dflt = 0,
    bool verbatim = false
)
Public Function ValueAsUInt (
    Optional dflt As UInteger = 0,
    Optional verbatim As Boolean = false
) As UInteger
Public Function ValueAsUInt (
    Optional dflt As UInteger = 0,
    Optional verbatim As Boolean = false
) As UInteger
public:
virtual unsigned int ValueAsUInt(
    unsigned int dflt = 0,
    bool verbatim = false
) sealed
public:
virtual unsigned int ValueAsUInt(
    unsigned int dflt = 0,
    bool verbatim = false
) sealed
abstract ValueAsUInt :
        ?dflt : uint32 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> uint32
override ValueAsUInt :
        ?dflt : uint32 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> uint32
abstract ValueAsUInt :
        ?dflt : uint32 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> uint32
override ValueAsUInt :
        ?dflt : uint32 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> uint32

Parameters

dflt (Optional)
Type: Online System UInt32
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online UInt32

Implements

IConfigNode ValueAsUInt(UInt32, Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsULong Method

ConfigNode ValueAsULong Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong ValueAsULong(
    ulong dflt = 0,
    bool verbatim = false
)
public ulong ValueAsULong(
    ulong dflt = 0,
    bool verbatim = false
)
Public Function ValueAsULong (
    Optional dflt As ULong = 0,
    Optional verbatim As Boolean = false
) As ULong
Public Function ValueAsULong (
    Optional dflt As ULong = 0,
    Optional verbatim As Boolean = false
) As ULong
public:
virtual unsigned long long ValueAsULong(
    unsigned long long dflt = 0,
    bool verbatim = false
) sealed
public:
virtual unsigned long long ValueAsULong(
    unsigned long long dflt = 0,
    bool verbatim = false
) sealed
abstract ValueAsULong :
        ?dflt : uint64 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> uint64
override ValueAsULong :
        ?dflt : uint64 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> uint64
abstract ValueAsULong :
        ?dflt : uint64 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> uint64
override ValueAsULong :
        ?dflt : uint64 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> uint64

Parameters

dflt (Optional)
Type: Online System UInt64
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online UInt64

Implements

IConfigNode ValueAsULong(UInt64, Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.ValueAsUShort Method

ConfigNode ValueAsUShort Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ushort ValueAsUShort(
    ushort dflt = 0,
    bool verbatim = false
)
public ushort ValueAsUShort(
    ushort dflt = 0,
    bool verbatim = false
)
Public Function ValueAsUShort (
    Optional dflt As UShort = 0,
    Optional verbatim As Boolean = false
) As UShort
Public Function ValueAsUShort (
    Optional dflt As UShort = 0,
    Optional verbatim As Boolean = false
) As UShort
public:
virtual unsigned short ValueAsUShort(
    unsigned short dflt = 0,
    bool verbatim = false
) sealed
public:
virtual unsigned short ValueAsUShort(
    unsigned short dflt = 0,
    bool verbatim = false
) sealed
abstract ValueAsUShort :
        ?dflt : uint16 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> uint16
override ValueAsUShort :
        ?dflt : uint16 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> uint16
abstract ValueAsUShort :
        ?dflt : uint16 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> uint16
override ValueAsUShort :
        ?dflt : uint16 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> uint16

Parameters

dflt (Optional)
Type: Online System UInt16
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online UInt16

Implements

IConfigNode ValueAsUShort(UInt16, Boolean)
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode Properties

ConfigNode Properties NFX Class Library

The ConfigNode type exposes the following members.
Properties
 | Name | Description
Public property | Configuration | References configuration this node is under
Public property | EvaluatedValue | Returns null or value of this node with all variables evaluated
Public property | Exists | Determines whether this node really exists in configuration or is just a sentinel empty node
Public property | Modified | Indicates whether a node was modified
Public property | Name | Retrieves node name
Public property | Parent | References parent node or Empty if this node has no parent
Public property | RootPath | Returns path from root to this node
Public property | Value | Retrieves node value or null. The value getter performs evaluation of variables, while setter sets the value verbatim
Public property | VerbatimValue | Returns verbatim (without variable evaluation) node value or null
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IConfigNode Parent | References parent node
Explicit interface implemetation | IConfigNode RootPath |
Back to Top
See Also
ConfigNode Class
NFX.Environment Namespace


ConfigNode.Configuration Property

ConfigNode Configuration Property NFX Class Library

References configuration this node is under

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Configuration Configuration { get; }
public Configuration Configuration { get; }
Public ReadOnly Property Configuration As Configuration
    Get
Public ReadOnly Property Configuration As Configuration
    Get
public:
virtual property Configuration^ Configuration {
    Configuration^ get () sealed;
}
public:
virtual property Configuration^ Configuration {
    Configuration^ get () sealed;
}
abstract Configuration : Configuration with get
override Configuration : Configuration with get
abstract Configuration : Configuration with get
override Configuration : Configuration with get

Property Value

Type: Configuration

Implements

IConfigNode Configuration
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.EvaluatedValue Property

ConfigNode EvaluatedValue Property NFX Class Library

Returns null or value of this node with all variables evaluated

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string EvaluatedValue { get; }
public string EvaluatedValue { get; }
Public ReadOnly Property EvaluatedValue As String
    Get
Public ReadOnly Property EvaluatedValue As String
    Get
public:
virtual property String^ EvaluatedValue {
    String^ get () sealed;
}
public:
virtual property String^ EvaluatedValue {
    String^ get () sealed;
}
abstract EvaluatedValue : string with get
override EvaluatedValue : string with get
abstract EvaluatedValue : string with get
override EvaluatedValue : string with get

Property Value

Type: Online String

Implements

IConfigNode EvaluatedValue
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.Exists Property

ConfigNode Exists Property NFX Class Library

Determines whether this node really exists in configuration or is just a sentinel empty node

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Exists { get; }
public bool Exists { get; }
Public ReadOnly Property Exists As Boolean
    Get
Public ReadOnly Property Exists As Boolean
    Get
public:
virtual property bool Exists {
    bool get () sealed;
}
public:
virtual property bool Exists {
    bool get () sealed;
}
abstract Exists : bool with get
override Exists : bool with get
abstract Exists : bool with get
override Exists : bool with get

Property Value

Type: Online Boolean

Implements

IConfigNode Exists
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.IConfigNode.Parent Property

ConfigNode IConfigNode Parent Property NFX Class Library

References parent node

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IConfigSectionNode IConfigNode.Parent { get; }
IConfigSectionNode IConfigNode.Parent { get; }
Private ReadOnly Property Parent As IConfigSectionNode
    Implements IConfigNode.Parent
    Get
Private ReadOnly Property Parent As IConfigSectionNode
    Implements IConfigNode.Parent
    Get
private:
virtual property IConfigSectionNode^ Parent {
    IConfigSectionNode^ get () sealed = IConfigNode::Parent::get;
}
private:
virtual property IConfigSectionNode^ Parent {
    IConfigSectionNode^ get () sealed = IConfigNode::Parent::get;
}
private abstract Parent : IConfigSectionNode with get
private override Parent : IConfigSectionNode with get
private abstract Parent : IConfigSectionNode with get
private override Parent : IConfigSectionNode with get

Property Value

Type: IConfigSectionNode

Implements

IConfigNode Parent
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.IConfigNode.RootPath Property

ConfigNode IConfigNode RootPath Property NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string IConfigNode.RootPath { get; }
string IConfigNode.RootPath { get; }
Private ReadOnly Property RootPath As String
    Implements IConfigNode.RootPath
    Get
Private ReadOnly Property RootPath As String
    Implements IConfigNode.RootPath
    Get
private:
virtual property String^ RootPath {
    String^ get () sealed = IConfigNode::RootPath::get;
}
private:
virtual property String^ RootPath {
    String^ get () sealed = IConfigNode::RootPath::get;
}
private abstract RootPath : string with get
private override RootPath : string with get
private abstract RootPath : string with get
private override RootPath : string with get

Property Value

Type: Online String

Implements

IConfigNode RootPath
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.Modified Property

ConfigNode Modified Property NFX Class Library

Indicates whether a node was modified

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Modified { get; }
public virtual bool Modified { get; }
Public Overridable ReadOnly Property Modified As Boolean
    Get
Public Overridable ReadOnly Property Modified As Boolean
    Get
public:
virtual property bool Modified {
    bool get ();
}
public:
virtual property bool Modified {
    bool get ();
}
abstract Modified : bool with get
override Modified : bool with get
abstract Modified : bool with get
override Modified : bool with get

Property Value

Type: Online Boolean
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.Name Property

ConfigNode Name Property NFX Class Library

Retrieves node name

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
Public Property Name As String
    Get
    Set
Public Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Name : string with get, set
override Name : string with get, set
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: Online String

Implements

INamed Name
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.Parent Property

ConfigNode Parent Property NFX Class Library

References parent node or Empty if this node has no parent

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigSectionNode Parent { get; }
public ConfigSectionNode Parent { get; }
Public ReadOnly Property Parent As ConfigSectionNode
    Get
Public ReadOnly Property Parent As ConfigSectionNode
    Get
public:
property ConfigSectionNode^ Parent {
    ConfigSectionNode^ get ();
}
public:
property ConfigSectionNode^ Parent {
    ConfigSectionNode^ get ();
}
member Parent : ConfigSectionNode with get
member Parent : ConfigSectionNode with get

Property Value

Type: ConfigSectionNode
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.RootPath Property

ConfigNode RootPath Property NFX Class Library

Returns path from root to this node

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string RootPath { get; }
public string RootPath { get; }
Public ReadOnly Property RootPath As String
    Get
Public ReadOnly Property RootPath As String
    Get
public:
property String^ RootPath {
    String^ get ();
}
public:
property String^ RootPath {
    String^ get ();
}
member RootPath : string with get
member RootPath : string with get

Property Value

Type: Online String
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.Value Property

ConfigNode Value Property NFX Class Library

Retrieves node value or null. The value getter performs evaluation of variables, while setter sets the value verbatim

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Value { get; set; }
public string Value { get; set; }
Public Property Value As String
    Get
    Set
Public Property Value As String
    Get
    Set
public:
virtual property String^ Value {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ Value {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Value : string with get, set
override Value : string with get, set
abstract Value : string with get, set
override Value : string with get, set

Property Value

Type: Online String

Implements

IConfigNode Value
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNode.VerbatimValue Property

ConfigNode VerbatimValue Property NFX Class Library

Returns verbatim (without variable evaluation) node value or null

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string VerbatimValue { get; }
public string VerbatimValue { get; }
Public ReadOnly Property VerbatimValue As String
    Get
Public ReadOnly Property VerbatimValue As String
    Get
public:
virtual property String^ VerbatimValue {
    String^ get () sealed;
}
public:
virtual property String^ VerbatimValue {
    String^ get () sealed;
}
abstract VerbatimValue : string with get
override VerbatimValue : string with get
abstract VerbatimValue : string with get
override VerbatimValue : string with get

Property Value

Type: Online String

Implements

IConfigNode VerbatimValue
See Also
ConfigNode Class
ConfigNode Members
NFX.Environment Namespace


ConfigNodeEqualityComparer Class

ConfigNodeEqualityComparer Class NFX Class Library

Performs deep structural comparison of IConfigNodes
Inheritance Hierarchy
Online System Object
Online System.Collections.Generic EqualityComparer IConfigNode
NFX.Environment ConfigNodeEqualityComparer

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ConfigNodeEqualityComparer : EqualityComparer<IConfigNode>
public sealed class ConfigNodeEqualityComparer : EqualityComparer<IConfigNode>
Public NotInheritable Class ConfigNodeEqualityComparer
    Inherits EqualityComparer(Of IConfigNode)
Public NotInheritable Class ConfigNodeEqualityComparer
    Inherits EqualityComparer(Of IConfigNode)
public ref class ConfigNodeEqualityComparer sealed : public EqualityComparer<IConfigNode^>
public ref class ConfigNodeEqualityComparer sealed : public EqualityComparer<IConfigNode^>
[<SealedAttribute>]
type ConfigNodeEqualityComparer =
    class
        inherit EqualityComparer<IConfigNode>
    end
[<SealedAttribute>]
type ConfigNodeEqualityComparer =
    class
        inherit EqualityComparer<IConfigNode>
    end
See Also
ConfigNodeEqualityComparer Members
NFX.Environment Namespace


ConfigNodeEqualityComparer Members

ConfigNodeEqualityComparer Members NFX Class Library

The ConfigNodeEqualityComparer type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Equals(IConfigNode, IConfigNode) | (Overrides Online EqualityComparer T Equals(T, T).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetHashCode(IConfigNode) | (Overrides Online EqualityComparer T GetHashCode(T).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
Name | Description
Instance |
Back to Top
See Also
ConfigNodeEqualityComparer Class
NFX.Environment Namespace


ConfigNodeEqualityComparer Methods

ConfigNodeEqualityComparer Methods NFX Class Library

The ConfigNodeEqualityComparer type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Equals(IConfigNode, IConfigNode) | (Overrides Online EqualityComparer T Equals(T, T).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetHashCode(IConfigNode) | (Overrides Online EqualityComparer T GetHashCode(T).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ConfigNodeEqualityComparer Class
NFX.Environment Namespace


ConfigNodeEqualityComparer.Equals Method

ConfigNodeEqualityComparer Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Online Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Equals(IConfigNode, IConfigNode) | (Overrides Online EqualityComparer T Equals(T, T).)
Back to Top
See Also
ConfigNodeEqualityComparer Class
ConfigNodeEqualityComparer Members
NFX.Environment Namespace


ConfigNodeEqualityComparer.Equals Method (IConfigNode, IConfigNode)

ConfigNodeEqualityComparer Equals Method (IConfigNode, IConfigNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    IConfigNode x,
    IConfigNode y
)
public override bool Equals(
    IConfigNode x,
    IConfigNode y
)
Public Overrides Function Equals (
    x As IConfigNode,
    y As IConfigNode
) As Boolean
Public Overrides Function Equals (
    x As IConfigNode,
    y As IConfigNode
) As Boolean
public:
virtual bool Equals(
    IConfigNode^ x,
    IConfigNode^ y
) override
public:
virtual bool Equals(
    IConfigNode^ x,
    IConfigNode^ y
) override
abstract Equals :
        x : IConfigNode *
        y : IConfigNode -> bool
override Equals :
        x : IConfigNode *
        y : IConfigNode -> bool
abstract Equals :
        x : IConfigNode *
        y : IConfigNode -> bool
override Equals :
        x : IConfigNode *
        y : IConfigNode -> bool

Parameters

x
Type: NFX.Environment IConfigNode
y
Type: NFX.Environment IConfigNode

Return Value

Type: Online Boolean

Implements

Online IEqualityComparer T Equals(T, T)
See Also
ConfigNodeEqualityComparer Class
ConfigNodeEqualityComparer Members
Equals Overload
NFX.Environment Namespace


ConfigNodeEqualityComparer.GetHashCode Method

ConfigNodeEqualityComparer GetHashCode Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetHashCode(IConfigNode) | (Overrides Online EqualityComparer T GetHashCode(T).)
Back to Top
See Also
ConfigNodeEqualityComparer Class
ConfigNodeEqualityComparer Members
NFX.Environment Namespace


ConfigNodeEqualityComparer.GetHashCode Method (IConfigNode)

ConfigNodeEqualityComparer GetHashCode Method (IConfigNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode(
    IConfigNode node
)
public override int GetHashCode(
    IConfigNode node
)
Public Overrides Function GetHashCode (
    node As IConfigNode
) As Integer
Public Overrides Function GetHashCode (
    node As IConfigNode
) As Integer
public:
virtual int GetHashCode(
    IConfigNode^ node
) override
public:
virtual int GetHashCode(
    IConfigNode^ node
) override
abstract GetHashCode :
        node : IConfigNode -> int
override GetHashCode :
        node : IConfigNode -> int
abstract GetHashCode :
        node : IConfigNode -> int
override GetHashCode :
        node : IConfigNode -> int

Parameters

node
Type: NFX.Environment IConfigNode

Return Value

Type: Online Int32

Implements

Online IEqualityComparer T GetHashCode(T)
See Also
ConfigNodeEqualityComparer Class
ConfigNodeEqualityComparer Members
GetHashCode Overload
NFX.Environment Namespace


ConfigNodeEqualityComparer Properties

ConfigNodeEqualityComparer Properties NFX Class Library

The ConfigNodeEqualityComparer type exposes the following members.
Properties
Name | Description
Instance |
Back to Top
See Also
ConfigNodeEqualityComparer Class
NFX.Environment Namespace


ConfigNodeEqualityComparer.Instance Property

ConfigNodeEqualityComparer Instance Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ConfigNodeEqualityComparer Instance { get; }
public static ConfigNodeEqualityComparer Instance { get; }
Public Shared ReadOnly Property Instance As ConfigNodeEqualityComparer
    Get
Public Shared ReadOnly Property Instance As ConfigNodeEqualityComparer
    Get
public:
static property ConfigNodeEqualityComparer^ Instance {
    ConfigNodeEqualityComparer^ get ();
}
public:
static property ConfigNodeEqualityComparer^ Instance {
    ConfigNodeEqualityComparer^ get ();
}
static member Instance : ConfigNodeEqualityComparer with get
static member Instance : ConfigNodeEqualityComparer with get

Property Value

Type: ConfigNodeEqualityComparer
See Also
ConfigNodeEqualityComparer Class
ConfigNodeEqualityComparer Members
NFX.Environment Namespace


ConfigSectionNode Class

ConfigSectionNode Class NFX Class Library

Represents configuration section node. This class is thread safe
Inheritance Hierarchy
Online System Object
NFX.Environment ConfigNode
NFX.Environment ConfigSectionNode

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class ConfigSectionNode : ConfigNode,
    IConfigSectionNode, IConfigNode, INamed
[SerializableAttribute]
public sealed class ConfigSectionNode : ConfigNode,
    IConfigSectionNode, IConfigNode, INamed
<SerializableAttribute>
Public NotInheritable Class ConfigSectionNode
    Inherits ConfigNode
    Implements IConfigSectionNode, IConfigNode, INamed
<SerializableAttribute>
Public NotInheritable Class ConfigSectionNode
    Inherits ConfigNode
    Implements IConfigSectionNode, IConfigNode, INamed
[SerializableAttribute]
public ref class ConfigSectionNode sealed : public ConfigNode,
    IConfigSectionNode, IConfigNode, INamed
[SerializableAttribute]
public ref class ConfigSectionNode sealed : public ConfigNode,
    IConfigSectionNode, IConfigNode, INamed
[<SealedAttribute>]
[<SerializableAttribute>]
type ConfigSectionNode =
    class
        inherit ConfigNode
        interface IConfigSectionNode
        interface IConfigNode
        interface INamed
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type ConfigSectionNode =
    class
        inherit ConfigNode
        interface IConfigSectionNode
        interface IConfigNode
        interface INamed
    end
See Also
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode Members

ConfigSectionNode Members NFX Class Library

The ConfigSectionNode type exposes the following members.
Constructors
 | Name | Description
Protected method | ConfigSectionNode(Configuration, ConfigSectionNode) | Initializes a new instance of the ConfigSectionNode class
Protected method | ConfigSectionNode(Configuration, ConfigSectionNode, IConfigSectionNode) | Performs deep clone copy from another node which can be in this or different configuration
Protected method | ConfigSectionNode(Configuration, ConfigSectionNode, String, String) | Initializes a new instance of the ConfigSectionNode class
Back to Top
Methods
 | Name | Description
Public method | AddAttributeNode(String) |
Public method | AddAttributeNode(String, Object) |
Public method | AddAttributeNode(String, String) |
Public method | AddChildNode(String) |
Public method | AddChildNode(IConfigSectionNode) | Adds a new child node into this one deeply cloning nodes data from some other node which may belong to a different conf instance
Public method | AddChildNode(String, Object) |
Public method | AddChildNode(String, String) | Adds a new child section node to this node
Public method | AddChildNodeFromMerge | Adds a new section node to this configuration which is an ordered merge result of two other nodes - base and override.
Public method | AttrByIndex | Returns attribute node by its index or empty attribute if real attribute with such index does not exist
Public method | AttrByName |
Public method | AttrsToStringMap | Returns attribute values as string map
Protected method | checkCanModify | (Inherited from ConfigNode.)
Public method | Delete | Deletes this section from its parent (Overrides ConfigNode Delete .)
Public method | DeleteAllAttributes | Deletes all attribute nodes from this node
Public method | DeleteAllChildren | Deletes all child section nodes from this node
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | EvaluateValueVariables | Evaluates a value string expanding all variables with var-paths relative to this node. Evaluates configuration variables such as "$(varname)" or "$(@varname)". Varnames are paths to other config nodes from the same configuration or variable names when prefixed with "~". If varname starts with "@" then it gets combined with input as path string. "~" is used to qualify environment vars that get resolved through Configuration.EnvironmentVarResolver Example: `....add key="Schema.$(/A/B/C/$attr)" value="$(@~HOME)bin\Transforms\"...`
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | include |
Public method | IsSameName(String) | Returns true when another name is the same as this node's name per case-insensitive culture-neutral comparison (Inherited from ConfigNode.)
Public method | IsSameName(IConfigNode) | Returns true when another node has the same name as this one per case-insensitive culture-neutral comparison (Inherited from ConfigNode.)
Public method | IsSameNameAttr(String) | Returns true when another name is the same as this section "name" attribute per case-insensitive culture-neutral comparison
Public method | IsSameNameAttr(IConfigSectionNode) | Returns true when another node has the attribute called 'name' and its value is the same as in this one per case-insensitive culture-neutral comparison
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MergeAttributes | Merges attributes from another node into this one. Another node may belong to a different configuration instance
Public method | MergeSections | Merges child sections from another node into this one. Another node may belong to a different configuration instance. This method ignores override flags and merges nodes regardless
Public method | Navigate | Navigates the path and return the appropriate node. Example: '!/nfx/logger/destination/$file-name'
Public method | NavigateSection | Navigates the path and return the appropriate section node. Example '!/nfx/logger/destination'
Public method | OverrideBy | Merges another node data by overriding this node's value/attributes/sub nodes according to rules.
Public method | ProcessIncludePragmas | Replaces all include pragmas - sections with specified names ('_include' by default), with pointed to configuration file content as obtained via the call to file system specified in every pragma. If no FS specified then LocalFileSystem is used. If no file name specified when try to allocate config node provider. Returns true if include pragmas were found. Note: this method does not process new include pragmas that may have fetched during this call. Caution: the file system used in the operation may rely on the App container that may need to be set-up for the call to succeed, therefore calling this method before app has activated may fail, in such cases a temp app container may be set to get the config file with processed includes, then the result may be passed to the primary app container ctor. This call is not logically thread-safe, it must be called from the main thread in the app
Public method | ReplaceBy | Completely replaces this node's attributes, value and children with data from another node
Public method | ResetModified | Resets modification of this an all child nodes (Overrides ConfigNode ResetModified .)
Public method | ToConfigurationJSONDataMap | Returns this config node as JSON data map suitable for making JSONConfiguration. Contrast with ToJSONDataMap
Public method | ToJSONDataMap | Converts this ConfigSectionNode to JSONDataMap. Contrast with ToConfigurationJSONDataMap Be carefull: that this operation can "lose" data from ConfigSectionNode. In other words some ConfigSectionNode information can not be reflected in corresponding JSONDataMap, for example this method overwrites duplicate key names and does not support section values
Public method | ToJSONString | Serializes configuration tree rooted at this node into JSON configuration format and returns it as a string
Public method | ToLaconicString | Serializes configuration tree rooted at this node into Laconic format and returns it as a string
Public method | ToString | (Inherited from ConfigNode.)
Public method | ValueAsBool | (Inherited from ConfigNode.)
Public method | ValueAsByte | (Inherited from ConfigNode.)
Public method | ValueAsByteArray | (Inherited from ConfigNode.)
Public method | ValueAsDateTime | (Inherited from ConfigNode.)
Public method | ValueAsDecimal | (Inherited from ConfigNode.)
Public method | ValueAsDouble | (Inherited from ConfigNode.)
Public method | ValueAsEnum TEnum | (Inherited from ConfigNode.)
Public method | ValueAsFloat | (Inherited from ConfigNode.)
Public method | ValueAsGDID | (Inherited from ConfigNode.)
Public method | ValueAsGUID | (Inherited from ConfigNode.)
Public method | ValueAsInt | (Inherited from ConfigNode.)
Public method | ValueAsLong | (Inherited from ConfigNode.)
Public method | ValueAsNullableBool | (Inherited from ConfigNode.)
Public method | ValueAsNullableByte | (Inherited from ConfigNode.)
Public method | ValueAsNullableDateTime | (Inherited from ConfigNode.)
Public method | ValueAsNullableDecimal | (Inherited from ConfigNode.)
Public method | ValueAsNullableDouble | (Inherited from ConfigNode.)
Public method | ValueAsNullableEnum TEnum | (Inherited from ConfigNode.)
Public method | ValueAsNullableFloat | (Inherited from ConfigNode.)
Public method | ValueAsNullableGDID | (Inherited from ConfigNode.)
Public method | ValueAsNullableGUID | (Inherited from ConfigNode.)
Public method | ValueAsNullableInt | (Inherited from ConfigNode.)
Public method | ValueAsNullableLong | (Inherited from ConfigNode.)
Public method | ValueAsNullableSByte | (Inherited from ConfigNode.)
Public method | ValueAsNullableShort | (Inherited from ConfigNode.)
Public method | ValueAsNullableTimeSpan | (Inherited from ConfigNode.)
Public method | ValueAsNullableUInt | (Inherited from ConfigNode.)
Public method | ValueAsNullableULong | (Inherited from ConfigNode.)
Public method | ValueAsNullableUShort | (Inherited from ConfigNode.)
Public method | ValueAsSByte | (Inherited from ConfigNode.)
Public method | ValueAsShort | (Inherited from ConfigNode.)
Public method | ValueAsString | (Inherited from ConfigNode.)
Public method | ValueAsTimeSpan | (Inherited from ConfigNode.)
Public method | ValueAsType | Tries to get value as specified type or throws if it can not be converted (Inherited from ConfigNode.)
Public method | ValueAsUInt | (Inherited from ConfigNode.)
Public method | ValueAsULong | (Inherited from ConfigNode.)
Public method | ValueAsUShort | (Inherited from ConfigNode.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | HasTheSameContent | Returns true when both config nodes represents the same manifest - that is the same file structure (Defined by ManifestUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | __Empty | (Inherited from ConfigNode.)
Protected field | m_Attributes |
Protected field | m_Children |
Protected field | m_Configuration | (Inherited from ConfigNode.)
Protected field | m_Modified | (Inherited from ConfigNode.)
Protected field | m_Script_Bool_Condition_Result | Internal field used for attaching temporary script state. do not use
Protected field | m_Script_Statement | Internal field used for attaching temporary script state. do not use
Back to Top
Properties
 | Name | Description
Public property | AttrCount | Returns number of child attribute nodes
Public property | Attributes | Enumerates all attribute nodes
Public property | ChildCount | Returns number of child section nodes
Public property | Children | Enumerates all child nodes
Public property | Configuration | References configuration this node is under (Inherited from ConfigNode.)
Public property | EvaluatedValue | Returns null or value of this node with all variables evaluated (Inherited from ConfigNode.)
Public property | Exists | Determines whether this node really exists in configuration or is just a sentinel empty node (Inherited from ConfigNode.)
Public property | HasAttributes | Indicates whether this node has any associated attributes
Public property | HasChildren | Indicates whether this node has any child section nodes
Public property | Item Int32 | Retrieves section node by index or empty node instance if section node with such index could not be found
Public property | Item String | Retrieves section node by names, from left to right until existing node is found. If no existing node could be found then empty node instance is returned
Public property | Modified | Indicates whether this or any child nodes or attributes were modified (Overrides ConfigNode Modified.)
Public property | Name | Retrieves node name (Inherited from ConfigNode.)
Public property | Parent | References parent node or Empty if this node has no parent (Inherited from ConfigNode.)
Public property | RootPath | Returns path from root to this node (Inherited from ConfigNode.)
Public property | Value | Retrieves node value or null. The value getter performs evaluation of variables, while setter sets the value verbatim (Inherited from ConfigNode.)
Public property | VerbatimValue | Returns verbatim (without variable evaluation) node value or null (Inherited from ConfigNode.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IConfigNode Parent | References parent node (Inherited from ConfigNode.)
Explicit interface implemetation | IConfigNode RootPath | (Inherited from ConfigNode.)
Explicit interface implemetation | IConfigSectionNode AttrByIndex |
Explicit interface implemetation | IConfigSectionNode AttrByName |
Explicit interface implemetation | IConfigSectionNode Attributes |
Explicit interface implemetation | IConfigSectionNode Children |
Explicit interface implemetation | IConfigSectionNode Item Int32 |
Explicit interface implemetation | IConfigSectionNode Item String |
Explicit interface implemetation | IConfigSectionNode Navigate |
Explicit interface implemetation | IConfigSectionNode NavigateSection |
Back to Top
See Also
ConfigSectionNode Class
NFX.Environment Namespace


ConfigSectionNode Constructor

ConfigSectionNode Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | ConfigSectionNode(Configuration, ConfigSectionNode) | Initializes a new instance of the ConfigSectionNode class
Protected method | ConfigSectionNode(Configuration, ConfigSectionNode, IConfigSectionNode) | Performs deep clone copy from another node which can be in this or different configuration
Protected method | ConfigSectionNode(Configuration, ConfigSectionNode, String, String) | Initializes a new instance of the ConfigSectionNode class
Back to Top
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode Constructor (Configuration, ConfigSectionNode)

ConfigSectionNode Constructor (Configuration, ConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConfigSectionNode class

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ConfigSectionNode(
    Configuration conf,
    ConfigSectionNode parent
)
internal ConfigSectionNode(
    Configuration conf,
    ConfigSectionNode parent
)
Friend Sub New (
    conf As Configuration,
    parent As ConfigSectionNode
)
Friend Sub New (
    conf As Configuration,
    parent As ConfigSectionNode
)
internal:
ConfigSectionNode(
    Configuration^ conf,
    ConfigSectionNode^ parent
)
internal:
ConfigSectionNode(
    Configuration^ conf,
    ConfigSectionNode^ parent
)
new :
        conf : Configuration *
        parent : ConfigSectionNode -> ConfigSectionNode
new :
        conf : Configuration *
        parent : ConfigSectionNode -> ConfigSectionNode

Parameters

conf
Type: NFX.Environment Configuration
parent
Type: NFX.Environment ConfigSectionNode
See Also
ConfigSectionNode Class
ConfigSectionNode Members
ConfigSectionNode Overload
NFX.Environment Namespace


ConfigSectionNode Constructor (Configuration, ConfigSectionNode, IConfigSectionNode)

ConfigSectionNode Constructor (Configuration, ConfigSectionNode, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Performs deep clone copy from another node which can be in this or different configuration

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ConfigSectionNode(
    Configuration conf,
    ConfigSectionNode parent,
    IConfigSectionNode clone
)
internal ConfigSectionNode(
    Configuration conf,
    ConfigSectionNode parent,
    IConfigSectionNode clone
)
Friend Sub New (
    conf As Configuration,
    parent As ConfigSectionNode,
    clone As IConfigSectionNode
)
Friend Sub New (
    conf As Configuration,
    parent As ConfigSectionNode,
    clone As IConfigSectionNode
)
internal:
ConfigSectionNode(
    Configuration^ conf,
    ConfigSectionNode^ parent,
    IConfigSectionNode^ clone
)
internal:
ConfigSectionNode(
    Configuration^ conf,
    ConfigSectionNode^ parent,
    IConfigSectionNode^ clone
)
new :
        conf : Configuration *
        parent : ConfigSectionNode *
        clone : IConfigSectionNode -> ConfigSectionNode
new :
        conf : Configuration *
        parent : ConfigSectionNode *
        clone : IConfigSectionNode -> ConfigSectionNode

Parameters

conf
Type: NFX.Environment Configuration
parent
Type: NFX.Environment ConfigSectionNode
clone
Type: NFX.Environment IConfigSectionNode
See Also
ConfigSectionNode Class
ConfigSectionNode Members
ConfigSectionNode Overload
NFX.Environment Namespace


ConfigSectionNode Constructor (Configuration, ConfigSectionNode, String, String)

ConfigSectionNode Constructor (Configuration, ConfigSectionNode, String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConfigSectionNode class

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ConfigSectionNode(
    Configuration conf,
    ConfigSectionNode parent,
    string name,
    string value
)
internal ConfigSectionNode(
    Configuration conf,
    ConfigSectionNode parent,
    string name,
    string value
)
Friend Sub New (
    conf As Configuration,
    parent As ConfigSectionNode,
    name As String,
    value As String
)
Friend Sub New (
    conf As Configuration,
    parent As ConfigSectionNode,
    name As String,
    value As String
)
internal:
ConfigSectionNode(
    Configuration^ conf,
    ConfigSectionNode^ parent,
    String^ name,
    String^ value
)
internal:
ConfigSectionNode(
    Configuration^ conf,
    ConfigSectionNode^ parent,
    String^ name,
    String^ value
)
new :
        conf : Configuration *
        parent : ConfigSectionNode *
        name : string *
        value : string -> ConfigSectionNode
new :
        conf : Configuration *
        parent : ConfigSectionNode *
        name : string *
        value : string -> ConfigSectionNode

Parameters

conf
Type: NFX.Environment Configuration
parent
Type: NFX.Environment ConfigSectionNode
name
Type: Online System String
value
Type: Online System String
See Also
ConfigSectionNode Class
ConfigSectionNode Members
ConfigSectionNode Overload
NFX.Environment Namespace


ConfigSectionNode Fields

ConfigSectionNode Fields NFX Class Library

The ConfigSectionNode type exposes the following members.
Fields
 | Name | Description
Protected field | __Empty | (Inherited from ConfigNode.)
Protected field | m_Attributes |
Protected field | m_Children |
Protected field | m_Configuration | (Inherited from ConfigNode.)
Protected field | m_Modified | (Inherited from ConfigNode.)
Protected field | m_Script_Bool_Condition_Result | Internal field used for attaching temporary script state. do not use
Protected field | m_Script_Statement | Internal field used for attaching temporary script state. do not use
Back to Top
See Also
ConfigSectionNode Class
NFX.Environment Namespace


ConfigSectionNode.m_Attributes Field

ConfigSectionNode m_Attributes Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ConfigAttrNodeList m_Attributes
internal ConfigAttrNodeList m_Attributes
Friend m_Attributes As ConfigAttrNodeList
Friend m_Attributes As ConfigAttrNodeList
internal:
ConfigAttrNodeList^ m_Attributes
internal:
ConfigAttrNodeList^ m_Attributes
val mutable internal m_Attributes: ConfigAttrNodeList
val mutable internal m_Attributes: ConfigAttrNodeList

Field Value

Type: ConfigAttrNodeList
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.m_Children Field

ConfigSectionNode m_Children Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ConfigSectionNodeList m_Children
internal ConfigSectionNodeList m_Children
Friend m_Children As ConfigSectionNodeList
Friend m_Children As ConfigSectionNodeList
internal:
ConfigSectionNodeList^ m_Children
internal:
ConfigSectionNodeList^ m_Children
val mutable internal m_Children: ConfigSectionNodeList
val mutable internal m_Children: ConfigSectionNodeList

Field Value

Type: ConfigSectionNodeList
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.m_Script_Bool_Condition_Result Field

ConfigSectionNode m_Script_Bool_Condition_Result Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Internal field used for attaching temporary script state. do not use

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal bool m_Script_Bool_Condition_Result
internal bool m_Script_Bool_Condition_Result
Friend m_Script_Bool_Condition_Result As Boolean
Friend m_Script_Bool_Condition_Result As Boolean
internal:
bool m_Script_Bool_Condition_Result
internal:
bool m_Script_Bool_Condition_Result
val mutable internal m_Script_Bool_Condition_Result: bool
val mutable internal m_Script_Bool_Condition_Result: bool

Field Value

Type: Online Boolean
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.m_Script_Statement Field

ConfigSectionNode m_Script_Statement Field NFX Class Library

Internal field used for attaching temporary script state. do not use

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal bool m_Script_Statement
internal bool m_Script_Statement
Friend m_Script_Statement As Boolean
Friend m_Script_Statement As Boolean
internal:
bool m_Script_Statement
internal:
bool m_Script_Statement
val mutable internal m_Script_Statement: bool
val mutable internal m_Script_Statement: bool

Field Value

Type: Online Boolean
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode Methods

ConfigSectionNode Methods NFX Class Library

The ConfigSectionNode type exposes the following members.
Methods
 | Name | Description
Public method | AddAttributeNode(String) |
Public method | AddAttributeNode(String, Object) |
Public method | AddAttributeNode(String, String) |
Public method | AddChildNode(String) |
Public method | AddChildNode(IConfigSectionNode) | Adds a new child node into this one deeply cloning nodes data from some other node which may belong to a different conf instance
Public method | AddChildNode(String, Object) |
Public method | AddChildNode(String, String) | Adds a new child section node to this node
Public method | AddChildNodeFromMerge | Adds a new section node to this configuration which is an ordered merge result of two other nodes - base and override.
Public method | AttrByIndex | Returns attribute node by its index or empty attribute if real attribute with such index does not exist
Public method | AttrByName |
Public method | AttrsToStringMap | Returns attribute values as string map
Protected method | checkCanModify | (Inherited from ConfigNode.)
Public method | Delete | Deletes this section from its parent (Overrides ConfigNode Delete .)
Public method | DeleteAllAttributes | Deletes all attribute nodes from this node
Public method | DeleteAllChildren | Deletes all child section nodes from this node
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | EvaluateValueVariables | Evaluates a value string expanding all variables with var-paths relative to this node. Evaluates configuration variables such as "$(varname)" or "$(@varname)". Varnames are paths to other config nodes from the same configuration or variable names when prefixed with "~". If varname starts with "@" then it gets combined with input as path string. "~" is used to qualify environment vars that get resolved through Configuration.EnvironmentVarResolver Example: `....add key="Schema.$(/A/B/C/$attr)" value="$(@~HOME)bin\Transforms\"...`
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | include |
Public method | IsSameName(String) | Returns true when another name is the same as this node's name per case-insensitive culture-neutral comparison (Inherited from ConfigNode.)
Public method | IsSameName(IConfigNode) | Returns true when another node has the same name as this one per case-insensitive culture-neutral comparison (Inherited from ConfigNode.)
Public method | IsSameNameAttr(String) | Returns true when another name is the same as this section "name" attribute per case-insensitive culture-neutral comparison
Public method | IsSameNameAttr(IConfigSectionNode) | Returns true when another node has the attribute called 'name' and its value is the same as in this one per case-insensitive culture-neutral comparison
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MergeAttributes | Merges attributes from another node into this one. Another node may belong to a different configuration instance
Public method | MergeSections | Merges child sections from another node into this one. Another node may belong to a different configuration instance. This method ignores override flags and merges nodes regardless
Public method | Navigate | Navigates the path and return the appropriate node. Example: '!/nfx/logger/destination/$file-name'
Public method | NavigateSection | Navigates the path and return the appropriate section node. Example '!/nfx/logger/destination'
Public method | OverrideBy | Merges another node data by overriding this node's value/attributes/sub nodes according to rules.
Public method | ProcessIncludePragmas | Replaces all include pragmas - sections with specified names ('_include' by default), with pointed to configuration file content as obtained via the call to file system specified in every pragma. If no FS specified then LocalFileSystem is used. If no file name specified when try to allocate config node provider. Returns true if include pragmas were found. Note: this method does not process new include pragmas that may have fetched during this call. Caution: the file system used in the operation may rely on the App container that may need to be set-up for the call to succeed, therefore calling this method before app has activated may fail, in such cases a temp app container may be set to get the config file with processed includes, then the result may be passed to the primary app container ctor. This call is not logically thread-safe, it must be called from the main thread in the app
Public method | ReplaceBy | Completely replaces this node's attributes, value and children with data from another node
Public method | ResetModified | Resets modification of this an all child nodes (Overrides ConfigNode ResetModified .)
Public method | ToConfigurationJSONDataMap | Returns this config node as JSON data map suitable for making JSONConfiguration. Contrast with ToJSONDataMap
Public method | ToJSONDataMap | Converts this ConfigSectionNode to JSONDataMap. Contrast with ToConfigurationJSONDataMap Be carefull: that this operation can "lose" data from ConfigSectionNode. In other words some ConfigSectionNode information can not be reflected in corresponding JSONDataMap, for example this method overwrites duplicate key names and does not support section values
Public method | ToJSONString | Serializes configuration tree rooted at this node into JSON configuration format and returns it as a string
Public method | ToLaconicString | Serializes configuration tree rooted at this node into Laconic format and returns it as a string
Public method | ToString | (Inherited from ConfigNode.)
Public method | ValueAsBool | (Inherited from ConfigNode.)
Public method | ValueAsByte | (Inherited from ConfigNode.)
Public method | ValueAsByteArray | (Inherited from ConfigNode.)
Public method | ValueAsDateTime | (Inherited from ConfigNode.)
Public method | ValueAsDecimal | (Inherited from ConfigNode.)
Public method | ValueAsDouble | (Inherited from ConfigNode.)
Public method | ValueAsEnum TEnum | (Inherited from ConfigNode.)
Public method | ValueAsFloat | (Inherited from ConfigNode.)
Public method | ValueAsGDID | (Inherited from ConfigNode.)
Public method | ValueAsGUID | (Inherited from ConfigNode.)
Public method | ValueAsInt | (Inherited from ConfigNode.)
Public method | ValueAsLong | (Inherited from ConfigNode.)
Public method | ValueAsNullableBool | (Inherited from ConfigNode.)
Public method | ValueAsNullableByte | (Inherited from ConfigNode.)
Public method | ValueAsNullableDateTime | (Inherited from ConfigNode.)
Public method | ValueAsNullableDecimal | (Inherited from ConfigNode.)
Public method | ValueAsNullableDouble | (Inherited from ConfigNode.)
Public method | ValueAsNullableEnum TEnum | (Inherited from ConfigNode.)
Public method | ValueAsNullableFloat | (Inherited from ConfigNode.)
Public method | ValueAsNullableGDID | (Inherited from ConfigNode.)
Public method | ValueAsNullableGUID | (Inherited from ConfigNode.)
Public method | ValueAsNullableInt | (Inherited from ConfigNode.)
Public method | ValueAsNullableLong | (Inherited from ConfigNode.)
Public method | ValueAsNullableSByte | (Inherited from ConfigNode.)
Public method | ValueAsNullableShort | (Inherited from ConfigNode.)
Public method | ValueAsNullableTimeSpan | (Inherited from ConfigNode.)
Public method | ValueAsNullableUInt | (Inherited from ConfigNode.)
Public method | ValueAsNullableULong | (Inherited from ConfigNode.)
Public method | ValueAsNullableUShort | (Inherited from ConfigNode.)
Public method | ValueAsSByte | (Inherited from ConfigNode.)
Public method | ValueAsShort | (Inherited from ConfigNode.)
Public method | ValueAsString | (Inherited from ConfigNode.)
Public method | ValueAsTimeSpan | (Inherited from ConfigNode.)
Public method | ValueAsType | Tries to get value as specified type or throws if it can not be converted (Inherited from ConfigNode.)
Public method | ValueAsUInt | (Inherited from ConfigNode.)
Public method | ValueAsULong | (Inherited from ConfigNode.)
Public method | ValueAsUShort | (Inherited from ConfigNode.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | HasTheSameContent | Returns true when both config nodes represents the same manifest - that is the same file structure (Defined by ManifestUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IConfigSectionNode AttrByIndex |
Explicit interface implemetation | IConfigSectionNode AttrByName |
Explicit interface implemetation | IConfigSectionNode Navigate |
Explicit interface implemetation | IConfigSectionNode NavigateSection |
Back to Top
See Also
ConfigSectionNode Class
NFX.Environment Namespace


ConfigSectionNode.AddAttributeNode Method

ConfigSectionNode AddAttributeNode Method NFX Class Library

Overload List
 | Name | Description
Public method | AddAttributeNode(String) |
Public method | AddAttributeNode(String, Object) |
Public method | AddAttributeNode(String, String) |
Back to Top
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.AddAttributeNode Method (String)

ConfigSectionNode AddAttributeNode Method (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigAttrNode AddAttributeNode(
    string name
)
public ConfigAttrNode AddAttributeNode(
    string name
)
Public Function AddAttributeNode (
    name As String
) As ConfigAttrNode
Public Function AddAttributeNode (
    name As String
) As ConfigAttrNode
public:
ConfigAttrNode^ AddAttributeNode(
    String^ name
)
public:
ConfigAttrNode^ AddAttributeNode(
    String^ name
)
member AddAttributeNode :
        name : string -> ConfigAttrNode
member AddAttributeNode :
        name : string -> ConfigAttrNode

Parameters

name
Type: Online System String

Return Value

Type: ConfigAttrNode
See Also
ConfigSectionNode Class
ConfigSectionNode Members
AddAttributeNode Overload
NFX.Environment Namespace


ConfigSectionNode.AddAttributeNode Method (String, Object)

ConfigSectionNode AddAttributeNode Method (String, Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigAttrNode AddAttributeNode(
    string name,
    Object value
)
public ConfigAttrNode AddAttributeNode(
    string name,
    Object value
)
Public Function AddAttributeNode (
    name As String,
    value As Object
) As ConfigAttrNode
Public Function AddAttributeNode (
    name As String,
    value As Object
) As ConfigAttrNode
public:
ConfigAttrNode^ AddAttributeNode(
    String^ name,
    Object^ value
)
public:
ConfigAttrNode^ AddAttributeNode(
    String^ name,
    Object^ value
)
member AddAttributeNode :
        name : string *
        value : Object -> ConfigAttrNode
member AddAttributeNode :
        name : string *
        value : Object -> ConfigAttrNode

Parameters

name
Type: Online System String
value
Type: Online System Object

Return Value

Type: ConfigAttrNode
See Also
ConfigSectionNode Class
ConfigSectionNode Members
AddAttributeNode Overload
NFX.Environment Namespace


ConfigSectionNode.AddAttributeNode Method (String, String)

ConfigSectionNode AddAttributeNode Method (String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigAttrNode AddAttributeNode(
    string name,
    string value
)
public ConfigAttrNode AddAttributeNode(
    string name,
    string value
)
Public Function AddAttributeNode (
    name As String,
    value As String
) As ConfigAttrNode
Public Function AddAttributeNode (
    name As String,
    value As String
) As ConfigAttrNode
public:
ConfigAttrNode^ AddAttributeNode(
    String^ name,
    String^ value
)
public:
ConfigAttrNode^ AddAttributeNode(
    String^ name,
    String^ value
)
member AddAttributeNode :
        name : string *
        value : string -> ConfigAttrNode
member AddAttributeNode :
        name : string *
        value : string -> ConfigAttrNode

Parameters

name
Type: Online System String
value
Type: Online System String

Return Value

Type: ConfigAttrNode
See Also
ConfigSectionNode Class
ConfigSectionNode Members
AddAttributeNode Overload
NFX.Environment Namespace


ConfigSectionNode.AddChildNode Method

ConfigSectionNode AddChildNode Method NFX Class Library

Overload List
 | Name | Description
Public method | AddChildNode(String) |
Public method | AddChildNode(IConfigSectionNode) | Adds a new child node into this one deeply cloning nodes data from some other node which may belong to a different conf instance
Public method | AddChildNode(String, Object) |
Public method | AddChildNode(String, String) | Adds a new child section node to this node
Back to Top
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.AddChildNode Method (String)

ConfigSectionNode AddChildNode Method (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigSectionNode AddChildNode(
    string name
)
public ConfigSectionNode AddChildNode(
    string name
)
Public Function AddChildNode (
    name As String
) As ConfigSectionNode
Public Function AddChildNode (
    name As String
) As ConfigSectionNode
public:
ConfigSectionNode^ AddChildNode(
    String^ name
)
public:
ConfigSectionNode^ AddChildNode(
    String^ name
)
member AddChildNode :
        name : string -> ConfigSectionNode
member AddChildNode :
        name : string -> ConfigSectionNode

Parameters

name
Type: Online System String

Return Value

Type: ConfigSectionNode
See Also
ConfigSectionNode Class
ConfigSectionNode Members
AddChildNode Overload
NFX.Environment Namespace


ConfigSectionNode.AddChildNode Method (IConfigSectionNode)

ConfigSectionNode AddChildNode Method (IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Adds a new child node into this one deeply cloning nodes data from some other node which may belong to a different conf instance

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigSectionNode AddChildNode(
    IConfigSectionNode clone
)
public ConfigSectionNode AddChildNode(
    IConfigSectionNode clone
)
Public Function AddChildNode (
    clone As IConfigSectionNode
) As ConfigSectionNode
Public Function AddChildNode (
    clone As IConfigSectionNode
) As ConfigSectionNode
public:
ConfigSectionNode^ AddChildNode(
    IConfigSectionNode^ clone
)
public:
ConfigSectionNode^ AddChildNode(
    IConfigSectionNode^ clone
)
member AddChildNode :
        clone : IConfigSectionNode -> ConfigSectionNode
member AddChildNode :
        clone : IConfigSectionNode -> ConfigSectionNode

Parameters

clone
Type: NFX.Environment IConfigSectionNode

Return Value

Type: ConfigSectionNode
See Also
ConfigSectionNode Class
ConfigSectionNode Members
AddChildNode Overload
NFX.Environment Namespace


ConfigSectionNode.AddChildNode Method (String, Object)

ConfigSectionNode AddChildNode Method (String, Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigSectionNode AddChildNode(
    string name,
    Object value
)
public ConfigSectionNode AddChildNode(
    string name,
    Object value
)
Public Function AddChildNode (
    name As String,
    value As Object
) As ConfigSectionNode
Public Function AddChildNode (
    name As String,
    value As Object
) As ConfigSectionNode
public:
ConfigSectionNode^ AddChildNode(
    String^ name,
    Object^ value
)
public:
ConfigSectionNode^ AddChildNode(
    String^ name,
    Object^ value
)
member AddChildNode :
        name : string *
        value : Object -> ConfigSectionNode
member AddChildNode :
        name : string *
        value : Object -> ConfigSectionNode

Parameters

name
Type: Online System String
value
Type: Online System Object

Return Value

Type: ConfigSectionNode
See Also
ConfigSectionNode Class
ConfigSectionNode Members
AddChildNode Overload
NFX.Environment Namespace


ConfigSectionNode.AddChildNode Method (String, String)

ConfigSectionNode AddChildNode Method (String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Adds a new child section node to this node

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigSectionNode AddChildNode(
    string name,
    string value
)
public ConfigSectionNode AddChildNode(
    string name,
    string value
)
Public Function AddChildNode (
    name As String,
    value As String
) As ConfigSectionNode
Public Function AddChildNode (
    name As String,
    value As String
) As ConfigSectionNode
public:
ConfigSectionNode^ AddChildNode(
    String^ name,
    String^ value
)
public:
ConfigSectionNode^ AddChildNode(
    String^ name,
    String^ value
)
member AddChildNode :
        name : string *
        value : string -> ConfigSectionNode
member AddChildNode :
        name : string *
        value : string -> ConfigSectionNode

Parameters

name
Type: Online System String
value
Type: Online System String

Return Value

Type: ConfigSectionNode
See Also
ConfigSectionNode Class
ConfigSectionNode Members
AddChildNode Overload
NFX.Environment Namespace


ConfigSectionNode.AddChildNodeFromMerge Method

ConfigSectionNode AddChildNodeFromMerge Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Adds a new section node to this configuration which is an ordered merge result of two other nodes - base and override.

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigSectionNode AddChildNodeFromMerge(
    IConfigSectionNode baseNode,
    IConfigSectionNode overrideNode,
    NodeOverrideRules rules = null
)
public ConfigSectionNode AddChildNodeFromMerge(
    IConfigSectionNode baseNode,
    IConfigSectionNode overrideNode,
    NodeOverrideRules rules = null
)
Public Function AddChildNodeFromMerge (
    baseNode As IConfigSectionNode,
    overrideNode As IConfigSectionNode,
    Optional rules As NodeOverrideRules = Nothing
) As ConfigSectionNode
Public Function AddChildNodeFromMerge (
    baseNode As IConfigSectionNode,
    overrideNode As IConfigSectionNode,
    Optional rules As NodeOverrideRules = Nothing
) As ConfigSectionNode
public:
ConfigSectionNode^ AddChildNodeFromMerge(
    IConfigSectionNode^ baseNode,
    IConfigSectionNode^ overrideNode,
    NodeOverrideRules^ rules = nullptr
)
public:
ConfigSectionNode^ AddChildNodeFromMerge(
    IConfigSectionNode^ baseNode,
    IConfigSectionNode^ overrideNode,
    NodeOverrideRules^ rules = nullptr
)
member AddChildNodeFromMerge :
        baseNode : IConfigSectionNode *
        overrideNode : IConfigSectionNode *
        ?rules : NodeOverrideRules
(* Defaults:
        let _rules = defaultArg rules null
*)
-> ConfigSectionNode
member AddChildNodeFromMerge :
        baseNode : IConfigSectionNode *
        overrideNode : IConfigSectionNode *
        ?rules : NodeOverrideRules
(* Defaults:
        let _rules = defaultArg rules null
*)
-> ConfigSectionNode

Parameters

baseNode
Type: NFX.Environment IConfigSectionNode
A base node that data is defaulted from
overrideNode
Type: NFX.Environment IConfigSectionNode
A node that contains overrides/additions of/to data from base node
rules (Optional)
Type: NFX.Environment NodeOverrideRules
Rules to use for this merge. Default rules will be used if null is passed

Return Value

Type: ConfigSectionNode
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.AttrByIndex Method

ConfigSectionNode AttrByIndex Method NFX Class Library

Returns attribute node by its index or empty attribute if real attribute with such index does not exist

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigAttrNode AttrByIndex(
    int idx
)
public ConfigAttrNode AttrByIndex(
    int idx
)
Public Function AttrByIndex (
    idx As Integer
) As ConfigAttrNode
Public Function AttrByIndex (
    idx As Integer
) As ConfigAttrNode
public:
ConfigAttrNode^ AttrByIndex(
    int idx
)
public:
ConfigAttrNode^ AttrByIndex(
    int idx
)
member AttrByIndex :
        idx : int -> ConfigAttrNode
member AttrByIndex :
        idx : int -> ConfigAttrNode

Parameters

idx
Type: Online System Int32

Return Value

Type: ConfigAttrNode
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.AttrByName Method

ConfigSectionNode AttrByName Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigAttrNode AttrByName(
    string name,
    bool autoCreate = false
)
public ConfigAttrNode AttrByName(
    string name,
    bool autoCreate = false
)
Public Function AttrByName (
    name As String,
    Optional autoCreate As Boolean = false
) As ConfigAttrNode
Public Function AttrByName (
    name As String,
    Optional autoCreate As Boolean = false
) As ConfigAttrNode
public:
ConfigAttrNode^ AttrByName(
    String^ name,
    bool autoCreate = false
)
public:
ConfigAttrNode^ AttrByName(
    String^ name,
    bool autoCreate = false
)
member AttrByName :
        name : string *
        ?autoCreate : bool
(* Defaults:
        let _autoCreate = defaultArg autoCreate false
*)
-> ConfigAttrNode
member AttrByName :
        name : string *
        ?autoCreate : bool
(* Defaults:
        let _autoCreate = defaultArg autoCreate false
*)
-> ConfigAttrNode

Parameters

name
Type: Online System String
autoCreate (Optional)
Type: Online System Boolean

Return Value

Type: ConfigAttrNode
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.AttrsToStringMap Method

ConfigSectionNode AttrsToStringMap Method NFX Class Library

Returns attribute values as string map

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StringMap AttrsToStringMap(
    bool verbatim = false
)
public StringMap AttrsToStringMap(
    bool verbatim = false
)
Public Function AttrsToStringMap (
    Optional verbatim As Boolean = false
) As StringMap
Public Function AttrsToStringMap (
    Optional verbatim As Boolean = false
) As StringMap
public:
virtual StringMap^ AttrsToStringMap(
    bool verbatim = false
) sealed
public:
virtual StringMap^ AttrsToStringMap(
    bool verbatim = false
) sealed
abstract AttrsToStringMap :
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> StringMap
override AttrsToStringMap :
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> StringMap
abstract AttrsToStringMap :
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> StringMap
override AttrsToStringMap :
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> StringMap

Parameters

verbatim (Optional)
Type: Online System Boolean

Return Value

Type: StringMap

Implements

IConfigSectionNode AttrsToStringMap(Boolean)
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.Delete Method

ConfigSectionNode Delete Method NFX Class Library

Deletes this section from its parent

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Delete()
public override void Delete()
Public Overrides Sub Delete
Public Overrides Sub Delete
public:
virtual void Delete() override
public:
virtual void Delete() override
abstract Delete : unit -> unit
override Delete : unit -> unit
abstract Delete : unit -> unit
override Delete : unit -> unit
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.DeleteAllAttributes Method

ConfigSectionNode DeleteAllAttributes Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Deletes all attribute nodes from this node

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DeleteAllAttributes()
public void DeleteAllAttributes()
Public Sub DeleteAllAttributes
Public Sub DeleteAllAttributes
public:
void DeleteAllAttributes()
public:
void DeleteAllAttributes()
member DeleteAllAttributes : unit -> unit
member DeleteAllAttributes : unit -> unit
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.DeleteAllChildren Method

ConfigSectionNode DeleteAllChildren Method NFX Class Library

Deletes all child section nodes from this node

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DeleteAllChildren()
public void DeleteAllChildren()
Public Sub DeleteAllChildren
Public Sub DeleteAllChildren
public:
void DeleteAllChildren()
public:
void DeleteAllChildren()
member DeleteAllChildren : unit -> unit
member DeleteAllChildren : unit -> unit
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.EvaluateValueVariables Method

ConfigSectionNode EvaluateValueVariables Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Evaluates a value string expanding all variables with var-paths relative to this node. Evaluates configuration variables such as "$(varname)" or "$(@varname)". Varnames are paths to other config nodes from the same configuration or variable names when prefixed with "~". If varname starts with "@" then it gets combined with input as path string. "~" is used to qualify environment vars that get resolved through Configuration.EnvironmentVarResolver Example: `....add key="Schema.$(/A/B/C/$attr)" value="$(@~HOME)bin\Transforms\"...`

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string EvaluateValueVariables(
    string value
)
public string EvaluateValueVariables(
    string value
)
Public Function EvaluateValueVariables (
    value As String
) As String
Public Function EvaluateValueVariables (
    value As String
) As String
public:
virtual String^ EvaluateValueVariables(
    String^ value
) sealed
public:
virtual String^ EvaluateValueVariables(
    String^ value
) sealed
abstract EvaluateValueVariables :
        value : string -> string
override EvaluateValueVariables :
        value : string -> string
abstract EvaluateValueVariables :
        value : string -> string
override EvaluateValueVariables :
        value : string -> string

Parameters

value
Type: Online System String

Return Value

Type: Online String

Implements

IConfigSectionNode EvaluateValueVariables(String)
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.IConfigSectionNode.AttrByIndex Method

ConfigSectionNode IConfigSectionNode AttrByIndex Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IConfigAttrNode IConfigSectionNode.AttrByIndex(
    int idx
)
IConfigAttrNode IConfigSectionNode.AttrByIndex(
    int idx
)
Private Function AttrByIndex (
    idx As Integer
) As IConfigAttrNode Implements IConfigSectionNode.AttrByIndex
Private Function AttrByIndex (
    idx As Integer
) As IConfigAttrNode Implements IConfigSectionNode.AttrByIndex
private:
virtual IConfigAttrNode^ AttrByIndex(
    int idx
) sealed = IConfigSectionNode::AttrByIndex
private:
virtual IConfigAttrNode^ AttrByIndex(
    int idx
) sealed = IConfigSectionNode::AttrByIndex
private abstract AttrByIndex :
        idx : int -> IConfigAttrNode
private override AttrByIndex :
        idx : int -> IConfigAttrNode
private abstract AttrByIndex :
        idx : int -> IConfigAttrNode
private override AttrByIndex :
        idx : int -> IConfigAttrNode

Parameters

idx
Type: Online System Int32

Return Value

Type: IConfigAttrNode

Implements

IConfigSectionNode AttrByIndex(Int32)
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.IConfigSectionNode.AttrByName Method

ConfigSectionNode IConfigSectionNode AttrByName Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IConfigAttrNode IConfigSectionNode.AttrByName(
    string name,
    bool autoCreate
)
IConfigAttrNode IConfigSectionNode.AttrByName(
    string name,
    bool autoCreate
)
Private Function AttrByName (
    name As String,
    autoCreate As Boolean
) As IConfigAttrNode Implements IConfigSectionNode.AttrByName
Private Function AttrByName (
    name As String,
    autoCreate As Boolean
) As IConfigAttrNode Implements IConfigSectionNode.AttrByName
private:
virtual IConfigAttrNode^ AttrByName(
    String^ name,
    bool autoCreate
) sealed = IConfigSectionNode::AttrByName
private:
virtual IConfigAttrNode^ AttrByName(
    String^ name,
    bool autoCreate
) sealed = IConfigSectionNode::AttrByName
private abstract AttrByName :
        name : string *
        autoCreate : bool -> IConfigAttrNode
private override AttrByName :
        name : string *
        autoCreate : bool -> IConfigAttrNode
private abstract AttrByName :
        name : string *
        autoCreate : bool -> IConfigAttrNode
private override AttrByName :
        name : string *
        autoCreate : bool -> IConfigAttrNode

Parameters

name
Type: Online System String
autoCreate
Type: Online System Boolean

Return Value

Type: IConfigAttrNode

Implements

IConfigSectionNode AttrByName(String, Boolean)
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.IConfigSectionNode.Navigate Method

ConfigSectionNode IConfigSectionNode Navigate Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IConfigNode IConfigSectionNode.Navigate(
    string path
)
IConfigNode IConfigSectionNode.Navigate(
    string path
)
Private Function Navigate (
    path As String
) As IConfigNode Implements IConfigSectionNode.Navigate
Private Function Navigate (
    path As String
) As IConfigNode Implements IConfigSectionNode.Navigate
private:
virtual IConfigNode^ Navigate(
    String^ path
) sealed = IConfigSectionNode::Navigate
private:
virtual IConfigNode^ Navigate(
    String^ path
) sealed = IConfigSectionNode::Navigate
private abstract Navigate :
        path : string -> IConfigNode
private override Navigate :
        path : string -> IConfigNode
private abstract Navigate :
        path : string -> IConfigNode
private override Navigate :
        path : string -> IConfigNode

Parameters

path
Type: Online System String

Return Value

Type: IConfigNode

Implements

IConfigSectionNode Navigate(String)
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.IConfigSectionNode.NavigateSection Method

ConfigSectionNode IConfigSectionNode NavigateSection Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IConfigSectionNode IConfigSectionNode.NavigateSection(
    string path
)
IConfigSectionNode IConfigSectionNode.NavigateSection(
    string path
)
Private Function NavigateSection (
    path As String
) As IConfigSectionNode Implements IConfigSectionNode.NavigateSection
Private Function NavigateSection (
    path As String
) As IConfigSectionNode Implements IConfigSectionNode.NavigateSection
private:
virtual IConfigSectionNode^ NavigateSection(
    String^ path
) sealed = IConfigSectionNode::NavigateSection
private:
virtual IConfigSectionNode^ NavigateSection(
    String^ path
) sealed = IConfigSectionNode::NavigateSection
private abstract NavigateSection :
        path : string -> IConfigSectionNode
private override NavigateSection :
        path : string -> IConfigSectionNode
private abstract NavigateSection :
        path : string -> IConfigSectionNode
private override NavigateSection :
        path : string -> IConfigSectionNode

Parameters

path
Type: Online System String

Return Value

Type: IConfigSectionNode

Implements

IConfigSectionNode NavigateSection(String)
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.include Method

ConfigSectionNode include Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void include(
    ConfigSectionNode other
)
internal void include(
    ConfigSectionNode other
)
Friend Sub include (
    other As ConfigSectionNode
)
Friend Sub include (
    other As ConfigSectionNode
)
internal:
void include(
    ConfigSectionNode^ other
)
internal:
void include(
    ConfigSectionNode^ other
)
internal member include :
        other : ConfigSectionNode -> unit
internal member include :
        other : ConfigSectionNode -> unit

Parameters

other
Type: NFX.Environment ConfigSectionNode
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.IsSameNameAttr Method

ConfigSectionNode IsSameNameAttr Method NFX Class Library

Overload List
 | Name | Description
Public method | IsSameNameAttr(String) | Returns true when another name is the same as this section "name" attribute per case-insensitive culture-neutral comparison
Public method | IsSameNameAttr(IConfigSectionNode) | Returns true when another node has the attribute called 'name' and its value is the same as in this one per case-insensitive culture-neutral comparison
Back to Top
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.IsSameNameAttr Method (String)

ConfigSectionNode IsSameNameAttr Method (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns true when another name is the same as this section "name" attribute per case-insensitive culture-neutral comparison

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsSameNameAttr(
    string other
)
public bool IsSameNameAttr(
    string other
)
Public Function IsSameNameAttr (
    other As String
) As Boolean
Public Function IsSameNameAttr (
    other As String
) As Boolean
public:
virtual bool IsSameNameAttr(
    String^ other
) sealed
public:
virtual bool IsSameNameAttr(
    String^ other
) sealed
abstract IsSameNameAttr :
        other : string -> bool
override IsSameNameAttr :
        other : string -> bool
abstract IsSameNameAttr :
        other : string -> bool
override IsSameNameAttr :
        other : string -> bool

Parameters

other
Type: Online System String

Return Value

Type: Online Boolean

Implements

IConfigSectionNode IsSameNameAttr(String)
See Also
ConfigSectionNode Class
ConfigSectionNode Members
IsSameNameAttr Overload
NFX.Environment Namespace


ConfigSectionNode.IsSameNameAttr Method (IConfigSectionNode)

ConfigSectionNode IsSameNameAttr Method (IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns true when another node has the attribute called 'name' and its value is the same as in this one per case-insensitive culture-neutral comparison

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsSameNameAttr(
    IConfigSectionNode other
)
public bool IsSameNameAttr(
    IConfigSectionNode other
)
Public Function IsSameNameAttr (
    other As IConfigSectionNode
) As Boolean
Public Function IsSameNameAttr (
    other As IConfigSectionNode
) As Boolean
public:
virtual bool IsSameNameAttr(
    IConfigSectionNode^ other
) sealed
public:
virtual bool IsSameNameAttr(
    IConfigSectionNode^ other
) sealed
abstract IsSameNameAttr :
        other : IConfigSectionNode -> bool
override IsSameNameAttr :
        other : IConfigSectionNode -> bool
abstract IsSameNameAttr :
        other : IConfigSectionNode -> bool
override IsSameNameAttr :
        other : IConfigSectionNode -> bool

Parameters

other
Type: NFX.Environment IConfigSectionNode

Return Value

Type: Online Boolean

Implements

IConfigSectionNode IsSameNameAttr(IConfigSectionNode)
See Also
ConfigSectionNode Class
ConfigSectionNode Members
IsSameNameAttr Overload
NFX.Environment Namespace


ConfigSectionNode.MergeAttributes Method

ConfigSectionNode MergeAttributes Method NFX Class Library

Merges attributes from another node into this one. Another node may belong to a different configuration instance

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void MergeAttributes(
    IConfigSectionNode other,
    NodeOverrideRules rules = null
)
public void MergeAttributes(
    IConfigSectionNode other,
    NodeOverrideRules rules = null
)
Public Sub MergeAttributes (
    other As IConfigSectionNode,
    Optional rules As NodeOverrideRules = Nothing
)
Public Sub MergeAttributes (
    other As IConfigSectionNode,
    Optional rules As NodeOverrideRules = Nothing
)
public:
void MergeAttributes(
    IConfigSectionNode^ other,
    NodeOverrideRules^ rules = nullptr
)
public:
void MergeAttributes(
    IConfigSectionNode^ other,
    NodeOverrideRules^ rules = nullptr
)
member MergeAttributes :
        other : IConfigSectionNode *
        ?rules : NodeOverrideRules
(* Defaults:
        let _rules = defaultArg rules null
*)
-> unit
member MergeAttributes :
        other : IConfigSectionNode *
        ?rules : NodeOverrideRules
(* Defaults:
        let _rules = defaultArg rules null
*)
-> unit

Parameters

other
Type: NFX.Environment IConfigSectionNode
rules (Optional)
Type: NFX.Environment NodeOverrideRules
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.MergeSections Method

ConfigSectionNode MergeSections Method NFX Class Library

Merges child sections from another node into this one. Another node may belong to a different configuration instance. This method ignores override flags and merges nodes regardless

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void MergeSections(
    IConfigSectionNode other,
    NodeOverrideRules rules = null
)
public void MergeSections(
    IConfigSectionNode other,
    NodeOverrideRules rules = null
)
Public Sub MergeSections (
    other As IConfigSectionNode,
    Optional rules As NodeOverrideRules = Nothing
)
Public Sub MergeSections (
    other As IConfigSectionNode,
    Optional rules As NodeOverrideRules = Nothing
)
public:
void MergeSections(
    IConfigSectionNode^ other,
    NodeOverrideRules^ rules = nullptr
)
public:
void MergeSections(
    IConfigSectionNode^ other,
    NodeOverrideRules^ rules = nullptr
)
member MergeSections :
        other : IConfigSectionNode *
        ?rules : NodeOverrideRules
(* Defaults:
        let _rules = defaultArg rules null
*)
-> unit
member MergeSections :
        other : IConfigSectionNode *
        ?rules : NodeOverrideRules
(* Defaults:
        let _rules = defaultArg rules null
*)
-> unit

Parameters

other
Type: NFX.Environment IConfigSectionNode
rules (Optional)
Type: NFX.Environment NodeOverrideRules
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.Navigate Method

ConfigSectionNode Navigate Method NFX Class Library

Navigates the path and return the appropriate node. Example: '!/nfx/logger/destination/$file-name'

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigNode Navigate(
    string path
)
public ConfigNode Navigate(
    string path
)
Public Function Navigate (
    path As String
) As ConfigNode
Public Function Navigate (
    path As String
) As ConfigNode
public:
ConfigNode^ Navigate(
    String^ path
)
public:
ConfigNode^ Navigate(
    String^ path
)
member Navigate :
        path : string -> ConfigNode
member Navigate :
        path : string -> ConfigNode

Parameters

path
Type: Online System String
If path starts from '!' then exception will be thrown if such a node does not exist; Use '/' as leading char for root, '..' for step up, '$' for attribute name, [int] for access to subsection or attribute by index, section[value] for access using value comparison of named section, section[attr=value] for access using value of sections named attr Multiple paths may be coalesed using '|' or ';'

Return Value

Type: ConfigNode
Remarks
/table[patient] - get first section named "table" with value "patient" /[3] - get 4th child section from the root /table/$[2] - get 3rd attribute of first section named "table" /table[short-name=pat] - get first section named "table" having attribute named "short-name" equal "pat"
Examples
Navigate("/vars/[3]"); Navigate("/tables/table[resident]"); Navigate("/vars/var1/$[2]"); Navigate("/tables/table[name=patient]");
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.NavigateSection Method

ConfigSectionNode NavigateSection Method NFX Class Library

Navigates the path and return the appropriate section node. Example '!/nfx/logger/destination'

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigSectionNode NavigateSection(
    string path
)
public ConfigSectionNode NavigateSection(
    string path
)
Public Function NavigateSection (
    path As String
) As ConfigSectionNode
Public Function NavigateSection (
    path As String
) As ConfigSectionNode
public:
ConfigSectionNode^ NavigateSection(
    String^ path
)
public:
ConfigSectionNode^ NavigateSection(
    String^ path
)
member NavigateSection :
        path : string -> ConfigSectionNode
member NavigateSection :
        path : string -> ConfigSectionNode

Parameters

path
Type: Online System String
If path starts from '!' then exception will be thrown if such a section node does not exist; Use '/' as leading char for root, '..' for step up. Multiple paths may be coalesced using '|' or ';'

Return Value

Type: ConfigSectionNode
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.OverrideBy Method

ConfigSectionNode OverrideBy Method NFX Class Library

Merges another node data by overriding this node's value/attributes/sub nodes according to rules.

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool OverrideBy(
    IConfigSectionNode other,
    NodeOverrideRules rules = null
)
public bool OverrideBy(
    IConfigSectionNode other,
    NodeOverrideRules rules = null
)
Public Function OverrideBy (
    other As IConfigSectionNode,
    Optional rules As NodeOverrideRules = Nothing
) As Boolean
Public Function OverrideBy (
    other As IConfigSectionNode,
    Optional rules As NodeOverrideRules = Nothing
) As Boolean
public:
bool OverrideBy(
    IConfigSectionNode^ other,
    NodeOverrideRules^ rules = nullptr
)
public:
bool OverrideBy(
    IConfigSectionNode^ other,
    NodeOverrideRules^ rules = nullptr
)
member OverrideBy :
        other : IConfigSectionNode *
        ?rules : NodeOverrideRules
(* Defaults:
        let _rules = defaultArg rules null
*)
-> bool
member OverrideBy :
        other : IConfigSectionNode *
        ?rules : NodeOverrideRules
(* Defaults:
        let _rules = defaultArg rules null
*)
-> bool

Parameters

other
Type: NFX.Environment IConfigSectionNode
rules (Optional)
Type: NFX.Environment NodeOverrideRules

Return Value

Type: Online Boolean
True when merge match was made
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.ProcessIncludePragmas Method

ConfigSectionNode ProcessIncludePragmas Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Replaces all include pragmas - sections with specified names ('_include' by default), with pointed to configuration file content as obtained via the call to file system specified in every pragma. If no FS specified then LocalFileSystem is used. If no file name specified when try to allocate config node provider. Returns true if include pragmas were found. Note: this method does not process new include pragmas that may have fetched during this call. Caution: the file system used in the operation may rely on the App container that may need to be set-up for the call to succeed, therefore calling this method before app has activated may fail, in such cases a temp app container may be set to get the config file with processed includes, then the result may be passed to the primary app container ctor. This call is not logically thread-safe, it must be called from the main thread in the app

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ProcessIncludePragmas(
    bool recurse,
    string includePragma = null
)
public bool ProcessIncludePragmas(
    bool recurse,
    string includePragma = null
)
Public Function ProcessIncludePragmas (
    recurse As Boolean,
    Optional includePragma As String = Nothing
) As Boolean
Public Function ProcessIncludePragmas (
    recurse As Boolean,
    Optional includePragma As String = Nothing
) As Boolean
public:
bool ProcessIncludePragmas(
    bool recurse,
    String^ includePragma = nullptr
)
public:
bool ProcessIncludePragmas(
    bool recurse,
    String^ includePragma = nullptr
)
member ProcessIncludePragmas :
        recurse : bool *
        ?includePragma : string
(* Defaults:
        let _includePragma = defaultArg includePragma null
*)
-> bool
member ProcessIncludePragmas :
        recurse : bool *
        ?includePragma : string
(* Defaults:
        let _includePragma = defaultArg includePragma null
*)
-> bool

Parameters

recurse
Type: Online System Boolean
True to process inner nodes
includePragma (Optional)
Type: Online System String
Pragma section name, '_include' by default

Return Value

Type: Online Boolean
True if pragmas were found
Examples
nfx { sectionA{ a=2 b=3} _include { name=secret // '_include' will be replaced by 'secret' with sub-nodes from referenced file file="/etc/cluster/mysecret.laconf" //would come from local FS required=false //if file is not found then nothing will be included instead of '_include' which will be just removed } _include { // '_include' will be replaced by whatever root section content in the referenced file fs {type="NFX.Web.IO.FileSystem.SVNFileSystem, NFX.Web"} session { server-url="https://myhost.com/mySvnRepo/trunk/configs" user-name="user1" user-password="******"} } }
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.ReplaceBy Method

ConfigSectionNode ReplaceBy Method NFX Class Library

Completely replaces this node's attributes, value and children with data from another node

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ReplaceBy(
    IConfigSectionNode other
)
public void ReplaceBy(
    IConfigSectionNode other
)
Public Sub ReplaceBy (
    other As IConfigSectionNode
)
Public Sub ReplaceBy (
    other As IConfigSectionNode
)
public:
void ReplaceBy(
    IConfigSectionNode^ other
)
public:
void ReplaceBy(
    IConfigSectionNode^ other
)
member ReplaceBy :
        other : IConfigSectionNode -> unit
member ReplaceBy :
        other : IConfigSectionNode -> unit

Parameters

other
Type: NFX.Environment IConfigSectionNode
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.ResetModified Method

ConfigSectionNode ResetModified Method NFX Class Library

Resets modification of this an all child nodes

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void ResetModified()
public override void ResetModified()
Public Overrides Sub ResetModified
Public Overrides Sub ResetModified
public:
virtual void ResetModified() override
public:
virtual void ResetModified() override
abstract ResetModified : unit -> unit
override ResetModified : unit -> unit
abstract ResetModified : unit -> unit
override ResetModified : unit -> unit
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.ToConfigurationJSONDataMap Method

ConfigSectionNode ToConfigurationJSONDataMap Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns this config node as JSON data map suitable for making JSONConfiguration. Contrast with ToJSONDataMap

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDataMap ToConfigurationJSONDataMap()
public JSONDataMap ToConfigurationJSONDataMap()
Public Function ToConfigurationJSONDataMap As JSONDataMap
Public Function ToConfigurationJSONDataMap As JSONDataMap
public:
virtual JSONDataMap^ ToConfigurationJSONDataMap() sealed
public:
virtual JSONDataMap^ ToConfigurationJSONDataMap() sealed
abstract ToConfigurationJSONDataMap : unit -> JSONDataMap
override ToConfigurationJSONDataMap : unit -> JSONDataMap
abstract ToConfigurationJSONDataMap : unit -> JSONDataMap
override ToConfigurationJSONDataMap : unit -> JSONDataMap

Return Value

Type: JSONDataMap

Implements

IConfigSectionNode ToConfigurationJSONDataMap
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.ToJSONDataMap Method

ConfigSectionNode ToJSONDataMap Method NFX Class Library

Converts this ConfigSectionNode to JSONDataMap. Contrast with ToConfigurationJSONDataMap Be carefull: that this operation can "lose" data from ConfigSectionNode. In other words some ConfigSectionNode information can not be reflected in corresponding JSONDataMap, for example this method overwrites duplicate key names and does not support section values

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDataMap ToJSONDataMap()
public JSONDataMap ToJSONDataMap()
Public Function ToJSONDataMap As JSONDataMap
Public Function ToJSONDataMap As JSONDataMap
public:
virtual JSONDataMap^ ToJSONDataMap() sealed
public:
virtual JSONDataMap^ ToJSONDataMap() sealed
abstract ToJSONDataMap : unit -> JSONDataMap
override ToJSONDataMap : unit -> JSONDataMap
abstract ToJSONDataMap : unit -> JSONDataMap
override ToJSONDataMap : unit -> JSONDataMap

Return Value

Type: JSONDataMap

Implements

IConfigSectionNode ToJSONDataMap
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.ToJSONString Method

ConfigSectionNode ToJSONString Method NFX Class Library

Serializes configuration tree rooted at this node into JSON configuration format and returns it as a string

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ToJSONString(
    JSONWritingOptions options = null
)
public string ToJSONString(
    JSONWritingOptions options = null
)
Public Function ToJSONString (
    Optional options As JSONWritingOptions = Nothing
) As String
Public Function ToJSONString (
    Optional options As JSONWritingOptions = Nothing
) As String
public:
virtual String^ ToJSONString(
    JSONWritingOptions^ options = nullptr
) sealed
public:
virtual String^ ToJSONString(
    JSONWritingOptions^ options = nullptr
) sealed
abstract ToJSONString :
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> string
override ToJSONString :
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> string
abstract ToJSONString :
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> string
override ToJSONString :
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> string

Parameters

options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Return Value

Type: Online String

Implements

IConfigSectionNode ToJSONString(JSONWritingOptions)
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.ToLaconicString Method

ConfigSectionNode ToLaconicString Method NFX Class Library

Serializes configuration tree rooted at this node into Laconic format and returns it as a string

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ToLaconicString(
    LaconfigWritingOptions options = null
)
public string ToLaconicString(
    LaconfigWritingOptions options = null
)
Public Function ToLaconicString (
    Optional options As LaconfigWritingOptions = Nothing
) As String
Public Function ToLaconicString (
    Optional options As LaconfigWritingOptions = Nothing
) As String
public:
virtual String^ ToLaconicString(
    LaconfigWritingOptions^ options = nullptr
) sealed
public:
virtual String^ ToLaconicString(
    LaconfigWritingOptions^ options = nullptr
) sealed
abstract ToLaconicString :
        ?options : LaconfigWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> string
override ToLaconicString :
        ?options : LaconfigWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> string
abstract ToLaconicString :
        ?options : LaconfigWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> string
override ToLaconicString :
        ?options : LaconfigWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> string

Parameters

options (Optional)
Type: NFX.CodeAnalysis.Laconfig LaconfigWritingOptions

Return Value

Type: Online String

Implements

IConfigSectionNode ToLaconicString(LaconfigWritingOptions)
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode Properties

ConfigSectionNode Properties NFX Class Library

The ConfigSectionNode type exposes the following members.
Properties
 | Name | Description
Public property | AttrCount | Returns number of child attribute nodes
Public property | Attributes | Enumerates all attribute nodes
Public property | ChildCount | Returns number of child section nodes
Public property | Children | Enumerates all child nodes
Public property | Configuration | References configuration this node is under (Inherited from ConfigNode.)
Public property | EvaluatedValue | Returns null or value of this node with all variables evaluated (Inherited from ConfigNode.)
Public property | Exists | Determines whether this node really exists in configuration or is just a sentinel empty node (Inherited from ConfigNode.)
Public property | HasAttributes | Indicates whether this node has any associated attributes
Public property | HasChildren | Indicates whether this node has any child section nodes
Public property | Item Int32 | Retrieves section node by index or empty node instance if section node with such index could not be found
Public property | Item String | Retrieves section node by names, from left to right until existing node is found. If no existing node could be found then empty node instance is returned
Public property | Modified | Indicates whether this or any child nodes or attributes were modified (Overrides ConfigNode Modified.)
Public property | Name | Retrieves node name (Inherited from ConfigNode.)
Public property | Parent | References parent node or Empty if this node has no parent (Inherited from ConfigNode.)
Public property | RootPath | Returns path from root to this node (Inherited from ConfigNode.)
Public property | Value | Retrieves node value or null. The value getter performs evaluation of variables, while setter sets the value verbatim (Inherited from ConfigNode.)
Public property | VerbatimValue | Returns verbatim (without variable evaluation) node value or null (Inherited from ConfigNode.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IConfigNode Parent | References parent node (Inherited from ConfigNode.)
Explicit interface implemetation | IConfigNode RootPath | (Inherited from ConfigNode.)
Explicit interface implemetation | IConfigSectionNode Attributes |
Explicit interface implemetation | IConfigSectionNode Children |
Explicit interface implemetation | IConfigSectionNode Item Int32 |
Explicit interface implemetation | IConfigSectionNode Item String |
Back to Top
See Also
ConfigSectionNode Class
NFX.Environment Namespace


ConfigSectionNode.AttrCount Property

ConfigSectionNode AttrCount Property NFX Class Library

Returns number of child attribute nodes

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int AttrCount { get; }
public int AttrCount { get; }
Public ReadOnly Property AttrCount As Integer
    Get
Public ReadOnly Property AttrCount As Integer
    Get
public:
virtual property int AttrCount {
    int get () sealed;
}
public:
virtual property int AttrCount {
    int get () sealed;
}
abstract AttrCount : int with get
override AttrCount : int with get
abstract AttrCount : int with get
override AttrCount : int with get

Property Value

Type: Online Int32

Implements

IConfigSectionNode AttrCount
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.Attributes Property

ConfigSectionNode Attributes Property NFX Class Library

Enumerates all attribute nodes

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<ConfigAttrNode> Attributes { get; }
public IEnumerable<ConfigAttrNode> Attributes { get; }
Public ReadOnly Property Attributes As IEnumerable(Of ConfigAttrNode)
    Get
Public ReadOnly Property Attributes As IEnumerable(Of ConfigAttrNode)
    Get
public:
property IEnumerable<ConfigAttrNode^>^ Attributes {
    IEnumerable<ConfigAttrNode^>^ get ();
}
public:
property IEnumerable<ConfigAttrNode^>^ Attributes {
    IEnumerable<ConfigAttrNode^>^ get ();
}
member Attributes : IEnumerable<ConfigAttrNode> with get
member Attributes : IEnumerable<ConfigAttrNode> with get

Property Value

Type: Online IEnumerable ConfigAttrNode
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.ChildCount Property

ConfigSectionNode ChildCount Property NFX Class Library

Returns number of child section nodes

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ChildCount { get; }
public int ChildCount { get; }
Public ReadOnly Property ChildCount As Integer
    Get
Public ReadOnly Property ChildCount As Integer
    Get
public:
virtual property int ChildCount {
    int get () sealed;
}
public:
virtual property int ChildCount {
    int get () sealed;
}
abstract ChildCount : int with get
override ChildCount : int with get
abstract ChildCount : int with get
override ChildCount : int with get

Property Value

Type: Online Int32

Implements

IConfigSectionNode ChildCount
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.Children Property

ConfigSectionNode Children Property NFX Class Library

Enumerates all child nodes

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<ConfigSectionNode> Children { get; }
public IEnumerable<ConfigSectionNode> Children { get; }
Public ReadOnly Property Children As IEnumerable(Of ConfigSectionNode)
    Get
Public ReadOnly Property Children As IEnumerable(Of ConfigSectionNode)
    Get
public:
property IEnumerable<ConfigSectionNode^>^ Children {
    IEnumerable<ConfigSectionNode^>^ get ();
}
public:
property IEnumerable<ConfigSectionNode^>^ Children {
    IEnumerable<ConfigSectionNode^>^ get ();
}
member Children : IEnumerable<ConfigSectionNode> with get
member Children : IEnumerable<ConfigSectionNode> with get

Property Value

Type: Online IEnumerable ConfigSectionNode
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.HasAttributes Property

ConfigSectionNode HasAttributes Property NFX Class Library

Indicates whether this node has any associated attributes

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasAttributes { get; }
public bool HasAttributes { get; }
Public ReadOnly Property HasAttributes As Boolean
    Get
Public ReadOnly Property HasAttributes As Boolean
    Get
public:
virtual property bool HasAttributes {
    bool get () sealed;
}
public:
virtual property bool HasAttributes {
    bool get () sealed;
}
abstract HasAttributes : bool with get
override HasAttributes : bool with get
abstract HasAttributes : bool with get
override HasAttributes : bool with get

Property Value

Type: Online Boolean

Implements

IConfigSectionNode HasAttributes
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.HasChildren Property

ConfigSectionNode HasChildren Property NFX Class Library

Indicates whether this node has any child section nodes

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasChildren { get; }
public bool HasChildren { get; }
Public ReadOnly Property HasChildren As Boolean
    Get
Public ReadOnly Property HasChildren As Boolean
    Get
public:
virtual property bool HasChildren {
    bool get () sealed;
}
public:
virtual property bool HasChildren {
    bool get () sealed;
}
abstract HasChildren : bool with get
override HasChildren : bool with get
abstract HasChildren : bool with get
override HasChildren : bool with get

Property Value

Type: Online Boolean

Implements

IConfigSectionNode HasChildren
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.IConfigSectionNode.Attributes Property

ConfigSectionNode IConfigSectionNode Attributes Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<IConfigAttrNode> IConfigSectionNode.Attributes { get; }
IEnumerable<IConfigAttrNode> IConfigSectionNode.Attributes { get; }
Private ReadOnly Property Attributes As IEnumerable(Of IConfigAttrNode)
    Implements IConfigSectionNode.Attributes
    Get
Private ReadOnly Property Attributes As IEnumerable(Of IConfigAttrNode)
    Implements IConfigSectionNode.Attributes
    Get
private:
virtual property IEnumerable<IConfigAttrNode^>^ Attributes {
    IEnumerable<IConfigAttrNode^>^ get () sealed = IConfigSectionNode::Attributes::get;
}
private:
virtual property IEnumerable<IConfigAttrNode^>^ Attributes {
    IEnumerable<IConfigAttrNode^>^ get () sealed = IConfigSectionNode::Attributes::get;
}
private abstract Attributes : IEnumerable<IConfigAttrNode> with get
private override Attributes : IEnumerable<IConfigAttrNode> with get
private abstract Attributes : IEnumerable<IConfigAttrNode> with get
private override Attributes : IEnumerable<IConfigAttrNode> with get

Property Value

Type: Online IEnumerable IConfigAttrNode

Implements

IConfigSectionNode Attributes
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.IConfigSectionNode.Children Property

ConfigSectionNode IConfigSectionNode Children Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<IConfigSectionNode> IConfigSectionNode.Children { get; }
IEnumerable<IConfigSectionNode> IConfigSectionNode.Children { get; }
Private ReadOnly Property Children As IEnumerable(Of IConfigSectionNode)
    Implements IConfigSectionNode.Children
    Get
Private ReadOnly Property Children As IEnumerable(Of IConfigSectionNode)
    Implements IConfigSectionNode.Children
    Get
private:
virtual property IEnumerable<IConfigSectionNode^>^ Children {
    IEnumerable<IConfigSectionNode^>^ get () sealed = IConfigSectionNode::Children::get;
}
private:
virtual property IEnumerable<IConfigSectionNode^>^ Children {
    IEnumerable<IConfigSectionNode^>^ get () sealed = IConfigSectionNode::Children::get;
}
private abstract Children : IEnumerable<IConfigSectionNode> with get
private override Children : IEnumerable<IConfigSectionNode> with get
private abstract Children : IEnumerable<IConfigSectionNode> with get
private override Children : IEnumerable<IConfigSectionNode> with get

Property Value

Type: Online IEnumerable IConfigSectionNode

Implements

IConfigSectionNode Children
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.Item Property

ConfigSectionNode Item Property NFX Class Library

Overload List
 | Name | Description
Public property | Item Int32 | Retrieves section node by index or empty node instance if section node with such index could not be found
Public property | Item String | Retrieves section node by names, from left to right until existing node is found. If no existing node could be found then empty node instance is returned
Back to Top
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.Item Property (Int32)

ConfigSectionNode Item Property (Int32) NFX Class Library

Retrieves section node by index or empty node instance if section node with such index could not be found

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigSectionNode this[
    int idx
] { get; }
public ConfigSectionNode this[
    int idx
] { get; }
Public ReadOnly Default Property Item (
    idx As Integer
) As ConfigSectionNode
    Get
Public ReadOnly Default Property Item (
    idx As Integer
) As ConfigSectionNode
    Get
public:
property ConfigSectionNode^ default[int idx] {
    ConfigSectionNode^ get (int idx);
}
public:
property ConfigSectionNode^ default[int idx] {
    ConfigSectionNode^ get (int idx);
}
member Item : ConfigSectionNode with get
member Item : ConfigSectionNode with get

Parameters

idx
Type: Online System Int32

Property Value

Type: ConfigSectionNode
See Also
ConfigSectionNode Class
ConfigSectionNode Members
Item Overload
NFX.Environment Namespace


ConfigSectionNode.Item Property (String[])

ConfigSectionNode Item Property ( String ) NFX Class Library

Retrieves section node by names, from left to right until existing node is found. If no existing node could be found then empty node instance is returned

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigSectionNode this[
    params string[] names
] { get; }
public ConfigSectionNode this[
    params string[] names
] { get; }
Public ReadOnly Default Property Item (
    ParamArray names As String()
) As ConfigSectionNode
    Get
Public ReadOnly Default Property Item (
    ParamArray names As String()
) As ConfigSectionNode
    Get
public:
property ConfigSectionNode^ default[... array<String^>^ names] {
    ConfigSectionNode^ get (... array<String^>^ names);
}
public:
property ConfigSectionNode^ default[... array<String^>^ names] {
    ConfigSectionNode^ get (... array<String^>^ names);
}
member Item : ConfigSectionNode with get
member Item : ConfigSectionNode with get

Parameters

names
Type: Online System String

Property Value

Type: ConfigSectionNode
See Also
ConfigSectionNode Class
ConfigSectionNode Members
Item Overload
NFX.Environment Namespace


ConfigSectionNode.Item Property

ConfigSectionNode Item Property NFX Class Library

Overload List
 | Name | Description
Explicit interface implemetation | IConfigSectionNode Item Int32 |
Explicit interface implemetation | IConfigSectionNode Item String |
Back to Top
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNode.IConfigSectionNode.Item Property (Int32)

ConfigSectionNode IConfigSectionNode Item Property (Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IConfigSectionNode IConfigSectionNode.this[
    int idx
] { get; }
IConfigSectionNode IConfigSectionNode.this[
    int idx
] { get; }
Private ReadOnly Property Item (
    idx As Integer
) As IConfigSectionNode Implements IConfigSectionNode.Item
    Get
Private ReadOnly Property Item (
    idx As Integer
) As IConfigSectionNode Implements IConfigSectionNode.Item
    Get
private:
virtual property IConfigSectionNode^ Item[int idx] {
    IConfigSectionNode^ get (int idx) sealed = IConfigSectionNode::Item::get;
}
private:
virtual property IConfigSectionNode^ Item[int idx] {
    IConfigSectionNode^ get (int idx) sealed = IConfigSectionNode::Item::get;
}
private abstract Item : IConfigSectionNode with get
private override Item : IConfigSectionNode with get
private abstract Item : IConfigSectionNode with get
private override Item : IConfigSectionNode with get

Parameters

idx
Type: Online System Int32

Property Value

Type: IConfigSectionNode

Implements

IConfigSectionNode Item Int32
See Also
ConfigSectionNode Class
ConfigSectionNode Members
Item Overload
NFX.Environment Namespace


ConfigSectionNode.IConfigSectionNode.Item Property (String[])

ConfigSectionNode IConfigSectionNode Item Property ( String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IConfigSectionNode IConfigSectionNode.this[
    params string[] names
] { get; }
IConfigSectionNode IConfigSectionNode.this[
    params string[] names
] { get; }
Private ReadOnly Property Item (
    ParamArray names As String()
) As IConfigSectionNode Implements IConfigSectionNode.Item
    Get
Private ReadOnly Property Item (
    ParamArray names As String()
) As IConfigSectionNode Implements IConfigSectionNode.Item
    Get
private:
virtual property IConfigSectionNode^ Item[... array<String^>^ names] {
    IConfigSectionNode^ get (... array<String^>^ names) sealed = IConfigSectionNode::Item::get;
}
private:
virtual property IConfigSectionNode^ Item[... array<String^>^ names] {
    IConfigSectionNode^ get (... array<String^>^ names) sealed = IConfigSectionNode::Item::get;
}
private abstract Item : IConfigSectionNode with get
private override Item : IConfigSectionNode with get
private abstract Item : IConfigSectionNode with get
private override Item : IConfigSectionNode with get

Parameters

names
Type: Online System String

Property Value

Type: IConfigSectionNode

Implements

IConfigSectionNode Item String
See Also
ConfigSectionNode Class
ConfigSectionNode Members
Item Overload
NFX.Environment Namespace


ConfigSectionNode.Modified Property

ConfigSectionNode Modified Property NFX Class Library

Indicates whether this or any child nodes or attributes were modified

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Modified { get; }
public override bool Modified { get; }
Public Overrides ReadOnly Property Modified As Boolean
    Get
Public Overrides ReadOnly Property Modified As Boolean
    Get
public:
virtual property bool Modified {
    bool get () override;
}
public:
virtual property bool Modified {
    bool get () override;
}
abstract Modified : bool with get
override Modified : bool with get
abstract Modified : bool with get
override Modified : bool with get

Property Value

Type: Online Boolean
See Also
ConfigSectionNode Class
ConfigSectionNode Members
NFX.Environment Namespace


ConfigSectionNodeList Class

ConfigSectionNodeList Class NFX Class Library

Inheritance Hierarchy
Online System Object
Online System.Collections.Generic List ConfigSectionNode
NFX.Environment ConfigSectionNodeList

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
internal class ConfigSectionNodeList : List<ConfigSectionNode>
[SerializableAttribute]
internal class ConfigSectionNodeList : List<ConfigSectionNode>
<SerializableAttribute>
Friend Class ConfigSectionNodeList
    Inherits List(Of ConfigSectionNode)
<SerializableAttribute>
Friend Class ConfigSectionNodeList
    Inherits List(Of ConfigSectionNode)
[SerializableAttribute]
internal ref class ConfigSectionNodeList : public List<ConfigSectionNode^>
[SerializableAttribute]
internal ref class ConfigSectionNodeList : public List<ConfigSectionNode^>
[<SerializableAttribute>]
type ConfigSectionNodeList =
    class
        inherit List<ConfigSectionNode>
    end
[<SerializableAttribute>]
type ConfigSectionNodeList =
    class
        inherit List<ConfigSectionNode>
    end
See Also
ConfigSectionNodeList Members
NFX.Environment Namespace


ConfigSectionNodeList Members

ConfigSectionNodeList Members NFX Class Library

The ConfigSectionNodeList type exposes the following members.
Constructors
 | Name | Description
Public method | ConfigSectionNodeList | Initializes a new instance of the ConfigSectionNodeList class
Back to Top
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List ConfigSectionNode .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List ConfigSectionNode .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List ConfigSectionNode .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List ConfigSectionNode .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List ConfigSectionNode .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List ConfigSectionNode .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List ConfigSectionNode .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List ConfigSectionNode .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List ConfigSectionNode .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List ConfigSectionNode .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List ConfigSectionNode .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List ConfigSectionNode .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List ConfigSectionNode .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List ConfigSectionNode .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List ConfigSectionNode .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List ConfigSectionNode .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List ConfigSectionNode .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List ConfigSectionNode .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List ConfigSectionNode .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List ConfigSectionNode .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List ConfigSectionNode .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List ConfigSectionNode .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List ConfigSectionNode .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List ConfigSectionNode .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List ConfigSectionNode .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List ConfigSectionNode .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List ConfigSectionNode .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List ConfigSectionNode .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List ConfigSectionNode .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List ConfigSectionNode .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List ConfigSectionNode .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List ConfigSectionNode .)
Back to Top
See Also
ConfigSectionNodeList Class
NFX.Environment Namespace


ConfigSectionNodeList Constructor

ConfigSectionNodeList Constructor NFX Class Library

Initializes a new instance of the ConfigSectionNodeList class

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigSectionNodeList()
public ConfigSectionNodeList()
Public Sub New
Public Sub New
public:
ConfigSectionNodeList()
public:
ConfigSectionNodeList()
new : unit -> ConfigSectionNodeList
new : unit -> ConfigSectionNodeList
See Also
ConfigSectionNodeList Class
ConfigSectionNodeList Members
NFX.Environment Namespace


ConfigSectionNodeList Methods

ConfigSectionNodeList Methods NFX Class Library

The ConfigSectionNodeList type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List ConfigSectionNode .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List ConfigSectionNode .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List ConfigSectionNode .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List ConfigSectionNode .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List ConfigSectionNode .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List ConfigSectionNode .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List ConfigSectionNode .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List ConfigSectionNode .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List ConfigSectionNode .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List ConfigSectionNode .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List ConfigSectionNode .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List ConfigSectionNode .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List ConfigSectionNode .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List ConfigSectionNode .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List ConfigSectionNode .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List ConfigSectionNode .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List ConfigSectionNode .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List ConfigSectionNode .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List ConfigSectionNode .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List ConfigSectionNode .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List ConfigSectionNode .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List ConfigSectionNode .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List ConfigSectionNode .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List ConfigSectionNode .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List ConfigSectionNode .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List ConfigSectionNode .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List ConfigSectionNode .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List ConfigSectionNode .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List ConfigSectionNode .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List ConfigSectionNode .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ConfigSectionNodeList Class
NFX.Environment Namespace


ConfigSectionNodeList Properties

ConfigSectionNodeList Properties NFX Class Library

The ConfigSectionNodeList type exposes the following members.
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List ConfigSectionNode .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List ConfigSectionNode .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List ConfigSectionNode .)
Back to Top
See Also
ConfigSectionNodeList Class
NFX.Environment Namespace


ConfigStringBuilder Class

ConfigStringBuilder Class NFX Class Library

Facilitates the creation/building of strings from existing strings or configuration vectors. This is used for example to build DB connect strings from host names that need to be resolved via an external system
Inheritance Hierarchy
Online System Object
NFX.Environment ConfigStringBuilder

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class ConfigStringBuilder
public static class ConfigStringBuilder
Public NotInheritable Class ConfigStringBuilder
Public NotInheritable Class ConfigStringBuilder
public ref class ConfigStringBuilder abstract sealed
public ref class ConfigStringBuilder abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ConfigStringBuilder =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ConfigStringBuilder =  class end
See Also
ConfigStringBuilder Members
NFX.Environment Namespace


ConfigStringBuilder Members

ConfigStringBuilder Members NFX Class Library

Methods
Name | Description
Build(IConfigNode) | Builds the string based on the configured state supplied as a config vector, or passes the supplied string through if it is not a loaconic vector with CONFIG_BUILDER_ROOT
Build(IConfigSectionNode, String) | Builds the string based on the configured state supplied as a config vector, or passes the supplied string through if it is not a loaconic vector with CONFIG_BUILDER_ROOT
Back to Top
See Also
ConfigStringBuilder Class
NFX.Environment Namespace


ConfigStringBuilder Methods

ConfigStringBuilder Methods NFX Class Library

Methods
Name | Description
Build(IConfigNode) | Builds the string based on the configured state supplied as a config vector, or passes the supplied string through if it is not a loaconic vector with CONFIG_BUILDER_ROOT
Build(IConfigSectionNode, String) | Builds the string based on the configured state supplied as a config vector, or passes the supplied string through if it is not a loaconic vector with CONFIG_BUILDER_ROOT
Back to Top
See Also
ConfigStringBuilder Class
NFX.Environment Namespace


ConfigStringBuilder.Build Method

ConfigStringBuilder Build Method NFX Class Library

Overload List
Name | Description
Build(IConfigNode) | Builds the string based on the configured state supplied as a config vector, or passes the supplied string through if it is not a loaconic vector with CONFIG_BUILDER_ROOT
Build(IConfigSectionNode, String) | Builds the string based on the configured state supplied as a config vector, or passes the supplied string through if it is not a loaconic vector with CONFIG_BUILDER_ROOT
Back to Top
See Also
ConfigStringBuilder Class
ConfigStringBuilder Members
NFX.Environment Namespace


ConfigStringBuilder.Build Method (IConfigNode)

ConfigStringBuilder Build Method (IConfigNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Builds the string based on the configured state supplied as a config vector, or passes the supplied string through if it is not a loaconic vector with CONFIG_BUILDER_ROOT

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Build(
    IConfigNode source
)
public static string Build(
    IConfigNode source
)
Public Shared Function Build (
    source As IConfigNode
) As String
Public Shared Function Build (
    source As IConfigNode
) As String
public:
static String^ Build(
    IConfigNode^ source
)
public:
static String^ Build(
    IConfigNode^ source
)
static member Build :
        source : IConfigNode -> string
static member Build :
        source : IConfigNode -> string

Parameters

source
Type: NFX.Environment IConfigNode
The original source which may be IConfigStringBuilder injector or attribute value

Return Value

Type: Online String
The original attribute string value or the string returnd by IConfigStringBuilder.BuildString() method if IConfigStringBuilder was specified
See Also
ConfigStringBuilder Class
ConfigStringBuilder Members
Build Overload
NFX.Environment Namespace


ConfigStringBuilder.Build Method (IConfigSectionNode, String)

ConfigStringBuilder Build Method (IConfigSectionNode, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Builds the string based on the configured state supplied as a config vector, or passes the supplied string through if it is not a loaconic vector with CONFIG_BUILDER_ROOT

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Build(
    IConfigSectionNode level,
    string sectionOrAttributeName
)
public static string Build(
    IConfigSectionNode level,
    string sectionOrAttributeName
)
Public Shared Function Build (
    level As IConfigSectionNode,
    sectionOrAttributeName As String
) As String
Public Shared Function Build (
    level As IConfigSectionNode,
    sectionOrAttributeName As String
) As String
public:
static String^ Build(
    IConfigSectionNode^ level,
    String^ sectionOrAttributeName
)
public:
static String^ Build(
    IConfigSectionNode^ level,
    String^ sectionOrAttributeName
)
static member Build :
        level : IConfigSectionNode *
        sectionOrAttributeName : string -> string
static member Build :
        level : IConfigSectionNode *
        sectionOrAttributeName : string -> string

Parameters

level
Type: NFX.Environment IConfigSectionNode
The configuration section level
sectionOrAttributeName
Type: Online System String
The name of section or attribute at the specified level

Return Value

Type: Online String
The original attribute string value or the string returnd by IConfigStringBuilder.BuildString() method if IConfigStringBuilder was specified
See Also
ConfigStringBuilder Class
ConfigStringBuilder Members
Build Overload
NFX.Environment Namespace


Configuration Class

Configuration Class NFX Class Library

Provides top-level configuration abstraction
Inheritance Hierarchy
Online System Object
NFX.Environment Configuration
NFX.Environment CommandArgsConfiguration
NFX.Environment FileConfiguration
NFX.Environment MemoryConfiguration

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class Configuration : ICloneable
[SerializableAttribute]
public abstract class Configuration : ICloneable
<SerializableAttribute>
Public MustInherit Class Configuration
    Implements ICloneable
<SerializableAttribute>
Public MustInherit Class Configuration
    Implements ICloneable
[SerializableAttribute]
public ref class Configuration abstract : ICloneable
[SerializableAttribute]
public ref class Configuration abstract : ICloneable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type Configuration =
    class
        interface ICloneable
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type Configuration =
    class
        interface ICloneable
    end
See Also
Configuration Members
NFX.Environment Namespace


Configuration Members

Configuration Members NFX Class Library

The Configuration type exposes the following members.
Constructors
 | Name | Description
Protected method | Configuration | Initializes a new instance of the Configuration class
Back to Top
Methods
 | Name | Description
Protected method | AdjustNodeName | Override to perform transforms on node names so they become suitable for particular configuration type
Public method | CheckAndAdjustNodeName | Checks node name for aptitude for particular configuration type. For example, XML configuration does not allow nodes with spaces or separator chars. When StrictNames is set to true and value is not appropriate then exception is thrown
Public method | Clone | Implements IClonable by returning new MemoryConfiguration clone
Public method | Clone(Configuration) | Creates a deep copy of this configuration into newInstance which was allocated externally
Public method | Clone T | Creates a deep copy of this configuration into new instance of T
Public method | Create | Creates new configuration - creates new configuration root with optional name parameter
Public method | CreateFromMerge | Creates new configuration from ordered merge result of two other nodes - base and override which can be from different configurations
Public method | CreateFromNode | Creates new configuration from other node, which may belong to a different configuration instance
Public method | Destroy | Erases all config data
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Include | Completely replaces this node with another node tree, positioning the new tree in the place of local node. Existing node is deleted after this operation completes, in its place child nodes from other node are inserted preserving their existing order. Attributes of other node get merged into parent of existing node
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | NewEmptyRoot | Creates a new empty config root based on laconic format
 | ProviderLoadFromAnySupportedFormatFile | Loads the contents of the supplied file name without format extension trying to match any of the supported format extensions. When match is found the file is loaded via an appropriate configuration provider
 | ProviderLoadFromFile | Loads the contents of the supplied file name in an appropriate configuration provider implementation for the supplied extension format
 | ProviderLoadFromString | Loads the supplied string content in the specified format, which may be format name like "xml" or "laconfig" with or without extension period
Public method | Refresh | Re-reads configuration from source
Public method | ResolveEnvironmentVar | Resolves variable name into its value
Public method | RunMacro | Runs macro and returns its value
Public method | Save | Saves configuration to source
Public method | ToConfigurationJSONDataMap | Returns this config as JSON data map suitable for making JSONConfiguration
Public method | ToLaconicFile | Serializes configuration tree into Laconic format and writes it into a file
Public method | ToLaconicStream | Serializes configuration tree into Laconic format and writes it into stream
Public method | ToLaconicString | Serializes configuration tree into Laconic format and returns it as a string
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | CONFIG_INCLUDE_PRAGMA_FILE_ATTR |
 | CONFIG_INCLUDE_PRAGMA_FS_SECTION |
 | CONFIG_INCLUDE_PRAGMA_PROVIDER_SECTION |
 | CONFIG_INCLUDE_PRAGMA_REQUIRED_ATTR |
 | CONFIG_INCLUDE_PRAGMA_SESSION_SECTION |
 | CONFIG_LACONIC_FORMAT |
 | CONFIG_NAME_ATTR |
 | CONFIG_ORDER_ATTR |
 | DEFAULT_CONFIG_INCLUDE_PRAGMA |
 | DEFAULT_VAR_END |
 | DEFAULT_VAR_ENV_MOD |
 | DEFAULT_VAR_ESCAPE |
 | DEFAULT_VAR_MACRO_START |
 | DEFAULT_VAR_PATH_MOD |
 | DEFAULT_VAR_START |
Protected field | m_EmptyAttrNode |
Protected field | m_EmptySectionNode |
Protected field | m_Root |
 | ProcesswideConfigNodeProviderType | Gets/sets global implementor of IConfigNodeProvider that is used by all configurations in this process instance when type is not specified
 | ProcesswideEnvironmentVarResolver | Gets/sets global Environment variable resolver that is used by all configurations in this process instance
Back to Top
Properties
 | Name | Description
 | AllSupportedFormats | Returns all configuration file formats (file extensions without '.') supported by ProviderLoadFromFile/ProviderLoadFromAnySupportedFormatFile/ProviderLoadFromString
Public property | ContentView | Primarily used for debugging - returns the content of the configuration as text in the pretty-printed Laconic format
Public property | EmptyAttr | References a special instance of an empty attribute node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist
Public property | EmptySection | References a special instance of an empty section node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist
Public property | EnvironmentVarResolver | References variable resolver. If this property is not set then default Windows environment var resolver is used
Public property | IsReadOnly | Indicates whether configuration is read-only
Public property | MacroRunner | References macro runner. If this property is not set then default macro runner is used
Public property | MacroRunnerContext | Gets/sets an object passed by the framework into MacroRunner.Run() method. This property is auto-set for classes decorated with [ConfigMacroContext] attribute
Public property | Root | Accesses root section configuration node
Public property | StrictNames | Determines whether exception is thrown when configuration node name contains inappropriate chars for particular configuration type. For example, for XMLConfiguration node names may not have spaces and other separator chars. When StrictNames is false then particular configurations may replace incompatible chars in node names with neutral ones (i.e. "my value"->"my-value" in case of XMLConfiguration).
Public property | Variable_END | Variable end tag
Public property | Variable_ENV_MOD | Variable environment modifier
Public property | Variable_ESCAPE | Variable escape tag
Public property | Variable_MACRO_START | Variable get clause modifier
Public property | Variable_PATH_MOD | Variable path modifier
Public property | Variable_START | Variable start tag
Back to Top
See Also
Configuration Class
NFX.Environment Namespace


Configuration Constructor

Configuration Constructor NFX Class Library

Initializes a new instance of the Configuration class

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Configuration()
protected Configuration()
Protected Sub New
Protected Sub New
protected:
Configuration()
protected:
Configuration()
new : unit -> Configuration
new : unit -> Configuration
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration Fields

Configuration Fields NFX Class Library

The Configuration type exposes the following members.
Fields
 | Name | Description
 | CONFIG_INCLUDE_PRAGMA_FILE_ATTR |
 | CONFIG_INCLUDE_PRAGMA_FS_SECTION |
 | CONFIG_INCLUDE_PRAGMA_PROVIDER_SECTION |
 | CONFIG_INCLUDE_PRAGMA_REQUIRED_ATTR |
 | CONFIG_INCLUDE_PRAGMA_SESSION_SECTION |
 | CONFIG_LACONIC_FORMAT |
 | CONFIG_NAME_ATTR |
 | CONFIG_ORDER_ATTR |
 | DEFAULT_CONFIG_INCLUDE_PRAGMA |
 | DEFAULT_VAR_END |
 | DEFAULT_VAR_ENV_MOD |
 | DEFAULT_VAR_ESCAPE |
 | DEFAULT_VAR_MACRO_START |
 | DEFAULT_VAR_PATH_MOD |
 | DEFAULT_VAR_START |
Protected field | m_EmptyAttrNode |
Protected field | m_EmptySectionNode |
Protected field | m_Root |
 | ProcesswideConfigNodeProviderType | Gets/sets global implementor of IConfigNodeProvider that is used by all configurations in this process instance when type is not specified
 | ProcesswideEnvironmentVarResolver | Gets/sets global Environment variable resolver that is used by all configurations in this process instance
Back to Top
See Also
Configuration Class
NFX.Environment Namespace


Configuration.CONFIG_INCLUDE_PRAGMA_FILE_ATTR Field

Configuration CONFIG_INCLUDE_PRAGMA_FILE_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_INCLUDE_PRAGMA_FILE_ATTR
public const string CONFIG_INCLUDE_PRAGMA_FILE_ATTR
Public Const CONFIG_INCLUDE_PRAGMA_FILE_ATTR As String
Public Const CONFIG_INCLUDE_PRAGMA_FILE_ATTR As String
public:
literal String^ CONFIG_INCLUDE_PRAGMA_FILE_ATTR
public:
literal String^ CONFIG_INCLUDE_PRAGMA_FILE_ATTR
static val mutable CONFIG_INCLUDE_PRAGMA_FILE_ATTR: string
static val mutable CONFIG_INCLUDE_PRAGMA_FILE_ATTR: string

Field Value

Type: Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.CONFIG_INCLUDE_PRAGMA_FS_SECTION Field

Configuration CONFIG_INCLUDE_PRAGMA_FS_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_INCLUDE_PRAGMA_FS_SECTION
public const string CONFIG_INCLUDE_PRAGMA_FS_SECTION
Public Const CONFIG_INCLUDE_PRAGMA_FS_SECTION As String
Public Const CONFIG_INCLUDE_PRAGMA_FS_SECTION As String
public:
literal String^ CONFIG_INCLUDE_PRAGMA_FS_SECTION
public:
literal String^ CONFIG_INCLUDE_PRAGMA_FS_SECTION
static val mutable CONFIG_INCLUDE_PRAGMA_FS_SECTION: string
static val mutable CONFIG_INCLUDE_PRAGMA_FS_SECTION: string

Field Value

Type: Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.CONFIG_INCLUDE_PRAGMA_PROVIDER_SECTION Field

Configuration CONFIG_INCLUDE_PRAGMA_PROVIDER_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_INCLUDE_PRAGMA_PROVIDER_SECTION
public const string CONFIG_INCLUDE_PRAGMA_PROVIDER_SECTION
Public Const CONFIG_INCLUDE_PRAGMA_PROVIDER_SECTION As String
Public Const CONFIG_INCLUDE_PRAGMA_PROVIDER_SECTION As String
public:
literal String^ CONFIG_INCLUDE_PRAGMA_PROVIDER_SECTION
public:
literal String^ CONFIG_INCLUDE_PRAGMA_PROVIDER_SECTION
static val mutable CONFIG_INCLUDE_PRAGMA_PROVIDER_SECTION: string
static val mutable CONFIG_INCLUDE_PRAGMA_PROVIDER_SECTION: string

Field Value

Type: Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.CONFIG_INCLUDE_PRAGMA_REQUIRED_ATTR Field

Configuration CONFIG_INCLUDE_PRAGMA_REQUIRED_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_INCLUDE_PRAGMA_REQUIRED_ATTR
public const string CONFIG_INCLUDE_PRAGMA_REQUIRED_ATTR
Public Const CONFIG_INCLUDE_PRAGMA_REQUIRED_ATTR As String
Public Const CONFIG_INCLUDE_PRAGMA_REQUIRED_ATTR As String
public:
literal String^ CONFIG_INCLUDE_PRAGMA_REQUIRED_ATTR
public:
literal String^ CONFIG_INCLUDE_PRAGMA_REQUIRED_ATTR
static val mutable CONFIG_INCLUDE_PRAGMA_REQUIRED_ATTR: string
static val mutable CONFIG_INCLUDE_PRAGMA_REQUIRED_ATTR: string

Field Value

Type: Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.CONFIG_INCLUDE_PRAGMA_SESSION_SECTION Field

Configuration CONFIG_INCLUDE_PRAGMA_SESSION_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_INCLUDE_PRAGMA_SESSION_SECTION
public const string CONFIG_INCLUDE_PRAGMA_SESSION_SECTION
Public Const CONFIG_INCLUDE_PRAGMA_SESSION_SECTION As String
Public Const CONFIG_INCLUDE_PRAGMA_SESSION_SECTION As String
public:
literal String^ CONFIG_INCLUDE_PRAGMA_SESSION_SECTION
public:
literal String^ CONFIG_INCLUDE_PRAGMA_SESSION_SECTION
static val mutable CONFIG_INCLUDE_PRAGMA_SESSION_SECTION: string
static val mutable CONFIG_INCLUDE_PRAGMA_SESSION_SECTION: string

Field Value

Type: Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.CONFIG_LACONIC_FORMAT Field

Configuration CONFIG_LACONIC_FORMAT Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_LACONIC_FORMAT
public const string CONFIG_LACONIC_FORMAT
Public Const CONFIG_LACONIC_FORMAT As String
Public Const CONFIG_LACONIC_FORMAT As String
public:
literal String^ CONFIG_LACONIC_FORMAT
public:
literal String^ CONFIG_LACONIC_FORMAT
static val mutable CONFIG_LACONIC_FORMAT: string
static val mutable CONFIG_LACONIC_FORMAT: string

Field Value

Type: Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.CONFIG_NAME_ATTR Field

Configuration CONFIG_NAME_ATTR Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_NAME_ATTR
public const string CONFIG_NAME_ATTR
Public Const CONFIG_NAME_ATTR As String
Public Const CONFIG_NAME_ATTR As String
public:
literal String^ CONFIG_NAME_ATTR
public:
literal String^ CONFIG_NAME_ATTR
static val mutable CONFIG_NAME_ATTR: string
static val mutable CONFIG_NAME_ATTR: string

Field Value

Type: Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.CONFIG_ORDER_ATTR Field

Configuration CONFIG_ORDER_ATTR Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_ORDER_ATTR
public const string CONFIG_ORDER_ATTR
Public Const CONFIG_ORDER_ATTR As String
Public Const CONFIG_ORDER_ATTR As String
public:
literal String^ CONFIG_ORDER_ATTR
public:
literal String^ CONFIG_ORDER_ATTR
static val mutable CONFIG_ORDER_ATTR: string
static val mutable CONFIG_ORDER_ATTR: string

Field Value

Type: Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.DEFAULT_CONFIG_INCLUDE_PRAGMA Field

Configuration DEFAULT_CONFIG_INCLUDE_PRAGMA Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_CONFIG_INCLUDE_PRAGMA
public const string DEFAULT_CONFIG_INCLUDE_PRAGMA
Public Const DEFAULT_CONFIG_INCLUDE_PRAGMA As String
Public Const DEFAULT_CONFIG_INCLUDE_PRAGMA As String
public:
literal String^ DEFAULT_CONFIG_INCLUDE_PRAGMA
public:
literal String^ DEFAULT_CONFIG_INCLUDE_PRAGMA
static val mutable DEFAULT_CONFIG_INCLUDE_PRAGMA: string
static val mutable DEFAULT_CONFIG_INCLUDE_PRAGMA: string

Field Value

Type: Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.DEFAULT_VAR_END Field

Configuration DEFAULT_VAR_END Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_VAR_END
public const string DEFAULT_VAR_END
Public Const DEFAULT_VAR_END As String
Public Const DEFAULT_VAR_END As String
public:
literal String^ DEFAULT_VAR_END
public:
literal String^ DEFAULT_VAR_END
static val mutable DEFAULT_VAR_END: string
static val mutable DEFAULT_VAR_END: string

Field Value

Type: Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.DEFAULT_VAR_ENV_MOD Field

Configuration DEFAULT_VAR_ENV_MOD Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_VAR_ENV_MOD
public const string DEFAULT_VAR_ENV_MOD
Public Const DEFAULT_VAR_ENV_MOD As String
Public Const DEFAULT_VAR_ENV_MOD As String
public:
literal String^ DEFAULT_VAR_ENV_MOD
public:
literal String^ DEFAULT_VAR_ENV_MOD
static val mutable DEFAULT_VAR_ENV_MOD: string
static val mutable DEFAULT_VAR_ENV_MOD: string

Field Value

Type: Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.DEFAULT_VAR_ESCAPE Field

Configuration DEFAULT_VAR_ESCAPE Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_VAR_ESCAPE
public const string DEFAULT_VAR_ESCAPE
Public Const DEFAULT_VAR_ESCAPE As String
Public Const DEFAULT_VAR_ESCAPE As String
public:
literal String^ DEFAULT_VAR_ESCAPE
public:
literal String^ DEFAULT_VAR_ESCAPE
static val mutable DEFAULT_VAR_ESCAPE: string
static val mutable DEFAULT_VAR_ESCAPE: string

Field Value

Type: Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.DEFAULT_VAR_MACRO_START Field

Configuration DEFAULT_VAR_MACRO_START Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_VAR_MACRO_START
public const string DEFAULT_VAR_MACRO_START
Public Const DEFAULT_VAR_MACRO_START As String
Public Const DEFAULT_VAR_MACRO_START As String
public:
literal String^ DEFAULT_VAR_MACRO_START
public:
literal String^ DEFAULT_VAR_MACRO_START
static val mutable DEFAULT_VAR_MACRO_START: string
static val mutable DEFAULT_VAR_MACRO_START: string

Field Value

Type: Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.DEFAULT_VAR_PATH_MOD Field

Configuration DEFAULT_VAR_PATH_MOD Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_VAR_PATH_MOD
public const string DEFAULT_VAR_PATH_MOD
Public Const DEFAULT_VAR_PATH_MOD As String
Public Const DEFAULT_VAR_PATH_MOD As String
public:
literal String^ DEFAULT_VAR_PATH_MOD
public:
literal String^ DEFAULT_VAR_PATH_MOD
static val mutable DEFAULT_VAR_PATH_MOD: string
static val mutable DEFAULT_VAR_PATH_MOD: string

Field Value

Type: Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.DEFAULT_VAR_START Field

Configuration DEFAULT_VAR_START Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_VAR_START
public const string DEFAULT_VAR_START
Public Const DEFAULT_VAR_START As String
Public Const DEFAULT_VAR_START As String
public:
literal String^ DEFAULT_VAR_START
public:
literal String^ DEFAULT_VAR_START
static val mutable DEFAULT_VAR_START: string
static val mutable DEFAULT_VAR_START: string

Field Value

Type: Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.m_EmptyAttrNode Field

Configuration m_EmptyAttrNode Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal ConfigAttrNode m_EmptyAttrNode
protected internal ConfigAttrNode m_EmptyAttrNode
Protected Friend m_EmptyAttrNode As ConfigAttrNode
Protected Friend m_EmptyAttrNode As ConfigAttrNode
protected public:
ConfigAttrNode^ m_EmptyAttrNode
protected public:
ConfigAttrNode^ m_EmptyAttrNode
val mutable m_EmptyAttrNode: ConfigAttrNode
val mutable m_EmptyAttrNode: ConfigAttrNode

Field Value

Type: ConfigAttrNode
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.m_EmptySectionNode Field

Configuration m_EmptySectionNode Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal ConfigSectionNode m_EmptySectionNode
protected internal ConfigSectionNode m_EmptySectionNode
Protected Friend m_EmptySectionNode As ConfigSectionNode
Protected Friend m_EmptySectionNode As ConfigSectionNode
protected public:
ConfigSectionNode^ m_EmptySectionNode
protected public:
ConfigSectionNode^ m_EmptySectionNode
val mutable m_EmptySectionNode: ConfigSectionNode
val mutable m_EmptySectionNode: ConfigSectionNode

Field Value

Type: ConfigSectionNode
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.m_Root Field

Configuration m_Root Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ConfigSectionNode m_Root
protected ConfigSectionNode m_Root
Protected m_Root As ConfigSectionNode
Protected m_Root As ConfigSectionNode
protected:
ConfigSectionNode^ m_Root
protected:
ConfigSectionNode^ m_Root
val mutable m_Root: ConfigSectionNode
val mutable m_Root: ConfigSectionNode

Field Value

Type: ConfigSectionNode
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.ProcesswideConfigNodeProviderType Field

Configuration ProcesswideConfigNodeProviderType Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets/sets global implementor of IConfigNodeProvider that is used by all configurations in this process instance when type is not specified

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Type ProcesswideConfigNodeProviderType
public static Type ProcesswideConfigNodeProviderType
Public Shared ProcesswideConfigNodeProviderType As Type
Public Shared ProcesswideConfigNodeProviderType As Type
public:
static Type^ ProcesswideConfigNodeProviderType
public:
static Type^ ProcesswideConfigNodeProviderType
static val mutable ProcesswideConfigNodeProviderType: Type
static val mutable ProcesswideConfigNodeProviderType: Type

Field Value

Type: Online Type
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.ProcesswideEnvironmentVarResolver Field

Configuration ProcesswideEnvironmentVarResolver Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets/sets global Environment variable resolver that is used by all configurations in this process instance

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnvironmentVariableResolver ProcesswideEnvironmentVarResolver
public static IEnvironmentVariableResolver ProcesswideEnvironmentVarResolver
Public Shared ProcesswideEnvironmentVarResolver As IEnvironmentVariableResolver
Public Shared ProcesswideEnvironmentVarResolver As IEnvironmentVariableResolver
public:
static IEnvironmentVariableResolver^ ProcesswideEnvironmentVarResolver
public:
static IEnvironmentVariableResolver^ ProcesswideEnvironmentVarResolver
static val mutable ProcesswideEnvironmentVarResolver: IEnvironmentVariableResolver
static val mutable ProcesswideEnvironmentVarResolver: IEnvironmentVariableResolver

Field Value

Type: IEnvironmentVariableResolver
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration Methods

Configuration Methods NFX Class Library

The Configuration type exposes the following members.
Methods
 | Name | Description
Protected method | AdjustNodeName | Override to perform transforms on node names so they become suitable for particular configuration type
Public method | CheckAndAdjustNodeName | Checks node name for aptitude for particular configuration type. For example, XML configuration does not allow nodes with spaces or separator chars. When StrictNames is set to true and value is not appropriate then exception is thrown
Public method | Clone | Implements IClonable by returning new MemoryConfiguration clone
Public method | Clone(Configuration) | Creates a deep copy of this configuration into newInstance which was allocated externally
Public method | Clone T | Creates a deep copy of this configuration into new instance of T
Public method | Create | Creates new configuration - creates new configuration root with optional name parameter
Public method | CreateFromMerge | Creates new configuration from ordered merge result of two other nodes - base and override which can be from different configurations
Public method | CreateFromNode | Creates new configuration from other node, which may belong to a different configuration instance
Public method | Destroy | Erases all config data
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Include | Completely replaces this node with another node tree, positioning the new tree in the place of local node. Existing node is deleted after this operation completes, in its place child nodes from other node are inserted preserving their existing order. Attributes of other node get merged into parent of existing node
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | NewEmptyRoot | Creates a new empty config root based on laconic format
 | ProviderLoadFromAnySupportedFormatFile | Loads the contents of the supplied file name without format extension trying to match any of the supported format extensions. When match is found the file is loaded via an appropriate configuration provider
 | ProviderLoadFromFile | Loads the contents of the supplied file name in an appropriate configuration provider implementation for the supplied extension format
 | ProviderLoadFromString | Loads the supplied string content in the specified format, which may be format name like "xml" or "laconfig" with or without extension period
Public method | Refresh | Re-reads configuration from source
Public method | ResolveEnvironmentVar | Resolves variable name into its value
Public method | RunMacro | Runs macro and returns its value
Public method | Save | Saves configuration to source
Public method | ToConfigurationJSONDataMap | Returns this config as JSON data map suitable for making JSONConfiguration
Public method | ToLaconicFile | Serializes configuration tree into Laconic format and writes it into a file
Public method | ToLaconicStream | Serializes configuration tree into Laconic format and writes it into stream
Public method | ToLaconicString | Serializes configuration tree into Laconic format and returns it as a string
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Configuration Class
NFX.Environment Namespace


Configuration.AdjustNodeName Method

Configuration AdjustNodeName Method NFX Class Library

Override to perform transforms on node names so they become suitable for particular configuration type

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual string AdjustNodeName(
    string name
)
protected virtual string AdjustNodeName(
    string name
)
Protected Overridable Function AdjustNodeName (
    name As String
) As String
Protected Overridable Function AdjustNodeName (
    name As String
) As String
protected:
virtual String^ AdjustNodeName(
    String^ name
)
protected:
virtual String^ AdjustNodeName(
    String^ name
)
abstract AdjustNodeName :
        name : string -> string
override AdjustNodeName :
        name : string -> string
abstract AdjustNodeName :
        name : string -> string
override AdjustNodeName :
        name : string -> string

Parameters

name
Type: Online System String

Return Value

Type: Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.CheckAndAdjustNodeName Method

Configuration CheckAndAdjustNodeName Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Checks node name for aptitude for particular configuration type. For example, XML configuration does not allow nodes with spaces or separator chars. When StrictNames is set to true and value is not appropriate then exception is thrown

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CheckAndAdjustNodeName(
    string name
)
public string CheckAndAdjustNodeName(
    string name
)
Public Function CheckAndAdjustNodeName (
    name As String
) As String
Public Function CheckAndAdjustNodeName (
    name As String
) As String
public:
String^ CheckAndAdjustNodeName(
    String^ name
)
public:
String^ CheckAndAdjustNodeName(
    String^ name
)
member CheckAndAdjustNodeName :
        name : string -> string
member CheckAndAdjustNodeName :
        name : string -> string

Parameters

name
Type: Online System String

Return Value

Type: Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.Clone Method

Configuration Clone Method NFX Class Library

Overload List
 | Name | Description
Public method | Clone | Implements IClonable by returning new MemoryConfiguration clone
Public method | Clone T | Creates a deep copy of this configuration into new instance of T
Public method | Clone(Configuration) | Creates a deep copy of this configuration into newInstance which was allocated externally
Back to Top
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.Clone Method

Configuration Clone Method NFX Class Library

Implements IClonable by returning new MemoryConfiguration clone

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Clone()
public Object Clone()
Public Function Clone As Object
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Online Object

Implements

Online ICloneable Clone
See Also
Configuration Class
Configuration Members
Clone Overload
NFX.Environment Namespace


Configuration.Clone(T) Method

Configuration Clone T Method NFX Class Library

Creates a deep copy of this configuration into new instance of T

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Configuration Clone<T>()
where T : new(), Configuration
public Configuration Clone<T>()
where T : new(), Configuration
Public Function Clone(Of T As {New, Configuration}) As Configuration
Public Function Clone(Of T As {New, Configuration}) As Configuration
public:
generic<typename T>
where T : gcnew(), Configuration
Configuration^ Clone()
public:
generic<typename T>
where T : gcnew(), Configuration
Configuration^ Clone()
member Clone : unit -> Configuration  when 'T : new() and Configuration
member Clone : unit -> Configuration  when 'T : new() and Configuration
Type Parameters
T

Return Value

Type: Configuration
See Also
Configuration Class
Configuration Members
Clone Overload
NFX.Environment Namespace


Configuration.Clone Method (Configuration)

Configuration Clone Method (Configuration) NFX Class Library

Creates a deep copy of this configuration into newInstance which was allocated externally

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Configuration Clone(
    Configuration newInstance
)
public Configuration Clone(
    Configuration newInstance
)
Public Function Clone (
    newInstance As Configuration
) As Configuration
Public Function Clone (
    newInstance As Configuration
) As Configuration
public:
Configuration^ Clone(
    Configuration^ newInstance
)
public:
Configuration^ Clone(
    Configuration^ newInstance
)
member Clone :
        newInstance : Configuration -> Configuration
member Clone :
        newInstance : Configuration -> Configuration

Parameters

newInstance
Type: NFX.Environment Configuration

Return Value

Type: Configuration
See Also
Configuration Class
Configuration Members
Clone Overload
NFX.Environment Namespace


Configuration.Create Method

Configuration Create Method NFX Class Library

Creates new configuration - creates new configuration root with optional name parameter

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Create(
    string name = "configuration"
)
public void Create(
    string name = "configuration"
)
Public Sub Create (
    Optional name As String = "configuration"
)
Public Sub Create (
    Optional name As String = "configuration"
)
public:
void Create(
    String^ name = L"configuration"
)
public:
void Create(
    String^ name = L"configuration"
)
member Create :
        ?name : string
(* Defaults:
        let _name = defaultArg name "configuration"
*)
-> unit
member Create :
        ?name : string
(* Defaults:
        let _name = defaultArg name "configuration"
*)
-> unit

Parameters

name (Optional)
Type: Online System String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.CreateFromMerge Method

Configuration CreateFromMerge Method NFX Class Library

Creates new configuration from ordered merge result of two other nodes - base and override which can be from different configurations

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CreateFromMerge(
    ConfigSectionNode baseNode,
    ConfigSectionNode overrideNode,
    NodeOverrideRules rules = null
)
public void CreateFromMerge(
    ConfigSectionNode baseNode,
    ConfigSectionNode overrideNode,
    NodeOverrideRules rules = null
)
Public Sub CreateFromMerge (
    baseNode As ConfigSectionNode,
    overrideNode As ConfigSectionNode,
    Optional rules As NodeOverrideRules = Nothing
)
Public Sub CreateFromMerge (
    baseNode As ConfigSectionNode,
    overrideNode As ConfigSectionNode,
    Optional rules As NodeOverrideRules = Nothing
)
public:
void CreateFromMerge(
    ConfigSectionNode^ baseNode,
    ConfigSectionNode^ overrideNode,
    NodeOverrideRules^ rules = nullptr
)
public:
void CreateFromMerge(
    ConfigSectionNode^ baseNode,
    ConfigSectionNode^ overrideNode,
    NodeOverrideRules^ rules = nullptr
)
member CreateFromMerge :
        baseNode : ConfigSectionNode *
        overrideNode : ConfigSectionNode *
        ?rules : NodeOverrideRules
(* Defaults:
        let _rules = defaultArg rules null
*)
-> unit
member CreateFromMerge :
        baseNode : ConfigSectionNode *
        overrideNode : ConfigSectionNode *
        ?rules : NodeOverrideRules
(* Defaults:
        let _rules = defaultArg rules null
*)
-> unit

Parameters

baseNode
Type: NFX.Environment ConfigSectionNode
A base node that data is defaulted from
overrideNode
Type: NFX.Environment ConfigSectionNode
A node that contains overrides/additions of/to data from base node
rules (Optional)
Type: NFX.Environment NodeOverrideRules
Rules to use or default rules will be used in null is passed
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.CreateFromNode Method

Configuration CreateFromNode Method NFX Class Library

Creates new configuration from other node, which may belong to a different configuration instance

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CreateFromNode(
    IConfigSectionNode otherNode
)
public void CreateFromNode(
    IConfigSectionNode otherNode
)
Public Sub CreateFromNode (
    otherNode As IConfigSectionNode
)
Public Sub CreateFromNode (
    otherNode As IConfigSectionNode
)
public:
void CreateFromNode(
    IConfigSectionNode^ otherNode
)
public:
void CreateFromNode(
    IConfigSectionNode^ otherNode
)
member CreateFromNode :
        otherNode : IConfigSectionNode -> unit
member CreateFromNode :
        otherNode : IConfigSectionNode -> unit

Parameters

otherNode
Type: NFX.Environment IConfigSectionNode
A base node that data is defaulted from
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.Destroy Method

Configuration Destroy Method NFX Class Library

Erases all config data

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Destroy()
public void Destroy()
Public Sub Destroy
Public Sub Destroy
public:
void Destroy()
public:
void Destroy()
member Destroy : unit -> unit
member Destroy : unit -> unit
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.Include Method

Configuration Include Method NFX Class Library

Completely replaces this node with another node tree, positioning the new tree in the place of local node. Existing node is deleted after this operation completes, in its place child nodes from other node are inserted preserving their existing order. Attributes of other node get merged into parent of existing node

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Include(
    ConfigSectionNode existing,
    ConfigSectionNode other
)
public void Include(
    ConfigSectionNode existing,
    ConfigSectionNode other
)
Public Sub Include (
    existing As ConfigSectionNode,
    other As ConfigSectionNode
)
Public Sub Include (
    existing As ConfigSectionNode,
    other As ConfigSectionNode
)
public:
void Include(
    ConfigSectionNode^ existing,
    ConfigSectionNode^ other
)
public:
void Include(
    ConfigSectionNode^ existing,
    ConfigSectionNode^ other
)
member Include :
        existing : ConfigSectionNode *
        other : ConfigSectionNode -> unit
member Include :
        existing : ConfigSectionNode *
        other : ConfigSectionNode -> unit

Parameters

existing
Type: NFX.Environment ConfigSectionNode
other
Type: NFX.Environment ConfigSectionNode
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.NewEmptyRoot Method

Configuration NewEmptyRoot Method NFX Class Library

Creates a new empty config root based on laconic format

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ConfigSectionNode NewEmptyRoot(
    string name = null
)
public static ConfigSectionNode NewEmptyRoot(
    string name = null
)
Public Shared Function NewEmptyRoot (
    Optional name As String = Nothing
) As ConfigSectionNode
Public Shared Function NewEmptyRoot (
    Optional name As String = Nothing
) As ConfigSectionNode
public:
static ConfigSectionNode^ NewEmptyRoot(
    String^ name = nullptr
)
public:
static ConfigSectionNode^ NewEmptyRoot(
    String^ name = nullptr
)
static member NewEmptyRoot :
        ?name : string
(* Defaults:
        let _name = defaultArg name null
*)
-> ConfigSectionNode
static member NewEmptyRoot :
        ?name : string
(* Defaults:
        let _name = defaultArg name null
*)
-> ConfigSectionNode

Parameters

name (Optional)
Type: Online System String

Return Value

Type: ConfigSectionNode
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.ProviderLoadFromAnySupportedFormatFile Method

Configuration ProviderLoadFromAnySupportedFormatFile Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Loads the contents of the supplied file name without format extension trying to match any of the supported format extensions. When match is found the file is loaded via an appropriate configuration provider

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Configuration ProviderLoadFromAnySupportedFormatFile(
    string fileName
)
public static Configuration ProviderLoadFromAnySupportedFormatFile(
    string fileName
)
Public Shared Function ProviderLoadFromAnySupportedFormatFile (
    fileName As String
) As Configuration
Public Shared Function ProviderLoadFromAnySupportedFormatFile (
    fileName As String
) As Configuration
public:
static Configuration^ ProviderLoadFromAnySupportedFormatFile(
    String^ fileName
)
public:
static Configuration^ ProviderLoadFromAnySupportedFormatFile(
    String^ fileName
)
static member ProviderLoadFromAnySupportedFormatFile :
        fileName : string -> Configuration
static member ProviderLoadFromAnySupportedFormatFile :
        fileName : string -> Configuration

Parameters

fileName
Type: Online System String

Return Value

Type: Configuration
Examples
Given "c:\conf\users" as an input: if "c:\conf\users.xml" exists then it will be opened as XMLConfiguration if "c:\conf\users.laconf" exists then it will be opened as LaconicConfiguration if "c:\conf\users.json" exists then it will be opened as JSONConfiguration and so on... for the rest of supported formats
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.ProviderLoadFromFile Method

Configuration ProviderLoadFromFile Method NFX Class Library

Loads the contents of the supplied file name in an appropriate configuration provider implementation for the supplied extension format

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Configuration ProviderLoadFromFile(
    string fileName
)
public static Configuration ProviderLoadFromFile(
    string fileName
)
Public Shared Function ProviderLoadFromFile (
    fileName As String
) As Configuration
Public Shared Function ProviderLoadFromFile (
    fileName As String
) As Configuration
public:
static Configuration^ ProviderLoadFromFile(
    String^ fileName
)
public:
static Configuration^ ProviderLoadFromFile(
    String^ fileName
)
static member ProviderLoadFromFile :
        fileName : string -> Configuration
static member ProviderLoadFromFile :
        fileName : string -> Configuration

Parameters

fileName
Type: Online System String

Return Value

Type: Configuration
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.ProviderLoadFromString Method

Configuration ProviderLoadFromString Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Loads the supplied string content in the specified format, which may be format name like "xml" or "laconfig" with or without extension period

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Configuration ProviderLoadFromString(
    string content,
    string format
)
public static Configuration ProviderLoadFromString(
    string content,
    string format
)
Public Shared Function ProviderLoadFromString (
    content As String,
    format As String
) As Configuration
Public Shared Function ProviderLoadFromString (
    content As String,
    format As String
) As Configuration
public:
static Configuration^ ProviderLoadFromString(
    String^ content,
    String^ format
)
public:
static Configuration^ ProviderLoadFromString(
    String^ content,
    String^ format
)
static member ProviderLoadFromString :
        content : string *
        format : string -> Configuration
static member ProviderLoadFromString :
        content : string *
        format : string -> Configuration

Parameters

content
Type: Online System String
format
Type: Online System String

Return Value

Type: Configuration
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.Refresh Method

Configuration Refresh Method NFX Class Library

Re-reads configuration from source

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Refresh()
public virtual void Refresh()
Public Overridable Sub Refresh
Public Overridable Sub Refresh
public:
virtual void Refresh()
public:
virtual void Refresh()
abstract Refresh : unit -> unit
override Refresh : unit -> unit
abstract Refresh : unit -> unit
override Refresh : unit -> unit
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.ResolveEnvironmentVar Method

Configuration ResolveEnvironmentVar Method NFX Class Library

Resolves variable name into its value

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ResolveEnvironmentVar(
    string name,
    IEnvironmentVariableResolver resolver = null
)
public string ResolveEnvironmentVar(
    string name,
    IEnvironmentVariableResolver resolver = null
)
Public Function ResolveEnvironmentVar (
    name As String,
    Optional resolver As IEnvironmentVariableResolver = Nothing
) As String
Public Function ResolveEnvironmentVar (
    name As String,
    Optional resolver As IEnvironmentVariableResolver = Nothing
) As String
public:
String^ ResolveEnvironmentVar(
    String^ name,
    IEnvironmentVariableResolver^ resolver = nullptr
)
public:
String^ ResolveEnvironmentVar(
    String^ name,
    IEnvironmentVariableResolver^ resolver = nullptr
)
member ResolveEnvironmentVar :
        name : string *
        ?resolver : IEnvironmentVariableResolver
(* Defaults:
        let _resolver = defaultArg resolver null
*)
-> string
member ResolveEnvironmentVar :
        name : string *
        ?resolver : IEnvironmentVariableResolver
(* Defaults:
        let _resolver = defaultArg resolver null
*)
-> string

Parameters

name
Type: Online System String
resolver (Optional)
Type: NFX.Environment IEnvironmentVariableResolver

Return Value

Type: Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.RunMacro Method

Configuration RunMacro Method NFX Class Library

Runs macro and returns its value

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string RunMacro(
    IConfigSectionNode node,
    string inputValue,
    string macroName,
    IConfigSectionNode macroParams,
    IMacroRunner runner = null,
    Object context = null
)
public string RunMacro(
    IConfigSectionNode node,
    string inputValue,
    string macroName,
    IConfigSectionNode macroParams,
    IMacroRunner runner = null,
    Object context = null
)
Public Function RunMacro (
    node As IConfigSectionNode,
    inputValue As String,
    macroName As String,
    macroParams As IConfigSectionNode,
    Optional runner As IMacroRunner = Nothing,
    Optional context As Object = Nothing
) As String
Public Function RunMacro (
    node As IConfigSectionNode,
    inputValue As String,
    macroName As String,
    macroParams As IConfigSectionNode,
    Optional runner As IMacroRunner = Nothing,
    Optional context As Object = Nothing
) As String
public:
String^ RunMacro(
    IConfigSectionNode^ node,
    String^ inputValue,
    String^ macroName,
    IConfigSectionNode^ macroParams,
    IMacroRunner^ runner = nullptr,
    Object^ context = nullptr
)
public:
String^ RunMacro(
    IConfigSectionNode^ node,
    String^ inputValue,
    String^ macroName,
    IConfigSectionNode^ macroParams,
    IMacroRunner^ runner = nullptr,
    Object^ context = nullptr
)
member RunMacro :
        node : IConfigSectionNode *
        inputValue : string *
        macroName : string *
        macroParams : IConfigSectionNode *
        ?runner : IMacroRunner *
        ?context : Object
(* Defaults:
        let _runner = defaultArg runner null
        let _context = defaultArg context null
*)
-> string
member RunMacro :
        node : IConfigSectionNode *
        inputValue : string *
        macroName : string *
        macroParams : IConfigSectionNode *
        ?runner : IMacroRunner *
        ?context : Object
(* Defaults:
        let _runner = defaultArg runner null
        let _context = defaultArg context null
*)
-> string

Parameters

node
Type: NFX.Environment IConfigSectionNode
inputValue
Type: Online System String
macroName
Type: Online System String
macroParams
Type: NFX.Environment IConfigSectionNode
runner (Optional)
Type: NFX.Environment IMacroRunner
context (Optional)
Type: Online System Object

Return Value

Type: Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.Save Method

Configuration Save Method NFX Class Library

Saves configuration to source

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Save()
public virtual void Save()
Public Overridable Sub Save
Public Overridable Sub Save
public:
virtual void Save()
public:
virtual void Save()
abstract Save : unit -> unit
override Save : unit -> unit
abstract Save : unit -> unit
override Save : unit -> unit
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.ToConfigurationJSONDataMap Method

Configuration ToConfigurationJSONDataMap Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns this config as JSON data map suitable for making JSONConfiguration

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDataMap ToConfigurationJSONDataMap()
public JSONDataMap ToConfigurationJSONDataMap()
Public Function ToConfigurationJSONDataMap As JSONDataMap
Public Function ToConfigurationJSONDataMap As JSONDataMap
public:
JSONDataMap^ ToConfigurationJSONDataMap()
public:
JSONDataMap^ ToConfigurationJSONDataMap()
member ToConfigurationJSONDataMap : unit -> JSONDataMap
member ToConfigurationJSONDataMap : unit -> JSONDataMap

Return Value

Type: JSONDataMap
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.ToLaconicFile Method

Configuration ToLaconicFile Method NFX Class Library

Serializes configuration tree into Laconic format and writes it into a file

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ToLaconicFile(
    string filename,
    LaconfigWritingOptions options = null,
    Encoding encoding = null
)
public void ToLaconicFile(
    string filename,
    LaconfigWritingOptions options = null,
    Encoding encoding = null
)
Public Sub ToLaconicFile (
    filename As String,
    Optional options As LaconfigWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing
)
Public Sub ToLaconicFile (
    filename As String,
    Optional options As LaconfigWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing
)
public:
void ToLaconicFile(
    String^ filename,
    LaconfigWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr
)
public:
void ToLaconicFile(
    String^ filename,
    LaconfigWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr
)
member ToLaconicFile :
        filename : string *
        ?options : LaconfigWritingOptions *
        ?encoding : Encoding
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
*)
-> unit
member ToLaconicFile :
        filename : string *
        ?options : LaconfigWritingOptions *
        ?encoding : Encoding
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
*)
-> unit

Parameters

filename
Type: Online System String
options (Optional)
Type: NFX.CodeAnalysis.Laconfig LaconfigWritingOptions
encoding (Optional)
Type: Online System.Text Encoding
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.ToLaconicStream Method

Configuration ToLaconicStream Method NFX Class Library

Serializes configuration tree into Laconic format and writes it into stream

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ToLaconicStream(
    Stream stream,
    LaconfigWritingOptions options = null,
    Encoding encoding = null
)
public void ToLaconicStream(
    Stream stream,
    LaconfigWritingOptions options = null,
    Encoding encoding = null
)
Public Sub ToLaconicStream (
    stream As Stream,
    Optional options As LaconfigWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing
)
Public Sub ToLaconicStream (
    stream As Stream,
    Optional options As LaconfigWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing
)
public:
void ToLaconicStream(
    Stream^ stream,
    LaconfigWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr
)
public:
void ToLaconicStream(
    Stream^ stream,
    LaconfigWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr
)
member ToLaconicStream :
        stream : Stream *
        ?options : LaconfigWritingOptions *
        ?encoding : Encoding
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
*)
-> unit
member ToLaconicStream :
        stream : Stream *
        ?options : LaconfigWritingOptions *
        ?encoding : Encoding
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
*)
-> unit

Parameters

stream
Type: Online System.IO Stream
options (Optional)
Type: NFX.CodeAnalysis.Laconfig LaconfigWritingOptions
encoding (Optional)
Type: Online System.Text Encoding
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.ToLaconicString Method

Configuration ToLaconicString Method NFX Class Library

Serializes configuration tree into Laconic format and returns it as a string

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ToLaconicString(
    LaconfigWritingOptions options = null
)
public string ToLaconicString(
    LaconfigWritingOptions options = null
)
Public Function ToLaconicString (
    Optional options As LaconfigWritingOptions = Nothing
) As String
Public Function ToLaconicString (
    Optional options As LaconfigWritingOptions = Nothing
) As String
public:
String^ ToLaconicString(
    LaconfigWritingOptions^ options = nullptr
)
public:
String^ ToLaconicString(
    LaconfigWritingOptions^ options = nullptr
)
member ToLaconicString :
        ?options : LaconfigWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> string
member ToLaconicString :
        ?options : LaconfigWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> string

Parameters

options (Optional)
Type: NFX.CodeAnalysis.Laconfig LaconfigWritingOptions

Return Value

Type: Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration Properties

Configuration Properties NFX Class Library

The Configuration type exposes the following members.
Properties
 | Name | Description
 | AllSupportedFormats | Returns all configuration file formats (file extensions without '.') supported by ProviderLoadFromFile/ProviderLoadFromAnySupportedFormatFile/ProviderLoadFromString
Public property | ContentView | Primarily used for debugging - returns the content of the configuration as text in the pretty-printed Laconic format
Public property | EmptyAttr | References a special instance of an empty attribute node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist
Public property | EmptySection | References a special instance of an empty section node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist
Public property | EnvironmentVarResolver | References variable resolver. If this property is not set then default Windows environment var resolver is used
Public property | IsReadOnly | Indicates whether configuration is read-only
Public property | MacroRunner | References macro runner. If this property is not set then default macro runner is used
Public property | MacroRunnerContext | Gets/sets an object passed by the framework into MacroRunner.Run() method. This property is auto-set for classes decorated with [ConfigMacroContext] attribute
Public property | Root | Accesses root section configuration node
Public property | StrictNames | Determines whether exception is thrown when configuration node name contains inappropriate chars for particular configuration type. For example, for XMLConfiguration node names may not have spaces and other separator chars. When StrictNames is false then particular configurations may replace incompatible chars in node names with neutral ones (i.e. "my value"->"my-value" in case of XMLConfiguration).
Public property | Variable_END | Variable end tag
Public property | Variable_ENV_MOD | Variable environment modifier
Public property | Variable_ESCAPE | Variable escape tag
Public property | Variable_MACRO_START | Variable get clause modifier
Public property | Variable_PATH_MOD | Variable path modifier
Public property | Variable_START | Variable start tag
Back to Top
See Also
Configuration Class
NFX.Environment Namespace


Configuration.AllSupportedFormats Property

Configuration AllSupportedFormats Property NFX Class Library

Returns all configuration file formats (file extensions without '.') supported by ProviderLoadFromFile/ProviderLoadFromAnySupportedFormatFile/ProviderLoadFromString

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<string> AllSupportedFormats { get; }
public static IEnumerable<string> AllSupportedFormats { get; }
Public Shared ReadOnly Property AllSupportedFormats As IEnumerable(Of String)
    Get
Public Shared ReadOnly Property AllSupportedFormats As IEnumerable(Of String)
    Get
public:
static property IEnumerable<String^>^ AllSupportedFormats {
    IEnumerable<String^>^ get ();
}
public:
static property IEnumerable<String^>^ AllSupportedFormats {
    IEnumerable<String^>^ get ();
}
static member AllSupportedFormats : IEnumerable<string> with get
static member AllSupportedFormats : IEnumerable<string> with get

Property Value

Type: Online IEnumerable Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.ContentView Property

Configuration ContentView Property NFX Class Library

Primarily used for debugging - returns the content of the configuration as text in the pretty-printed Laconic format

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ContentView { get; }
public string ContentView { get; }
Public ReadOnly Property ContentView As String
    Get
Public ReadOnly Property ContentView As String
    Get
public:
property String^ ContentView {
    String^ get ();
}
public:
property String^ ContentView {
    String^ get ();
}
member ContentView : string with get
member ContentView : string with get

Property Value

Type: Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.EmptyAttr Property

Configuration EmptyAttr Property NFX Class Library

References a special instance of an empty attribute node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigAttrNode EmptyAttr { get; }
public ConfigAttrNode EmptyAttr { get; }
Public ReadOnly Property EmptyAttr As ConfigAttrNode
    Get
Public ReadOnly Property EmptyAttr As ConfigAttrNode
    Get
public:
property ConfigAttrNode^ EmptyAttr {
    ConfigAttrNode^ get ();
}
public:
property ConfigAttrNode^ EmptyAttr {
    ConfigAttrNode^ get ();
}
member EmptyAttr : ConfigAttrNode with get
member EmptyAttr : ConfigAttrNode with get

Property Value

Type: ConfigAttrNode
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.EmptySection Property

Configuration EmptySection Property NFX Class Library

References a special instance of an empty section node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigSectionNode EmptySection { get; }
public ConfigSectionNode EmptySection { get; }
Public ReadOnly Property EmptySection As ConfigSectionNode
    Get
Public ReadOnly Property EmptySection As ConfigSectionNode
    Get
public:
property ConfigSectionNode^ EmptySection {
    ConfigSectionNode^ get ();
}
public:
property ConfigSectionNode^ EmptySection {
    ConfigSectionNode^ get ();
}
member EmptySection : ConfigSectionNode with get
member EmptySection : ConfigSectionNode with get

Property Value

Type: ConfigSectionNode
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.EnvironmentVarResolver Property

Configuration EnvironmentVarResolver Property NFX Class Library

[This is preliminary documentation and is subject to change.]

References variable resolver. If this property is not set then default Windows environment var resolver is used

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnvironmentVariableResolver EnvironmentVarResolver { get; set; }
public IEnvironmentVariableResolver EnvironmentVarResolver { get; set; }
Public Property EnvironmentVarResolver As IEnvironmentVariableResolver
    Get
    Set
Public Property EnvironmentVarResolver As IEnvironmentVariableResolver
    Get
    Set
public:
property IEnvironmentVariableResolver^ EnvironmentVarResolver {
    IEnvironmentVariableResolver^ get ();
    void set (IEnvironmentVariableResolver^ value);
}
public:
property IEnvironmentVariableResolver^ EnvironmentVarResolver {
    IEnvironmentVariableResolver^ get ();
    void set (IEnvironmentVariableResolver^ value);
}
member EnvironmentVarResolver : IEnvironmentVariableResolver with get, set
member EnvironmentVarResolver : IEnvironmentVariableResolver with get, set

Property Value

Type: IEnvironmentVariableResolver
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.IsReadOnly Property

Configuration IsReadOnly Property NFX Class Library

Indicates whether configuration is read-only

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool IsReadOnly { get; }
public abstract bool IsReadOnly { get; }
Public MustOverride ReadOnly Property IsReadOnly As Boolean
    Get
Public MustOverride ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get () abstract;
}
public:
virtual property bool IsReadOnly {
    bool get () abstract;
}
abstract IsReadOnly : bool with get
abstract IsReadOnly : bool with get

Property Value

Type: Online Boolean
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.MacroRunner Property

Configuration MacroRunner Property NFX Class Library

References macro runner. If this property is not set then default macro runner is used

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IMacroRunner MacroRunner { get; set; }
public IMacroRunner MacroRunner { get; set; }
Public Property MacroRunner As IMacroRunner
    Get
    Set
Public Property MacroRunner As IMacroRunner
    Get
    Set
public:
property IMacroRunner^ MacroRunner {
    IMacroRunner^ get ();
    void set (IMacroRunner^ value);
}
public:
property IMacroRunner^ MacroRunner {
    IMacroRunner^ get ();
    void set (IMacroRunner^ value);
}
member MacroRunner : IMacroRunner with get, set
member MacroRunner : IMacroRunner with get, set

Property Value

Type: IMacroRunner
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.MacroRunnerContext Property

Configuration MacroRunnerContext Property NFX Class Library

Gets/sets an object passed by the framework into MacroRunner.Run() method. This property is auto-set for classes decorated with [ConfigMacroContext] attribute

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object MacroRunnerContext { get; set; }
public Object MacroRunnerContext { get; set; }
Public Property MacroRunnerContext As Object
    Get
    Set
Public Property MacroRunnerContext As Object
    Get
    Set
public:
property Object^ MacroRunnerContext {
    Object^ get ();
    void set (Object^ value);
}
public:
property Object^ MacroRunnerContext {
    Object^ get ();
    void set (Object^ value);
}
member MacroRunnerContext : Object with get, set
member MacroRunnerContext : Object with get, set

Property Value

Type: Online Object
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.Root Property

Configuration Root Property NFX Class Library

Accesses root section configuration node

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigSectionNode Root { get; }
public ConfigSectionNode Root { get; }
Public ReadOnly Property Root As ConfigSectionNode
    Get
Public ReadOnly Property Root As ConfigSectionNode
    Get
public:
property ConfigSectionNode^ Root {
    ConfigSectionNode^ get ();
}
public:
property ConfigSectionNode^ Root {
    ConfigSectionNode^ get ();
}
member Root : ConfigSectionNode with get
member Root : ConfigSectionNode with get

Property Value

Type: ConfigSectionNode
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.StrictNames Property

Configuration StrictNames Property NFX Class Library

Determines whether exception is thrown when configuration node name contains inappropriate chars for particular configuration type. For example, for XMLConfiguration node names may not have spaces and other separator chars. When StrictNames is false then particular configurations may replace incompatible chars in node names with neutral ones (i.e. "my value"->"my-value" in case of XMLConfiguration).

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool StrictNames { get; set; }
public bool StrictNames { get; set; }
Public Property StrictNames As Boolean
    Get
    Set
Public Property StrictNames As Boolean
    Get
    Set
public:
property bool StrictNames {
    bool get ();
    void set (bool value);
}
public:
property bool StrictNames {
    bool get ();
    void set (bool value);
}
member StrictNames : bool with get, set
member StrictNames : bool with get, set

Property Value

Type: Online Boolean
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.Variable_END Property

Configuration Variable_END Property NFX Class Library

Variable end tag

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Variable_END { get; set; }
public string Variable_END { get; set; }
Public Property Variable_END As String
    Get
    Set
Public Property Variable_END As String
    Get
    Set
public:
property String^ Variable_END {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Variable_END {
    String^ get ();
    void set (String^ value);
}
member Variable_END : string with get, set
member Variable_END : string with get, set

Property Value

Type: Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.Variable_ENV_MOD Property

Configuration Variable_ENV_MOD Property NFX Class Library

Variable environment modifier

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Variable_ENV_MOD { get; set; }
public string Variable_ENV_MOD { get; set; }
Public Property Variable_ENV_MOD As String
    Get
    Set
Public Property Variable_ENV_MOD As String
    Get
    Set
public:
property String^ Variable_ENV_MOD {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Variable_ENV_MOD {
    String^ get ();
    void set (String^ value);
}
member Variable_ENV_MOD : string with get, set
member Variable_ENV_MOD : string with get, set

Property Value

Type: Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.Variable_ESCAPE Property

Configuration Variable_ESCAPE Property NFX Class Library

Variable escape tag

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Variable_ESCAPE { get; set; }
public string Variable_ESCAPE { get; set; }
Public Property Variable_ESCAPE As String
    Get
    Set
Public Property Variable_ESCAPE As String
    Get
    Set
public:
property String^ Variable_ESCAPE {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Variable_ESCAPE {
    String^ get ();
    void set (String^ value);
}
member Variable_ESCAPE : string with get, set
member Variable_ESCAPE : string with get, set

Property Value

Type: Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.Variable_MACRO_START Property

Configuration Variable_MACRO_START Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Variable get clause modifier

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Variable_MACRO_START { get; }
public string Variable_MACRO_START { get; }
Public ReadOnly Property Variable_MACRO_START As String
    Get
Public ReadOnly Property Variable_MACRO_START As String
    Get
public:
property String^ Variable_MACRO_START {
    String^ get ();
}
public:
property String^ Variable_MACRO_START {
    String^ get ();
}
member Variable_MACRO_START : string with get
member Variable_MACRO_START : string with get

Property Value

Type: Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.Variable_PATH_MOD Property

Configuration Variable_PATH_MOD Property NFX Class Library

Variable path modifier

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Variable_PATH_MOD { get; set; }
public string Variable_PATH_MOD { get; set; }
Public Property Variable_PATH_MOD As String
    Get
    Set
Public Property Variable_PATH_MOD As String
    Get
    Set
public:
property String^ Variable_PATH_MOD {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Variable_PATH_MOD {
    String^ get ();
    void set (String^ value);
}
member Variable_PATH_MOD : string with get, set
member Variable_PATH_MOD : string with get, set

Property Value

Type: Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


Configuration.Variable_START Property

Configuration Variable_START Property NFX Class Library

Variable start tag

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Variable_START { get; set; }
public string Variable_START { get; set; }
Public Property Variable_START As String
    Get
    Set
Public Property Variable_START As String
    Get
    Set
public:
property String^ Variable_START {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Variable_START {
    String^ get ();
    void set (String^ value);
}
member Variable_START : string with get, set
member Variable_START : string with get, set

Property Value

Type: Online String
See Also
Configuration Class
Configuration Members
NFX.Environment Namespace


DefaultMacroRunner Class

DefaultMacroRunner Class NFX Class Library

Provides default implementation for configuration variable macros. NOTE: When serialized a new instance is created which will not equal by reference to static.Instance property
Inheritance Hierarchy
Online System Object
NFX.Environment DefaultMacroRunner

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class DefaultMacroRunner : IMacroRunner
[SerializableAttribute]
public class DefaultMacroRunner : IMacroRunner
<SerializableAttribute>
Public Class DefaultMacroRunner
    Implements IMacroRunner
<SerializableAttribute>
Public Class DefaultMacroRunner
    Implements IMacroRunner
[SerializableAttribute]
public ref class DefaultMacroRunner : IMacroRunner
[SerializableAttribute]
public ref class DefaultMacroRunner : IMacroRunner
[<SerializableAttribute>]
type DefaultMacroRunner =
    class
        interface IMacroRunner
    end
[<SerializableAttribute>]
type DefaultMacroRunner =
    class
        interface IMacroRunner
    end
See Also
DefaultMacroRunner Members
NFX.Environment Namespace


DefaultMacroRunner Members

DefaultMacroRunner Members NFX Class Library

The DefaultMacroRunner type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | GetValueAs | Returns a string value converted to desired type with optional default and format
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Run |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
AS_PREFIX |
Back to Top
Properties
Name | Description
Instance | Returns a singleton class instance
Back to Top
See Also
DefaultMacroRunner Class
NFX.Environment Namespace


DefaultMacroRunner Fields

DefaultMacroRunner Fields NFX Class Library

The DefaultMacroRunner type exposes the following members.
Fields
Name | Description
AS_PREFIX |
Back to Top
See Also
DefaultMacroRunner Class
NFX.Environment Namespace


DefaultMacroRunner.AS_PREFIX Field

DefaultMacroRunner AS_PREFIX Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string AS_PREFIX
public const string AS_PREFIX
Public Const AS_PREFIX As String
Public Const AS_PREFIX As String
public:
literal String^ AS_PREFIX
public:
literal String^ AS_PREFIX
static val mutable AS_PREFIX: string
static val mutable AS_PREFIX: string

Field Value

Type: Online String
See Also
DefaultMacroRunner Class
DefaultMacroRunner Members
NFX.Environment Namespace


DefaultMacroRunner Methods

DefaultMacroRunner Methods NFX Class Library

The DefaultMacroRunner type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | GetValueAs | Returns a string value converted to desired type with optional default and format
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Run |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
DefaultMacroRunner Class
NFX.Environment Namespace


DefaultMacroRunner.GetValueAs Method

DefaultMacroRunner GetValueAs Method NFX Class Library

Returns a string value converted to desired type with optional default and format

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetValueAs(
    string value,
    string type,
    string dflt = null,
    string fmt = null
)
public static string GetValueAs(
    string value,
    string type,
    string dflt = null,
    string fmt = null
)
Public Shared Function GetValueAs (
    value As String,
    type As String,
    Optional dflt As String = Nothing,
    Optional fmt As String = Nothing
) As String
Public Shared Function GetValueAs (
    value As String,
    type As String,
    Optional dflt As String = Nothing,
    Optional fmt As String = Nothing
) As String
public:
static String^ GetValueAs(
    String^ value,
    String^ type,
    String^ dflt = nullptr,
    String^ fmt = nullptr
)
public:
static String^ GetValueAs(
    String^ value,
    String^ type,
    String^ dflt = nullptr,
    String^ fmt = nullptr
)
static member GetValueAs :
        value : string *
        type : string *
        ?dflt : string *
        ?fmt : string
(* Defaults:
        let _dflt = defaultArg dflt null
        let _fmt = defaultArg fmt null
*)
-> string
static member GetValueAs :
        value : string *
        type : string *
        ?dflt : string *
        ?fmt : string
(* Defaults:
        let _dflt = defaultArg dflt null
        let _fmt = defaultArg fmt null
*)
-> string

Parameters

value
Type: Online System String
String value to convert
type
Type: Online System String
A type to convert string value into i.e. "decimal"
dflt (Optional)
Type: Online System String
Default value which is used when conversion of original value can not be made
fmt (Optional)
Type: Online System String
Format string that formats the converted value. Example: 'Goods: {0}'. The '0' index is the value

Return Value

Type: Online String
Converted value to desired type then back to string, using optional formatting and default if conversion did not succeed
See Also
DefaultMacroRunner Class
DefaultMacroRunner Members
NFX.Environment Namespace


DefaultMacroRunner.Run Method

DefaultMacroRunner Run Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Run(
    IConfigSectionNode node,
    string inputValue,
    string macroName,
    IConfigSectionNode macroParams,
    Object context = null
)
public string Run(
    IConfigSectionNode node,
    string inputValue,
    string macroName,
    IConfigSectionNode macroParams,
    Object context = null
)
Public Function Run (
    node As IConfigSectionNode,
    inputValue As String,
    macroName As String,
    macroParams As IConfigSectionNode,
    Optional context As Object = Nothing
) As String
Public Function Run (
    node As IConfigSectionNode,
    inputValue As String,
    macroName As String,
    macroParams As IConfigSectionNode,
    Optional context As Object = Nothing
) As String
public:
virtual String^ Run(
    IConfigSectionNode^ node,
    String^ inputValue,
    String^ macroName,
    IConfigSectionNode^ macroParams,
    Object^ context = nullptr
) sealed
public:
virtual String^ Run(
    IConfigSectionNode^ node,
    String^ inputValue,
    String^ macroName,
    IConfigSectionNode^ macroParams,
    Object^ context = nullptr
) sealed
abstract Run :
        node : IConfigSectionNode *
        inputValue : string *
        macroName : string *
        macroParams : IConfigSectionNode *
        ?context : Object
(* Defaults:
        let _context = defaultArg context null
*)
-> string
override Run :
        node : IConfigSectionNode *
        inputValue : string *
        macroName : string *
        macroParams : IConfigSectionNode *
        ?context : Object
(* Defaults:
        let _context = defaultArg context null
*)
-> string
abstract Run :
        node : IConfigSectionNode *
        inputValue : string *
        macroName : string *
        macroParams : IConfigSectionNode *
        ?context : Object
(* Defaults:
        let _context = defaultArg context null
*)
-> string
override Run :
        node : IConfigSectionNode *
        inputValue : string *
        macroName : string *
        macroParams : IConfigSectionNode *
        ?context : Object
(* Defaults:
        let _context = defaultArg context null
*)
-> string

Parameters

node
Type: NFX.Environment IConfigSectionNode
inputValue
Type: Online System String
macroName
Type: Online System String
macroParams
Type: NFX.Environment IConfigSectionNode
context (Optional)
Type: Online System Object

Return Value

Type: Online String

Implements

IMacroRunner Run(IConfigSectionNode, String, String, IConfigSectionNode, Object)
See Also
DefaultMacroRunner Class
DefaultMacroRunner Members
NFX.Environment Namespace


DefaultMacroRunner Properties

DefaultMacroRunner Properties NFX Class Library

The DefaultMacroRunner type exposes the following members.
Properties
Name | Description
Instance | Returns a singleton class instance
Back to Top
See Also
DefaultMacroRunner Class
NFX.Environment Namespace


DefaultMacroRunner.Instance Property

DefaultMacroRunner Instance Property NFX Class Library

Returns a singleton class instance

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DefaultMacroRunner Instance { get; }
public static DefaultMacroRunner Instance { get; }
Public Shared ReadOnly Property Instance As DefaultMacroRunner
    Get
Public Shared ReadOnly Property Instance As DefaultMacroRunner
    Get
public:
static property DefaultMacroRunner^ Instance {
    DefaultMacroRunner^ get ();
}
public:
static property DefaultMacroRunner^ Instance {
    DefaultMacroRunner^ get ();
}
static member Instance : DefaultMacroRunner with get
static member Instance : DefaultMacroRunner with get

Property Value

Type: DefaultMacroRunner
See Also
DefaultMacroRunner Class
DefaultMacroRunner Members
NFX.Environment Namespace


FactoryUtils Class

FactoryUtils Class NFX Class Library

Provides helper methods for dynamic object creation and configuration
Inheritance Hierarchy
Online System Object
NFX.Environment FactoryUtils

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class FactoryUtils
public static class FactoryUtils
Public NotInheritable Class FactoryUtils
Public NotInheritable Class FactoryUtils
public ref class FactoryUtils abstract sealed
public ref class FactoryUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FactoryUtils =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FactoryUtils =  class end
See Also
FactoryUtils Members
NFX.Environment Namespace


FactoryUtils Members

FactoryUtils Members NFX Class Library

The FactoryUtils type exposes the following members.
Methods
Name | Description
Make T | Creates an instance of appropriate configurable object as specified in supplied config node. This function does not configure the instance
MakeAndConfigure(IConfigSectionNode, Type, Object ) | Creates and configures an instance of appropriate configurable object as specified in supplied config node. Applies configured behaviours
MakeAndConfigure T (IConfigSectionNode, Type, Object ) | Creates and configures an instance of appropriate configurable object as specified in supplied config node. Applies configured behaviours
MakeUsingCtor T | Invokes a constructor for type feeding it the specified args: node{type="NS.Type, Assembly" arg0=1 arg1=true....} If the typePattern is passed, then the '*' in pattern is replaced with 'type' attr content. This is needed for security, as this method allows to inject any type with any ctor params when typePattern is null
Back to Top
Fields
Name | Description
CONFIG_TYPE_ATTR |
Back to Top
See Also
FactoryUtils Class
NFX.Environment Namespace


FactoryUtils Fields

FactoryUtils Fields NFX Class Library

The FactoryUtils type exposes the following members.
Fields
Name | Description
CONFIG_TYPE_ATTR |
Back to Top
See Also
FactoryUtils Class
NFX.Environment Namespace


FactoryUtils.CONFIG_TYPE_ATTR Field

FactoryUtils CONFIG_TYPE_ATTR Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_TYPE_ATTR
public const string CONFIG_TYPE_ATTR
Public Const CONFIG_TYPE_ATTR As String
Public Const CONFIG_TYPE_ATTR As String
public:
literal String^ CONFIG_TYPE_ATTR
public:
literal String^ CONFIG_TYPE_ATTR
static val mutable CONFIG_TYPE_ATTR: string
static val mutable CONFIG_TYPE_ATTR: string

Field Value

Type: Online String
See Also
FactoryUtils Class
FactoryUtils Members
NFX.Environment Namespace


FactoryUtils Methods

FactoryUtils Methods NFX Class Library

The FactoryUtils type exposes the following members.
Methods
Name | Description
Make T | Creates an instance of appropriate configurable object as specified in supplied config node. This function does not configure the instance
MakeAndConfigure(IConfigSectionNode, Type, Object ) | Creates and configures an instance of appropriate configurable object as specified in supplied config node. Applies configured behaviours
MakeAndConfigure T (IConfigSectionNode, Type, Object ) | Creates and configures an instance of appropriate configurable object as specified in supplied config node. Applies configured behaviours
MakeUsingCtor T | Invokes a constructor for type feeding it the specified args: node{type="NS.Type, Assembly" arg0=1 arg1=true....} If the typePattern is passed, then the '*' in pattern is replaced with 'type' attr content. This is needed for security, as this method allows to inject any type with any ctor params when typePattern is null
Back to Top
See Also
FactoryUtils Class
NFX.Environment Namespace


FactoryUtils.Make(T) Method

FactoryUtils Make T Method NFX Class Library

Creates an instance of appropriate configurable object as specified in supplied config node. This function does not configure the instance

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static T Make<T>(
    IConfigSectionNode node,
    Type defaultType = null,
    Object[] args = null
)
public static T Make<T>(
    IConfigSectionNode node,
    Type defaultType = null,
    Object[] args = null
)
Public Shared Function Make(Of T) (
    node As IConfigSectionNode,
    Optional defaultType As Type = Nothing,
    Optional args As Object() = Nothing
) As T
Public Shared Function Make(Of T) (
    node As IConfigSectionNode,
    Optional defaultType As Type = Nothing,
    Optional args As Object() = Nothing
) As T
public:
generic<typename T>
static T Make(
    IConfigSectionNode^ node,
    Type^ defaultType = nullptr,
    array<Object^>^ args = nullptr
)
public:
generic<typename T>
static T Make(
    IConfigSectionNode^ node,
    Type^ defaultType = nullptr,
    array<Object^>^ args = nullptr
)
static member Make :
        node : IConfigSectionNode *
        ?defaultType : Type *
        ?args : Object[]
(* Defaults:
        let _defaultType = defaultArg defaultType null
        let _args = defaultArg args null
*)
-> 'T
static member Make :
        node : IConfigSectionNode *
        ?defaultType : Type *
        ?args : Object[]
(* Defaults:
        let _defaultType = defaultArg defaultType null
        let _args = defaultArg args null
*)
-> 'T

Parameters

node
Type: NFX.Environment IConfigSectionNode
defaultType (Optional)
Type: Online System Type
args (Optional)
Type: Online System Object
Type Parameters
T

Return Value

Type: T
See Also
FactoryUtils Class
FactoryUtils Members
NFX.Environment Namespace


FactoryUtils.MakeAndConfigure Method

FactoryUtils MakeAndConfigure Method NFX Class Library

Overload List
Name | Description
MakeAndConfigure T (IConfigSectionNode, Type, Object ) | Creates and configures an instance of appropriate configurable object as specified in supplied config node. Applies configured behaviours
MakeAndConfigure(IConfigSectionNode, Type, Object ) | Creates and configures an instance of appropriate configurable object as specified in supplied config node. Applies configured behaviours
Back to Top
See Also
FactoryUtils Class
FactoryUtils Members
NFX.Environment Namespace


FactoryUtils.MakeAndConfigure(T) Method (IConfigSectionNode, Type, Object[])

FactoryUtils MakeAndConfigure T Method (IConfigSectionNode, Type, Object ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates and configures an instance of appropriate configurable object as specified in supplied config node. Applies configured behaviours

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static T MakeAndConfigure<T>(
    IConfigSectionNode node,
    Type defaultType = null,
    Object[] args = null
)
where T : IConfigurable
public static T MakeAndConfigure<T>(
    IConfigSectionNode node,
    Type defaultType = null,
    Object[] args = null
)
where T : IConfigurable
Public Shared Function MakeAndConfigure(Of T As IConfigurable) (
    node As IConfigSectionNode,
    Optional defaultType As Type = Nothing,
    Optional args As Object() = Nothing
) As T
Public Shared Function MakeAndConfigure(Of T As IConfigurable) (
    node As IConfigSectionNode,
    Optional defaultType As Type = Nothing,
    Optional args As Object() = Nothing
) As T
public:
generic<typename T>
where T : IConfigurable
static T MakeAndConfigure(
    IConfigSectionNode^ node,
    Type^ defaultType = nullptr,
    array<Object^>^ args = nullptr
)
public:
generic<typename T>
where T : IConfigurable
static T MakeAndConfigure(
    IConfigSectionNode^ node,
    Type^ defaultType = nullptr,
    array<Object^>^ args = nullptr
)
static member MakeAndConfigure :
        node : IConfigSectionNode *
        ?defaultType : Type *
        ?args : Object[]
(* Defaults:
        let _defaultType = defaultArg defaultType null
        let _args = defaultArg args null
*)
-> 'T  when 'T : IConfigurable
static member MakeAndConfigure :
        node : IConfigSectionNode *
        ?defaultType : Type *
        ?args : Object[]
(* Defaults:
        let _defaultType = defaultArg defaultType null
        let _args = defaultArg args null
*)
-> 'T  when 'T : IConfigurable

Parameters

node
Type: NFX.Environment IConfigSectionNode
defaultType (Optional)
Type: Online System Type
args (Optional)
Type: Online System Object
Type Parameters
T

Return Value

Type: T
See Also
FactoryUtils Class
FactoryUtils Members
MakeAndConfigure Overload
NFX.Environment Namespace


FactoryUtils.MakeAndConfigure Method (IConfigSectionNode, Type, Object[])

FactoryUtils MakeAndConfigure Method (IConfigSectionNode, Type, Object ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates and configures an instance of appropriate configurable object as specified in supplied config node. Applies configured behaviours

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IConfigurable MakeAndConfigure(
    IConfigSectionNode node,
    Type defaultType = null,
    Object[] args = null
)
public static IConfigurable MakeAndConfigure(
    IConfigSectionNode node,
    Type defaultType = null,
    Object[] args = null
)
Public Shared Function MakeAndConfigure (
    node As IConfigSectionNode,
    Optional defaultType As Type = Nothing,
    Optional args As Object() = Nothing
) As IConfigurable
Public Shared Function MakeAndConfigure (
    node As IConfigSectionNode,
    Optional defaultType As Type = Nothing,
    Optional args As Object() = Nothing
) As IConfigurable
public:
static IConfigurable^ MakeAndConfigure(
    IConfigSectionNode^ node,
    Type^ defaultType = nullptr,
    array<Object^>^ args = nullptr
)
public:
static IConfigurable^ MakeAndConfigure(
    IConfigSectionNode^ node,
    Type^ defaultType = nullptr,
    array<Object^>^ args = nullptr
)
static member MakeAndConfigure :
        node : IConfigSectionNode *
        ?defaultType : Type *
        ?args : Object[]
(* Defaults:
        let _defaultType = defaultArg defaultType null
        let _args = defaultArg args null
*)
-> IConfigurable
static member MakeAndConfigure :
        node : IConfigSectionNode *
        ?defaultType : Type *
        ?args : Object[]
(* Defaults:
        let _defaultType = defaultArg defaultType null
        let _args = defaultArg args null
*)
-> IConfigurable

Parameters

node
Type: NFX.Environment IConfigSectionNode
defaultType (Optional)
Type: Online System Type
args (Optional)
Type: Online System Object

Return Value

Type: IConfigurable
See Also
FactoryUtils Class
FactoryUtils Members
MakeAndConfigure Overload
NFX.Environment Namespace


FactoryUtils.MakeUsingCtor(T) Method

FactoryUtils MakeUsingCtor T Method NFX Class Library

Invokes a constructor for type feeding it the specified args: node{type="NS.Type, Assembly" arg0=1 arg1=true....} If the typePattern is passed, then the '*' in pattern is replaced with 'type' attr content. This is needed for security, as this method allows to inject any type with any ctor params when typePattern is null

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static T MakeUsingCtor<T>(
    IConfigSectionNode node,
    string typePattern = null
)
public static T MakeUsingCtor<T>(
    IConfigSectionNode node,
    string typePattern = null
)
Public Shared Function MakeUsingCtor(Of T) (
    node As IConfigSectionNode,
    Optional typePattern As String = Nothing
) As T
Public Shared Function MakeUsingCtor(Of T) (
    node As IConfigSectionNode,
    Optional typePattern As String = Nothing
) As T
public:
generic<typename T>
static T MakeUsingCtor(
    IConfigSectionNode^ node,
    String^ typePattern = nullptr
)
public:
generic<typename T>
static T MakeUsingCtor(
    IConfigSectionNode^ node,
    String^ typePattern = nullptr
)
static member MakeUsingCtor :
        node : IConfigSectionNode *
        ?typePattern : string
(* Defaults:
        let _typePattern = defaultArg typePattern null
*)
-> 'T
static member MakeUsingCtor :
        node : IConfigSectionNode *
        ?typePattern : string
(* Defaults:
        let _typePattern = defaultArg typePattern null
*)
-> 'T

Parameters

node
Type: NFX.Environment IConfigSectionNode
typePattern (Optional)
Type: Online System String
Type Parameters
T

Return Value

Type: T
See Also
FactoryUtils Class
FactoryUtils Members
NFX.Environment Namespace


FileConfiguration Class

FileConfiguration Class NFX Class Library

Provides file-based configuration base object used for concrete implementations such as XML or INI file base configurations
Inheritance Hierarchy
Online System Object
NFX.Environment Configuration
NFX.Environment FileConfiguration
NFX.Environment JSONConfiguration
NFX.Environment LaconicConfiguration
NFX.Environment XMLConfiguration

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class FileConfiguration : Configuration
[SerializableAttribute]
public abstract class FileConfiguration : Configuration
<SerializableAttribute>
Public MustInherit Class FileConfiguration
    Inherits Configuration
<SerializableAttribute>
Public MustInherit Class FileConfiguration
    Inherits Configuration
[SerializableAttribute]
public ref class FileConfiguration abstract : public Configuration
[SerializableAttribute]
public ref class FileConfiguration abstract : public Configuration
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type FileConfiguration =
    class
        inherit Configuration
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type FileConfiguration =
    class
        inherit Configuration
    end
See Also
FileConfiguration Members
NFX.Environment Namespace


FileConfiguration Members

FileConfiguration Members NFX Class Library

The FileConfiguration type exposes the following members.
Constructors
 | Name | Description
Protected method | FileConfiguration | Creates an instance of a new configuration not bound to any file
Protected method | FileConfiguration(String) | Creates an isntance of configuration and reads contents from the file
Back to Top
Methods
 | Name | Description
Protected method | AdjustNodeName | Override to perform transforms on node names so they become suitable for particular configuration type (Inherited from Configuration.)
Public method | CheckAndAdjustNodeName | Checks node name for aptitude for particular configuration type. For example, XML configuration does not allow nodes with spaces or separator chars. When StrictNames is set to true and value is not appropriate then exception is thrown (Inherited from Configuration.)
Public method | Clone(Configuration) | Creates a deep copy of this configuration into newInstance which was allocated externally (Inherited from Configuration.)
Public method | Clone T | Creates a deep copy of this configuration into new instance of T (Inherited from Configuration.)
Public method | Create | Creates new configuration - creates new configuration root with optional name parameter (Inherited from Configuration.)
Public method | CreateFromMerge | Creates new configuration from ordered merge result of two other nodes - base and override which can be from different configurations (Inherited from Configuration.)
Public method | CreateFromNode | Creates new configuration from other node, which may belong to a different configuration instance (Inherited from Configuration.)
Public method | Destroy | Erases all config data (Inherited from Configuration.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Include | Completely replaces this node with another node tree, positioning the new tree in the place of local node. Existing node is deleted after this operation completes, in its place child nodes from other node are inserted preserving their existing order. Attributes of other node get merged into parent of existing node (Inherited from Configuration.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Refresh | Re-reads configuration from source (Inherited from Configuration.)
Public method | ResolveEnvironmentVar | Resolves variable name into its value (Inherited from Configuration.)
Public method | RunMacro | Runs macro and returns its value (Inherited from Configuration.)
Public method | Save | Saves configuration to source (Inherited from Configuration.)
Public method | SaveAs | Saves configuration into specified file
Public method | SetReadOnly |
Public method | ToConfigurationJSONDataMap | Returns this config as JSON data map suitable for making JSONConfiguration (Inherited from Configuration.)
Public method | ToLaconicFile | Serializes configuration tree into Laconic format and writes it into a file (Inherited from Configuration.)
Public method | ToLaconicStream | Serializes configuration tree into Laconic format and writes it into stream (Inherited from Configuration.)
Public method | ToLaconicString | Serializes configuration tree into Laconic format and returns it as a string (Inherited from Configuration.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_EmptyAttrNode | (Inherited from Configuration.)
Protected field | m_EmptySectionNode | (Inherited from Configuration.)
Protected field | m_FileName |
Protected field | m_Root | (Inherited from Configuration.)
Back to Top
Properties
 | Name | Description
Public property | ContentView | Primarily used for debugging - returns the content of the configuration as text in the pretty-printed Laconic format (Inherited from Configuration.)
Public property | EmptyAttr | References a special instance of an empty attribute node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist (Inherited from Configuration.)
Public property | EmptySection | References a special instance of an empty section node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist (Inherited from Configuration.)
Public property | EnvironmentVarResolver | References variable resolver. If this property is not set then default Windows environment var resolver is used (Inherited from Configuration.)
Public property | FileName |
Public property | IsReadOnly | Indicates whether configuration is readonly or may be modified and saved (Overrides Configuration IsReadOnly.)
Public property | MacroRunner | References macro runner. If this property is not set then default macro runner is used (Inherited from Configuration.)
Public property | MacroRunnerContext | Gets/sets an object passed by the framework into MacroRunner.Run() method. This property is auto-set for classes decorated with [ConfigMacroContext] attribute (Inherited from Configuration.)
Public property | Root | Accesses root section configuration node (Inherited from Configuration.)
Public property | StrictNames | Determines whether exception is thrown when configuration node name contains inappropriate chars for particular configuration type. For example, for XMLConfiguration node names may not have spaces and other separator chars. When StrictNames is false then particular configurations may replace incompatible chars in node names with neutral ones (i.e. "my value"->"my-value" in case of XMLConfiguration). (Inherited from Configuration.)
Public property | Variable_END | Variable end tag (Inherited from Configuration.)
Public property | Variable_ENV_MOD | Variable environment modifier (Inherited from Configuration.)
Public property | Variable_ESCAPE | Variable escape tag (Inherited from Configuration.)
Public property | Variable_MACRO_START | Variable get clause modifier (Inherited from Configuration.)
Public property | Variable_PATH_MOD | Variable path modifier (Inherited from Configuration.)
Public property | Variable_START | Variable start tag (Inherited from Configuration.)
Back to Top
See Also
FileConfiguration Class
NFX.Environment Namespace


FileConfiguration Constructor

FileConfiguration Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | FileConfiguration | Creates an instance of a new configuration not bound to any file
Protected method | FileConfiguration(String) | Creates an isntance of configuration and reads contents from the file
Back to Top
See Also
FileConfiguration Class
FileConfiguration Members
NFX.Environment Namespace


FileConfiguration Constructor

FileConfiguration Constructor NFX Class Library

Creates an instance of a new configuration not bound to any file

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FileConfiguration()
protected FileConfiguration()
Protected Sub New
Protected Sub New
protected:
FileConfiguration()
protected:
FileConfiguration()
new : unit -> FileConfiguration
new : unit -> FileConfiguration
See Also
FileConfiguration Class
FileConfiguration Members
FileConfiguration Overload
NFX.Environment Namespace


FileConfiguration Constructor (String)

FileConfiguration Constructor (String) NFX Class Library

Creates an isntance of configuration and reads contents from the file

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FileConfiguration(
    string filename
)
protected FileConfiguration(
    string filename
)
Protected Sub New (
    filename As String
)
Protected Sub New (
    filename As String
)
protected:
FileConfiguration(
    String^ filename
)
protected:
FileConfiguration(
    String^ filename
)
new :
        filename : string -> FileConfiguration
new :
        filename : string -> FileConfiguration

Parameters

filename
Type: Online System String
See Also
FileConfiguration Class
FileConfiguration Members
FileConfiguration Overload
NFX.Environment Namespace


FileConfiguration Fields

FileConfiguration Fields NFX Class Library

The FileConfiguration type exposes the following members.
Fields
 | Name | Description
Protected field | m_EmptyAttrNode | (Inherited from Configuration.)
Protected field | m_EmptySectionNode | (Inherited from Configuration.)
Protected field | m_FileName |
Protected field | m_Root | (Inherited from Configuration.)
Back to Top
See Also
FileConfiguration Class
NFX.Environment Namespace


FileConfiguration.m_FileName Field

FileConfiguration m_FileName Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected string m_FileName
protected string m_FileName
Protected m_FileName As String
Protected m_FileName As String
protected:
String^ m_FileName
protected:
String^ m_FileName
val mutable m_FileName: string
val mutable m_FileName: string

Field Value

Type: Online String
See Also
FileConfiguration Class
FileConfiguration Members
NFX.Environment Namespace


FileConfiguration Methods

FileConfiguration Methods NFX Class Library

The FileConfiguration type exposes the following members.
Methods
 | Name | Description
Protected method | AdjustNodeName | Override to perform transforms on node names so they become suitable for particular configuration type (Inherited from Configuration.)
Public method | CheckAndAdjustNodeName | Checks node name for aptitude for particular configuration type. For example, XML configuration does not allow nodes with spaces or separator chars. When StrictNames is set to true and value is not appropriate then exception is thrown (Inherited from Configuration.)
Public method | Clone(Configuration) | Creates a deep copy of this configuration into newInstance which was allocated externally (Inherited from Configuration.)
Public method | Clone T | Creates a deep copy of this configuration into new instance of T (Inherited from Configuration.)
Public method | Create | Creates new configuration - creates new configuration root with optional name parameter (Inherited from Configuration.)
Public method | CreateFromMerge | Creates new configuration from ordered merge result of two other nodes - base and override which can be from different configurations (Inherited from Configuration.)
Public method | CreateFromNode | Creates new configuration from other node, which may belong to a different configuration instance (Inherited from Configuration.)
Public method | Destroy | Erases all config data (Inherited from Configuration.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Include | Completely replaces this node with another node tree, positioning the new tree in the place of local node. Existing node is deleted after this operation completes, in its place child nodes from other node are inserted preserving their existing order. Attributes of other node get merged into parent of existing node (Inherited from Configuration.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Refresh | Re-reads configuration from source (Inherited from Configuration.)
Public method | ResolveEnvironmentVar | Resolves variable name into its value (Inherited from Configuration.)
Public method | RunMacro | Runs macro and returns its value (Inherited from Configuration.)
Public method | Save | Saves configuration to source (Inherited from Configuration.)
Public method | SaveAs | Saves configuration into specified file
Public method | SetReadOnly |
Public method | ToConfigurationJSONDataMap | Returns this config as JSON data map suitable for making JSONConfiguration (Inherited from Configuration.)
Public method | ToLaconicFile | Serializes configuration tree into Laconic format and writes it into a file (Inherited from Configuration.)
Public method | ToLaconicStream | Serializes configuration tree into Laconic format and writes it into stream (Inherited from Configuration.)
Public method | ToLaconicString | Serializes configuration tree into Laconic format and returns it as a string (Inherited from Configuration.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
FileConfiguration Class
NFX.Environment Namespace


FileConfiguration.SaveAs Method

FileConfiguration SaveAs Method NFX Class Library

Saves configuration into specified file

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SaveAs(
    string filename
)
public virtual void SaveAs(
    string filename
)
Public Overridable Sub SaveAs (
    filename As String
)
Public Overridable Sub SaveAs (
    filename As String
)
public:
virtual void SaveAs(
    String^ filename
)
public:
virtual void SaveAs(
    String^ filename
)
abstract SaveAs :
        filename : string -> unit
override SaveAs :
        filename : string -> unit
abstract SaveAs :
        filename : string -> unit
override SaveAs :
        filename : string -> unit

Parameters

filename
Type: Online System String
See Also
FileConfiguration Class
FileConfiguration Members
NFX.Environment Namespace


FileConfiguration.SetReadOnly Method

FileConfiguration SetReadOnly Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetReadOnly(
    bool val
)
public void SetReadOnly(
    bool val
)
Public Sub SetReadOnly (
    val As Boolean
)
Public Sub SetReadOnly (
    val As Boolean
)
public:
void SetReadOnly(
    bool val
)
public:
void SetReadOnly(
    bool val
)
member SetReadOnly :
        val : bool -> unit
member SetReadOnly :
        val : bool -> unit

Parameters

val
Type: Online System Boolean
See Also
FileConfiguration Class
FileConfiguration Members
NFX.Environment Namespace


FileConfiguration Properties

FileConfiguration Properties NFX Class Library

The FileConfiguration type exposes the following members.
Properties
 | Name | Description
Public property | ContentView | Primarily used for debugging - returns the content of the configuration as text in the pretty-printed Laconic format (Inherited from Configuration.)
Public property | EmptyAttr | References a special instance of an empty attribute node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist (Inherited from Configuration.)
Public property | EmptySection | References a special instance of an empty section node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist (Inherited from Configuration.)
Public property | EnvironmentVarResolver | References variable resolver. If this property is not set then default Windows environment var resolver is used (Inherited from Configuration.)
Public property | FileName |
Public property | IsReadOnly | Indicates whether configuration is readonly or may be modified and saved (Overrides Configuration IsReadOnly.)
Public property | MacroRunner | References macro runner. If this property is not set then default macro runner is used (Inherited from Configuration.)
Public property | MacroRunnerContext | Gets/sets an object passed by the framework into MacroRunner.Run() method. This property is auto-set for classes decorated with [ConfigMacroContext] attribute (Inherited from Configuration.)
Public property | Root | Accesses root section configuration node (Inherited from Configuration.)
Public property | StrictNames | Determines whether exception is thrown when configuration node name contains inappropriate chars for particular configuration type. For example, for XMLConfiguration node names may not have spaces and other separator chars. When StrictNames is false then particular configurations may replace incompatible chars in node names with neutral ones (i.e. "my value"->"my-value" in case of XMLConfiguration). (Inherited from Configuration.)
Public property | Variable_END | Variable end tag (Inherited from Configuration.)
Public property | Variable_ENV_MOD | Variable environment modifier (Inherited from Configuration.)
Public property | Variable_ESCAPE | Variable escape tag (Inherited from Configuration.)
Public property | Variable_MACRO_START | Variable get clause modifier (Inherited from Configuration.)
Public property | Variable_PATH_MOD | Variable path modifier (Inherited from Configuration.)
Public property | Variable_START | Variable start tag (Inherited from Configuration.)
Back to Top
See Also
FileConfiguration Class
NFX.Environment Namespace


FileConfiguration.FileName Property

FileConfiguration FileName Property NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string FileName { get; }
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}
public:
property String^ FileName {
    String^ get ();
}
member FileName : string with get
member FileName : string with get

Property Value

Type: Online String
See Also
FileConfiguration Class
FileConfiguration Members
NFX.Environment Namespace


FileConfiguration.IsReadOnly Property

FileConfiguration IsReadOnly Property NFX Class Library

Indicates whether configuration is readonly or may be modified and saved

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsReadOnly { get; }
public override bool IsReadOnly { get; }
Public Overrides ReadOnly Property IsReadOnly As Boolean
    Get
Public Overrides ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get () override;
}
public:
virtual property bool IsReadOnly {
    bool get () override;
}
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get

Property Value

Type: Online Boolean
See Also
FileConfiguration Class
FileConfiguration Members
NFX.Environment Namespace


IConfigAttrNode Interface

IConfigAttrNode Interface NFX Class Library

Represents a read-only attribute of a attribute node

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IConfigAttrNode : IConfigNode,
    INamed
public interface IConfigAttrNode : IConfigNode,
    INamed
Public Interface IConfigAttrNode
    Inherits IConfigNode, INamed
Public Interface IConfigAttrNode
    Inherits IConfigNode, INamed
public interface class IConfigAttrNode : IConfigNode,
    INamed
public interface class IConfigAttrNode : IConfigNode,
    INamed
type IConfigAttrNode =
    interface
        interface IConfigNode
        interface INamed
    end
type IConfigAttrNode =
    interface
        interface IConfigNode
        interface INamed
    end
See Also
IConfigAttrNode Members
NFX.Environment Namespace


IConfigAttrNode Members

IConfigAttrNode Members NFX Class Library

The IConfigAttrNode type exposes the following members.
Methods
 | Name | Description
Public method | IsSameName(String) | Returns true when another name is the same as this node's name (Inherited from IConfigNode.)
Public method | IsSameName(IConfigNode) | Returns true when another node has the same name as this one (Inherited from IConfigNode.)
Public method | ValueAsBool | (Inherited from IConfigNode.)
Public method | ValueAsByte | (Inherited from IConfigNode.)
Public method | ValueAsByteArray | (Inherited from IConfigNode.)
Public method | ValueAsDateTime | (Inherited from IConfigNode.)
Public method | ValueAsDecimal | (Inherited from IConfigNode.)
Public method | ValueAsDouble | (Inherited from IConfigNode.)
Public method | ValueAsEnum TEnum | (Inherited from IConfigNode.)
Public method | ValueAsFloat | (Inherited from IConfigNode.)
Public method | ValueAsGDID | (Inherited from IConfigNode.)
Public method | ValueAsGUID | (Inherited from IConfigNode.)
Public method | ValueAsInt | (Inherited from IConfigNode.)
Public method | ValueAsLong | (Inherited from IConfigNode.)
Public method | ValueAsNullableBool | (Inherited from IConfigNode.)
Public method | ValueAsNullableByte | (Inherited from IConfigNode.)
Public method | ValueAsNullableDateTime | (Inherited from IConfigNode.)
Public method | ValueAsNullableDecimal | (Inherited from IConfigNode.)
Public method | ValueAsNullableDouble | (Inherited from IConfigNode.)
Public method | ValueAsNullableEnum TEnum | (Inherited from IConfigNode.)
Public method | ValueAsNullableFloat | (Inherited from IConfigNode.)
Public method | ValueAsNullableGDID | (Inherited from IConfigNode.)
Public method | ValueAsNullableGUID | (Inherited from IConfigNode.)
Public method | ValueAsNullableInt | (Inherited from IConfigNode.)
Public method | ValueAsNullableLong | (Inherited from IConfigNode.)
Public method | ValueAsNullableSByte | (Inherited from IConfigNode.)
Public method | ValueAsNullableShort | (Inherited from IConfigNode.)
Public method | ValueAsNullableTimeSpan | (Inherited from IConfigNode.)
Public method | ValueAsNullableUInt | (Inherited from IConfigNode.)
Public method | ValueAsNullableULong | (Inherited from IConfigNode.)
Public method | ValueAsNullableUShort | (Inherited from IConfigNode.)
Public method | ValueAsSByte | (Inherited from IConfigNode.)
Public method | ValueAsShort | (Inherited from IConfigNode.)
Public method | ValueAsString | (Inherited from IConfigNode.)
Public method | ValueAsTimeSpan | (Inherited from IConfigNode.)
Public method | ValueAsType | Tries to get value as specified type or throws if it can not be converted (Inherited from IConfigNode.)
Public method | ValueAsUInt | (Inherited from IConfigNode.)
Public method | ValueAsULong | (Inherited from IConfigNode.)
Public method | ValueAsUShort | (Inherited from IConfigNode.)
Back to Top
Properties
 | Name | Description
Public property | Configuration | References configuration this node is under (Inherited from IConfigNode.)
Public property | EvaluatedValue | Returns null or value of this node with all variables evaluated (Inherited from IConfigNode.)
Public property | Exists | Determines whether this node really exists in configuration or is just a sentinel empty node (Inherited from IConfigNode.)
Public property | Name | (Inherited from INamed.)
Public property | Parent | References parent node or empty node if this is the top-most node with no parent (Inherited from IConfigNode.)
Public property | RootPath | Returns a path from root to this node (Inherited from IConfigNode.)
Public property | Value | Returns null or value of this node with all variables evaluated (Inherited from IConfigNode.)
Public property | VerbatimValue | Returns varbatim (without variable evaluation) node value or null (Inherited from IConfigNode.)
Back to Top
See Also
IConfigAttrNode Interface
NFX.Environment Namespace


IConfigAttrNode Methods

IConfigAttrNode Methods NFX Class Library

The IConfigAttrNode type exposes the following members.
Methods
 | Name | Description
Public method | IsSameName(String) | Returns true when another name is the same as this node's name (Inherited from IConfigNode.)
Public method | IsSameName(IConfigNode) | Returns true when another node has the same name as this one (Inherited from IConfigNode.)
Public method | ValueAsBool | (Inherited from IConfigNode.)
Public method | ValueAsByte | (Inherited from IConfigNode.)
Public method | ValueAsByteArray | (Inherited from IConfigNode.)
Public method | ValueAsDateTime | (Inherited from IConfigNode.)
Public method | ValueAsDecimal | (Inherited from IConfigNode.)
Public method | ValueAsDouble | (Inherited from IConfigNode.)
Public method | ValueAsEnum TEnum | (Inherited from IConfigNode.)
Public method | ValueAsFloat | (Inherited from IConfigNode.)
Public method | ValueAsGDID | (Inherited from IConfigNode.)
Public method | ValueAsGUID | (Inherited from IConfigNode.)
Public method | ValueAsInt | (Inherited from IConfigNode.)
Public method | ValueAsLong | (Inherited from IConfigNode.)
Public method | ValueAsNullableBool | (Inherited from IConfigNode.)
Public method | ValueAsNullableByte | (Inherited from IConfigNode.)
Public method | ValueAsNullableDateTime | (Inherited from IConfigNode.)
Public method | ValueAsNullableDecimal | (Inherited from IConfigNode.)
Public method | ValueAsNullableDouble | (Inherited from IConfigNode.)
Public method | ValueAsNullableEnum TEnum | (Inherited from IConfigNode.)
Public method | ValueAsNullableFloat | (Inherited from IConfigNode.)
Public method | ValueAsNullableGDID | (Inherited from IConfigNode.)
Public method | ValueAsNullableGUID | (Inherited from IConfigNode.)
Public method | ValueAsNullableInt | (Inherited from IConfigNode.)
Public method | ValueAsNullableLong | (Inherited from IConfigNode.)
Public method | ValueAsNullableSByte | (Inherited from IConfigNode.)
Public method | ValueAsNullableShort | (Inherited from IConfigNode.)
Public method | ValueAsNullableTimeSpan | (Inherited from IConfigNode.)
Public method | ValueAsNullableUInt | (Inherited from IConfigNode.)
Public method | ValueAsNullableULong | (Inherited from IConfigNode.)
Public method | ValueAsNullableUShort | (Inherited from IConfigNode.)
Public method | ValueAsSByte | (Inherited from IConfigNode.)
Public method | ValueAsShort | (Inherited from IConfigNode.)
Public method | ValueAsString | (Inherited from IConfigNode.)
Public method | ValueAsTimeSpan | (Inherited from IConfigNode.)
Public method | ValueAsType | Tries to get value as specified type or throws if it can not be converted (Inherited from IConfigNode.)
Public method | ValueAsUInt | (Inherited from IConfigNode.)
Public method | ValueAsULong | (Inherited from IConfigNode.)
Public method | ValueAsUShort | (Inherited from IConfigNode.)
Back to Top
See Also
IConfigAttrNode Interface
NFX.Environment Namespace


IConfigAttrNode Properties

IConfigAttrNode Properties NFX Class Library

The IConfigAttrNode type exposes the following members.
Properties
 | Name | Description
Public property | Configuration | References configuration this node is under (Inherited from IConfigNode.)
Public property | EvaluatedValue | Returns null or value of this node with all variables evaluated (Inherited from IConfigNode.)
Public property | Exists | Determines whether this node really exists in configuration or is just a sentinel empty node (Inherited from IConfigNode.)
Public property | Name | (Inherited from INamed.)
Public property | Parent | References parent node or empty node if this is the top-most node with no parent (Inherited from IConfigNode.)
Public property | RootPath | Returns a path from root to this node (Inherited from IConfigNode.)
Public property | Value | Returns null or value of this node with all variables evaluated (Inherited from IConfigNode.)
Public property | VerbatimValue | Returns varbatim (without variable evaluation) node value or null (Inherited from IConfigNode.)
Back to Top
See Also
IConfigAttrNode Interface
NFX.Environment Namespace


IConfigNode Interface

IConfigNode Interface NFX Class Library

Provides read-only configuration node abstraction for section and attribute nodes

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IConfigNode : INamed
public interface IConfigNode : INamed
Public Interface IConfigNode
    Inherits INamed
Public Interface IConfigNode
    Inherits INamed
public interface class IConfigNode : INamed
public interface class IConfigNode : INamed
type IConfigNode =
    interface
        interface INamed
    end
type IConfigNode =
    interface
        interface INamed
    end
See Also
IConfigNode Members
NFX.Environment Namespace


IConfigNode Members

IConfigNode Members NFX Class Library

The IConfigNode type exposes the following members.
Methods
 | Name | Description
Public method | IsSameName(String) | Returns true when another name is the same as this node's name
Public method | IsSameName(IConfigNode) | Returns true when another node has the same name as this one
Public method | ValueAsBool |
Public method | ValueAsByte |
Public method | ValueAsByteArray |
Public method | ValueAsDateTime |
Public method | ValueAsDecimal |
Public method | ValueAsDouble |
Public method | ValueAsEnum TEnum |
Public method | ValueAsFloat |
Public method | ValueAsGDID |
Public method | ValueAsGUID |
Public method | ValueAsInt |
Public method | ValueAsLong |
Public method | ValueAsNullableBool |
Public method | ValueAsNullableByte |
Public method | ValueAsNullableDateTime |
Public method | ValueAsNullableDecimal |
Public method | ValueAsNullableDouble |
Public method | ValueAsNullableEnum TEnum |
Public method | ValueAsNullableFloat |
Public method | ValueAsNullableGDID |
Public method | ValueAsNullableGUID |
Public method | ValueAsNullableInt |
Public method | ValueAsNullableLong |
Public method | ValueAsNullableSByte |
Public method | ValueAsNullableShort |
Public method | ValueAsNullableTimeSpan |
Public method | ValueAsNullableUInt |
Public method | ValueAsNullableULong |
Public method | ValueAsNullableUShort |
Public method | ValueAsSByte |
Public method | ValueAsShort |
Public method | ValueAsString |
Public method | ValueAsTimeSpan |
Public method | ValueAsType | Tries to get value as specified type or throws if it can not be converted
Public method | ValueAsUInt |
Public method | ValueAsULong |
Public method | ValueAsUShort |
Back to Top
Properties
 | Name | Description
Public property | Configuration | References configuration this node is under
Public property | EvaluatedValue | Returns null or value of this node with all variables evaluated
Public property | Exists | Determines whether this node really exists in configuration or is just a sentinel empty node
Public property | Name | (Inherited from INamed.)
Public property | Parent | References parent node or empty node if this is the top-most node with no parent
Public property | RootPath | Returns a path from root to this node
Public property | Value | Returns null or value of this node with all variables evaluated
Public property | VerbatimValue | Returns varbatim (without variable evaluation) node value or null
Back to Top
See Also
IConfigNode Interface
NFX.Environment Namespace


IConfigNode Methods

IConfigNode Methods NFX Class Library

The IConfigNode type exposes the following members.
Methods
 | Name | Description
Public method | IsSameName(String) | Returns true when another name is the same as this node's name
Public method | IsSameName(IConfigNode) | Returns true when another node has the same name as this one
Public method | ValueAsBool |
Public method | ValueAsByte |
Public method | ValueAsByteArray |
Public method | ValueAsDateTime |
Public method | ValueAsDecimal |
Public method | ValueAsDouble |
Public method | ValueAsEnum TEnum |
Public method | ValueAsFloat |
Public method | ValueAsGDID |
Public method | ValueAsGUID |
Public method | ValueAsInt |
Public method | ValueAsLong |
Public method | ValueAsNullableBool |
Public method | ValueAsNullableByte |
Public method | ValueAsNullableDateTime |
Public method | ValueAsNullableDecimal |
Public method | ValueAsNullableDouble |
Public method | ValueAsNullableEnum TEnum |
Public method | ValueAsNullableFloat |
Public method | ValueAsNullableGDID |
Public method | ValueAsNullableGUID |
Public method | ValueAsNullableInt |
Public method | ValueAsNullableLong |
Public method | ValueAsNullableSByte |
Public method | ValueAsNullableShort |
Public method | ValueAsNullableTimeSpan |
Public method | ValueAsNullableUInt |
Public method | ValueAsNullableULong |
Public method | ValueAsNullableUShort |
Public method | ValueAsSByte |
Public method | ValueAsShort |
Public method | ValueAsString |
Public method | ValueAsTimeSpan |
Public method | ValueAsType | Tries to get value as specified type or throws if it can not be converted
Public method | ValueAsUInt |
Public method | ValueAsULong |
Public method | ValueAsUShort |
Back to Top
See Also
IConfigNode Interface
NFX.Environment Namespace


IConfigNode.IsSameName Method

IConfigNode IsSameName Method NFX Class Library

Overload List
 | Name | Description
Public method | IsSameName(String) | Returns true when another name is the same as this node's name
Public method | IsSameName(IConfigNode) | Returns true when another node has the same name as this one
Back to Top
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.IsSameName Method (String)

IConfigNode IsSameName Method (String) NFX Class Library

Returns true when another name is the same as this node's name

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsSameName(
    string other
)
bool IsSameName(
    string other
)
Function IsSameName (
    other As String
) As Boolean
Function IsSameName (
    other As String
) As Boolean
bool IsSameName(
    String^ other
)
bool IsSameName(
    String^ other
)
abstract IsSameName :
        other : string -> bool
abstract IsSameName :
        other : string -> bool

Parameters

other
Type: Online System String

Return Value

Type: Online Boolean
See Also
IConfigNode Interface
IConfigNode Members
IsSameName Overload
NFX.Environment Namespace


IConfigNode.IsSameName Method (IConfigNode)

IConfigNode IsSameName Method (IConfigNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns true when another node has the same name as this one

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsSameName(
    IConfigNode other
)
bool IsSameName(
    IConfigNode other
)
Function IsSameName (
    other As IConfigNode
) As Boolean
Function IsSameName (
    other As IConfigNode
) As Boolean
bool IsSameName(
    IConfigNode^ other
)
bool IsSameName(
    IConfigNode^ other
)
abstract IsSameName :
        other : IConfigNode -> bool
abstract IsSameName :
        other : IConfigNode -> bool

Parameters

other
Type: NFX.Environment IConfigNode

Return Value

Type: Online Boolean
See Also
IConfigNode Interface
IConfigNode Members
IsSameName Overload
NFX.Environment Namespace


IConfigNode.ValueAsBool Method

IConfigNode ValueAsBool Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool ValueAsBool(
    bool dflt = false,
    bool verbatim = false
)
bool ValueAsBool(
    bool dflt = false,
    bool verbatim = false
)
Function ValueAsBool (
    Optional dflt As Boolean = false,
    Optional verbatim As Boolean = false
) As Boolean
Function ValueAsBool (
    Optional dflt As Boolean = false,
    Optional verbatim As Boolean = false
) As Boolean
bool ValueAsBool(
    bool dflt = false,
    bool verbatim = false
)
bool ValueAsBool(
    bool dflt = false,
    bool verbatim = false
)
abstract ValueAsBool :
        ?dflt : bool *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt false
        let _verbatim = defaultArg verbatim false
*)
-> bool
abstract ValueAsBool :
        ?dflt : bool *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt false
        let _verbatim = defaultArg verbatim false
*)
-> bool

Parameters

dflt (Optional)
Type: Online System Boolean
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Boolean
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsByte Method

IConfigNode ValueAsByte Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
byte ValueAsByte(
    byte dflt = 0,
    bool verbatim = false
)
byte ValueAsByte(
    byte dflt = 0,
    bool verbatim = false
)
Function ValueAsByte (
    Optional dflt As Byte = 0,
    Optional verbatim As Boolean = false
) As Byte
Function ValueAsByte (
    Optional dflt As Byte = 0,
    Optional verbatim As Boolean = false
) As Byte
unsigned char ValueAsByte(
    unsigned char dflt = 0,
    bool verbatim = false
)
unsigned char ValueAsByte(
    unsigned char dflt = 0,
    bool verbatim = false
)
abstract ValueAsByte :
        ?dflt : byte *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> byte
abstract ValueAsByte :
        ?dflt : byte *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> byte

Parameters

dflt (Optional)
Type: Online System Byte
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Byte
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsByteArray Method

IConfigNode ValueAsByteArray Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
byte[] ValueAsByteArray(
    byte[] dflt = null,
    bool verbatim = false
)
byte[] ValueAsByteArray(
    byte[] dflt = null,
    bool verbatim = false
)
Function ValueAsByteArray (
    Optional dflt As Byte() = Nothing,
    Optional verbatim As Boolean = false
) As Byte()
Function ValueAsByteArray (
    Optional dflt As Byte() = Nothing,
    Optional verbatim As Boolean = false
) As Byte()
array<unsigned char>^ ValueAsByteArray(
    array<unsigned char>^ dflt = nullptr,
    bool verbatim = false
)
array<unsigned char>^ ValueAsByteArray(
    array<unsigned char>^ dflt = nullptr,
    bool verbatim = false
)
abstract ValueAsByteArray :
        ?dflt : byte[] *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> byte[]
abstract ValueAsByteArray :
        ?dflt : byte[] *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> byte[]

Parameters

dflt (Optional)
Type: Online System Byte
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Byte
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsDateTime Method

IConfigNode ValueAsDateTime Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
DateTime ValueAsDateTime(
    DateTime dflt,
    bool verbatim = false
)
DateTime ValueAsDateTime(
    DateTime dflt,
    bool verbatim = false
)
Function ValueAsDateTime (
    dflt As DateTime,
    Optional verbatim As Boolean = false
) As DateTime
Function ValueAsDateTime (
    dflt As DateTime,
    Optional verbatim As Boolean = false
) As DateTime
DateTime ValueAsDateTime(
    DateTime dflt,
    bool verbatim = false
)
DateTime ValueAsDateTime(
    DateTime dflt,
    bool verbatim = false
)
abstract ValueAsDateTime :
        dflt : DateTime *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> DateTime
abstract ValueAsDateTime :
        dflt : DateTime *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> DateTime

Parameters

dflt
Type: Online System DateTime
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online DateTime
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsDecimal Method

IConfigNode ValueAsDecimal Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
decimal ValueAsDecimal(
    [OptionalAttribute] decimal dflt,
    bool verbatim = false
)
decimal ValueAsDecimal(
    [OptionalAttribute] decimal dflt,
    bool verbatim = false
)
Function ValueAsDecimal (
    <OptionalAttribute> dflt As Decimal,
    Optional verbatim As Boolean = false
) As Decimal
Function ValueAsDecimal (
    <OptionalAttribute> dflt As Decimal,
    Optional verbatim As Boolean = false
) As Decimal
Decimal ValueAsDecimal(
    [OptionalAttribute] Decimal dflt,
    bool verbatim = false
)
Decimal ValueAsDecimal(
    [OptionalAttribute] Decimal dflt,
    bool verbatim = false
)
abstract ValueAsDecimal :
        [<OptionalAttribute>] dflt : decimal *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> decimal
abstract ValueAsDecimal :
        [<OptionalAttribute>] dflt : decimal *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> decimal

Parameters

dflt (Optional)
Type: Online System Decimal
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Decimal
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsDouble Method

IConfigNode ValueAsDouble Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
double ValueAsDouble(
    double dflt = 0,
    bool verbatim = false
)
double ValueAsDouble(
    double dflt = 0,
    bool verbatim = false
)
Function ValueAsDouble (
    Optional dflt As Double = 0,
    Optional verbatim As Boolean = false
) As Double
Function ValueAsDouble (
    Optional dflt As Double = 0,
    Optional verbatim As Boolean = false
) As Double
double ValueAsDouble(
    double dflt = 0,
    bool verbatim = false
)
double ValueAsDouble(
    double dflt = 0,
    bool verbatim = false
)
abstract ValueAsDouble :
        ?dflt : float *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> float
abstract ValueAsDouble :
        ?dflt : float *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> float

Parameters

dflt (Optional)
Type: Online System Double
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Double
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsEnum(TEnum) Method

IConfigNode ValueAsEnum TEnum Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
TEnum ValueAsEnum<TEnum>(
    TEnum dflt = null,
    bool verbatim = false
)
where TEnum : struct, new()
TEnum ValueAsEnum<TEnum>(
    TEnum dflt = null,
    bool verbatim = false
)
where TEnum : struct, new()
Function ValueAsEnum(Of TEnum As {Structure, New}) (
    Optional dflt As TEnum = Nothing,
    Optional verbatim As Boolean = false
) As TEnum
Function ValueAsEnum(Of TEnum As {Structure, New}) (
    Optional dflt As TEnum = Nothing,
    Optional verbatim As Boolean = false
) As TEnum
generic<typename TEnum>
where TEnum : value class, gcnew()
TEnum ValueAsEnum(
    TEnum dflt = nullptr,
    bool verbatim = false
)
generic<typename TEnum>
where TEnum : value class, gcnew()
TEnum ValueAsEnum(
    TEnum dflt = nullptr,
    bool verbatim = false
)
abstract ValueAsEnum :
        ?dflt : 'TEnum *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> 'TEnum  when 'TEnum : struct, new()
abstract ValueAsEnum :
        ?dflt : 'TEnum *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> 'TEnum  when 'TEnum : struct, new()

Parameters

dflt (Optional)
Type: TEnum
verbatim (Optional)
Type: Online System Boolean
Type Parameters
TEnum

Return Value

Type: TEnum
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsFloat Method

IConfigNode ValueAsFloat Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
float ValueAsFloat(
    float dflt = 0f,
    bool verbatim = false
)
float ValueAsFloat(
    float dflt = 0f,
    bool verbatim = false
)
Function ValueAsFloat (
    Optional dflt As Single = 0F,
    Optional verbatim As Boolean = false
) As Single
Function ValueAsFloat (
    Optional dflt As Single = 0F,
    Optional verbatim As Boolean = false
) As Single
float ValueAsFloat(
    float dflt = 0f,
    bool verbatim = false
)
float ValueAsFloat(
    float dflt = 0f,
    bool verbatim = false
)
abstract ValueAsFloat :
        ?dflt : float32 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0f
        let _verbatim = defaultArg verbatim false
*)
-> float32
abstract ValueAsFloat :
        ?dflt : float32 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0f
        let _verbatim = defaultArg verbatim false
*)
-> float32

Parameters

dflt (Optional)
Type: Online System Single
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Single
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsGDID Method

IConfigNode ValueAsGDID Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GDID ValueAsGDID(
    GDID dflt,
    bool verbatim = false
)
GDID ValueAsGDID(
    GDID dflt,
    bool verbatim = false
)
Function ValueAsGDID (
    dflt As GDID,
    Optional verbatim As Boolean = false
) As GDID
Function ValueAsGDID (
    dflt As GDID,
    Optional verbatim As Boolean = false
) As GDID
GDID ValueAsGDID(
    GDID dflt,
    bool verbatim = false
)
GDID ValueAsGDID(
    GDID dflt,
    bool verbatim = false
)
abstract ValueAsGDID :
        dflt : GDID *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> GDID
abstract ValueAsGDID :
        dflt : GDID *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> GDID

Parameters

dflt
Type: NFX.DataAccess.Distributed GDID
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: GDID
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsGUID Method

IConfigNode ValueAsGUID Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Guid ValueAsGUID(
    Guid dflt,
    bool verbatim = false
)
Guid ValueAsGUID(
    Guid dflt,
    bool verbatim = false
)
Function ValueAsGUID (
    dflt As Guid,
    Optional verbatim As Boolean = false
) As Guid
Function ValueAsGUID (
    dflt As Guid,
    Optional verbatim As Boolean = false
) As Guid
Guid ValueAsGUID(
    Guid dflt,
    bool verbatim = false
)
Guid ValueAsGUID(
    Guid dflt,
    bool verbatim = false
)
abstract ValueAsGUID :
        dflt : Guid *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> Guid
abstract ValueAsGUID :
        dflt : Guid *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> Guid

Parameters

dflt
Type: Online System Guid
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Guid
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsInt Method

IConfigNode ValueAsInt Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int ValueAsInt(
    int dflt = 0,
    bool verbatim = false
)
int ValueAsInt(
    int dflt = 0,
    bool verbatim = false
)
Function ValueAsInt (
    Optional dflt As Integer = 0,
    Optional verbatim As Boolean = false
) As Integer
Function ValueAsInt (
    Optional dflt As Integer = 0,
    Optional verbatim As Boolean = false
) As Integer
int ValueAsInt(
    int dflt = 0,
    bool verbatim = false
)
int ValueAsInt(
    int dflt = 0,
    bool verbatim = false
)
abstract ValueAsInt :
        ?dflt : int *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> int
abstract ValueAsInt :
        ?dflt : int *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> int

Parameters

dflt (Optional)
Type: Online System Int32
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Int32
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsLong Method

IConfigNode ValueAsLong Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
long ValueAsLong(
    long dflt = 0,
    bool verbatim = false
)
long ValueAsLong(
    long dflt = 0,
    bool verbatim = false
)
Function ValueAsLong (
    Optional dflt As Long = 0,
    Optional verbatim As Boolean = false
) As Long
Function ValueAsLong (
    Optional dflt As Long = 0,
    Optional verbatim As Boolean = false
) As Long
long long ValueAsLong(
    long long dflt = 0,
    bool verbatim = false
)
long long ValueAsLong(
    long long dflt = 0,
    bool verbatim = false
)
abstract ValueAsLong :
        ?dflt : int64 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> int64
abstract ValueAsLong :
        ?dflt : int64 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> int64

Parameters

dflt (Optional)
Type: Online System Int64
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Int64
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsNullableBool Method

IConfigNode ValueAsNullableBool Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Nullable<bool> ValueAsNullableBool(
    Nullable<bool> dflt = false,
    bool verbatim = false
)
Nullable<bool> ValueAsNullableBool(
    Nullable<bool> dflt = false,
    bool verbatim = false
)
Function ValueAsNullableBool (
    Optional dflt As Nullable(Of Boolean) = false,
    Optional verbatim As Boolean = false
) As Nullable(Of Boolean)
Function ValueAsNullableBool (
    Optional dflt As Nullable(Of Boolean) = false,
    Optional verbatim As Boolean = false
) As Nullable(Of Boolean)
Nullable<bool> ValueAsNullableBool(
    Nullable<bool> dflt = false,
    bool verbatim = false
)
Nullable<bool> ValueAsNullableBool(
    Nullable<bool> dflt = false,
    bool verbatim = false
)
abstract ValueAsNullableBool :
        ?dflt : Nullable<bool> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt false
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<bool>
abstract ValueAsNullableBool :
        ?dflt : Nullable<bool> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt false
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<bool>

Parameters

dflt (Optional)
Type: Online System Nullable Online Boolean
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online Boolean
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsNullableByte Method

IConfigNode ValueAsNullableByte Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Nullable<byte> ValueAsNullableByte(
    Nullable<byte> dflt = 0,
    bool verbatim = false
)
Nullable<byte> ValueAsNullableByte(
    Nullable<byte> dflt = 0,
    bool verbatim = false
)
Function ValueAsNullableByte (
    Optional dflt As Nullable(Of Byte) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of Byte)
Function ValueAsNullableByte (
    Optional dflt As Nullable(Of Byte) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of Byte)
Nullable<unsigned char> ValueAsNullableByte(
    Nullable<unsigned char> dflt = 0,
    bool verbatim = false
)
Nullable<unsigned char> ValueAsNullableByte(
    Nullable<unsigned char> dflt = 0,
    bool verbatim = false
)
abstract ValueAsNullableByte :
        ?dflt : Nullable<byte> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<byte>
abstract ValueAsNullableByte :
        ?dflt : Nullable<byte> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<byte>

Parameters

dflt (Optional)
Type: Online System Nullable Online Byte
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online Byte
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsNullableDateTime Method

IConfigNode ValueAsNullableDateTime Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Nullable<DateTime> ValueAsNullableDateTime(
    Nullable<DateTime> dflt = null,
    bool verbatim = false
)
Nullable<DateTime> ValueAsNullableDateTime(
    Nullable<DateTime> dflt = null,
    bool verbatim = false
)
Function ValueAsNullableDateTime (
    Optional dflt As Nullable(Of DateTime) = Nothing,
    Optional verbatim As Boolean = false
) As Nullable(Of DateTime)
Function ValueAsNullableDateTime (
    Optional dflt As Nullable(Of DateTime) = Nothing,
    Optional verbatim As Boolean = false
) As Nullable(Of DateTime)
Nullable<DateTime> ValueAsNullableDateTime(
    Nullable<DateTime> dflt = nullptr,
    bool verbatim = false
)
Nullable<DateTime> ValueAsNullableDateTime(
    Nullable<DateTime> dflt = nullptr,
    bool verbatim = false
)
abstract ValueAsNullableDateTime :
        ?dflt : Nullable<DateTime> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<DateTime>
abstract ValueAsNullableDateTime :
        ?dflt : Nullable<DateTime> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<DateTime>

Parameters

dflt (Optional)
Type: Online System Nullable Online DateTime
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online DateTime
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsNullableDecimal Method

IConfigNode ValueAsNullableDecimal Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Nullable<decimal> ValueAsNullableDecimal(
    [OptionalAttribute] Nullable<decimal> dflt,
    bool verbatim = false
)
Nullable<decimal> ValueAsNullableDecimal(
    [OptionalAttribute] Nullable<decimal> dflt,
    bool verbatim = false
)
Function ValueAsNullableDecimal (
    <OptionalAttribute> dflt As Nullable(Of Decimal),
    Optional verbatim As Boolean = false
) As Nullable(Of Decimal)
Function ValueAsNullableDecimal (
    <OptionalAttribute> dflt As Nullable(Of Decimal),
    Optional verbatim As Boolean = false
) As Nullable(Of Decimal)
Nullable<Decimal> ValueAsNullableDecimal(
    [OptionalAttribute] Nullable<Decimal> dflt,
    bool verbatim = false
)
Nullable<Decimal> ValueAsNullableDecimal(
    [OptionalAttribute] Nullable<Decimal> dflt,
    bool verbatim = false
)
abstract ValueAsNullableDecimal :
        [<OptionalAttribute>] dflt : Nullable<decimal> *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<decimal>
abstract ValueAsNullableDecimal :
        [<OptionalAttribute>] dflt : Nullable<decimal> *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<decimal>

Parameters

dflt (Optional)
Type: Online System Nullable Online Decimal
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online Decimal
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsNullableDouble Method

IConfigNode ValueAsNullableDouble Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Nullable<double> ValueAsNullableDouble(
    Nullable<double> dflt = 0,
    bool verbatim = false
)
Nullable<double> ValueAsNullableDouble(
    Nullable<double> dflt = 0,
    bool verbatim = false
)
Function ValueAsNullableDouble (
    Optional dflt As Nullable(Of Double) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of Double)
Function ValueAsNullableDouble (
    Optional dflt As Nullable(Of Double) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of Double)
Nullable<double> ValueAsNullableDouble(
    Nullable<double> dflt = 0,
    bool verbatim = false
)
Nullable<double> ValueAsNullableDouble(
    Nullable<double> dflt = 0,
    bool verbatim = false
)
abstract ValueAsNullableDouble :
        ?dflt : Nullable<float> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<float>
abstract ValueAsNullableDouble :
        ?dflt : Nullable<float> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<float>

Parameters

dflt (Optional)
Type: Online System Nullable Online Double
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online Double
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsNullableEnum(TEnum) Method

IConfigNode ValueAsNullableEnum TEnum Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Nullable<TEnum> ValueAsNullableEnum<TEnum>(
    Nullable<TEnum> dflt = null,
    bool verbatim = false
)
where TEnum : struct, new()
Nullable<TEnum> ValueAsNullableEnum<TEnum>(
    Nullable<TEnum> dflt = null,
    bool verbatim = false
)
where TEnum : struct, new()
Function ValueAsNullableEnum(Of TEnum As {Structure, New}) (
    Optional dflt As Nullable(Of TEnum) = Nothing,
    Optional verbatim As Boolean = false
) As Nullable(Of TEnum)
Function ValueAsNullableEnum(Of TEnum As {Structure, New}) (
    Optional dflt As Nullable(Of TEnum) = Nothing,
    Optional verbatim As Boolean = false
) As Nullable(Of TEnum)
generic<typename TEnum>
where TEnum : value class, gcnew()
Nullable<TEnum> ValueAsNullableEnum(
    Nullable<TEnum> dflt = nullptr,
    bool verbatim = false
)
generic<typename TEnum>
where TEnum : value class, gcnew()
Nullable<TEnum> ValueAsNullableEnum(
    Nullable<TEnum> dflt = nullptr,
    bool verbatim = false
)
abstract ValueAsNullableEnum :
        ?dflt : Nullable<'TEnum> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<'TEnum>  when 'TEnum : struct, new()
abstract ValueAsNullableEnum :
        ?dflt : Nullable<'TEnum> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<'TEnum>  when 'TEnum : struct, new()

Parameters

dflt (Optional)
Type: Online System Nullable TEnum
verbatim (Optional)
Type: Online System Boolean
Type Parameters
TEnum

Return Value

Type: Online Nullable TEnum
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsNullableFloat Method

IConfigNode ValueAsNullableFloat Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Nullable<float> ValueAsNullableFloat(
    Nullable<float> dflt = 0f,
    bool verbatim = false
)
Nullable<float> ValueAsNullableFloat(
    Nullable<float> dflt = 0f,
    bool verbatim = false
)
Function ValueAsNullableFloat (
    Optional dflt As Nullable(Of Single) = 0F,
    Optional verbatim As Boolean = false
) As Nullable(Of Single)
Function ValueAsNullableFloat (
    Optional dflt As Nullable(Of Single) = 0F,
    Optional verbatim As Boolean = false
) As Nullable(Of Single)
Nullable<float> ValueAsNullableFloat(
    Nullable<float> dflt = 0f,
    bool verbatim = false
)
Nullable<float> ValueAsNullableFloat(
    Nullable<float> dflt = 0f,
    bool verbatim = false
)
abstract ValueAsNullableFloat :
        ?dflt : Nullable<float32> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0f
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<float32>
abstract ValueAsNullableFloat :
        ?dflt : Nullable<float32> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0f
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<float32>

Parameters

dflt (Optional)
Type: Online System Nullable Online Single
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online Single
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsNullableGDID Method

IConfigNode ValueAsNullableGDID Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Nullable<GDID> ValueAsNullableGDID(
    Nullable<GDID> dflt = null,
    bool verbatim = false
)
Nullable<GDID> ValueAsNullableGDID(
    Nullable<GDID> dflt = null,
    bool verbatim = false
)
Function ValueAsNullableGDID (
    Optional dflt As Nullable(Of GDID) = Nothing,
    Optional verbatim As Boolean = false
) As Nullable(Of GDID)
Function ValueAsNullableGDID (
    Optional dflt As Nullable(Of GDID) = Nothing,
    Optional verbatim As Boolean = false
) As Nullable(Of GDID)
Nullable<GDID> ValueAsNullableGDID(
    Nullable<GDID> dflt = nullptr,
    bool verbatim = false
)
Nullable<GDID> ValueAsNullableGDID(
    Nullable<GDID> dflt = nullptr,
    bool verbatim = false
)
abstract ValueAsNullableGDID :
        ?dflt : Nullable<GDID> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<GDID>
abstract ValueAsNullableGDID :
        ?dflt : Nullable<GDID> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<GDID>

Parameters

dflt (Optional)
Type: Online System Nullable GDID
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable GDID
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsNullableGUID Method

IConfigNode ValueAsNullableGUID Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Nullable<Guid> ValueAsNullableGUID(
    Nullable<Guid> dflt = null,
    bool verbatim = false
)
Nullable<Guid> ValueAsNullableGUID(
    Nullable<Guid> dflt = null,
    bool verbatim = false
)
Function ValueAsNullableGUID (
    Optional dflt As Nullable(Of Guid) = Nothing,
    Optional verbatim As Boolean = false
) As Nullable(Of Guid)
Function ValueAsNullableGUID (
    Optional dflt As Nullable(Of Guid) = Nothing,
    Optional verbatim As Boolean = false
) As Nullable(Of Guid)
Nullable<Guid> ValueAsNullableGUID(
    Nullable<Guid> dflt = nullptr,
    bool verbatim = false
)
Nullable<Guid> ValueAsNullableGUID(
    Nullable<Guid> dflt = nullptr,
    bool verbatim = false
)
abstract ValueAsNullableGUID :
        ?dflt : Nullable<Guid> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<Guid>
abstract ValueAsNullableGUID :
        ?dflt : Nullable<Guid> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<Guid>

Parameters

dflt (Optional)
Type: Online System Nullable Online Guid
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online Guid
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsNullableInt Method

IConfigNode ValueAsNullableInt Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Nullable<int> ValueAsNullableInt(
    Nullable<int> dflt = 0,
    bool verbatim = false
)
Nullable<int> ValueAsNullableInt(
    Nullable<int> dflt = 0,
    bool verbatim = false
)
Function ValueAsNullableInt (
    Optional dflt As Nullable(Of Integer) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of Integer)
Function ValueAsNullableInt (
    Optional dflt As Nullable(Of Integer) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of Integer)
Nullable<int> ValueAsNullableInt(
    Nullable<int> dflt = 0,
    bool verbatim = false
)
Nullable<int> ValueAsNullableInt(
    Nullable<int> dflt = 0,
    bool verbatim = false
)
abstract ValueAsNullableInt :
        ?dflt : Nullable<int> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<int>
abstract ValueAsNullableInt :
        ?dflt : Nullable<int> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<int>

Parameters

dflt (Optional)
Type: Online System Nullable Online Int32
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online Int32
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsNullableLong Method

IConfigNode ValueAsNullableLong Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Nullable<long> ValueAsNullableLong(
    Nullable<long> dflt = 0,
    bool verbatim = false
)
Nullable<long> ValueAsNullableLong(
    Nullable<long> dflt = 0,
    bool verbatim = false
)
Function ValueAsNullableLong (
    Optional dflt As Nullable(Of Long) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of Long)
Function ValueAsNullableLong (
    Optional dflt As Nullable(Of Long) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of Long)
Nullable<long long> ValueAsNullableLong(
    Nullable<long long> dflt = 0,
    bool verbatim = false
)
Nullable<long long> ValueAsNullableLong(
    Nullable<long long> dflt = 0,
    bool verbatim = false
)
abstract ValueAsNullableLong :
        ?dflt : Nullable<int64> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<int64>
abstract ValueAsNullableLong :
        ?dflt : Nullable<int64> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<int64>

Parameters

dflt (Optional)
Type: Online System Nullable Online Int64
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online Int64
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsNullableSByte Method

IConfigNode ValueAsNullableSByte Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Nullable<sbyte> ValueAsNullableSByte(
    Nullable<sbyte> dflt = 0,
    bool verbatim = false
)
Nullable<sbyte> ValueAsNullableSByte(
    Nullable<sbyte> dflt = 0,
    bool verbatim = false
)
Function ValueAsNullableSByte (
    Optional dflt As Nullable(Of SByte) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of SByte)
Function ValueAsNullableSByte (
    Optional dflt As Nullable(Of SByte) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of SByte)
Nullable<signed char> ValueAsNullableSByte(
    Nullable<signed char> dflt = 0,
    bool verbatim = false
)
Nullable<signed char> ValueAsNullableSByte(
    Nullable<signed char> dflt = 0,
    bool verbatim = false
)
abstract ValueAsNullableSByte :
        ?dflt : Nullable<sbyte> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<sbyte>
abstract ValueAsNullableSByte :
        ?dflt : Nullable<sbyte> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<sbyte>

Parameters

dflt (Optional)
Type: Online System Nullable Online SByte
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online SByte
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsNullableShort Method

IConfigNode ValueAsNullableShort Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Nullable<short> ValueAsNullableShort(
    Nullable<short> dflt = 0,
    bool verbatim = false
)
Nullable<short> ValueAsNullableShort(
    Nullable<short> dflt = 0,
    bool verbatim = false
)
Function ValueAsNullableShort (
    Optional dflt As Nullable(Of Short) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of Short)
Function ValueAsNullableShort (
    Optional dflt As Nullable(Of Short) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of Short)
Nullable<short> ValueAsNullableShort(
    Nullable<short> dflt = 0,
    bool verbatim = false
)
Nullable<short> ValueAsNullableShort(
    Nullable<short> dflt = 0,
    bool verbatim = false
)
abstract ValueAsNullableShort :
        ?dflt : Nullable<int16> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<int16>
abstract ValueAsNullableShort :
        ?dflt : Nullable<int16> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<int16>

Parameters

dflt (Optional)
Type: Online System Nullable Online Int16
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online Int16
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsNullableTimeSpan Method

IConfigNode ValueAsNullableTimeSpan Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Nullable<TimeSpan> ValueAsNullableTimeSpan(
    Nullable<TimeSpan> dflt = null,
    bool verbatim = false
)
Nullable<TimeSpan> ValueAsNullableTimeSpan(
    Nullable<TimeSpan> dflt = null,
    bool verbatim = false
)
Function ValueAsNullableTimeSpan (
    Optional dflt As Nullable(Of TimeSpan) = Nothing,
    Optional verbatim As Boolean = false
) As Nullable(Of TimeSpan)
Function ValueAsNullableTimeSpan (
    Optional dflt As Nullable(Of TimeSpan) = Nothing,
    Optional verbatim As Boolean = false
) As Nullable(Of TimeSpan)
Nullable<TimeSpan> ValueAsNullableTimeSpan(
    Nullable<TimeSpan> dflt = nullptr,
    bool verbatim = false
)
Nullable<TimeSpan> ValueAsNullableTimeSpan(
    Nullable<TimeSpan> dflt = nullptr,
    bool verbatim = false
)
abstract ValueAsNullableTimeSpan :
        ?dflt : Nullable<TimeSpan> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<TimeSpan>
abstract ValueAsNullableTimeSpan :
        ?dflt : Nullable<TimeSpan> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<TimeSpan>

Parameters

dflt (Optional)
Type: Online System Nullable Online TimeSpan
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online TimeSpan
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsNullableUInt Method

IConfigNode ValueAsNullableUInt Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Nullable<uint> ValueAsNullableUInt(
    Nullable<uint> dflt = 0,
    bool verbatim = false
)
Nullable<uint> ValueAsNullableUInt(
    Nullable<uint> dflt = 0,
    bool verbatim = false
)
Function ValueAsNullableUInt (
    Optional dflt As Nullable(Of UInteger) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of UInteger)
Function ValueAsNullableUInt (
    Optional dflt As Nullable(Of UInteger) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of UInteger)
Nullable<unsigned int> ValueAsNullableUInt(
    Nullable<unsigned int> dflt = 0,
    bool verbatim = false
)
Nullable<unsigned int> ValueAsNullableUInt(
    Nullable<unsigned int> dflt = 0,
    bool verbatim = false
)
abstract ValueAsNullableUInt :
        ?dflt : Nullable<uint32> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<uint32>
abstract ValueAsNullableUInt :
        ?dflt : Nullable<uint32> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<uint32>

Parameters

dflt (Optional)
Type: Online System Nullable Online UInt32
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online UInt32
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsNullableULong Method

IConfigNode ValueAsNullableULong Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Nullable<ulong> ValueAsNullableULong(
    Nullable<ulong> dflt = 0,
    bool verbatim = false
)
Nullable<ulong> ValueAsNullableULong(
    Nullable<ulong> dflt = 0,
    bool verbatim = false
)
Function ValueAsNullableULong (
    Optional dflt As Nullable(Of ULong) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of ULong)
Function ValueAsNullableULong (
    Optional dflt As Nullable(Of ULong) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of ULong)
Nullable<unsigned long long> ValueAsNullableULong(
    Nullable<unsigned long long> dflt = 0,
    bool verbatim = false
)
Nullable<unsigned long long> ValueAsNullableULong(
    Nullable<unsigned long long> dflt = 0,
    bool verbatim = false
)
abstract ValueAsNullableULong :
        ?dflt : Nullable<uint64> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<uint64>
abstract ValueAsNullableULong :
        ?dflt : Nullable<uint64> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<uint64>

Parameters

dflt (Optional)
Type: Online System Nullable Online UInt64
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online UInt64
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsNullableUShort Method

IConfigNode ValueAsNullableUShort Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Nullable<ushort> ValueAsNullableUShort(
    Nullable<ushort> dflt = 0,
    bool verbatim = false
)
Nullable<ushort> ValueAsNullableUShort(
    Nullable<ushort> dflt = 0,
    bool verbatim = false
)
Function ValueAsNullableUShort (
    Optional dflt As Nullable(Of UShort) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of UShort)
Function ValueAsNullableUShort (
    Optional dflt As Nullable(Of UShort) = 0,
    Optional verbatim As Boolean = false
) As Nullable(Of UShort)
Nullable<unsigned short> ValueAsNullableUShort(
    Nullable<unsigned short> dflt = 0,
    bool verbatim = false
)
Nullable<unsigned short> ValueAsNullableUShort(
    Nullable<unsigned short> dflt = 0,
    bool verbatim = false
)
abstract ValueAsNullableUShort :
        ?dflt : Nullable<uint16> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<uint16>
abstract ValueAsNullableUShort :
        ?dflt : Nullable<uint16> *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> Nullable<uint16>

Parameters

dflt (Optional)
Type: Online System Nullable Online UInt16
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Nullable Online UInt16
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsSByte Method

IConfigNode ValueAsSByte Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
sbyte ValueAsSByte(
    sbyte dflt = 0,
    bool verbatim = false
)
sbyte ValueAsSByte(
    sbyte dflt = 0,
    bool verbatim = false
)
Function ValueAsSByte (
    Optional dflt As SByte = 0,
    Optional verbatim As Boolean = false
) As SByte
Function ValueAsSByte (
    Optional dflt As SByte = 0,
    Optional verbatim As Boolean = false
) As SByte
signed char ValueAsSByte(
    signed char dflt = 0,
    bool verbatim = false
)
signed char ValueAsSByte(
    signed char dflt = 0,
    bool verbatim = false
)
abstract ValueAsSByte :
        ?dflt : sbyte *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> sbyte
abstract ValueAsSByte :
        ?dflt : sbyte *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> sbyte

Parameters

dflt (Optional)
Type: Online System SByte
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online SByte
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsShort Method

IConfigNode ValueAsShort Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
short ValueAsShort(
    short dflt = 0,
    bool verbatim = false
)
short ValueAsShort(
    short dflt = 0,
    bool verbatim = false
)
Function ValueAsShort (
    Optional dflt As Short = 0,
    Optional verbatim As Boolean = false
) As Short
Function ValueAsShort (
    Optional dflt As Short = 0,
    Optional verbatim As Boolean = false
) As Short
short ValueAsShort(
    short dflt = 0,
    bool verbatim = false
)
short ValueAsShort(
    short dflt = 0,
    bool verbatim = false
)
abstract ValueAsShort :
        ?dflt : int16 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> int16
abstract ValueAsShort :
        ?dflt : int16 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> int16

Parameters

dflt (Optional)
Type: Online System Int16
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online Int16
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsString Method

IConfigNode ValueAsString Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string ValueAsString(
    string dflt = null,
    bool verbatim = false
)
string ValueAsString(
    string dflt = null,
    bool verbatim = false
)
Function ValueAsString (
    Optional dflt As String = Nothing,
    Optional verbatim As Boolean = false
) As String
Function ValueAsString (
    Optional dflt As String = Nothing,
    Optional verbatim As Boolean = false
) As String
String^ ValueAsString(
    String^ dflt = nullptr,
    bool verbatim = false
)
String^ ValueAsString(
    String^ dflt = nullptr,
    bool verbatim = false
)
abstract ValueAsString :
        ?dflt : string *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> string
abstract ValueAsString :
        ?dflt : string *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt null
        let _verbatim = defaultArg verbatim false
*)
-> string

Parameters

dflt (Optional)
Type: Online System String
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online String
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsTimeSpan Method

IConfigNode ValueAsTimeSpan Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
TimeSpan ValueAsTimeSpan(
    TimeSpan dflt,
    bool verbatim = false
)
TimeSpan ValueAsTimeSpan(
    TimeSpan dflt,
    bool verbatim = false
)
Function ValueAsTimeSpan (
    dflt As TimeSpan,
    Optional verbatim As Boolean = false
) As TimeSpan
Function ValueAsTimeSpan (
    dflt As TimeSpan,
    Optional verbatim As Boolean = false
) As TimeSpan
TimeSpan ValueAsTimeSpan(
    TimeSpan dflt,
    bool verbatim = false
)
TimeSpan ValueAsTimeSpan(
    TimeSpan dflt,
    bool verbatim = false
)
abstract ValueAsTimeSpan :
        dflt : TimeSpan *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> TimeSpan
abstract ValueAsTimeSpan :
        dflt : TimeSpan *
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> TimeSpan

Parameters

dflt
Type: Online System TimeSpan
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online TimeSpan
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsType Method

IConfigNode ValueAsType Method NFX Class Library

Tries to get value as specified type or throws if it can not be converted

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object ValueAsType(
    Type tp,
    bool verbatim = false,
    bool strict = true
)
Object ValueAsType(
    Type tp,
    bool verbatim = false,
    bool strict = true
)
Function ValueAsType (
    tp As Type,
    Optional verbatim As Boolean = false,
    Optional strict As Boolean = true
) As Object
Function ValueAsType (
    tp As Type,
    Optional verbatim As Boolean = false,
    Optional strict As Boolean = true
) As Object
Object^ ValueAsType(
    Type^ tp,
    bool verbatim = false,
    bool strict = true
)
Object^ ValueAsType(
    Type^ tp,
    bool verbatim = false,
    bool strict = true
)
abstract ValueAsType :
        tp : Type *
        ?verbatim : bool *
        ?strict : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
        let _strict = defaultArg strict true
*)
-> Object
abstract ValueAsType :
        tp : Type *
        ?verbatim : bool *
        ?strict : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
        let _strict = defaultArg strict true
*)
-> Object

Parameters

tp
Type: Online System Type
verbatim (Optional)
Type: Online System Boolean
strict (Optional)
Type: Online System Boolean

Return Value

Type: Online Object
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsUInt Method

IConfigNode ValueAsUInt Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
uint ValueAsUInt(
    uint dflt = 0,
    bool verbatim = false
)
uint ValueAsUInt(
    uint dflt = 0,
    bool verbatim = false
)
Function ValueAsUInt (
    Optional dflt As UInteger = 0,
    Optional verbatim As Boolean = false
) As UInteger
Function ValueAsUInt (
    Optional dflt As UInteger = 0,
    Optional verbatim As Boolean = false
) As UInteger
unsigned int ValueAsUInt(
    unsigned int dflt = 0,
    bool verbatim = false
)
unsigned int ValueAsUInt(
    unsigned int dflt = 0,
    bool verbatim = false
)
abstract ValueAsUInt :
        ?dflt : uint32 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> uint32
abstract ValueAsUInt :
        ?dflt : uint32 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> uint32

Parameters

dflt (Optional)
Type: Online System UInt32
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online UInt32
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsULong Method

IConfigNode ValueAsULong Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ulong ValueAsULong(
    ulong dflt = 0,
    bool verbatim = false
)
ulong ValueAsULong(
    ulong dflt = 0,
    bool verbatim = false
)
Function ValueAsULong (
    Optional dflt As ULong = 0,
    Optional verbatim As Boolean = false
) As ULong
Function ValueAsULong (
    Optional dflt As ULong = 0,
    Optional verbatim As Boolean = false
) As ULong
unsigned long long ValueAsULong(
    unsigned long long dflt = 0,
    bool verbatim = false
)
unsigned long long ValueAsULong(
    unsigned long long dflt = 0,
    bool verbatim = false
)
abstract ValueAsULong :
        ?dflt : uint64 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> uint64
abstract ValueAsULong :
        ?dflt : uint64 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> uint64

Parameters

dflt (Optional)
Type: Online System UInt64
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online UInt64
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.ValueAsUShort Method

IConfigNode ValueAsUShort Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ushort ValueAsUShort(
    ushort dflt = 0,
    bool verbatim = false
)
ushort ValueAsUShort(
    ushort dflt = 0,
    bool verbatim = false
)
Function ValueAsUShort (
    Optional dflt As UShort = 0,
    Optional verbatim As Boolean = false
) As UShort
Function ValueAsUShort (
    Optional dflt As UShort = 0,
    Optional verbatim As Boolean = false
) As UShort
unsigned short ValueAsUShort(
    unsigned short dflt = 0,
    bool verbatim = false
)
unsigned short ValueAsUShort(
    unsigned short dflt = 0,
    bool verbatim = false
)
abstract ValueAsUShort :
        ?dflt : uint16 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> uint16
abstract ValueAsUShort :
        ?dflt : uint16 *
        ?verbatim : bool
(* Defaults:
        let _dflt = defaultArg dflt 0
        let _verbatim = defaultArg verbatim false
*)
-> uint16

Parameters

dflt (Optional)
Type: Online System UInt16
verbatim (Optional)
Type: Online System Boolean

Return Value

Type: Online UInt16
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode Properties

IConfigNode Properties NFX Class Library

The IConfigNode type exposes the following members.
Properties
 | Name | Description
Public property | Configuration | References configuration this node is under
Public property | EvaluatedValue | Returns null or value of this node with all variables evaluated
Public property | Exists | Determines whether this node really exists in configuration or is just a sentinel empty node
Public property | Name | (Inherited from INamed.)
Public property | Parent | References parent node or empty node if this is the top-most node with no parent
Public property | RootPath | Returns a path from root to this node
Public property | Value | Returns null or value of this node with all variables evaluated
Public property | VerbatimValue | Returns varbatim (without variable evaluation) node value or null
Back to Top
See Also
IConfigNode Interface
NFX.Environment Namespace


IConfigNode.Configuration Property

IConfigNode Configuration Property NFX Class Library

References configuration this node is under

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Configuration Configuration { get; }
Configuration Configuration { get; }
ReadOnly Property Configuration As Configuration
    Get
ReadOnly Property Configuration As Configuration
    Get
property Configuration^ Configuration {
    Configuration^ get ();
}
property Configuration^ Configuration {
    Configuration^ get ();
}
abstract Configuration : Configuration with get
abstract Configuration : Configuration with get

Property Value

Type: Configuration
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.EvaluatedValue Property

IConfigNode EvaluatedValue Property NFX Class Library

Returns null or value of this node with all variables evaluated

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string EvaluatedValue { get; }
string EvaluatedValue { get; }
ReadOnly Property EvaluatedValue As String
    Get
ReadOnly Property EvaluatedValue As String
    Get
property String^ EvaluatedValue {
    String^ get ();
}
property String^ EvaluatedValue {
    String^ get ();
}
abstract EvaluatedValue : string with get
abstract EvaluatedValue : string with get

Property Value

Type: Online String
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.Exists Property

IConfigNode Exists Property NFX Class Library

Determines whether this node really exists in configuration or is just a sentinel empty node

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Exists { get; }
bool Exists { get; }
ReadOnly Property Exists As Boolean
    Get
ReadOnly Property Exists As Boolean
    Get
property bool Exists {
    bool get ();
}
property bool Exists {
    bool get ();
}
abstract Exists : bool with get
abstract Exists : bool with get

Property Value

Type: Online Boolean
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.Parent Property

IConfigNode Parent Property NFX Class Library

References parent node or empty node if this is the top-most node with no parent

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IConfigSectionNode Parent { get; }
IConfigSectionNode Parent { get; }
ReadOnly Property Parent As IConfigSectionNode
    Get
ReadOnly Property Parent As IConfigSectionNode
    Get
property IConfigSectionNode^ Parent {
    IConfigSectionNode^ get ();
}
property IConfigSectionNode^ Parent {
    IConfigSectionNode^ get ();
}
abstract Parent : IConfigSectionNode with get
abstract Parent : IConfigSectionNode with get

Property Value

Type: IConfigSectionNode
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.RootPath Property

IConfigNode RootPath Property NFX Class Library

Returns a path from root to this node

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string RootPath { get; }
string RootPath { get; }
ReadOnly Property RootPath As String
    Get
ReadOnly Property RootPath As String
    Get
property String^ RootPath {
    String^ get ();
}
property String^ RootPath {
    String^ get ();
}
abstract RootPath : string with get
abstract RootPath : string with get

Property Value

Type: Online String
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.Value Property

IConfigNode Value Property NFX Class Library

Returns null or value of this node with all variables evaluated

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Value { get; }
string Value { get; }
ReadOnly Property Value As String
    Get
ReadOnly Property Value As String
    Get
property String^ Value {
    String^ get ();
}
property String^ Value {
    String^ get ();
}
abstract Value : string with get
abstract Value : string with get

Property Value

Type: Online String
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNode.VerbatimValue Property

IConfigNode VerbatimValue Property NFX Class Library

Returns varbatim (without variable evaluation) node value or null

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string VerbatimValue { get; }
string VerbatimValue { get; }
ReadOnly Property VerbatimValue As String
    Get
ReadOnly Property VerbatimValue As String
    Get
property String^ VerbatimValue {
    String^ get ();
}
property String^ VerbatimValue {
    String^ get ();
}
abstract VerbatimValue : string with get
abstract VerbatimValue : string with get

Property Value

Type: Online String
See Also
IConfigNode Interface
IConfigNode Members
NFX.Environment Namespace


IConfigNodeProvider Interface

IConfigNodeProvider Interface NFX Class Library

Represents an entity that provides config node. It is primarily used for includes

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IConfigNodeProvider : IConfigurable
public interface IConfigNodeProvider : IConfigurable
Public Interface IConfigNodeProvider
    Inherits IConfigurable
Public Interface IConfigNodeProvider
    Inherits IConfigurable
public interface class IConfigNodeProvider : IConfigurable
public interface class IConfigNodeProvider : IConfigurable
type IConfigNodeProvider =
    interface
        interface IConfigurable
    end
type IConfigNodeProvider =
    interface
        interface IConfigurable
    end
See Also
IConfigNodeProvider Members
NFX.Environment Namespace


IConfigNodeProvider Members

IConfigNodeProvider Members NFX Class Library

The IConfigNodeProvider type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | ProvideConfigNode | Returns config node per optional context
Back to Top
See Also
IConfigNodeProvider Interface
NFX.Environment Namespace


IConfigNodeProvider Methods

IConfigNodeProvider Methods NFX Class Library

The IConfigNodeProvider type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | ProvideConfigNode | Returns config node per optional context
Back to Top
See Also
IConfigNodeProvider Interface
NFX.Environment Namespace


IConfigNodeProvider.ProvideConfigNode Method

IConfigNodeProvider ProvideConfigNode Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns config node per optional context

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ConfigSectionNode ProvideConfigNode(
    Object context = null
)
ConfigSectionNode ProvideConfigNode(
    Object context = null
)
Function ProvideConfigNode (
    Optional context As Object = Nothing
) As ConfigSectionNode
Function ProvideConfigNode (
    Optional context As Object = Nothing
) As ConfigSectionNode
ConfigSectionNode^ ProvideConfigNode(
    Object^ context = nullptr
)
ConfigSectionNode^ ProvideConfigNode(
    Object^ context = nullptr
)
abstract ProvideConfigNode :
        ?context : Object
(* Defaults:
        let _context = defaultArg context null
*)
-> ConfigSectionNode
abstract ProvideConfigNode :
        ?context : Object
(* Defaults:
        let _context = defaultArg context null
*)
-> ConfigSectionNode

Parameters

context (Optional)
Type: Online System Object

Return Value

Type: ConfigSectionNode
See Also
IConfigNodeProvider Interface
IConfigNodeProvider Members
NFX.Environment Namespace


IConfigSectionNode Interface

IConfigSectionNode Interface NFX Class Library

Provides read-only configuration section node abstraction

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IConfigSectionNode : IConfigNode,
    INamed
public interface IConfigSectionNode : IConfigNode,
    INamed
Public Interface IConfigSectionNode
    Inherits IConfigNode, INamed
Public Interface IConfigSectionNode
    Inherits IConfigNode, INamed
public interface class IConfigSectionNode : IConfigNode,
    INamed
public interface class IConfigSectionNode : IConfigNode,
    INamed
type IConfigSectionNode =
    interface
        interface IConfigNode
        interface INamed
    end
type IConfigSectionNode =
    interface
        interface IConfigNode
        interface INamed
    end
See Also
IConfigSectionNode Members
NFX.Environment Namespace


IConfigSectionNode Members

IConfigSectionNode Members NFX Class Library

The IConfigSectionNode type exposes the following members.
Methods
 | Name | Description
Public method | AttrByIndex | Returns attribute node by its index or empty attribute if real attribute with such index does not exist
Public method | AttrByName | Returns attribute node by its name or empty attribute if real attribute with such name does not exist
Public method | AttrsToStringMap | Returns attribute values as string map
Public method | EvaluateValueVariables | Evaluates a value string expanding all variables with var-paths relative to this node. Evaluates configuration variables such as "$(varname)" or "$(@varname)". Varnames are paths to other config nodes from the same configuration or variable names when prefixed with "~". If varname starts with "@" then it gets combined with input as path string. "~" is used to qualify environment vars that get resolved through Configuration.EnvironmentVarResolver Example: `....add key="Schema.$(/A/B/C/$attr)" value="$(@~HOME)bin\Transforms\"...`
Public method | IsSameName(String) | Returns true when another name is the same as this node's name (Inherited from IConfigNode.)
Public method | IsSameName(IConfigNode) | Returns true when another node has the same name as this one (Inherited from IConfigNode.)
Public method | IsSameNameAttr(String) | Returns true when this node has an attribute called "name" and its value is euqal to the supplied value per case-insensitive culture-neutral comparison
Public method | IsSameNameAttr(IConfigSectionNode) | Returns true when this and another nodes both have attribute "name" and their values are equal per case-insensitive culture-neutral comparison
Public method | Navigate | Navigates the path and return the appropriate node. Example '!/nfx/logger/destination/$file-name'
Public method | NavigateSection | Navigates the path and return the appropriate section node. Example '!/nfx/logger/destination'
Public method | ToConfigurationJSONDataMap | Returns the contents of this node per JSONConfiguration specification. Contrast with ToJSONDataMap
Public method | ToJSONDataMap | Converts this ConfigSectionNode to JSONDataMap. Contrast with ToConfigurationJSONDataMap Be carefull: that this operation can "loose" data from ConfigSectionNode. In other words some ConfigSectionNode information can not be reflected in corresponding JSONDataMap, for example this method overwrites duplicate key names and does not support section values
Public method | ToJSONString | Serializes configuration tree rooted at this node into JSON configuration format and returns it as a string
Public method | ToLaconicString | Serializes configuration tree rooted at this node into Laconic format and returns it as a string
Public method | ValueAsBool | (Inherited from IConfigNode.)
Public method | ValueAsByte | (Inherited from IConfigNode.)
Public method | ValueAsByteArray | (Inherited from IConfigNode.)
Public method | ValueAsDateTime | (Inherited from IConfigNode.)
Public method | ValueAsDecimal | (Inherited from IConfigNode.)
Public method | ValueAsDouble | (Inherited from IConfigNode.)
Public method | ValueAsEnum TEnum | (Inherited from IConfigNode.)
Public method | ValueAsFloat | (Inherited from IConfigNode.)
Public method | ValueAsGDID | (Inherited from IConfigNode.)
Public method | ValueAsGUID | (Inherited from IConfigNode.)
Public method | ValueAsInt | (Inherited from IConfigNode.)
Public method | ValueAsLong | (Inherited from IConfigNode.)
Public method | ValueAsNullableBool | (Inherited from IConfigNode.)
Public method | ValueAsNullableByte | (Inherited from IConfigNode.)
Public method | ValueAsNullableDateTime | (Inherited from IConfigNode.)
Public method | ValueAsNullableDecimal | (Inherited from IConfigNode.)
Public method | ValueAsNullableDouble | (Inherited from IConfigNode.)
Public method | ValueAsNullableEnum TEnum | (Inherited from IConfigNode.)
Public method | ValueAsNullableFloat | (Inherited from IConfigNode.)
Public method | ValueAsNullableGDID | (Inherited from IConfigNode.)
Public method | ValueAsNullableGUID | (Inherited from IConfigNode.)
Public method | ValueAsNullableInt | (Inherited from IConfigNode.)
Public method | ValueAsNullableLong | (Inherited from IConfigNode.)
Public method | ValueAsNullableSByte | (Inherited from IConfigNode.)
Public method | ValueAsNullableShort | (Inherited from IConfigNode.)
Public method | ValueAsNullableTimeSpan | (Inherited from IConfigNode.)
Public method | ValueAsNullableUInt | (Inherited from IConfigNode.)
Public method | ValueAsNullableULong | (Inherited from IConfigNode.)
Public method | ValueAsNullableUShort | (Inherited from IConfigNode.)
Public method | ValueAsSByte | (Inherited from IConfigNode.)
Public method | ValueAsShort | (Inherited from IConfigNode.)
Public method | ValueAsString | (Inherited from IConfigNode.)
Public method | ValueAsTimeSpan | (Inherited from IConfigNode.)
Public method | ValueAsType | Tries to get value as specified type or throws if it can not be converted (Inherited from IConfigNode.)
Public method | ValueAsUInt | (Inherited from IConfigNode.)
Public method | ValueAsULong | (Inherited from IConfigNode.)
Public method | ValueAsUShort | (Inherited from IConfigNode.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | HasTheSameContent | Returns true when both config nodes represents the same manifest - that is the same file structure (Defined by ManifestUtils.)
Back to Top
Properties
 | Name | Description
Public property | AttrCount | Returns number of child attribute nodes
Public property | Attributes | Enumerates all attribute nodes
Public property | ChildCount | Returns number of child section nodes
Public property | Children | Enumerates all child nodes
Public property | Configuration | References configuration this node is under (Inherited from IConfigNode.)
Public property | EvaluatedValue | Returns null or value of this node with all variables evaluated (Inherited from IConfigNode.)
Public property | Exists | Determines whether this node really exists in configuration or is just a sentinel empty node (Inherited from IConfigNode.)
Public property | HasAttributes | Indicates whether this node has any associated attributes
Public property | HasChildren | Indicates whether this node has any child section nodes
Public property | Item Int32 | Retrieves section node by index or empty node instance if section node with such index could not be found
Public property | Item String | Retrieves section node by names, from left to right until existing node is found. If no existing node could be found then empty node instance is returned
Public property | Name | (Inherited from INamed.)
Public property | Parent | References parent node or empty node if this is the top-most node with no parent (Inherited from IConfigNode.)
Public property | RootPath | Returns a path from root to this node (Inherited from IConfigNode.)
Public property | Value | Returns null or value of this node with all variables evaluated (Inherited from IConfigNode.)
Public property | VerbatimValue | Returns varbatim (without variable evaluation) node value or null (Inherited from IConfigNode.)
Back to Top
See Also
IConfigSectionNode Interface
NFX.Environment Namespace


IConfigSectionNode Methods

IConfigSectionNode Methods NFX Class Library

The IConfigSectionNode type exposes the following members.
Methods
 | Name | Description
Public method | AttrByIndex | Returns attribute node by its index or empty attribute if real attribute with such index does not exist
Public method | AttrByName | Returns attribute node by its name or empty attribute if real attribute with such name does not exist
Public method | AttrsToStringMap | Returns attribute values as string map
Public method | EvaluateValueVariables | Evaluates a value string expanding all variables with var-paths relative to this node. Evaluates configuration variables such as "$(varname)" or "$(@varname)". Varnames are paths to other config nodes from the same configuration or variable names when prefixed with "~". If varname starts with "@" then it gets combined with input as path string. "~" is used to qualify environment vars that get resolved through Configuration.EnvironmentVarResolver Example: `....add key="Schema.$(/A/B/C/$attr)" value="$(@~HOME)bin\Transforms\"...`
Public method | IsSameName(String) | Returns true when another name is the same as this node's name (Inherited from IConfigNode.)
Public method | IsSameName(IConfigNode) | Returns true when another node has the same name as this one (Inherited from IConfigNode.)
Public method | IsSameNameAttr(String) | Returns true when this node has an attribute called "name" and its value is euqal to the supplied value per case-insensitive culture-neutral comparison
Public method | IsSameNameAttr(IConfigSectionNode) | Returns true when this and another nodes both have attribute "name" and their values are equal per case-insensitive culture-neutral comparison
Public method | Navigate | Navigates the path and return the appropriate node. Example '!/nfx/logger/destination/$file-name'
Public method | NavigateSection | Navigates the path and return the appropriate section node. Example '!/nfx/logger/destination'
Public method | ToConfigurationJSONDataMap | Returns the contents of this node per JSONConfiguration specification. Contrast with ToJSONDataMap
Public method | ToJSONDataMap | Converts this ConfigSectionNode to JSONDataMap. Contrast with ToConfigurationJSONDataMap Be carefull: that this operation can "loose" data from ConfigSectionNode. In other words some ConfigSectionNode information can not be reflected in corresponding JSONDataMap, for example this method overwrites duplicate key names and does not support section values
Public method | ToJSONString | Serializes configuration tree rooted at this node into JSON configuration format and returns it as a string
Public method | ToLaconicString | Serializes configuration tree rooted at this node into Laconic format and returns it as a string
Public method | ValueAsBool | (Inherited from IConfigNode.)
Public method | ValueAsByte | (Inherited from IConfigNode.)
Public method | ValueAsByteArray | (Inherited from IConfigNode.)
Public method | ValueAsDateTime | (Inherited from IConfigNode.)
Public method | ValueAsDecimal | (Inherited from IConfigNode.)
Public method | ValueAsDouble | (Inherited from IConfigNode.)
Public method | ValueAsEnum TEnum | (Inherited from IConfigNode.)
Public method | ValueAsFloat | (Inherited from IConfigNode.)
Public method | ValueAsGDID | (Inherited from IConfigNode.)
Public method | ValueAsGUID | (Inherited from IConfigNode.)
Public method | ValueAsInt | (Inherited from IConfigNode.)
Public method | ValueAsLong | (Inherited from IConfigNode.)
Public method | ValueAsNullableBool | (Inherited from IConfigNode.)
Public method | ValueAsNullableByte | (Inherited from IConfigNode.)
Public method | ValueAsNullableDateTime | (Inherited from IConfigNode.)
Public method | ValueAsNullableDecimal | (Inherited from IConfigNode.)
Public method | ValueAsNullableDouble | (Inherited from IConfigNode.)
Public method | ValueAsNullableEnum TEnum | (Inherited from IConfigNode.)
Public method | ValueAsNullableFloat | (Inherited from IConfigNode.)
Public method | ValueAsNullableGDID | (Inherited from IConfigNode.)
Public method | ValueAsNullableGUID | (Inherited from IConfigNode.)
Public method | ValueAsNullableInt | (Inherited from IConfigNode.)
Public method | ValueAsNullableLong | (Inherited from IConfigNode.)
Public method | ValueAsNullableSByte | (Inherited from IConfigNode.)
Public method | ValueAsNullableShort | (Inherited from IConfigNode.)
Public method | ValueAsNullableTimeSpan | (Inherited from IConfigNode.)
Public method | ValueAsNullableUInt | (Inherited from IConfigNode.)
Public method | ValueAsNullableULong | (Inherited from IConfigNode.)
Public method | ValueAsNullableUShort | (Inherited from IConfigNode.)
Public method | ValueAsSByte | (Inherited from IConfigNode.)
Public method | ValueAsShort | (Inherited from IConfigNode.)
Public method | ValueAsString | (Inherited from IConfigNode.)
Public method | ValueAsTimeSpan | (Inherited from IConfigNode.)
Public method | ValueAsType | Tries to get value as specified type or throws if it can not be converted (Inherited from IConfigNode.)
Public method | ValueAsUInt | (Inherited from IConfigNode.)
Public method | ValueAsULong | (Inherited from IConfigNode.)
Public method | ValueAsUShort | (Inherited from IConfigNode.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | HasTheSameContent | Returns true when both config nodes represents the same manifest - that is the same file structure (Defined by ManifestUtils.)
Back to Top
See Also
IConfigSectionNode Interface
NFX.Environment Namespace


IConfigSectionNode.AttrByIndex Method

IConfigSectionNode AttrByIndex Method NFX Class Library

Returns attribute node by its index or empty attribute if real attribute with such index does not exist

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IConfigAttrNode AttrByIndex(
    int idx
)
IConfigAttrNode AttrByIndex(
    int idx
)
Function AttrByIndex (
    idx As Integer
) As IConfigAttrNode
Function AttrByIndex (
    idx As Integer
) As IConfigAttrNode
IConfigAttrNode^ AttrByIndex(
    int idx
)
IConfigAttrNode^ AttrByIndex(
    int idx
)
abstract AttrByIndex :
        idx : int -> IConfigAttrNode
abstract AttrByIndex :
        idx : int -> IConfigAttrNode

Parameters

idx
Type: Online System Int32

Return Value

Type: IConfigAttrNode
See Also
IConfigSectionNode Interface
IConfigSectionNode Members
NFX.Environment Namespace


IConfigSectionNode.AttrByName Method

IConfigSectionNode AttrByName Method NFX Class Library

Returns attribute node by its name or empty attribute if real attribute with such name does not exist

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IConfigAttrNode AttrByName(
    string name,
    bool autoCreate = false
)
IConfigAttrNode AttrByName(
    string name,
    bool autoCreate = false
)
Function AttrByName (
    name As String,
    Optional autoCreate As Boolean = false
) As IConfigAttrNode
Function AttrByName (
    name As String,
    Optional autoCreate As Boolean = false
) As IConfigAttrNode
IConfigAttrNode^ AttrByName(
    String^ name,
    bool autoCreate = false
)
IConfigAttrNode^ AttrByName(
    String^ name,
    bool autoCreate = false
)
abstract AttrByName :
        name : string *
        ?autoCreate : bool
(* Defaults:
        let _autoCreate = defaultArg autoCreate false
*)
-> IConfigAttrNode
abstract AttrByName :
        name : string *
        ?autoCreate : bool
(* Defaults:
        let _autoCreate = defaultArg autoCreate false
*)
-> IConfigAttrNode

Parameters

name
Type: Online System String
autoCreate (Optional)
Type: Online System Boolean

Return Value

Type: IConfigAttrNode
See Also
IConfigSectionNode Interface
IConfigSectionNode Members
NFX.Environment Namespace


IConfigSectionNode.AttrsToStringMap Method

IConfigSectionNode AttrsToStringMap Method NFX Class Library

Returns attribute values as string map

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
StringMap AttrsToStringMap(
    bool verbatim = false
)
StringMap AttrsToStringMap(
    bool verbatim = false
)
Function AttrsToStringMap (
    Optional verbatim As Boolean = false
) As StringMap
Function AttrsToStringMap (
    Optional verbatim As Boolean = false
) As StringMap
StringMap^ AttrsToStringMap(
    bool verbatim = false
)
StringMap^ AttrsToStringMap(
    bool verbatim = false
)
abstract AttrsToStringMap :
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> StringMap
abstract AttrsToStringMap :
        ?verbatim : bool
(* Defaults:
        let _verbatim = defaultArg verbatim false
*)
-> StringMap

Parameters

verbatim (Optional)
Type: Online System Boolean

Return Value

Type: StringMap
See Also
IConfigSectionNode Interface
IConfigSectionNode Members
NFX.Environment Namespace


IConfigSectionNode.EvaluateValueVariables Method

IConfigSectionNode EvaluateValueVariables Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Evaluates a value string expanding all variables with var-paths relative to this node. Evaluates configuration variables such as "$(varname)" or "$(@varname)". Varnames are paths to other config nodes from the same configuration or variable names when prefixed with "~". If varname starts with "@" then it gets combined with input as path string. "~" is used to qualify environment vars that get resolved through Configuration.EnvironmentVarResolver Example: `....add key="Schema.$(/A/B/C/$attr)" value="$(@~HOME)bin\Transforms\"...`

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string EvaluateValueVariables(
    string value
)
string EvaluateValueVariables(
    string value
)
Function EvaluateValueVariables (
    value As String
) As String
Function EvaluateValueVariables (
    value As String
) As String
String^ EvaluateValueVariables(
    String^ value
)
String^ EvaluateValueVariables(
    String^ value
)
abstract EvaluateValueVariables :
        value : string -> string
abstract EvaluateValueVariables :
        value : string -> string

Parameters

value
Type: Online System String

Return Value

Type: Online String
See Also
IConfigSectionNode Interface
IConfigSectionNode Members
NFX.Environment Namespace


IConfigSectionNode.IsSameNameAttr Method

IConfigSectionNode IsSameNameAttr Method NFX Class Library

Overload List
 | Name | Description
Public method | IsSameNameAttr(String) | Returns true when this node has an attribute called "name" and its value is euqal to the supplied value per case-insensitive culture-neutral comparison
Public method | IsSameNameAttr(IConfigSectionNode) | Returns true when this and another nodes both have attribute "name" and their values are equal per case-insensitive culture-neutral comparison
Back to Top
See Also
IConfigSectionNode Interface
IConfigSectionNode Members
NFX.Environment Namespace


IConfigSectionNode.IsSameNameAttr Method (String)

IConfigSectionNode IsSameNameAttr Method (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns true when this node has an attribute called "name" and its value is euqal to the supplied value per case-insensitive culture-neutral comparison

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsSameNameAttr(
    string other
)
bool IsSameNameAttr(
    string other
)
Function IsSameNameAttr (
    other As String
) As Boolean
Function IsSameNameAttr (
    other As String
) As Boolean
bool IsSameNameAttr(
    String^ other
)
bool IsSameNameAttr(
    String^ other
)
abstract IsSameNameAttr :
        other : string -> bool
abstract IsSameNameAttr :
        other : string -> bool

Parameters

other
Type: Online System String

Return Value

Type: Online Boolean
See Also
IConfigSectionNode Interface
IConfigSectionNode Members
IsSameNameAttr Overload
NFX.Environment Namespace


IConfigSectionNode.IsSameNameAttr Method (IConfigSectionNode)

IConfigSectionNode IsSameNameAttr Method (IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns true when this and another nodes both have attribute "name" and their values are equal per case-insensitive culture-neutral comparison

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsSameNameAttr(
    IConfigSectionNode other
)
bool IsSameNameAttr(
    IConfigSectionNode other
)
Function IsSameNameAttr (
    other As IConfigSectionNode
) As Boolean
Function IsSameNameAttr (
    other As IConfigSectionNode
) As Boolean
bool IsSameNameAttr(
    IConfigSectionNode^ other
)
bool IsSameNameAttr(
    IConfigSectionNode^ other
)
abstract IsSameNameAttr :
        other : IConfigSectionNode -> bool
abstract IsSameNameAttr :
        other : IConfigSectionNode -> bool

Parameters

other
Type: NFX.Environment IConfigSectionNode

Return Value

Type: Online Boolean
See Also
IConfigSectionNode Interface
IConfigSectionNode Members
IsSameNameAttr Overload
NFX.Environment Namespace


IConfigSectionNode.Navigate Method

IConfigSectionNode Navigate Method NFX Class Library

Navigates the path and return the appropriate node. Example '!/nfx/logger/destination/$file-name'

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IConfigNode Navigate(
    string path
)
IConfigNode Navigate(
    string path
)
Function Navigate (
    path As String
) As IConfigNode
Function Navigate (
    path As String
) As IConfigNode
IConfigNode^ Navigate(
    String^ path
)
IConfigNode^ Navigate(
    String^ path
)
abstract Navigate :
        path : string -> IConfigNode
abstract Navigate :
        path : string -> IConfigNode

Parameters

path
Type: Online System String
If path starts from '!' then exception will be thrown if such a node does not exist; Use '/' as leading char for root, '..' for step up, '$' for attribute name. Multiple paths may be coalesced using '|' or ';'

Return Value

Type: IConfigNode
See Also
IConfigSectionNode Interface
IConfigSectionNode Members
NFX.Environment Namespace


IConfigSectionNode.NavigateSection Method

IConfigSectionNode NavigateSection Method NFX Class Library

Navigates the path and return the appropriate section node. Example '!/nfx/logger/destination'

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IConfigSectionNode NavigateSection(
    string path
)
IConfigSectionNode NavigateSection(
    string path
)
Function NavigateSection (
    path As String
) As IConfigSectionNode
Function NavigateSection (
    path As String
) As IConfigSectionNode
IConfigSectionNode^ NavigateSection(
    String^ path
)
IConfigSectionNode^ NavigateSection(
    String^ path
)
abstract NavigateSection :
        path : string -> IConfigSectionNode
abstract NavigateSection :
        path : string -> IConfigSectionNode

Parameters

path
Type: Online System String
If path starts from '!' then exception will be thrown if such a section node does not exist; Use '/' as leading char for root, '..' for step up. Multiple paths may be coalesced using '|' or ';'

Return Value

Type: IConfigSectionNode
See Also
IConfigSectionNode Interface
IConfigSectionNode Members
NFX.Environment Namespace


IConfigSectionNode.ToConfigurationJSONDataMap Method

IConfigSectionNode ToConfigurationJSONDataMap Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns the contents of this node per JSONConfiguration specification. Contrast with ToJSONDataMap

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
JSONDataMap ToConfigurationJSONDataMap()
JSONDataMap ToConfigurationJSONDataMap()
Function ToConfigurationJSONDataMap As JSONDataMap
Function ToConfigurationJSONDataMap As JSONDataMap
JSONDataMap^ ToConfigurationJSONDataMap()
JSONDataMap^ ToConfigurationJSONDataMap()
abstract ToConfigurationJSONDataMap : unit -> JSONDataMap
abstract ToConfigurationJSONDataMap : unit -> JSONDataMap

Return Value

Type: JSONDataMap
See Also
IConfigSectionNode Interface
IConfigSectionNode Members
NFX.Environment Namespace


IConfigSectionNode.ToJSONDataMap Method

IConfigSectionNode ToJSONDataMap Method NFX Class Library

Converts this ConfigSectionNode to JSONDataMap. Contrast with ToConfigurationJSONDataMap Be carefull: that this operation can "loose" data from ConfigSectionNode. In other words some ConfigSectionNode information can not be reflected in corresponding JSONDataMap, for example this method overwrites duplicate key names and does not support section values

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
JSONDataMap ToJSONDataMap()
JSONDataMap ToJSONDataMap()
Function ToJSONDataMap As JSONDataMap
Function ToJSONDataMap As JSONDataMap
JSONDataMap^ ToJSONDataMap()
JSONDataMap^ ToJSONDataMap()
abstract ToJSONDataMap : unit -> JSONDataMap
abstract ToJSONDataMap : unit -> JSONDataMap

Return Value

Type: JSONDataMap
See Also
IConfigSectionNode Interface
IConfigSectionNode Members
NFX.Environment Namespace


IConfigSectionNode.ToJSONString Method

IConfigSectionNode ToJSONString Method NFX Class Library

Serializes configuration tree rooted at this node into JSON configuration format and returns it as a string

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string ToJSONString(
    JSONWritingOptions options = null
)
string ToJSONString(
    JSONWritingOptions options = null
)
Function ToJSONString (
    Optional options As JSONWritingOptions = Nothing
) As String
Function ToJSONString (
    Optional options As JSONWritingOptions = Nothing
) As String
String^ ToJSONString(
    JSONWritingOptions^ options = nullptr
)
String^ ToJSONString(
    JSONWritingOptions^ options = nullptr
)
abstract ToJSONString :
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> string
abstract ToJSONString :
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> string

Parameters

options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Return Value

Type: Online String
See Also
IConfigSectionNode Interface
IConfigSectionNode Members
NFX.Environment Namespace


IConfigSectionNode.ToLaconicString Method

IConfigSectionNode ToLaconicString Method NFX Class Library

Serializes configuration tree rooted at this node into Laconic format and returns it as a string

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string ToLaconicString(
    LaconfigWritingOptions options = null
)
string ToLaconicString(
    LaconfigWritingOptions options = null
)
Function ToLaconicString (
    Optional options As LaconfigWritingOptions = Nothing
) As String
Function ToLaconicString (
    Optional options As LaconfigWritingOptions = Nothing
) As String
String^ ToLaconicString(
    LaconfigWritingOptions^ options = nullptr
)
String^ ToLaconicString(
    LaconfigWritingOptions^ options = nullptr
)
abstract ToLaconicString :
        ?options : LaconfigWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> string
abstract ToLaconicString :
        ?options : LaconfigWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> string

Parameters

options (Optional)
Type: NFX.CodeAnalysis.Laconfig LaconfigWritingOptions

Return Value

Type: Online String
See Also
IConfigSectionNode Interface
IConfigSectionNode Members
NFX.Environment Namespace


IConfigSectionNode Properties

IConfigSectionNode Properties NFX Class Library

The IConfigSectionNode type exposes the following members.
Properties
 | Name | Description
Public property | AttrCount | Returns number of child attribute nodes
Public property | Attributes | Enumerates all attribute nodes
Public property | ChildCount | Returns number of child section nodes
Public property | Children | Enumerates all child nodes
Public property | Configuration | References configuration this node is under (Inherited from IConfigNode.)
Public property | EvaluatedValue | Returns null or value of this node with all variables evaluated (Inherited from IConfigNode.)
Public property | Exists | Determines whether this node really exists in configuration or is just a sentinel empty node (Inherited from IConfigNode.)
Public property | HasAttributes | Indicates whether this node has any associated attributes
Public property | HasChildren | Indicates whether this node has any child section nodes
Public property | Item Int32 | Retrieves section node by index or empty node instance if section node with such index could not be found
Public property | Item String | Retrieves section node by names, from left to right until existing node is found. If no existing node could be found then empty node instance is returned
Public property | Name | (Inherited from INamed.)
Public property | Parent | References parent node or empty node if this is the top-most node with no parent (Inherited from IConfigNode.)
Public property | RootPath | Returns a path from root to this node (Inherited from IConfigNode.)
Public property | Value | Returns null or value of this node with all variables evaluated (Inherited from IConfigNode.)
Public property | VerbatimValue | Returns varbatim (without variable evaluation) node value or null (Inherited from IConfigNode.)
Back to Top
See Also
IConfigSectionNode Interface
NFX.Environment Namespace


IConfigSectionNode.AttrCount Property

IConfigSectionNode AttrCount Property NFX Class Library

Returns number of child attribute nodes

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int AttrCount { get; }
int AttrCount { get; }
ReadOnly Property AttrCount As Integer
    Get
ReadOnly Property AttrCount As Integer
    Get
property int AttrCount {
    int get ();
}
property int AttrCount {
    int get ();
}
abstract AttrCount : int with get
abstract AttrCount : int with get

Property Value

Type: Online Int32
See Also
IConfigSectionNode Interface
IConfigSectionNode Members
NFX.Environment Namespace


IConfigSectionNode.Attributes Property

IConfigSectionNode Attributes Property NFX Class Library

Enumerates all attribute nodes

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<IConfigAttrNode> Attributes { get; }
IEnumerable<IConfigAttrNode> Attributes { get; }
ReadOnly Property Attributes As IEnumerable(Of IConfigAttrNode)
    Get
ReadOnly Property Attributes As IEnumerable(Of IConfigAttrNode)
    Get
property IEnumerable<IConfigAttrNode^>^ Attributes {
    IEnumerable<IConfigAttrNode^>^ get ();
}
property IEnumerable<IConfigAttrNode^>^ Attributes {
    IEnumerable<IConfigAttrNode^>^ get ();
}
abstract Attributes : IEnumerable<IConfigAttrNode> with get
abstract Attributes : IEnumerable<IConfigAttrNode> with get

Property Value

Type: Online IEnumerable IConfigAttrNode
See Also
IConfigSectionNode Interface
IConfigSectionNode Members
NFX.Environment Namespace


IConfigSectionNode.ChildCount Property

IConfigSectionNode ChildCount Property NFX Class Library

Returns number of child section nodes

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int ChildCount { get; }
int ChildCount { get; }
ReadOnly Property ChildCount As Integer
    Get
ReadOnly Property ChildCount As Integer
    Get
property int ChildCount {
    int get ();
}
property int ChildCount {
    int get ();
}
abstract ChildCount : int with get
abstract ChildCount : int with get

Property Value

Type: Online Int32
See Also
IConfigSectionNode Interface
IConfigSectionNode Members
NFX.Environment Namespace


IConfigSectionNode.Children Property

IConfigSectionNode Children Property NFX Class Library

Enumerates all child nodes

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<IConfigSectionNode> Children { get; }
IEnumerable<IConfigSectionNode> Children { get; }
ReadOnly Property Children As IEnumerable(Of IConfigSectionNode)
    Get
ReadOnly Property Children As IEnumerable(Of IConfigSectionNode)
    Get
property IEnumerable<IConfigSectionNode^>^ Children {
    IEnumerable<IConfigSectionNode^>^ get ();
}
property IEnumerable<IConfigSectionNode^>^ Children {
    IEnumerable<IConfigSectionNode^>^ get ();
}
abstract Children : IEnumerable<IConfigSectionNode> with get
abstract Children : IEnumerable<IConfigSectionNode> with get

Property Value

Type: Online IEnumerable IConfigSectionNode
See Also
IConfigSectionNode Interface
IConfigSectionNode Members
NFX.Environment Namespace


IConfigSectionNode.HasAttributes Property

IConfigSectionNode HasAttributes Property NFX Class Library

Indicates whether this node has any associated attributes

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool HasAttributes { get; }
bool HasAttributes { get; }
ReadOnly Property HasAttributes As Boolean
    Get
ReadOnly Property HasAttributes As Boolean
    Get
property bool HasAttributes {
    bool get ();
}
property bool HasAttributes {
    bool get ();
}
abstract HasAttributes : bool with get
abstract HasAttributes : bool with get

Property Value

Type: Online Boolean
See Also
IConfigSectionNode Interface
IConfigSectionNode Members
NFX.Environment Namespace


IConfigSectionNode.HasChildren Property

IConfigSectionNode HasChildren Property NFX Class Library

Indicates whether this node has any child section nodes

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool HasChildren { get; }
bool HasChildren { get; }
ReadOnly Property HasChildren As Boolean
    Get
ReadOnly Property HasChildren As Boolean
    Get
property bool HasChildren {
    bool get ();
}
property bool HasChildren {
    bool get ();
}
abstract HasChildren : bool with get
abstract HasChildren : bool with get

Property Value

Type: Online Boolean
See Also
IConfigSectionNode Interface
IConfigSectionNode Members
NFX.Environment Namespace


IConfigSectionNode.Item Property

IConfigSectionNode Item Property NFX Class Library

Overload List
 | Name | Description
Public property | Item Int32 | Retrieves section node by index or empty node instance if section node with such index could not be found
Public property | Item String | Retrieves section node by names, from left to right until existing node is found. If no existing node could be found then empty node instance is returned
Back to Top
See Also
IConfigSectionNode Interface
IConfigSectionNode Members
NFX.Environment Namespace


IConfigSectionNode.Item Property (Int32)

IConfigSectionNode Item Property (Int32) NFX Class Library

Retrieves section node by index or empty node instance if section node with such index could not be found

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IConfigSectionNode this[
    int idx
] { get; }
IConfigSectionNode this[
    int idx
] { get; }
ReadOnly Default Property Item (
    idx As Integer
) As IConfigSectionNode
    Get
ReadOnly Default Property Item (
    idx As Integer
) As IConfigSectionNode
    Get
property IConfigSectionNode^ default[int idx] {
    IConfigSectionNode^ get (int idx);
}
property IConfigSectionNode^ default[int idx] {
    IConfigSectionNode^ get (int idx);
}
abstract Item : IConfigSectionNode with get
abstract Item : IConfigSectionNode with get

Parameters

idx
Type: Online System Int32

Property Value

Type: IConfigSectionNode
See Also
IConfigSectionNode Interface
IConfigSectionNode Members
Item Overload
NFX.Environment Namespace


IConfigSectionNode.Item Property (String[])

IConfigSectionNode Item Property ( String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Retrieves section node by names, from left to right until existing node is found. If no existing node could be found then empty node instance is returned

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IConfigSectionNode this[
    params string[] names
] { get; }
IConfigSectionNode this[
    params string[] names
] { get; }
ReadOnly Default Property Item (
    ParamArray names As String()
) As IConfigSectionNode
    Get
ReadOnly Default Property Item (
    ParamArray names As String()
) As IConfigSectionNode
    Get
property IConfigSectionNode^ default[... array<String^>^ names] {
    IConfigSectionNode^ get (... array<String^>^ names);
}
property IConfigSectionNode^ default[... array<String^>^ names] {
    IConfigSectionNode^ get (... array<String^>^ names);
}
abstract Item : IConfigSectionNode with get
abstract Item : IConfigSectionNode with get

Parameters

names
Type: Online System String

Property Value

Type: IConfigSectionNode
See Also
IConfigSectionNode Interface
IConfigSectionNode Members
Item Overload
NFX.Environment Namespace


IConfigSettings Interface

IConfigSettings Interface NFX Class Library

Represents an entity that provides a type-safe access to configuration settings that come from Configuration nodes. This class obviates the need for navigation between config nodes on every property get and facilitates faster access to some config parameters that need to be gotten efficiently, as they are now kept cached in RAM in native format (i.e. DateTime vs. string) as fields. Usually classes that implement this interface are singleton and they get registered with the application using IApplication.RegisterConfigSettings() method. Warning: the implementation must be thread-safe and allow property getters to keep reading while ConfigChanged() notification happens

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IConfigSettings
public interface IConfigSettings
Public Interface IConfigSettings
Public Interface IConfigSettings
public interface class IConfigSettings
public interface class IConfigSettings
type IConfigSettings =  interface end
type IConfigSettings =  interface end
See Also
IConfigSettings Members
NFX.Environment Namespace


IConfigSettings Members

IConfigSettings Members NFX Class Library

The IConfigSettings type exposes the following members.
Methods
 | Name | Description
Public method | ConfigChanged | Notifies the implementer that underlying source configuration has changed and memory-resident fields need to be re-read from config nodes. Usually this method is called by application container when instance of this class has been registered with the application using IApplication.RegisterConfigSettings(). Warning: the implementation must be thread-safe and allow getters to keep reading while notification happens
Back to Top
See Also
IConfigSettings Interface
NFX.Environment Namespace


IConfigSettings Methods

IConfigSettings Methods NFX Class Library

The IConfigSettings type exposes the following members.
Methods
 | Name | Description
Public method | ConfigChanged | Notifies the implementer that underlying source configuration has changed and memory-resident fields need to be re-read from config nodes. Usually this method is called by application container when instance of this class has been registered with the application using IApplication.RegisterConfigSettings(). Warning: the implementation must be thread-safe and allow getters to keep reading while notification happens
Back to Top
See Also
IConfigSettings Interface
NFX.Environment Namespace


IConfigSettings.ConfigChanged Method

IConfigSettings ConfigChanged Method NFX Class Library

Notifies the implementer that underlying source configuration has changed and memory-resident fields need to be re-read from config nodes. Usually this method is called by application container when instance of this class has been registered with the application using IApplication.RegisterConfigSettings(). Warning: the implementation must be thread-safe and allow getters to keep reading while notification happens

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ConfigChanged(
    IConfigSectionNode atNode
)
void ConfigChanged(
    IConfigSectionNode atNode
)
Sub ConfigChanged (
    atNode As IConfigSectionNode
)
Sub ConfigChanged (
    atNode As IConfigSectionNode
)
void ConfigChanged(
    IConfigSectionNode^ atNode
)
void ConfigChanged(
    IConfigSectionNode^ atNode
)
abstract ConfigChanged :
        atNode : IConfigSectionNode -> unit
abstract ConfigChanged :
        atNode : IConfigSectionNode -> unit

Parameters

atNode
Type: NFX.Environment IConfigSectionNode
Passes the most top-level node that covers all of the changes that happened in the source config system. Usually this is a root config node. The capability of source config change detection on node level is not supported by all providers
See Also
IConfigSettings Interface
IConfigSettings Members
NFX.Environment Namespace


IConfigStringBuilder Interface

IConfigStringBuilder Interface NFX Class Library

Denotes objects that can build a string (i.e. a database connection string) from the configured state/properties. This is used for example to build DB connect strings from host names that need to be resolved via an external system

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IConfigStringBuilder : IConfigurable
public interface IConfigStringBuilder : IConfigurable
Public Interface IConfigStringBuilder
    Inherits IConfigurable
Public Interface IConfigStringBuilder
    Inherits IConfigurable
public interface class IConfigStringBuilder : IConfigurable
public interface class IConfigStringBuilder : IConfigurable
type IConfigStringBuilder =
    interface
        interface IConfigurable
    end
type IConfigStringBuilder =
    interface
        interface IConfigurable
    end
See Also
IConfigStringBuilder Members
NFX.Environment Namespace


IConfigStringBuilder Members

IConfigStringBuilder Members NFX Class Library

The IConfigStringBuilder type exposes the following members.
Methods
 | Name | Description
Public method | BuildString | Builds the string based on the configured state
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Back to Top
See Also
IConfigStringBuilder Interface
NFX.Environment Namespace


IConfigStringBuilder Methods

IConfigStringBuilder Methods NFX Class Library

The IConfigStringBuilder type exposes the following members.
Methods
 | Name | Description
Public method | BuildString | Builds the string based on the configured state
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Back to Top
See Also
IConfigStringBuilder Interface
NFX.Environment Namespace


IConfigStringBuilder.BuildString Method

IConfigStringBuilder BuildString Method NFX Class Library

Builds the string based on the configured state

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string BuildString()
string BuildString()
Function BuildString As String
Function BuildString As String
String^ BuildString()
String^ BuildString()
abstract BuildString : unit -> string
abstract BuildString : unit -> string

Return Value

Type: Online String
See Also
IConfigStringBuilder Interface
IConfigStringBuilder Members
NFX.Environment Namespace


IConfigurable Interface

IConfigurable Interface NFX Class Library

Designates entities that may be configured

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IConfigurable
public interface IConfigurable
Public Interface IConfigurable
Public Interface IConfigurable
public interface class IConfigurable
public interface class IConfigurable
type IConfigurable =  interface end
type IConfigurable =  interface end
See Also
IConfigurable Members
NFX.Environment Namespace


IConfigurable Members

IConfigurable Members NFX Class Library

The IConfigurable type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Configures an entity from supplied config node
Back to Top
See Also
IConfigurable Interface
NFX.Environment Namespace


IConfigurable Methods

IConfigurable Methods NFX Class Library

The IConfigurable type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Configures an entity from supplied config node
Back to Top
See Also
IConfigurable Interface
NFX.Environment Namespace


IConfigurable.Configure Method

IConfigurable Configure Method NFX Class Library

Configures an entity from supplied config node

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Configure(
    IConfigSectionNode node
)
void Configure(
    IConfigSectionNode node
)
Sub Configure (
    node As IConfigSectionNode
)
Sub Configure (
    node As IConfigSectionNode
)
void Configure(
    IConfigSectionNode^ node
)
void Configure(
    IConfigSectionNode^ node
)
abstract Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
IConfigurable Interface
IConfigurable Members
NFX.Environment Namespace


IConfigurationPersistent Interface

IConfigurationPersistent Interface NFX Class Library

Designates entities that may persist their parameters/state in configuration

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IConfigurationPersistent
public interface IConfigurationPersistent
Public Interface IConfigurationPersistent
Public Interface IConfigurationPersistent
public interface class IConfigurationPersistent
public interface class IConfigurationPersistent
type IConfigurationPersistent =  interface end
type IConfigurationPersistent =  interface end
See Also
IConfigurationPersistent Members
NFX.Environment Namespace


IConfigurationPersistent Members

IConfigurationPersistent Members NFX Class Library

The IConfigurationPersistent type exposes the following members.
Methods
 | Name | Description
Public method | PersistConfiguration | Persists relevant entities parameters/state into configuration
Back to Top
See Also
IConfigurationPersistent Interface
NFX.Environment Namespace


IConfigurationPersistent Methods

IConfigurationPersistent Methods NFX Class Library

The IConfigurationPersistent type exposes the following members.
Methods
 | Name | Description
Public method | PersistConfiguration | Persists relevant entities parameters/state into configuration
Back to Top
See Also
IConfigurationPersistent Interface
NFX.Environment Namespace


IConfigurationPersistent.PersistConfiguration Method

IConfigurationPersistent PersistConfiguration Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Persists relevant entities parameters/state into configuration

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void PersistConfiguration(
    ConfigSectionNode node
)
void PersistConfiguration(
    ConfigSectionNode node
)
Sub PersistConfiguration (
    node As ConfigSectionNode
)
Sub PersistConfiguration (
    node As ConfigSectionNode
)
void PersistConfiguration(
    ConfigSectionNode^ node
)
void PersistConfiguration(
    ConfigSectionNode^ node
)
abstract PersistConfiguration :
        node : ConfigSectionNode -> unit
abstract PersistConfiguration :
        node : ConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment ConfigSectionNode
See Also
IConfigurationPersistent Interface
IConfigurationPersistent Members
NFX.Environment Namespace


IEnvironmentVariableResolver Interface

IEnvironmentVariableResolver Interface NFX Class Library

Represents an entity that can resolve variables

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IEnvironmentVariableResolver
public interface IEnvironmentVariableResolver
Public Interface IEnvironmentVariableResolver
Public Interface IEnvironmentVariableResolver
public interface class IEnvironmentVariableResolver
public interface class IEnvironmentVariableResolver
type IEnvironmentVariableResolver =  interface end
type IEnvironmentVariableResolver =  interface end
See Also
IEnvironmentVariableResolver Members
NFX.Environment Namespace


IEnvironmentVariableResolver Members

IEnvironmentVariableResolver Members NFX Class Library

The IEnvironmentVariableResolver type exposes the following members.
Methods
 | Name | Description
Public method | ResolveEnvironmentVariable | Turns named variable into its value or null
Back to Top
See Also
IEnvironmentVariableResolver Interface
NFX.Environment Namespace


IEnvironmentVariableResolver Methods

IEnvironmentVariableResolver Methods NFX Class Library

The IEnvironmentVariableResolver type exposes the following members.
Methods
 | Name | Description
Public method | ResolveEnvironmentVariable | Turns named variable into its value or null
Back to Top
See Also
IEnvironmentVariableResolver Interface
NFX.Environment Namespace


IEnvironmentVariableResolver.ResolveEnvironmentVariable Method

IEnvironmentVariableResolver ResolveEnvironmentVariable Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Turns named variable into its value or null

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string ResolveEnvironmentVariable(
    string name
)
string ResolveEnvironmentVariable(
    string name
)
Function ResolveEnvironmentVariable (
    name As String
) As String
Function ResolveEnvironmentVariable (
    name As String
) As String
String^ ResolveEnvironmentVariable(
    String^ name
)
String^ ResolveEnvironmentVariable(
    String^ name
)
abstract ResolveEnvironmentVariable :
        name : string -> string
abstract ResolveEnvironmentVariable :
        name : string -> string

Parameters

name
Type: Online System String

Return Value

Type: Online String
See Also
IEnvironmentVariableResolver Interface
IEnvironmentVariableResolver Members
NFX.Environment Namespace


IMacroRunner Interface

IMacroRunner Interface NFX Class Library

Represents an entity that runs config var macros

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IMacroRunner
public interface IMacroRunner
Public Interface IMacroRunner
Public Interface IMacroRunner
public interface class IMacroRunner
public interface class IMacroRunner
type IMacroRunner =  interface end
type IMacroRunner =  interface end
See Also
IMacroRunner Members
NFX.Environment Namespace


IMacroRunner Members

IMacroRunner Members NFX Class Library

The IMacroRunner type exposes the following members.
Methods
 | Name | Description
Public method | Run | Runs macro
Back to Top
See Also
IMacroRunner Interface
NFX.Environment Namespace


IMacroRunner Methods

IMacroRunner Methods NFX Class Library

The IMacroRunner type exposes the following members.
Methods
 | Name | Description
Public method | Run | Runs macro
Back to Top
See Also
IMacroRunner Interface
NFX.Environment Namespace


IMacroRunner.Run Method

IMacroRunner Run Method NFX Class Library

Runs macro

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Run(
    IConfigSectionNode node,
    string inputValue,
    string macroName,
    IConfigSectionNode macroParams,
    Object context = null
)
string Run(
    IConfigSectionNode node,
    string inputValue,
    string macroName,
    IConfigSectionNode macroParams,
    Object context = null
)
Function Run (
    node As IConfigSectionNode,
    inputValue As String,
    macroName As String,
    macroParams As IConfigSectionNode,
    Optional context As Object = Nothing
) As String
Function Run (
    node As IConfigSectionNode,
    inputValue As String,
    macroName As String,
    macroParams As IConfigSectionNode,
    Optional context As Object = Nothing
) As String
String^ Run(
    IConfigSectionNode^ node,
    String^ inputValue,
    String^ macroName,
    IConfigSectionNode^ macroParams,
    Object^ context = nullptr
)
String^ Run(
    IConfigSectionNode^ node,
    String^ inputValue,
    String^ macroName,
    IConfigSectionNode^ macroParams,
    Object^ context = nullptr
)
abstract Run :
        node : IConfigSectionNode *
        inputValue : string *
        macroName : string *
        macroParams : IConfigSectionNode *
        ?context : Object
(* Defaults:
        let _context = defaultArg context null
*)
-> string
abstract Run :
        node : IConfigSectionNode *
        inputValue : string *
        macroName : string *
        macroParams : IConfigSectionNode *
        ?context : Object
(* Defaults:
        let _context = defaultArg context null
*)
-> string

Parameters

node
Type: NFX.Environment IConfigSectionNode
inputValue
Type: Online System String
macroName
Type: Online System String
macroParams
Type: NFX.Environment IConfigSectionNode
context (Optional)
Type: Online System Object

Return Value

Type: Online String
See Also
IMacroRunner Interface
IMacroRunner Members
NFX.Environment Namespace


JSONConfiguration Class

JSONConfiguration Class NFX Class Library

Provides implementation of configuration based on a classic JSON content
Inheritance Hierarchy
Online System Object
NFX.Environment Configuration
NFX.Environment FileConfiguration
NFX.Environment JSONConfiguration

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class JSONConfiguration : FileConfiguration
[SerializableAttribute]
public class JSONConfiguration : FileConfiguration
<SerializableAttribute>
Public Class JSONConfiguration
    Inherits FileConfiguration
<SerializableAttribute>
Public Class JSONConfiguration
    Inherits FileConfiguration
[SerializableAttribute]
public ref class JSONConfiguration : public FileConfiguration
[SerializableAttribute]
public ref class JSONConfiguration : public FileConfiguration
[<SerializableAttribute>]
type JSONConfiguration =
    class
        inherit FileConfiguration
    end
[<SerializableAttribute>]
type JSONConfiguration =
    class
        inherit FileConfiguration
    end
See Also
JSONConfiguration Members
NFX.Environment Namespace


JSONConfiguration Members

JSONConfiguration Members NFX Class Library

The JSONConfiguration type exposes the following members.
Constructors
 | Name | Description
Public method | JSONConfiguration | Creates an instance of a new configuration not bound to any JSON file
Public method | JSONConfiguration(String) | Creates an isntance of the new configuration and reads contents from a JSON file
Back to Top
Methods
 | Name | Description
Protected method | AdjustNodeName | Override to perform transforms on node names so they become suitable for particular configuration type (Inherited from Configuration.)
Public method | CheckAndAdjustNodeName | Checks node name for aptitude for particular configuration type. For example, XML configuration does not allow nodes with spaces or separator chars. When StrictNames is set to true and value is not appropriate then exception is thrown (Inherited from Configuration.)
Public method | Clone(Configuration) | Creates a deep copy of this configuration into newInstance which was allocated externally (Inherited from Configuration.)
Public method | Clone T | Creates a deep copy of this configuration into new instance of T (Inherited from Configuration.)
Public method | Create | Creates new configuration - creates new configuration root with optional name parameter (Inherited from Configuration.)
 | CreateFromJSON | Creates an instance of configuration initialized from JSON content passed as string
Public method | CreateFromMerge | Creates new configuration from ordered merge result of two other nodes - base and override which can be from different configurations (Inherited from Configuration.)
Public method | CreateFromNode | Creates new configuration from other node, which may belong to a different configuration instance (Inherited from Configuration.)
Public method | Destroy | Erases all config data (Inherited from Configuration.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Include | Completely replaces this node with another node tree, positioning the new tree in the place of local node. Existing node is deleted after this operation completes, in its place child nodes from other node are inserted preserving their existing order. Attributes of other node get merged into parent of existing node (Inherited from Configuration.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Refresh | (Overrides Configuration Refresh .)
Public method | ResolveEnvironmentVar | Resolves variable name into its value (Inherited from Configuration.)
Public method | RunMacro | Runs macro and returns its value (Inherited from Configuration.)
Public method | Save | (Overrides Configuration Save .)
Public method | SaveAs(String) | Saves configuration into a JSON file (Overrides FileConfiguration SaveAs(String).)
Public method | SaveAs(String, JSONWritingOptions, Encoding) | Saves configuration into a JSON file
Public method | SaveToString | Saves JSON configuration to string
Public method | SetReadOnly | (Inherited from FileConfiguration.)
Public method | ToConfigurationJSONDataMap | Returns this config as JSON data map suitable for making JSONConfiguration (Inherited from Configuration.)
Public method | ToLaconicFile | Serializes configuration tree into Laconic format and writes it into a file (Inherited from Configuration.)
Public method | ToLaconicStream | Serializes configuration tree into Laconic format and writes it into stream (Inherited from Configuration.)
Public method | ToLaconicString | Serializes configuration tree into Laconic format and returns it as a string (Inherited from Configuration.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_EmptyAttrNode | (Inherited from Configuration.)
Protected field | m_EmptySectionNode | (Inherited from Configuration.)
Protected field | m_FileName | (Inherited from FileConfiguration.)
Protected field | m_Root | (Inherited from Configuration.)
 | SECTION_VALUE_ATTR |
Back to Top
Properties
 | Name | Description
Public property | ContentView | Primarily used for debugging - returns the content of the configuration as text in the pretty-printed Laconic format (Inherited from Configuration.)
Public property | EmptyAttr | References a special instance of an empty attribute node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist (Inherited from Configuration.)
Public property | EmptySection | References a special instance of an empty section node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist (Inherited from Configuration.)
Public property | EnvironmentVarResolver | References variable resolver. If this property is not set then default Windows environment var resolver is used (Inherited from Configuration.)
Public property | FileName | (Inherited from FileConfiguration.)
Public property | IsReadOnly | Indicates whether configuration is readonly or may be modified and saved (Inherited from FileConfiguration.)
Public property | MacroRunner | References macro runner. If this property is not set then default macro runner is used (Inherited from Configuration.)
Public property | MacroRunnerContext | Gets/sets an object passed by the framework into MacroRunner.Run() method. This property is auto-set for classes decorated with [ConfigMacroContext] attribute (Inherited from Configuration.)
Public property | Root | Accesses root section configuration node (Inherited from Configuration.)
Public property | StrictNames | Determines whether exception is thrown when configuration node name contains inappropriate chars for particular configuration type. For example, for XMLConfiguration node names may not have spaces and other separator chars. When StrictNames is false then particular configurations may replace incompatible chars in node names with neutral ones (i.e. "my value"->"my-value" in case of XMLConfiguration). (Inherited from Configuration.)
Public property | Variable_END | Variable end tag (Inherited from Configuration.)
Public property | Variable_ENV_MOD | Variable environment modifier (Inherited from Configuration.)
Public property | Variable_ESCAPE | Variable escape tag (Inherited from Configuration.)
Public property | Variable_MACRO_START | Variable get clause modifier (Inherited from Configuration.)
Public property | Variable_PATH_MOD | Variable path modifier (Inherited from Configuration.)
Public property | Variable_START | Variable start tag (Inherited from Configuration.)
Back to Top
See Also
JSONConfiguration Class
NFX.Environment Namespace


JSONConfiguration Constructor

JSONConfiguration Constructor NFX Class Library

Overload List
 | Name | Description
Public method | JSONConfiguration | Creates an instance of a new configuration not bound to any JSON file
Public method | JSONConfiguration(String) | Creates an isntance of the new configuration and reads contents from a JSON file
Back to Top
See Also
JSONConfiguration Class
JSONConfiguration Members
NFX.Environment Namespace


JSONConfiguration Constructor

JSONConfiguration Constructor NFX Class Library

Creates an instance of a new configuration not bound to any JSON file

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONConfiguration()
public JSONConfiguration()
Public Sub New
Public Sub New
public:
JSONConfiguration()
public:
JSONConfiguration()
new : unit -> JSONConfiguration
new : unit -> JSONConfiguration
See Also
JSONConfiguration Class
JSONConfiguration Members
JSONConfiguration Overload
NFX.Environment Namespace


JSONConfiguration Constructor (String)

JSONConfiguration Constructor (String) NFX Class Library

Creates an isntance of the new configuration and reads contents from a JSON file

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONConfiguration(
    string filename
)
public JSONConfiguration(
    string filename
)
Public Sub New (
    filename As String
)
Public Sub New (
    filename As String
)
public:
JSONConfiguration(
    String^ filename
)
public:
JSONConfiguration(
    String^ filename
)
new :
        filename : string -> JSONConfiguration
new :
        filename : string -> JSONConfiguration

Parameters

filename
Type: Online System String
See Also
JSONConfiguration Class
JSONConfiguration Members
JSONConfiguration Overload
NFX.Environment Namespace


JSONConfiguration Fields

JSONConfiguration Fields NFX Class Library

The JSONConfiguration type exposes the following members.
Fields
 | Name | Description
Protected field | m_EmptyAttrNode | (Inherited from Configuration.)
Protected field | m_EmptySectionNode | (Inherited from Configuration.)
Protected field | m_FileName | (Inherited from FileConfiguration.)
Protected field | m_Root | (Inherited from Configuration.)
 | SECTION_VALUE_ATTR |
Back to Top
See Also
JSONConfiguration Class
NFX.Environment Namespace


JSONConfiguration.SECTION_VALUE_ATTR Field

JSONConfiguration SECTION_VALUE_ATTR Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SECTION_VALUE_ATTR
public const string SECTION_VALUE_ATTR
Public Const SECTION_VALUE_ATTR As String
Public Const SECTION_VALUE_ATTR As String
public:
literal String^ SECTION_VALUE_ATTR
public:
literal String^ SECTION_VALUE_ATTR
static val mutable SECTION_VALUE_ATTR: string
static val mutable SECTION_VALUE_ATTR: string

Field Value

Type: Online String
See Also
JSONConfiguration Class
JSONConfiguration Members
NFX.Environment Namespace


JSONConfiguration Methods

JSONConfiguration Methods NFX Class Library

The JSONConfiguration type exposes the following members.
Methods
 | Name | Description
Protected method | AdjustNodeName | Override to perform transforms on node names so they become suitable for particular configuration type (Inherited from Configuration.)
Public method | CheckAndAdjustNodeName | Checks node name for aptitude for particular configuration type. For example, XML configuration does not allow nodes with spaces or separator chars. When StrictNames is set to true and value is not appropriate then exception is thrown (Inherited from Configuration.)
Public method | Clone(Configuration) | Creates a deep copy of this configuration into newInstance which was allocated externally (Inherited from Configuration.)
Public method | Clone T | Creates a deep copy of this configuration into new instance of T (Inherited from Configuration.)
Public method | Create | Creates new configuration - creates new configuration root with optional name parameter (Inherited from Configuration.)
 | CreateFromJSON | Creates an instance of configuration initialized from JSON content passed as string
Public method | CreateFromMerge | Creates new configuration from ordered merge result of two other nodes - base and override which can be from different configurations (Inherited from Configuration.)
Public method | CreateFromNode | Creates new configuration from other node, which may belong to a different configuration instance (Inherited from Configuration.)
Public method | Destroy | Erases all config data (Inherited from Configuration.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Include | Completely replaces this node with another node tree, positioning the new tree in the place of local node. Existing node is deleted after this operation completes, in its place child nodes from other node are inserted preserving their existing order. Attributes of other node get merged into parent of existing node (Inherited from Configuration.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Refresh | (Overrides Configuration Refresh .)
Public method | ResolveEnvironmentVar | Resolves variable name into its value (Inherited from Configuration.)
Public method | RunMacro | Runs macro and returns its value (Inherited from Configuration.)
Public method | Save | (Overrides Configuration Save .)
Public method | SaveAs(String) | Saves configuration into a JSON file (Overrides FileConfiguration SaveAs(String).)
Public method | SaveAs(String, JSONWritingOptions, Encoding) | Saves configuration into a JSON file
Public method | SaveToString | Saves JSON configuration to string
Public method | SetReadOnly | (Inherited from FileConfiguration.)
Public method | ToConfigurationJSONDataMap | Returns this config as JSON data map suitable for making JSONConfiguration (Inherited from Configuration.)
Public method | ToLaconicFile | Serializes configuration tree into Laconic format and writes it into a file (Inherited from Configuration.)
Public method | ToLaconicStream | Serializes configuration tree into Laconic format and writes it into stream (Inherited from Configuration.)
Public method | ToLaconicString | Serializes configuration tree into Laconic format and returns it as a string (Inherited from Configuration.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
JSONConfiguration Class
NFX.Environment Namespace


JSONConfiguration.CreateFromJSON Method

JSONConfiguration CreateFromJSON Method NFX Class Library

Creates an instance of configuration initialized from JSON content passed as string

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static JSONConfiguration CreateFromJSON(
    string content
)
public static JSONConfiguration CreateFromJSON(
    string content
)
Public Shared Function CreateFromJSON (
    content As String
) As JSONConfiguration
Public Shared Function CreateFromJSON (
    content As String
) As JSONConfiguration
public:
static JSONConfiguration^ CreateFromJSON(
    String^ content
)
public:
static JSONConfiguration^ CreateFromJSON(
    String^ content
)
static member CreateFromJSON :
        content : string -> JSONConfiguration
static member CreateFromJSON :
        content : string -> JSONConfiguration

Parameters

content
Type: Online System String

Return Value

Type: JSONConfiguration
See Also
JSONConfiguration Class
JSONConfiguration Members
NFX.Environment Namespace


JSONConfiguration.Refresh Method

JSONConfiguration Refresh Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Refresh()
public override void Refresh()
Public Overrides Sub Refresh
Public Overrides Sub Refresh
public:
virtual void Refresh() override
public:
virtual void Refresh() override
abstract Refresh : unit -> unit
override Refresh : unit -> unit
abstract Refresh : unit -> unit
override Refresh : unit -> unit
See Also
JSONConfiguration Class
JSONConfiguration Members
NFX.Environment Namespace


JSONConfiguration.Save Method

JSONConfiguration Save Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Save()
public override void Save()
Public Overrides Sub Save
Public Overrides Sub Save
public:
virtual void Save() override
public:
virtual void Save() override
abstract Save : unit -> unit
override Save : unit -> unit
abstract Save : unit -> unit
override Save : unit -> unit
See Also
JSONConfiguration Class
JSONConfiguration Members
NFX.Environment Namespace


JSONConfiguration.SaveAs Method

JSONConfiguration SaveAs Method NFX Class Library

Overload List
 | Name | Description
Public method | SaveAs(String) | Saves configuration into a JSON file (Overrides FileConfiguration SaveAs(String).)
Public method | SaveAs(String, JSONWritingOptions, Encoding) | Saves configuration into a JSON file
Back to Top
See Also
JSONConfiguration Class
JSONConfiguration Members
NFX.Environment Namespace


JSONConfiguration.SaveAs Method (String)

JSONConfiguration SaveAs Method (String) NFX Class Library

Saves configuration into a JSON file

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SaveAs(
    string filename
)
public override void SaveAs(
    string filename
)
Public Overrides Sub SaveAs (
    filename As String
)
Public Overrides Sub SaveAs (
    filename As String
)
public:
virtual void SaveAs(
    String^ filename
) override
public:
virtual void SaveAs(
    String^ filename
) override
abstract SaveAs :
        filename : string -> unit
override SaveAs :
        filename : string -> unit
abstract SaveAs :
        filename : string -> unit
override SaveAs :
        filename : string -> unit

Parameters

filename
Type: Online System String
See Also
JSONConfiguration Class
JSONConfiguration Members
SaveAs Overload
NFX.Environment Namespace


JSONConfiguration.SaveAs Method (String, JSONWritingOptions, Encoding)

JSONConfiguration SaveAs Method (String, JSONWritingOptions, Encoding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Saves configuration into a JSON file

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SaveAs(
    string filename,
    JSONWritingOptions options = null,
    Encoding encoding = null
)
public void SaveAs(
    string filename,
    JSONWritingOptions options = null,
    Encoding encoding = null
)
Public Sub SaveAs (
    filename As String,
    Optional options As JSONWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing
)
Public Sub SaveAs (
    filename As String,
    Optional options As JSONWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing
)
public:
void SaveAs(
    String^ filename,
    JSONWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr
)
public:
void SaveAs(
    String^ filename,
    JSONWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr
)
member SaveAs :
        filename : string *
        ?options : JSONWritingOptions *
        ?encoding : Encoding
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
*)
-> unit
member SaveAs :
        filename : string *
        ?options : JSONWritingOptions *
        ?encoding : Encoding
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
*)
-> unit

Parameters

filename
Type: Online System String
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions
encoding (Optional)
Type: Online System.Text Encoding
See Also
JSONConfiguration Class
JSONConfiguration Members
SaveAs Overload
NFX.Environment Namespace


JSONConfiguration.SaveToString Method

JSONConfiguration SaveToString Method NFX Class Library

Saves JSON configuration to string

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SaveToString(
    JSONWritingOptions options = null
)
public string SaveToString(
    JSONWritingOptions options = null
)
Public Function SaveToString (
    Optional options As JSONWritingOptions = Nothing
) As String
Public Function SaveToString (
    Optional options As JSONWritingOptions = Nothing
) As String
public:
String^ SaveToString(
    JSONWritingOptions^ options = nullptr
)
public:
String^ SaveToString(
    JSONWritingOptions^ options = nullptr
)
member SaveToString :
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> string
member SaveToString :
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> string

Parameters

options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Return Value

Type: Online String
See Also
JSONConfiguration Class
JSONConfiguration Members
NFX.Environment Namespace


JSONConfiguration.ToString Method

JSONConfiguration ToString Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
JSONConfiguration Class
JSONConfiguration Members
NFX.Environment Namespace


JSONConfiguration Properties

JSONConfiguration Properties NFX Class Library

The JSONConfiguration type exposes the following members.
Properties
 | Name | Description
Public property | ContentView | Primarily used for debugging - returns the content of the configuration as text in the pretty-printed Laconic format (Inherited from Configuration.)
Public property | EmptyAttr | References a special instance of an empty attribute node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist (Inherited from Configuration.)
Public property | EmptySection | References a special instance of an empty section node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist (Inherited from Configuration.)
Public property | EnvironmentVarResolver | References variable resolver. If this property is not set then default Windows environment var resolver is used (Inherited from Configuration.)
Public property | FileName | (Inherited from FileConfiguration.)
Public property | IsReadOnly | Indicates whether configuration is readonly or may be modified and saved (Inherited from FileConfiguration.)
Public property | MacroRunner | References macro runner. If this property is not set then default macro runner is used (Inherited from Configuration.)
Public property | MacroRunnerContext | Gets/sets an object passed by the framework into MacroRunner.Run() method. This property is auto-set for classes decorated with [ConfigMacroContext] attribute (Inherited from Configuration.)
Public property | Root | Accesses root section configuration node (Inherited from Configuration.)
Public property | StrictNames | Determines whether exception is thrown when configuration node name contains inappropriate chars for particular configuration type. For example, for XMLConfiguration node names may not have spaces and other separator chars. When StrictNames is false then particular configurations may replace incompatible chars in node names with neutral ones (i.e. "my value"->"my-value" in case of XMLConfiguration). (Inherited from Configuration.)
Public property | Variable_END | Variable end tag (Inherited from Configuration.)
Public property | Variable_ENV_MOD | Variable environment modifier (Inherited from Configuration.)
Public property | Variable_ESCAPE | Variable escape tag (Inherited from Configuration.)
Public property | Variable_MACRO_START | Variable get clause modifier (Inherited from Configuration.)
Public property | Variable_PATH_MOD | Variable path modifier (Inherited from Configuration.)
Public property | Variable_START | Variable start tag (Inherited from Configuration.)
Back to Top
See Also
JSONConfiguration Class
NFX.Environment Namespace


LaconicConfiguration Class

LaconicConfiguration Class NFX Class Library

Provides implementation of configuration based on Laconic content format
Inheritance Hierarchy
Online System Object
NFX.Environment Configuration
NFX.Environment FileConfiguration
NFX.Environment LaconicConfiguration

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class LaconicConfiguration : FileConfiguration
[SerializableAttribute]
public class LaconicConfiguration : FileConfiguration
<SerializableAttribute>
Public Class LaconicConfiguration
    Inherits FileConfiguration
<SerializableAttribute>
Public Class LaconicConfiguration
    Inherits FileConfiguration
[SerializableAttribute]
public ref class LaconicConfiguration : public FileConfiguration
[SerializableAttribute]
public ref class LaconicConfiguration : public FileConfiguration
[<SerializableAttribute>]
type LaconicConfiguration =
    class
        inherit FileConfiguration
    end
[<SerializableAttribute>]
type LaconicConfiguration =
    class
        inherit FileConfiguration
    end
Examples
Example Laconic Configuration Content: nfx //comments are allowed { log-root=$"c:\nfx\" log-csv="NFX.Log.Destinations.CSVFileDestination, NFX" debug-default-action="Log,Throw" log { name="Logger" destination { type=$(/$log-csv) name="WinFormsTest Log"//strings in dblquotes path=$(/$log-root) name-time-format='yyyyMMdd'//strings in snglquotes generate-failover-msg=false } } /* multiline comments data-store {type="NFX.RecordModel.DataAccess.MongoDB.MongoDBModelDataStore, NFX.MongoDB" connect-string="mongodb://localhost" db-name="test"} */ }
See Also
LaconicConfiguration Members
NFX.Environment Namespace


LaconicConfiguration Members

LaconicConfiguration Members NFX Class Library

The LaconicConfiguration type exposes the following members.
Constructors
 | Name | Description
Public method | LaconicConfiguration | Creates an instance of a new configuration not bound to any laconfig file
Public method | LaconicConfiguration(String) | Creates an isntance of the new configuration and reads contents from a laconfig file
Back to Top
Methods
 | Name | Description
Protected method | AdjustNodeName | Override to perform transforms on node names so they become suitable for particular configuration type (Inherited from Configuration.)
Public method | CheckAndAdjustNodeName | Checks node name for aptitude for particular configuration type. For example, XML configuration does not allow nodes with spaces or separator chars. When StrictNames is set to true and value is not appropriate then exception is thrown (Inherited from Configuration.)
Public method | Clone(Configuration) | Creates a deep copy of this configuration into newInstance which was allocated externally (Inherited from Configuration.)
Public method | Clone T | Creates a deep copy of this configuration into new instance of T (Inherited from Configuration.)
Public method | Create | Creates new configuration - creates new configuration root with optional name parameter (Inherited from Configuration.)
Public method | CreateFromMerge | Creates new configuration from ordered merge result of two other nodes - base and override which can be from different configurations (Inherited from Configuration.)
Public method | CreateFromNode | Creates new configuration from other node, which may belong to a different configuration instance (Inherited from Configuration.)
 | CreateFromString | Creates an instance of configuration initialized from laconfig passed as string
Public method | Destroy | Erases all config data (Inherited from Configuration.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Include | Completely replaces this node with another node tree, positioning the new tree in the place of local node. Existing node is deleted after this operation completes, in its place child nodes from other node are inserted preserving their existing order. Attributes of other node get merged into parent of existing node (Inherited from Configuration.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Refresh | (Overrides Configuration Refresh .)
Public method | ResolveEnvironmentVar | Resolves variable name into its value (Inherited from Configuration.)
Public method | RunMacro | Runs macro and returns its value (Inherited from Configuration.)
Public method | Save | (Overrides Configuration Save .)
Public method | SaveAs(String) | Saves configuration into a file (Overrides FileConfiguration SaveAs(String).)
Public method | SaveAs(String, LaconfigWritingOptions) | Saves configuration into a file
Public method | SaveToString | Saves laconic configuration into string in Laconfig format and returns it
Public method | SetReadOnly | (Inherited from FileConfiguration.)
Public method | ToConfigurationJSONDataMap | Returns this config as JSON data map suitable for making JSONConfiguration (Inherited from Configuration.)
Public method | ToLaconicFile | Serializes configuration tree into Laconic format and writes it into a file (Inherited from Configuration.)
Public method | ToLaconicStream | Serializes configuration tree into Laconic format and writes it into stream (Inherited from Configuration.)
Public method | ToLaconicString | Serializes configuration tree into Laconic format and returns it as a string (Inherited from Configuration.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_EmptyAttrNode | (Inherited from Configuration.)
Protected field | m_EmptySectionNode | (Inherited from Configuration.)
Protected field | m_FileName | (Inherited from FileConfiguration.)
Protected field | m_Root | (Inherited from Configuration.)
Back to Top
Properties
 | Name | Description
Public property | ContentView | Primarily used for debugging - returns the content of the configuration as text in the pretty-printed Laconic format (Inherited from Configuration.)
Public property | EmptyAttr | References a special instance of an empty attribute node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist (Inherited from Configuration.)
Public property | EmptySection | References a special instance of an empty section node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist (Inherited from Configuration.)
Public property | EnvironmentVarResolver | References variable resolver. If this property is not set then default Windows environment var resolver is used (Inherited from Configuration.)
Public property | FileName | (Inherited from FileConfiguration.)
Public property | IsReadOnly | Indicates whether configuration is readonly or may be modified and saved (Inherited from FileConfiguration.)
Public property | MacroRunner | References macro runner. If this property is not set then default macro runner is used (Inherited from Configuration.)
Public property | MacroRunnerContext | Gets/sets an object passed by the framework into MacroRunner.Run() method. This property is auto-set for classes decorated with [ConfigMacroContext] attribute (Inherited from Configuration.)
Public property | Root | Accesses root section configuration node (Inherited from Configuration.)
Public property | StrictNames | Determines whether exception is thrown when configuration node name contains inappropriate chars for particular configuration type. For example, for XMLConfiguration node names may not have spaces and other separator chars. When StrictNames is false then particular configurations may replace incompatible chars in node names with neutral ones (i.e. "my value"->"my-value" in case of XMLConfiguration). (Inherited from Configuration.)
Public property | Variable_END | Variable end tag (Inherited from Configuration.)
Public property | Variable_ENV_MOD | Variable environment modifier (Inherited from Configuration.)
Public property | Variable_ESCAPE | Variable escape tag (Inherited from Configuration.)
Public property | Variable_MACRO_START | Variable get clause modifier (Inherited from Configuration.)
Public property | Variable_PATH_MOD | Variable path modifier (Inherited from Configuration.)
Public property | Variable_START | Variable start tag (Inherited from Configuration.)
Back to Top
See Also
LaconicConfiguration Class
NFX.Environment Namespace


LaconicConfiguration Constructor

LaconicConfiguration Constructor NFX Class Library

Overload List
 | Name | Description
Public method | LaconicConfiguration | Creates an instance of a new configuration not bound to any laconfig file
Public method | LaconicConfiguration(String) | Creates an isntance of the new configuration and reads contents from a laconfig file
Back to Top
See Also
LaconicConfiguration Class
LaconicConfiguration Members
NFX.Environment Namespace


LaconicConfiguration Constructor

LaconicConfiguration Constructor NFX Class Library

Creates an instance of a new configuration not bound to any laconfig file

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LaconicConfiguration()
public LaconicConfiguration()
Public Sub New
Public Sub New
public:
LaconicConfiguration()
public:
LaconicConfiguration()
new : unit -> LaconicConfiguration
new : unit -> LaconicConfiguration
See Also
LaconicConfiguration Class
LaconicConfiguration Members
LaconicConfiguration Overload
NFX.Environment Namespace


LaconicConfiguration Constructor (String)

LaconicConfiguration Constructor (String) NFX Class Library

Creates an isntance of the new configuration and reads contents from a laconfig file

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LaconicConfiguration(
    string filename
)
public LaconicConfiguration(
    string filename
)
Public Sub New (
    filename As String
)
Public Sub New (
    filename As String
)
public:
LaconicConfiguration(
    String^ filename
)
public:
LaconicConfiguration(
    String^ filename
)
new :
        filename : string -> LaconicConfiguration
new :
        filename : string -> LaconicConfiguration

Parameters

filename
Type: Online System String
See Also
LaconicConfiguration Class
LaconicConfiguration Members
LaconicConfiguration Overload
NFX.Environment Namespace


LaconicConfiguration Fields

LaconicConfiguration Fields NFX Class Library

The LaconicConfiguration type exposes the following members.
Fields
 | Name | Description
Protected field | m_EmptyAttrNode | (Inherited from Configuration.)
Protected field | m_EmptySectionNode | (Inherited from Configuration.)
Protected field | m_FileName | (Inherited from FileConfiguration.)
Protected field | m_Root | (Inherited from Configuration.)
Back to Top
See Also
LaconicConfiguration Class
NFX.Environment Namespace


LaconicConfiguration Methods

LaconicConfiguration Methods NFX Class Library

The LaconicConfiguration type exposes the following members.
Methods
 | Name | Description
Protected method | AdjustNodeName | Override to perform transforms on node names so they become suitable for particular configuration type (Inherited from Configuration.)
Public method | CheckAndAdjustNodeName | Checks node name for aptitude for particular configuration type. For example, XML configuration does not allow nodes with spaces or separator chars. When StrictNames is set to true and value is not appropriate then exception is thrown (Inherited from Configuration.)
Public method | Clone(Configuration) | Creates a deep copy of this configuration into newInstance which was allocated externally (Inherited from Configuration.)
Public method | Clone T | Creates a deep copy of this configuration into new instance of T (Inherited from Configuration.)
Public method | Create | Creates new configuration - creates new configuration root with optional name parameter (Inherited from Configuration.)
Public method | CreateFromMerge | Creates new configuration from ordered merge result of two other nodes - base and override which can be from different configurations (Inherited from Configuration.)
Public method | CreateFromNode | Creates new configuration from other node, which may belong to a different configuration instance (Inherited from Configuration.)
 | CreateFromString | Creates an instance of configuration initialized from laconfig passed as string
Public method | Destroy | Erases all config data (Inherited from Configuration.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Include | Completely replaces this node with another node tree, positioning the new tree in the place of local node. Existing node is deleted after this operation completes, in its place child nodes from other node are inserted preserving their existing order. Attributes of other node get merged into parent of existing node (Inherited from Configuration.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Refresh | (Overrides Configuration Refresh .)
Public method | ResolveEnvironmentVar | Resolves variable name into its value (Inherited from Configuration.)
Public method | RunMacro | Runs macro and returns its value (Inherited from Configuration.)
Public method | Save | (Overrides Configuration Save .)
Public method | SaveAs(String) | Saves configuration into a file (Overrides FileConfiguration SaveAs(String).)
Public method | SaveAs(String, LaconfigWritingOptions) | Saves configuration into a file
Public method | SaveToString | Saves laconic configuration into string in Laconfig format and returns it
Public method | SetReadOnly | (Inherited from FileConfiguration.)
Public method | ToConfigurationJSONDataMap | Returns this config as JSON data map suitable for making JSONConfiguration (Inherited from Configuration.)
Public method | ToLaconicFile | Serializes configuration tree into Laconic format and writes it into a file (Inherited from Configuration.)
Public method | ToLaconicStream | Serializes configuration tree into Laconic format and writes it into stream (Inherited from Configuration.)
Public method | ToLaconicString | Serializes configuration tree into Laconic format and returns it as a string (Inherited from Configuration.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LaconicConfiguration Class
NFX.Environment Namespace


LaconicConfiguration.CreateFromString Method

LaconicConfiguration CreateFromString Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates an instance of configuration initialized from laconfig passed as string

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static LaconicConfiguration CreateFromString(
    string content
)
public static LaconicConfiguration CreateFromString(
    string content
)
Public Shared Function CreateFromString (
    content As String
) As LaconicConfiguration
Public Shared Function CreateFromString (
    content As String
) As LaconicConfiguration
public:
static LaconicConfiguration^ CreateFromString(
    String^ content
)
public:
static LaconicConfiguration^ CreateFromString(
    String^ content
)
static member CreateFromString :
        content : string -> LaconicConfiguration
static member CreateFromString :
        content : string -> LaconicConfiguration

Parameters

content
Type: Online System String

Return Value

Type: LaconicConfiguration
See Also
LaconicConfiguration Class
LaconicConfiguration Members
NFX.Environment Namespace


LaconicConfiguration.Refresh Method

LaconicConfiguration Refresh Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Refresh()
public override void Refresh()
Public Overrides Sub Refresh
Public Overrides Sub Refresh
public:
virtual void Refresh() override
public:
virtual void Refresh() override
abstract Refresh : unit -> unit
override Refresh : unit -> unit
abstract Refresh : unit -> unit
override Refresh : unit -> unit
See Also
LaconicConfiguration Class
LaconicConfiguration Members
NFX.Environment Namespace


LaconicConfiguration.Save Method

LaconicConfiguration Save Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Save()
public override void Save()
Public Overrides Sub Save
Public Overrides Sub Save
public:
virtual void Save() override
public:
virtual void Save() override
abstract Save : unit -> unit
override Save : unit -> unit
abstract Save : unit -> unit
override Save : unit -> unit
See Also
LaconicConfiguration Class
LaconicConfiguration Members
NFX.Environment Namespace


LaconicConfiguration.SaveAs Method

LaconicConfiguration SaveAs Method NFX Class Library

Overload List
 | Name | Description
Public method | SaveAs(String) | Saves configuration into a file (Overrides FileConfiguration SaveAs(String).)
Public method | SaveAs(String, LaconfigWritingOptions) | Saves configuration into a file
Back to Top
See Also
LaconicConfiguration Class
LaconicConfiguration Members
NFX.Environment Namespace


LaconicConfiguration.SaveAs Method (String)

LaconicConfiguration SaveAs Method (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Saves configuration into a file

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SaveAs(
    string filename
)
public override void SaveAs(
    string filename
)
Public Overrides Sub SaveAs (
    filename As String
)
Public Overrides Sub SaveAs (
    filename As String
)
public:
virtual void SaveAs(
    String^ filename
) override
public:
virtual void SaveAs(
    String^ filename
) override
abstract SaveAs :
        filename : string -> unit
override SaveAs :
        filename : string -> unit
abstract SaveAs :
        filename : string -> unit
override SaveAs :
        filename : string -> unit

Parameters

filename
Type: Online System String
See Also
LaconicConfiguration Class
LaconicConfiguration Members
SaveAs Overload
NFX.Environment Namespace


LaconicConfiguration.SaveAs Method (String, LaconfigWritingOptions)

LaconicConfiguration SaveAs Method (String, LaconfigWritingOptions) NFX Class Library

[This is preliminary documentation and is subject to change.]

Saves configuration into a file

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SaveAs(
    string filename,
    LaconfigWritingOptions options = null
)
public void SaveAs(
    string filename,
    LaconfigWritingOptions options = null
)
Public Sub SaveAs (
    filename As String,
    Optional options As LaconfigWritingOptions = Nothing
)
Public Sub SaveAs (
    filename As String,
    Optional options As LaconfigWritingOptions = Nothing
)
public:
void SaveAs(
    String^ filename,
    LaconfigWritingOptions^ options = nullptr
)
public:
void SaveAs(
    String^ filename,
    LaconfigWritingOptions^ options = nullptr
)
member SaveAs :
        filename : string *
        ?options : LaconfigWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
member SaveAs :
        filename : string *
        ?options : LaconfigWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

filename
Type: Online System String
options (Optional)
Type: NFX.CodeAnalysis.Laconfig LaconfigWritingOptions
See Also
LaconicConfiguration Class
LaconicConfiguration Members
SaveAs Overload
NFX.Environment Namespace


LaconicConfiguration.SaveToString Method

LaconicConfiguration SaveToString Method NFX Class Library

Saves laconic configuration into string in Laconfig format and returns it

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SaveToString(
    LaconfigWritingOptions options = null
)
public string SaveToString(
    LaconfigWritingOptions options = null
)
Public Function SaveToString (
    Optional options As LaconfigWritingOptions = Nothing
) As String
Public Function SaveToString (
    Optional options As LaconfigWritingOptions = Nothing
) As String
public:
String^ SaveToString(
    LaconfigWritingOptions^ options = nullptr
)
public:
String^ SaveToString(
    LaconfigWritingOptions^ options = nullptr
)
member SaveToString :
        ?options : LaconfigWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> string
member SaveToString :
        ?options : LaconfigWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> string

Parameters

options (Optional)
Type: NFX.CodeAnalysis.Laconfig LaconfigWritingOptions

Return Value

Type: Online String
See Also
LaconicConfiguration Class
LaconicConfiguration Members
NFX.Environment Namespace


LaconicConfiguration.ToString Method

LaconicConfiguration ToString Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
LaconicConfiguration Class
LaconicConfiguration Members
NFX.Environment Namespace


LaconicConfiguration Properties

LaconicConfiguration Properties NFX Class Library

The LaconicConfiguration type exposes the following members.
Properties
 | Name | Description
Public property | ContentView | Primarily used for debugging - returns the content of the configuration as text in the pretty-printed Laconic format (Inherited from Configuration.)
Public property | EmptyAttr | References a special instance of an empty attribute node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist (Inherited from Configuration.)
Public property | EmptySection | References a special instance of an empty section node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist (Inherited from Configuration.)
Public property | EnvironmentVarResolver | References variable resolver. If this property is not set then default Windows environment var resolver is used (Inherited from Configuration.)
Public property | FileName | (Inherited from FileConfiguration.)
Public property | IsReadOnly | Indicates whether configuration is readonly or may be modified and saved (Inherited from FileConfiguration.)
Public property | MacroRunner | References macro runner. If this property is not set then default macro runner is used (Inherited from Configuration.)
Public property | MacroRunnerContext | Gets/sets an object passed by the framework into MacroRunner.Run() method. This property is auto-set for classes decorated with [ConfigMacroContext] attribute (Inherited from Configuration.)
Public property | Root | Accesses root section configuration node (Inherited from Configuration.)
Public property | StrictNames | Determines whether exception is thrown when configuration node name contains inappropriate chars for particular configuration type. For example, for XMLConfiguration node names may not have spaces and other separator chars. When StrictNames is false then particular configurations may replace incompatible chars in node names with neutral ones (i.e. "my value"->"my-value" in case of XMLConfiguration). (Inherited from Configuration.)
Public property | Variable_END | Variable end tag (Inherited from Configuration.)
Public property | Variable_ENV_MOD | Variable environment modifier (Inherited from Configuration.)
Public property | Variable_ESCAPE | Variable escape tag (Inherited from Configuration.)
Public property | Variable_MACRO_START | Variable get clause modifier (Inherited from Configuration.)
Public property | Variable_PATH_MOD | Variable path modifier (Inherited from Configuration.)
Public property | Variable_START | Variable start tag (Inherited from Configuration.)
Back to Top
See Also
LaconicConfiguration Class
NFX.Environment Namespace


MemoryConfiguration Class

MemoryConfiguration Class NFX Class Library

Implements configuration that can not be persisted/loaded anywhere - just stored in memory
Inheritance Hierarchy
Online System Object
NFX.Environment Configuration
NFX.Environment MemoryConfiguration

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class MemoryConfiguration : Configuration
[SerializableAttribute]
public sealed class MemoryConfiguration : Configuration
<SerializableAttribute>
Public NotInheritable Class MemoryConfiguration
    Inherits Configuration
<SerializableAttribute>
Public NotInheritable Class MemoryConfiguration
    Inherits Configuration
[SerializableAttribute]
public ref class MemoryConfiguration sealed : public Configuration
[SerializableAttribute]
public ref class MemoryConfiguration sealed : public Configuration
[<SealedAttribute>]
[<SerializableAttribute>]
type MemoryConfiguration =
    class
        inherit Configuration
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type MemoryConfiguration =
    class
        inherit Configuration
    end
See Also
MemoryConfiguration Members
NFX.Environment Namespace


MemoryConfiguration Members

MemoryConfiguration Members NFX Class Library

The MemoryConfiguration type exposes the following members.
Constructors
 | Name | Description
Public method | MemoryConfiguration | Initializes a new instance of the MemoryConfiguration class
Back to Top
Methods
 | Name | Description
Protected method | AdjustNodeName | Override to perform transforms on node names so they become suitable for particular configuration type (Inherited from Configuration.)
Public method | CheckAndAdjustNodeName | Checks node name for aptitude for particular configuration type. For example, XML configuration does not allow nodes with spaces or separator chars. When StrictNames is set to true and value is not appropriate then exception is thrown (Inherited from Configuration.)
Public method | Clone(Configuration) | Creates a deep copy of this configuration into newInstance which was allocated externally (Inherited from Configuration.)
Public method | Clone T | Creates a deep copy of this configuration into new instance of T (Inherited from Configuration.)
Public method | Create | Creates new configuration - creates new configuration root with optional name parameter (Inherited from Configuration.)
Public method | CreateFromMerge | Creates new configuration from ordered merge result of two other nodes - base and override which can be from different configurations (Inherited from Configuration.)
Public method | CreateFromNode | Creates new configuration from other node, which may belong to a different configuration instance (Inherited from Configuration.)
Public method | Destroy | Erases all config data (Inherited from Configuration.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Include | Completely replaces this node with another node tree, positioning the new tree in the place of local node. Existing node is deleted after this operation completes, in its place child nodes from other node are inserted preserving their existing order. Attributes of other node get merged into parent of existing node (Inherited from Configuration.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Refresh | Re-reads configuration from source (Inherited from Configuration.)
Public method | ResolveEnvironmentVar | Resolves variable name into its value (Inherited from Configuration.)
Public method | RunMacro | Runs macro and returns its value (Inherited from Configuration.)
Public method | Save | Saves configuration to source (Inherited from Configuration.)
Public method | ToConfigurationJSONDataMap | Returns this config as JSON data map suitable for making JSONConfiguration (Inherited from Configuration.)
Public method | ToLaconicFile | Serializes configuration tree into Laconic format and writes it into a file (Inherited from Configuration.)
Public method | ToLaconicStream | Serializes configuration tree into Laconic format and writes it into stream (Inherited from Configuration.)
Public method | ToLaconicString | Serializes configuration tree into Laconic format and returns it as a string (Inherited from Configuration.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_EmptyAttrNode | (Inherited from Configuration.)
Protected field | m_EmptySectionNode | (Inherited from Configuration.)
Protected field | m_Root | (Inherited from Configuration.)
Back to Top
Properties
 | Name | Description
Public property | ContentView | Primarily used for debugging - returns the content of the configuration as text in the pretty-printed Laconic format (Inherited from Configuration.)
Public property | EmptyAttr | References a special instance of an empty attribute node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist (Inherited from Configuration.)
Public property | EmptySection | References a special instance of an empty section node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist (Inherited from Configuration.)
Public property | EnvironmentVarResolver | References variable resolver. If this property is not set then default Windows environment var resolver is used (Inherited from Configuration.)
Public property | IsReadOnly | (Overrides Configuration IsReadOnly.)
Public property | MacroRunner | References macro runner. If this property is not set then default macro runner is used (Inherited from Configuration.)
Public property | MacroRunnerContext | Gets/sets an object passed by the framework into MacroRunner.Run() method. This property is auto-set for classes decorated with [ConfigMacroContext] attribute (Inherited from Configuration.)
Public property | Root | Accesses root section configuration node (Inherited from Configuration.)
Public property | StrictNames | Determines whether exception is thrown when configuration node name contains inappropriate chars for particular configuration type. For example, for XMLConfiguration node names may not have spaces and other separator chars. When StrictNames is false then particular configurations may replace incompatible chars in node names with neutral ones (i.e. "my value"->"my-value" in case of XMLConfiguration). (Inherited from Configuration.)
Public property | Variable_END | Variable end tag (Inherited from Configuration.)
Public property | Variable_ENV_MOD | Variable environment modifier (Inherited from Configuration.)
Public property | Variable_ESCAPE | Variable escape tag (Inherited from Configuration.)
Public property | Variable_MACRO_START | Variable get clause modifier (Inherited from Configuration.)
Public property | Variable_PATH_MOD | Variable path modifier (Inherited from Configuration.)
Public property | Variable_START | Variable start tag (Inherited from Configuration.)
Back to Top
See Also
MemoryConfiguration Class
NFX.Environment Namespace


MemoryConfiguration Constructor

MemoryConfiguration Constructor NFX Class Library

Initializes a new instance of the MemoryConfiguration class

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MemoryConfiguration()
public MemoryConfiguration()
Public Sub New
Public Sub New
public:
MemoryConfiguration()
public:
MemoryConfiguration()
new : unit -> MemoryConfiguration
new : unit -> MemoryConfiguration
See Also
MemoryConfiguration Class
MemoryConfiguration Members
NFX.Environment Namespace


MemoryConfiguration Fields

MemoryConfiguration Fields NFX Class Library

The MemoryConfiguration type exposes the following members.
Fields
 | Name | Description
Protected field | m_EmptyAttrNode | (Inherited from Configuration.)
Protected field | m_EmptySectionNode | (Inherited from Configuration.)
Protected field | m_Root | (Inherited from Configuration.)
Back to Top
See Also
MemoryConfiguration Class
NFX.Environment Namespace


MemoryConfiguration Methods

MemoryConfiguration Methods NFX Class Library

The MemoryConfiguration type exposes the following members.
Methods
 | Name | Description
Protected method | AdjustNodeName | Override to perform transforms on node names so they become suitable for particular configuration type (Inherited from Configuration.)
Public method | CheckAndAdjustNodeName | Checks node name for aptitude for particular configuration type. For example, XML configuration does not allow nodes with spaces or separator chars. When StrictNames is set to true and value is not appropriate then exception is thrown (Inherited from Configuration.)
Public method | Clone(Configuration) | Creates a deep copy of this configuration into newInstance which was allocated externally (Inherited from Configuration.)
Public method | Clone T | Creates a deep copy of this configuration into new instance of T (Inherited from Configuration.)
Public method | Create | Creates new configuration - creates new configuration root with optional name parameter (Inherited from Configuration.)
Public method | CreateFromMerge | Creates new configuration from ordered merge result of two other nodes - base and override which can be from different configurations (Inherited from Configuration.)
Public method | CreateFromNode | Creates new configuration from other node, which may belong to a different configuration instance (Inherited from Configuration.)
Public method | Destroy | Erases all config data (Inherited from Configuration.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Include | Completely replaces this node with another node tree, positioning the new tree in the place of local node. Existing node is deleted after this operation completes, in its place child nodes from other node are inserted preserving their existing order. Attributes of other node get merged into parent of existing node (Inherited from Configuration.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Refresh | Re-reads configuration from source (Inherited from Configuration.)
Public method | ResolveEnvironmentVar | Resolves variable name into its value (Inherited from Configuration.)
Public method | RunMacro | Runs macro and returns its value (Inherited from Configuration.)
Public method | Save | Saves configuration to source (Inherited from Configuration.)
Public method | ToConfigurationJSONDataMap | Returns this config as JSON data map suitable for making JSONConfiguration (Inherited from Configuration.)
Public method | ToLaconicFile | Serializes configuration tree into Laconic format and writes it into a file (Inherited from Configuration.)
Public method | ToLaconicStream | Serializes configuration tree into Laconic format and writes it into stream (Inherited from Configuration.)
Public method | ToLaconicString | Serializes configuration tree into Laconic format and returns it as a string (Inherited from Configuration.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MemoryConfiguration Class
NFX.Environment Namespace


MemoryConfiguration Properties

MemoryConfiguration Properties NFX Class Library

The MemoryConfiguration type exposes the following members.
Properties
 | Name | Description
Public property | ContentView | Primarily used for debugging - returns the content of the configuration as text in the pretty-printed Laconic format (Inherited from Configuration.)
Public property | EmptyAttr | References a special instance of an empty attribute node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist (Inherited from Configuration.)
Public property | EmptySection | References a special instance of an empty section node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist (Inherited from Configuration.)
Public property | EnvironmentVarResolver | References variable resolver. If this property is not set then default Windows environment var resolver is used (Inherited from Configuration.)
Public property | IsReadOnly | (Overrides Configuration IsReadOnly.)
Public property | MacroRunner | References macro runner. If this property is not set then default macro runner is used (Inherited from Configuration.)
Public property | MacroRunnerContext | Gets/sets an object passed by the framework into MacroRunner.Run() method. This property is auto-set for classes decorated with [ConfigMacroContext] attribute (Inherited from Configuration.)
Public property | Root | Accesses root section configuration node (Inherited from Configuration.)
Public property | StrictNames | Determines whether exception is thrown when configuration node name contains inappropriate chars for particular configuration type. For example, for XMLConfiguration node names may not have spaces and other separator chars. When StrictNames is false then particular configurations may replace incompatible chars in node names with neutral ones (i.e. "my value"->"my-value" in case of XMLConfiguration). (Inherited from Configuration.)
Public property | Variable_END | Variable end tag (Inherited from Configuration.)
Public property | Variable_ENV_MOD | Variable environment modifier (Inherited from Configuration.)
Public property | Variable_ESCAPE | Variable escape tag (Inherited from Configuration.)
Public property | Variable_MACRO_START | Variable get clause modifier (Inherited from Configuration.)
Public property | Variable_PATH_MOD | Variable path modifier (Inherited from Configuration.)
Public property | Variable_START | Variable start tag (Inherited from Configuration.)
Back to Top
See Also
MemoryConfiguration Class
NFX.Environment Namespace


MemoryConfiguration.IsReadOnly Property

MemoryConfiguration IsReadOnly Property NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsReadOnly { get; }
public override bool IsReadOnly { get; }
Public Overrides ReadOnly Property IsReadOnly As Boolean
    Get
Public Overrides ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get () override;
}
public:
virtual property bool IsReadOnly {
    bool get () override;
}
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get

Property Value

Type: Online Boolean
See Also
MemoryConfiguration Class
MemoryConfiguration Members
NFX.Environment Namespace


NodeOverrideRules Class

NodeOverrideRules Class NFX Class Library

Contains node override rule definitions such as override specifier names and values. This class is used for merging/override of configurations/nodes
Inheritance Hierarchy
Online System Object
NFX.Environment NodeOverrideRules

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class NodeOverrideRules
public sealed class NodeOverrideRules
Public NotInheritable Class NodeOverrideRules
Public NotInheritable Class NodeOverrideRules
public ref class NodeOverrideRules sealed
public ref class NodeOverrideRules sealed
[<SealedAttribute>]
type NodeOverrideRules =  class end
[<SealedAttribute>]
type NodeOverrideRules =  class end
See Also
NodeOverrideRules Members
NFX.Environment Namespace


NodeOverrideRules Members

NodeOverrideRules Members NFX Class Library

The NodeOverrideRules type exposes the following members.
Constructors
 | Name | Description
Public method | NodeOverrideRules | Initializes a new instance of the NodeOverrideRules class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | StringToOverrideSpec | Tries to convert a string to OverrideSpec enum. If string is null or empty then "All" is returned, otherwise exception is thrown if the value does not match any of the expected values. The comparison is case-insensitive
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
DEFAULT_ATTRIBUTE_CLEAR_NAME |
DEFAULT_OVERRIDE_ATTR_NAME |
DEFAULT_OVERRIDE_VALUE_ALL |
DEFAULT_OVERRIDE_VALUE_ATTRIBUTES |
DEFAULT_OVERRIDE_VALUE_FAIL |
DEFAULT_OVERRIDE_VALUE_REPLACE |
DEFAULT_OVERRIDE_VALUE_SECTIONS |
DEFAULT_OVERRIDE_VALUE_STOP |
DEFAULT_SECTION_CLEAR_NAME |
DEFAULT_SECTION_DELETE_NAME |
DEFAULT_SECTION_MATCH_ATTR_NAME |
Back to Top
Properties
 | Name | Description
Public property | AppendSectionsWithoutMatchAttr | When true will APPEND sections not having SectionMatchAttrName defined, otherwise matches section names by SectionMatchAttrName
Public property | AttributeClearName | Provides a name for clear section - when present it deletes all existing attributes
 | Default | Default instance that uses default names
Public property | OverrideAttrName | Provides name for override attribute
Public property | OverrideValue_All | Provides value for all(sections and attributes) override
Public property | OverrideValue_Attributes | Provides value for attributes-only override
Public property | OverrideValue_Fail | Provides value for fail override - an exception is thrown when a child tries to override this section
Public property | OverrideValue_Replace | Provides value for replace override - when overriding section replaces base completely
Public property | OverrideValue_Sections | Provides value for sections-only override
Public property | OverrideValue_Stop | Provides value for stop override - so no section can modify anything in this one
Public property | SectionClearName | Provides a name for clear section - when present it deletes all existing subsections
Public property | SectionDeleteName | Provides a name for clear section - when present it deletes all existing attributes
Public property | SectionMatchAttrName | Provides attribute name for matching of multiple sections with the same name, i.e. a logger may have many 'destinations' subnodes each with different 'name' attribute
Back to Top
See Also
NodeOverrideRules Class
NFX.Environment Namespace


NodeOverrideRules Constructor

NodeOverrideRules Constructor NFX Class Library

Initializes a new instance of the NodeOverrideRules class

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NodeOverrideRules()
public NodeOverrideRules()
Public Sub New
Public Sub New
public:
NodeOverrideRules()
public:
NodeOverrideRules()
new : unit -> NodeOverrideRules
new : unit -> NodeOverrideRules
See Also
NodeOverrideRules Class
NodeOverrideRules Members
NFX.Environment Namespace


NodeOverrideRules Fields

NodeOverrideRules Fields NFX Class Library

The NodeOverrideRules type exposes the following members.
Fields
Name | Description
DEFAULT_ATTRIBUTE_CLEAR_NAME |
DEFAULT_OVERRIDE_ATTR_NAME |
DEFAULT_OVERRIDE_VALUE_ALL |
DEFAULT_OVERRIDE_VALUE_ATTRIBUTES |
DEFAULT_OVERRIDE_VALUE_FAIL |
DEFAULT_OVERRIDE_VALUE_REPLACE |
DEFAULT_OVERRIDE_VALUE_SECTIONS |
DEFAULT_OVERRIDE_VALUE_STOP |
DEFAULT_SECTION_CLEAR_NAME |
DEFAULT_SECTION_DELETE_NAME |
DEFAULT_SECTION_MATCH_ATTR_NAME |
Back to Top
See Also
NodeOverrideRules Class
NFX.Environment Namespace


NodeOverrideRules.DEFAULT_ATTRIBUTE_CLEAR_NAME Field

NodeOverrideRules DEFAULT_ATTRIBUTE_CLEAR_NAME Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_ATTRIBUTE_CLEAR_NAME
public const string DEFAULT_ATTRIBUTE_CLEAR_NAME
Public Const DEFAULT_ATTRIBUTE_CLEAR_NAME As String
Public Const DEFAULT_ATTRIBUTE_CLEAR_NAME As String
public:
literal String^ DEFAULT_ATTRIBUTE_CLEAR_NAME
public:
literal String^ DEFAULT_ATTRIBUTE_CLEAR_NAME
static val mutable DEFAULT_ATTRIBUTE_CLEAR_NAME: string
static val mutable DEFAULT_ATTRIBUTE_CLEAR_NAME: string

Field Value

Type: Online String
See Also
NodeOverrideRules Class
NodeOverrideRules Members
NFX.Environment Namespace


NodeOverrideRules.DEFAULT_OVERRIDE_ATTR_NAME Field

NodeOverrideRules DEFAULT_OVERRIDE_ATTR_NAME Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_OVERRIDE_ATTR_NAME
public const string DEFAULT_OVERRIDE_ATTR_NAME
Public Const DEFAULT_OVERRIDE_ATTR_NAME As String
Public Const DEFAULT_OVERRIDE_ATTR_NAME As String
public:
literal String^ DEFAULT_OVERRIDE_ATTR_NAME
public:
literal String^ DEFAULT_OVERRIDE_ATTR_NAME
static val mutable DEFAULT_OVERRIDE_ATTR_NAME: string
static val mutable DEFAULT_OVERRIDE_ATTR_NAME: string

Field Value

Type: Online String
See Also
NodeOverrideRules Class
NodeOverrideRules Members
NFX.Environment Namespace


NodeOverrideRules.DEFAULT_OVERRIDE_VALUE_ALL Field

NodeOverrideRules DEFAULT_OVERRIDE_VALUE_ALL Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_OVERRIDE_VALUE_ALL
public const string DEFAULT_OVERRIDE_VALUE_ALL
Public Const DEFAULT_OVERRIDE_VALUE_ALL As String
Public Const DEFAULT_OVERRIDE_VALUE_ALL As String
public:
literal String^ DEFAULT_OVERRIDE_VALUE_ALL
public:
literal String^ DEFAULT_OVERRIDE_VALUE_ALL
static val mutable DEFAULT_OVERRIDE_VALUE_ALL: string
static val mutable DEFAULT_OVERRIDE_VALUE_ALL: string

Field Value

Type: Online String
See Also
NodeOverrideRules Class
NodeOverrideRules Members
NFX.Environment Namespace


NodeOverrideRules.DEFAULT_OVERRIDE_VALUE_ATTRIBUTES Field

NodeOverrideRules DEFAULT_OVERRIDE_VALUE_ATTRIBUTES Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_OVERRIDE_VALUE_ATTRIBUTES
public const string DEFAULT_OVERRIDE_VALUE_ATTRIBUTES
Public Const DEFAULT_OVERRIDE_VALUE_ATTRIBUTES As String
Public Const DEFAULT_OVERRIDE_VALUE_ATTRIBUTES As String
public:
literal String^ DEFAULT_OVERRIDE_VALUE_ATTRIBUTES
public:
literal String^ DEFAULT_OVERRIDE_VALUE_ATTRIBUTES
static val mutable DEFAULT_OVERRIDE_VALUE_ATTRIBUTES: string
static val mutable DEFAULT_OVERRIDE_VALUE_ATTRIBUTES: string

Field Value

Type: Online String
See Also
NodeOverrideRules Class
NodeOverrideRules Members
NFX.Environment Namespace


NodeOverrideRules.DEFAULT_OVERRIDE_VALUE_FAIL Field

NodeOverrideRules DEFAULT_OVERRIDE_VALUE_FAIL Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_OVERRIDE_VALUE_FAIL
public const string DEFAULT_OVERRIDE_VALUE_FAIL
Public Const DEFAULT_OVERRIDE_VALUE_FAIL As String
Public Const DEFAULT_OVERRIDE_VALUE_FAIL As String
public:
literal String^ DEFAULT_OVERRIDE_VALUE_FAIL
public:
literal String^ DEFAULT_OVERRIDE_VALUE_FAIL
static val mutable DEFAULT_OVERRIDE_VALUE_FAIL: string
static val mutable DEFAULT_OVERRIDE_VALUE_FAIL: string

Field Value

Type: Online String
See Also
NodeOverrideRules Class
NodeOverrideRules Members
NFX.Environment Namespace


NodeOverrideRules.DEFAULT_OVERRIDE_VALUE_REPLACE Field

NodeOverrideRules DEFAULT_OVERRIDE_VALUE_REPLACE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_OVERRIDE_VALUE_REPLACE
public const string DEFAULT_OVERRIDE_VALUE_REPLACE
Public Const DEFAULT_OVERRIDE_VALUE_REPLACE As String
Public Const DEFAULT_OVERRIDE_VALUE_REPLACE As String
public:
literal String^ DEFAULT_OVERRIDE_VALUE_REPLACE
public:
literal String^ DEFAULT_OVERRIDE_VALUE_REPLACE
static val mutable DEFAULT_OVERRIDE_VALUE_REPLACE: string
static val mutable DEFAULT_OVERRIDE_VALUE_REPLACE: string

Field Value

Type: Online String
See Also
NodeOverrideRules Class
NodeOverrideRules Members
NFX.Environment Namespace


NodeOverrideRules.DEFAULT_OVERRIDE_VALUE_SECTIONS Field

NodeOverrideRules DEFAULT_OVERRIDE_VALUE_SECTIONS Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_OVERRIDE_VALUE_SECTIONS
public const string DEFAULT_OVERRIDE_VALUE_SECTIONS
Public Const DEFAULT_OVERRIDE_VALUE_SECTIONS As String
Public Const DEFAULT_OVERRIDE_VALUE_SECTIONS As String
public:
literal String^ DEFAULT_OVERRIDE_VALUE_SECTIONS
public:
literal String^ DEFAULT_OVERRIDE_VALUE_SECTIONS
static val mutable DEFAULT_OVERRIDE_VALUE_SECTIONS: string
static val mutable DEFAULT_OVERRIDE_VALUE_SECTIONS: string

Field Value

Type: Online String
See Also
NodeOverrideRules Class
NodeOverrideRules Members
NFX.Environment Namespace


NodeOverrideRules.DEFAULT_OVERRIDE_VALUE_STOP Field

NodeOverrideRules DEFAULT_OVERRIDE_VALUE_STOP Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_OVERRIDE_VALUE_STOP
public const string DEFAULT_OVERRIDE_VALUE_STOP
Public Const DEFAULT_OVERRIDE_VALUE_STOP As String
Public Const DEFAULT_OVERRIDE_VALUE_STOP As String
public:
literal String^ DEFAULT_OVERRIDE_VALUE_STOP
public:
literal String^ DEFAULT_OVERRIDE_VALUE_STOP
static val mutable DEFAULT_OVERRIDE_VALUE_STOP: string
static val mutable DEFAULT_OVERRIDE_VALUE_STOP: string

Field Value

Type: Online String
See Also
NodeOverrideRules Class
NodeOverrideRules Members
NFX.Environment Namespace


NodeOverrideRules.DEFAULT_SECTION_CLEAR_NAME Field

NodeOverrideRules DEFAULT_SECTION_CLEAR_NAME Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_SECTION_CLEAR_NAME
public const string DEFAULT_SECTION_CLEAR_NAME
Public Const DEFAULT_SECTION_CLEAR_NAME As String
Public Const DEFAULT_SECTION_CLEAR_NAME As String
public:
literal String^ DEFAULT_SECTION_CLEAR_NAME
public:
literal String^ DEFAULT_SECTION_CLEAR_NAME
static val mutable DEFAULT_SECTION_CLEAR_NAME: string
static val mutable DEFAULT_SECTION_CLEAR_NAME: string

Field Value

Type: Online String
See Also
NodeOverrideRules Class
NodeOverrideRules Members
NFX.Environment Namespace


NodeOverrideRules.DEFAULT_SECTION_DELETE_NAME Field

NodeOverrideRules DEFAULT_SECTION_DELETE_NAME Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_SECTION_DELETE_NAME
public const string DEFAULT_SECTION_DELETE_NAME
Public Const DEFAULT_SECTION_DELETE_NAME As String
Public Const DEFAULT_SECTION_DELETE_NAME As String
public:
literal String^ DEFAULT_SECTION_DELETE_NAME
public:
literal String^ DEFAULT_SECTION_DELETE_NAME
static val mutable DEFAULT_SECTION_DELETE_NAME: string
static val mutable DEFAULT_SECTION_DELETE_NAME: string

Field Value

Type: Online String
See Also
NodeOverrideRules Class
NodeOverrideRules Members
NFX.Environment Namespace


NodeOverrideRules.DEFAULT_SECTION_MATCH_ATTR_NAME Field

NodeOverrideRules DEFAULT_SECTION_MATCH_ATTR_NAME Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_SECTION_MATCH_ATTR_NAME
public const string DEFAULT_SECTION_MATCH_ATTR_NAME
Public Const DEFAULT_SECTION_MATCH_ATTR_NAME As String
Public Const DEFAULT_SECTION_MATCH_ATTR_NAME As String
public:
literal String^ DEFAULT_SECTION_MATCH_ATTR_NAME
public:
literal String^ DEFAULT_SECTION_MATCH_ATTR_NAME
static val mutable DEFAULT_SECTION_MATCH_ATTR_NAME: string
static val mutable DEFAULT_SECTION_MATCH_ATTR_NAME: string

Field Value

Type: Online String
See Also
NodeOverrideRules Class
NodeOverrideRules Members
NFX.Environment Namespace


NodeOverrideRules Methods

NodeOverrideRules Methods NFX Class Library

The NodeOverrideRules type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | StringToOverrideSpec | Tries to convert a string to OverrideSpec enum. If string is null or empty then "All" is returned, otherwise exception is thrown if the value does not match any of the expected values. The comparison is case-insensitive
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NodeOverrideRules Class
NFX.Environment Namespace


NodeOverrideRules.StringToOverrideSpec Method

NodeOverrideRules StringToOverrideSpec Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Tries to convert a string to OverrideSpec enum. If string is null or empty then "All" is returned, otherwise exception is thrown if the value does not match any of the expected values. The comparison is case-insensitive

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OverrideSpec StringToOverrideSpec(
    string str
)
public OverrideSpec StringToOverrideSpec(
    string str
)
Public Function StringToOverrideSpec (
    str As String
) As OverrideSpec
Public Function StringToOverrideSpec (
    str As String
) As OverrideSpec
public:
OverrideSpec StringToOverrideSpec(
    String^ str
)
public:
OverrideSpec StringToOverrideSpec(
    String^ str
)
member StringToOverrideSpec :
        str : string -> OverrideSpec
member StringToOverrideSpec :
        str : string -> OverrideSpec

Parameters

str
Type: Online System String

Return Value

Type: OverrideSpec
See Also
NodeOverrideRules Class
NodeOverrideRules Members
NFX.Environment Namespace


NodeOverrideRules Properties

NodeOverrideRules Properties NFX Class Library

The NodeOverrideRules type exposes the following members.
Properties
 | Name | Description
Public property | AppendSectionsWithoutMatchAttr | When true will APPEND sections not having SectionMatchAttrName defined, otherwise matches section names by SectionMatchAttrName
Public property | AttributeClearName | Provides a name for clear section - when present it deletes all existing attributes
 | Default | Default instance that uses default names
Public property | OverrideAttrName | Provides name for override attribute
Public property | OverrideValue_All | Provides value for all(sections and attributes) override
Public property | OverrideValue_Attributes | Provides value for attributes-only override
Public property | OverrideValue_Fail | Provides value for fail override - an exception is thrown when a child tries to override this section
Public property | OverrideValue_Replace | Provides value for replace override - when overriding section replaces base completely
Public property | OverrideValue_Sections | Provides value for sections-only override
Public property | OverrideValue_Stop | Provides value for stop override - so no section can modify anything in this one
Public property | SectionClearName | Provides a name for clear section - when present it deletes all existing subsections
Public property | SectionDeleteName | Provides a name for clear section - when present it deletes all existing attributes
Public property | SectionMatchAttrName | Provides attribute name for matching of multiple sections with the same name, i.e. a logger may have many 'destinations' subnodes each with different 'name' attribute
Back to Top
See Also
NodeOverrideRules Class
NFX.Environment Namespace


NodeOverrideRules.AppendSectionsWithoutMatchAttr Property

NodeOverrideRules AppendSectionsWithoutMatchAttr Property NFX Class Library

[This is preliminary documentation and is subject to change.]

When true will APPEND sections not having SectionMatchAttrName defined, otherwise matches section names by SectionMatchAttrName

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool AppendSectionsWithoutMatchAttr { get; set; }
public bool AppendSectionsWithoutMatchAttr { get; set; }
Public Property AppendSectionsWithoutMatchAttr As Boolean
    Get
    Set
Public Property AppendSectionsWithoutMatchAttr As Boolean
    Get
    Set
public:
property bool AppendSectionsWithoutMatchAttr {
    bool get ();
    void set (bool value);
}
public:
property bool AppendSectionsWithoutMatchAttr {
    bool get ();
    void set (bool value);
}
member AppendSectionsWithoutMatchAttr : bool with get, set
member AppendSectionsWithoutMatchAttr : bool with get, set

Property Value

Type: Online Boolean
See Also
NodeOverrideRules Class
NodeOverrideRules Members
NFX.Environment Namespace


NodeOverrideRules.AttributeClearName Property

NodeOverrideRules AttributeClearName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Provides a name for clear section - when present it deletes all existing attributes

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AttributeClearName { get; set; }
public string AttributeClearName { get; set; }
Public Property AttributeClearName As String
    Get
    Set
Public Property AttributeClearName As String
    Get
    Set
public:
property String^ AttributeClearName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ AttributeClearName {
    String^ get ();
    void set (String^ value);
}
member AttributeClearName : string with get, set
member AttributeClearName : string with get, set

Property Value

Type: Online String
See Also
NodeOverrideRules Class
NodeOverrideRules Members
NFX.Environment Namespace


NodeOverrideRules.Default Property

NodeOverrideRules Default Property NFX Class Library

Default instance that uses default names

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NodeOverrideRules Default { get; }
public static NodeOverrideRules Default { get; }
Public Shared ReadOnly Property Default As NodeOverrideRules
    Get
Public Shared ReadOnly Property Default As NodeOverrideRules
    Get
public:
static property NodeOverrideRules^ Default {
    NodeOverrideRules^ get ();
}
public:
static property NodeOverrideRules^ Default {
    NodeOverrideRules^ get ();
}
static member Default : NodeOverrideRules with get
static member Default : NodeOverrideRules with get

Property Value

Type: NodeOverrideRules
See Also
NodeOverrideRules Class
NodeOverrideRules Members
NFX.Environment Namespace


NodeOverrideRules.OverrideAttrName Property

NodeOverrideRules OverrideAttrName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Provides name for override attribute

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string OverrideAttrName { get; set; }
public string OverrideAttrName { get; set; }
Public Property OverrideAttrName As String
    Get
    Set
Public Property OverrideAttrName As String
    Get
    Set
public:
property String^ OverrideAttrName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OverrideAttrName {
    String^ get ();
    void set (String^ value);
}
member OverrideAttrName : string with get, set
member OverrideAttrName : string with get, set

Property Value

Type: Online String
See Also
NodeOverrideRules Class
NodeOverrideRules Members
NFX.Environment Namespace


NodeOverrideRules.OverrideValue_All Property

NodeOverrideRules OverrideValue_All Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Provides value for all(sections and attributes) override

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string OverrideValue_All { get; set; }
public string OverrideValue_All { get; set; }
Public Property OverrideValue_All As String
    Get
    Set
Public Property OverrideValue_All As String
    Get
    Set
public:
property String^ OverrideValue_All {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OverrideValue_All {
    String^ get ();
    void set (String^ value);
}
member OverrideValue_All : string with get, set
member OverrideValue_All : string with get, set

Property Value

Type: Online String
See Also
NodeOverrideRules Class
NodeOverrideRules Members
NFX.Environment Namespace


NodeOverrideRules.OverrideValue_Attributes Property

NodeOverrideRules OverrideValue_Attributes Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Provides value for attributes-only override

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string OverrideValue_Attributes { get; set; }
public string OverrideValue_Attributes { get; set; }
Public Property OverrideValue_Attributes As String
    Get
    Set
Public Property OverrideValue_Attributes As String
    Get
    Set
public:
property String^ OverrideValue_Attributes {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OverrideValue_Attributes {
    String^ get ();
    void set (String^ value);
}
member OverrideValue_Attributes : string with get, set
member OverrideValue_Attributes : string with get, set

Property Value

Type: Online String
See Also
NodeOverrideRules Class
NodeOverrideRules Members
NFX.Environment Namespace


NodeOverrideRules.OverrideValue_Fail Property

NodeOverrideRules OverrideValue_Fail Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Provides value for fail override - an exception is thrown when a child tries to override this section

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string OverrideValue_Fail { get; set; }
public string OverrideValue_Fail { get; set; }
Public Property OverrideValue_Fail As String
    Get
    Set
Public Property OverrideValue_Fail As String
    Get
    Set
public:
property String^ OverrideValue_Fail {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OverrideValue_Fail {
    String^ get ();
    void set (String^ value);
}
member OverrideValue_Fail : string with get, set
member OverrideValue_Fail : string with get, set

Property Value

Type: Online String
See Also
NodeOverrideRules Class
NodeOverrideRules Members
NFX.Environment Namespace


NodeOverrideRules.OverrideValue_Replace Property

NodeOverrideRules OverrideValue_Replace Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Provides value for replace override - when overriding section replaces base completely

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string OverrideValue_Replace { get; set; }
public string OverrideValue_Replace { get; set; }
Public Property OverrideValue_Replace As String
    Get
    Set
Public Property OverrideValue_Replace As String
    Get
    Set
public:
property String^ OverrideValue_Replace {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OverrideValue_Replace {
    String^ get ();
    void set (String^ value);
}
member OverrideValue_Replace : string with get, set
member OverrideValue_Replace : string with get, set

Property Value

Type: Online String
See Also
NodeOverrideRules Class
NodeOverrideRules Members
NFX.Environment Namespace


NodeOverrideRules.OverrideValue_Sections Property

NodeOverrideRules OverrideValue_Sections Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Provides value for sections-only override

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string OverrideValue_Sections { get; set; }
public string OverrideValue_Sections { get; set; }
Public Property OverrideValue_Sections As String
    Get
    Set
Public Property OverrideValue_Sections As String
    Get
    Set
public:
property String^ OverrideValue_Sections {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OverrideValue_Sections {
    String^ get ();
    void set (String^ value);
}
member OverrideValue_Sections : string with get, set
member OverrideValue_Sections : string with get, set

Property Value

Type: Online String
See Also
NodeOverrideRules Class
NodeOverrideRules Members
NFX.Environment Namespace


NodeOverrideRules.OverrideValue_Stop Property

NodeOverrideRules OverrideValue_Stop Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Provides value for stop override - so no section can modify anything in this one

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string OverrideValue_Stop { get; set; }
public string OverrideValue_Stop { get; set; }
Public Property OverrideValue_Stop As String
    Get
    Set
Public Property OverrideValue_Stop As String
    Get
    Set
public:
property String^ OverrideValue_Stop {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OverrideValue_Stop {
    String^ get ();
    void set (String^ value);
}
member OverrideValue_Stop : string with get, set
member OverrideValue_Stop : string with get, set

Property Value

Type: Online String
See Also
NodeOverrideRules Class
NodeOverrideRules Members
NFX.Environment Namespace


NodeOverrideRules.SectionClearName Property

NodeOverrideRules SectionClearName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Provides a name for clear section - when present it deletes all existing subsections

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SectionClearName { get; set; }
public string SectionClearName { get; set; }
Public Property SectionClearName As String
    Get
    Set
Public Property SectionClearName As String
    Get
    Set
public:
property String^ SectionClearName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ SectionClearName {
    String^ get ();
    void set (String^ value);
}
member SectionClearName : string with get, set
member SectionClearName : string with get, set

Property Value

Type: Online String
See Also
NodeOverrideRules Class
NodeOverrideRules Members
NFX.Environment Namespace


NodeOverrideRules.SectionDeleteName Property

NodeOverrideRules SectionDeleteName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Provides a name for clear section - when present it deletes all existing attributes

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SectionDeleteName { get; set; }
public string SectionDeleteName { get; set; }
Public Property SectionDeleteName As String
    Get
    Set
Public Property SectionDeleteName As String
    Get
    Set
public:
property String^ SectionDeleteName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ SectionDeleteName {
    String^ get ();
    void set (String^ value);
}
member SectionDeleteName : string with get, set
member SectionDeleteName : string with get, set

Property Value

Type: Online String
See Also
NodeOverrideRules Class
NodeOverrideRules Members
NFX.Environment Namespace


NodeOverrideRules.SectionMatchAttrName Property

NodeOverrideRules SectionMatchAttrName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Provides attribute name for matching of multiple sections with the same name, i.e. a logger may have many 'destinations' subnodes each with different 'name' attribute

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SectionMatchAttrName { get; set; }
public string SectionMatchAttrName { get; set; }
Public Property SectionMatchAttrName As String
    Get
    Set
Public Property SectionMatchAttrName As String
    Get
    Set
public:
property String^ SectionMatchAttrName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ SectionMatchAttrName {
    String^ get ();
    void set (String^ value);
}
member SectionMatchAttrName : string with get, set
member SectionMatchAttrName : string with get, set

Property Value

Type: Online String
See Also
NodeOverrideRules Class
NodeOverrideRules Members
NFX.Environment Namespace


OverrideSpec Enumeration

OverrideSpec Enumeration NFX Class Library

Override specifications that dictate what to do when another node supplies entity with the same name

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum OverrideSpec
public enum OverrideSpec
Public Enumeration OverrideSpec
Public Enumeration OverrideSpec
public enum class OverrideSpec
public enum class OverrideSpec
type OverrideSpec
type OverrideSpec
Members
Member name | Value | Description
All | 0 | Override everything: attributes, sections, and value
Attributes | 1 | Ovveride attributes only
Sections | 2 | Override sections only
Replace | 3 | Completely replace node
Stop | 4 | Stop override at this level
Fail | 5 | Fail the process
See Also
NFX.Environment Namespace


ScriptRunner Class

ScriptRunner Class NFX Class Library

Executes configuration scripts which are embedded in configuration
Inheritance Hierarchy
Online System Object
NFX.Environment ScriptRunner

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ScriptRunner : IConfigurable
public class ScriptRunner : IConfigurable
Public Class ScriptRunner
    Implements IConfigurable
Public Class ScriptRunner
    Implements IConfigurable
public ref class ScriptRunner : IConfigurable
public ref class ScriptRunner : IConfigurable
type ScriptRunner =
    class
        interface IConfigurable
    end
type ScriptRunner =
    class
        interface IConfigurable
    end
See Also
ScriptRunner Members
NFX.Environment Namespace


ScriptRunner Members

ScriptRunner Members NFX Class Library

The ScriptRunner type exposes the following members.
Constructors
 | Name | Description
Public method | ScriptRunner | Initializes a new instance of the ScriptRunner class
Back to Top
Methods
 | Name | Description
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Execute | Runs script on the configuration
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_SCRIPT_RUNNER_PATH |
CONFIG_SCRIPT_RUNNER_SECTION |
CONFIG_TIMEOUT_ATTR |
DEFAULT_KEYWORD_BLOCK |
DEFAULT_KEYWORD_CALL |
DEFAULT_KEYWORD_ELSE |
DEFAULT_KEYWORD_IF |
DEFAULT_KEYWORD_LOOP |
DEFAULT_KEYWORD_SET |
DEFAULT_SCRIPT_ONLY_ATTR |
DEFAULT_TIMEOUT_MS |
Back to Top
Properties
 | Name | Description
Public property | AttributeScriptOnly | Gets/sets attribute name that indicates that marked entity should not be brough over into script output target
Public property | KeywordBLOCK | Gets/sets BLOCK keyword - used for unconditional script evaluation block
Public property | KeywordCALL | Gets/sets CALL keyword - used for sub-routine invocation
Public property | KeywordELSE | Gets/sets ELSE keyword - used for IF-complementary conditional block
Public property | KeywordIF | Gets/sets IF keyword - used for conditional block
Public property | KeywordLOOP | Gets/sets LOOP keyword - used for repetition block
Public property | KeywordSET | Gets/sets SET keyword - used for variable assignment statement
Public property | TimeoutMs | Gets/sets script execution timeout
Back to Top
See Also
ScriptRunner Class
NFX.Environment Namespace


ScriptRunner Constructor

ScriptRunner Constructor NFX Class Library

Initializes a new instance of the ScriptRunner class

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ScriptRunner()
public ScriptRunner()
Public Sub New
Public Sub New
public:
ScriptRunner()
public:
ScriptRunner()
new : unit -> ScriptRunner
new : unit -> ScriptRunner
See Also
ScriptRunner Class
ScriptRunner Members
NFX.Environment Namespace


ScriptRunner Fields

ScriptRunner Fields NFX Class Library

The ScriptRunner type exposes the following members.
Fields
Name | Description
CONFIG_SCRIPT_RUNNER_PATH |
CONFIG_SCRIPT_RUNNER_SECTION |
CONFIG_TIMEOUT_ATTR |
DEFAULT_KEYWORD_BLOCK |
DEFAULT_KEYWORD_CALL |
DEFAULT_KEYWORD_ELSE |
DEFAULT_KEYWORD_IF |
DEFAULT_KEYWORD_LOOP |
DEFAULT_KEYWORD_SET |
DEFAULT_SCRIPT_ONLY_ATTR |
DEFAULT_TIMEOUT_MS |
Back to Top
See Also
ScriptRunner Class
NFX.Environment Namespace


ScriptRunner.CONFIG_SCRIPT_RUNNER_PATH Field

ScriptRunner CONFIG_SCRIPT_RUNNER_PATH Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SCRIPT_RUNNER_PATH
public const string CONFIG_SCRIPT_RUNNER_PATH
Public Const CONFIG_SCRIPT_RUNNER_PATH As String
Public Const CONFIG_SCRIPT_RUNNER_PATH As String
public:
literal String^ CONFIG_SCRIPT_RUNNER_PATH
public:
literal String^ CONFIG_SCRIPT_RUNNER_PATH
static val mutable CONFIG_SCRIPT_RUNNER_PATH: string
static val mutable CONFIG_SCRIPT_RUNNER_PATH: string

Field Value

Type: Online String
See Also
ScriptRunner Class
ScriptRunner Members
NFX.Environment Namespace


ScriptRunner.CONFIG_SCRIPT_RUNNER_SECTION Field

ScriptRunner CONFIG_SCRIPT_RUNNER_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SCRIPT_RUNNER_SECTION
public const string CONFIG_SCRIPT_RUNNER_SECTION
Public Const CONFIG_SCRIPT_RUNNER_SECTION As String
Public Const CONFIG_SCRIPT_RUNNER_SECTION As String
public:
literal String^ CONFIG_SCRIPT_RUNNER_SECTION
public:
literal String^ CONFIG_SCRIPT_RUNNER_SECTION
static val mutable CONFIG_SCRIPT_RUNNER_SECTION: string
static val mutable CONFIG_SCRIPT_RUNNER_SECTION: string

Field Value

Type: Online String
See Also
ScriptRunner Class
ScriptRunner Members
NFX.Environment Namespace


ScriptRunner.CONFIG_TIMEOUT_ATTR Field

ScriptRunner CONFIG_TIMEOUT_ATTR Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_TIMEOUT_ATTR
public const string CONFIG_TIMEOUT_ATTR
Public Const CONFIG_TIMEOUT_ATTR As String
Public Const CONFIG_TIMEOUT_ATTR As String
public:
literal String^ CONFIG_TIMEOUT_ATTR
public:
literal String^ CONFIG_TIMEOUT_ATTR
static val mutable CONFIG_TIMEOUT_ATTR: string
static val mutable CONFIG_TIMEOUT_ATTR: string

Field Value

Type: Online String
See Also
ScriptRunner Class
ScriptRunner Members
NFX.Environment Namespace


ScriptRunner.DEFAULT_KEYWORD_BLOCK Field

ScriptRunner DEFAULT_KEYWORD_BLOCK Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_KEYWORD_BLOCK
public const string DEFAULT_KEYWORD_BLOCK
Public Const DEFAULT_KEYWORD_BLOCK As String
Public Const DEFAULT_KEYWORD_BLOCK As String
public:
literal String^ DEFAULT_KEYWORD_BLOCK
public:
literal String^ DEFAULT_KEYWORD_BLOCK
static val mutable DEFAULT_KEYWORD_BLOCK: string
static val mutable DEFAULT_KEYWORD_BLOCK: string

Field Value

Type: Online String
See Also
ScriptRunner Class
ScriptRunner Members
NFX.Environment Namespace


ScriptRunner.DEFAULT_KEYWORD_CALL Field

ScriptRunner DEFAULT_KEYWORD_CALL Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_KEYWORD_CALL
public const string DEFAULT_KEYWORD_CALL
Public Const DEFAULT_KEYWORD_CALL As String
Public Const DEFAULT_KEYWORD_CALL As String
public:
literal String^ DEFAULT_KEYWORD_CALL
public:
literal String^ DEFAULT_KEYWORD_CALL
static val mutable DEFAULT_KEYWORD_CALL: string
static val mutable DEFAULT_KEYWORD_CALL: string

Field Value

Type: Online String
See Also
ScriptRunner Class
ScriptRunner Members
NFX.Environment Namespace


ScriptRunner.DEFAULT_KEYWORD_ELSE Field

ScriptRunner DEFAULT_KEYWORD_ELSE Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_KEYWORD_ELSE
public const string DEFAULT_KEYWORD_ELSE
Public Const DEFAULT_KEYWORD_ELSE As String
Public Const DEFAULT_KEYWORD_ELSE As String
public:
literal String^ DEFAULT_KEYWORD_ELSE
public:
literal String^ DEFAULT_KEYWORD_ELSE
static val mutable DEFAULT_KEYWORD_ELSE: string
static val mutable DEFAULT_KEYWORD_ELSE: string

Field Value

Type: Online String
See Also
ScriptRunner Class
ScriptRunner Members
NFX.Environment Namespace


ScriptRunner.DEFAULT_KEYWORD_IF Field

ScriptRunner DEFAULT_KEYWORD_IF Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_KEYWORD_IF
public const string DEFAULT_KEYWORD_IF
Public Const DEFAULT_KEYWORD_IF As String
Public Const DEFAULT_KEYWORD_IF As String
public:
literal String^ DEFAULT_KEYWORD_IF
public:
literal String^ DEFAULT_KEYWORD_IF
static val mutable DEFAULT_KEYWORD_IF: string
static val mutable DEFAULT_KEYWORD_IF: string

Field Value

Type: Online String
See Also
ScriptRunner Class
ScriptRunner Members
NFX.Environment Namespace


ScriptRunner.DEFAULT_KEYWORD_LOOP Field

ScriptRunner DEFAULT_KEYWORD_LOOP Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_KEYWORD_LOOP
public const string DEFAULT_KEYWORD_LOOP
Public Const DEFAULT_KEYWORD_LOOP As String
Public Const DEFAULT_KEYWORD_LOOP As String
public:
literal String^ DEFAULT_KEYWORD_LOOP
public:
literal String^ DEFAULT_KEYWORD_LOOP
static val mutable DEFAULT_KEYWORD_LOOP: string
static val mutable DEFAULT_KEYWORD_LOOP: string

Field Value

Type: Online String
See Also
ScriptRunner Class
ScriptRunner Members
NFX.Environment Namespace


ScriptRunner.DEFAULT_KEYWORD_SET Field

ScriptRunner DEFAULT_KEYWORD_SET Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_KEYWORD_SET
public const string DEFAULT_KEYWORD_SET
Public Const DEFAULT_KEYWORD_SET As String
Public Const DEFAULT_KEYWORD_SET As String
public:
literal String^ DEFAULT_KEYWORD_SET
public:
literal String^ DEFAULT_KEYWORD_SET
static val mutable DEFAULT_KEYWORD_SET: string
static val mutable DEFAULT_KEYWORD_SET: string

Field Value

Type: Online String
See Also
ScriptRunner Class
ScriptRunner Members
NFX.Environment Namespace


ScriptRunner.DEFAULT_SCRIPT_ONLY_ATTR Field

ScriptRunner DEFAULT_SCRIPT_ONLY_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_SCRIPT_ONLY_ATTR
public const string DEFAULT_SCRIPT_ONLY_ATTR
Public Const DEFAULT_SCRIPT_ONLY_ATTR As String
Public Const DEFAULT_SCRIPT_ONLY_ATTR As String
public:
literal String^ DEFAULT_SCRIPT_ONLY_ATTR
public:
literal String^ DEFAULT_SCRIPT_ONLY_ATTR
static val mutable DEFAULT_SCRIPT_ONLY_ATTR: string
static val mutable DEFAULT_SCRIPT_ONLY_ATTR: string

Field Value

Type: Online String
See Also
ScriptRunner Class
ScriptRunner Members
NFX.Environment Namespace


ScriptRunner.DEFAULT_TIMEOUT_MS Field

ScriptRunner DEFAULT_TIMEOUT_MS Field NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_TIMEOUT_MS
public const int DEFAULT_TIMEOUT_MS
Public Const DEFAULT_TIMEOUT_MS As Integer
Public Const DEFAULT_TIMEOUT_MS As Integer
public:
literal int DEFAULT_TIMEOUT_MS
public:
literal int DEFAULT_TIMEOUT_MS
static val mutable DEFAULT_TIMEOUT_MS: int
static val mutable DEFAULT_TIMEOUT_MS: int

Field Value

Type: Online Int32
See Also
ScriptRunner Class
ScriptRunner Members
NFX.Environment Namespace


ScriptRunner Methods

ScriptRunner Methods NFX Class Library

The ScriptRunner type exposes the following members.
Methods
 | Name | Description
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Execute | Runs script on the configuration
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ScriptRunner Class
NFX.Environment Namespace


ScriptRunner.Configure Method

ScriptRunner Configure Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode node
)
public void Configure(
    IConfigSectionNode node
)
Public Sub Configure (
    node As IConfigSectionNode
)
Public Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
ScriptRunner Class
ScriptRunner Members
NFX.Environment Namespace


ScriptRunner.Execute Method

ScriptRunner Execute Method NFX Class Library

Runs script on the configuration

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Execute(
    Configuration source,
    Configuration target
)
public void Execute(
    Configuration source,
    Configuration target
)
Public Sub Execute (
    source As Configuration,
    target As Configuration
)
Public Sub Execute (
    source As Configuration,
    target As Configuration
)
public:
void Execute(
    Configuration^ source,
    Configuration^ target
)
public:
void Execute(
    Configuration^ source,
    Configuration^ target
)
member Execute :
        source : Configuration *
        target : Configuration -> unit
member Execute :
        source : Configuration *
        target : Configuration -> unit

Parameters

source
Type: NFX.Environment Configuration
target
Type: NFX.Environment Configuration
See Also
ScriptRunner Class
ScriptRunner Members
NFX.Environment Namespace


ScriptRunner Properties

ScriptRunner Properties NFX Class Library

The ScriptRunner type exposes the following members.
Properties
 | Name | Description
Public property | AttributeScriptOnly | Gets/sets attribute name that indicates that marked entity should not be brough over into script output target
Public property | KeywordBLOCK | Gets/sets BLOCK keyword - used for unconditional script evaluation block
Public property | KeywordCALL | Gets/sets CALL keyword - used for sub-routine invocation
Public property | KeywordELSE | Gets/sets ELSE keyword - used for IF-complementary conditional block
Public property | KeywordIF | Gets/sets IF keyword - used for conditional block
Public property | KeywordLOOP | Gets/sets LOOP keyword - used for repetition block
Public property | KeywordSET | Gets/sets SET keyword - used for variable assignment statement
Public property | TimeoutMs | Gets/sets script execution timeout
Back to Top
See Also
ScriptRunner Class
NFX.Environment Namespace


ScriptRunner.AttributeScriptOnly Property

ScriptRunner AttributeScriptOnly Property NFX Class Library

Gets/sets attribute name that indicates that marked entity should not be brough over into script output target

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AttributeScriptOnly { get; set; }
public string AttributeScriptOnly { get; set; }
Public Property AttributeScriptOnly As String
    Get
    Set
Public Property AttributeScriptOnly As String
    Get
    Set
public:
property String^ AttributeScriptOnly {
    String^ get ();
    void set (String^ value);
}
public:
property String^ AttributeScriptOnly {
    String^ get ();
    void set (String^ value);
}
member AttributeScriptOnly : string with get, set
member AttributeScriptOnly : string with get, set

Property Value

Type: Online String
See Also
ScriptRunner Class
ScriptRunner Members
NFX.Environment Namespace


ScriptRunner.KeywordBLOCK Property

ScriptRunner KeywordBLOCK Property NFX Class Library

Gets/sets BLOCK keyword - used for unconditional script evaluation block

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string KeywordBLOCK { get; set; }
public string KeywordBLOCK { get; set; }
Public Property KeywordBLOCK As String
    Get
    Set
Public Property KeywordBLOCK As String
    Get
    Set
public:
property String^ KeywordBLOCK {
    String^ get ();
    void set (String^ value);
}
public:
property String^ KeywordBLOCK {
    String^ get ();
    void set (String^ value);
}
member KeywordBLOCK : string with get, set
member KeywordBLOCK : string with get, set

Property Value

Type: Online String
See Also
ScriptRunner Class
ScriptRunner Members
NFX.Environment Namespace


ScriptRunner.KeywordCALL Property

ScriptRunner KeywordCALL Property NFX Class Library

Gets/sets CALL keyword - used for sub-routine invocation

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string KeywordCALL { get; set; }
public string KeywordCALL { get; set; }
Public Property KeywordCALL As String
    Get
    Set
Public Property KeywordCALL As String
    Get
    Set
public:
property String^ KeywordCALL {
    String^ get ();
    void set (String^ value);
}
public:
property String^ KeywordCALL {
    String^ get ();
    void set (String^ value);
}
member KeywordCALL : string with get, set
member KeywordCALL : string with get, set

Property Value

Type: Online String
See Also
ScriptRunner Class
ScriptRunner Members
NFX.Environment Namespace


ScriptRunner.KeywordELSE Property

ScriptRunner KeywordELSE Property NFX Class Library

Gets/sets ELSE keyword - used for IF-complementary conditional block

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string KeywordELSE { get; set; }
public string KeywordELSE { get; set; }
Public Property KeywordELSE As String
    Get
    Set
Public Property KeywordELSE As String
    Get
    Set
public:
property String^ KeywordELSE {
    String^ get ();
    void set (String^ value);
}
public:
property String^ KeywordELSE {
    String^ get ();
    void set (String^ value);
}
member KeywordELSE : string with get, set
member KeywordELSE : string with get, set

Property Value

Type: Online String
See Also
ScriptRunner Class
ScriptRunner Members
NFX.Environment Namespace


ScriptRunner.KeywordIF Property

ScriptRunner KeywordIF Property NFX Class Library

Gets/sets IF keyword - used for conditional block

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string KeywordIF { get; set; }
public string KeywordIF { get; set; }
Public Property KeywordIF As String
    Get
    Set
Public Property KeywordIF As String
    Get
    Set
public:
property String^ KeywordIF {
    String^ get ();
    void set (String^ value);
}
public:
property String^ KeywordIF {
    String^ get ();
    void set (String^ value);
}
member KeywordIF : string with get, set
member KeywordIF : string with get, set

Property Value

Type: Online String
See Also
ScriptRunner Class
ScriptRunner Members
NFX.Environment Namespace


ScriptRunner.KeywordLOOP Property

ScriptRunner KeywordLOOP Property NFX Class Library

Gets/sets LOOP keyword - used for repetition block

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string KeywordLOOP { get; set; }
public string KeywordLOOP { get; set; }
Public Property KeywordLOOP As String
    Get
    Set
Public Property KeywordLOOP As String
    Get
    Set
public:
property String^ KeywordLOOP {
    String^ get ();
    void set (String^ value);
}
public:
property String^ KeywordLOOP {
    String^ get ();
    void set (String^ value);
}
member KeywordLOOP : string with get, set
member KeywordLOOP : string with get, set

Property Value

Type: Online String
See Also
ScriptRunner Class
ScriptRunner Members
NFX.Environment Namespace


ScriptRunner.KeywordSET Property

ScriptRunner KeywordSET Property NFX Class Library

Gets/sets SET keyword - used for variable assignment statement

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string KeywordSET { get; set; }
public string KeywordSET { get; set; }
Public Property KeywordSET As String
    Get
    Set
Public Property KeywordSET As String
    Get
    Set
public:
property String^ KeywordSET {
    String^ get ();
    void set (String^ value);
}
public:
property String^ KeywordSET {
    String^ get ();
    void set (String^ value);
}
member KeywordSET : string with get, set
member KeywordSET : string with get, set

Property Value

Type: Online String
See Also
ScriptRunner Class
ScriptRunner Members
NFX.Environment Namespace


ScriptRunner.TimeoutMs Property

ScriptRunner TimeoutMs Property NFX Class Library

Gets/sets script execution timeout

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int TimeoutMs { get; set; }
public int TimeoutMs { get; set; }
Public Property TimeoutMs As Integer
    Get
    Set
Public Property TimeoutMs As Integer
    Get
    Set
public:
property int TimeoutMs {
    int get ();
    void set (int value);
}
public:
property int TimeoutMs {
    int get ();
    void set (int value);
}
member TimeoutMs : int with get, set
member TimeoutMs : int with get, set

Property Value

Type: Online Int32
See Also
ScriptRunner Class
ScriptRunner Members
NFX.Environment Namespace


Vars Class

Vars Class NFX Class Library

Allows for simple ad-hoc environment var passing to configuration
Inheritance Hierarchy
Online System Object
Online System.Collections.Generic Dictionary Online String, Online String
NFX.Environment Vars

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class Vars : Dictionary<string, string>,
    IEnvironmentVariableResolver
[SerializableAttribute]
public sealed class Vars : Dictionary<string, string>,
    IEnvironmentVariableResolver
<SerializableAttribute>
Public NotInheritable Class Vars
    Inherits Dictionary(Of String, String)
    Implements IEnvironmentVariableResolver
<SerializableAttribute>
Public NotInheritable Class Vars
    Inherits Dictionary(Of String, String)
    Implements IEnvironmentVariableResolver
[SerializableAttribute]
public ref class Vars sealed : public Dictionary<String^, String^>,
    IEnvironmentVariableResolver
[SerializableAttribute]
public ref class Vars sealed : public Dictionary<String^, String^>,
    IEnvironmentVariableResolver
[<SealedAttribute>]
[<SerializableAttribute>]
type Vars =
    class
        inherit Dictionary<string, string>
        interface IEnvironmentVariableResolver
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type Vars =
    class
        inherit Dictionary<string, string>
        interface IEnvironmentVariableResolver
    end
See Also
Vars Members
NFX.Environment Namespace


Vars Members

Vars Members NFX Class Library

The Vars type exposes the following members.
Constructors
 | Name | Description
Public method | Vars | Initializes a new instance of the Vars class
Back to Top
Methods
 | Name | Description
Public method | Online Add | (Inherited from Online Dictionary Online String, Online String .)
Public method | Online Clear | (Inherited from Online Dictionary Online String, Online String .)
Public method | Online ContainsKey | (Inherited from Online Dictionary Online String, Online String .)
Public method | Online ContainsValue | (Inherited from Online Dictionary Online String, Online String .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | (Inherited from Online Dictionary Online String, Online String .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online Dictionary TKey, TValue instance. (Inherited from Online Dictionary Online String, Online String .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online Dictionary Online String, Online String .)
Public method | Online Remove | (Inherited from Online Dictionary Online String, Online String .)
Public method | ResolveEnvironmentVariable |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TryGetValue | (Inherited from Online Dictionary Online String, Online String .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online Comparer | (Inherited from Online Dictionary Online String, Online String .)
Public property | Online Count | (Inherited from Online Dictionary Online String, Online String .)
Public property | Online Item | (Inherited from Online Dictionary Online String, Online String .)
Public property | Online Keys | (Inherited from Online Dictionary Online String, Online String .)
Public property | Online Values | (Inherited from Online Dictionary Online String, Online String .)
Back to Top
See Also
Vars Class
NFX.Environment Namespace


Vars Constructor

Vars Constructor NFX Class Library

Initializes a new instance of the Vars class

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Vars()
public Vars()
Public Sub New
Public Sub New
public:
Vars()
public:
Vars()
new : unit -> Vars
new : unit -> Vars
See Also
Vars Class
Vars Members
NFX.Environment Namespace


Vars Methods

Vars Methods NFX Class Library

The Vars type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | (Inherited from Online Dictionary Online String, Online String .)
Public method | Online Clear | (Inherited from Online Dictionary Online String, Online String .)
Public method | Online ContainsKey | (Inherited from Online Dictionary Online String, Online String .)
Public method | Online ContainsValue | (Inherited from Online Dictionary Online String, Online String .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | (Inherited from Online Dictionary Online String, Online String .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online Dictionary TKey, TValue instance. (Inherited from Online Dictionary Online String, Online String .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online Dictionary Online String, Online String .)
Public method | Online Remove | (Inherited from Online Dictionary Online String, Online String .)
Public method | ResolveEnvironmentVariable |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TryGetValue | (Inherited from Online Dictionary Online String, Online String .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Vars Class
NFX.Environment Namespace


Vars.ResolveEnvironmentVariable Method

Vars ResolveEnvironmentVariable Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ResolveEnvironmentVariable(
    string name
)
public string ResolveEnvironmentVariable(
    string name
)
Public Function ResolveEnvironmentVariable (
    name As String
) As String
Public Function ResolveEnvironmentVariable (
    name As String
) As String
public:
virtual String^ ResolveEnvironmentVariable(
    String^ name
) sealed
public:
virtual String^ ResolveEnvironmentVariable(
    String^ name
) sealed
abstract ResolveEnvironmentVariable :
        name : string -> string
override ResolveEnvironmentVariable :
        name : string -> string
abstract ResolveEnvironmentVariable :
        name : string -> string
override ResolveEnvironmentVariable :
        name : string -> string

Parameters

name
Type: Online System String

Return Value

Type: Online String

Implements

IEnvironmentVariableResolver ResolveEnvironmentVariable(String)
See Also
Vars Class
Vars Members
NFX.Environment Namespace


Vars Properties

Vars Properties NFX Class Library

The Vars type exposes the following members.
Properties
 | Name | Description
Public property | Online Comparer | (Inherited from Online Dictionary Online String, Online String .)
Public property | Online Count | (Inherited from Online Dictionary Online String, Online String .)
Public property | Online Item | (Inherited from Online Dictionary Online String, Online String .)
Public property | Online Keys | (Inherited from Online Dictionary Online String, Online String .)
Public property | Online Values | (Inherited from Online Dictionary Online String, Online String .)
Back to Top
See Also
Vars Class
NFX.Environment Namespace


WindowsEnvironmentVariableResolver Class

WindowsEnvironmentVariableResolver Class NFX Class Library

Resolves variables using Windows environment variables. NOTE: When serialized a new instance is created which will not equal by reference to static.Instance property
Inheritance Hierarchy
Online System Object
NFX.Environment WindowsEnvironmentVariableResolver

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class WindowsEnvironmentVariableResolver : IEnvironmentVariableResolver
[SerializableAttribute]
public sealed class WindowsEnvironmentVariableResolver : IEnvironmentVariableResolver
<SerializableAttribute>
Public NotInheritable Class WindowsEnvironmentVariableResolver
    Implements IEnvironmentVariableResolver
<SerializableAttribute>
Public NotInheritable Class WindowsEnvironmentVariableResolver
    Implements IEnvironmentVariableResolver
[SerializableAttribute]
public ref class WindowsEnvironmentVariableResolver sealed : IEnvironmentVariableResolver
[SerializableAttribute]
public ref class WindowsEnvironmentVariableResolver sealed : IEnvironmentVariableResolver
[<SealedAttribute>]
[<SerializableAttribute>]
type WindowsEnvironmentVariableResolver =
    class
        interface IEnvironmentVariableResolver
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type WindowsEnvironmentVariableResolver =
    class
        interface IEnvironmentVariableResolver
    end
See Also
WindowsEnvironmentVariableResolver Members
NFX.Environment Namespace


WindowsEnvironmentVariableResolver Members

WindowsEnvironmentVariableResolver Members NFX Class Library

The WindowsEnvironmentVariableResolver type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ResolveEnvironmentVariable |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
Name | Description
Instance | Returns a singleton class instance
Back to Top
See Also
WindowsEnvironmentVariableResolver Class
NFX.Environment Namespace


WindowsEnvironmentVariableResolver Methods

WindowsEnvironmentVariableResolver Methods NFX Class Library

The WindowsEnvironmentVariableResolver type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ResolveEnvironmentVariable |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WindowsEnvironmentVariableResolver Class
NFX.Environment Namespace


WindowsEnvironmentVariableResolver.ResolveEnvironmentVariable Method

WindowsEnvironmentVariableResolver ResolveEnvironmentVariable Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ResolveEnvironmentVariable(
    string name
)
public string ResolveEnvironmentVariable(
    string name
)
Public Function ResolveEnvironmentVariable (
    name As String
) As String
Public Function ResolveEnvironmentVariable (
    name As String
) As String
public:
virtual String^ ResolveEnvironmentVariable(
    String^ name
) sealed
public:
virtual String^ ResolveEnvironmentVariable(
    String^ name
) sealed
abstract ResolveEnvironmentVariable :
        name : string -> string
override ResolveEnvironmentVariable :
        name : string -> string
abstract ResolveEnvironmentVariable :
        name : string -> string
override ResolveEnvironmentVariable :
        name : string -> string

Parameters

name
Type: Online System String

Return Value

Type: Online String

Implements

IEnvironmentVariableResolver ResolveEnvironmentVariable(String)
See Also
WindowsEnvironmentVariableResolver Class
WindowsEnvironmentVariableResolver Members
NFX.Environment Namespace


WindowsEnvironmentVariableResolver Properties

WindowsEnvironmentVariableResolver Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The WindowsEnvironmentVariableResolver type exposes the following members.
Properties
Name | Description
Instance | Returns a singleton class instance
Back to Top
See Also
WindowsEnvironmentVariableResolver Class
NFX.Environment Namespace


WindowsEnvironmentVariableResolver.Instance Property

WindowsEnvironmentVariableResolver Instance Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns a singleton class instance

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static WindowsEnvironmentVariableResolver Instance { get; }
public static WindowsEnvironmentVariableResolver Instance { get; }
Public Shared ReadOnly Property Instance As WindowsEnvironmentVariableResolver
    Get
Public Shared ReadOnly Property Instance As WindowsEnvironmentVariableResolver
    Get
public:
static property WindowsEnvironmentVariableResolver^ Instance {
    WindowsEnvironmentVariableResolver^ get ();
}
public:
static property WindowsEnvironmentVariableResolver^ Instance {
    WindowsEnvironmentVariableResolver^ get ();
}
static member Instance : WindowsEnvironmentVariableResolver with get
static member Instance : WindowsEnvironmentVariableResolver with get

Property Value

Type: WindowsEnvironmentVariableResolver
See Also
WindowsEnvironmentVariableResolver Class
WindowsEnvironmentVariableResolver Members
NFX.Environment Namespace


XMLConfiguration Class

XMLConfiguration Class NFX Class Library

Provides implementation of configuration based on a classic XML content
Inheritance Hierarchy
Online System Object
NFX.Environment Configuration
NFX.Environment FileConfiguration
NFX.Environment XMLConfiguration

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class XMLConfiguration : FileConfiguration
[SerializableAttribute]
public class XMLConfiguration : FileConfiguration
<SerializableAttribute>
Public Class XMLConfiguration
    Inherits FileConfiguration
<SerializableAttribute>
Public Class XMLConfiguration
    Inherits FileConfiguration
[SerializableAttribute]
public ref class XMLConfiguration : public FileConfiguration
[SerializableAttribute]
public ref class XMLConfiguration : public FileConfiguration
[<SerializableAttribute>]
type XMLConfiguration =
    class
        inherit FileConfiguration
    end
[<SerializableAttribute>]
type XMLConfiguration =
    class
        inherit FileConfiguration
    end
See Also
XMLConfiguration Members
NFX.Environment Namespace


XMLConfiguration Members

XMLConfiguration Members NFX Class Library

The XMLConfiguration type exposes the following members.
Constructors
 | Name | Description
Public method | XMLConfiguration | Creates an instance of a new configuration not bound to any XML file
Public method | XMLConfiguration(String) | Creates an isntance of the new configuration and reads contents from an XML file
Back to Top
Methods
 | Name | Description
Protected method | AdjustNodeName | (Overrides Configuration AdjustNodeName(String).)
Public method | CheckAndAdjustNodeName | Checks node name for aptitude for particular configuration type. For example, XML configuration does not allow nodes with spaces or separator chars. When StrictNames is set to true and value is not appropriate then exception is thrown (Inherited from Configuration.)
Public method | Clone(Configuration) | Creates a deep copy of this configuration into newInstance which was allocated externally (Inherited from Configuration.)
Public method | Clone T | Creates a deep copy of this configuration into new instance of T (Inherited from Configuration.)
Public method | Create | Creates new configuration - creates new configuration root with optional name parameter (Inherited from Configuration.)
Public method | CreateFromMerge | Creates new configuration from ordered merge result of two other nodes - base and override which can be from different configurations (Inherited from Configuration.)
Public method | CreateFromNode | Creates new configuration from other node, which may belong to a different configuration instance (Inherited from Configuration.)
 | CreateFromXML | Creates an instance of configuration initialized from XML content passed as string
Public method | Destroy | Erases all config data (Inherited from Configuration.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Include | Completely replaces this node with another node tree, positioning the new tree in the place of local node. Existing node is deleted after this operation completes, in its place child nodes from other node are inserted preserving their existing order. Attributes of other node get merged into parent of existing node (Inherited from Configuration.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Refresh | (Overrides Configuration Refresh .)
Public method | ResolveEnvironmentVar | Resolves variable name into its value (Inherited from Configuration.)
Public method | RunMacro | Runs macro and returns its value (Inherited from Configuration.)
Public method | Save | (Overrides Configuration Save .)
Public method | SaveAs(String) | Saves configuration into a file (Overrides FileConfiguration SaveAs(String).)
Public method | SaveAs(String, String) | Saves configuration to a file with optional link to XSL file
Public method | SaveToString | Saves XML configuration with optional link to XSL file, into string and returns it
Public method | SetReadOnly | (Inherited from FileConfiguration.)
Public method | ToConfigurationJSONDataMap | Returns this config as JSON data map suitable for making JSONConfiguration (Inherited from Configuration.)
Public method | ToLaconicFile | Serializes configuration tree into Laconic format and writes it into a file (Inherited from Configuration.)
Public method | ToLaconicStream | Serializes configuration tree into Laconic format and writes it into stream (Inherited from Configuration.)
Public method | ToLaconicString | Serializes configuration tree into Laconic format and returns it as a string (Inherited from Configuration.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_EmptyAttrNode | (Inherited from Configuration.)
Protected field | m_EmptySectionNode | (Inherited from Configuration.)
Protected field | m_FileName | (Inherited from FileConfiguration.)
Protected field | m_Root | (Inherited from Configuration.)
Back to Top
Properties
 | Name | Description
Public property | ContentView | Primarily used for debugging - returns the content of the configuration as text in the pretty-printed Laconic format (Inherited from Configuration.)
Public property | EmptyAttr | References a special instance of an empty attribute node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist (Inherited from Configuration.)
Public property | EmptySection | References a special instance of an empty section node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist (Inherited from Configuration.)
Public property | EnvironmentVarResolver | References variable resolver. If this property is not set then default Windows environment var resolver is used (Inherited from Configuration.)
Public property | FileName | (Inherited from FileConfiguration.)
Public property | IsReadOnly | Indicates whether configuration is readonly or may be modified and saved (Inherited from FileConfiguration.)
Public property | MacroRunner | References macro runner. If this property is not set then default macro runner is used (Inherited from Configuration.)
Public property | MacroRunnerContext | Gets/sets an object passed by the framework into MacroRunner.Run() method. This property is auto-set for classes decorated with [ConfigMacroContext] attribute (Inherited from Configuration.)
Public property | Root | Accesses root section configuration node (Inherited from Configuration.)
Public property | StrictNames | Determines whether exception is thrown when configuration node name contains inappropriate chars for particular configuration type. For example, for XMLConfiguration node names may not have spaces and other separator chars. When StrictNames is false then particular configurations may replace incompatible chars in node names with neutral ones (i.e. "my value"->"my-value" in case of XMLConfiguration). (Inherited from Configuration.)
Public property | Variable_END | Variable end tag (Inherited from Configuration.)
Public property | Variable_ENV_MOD | Variable environment modifier (Inherited from Configuration.)
Public property | Variable_ESCAPE | Variable escape tag (Inherited from Configuration.)
Public property | Variable_MACRO_START | Variable get clause modifier (Inherited from Configuration.)
Public property | Variable_PATH_MOD | Variable path modifier (Inherited from Configuration.)
Public property | Variable_START | Variable start tag (Inherited from Configuration.)
Back to Top
See Also
XMLConfiguration Class
NFX.Environment Namespace


XMLConfiguration Constructor

XMLConfiguration Constructor NFX Class Library

Overload List
 | Name | Description
Public method | XMLConfiguration | Creates an instance of a new configuration not bound to any XML file
Public method | XMLConfiguration(String) | Creates an isntance of the new configuration and reads contents from an XML file
Back to Top
See Also
XMLConfiguration Class
XMLConfiguration Members
NFX.Environment Namespace


XMLConfiguration Constructor

XMLConfiguration Constructor NFX Class Library

Creates an instance of a new configuration not bound to any XML file

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public XMLConfiguration()
public XMLConfiguration()
Public Sub New
Public Sub New
public:
XMLConfiguration()
public:
XMLConfiguration()
new : unit -> XMLConfiguration
new : unit -> XMLConfiguration
See Also
XMLConfiguration Class
XMLConfiguration Members
XMLConfiguration Overload
NFX.Environment Namespace


XMLConfiguration Constructor (String)

XMLConfiguration Constructor (String) NFX Class Library

Creates an isntance of the new configuration and reads contents from an XML file

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public XMLConfiguration(
    string filename
)
public XMLConfiguration(
    string filename
)
Public Sub New (
    filename As String
)
Public Sub New (
    filename As String
)
public:
XMLConfiguration(
    String^ filename
)
public:
XMLConfiguration(
    String^ filename
)
new :
        filename : string -> XMLConfiguration
new :
        filename : string -> XMLConfiguration

Parameters

filename
Type: Online System String
See Also
XMLConfiguration Class
XMLConfiguration Members
XMLConfiguration Overload
NFX.Environment Namespace


XMLConfiguration Fields

XMLConfiguration Fields NFX Class Library

The XMLConfiguration type exposes the following members.
Fields
 | Name | Description
Protected field | m_EmptyAttrNode | (Inherited from Configuration.)
Protected field | m_EmptySectionNode | (Inherited from Configuration.)
Protected field | m_FileName | (Inherited from FileConfiguration.)
Protected field | m_Root | (Inherited from Configuration.)
Back to Top
See Also
XMLConfiguration Class
NFX.Environment Namespace


XMLConfiguration Methods

XMLConfiguration Methods NFX Class Library

The XMLConfiguration type exposes the following members.
Methods
 | Name | Description
Protected method | AdjustNodeName | (Overrides Configuration AdjustNodeName(String).)
Public method | CheckAndAdjustNodeName | Checks node name for aptitude for particular configuration type. For example, XML configuration does not allow nodes with spaces or separator chars. When StrictNames is set to true and value is not appropriate then exception is thrown (Inherited from Configuration.)
Public method | Clone(Configuration) | Creates a deep copy of this configuration into newInstance which was allocated externally (Inherited from Configuration.)
Public method | Clone T | Creates a deep copy of this configuration into new instance of T (Inherited from Configuration.)
Public method | Create | Creates new configuration - creates new configuration root with optional name parameter (Inherited from Configuration.)
Public method | CreateFromMerge | Creates new configuration from ordered merge result of two other nodes - base and override which can be from different configurations (Inherited from Configuration.)
Public method | CreateFromNode | Creates new configuration from other node, which may belong to a different configuration instance (Inherited from Configuration.)
 | CreateFromXML | Creates an instance of configuration initialized from XML content passed as string
Public method | Destroy | Erases all config data (Inherited from Configuration.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Include | Completely replaces this node with another node tree, positioning the new tree in the place of local node. Existing node is deleted after this operation completes, in its place child nodes from other node are inserted preserving their existing order. Attributes of other node get merged into parent of existing node (Inherited from Configuration.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Refresh | (Overrides Configuration Refresh .)
Public method | ResolveEnvironmentVar | Resolves variable name into its value (Inherited from Configuration.)
Public method | RunMacro | Runs macro and returns its value (Inherited from Configuration.)
Public method | Save | (Overrides Configuration Save .)
Public method | SaveAs(String) | Saves configuration into a file (Overrides FileConfiguration SaveAs(String).)
Public method | SaveAs(String, String) | Saves configuration to a file with optional link to XSL file
Public method | SaveToString | Saves XML configuration with optional link to XSL file, into string and returns it
Public method | SetReadOnly | (Inherited from FileConfiguration.)
Public method | ToConfigurationJSONDataMap | Returns this config as JSON data map suitable for making JSONConfiguration (Inherited from Configuration.)
Public method | ToLaconicFile | Serializes configuration tree into Laconic format and writes it into a file (Inherited from Configuration.)
Public method | ToLaconicStream | Serializes configuration tree into Laconic format and writes it into stream (Inherited from Configuration.)
Public method | ToLaconicString | Serializes configuration tree into Laconic format and returns it as a string (Inherited from Configuration.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
XMLConfiguration Class
NFX.Environment Namespace


XMLConfiguration.AdjustNodeName Method

XMLConfiguration AdjustNodeName Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override string AdjustNodeName(
    string name
)
protected override string AdjustNodeName(
    string name
)
Protected Overrides Function AdjustNodeName (
    name As String
) As String
Protected Overrides Function AdjustNodeName (
    name As String
) As String
protected:
virtual String^ AdjustNodeName(
    String^ name
) override
protected:
virtual String^ AdjustNodeName(
    String^ name
) override
abstract AdjustNodeName :
        name : string -> string
override AdjustNodeName :
        name : string -> string
abstract AdjustNodeName :
        name : string -> string
override AdjustNodeName :
        name : string -> string

Parameters

name
Type: Online System String

Return Value

Type: Online String
See Also
XMLConfiguration Class
XMLConfiguration Members
NFX.Environment Namespace


XMLConfiguration.CreateFromXML Method

XMLConfiguration CreateFromXML Method NFX Class Library

Creates an instance of configuration initialized from XML content passed as string

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static XMLConfiguration CreateFromXML(
    string content
)
public static XMLConfiguration CreateFromXML(
    string content
)
Public Shared Function CreateFromXML (
    content As String
) As XMLConfiguration
Public Shared Function CreateFromXML (
    content As String
) As XMLConfiguration
public:
static XMLConfiguration^ CreateFromXML(
    String^ content
)
public:
static XMLConfiguration^ CreateFromXML(
    String^ content
)
static member CreateFromXML :
        content : string -> XMLConfiguration
static member CreateFromXML :
        content : string -> XMLConfiguration

Parameters

content
Type: Online System String

Return Value

Type: XMLConfiguration
See Also
XMLConfiguration Class
XMLConfiguration Members
NFX.Environment Namespace


XMLConfiguration.Refresh Method

XMLConfiguration Refresh Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Refresh()
public override void Refresh()
Public Overrides Sub Refresh
Public Overrides Sub Refresh
public:
virtual void Refresh() override
public:
virtual void Refresh() override
abstract Refresh : unit -> unit
override Refresh : unit -> unit
abstract Refresh : unit -> unit
override Refresh : unit -> unit
See Also
XMLConfiguration Class
XMLConfiguration Members
NFX.Environment Namespace


XMLConfiguration.Save Method

XMLConfiguration Save Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Save()
public override void Save()
Public Overrides Sub Save
Public Overrides Sub Save
public:
virtual void Save() override
public:
virtual void Save() override
abstract Save : unit -> unit
override Save : unit -> unit
abstract Save : unit -> unit
override Save : unit -> unit
See Also
XMLConfiguration Class
XMLConfiguration Members
NFX.Environment Namespace


XMLConfiguration.SaveAs Method

XMLConfiguration SaveAs Method NFX Class Library

Overload List
 | Name | Description
Public method | SaveAs(String) | Saves configuration into a file (Overrides FileConfiguration SaveAs(String).)
Public method | SaveAs(String, String) | Saves configuration to a file with optional link to XSL file
Back to Top
See Also
XMLConfiguration Class
XMLConfiguration Members
NFX.Environment Namespace


XMLConfiguration.SaveAs Method (String)

XMLConfiguration SaveAs Method (String) NFX Class Library

Saves configuration into a file

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SaveAs(
    string filename
)
public override void SaveAs(
    string filename
)
Public Overrides Sub SaveAs (
    filename As String
)
Public Overrides Sub SaveAs (
    filename As String
)
public:
virtual void SaveAs(
    String^ filename
) override
public:
virtual void SaveAs(
    String^ filename
) override
abstract SaveAs :
        filename : string -> unit
override SaveAs :
        filename : string -> unit
abstract SaveAs :
        filename : string -> unit
override SaveAs :
        filename : string -> unit

Parameters

filename
Type: Online System String
See Also
XMLConfiguration Class
XMLConfiguration Members
SaveAs Overload
NFX.Environment Namespace


XMLConfiguration.SaveAs Method (String, String)

XMLConfiguration SaveAs Method (String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Saves configuration to a file with optional link to XSL file

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SaveAs(
    string filename,
    string xsl
)
public void SaveAs(
    string filename,
    string xsl
)
Public Sub SaveAs (
    filename As String,
    xsl As String
)
Public Sub SaveAs (
    filename As String,
    xsl As String
)
public:
void SaveAs(
    String^ filename,
    String^ xsl
)
public:
void SaveAs(
    String^ filename,
    String^ xsl
)
member SaveAs :
        filename : string *
        xsl : string -> unit
member SaveAs :
        filename : string *
        xsl : string -> unit

Parameters

filename
Type: Online System String
xsl
Type: Online System String
See Also
XMLConfiguration Class
XMLConfiguration Members
SaveAs Overload
NFX.Environment Namespace


XMLConfiguration.SaveToString Method

XMLConfiguration SaveToString Method NFX Class Library

Saves XML configuration with optional link to XSL file, into string and returns it

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SaveToString(
    string xsl = null
)
public string SaveToString(
    string xsl = null
)
Public Function SaveToString (
    Optional xsl As String = Nothing
) As String
Public Function SaveToString (
    Optional xsl As String = Nothing
) As String
public:
String^ SaveToString(
    String^ xsl = nullptr
)
public:
String^ SaveToString(
    String^ xsl = nullptr
)
member SaveToString :
        ?xsl : string
(* Defaults:
        let _xsl = defaultArg xsl null
*)
-> string
member SaveToString :
        ?xsl : string
(* Defaults:
        let _xsl = defaultArg xsl null
*)
-> string

Parameters

xsl (Optional)
Type: Online System String

Return Value

Type: Online String
See Also
XMLConfiguration Class
XMLConfiguration Members
NFX.Environment Namespace


XMLConfiguration.ToString Method

XMLConfiguration ToString Method NFX Class Library

Namespace: NFX.Environment
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
XMLConfiguration Class
XMLConfiguration Members
NFX.Environment Namespace


XMLConfiguration Properties

XMLConfiguration Properties NFX Class Library

The XMLConfiguration type exposes the following members.
Properties
 | Name | Description
Public property | ContentView | Primarily used for debugging - returns the content of the configuration as text in the pretty-printed Laconic format (Inherited from Configuration.)
Public property | EmptyAttr | References a special instance of an empty attribute node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist (Inherited from Configuration.)
Public property | EmptySection | References a special instance of an empty section node (one per configuration). Empty nodes are returned by indexers when a real node with specified name does not exist (Inherited from Configuration.)
Public property | EnvironmentVarResolver | References variable resolver. If this property is not set then default Windows environment var resolver is used (Inherited from Configuration.)
Public property | FileName | (Inherited from FileConfiguration.)
Public property | IsReadOnly | Indicates whether configuration is readonly or may be modified and saved (Inherited from FileConfiguration.)
Public property | MacroRunner | References macro runner. If this property is not set then default macro runner is used (Inherited from Configuration.)
Public property | MacroRunnerContext | Gets/sets an object passed by the framework into MacroRunner.Run() method. This property is auto-set for classes decorated with [ConfigMacroContext] attribute (Inherited from Configuration.)
Public property | Root | Accesses root section configuration node (Inherited from Configuration.)
Public property | StrictNames | Determines whether exception is thrown when configuration node name contains inappropriate chars for particular configuration type. For example, for XMLConfiguration node names may not have spaces and other separator chars. When StrictNames is false then particular configurations may replace incompatible chars in node names with neutral ones (i.e. "my value"->"my-value" in case of XMLConfiguration). (Inherited from Configuration.)
Public property | Variable_END | Variable end tag (Inherited from Configuration.)
Public property | Variable_ENV_MOD | Variable environment modifier (Inherited from Configuration.)
Public property | Variable_ESCAPE | Variable escape tag (Inherited from Configuration.)
Public property | Variable_MACRO_START | Variable get clause modifier (Inherited from Configuration.)
Public property | Variable_PATH_MOD | Variable path modifier (Inherited from Configuration.)
Public property | Variable_START | Variable start tag (Inherited from Configuration.)
Back to Top
See Also
XMLConfiguration Class
NFX.Environment Namespace


NFX.Erlang Namespace

NFX.Erlang Namespace NFX Class Library

Natively provides Erlang types/terms/parsing and OTP support
Classes
 | Class | Description
Protected class | AtomTable | Non-garbage collected hash table for atoms. It stores strings as atoms so that atoms can be quickly compared to with O(1) complexity. The instance of this table is statically maintained and its content is never cleared. The table contains a unique list of strings represented as atoms added throughout the lifetime of the application.
Public class | ConstAtoms |
Public class | ErlAbstractConnection | Maintains a connection between a C# process and a remote Erlang, C# or C node. The object maintains connection state and allows data to be sent to and received from the peer
Public class | ErlAbstractNode | Represents an OTP node
Public class | ErlApp |
Public class | ErlAuthException |
Public class | ErlBadDataException |
Public class | ErlConnection | Maintains a connection between a C# process and a remote Erlang, C# or C node. The object maintains connection state and allows data to be sent to and received from the peer
Public class | ErlConnectionException | Exception thrown when the connection with a given node gets broken
Public class | ErlConsts | Provides non-localizable Erlang constants
Protected class | ErlDown | Message sent when the monitored Pid dies
Protected class | ErlEpmd | Provides methods for registering, unregistering and looking up nodes with the Erlang portmapper daemon (Epmd). For each registered node, Epmd maintains information about the port on which incoming connections are accepted, as well as which versions of the Erlang communication protocolt the node supports
Public class | ErlException |
Protected class | ErlExit | Special message sent when a linked pid dies
Public class | ErlIncompatibleTypesException |
Public class | ErlInputStream | Provides a stream for decoding Erlang terms from external format
Public class | ErlLinks |
Public class | ErlList |
Public class | ErlLocalNode |
Public class | ErlMbox | Provides a simple mechanism for exchanging messages with Erlang processes or other instances of this class
Public class | ErlMsg | Provides a distributed carrier for Erlang messages
Public class | ErlObject | Class defines extension methods on types implementing IErlObject interface and static methods dealing with IErlObject
Public class | ErlOutputStream | Provides a stream for encoding Erlang terms to external format for transmission or storage
Public class | ErlPasswordSession | Keeps password for node and user
Public class | ErlPatternMatcher | Pattern matcher that implements a container of patterns to be matched against a given Erlang term. On successful match, the corresponding func registered with that pattern gets invoked
Public class | ErlRemoteNode |
Public class | ErlTcpTransport | TCP transport
Public class | ErlTrace | Special class used for passing tracing information in Erlang distributed messages SEND_TT, EXIT_TT, REG_SEND_TT, EXIT2_TT
Public class | ErlTransportFactory | Factory of IErlTransport
Public class | ErlTransportPasswordSource | Source of passwrod for transport (i.e. for SSH connection)
Public class | ErlTuple |
Public class | ErlTupleBase |
Public class | ErlVarBind | Dictionary of variables bound to terms
Public class | NotEnoughDataException | Exception thrown when decoding an Erlang term if there's not enough data in the buffer to construct the term
Protected class | StringConsts | A dictionary of framework text messages. Localization may be done in this class in future
Structures
 | Structure | Description
Public structure | ErlAtom |
Public structure | ErlBinary | Provides a C# representation of Erlang integer types
Public structure | ErlBoolean | Provides a C# representation of Erlang floats and doubles. Erlang defines only one floating point numeric type
Public structure | ErlByte | Provides a C# representation of Erlang integer types
Public structure | ErlDouble | Provides a C# representation of Erlang floats and doubles. Erlang defines only one floating point numeric type
Public structure | ErlLink |
Public structure | ErlLong | Provides a C# representation of Erlang integer types
Public structure | ErlPatternMatcher Pattern |
Public structure | ErlPid | Provides a C# representation of Erlang integer types
Public structure | ErlPort | Provides a C# representation of Erlang integer types
Public structure | ErlRef | Provides a C# representation of Erlang integer types
Public structure | ErlString |
Public structure | ErlVar | Provides a C# representation of an Erlang variable
Interfaces
 | Interface | Description
Public interface | IErlObject | All Erlang terms implement this interface
Public interface | IErlObject T |
Public interface | IErlTransport | General interface of TCP transports (i.e. usual TCP channel or SSH tunneled TCP channel)
Public interface | IQueable | Represents a interface that messages enqueued to ErlMbox must support
Delegates
Delegate | Description
Public delegate | ConnAttemptEventHandler
Public delegate | EpmdFailedConnAttemptEventHandler
Public delegate ErlPasswordRequiredEventHandler
Delegate is called when SSH tunnel requires password for authentication
Public delegate | IoOutputEventHandler
Public delegate MailboxMsgEventHandler
Indicates arrival of a message to a given mailbox. The msg is of type ErlMsg, ErlExit, ErlDown, or ErlException.

Return Value

Type:
If returns true, the message is handled, and will not be put in the mailbox's queue. Otherwise, the message will be enqueued in the mailbox's queue.
Public delegate | NodeStatusChangeEventHandler
Public delegate | PatternMatchFunc
Public delegate | PatternMatchFunc TContext
Public delegate ReadWriteEventHandler
Delegate called on read/write from socket
Public delegate TraceEventHandler
Debugging delegate called to be able to record transport-related events
Public delegate | UnhandledMsgEventHandler
Enumerations
 | Enumeration | Description
Public enumeration | Direction |
Protected enumeration | ErlAbstractNode NodeCompatibility |
Protected enumeration | ErlAbstractNode NodeType |
Protected enumeration | ErlExternalTag | Tags used for external format serialization
Public enumeration | ErlMsg Tag | Erlang message header tags
Public enumeration | ErlTraceLevel |
Public enumeration | ErlTypeOrder | Defines ordering semantics for Erlang types


AtomTable Class

AtomTable Class NFX Class Library

Non-garbage collected hash table for atoms. It stores strings as atoms so that atoms can be quickly compared to with O(1) complexity. The instance of this table is statically maintained and its content is never cleared. The table contains a unique list of strings represented as atoms added throughout the lifetime of the application.
Inheritance Hierarchy
Online System Object
NFX.Erlang AtomTable

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class AtomTable
internal class AtomTable
Friend Class AtomTable
Friend Class AtomTable
internal ref class AtomTable
internal ref class AtomTable
type AtomTable =  class end
type AtomTable =  class end
See Also
AtomTable Members
NFX.Erlang Namespace


AtomTable Members

AtomTable Members NFX Class Library

The AtomTable type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Exists | Returns true if given atom is present in the atom table
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IndexOf | Returns index of atom in the atom table. If atom is not found returns -1
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
EMPTY_INDEX |
FALSE_INDEX |
MAX_ATOM_LEN |
TRUE_INDEX |
UNDEFINED_INDEX |
Back to Top
Properties
 | Name | Description
Public property | Count | Returns the current number of atoms stored in the atom table
 | Initialized | Returns true if AtomTable.Instance is initialized
 | Instance | Returns singleton instance of the atom table
Public property | Item Int32 | Lookup an atom in the atom table by index
Public property | Item String | Lookup an atom in the atom table by name. If the atom is not present in the atom table - add it. Return the index of the atom in the atom table
Back to Top
See Also
AtomTable Class
NFX.Erlang Namespace


AtomTable Fields

AtomTable Fields NFX Class Library

The AtomTable type exposes the following members.
Fields
Name | Description
EMPTY_INDEX |
FALSE_INDEX |
MAX_ATOM_LEN |
TRUE_INDEX |
UNDEFINED_INDEX |
Back to Top
See Also
AtomTable Class
NFX.Erlang Namespace


AtomTable.EMPTY_INDEX Field

AtomTable EMPTY_INDEX Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int EMPTY_INDEX
public const int EMPTY_INDEX
Public Const EMPTY_INDEX As Integer
Public Const EMPTY_INDEX As Integer
public:
literal int EMPTY_INDEX
public:
literal int EMPTY_INDEX
static val mutable EMPTY_INDEX: int
static val mutable EMPTY_INDEX: int

Field Value

Type: Online Int32
See Also
AtomTable Class
AtomTable Members
NFX.Erlang Namespace


AtomTable.FALSE_INDEX Field

AtomTable FALSE_INDEX Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int FALSE_INDEX
public const int FALSE_INDEX
Public Const FALSE_INDEX As Integer
Public Const FALSE_INDEX As Integer
public:
literal int FALSE_INDEX
public:
literal int FALSE_INDEX
static val mutable FALSE_INDEX: int
static val mutable FALSE_INDEX: int

Field Value

Type: Online Int32
See Also
AtomTable Class
AtomTable Members
NFX.Erlang Namespace


AtomTable.MAX_ATOM_LEN Field

AtomTable MAX_ATOM_LEN Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal const int MAX_ATOM_LEN
internal const int MAX_ATOM_LEN
Friend Const MAX_ATOM_LEN As Integer
Friend Const MAX_ATOM_LEN As Integer
internal:
literal int MAX_ATOM_LEN
internal:
literal int MAX_ATOM_LEN
static val mutable internal MAX_ATOM_LEN: int
static val mutable internal MAX_ATOM_LEN: int

Field Value

Type: Online Int32
See Also
AtomTable Class
AtomTable Members
NFX.Erlang Namespace


AtomTable.TRUE_INDEX Field

AtomTable TRUE_INDEX Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int TRUE_INDEX
public const int TRUE_INDEX
Public Const TRUE_INDEX As Integer
Public Const TRUE_INDEX As Integer
public:
literal int TRUE_INDEX
public:
literal int TRUE_INDEX
static val mutable TRUE_INDEX: int
static val mutable TRUE_INDEX: int

Field Value

Type: Online Int32
See Also
AtomTable Class
AtomTable Members
NFX.Erlang Namespace


AtomTable.UNDEFINED_INDEX Field

AtomTable UNDEFINED_INDEX Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int UNDEFINED_INDEX
public const int UNDEFINED_INDEX
Public Const UNDEFINED_INDEX As Integer
Public Const UNDEFINED_INDEX As Integer
public:
literal int UNDEFINED_INDEX
public:
literal int UNDEFINED_INDEX
static val mutable UNDEFINED_INDEX: int
static val mutable UNDEFINED_INDEX: int

Field Value

Type: Online Int32
See Also
AtomTable Class
AtomTable Members
NFX.Erlang Namespace


AtomTable Methods

AtomTable Methods NFX Class Library

The AtomTable type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Exists | Returns true if given atom is present in the atom table
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IndexOf | Returns index of atom in the atom table. If atom is not found returns -1
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
AtomTable Class
NFX.Erlang Namespace


AtomTable.Exists Method

AtomTable Exists Method NFX Class Library

Returns true if given atom is present in the atom table

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Exists(
    string atom
)
public bool Exists(
    string atom
)
Public Function Exists (
    atom As String
) As Boolean
Public Function Exists (
    atom As String
) As Boolean
public:
bool Exists(
    String^ atom
)
public:
bool Exists(
    String^ atom
)
member Exists :
        atom : string -> bool
member Exists :
        atom : string -> bool

Parameters

atom
Type: Online System String

Return Value

Type: Online Boolean
See Also
AtomTable Class
AtomTable Members
NFX.Erlang Namespace


AtomTable.IndexOf Method

AtomTable IndexOf Method NFX Class Library

Returns index of atom in the atom table. If atom is not found returns -1

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int IndexOf(
    string atom
)
public int IndexOf(
    string atom
)
Public Function IndexOf (
    atom As String
) As Integer
Public Function IndexOf (
    atom As String
) As Integer
public:
int IndexOf(
    String^ atom
)
public:
int IndexOf(
    String^ atom
)
member IndexOf :
        atom : string -> int
member IndexOf :
        atom : string -> int

Parameters

atom
Type: Online System String

Return Value

Type: Online Int32
See Also
AtomTable Class
AtomTable Members
NFX.Erlang Namespace


AtomTable Properties

AtomTable Properties NFX Class Library

The AtomTable type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns the current number of atoms stored in the atom table
 | Initialized | Returns true if AtomTable.Instance is initialized
 | Instance | Returns singleton instance of the atom table
Public property | Item Int32 | Lookup an atom in the atom table by index
Public property | Item String | Lookup an atom in the atom table by name. If the atom is not present in the atom table - add it. Return the index of the atom in the atom table
Back to Top
See Also
AtomTable Class
NFX.Erlang Namespace


AtomTable.Count Property

AtomTable Count Property NFX Class Library

Returns the current number of atoms stored in the atom table

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
public:
property int Count {
    int get ();
}
member Count : int with get
member Count : int with get

Property Value

Type: Online Int32
See Also
AtomTable Class
AtomTable Members
NFX.Erlang Namespace


AtomTable.Initialized Property

AtomTable Initialized Property NFX Class Library

Returns true if AtomTable.Instance is initialized

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static bool Initialized { get; }
internal static bool Initialized { get; }
Friend Shared ReadOnly Property Initialized As Boolean
    Get
Friend Shared ReadOnly Property Initialized As Boolean
    Get
internal:
static property bool Initialized {
    bool get ();
}
internal:
static property bool Initialized {
    bool get ();
}
internal static member Initialized : bool with get
internal static member Initialized : bool with get

Property Value

Type: Online Boolean
See Also
AtomTable Class
AtomTable Members
NFX.Erlang Namespace


AtomTable.Instance Property

AtomTable Instance Property NFX Class Library

Returns singleton instance of the atom table

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static AtomTable Instance { get; }
public static AtomTable Instance { get; }
Public Shared ReadOnly Property Instance As AtomTable
    Get
Public Shared ReadOnly Property Instance As AtomTable
    Get
public:
static property AtomTable^ Instance {
    AtomTable^ get ();
}
public:
static property AtomTable^ Instance {
    AtomTable^ get ();
}
static member Instance : AtomTable with get
static member Instance : AtomTable with get

Property Value

Type: AtomTable
See Also
AtomTable Class
AtomTable Members
NFX.Erlang Namespace


AtomTable.Item Property

AtomTable Item Property NFX Class Library

Overload List
 | Name | Description
Public property | Item Int32 | Lookup an atom in the atom table by index
Public property | Item String | Lookup an atom in the atom table by name. If the atom is not present in the atom table - add it. Return the index of the atom in the atom table
Back to Top
See Also
AtomTable Class
AtomTable Members
NFX.Erlang Namespace


AtomTable.Item Property (Int32)

AtomTable Item Property (Int32) NFX Class Library

Lookup an atom in the atom table by index

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string this[
    int n
] { get; }
public string this[
    int n
] { get; }
Public ReadOnly Default Property Item (
    n As Integer
) As String
    Get
Public ReadOnly Default Property Item (
    n As Integer
) As String
    Get
public:
property String^ default[int n] {
    String^ get (int n);
}
public:
property String^ default[int n] {
    String^ get (int n);
}
member Item : string with get
member Item : string with get

Parameters

n
Type: Online System Int32

Property Value

Type: Online String
See Also
AtomTable Class
AtomTable Members
Item Overload
NFX.Erlang Namespace


AtomTable.Item Property (String)

AtomTable Item Property (String) NFX Class Library

Lookup an atom in the atom table by name. If the atom is not present in the atom table - add it. Return the index of the atom in the atom table

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int this[
    string atom
] { get; }
public int this[
    string atom
] { get; }
Public ReadOnly Default Property Item (
    atom As String
) As Integer
    Get
Public ReadOnly Default Property Item (
    atom As String
) As Integer
    Get
public:
property int default[String^ atom] {
    int get (String^ atom);
}
public:
property int default[String^ atom] {
    int get (String^ atom);
}
member Item : int with get
member Item : int with get

Parameters

atom
Type: Online System String

Property Value

Type: Online Int32
See Also
AtomTable Class
AtomTable Members
Item Overload
NFX.Erlang Namespace


ConnAttemptEventHandler Delegate

ConnAttemptEventHandler Delegate NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void ConnAttemptEventHandler(
    ErlLocalNode sender,
    ErlAtom node,
    Direction dir,
    Object info
)
public delegate void ConnAttemptEventHandler(
    ErlLocalNode sender,
    ErlAtom node,
    Direction dir,
    Object info
)
Public Delegate Sub ConnAttemptEventHandler (
    sender As ErlLocalNode,
    node As ErlAtom,
    dir As Direction,
    info As Object
)
Public Delegate Sub ConnAttemptEventHandler (
    sender As ErlLocalNode,
    node As ErlAtom,
    dir As Direction,
    info As Object
)
public delegate void ConnAttemptEventHandler(
    ErlLocalNode^ sender,
    ErlAtom node,
    Direction dir,
    Object^ info
)
public delegate void ConnAttemptEventHandler(
    ErlLocalNode^ sender,
    ErlAtom node,
    Direction dir,
    Object^ info
)
type ConnAttemptEventHandler =
    delegate of
        sender : ErlLocalNode *
        node : ErlAtom *
        dir : Direction *
        info : Object -> unit
type ConnAttemptEventHandler =
    delegate of
        sender : ErlLocalNode *
        node : ErlAtom *
        dir : Direction *
        info : Object -> unit

Parameters

sender
Type: NFX.Erlang ErlLocalNode
node
Type: NFX.Erlang ErlAtom
dir
Type: NFX.Erlang Direction
info
Type: Online System Object
See Also
NFX.Erlang Namespace


ConstAtoms Class

ConstAtoms Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Erlang ConstAtoms

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class ConstAtoms
public static class ConstAtoms
Public NotInheritable Class ConstAtoms
Public NotInheritable Class ConstAtoms
public ref class ConstAtoms abstract sealed
public ref class ConstAtoms abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ConstAtoms =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ConstAtoms =  class end
See Also
ConstAtoms Members
NFX.Erlang Namespace


ConstAtoms Members

ConstAtoms Members NFX Class Library

The ConstAtoms type exposes the following members.
Fields
Name | Description
ANY |
AtomTable |
BadRpc |
Call |
Cast |
Erlang |
Error |
Format |
GenCast |
Io_Lib |
Latin1 |
NoConnection |
NoProc |
Normal |
Ok |
Request |
Rex |
Rpc |
Undefined |
Unsupported |
User |
Back to Top
See Also
ConstAtoms Class
NFX.Erlang Namespace


ConstAtoms Fields

ConstAtoms Fields NFX Class Library

The ConstAtoms type exposes the following members.
Fields
Name | Description
ANY |
AtomTable |
BadRpc |
Call |
Cast |
Erlang |
Error |
Format |
GenCast |
Io_Lib |
Latin1 |
NoConnection |
NoProc |
Normal |
Ok |
Request |
Rex |
Rpc |
Undefined |
Unsupported |
User |
Back to Top
See Also
ConstAtoms Class
NFX.Erlang Namespace


ConstAtoms.ANY Field

ConstAtoms ANY Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlAtom ANY
public static ErlAtom ANY
Public Shared ANY As ErlAtom
Public Shared ANY As ErlAtom
public:
static ErlAtom ANY
public:
static ErlAtom ANY
static val mutable ANY: ErlAtom
static val mutable ANY: ErlAtom

Field Value

Type: ErlAtom
See Also
ConstAtoms Class
ConstAtoms Members
NFX.Erlang Namespace


ConstAtoms.AtomTable Field

ConstAtoms AtomTable Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static AtomTable AtomTable
internal static AtomTable AtomTable
Friend Shared AtomTable As AtomTable
Friend Shared AtomTable As AtomTable
internal:
static AtomTable^ AtomTable
internal:
static AtomTable^ AtomTable
static val mutable internal AtomTable: AtomTable
static val mutable internal AtomTable: AtomTable

Field Value

Type: AtomTable
See Also
ConstAtoms Class
ConstAtoms Members
NFX.Erlang Namespace


ConstAtoms.BadRpc Field

ConstAtoms BadRpc Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlAtom BadRpc
public static ErlAtom BadRpc
Public Shared BadRpc As ErlAtom
Public Shared BadRpc As ErlAtom
public:
static ErlAtom BadRpc
public:
static ErlAtom BadRpc
static val mutable BadRpc: ErlAtom
static val mutable BadRpc: ErlAtom

Field Value

Type: ErlAtom
See Also
ConstAtoms Class
ConstAtoms Members
NFX.Erlang Namespace


ConstAtoms.Call Field

ConstAtoms Call Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlAtom Call
public static ErlAtom Call
Public Shared Call As ErlAtom
Public Shared Call As ErlAtom
public:
static ErlAtom Call
public:
static ErlAtom Call
static val mutable Call: ErlAtom
static val mutable Call: ErlAtom

Field Value

Type: ErlAtom
See Also
ConstAtoms Class
ConstAtoms Members
NFX.Erlang Namespace


ConstAtoms.Cast Field

ConstAtoms Cast Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlAtom Cast
public static ErlAtom Cast
Public Shared Cast As ErlAtom
Public Shared Cast As ErlAtom
public:
static ErlAtom Cast
public:
static ErlAtom Cast
static val mutable Cast: ErlAtom
static val mutable Cast: ErlAtom

Field Value

Type: ErlAtom
See Also
ConstAtoms Class
ConstAtoms Members
NFX.Erlang Namespace


ConstAtoms.Erlang Field

ConstAtoms Erlang Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlAtom Erlang
public static ErlAtom Erlang
Public Shared Erlang As ErlAtom
Public Shared Erlang As ErlAtom
public:
static ErlAtom Erlang
public:
static ErlAtom Erlang
static val mutable Erlang: ErlAtom
static val mutable Erlang: ErlAtom

Field Value

Type: ErlAtom
See Also
ConstAtoms Class
ConstAtoms Members
NFX.Erlang Namespace


ConstAtoms.Error Field

ConstAtoms Error Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlAtom Error
public static ErlAtom Error
Public Shared Error As ErlAtom
Public Shared Error As ErlAtom
public:
static ErlAtom Error
public:
static ErlAtom Error
static val mutable Error: ErlAtom
static val mutable Error: ErlAtom

Field Value

Type: ErlAtom
See Also
ConstAtoms Class
ConstAtoms Members
NFX.Erlang Namespace


ConstAtoms.Format Field

ConstAtoms Format Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlAtom Format
public static ErlAtom Format
Public Shared Format As ErlAtom
Public Shared Format As ErlAtom
public:
static ErlAtom Format
public:
static ErlAtom Format
static val mutable Format: ErlAtom
static val mutable Format: ErlAtom

Field Value

Type: ErlAtom
See Also
ConstAtoms Class
ConstAtoms Members
NFX.Erlang Namespace


ConstAtoms.GenCast Field

ConstAtoms GenCast Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlAtom GenCast
public static ErlAtom GenCast
Public Shared GenCast As ErlAtom
Public Shared GenCast As ErlAtom
public:
static ErlAtom GenCast
public:
static ErlAtom GenCast
static val mutable GenCast: ErlAtom
static val mutable GenCast: ErlAtom

Field Value

Type: ErlAtom
See Also
ConstAtoms Class
ConstAtoms Members
NFX.Erlang Namespace


ConstAtoms.Io_Lib Field

ConstAtoms Io_Lib Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlAtom Io_Lib
public static ErlAtom Io_Lib
Public Shared Io_Lib As ErlAtom
Public Shared Io_Lib As ErlAtom
public:
static ErlAtom Io_Lib
public:
static ErlAtom Io_Lib
static val mutable Io_Lib: ErlAtom
static val mutable Io_Lib: ErlAtom

Field Value

Type: ErlAtom
See Also
ConstAtoms Class
ConstAtoms Members
NFX.Erlang Namespace


ConstAtoms.Latin1 Field

ConstAtoms Latin1 Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlAtom Latin1
public static ErlAtom Latin1
Public Shared Latin1 As ErlAtom
Public Shared Latin1 As ErlAtom
public:
static ErlAtom Latin1
public:
static ErlAtom Latin1
static val mutable Latin1: ErlAtom
static val mutable Latin1: ErlAtom

Field Value

Type: ErlAtom
See Also
ConstAtoms Class
ConstAtoms Members
NFX.Erlang Namespace


ConstAtoms.NoConnection Field

ConstAtoms NoConnection Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlAtom NoConnection
public static ErlAtom NoConnection
Public Shared NoConnection As ErlAtom
Public Shared NoConnection As ErlAtom
public:
static ErlAtom NoConnection
public:
static ErlAtom NoConnection
static val mutable NoConnection: ErlAtom
static val mutable NoConnection: ErlAtom

Field Value

Type: ErlAtom
See Also
ConstAtoms Class
ConstAtoms Members
NFX.Erlang Namespace


ConstAtoms.NoProc Field

ConstAtoms NoProc Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlAtom NoProc
public static ErlAtom NoProc
Public Shared NoProc As ErlAtom
Public Shared NoProc As ErlAtom
public:
static ErlAtom NoProc
public:
static ErlAtom NoProc
static val mutable NoProc: ErlAtom
static val mutable NoProc: ErlAtom

Field Value

Type: ErlAtom
See Also
ConstAtoms Class
ConstAtoms Members
NFX.Erlang Namespace


ConstAtoms.Normal Field

ConstAtoms Normal Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlAtom Normal
public static ErlAtom Normal
Public Shared Normal As ErlAtom
Public Shared Normal As ErlAtom
public:
static ErlAtom Normal
public:
static ErlAtom Normal
static val mutable Normal: ErlAtom
static val mutable Normal: ErlAtom

Field Value

Type: ErlAtom
See Also
ConstAtoms Class
ConstAtoms Members
NFX.Erlang Namespace


ConstAtoms.Ok Field

ConstAtoms Ok Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlAtom Ok
public static ErlAtom Ok
Public Shared Ok As ErlAtom
Public Shared Ok As ErlAtom
public:
static ErlAtom Ok
public:
static ErlAtom Ok
static val mutable Ok: ErlAtom
static val mutable Ok: ErlAtom

Field Value

Type: ErlAtom
See Also
ConstAtoms Class
ConstAtoms Members
NFX.Erlang Namespace


ConstAtoms.Request Field

ConstAtoms Request Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlAtom Request
public static ErlAtom Request
Public Shared Request As ErlAtom
Public Shared Request As ErlAtom
public:
static ErlAtom Request
public:
static ErlAtom Request
static val mutable Request: ErlAtom
static val mutable Request: ErlAtom

Field Value

Type: ErlAtom
See Also
ConstAtoms Class
ConstAtoms Members
NFX.Erlang Namespace


ConstAtoms.Rex Field

ConstAtoms Rex Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlAtom Rex
public static ErlAtom Rex
Public Shared Rex As ErlAtom
Public Shared Rex As ErlAtom
public:
static ErlAtom Rex
public:
static ErlAtom Rex
static val mutable Rex: ErlAtom
static val mutable Rex: ErlAtom

Field Value

Type: ErlAtom
See Also
ConstAtoms Class
ConstAtoms Members
NFX.Erlang Namespace


ConstAtoms.Rpc Field

ConstAtoms Rpc Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlAtom Rpc
public static ErlAtom Rpc
Public Shared Rpc As ErlAtom
Public Shared Rpc As ErlAtom
public:
static ErlAtom Rpc
public:
static ErlAtom Rpc
static val mutable Rpc: ErlAtom
static val mutable Rpc: ErlAtom

Field Value

Type: ErlAtom
See Also
ConstAtoms Class
ConstAtoms Members
NFX.Erlang Namespace


ConstAtoms.Undefined Field

ConstAtoms Undefined Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlAtom Undefined
public static ErlAtom Undefined
Public Shared Undefined As ErlAtom
Public Shared Undefined As ErlAtom
public:
static ErlAtom Undefined
public:
static ErlAtom Undefined
static val mutable Undefined: ErlAtom
static val mutable Undefined: ErlAtom

Field Value

Type: ErlAtom
See Also
ConstAtoms Class
ConstAtoms Members
NFX.Erlang Namespace


ConstAtoms.Unsupported Field

ConstAtoms Unsupported Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlAtom Unsupported
public static ErlAtom Unsupported
Public Shared Unsupported As ErlAtom
Public Shared Unsupported As ErlAtom
public:
static ErlAtom Unsupported
public:
static ErlAtom Unsupported
static val mutable Unsupported: ErlAtom
static val mutable Unsupported: ErlAtom

Field Value

Type: ErlAtom
See Also
ConstAtoms Class
ConstAtoms Members
NFX.Erlang Namespace


ConstAtoms.User Field

ConstAtoms User Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlAtom User
public static ErlAtom User
Public Shared User As ErlAtom
Public Shared User As ErlAtom
public:
static ErlAtom User
public:
static ErlAtom User
static val mutable User: ErlAtom
static val mutable User: ErlAtom

Field Value

Type: ErlAtom
See Also
ConstAtoms Class
ConstAtoms Members
NFX.Erlang Namespace


Direction Enumeration

Direction Enumeration NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum Direction
public enum Direction
Public Enumeration Direction
Public Enumeration Direction
public enum class Direction
public enum class Direction
type Direction
type Direction
Members
Member name | Value | Description
Inbound | 0 |
Outbound | 1 |
See Also
NFX.Erlang Namespace


EpmdFailedConnAttemptEventHandler Delegate

EpmdFailedConnAttemptEventHandler Delegate NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void EpmdFailedConnAttemptEventHandler(
    ErlLocalNode sender,
    ErlAtom node,
    Object info
)
public delegate void EpmdFailedConnAttemptEventHandler(
    ErlLocalNode sender,
    ErlAtom node,
    Object info
)
Public Delegate Sub EpmdFailedConnAttemptEventHandler (
    sender As ErlLocalNode,
    node As ErlAtom,
    info As Object
)
Public Delegate Sub EpmdFailedConnAttemptEventHandler (
    sender As ErlLocalNode,
    node As ErlAtom,
    info As Object
)
public delegate void EpmdFailedConnAttemptEventHandler(
    ErlLocalNode^ sender,
    ErlAtom node,
    Object^ info
)
public delegate void EpmdFailedConnAttemptEventHandler(
    ErlLocalNode^ sender,
    ErlAtom node,
    Object^ info
)
type EpmdFailedConnAttemptEventHandler =
    delegate of
        sender : ErlLocalNode *
        node : ErlAtom *
        info : Object -> unit
type EpmdFailedConnAttemptEventHandler =
    delegate of
        sender : ErlLocalNode *
        node : ErlAtom *
        info : Object -> unit

Parameters

sender
Type: NFX.Erlang ErlLocalNode
node
Type: NFX.Erlang ErlAtom
info
Type: Online System Object
See Also
NFX.Erlang Namespace


ErlAbstractConnection Class

ErlAbstractConnection Class NFX Class Library

Maintains a connection between a C# process and a remote Erlang, C# or C node. The object maintains connection state and allows data to be sent to and received from the peer
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Erlang ErlAbstractConnection
NFX.Erlang ErlConnection

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class ErlAbstractConnection : DisposableObject
public abstract class ErlAbstractConnection : DisposableObject
Public MustInherit Class ErlAbstractConnection
    Inherits DisposableObject
Public MustInherit Class ErlAbstractConnection
    Inherits DisposableObject
public ref class ErlAbstractConnection abstract : public DisposableObject
public ref class ErlAbstractConnection abstract : public DisposableObject
[<AbstractClassAttribute>]
type ErlAbstractConnection =
    class
        inherit DisposableObject
    end
[<AbstractClassAttribute>]
type ErlAbstractConnection =
    class
        inherit DisposableObject
    end
Remarks
This abstract class provides the neccesary methods to maintain the actual connection and encode the messages and headers in the proper format according to the Erlang distribution protocol. Subclasses can use these methods to provide a more or less transparent communication channel as desired. Note that no receive methods are provided. Subclasses must provide methods for message delivery, and may implement their own receive methods. If an exception occurs in any of the methods in this class, the connection will be closed and must be reopened in order to resume communication with the peer. This will be indicated to the subclass by passing the exception to its delivery() method
See Also
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection Members

ErlAbstractConnection Members NFX Class Library

The ErlAbstractConnection type exposes the following members.
Constructors
 | Name | Description
Protected method | ErlAbstractConnection(ErlLocalNode, IErlTransport) | Accept an incoming connection from a remote node. Used by ErlLocalNode.Accept to create a connection based on data received when handshaking with the peer node, when the remote node is the connection intitiator.
Protected method | ErlAbstractConnection(ErlLocalNode, ErlRemoteNode, Nullable ErlAtom , Boolean) | Intiate and open a connection to a remote node
Back to Top
Methods
 | Name | Description
Protected method | Close | Close the connection to the remote node
Protected method | Connect |
Protected method | Deliver(ErlConnectionException) | Deliver communication exceptions to the recipient
Protected method | Deliver(ErlMsg) | Deliver messages to the recipient
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoSend |
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | HeaderType |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadSock | Read data from socket
Protected method | Send |
Public method | SendRPC | Send an RPC request to the remote Erlang node
Public method | SendRPCcast | Send an RPC cast request to the remote Erlang node
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | CHALLENGE_ACK |
 | CHALLENGE_REPLY |
 | CHALLENGE_STATUS |
 | DEFAULT_MAX_PAYLOAD_LENGTH |
 | HEADER_LEN |
Protected field | m_Connected |
Protected field | m_Cookie |
Protected field | m_CookieOk |
Protected field | m_Home |
Protected field | m_Peer |
Protected field | m_ShouldSendCookie |
Protected field | m_Transport |
 | PASS_THROUGH |
 | s_Random |
Back to Top
Properties
 | Name | Description
Public property | Connected | Determine if the connection is still alive. Note that this method only reports the status of the connection, and that it is possible that there are unread messages waiting in the receive queue
 | ConnectTimeout |
Public property | Cookie |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | LocalNode |
Public property | MaxPayloadLength | Max size of the message accepted from the peer. The connection will be closed if a message is received of size greater than this.
Public property | Name |
Public property | ReceivedBytes | Total number of bytes received from connection
Public property | ReceivedMsgs | Total number of messages received from connection
Public property | RemoteNode |
Protected property | SendCookie | Cookie to send along with each distribution message
Public property | SentBytes | Total number of bytes sent through connection
Public property | SentMsgs | Total number of messages sent through connection
Public property | TraceLevel | Set the trace level for this connection. Normally tracing is off by default
Back to Top
See Also
ErlAbstractConnection Class
NFX.Erlang Namespace


ErlAbstractConnection Constructor

ErlAbstractConnection Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | ErlAbstractConnection(ErlLocalNode, IErlTransport) | Accept an incoming connection from a remote node. Used by ErlLocalNode.Accept to create a connection based on data received when handshaking with the peer node, when the remote node is the connection intitiator.
Protected method | ErlAbstractConnection(ErlLocalNode, ErlRemoteNode, Nullable ErlAtom , Boolean) | Intiate and open a connection to a remote node
Back to Top
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection Constructor (ErlLocalNode, IErlTransport)

ErlAbstractConnection Constructor (ErlLocalNode, IErlTransport) NFX Class Library

[This is preliminary documentation and is subject to change.]

Accept an incoming connection from a remote node. Used by ErlLocalNode.Accept to create a connection based on data received when handshaking with the peer node, when the remote node is the connection intitiator.

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ErlAbstractConnection(
    ErlLocalNode home,
    IErlTransport s
)
protected ErlAbstractConnection(
    ErlLocalNode home,
    IErlTransport s
)
Protected Sub New (
    home As ErlLocalNode,
    s As IErlTransport
)
Protected Sub New (
    home As ErlLocalNode,
    s As IErlTransport
)
protected:
ErlAbstractConnection(
    ErlLocalNode^ home,
    IErlTransport^ s
)
protected:
ErlAbstractConnection(
    ErlLocalNode^ home,
    IErlTransport^ s
)
new :
        home : ErlLocalNode *
        s : IErlTransport -> ErlAbstractConnection
new :
        home : ErlLocalNode *
        s : IErlTransport -> ErlAbstractConnection

Parameters

home
Type: NFX.Erlang ErlLocalNode
s
Type: NFX.Erlang IErlTransport
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
ErlAbstractConnection Overload
NFX.Erlang Namespace


ErlAbstractConnection Constructor (ErlLocalNode, ErlRemoteNode, Nullable(ErlAtom), Boolean)

ErlAbstractConnection Constructor (ErlLocalNode, ErlRemoteNode, Nullable ErlAtom , Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Intiate and open a connection to a remote node

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ErlAbstractConnection(
    ErlLocalNode self,
    ErlRemoteNode other,
    Nullable<ErlAtom> cookie = null,
    bool connect = true
)
protected ErlAbstractConnection(
    ErlLocalNode self,
    ErlRemoteNode other,
    Nullable<ErlAtom> cookie = null,
    bool connect = true
)
Protected Sub New (
    self As ErlLocalNode,
    other As ErlRemoteNode,
    Optional cookie As Nullable(Of ErlAtom) = Nothing,
    Optional connect As Boolean = true
)
Protected Sub New (
    self As ErlLocalNode,
    other As ErlRemoteNode,
    Optional cookie As Nullable(Of ErlAtom) = Nothing,
    Optional connect As Boolean = true
)
protected:
ErlAbstractConnection(
    ErlLocalNode^ self,
    ErlRemoteNode^ other,
    Nullable<ErlAtom> cookie = nullptr,
    bool connect = true
)
protected:
ErlAbstractConnection(
    ErlLocalNode^ self,
    ErlRemoteNode^ other,
    Nullable<ErlAtom> cookie = nullptr,
    bool connect = true
)
new :
        self : ErlLocalNode *
        other : ErlRemoteNode *
        ?cookie : Nullable<ErlAtom> *
        ?connect : bool
(* Defaults:
        let _cookie = defaultArg cookie null
        let _connect = defaultArg connect true
*)
-> ErlAbstractConnection
new :
        self : ErlLocalNode *
        other : ErlRemoteNode *
        ?cookie : Nullable<ErlAtom> *
        ?connect : bool
(* Defaults:
        let _cookie = defaultArg cookie null
        let _connect = defaultArg connect true
*)
-> ErlAbstractConnection

Parameters

self
Type: NFX.Erlang ErlLocalNode
other
Type: NFX.Erlang ErlRemoteNode
cookie (Optional)
Type: Online System Nullable ErlAtom
connect (Optional)
Type: Online System Boolean
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
ErlAbstractConnection Overload
NFX.Erlang Namespace


ErlAbstractConnection Fields

ErlAbstractConnection Fields NFX Class Library

The ErlAbstractConnection type exposes the following members.
Fields
 | Name | Description
 | CHALLENGE_ACK |
 | CHALLENGE_REPLY |
 | CHALLENGE_STATUS |
 | DEFAULT_MAX_PAYLOAD_LENGTH |
 | HEADER_LEN |
Protected field | m_Connected |
Protected field | m_Cookie |
Protected field | m_CookieOk |
Protected field | m_Home |
Protected field | m_Peer |
Protected field | m_ShouldSendCookie |
Protected field | m_Transport |
 | PASS_THROUGH |
 | s_Random |
Back to Top
See Also
ErlAbstractConnection Class
NFX.Erlang Namespace


ErlAbstractConnection.CHALLENGE_ACK Field

ErlAbstractConnection CHALLENGE_ACK Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int CHALLENGE_ACK
protected const int CHALLENGE_ACK
Protected Const CHALLENGE_ACK As Integer
Protected Const CHALLENGE_ACK As Integer
protected:
literal int CHALLENGE_ACK
protected:
literal int CHALLENGE_ACK
static val mutable CHALLENGE_ACK: int
static val mutable CHALLENGE_ACK: int

Field Value

Type: Online Int32
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.CHALLENGE_REPLY Field

ErlAbstractConnection CHALLENGE_REPLY Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int CHALLENGE_REPLY
protected const int CHALLENGE_REPLY
Protected Const CHALLENGE_REPLY As Integer
Protected Const CHALLENGE_REPLY As Integer
protected:
literal int CHALLENGE_REPLY
protected:
literal int CHALLENGE_REPLY
static val mutable CHALLENGE_REPLY: int
static val mutable CHALLENGE_REPLY: int

Field Value

Type: Online Int32
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.CHALLENGE_STATUS Field

ErlAbstractConnection CHALLENGE_STATUS Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int CHALLENGE_STATUS
protected const int CHALLENGE_STATUS
Protected Const CHALLENGE_STATUS As Integer
Protected Const CHALLENGE_STATUS As Integer
protected:
literal int CHALLENGE_STATUS
protected:
literal int CHALLENGE_STATUS
static val mutable CHALLENGE_STATUS: int
static val mutable CHALLENGE_STATUS: int

Field Value

Type: Online Int32
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.DEFAULT_MAX_PAYLOAD_LENGTH Field

ErlAbstractConnection DEFAULT_MAX_PAYLOAD_LENGTH Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int DEFAULT_MAX_PAYLOAD_LENGTH
protected const int DEFAULT_MAX_PAYLOAD_LENGTH
Protected Const DEFAULT_MAX_PAYLOAD_LENGTH As Integer
Protected Const DEFAULT_MAX_PAYLOAD_LENGTH As Integer
protected:
literal int DEFAULT_MAX_PAYLOAD_LENGTH
protected:
literal int DEFAULT_MAX_PAYLOAD_LENGTH
static val mutable DEFAULT_MAX_PAYLOAD_LENGTH: int
static val mutable DEFAULT_MAX_PAYLOAD_LENGTH: int

Field Value

Type: Online Int32
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.HEADER_LEN Field

ErlAbstractConnection HEADER_LEN Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int HEADER_LEN
protected const int HEADER_LEN
Protected Const HEADER_LEN As Integer
Protected Const HEADER_LEN As Integer
protected:
literal int HEADER_LEN
protected:
literal int HEADER_LEN
static val mutable HEADER_LEN: int
static val mutable HEADER_LEN: int

Field Value

Type: Online Int32
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.m_Connected Field

ErlAbstractConnection m_Connected Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool m_Connected
protected bool m_Connected
Protected m_Connected As Boolean
Protected m_Connected As Boolean
protected:
bool m_Connected
protected:
bool m_Connected
val mutable m_Connected: bool
val mutable m_Connected: bool

Field Value

Type: Online Boolean
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.m_Cookie Field

ErlAbstractConnection m_Cookie Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ErlAtom m_Cookie
protected ErlAtom m_Cookie
Protected m_Cookie As ErlAtom
Protected m_Cookie As ErlAtom
protected:
ErlAtom m_Cookie
protected:
ErlAtom m_Cookie
val mutable m_Cookie: ErlAtom
val mutable m_Cookie: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.m_CookieOk Field

ErlAbstractConnection m_CookieOk Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool m_CookieOk
protected bool m_CookieOk
Protected m_CookieOk As Boolean
Protected m_CookieOk As Boolean
protected:
bool m_CookieOk
protected:
bool m_CookieOk
val mutable m_CookieOk: bool
val mutable m_CookieOk: bool

Field Value

Type: Online Boolean
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.m_Home Field

ErlAbstractConnection m_Home Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ErlLocalNode m_Home
protected ErlLocalNode m_Home
Protected m_Home As ErlLocalNode
Protected m_Home As ErlLocalNode
protected:
ErlLocalNode^ m_Home
protected:
ErlLocalNode^ m_Home
val mutable m_Home: ErlLocalNode
val mutable m_Home: ErlLocalNode

Field Value

Type: ErlLocalNode
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.m_Peer Field

ErlAbstractConnection m_Peer Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ErlRemoteNode m_Peer
protected ErlRemoteNode m_Peer
Protected m_Peer As ErlRemoteNode
Protected m_Peer As ErlRemoteNode
protected:
ErlRemoteNode^ m_Peer
protected:
ErlRemoteNode^ m_Peer
val mutable m_Peer: ErlRemoteNode
val mutable m_Peer: ErlRemoteNode

Field Value

Type: ErlRemoteNode
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.m_ShouldSendCookie Field

ErlAbstractConnection m_ShouldSendCookie Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool m_ShouldSendCookie
protected bool m_ShouldSendCookie
Protected m_ShouldSendCookie As Boolean
Protected m_ShouldSendCookie As Boolean
protected:
bool m_ShouldSendCookie
protected:
bool m_ShouldSendCookie
val mutable m_ShouldSendCookie: bool
val mutable m_ShouldSendCookie: bool

Field Value

Type: Online Boolean
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.m_Transport Field

ErlAbstractConnection m_Transport Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IErlTransport m_Transport
protected IErlTransport m_Transport
Protected m_Transport As IErlTransport
Protected m_Transport As IErlTransport
protected:
IErlTransport^ m_Transport
protected:
IErlTransport^ m_Transport
val mutable m_Transport: IErlTransport
val mutable m_Transport: IErlTransport

Field Value

Type: IErlTransport
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.PASS_THROUGH Field

ErlAbstractConnection PASS_THROUGH Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const byte PASS_THROUGH
protected const byte PASS_THROUGH
Protected Const PASS_THROUGH As Byte
Protected Const PASS_THROUGH As Byte
protected:
literal unsigned char PASS_THROUGH
protected:
literal unsigned char PASS_THROUGH
static val mutable PASS_THROUGH: byte
static val mutable PASS_THROUGH: byte

Field Value

Type: Online Byte
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.s_Random Field

ErlAbstractConnection s_Random Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected static Random s_Random
protected static Random s_Random
Protected Shared s_Random As Random
Protected Shared s_Random As Random
protected:
static Random^ s_Random
protected:
static Random^ s_Random
static val mutable s_Random: Random
static val mutable s_Random: Random

Field Value

Type: Online Random
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection Methods

ErlAbstractConnection Methods NFX Class Library

The ErlAbstractConnection type exposes the following members.
Methods
 | Name | Description
Protected method | Close | Close the connection to the remote node
Protected method | Connect |
Protected method | Deliver(ErlConnectionException) | Deliver communication exceptions to the recipient
Protected method | Deliver(ErlMsg) | Deliver messages to the recipient
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoSend |
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | HeaderType |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadSock | Read data from socket
Protected method | Send |
Public method | SendRPC | Send an RPC request to the remote Erlang node
Public method | SendRPCcast | Send an RPC cast request to the remote Erlang node
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ErlAbstractConnection Class
NFX.Erlang Namespace


ErlAbstractConnection.Close Method

ErlAbstractConnection Close Method NFX Class Library

Close the connection to the remote node

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void Close()
protected virtual void Close()
Protected Overridable Sub Close
Protected Overridable Sub Close
protected:
virtual void Close()
protected:
virtual void Close()
abstract Close : unit -> unit
override Close : unit -> unit
abstract Close : unit -> unit
override Close : unit -> unit
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.Connect Method

ErlAbstractConnection Connect Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Connect()
internal void Connect()
Friend Sub Connect
Friend Sub Connect
internal:
void Connect()
internal:
void Connect()
internal member Connect : unit -> unit
internal member Connect : unit -> unit
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.Deliver Method

ErlAbstractConnection Deliver Method NFX Class Library

Overload List
 | Name | Description
Protected method | Deliver(ErlConnectionException) | Deliver communication exceptions to the recipient
Protected method | Deliver(ErlMsg) | Deliver messages to the recipient
Back to Top
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.Deliver Method (ErlConnectionException)

ErlAbstractConnection Deliver Method (ErlConnectionException) NFX Class Library

[This is preliminary documentation and is subject to change.]

Deliver communication exceptions to the recipient

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void Deliver(
    ErlConnectionException e
)
protected abstract void Deliver(
    ErlConnectionException e
)
Protected MustOverride Sub Deliver (
    e As ErlConnectionException
)
Protected MustOverride Sub Deliver (
    e As ErlConnectionException
)
protected:
virtual void Deliver(
    ErlConnectionException^ e
) abstract
protected:
virtual void Deliver(
    ErlConnectionException^ e
) abstract
abstract Deliver :
        e : ErlConnectionException -> unit
abstract Deliver :
        e : ErlConnectionException -> unit

Parameters

e
Type: NFX.Erlang ErlConnectionException
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
Deliver Overload
NFX.Erlang Namespace


ErlAbstractConnection.Deliver Method (ErlMsg)

ErlAbstractConnection Deliver Method (ErlMsg) NFX Class Library

[This is preliminary documentation and is subject to change.]

Deliver messages to the recipient

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void Deliver(
    ErlMsg msg
)
protected abstract void Deliver(
    ErlMsg msg
)
Protected MustOverride Sub Deliver (
    msg As ErlMsg
)
Protected MustOverride Sub Deliver (
    msg As ErlMsg
)
protected:
virtual void Deliver(
    ErlMsg^ msg
) abstract
protected:
virtual void Deliver(
    ErlMsg^ msg
) abstract
abstract Deliver :
        msg : ErlMsg -> unit
abstract Deliver :
        msg : ErlMsg -> unit

Parameters

msg
Type: NFX.Erlang ErlMsg
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
Deliver Overload
NFX.Erlang Namespace


ErlAbstractConnection.Destructor Method

ErlAbstractConnection Destructor Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.DoSend Method

ErlAbstractConnection DoSend Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void DoSend(
    ErlOutputStream header,
    ErlOutputStream payload = null
)
protected void DoSend(
    ErlOutputStream header,
    ErlOutputStream payload = null
)
Protected Sub DoSend (
    header As ErlOutputStream,
    Optional payload As ErlOutputStream = Nothing
)
Protected Sub DoSend (
    header As ErlOutputStream,
    Optional payload As ErlOutputStream = Nothing
)
protected:
void DoSend(
    ErlOutputStream^ header,
    ErlOutputStream^ payload = nullptr
)
protected:
void DoSend(
    ErlOutputStream^ header,
    ErlOutputStream^ payload = nullptr
)
member DoSend :
        header : ErlOutputStream *
        ?payload : ErlOutputStream
(* Defaults:
        let _payload = defaultArg payload null
*)
-> unit
member DoSend :
        header : ErlOutputStream *
        ?payload : ErlOutputStream
(* Defaults:
        let _payload = defaultArg payload null
*)
-> unit

Parameters

header
Type: NFX.Erlang ErlOutputStream
payload (Optional)
Type: NFX.Erlang ErlOutputStream
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.HeaderType Method

ErlAbstractConnection HeaderType Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected string HeaderType(
    IErlObject h
)
protected string HeaderType(
    IErlObject h
)
Protected Function HeaderType (
    h As IErlObject
) As String
Protected Function HeaderType (
    h As IErlObject
) As String
protected:
String^ HeaderType(
    IErlObject^ h
)
protected:
String^ HeaderType(
    IErlObject^ h
)
member HeaderType :
        h : IErlObject -> string
member HeaderType :
        h : IErlObject -> string

Parameters

h
Type: NFX.Erlang IErlObject

Return Value

Type: Online String
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.ReadSock Method

ErlAbstractConnection ReadSock Method NFX Class Library

Read data from socket

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int ReadSock(
    byte[] b,
    int sz,
    bool readingPayload
)
protected int ReadSock(
    byte[] b,
    int sz,
    bool readingPayload
)
Protected Function ReadSock (
    b As Byte(),
    sz As Integer,
    readingPayload As Boolean
) As Integer
Protected Function ReadSock (
    b As Byte(),
    sz As Integer,
    readingPayload As Boolean
) As Integer
protected:
int ReadSock(
    array<unsigned char>^ b,
    int sz,
    bool readingPayload
)
protected:
int ReadSock(
    array<unsigned char>^ b,
    int sz,
    bool readingPayload
)
member ReadSock :
        b : byte[] *
        sz : int *
        readingPayload : bool -> int
member ReadSock :
        b : byte[] *
        sz : int *
        readingPayload : bool -> int

Parameters

b
Type: Online System Byte
sz
Type: Online System Int32
readingPayload
Type: Online System Boolean

Return Value

Type: Online Int32
Remarks
This method now throws exception if we don't get full read
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.Send Method

ErlAbstractConnection Send Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Send(
    ErlMsg msg
)
internal void Send(
    ErlMsg msg
)
Friend Sub Send (
    msg As ErlMsg
)
Friend Sub Send (
    msg As ErlMsg
)
internal:
void Send(
    ErlMsg^ msg
)
internal:
void Send(
    ErlMsg^ msg
)
internal member Send :
        msg : ErlMsg -> unit
internal member Send :
        msg : ErlMsg -> unit

Parameters

msg
Type: NFX.Erlang ErlMsg
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.SendRPC Method

ErlAbstractConnection SendRPC Method NFX Class Library

Send an RPC request to the remote Erlang node

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SendRPC(
    ErlPid from,
    string mod,
    string fun,
    ErlList args
)
public void SendRPC(
    ErlPid from,
    string mod,
    string fun,
    ErlList args
)
Public Sub SendRPC (
    from As ErlPid,
    mod As String,
    fun As String,
    args As ErlList
)
Public Sub SendRPC (
    from As ErlPid,
    mod As String,
    fun As String,
    args As ErlList
)
public:
void SendRPC(
    ErlPid from,
    String^ mod,
    String^ fun,
    ErlList^ args
)
public:
void SendRPC(
    ErlPid from,
    String^ mod,
    String^ fun,
    ErlList^ args
)
member SendRPC :
        from : ErlPid *
        mod : string *
        fun : string *
        args : ErlList -> unit
member SendRPC :
        from : ErlPid *
        mod : string *
        fun : string *
        args : ErlList -> unit

Parameters

from
Type: NFX.Erlang ErlPid
mod
Type: Online System String
fun
Type: Online System String
args
Type: NFX.Erlang ErlList
Remarks
This convenience function creates the following message and sends it to 'rex' on the remote node:
View Colorized Copy to Clipboard Print
{ Self, { call, Mod, Fun, Args, user }}
{ Self, { call, Mod, Fun, Args, user }}
Note that this method has unpredicatble results if the remote node is not an Erlang node
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.SendRPCcast Method

ErlAbstractConnection SendRPCcast Method NFX Class Library

Send an RPC cast request to the remote Erlang node

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SendRPCcast(
    ErlPid from,
    string mod,
    string fun,
    ErlList args
)
public void SendRPCcast(
    ErlPid from,
    string mod,
    string fun,
    ErlList args
)
Public Sub SendRPCcast (
    from As ErlPid,
    mod As String,
    fun As String,
    args As ErlList
)
Public Sub SendRPCcast (
    from As ErlPid,
    mod As String,
    fun As String,
    args As ErlList
)
public:
void SendRPCcast(
    ErlPid from,
    String^ mod,
    String^ fun,
    ErlList^ args
)
public:
void SendRPCcast(
    ErlPid from,
    String^ mod,
    String^ fun,
    ErlList^ args
)
member SendRPCcast :
        from : ErlPid *
        mod : string *
        fun : string *
        args : ErlList -> unit
member SendRPCcast :
        from : ErlPid *
        mod : string *
        fun : string *
        args : ErlList -> unit

Parameters

from
Type: NFX.Erlang ErlPid
mod
Type: Online System String
fun
Type: Online System String
args
Type: NFX.Erlang ErlList
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection Properties

ErlAbstractConnection Properties NFX Class Library

The ErlAbstractConnection type exposes the following members.
Properties
 | Name | Description
Public property | Connected | Determine if the connection is still alive. Note that this method only reports the status of the connection, and that it is possible that there are unread messages waiting in the receive queue
 | ConnectTimeout |
Public property | Cookie |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | LocalNode |
Public property | MaxPayloadLength | Max size of the message accepted from the peer. The connection will be closed if a message is received of size greater than this.
Public property | Name |
Public property | ReceivedBytes | Total number of bytes received from connection
Public property | ReceivedMsgs | Total number of messages received from connection
Public property | RemoteNode |
Protected property | SendCookie | Cookie to send along with each distribution message
Public property | SentBytes | Total number of bytes sent through connection
Public property | SentMsgs | Total number of messages sent through connection
Public property | TraceLevel | Set the trace level for this connection. Normally tracing is off by default
Back to Top
See Also
ErlAbstractConnection Class
NFX.Erlang Namespace


ErlAbstractConnection.Connected Property

ErlAbstractConnection Connected Property NFX Class Library

Determine if the connection is still alive. Note that this method only reports the status of the connection, and that it is possible that there are unread messages waiting in the receive queue

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Connected { get; }
public bool Connected { get; }
Public ReadOnly Property Connected As Boolean
    Get
Public ReadOnly Property Connected As Boolean
    Get
public:
property bool Connected {
    bool get ();
}
public:
property bool Connected {
    bool get ();
}
member Connected : bool with get
member Connected : bool with get

Property Value

Type: Online Boolean
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.ConnectTimeout Property

ErlAbstractConnection ConnectTimeout Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int ConnectTimeout { get; set; }
public static int ConnectTimeout { get; set; }
Public Shared Property ConnectTimeout As Integer
    Get
    Set
Public Shared Property ConnectTimeout As Integer
    Get
    Set
public:
static property int ConnectTimeout {
    int get ();
    void set (int value);
}
public:
static property int ConnectTimeout {
    int get ();
    void set (int value);
}
static member ConnectTimeout : int with get, set
static member ConnectTimeout : int with get, set

Property Value

Type: Online Int32
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.Cookie Property

ErlAbstractConnection Cookie Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlAtom Cookie { get; }
public ErlAtom Cookie { get; }
Public ReadOnly Property Cookie As ErlAtom
    Get
Public ReadOnly Property Cookie As ErlAtom
    Get
public:
property ErlAtom Cookie {
    ErlAtom get ();
}
public:
property ErlAtom Cookie {
    ErlAtom get ();
}
member Cookie : ErlAtom with get
member Cookie : ErlAtom with get

Property Value

Type: ErlAtom
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.LocalNode Property

ErlAbstractConnection LocalNode Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlLocalNode LocalNode { get; }
public ErlLocalNode LocalNode { get; }
Public ReadOnly Property LocalNode As ErlLocalNode
    Get
Public ReadOnly Property LocalNode As ErlLocalNode
    Get
public:
property ErlLocalNode^ LocalNode {
    ErlLocalNode^ get ();
}
public:
property ErlLocalNode^ LocalNode {
    ErlLocalNode^ get ();
}
member LocalNode : ErlLocalNode with get
member LocalNode : ErlLocalNode with get

Property Value

Type: ErlLocalNode
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.MaxPayloadLength Property

ErlAbstractConnection MaxPayloadLength Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Max size of the message accepted from the peer. The connection will be closed if a message is received of size greater than this.

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MaxPayloadLength { get; set; }
public int MaxPayloadLength { get; set; }
Public Property MaxPayloadLength As Integer
    Get
    Set
Public Property MaxPayloadLength As Integer
    Get
    Set
public:
property int MaxPayloadLength {
    int get ();
    void set (int value);
}
public:
property int MaxPayloadLength {
    int get ();
    void set (int value);
}
member MaxPayloadLength : int with get, set
member MaxPayloadLength : int with get, set

Property Value

Type: Online Int32
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.Name Property

ErlAbstractConnection Name Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlAtom Name { get; }
public ErlAtom Name { get; }
Public ReadOnly Property Name As ErlAtom
    Get
Public ReadOnly Property Name As ErlAtom
    Get
public:
property ErlAtom Name {
    ErlAtom get ();
}
public:
property ErlAtom Name {
    ErlAtom get ();
}
member Name : ErlAtom with get
member Name : ErlAtom with get

Property Value

Type: ErlAtom
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.ReceivedBytes Property

ErlAbstractConnection ReceivedBytes Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Total number of bytes received from connection

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long ReceivedBytes { get; }
public long ReceivedBytes { get; }
Public ReadOnly Property ReceivedBytes As Long
    Get
Public ReadOnly Property ReceivedBytes As Long
    Get
public:
property long long ReceivedBytes {
    long long get ();
}
public:
property long long ReceivedBytes {
    long long get ();
}
member ReceivedBytes : int64 with get
member ReceivedBytes : int64 with get

Property Value

Type: Online Int64
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.ReceivedMsgs Property

ErlAbstractConnection ReceivedMsgs Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Total number of messages received from connection

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long ReceivedMsgs { get; }
public long ReceivedMsgs { get; }
Public ReadOnly Property ReceivedMsgs As Long
    Get
Public ReadOnly Property ReceivedMsgs As Long
    Get
public:
property long long ReceivedMsgs {
    long long get ();
}
public:
property long long ReceivedMsgs {
    long long get ();
}
member ReceivedMsgs : int64 with get
member ReceivedMsgs : int64 with get

Property Value

Type: Online Int64
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.RemoteNode Property

ErlAbstractConnection RemoteNode Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlRemoteNode RemoteNode { get; }
public ErlRemoteNode RemoteNode { get; }
Public ReadOnly Property RemoteNode As ErlRemoteNode
    Get
Public ReadOnly Property RemoteNode As ErlRemoteNode
    Get
public:
property ErlRemoteNode^ RemoteNode {
    ErlRemoteNode^ get ();
}
public:
property ErlRemoteNode^ RemoteNode {
    ErlRemoteNode^ get ();
}
member RemoteNode : ErlRemoteNode with get
member RemoteNode : ErlRemoteNode with get

Property Value

Type: ErlRemoteNode
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.SendCookie Property

ErlAbstractConnection SendCookie Property NFX Class Library

Cookie to send along with each distribution message

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ErlAtom SendCookie { get; }
protected ErlAtom SendCookie { get; }
Protected ReadOnly Property SendCookie As ErlAtom
    Get
Protected ReadOnly Property SendCookie As ErlAtom
    Get
protected:
property ErlAtom SendCookie {
    ErlAtom get ();
}
protected:
property ErlAtom SendCookie {
    ErlAtom get ();
}
member SendCookie : ErlAtom with get
member SendCookie : ErlAtom with get

Property Value

Type: ErlAtom
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.SentBytes Property

ErlAbstractConnection SentBytes Property NFX Class Library

Total number of bytes sent through connection

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long SentBytes { get; }
public long SentBytes { get; }
Public ReadOnly Property SentBytes As Long
    Get
Public ReadOnly Property SentBytes As Long
    Get
public:
property long long SentBytes {
    long long get ();
}
public:
property long long SentBytes {
    long long get ();
}
member SentBytes : int64 with get
member SentBytes : int64 with get

Property Value

Type: Online Int64
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.SentMsgs Property

ErlAbstractConnection SentMsgs Property NFX Class Library

Total number of messages sent through connection

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long SentMsgs { get; }
public long SentMsgs { get; }
Public ReadOnly Property SentMsgs As Long
    Get
Public ReadOnly Property SentMsgs As Long
    Get
public:
property long long SentMsgs {
    long long get ();
}
public:
property long long SentMsgs {
    long long get ();
}
member SentMsgs : int64 with get
member SentMsgs : int64 with get

Property Value

Type: Online Int64
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractConnection.TraceLevel Property

ErlAbstractConnection TraceLevel Property NFX Class Library

Set the trace level for this connection. Normally tracing is off by default

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTraceLevel TraceLevel { get; }
public ErlTraceLevel TraceLevel { get; }
Public ReadOnly Property TraceLevel As ErlTraceLevel
    Get
Public ReadOnly Property TraceLevel As ErlTraceLevel
    Get
public:
property ErlTraceLevel TraceLevel {
    ErlTraceLevel get ();
}
public:
property ErlTraceLevel TraceLevel {
    ErlTraceLevel get ();
}
member TraceLevel : ErlTraceLevel with get
member TraceLevel : ErlTraceLevel with get

Property Value

Type: ErlTraceLevel
See Also
ErlAbstractConnection Class
ErlAbstractConnection Members
NFX.Erlang Namespace


ErlAbstractNode Class

ErlAbstractNode Class NFX Class Library

Represents an OTP node
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.Erlang ErlAbstractNode
NFX.Erlang ErlLocalNode
NFX.Erlang ErlRemoteNode

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class ErlAbstractNode : Service
public abstract class ErlAbstractNode : Service
Public MustInherit Class ErlAbstractNode
    Inherits Service
Public MustInherit Class ErlAbstractNode
    Inherits Service
public ref class ErlAbstractNode abstract : public Service
public ref class ErlAbstractNode abstract : public Service
[<AbstractClassAttribute>]
type ErlAbstractNode =
    class
        inherit Service
    end
[<AbstractClassAttribute>]
type ErlAbstractNode =
    class
        inherit Service
    end
Remarks
About nodenames: Erlang nodenames consist of two components, an alivename and a hostname separated by '@'. Additionally, there are two nodename formats: short and long. Short names are of the form "alive@hostname", while long names are of the form "alive@host.fully.qualified.domainname". Erlang has special requirements regarding the use of the short and long formats, in particular they cannot be mixed freely in a network of communicating nodes, however Jinterface makes no distinction. See the Erlang documentation for more information about nodenames. The constructors for the AbstractNode classes will create names exactly as you provide them as long as the name contains '@'. If the string you provide contains no '@', it will be treated as an alivename and the name of the local host will be appended, resulting in a shortname. Nodenames longer than 255 characters will be truncated without warning. Upon initialization, this class attempts to read the file .erlang.cookie in the user's home directory, and uses the trimmed first line of the file as the default cookie by those constructors lacking a cookie argument. If for any reason the file cannot be found or read, the default cookie will be set to the empty string (""). The location of a user's home directory is determined using the system environment "HOME", which may not be automatically set on all platforms
See Also
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode Members

ErlAbstractNode Members NFX Class Library

The ErlAbstractNode type exposes the following members.
Constructors
 | Name | Description
Protected method | ErlAbstractNode(String, IConfigSectionNode) | This constructor
Protected method | ErlAbstractNode(String, Boolean) | Create a node with the given name and the default cookie
Protected method | ErlAbstractNode(String, ErlAtom, Boolean) | Create a node with the given name and cookie
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | NodeShortName |
Protected method | SetNodeName |
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
 | splitNodeName |
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | ToString | (Overrides Online Object ToString .)
 | tryReadStringFromFile |
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | DIST_HIGH |
 | DIST_LOW |
 | LocalHost |
Protected field | m_Creation |
Protected field | m_TcpKeepAlive |
Protected field | m_TcpLinger |
Protected field | m_TcpNoDelay |
Protected field | m_TcpRcvBufSize |
Protected field | m_TcpSndBufSize |
 | NTYPE |
 | s_DefaultCookie |
 | s_UseShortNames |
Back to Top
Properties
 | Name | Description
Public property | AliveName | Get the alivename part of the hostname. Nodenames are composed of two parts, an alivename and a hostname, separated by '@'. This method returns the part of the nodename preceding the '@'
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Cookie | Get the authorization cookie used by this node
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Protected property | DistChoose |
Protected property | DistHigh |
Protected property | DistLow |
Protected property | Epmd | Get/Set the Epmd socket after publishing this nodes listen port to Epmd
Protected property | Flags |
Public property | Host | Get the hostname part of the nodename. Nodenames are composed of two parts, an alivename and a hostname, separated by '@'. This method returns the part of the nodename following the '@'
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | NodeLongName | Get the long name of this node
Public property | NodeName | Get the name of this node (short or long depending on UseShortName)
Protected property | Ntype |
Public property | Port | Get the port number used by this node. For local node the value may be 0 if the node was not registered with the EPMD port mapper
Protected property | Proto |
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TcpKeepAlive |
Public property | TcpLinger |
Public property | TcpNoDelay |
Public property | TcpRcvBufSize |
Public property | TcpSndBufSize |
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Protected property | UseShortName |
Back to Top
See Also
ErlAbstractNode Class
NFX.Erlang Namespace


ErlAbstractNode Constructor

ErlAbstractNode Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | ErlAbstractNode(String, IConfigSectionNode) | This constructor
Protected method | ErlAbstractNode(String, Boolean) | Create a node with the given name and the default cookie
Protected method | ErlAbstractNode(String, ErlAtom, Boolean) | Create a node with the given name and cookie
Back to Top
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode Constructor (String, IConfigSectionNode)

ErlAbstractNode Constructor (String, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

This constructor

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ErlAbstractNode(
    string name,
    IConfigSectionNode config
)
protected ErlAbstractNode(
    string name,
    IConfigSectionNode config
)
Protected Sub New (
    name As String,
    config As IConfigSectionNode
)
Protected Sub New (
    name As String,
    config As IConfigSectionNode
)
protected:
ErlAbstractNode(
    String^ name,
    IConfigSectionNode^ config
)
protected:
ErlAbstractNode(
    String^ name,
    IConfigSectionNode^ config
)
new :
        name : string *
        config : IConfigSectionNode -> ErlAbstractNode
new :
        name : string *
        config : IConfigSectionNode -> ErlAbstractNode

Parameters

name
Type: Online System String
config
Type: NFX.Environment IConfigSectionNode
See Also
ErlAbstractNode Class
ErlAbstractNode Members
ErlAbstractNode Overload
NFX.Erlang Namespace


ErlAbstractNode Constructor (String, Boolean)

ErlAbstractNode Constructor (String, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Create a node with the given name and the default cookie

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal ErlAbstractNode(
    string node,
    bool shortName
)
protected internal ErlAbstractNode(
    string node,
    bool shortName
)
Protected Friend Sub New (
    node As String,
    shortName As Boolean
)
Protected Friend Sub New (
    node As String,
    shortName As Boolean
)
protected public:
ErlAbstractNode(
    String^ node,
    bool shortName
)
protected public:
ErlAbstractNode(
    String^ node,
    bool shortName
)
new :
        node : string *
        shortName : bool -> ErlAbstractNode
new :
        node : string *
        shortName : bool -> ErlAbstractNode

Parameters

node
Type: Online System String
shortName
Type: Online System Boolean
See Also
ErlAbstractNode Class
ErlAbstractNode Members
ErlAbstractNode Overload
NFX.Erlang Namespace


ErlAbstractNode Constructor (String, ErlAtom, Boolean)

ErlAbstractNode Constructor (String, ErlAtom, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Create a node with the given name and cookie

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ErlAbstractNode(
    string name,
    ErlAtom cookie,
    bool shortName
)
protected ErlAbstractNode(
    string name,
    ErlAtom cookie,
    bool shortName
)
Protected Sub New (
    name As String,
    cookie As ErlAtom,
    shortName As Boolean
)
Protected Sub New (
    name As String,
    cookie As ErlAtom,
    shortName As Boolean
)
protected:
ErlAbstractNode(
    String^ name,
    ErlAtom cookie,
    bool shortName
)
protected:
ErlAbstractNode(
    String^ name,
    ErlAtom cookie,
    bool shortName
)
new :
        name : string *
        cookie : ErlAtom *
        shortName : bool -> ErlAbstractNode
new :
        name : string *
        cookie : ErlAtom *
        shortName : bool -> ErlAbstractNode

Parameters

name
Type: Online System String
Node name in the form "name" or "name@hostname"
cookie
Type: NFX.Erlang ErlAtom
Security cookie used to connect to this/other node(s)
shortName
Type: Online System Boolean
Use short/long host names
See Also
ErlAbstractNode Class
ErlAbstractNode Members
ErlAbstractNode Overload
NFX.Erlang Namespace


ErlAbstractNode Fields

ErlAbstractNode Fields NFX Class Library

The ErlAbstractNode type exposes the following members.
Fields
 | Name | Description
 | DIST_HIGH |
 | DIST_LOW |
 | LocalHost |
Protected field | m_Creation |
Protected field | m_TcpKeepAlive |
Protected field | m_TcpLinger |
Protected field | m_TcpNoDelay |
Protected field | m_TcpRcvBufSize |
Protected field | m_TcpSndBufSize |
 | NTYPE |
 | s_DefaultCookie |
 | s_UseShortNames |
Back to Top
See Also
ErlAbstractNode Class
NFX.Erlang Namespace


ErlAbstractNode.DIST_HIGH Field

ErlAbstractNode DIST_HIGH Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal const int DIST_HIGH
internal const int DIST_HIGH
Friend Const DIST_HIGH As Integer
Friend Const DIST_HIGH As Integer
internal:
literal int DIST_HIGH
internal:
literal int DIST_HIGH
static val mutable internal DIST_HIGH: int
static val mutable internal DIST_HIGH: int

Field Value

Type: Online Int32
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.DIST_LOW Field

ErlAbstractNode DIST_LOW Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal const int DIST_LOW
internal const int DIST_LOW
Friend Const DIST_LOW As Integer
Friend Const DIST_LOW As Integer
internal:
literal int DIST_LOW
internal:
literal int DIST_LOW
static val mutable internal DIST_LOW: int
static val mutable internal DIST_LOW: int

Field Value

Type: Online Int32
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.LocalHost Field

ErlAbstractNode LocalHost Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static readonly string LocalHost
internal static readonly string LocalHost
Friend Shared ReadOnly LocalHost As String
Friend Shared ReadOnly LocalHost As String
internal:
static initonly String^ LocalHost
internal:
static initonly String^ LocalHost
static val internal LocalHost: string
static val internal LocalHost: string

Field Value

Type: Online String
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.m_Creation Field

ErlAbstractNode m_Creation Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int m_Creation
protected int m_Creation
Protected m_Creation As Integer
Protected m_Creation As Integer
protected:
int m_Creation
protected:
int m_Creation
val mutable m_Creation: int
val mutable m_Creation: int

Field Value

Type: Online Int32
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.m_TcpKeepAlive Field

ErlAbstractNode m_TcpKeepAlive Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$tcp-keep-alive")]
protected bool m_TcpKeepAlive
[ConfigAttribute("$tcp-keep-alive")]
protected bool m_TcpKeepAlive
<ConfigAttribute("$tcp-keep-alive")>
Protected m_TcpKeepAlive As Boolean
<ConfigAttribute("$tcp-keep-alive")>
Protected m_TcpKeepAlive As Boolean
protected:
[ConfigAttribute(L"$tcp-keep-alive")]
bool m_TcpKeepAlive
protected:
[ConfigAttribute(L"$tcp-keep-alive")]
bool m_TcpKeepAlive
[<ConfigAttribute("$tcp-keep-alive")>]
val mutable m_TcpKeepAlive: bool
[<ConfigAttribute("$tcp-keep-alive")>]
val mutable m_TcpKeepAlive: bool

Field Value

Type: Online Boolean
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.m_TcpLinger Field

ErlAbstractNode m_TcpLinger Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$tcp-linger")]
protected bool m_TcpLinger
[ConfigAttribute("$tcp-linger")]
protected bool m_TcpLinger
<ConfigAttribute("$tcp-linger")>
Protected m_TcpLinger As Boolean
<ConfigAttribute("$tcp-linger")>
Protected m_TcpLinger As Boolean
protected:
[ConfigAttribute(L"$tcp-linger")]
bool m_TcpLinger
protected:
[ConfigAttribute(L"$tcp-linger")]
bool m_TcpLinger
[<ConfigAttribute("$tcp-linger")>]
val mutable m_TcpLinger: bool
[<ConfigAttribute("$tcp-linger")>]
val mutable m_TcpLinger: bool

Field Value

Type: Online Boolean
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.m_TcpNoDelay Field

ErlAbstractNode m_TcpNoDelay Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$tcp-no-delay")]
protected bool m_TcpNoDelay
[ConfigAttribute("$tcp-no-delay")]
protected bool m_TcpNoDelay
<ConfigAttribute("$tcp-no-delay")>
Protected m_TcpNoDelay As Boolean
<ConfigAttribute("$tcp-no-delay")>
Protected m_TcpNoDelay As Boolean
protected:
[ConfigAttribute(L"$tcp-no-delay")]
bool m_TcpNoDelay
protected:
[ConfigAttribute(L"$tcp-no-delay")]
bool m_TcpNoDelay
[<ConfigAttribute("$tcp-no-delay")>]
val mutable m_TcpNoDelay: bool
[<ConfigAttribute("$tcp-no-delay")>]
val mutable m_TcpNoDelay: bool

Field Value

Type: Online Boolean
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.m_TcpRcvBufSize Field

ErlAbstractNode m_TcpRcvBufSize Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$tcp-rcv-buf-size")]
protected int m_TcpRcvBufSize
[ConfigAttribute("$tcp-rcv-buf-size")]
protected int m_TcpRcvBufSize
<ConfigAttribute("$tcp-rcv-buf-size")>
Protected m_TcpRcvBufSize As Integer
<ConfigAttribute("$tcp-rcv-buf-size")>
Protected m_TcpRcvBufSize As Integer
protected:
[ConfigAttribute(L"$tcp-rcv-buf-size")]
int m_TcpRcvBufSize
protected:
[ConfigAttribute(L"$tcp-rcv-buf-size")]
int m_TcpRcvBufSize
[<ConfigAttribute("$tcp-rcv-buf-size")>]
val mutable m_TcpRcvBufSize: int
[<ConfigAttribute("$tcp-rcv-buf-size")>]
val mutable m_TcpRcvBufSize: int

Field Value

Type: Online Int32
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.m_TcpSndBufSize Field

ErlAbstractNode m_TcpSndBufSize Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$tcp-snd-buf-size")]
protected int m_TcpSndBufSize
[ConfigAttribute("$tcp-snd-buf-size")]
protected int m_TcpSndBufSize
<ConfigAttribute("$tcp-snd-buf-size")>
Protected m_TcpSndBufSize As Integer
<ConfigAttribute("$tcp-snd-buf-size")>
Protected m_TcpSndBufSize As Integer
protected:
[ConfigAttribute(L"$tcp-snd-buf-size")]
int m_TcpSndBufSize
protected:
[ConfigAttribute(L"$tcp-snd-buf-size")]
int m_TcpSndBufSize
[<ConfigAttribute("$tcp-snd-buf-size")>]
val mutable m_TcpSndBufSize: int
[<ConfigAttribute("$tcp-snd-buf-size")>]
val mutable m_TcpSndBufSize: int

Field Value

Type: Online Int32
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.NTYPE Field

ErlAbstractNode NTYPE Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal const ErlAbstractNode..::..NodeType NTYPE
internal const ErlAbstractNode..::..NodeType NTYPE
Friend Const NTYPE As ErlAbstractNode..::..NodeType
Friend Const NTYPE As ErlAbstractNode..::..NodeType
internal:
literal ErlAbstractNode..::..NodeType NTYPE
internal:
literal ErlAbstractNode..::..NodeType NTYPE
static val mutable internal NTYPE: ErlAbstractNode..::..NodeType
static val mutable internal NTYPE: ErlAbstractNode..::..NodeType

Field Value

Type: ErlAbstractNode NodeType
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.s_DefaultCookie Field

ErlAbstractNode s_DefaultCookie Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static ErlAtom s_DefaultCookie
internal static ErlAtom s_DefaultCookie
Friend Shared s_DefaultCookie As ErlAtom
Friend Shared s_DefaultCookie As ErlAtom
internal:
static ErlAtom s_DefaultCookie
internal:
static ErlAtom s_DefaultCookie
static val mutable internal s_DefaultCookie: ErlAtom
static val mutable internal s_DefaultCookie: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.s_UseShortNames Field

ErlAbstractNode s_UseShortNames Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static bool s_UseShortNames
internal static bool s_UseShortNames
Friend Shared s_UseShortNames As Boolean
Friend Shared s_UseShortNames As Boolean
internal:
static bool s_UseShortNames
internal:
static bool s_UseShortNames
static val mutable internal s_UseShortNames: bool
static val mutable internal s_UseShortNames: bool

Field Value

Type: Online Boolean
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode Methods

ErlAbstractNode Methods NFX Class Library

The ErlAbstractNode type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | NodeShortName |
Protected method | SetNodeName |
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
 | splitNodeName |
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | ToString | (Overrides Online Object ToString .)
 | tryReadStringFromFile |
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ErlAbstractNode Class
NFX.Erlang Namespace


ErlAbstractNode.DoConfigure Method

ErlAbstractNode DoConfigure Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.NodeShortName Method

ErlAbstractNode NodeShortName Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static ErlAtom NodeShortName(
    string nodeName,
    bool shortName
)
internal static ErlAtom NodeShortName(
    string nodeName,
    bool shortName
)
Friend Shared Function NodeShortName (
    nodeName As String,
    shortName As Boolean
) As ErlAtom
Friend Shared Function NodeShortName (
    nodeName As String,
    shortName As Boolean
) As ErlAtom
internal:
static ErlAtom NodeShortName(
    String^ nodeName,
    bool shortName
)
internal:
static ErlAtom NodeShortName(
    String^ nodeName,
    bool shortName
)
internal static member NodeShortName :
        nodeName : string *
        shortName : bool -> ErlAtom
internal static member NodeShortName :
        nodeName : string *
        shortName : bool -> ErlAtom

Parameters

nodeName
Type: Online System String
shortName
Type: Online System Boolean

Return Value

Type: ErlAtom
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.SetNodeName Method

ErlAbstractNode SetNodeName Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void SetNodeName(
    string name
)
internal void SetNodeName(
    string name
)
Friend Sub SetNodeName (
    name As String
)
Friend Sub SetNodeName (
    name As String
)
internal:
void SetNodeName(
    String^ name
)
internal:
void SetNodeName(
    String^ name
)
internal member SetNodeName :
        name : string -> unit
internal member SetNodeName :
        name : string -> unit

Parameters

name
Type: Online System String
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.splitNodeName Method

ErlAbstractNode splitNodeName Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static void splitNodeName(
    string name,
    bool shortName,
    out string alive,
    out string host,
    out ErlAtom nodeName,
    out ErlAtom longName
)
internal static void splitNodeName(
    string name,
    bool shortName,
    out string alive,
    out string host,
    out ErlAtom nodeName,
    out ErlAtom longName
)
Friend Shared Sub splitNodeName (
    name As String,
    shortName As Boolean,
    <OutAttribute> ByRef alive As String,
    <OutAttribute> ByRef host As String,
    <OutAttribute> ByRef nodeName As ErlAtom,
    <OutAttribute> ByRef longName As ErlAtom
)
Friend Shared Sub splitNodeName (
    name As String,
    shortName As Boolean,
    <OutAttribute> ByRef alive As String,
    <OutAttribute> ByRef host As String,
    <OutAttribute> ByRef nodeName As ErlAtom,
    <OutAttribute> ByRef longName As ErlAtom
)
internal:
static void splitNodeName(
    String^ name,
    bool shortName,
    [OutAttribute] String^% alive,
    [OutAttribute] String^% host,
    [OutAttribute] ErlAtom% nodeName,
    [OutAttribute] ErlAtom% longName
)
internal:
static void splitNodeName(
    String^ name,
    bool shortName,
    [OutAttribute] String^% alive,
    [OutAttribute] String^% host,
    [OutAttribute] ErlAtom% nodeName,
    [OutAttribute] ErlAtom% longName
)
internal static member splitNodeName :
        name : string *
        shortName : bool *
        alive : string byref *
        host : string byref *
        nodeName : ErlAtom byref *
        longName : ErlAtom byref -> unit
internal static member splitNodeName :
        name : string *
        shortName : bool *
        alive : string byref *
        host : string byref *
        nodeName : ErlAtom byref *
        longName : ErlAtom byref -> unit

Parameters

name
Type: Online System String
shortName
Type: Online System Boolean
alive
Type: Online System String
host
Type: Online System String
nodeName
Type: NFX.Erlang ErlAtom
longName
Type: NFX.Erlang ErlAtom
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.ToString Method

ErlAbstractNode ToString Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.tryReadStringFromFile Method

ErlAbstractNode tryReadStringFromFile Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected static string tryReadStringFromFile(
    string filename
)
protected static string tryReadStringFromFile(
    string filename
)
Protected Shared Function tryReadStringFromFile (
    filename As String
) As String
Protected Shared Function tryReadStringFromFile (
    filename As String
) As String
protected:
static String^ tryReadStringFromFile(
    String^ filename
)
protected:
static String^ tryReadStringFromFile(
    String^ filename
)
static member tryReadStringFromFile :
        filename : string -> string
static member tryReadStringFromFile :
        filename : string -> string

Parameters

filename
Type: Online System String

Return Value

Type: Online String
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode Properties

ErlAbstractNode Properties NFX Class Library

The ErlAbstractNode type exposes the following members.
Properties
 | Name | Description
Public property | AliveName | Get the alivename part of the hostname. Nodenames are composed of two parts, an alivename and a hostname, separated by '@'. This method returns the part of the nodename preceding the '@'
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Cookie | Get the authorization cookie used by this node
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Protected property | DistChoose |
Protected property | DistHigh |
Protected property | DistLow |
Protected property | Epmd | Get/Set the Epmd socket after publishing this nodes listen port to Epmd
Protected property | Flags |
Public property | Host | Get the hostname part of the nodename. Nodenames are composed of two parts, an alivename and a hostname, separated by '@'. This method returns the part of the nodename following the '@'
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | NodeLongName | Get the long name of this node
Public property | NodeName | Get the name of this node (short or long depending on UseShortName)
Protected property | Ntype |
Public property | Port | Get the port number used by this node. For local node the value may be 0 if the node was not registered with the EPMD port mapper
Protected property | Proto |
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TcpKeepAlive |
Public property | TcpLinger |
Public property | TcpNoDelay |
Public property | TcpRcvBufSize |
Public property | TcpSndBufSize |
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Protected property | UseShortName |
Back to Top
See Also
ErlAbstractNode Class
NFX.Erlang Namespace


ErlAbstractNode.AliveName Property

ErlAbstractNode AliveName Property NFX Class Library

Get the alivename part of the hostname. Nodenames are composed of two parts, an alivename and a hostname, separated by '@'. This method returns the part of the nodename preceding the '@'

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AliveName { get; }
public string AliveName { get; }
Public ReadOnly Property AliveName As String
    Get
Public ReadOnly Property AliveName As String
    Get
public:
property String^ AliveName {
    String^ get ();
}
public:
property String^ AliveName {
    String^ get ();
}
member AliveName : string with get
member AliveName : string with get

Property Value

Type: Online String
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.Cookie Property

ErlAbstractNode Cookie Property NFX Class Library

Get the authorization cookie used by this node

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$cookie")]
public ErlAtom Cookie { get; set; }
[ConfigAttribute("$cookie")]
public ErlAtom Cookie { get; set; }
<ConfigAttribute("$cookie")>
Public Property Cookie As ErlAtom
    Get
    Set
<ConfigAttribute("$cookie")>
Public Property Cookie As ErlAtom
    Get
    Set
public:
[ConfigAttribute(L"$cookie")]
property ErlAtom Cookie {
    ErlAtom get ();
    void set (ErlAtom value);
}
public:
[ConfigAttribute(L"$cookie")]
property ErlAtom Cookie {
    ErlAtom get ();
    void set (ErlAtom value);
}
[<ConfigAttribute("$cookie")>]
member Cookie : ErlAtom with get, set
[<ConfigAttribute("$cookie")>]
member Cookie : ErlAtom with get, set

Property Value

Type: ErlAtom
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.DistChoose Property

ErlAbstractNode DistChoose Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int DistChoose { get; set; }
internal int DistChoose { get; set; }
Friend Property DistChoose As Integer
    Get
    Set
Friend Property DistChoose As Integer
    Get
    Set
internal:
property int DistChoose {
    int get ();
    void set (int value);
}
internal:
property int DistChoose {
    int get ();
    void set (int value);
}
internal member DistChoose : int with get, set
internal member DistChoose : int with get, set

Property Value

Type: Online Int32
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.DistHigh Property

ErlAbstractNode DistHigh Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int DistHigh { get; set; }
internal int DistHigh { get; set; }
Friend Property DistHigh As Integer
    Get
    Set
Friend Property DistHigh As Integer
    Get
    Set
internal:
property int DistHigh {
    int get ();
    void set (int value);
}
internal:
property int DistHigh {
    int get ();
    void set (int value);
}
internal member DistHigh : int with get, set
internal member DistHigh : int with get, set

Property Value

Type: Online Int32
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.DistLow Property

ErlAbstractNode DistLow Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int DistLow { get; set; }
internal int DistLow { get; set; }
Friend Property DistLow As Integer
    Get
    Set
Friend Property DistLow As Integer
    Get
    Set
internal:
property int DistLow {
    int get ();
    void set (int value);
}
internal:
property int DistLow {
    int get ();
    void set (int value);
}
internal member DistLow : int with get, set
internal member DistLow : int with get, set

Property Value

Type: Online Int32
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.Epmd Property

ErlAbstractNode Epmd Property NFX Class Library

Get/Set the Epmd socket after publishing this nodes listen port to Epmd

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal IErlTransport Epmd { get; set; }
internal IErlTransport Epmd { get; set; }
Friend Property Epmd As IErlTransport
    Get
    Set
Friend Property Epmd As IErlTransport
    Get
    Set
internal:
property IErlTransport^ Epmd {
    IErlTransport^ get ();
    void set (IErlTransport^ value);
}
internal:
property IErlTransport^ Epmd {
    IErlTransport^ get ();
    void set (IErlTransport^ value);
}
internal member Epmd : IErlTransport with get, set
internal member Epmd : IErlTransport with get, set

Property Value

Type: IErlTransport
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.Flags Property

ErlAbstractNode Flags Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ErlAbstractNode..::..NodeCompatibility Flags { get; set; }
internal ErlAbstractNode..::..NodeCompatibility Flags { get; set; }
Friend Property Flags As ErlAbstractNode..::..NodeCompatibility
    Get
    Set
Friend Property Flags As ErlAbstractNode..::..NodeCompatibility
    Get
    Set
internal:
property ErlAbstractNode..::..NodeCompatibility Flags {
    ErlAbstractNode..::..NodeCompatibility get ();
    void set (ErlAbstractNode..::..NodeCompatibility value);
}
internal:
property ErlAbstractNode..::..NodeCompatibility Flags {
    ErlAbstractNode..::..NodeCompatibility get ();
    void set (ErlAbstractNode..::..NodeCompatibility value);
}
internal member Flags : ErlAbstractNode..::..NodeCompatibility with get, set
internal member Flags : ErlAbstractNode..::..NodeCompatibility with get, set

Property Value

Type: ErlAbstractNode NodeCompatibility
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.Host Property

ErlAbstractNode Host Property NFX Class Library

Get the hostname part of the nodename. Nodenames are composed of two parts, an alivename and a hostname, separated by '@'. This method returns the part of the nodename following the '@'

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Host { get; }
public string Host { get; }
Public ReadOnly Property Host As String
    Get
Public ReadOnly Property Host As String
    Get
public:
property String^ Host {
    String^ get ();
}
public:
property String^ Host {
    String^ get ();
}
member Host : string with get
member Host : string with get

Property Value

Type: Online String
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.NodeLongName Property

ErlAbstractNode NodeLongName Property NFX Class Library

Get the long name of this node

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlAtom NodeLongName { get; }
public ErlAtom NodeLongName { get; }
Public ReadOnly Property NodeLongName As ErlAtom
    Get
Public ReadOnly Property NodeLongName As ErlAtom
    Get
public:
property ErlAtom NodeLongName {
    ErlAtom get ();
}
public:
property ErlAtom NodeLongName {
    ErlAtom get ();
}
member NodeLongName : ErlAtom with get
member NodeLongName : ErlAtom with get

Property Value

Type: ErlAtom
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.NodeName Property

ErlAbstractNode NodeName Property NFX Class Library

Get the name of this node (short or long depending on UseShortName)

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlAtom NodeName { get; }
public ErlAtom NodeName { get; }
Public ReadOnly Property NodeName As ErlAtom
    Get
Public ReadOnly Property NodeName As ErlAtom
    Get
public:
property ErlAtom NodeName {
    ErlAtom get ();
}
public:
property ErlAtom NodeName {
    ErlAtom get ();
}
member NodeName : ErlAtom with get
member NodeName : ErlAtom with get

Property Value

Type: ErlAtom
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.Ntype Property

ErlAbstractNode Ntype Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ErlAbstractNode..::..NodeType Ntype { get; set; }
internal ErlAbstractNode..::..NodeType Ntype { get; set; }
Friend Property Ntype As ErlAbstractNode..::..NodeType
    Get
    Set
Friend Property Ntype As ErlAbstractNode..::..NodeType
    Get
    Set
internal:
property ErlAbstractNode..::..NodeType Ntype {
    ErlAbstractNode..::..NodeType get ();
    void set (ErlAbstractNode..::..NodeType value);
}
internal:
property ErlAbstractNode..::..NodeType Ntype {
    ErlAbstractNode..::..NodeType get ();
    void set (ErlAbstractNode..::..NodeType value);
}
internal member Ntype : ErlAbstractNode..::..NodeType with get, set
internal member Ntype : ErlAbstractNode..::..NodeType with get, set

Property Value

Type: ErlAbstractNode NodeType
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.Port Property

ErlAbstractNode Port Property NFX Class Library

Get the port number used by this node. For local node the value may be 0 if the node was not registered with the EPMD port mapper

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Port { get; internal set; }
public int Port { get; internal set; }
Public Property Port As Integer
    Get
    Friend Set
Public Property Port As Integer
    Get
    Friend Set
public:
property int Port {
    int get ();
    internal: void set (int value);
}
public:
property int Port {
    int get ();
    internal: void set (int value);
}
member Port : int with get, internal set
member Port : int with get, internal set

Property Value

Type: Online Int32
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.Proto Property

ErlAbstractNode Proto Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int Proto { get; set; }
internal int Proto { get; set; }
Friend Property Proto As Integer
    Get
    Set
Friend Property Proto As Integer
    Get
    Set
internal:
property int Proto {
    int get ();
    void set (int value);
}
internal:
property int Proto {
    int get ();
    void set (int value);
}
internal member Proto : int with get, set
internal member Proto : int with get, set

Property Value

Type: Online Int32
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.TcpKeepAlive Property

ErlAbstractNode TcpKeepAlive Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TcpKeepAlive { get; set; }
public bool TcpKeepAlive { get; set; }
Public Property TcpKeepAlive As Boolean
    Get
    Set
Public Property TcpKeepAlive As Boolean
    Get
    Set
public:
property bool TcpKeepAlive {
    bool get ();
    void set (bool value);
}
public:
property bool TcpKeepAlive {
    bool get ();
    void set (bool value);
}
member TcpKeepAlive : bool with get, set
member TcpKeepAlive : bool with get, set

Property Value

Type: Online Boolean
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.TcpLinger Property

ErlAbstractNode TcpLinger Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TcpLinger { get; set; }
public bool TcpLinger { get; set; }
Public Property TcpLinger As Boolean
    Get
    Set
Public Property TcpLinger As Boolean
    Get
    Set
public:
property bool TcpLinger {
    bool get ();
    void set (bool value);
}
public:
property bool TcpLinger {
    bool get ();
    void set (bool value);
}
member TcpLinger : bool with get, set
member TcpLinger : bool with get, set

Property Value

Type: Online Boolean
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.TcpNoDelay Property

ErlAbstractNode TcpNoDelay Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TcpNoDelay { get; set; }
public bool TcpNoDelay { get; set; }
Public Property TcpNoDelay As Boolean
    Get
    Set
Public Property TcpNoDelay As Boolean
    Get
    Set
public:
property bool TcpNoDelay {
    bool get ();
    void set (bool value);
}
public:
property bool TcpNoDelay {
    bool get ();
    void set (bool value);
}
member TcpNoDelay : bool with get, set
member TcpNoDelay : bool with get, set

Property Value

Type: Online Boolean
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.TcpRcvBufSize Property

ErlAbstractNode TcpRcvBufSize Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int TcpRcvBufSize { get; set; }
public int TcpRcvBufSize { get; set; }
Public Property TcpRcvBufSize As Integer
    Get
    Set
Public Property TcpRcvBufSize As Integer
    Get
    Set
public:
property int TcpRcvBufSize {
    int get ();
    void set (int value);
}
public:
property int TcpRcvBufSize {
    int get ();
    void set (int value);
}
member TcpRcvBufSize : int with get, set
member TcpRcvBufSize : int with get, set

Property Value

Type: Online Int32
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.TcpSndBufSize Property

ErlAbstractNode TcpSndBufSize Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int TcpSndBufSize { get; set; }
public int TcpSndBufSize { get; set; }
Public Property TcpSndBufSize As Integer
    Get
    Set
Public Property TcpSndBufSize As Integer
    Get
    Set
public:
property int TcpSndBufSize {
    int get ();
    void set (int value);
}
public:
property int TcpSndBufSize {
    int get ();
    void set (int value);
}
member TcpSndBufSize : int with get, set
member TcpSndBufSize : int with get, set

Property Value

Type: Online Int32
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.UseShortName Property

ErlAbstractNode UseShortName Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("../$short-name")]
internal bool UseShortName { get; set; }
[ConfigAttribute("../$short-name")]
internal bool UseShortName { get; set; }
<ConfigAttribute("../$short-name")>
Friend Property UseShortName As Boolean
    Get
    Set
<ConfigAttribute("../$short-name")>
Friend Property UseShortName As Boolean
    Get
    Set
internal:
[ConfigAttribute(L"../$short-name")]
property bool UseShortName {
    bool get ();
    void set (bool value);
}
internal:
[ConfigAttribute(L"../$short-name")]
property bool UseShortName {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute("../$short-name")>]
internal member UseShortName : bool with get, set
[<ConfigAttribute("../$short-name")>]
internal member UseShortName : bool with get, set

Property Value

Type: Online Boolean
See Also
ErlAbstractNode Class
ErlAbstractNode Members
NFX.Erlang Namespace


ErlAbstractNode.NodeCompatibility Enumeration

ErlAbstractNode NodeCompatibility Enumeration NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[FlagsAttribute]
internal enum NodeCompatibility
[FlagsAttribute]
internal enum NodeCompatibility
<FlagsAttribute>
Friend Enumeration NodeCompatibility
<FlagsAttribute>
Friend Enumeration NodeCompatibility
[FlagsAttribute]
internal enum class NodeCompatibility
[FlagsAttribute]
internal enum class NodeCompatibility
[<FlagsAttribute>]
type internal NodeCompatibility
[<FlagsAttribute>]
type internal NodeCompatibility
Members
Member name | Value | Description
Published | 1 |
AtomCache | 2 |
ExtendedReferences | 4 |
DistMonitor | 8 |
FunTags | 16 |
ExtendedPidsPorts | 256 |
BitBinaries | 1024 |
NewFloats | 2048 |
Flags | 3340 |
See Also
NFX.Erlang Namespace


ErlAbstractNode.NodeType Enumeration

ErlAbstractNode NodeType Enumeration NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal enum NodeType
internal enum NodeType
Friend Enumeration NodeType
Friend Enumeration NodeType
internal enum class NodeType
internal enum class NodeType
type internal NodeType
type internal NodeType
Members
Member name | Value | Description
Ntype_R6 | 110 |
Ntype_R4_Erlang | 109 |
Ntype_R4_Hidden | 104 |
See Also
NFX.Erlang Namespace


ErlApp Class

ErlApp Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Erlang ErlApp

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ErlApp : IApplicationStarter, IConfigurable,
    INamed
public class ErlApp : IApplicationStarter, IConfigurable,
    INamed
Public Class ErlApp
    Implements IApplicationStarter, IConfigurable, INamed
Public Class ErlApp
    Implements IApplicationStarter, IConfigurable, INamed
public ref class ErlApp : IApplicationStarter, IConfigurable,
    INamed
public ref class ErlApp : IApplicationStarter, IConfigurable,
    INamed
type ErlApp =
    class
        interface IApplicationStarter
        interface IConfigurable
        interface INamed
    end
type ErlApp =
    class
        interface IApplicationStarter
        interface IConfigurable
        interface INamed
    end
See Also
ErlApp Members
NFX.Erlang Namespace


ErlApp Members

ErlApp Members NFX Class Library

The ErlApp type exposes the following members.
Constructors
 | Name | Description
Public method | ErlApp | Initializes a new instance of the ErlApp class
Back to Top
Methods
 | Name | Description
Public method | ApplicationStartAfterInit |
Public method | ApplicationStartBeforeInit |
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
 | TraceEnabled |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
DefaultTraceLevel |
IgnoreLocalEpmdConnectErrors |
UseExtendedPidsPorts |
Back to Top
Properties
 | Name | Description
Public property | ApplicationStartBreakOnException |
Public property | Name |
 | Node | Global node from config
Back to Top
See Also
ErlApp Class
NFX.Erlang Namespace


ErlApp Constructor

ErlApp Constructor NFX Class Library

Initializes a new instance of the ErlApp class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlApp()
public ErlApp()
Public Sub New
Public Sub New
public:
ErlApp()
public:
ErlApp()
new : unit -> ErlApp
new : unit -> ErlApp
See Also
ErlApp Class
ErlApp Members
NFX.Erlang Namespace


ErlApp Fields

ErlApp Fields NFX Class Library

The ErlApp type exposes the following members.
Fields
Name | Description
DefaultTraceLevel |
IgnoreLocalEpmdConnectErrors |
UseExtendedPidsPorts |
Back to Top
See Also
ErlApp Class
NFX.Erlang Namespace


ErlApp.DefaultTraceLevel Field

ErlApp DefaultTraceLevel Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlTraceLevel DefaultTraceLevel
public static ErlTraceLevel DefaultTraceLevel
Public Shared DefaultTraceLevel As ErlTraceLevel
Public Shared DefaultTraceLevel As ErlTraceLevel
public:
static ErlTraceLevel DefaultTraceLevel
public:
static ErlTraceLevel DefaultTraceLevel
static val mutable DefaultTraceLevel: ErlTraceLevel
static val mutable DefaultTraceLevel: ErlTraceLevel

Field Value

Type: ErlTraceLevel
See Also
ErlApp Class
ErlApp Members
NFX.Erlang Namespace


ErlApp.IgnoreLocalEpmdConnectErrors Field

ErlApp IgnoreLocalEpmdConnectErrors Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IgnoreLocalEpmdConnectErrors
public static bool IgnoreLocalEpmdConnectErrors
Public Shared IgnoreLocalEpmdConnectErrors As Boolean
Public Shared IgnoreLocalEpmdConnectErrors As Boolean
public:
static bool IgnoreLocalEpmdConnectErrors
public:
static bool IgnoreLocalEpmdConnectErrors
static val mutable IgnoreLocalEpmdConnectErrors: bool
static val mutable IgnoreLocalEpmdConnectErrors: bool

Field Value

Type: Online Boolean
See Also
ErlApp Class
ErlApp Members
NFX.Erlang Namespace


ErlApp.UseExtendedPidsPorts Field

ErlApp UseExtendedPidsPorts Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool UseExtendedPidsPorts
public static bool UseExtendedPidsPorts
Public Shared UseExtendedPidsPorts As Boolean
Public Shared UseExtendedPidsPorts As Boolean
public:
static bool UseExtendedPidsPorts
public:
static bool UseExtendedPidsPorts
static val mutable UseExtendedPidsPorts: bool
static val mutable UseExtendedPidsPorts: bool

Field Value

Type: Online Boolean
See Also
ErlApp Class
ErlApp Members
NFX.Erlang Namespace


ErlApp Methods

ErlApp Methods NFX Class Library

The ErlApp type exposes the following members.
Methods
 | Name | Description
Public method | ApplicationStartAfterInit |
Public method | ApplicationStartBeforeInit |
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
 | TraceEnabled |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ErlApp Class
NFX.Erlang Namespace


ErlApp.ApplicationStartAfterInit Method

ErlApp ApplicationStartAfterInit Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ApplicationStartAfterInit(
    IApplication application
)
public void ApplicationStartAfterInit(
    IApplication application
)
Public Sub ApplicationStartAfterInit (
    application As IApplication
)
Public Sub ApplicationStartAfterInit (
    application As IApplication
)
public:
virtual void ApplicationStartAfterInit(
    IApplication^ application
) sealed
public:
virtual void ApplicationStartAfterInit(
    IApplication^ application
) sealed
abstract ApplicationStartAfterInit :
        application : IApplication -> unit
override ApplicationStartAfterInit :
        application : IApplication -> unit
abstract ApplicationStartAfterInit :
        application : IApplication -> unit
override ApplicationStartAfterInit :
        application : IApplication -> unit

Parameters

application
Type: NFX.ApplicationModel IApplication

Implements

IApplicationStarter ApplicationStartAfterInit(IApplication)
See Also
ErlApp Class
ErlApp Members
NFX.Erlang Namespace


ErlApp.ApplicationStartBeforeInit Method

ErlApp ApplicationStartBeforeInit Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ApplicationStartBeforeInit(
    IApplication application
)
public void ApplicationStartBeforeInit(
    IApplication application
)
Public Sub ApplicationStartBeforeInit (
    application As IApplication
)
Public Sub ApplicationStartBeforeInit (
    application As IApplication
)
public:
virtual void ApplicationStartBeforeInit(
    IApplication^ application
) sealed
public:
virtual void ApplicationStartBeforeInit(
    IApplication^ application
) sealed
abstract ApplicationStartBeforeInit :
        application : IApplication -> unit
override ApplicationStartBeforeInit :
        application : IApplication -> unit
abstract ApplicationStartBeforeInit :
        application : IApplication -> unit
override ApplicationStartBeforeInit :
        application : IApplication -> unit

Parameters

application
Type: NFX.ApplicationModel IApplication

Implements

IApplicationStarter ApplicationStartBeforeInit(IApplication)
See Also
ErlApp Class
ErlApp Members
NFX.Erlang Namespace


ErlApp.Configure Method

ErlApp Configure Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode node
)
public void Configure(
    IConfigSectionNode node
)
Public Sub Configure (
    node As IConfigSectionNode
)
Public Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
ErlApp Class
ErlApp Members
NFX.Erlang Namespace


ErlApp.TraceEnabled Method

ErlApp TraceEnabled Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool TraceEnabled(
    ErlTraceLevel level,
    ErlTraceLevel minLevel
)
public static bool TraceEnabled(
    ErlTraceLevel level,
    ErlTraceLevel minLevel
)
Public Shared Function TraceEnabled (
    level As ErlTraceLevel,
    minLevel As ErlTraceLevel
) As Boolean
Public Shared Function TraceEnabled (
    level As ErlTraceLevel,
    minLevel As ErlTraceLevel
) As Boolean
public:
static bool TraceEnabled(
    ErlTraceLevel level,
    ErlTraceLevel minLevel
)
public:
static bool TraceEnabled(
    ErlTraceLevel level,
    ErlTraceLevel minLevel
)
static member TraceEnabled :
        level : ErlTraceLevel *
        minLevel : ErlTraceLevel -> bool
static member TraceEnabled :
        level : ErlTraceLevel *
        minLevel : ErlTraceLevel -> bool

Parameters

level
Type: NFX.Erlang ErlTraceLevel
minLevel
Type: NFX.Erlang ErlTraceLevel

Return Value

Type: Online Boolean
See Also
ErlApp Class
ErlApp Members
NFX.Erlang Namespace


ErlApp Properties

ErlApp Properties NFX Class Library

The ErlApp type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationStartBreakOnException |
Public property | Name |
 | Node | Global node from config
Back to Top
See Also
ErlApp Class
NFX.Erlang Namespace


ErlApp.ApplicationStartBreakOnException Property

ErlApp ApplicationStartBreakOnException Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ApplicationStartBreakOnException { get; }
public bool ApplicationStartBreakOnException { get; }
Public ReadOnly Property ApplicationStartBreakOnException As Boolean
    Get
Public ReadOnly Property ApplicationStartBreakOnException As Boolean
    Get
public:
virtual property bool ApplicationStartBreakOnException {
    bool get () sealed;
}
public:
virtual property bool ApplicationStartBreakOnException {
    bool get () sealed;
}
abstract ApplicationStartBreakOnException : bool with get
override ApplicationStartBreakOnException : bool with get
abstract ApplicationStartBreakOnException : bool with get
override ApplicationStartBreakOnException : bool with get

Property Value

Type: Online Boolean

Implements

IApplicationStarter ApplicationStartBreakOnException
See Also
ErlApp Class
ErlApp Members
NFX.Erlang Namespace


ErlApp.Name Property

ErlApp Name Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
ErlApp Class
ErlApp Members
NFX.Erlang Namespace


ErlApp.Node Property

ErlApp Node Property NFX Class Library

Global node from config

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlLocalNode Node { get; internal set; }
public static ErlLocalNode Node { get; internal set; }
Public Shared Property Node As ErlLocalNode
    Get
    Friend Set
Public Shared Property Node As ErlLocalNode
    Get
    Friend Set
public:
static property ErlLocalNode^ Node {
    ErlLocalNode^ get ();
    internal: void set (ErlLocalNode^ value);
}
public:
static property ErlLocalNode^ Node {
    ErlLocalNode^ get ();
    internal: void set (ErlLocalNode^ value);
}
static member Node : ErlLocalNode with get, internal set
static member Node : ErlLocalNode with get, internal set

Property Value

Type: ErlLocalNode
See Also
ErlApp Class
ErlApp Members
NFX.Erlang Namespace


ErlAtom Structure

ErlAtom Structure NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct ErlAtom : IErlObject<string>,
    IErlObject, IComparable, IComparable<IErlObject>, IEquatable<IErlObject>,
    ICloneable
public struct ErlAtom : IErlObject<string>,
    IErlObject, IComparable, IComparable<IErlObject>, IEquatable<IErlObject>,
    ICloneable
Public Structure ErlAtom
    Implements IErlObject(Of String), IErlObject,
    IComparable, IComparable(Of IErlObject), IEquatable(Of IErlObject),
    ICloneable
Public Structure ErlAtom
    Implements IErlObject(Of String), IErlObject,
    IComparable, IComparable(Of IErlObject), IEquatable(Of IErlObject),
    ICloneable
public value class ErlAtom : IErlObject<String^>,
    IErlObject, IComparable, IComparable<IErlObject^>, IEquatable<IErlObject^>,
    ICloneable
public value class ErlAtom : IErlObject<String^>,
    IErlObject, IComparable, IComparable<IErlObject^>, IEquatable<IErlObject^>,
    ICloneable
[<SealedAttribute>]
type ErlAtom =
    struct
        interface IErlObject<string>
        interface IErlObject
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
    end
[<SealedAttribute>]
type ErlAtom =
    struct
        interface IErlObject<string>
        interface IErlObject
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
    end
See Also
ErlAtom Members
NFX.Erlang Namespace


ErlAtom Members

ErlAtom Members NFX Class Library

The ErlAtom type exposes the following members.
Constructors
 | Name | Description
Public method | ErlAtom(String) | Create an atom from the given string
Public method | ErlAtom(ErlAtom) | Initializes a new instance of the ErlAtom class
Public method | ErlAtom( Byte , Int32 , Int32) | Initializes a new instance of the ErlAtom class
Back to Top
Methods
 | Name | Description
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the atom is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the atom is less than obj, positive - greater than the obj
Public method | Equals(Object) | Determine if this atom equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(IErlObject) | Determine if two atoms are equal
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Get internal hash code (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Public method | Matches | Perform pattern match on this Erlang term without binding any variables
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Subst |
Public method | ToString | Get the printname of the atom represented by this object. The difference between this method and {link #atomValue atomValue()} is that the printname is quoted and escaped where necessary, according to the Erlang rules for atom naming (Overrides Online ValueType ToString .)
Public method | Visit TAccumulate | Execute fun for every nested term
Back to Top
Operators
Name | Description
Equality |
(String to ErlAtom) | Implicit conversion of string to atom
(ErlAtom to String) | Implicit conversion of atom to string
Inequality |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | False |
Public field | Index | The index of this atom in the global atom table
 | Normal |
 | Null |
 | True |
 | Undefined |
Back to Top
Properties
 | Name | Description
Public property | Empty | Returns true if this instance equals ErlAtom.Null
Public property | IsScalar | Determines whether the underlying type is scalar or complex (i.e. tuple, list)
Public property | Length | Return the length of the atom string
Public property | TypeOrder |
Public property | Value | Get the actual string contained in this object
Public property | ValueAsBool |
Public property | ValueAsByteArray |
Public property | ValueAsChar |
Public property | ValueAsDateTime |
Public property | ValueAsDecimal |
Public property | ValueAsDouble |
Public property | ValueAsInt |
Public property | ValueAsLong |
Public property | ValueAsObject |
Public property | ValueAsString |
Public property | ValueAsTimeSpan |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone |
Back to Top
See Also
ErlAtom Structure
NFX.Erlang Namespace


ErlAtom Constructor

ErlAtom Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ErlAtom(String) | Create an atom from the given string
Public method | ErlAtom(ErlAtom) | Initializes a new instance of the ErlAtom class
Public method | ErlAtom( Byte , Int32 , Int32) | Initializes a new instance of the ErlAtom class
Back to Top
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom Constructor (String)

ErlAtom Constructor (String) NFX Class Library

Create an atom from the given string

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlAtom(
    string atom
)
public ErlAtom(
    string atom
)
Public Sub New (
    atom As String
)
Public Sub New (
    atom As String
)
public:
ErlAtom(
    String^ atom
)
public:
ErlAtom(
    String^ atom
)
new :
        atom : string -> ErlAtom
new :
        atom : string -> ErlAtom

Parameters

atom
Type: Online System String
See Also
ErlAtom Structure
ErlAtom Members
ErlAtom Overload
NFX.Erlang Namespace


ErlAtom Constructor (ErlAtom)

ErlAtom Constructor (ErlAtom) NFX Class Library

Initializes a new instance of the ErlAtom class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlAtom(
    ErlAtom atom
)
public ErlAtom(
    ErlAtom atom
)
Public Sub New (
    atom As ErlAtom
)
Public Sub New (
    atom As ErlAtom
)
public:
ErlAtom(
    ErlAtom atom
)
public:
ErlAtom(
    ErlAtom atom
)
new :
        atom : ErlAtom -> ErlAtom
new :
        atom : ErlAtom -> ErlAtom

Parameters

atom
Type: NFX.Erlang ErlAtom
See Also
ErlAtom Structure
ErlAtom Members
ErlAtom Overload
NFX.Erlang Namespace


ErlAtom Constructor (Byte[], Int32, Int32)

ErlAtom Constructor ( Byte , Int32 , Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlAtom class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlAtom(
    byte[] buf,
    ref int offset,
    int count
)
public ErlAtom(
    byte[] buf,
    ref int offset,
    int count
)
Public Sub New (
    buf As Byte(),
    ByRef offset As Integer,
    count As Integer
)
Public Sub New (
    buf As Byte(),
    ByRef offset As Integer,
    count As Integer
)
public:
ErlAtom(
    array<unsigned char>^ buf,
    int% offset,
    int count
)
public:
ErlAtom(
    array<unsigned char>^ buf,
    int% offset,
    int count
)
new :
        buf : byte[] *
        offset : int byref *
        count : int -> ErlAtom
new :
        buf : byte[] *
        offset : int byref *
        count : int -> ErlAtom

Parameters

buf
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32
See Also
ErlAtom Structure
ErlAtom Members
ErlAtom Overload
NFX.Erlang Namespace


ErlAtom Fields

ErlAtom Fields NFX Class Library

The ErlAtom type exposes the following members.
Fields
 | Name | Description
 | False |
Public field | Index | The index of this atom in the global atom table
 | Normal |
 | Null |
 | True |
 | Undefined |
Back to Top
See Also
ErlAtom Structure
NFX.Erlang Namespace


ErlAtom.False Field

ErlAtom False Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ErlAtom False
public static readonly ErlAtom False
Public Shared ReadOnly False As ErlAtom
Public Shared ReadOnly False As ErlAtom
public:
static initonly ErlAtom False
public:
static initonly ErlAtom False
static val False: ErlAtom
static val False: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.Index Field

ErlAtom Index Field NFX Class Library

The index of this atom in the global atom table

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Index
public readonly int Index
Public ReadOnly Index As Integer
Public ReadOnly Index As Integer
public:
initonly int Index
public:
initonly int Index
val Index: int
val Index: int

Field Value

Type: Online Int32
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.Normal Field

ErlAtom Normal Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ErlAtom Normal
public static readonly ErlAtom Normal
Public Shared ReadOnly Normal As ErlAtom
Public Shared ReadOnly Normal As ErlAtom
public:
static initonly ErlAtom Normal
public:
static initonly ErlAtom Normal
static val Normal: ErlAtom
static val Normal: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.Null Field

ErlAtom Null Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ErlAtom Null
public static readonly ErlAtom Null
Public Shared ReadOnly Null As ErlAtom
Public Shared ReadOnly Null As ErlAtom
public:
static initonly ErlAtom Null
public:
static initonly ErlAtom Null
static val Null: ErlAtom
static val Null: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.True Field

ErlAtom True Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ErlAtom True
public static readonly ErlAtom True
Public Shared ReadOnly True As ErlAtom
Public Shared ReadOnly True As ErlAtom
public:
static initonly ErlAtom True
public:
static initonly ErlAtom True
static val True: ErlAtom
static val True: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.Undefined Field

ErlAtom Undefined Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ErlAtom Undefined
public static readonly ErlAtom Undefined
Public Shared ReadOnly Undefined As ErlAtom
Public Shared ReadOnly Undefined As ErlAtom
public:
static initonly ErlAtom Undefined
public:
static initonly ErlAtom Undefined
static val Undefined: ErlAtom
static val Undefined: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom Methods

ErlAtom Methods NFX Class Library

The ErlAtom type exposes the following members.
Methods
 | Name | Description
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the atom is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the atom is less than obj, positive - greater than the obj
Public method | Equals(Object) | Determine if this atom equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(IErlObject) | Determine if two atoms are equal
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Get internal hash code (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Public method | Matches | Perform pattern match on this Erlang term without binding any variables
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Subst |
Public method | ToString | Get the printname of the atom represented by this object. The difference between this method and {link #atomValue atomValue()} is that the printname is quoted and escaped where necessary, according to the Erlang rules for atom naming (Overrides Online ValueType ToString .)
Public method | Visit TAccumulate | Execute fun for every nested term
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone |
Back to Top
See Also
ErlAtom Structure
NFX.Erlang Namespace


ErlAtom.ICloneable.Clone Method

ErlAtom ICloneable Clone Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object ICloneable.Clone()
Object ICloneable.Clone()
Private Function Clone As Object Implements ICloneable.Clone
Private Function Clone As Object Implements ICloneable.Clone
private:
virtual Object^ Clone() sealed = ICloneable::Clone
private:
virtual Object^ Clone() sealed = ICloneable::Clone
private abstract Clone : unit -> Object
private override Clone : unit -> Object
private abstract Clone : unit -> Object
private override Clone : unit -> Object

Return Value

Type: Online Object

Implements

Online ICloneable Clone
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.Clone Method

ErlAtom Clone Method NFX Class Library

Clone an instance of the object (non-scalar immutable objects are copied by reference)

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject Clone()
public IErlObject Clone()
Public Function Clone As IErlObject
Public Function Clone As IErlObject
public:
virtual IErlObject^ Clone() sealed
public:
virtual IErlObject^ Clone() sealed
abstract Clone : unit -> IErlObject
override Clone : unit -> IErlObject
abstract Clone : unit -> IErlObject
override Clone : unit -> IErlObject

Return Value

Type: IErlObject

Implements

IErlObject Clone
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.CompareTo Method

ErlAtom CompareTo Method NFX Class Library

Overload List
 | Name | Description
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the atom is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the atom is less than obj, positive - greater than the obj
Back to Top
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.CompareTo Method (Object)

ErlAtom CompareTo Method (Object) NFX Class Library

Compare this instance to the object. Negative value means that the atom is less than obj, positive - greater than the obj

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    Object obj
)
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
Public Function CompareTo (
    obj As Object
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
public:
virtual int CompareTo(
    Object^ obj
) sealed
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int

Parameters

obj
Type: Online System Object

Return Value

Type: Online Int32

Implements

Online IComparable CompareTo(Object)
See Also
ErlAtom Structure
ErlAtom Members
CompareTo Overload
NFX.Erlang Namespace


ErlAtom.CompareTo Method (IErlObject)

ErlAtom CompareTo Method (IErlObject) NFX Class Library

Compare this instance to the IErlObject. Negative value means that the atom is less than obj, positive - greater than the obj

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    IErlObject obj
)
public int CompareTo(
    IErlObject obj
)
Public Function CompareTo (
    obj As IErlObject
) As Integer
Public Function CompareTo (
    obj As IErlObject
) As Integer
public:
virtual int CompareTo(
    IErlObject^ obj
) sealed
public:
virtual int CompareTo(
    IErlObject^ obj
) sealed
abstract CompareTo :
        obj : IErlObject -> int
override CompareTo :
        obj : IErlObject -> int
abstract CompareTo :
        obj : IErlObject -> int
override CompareTo :
        obj : IErlObject -> int

Parameters

obj
Type: NFX.Erlang IErlObject

Return Value

Type: Online Int32

Implements

Online IComparable T CompareTo(T)
See Also
ErlAtom Structure
ErlAtom Members
CompareTo Overload
NFX.Erlang Namespace


ErlAtom.Equals Method

ErlAtom Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | Determine if this atom equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(IErlObject) | Determine if two atoms are equal
Back to Top
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.Equals Method (Object)

ErlAtom Equals Method (Object) NFX Class Library

Determine if this atom equals to the object

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals (
    o As Object
) As Boolean
Public Overrides Function Equals (
    o As Object
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool

Parameters

o
Type: Online System Object

Return Value

Type: Online Boolean
See Also
ErlAtom Structure
ErlAtom Members
Equals Overload
NFX.Erlang Namespace


ErlAtom.Equals Method (IErlObject)

ErlAtom Equals Method (IErlObject) NFX Class Library

Determine if two atoms are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    IErlObject o
)
public bool Equals(
    IErlObject o
)
Public Function Equals (
    o As IErlObject
) As Boolean
Public Function Equals (
    o As IErlObject
) As Boolean
public:
virtual bool Equals(
    IErlObject^ o
) sealed
public:
virtual bool Equals(
    IErlObject^ o
) sealed
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool

Parameters

o
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
ErlAtom Structure
ErlAtom Members
Equals Overload
NFX.Erlang Namespace


ErlAtom.GetHashCode Method

ErlAtom GetHashCode Method NFX Class Library

Get internal hash code

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.Match Method

ErlAtom Match Method NFX Class Library

Overload List
 | Name | Description
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Back to Top
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.Match Method (IErlObject)

ErlAtom Match Method (IErlObject) NFX Class Library

Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlVarBind Match(
    IErlObject pattern
)
public ErlVarBind Match(
    IErlObject pattern
)
Public Function Match (
    pattern As IErlObject
) As ErlVarBind
Public Function Match (
    pattern As IErlObject
) As ErlVarBind
public:
virtual ErlVarBind^ Match(
    IErlObject^ pattern
) sealed
public:
virtual ErlVarBind^ Match(
    IErlObject^ pattern
) sealed
abstract Match :
        pattern : IErlObject -> ErlVarBind
override Match :
        pattern : IErlObject -> ErlVarBind
abstract Match :
        pattern : IErlObject -> ErlVarBind
override Match :
        pattern : IErlObject -> ErlVarBind

Parameters

pattern
Type: NFX.Erlang IErlObject

Return Value

Type: ErlVarBind

Implements

IErlObject Match(IErlObject)
See Also
ErlAtom Structure
ErlAtom Members
Match Overload
NFX.Erlang Namespace


ErlAtom.Match Method (IErlObject, ErlVarBind)

ErlAtom Match Method (IErlObject, ErlVarBind) NFX Class Library

[This is preliminary documentation and is subject to change.]

Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Match(
    IErlObject pattern,
    ErlVarBind binding
)
public bool Match(
    IErlObject pattern,
    ErlVarBind binding
)
Public Function Match (
    pattern As IErlObject,
    binding As ErlVarBind
) As Boolean
Public Function Match (
    pattern As IErlObject,
    binding As ErlVarBind
) As Boolean
public:
virtual bool Match(
    IErlObject^ pattern,
    ErlVarBind^ binding
) sealed
public:
virtual bool Match(
    IErlObject^ pattern,
    ErlVarBind^ binding
) sealed
abstract Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
override Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
abstract Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
override Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool

Parameters

pattern
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind

Return Value

Type: Online Boolean

Implements

IErlObject Match(IErlObject, ErlVarBind)
See Also
ErlAtom Structure
ErlAtom Members
Match Overload
NFX.Erlang Namespace


ErlAtom.Matches Method

ErlAtom Matches Method NFX Class Library

Perform pattern match on this Erlang term without binding any variables

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Matches(
    IErlObject pattern
)
public bool Matches(
    IErlObject pattern
)
Public Function Matches (
    pattern As IErlObject
) As Boolean
Public Function Matches (
    pattern As IErlObject
) As Boolean
public:
virtual bool Matches(
    IErlObject^ pattern
) sealed
public:
virtual bool Matches(
    IErlObject^ pattern
) sealed
abstract Matches :
        pattern : IErlObject -> bool
override Matches :
        pattern : IErlObject -> bool
abstract Matches :
        pattern : IErlObject -> bool
override Matches :
        pattern : IErlObject -> bool

Parameters

pattern
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Implements

IErlObject Matches(IErlObject)
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.Subst Method

ErlAtom Subst Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Subst(
    ref IErlObject term,
    ErlVarBind binding
)
public bool Subst(
    ref IErlObject term,
    ErlVarBind binding
)
Public Function Subst (
    ByRef term As IErlObject,
    binding As ErlVarBind
) As Boolean
Public Function Subst (
    ByRef term As IErlObject,
    binding As ErlVarBind
) As Boolean
public:
virtual bool Subst(
    IErlObject^% term,
    ErlVarBind^ binding
) sealed
public:
virtual bool Subst(
    IErlObject^% term,
    ErlVarBind^ binding
) sealed
abstract Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
override Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
abstract Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
override Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool

Parameters

term
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind

Return Value

Type: Online Boolean

Implements

IErlObject Subst(IErlObject , ErlVarBind)
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.ToString Method

ErlAtom ToString Method NFX Class Library

Get the printname of the atom represented by this object. The difference between this method and {link #atomValue atomValue()} is that the printname is quoted and escaped where necessary, according to the Erlang rules for atom naming

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.Visit(TAccumulate) Method

ErlAtom Visit TAccumulate Method NFX Class Library

Execute fun for every nested term

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TAccumulate Visit<TAccumulate>(
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
public TAccumulate Visit<TAccumulate>(
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
Public Function Visit(Of TAccumulate) (
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
Public Function Visit(Of TAccumulate) (
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
public:
generic<typename TAccumulate>
virtual TAccumulate Visit(
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
) sealed
public:
generic<typename TAccumulate>
virtual TAccumulate Visit(
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
) sealed
abstract Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
override Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
abstract Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
override Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate

Parameters

acc
Type: TAccumulate
fun
Type: Online System Func TAccumulate, IErlObject, TAccumulate
Type Parameters
TAccumulate

Return Value

Type: TAccumulate

Implements

IErlObject Visit TAccumulate (TAccumulate, Func TAccumulate, IErlObject, TAccumulate )
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom Operators and Type Conversions

ErlAtom Operators and Type Conversions NFX Class Library

The ErlAtom type exposes the following members.
Operators
Name | Description
Equality |
(String to ErlAtom) | Implicit conversion of string to atom
(ErlAtom to String) | Implicit conversion of atom to string
Inequality |
Back to Top
See Also
ErlAtom Structure
NFX.Erlang Namespace


ErlAtom.Equality Operator

ErlAtom Equality Operator NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    ErlAtom lhs,
    ErlAtom rhs
)
public static bool operator ==(
    ErlAtom lhs,
    ErlAtom rhs
)
Public Shared Operator = (
    lhs As ErlAtom,
    rhs As ErlAtom
) As Boolean
Public Shared Operator = (
    lhs As ErlAtom,
    rhs As ErlAtom
) As Boolean
public:
static bool operator ==(
    ErlAtom lhs,
    ErlAtom rhs
)
public:
static bool operator ==(
    ErlAtom lhs,
    ErlAtom rhs
)
static let inline (=)
        lhs : ErlAtom *
        rhs : ErlAtom  : bool
static let inline (=)
        lhs : ErlAtom *
        rhs : ErlAtom  : bool

Parameters

lhs
Type: NFX.Erlang ErlAtom
rhs
Type: NFX.Erlang ErlAtom

Return Value

Type: Online Boolean
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom Implicit Conversion Operators

ErlAtom Conversion Operators NFX Class Library

Overload List
Name | Description
(String to ErlAtom) | Implicit conversion of string to atom
(ErlAtom to String) | Implicit conversion of atom to string
Back to Top
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom Implicit Conversion (String to ErlAtom)

ErlAtom Conversion (String to ErlAtom) NFX Class Library

Implicit conversion of string to atom

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static implicit operator ErlAtom (
    string a
)
public static implicit operator ErlAtom (
    string a
)
Public Shared Widening Operator CType (
    a As String
) As ErlAtom
Public Shared Widening Operator CType (
    a As String
) As ErlAtom
static implicit operator ErlAtom (
    String^ a
)
static implicit operator ErlAtom (
    String^ a
)
F# does not support the declaration of new casting operators.
F# does not support the declaration of new casting operators.

Parameters

a
Type: Online System String

Return Value

Type: ErlAtom
See Also
ErlAtom Structure
ErlAtom Members
Overload
NFX.Erlang Namespace


ErlAtom Implicit Conversion (ErlAtom to String)

ErlAtom Conversion (ErlAtom to String) NFX Class Library

Implicit conversion of atom to string

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static implicit operator string (
    ErlAtom a
)
public static implicit operator string (
    ErlAtom a
)
Public Shared Widening Operator CType (
    a As ErlAtom
) As String
Public Shared Widening Operator CType (
    a As ErlAtom
) As String
static implicit operator String^ (
    ErlAtom a
)
static implicit operator String^ (
    ErlAtom a
)
F# does not support the declaration of new casting operators.
F# does not support the declaration of new casting operators.

Parameters

a
Type: NFX.Erlang ErlAtom

Return Value

Type: Online String
See Also
ErlAtom Structure
ErlAtom Members
Overload
NFX.Erlang Namespace


ErlAtom.Inequality Operator

ErlAtom Inequality Operator NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    ErlAtom lhs,
    ErlAtom rhs
)
public static bool operator !=(
    ErlAtom lhs,
    ErlAtom rhs
)
Public Shared Operator <> (
    lhs As ErlAtom,
    rhs As ErlAtom
) As Boolean
Public Shared Operator <> (
    lhs As ErlAtom,
    rhs As ErlAtom
) As Boolean
public:
static bool operator !=(
    ErlAtom lhs,
    ErlAtom rhs
)
public:
static bool operator !=(
    ErlAtom lhs,
    ErlAtom rhs
)
static let inline (<>)
        lhs : ErlAtom *
        rhs : ErlAtom  : bool
static let inline (<>)
        lhs : ErlAtom *
        rhs : ErlAtom  : bool

Parameters

lhs
Type: NFX.Erlang ErlAtom
rhs
Type: NFX.Erlang ErlAtom

Return Value

Type: Online Boolean
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom Properties

ErlAtom Properties NFX Class Library

The ErlAtom type exposes the following members.
Properties
 | Name | Description
Public property | Empty | Returns true if this instance equals ErlAtom.Null
Public property | IsScalar | Determines whether the underlying type is scalar or complex (i.e. tuple, list)
Public property | Length | Return the length of the atom string
Public property | TypeOrder |
Public property | Value | Get the actual string contained in this object
Public property | ValueAsBool |
Public property | ValueAsByteArray |
Public property | ValueAsChar |
Public property | ValueAsDateTime |
Public property | ValueAsDecimal |
Public property | ValueAsDouble |
Public property | ValueAsInt |
Public property | ValueAsLong |
Public property | ValueAsObject |
Public property | ValueAsString |
Public property | ValueAsTimeSpan |
Back to Top
See Also
ErlAtom Structure
NFX.Erlang Namespace


ErlAtom.Empty Property

ErlAtom Empty Property NFX Class Library

Returns true if this instance equals ErlAtom.Null

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Empty { get; }
public bool Empty { get; }
Public ReadOnly Property Empty As Boolean
    Get
Public ReadOnly Property Empty As Boolean
    Get
public:
property bool Empty {
    bool get ();
}
public:
property bool Empty {
    bool get ();
}
member Empty : bool with get
member Empty : bool with get

Property Value

Type: Online Boolean
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.IsScalar Property

ErlAtom IsScalar Property NFX Class Library

Determines whether the underlying type is scalar or complex (i.e. tuple, list)

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsScalar { get; }
public bool IsScalar { get; }
Public ReadOnly Property IsScalar As Boolean
    Get
Public ReadOnly Property IsScalar As Boolean
    Get
public:
virtual property bool IsScalar {
    bool get () sealed;
}
public:
virtual property bool IsScalar {
    bool get () sealed;
}
abstract IsScalar : bool with get
override IsScalar : bool with get
abstract IsScalar : bool with get
override IsScalar : bool with get

Property Value

Type: Online Boolean

Implements

IErlObject IsScalar
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.Length Property

ErlAtom Length Property NFX Class Library

Return the length of the atom string

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Length { get; }
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get
Public ReadOnly Property Length As Integer
    Get
public:
property int Length {
    int get ();
}
public:
property int Length {
    int get ();
}
member Length : int with get
member Length : int with get

Property Value

Type: Online Int32
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.TypeOrder Property

ErlAtom TypeOrder Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTypeOrder TypeOrder { get; }
public ErlTypeOrder TypeOrder { get; }
Public ReadOnly Property TypeOrder As ErlTypeOrder
    Get
Public ReadOnly Property TypeOrder As ErlTypeOrder
    Get
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () sealed;
}
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () sealed;
}
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get

Property Value

Type: ErlTypeOrder

Implements

IErlObject TypeOrder
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.Value Property

ErlAtom Value Property NFX Class Library

Get the actual string contained in this object

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Value { get; }
public string Value { get; }
Public ReadOnly Property Value As String
    Get
Public ReadOnly Property Value As String
    Get
public:
virtual property String^ Value {
    String^ get () sealed;
}
public:
virtual property String^ Value {
    String^ get () sealed;
}
abstract Value : string with get
override Value : string with get
abstract Value : string with get
override Value : string with get

Property Value

Type: Online String

Implements

IErlObject T Value
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.ValueAsBool Property

ErlAtom ValueAsBool Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ValueAsBool { get; }
public bool ValueAsBool { get; }
Public ReadOnly Property ValueAsBool As Boolean
    Get
Public ReadOnly Property ValueAsBool As Boolean
    Get
public:
virtual property bool ValueAsBool {
    bool get () sealed;
}
public:
virtual property bool ValueAsBool {
    bool get () sealed;
}
abstract ValueAsBool : bool with get
override ValueAsBool : bool with get
abstract ValueAsBool : bool with get
override ValueAsBool : bool with get

Property Value

Type: Online Boolean

Implements

IErlObject ValueAsBool
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.ValueAsByteArray Property

ErlAtom ValueAsByteArray Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] ValueAsByteArray { get; }
public byte[] ValueAsByteArray { get; }
Public ReadOnly Property ValueAsByteArray As Byte()
    Get
Public ReadOnly Property ValueAsByteArray As Byte()
    Get
public:
virtual property array<unsigned char>^ ValueAsByteArray {
    array<unsigned char>^ get () sealed;
}
public:
virtual property array<unsigned char>^ ValueAsByteArray {
    array<unsigned char>^ get () sealed;
}
abstract ValueAsByteArray : byte[] with get
override ValueAsByteArray : byte[] with get
abstract ValueAsByteArray : byte[] with get
override ValueAsByteArray : byte[] with get

Property Value

Type: Online Byte

Implements

IErlObject ValueAsByteArray
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.ValueAsChar Property

ErlAtom ValueAsChar Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char ValueAsChar { get; }
public char ValueAsChar { get; }
Public ReadOnly Property ValueAsChar As Char
    Get
Public ReadOnly Property ValueAsChar As Char
    Get
public:
virtual property wchar_t ValueAsChar {
    wchar_t get () sealed;
}
public:
virtual property wchar_t ValueAsChar {
    wchar_t get () sealed;
}
abstract ValueAsChar : char with get
override ValueAsChar : char with get
abstract ValueAsChar : char with get
override ValueAsChar : char with get

Property Value

Type: Online Char

Implements

IErlObject ValueAsChar
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.ValueAsDateTime Property

ErlAtom ValueAsDateTime Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime ValueAsDateTime { get; }
public DateTime ValueAsDateTime { get; }
Public ReadOnly Property ValueAsDateTime As DateTime
    Get
Public ReadOnly Property ValueAsDateTime As DateTime
    Get
public:
virtual property DateTime ValueAsDateTime {
    DateTime get () sealed;
}
public:
virtual property DateTime ValueAsDateTime {
    DateTime get () sealed;
}
abstract ValueAsDateTime : DateTime with get
override ValueAsDateTime : DateTime with get
abstract ValueAsDateTime : DateTime with get
override ValueAsDateTime : DateTime with get

Property Value

Type: Online DateTime

Implements

IErlObject ValueAsDateTime
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.ValueAsDecimal Property

ErlAtom ValueAsDecimal Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal ValueAsDecimal { get; }
public decimal ValueAsDecimal { get; }
Public ReadOnly Property ValueAsDecimal As Decimal
    Get
Public ReadOnly Property ValueAsDecimal As Decimal
    Get
public:
virtual property Decimal ValueAsDecimal {
    Decimal get () sealed;
}
public:
virtual property Decimal ValueAsDecimal {
    Decimal get () sealed;
}
abstract ValueAsDecimal : decimal with get
override ValueAsDecimal : decimal with get
abstract ValueAsDecimal : decimal with get
override ValueAsDecimal : decimal with get

Property Value

Type: Online Decimal

Implements

IErlObject ValueAsDecimal
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.ValueAsDouble Property

ErlAtom ValueAsDouble Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double ValueAsDouble { get; }
public double ValueAsDouble { get; }
Public ReadOnly Property ValueAsDouble As Double
    Get
Public ReadOnly Property ValueAsDouble As Double
    Get
public:
virtual property double ValueAsDouble {
    double get () sealed;
}
public:
virtual property double ValueAsDouble {
    double get () sealed;
}
abstract ValueAsDouble : float with get
override ValueAsDouble : float with get
abstract ValueAsDouble : float with get
override ValueAsDouble : float with get

Property Value

Type: Online Double

Implements

IErlObject ValueAsDouble
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.ValueAsInt Property

ErlAtom ValueAsInt Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ValueAsInt { get; }
public int ValueAsInt { get; }
Public ReadOnly Property ValueAsInt As Integer
    Get
Public ReadOnly Property ValueAsInt As Integer
    Get
public:
virtual property int ValueAsInt {
    int get () sealed;
}
public:
virtual property int ValueAsInt {
    int get () sealed;
}
abstract ValueAsInt : int with get
override ValueAsInt : int with get
abstract ValueAsInt : int with get
override ValueAsInt : int with get

Property Value

Type: Online Int32

Implements

IErlObject ValueAsInt
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.ValueAsLong Property

ErlAtom ValueAsLong Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long ValueAsLong { get; }
public long ValueAsLong { get; }
Public ReadOnly Property ValueAsLong As Long
    Get
Public ReadOnly Property ValueAsLong As Long
    Get
public:
virtual property long long ValueAsLong {
    long long get () sealed;
}
public:
virtual property long long ValueAsLong {
    long long get () sealed;
}
abstract ValueAsLong : int64 with get
override ValueAsLong : int64 with get
abstract ValueAsLong : int64 with get
override ValueAsLong : int64 with get

Property Value

Type: Online Int64

Implements

IErlObject ValueAsLong
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.ValueAsObject Property

ErlAtom ValueAsObject Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object ValueAsObject { get; }
public Object ValueAsObject { get; }
Public ReadOnly Property ValueAsObject As Object
    Get
Public ReadOnly Property ValueAsObject As Object
    Get
public:
virtual property Object^ ValueAsObject {
    Object^ get () sealed;
}
public:
virtual property Object^ ValueAsObject {
    Object^ get () sealed;
}
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get

Property Value

Type: Online Object

Implements

IErlObject ValueAsObject
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.ValueAsString Property

ErlAtom ValueAsString Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ValueAsString { get; }
public string ValueAsString { get; }
Public ReadOnly Property ValueAsString As String
    Get
Public ReadOnly Property ValueAsString As String
    Get
public:
virtual property String^ ValueAsString {
    String^ get () sealed;
}
public:
virtual property String^ ValueAsString {
    String^ get () sealed;
}
abstract ValueAsString : string with get
override ValueAsString : string with get
abstract ValueAsString : string with get
override ValueAsString : string with get

Property Value

Type: Online String

Implements

IErlObject ValueAsString
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAtom.ValueAsTimeSpan Property

ErlAtom ValueAsTimeSpan Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpan ValueAsTimeSpan { get; }
public TimeSpan ValueAsTimeSpan { get; }
Public ReadOnly Property ValueAsTimeSpan As TimeSpan
    Get
Public ReadOnly Property ValueAsTimeSpan As TimeSpan
    Get
public:
virtual property TimeSpan ValueAsTimeSpan {
    TimeSpan get () sealed;
}
public:
virtual property TimeSpan ValueAsTimeSpan {
    TimeSpan get () sealed;
}
abstract ValueAsTimeSpan : TimeSpan with get
override ValueAsTimeSpan : TimeSpan with get
abstract ValueAsTimeSpan : TimeSpan with get
override ValueAsTimeSpan : TimeSpan with get

Property Value

Type: Online TimeSpan

Implements

IErlObject ValueAsTimeSpan
See Also
ErlAtom Structure
ErlAtom Members
NFX.Erlang Namespace


ErlAuthException Class

ErlAuthException Class NFX Class Library

Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Erlang ErlException
NFX.Erlang ErlConnectionException
NFX.Erlang ErlAuthException

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ErlAuthException : ErlConnectionException
public class ErlAuthException : ErlConnectionException
Public Class ErlAuthException
    Inherits ErlConnectionException
Public Class ErlAuthException
    Inherits ErlConnectionException
public ref class ErlAuthException : public ErlConnectionException
public ref class ErlAuthException : public ErlConnectionException
type ErlAuthException =
    class
        inherit ErlConnectionException
    end
type ErlAuthException =
    class
        inherit ErlConnectionException
    end
See Also
ErlAuthException Members
NFX.Erlang Namespace


ErlAuthException Members

ErlAuthException Members NFX Class Library

The ErlAuthException type exposes the following members.
Constructors
 | Name | Description
Public method | ErlAuthException(ErlAtom, IErlObject) | Initializes a new instance of the ErlAuthException class
Public method | ErlAuthException(ErlAtom, String) | Initializes a new instance of the ErlAuthException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | Node | Name of the node that experienced connectivity loss (Inherited from ErlConnectionException.)
Public field | Reason | Get the reason associated with this exit signal (Inherited from ErlConnectionException.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Message | (Inherited from ErlConnectionException.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ErlAuthException Class
NFX.Erlang Namespace


ErlAuthException Constructor

ErlAuthException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ErlAuthException(ErlAtom, IErlObject) | Initializes a new instance of the ErlAuthException class
Public method | ErlAuthException(ErlAtom, String) | Initializes a new instance of the ErlAuthException class
Back to Top
See Also
ErlAuthException Class
ErlAuthException Members
NFX.Erlang Namespace


ErlAuthException Constructor (ErlAtom, IErlObject)

ErlAuthException Constructor (ErlAtom, IErlObject) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlAuthException class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlAuthException(
    ErlAtom nodeName,
    IErlObject reason
)
public ErlAuthException(
    ErlAtom nodeName,
    IErlObject reason
)
Public Sub New (
    nodeName As ErlAtom,
    reason As IErlObject
)
Public Sub New (
    nodeName As ErlAtom,
    reason As IErlObject
)
public:
ErlAuthException(
    ErlAtom nodeName,
    IErlObject^ reason
)
public:
ErlAuthException(
    ErlAtom nodeName,
    IErlObject^ reason
)
new :
        nodeName : ErlAtom *
        reason : IErlObject -> ErlAuthException
new :
        nodeName : ErlAtom *
        reason : IErlObject -> ErlAuthException

Parameters

nodeName
Type: NFX.Erlang ErlAtom
reason
Type: NFX.Erlang IErlObject
See Also
ErlAuthException Class
ErlAuthException Members
ErlAuthException Overload
NFX.Erlang Namespace


ErlAuthException Constructor (ErlAtom, String)

ErlAuthException Constructor (ErlAtom, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlAuthException class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlAuthException(
    ErlAtom nodeName,
    string reason
)
public ErlAuthException(
    ErlAtom nodeName,
    string reason
)
Public Sub New (
    nodeName As ErlAtom,
    reason As String
)
Public Sub New (
    nodeName As ErlAtom,
    reason As String
)
public:
ErlAuthException(
    ErlAtom nodeName,
    String^ reason
)
public:
ErlAuthException(
    ErlAtom nodeName,
    String^ reason
)
new :
        nodeName : ErlAtom *
        reason : string -> ErlAuthException
new :
        nodeName : ErlAtom *
        reason : string -> ErlAuthException

Parameters

nodeName
Type: NFX.Erlang ErlAtom
reason
Type: Online System String
See Also
ErlAuthException Class
ErlAuthException Members
ErlAuthException Overload
NFX.Erlang Namespace


ErlAuthException Fields

ErlAuthException Fields NFX Class Library

The ErlAuthException type exposes the following members.
Fields
 | Name | Description
Public field | Node | Name of the node that experienced connectivity loss (Inherited from ErlConnectionException.)
Public field | Reason | Get the reason associated with this exit signal (Inherited from ErlConnectionException.)
Back to Top
See Also
ErlAuthException Class
NFX.Erlang Namespace


ErlAuthException Methods

ErlAuthException Methods NFX Class Library

The ErlAuthException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
ErlAuthException Class
NFX.Erlang Namespace


ErlAuthException Properties

ErlAuthException Properties NFX Class Library

The ErlAuthException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Message | (Inherited from ErlConnectionException.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
ErlAuthException Class
NFX.Erlang Namespace


ErlAuthException Events

ErlAuthException Events NFX Class Library

The ErlAuthException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ErlAuthException Class
NFX.Erlang Namespace


ErlBadDataException Class

ErlBadDataException Class NFX Class Library

Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Erlang ErlException
NFX.Erlang ErlConnectionException
NFX.Erlang ErlBadDataException

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ErlBadDataException : ErlConnectionException
public class ErlBadDataException : ErlConnectionException
Public Class ErlBadDataException
    Inherits ErlConnectionException
Public Class ErlBadDataException
    Inherits ErlConnectionException
public ref class ErlBadDataException : public ErlConnectionException
public ref class ErlBadDataException : public ErlConnectionException
type ErlBadDataException =
    class
        inherit ErlConnectionException
    end
type ErlBadDataException =
    class
        inherit ErlConnectionException
    end
See Also
ErlBadDataException Members
NFX.Erlang Namespace


ErlBadDataException Members

ErlBadDataException Members NFX Class Library

The ErlBadDataException type exposes the following members.
Constructors
 | Name | Description
Public method | ErlBadDataException(ErlAtom, IErlObject) | Initializes a new instance of the ErlBadDataException class
Public method | ErlBadDataException(ErlAtom, String) | Initializes a new instance of the ErlBadDataException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | Node | Name of the node that experienced connectivity loss (Inherited from ErlConnectionException.)
Public field | Reason | Get the reason associated with this exit signal (Inherited from ErlConnectionException.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Message | (Inherited from ErlConnectionException.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ErlBadDataException Class
NFX.Erlang Namespace


ErlBadDataException Constructor

ErlBadDataException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ErlBadDataException(ErlAtom, IErlObject) | Initializes a new instance of the ErlBadDataException class
Public method | ErlBadDataException(ErlAtom, String) | Initializes a new instance of the ErlBadDataException class
Back to Top
See Also
ErlBadDataException Class
ErlBadDataException Members
NFX.Erlang Namespace


ErlBadDataException Constructor (ErlAtom, IErlObject)

ErlBadDataException Constructor (ErlAtom, IErlObject) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlBadDataException class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlBadDataException(
    ErlAtom nodeName,
    IErlObject reason
)
public ErlBadDataException(
    ErlAtom nodeName,
    IErlObject reason
)
Public Sub New (
    nodeName As ErlAtom,
    reason As IErlObject
)
Public Sub New (
    nodeName As ErlAtom,
    reason As IErlObject
)
public:
ErlBadDataException(
    ErlAtom nodeName,
    IErlObject^ reason
)
public:
ErlBadDataException(
    ErlAtom nodeName,
    IErlObject^ reason
)
new :
        nodeName : ErlAtom *
        reason : IErlObject -> ErlBadDataException
new :
        nodeName : ErlAtom *
        reason : IErlObject -> ErlBadDataException

Parameters

nodeName
Type: NFX.Erlang ErlAtom
reason
Type: NFX.Erlang IErlObject
See Also
ErlBadDataException Class
ErlBadDataException Members
ErlBadDataException Overload
NFX.Erlang Namespace


ErlBadDataException Constructor (ErlAtom, String)

ErlBadDataException Constructor (ErlAtom, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlBadDataException class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlBadDataException(
    ErlAtom nodeName,
    string reason
)
public ErlBadDataException(
    ErlAtom nodeName,
    string reason
)
Public Sub New (
    nodeName As ErlAtom,
    reason As String
)
Public Sub New (
    nodeName As ErlAtom,
    reason As String
)
public:
ErlBadDataException(
    ErlAtom nodeName,
    String^ reason
)
public:
ErlBadDataException(
    ErlAtom nodeName,
    String^ reason
)
new :
        nodeName : ErlAtom *
        reason : string -> ErlBadDataException
new :
        nodeName : ErlAtom *
        reason : string -> ErlBadDataException

Parameters

nodeName
Type: NFX.Erlang ErlAtom
reason
Type: Online System String
See Also
ErlBadDataException Class
ErlBadDataException Members
ErlBadDataException Overload
NFX.Erlang Namespace


ErlBadDataException Fields

ErlBadDataException Fields NFX Class Library

The ErlBadDataException type exposes the following members.
Fields
 | Name | Description
Public field | Node | Name of the node that experienced connectivity loss (Inherited from ErlConnectionException.)
Public field | Reason | Get the reason associated with this exit signal (Inherited from ErlConnectionException.)
Back to Top
See Also
ErlBadDataException Class
NFX.Erlang Namespace


ErlBadDataException Methods

ErlBadDataException Methods NFX Class Library

The ErlBadDataException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
ErlBadDataException Class
NFX.Erlang Namespace


ErlBadDataException Properties

ErlBadDataException Properties NFX Class Library

The ErlBadDataException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Message | (Inherited from ErlConnectionException.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
ErlBadDataException Class
NFX.Erlang Namespace


ErlBadDataException Events

ErlBadDataException Events NFX Class Library

The ErlBadDataException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ErlBadDataException Class
NFX.Erlang Namespace


ErlBinary Structure

ErlBinary Structure NFX Class Library

Provides a C# representation of Erlang integer types

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct ErlBinary : IErlObject<byte[]>,
    IErlObject, IComparable, IComparable<IErlObject>, IEquatable<IErlObject>,
    ICloneable
public struct ErlBinary : IErlObject<byte[]>,
    IErlObject, IComparable, IComparable<IErlObject>, IEquatable<IErlObject>,
    ICloneable
Public Structure ErlBinary
    Implements IErlObject(Of Byte()), IErlObject,
    IComparable, IComparable(Of IErlObject), IEquatable(Of IErlObject),
    ICloneable
Public Structure ErlBinary
    Implements IErlObject(Of Byte()), IErlObject,
    IComparable, IComparable(Of IErlObject), IEquatable(Of IErlObject),
    ICloneable
public value class ErlBinary : IErlObject<array<unsigned char>^>,
    IErlObject, IComparable, IComparable<IErlObject^>, IEquatable<IErlObject^>,
    ICloneable
public value class ErlBinary : IErlObject<array<unsigned char>^>,
    IErlObject, IComparable, IComparable<IErlObject^>, IEquatable<IErlObject^>,
    ICloneable
[<SealedAttribute>]
type ErlBinary =
    struct
        interface IErlObject<byte[]>
        interface IErlObject
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
    end
[<SealedAttribute>]
type ErlBinary =
    struct
        interface IErlObject<byte[]>
        interface IErlObject
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
    end
See Also
ErlBinary Members
NFX.Erlang Namespace


ErlBinary Members

ErlBinary Members NFX Class Library

The ErlBinary type exposes the following members.
Constructors
 | Name | Description
Public method | ErlBinary( Byte , Boolean) | Create an Erlang binary from the given value
Public method | ErlBinary( Byte , Int32, Int32) | Create an Erlang binary by copying its value from the given buffer
Back to Top
Methods
 | Name | Description
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj
Public method | Equals(Object) | Determine if this instance equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(ErlBinary) | Determine if two instances are equal
Public method | Equals(IErlObject) | Determine if two instances are equal
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Get internal hash code (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Public method | Matches | Perform pattern match on this Erlang term without binding any variables
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Subst |
Public method | ToBinaryString(Int32) | Returns binary representation of the string encoded as <<...>>
 | ToBinaryString( Byte , Int32, Int32, Int32) | Convert a byte buffer to printable binary representation (i.e. <<131,15,12,...>>)
Public method | ToPrintableString(Int32) | Returns printable binary representation of the string encoded as <<"abc...">>
 | ToPrintableString( Byte , Int32, Int32, Int32) | Convert a byte buffer to printable binary representation (i.e. <<"abc...">>)
Public method | ToString | (Overrides Online ValueType ToString .)
Public method | ToString(Encoding) |
Public method | Visit TAccumulate | Execute fun for every nested term
Back to Top
Operators
Name | Description
Equality |
(ErlBinary to Byte ) | Implicit conversion of ErlBinary to byte[]
Inequality |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | IsScalar |
Public property | Length | Return length of the binary byte array
Public property | TypeOrder |
Public property | Value |
Public property | ValueAsBool |
Public property | ValueAsByteArray |
Public property | ValueAsChar |
Public property | ValueAsDateTime |
Public property | ValueAsDecimal |
Public property | ValueAsDouble |
Public property | ValueAsInt |
Public property | ValueAsLong |
Public property | ValueAsObject |
Public property | ValueAsString |
Public property | ValueAsTimeSpan |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone |
Back to Top
See Also
ErlBinary Structure
NFX.Erlang Namespace


ErlBinary Constructor

ErlBinary Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ErlBinary( Byte , Boolean) | Create an Erlang binary from the given value
Public method | ErlBinary( Byte , Int32, Int32) | Create an Erlang binary by copying its value from the given buffer
Back to Top
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary Constructor (Byte[], Boolean)

ErlBinary Constructor ( Byte , Boolean) NFX Class Library

Create an Erlang binary from the given value

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlBinary(
    byte[] val,
    bool copy = true
)
public ErlBinary(
    byte[] val,
    bool copy = true
)
Public Sub New (
    val As Byte(),
    Optional copy As Boolean = true
)
Public Sub New (
    val As Byte(),
    Optional copy As Boolean = true
)
public:
ErlBinary(
    array<unsigned char>^ val,
    bool copy = true
)
public:
ErlBinary(
    array<unsigned char>^ val,
    bool copy = true
)
new :
        val : byte[] *
        ?copy : bool
(* Defaults:
        let _copy = defaultArg copy true
*)
-> ErlBinary
new :
        val : byte[] *
        ?copy : bool
(* Defaults:
        let _copy = defaultArg copy true
*)
-> ErlBinary

Parameters

val
Type: Online System Byte
copy (Optional)
Type: Online System Boolean
See Also
ErlBinary Structure
ErlBinary Members
ErlBinary Overload
NFX.Erlang Namespace


ErlBinary Constructor (Byte[], Int32, Int32)

ErlBinary Constructor ( Byte , Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Create an Erlang binary by copying its value from the given buffer

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlBinary(
    byte[] buf,
    int offset,
    int count
)
public ErlBinary(
    byte[] buf,
    int offset,
    int count
)
Public Sub New (
    buf As Byte(),
    offset As Integer,
    count As Integer
)
Public Sub New (
    buf As Byte(),
    offset As Integer,
    count As Integer
)
public:
ErlBinary(
    array<unsigned char>^ buf,
    int offset,
    int count
)
public:
ErlBinary(
    array<unsigned char>^ buf,
    int offset,
    int count
)
new :
        buf : byte[] *
        offset : int *
        count : int -> ErlBinary
new :
        buf : byte[] *
        offset : int *
        count : int -> ErlBinary

Parameters

buf
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32
See Also
ErlBinary Structure
ErlBinary Members
ErlBinary Overload
NFX.Erlang Namespace


ErlBinary Methods

ErlBinary Methods NFX Class Library

The ErlBinary type exposes the following members.
Methods
 | Name | Description
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj
Public method | Equals(Object) | Determine if this instance equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(ErlBinary) | Determine if two instances are equal
Public method | Equals(IErlObject) | Determine if two instances are equal
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Get internal hash code (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Public method | Matches | Perform pattern match on this Erlang term without binding any variables
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Subst |
Public method | ToBinaryString(Int32) | Returns binary representation of the string encoded as <<...>>
 | ToBinaryString( Byte , Int32, Int32, Int32) | Convert a byte buffer to printable binary representation (i.e. <<131,15,12,...>>)
Public method | ToPrintableString(Int32) | Returns printable binary representation of the string encoded as <<"abc...">>
 | ToPrintableString( Byte , Int32, Int32, Int32) | Convert a byte buffer to printable binary representation (i.e. <<"abc...">>)
Public method | ToString | (Overrides Online ValueType ToString .)
Public method | ToString(Encoding) |
Public method | Visit TAccumulate | Execute fun for every nested term
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone |
Back to Top
See Also
ErlBinary Structure
NFX.Erlang Namespace


ErlBinary.ICloneable.Clone Method

ErlBinary ICloneable Clone Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object ICloneable.Clone()
Object ICloneable.Clone()
Private Function Clone As Object Implements ICloneable.Clone
Private Function Clone As Object Implements ICloneable.Clone
private:
virtual Object^ Clone() sealed = ICloneable::Clone
private:
virtual Object^ Clone() sealed = ICloneable::Clone
private abstract Clone : unit -> Object
private override Clone : unit -> Object
private abstract Clone : unit -> Object
private override Clone : unit -> Object

Return Value

Type: Online Object

Implements

Online ICloneable Clone
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary.Clone Method

ErlBinary Clone Method NFX Class Library

Clone an instance of the object (non-scalar immutable objects are copied by reference)

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject Clone()
public IErlObject Clone()
Public Function Clone As IErlObject
Public Function Clone As IErlObject
public:
virtual IErlObject^ Clone() sealed
public:
virtual IErlObject^ Clone() sealed
abstract Clone : unit -> IErlObject
override Clone : unit -> IErlObject
abstract Clone : unit -> IErlObject
override Clone : unit -> IErlObject

Return Value

Type: IErlObject

Implements

IErlObject Clone
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary.CompareTo Method

ErlBinary CompareTo Method NFX Class Library

Overload List
 | Name | Description
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj
Back to Top
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary.CompareTo Method (Object)

ErlBinary CompareTo Method (Object) NFX Class Library

Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    Object obj
)
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
Public Function CompareTo (
    obj As Object
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
public:
virtual int CompareTo(
    Object^ obj
) sealed
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int

Parameters

obj
Type: Online System Object

Return Value

Type: Online Int32

Implements

Online IComparable CompareTo(Object)
See Also
ErlBinary Structure
ErlBinary Members
CompareTo Overload
NFX.Erlang Namespace


ErlBinary.CompareTo Method (IErlObject)

ErlBinary CompareTo Method (IErlObject) NFX Class Library

Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    IErlObject obj
)
public int CompareTo(
    IErlObject obj
)
Public Function CompareTo (
    obj As IErlObject
) As Integer
Public Function CompareTo (
    obj As IErlObject
) As Integer
public:
virtual int CompareTo(
    IErlObject^ obj
) sealed
public:
virtual int CompareTo(
    IErlObject^ obj
) sealed
abstract CompareTo :
        obj : IErlObject -> int
override CompareTo :
        obj : IErlObject -> int
abstract CompareTo :
        obj : IErlObject -> int
override CompareTo :
        obj : IErlObject -> int

Parameters

obj
Type: NFX.Erlang IErlObject

Return Value

Type: Online Int32

Implements

Online IComparable T CompareTo(T)
See Also
ErlBinary Structure
ErlBinary Members
CompareTo Overload
NFX.Erlang Namespace


ErlBinary.Equals Method

ErlBinary Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | Determine if this instance equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(ErlBinary) | Determine if two instances are equal
Public method | Equals(IErlObject) | Determine if two instances are equal
Back to Top
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary.Equals Method (Object)

ErlBinary Equals Method (Object) NFX Class Library

Determine if this instance equals to the object

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals (
    o As Object
) As Boolean
Public Overrides Function Equals (
    o As Object
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool

Parameters

o
Type: Online System Object

Return Value

Type: Online Boolean
See Also
ErlBinary Structure
ErlBinary Members
Equals Overload
NFX.Erlang Namespace


ErlBinary.Equals Method (ErlBinary)

ErlBinary Equals Method (ErlBinary) NFX Class Library

Determine if two instances are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    ErlBinary rhs
)
public bool Equals(
    ErlBinary rhs
)
Public Function Equals (
    rhs As ErlBinary
) As Boolean
Public Function Equals (
    rhs As ErlBinary
) As Boolean
public:
bool Equals(
    ErlBinary rhs
)
public:
bool Equals(
    ErlBinary rhs
)
member Equals :
        rhs : ErlBinary -> bool
member Equals :
        rhs : ErlBinary -> bool

Parameters

rhs
Type: NFX.Erlang ErlBinary

Return Value

Type: Online Boolean
See Also
ErlBinary Structure
ErlBinary Members
Equals Overload
NFX.Erlang Namespace


ErlBinary.Equals Method (IErlObject)

ErlBinary Equals Method (IErlObject) NFX Class Library

Determine if two instances are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    IErlObject o
)
public bool Equals(
    IErlObject o
)
Public Function Equals (
    o As IErlObject
) As Boolean
Public Function Equals (
    o As IErlObject
) As Boolean
public:
virtual bool Equals(
    IErlObject^ o
) sealed
public:
virtual bool Equals(
    IErlObject^ o
) sealed
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool

Parameters

o
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
ErlBinary Structure
ErlBinary Members
Equals Overload
NFX.Erlang Namespace


ErlBinary.GetHashCode Method

ErlBinary GetHashCode Method NFX Class Library

Get internal hash code

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary.Match Method

ErlBinary Match Method NFX Class Library

Overload List
 | Name | Description
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Back to Top
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary.Match Method (IErlObject)

ErlBinary Match Method (IErlObject) NFX Class Library

Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlVarBind Match(
    IErlObject pattern
)
public ErlVarBind Match(
    IErlObject pattern
)
Public Function Match (
    pattern As IErlObject
) As ErlVarBind
Public Function Match (
    pattern As IErlObject
) As ErlVarBind
public:
virtual ErlVarBind^ Match(
    IErlObject^ pattern
) sealed
public:
virtual ErlVarBind^ Match(
    IErlObject^ pattern
) sealed
abstract Match :
        pattern : IErlObject -> ErlVarBind
override Match :
        pattern : IErlObject -> ErlVarBind
abstract Match :
        pattern : IErlObject -> ErlVarBind
override Match :
        pattern : IErlObject -> ErlVarBind

Parameters

pattern
Type: NFX.Erlang IErlObject

Return Value

Type: ErlVarBind

Implements

IErlObject Match(IErlObject)
See Also
ErlBinary Structure
ErlBinary Members
Match Overload
NFX.Erlang Namespace


ErlBinary.Match Method (IErlObject, ErlVarBind)

ErlBinary Match Method (IErlObject, ErlVarBind) NFX Class Library

[This is preliminary documentation and is subject to change.]

Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Match(
    IErlObject pattern,
    ErlVarBind binding
)
public bool Match(
    IErlObject pattern,
    ErlVarBind binding
)
Public Function Match (
    pattern As IErlObject,
    binding As ErlVarBind
) As Boolean
Public Function Match (
    pattern As IErlObject,
    binding As ErlVarBind
) As Boolean
public:
virtual bool Match(
    IErlObject^ pattern,
    ErlVarBind^ binding
) sealed
public:
virtual bool Match(
    IErlObject^ pattern,
    ErlVarBind^ binding
) sealed
abstract Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
override Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
abstract Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
override Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool

Parameters

pattern
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind

Return Value

Type: Online Boolean

Implements

IErlObject Match(IErlObject, ErlVarBind)
See Also
ErlBinary Structure
ErlBinary Members
Match Overload
NFX.Erlang Namespace


ErlBinary.Matches Method

ErlBinary Matches Method NFX Class Library

Perform pattern match on this Erlang term without binding any variables

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Matches(
    IErlObject pattern
)
public bool Matches(
    IErlObject pattern
)
Public Function Matches (
    pattern As IErlObject
) As Boolean
Public Function Matches (
    pattern As IErlObject
) As Boolean
public:
virtual bool Matches(
    IErlObject^ pattern
) sealed
public:
virtual bool Matches(
    IErlObject^ pattern
) sealed
abstract Matches :
        pattern : IErlObject -> bool
override Matches :
        pattern : IErlObject -> bool
abstract Matches :
        pattern : IErlObject -> bool
override Matches :
        pattern : IErlObject -> bool

Parameters

pattern
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Implements

IErlObject Matches(IErlObject)
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary.Subst Method

ErlBinary Subst Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Subst(
    ref IErlObject term,
    ErlVarBind binding
)
public bool Subst(
    ref IErlObject term,
    ErlVarBind binding
)
Public Function Subst (
    ByRef term As IErlObject,
    binding As ErlVarBind
) As Boolean
Public Function Subst (
    ByRef term As IErlObject,
    binding As ErlVarBind
) As Boolean
public:
virtual bool Subst(
    IErlObject^% term,
    ErlVarBind^ binding
) sealed
public:
virtual bool Subst(
    IErlObject^% term,
    ErlVarBind^ binding
) sealed
abstract Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
override Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
abstract Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
override Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool

Parameters

term
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind

Return Value

Type: Online Boolean

Implements

IErlObject Subst(IErlObject , ErlVarBind)
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary.ToBinaryString Method

ErlBinary ToBinaryString Method NFX Class Library

Overload List
 | Name | Description
Public method | ToBinaryString(Int32) | Returns binary representation of the string encoded as <<...>>
 | ToBinaryString( Byte , Int32, Int32, Int32) | Convert a byte buffer to printable binary representation (i.e. <<131,15,12,...>>)
Back to Top
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary.ToBinaryString Method (Int32)

ErlBinary ToBinaryString Method (Int32) NFX Class Library

Returns binary representation of the string encoded as <<...>>

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ToBinaryString(
    int maxLen = 0
)
public string ToBinaryString(
    int maxLen = 0
)
Public Function ToBinaryString (
    Optional maxLen As Integer = 0
) As String
Public Function ToBinaryString (
    Optional maxLen As Integer = 0
) As String
public:
String^ ToBinaryString(
    int maxLen = 0
)
public:
String^ ToBinaryString(
    int maxLen = 0
)
member ToBinaryString :
        ?maxLen : int
(* Defaults:
        let _maxLen = defaultArg maxLen 0
*)
-> string
member ToBinaryString :
        ?maxLen : int
(* Defaults:
        let _maxLen = defaultArg maxLen 0
*)
-> string

Parameters

maxLen (Optional)
Type: Online System Int32

Return Value

Type: Online String
See Also
ErlBinary Structure
ErlBinary Members
ToBinaryString Overload
NFX.Erlang Namespace


ErlBinary.ToBinaryString Method (Byte[], Int32, Int32, Int32)

ErlBinary ToBinaryString Method ( Byte , Int32, Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Convert a byte buffer to printable binary representation (i.e. <<131,15,12,...>>)

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ToBinaryString(
    byte[] buf,
    int offset,
    int count,
    int maxLen = 0
)
public static string ToBinaryString(
    byte[] buf,
    int offset,
    int count,
    int maxLen = 0
)
Public Shared Function ToBinaryString (
    buf As Byte(),
    offset As Integer,
    count As Integer,
    Optional maxLen As Integer = 0
) As String
Public Shared Function ToBinaryString (
    buf As Byte(),
    offset As Integer,
    count As Integer,
    Optional maxLen As Integer = 0
) As String
public:
static String^ ToBinaryString(
    array<unsigned char>^ buf,
    int offset,
    int count,
    int maxLen = 0
)
public:
static String^ ToBinaryString(
    array<unsigned char>^ buf,
    int offset,
    int count,
    int maxLen = 0
)
static member ToBinaryString :
        buf : byte[] *
        offset : int *
        count : int *
        ?maxLen : int
(* Defaults:
        let _maxLen = defaultArg maxLen 0
*)
-> string
static member ToBinaryString :
        buf : byte[] *
        offset : int *
        count : int *
        ?maxLen : int
(* Defaults:
        let _maxLen = defaultArg maxLen 0
*)
-> string

Parameters

buf
Type: Online System Byte
Buffer to convert
offset
Type: Online System Int32
Offset in the buffer
count
Type: Online System Int32
Number of bytes to convert
maxLen (Optional)
Type: Online System Int32
Maximum allowed length of returned string. If given, and resulting string exceeds this value, it'll be trimmed to this length ending with "...>>"

Return Value

Type: Online String
See Also
ErlBinary Structure
ErlBinary Members
ToBinaryString Overload
NFX.Erlang Namespace


ErlBinary.ToPrintableString Method

ErlBinary ToPrintableString Method NFX Class Library

Overload List
 | Name | Description
Public method | ToPrintableString(Int32) | Returns printable binary representation of the string encoded as <<"abc...">>
 | ToPrintableString( Byte , Int32, Int32, Int32) | Convert a byte buffer to printable binary representation (i.e. <<"abc...">>)
Back to Top
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary.ToPrintableString Method (Int32)

ErlBinary ToPrintableString Method (Int32) NFX Class Library

Returns printable binary representation of the string encoded as <<"abc...">>

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ToPrintableString(
    int maxLen = 0
)
public string ToPrintableString(
    int maxLen = 0
)
Public Function ToPrintableString (
    Optional maxLen As Integer = 0
) As String
Public Function ToPrintableString (
    Optional maxLen As Integer = 0
) As String
public:
String^ ToPrintableString(
    int maxLen = 0
)
public:
String^ ToPrintableString(
    int maxLen = 0
)
member ToPrintableString :
        ?maxLen : int
(* Defaults:
        let _maxLen = defaultArg maxLen 0
*)
-> string
member ToPrintableString :
        ?maxLen : int
(* Defaults:
        let _maxLen = defaultArg maxLen 0
*)
-> string

Parameters

maxLen (Optional)
Type: Online System Int32

Return Value

Type: Online String
See Also
ErlBinary Structure
ErlBinary Members
ToPrintableString Overload
NFX.Erlang Namespace


ErlBinary.ToPrintableString Method (Byte[], Int32, Int32, Int32)

ErlBinary ToPrintableString Method ( Byte , Int32, Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Convert a byte buffer to printable binary representation (i.e. <<"abc...">>)

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ToPrintableString(
    byte[] buf,
    int offset,
    int count,
    int maxLen = 0
)
public static string ToPrintableString(
    byte[] buf,
    int offset,
    int count,
    int maxLen = 0
)
Public Shared Function ToPrintableString (
    buf As Byte(),
    offset As Integer,
    count As Integer,
    Optional maxLen As Integer = 0
) As String
Public Shared Function ToPrintableString (
    buf As Byte(),
    offset As Integer,
    count As Integer,
    Optional maxLen As Integer = 0
) As String
public:
static String^ ToPrintableString(
    array<unsigned char>^ buf,
    int offset,
    int count,
    int maxLen = 0
)
public:
static String^ ToPrintableString(
    array<unsigned char>^ buf,
    int offset,
    int count,
    int maxLen = 0
)
static member ToPrintableString :
        buf : byte[] *
        offset : int *
        count : int *
        ?maxLen : int
(* Defaults:
        let _maxLen = defaultArg maxLen 0
*)
-> string
static member ToPrintableString :
        buf : byte[] *
        offset : int *
        count : int *
        ?maxLen : int
(* Defaults:
        let _maxLen = defaultArg maxLen 0
*)
-> string

Parameters

buf
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32
maxLen (Optional)
Type: Online System Int32

Return Value

Type: Online String
See Also
ErlBinary Structure
ErlBinary Members
ToPrintableString Overload
NFX.Erlang Namespace


ErlBinary.ToString Method

ErlBinary ToString Method NFX Class Library

Overload List
 | Name | Description
Public method | ToString | (Overrides Online ValueType ToString .)
Public method | ToString(Encoding) |
Back to Top
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary.ToString Method

ErlBinary ToString Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
ErlBinary Structure
ErlBinary Members
ToString Overload
NFX.Erlang Namespace


ErlBinary.ToString Method (Encoding)

ErlBinary ToString Method (Encoding) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ToString(
    Encoding encoding
)
public string ToString(
    Encoding encoding
)
Public Function ToString (
    encoding As Encoding
) As String
Public Function ToString (
    encoding As Encoding
) As String
public:
String^ ToString(
    Encoding^ encoding
)
public:
String^ ToString(
    Encoding^ encoding
)
member ToString :
        encoding : Encoding -> string
member ToString :
        encoding : Encoding -> string

Parameters

encoding
Type: Online System.Text Encoding

Return Value

Type: Online String
See Also
ErlBinary Structure
ErlBinary Members
ToString Overload
NFX.Erlang Namespace


ErlBinary.Visit(TAccumulate) Method

ErlBinary Visit TAccumulate Method NFX Class Library

Execute fun for every nested term

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TAccumulate Visit<TAccumulate>(
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
public TAccumulate Visit<TAccumulate>(
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
Public Function Visit(Of TAccumulate) (
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
Public Function Visit(Of TAccumulate) (
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
public:
generic<typename TAccumulate>
virtual TAccumulate Visit(
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
) sealed
public:
generic<typename TAccumulate>
virtual TAccumulate Visit(
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
) sealed
abstract Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
override Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
abstract Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
override Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate

Parameters

acc
Type: TAccumulate
fun
Type: Online System Func TAccumulate, IErlObject, TAccumulate
Type Parameters
TAccumulate

Return Value

Type: TAccumulate

Implements

IErlObject Visit TAccumulate (TAccumulate, Func TAccumulate, IErlObject, TAccumulate )
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary Operators and Type Conversions

ErlBinary Operators and Type Conversions NFX Class Library

The ErlBinary type exposes the following members.
Operators
Name | Description
Equality |
(ErlBinary to Byte ) | Implicit conversion of ErlBinary to byte[]
Inequality |
Back to Top
See Also
ErlBinary Structure
NFX.Erlang Namespace


ErlBinary.Equality Operator

ErlBinary Equality Operator NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    ErlBinary lhs,
    ErlBinary rhs
)
public static bool operator ==(
    ErlBinary lhs,
    ErlBinary rhs
)
Public Shared Operator = (
    lhs As ErlBinary,
    rhs As ErlBinary
) As Boolean
Public Shared Operator = (
    lhs As ErlBinary,
    rhs As ErlBinary
) As Boolean
public:
static bool operator ==(
    ErlBinary lhs,
    ErlBinary rhs
)
public:
static bool operator ==(
    ErlBinary lhs,
    ErlBinary rhs
)
static let inline (=)
        lhs : ErlBinary *
        rhs : ErlBinary  : bool
static let inline (=)
        lhs : ErlBinary *
        rhs : ErlBinary  : bool

Parameters

lhs
Type: NFX.Erlang ErlBinary
rhs
Type: NFX.Erlang ErlBinary

Return Value

Type: Online Boolean
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary Implicit Conversion (ErlBinary to Byte[])

ErlBinary Conversion (ErlBinary to Byte ) NFX Class Library

Implicit conversion of ErlBinary to byte[]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static implicit operator byte[] (
    ErlBinary t
)
public static implicit operator byte[] (
    ErlBinary t
)
Public Shared Widening Operator CType (
    t As ErlBinary
) As Byte()
Public Shared Widening Operator CType (
    t As ErlBinary
) As Byte()
static implicit operator array<unsigned char>^ (
    ErlBinary t
)
static implicit operator array<unsigned char>^ (
    ErlBinary t
)
F# does not support the declaration of new casting operators.
F# does not support the declaration of new casting operators.

Parameters

t
Type: NFX.Erlang ErlBinary

Return Value

Type: Online Byte
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary.Inequality Operator

ErlBinary Inequality Operator NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    ErlBinary lhs,
    ErlBinary rhs
)
public static bool operator !=(
    ErlBinary lhs,
    ErlBinary rhs
)
Public Shared Operator <> (
    lhs As ErlBinary,
    rhs As ErlBinary
) As Boolean
Public Shared Operator <> (
    lhs As ErlBinary,
    rhs As ErlBinary
) As Boolean
public:
static bool operator !=(
    ErlBinary lhs,
    ErlBinary rhs
)
public:
static bool operator !=(
    ErlBinary lhs,
    ErlBinary rhs
)
static let inline (<>)
        lhs : ErlBinary *
        rhs : ErlBinary  : bool
static let inline (<>)
        lhs : ErlBinary *
        rhs : ErlBinary  : bool

Parameters

lhs
Type: NFX.Erlang ErlBinary
rhs
Type: NFX.Erlang ErlBinary

Return Value

Type: Online Boolean
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary Properties

ErlBinary Properties NFX Class Library

The ErlBinary type exposes the following members.
Properties
 | Name | Description
Public property | IsScalar |
Public property | Length | Return length of the binary byte array
Public property | TypeOrder |
Public property | Value |
Public property | ValueAsBool |
Public property | ValueAsByteArray |
Public property | ValueAsChar |
Public property | ValueAsDateTime |
Public property | ValueAsDecimal |
Public property | ValueAsDouble |
Public property | ValueAsInt |
Public property | ValueAsLong |
Public property | ValueAsObject |
Public property | ValueAsString |
Public property | ValueAsTimeSpan |
Back to Top
See Also
ErlBinary Structure
NFX.Erlang Namespace


ErlBinary.IsScalar Property

ErlBinary IsScalar Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsScalar { get; }
public bool IsScalar { get; }
Public ReadOnly Property IsScalar As Boolean
    Get
Public ReadOnly Property IsScalar As Boolean
    Get
public:
virtual property bool IsScalar {
    bool get () sealed;
}
public:
virtual property bool IsScalar {
    bool get () sealed;
}
abstract IsScalar : bool with get
override IsScalar : bool with get
abstract IsScalar : bool with get
override IsScalar : bool with get

Property Value

Type: Online Boolean

Implements

IErlObject IsScalar
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary.Length Property

ErlBinary Length Property NFX Class Library

Return length of the binary byte array

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Length { get; }
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get
Public ReadOnly Property Length As Integer
    Get
public:
property int Length {
    int get ();
}
public:
property int Length {
    int get ();
}
member Length : int with get
member Length : int with get

Property Value

Type: Online Int32
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary.TypeOrder Property

ErlBinary TypeOrder Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTypeOrder TypeOrder { get; }
public ErlTypeOrder TypeOrder { get; }
Public ReadOnly Property TypeOrder As ErlTypeOrder
    Get
Public ReadOnly Property TypeOrder As ErlTypeOrder
    Get
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () sealed;
}
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () sealed;
}
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get

Property Value

Type: ErlTypeOrder

Implements

IErlObject TypeOrder
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary.Value Property

ErlBinary Value Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] Value { get; }
public byte[] Value { get; }
Public ReadOnly Property Value As Byte()
    Get
Public ReadOnly Property Value As Byte()
    Get
public:
virtual property array<unsigned char>^ Value {
    array<unsigned char>^ get () sealed;
}
public:
virtual property array<unsigned char>^ Value {
    array<unsigned char>^ get () sealed;
}
abstract Value : byte[] with get
override Value : byte[] with get
abstract Value : byte[] with get
override Value : byte[] with get

Property Value

Type: Online Byte

Implements

IErlObject T Value
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary.ValueAsBool Property

ErlBinary ValueAsBool Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ValueAsBool { get; }
public bool ValueAsBool { get; }
Public ReadOnly Property ValueAsBool As Boolean
    Get
Public ReadOnly Property ValueAsBool As Boolean
    Get
public:
virtual property bool ValueAsBool {
    bool get () sealed;
}
public:
virtual property bool ValueAsBool {
    bool get () sealed;
}
abstract ValueAsBool : bool with get
override ValueAsBool : bool with get
abstract ValueAsBool : bool with get
override ValueAsBool : bool with get

Property Value

Type: Online Boolean

Implements

IErlObject ValueAsBool
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary.ValueAsByteArray Property

ErlBinary ValueAsByteArray Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] ValueAsByteArray { get; }
public byte[] ValueAsByteArray { get; }
Public ReadOnly Property ValueAsByteArray As Byte()
    Get
Public ReadOnly Property ValueAsByteArray As Byte()
    Get
public:
virtual property array<unsigned char>^ ValueAsByteArray {
    array<unsigned char>^ get () sealed;
}
public:
virtual property array<unsigned char>^ ValueAsByteArray {
    array<unsigned char>^ get () sealed;
}
abstract ValueAsByteArray : byte[] with get
override ValueAsByteArray : byte[] with get
abstract ValueAsByteArray : byte[] with get
override ValueAsByteArray : byte[] with get

Property Value

Type: Online Byte

Implements

IErlObject ValueAsByteArray
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary.ValueAsChar Property

ErlBinary ValueAsChar Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char ValueAsChar { get; }
public char ValueAsChar { get; }
Public ReadOnly Property ValueAsChar As Char
    Get
Public ReadOnly Property ValueAsChar As Char
    Get
public:
virtual property wchar_t ValueAsChar {
    wchar_t get () sealed;
}
public:
virtual property wchar_t ValueAsChar {
    wchar_t get () sealed;
}
abstract ValueAsChar : char with get
override ValueAsChar : char with get
abstract ValueAsChar : char with get
override ValueAsChar : char with get

Property Value

Type: Online Char

Implements

IErlObject ValueAsChar
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary.ValueAsDateTime Property

ErlBinary ValueAsDateTime Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime ValueAsDateTime { get; }
public DateTime ValueAsDateTime { get; }
Public ReadOnly Property ValueAsDateTime As DateTime
    Get
Public ReadOnly Property ValueAsDateTime As DateTime
    Get
public:
virtual property DateTime ValueAsDateTime {
    DateTime get () sealed;
}
public:
virtual property DateTime ValueAsDateTime {
    DateTime get () sealed;
}
abstract ValueAsDateTime : DateTime with get
override ValueAsDateTime : DateTime with get
abstract ValueAsDateTime : DateTime with get
override ValueAsDateTime : DateTime with get

Property Value

Type: Online DateTime

Implements

IErlObject ValueAsDateTime
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary.ValueAsDecimal Property

ErlBinary ValueAsDecimal Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal ValueAsDecimal { get; }
public decimal ValueAsDecimal { get; }
Public ReadOnly Property ValueAsDecimal As Decimal
    Get
Public ReadOnly Property ValueAsDecimal As Decimal
    Get
public:
virtual property Decimal ValueAsDecimal {
    Decimal get () sealed;
}
public:
virtual property Decimal ValueAsDecimal {
    Decimal get () sealed;
}
abstract ValueAsDecimal : decimal with get
override ValueAsDecimal : decimal with get
abstract ValueAsDecimal : decimal with get
override ValueAsDecimal : decimal with get

Property Value

Type: Online Decimal

Implements

IErlObject ValueAsDecimal
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary.ValueAsDouble Property

ErlBinary ValueAsDouble Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double ValueAsDouble { get; }
public double ValueAsDouble { get; }
Public ReadOnly Property ValueAsDouble As Double
    Get
Public ReadOnly Property ValueAsDouble As Double
    Get
public:
virtual property double ValueAsDouble {
    double get () sealed;
}
public:
virtual property double ValueAsDouble {
    double get () sealed;
}
abstract ValueAsDouble : float with get
override ValueAsDouble : float with get
abstract ValueAsDouble : float with get
override ValueAsDouble : float with get

Property Value

Type: Online Double

Implements

IErlObject ValueAsDouble
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary.ValueAsInt Property

ErlBinary ValueAsInt Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ValueAsInt { get; }
public int ValueAsInt { get; }
Public ReadOnly Property ValueAsInt As Integer
    Get
Public ReadOnly Property ValueAsInt As Integer
    Get
public:
virtual property int ValueAsInt {
    int get () sealed;
}
public:
virtual property int ValueAsInt {
    int get () sealed;
}
abstract ValueAsInt : int with get
override ValueAsInt : int with get
abstract ValueAsInt : int with get
override ValueAsInt : int with get

Property Value

Type: Online Int32

Implements

IErlObject ValueAsInt
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary.ValueAsLong Property

ErlBinary ValueAsLong Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long ValueAsLong { get; }
public long ValueAsLong { get; }
Public ReadOnly Property ValueAsLong As Long
    Get
Public ReadOnly Property ValueAsLong As Long
    Get
public:
virtual property long long ValueAsLong {
    long long get () sealed;
}
public:
virtual property long long ValueAsLong {
    long long get () sealed;
}
abstract ValueAsLong : int64 with get
override ValueAsLong : int64 with get
abstract ValueAsLong : int64 with get
override ValueAsLong : int64 with get

Property Value

Type: Online Int64

Implements

IErlObject ValueAsLong
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary.ValueAsObject Property

ErlBinary ValueAsObject Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object ValueAsObject { get; }
public Object ValueAsObject { get; }
Public ReadOnly Property ValueAsObject As Object
    Get
Public ReadOnly Property ValueAsObject As Object
    Get
public:
virtual property Object^ ValueAsObject {
    Object^ get () sealed;
}
public:
virtual property Object^ ValueAsObject {
    Object^ get () sealed;
}
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get

Property Value

Type: Online Object

Implements

IErlObject ValueAsObject
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary.ValueAsString Property

ErlBinary ValueAsString Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ValueAsString { get; }
public string ValueAsString { get; }
Public ReadOnly Property ValueAsString As String
    Get
Public ReadOnly Property ValueAsString As String
    Get
public:
virtual property String^ ValueAsString {
    String^ get () sealed;
}
public:
virtual property String^ ValueAsString {
    String^ get () sealed;
}
abstract ValueAsString : string with get
override ValueAsString : string with get
abstract ValueAsString : string with get
override ValueAsString : string with get

Property Value

Type: Online String

Implements

IErlObject ValueAsString
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBinary.ValueAsTimeSpan Property

ErlBinary ValueAsTimeSpan Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpan ValueAsTimeSpan { get; }
public TimeSpan ValueAsTimeSpan { get; }
Public ReadOnly Property ValueAsTimeSpan As TimeSpan
    Get
Public ReadOnly Property ValueAsTimeSpan As TimeSpan
    Get
public:
virtual property TimeSpan ValueAsTimeSpan {
    TimeSpan get () sealed;
}
public:
virtual property TimeSpan ValueAsTimeSpan {
    TimeSpan get () sealed;
}
abstract ValueAsTimeSpan : TimeSpan with get
override ValueAsTimeSpan : TimeSpan with get
abstract ValueAsTimeSpan : TimeSpan with get
override ValueAsTimeSpan : TimeSpan with get

Property Value

Type: Online TimeSpan

Implements

IErlObject ValueAsTimeSpan
See Also
ErlBinary Structure
ErlBinary Members
NFX.Erlang Namespace


ErlBoolean Structure

ErlBoolean Structure NFX Class Library

Provides a C# representation of Erlang floats and doubles. Erlang defines only one floating point numeric type

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct ErlBoolean : IErlObject<bool>,
    IErlObject, IComparable, IComparable<IErlObject>, IEquatable<IErlObject>,
    ICloneable
public struct ErlBoolean : IErlObject<bool>,
    IErlObject, IComparable, IComparable<IErlObject>, IEquatable<IErlObject>,
    ICloneable
Public Structure ErlBoolean
    Implements IErlObject(Of Boolean), IErlObject,
    IComparable, IComparable(Of IErlObject), IEquatable(Of IErlObject),
    ICloneable
Public Structure ErlBoolean
    Implements IErlObject(Of Boolean), IErlObject,
    IComparable, IComparable(Of IErlObject), IEquatable(Of IErlObject),
    ICloneable
public value class ErlBoolean : IErlObject<bool>,
    IErlObject, IComparable, IComparable<IErlObject^>, IEquatable<IErlObject^>,
    ICloneable
public value class ErlBoolean : IErlObject<bool>,
    IErlObject, IComparable, IComparable<IErlObject^>, IEquatable<IErlObject^>,
    ICloneable
[<SealedAttribute>]
type ErlBoolean =
    struct
        interface IErlObject<bool>
        interface IErlObject
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
    end
[<SealedAttribute>]
type ErlBoolean =
    struct
        interface IErlObject<bool>
        interface IErlObject
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
    end
See Also
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean Members

ErlBoolean Members NFX Class Library

The ErlBoolean type exposes the following members.
Constructors
 | Name | Description
Public method | ErlBoolean | Create an Erlang boolean from the given boolean value.
Back to Top
Methods
 | Name | Description
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the atom is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the atom is less than obj, positive - greater than the obj
Public method | Equals(Object) | Determine if this atom equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(ErlBoolean) | Determine if two atoms are equal
Public method | Equals(IErlObject) | Determine if two atoms are equal
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Get internal hash code (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Public method | Matches | Perform pattern match on this Erlang term without binding any variables
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Subst |
Public method | ToString | (Overrides Online ValueType ToString .)
Public method | Visit TAccumulate | Execute fun for every nested term
Back to Top
Operators
Name | Description
Equality |
(Boolean to ErlBoolean) | Implicit conversion of bool to ErlBoolean
(ErlBoolean to Boolean) | Implicit conversion of ErlBoolean to bool
Inequality |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | IsScalar |
Public property | TypeOrder |
Public property | Value |
Public property | ValueAsBool |
Public property | ValueAsByteArray |
Public property | ValueAsChar |
Public property | ValueAsDateTime |
Public property | ValueAsDecimal |
Public property | ValueAsDouble |
Public property | ValueAsInt |
Public property | ValueAsLong |
Public property | ValueAsObject |
Public property | ValueAsString |
Public property | ValueAsTimeSpan |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone |
Back to Top
See Also
ErlBoolean Structure
NFX.Erlang Namespace


ErlBoolean Constructor

ErlBoolean Constructor NFX Class Library

Create an Erlang boolean from the given boolean value.

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlBoolean(
    bool b
)
public ErlBoolean(
    bool b
)
Public Sub New (
    b As Boolean
)
Public Sub New (
    b As Boolean
)
public:
ErlBoolean(
    bool b
)
public:
ErlBoolean(
    bool b
)
new :
        b : bool -> ErlBoolean
new :
        b : bool -> ErlBoolean

Parameters

b
Type: Online System Boolean
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean Methods

ErlBoolean Methods NFX Class Library

The ErlBoolean type exposes the following members.
Methods
 | Name | Description
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the atom is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the atom is less than obj, positive - greater than the obj
Public method | Equals(Object) | Determine if this atom equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(ErlBoolean) | Determine if two atoms are equal
Public method | Equals(IErlObject) | Determine if two atoms are equal
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Get internal hash code (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Public method | Matches | Perform pattern match on this Erlang term without binding any variables
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Subst |
Public method | ToString | (Overrides Online ValueType ToString .)
Public method | Visit TAccumulate | Execute fun for every nested term
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone |
Back to Top
See Also
ErlBoolean Structure
NFX.Erlang Namespace


ErlBoolean.ICloneable.Clone Method

ErlBoolean ICloneable Clone Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object ICloneable.Clone()
Object ICloneable.Clone()
Private Function Clone As Object Implements ICloneable.Clone
Private Function Clone As Object Implements ICloneable.Clone
private:
virtual Object^ Clone() sealed = ICloneable::Clone
private:
virtual Object^ Clone() sealed = ICloneable::Clone
private abstract Clone : unit -> Object
private override Clone : unit -> Object
private abstract Clone : unit -> Object
private override Clone : unit -> Object

Return Value

Type: Online Object

Implements

Online ICloneable Clone
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean.Clone Method

ErlBoolean Clone Method NFX Class Library

Clone an instance of the object (non-scalar immutable objects are copied by reference)

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject Clone()
public IErlObject Clone()
Public Function Clone As IErlObject
Public Function Clone As IErlObject
public:
virtual IErlObject^ Clone() sealed
public:
virtual IErlObject^ Clone() sealed
abstract Clone : unit -> IErlObject
override Clone : unit -> IErlObject
abstract Clone : unit -> IErlObject
override Clone : unit -> IErlObject

Return Value

Type: IErlObject

Implements

IErlObject Clone
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean.CompareTo Method

ErlBoolean CompareTo Method NFX Class Library

Overload List
 | Name | Description
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the atom is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the atom is less than obj, positive - greater than the obj
Back to Top
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean.CompareTo Method (Object)

ErlBoolean CompareTo Method (Object) NFX Class Library

Compare this instance to the object. Negative value means that the atom is less than obj, positive - greater than the obj

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    Object obj
)
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
Public Function CompareTo (
    obj As Object
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
public:
virtual int CompareTo(
    Object^ obj
) sealed
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int

Parameters

obj
Type: Online System Object

Return Value

Type: Online Int32

Implements

Online IComparable CompareTo(Object)
See Also
ErlBoolean Structure
ErlBoolean Members
CompareTo Overload
NFX.Erlang Namespace


ErlBoolean.CompareTo Method (IErlObject)

ErlBoolean CompareTo Method (IErlObject) NFX Class Library

Compare this instance to the IErlObject. Negative value means that the atom is less than obj, positive - greater than the obj

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    IErlObject obj
)
public int CompareTo(
    IErlObject obj
)
Public Function CompareTo (
    obj As IErlObject
) As Integer
Public Function CompareTo (
    obj As IErlObject
) As Integer
public:
virtual int CompareTo(
    IErlObject^ obj
) sealed
public:
virtual int CompareTo(
    IErlObject^ obj
) sealed
abstract CompareTo :
        obj : IErlObject -> int
override CompareTo :
        obj : IErlObject -> int
abstract CompareTo :
        obj : IErlObject -> int
override CompareTo :
        obj : IErlObject -> int

Parameters

obj
Type: NFX.Erlang IErlObject

Return Value

Type: Online Int32

Implements

Online IComparable T CompareTo(T)
See Also
ErlBoolean Structure
ErlBoolean Members
CompareTo Overload
NFX.Erlang Namespace


ErlBoolean.Equals Method

ErlBoolean Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | Determine if this atom equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(ErlBoolean) | Determine if two atoms are equal
Public method | Equals(IErlObject) | Determine if two atoms are equal
Back to Top
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean.Equals Method (Object)

ErlBoolean Equals Method (Object) NFX Class Library

Determine if this atom equals to the object

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals (
    o As Object
) As Boolean
Public Overrides Function Equals (
    o As Object
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool

Parameters

o
Type: Online System Object

Return Value

Type: Online Boolean
See Also
ErlBoolean Structure
ErlBoolean Members
Equals Overload
NFX.Erlang Namespace


ErlBoolean.Equals Method (ErlBoolean)

ErlBoolean Equals Method (ErlBoolean) NFX Class Library

Determine if two atoms are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    ErlBoolean o
)
public bool Equals(
    ErlBoolean o
)
Public Function Equals (
    o As ErlBoolean
) As Boolean
Public Function Equals (
    o As ErlBoolean
) As Boolean
public:
bool Equals(
    ErlBoolean o
)
public:
bool Equals(
    ErlBoolean o
)
member Equals :
        o : ErlBoolean -> bool
member Equals :
        o : ErlBoolean -> bool

Parameters

o
Type: NFX.Erlang ErlBoolean

Return Value

Type: Online Boolean
See Also
ErlBoolean Structure
ErlBoolean Members
Equals Overload
NFX.Erlang Namespace


ErlBoolean.Equals Method (IErlObject)

ErlBoolean Equals Method (IErlObject) NFX Class Library

Determine if two atoms are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    IErlObject o
)
public bool Equals(
    IErlObject o
)
Public Function Equals (
    o As IErlObject
) As Boolean
Public Function Equals (
    o As IErlObject
) As Boolean
public:
virtual bool Equals(
    IErlObject^ o
) sealed
public:
virtual bool Equals(
    IErlObject^ o
) sealed
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool

Parameters

o
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
ErlBoolean Structure
ErlBoolean Members
Equals Overload
NFX.Erlang Namespace


ErlBoolean.GetHashCode Method

ErlBoolean GetHashCode Method NFX Class Library

Get internal hash code

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean.Match Method

ErlBoolean Match Method NFX Class Library

Overload List
 | Name | Description
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Back to Top
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean.Match Method (IErlObject)

ErlBoolean Match Method (IErlObject) NFX Class Library

Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlVarBind Match(
    IErlObject pattern
)
public ErlVarBind Match(
    IErlObject pattern
)
Public Function Match (
    pattern As IErlObject
) As ErlVarBind
Public Function Match (
    pattern As IErlObject
) As ErlVarBind
public:
virtual ErlVarBind^ Match(
    IErlObject^ pattern
) sealed
public:
virtual ErlVarBind^ Match(
    IErlObject^ pattern
) sealed
abstract Match :
        pattern : IErlObject -> ErlVarBind
override Match :
        pattern : IErlObject -> ErlVarBind
abstract Match :
        pattern : IErlObject -> ErlVarBind
override Match :
        pattern : IErlObject -> ErlVarBind

Parameters

pattern
Type: NFX.Erlang IErlObject

Return Value

Type: ErlVarBind

Implements

IErlObject Match(IErlObject)
See Also
ErlBoolean Structure
ErlBoolean Members
Match Overload
NFX.Erlang Namespace


ErlBoolean.Match Method (IErlObject, ErlVarBind)

ErlBoolean Match Method (IErlObject, ErlVarBind) NFX Class Library

[This is preliminary documentation and is subject to change.]

Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Match(
    IErlObject pattern,
    ErlVarBind binding
)
public bool Match(
    IErlObject pattern,
    ErlVarBind binding
)
Public Function Match (
    pattern As IErlObject,
    binding As ErlVarBind
) As Boolean
Public Function Match (
    pattern As IErlObject,
    binding As ErlVarBind
) As Boolean
public:
virtual bool Match(
    IErlObject^ pattern,
    ErlVarBind^ binding
) sealed
public:
virtual bool Match(
    IErlObject^ pattern,
    ErlVarBind^ binding
) sealed
abstract Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
override Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
abstract Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
override Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool

Parameters

pattern
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind

Return Value

Type: Online Boolean

Implements

IErlObject Match(IErlObject, ErlVarBind)
See Also
ErlBoolean Structure
ErlBoolean Members
Match Overload
NFX.Erlang Namespace


ErlBoolean.Matches Method

ErlBoolean Matches Method NFX Class Library

Perform pattern match on this Erlang term without binding any variables

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Matches(
    IErlObject pattern
)
public bool Matches(
    IErlObject pattern
)
Public Function Matches (
    pattern As IErlObject
) As Boolean
Public Function Matches (
    pattern As IErlObject
) As Boolean
public:
virtual bool Matches(
    IErlObject^ pattern
) sealed
public:
virtual bool Matches(
    IErlObject^ pattern
) sealed
abstract Matches :
        pattern : IErlObject -> bool
override Matches :
        pattern : IErlObject -> bool
abstract Matches :
        pattern : IErlObject -> bool
override Matches :
        pattern : IErlObject -> bool

Parameters

pattern
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Implements

IErlObject Matches(IErlObject)
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean.Subst Method

ErlBoolean Subst Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Subst(
    ref IErlObject term,
    ErlVarBind binding
)
public bool Subst(
    ref IErlObject term,
    ErlVarBind binding
)
Public Function Subst (
    ByRef term As IErlObject,
    binding As ErlVarBind
) As Boolean
Public Function Subst (
    ByRef term As IErlObject,
    binding As ErlVarBind
) As Boolean
public:
virtual bool Subst(
    IErlObject^% term,
    ErlVarBind^ binding
) sealed
public:
virtual bool Subst(
    IErlObject^% term,
    ErlVarBind^ binding
) sealed
abstract Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
override Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
abstract Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
override Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool

Parameters

term
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind

Return Value

Type: Online Boolean

Implements

IErlObject Subst(IErlObject , ErlVarBind)
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean.ToString Method

ErlBoolean ToString Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean.Visit(TAccumulate) Method

ErlBoolean Visit TAccumulate Method NFX Class Library

Execute fun for every nested term

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TAccumulate Visit<TAccumulate>(
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
public TAccumulate Visit<TAccumulate>(
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
Public Function Visit(Of TAccumulate) (
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
Public Function Visit(Of TAccumulate) (
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
public:
generic<typename TAccumulate>
virtual TAccumulate Visit(
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
) sealed
public:
generic<typename TAccumulate>
virtual TAccumulate Visit(
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
) sealed
abstract Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
override Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
abstract Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
override Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate

Parameters

acc
Type: TAccumulate
fun
Type: Online System Func TAccumulate, IErlObject, TAccumulate
Type Parameters
TAccumulate

Return Value

Type: TAccumulate

Implements

IErlObject Visit TAccumulate (TAccumulate, Func TAccumulate, IErlObject, TAccumulate )
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean Operators and Type Conversions

ErlBoolean Operators and Type Conversions NFX Class Library

The ErlBoolean type exposes the following members.
Operators
Name | Description
Equality |
(Boolean to ErlBoolean) | Implicit conversion of bool to ErlBoolean
(ErlBoolean to Boolean) | Implicit conversion of ErlBoolean to bool
Inequality |
Back to Top
See Also
ErlBoolean Structure
NFX.Erlang Namespace


ErlBoolean.Equality Operator

ErlBoolean Equality Operator NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    ErlBoolean lhs,
    ErlBoolean rhs
)
public static bool operator ==(
    ErlBoolean lhs,
    ErlBoolean rhs
)
Public Shared Operator = (
    lhs As ErlBoolean,
    rhs As ErlBoolean
) As Boolean
Public Shared Operator = (
    lhs As ErlBoolean,
    rhs As ErlBoolean
) As Boolean
public:
static bool operator ==(
    ErlBoolean lhs,
    ErlBoolean rhs
)
public:
static bool operator ==(
    ErlBoolean lhs,
    ErlBoolean rhs
)
static let inline (=)
        lhs : ErlBoolean *
        rhs : ErlBoolean  : bool
static let inline (=)
        lhs : ErlBoolean *
        rhs : ErlBoolean  : bool

Parameters

lhs
Type: NFX.Erlang ErlBoolean
rhs
Type: NFX.Erlang ErlBoolean

Return Value

Type: Online Boolean
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean Implicit Conversion Operators

ErlBoolean Conversion Operators NFX Class Library

Overload List
Name | Description
(Boolean to ErlBoolean) | Implicit conversion of bool to ErlBoolean
(ErlBoolean to Boolean) | Implicit conversion of ErlBoolean to bool
Back to Top
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean Implicit Conversion (Boolean to ErlBoolean)

ErlBoolean Conversion (Boolean to ErlBoolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Implicit conversion of bool to ErlBoolean

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static implicit operator ErlBoolean (
    bool a
)
public static implicit operator ErlBoolean (
    bool a
)
Public Shared Widening Operator CType (
    a As Boolean
) As ErlBoolean
Public Shared Widening Operator CType (
    a As Boolean
) As ErlBoolean
static implicit operator ErlBoolean (
    bool a
)
static implicit operator ErlBoolean (
    bool a
)
F# does not support the declaration of new casting operators.
F# does not support the declaration of new casting operators.

Parameters

a
Type: Online System Boolean

Return Value

Type: ErlBoolean
See Also
ErlBoolean Structure
ErlBoolean Members
Overload
NFX.Erlang Namespace


ErlBoolean Implicit Conversion (ErlBoolean to Boolean)

ErlBoolean Conversion (ErlBoolean to Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Implicit conversion of ErlBoolean to bool

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static implicit operator bool (
    ErlBoolean t
)
public static implicit operator bool (
    ErlBoolean t
)
Public Shared Widening Operator CType (
    t As ErlBoolean
) As Boolean
Public Shared Widening Operator CType (
    t As ErlBoolean
) As Boolean
static implicit operator bool (
    ErlBoolean t
)
static implicit operator bool (
    ErlBoolean t
)
F# does not support the declaration of new casting operators.
F# does not support the declaration of new casting operators.

Parameters

t
Type: NFX.Erlang ErlBoolean

Return Value

Type: Online Boolean
See Also
ErlBoolean Structure
ErlBoolean Members
Overload
NFX.Erlang Namespace


ErlBoolean.Inequality Operator

ErlBoolean Inequality Operator NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    ErlBoolean lhs,
    ErlBoolean rhs
)
public static bool operator !=(
    ErlBoolean lhs,
    ErlBoolean rhs
)
Public Shared Operator <> (
    lhs As ErlBoolean,
    rhs As ErlBoolean
) As Boolean
Public Shared Operator <> (
    lhs As ErlBoolean,
    rhs As ErlBoolean
) As Boolean
public:
static bool operator !=(
    ErlBoolean lhs,
    ErlBoolean rhs
)
public:
static bool operator !=(
    ErlBoolean lhs,
    ErlBoolean rhs
)
static let inline (<>)
        lhs : ErlBoolean *
        rhs : ErlBoolean  : bool
static let inline (<>)
        lhs : ErlBoolean *
        rhs : ErlBoolean  : bool

Parameters

lhs
Type: NFX.Erlang ErlBoolean
rhs
Type: NFX.Erlang ErlBoolean

Return Value

Type: Online Boolean
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean Properties

ErlBoolean Properties NFX Class Library

The ErlBoolean type exposes the following members.
Properties
 | Name | Description
Public property | IsScalar |
Public property | TypeOrder |
Public property | Value |
Public property | ValueAsBool |
Public property | ValueAsByteArray |
Public property | ValueAsChar |
Public property | ValueAsDateTime |
Public property | ValueAsDecimal |
Public property | ValueAsDouble |
Public property | ValueAsInt |
Public property | ValueAsLong |
Public property | ValueAsObject |
Public property | ValueAsString |
Public property | ValueAsTimeSpan |
Back to Top
See Also
ErlBoolean Structure
NFX.Erlang Namespace


ErlBoolean.IsScalar Property

ErlBoolean IsScalar Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsScalar { get; }
public bool IsScalar { get; }
Public ReadOnly Property IsScalar As Boolean
    Get
Public ReadOnly Property IsScalar As Boolean
    Get
public:
virtual property bool IsScalar {
    bool get () sealed;
}
public:
virtual property bool IsScalar {
    bool get () sealed;
}
abstract IsScalar : bool with get
override IsScalar : bool with get
abstract IsScalar : bool with get
override IsScalar : bool with get

Property Value

Type: Online Boolean

Implements

IErlObject IsScalar
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean.TypeOrder Property

ErlBoolean TypeOrder Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTypeOrder TypeOrder { get; }
public ErlTypeOrder TypeOrder { get; }
Public ReadOnly Property TypeOrder As ErlTypeOrder
    Get
Public ReadOnly Property TypeOrder As ErlTypeOrder
    Get
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () sealed;
}
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () sealed;
}
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get

Property Value

Type: ErlTypeOrder

Implements

IErlObject TypeOrder
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean.Value Property

ErlBoolean Value Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Value { get; }
public bool Value { get; }
Public ReadOnly Property Value As Boolean
    Get
Public ReadOnly Property Value As Boolean
    Get
public:
virtual property bool Value {
    bool get () sealed;
}
public:
virtual property bool Value {
    bool get () sealed;
}
abstract Value : bool with get
override Value : bool with get
abstract Value : bool with get
override Value : bool with get

Property Value

Type: Online Boolean

Implements

IErlObject T Value
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean.ValueAsBool Property

ErlBoolean ValueAsBool Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ValueAsBool { get; }
public bool ValueAsBool { get; }
Public ReadOnly Property ValueAsBool As Boolean
    Get
Public ReadOnly Property ValueAsBool As Boolean
    Get
public:
virtual property bool ValueAsBool {
    bool get () sealed;
}
public:
virtual property bool ValueAsBool {
    bool get () sealed;
}
abstract ValueAsBool : bool with get
override ValueAsBool : bool with get
abstract ValueAsBool : bool with get
override ValueAsBool : bool with get

Property Value

Type: Online Boolean

Implements

IErlObject ValueAsBool
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean.ValueAsByteArray Property

ErlBoolean ValueAsByteArray Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] ValueAsByteArray { get; }
public byte[] ValueAsByteArray { get; }
Public ReadOnly Property ValueAsByteArray As Byte()
    Get
Public ReadOnly Property ValueAsByteArray As Byte()
    Get
public:
virtual property array<unsigned char>^ ValueAsByteArray {
    array<unsigned char>^ get () sealed;
}
public:
virtual property array<unsigned char>^ ValueAsByteArray {
    array<unsigned char>^ get () sealed;
}
abstract ValueAsByteArray : byte[] with get
override ValueAsByteArray : byte[] with get
abstract ValueAsByteArray : byte[] with get
override ValueAsByteArray : byte[] with get

Property Value

Type: Online Byte

Implements

IErlObject ValueAsByteArray
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean.ValueAsChar Property

ErlBoolean ValueAsChar Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char ValueAsChar { get; }
public char ValueAsChar { get; }
Public ReadOnly Property ValueAsChar As Char
    Get
Public ReadOnly Property ValueAsChar As Char
    Get
public:
virtual property wchar_t ValueAsChar {
    wchar_t get () sealed;
}
public:
virtual property wchar_t ValueAsChar {
    wchar_t get () sealed;
}
abstract ValueAsChar : char with get
override ValueAsChar : char with get
abstract ValueAsChar : char with get
override ValueAsChar : char with get

Property Value

Type: Online Char

Implements

IErlObject ValueAsChar
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean.ValueAsDateTime Property

ErlBoolean ValueAsDateTime Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime ValueAsDateTime { get; }
public DateTime ValueAsDateTime { get; }
Public ReadOnly Property ValueAsDateTime As DateTime
    Get
Public ReadOnly Property ValueAsDateTime As DateTime
    Get
public:
virtual property DateTime ValueAsDateTime {
    DateTime get () sealed;
}
public:
virtual property DateTime ValueAsDateTime {
    DateTime get () sealed;
}
abstract ValueAsDateTime : DateTime with get
override ValueAsDateTime : DateTime with get
abstract ValueAsDateTime : DateTime with get
override ValueAsDateTime : DateTime with get

Property Value

Type: Online DateTime

Implements

IErlObject ValueAsDateTime
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean.ValueAsDecimal Property

ErlBoolean ValueAsDecimal Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal ValueAsDecimal { get; }
public decimal ValueAsDecimal { get; }
Public ReadOnly Property ValueAsDecimal As Decimal
    Get
Public ReadOnly Property ValueAsDecimal As Decimal
    Get
public:
virtual property Decimal ValueAsDecimal {
    Decimal get () sealed;
}
public:
virtual property Decimal ValueAsDecimal {
    Decimal get () sealed;
}
abstract ValueAsDecimal : decimal with get
override ValueAsDecimal : decimal with get
abstract ValueAsDecimal : decimal with get
override ValueAsDecimal : decimal with get

Property Value

Type: Online Decimal

Implements

IErlObject ValueAsDecimal
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean.ValueAsDouble Property

ErlBoolean ValueAsDouble Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double ValueAsDouble { get; }
public double ValueAsDouble { get; }
Public ReadOnly Property ValueAsDouble As Double
    Get
Public ReadOnly Property ValueAsDouble As Double
    Get
public:
virtual property double ValueAsDouble {
    double get () sealed;
}
public:
virtual property double ValueAsDouble {
    double get () sealed;
}
abstract ValueAsDouble : float with get
override ValueAsDouble : float with get
abstract ValueAsDouble : float with get
override ValueAsDouble : float with get

Property Value

Type: Online Double

Implements

IErlObject ValueAsDouble
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean.ValueAsInt Property

ErlBoolean ValueAsInt Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ValueAsInt { get; }
public int ValueAsInt { get; }
Public ReadOnly Property ValueAsInt As Integer
    Get
Public ReadOnly Property ValueAsInt As Integer
    Get
public:
virtual property int ValueAsInt {
    int get () sealed;
}
public:
virtual property int ValueAsInt {
    int get () sealed;
}
abstract ValueAsInt : int with get
override ValueAsInt : int with get
abstract ValueAsInt : int with get
override ValueAsInt : int with get

Property Value

Type: Online Int32

Implements

IErlObject ValueAsInt
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean.ValueAsLong Property

ErlBoolean ValueAsLong Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long ValueAsLong { get; }
public long ValueAsLong { get; }
Public ReadOnly Property ValueAsLong As Long
    Get
Public ReadOnly Property ValueAsLong As Long
    Get
public:
virtual property long long ValueAsLong {
    long long get () sealed;
}
public:
virtual property long long ValueAsLong {
    long long get () sealed;
}
abstract ValueAsLong : int64 with get
override ValueAsLong : int64 with get
abstract ValueAsLong : int64 with get
override ValueAsLong : int64 with get

Property Value

Type: Online Int64

Implements

IErlObject ValueAsLong
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean.ValueAsObject Property

ErlBoolean ValueAsObject Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object ValueAsObject { get; }
public Object ValueAsObject { get; }
Public ReadOnly Property ValueAsObject As Object
    Get
Public ReadOnly Property ValueAsObject As Object
    Get
public:
virtual property Object^ ValueAsObject {
    Object^ get () sealed;
}
public:
virtual property Object^ ValueAsObject {
    Object^ get () sealed;
}
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get

Property Value

Type: Online Object

Implements

IErlObject ValueAsObject
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean.ValueAsString Property

ErlBoolean ValueAsString Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ValueAsString { get; }
public string ValueAsString { get; }
Public ReadOnly Property ValueAsString As String
    Get
Public ReadOnly Property ValueAsString As String
    Get
public:
virtual property String^ ValueAsString {
    String^ get () sealed;
}
public:
virtual property String^ ValueAsString {
    String^ get () sealed;
}
abstract ValueAsString : string with get
override ValueAsString : string with get
abstract ValueAsString : string with get
override ValueAsString : string with get

Property Value

Type: Online String

Implements

IErlObject ValueAsString
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlBoolean.ValueAsTimeSpan Property

ErlBoolean ValueAsTimeSpan Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpan ValueAsTimeSpan { get; }
public TimeSpan ValueAsTimeSpan { get; }
Public ReadOnly Property ValueAsTimeSpan As TimeSpan
    Get
Public ReadOnly Property ValueAsTimeSpan As TimeSpan
    Get
public:
virtual property TimeSpan ValueAsTimeSpan {
    TimeSpan get () sealed;
}
public:
virtual property TimeSpan ValueAsTimeSpan {
    TimeSpan get () sealed;
}
abstract ValueAsTimeSpan : TimeSpan with get
override ValueAsTimeSpan : TimeSpan with get
abstract ValueAsTimeSpan : TimeSpan with get
override ValueAsTimeSpan : TimeSpan with get

Property Value

Type: Online TimeSpan

Implements

IErlObject ValueAsTimeSpan
See Also
ErlBoolean Structure
ErlBoolean Members
NFX.Erlang Namespace


ErlByte Structure

ErlByte Structure NFX Class Library

Provides a C# representation of Erlang integer types

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct ErlByte : IErlObject<byte>,
    IErlObject, IComparable, IComparable<IErlObject>, IEquatable<IErlObject>,
    ICloneable
public struct ErlByte : IErlObject<byte>,
    IErlObject, IComparable, IComparable<IErlObject>, IEquatable<IErlObject>,
    ICloneable
Public Structure ErlByte
    Implements IErlObject(Of Byte), IErlObject,
    IComparable, IComparable(Of IErlObject), IEquatable(Of IErlObject),
    ICloneable
Public Structure ErlByte
    Implements IErlObject(Of Byte), IErlObject,
    IComparable, IComparable(Of IErlObject), IEquatable(Of IErlObject),
    ICloneable
public value class ErlByte : IErlObject<unsigned char>,
    IErlObject, IComparable, IComparable<IErlObject^>, IEquatable<IErlObject^>,
    ICloneable
public value class ErlByte : IErlObject<unsigned char>,
    IErlObject, IComparable, IComparable<IErlObject^>, IEquatable<IErlObject^>,
    ICloneable
[<SealedAttribute>]
type ErlByte =
    struct
        interface IErlObject<byte>
        interface IErlObject
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
    end
[<SealedAttribute>]
type ErlByte =
    struct
        interface IErlObject<byte>
        interface IErlObject
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
    end
See Also
ErlByte Members
NFX.Erlang Namespace


ErlByte Members

ErlByte Members NFX Class Library

The ErlByte type exposes the following members.
Constructors
 | Name | Description
Public method | ErlByte(Byte) | Create an Erlang integer from the given value
Public method | ErlByte(Char) | Initializes a new instance of the ErlByte class
Back to Top
Methods
 | Name | Description
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj
Public method | Equals(Object) | Determine if this atom equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(ErlByte) | Determine if two instances are equal
Public method | Equals(ErlLong) |
Public method | Equals(IErlObject) | Determine if two values are equal
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Get internal hash code (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Public method | Matches | Perform pattern match on this Erlang term without binding any variables
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Subst |
Public method | ToString | (Overrides Online ValueType ToString .)
Public method | Visit TAccumulate | Execute fun for every nested term
Back to Top
Operators
Name | Description
Equality(Byte, ErlByte) |
Equality(Char, ErlByte) |
Equality(ErlByte, ErlByte) |
Equality(ErlByte, Byte) |
Equality(ErlByte, Char) |
(Char to ErlByte) |
(Int32 to ErlByte) | Implicit conversion of byte/char to ErlByte
(ErlByte to Char) |
(Byte to ErlByte) |
(ErlByte to Byte) | Implicit conversion of ErlByte to byte
Inequality(Byte, ErlByte) |
Inequality(Char, ErlByte) |
Inequality(ErlByte, ErlByte) |
Inequality(ErlByte, Byte) |
Inequality(ErlByte, Char) |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | IsScalar |
Public property | TypeOrder |
Public property | Value |
Public property | ValueAsBool |
Public property | ValueAsByteArray |
Public property | ValueAsChar |
Public property | ValueAsDateTime |
Public property | ValueAsDecimal |
Public property | ValueAsDouble |
Public property | ValueAsInt |
Public property | ValueAsLong |
Public property | ValueAsObject |
Public property | ValueAsString |
Public property | ValueAsTimeSpan |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone |
Back to Top
See Also
ErlByte Structure
NFX.Erlang Namespace


ErlByte Constructor

ErlByte Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ErlByte(Byte) | Create an Erlang integer from the given value
Public method | ErlByte(Char) | Initializes a new instance of the ErlByte class
Back to Top
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte Constructor (Byte)

ErlByte Constructor (Byte) NFX Class Library

Create an Erlang integer from the given value

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlByte(
    byte val
)
public ErlByte(
    byte val
)
Public Sub New (
    val As Byte
)
Public Sub New (
    val As Byte
)
public:
ErlByte(
    unsigned char val
)
public:
ErlByte(
    unsigned char val
)
new :
        val : byte -> ErlByte
new :
        val : byte -> ErlByte

Parameters

val
Type: Online System Byte
See Also
ErlByte Structure
ErlByte Members
ErlByte Overload
NFX.Erlang Namespace


ErlByte Constructor (Char)

ErlByte Constructor (Char) NFX Class Library

Initializes a new instance of the ErlByte class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlByte(
    char val
)
public ErlByte(
    char val
)
Public Sub New (
    val As Char
)
Public Sub New (
    val As Char
)
public:
ErlByte(
    wchar_t val
)
public:
ErlByte(
    wchar_t val
)
new :
        val : char -> ErlByte
new :
        val : char -> ErlByte

Parameters

val
Type: Online System Char
See Also
ErlByte Structure
ErlByte Members
ErlByte Overload
NFX.Erlang Namespace


ErlByte Methods

ErlByte Methods NFX Class Library

The ErlByte type exposes the following members.
Methods
 | Name | Description
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj
Public method | Equals(Object) | Determine if this atom equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(ErlByte) | Determine if two instances are equal
Public method | Equals(ErlLong) |
Public method | Equals(IErlObject) | Determine if two values are equal
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Get internal hash code (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Public method | Matches | Perform pattern match on this Erlang term without binding any variables
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Subst |
Public method | ToString | (Overrides Online ValueType ToString .)
Public method | Visit TAccumulate | Execute fun for every nested term
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone |
Back to Top
See Also
ErlByte Structure
NFX.Erlang Namespace


ErlByte.ICloneable.Clone Method

ErlByte ICloneable Clone Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object ICloneable.Clone()
Object ICloneable.Clone()
Private Function Clone As Object Implements ICloneable.Clone
Private Function Clone As Object Implements ICloneable.Clone
private:
virtual Object^ Clone() sealed = ICloneable::Clone
private:
virtual Object^ Clone() sealed = ICloneable::Clone
private abstract Clone : unit -> Object
private override Clone : unit -> Object
private abstract Clone : unit -> Object
private override Clone : unit -> Object

Return Value

Type: Online Object

Implements

Online ICloneable Clone
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte.Clone Method

ErlByte Clone Method NFX Class Library

Clone an instance of the object (non-scalar immutable objects are copied by reference)

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject Clone()
public IErlObject Clone()
Public Function Clone As IErlObject
Public Function Clone As IErlObject
public:
virtual IErlObject^ Clone() sealed
public:
virtual IErlObject^ Clone() sealed
abstract Clone : unit -> IErlObject
override Clone : unit -> IErlObject
abstract Clone : unit -> IErlObject
override Clone : unit -> IErlObject

Return Value

Type: IErlObject

Implements

IErlObject Clone
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte.CompareTo Method

ErlByte CompareTo Method NFX Class Library

Overload List
 | Name | Description
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj
Back to Top
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte.CompareTo Method (Object)

ErlByte CompareTo Method (Object) NFX Class Library

Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    Object obj
)
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
Public Function CompareTo (
    obj As Object
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
public:
virtual int CompareTo(
    Object^ obj
) sealed
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int

Parameters

obj
Type: Online System Object

Return Value

Type: Online Int32

Implements

Online IComparable CompareTo(Object)
See Also
ErlByte Structure
ErlByte Members
CompareTo Overload
NFX.Erlang Namespace


ErlByte.CompareTo Method (IErlObject)

ErlByte CompareTo Method (IErlObject) NFX Class Library

Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    IErlObject obj
)
public int CompareTo(
    IErlObject obj
)
Public Function CompareTo (
    obj As IErlObject
) As Integer
Public Function CompareTo (
    obj As IErlObject
) As Integer
public:
virtual int CompareTo(
    IErlObject^ obj
) sealed
public:
virtual int CompareTo(
    IErlObject^ obj
) sealed
abstract CompareTo :
        obj : IErlObject -> int
override CompareTo :
        obj : IErlObject -> int
abstract CompareTo :
        obj : IErlObject -> int
override CompareTo :
        obj : IErlObject -> int

Parameters

obj
Type: NFX.Erlang IErlObject

Return Value

Type: Online Int32

Implements

Online IComparable T CompareTo(T)
See Also
ErlByte Structure
ErlByte Members
CompareTo Overload
NFX.Erlang Namespace


ErlByte.Equals Method

ErlByte Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | Determine if this atom equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(ErlByte) | Determine if two instances are equal
Public method | Equals(ErlLong) |
Public method | Equals(IErlObject) | Determine if two values are equal
Back to Top
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte.Equals Method (Object)

ErlByte Equals Method (Object) NFX Class Library

Determine if this atom equals to the object

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals (
    o As Object
) As Boolean
Public Overrides Function Equals (
    o As Object
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool

Parameters

o
Type: Online System Object

Return Value

Type: Online Boolean
See Also
ErlByte Structure
ErlByte Members
Equals Overload
NFX.Erlang Namespace


ErlByte.Equals Method (ErlByte)

ErlByte Equals Method (ErlByte) NFX Class Library

Determine if two instances are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    ErlByte o
)
public bool Equals(
    ErlByte o
)
Public Function Equals (
    o As ErlByte
) As Boolean
Public Function Equals (
    o As ErlByte
) As Boolean
public:
bool Equals(
    ErlByte o
)
public:
bool Equals(
    ErlByte o
)
member Equals :
        o : ErlByte -> bool
member Equals :
        o : ErlByte -> bool

Parameters

o
Type: NFX.Erlang ErlByte

Return Value

Type: Online Boolean
See Also
ErlByte Structure
ErlByte Members
Equals Overload
NFX.Erlang Namespace


ErlByte.Equals Method (ErlLong)

ErlByte Equals Method (ErlLong) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    ErlLong o
)
public bool Equals(
    ErlLong o
)
Public Function Equals (
    o As ErlLong
) As Boolean
Public Function Equals (
    o As ErlLong
) As Boolean
public:
bool Equals(
    ErlLong o
)
public:
bool Equals(
    ErlLong o
)
member Equals :
        o : ErlLong -> bool
member Equals :
        o : ErlLong -> bool

Parameters

o
Type: NFX.Erlang ErlLong

Return Value

Type: Online Boolean
See Also
ErlByte Structure
ErlByte Members
Equals Overload
NFX.Erlang Namespace


ErlByte.Equals Method (IErlObject)

ErlByte Equals Method (IErlObject) NFX Class Library

Determine if two values are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    IErlObject o
)
public bool Equals(
    IErlObject o
)
Public Function Equals (
    o As IErlObject
) As Boolean
Public Function Equals (
    o As IErlObject
) As Boolean
public:
virtual bool Equals(
    IErlObject^ o
) sealed
public:
virtual bool Equals(
    IErlObject^ o
) sealed
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool

Parameters

o
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
ErlByte Structure
ErlByte Members
Equals Overload
NFX.Erlang Namespace


ErlByte.GetHashCode Method

ErlByte GetHashCode Method NFX Class Library

Get internal hash code

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte.Match Method

ErlByte Match Method NFX Class Library

Overload List
 | Name | Description
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Back to Top
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte.Match Method (IErlObject)

ErlByte Match Method (IErlObject) NFX Class Library

Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlVarBind Match(
    IErlObject pattern
)
public ErlVarBind Match(
    IErlObject pattern
)
Public Function Match (
    pattern As IErlObject
) As ErlVarBind
Public Function Match (
    pattern As IErlObject
) As ErlVarBind
public:
virtual ErlVarBind^ Match(
    IErlObject^ pattern
) sealed
public:
virtual ErlVarBind^ Match(
    IErlObject^ pattern
) sealed
abstract Match :
        pattern : IErlObject -> ErlVarBind
override Match :
        pattern : IErlObject -> ErlVarBind
abstract Match :
        pattern : IErlObject -> ErlVarBind
override Match :
        pattern : IErlObject -> ErlVarBind

Parameters

pattern
Type: NFX.Erlang IErlObject

Return Value

Type: ErlVarBind

Implements

IErlObject Match(IErlObject)
See Also
ErlByte Structure
ErlByte Members
Match Overload
NFX.Erlang Namespace


ErlByte.Match Method (IErlObject, ErlVarBind)

ErlByte Match Method (IErlObject, ErlVarBind) NFX Class Library

[This is preliminary documentation and is subject to change.]

Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Match(
    IErlObject pattern,
    ErlVarBind binding
)
public bool Match(
    IErlObject pattern,
    ErlVarBind binding
)
Public Function Match (
    pattern As IErlObject,
    binding As ErlVarBind
) As Boolean
Public Function Match (
    pattern As IErlObject,
    binding As ErlVarBind
) As Boolean
public:
virtual bool Match(
    IErlObject^ pattern,
    ErlVarBind^ binding
) sealed
public:
virtual bool Match(
    IErlObject^ pattern,
    ErlVarBind^ binding
) sealed
abstract Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
override Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
abstract Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
override Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool

Parameters

pattern
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind

Return Value

Type: Online Boolean

Implements

IErlObject Match(IErlObject, ErlVarBind)
See Also
ErlByte Structure
ErlByte Members
Match Overload
NFX.Erlang Namespace


ErlByte.Matches Method

ErlByte Matches Method NFX Class Library

Perform pattern match on this Erlang term without binding any variables

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Matches(
    IErlObject pattern
)
public bool Matches(
    IErlObject pattern
)
Public Function Matches (
    pattern As IErlObject
) As Boolean
Public Function Matches (
    pattern As IErlObject
) As Boolean
public:
virtual bool Matches(
    IErlObject^ pattern
) sealed
public:
virtual bool Matches(
    IErlObject^ pattern
) sealed
abstract Matches :
        pattern : IErlObject -> bool
override Matches :
        pattern : IErlObject -> bool
abstract Matches :
        pattern : IErlObject -> bool
override Matches :
        pattern : IErlObject -> bool

Parameters

pattern
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Implements

IErlObject Matches(IErlObject)
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte.Subst Method

ErlByte Subst Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Subst(
    ref IErlObject term,
    ErlVarBind binding
)
public bool Subst(
    ref IErlObject term,
    ErlVarBind binding
)
Public Function Subst (
    ByRef term As IErlObject,
    binding As ErlVarBind
) As Boolean
Public Function Subst (
    ByRef term As IErlObject,
    binding As ErlVarBind
) As Boolean
public:
virtual bool Subst(
    IErlObject^% term,
    ErlVarBind^ binding
) sealed
public:
virtual bool Subst(
    IErlObject^% term,
    ErlVarBind^ binding
) sealed
abstract Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
override Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
abstract Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
override Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool

Parameters

term
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind

Return Value

Type: Online Boolean

Implements

IErlObject Subst(IErlObject , ErlVarBind)
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte.ToString Method

ErlByte ToString Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte.Visit(TAccumulate) Method

ErlByte Visit TAccumulate Method NFX Class Library

Execute fun for every nested term

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TAccumulate Visit<TAccumulate>(
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
public TAccumulate Visit<TAccumulate>(
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
Public Function Visit(Of TAccumulate) (
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
Public Function Visit(Of TAccumulate) (
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
public:
generic<typename TAccumulate>
virtual TAccumulate Visit(
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
) sealed
public:
generic<typename TAccumulate>
virtual TAccumulate Visit(
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
) sealed
abstract Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
override Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
abstract Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
override Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate

Parameters

acc
Type: TAccumulate
fun
Type: Online System Func TAccumulate, IErlObject, TAccumulate
Type Parameters
TAccumulate

Return Value

Type: TAccumulate

Implements

IErlObject Visit TAccumulate (TAccumulate, Func TAccumulate, IErlObject, TAccumulate )
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte Operators and Type Conversions

ErlByte Operators and Type Conversions NFX Class Library

Operators
Name | Description
Equality(Byte, ErlByte) |
Equality(Char, ErlByte) |
Equality(ErlByte, ErlByte) |
Equality(ErlByte, Byte) |
Equality(ErlByte, Char) |
(Char to ErlByte) |
(Int32 to ErlByte) | Implicit conversion of byte/char to ErlByte
(ErlByte to Char) |
(Byte to ErlByte) |
(ErlByte to Byte) | Implicit conversion of ErlByte to byte
Inequality(Byte, ErlByte) |
Inequality(Char, ErlByte) |
Inequality(ErlByte, ErlByte) |
Inequality(ErlByte, Byte) |
Inequality(ErlByte, Char) |
Back to Top
See Also
ErlByte Structure
NFX.Erlang Namespace


ErlByte.Equality Operator

ErlByte Equality Operator NFX Class Library

Overload List
Name | Description
Equality(Byte, ErlByte) |
Equality(Char, ErlByte) |
Equality(ErlByte, ErlByte) |
Equality(ErlByte, Byte) |
Equality(ErlByte, Char) |
Back to Top
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte.Equality Operator (Byte, ErlByte)

ErlByte Equality Operator (Byte, ErlByte) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    byte lhs,
    ErlByte rhs
)
public static bool operator ==(
    byte lhs,
    ErlByte rhs
)
Public Shared Operator = (
    lhs As Byte,
    rhs As ErlByte
) As Boolean
Public Shared Operator = (
    lhs As Byte,
    rhs As ErlByte
) As Boolean
public:
static bool operator ==(
    unsigned char lhs,
    ErlByte rhs
)
public:
static bool operator ==(
    unsigned char lhs,
    ErlByte rhs
)
static let inline (=)
        lhs : byte *
        rhs : ErlByte  : bool
static let inline (=)
        lhs : byte *
        rhs : ErlByte  : bool

Parameters

lhs
Type: Online System Byte
rhs
Type: NFX.Erlang ErlByte

Return Value

Type: Online Boolean
See Also
ErlByte Structure
ErlByte Members
Equality Overload
NFX.Erlang Namespace


ErlByte.Equality Operator (Char, ErlByte)

ErlByte Equality Operator (Char, ErlByte) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    char lhs,
    ErlByte rhs
)
public static bool operator ==(
    char lhs,
    ErlByte rhs
)
Public Shared Operator = (
    lhs As Char,
    rhs As ErlByte
) As Boolean
Public Shared Operator = (
    lhs As Char,
    rhs As ErlByte
) As Boolean
public:
static bool operator ==(
    wchar_t lhs,
    ErlByte rhs
)
public:
static bool operator ==(
    wchar_t lhs,
    ErlByte rhs
)
static let inline (=)
        lhs : char *
        rhs : ErlByte  : bool
static let inline (=)
        lhs : char *
        rhs : ErlByte  : bool

Parameters

lhs
Type: Online System Char
rhs
Type: NFX.Erlang ErlByte

Return Value

Type: Online Boolean
See Also
ErlByte Structure
ErlByte Members
Equality Overload
NFX.Erlang Namespace


ErlByte.Equality Operator (ErlByte, ErlByte)

ErlByte Equality Operator (ErlByte, ErlByte) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    ErlByte lhs,
    ErlByte rhs
)
public static bool operator ==(
    ErlByte lhs,
    ErlByte rhs
)
Public Shared Operator = (
    lhs As ErlByte,
    rhs As ErlByte
) As Boolean
Public Shared Operator = (
    lhs As ErlByte,
    rhs As ErlByte
) As Boolean
public:
static bool operator ==(
    ErlByte lhs,
    ErlByte rhs
)
public:
static bool operator ==(
    ErlByte lhs,
    ErlByte rhs
)
static let inline (=)
        lhs : ErlByte *
        rhs : ErlByte  : bool
static let inline (=)
        lhs : ErlByte *
        rhs : ErlByte  : bool

Parameters

lhs
Type: NFX.Erlang ErlByte
rhs
Type: NFX.Erlang ErlByte

Return Value

Type: Online Boolean
See Also
ErlByte Structure
ErlByte Members
Equality Overload
NFX.Erlang Namespace


ErlByte.Equality Operator (ErlByte, Byte)

ErlByte Equality Operator (ErlByte, Byte) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    ErlByte lhs,
    byte rhs
)
public static bool operator ==(
    ErlByte lhs,
    byte rhs
)
Public Shared Operator = (
    lhs As ErlByte,
    rhs As Byte
) As Boolean
Public Shared Operator = (
    lhs As ErlByte,
    rhs As Byte
) As Boolean
public:
static bool operator ==(
    ErlByte lhs,
    unsigned char rhs
)
public:
static bool operator ==(
    ErlByte lhs,
    unsigned char rhs
)
static let inline (=)
        lhs : ErlByte *
        rhs : byte  : bool
static let inline (=)
        lhs : ErlByte *
        rhs : byte  : bool

Parameters

lhs
Type: NFX.Erlang ErlByte
rhs
Type: Online System Byte

Return Value

Type: Online Boolean
See Also
ErlByte Structure
ErlByte Members
Equality Overload
NFX.Erlang Namespace


ErlByte.Equality Operator (ErlByte, Char)

ErlByte Equality Operator (ErlByte, Char) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    ErlByte lhs,
    char rhs
)
public static bool operator ==(
    ErlByte lhs,
    char rhs
)
Public Shared Operator = (
    lhs As ErlByte,
    rhs As Char
) As Boolean
Public Shared Operator = (
    lhs As ErlByte,
    rhs As Char
) As Boolean
public:
static bool operator ==(
    ErlByte lhs,
    wchar_t rhs
)
public:
static bool operator ==(
    ErlByte lhs,
    wchar_t rhs
)
static let inline (=)
        lhs : ErlByte *
        rhs : char  : bool
static let inline (=)
        lhs : ErlByte *
        rhs : char  : bool

Parameters

lhs
Type: NFX.Erlang ErlByte
rhs
Type: Online System Char

Return Value

Type: Online Boolean
See Also
ErlByte Structure
ErlByte Members
Equality Overload
NFX.Erlang Namespace


ErlByte Explicit Conversion Operators

ErlByte Conversion Operators NFX Class Library

Overload List
Name | Description
(Char to ErlByte) |
(Int32 to ErlByte) | Implicit conversion of byte/char to ErlByte
(ErlByte to Char) |
Back to Top
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte Explicit Conversion (Char to ErlByte)

ErlByte Conversion (Char to ErlByte) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static explicit operator ErlByte (
    char t
)
public static explicit operator ErlByte (
    char t
)
Public Shared Narrowing Operator CType (
    t As Char
) As ErlByte
Public Shared Narrowing Operator CType (
    t As Char
) As ErlByte
static explicit operator ErlByte (
    wchar_t t
)
static explicit operator ErlByte (
    wchar_t t
)
F# does not support the declaration of new casting operators.
F# does not support the declaration of new casting operators.

Parameters

t
Type: Online System Char

Return Value

Type: ErlByte
See Also
ErlByte Structure
ErlByte Members
Overload
NFX.Erlang Namespace


ErlByte Explicit Conversion (Int32 to ErlByte)

ErlByte Conversion (Int32 to ErlByte) NFX Class Library

Implicit conversion of byte/char to ErlByte

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static explicit operator ErlByte (
    int t
)
public static explicit operator ErlByte (
    int t
)
Public Shared Narrowing Operator CType (
    t As Integer
) As ErlByte
Public Shared Narrowing Operator CType (
    t As Integer
) As ErlByte
static explicit operator ErlByte (
    int t
)
static explicit operator ErlByte (
    int t
)
F# does not support the declaration of new casting operators.
F# does not support the declaration of new casting operators.

Parameters

t
Type: Online System Int32

Return Value

Type: ErlByte
See Also
ErlByte Structure
ErlByte Members
Overload
NFX.Erlang Namespace


ErlByte Explicit Conversion (ErlByte to Char)

ErlByte Conversion (ErlByte to Char) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static explicit operator char (
    ErlByte t
)
public static explicit operator char (
    ErlByte t
)
Public Shared Narrowing Operator CType (
    t As ErlByte
) As Char
Public Shared Narrowing Operator CType (
    t As ErlByte
) As Char
static explicit operator wchar_t (
    ErlByte t
)
static explicit operator wchar_t (
    ErlByte t
)
F# does not support the declaration of new casting operators.
F# does not support the declaration of new casting operators.

Parameters

t
Type: NFX.Erlang ErlByte

Return Value

Type: Online Char
See Also
ErlByte Structure
ErlByte Members
Overload
NFX.Erlang Namespace


ErlByte Implicit Conversion Operators

ErlByte Conversion Operators NFX Class Library

Overload List
Name | Description
(Byte to ErlByte) |
(ErlByte to Byte) | Implicit conversion of ErlByte to byte
Back to Top
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte Implicit Conversion (Byte to ErlByte)

ErlByte Conversion (Byte to ErlByte) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static implicit operator ErlByte (
    byte t
)
public static implicit operator ErlByte (
    byte t
)
Public Shared Widening Operator CType (
    t As Byte
) As ErlByte
Public Shared Widening Operator CType (
    t As Byte
) As ErlByte
static implicit operator ErlByte (
    unsigned char t
)
static implicit operator ErlByte (
    unsigned char t
)
F# does not support the declaration of new casting operators.
F# does not support the declaration of new casting operators.

Parameters

t
Type: Online System Byte

Return Value

Type: ErlByte
See Also
ErlByte Structure
ErlByte Members
Overload
NFX.Erlang Namespace


ErlByte Implicit Conversion (ErlByte to Byte)

ErlByte Conversion (ErlByte to Byte) NFX Class Library

Implicit conversion of ErlByte to byte

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static implicit operator byte (
    ErlByte t
)
public static implicit operator byte (
    ErlByte t
)
Public Shared Widening Operator CType (
    t As ErlByte
) As Byte
Public Shared Widening Operator CType (
    t As ErlByte
) As Byte
static implicit operator unsigned char (
    ErlByte t
)
static implicit operator unsigned char (
    ErlByte t
)
F# does not support the declaration of new casting operators.
F# does not support the declaration of new casting operators.

Parameters

t
Type: NFX.Erlang ErlByte

Return Value

Type: Online Byte
See Also
ErlByte Structure
ErlByte Members
Overload
NFX.Erlang Namespace


ErlByte.Inequality Operator

ErlByte Inequality Operator NFX Class Library

Overload List
Name | Description
Inequality(Byte, ErlByte) |
Inequality(Char, ErlByte) |
Inequality(ErlByte, ErlByte) |
Inequality(ErlByte, Byte) |
Inequality(ErlByte, Char) |
Back to Top
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte.Inequality Operator (Byte, ErlByte)

ErlByte Inequality Operator (Byte, ErlByte) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    byte lhs,
    ErlByte rhs
)
public static bool operator !=(
    byte lhs,
    ErlByte rhs
)
Public Shared Operator <> (
    lhs As Byte,
    rhs As ErlByte
) As Boolean
Public Shared Operator <> (
    lhs As Byte,
    rhs As ErlByte
) As Boolean
public:
static bool operator !=(
    unsigned char lhs,
    ErlByte rhs
)
public:
static bool operator !=(
    unsigned char lhs,
    ErlByte rhs
)
static let inline (<>)
        lhs : byte *
        rhs : ErlByte  : bool
static let inline (<>)
        lhs : byte *
        rhs : ErlByte  : bool

Parameters

lhs
Type: Online System Byte
rhs
Type: NFX.Erlang ErlByte

Return Value

Type: Online Boolean
See Also
ErlByte Structure
ErlByte Members
Inequality Overload
NFX.Erlang Namespace


ErlByte.Inequality Operator (Char, ErlByte)

ErlByte Inequality Operator (Char, ErlByte) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    char lhs,
    ErlByte rhs
)
public static bool operator !=(
    char lhs,
    ErlByte rhs
)
Public Shared Operator <> (
    lhs As Char,
    rhs As ErlByte
) As Boolean
Public Shared Operator <> (
    lhs As Char,
    rhs As ErlByte
) As Boolean
public:
static bool operator !=(
    wchar_t lhs,
    ErlByte rhs
)
public:
static bool operator !=(
    wchar_t lhs,
    ErlByte rhs
)
static let inline (<>)
        lhs : char *
        rhs : ErlByte  : bool
static let inline (<>)
        lhs : char *
        rhs : ErlByte  : bool

Parameters

lhs
Type: Online System Char
rhs
Type: NFX.Erlang ErlByte

Return Value

Type: Online Boolean
See Also
ErlByte Structure
ErlByte Members
Inequality Overload
NFX.Erlang Namespace


ErlByte.Inequality Operator (ErlByte, ErlByte)

ErlByte Inequality Operator (ErlByte, ErlByte) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    ErlByte lhs,
    ErlByte rhs
)
public static bool operator !=(
    ErlByte lhs,
    ErlByte rhs
)
Public Shared Operator <> (
    lhs As ErlByte,
    rhs As ErlByte
) As Boolean
Public Shared Operator <> (
    lhs As ErlByte,
    rhs As ErlByte
) As Boolean
public:
static bool operator !=(
    ErlByte lhs,
    ErlByte rhs
)
public:
static bool operator !=(
    ErlByte lhs,
    ErlByte rhs
)
static let inline (<>)
        lhs : ErlByte *
        rhs : ErlByte  : bool
static let inline (<>)
        lhs : ErlByte *
        rhs : ErlByte  : bool

Parameters

lhs
Type: NFX.Erlang ErlByte
rhs
Type: NFX.Erlang ErlByte

Return Value

Type: Online Boolean
See Also
ErlByte Structure
ErlByte Members
Inequality Overload
NFX.Erlang Namespace


ErlByte.Inequality Operator (ErlByte, Byte)

ErlByte Inequality Operator (ErlByte, Byte) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    ErlByte lhs,
    byte rhs
)
public static bool operator !=(
    ErlByte lhs,
    byte rhs
)
Public Shared Operator <> (
    lhs As ErlByte,
    rhs As Byte
) As Boolean
Public Shared Operator <> (
    lhs As ErlByte,
    rhs As Byte
) As Boolean
public:
static bool operator !=(
    ErlByte lhs,
    unsigned char rhs
)
public:
static bool operator !=(
    ErlByte lhs,
    unsigned char rhs
)
static let inline (<>)
        lhs : ErlByte *
        rhs : byte  : bool
static let inline (<>)
        lhs : ErlByte *
        rhs : byte  : bool

Parameters

lhs
Type: NFX.Erlang ErlByte
rhs
Type: Online System Byte

Return Value

Type: Online Boolean
See Also
ErlByte Structure
ErlByte Members
Inequality Overload
NFX.Erlang Namespace


ErlByte.Inequality Operator (ErlByte, Char)

ErlByte Inequality Operator (ErlByte, Char) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    ErlByte lhs,
    char rhs
)
public static bool operator !=(
    ErlByte lhs,
    char rhs
)
Public Shared Operator <> (
    lhs As ErlByte,
    rhs As Char
) As Boolean
Public Shared Operator <> (
    lhs As ErlByte,
    rhs As Char
) As Boolean
public:
static bool operator !=(
    ErlByte lhs,
    wchar_t rhs
)
public:
static bool operator !=(
    ErlByte lhs,
    wchar_t rhs
)
static let inline (<>)
        lhs : ErlByte *
        rhs : char  : bool
static let inline (<>)
        lhs : ErlByte *
        rhs : char  : bool

Parameters

lhs
Type: NFX.Erlang ErlByte
rhs
Type: Online System Char

Return Value

Type: Online Boolean
See Also
ErlByte Structure
ErlByte Members
Inequality Overload
NFX.Erlang Namespace


ErlByte Properties

ErlByte Properties NFX Class Library

The ErlByte type exposes the following members.
Properties
 | Name | Description
Public property | IsScalar |
Public property | TypeOrder |
Public property | Value |
Public property | ValueAsBool |
Public property | ValueAsByteArray |
Public property | ValueAsChar |
Public property | ValueAsDateTime |
Public property | ValueAsDecimal |
Public property | ValueAsDouble |
Public property | ValueAsInt |
Public property | ValueAsLong |
Public property | ValueAsObject |
Public property | ValueAsString |
Public property | ValueAsTimeSpan |
Back to Top
See Also
ErlByte Structure
NFX.Erlang Namespace


ErlByte.IsScalar Property

ErlByte IsScalar Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsScalar { get; }
public bool IsScalar { get; }
Public ReadOnly Property IsScalar As Boolean
    Get
Public ReadOnly Property IsScalar As Boolean
    Get
public:
virtual property bool IsScalar {
    bool get () sealed;
}
public:
virtual property bool IsScalar {
    bool get () sealed;
}
abstract IsScalar : bool with get
override IsScalar : bool with get
abstract IsScalar : bool with get
override IsScalar : bool with get

Property Value

Type: Online Boolean

Implements

IErlObject IsScalar
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte.TypeOrder Property

ErlByte TypeOrder Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTypeOrder TypeOrder { get; }
public ErlTypeOrder TypeOrder { get; }
Public ReadOnly Property TypeOrder As ErlTypeOrder
    Get
Public ReadOnly Property TypeOrder As ErlTypeOrder
    Get
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () sealed;
}
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () sealed;
}
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get

Property Value

Type: ErlTypeOrder

Implements

IErlObject TypeOrder
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte.Value Property

ErlByte Value Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte Value { get; }
public byte Value { get; }
Public ReadOnly Property Value As Byte
    Get
Public ReadOnly Property Value As Byte
    Get
public:
virtual property unsigned char Value {
    unsigned char get () sealed;
}
public:
virtual property unsigned char Value {
    unsigned char get () sealed;
}
abstract Value : byte with get
override Value : byte with get
abstract Value : byte with get
override Value : byte with get

Property Value

Type: Online Byte

Implements

IErlObject T Value
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte.ValueAsBool Property

ErlByte ValueAsBool Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ValueAsBool { get; }
public bool ValueAsBool { get; }
Public ReadOnly Property ValueAsBool As Boolean
    Get
Public ReadOnly Property ValueAsBool As Boolean
    Get
public:
virtual property bool ValueAsBool {
    bool get () sealed;
}
public:
virtual property bool ValueAsBool {
    bool get () sealed;
}
abstract ValueAsBool : bool with get
override ValueAsBool : bool with get
abstract ValueAsBool : bool with get
override ValueAsBool : bool with get

Property Value

Type: Online Boolean

Implements

IErlObject ValueAsBool
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte.ValueAsByteArray Property

ErlByte ValueAsByteArray Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] ValueAsByteArray { get; }
public byte[] ValueAsByteArray { get; }
Public ReadOnly Property ValueAsByteArray As Byte()
    Get
Public ReadOnly Property ValueAsByteArray As Byte()
    Get
public:
virtual property array<unsigned char>^ ValueAsByteArray {
    array<unsigned char>^ get () sealed;
}
public:
virtual property array<unsigned char>^ ValueAsByteArray {
    array<unsigned char>^ get () sealed;
}
abstract ValueAsByteArray : byte[] with get
override ValueAsByteArray : byte[] with get
abstract ValueAsByteArray : byte[] with get
override ValueAsByteArray : byte[] with get

Property Value

Type: Online Byte

Implements

IErlObject ValueAsByteArray
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte.ValueAsChar Property

ErlByte ValueAsChar Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char ValueAsChar { get; }
public char ValueAsChar { get; }
Public ReadOnly Property ValueAsChar As Char
    Get
Public ReadOnly Property ValueAsChar As Char
    Get
public:
virtual property wchar_t ValueAsChar {
    wchar_t get () sealed;
}
public:
virtual property wchar_t ValueAsChar {
    wchar_t get () sealed;
}
abstract ValueAsChar : char with get
override ValueAsChar : char with get
abstract ValueAsChar : char with get
override ValueAsChar : char with get

Property Value

Type: Online Char

Implements

IErlObject ValueAsChar
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte.ValueAsDateTime Property

ErlByte ValueAsDateTime Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime ValueAsDateTime { get; }
public DateTime ValueAsDateTime { get; }
Public ReadOnly Property ValueAsDateTime As DateTime
    Get
Public ReadOnly Property ValueAsDateTime As DateTime
    Get
public:
virtual property DateTime ValueAsDateTime {
    DateTime get () sealed;
}
public:
virtual property DateTime ValueAsDateTime {
    DateTime get () sealed;
}
abstract ValueAsDateTime : DateTime with get
override ValueAsDateTime : DateTime with get
abstract ValueAsDateTime : DateTime with get
override ValueAsDateTime : DateTime with get

Property Value

Type: Online DateTime

Implements

IErlObject ValueAsDateTime
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte.ValueAsDecimal Property

ErlByte ValueAsDecimal Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal ValueAsDecimal { get; }
public decimal ValueAsDecimal { get; }
Public ReadOnly Property ValueAsDecimal As Decimal
    Get
Public ReadOnly Property ValueAsDecimal As Decimal
    Get
public:
virtual property Decimal ValueAsDecimal {
    Decimal get () sealed;
}
public:
virtual property Decimal ValueAsDecimal {
    Decimal get () sealed;
}
abstract ValueAsDecimal : decimal with get
override ValueAsDecimal : decimal with get
abstract ValueAsDecimal : decimal with get
override ValueAsDecimal : decimal with get

Property Value

Type: Online Decimal

Implements

IErlObject ValueAsDecimal
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte.ValueAsDouble Property

ErlByte ValueAsDouble Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double ValueAsDouble { get; }
public double ValueAsDouble { get; }
Public ReadOnly Property ValueAsDouble As Double
    Get
Public ReadOnly Property ValueAsDouble As Double
    Get
public:
virtual property double ValueAsDouble {
    double get () sealed;
}
public:
virtual property double ValueAsDouble {
    double get () sealed;
}
abstract ValueAsDouble : float with get
override ValueAsDouble : float with get
abstract ValueAsDouble : float with get
override ValueAsDouble : float with get

Property Value

Type: Online Double

Implements

IErlObject ValueAsDouble
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte.ValueAsInt Property

ErlByte ValueAsInt Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ValueAsInt { get; }
public int ValueAsInt { get; }
Public ReadOnly Property ValueAsInt As Integer
    Get
Public ReadOnly Property ValueAsInt As Integer
    Get
public:
virtual property int ValueAsInt {
    int get () sealed;
}
public:
virtual property int ValueAsInt {
    int get () sealed;
}
abstract ValueAsInt : int with get
override ValueAsInt : int with get
abstract ValueAsInt : int with get
override ValueAsInt : int with get

Property Value

Type: Online Int32

Implements

IErlObject ValueAsInt
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte.ValueAsLong Property

ErlByte ValueAsLong Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long ValueAsLong { get; }
public long ValueAsLong { get; }
Public ReadOnly Property ValueAsLong As Long
    Get
Public ReadOnly Property ValueAsLong As Long
    Get
public:
virtual property long long ValueAsLong {
    long long get () sealed;
}
public:
virtual property long long ValueAsLong {
    long long get () sealed;
}
abstract ValueAsLong : int64 with get
override ValueAsLong : int64 with get
abstract ValueAsLong : int64 with get
override ValueAsLong : int64 with get

Property Value

Type: Online Int64

Implements

IErlObject ValueAsLong
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte.ValueAsObject Property

ErlByte ValueAsObject Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object ValueAsObject { get; }
public Object ValueAsObject { get; }
Public ReadOnly Property ValueAsObject As Object
    Get
Public ReadOnly Property ValueAsObject As Object
    Get
public:
virtual property Object^ ValueAsObject {
    Object^ get () sealed;
}
public:
virtual property Object^ ValueAsObject {
    Object^ get () sealed;
}
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get

Property Value

Type: Online Object

Implements

IErlObject ValueAsObject
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte.ValueAsString Property

ErlByte ValueAsString Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ValueAsString { get; }
public string ValueAsString { get; }
Public ReadOnly Property ValueAsString As String
    Get
Public ReadOnly Property ValueAsString As String
    Get
public:
virtual property String^ ValueAsString {
    String^ get () sealed;
}
public:
virtual property String^ ValueAsString {
    String^ get () sealed;
}
abstract ValueAsString : string with get
override ValueAsString : string with get
abstract ValueAsString : string with get
override ValueAsString : string with get

Property Value

Type: Online String

Implements

IErlObject ValueAsString
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlByte.ValueAsTimeSpan Property

ErlByte ValueAsTimeSpan Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpan ValueAsTimeSpan { get; }
public TimeSpan ValueAsTimeSpan { get; }
Public ReadOnly Property ValueAsTimeSpan As TimeSpan
    Get
Public ReadOnly Property ValueAsTimeSpan As TimeSpan
    Get
public:
virtual property TimeSpan ValueAsTimeSpan {
    TimeSpan get () sealed;
}
public:
virtual property TimeSpan ValueAsTimeSpan {
    TimeSpan get () sealed;
}
abstract ValueAsTimeSpan : TimeSpan with get
override ValueAsTimeSpan : TimeSpan with get
abstract ValueAsTimeSpan : TimeSpan with get
override ValueAsTimeSpan : TimeSpan with get

Property Value

Type: Online TimeSpan

Implements

IErlObject ValueAsTimeSpan
See Also
ErlByte Structure
ErlByte Members
NFX.Erlang Namespace


ErlConnection Class

ErlConnection Class NFX Class Library

Maintains a connection between a C# process and a remote Erlang, C# or C node. The object maintains connection state and allows data to be sent to and received from the peer
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Erlang ErlAbstractConnection
NFX.Erlang ErlConnection

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ErlConnection : ErlAbstractConnection
public class ErlConnection : ErlAbstractConnection
Public Class ErlConnection
    Inherits ErlAbstractConnection
Public Class ErlConnection
    Inherits ErlAbstractConnection
public ref class ErlConnection : public ErlAbstractConnection
public ref class ErlConnection : public ErlAbstractConnection
type ErlConnection =
    class
        inherit ErlAbstractConnection
    end
type ErlConnection =
    class
        inherit ErlAbstractConnection
    end
Remarks
In current implementation each connection creates a thread
See Also
ErlConnection Members
NFX.Erlang Namespace


ErlConnection Members

ErlConnection Members NFX Class Library

The ErlConnection type exposes the following members.
Constructors
 | Name | Description
Public method | ErlConnection(ErlLocalNode, TcpClient) | Accept an incoming connection from a remote node
Protected method | ErlConnection(ErlLocalNode, ErlRemoteNode, Boolean) | Intiate and open a connection to a remote node
Back to Top
Methods
 | Name | Description
Protected method | Close | (Overrides ErlAbstractConnection Close .)
Protected method | Connect | (Inherited from ErlAbstractConnection.)
Protected method | Deliver(ErlConnectionException) | Deliver communication exceptions to the recipient (Overrides ErlAbstractConnection Deliver(ErlConnectionException).)
Protected method | Deliver(ErlMsg) | Deliver messages to the recipient (Overrides ErlAbstractConnection Deliver(ErlMsg).)
Protected method | Destructor | (Inherited from ErlAbstractConnection.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoSend | (Inherited from ErlAbstractConnection.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | HeaderType | (Inherited from ErlAbstractConnection.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadSock | Read data from socket (Inherited from ErlAbstractConnection.)
Protected method | Send(ErlMsg) | (Inherited from ErlAbstractConnection.)
Public method | Send(ErlPid, IErlObject) | Send an Erlang term to a Pid on a local or remote node
Public method | Send(ErlPid, ErlAtom, IErlObject) |
Public method | SendRPC | Send an RPC request to the remote Erlang node (Inherited from ErlAbstractConnection.)
Public method | SendRPCcast | Send an RPC cast request to the remote Erlang node (Inherited from ErlAbstractConnection.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Connected | (Inherited from ErlAbstractConnection.)
Protected field | m_Cookie | (Inherited from ErlAbstractConnection.)
Protected field | m_CookieOk | (Inherited from ErlAbstractConnection.)
Protected field | m_Done |
Protected field | m_Home | (Inherited from ErlAbstractConnection.)
Protected field | m_Peer | (Inherited from ErlAbstractConnection.)
Protected field | m_ShouldSendCookie | (Inherited from ErlAbstractConnection.)
Protected field | m_Transport | (Inherited from ErlAbstractConnection.)
Back to Top
Properties
 | Name | Description
Public property | Connected | Determine if the connection is still alive. Note that this method only reports the status of the connection, and that it is possible that there are unread messages waiting in the receive queue (Inherited from ErlAbstractConnection.)
Public property | Cookie | (Inherited from ErlAbstractConnection.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | LocalNode | (Inherited from ErlAbstractConnection.)
Public property | MaxPayloadLength | Max size of the message accepted from the peer. The connection will be closed if a message is received of size greater than this. (Inherited from ErlAbstractConnection.)
Public property | Name | (Inherited from ErlAbstractConnection.)
Public property | ReceivedBytes | Total number of bytes received from connection (Inherited from ErlAbstractConnection.)
Public property | ReceivedMsgs | Total number of messages received from connection (Inherited from ErlAbstractConnection.)
Public property | RemoteNode | (Inherited from ErlAbstractConnection.)
Protected property | SendCookie | Cookie to send along with each distribution message (Inherited from ErlAbstractConnection.)
Public property | SentBytes | Total number of bytes sent through connection (Inherited from ErlAbstractConnection.)
Public property | SentMsgs | Total number of messages sent through connection (Inherited from ErlAbstractConnection.)
Public property | TraceLevel | Set the trace level for this connection. Normally tracing is off by default (Inherited from ErlAbstractConnection.)
Back to Top
See Also
ErlConnection Class
NFX.Erlang Namespace


ErlConnection Constructor

ErlConnection Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ErlConnection(ErlLocalNode, TcpClient) | Accept an incoming connection from a remote node
Protected method | ErlConnection(ErlLocalNode, ErlRemoteNode, Boolean) | Intiate and open a connection to a remote node
Back to Top
See Also
ErlConnection Class
ErlConnection Members
NFX.Erlang Namespace


ErlConnection Constructor (ErlLocalNode, TcpClient)

ErlConnection Constructor (ErlLocalNode, TcpClient) NFX Class Library

[This is preliminary documentation and is subject to change.]

Accept an incoming connection from a remote node

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlConnection(
    ErlLocalNode node,
    TcpClient peer
)
public ErlConnection(
    ErlLocalNode node,
    TcpClient peer
)
Public Sub New (
    node As ErlLocalNode,
    peer As TcpClient
)
Public Sub New (
    node As ErlLocalNode,
    peer As TcpClient
)
public:
ErlConnection(
    ErlLocalNode^ node,
    TcpClient^ peer
)
public:
ErlConnection(
    ErlLocalNode^ node,
    TcpClient^ peer
)
new :
        node : ErlLocalNode *
        peer : TcpClient -> ErlConnection
new :
        node : ErlLocalNode *
        peer : TcpClient -> ErlConnection

Parameters

node
Type: NFX.Erlang ErlLocalNode
peer
Type: Online System.Net.Sockets TcpClient
See Also
ErlConnection Class
ErlConnection Members
ErlConnection Overload
NFX.Erlang Namespace


ErlConnection Constructor (ErlLocalNode, ErlRemoteNode, Boolean)

ErlConnection Constructor (ErlLocalNode, ErlRemoteNode, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Intiate and open a connection to a remote node

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ErlConnection(
    ErlLocalNode node,
    ErlRemoteNode peer,
    bool connect = true
)
internal ErlConnection(
    ErlLocalNode node,
    ErlRemoteNode peer,
    bool connect = true
)
Friend Sub New (
    node As ErlLocalNode,
    peer As ErlRemoteNode,
    Optional connect As Boolean = true
)
Friend Sub New (
    node As ErlLocalNode,
    peer As ErlRemoteNode,
    Optional connect As Boolean = true
)
internal:
ErlConnection(
    ErlLocalNode^ node,
    ErlRemoteNode^ peer,
    bool connect = true
)
internal:
ErlConnection(
    ErlLocalNode^ node,
    ErlRemoteNode^ peer,
    bool connect = true
)
new :
        node : ErlLocalNode *
        peer : ErlRemoteNode *
        ?connect : bool
(* Defaults:
        let _connect = defaultArg connect true
*)
-> ErlConnection
new :
        node : ErlLocalNode *
        peer : ErlRemoteNode *
        ?connect : bool
(* Defaults:
        let _connect = defaultArg connect true
*)
-> ErlConnection

Parameters

node
Type: NFX.Erlang ErlLocalNode
peer
Type: NFX.Erlang ErlRemoteNode
connect (Optional)
Type: Online System Boolean
See Also
ErlConnection Class
ErlConnection Members
ErlConnection Overload
NFX.Erlang Namespace


ErlConnection Fields

ErlConnection Fields NFX Class Library

The ErlConnection type exposes the following members.
Fields
 | Name | Description
Protected field | m_Connected | (Inherited from ErlAbstractConnection.)
Protected field | m_Cookie | (Inherited from ErlAbstractConnection.)
Protected field | m_CookieOk | (Inherited from ErlAbstractConnection.)
Protected field | m_Done |
Protected field | m_Home | (Inherited from ErlAbstractConnection.)
Protected field | m_Peer | (Inherited from ErlAbstractConnection.)
Protected field | m_ShouldSendCookie | (Inherited from ErlAbstractConnection.)
Protected field | m_Transport | (Inherited from ErlAbstractConnection.)
Back to Top
See Also
ErlConnection Class
NFX.Erlang Namespace


ErlConnection.m_Done Field

ErlConnection m_Done Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool m_Done
protected bool m_Done
Protected m_Done As Boolean
Protected m_Done As Boolean
protected:
bool m_Done
protected:
bool m_Done
val mutable m_Done: bool
val mutable m_Done: bool

Field Value

Type: Online Boolean
See Also
ErlConnection Class
ErlConnection Members
NFX.Erlang Namespace


ErlConnection Methods

ErlConnection Methods NFX Class Library

The ErlConnection type exposes the following members.
Methods
 | Name | Description
Protected method | Close | (Overrides ErlAbstractConnection Close .)
Protected method | Connect | (Inherited from ErlAbstractConnection.)
Protected method | Deliver(ErlConnectionException) | Deliver communication exceptions to the recipient (Overrides ErlAbstractConnection Deliver(ErlConnectionException).)
Protected method | Deliver(ErlMsg) | Deliver messages to the recipient (Overrides ErlAbstractConnection Deliver(ErlMsg).)
Protected method | Destructor | (Inherited from ErlAbstractConnection.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoSend | (Inherited from ErlAbstractConnection.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | HeaderType | (Inherited from ErlAbstractConnection.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadSock | Read data from socket (Inherited from ErlAbstractConnection.)
Protected method | Send(ErlMsg) | (Inherited from ErlAbstractConnection.)
Public method | Send(ErlPid, IErlObject) | Send an Erlang term to a Pid on a local or remote node
Public method | Send(ErlPid, ErlAtom, IErlObject) |
Public method | SendRPC | Send an RPC request to the remote Erlang node (Inherited from ErlAbstractConnection.)
Public method | SendRPCcast | Send an RPC cast request to the remote Erlang node (Inherited from ErlAbstractConnection.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ErlConnection Class
NFX.Erlang Namespace


ErlConnection.Close Method

ErlConnection Close Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Close()
protected override void Close()
Protected Overrides Sub Close
Protected Overrides Sub Close
protected:
virtual void Close() override
protected:
virtual void Close() override
abstract Close : unit -> unit
override Close : unit -> unit
abstract Close : unit -> unit
override Close : unit -> unit
See Also
ErlConnection Class
ErlConnection Members
NFX.Erlang Namespace


ErlConnection.Deliver Method

ErlConnection Deliver Method NFX Class Library

Overload List
 | Name | Description
Protected method | Deliver(ErlConnectionException) | Deliver communication exceptions to the recipient (Overrides ErlAbstractConnection Deliver(ErlConnectionException).)
Protected method | Deliver(ErlMsg) | Deliver messages to the recipient (Overrides ErlAbstractConnection Deliver(ErlMsg).)
Back to Top
See Also
ErlConnection Class
ErlConnection Members
NFX.Erlang Namespace


ErlConnection.Deliver Method (ErlConnectionException)

ErlConnection Deliver Method (ErlConnectionException) NFX Class Library

[This is preliminary documentation and is subject to change.]

Deliver communication exceptions to the recipient

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Deliver(
    ErlConnectionException e
)
protected override void Deliver(
    ErlConnectionException e
)
Protected Overrides Sub Deliver (
    e As ErlConnectionException
)
Protected Overrides Sub Deliver (
    e As ErlConnectionException
)
protected:
virtual void Deliver(
    ErlConnectionException^ e
) override
protected:
virtual void Deliver(
    ErlConnectionException^ e
) override
abstract Deliver :
        e : ErlConnectionException -> unit
override Deliver :
        e : ErlConnectionException -> unit
abstract Deliver :
        e : ErlConnectionException -> unit
override Deliver :
        e : ErlConnectionException -> unit

Parameters

e
Type: NFX.Erlang ErlConnectionException
See Also
ErlConnection Class
ErlConnection Members
Deliver Overload
NFX.Erlang Namespace


ErlConnection.Deliver Method (ErlMsg)

ErlConnection Deliver Method (ErlMsg) NFX Class Library

Deliver messages to the recipient

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Deliver(
    ErlMsg msg
)
protected override void Deliver(
    ErlMsg msg
)
Protected Overrides Sub Deliver (
    msg As ErlMsg
)
Protected Overrides Sub Deliver (
    msg As ErlMsg
)
protected:
virtual void Deliver(
    ErlMsg^ msg
) override
protected:
virtual void Deliver(
    ErlMsg^ msg
) override
abstract Deliver :
        msg : ErlMsg -> unit
override Deliver :
        msg : ErlMsg -> unit
abstract Deliver :
        msg : ErlMsg -> unit
override Deliver :
        msg : ErlMsg -> unit

Parameters

msg
Type: NFX.Erlang ErlMsg
See Also
ErlConnection Class
ErlConnection Members
Deliver Overload
NFX.Erlang Namespace


ErlConnection.Send Method

ErlConnection Send Method NFX Class Library

Overload List
 | Name | Description
Protected method | Send(ErlMsg) | (Inherited from ErlAbstractConnection.)
Public method | Send(ErlPid, IErlObject) | Send an Erlang term to a Pid on a local or remote node
Public method | Send(ErlPid, ErlAtom, IErlObject) |
Back to Top
See Also
ErlConnection Class
ErlConnection Members
NFX.Erlang Namespace


ErlConnection.Send Method (ErlPid, IErlObject)

ErlConnection Send Method (ErlPid, IErlObject) NFX Class Library

[This is preliminary documentation and is subject to change.]

Send an Erlang term to a Pid on a local or remote node

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Send(
    ErlPid dest,
    IErlObject msg
)
public void Send(
    ErlPid dest,
    IErlObject msg
)
Public Sub Send (
    dest As ErlPid,
    msg As IErlObject
)
Public Sub Send (
    dest As ErlPid,
    msg As IErlObject
)
public:
void Send(
    ErlPid dest,
    IErlObject^ msg
)
public:
void Send(
    ErlPid dest,
    IErlObject^ msg
)
member Send :
        dest : ErlPid *
        msg : IErlObject -> unit
member Send :
        dest : ErlPid *
        msg : IErlObject -> unit

Parameters

dest
Type: NFX.Erlang ErlPid
msg
Type: NFX.Erlang IErlObject
See Also
ErlConnection Class
ErlConnection Members
Send Overload
NFX.Erlang Namespace


ErlConnection.Send Method (ErlPid, ErlAtom, IErlObject)

ErlConnection Send Method (ErlPid, ErlAtom, IErlObject) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Send(
    ErlPid from,
    ErlAtom dest,
    IErlObject msg
)
public void Send(
    ErlPid from,
    ErlAtom dest,
    IErlObject msg
)
Public Sub Send (
    from As ErlPid,
    dest As ErlAtom,
    msg As IErlObject
)
Public Sub Send (
    from As ErlPid,
    dest As ErlAtom,
    msg As IErlObject
)
public:
void Send(
    ErlPid from,
    ErlAtom dest,
    IErlObject^ msg
)
public:
void Send(
    ErlPid from,
    ErlAtom dest,
    IErlObject^ msg
)
member Send :
        from : ErlPid *
        dest : ErlAtom *
        msg : IErlObject -> unit
member Send :
        from : ErlPid *
        dest : ErlAtom *
        msg : IErlObject -> unit

Parameters

from
Type: NFX.Erlang ErlPid
dest
Type: NFX.Erlang ErlAtom
msg
Type: NFX.Erlang IErlObject
See Also
ErlConnection Class
ErlConnection Members
Send Overload
NFX.Erlang Namespace


ErlConnection Properties

ErlConnection Properties NFX Class Library

The ErlConnection type exposes the following members.
Properties
 | Name | Description
Public property | Connected | Determine if the connection is still alive. Note that this method only reports the status of the connection, and that it is possible that there are unread messages waiting in the receive queue (Inherited from ErlAbstractConnection.)
Public property | Cookie | (Inherited from ErlAbstractConnection.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | LocalNode | (Inherited from ErlAbstractConnection.)
Public property | MaxPayloadLength | Max size of the message accepted from the peer. The connection will be closed if a message is received of size greater than this. (Inherited from ErlAbstractConnection.)
Public property | Name | (Inherited from ErlAbstractConnection.)
Public property | ReceivedBytes | Total number of bytes received from connection (Inherited from ErlAbstractConnection.)
Public property | ReceivedMsgs | Total number of messages received from connection (Inherited from ErlAbstractConnection.)
Public property | RemoteNode | (Inherited from ErlAbstractConnection.)
Protected property | SendCookie | Cookie to send along with each distribution message (Inherited from ErlAbstractConnection.)
Public property | SentBytes | Total number of bytes sent through connection (Inherited from ErlAbstractConnection.)
Public property | SentMsgs | Total number of messages sent through connection (Inherited from ErlAbstractConnection.)
Public property | TraceLevel | Set the trace level for this connection. Normally tracing is off by default (Inherited from ErlAbstractConnection.)
Back to Top
See Also
ErlConnection Class
NFX.Erlang Namespace


ErlConnectionException Class

ErlConnectionException Class NFX Class Library

Exception thrown when the connection with a given node gets broken
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Erlang ErlException
NFX.Erlang ErlConnectionException
NFX.Erlang ErlAuthException
NFX.Erlang ErlBadDataException
NFX.Erlang ErlExit

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ErlConnectionException : ErlException
public class ErlConnectionException : ErlException
Public Class ErlConnectionException
    Inherits ErlException
Public Class ErlConnectionException
    Inherits ErlException
public ref class ErlConnectionException : public ErlException
public ref class ErlConnectionException : public ErlException
type ErlConnectionException =
    class
        inherit ErlException
    end
type ErlConnectionException =
    class
        inherit ErlException
    end
See Also
ErlConnectionException Members
NFX.Erlang Namespace


ErlConnectionException Members

ErlConnectionException Members NFX Class Library

The ErlConnectionException type exposes the following members.
Constructors
 | Name | Description
Public method | ErlConnectionException(ErlAtom, IErlObject) | Initializes a new instance of the ErlConnectionException class
Public method | ErlConnectionException(ErlAtom, String) | Initializes a new instance of the ErlConnectionException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | Node | Name of the node that experienced connectivity loss
Public field | Reason | Get the reason associated with this exit signal
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Message | (Overrides Online Exception Message.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ErlConnectionException Class
NFX.Erlang Namespace


ErlConnectionException Constructor

ErlConnectionException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ErlConnectionException(ErlAtom, IErlObject) | Initializes a new instance of the ErlConnectionException class
Public method | ErlConnectionException(ErlAtom, String) | Initializes a new instance of the ErlConnectionException class
Back to Top
See Also
ErlConnectionException Class
ErlConnectionException Members
NFX.Erlang Namespace


ErlConnectionException Constructor (ErlAtom, IErlObject)

ErlConnectionException Constructor (ErlAtom, IErlObject) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlConnectionException class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlConnectionException(
    ErlAtom nodeName,
    IErlObject reason
)
public ErlConnectionException(
    ErlAtom nodeName,
    IErlObject reason
)
Public Sub New (
    nodeName As ErlAtom,
    reason As IErlObject
)
Public Sub New (
    nodeName As ErlAtom,
    reason As IErlObject
)
public:
ErlConnectionException(
    ErlAtom nodeName,
    IErlObject^ reason
)
public:
ErlConnectionException(
    ErlAtom nodeName,
    IErlObject^ reason
)
new :
        nodeName : ErlAtom *
        reason : IErlObject -> ErlConnectionException
new :
        nodeName : ErlAtom *
        reason : IErlObject -> ErlConnectionException

Parameters

nodeName
Type: NFX.Erlang ErlAtom
reason
Type: NFX.Erlang IErlObject
See Also
ErlConnectionException Class
ErlConnectionException Members
ErlConnectionException Overload
NFX.Erlang Namespace


ErlConnectionException Constructor (ErlAtom, String)

ErlConnectionException Constructor (ErlAtom, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlConnectionException class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlConnectionException(
    ErlAtom nodeName,
    string reason
)
public ErlConnectionException(
    ErlAtom nodeName,
    string reason
)
Public Sub New (
    nodeName As ErlAtom,
    reason As String
)
Public Sub New (
    nodeName As ErlAtom,
    reason As String
)
public:
ErlConnectionException(
    ErlAtom nodeName,
    String^ reason
)
public:
ErlConnectionException(
    ErlAtom nodeName,
    String^ reason
)
new :
        nodeName : ErlAtom *
        reason : string -> ErlConnectionException
new :
        nodeName : ErlAtom *
        reason : string -> ErlConnectionException

Parameters

nodeName
Type: NFX.Erlang ErlAtom
reason
Type: Online System String
See Also
ErlConnectionException Class
ErlConnectionException Members
ErlConnectionException Overload
NFX.Erlang Namespace


ErlConnectionException Fields

ErlConnectionException Fields NFX Class Library

The ErlConnectionException type exposes the following members.
Fields
 | Name | Description
Public field | Node | Name of the node that experienced connectivity loss
Public field | Reason | Get the reason associated with this exit signal
Back to Top
See Also
ErlConnectionException Class
NFX.Erlang Namespace


ErlConnectionException.Node Field

ErlConnectionException Node Field NFX Class Library

Name of the node that experienced connectivity loss

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ErlAtom Node
public readonly ErlAtom Node
Public ReadOnly Node As ErlAtom
Public ReadOnly Node As ErlAtom
public:
initonly ErlAtom Node
public:
initonly ErlAtom Node
val Node: ErlAtom
val Node: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlConnectionException Class
ErlConnectionException Members
NFX.Erlang Namespace


ErlConnectionException.Reason Field

ErlConnectionException Reason Field NFX Class Library

Get the reason associated with this exit signal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly IErlObject Reason
public readonly IErlObject Reason
Public ReadOnly Reason As IErlObject
Public ReadOnly Reason As IErlObject
public:
initonly IErlObject^ Reason
public:
initonly IErlObject^ Reason
val Reason: IErlObject
val Reason: IErlObject

Field Value

Type: IErlObject
See Also
ErlConnectionException Class
ErlConnectionException Members
NFX.Erlang Namespace


ErlConnectionException Methods

ErlConnectionException Methods NFX Class Library

The ErlConnectionException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
ErlConnectionException Class
NFX.Erlang Namespace


ErlConnectionException Properties

ErlConnectionException Properties NFX Class Library

The ErlConnectionException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Message | (Overrides Online Exception Message.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
ErlConnectionException Class
NFX.Erlang Namespace


ErlConnectionException.Message Property

ErlConnectionException Message Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Message { get; }
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get
Public Overrides ReadOnly Property Message As String
    Get
public:
virtual property String^ Message {
    String^ get () override;
}
public:
virtual property String^ Message {
    String^ get () override;
}
abstract Message : string with get
override Message : string with get
abstract Message : string with get
override Message : string with get

Property Value

Type: Online String

Implements

Online _Exception Message
See Also
ErlConnectionException Class
ErlConnectionException Members
NFX.Erlang Namespace


ErlConnectionException Events

ErlConnectionException Events NFX Class Library

The ErlConnectionException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ErlConnectionException Class
NFX.Erlang Namespace


ErlConsts Class

ErlConsts Class NFX Class Library

Provides non-localizable Erlang constants
Inheritance Hierarchy
Online System Object
NFX.Erlang ErlConsts

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class ErlConsts
public static class ErlConsts
Public NotInheritable Class ErlConsts
Public NotInheritable Class ErlConsts
public ref class ErlConsts abstract sealed
public ref class ErlConsts abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ErlConsts =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ErlConsts =  class end
See Also
ErlConsts Members
NFX.Erlang Namespace


ErlConsts Members

ErlConsts Members NFX Class Library

The ErlConsts type exposes the following members.
Fields
Name | Description
ANY |
CONFIG_IS_LOCAL_ATTR |
ERL_INT_MAX | The largest value that can be encoded as an integer
ERL_INT_MIN | The smallest value that can be encoded as an integer
ERLANG_ACCEPT_ATTR |
ERLANG_ADDRESS_ATTR |
ERLANG_CONFIG_SECTION |
ERLANG_CONFIG_TRANSPORT_SECTION |
ERLANG_CONN_TIMEOUT_ATTR |
ERLANG_CONNECT_ON_STARUP |
ERLANG_COOKIE_ATTR |
ERLANG_CREATION_FILE_ATTR |
ERLANG_NODE_SECTION |
ERLANG_SHORT_NAME_ATTR |
FALSE |
TRUE |
UNDEFINED |
Back to Top
See Also
ErlConsts Class
NFX.Erlang Namespace


ErlConsts Fields

ErlConsts Fields NFX Class Library

The ErlConsts type exposes the following members.
Fields
Name | Description
ANY |
CONFIG_IS_LOCAL_ATTR |
ERL_INT_MAX | The largest value that can be encoded as an integer
ERL_INT_MIN | The smallest value that can be encoded as an integer
ERLANG_ACCEPT_ATTR |
ERLANG_ADDRESS_ATTR |
ERLANG_CONFIG_SECTION |
ERLANG_CONFIG_TRANSPORT_SECTION |
ERLANG_CONN_TIMEOUT_ATTR |
ERLANG_CONNECT_ON_STARUP |
ERLANG_COOKIE_ATTR |
ERLANG_CREATION_FILE_ATTR |
ERLANG_NODE_SECTION |
ERLANG_SHORT_NAME_ATTR |
FALSE |
TRUE |
UNDEFINED |
Back to Top
See Also
ErlConsts Class
NFX.Erlang Namespace


ErlConsts.ANY Field

ErlConsts ANY Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ANY
public const string ANY
Public Const ANY As String
Public Const ANY As String
public:
literal String^ ANY
public:
literal String^ ANY
static val mutable ANY: string
static val mutable ANY: string

Field Value

Type: Online String
See Also
ErlConsts Class
ErlConsts Members
NFX.Erlang Namespace


ErlConsts.CONFIG_IS_LOCAL_ATTR Field

ErlConsts CONFIG_IS_LOCAL_ATTR Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal const string CONFIG_IS_LOCAL_ATTR
internal const string CONFIG_IS_LOCAL_ATTR
Friend Const CONFIG_IS_LOCAL_ATTR As String
Friend Const CONFIG_IS_LOCAL_ATTR As String
internal:
literal String^ CONFIG_IS_LOCAL_ATTR
internal:
literal String^ CONFIG_IS_LOCAL_ATTR
static val mutable internal CONFIG_IS_LOCAL_ATTR: string
static val mutable internal CONFIG_IS_LOCAL_ATTR: string

Field Value

Type: Online String
See Also
ErlConsts Class
ErlConsts Members
NFX.Erlang Namespace


ErlConsts.ERL_INT_MAX Field

ErlConsts ERL_INT_MAX Field NFX Class Library

The largest value that can be encoded as an integer

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly int ERL_INT_MAX
public static readonly int ERL_INT_MAX
Public Shared ReadOnly ERL_INT_MAX As Integer
Public Shared ReadOnly ERL_INT_MAX As Integer
public:
static initonly int ERL_INT_MAX
public:
static initonly int ERL_INT_MAX
static val ERL_INT_MAX: int
static val ERL_INT_MAX: int

Field Value

Type: Online Int32
See Also
ErlConsts Class
ErlConsts Members
NFX.Erlang Namespace


ErlConsts.ERL_INT_MIN Field

ErlConsts ERL_INT_MIN Field NFX Class Library

The smallest value that can be encoded as an integer

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly int ERL_INT_MIN
public static readonly int ERL_INT_MIN
Public Shared ReadOnly ERL_INT_MIN As Integer
Public Shared ReadOnly ERL_INT_MIN As Integer
public:
static initonly int ERL_INT_MIN
public:
static initonly int ERL_INT_MIN
static val ERL_INT_MIN: int
static val ERL_INT_MIN: int

Field Value

Type: Online Int32
See Also
ErlConsts Class
ErlConsts Members
NFX.Erlang Namespace


ErlConsts.ERLANG_ACCEPT_ATTR Field

ErlConsts ERLANG_ACCEPT_ATTR Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal const string ERLANG_ACCEPT_ATTR
internal const string ERLANG_ACCEPT_ATTR
Friend Const ERLANG_ACCEPT_ATTR As String
Friend Const ERLANG_ACCEPT_ATTR As String
internal:
literal String^ ERLANG_ACCEPT_ATTR
internal:
literal String^ ERLANG_ACCEPT_ATTR
static val mutable internal ERLANG_ACCEPT_ATTR: string
static val mutable internal ERLANG_ACCEPT_ATTR: string

Field Value

Type: Online String
See Also
ErlConsts Class
ErlConsts Members
NFX.Erlang Namespace


ErlConsts.ERLANG_ADDRESS_ATTR Field

ErlConsts ERLANG_ADDRESS_ATTR Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal const string ERLANG_ADDRESS_ATTR
internal const string ERLANG_ADDRESS_ATTR
Friend Const ERLANG_ADDRESS_ATTR As String
Friend Const ERLANG_ADDRESS_ATTR As String
internal:
literal String^ ERLANG_ADDRESS_ATTR
internal:
literal String^ ERLANG_ADDRESS_ATTR
static val mutable internal ERLANG_ADDRESS_ATTR: string
static val mutable internal ERLANG_ADDRESS_ATTR: string

Field Value

Type: Online String
See Also
ErlConsts Class
ErlConsts Members
NFX.Erlang Namespace


ErlConsts.ERLANG_CONFIG_SECTION Field

ErlConsts ERLANG_CONFIG_SECTION Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal const string ERLANG_CONFIG_SECTION
internal const string ERLANG_CONFIG_SECTION
Friend Const ERLANG_CONFIG_SECTION As String
Friend Const ERLANG_CONFIG_SECTION As String
internal:
literal String^ ERLANG_CONFIG_SECTION
internal:
literal String^ ERLANG_CONFIG_SECTION
static val mutable internal ERLANG_CONFIG_SECTION: string
static val mutable internal ERLANG_CONFIG_SECTION: string

Field Value

Type: Online String
See Also
ErlConsts Class
ErlConsts Members
NFX.Erlang Namespace


ErlConsts.ERLANG_CONFIG_TRANSPORT_SECTION Field

ErlConsts ERLANG_CONFIG_TRANSPORT_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal const string ERLANG_CONFIG_TRANSPORT_SECTION
internal const string ERLANG_CONFIG_TRANSPORT_SECTION
Friend Const ERLANG_CONFIG_TRANSPORT_SECTION As String
Friend Const ERLANG_CONFIG_TRANSPORT_SECTION As String
internal:
literal String^ ERLANG_CONFIG_TRANSPORT_SECTION
internal:
literal String^ ERLANG_CONFIG_TRANSPORT_SECTION
static val mutable internal ERLANG_CONFIG_TRANSPORT_SECTION: string
static val mutable internal ERLANG_CONFIG_TRANSPORT_SECTION: string

Field Value

Type: Online String
See Also
ErlConsts Class
ErlConsts Members
NFX.Erlang Namespace


ErlConsts.ERLANG_CONN_TIMEOUT_ATTR Field

ErlConsts ERLANG_CONN_TIMEOUT_ATTR Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal const string ERLANG_CONN_TIMEOUT_ATTR
internal const string ERLANG_CONN_TIMEOUT_ATTR
Friend Const ERLANG_CONN_TIMEOUT_ATTR As String
Friend Const ERLANG_CONN_TIMEOUT_ATTR As String
internal:
literal String^ ERLANG_CONN_TIMEOUT_ATTR
internal:
literal String^ ERLANG_CONN_TIMEOUT_ATTR
static val mutable internal ERLANG_CONN_TIMEOUT_ATTR: string
static val mutable internal ERLANG_CONN_TIMEOUT_ATTR: string

Field Value

Type: Online String
See Also
ErlConsts Class
ErlConsts Members
NFX.Erlang Namespace


ErlConsts.ERLANG_CONNECT_ON_STARUP Field

ErlConsts ERLANG_CONNECT_ON_STARUP Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal const string ERLANG_CONNECT_ON_STARUP
internal const string ERLANG_CONNECT_ON_STARUP
Friend Const ERLANG_CONNECT_ON_STARUP As String
Friend Const ERLANG_CONNECT_ON_STARUP As String
internal:
literal String^ ERLANG_CONNECT_ON_STARUP
internal:
literal String^ ERLANG_CONNECT_ON_STARUP
static val mutable internal ERLANG_CONNECT_ON_STARUP: string
static val mutable internal ERLANG_CONNECT_ON_STARUP: string

Field Value

Type: Online String
See Also
ErlConsts Class
ErlConsts Members
NFX.Erlang Namespace


ErlConsts.ERLANG_COOKIE_ATTR Field

ErlConsts ERLANG_COOKIE_ATTR Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal const string ERLANG_COOKIE_ATTR
internal const string ERLANG_COOKIE_ATTR
Friend Const ERLANG_COOKIE_ATTR As String
Friend Const ERLANG_COOKIE_ATTR As String
internal:
literal String^ ERLANG_COOKIE_ATTR
internal:
literal String^ ERLANG_COOKIE_ATTR
static val mutable internal ERLANG_COOKIE_ATTR: string
static val mutable internal ERLANG_COOKIE_ATTR: string

Field Value

Type: Online String
See Also
ErlConsts Class
ErlConsts Members
NFX.Erlang Namespace


ErlConsts.ERLANG_CREATION_FILE_ATTR Field

ErlConsts ERLANG_CREATION_FILE_ATTR Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal const string ERLANG_CREATION_FILE_ATTR
internal const string ERLANG_CREATION_FILE_ATTR
Friend Const ERLANG_CREATION_FILE_ATTR As String
Friend Const ERLANG_CREATION_FILE_ATTR As String
internal:
literal String^ ERLANG_CREATION_FILE_ATTR
internal:
literal String^ ERLANG_CREATION_FILE_ATTR
static val mutable internal ERLANG_CREATION_FILE_ATTR: string
static val mutable internal ERLANG_CREATION_FILE_ATTR: string

Field Value

Type: Online String
See Also
ErlConsts Class
ErlConsts Members
NFX.Erlang Namespace


ErlConsts.ERLANG_NODE_SECTION Field

ErlConsts ERLANG_NODE_SECTION Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal const string ERLANG_NODE_SECTION
internal const string ERLANG_NODE_SECTION
Friend Const ERLANG_NODE_SECTION As String
Friend Const ERLANG_NODE_SECTION As String
internal:
literal String^ ERLANG_NODE_SECTION
internal:
literal String^ ERLANG_NODE_SECTION
static val mutable internal ERLANG_NODE_SECTION: string
static val mutable internal ERLANG_NODE_SECTION: string

Field Value

Type: Online String
See Also
ErlConsts Class
ErlConsts Members
NFX.Erlang Namespace


ErlConsts.ERLANG_SHORT_NAME_ATTR Field

ErlConsts ERLANG_SHORT_NAME_ATTR Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal const string ERLANG_SHORT_NAME_ATTR
internal const string ERLANG_SHORT_NAME_ATTR
Friend Const ERLANG_SHORT_NAME_ATTR As String
Friend Const ERLANG_SHORT_NAME_ATTR As String
internal:
literal String^ ERLANG_SHORT_NAME_ATTR
internal:
literal String^ ERLANG_SHORT_NAME_ATTR
static val mutable internal ERLANG_SHORT_NAME_ATTR: string
static val mutable internal ERLANG_SHORT_NAME_ATTR: string

Field Value

Type: Online String
See Also
ErlConsts Class
ErlConsts Members
NFX.Erlang Namespace


ErlConsts.FALSE Field

ErlConsts FALSE Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FALSE
public const string FALSE
Public Const FALSE As String
Public Const FALSE As String
public:
literal String^ FALSE
public:
literal String^ FALSE
static val mutable FALSE: string
static val mutable FALSE: string

Field Value

Type: Online String
See Also
ErlConsts Class
ErlConsts Members
NFX.Erlang Namespace


ErlConsts.TRUE Field

ErlConsts TRUE Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string TRUE
public const string TRUE
Public Const TRUE As String
Public Const TRUE As String
public:
literal String^ TRUE
public:
literal String^ TRUE
static val mutable TRUE: string
static val mutable TRUE: string

Field Value

Type: Online String
See Also
ErlConsts Class
ErlConsts Members
NFX.Erlang Namespace


ErlConsts.UNDEFINED Field

ErlConsts UNDEFINED Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNDEFINED
public const string UNDEFINED
Public Const UNDEFINED As String
Public Const UNDEFINED As String
public:
literal String^ UNDEFINED
public:
literal String^ UNDEFINED
static val mutable UNDEFINED: string
static val mutable UNDEFINED: string

Field Value

Type: Online String
See Also
ErlConsts Class
ErlConsts Members
NFX.Erlang Namespace


ErlDouble Structure

ErlDouble Structure NFX Class Library

Provides a C# representation of Erlang floats and doubles. Erlang defines only one floating point numeric type

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct ErlDouble : IErlObject<double>,
    IErlObject, IComparable, IComparable<IErlObject>, IEquatable<IErlObject>,
    ICloneable
public struct ErlDouble : IErlObject<double>,
    IErlObject, IComparable, IComparable<IErlObject>, IEquatable<IErlObject>,
    ICloneable
Public Structure ErlDouble
    Implements IErlObject(Of Double), IErlObject,
    IComparable, IComparable(Of IErlObject), IEquatable(Of IErlObject),
    ICloneable
Public Structure ErlDouble
    Implements IErlObject(Of Double), IErlObject,
    IComparable, IComparable(Of IErlObject), IEquatable(Of IErlObject),
    ICloneable
public value class ErlDouble : IErlObject<double>,
    IErlObject, IComparable, IComparable<IErlObject^>, IEquatable<IErlObject^>,
    ICloneable
public value class ErlDouble : IErlObject<double>,
    IErlObject, IComparable, IComparable<IErlObject^>, IEquatable<IErlObject^>,
    ICloneable
[<SealedAttribute>]
type ErlDouble =
    struct
        interface IErlObject<float>
        interface IErlObject
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
    end
[<SealedAttribute>]
type ErlDouble =
    struct
        interface IErlObject<float>
        interface IErlObject
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
    end
See Also
ErlDouble Members
NFX.Erlang Namespace


ErlDouble Members

ErlDouble Members NFX Class Library

The ErlDouble type exposes the following members.
Constructors
 | Name | Description
Public method | ErlDouble | Create an Erlang float from the given double value.
Back to Top
Methods
 | Name | Description
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj
Public method | Equals(Object) | Determine if this instance equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(IErlObject) | Determine if two instances are equal
Public method | Equals(ErlDouble, Double) | Determine if two instances are equal
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Get internal hash code (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Public method | Matches | Perform pattern match on this Erlang term without binding any variables
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Subst |
Public method | ToString | (Overrides Online ValueType ToString .)
Public method | Visit TAccumulate | Execute fun for every nested term
Back to Top
Operators
Name | Description
Equality(Double, ErlDouble) |
Equality(ErlDouble, ErlDouble) |
Equality(ErlDouble, Double) |
(Double to ErlDouble) |
(ErlDouble to Double) | Implicit conversion of ErlLong to double
Inequality(Double, ErlDouble) |
Inequality(ErlDouble, ErlDouble) |
Inequality(ErlDouble, Double) |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | IsScalar |
Public property | TypeOrder |
Public property | Value |
Public property | ValueAsBool |
Public property | ValueAsByteArray |
Public property | ValueAsChar |
Public property | ValueAsDateTime |
Public property | ValueAsDecimal |
Public property | ValueAsDouble |
Public property | ValueAsInt |
Public property | ValueAsLong |
Public property | ValueAsObject |
Public property | ValueAsString |
Public property | ValueAsTimeSpan |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone |
Back to Top
See Also
ErlDouble Structure
NFX.Erlang Namespace


ErlDouble Constructor

ErlDouble Constructor NFX Class Library

Create an Erlang float from the given double value.

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlDouble(
    double d
)
public ErlDouble(
    double d
)
Public Sub New (
    d As Double
)
Public Sub New (
    d As Double
)
public:
ErlDouble(
    double d
)
public:
ErlDouble(
    double d
)
new :
        d : float -> ErlDouble
new :
        d : float -> ErlDouble

Parameters

d
Type: Online System Double
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDouble Methods

ErlDouble Methods NFX Class Library

The ErlDouble type exposes the following members.
Methods
 | Name | Description
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj
Public method | Equals(Object) | Determine if this instance equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(IErlObject) | Determine if two instances are equal
Public method | Equals(ErlDouble, Double) | Determine if two instances are equal
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Get internal hash code (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Public method | Matches | Perform pattern match on this Erlang term without binding any variables
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Subst |
Public method | ToString | (Overrides Online ValueType ToString .)
Public method | Visit TAccumulate | Execute fun for every nested term
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone |
Back to Top
See Also
ErlDouble Structure
NFX.Erlang Namespace


ErlDouble.ICloneable.Clone Method

ErlDouble ICloneable Clone Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object ICloneable.Clone()
Object ICloneable.Clone()
Private Function Clone As Object Implements ICloneable.Clone
Private Function Clone As Object Implements ICloneable.Clone
private:
virtual Object^ Clone() sealed = ICloneable::Clone
private:
virtual Object^ Clone() sealed = ICloneable::Clone
private abstract Clone : unit -> Object
private override Clone : unit -> Object
private abstract Clone : unit -> Object
private override Clone : unit -> Object

Return Value

Type: Online Object

Implements

Online ICloneable Clone
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDouble.Clone Method

ErlDouble Clone Method NFX Class Library

Clone an instance of the object (non-scalar immutable objects are copied by reference)

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject Clone()
public IErlObject Clone()
Public Function Clone As IErlObject
Public Function Clone As IErlObject
public:
virtual IErlObject^ Clone() sealed
public:
virtual IErlObject^ Clone() sealed
abstract Clone : unit -> IErlObject
override Clone : unit -> IErlObject
abstract Clone : unit -> IErlObject
override Clone : unit -> IErlObject

Return Value

Type: IErlObject

Implements

IErlObject Clone
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDouble.CompareTo Method

ErlDouble CompareTo Method NFX Class Library

Overload List
 | Name | Description
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj
Back to Top
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDouble.CompareTo Method (Object)

ErlDouble CompareTo Method (Object) NFX Class Library

Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    Object obj
)
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
Public Function CompareTo (
    obj As Object
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
public:
virtual int CompareTo(
    Object^ obj
) sealed
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int

Parameters

obj
Type: Online System Object

Return Value

Type: Online Int32

Implements

Online IComparable CompareTo(Object)
See Also
ErlDouble Structure
ErlDouble Members
CompareTo Overload
NFX.Erlang Namespace


ErlDouble.CompareTo Method (IErlObject)

ErlDouble CompareTo Method (IErlObject) NFX Class Library

Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    IErlObject obj
)
public int CompareTo(
    IErlObject obj
)
Public Function CompareTo (
    obj As IErlObject
) As Integer
Public Function CompareTo (
    obj As IErlObject
) As Integer
public:
virtual int CompareTo(
    IErlObject^ obj
) sealed
public:
virtual int CompareTo(
    IErlObject^ obj
) sealed
abstract CompareTo :
        obj : IErlObject -> int
override CompareTo :
        obj : IErlObject -> int
abstract CompareTo :
        obj : IErlObject -> int
override CompareTo :
        obj : IErlObject -> int

Parameters

obj
Type: NFX.Erlang IErlObject

Return Value

Type: Online Int32

Implements

Online IComparable T CompareTo(T)
See Also
ErlDouble Structure
ErlDouble Members
CompareTo Overload
NFX.Erlang Namespace


ErlDouble.Equals Method

ErlDouble Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | Determine if this instance equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(IErlObject) | Determine if two instances are equal
Public method | Equals(ErlDouble, Double) | Determine if two instances are equal
Back to Top
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDouble.Equals Method (Object)

ErlDouble Equals Method (Object) NFX Class Library

Determine if this instance equals to the object

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals (
    o As Object
) As Boolean
Public Overrides Function Equals (
    o As Object
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool

Parameters

o
Type: Online System Object

Return Value

Type: Online Boolean
See Also
ErlDouble Structure
ErlDouble Members
Equals Overload
NFX.Erlang Namespace


ErlDouble.Equals Method (IErlObject)

ErlDouble Equals Method (IErlObject) NFX Class Library

Determine if two instances are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    IErlObject o
)
public bool Equals(
    IErlObject o
)
Public Function Equals (
    o As IErlObject
) As Boolean
Public Function Equals (
    o As IErlObject
) As Boolean
public:
virtual bool Equals(
    IErlObject^ o
) sealed
public:
virtual bool Equals(
    IErlObject^ o
) sealed
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool

Parameters

o
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
ErlDouble Structure
ErlDouble Members
Equals Overload
NFX.Erlang Namespace


ErlDouble.Equals Method (ErlDouble, Double)

ErlDouble Equals Method (ErlDouble, Double) NFX Class Library

[This is preliminary documentation and is subject to change.]

Determine if two instances are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    ErlDouble o,
    double precision = 0
)
public bool Equals(
    ErlDouble o,
    double precision = 0
)
Public Function Equals (
    o As ErlDouble,
    Optional precision As Double = 0
) As Boolean
Public Function Equals (
    o As ErlDouble,
    Optional precision As Double = 0
) As Boolean
public:
bool Equals(
    ErlDouble o,
    double precision = 0
)
public:
bool Equals(
    ErlDouble o,
    double precision = 0
)
member Equals :
        o : ErlDouble *
        ?precision : float
(* Defaults:
        let _precision = defaultArg precision 0
*)
-> bool
member Equals :
        o : ErlDouble *
        ?precision : float
(* Defaults:
        let _precision = defaultArg precision 0
*)
-> bool

Parameters

o
Type: NFX.Erlang ErlDouble
precision (Optional)
Type: Online System Double

Return Value

Type: Online Boolean
See Also
ErlDouble Structure
ErlDouble Members
Equals Overload
NFX.Erlang Namespace


ErlDouble.GetHashCode Method

ErlDouble GetHashCode Method NFX Class Library

Get internal hash code

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDouble.Match Method

ErlDouble Match Method NFX Class Library

Overload List
 | Name | Description
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Back to Top
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDouble.Match Method (IErlObject)

ErlDouble Match Method (IErlObject) NFX Class Library

Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlVarBind Match(
    IErlObject pattern
)
public ErlVarBind Match(
    IErlObject pattern
)
Public Function Match (
    pattern As IErlObject
) As ErlVarBind
Public Function Match (
    pattern As IErlObject
) As ErlVarBind
public:
virtual ErlVarBind^ Match(
    IErlObject^ pattern
) sealed
public:
virtual ErlVarBind^ Match(
    IErlObject^ pattern
) sealed
abstract Match :
        pattern : IErlObject -> ErlVarBind
override Match :
        pattern : IErlObject -> ErlVarBind
abstract Match :
        pattern : IErlObject -> ErlVarBind
override Match :
        pattern : IErlObject -> ErlVarBind

Parameters

pattern
Type: NFX.Erlang IErlObject

Return Value

Type: ErlVarBind

Implements

IErlObject Match(IErlObject)
See Also
ErlDouble Structure
ErlDouble Members
Match Overload
NFX.Erlang Namespace


ErlDouble.Match Method (IErlObject, ErlVarBind)

ErlDouble Match Method (IErlObject, ErlVarBind) NFX Class Library

[This is preliminary documentation and is subject to change.]

Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Match(
    IErlObject pattern,
    ErlVarBind binding
)
public bool Match(
    IErlObject pattern,
    ErlVarBind binding
)
Public Function Match (
    pattern As IErlObject,
    binding As ErlVarBind
) As Boolean
Public Function Match (
    pattern As IErlObject,
    binding As ErlVarBind
) As Boolean
public:
virtual bool Match(
    IErlObject^ pattern,
    ErlVarBind^ binding
) sealed
public:
virtual bool Match(
    IErlObject^ pattern,
    ErlVarBind^ binding
) sealed
abstract Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
override Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
abstract Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
override Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool

Parameters

pattern
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind

Return Value

Type: Online Boolean

Implements

IErlObject Match(IErlObject, ErlVarBind)
See Also
ErlDouble Structure
ErlDouble Members
Match Overload
NFX.Erlang Namespace


ErlDouble.Matches Method

ErlDouble Matches Method NFX Class Library

Perform pattern match on this Erlang term without binding any variables

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Matches(
    IErlObject pattern
)
public bool Matches(
    IErlObject pattern
)
Public Function Matches (
    pattern As IErlObject
) As Boolean
Public Function Matches (
    pattern As IErlObject
) As Boolean
public:
virtual bool Matches(
    IErlObject^ pattern
) sealed
public:
virtual bool Matches(
    IErlObject^ pattern
) sealed
abstract Matches :
        pattern : IErlObject -> bool
override Matches :
        pattern : IErlObject -> bool
abstract Matches :
        pattern : IErlObject -> bool
override Matches :
        pattern : IErlObject -> bool

Parameters

pattern
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Implements

IErlObject Matches(IErlObject)
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDouble.Subst Method

ErlDouble Subst Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Subst(
    ref IErlObject term,
    ErlVarBind binding
)
public bool Subst(
    ref IErlObject term,
    ErlVarBind binding
)
Public Function Subst (
    ByRef term As IErlObject,
    binding As ErlVarBind
) As Boolean
Public Function Subst (
    ByRef term As IErlObject,
    binding As ErlVarBind
) As Boolean
public:
virtual bool Subst(
    IErlObject^% term,
    ErlVarBind^ binding
) sealed
public:
virtual bool Subst(
    IErlObject^% term,
    ErlVarBind^ binding
) sealed
abstract Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
override Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
abstract Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
override Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool

Parameters

term
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind

Return Value

Type: Online Boolean

Implements

IErlObject Subst(IErlObject , ErlVarBind)
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDouble.ToString Method

ErlDouble ToString Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDouble.Visit(TAccumulate) Method

ErlDouble Visit TAccumulate Method NFX Class Library

Execute fun for every nested term

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TAccumulate Visit<TAccumulate>(
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
public TAccumulate Visit<TAccumulate>(
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
Public Function Visit(Of TAccumulate) (
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
Public Function Visit(Of TAccumulate) (
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
public:
generic<typename TAccumulate>
virtual TAccumulate Visit(
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
) sealed
public:
generic<typename TAccumulate>
virtual TAccumulate Visit(
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
) sealed
abstract Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
override Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
abstract Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
override Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate

Parameters

acc
Type: TAccumulate
fun
Type: Online System Func TAccumulate, IErlObject, TAccumulate
Type Parameters
TAccumulate

Return Value

Type: TAccumulate

Implements

IErlObject Visit TAccumulate (TAccumulate, Func TAccumulate, IErlObject, TAccumulate )
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDouble Operators and Type Conversions

ErlDouble Operators and Type Conversions NFX Class Library

Operators
Name | Description
Equality(Double, ErlDouble) |
Equality(ErlDouble, ErlDouble) |
Equality(ErlDouble, Double) |
(Double to ErlDouble) |
(ErlDouble to Double) | Implicit conversion of ErlLong to double
Inequality(Double, ErlDouble) |
Inequality(ErlDouble, ErlDouble) |
Inequality(ErlDouble, Double) |
Back to Top
See Also
ErlDouble Structure
NFX.Erlang Namespace


ErlDouble.Equality Operator

ErlDouble Equality Operator NFX Class Library

Overload List
Name | Description
Equality(Double, ErlDouble) |
Equality(ErlDouble, ErlDouble) |
Equality(ErlDouble, Double) |
Back to Top
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDouble.Equality Operator (Double, ErlDouble)

ErlDouble Equality Operator (Double, ErlDouble) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    double lhs,
    ErlDouble rhs
)
public static bool operator ==(
    double lhs,
    ErlDouble rhs
)
Public Shared Operator = (
    lhs As Double,
    rhs As ErlDouble
) As Boolean
Public Shared Operator = (
    lhs As Double,
    rhs As ErlDouble
) As Boolean
public:
static bool operator ==(
    double lhs,
    ErlDouble rhs
)
public:
static bool operator ==(
    double lhs,
    ErlDouble rhs
)
static let inline (=)
        lhs : float *
        rhs : ErlDouble  : bool
static let inline (=)
        lhs : float *
        rhs : ErlDouble  : bool

Parameters

lhs
Type: Online System Double
rhs
Type: NFX.Erlang ErlDouble

Return Value

Type: Online Boolean
See Also
ErlDouble Structure
ErlDouble Members
Equality Overload
NFX.Erlang Namespace


ErlDouble.Equality Operator (ErlDouble, ErlDouble)

ErlDouble Equality Operator (ErlDouble, ErlDouble) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    ErlDouble lhs,
    ErlDouble rhs
)
public static bool operator ==(
    ErlDouble lhs,
    ErlDouble rhs
)
Public Shared Operator = (
    lhs As ErlDouble,
    rhs As ErlDouble
) As Boolean
Public Shared Operator = (
    lhs As ErlDouble,
    rhs As ErlDouble
) As Boolean
public:
static bool operator ==(
    ErlDouble lhs,
    ErlDouble rhs
)
public:
static bool operator ==(
    ErlDouble lhs,
    ErlDouble rhs
)
static let inline (=)
        lhs : ErlDouble *
        rhs : ErlDouble  : bool
static let inline (=)
        lhs : ErlDouble *
        rhs : ErlDouble  : bool

Parameters

lhs
Type: NFX.Erlang ErlDouble
rhs
Type: NFX.Erlang ErlDouble

Return Value

Type: Online Boolean
See Also
ErlDouble Structure
ErlDouble Members
Equality Overload
NFX.Erlang Namespace


ErlDouble.Equality Operator (ErlDouble, Double)

ErlDouble Equality Operator (ErlDouble, Double) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    ErlDouble lhs,
    double rhs
)
public static bool operator ==(
    ErlDouble lhs,
    double rhs
)
Public Shared Operator = (
    lhs As ErlDouble,
    rhs As Double
) As Boolean
Public Shared Operator = (
    lhs As ErlDouble,
    rhs As Double
) As Boolean
public:
static bool operator ==(
    ErlDouble lhs,
    double rhs
)
public:
static bool operator ==(
    ErlDouble lhs,
    double rhs
)
static let inline (=)
        lhs : ErlDouble *
        rhs : float  : bool
static let inline (=)
        lhs : ErlDouble *
        rhs : float  : bool

Parameters

lhs
Type: NFX.Erlang ErlDouble
rhs
Type: Online System Double

Return Value

Type: Online Boolean
See Also
ErlDouble Structure
ErlDouble Members
Equality Overload
NFX.Erlang Namespace


ErlDouble Implicit Conversion Operators

ErlDouble Conversion Operators NFX Class Library

Overload List
Name | Description
(Double to ErlDouble) |
(ErlDouble to Double) | Implicit conversion of ErlLong to double
Back to Top
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDouble Implicit Conversion (Double to ErlDouble)

ErlDouble Conversion (Double to ErlDouble) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static implicit operator ErlDouble (
    double t
)
public static implicit operator ErlDouble (
    double t
)
Public Shared Widening Operator CType (
    t As Double
) As ErlDouble
Public Shared Widening Operator CType (
    t As Double
) As ErlDouble
static implicit operator ErlDouble (
    double t
)
static implicit operator ErlDouble (
    double t
)
F# does not support the declaration of new casting operators.
F# does not support the declaration of new casting operators.

Parameters

t
Type: Online System Double

Return Value

Type: ErlDouble
See Also
ErlDouble Structure
ErlDouble Members
Overload
NFX.Erlang Namespace


ErlDouble Implicit Conversion (ErlDouble to Double)

ErlDouble Conversion (ErlDouble to Double) NFX Class Library

Implicit conversion of ErlLong to double

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static implicit operator double (
    ErlDouble t
)
public static implicit operator double (
    ErlDouble t
)
Public Shared Widening Operator CType (
    t As ErlDouble
) As Double
Public Shared Widening Operator CType (
    t As ErlDouble
) As Double
static implicit operator double (
    ErlDouble t
)
static implicit operator double (
    ErlDouble t
)
F# does not support the declaration of new casting operators.
F# does not support the declaration of new casting operators.

Parameters

t
Type: NFX.Erlang ErlDouble

Return Value

Type: Online Double
See Also
ErlDouble Structure
ErlDouble Members
Overload
NFX.Erlang Namespace


ErlDouble.Inequality Operator

ErlDouble Inequality Operator NFX Class Library

Overload List
Name | Description
Inequality(Double, ErlDouble) |
Inequality(ErlDouble, ErlDouble) |
Inequality(ErlDouble, Double) |
Back to Top
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDouble.Inequality Operator (Double, ErlDouble)

ErlDouble Inequality Operator (Double, ErlDouble) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    double lhs,
    ErlDouble rhs
)
public static bool operator !=(
    double lhs,
    ErlDouble rhs
)
Public Shared Operator <> (
    lhs As Double,
    rhs As ErlDouble
) As Boolean
Public Shared Operator <> (
    lhs As Double,
    rhs As ErlDouble
) As Boolean
public:
static bool operator !=(
    double lhs,
    ErlDouble rhs
)
public:
static bool operator !=(
    double lhs,
    ErlDouble rhs
)
static let inline (<>)
        lhs : float *
        rhs : ErlDouble  : bool
static let inline (<>)
        lhs : float *
        rhs : ErlDouble  : bool

Parameters

lhs
Type: Online System Double
rhs
Type: NFX.Erlang ErlDouble

Return Value

Type: Online Boolean
See Also
ErlDouble Structure
ErlDouble Members
Inequality Overload
NFX.Erlang Namespace


ErlDouble.Inequality Operator (ErlDouble, ErlDouble)

ErlDouble Inequality Operator (ErlDouble, ErlDouble) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    ErlDouble lhs,
    ErlDouble rhs
)
public static bool operator !=(
    ErlDouble lhs,
    ErlDouble rhs
)
Public Shared Operator <> (
    lhs As ErlDouble,
    rhs As ErlDouble
) As Boolean
Public Shared Operator <> (
    lhs As ErlDouble,
    rhs As ErlDouble
) As Boolean
public:
static bool operator !=(
    ErlDouble lhs,
    ErlDouble rhs
)
public:
static bool operator !=(
    ErlDouble lhs,
    ErlDouble rhs
)
static let inline (<>)
        lhs : ErlDouble *
        rhs : ErlDouble  : bool
static let inline (<>)
        lhs : ErlDouble *
        rhs : ErlDouble  : bool

Parameters

lhs
Type: NFX.Erlang ErlDouble
rhs
Type: NFX.Erlang ErlDouble

Return Value

Type: Online Boolean
See Also
ErlDouble Structure
ErlDouble Members
Inequality Overload
NFX.Erlang Namespace


ErlDouble.Inequality Operator (ErlDouble, Double)

ErlDouble Inequality Operator (ErlDouble, Double) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    ErlDouble lhs,
    double rhs
)
public static bool operator !=(
    ErlDouble lhs,
    double rhs
)
Public Shared Operator <> (
    lhs As ErlDouble,
    rhs As Double
) As Boolean
Public Shared Operator <> (
    lhs As ErlDouble,
    rhs As Double
) As Boolean
public:
static bool operator !=(
    ErlDouble lhs,
    double rhs
)
public:
static bool operator !=(
    ErlDouble lhs,
    double rhs
)
static let inline (<>)
        lhs : ErlDouble *
        rhs : float  : bool
static let inline (<>)
        lhs : ErlDouble *
        rhs : float  : bool

Parameters

lhs
Type: NFX.Erlang ErlDouble
rhs
Type: Online System Double

Return Value

Type: Online Boolean
See Also
ErlDouble Structure
ErlDouble Members
Inequality Overload
NFX.Erlang Namespace


ErlDouble Properties

ErlDouble Properties NFX Class Library

The ErlDouble type exposes the following members.
Properties
 | Name | Description
Public property | IsScalar |
Public property | TypeOrder |
Public property | Value |
Public property | ValueAsBool |
Public property | ValueAsByteArray |
Public property | ValueAsChar |
Public property | ValueAsDateTime |
Public property | ValueAsDecimal |
Public property | ValueAsDouble |
Public property | ValueAsInt |
Public property | ValueAsLong |
Public property | ValueAsObject |
Public property | ValueAsString |
Public property | ValueAsTimeSpan |
Back to Top
See Also
ErlDouble Structure
NFX.Erlang Namespace


ErlDouble.IsScalar Property

ErlDouble IsScalar Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsScalar { get; }
public bool IsScalar { get; }
Public ReadOnly Property IsScalar As Boolean
    Get
Public ReadOnly Property IsScalar As Boolean
    Get
public:
virtual property bool IsScalar {
    bool get () sealed;
}
public:
virtual property bool IsScalar {
    bool get () sealed;
}
abstract IsScalar : bool with get
override IsScalar : bool with get
abstract IsScalar : bool with get
override IsScalar : bool with get

Property Value

Type: Online Boolean

Implements

IErlObject IsScalar
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDouble.TypeOrder Property

ErlDouble TypeOrder Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTypeOrder TypeOrder { get; }
public ErlTypeOrder TypeOrder { get; }
Public ReadOnly Property TypeOrder As ErlTypeOrder
    Get
Public ReadOnly Property TypeOrder As ErlTypeOrder
    Get
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () sealed;
}
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () sealed;
}
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get

Property Value

Type: ErlTypeOrder

Implements

IErlObject TypeOrder
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDouble.Value Property

ErlDouble Value Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double Value { get; }
public double Value { get; }
Public ReadOnly Property Value As Double
    Get
Public ReadOnly Property Value As Double
    Get
public:
virtual property double Value {
    double get () sealed;
}
public:
virtual property double Value {
    double get () sealed;
}
abstract Value : float with get
override Value : float with get
abstract Value : float with get
override Value : float with get

Property Value

Type: Online Double

Implements

IErlObject T Value
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDouble.ValueAsBool Property

ErlDouble ValueAsBool Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ValueAsBool { get; }
public bool ValueAsBool { get; }
Public ReadOnly Property ValueAsBool As Boolean
    Get
Public ReadOnly Property ValueAsBool As Boolean
    Get
public:
virtual property bool ValueAsBool {
    bool get () sealed;
}
public:
virtual property bool ValueAsBool {
    bool get () sealed;
}
abstract ValueAsBool : bool with get
override ValueAsBool : bool with get
abstract ValueAsBool : bool with get
override ValueAsBool : bool with get

Property Value

Type: Online Boolean

Implements

IErlObject ValueAsBool
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDouble.ValueAsByteArray Property

ErlDouble ValueAsByteArray Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] ValueAsByteArray { get; }
public byte[] ValueAsByteArray { get; }
Public ReadOnly Property ValueAsByteArray As Byte()
    Get
Public ReadOnly Property ValueAsByteArray As Byte()
    Get
public:
virtual property array<unsigned char>^ ValueAsByteArray {
    array<unsigned char>^ get () sealed;
}
public:
virtual property array<unsigned char>^ ValueAsByteArray {
    array<unsigned char>^ get () sealed;
}
abstract ValueAsByteArray : byte[] with get
override ValueAsByteArray : byte[] with get
abstract ValueAsByteArray : byte[] with get
override ValueAsByteArray : byte[] with get

Property Value

Type: Online Byte

Implements

IErlObject ValueAsByteArray
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDouble.ValueAsChar Property

ErlDouble ValueAsChar Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char ValueAsChar { get; }
public char ValueAsChar { get; }
Public ReadOnly Property ValueAsChar As Char
    Get
Public ReadOnly Property ValueAsChar As Char
    Get
public:
virtual property wchar_t ValueAsChar {
    wchar_t get () sealed;
}
public:
virtual property wchar_t ValueAsChar {
    wchar_t get () sealed;
}
abstract ValueAsChar : char with get
override ValueAsChar : char with get
abstract ValueAsChar : char with get
override ValueAsChar : char with get

Property Value

Type: Online Char

Implements

IErlObject ValueAsChar
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDouble.ValueAsDateTime Property

ErlDouble ValueAsDateTime Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime ValueAsDateTime { get; }
public DateTime ValueAsDateTime { get; }
Public ReadOnly Property ValueAsDateTime As DateTime
    Get
Public ReadOnly Property ValueAsDateTime As DateTime
    Get
public:
virtual property DateTime ValueAsDateTime {
    DateTime get () sealed;
}
public:
virtual property DateTime ValueAsDateTime {
    DateTime get () sealed;
}
abstract ValueAsDateTime : DateTime with get
override ValueAsDateTime : DateTime with get
abstract ValueAsDateTime : DateTime with get
override ValueAsDateTime : DateTime with get

Property Value

Type: Online DateTime

Implements

IErlObject ValueAsDateTime
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDouble.ValueAsDecimal Property

ErlDouble ValueAsDecimal Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal ValueAsDecimal { get; }
public decimal ValueAsDecimal { get; }
Public ReadOnly Property ValueAsDecimal As Decimal
    Get
Public ReadOnly Property ValueAsDecimal As Decimal
    Get
public:
virtual property Decimal ValueAsDecimal {
    Decimal get () sealed;
}
public:
virtual property Decimal ValueAsDecimal {
    Decimal get () sealed;
}
abstract ValueAsDecimal : decimal with get
override ValueAsDecimal : decimal with get
abstract ValueAsDecimal : decimal with get
override ValueAsDecimal : decimal with get

Property Value

Type: Online Decimal

Implements

IErlObject ValueAsDecimal
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDouble.ValueAsDouble Property

ErlDouble ValueAsDouble Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double ValueAsDouble { get; }
public double ValueAsDouble { get; }
Public ReadOnly Property ValueAsDouble As Double
    Get
Public ReadOnly Property ValueAsDouble As Double
    Get
public:
virtual property double ValueAsDouble {
    double get () sealed;
}
public:
virtual property double ValueAsDouble {
    double get () sealed;
}
abstract ValueAsDouble : float with get
override ValueAsDouble : float with get
abstract ValueAsDouble : float with get
override ValueAsDouble : float with get

Property Value

Type: Online Double

Implements

IErlObject ValueAsDouble
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDouble.ValueAsInt Property

ErlDouble ValueAsInt Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ValueAsInt { get; }
public int ValueAsInt { get; }
Public ReadOnly Property ValueAsInt As Integer
    Get
Public ReadOnly Property ValueAsInt As Integer
    Get
public:
virtual property int ValueAsInt {
    int get () sealed;
}
public:
virtual property int ValueAsInt {
    int get () sealed;
}
abstract ValueAsInt : int with get
override ValueAsInt : int with get
abstract ValueAsInt : int with get
override ValueAsInt : int with get

Property Value

Type: Online Int32

Implements

IErlObject ValueAsInt
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDouble.ValueAsLong Property

ErlDouble ValueAsLong Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long ValueAsLong { get; }
public long ValueAsLong { get; }
Public ReadOnly Property ValueAsLong As Long
    Get
Public ReadOnly Property ValueAsLong As Long
    Get
public:
virtual property long long ValueAsLong {
    long long get () sealed;
}
public:
virtual property long long ValueAsLong {
    long long get () sealed;
}
abstract ValueAsLong : int64 with get
override ValueAsLong : int64 with get
abstract ValueAsLong : int64 with get
override ValueAsLong : int64 with get

Property Value

Type: Online Int64

Implements

IErlObject ValueAsLong
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDouble.ValueAsObject Property

ErlDouble ValueAsObject Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object ValueAsObject { get; }
public Object ValueAsObject { get; }
Public ReadOnly Property ValueAsObject As Object
    Get
Public ReadOnly Property ValueAsObject As Object
    Get
public:
virtual property Object^ ValueAsObject {
    Object^ get () sealed;
}
public:
virtual property Object^ ValueAsObject {
    Object^ get () sealed;
}
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get

Property Value

Type: Online Object

Implements

IErlObject ValueAsObject
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDouble.ValueAsString Property

ErlDouble ValueAsString Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ValueAsString { get; }
public string ValueAsString { get; }
Public ReadOnly Property ValueAsString As String
    Get
Public ReadOnly Property ValueAsString As String
    Get
public:
virtual property String^ ValueAsString {
    String^ get () sealed;
}
public:
virtual property String^ ValueAsString {
    String^ get () sealed;
}
abstract ValueAsString : string with get
override ValueAsString : string with get
abstract ValueAsString : string with get
override ValueAsString : string with get

Property Value

Type: Online String

Implements

IErlObject ValueAsString
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDouble.ValueAsTimeSpan Property

ErlDouble ValueAsTimeSpan Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpan ValueAsTimeSpan { get; }
public TimeSpan ValueAsTimeSpan { get; }
Public ReadOnly Property ValueAsTimeSpan As TimeSpan
    Get
Public ReadOnly Property ValueAsTimeSpan As TimeSpan
    Get
public:
virtual property TimeSpan ValueAsTimeSpan {
    TimeSpan get () sealed;
}
public:
virtual property TimeSpan ValueAsTimeSpan {
    TimeSpan get () sealed;
}
abstract ValueAsTimeSpan : TimeSpan with get
override ValueAsTimeSpan : TimeSpan with get
abstract ValueAsTimeSpan : TimeSpan with get
override ValueAsTimeSpan : TimeSpan with get

Property Value

Type: Online TimeSpan

Implements

IErlObject ValueAsTimeSpan
See Also
ErlDouble Structure
ErlDouble Members
NFX.Erlang Namespace


ErlDown Class

ErlDown Class NFX Class Library

Message sent when the monitored Pid dies
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Erlang ErlException
NFX.Erlang ErlConnectionException
NFX.Erlang ErlExit
NFX.Erlang ErlDown

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class ErlDown : ErlExit
internal class ErlDown : ErlExit
Friend Class ErlDown
    Inherits ErlExit
Friend Class ErlDown
    Inherits ErlExit
internal ref class ErlDown : public ErlExit
internal ref class ErlDown : public ErlExit
type ErlDown =
    class
        inherit ErlExit
    end
type ErlDown =
    class
        inherit ErlExit
    end
See Also
ErlDown Members
NFX.Erlang Namespace


ErlDown Members

ErlDown Members NFX Class Library

The ErlDown type exposes the following members.
Constructors
 | Name | Description
Public method | ErlDown | Initializes a new instance of the ErlDown class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | Node | Name of the node that experienced connectivity loss (Inherited from ErlConnectionException.)
Public field | Pid | The pid that sent this exit (Inherited from ErlExit.)
Public field | Reason | Get the reason associated with this exit signal (Inherited from ErlConnectionException.)
Public field | Ref |
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Message | (Inherited from ErlConnectionException.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ErlDown Class
NFX.Erlang Namespace


ErlDown Constructor

ErlDown Constructor NFX Class Library

Initializes a new instance of the ErlDown class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlDown(
    ErlRef eref,
    ErlPid pid,
    IErlObject reason
)
public ErlDown(
    ErlRef eref,
    ErlPid pid,
    IErlObject reason
)
Public Sub New (
    eref As ErlRef,
    pid As ErlPid,
    reason As IErlObject
)
Public Sub New (
    eref As ErlRef,
    pid As ErlPid,
    reason As IErlObject
)
public:
ErlDown(
    ErlRef eref,
    ErlPid pid,
    IErlObject^ reason
)
public:
ErlDown(
    ErlRef eref,
    ErlPid pid,
    IErlObject^ reason
)
new :
        eref : ErlRef *
        pid : ErlPid *
        reason : IErlObject -> ErlDown
new :
        eref : ErlRef *
        pid : ErlPid *
        reason : IErlObject -> ErlDown

Parameters

eref
Type: NFX.Erlang ErlRef
pid
Type: NFX.Erlang ErlPid
reason
Type: NFX.Erlang IErlObject
See Also
ErlDown Class
ErlDown Members
NFX.Erlang Namespace


ErlDown Fields

ErlDown Fields NFX Class Library

The ErlDown type exposes the following members.
Fields
 | Name | Description
Public field | Node | Name of the node that experienced connectivity loss (Inherited from ErlConnectionException.)
Public field | Pid | The pid that sent this exit (Inherited from ErlExit.)
Public field | Reason | Get the reason associated with this exit signal (Inherited from ErlConnectionException.)
Public field | Ref |
Back to Top
See Also
ErlDown Class
NFX.Erlang Namespace


ErlDown.Ref Field

ErlDown Ref Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ErlRef Ref
public readonly ErlRef Ref
Public ReadOnly Ref As ErlRef
Public ReadOnly Ref As ErlRef
public:
initonly ErlRef Ref
public:
initonly ErlRef Ref
val Ref: ErlRef
val Ref: ErlRef

Field Value

Type: ErlRef
See Also
ErlDown Class
ErlDown Members
NFX.Erlang Namespace


ErlDown Methods

ErlDown Methods NFX Class Library

The ErlDown type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
ErlDown Class
NFX.Erlang Namespace


ErlDown Properties

ErlDown Properties NFX Class Library

The ErlDown type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Message | (Inherited from ErlConnectionException.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
ErlDown Class
NFX.Erlang Namespace


ErlDown Events

ErlDown Events NFX Class Library

The ErlDown type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ErlDown Class
NFX.Erlang Namespace


ErlEpmd Class

ErlEpmd Class NFX Class Library

Provides methods for registering, unregistering and looking up nodes with the Erlang portmapper daemon (Epmd). For each registered node, Epmd maintains information about the port on which incoming connections are accepted, as well as which versions of the Erlang communication protocolt the node supports
Inheritance Hierarchy
Online System Object
NFX.Erlang ErlEpmd

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static class ErlEpmd
internal static class ErlEpmd
Friend NotInheritable Class ErlEpmd
Friend NotInheritable Class ErlEpmd
internal ref class ErlEpmd abstract sealed
internal ref class ErlEpmd abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ErlEpmd =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ErlEpmd =  class end
Remarks
Nodes wishing to contact other nodes must first request information from Epmd before a connection can be set up, however this is done automatically by Connection(String, Nullable ErlAtom ) when necessary. The methods PublishPort(ErlLocalNode) and UnPublishPort(ErlLocalNode) will fail if an Epmd process is not running on the localhost. Additionally LookupPort(ErlLocalNode, ErlRemoteNode, Boolean) will fail if there is no Epmd process running on the host where the specified node is running. See the Erlang documentation for information about starting Epmd. This class contains only static methods, there are no constructors.
See Also
ErlEpmd Members
NFX.Erlang Namespace


ErlEpmd Members

ErlEpmd Members NFX Class Library

The ErlEpmd type exposes the following members.
Methods
Name | Description
LookupPort | Determine what port a node listens for incoming connections on
PublishPort | Publish node's port at local EPMD, so that other nodes can connect to it. On failure to connect to EPMD the function may throw if the value of ErlApp.IgnoreLocalEpmdConnectErrors variable is true. On failed connection attempt the function calls node.OnEpmdFailedConnectAttempt delegate
UnPublishPort | Unregister from Epmd. Other nodes wishing to connect will no longer be able to
Back to Top
Fields
Name | Description
EPMD_PORT |
Back to Top
See Also
ErlEpmd Class
NFX.Erlang Namespace


ErlEpmd Fields

ErlEpmd Fields NFX Class Library

The ErlEpmd type exposes the following members.
Fields
Name | Description
EPMD_PORT |
Back to Top
See Also
ErlEpmd Class
NFX.Erlang Namespace


ErlEpmd.EPMD_PORT Field

ErlEpmd EPMD_PORT Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int EPMD_PORT
public const int EPMD_PORT
Public Const EPMD_PORT As Integer
Public Const EPMD_PORT As Integer
public:
literal int EPMD_PORT
public:
literal int EPMD_PORT
static val mutable EPMD_PORT: int
static val mutable EPMD_PORT: int

Field Value

Type: Online Int32
See Also
ErlEpmd Class
ErlEpmd Members
NFX.Erlang Namespace


ErlEpmd Methods

ErlEpmd Methods NFX Class Library

The ErlEpmd type exposes the following members.
Methods
Name | Description
LookupPort | Determine what port a node listens for incoming connections on
PublishPort | Publish node's port at local EPMD, so that other nodes can connect to it. On failure to connect to EPMD the function may throw if the value of ErlApp.IgnoreLocalEpmdConnectErrors variable is true. On failed connection attempt the function calls node.OnEpmdFailedConnectAttempt delegate
UnPublishPort | Unregister from Epmd. Other nodes wishing to connect will no longer be able to
Back to Top
See Also
ErlEpmd Class
NFX.Erlang Namespace


ErlEpmd.LookupPort Method

ErlEpmd LookupPort Method NFX Class Library

Determine what port a node listens for incoming connections on

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int LookupPort(
    ErlLocalNode home,
    ErlRemoteNode node,
    bool closeSocket = false
)
public static int LookupPort(
    ErlLocalNode home,
    ErlRemoteNode node,
    bool closeSocket = false
)
Public Shared Function LookupPort (
    home As ErlLocalNode,
    node As ErlRemoteNode,
    Optional closeSocket As Boolean = false
) As Integer
Public Shared Function LookupPort (
    home As ErlLocalNode,
    node As ErlRemoteNode,
    Optional closeSocket As Boolean = false
) As Integer
public:
static int LookupPort(
    ErlLocalNode^ home,
    ErlRemoteNode^ node,
    bool closeSocket = false
)
public:
static int LookupPort(
    ErlLocalNode^ home,
    ErlRemoteNode^ node,
    bool closeSocket = false
)
static member LookupPort :
        home : ErlLocalNode *
        node : ErlRemoteNode *
        ?closeSocket : bool
(* Defaults:
        let _closeSocket = defaultArg closeSocket false
*)
-> int
static member LookupPort :
        home : ErlLocalNode *
        node : ErlRemoteNode *
        ?closeSocket : bool
(* Defaults:
        let _closeSocket = defaultArg closeSocket false
*)
-> int

Parameters

home
Type: NFX.Erlang ErlLocalNode
Local node
node
Type: NFX.Erlang ErlRemoteNode
Remote lode for which to look up the port number from remote EPMD
closeSocket (Optional)
Type: Online System Boolean
If true, close the connection to remote EPMD at return

Return Value

Type: Online Int32
the listen port for the specified node, or 0 if the node was not registered with Epmd
See Also
ErlEpmd Class
ErlEpmd Members
NFX.Erlang Namespace


ErlEpmd.PublishPort Method

ErlEpmd PublishPort Method NFX Class Library

Publish node's port at local EPMD, so that other nodes can connect to it. On failure to connect to EPMD the function may throw if the value of ErlApp.IgnoreLocalEpmdConnectErrors variable is true. On failed connection attempt the function calls node.OnEpmdFailedConnectAttempt delegate

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool PublishPort(
    ErlLocalNode node
)
public static bool PublishPort(
    ErlLocalNode node
)
Public Shared Function PublishPort (
    node As ErlLocalNode
) As Boolean
Public Shared Function PublishPort (
    node As ErlLocalNode
) As Boolean
public:
static bool PublishPort(
    ErlLocalNode^ node
)
public:
static bool PublishPort(
    ErlLocalNode^ node
)
static member PublishPort :
        node : ErlLocalNode -> bool
static member PublishPort :
        node : ErlLocalNode -> bool

Parameters

node
Type: NFX.Erlang ErlLocalNode

Return Value

Type: Online Boolean
Remarks
This function will get an exception if it tries to talk to an r3 epmd, or if something else happens that it cannot forsee. In both cases we return an exception (and the caller should try again, using the r3 protocol). If we manage to successfully communicate with an r4 epmd, we return either the socket, or null, depending on the result
See Also
ErlEpmd Class
ErlEpmd Members
NFX.Erlang Namespace


ErlEpmd.UnPublishPort Method

ErlEpmd UnPublishPort Method NFX Class Library

Unregister from Epmd. Other nodes wishing to connect will no longer be able to

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void UnPublishPort(
    ErlLocalNode node
)
public static void UnPublishPort(
    ErlLocalNode node
)
Public Shared Sub UnPublishPort (
    node As ErlLocalNode
)
Public Shared Sub UnPublishPort (
    node As ErlLocalNode
)
public:
static void UnPublishPort(
    ErlLocalNode^ node
)
public:
static void UnPublishPort(
    ErlLocalNode^ node
)
static member UnPublishPort :
        node : ErlLocalNode -> unit
static member UnPublishPort :
        node : ErlLocalNode -> unit

Parameters

node
Type: NFX.Erlang ErlLocalNode
See Also
ErlEpmd Class
ErlEpmd Members
NFX.Erlang Namespace


ErlException Class

ErlException Class NFX Class Library

Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Erlang ErlException
NFX.Erlang ErlConnectionException
NFX.Erlang ErlIncompatibleTypesException
NFX.Erlang NotEnoughDataException

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ErlException : NFXException,
    IQueable
public class ErlException : NFXException,
    IQueable
Public Class ErlException
    Inherits NFXException
    Implements IQueable
Public Class ErlException
    Inherits NFXException
    Implements IQueable
public ref class ErlException : public NFXException,
    IQueable
public ref class ErlException : public NFXException,
    IQueable
type ErlException =
    class
        inherit NFXException
        interface IQueable
    end
type ErlException =
    class
        inherit NFXException
        interface IQueable
    end
See Also
ErlException Members
NFX.Erlang Namespace


ErlException Members

ErlException Members NFX Class Library

The ErlException type exposes the following members.
Constructors
 | Name | Description
Public method | ErlException(String) | Initializes a new instance of the ErlException class
Public method | ErlException(SerializationInfo, StreamingContext) | Initializes a new instance of the ErlException class
Public method | ErlException(String, Exception) | Initializes a new instance of the ErlException class
Public method | ErlException(String, Object ) | Initializes a new instance of the ErlException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ErlException Class
NFX.Erlang Namespace


ErlException Constructor

ErlException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ErlException(String) | Initializes a new instance of the ErlException class
Public method | ErlException(SerializationInfo, StreamingContext) | Initializes a new instance of the ErlException class
Public method | ErlException(String, Exception) | Initializes a new instance of the ErlException class
Public method | ErlException(String, Object ) | Initializes a new instance of the ErlException class
Back to Top
See Also
ErlException Class
ErlException Members
NFX.Erlang Namespace


ErlException Constructor (String)

ErlException Constructor (String) NFX Class Library

Initializes a new instance of the ErlException class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlException(
    string message
)
public ErlException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
ErlException(
    String^ message
)
public:
ErlException(
    String^ message
)
new :
        message : string -> ErlException
new :
        message : string -> ErlException

Parameters

message
Type: Online System String
See Also
ErlException Class
ErlException Members
ErlException Overload
NFX.Erlang Namespace


ErlException Constructor (SerializationInfo, StreamingContext)

ErlException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlException class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlException(
    SerializationInfo info,
    StreamingContext context
)
public ErlException(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
ErlException(
    SerializationInfo^ info,
    StreamingContext context
)
public:
ErlException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ErlException
new :
        info : SerializationInfo *
        context : StreamingContext -> ErlException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
ErlException Class
ErlException Members
ErlException Overload
NFX.Erlang Namespace


ErlException Constructor (String, Exception)

ErlException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlException class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlException(
    string message,
    Exception inner
)
public ErlException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
ErlException(
    String^ message,
    Exception^ inner
)
public:
ErlException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> ErlException
new :
        message : string *
        inner : Exception -> ErlException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
ErlException Class
ErlException Members
ErlException Overload
NFX.Erlang Namespace


ErlException Constructor (String, Object[])

ErlException Constructor (String, Object ) NFX Class Library

Initializes a new instance of the ErlException class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlException(
    string message,
    params Object[] args
)
public ErlException(
    string message,
    params Object[] args
)
Public Sub New (
    message As String,
    ParamArray args As Object()
)
Public Sub New (
    message As String,
    ParamArray args As Object()
)
public:
ErlException(
    String^ message,
    ... array<Object^>^ args
)
public:
ErlException(
    String^ message,
    ... array<Object^>^ args
)
new :
        message : string *
        args : Object[] -> ErlException
new :
        message : string *
        args : Object[] -> ErlException

Parameters

message
Type: Online System String
args
Type: Online System Object
See Also
ErlException Class
ErlException Members
ErlException Overload
NFX.Erlang Namespace


ErlException Methods

ErlException Methods NFX Class Library

The ErlException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
ErlException Class
NFX.Erlang Namespace


ErlException Properties

ErlException Properties NFX Class Library

The ErlException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
ErlException Class
NFX.Erlang Namespace


ErlException Events

ErlException Events NFX Class Library

The ErlException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ErlException Class
NFX.Erlang Namespace


ErlExit Class

ErlExit Class NFX Class Library

Special message sent when a linked pid dies
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Erlang ErlException
NFX.Erlang ErlConnectionException
NFX.Erlang ErlExit
NFX.Erlang ErlDown

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class ErlExit : ErlConnectionException
internal class ErlExit : ErlConnectionException
Friend Class ErlExit
    Inherits ErlConnectionException
Friend Class ErlExit
    Inherits ErlConnectionException
internal ref class ErlExit : public ErlConnectionException
internal ref class ErlExit : public ErlConnectionException
type ErlExit =
    class
        inherit ErlConnectionException
    end
type ErlExit =
    class
        inherit ErlConnectionException
    end
See Also
ErlExit Members
NFX.Erlang Namespace


ErlExit Members

ErlExit Members NFX Class Library

The ErlExit type exposes the following members.
Constructors
 | Name | Description
Public method | ErlExit(ErlPid, IErlObject) | Initializes a new instance of the ErlExit class
Public method | ErlExit(ErlPid, String) | Initializes a new instance of the ErlExit class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | Node | Name of the node that experienced connectivity loss (Inherited from ErlConnectionException.)
Public field | Pid | The pid that sent this exit
Public field | Reason | Get the reason associated with this exit signal (Inherited from ErlConnectionException.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Message | (Inherited from ErlConnectionException.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ErlExit Class
NFX.Erlang Namespace


ErlExit Constructor

ErlExit Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ErlExit(ErlPid, IErlObject) | Initializes a new instance of the ErlExit class
Public method | ErlExit(ErlPid, String) | Initializes a new instance of the ErlExit class
Back to Top
See Also
ErlExit Class
ErlExit Members
NFX.Erlang Namespace


ErlExit Constructor (ErlPid, IErlObject)

ErlExit Constructor (ErlPid, IErlObject) NFX Class Library

Initializes a new instance of the ErlExit class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlExit(
    ErlPid pid,
    IErlObject reason
)
public ErlExit(
    ErlPid pid,
    IErlObject reason
)
Public Sub New (
    pid As ErlPid,
    reason As IErlObject
)
Public Sub New (
    pid As ErlPid,
    reason As IErlObject
)
public:
ErlExit(
    ErlPid pid,
    IErlObject^ reason
)
public:
ErlExit(
    ErlPid pid,
    IErlObject^ reason
)
new :
        pid : ErlPid *
        reason : IErlObject -> ErlExit
new :
        pid : ErlPid *
        reason : IErlObject -> ErlExit

Parameters

pid
Type: NFX.Erlang ErlPid
reason
Type: NFX.Erlang IErlObject
See Also
ErlExit Class
ErlExit Members
ErlExit Overload
NFX.Erlang Namespace


ErlExit Constructor (ErlPid, String)

ErlExit Constructor (ErlPid, String) NFX Class Library

Initializes a new instance of the ErlExit class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlExit(
    ErlPid pid,
    string reason
)
public ErlExit(
    ErlPid pid,
    string reason
)
Public Sub New (
    pid As ErlPid,
    reason As String
)
Public Sub New (
    pid As ErlPid,
    reason As String
)
public:
ErlExit(
    ErlPid pid,
    String^ reason
)
public:
ErlExit(
    ErlPid pid,
    String^ reason
)
new :
        pid : ErlPid *
        reason : string -> ErlExit
new :
        pid : ErlPid *
        reason : string -> ErlExit

Parameters

pid
Type: NFX.Erlang ErlPid
reason
Type: Online System String
See Also
ErlExit Class
ErlExit Members
ErlExit Overload
NFX.Erlang Namespace


ErlExit Fields

ErlExit Fields NFX Class Library

The ErlExit type exposes the following members.
Fields
 | Name | Description
Public field | Node | Name of the node that experienced connectivity loss (Inherited from ErlConnectionException.)
Public field | Pid | The pid that sent this exit
Public field | Reason | Get the reason associated with this exit signal (Inherited from ErlConnectionException.)
Back to Top
See Also
ErlExit Class
NFX.Erlang Namespace


ErlExit.Pid Field

ErlExit Pid Field NFX Class Library

The pid that sent this exit

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ErlPid Pid
public readonly ErlPid Pid
Public ReadOnly Pid As ErlPid
Public ReadOnly Pid As ErlPid
public:
initonly ErlPid Pid
public:
initonly ErlPid Pid
val Pid: ErlPid
val Pid: ErlPid

Field Value

Type: ErlPid
See Also
ErlExit Class
ErlExit Members
NFX.Erlang Namespace


ErlExit Methods

ErlExit Methods NFX Class Library

The ErlExit type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
ErlExit Class
NFX.Erlang Namespace


ErlExit Properties

ErlExit Properties NFX Class Library

The ErlExit type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Message | (Inherited from ErlConnectionException.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
ErlExit Class
NFX.Erlang Namespace


ErlExit Events

ErlExit Events NFX Class Library

The ErlExit type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ErlExit Class
NFX.Erlang Namespace


ErlExternalTag Enumeration

ErlExternalTag Enumeration NFX Class Library

Tags used for external format serialization

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal enum ErlExternalTag
internal enum ErlExternalTag
Friend Enumeration ErlExternalTag
Friend Enumeration ErlExternalTag
internal enum class ErlExternalTag
internal enum class ErlExternalTag
type internal ErlExternalTag
type internal ErlExternalTag
Members
Member name | Value | Description
SmallInt | 97 |
Int | 98 |
Float | 99 |
NewFloat | 70 |
Atom | 100 |
SmallAtom | 115 |
AtomUtf8 | 118 |
SmallAtomUtf8 | 119 |
Ref | 101 |
NewRef | 114 |
Port | 102 |
Pid | 103 |
SmallTuple | 104 |
LargeTuple | 105 |
Nil | 106 |
String | 107 |
List | 108 |
Bin | 109 |
SmallBigInt | 110 |
LargeBigInt | 111 |
Version | 131 |
Remarks
https://github.com/erlang/otp/blob/master/lib/erl_interface/include/ei.h
See Also
NFX.Erlang Namespace


ErlIncompatibleTypesException Class

ErlIncompatibleTypesException Class NFX Class Library

Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Erlang ErlException
NFX.Erlang ErlIncompatibleTypesException

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ErlIncompatibleTypesException : ErlException
public class ErlIncompatibleTypesException : ErlException
Public Class ErlIncompatibleTypesException
    Inherits ErlException
Public Class ErlIncompatibleTypesException
    Inherits ErlException
public ref class ErlIncompatibleTypesException : public ErlException
public ref class ErlIncompatibleTypesException : public ErlException
type ErlIncompatibleTypesException =
    class
        inherit ErlException
    end
type ErlIncompatibleTypesException =
    class
        inherit ErlException
    end
See Also
ErlIncompatibleTypesException Members
NFX.Erlang Namespace


ErlIncompatibleTypesException Members

ErlIncompatibleTypesException Members NFX Class Library

The ErlIncompatibleTypesException type exposes the following members.
Constructors
 | Name | Description
Public method | ErlIncompatibleTypesException(SerializationInfo, StreamingContext) | Initializes a new instance of the ErlIncompatibleTypesException class
Public method | ErlIncompatibleTypesException(IErlObject, Type) | Initializes a new instance of the ErlIncompatibleTypesException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ErlIncompatibleTypesException Class
NFX.Erlang Namespace


ErlIncompatibleTypesException Constructor

ErlIncompatibleTypesException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ErlIncompatibleTypesException(SerializationInfo, StreamingContext) | Initializes a new instance of the ErlIncompatibleTypesException class
Public method | ErlIncompatibleTypesException(IErlObject, Type) | Initializes a new instance of the ErlIncompatibleTypesException class
Back to Top
See Also
ErlIncompatibleTypesException Class
ErlIncompatibleTypesException Members
NFX.Erlang Namespace


ErlIncompatibleTypesException Constructor (SerializationInfo, StreamingContext)

ErlIncompatibleTypesException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlIncompatibleTypesException class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlIncompatibleTypesException(
    SerializationInfo info,
    StreamingContext context
)
public ErlIncompatibleTypesException(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
ErlIncompatibleTypesException(
    SerializationInfo^ info,
    StreamingContext context
)
public:
ErlIncompatibleTypesException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ErlIncompatibleTypesException
new :
        info : SerializationInfo *
        context : StreamingContext -> ErlIncompatibleTypesException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
ErlIncompatibleTypesException Class
ErlIncompatibleTypesException Members
ErlIncompatibleTypesException Overload
NFX.Erlang Namespace


ErlIncompatibleTypesException Constructor (IErlObject, Type)

ErlIncompatibleTypesException Constructor (IErlObject, Type) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlIncompatibleTypesException class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlIncompatibleTypesException(
    IErlObject lhs,
    Type rhs
)
public ErlIncompatibleTypesException(
    IErlObject lhs,
    Type rhs
)
Public Sub New (
    lhs As IErlObject,
    rhs As Type
)
Public Sub New (
    lhs As IErlObject,
    rhs As Type
)
public:
ErlIncompatibleTypesException(
    IErlObject^ lhs,
    Type^ rhs
)
public:
ErlIncompatibleTypesException(
    IErlObject^ lhs,
    Type^ rhs
)
new :
        lhs : IErlObject *
        rhs : Type -> ErlIncompatibleTypesException
new :
        lhs : IErlObject *
        rhs : Type -> ErlIncompatibleTypesException

Parameters

lhs
Type: NFX.Erlang IErlObject
rhs
Type: Online System Type
See Also
ErlIncompatibleTypesException Class
ErlIncompatibleTypesException Members
ErlIncompatibleTypesException Overload
NFX.Erlang Namespace


ErlIncompatibleTypesException Methods

ErlIncompatibleTypesException Methods NFX Class Library

The ErlIncompatibleTypesException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
ErlIncompatibleTypesException Class
NFX.Erlang Namespace


ErlIncompatibleTypesException Properties

ErlIncompatibleTypesException Properties NFX Class Library

The ErlIncompatibleTypesException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
ErlIncompatibleTypesException Class
NFX.Erlang Namespace


ErlIncompatibleTypesException Events

ErlIncompatibleTypesException Events NFX Class Library

The ErlIncompatibleTypesException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ErlIncompatibleTypesException Class
NFX.Erlang Namespace


ErlInputStream Class

ErlInputStream Class NFX Class Library

Provides a stream for decoding Erlang terms from external format
Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.IO Stream
NFX.Erlang ErlInputStream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ErlInputStream : Stream
public class ErlInputStream : Stream
Public Class ErlInputStream
    Inherits Stream
Public Class ErlInputStream
    Inherits Stream
public ref class ErlInputStream : public Stream
public ref class ErlInputStream : public Stream
type ErlInputStream =
    class
        inherit Stream
    end
type ErlInputStream =
    class
        inherit Stream
    end
See Also
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream Members

ErlInputStream Members NFX Class Library

The ErlInputStream type exposes the following members.
Constructors
 | Name | Description
Public method | ErlInputStream( Byte , Boolean, Encoding) | Initializes a new instance of the ErlInputStream class
Public method | ErlInputStream( Byte , Int32, Int32, Boolean, Encoding) | Initializes a new instance of the ErlInputStream class
Back to Top
Methods
 | Name | Description
Public method | Online BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Protected method | CheckVersion |
Public method | Online Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Online Stream.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Protected method | Online CreateWaitHandle | Obsolete. Allocates a Online WaitHandle object. (Inherited from Online Stream.)
Public method | Online Dispose | Releases all resources used by the Online Stream. (Inherited from Online Stream.)
Protected method | Online Dispose(Boolean) | Releases the unmanaged resources used by the Online Stream and optionally releases the managed resources. (Inherited from Online Stream.)
Public method | Online EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Overrides Online Stream Flush .)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Online Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Online Stream.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Online Stream.)
Protected method | Peek |
Public method | Read | Read arbitraty Erlang term from the stream
Public method | Read(Boolean) | Read arbitraty Erlang term from the stream, optionally checking protocol version byte
Public method | Read( Byte , Int32, Int32) | (Overrides Online Stream Read( Byte , Int32, Int32).)
Protected method | Read1 |
Protected method | Read2BE |
Protected method | Read4BE |
Public method | ReadAsync( Byte , Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Online Stream.)
Public method | ReadAsync( Byte , Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Online Stream.)
Public method | ReadAtom | Read an Erlang atom from the stream
Public method | ReadAtomOrBool |
Public method | ReadBinary | Read an Erlang binary from the stream
Public method | ReadBoolean | Read an Erlang atom from the stream and interpret the value as a boolean
Public method | ReadByte | Read an Erlang byte from the stream
Public method | ReadByteOrLong |
Protected method | ReadBytesAsString |
Public method | ReadDouble | Read an Erlang float from the stream
Public method | ReadList | Read Erlang list from the stream
Public method | ReadLong |
Protected method | ReadN |
Public method | ReadPid | Read Erlang pid from the stream
Public method | ReadPort | Read Erlang port from the stream
Public method | ReadRef | Read Erlang reference from the stream
Public method | ReadString | Read Erlang string or list from the stream
Public method | ReadTuple | Read Erlang tuple from the stream
Public method | Seek | (Overrides Online Stream Seek(Int64, SeekOrigin).)
Public method | SetLength | (Overrides Online Stream SetLength(Int64).)
Public method | ToBinaryString |
Public method | ToString | (Overrides Online Object ToString .)
Public method | Write | (Overrides Online Stream Write( Byte , Int32, Int32).)
Public method | WriteAsync( Byte , Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Online Stream.)
Public method | WriteAsync( Byte , Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Online Stream.)
Public method | Online WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Online Stream.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsCharEnumerable | (Defined by IOMiscUtils.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Public Extension Method | ReadBEInt32 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEShort | Reads a short encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUInt64 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUShort | Reads an ushort encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadSLEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadSLEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | WriteBEInt32 | Writes an integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEShort | Writes a short encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUInt64 | Writes an unsigned long integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUShort | Writes an ushort encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteSLEB128(Int64, Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteSLEB128(Int64, Int32 , Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, UInt32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, Int32 , UInt32) | Overloaded. (Defined by LEB128.)
Back to Top
Properties
 | Name | Description
Public property | CanRead | (Overrides Online Stream CanRead.)
Public property | CanSeek | (Overrides Online Stream CanSeek.)
Public property | Online CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Online Stream.)
Public property | CanWrite | (Overrides Online Stream CanWrite.)
Public property | Length | (Overrides Online Stream Length.)
Public property | Position | (Overrides Online Stream Position.)
Public property | Online ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Online Stream.)
Public property | Online WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Online Stream.)
Back to Top
See Also
ErlInputStream Class
NFX.Erlang Namespace


ErlInputStream Constructor

ErlInputStream Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ErlInputStream( Byte , Boolean, Encoding) | Initializes a new instance of the ErlInputStream class
Public method | ErlInputStream( Byte , Int32, Int32, Boolean, Encoding) | Initializes a new instance of the ErlInputStream class
Back to Top
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream Constructor (Byte[], Boolean, Encoding)

ErlInputStream Constructor ( Byte , Boolean, Encoding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlInputStream class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlInputStream(
    byte[] buf,
    bool checkVersion = true,
    Encoding encoding = null
)
public ErlInputStream(
    byte[] buf,
    bool checkVersion = true,
    Encoding encoding = null
)
Public Sub New (
    buf As Byte(),
    Optional checkVersion As Boolean = true,
    Optional encoding As Encoding = Nothing
)
Public Sub New (
    buf As Byte(),
    Optional checkVersion As Boolean = true,
    Optional encoding As Encoding = Nothing
)
public:
ErlInputStream(
    array<unsigned char>^ buf,
    bool checkVersion = true,
    Encoding^ encoding = nullptr
)
public:
ErlInputStream(
    array<unsigned char>^ buf,
    bool checkVersion = true,
    Encoding^ encoding = nullptr
)
new :
        buf : byte[] *
        ?checkVersion : bool *
        ?encoding : Encoding
(* Defaults:
        let _checkVersion = defaultArg checkVersion true
        let _encoding = defaultArg encoding null
*)
-> ErlInputStream
new :
        buf : byte[] *
        ?checkVersion : bool *
        ?encoding : Encoding
(* Defaults:
        let _checkVersion = defaultArg checkVersion true
        let _encoding = defaultArg encoding null
*)
-> ErlInputStream

Parameters

buf
Type: Online System Byte
checkVersion (Optional)
Type: Online System Boolean
encoding (Optional)
Type: Online System.Text Encoding
See Also
ErlInputStream Class
ErlInputStream Members
ErlInputStream Overload
NFX.Erlang Namespace


ErlInputStream Constructor (Byte[], Int32, Int32, Boolean, Encoding)

ErlInputStream Constructor ( Byte , Int32, Int32, Boolean, Encoding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlInputStream class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlInputStream(
    byte[] buf,
    int offset,
    int length,
    bool checkVersion = true,
    Encoding encoding = null
)
public ErlInputStream(
    byte[] buf,
    int offset,
    int length,
    bool checkVersion = true,
    Encoding encoding = null
)
Public Sub New (
    buf As Byte(),
    offset As Integer,
    length As Integer,
    Optional checkVersion As Boolean = true,
    Optional encoding As Encoding = Nothing
)
Public Sub New (
    buf As Byte(),
    offset As Integer,
    length As Integer,
    Optional checkVersion As Boolean = true,
    Optional encoding As Encoding = Nothing
)
public:
ErlInputStream(
    array<unsigned char>^ buf,
    int offset,
    int length,
    bool checkVersion = true,
    Encoding^ encoding = nullptr
)
public:
ErlInputStream(
    array<unsigned char>^ buf,
    int offset,
    int length,
    bool checkVersion = true,
    Encoding^ encoding = nullptr
)
new :
        buf : byte[] *
        offset : int *
        length : int *
        ?checkVersion : bool *
        ?encoding : Encoding
(* Defaults:
        let _checkVersion = defaultArg checkVersion true
        let _encoding = defaultArg encoding null
*)
-> ErlInputStream
new :
        buf : byte[] *
        offset : int *
        length : int *
        ?checkVersion : bool *
        ?encoding : Encoding
(* Defaults:
        let _checkVersion = defaultArg checkVersion true
        let _encoding = defaultArg encoding null
*)
-> ErlInputStream

Parameters

buf
Type: Online System Byte
offset
Type: Online System Int32
length
Type: Online System Int32
checkVersion (Optional)
Type: Online System Boolean
encoding (Optional)
Type: Online System.Text Encoding
See Also
ErlInputStream Class
ErlInputStream Members
ErlInputStream Overload
NFX.Erlang Namespace


ErlInputStream Methods

ErlInputStream Methods NFX Class Library

The ErlInputStream type exposes the following members.
Methods
 | Name | Description
Public method | Online BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Protected method | CheckVersion |
Public method | Online Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Online Stream.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Protected method | Online CreateWaitHandle | Obsolete. Allocates a Online WaitHandle object. (Inherited from Online Stream.)
Public method | Online Dispose | Releases all resources used by the Online Stream. (Inherited from Online Stream.)
Protected method | Online Dispose(Boolean) | Releases the unmanaged resources used by the Online Stream and optionally releases the managed resources. (Inherited from Online Stream.)
Public method | Online EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Overrides Online Stream Flush .)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Online Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Online Stream.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Online Stream.)
Protected method | Peek |
Public method | Read | Read arbitraty Erlang term from the stream
Public method | Read(Boolean) | Read arbitraty Erlang term from the stream, optionally checking protocol version byte
Public method | Read( Byte , Int32, Int32) | (Overrides Online Stream Read( Byte , Int32, Int32).)
Protected method | Read1 |
Protected method | Read2BE |
Protected method | Read4BE |
Public method | ReadAsync( Byte , Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Online Stream.)
Public method | ReadAsync( Byte , Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Online Stream.)
Public method | ReadAtom | Read an Erlang atom from the stream
Public method | ReadAtomOrBool |
Public method | ReadBinary | Read an Erlang binary from the stream
Public method | ReadBoolean | Read an Erlang atom from the stream and interpret the value as a boolean
Public method | ReadByte | Read an Erlang byte from the stream
Public method | ReadByteOrLong |
Protected method | ReadBytesAsString |
Public method | ReadDouble | Read an Erlang float from the stream
Public method | ReadList | Read Erlang list from the stream
Public method | ReadLong |
Protected method | ReadN |
Public method | ReadPid | Read Erlang pid from the stream
Public method | ReadPort | Read Erlang port from the stream
Public method | ReadRef | Read Erlang reference from the stream
Public method | ReadString | Read Erlang string or list from the stream
Public method | ReadTuple | Read Erlang tuple from the stream
Public method | Seek | (Overrides Online Stream Seek(Int64, SeekOrigin).)
Public method | SetLength | (Overrides Online Stream SetLength(Int64).)
Public method | ToBinaryString |
Public method | ToString | (Overrides Online Object ToString .)
Public method | Write | (Overrides Online Stream Write( Byte , Int32, Int32).)
Public method | WriteAsync( Byte , Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Online Stream.)
Public method | WriteAsync( Byte , Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Online Stream.)
Public method | Online WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Online Stream.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsCharEnumerable | (Defined by IOMiscUtils.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Public Extension Method | ReadBEInt32 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEShort | Reads a short encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUInt64 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUShort | Reads an ushort encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadSLEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadSLEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | WriteBEInt32 | Writes an integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEShort | Writes a short encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUInt64 | Writes an unsigned long integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUShort | Writes an ushort encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteSLEB128(Int64, Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteSLEB128(Int64, Int32 , Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, UInt32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, Int32 , UInt32) | Overloaded. (Defined by LEB128.)
Back to Top
See Also
ErlInputStream Class
NFX.Erlang Namespace


ErlInputStream.CheckVersion Method

ErlInputStream CheckVersion Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void CheckVersion()
internal void CheckVersion()
Friend Sub CheckVersion
Friend Sub CheckVersion
internal:
void CheckVersion()
internal:
void CheckVersion()
internal member CheckVersion : unit -> unit
internal member CheckVersion : unit -> unit
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.Flush Method

ErlInputStream Flush Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Flush()
public override void Flush()
Public Overrides Sub Flush
Public Overrides Sub Flush
public:
virtual void Flush() override
public:
virtual void Flush() override
abstract Flush : unit -> unit
override Flush : unit -> unit
abstract Flush : unit -> unit
override Flush : unit -> unit
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.Peek Method

ErlInputStream Peek Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Tuple<bool, byte> Peek()
internal Tuple<bool, byte> Peek()
Friend Function Peek As Tuple(Of Boolean, Byte)
Friend Function Peek As Tuple(Of Boolean, Byte)
internal:
Tuple<bool, unsigned char>^ Peek()
internal:
Tuple<bool, unsigned char>^ Peek()
internal member Peek : unit -> Tuple<bool, byte>
internal member Peek : unit -> Tuple<bool, byte>

Return Value

Type: Online Tuple Online Boolean, Online Byte
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.Read Method

ErlInputStream Read Method NFX Class Library

Overload List
 | Name | Description
Public method | Read | Read arbitraty Erlang term from the stream
Public method | Read(Boolean) | Read arbitraty Erlang term from the stream, optionally checking protocol version byte
Public method | Read( Byte , Int32, Int32) | (Overrides Online Stream Read( Byte , Int32, Int32).)
Back to Top
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.Read Method

ErlInputStream Read Method NFX Class Library

Read arbitraty Erlang term from the stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject Read()
public IErlObject Read()
Public Function Read As IErlObject
Public Function Read As IErlObject
public:
IErlObject^ Read()
public:
IErlObject^ Read()
member Read : unit -> IErlObject
member Read : unit -> IErlObject

Return Value

Type: IErlObject
See Also
ErlInputStream Class
ErlInputStream Members
Read Overload
NFX.Erlang Namespace


ErlInputStream.Read Method (Boolean)

ErlInputStream Read Method (Boolean) NFX Class Library

Read arbitraty Erlang term from the stream, optionally checking protocol version byte

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject Read(
    bool checkVersion
)
public IErlObject Read(
    bool checkVersion
)
Public Function Read (
    checkVersion As Boolean
) As IErlObject
Public Function Read (
    checkVersion As Boolean
) As IErlObject
public:
IErlObject^ Read(
    bool checkVersion
)
public:
IErlObject^ Read(
    bool checkVersion
)
member Read :
        checkVersion : bool -> IErlObject
member Read :
        checkVersion : bool -> IErlObject

Parameters

checkVersion
Type: Online System Boolean

Return Value

Type: IErlObject
See Also
ErlInputStream Class
ErlInputStream Members
Read Overload
NFX.Erlang Namespace


ErlInputStream.Read Method (Byte[], Int32, Int32)

ErlInputStream Read Method ( Byte , Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int

Parameters

buffer
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32

Return Value

Type: Online Int32
See Also
ErlInputStream Class
ErlInputStream Members
Read Overload
NFX.Erlang Namespace


ErlInputStream.Read1 Method

ErlInputStream Read1 Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal byte Read1()
internal byte Read1()
Friend Function Read1 As Byte
Friend Function Read1 As Byte
internal:
unsigned char Read1()
internal:
unsigned char Read1()
internal member Read1 : unit -> byte
internal member Read1 : unit -> byte

Return Value

Type: Online Byte
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.Read2BE Method

ErlInputStream Read2BE Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int Read2BE()
internal int Read2BE()
Friend Function Read2BE As Integer
Friend Function Read2BE As Integer
internal:
int Read2BE()
internal:
int Read2BE()
internal member Read2BE : unit -> int
internal member Read2BE : unit -> int

Return Value

Type: Online Int32
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.Read4BE Method

ErlInputStream Read4BE Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int Read4BE()
internal int Read4BE()
Friend Function Read4BE As Integer
Friend Function Read4BE As Integer
internal:
int Read4BE()
internal:
int Read4BE()
internal member Read4BE : unit -> int
internal member Read4BE : unit -> int

Return Value

Type: Online Int32
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.ReadAtom Method

ErlInputStream ReadAtom Method NFX Class Library

Read an Erlang atom from the stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlAtom ReadAtom()
public ErlAtom ReadAtom()
Public Function ReadAtom As ErlAtom
Public Function ReadAtom As ErlAtom
public:
ErlAtom ReadAtom()
public:
ErlAtom ReadAtom()
member ReadAtom : unit -> ErlAtom
member ReadAtom : unit -> ErlAtom

Return Value

Type: ErlAtom
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.ReadAtomOrBool Method

ErlInputStream ReadAtomOrBool Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject ReadAtomOrBool()
public IErlObject ReadAtomOrBool()
Public Function ReadAtomOrBool As IErlObject
Public Function ReadAtomOrBool As IErlObject
public:
IErlObject^ ReadAtomOrBool()
public:
IErlObject^ ReadAtomOrBool()
member ReadAtomOrBool : unit -> IErlObject
member ReadAtomOrBool : unit -> IErlObject

Return Value

Type: IErlObject
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.ReadBinary Method

ErlInputStream ReadBinary Method NFX Class Library

Read an Erlang binary from the stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlBinary ReadBinary()
public ErlBinary ReadBinary()
Public Function ReadBinary As ErlBinary
Public Function ReadBinary As ErlBinary
public:
ErlBinary ReadBinary()
public:
ErlBinary ReadBinary()
member ReadBinary : unit -> ErlBinary
member ReadBinary : unit -> ErlBinary

Return Value

Type: ErlBinary
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.ReadBoolean Method

ErlInputStream ReadBoolean Method NFX Class Library

Read an Erlang atom from the stream and interpret the value as a boolean

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlBoolean ReadBoolean()
public ErlBoolean ReadBoolean()
Public Function ReadBoolean As ErlBoolean
Public Function ReadBoolean As ErlBoolean
public:
ErlBoolean ReadBoolean()
public:
ErlBoolean ReadBoolean()
member ReadBoolean : unit -> ErlBoolean
member ReadBoolean : unit -> ErlBoolean

Return Value

Type: ErlBoolean
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.ReadByte Method

ErlInputStream ReadByte Method NFX Class Library

Read an Erlang byte from the stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlByte ReadByte()
public ErlByte ReadByte()
Public Function ReadByte As ErlByte
Public Function ReadByte As ErlByte
public:
ErlByte ReadByte()
public:
ErlByte ReadByte()
member ReadByte : unit -> ErlByte
member ReadByte : unit -> ErlByte

Return Value

Type: ErlByte
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.ReadByteOrLong Method

ErlInputStream ReadByteOrLong Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject ReadByteOrLong()
public IErlObject ReadByteOrLong()
Public Function ReadByteOrLong As IErlObject
Public Function ReadByteOrLong As IErlObject
public:
IErlObject^ ReadByteOrLong()
public:
IErlObject^ ReadByteOrLong()
member ReadByteOrLong : unit -> IErlObject
member ReadByteOrLong : unit -> IErlObject

Return Value

Type: IErlObject
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.ReadBytesAsString Method

ErlInputStream ReadBytesAsString Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal string ReadBytesAsString(
    int len = 0,
    Encoding encoding = null
)
internal string ReadBytesAsString(
    int len = 0,
    Encoding encoding = null
)
Friend Function ReadBytesAsString (
    Optional len As Integer = 0,
    Optional encoding As Encoding = Nothing
) As String
Friend Function ReadBytesAsString (
    Optional len As Integer = 0,
    Optional encoding As Encoding = Nothing
) As String
internal:
String^ ReadBytesAsString(
    int len = 0,
    Encoding^ encoding = nullptr
)
internal:
String^ ReadBytesAsString(
    int len = 0,
    Encoding^ encoding = nullptr
)
internal member ReadBytesAsString :
        ?len : int *
        ?encoding : Encoding
(* Defaults:
        let _len = defaultArg len 0
        let _encoding = defaultArg encoding null
*)
-> string
internal member ReadBytesAsString :
        ?len : int *
        ?encoding : Encoding
(* Defaults:
        let _len = defaultArg len 0
        let _encoding = defaultArg encoding null
*)
-> string

Parameters

len (Optional)
Type: Online System Int32
encoding (Optional)
Type: Online System.Text Encoding

Return Value

Type: Online String
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.ReadDouble Method

ErlInputStream ReadDouble Method NFX Class Library

Read an Erlang float from the stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlDouble ReadDouble()
public ErlDouble ReadDouble()
Public Function ReadDouble As ErlDouble
Public Function ReadDouble As ErlDouble
public:
ErlDouble ReadDouble()
public:
ErlDouble ReadDouble()
member ReadDouble : unit -> ErlDouble
member ReadDouble : unit -> ErlDouble

Return Value

Type: ErlDouble
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.ReadList Method

ErlInputStream ReadList Method NFX Class Library

Read Erlang list from the stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlList ReadList()
public ErlList ReadList()
Public Function ReadList As ErlList
Public Function ReadList As ErlList
public:
ErlList^ ReadList()
public:
ErlList^ ReadList()
member ReadList : unit -> ErlList
member ReadList : unit -> ErlList

Return Value

Type: ErlList
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.ReadLong Method

ErlInputStream ReadLong Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlLong ReadLong()
public ErlLong ReadLong()
Public Function ReadLong As ErlLong
Public Function ReadLong As ErlLong
public:
ErlLong ReadLong()
public:
ErlLong ReadLong()
member ReadLong : unit -> ErlLong
member ReadLong : unit -> ErlLong

Return Value

Type: ErlLong
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.ReadN Method

ErlInputStream ReadN Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void ReadN(
    byte[] buf
)
internal void ReadN(
    byte[] buf
)
Friend Sub ReadN (
    buf As Byte()
)
Friend Sub ReadN (
    buf As Byte()
)
internal:
void ReadN(
    array<unsigned char>^ buf
)
internal:
void ReadN(
    array<unsigned char>^ buf
)
internal member ReadN :
        buf : byte[] -> unit
internal member ReadN :
        buf : byte[] -> unit

Parameters

buf
Type: Online System Byte
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.ReadPid Method

ErlInputStream ReadPid Method NFX Class Library

Read Erlang pid from the stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlPid ReadPid()
public ErlPid ReadPid()
Public Function ReadPid As ErlPid
Public Function ReadPid As ErlPid
public:
ErlPid ReadPid()
public:
ErlPid ReadPid()
member ReadPid : unit -> ErlPid
member ReadPid : unit -> ErlPid

Return Value

Type: ErlPid
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.ReadPort Method

ErlInputStream ReadPort Method NFX Class Library

Read Erlang port from the stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlPort ReadPort()
public ErlPort ReadPort()
Public Function ReadPort As ErlPort
Public Function ReadPort As ErlPort
public:
ErlPort ReadPort()
public:
ErlPort ReadPort()
member ReadPort : unit -> ErlPort
member ReadPort : unit -> ErlPort

Return Value

Type: ErlPort
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.ReadRef Method

ErlInputStream ReadRef Method NFX Class Library

Read Erlang reference from the stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlRef ReadRef()
public ErlRef ReadRef()
Public Function ReadRef As ErlRef
Public Function ReadRef As ErlRef
public:
ErlRef ReadRef()
public:
ErlRef ReadRef()
member ReadRef : unit -> ErlRef
member ReadRef : unit -> ErlRef

Return Value

Type: ErlRef
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.ReadString Method

ErlInputStream ReadString Method NFX Class Library

Read Erlang string or list from the stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlString ReadString()
public ErlString ReadString()
Public Function ReadString As ErlString
Public Function ReadString As ErlString
public:
ErlString ReadString()
public:
ErlString ReadString()
member ReadString : unit -> ErlString
member ReadString : unit -> ErlString

Return Value

Type: ErlString
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.ReadTuple Method

ErlInputStream ReadTuple Method NFX Class Library

Read Erlang tuple from the stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTuple ReadTuple()
public ErlTuple ReadTuple()
Public Function ReadTuple As ErlTuple
Public Function ReadTuple As ErlTuple
public:
ErlTuple^ ReadTuple()
public:
ErlTuple^ ReadTuple()
member ReadTuple : unit -> ErlTuple
member ReadTuple : unit -> ErlTuple

Return Value

Type: ErlTuple
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.Seek Method

ErlInputStream Seek Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long Seek(
    long offset,
    SeekOrigin origin
)
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64

Parameters

offset
Type: Online System Int64
origin
Type: Online System.IO SeekOrigin

Return Value

Type: Online Int64
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.SetLength Method

ErlInputStream SetLength Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetLength(
    long value
)
public override void SetLength(
    long value
)
Public Overrides Sub SetLength (
    value As Long
)
Public Overrides Sub SetLength (
    value As Long
)
public:
virtual void SetLength(
    long long value
) override
public:
virtual void SetLength(
    long long value
) override
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit

Parameters

value
Type: Online System Int64
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.ToBinaryString Method

ErlInputStream ToBinaryString Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ToBinaryString(
    int offset = 0,
    int count = -1,
    int maxLen = 0
)
public string ToBinaryString(
    int offset = 0,
    int count = -1,
    int maxLen = 0
)
Public Function ToBinaryString (
    Optional offset As Integer = 0,
    Optional count As Integer = -1,
    Optional maxLen As Integer = 0
) As String
Public Function ToBinaryString (
    Optional offset As Integer = 0,
    Optional count As Integer = -1,
    Optional maxLen As Integer = 0
) As String
public:
String^ ToBinaryString(
    int offset = 0,
    int count = -1,
    int maxLen = 0
)
public:
String^ ToBinaryString(
    int offset = 0,
    int count = -1,
    int maxLen = 0
)
member ToBinaryString :
        ?offset : int *
        ?count : int *
        ?maxLen : int
(* Defaults:
        let _offset = defaultArg offset 0
        let _count = defaultArg count -1
        let _maxLen = defaultArg maxLen 0
*)
-> string
member ToBinaryString :
        ?offset : int *
        ?count : int *
        ?maxLen : int
(* Defaults:
        let _offset = defaultArg offset 0
        let _count = defaultArg count -1
        let _maxLen = defaultArg maxLen 0
*)
-> string

Parameters

offset (Optional)
Type: Online System Int32
count (Optional)
Type: Online System Int32
maxLen (Optional)
Type: Online System Int32

Return Value

Type: Online String
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.ToString Method

ErlInputStream ToString Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.Write Method

ErlInputStream Write Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit

Parameters

buffer
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream Properties

ErlInputStream Properties NFX Class Library

The ErlInputStream type exposes the following members.
Properties
 | Name | Description
Public property | CanRead | (Overrides Online Stream CanRead.)
Public property | CanSeek | (Overrides Online Stream CanSeek.)
Public property | Online CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Online Stream.)
Public property | CanWrite | (Overrides Online Stream CanWrite.)
Public property | Length | (Overrides Online Stream Length.)
Public property | Position | (Overrides Online Stream Position.)
Public property | Online ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Online Stream.)
Public property | Online WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Online Stream.)
Back to Top
See Also
ErlInputStream Class
NFX.Erlang Namespace


ErlInputStream.CanRead Property

ErlInputStream CanRead Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool CanRead { get; }
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
    Get
Public Overrides ReadOnly Property CanRead As Boolean
    Get
public:
virtual property bool CanRead {
    bool get () override;
}
public:
virtual property bool CanRead {
    bool get () override;
}
abstract CanRead : bool with get
override CanRead : bool with get
abstract CanRead : bool with get
override CanRead : bool with get

Property Value

Type: Online Boolean
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.CanSeek Property

ErlInputStream CanSeek Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool CanSeek { get; }
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
public:
virtual property bool CanSeek {
    bool get () override;
}
public:
virtual property bool CanSeek {
    bool get () override;
}
abstract CanSeek : bool with get
override CanSeek : bool with get
abstract CanSeek : bool with get
override CanSeek : bool with get

Property Value

Type: Online Boolean
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.CanWrite Property

ErlInputStream CanWrite Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool CanWrite { get; }
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
public:
virtual property bool CanWrite {
    bool get () override;
}
public:
virtual property bool CanWrite {
    bool get () override;
}
abstract CanWrite : bool with get
override CanWrite : bool with get
abstract CanWrite : bool with get
override CanWrite : bool with get

Property Value

Type: Online Boolean
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.Length Property

ErlInputStream Length Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long Length { get; }
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
    Get
Public Overrides ReadOnly Property Length As Long
    Get
public:
virtual property long long Length {
    long long get () override;
}
public:
virtual property long long Length {
    long long get () override;
}
abstract Length : int64 with get
override Length : int64 with get
abstract Length : int64 with get
override Length : int64 with get

Property Value

Type: Online Int64
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlInputStream.Position Property

ErlInputStream Position Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long Position { get; set; }
public override long Position { get; set; }
Public Overrides Property Position As Long
    Get
    Set
Public Overrides Property Position As Long
    Get
    Set
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
abstract Position : int64 with get, set
override Position : int64 with get, set
abstract Position : int64 with get, set
override Position : int64 with get, set

Property Value

Type: Online Int64
See Also
ErlInputStream Class
ErlInputStream Members
NFX.Erlang Namespace


ErlLink Structure

ErlLink Structure NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct ErlLink : IEquatable<ErlLink>,
    IComparable<ErlLink>
public struct ErlLink : IEquatable<ErlLink>,
    IComparable<ErlLink>
Public Structure ErlLink
    Implements IEquatable(Of ErlLink), IComparable(Of ErlLink)
Public Structure ErlLink
    Implements IEquatable(Of ErlLink), IComparable(Of ErlLink)
public value class ErlLink : IEquatable<ErlLink>,
    IComparable<ErlLink>
public value class ErlLink : IEquatable<ErlLink>,
    IComparable<ErlLink>
[<SealedAttribute>]
type ErlLink =
    struct
        interface IEquatable<ErlLink>
        interface IComparable<ErlLink>
    end
[<SealedAttribute>]
type ErlLink =
    struct
        interface IEquatable<ErlLink>
        interface IComparable<ErlLink>
    end
See Also
ErlLink Members
NFX.Erlang Namespace


ErlLink Members

ErlLink Members NFX Class Library

The ErlLink type exposes the following members.
Constructors
 | Name | Description
Public method | ErlLink(ErlAtom) | Initializes a new instance of the ErlLink class
Public method | ErlLink(ErlPid) | Initializes a new instance of the ErlLink class
Back to Top
Methods
 | Name | Description
Public method | CompareTo |
Public method | Contains |
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(ErlLink) |
Public method | Equals(ErlPid) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Node |
Public field | Pid |
Back to Top
Properties
 | Name | Description
Public property | HasPid | Returns true if this link points to a pid rather than to a node
Public property | IsNodeLink |
Back to Top
See Also
ErlLink Structure
NFX.Erlang Namespace


ErlLink Constructor

ErlLink Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ErlLink(ErlAtom) | Initializes a new instance of the ErlLink class
Public method | ErlLink(ErlPid) | Initializes a new instance of the ErlLink class
Back to Top
See Also
ErlLink Structure
ErlLink Members
NFX.Erlang Namespace


ErlLink Constructor (ErlAtom)

ErlLink Constructor (ErlAtom) NFX Class Library

Initializes a new instance of the ErlLink class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlLink(
    ErlAtom remoteNode
)
public ErlLink(
    ErlAtom remoteNode
)
Public Sub New (
    remoteNode As ErlAtom
)
Public Sub New (
    remoteNode As ErlAtom
)
public:
ErlLink(
    ErlAtom remoteNode
)
public:
ErlLink(
    ErlAtom remoteNode
)
new :
        remoteNode : ErlAtom -> ErlLink
new :
        remoteNode : ErlAtom -> ErlLink

Parameters

remoteNode
Type: NFX.Erlang ErlAtom
See Also
ErlLink Structure
ErlLink Members
ErlLink Overload
NFX.Erlang Namespace


ErlLink Constructor (ErlPid)

ErlLink Constructor (ErlPid) NFX Class Library

Initializes a new instance of the ErlLink class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlLink(
    ErlPid remote
)
public ErlLink(
    ErlPid remote
)
Public Sub New (
    remote As ErlPid
)
Public Sub New (
    remote As ErlPid
)
public:
ErlLink(
    ErlPid remote
)
public:
ErlLink(
    ErlPid remote
)
new :
        remote : ErlPid -> ErlLink
new :
        remote : ErlPid -> ErlLink

Parameters

remote
Type: NFX.Erlang ErlPid
See Also
ErlLink Structure
ErlLink Members
ErlLink Overload
NFX.Erlang Namespace


ErlLink Fields

ErlLink Fields NFX Class Library

The ErlLink type exposes the following members.
Fields
 | Name | Description
Public field | Node |
Public field | Pid |
Back to Top
See Also
ErlLink Structure
NFX.Erlang Namespace


ErlLink.Node Field

ErlLink Node Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ErlAtom Node
public readonly ErlAtom Node
Public ReadOnly Node As ErlAtom
Public ReadOnly Node As ErlAtom
public:
initonly ErlAtom Node
public:
initonly ErlAtom Node
val Node: ErlAtom
val Node: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlLink Structure
ErlLink Members
NFX.Erlang Namespace


ErlLink.Pid Field

ErlLink Pid Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ErlPid Pid
public readonly ErlPid Pid
Public ReadOnly Pid As ErlPid
Public ReadOnly Pid As ErlPid
public:
initonly ErlPid Pid
public:
initonly ErlPid Pid
val Pid: ErlPid
val Pid: ErlPid

Field Value

Type: ErlPid
See Also
ErlLink Structure
ErlLink Members
NFX.Erlang Namespace


ErlLink Methods

ErlLink Methods NFX Class Library

The ErlLink type exposes the following members.
Methods
 | Name | Description
Public method | CompareTo |
Public method | Contains |
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(ErlLink) |
Public method | Equals(ErlPid) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ErlLink Structure
NFX.Erlang Namespace


ErlLink.CompareTo Method

ErlLink CompareTo Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    ErlLink other
)
public int CompareTo(
    ErlLink other
)
Public Function CompareTo (
    other As ErlLink
) As Integer
Public Function CompareTo (
    other As ErlLink
) As Integer
public:
virtual int CompareTo(
    ErlLink other
) sealed
public:
virtual int CompareTo(
    ErlLink other
) sealed
abstract CompareTo :
        other : ErlLink -> int
override CompareTo :
        other : ErlLink -> int
abstract CompareTo :
        other : ErlLink -> int
override CompareTo :
        other : ErlLink -> int

Parameters

other
Type: NFX.Erlang ErlLink

Return Value

Type: Online Int32

Implements

Online IComparable T CompareTo(T)
See Also
ErlLink Structure
ErlLink Members
NFX.Erlang Namespace


ErlLink.Contains Method

ErlLink Contains Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Contains(
    ErlPid pid
)
public bool Contains(
    ErlPid pid
)
Public Function Contains (
    pid As ErlPid
) As Boolean
Public Function Contains (
    pid As ErlPid
) As Boolean
public:
bool Contains(
    ErlPid pid
)
public:
bool Contains(
    ErlPid pid
)
member Contains :
        pid : ErlPid -> bool
member Contains :
        pid : ErlPid -> bool

Parameters

pid
Type: NFX.Erlang ErlPid

Return Value

Type: Online Boolean
See Also
ErlLink Structure
ErlLink Members
NFX.Erlang Namespace


ErlLink.Equals Method

ErlLink Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(ErlLink) |
Public method | Equals(ErlPid) |
Back to Top
See Also
ErlLink Structure
ErlLink Members
NFX.Erlang Namespace


ErlLink.Equals Method (Object)

ErlLink Equals Method (Object) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
ErlLink Structure
ErlLink Members
Equals Overload
NFX.Erlang Namespace


ErlLink.Equals Method (ErlLink)

ErlLink Equals Method (ErlLink) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    ErlLink rhs
)
public bool Equals(
    ErlLink rhs
)
Public Function Equals (
    rhs As ErlLink
) As Boolean
Public Function Equals (
    rhs As ErlLink
) As Boolean
public:
virtual bool Equals(
    ErlLink rhs
) sealed
public:
virtual bool Equals(
    ErlLink rhs
) sealed
abstract Equals :
        rhs : ErlLink -> bool
override Equals :
        rhs : ErlLink -> bool
abstract Equals :
        rhs : ErlLink -> bool
override Equals :
        rhs : ErlLink -> bool

Parameters

rhs
Type: NFX.Erlang ErlLink

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
ErlLink Structure
ErlLink Members
Equals Overload
NFX.Erlang Namespace


ErlLink.Equals Method (ErlPid)

ErlLink Equals Method (ErlPid) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    ErlPid remote
)
public bool Equals(
    ErlPid remote
)
Public Function Equals (
    remote As ErlPid
) As Boolean
Public Function Equals (
    remote As ErlPid
) As Boolean
public:
bool Equals(
    ErlPid remote
)
public:
bool Equals(
    ErlPid remote
)
member Equals :
        remote : ErlPid -> bool
member Equals :
        remote : ErlPid -> bool

Parameters

remote
Type: NFX.Erlang ErlPid

Return Value

Type: Online Boolean
See Also
ErlLink Structure
ErlLink Members
Equals Overload
NFX.Erlang Namespace


ErlLink.GetHashCode Method

ErlLink GetHashCode Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
ErlLink Structure
ErlLink Members
NFX.Erlang Namespace


ErlLink.ToString Method

ErlLink ToString Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
ErlLink Structure
ErlLink Members
NFX.Erlang Namespace


ErlLink Properties

ErlLink Properties NFX Class Library

The ErlLink type exposes the following members.
Properties
 | Name | Description
Public property | HasPid | Returns true if this link points to a pid rather than to a node
Public property | IsNodeLink |
Back to Top
See Also
ErlLink Structure
NFX.Erlang Namespace


ErlLink.HasPid Property

ErlLink HasPid Property NFX Class Library

Returns true if this link points to a pid rather than to a node

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasPid { get; }
public bool HasPid { get; }
Public ReadOnly Property HasPid As Boolean
    Get
Public ReadOnly Property HasPid As Boolean
    Get
public:
property bool HasPid {
    bool get ();
}
public:
property bool HasPid {
    bool get ();
}
member HasPid : bool with get
member HasPid : bool with get

Property Value

Type: Online Boolean
See Also
ErlLink Structure
ErlLink Members
NFX.Erlang Namespace


ErlLink.IsNodeLink Property

ErlLink IsNodeLink Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsNodeLink { get; }
public bool IsNodeLink { get; }
Public ReadOnly Property IsNodeLink As Boolean
    Get
Public ReadOnly Property IsNodeLink As Boolean
    Get
public:
property bool IsNodeLink {
    bool get ();
}
public:
property bool IsNodeLink {
    bool get ();
}
member IsNodeLink : bool with get
member IsNodeLink : bool with get

Property Value

Type: Online Boolean
See Also
ErlLink Structure
ErlLink Members
NFX.Erlang Namespace


ErlLinks Class

ErlLinks Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Erlang ErlLinks

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ErlLinks : IEnumerable<ErlLink>,
    IEnumerable
public class ErlLinks : IEnumerable<ErlLink>,
    IEnumerable
Public Class ErlLinks
    Implements IEnumerable(Of ErlLink), IEnumerable
Public Class ErlLinks
    Implements IEnumerable(Of ErlLink), IEnumerable
public ref class ErlLinks : IEnumerable<ErlLink>,
    IEnumerable
public ref class ErlLinks : IEnumerable<ErlLink>,
    IEnumerable
type ErlLinks =
    class
        interface IEnumerable<ErlLink>
        interface IEnumerable
    end
type ErlLinks =
    class
        interface IEnumerable<ErlLink>
        interface IEnumerable
    end
See Also
ErlLinks Members
NFX.Erlang Namespace


ErlLinks Members

ErlLinks Members NFX Class Library

The ErlLinks type exposes the following members.
Constructors
 | Name | Description
Public method | ErlLinks | Initializes a new instance of the ErlLinks class
Back to Top
Methods
 | Name | Description
Public method | Add(ErlAtom) |
Public method | Add(ErlLink) |
Public method | Add(ErlPid) |
Public method | Clear |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Exists |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove(ErlAtom) |
Public method | Remove(ErlLink) |
Public method | Remove(ErlPid) |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable ErlLink | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct ErlLink, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax ErlLink, TComparand (Func ErlLink, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax ErlLink, TComparand (Func ErlLink, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin ErlLink, TComparand (Func ErlLink, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin ErlLink, TComparand (Func ErlLink, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault ErlLink | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach ErlLink (Action ErlLink ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach ErlLink (Action ErlLink, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast ErlLink | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast ErlLink (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Count |
Public property | Links |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable ErlLink GetEnumerator |
Back to Top
See Also
ErlLinks Class
NFX.Erlang Namespace


ErlLinks Constructor

ErlLinks Constructor NFX Class Library

Initializes a new instance of the ErlLinks class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlLinks()
public ErlLinks()
Public Sub New
Public Sub New
public:
ErlLinks()
public:
ErlLinks()
new : unit -> ErlLinks
new : unit -> ErlLinks
See Also
ErlLinks Class
ErlLinks Members
NFX.Erlang Namespace


ErlLinks Methods

ErlLinks Methods NFX Class Library

The ErlLinks type exposes the following members.
Methods
 | Name | Description
Public method | Add(ErlAtom) |
Public method | Add(ErlLink) |
Public method | Add(ErlPid) |
Public method | Clear |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Exists |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove(ErlAtom) |
Public method | Remove(ErlLink) |
Public method | Remove(ErlPid) |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable ErlLink | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct ErlLink, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax ErlLink, TComparand (Func ErlLink, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax ErlLink, TComparand (Func ErlLink, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin ErlLink, TComparand (Func ErlLink, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin ErlLink, TComparand (Func ErlLink, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault ErlLink | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach ErlLink (Action ErlLink ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach ErlLink (Action ErlLink, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast ErlLink | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast ErlLink (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable ErlLink GetEnumerator |
Back to Top
See Also
ErlLinks Class
NFX.Erlang Namespace


ErlLinks.IEnumerable(ErlLink).GetEnumerator Method

ErlLinks IEnumerable ErlLink GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator<ErlLink> IEnumerable<ErlLink>.GetEnumerator()
IEnumerator<ErlLink> IEnumerable<ErlLink>.GetEnumerator()
Private Function GetEnumerator As IEnumerator(Of ErlLink)
    Implements IEnumerable(Of ErlLink).GetEnumerator
Private Function GetEnumerator As IEnumerator(Of ErlLink)
    Implements IEnumerable(Of ErlLink).GetEnumerator
private:
virtual IEnumerator<ErlLink>^ GetEnumerator() sealed = IEnumerable<ErlLink>::GetEnumerator
private:
virtual IEnumerator<ErlLink>^ GetEnumerator() sealed = IEnumerable<ErlLink>::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator<ErlLink>
private override GetEnumerator : unit -> IEnumerator<ErlLink>
private abstract GetEnumerator : unit -> IEnumerator<ErlLink>
private override GetEnumerator : unit -> IEnumerator<ErlLink>

Return Value

Type: Online IEnumerator ErlLink

Implements

Online IEnumerable T GetEnumerator
See Also
ErlLinks Class
ErlLinks Members
NFX.Erlang Namespace


ErlLinks.Add Method

ErlLinks Add Method NFX Class Library

Overload List
 | Name | Description
Public method | Add(ErlAtom) |
Public method | Add(ErlLink) |
Public method | Add(ErlPid) |
Back to Top
See Also
ErlLinks Class
ErlLinks Members
NFX.Erlang Namespace


ErlLinks.Add Method (ErlAtom)

ErlLinks Add Method (ErlAtom) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Add(
    ErlAtom toNode
)
public bool Add(
    ErlAtom toNode
)
Public Function Add (
    toNode As ErlAtom
) As Boolean
Public Function Add (
    toNode As ErlAtom
) As Boolean
public:
bool Add(
    ErlAtom toNode
)
public:
bool Add(
    ErlAtom toNode
)
member Add :
        toNode : ErlAtom -> bool
member Add :
        toNode : ErlAtom -> bool

Parameters

toNode
Type: NFX.Erlang ErlAtom

Return Value

Type: Online Boolean
See Also
ErlLinks Class
ErlLinks Members
Add Overload
NFX.Erlang Namespace


ErlLinks.Add Method (ErlLink)

ErlLinks Add Method (ErlLink) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Add(
    ErlLink link
)
public bool Add(
    ErlLink link
)
Public Function Add (
    link As ErlLink
) As Boolean
Public Function Add (
    link As ErlLink
) As Boolean
public:
bool Add(
    ErlLink link
)
public:
bool Add(
    ErlLink link
)
member Add :
        link : ErlLink -> bool
member Add :
        link : ErlLink -> bool

Parameters

link
Type: NFX.Erlang ErlLink

Return Value

Type: Online Boolean
See Also
ErlLinks Class
ErlLinks Members
Add Overload
NFX.Erlang Namespace


ErlLinks.Add Method (ErlPid)

ErlLinks Add Method (ErlPid) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Add(
    ErlPid to
)
public bool Add(
    ErlPid to
)
Public Function Add (
    to As ErlPid
) As Boolean
Public Function Add (
    to As ErlPid
) As Boolean
public:
bool Add(
    ErlPid to
)
public:
bool Add(
    ErlPid to
)
member Add :
        to : ErlPid -> bool
member Add :
        to : ErlPid -> bool

Parameters

to
Type: NFX.Erlang ErlPid

Return Value

Type: Online Boolean
See Also
ErlLinks Class
ErlLinks Members
Add Overload
NFX.Erlang Namespace


ErlLinks.Clear Method

ErlLinks Clear Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SortedSet<ErlLink> Clear()
public SortedSet<ErlLink> Clear()
Public Function Clear As SortedSet(Of ErlLink)
Public Function Clear As SortedSet(Of ErlLink)
public:
SortedSet<ErlLink>^ Clear()
public:
SortedSet<ErlLink>^ Clear()
member Clear : unit -> SortedSet<ErlLink>
member Clear : unit -> SortedSet<ErlLink>

Return Value

Type: Online SortedSet ErlLink
See Also
ErlLinks Class
ErlLinks Members
NFX.Erlang Namespace


ErlLinks.Exists Method

ErlLinks Exists Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Exists(
    ErlLink link
)
public bool Exists(
    ErlLink link
)
Public Function Exists (
    link As ErlLink
) As Boolean
Public Function Exists (
    link As ErlLink
) As Boolean
public:
bool Exists(
    ErlLink link
)
public:
bool Exists(
    ErlLink link
)
member Exists :
        link : ErlLink -> bool
member Exists :
        link : ErlLink -> bool

Parameters

link
Type: NFX.Erlang ErlLink

Return Value

Type: Online Boolean
See Also
ErlLinks Class
ErlLinks Members
NFX.Erlang Namespace


ErlLinks.GetEnumerator Method

ErlLinks GetEnumerator Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator GetEnumerator()
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed
public:
virtual IEnumerator^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
ErlLinks Class
ErlLinks Members
NFX.Erlang Namespace


ErlLinks.Remove Method

ErlLinks Remove Method NFX Class Library

Overload List
 | Name | Description
Public method | Remove(ErlAtom) |
Public method | Remove(ErlLink) |
Public method | Remove(ErlPid) |
Back to Top
See Also
ErlLinks Class
ErlLinks Members
NFX.Erlang Namespace


ErlLinks.Remove Method (ErlAtom)

ErlLinks Remove Method (ErlAtom) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<ErlLink> Remove(
    ErlAtom toNode
)
public List<ErlLink> Remove(
    ErlAtom toNode
)
Public Function Remove (
    toNode As ErlAtom
) As List(Of ErlLink)
Public Function Remove (
    toNode As ErlAtom
) As List(Of ErlLink)
public:
List<ErlLink>^ Remove(
    ErlAtom toNode
)
public:
List<ErlLink>^ Remove(
    ErlAtom toNode
)
member Remove :
        toNode : ErlAtom -> List<ErlLink>
member Remove :
        toNode : ErlAtom -> List<ErlLink>

Parameters

toNode
Type: NFX.Erlang ErlAtom

Return Value

Type: Online List ErlLink
See Also
ErlLinks Class
ErlLinks Members
Remove Overload
NFX.Erlang Namespace


ErlLinks.Remove Method (ErlLink)

ErlLinks Remove Method (ErlLink) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Remove(
    ErlLink link
)
public bool Remove(
    ErlLink link
)
Public Function Remove (
    link As ErlLink
) As Boolean
Public Function Remove (
    link As ErlLink
) As Boolean
public:
bool Remove(
    ErlLink link
)
public:
bool Remove(
    ErlLink link
)
member Remove :
        link : ErlLink -> bool
member Remove :
        link : ErlLink -> bool

Parameters

link
Type: NFX.Erlang ErlLink

Return Value

Type: Online Boolean
See Also
ErlLinks Class
ErlLinks Members
Remove Overload
NFX.Erlang Namespace


ErlLinks.Remove Method (ErlPid)

ErlLinks Remove Method (ErlPid) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Remove(
    ErlPid to
)
public bool Remove(
    ErlPid to
)
Public Function Remove (
    to As ErlPid
) As Boolean
Public Function Remove (
    to As ErlPid
) As Boolean
public:
bool Remove(
    ErlPid to
)
public:
bool Remove(
    ErlPid to
)
member Remove :
        to : ErlPid -> bool
member Remove :
        to : ErlPid -> bool

Parameters

to
Type: NFX.Erlang ErlPid

Return Value

Type: Online Boolean
See Also
ErlLinks Class
ErlLinks Members
Remove Overload
NFX.Erlang Namespace


ErlLinks Properties

ErlLinks Properties NFX Class Library

The ErlLinks type exposes the following members.
Properties
 | Name | Description
Public property | Count |
Public property | Links |
Back to Top
See Also
ErlLinks Class
NFX.Erlang Namespace


ErlLinks.Count Property

ErlLinks Count Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
public:
property int Count {
    int get ();
}
member Count : int with get
member Count : int with get

Property Value

Type: Online Int32
See Also
ErlLinks Class
ErlLinks Members
NFX.Erlang Namespace


ErlLinks.Links Property

ErlLinks Links Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SortedSet<ErlLink> Links { get; }
public SortedSet<ErlLink> Links { get; }
Public ReadOnly Property Links As SortedSet(Of ErlLink)
    Get
Public ReadOnly Property Links As SortedSet(Of ErlLink)
    Get
public:
property SortedSet<ErlLink>^ Links {
    SortedSet<ErlLink>^ get ();
}
public:
property SortedSet<ErlLink>^ Links {
    SortedSet<ErlLink>^ get ();
}
member Links : SortedSet<ErlLink> with get
member Links : SortedSet<ErlLink> with get

Property Value

Type: Online SortedSet ErlLink
See Also
ErlLinks Class
ErlLinks Members
NFX.Erlang Namespace


ErlList Class

ErlList Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Erlang ErlTupleBase
NFX.Erlang ErlList

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ErlList : ErlTupleBase
public class ErlList : ErlTupleBase
Public Class ErlList
    Inherits ErlTupleBase
Public Class ErlList
    Inherits ErlTupleBase
public ref class ErlList : public ErlTupleBase
public ref class ErlList : public ErlTupleBase
type ErlList =
    class
        inherit ErlTupleBase
    end
type ErlList =
    class
        inherit ErlTupleBase
    end
See Also
ErlList Members
NFX.Erlang Namespace


ErlList Members

ErlList Members NFX Class Library

The ErlList type exposes the following members.
Constructors
 | Name | Description
Public method | ErlList( Object ) | Initializes a new instance of the ErlList class
Public method | ErlList(ErlList) | Initializes a new instance of the ErlList class
Public method | ErlList( IErlObject , Boolean) | Create an Erlang string from the given string
Public method | ErlList(List IErlObject , Boolean) | Initializes a new instance of the ErlList class
Back to Top
Methods
 | Name | Description
Public method | Add | Add an item to a mutable list. This method must be used only during list construction phase, since it treats the list as a mutable entity (Inherited from ErlTupleBase.)
Public method | Cast T | Return index'th element cast to the given type (Inherited from ErlTupleBase.)
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference) (Inherited from ErlTupleBase.)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the atom is less than obj, positive - greater than the obj (Inherited from ErlTupleBase.)
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the atom is less than obj, positive - greater than the obj (Inherited from ErlTupleBase.)
 | Create |
Public method | Equals(Object) | (Overrides ErlTupleBase Equals(Object).)
Public method | Equals(ErlList) | Determine if two Erlang lists are equal
Public method | Equals(IErlObject) | Determine if two Erlang objects are equal (Overrides ErlTupleBase Equals(IErlObject).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides ErlTupleBase GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeInstance | (Overrides ErlTupleBase MakeInstance .)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern (Inherited from ErlTupleBase.)
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding. (Inherited from ErlTupleBase.)
Public method | Matches | Perform pattern match on this Erlang term without binding any variables (Inherited from ErlTupleBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Subst | (Inherited from ErlTupleBase.)
Public method | ToString | Get the string representation of the list. (Inherited from ErlTupleBase.)
Public method | ToString(Boolean) | (Inherited from ErlTupleBase.)
Public method | Visit TAccumulate | Execute fun for every nested term (Inherited from ErlTupleBase.)
Back to Top
Operators
Name | Description
Equality |
(ErlList to List IErlObject ) | Implicit conversion of atom to string
Inequality |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | Empty |
Protected field | m_Items | The index of this atom in the global atom table (Inherited from ErlTupleBase.)
Back to Top
Properties
 | Name | Description
Protected property | CloseBracket | (Overrides ErlTupleBase CloseBracket.)
Public property | Count | Return number of elements in the container (Inherited from ErlTupleBase.)
Public property | IsScalar | Determines whether the underlying type is scalar or complex (i.e. tuple, list) (Inherited from ErlTupleBase.)
Public property | Item | Return index'th element from the container (Inherited from ErlTupleBase.)
Protected property | OpenBracket | (Overrides ErlTupleBase OpenBracket.)
Public property | TypeOrder | (Overrides ErlTupleBase TypeOrder.)
Public property | Value | Get the list of Erlang terms contained in this object (Inherited from ErlTupleBase.)
Public property | ValueAsBool | (Inherited from ErlTupleBase.)
Public property | ValueAsByteArray | (Inherited from ErlTupleBase.)
Public property | ValueAsChar | (Inherited from ErlTupleBase.)
Public property | ValueAsDateTime | (Inherited from ErlTupleBase.)
Public property | ValueAsDecimal | (Inherited from ErlTupleBase.)
Public property | ValueAsDouble | (Inherited from ErlTupleBase.)
Public property | ValueAsInt | (Inherited from ErlTupleBase.)
Public property | ValueAsLong | (Inherited from ErlTupleBase.)
Public property | ValueAsObject | (Inherited from ErlTupleBase.)
Public property | ValueAsString | (Overrides ErlTupleBase ValueAsString.)
Public property | ValueAsTimeSpan | (Inherited from ErlTupleBase.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone | (Inherited from ErlTupleBase.)
Explicit interface implemetation | IEnumerable IErlObject GetEnumerator | (Inherited from ErlTupleBase.)
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from ErlTupleBase.)
Back to Top
See Also
ErlList Class
NFX.Erlang Namespace


ErlList Constructor

ErlList Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ErlList( Object ) | Initializes a new instance of the ErlList class
Public method | ErlList(ErlList) | Initializes a new instance of the ErlList class
Public method | ErlList( IErlObject , Boolean) | Create an Erlang string from the given string
Public method | ErlList(List IErlObject , Boolean) | Initializes a new instance of the ErlList class
Back to Top
See Also
ErlList Class
ErlList Members
NFX.Erlang Namespace


ErlList Constructor (Object[])

ErlList Constructor ( Object ) NFX Class Library

Initializes a new instance of the ErlList class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlList(
    params Object[] items
)
public ErlList(
    params Object[] items
)
Public Sub New (
    ParamArray items As Object()
)
Public Sub New (
    ParamArray items As Object()
)
public:
ErlList(
    ... array<Object^>^ items
)
public:
ErlList(
    ... array<Object^>^ items
)
new :
        items : Object[] -> ErlList
new :
        items : Object[] -> ErlList

Parameters

items
Type: Online System Object
See Also
ErlList Class
ErlList Members
ErlList Overload
NFX.Erlang Namespace


ErlList Constructor (ErlList)

ErlList Constructor (ErlList) NFX Class Library

Initializes a new instance of the ErlList class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlList(
    ErlList list
)
public ErlList(
    ErlList list
)
Public Sub New (
    list As ErlList
)
Public Sub New (
    list As ErlList
)
public:
ErlList(
    ErlList^ list
)
public:
ErlList(
    ErlList^ list
)
new :
        list : ErlList -> ErlList
new :
        list : ErlList -> ErlList

Parameters

list
Type: NFX.Erlang ErlList
See Also
ErlList Class
ErlList Members
ErlList Overload
NFX.Erlang Namespace


ErlList Constructor (IErlObject[], Boolean)

ErlList Constructor ( IErlObject , Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Create an Erlang string from the given string

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlList(
    IErlObject[] items,
    bool clone = true
)
public ErlList(
    IErlObject[] items,
    bool clone = true
)
Public Sub New (
    items As IErlObject(),
    Optional clone As Boolean = true
)
Public Sub New (
    items As IErlObject(),
    Optional clone As Boolean = true
)
public:
ErlList(
    array<IErlObject^>^ items,
    bool clone = true
)
public:
ErlList(
    array<IErlObject^>^ items,
    bool clone = true
)
new :
        items : IErlObject[] *
        ?clone : bool
(* Defaults:
        let _clone = defaultArg clone true
*)
-> ErlList
new :
        items : IErlObject[] *
        ?clone : bool
(* Defaults:
        let _clone = defaultArg clone true
*)
-> ErlList

Parameters

items
Type: NFX.Erlang IErlObject
clone (Optional)
Type: Online System Boolean
See Also
ErlList Class
ErlList Members
ErlList Overload
NFX.Erlang Namespace


ErlList Constructor (List(IErlObject), Boolean)

ErlList Constructor (List IErlObject , Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlList class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlList(
    List<IErlObject> items,
    bool clone = true
)
public ErlList(
    List<IErlObject> items,
    bool clone = true
)
Public Sub New (
    items As List(Of IErlObject),
    Optional clone As Boolean = true
)
Public Sub New (
    items As List(Of IErlObject),
    Optional clone As Boolean = true
)
public:
ErlList(
    List<IErlObject^>^ items,
    bool clone = true
)
public:
ErlList(
    List<IErlObject^>^ items,
    bool clone = true
)
new :
        items : List<IErlObject> *
        ?clone : bool
(* Defaults:
        let _clone = defaultArg clone true
*)
-> ErlList
new :
        items : List<IErlObject> *
        ?clone : bool
(* Defaults:
        let _clone = defaultArg clone true
*)
-> ErlList

Parameters

items
Type: Online System.Collections.Generic List IErlObject
clone (Optional)
Type: Online System Boolean
See Also
ErlList Class
ErlList Members
ErlList Overload
NFX.Erlang Namespace


ErlList Fields

ErlList Fields NFX Class Library

The ErlList type exposes the following members.
Fields
 | Name | Description
 | Empty |
Protected field | m_Items | The index of this atom in the global atom table (Inherited from ErlTupleBase.)
Back to Top
See Also
ErlList Class
NFX.Erlang Namespace


ErlList.Empty Field

ErlList Empty Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ErlList Empty
public static readonly ErlList Empty
Public Shared ReadOnly Empty As ErlList
Public Shared ReadOnly Empty As ErlList
public:
static initonly ErlList^ Empty
public:
static initonly ErlList^ Empty
static val Empty: ErlList
static val Empty: ErlList

Field Value

Type: ErlList
See Also
ErlList Class
ErlList Members
NFX.Erlang Namespace


ErlList Methods

ErlList Methods NFX Class Library

The ErlList type exposes the following members.
Methods
 | Name | Description
Public method | Add | Add an item to a mutable list. This method must be used only during list construction phase, since it treats the list as a mutable entity (Inherited from ErlTupleBase.)
Public method | Cast T | Return index'th element cast to the given type (Inherited from ErlTupleBase.)
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference) (Inherited from ErlTupleBase.)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the atom is less than obj, positive - greater than the obj (Inherited from ErlTupleBase.)
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the atom is less than obj, positive - greater than the obj (Inherited from ErlTupleBase.)
 | Create |
Public method | Equals(Object) | (Overrides ErlTupleBase Equals(Object).)
Public method | Equals(ErlList) | Determine if two Erlang lists are equal
Public method | Equals(IErlObject) | Determine if two Erlang objects are equal (Overrides ErlTupleBase Equals(IErlObject).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides ErlTupleBase GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeInstance | (Overrides ErlTupleBase MakeInstance .)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern (Inherited from ErlTupleBase.)
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding. (Inherited from ErlTupleBase.)
Public method | Matches | Perform pattern match on this Erlang term without binding any variables (Inherited from ErlTupleBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Subst | (Inherited from ErlTupleBase.)
Public method | ToString | Get the string representation of the list. (Inherited from ErlTupleBase.)
Public method | ToString(Boolean) | (Inherited from ErlTupleBase.)
Public method | Visit TAccumulate | Execute fun for every nested term (Inherited from ErlTupleBase.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone | (Inherited from ErlTupleBase.)
Explicit interface implemetation | IEnumerable IErlObject GetEnumerator | (Inherited from ErlTupleBase.)
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from ErlTupleBase.)
Back to Top
See Also
ErlList Class
NFX.Erlang Namespace


ErlList.Create Method

ErlList Create Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlList Create(
    params Object[] items
)
public static ErlList Create(
    params Object[] items
)
Public Shared Function Create (
    ParamArray items As Object()
) As ErlList
Public Shared Function Create (
    ParamArray items As Object()
) As ErlList
public:
static ErlList^ Create(
    ... array<Object^>^ items
)
public:
static ErlList^ Create(
    ... array<Object^>^ items
)
static member Create :
        items : Object[] -> ErlList
static member Create :
        items : Object[] -> ErlList

Parameters

items
Type: Online System Object

Return Value

Type: ErlList
See Also
ErlList Class
ErlList Members
NFX.Erlang Namespace


ErlList.Equals Method

ErlList Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ErlTupleBase Equals(Object).)
Public method | Equals(ErlList) | Determine if two Erlang lists are equal
Public method | Equals(IErlObject) | Determine if two Erlang objects are equal (Overrides ErlTupleBase Equals(IErlObject).)
Back to Top
See Also
ErlList Class
ErlList Members
NFX.Erlang Namespace


ErlList.Equals Method (Object)

ErlList Equals Method (Object) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals (
    o As Object
) As Boolean
Public Overrides Function Equals (
    o As Object
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool

Parameters

o
Type: Online System Object

Return Value

Type: Online Boolean
See Also
ErlList Class
ErlList Members
Equals Overload
NFX.Erlang Namespace


ErlList.Equals Method (ErlList)

ErlList Equals Method (ErlList) NFX Class Library

Determine if two Erlang lists are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    ErlList o
)
public bool Equals(
    ErlList o
)
Public Function Equals (
    o As ErlList
) As Boolean
Public Function Equals (
    o As ErlList
) As Boolean
public:
bool Equals(
    ErlList^ o
)
public:
bool Equals(
    ErlList^ o
)
member Equals :
        o : ErlList -> bool
member Equals :
        o : ErlList -> bool

Parameters

o
Type: NFX.Erlang ErlList

Return Value

Type: Online Boolean
See Also
ErlList Class
ErlList Members
Equals Overload
NFX.Erlang Namespace


ErlList.Equals Method (IErlObject)

ErlList Equals Method (IErlObject) NFX Class Library

Determine if two Erlang objects are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    IErlObject o
)
public override bool Equals(
    IErlObject o
)
Public Overrides Function Equals (
    o As IErlObject
) As Boolean
Public Overrides Function Equals (
    o As IErlObject
) As Boolean
public:
virtual bool Equals(
    IErlObject^ o
) override
public:
virtual bool Equals(
    IErlObject^ o
) override
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool

Parameters

o
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
ErlList Class
ErlList Members
Equals Overload
NFX.Erlang Namespace


ErlList.GetHashCode Method

ErlList GetHashCode Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
ErlList Class
ErlList Members
NFX.Erlang Namespace


ErlList.MakeInstance Method

ErlList MakeInstance Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override ErlTupleBase MakeInstance()
protected override ErlTupleBase MakeInstance()
Protected Overrides Function MakeInstance As ErlTupleBase
Protected Overrides Function MakeInstance As ErlTupleBase
protected:
virtual ErlTupleBase^ MakeInstance() override
protected:
virtual ErlTupleBase^ MakeInstance() override
abstract MakeInstance : unit -> ErlTupleBase
override MakeInstance : unit -> ErlTupleBase
abstract MakeInstance : unit -> ErlTupleBase
override MakeInstance : unit -> ErlTupleBase

Return Value

Type: ErlTupleBase
See Also
ErlList Class
ErlList Members
NFX.Erlang Namespace


ErlList Operators and Type Conversions

ErlList Operators and Type Conversions NFX Class Library

The ErlList type exposes the following members.
Operators
Name | Description
Equality |
(ErlList to List IErlObject ) | Implicit conversion of atom to string
Inequality |
Back to Top
See Also
ErlList Class
NFX.Erlang Namespace


ErlList.Equality Operator

ErlList Equality Operator NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    ErlList lhs,
    IErlObject rhs
)
public static bool operator ==(
    ErlList lhs,
    IErlObject rhs
)
Public Shared Operator = (
    lhs As ErlList,
    rhs As IErlObject
) As Boolean
Public Shared Operator = (
    lhs As ErlList,
    rhs As IErlObject
) As Boolean
public:
static bool operator ==(
    ErlList^ lhs,
    IErlObject^ rhs
)
public:
static bool operator ==(
    ErlList^ lhs,
    IErlObject^ rhs
)
static let inline (=)
        lhs : ErlList *
        rhs : IErlObject  : bool
static let inline (=)
        lhs : ErlList *
        rhs : IErlObject  : bool

Parameters

lhs
Type: NFX.Erlang ErlList
rhs
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean
See Also
ErlList Class
ErlList Members
NFX.Erlang Namespace


ErlList Implicit Conversion (ErlList to List(IErlObject))

ErlList Conversion (ErlList to List IErlObject ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Implicit conversion of atom to string

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static implicit operator List<IErlObject> (
    ErlList a
)
public static implicit operator List<IErlObject> (
    ErlList a
)
Public Shared Widening Operator CType (
    a As ErlList
) As List(Of IErlObject)
Public Shared Widening Operator CType (
    a As ErlList
) As List(Of IErlObject)
static implicit operator List<IErlObject^>^ (
    ErlList^ a
)
static implicit operator List<IErlObject^>^ (
    ErlList^ a
)
F# does not support the declaration of new casting operators.
F# does not support the declaration of new casting operators.

Parameters

a
Type: NFX.Erlang ErlList

Return Value

Type: Online List IErlObject
See Also
ErlList Class
ErlList Members
NFX.Erlang Namespace


ErlList.Inequality Operator

ErlList Inequality Operator NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    ErlList lhs,
    IErlObject rhs
)
public static bool operator !=(
    ErlList lhs,
    IErlObject rhs
)
Public Shared Operator <> (
    lhs As ErlList,
    rhs As IErlObject
) As Boolean
Public Shared Operator <> (
    lhs As ErlList,
    rhs As IErlObject
) As Boolean
public:
static bool operator !=(
    ErlList^ lhs,
    IErlObject^ rhs
)
public:
static bool operator !=(
    ErlList^ lhs,
    IErlObject^ rhs
)
static let inline (<>)
        lhs : ErlList *
        rhs : IErlObject  : bool
static let inline (<>)
        lhs : ErlList *
        rhs : IErlObject  : bool

Parameters

lhs
Type: NFX.Erlang ErlList
rhs
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean
See Also
ErlList Class
ErlList Members
NFX.Erlang Namespace


ErlList Properties

ErlList Properties NFX Class Library

The ErlList type exposes the following members.
Properties
 | Name | Description
Protected property | CloseBracket | (Overrides ErlTupleBase CloseBracket.)
Public property | Count | Return number of elements in the container (Inherited from ErlTupleBase.)
Public property | IsScalar | Determines whether the underlying type is scalar or complex (i.e. tuple, list) (Inherited from ErlTupleBase.)
Public property | Item | Return index'th element from the container (Inherited from ErlTupleBase.)
Protected property | OpenBracket | (Overrides ErlTupleBase OpenBracket.)
Public property | TypeOrder | (Overrides ErlTupleBase TypeOrder.)
Public property | Value | Get the list of Erlang terms contained in this object (Inherited from ErlTupleBase.)
Public property | ValueAsBool | (Inherited from ErlTupleBase.)
Public property | ValueAsByteArray | (Inherited from ErlTupleBase.)
Public property | ValueAsChar | (Inherited from ErlTupleBase.)
Public property | ValueAsDateTime | (Inherited from ErlTupleBase.)
Public property | ValueAsDecimal | (Inherited from ErlTupleBase.)
Public property | ValueAsDouble | (Inherited from ErlTupleBase.)
Public property | ValueAsInt | (Inherited from ErlTupleBase.)
Public property | ValueAsLong | (Inherited from ErlTupleBase.)
Public property | ValueAsObject | (Inherited from ErlTupleBase.)
Public property | ValueAsString | (Overrides ErlTupleBase ValueAsString.)
Public property | ValueAsTimeSpan | (Inherited from ErlTupleBase.)
Back to Top
See Also
ErlList Class
NFX.Erlang Namespace


ErlList.CloseBracket Property

ErlList CloseBracket Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override char CloseBracket { get; }
protected override char CloseBracket { get; }
Protected Overrides ReadOnly Property CloseBracket As Char
    Get
Protected Overrides ReadOnly Property CloseBracket As Char
    Get
protected:
virtual property wchar_t CloseBracket {
    wchar_t get () override;
}
protected:
virtual property wchar_t CloseBracket {
    wchar_t get () override;
}
abstract CloseBracket : char with get
override CloseBracket : char with get
abstract CloseBracket : char with get
override CloseBracket : char with get

Property Value

Type: Online Char
See Also
ErlList Class
ErlList Members
NFX.Erlang Namespace


ErlList.OpenBracket Property

ErlList OpenBracket Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override char OpenBracket { get; }
protected override char OpenBracket { get; }
Protected Overrides ReadOnly Property OpenBracket As Char
    Get
Protected Overrides ReadOnly Property OpenBracket As Char
    Get
protected:
virtual property wchar_t OpenBracket {
    wchar_t get () override;
}
protected:
virtual property wchar_t OpenBracket {
    wchar_t get () override;
}
abstract OpenBracket : char with get
override OpenBracket : char with get
abstract OpenBracket : char with get
override OpenBracket : char with get

Property Value

Type: Online Char
See Also
ErlList Class
ErlList Members
NFX.Erlang Namespace


ErlList.TypeOrder Property

ErlList TypeOrder Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ErlTypeOrder TypeOrder { get; }
public override ErlTypeOrder TypeOrder { get; }
Public Overrides ReadOnly Property TypeOrder As ErlTypeOrder
    Get
Public Overrides ReadOnly Property TypeOrder As ErlTypeOrder
    Get
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () override;
}
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () override;
}
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get

Property Value

Type: ErlTypeOrder

Implements

IErlObject TypeOrder
See Also
ErlList Class
ErlList Members
NFX.Erlang Namespace


ErlList.ValueAsString Property

ErlList ValueAsString Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueAsString { get; }
public override string ValueAsString { get; }
Public Overrides ReadOnly Property ValueAsString As String
    Get
Public Overrides ReadOnly Property ValueAsString As String
    Get
public:
virtual property String^ ValueAsString {
    String^ get () override;
}
public:
virtual property String^ ValueAsString {
    String^ get () override;
}
abstract ValueAsString : string with get
override ValueAsString : string with get
abstract ValueAsString : string with get
override ValueAsString : string with get

Property Value

Type: Online String

Implements

IErlObject ValueAsString
See Also
ErlList Class
ErlList Members
NFX.Erlang Namespace


ErlLocalNode Class

ErlLocalNode Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.Erlang ErlAbstractNode
NFX.Erlang ErlLocalNode

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ErlLocalNode : ErlAbstractNode,
    IApplicationFinishNotifiable, INamed
public class ErlLocalNode : ErlAbstractNode,
    IApplicationFinishNotifiable, INamed
Public Class ErlLocalNode
    Inherits ErlAbstractNode
    Implements IApplicationFinishNotifiable, INamed
Public Class ErlLocalNode
    Inherits ErlAbstractNode
    Implements IApplicationFinishNotifiable, INamed
public ref class ErlLocalNode : public ErlAbstractNode,
    IApplicationFinishNotifiable, INamed
public ref class ErlLocalNode : public ErlAbstractNode,
    IApplicationFinishNotifiable, INamed
type ErlLocalNode =
    class
        inherit ErlAbstractNode
        interface IApplicationFinishNotifiable
        interface INamed
    end
type ErlLocalNode =
    class
        inherit ErlAbstractNode
        interface IApplicationFinishNotifiable
        interface INamed
    end
See Also
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode Members

ErlLocalNode Members NFX Class Library

The ErlLocalNode type exposes the following members.
Constructors
 | Name | Description
Protected method | ErlLocalNode(String, IConfigSectionNode) | Initializes a new instance of the ErlLocalNode class
Public method | ErlLocalNode(String, Boolean, Boolean) | Create a node with the given name and the default cookie
Public method | ErlLocalNode(String, ErlAtom, Boolean, Boolean) | Create a node with the given name, cookie, and short name indicator
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | Add | Add a connection to collection
Public method | ApplicationFinishAfterCleanup |
Public method | ApplicationFinishBeforeCleanup |
Protected method | BreakLinks | Break links of all pids linked to pids on the fromNode node
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | CloseMbox | Close the given mailbox
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Public method | Connection(String, Nullable ErlAtom ) |
Public method | Connection(ErlAtom, Nullable ErlAtom ) |
Protected method | Connection(String, IConfigSectionNode, Nullable ErlAtom ) |
Public method | CreateMbox(String) | Create a new named mailbox (emulates spawning a new Pid)
Public method | CreateMbox(ErlAtom) | Create a new named mailbox (emulates spawning a new Pid)
 | CreateNullPid | Create an Erlang ErlPid that belongs to current node
Protected method | CreatePid | Create an Erlang ErlPid. Erlang pids are based upon some node specific information; this method creates a pid using the information in this node. Each call to this method produces a unique pid
Protected method | CreatePort | Create an Erlang ErlPort. Erlang ports are based upon some node specific information; this method creates a port using the information in this node. Each call to this method produces a unique port. It may not be meaningful to create a port in a non-Erlang environment, but this method is provided for completeness
Public method | CreateRef | Create an Erlang {@link Ref reference}. Erlang references are based upon some node specific information; this method creates a reference using the information in this node. Each call to this method produces a unique reference
Protected method | Deliver(ErlConnectionException) |
Protected method | Deliver(ErlMsg) |
Protected method | Deliver(ErlAtom, ErlMsg) |
Protected method | Destructor | (Inherited from Service.)
Public method | Disconnect |
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides ErlAbstractNode DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Start current node. This optionally creates a socket listener and I/O server (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | FindMbox | Determine the mailbox corresponding to a registered name on this ErlLocalNode
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
 | MakeLocalNodeForThisAppOnThisHost | Makes local node name based on app id and local host name
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnConnectAttempt |
Protected method | OnEpmdFailedConnectAttempt |
Protected method | OnIoOutput |
Protected method | OnNodeStatusChange |
Protected method | OnReadWrite |
Protected method | OnTrace(ErlTraceLevel, Direction, Func String , String, Int32) |
Protected method | OnTrace(ErlTraceLevel, Direction, String, String, Int32) |
Protected method | OnTraceCore |
Protected method | OnUnhandledMsg |
Public method | RemoteNodeConfig | Get configuration settings for a given remote node
Public method | Remove | Remove a connection from collection
Public method | RPC |
Public method | Send(ErlPid, IErlObject) | Send a message to a remote ErlPid, representing either another ErlMbox or an Erlang process
Public method | Send(ErlPid, ErlAtom, IErlObject) | Send a message to a named mailbox on local node
Public method | Send(ErlPid, ErlAtom, ErlAtom, IErlObject) | Send a message to a named mailbox on a given remote node
Protected method | SetNodeName | (Inherited from ErlAbstractNode.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | ToString | (Inherited from ErlAbstractNode.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitAny( ErlMbox ) |
Public method | WaitAny(Int32, ErlMbox ) |
Public method | WaitAny( ErlMbox , Int32) | Wait for arrival of messages in any one of the given mailboxes
Public method | WaitAny(IEnumerable ErlMbox , Int32) |
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Creation | (Inherited from ErlAbstractNode.)
Protected field | m_Mailboxes |
Protected field | m_OnReadWrite | Delegate invoked on read/write from socket
Protected field | m_TcpKeepAlive | (Inherited from ErlAbstractNode.)
Protected field | m_TcpLinger | (Inherited from ErlAbstractNode.)
Protected field | m_TcpNoDelay | (Inherited from ErlAbstractNode.)
Protected field | m_TcpRcvBufSize | (Inherited from ErlAbstractNode.)
Protected field | m_TcpSndBufSize | (Inherited from ErlAbstractNode.)
Back to Top
Properties
 | Name | Description
Protected property | AcceptAddressPort | Configuration Address and Port information for the listener in the "address:port" format
Public property | AcceptConnections | If true local node will start a listener
Public property | AliveName | Get the alivename part of the hostname. Nodenames are composed of two parts, an alivename and a hostname, separated by '@'. This method returns the part of the nodename preceding the '@' (Inherited from ErlAbstractNode.)
Public property | AllNodeConfigs | Configs for remote nodes
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Connections |
Public property | Cookie | Get the authorization cookie used by this node (Inherited from ErlAbstractNode.)
Public property | Creation | Contains node creation bits that facilitate Pid uniqueness upon node restart
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Protected property | DistChoose | (Inherited from ErlAbstractNode.)
Protected property | DistHigh | (Inherited from ErlAbstractNode.)
Protected property | DistLow | (Inherited from ErlAbstractNode.)
Protected property | Epmd | Get/Set the Epmd socket after publishing this nodes listen port to Epmd (Inherited from ErlAbstractNode.)
Protected property | Flags | (Inherited from ErlAbstractNode.)
Public property | GroupLeader | Mailbox for handling all I/O directed from remote nodes
Public property | Host | Get the hostname part of the nodename. Nodenames are composed of two parts, an alivename and a hostname, separated by '@'. This method returns the part of the nodename following the '@' (Inherited from ErlAbstractNode.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | LogUnhandledMsgs | Record unhandled msgs to log
Protected property | Mailboxes |
Protected property | MboxFreelist | Cache of freed mailboxes that can be reused for RPC calls
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | NodeLongName | Get the long name of this node (Inherited from ErlAbstractNode.)
Public property | NodeName | Get the name of this node (short or long depending on UseShortName) (Inherited from ErlAbstractNode.)
Protected property | Ntype | (Inherited from ErlAbstractNode.)
Public property | Port | Get the port number used by this node. For local node the value may be 0 if the node was not registered with the EPMD port mapper (Inherited from ErlAbstractNode.)
Protected property | Proto | (Inherited from ErlAbstractNode.)
Public property | RemoteNodeConfigs |
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TcpKeepAlive | (Inherited from ErlAbstractNode.)
Public property | TcpLinger | (Inherited from ErlAbstractNode.)
Public property | TcpNoDelay | (Inherited from ErlAbstractNode.)
Public property | TcpRcvBufSize | (Inherited from ErlAbstractNode.)
Public property | TcpSndBufSize | (Inherited from ErlAbstractNode.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TraceLevel | Set the trace level for this connection. Normally tracing is off by default
Public property | TraceToLog | Save trace events to log
Protected property | UseShortName | (Inherited from ErlAbstractNode.)
Back to Top
Events
 | Name | Description
Public event | ConnectAttempt |
Public event | EpmdFailedConnectAttempt |
Public event | IoOutput |
Public event | NodeStatusChange |
Public event | ReadWrite |
Public event | Trace | Trace callback executed if connection tracing is enabled
Public event | UnhandledMsg |
Back to Top
See Also
ErlLocalNode Class
NFX.Erlang Namespace


ErlLocalNode Constructor

ErlLocalNode Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | ErlLocalNode(String, IConfigSectionNode) | Initializes a new instance of the ErlLocalNode class
Public method | ErlLocalNode(String, Boolean, Boolean) | Create a node with the given name and the default cookie
Public method | ErlLocalNode(String, ErlAtom, Boolean, Boolean) | Create a node with the given name, cookie, and short name indicator
Back to Top
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode Constructor (String, IConfigSectionNode)

ErlLocalNode Constructor (String, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlLocalNode class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ErlLocalNode(
    string node,
    IConfigSectionNode config
)
internal ErlLocalNode(
    string node,
    IConfigSectionNode config
)
Friend Sub New (
    node As String,
    config As IConfigSectionNode
)
Friend Sub New (
    node As String,
    config As IConfigSectionNode
)
internal:
ErlLocalNode(
    String^ node,
    IConfigSectionNode^ config
)
internal:
ErlLocalNode(
    String^ node,
    IConfigSectionNode^ config
)
new :
        node : string *
        config : IConfigSectionNode -> ErlLocalNode
new :
        node : string *
        config : IConfigSectionNode -> ErlLocalNode

Parameters

node
Type: Online System String
config
Type: NFX.Environment IConfigSectionNode
See Also
ErlLocalNode Class
ErlLocalNode Members
ErlLocalNode Overload
NFX.Erlang Namespace


ErlLocalNode Constructor (String, Boolean, Boolean)

ErlLocalNode Constructor (String, Boolean, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Create a node with the given name and the default cookie

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlLocalNode(
    string node,
    bool shortName = true,
    bool acceptConns = true
)
public ErlLocalNode(
    string node,
    bool shortName = true,
    bool acceptConns = true
)
Public Sub New (
    node As String,
    Optional shortName As Boolean = true,
    Optional acceptConns As Boolean = true
)
Public Sub New (
    node As String,
    Optional shortName As Boolean = true,
    Optional acceptConns As Boolean = true
)
public:
ErlLocalNode(
    String^ node,
    bool shortName = true,
    bool acceptConns = true
)
public:
ErlLocalNode(
    String^ node,
    bool shortName = true,
    bool acceptConns = true
)
new :
        node : string *
        ?shortName : bool *
        ?acceptConns : bool
(* Defaults:
        let _shortName = defaultArg shortName true
        let _acceptConns = defaultArg acceptConns true
*)
-> ErlLocalNode
new :
        node : string *
        ?shortName : bool *
        ?acceptConns : bool
(* Defaults:
        let _shortName = defaultArg shortName true
        let _acceptConns = defaultArg acceptConns true
*)
-> ErlLocalNode

Parameters

node
Type: Online System String
shortName (Optional)
Type: Online System Boolean
acceptConns (Optional)
Type: Online System Boolean
See Also
ErlLocalNode Class
ErlLocalNode Members
ErlLocalNode Overload
NFX.Erlang Namespace


ErlLocalNode Constructor (String, ErlAtom, Boolean, Boolean)

ErlLocalNode Constructor (String, ErlAtom, Boolean, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Create a node with the given name, cookie, and short name indicator

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlLocalNode(
    string node,
    ErlAtom cookie,
    bool shortName = true,
    bool acceptConns = true
)
public ErlLocalNode(
    string node,
    ErlAtom cookie,
    bool shortName = true,
    bool acceptConns = true
)
Public Sub New (
    node As String,
    cookie As ErlAtom,
    Optional shortName As Boolean = true,
    Optional acceptConns As Boolean = true
)
Public Sub New (
    node As String,
    cookie As ErlAtom,
    Optional shortName As Boolean = true,
    Optional acceptConns As Boolean = true
)
public:
ErlLocalNode(
    String^ node,
    ErlAtom cookie,
    bool shortName = true,
    bool acceptConns = true
)
public:
ErlLocalNode(
    String^ node,
    ErlAtom cookie,
    bool shortName = true,
    bool acceptConns = true
)
new :
        node : string *
        cookie : ErlAtom *
        ?shortName : bool *
        ?acceptConns : bool
(* Defaults:
        let _shortName = defaultArg shortName true
        let _acceptConns = defaultArg acceptConns true
*)
-> ErlLocalNode
new :
        node : string *
        cookie : ErlAtom *
        ?shortName : bool *
        ?acceptConns : bool
(* Defaults:
        let _shortName = defaultArg shortName true
        let _acceptConns = defaultArg acceptConns true
*)
-> ErlLocalNode

Parameters

node
Type: Online System String
cookie
Type: NFX.Erlang ErlAtom
shortName (Optional)
Type: Online System Boolean
acceptConns (Optional)
Type: Online System Boolean
See Also
ErlLocalNode Class
ErlLocalNode Members
ErlLocalNode Overload
NFX.Erlang Namespace


ErlLocalNode Fields

ErlLocalNode Fields NFX Class Library

The ErlLocalNode type exposes the following members.
Fields
 | Name | Description
Protected field | m_Creation | (Inherited from ErlAbstractNode.)
Protected field | m_Mailboxes |
Protected field | m_OnReadWrite | Delegate invoked on read/write from socket
Protected field | m_TcpKeepAlive | (Inherited from ErlAbstractNode.)
Protected field | m_TcpLinger | (Inherited from ErlAbstractNode.)
Protected field | m_TcpNoDelay | (Inherited from ErlAbstractNode.)
Protected field | m_TcpRcvBufSize | (Inherited from ErlAbstractNode.)
Protected field | m_TcpSndBufSize | (Inherited from ErlAbstractNode.)
Back to Top
See Also
ErlLocalNode Class
NFX.Erlang Namespace


ErlLocalNode.m_Mailboxes Field

ErlLocalNode m_Mailboxes Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal MboxRegistry m_Mailboxes
internal MboxRegistry m_Mailboxes
Friend m_Mailboxes As MboxRegistry
Friend m_Mailboxes As MboxRegistry
internal:
MboxRegistry^ m_Mailboxes
internal:
MboxRegistry^ m_Mailboxes
val mutable internal m_Mailboxes: MboxRegistry
val mutable internal m_Mailboxes: MboxRegistry

Field Value

Type: MboxRegistry
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.m_OnReadWrite Field

ErlLocalNode m_OnReadWrite Field NFX Class Library

Delegate invoked on read/write from socket

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ReadWriteEventHandler m_OnReadWrite
protected ReadWriteEventHandler m_OnReadWrite
Protected m_OnReadWrite As ReadWriteEventHandler
Protected m_OnReadWrite As ReadWriteEventHandler
protected:
ReadWriteEventHandler^ m_OnReadWrite
protected:
ReadWriteEventHandler^ m_OnReadWrite
val mutable m_OnReadWrite: ReadWriteEventHandler
val mutable m_OnReadWrite: ReadWriteEventHandler

Field Value

Type: ReadWriteEventHandler
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode Methods

ErlLocalNode Methods NFX Class Library

The ErlLocalNode type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | Add | Add a connection to collection
Public method | ApplicationFinishAfterCleanup |
Public method | ApplicationFinishBeforeCleanup |
Protected method | BreakLinks | Break links of all pids linked to pids on the fromNode node
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | CloseMbox | Close the given mailbox
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Public method | Connection(String, Nullable ErlAtom ) |
Public method | Connection(ErlAtom, Nullable ErlAtom ) |
Protected method | Connection(String, IConfigSectionNode, Nullable ErlAtom ) |
Public method | CreateMbox(String) | Create a new named mailbox (emulates spawning a new Pid)
Public method | CreateMbox(ErlAtom) | Create a new named mailbox (emulates spawning a new Pid)
 | CreateNullPid | Create an Erlang ErlPid that belongs to current node
Protected method | CreatePid | Create an Erlang ErlPid. Erlang pids are based upon some node specific information; this method creates a pid using the information in this node. Each call to this method produces a unique pid
Protected method | CreatePort | Create an Erlang ErlPort. Erlang ports are based upon some node specific information; this method creates a port using the information in this node. Each call to this method produces a unique port. It may not be meaningful to create a port in a non-Erlang environment, but this method is provided for completeness
Public method | CreateRef | Create an Erlang {@link Ref reference}. Erlang references are based upon some node specific information; this method creates a reference using the information in this node. Each call to this method produces a unique reference
Protected method | Deliver(ErlConnectionException) |
Protected method | Deliver(ErlMsg) |
Protected method | Deliver(ErlAtom, ErlMsg) |
Protected method | Destructor | (Inherited from Service.)
Public method | Disconnect |
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides ErlAbstractNode DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Start current node. This optionally creates a socket listener and I/O server (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | FindMbox | Determine the mailbox corresponding to a registered name on this ErlLocalNode
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
 | MakeLocalNodeForThisAppOnThisHost | Makes local node name based on app id and local host name
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnConnectAttempt |
Protected method | OnEpmdFailedConnectAttempt |
Protected method | OnIoOutput |
Protected method | OnNodeStatusChange |
Protected method | OnReadWrite |
Protected method | OnTrace(ErlTraceLevel, Direction, Func String , String, Int32) |
Protected method | OnTrace(ErlTraceLevel, Direction, String, String, Int32) |
Protected method | OnTraceCore |
Protected method | OnUnhandledMsg |
Public method | RemoteNodeConfig | Get configuration settings for a given remote node
Public method | Remove | Remove a connection from collection
Public method | RPC |
Public method | Send(ErlPid, IErlObject) | Send a message to a remote ErlPid, representing either another ErlMbox or an Erlang process
Public method | Send(ErlPid, ErlAtom, IErlObject) | Send a message to a named mailbox on local node
Public method | Send(ErlPid, ErlAtom, ErlAtom, IErlObject) | Send a message to a named mailbox on a given remote node
Protected method | SetNodeName | (Inherited from ErlAbstractNode.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | ToString | (Inherited from ErlAbstractNode.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitAny( ErlMbox ) |
Public method | WaitAny(Int32, ErlMbox ) |
Public method | WaitAny( ErlMbox , Int32) | Wait for arrival of messages in any one of the given mailboxes
Public method | WaitAny(IEnumerable ErlMbox , Int32) |
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ErlLocalNode Class
NFX.Erlang Namespace


ErlLocalNode.Add Method

ErlLocalNode Add Method NFX Class Library

Add a connection to collection

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Add(
    ErlConnection conn
)
public bool Add(
    ErlConnection conn
)
Public Function Add (
    conn As ErlConnection
) As Boolean
Public Function Add (
    conn As ErlConnection
) As Boolean
public:
bool Add(
    ErlConnection^ conn
)
public:
bool Add(
    ErlConnection^ conn
)
member Add :
        conn : ErlConnection -> bool
member Add :
        conn : ErlConnection -> bool

Parameters

conn
Type: NFX.Erlang ErlConnection

Return Value

Type: Online Boolean
Returns false if this connection was already previously added
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.ApplicationFinishAfterCleanup Method

ErlLocalNode ApplicationFinishAfterCleanup Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ApplicationFinishAfterCleanup(
    IApplication application
)
public void ApplicationFinishAfterCleanup(
    IApplication application
)
Public Sub ApplicationFinishAfterCleanup (
    application As IApplication
)
Public Sub ApplicationFinishAfterCleanup (
    application As IApplication
)
public:
virtual void ApplicationFinishAfterCleanup(
    IApplication^ application
) sealed
public:
virtual void ApplicationFinishAfterCleanup(
    IApplication^ application
) sealed
abstract ApplicationFinishAfterCleanup :
        application : IApplication -> unit
override ApplicationFinishAfterCleanup :
        application : IApplication -> unit
abstract ApplicationFinishAfterCleanup :
        application : IApplication -> unit
override ApplicationFinishAfterCleanup :
        application : IApplication -> unit

Parameters

application
Type: NFX.ApplicationModel IApplication

Implements

IApplicationFinishNotifiable ApplicationFinishAfterCleanup(IApplication)
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.ApplicationFinishBeforeCleanup Method

ErlLocalNode ApplicationFinishBeforeCleanup Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ApplicationFinishBeforeCleanup(
    IApplication application
)
public void ApplicationFinishBeforeCleanup(
    IApplication application
)
Public Sub ApplicationFinishBeforeCleanup (
    application As IApplication
)
Public Sub ApplicationFinishBeforeCleanup (
    application As IApplication
)
public:
virtual void ApplicationFinishBeforeCleanup(
    IApplication^ application
) sealed
public:
virtual void ApplicationFinishBeforeCleanup(
    IApplication^ application
) sealed
abstract ApplicationFinishBeforeCleanup :
        application : IApplication -> unit
override ApplicationFinishBeforeCleanup :
        application : IApplication -> unit
abstract ApplicationFinishBeforeCleanup :
        application : IApplication -> unit
override ApplicationFinishBeforeCleanup :
        application : IApplication -> unit

Parameters

application
Type: NFX.ApplicationModel IApplication

Implements

IApplicationFinishNotifiable ApplicationFinishBeforeCleanup(IApplication)
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.BreakLinks Method

ErlLocalNode BreakLinks Method NFX Class Library

Break links of all pids linked to pids on the fromNode node

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void BreakLinks(
    ErlAtom fromNode,
    IErlObject reason
)
internal void BreakLinks(
    ErlAtom fromNode,
    IErlObject reason
)
Friend Sub BreakLinks (
    fromNode As ErlAtom,
    reason As IErlObject
)
Friend Sub BreakLinks (
    fromNode As ErlAtom,
    reason As IErlObject
)
internal:
void BreakLinks(
    ErlAtom fromNode,
    IErlObject^ reason
)
internal:
void BreakLinks(
    ErlAtom fromNode,
    IErlObject^ reason
)
internal member BreakLinks :
        fromNode : ErlAtom *
        reason : IErlObject -> unit
internal member BreakLinks :
        fromNode : ErlAtom *
        reason : IErlObject -> unit

Parameters

fromNode
Type: NFX.Erlang ErlAtom
reason
Type: NFX.Erlang IErlObject
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.CloseMbox Method

ErlLocalNode CloseMbox Method NFX Class Library

Close the given mailbox

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CloseMbox(
    ErlMbox mbox
)
public void CloseMbox(
    ErlMbox mbox
)
Public Sub CloseMbox (
    mbox As ErlMbox
)
Public Sub CloseMbox (
    mbox As ErlMbox
)
public:
void CloseMbox(
    ErlMbox^ mbox
)
public:
void CloseMbox(
    ErlMbox^ mbox
)
member CloseMbox :
        mbox : ErlMbox -> unit
member CloseMbox :
        mbox : ErlMbox -> unit

Parameters

mbox
Type: NFX.Erlang ErlMbox
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.Connection Method

ErlLocalNode Connection Method NFX Class Library

Overload List
 | Name | Description
Public method | Connection(String, Nullable ErlAtom ) |
Public method | Connection(ErlAtom, Nullable ErlAtom ) |
Protected method | Connection(String, IConfigSectionNode, Nullable ErlAtom ) |
Back to Top
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.Connection Method (String, Nullable(ErlAtom))

ErlLocalNode Connection Method (String, Nullable ErlAtom ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlConnection Connection(
    string node,
    Nullable<ErlAtom> cookie = null
)
public ErlConnection Connection(
    string node,
    Nullable<ErlAtom> cookie = null
)
Public Function Connection (
    node As String,
    Optional cookie As Nullable(Of ErlAtom) = Nothing
) As ErlConnection
Public Function Connection (
    node As String,
    Optional cookie As Nullable(Of ErlAtom) = Nothing
) As ErlConnection
public:
ErlConnection^ Connection(
    String^ node,
    Nullable<ErlAtom> cookie = nullptr
)
public:
ErlConnection^ Connection(
    String^ node,
    Nullable<ErlAtom> cookie = nullptr
)
member Connection :
        node : string *
        ?cookie : Nullable<ErlAtom>
(* Defaults:
        let _cookie = defaultArg cookie null
*)
-> ErlConnection
member Connection :
        node : string *
        ?cookie : Nullable<ErlAtom>
(* Defaults:
        let _cookie = defaultArg cookie null
*)
-> ErlConnection

Parameters

node
Type: Online System String
cookie (Optional)
Type: Online System Nullable ErlAtom

Return Value

Type: ErlConnection
See Also
ErlLocalNode Class
ErlLocalNode Members
Connection Overload
NFX.Erlang Namespace


ErlLocalNode.Connection Method (ErlAtom, Nullable(ErlAtom))

ErlLocalNode Connection Method (ErlAtom, Nullable ErlAtom ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlConnection Connection(
    ErlAtom toNode,
    Nullable<ErlAtom> cookie = null
)
public ErlConnection Connection(
    ErlAtom toNode,
    Nullable<ErlAtom> cookie = null
)
Public Function Connection (
    toNode As ErlAtom,
    Optional cookie As Nullable(Of ErlAtom) = Nothing
) As ErlConnection
Public Function Connection (
    toNode As ErlAtom,
    Optional cookie As Nullable(Of ErlAtom) = Nothing
) As ErlConnection
public:
ErlConnection^ Connection(
    ErlAtom toNode,
    Nullable<ErlAtom> cookie = nullptr
)
public:
ErlConnection^ Connection(
    ErlAtom toNode,
    Nullable<ErlAtom> cookie = nullptr
)
member Connection :
        toNode : ErlAtom *
        ?cookie : Nullable<ErlAtom>
(* Defaults:
        let _cookie = defaultArg cookie null
*)
-> ErlConnection
member Connection :
        toNode : ErlAtom *
        ?cookie : Nullable<ErlAtom>
(* Defaults:
        let _cookie = defaultArg cookie null
*)
-> ErlConnection

Parameters

toNode
Type: NFX.Erlang ErlAtom
cookie (Optional)
Type: Online System Nullable ErlAtom

Return Value

Type: ErlConnection
See Also
ErlLocalNode Class
ErlLocalNode Members
Connection Overload
NFX.Erlang Namespace


ErlLocalNode.Connection Method (String, IConfigSectionNode, Nullable(ErlAtom))

ErlLocalNode Connection Method (String, IConfigSectionNode, Nullable ErlAtom ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ErlConnection Connection(
    string toNode,
    IConfigSectionNode config,
    Nullable<ErlAtom> cookie = null
)
internal ErlConnection Connection(
    string toNode,
    IConfigSectionNode config,
    Nullable<ErlAtom> cookie = null
)
Friend Function Connection (
    toNode As String,
    config As IConfigSectionNode,
    Optional cookie As Nullable(Of ErlAtom) = Nothing
) As ErlConnection
Friend Function Connection (
    toNode As String,
    config As IConfigSectionNode,
    Optional cookie As Nullable(Of ErlAtom) = Nothing
) As ErlConnection
internal:
ErlConnection^ Connection(
    String^ toNode,
    IConfigSectionNode^ config,
    Nullable<ErlAtom> cookie = nullptr
)
internal:
ErlConnection^ Connection(
    String^ toNode,
    IConfigSectionNode^ config,
    Nullable<ErlAtom> cookie = nullptr
)
internal member Connection :
        toNode : string *
        config : IConfigSectionNode *
        ?cookie : Nullable<ErlAtom>
(* Defaults:
        let _cookie = defaultArg cookie null
*)
-> ErlConnection
internal member Connection :
        toNode : string *
        config : IConfigSectionNode *
        ?cookie : Nullable<ErlAtom>
(* Defaults:
        let _cookie = defaultArg cookie null
*)
-> ErlConnection

Parameters

toNode
Type: Online System String
config
Type: NFX.Environment IConfigSectionNode
cookie (Optional)
Type: Online System Nullable ErlAtom

Return Value

Type: ErlConnection
See Also
ErlLocalNode Class
ErlLocalNode Members
Connection Overload
NFX.Erlang Namespace


ErlLocalNode.CreateMbox Method

ErlLocalNode CreateMbox Method NFX Class Library

Overload List
 | Name | Description
Public method | CreateMbox(String) | Create a new named mailbox (emulates spawning a new Pid)
Public method | CreateMbox(ErlAtom) | Create a new named mailbox (emulates spawning a new Pid)
Back to Top
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.CreateMbox Method (String)

ErlLocalNode CreateMbox Method (String) NFX Class Library

Create a new named mailbox (emulates spawning a new Pid)

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlMbox CreateMbox(
    string name = null
)
public ErlMbox CreateMbox(
    string name = null
)
Public Function CreateMbox (
    Optional name As String = Nothing
) As ErlMbox
Public Function CreateMbox (
    Optional name As String = Nothing
) As ErlMbox
public:
ErlMbox^ CreateMbox(
    String^ name = nullptr
)
public:
ErlMbox^ CreateMbox(
    String^ name = nullptr
)
member CreateMbox :
        ?name : string
(* Defaults:
        let _name = defaultArg name null
*)
-> ErlMbox
member CreateMbox :
        ?name : string
(* Defaults:
        let _name = defaultArg name null
*)
-> ErlMbox

Parameters

name (Optional)
Type: Online System String

Return Value

Type: ErlMbox
See Also
ErlLocalNode Class
ErlLocalNode Members
CreateMbox Overload
NFX.Erlang Namespace


ErlLocalNode.CreateMbox Method (ErlAtom)

ErlLocalNode CreateMbox Method (ErlAtom) NFX Class Library

Create a new named mailbox (emulates spawning a new Pid)

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlMbox CreateMbox(
    ErlAtom name
)
public ErlMbox CreateMbox(
    ErlAtom name
)
Public Function CreateMbox (
    name As ErlAtom
) As ErlMbox
Public Function CreateMbox (
    name As ErlAtom
) As ErlMbox
public:
ErlMbox^ CreateMbox(
    ErlAtom name
)
public:
ErlMbox^ CreateMbox(
    ErlAtom name
)
member CreateMbox :
        name : ErlAtom -> ErlMbox
member CreateMbox :
        name : ErlAtom -> ErlMbox

Parameters

name
Type: NFX.Erlang ErlAtom

Return Value

Type: ErlMbox
See Also
ErlLocalNode Class
ErlLocalNode Members
CreateMbox Overload
NFX.Erlang Namespace


ErlLocalNode.CreateNullPid Method

ErlLocalNode CreateNullPid Method NFX Class Library

Create an Erlang ErlPid that belongs to current node

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static ErlPid CreateNullPid(
    ErlAtom node
)
internal static ErlPid CreateNullPid(
    ErlAtom node
)
Friend Shared Function CreateNullPid (
    node As ErlAtom
) As ErlPid
Friend Shared Function CreateNullPid (
    node As ErlAtom
) As ErlPid
internal:
static ErlPid CreateNullPid(
    ErlAtom node
)
internal:
static ErlPid CreateNullPid(
    ErlAtom node
)
internal static member CreateNullPid :
        node : ErlAtom -> ErlPid
internal static member CreateNullPid :
        node : ErlAtom -> ErlPid

Parameters

node
Type: NFX.Erlang ErlAtom

Return Value

Type: ErlPid
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.CreatePid Method

ErlLocalNode CreatePid Method NFX Class Library

Create an Erlang ErlPid. Erlang pids are based upon some node specific information; this method creates a pid using the information in this node. Each call to this method produces a unique pid

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ErlPid CreatePid()
internal ErlPid CreatePid()
Friend Function CreatePid As ErlPid
Friend Function CreatePid As ErlPid
internal:
ErlPid CreatePid()
internal:
ErlPid CreatePid()
internal member CreatePid : unit -> ErlPid
internal member CreatePid : unit -> ErlPid

Return Value

Type: ErlPid
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.CreatePort Method

ErlLocalNode CreatePort Method NFX Class Library

Create an Erlang ErlPort. Erlang ports are based upon some node specific information; this method creates a port using the information in this node. Each call to this method produces a unique port. It may not be meaningful to create a port in a non-Erlang environment, but this method is provided for completeness

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ErlPort CreatePort()
internal ErlPort CreatePort()
Friend Function CreatePort As ErlPort
Friend Function CreatePort As ErlPort
internal:
ErlPort CreatePort()
internal:
ErlPort CreatePort()
internal member CreatePort : unit -> ErlPort
internal member CreatePort : unit -> ErlPort

Return Value

Type: ErlPort
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.CreateRef Method

ErlLocalNode CreateRef Method NFX Class Library

Create an Erlang {@link Ref reference}. Erlang references are based upon some node specific information; this method creates a reference using the information in this node. Each call to this method produces a unique reference

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlRef CreateRef()
public ErlRef CreateRef()
Public Function CreateRef As ErlRef
Public Function CreateRef As ErlRef
public:
ErlRef CreateRef()
public:
ErlRef CreateRef()
member CreateRef : unit -> ErlRef
member CreateRef : unit -> ErlRef

Return Value

Type: ErlRef
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.Deliver Method

ErlLocalNode Deliver Method NFX Class Library

Overload List
 | Name | Description
Protected method | Deliver(ErlConnectionException) |
Protected method | Deliver(ErlMsg) |
Protected method | Deliver(ErlAtom, ErlMsg) |
Back to Top
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.Deliver Method (ErlConnectionException)

ErlLocalNode Deliver Method (ErlConnectionException) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal bool Deliver(
    ErlConnectionException e
)
internal bool Deliver(
    ErlConnectionException e
)
Friend Function Deliver (
    e As ErlConnectionException
) As Boolean
Friend Function Deliver (
    e As ErlConnectionException
) As Boolean
internal:
bool Deliver(
    ErlConnectionException^ e
)
internal:
bool Deliver(
    ErlConnectionException^ e
)
internal member Deliver :
        e : ErlConnectionException -> bool
internal member Deliver :
        e : ErlConnectionException -> bool

Parameters

e
Type: NFX.Erlang ErlConnectionException

Return Value

Type: Online Boolean
See Also
ErlLocalNode Class
ErlLocalNode Members
Deliver Overload
NFX.Erlang Namespace


ErlLocalNode.Deliver Method (ErlMsg)

ErlLocalNode Deliver Method (ErlMsg) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal bool Deliver(
    ErlMsg msg
)
internal bool Deliver(
    ErlMsg msg
)
Friend Function Deliver (
    msg As ErlMsg
) As Boolean
Friend Function Deliver (
    msg As ErlMsg
) As Boolean
internal:
bool Deliver(
    ErlMsg^ msg
)
internal:
bool Deliver(
    ErlMsg^ msg
)
internal member Deliver :
        msg : ErlMsg -> bool
internal member Deliver :
        msg : ErlMsg -> bool

Parameters

msg
Type: NFX.Erlang ErlMsg

Return Value

Type: Online Boolean
See Also
ErlLocalNode Class
ErlLocalNode Members
Deliver Overload
NFX.Erlang Namespace


ErlLocalNode.Deliver Method (ErlAtom, ErlMsg)

ErlLocalNode Deliver Method (ErlAtom, ErlMsg) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal bool Deliver(
    ErlAtom node,
    ErlMsg msg
)
internal bool Deliver(
    ErlAtom node,
    ErlMsg msg
)
Friend Function Deliver (
    node As ErlAtom,
    msg As ErlMsg
) As Boolean
Friend Function Deliver (
    node As ErlAtom,
    msg As ErlMsg
) As Boolean
internal:
bool Deliver(
    ErlAtom node,
    ErlMsg^ msg
)
internal:
bool Deliver(
    ErlAtom node,
    ErlMsg^ msg
)
internal member Deliver :
        node : ErlAtom *
        msg : ErlMsg -> bool
internal member Deliver :
        node : ErlAtom *
        msg : ErlMsg -> bool

Parameters

node
Type: NFX.Erlang ErlAtom
msg
Type: NFX.Erlang ErlMsg

Return Value

Type: Online Boolean
See Also
ErlLocalNode Class
ErlLocalNode Members
Deliver Overload
NFX.Erlang Namespace


ErlLocalNode.Disconnect Method

ErlLocalNode Disconnect Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Disconnect(
    string fromNode
)
public bool Disconnect(
    string fromNode
)
Public Function Disconnect (
    fromNode As String
) As Boolean
Public Function Disconnect (
    fromNode As String
) As Boolean
public:
bool Disconnect(
    String^ fromNode
)
public:
bool Disconnect(
    String^ fromNode
)
member Disconnect :
        fromNode : string -> bool
member Disconnect :
        fromNode : string -> bool

Parameters

fromNode
Type: Online System String

Return Value

Type: Online Boolean
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.DoConfigure Method

ErlLocalNode DoConfigure Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.DoStart Method

ErlLocalNode DoStart Method NFX Class Library

Start current node. This optionally creates a socket listener and I/O server

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.DoWaitForCompleteStop Method

ErlLocalNode DoWaitForCompleteStop Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.FindMbox Method

ErlLocalNode FindMbox Method NFX Class Library

Determine the mailbox corresponding to a registered name on this ErlLocalNode

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlMbox FindMbox(
    ErlAtom name
)
public ErlMbox FindMbox(
    ErlAtom name
)
Public Function FindMbox (
    name As ErlAtom
) As ErlMbox
Public Function FindMbox (
    name As ErlAtom
) As ErlMbox
public:
ErlMbox^ FindMbox(
    ErlAtom name
)
public:
ErlMbox^ FindMbox(
    ErlAtom name
)
member FindMbox :
        name : ErlAtom -> ErlMbox
member FindMbox :
        name : ErlAtom -> ErlMbox

Parameters

name
Type: NFX.Erlang ErlAtom

Return Value

Type: ErlMbox
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.MakeLocalNodeForThisAppOnThisHost Method

ErlLocalNode MakeLocalNodeForThisAppOnThisHost Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Makes local node name based on app id and local host name

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string MakeLocalNodeForThisAppOnThisHost()
public static string MakeLocalNodeForThisAppOnThisHost()
Public Shared Function MakeLocalNodeForThisAppOnThisHost As String
Public Shared Function MakeLocalNodeForThisAppOnThisHost As String
public:
static String^ MakeLocalNodeForThisAppOnThisHost()
public:
static String^ MakeLocalNodeForThisAppOnThisHost()
static member MakeLocalNodeForThisAppOnThisHost : unit -> string
static member MakeLocalNodeForThisAppOnThisHost : unit -> string

Return Value

Type: Online String
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.OnConnectAttempt Method

ErlLocalNode OnConnectAttempt Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual void OnConnectAttempt(
    ErlAtom node,
    Direction dir,
    Object info
)
protected internal virtual void OnConnectAttempt(
    ErlAtom node,
    Direction dir,
    Object info
)
Protected Friend Overridable Sub OnConnectAttempt (
    node As ErlAtom,
    dir As Direction,
    info As Object
)
Protected Friend Overridable Sub OnConnectAttempt (
    node As ErlAtom,
    dir As Direction,
    info As Object
)
protected public:
virtual void OnConnectAttempt(
    ErlAtom node,
    Direction dir,
    Object^ info
)
protected public:
virtual void OnConnectAttempt(
    ErlAtom node,
    Direction dir,
    Object^ info
)
abstract OnConnectAttempt :
        node : ErlAtom *
        dir : Direction *
        info : Object -> unit
override OnConnectAttempt :
        node : ErlAtom *
        dir : Direction *
        info : Object -> unit
abstract OnConnectAttempt :
        node : ErlAtom *
        dir : Direction *
        info : Object -> unit
override OnConnectAttempt :
        node : ErlAtom *
        dir : Direction *
        info : Object -> unit

Parameters

node
Type: NFX.Erlang ErlAtom
dir
Type: NFX.Erlang Direction
info
Type: Online System Object
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.OnEpmdFailedConnectAttempt Method

ErlLocalNode OnEpmdFailedConnectAttempt Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal void OnEpmdFailedConnectAttempt(
    ErlAtom node,
    Object info
)
protected internal void OnEpmdFailedConnectAttempt(
    ErlAtom node,
    Object info
)
Protected Friend Sub OnEpmdFailedConnectAttempt (
    node As ErlAtom,
    info As Object
)
Protected Friend Sub OnEpmdFailedConnectAttempt (
    node As ErlAtom,
    info As Object
)
protected public:
void OnEpmdFailedConnectAttempt(
    ErlAtom node,
    Object^ info
)
protected public:
void OnEpmdFailedConnectAttempt(
    ErlAtom node,
    Object^ info
)
member OnEpmdFailedConnectAttempt :
        node : ErlAtom *
        info : Object -> unit
member OnEpmdFailedConnectAttempt :
        node : ErlAtom *
        info : Object -> unit

Parameters

node
Type: NFX.Erlang ErlAtom
info
Type: Online System Object
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.OnIoOutput Method

ErlLocalNode OnIoOutput Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual void OnIoOutput(
    ErlAtom encoding,
    IErlObject output
)
protected internal virtual void OnIoOutput(
    ErlAtom encoding,
    IErlObject output
)
Protected Friend Overridable Sub OnIoOutput (
    encoding As ErlAtom,
    output As IErlObject
)
Protected Friend Overridable Sub OnIoOutput (
    encoding As ErlAtom,
    output As IErlObject
)
protected public:
virtual void OnIoOutput(
    ErlAtom encoding,
    IErlObject^ output
)
protected public:
virtual void OnIoOutput(
    ErlAtom encoding,
    IErlObject^ output
)
abstract OnIoOutput :
        encoding : ErlAtom *
        output : IErlObject -> unit
override OnIoOutput :
        encoding : ErlAtom *
        output : IErlObject -> unit
abstract OnIoOutput :
        encoding : ErlAtom *
        output : IErlObject -> unit
override OnIoOutput :
        encoding : ErlAtom *
        output : IErlObject -> unit

Parameters

encoding
Type: NFX.Erlang ErlAtom
output
Type: NFX.Erlang IErlObject
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.OnNodeStatusChange Method

ErlLocalNode OnNodeStatusChange Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual void OnNodeStatusChange(
    ErlAtom node,
    bool up,
    Object info
)
protected internal virtual void OnNodeStatusChange(
    ErlAtom node,
    bool up,
    Object info
)
Protected Friend Overridable Sub OnNodeStatusChange (
    node As ErlAtom,
    up As Boolean,
    info As Object
)
Protected Friend Overridable Sub OnNodeStatusChange (
    node As ErlAtom,
    up As Boolean,
    info As Object
)
protected public:
virtual void OnNodeStatusChange(
    ErlAtom node,
    bool up,
    Object^ info
)
protected public:
virtual void OnNodeStatusChange(
    ErlAtom node,
    bool up,
    Object^ info
)
abstract OnNodeStatusChange :
        node : ErlAtom *
        up : bool *
        info : Object -> unit
override OnNodeStatusChange :
        node : ErlAtom *
        up : bool *
        info : Object -> unit
abstract OnNodeStatusChange :
        node : ErlAtom *
        up : bool *
        info : Object -> unit
override OnNodeStatusChange :
        node : ErlAtom *
        up : bool *
        info : Object -> unit

Parameters

node
Type: NFX.Erlang ErlAtom
up
Type: Online System Boolean
info
Type: Online System Object
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.OnReadWrite Method

ErlLocalNode OnReadWrite Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual void OnReadWrite(
    ErlAbstractConnection conn,
    Direction dir,
    int lastBytes,
    long totalBytes,
    long totalMsgs
)
protected internal virtual void OnReadWrite(
    ErlAbstractConnection conn,
    Direction dir,
    int lastBytes,
    long totalBytes,
    long totalMsgs
)
Protected Friend Overridable Sub OnReadWrite (
    conn As ErlAbstractConnection,
    dir As Direction,
    lastBytes As Integer,
    totalBytes As Long,
    totalMsgs As Long
)
Protected Friend Overridable Sub OnReadWrite (
    conn As ErlAbstractConnection,
    dir As Direction,
    lastBytes As Integer,
    totalBytes As Long,
    totalMsgs As Long
)
protected public:
virtual void OnReadWrite(
    ErlAbstractConnection^ conn,
    Direction dir,
    int lastBytes,
    long long totalBytes,
    long long totalMsgs
)
protected public:
virtual void OnReadWrite(
    ErlAbstractConnection^ conn,
    Direction dir,
    int lastBytes,
    long long totalBytes,
    long long totalMsgs
)
abstract OnReadWrite :
        conn : ErlAbstractConnection *
        dir : Direction *
        lastBytes : int *
        totalBytes : int64 *
        totalMsgs : int64 -> unit
override OnReadWrite :
        conn : ErlAbstractConnection *
        dir : Direction *
        lastBytes : int *
        totalBytes : int64 *
        totalMsgs : int64 -> unit
abstract OnReadWrite :
        conn : ErlAbstractConnection *
        dir : Direction *
        lastBytes : int *
        totalBytes : int64 *
        totalMsgs : int64 -> unit
override OnReadWrite :
        conn : ErlAbstractConnection *
        dir : Direction *
        lastBytes : int *
        totalBytes : int64 *
        totalMsgs : int64 -> unit

Parameters

conn
Type: NFX.Erlang ErlAbstractConnection
dir
Type: NFX.Erlang Direction
lastBytes
Type: Online System Int32
totalBytes
Type: Online System Int64
totalMsgs
Type: Online System Int64
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.OnTrace Method

ErlLocalNode OnTrace Method NFX Class Library

Overload List
 | Name | Description
Protected method | OnTrace(ErlTraceLevel, Direction, Func String , String, Int32) |
Protected method | OnTrace(ErlTraceLevel, Direction, String, String, Int32) |
Back to Top
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.OnTrace Method (ErlTraceLevel, Direction, Func(String), String, Int32)

ErlLocalNode OnTrace Method (ErlTraceLevel, Direction, Func String , String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual void OnTrace(
    ErlTraceLevel type,
    Direction dir,
    Func<string> msgFunc,
    string file = null,
    int line = 0
)
protected internal virtual void OnTrace(
    ErlTraceLevel type,
    Direction dir,
    Func<string> msgFunc,
    string file = null,
    int line = 0
)
Protected Friend Overridable Sub OnTrace (
    type As ErlTraceLevel,
    dir As Direction,
    msgFunc As Func(Of String),
    Optional file As String = Nothing,
    Optional line As Integer = 0
)
Protected Friend Overridable Sub OnTrace (
    type As ErlTraceLevel,
    dir As Direction,
    msgFunc As Func(Of String),
    Optional file As String = Nothing,
    Optional line As Integer = 0
)
protected public:
virtual void OnTrace(
    ErlTraceLevel type,
    Direction dir,
    Func<String^>^ msgFunc,
    String^ file = nullptr,
    int line = 0
)
protected public:
virtual void OnTrace(
    ErlTraceLevel type,
    Direction dir,
    Func<String^>^ msgFunc,
    String^ file = nullptr,
    int line = 0
)
abstract OnTrace :
        type : ErlTraceLevel *
        dir : Direction *
        msgFunc : Func<string> *
        ?file : string *
        ?line : int
(* Defaults:
        let _file = defaultArg file null
        let _line = defaultArg line 0
*)
-> unit
override OnTrace :
        type : ErlTraceLevel *
        dir : Direction *
        msgFunc : Func<string> *
        ?file : string *
        ?line : int
(* Defaults:
        let _file = defaultArg file null
        let _line = defaultArg line 0
*)
-> unit
abstract OnTrace :
        type : ErlTraceLevel *
        dir : Direction *
        msgFunc : Func<string> *
        ?file : string *
        ?line : int
(* Defaults:
        let _file = defaultArg file null
        let _line = defaultArg line 0
*)
-> unit
override OnTrace :
        type : ErlTraceLevel *
        dir : Direction *
        msgFunc : Func<string> *
        ?file : string *
        ?line : int
(* Defaults:
        let _file = defaultArg file null
        let _line = defaultArg line 0
*)
-> unit

Parameters

type
Type: NFX.Erlang ErlTraceLevel
dir
Type: NFX.Erlang Direction
msgFunc
Type: Online System Func Online String
file (Optional)
Type: Online System String
line (Optional)
Type: Online System Int32
See Also
ErlLocalNode Class
ErlLocalNode Members
OnTrace Overload
NFX.Erlang Namespace


ErlLocalNode.OnTrace Method (ErlTraceLevel, Direction, String, String, Int32)

ErlLocalNode OnTrace Method (ErlTraceLevel, Direction, String, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal void OnTrace(
    ErlTraceLevel type,
    Direction dir,
    string msg,
    string file = null,
    int line = 0
)
protected internal void OnTrace(
    ErlTraceLevel type,
    Direction dir,
    string msg,
    string file = null,
    int line = 0
)
Protected Friend Sub OnTrace (
    type As ErlTraceLevel,
    dir As Direction,
    msg As String,
    Optional file As String = Nothing,
    Optional line As Integer = 0
)
Protected Friend Sub OnTrace (
    type As ErlTraceLevel,
    dir As Direction,
    msg As String,
    Optional file As String = Nothing,
    Optional line As Integer = 0
)
protected public:
void OnTrace(
    ErlTraceLevel type,
    Direction dir,
    String^ msg,
    String^ file = nullptr,
    int line = 0
)
protected public:
void OnTrace(
    ErlTraceLevel type,
    Direction dir,
    String^ msg,
    String^ file = nullptr,
    int line = 0
)
member OnTrace :
        type : ErlTraceLevel *
        dir : Direction *
        msg : string *
        ?file : string *
        ?line : int
(* Defaults:
        let _file = defaultArg file null
        let _line = defaultArg line 0
*)
-> unit
member OnTrace :
        type : ErlTraceLevel *
        dir : Direction *
        msg : string *
        ?file : string *
        ?line : int
(* Defaults:
        let _file = defaultArg file null
        let _line = defaultArg line 0
*)
-> unit

Parameters

type
Type: NFX.Erlang ErlTraceLevel
dir
Type: NFX.Erlang Direction
msg
Type: Online System String
file (Optional)
Type: Online System String
line (Optional)
Type: Online System Int32
See Also
ErlLocalNode Class
ErlLocalNode Members
OnTrace Overload
NFX.Erlang Namespace


ErlLocalNode.OnTraceCore Method

ErlLocalNode OnTraceCore Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void OnTraceCore(
    ErlTraceLevel type,
    Direction dir,
    string msg,
    string file,
    int line
)
protected virtual void OnTraceCore(
    ErlTraceLevel type,
    Direction dir,
    string msg,
    string file,
    int line
)
Protected Overridable Sub OnTraceCore (
    type As ErlTraceLevel,
    dir As Direction,
    msg As String,
    file As String,
    line As Integer
)
Protected Overridable Sub OnTraceCore (
    type As ErlTraceLevel,
    dir As Direction,
    msg As String,
    file As String,
    line As Integer
)
protected:
virtual void OnTraceCore(
    ErlTraceLevel type,
    Direction dir,
    String^ msg,
    String^ file,
    int line
)
protected:
virtual void OnTraceCore(
    ErlTraceLevel type,
    Direction dir,
    String^ msg,
    String^ file,
    int line
)
abstract OnTraceCore :
        type : ErlTraceLevel *
        dir : Direction *
        msg : string *
        file : string *
        line : int -> unit
override OnTraceCore :
        type : ErlTraceLevel *
        dir : Direction *
        msg : string *
        file : string *
        line : int -> unit
abstract OnTraceCore :
        type : ErlTraceLevel *
        dir : Direction *
        msg : string *
        file : string *
        line : int -> unit
override OnTraceCore :
        type : ErlTraceLevel *
        dir : Direction *
        msg : string *
        file : string *
        line : int -> unit

Parameters

type
Type: NFX.Erlang ErlTraceLevel
dir
Type: NFX.Erlang Direction
msg
Type: Online System String
file
Type: Online System String
line
Type: Online System Int32
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.OnUnhandledMsg Method

ErlLocalNode OnUnhandledMsg Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual void OnUnhandledMsg(
    ErlConnection conn,
    ErlMsg msg,
    string file = null,
    int line = 0
)
protected internal virtual void OnUnhandledMsg(
    ErlConnection conn,
    ErlMsg msg,
    string file = null,
    int line = 0
)
Protected Friend Overridable Sub OnUnhandledMsg (
    conn As ErlConnection,
    msg As ErlMsg,
    Optional file As String = Nothing,
    Optional line As Integer = 0
)
Protected Friend Overridable Sub OnUnhandledMsg (
    conn As ErlConnection,
    msg As ErlMsg,
    Optional file As String = Nothing,
    Optional line As Integer = 0
)
protected public:
virtual void OnUnhandledMsg(
    ErlConnection^ conn,
    ErlMsg^ msg,
    String^ file = nullptr,
    int line = 0
)
protected public:
virtual void OnUnhandledMsg(
    ErlConnection^ conn,
    ErlMsg^ msg,
    String^ file = nullptr,
    int line = 0
)
abstract OnUnhandledMsg :
        conn : ErlConnection *
        msg : ErlMsg *
        ?file : string *
        ?line : int
(* Defaults:
        let _file = defaultArg file null
        let _line = defaultArg line 0
*)
-> unit
override OnUnhandledMsg :
        conn : ErlConnection *
        msg : ErlMsg *
        ?file : string *
        ?line : int
(* Defaults:
        let _file = defaultArg file null
        let _line = defaultArg line 0
*)
-> unit
abstract OnUnhandledMsg :
        conn : ErlConnection *
        msg : ErlMsg *
        ?file : string *
        ?line : int
(* Defaults:
        let _file = defaultArg file null
        let _line = defaultArg line 0
*)
-> unit
override OnUnhandledMsg :
        conn : ErlConnection *
        msg : ErlMsg *
        ?file : string *
        ?line : int
(* Defaults:
        let _file = defaultArg file null
        let _line = defaultArg line 0
*)
-> unit

Parameters

conn
Type: NFX.Erlang ErlConnection
msg
Type: NFX.Erlang ErlMsg
file (Optional)
Type: Online System String
line (Optional)
Type: Online System Int32
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.RemoteNodeConfig Method

ErlLocalNode RemoteNodeConfig Method NFX Class Library

Get configuration settings for a given remote node

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigSectionNode RemoteNodeConfig(
    string remoteNodeName
)
public ConfigSectionNode RemoteNodeConfig(
    string remoteNodeName
)
Public Function RemoteNodeConfig (
    remoteNodeName As String
) As ConfigSectionNode
Public Function RemoteNodeConfig (
    remoteNodeName As String
) As ConfigSectionNode
public:
ConfigSectionNode^ RemoteNodeConfig(
    String^ remoteNodeName
)
public:
ConfigSectionNode^ RemoteNodeConfig(
    String^ remoteNodeName
)
member RemoteNodeConfig :
        remoteNodeName : string -> ConfigSectionNode
member RemoteNodeConfig :
        remoteNodeName : string -> ConfigSectionNode

Parameters

remoteNodeName
Type: Online System String

Return Value

Type: ConfigSectionNode
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.Remove Method

ErlLocalNode Remove Method NFX Class Library

Remove a connection from collection

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Remove(
    ErlConnection conn
)
public void Remove(
    ErlConnection conn
)
Public Sub Remove (
    conn As ErlConnection
)
Public Sub Remove (
    conn As ErlConnection
)
public:
void Remove(
    ErlConnection^ conn
)
public:
void Remove(
    ErlConnection^ conn
)
member Remove :
        conn : ErlConnection -> unit
member Remove :
        conn : ErlConnection -> unit

Parameters

conn
Type: NFX.Erlang ErlConnection
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.RPC Method

ErlLocalNode RPC Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject RPC(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList args,
    int timeout
)
public IErlObject RPC(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList args,
    int timeout
)
Public Function RPC (
    node As ErlAtom,
    mod As ErlAtom,
    fun As ErlAtom,
    args As ErlList,
    timeout As Integer
) As IErlObject
Public Function RPC (
    node As ErlAtom,
    mod As ErlAtom,
    fun As ErlAtom,
    args As ErlList,
    timeout As Integer
) As IErlObject
public:
IErlObject^ RPC(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList^ args,
    int timeout
)
public:
IErlObject^ RPC(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList^ args,
    int timeout
)
member RPC :
        node : ErlAtom *
        mod : ErlAtom *
        fun : ErlAtom *
        args : ErlList *
        timeout : int -> IErlObject
member RPC :
        node : ErlAtom *
        mod : ErlAtom *
        fun : ErlAtom *
        args : ErlList *
        timeout : int -> IErlObject

Parameters

node
Type: NFX.Erlang ErlAtom
mod
Type: NFX.Erlang ErlAtom
fun
Type: NFX.Erlang ErlAtom
args
Type: NFX.Erlang ErlList
timeout
Type: Online System Int32

Return Value

Type: IErlObject
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.Send Method

ErlLocalNode Send Method NFX Class Library

Overload List
 | Name | Description
Public method | Send(ErlPid, IErlObject) | Send a message to a remote ErlPid, representing either another ErlMbox or an Erlang process
Public method | Send(ErlPid, ErlAtom, IErlObject) | Send a message to a named mailbox on local node
Public method | Send(ErlPid, ErlAtom, ErlAtom, IErlObject) | Send a message to a named mailbox on a given remote node
Back to Top
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.Send Method (ErlPid, IErlObject)

ErlLocalNode Send Method (ErlPid, IErlObject) NFX Class Library

[This is preliminary documentation and is subject to change.]

Send a message to a remote ErlPid, representing either another ErlMbox or an Erlang process

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Send(
    ErlPid to,
    IErlObject msg
)
public bool Send(
    ErlPid to,
    IErlObject msg
)
Public Function Send (
    to As ErlPid,
    msg As IErlObject
) As Boolean
Public Function Send (
    to As ErlPid,
    msg As IErlObject
) As Boolean
public:
bool Send(
    ErlPid to,
    IErlObject^ msg
)
public:
bool Send(
    ErlPid to,
    IErlObject^ msg
)
member Send :
        to : ErlPid *
        msg : IErlObject -> bool
member Send :
        to : ErlPid *
        msg : IErlObject -> bool

Parameters

to
Type: NFX.Erlang ErlPid
msg
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean
true if message was sent successfully
See Also
ErlLocalNode Class
ErlLocalNode Members
Send Overload
NFX.Erlang Namespace


ErlLocalNode.Send Method (ErlPid, ErlAtom, IErlObject)

ErlLocalNode Send Method (ErlPid, ErlAtom, IErlObject) NFX Class Library

[This is preliminary documentation and is subject to change.]

Send a message to a named mailbox on local node

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Send(
    ErlPid from,
    ErlAtom toName,
    IErlObject msg
)
public bool Send(
    ErlPid from,
    ErlAtom toName,
    IErlObject msg
)
Public Function Send (
    from As ErlPid,
    toName As ErlAtom,
    msg As IErlObject
) As Boolean
Public Function Send (
    from As ErlPid,
    toName As ErlAtom,
    msg As IErlObject
) As Boolean
public:
bool Send(
    ErlPid from,
    ErlAtom toName,
    IErlObject^ msg
)
public:
bool Send(
    ErlPid from,
    ErlAtom toName,
    IErlObject^ msg
)
member Send :
        from : ErlPid *
        toName : ErlAtom *
        msg : IErlObject -> bool
member Send :
        from : ErlPid *
        toName : ErlAtom *
        msg : IErlObject -> bool

Parameters

from
Type: NFX.Erlang ErlPid
toName
Type: NFX.Erlang ErlAtom
msg
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean
See Also
ErlLocalNode Class
ErlLocalNode Members
Send Overload
NFX.Erlang Namespace


ErlLocalNode.Send Method (ErlPid, ErlAtom, ErlAtom, IErlObject)

ErlLocalNode Send Method (ErlPid, ErlAtom, ErlAtom, IErlObject) NFX Class Library

[This is preliminary documentation and is subject to change.]

Send a message to a named mailbox on a given remote node

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Send(
    ErlPid from,
    ErlAtom remoteNode,
    ErlAtom toName,
    IErlObject msg
)
public bool Send(
    ErlPid from,
    ErlAtom remoteNode,
    ErlAtom toName,
    IErlObject msg
)
Public Function Send (
    from As ErlPid,
    remoteNode As ErlAtom,
    toName As ErlAtom,
    msg As IErlObject
) As Boolean
Public Function Send (
    from As ErlPid,
    remoteNode As ErlAtom,
    toName As ErlAtom,
    msg As IErlObject
) As Boolean
public:
bool Send(
    ErlPid from,
    ErlAtom remoteNode,
    ErlAtom toName,
    IErlObject^ msg
)
public:
bool Send(
    ErlPid from,
    ErlAtom remoteNode,
    ErlAtom toName,
    IErlObject^ msg
)
member Send :
        from : ErlPid *
        remoteNode : ErlAtom *
        toName : ErlAtom *
        msg : IErlObject -> bool
member Send :
        from : ErlPid *
        remoteNode : ErlAtom *
        toName : ErlAtom *
        msg : IErlObject -> bool

Parameters

from
Type: NFX.Erlang ErlPid
remoteNode
Type: NFX.Erlang ErlAtom
toName
Type: NFX.Erlang ErlAtom
msg
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean
See Also
ErlLocalNode Class
ErlLocalNode Members
Send Overload
NFX.Erlang Namespace


ErlLocalNode.WaitAny Method

ErlLocalNode WaitAny Method NFX Class Library

Overload List
 | Name | Description
Public method | WaitAny( ErlMbox ) |
Public method | WaitAny(Int32, ErlMbox ) |
Public method | WaitAny( ErlMbox , Int32) | Wait for arrival of messages in any one of the given mailboxes
Public method | WaitAny(IEnumerable ErlMbox , Int32) |
Back to Top
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.WaitAny Method (ErlMbox[])

ErlLocalNode WaitAny Method ( ErlMbox ) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int WaitAny(
    params ErlMbox[] mboxes
)
public int WaitAny(
    params ErlMbox[] mboxes
)
Public Function WaitAny (
    ParamArray mboxes As ErlMbox()
) As Integer
Public Function WaitAny (
    ParamArray mboxes As ErlMbox()
) As Integer
public:
int WaitAny(
    ... array<ErlMbox^>^ mboxes
)
public:
int WaitAny(
    ... array<ErlMbox^>^ mboxes
)
member WaitAny :
        mboxes : ErlMbox[] -> int
member WaitAny :
        mboxes : ErlMbox[] -> int

Parameters

mboxes
Type: NFX.Erlang ErlMbox

Return Value

Type: Online Int32
See Also
ErlLocalNode Class
ErlLocalNode Members
WaitAny Overload
NFX.Erlang Namespace


ErlLocalNode.WaitAny Method (Int32, ErlMbox[])

ErlLocalNode WaitAny Method (Int32, ErlMbox ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int WaitAny(
    int msecTimeout,
    params ErlMbox[] mboxes
)
public int WaitAny(
    int msecTimeout,
    params ErlMbox[] mboxes
)
Public Function WaitAny (
    msecTimeout As Integer,
    ParamArray mboxes As ErlMbox()
) As Integer
Public Function WaitAny (
    msecTimeout As Integer,
    ParamArray mboxes As ErlMbox()
) As Integer
public:
int WaitAny(
    int msecTimeout,
    ... array<ErlMbox^>^ mboxes
)
public:
int WaitAny(
    int msecTimeout,
    ... array<ErlMbox^>^ mboxes
)
member WaitAny :
        msecTimeout : int *
        mboxes : ErlMbox[] -> int
member WaitAny :
        msecTimeout : int *
        mboxes : ErlMbox[] -> int

Parameters

msecTimeout
Type: Online System Int32
mboxes
Type: NFX.Erlang ErlMbox

Return Value

Type: Online Int32
See Also
ErlLocalNode Class
ErlLocalNode Members
WaitAny Overload
NFX.Erlang Namespace


ErlLocalNode.WaitAny Method (ErlMbox[], Int32)

ErlLocalNode WaitAny Method ( ErlMbox , Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Wait for arrival of messages in any one of the given mailboxes

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int WaitAny(
    ErlMbox[] mboxes,
    int msecTimeout = -1
)
public int WaitAny(
    ErlMbox[] mboxes,
    int msecTimeout = -1
)
Public Function WaitAny (
    mboxes As ErlMbox(),
    Optional msecTimeout As Integer = -1
) As Integer
Public Function WaitAny (
    mboxes As ErlMbox(),
    Optional msecTimeout As Integer = -1
) As Integer
public:
int WaitAny(
    array<ErlMbox^>^ mboxes,
    int msecTimeout = -1
)
public:
int WaitAny(
    array<ErlMbox^>^ mboxes,
    int msecTimeout = -1
)
member WaitAny :
        mboxes : ErlMbox[] *
        ?msecTimeout : int
(* Defaults:
        let _msecTimeout = defaultArg msecTimeout -1
*)
-> int
member WaitAny :
        mboxes : ErlMbox[] *
        ?msecTimeout : int
(* Defaults:
        let _msecTimeout = defaultArg msecTimeout -1
*)
-> int

Parameters

mboxes
Type: NFX.Erlang ErlMbox
Mailboxes to wait for messages in
msecTimeout (Optional)
Type: Online System Int32
Timeout in milliseconds

Return Value

Type: Online Int32
Index of the first non-empty mailbox or -1 on timeout
See Also
ErlLocalNode Class
ErlLocalNode Members
WaitAny Overload
NFX.Erlang Namespace


ErlLocalNode.WaitAny Method (IEnumerable(ErlMbox), Int32)

ErlLocalNode WaitAny Method (IEnumerable ErlMbox , Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int WaitAny(
    IEnumerable<ErlMbox> mboxes,
    int msecTimeout = -1
)
public int WaitAny(
    IEnumerable<ErlMbox> mboxes,
    int msecTimeout = -1
)
Public Function WaitAny (
    mboxes As IEnumerable(Of ErlMbox),
    Optional msecTimeout As Integer = -1
) As Integer
Public Function WaitAny (
    mboxes As IEnumerable(Of ErlMbox),
    Optional msecTimeout As Integer = -1
) As Integer
public:
int WaitAny(
    IEnumerable<ErlMbox^>^ mboxes,
    int msecTimeout = -1
)
public:
int WaitAny(
    IEnumerable<ErlMbox^>^ mboxes,
    int msecTimeout = -1
)
member WaitAny :
        mboxes : IEnumerable<ErlMbox> *
        ?msecTimeout : int
(* Defaults:
        let _msecTimeout = defaultArg msecTimeout -1
*)
-> int
member WaitAny :
        mboxes : IEnumerable<ErlMbox> *
        ?msecTimeout : int
(* Defaults:
        let _msecTimeout = defaultArg msecTimeout -1
*)
-> int

Parameters

mboxes
Type: Online System.Collections.Generic IEnumerable ErlMbox
msecTimeout (Optional)
Type: Online System Int32

Return Value

Type: Online Int32
See Also
ErlLocalNode Class
ErlLocalNode Members
WaitAny Overload
NFX.Erlang Namespace


ErlLocalNode Properties

ErlLocalNode Properties NFX Class Library

The ErlLocalNode type exposes the following members.
Properties
 | Name | Description
Protected property | AcceptAddressPort | Configuration Address and Port information for the listener in the "address:port" format
Public property | AcceptConnections | If true local node will start a listener
Public property | AliveName | Get the alivename part of the hostname. Nodenames are composed of two parts, an alivename and a hostname, separated by '@'. This method returns the part of the nodename preceding the '@' (Inherited from ErlAbstractNode.)
Public property | AllNodeConfigs | Configs for remote nodes
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Connections |
Public property | Cookie | Get the authorization cookie used by this node (Inherited from ErlAbstractNode.)
Public property | Creation | Contains node creation bits that facilitate Pid uniqueness upon node restart
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Protected property | DistChoose | (Inherited from ErlAbstractNode.)
Protected property | DistHigh | (Inherited from ErlAbstractNode.)
Protected property | DistLow | (Inherited from ErlAbstractNode.)
Protected property | Epmd | Get/Set the Epmd socket after publishing this nodes listen port to Epmd (Inherited from ErlAbstractNode.)
Protected property | Flags | (Inherited from ErlAbstractNode.)
Public property | GroupLeader | Mailbox for handling all I/O directed from remote nodes
Public property | Host | Get the hostname part of the nodename. Nodenames are composed of two parts, an alivename and a hostname, separated by '@'. This method returns the part of the nodename following the '@' (Inherited from ErlAbstractNode.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | LogUnhandledMsgs | Record unhandled msgs to log
Protected property | Mailboxes |
Protected property | MboxFreelist | Cache of freed mailboxes that can be reused for RPC calls
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | NodeLongName | Get the long name of this node (Inherited from ErlAbstractNode.)
Public property | NodeName | Get the name of this node (short or long depending on UseShortName) (Inherited from ErlAbstractNode.)
Protected property | Ntype | (Inherited from ErlAbstractNode.)
Public property | Port | Get the port number used by this node. For local node the value may be 0 if the node was not registered with the EPMD port mapper (Inherited from ErlAbstractNode.)
Protected property | Proto | (Inherited from ErlAbstractNode.)
Public property | RemoteNodeConfigs |
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TcpKeepAlive | (Inherited from ErlAbstractNode.)
Public property | TcpLinger | (Inherited from ErlAbstractNode.)
Public property | TcpNoDelay | (Inherited from ErlAbstractNode.)
Public property | TcpRcvBufSize | (Inherited from ErlAbstractNode.)
Public property | TcpSndBufSize | (Inherited from ErlAbstractNode.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TraceLevel | Set the trace level for this connection. Normally tracing is off by default
Public property | TraceToLog | Save trace events to log
Protected property | UseShortName | (Inherited from ErlAbstractNode.)
Back to Top
See Also
ErlLocalNode Class
NFX.Erlang Namespace


ErlLocalNode.AcceptAddressPort Property

ErlLocalNode AcceptAddressPort Property NFX Class Library

Configuration Address and Port information for the listener in the "address:port" format

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$address")]
internal string AcceptAddressPort { get; set; }
[ConfigAttribute("$address")]
internal string AcceptAddressPort { get; set; }
<ConfigAttribute("$address")>
Friend Property AcceptAddressPort As String
    Get
    Set
<ConfigAttribute("$address")>
Friend Property AcceptAddressPort As String
    Get
    Set
internal:
[ConfigAttribute(L"$address")]
property String^ AcceptAddressPort {
    String^ get ();
    void set (String^ value);
}
internal:
[ConfigAttribute(L"$address")]
property String^ AcceptAddressPort {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute("$address")>]
internal member AcceptAddressPort : string with get, set
[<ConfigAttribute("$address")>]
internal member AcceptAddressPort : string with get, set

Property Value

Type: Online String
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.AcceptConnections Property

ErlLocalNode AcceptConnections Property NFX Class Library

If true local node will start a listener

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$accept")]
public bool AcceptConnections { get; set; }
[ConfigAttribute("$accept")]
public bool AcceptConnections { get; set; }
<ConfigAttribute("$accept")>
Public Property AcceptConnections As Boolean
    Get
    Set
<ConfigAttribute("$accept")>
Public Property AcceptConnections As Boolean
    Get
    Set
public:
[ConfigAttribute(L"$accept")]
property bool AcceptConnections {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute(L"$accept")]
property bool AcceptConnections {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute("$accept")>]
member AcceptConnections : bool with get, set
[<ConfigAttribute("$accept")>]
member AcceptConnections : bool with get, set

Property Value

Type: Online Boolean
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.AllNodeConfigs Property

ErlLocalNode AllNodeConfigs Property NFX Class Library

Configs for remote nodes

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigSectionNode AllNodeConfigs { get; internal set; }
public ConfigSectionNode AllNodeConfigs { get; internal set; }
Public Property AllNodeConfigs As ConfigSectionNode
    Get
    Friend Set
Public Property AllNodeConfigs As ConfigSectionNode
    Get
    Friend Set
public:
property ConfigSectionNode^ AllNodeConfigs {
    ConfigSectionNode^ get ();
    internal: void set (ConfigSectionNode^ value);
}
public:
property ConfigSectionNode^ AllNodeConfigs {
    ConfigSectionNode^ get ();
    internal: void set (ConfigSectionNode^ value);
}
member AllNodeConfigs : ConfigSectionNode with get, internal set
member AllNodeConfigs : ConfigSectionNode with get, internal set

Property Value

Type: ConfigSectionNode
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.Connections Property

ErlLocalNode Connections Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<KeyValuePair<ErlAtom, ErlConnection>> Connections { get; }
public IEnumerator<KeyValuePair<ErlAtom, ErlConnection>> Connections { get; }
Public ReadOnly Property Connections As IEnumerator(Of KeyValuePair(Of ErlAtom, ErlConnection))
    Get
Public ReadOnly Property Connections As IEnumerator(Of KeyValuePair(Of ErlAtom, ErlConnection))
    Get
public:
property IEnumerator<KeyValuePair<ErlAtom, ErlConnection^>>^ Connections {
    IEnumerator<KeyValuePair<ErlAtom, ErlConnection^>>^ get ();
}
public:
property IEnumerator<KeyValuePair<ErlAtom, ErlConnection^>>^ Connections {
    IEnumerator<KeyValuePair<ErlAtom, ErlConnection^>>^ get ();
}
member Connections : IEnumerator<KeyValuePair<ErlAtom, ErlConnection>> with get
member Connections : IEnumerator<KeyValuePair<ErlAtom, ErlConnection>> with get

Property Value

Type: Online IEnumerator Online KeyValuePair ErlAtom, ErlConnection
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.Creation Property

ErlLocalNode Creation Property NFX Class Library

Contains node creation bits that facilitate Pid uniqueness upon node restart

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte Creation { get; internal set; }
public byte Creation { get; internal set; }
Public Property Creation As Byte
    Get
    Friend Set
Public Property Creation As Byte
    Get
    Friend Set
public:
property unsigned char Creation {
    unsigned char get ();
    internal: void set (unsigned char value);
}
public:
property unsigned char Creation {
    unsigned char get ();
    internal: void set (unsigned char value);
}
member Creation : byte with get, internal set
member Creation : byte with get, internal set

Property Value

Type: Online Byte
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.GroupLeader Property

ErlLocalNode GroupLeader Property NFX Class Library

Mailbox for handling all I/O directed from remote nodes

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlMbox GroupLeader { get; }
public ErlMbox GroupLeader { get; }
Public ReadOnly Property GroupLeader As ErlMbox
    Get
Public ReadOnly Property GroupLeader As ErlMbox
    Get
public:
property ErlMbox^ GroupLeader {
    ErlMbox^ get ();
}
public:
property ErlMbox^ GroupLeader {
    ErlMbox^ get ();
}
member GroupLeader : ErlMbox with get
member GroupLeader : ErlMbox with get

Property Value

Type: ErlMbox
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.LogUnhandledMsgs Property

ErlLocalNode LogUnhandledMsgs Property NFX Class Library

Record unhandled msgs to log

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool LogUnhandledMsgs { get; set; }
[ConfigAttribute]
public bool LogUnhandledMsgs { get; set; }
<ConfigAttribute>
Public Property LogUnhandledMsgs As Boolean
    Get
    Set
<ConfigAttribute>
Public Property LogUnhandledMsgs As Boolean
    Get
    Set
public:
[ConfigAttribute]
property bool LogUnhandledMsgs {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute]
property bool LogUnhandledMsgs {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute>]
member LogUnhandledMsgs : bool with get, set
[<ConfigAttribute>]
member LogUnhandledMsgs : bool with get, set

Property Value

Type: Online Boolean
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.Mailboxes Property

ErlLocalNode Mailboxes Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal MboxRegistry Mailboxes { get; }
internal MboxRegistry Mailboxes { get; }
Friend ReadOnly Property Mailboxes As MboxRegistry
    Get
Friend ReadOnly Property Mailboxes As MboxRegistry
    Get
internal:
property MboxRegistry^ Mailboxes {
    MboxRegistry^ get ();
}
internal:
property MboxRegistry^ Mailboxes {
    MboxRegistry^ get ();
}
internal member Mailboxes : MboxRegistry with get
internal member Mailboxes : MboxRegistry with get

Property Value

Type: MboxRegistry
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.MboxFreelist Property

ErlLocalNode MboxFreelist Property NFX Class Library

Cache of freed mailboxes that can be reused for RPC calls

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ConcurrentQueue<ErlMbox> MboxFreelist { get; }
internal ConcurrentQueue<ErlMbox> MboxFreelist { get; }
Friend ReadOnly Property MboxFreelist As ConcurrentQueue(Of ErlMbox)
    Get
Friend ReadOnly Property MboxFreelist As ConcurrentQueue(Of ErlMbox)
    Get
internal:
property ConcurrentQueue<ErlMbox^>^ MboxFreelist {
    ConcurrentQueue<ErlMbox^>^ get ();
}
internal:
property ConcurrentQueue<ErlMbox^>^ MboxFreelist {
    ConcurrentQueue<ErlMbox^>^ get ();
}
internal member MboxFreelist : ConcurrentQueue<ErlMbox> with get
internal member MboxFreelist : ConcurrentQueue<ErlMbox> with get

Property Value

Type: Online ConcurrentQueue ErlMbox
Remarks
This is needed because the unique Pid space is limited to 2^28
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.RemoteNodeConfigs Property

ErlLocalNode RemoteNodeConfigs Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<ConfigSectionNode> RemoteNodeConfigs { get; }
public IEnumerable<ConfigSectionNode> RemoteNodeConfigs { get; }
Public ReadOnly Property RemoteNodeConfigs As IEnumerable(Of ConfigSectionNode)
    Get
Public ReadOnly Property RemoteNodeConfigs As IEnumerable(Of ConfigSectionNode)
    Get
public:
property IEnumerable<ConfigSectionNode^>^ RemoteNodeConfigs {
    IEnumerable<ConfigSectionNode^>^ get ();
}
public:
property IEnumerable<ConfigSectionNode^>^ RemoteNodeConfigs {
    IEnumerable<ConfigSectionNode^>^ get ();
}
member RemoteNodeConfigs : IEnumerable<ConfigSectionNode> with get
member RemoteNodeConfigs : IEnumerable<ConfigSectionNode> with get

Property Value

Type: Online IEnumerable ConfigSectionNode
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.TraceLevel Property

ErlLocalNode TraceLevel Property NFX Class Library

Set the trace level for this connection. Normally tracing is off by default

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$trace")]
public ErlTraceLevel TraceLevel { get; set; }
[ConfigAttribute("$trace")]
public ErlTraceLevel TraceLevel { get; set; }
<ConfigAttribute("$trace")>
Public Property TraceLevel As ErlTraceLevel
    Get
    Set
<ConfigAttribute("$trace")>
Public Property TraceLevel As ErlTraceLevel
    Get
    Set
public:
[ConfigAttribute(L"$trace")]
property ErlTraceLevel TraceLevel {
    ErlTraceLevel get ();
    void set (ErlTraceLevel value);
}
public:
[ConfigAttribute(L"$trace")]
property ErlTraceLevel TraceLevel {
    ErlTraceLevel get ();
    void set (ErlTraceLevel value);
}
[<ConfigAttribute("$trace")>]
member TraceLevel : ErlTraceLevel with get, set
[<ConfigAttribute("$trace")>]
member TraceLevel : ErlTraceLevel with get, set

Property Value

Type: ErlTraceLevel
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.TraceToLog Property

ErlLocalNode TraceToLog Property NFX Class Library

Save trace events to log

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool TraceToLog { get; set; }
[ConfigAttribute]
public bool TraceToLog { get; set; }
<ConfigAttribute>
Public Property TraceToLog As Boolean
    Get
    Set
<ConfigAttribute>
Public Property TraceToLog As Boolean
    Get
    Set
public:
[ConfigAttribute]
property bool TraceToLog {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute]
property bool TraceToLog {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute>]
member TraceToLog : bool with get, set
[<ConfigAttribute>]
member TraceToLog : bool with get, set

Property Value

Type: Online Boolean
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode Events

ErlLocalNode Events NFX Class Library

The ErlLocalNode type exposes the following members.
Events
 | Name | Description
Public event | ConnectAttempt |
Public event | EpmdFailedConnectAttempt |
Public event | IoOutput |
Public event | NodeStatusChange |
Public event | ReadWrite |
Public event | Trace | Trace callback executed if connection tracing is enabled
Public event | UnhandledMsg |
Back to Top
See Also
ErlLocalNode Class
NFX.Erlang Namespace


ErlLocalNode.ConnectAttempt Event

ErlLocalNode ConnectAttempt Event NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event ConnAttemptEventHandler ConnectAttempt
public event ConnAttemptEventHandler ConnectAttempt
Public Event ConnectAttempt As ConnAttemptEventHandler
Public Event ConnectAttempt As ConnAttemptEventHandler
public:
 event ConnAttemptEventHandler^ ConnectAttempt {
    void add (ConnAttemptEventHandler^ value);
    void remove (ConnAttemptEventHandler^ value);
}
public:
 event ConnAttemptEventHandler^ ConnectAttempt {
    void add (ConnAttemptEventHandler^ value);
    void remove (ConnAttemptEventHandler^ value);
}
member ConnectAttempt : IEvent<ConnAttemptEventHandler,
    EventArgs>
member ConnectAttempt : IEvent<ConnAttemptEventHandler,
    EventArgs>

Value

Type: NFX.Erlang ConnAttemptEventHandler
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.EpmdFailedConnectAttempt Event

ErlLocalNode EpmdFailedConnectAttempt Event NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EpmdFailedConnAttemptEventHandler EpmdFailedConnectAttempt
public event EpmdFailedConnAttemptEventHandler EpmdFailedConnectAttempt
Public Event EpmdFailedConnectAttempt As EpmdFailedConnAttemptEventHandler
Public Event EpmdFailedConnectAttempt As EpmdFailedConnAttemptEventHandler
public:
 event EpmdFailedConnAttemptEventHandler^ EpmdFailedConnectAttempt {
    void add (EpmdFailedConnAttemptEventHandler^ value);
    void remove (EpmdFailedConnAttemptEventHandler^ value);
}
public:
 event EpmdFailedConnAttemptEventHandler^ EpmdFailedConnectAttempt {
    void add (EpmdFailedConnAttemptEventHandler^ value);
    void remove (EpmdFailedConnAttemptEventHandler^ value);
}
member EpmdFailedConnectAttempt : IEvent<EpmdFailedConnAttemptEventHandler,
    EventArgs>
member EpmdFailedConnectAttempt : IEvent<EpmdFailedConnAttemptEventHandler,
    EventArgs>

Value

Type: NFX.Erlang EpmdFailedConnAttemptEventHandler
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.IoOutput Event

ErlLocalNode IoOutput Event NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event IoOutputEventHandler IoOutput
public event IoOutputEventHandler IoOutput
Public Event IoOutput As IoOutputEventHandler
Public Event IoOutput As IoOutputEventHandler
public:
 event IoOutputEventHandler^ IoOutput {
    void add (IoOutputEventHandler^ value);
    void remove (IoOutputEventHandler^ value);
}
public:
 event IoOutputEventHandler^ IoOutput {
    void add (IoOutputEventHandler^ value);
    void remove (IoOutputEventHandler^ value);
}
member IoOutput : IEvent<IoOutputEventHandler,
    EventArgs>
member IoOutput : IEvent<IoOutputEventHandler,
    EventArgs>

Value

Type: NFX.Erlang IoOutputEventHandler
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.NodeStatusChange Event

ErlLocalNode NodeStatusChange Event NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event NodeStatusChangeEventHandler NodeStatusChange
public event NodeStatusChangeEventHandler NodeStatusChange
Public Event NodeStatusChange As NodeStatusChangeEventHandler
Public Event NodeStatusChange As NodeStatusChangeEventHandler
public:
 event NodeStatusChangeEventHandler^ NodeStatusChange {
    void add (NodeStatusChangeEventHandler^ value);
    void remove (NodeStatusChangeEventHandler^ value);
}
public:
 event NodeStatusChangeEventHandler^ NodeStatusChange {
    void add (NodeStatusChangeEventHandler^ value);
    void remove (NodeStatusChangeEventHandler^ value);
}
member NodeStatusChange : IEvent<NodeStatusChangeEventHandler,
    EventArgs>
member NodeStatusChange : IEvent<NodeStatusChangeEventHandler,
    EventArgs>

Value

Type: NFX.Erlang NodeStatusChangeEventHandler
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.ReadWrite Event

ErlLocalNode ReadWrite Event NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event ReadWriteEventHandler ReadWrite
public event ReadWriteEventHandler ReadWrite
Public Event ReadWrite As ReadWriteEventHandler
Public Event ReadWrite As ReadWriteEventHandler
public:
 event ReadWriteEventHandler^ ReadWrite {
    void add (ReadWriteEventHandler^ value);
    void remove (ReadWriteEventHandler^ value);
}
public:
 event ReadWriteEventHandler^ ReadWrite {
    void add (ReadWriteEventHandler^ value);
    void remove (ReadWriteEventHandler^ value);
}
member ReadWrite : IEvent<ReadWriteEventHandler,
    EventArgs>
member ReadWrite : IEvent<ReadWriteEventHandler,
    EventArgs>

Value

Type: NFX.Erlang ReadWriteEventHandler
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.Trace Event

ErlLocalNode Trace Event NFX Class Library

Trace callback executed if connection tracing is enabled

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event TraceEventHandler Trace
public event TraceEventHandler Trace
Public Event Trace As TraceEventHandler
Public Event Trace As TraceEventHandler
public:
 event TraceEventHandler^ Trace {
    void add (TraceEventHandler^ value);
    void remove (TraceEventHandler^ value);
}
public:
 event TraceEventHandler^ Trace {
    void add (TraceEventHandler^ value);
    void remove (TraceEventHandler^ value);
}
member Trace : IEvent<TraceEventHandler,
    EventArgs>
member Trace : IEvent<TraceEventHandler,
    EventArgs>

Value

Type: NFX.Erlang TraceEventHandler
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLocalNode.UnhandledMsg Event

ErlLocalNode UnhandledMsg Event NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event UnhandledMsgEventHandler UnhandledMsg
public event UnhandledMsgEventHandler UnhandledMsg
Public Event UnhandledMsg As UnhandledMsgEventHandler
Public Event UnhandledMsg As UnhandledMsgEventHandler
public:
 event UnhandledMsgEventHandler^ UnhandledMsg {
    void add (UnhandledMsgEventHandler^ value);
    void remove (UnhandledMsgEventHandler^ value);
}
public:
 event UnhandledMsgEventHandler^ UnhandledMsg {
    void add (UnhandledMsgEventHandler^ value);
    void remove (UnhandledMsgEventHandler^ value);
}
member UnhandledMsg : IEvent<UnhandledMsgEventHandler,
    EventArgs>
member UnhandledMsg : IEvent<UnhandledMsgEventHandler,
    EventArgs>

Value

Type: NFX.Erlang UnhandledMsgEventHandler
See Also
ErlLocalNode Class
ErlLocalNode Members
NFX.Erlang Namespace


ErlLong Structure

ErlLong Structure NFX Class Library

Provides a C# representation of Erlang integer types

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct ErlLong : IErlObject<long>,
    IErlObject, IComparable, IComparable<IErlObject>, IEquatable<IErlObject>,
    ICloneable
public struct ErlLong : IErlObject<long>,
    IErlObject, IComparable, IComparable<IErlObject>, IEquatable<IErlObject>,
    ICloneable
Public Structure ErlLong
    Implements IErlObject(Of Long), IErlObject,
    IComparable, IComparable(Of IErlObject), IEquatable(Of IErlObject),
    ICloneable
Public Structure ErlLong
    Implements IErlObject(Of Long), IErlObject,
    IComparable, IComparable(Of IErlObject), IEquatable(Of IErlObject),
    ICloneable
public value class ErlLong : IErlObject<long long>,
    IErlObject, IComparable, IComparable<IErlObject^>, IEquatable<IErlObject^>,
    ICloneable
public value class ErlLong : IErlObject<long long>,
    IErlObject, IComparable, IComparable<IErlObject^>, IEquatable<IErlObject^>,
    ICloneable
[<SealedAttribute>]
type ErlLong =
    struct
        interface IErlObject<int64>
        interface IErlObject
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
    end
[<SealedAttribute>]
type ErlLong =
    struct
        interface IErlObject<int64>
        interface IErlObject
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
    end
See Also
ErlLong Members
NFX.Erlang Namespace


ErlLong Members

ErlLong Members NFX Class Library

The ErlLong type exposes the following members.
Constructors
 | Name | Description
Public method | ErlLong(Int64) | Create an Erlang integer from the given value
Public method | ErlLong( Byte , Int32 , Int32) | Initializes a new instance of the ErlLong class
Back to Top
Methods
 | Name | Description
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj
Public method | Equals(Object) | Determine if this instance equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(ErlByte) |
Public method | Equals(ErlLong) | Determine if two instances are equal
Public method | Equals(IErlObject) | Determine if two instances are equal
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Get internal hash code (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Public method | Matches | Perform pattern match on this Erlang term without binding any variables
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Subst |
Public method | ToString | (Overrides Online ValueType ToString .)
Public method | Visit TAccumulate | Execute fun for every nested term
Back to Top
Operators
Name | Description
Equality(Byte, ErlLong) |
Equality(Int32, ErlLong) |
Equality(Int64, ErlLong) |
Equality(ErlLong, ErlLong) |
Equality(ErlLong, Byte) |
Equality(ErlLong, Int32) |
Equality(ErlLong, Int64) |
(Int32 to ErlLong) |
(ErlLong to Int32) | Implicit conversion of ErlLong to int
(Int64 to ErlLong) |
(ErlLong to Int64) |
Inequality(Byte, ErlLong) |
Inequality(Int32, ErlLong) |
Inequality(Int64, ErlLong) |
Inequality(ErlLong, ErlLong) |
Inequality(ErlLong, Byte) |
Inequality(ErlLong, Int32) |
Inequality(ErlLong, Int64) |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | IsScalar |
Public property | TypeOrder |
Public property | Value |
Public property | ValueAsBool |
Public property | ValueAsByteArray |
Public property | ValueAsChar |
Public property | ValueAsDateTime |
Public property | ValueAsDecimal |
Public property | ValueAsDouble |
Public property | ValueAsInt |
Public property | ValueAsLong |
Public property | ValueAsObject |
Public property | ValueAsString |
Public property | ValueAsTimeSpan |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone |
Back to Top
See Also
ErlLong Structure
NFX.Erlang Namespace


ErlLong Constructor

ErlLong Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ErlLong(Int64) | Create an Erlang integer from the given value
Public method | ErlLong( Byte , Int32 , Int32) | Initializes a new instance of the ErlLong class
Back to Top
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong Constructor (Int64)

ErlLong Constructor (Int64) NFX Class Library

Create an Erlang integer from the given value

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlLong(
    long val
)
public ErlLong(
    long val
)
Public Sub New (
    val As Long
)
Public Sub New (
    val As Long
)
public:
ErlLong(
    long long val
)
public:
ErlLong(
    long long val
)
new :
        val : int64 -> ErlLong
new :
        val : int64 -> ErlLong

Parameters

val
Type: Online System Int64
See Also
ErlLong Structure
ErlLong Members
ErlLong Overload
NFX.Erlang Namespace


ErlLong Constructor (Byte[], Int32, Int32)

ErlLong Constructor ( Byte , Int32 , Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlLong class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlLong(
    byte[] buf,
    ref int offset,
    int count
)
public ErlLong(
    byte[] buf,
    ref int offset,
    int count
)
Public Sub New (
    buf As Byte(),
    ByRef offset As Integer,
    count As Integer
)
Public Sub New (
    buf As Byte(),
    ByRef offset As Integer,
    count As Integer
)
public:
ErlLong(
    array<unsigned char>^ buf,
    int% offset,
    int count
)
public:
ErlLong(
    array<unsigned char>^ buf,
    int% offset,
    int count
)
new :
        buf : byte[] *
        offset : int byref *
        count : int -> ErlLong
new :
        buf : byte[] *
        offset : int byref *
        count : int -> ErlLong

Parameters

buf
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32
See Also
ErlLong Structure
ErlLong Members
ErlLong Overload
NFX.Erlang Namespace


ErlLong Methods

ErlLong Methods NFX Class Library

The ErlLong type exposes the following members.
Methods
 | Name | Description
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj
Public method | Equals(Object) | Determine if this instance equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(ErlByte) |
Public method | Equals(ErlLong) | Determine if two instances are equal
Public method | Equals(IErlObject) | Determine if two instances are equal
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Get internal hash code (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Public method | Matches | Perform pattern match on this Erlang term without binding any variables
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Subst |
Public method | ToString | (Overrides Online ValueType ToString .)
Public method | Visit TAccumulate | Execute fun for every nested term
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone |
Back to Top
See Also
ErlLong Structure
NFX.Erlang Namespace


ErlLong.ICloneable.Clone Method

ErlLong ICloneable Clone Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object ICloneable.Clone()
Object ICloneable.Clone()
Private Function Clone As Object Implements ICloneable.Clone
Private Function Clone As Object Implements ICloneable.Clone
private:
virtual Object^ Clone() sealed = ICloneable::Clone
private:
virtual Object^ Clone() sealed = ICloneable::Clone
private abstract Clone : unit -> Object
private override Clone : unit -> Object
private abstract Clone : unit -> Object
private override Clone : unit -> Object

Return Value

Type: Online Object

Implements

Online ICloneable Clone
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong.Clone Method

ErlLong Clone Method NFX Class Library

Clone an instance of the object (non-scalar immutable objects are copied by reference)

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject Clone()
public IErlObject Clone()
Public Function Clone As IErlObject
Public Function Clone As IErlObject
public:
virtual IErlObject^ Clone() sealed
public:
virtual IErlObject^ Clone() sealed
abstract Clone : unit -> IErlObject
override Clone : unit -> IErlObject
abstract Clone : unit -> IErlObject
override Clone : unit -> IErlObject

Return Value

Type: IErlObject

Implements

IErlObject Clone
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong.CompareTo Method

ErlLong CompareTo Method NFX Class Library

Overload List
 | Name | Description
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj
Back to Top
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong.CompareTo Method (Object)

ErlLong CompareTo Method (Object) NFX Class Library

Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    Object obj
)
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
Public Function CompareTo (
    obj As Object
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
public:
virtual int CompareTo(
    Object^ obj
) sealed
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int

Parameters

obj
Type: Online System Object

Return Value

Type: Online Int32

Implements

Online IComparable CompareTo(Object)
See Also
ErlLong Structure
ErlLong Members
CompareTo Overload
NFX.Erlang Namespace


ErlLong.CompareTo Method (IErlObject)

ErlLong CompareTo Method (IErlObject) NFX Class Library

Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    IErlObject obj
)
public int CompareTo(
    IErlObject obj
)
Public Function CompareTo (
    obj As IErlObject
) As Integer
Public Function CompareTo (
    obj As IErlObject
) As Integer
public:
virtual int CompareTo(
    IErlObject^ obj
) sealed
public:
virtual int CompareTo(
    IErlObject^ obj
) sealed
abstract CompareTo :
        obj : IErlObject -> int
override CompareTo :
        obj : IErlObject -> int
abstract CompareTo :
        obj : IErlObject -> int
override CompareTo :
        obj : IErlObject -> int

Parameters

obj
Type: NFX.Erlang IErlObject

Return Value

Type: Online Int32

Implements

Online IComparable T CompareTo(T)
See Also
ErlLong Structure
ErlLong Members
CompareTo Overload
NFX.Erlang Namespace


ErlLong.Equals Method

ErlLong Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | Determine if this instance equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(ErlByte) |
Public method | Equals(ErlLong) | Determine if two instances are equal
Public method | Equals(IErlObject) | Determine if two instances are equal
Back to Top
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong.Equals Method (Object)

ErlLong Equals Method (Object) NFX Class Library

Determine if this instance equals to the object

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals (
    o As Object
) As Boolean
Public Overrides Function Equals (
    o As Object
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool

Parameters

o
Type: Online System Object

Return Value

Type: Online Boolean
See Also
ErlLong Structure
ErlLong Members
Equals Overload
NFX.Erlang Namespace


ErlLong.Equals Method (ErlByte)

ErlLong Equals Method (ErlByte) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    ErlByte o
)
public bool Equals(
    ErlByte o
)
Public Function Equals (
    o As ErlByte
) As Boolean
Public Function Equals (
    o As ErlByte
) As Boolean
public:
bool Equals(
    ErlByte o
)
public:
bool Equals(
    ErlByte o
)
member Equals :
        o : ErlByte -> bool
member Equals :
        o : ErlByte -> bool

Parameters

o
Type: NFX.Erlang ErlByte

Return Value

Type: Online Boolean
See Also
ErlLong Structure
ErlLong Members
Equals Overload
NFX.Erlang Namespace


ErlLong.Equals Method (ErlLong)

ErlLong Equals Method (ErlLong) NFX Class Library

Determine if two instances are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    ErlLong o
)
public bool Equals(
    ErlLong o
)
Public Function Equals (
    o As ErlLong
) As Boolean
Public Function Equals (
    o As ErlLong
) As Boolean
public:
bool Equals(
    ErlLong o
)
public:
bool Equals(
    ErlLong o
)
member Equals :
        o : ErlLong -> bool
member Equals :
        o : ErlLong -> bool

Parameters

o
Type: NFX.Erlang ErlLong

Return Value

Type: Online Boolean
See Also
ErlLong Structure
ErlLong Members
Equals Overload
NFX.Erlang Namespace


ErlLong.Equals Method (IErlObject)

ErlLong Equals Method (IErlObject) NFX Class Library

Determine if two instances are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    IErlObject o
)
public bool Equals(
    IErlObject o
)
Public Function Equals (
    o As IErlObject
) As Boolean
Public Function Equals (
    o As IErlObject
) As Boolean
public:
virtual bool Equals(
    IErlObject^ o
) sealed
public:
virtual bool Equals(
    IErlObject^ o
) sealed
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool

Parameters

o
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
ErlLong Structure
ErlLong Members
Equals Overload
NFX.Erlang Namespace


ErlLong.GetHashCode Method

ErlLong GetHashCode Method NFX Class Library

Get internal hash code

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong.Match Method

ErlLong Match Method NFX Class Library

Overload List
 | Name | Description
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Back to Top
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong.Match Method (IErlObject)

ErlLong Match Method (IErlObject) NFX Class Library

Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlVarBind Match(
    IErlObject pattern
)
public ErlVarBind Match(
    IErlObject pattern
)
Public Function Match (
    pattern As IErlObject
) As ErlVarBind
Public Function Match (
    pattern As IErlObject
) As ErlVarBind
public:
virtual ErlVarBind^ Match(
    IErlObject^ pattern
) sealed
public:
virtual ErlVarBind^ Match(
    IErlObject^ pattern
) sealed
abstract Match :
        pattern : IErlObject -> ErlVarBind
override Match :
        pattern : IErlObject -> ErlVarBind
abstract Match :
        pattern : IErlObject -> ErlVarBind
override Match :
        pattern : IErlObject -> ErlVarBind

Parameters

pattern
Type: NFX.Erlang IErlObject

Return Value

Type: ErlVarBind

Implements

IErlObject Match(IErlObject)
See Also
ErlLong Structure
ErlLong Members
Match Overload
NFX.Erlang Namespace


ErlLong.Match Method (IErlObject, ErlVarBind)

ErlLong Match Method (IErlObject, ErlVarBind) NFX Class Library

[This is preliminary documentation and is subject to change.]

Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Match(
    IErlObject pattern,
    ErlVarBind binding
)
public bool Match(
    IErlObject pattern,
    ErlVarBind binding
)
Public Function Match (
    pattern As IErlObject,
    binding As ErlVarBind
) As Boolean
Public Function Match (
    pattern As IErlObject,
    binding As ErlVarBind
) As Boolean
public:
virtual bool Match(
    IErlObject^ pattern,
    ErlVarBind^ binding
) sealed
public:
virtual bool Match(
    IErlObject^ pattern,
    ErlVarBind^ binding
) sealed
abstract Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
override Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
abstract Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
override Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool

Parameters

pattern
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind

Return Value

Type: Online Boolean

Implements

IErlObject Match(IErlObject, ErlVarBind)
See Also
ErlLong Structure
ErlLong Members
Match Overload
NFX.Erlang Namespace


ErlLong.Matches Method

ErlLong Matches Method NFX Class Library

Perform pattern match on this Erlang term without binding any variables

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Matches(
    IErlObject pattern
)
public bool Matches(
    IErlObject pattern
)
Public Function Matches (
    pattern As IErlObject
) As Boolean
Public Function Matches (
    pattern As IErlObject
) As Boolean
public:
virtual bool Matches(
    IErlObject^ pattern
) sealed
public:
virtual bool Matches(
    IErlObject^ pattern
) sealed
abstract Matches :
        pattern : IErlObject -> bool
override Matches :
        pattern : IErlObject -> bool
abstract Matches :
        pattern : IErlObject -> bool
override Matches :
        pattern : IErlObject -> bool

Parameters

pattern
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Implements

IErlObject Matches(IErlObject)
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong.Subst Method

ErlLong Subst Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Subst(
    ref IErlObject term,
    ErlVarBind binding
)
public bool Subst(
    ref IErlObject term,
    ErlVarBind binding
)
Public Function Subst (
    ByRef term As IErlObject,
    binding As ErlVarBind
) As Boolean
Public Function Subst (
    ByRef term As IErlObject,
    binding As ErlVarBind
) As Boolean
public:
virtual bool Subst(
    IErlObject^% term,
    ErlVarBind^ binding
) sealed
public:
virtual bool Subst(
    IErlObject^% term,
    ErlVarBind^ binding
) sealed
abstract Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
override Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
abstract Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
override Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool

Parameters

term
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind

Return Value

Type: Online Boolean

Implements

IErlObject Subst(IErlObject , ErlVarBind)
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong.ToString Method

ErlLong ToString Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong.Visit(TAccumulate) Method

ErlLong Visit TAccumulate Method NFX Class Library

Execute fun for every nested term

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TAccumulate Visit<TAccumulate>(
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
public TAccumulate Visit<TAccumulate>(
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
Public Function Visit(Of TAccumulate) (
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
Public Function Visit(Of TAccumulate) (
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
public:
generic<typename TAccumulate>
virtual TAccumulate Visit(
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
) sealed
public:
generic<typename TAccumulate>
virtual TAccumulate Visit(
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
) sealed
abstract Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
override Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
abstract Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
override Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate

Parameters

acc
Type: TAccumulate
fun
Type: Online System Func TAccumulate, IErlObject, TAccumulate
Type Parameters
TAccumulate

Return Value

Type: TAccumulate

Implements

IErlObject Visit TAccumulate (TAccumulate, Func TAccumulate, IErlObject, TAccumulate )
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong Operators and Type Conversions

ErlLong Operators and Type Conversions NFX Class Library

Operators
Name | Description
Equality(Byte, ErlLong) |
Equality(Int32, ErlLong) |
Equality(Int64, ErlLong) |
Equality(ErlLong, ErlLong) |
Equality(ErlLong, Byte) |
Equality(ErlLong, Int32) |
Equality(ErlLong, Int64) |
(Int32 to ErlLong) |
(ErlLong to Int32) | Implicit conversion of ErlLong to int
(Int64 to ErlLong) |
(ErlLong to Int64) |
Inequality(Byte, ErlLong) |
Inequality(Int32, ErlLong) |
Inequality(Int64, ErlLong) |
Inequality(ErlLong, ErlLong) |
Inequality(ErlLong, Byte) |
Inequality(ErlLong, Int32) |
Inequality(ErlLong, Int64) |
Back to Top
See Also
ErlLong Structure
NFX.Erlang Namespace


ErlLong.Equality Operator

ErlLong Equality Operator NFX Class Library

Overload List
Name | Description
Equality(Byte, ErlLong) |
Equality(Int32, ErlLong) |
Equality(Int64, ErlLong) |
Equality(ErlLong, ErlLong) |
Equality(ErlLong, Byte) |
Equality(ErlLong, Int32) |
Equality(ErlLong, Int64) |
Back to Top
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong.Equality Operator (Byte, ErlLong)

ErlLong Equality Operator (Byte, ErlLong) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    byte d,
    ErlLong lhs
)
public static bool operator ==(
    byte d,
    ErlLong lhs
)
Public Shared Operator = (
    d As Byte,
    lhs As ErlLong
) As Boolean
Public Shared Operator = (
    d As Byte,
    lhs As ErlLong
) As Boolean
public:
static bool operator ==(
    unsigned char d,
    ErlLong lhs
)
public:
static bool operator ==(
    unsigned char d,
    ErlLong lhs
)
static let inline (=)
        d : byte *
        lhs : ErlLong  : bool
static let inline (=)
        d : byte *
        lhs : ErlLong  : bool

Parameters

d
Type: Online System Byte
lhs
Type: NFX.Erlang ErlLong

Return Value

Type: Online Boolean
See Also
ErlLong Structure
ErlLong Members
Equality Overload
NFX.Erlang Namespace


ErlLong.Equality Operator (Int32, ErlLong)

ErlLong Equality Operator (Int32, ErlLong) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    int d,
    ErlLong lhs
)
public static bool operator ==(
    int d,
    ErlLong lhs
)
Public Shared Operator = (
    d As Integer,
    lhs As ErlLong
) As Boolean
Public Shared Operator = (
    d As Integer,
    lhs As ErlLong
) As Boolean
public:
static bool operator ==(
    int d,
    ErlLong lhs
)
public:
static bool operator ==(
    int d,
    ErlLong lhs
)
static let inline (=)
        d : int *
        lhs : ErlLong  : bool
static let inline (=)
        d : int *
        lhs : ErlLong  : bool

Parameters

d
Type: Online System Int32
lhs
Type: NFX.Erlang ErlLong

Return Value

Type: Online Boolean
See Also
ErlLong Structure
ErlLong Members
Equality Overload
NFX.Erlang Namespace


ErlLong.Equality Operator (Int64, ErlLong)

ErlLong Equality Operator (Int64, ErlLong) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    long d,
    ErlLong lhs
)
public static bool operator ==(
    long d,
    ErlLong lhs
)
Public Shared Operator = (
    d As Long,
    lhs As ErlLong
) As Boolean
Public Shared Operator = (
    d As Long,
    lhs As ErlLong
) As Boolean
public:
static bool operator ==(
    long long d,
    ErlLong lhs
)
public:
static bool operator ==(
    long long d,
    ErlLong lhs
)
static let inline (=)
        d : int64 *
        lhs : ErlLong  : bool
static let inline (=)
        d : int64 *
        lhs : ErlLong  : bool

Parameters

d
Type: Online System Int64
lhs
Type: NFX.Erlang ErlLong

Return Value

Type: Online Boolean
See Also
ErlLong Structure
ErlLong Members
Equality Overload
NFX.Erlang Namespace


ErlLong.Equality Operator (ErlLong, ErlLong)

ErlLong Equality Operator (ErlLong, ErlLong) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    ErlLong lhs,
    ErlLong rhs
)
public static bool operator ==(
    ErlLong lhs,
    ErlLong rhs
)
Public Shared Operator = (
    lhs As ErlLong,
    rhs As ErlLong
) As Boolean
Public Shared Operator = (
    lhs As ErlLong,
    rhs As ErlLong
) As Boolean
public:
static bool operator ==(
    ErlLong lhs,
    ErlLong rhs
)
public:
static bool operator ==(
    ErlLong lhs,
    ErlLong rhs
)
static let inline (=)
        lhs : ErlLong *
        rhs : ErlLong  : bool
static let inline (=)
        lhs : ErlLong *
        rhs : ErlLong  : bool

Parameters

lhs
Type: NFX.Erlang ErlLong
rhs
Type: NFX.Erlang ErlLong

Return Value

Type: Online Boolean
See Also
ErlLong Structure
ErlLong Members
Equality Overload
NFX.Erlang Namespace


ErlLong.Equality Operator (ErlLong, Byte)

ErlLong Equality Operator (ErlLong, Byte) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    ErlLong lhs,
    byte d
)
public static bool operator ==(
    ErlLong lhs,
    byte d
)
Public Shared Operator = (
    lhs As ErlLong,
    d As Byte
) As Boolean
Public Shared Operator = (
    lhs As ErlLong,
    d As Byte
) As Boolean
public:
static bool operator ==(
    ErlLong lhs,
    unsigned char d
)
public:
static bool operator ==(
    ErlLong lhs,
    unsigned char d
)
static let inline (=)
        lhs : ErlLong *
        d : byte  : bool
static let inline (=)
        lhs : ErlLong *
        d : byte  : bool

Parameters

lhs
Type: NFX.Erlang ErlLong
d
Type: Online System Byte

Return Value

Type: Online Boolean
See Also
ErlLong Structure
ErlLong Members
Equality Overload
NFX.Erlang Namespace


ErlLong.Equality Operator (ErlLong, Int32)

ErlLong Equality Operator (ErlLong, Int32) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    ErlLong lhs,
    int d
)
public static bool operator ==(
    ErlLong lhs,
    int d
)
Public Shared Operator = (
    lhs As ErlLong,
    d As Integer
) As Boolean
Public Shared Operator = (
    lhs As ErlLong,
    d As Integer
) As Boolean
public:
static bool operator ==(
    ErlLong lhs,
    int d
)
public:
static bool operator ==(
    ErlLong lhs,
    int d
)
static let inline (=)
        lhs : ErlLong *
        d : int  : bool
static let inline (=)
        lhs : ErlLong *
        d : int  : bool

Parameters

lhs
Type: NFX.Erlang ErlLong
d
Type: Online System Int32

Return Value

Type: Online Boolean
See Also
ErlLong Structure
ErlLong Members
Equality Overload
NFX.Erlang Namespace


ErlLong.Equality Operator (ErlLong, Int64)

ErlLong Equality Operator (ErlLong, Int64) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    ErlLong lhs,
    long d
)
public static bool operator ==(
    ErlLong lhs,
    long d
)
Public Shared Operator = (
    lhs As ErlLong,
    d As Long
) As Boolean
Public Shared Operator = (
    lhs As ErlLong,
    d As Long
) As Boolean
public:
static bool operator ==(
    ErlLong lhs,
    long long d
)
public:
static bool operator ==(
    ErlLong lhs,
    long long d
)
static let inline (=)
        lhs : ErlLong *
        d : int64  : bool
static let inline (=)
        lhs : ErlLong *
        d : int64  : bool

Parameters

lhs
Type: NFX.Erlang ErlLong
d
Type: Online System Int64

Return Value

Type: Online Boolean
See Also
ErlLong Structure
ErlLong Members
Equality Overload
NFX.Erlang Namespace


ErlLong Explicit Conversion Operators

ErlLong Conversion Operators NFX Class Library

Overload List
Name | Description
(Int32 to ErlLong) |
(ErlLong to Int32) | Implicit conversion of ErlLong to int
Back to Top
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong Explicit Conversion (Int32 to ErlLong)

ErlLong Conversion (Int32 to ErlLong) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static explicit operator ErlLong (
    int t
)
public static explicit operator ErlLong (
    int t
)
Public Shared Narrowing Operator CType (
    t As Integer
) As ErlLong
Public Shared Narrowing Operator CType (
    t As Integer
) As ErlLong
static explicit operator ErlLong (
    int t
)
static explicit operator ErlLong (
    int t
)
F# does not support the declaration of new casting operators.
F# does not support the declaration of new casting operators.

Parameters

t
Type: Online System Int32

Return Value

Type: ErlLong
See Also
ErlLong Structure
ErlLong Members
Overload
NFX.Erlang Namespace


ErlLong Explicit Conversion (ErlLong to Int32)

ErlLong Conversion (ErlLong to Int32) NFX Class Library

Implicit conversion of ErlLong to int

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static explicit operator int (
    ErlLong t
)
public static explicit operator int (
    ErlLong t
)
Public Shared Narrowing Operator CType (
    t As ErlLong
) As Integer
Public Shared Narrowing Operator CType (
    t As ErlLong
) As Integer
static explicit operator int (
    ErlLong t
)
static explicit operator int (
    ErlLong t
)
F# does not support the declaration of new casting operators.
F# does not support the declaration of new casting operators.

Parameters

t
Type: NFX.Erlang ErlLong

Return Value

Type: Online Int32
See Also
ErlLong Structure
ErlLong Members
Overload
NFX.Erlang Namespace


ErlLong Implicit Conversion Operators

ErlLong Conversion Operators NFX Class Library

Overload List
Name | Description
(Int64 to ErlLong) |
(ErlLong to Int64) |
Back to Top
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong Implicit Conversion (Int64 to ErlLong)

ErlLong Conversion (Int64 to ErlLong) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static implicit operator ErlLong (
    long t
)
public static implicit operator ErlLong (
    long t
)
Public Shared Widening Operator CType (
    t As Long
) As ErlLong
Public Shared Widening Operator CType (
    t As Long
) As ErlLong
static implicit operator ErlLong (
    long long t
)
static implicit operator ErlLong (
    long long t
)
F# does not support the declaration of new casting operators.
F# does not support the declaration of new casting operators.

Parameters

t
Type: Online System Int64

Return Value

Type: ErlLong
See Also
ErlLong Structure
ErlLong Members
Overload
NFX.Erlang Namespace


ErlLong Implicit Conversion (ErlLong to Int64)

ErlLong Conversion (ErlLong to Int64) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static implicit operator long (
    ErlLong t
)
public static implicit operator long (
    ErlLong t
)
Public Shared Widening Operator CType (
    t As ErlLong
) As Long
Public Shared Widening Operator CType (
    t As ErlLong
) As Long
static implicit operator long long (
    ErlLong t
)
static implicit operator long long (
    ErlLong t
)
F# does not support the declaration of new casting operators.
F# does not support the declaration of new casting operators.

Parameters

t
Type: NFX.Erlang ErlLong

Return Value

Type: Online Int64
See Also
ErlLong Structure
ErlLong Members
Overload
NFX.Erlang Namespace


ErlLong.Inequality Operator

ErlLong Inequality Operator NFX Class Library

Overload List
Name | Description
Inequality(Byte, ErlLong) |
Inequality(Int32, ErlLong) |
Inequality(Int64, ErlLong) |
Inequality(ErlLong, ErlLong) |
Inequality(ErlLong, Byte) |
Inequality(ErlLong, Int32) |
Inequality(ErlLong, Int64) |
Back to Top
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong.Inequality Operator (Byte, ErlLong)

ErlLong Inequality Operator (Byte, ErlLong) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    byte d,
    ErlLong lhs
)
public static bool operator !=(
    byte d,
    ErlLong lhs
)
Public Shared Operator <> (
    d As Byte,
    lhs As ErlLong
) As Boolean
Public Shared Operator <> (
    d As Byte,
    lhs As ErlLong
) As Boolean
public:
static bool operator !=(
    unsigned char d,
    ErlLong lhs
)
public:
static bool operator !=(
    unsigned char d,
    ErlLong lhs
)
static let inline (<>)
        d : byte *
        lhs : ErlLong  : bool
static let inline (<>)
        d : byte *
        lhs : ErlLong  : bool

Parameters

d
Type: Online System Byte
lhs
Type: NFX.Erlang ErlLong

Return Value

Type: Online Boolean
See Also
ErlLong Structure
ErlLong Members
Inequality Overload
NFX.Erlang Namespace


ErlLong.Inequality Operator (Int32, ErlLong)

ErlLong Inequality Operator (Int32, ErlLong) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    int d,
    ErlLong lhs
)
public static bool operator !=(
    int d,
    ErlLong lhs
)
Public Shared Operator <> (
    d As Integer,
    lhs As ErlLong
) As Boolean
Public Shared Operator <> (
    d As Integer,
    lhs As ErlLong
) As Boolean
public:
static bool operator !=(
    int d,
    ErlLong lhs
)
public:
static bool operator !=(
    int d,
    ErlLong lhs
)
static let inline (<>)
        d : int *
        lhs : ErlLong  : bool
static let inline (<>)
        d : int *
        lhs : ErlLong  : bool

Parameters

d
Type: Online System Int32
lhs
Type: NFX.Erlang ErlLong

Return Value

Type: Online Boolean
See Also
ErlLong Structure
ErlLong Members
Inequality Overload
NFX.Erlang Namespace


ErlLong.Inequality Operator (Int64, ErlLong)

ErlLong Inequality Operator (Int64, ErlLong) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    long d,
    ErlLong lhs
)
public static bool operator !=(
    long d,
    ErlLong lhs
)
Public Shared Operator <> (
    d As Long,
    lhs As ErlLong
) As Boolean
Public Shared Operator <> (
    d As Long,
    lhs As ErlLong
) As Boolean
public:
static bool operator !=(
    long long d,
    ErlLong lhs
)
public:
static bool operator !=(
    long long d,
    ErlLong lhs
)
static let inline (<>)
        d : int64 *
        lhs : ErlLong  : bool
static let inline (<>)
        d : int64 *
        lhs : ErlLong  : bool

Parameters

d
Type: Online System Int64
lhs
Type: NFX.Erlang ErlLong

Return Value

Type: Online Boolean
See Also
ErlLong Structure
ErlLong Members
Inequality Overload
NFX.Erlang Namespace


ErlLong.Inequality Operator (ErlLong, ErlLong)

ErlLong Inequality Operator (ErlLong, ErlLong) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    ErlLong lhs,
    ErlLong rhs
)
public static bool operator !=(
    ErlLong lhs,
    ErlLong rhs
)
Public Shared Operator <> (
    lhs As ErlLong,
    rhs As ErlLong
) As Boolean
Public Shared Operator <> (
    lhs As ErlLong,
    rhs As ErlLong
) As Boolean
public:
static bool operator !=(
    ErlLong lhs,
    ErlLong rhs
)
public:
static bool operator !=(
    ErlLong lhs,
    ErlLong rhs
)
static let inline (<>)
        lhs : ErlLong *
        rhs : ErlLong  : bool
static let inline (<>)
        lhs : ErlLong *
        rhs : ErlLong  : bool

Parameters

lhs
Type: NFX.Erlang ErlLong
rhs
Type: NFX.Erlang ErlLong

Return Value

Type: Online Boolean
See Also
ErlLong Structure
ErlLong Members
Inequality Overload
NFX.Erlang Namespace


ErlLong.Inequality Operator (ErlLong, Byte)

ErlLong Inequality Operator (ErlLong, Byte) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    ErlLong lhs,
    byte d
)
public static bool operator !=(
    ErlLong lhs,
    byte d
)
Public Shared Operator <> (
    lhs As ErlLong,
    d As Byte
) As Boolean
Public Shared Operator <> (
    lhs As ErlLong,
    d As Byte
) As Boolean
public:
static bool operator !=(
    ErlLong lhs,
    unsigned char d
)
public:
static bool operator !=(
    ErlLong lhs,
    unsigned char d
)
static let inline (<>)
        lhs : ErlLong *
        d : byte  : bool
static let inline (<>)
        lhs : ErlLong *
        d : byte  : bool

Parameters

lhs
Type: NFX.Erlang ErlLong
d
Type: Online System Byte

Return Value

Type: Online Boolean
See Also
ErlLong Structure
ErlLong Members
Inequality Overload
NFX.Erlang Namespace


ErlLong.Inequality Operator (ErlLong, Int32)

ErlLong Inequality Operator (ErlLong, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    ErlLong lhs,
    int d
)
public static bool operator !=(
    ErlLong lhs,
    int d
)
Public Shared Operator <> (
    lhs As ErlLong,
    d As Integer
) As Boolean
Public Shared Operator <> (
    lhs As ErlLong,
    d As Integer
) As Boolean
public:
static bool operator !=(
    ErlLong lhs,
    int d
)
public:
static bool operator !=(
    ErlLong lhs,
    int d
)
static let inline (<>)
        lhs : ErlLong *
        d : int  : bool
static let inline (<>)
        lhs : ErlLong *
        d : int  : bool

Parameters

lhs
Type: NFX.Erlang ErlLong
d
Type: Online System Int32

Return Value

Type: Online Boolean
See Also
ErlLong Structure
ErlLong Members
Inequality Overload
NFX.Erlang Namespace


ErlLong.Inequality Operator (ErlLong, Int64)

ErlLong Inequality Operator (ErlLong, Int64) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    ErlLong lhs,
    long d
)
public static bool operator !=(
    ErlLong lhs,
    long d
)
Public Shared Operator <> (
    lhs As ErlLong,
    d As Long
) As Boolean
Public Shared Operator <> (
    lhs As ErlLong,
    d As Long
) As Boolean
public:
static bool operator !=(
    ErlLong lhs,
    long long d
)
public:
static bool operator !=(
    ErlLong lhs,
    long long d
)
static let inline (<>)
        lhs : ErlLong *
        d : int64  : bool
static let inline (<>)
        lhs : ErlLong *
        d : int64  : bool

Parameters

lhs
Type: NFX.Erlang ErlLong
d
Type: Online System Int64

Return Value

Type: Online Boolean
See Also
ErlLong Structure
ErlLong Members
Inequality Overload
NFX.Erlang Namespace


ErlLong Properties

ErlLong Properties NFX Class Library

The ErlLong type exposes the following members.
Properties
 | Name | Description
Public property | IsScalar |
Public property | TypeOrder |
Public property | Value |
Public property | ValueAsBool |
Public property | ValueAsByteArray |
Public property | ValueAsChar |
Public property | ValueAsDateTime |
Public property | ValueAsDecimal |
Public property | ValueAsDouble |
Public property | ValueAsInt |
Public property | ValueAsLong |
Public property | ValueAsObject |
Public property | ValueAsString |
Public property | ValueAsTimeSpan |
Back to Top
See Also
ErlLong Structure
NFX.Erlang Namespace


ErlLong.IsScalar Property

ErlLong IsScalar Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsScalar { get; }
public bool IsScalar { get; }
Public ReadOnly Property IsScalar As Boolean
    Get
Public ReadOnly Property IsScalar As Boolean
    Get
public:
virtual property bool IsScalar {
    bool get () sealed;
}
public:
virtual property bool IsScalar {
    bool get () sealed;
}
abstract IsScalar : bool with get
override IsScalar : bool with get
abstract IsScalar : bool with get
override IsScalar : bool with get

Property Value

Type: Online Boolean

Implements

IErlObject IsScalar
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong.TypeOrder Property

ErlLong TypeOrder Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTypeOrder TypeOrder { get; }
public ErlTypeOrder TypeOrder { get; }
Public ReadOnly Property TypeOrder As ErlTypeOrder
    Get
Public ReadOnly Property TypeOrder As ErlTypeOrder
    Get
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () sealed;
}
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () sealed;
}
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get

Property Value

Type: ErlTypeOrder

Implements

IErlObject TypeOrder
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong.Value Property

ErlLong Value Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long Value { get; }
public long Value { get; }
Public ReadOnly Property Value As Long
    Get
Public ReadOnly Property Value As Long
    Get
public:
virtual property long long Value {
    long long get () sealed;
}
public:
virtual property long long Value {
    long long get () sealed;
}
abstract Value : int64 with get
override Value : int64 with get
abstract Value : int64 with get
override Value : int64 with get

Property Value

Type: Online Int64

Implements

IErlObject T Value
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong.ValueAsBool Property

ErlLong ValueAsBool Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ValueAsBool { get; }
public bool ValueAsBool { get; }
Public ReadOnly Property ValueAsBool As Boolean
    Get
Public ReadOnly Property ValueAsBool As Boolean
    Get
public:
virtual property bool ValueAsBool {
    bool get () sealed;
}
public:
virtual property bool ValueAsBool {
    bool get () sealed;
}
abstract ValueAsBool : bool with get
override ValueAsBool : bool with get
abstract ValueAsBool : bool with get
override ValueAsBool : bool with get

Property Value

Type: Online Boolean

Implements

IErlObject ValueAsBool
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong.ValueAsByteArray Property

ErlLong ValueAsByteArray Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] ValueAsByteArray { get; }
public byte[] ValueAsByteArray { get; }
Public ReadOnly Property ValueAsByteArray As Byte()
    Get
Public ReadOnly Property ValueAsByteArray As Byte()
    Get
public:
virtual property array<unsigned char>^ ValueAsByteArray {
    array<unsigned char>^ get () sealed;
}
public:
virtual property array<unsigned char>^ ValueAsByteArray {
    array<unsigned char>^ get () sealed;
}
abstract ValueAsByteArray : byte[] with get
override ValueAsByteArray : byte[] with get
abstract ValueAsByteArray : byte[] with get
override ValueAsByteArray : byte[] with get

Property Value

Type: Online Byte

Implements

IErlObject ValueAsByteArray
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong.ValueAsChar Property

ErlLong ValueAsChar Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char ValueAsChar { get; }
public char ValueAsChar { get; }
Public ReadOnly Property ValueAsChar As Char
    Get
Public ReadOnly Property ValueAsChar As Char
    Get
public:
virtual property wchar_t ValueAsChar {
    wchar_t get () sealed;
}
public:
virtual property wchar_t ValueAsChar {
    wchar_t get () sealed;
}
abstract ValueAsChar : char with get
override ValueAsChar : char with get
abstract ValueAsChar : char with get
override ValueAsChar : char with get

Property Value

Type: Online Char

Implements

IErlObject ValueAsChar
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong.ValueAsDateTime Property

ErlLong ValueAsDateTime Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime ValueAsDateTime { get; }
public DateTime ValueAsDateTime { get; }
Public ReadOnly Property ValueAsDateTime As DateTime
    Get
Public ReadOnly Property ValueAsDateTime As DateTime
    Get
public:
virtual property DateTime ValueAsDateTime {
    DateTime get () sealed;
}
public:
virtual property DateTime ValueAsDateTime {
    DateTime get () sealed;
}
abstract ValueAsDateTime : DateTime with get
override ValueAsDateTime : DateTime with get
abstract ValueAsDateTime : DateTime with get
override ValueAsDateTime : DateTime with get

Property Value

Type: Online DateTime

Implements

IErlObject ValueAsDateTime
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong.ValueAsDecimal Property

ErlLong ValueAsDecimal Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal ValueAsDecimal { get; }
public decimal ValueAsDecimal { get; }
Public ReadOnly Property ValueAsDecimal As Decimal
    Get
Public ReadOnly Property ValueAsDecimal As Decimal
    Get
public:
virtual property Decimal ValueAsDecimal {
    Decimal get () sealed;
}
public:
virtual property Decimal ValueAsDecimal {
    Decimal get () sealed;
}
abstract ValueAsDecimal : decimal with get
override ValueAsDecimal : decimal with get
abstract ValueAsDecimal : decimal with get
override ValueAsDecimal : decimal with get

Property Value

Type: Online Decimal

Implements

IErlObject ValueAsDecimal
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong.ValueAsDouble Property

ErlLong ValueAsDouble Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double ValueAsDouble { get; }
public double ValueAsDouble { get; }
Public ReadOnly Property ValueAsDouble As Double
    Get
Public ReadOnly Property ValueAsDouble As Double
    Get
public:
virtual property double ValueAsDouble {
    double get () sealed;
}
public:
virtual property double ValueAsDouble {
    double get () sealed;
}
abstract ValueAsDouble : float with get
override ValueAsDouble : float with get
abstract ValueAsDouble : float with get
override ValueAsDouble : float with get

Property Value

Type: Online Double

Implements

IErlObject ValueAsDouble
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong.ValueAsInt Property

ErlLong ValueAsInt Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ValueAsInt { get; }
public int ValueAsInt { get; }
Public ReadOnly Property ValueAsInt As Integer
    Get
Public ReadOnly Property ValueAsInt As Integer
    Get
public:
virtual property int ValueAsInt {
    int get () sealed;
}
public:
virtual property int ValueAsInt {
    int get () sealed;
}
abstract ValueAsInt : int with get
override ValueAsInt : int with get
abstract ValueAsInt : int with get
override ValueAsInt : int with get

Property Value

Type: Online Int32

Implements

IErlObject ValueAsInt
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong.ValueAsLong Property

ErlLong ValueAsLong Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long ValueAsLong { get; }
public long ValueAsLong { get; }
Public ReadOnly Property ValueAsLong As Long
    Get
Public ReadOnly Property ValueAsLong As Long
    Get
public:
virtual property long long ValueAsLong {
    long long get () sealed;
}
public:
virtual property long long ValueAsLong {
    long long get () sealed;
}
abstract ValueAsLong : int64 with get
override ValueAsLong : int64 with get
abstract ValueAsLong : int64 with get
override ValueAsLong : int64 with get

Property Value

Type: Online Int64

Implements

IErlObject ValueAsLong
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong.ValueAsObject Property

ErlLong ValueAsObject Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object ValueAsObject { get; }
public Object ValueAsObject { get; }
Public ReadOnly Property ValueAsObject As Object
    Get
Public ReadOnly Property ValueAsObject As Object
    Get
public:
virtual property Object^ ValueAsObject {
    Object^ get () sealed;
}
public:
virtual property Object^ ValueAsObject {
    Object^ get () sealed;
}
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get

Property Value

Type: Online Object

Implements

IErlObject ValueAsObject
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong.ValueAsString Property

ErlLong ValueAsString Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ValueAsString { get; }
public string ValueAsString { get; }
Public ReadOnly Property ValueAsString As String
    Get
Public ReadOnly Property ValueAsString As String
    Get
public:
virtual property String^ ValueAsString {
    String^ get () sealed;
}
public:
virtual property String^ ValueAsString {
    String^ get () sealed;
}
abstract ValueAsString : string with get
override ValueAsString : string with get
abstract ValueAsString : string with get
override ValueAsString : string with get

Property Value

Type: Online String

Implements

IErlObject ValueAsString
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlLong.ValueAsTimeSpan Property

ErlLong ValueAsTimeSpan Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpan ValueAsTimeSpan { get; }
public TimeSpan ValueAsTimeSpan { get; }
Public ReadOnly Property ValueAsTimeSpan As TimeSpan
    Get
Public ReadOnly Property ValueAsTimeSpan As TimeSpan
    Get
public:
virtual property TimeSpan ValueAsTimeSpan {
    TimeSpan get () sealed;
}
public:
virtual property TimeSpan ValueAsTimeSpan {
    TimeSpan get () sealed;
}
abstract ValueAsTimeSpan : TimeSpan with get
override ValueAsTimeSpan : TimeSpan with get
abstract ValueAsTimeSpan : TimeSpan with get
override ValueAsTimeSpan : TimeSpan with get

Property Value

Type: Online TimeSpan

Implements

IErlObject ValueAsTimeSpan
See Also
ErlLong Structure
ErlLong Members
NFX.Erlang Namespace


ErlMbox Class

ErlMbox Class NFX Class Library

Provides a simple mechanism for exchanging messages with Erlang processes or other instances of this class
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Erlang ErlMbox

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ErlMbox : DisposableObject
public class ErlMbox : DisposableObject
Public Class ErlMbox
    Inherits DisposableObject
Public Class ErlMbox
    Inherits DisposableObject
public ref class ErlMbox : public DisposableObject
public ref class ErlMbox : public DisposableObject
type ErlMbox =
    class
        inherit DisposableObject
    end
type ErlMbox =
    class
        inherit DisposableObject
    end
Remarks
Each mailbox is associated with a unique ErlPid that contains information necessary for delivery of messages. When sending messages to named processes or mailboxes, the sender pid is made available to the recipient of the message. When sending messages to other mailboxes, the recipient can only respond if the sender includes the pid as part of the message contents. The sender can determine his own pid by calling Self. Mailboxes can be named, either at creation or later. Messages can be sent to named mailboxes and named Erlang processes without knowing the ErlPid that identifies the mailbox. This is neccessary in order to set up initial communication between parts of an application. Each mailbox can have at most one name. Messages to remote nodes are externalized for transmission, and as a result the recipient receives a copy of the original C# object. To ensure consistent behaviour when messages are sent between local mailboxes, such messages are cloned before delivery. Additionally, mailboxes can be linked in much the same way as Erlang processes. If a link is active when a mailbox is closed any linked Erlang processes or ErlMbox's will be sent an exit signal. As well, exit signals will be (eventually) sent if a mailbox goes out of scope and its Dispose method called. However due to the nature of finalization (i.e. C# makes no guarantees about when Dispose will be called) it is recommended that you always explicitly close mailboxes if you are using links instead of relying on finalization to notify other parties in a timely manner. When retrieving messages from a mailbox that has received an exit signal, an ErlExit exception will be raised. Note that the exception is queued in the mailbox along with other messages, and will not be raised until it reaches the head of the queue and is about to be retrieved
See Also
ErlMbox Members
NFX.Erlang Namespace


ErlMbox Members

ErlMbox Members NFX Class Library

The ErlMbox type exposes the following members.
Constructors
 | Name | Description
Protected method | ErlMbox(ErlLocalNode, ErlPid, ErlAtom) | Initializes a new instance of the ErlMbox class
Protected method | ErlMbox(ErlLocalNode, ErlPid, String) | Create a mailbox with optional name
Back to Top
Methods
 | Name | Description
Public method | AsyncRPC(ErlAtom, ErlAtom, ErlAtom, ErlList, Nullable ErlAtom ) |
Public method | AsyncRPC(ErlAtom, String, String, ErlList, Nullable ErlAtom ) |
Public method | AsyncRPC(ErlAtom, ErlAtom, ErlAtom, ErlList, IErlObject, Nullable ErlAtom ) | Send RPC call to a given node.
Public method | AsyncRPC(ErlAtom, String, String, ErlList, ErlPid, Nullable ErlAtom ) |
Protected method | BreakLinks(ErlAtom) | Used to break all known links to this mbox
Protected method | BreakLinks(ErlAtom, IErlObject) | Used to break all known links to this mbox
Public method | Clear |
Protected method | Close | Close this mailbox
Protected method | Deliver(ErlConnectionException) |
Protected method | Deliver(ErlMsg) | Called to deliver message to this mailbox
Protected method | Dequeue |
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | Down |
Protected method | Enqueue |
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Equals | Determine if two mailboxes are equal (Overrides Online Object Equals(Object).)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Link | Link to a remote mailbox or Erlang process. Links are idempotent, calling this method multiple times will not result in more than one link being created
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnMailboxMessage |
Public method | Receive | Wait for a message to arrive for this mailbox. On timeout return null
Public method | receiveBuf | Wait for a message to arrive for this mailbox
Public method | ReceiveMatch(ErlPatternMatcher, Int32) | Receive a message and match it against a given pattern
Public method | ReceiveMatch(IErlObject, Int32) | Receive a message and match it against a given pattern
Public method | ReceiveRPC |
Public method | Register(String) | Register a name for this mailbox. Registering a name for a mailbox enables others to send messages without knowing the ErlPid of the mailbox. A mailbox can have at most one name; if the mailbox already had a name, calling this method will supercede that name
Public method | Register(ErlAtom) |
Public method | RPC(ErlAtom, ErlAtom, ErlAtom, ErlList, Nullable ErlAtom ) |
Public method | RPC(ErlAtom, String, String, ErlList, Nullable ErlAtom ) |
Public method | RPC(ErlAtom, ErlAtom, ErlAtom, ErlList, Int32, Nullable ErlAtom ) |
Public method | RPC(ErlAtom, String, String, ErlList, Int32, Nullable ErlAtom ) |
Public method | RPCcast(ErlAtom, ErlAtom, ErlAtom, ErlList) |
Public method | RPCcast(ErlAtom, ErlAtom, ErlAtom, ErlList, IErlObject) |
Public method | Send | Send a message to a named mailbox created from another node
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Unlink | Remove a link to a remote mailbox or Erlang process. This method removes a link created with ErlLink Links are idempotent; calling this method once will remove all links between this mailbox and the remote ErlPid
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Empty | Return true if there are no messages waiting in the receive queue of this connection
Public property | Handle | Queue not empty status notification handle
Protected property | LastUsed | Timestamps when this mailbox was last used - this is used internally by mailbox caching
Public property | MsgCount | Return the number of messages currently waiting in the receive queue of this connection
Public property | Name | Get the registered name of this mailbox, or string.Empty if the mailbox doesn't have a registered name
Public property | Node |
Public property | QueueActive |
Public property | Self | Get the Pid identifying associated with this mailbox
Back to Top
Events
 | Name | Description
Public event | MailboxMessage | If this event is assigned, it will be called on arrival of a message, but the messages will not be put in the queue
Back to Top
See Also
ErlMbox Class
NFX.Erlang Namespace


ErlMbox Constructor

ErlMbox Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | ErlMbox(ErlLocalNode, ErlPid, ErlAtom) | Initializes a new instance of the ErlMbox class
Protected method | ErlMbox(ErlLocalNode, ErlPid, String) | Create a mailbox with optional name
Back to Top
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox Constructor (ErlLocalNode, ErlPid, ErlAtom)

ErlMbox Constructor (ErlLocalNode, ErlPid, ErlAtom) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlMbox class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ErlMbox(
    ErlLocalNode home,
    ErlPid self,
    ErlAtom name
)
internal ErlMbox(
    ErlLocalNode home,
    ErlPid self,
    ErlAtom name
)
Friend Sub New (
    home As ErlLocalNode,
    self As ErlPid,
    name As ErlAtom
)
Friend Sub New (
    home As ErlLocalNode,
    self As ErlPid,
    name As ErlAtom
)
internal:
ErlMbox(
    ErlLocalNode^ home,
    ErlPid self,
    ErlAtom name
)
internal:
ErlMbox(
    ErlLocalNode^ home,
    ErlPid self,
    ErlAtom name
)
new :
        home : ErlLocalNode *
        self : ErlPid *
        name : ErlAtom -> ErlMbox
new :
        home : ErlLocalNode *
        self : ErlPid *
        name : ErlAtom -> ErlMbox

Parameters

home
Type: NFX.Erlang ErlLocalNode
self
Type: NFX.Erlang ErlPid
name
Type: NFX.Erlang ErlAtom
See Also
ErlMbox Class
ErlMbox Members
ErlMbox Overload
NFX.Erlang Namespace


ErlMbox Constructor (ErlLocalNode, ErlPid, String)

ErlMbox Constructor (ErlLocalNode, ErlPid, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Create a mailbox with optional name

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ErlMbox(
    ErlLocalNode home,
    ErlPid self,
    string name = null
)
internal ErlMbox(
    ErlLocalNode home,
    ErlPid self,
    string name = null
)
Friend Sub New (
    home As ErlLocalNode,
    self As ErlPid,
    Optional name As String = Nothing
)
Friend Sub New (
    home As ErlLocalNode,
    self As ErlPid,
    Optional name As String = Nothing
)
internal:
ErlMbox(
    ErlLocalNode^ home,
    ErlPid self,
    String^ name = nullptr
)
internal:
ErlMbox(
    ErlLocalNode^ home,
    ErlPid self,
    String^ name = nullptr
)
new :
        home : ErlLocalNode *
        self : ErlPid *
        ?name : string
(* Defaults:
        let _name = defaultArg name null
*)
-> ErlMbox
new :
        home : ErlLocalNode *
        self : ErlPid *
        ?name : string
(* Defaults:
        let _name = defaultArg name null
*)
-> ErlMbox

Parameters

home
Type: NFX.Erlang ErlLocalNode
self
Type: NFX.Erlang ErlPid
name (Optional)
Type: Online System String
See Also
ErlMbox Class
ErlMbox Members
ErlMbox Overload
NFX.Erlang Namespace


ErlMbox Methods

ErlMbox Methods NFX Class Library

The ErlMbox type exposes the following members.
Methods
 | Name | Description
Public method | AsyncRPC(ErlAtom, ErlAtom, ErlAtom, ErlList, Nullable ErlAtom ) |
Public method | AsyncRPC(ErlAtom, String, String, ErlList, Nullable ErlAtom ) |
Public method | AsyncRPC(ErlAtom, ErlAtom, ErlAtom, ErlList, IErlObject, Nullable ErlAtom ) | Send RPC call to a given node.
Public method | AsyncRPC(ErlAtom, String, String, ErlList, ErlPid, Nullable ErlAtom ) |
Protected method | BreakLinks(ErlAtom) | Used to break all known links to this mbox
Protected method | BreakLinks(ErlAtom, IErlObject) | Used to break all known links to this mbox
Public method | Clear |
Protected method | Close | Close this mailbox
Protected method | Deliver(ErlConnectionException) |
Protected method | Deliver(ErlMsg) | Called to deliver message to this mailbox
Protected method | Dequeue |
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | Down |
Protected method | Enqueue |
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Equals | Determine if two mailboxes are equal (Overrides Online Object Equals(Object).)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Link | Link to a remote mailbox or Erlang process. Links are idempotent, calling this method multiple times will not result in more than one link being created
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OnMailboxMessage |
Public method | Receive | Wait for a message to arrive for this mailbox. On timeout return null
Public method | receiveBuf | Wait for a message to arrive for this mailbox
Public method | ReceiveMatch(ErlPatternMatcher, Int32) | Receive a message and match it against a given pattern
Public method | ReceiveMatch(IErlObject, Int32) | Receive a message and match it against a given pattern
Public method | ReceiveRPC |
Public method | Register(String) | Register a name for this mailbox. Registering a name for a mailbox enables others to send messages without knowing the ErlPid of the mailbox. A mailbox can have at most one name; if the mailbox already had a name, calling this method will supercede that name
Public method | Register(ErlAtom) |
Public method | RPC(ErlAtom, ErlAtom, ErlAtom, ErlList, Nullable ErlAtom ) |
Public method | RPC(ErlAtom, String, String, ErlList, Nullable ErlAtom ) |
Public method | RPC(ErlAtom, ErlAtom, ErlAtom, ErlList, Int32, Nullable ErlAtom ) |
Public method | RPC(ErlAtom, String, String, ErlList, Int32, Nullable ErlAtom ) |
Public method | RPCcast(ErlAtom, ErlAtom, ErlAtom, ErlList) |
Public method | RPCcast(ErlAtom, ErlAtom, ErlAtom, ErlList, IErlObject) |
Public method | Send | Send a message to a named mailbox created from another node
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Unlink | Remove a link to a remote mailbox or Erlang process. This method removes a link created with ErlLink Links are idempotent; calling this method once will remove all links between this mailbox and the remote ErlPid
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ErlMbox Class
NFX.Erlang Namespace


ErlMbox.AsyncRPC Method

ErlMbox AsyncRPC Method NFX Class Library

Overload List
 | Name | Description
Public method | AsyncRPC(ErlAtom, ErlAtom, ErlAtom, ErlList, Nullable ErlAtom ) |
Public method | AsyncRPC(ErlAtom, String, String, ErlList, Nullable ErlAtom ) |
Public method | AsyncRPC(ErlAtom, ErlAtom, ErlAtom, ErlList, IErlObject, Nullable ErlAtom ) | Send RPC call to a given node.
Public method | AsyncRPC(ErlAtom, String, String, ErlList, ErlPid, Nullable ErlAtom ) |
Back to Top
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.AsyncRPC Method (ErlAtom, ErlAtom, ErlAtom, ErlList, Nullable(ErlAtom))

ErlMbox AsyncRPC Method (ErlAtom, ErlAtom, ErlAtom, ErlList, Nullable ErlAtom ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AsyncRPC(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList args,
    Nullable<ErlAtom> remoteCookie = null
)
public void AsyncRPC(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList args,
    Nullable<ErlAtom> remoteCookie = null
)
Public Sub AsyncRPC (
    node As ErlAtom,
    mod As ErlAtom,
    fun As ErlAtom,
    args As ErlList,
    Optional remoteCookie As Nullable(Of ErlAtom) = Nothing
)
Public Sub AsyncRPC (
    node As ErlAtom,
    mod As ErlAtom,
    fun As ErlAtom,
    args As ErlList,
    Optional remoteCookie As Nullable(Of ErlAtom) = Nothing
)
public:
void AsyncRPC(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList^ args,
    Nullable<ErlAtom> remoteCookie = nullptr
)
public:
void AsyncRPC(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList^ args,
    Nullable<ErlAtom> remoteCookie = nullptr
)
member AsyncRPC :
        node : ErlAtom *
        mod : ErlAtom *
        fun : ErlAtom *
        args : ErlList *
        ?remoteCookie : Nullable<ErlAtom>
(* Defaults:
        let _remoteCookie = defaultArg remoteCookie null
*)
-> unit
member AsyncRPC :
        node : ErlAtom *
        mod : ErlAtom *
        fun : ErlAtom *
        args : ErlList *
        ?remoteCookie : Nullable<ErlAtom>
(* Defaults:
        let _remoteCookie = defaultArg remoteCookie null
*)
-> unit

Parameters

node
Type: NFX.Erlang ErlAtom
mod
Type: NFX.Erlang ErlAtom
fun
Type: NFX.Erlang ErlAtom
args
Type: NFX.Erlang ErlList
remoteCookie (Optional)
Type: Online System Nullable ErlAtom
See Also
ErlMbox Class
ErlMbox Members
AsyncRPC Overload
NFX.Erlang Namespace


ErlMbox.AsyncRPC Method (ErlAtom, String, String, ErlList, Nullable(ErlAtom))

ErlMbox AsyncRPC Method (ErlAtom, String, String, ErlList, Nullable ErlAtom ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AsyncRPC(
    ErlAtom node,
    string mod,
    string fun,
    ErlList args,
    Nullable<ErlAtom> remoteCookie = null
)
public void AsyncRPC(
    ErlAtom node,
    string mod,
    string fun,
    ErlList args,
    Nullable<ErlAtom> remoteCookie = null
)
Public Sub AsyncRPC (
    node As ErlAtom,
    mod As String,
    fun As String,
    args As ErlList,
    Optional remoteCookie As Nullable(Of ErlAtom) = Nothing
)
Public Sub AsyncRPC (
    node As ErlAtom,
    mod As String,
    fun As String,
    args As ErlList,
    Optional remoteCookie As Nullable(Of ErlAtom) = Nothing
)
public:
void AsyncRPC(
    ErlAtom node,
    String^ mod,
    String^ fun,
    ErlList^ args,
    Nullable<ErlAtom> remoteCookie = nullptr
)
public:
void AsyncRPC(
    ErlAtom node,
    String^ mod,
    String^ fun,
    ErlList^ args,
    Nullable<ErlAtom> remoteCookie = nullptr
)
member AsyncRPC :
        node : ErlAtom *
        mod : string *
        fun : string *
        args : ErlList *
        ?remoteCookie : Nullable<ErlAtom>
(* Defaults:
        let _remoteCookie = defaultArg remoteCookie null
*)
-> unit
member AsyncRPC :
        node : ErlAtom *
        mod : string *
        fun : string *
        args : ErlList *
        ?remoteCookie : Nullable<ErlAtom>
(* Defaults:
        let _remoteCookie = defaultArg remoteCookie null
*)
-> unit

Parameters

node
Type: NFX.Erlang ErlAtom
mod
Type: Online System String
fun
Type: Online System String
args
Type: NFX.Erlang ErlList
remoteCookie (Optional)
Type: Online System Nullable ErlAtom
See Also
ErlMbox Class
ErlMbox Members
AsyncRPC Overload
NFX.Erlang Namespace


ErlMbox.AsyncRPC Method (ErlAtom, ErlAtom, ErlAtom, ErlList, IErlObject, Nullable(ErlAtom))

ErlMbox AsyncRPC Method (ErlAtom, ErlAtom, ErlAtom, ErlList, IErlObject, Nullable ErlAtom ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Send RPC call to a given node.

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AsyncRPC(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList args,
    IErlObject ioServer,
    Nullable<ErlAtom> remoteCookie = null
)
public void AsyncRPC(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList args,
    IErlObject ioServer,
    Nullable<ErlAtom> remoteCookie = null
)
Public Sub AsyncRPC (
    node As ErlAtom,
    mod As ErlAtom,
    fun As ErlAtom,
    args As ErlList,
    ioServer As IErlObject,
    Optional remoteCookie As Nullable(Of ErlAtom) = Nothing
)
Public Sub AsyncRPC (
    node As ErlAtom,
    mod As ErlAtom,
    fun As ErlAtom,
    args As ErlList,
    ioServer As IErlObject,
    Optional remoteCookie As Nullable(Of ErlAtom) = Nothing
)
public:
void AsyncRPC(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList^ args,
    IErlObject^ ioServer,
    Nullable<ErlAtom> remoteCookie = nullptr
)
public:
void AsyncRPC(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList^ args,
    IErlObject^ ioServer,
    Nullable<ErlAtom> remoteCookie = nullptr
)
member AsyncRPC :
        node : ErlAtom *
        mod : ErlAtom *
        fun : ErlAtom *
        args : ErlList *
        ioServer : IErlObject *
        ?remoteCookie : Nullable<ErlAtom>
(* Defaults:
        let _remoteCookie = defaultArg remoteCookie null
*)
-> unit
member AsyncRPC :
        node : ErlAtom *
        mod : ErlAtom *
        fun : ErlAtom *
        args : ErlList *
        ioServer : IErlObject *
        ?remoteCookie : Nullable<ErlAtom>
(* Defaults:
        let _remoteCookie = defaultArg remoteCookie null
*)
-> unit

Parameters

node
Type: NFX.Erlang ErlAtom
Destination node for this RPC call
mod
Type: NFX.Erlang ErlAtom
Module name to call
fun
Type: NFX.Erlang ErlAtom
Function name to call
args
Type: NFX.Erlang ErlList
Function arguments
ioServer
Type: NFX.Erlang IErlObject
Either a PID or an Atom containing registered I/O server's name.
remoteCookie (Optional)
Type: Online System Nullable ErlAtom
Remote cookie
See Also
ErlMbox Class
ErlMbox Members
AsyncRPC Overload
NFX.Erlang Namespace


ErlMbox.AsyncRPC Method (ErlAtom, String, String, ErlList, ErlPid, Nullable(ErlAtom))

ErlMbox AsyncRPC Method (ErlAtom, String, String, ErlList, ErlPid, Nullable ErlAtom ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AsyncRPC(
    ErlAtom node,
    string mod,
    string fun,
    ErlList args,
    ErlPid ioServer,
    Nullable<ErlAtom> remoteCookie = null
)
public void AsyncRPC(
    ErlAtom node,
    string mod,
    string fun,
    ErlList args,
    ErlPid ioServer,
    Nullable<ErlAtom> remoteCookie = null
)
Public Sub AsyncRPC (
    node As ErlAtom,
    mod As String,
    fun As String,
    args As ErlList,
    ioServer As ErlPid,
    Optional remoteCookie As Nullable(Of ErlAtom) = Nothing
)
Public Sub AsyncRPC (
    node As ErlAtom,
    mod As String,
    fun As String,
    args As ErlList,
    ioServer As ErlPid,
    Optional remoteCookie As Nullable(Of ErlAtom) = Nothing
)
public:
void AsyncRPC(
    ErlAtom node,
    String^ mod,
    String^ fun,
    ErlList^ args,
    ErlPid ioServer,
    Nullable<ErlAtom> remoteCookie = nullptr
)
public:
void AsyncRPC(
    ErlAtom node,
    String^ mod,
    String^ fun,
    ErlList^ args,
    ErlPid ioServer,
    Nullable<ErlAtom> remoteCookie = nullptr
)
member AsyncRPC :
        node : ErlAtom *
        mod : string *
        fun : string *
        args : ErlList *
        ioServer : ErlPid *
        ?remoteCookie : Nullable<ErlAtom>
(* Defaults:
        let _remoteCookie = defaultArg remoteCookie null
*)
-> unit
member AsyncRPC :
        node : ErlAtom *
        mod : string *
        fun : string *
        args : ErlList *
        ioServer : ErlPid *
        ?remoteCookie : Nullable<ErlAtom>
(* Defaults:
        let _remoteCookie = defaultArg remoteCookie null
*)
-> unit

Parameters

node
Type: NFX.Erlang ErlAtom
mod
Type: Online System String
fun
Type: Online System String
args
Type: NFX.Erlang ErlList
ioServer
Type: NFX.Erlang ErlPid
remoteCookie (Optional)
Type: Online System Nullable ErlAtom
See Also
ErlMbox Class
ErlMbox Members
AsyncRPC Overload
NFX.Erlang Namespace


ErlMbox.BreakLinks Method

ErlMbox BreakLinks Method NFX Class Library

Overload List
 | Name | Description
Protected method | BreakLinks(ErlAtom) | Used to break all known links to this mbox
Protected method | BreakLinks(ErlAtom, IErlObject) | Used to break all known links to this mbox
Back to Top
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.BreakLinks Method (ErlAtom)

ErlMbox BreakLinks Method (ErlAtom) NFX Class Library

Used to break all known links to this mbox

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void BreakLinks(
    ErlAtom reason
)
internal void BreakLinks(
    ErlAtom reason
)
Friend Sub BreakLinks (
    reason As ErlAtom
)
Friend Sub BreakLinks (
    reason As ErlAtom
)
internal:
void BreakLinks(
    ErlAtom reason
)
internal:
void BreakLinks(
    ErlAtom reason
)
internal member BreakLinks :
        reason : ErlAtom -> unit
internal member BreakLinks :
        reason : ErlAtom -> unit

Parameters

reason
Type: NFX.Erlang ErlAtom
See Also
ErlMbox Class
ErlMbox Members
BreakLinks Overload
NFX.Erlang Namespace


ErlMbox.BreakLinks Method (ErlAtom, IErlObject)

ErlMbox BreakLinks Method (ErlAtom, IErlObject) NFX Class Library

[This is preliminary documentation and is subject to change.]

Used to break all known links to this mbox

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void BreakLinks(
    ErlAtom fromNode,
    IErlObject reason
)
internal void BreakLinks(
    ErlAtom fromNode,
    IErlObject reason
)
Friend Sub BreakLinks (
    fromNode As ErlAtom,
    reason As IErlObject
)
Friend Sub BreakLinks (
    fromNode As ErlAtom,
    reason As IErlObject
)
internal:
void BreakLinks(
    ErlAtom fromNode,
    IErlObject^ reason
)
internal:
void BreakLinks(
    ErlAtom fromNode,
    IErlObject^ reason
)
internal member BreakLinks :
        fromNode : ErlAtom *
        reason : IErlObject -> unit
internal member BreakLinks :
        fromNode : ErlAtom *
        reason : IErlObject -> unit

Parameters

fromNode
Type: NFX.Erlang ErlAtom
reason
Type: NFX.Erlang IErlObject
See Also
ErlMbox Class
ErlMbox Members
BreakLinks Overload
NFX.Erlang Namespace


ErlMbox.Clear Method

ErlMbox Clear Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
void Clear()
public:
void Clear()
member Clear : unit -> unit
member Clear : unit -> unit
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.Close Method

ErlMbox Close Method NFX Class Library

Close this mailbox

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Close()
internal void Close()
Friend Sub Close
Friend Sub Close
internal:
void Close()
internal:
void Close()
internal member Close : unit -> unit
internal member Close : unit -> unit
Remarks
After this operation, the mailbox will no longer be able to receive messages. Any delivered but as yet unretrieved messages can still be retrieved however. If there are links from this mailbox to other ErlPid pids they will be broken when this method is called and exit signals will be sent.
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.Deliver Method

ErlMbox Deliver Method NFX Class Library

Overload List
 | Name | Description
Protected method | Deliver(ErlConnectionException) |
Protected method | Deliver(ErlMsg) | Called to deliver message to this mailbox
Back to Top
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.Deliver Method (ErlConnectionException)

ErlMbox Deliver Method (ErlConnectionException) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Deliver(
    ErlConnectionException e
)
internal void Deliver(
    ErlConnectionException e
)
Friend Sub Deliver (
    e As ErlConnectionException
)
Friend Sub Deliver (
    e As ErlConnectionException
)
internal:
void Deliver(
    ErlConnectionException^ e
)
internal:
void Deliver(
    ErlConnectionException^ e
)
internal member Deliver :
        e : ErlConnectionException -> unit
internal member Deliver :
        e : ErlConnectionException -> unit

Parameters

e
Type: NFX.Erlang ErlConnectionException
See Also
ErlMbox Class
ErlMbox Members
Deliver Overload
NFX.Erlang Namespace


ErlMbox.Deliver Method (ErlMsg)

ErlMbox Deliver Method (ErlMsg) NFX Class Library

Called to deliver message to this mailbox

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Deliver(
    ErlMsg m
)
internal void Deliver(
    ErlMsg m
)
Friend Sub Deliver (
    m As ErlMsg
)
Friend Sub Deliver (
    m As ErlMsg
)
internal:
void Deliver(
    ErlMsg^ m
)
internal:
void Deliver(
    ErlMsg^ m
)
internal member Deliver :
        m : ErlMsg -> unit
internal member Deliver :
        m : ErlMsg -> unit

Parameters

m
Type: NFX.Erlang ErlMsg
See Also
ErlMbox Class
ErlMbox Members
Deliver Overload
NFX.Erlang Namespace


ErlMbox.Dequeue Method

ErlMbox Dequeue Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IQueable Dequeue(
    int timeout = -1
)
protected IQueable Dequeue(
    int timeout = -1
)
Protected Function Dequeue (
    Optional timeout As Integer = -1
) As IQueable
Protected Function Dequeue (
    Optional timeout As Integer = -1
) As IQueable
protected:
IQueable^ Dequeue(
    int timeout = -1
)
protected:
IQueable^ Dequeue(
    int timeout = -1
)
member Dequeue :
        ?timeout : int
(* Defaults:
        let _timeout = defaultArg timeout -1
*)
-> IQueable
member Dequeue :
        ?timeout : int
(* Defaults:
        let _timeout = defaultArg timeout -1
*)
-> IQueable

Parameters

timeout (Optional)
Type: Online System Int32

Return Value

Type: IQueable
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.Destructor Method

ErlMbox Destructor Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.Down Method

ErlMbox Down Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Down(
    ErlRef eref,
    ErlPid pid,
    ErlAtom reason
)
public void Down(
    ErlRef eref,
    ErlPid pid,
    ErlAtom reason
)
Public Sub Down (
    eref As ErlRef,
    pid As ErlPid,
    reason As ErlAtom
)
Public Sub Down (
    eref As ErlRef,
    pid As ErlPid,
    reason As ErlAtom
)
public:
void Down(
    ErlRef eref,
    ErlPid pid,
    ErlAtom reason
)
public:
void Down(
    ErlRef eref,
    ErlPid pid,
    ErlAtom reason
)
member Down :
        eref : ErlRef *
        pid : ErlPid *
        reason : ErlAtom -> unit
member Down :
        eref : ErlRef *
        pid : ErlPid *
        reason : ErlAtom -> unit

Parameters

eref
Type: NFX.Erlang ErlRef
pid
Type: NFX.Erlang ErlPid
reason
Type: NFX.Erlang ErlAtom
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.Enqueue Method

ErlMbox Enqueue Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void Enqueue(
    IQueable data
)
protected void Enqueue(
    IQueable data
)
Protected Sub Enqueue (
    data As IQueable
)
Protected Sub Enqueue (
    data As IQueable
)
protected:
void Enqueue(
    IQueable^ data
)
protected:
void Enqueue(
    IQueable^ data
)
member Enqueue :
        data : IQueable -> unit
member Enqueue :
        data : IQueable -> unit

Parameters

data
Type: NFX.Erlang IQueable
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.Equals Method

ErlMbox Equals Method NFX Class Library

Determine if two mailboxes are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals (
    o As Object
) As Boolean
Public Overrides Function Equals (
    o As Object
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool

Parameters

o
Type: Online System Object

Return Value

Type: Online Boolean
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.GetHashCode Method

ErlMbox GetHashCode Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.Link Method

ErlMbox Link Method NFX Class Library

Link to a remote mailbox or Erlang process. Links are idempotent, calling this method multiple times will not result in more than one link being created

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Link(
    ErlPid to
)
public void Link(
    ErlPid to
)
Public Sub Link (
    to As ErlPid
)
Public Sub Link (
    to As ErlPid
)
public:
void Link(
    ErlPid to
)
public:
void Link(
    ErlPid to
)
member Link :
        to : ErlPid -> unit
member Link :
        to : ErlPid -> unit

Parameters

to
Type: NFX.Erlang ErlPid
Remarks
If the remote process subsequently exits or the mailbox is closed, a subsequent attempt to retrieve a message through this mailbox will cause an {@link Exit Exit} exception to be raised. Similarly, if the sending mailbox is closed, the linked mailbox or process will receive an exit signal. If the remote process cannot be reached in order to set the link, the exception is raised immediately.
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.OnMailboxMessage Method

ErlMbox OnMailboxMessage Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool OnMailboxMessage(
    IQueable msg
)
protected virtual bool OnMailboxMessage(
    IQueable msg
)
Protected Overridable Function OnMailboxMessage (
    msg As IQueable
) As Boolean
Protected Overridable Function OnMailboxMessage (
    msg As IQueable
) As Boolean
protected:
virtual bool OnMailboxMessage(
    IQueable^ msg
)
protected:
virtual bool OnMailboxMessage(
    IQueable^ msg
)
abstract OnMailboxMessage :
        msg : IQueable -> bool
override OnMailboxMessage :
        msg : IQueable -> bool
abstract OnMailboxMessage :
        msg : IQueable -> bool
override OnMailboxMessage :
        msg : IQueable -> bool

Parameters

msg
Type: NFX.Erlang IQueable

Return Value

Type: Online Boolean
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.Receive Method

ErlMbox Receive Method NFX Class Library

Wait for a message to arrive for this mailbox. On timeout return null

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject Receive(
    int timeout = -1
)
public IErlObject Receive(
    int timeout = -1
)
Public Function Receive (
    Optional timeout As Integer = -1
) As IErlObject
Public Function Receive (
    Optional timeout As Integer = -1
) As IErlObject
public:
IErlObject^ Receive(
    int timeout = -1
)
public:
IErlObject^ Receive(
    int timeout = -1
)
member Receive :
        ?timeout : int
(* Defaults:
        let _timeout = defaultArg timeout -1
*)
-> IErlObject
member Receive :
        ?timeout : int
(* Defaults:
        let _timeout = defaultArg timeout -1
*)
-> IErlObject

Parameters

timeout (Optional)
Type: Online System Int32
Timeout time in milliseconds

Return Value

Type: IErlObject
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.receiveBuf Method

ErlMbox receiveBuf Method NFX Class Library

Wait for a message to arrive for this mailbox

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlInputStream receiveBuf(
    int timeout
)
public ErlInputStream receiveBuf(
    int timeout
)
Public Function receiveBuf (
    timeout As Integer
) As ErlInputStream
Public Function receiveBuf (
    timeout As Integer
) As ErlInputStream
public:
ErlInputStream^ receiveBuf(
    int timeout
)
public:
ErlInputStream^ receiveBuf(
    int timeout
)
member receiveBuf :
        timeout : int -> ErlInputStream
member receiveBuf :
        timeout : int -> ErlInputStream

Parameters

timeout
Type: Online System Int32
time in milliseconds

Return Value

Type: ErlInputStream
a stream representing the still-encoded body of the next message waiting in this mailbox, or null on timeout
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.ReceiveMatch Method

ErlMbox ReceiveMatch Method NFX Class Library

Overload List
 | Name | Description
Public method | ReceiveMatch(ErlPatternMatcher, Int32) | Receive a message and match it against a given pattern
Public method | ReceiveMatch(IErlObject, Int32) | Receive a message and match it against a given pattern
Back to Top
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.ReceiveMatch Method (ErlPatternMatcher, Int32)

ErlMbox ReceiveMatch Method (ErlPatternMatcher, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Receive a message and match it against a given pattern

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Tuple<IErlObject, int> ReceiveMatch(
    ErlPatternMatcher pm,
    int timeoutMsec = -1
)
public Tuple<IErlObject, int> ReceiveMatch(
    ErlPatternMatcher pm,
    int timeoutMsec = -1
)
Public Function ReceiveMatch (
    pm As ErlPatternMatcher,
    Optional timeoutMsec As Integer = -1
) As Tuple(Of IErlObject, Integer)
Public Function ReceiveMatch (
    pm As ErlPatternMatcher,
    Optional timeoutMsec As Integer = -1
) As Tuple(Of IErlObject, Integer)
public:
Tuple<IErlObject^, int>^ ReceiveMatch(
    ErlPatternMatcher^ pm,
    int timeoutMsec = -1
)
public:
Tuple<IErlObject^, int>^ ReceiveMatch(
    ErlPatternMatcher^ pm,
    int timeoutMsec = -1
)
member ReceiveMatch :
        pm : ErlPatternMatcher *
        ?timeoutMsec : int
(* Defaults:
        let _timeoutMsec = defaultArg timeoutMsec -1
*)
-> Tuple<IErlObject, int>
member ReceiveMatch :
        pm : ErlPatternMatcher *
        ?timeoutMsec : int
(* Defaults:
        let _timeoutMsec = defaultArg timeoutMsec -1
*)
-> Tuple<IErlObject, int>

Parameters

pm
Type: NFX.Erlang ErlPatternMatcher
Patterns to match the message against
timeoutMsec (Optional)
Type: Online System Int32
Timeout in milliseconds

Return Value

Type: Online Tuple IErlObject, Online Int32
Return a tuple containing the received message and index of the pattern in the pm instance that was successfully matched. On timeout the 2nd element of the tuple is -2 and 1st element of the tuple is null. On unsuccessful match the second element of the tuple is -1
See Also
ErlMbox Class
ErlMbox Members
ReceiveMatch Overload
NFX.Erlang Namespace


ErlMbox.ReceiveMatch Method (IErlObject, Int32)

ErlMbox ReceiveMatch Method (IErlObject, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Receive a message and match it against a given pattern

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Tuple<IErlObject, ErlVarBind> ReceiveMatch(
    IErlObject pattern,
    int timeoutMsec = -1
)
public Tuple<IErlObject, ErlVarBind> ReceiveMatch(
    IErlObject pattern,
    int timeoutMsec = -1
)
Public Function ReceiveMatch (
    pattern As IErlObject,
    Optional timeoutMsec As Integer = -1
) As Tuple(Of IErlObject, ErlVarBind)
Public Function ReceiveMatch (
    pattern As IErlObject,
    Optional timeoutMsec As Integer = -1
) As Tuple(Of IErlObject, ErlVarBind)
public:
Tuple<IErlObject^, ErlVarBind^>^ ReceiveMatch(
    IErlObject^ pattern,
    int timeoutMsec = -1
)
public:
Tuple<IErlObject^, ErlVarBind^>^ ReceiveMatch(
    IErlObject^ pattern,
    int timeoutMsec = -1
)
member ReceiveMatch :
        pattern : IErlObject *
        ?timeoutMsec : int
(* Defaults:
        let _timeoutMsec = defaultArg timeoutMsec -1
*)
-> Tuple<IErlObject, ErlVarBind>
member ReceiveMatch :
        pattern : IErlObject *
        ?timeoutMsec : int
(* Defaults:
        let _timeoutMsec = defaultArg timeoutMsec -1
*)
-> Tuple<IErlObject, ErlVarBind>

Parameters

pattern
Type: NFX.Erlang IErlObject
Pattern to match the message against
timeoutMsec (Optional)
Type: Online System Int32
Timeout in milliseconds

Return Value

Type: Online Tuple IErlObject, ErlVarBind
Return a tuple containing the received message and variable binding object. On timeout the first element of the tuple is null. On unsuccessful match the second element of the tuple is null
See Also
ErlMbox Class
ErlMbox Members
ReceiveMatch Overload
NFX.Erlang Namespace


ErlMbox.ReceiveRPC Method

ErlMbox ReceiveRPC Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject ReceiveRPC(
    int timeout = -1
)
public IErlObject ReceiveRPC(
    int timeout = -1
)
Public Function ReceiveRPC (
    Optional timeout As Integer = -1
) As IErlObject
Public Function ReceiveRPC (
    Optional timeout As Integer = -1
) As IErlObject
public:
IErlObject^ ReceiveRPC(
    int timeout = -1
)
public:
IErlObject^ ReceiveRPC(
    int timeout = -1
)
member ReceiveRPC :
        ?timeout : int
(* Defaults:
        let _timeout = defaultArg timeout -1
*)
-> IErlObject
member ReceiveRPC :
        ?timeout : int
(* Defaults:
        let _timeout = defaultArg timeout -1
*)
-> IErlObject

Parameters

timeout (Optional)
Type: Online System Int32

Return Value

Type: IErlObject
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.Register Method

ErlMbox Register Method NFX Class Library

Overload List
 | Name | Description
Public method | Register(String) | Register a name for this mailbox. Registering a name for a mailbox enables others to send messages without knowing the ErlPid of the mailbox. A mailbox can have at most one name; if the mailbox already had a name, calling this method will supercede that name
Public method | Register(ErlAtom) |
Back to Top
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.Register Method (String)

ErlMbox Register Method (String) NFX Class Library

Register a name for this mailbox. Registering a name for a mailbox enables others to send messages without knowing the ErlPid of the mailbox. A mailbox can have at most one name; if the mailbox already had a name, calling this method will supercede that name

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Register(
    string name
)
public bool Register(
    string name
)
Public Function Register (
    name As String
) As Boolean
Public Function Register (
    name As String
) As Boolean
public:
bool Register(
    String^ name
)
public:
bool Register(
    String^ name
)
member Register :
        name : string -> bool
member Register :
        name : string -> bool

Parameters

name
Type: Online System String

Return Value

Type: Online Boolean
true if the name was available, or false otherwise
See Also
ErlMbox Class
ErlMbox Members
Register Overload
NFX.Erlang Namespace


ErlMbox.Register Method (ErlAtom)

ErlMbox Register Method (ErlAtom) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Register(
    ErlAtom name
)
public bool Register(
    ErlAtom name
)
Public Function Register (
    name As ErlAtom
) As Boolean
Public Function Register (
    name As ErlAtom
) As Boolean
public:
bool Register(
    ErlAtom name
)
public:
bool Register(
    ErlAtom name
)
member Register :
        name : ErlAtom -> bool
member Register :
        name : ErlAtom -> bool

Parameters

name
Type: NFX.Erlang ErlAtom

Return Value

Type: Online Boolean
See Also
ErlMbox Class
ErlMbox Members
Register Overload
NFX.Erlang Namespace


ErlMbox.RPC Method

ErlMbox RPC Method NFX Class Library

Overload List
 | Name | Description
Public method | RPC(ErlAtom, ErlAtom, ErlAtom, ErlList, Nullable ErlAtom ) |
Public method | RPC(ErlAtom, String, String, ErlList, Nullable ErlAtom ) |
Public method | RPC(ErlAtom, ErlAtom, ErlAtom, ErlList, Int32, Nullable ErlAtom ) |
Public method | RPC(ErlAtom, String, String, ErlList, Int32, Nullable ErlAtom ) |
Back to Top
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.RPC Method (ErlAtom, ErlAtom, ErlAtom, ErlList, Nullable(ErlAtom))

ErlMbox RPC Method (ErlAtom, ErlAtom, ErlAtom, ErlList, Nullable ErlAtom ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject RPC(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList args,
    Nullable<ErlAtom> remoteCookie = null
)
public IErlObject RPC(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList args,
    Nullable<ErlAtom> remoteCookie = null
)
Public Function RPC (
    node As ErlAtom,
    mod As ErlAtom,
    fun As ErlAtom,
    args As ErlList,
    Optional remoteCookie As Nullable(Of ErlAtom) = Nothing
) As IErlObject
Public Function RPC (
    node As ErlAtom,
    mod As ErlAtom,
    fun As ErlAtom,
    args As ErlList,
    Optional remoteCookie As Nullable(Of ErlAtom) = Nothing
) As IErlObject
public:
IErlObject^ RPC(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList^ args,
    Nullable<ErlAtom> remoteCookie = nullptr
)
public:
IErlObject^ RPC(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList^ args,
    Nullable<ErlAtom> remoteCookie = nullptr
)
member RPC :
        node : ErlAtom *
        mod : ErlAtom *
        fun : ErlAtom *
        args : ErlList *
        ?remoteCookie : Nullable<ErlAtom>
(* Defaults:
        let _remoteCookie = defaultArg remoteCookie null
*)
-> IErlObject
member RPC :
        node : ErlAtom *
        mod : ErlAtom *
        fun : ErlAtom *
        args : ErlList *
        ?remoteCookie : Nullable<ErlAtom>
(* Defaults:
        let _remoteCookie = defaultArg remoteCookie null
*)
-> IErlObject

Parameters

node
Type: NFX.Erlang ErlAtom
mod
Type: NFX.Erlang ErlAtom
fun
Type: NFX.Erlang ErlAtom
args
Type: NFX.Erlang ErlList
remoteCookie (Optional)
Type: Online System Nullable ErlAtom

Return Value

Type: IErlObject
See Also
ErlMbox Class
ErlMbox Members
RPC Overload
NFX.Erlang Namespace


ErlMbox.RPC Method (ErlAtom, String, String, ErlList, Nullable(ErlAtom))

ErlMbox RPC Method (ErlAtom, String, String, ErlList, Nullable ErlAtom ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject RPC(
    ErlAtom node,
    string mod,
    string fun,
    ErlList args,
    Nullable<ErlAtom> remoteCookie = null
)
public IErlObject RPC(
    ErlAtom node,
    string mod,
    string fun,
    ErlList args,
    Nullable<ErlAtom> remoteCookie = null
)
Public Function RPC (
    node As ErlAtom,
    mod As String,
    fun As String,
    args As ErlList,
    Optional remoteCookie As Nullable(Of ErlAtom) = Nothing
) As IErlObject
Public Function RPC (
    node As ErlAtom,
    mod As String,
    fun As String,
    args As ErlList,
    Optional remoteCookie As Nullable(Of ErlAtom) = Nothing
) As IErlObject
public:
IErlObject^ RPC(
    ErlAtom node,
    String^ mod,
    String^ fun,
    ErlList^ args,
    Nullable<ErlAtom> remoteCookie = nullptr
)
public:
IErlObject^ RPC(
    ErlAtom node,
    String^ mod,
    String^ fun,
    ErlList^ args,
    Nullable<ErlAtom> remoteCookie = nullptr
)
member RPC :
        node : ErlAtom *
        mod : string *
        fun : string *
        args : ErlList *
        ?remoteCookie : Nullable<ErlAtom>
(* Defaults:
        let _remoteCookie = defaultArg remoteCookie null
*)
-> IErlObject
member RPC :
        node : ErlAtom *
        mod : string *
        fun : string *
        args : ErlList *
        ?remoteCookie : Nullable<ErlAtom>
(* Defaults:
        let _remoteCookie = defaultArg remoteCookie null
*)
-> IErlObject

Parameters

node
Type: NFX.Erlang ErlAtom
mod
Type: Online System String
fun
Type: Online System String
args
Type: NFX.Erlang ErlList
remoteCookie (Optional)
Type: Online System Nullable ErlAtom

Return Value

Type: IErlObject
See Also
ErlMbox Class
ErlMbox Members
RPC Overload
NFX.Erlang Namespace


ErlMbox.RPC Method (ErlAtom, ErlAtom, ErlAtom, ErlList, Int32, Nullable(ErlAtom))

ErlMbox RPC Method (ErlAtom, ErlAtom, ErlAtom, ErlList, Int32, Nullable ErlAtom ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject RPC(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList args,
    int timeout,
    Nullable<ErlAtom> remoteCookie = null
)
public IErlObject RPC(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList args,
    int timeout,
    Nullable<ErlAtom> remoteCookie = null
)
Public Function RPC (
    node As ErlAtom,
    mod As ErlAtom,
    fun As ErlAtom,
    args As ErlList,
    timeout As Integer,
    Optional remoteCookie As Nullable(Of ErlAtom) = Nothing
) As IErlObject
Public Function RPC (
    node As ErlAtom,
    mod As ErlAtom,
    fun As ErlAtom,
    args As ErlList,
    timeout As Integer,
    Optional remoteCookie As Nullable(Of ErlAtom) = Nothing
) As IErlObject
public:
IErlObject^ RPC(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList^ args,
    int timeout,
    Nullable<ErlAtom> remoteCookie = nullptr
)
public:
IErlObject^ RPC(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList^ args,
    int timeout,
    Nullable<ErlAtom> remoteCookie = nullptr
)
member RPC :
        node : ErlAtom *
        mod : ErlAtom *
        fun : ErlAtom *
        args : ErlList *
        timeout : int *
        ?remoteCookie : Nullable<ErlAtom>
(* Defaults:
        let _remoteCookie = defaultArg remoteCookie null
*)
-> IErlObject
member RPC :
        node : ErlAtom *
        mod : ErlAtom *
        fun : ErlAtom *
        args : ErlList *
        timeout : int *
        ?remoteCookie : Nullable<ErlAtom>
(* Defaults:
        let _remoteCookie = defaultArg remoteCookie null
*)
-> IErlObject

Parameters

node
Type: NFX.Erlang ErlAtom
mod
Type: NFX.Erlang ErlAtom
fun
Type: NFX.Erlang ErlAtom
args
Type: NFX.Erlang ErlList
timeout
Type: Online System Int32
remoteCookie (Optional)
Type: Online System Nullable ErlAtom

Return Value

Type: IErlObject
See Also
ErlMbox Class
ErlMbox Members
RPC Overload
NFX.Erlang Namespace


ErlMbox.RPC Method (ErlAtom, String, String, ErlList, Int32, Nullable(ErlAtom))

ErlMbox RPC Method (ErlAtom, String, String, ErlList, Int32, Nullable ErlAtom ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject RPC(
    ErlAtom node,
    string mod,
    string fun,
    ErlList args,
    int timeout,
    Nullable<ErlAtom> remoteCookie = null
)
public IErlObject RPC(
    ErlAtom node,
    string mod,
    string fun,
    ErlList args,
    int timeout,
    Nullable<ErlAtom> remoteCookie = null
)
Public Function RPC (
    node As ErlAtom,
    mod As String,
    fun As String,
    args As ErlList,
    timeout As Integer,
    Optional remoteCookie As Nullable(Of ErlAtom) = Nothing
) As IErlObject
Public Function RPC (
    node As ErlAtom,
    mod As String,
    fun As String,
    args As ErlList,
    timeout As Integer,
    Optional remoteCookie As Nullable(Of ErlAtom) = Nothing
) As IErlObject
public:
IErlObject^ RPC(
    ErlAtom node,
    String^ mod,
    String^ fun,
    ErlList^ args,
    int timeout,
    Nullable<ErlAtom> remoteCookie = nullptr
)
public:
IErlObject^ RPC(
    ErlAtom node,
    String^ mod,
    String^ fun,
    ErlList^ args,
    int timeout,
    Nullable<ErlAtom> remoteCookie = nullptr
)
member RPC :
        node : ErlAtom *
        mod : string *
        fun : string *
        args : ErlList *
        timeout : int *
        ?remoteCookie : Nullable<ErlAtom>
(* Defaults:
        let _remoteCookie = defaultArg remoteCookie null
*)
-> IErlObject
member RPC :
        node : ErlAtom *
        mod : string *
        fun : string *
        args : ErlList *
        timeout : int *
        ?remoteCookie : Nullable<ErlAtom>
(* Defaults:
        let _remoteCookie = defaultArg remoteCookie null
*)
-> IErlObject

Parameters

node
Type: NFX.Erlang ErlAtom
mod
Type: Online System String
fun
Type: Online System String
args
Type: NFX.Erlang ErlList
timeout
Type: Online System Int32
remoteCookie (Optional)
Type: Online System Nullable ErlAtom

Return Value

Type: IErlObject
See Also
ErlMbox Class
ErlMbox Members
RPC Overload
NFX.Erlang Namespace


ErlMbox.RPCcast Method

ErlMbox RPCcast Method NFX Class Library

Overload List
 | Name | Description
Public method | RPCcast(ErlAtom, ErlAtom, ErlAtom, ErlList) |
Public method | RPCcast(ErlAtom, ErlAtom, ErlAtom, ErlList, IErlObject) |
Back to Top
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.RPCcast Method (ErlAtom, ErlAtom, ErlAtom, ErlList)

ErlMbox RPCcast Method (ErlAtom, ErlAtom, ErlAtom, ErlList) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RPCcast(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList args
)
public void RPCcast(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList args
)
Public Sub RPCcast (
    node As ErlAtom,
    mod As ErlAtom,
    fun As ErlAtom,
    args As ErlList
)
Public Sub RPCcast (
    node As ErlAtom,
    mod As ErlAtom,
    fun As ErlAtom,
    args As ErlList
)
public:
void RPCcast(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList^ args
)
public:
void RPCcast(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList^ args
)
member RPCcast :
        node : ErlAtom *
        mod : ErlAtom *
        fun : ErlAtom *
        args : ErlList -> unit
member RPCcast :
        node : ErlAtom *
        mod : ErlAtom *
        fun : ErlAtom *
        args : ErlList -> unit

Parameters

node
Type: NFX.Erlang ErlAtom
mod
Type: NFX.Erlang ErlAtom
fun
Type: NFX.Erlang ErlAtom
args
Type: NFX.Erlang ErlList
See Also
ErlMbox Class
ErlMbox Members
RPCcast Overload
NFX.Erlang Namespace


ErlMbox.RPCcast Method (ErlAtom, ErlAtom, ErlAtom, ErlList, IErlObject)

ErlMbox RPCcast Method (ErlAtom, ErlAtom, ErlAtom, ErlList, IErlObject) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RPCcast(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList args,
    IErlObject ioServer
)
public void RPCcast(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList args,
    IErlObject ioServer
)
Public Sub RPCcast (
    node As ErlAtom,
    mod As ErlAtom,
    fun As ErlAtom,
    args As ErlList,
    ioServer As IErlObject
)
Public Sub RPCcast (
    node As ErlAtom,
    mod As ErlAtom,
    fun As ErlAtom,
    args As ErlList,
    ioServer As IErlObject
)
public:
void RPCcast(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList^ args,
    IErlObject^ ioServer
)
public:
void RPCcast(
    ErlAtom node,
    ErlAtom mod,
    ErlAtom fun,
    ErlList^ args,
    IErlObject^ ioServer
)
member RPCcast :
        node : ErlAtom *
        mod : ErlAtom *
        fun : ErlAtom *
        args : ErlList *
        ioServer : IErlObject -> unit
member RPCcast :
        node : ErlAtom *
        mod : ErlAtom *
        fun : ErlAtom *
        args : ErlList *
        ioServer : IErlObject -> unit

Parameters

node
Type: NFX.Erlang ErlAtom
mod
Type: NFX.Erlang ErlAtom
fun
Type: NFX.Erlang ErlAtom
args
Type: NFX.Erlang ErlList
ioServer
Type: NFX.Erlang IErlObject
See Also
ErlMbox Class
ErlMbox Members
RPCcast Overload
NFX.Erlang Namespace


ErlMbox.Send Method

ErlMbox Send Method NFX Class Library

Send a message to a named mailbox created from another node

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Send(
    ErlAtom node,
    ErlAtom name,
    IErlObject msg
)
public bool Send(
    ErlAtom node,
    ErlAtom name,
    IErlObject msg
)
Public Function Send (
    node As ErlAtom,
    name As ErlAtom,
    msg As IErlObject
) As Boolean
Public Function Send (
    node As ErlAtom,
    name As ErlAtom,
    msg As IErlObject
) As Boolean
public:
bool Send(
    ErlAtom node,
    ErlAtom name,
    IErlObject^ msg
)
public:
bool Send(
    ErlAtom node,
    ErlAtom name,
    IErlObject^ msg
)
member Send :
        node : ErlAtom *
        name : ErlAtom *
        msg : IErlObject -> bool
member Send :
        node : ErlAtom *
        name : ErlAtom *
        msg : IErlObject -> bool

Parameters

node
Type: NFX.Erlang ErlAtom
name
Type: NFX.Erlang ErlAtom
msg
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.Unlink Method

ErlMbox Unlink Method NFX Class Library

Remove a link to a remote mailbox or Erlang process. This method removes a link created with ErlLink Links are idempotent; calling this method once will remove all links between this mailbox and the remote ErlPid

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Unlink(
    ErlPid to
)
public void Unlink(
    ErlPid to
)
Public Sub Unlink (
    to As ErlPid
)
Public Sub Unlink (
    to As ErlPid
)
public:
void Unlink(
    ErlPid to
)
public:
void Unlink(
    ErlPid to
)
member Unlink :
        to : ErlPid -> unit
member Unlink :
        to : ErlPid -> unit

Parameters

to
Type: NFX.Erlang ErlPid
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox Properties

ErlMbox Properties NFX Class Library

The ErlMbox type exposes the following members.
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Empty | Return true if there are no messages waiting in the receive queue of this connection
Public property | Handle | Queue not empty status notification handle
Protected property | LastUsed | Timestamps when this mailbox was last used - this is used internally by mailbox caching
Public property | MsgCount | Return the number of messages currently waiting in the receive queue of this connection
Public property | Name | Get the registered name of this mailbox, or string.Empty if the mailbox doesn't have a registered name
Public property | Node |
Public property | QueueActive |
Public property | Self | Get the Pid identifying associated with this mailbox
Back to Top
See Also
ErlMbox Class
NFX.Erlang Namespace


ErlMbox.Empty Property

ErlMbox Empty Property NFX Class Library

Return true if there are no messages waiting in the receive queue of this connection

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Empty { get; }
public bool Empty { get; }
Public ReadOnly Property Empty As Boolean
    Get
Public ReadOnly Property Empty As Boolean
    Get
public:
property bool Empty {
    bool get ();
}
public:
property bool Empty {
    bool get ();
}
member Empty : bool with get
member Empty : bool with get

Property Value

Type: Online Boolean
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.Handle Property

ErlMbox Handle Property NFX Class Library

Queue not empty status notification handle

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WaitHandle Handle { get; }
public WaitHandle Handle { get; }
Public ReadOnly Property Handle As WaitHandle
    Get
Public ReadOnly Property Handle As WaitHandle
    Get
public:
property WaitHandle^ Handle {
    WaitHandle^ get ();
}
public:
property WaitHandle^ Handle {
    WaitHandle^ get ();
}
member Handle : WaitHandle with get
member Handle : WaitHandle with get

Property Value

Type: Online WaitHandle
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.LastUsed Property

ErlMbox LastUsed Property NFX Class Library

Timestamps when this mailbox was last used - this is used internally by mailbox caching

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal DateTime LastUsed { get; set; }
internal DateTime LastUsed { get; set; }
Friend Property LastUsed As DateTime
    Get
    Set
Friend Property LastUsed As DateTime
    Get
    Set
internal:
property DateTime LastUsed {
    DateTime get ();
    void set (DateTime value);
}
internal:
property DateTime LastUsed {
    DateTime get ();
    void set (DateTime value);
}
internal member LastUsed : DateTime with get, set
internal member LastUsed : DateTime with get, set

Property Value

Type: Online DateTime
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.MsgCount Property

ErlMbox MsgCount Property NFX Class Library

Return the number of messages currently waiting in the receive queue of this connection

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MsgCount { get; }
public int MsgCount { get; }
Public ReadOnly Property MsgCount As Integer
    Get
Public ReadOnly Property MsgCount As Integer
    Get
public:
property int MsgCount {
    int get ();
}
public:
property int MsgCount {
    int get ();
}
member MsgCount : int with get
member MsgCount : int with get

Property Value

Type: Online Int32
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.Name Property

ErlMbox Name Property NFX Class Library

Get the registered name of this mailbox, or string.Empty if the mailbox doesn't have a registered name

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlAtom Name { get; }
public ErlAtom Name { get; }
Public ReadOnly Property Name As ErlAtom
    Get
Public ReadOnly Property Name As ErlAtom
    Get
public:
property ErlAtom Name {
    ErlAtom get ();
}
public:
property ErlAtom Name {
    ErlAtom get ();
}
member Name : ErlAtom with get
member Name : ErlAtom with get

Return Value

Type: ErlAtom
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.Node Property

ErlMbox Node Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlLocalNode Node { get; }
public ErlLocalNode Node { get; }
Public ReadOnly Property Node As ErlLocalNode
    Get
Public ReadOnly Property Node As ErlLocalNode
    Get
public:
property ErlLocalNode^ Node {
    ErlLocalNode^ get ();
}
public:
property ErlLocalNode^ Node {
    ErlLocalNode^ get ();
}
member Node : ErlLocalNode with get
member Node : ErlLocalNode with get

Property Value

Type: ErlLocalNode
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.QueueActive Property

ErlMbox QueueActive Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool QueueActive { get; }
public bool QueueActive { get; }
Public ReadOnly Property QueueActive As Boolean
    Get
Public ReadOnly Property QueueActive As Boolean
    Get
public:
property bool QueueActive {
    bool get ();
}
public:
property bool QueueActive {
    bool get ();
}
member QueueActive : bool with get
member QueueActive : bool with get

Property Value

Type: Online Boolean
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox.Self Property

ErlMbox Self Property NFX Class Library

Get the Pid identifying associated with this mailbox

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlPid Self { get; }
public ErlPid Self { get; }
Public ReadOnly Property Self As ErlPid
    Get
Public ReadOnly Property Self As ErlPid
    Get
public:
property ErlPid Self {
    ErlPid get ();
}
public:
property ErlPid Self {
    ErlPid get ();
}
member Self : ErlPid with get
member Self : ErlPid with get

Property Value

Type: ErlPid
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMbox Events

ErlMbox Events NFX Class Library

The ErlMbox type exposes the following members.
Events
 | Name | Description
Public event | MailboxMessage | If this event is assigned, it will be called on arrival of a message, but the messages will not be put in the queue
Back to Top
See Also
ErlMbox Class
NFX.Erlang Namespace


ErlMbox.MailboxMessage Event

ErlMbox MailboxMessage Event NFX Class Library

If this event is assigned, it will be called on arrival of a message, but the messages will not be put in the queue

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event MailboxMsgEventHandler MailboxMessage
public event MailboxMsgEventHandler MailboxMessage
Public Event MailboxMessage As MailboxMsgEventHandler
Public Event MailboxMessage As MailboxMsgEventHandler
public:
 event MailboxMsgEventHandler^ MailboxMessage {
    void add (MailboxMsgEventHandler^ value);
    void remove (MailboxMsgEventHandler^ value);
}
public:
 event MailboxMsgEventHandler^ MailboxMessage {
    void add (MailboxMsgEventHandler^ value);
    void remove (MailboxMsgEventHandler^ value);
}
member MailboxMessage : IEvent<MailboxMsgEventHandler,
    EventArgs>
member MailboxMessage : IEvent<MailboxMsgEventHandler,
    EventArgs>

Value

Type: NFX.Erlang MailboxMsgEventHandler
See Also
ErlMbox Class
ErlMbox Members
NFX.Erlang Namespace


ErlMsg Class

ErlMsg Class NFX Class Library

Provides a distributed carrier for Erlang messages
Inheritance Hierarchy
Online System Object
NFX.Erlang ErlMsg

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ErlMsg : IQueable
public class ErlMsg : IQueable
Public Class ErlMsg
    Implements IQueable
Public Class ErlMsg
    Implements IQueable
public ref class ErlMsg : IQueable
public ref class ErlMsg : IQueable
type ErlMsg =
    class
        interface IQueable
    end
type ErlMsg =
    class
        interface IQueable
    end
Remarks
Instances of this class are created to package header and payload information in received Erlang messages so that the recipient can obtain both parts with a single call to receiveMsg The header information that is available is as follows:
  • a tag indicating the type of message
  • the intended recipient of the message, either as a ErlPid or as a ErlAtom, but never both.
  • (sometimes) the sender of the message. Due to some eccentric characteristics of the Erlang distribution protocol, not all messages have information about the sending process. In particular, only messages whose tag is RegSend contain sender information.
Message are sent using the Erlang external format (see separate documentation). When a message is received and delivered to the recipient ErlMbox, the body of the message is still in this external representation until Msg is called, at which point the message is decoded. A copy of the decoded message is stored in the OtpMsg so that subsequent calls to Msg do not require that the message be decoded a second time.
See Also
ErlMsg Members
NFX.Erlang Namespace


ErlMsg Members

ErlMsg Members NFX Class Library

The ErlMsg type exposes the following members.
Constructors
 | Name | Description
Protected method | ErlMsg | Initializes a new instance of the ErlMsg class
Back to Top
Methods
 | Name | Description
 | DemonitorP |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
 | Exit |
 | Exit2 |
 | Exit2TT |
 | ExitTT |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | GroupLeader |
 | Link |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | MonitorP |
 | MonitorPexit |
 | NodeLink |
 | RegSend |
 | RegSendTT |
 | Send |
 | SendTT |
Protected method | ToCtrlTuple |
Protected method | ToCtrlTuple(ErlAtom) |
 | ToCtrlTuple(ErlMsg) |
Public method | ToString | (Overrides Online Object ToString .)
 | Unlink |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Cookie | Contains cookie if it is to be sent or was received in the message
Public field | Paybuf | The payload of this deserialized message
Public field | Reason | Reason associated with some messages
Public field | Ref | Returns reference contained in this message
Public field | TraceToken | Trace token delivered in the message
Public field | Type | The type of message
Back to Top
Properties
 | Name | Description
Public property | HasSender | Returns true if the message has a non-empty sender
Public property | Msg | Deserialized Erlang message contained in this instance
Protected property | Payload |
Public property | Recipient | Get the recipient for this message, as a Pid or a registered name (Atom)
Public property | RecipientName | Get the name of the recipient for this message
Public property | RecipientPid | Get the Pid of the recipient for this message, if it is a Send message
Public property | Sender | Get the sender for this message, as a Pid or a registered name (Atom)
Public property | SenderName |
Public property | SenderPid | Returns pid of the sender (may be empty, i.e. SenderPid.Empty == true)
Back to Top
See Also
ErlMsg Class
NFX.Erlang Namespace


ErlMsg Constructor

ErlMsg Constructor NFX Class Library

Initializes a new instance of the ErlMsg class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ErlMsg(
    ErlMsg..::..Tag tag,
    IErlObject from,
    IErlObject to,
    Nullable<ErlRef> eref = null,
    IErlObject reason = null,
    IErlObject payload = null,
    ErlInputStream paybuf = null,
    Nullable<ErlAtom> cookie = null,
    ErlTrace trace = null
)
internal ErlMsg(
    ErlMsg..::..Tag tag,
    IErlObject from,
    IErlObject to,
    Nullable<ErlRef> eref = null,
    IErlObject reason = null,
    IErlObject payload = null,
    ErlInputStream paybuf = null,
    Nullable<ErlAtom> cookie = null,
    ErlTrace trace = null
)
Friend Sub New (
    tag As ErlMsg..::..Tag,
    from As IErlObject,
    to As IErlObject,
    Optional eref As Nullable(Of ErlRef) = Nothing,
    Optional reason As IErlObject = Nothing,
    Optional payload As IErlObject = Nothing,
    Optional paybuf As ErlInputStream = Nothing,
    Optional cookie As Nullable(Of ErlAtom) = Nothing,
    Optional trace As ErlTrace = Nothing
)
Friend Sub New (
    tag As ErlMsg..::..Tag,
    from As IErlObject,
    to As IErlObject,
    Optional eref As Nullable(Of ErlRef) = Nothing,
    Optional reason As IErlObject = Nothing,
    Optional payload As IErlObject = Nothing,
    Optional paybuf As ErlInputStream = Nothing,
    Optional cookie As Nullable(Of ErlAtom) = Nothing,
    Optional trace As ErlTrace = Nothing
)
internal:
ErlMsg(
    ErlMsg..::..Tag tag,
    IErlObject^ from,
    IErlObject^ to,
    Nullable<ErlRef> eref = nullptr,
    IErlObject^ reason = nullptr,
    IErlObject^ payload = nullptr,
    ErlInputStream^ paybuf = nullptr,
    Nullable<ErlAtom> cookie = nullptr,
    ErlTrace^ trace = nullptr
)
internal:
ErlMsg(
    ErlMsg..::..Tag tag,
    IErlObject^ from,
    IErlObject^ to,
    Nullable<ErlRef> eref = nullptr,
    IErlObject^ reason = nullptr,
    IErlObject^ payload = nullptr,
    ErlInputStream^ paybuf = nullptr,
    Nullable<ErlAtom> cookie = nullptr,
    ErlTrace^ trace = nullptr
)
new :
        tag : ErlMsg..::..Tag *
        from : IErlObject *
        to : IErlObject *
        ?eref : Nullable<ErlRef> *
        ?reason : IErlObject *
        ?payload : IErlObject *
        ?paybuf : ErlInputStream *
        ?cookie : Nullable<ErlAtom> *
        ?trace : ErlTrace
(* Defaults:
        let _eref = defaultArg eref null
        let _reason = defaultArg reason null
        let _payload = defaultArg payload null
        let _paybuf = defaultArg paybuf null
        let _cookie = defaultArg cookie null
        let _trace = defaultArg trace null
*)
-> ErlMsg
new :
        tag : ErlMsg..::..Tag *
        from : IErlObject *
        to : IErlObject *
        ?eref : Nullable<ErlRef> *
        ?reason : IErlObject *
        ?payload : IErlObject *
        ?paybuf : ErlInputStream *
        ?cookie : Nullable<ErlAtom> *
        ?trace : ErlTrace
(* Defaults:
        let _eref = defaultArg eref null
        let _reason = defaultArg reason null
        let _payload = defaultArg payload null
        let _paybuf = defaultArg paybuf null
        let _cookie = defaultArg cookie null
        let _trace = defaultArg trace null
*)
-> ErlMsg

Parameters

tag
Type: NFX.Erlang ErlMsg Tag
from
Type: NFX.Erlang IErlObject
to
Type: NFX.Erlang IErlObject
eref (Optional)
Type: Online System Nullable ErlRef
reason (Optional)
Type: NFX.Erlang IErlObject
payload (Optional)
Type: NFX.Erlang IErlObject
paybuf (Optional)
Type: NFX.Erlang ErlInputStream
cookie (Optional)
Type: Online System Nullable ErlAtom
trace (Optional)
Type: NFX.Erlang ErlTrace
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg Fields

ErlMsg Fields NFX Class Library

The ErlMsg type exposes the following members.
Fields
 | Name | Description
Public field | Cookie | Contains cookie if it is to be sent or was received in the message
Public field | Paybuf | The payload of this deserialized message
Public field | Reason | Reason associated with some messages
Public field | Ref | Returns reference contained in this message
Public field | TraceToken | Trace token delivered in the message
Public field | Type | The type of message
Back to Top
See Also
ErlMsg Class
NFX.Erlang Namespace


ErlMsg.Cookie Field

ErlMsg Cookie Field NFX Class Library

Contains cookie if it is to be sent or was received in the message

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ErlAtom Cookie
public readonly ErlAtom Cookie
Public ReadOnly Cookie As ErlAtom
Public ReadOnly Cookie As ErlAtom
public:
initonly ErlAtom Cookie
public:
initonly ErlAtom Cookie
val Cookie: ErlAtom
val Cookie: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.Paybuf Field

ErlMsg Paybuf Field NFX Class Library

The payload of this deserialized message

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ErlInputStream Paybuf
public readonly ErlInputStream Paybuf
Public ReadOnly Paybuf As ErlInputStream
Public ReadOnly Paybuf As ErlInputStream
public:
initonly ErlInputStream^ Paybuf
public:
initonly ErlInputStream^ Paybuf
val Paybuf: ErlInputStream
val Paybuf: ErlInputStream

Field Value

Type: ErlInputStream
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.Reason Field

ErlMsg Reason Field NFX Class Library

Reason associated with some messages

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly IErlObject Reason
public readonly IErlObject Reason
Public ReadOnly Reason As IErlObject
Public ReadOnly Reason As IErlObject
public:
initonly IErlObject^ Reason
public:
initonly IErlObject^ Reason
val Reason: IErlObject
val Reason: IErlObject

Field Value

Type: IErlObject
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.Ref Field

ErlMsg Ref Field NFX Class Library

Returns reference contained in this message

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ErlRef Ref
public readonly ErlRef Ref
Public ReadOnly Ref As ErlRef
Public ReadOnly Ref As ErlRef
public:
initonly ErlRef Ref
public:
initonly ErlRef Ref
val Ref: ErlRef
val Ref: ErlRef

Field Value

Type: ErlRef
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.TraceToken Field

ErlMsg TraceToken Field NFX Class Library

Trace token delivered in the message

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ErlTrace TraceToken
public readonly ErlTrace TraceToken
Public ReadOnly TraceToken As ErlTrace
Public ReadOnly TraceToken As ErlTrace
public:
initonly ErlTrace^ TraceToken
public:
initonly ErlTrace^ TraceToken
val TraceToken: ErlTrace
val TraceToken: ErlTrace

Field Value

Type: ErlTrace
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.Type Field

ErlMsg Type Field NFX Class Library

The type of message

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ErlMsg..::..Tag Type
public readonly ErlMsg..::..Tag Type
Public ReadOnly Type As ErlMsg..::..Tag
Public ReadOnly Type As ErlMsg..::..Tag
public:
initonly ErlMsg..::..Tag Type
public:
initonly ErlMsg..::..Tag Type
val Type: ErlMsg..::..Tag
val Type: ErlMsg..::..Tag

Field Value

Type: ErlMsg Tag
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg Methods

ErlMsg Methods NFX Class Library

The ErlMsg type exposes the following members.
Methods
 | Name | Description
 | DemonitorP |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
 | Exit |
 | Exit2 |
 | Exit2TT |
 | ExitTT |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | GroupLeader |
 | Link |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | MonitorP |
 | MonitorPexit |
 | NodeLink |
 | RegSend |
 | RegSendTT |
 | Send |
 | SendTT |
Protected method | ToCtrlTuple |
Protected method | ToCtrlTuple(ErlAtom) |
 | ToCtrlTuple(ErlMsg) |
Public method | ToString | (Overrides Online Object ToString .)
 | Unlink |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ErlMsg Class
NFX.Erlang Namespace


ErlMsg.DemonitorP Method

ErlMsg DemonitorP Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static ErlMsg DemonitorP(
    ErlPid from,
    IErlObject dest,
    ErlRef eref
)
internal static ErlMsg DemonitorP(
    ErlPid from,
    IErlObject dest,
    ErlRef eref
)
Friend Shared Function DemonitorP (
    from As ErlPid,
    dest As IErlObject,
    eref As ErlRef
) As ErlMsg
Friend Shared Function DemonitorP (
    from As ErlPid,
    dest As IErlObject,
    eref As ErlRef
) As ErlMsg
internal:
static ErlMsg^ DemonitorP(
    ErlPid from,
    IErlObject^ dest,
    ErlRef eref
)
internal:
static ErlMsg^ DemonitorP(
    ErlPid from,
    IErlObject^ dest,
    ErlRef eref
)
internal static member DemonitorP :
        from : ErlPid *
        dest : IErlObject *
        eref : ErlRef -> ErlMsg
internal static member DemonitorP :
        from : ErlPid *
        dest : IErlObject *
        eref : ErlRef -> ErlMsg

Parameters

from
Type: NFX.Erlang ErlPid
dest
Type: NFX.Erlang IErlObject
eref
Type: NFX.Erlang ErlRef

Return Value

Type: ErlMsg
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.Exit Method

ErlMsg Exit Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static ErlMsg Exit(
    ErlPid from,
    ErlPid dest,
    IErlObject reason
)
internal static ErlMsg Exit(
    ErlPid from,
    ErlPid dest,
    IErlObject reason
)
Friend Shared Function Exit (
    from As ErlPid,
    dest As ErlPid,
    reason As IErlObject
) As ErlMsg
Friend Shared Function Exit (
    from As ErlPid,
    dest As ErlPid,
    reason As IErlObject
) As ErlMsg
internal:
static ErlMsg^ Exit(
    ErlPid from,
    ErlPid dest,
    IErlObject^ reason
)
internal:
static ErlMsg^ Exit(
    ErlPid from,
    ErlPid dest,
    IErlObject^ reason
)
internal static member Exit :
        from : ErlPid *
        dest : ErlPid *
        reason : IErlObject -> ErlMsg
internal static member Exit :
        from : ErlPid *
        dest : ErlPid *
        reason : IErlObject -> ErlMsg

Parameters

from
Type: NFX.Erlang ErlPid
dest
Type: NFX.Erlang ErlPid
reason
Type: NFX.Erlang IErlObject

Return Value

Type: ErlMsg
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.Exit2 Method

ErlMsg Exit2 Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static ErlMsg Exit2(
    ErlPid from,
    ErlPid dest,
    IErlObject reason
)
internal static ErlMsg Exit2(
    ErlPid from,
    ErlPid dest,
    IErlObject reason
)
Friend Shared Function Exit2 (
    from As ErlPid,
    dest As ErlPid,
    reason As IErlObject
) As ErlMsg
Friend Shared Function Exit2 (
    from As ErlPid,
    dest As ErlPid,
    reason As IErlObject
) As ErlMsg
internal:
static ErlMsg^ Exit2(
    ErlPid from,
    ErlPid dest,
    IErlObject^ reason
)
internal:
static ErlMsg^ Exit2(
    ErlPid from,
    ErlPid dest,
    IErlObject^ reason
)
internal static member Exit2 :
        from : ErlPid *
        dest : ErlPid *
        reason : IErlObject -> ErlMsg
internal static member Exit2 :
        from : ErlPid *
        dest : ErlPid *
        reason : IErlObject -> ErlMsg

Parameters

from
Type: NFX.Erlang ErlPid
dest
Type: NFX.Erlang ErlPid
reason
Type: NFX.Erlang IErlObject

Return Value

Type: ErlMsg
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.Exit2TT Method

ErlMsg Exit2TT Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static ErlMsg Exit2TT(
    ErlPid from,
    ErlPid dest,
    IErlObject reason,
    ErlTrace traceToken
)
internal static ErlMsg Exit2TT(
    ErlPid from,
    ErlPid dest,
    IErlObject reason,
    ErlTrace traceToken
)
Friend Shared Function Exit2TT (
    from As ErlPid,
    dest As ErlPid,
    reason As IErlObject,
    traceToken As ErlTrace
) As ErlMsg
Friend Shared Function Exit2TT (
    from As ErlPid,
    dest As ErlPid,
    reason As IErlObject,
    traceToken As ErlTrace
) As ErlMsg
internal:
static ErlMsg^ Exit2TT(
    ErlPid from,
    ErlPid dest,
    IErlObject^ reason,
    ErlTrace^ traceToken
)
internal:
static ErlMsg^ Exit2TT(
    ErlPid from,
    ErlPid dest,
    IErlObject^ reason,
    ErlTrace^ traceToken
)
internal static member Exit2TT :
        from : ErlPid *
        dest : ErlPid *
        reason : IErlObject *
        traceToken : ErlTrace -> ErlMsg
internal static member Exit2TT :
        from : ErlPid *
        dest : ErlPid *
        reason : IErlObject *
        traceToken : ErlTrace -> ErlMsg

Parameters

from
Type: NFX.Erlang ErlPid
dest
Type: NFX.Erlang ErlPid
reason
Type: NFX.Erlang IErlObject
traceToken
Type: NFX.Erlang ErlTrace

Return Value

Type: ErlMsg
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.ExitTT Method

ErlMsg ExitTT Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static ErlMsg ExitTT(
    ErlPid from,
    ErlPid dest,
    IErlObject reason,
    ErlTrace traceToken
)
internal static ErlMsg ExitTT(
    ErlPid from,
    ErlPid dest,
    IErlObject reason,
    ErlTrace traceToken
)
Friend Shared Function ExitTT (
    from As ErlPid,
    dest As ErlPid,
    reason As IErlObject,
    traceToken As ErlTrace
) As ErlMsg
Friend Shared Function ExitTT (
    from As ErlPid,
    dest As ErlPid,
    reason As IErlObject,
    traceToken As ErlTrace
) As ErlMsg
internal:
static ErlMsg^ ExitTT(
    ErlPid from,
    ErlPid dest,
    IErlObject^ reason,
    ErlTrace^ traceToken
)
internal:
static ErlMsg^ ExitTT(
    ErlPid from,
    ErlPid dest,
    IErlObject^ reason,
    ErlTrace^ traceToken
)
internal static member ExitTT :
        from : ErlPid *
        dest : ErlPid *
        reason : IErlObject *
        traceToken : ErlTrace -> ErlMsg
internal static member ExitTT :
        from : ErlPid *
        dest : ErlPid *
        reason : IErlObject *
        traceToken : ErlTrace -> ErlMsg

Parameters

from
Type: NFX.Erlang ErlPid
dest
Type: NFX.Erlang ErlPid
reason
Type: NFX.Erlang IErlObject
traceToken
Type: NFX.Erlang ErlTrace

Return Value

Type: ErlMsg
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.GroupLeader Method

ErlMsg GroupLeader Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static ErlMsg GroupLeader(
    ErlPid from,
    ErlPid dest
)
internal static ErlMsg GroupLeader(
    ErlPid from,
    ErlPid dest
)
Friend Shared Function GroupLeader (
    from As ErlPid,
    dest As ErlPid
) As ErlMsg
Friend Shared Function GroupLeader (
    from As ErlPid,
    dest As ErlPid
) As ErlMsg
internal:
static ErlMsg^ GroupLeader(
    ErlPid from,
    ErlPid dest
)
internal:
static ErlMsg^ GroupLeader(
    ErlPid from,
    ErlPid dest
)
internal static member GroupLeader :
        from : ErlPid *
        dest : ErlPid -> ErlMsg
internal static member GroupLeader :
        from : ErlPid *
        dest : ErlPid -> ErlMsg

Parameters

from
Type: NFX.Erlang ErlPid
dest
Type: NFX.Erlang ErlPid

Return Value

Type: ErlMsg
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.Link Method

ErlMsg Link Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static ErlMsg Link(
    ErlPid from,
    ErlPid dest
)
internal static ErlMsg Link(
    ErlPid from,
    ErlPid dest
)
Friend Shared Function Link (
    from As ErlPid,
    dest As ErlPid
) As ErlMsg
Friend Shared Function Link (
    from As ErlPid,
    dest As ErlPid
) As ErlMsg
internal:
static ErlMsg^ Link(
    ErlPid from,
    ErlPid dest
)
internal:
static ErlMsg^ Link(
    ErlPid from,
    ErlPid dest
)
internal static member Link :
        from : ErlPid *
        dest : ErlPid -> ErlMsg
internal static member Link :
        from : ErlPid *
        dest : ErlPid -> ErlMsg

Parameters

from
Type: NFX.Erlang ErlPid
dest
Type: NFX.Erlang ErlPid

Return Value

Type: ErlMsg
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.MonitorP Method

ErlMsg MonitorP Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static ErlMsg MonitorP(
    ErlPid from,
    IErlObject dest,
    ErlRef eref
)
internal static ErlMsg MonitorP(
    ErlPid from,
    IErlObject dest,
    ErlRef eref
)
Friend Shared Function MonitorP (
    from As ErlPid,
    dest As IErlObject,
    eref As ErlRef
) As ErlMsg
Friend Shared Function MonitorP (
    from As ErlPid,
    dest As IErlObject,
    eref As ErlRef
) As ErlMsg
internal:
static ErlMsg^ MonitorP(
    ErlPid from,
    IErlObject^ dest,
    ErlRef eref
)
internal:
static ErlMsg^ MonitorP(
    ErlPid from,
    IErlObject^ dest,
    ErlRef eref
)
internal static member MonitorP :
        from : ErlPid *
        dest : IErlObject *
        eref : ErlRef -> ErlMsg
internal static member MonitorP :
        from : ErlPid *
        dest : IErlObject *
        eref : ErlRef -> ErlMsg

Parameters

from
Type: NFX.Erlang ErlPid
dest
Type: NFX.Erlang IErlObject
eref
Type: NFX.Erlang ErlRef

Return Value

Type: ErlMsg
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.MonitorPexit Method

ErlMsg MonitorPexit Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static ErlMsg MonitorPexit(
    IErlObject from,
    ErlPid dest,
    ErlRef eref,
    IErlObject reason
)
internal static ErlMsg MonitorPexit(
    IErlObject from,
    ErlPid dest,
    ErlRef eref,
    IErlObject reason
)
Friend Shared Function MonitorPexit (
    from As IErlObject,
    dest As ErlPid,
    eref As ErlRef,
    reason As IErlObject
) As ErlMsg
Friend Shared Function MonitorPexit (
    from As IErlObject,
    dest As ErlPid,
    eref As ErlRef,
    reason As IErlObject
) As ErlMsg
internal:
static ErlMsg^ MonitorPexit(
    IErlObject^ from,
    ErlPid dest,
    ErlRef eref,
    IErlObject^ reason
)
internal:
static ErlMsg^ MonitorPexit(
    IErlObject^ from,
    ErlPid dest,
    ErlRef eref,
    IErlObject^ reason
)
internal static member MonitorPexit :
        from : IErlObject *
        dest : ErlPid *
        eref : ErlRef *
        reason : IErlObject -> ErlMsg
internal static member MonitorPexit :
        from : IErlObject *
        dest : ErlPid *
        eref : ErlRef *
        reason : IErlObject -> ErlMsg

Parameters

from
Type: NFX.Erlang IErlObject
dest
Type: NFX.Erlang ErlPid
eref
Type: NFX.Erlang ErlRef
reason
Type: NFX.Erlang IErlObject

Return Value

Type: ErlMsg
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.NodeLink Method

ErlMsg NodeLink Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static ErlMsg NodeLink()
internal static ErlMsg NodeLink()
Friend Shared Function NodeLink As ErlMsg
Friend Shared Function NodeLink As ErlMsg
internal:
static ErlMsg^ NodeLink()
internal:
static ErlMsg^ NodeLink()
internal static member NodeLink : unit -> ErlMsg
internal static member NodeLink : unit -> ErlMsg

Return Value

Type: ErlMsg
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.RegSend Method

ErlMsg RegSend Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static ErlMsg RegSend(
    ErlPid from,
    ErlAtom dest,
    IErlObject msg,
    Nullable<ErlAtom> cookie = null
)
internal static ErlMsg RegSend(
    ErlPid from,
    ErlAtom dest,
    IErlObject msg,
    Nullable<ErlAtom> cookie = null
)
Friend Shared Function RegSend (
    from As ErlPid,
    dest As ErlAtom,
    msg As IErlObject,
    Optional cookie As Nullable(Of ErlAtom) = Nothing
) As ErlMsg
Friend Shared Function RegSend (
    from As ErlPid,
    dest As ErlAtom,
    msg As IErlObject,
    Optional cookie As Nullable(Of ErlAtom) = Nothing
) As ErlMsg
internal:
static ErlMsg^ RegSend(
    ErlPid from,
    ErlAtom dest,
    IErlObject^ msg,
    Nullable<ErlAtom> cookie = nullptr
)
internal:
static ErlMsg^ RegSend(
    ErlPid from,
    ErlAtom dest,
    IErlObject^ msg,
    Nullable<ErlAtom> cookie = nullptr
)
internal static member RegSend :
        from : ErlPid *
        dest : ErlAtom *
        msg : IErlObject *
        ?cookie : Nullable<ErlAtom>
(* Defaults:
        let _cookie = defaultArg cookie null
*)
-> ErlMsg
internal static member RegSend :
        from : ErlPid *
        dest : ErlAtom *
        msg : IErlObject *
        ?cookie : Nullable<ErlAtom>
(* Defaults:
        let _cookie = defaultArg cookie null
*)
-> ErlMsg

Parameters

from
Type: NFX.Erlang ErlPid
dest
Type: NFX.Erlang ErlAtom
msg
Type: NFX.Erlang IErlObject
cookie (Optional)
Type: Online System Nullable ErlAtom

Return Value

Type: ErlMsg
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.RegSendTT Method

ErlMsg RegSendTT Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static ErlMsg RegSendTT(
    ErlPid from,
    ErlAtom dest,
    IErlObject msg,
    ErlTrace trace,
    Nullable<ErlAtom> cookie = null
)
internal static ErlMsg RegSendTT(
    ErlPid from,
    ErlAtom dest,
    IErlObject msg,
    ErlTrace trace,
    Nullable<ErlAtom> cookie = null
)
Friend Shared Function RegSendTT (
    from As ErlPid,
    dest As ErlAtom,
    msg As IErlObject,
    trace As ErlTrace,
    Optional cookie As Nullable(Of ErlAtom) = Nothing
) As ErlMsg
Friend Shared Function RegSendTT (
    from As ErlPid,
    dest As ErlAtom,
    msg As IErlObject,
    trace As ErlTrace,
    Optional cookie As Nullable(Of ErlAtom) = Nothing
) As ErlMsg
internal:
static ErlMsg^ RegSendTT(
    ErlPid from,
    ErlAtom dest,
    IErlObject^ msg,
    ErlTrace^ trace,
    Nullable<ErlAtom> cookie = nullptr
)
internal:
static ErlMsg^ RegSendTT(
    ErlPid from,
    ErlAtom dest,
    IErlObject^ msg,
    ErlTrace^ trace,
    Nullable<ErlAtom> cookie = nullptr
)
internal static member RegSendTT :
        from : ErlPid *
        dest : ErlAtom *
        msg : IErlObject *
        trace : ErlTrace *
        ?cookie : Nullable<ErlAtom>
(* Defaults:
        let _cookie = defaultArg cookie null
*)
-> ErlMsg
internal static member RegSendTT :
        from : ErlPid *
        dest : ErlAtom *
        msg : IErlObject *
        trace : ErlTrace *
        ?cookie : Nullable<ErlAtom>
(* Defaults:
        let _cookie = defaultArg cookie null
*)
-> ErlMsg

Parameters

from
Type: NFX.Erlang ErlPid
dest
Type: NFX.Erlang ErlAtom
msg
Type: NFX.Erlang IErlObject
trace
Type: NFX.Erlang ErlTrace
cookie (Optional)
Type: Online System Nullable ErlAtom

Return Value

Type: ErlMsg
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.Send Method

ErlMsg Send Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static ErlMsg Send(
    ErlPid dest,
    IErlObject msg,
    Nullable<ErlAtom> cookie = null
)
internal static ErlMsg Send(
    ErlPid dest,
    IErlObject msg,
    Nullable<ErlAtom> cookie = null
)
Friend Shared Function Send (
    dest As ErlPid,
    msg As IErlObject,
    Optional cookie As Nullable(Of ErlAtom) = Nothing
) As ErlMsg
Friend Shared Function Send (
    dest As ErlPid,
    msg As IErlObject,
    Optional cookie As Nullable(Of ErlAtom) = Nothing
) As ErlMsg
internal:
static ErlMsg^ Send(
    ErlPid dest,
    IErlObject^ msg,
    Nullable<ErlAtom> cookie = nullptr
)
internal:
static ErlMsg^ Send(
    ErlPid dest,
    IErlObject^ msg,
    Nullable<ErlAtom> cookie = nullptr
)
internal static member Send :
        dest : ErlPid *
        msg : IErlObject *
        ?cookie : Nullable<ErlAtom>
(* Defaults:
        let _cookie = defaultArg cookie null
*)
-> ErlMsg
internal static member Send :
        dest : ErlPid *
        msg : IErlObject *
        ?cookie : Nullable<ErlAtom>
(* Defaults:
        let _cookie = defaultArg cookie null
*)
-> ErlMsg

Parameters

dest
Type: NFX.Erlang ErlPid
msg
Type: NFX.Erlang IErlObject
cookie (Optional)
Type: Online System Nullable ErlAtom

Return Value

Type: ErlMsg
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.SendTT Method

ErlMsg SendTT Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static ErlMsg SendTT(
    ErlPid dest,
    IErlObject msg,
    ErlTrace traceToken,
    Nullable<ErlAtom> cookie = null
)
internal static ErlMsg SendTT(
    ErlPid dest,
    IErlObject msg,
    ErlTrace traceToken,
    Nullable<ErlAtom> cookie = null
)
Friend Shared Function SendTT (
    dest As ErlPid,
    msg As IErlObject,
    traceToken As ErlTrace,
    Optional cookie As Nullable(Of ErlAtom) = Nothing
) As ErlMsg
Friend Shared Function SendTT (
    dest As ErlPid,
    msg As IErlObject,
    traceToken As ErlTrace,
    Optional cookie As Nullable(Of ErlAtom) = Nothing
) As ErlMsg
internal:
static ErlMsg^ SendTT(
    ErlPid dest,
    IErlObject^ msg,
    ErlTrace^ traceToken,
    Nullable<ErlAtom> cookie = nullptr
)
internal:
static ErlMsg^ SendTT(
    ErlPid dest,
    IErlObject^ msg,
    ErlTrace^ traceToken,
    Nullable<ErlAtom> cookie = nullptr
)
internal static member SendTT :
        dest : ErlPid *
        msg : IErlObject *
        traceToken : ErlTrace *
        ?cookie : Nullable<ErlAtom>
(* Defaults:
        let _cookie = defaultArg cookie null
*)
-> ErlMsg
internal static member SendTT :
        dest : ErlPid *
        msg : IErlObject *
        traceToken : ErlTrace *
        ?cookie : Nullable<ErlAtom>
(* Defaults:
        let _cookie = defaultArg cookie null
*)
-> ErlMsg

Parameters

dest
Type: NFX.Erlang ErlPid
msg
Type: NFX.Erlang IErlObject
traceToken
Type: NFX.Erlang ErlTrace
cookie (Optional)
Type: Online System Nullable ErlAtom

Return Value

Type: ErlMsg
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.ToCtrlTuple Method

ErlMsg ToCtrlTuple Method NFX Class Library

Overload List
 | Name | Description
Protected method | ToCtrlTuple |
Protected method | ToCtrlTuple(ErlAtom) |
 | ToCtrlTuple(ErlMsg) |
Back to Top
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.ToCtrlTuple Method

ErlMsg ToCtrlTuple Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ErlTuple ToCtrlTuple()
internal ErlTuple ToCtrlTuple()
Friend Function ToCtrlTuple As ErlTuple
Friend Function ToCtrlTuple As ErlTuple
internal:
ErlTuple^ ToCtrlTuple()
internal:
ErlTuple^ ToCtrlTuple()
internal member ToCtrlTuple : unit -> ErlTuple
internal member ToCtrlTuple : unit -> ErlTuple

Return Value

Type: ErlTuple
See Also
ErlMsg Class
ErlMsg Members
ToCtrlTuple Overload
NFX.Erlang Namespace


ErlMsg.ToCtrlTuple Method (ErlAtom)

ErlMsg ToCtrlTuple Method (ErlAtom) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ErlTuple ToCtrlTuple(
    ErlAtom cookie
)
internal ErlTuple ToCtrlTuple(
    ErlAtom cookie
)
Friend Function ToCtrlTuple (
    cookie As ErlAtom
) As ErlTuple
Friend Function ToCtrlTuple (
    cookie As ErlAtom
) As ErlTuple
internal:
ErlTuple^ ToCtrlTuple(
    ErlAtom cookie
)
internal:
ErlTuple^ ToCtrlTuple(
    ErlAtom cookie
)
internal member ToCtrlTuple :
        cookie : ErlAtom -> ErlTuple
internal member ToCtrlTuple :
        cookie : ErlAtom -> ErlTuple

Parameters

cookie
Type: NFX.Erlang ErlAtom

Return Value

Type: ErlTuple
See Also
ErlMsg Class
ErlMsg Members
ToCtrlTuple Overload
NFX.Erlang Namespace


ErlMsg.ToCtrlTuple Method (ErlMsg)

ErlMsg ToCtrlTuple Method (ErlMsg) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static ErlTuple ToCtrlTuple(
    ErlMsg msg
)
internal static ErlTuple ToCtrlTuple(
    ErlMsg msg
)
Friend Shared Function ToCtrlTuple (
    msg As ErlMsg
) As ErlTuple
Friend Shared Function ToCtrlTuple (
    msg As ErlMsg
) As ErlTuple
internal:
static ErlTuple^ ToCtrlTuple(
    ErlMsg^ msg
)
internal:
static ErlTuple^ ToCtrlTuple(
    ErlMsg^ msg
)
internal static member ToCtrlTuple :
        msg : ErlMsg -> ErlTuple
internal static member ToCtrlTuple :
        msg : ErlMsg -> ErlTuple

Parameters

msg
Type: NFX.Erlang ErlMsg

Return Value

Type: ErlTuple
See Also
ErlMsg Class
ErlMsg Members
ToCtrlTuple Overload
NFX.Erlang Namespace


ErlMsg.ToString Method

ErlMsg ToString Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.Unlink Method

ErlMsg Unlink Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static ErlMsg Unlink(
    ErlPid from,
    ErlPid dest
)
internal static ErlMsg Unlink(
    ErlPid from,
    ErlPid dest
)
Friend Shared Function Unlink (
    from As ErlPid,
    dest As ErlPid
) As ErlMsg
Friend Shared Function Unlink (
    from As ErlPid,
    dest As ErlPid
) As ErlMsg
internal:
static ErlMsg^ Unlink(
    ErlPid from,
    ErlPid dest
)
internal:
static ErlMsg^ Unlink(
    ErlPid from,
    ErlPid dest
)
internal static member Unlink :
        from : ErlPid *
        dest : ErlPid -> ErlMsg
internal static member Unlink :
        from : ErlPid *
        dest : ErlPid -> ErlMsg

Parameters

from
Type: NFX.Erlang ErlPid
dest
Type: NFX.Erlang ErlPid

Return Value

Type: ErlMsg
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg Properties

ErlMsg Properties NFX Class Library

The ErlMsg type exposes the following members.
Properties
 | Name | Description
Public property | HasSender | Returns true if the message has a non-empty sender
Public property | Msg | Deserialized Erlang message contained in this instance
Protected property | Payload |
Public property | Recipient | Get the recipient for this message, as a Pid or a registered name (Atom)
Public property | RecipientName | Get the name of the recipient for this message
Public property | RecipientPid | Get the Pid of the recipient for this message, if it is a Send message
Public property | Sender | Get the sender for this message, as a Pid or a registered name (Atom)
Public property | SenderName |
Public property | SenderPid | Returns pid of the sender (may be empty, i.e. SenderPid.Empty == true)
Back to Top
See Also
ErlMsg Class
NFX.Erlang Namespace


ErlMsg.HasSender Property

ErlMsg HasSender Property NFX Class Library

Returns true if the message has a non-empty sender

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasSender { get; }
public bool HasSender { get; }
Public ReadOnly Property HasSender As Boolean
    Get
Public ReadOnly Property HasSender As Boolean
    Get
public:
property bool HasSender {
    bool get ();
}
public:
property bool HasSender {
    bool get ();
}
member HasSender : bool with get
member HasSender : bool with get

Property Value

Type: Online Boolean
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.Msg Property

ErlMsg Msg Property NFX Class Library

Deserialized Erlang message contained in this instance

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject Msg { get; }
public IErlObject Msg { get; }
Public ReadOnly Property Msg As IErlObject
    Get
Public ReadOnly Property Msg As IErlObject
    Get
public:
property IErlObject^ Msg {
    IErlObject^ get ();
}
public:
property IErlObject^ Msg {
    IErlObject^ get ();
}
member Msg : IErlObject with get
member Msg : IErlObject with get

Property Value

Type: IErlObject
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.Payload Property

ErlMsg Payload Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal IErlObject Payload { get; }
internal IErlObject Payload { get; }
Friend ReadOnly Property Payload As IErlObject
    Get
Friend ReadOnly Property Payload As IErlObject
    Get
internal:
property IErlObject^ Payload {
    IErlObject^ get ();
}
internal:
property IErlObject^ Payload {
    IErlObject^ get ();
}
internal member Payload : IErlObject with get
internal member Payload : IErlObject with get

Property Value

Type: IErlObject
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.Recipient Property

ErlMsg Recipient Property NFX Class Library

Get the recipient for this message, as a Pid or a registered name (Atom)

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject Recipient { get; }
public IErlObject Recipient { get; }
Public ReadOnly Property Recipient As IErlObject
    Get
Public ReadOnly Property Recipient As IErlObject
    Get
public:
property IErlObject^ Recipient {
    IErlObject^ get ();
}
public:
property IErlObject^ Recipient {
    IErlObject^ get ();
}
member Recipient : IErlObject with get
member Recipient : IErlObject with get

Property Value

Type: IErlObject
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.RecipientName Property

ErlMsg RecipientName Property NFX Class Library

Get the name of the recipient for this message

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlAtom RecipientName { get; }
public ErlAtom RecipientName { get; }
Public ReadOnly Property RecipientName As ErlAtom
    Get
Public ReadOnly Property RecipientName As ErlAtom
    Get
public:
property ErlAtom RecipientName {
    ErlAtom get ();
}
public:
property ErlAtom RecipientName {
    ErlAtom get ();
}
member RecipientName : ErlAtom with get
member RecipientName : ErlAtom with get

Property Value

Type: ErlAtom
Remarks
Messages are sent to Pids or names. If this message was sent to a name then the name is returned by this method
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.RecipientPid Property

ErlMsg RecipientPid Property NFX Class Library

Get the Pid of the recipient for this message, if it is a Send message

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlPid RecipientPid { get; }
public ErlPid RecipientPid { get; }
Public ReadOnly Property RecipientPid As ErlPid
    Get
Public ReadOnly Property RecipientPid As ErlPid
    Get
public:
property ErlPid RecipientPid {
    ErlPid get ();
}
public:
property ErlPid RecipientPid {
    ErlPid get ();
}
member RecipientPid : ErlPid with get
member RecipientPid : ErlPid with get

Property Value

Type: ErlPid
Remarks
Messages are sent to Pids or names. If this message was sent to a Pid then the Pid is returned by this method. The recipient Pid is also available for link, unlink and exit messages
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.Sender Property

ErlMsg Sender Property NFX Class Library

Get the sender for this message, as a Pid or a registered name (Atom)

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject Sender { get; }
public IErlObject Sender { get; }
Public ReadOnly Property Sender As IErlObject
    Get
Public ReadOnly Property Sender As IErlObject
    Get
public:
property IErlObject^ Sender {
    IErlObject^ get ();
}
public:
property IErlObject^ Sender {
    IErlObject^ get ();
}
member Sender : IErlObject with get
member Sender : IErlObject with get

Property Value

Type: IErlObject
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.SenderName Property

ErlMsg SenderName Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlAtom SenderName { get; internal set; }
public ErlAtom SenderName { get; internal set; }
Public Property SenderName As ErlAtom
    Get
    Friend Set
Public Property SenderName As ErlAtom
    Get
    Friend Set
public:
property ErlAtom SenderName {
    ErlAtom get ();
    internal: void set (ErlAtom value);
}
public:
property ErlAtom SenderName {
    ErlAtom get ();
    internal: void set (ErlAtom value);
}
member SenderName : ErlAtom with get, internal set
member SenderName : ErlAtom with get, internal set

Property Value

Type: ErlAtom
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.SenderPid Property

ErlMsg SenderPid Property NFX Class Library

Returns pid of the sender (may be empty, i.e. SenderPid.Empty == true)

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlPid SenderPid { get; }
public ErlPid SenderPid { get; }
Public ReadOnly Property SenderPid As ErlPid
    Get
Public ReadOnly Property SenderPid As ErlPid
    Get
public:
property ErlPid SenderPid {
    ErlPid get ();
}
public:
property ErlPid SenderPid {
    ErlPid get ();
}
member SenderPid : ErlPid with get
member SenderPid : ErlPid with get

Property Value

Type: ErlPid
See Also
ErlMsg Class
ErlMsg Members
NFX.Erlang Namespace


ErlMsg.Tag Enumeration

ErlMsg Tag Enumeration NFX Class Library

Erlang message header tags

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum Tag
public enum Tag
Public Enumeration Tag
Public Enumeration Tag
public enum class Tag
public enum class Tag
type Tag
type Tag
Members
Member name | Value | Description
Undefined | -1 |
Link | 1 |
Send | 2 |
Exit | 3 |
Unlink | 4 |
NodeLink | 5 |
RegSend | 6 |
GroupLeader | 7 |
Exit2 | 8 |
SendTT | 12 |
ExitTT | 13 |
RegSendTT | 16 |
Exit2TT | 18 |
MonitorP | 19 |
DemonitorP | 20 |
MonitorPexit | 21 |
See Also
NFX.Erlang Namespace


ErlObject Class

ErlObject Class NFX Class Library

Class defines extension methods on types implementing IErlObject interface and static methods dealing with IErlObject
Inheritance Hierarchy
Online System Object
NFX.Erlang ErlObject

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class ErlObject
public static class ErlObject
<ExtensionAttribute>
Public NotInheritable Class ErlObject
<ExtensionAttribute>
Public NotInheritable Class ErlObject
[ExtensionAttribute]
public ref class ErlObject abstract sealed
[ExtensionAttribute]
public ref class ErlObject abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ErlObject =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ErlObject =  class end
See Also
ErlObject Members
NFX.Erlang Namespace


ErlObject Members

ErlObject Members NFX Class Library

The ErlObject type exposes the following members.
Methods
Name | Description
AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible
ErlArgs | Convert C# string to ErlString
Format | Substitute variables in the args[0] string
IsInt | Determines if Erlang object is of type ErlByte or ErlLong
IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference
Parse(String, Object ) | Parse a string into an Erlang term
Parse T (String, Object ) | Parse a string into an Erlang term
ParseMFA | Parse a string representation of an Erlang function call "Module:Function(Arg1, ..., ArgN)" to a 3-element (Module, Function, Arguments) tuple
Subst | Substibute all variables in the given object using provided binding and return the resulting object
To T | Parse a string into an Erlang term
ToErlMFA | Parse a string representation of an Erlang function call "Module:Function(Arg1, ..., ArgN)" to a 3-element (Module, Function, Arguments) tuple
ToErlObject(Object) | Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible
ToErlObject(String, Object ) | String extension method to parse a string into an Erlang term
ToErlObject(Object, ErlTypeOrder, Boolean) | Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible
ToErlString | Convert C# string to ErlString
Visit TAccumulate | Execute fun for every nested term
Back to Top
See Also
ErlObject Class
NFX.Erlang Namespace


ErlObject Methods

ErlObject Methods NFX Class Library

The ErlObject type exposes the following members.
Methods
Name | Description
AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible
ErlArgs | Convert C# string to ErlString
Format | Substitute variables in the args[0] string
IsInt | Determines if Erlang object is of type ErlByte or ErlLong
IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference
Parse(String, Object ) | Parse a string into an Erlang term
Parse T (String, Object ) | Parse a string into an Erlang term
ParseMFA | Parse a string representation of an Erlang function call "Module:Function(Arg1, ..., ArgN)" to a 3-element (Module, Function, Arguments) tuple
Subst | Substibute all variables in the given object using provided binding and return the resulting object
To T | Parse a string into an Erlang term
ToErlMFA | Parse a string representation of an Erlang function call "Module:Function(Arg1, ..., ArgN)" to a 3-element (Module, Function, Arguments) tuple
ToErlObject(Object) | Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible
ToErlObject(String, Object ) | String extension method to parse a string into an Erlang term
ToErlObject(Object, ErlTypeOrder, Boolean) | Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible
ToErlString | Convert C# string to ErlString
Visit TAccumulate | Execute fun for every nested term
Back to Top
See Also
ErlObject Class
NFX.Erlang Namespace


ErlObject.AsType Method

ErlObject AsType Method NFX Class Library

Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Object AsType(
    this IErlObject val,
    Type t
)
public static Object AsType(
    this IErlObject val,
    Type t
)
<ExtensionAttribute>
Public Shared Function AsType (
    val As IErlObject,
    t As Type
) As Object
<ExtensionAttribute>
Public Shared Function AsType (
    val As IErlObject,
    t As Type
) As Object
public:
[ExtensionAttribute]
static Object^ AsType(
    IErlObject^ val,
    Type^ t
)
public:
[ExtensionAttribute]
static Object^ AsType(
    IErlObject^ val,
    Type^ t
)
static member AsType :
        val : IErlObject *
        t : Type -> Object
static member AsType :
        val : IErlObject *
        t : Type -> Object

Parameters

val
Type: NFX.Erlang IErlObject
t
Type: Online System Type

Return Value

Type: Online Object

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IErlObject. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ErlObject Class
ErlObject Members
NFX.Erlang Namespace


ErlObject.ErlArgs Method

ErlObject ErlArgs Method NFX Class Library

Convert C# string to ErlString

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ErlArgs(
    this string str,
    params Object[] args
)
public static string ErlArgs(
    this string str,
    params Object[] args
)
<ExtensionAttribute>
Public Shared Function ErlArgs (
    str As String,
    ParamArray args As Object()
) As String
<ExtensionAttribute>
Public Shared Function ErlArgs (
    str As String,
    ParamArray args As Object()
) As String
public:
[ExtensionAttribute]
static String^ ErlArgs(
    String^ str,
    ... array<Object^>^ args
)
public:
[ExtensionAttribute]
static String^ ErlArgs(
    String^ str,
    ... array<Object^>^ args
)
static member ErlArgs :
        str : string *
        args : Object[] -> string
static member ErlArgs :
        str : string *
        args : Object[] -> string

Parameters

str
Type: Online System String
args
Type: Online System Object

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ErlObject Class
ErlObject Members
NFX.Erlang Namespace


ErlObject.Format Method

ErlObject Format Method NFX Class Library

Substitute variables in the args[0] string

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Format(
    ErlList args
)
public static string Format(
    ErlList args
)
Public Shared Function Format (
    args As ErlList
) As String
Public Shared Function Format (
    args As ErlList
) As String
public:
static String^ Format(
    ErlList^ args
)
public:
static String^ Format(
    ErlList^ args
)
static member Format :
        args : ErlList -> string
static member Format :
        args : ErlList -> string

Parameters

args
Type: NFX.Erlang ErlList

Return Value

Type: Online String
See Also
ErlObject Class
ErlObject Members
NFX.Erlang Namespace


ErlObject.IsInt Method

ErlObject IsInt Method NFX Class Library

Determines if Erlang object is of type ErlByte or ErlLong

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsInt(
    this IErlObject o
)
public static bool IsInt(
    this IErlObject o
)
<ExtensionAttribute>
Public Shared Function IsInt (
    o As IErlObject
) As Boolean
<ExtensionAttribute>
Public Shared Function IsInt (
    o As IErlObject
) As Boolean
public:
[ExtensionAttribute]
static bool IsInt(
    IErlObject^ o
)
public:
[ExtensionAttribute]
static bool IsInt(
    IErlObject^ o
)
static member IsInt :
        o : IErlObject -> bool
static member IsInt :
        o : IErlObject -> bool

Parameters

o
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IErlObject. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ErlObject Class
ErlObject Members
NFX.Erlang Namespace


ErlObject.IsNull Method

ErlObject IsNull Method NFX Class Library

Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsNull(
    this IErlObject o
)
public static bool IsNull(
    this IErlObject o
)
<ExtensionAttribute>
Public Shared Function IsNull (
    o As IErlObject
) As Boolean
<ExtensionAttribute>
Public Shared Function IsNull (
    o As IErlObject
) As Boolean
public:
[ExtensionAttribute]
static bool IsNull(
    IErlObject^ o
)
public:
[ExtensionAttribute]
static bool IsNull(
    IErlObject^ o
)
static member IsNull :
        o : IErlObject -> bool
static member IsNull :
        o : IErlObject -> bool

Parameters

o
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IErlObject. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ErlObject Class
ErlObject Members
NFX.Erlang Namespace


ErlObject.Parse Method

ErlObject Parse Method NFX Class Library

Overload List
Name | Description
Parse T (String, Object ) | Parse a string into an Erlang term
Parse(String, Object ) | Parse a string into an Erlang term
Back to Top
See Also
ErlObject Class
ErlObject Members
NFX.Erlang Namespace


ErlObject.Parse(T) Method (String, Object[])

ErlObject Parse T Method (String, Object ) NFX Class Library

Parse a string into an Erlang term

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static T Parse<T>(
    string fmt,
    params Object[] args
)
where T : IErlObject
public static T Parse<T>(
    string fmt,
    params Object[] args
)
where T : IErlObject
Public Shared Function Parse(Of T As IErlObject) (
    fmt As String,
    ParamArray args As Object()
) As T
Public Shared Function Parse(Of T As IErlObject) (
    fmt As String,
    ParamArray args As Object()
) As T
public:
generic<typename T>
where T : IErlObject
static T Parse(
    String^ fmt,
    ... array<Object^>^ args
)
public:
generic<typename T>
where T : IErlObject
static T Parse(
    String^ fmt,
    ... array<Object^>^ args
)
static member Parse :
        fmt : string *
        args : Object[] -> 'T  when 'T : IErlObject
static member Parse :
        fmt : string *
        args : Object[] -> 'T  when 'T : IErlObject

Parameters

fmt
Type: Online System String
args
Type: Online System Object
Type Parameters
T

Return Value

Type: T
See Also
ErlObject Class
ErlObject Members
Parse Overload
NFX.Erlang Namespace


ErlObject.Parse Method (String, Object[])

ErlObject Parse Method (String, Object ) NFX Class Library

Parse a string into an Erlang term

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IErlObject Parse(
    string fmt,
    params Object[] args
)
public static IErlObject Parse(
    string fmt,
    params Object[] args
)
Public Shared Function Parse (
    fmt As String,
    ParamArray args As Object()
) As IErlObject
Public Shared Function Parse (
    fmt As String,
    ParamArray args As Object()
) As IErlObject
public:
static IErlObject^ Parse(
    String^ fmt,
    ... array<Object^>^ args
)
public:
static IErlObject^ Parse(
    String^ fmt,
    ... array<Object^>^ args
)
static member Parse :
        fmt : string *
        args : Object[] -> IErlObject
static member Parse :
        fmt : string *
        args : Object[] -> IErlObject

Parameters

fmt
Type: Online System String
args
Type: Online System Object

Return Value

Type: IErlObject
See Also
ErlObject Class
ErlObject Members
Parse Overload
NFX.Erlang Namespace


ErlObject.ParseMFA Method

ErlObject ParseMFA Method NFX Class Library

Parse a string representation of an Erlang function call "Module:Function(Arg1, ..., ArgN)" to a 3-element (Module, Function, Arguments) tuple

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Tuple<ErlAtom, ErlAtom, ErlList> ParseMFA(
    string fmt,
    params Object[] args
)
public static Tuple<ErlAtom, ErlAtom, ErlList> ParseMFA(
    string fmt,
    params Object[] args
)
Public Shared Function ParseMFA (
    fmt As String,
    ParamArray args As Object()
) As Tuple(Of ErlAtom, ErlAtom, ErlList)
Public Shared Function ParseMFA (
    fmt As String,
    ParamArray args As Object()
) As Tuple(Of ErlAtom, ErlAtom, ErlList)
public:
static Tuple<ErlAtom, ErlAtom, ErlList^>^ ParseMFA(
    String^ fmt,
    ... array<Object^>^ args
)
public:
static Tuple<ErlAtom, ErlAtom, ErlList^>^ ParseMFA(
    String^ fmt,
    ... array<Object^>^ args
)
static member ParseMFA :
        fmt : string *
        args : Object[] -> Tuple<ErlAtom, ErlAtom, ErlList>
static member ParseMFA :
        fmt : string *
        args : Object[] -> Tuple<ErlAtom, ErlAtom, ErlList>

Parameters

fmt
Type: Online System String
args
Type: Online System Object

Return Value

Type: Online Tuple ErlAtom, ErlAtom, ErlList
See Also
ErlObject Class
ErlObject Members
NFX.Erlang Namespace


ErlObject.Subst Method

ErlObject Subst Method NFX Class Library

Substibute all variables in the given object using provided binding and return the resulting object

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IErlObject Subst(
    this IErlObject o,
    ErlVarBind binding
)
public static IErlObject Subst(
    this IErlObject o,
    ErlVarBind binding
)
<ExtensionAttribute>
Public Shared Function Subst (
    o As IErlObject,
    binding As ErlVarBind
) As IErlObject
<ExtensionAttribute>
Public Shared Function Subst (
    o As IErlObject,
    binding As ErlVarBind
) As IErlObject
public:
[ExtensionAttribute]
static IErlObject^ Subst(
    IErlObject^ o,
    ErlVarBind^ binding
)
public:
[ExtensionAttribute]
static IErlObject^ Subst(
    IErlObject^ o,
    ErlVarBind^ binding
)
static member Subst :
        o : IErlObject *
        binding : ErlVarBind -> IErlObject
static member Subst :
        o : IErlObject *
        binding : ErlVarBind -> IErlObject

Parameters

o
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind

Return Value

Type: IErlObject

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IErlObject. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ErlObject Class
ErlObject Members
NFX.Erlang Namespace


ErlObject.To(T) Method

ErlObject To T Method NFX Class Library

Parse a string into an Erlang term

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static T To<T>(
    this string fmt,
    params Object[] args
)
where T : IErlObject
public static T To<T>(
    this string fmt,
    params Object[] args
)
where T : IErlObject
<ExtensionAttribute>
Public Shared Function To(Of T As IErlObject) (
    fmt As String,
    ParamArray args As Object()
) As T
<ExtensionAttribute>
Public Shared Function To(Of T As IErlObject) (
    fmt As String,
    ParamArray args As Object()
) As T
public:
[ExtensionAttribute]
generic<typename T>
where T : IErlObject
static T To(
    String^ fmt,
    ... array<Object^>^ args
)
public:
[ExtensionAttribute]
generic<typename T>
where T : IErlObject
static T To(
    String^ fmt,
    ... array<Object^>^ args
)
static member To :
        fmt : string *
        args : Object[] -> 'T  when 'T : IErlObject
static member To :
        fmt : string *
        args : Object[] -> 'T  when 'T : IErlObject

Parameters

fmt
Type: Online System String
args
Type: Online System Object
Type Parameters
T

Return Value

Type: T

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ErlObject Class
ErlObject Members
NFX.Erlang Namespace


ErlObject.ToErlMFA Method

ErlObject ToErlMFA Method NFX Class Library

Parse a string representation of an Erlang function call "Module:Function(Arg1, ..., ArgN)" to a 3-element (Module, Function, Arguments) tuple

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Tuple<ErlAtom, ErlAtom, ErlList> ToErlMFA(
    this string fmt,
    params Object[] args
)
public static Tuple<ErlAtom, ErlAtom, ErlList> ToErlMFA(
    this string fmt,
    params Object[] args
)
<ExtensionAttribute>
Public Shared Function ToErlMFA (
    fmt As String,
    ParamArray args As Object()
) As Tuple(Of ErlAtom, ErlAtom, ErlList)
<ExtensionAttribute>
Public Shared Function ToErlMFA (
    fmt As String,
    ParamArray args As Object()
) As Tuple(Of ErlAtom, ErlAtom, ErlList)
public:
[ExtensionAttribute]
static Tuple<ErlAtom, ErlAtom, ErlList^>^ ToErlMFA(
    String^ fmt,
    ... array<Object^>^ args
)
public:
[ExtensionAttribute]
static Tuple<ErlAtom, ErlAtom, ErlList^>^ ToErlMFA(
    String^ fmt,
    ... array<Object^>^ args
)
static member ToErlMFA :
        fmt : string *
        args : Object[] -> Tuple<ErlAtom, ErlAtom, ErlList>
static member ToErlMFA :
        fmt : string *
        args : Object[] -> Tuple<ErlAtom, ErlAtom, ErlList>

Parameters

fmt
Type: Online System String
args
Type: Online System Object

Return Value

Type: Online Tuple ErlAtom, ErlAtom, ErlList

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ErlObject Class
ErlObject Members
NFX.Erlang Namespace


ErlObject.ToErlObject Method

ErlObject ToErlObject Method NFX Class Library

Overload List
Name | Description
ToErlObject(Object) | Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible
ToErlObject(String, Object ) | String extension method to parse a string into an Erlang term
ToErlObject(Object, ErlTypeOrder, Boolean) | Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible
Back to Top
See Also
ErlObject Class
ErlObject Members
NFX.Erlang Namespace


ErlObject.ToErlObject Method (Object)

ErlObject ToErlObject Method (Object) NFX Class Library

Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IErlObject ToErlObject(
    this Object o
)
public static IErlObject ToErlObject(
    this Object o
)
<ExtensionAttribute>
Public Shared Function ToErlObject (
    o As Object
) As IErlObject
<ExtensionAttribute>
Public Shared Function ToErlObject (
    o As Object
) As IErlObject
public:
[ExtensionAttribute]
static IErlObject^ ToErlObject(
    Object^ o
)
public:
[ExtensionAttribute]
static IErlObject^ ToErlObject(
    Object^ o
)
static member ToErlObject :
        o : Object -> IErlObject
static member ToErlObject :
        o : Object -> IErlObject

Parameters

o
Type: Online System Object

Return Value

Type: IErlObject

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ErlObject Class
ErlObject Members
ToErlObject Overload
NFX.Erlang Namespace


ErlObject.ToErlObject Method (String, Object[])

ErlObject ToErlObject Method (String, Object ) NFX Class Library

[This is preliminary documentation and is subject to change.]

String extension method to parse a string into an Erlang term

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IErlObject ToErlObject(
    this string fmt,
    params Object[] args
)
public static IErlObject ToErlObject(
    this string fmt,
    params Object[] args
)
<ExtensionAttribute>
Public Shared Function ToErlObject (
    fmt As String,
    ParamArray args As Object()
) As IErlObject
<ExtensionAttribute>
Public Shared Function ToErlObject (
    fmt As String,
    ParamArray args As Object()
) As IErlObject
public:
[ExtensionAttribute]
static IErlObject^ ToErlObject(
    String^ fmt,
    ... array<Object^>^ args
)
public:
[ExtensionAttribute]
static IErlObject^ ToErlObject(
    String^ fmt,
    ... array<Object^>^ args
)
static member ToErlObject :
        fmt : string *
        args : Object[] -> IErlObject
static member ToErlObject :
        fmt : string *
        args : Object[] -> IErlObject

Parameters

fmt
Type: Online System String
args
Type: Online System Object

Return Value

Type: IErlObject

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ErlObject Class
ErlObject Members
ToErlObject Overload
NFX.Erlang Namespace


ErlObject.ToErlObject Method (Object, ErlTypeOrder, Boolean)

ErlObject ToErlObject Method (Object, ErlTypeOrder, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IErlObject ToErlObject(
    this Object o,
    ErlTypeOrder etp,
    bool strict = true
)
public static IErlObject ToErlObject(
    this Object o,
    ErlTypeOrder etp,
    bool strict = true
)
<ExtensionAttribute>
Public Shared Function ToErlObject (
    o As Object,
    etp As ErlTypeOrder,
    Optional strict As Boolean = true
) As IErlObject
<ExtensionAttribute>
Public Shared Function ToErlObject (
    o As Object,
    etp As ErlTypeOrder,
    Optional strict As Boolean = true
) As IErlObject
public:
[ExtensionAttribute]
static IErlObject^ ToErlObject(
    Object^ o,
    ErlTypeOrder etp,
    bool strict = true
)
public:
[ExtensionAttribute]
static IErlObject^ ToErlObject(
    Object^ o,
    ErlTypeOrder etp,
    bool strict = true
)
static member ToErlObject :
        o : Object *
        etp : ErlTypeOrder *
        ?strict : bool
(* Defaults:
        let _strict = defaultArg strict true
*)
-> IErlObject
static member ToErlObject :
        o : Object *
        etp : ErlTypeOrder *
        ?strict : bool
(* Defaults:
        let _strict = defaultArg strict true
*)
-> IErlObject

Parameters

o
Type: Online System Object
etp
Type: NFX.Erlang ErlTypeOrder
strict (Optional)
Type: Online System Boolean

Return Value

Type: IErlObject

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ErlObject Class
ErlObject Members
ToErlObject Overload
NFX.Erlang Namespace


ErlObject.ToErlString Method

ErlObject ToErlString Method NFX Class Library

Convert C# string to ErlString

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlString ToErlString(
    this string str
)
public static ErlString ToErlString(
    this string str
)
<ExtensionAttribute>
Public Shared Function ToErlString (
    str As String
) As ErlString
<ExtensionAttribute>
Public Shared Function ToErlString (
    str As String
) As ErlString
public:
[ExtensionAttribute]
static ErlString ToErlString(
    String^ str
)
public:
[ExtensionAttribute]
static ErlString ToErlString(
    String^ str
)
static member ToErlString :
        str : string -> ErlString
static member ToErlString :
        str : string -> ErlString

Parameters

str
Type: Online System String

Return Value

Type: ErlString

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ErlObject Class
ErlObject Members
NFX.Erlang Namespace


ErlObject.Visit(TAccumulate) Method

ErlObject Visit TAccumulate Method NFX Class Library

Execute fun for every nested term

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TAccumulate Visit<TAccumulate>(
    this IErlObject o,
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
public static TAccumulate Visit<TAccumulate>(
    this IErlObject o,
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
<ExtensionAttribute>
Public Shared Function Visit(Of TAccumulate) (
    o As IErlObject,
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
<ExtensionAttribute>
Public Shared Function Visit(Of TAccumulate) (
    o As IErlObject,
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
public:
[ExtensionAttribute]
generic<typename TAccumulate>
static TAccumulate Visit(
    IErlObject^ o,
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
)
public:
[ExtensionAttribute]
generic<typename TAccumulate>
static TAccumulate Visit(
    IErlObject^ o,
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
)
static member Visit :
        o : IErlObject *
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
static member Visit :
        o : IErlObject *
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate

Parameters

o
Type: NFX.Erlang IErlObject
acc
Type: TAccumulate
fun
Type: Online System Func TAccumulate, IErlObject, TAccumulate
Type Parameters
TAccumulate

Return Value

Type: TAccumulate

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IErlObject. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ErlObject Class
ErlObject Members
NFX.Erlang Namespace


ErlOutputStream Class

ErlOutputStream Class NFX Class Library

Provides a stream for encoding Erlang terms to external format for transmission or storage
Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.IO Stream
NFX.Erlang ErlOutputStream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ErlOutputStream : Stream
public class ErlOutputStream : Stream
Public Class ErlOutputStream
    Inherits Stream
Public Class ErlOutputStream
    Inherits Stream
public ref class ErlOutputStream : public Stream
public ref class ErlOutputStream : public Stream
type ErlOutputStream =
    class
        inherit Stream
    end
type ErlOutputStream =
    class
        inherit Stream
    end
See Also
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream Members

ErlOutputStream Members NFX Class Library

The ErlOutputStream type exposes the following members.
Constructors
 | Name | Description
Public method | ErlOutputStream | Create a stream containing the serialized Erlang term. Optionally include in the beginning Erlang protocol version byte
Back to Top
Methods
 | Name | Description
Public method | Online BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Online Stream.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Protected method | Online CreateWaitHandle | Obsolete. Allocates a Online WaitHandle object. (Inherited from Online Stream.)
Public method | Online Dispose | Releases all resources used by the Online Stream. (Inherited from Online Stream.)
Protected method | Online Dispose(Boolean) | Releases the unmanaged resources used by the Online Stream and optionally releases the managed resources. (Inherited from Online Stream.)
 | EncodeSize |
Public method | Online EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Overrides Online Stream Flush .)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Online Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Online Stream.)
Public method | GetBuffer | Get internal buffer
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | InputStream |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Online Stream.)
Public method | Poke4BE | Write the low four bytes of a value to the stream in bif endian order, at the specified position. If the position specified is beyond the end of the stream, this method will have no effect
Public method | Read | (Overrides Online Stream Read( Byte , Int32, Int32).)
Public method | ReadAsync( Byte , Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Online Stream.)
Public method | ReadAsync( Byte , Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Online Stream.)
Public method | Online ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Online Stream.)
Public method | Reset | Reset the stream so that it can be reused
Public method | Seek | (Overrides Online Stream Seek(Int64, SeekOrigin).)
Public method | SetLength | (Overrides Online Stream SetLength(Int64).)
Public method | ToBinary |
Public method | ToBinaryString | Convert stream content to printable binary string (i.e. <<131,10,...>>)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write(Byte) | Write one byte to the stream
Protected method | Write( Byte ) | Write an array of bytes to the stream
Public method | Write(IErlObject) | Write an arbitrary Erlang term to the stream.
Public method | Write( Byte , Int32, Int32) | (Overrides Online Stream Write( Byte , Int32, Int32).)
Protected method | Write1 | Write the low byte of a value to the stream
Protected method | Write2BE | Write the low two bytes of a value to the stream in big endian order
Protected method | Write4BE | Write the low four bytes of a value to the stream in big endian order
Public method | WriteAsync( Byte , Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Online Stream.)
Public method | WriteAsync( Byte , Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Online Stream.)
Public method | WriteAtom(String, Encoding) | Write string value as atom to the stream
Public method | WriteAtom(ErlAtom, Encoding) | Write atom to the stream
Public method | WriteBinary | Write an array of bytes to the stream as an Erlang binary
Public method | WriteBoolean | Write a boolean value to the stream as the Erlang atom 'true' or 'false'
Public method | Online WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Online Stream.)
Public method | WriteByte(ErlByte) | Write a single byte to the stream as an Erlang integer
Public method | WriteChar | Write a character to the stream as an Erlang integer
Public method | WriteDouble | Write a double value to the stream
Public method | WriteInt | Write an integer to the stream
Public method | WriteList | Write Erlang list to stream
Public method | WriteListHead | Write an Erlang list header to the stream. After calling this method, you must write 'arity' elements to the stream followed by nil, or it will not be possible to decode it later.
Public method | WriteLong(Int64) | Write a long to stream
Public method | WriteLong(ErlLong) | Write an Erlang long to the stream
Public method | WriteNil | Write an empty Erlang list to the stream
Public method | WritePid | Write an Erlang PID to the stream
Public method | WritePort | Write an Erlang port to the stream
Public method | WriteRef | Write a new style (R6 and later) Erlang ref to the stream
Public method | WriteString(String, Encoding) | Write a string to the stream
Public method | WriteString(ErlString, Encoding) | Write a string to the stream
Public method | WriteTo | Write the contents of the stream to an OutputStream
Public method | WriteTrace | Write Erlang tuple to stream
Public method | WriteTuple | Write Erlang tuple to stream
Public method | WriteTupleHead | Write an Erlang tuple header to the stream. After calling this method, you must write 'arity' elements to the stream or it will not be possible to decode it later.
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsCharEnumerable | (Defined by IOMiscUtils.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Public Extension Method | ReadBEInt32 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEShort | Reads a short encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUInt64 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUShort | Reads an ushort encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadSLEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadSLEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | WriteBEInt32 | Writes an integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEShort | Writes a short encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUInt64 | Writes an unsigned long integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUShort | Writes an ushort encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteSLEB128(Int64, Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteSLEB128(Int64, Int32 , Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, UInt32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, Int32 , UInt32) | Overloaded. (Defined by LEB128.)
Back to Top
Properties
 | Name | Description
Public property | CanRead | (Overrides Online Stream CanRead.)
Public property | CanSeek | (Overrides Online Stream CanSeek.)
Public property | Online CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Online Stream.)
Public property | CanWrite | (Overrides Online Stream CanWrite.)
Public property | Capacity | Get the current capacity of the stream. As bytes are added the capacity of the stream is increased automatically, however this method returns the current size
Public property | Length | Get the number of bytes in the stream (Overrides Online Stream Length.)
Public property | Position | Get the current position in the stream (Overrides Online Stream Position.)
Public property | Online ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Online Stream.)
Public property | Online WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Online Stream.)
Back to Top
See Also
ErlOutputStream Class
NFX.Erlang Namespace


ErlOutputStream Constructor

ErlOutputStream Constructor NFX Class Library

Create a stream containing the serialized Erlang term. Optionally include in the beginning Erlang protocol version byte

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlOutputStream(
    IErlObject o = null,
    bool writeVersion = true,
    bool writePktSize = false,
    int capacity = 2048
)
public ErlOutputStream(
    IErlObject o = null,
    bool writeVersion = true,
    bool writePktSize = false,
    int capacity = 2048
)
Public Sub New (
    Optional o As IErlObject = Nothing,
    Optional writeVersion As Boolean = true,
    Optional writePktSize As Boolean = false,
    Optional capacity As Integer = 2048
)
Public Sub New (
    Optional o As IErlObject = Nothing,
    Optional writeVersion As Boolean = true,
    Optional writePktSize As Boolean = false,
    Optional capacity As Integer = 2048
)
public:
ErlOutputStream(
    IErlObject^ o = nullptr,
    bool writeVersion = true,
    bool writePktSize = false,
    int capacity = 2048
)
public:
ErlOutputStream(
    IErlObject^ o = nullptr,
    bool writeVersion = true,
    bool writePktSize = false,
    int capacity = 2048
)
new :
        ?o : IErlObject *
        ?writeVersion : bool *
        ?writePktSize : bool *
        ?capacity : int
(* Defaults:
        let _o = defaultArg o null
        let _writeVersion = defaultArg writeVersion true
        let _writePktSize = defaultArg writePktSize false
        let _capacity = defaultArg capacity 2048
*)
-> ErlOutputStream
new :
        ?o : IErlObject *
        ?writeVersion : bool *
        ?writePktSize : bool *
        ?capacity : int
(* Defaults:
        let _o = defaultArg o null
        let _writeVersion = defaultArg writeVersion true
        let _writePktSize = defaultArg writePktSize false
        let _capacity = defaultArg capacity 2048
*)
-> ErlOutputStream

Parameters

o (Optional)
Type: NFX.Erlang IErlObject
writeVersion (Optional)
Type: Online System Boolean
writePktSize (Optional)
Type: Online System Boolean
capacity (Optional)
Type: Online System Int32
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream Methods

ErlOutputStream Methods NFX Class Library

The ErlOutputStream type exposes the following members.
Methods
 | Name | Description
Public method | Online BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Online Stream.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Protected method | Online CreateWaitHandle | Obsolete. Allocates a Online WaitHandle object. (Inherited from Online Stream.)
Public method | Online Dispose | Releases all resources used by the Online Stream. (Inherited from Online Stream.)
Protected method | Online Dispose(Boolean) | Releases the unmanaged resources used by the Online Stream and optionally releases the managed resources. (Inherited from Online Stream.)
 | EncodeSize |
Public method | Online EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Overrides Online Stream Flush .)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Online Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Online Stream.)
Public method | GetBuffer | Get internal buffer
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | InputStream |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Online Stream.)
Public method | Poke4BE | Write the low four bytes of a value to the stream in bif endian order, at the specified position. If the position specified is beyond the end of the stream, this method will have no effect
Public method | Read | (Overrides Online Stream Read( Byte , Int32, Int32).)
Public method | ReadAsync( Byte , Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Online Stream.)
Public method | ReadAsync( Byte , Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Online Stream.)
Public method | Online ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Online Stream.)
Public method | Reset | Reset the stream so that it can be reused
Public method | Seek | (Overrides Online Stream Seek(Int64, SeekOrigin).)
Public method | SetLength | (Overrides Online Stream SetLength(Int64).)
Public method | ToBinary |
Public method | ToBinaryString | Convert stream content to printable binary string (i.e. <<131,10,...>>)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write(Byte) | Write one byte to the stream
Protected method | Write( Byte ) | Write an array of bytes to the stream
Public method | Write(IErlObject) | Write an arbitrary Erlang term to the stream.
Public method | Write( Byte , Int32, Int32) | (Overrides Online Stream Write( Byte , Int32, Int32).)
Protected method | Write1 | Write the low byte of a value to the stream
Protected method | Write2BE | Write the low two bytes of a value to the stream in big endian order
Protected method | Write4BE | Write the low four bytes of a value to the stream in big endian order
Public method | WriteAsync( Byte , Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Online Stream.)
Public method | WriteAsync( Byte , Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Online Stream.)
Public method | WriteAtom(String, Encoding) | Write string value as atom to the stream
Public method | WriteAtom(ErlAtom, Encoding) | Write atom to the stream
Public method | WriteBinary | Write an array of bytes to the stream as an Erlang binary
Public method | WriteBoolean | Write a boolean value to the stream as the Erlang atom 'true' or 'false'
Public method | Online WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Online Stream.)
Public method | WriteByte(ErlByte) | Write a single byte to the stream as an Erlang integer
Public method | WriteChar | Write a character to the stream as an Erlang integer
Public method | WriteDouble | Write a double value to the stream
Public method | WriteInt | Write an integer to the stream
Public method | WriteList | Write Erlang list to stream
Public method | WriteListHead | Write an Erlang list header to the stream. After calling this method, you must write 'arity' elements to the stream followed by nil, or it will not be possible to decode it later.
Public method | WriteLong(Int64) | Write a long to stream
Public method | WriteLong(ErlLong) | Write an Erlang long to the stream
Public method | WriteNil | Write an empty Erlang list to the stream
Public method | WritePid | Write an Erlang PID to the stream
Public method | WritePort | Write an Erlang port to the stream
Public method | WriteRef | Write a new style (R6 and later) Erlang ref to the stream
Public method | WriteString(String, Encoding) | Write a string to the stream
Public method | WriteString(ErlString, Encoding) | Write a string to the stream
Public method | WriteTo | Write the contents of the stream to an OutputStream
Public method | WriteTrace | Write Erlang tuple to stream
Public method | WriteTuple | Write Erlang tuple to stream
Public method | WriteTupleHead | Write an Erlang tuple header to the stream. After calling this method, you must write 'arity' elements to the stream or it will not be possible to decode it later.
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsCharEnumerable | (Defined by IOMiscUtils.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Public Extension Method | ReadBEInt32 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEShort | Reads a short encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUInt64 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUShort | Reads an ushort encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadSLEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadSLEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | WriteBEInt32 | Writes an integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEShort | Writes a short encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUInt64 | Writes an unsigned long integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUShort | Writes an ushort encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteSLEB128(Int64, Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteSLEB128(Int64, Int32 , Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, UInt32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, Int32 , UInt32) | Overloaded. (Defined by LEB128.)
Back to Top
See Also
ErlOutputStream Class
NFX.Erlang Namespace


ErlOutputStream.EncodeSize Method

ErlOutputStream EncodeSize Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int EncodeSize(
    IErlObject o
)
public static int EncodeSize(
    IErlObject o
)
Public Shared Function EncodeSize (
    o As IErlObject
) As Integer
Public Shared Function EncodeSize (
    o As IErlObject
) As Integer
public:
static int EncodeSize(
    IErlObject^ o
)
public:
static int EncodeSize(
    IErlObject^ o
)
static member EncodeSize :
        o : IErlObject -> int
static member EncodeSize :
        o : IErlObject -> int

Parameters

o
Type: NFX.Erlang IErlObject

Return Value

Type: Online Int32
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.Flush Method

ErlOutputStream Flush Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Flush()
public override void Flush()
Public Overrides Sub Flush
Public Overrides Sub Flush
public:
virtual void Flush() override
public:
virtual void Flush() override
abstract Flush : unit -> unit
override Flush : unit -> unit
abstract Flush : unit -> unit
override Flush : unit -> unit
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.GetBuffer Method

ErlOutputStream GetBuffer Method NFX Class Library

Get internal buffer

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] GetBuffer()
public byte[] GetBuffer()
Public Function GetBuffer As Byte()
Public Function GetBuffer As Byte()
public:
array<unsigned char>^ GetBuffer()
public:
array<unsigned char>^ GetBuffer()
member GetBuffer : unit -> byte[]
member GetBuffer : unit -> byte[]

Return Value

Type: Online Byte
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.InputStream Method

ErlOutputStream InputStream Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlInputStream InputStream(
    int offset
)
public ErlInputStream InputStream(
    int offset
)
Public Function InputStream (
    offset As Integer
) As ErlInputStream
Public Function InputStream (
    offset As Integer
) As ErlInputStream
public:
ErlInputStream^ InputStream(
    int offset
)
public:
ErlInputStream^ InputStream(
    int offset
)
member InputStream :
        offset : int -> ErlInputStream
member InputStream :
        offset : int -> ErlInputStream

Parameters

offset
Type: Online System Int32

Return Value

Type: ErlInputStream
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.Poke4BE Method

ErlOutputStream Poke4BE Method NFX Class Library

Write the low four bytes of a value to the stream in bif endian order, at the specified position. If the position specified is beyond the end of the stream, this method will have no effect

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Poke4BE(
    int offset,
    int n
)
public void Poke4BE(
    int offset,
    int n
)
Public Sub Poke4BE (
    offset As Integer,
    n As Integer
)
Public Sub Poke4BE (
    offset As Integer,
    n As Integer
)
public:
void Poke4BE(
    int offset,
    int n
)
public:
void Poke4BE(
    int offset,
    int n
)
member Poke4BE :
        offset : int *
        n : int -> unit
member Poke4BE :
        offset : int *
        n : int -> unit

Parameters

offset
Type: Online System Int32
n
Type: Online System Int32
Remarks
Normally this method should be used in conjunction with Position, when is is necessary to insert data into the stream before it is known what the actual value should be. For example:
             int pos = s.Position;
             s.Write4BE(0); // make space for length data,
             // but final value is not yet known

             [ ...more write statements...]

             // later... when we know the length value
             s.Poke4BE(pos, length);
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.Read Method

ErlOutputStream Read Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int

Parameters

buffer
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32

Return Value

Type: Online Int32
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.Reset Method

ErlOutputStream Reset Method NFX Class Library

Reset the stream so that it can be reused

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Reset()
public void Reset()
Public Sub Reset
Public Sub Reset
public:
void Reset()
public:
void Reset()
member Reset : unit -> unit
member Reset : unit -> unit
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.Seek Method

ErlOutputStream Seek Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long Seek(
    long offset,
    SeekOrigin origin
)
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64

Parameters

offset
Type: Online System Int64
origin
Type: Online System.IO SeekOrigin

Return Value

Type: Online Int64
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.SetLength Method

ErlOutputStream SetLength Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetLength(
    long value
)
public override void SetLength(
    long value
)
Public Overrides Sub SetLength (
    value As Long
)
Public Overrides Sub SetLength (
    value As Long
)
public:
virtual void SetLength(
    long long value
) override
public:
virtual void SetLength(
    long long value
) override
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit

Parameters

value
Type: Online System Int64
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.ToBinary Method

ErlOutputStream ToBinary Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlBinary ToBinary()
public ErlBinary ToBinary()
Public Function ToBinary As ErlBinary
Public Function ToBinary As ErlBinary
public:
ErlBinary ToBinary()
public:
ErlBinary ToBinary()
member ToBinary : unit -> ErlBinary
member ToBinary : unit -> ErlBinary

Return Value

Type: ErlBinary
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.ToBinaryString Method

ErlOutputStream ToBinaryString Method NFX Class Library

Convert stream content to printable binary string (i.e. <<131,10,...>>)

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ToBinaryString()
public string ToBinaryString()
Public Function ToBinaryString As String
Public Function ToBinaryString As String
public:
String^ ToBinaryString()
public:
String^ ToBinaryString()
member ToBinaryString : unit -> string
member ToBinaryString : unit -> string

Return Value

Type: Online String
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.Write Method

ErlOutputStream Write Method NFX Class Library

Overload List
 | Name | Description
Public method | Write(Byte) | Write one byte to the stream
Protected method | Write( Byte ) | Write an array of bytes to the stream
Public method | Write(IErlObject) | Write an arbitrary Erlang term to the stream.
Public method | Write( Byte , Int32, Int32) | (Overrides Online Stream Write( Byte , Int32, Int32).)
Back to Top
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.Write Method (Byte)

ErlOutputStream Write Method (Byte) NFX Class Library

Write one byte to the stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Write(
    byte b
)
public void Write(
    byte b
)
Public Sub Write (
    b As Byte
)
Public Sub Write (
    b As Byte
)
public:
void Write(
    unsigned char b
)
public:
void Write(
    unsigned char b
)
member Write :
        b : byte -> unit
member Write :
        b : byte -> unit

Parameters

b
Type: Online System Byte
See Also
ErlOutputStream Class
ErlOutputStream Members
Write Overload
NFX.Erlang Namespace


ErlOutputStream.Write Method (Byte[])

ErlOutputStream Write Method ( Byte ) NFX Class Library

Write an array of bytes to the stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Write(
    byte[] buf
)
internal void Write(
    byte[] buf
)
Friend Sub Write (
    buf As Byte()
)
Friend Sub Write (
    buf As Byte()
)
internal:
void Write(
    array<unsigned char>^ buf
)
internal:
void Write(
    array<unsigned char>^ buf
)
internal member Write :
        buf : byte[] -> unit
internal member Write :
        buf : byte[] -> unit

Parameters

buf
Type: Online System Byte
See Also
ErlOutputStream Class
ErlOutputStream Members
Write Overload
NFX.Erlang Namespace


ErlOutputStream.Write Method (IErlObject)

ErlOutputStream Write Method (IErlObject) NFX Class Library

Write an arbitrary Erlang term to the stream.

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Write(
    IErlObject o
)
public void Write(
    IErlObject o
)
Public Sub Write (
    o As IErlObject
)
Public Sub Write (
    o As IErlObject
)
public:
void Write(
    IErlObject^ o
)
public:
void Write(
    IErlObject^ o
)
member Write :
        o : IErlObject -> unit
member Write :
        o : IErlObject -> unit

Parameters

o
Type: NFX.Erlang IErlObject
See Also
ErlOutputStream Class
ErlOutputStream Members
Write Overload
NFX.Erlang Namespace


ErlOutputStream.Write Method (Byte[], Int32, Int32)

ErlOutputStream Write Method ( Byte , Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit

Parameters

buffer
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32
See Also
ErlOutputStream Class
ErlOutputStream Members
Write Overload
NFX.Erlang Namespace


ErlOutputStream.Write1 Method

ErlOutputStream Write1 Method NFX Class Library

Write the low byte of a value to the stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Write1(
    long n
)
internal void Write1(
    long n
)
Friend Sub Write1 (
    n As Long
)
Friend Sub Write1 (
    n As Long
)
internal:
void Write1(
    long long n
)
internal:
void Write1(
    long long n
)
internal member Write1 :
        n : int64 -> unit
internal member Write1 :
        n : int64 -> unit

Parameters

n
Type: Online System Int64
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.Write2BE Method

ErlOutputStream Write2BE Method NFX Class Library

Write the low two bytes of a value to the stream in big endian order

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Write2BE(
    long n
)
internal void Write2BE(
    long n
)
Friend Sub Write2BE (
    n As Long
)
Friend Sub Write2BE (
    n As Long
)
internal:
void Write2BE(
    long long n
)
internal:
void Write2BE(
    long long n
)
internal member Write2BE :
        n : int64 -> unit
internal member Write2BE :
        n : int64 -> unit

Parameters

n
Type: Online System Int64
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.Write4BE Method

ErlOutputStream Write4BE Method NFX Class Library

Write the low four bytes of a value to the stream in big endian order

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Write4BE(
    long n
)
internal void Write4BE(
    long n
)
Friend Sub Write4BE (
    n As Long
)
Friend Sub Write4BE (
    n As Long
)
internal:
void Write4BE(
    long long n
)
internal:
void Write4BE(
    long long n
)
internal member Write4BE :
        n : int64 -> unit
internal member Write4BE :
        n : int64 -> unit

Parameters

n
Type: Online System Int64
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.WriteAtom Method

ErlOutputStream WriteAtom Method NFX Class Library

Overload List
 | Name | Description
Public method | WriteAtom(String, Encoding) | Write string value as atom to the stream
Public method | WriteAtom(ErlAtom, Encoding) | Write atom to the stream
Back to Top
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.WriteAtom Method (String, Encoding)

ErlOutputStream WriteAtom Method (String, Encoding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Write string value as atom to the stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteAtom(
    string atom,
    Encoding encoding = null
)
public void WriteAtom(
    string atom,
    Encoding encoding = null
)
Public Sub WriteAtom (
    atom As String,
    Optional encoding As Encoding = Nothing
)
Public Sub WriteAtom (
    atom As String,
    Optional encoding As Encoding = Nothing
)
public:
void WriteAtom(
    String^ atom,
    Encoding^ encoding = nullptr
)
public:
void WriteAtom(
    String^ atom,
    Encoding^ encoding = nullptr
)
member WriteAtom :
        atom : string *
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> unit
member WriteAtom :
        atom : string *
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> unit

Parameters

atom
Type: Online System String
encoding (Optional)
Type: Online System.Text Encoding
See Also
ErlOutputStream Class
ErlOutputStream Members
WriteAtom Overload
NFX.Erlang Namespace


ErlOutputStream.WriteAtom Method (ErlAtom, Encoding)

ErlOutputStream WriteAtom Method (ErlAtom, Encoding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Write atom to the stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteAtom(
    ErlAtom atom,
    Encoding encoding = null
)
public void WriteAtom(
    ErlAtom atom,
    Encoding encoding = null
)
Public Sub WriteAtom (
    atom As ErlAtom,
    Optional encoding As Encoding = Nothing
)
Public Sub WriteAtom (
    atom As ErlAtom,
    Optional encoding As Encoding = Nothing
)
public:
void WriteAtom(
    ErlAtom atom,
    Encoding^ encoding = nullptr
)
public:
void WriteAtom(
    ErlAtom atom,
    Encoding^ encoding = nullptr
)
member WriteAtom :
        atom : ErlAtom *
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> unit
member WriteAtom :
        atom : ErlAtom *
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> unit

Parameters

atom
Type: NFX.Erlang ErlAtom
encoding (Optional)
Type: Online System.Text Encoding
See Also
ErlOutputStream Class
ErlOutputStream Members
WriteAtom Overload
NFX.Erlang Namespace


ErlOutputStream.WriteBinary Method

ErlOutputStream WriteBinary Method NFX Class Library

Write an array of bytes to the stream as an Erlang binary

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteBinary(
    ErlBinary bin
)
public void WriteBinary(
    ErlBinary bin
)
Public Sub WriteBinary (
    bin As ErlBinary
)
Public Sub WriteBinary (
    bin As ErlBinary
)
public:
void WriteBinary(
    ErlBinary bin
)
public:
void WriteBinary(
    ErlBinary bin
)
member WriteBinary :
        bin : ErlBinary -> unit
member WriteBinary :
        bin : ErlBinary -> unit

Parameters

bin
Type: NFX.Erlang ErlBinary
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.WriteBoolean Method

ErlOutputStream WriteBoolean Method NFX Class Library

Write a boolean value to the stream as the Erlang atom 'true' or 'false'

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteBoolean(
    ErlBoolean b
)
public void WriteBoolean(
    ErlBoolean b
)
Public Sub WriteBoolean (
    b As ErlBoolean
)
Public Sub WriteBoolean (
    b As ErlBoolean
)
public:
void WriteBoolean(
    ErlBoolean b
)
public:
void WriteBoolean(
    ErlBoolean b
)
member WriteBoolean :
        b : ErlBoolean -> unit
member WriteBoolean :
        b : ErlBoolean -> unit

Parameters

b
Type: NFX.Erlang ErlBoolean
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.WriteByte Method

ErlOutputStream WriteByte Method NFX Class Library

Overload List
 | Name | Description
Public method | Online WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Online Stream.)
Public method | WriteByte(ErlByte) | Write a single byte to the stream as an Erlang integer
Back to Top
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.WriteByte Method (ErlByte)

ErlOutputStream WriteByte Method (ErlByte) NFX Class Library

Write a single byte to the stream as an Erlang integer

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteByte(
    ErlByte b
)
public void WriteByte(
    ErlByte b
)
Public Sub WriteByte (
    b As ErlByte
)
Public Sub WriteByte (
    b As ErlByte
)
public:
void WriteByte(
    ErlByte b
)
public:
void WriteByte(
    ErlByte b
)
member WriteByte :
        b : ErlByte -> unit
member WriteByte :
        b : ErlByte -> unit

Parameters

b
Type: NFX.Erlang ErlByte
See Also
ErlOutputStream Class
ErlOutputStream Members
WriteByte Overload
NFX.Erlang Namespace


ErlOutputStream.WriteChar Method

ErlOutputStream WriteChar Method NFX Class Library

Write a character to the stream as an Erlang integer

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteChar(
    char c
)
public void WriteChar(
    char c
)
Public Sub WriteChar (
    c As Char
)
Public Sub WriteChar (
    c As Char
)
public:
void WriteChar(
    wchar_t c
)
public:
void WriteChar(
    wchar_t c
)
member WriteChar :
        c : char -> unit
member WriteChar :
        c : char -> unit

Parameters

c
Type: Online System Char
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.WriteDouble Method

ErlOutputStream WriteDouble Method NFX Class Library

Write a double value to the stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteDouble(
    ErlDouble d
)
public void WriteDouble(
    ErlDouble d
)
Public Sub WriteDouble (
    d As ErlDouble
)
Public Sub WriteDouble (
    d As ErlDouble
)
public:
void WriteDouble(
    ErlDouble d
)
public:
void WriteDouble(
    ErlDouble d
)
member WriteDouble :
        d : ErlDouble -> unit
member WriteDouble :
        d : ErlDouble -> unit

Parameters

d
Type: NFX.Erlang ErlDouble
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.WriteInt Method

ErlOutputStream WriteInt Method NFX Class Library

Write an integer to the stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteInt(
    int i
)
public void WriteInt(
    int i
)
Public Sub WriteInt (
    i As Integer
)
Public Sub WriteInt (
    i As Integer
)
public:
void WriteInt(
    int i
)
public:
void WriteInt(
    int i
)
member WriteInt :
        i : int -> unit
member WriteInt :
        i : int -> unit

Parameters

i
Type: Online System Int32
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.WriteList Method

ErlOutputStream WriteList Method NFX Class Library

Write Erlang list to stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteList(
    ErlList list
)
public void WriteList(
    ErlList list
)
Public Sub WriteList (
    list As ErlList
)
Public Sub WriteList (
    list As ErlList
)
public:
void WriteList(
    ErlList^ list
)
public:
void WriteList(
    ErlList^ list
)
member WriteList :
        list : ErlList -> unit
member WriteList :
        list : ErlList -> unit

Parameters

list
Type: NFX.Erlang ErlList
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.WriteListHead Method

ErlOutputStream WriteListHead Method NFX Class Library

Write an Erlang list header to the stream. After calling this method, you must write 'arity' elements to the stream followed by nil, or it will not be possible to decode it later.

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteListHead(
    int arity,
    bool isStr = false
)
public void WriteListHead(
    int arity,
    bool isStr = false
)
Public Sub WriteListHead (
    arity As Integer,
    Optional isStr As Boolean = false
)
Public Sub WriteListHead (
    arity As Integer,
    Optional isStr As Boolean = false
)
public:
void WriteListHead(
    int arity,
    bool isStr = false
)
public:
void WriteListHead(
    int arity,
    bool isStr = false
)
member WriteListHead :
        arity : int *
        ?isStr : bool
(* Defaults:
        let _isStr = defaultArg isStr false
*)
-> unit
member WriteListHead :
        arity : int *
        ?isStr : bool
(* Defaults:
        let _isStr = defaultArg isStr false
*)
-> unit

Parameters

arity
Type: Online System Int32
isStr (Optional)
Type: Online System Boolean
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.WriteLong Method

ErlOutputStream WriteLong Method NFX Class Library

Overload List
 | Name | Description
Public method | WriteLong(Int64) | Write a long to stream
Public method | WriteLong(ErlLong) | Write an Erlang long to the stream
Back to Top
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.WriteLong Method (Int64)

ErlOutputStream WriteLong Method (Int64) NFX Class Library

Write a long to stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteLong(
    long l
)
public void WriteLong(
    long l
)
Public Sub WriteLong (
    l As Long
)
Public Sub WriteLong (
    l As Long
)
public:
void WriteLong(
    long long l
)
public:
void WriteLong(
    long long l
)
member WriteLong :
        l : int64 -> unit
member WriteLong :
        l : int64 -> unit

Parameters

l
Type: Online System Int64
See Also
ErlOutputStream Class
ErlOutputStream Members
WriteLong Overload
NFX.Erlang Namespace


ErlOutputStream.WriteLong Method (ErlLong)

ErlOutputStream WriteLong Method (ErlLong) NFX Class Library

Write an Erlang long to the stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteLong(
    ErlLong l
)
public void WriteLong(
    ErlLong l
)
Public Sub WriteLong (
    l As ErlLong
)
Public Sub WriteLong (
    l As ErlLong
)
public:
void WriteLong(
    ErlLong l
)
public:
void WriteLong(
    ErlLong l
)
member WriteLong :
        l : ErlLong -> unit
member WriteLong :
        l : ErlLong -> unit

Parameters

l
Type: NFX.Erlang ErlLong
See Also
ErlOutputStream Class
ErlOutputStream Members
WriteLong Overload
NFX.Erlang Namespace


ErlOutputStream.WriteNil Method

ErlOutputStream WriteNil Method NFX Class Library

Write an empty Erlang list to the stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteNil()
public void WriteNil()
Public Sub WriteNil
Public Sub WriteNil
public:
void WriteNil()
public:
void WriteNil()
member WriteNil : unit -> unit
member WriteNil : unit -> unit
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.WritePid Method

ErlOutputStream WritePid Method NFX Class Library

Write an Erlang PID to the stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WritePid(
    ErlPid pid
)
public void WritePid(
    ErlPid pid
)
Public Sub WritePid (
    pid As ErlPid
)
Public Sub WritePid (
    pid As ErlPid
)
public:
void WritePid(
    ErlPid pid
)
public:
void WritePid(
    ErlPid pid
)
member WritePid :
        pid : ErlPid -> unit
member WritePid :
        pid : ErlPid -> unit

Parameters

pid
Type: NFX.Erlang ErlPid
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.WritePort Method

ErlOutputStream WritePort Method NFX Class Library

Write an Erlang port to the stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WritePort(
    ErlPort p
)
public void WritePort(
    ErlPort p
)
Public Sub WritePort (
    p As ErlPort
)
Public Sub WritePort (
    p As ErlPort
)
public:
void WritePort(
    ErlPort p
)
public:
void WritePort(
    ErlPort p
)
member WritePort :
        p : ErlPort -> unit
member WritePort :
        p : ErlPort -> unit

Parameters

p
Type: NFX.Erlang ErlPort
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.WriteRef Method

ErlOutputStream WriteRef Method NFX Class Library

Write a new style (R6 and later) Erlang ref to the stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteRef(
    ErlRef r
)
public void WriteRef(
    ErlRef r
)
Public Sub WriteRef (
    r As ErlRef
)
Public Sub WriteRef (
    r As ErlRef
)
public:
void WriteRef(
    ErlRef r
)
public:
void WriteRef(
    ErlRef r
)
member WriteRef :
        r : ErlRef -> unit
member WriteRef :
        r : ErlRef -> unit

Parameters

r
Type: NFX.Erlang ErlRef
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.WriteString Method

ErlOutputStream WriteString Method NFX Class Library

Overload List
 | Name | Description
Public method | WriteString(String, Encoding) | Write a string to the stream
Public method | WriteString(ErlString, Encoding) | Write a string to the stream
Back to Top
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.WriteString Method (String, Encoding)

ErlOutputStream WriteString Method (String, Encoding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Write a string to the stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteString(
    string s,
    Encoding encoding = null
)
public void WriteString(
    string s,
    Encoding encoding = null
)
Public Sub WriteString (
    s As String,
    Optional encoding As Encoding = Nothing
)
Public Sub WriteString (
    s As String,
    Optional encoding As Encoding = Nothing
)
public:
void WriteString(
    String^ s,
    Encoding^ encoding = nullptr
)
public:
void WriteString(
    String^ s,
    Encoding^ encoding = nullptr
)
member WriteString :
        s : string *
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> unit
member WriteString :
        s : string *
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> unit

Parameters

s
Type: Online System String
encoding (Optional)
Type: Online System.Text Encoding
See Also
ErlOutputStream Class
ErlOutputStream Members
WriteString Overload
NFX.Erlang Namespace


ErlOutputStream.WriteString Method (ErlString, Encoding)

ErlOutputStream WriteString Method (ErlString, Encoding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Write a string to the stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteString(
    ErlString s,
    Encoding encoding = null
)
public void WriteString(
    ErlString s,
    Encoding encoding = null
)
Public Sub WriteString (
    s As ErlString,
    Optional encoding As Encoding = Nothing
)
Public Sub WriteString (
    s As ErlString,
    Optional encoding As Encoding = Nothing
)
public:
void WriteString(
    ErlString s,
    Encoding^ encoding = nullptr
)
public:
void WriteString(
    ErlString s,
    Encoding^ encoding = nullptr
)
member WriteString :
        s : ErlString *
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> unit
member WriteString :
        s : ErlString *
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> unit

Parameters

s
Type: NFX.Erlang ErlString
encoding (Optional)
Type: Online System.Text Encoding
See Also
ErlOutputStream Class
ErlOutputStream Members
WriteString Overload
NFX.Erlang Namespace


ErlOutputStream.WriteTo Method

ErlOutputStream WriteTo Method NFX Class Library

Write the contents of the stream to an OutputStream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteTo(
    Stream os
)
public void WriteTo(
    Stream os
)
Public Sub WriteTo (
    os As Stream
)
Public Sub WriteTo (
    os As Stream
)
public:
void WriteTo(
    Stream^ os
)
public:
void WriteTo(
    Stream^ os
)
member WriteTo :
        os : Stream -> unit
member WriteTo :
        os : Stream -> unit

Parameters

os
Type: Online System.IO Stream
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.WriteTrace Method

ErlOutputStream WriteTrace Method NFX Class Library

Write Erlang tuple to stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteTrace(
    ErlTrace tup
)
public void WriteTrace(
    ErlTrace tup
)
Public Sub WriteTrace (
    tup As ErlTrace
)
Public Sub WriteTrace (
    tup As ErlTrace
)
public:
void WriteTrace(
    ErlTrace^ tup
)
public:
void WriteTrace(
    ErlTrace^ tup
)
member WriteTrace :
        tup : ErlTrace -> unit
member WriteTrace :
        tup : ErlTrace -> unit

Parameters

tup
Type: NFX.Erlang ErlTrace
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.WriteTuple Method

ErlOutputStream WriteTuple Method NFX Class Library

Write Erlang tuple to stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteTuple(
    ErlTuple tup
)
public void WriteTuple(
    ErlTuple tup
)
Public Sub WriteTuple (
    tup As ErlTuple
)
Public Sub WriteTuple (
    tup As ErlTuple
)
public:
void WriteTuple(
    ErlTuple^ tup
)
public:
void WriteTuple(
    ErlTuple^ tup
)
member WriteTuple :
        tup : ErlTuple -> unit
member WriteTuple :
        tup : ErlTuple -> unit

Parameters

tup
Type: NFX.Erlang ErlTuple
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.WriteTupleHead Method

ErlOutputStream WriteTupleHead Method NFX Class Library

Write an Erlang tuple header to the stream. After calling this method, you must write 'arity' elements to the stream or it will not be possible to decode it later.

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteTupleHead(
    int arity
)
public void WriteTupleHead(
    int arity
)
Public Sub WriteTupleHead (
    arity As Integer
)
Public Sub WriteTupleHead (
    arity As Integer
)
public:
void WriteTupleHead(
    int arity
)
public:
void WriteTupleHead(
    int arity
)
member WriteTupleHead :
        arity : int -> unit
member WriteTupleHead :
        arity : int -> unit

Parameters

arity
Type: Online System Int32
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream Properties

ErlOutputStream Properties NFX Class Library

The ErlOutputStream type exposes the following members.
Properties
 | Name | Description
Public property | CanRead | (Overrides Online Stream CanRead.)
Public property | CanSeek | (Overrides Online Stream CanSeek.)
Public property | Online CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Online Stream.)
Public property | CanWrite | (Overrides Online Stream CanWrite.)
Public property | Capacity | Get the current capacity of the stream. As bytes are added the capacity of the stream is increased automatically, however this method returns the current size
Public property | Length | Get the number of bytes in the stream (Overrides Online Stream Length.)
Public property | Position | Get the current position in the stream (Overrides Online Stream Position.)
Public property | Online ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Online Stream.)
Public property | Online WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Online Stream.)
Back to Top
See Also
ErlOutputStream Class
NFX.Erlang Namespace


ErlOutputStream.CanRead Property

ErlOutputStream CanRead Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool CanRead { get; }
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
    Get
Public Overrides ReadOnly Property CanRead As Boolean
    Get
public:
virtual property bool CanRead {
    bool get () override;
}
public:
virtual property bool CanRead {
    bool get () override;
}
abstract CanRead : bool with get
override CanRead : bool with get
abstract CanRead : bool with get
override CanRead : bool with get

Property Value

Type: Online Boolean
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.CanSeek Property

ErlOutputStream CanSeek Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool CanSeek { get; }
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
public:
virtual property bool CanSeek {
    bool get () override;
}
public:
virtual property bool CanSeek {
    bool get () override;
}
abstract CanSeek : bool with get
override CanSeek : bool with get
abstract CanSeek : bool with get
override CanSeek : bool with get

Property Value

Type: Online Boolean
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.CanWrite Property

ErlOutputStream CanWrite Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool CanWrite { get; }
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
public:
virtual property bool CanWrite {
    bool get () override;
}
public:
virtual property bool CanWrite {
    bool get () override;
}
abstract CanWrite : bool with get
override CanWrite : bool with get
abstract CanWrite : bool with get
override CanWrite : bool with get

Property Value

Type: Online Boolean
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.Capacity Property

ErlOutputStream Capacity Property NFX Class Library

Get the current capacity of the stream. As bytes are added the capacity of the stream is increased automatically, however this method returns the current size

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Capacity { get; }
public int Capacity { get; }
Public ReadOnly Property Capacity As Integer
    Get
Public ReadOnly Property Capacity As Integer
    Get
public:
property int Capacity {
    int get ();
}
public:
property int Capacity {
    int get ();
}
member Capacity : int with get
member Capacity : int with get

Property Value

Type: Online Int32
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.Length Property

ErlOutputStream Length Property NFX Class Library

Get the number of bytes in the stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long Length { get; }
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
    Get
Public Overrides ReadOnly Property Length As Long
    Get
public:
virtual property long long Length {
    long long get () override;
}
public:
virtual property long long Length {
    long long get () override;
}
abstract Length : int64 with get
override Length : int64 with get
abstract Length : int64 with get
override Length : int64 with get

Property Value

Type: Online Int64
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlOutputStream.Position Property

ErlOutputStream Position Property NFX Class Library

Get the current position in the stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long Position { get; set; }
public override long Position { get; set; }
Public Overrides Property Position As Long
    Get
    Set
Public Overrides Property Position As Long
    Get
    Set
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
abstract Position : int64 with get, set
override Position : int64 with get, set
abstract Position : int64 with get, set
override Position : int64 with get, set

Property Value

Type: Online Int64
See Also
ErlOutputStream Class
ErlOutputStream Members
NFX.Erlang Namespace


ErlPasswordRequiredEventHandler Delegate

ErlPasswordRequiredEventHandler Delegate NFX Class Library

Delegate is called when SSH tunnel requires password for authentication

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void ErlPasswordRequiredEventHandler(
    ErlPasswordSession session
)
public delegate void ErlPasswordRequiredEventHandler(
    ErlPasswordSession session
)
Public Delegate Sub ErlPasswordRequiredEventHandler (
    session As ErlPasswordSession
)
Public Delegate Sub ErlPasswordRequiredEventHandler (
    session As ErlPasswordSession
)
public delegate void ErlPasswordRequiredEventHandler(
    ErlPasswordSession^ session
)
public delegate void ErlPasswordRequiredEventHandler(
    ErlPasswordSession^ session
)
type ErlPasswordRequiredEventHandler =
    delegate of
        session : ErlPasswordSession -> unit
type ErlPasswordRequiredEventHandler =
    delegate of
        session : ErlPasswordSession -> unit

Parameters

session
Type: NFX.Erlang ErlPasswordSession
See Also
NFX.Erlang Namespace


ErlPasswordSession Class

ErlPasswordSession Class NFX Class Library

Keeps password for node and user
Inheritance Hierarchy
Online System Object
NFX.Erlang ErlPasswordSession

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ErlPasswordSession : IDisposable
public class ErlPasswordSession : IDisposable
Public Class ErlPasswordSession
    Implements IDisposable
Public Class ErlPasswordSession
    Implements IDisposable
public ref class ErlPasswordSession : IDisposable
public ref class ErlPasswordSession : IDisposable
type ErlPasswordSession =
    class
        interface IDisposable
    end
type ErlPasswordSession =
    class
        interface IDisposable
    end
See Also
ErlPasswordSession Members
NFX.Erlang Namespace


ErlPasswordSession Members

ErlPasswordSession Members NFX Class Library

The ErlPasswordSession type exposes the following members.
Constructors
 | Name | Description
Protected method | ErlPasswordSession | Initializes a new instance of the ErlPasswordSession class
Back to Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ErlPasswordSession
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | NodeName |
Public property | Password |
Public property | UserName |
Back to Top
See Also
ErlPasswordSession Class
NFX.Erlang Namespace


ErlPasswordSession Constructor

ErlPasswordSession Constructor NFX Class Library

Initializes a new instance of the ErlPasswordSession class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ErlPasswordSession(
    string nodeName,
    string userName
)
internal ErlPasswordSession(
    string nodeName,
    string userName
)
Friend Sub New (
    nodeName As String,
    userName As String
)
Friend Sub New (
    nodeName As String,
    userName As String
)
internal:
ErlPasswordSession(
    String^ nodeName,
    String^ userName
)
internal:
ErlPasswordSession(
    String^ nodeName,
    String^ userName
)
new :
        nodeName : string *
        userName : string -> ErlPasswordSession
new :
        nodeName : string *
        userName : string -> ErlPasswordSession

Parameters

nodeName
Type: Online System String
userName
Type: Online System String
See Also
ErlPasswordSession Class
ErlPasswordSession Members
NFX.Erlang Namespace


ErlPasswordSession Methods

ErlPasswordSession Methods NFX Class Library

The ErlPasswordSession type exposes the following members.
Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ErlPasswordSession Class
NFX.Erlang Namespace


ErlPasswordSession.Dispose Method

ErlPasswordSession Dispose Method NFX Class Library

Releases all resources used by the ErlPasswordSession

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

Online IDisposable Dispose
See Also
ErlPasswordSession Class
ErlPasswordSession Members
NFX.Erlang Namespace


ErlPasswordSession.Equals Method

ErlPasswordSession Equals Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
ErlPasswordSession Class
ErlPasswordSession Members
NFX.Erlang Namespace


ErlPasswordSession.GetHashCode Method

ErlPasswordSession GetHashCode Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
ErlPasswordSession Class
ErlPasswordSession Members
NFX.Erlang Namespace


ErlPasswordSession Properties

ErlPasswordSession Properties NFX Class Library

The ErlPasswordSession type exposes the following members.
Properties
 | Name | Description
Public property | NodeName |
Public property | Password |
Public property | UserName |
Back to Top
See Also
ErlPasswordSession Class
NFX.Erlang Namespace


ErlPasswordSession.NodeName Property

ErlPasswordSession NodeName Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string NodeName { get; private set; }
public string NodeName { get; private set; }
Public Property NodeName As String
    Get
    Private Set
Public Property NodeName As String
    Get
    Private Set
public:
property String^ NodeName {
    String^ get ();
    private: void set (String^ value);
}
public:
property String^ NodeName {
    String^ get ();
    private: void set (String^ value);
}
member NodeName : string with get, private set
member NodeName : string with get, private set

Property Value

Type: Online String
See Also
ErlPasswordSession Class
ErlPasswordSession Members
NFX.Erlang Namespace


ErlPasswordSession.Password Property

ErlPasswordSession Password Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SecureString Password { get; set; }
public SecureString Password { get; set; }
Public Property Password As SecureString
    Get
    Set
Public Property Password As SecureString
    Get
    Set
public:
property SecureString^ Password {
    SecureString^ get ();
    void set (SecureString^ value);
}
public:
property SecureString^ Password {
    SecureString^ get ();
    void set (SecureString^ value);
}
member Password : SecureString with get, set
member Password : SecureString with get, set

Property Value

Type: Online SecureString
See Also
ErlPasswordSession Class
ErlPasswordSession Members
NFX.Erlang Namespace


ErlPasswordSession.UserName Property

ErlPasswordSession UserName Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string UserName { get; private set; }
public string UserName { get; private set; }
Public Property UserName As String
    Get
    Private Set
Public Property UserName As String
    Get
    Private Set
public:
property String^ UserName {
    String^ get ();
    private: void set (String^ value);
}
public:
property String^ UserName {
    String^ get ();
    private: void set (String^ value);
}
member UserName : string with get, private set
member UserName : string with get, private set

Property Value

Type: Online String
See Also
ErlPasswordSession Class
ErlPasswordSession Members
NFX.Erlang Namespace


ErlPatternMatcher Class

ErlPatternMatcher Class NFX Class Library

Pattern matcher that implements a container of patterns to be matched against a given Erlang term. On successful match, the corresponding func registered with that pattern gets invoked
Inheritance Hierarchy
Online System Object
NFX.Erlang ErlPatternMatcher

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ErlPatternMatcher : IEnumerable<ErlPatternMatcher..::..Pattern>,
    IEnumerable
public class ErlPatternMatcher : IEnumerable<ErlPatternMatcher..::..Pattern>,
    IEnumerable
Public Class ErlPatternMatcher
    Implements IEnumerable(Of ErlPatternMatcher..::..Pattern), IEnumerable
Public Class ErlPatternMatcher
    Implements IEnumerable(Of ErlPatternMatcher..::..Pattern), IEnumerable
public ref class ErlPatternMatcher : IEnumerable<ErlPatternMatcher..::..Pattern>,
    IEnumerable
public ref class ErlPatternMatcher : IEnumerable<ErlPatternMatcher..::..Pattern>,
    IEnumerable
type ErlPatternMatcher =
    class
        interface IEnumerable<ErlPatternMatcher..::..Pattern>
        interface IEnumerable
    end
type ErlPatternMatcher =
    class
        interface IEnumerable<ErlPatternMatcher..::..Pattern>
        interface IEnumerable
    end
See Also
ErlPatternMatcher Members
NFX.Erlang Namespace


ErlPatternMatcher Members

ErlPatternMatcher Members NFX Class Library

The ErlPatternMatcher type exposes the following members.
Constructors
 | Name | Description
Public method | ErlPatternMatcher | Initializes a new instance of the ErlPatternMatcher class
Back to Top
Methods
 | Name | Description
Public method | Add(String, PatternMatchFunc) | Add a matching pattern to the collection
Public method | Add(IErlObject, PatternMatchFunc) | Add a matching pattern to the collection
Public method | Add TContext (TContext, IErlObject, PatternMatchFunc TContext ) | Add a matching pattern to the collection
Public method | Add TContext (TContext, String, PatternMatchFunc TContext ) | Add a matching pattern to the collection
Public method | Clear | Clear the collection of patterns
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match | Match a term against the patterns in the collection. The first successful match will result in invocation of the func associated with the pattern, and storing func result in the term
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove | Remove pattern from collection given its ID
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable ErlPatternMatcher Pattern | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct ErlPatternMatcher Pattern, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax ErlPatternMatcher Pattern, TComparand (Func ErlPatternMatcher Pattern, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax ErlPatternMatcher Pattern, TComparand (Func ErlPatternMatcher Pattern, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin ErlPatternMatcher Pattern, TComparand (Func ErlPatternMatcher Pattern, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin ErlPatternMatcher Pattern, TComparand (Func ErlPatternMatcher Pattern, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault ErlPatternMatcher Pattern | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach ErlPatternMatcher Pattern (Action ErlPatternMatcher Pattern ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach ErlPatternMatcher Pattern (Action ErlPatternMatcher Pattern, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast ErlPatternMatcher Pattern | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast ErlPatternMatcher Pattern (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | PatternsToString |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable ErlPatternMatcher Pattern GetEnumerator |
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
ErlPatternMatcher Class
NFX.Erlang Namespace


ErlPatternMatcher Constructor

ErlPatternMatcher Constructor NFX Class Library

Initializes a new instance of the ErlPatternMatcher class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlPatternMatcher()
public ErlPatternMatcher()
Public Sub New
Public Sub New
public:
ErlPatternMatcher()
public:
ErlPatternMatcher()
new : unit -> ErlPatternMatcher
new : unit -> ErlPatternMatcher
See Also
ErlPatternMatcher Class
ErlPatternMatcher Members
NFX.Erlang Namespace


ErlPatternMatcher Methods

ErlPatternMatcher Methods NFX Class Library

The ErlPatternMatcher type exposes the following members.
Methods
 | Name | Description
Public method | Add(String, PatternMatchFunc) | Add a matching pattern to the collection
Public method | Add(IErlObject, PatternMatchFunc) | Add a matching pattern to the collection
Public method | Add TContext (TContext, IErlObject, PatternMatchFunc TContext ) | Add a matching pattern to the collection
Public method | Add TContext (TContext, String, PatternMatchFunc TContext ) | Add a matching pattern to the collection
Public method | Clear | Clear the collection of patterns
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match | Match a term against the patterns in the collection. The first successful match will result in invocation of the func associated with the pattern, and storing func result in the term
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove | Remove pattern from collection given its ID
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable ErlPatternMatcher Pattern | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct ErlPatternMatcher Pattern, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax ErlPatternMatcher Pattern, TComparand (Func ErlPatternMatcher Pattern, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax ErlPatternMatcher Pattern, TComparand (Func ErlPatternMatcher Pattern, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin ErlPatternMatcher Pattern, TComparand (Func ErlPatternMatcher Pattern, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin ErlPatternMatcher Pattern, TComparand (Func ErlPatternMatcher Pattern, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault ErlPatternMatcher Pattern | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach ErlPatternMatcher Pattern (Action ErlPatternMatcher Pattern ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach ErlPatternMatcher Pattern (Action ErlPatternMatcher Pattern, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast ErlPatternMatcher Pattern | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast ErlPatternMatcher Pattern (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable ErlPatternMatcher Pattern GetEnumerator |
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
ErlPatternMatcher Class
NFX.Erlang Namespace


ErlPatternMatcher.IEnumerable(ErlPatternMatcher.Pattern).GetEnumerator Method

ErlPatternMatcher IEnumerable ErlPatternMatcher Pattern GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator<ErlPatternMatcher..::..Pattern> IEnumerable<ErlPatternMatcher..::..Pattern>.GetEnumerator()
IEnumerator<ErlPatternMatcher..::..Pattern> IEnumerable<ErlPatternMatcher..::..Pattern>.GetEnumerator()
Private Function GetEnumerator As IEnumerator(Of ErlPatternMatcher..::..Pattern)
    Implements IEnumerable(Of ErlPatternMatcher..::..Pattern).GetEnumerator
Private Function GetEnumerator As IEnumerator(Of ErlPatternMatcher..::..Pattern)
    Implements IEnumerable(Of ErlPatternMatcher..::..Pattern).GetEnumerator
private:
virtual IEnumerator<ErlPatternMatcher..::..Pattern>^ GetEnumerator() sealed = IEnumerable<ErlPatternMatcher..::..Pattern>::GetEnumerator
private:
virtual IEnumerator<ErlPatternMatcher..::..Pattern>^ GetEnumerator() sealed = IEnumerable<ErlPatternMatcher..::..Pattern>::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator<ErlPatternMatcher..::..Pattern>
private override GetEnumerator : unit -> IEnumerator<ErlPatternMatcher..::..Pattern>
private abstract GetEnumerator : unit -> IEnumerator<ErlPatternMatcher..::..Pattern>
private override GetEnumerator : unit -> IEnumerator<ErlPatternMatcher..::..Pattern>

Return Value

Type: Online IEnumerator ErlPatternMatcher Pattern

Implements

Online IEnumerable T GetEnumerator
See Also
ErlPatternMatcher Class
ErlPatternMatcher Members
NFX.Erlang Namespace


ErlPatternMatcher.IEnumerable.GetEnumerator Method

ErlPatternMatcher IEnumerable GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
ErlPatternMatcher Class
ErlPatternMatcher Members
NFX.Erlang Namespace


ErlPatternMatcher.Add Method

ErlPatternMatcher Add Method NFX Class Library

Overload List
 | Name | Description
Public method | Add(String, PatternMatchFunc) | Add a matching pattern to the collection
Public method | Add(IErlObject, PatternMatchFunc) | Add a matching pattern to the collection
Public method | Add TContext (TContext, IErlObject, PatternMatchFunc TContext ) | Add a matching pattern to the collection
Public method | Add TContext (TContext, String, PatternMatchFunc TContext ) | Add a matching pattern to the collection
Back to Top
See Also
ErlPatternMatcher Class
ErlPatternMatcher Members
NFX.Erlang Namespace


ErlPatternMatcher.Add Method (String, PatternMatchFunc)

ErlPatternMatcher Add Method (String, PatternMatchFunc) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add a matching pattern to the collection

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Add(
    string pattern,
    PatternMatchFunc func
)
public int Add(
    string pattern,
    PatternMatchFunc func
)
Public Function Add (
    pattern As String,
    func As PatternMatchFunc
) As Integer
Public Function Add (
    pattern As String,
    func As PatternMatchFunc
) As Integer
public:
int Add(
    String^ pattern,
    PatternMatchFunc^ func
)
public:
int Add(
    String^ pattern,
    PatternMatchFunc^ func
)
member Add :
        pattern : string *
        func : PatternMatchFunc -> int
member Add :
        pattern : string *
        func : PatternMatchFunc -> int

Parameters

pattern
Type: Online System String
Pattern to compile
func
Type: NFX.Erlang PatternMatchFunc
Function to invoke on successful match

Return Value

Type: Online Int32
ID of the newly added pattern
See Also
ErlPatternMatcher Class
ErlPatternMatcher Members
Add Overload
NFX.Erlang Namespace


ErlPatternMatcher.Add Method (IErlObject, PatternMatchFunc)

ErlPatternMatcher Add Method (IErlObject, PatternMatchFunc) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add a matching pattern to the collection

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Add(
    IErlObject pattern,
    PatternMatchFunc func
)
public int Add(
    IErlObject pattern,
    PatternMatchFunc func
)
Public Function Add (
    pattern As IErlObject,
    func As PatternMatchFunc
) As Integer
Public Function Add (
    pattern As IErlObject,
    func As PatternMatchFunc
) As Integer
public:
int Add(
    IErlObject^ pattern,
    PatternMatchFunc^ func
)
public:
int Add(
    IErlObject^ pattern,
    PatternMatchFunc^ func
)
member Add :
        pattern : IErlObject *
        func : PatternMatchFunc -> int
member Add :
        pattern : IErlObject *
        func : PatternMatchFunc -> int

Parameters

pattern
Type: NFX.Erlang IErlObject
Erlang term to be used as a match pattern
func
Type: NFX.Erlang PatternMatchFunc
Function to invoke on successful match

Return Value

Type: Online Int32
ID of the newly added pattern
See Also
ErlPatternMatcher Class
ErlPatternMatcher Members
Add Overload
NFX.Erlang Namespace


ErlPatternMatcher.Add(TContext) Method (TContext, IErlObject, PatternMatchFunc(TContext))

ErlPatternMatcher Add TContext Method (TContext, IErlObject, PatternMatchFunc TContext ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add a matching pattern to the collection

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Add<TContext>(
    TContext context,
    IErlObject pattern,
    PatternMatchFunc<TContext> func
)
public int Add<TContext>(
    TContext context,
    IErlObject pattern,
    PatternMatchFunc<TContext> func
)
Public Function Add(Of TContext) (
    context As TContext,
    pattern As IErlObject,
    func As PatternMatchFunc(Of TContext)
) As Integer
Public Function Add(Of TContext) (
    context As TContext,
    pattern As IErlObject,
    func As PatternMatchFunc(Of TContext)
) As Integer
public:
generic<typename TContext>
int Add(
    TContext context,
    IErlObject^ pattern,
    PatternMatchFunc<TContext>^ func
)
public:
generic<typename TContext>
int Add(
    TContext context,
    IErlObject^ pattern,
    PatternMatchFunc<TContext>^ func
)
member Add :
        context : 'TContext *
        pattern : IErlObject *
        func : PatternMatchFunc<'TContext> -> int
member Add :
        context : 'TContext *
        pattern : IErlObject *
        func : PatternMatchFunc<'TContext> -> int

Parameters

context
Type: TContext
Context passed to func
pattern
Type: NFX.Erlang IErlObject
Compiled pattern containing variables to match
func
Type: NFX.Erlang PatternMatchFunc TContext
Function to invoke on successful match
Type Parameters
TContext
Type of context passed to func

Return Value

Type: Online Int32
ID of the newly added pattern
See Also
ErlPatternMatcher Class
ErlPatternMatcher Members
Add Overload
NFX.Erlang Namespace


ErlPatternMatcher.Add(TContext) Method (TContext, String, PatternMatchFunc(TContext))

ErlPatternMatcher Add TContext Method (TContext, String, PatternMatchFunc TContext ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add a matching pattern to the collection

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Add<TContext>(
    TContext context,
    string pattern,
    PatternMatchFunc<TContext> func
)
public int Add<TContext>(
    TContext context,
    string pattern,
    PatternMatchFunc<TContext> func
)
Public Function Add(Of TContext) (
    context As TContext,
    pattern As String,
    func As PatternMatchFunc(Of TContext)
) As Integer
Public Function Add(Of TContext) (
    context As TContext,
    pattern As String,
    func As PatternMatchFunc(Of TContext)
) As Integer
public:
generic<typename TContext>
int Add(
    TContext context,
    String^ pattern,
    PatternMatchFunc<TContext>^ func
)
public:
generic<typename TContext>
int Add(
    TContext context,
    String^ pattern,
    PatternMatchFunc<TContext>^ func
)
member Add :
        context : 'TContext *
        pattern : string *
        func : PatternMatchFunc<'TContext> -> int
member Add :
        context : 'TContext *
        pattern : string *
        func : PatternMatchFunc<'TContext> -> int

Parameters

context
Type: TContext
Context passed to func
pattern
Type: Online System String
Pattern to compile
func
Type: NFX.Erlang PatternMatchFunc TContext
Function to invoke on successful match
Type Parameters
TContext
Type of context passed to func

Return Value

Type: Online Int32
ID of the newly added pattern
See Also
ErlPatternMatcher Class
ErlPatternMatcher Members
Add Overload
NFX.Erlang Namespace


ErlPatternMatcher.Clear Method

ErlPatternMatcher Clear Method NFX Class Library

Clear the collection of patterns

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
void Clear()
public:
void Clear()
member Clear : unit -> unit
member Clear : unit -> unit
See Also
ErlPatternMatcher Class
ErlPatternMatcher Members
NFX.Erlang Namespace


ErlPatternMatcher.Match Method

ErlPatternMatcher Match Method NFX Class Library

Match a term against the patterns in the collection. The first successful match will result in invocation of the func associated with the pattern, and storing func result in the term

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Match(
    ref IErlObject term,
    params Object[] args
)
public int Match(
    ref IErlObject term,
    params Object[] args
)
Public Function Match (
    ByRef term As IErlObject,
    ParamArray args As Object()
) As Integer
Public Function Match (
    ByRef term As IErlObject,
    ParamArray args As Object()
) As Integer
public:
int Match(
    IErlObject^% term,
    ... array<Object^>^ args
)
public:
int Match(
    IErlObject^% term,
    ... array<Object^>^ args
)
member Match :
        term : IErlObject byref *
        args : Object[] -> int
member Match :
        term : IErlObject byref *
        args : Object[] -> int

Parameters

term
Type: NFX.Erlang IErlObject
Term to match against patterns
args
Type: Online System Object
Arguments to be passed to an func on successful pattern match

Return Value

Type: Online Int32
ID of the pattern that matched, or -1 if there were no matches
See Also
ErlPatternMatcher Class
ErlPatternMatcher Members
NFX.Erlang Namespace


ErlPatternMatcher.Remove Method

ErlPatternMatcher Remove Method NFX Class Library

Remove pattern from collection given its ID

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Remove(
    int id
)
public void Remove(
    int id
)
Public Sub Remove (
    id As Integer
)
Public Sub Remove (
    id As Integer
)
public:
void Remove(
    int id
)
public:
void Remove(
    int id
)
member Remove :
        id : int -> unit
member Remove :
        id : int -> unit

Parameters

id
Type: Online System Int32
See Also
ErlPatternMatcher Class
ErlPatternMatcher Members
NFX.Erlang Namespace


ErlPatternMatcher Properties

ErlPatternMatcher Properties NFX Class Library

The ErlPatternMatcher type exposes the following members.
Properties
 | Name | Description
Public property | PatternsToString |
Back to Top
See Also
ErlPatternMatcher Class
NFX.Erlang Namespace


ErlPatternMatcher.PatternsToString Property

ErlPatternMatcher PatternsToString Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string PatternsToString { get; }
public string PatternsToString { get; }
Public ReadOnly Property PatternsToString As String
    Get
Public ReadOnly Property PatternsToString As String
    Get
public:
property String^ PatternsToString {
    String^ get ();
}
public:
property String^ PatternsToString {
    String^ get ();
}
member PatternsToString : string with get
member PatternsToString : string with get

Property Value

Type: Online String
See Also
ErlPatternMatcher Class
ErlPatternMatcher Members
NFX.Erlang Namespace


ErlPatternMatcher.Pattern Structure

ErlPatternMatcher Pattern Structure NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct Pattern
public struct Pattern
Public Structure Pattern
Public Structure Pattern
public value class Pattern
public value class Pattern
[<SealedAttribute>]
type Pattern =  struct end
[<SealedAttribute>]
type Pattern =  struct end
See Also
ErlPatternMatcher Pattern Members
NFX.Erlang Namespace


ErlPatternMatcher.Pattern Members

ErlPatternMatcher Pattern Members NFX Class Library

The ErlPatternMatcher Pattern type exposes the following members.
Constructors
 | Name | Description
Public method | ErlPatternMatcher Pattern(Int32, PatternMatchFunc, IErlObject) | Initializes a new instance of the ErlPatternMatcher Pattern class
Public method | ErlPatternMatcher Pattern(Int32, PatternMatchFunc, String, Object ) | Initializes a new instance of the ErlPatternMatcher Pattern class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Func |
Public field | ID |
Public field | Term |
Back to Top
See Also
ErlPatternMatcher Pattern Structure
NFX.Erlang Namespace


ErlPatternMatcher.Pattern Constructor

ErlPatternMatcher Pattern Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ErlPatternMatcher Pattern(Int32, PatternMatchFunc, IErlObject) | Initializes a new instance of the ErlPatternMatcher Pattern class
Public method | ErlPatternMatcher Pattern(Int32, PatternMatchFunc, String, Object ) | Initializes a new instance of the ErlPatternMatcher Pattern class
Back to Top
See Also
ErlPatternMatcher Pattern Structure
ErlPatternMatcher Pattern Members
NFX.Erlang Namespace


ErlPatternMatcher.Pattern Constructor (Int32, PatternMatchFunc, IErlObject)

ErlPatternMatcher Pattern Constructor (Int32, PatternMatchFunc, IErlObject) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlPatternMatcher Pattern class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Pattern(
    int id,
    PatternMatchFunc b,
    IErlObject p
)
public Pattern(
    int id,
    PatternMatchFunc b,
    IErlObject p
)
Public Sub New (
    id As Integer,
    b As PatternMatchFunc,
    p As IErlObject
)
Public Sub New (
    id As Integer,
    b As PatternMatchFunc,
    p As IErlObject
)
public:
Pattern(
    int id,
    PatternMatchFunc^ b,
    IErlObject^ p
)
public:
Pattern(
    int id,
    PatternMatchFunc^ b,
    IErlObject^ p
)
new :
        id : int *
        b : PatternMatchFunc *
        p : IErlObject -> Pattern
new :
        id : int *
        b : PatternMatchFunc *
        p : IErlObject -> Pattern

Parameters

id
Type: Online System Int32
b
Type: NFX.Erlang PatternMatchFunc
p
Type: NFX.Erlang IErlObject
See Also
ErlPatternMatcher Pattern Structure
ErlPatternMatcher Pattern Members
ErlPatternMatcher Pattern Overload
NFX.Erlang Namespace


ErlPatternMatcher.Pattern Constructor (Int32, PatternMatchFunc, String, Object[])

ErlPatternMatcher Pattern Constructor (Int32, PatternMatchFunc, String, Object ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlPatternMatcher Pattern class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Pattern(
    int id,
    PatternMatchFunc b,
    string pattern,
    params Object[] args
)
public Pattern(
    int id,
    PatternMatchFunc b,
    string pattern,
    params Object[] args
)
Public Sub New (
    id As Integer,
    b As PatternMatchFunc,
    pattern As String,
    ParamArray args As Object()
)
Public Sub New (
    id As Integer,
    b As PatternMatchFunc,
    pattern As String,
    ParamArray args As Object()
)
public:
Pattern(
    int id,
    PatternMatchFunc^ b,
    String^ pattern,
    ... array<Object^>^ args
)
public:
Pattern(
    int id,
    PatternMatchFunc^ b,
    String^ pattern,
    ... array<Object^>^ args
)
new :
        id : int *
        b : PatternMatchFunc *
        pattern : string *
        args : Object[] -> Pattern
new :
        id : int *
        b : PatternMatchFunc *
        pattern : string *
        args : Object[] -> Pattern

Parameters

id
Type: Online System Int32
b
Type: NFX.Erlang PatternMatchFunc
pattern
Type: Online System String
args
Type: Online System Object
See Also
ErlPatternMatcher Pattern Structure
ErlPatternMatcher Pattern Members
ErlPatternMatcher Pattern Overload
NFX.Erlang Namespace


ErlPatternMatcher.Pattern Fields

ErlPatternMatcher Pattern Fields NFX Class Library

The ErlPatternMatcher Pattern type exposes the following members.
Fields
 | Name | Description
Public field | Func |
Public field | ID |
Public field | Term |
Back to Top
See Also
ErlPatternMatcher Pattern Structure
NFX.Erlang Namespace


ErlPatternMatcher.Pattern.Func Field

ErlPatternMatcher Pattern Func Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly PatternMatchFunc Func
public readonly PatternMatchFunc Func
Public ReadOnly Func As PatternMatchFunc
Public ReadOnly Func As PatternMatchFunc
public:
initonly PatternMatchFunc^ Func
public:
initonly PatternMatchFunc^ Func
val Func: PatternMatchFunc
val Func: PatternMatchFunc

Field Value

Type: PatternMatchFunc
See Also
ErlPatternMatcher Pattern Structure
ErlPatternMatcher Pattern Members
NFX.Erlang Namespace


ErlPatternMatcher.Pattern.ID Field

ErlPatternMatcher Pattern ID Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int ID
public readonly int ID
Public ReadOnly ID As Integer
Public ReadOnly ID As Integer
public:
initonly int ID
public:
initonly int ID
val ID: int
val ID: int

Field Value

Type: Online Int32
See Also
ErlPatternMatcher Pattern Structure
ErlPatternMatcher Pattern Members
NFX.Erlang Namespace


ErlPatternMatcher.Pattern.Term Field

ErlPatternMatcher Pattern Term Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly IErlObject Term
public readonly IErlObject Term
Public ReadOnly Term As IErlObject
Public ReadOnly Term As IErlObject
public:
initonly IErlObject^ Term
public:
initonly IErlObject^ Term
val Term: IErlObject
val Term: IErlObject

Field Value

Type: IErlObject
See Also
ErlPatternMatcher Pattern Structure
ErlPatternMatcher Pattern Members
NFX.Erlang Namespace


ErlPatternMatcher.Pattern Methods

ErlPatternMatcher Pattern Methods NFX Class Library

The ErlPatternMatcher Pattern type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ErlPatternMatcher Pattern Structure
NFX.Erlang Namespace


ErlPid Structure

ErlPid Structure NFX Class Library

Provides a C# representation of Erlang integer types

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct ErlPid : IErlObject<ErlPid>,
    IErlObject, IComparable, IComparable<IErlObject>, IEquatable<IErlObject>,
    ICloneable
public struct ErlPid : IErlObject<ErlPid>,
    IErlObject, IComparable, IComparable<IErlObject>, IEquatable<IErlObject>,
    ICloneable
Public Structure ErlPid
    Implements IErlObject(Of ErlPid), IErlObject,
    IComparable, IComparable(Of IErlObject), IEquatable(Of IErlObject),
    ICloneable
Public Structure ErlPid
    Implements IErlObject(Of ErlPid), IErlObject,
    IComparable, IComparable(Of IErlObject), IEquatable(Of IErlObject),
    ICloneable
public value class ErlPid : IErlObject<ErlPid>,
    IErlObject, IComparable, IComparable<IErlObject^>, IEquatable<IErlObject^>,
    ICloneable
public value class ErlPid : IErlObject<ErlPid>,
    IErlObject, IComparable, IComparable<IErlObject^>, IEquatable<IErlObject^>,
    ICloneable
[<SealedAttribute>]
type ErlPid =
    struct
        interface IErlObject<ErlPid>
        interface IErlObject
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
    end
[<SealedAttribute>]
type ErlPid =
    struct
        interface IErlObject<ErlPid>
        interface IErlObject
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
    end
See Also
ErlPid Members
NFX.Erlang Namespace


ErlPid Members

ErlPid Members NFX Class Library

The ErlPid type exposes the following members.
Constructors
 | Name | Description
Protected method | ErlPid(ErlAtom, Int32, Int32) | Create an Erlang pid from a monotonically increasing integer in range [1 ... ]
Public method | ErlPid(String, Int32, Int32, Int32) | Create an Erlang pid from the given values
Public method | ErlPid(ErlAtom, Int32, Int32, Int32) | Create an Erlang pid from the given values
Back to Top
Methods
 | Name | Description
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj
Public method | Equals(Object) | Determine if this instance equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(ErlPid) | Determine if two instances are equal
Public method | Equals(IErlObject) | Determine if two instances are equal
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Get internal hash code (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Public method | Matches | Perform pattern match on this Erlang term without binding any variables
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Parse |
Public method | Subst |
Public method | ToString | (Overrides Online ValueType ToString .)
 | TryParse |
Public method | Visit TAccumulate | Execute fun for every nested term
Back to Top
Operators
Name | Description
Equality |
Inequality |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Node |
 | Null | Special value non-existing Pid used for "null" pid comparison
Back to Top
Properties
 | Name | Description
Public property | Creation |
Public property | Empty |
Public property | Id |
Public property | IsScalar |
Protected property | Num |
Public property | Serial |
Public property | TypeOrder |
Public property | Value |
Public property | ValueAsBool |
Public property | ValueAsByteArray |
Public property | ValueAsChar |
Public property | ValueAsDateTime |
Public property | ValueAsDecimal |
Public property | ValueAsDouble |
Public property | ValueAsInt |
Public property | ValueAsLong |
Public property | ValueAsObject |
Public property | ValueAsString |
Public property | ValueAsTimeSpan |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone |
Back to Top
See Also
ErlPid Structure
NFX.Erlang Namespace


ErlPid Constructor

ErlPid Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | ErlPid(ErlAtom, Int32, Int32) | Create an Erlang pid from a monotonically increasing integer in range [1 ... ]
Public method | ErlPid(String, Int32, Int32, Int32) | Create an Erlang pid from the given values
Public method | ErlPid(ErlAtom, Int32, Int32, Int32) | Create an Erlang pid from the given values
Back to Top
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid Constructor (ErlAtom, Int32, Int32)

ErlPid Constructor (ErlAtom, Int32, Int32) NFX Class Library

Create an Erlang pid from a monotonically increasing integer in range [1 ... ]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ErlPid(
    ErlAtom node,
    int id,
    int creation
)
internal ErlPid(
    ErlAtom node,
    int id,
    int creation
)
Friend Sub New (
    node As ErlAtom,
    id As Integer,
    creation As Integer
)
Friend Sub New (
    node As ErlAtom,
    id As Integer,
    creation As Integer
)
internal:
ErlPid(
    ErlAtom node,
    int id,
    int creation
)
internal:
ErlPid(
    ErlAtom node,
    int id,
    int creation
)
new :
        node : ErlAtom *
        id : int *
        creation : int -> ErlPid
new :
        node : ErlAtom *
        id : int *
        creation : int -> ErlPid

Parameters

node
Type: NFX.Erlang ErlAtom
id
Type: Online System Int32
creation
Type: Online System Int32
See Also
ErlPid Structure
ErlPid Members
ErlPid Overload
NFX.Erlang Namespace


ErlPid Constructor (String, Int32, Int32, Int32)

ErlPid Constructor (String, Int32, Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Create an Erlang pid from the given values

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlPid(
    string node,
    int id,
    int serial,
    int creation
)
public ErlPid(
    string node,
    int id,
    int serial,
    int creation
)
Public Sub New (
    node As String,
    id As Integer,
    serial As Integer,
    creation As Integer
)
Public Sub New (
    node As String,
    id As Integer,
    serial As Integer,
    creation As Integer
)
public:
ErlPid(
    String^ node,
    int id,
    int serial,
    int creation
)
public:
ErlPid(
    String^ node,
    int id,
    int serial,
    int creation
)
new :
        node : string *
        id : int *
        serial : int *
        creation : int -> ErlPid
new :
        node : string *
        id : int *
        serial : int *
        creation : int -> ErlPid

Parameters

node
Type: Online System String
id
Type: Online System Int32
serial
Type: Online System Int32
creation
Type: Online System Int32
See Also
ErlPid Structure
ErlPid Members
ErlPid Overload
NFX.Erlang Namespace


ErlPid Constructor (ErlAtom, Int32, Int32, Int32)

ErlPid Constructor (ErlAtom, Int32, Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Create an Erlang pid from the given values

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlPid(
    ErlAtom node,
    int id,
    int serial,
    int creation
)
public ErlPid(
    ErlAtom node,
    int id,
    int serial,
    int creation
)
Public Sub New (
    node As ErlAtom,
    id As Integer,
    serial As Integer,
    creation As Integer
)
Public Sub New (
    node As ErlAtom,
    id As Integer,
    serial As Integer,
    creation As Integer
)
public:
ErlPid(
    ErlAtom node,
    int id,
    int serial,
    int creation
)
public:
ErlPid(
    ErlAtom node,
    int id,
    int serial,
    int creation
)
new :
        node : ErlAtom *
        id : int *
        serial : int *
        creation : int -> ErlPid
new :
        node : ErlAtom *
        id : int *
        serial : int *
        creation : int -> ErlPid

Parameters

node
Type: NFX.Erlang ErlAtom
id
Type: Online System Int32
serial
Type: Online System Int32
creation
Type: Online System Int32
See Also
ErlPid Structure
ErlPid Members
ErlPid Overload
NFX.Erlang Namespace


ErlPid Fields

ErlPid Fields NFX Class Library

The ErlPid type exposes the following members.
Fields
 | Name | Description
Public field | Node |
 | Null | Special value non-existing Pid used for "null" pid comparison
Back to Top
See Also
ErlPid Structure
NFX.Erlang Namespace


ErlPid.Node Field

ErlPid Node Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ErlAtom Node
public readonly ErlAtom Node
Public ReadOnly Node As ErlAtom
Public ReadOnly Node As ErlAtom
public:
initonly ErlAtom Node
public:
initonly ErlAtom Node
val Node: ErlAtom
val Node: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.Null Field

ErlPid Null Field NFX Class Library

Special value non-existing Pid used for "null" pid comparison

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ErlPid Null
public static readonly ErlPid Null
Public Shared ReadOnly Null As ErlPid
Public Shared ReadOnly Null As ErlPid
public:
static initonly ErlPid Null
public:
static initonly ErlPid Null
static val Null: ErlPid
static val Null: ErlPid

Field Value

Type: ErlPid
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid Methods

ErlPid Methods NFX Class Library

The ErlPid type exposes the following members.
Methods
 | Name | Description
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj
Public method | Equals(Object) | Determine if this instance equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(ErlPid) | Determine if two instances are equal
Public method | Equals(IErlObject) | Determine if two instances are equal
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Get internal hash code (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Public method | Matches | Perform pattern match on this Erlang term without binding any variables
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Parse |
Public method | Subst |
Public method | ToString | (Overrides Online ValueType ToString .)
 | TryParse |
Public method | Visit TAccumulate | Execute fun for every nested term
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone |
Back to Top
See Also
ErlPid Structure
NFX.Erlang Namespace


ErlPid.ICloneable.Clone Method

ErlPid ICloneable Clone Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object ICloneable.Clone()
Object ICloneable.Clone()
Private Function Clone As Object Implements ICloneable.Clone
Private Function Clone As Object Implements ICloneable.Clone
private:
virtual Object^ Clone() sealed = ICloneable::Clone
private:
virtual Object^ Clone() sealed = ICloneable::Clone
private abstract Clone : unit -> Object
private override Clone : unit -> Object
private abstract Clone : unit -> Object
private override Clone : unit -> Object

Return Value

Type: Online Object

Implements

Online ICloneable Clone
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.Clone Method

ErlPid Clone Method NFX Class Library

Clone an instance of the object (non-scalar immutable objects are copied by reference)

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject Clone()
public IErlObject Clone()
Public Function Clone As IErlObject
Public Function Clone As IErlObject
public:
virtual IErlObject^ Clone() sealed
public:
virtual IErlObject^ Clone() sealed
abstract Clone : unit -> IErlObject
override Clone : unit -> IErlObject
abstract Clone : unit -> IErlObject
override Clone : unit -> IErlObject

Return Value

Type: IErlObject

Implements

IErlObject Clone
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.CompareTo Method

ErlPid CompareTo Method NFX Class Library

Overload List
 | Name | Description
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj
Back to Top
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.CompareTo Method (Object)

ErlPid CompareTo Method (Object) NFX Class Library

Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    Object obj
)
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
Public Function CompareTo (
    obj As Object
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
public:
virtual int CompareTo(
    Object^ obj
) sealed
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int

Parameters

obj
Type: Online System Object

Return Value

Type: Online Int32

Implements

Online IComparable CompareTo(Object)
See Also
ErlPid Structure
ErlPid Members
CompareTo Overload
NFX.Erlang Namespace


ErlPid.CompareTo Method (IErlObject)

ErlPid CompareTo Method (IErlObject) NFX Class Library

Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    IErlObject obj
)
public int CompareTo(
    IErlObject obj
)
Public Function CompareTo (
    obj As IErlObject
) As Integer
Public Function CompareTo (
    obj As IErlObject
) As Integer
public:
virtual int CompareTo(
    IErlObject^ obj
) sealed
public:
virtual int CompareTo(
    IErlObject^ obj
) sealed
abstract CompareTo :
        obj : IErlObject -> int
override CompareTo :
        obj : IErlObject -> int
abstract CompareTo :
        obj : IErlObject -> int
override CompareTo :
        obj : IErlObject -> int

Parameters

obj
Type: NFX.Erlang IErlObject

Return Value

Type: Online Int32

Implements

Online IComparable T CompareTo(T)
See Also
ErlPid Structure
ErlPid Members
CompareTo Overload
NFX.Erlang Namespace


ErlPid.Equals Method

ErlPid Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | Determine if this instance equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(ErlPid) | Determine if two instances are equal
Public method | Equals(IErlObject) | Determine if two instances are equal
Back to Top
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.Equals Method (Object)

ErlPid Equals Method (Object) NFX Class Library

Determine if this instance equals to the object

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals (
    o As Object
) As Boolean
Public Overrides Function Equals (
    o As Object
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool

Parameters

o
Type: Online System Object

Return Value

Type: Online Boolean
See Also
ErlPid Structure
ErlPid Members
Equals Overload
NFX.Erlang Namespace


ErlPid.Equals Method (ErlPid)

ErlPid Equals Method (ErlPid) NFX Class Library

Determine if two instances are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    ErlPid pid
)
public bool Equals(
    ErlPid pid
)
Public Function Equals (
    pid As ErlPid
) As Boolean
Public Function Equals (
    pid As ErlPid
) As Boolean
public:
bool Equals(
    ErlPid pid
)
public:
bool Equals(
    ErlPid pid
)
member Equals :
        pid : ErlPid -> bool
member Equals :
        pid : ErlPid -> bool

Parameters

pid
Type: NFX.Erlang ErlPid

Return Value

Type: Online Boolean
See Also
ErlPid Structure
ErlPid Members
Equals Overload
NFX.Erlang Namespace


ErlPid.Equals Method (IErlObject)

ErlPid Equals Method (IErlObject) NFX Class Library

Determine if two instances are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    IErlObject o
)
public bool Equals(
    IErlObject o
)
Public Function Equals (
    o As IErlObject
) As Boolean
Public Function Equals (
    o As IErlObject
) As Boolean
public:
virtual bool Equals(
    IErlObject^ o
) sealed
public:
virtual bool Equals(
    IErlObject^ o
) sealed
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool

Parameters

o
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
ErlPid Structure
ErlPid Members
Equals Overload
NFX.Erlang Namespace


ErlPid.GetHashCode Method

ErlPid GetHashCode Method NFX Class Library

Get internal hash code

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.Match Method

ErlPid Match Method NFX Class Library

Overload List
 | Name | Description
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Back to Top
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.Match Method (IErlObject)

ErlPid Match Method (IErlObject) NFX Class Library

Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlVarBind Match(
    IErlObject pattern
)
public ErlVarBind Match(
    IErlObject pattern
)
Public Function Match (
    pattern As IErlObject
) As ErlVarBind
Public Function Match (
    pattern As IErlObject
) As ErlVarBind
public:
virtual ErlVarBind^ Match(
    IErlObject^ pattern
) sealed
public:
virtual ErlVarBind^ Match(
    IErlObject^ pattern
) sealed
abstract Match :
        pattern : IErlObject -> ErlVarBind
override Match :
        pattern : IErlObject -> ErlVarBind
abstract Match :
        pattern : IErlObject -> ErlVarBind
override Match :
        pattern : IErlObject -> ErlVarBind

Parameters

pattern
Type: NFX.Erlang IErlObject

Return Value

Type: ErlVarBind

Implements

IErlObject Match(IErlObject)
See Also
ErlPid Structure
ErlPid Members
Match Overload
NFX.Erlang Namespace


ErlPid.Match Method (IErlObject, ErlVarBind)

ErlPid Match Method (IErlObject, ErlVarBind) NFX Class Library

[This is preliminary documentation and is subject to change.]

Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Match(
    IErlObject pattern,
    ErlVarBind binding
)
public bool Match(
    IErlObject pattern,
    ErlVarBind binding
)
Public Function Match (
    pattern As IErlObject,
    binding As ErlVarBind
) As Boolean
Public Function Match (
    pattern As IErlObject,
    binding As ErlVarBind
) As Boolean
public:
virtual bool Match(
    IErlObject^ pattern,
    ErlVarBind^ binding
) sealed
public:
virtual bool Match(
    IErlObject^ pattern,
    ErlVarBind^ binding
) sealed
abstract Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
override Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
abstract Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
override Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool

Parameters

pattern
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind

Return Value

Type: Online Boolean

Implements

IErlObject Match(IErlObject, ErlVarBind)
See Also
ErlPid Structure
ErlPid Members
Match Overload
NFX.Erlang Namespace


ErlPid.Matches Method

ErlPid Matches Method NFX Class Library

Perform pattern match on this Erlang term without binding any variables

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Matches(
    IErlObject pattern
)
public bool Matches(
    IErlObject pattern
)
Public Function Matches (
    pattern As IErlObject
) As Boolean
Public Function Matches (
    pattern As IErlObject
) As Boolean
public:
virtual bool Matches(
    IErlObject^ pattern
) sealed
public:
virtual bool Matches(
    IErlObject^ pattern
) sealed
abstract Matches :
        pattern : IErlObject -> bool
override Matches :
        pattern : IErlObject -> bool
abstract Matches :
        pattern : IErlObject -> bool
override Matches :
        pattern : IErlObject -> bool

Parameters

pattern
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Implements

IErlObject Matches(IErlObject)
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.Parse Method

ErlPid Parse Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlPid Parse(
    string pid
)
public static ErlPid Parse(
    string pid
)
Public Shared Function Parse (
    pid As String
) As ErlPid
Public Shared Function Parse (
    pid As String
) As ErlPid
public:
static ErlPid Parse(
    String^ pid
)
public:
static ErlPid Parse(
    String^ pid
)
static member Parse :
        pid : string -> ErlPid
static member Parse :
        pid : string -> ErlPid

Parameters

pid
Type: Online System String

Return Value

Type: ErlPid
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.Subst Method

ErlPid Subst Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Subst(
    ref IErlObject term,
    ErlVarBind binding
)
public bool Subst(
    ref IErlObject term,
    ErlVarBind binding
)
Public Function Subst (
    ByRef term As IErlObject,
    binding As ErlVarBind
) As Boolean
Public Function Subst (
    ByRef term As IErlObject,
    binding As ErlVarBind
) As Boolean
public:
virtual bool Subst(
    IErlObject^% term,
    ErlVarBind^ binding
) sealed
public:
virtual bool Subst(
    IErlObject^% term,
    ErlVarBind^ binding
) sealed
abstract Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
override Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
abstract Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
override Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool

Parameters

term
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind

Return Value

Type: Online Boolean

Implements

IErlObject Subst(IErlObject , ErlVarBind)
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.ToString Method

ErlPid ToString Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.TryParse Method

ErlPid TryParse Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool TryParse(
    string pid,
    out ErlPid epid
)
public static bool TryParse(
    string pid,
    out ErlPid epid
)
Public Shared Function TryParse (
    pid As String,
    <OutAttribute> ByRef epid As ErlPid
) As Boolean
Public Shared Function TryParse (
    pid As String,
    <OutAttribute> ByRef epid As ErlPid
) As Boolean
public:
static bool TryParse(
    String^ pid,
    [OutAttribute] ErlPid% epid
)
public:
static bool TryParse(
    String^ pid,
    [OutAttribute] ErlPid% epid
)
static member TryParse :
        pid : string *
        epid : ErlPid byref -> bool
static member TryParse :
        pid : string *
        epid : ErlPid byref -> bool

Parameters

pid
Type: Online System String
epid
Type: NFX.Erlang ErlPid

Return Value

Type: Online Boolean
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.Visit(TAccumulate) Method

ErlPid Visit TAccumulate Method NFX Class Library

Execute fun for every nested term

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TAccumulate Visit<TAccumulate>(
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
public TAccumulate Visit<TAccumulate>(
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
Public Function Visit(Of TAccumulate) (
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
Public Function Visit(Of TAccumulate) (
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
public:
generic<typename TAccumulate>
virtual TAccumulate Visit(
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
) sealed
public:
generic<typename TAccumulate>
virtual TAccumulate Visit(
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
) sealed
abstract Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
override Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
abstract Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
override Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate

Parameters

acc
Type: TAccumulate
fun
Type: Online System Func TAccumulate, IErlObject, TAccumulate
Type Parameters
TAccumulate

Return Value

Type: TAccumulate

Implements

IErlObject Visit TAccumulate (TAccumulate, Func TAccumulate, IErlObject, TAccumulate )
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid Operators

ErlPid Operators NFX Class Library

The ErlPid type exposes the following members.
Operators
Name | Description
Equality |
Inequality |
Back to Top
See Also
ErlPid Structure
NFX.Erlang Namespace


ErlPid.Equality Operator

ErlPid Equality Operator NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    ErlPid lhs,
    ErlPid rhs
)
public static bool operator ==(
    ErlPid lhs,
    ErlPid rhs
)
Public Shared Operator = (
    lhs As ErlPid,
    rhs As ErlPid
) As Boolean
Public Shared Operator = (
    lhs As ErlPid,
    rhs As ErlPid
) As Boolean
public:
static bool operator ==(
    ErlPid lhs,
    ErlPid rhs
)
public:
static bool operator ==(
    ErlPid lhs,
    ErlPid rhs
)
static let inline (=)
        lhs : ErlPid *
        rhs : ErlPid  : bool
static let inline (=)
        lhs : ErlPid *
        rhs : ErlPid  : bool

Parameters

lhs
Type: NFX.Erlang ErlPid
rhs
Type: NFX.Erlang ErlPid

Return Value

Type: Online Boolean
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.Inequality Operator

ErlPid Inequality Operator NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    ErlPid lhs,
    ErlPid rhs
)
public static bool operator !=(
    ErlPid lhs,
    ErlPid rhs
)
Public Shared Operator <> (
    lhs As ErlPid,
    rhs As ErlPid
) As Boolean
Public Shared Operator <> (
    lhs As ErlPid,
    rhs As ErlPid
) As Boolean
public:
static bool operator !=(
    ErlPid lhs,
    ErlPid rhs
)
public:
static bool operator !=(
    ErlPid lhs,
    ErlPid rhs
)
static let inline (<>)
        lhs : ErlPid *
        rhs : ErlPid  : bool
static let inline (<>)
        lhs : ErlPid *
        rhs : ErlPid  : bool

Parameters

lhs
Type: NFX.Erlang ErlPid
rhs
Type: NFX.Erlang ErlPid

Return Value

Type: Online Boolean
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid Properties

ErlPid Properties NFX Class Library

The ErlPid type exposes the following members.
Properties
 | Name | Description
Public property | Creation |
Public property | Empty |
Public property | Id |
Public property | IsScalar |
Protected property | Num |
Public property | Serial |
Public property | TypeOrder |
Public property | Value |
Public property | ValueAsBool |
Public property | ValueAsByteArray |
Public property | ValueAsChar |
Public property | ValueAsDateTime |
Public property | ValueAsDecimal |
Public property | ValueAsDouble |
Public property | ValueAsInt |
Public property | ValueAsLong |
Public property | ValueAsObject |
Public property | ValueAsString |
Public property | ValueAsTimeSpan |
Back to Top
See Also
ErlPid Structure
NFX.Erlang Namespace


ErlPid.Creation Property

ErlPid Creation Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Creation { get; }
public int Creation { get; }
Public ReadOnly Property Creation As Integer
    Get
Public ReadOnly Property Creation As Integer
    Get
public:
property int Creation {
    int get ();
}
public:
property int Creation {
    int get ();
}
member Creation : int with get
member Creation : int with get

Property Value

Type: Online Int32
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.Empty Property

ErlPid Empty Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Empty { get; }
public bool Empty { get; }
Public ReadOnly Property Empty As Boolean
    Get
Public ReadOnly Property Empty As Boolean
    Get
public:
property bool Empty {
    bool get ();
}
public:
property bool Empty {
    bool get ();
}
member Empty : bool with get
member Empty : bool with get

Property Value

Type: Online Boolean
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.Id Property

ErlPid Id Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Id { get; }
public int Id { get; }
Public ReadOnly Property Id As Integer
    Get
Public ReadOnly Property Id As Integer
    Get
public:
property int Id {
    int get ();
}
public:
property int Id {
    int get ();
}
member Id : int with get
member Id : int with get

Property Value

Type: Online Int32
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.IsScalar Property

ErlPid IsScalar Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsScalar { get; }
public bool IsScalar { get; }
Public ReadOnly Property IsScalar As Boolean
    Get
Public ReadOnly Property IsScalar As Boolean
    Get
public:
virtual property bool IsScalar {
    bool get () sealed;
}
public:
virtual property bool IsScalar {
    bool get () sealed;
}
abstract IsScalar : bool with get
override IsScalar : bool with get
abstract IsScalar : bool with get
override IsScalar : bool with get

Property Value

Type: Online Boolean

Implements

IErlObject IsScalar
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.Num Property

ErlPid Num Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int Num { get; }
internal int Num { get; }
Friend ReadOnly Property Num As Integer
    Get
Friend ReadOnly Property Num As Integer
    Get
internal:
property int Num {
    int get ();
}
internal:
property int Num {
    int get ();
}
internal member Num : int with get
internal member Num : int with get

Property Value

Type: Online Int32
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.Serial Property

ErlPid Serial Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Serial { get; }
public int Serial { get; }
Public ReadOnly Property Serial As Integer
    Get
Public ReadOnly Property Serial As Integer
    Get
public:
property int Serial {
    int get ();
}
public:
property int Serial {
    int get ();
}
member Serial : int with get
member Serial : int with get

Property Value

Type: Online Int32
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.TypeOrder Property

ErlPid TypeOrder Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTypeOrder TypeOrder { get; }
public ErlTypeOrder TypeOrder { get; }
Public ReadOnly Property TypeOrder As ErlTypeOrder
    Get
Public ReadOnly Property TypeOrder As ErlTypeOrder
    Get
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () sealed;
}
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () sealed;
}
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get

Property Value

Type: ErlTypeOrder

Implements

IErlObject TypeOrder
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.Value Property

ErlPid Value Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlPid Value { get; }
public ErlPid Value { get; }
Public ReadOnly Property Value As ErlPid
    Get
Public ReadOnly Property Value As ErlPid
    Get
public:
virtual property ErlPid Value {
    ErlPid get () sealed;
}
public:
virtual property ErlPid Value {
    ErlPid get () sealed;
}
abstract Value : ErlPid with get
override Value : ErlPid with get
abstract Value : ErlPid with get
override Value : ErlPid with get

Property Value

Type: ErlPid

Implements

IErlObject T Value
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.ValueAsBool Property

ErlPid ValueAsBool Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ValueAsBool { get; }
public bool ValueAsBool { get; }
Public ReadOnly Property ValueAsBool As Boolean
    Get
Public ReadOnly Property ValueAsBool As Boolean
    Get
public:
virtual property bool ValueAsBool {
    bool get () sealed;
}
public:
virtual property bool ValueAsBool {
    bool get () sealed;
}
abstract ValueAsBool : bool with get
override ValueAsBool : bool with get
abstract ValueAsBool : bool with get
override ValueAsBool : bool with get

Property Value

Type: Online Boolean

Implements

IErlObject ValueAsBool
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.ValueAsByteArray Property

ErlPid ValueAsByteArray Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] ValueAsByteArray { get; }
public byte[] ValueAsByteArray { get; }
Public ReadOnly Property ValueAsByteArray As Byte()
    Get
Public ReadOnly Property ValueAsByteArray As Byte()
    Get
public:
virtual property array<unsigned char>^ ValueAsByteArray {
    array<unsigned char>^ get () sealed;
}
public:
virtual property array<unsigned char>^ ValueAsByteArray {
    array<unsigned char>^ get () sealed;
}
abstract ValueAsByteArray : byte[] with get
override ValueAsByteArray : byte[] with get
abstract ValueAsByteArray : byte[] with get
override ValueAsByteArray : byte[] with get

Property Value

Type: Online Byte

Implements

IErlObject ValueAsByteArray
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.ValueAsChar Property

ErlPid ValueAsChar Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char ValueAsChar { get; }
public char ValueAsChar { get; }
Public ReadOnly Property ValueAsChar As Char
    Get
Public ReadOnly Property ValueAsChar As Char
    Get
public:
virtual property wchar_t ValueAsChar {
    wchar_t get () sealed;
}
public:
virtual property wchar_t ValueAsChar {
    wchar_t get () sealed;
}
abstract ValueAsChar : char with get
override ValueAsChar : char with get
abstract ValueAsChar : char with get
override ValueAsChar : char with get

Property Value

Type: Online Char

Implements

IErlObject ValueAsChar
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.ValueAsDateTime Property

ErlPid ValueAsDateTime Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime ValueAsDateTime { get; }
public DateTime ValueAsDateTime { get; }
Public ReadOnly Property ValueAsDateTime As DateTime
    Get
Public ReadOnly Property ValueAsDateTime As DateTime
    Get
public:
virtual property DateTime ValueAsDateTime {
    DateTime get () sealed;
}
public:
virtual property DateTime ValueAsDateTime {
    DateTime get () sealed;
}
abstract ValueAsDateTime : DateTime with get
override ValueAsDateTime : DateTime with get
abstract ValueAsDateTime : DateTime with get
override ValueAsDateTime : DateTime with get

Property Value

Type: Online DateTime

Implements

IErlObject ValueAsDateTime
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.ValueAsDecimal Property

ErlPid ValueAsDecimal Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal ValueAsDecimal { get; }
public decimal ValueAsDecimal { get; }
Public ReadOnly Property ValueAsDecimal As Decimal
    Get
Public ReadOnly Property ValueAsDecimal As Decimal
    Get
public:
virtual property Decimal ValueAsDecimal {
    Decimal get () sealed;
}
public:
virtual property Decimal ValueAsDecimal {
    Decimal get () sealed;
}
abstract ValueAsDecimal : decimal with get
override ValueAsDecimal : decimal with get
abstract ValueAsDecimal : decimal with get
override ValueAsDecimal : decimal with get

Property Value

Type: Online Decimal

Implements

IErlObject ValueAsDecimal
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.ValueAsDouble Property

ErlPid ValueAsDouble Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double ValueAsDouble { get; }
public double ValueAsDouble { get; }
Public ReadOnly Property ValueAsDouble As Double
    Get
Public ReadOnly Property ValueAsDouble As Double
    Get
public:
virtual property double ValueAsDouble {
    double get () sealed;
}
public:
virtual property double ValueAsDouble {
    double get () sealed;
}
abstract ValueAsDouble : float with get
override ValueAsDouble : float with get
abstract ValueAsDouble : float with get
override ValueAsDouble : float with get

Property Value

Type: Online Double

Implements

IErlObject ValueAsDouble
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.ValueAsInt Property

ErlPid ValueAsInt Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ValueAsInt { get; }
public int ValueAsInt { get; }
Public ReadOnly Property ValueAsInt As Integer
    Get
Public ReadOnly Property ValueAsInt As Integer
    Get
public:
virtual property int ValueAsInt {
    int get () sealed;
}
public:
virtual property int ValueAsInt {
    int get () sealed;
}
abstract ValueAsInt : int with get
override ValueAsInt : int with get
abstract ValueAsInt : int with get
override ValueAsInt : int with get

Property Value

Type: Online Int32

Implements

IErlObject ValueAsInt
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.ValueAsLong Property

ErlPid ValueAsLong Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long ValueAsLong { get; }
public long ValueAsLong { get; }
Public ReadOnly Property ValueAsLong As Long
    Get
Public ReadOnly Property ValueAsLong As Long
    Get
public:
virtual property long long ValueAsLong {
    long long get () sealed;
}
public:
virtual property long long ValueAsLong {
    long long get () sealed;
}
abstract ValueAsLong : int64 with get
override ValueAsLong : int64 with get
abstract ValueAsLong : int64 with get
override ValueAsLong : int64 with get

Property Value

Type: Online Int64

Implements

IErlObject ValueAsLong
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.ValueAsObject Property

ErlPid ValueAsObject Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object ValueAsObject { get; }
public Object ValueAsObject { get; }
Public ReadOnly Property ValueAsObject As Object
    Get
Public ReadOnly Property ValueAsObject As Object
    Get
public:
virtual property Object^ ValueAsObject {
    Object^ get () sealed;
}
public:
virtual property Object^ ValueAsObject {
    Object^ get () sealed;
}
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get

Property Value

Type: Online Object

Implements

IErlObject ValueAsObject
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.ValueAsString Property

ErlPid ValueAsString Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ValueAsString { get; }
public string ValueAsString { get; }
Public ReadOnly Property ValueAsString As String
    Get
Public ReadOnly Property ValueAsString As String
    Get
public:
virtual property String^ ValueAsString {
    String^ get () sealed;
}
public:
virtual property String^ ValueAsString {
    String^ get () sealed;
}
abstract ValueAsString : string with get
override ValueAsString : string with get
abstract ValueAsString : string with get
override ValueAsString : string with get

Property Value

Type: Online String

Implements

IErlObject ValueAsString
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPid.ValueAsTimeSpan Property

ErlPid ValueAsTimeSpan Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpan ValueAsTimeSpan { get; }
public TimeSpan ValueAsTimeSpan { get; }
Public ReadOnly Property ValueAsTimeSpan As TimeSpan
    Get
Public ReadOnly Property ValueAsTimeSpan As TimeSpan
    Get
public:
virtual property TimeSpan ValueAsTimeSpan {
    TimeSpan get () sealed;
}
public:
virtual property TimeSpan ValueAsTimeSpan {
    TimeSpan get () sealed;
}
abstract ValueAsTimeSpan : TimeSpan with get
override ValueAsTimeSpan : TimeSpan with get
abstract ValueAsTimeSpan : TimeSpan with get
override ValueAsTimeSpan : TimeSpan with get

Property Value

Type: Online TimeSpan

Implements

IErlObject ValueAsTimeSpan
See Also
ErlPid Structure
ErlPid Members
NFX.Erlang Namespace


ErlPort Structure

ErlPort Structure NFX Class Library

Provides a C# representation of Erlang integer types

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct ErlPort : IErlObject<ErlPort>,
    IErlObject, IComparable, IComparable<IErlObject>, IEquatable<IErlObject>,
    ICloneable
public struct ErlPort : IErlObject<ErlPort>,
    IErlObject, IComparable, IComparable<IErlObject>, IEquatable<IErlObject>,
    ICloneable
Public Structure ErlPort
    Implements IErlObject(Of ErlPort), IErlObject,
    IComparable, IComparable(Of IErlObject), IEquatable(Of IErlObject),
    ICloneable
Public Structure ErlPort
    Implements IErlObject(Of ErlPort), IErlObject,
    IComparable, IComparable(Of IErlObject), IEquatable(Of IErlObject),
    ICloneable
public value class ErlPort : IErlObject<ErlPort>,
    IErlObject, IComparable, IComparable<IErlObject^>, IEquatable<IErlObject^>,
    ICloneable
public value class ErlPort : IErlObject<ErlPort>,
    IErlObject, IComparable, IComparable<IErlObject^>, IEquatable<IErlObject^>,
    ICloneable
[<SealedAttribute>]
type ErlPort =
    struct
        interface IErlObject<ErlPort>
        interface IErlObject
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
    end
[<SealedAttribute>]
type ErlPort =
    struct
        interface IErlObject<ErlPort>
        interface IErlObject
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
    end
See Also
ErlPort Members
NFX.Erlang Namespace


ErlPort Members

ErlPort Members NFX Class Library

The ErlPort type exposes the following members.
Constructors
 | Name | Description
Public method | ErlPort(String, Int32, Int32) | Create an Erlang port from the given values
Public method | ErlPort(ErlAtom, Int32, Int32) | Create an Erlang port from the given values
Back to Top
Methods
 | Name | Description
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj
Public method | Equals(Object) | Determine if this instance equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(ErlPort) | Determine if two instances are equal
Public method | Equals(IErlObject) | Determine if two instances are equal
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Get internal hash code (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Public method | Matches | Perform pattern match on this Erlang term without binding any variables
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Subst |
Public method | ToString | (Overrides Online ValueType ToString .)
Public method | Visit TAccumulate | Execute fun for every nested term
Back to Top
Operators
Name | Description
Equality |
Inequality |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Creation |
Public field | Id |
Public field | Node |
 | Null | Special value non-existing Port used for "null" pid comparison
Back to Top
Properties
 | Name | Description
Public property | Empty |
Public property | IsScalar |
Public property | TypeOrder |
Public property | Value |
Public property | ValueAsBool |
Public property | ValueAsByteArray |
Public property | ValueAsChar |
Public property | ValueAsDateTime |
Public property | ValueAsDecimal |
Public property | ValueAsDouble |
Public property | ValueAsInt |
Public property | ValueAsLong |
Public property | ValueAsObject |
Public property | ValueAsString |
Public property | ValueAsTimeSpan |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone |
Back to Top
See Also
ErlPort Structure
NFX.Erlang Namespace


ErlPort Constructor

ErlPort Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ErlPort(String, Int32, Int32) | Create an Erlang port from the given values
Public method | ErlPort(ErlAtom, Int32, Int32) | Create an Erlang port from the given values
Back to Top
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort Constructor (String, Int32, Int32)

ErlPort Constructor (String, Int32, Int32) NFX Class Library

Create an Erlang port from the given values

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlPort(
    string node,
    int id,
    int creation
)
public ErlPort(
    string node,
    int id,
    int creation
)
Public Sub New (
    node As String,
    id As Integer,
    creation As Integer
)
Public Sub New (
    node As String,
    id As Integer,
    creation As Integer
)
public:
ErlPort(
    String^ node,
    int id,
    int creation
)
public:
ErlPort(
    String^ node,
    int id,
    int creation
)
new :
        node : string *
        id : int *
        creation : int -> ErlPort
new :
        node : string *
        id : int *
        creation : int -> ErlPort

Parameters

node
Type: Online System String
id
Type: Online System Int32
creation
Type: Online System Int32
See Also
ErlPort Structure
ErlPort Members
ErlPort Overload
NFX.Erlang Namespace


ErlPort Constructor (ErlAtom, Int32, Int32)

ErlPort Constructor (ErlAtom, Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Create an Erlang port from the given values

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlPort(
    ErlAtom node,
    int id,
    int creation
)
public ErlPort(
    ErlAtom node,
    int id,
    int creation
)
Public Sub New (
    node As ErlAtom,
    id As Integer,
    creation As Integer
)
Public Sub New (
    node As ErlAtom,
    id As Integer,
    creation As Integer
)
public:
ErlPort(
    ErlAtom node,
    int id,
    int creation
)
public:
ErlPort(
    ErlAtom node,
    int id,
    int creation
)
new :
        node : ErlAtom *
        id : int *
        creation : int -> ErlPort
new :
        node : ErlAtom *
        id : int *
        creation : int -> ErlPort

Parameters

node
Type: NFX.Erlang ErlAtom
id
Type: Online System Int32
creation
Type: Online System Int32
See Also
ErlPort Structure
ErlPort Members
ErlPort Overload
NFX.Erlang Namespace


ErlPort Fields

ErlPort Fields NFX Class Library

The ErlPort type exposes the following members.
Fields
 | Name | Description
Public field | Creation |
Public field | Id |
Public field | Node |
 | Null | Special value non-existing Port used for "null" pid comparison
Back to Top
See Also
ErlPort Structure
NFX.Erlang Namespace


ErlPort.Creation Field

ErlPort Creation Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Creation
public readonly int Creation
Public ReadOnly Creation As Integer
Public ReadOnly Creation As Integer
public:
initonly int Creation
public:
initonly int Creation
val Creation: int
val Creation: int

Field Value

Type: Online Int32
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort.Id Field

ErlPort Id Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Id
public readonly int Id
Public ReadOnly Id As Integer
Public ReadOnly Id As Integer
public:
initonly int Id
public:
initonly int Id
val Id: int
val Id: int

Field Value

Type: Online Int32
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort.Node Field

ErlPort Node Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ErlAtom Node
public readonly ErlAtom Node
Public ReadOnly Node As ErlAtom
Public ReadOnly Node As ErlAtom
public:
initonly ErlAtom Node
public:
initonly ErlAtom Node
val Node: ErlAtom
val Node: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort.Null Field

ErlPort Null Field NFX Class Library

Special value non-existing Port used for "null" pid comparison

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ErlPort Null
public static readonly ErlPort Null
Public Shared ReadOnly Null As ErlPort
Public Shared ReadOnly Null As ErlPort
public:
static initonly ErlPort Null
public:
static initonly ErlPort Null
static val Null: ErlPort
static val Null: ErlPort

Field Value

Type: ErlPort
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort Methods

ErlPort Methods NFX Class Library

The ErlPort type exposes the following members.
Methods
 | Name | Description
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj
Public method | Equals(Object) | Determine if this instance equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(ErlPort) | Determine if two instances are equal
Public method | Equals(IErlObject) | Determine if two instances are equal
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Get internal hash code (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Public method | Matches | Perform pattern match on this Erlang term without binding any variables
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Subst |
Public method | ToString | (Overrides Online ValueType ToString .)
Public method | Visit TAccumulate | Execute fun for every nested term
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone |
Back to Top
See Also
ErlPort Structure
NFX.Erlang Namespace


ErlPort.ICloneable.Clone Method

ErlPort ICloneable Clone Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object ICloneable.Clone()
Object ICloneable.Clone()
Private Function Clone As Object Implements ICloneable.Clone
Private Function Clone As Object Implements ICloneable.Clone
private:
virtual Object^ Clone() sealed = ICloneable::Clone
private:
virtual Object^ Clone() sealed = ICloneable::Clone
private abstract Clone : unit -> Object
private override Clone : unit -> Object
private abstract Clone : unit -> Object
private override Clone : unit -> Object

Return Value

Type: Online Object

Implements

Online ICloneable Clone
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort.Clone Method

ErlPort Clone Method NFX Class Library

Clone an instance of the object (non-scalar immutable objects are copied by reference)

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject Clone()
public IErlObject Clone()
Public Function Clone As IErlObject
Public Function Clone As IErlObject
public:
virtual IErlObject^ Clone() sealed
public:
virtual IErlObject^ Clone() sealed
abstract Clone : unit -> IErlObject
override Clone : unit -> IErlObject
abstract Clone : unit -> IErlObject
override Clone : unit -> IErlObject

Return Value

Type: IErlObject

Implements

IErlObject Clone
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort.CompareTo Method

ErlPort CompareTo Method NFX Class Library

Overload List
 | Name | Description
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj
Back to Top
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort.CompareTo Method (Object)

ErlPort CompareTo Method (Object) NFX Class Library

Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    Object obj
)
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
Public Function CompareTo (
    obj As Object
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
public:
virtual int CompareTo(
    Object^ obj
) sealed
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int

Parameters

obj
Type: Online System Object

Return Value

Type: Online Int32

Implements

Online IComparable CompareTo(Object)
See Also
ErlPort Structure
ErlPort Members
CompareTo Overload
NFX.Erlang Namespace


ErlPort.CompareTo Method (IErlObject)

ErlPort CompareTo Method (IErlObject) NFX Class Library

Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    IErlObject obj
)
public int CompareTo(
    IErlObject obj
)
Public Function CompareTo (
    obj As IErlObject
) As Integer
Public Function CompareTo (
    obj As IErlObject
) As Integer
public:
virtual int CompareTo(
    IErlObject^ obj
) sealed
public:
virtual int CompareTo(
    IErlObject^ obj
) sealed
abstract CompareTo :
        obj : IErlObject -> int
override CompareTo :
        obj : IErlObject -> int
abstract CompareTo :
        obj : IErlObject -> int
override CompareTo :
        obj : IErlObject -> int

Parameters

obj
Type: NFX.Erlang IErlObject

Return Value

Type: Online Int32

Implements

Online IComparable T CompareTo(T)
See Also
ErlPort Structure
ErlPort Members
CompareTo Overload
NFX.Erlang Namespace


ErlPort.Equals Method

ErlPort Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | Determine if this instance equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(ErlPort) | Determine if two instances are equal
Public method | Equals(IErlObject) | Determine if two instances are equal
Back to Top
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort.Equals Method (Object)

ErlPort Equals Method (Object) NFX Class Library

Determine if this instance equals to the object

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals (
    o As Object
) As Boolean
Public Overrides Function Equals (
    o As Object
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool

Parameters

o
Type: Online System Object

Return Value

Type: Online Boolean
See Also
ErlPort Structure
ErlPort Members
Equals Overload
NFX.Erlang Namespace


ErlPort.Equals Method (ErlPort)

ErlPort Equals Method (ErlPort) NFX Class Library

Determine if two instances are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    ErlPort port
)
public bool Equals(
    ErlPort port
)
Public Function Equals (
    port As ErlPort
) As Boolean
Public Function Equals (
    port As ErlPort
) As Boolean
public:
bool Equals(
    ErlPort port
)
public:
bool Equals(
    ErlPort port
)
member Equals :
        port : ErlPort -> bool
member Equals :
        port : ErlPort -> bool

Parameters

port
Type: NFX.Erlang ErlPort

Return Value

Type: Online Boolean
See Also
ErlPort Structure
ErlPort Members
Equals Overload
NFX.Erlang Namespace


ErlPort.Equals Method (IErlObject)

ErlPort Equals Method (IErlObject) NFX Class Library

Determine if two instances are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    IErlObject o
)
public bool Equals(
    IErlObject o
)
Public Function Equals (
    o As IErlObject
) As Boolean
Public Function Equals (
    o As IErlObject
) As Boolean
public:
virtual bool Equals(
    IErlObject^ o
) sealed
public:
virtual bool Equals(
    IErlObject^ o
) sealed
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool

Parameters

o
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
ErlPort Structure
ErlPort Members
Equals Overload
NFX.Erlang Namespace


ErlPort.GetHashCode Method

ErlPort GetHashCode Method NFX Class Library

Get internal hash code

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort.Match Method

ErlPort Match Method NFX Class Library

Overload List
 | Name | Description
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Back to Top
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort.Match Method (IErlObject)

ErlPort Match Method (IErlObject) NFX Class Library

Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlVarBind Match(
    IErlObject pattern
)
public ErlVarBind Match(
    IErlObject pattern
)
Public Function Match (
    pattern As IErlObject
) As ErlVarBind
Public Function Match (
    pattern As IErlObject
) As ErlVarBind
public:
virtual ErlVarBind^ Match(
    IErlObject^ pattern
) sealed
public:
virtual ErlVarBind^ Match(
    IErlObject^ pattern
) sealed
abstract Match :
        pattern : IErlObject -> ErlVarBind
override Match :
        pattern : IErlObject -> ErlVarBind
abstract Match :
        pattern : IErlObject -> ErlVarBind
override Match :
        pattern : IErlObject -> ErlVarBind

Parameters

pattern
Type: NFX.Erlang IErlObject

Return Value

Type: ErlVarBind

Implements

IErlObject Match(IErlObject)
See Also
ErlPort Structure
ErlPort Members
Match Overload
NFX.Erlang Namespace


ErlPort.Match Method (IErlObject, ErlVarBind)

ErlPort Match Method (IErlObject, ErlVarBind) NFX Class Library

[This is preliminary documentation and is subject to change.]

Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Match(
    IErlObject pattern,
    ErlVarBind binding
)
public bool Match(
    IErlObject pattern,
    ErlVarBind binding
)
Public Function Match (
    pattern As IErlObject,
    binding As ErlVarBind
) As Boolean
Public Function Match (
    pattern As IErlObject,
    binding As ErlVarBind
) As Boolean
public:
virtual bool Match(
    IErlObject^ pattern,
    ErlVarBind^ binding
) sealed
public:
virtual bool Match(
    IErlObject^ pattern,
    ErlVarBind^ binding
) sealed
abstract Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
override Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
abstract Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
override Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool

Parameters

pattern
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind

Return Value

Type: Online Boolean

Implements

IErlObject Match(IErlObject, ErlVarBind)
See Also
ErlPort Structure
ErlPort Members
Match Overload
NFX.Erlang Namespace


ErlPort.Matches Method

ErlPort Matches Method NFX Class Library

Perform pattern match on this Erlang term without binding any variables

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Matches(
    IErlObject pattern
)
public bool Matches(
    IErlObject pattern
)
Public Function Matches (
    pattern As IErlObject
) As Boolean
Public Function Matches (
    pattern As IErlObject
) As Boolean
public:
virtual bool Matches(
    IErlObject^ pattern
) sealed
public:
virtual bool Matches(
    IErlObject^ pattern
) sealed
abstract Matches :
        pattern : IErlObject -> bool
override Matches :
        pattern : IErlObject -> bool
abstract Matches :
        pattern : IErlObject -> bool
override Matches :
        pattern : IErlObject -> bool

Parameters

pattern
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Implements

IErlObject Matches(IErlObject)
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort.Subst Method

ErlPort Subst Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Subst(
    ref IErlObject term,
    ErlVarBind binding
)
public bool Subst(
    ref IErlObject term,
    ErlVarBind binding
)
Public Function Subst (
    ByRef term As IErlObject,
    binding As ErlVarBind
) As Boolean
Public Function Subst (
    ByRef term As IErlObject,
    binding As ErlVarBind
) As Boolean
public:
virtual bool Subst(
    IErlObject^% term,
    ErlVarBind^ binding
) sealed
public:
virtual bool Subst(
    IErlObject^% term,
    ErlVarBind^ binding
) sealed
abstract Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
override Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
abstract Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
override Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool

Parameters

term
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind

Return Value

Type: Online Boolean

Implements

IErlObject Subst(IErlObject , ErlVarBind)
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort.ToString Method

ErlPort ToString Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort.Visit(TAccumulate) Method

ErlPort Visit TAccumulate Method NFX Class Library

Execute fun for every nested term

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TAccumulate Visit<TAccumulate>(
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
public TAccumulate Visit<TAccumulate>(
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
Public Function Visit(Of TAccumulate) (
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
Public Function Visit(Of TAccumulate) (
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
public:
generic<typename TAccumulate>
virtual TAccumulate Visit(
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
) sealed
public:
generic<typename TAccumulate>
virtual TAccumulate Visit(
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
) sealed
abstract Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
override Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
abstract Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
override Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate

Parameters

acc
Type: TAccumulate
fun
Type: Online System Func TAccumulate, IErlObject, TAccumulate
Type Parameters
TAccumulate

Return Value

Type: TAccumulate

Implements

IErlObject Visit TAccumulate (TAccumulate, Func TAccumulate, IErlObject, TAccumulate )
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort Operators

ErlPort Operators NFX Class Library

The ErlPort type exposes the following members.
Operators
Name | Description
Equality |
Inequality |
Back to Top
See Also
ErlPort Structure
NFX.Erlang Namespace


ErlPort.Equality Operator

ErlPort Equality Operator NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    ErlPort lhs,
    ErlPort rhs
)
public static bool operator ==(
    ErlPort lhs,
    ErlPort rhs
)
Public Shared Operator = (
    lhs As ErlPort,
    rhs As ErlPort
) As Boolean
Public Shared Operator = (
    lhs As ErlPort,
    rhs As ErlPort
) As Boolean
public:
static bool operator ==(
    ErlPort lhs,
    ErlPort rhs
)
public:
static bool operator ==(
    ErlPort lhs,
    ErlPort rhs
)
static let inline (=)
        lhs : ErlPort *
        rhs : ErlPort  : bool
static let inline (=)
        lhs : ErlPort *
        rhs : ErlPort  : bool

Parameters

lhs
Type: NFX.Erlang ErlPort
rhs
Type: NFX.Erlang ErlPort

Return Value

Type: Online Boolean
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort.Inequality Operator

ErlPort Inequality Operator NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    ErlPort lhs,
    ErlPort rhs
)
public static bool operator !=(
    ErlPort lhs,
    ErlPort rhs
)
Public Shared Operator <> (
    lhs As ErlPort,
    rhs As ErlPort
) As Boolean
Public Shared Operator <> (
    lhs As ErlPort,
    rhs As ErlPort
) As Boolean
public:
static bool operator !=(
    ErlPort lhs,
    ErlPort rhs
)
public:
static bool operator !=(
    ErlPort lhs,
    ErlPort rhs
)
static let inline (<>)
        lhs : ErlPort *
        rhs : ErlPort  : bool
static let inline (<>)
        lhs : ErlPort *
        rhs : ErlPort  : bool

Parameters

lhs
Type: NFX.Erlang ErlPort
rhs
Type: NFX.Erlang ErlPort

Return Value

Type: Online Boolean
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort Properties

ErlPort Properties NFX Class Library

The ErlPort type exposes the following members.
Properties
 | Name | Description
Public property | Empty |
Public property | IsScalar |
Public property | TypeOrder |
Public property | Value |
Public property | ValueAsBool |
Public property | ValueAsByteArray |
Public property | ValueAsChar |
Public property | ValueAsDateTime |
Public property | ValueAsDecimal |
Public property | ValueAsDouble |
Public property | ValueAsInt |
Public property | ValueAsLong |
Public property | ValueAsObject |
Public property | ValueAsString |
Public property | ValueAsTimeSpan |
Back to Top
See Also
ErlPort Structure
NFX.Erlang Namespace


ErlPort.Empty Property

ErlPort Empty Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Empty { get; }
public bool Empty { get; }
Public ReadOnly Property Empty As Boolean
    Get
Public ReadOnly Property Empty As Boolean
    Get
public:
property bool Empty {
    bool get ();
}
public:
property bool Empty {
    bool get ();
}
member Empty : bool with get
member Empty : bool with get

Property Value

Type: Online Boolean
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort.IsScalar Property

ErlPort IsScalar Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsScalar { get; }
public bool IsScalar { get; }
Public ReadOnly Property IsScalar As Boolean
    Get
Public ReadOnly Property IsScalar As Boolean
    Get
public:
virtual property bool IsScalar {
    bool get () sealed;
}
public:
virtual property bool IsScalar {
    bool get () sealed;
}
abstract IsScalar : bool with get
override IsScalar : bool with get
abstract IsScalar : bool with get
override IsScalar : bool with get

Property Value

Type: Online Boolean

Implements

IErlObject IsScalar
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort.TypeOrder Property

ErlPort TypeOrder Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTypeOrder TypeOrder { get; }
public ErlTypeOrder TypeOrder { get; }
Public ReadOnly Property TypeOrder As ErlTypeOrder
    Get
Public ReadOnly Property TypeOrder As ErlTypeOrder
    Get
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () sealed;
}
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () sealed;
}
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get

Property Value

Type: ErlTypeOrder

Implements

IErlObject TypeOrder
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort.Value Property

ErlPort Value Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlPort Value { get; }
public ErlPort Value { get; }
Public ReadOnly Property Value As ErlPort
    Get
Public ReadOnly Property Value As ErlPort
    Get
public:
virtual property ErlPort Value {
    ErlPort get () sealed;
}
public:
virtual property ErlPort Value {
    ErlPort get () sealed;
}
abstract Value : ErlPort with get
override Value : ErlPort with get
abstract Value : ErlPort with get
override Value : ErlPort with get

Property Value

Type: ErlPort

Implements

IErlObject T Value
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort.ValueAsBool Property

ErlPort ValueAsBool Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ValueAsBool { get; }
public bool ValueAsBool { get; }
Public ReadOnly Property ValueAsBool As Boolean
    Get
Public ReadOnly Property ValueAsBool As Boolean
    Get
public:
virtual property bool ValueAsBool {
    bool get () sealed;
}
public:
virtual property bool ValueAsBool {
    bool get () sealed;
}
abstract ValueAsBool : bool with get
override ValueAsBool : bool with get
abstract ValueAsBool : bool with get
override ValueAsBool : bool with get

Property Value

Type: Online Boolean

Implements

IErlObject ValueAsBool
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort.ValueAsByteArray Property

ErlPort ValueAsByteArray Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] ValueAsByteArray { get; }
public byte[] ValueAsByteArray { get; }
Public ReadOnly Property ValueAsByteArray As Byte()
    Get
Public ReadOnly Property ValueAsByteArray As Byte()
    Get
public:
virtual property array<unsigned char>^ ValueAsByteArray {
    array<unsigned char>^ get () sealed;
}
public:
virtual property array<unsigned char>^ ValueAsByteArray {
    array<unsigned char>^ get () sealed;
}
abstract ValueAsByteArray : byte[] with get
override ValueAsByteArray : byte[] with get
abstract ValueAsByteArray : byte[] with get
override ValueAsByteArray : byte[] with get

Property Value

Type: Online Byte

Implements

IErlObject ValueAsByteArray
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort.ValueAsChar Property

ErlPort ValueAsChar Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char ValueAsChar { get; }
public char ValueAsChar { get; }
Public ReadOnly Property ValueAsChar As Char
    Get
Public ReadOnly Property ValueAsChar As Char
    Get
public:
virtual property wchar_t ValueAsChar {
    wchar_t get () sealed;
}
public:
virtual property wchar_t ValueAsChar {
    wchar_t get () sealed;
}
abstract ValueAsChar : char with get
override ValueAsChar : char with get
abstract ValueAsChar : char with get
override ValueAsChar : char with get

Property Value

Type: Online Char

Implements

IErlObject ValueAsChar
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort.ValueAsDateTime Property

ErlPort ValueAsDateTime Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime ValueAsDateTime { get; }
public DateTime ValueAsDateTime { get; }
Public ReadOnly Property ValueAsDateTime As DateTime
    Get
Public ReadOnly Property ValueAsDateTime As DateTime
    Get
public:
virtual property DateTime ValueAsDateTime {
    DateTime get () sealed;
}
public:
virtual property DateTime ValueAsDateTime {
    DateTime get () sealed;
}
abstract ValueAsDateTime : DateTime with get
override ValueAsDateTime : DateTime with get
abstract ValueAsDateTime : DateTime with get
override ValueAsDateTime : DateTime with get

Property Value

Type: Online DateTime

Implements

IErlObject ValueAsDateTime
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort.ValueAsDecimal Property

ErlPort ValueAsDecimal Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal ValueAsDecimal { get; }
public decimal ValueAsDecimal { get; }
Public ReadOnly Property ValueAsDecimal As Decimal
    Get
Public ReadOnly Property ValueAsDecimal As Decimal
    Get
public:
virtual property Decimal ValueAsDecimal {
    Decimal get () sealed;
}
public:
virtual property Decimal ValueAsDecimal {
    Decimal get () sealed;
}
abstract ValueAsDecimal : decimal with get
override ValueAsDecimal : decimal with get
abstract ValueAsDecimal : decimal with get
override ValueAsDecimal : decimal with get

Property Value

Type: Online Decimal

Implements

IErlObject ValueAsDecimal
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort.ValueAsDouble Property

ErlPort ValueAsDouble Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double ValueAsDouble { get; }
public double ValueAsDouble { get; }
Public ReadOnly Property ValueAsDouble As Double
    Get
Public ReadOnly Property ValueAsDouble As Double
    Get
public:
virtual property double ValueAsDouble {
    double get () sealed;
}
public:
virtual property double ValueAsDouble {
    double get () sealed;
}
abstract ValueAsDouble : float with get
override ValueAsDouble : float with get
abstract ValueAsDouble : float with get
override ValueAsDouble : float with get

Property Value

Type: Online Double

Implements

IErlObject ValueAsDouble
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort.ValueAsInt Property

ErlPort ValueAsInt Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ValueAsInt { get; }
public int ValueAsInt { get; }
Public ReadOnly Property ValueAsInt As Integer
    Get
Public ReadOnly Property ValueAsInt As Integer
    Get
public:
virtual property int ValueAsInt {
    int get () sealed;
}
public:
virtual property int ValueAsInt {
    int get () sealed;
}
abstract ValueAsInt : int with get
override ValueAsInt : int with get
abstract ValueAsInt : int with get
override ValueAsInt : int with get

Property Value

Type: Online Int32

Implements

IErlObject ValueAsInt
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort.ValueAsLong Property

ErlPort ValueAsLong Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long ValueAsLong { get; }
public long ValueAsLong { get; }
Public ReadOnly Property ValueAsLong As Long
    Get
Public ReadOnly Property ValueAsLong As Long
    Get
public:
virtual property long long ValueAsLong {
    long long get () sealed;
}
public:
virtual property long long ValueAsLong {
    long long get () sealed;
}
abstract ValueAsLong : int64 with get
override ValueAsLong : int64 with get
abstract ValueAsLong : int64 with get
override ValueAsLong : int64 with get

Property Value

Type: Online Int64

Implements

IErlObject ValueAsLong
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort.ValueAsObject Property

ErlPort ValueAsObject Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object ValueAsObject { get; }
public Object ValueAsObject { get; }
Public ReadOnly Property ValueAsObject As Object
    Get
Public ReadOnly Property ValueAsObject As Object
    Get
public:
virtual property Object^ ValueAsObject {
    Object^ get () sealed;
}
public:
virtual property Object^ ValueAsObject {
    Object^ get () sealed;
}
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get

Property Value

Type: Online Object

Implements

IErlObject ValueAsObject
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort.ValueAsString Property

ErlPort ValueAsString Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ValueAsString { get; }
public string ValueAsString { get; }
Public ReadOnly Property ValueAsString As String
    Get
Public ReadOnly Property ValueAsString As String
    Get
public:
virtual property String^ ValueAsString {
    String^ get () sealed;
}
public:
virtual property String^ ValueAsString {
    String^ get () sealed;
}
abstract ValueAsString : string with get
override ValueAsString : string with get
abstract ValueAsString : string with get
override ValueAsString : string with get

Property Value

Type: Online String

Implements

IErlObject ValueAsString
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlPort.ValueAsTimeSpan Property

ErlPort ValueAsTimeSpan Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpan ValueAsTimeSpan { get; }
public TimeSpan ValueAsTimeSpan { get; }
Public ReadOnly Property ValueAsTimeSpan As TimeSpan
    Get
Public ReadOnly Property ValueAsTimeSpan As TimeSpan
    Get
public:
virtual property TimeSpan ValueAsTimeSpan {
    TimeSpan get () sealed;
}
public:
virtual property TimeSpan ValueAsTimeSpan {
    TimeSpan get () sealed;
}
abstract ValueAsTimeSpan : TimeSpan with get
override ValueAsTimeSpan : TimeSpan with get
abstract ValueAsTimeSpan : TimeSpan with get
override ValueAsTimeSpan : TimeSpan with get

Property Value

Type: Online TimeSpan

Implements

IErlObject ValueAsTimeSpan
See Also
ErlPort Structure
ErlPort Members
NFX.Erlang Namespace


ErlRef Structure

ErlRef Structure NFX Class Library

Provides a C# representation of Erlang integer types

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct ErlRef : IErlObject<ErlRef>,
    IErlObject, IComparable, IComparable<IErlObject>, IEquatable<IErlObject>,
    ICloneable
public struct ErlRef : IErlObject<ErlRef>,
    IErlObject, IComparable, IComparable<IErlObject>, IEquatable<IErlObject>,
    ICloneable
Public Structure ErlRef
    Implements IErlObject(Of ErlRef), IErlObject,
    IComparable, IComparable(Of IErlObject), IEquatable(Of IErlObject),
    ICloneable
Public Structure ErlRef
    Implements IErlObject(Of ErlRef), IErlObject,
    IComparable, IComparable(Of IErlObject), IEquatable(Of IErlObject),
    ICloneable
public value class ErlRef : IErlObject<ErlRef>,
    IErlObject, IComparable, IComparable<IErlObject^>, IEquatable<IErlObject^>,
    ICloneable
public value class ErlRef : IErlObject<ErlRef>,
    IErlObject, IComparable, IComparable<IErlObject^>, IEquatable<IErlObject^>,
    ICloneable
[<SealedAttribute>]
type ErlRef =
    struct
        interface IErlObject<ErlRef>
        interface IErlObject
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
    end
[<SealedAttribute>]
type ErlRef =
    struct
        interface IErlObject<ErlRef>
        interface IErlObject
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
    end
See Also
ErlRef Members
NFX.Erlang Namespace


ErlRef Members

ErlRef Members NFX Class Library

The ErlRef type exposes the following members.
Constructors
 | Name | Description
Public method | ErlRef(String, Int32 , Int32) | Create an Erlang reference from the given values
Public method | ErlRef(ErlAtom, Int32 , Int32) | Create an Erlang reference from the given values
Public method | ErlRef(ErlAtom, UInt32 , Int32) | Create an Erlang reference from the given values
Public method | ErlRef(String, Int32, Int32, Int32, Int32) | Initializes a new instance of the ErlRef class
Public method | ErlRef(ErlAtom, Int32, Int32, Int32, Int32) | Initializes a new instance of the ErlRef class
Back to Top
Methods
 | Name | Description
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj
Public method | Equals(Object) | Determine if this instance equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(ErlRef) | Determine if two instances are equal
Public method | Equals(IErlObject) | Determine if two instances are equal
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Get internal hash code (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Public method | Matches | Perform pattern match on this Erlang term without binding any variables
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Parse |
Public method | Subst |
Public method | ToString | (Overrides Online ValueType ToString .)
 | TryParse |
Public method | Visit TAccumulate | Execute fun for every nested term
Back to Top
Operators
Name | Description
Equality |
Inequality |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Creation |
Public field | Ids |
Public field | Node |
 | Null | Special value non-existing Pid used for "null" ref comparison
Back to Top
Properties
 | Name | Description
Public property | Empty |
Public property | IsScalar |
Public property | TypeOrder |
Public property | Value |
Public property | ValueAsBool |
Public property | ValueAsByteArray |
Public property | ValueAsChar |
Public property | ValueAsDateTime |
Public property | ValueAsDecimal |
Public property | ValueAsDouble |
Public property | ValueAsInt |
Public property | ValueAsLong |
Public property | ValueAsObject |
Public property | ValueAsString |
Public property | ValueAsTimeSpan |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone |
Back to Top
See Also
ErlRef Structure
NFX.Erlang Namespace


ErlRef Constructor

ErlRef Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ErlRef(String, Int32 , Int32) | Create an Erlang reference from the given values
Public method | ErlRef(ErlAtom, Int32 , Int32) | Create an Erlang reference from the given values
Public method | ErlRef(ErlAtom, UInt32 , Int32) | Create an Erlang reference from the given values
Public method | ErlRef(String, Int32, Int32, Int32, Int32) | Initializes a new instance of the ErlRef class
Public method | ErlRef(ErlAtom, Int32, Int32, Int32, Int32) | Initializes a new instance of the ErlRef class
Back to Top
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef Constructor (String, Int32[], Int32)

ErlRef Constructor (String, Int32 , Int32) NFX Class Library

Create an Erlang reference from the given values

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlRef(
    string node,
    int[] ids,
    int creation
)
public ErlRef(
    string node,
    int[] ids,
    int creation
)
Public Sub New (
    node As String,
    ids As Integer(),
    creation As Integer
)
Public Sub New (
    node As String,
    ids As Integer(),
    creation As Integer
)
public:
ErlRef(
    String^ node,
    array<int>^ ids,
    int creation
)
public:
ErlRef(
    String^ node,
    array<int>^ ids,
    int creation
)
new :
        node : string *
        ids : int[] *
        creation : int -> ErlRef
new :
        node : string *
        ids : int[] *
        creation : int -> ErlRef

Parameters

node
Type: Online System String
ids
Type: Online System Int32
creation
Type: Online System Int32
See Also
ErlRef Structure
ErlRef Members
ErlRef Overload
NFX.Erlang Namespace


ErlRef Constructor (ErlAtom, Int32[], Int32)

ErlRef Constructor (ErlAtom, Int32 , Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Create an Erlang reference from the given values

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlRef(
    ErlAtom node,
    int[] ids,
    int creation
)
public ErlRef(
    ErlAtom node,
    int[] ids,
    int creation
)
Public Sub New (
    node As ErlAtom,
    ids As Integer(),
    creation As Integer
)
Public Sub New (
    node As ErlAtom,
    ids As Integer(),
    creation As Integer
)
public:
ErlRef(
    ErlAtom node,
    array<int>^ ids,
    int creation
)
public:
ErlRef(
    ErlAtom node,
    array<int>^ ids,
    int creation
)
new :
        node : ErlAtom *
        ids : int[] *
        creation : int -> ErlRef
new :
        node : ErlAtom *
        ids : int[] *
        creation : int -> ErlRef

Parameters

node
Type: NFX.Erlang ErlAtom
ids
Type: Online System Int32
creation
Type: Online System Int32
See Also
ErlRef Structure
ErlRef Members
ErlRef Overload
NFX.Erlang Namespace


ErlRef Constructor (ErlAtom, UInt32[], Int32)

ErlRef Constructor (ErlAtom, UInt32 , Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Create an Erlang reference from the given values

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlRef(
    ErlAtom node,
    uint[] ids,
    int creation
)
public ErlRef(
    ErlAtom node,
    uint[] ids,
    int creation
)
Public Sub New (
    node As ErlAtom,
    ids As UInteger(),
    creation As Integer
)
Public Sub New (
    node As ErlAtom,
    ids As UInteger(),
    creation As Integer
)
public:
ErlRef(
    ErlAtom node,
    array<unsigned int>^ ids,
    int creation
)
public:
ErlRef(
    ErlAtom node,
    array<unsigned int>^ ids,
    int creation
)
new :
        node : ErlAtom *
        ids : uint32[] *
        creation : int -> ErlRef
new :
        node : ErlAtom *
        ids : uint32[] *
        creation : int -> ErlRef

Parameters

node
Type: NFX.Erlang ErlAtom
ids
Type: Online System UInt32
creation
Type: Online System Int32
See Also
ErlRef Structure
ErlRef Members
ErlRef Overload
NFX.Erlang Namespace


ErlRef Constructor (String, Int32, Int32, Int32, Int32)

ErlRef Constructor (String, Int32, Int32, Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlRef class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlRef(
    string node,
    int id1,
    int id2,
    int id3,
    int creation
)
public ErlRef(
    string node,
    int id1,
    int id2,
    int id3,
    int creation
)
Public Sub New (
    node As String,
    id1 As Integer,
    id2 As Integer,
    id3 As Integer,
    creation As Integer
)
Public Sub New (
    node As String,
    id1 As Integer,
    id2 As Integer,
    id3 As Integer,
    creation As Integer
)
public:
ErlRef(
    String^ node,
    int id1,
    int id2,
    int id3,
    int creation
)
public:
ErlRef(
    String^ node,
    int id1,
    int id2,
    int id3,
    int creation
)
new :
        node : string *
        id1 : int *
        id2 : int *
        id3 : int *
        creation : int -> ErlRef
new :
        node : string *
        id1 : int *
        id2 : int *
        id3 : int *
        creation : int -> ErlRef

Parameters

node
Type: Online System String
id1
Type: Online System Int32
id2
Type: Online System Int32
id3
Type: Online System Int32
creation
Type: Online System Int32
See Also
ErlRef Structure
ErlRef Members
ErlRef Overload
NFX.Erlang Namespace


ErlRef Constructor (ErlAtom, Int32, Int32, Int32, Int32)

ErlRef Constructor (ErlAtom, Int32, Int32, Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlRef class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlRef(
    ErlAtom node,
    int id1,
    int id2,
    int id3,
    int creation
)
public ErlRef(
    ErlAtom node,
    int id1,
    int id2,
    int id3,
    int creation
)
Public Sub New (
    node As ErlAtom,
    id1 As Integer,
    id2 As Integer,
    id3 As Integer,
    creation As Integer
)
Public Sub New (
    node As ErlAtom,
    id1 As Integer,
    id2 As Integer,
    id3 As Integer,
    creation As Integer
)
public:
ErlRef(
    ErlAtom node,
    int id1,
    int id2,
    int id3,
    int creation
)
public:
ErlRef(
    ErlAtom node,
    int id1,
    int id2,
    int id3,
    int creation
)
new :
        node : ErlAtom *
        id1 : int *
        id2 : int *
        id3 : int *
        creation : int -> ErlRef
new :
        node : ErlAtom *
        id1 : int *
        id2 : int *
        id3 : int *
        creation : int -> ErlRef

Parameters

node
Type: NFX.Erlang ErlAtom
id1
Type: Online System Int32
id2
Type: Online System Int32
id3
Type: Online System Int32
creation
Type: Online System Int32
See Also
ErlRef Structure
ErlRef Members
ErlRef Overload
NFX.Erlang Namespace


ErlRef Fields

ErlRef Fields NFX Class Library

The ErlRef type exposes the following members.
Fields
 | Name | Description
Public field | Creation |
Public field | Ids |
Public field | Node |
 | Null | Special value non-existing Pid used for "null" ref comparison
Back to Top
See Also
ErlRef Structure
NFX.Erlang Namespace


ErlRef.Creation Field

ErlRef Creation Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Creation
public readonly int Creation
Public ReadOnly Creation As Integer
Public ReadOnly Creation As Integer
public:
initonly int Creation
public:
initonly int Creation
val Creation: int
val Creation: int

Field Value

Type: Online Int32
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.Ids Field

ErlRef Ids Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly uint[] Ids
public readonly uint[] Ids
Public ReadOnly Ids As UInteger()
Public ReadOnly Ids As UInteger()
public:
initonly array<unsigned int>^ Ids
public:
initonly array<unsigned int>^ Ids
val Ids: uint32[]
val Ids: uint32[]

Field Value

Type: Online UInt32
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.Node Field

ErlRef Node Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ErlAtom Node
public readonly ErlAtom Node
Public ReadOnly Node As ErlAtom
Public ReadOnly Node As ErlAtom
public:
initonly ErlAtom Node
public:
initonly ErlAtom Node
val Node: ErlAtom
val Node: ErlAtom

Field Value

Type: ErlAtom
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.Null Field

ErlRef Null Field NFX Class Library

Special value non-existing Pid used for "null" ref comparison

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ErlRef Null
public static readonly ErlRef Null
Public Shared ReadOnly Null As ErlRef
Public Shared ReadOnly Null As ErlRef
public:
static initonly ErlRef Null
public:
static initonly ErlRef Null
static val Null: ErlRef
static val Null: ErlRef

Field Value

Type: ErlRef
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef Methods

ErlRef Methods NFX Class Library

The ErlRef type exposes the following members.
Methods
 | Name | Description
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj
Public method | Equals(Object) | Determine if this instance equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(ErlRef) | Determine if two instances are equal
Public method | Equals(IErlObject) | Determine if two instances are equal
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Get internal hash code (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Public method | Matches | Perform pattern match on this Erlang term without binding any variables
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Parse |
Public method | Subst |
Public method | ToString | (Overrides Online ValueType ToString .)
 | TryParse |
Public method | Visit TAccumulate | Execute fun for every nested term
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone |
Back to Top
See Also
ErlRef Structure
NFX.Erlang Namespace


ErlRef.ICloneable.Clone Method

ErlRef ICloneable Clone Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object ICloneable.Clone()
Object ICloneable.Clone()
Private Function Clone As Object Implements ICloneable.Clone
Private Function Clone As Object Implements ICloneable.Clone
private:
virtual Object^ Clone() sealed = ICloneable::Clone
private:
virtual Object^ Clone() sealed = ICloneable::Clone
private abstract Clone : unit -> Object
private override Clone : unit -> Object
private abstract Clone : unit -> Object
private override Clone : unit -> Object

Return Value

Type: Online Object

Implements

Online ICloneable Clone
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.Clone Method

ErlRef Clone Method NFX Class Library

Clone an instance of the object (non-scalar immutable objects are copied by reference)

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject Clone()
public IErlObject Clone()
Public Function Clone As IErlObject
Public Function Clone As IErlObject
public:
virtual IErlObject^ Clone() sealed
public:
virtual IErlObject^ Clone() sealed
abstract Clone : unit -> IErlObject
override Clone : unit -> IErlObject
abstract Clone : unit -> IErlObject
override Clone : unit -> IErlObject

Return Value

Type: IErlObject

Implements

IErlObject Clone
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.CompareTo Method

ErlRef CompareTo Method NFX Class Library

Overload List
 | Name | Description
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj
Back to Top
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.CompareTo Method (Object)

ErlRef CompareTo Method (Object) NFX Class Library

Compare this instance to the object. Negative value means that the value is less than obj, positive - greater than the obj

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    Object obj
)
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
Public Function CompareTo (
    obj As Object
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
public:
virtual int CompareTo(
    Object^ obj
) sealed
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int

Parameters

obj
Type: Online System Object

Return Value

Type: Online Int32

Implements

Online IComparable CompareTo(Object)
See Also
ErlRef Structure
ErlRef Members
CompareTo Overload
NFX.Erlang Namespace


ErlRef.CompareTo Method (IErlObject)

ErlRef CompareTo Method (IErlObject) NFX Class Library

Compare this instance to the IErlObject. Negative value means that the value is less than obj, positive - greater than the obj

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    IErlObject obj
)
public int CompareTo(
    IErlObject obj
)
Public Function CompareTo (
    obj As IErlObject
) As Integer
Public Function CompareTo (
    obj As IErlObject
) As Integer
public:
virtual int CompareTo(
    IErlObject^ obj
) sealed
public:
virtual int CompareTo(
    IErlObject^ obj
) sealed
abstract CompareTo :
        obj : IErlObject -> int
override CompareTo :
        obj : IErlObject -> int
abstract CompareTo :
        obj : IErlObject -> int
override CompareTo :
        obj : IErlObject -> int

Parameters

obj
Type: NFX.Erlang IErlObject

Return Value

Type: Online Int32

Implements

Online IComparable T CompareTo(T)
See Also
ErlRef Structure
ErlRef Members
CompareTo Overload
NFX.Erlang Namespace


ErlRef.Equals Method

ErlRef Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | Determine if this instance equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(ErlRef) | Determine if two instances are equal
Public method | Equals(IErlObject) | Determine if two instances are equal
Back to Top
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.Equals Method (Object)

ErlRef Equals Method (Object) NFX Class Library

Determine if this instance equals to the object

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals (
    o As Object
) As Boolean
Public Overrides Function Equals (
    o As Object
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool

Parameters

o
Type: Online System Object

Return Value

Type: Online Boolean
See Also
ErlRef Structure
ErlRef Members
Equals Overload
NFX.Erlang Namespace


ErlRef.Equals Method (ErlRef)

ErlRef Equals Method (ErlRef) NFX Class Library

Determine if two instances are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    ErlRef rhs
)
public bool Equals(
    ErlRef rhs
)
Public Function Equals (
    rhs As ErlRef
) As Boolean
Public Function Equals (
    rhs As ErlRef
) As Boolean
public:
bool Equals(
    ErlRef rhs
)
public:
bool Equals(
    ErlRef rhs
)
member Equals :
        rhs : ErlRef -> bool
member Equals :
        rhs : ErlRef -> bool

Parameters

rhs
Type: NFX.Erlang ErlRef

Return Value

Type: Online Boolean
See Also
ErlRef Structure
ErlRef Members
Equals Overload
NFX.Erlang Namespace


ErlRef.Equals Method (IErlObject)

ErlRef Equals Method (IErlObject) NFX Class Library

Determine if two instances are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    IErlObject o
)
public bool Equals(
    IErlObject o
)
Public Function Equals (
    o As IErlObject
) As Boolean
Public Function Equals (
    o As IErlObject
) As Boolean
public:
virtual bool Equals(
    IErlObject^ o
) sealed
public:
virtual bool Equals(
    IErlObject^ o
) sealed
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool

Parameters

o
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
ErlRef Structure
ErlRef Members
Equals Overload
NFX.Erlang Namespace


ErlRef.GetHashCode Method

ErlRef GetHashCode Method NFX Class Library

Get internal hash code

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.Match Method

ErlRef Match Method NFX Class Library

Overload List
 | Name | Description
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Back to Top
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.Match Method (IErlObject)

ErlRef Match Method (IErlObject) NFX Class Library

Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlVarBind Match(
    IErlObject pattern
)
public ErlVarBind Match(
    IErlObject pattern
)
Public Function Match (
    pattern As IErlObject
) As ErlVarBind
Public Function Match (
    pattern As IErlObject
) As ErlVarBind
public:
virtual ErlVarBind^ Match(
    IErlObject^ pattern
) sealed
public:
virtual ErlVarBind^ Match(
    IErlObject^ pattern
) sealed
abstract Match :
        pattern : IErlObject -> ErlVarBind
override Match :
        pattern : IErlObject -> ErlVarBind
abstract Match :
        pattern : IErlObject -> ErlVarBind
override Match :
        pattern : IErlObject -> ErlVarBind

Parameters

pattern
Type: NFX.Erlang IErlObject

Return Value

Type: ErlVarBind

Implements

IErlObject Match(IErlObject)
See Also
ErlRef Structure
ErlRef Members
Match Overload
NFX.Erlang Namespace


ErlRef.Match Method (IErlObject, ErlVarBind)

ErlRef Match Method (IErlObject, ErlVarBind) NFX Class Library

[This is preliminary documentation and is subject to change.]

Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Match(
    IErlObject pattern,
    ErlVarBind binding
)
public bool Match(
    IErlObject pattern,
    ErlVarBind binding
)
Public Function Match (
    pattern As IErlObject,
    binding As ErlVarBind
) As Boolean
Public Function Match (
    pattern As IErlObject,
    binding As ErlVarBind
) As Boolean
public:
virtual bool Match(
    IErlObject^ pattern,
    ErlVarBind^ binding
) sealed
public:
virtual bool Match(
    IErlObject^ pattern,
    ErlVarBind^ binding
) sealed
abstract Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
override Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
abstract Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
override Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool

Parameters

pattern
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind

Return Value

Type: Online Boolean

Implements

IErlObject Match(IErlObject, ErlVarBind)
See Also
ErlRef Structure
ErlRef Members
Match Overload
NFX.Erlang Namespace


ErlRef.Matches Method

ErlRef Matches Method NFX Class Library

Perform pattern match on this Erlang term without binding any variables

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Matches(
    IErlObject pattern
)
public bool Matches(
    IErlObject pattern
)
Public Function Matches (
    pattern As IErlObject
) As Boolean
Public Function Matches (
    pattern As IErlObject
) As Boolean
public:
virtual bool Matches(
    IErlObject^ pattern
) sealed
public:
virtual bool Matches(
    IErlObject^ pattern
) sealed
abstract Matches :
        pattern : IErlObject -> bool
override Matches :
        pattern : IErlObject -> bool
abstract Matches :
        pattern : IErlObject -> bool
override Matches :
        pattern : IErlObject -> bool

Parameters

pattern
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Implements

IErlObject Matches(IErlObject)
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.Parse Method

ErlRef Parse Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlRef Parse(
    string eref
)
public static ErlRef Parse(
    string eref
)
Public Shared Function Parse (
    eref As String
) As ErlRef
Public Shared Function Parse (
    eref As String
) As ErlRef
public:
static ErlRef Parse(
    String^ eref
)
public:
static ErlRef Parse(
    String^ eref
)
static member Parse :
        eref : string -> ErlRef
static member Parse :
        eref : string -> ErlRef

Parameters

eref
Type: Online System String

Return Value

Type: ErlRef
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.Subst Method

ErlRef Subst Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Subst(
    ref IErlObject term,
    ErlVarBind binding
)
public bool Subst(
    ref IErlObject term,
    ErlVarBind binding
)
Public Function Subst (
    ByRef term As IErlObject,
    binding As ErlVarBind
) As Boolean
Public Function Subst (
    ByRef term As IErlObject,
    binding As ErlVarBind
) As Boolean
public:
virtual bool Subst(
    IErlObject^% term,
    ErlVarBind^ binding
) sealed
public:
virtual bool Subst(
    IErlObject^% term,
    ErlVarBind^ binding
) sealed
abstract Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
override Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
abstract Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
override Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool

Parameters

term
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind

Return Value

Type: Online Boolean

Implements

IErlObject Subst(IErlObject , ErlVarBind)
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.ToString Method

ErlRef ToString Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.TryParse Method

ErlRef TryParse Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool TryParse(
    string eref,
    out ErlRef erlRef
)
public static bool TryParse(
    string eref,
    out ErlRef erlRef
)
Public Shared Function TryParse (
    eref As String,
    <OutAttribute> ByRef erlRef As ErlRef
) As Boolean
Public Shared Function TryParse (
    eref As String,
    <OutAttribute> ByRef erlRef As ErlRef
) As Boolean
public:
static bool TryParse(
    String^ eref,
    [OutAttribute] ErlRef% erlRef
)
public:
static bool TryParse(
    String^ eref,
    [OutAttribute] ErlRef% erlRef
)
static member TryParse :
        eref : string *
        erlRef : ErlRef byref -> bool
static member TryParse :
        eref : string *
        erlRef : ErlRef byref -> bool

Parameters

eref
Type: Online System String
erlRef
Type: NFX.Erlang ErlRef

Return Value

Type: Online Boolean
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.Visit(TAccumulate) Method

ErlRef Visit TAccumulate Method NFX Class Library

Execute fun for every nested term

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TAccumulate Visit<TAccumulate>(
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
public TAccumulate Visit<TAccumulate>(
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
Public Function Visit(Of TAccumulate) (
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
Public Function Visit(Of TAccumulate) (
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
public:
generic<typename TAccumulate>
virtual TAccumulate Visit(
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
) sealed
public:
generic<typename TAccumulate>
virtual TAccumulate Visit(
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
) sealed
abstract Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
override Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
abstract Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
override Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate

Parameters

acc
Type: TAccumulate
fun
Type: Online System Func TAccumulate, IErlObject, TAccumulate
Type Parameters
TAccumulate

Return Value

Type: TAccumulate

Implements

IErlObject Visit TAccumulate (TAccumulate, Func TAccumulate, IErlObject, TAccumulate )
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef Operators

ErlRef Operators NFX Class Library

The ErlRef type exposes the following members.
Operators
Name | Description
Equality |
Inequality |
Back to Top
See Also
ErlRef Structure
NFX.Erlang Namespace


ErlRef.Equality Operator

ErlRef Equality Operator NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    ErlRef lhs,
    ErlRef rhs
)
public static bool operator ==(
    ErlRef lhs,
    ErlRef rhs
)
Public Shared Operator = (
    lhs As ErlRef,
    rhs As ErlRef
) As Boolean
Public Shared Operator = (
    lhs As ErlRef,
    rhs As ErlRef
) As Boolean
public:
static bool operator ==(
    ErlRef lhs,
    ErlRef rhs
)
public:
static bool operator ==(
    ErlRef lhs,
    ErlRef rhs
)
static let inline (=)
        lhs : ErlRef *
        rhs : ErlRef  : bool
static let inline (=)
        lhs : ErlRef *
        rhs : ErlRef  : bool

Parameters

lhs
Type: NFX.Erlang ErlRef
rhs
Type: NFX.Erlang ErlRef

Return Value

Type: Online Boolean
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.Inequality Operator

ErlRef Inequality Operator NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    ErlRef lhs,
    ErlRef rhs
)
public static bool operator !=(
    ErlRef lhs,
    ErlRef rhs
)
Public Shared Operator <> (
    lhs As ErlRef,
    rhs As ErlRef
) As Boolean
Public Shared Operator <> (
    lhs As ErlRef,
    rhs As ErlRef
) As Boolean
public:
static bool operator !=(
    ErlRef lhs,
    ErlRef rhs
)
public:
static bool operator !=(
    ErlRef lhs,
    ErlRef rhs
)
static let inline (<>)
        lhs : ErlRef *
        rhs : ErlRef  : bool
static let inline (<>)
        lhs : ErlRef *
        rhs : ErlRef  : bool

Parameters

lhs
Type: NFX.Erlang ErlRef
rhs
Type: NFX.Erlang ErlRef

Return Value

Type: Online Boolean
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef Properties

ErlRef Properties NFX Class Library

The ErlRef type exposes the following members.
Properties
 | Name | Description
Public property | Empty |
Public property | IsScalar |
Public property | TypeOrder |
Public property | Value |
Public property | ValueAsBool |
Public property | ValueAsByteArray |
Public property | ValueAsChar |
Public property | ValueAsDateTime |
Public property | ValueAsDecimal |
Public property | ValueAsDouble |
Public property | ValueAsInt |
Public property | ValueAsLong |
Public property | ValueAsObject |
Public property | ValueAsString |
Public property | ValueAsTimeSpan |
Back to Top
See Also
ErlRef Structure
NFX.Erlang Namespace


ErlRef.Empty Property

ErlRef Empty Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Empty { get; }
public bool Empty { get; }
Public ReadOnly Property Empty As Boolean
    Get
Public ReadOnly Property Empty As Boolean
    Get
public:
property bool Empty {
    bool get ();
}
public:
property bool Empty {
    bool get ();
}
member Empty : bool with get
member Empty : bool with get

Property Value

Type: Online Boolean
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.IsScalar Property

ErlRef IsScalar Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsScalar { get; }
public bool IsScalar { get; }
Public ReadOnly Property IsScalar As Boolean
    Get
Public ReadOnly Property IsScalar As Boolean
    Get
public:
virtual property bool IsScalar {
    bool get () sealed;
}
public:
virtual property bool IsScalar {
    bool get () sealed;
}
abstract IsScalar : bool with get
override IsScalar : bool with get
abstract IsScalar : bool with get
override IsScalar : bool with get

Property Value

Type: Online Boolean

Implements

IErlObject IsScalar
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.TypeOrder Property

ErlRef TypeOrder Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTypeOrder TypeOrder { get; }
public ErlTypeOrder TypeOrder { get; }
Public ReadOnly Property TypeOrder As ErlTypeOrder
    Get
Public ReadOnly Property TypeOrder As ErlTypeOrder
    Get
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () sealed;
}
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () sealed;
}
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get

Property Value

Type: ErlTypeOrder

Implements

IErlObject TypeOrder
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.Value Property

ErlRef Value Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlRef Value { get; }
public ErlRef Value { get; }
Public ReadOnly Property Value As ErlRef
    Get
Public ReadOnly Property Value As ErlRef
    Get
public:
virtual property ErlRef Value {
    ErlRef get () sealed;
}
public:
virtual property ErlRef Value {
    ErlRef get () sealed;
}
abstract Value : ErlRef with get
override Value : ErlRef with get
abstract Value : ErlRef with get
override Value : ErlRef with get

Property Value

Type: ErlRef

Implements

IErlObject T Value
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.ValueAsBool Property

ErlRef ValueAsBool Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ValueAsBool { get; }
public bool ValueAsBool { get; }
Public ReadOnly Property ValueAsBool As Boolean
    Get
Public ReadOnly Property ValueAsBool As Boolean
    Get
public:
virtual property bool ValueAsBool {
    bool get () sealed;
}
public:
virtual property bool ValueAsBool {
    bool get () sealed;
}
abstract ValueAsBool : bool with get
override ValueAsBool : bool with get
abstract ValueAsBool : bool with get
override ValueAsBool : bool with get

Property Value

Type: Online Boolean

Implements

IErlObject ValueAsBool
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.ValueAsByteArray Property

ErlRef ValueAsByteArray Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] ValueAsByteArray { get; }
public byte[] ValueAsByteArray { get; }
Public ReadOnly Property ValueAsByteArray As Byte()
    Get
Public ReadOnly Property ValueAsByteArray As Byte()
    Get
public:
virtual property array<unsigned char>^ ValueAsByteArray {
    array<unsigned char>^ get () sealed;
}
public:
virtual property array<unsigned char>^ ValueAsByteArray {
    array<unsigned char>^ get () sealed;
}
abstract ValueAsByteArray : byte[] with get
override ValueAsByteArray : byte[] with get
abstract ValueAsByteArray : byte[] with get
override ValueAsByteArray : byte[] with get

Property Value

Type: Online Byte

Implements

IErlObject ValueAsByteArray
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.ValueAsChar Property

ErlRef ValueAsChar Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char ValueAsChar { get; }
public char ValueAsChar { get; }
Public ReadOnly Property ValueAsChar As Char
    Get
Public ReadOnly Property ValueAsChar As Char
    Get
public:
virtual property wchar_t ValueAsChar {
    wchar_t get () sealed;
}
public:
virtual property wchar_t ValueAsChar {
    wchar_t get () sealed;
}
abstract ValueAsChar : char with get
override ValueAsChar : char with get
abstract ValueAsChar : char with get
override ValueAsChar : char with get

Property Value

Type: Online Char

Implements

IErlObject ValueAsChar
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.ValueAsDateTime Property

ErlRef ValueAsDateTime Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime ValueAsDateTime { get; }
public DateTime ValueAsDateTime { get; }
Public ReadOnly Property ValueAsDateTime As DateTime
    Get
Public ReadOnly Property ValueAsDateTime As DateTime
    Get
public:
virtual property DateTime ValueAsDateTime {
    DateTime get () sealed;
}
public:
virtual property DateTime ValueAsDateTime {
    DateTime get () sealed;
}
abstract ValueAsDateTime : DateTime with get
override ValueAsDateTime : DateTime with get
abstract ValueAsDateTime : DateTime with get
override ValueAsDateTime : DateTime with get

Property Value

Type: Online DateTime

Implements

IErlObject ValueAsDateTime
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.ValueAsDecimal Property

ErlRef ValueAsDecimal Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal ValueAsDecimal { get; }
public decimal ValueAsDecimal { get; }
Public ReadOnly Property ValueAsDecimal As Decimal
    Get
Public ReadOnly Property ValueAsDecimal As Decimal
    Get
public:
virtual property Decimal ValueAsDecimal {
    Decimal get () sealed;
}
public:
virtual property Decimal ValueAsDecimal {
    Decimal get () sealed;
}
abstract ValueAsDecimal : decimal with get
override ValueAsDecimal : decimal with get
abstract ValueAsDecimal : decimal with get
override ValueAsDecimal : decimal with get

Property Value

Type: Online Decimal

Implements

IErlObject ValueAsDecimal
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.ValueAsDouble Property

ErlRef ValueAsDouble Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double ValueAsDouble { get; }
public double ValueAsDouble { get; }
Public ReadOnly Property ValueAsDouble As Double
    Get
Public ReadOnly Property ValueAsDouble As Double
    Get
public:
virtual property double ValueAsDouble {
    double get () sealed;
}
public:
virtual property double ValueAsDouble {
    double get () sealed;
}
abstract ValueAsDouble : float with get
override ValueAsDouble : float with get
abstract ValueAsDouble : float with get
override ValueAsDouble : float with get

Property Value

Type: Online Double

Implements

IErlObject ValueAsDouble
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.ValueAsInt Property

ErlRef ValueAsInt Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ValueAsInt { get; }
public int ValueAsInt { get; }
Public ReadOnly Property ValueAsInt As Integer
    Get
Public ReadOnly Property ValueAsInt As Integer
    Get
public:
virtual property int ValueAsInt {
    int get () sealed;
}
public:
virtual property int ValueAsInt {
    int get () sealed;
}
abstract ValueAsInt : int with get
override ValueAsInt : int with get
abstract ValueAsInt : int with get
override ValueAsInt : int with get

Property Value

Type: Online Int32

Implements

IErlObject ValueAsInt
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.ValueAsLong Property

ErlRef ValueAsLong Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long ValueAsLong { get; }
public long ValueAsLong { get; }
Public ReadOnly Property ValueAsLong As Long
    Get
Public ReadOnly Property ValueAsLong As Long
    Get
public:
virtual property long long ValueAsLong {
    long long get () sealed;
}
public:
virtual property long long ValueAsLong {
    long long get () sealed;
}
abstract ValueAsLong : int64 with get
override ValueAsLong : int64 with get
abstract ValueAsLong : int64 with get
override ValueAsLong : int64 with get

Property Value

Type: Online Int64

Implements

IErlObject ValueAsLong
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.ValueAsObject Property

ErlRef ValueAsObject Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object ValueAsObject { get; }
public Object ValueAsObject { get; }
Public ReadOnly Property ValueAsObject As Object
    Get
Public ReadOnly Property ValueAsObject As Object
    Get
public:
virtual property Object^ ValueAsObject {
    Object^ get () sealed;
}
public:
virtual property Object^ ValueAsObject {
    Object^ get () sealed;
}
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get

Property Value

Type: Online Object

Implements

IErlObject ValueAsObject
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.ValueAsString Property

ErlRef ValueAsString Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ValueAsString { get; }
public string ValueAsString { get; }
Public ReadOnly Property ValueAsString As String
    Get
Public ReadOnly Property ValueAsString As String
    Get
public:
virtual property String^ ValueAsString {
    String^ get () sealed;
}
public:
virtual property String^ ValueAsString {
    String^ get () sealed;
}
abstract ValueAsString : string with get
override ValueAsString : string with get
abstract ValueAsString : string with get
override ValueAsString : string with get

Property Value

Type: Online String

Implements

IErlObject ValueAsString
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRef.ValueAsTimeSpan Property

ErlRef ValueAsTimeSpan Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpan ValueAsTimeSpan { get; }
public TimeSpan ValueAsTimeSpan { get; }
Public ReadOnly Property ValueAsTimeSpan As TimeSpan
    Get
Public ReadOnly Property ValueAsTimeSpan As TimeSpan
    Get
public:
virtual property TimeSpan ValueAsTimeSpan {
    TimeSpan get () sealed;
}
public:
virtual property TimeSpan ValueAsTimeSpan {
    TimeSpan get () sealed;
}
abstract ValueAsTimeSpan : TimeSpan with get
override ValueAsTimeSpan : TimeSpan with get
abstract ValueAsTimeSpan : TimeSpan with get
override ValueAsTimeSpan : TimeSpan with get

Property Value

Type: Online TimeSpan

Implements

IErlObject ValueAsTimeSpan
See Also
ErlRef Structure
ErlRef Members
NFX.Erlang Namespace


ErlRemoteNode Class

ErlRemoteNode Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.Erlang ErlAbstractNode
NFX.Erlang ErlRemoteNode

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ErlRemoteNode : ErlAbstractNode
public class ErlRemoteNode : ErlAbstractNode
Public Class ErlRemoteNode
    Inherits ErlAbstractNode
Public Class ErlRemoteNode
    Inherits ErlAbstractNode
public ref class ErlRemoteNode : public ErlAbstractNode
public ref class ErlRemoteNode : public ErlAbstractNode
type ErlRemoteNode =
    class
        inherit ErlAbstractNode
    end
type ErlRemoteNode =
    class
        inherit ErlAbstractNode
    end
See Also
ErlRemoteNode Members
NFX.Erlang Namespace


ErlRemoteNode Members

ErlRemoteNode Members NFX Class Library

The ErlRemoteNode type exposes the following members.
Constructors
 | Name | Description
Protected method | ErlRemoteNode(ErlLocalNode) | Constructor used for creating a remote node by the Acceptor of incoming connections
Public method | ErlRemoteNode(ErlLocalNode, ErlAtom, Nullable ErlAtom ) | Create a peer node
Public method | ErlRemoteNode(ErlLocalNode, String, Nullable ErlAtom ) | Create a peer node
Public method | ErlRemoteNode(ErlLocalNode, ErlAtom, IConfigSettings, Nullable ErlAtom ) | Create a peer node
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | AppendSSHParamsToTransport |
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Public method | Connect | Create a connection to a remote node
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Inherited from ErlAbstractNode.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | SetNodeName | (Inherited from ErlAbstractNode.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | ToString | (Inherited from ErlAbstractNode.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Creation | (Inherited from ErlAbstractNode.)
Protected field | m_TcpKeepAlive | (Inherited from ErlAbstractNode.)
Protected field | m_TcpLinger | (Inherited from ErlAbstractNode.)
Protected field | m_TcpNoDelay | (Inherited from ErlAbstractNode.)
Protected field | m_TcpRcvBufSize | (Inherited from ErlAbstractNode.)
Protected field | m_TcpSndBufSize | (Inherited from ErlAbstractNode.)
Back to Top
Properties
 | Name | Description
Public property | AliveName | Get the alivename part of the hostname. Nodenames are composed of two parts, an alivename and a hostname, separated by '@'. This method returns the part of the nodename preceding the '@' (Inherited from ErlAbstractNode.)
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | ConnectTimeout | Connect timeout, ms
Public property | Cookie | Get the authorization cookie used by this node (Inherited from ErlAbstractNode.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Protected property | DistChoose | (Inherited from ErlAbstractNode.)
Protected property | DistHigh | (Inherited from ErlAbstractNode.)
Protected property | DistLow | (Inherited from ErlAbstractNode.)
Protected property | Epmd | Get/Set the Epmd socket after publishing this nodes listen port to Epmd (Inherited from ErlAbstractNode.)
Protected property | Flags | (Inherited from ErlAbstractNode.)
Public property | Host | Get the hostname part of the nodename. Nodenames are composed of two parts, an alivename and a hostname, separated by '@'. This method returns the part of the nodename following the '@' (Inherited from ErlAbstractNode.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | NodeLongName | Get the long name of this node (Inherited from ErlAbstractNode.)
Public property | NodeName | Get the name of this node (short or long depending on UseShortName) (Inherited from ErlAbstractNode.)
Protected property | Ntype | (Inherited from ErlAbstractNode.)
Public property | Port | Get the port number used by this node. For local node the value may be 0 if the node was not registered with the EPMD port mapper (Inherited from ErlAbstractNode.)
Protected property | Proto | (Inherited from ErlAbstractNode.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | SSHAuthenticationType | Type of auth on SSH server
Public property | SSHPrivateKeyFilePath | Private key file path (only for AuthenticationType = PublicKey) Required SSH2 ENCRYPTED PRIVATE KEY format.
Public property | SSHServerPort | Port of SSH server
Public property | SSHUserName | SSH user name
Public property | Status | Current service status (Inherited from Service.)
Public property | TcpKeepAlive | (Inherited from ErlAbstractNode.)
Public property | TcpLinger | (Inherited from ErlAbstractNode.)
Public property | TcpNoDelay | (Inherited from ErlAbstractNode.)
Public property | TcpRcvBufSize | (Inherited from ErlAbstractNode.)
Public property | TcpSndBufSize | (Inherited from ErlAbstractNode.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransportClassName | Full name of transport class (if not specified - it uses ErlTcpTransport)
Protected property | UseShortName | (Inherited from ErlAbstractNode.)
Back to Top
See Also
ErlRemoteNode Class
NFX.Erlang Namespace


ErlRemoteNode Constructor

ErlRemoteNode Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | ErlRemoteNode(ErlLocalNode) | Constructor used for creating a remote node by the Acceptor of incoming connections
Public method | ErlRemoteNode(ErlLocalNode, ErlAtom, Nullable ErlAtom ) | Create a peer node
Public method | ErlRemoteNode(ErlLocalNode, String, Nullable ErlAtom ) | Create a peer node
Public method | ErlRemoteNode(ErlLocalNode, ErlAtom, IConfigSettings, Nullable ErlAtom ) | Create a peer node
Back to Top
See Also
ErlRemoteNode Class
ErlRemoteNode Members
NFX.Erlang Namespace


ErlRemoteNode Constructor (ErlLocalNode)

ErlRemoteNode Constructor (ErlLocalNode) NFX Class Library

Constructor used for creating a remote node by the Acceptor of incoming connections

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ErlRemoteNode(
    ErlLocalNode home
)
internal ErlRemoteNode(
    ErlLocalNode home
)
Friend Sub New (
    home As ErlLocalNode
)
Friend Sub New (
    home As ErlLocalNode
)
internal:
ErlRemoteNode(
    ErlLocalNode^ home
)
internal:
ErlRemoteNode(
    ErlLocalNode^ home
)
new :
        home : ErlLocalNode -> ErlRemoteNode
new :
        home : ErlLocalNode -> ErlRemoteNode

Parameters

home
Type: NFX.Erlang ErlLocalNode
See Also
ErlRemoteNode Class
ErlRemoteNode Members
ErlRemoteNode Overload
NFX.Erlang Namespace


ErlRemoteNode Constructor (ErlLocalNode, ErlAtom, Nullable(ErlAtom))

ErlRemoteNode Constructor (ErlLocalNode, ErlAtom, Nullable ErlAtom ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Create a peer node

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlRemoteNode(
    ErlLocalNode home,
    ErlAtom toNode,
    Nullable<ErlAtom> cookie = null
)
public ErlRemoteNode(
    ErlLocalNode home,
    ErlAtom toNode,
    Nullable<ErlAtom> cookie = null
)
Public Sub New (
    home As ErlLocalNode,
    toNode As ErlAtom,
    Optional cookie As Nullable(Of ErlAtom) = Nothing
)
Public Sub New (
    home As ErlLocalNode,
    toNode As ErlAtom,
    Optional cookie As Nullable(Of ErlAtom) = Nothing
)
public:
ErlRemoteNode(
    ErlLocalNode^ home,
    ErlAtom toNode,
    Nullable<ErlAtom> cookie = nullptr
)
public:
ErlRemoteNode(
    ErlLocalNode^ home,
    ErlAtom toNode,
    Nullable<ErlAtom> cookie = nullptr
)
new :
        home : ErlLocalNode *
        toNode : ErlAtom *
        ?cookie : Nullable<ErlAtom>
(* Defaults:
        let _cookie = defaultArg cookie null
*)
-> ErlRemoteNode
new :
        home : ErlLocalNode *
        toNode : ErlAtom *
        ?cookie : Nullable<ErlAtom>
(* Defaults:
        let _cookie = defaultArg cookie null
*)
-> ErlRemoteNode

Parameters

home
Type: NFX.Erlang ErlLocalNode
toNode
Type: NFX.Erlang ErlAtom
cookie (Optional)
Type: Online System Nullable ErlAtom
See Also
ErlRemoteNode Class
ErlRemoteNode Members
ErlRemoteNode Overload
NFX.Erlang Namespace


ErlRemoteNode Constructor (ErlLocalNode, String, Nullable(ErlAtom))

ErlRemoteNode Constructor (ErlLocalNode, String, Nullable ErlAtom ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Create a peer node

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlRemoteNode(
    ErlLocalNode home,
    string toNode,
    Nullable<ErlAtom> cookie = null
)
public ErlRemoteNode(
    ErlLocalNode home,
    string toNode,
    Nullable<ErlAtom> cookie = null
)
Public Sub New (
    home As ErlLocalNode,
    toNode As String,
    Optional cookie As Nullable(Of ErlAtom) = Nothing
)
Public Sub New (
    home As ErlLocalNode,
    toNode As String,
    Optional cookie As Nullable(Of ErlAtom) = Nothing
)
public:
ErlRemoteNode(
    ErlLocalNode^ home,
    String^ toNode,
    Nullable<ErlAtom> cookie = nullptr
)
public:
ErlRemoteNode(
    ErlLocalNode^ home,
    String^ toNode,
    Nullable<ErlAtom> cookie = nullptr
)
new :
        home : ErlLocalNode *
        toNode : string *
        ?cookie : Nullable<ErlAtom>
(* Defaults:
        let _cookie = defaultArg cookie null
*)
-> ErlRemoteNode
new :
        home : ErlLocalNode *
        toNode : string *
        ?cookie : Nullable<ErlAtom>
(* Defaults:
        let _cookie = defaultArg cookie null
*)
-> ErlRemoteNode

Parameters

home
Type: NFX.Erlang ErlLocalNode
toNode
Type: Online System String
cookie (Optional)
Type: Online System Nullable ErlAtom
See Also
ErlRemoteNode Class
ErlRemoteNode Members
ErlRemoteNode Overload
NFX.Erlang Namespace


ErlRemoteNode Constructor (ErlLocalNode, ErlAtom, IConfigSettings, Nullable(ErlAtom))

ErlRemoteNode Constructor (ErlLocalNode, ErlAtom, IConfigSettings, Nullable ErlAtom ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Create a peer node

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlRemoteNode(
    ErlLocalNode home,
    ErlAtom toNode,
    IConfigSettings config,
    Nullable<ErlAtom> cookie = null
)
public ErlRemoteNode(
    ErlLocalNode home,
    ErlAtom toNode,
    IConfigSettings config,
    Nullable<ErlAtom> cookie = null
)
Public Sub New (
    home As ErlLocalNode,
    toNode As ErlAtom,
    config As IConfigSettings,
    Optional cookie As Nullable(Of ErlAtom) = Nothing
)
Public Sub New (
    home As ErlLocalNode,
    toNode As ErlAtom,
    config As IConfigSettings,
    Optional cookie As Nullable(Of ErlAtom) = Nothing
)
public:
ErlRemoteNode(
    ErlLocalNode^ home,
    ErlAtom toNode,
    IConfigSettings^ config,
    Nullable<ErlAtom> cookie = nullptr
)
public:
ErlRemoteNode(
    ErlLocalNode^ home,
    ErlAtom toNode,
    IConfigSettings^ config,
    Nullable<ErlAtom> cookie = nullptr
)
new :
        home : ErlLocalNode *
        toNode : ErlAtom *
        config : IConfigSettings *
        ?cookie : Nullable<ErlAtom>
(* Defaults:
        let _cookie = defaultArg cookie null
*)
-> ErlRemoteNode
new :
        home : ErlLocalNode *
        toNode : ErlAtom *
        config : IConfigSettings *
        ?cookie : Nullable<ErlAtom>
(* Defaults:
        let _cookie = defaultArg cookie null
*)
-> ErlRemoteNode

Parameters

home
Type: NFX.Erlang ErlLocalNode
toNode
Type: NFX.Erlang ErlAtom
config
Type: NFX.Environment IConfigSettings
cookie (Optional)
Type: Online System Nullable ErlAtom
See Also
ErlRemoteNode Class
ErlRemoteNode Members
ErlRemoteNode Overload
NFX.Erlang Namespace


ErlRemoteNode Fields

ErlRemoteNode Fields NFX Class Library

The ErlRemoteNode type exposes the following members.
Fields
 | Name | Description
Protected field | m_Creation | (Inherited from ErlAbstractNode.)
Protected field | m_TcpKeepAlive | (Inherited from ErlAbstractNode.)
Protected field | m_TcpLinger | (Inherited from ErlAbstractNode.)
Protected field | m_TcpNoDelay | (Inherited from ErlAbstractNode.)
Protected field | m_TcpRcvBufSize | (Inherited from ErlAbstractNode.)
Protected field | m_TcpSndBufSize | (Inherited from ErlAbstractNode.)
Back to Top
See Also
ErlRemoteNode Class
NFX.Erlang Namespace


ErlRemoteNode Methods

ErlRemoteNode Methods NFX Class Library

The ErlRemoteNode type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | AppendSSHParamsToTransport |
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Public method | Connect | Create a connection to a remote node
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Inherited from ErlAbstractNode.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | SetNodeName | (Inherited from ErlAbstractNode.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | ToString | (Inherited from ErlAbstractNode.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ErlRemoteNode Class
NFX.Erlang Namespace


ErlRemoteNode.AppendSSHParamsToTransport Method

ErlRemoteNode AppendSSHParamsToTransport Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AppendSSHParamsToTransport(
    IErlTransport transport
)
public void AppendSSHParamsToTransport(
    IErlTransport transport
)
Public Sub AppendSSHParamsToTransport (
    transport As IErlTransport
)
Public Sub AppendSSHParamsToTransport (
    transport As IErlTransport
)
public:
void AppendSSHParamsToTransport(
    IErlTransport^ transport
)
public:
void AppendSSHParamsToTransport(
    IErlTransport^ transport
)
member AppendSSHParamsToTransport :
        transport : IErlTransport -> unit
member AppendSSHParamsToTransport :
        transport : IErlTransport -> unit

Parameters

transport
Type: NFX.Erlang IErlTransport
See Also
ErlRemoteNode Class
ErlRemoteNode Members
NFX.Erlang Namespace


ErlRemoteNode.Connect Method

ErlRemoteNode Connect Method NFX Class Library

Create a connection to a remote node

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlConnection Connect(
    ErlLocalNode self
)
public ErlConnection Connect(
    ErlLocalNode self
)
Public Function Connect (
    self As ErlLocalNode
) As ErlConnection
Public Function Connect (
    self As ErlLocalNode
) As ErlConnection
public:
ErlConnection^ Connect(
    ErlLocalNode^ self
)
public:
ErlConnection^ Connect(
    ErlLocalNode^ self
)
member Connect :
        self : ErlLocalNode -> ErlConnection
member Connect :
        self : ErlLocalNode -> ErlConnection

Parameters

self
Type: NFX.Erlang ErlLocalNode
the local node from which you wish to connect

Return Value

Type: ErlConnection
A connection to the remote node
See Also
ErlRemoteNode Class
ErlRemoteNode Members
NFX.Erlang Namespace


ErlRemoteNode Properties

ErlRemoteNode Properties NFX Class Library

The ErlRemoteNode type exposes the following members.
Properties
 | Name | Description
Public property | AliveName | Get the alivename part of the hostname. Nodenames are composed of two parts, an alivename and a hostname, separated by '@'. This method returns the part of the nodename preceding the '@' (Inherited from ErlAbstractNode.)
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | ConnectTimeout | Connect timeout, ms
Public property | Cookie | Get the authorization cookie used by this node (Inherited from ErlAbstractNode.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Protected property | DistChoose | (Inherited from ErlAbstractNode.)
Protected property | DistHigh | (Inherited from ErlAbstractNode.)
Protected property | DistLow | (Inherited from ErlAbstractNode.)
Protected property | Epmd | Get/Set the Epmd socket after publishing this nodes listen port to Epmd (Inherited from ErlAbstractNode.)
Protected property | Flags | (Inherited from ErlAbstractNode.)
Public property | Host | Get the hostname part of the nodename. Nodenames are composed of two parts, an alivename and a hostname, separated by '@'. This method returns the part of the nodename following the '@' (Inherited from ErlAbstractNode.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | NodeLongName | Get the long name of this node (Inherited from ErlAbstractNode.)
Public property | NodeName | Get the name of this node (short or long depending on UseShortName) (Inherited from ErlAbstractNode.)
Protected property | Ntype | (Inherited from ErlAbstractNode.)
Public property | Port | Get the port number used by this node. For local node the value may be 0 if the node was not registered with the EPMD port mapper (Inherited from ErlAbstractNode.)
Protected property | Proto | (Inherited from ErlAbstractNode.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | SSHAuthenticationType | Type of auth on SSH server
Public property | SSHPrivateKeyFilePath | Private key file path (only for AuthenticationType = PublicKey) Required SSH2 ENCRYPTED PRIVATE KEY format.
Public property | SSHServerPort | Port of SSH server
Public property | SSHUserName | SSH user name
Public property | Status | Current service status (Inherited from Service.)
Public property | TcpKeepAlive | (Inherited from ErlAbstractNode.)
Public property | TcpLinger | (Inherited from ErlAbstractNode.)
Public property | TcpNoDelay | (Inherited from ErlAbstractNode.)
Public property | TcpRcvBufSize | (Inherited from ErlAbstractNode.)
Public property | TcpSndBufSize | (Inherited from ErlAbstractNode.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransportClassName | Full name of transport class (if not specified - it uses ErlTcpTransport)
Protected property | UseShortName | (Inherited from ErlAbstractNode.)
Back to Top
See Also
ErlRemoteNode Class
NFX.Erlang Namespace


ErlRemoteNode.ConnectTimeout Property

ErlRemoteNode ConnectTimeout Property NFX Class Library

Connect timeout, ms

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ConnectTimeout { get; set; }
public int ConnectTimeout { get; set; }
Public Property ConnectTimeout As Integer
    Get
    Set
Public Property ConnectTimeout As Integer
    Get
    Set
public:
property int ConnectTimeout {
    int get ();
    void set (int value);
}
public:
property int ConnectTimeout {
    int get ();
    void set (int value);
}
member ConnectTimeout : int with get, set
member ConnectTimeout : int with get, set

Property Value

Type: Online Int32
See Also
ErlRemoteNode Class
ErlRemoteNode Members
NFX.Erlang Namespace


ErlRemoteNode.SSHAuthenticationType Property

ErlRemoteNode SSHAuthenticationType Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Type of auth on SSH server

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SSHAuthenticationType { get; set; }
public string SSHAuthenticationType { get; set; }
Public Property SSHAuthenticationType As String
    Get
    Set
Public Property SSHAuthenticationType As String
    Get
    Set
public:
property String^ SSHAuthenticationType {
    String^ get ();
    void set (String^ value);
}
public:
property String^ SSHAuthenticationType {
    String^ get ();
    void set (String^ value);
}
member SSHAuthenticationType : string with get, set
member SSHAuthenticationType : string with get, set

Property Value

Type: Online String
See Also
ErlRemoteNode Class
ErlRemoteNode Members
NFX.Erlang Namespace


ErlRemoteNode.SSHPrivateKeyFilePath Property

ErlRemoteNode SSHPrivateKeyFilePath Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Private key file path (only for AuthenticationType = PublicKey) Required SSH2 ENCRYPTED PRIVATE KEY format.

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SSHPrivateKeyFilePath { get; set; }
public string SSHPrivateKeyFilePath { get; set; }
Public Property SSHPrivateKeyFilePath As String
    Get
    Set
Public Property SSHPrivateKeyFilePath As String
    Get
    Set
public:
property String^ SSHPrivateKeyFilePath {
    String^ get ();
    void set (String^ value);
}
public:
property String^ SSHPrivateKeyFilePath {
    String^ get ();
    void set (String^ value);
}
member SSHPrivateKeyFilePath : string with get, set
member SSHPrivateKeyFilePath : string with get, set

Property Value

Type: Online String
See Also
ErlRemoteNode Class
ErlRemoteNode Members
NFX.Erlang Namespace


ErlRemoteNode.SSHServerPort Property

ErlRemoteNode SSHServerPort Property NFX Class Library

Port of SSH server

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int SSHServerPort { get; set; }
public int SSHServerPort { get; set; }
Public Property SSHServerPort As Integer
    Get
    Set
Public Property SSHServerPort As Integer
    Get
    Set
public:
property int SSHServerPort {
    int get ();
    void set (int value);
}
public:
property int SSHServerPort {
    int get ();
    void set (int value);
}
member SSHServerPort : int with get, set
member SSHServerPort : int with get, set

Property Value

Type: Online Int32
See Also
ErlRemoteNode Class
ErlRemoteNode Members
NFX.Erlang Namespace


ErlRemoteNode.SSHUserName Property

ErlRemoteNode SSHUserName Property NFX Class Library

SSH user name

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SSHUserName { get; set; }
public string SSHUserName { get; set; }
Public Property SSHUserName As String
    Get
    Set
Public Property SSHUserName As String
    Get
    Set
public:
property String^ SSHUserName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ SSHUserName {
    String^ get ();
    void set (String^ value);
}
member SSHUserName : string with get, set
member SSHUserName : string with get, set

Property Value

Type: Online String
See Also
ErlRemoteNode Class
ErlRemoteNode Members
NFX.Erlang Namespace


ErlRemoteNode.TransportClassName Property

ErlRemoteNode TransportClassName Property NFX Class Library

Full name of transport class (if not specified - it uses ErlTcpTransport)

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string TransportClassName { get; set; }
public string TransportClassName { get; set; }
Public Property TransportClassName As String
    Get
    Set
Public Property TransportClassName As String
    Get
    Set
public:
property String^ TransportClassName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ TransportClassName {
    String^ get ();
    void set (String^ value);
}
member TransportClassName : string with get, set
member TransportClassName : string with get, set

Property Value

Type: Online String
See Also
ErlRemoteNode Class
ErlRemoteNode Members
NFX.Erlang Namespace


ErlString Structure

ErlString Structure NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct ErlString : IErlObject<string>,
    IErlObject, IComparable, IComparable<IErlObject>, IEquatable<IErlObject>,
    ICloneable
public struct ErlString : IErlObject<string>,
    IErlObject, IComparable, IComparable<IErlObject>, IEquatable<IErlObject>,
    ICloneable
Public Structure ErlString
    Implements IErlObject(Of String), IErlObject,
    IComparable, IComparable(Of IErlObject), IEquatable(Of IErlObject),
    ICloneable
Public Structure ErlString
    Implements IErlObject(Of String), IErlObject,
    IComparable, IComparable(Of IErlObject), IEquatable(Of IErlObject),
    ICloneable
public value class ErlString : IErlObject<String^>,
    IErlObject, IComparable, IComparable<IErlObject^>, IEquatable<IErlObject^>,
    ICloneable
public value class ErlString : IErlObject<String^>,
    IErlObject, IComparable, IComparable<IErlObject^>, IEquatable<IErlObject^>,
    ICloneable
[<SealedAttribute>]
type ErlString =
    struct
        interface IErlObject<string>
        interface IErlObject
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
    end
[<SealedAttribute>]
type ErlString =
    struct
        interface IErlObject<string>
        interface IErlObject
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
    end
See Also
ErlString Members
NFX.Erlang Namespace


ErlString Members

ErlString Members NFX Class Library

The ErlString type exposes the following members.
Constructors
 | Name | Description
Public method | ErlString | Create an Erlang string from the given string
Back to Top
Methods
 | Name | Description
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the atom is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the atom is less than obj, positive - greater than the obj
Public method | Equals(Object) | Determine if this atom equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(ErlString) | Determine if two Erlang objects are equal
Public method | Equals(IErlObject) | Determine if two Erlang objects are equal
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Get internal hash code (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Public method | Matches | Perform pattern match on this Erlang term without binding any variables
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Subst |
Public method | ToString | Get the printname of the atom represented by this object. The difference between this method and {link #atomValue atomValue()} is that the printname is quoted and escaped where necessary, according to the Erlang rules for atom naming (Overrides Online ValueType ToString .)
Public method | ToString(Boolean) |
Public method | Visit TAccumulate | Execute fun for every nested term
Back to Top
Operators
Name | Description
Equality(String, ErlString) |
Equality(ErlString, ErlString) |
Equality(ErlString, String) |
(String to ErlString) | Implicit conversion of string to ErlString
(ErlString to String) | Implicit conversion of ErlString to string
Inequality(String, ErlString) |
Inequality(ErlString, ErlString) |
Inequality(ErlString, String) |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Empty | Returns true if Value is a non-empty string
Public property | IsScalar | Determines whether the underlying type is scalar or complex (i.e. tuple, list)
Public property | Length | Length of the string
Public property | TypeOrder |
Public property | Value | Get the actual string contained in this object
Public property | ValueAsBool |
Public property | ValueAsByteArray |
Public property | ValueAsChar |
Public property | ValueAsDateTime |
Public property | ValueAsDecimal |
Public property | ValueAsDouble |
Public property | ValueAsInt |
Public property | ValueAsLong |
Public property | ValueAsObject |
Public property | ValueAsString |
Public property | ValueAsTimeSpan |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone |
Back to Top
See Also
ErlString Structure
NFX.Erlang Namespace


ErlString Constructor

ErlString Constructor NFX Class Library

Create an Erlang string from the given string

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlString(
    string val
)
public ErlString(
    string val
)
Public Sub New (
    val As String
)
Public Sub New (
    val As String
)
public:
ErlString(
    String^ val
)
public:
ErlString(
    String^ val
)
new :
        val : string -> ErlString
new :
        val : string -> ErlString

Parameters

val
Type: Online System String
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString Methods

ErlString Methods NFX Class Library

The ErlString type exposes the following members.
Methods
 | Name | Description
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the atom is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the atom is less than obj, positive - greater than the obj
Public method | Equals(Object) | Determine if this atom equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(ErlString) | Determine if two Erlang objects are equal
Public method | Equals(IErlObject) | Determine if two Erlang objects are equal
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Get internal hash code (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Public method | Matches | Perform pattern match on this Erlang term without binding any variables
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Subst |
Public method | ToString | Get the printname of the atom represented by this object. The difference between this method and {link #atomValue atomValue()} is that the printname is quoted and escaped where necessary, according to the Erlang rules for atom naming (Overrides Online ValueType ToString .)
Public method | ToString(Boolean) |
Public method | Visit TAccumulate | Execute fun for every nested term
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone |
Back to Top
See Also
ErlString Structure
NFX.Erlang Namespace


ErlString.ICloneable.Clone Method

ErlString ICloneable Clone Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object ICloneable.Clone()
Object ICloneable.Clone()
Private Function Clone As Object Implements ICloneable.Clone
Private Function Clone As Object Implements ICloneable.Clone
private:
virtual Object^ Clone() sealed = ICloneable::Clone
private:
virtual Object^ Clone() sealed = ICloneable::Clone
private abstract Clone : unit -> Object
private override Clone : unit -> Object
private abstract Clone : unit -> Object
private override Clone : unit -> Object

Return Value

Type: Online Object

Implements

Online ICloneable Clone
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString.Clone Method

ErlString Clone Method NFX Class Library

Clone an instance of the object (non-scalar immutable objects are copied by reference)

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject Clone()
public IErlObject Clone()
Public Function Clone As IErlObject
Public Function Clone As IErlObject
public:
virtual IErlObject^ Clone() sealed
public:
virtual IErlObject^ Clone() sealed
abstract Clone : unit -> IErlObject
override Clone : unit -> IErlObject
abstract Clone : unit -> IErlObject
override Clone : unit -> IErlObject

Return Value

Type: IErlObject

Implements

IErlObject Clone
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString.CompareTo Method

ErlString CompareTo Method NFX Class Library

Overload List
 | Name | Description
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the atom is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the atom is less than obj, positive - greater than the obj
Back to Top
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString.CompareTo Method (Object)

ErlString CompareTo Method (Object) NFX Class Library

Compare this instance to the object. Negative value means that the atom is less than obj, positive - greater than the obj

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    Object obj
)
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
Public Function CompareTo (
    obj As Object
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
public:
virtual int CompareTo(
    Object^ obj
) sealed
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int

Parameters

obj
Type: Online System Object

Return Value

Type: Online Int32

Implements

Online IComparable CompareTo(Object)
See Also
ErlString Structure
ErlString Members
CompareTo Overload
NFX.Erlang Namespace


ErlString.CompareTo Method (IErlObject)

ErlString CompareTo Method (IErlObject) NFX Class Library

Compare this instance to the IErlObject. Negative value means that the atom is less than obj, positive - greater than the obj

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    IErlObject obj
)
public int CompareTo(
    IErlObject obj
)
Public Function CompareTo (
    obj As IErlObject
) As Integer
Public Function CompareTo (
    obj As IErlObject
) As Integer
public:
virtual int CompareTo(
    IErlObject^ obj
) sealed
public:
virtual int CompareTo(
    IErlObject^ obj
) sealed
abstract CompareTo :
        obj : IErlObject -> int
override CompareTo :
        obj : IErlObject -> int
abstract CompareTo :
        obj : IErlObject -> int
override CompareTo :
        obj : IErlObject -> int

Parameters

obj
Type: NFX.Erlang IErlObject

Return Value

Type: Online Int32

Implements

Online IComparable T CompareTo(T)
See Also
ErlString Structure
ErlString Members
CompareTo Overload
NFX.Erlang Namespace


ErlString.Equals Method

ErlString Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | Determine if this atom equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(ErlString) | Determine if two Erlang objects are equal
Public method | Equals(IErlObject) | Determine if two Erlang objects are equal
Back to Top
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString.Equals Method (Object)

ErlString Equals Method (Object) NFX Class Library

Determine if this atom equals to the object

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals (
    o As Object
) As Boolean
Public Overrides Function Equals (
    o As Object
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool

Parameters

o
Type: Online System Object

Return Value

Type: Online Boolean
See Also
ErlString Structure
ErlString Members
Equals Overload
NFX.Erlang Namespace


ErlString.Equals Method (ErlString)

ErlString Equals Method (ErlString) NFX Class Library

Determine if two Erlang objects are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    ErlString rhs
)
public bool Equals(
    ErlString rhs
)
Public Function Equals (
    rhs As ErlString
) As Boolean
Public Function Equals (
    rhs As ErlString
) As Boolean
public:
bool Equals(
    ErlString rhs
)
public:
bool Equals(
    ErlString rhs
)
member Equals :
        rhs : ErlString -> bool
member Equals :
        rhs : ErlString -> bool

Parameters

rhs
Type: NFX.Erlang ErlString

Return Value

Type: Online Boolean
See Also
ErlString Structure
ErlString Members
Equals Overload
NFX.Erlang Namespace


ErlString.Equals Method (IErlObject)

ErlString Equals Method (IErlObject) NFX Class Library

Determine if two Erlang objects are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    IErlObject o
)
public bool Equals(
    IErlObject o
)
Public Function Equals (
    o As IErlObject
) As Boolean
Public Function Equals (
    o As IErlObject
) As Boolean
public:
virtual bool Equals(
    IErlObject^ o
) sealed
public:
virtual bool Equals(
    IErlObject^ o
) sealed
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool

Parameters

o
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
ErlString Structure
ErlString Members
Equals Overload
NFX.Erlang Namespace


ErlString.GetHashCode Method

ErlString GetHashCode Method NFX Class Library

Get internal hash code

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString.Match Method

ErlString Match Method NFX Class Library

Overload List
 | Name | Description
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Back to Top
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString.Match Method (IErlObject)

ErlString Match Method (IErlObject) NFX Class Library

Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlVarBind Match(
    IErlObject pattern
)
public ErlVarBind Match(
    IErlObject pattern
)
Public Function Match (
    pattern As IErlObject
) As ErlVarBind
Public Function Match (
    pattern As IErlObject
) As ErlVarBind
public:
virtual ErlVarBind^ Match(
    IErlObject^ pattern
) sealed
public:
virtual ErlVarBind^ Match(
    IErlObject^ pattern
) sealed
abstract Match :
        pattern : IErlObject -> ErlVarBind
override Match :
        pattern : IErlObject -> ErlVarBind
abstract Match :
        pattern : IErlObject -> ErlVarBind
override Match :
        pattern : IErlObject -> ErlVarBind

Parameters

pattern
Type: NFX.Erlang IErlObject

Return Value

Type: ErlVarBind

Implements

IErlObject Match(IErlObject)
See Also
ErlString Structure
ErlString Members
Match Overload
NFX.Erlang Namespace


ErlString.Match Method (IErlObject, ErlVarBind)

ErlString Match Method (IErlObject, ErlVarBind) NFX Class Library

[This is preliminary documentation and is subject to change.]

Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Match(
    IErlObject pattern,
    ErlVarBind binding
)
public bool Match(
    IErlObject pattern,
    ErlVarBind binding
)
Public Function Match (
    pattern As IErlObject,
    binding As ErlVarBind
) As Boolean
Public Function Match (
    pattern As IErlObject,
    binding As ErlVarBind
) As Boolean
public:
virtual bool Match(
    IErlObject^ pattern,
    ErlVarBind^ binding
) sealed
public:
virtual bool Match(
    IErlObject^ pattern,
    ErlVarBind^ binding
) sealed
abstract Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
override Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
abstract Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
override Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool

Parameters

pattern
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind

Return Value

Type: Online Boolean

Implements

IErlObject Match(IErlObject, ErlVarBind)
See Also
ErlString Structure
ErlString Members
Match Overload
NFX.Erlang Namespace


ErlString.Matches Method

ErlString Matches Method NFX Class Library

Perform pattern match on this Erlang term without binding any variables

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Matches(
    IErlObject pattern
)
public bool Matches(
    IErlObject pattern
)
Public Function Matches (
    pattern As IErlObject
) As Boolean
Public Function Matches (
    pattern As IErlObject
) As Boolean
public:
virtual bool Matches(
    IErlObject^ pattern
) sealed
public:
virtual bool Matches(
    IErlObject^ pattern
) sealed
abstract Matches :
        pattern : IErlObject -> bool
override Matches :
        pattern : IErlObject -> bool
abstract Matches :
        pattern : IErlObject -> bool
override Matches :
        pattern : IErlObject -> bool

Parameters

pattern
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Implements

IErlObject Matches(IErlObject)
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString.Subst Method

ErlString Subst Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Subst(
    ref IErlObject term,
    ErlVarBind binding
)
public bool Subst(
    ref IErlObject term,
    ErlVarBind binding
)
Public Function Subst (
    ByRef term As IErlObject,
    binding As ErlVarBind
) As Boolean
Public Function Subst (
    ByRef term As IErlObject,
    binding As ErlVarBind
) As Boolean
public:
virtual bool Subst(
    IErlObject^% term,
    ErlVarBind^ binding
) sealed
public:
virtual bool Subst(
    IErlObject^% term,
    ErlVarBind^ binding
) sealed
abstract Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
override Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
abstract Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
override Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool

Parameters

term
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind

Return Value

Type: Online Boolean

Implements

IErlObject Subst(IErlObject , ErlVarBind)
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString.ToString Method

ErlString ToString Method NFX Class Library

Overload List
 | Name | Description
Public method | ToString | Get the printname of the atom represented by this object. The difference between this method and {link #atomValue atomValue()} is that the printname is quoted and escaped where necessary, according to the Erlang rules for atom naming (Overrides Online ValueType ToString .)
Public method | ToString(Boolean) |
Back to Top
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString.ToString Method

ErlString ToString Method NFX Class Library

Get the printname of the atom represented by this object. The difference between this method and {link #atomValue atomValue()} is that the printname is quoted and escaped where necessary, according to the Erlang rules for atom naming

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
ErlString Structure
ErlString Members
ToString Overload
NFX.Erlang Namespace


ErlString.ToString Method (Boolean)

ErlString ToString Method (Boolean) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ToString(
    bool withQuotes
)
public string ToString(
    bool withQuotes
)
Public Function ToString (
    withQuotes As Boolean
) As String
Public Function ToString (
    withQuotes As Boolean
) As String
public:
String^ ToString(
    bool withQuotes
)
public:
String^ ToString(
    bool withQuotes
)
member ToString :
        withQuotes : bool -> string
member ToString :
        withQuotes : bool -> string

Parameters

withQuotes
Type: Online System Boolean

Return Value

Type: Online String
See Also
ErlString Structure
ErlString Members
ToString Overload
NFX.Erlang Namespace


ErlString.Visit(TAccumulate) Method

ErlString Visit TAccumulate Method NFX Class Library

Execute fun for every nested term

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TAccumulate Visit<TAccumulate>(
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
public TAccumulate Visit<TAccumulate>(
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
Public Function Visit(Of TAccumulate) (
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
Public Function Visit(Of TAccumulate) (
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
public:
generic<typename TAccumulate>
virtual TAccumulate Visit(
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
) sealed
public:
generic<typename TAccumulate>
virtual TAccumulate Visit(
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
) sealed
abstract Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
override Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
abstract Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
override Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate

Parameters

acc
Type: TAccumulate
fun
Type: Online System Func TAccumulate, IErlObject, TAccumulate
Type Parameters
TAccumulate

Return Value

Type: TAccumulate

Implements

IErlObject Visit TAccumulate (TAccumulate, Func TAccumulate, IErlObject, TAccumulate )
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString Operators and Type Conversions

ErlString Operators and Type Conversions NFX Class Library

Operators
Name | Description
Equality(String, ErlString) |
Equality(ErlString, ErlString) |
Equality(ErlString, String) |
(String to ErlString) | Implicit conversion of string to ErlString
(ErlString to String) | Implicit conversion of ErlString to string
Inequality(String, ErlString) |
Inequality(ErlString, ErlString) |
Inequality(ErlString, String) |
Back to Top
See Also
ErlString Structure
NFX.Erlang Namespace


ErlString.Equality Operator

ErlString Equality Operator NFX Class Library

Overload List
Name | Description
Equality(String, ErlString) |
Equality(ErlString, ErlString) |
Equality(ErlString, String) |
Back to Top
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString.Equality Operator (String, ErlString)

ErlString Equality Operator (String, ErlString) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    string rhs,
    ErlString lhs
)
public static bool operator ==(
    string rhs,
    ErlString lhs
)
Public Shared Operator = (
    rhs As String,
    lhs As ErlString
) As Boolean
Public Shared Operator = (
    rhs As String,
    lhs As ErlString
) As Boolean
public:
static bool operator ==(
    String^ rhs,
    ErlString lhs
)
public:
static bool operator ==(
    String^ rhs,
    ErlString lhs
)
static let inline (=)
        rhs : string *
        lhs : ErlString  : bool
static let inline (=)
        rhs : string *
        lhs : ErlString  : bool

Parameters

rhs
Type: Online System String
lhs
Type: NFX.Erlang ErlString

Return Value

Type: Online Boolean
See Also
ErlString Structure
ErlString Members
Equality Overload
NFX.Erlang Namespace


ErlString.Equality Operator (ErlString, ErlString)

ErlString Equality Operator (ErlString, ErlString) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    ErlString lhs,
    ErlString rhs
)
public static bool operator ==(
    ErlString lhs,
    ErlString rhs
)
Public Shared Operator = (
    lhs As ErlString,
    rhs As ErlString
) As Boolean
Public Shared Operator = (
    lhs As ErlString,
    rhs As ErlString
) As Boolean
public:
static bool operator ==(
    ErlString lhs,
    ErlString rhs
)
public:
static bool operator ==(
    ErlString lhs,
    ErlString rhs
)
static let inline (=)
        lhs : ErlString *
        rhs : ErlString  : bool
static let inline (=)
        lhs : ErlString *
        rhs : ErlString  : bool

Parameters

lhs
Type: NFX.Erlang ErlString
rhs
Type: NFX.Erlang ErlString

Return Value

Type: Online Boolean
See Also
ErlString Structure
ErlString Members
Equality Overload
NFX.Erlang Namespace


ErlString.Equality Operator (ErlString, String)

ErlString Equality Operator (ErlString, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    ErlString lhs,
    string rhs
)
public static bool operator ==(
    ErlString lhs,
    string rhs
)
Public Shared Operator = (
    lhs As ErlString,
    rhs As String
) As Boolean
Public Shared Operator = (
    lhs As ErlString,
    rhs As String
) As Boolean
public:
static bool operator ==(
    ErlString lhs,
    String^ rhs
)
public:
static bool operator ==(
    ErlString lhs,
    String^ rhs
)
static let inline (=)
        lhs : ErlString *
        rhs : string  : bool
static let inline (=)
        lhs : ErlString *
        rhs : string  : bool

Parameters

lhs
Type: NFX.Erlang ErlString
rhs
Type: Online System String

Return Value

Type: Online Boolean
See Also
ErlString Structure
ErlString Members
Equality Overload
NFX.Erlang Namespace


ErlString Implicit Conversion Operators

ErlString Conversion Operators NFX Class Library

Overload List
Name | Description
(String to ErlString) | Implicit conversion of string to ErlString
(ErlString to String) | Implicit conversion of ErlString to string
Back to Top
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString Implicit Conversion (String to ErlString)

ErlString Conversion (String to ErlString) NFX Class Library

Implicit conversion of string to ErlString

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static implicit operator ErlString (
    string a
)
public static implicit operator ErlString (
    string a
)
Public Shared Widening Operator CType (
    a As String
) As ErlString
Public Shared Widening Operator CType (
    a As String
) As ErlString
static implicit operator ErlString (
    String^ a
)
static implicit operator ErlString (
    String^ a
)
F# does not support the declaration of new casting operators.
F# does not support the declaration of new casting operators.

Parameters

a
Type: Online System String

Return Value

Type: ErlString
See Also
ErlString Structure
ErlString Members
Overload
NFX.Erlang Namespace


ErlString Implicit Conversion (ErlString to String)

ErlString Conversion (ErlString to String) NFX Class Library

Implicit conversion of ErlString to string

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static implicit operator string (
    ErlString a
)
public static implicit operator string (
    ErlString a
)
Public Shared Widening Operator CType (
    a As ErlString
) As String
Public Shared Widening Operator CType (
    a As ErlString
) As String
static implicit operator String^ (
    ErlString a
)
static implicit operator String^ (
    ErlString a
)
F# does not support the declaration of new casting operators.
F# does not support the declaration of new casting operators.

Parameters

a
Type: NFX.Erlang ErlString

Return Value

Type: Online String
See Also
ErlString Structure
ErlString Members
Overload
NFX.Erlang Namespace


ErlString.Inequality Operator

ErlString Inequality Operator NFX Class Library

Overload List
Name | Description
Inequality(String, ErlString) |
Inequality(ErlString, ErlString) |
Inequality(ErlString, String) |
Back to Top
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString.Inequality Operator (String, ErlString)

ErlString Inequality Operator (String, ErlString) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    string rhs,
    ErlString lhs
)
public static bool operator !=(
    string rhs,
    ErlString lhs
)
Public Shared Operator <> (
    rhs As String,
    lhs As ErlString
) As Boolean
Public Shared Operator <> (
    rhs As String,
    lhs As ErlString
) As Boolean
public:
static bool operator !=(
    String^ rhs,
    ErlString lhs
)
public:
static bool operator !=(
    String^ rhs,
    ErlString lhs
)
static let inline (<>)
        rhs : string *
        lhs : ErlString  : bool
static let inline (<>)
        rhs : string *
        lhs : ErlString  : bool

Parameters

rhs
Type: Online System String
lhs
Type: NFX.Erlang ErlString

Return Value

Type: Online Boolean
See Also
ErlString Structure
ErlString Members
Inequality Overload
NFX.Erlang Namespace


ErlString.Inequality Operator (ErlString, ErlString)

ErlString Inequality Operator (ErlString, ErlString) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    ErlString lhs,
    ErlString rhs
)
public static bool operator !=(
    ErlString lhs,
    ErlString rhs
)
Public Shared Operator <> (
    lhs As ErlString,
    rhs As ErlString
) As Boolean
Public Shared Operator <> (
    lhs As ErlString,
    rhs As ErlString
) As Boolean
public:
static bool operator !=(
    ErlString lhs,
    ErlString rhs
)
public:
static bool operator !=(
    ErlString lhs,
    ErlString rhs
)
static let inline (<>)
        lhs : ErlString *
        rhs : ErlString  : bool
static let inline (<>)
        lhs : ErlString *
        rhs : ErlString  : bool

Parameters

lhs
Type: NFX.Erlang ErlString
rhs
Type: NFX.Erlang ErlString

Return Value

Type: Online Boolean
See Also
ErlString Structure
ErlString Members
Inequality Overload
NFX.Erlang Namespace


ErlString.Inequality Operator (ErlString, String)

ErlString Inequality Operator (ErlString, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    ErlString lhs,
    string rhs
)
public static bool operator !=(
    ErlString lhs,
    string rhs
)
Public Shared Operator <> (
    lhs As ErlString,
    rhs As String
) As Boolean
Public Shared Operator <> (
    lhs As ErlString,
    rhs As String
) As Boolean
public:
static bool operator !=(
    ErlString lhs,
    String^ rhs
)
public:
static bool operator !=(
    ErlString lhs,
    String^ rhs
)
static let inline (<>)
        lhs : ErlString *
        rhs : string  : bool
static let inline (<>)
        lhs : ErlString *
        rhs : string  : bool

Parameters

lhs
Type: NFX.Erlang ErlString
rhs
Type: Online System String

Return Value

Type: Online Boolean
See Also
ErlString Structure
ErlString Members
Inequality Overload
NFX.Erlang Namespace


ErlString Properties

ErlString Properties NFX Class Library

The ErlString type exposes the following members.
Properties
 | Name | Description
Public property | Empty | Returns true if Value is a non-empty string
Public property | IsScalar | Determines whether the underlying type is scalar or complex (i.e. tuple, list)
Public property | Length | Length of the string
Public property | TypeOrder |
Public property | Value | Get the actual string contained in this object
Public property | ValueAsBool |
Public property | ValueAsByteArray |
Public property | ValueAsChar |
Public property | ValueAsDateTime |
Public property | ValueAsDecimal |
Public property | ValueAsDouble |
Public property | ValueAsInt |
Public property | ValueAsLong |
Public property | ValueAsObject |
Public property | ValueAsString |
Public property | ValueAsTimeSpan |
Back to Top
See Also
ErlString Structure
NFX.Erlang Namespace


ErlString.Empty Property

ErlString Empty Property NFX Class Library

Returns true if Value is a non-empty string

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Empty { get; }
public bool Empty { get; }
Public ReadOnly Property Empty As Boolean
    Get
Public ReadOnly Property Empty As Boolean
    Get
public:
property bool Empty {
    bool get ();
}
public:
property bool Empty {
    bool get ();
}
member Empty : bool with get
member Empty : bool with get

Property Value

Type: Online Boolean
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString.IsScalar Property

ErlString IsScalar Property NFX Class Library

Determines whether the underlying type is scalar or complex (i.e. tuple, list)

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsScalar { get; }
public bool IsScalar { get; }
Public ReadOnly Property IsScalar As Boolean
    Get
Public ReadOnly Property IsScalar As Boolean
    Get
public:
virtual property bool IsScalar {
    bool get () sealed;
}
public:
virtual property bool IsScalar {
    bool get () sealed;
}
abstract IsScalar : bool with get
override IsScalar : bool with get
abstract IsScalar : bool with get
override IsScalar : bool with get

Property Value

Type: Online Boolean

Implements

IErlObject IsScalar
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString.Length Property

ErlString Length Property NFX Class Library

Length of the string

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Length { get; }
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get
Public ReadOnly Property Length As Integer
    Get
public:
property int Length {
    int get ();
}
public:
property int Length {
    int get ();
}
member Length : int with get
member Length : int with get

Property Value

Type: Online Int32
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString.TypeOrder Property

ErlString TypeOrder Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTypeOrder TypeOrder { get; }
public ErlTypeOrder TypeOrder { get; }
Public ReadOnly Property TypeOrder As ErlTypeOrder
    Get
Public ReadOnly Property TypeOrder As ErlTypeOrder
    Get
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () sealed;
}
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () sealed;
}
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get

Property Value

Type: ErlTypeOrder

Implements

IErlObject TypeOrder
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString.Value Property

ErlString Value Property NFX Class Library

Get the actual string contained in this object

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Value { get; }
public string Value { get; }
Public ReadOnly Property Value As String
    Get
Public ReadOnly Property Value As String
    Get
public:
virtual property String^ Value {
    String^ get () sealed;
}
public:
virtual property String^ Value {
    String^ get () sealed;
}
abstract Value : string with get
override Value : string with get
abstract Value : string with get
override Value : string with get

Property Value

Type: Online String

Implements

IErlObject T Value
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString.ValueAsBool Property

ErlString ValueAsBool Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ValueAsBool { get; }
public bool ValueAsBool { get; }
Public ReadOnly Property ValueAsBool As Boolean
    Get
Public ReadOnly Property ValueAsBool As Boolean
    Get
public:
virtual property bool ValueAsBool {
    bool get () sealed;
}
public:
virtual property bool ValueAsBool {
    bool get () sealed;
}
abstract ValueAsBool : bool with get
override ValueAsBool : bool with get
abstract ValueAsBool : bool with get
override ValueAsBool : bool with get

Property Value

Type: Online Boolean

Implements

IErlObject ValueAsBool
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString.ValueAsByteArray Property

ErlString ValueAsByteArray Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] ValueAsByteArray { get; }
public byte[] ValueAsByteArray { get; }
Public ReadOnly Property ValueAsByteArray As Byte()
    Get
Public ReadOnly Property ValueAsByteArray As Byte()
    Get
public:
virtual property array<unsigned char>^ ValueAsByteArray {
    array<unsigned char>^ get () sealed;
}
public:
virtual property array<unsigned char>^ ValueAsByteArray {
    array<unsigned char>^ get () sealed;
}
abstract ValueAsByteArray : byte[] with get
override ValueAsByteArray : byte[] with get
abstract ValueAsByteArray : byte[] with get
override ValueAsByteArray : byte[] with get

Property Value

Type: Online Byte

Implements

IErlObject ValueAsByteArray
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString.ValueAsChar Property

ErlString ValueAsChar Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char ValueAsChar { get; }
public char ValueAsChar { get; }
Public ReadOnly Property ValueAsChar As Char
    Get
Public ReadOnly Property ValueAsChar As Char
    Get
public:
virtual property wchar_t ValueAsChar {
    wchar_t get () sealed;
}
public:
virtual property wchar_t ValueAsChar {
    wchar_t get () sealed;
}
abstract ValueAsChar : char with get
override ValueAsChar : char with get
abstract ValueAsChar : char with get
override ValueAsChar : char with get

Property Value

Type: Online Char

Implements

IErlObject ValueAsChar
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString.ValueAsDateTime Property

ErlString ValueAsDateTime Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime ValueAsDateTime { get; }
public DateTime ValueAsDateTime { get; }
Public ReadOnly Property ValueAsDateTime As DateTime
    Get
Public ReadOnly Property ValueAsDateTime As DateTime
    Get
public:
virtual property DateTime ValueAsDateTime {
    DateTime get () sealed;
}
public:
virtual property DateTime ValueAsDateTime {
    DateTime get () sealed;
}
abstract ValueAsDateTime : DateTime with get
override ValueAsDateTime : DateTime with get
abstract ValueAsDateTime : DateTime with get
override ValueAsDateTime : DateTime with get

Property Value

Type: Online DateTime

Implements

IErlObject ValueAsDateTime
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString.ValueAsDecimal Property

ErlString ValueAsDecimal Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal ValueAsDecimal { get; }
public decimal ValueAsDecimal { get; }
Public ReadOnly Property ValueAsDecimal As Decimal
    Get
Public ReadOnly Property ValueAsDecimal As Decimal
    Get
public:
virtual property Decimal ValueAsDecimal {
    Decimal get () sealed;
}
public:
virtual property Decimal ValueAsDecimal {
    Decimal get () sealed;
}
abstract ValueAsDecimal : decimal with get
override ValueAsDecimal : decimal with get
abstract ValueAsDecimal : decimal with get
override ValueAsDecimal : decimal with get

Property Value

Type: Online Decimal

Implements

IErlObject ValueAsDecimal
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString.ValueAsDouble Property

ErlString ValueAsDouble Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double ValueAsDouble { get; }
public double ValueAsDouble { get; }
Public ReadOnly Property ValueAsDouble As Double
    Get
Public ReadOnly Property ValueAsDouble As Double
    Get
public:
virtual property double ValueAsDouble {
    double get () sealed;
}
public:
virtual property double ValueAsDouble {
    double get () sealed;
}
abstract ValueAsDouble : float with get
override ValueAsDouble : float with get
abstract ValueAsDouble : float with get
override ValueAsDouble : float with get

Property Value

Type: Online Double

Implements

IErlObject ValueAsDouble
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString.ValueAsInt Property

ErlString ValueAsInt Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ValueAsInt { get; }
public int ValueAsInt { get; }
Public ReadOnly Property ValueAsInt As Integer
    Get
Public ReadOnly Property ValueAsInt As Integer
    Get
public:
virtual property int ValueAsInt {
    int get () sealed;
}
public:
virtual property int ValueAsInt {
    int get () sealed;
}
abstract ValueAsInt : int with get
override ValueAsInt : int with get
abstract ValueAsInt : int with get
override ValueAsInt : int with get

Property Value

Type: Online Int32

Implements

IErlObject ValueAsInt
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString.ValueAsLong Property

ErlString ValueAsLong Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long ValueAsLong { get; }
public long ValueAsLong { get; }
Public ReadOnly Property ValueAsLong As Long
    Get
Public ReadOnly Property ValueAsLong As Long
    Get
public:
virtual property long long ValueAsLong {
    long long get () sealed;
}
public:
virtual property long long ValueAsLong {
    long long get () sealed;
}
abstract ValueAsLong : int64 with get
override ValueAsLong : int64 with get
abstract ValueAsLong : int64 with get
override ValueAsLong : int64 with get

Property Value

Type: Online Int64

Implements

IErlObject ValueAsLong
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString.ValueAsObject Property

ErlString ValueAsObject Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object ValueAsObject { get; }
public Object ValueAsObject { get; }
Public ReadOnly Property ValueAsObject As Object
    Get
Public ReadOnly Property ValueAsObject As Object
    Get
public:
virtual property Object^ ValueAsObject {
    Object^ get () sealed;
}
public:
virtual property Object^ ValueAsObject {
    Object^ get () sealed;
}
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get

Property Value

Type: Online Object

Implements

IErlObject ValueAsObject
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString.ValueAsString Property

ErlString ValueAsString Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ValueAsString { get; }
public string ValueAsString { get; }
Public ReadOnly Property ValueAsString As String
    Get
Public ReadOnly Property ValueAsString As String
    Get
public:
virtual property String^ ValueAsString {
    String^ get () sealed;
}
public:
virtual property String^ ValueAsString {
    String^ get () sealed;
}
abstract ValueAsString : string with get
override ValueAsString : string with get
abstract ValueAsString : string with get
override ValueAsString : string with get

Property Value

Type: Online String

Implements

IErlObject ValueAsString
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlString.ValueAsTimeSpan Property

ErlString ValueAsTimeSpan Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpan ValueAsTimeSpan { get; }
public TimeSpan ValueAsTimeSpan { get; }
Public ReadOnly Property ValueAsTimeSpan As TimeSpan
    Get
Public ReadOnly Property ValueAsTimeSpan As TimeSpan
    Get
public:
virtual property TimeSpan ValueAsTimeSpan {
    TimeSpan get () sealed;
}
public:
virtual property TimeSpan ValueAsTimeSpan {
    TimeSpan get () sealed;
}
abstract ValueAsTimeSpan : TimeSpan with get
override ValueAsTimeSpan : TimeSpan with get
abstract ValueAsTimeSpan : TimeSpan with get
override ValueAsTimeSpan : TimeSpan with get

Property Value

Type: Online TimeSpan

Implements

IErlObject ValueAsTimeSpan
See Also
ErlString Structure
ErlString Members
NFX.Erlang Namespace


ErlTcpTransport Class

ErlTcpTransport Class NFX Class Library

TCP transport
Inheritance Hierarchy
Online System Object
NFX.Erlang ErlTcpTransport

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ErlTcpTransport : IErlTransport,
    IDisposable
public class ErlTcpTransport : IErlTransport,
    IDisposable
Public Class ErlTcpTransport
    Implements IErlTransport, IDisposable
Public Class ErlTcpTransport
    Implements IErlTransport, IDisposable
public ref class ErlTcpTransport : IErlTransport,
    IDisposable
public ref class ErlTcpTransport : IErlTransport,
    IDisposable
type ErlTcpTransport =
    class
        interface IErlTransport
        interface IDisposable
    end
type ErlTcpTransport =
    class
        interface IErlTransport
        interface IDisposable
    end
See Also
ErlTcpTransport Members
NFX.Erlang Namespace


ErlTcpTransport Members

ErlTcpTransport Members NFX Class Library

The ErlTcpTransport type exposes the following members.
Constructors
 | Name | Description
Public method | ErlTcpTransport | Initializes a new instance of the ErlTcpTransport class
Public method | ErlTcpTransport(TcpClient) | Initializes a new instance of the ErlTcpTransport class
Public method | ErlTcpTransport(String, Int32) | Initializes a new instance of the ErlTcpTransport class
Back to Top
Methods
 | Name | Description
Public method | Close |
Public method | Connect(String, Int32) |
Public method | Connect(String, Int32, Int32) |
Public method | Dispose | Releases all resources used by the ErlTcpTransport
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetStream |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetSocketOption |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Client |
Back to Top
Properties
 | Name | Description
Public property | ConnectTimeout |
Public property | NoDelay |
Public property | NodeName |
Public property | ReceiveBufferSize |
Public property | RemoteEndPoint |
Public property | SendBufferSize |
Public property | SSHAuthenticationType |
Public property | SSHPrivateKeyFilePath |
Public property | SSHServerPort |
Public property | SSHUserName |
Back to Top
Events
 | Name | Description
Public event | Trace | Transmits trace messages
Back to Top
See Also
ErlTcpTransport Class
NFX.Erlang Namespace


ErlTcpTransport Constructor

ErlTcpTransport Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ErlTcpTransport | Initializes a new instance of the ErlTcpTransport class
Public method | ErlTcpTransport(TcpClient) | Initializes a new instance of the ErlTcpTransport class
Public method | ErlTcpTransport(String, Int32) | Initializes a new instance of the ErlTcpTransport class
Back to Top
See Also
ErlTcpTransport Class
ErlTcpTransport Members
NFX.Erlang Namespace


ErlTcpTransport Constructor

ErlTcpTransport Constructor NFX Class Library

Initializes a new instance of the ErlTcpTransport class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTcpTransport()
public ErlTcpTransport()
Public Sub New
Public Sub New
public:
ErlTcpTransport()
public:
ErlTcpTransport()
new : unit -> ErlTcpTransport
new : unit -> ErlTcpTransport
See Also
ErlTcpTransport Class
ErlTcpTransport Members
ErlTcpTransport Overload
NFX.Erlang Namespace


ErlTcpTransport Constructor (TcpClient)

ErlTcpTransport Constructor (TcpClient) NFX Class Library

Initializes a new instance of the ErlTcpTransport class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTcpTransport(
    TcpClient client
)
public ErlTcpTransport(
    TcpClient client
)
Public Sub New (
    client As TcpClient
)
Public Sub New (
    client As TcpClient
)
public:
ErlTcpTransport(
    TcpClient^ client
)
public:
ErlTcpTransport(
    TcpClient^ client
)
new :
        client : TcpClient -> ErlTcpTransport
new :
        client : TcpClient -> ErlTcpTransport

Parameters

client
Type: Online System.Net.Sockets TcpClient
See Also
ErlTcpTransport Class
ErlTcpTransport Members
ErlTcpTransport Overload
NFX.Erlang Namespace


ErlTcpTransport Constructor (String, Int32)

ErlTcpTransport Constructor (String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlTcpTransport class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTcpTransport(
    string host,
    int port
)
public ErlTcpTransport(
    string host,
    int port
)
Public Sub New (
    host As String,
    port As Integer
)
Public Sub New (
    host As String,
    port As Integer
)
public:
ErlTcpTransport(
    String^ host,
    int port
)
public:
ErlTcpTransport(
    String^ host,
    int port
)
new :
        host : string *
        port : int -> ErlTcpTransport
new :
        host : string *
        port : int -> ErlTcpTransport

Parameters

host
Type: Online System String
port
Type: Online System Int32
See Also
ErlTcpTransport Class
ErlTcpTransport Members
ErlTcpTransport Overload
NFX.Erlang Namespace


ErlTcpTransport Fields

ErlTcpTransport Fields NFX Class Library

The ErlTcpTransport type exposes the following members.
Fields
 | Name | Description
Protected field | m_Client |
Back to Top
See Also
ErlTcpTransport Class
NFX.Erlang Namespace


ErlTcpTransport.m_Client Field

ErlTcpTransport m_Client Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TcpClient m_Client
protected TcpClient m_Client
Protected m_Client As TcpClient
Protected m_Client As TcpClient
protected:
TcpClient^ m_Client
protected:
TcpClient^ m_Client
val mutable m_Client: TcpClient
val mutable m_Client: TcpClient

Field Value

Type: Online TcpClient
See Also
ErlTcpTransport Class
ErlTcpTransport Members
NFX.Erlang Namespace


ErlTcpTransport Methods

ErlTcpTransport Methods NFX Class Library

The ErlTcpTransport type exposes the following members.
Methods
 | Name | Description
Public method | Close |
Public method | Connect(String, Int32) |
Public method | Connect(String, Int32, Int32) |
Public method | Dispose |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetStream |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetSocketOption |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ErlTcpTransport Class
NFX.Erlang Namespace


ErlTcpTransport.Close Method

ErlTcpTransport Close Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Close()
public void Close()
Public Sub Close
Public Sub Close
public:
virtual void Close() sealed
public:
virtual void Close() sealed
abstract Close : unit -> unit
override Close : unit -> unit
abstract Close : unit -> unit
override Close : unit -> unit

Implements

IErlTransport Close
See Also
ErlTcpTransport Class
ErlTcpTransport Members
NFX.Erlang Namespace


ErlTcpTransport.Connect Method

ErlTcpTransport Connect Method NFX Class Library

Overload List
 | Name | Description
Public method | Connect(String, Int32) |
Public method | Connect(String, Int32, Int32) |
Back to Top
See Also
ErlTcpTransport Class
ErlTcpTransport Members
NFX.Erlang Namespace


ErlTcpTransport.Connect Method (String, Int32)

ErlTcpTransport Connect Method (String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Connect(
    string host,
    int port
)
public virtual void Connect(
    string host,
    int port
)
Public Overridable Sub Connect (
    host As String,
    port As Integer
)
Public Overridable Sub Connect (
    host As String,
    port As Integer
)
public:
virtual void Connect(
    String^ host,
    int port
)
public:
virtual void Connect(
    String^ host,
    int port
)
abstract Connect :
        host : string *
        port : int -> unit
override Connect :
        host : string *
        port : int -> unit
abstract Connect :
        host : string *
        port : int -> unit
override Connect :
        host : string *
        port : int -> unit

Parameters

host
Type: Online System String
port
Type: Online System Int32

Implements

IErlTransport Connect(String, Int32)
See Also
ErlTcpTransport Class
ErlTcpTransport Members
Connect Overload
NFX.Erlang Namespace


ErlTcpTransport.Connect Method (String, Int32, Int32)

ErlTcpTransport Connect Method (String, Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Connect(
    string host,
    int port,
    int timeoutMsec
)
public virtual void Connect(
    string host,
    int port,
    int timeoutMsec
)
Public Overridable Sub Connect (
    host As String,
    port As Integer,
    timeoutMsec As Integer
)
Public Overridable Sub Connect (
    host As String,
    port As Integer,
    timeoutMsec As Integer
)
public:
virtual void Connect(
    String^ host,
    int port,
    int timeoutMsec
)
public:
virtual void Connect(
    String^ host,
    int port,
    int timeoutMsec
)
abstract Connect :
        host : string *
        port : int *
        timeoutMsec : int -> unit
override Connect :
        host : string *
        port : int *
        timeoutMsec : int -> unit
abstract Connect :
        host : string *
        port : int *
        timeoutMsec : int -> unit
override Connect :
        host : string *
        port : int *
        timeoutMsec : int -> unit

Parameters

host
Type: Online System String
port
Type: Online System Int32
timeoutMsec
Type: Online System Int32

Implements

IErlTransport Connect(String, Int32, Int32)
See Also
ErlTcpTransport Class
ErlTcpTransport Members
Connect Overload
NFX.Erlang Namespace


ErlTcpTransport.Dispose Method

ErlTcpTransport Dispose Method NFX Class Library

Releases all resources used by the ErlTcpTransport

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

Online IDisposable Dispose
See Also
ErlTcpTransport Class
ErlTcpTransport Members
NFX.Erlang Namespace


ErlTcpTransport.GetStream Method

ErlTcpTransport GetStream Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Stream GetStream()
public Stream GetStream()
Public Function GetStream As Stream
Public Function GetStream As Stream
public:
virtual Stream^ GetStream() sealed
public:
virtual Stream^ GetStream() sealed
abstract GetStream : unit -> Stream
override GetStream : unit -> Stream
abstract GetStream : unit -> Stream
override GetStream : unit -> Stream

Return Value

Type: Online Stream

Implements

IErlTransport GetStream
See Also
ErlTcpTransport Class
ErlTcpTransport Members
NFX.Erlang Namespace


ErlTcpTransport.SetSocketOption Method

ErlTcpTransport SetSocketOption Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetSocketOption(
    SocketOptionLevel optionLevel,
    SocketOptionName optionName,
    bool optionValue
)
public void SetSocketOption(
    SocketOptionLevel optionLevel,
    SocketOptionName optionName,
    bool optionValue
)
Public Sub SetSocketOption (
    optionLevel As SocketOptionLevel,
    optionName As SocketOptionName,
    optionValue As Boolean
)
Public Sub SetSocketOption (
    optionLevel As SocketOptionLevel,
    optionName As SocketOptionName,
    optionValue As Boolean
)
public:
virtual void SetSocketOption(
    SocketOptionLevel optionLevel,
    SocketOptionName optionName,
    bool optionValue
) sealed
public:
virtual void SetSocketOption(
    SocketOptionLevel optionLevel,
    SocketOptionName optionName,
    bool optionValue
) sealed
abstract SetSocketOption :
        optionLevel : SocketOptionLevel *
        optionName : SocketOptionName *
        optionValue : bool -> unit
override SetSocketOption :
        optionLevel : SocketOptionLevel *
        optionName : SocketOptionName *
        optionValue : bool -> unit
abstract SetSocketOption :
        optionLevel : SocketOptionLevel *
        optionName : SocketOptionName *
        optionValue : bool -> unit
override SetSocketOption :
        optionLevel : SocketOptionLevel *
        optionName : SocketOptionName *
        optionValue : bool -> unit

Parameters

optionLevel
Type: Online System.Net.Sockets SocketOptionLevel
optionName
Type: Online System.Net.Sockets SocketOptionName
optionValue
Type: Online System Boolean

Implements

IErlTransport SetSocketOption(SocketOptionLevel, SocketOptionName, Boolean)
See Also
ErlTcpTransport Class
ErlTcpTransport Members
NFX.Erlang Namespace


ErlTcpTransport Properties

ErlTcpTransport Properties NFX Class Library

The ErlTcpTransport type exposes the following members.
Properties
 | Name | Description
Public property | ConnectTimeout |
Public property | NoDelay |
Public property | NodeName |
Public property | ReceiveBufferSize |
Public property | RemoteEndPoint |
Public property | SendBufferSize |
Public property | SSHAuthenticationType |
Public property | SSHPrivateKeyFilePath |
Public property | SSHServerPort |
Public property | SSHUserName |
Back to Top
See Also
ErlTcpTransport Class
NFX.Erlang Namespace


ErlTcpTransport.ConnectTimeout Property

ErlTcpTransport ConnectTimeout Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ConnectTimeout { get; set; }
public int ConnectTimeout { get; set; }
Public Property ConnectTimeout As Integer
    Get
    Set
Public Property ConnectTimeout As Integer
    Get
    Set
public:
virtual property int ConnectTimeout {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int ConnectTimeout {
    int get () sealed;
    void set (int value) sealed;
}
abstract ConnectTimeout : int with get, set
override ConnectTimeout : int with get, set
abstract ConnectTimeout : int with get, set
override ConnectTimeout : int with get, set

Property Value

Type: Online Int32

Implements

IErlTransport ConnectTimeout
See Also
ErlTcpTransport Class
ErlTcpTransport Members
NFX.Erlang Namespace


ErlTcpTransport.NoDelay Property

ErlTcpTransport NoDelay Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool NoDelay { get; set; }
public bool NoDelay { get; set; }
Public Property NoDelay As Boolean
    Get
    Set
Public Property NoDelay As Boolean
    Get
    Set
public:
virtual property bool NoDelay {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool NoDelay {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract NoDelay : bool with get, set
override NoDelay : bool with get, set
abstract NoDelay : bool with get, set
override NoDelay : bool with get, set

Property Value

Type: Online Boolean

Implements

IErlTransport NoDelay
See Also
ErlTcpTransport Class
ErlTcpTransport Members
NFX.Erlang Namespace


ErlTcpTransport.NodeName Property

ErlTcpTransport NodeName Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string NodeName { get; set; }
public string NodeName { get; set; }
Public Property NodeName As String
    Get
    Set
Public Property NodeName As String
    Get
    Set
public:
virtual property String^ NodeName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ NodeName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract NodeName : string with get, set
override NodeName : string with get, set
abstract NodeName : string with get, set
override NodeName : string with get, set

Property Value

Type: Online String

Implements

IErlTransport NodeName
See Also
ErlTcpTransport Class
ErlTcpTransport Members
NFX.Erlang Namespace


ErlTcpTransport.ReceiveBufferSize Property

ErlTcpTransport ReceiveBufferSize Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ReceiveBufferSize { get; set; }
public int ReceiveBufferSize { get; set; }
Public Property ReceiveBufferSize As Integer
    Get
    Set
Public Property ReceiveBufferSize As Integer
    Get
    Set
public:
virtual property int ReceiveBufferSize {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int ReceiveBufferSize {
    int get () sealed;
    void set (int value) sealed;
}
abstract ReceiveBufferSize : int with get, set
override ReceiveBufferSize : int with get, set
abstract ReceiveBufferSize : int with get, set
override ReceiveBufferSize : int with get, set

Property Value

Type: Online Int32

Implements

IErlTransport ReceiveBufferSize
See Also
ErlTcpTransport Class
ErlTcpTransport Members
NFX.Erlang Namespace


ErlTcpTransport.RemoteEndPoint Property

ErlTcpTransport RemoteEndPoint Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EndPoint RemoteEndPoint { get; }
public EndPoint RemoteEndPoint { get; }
Public ReadOnly Property RemoteEndPoint As EndPoint
    Get
Public ReadOnly Property RemoteEndPoint As EndPoint
    Get
public:
virtual property EndPoint^ RemoteEndPoint {
    EndPoint^ get () sealed;
}
public:
virtual property EndPoint^ RemoteEndPoint {
    EndPoint^ get () sealed;
}
abstract RemoteEndPoint : EndPoint with get
override RemoteEndPoint : EndPoint with get
abstract RemoteEndPoint : EndPoint with get
override RemoteEndPoint : EndPoint with get

Property Value

Type: Online EndPoint

Implements

IErlTransport RemoteEndPoint
See Also
ErlTcpTransport Class
ErlTcpTransport Members
NFX.Erlang Namespace


ErlTcpTransport.SendBufferSize Property

ErlTcpTransport SendBufferSize Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int SendBufferSize { get; set; }
public int SendBufferSize { get; set; }
Public Property SendBufferSize As Integer
    Get
    Set
Public Property SendBufferSize As Integer
    Get
    Set
public:
virtual property int SendBufferSize {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int SendBufferSize {
    int get () sealed;
    void set (int value) sealed;
}
abstract SendBufferSize : int with get, set
override SendBufferSize : int with get, set
abstract SendBufferSize : int with get, set
override SendBufferSize : int with get, set

Property Value

Type: Online Int32

Implements

IErlTransport SendBufferSize
See Also
ErlTcpTransport Class
ErlTcpTransport Members
NFX.Erlang Namespace


ErlTcpTransport.SSHAuthenticationType Property

ErlTcpTransport SSHAuthenticationType Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SSHAuthenticationType { get; set; }
public string SSHAuthenticationType { get; set; }
Public Property SSHAuthenticationType As String
    Get
    Set
Public Property SSHAuthenticationType As String
    Get
    Set
public:
virtual property String^ SSHAuthenticationType {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ SSHAuthenticationType {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract SSHAuthenticationType : string with get, set
override SSHAuthenticationType : string with get, set
abstract SSHAuthenticationType : string with get, set
override SSHAuthenticationType : string with get, set

Property Value

Type: Online String

Implements

IErlTransport SSHAuthenticationType
See Also
ErlTcpTransport Class
ErlTcpTransport Members
NFX.Erlang Namespace


ErlTcpTransport.SSHPrivateKeyFilePath Property

ErlTcpTransport SSHPrivateKeyFilePath Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SSHPrivateKeyFilePath { get; set; }
public string SSHPrivateKeyFilePath { get; set; }
Public Property SSHPrivateKeyFilePath As String
    Get
    Set
Public Property SSHPrivateKeyFilePath As String
    Get
    Set
public:
virtual property String^ SSHPrivateKeyFilePath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ SSHPrivateKeyFilePath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract SSHPrivateKeyFilePath : string with get, set
override SSHPrivateKeyFilePath : string with get, set
abstract SSHPrivateKeyFilePath : string with get, set
override SSHPrivateKeyFilePath : string with get, set

Property Value

Type: Online String

Implements

IErlTransport SSHPrivateKeyFilePath
See Also
ErlTcpTransport Class
ErlTcpTransport Members
NFX.Erlang Namespace


ErlTcpTransport.SSHServerPort Property

ErlTcpTransport SSHServerPort Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int SSHServerPort { get; set; }
public int SSHServerPort { get; set; }
Public Property SSHServerPort As Integer
    Get
    Set
Public Property SSHServerPort As Integer
    Get
    Set
public:
virtual property int SSHServerPort {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int SSHServerPort {
    int get () sealed;
    void set (int value) sealed;
}
abstract SSHServerPort : int with get, set
override SSHServerPort : int with get, set
abstract SSHServerPort : int with get, set
override SSHServerPort : int with get, set

Property Value

Type: Online Int32

Implements

IErlTransport SSHServerPort
See Also
ErlTcpTransport Class
ErlTcpTransport Members
NFX.Erlang Namespace


ErlTcpTransport.SSHUserName Property

ErlTcpTransport SSHUserName Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SSHUserName { get; set; }
public string SSHUserName { get; set; }
Public Property SSHUserName As String
    Get
    Set
Public Property SSHUserName As String
    Get
    Set
public:
virtual property String^ SSHUserName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ SSHUserName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract SSHUserName : string with get, set
override SSHUserName : string with get, set
abstract SSHUserName : string with get, set
override SSHUserName : string with get, set

Property Value

Type: Online String

Implements

IErlTransport SSHUserName
See Also
ErlTcpTransport Class
ErlTcpTransport Members
NFX.Erlang Namespace


ErlTcpTransport Events

ErlTcpTransport Events NFX Class Library

The ErlTcpTransport type exposes the following members.
Events
 | Name | Description
Public event | Trace | Transmits trace messages
Back to Top
See Also
ErlTcpTransport Class
NFX.Erlang Namespace


ErlTcpTransport.Trace Event

ErlTcpTransport Trace Event NFX Class Library

Transmits trace messages

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event TraceEventHandler Trace
public event TraceEventHandler Trace
Public Event Trace As TraceEventHandler
Public Event Trace As TraceEventHandler
public:
virtual  event TraceEventHandler^ Trace {
    void add (TraceEventHandler^ value);
    void remove (TraceEventHandler^ value);
}
public:
virtual  event TraceEventHandler^ Trace {
    void add (TraceEventHandler^ value);
    void remove (TraceEventHandler^ value);
}
abstract Trace : IEvent<TraceEventHandler,
    EventArgs>
override Trace : IEvent<TraceEventHandler,
    EventArgs>
abstract Trace : IEvent<TraceEventHandler,
    EventArgs>
override Trace : IEvent<TraceEventHandler,
    EventArgs>

Value

Type: NFX.Erlang TraceEventHandler

Implements

IErlTransport Trace
See Also
ErlTcpTransport Class
ErlTcpTransport Members
NFX.Erlang Namespace


ErlTrace Class

ErlTrace Class NFX Class Library

Special class used for passing tracing information in Erlang distributed messages SEND_TT, EXIT_TT, REG_SEND_TT, EXIT2_TT
Inheritance Hierarchy
Online System Object
NFX.Erlang ErlTupleBase
NFX.Erlang ErlTuple
NFX.Erlang ErlTrace

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ErlTrace : ErlTuple
public class ErlTrace : ErlTuple
Public Class ErlTrace
    Inherits ErlTuple
Public Class ErlTrace
    Inherits ErlTuple
public ref class ErlTrace : public ErlTuple
public ref class ErlTrace : public ErlTuple
type ErlTrace =
    class
        inherit ErlTuple
    end
type ErlTrace =
    class
        inherit ErlTuple
    end
Remarks
See
See Also
ErlTrace Members
NFX.Erlang Namespace


ErlTrace Members

ErlTrace Members NFX Class Library

The ErlTrace type exposes the following members.
Constructors
 | Name | Description
Public method | ErlTrace | Initializes a new instance of the ErlTrace class
Public method | ErlTrace(ErlTuple) | Initializes a new instance of the ErlTrace class
Public method | ErlTrace(Int32, Int32, Int32, ErlPid, Int32) | Create an Erlang trace from the given arguments
Back to Top
Methods
 | Name | Description
Public method | Add | Add an item to a mutable list. This method must be used only during list construction phase, since it treats the list as a mutable entity (Inherited from ErlTupleBase.)
Public method | Cast T | Return index'th element cast to the given type (Inherited from ErlTupleBase.)
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference) (Inherited from ErlTupleBase.)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the atom is less than obj, positive - greater than the obj (Inherited from ErlTupleBase.)
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the atom is less than obj, positive - greater than the obj (Inherited from ErlTupleBase.)
Public method | Equals(Object) | (Overrides ErlTuple Equals(Object).)
Public method | Equals(ErlTrace) | Determine if two Erlang tuples are equal
Public method | Equals(ErlTuple) | Determine if two Erlang tuples are equal (Inherited from ErlTuple.)
Public method | Equals(IErlObject) | Determine if two Erlang objects are equal (Overrides ErlTuple Equals(IErlObject).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides ErlTuple GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeInstance | (Overrides ErlTuple MakeInstance .)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern (Inherited from ErlTupleBase.)
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding. (Inherited from ErlTupleBase.)
Public method | Matches | Perform pattern match on this Erlang term without binding any variables (Inherited from ErlTupleBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Subst | (Inherited from ErlTupleBase.)
Public method | ToString | Get the string representation of the list. (Inherited from ErlTupleBase.)
Public method | ToString(Boolean) | (Inherited from ErlTupleBase.)
Public method | Visit TAccumulate | Execute fun for every nested term (Inherited from ErlTupleBase.)
Back to Top
Operators
Name | Description
Equality |
(ErlTrace to List IErlObject ) | Implicit conversion of atom to string
Inequality |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Items | The index of this atom in the global atom table (Inherited from ErlTupleBase.)
Back to Top
Properties
Name | Description
Protected property | CloseBracket | (Overrides ErlTuple CloseBracket.)
Public property Count
Return number of elements in the container
(Inherited from ErlTupleBase.)
Public property | Flags
Public property | From
Public property IsScalar
Determines whether the underlying type is scalar or complex (i.e. tuple, list)
(Inherited from ErlTupleBase.)
Public property Item
Return index'th element from the container
(Inherited from ErlTupleBase.)
Public property | Label
Protected property | OpenBracket | (Overrides ErlTuple OpenBracket.)
Public property | Prev
Public property | Serial
Public property | TypeOrder | (Overrides ErlTuple TypeOrder.)
Public property Value
Get the list of Erlang terms contained in this object
(Inherited from ErlTupleBase.)
Public property | ValueAsBool | (Inherited from ErlTupleBase.)
Public property | ValueAsByteArray | (Inherited from ErlTupleBase.)
Public property | ValueAsChar | (Inherited from ErlTupleBase.)
Public property ValueAsDateTime
Returns tuple value as DateTime in UTC if the tuple is in the form
View Colorized Copy to Clipboard Print
{MegaSec, Sec, MicroSec}
{MegaSec, Sec, MicroSec}
(Inherited from ErlTuple.)
Public property | ValueAsDecimal | (Inherited from ErlTupleBase.)
Public property | ValueAsDouble | (Inherited from ErlTupleBase.)
Public property | ValueAsInt | (Inherited from ErlTupleBase.)
Public property | ValueAsLong | (Inherited from ErlTupleBase.)
Public property | ValueAsObject | (Inherited from ErlTupleBase.)
Public property | ValueAsString | (Inherited from ErlTupleBase.)
Public property | ValueAsTimeSpan | (Inherited from ErlTupleBase.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone | (Inherited from ErlTupleBase.)
Explicit interface implemetation | IEnumerable IErlObject GetEnumerator | (Inherited from ErlTupleBase.)
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from ErlTupleBase.)
Back to Top
See Also
ErlTrace Class
NFX.Erlang Namespace


ErlTrace Constructor

ErlTrace Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ErlTrace | Initializes a new instance of the ErlTrace class
Public method | ErlTrace(ErlTuple) | Initializes a new instance of the ErlTrace class
Public method | ErlTrace(Int32, Int32, Int32, ErlPid, Int32) | Create an Erlang trace from the given arguments
Back to Top
See Also
ErlTrace Class
ErlTrace Members
NFX.Erlang Namespace


ErlTrace Constructor

ErlTrace Constructor NFX Class Library

Initializes a new instance of the ErlTrace class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTrace()
public ErlTrace()
Public Sub New
Public Sub New
public:
ErlTrace()
public:
ErlTrace()
new : unit -> ErlTrace
new : unit -> ErlTrace
See Also
ErlTrace Class
ErlTrace Members
ErlTrace Overload
NFX.Erlang Namespace


ErlTrace Constructor (ErlTuple)

ErlTrace Constructor (ErlTuple) NFX Class Library

Initializes a new instance of the ErlTrace class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTrace(
    ErlTuple list
)
public ErlTrace(
    ErlTuple list
)
Public Sub New (
    list As ErlTuple
)
Public Sub New (
    list As ErlTuple
)
public:
ErlTrace(
    ErlTuple^ list
)
public:
ErlTrace(
    ErlTuple^ list
)
new :
        list : ErlTuple -> ErlTrace
new :
        list : ErlTuple -> ErlTrace

Parameters

list
Type: NFX.Erlang ErlTuple
See Also
ErlTrace Class
ErlTrace Members
ErlTrace Overload
NFX.Erlang Namespace


ErlTrace Constructor (Int32, Int32, Int32, ErlPid, Int32)

ErlTrace Constructor (Int32, Int32, Int32, ErlPid, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Create an Erlang trace from the given arguments

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTrace(
    int flags,
    int label,
    int serial,
    ErlPid from,
    int prev
)
public ErlTrace(
    int flags,
    int label,
    int serial,
    ErlPid from,
    int prev
)
Public Sub New (
    flags As Integer,
    label As Integer,
    serial As Integer,
    from As ErlPid,
    prev As Integer
)
Public Sub New (
    flags As Integer,
    label As Integer,
    serial As Integer,
    from As ErlPid,
    prev As Integer
)
public:
ErlTrace(
    int flags,
    int label,
    int serial,
    ErlPid from,
    int prev
)
public:
ErlTrace(
    int flags,
    int label,
    int serial,
    ErlPid from,
    int prev
)
new :
        flags : int *
        label : int *
        serial : int *
        from : ErlPid *
        prev : int -> ErlTrace
new :
        flags : int *
        label : int *
        serial : int *
        from : ErlPid *
        prev : int -> ErlTrace

Parameters

flags
Type: Online System Int32
label
Type: Online System Int32
serial
Type: Online System Int32
from
Type: NFX.Erlang ErlPid
prev
Type: Online System Int32
See Also
ErlTrace Class
ErlTrace Members
ErlTrace Overload
NFX.Erlang Namespace


ErlTrace Fields

ErlTrace Fields NFX Class Library

The ErlTrace type exposes the following members.
Fields
 | Name | Description
Protected field | m_Items | The index of this atom in the global atom table (Inherited from ErlTupleBase.)
Back to Top
See Also
ErlTrace Class
NFX.Erlang Namespace


ErlTrace Methods

ErlTrace Methods NFX Class Library

The ErlTrace type exposes the following members.
Methods
 | Name | Description
Public method | Add | Add an item to a mutable list. This method must be used only during list construction phase, since it treats the list as a mutable entity (Inherited from ErlTupleBase.)
Public method | Cast T | Return index'th element cast to the given type (Inherited from ErlTupleBase.)
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference) (Inherited from ErlTupleBase.)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the atom is less than obj, positive - greater than the obj (Inherited from ErlTupleBase.)
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the atom is less than obj, positive - greater than the obj (Inherited from ErlTupleBase.)
Public method | Equals(Object) | (Overrides ErlTuple Equals(Object).)
Public method | Equals(ErlTrace) | Determine if two Erlang tuples are equal
Public method | Equals(ErlTuple) | Determine if two Erlang tuples are equal (Inherited from ErlTuple.)
Public method | Equals(IErlObject) | Determine if two Erlang objects are equal (Overrides ErlTuple Equals(IErlObject).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides ErlTuple GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeInstance | (Overrides ErlTuple MakeInstance .)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern (Inherited from ErlTupleBase.)
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding. (Inherited from ErlTupleBase.)
Public method | Matches | Perform pattern match on this Erlang term without binding any variables (Inherited from ErlTupleBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Subst | (Inherited from ErlTupleBase.)
Public method | ToString | Get the string representation of the list. (Inherited from ErlTupleBase.)
Public method | ToString(Boolean) | (Inherited from ErlTupleBase.)
Public method | Visit TAccumulate | Execute fun for every nested term (Inherited from ErlTupleBase.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone | (Inherited from ErlTupleBase.)
Explicit interface implemetation | IEnumerable IErlObject GetEnumerator | (Inherited from ErlTupleBase.)
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from ErlTupleBase.)
Back to Top
See Also
ErlTrace Class
NFX.Erlang Namespace


ErlTrace.Equals Method

ErlTrace Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ErlTuple Equals(Object).)
Public method | Equals(ErlTrace) | Determine if two Erlang tuples are equal
Public method | Equals(ErlTuple) | Determine if two Erlang tuples are equal (Inherited from ErlTuple.)
Public method | Equals(IErlObject) | Determine if two Erlang objects are equal (Overrides ErlTuple Equals(IErlObject).)
Back to Top
See Also
ErlTrace Class
ErlTrace Members
NFX.Erlang Namespace


ErlTrace.Equals Method (Object)

ErlTrace Equals Method (Object) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals (
    o As Object
) As Boolean
Public Overrides Function Equals (
    o As Object
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool

Parameters

o
Type: Online System Object

Return Value

Type: Online Boolean
See Also
ErlTrace Class
ErlTrace Members
Equals Overload
NFX.Erlang Namespace


ErlTrace.Equals Method (ErlTrace)

ErlTrace Equals Method (ErlTrace) NFX Class Library

Determine if two Erlang tuples are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    ErlTrace o
)
public bool Equals(
    ErlTrace o
)
Public Function Equals (
    o As ErlTrace
) As Boolean
Public Function Equals (
    o As ErlTrace
) As Boolean
public:
bool Equals(
    ErlTrace^ o
)
public:
bool Equals(
    ErlTrace^ o
)
member Equals :
        o : ErlTrace -> bool
member Equals :
        o : ErlTrace -> bool

Parameters

o
Type: NFX.Erlang ErlTrace

Return Value

Type: Online Boolean
See Also
ErlTrace Class
ErlTrace Members
Equals Overload
NFX.Erlang Namespace


ErlTrace.Equals Method (IErlObject)

ErlTrace Equals Method (IErlObject) NFX Class Library

Determine if two Erlang objects are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    IErlObject o
)
public override bool Equals(
    IErlObject o
)
Public Overrides Function Equals (
    o As IErlObject
) As Boolean
Public Overrides Function Equals (
    o As IErlObject
) As Boolean
public:
virtual bool Equals(
    IErlObject^ o
) override
public:
virtual bool Equals(
    IErlObject^ o
) override
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool

Parameters

o
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
ErlTrace Class
ErlTrace Members
Equals Overload
NFX.Erlang Namespace


ErlTrace.GetHashCode Method

ErlTrace GetHashCode Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
ErlTrace Class
ErlTrace Members
NFX.Erlang Namespace


ErlTrace.MakeInstance Method

ErlTrace MakeInstance Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override ErlTupleBase MakeInstance()
protected override ErlTupleBase MakeInstance()
Protected Overrides Function MakeInstance As ErlTupleBase
Protected Overrides Function MakeInstance As ErlTupleBase
protected:
virtual ErlTupleBase^ MakeInstance() override
protected:
virtual ErlTupleBase^ MakeInstance() override
abstract MakeInstance : unit -> ErlTupleBase
override MakeInstance : unit -> ErlTupleBase
abstract MakeInstance : unit -> ErlTupleBase
override MakeInstance : unit -> ErlTupleBase

Return Value

Type: ErlTupleBase
See Also
ErlTrace Class
ErlTrace Members
NFX.Erlang Namespace


ErlTrace Operators and Type Conversions

ErlTrace Operators and Type Conversions NFX Class Library

The ErlTrace type exposes the following members.
Operators
Name | Description
Equality |
(ErlTrace to List IErlObject ) | Implicit conversion of atom to string
Inequality |
Back to Top
See Also
ErlTrace Class
NFX.Erlang Namespace


ErlTrace.Equality Operator

ErlTrace Equality Operator NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    ErlTrace lhs,
    IErlObject rhs
)
public static bool operator ==(
    ErlTrace lhs,
    IErlObject rhs
)
Public Shared Operator = (
    lhs As ErlTrace,
    rhs As IErlObject
) As Boolean
Public Shared Operator = (
    lhs As ErlTrace,
    rhs As IErlObject
) As Boolean
public:
static bool operator ==(
    ErlTrace^ lhs,
    IErlObject^ rhs
)
public:
static bool operator ==(
    ErlTrace^ lhs,
    IErlObject^ rhs
)
static let inline (=)
        lhs : ErlTrace *
        rhs : IErlObject  : bool
static let inline (=)
        lhs : ErlTrace *
        rhs : IErlObject  : bool

Parameters

lhs
Type: NFX.Erlang ErlTrace
rhs
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean
See Also
ErlTrace Class
ErlTrace Members
NFX.Erlang Namespace


ErlTrace Implicit Conversion (ErlTrace to List(IErlObject))

ErlTrace Conversion (ErlTrace to List IErlObject ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Implicit conversion of atom to string

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static implicit operator List<IErlObject> (
    ErlTrace a
)
public static implicit operator List<IErlObject> (
    ErlTrace a
)
Public Shared Widening Operator CType (
    a As ErlTrace
) As List(Of IErlObject)
Public Shared Widening Operator CType (
    a As ErlTrace
) As List(Of IErlObject)
static implicit operator List<IErlObject^>^ (
    ErlTrace^ a
)
static implicit operator List<IErlObject^>^ (
    ErlTrace^ a
)
F# does not support the declaration of new casting operators.
F# does not support the declaration of new casting operators.

Parameters

a
Type: NFX.Erlang ErlTrace

Return Value

Type: Online List IErlObject
See Also
ErlTrace Class
ErlTrace Members
NFX.Erlang Namespace


ErlTrace.Inequality Operator

ErlTrace Inequality Operator NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    ErlTrace lhs,
    IErlObject rhs
)
public static bool operator !=(
    ErlTrace lhs,
    IErlObject rhs
)
Public Shared Operator <> (
    lhs As ErlTrace,
    rhs As IErlObject
) As Boolean
Public Shared Operator <> (
    lhs As ErlTrace,
    rhs As IErlObject
) As Boolean
public:
static bool operator !=(
    ErlTrace^ lhs,
    IErlObject^ rhs
)
public:
static bool operator !=(
    ErlTrace^ lhs,
    IErlObject^ rhs
)
static let inline (<>)
        lhs : ErlTrace *
        rhs : IErlObject  : bool
static let inline (<>)
        lhs : ErlTrace *
        rhs : IErlObject  : bool

Parameters

lhs
Type: NFX.Erlang ErlTrace
rhs
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean
See Also
ErlTrace Class
ErlTrace Members
NFX.Erlang Namespace


ErlTrace Properties

ErlTrace Properties NFX Class Library

The ErlTrace type exposes the following members.
Properties
Name | Description
Protected property | CloseBracket | (Overrides ErlTuple CloseBracket.)
Public property Count
Return number of elements in the container
(Inherited from ErlTupleBase.)
Public property | Flags
Public property | From
Public property IsScalar
Determines whether the underlying type is scalar or complex (i.e. tuple, list)
(Inherited from ErlTupleBase.)
Public property Item
Return index'th element from the container
(Inherited from ErlTupleBase.)
Public property | Label
Protected property | OpenBracket | (Overrides ErlTuple OpenBracket.)
Public property | Prev
Public property | Serial
Public property | TypeOrder | (Overrides ErlTuple TypeOrder.)
Public property Value
Get the list of Erlang terms contained in this object
(Inherited from ErlTupleBase.)
Public property | ValueAsBool | (Inherited from ErlTupleBase.)
Public property | ValueAsByteArray | (Inherited from ErlTupleBase.)
Public property | ValueAsChar | (Inherited from ErlTupleBase.)
Public property ValueAsDateTime
Returns tuple value as DateTime in UTC if the tuple is in the form
View Colorized Copy to Clipboard Print
{MegaSec, Sec, MicroSec}
{MegaSec, Sec, MicroSec}
(Inherited from ErlTuple.)
Public property | ValueAsDecimal | (Inherited from ErlTupleBase.)
Public property | ValueAsDouble | (Inherited from ErlTupleBase.)
Public property | ValueAsInt | (Inherited from ErlTupleBase.)
Public property | ValueAsLong | (Inherited from ErlTupleBase.)
Public property | ValueAsObject | (Inherited from ErlTupleBase.)
Public property | ValueAsString | (Inherited from ErlTupleBase.)
Public property | ValueAsTimeSpan | (Inherited from ErlTupleBase.)
Back to Top
See Also
ErlTrace Class
NFX.Erlang Namespace


ErlTrace.CloseBracket Property

ErlTrace CloseBracket Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override char CloseBracket { get; }
protected override char CloseBracket { get; }
Protected Overrides ReadOnly Property CloseBracket As Char
    Get
Protected Overrides ReadOnly Property CloseBracket As Char
    Get
protected:
virtual property wchar_t CloseBracket {
    wchar_t get () override;
}
protected:
virtual property wchar_t CloseBracket {
    wchar_t get () override;
}
abstract CloseBracket : char with get
override CloseBracket : char with get
abstract CloseBracket : char with get
override CloseBracket : char with get

Property Value

Type: Online Char
See Also
ErlTrace Class
ErlTrace Members
NFX.Erlang Namespace


ErlTrace.Flags Property

ErlTrace Flags Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Flags { get; }
public int Flags { get; }
Public ReadOnly Property Flags As Integer
    Get
Public ReadOnly Property Flags As Integer
    Get
public:
property int Flags {
    int get ();
}
public:
property int Flags {
    int get ();
}
member Flags : int with get
member Flags : int with get

Property Value

Type: Online Int32
See Also
ErlTrace Class
ErlTrace Members
NFX.Erlang Namespace


ErlTrace.From Property

ErlTrace From Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlPid From { get; }
public ErlPid From { get; }
Public ReadOnly Property From As ErlPid
    Get
Public ReadOnly Property From As ErlPid
    Get
public:
property ErlPid From {
    ErlPid get ();
}
public:
property ErlPid From {
    ErlPid get ();
}
member From : ErlPid with get
member From : ErlPid with get

Property Value

Type: ErlPid
See Also
ErlTrace Class
ErlTrace Members
NFX.Erlang Namespace


ErlTrace.Label Property

ErlTrace Label Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Label { get; }
public int Label { get; }
Public ReadOnly Property Label As Integer
    Get
Public ReadOnly Property Label As Integer
    Get
public:
property int Label {
    int get ();
}
public:
property int Label {
    int get ();
}
member Label : int with get
member Label : int with get

Property Value

Type: Online Int32
See Also
ErlTrace Class
ErlTrace Members
NFX.Erlang Namespace


ErlTrace.OpenBracket Property

ErlTrace OpenBracket Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override char OpenBracket { get; }
protected override char OpenBracket { get; }
Protected Overrides ReadOnly Property OpenBracket As Char
    Get
Protected Overrides ReadOnly Property OpenBracket As Char
    Get
protected:
virtual property wchar_t OpenBracket {
    wchar_t get () override;
}
protected:
virtual property wchar_t OpenBracket {
    wchar_t get () override;
}
abstract OpenBracket : char with get
override OpenBracket : char with get
abstract OpenBracket : char with get
override OpenBracket : char with get

Property Value

Type: Online Char
See Also
ErlTrace Class
ErlTrace Members
NFX.Erlang Namespace


ErlTrace.Prev Property

ErlTrace Prev Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Prev { get; }
public int Prev { get; }
Public ReadOnly Property Prev As Integer
    Get
Public ReadOnly Property Prev As Integer
    Get
public:
property int Prev {
    int get ();
}
public:
property int Prev {
    int get ();
}
member Prev : int with get
member Prev : int with get

Property Value

Type: Online Int32
See Also
ErlTrace Class
ErlTrace Members
NFX.Erlang Namespace


ErlTrace.Serial Property

ErlTrace Serial Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Serial { get; }
public int Serial { get; }
Public ReadOnly Property Serial As Integer
    Get
Public ReadOnly Property Serial As Integer
    Get
public:
property int Serial {
    int get ();
}
public:
property int Serial {
    int get ();
}
member Serial : int with get
member Serial : int with get

Property Value

Type: Online Int32
See Also
ErlTrace Class
ErlTrace Members
NFX.Erlang Namespace


ErlTrace.TypeOrder Property

ErlTrace TypeOrder Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ErlTypeOrder TypeOrder { get; }
public override ErlTypeOrder TypeOrder { get; }
Public Overrides ReadOnly Property TypeOrder As ErlTypeOrder
    Get
Public Overrides ReadOnly Property TypeOrder As ErlTypeOrder
    Get
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () override;
}
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () override;
}
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get

Property Value

Type: ErlTypeOrder

Implements

IErlObject TypeOrder
See Also
ErlTrace Class
ErlTrace Members
NFX.Erlang Namespace


ErlTraceLevel Enumeration

ErlTraceLevel Enumeration NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum ErlTraceLevel
public enum ErlTraceLevel
Public Enumeration ErlTraceLevel
Public Enumeration ErlTraceLevel
public enum class ErlTraceLevel
public enum class ErlTraceLevel
type ErlTraceLevel
type ErlTraceLevel
Members
Member name | Value | Description
Off | 0 | Tracing is off
Send | 1 | Trace ordinary send and receive messages
Ctrl | 2 | Trace control messages (e.g. link/unlink)
Handshake | 3 | Trace handshaking at connection startup
Epmd | 4 | Trace Epmd connectivity
Wire | 5 | Trace wire-level message content
See Also
NFX.Erlang Namespace


ErlTransportFactory Class

ErlTransportFactory Class NFX Class Library

Factory of IErlTransport
Inheritance Hierarchy
Online System Object
NFX.Erlang ErlTransportFactory

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class ErlTransportFactory
public static class ErlTransportFactory
Public NotInheritable Class ErlTransportFactory
Public NotInheritable Class ErlTransportFactory
public ref class ErlTransportFactory abstract sealed
public ref class ErlTransportFactory abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ErlTransportFactory =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ErlTransportFactory =  class end
See Also
ErlTransportFactory Members
NFX.Erlang Namespace


ErlTransportFactory Members

ErlTransportFactory Members NFX Class Library

Methods
Name | Description
Create(String, String) |
Create(String, String, String, Int32) |
Back to Top
See Also
ErlTransportFactory Class
NFX.Erlang Namespace


ErlTransportFactory Methods

ErlTransportFactory Methods NFX Class Library

Methods
Name | Description
Create(String, String) |
Create(String, String, String, Int32) |
Back to Top
See Also
ErlTransportFactory Class
NFX.Erlang Namespace


ErlTransportFactory.Create Method

ErlTransportFactory Create Method NFX Class Library

Overload List
Name | Description
Create(String, String) |
Create(String, String, String, Int32) |
Back to Top
See Also
ErlTransportFactory Class
ErlTransportFactory Members
NFX.Erlang Namespace


ErlTransportFactory.Create Method (String, String)

ErlTransportFactory Create Method (String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IErlTransport Create(
    string transportTypeFullName,
    string remoteNodeName
)
public static IErlTransport Create(
    string transportTypeFullName,
    string remoteNodeName
)
Public Shared Function Create (
    transportTypeFullName As String,
    remoteNodeName As String
) As IErlTransport
Public Shared Function Create (
    transportTypeFullName As String,
    remoteNodeName As String
) As IErlTransport
public:
static IErlTransport^ Create(
    String^ transportTypeFullName,
    String^ remoteNodeName
)
public:
static IErlTransport^ Create(
    String^ transportTypeFullName,
    String^ remoteNodeName
)
static member Create :
        transportTypeFullName : string *
        remoteNodeName : string -> IErlTransport
static member Create :
        transportTypeFullName : string *
        remoteNodeName : string -> IErlTransport

Parameters

transportTypeFullName
Type: Online System String
remoteNodeName
Type: Online System String

Return Value

Type: IErlTransport
See Also
ErlTransportFactory Class
ErlTransportFactory Members
Create Overload
NFX.Erlang Namespace


ErlTransportFactory.Create Method (String, String, String, Int32)

ErlTransportFactory Create Method (String, String, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IErlTransport Create(
    string transportTypeFullName,
    string remoteNodeName,
    string host,
    int port
)
public static IErlTransport Create(
    string transportTypeFullName,
    string remoteNodeName,
    string host,
    int port
)
Public Shared Function Create (
    transportTypeFullName As String,
    remoteNodeName As String,
    host As String,
    port As Integer
) As IErlTransport
Public Shared Function Create (
    transportTypeFullName As String,
    remoteNodeName As String,
    host As String,
    port As Integer
) As IErlTransport
public:
static IErlTransport^ Create(
    String^ transportTypeFullName,
    String^ remoteNodeName,
    String^ host,
    int port
)
public:
static IErlTransport^ Create(
    String^ transportTypeFullName,
    String^ remoteNodeName,
    String^ host,
    int port
)
static member Create :
        transportTypeFullName : string *
        remoteNodeName : string *
        host : string *
        port : int -> IErlTransport
static member Create :
        transportTypeFullName : string *
        remoteNodeName : string *
        host : string *
        port : int -> IErlTransport

Parameters

transportTypeFullName
Type: Online System String
remoteNodeName
Type: Online System String
host
Type: Online System String
port
Type: Online System Int32

Return Value

Type: IErlTransport
See Also
ErlTransportFactory Class
ErlTransportFactory Members
Create Overload
NFX.Erlang Namespace


ErlTransportPasswordSource Class

ErlTransportPasswordSource Class NFX Class Library

Source of passwrod for transport (i.e. for SSH connection)
Inheritance Hierarchy
Online System Object
NFX.Erlang ErlTransportPasswordSource

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class ErlTransportPasswordSource
public static class ErlTransportPasswordSource
Public NotInheritable Class ErlTransportPasswordSource
Public NotInheritable Class ErlTransportPasswordSource
public ref class ErlTransportPasswordSource abstract sealed
public ref class ErlTransportPasswordSource abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ErlTransportPasswordSource =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ErlTransportPasswordSource =  class end
Remarks
When IErlTransport requires password, it will call method GetPassword() of this class. The app must to handle event PasswordRequired to return password.
See Also
ErlTransportPasswordSource Members
NFX.Erlang Namespace


ErlTransportPasswordSource Members

ErlTransportPasswordSource Members NFX Class Library

The ErlTransportPasswordSource type exposes the following members.
Methods
Name | Description
FinishPasswordSession | Removes password session from cache
GetPassword | Returns password for specified userName and nodeName
StartPasswordSession | Starts cache session of password
Back to Top
Events
Name | Description
PasswordRequired | Called when SSH(or other secure transport) user password (or private key file passphrase) is required. Handler must to return password for specified userName and nodeName
Back to Top
See Also
ErlTransportPasswordSource Class
NFX.Erlang Namespace


ErlTransportPasswordSource Methods

ErlTransportPasswordSource Methods NFX Class Library

The ErlTransportPasswordSource type exposes the following members.
Methods
Name | Description
FinishPasswordSession | Removes password session from cache
GetPassword | Returns password for specified userName and nodeName
StartPasswordSession | Starts cache session of password
Back to Top
See Also
ErlTransportPasswordSource Class
NFX.Erlang Namespace


ErlTransportPasswordSource.FinishPasswordSession Method

ErlTransportPasswordSource FinishPasswordSession Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Removes password session from cache

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static void FinishPasswordSession(
    ErlPasswordSession ps
)
internal static void FinishPasswordSession(
    ErlPasswordSession ps
)
Friend Shared Sub FinishPasswordSession (
    ps As ErlPasswordSession
)
Friend Shared Sub FinishPasswordSession (
    ps As ErlPasswordSession
)
internal:
static void FinishPasswordSession(
    ErlPasswordSession^ ps
)
internal:
static void FinishPasswordSession(
    ErlPasswordSession^ ps
)
internal static member FinishPasswordSession :
        ps : ErlPasswordSession -> unit
internal static member FinishPasswordSession :
        ps : ErlPasswordSession -> unit

Parameters

ps
Type: NFX.Erlang ErlPasswordSession
See Also
ErlTransportPasswordSource Class
ErlTransportPasswordSource Members
NFX.Erlang Namespace


ErlTransportPasswordSource.GetPassword Method

ErlTransportPasswordSource GetPassword Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns password for specified userName and nodeName

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static SecureString GetPassword(
    Object sender,
    string nodeName,
    string userName
)
public static SecureString GetPassword(
    Object sender,
    string nodeName,
    string userName
)
Public Shared Function GetPassword (
    sender As Object,
    nodeName As String,
    userName As String
) As SecureString
Public Shared Function GetPassword (
    sender As Object,
    nodeName As String,
    userName As String
) As SecureString
public:
static SecureString^ GetPassword(
    Object^ sender,
    String^ nodeName,
    String^ userName
)
public:
static SecureString^ GetPassword(
    Object^ sender,
    String^ nodeName,
    String^ userName
)
static member GetPassword :
        sender : Object *
        nodeName : string *
        userName : string -> SecureString
static member GetPassword :
        sender : Object *
        nodeName : string *
        userName : string -> SecureString

Parameters

sender
Type: Online System Object
nodeName
Type: Online System String
userName
Type: Online System String

Return Value

Type: Online SecureString
See Also
ErlTransportPasswordSource Class
ErlTransportPasswordSource Members
NFX.Erlang Namespace


ErlTransportPasswordSource.StartPasswordSession Method

ErlTransportPasswordSource StartPasswordSession Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Starts cache session of password

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlPasswordSession StartPasswordSession(
    string nodeName,
    string userName
)
public static ErlPasswordSession StartPasswordSession(
    string nodeName,
    string userName
)
Public Shared Function StartPasswordSession (
    nodeName As String,
    userName As String
) As ErlPasswordSession
Public Shared Function StartPasswordSession (
    nodeName As String,
    userName As String
) As ErlPasswordSession
public:
static ErlPasswordSession^ StartPasswordSession(
    String^ nodeName,
    String^ userName
)
public:
static ErlPasswordSession^ StartPasswordSession(
    String^ nodeName,
    String^ userName
)
static member StartPasswordSession :
        nodeName : string *
        userName : string -> ErlPasswordSession
static member StartPasswordSession :
        nodeName : string *
        userName : string -> ErlPasswordSession

Parameters

nodeName
Type: Online System String
userName
Type: Online System String

Return Value

Type: ErlPasswordSession
See Also
ErlTransportPasswordSource Class
ErlTransportPasswordSource Members
NFX.Erlang Namespace


ErlTransportPasswordSource Events

ErlTransportPasswordSource Events NFX Class Library

The ErlTransportPasswordSource type exposes the following members.
Events
Name | Description
PasswordRequired | Called when SSH(or other secure transport) user password (or private key file passphrase) is required. Handler must to return password for specified userName and nodeName
Back to Top
See Also
ErlTransportPasswordSource Class
NFX.Erlang Namespace


ErlTransportPasswordSource.PasswordRequired Event

ErlTransportPasswordSource PasswordRequired Event NFX Class Library

[This is preliminary documentation and is subject to change.]

Called when SSH(or other secure transport) user password (or private key file passphrase) is required. Handler must to return password for specified userName and nodeName

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static event ErlPasswordRequiredEventHandler PasswordRequired
public static event ErlPasswordRequiredEventHandler PasswordRequired
Public Shared Event PasswordRequired As ErlPasswordRequiredEventHandler
Public Shared Event PasswordRequired As ErlPasswordRequiredEventHandler
public:
static  event ErlPasswordRequiredEventHandler^ PasswordRequired {
    void add (ErlPasswordRequiredEventHandler^ value);
    void remove (ErlPasswordRequiredEventHandler^ value);
}
public:
static  event ErlPasswordRequiredEventHandler^ PasswordRequired {
    void add (ErlPasswordRequiredEventHandler^ value);
    void remove (ErlPasswordRequiredEventHandler^ value);
}
member PasswordRequired : IEvent<ErlPasswordRequiredEventHandler,
    EventArgs>
member PasswordRequired : IEvent<ErlPasswordRequiredEventHandler,
    EventArgs>

Value

Type: NFX.Erlang ErlPasswordRequiredEventHandler
See Also
ErlTransportPasswordSource Class
ErlTransportPasswordSource Members
NFX.Erlang Namespace


ErlTuple Class

ErlTuple Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Erlang ErlTupleBase
NFX.Erlang ErlTuple
NFX.Erlang ErlTrace

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ErlTuple : ErlTupleBase
public class ErlTuple : ErlTupleBase
Public Class ErlTuple
    Inherits ErlTupleBase
Public Class ErlTuple
    Inherits ErlTupleBase
public ref class ErlTuple : public ErlTupleBase
public ref class ErlTuple : public ErlTupleBase
type ErlTuple =
    class
        inherit ErlTupleBase
    end
type ErlTuple =
    class
        inherit ErlTupleBase
    end
See Also
ErlTuple Members
NFX.Erlang Namespace


ErlTuple Members

ErlTuple Members NFX Class Library

The ErlTuple type exposes the following members.
Constructors
 | Name | Description
Public method | ErlTuple( Object ) | Initializes a new instance of the ErlTuple class
Public method | ErlTuple(ErlTuple) | Initializes a new instance of the ErlTuple class
Public method | ErlTuple( IErlObject ) | Create an Erlang tuple from the given list of items
Public method | ErlTuple(List IErlObject , Boolean) | Initializes a new instance of the ErlTuple class
Back to Top
Methods
 | Name | Description
Public method | Add | Add an item to a mutable list. This method must be used only during list construction phase, since it treats the list as a mutable entity (Inherited from ErlTupleBase.)
Public method | Cast T | Return index'th element cast to the given type (Inherited from ErlTupleBase.)
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference) (Inherited from ErlTupleBase.)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the atom is less than obj, positive - greater than the obj (Inherited from ErlTupleBase.)
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the atom is less than obj, positive - greater than the obj (Inherited from ErlTupleBase.)
 | Create |
Public method | Equals(Object) | (Overrides ErlTupleBase Equals(Object).)
Public method | Equals(ErlTuple) | Determine if two Erlang tuples are equal
Public method | Equals(IErlObject) | Determine if two Erlang objects are equal (Overrides ErlTupleBase Equals(IErlObject).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides ErlTupleBase GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeInstance | (Overrides ErlTupleBase MakeInstance .)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern (Inherited from ErlTupleBase.)
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding. (Inherited from ErlTupleBase.)
Public method | Matches | Perform pattern match on this Erlang term without binding any variables (Inherited from ErlTupleBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Subst | (Inherited from ErlTupleBase.)
Public method | ToString | Get the string representation of the list. (Inherited from ErlTupleBase.)
Public method | ToString(Boolean) | (Inherited from ErlTupleBase.)
Public method | Visit TAccumulate | Execute fun for every nested term (Inherited from ErlTupleBase.)
Back to Top
Operators
Name | Description
Equality |
(ErlTuple to List IErlObject ) | Implicit conversion of atom to string
Inequality |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Items | The index of this atom in the global atom table (Inherited from ErlTupleBase.)
Back to Top
Properties
Name | Description
Protected property | CloseBracket | (Overrides ErlTupleBase CloseBracket.)
Public property Count
Return number of elements in the container
(Inherited from ErlTupleBase.)
Public property IsScalar
Determines whether the underlying type is scalar or complex (i.e. tuple, list)
(Inherited from ErlTupleBase.)
Public property Item
Return index'th element from the container
(Inherited from ErlTupleBase.)
Protected property | OpenBracket | (Overrides ErlTupleBase OpenBracket.)
Public property | TypeOrder | (Overrides ErlTupleBase TypeOrder.)
Public property Value
Get the list of Erlang terms contained in this object
(Inherited from ErlTupleBase.)
Public property | ValueAsBool | (Inherited from ErlTupleBase.)
Public property | ValueAsByteArray | (Inherited from ErlTupleBase.)
Public property | ValueAsChar | (Inherited from ErlTupleBase.)
Public property ValueAsDateTime
Returns tuple value as DateTime in UTC if the tuple is in the form
View Colorized Copy to Clipboard Print
{MegaSec, Sec, MicroSec}
{MegaSec, Sec, MicroSec}
(Overrides ErlTupleBase ValueAsDateTime.)
Public property | ValueAsDecimal | (Inherited from ErlTupleBase.)
Public property | ValueAsDouble | (Inherited from ErlTupleBase.)
Public property | ValueAsInt | (Inherited from ErlTupleBase.)
Public property | ValueAsLong | (Inherited from ErlTupleBase.)
Public property | ValueAsObject | (Inherited from ErlTupleBase.)
Public property | ValueAsString | (Inherited from ErlTupleBase.)
Public property | ValueAsTimeSpan | (Inherited from ErlTupleBase.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone | (Inherited from ErlTupleBase.)
Explicit interface implemetation | IEnumerable IErlObject GetEnumerator | (Inherited from ErlTupleBase.)
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from ErlTupleBase.)
Back to Top
See Also
ErlTuple Class
NFX.Erlang Namespace


ErlTuple Constructor

ErlTuple Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ErlTuple( Object ) | Initializes a new instance of the ErlTuple class
Public method | ErlTuple(ErlTuple) | Initializes a new instance of the ErlTuple class
Public method | ErlTuple( IErlObject ) | Create an Erlang tuple from the given list of items
Public method | ErlTuple(List IErlObject , Boolean) | Initializes a new instance of the ErlTuple class
Back to Top
See Also
ErlTuple Class
ErlTuple Members
NFX.Erlang Namespace


ErlTuple Constructor (Object[])

ErlTuple Constructor ( Object ) NFX Class Library

Initializes a new instance of the ErlTuple class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTuple(
    params Object[] items
)
public ErlTuple(
    params Object[] items
)
Public Sub New (
    ParamArray items As Object()
)
Public Sub New (
    ParamArray items As Object()
)
public:
ErlTuple(
    ... array<Object^>^ items
)
public:
ErlTuple(
    ... array<Object^>^ items
)
new :
        items : Object[] -> ErlTuple
new :
        items : Object[] -> ErlTuple

Parameters

items
Type: Online System Object
See Also
ErlTuple Class
ErlTuple Members
ErlTuple Overload
NFX.Erlang Namespace


ErlTuple Constructor (ErlTuple)

ErlTuple Constructor (ErlTuple) NFX Class Library

Initializes a new instance of the ErlTuple class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTuple(
    ErlTuple list
)
public ErlTuple(
    ErlTuple list
)
Public Sub New (
    list As ErlTuple
)
Public Sub New (
    list As ErlTuple
)
public:
ErlTuple(
    ErlTuple^ list
)
public:
ErlTuple(
    ErlTuple^ list
)
new :
        list : ErlTuple -> ErlTuple
new :
        list : ErlTuple -> ErlTuple

Parameters

list
Type: NFX.Erlang ErlTuple
See Also
ErlTuple Class
ErlTuple Members
ErlTuple Overload
NFX.Erlang Namespace


ErlTuple Constructor (IErlObject[])

ErlTuple Constructor ( IErlObject ) NFX Class Library

Create an Erlang tuple from the given list of items

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTuple(
    IErlObject[] items
)
public ErlTuple(
    IErlObject[] items
)
Public Sub New (
    items As IErlObject()
)
Public Sub New (
    items As IErlObject()
)
public:
ErlTuple(
    array<IErlObject^>^ items
)
public:
ErlTuple(
    array<IErlObject^>^ items
)
new :
        items : IErlObject[] -> ErlTuple
new :
        items : IErlObject[] -> ErlTuple

Parameters

items
Type: NFX.Erlang IErlObject
See Also
ErlTuple Class
ErlTuple Members
ErlTuple Overload
NFX.Erlang Namespace


ErlTuple Constructor (List(IErlObject), Boolean)

ErlTuple Constructor (List IErlObject , Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlTuple class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTuple(
    List<IErlObject> items,
    bool clone = true
)
public ErlTuple(
    List<IErlObject> items,
    bool clone = true
)
Public Sub New (
    items As List(Of IErlObject),
    Optional clone As Boolean = true
)
Public Sub New (
    items As List(Of IErlObject),
    Optional clone As Boolean = true
)
public:
ErlTuple(
    List<IErlObject^>^ items,
    bool clone = true
)
public:
ErlTuple(
    List<IErlObject^>^ items,
    bool clone = true
)
new :
        items : List<IErlObject> *
        ?clone : bool
(* Defaults:
        let _clone = defaultArg clone true
*)
-> ErlTuple
new :
        items : List<IErlObject> *
        ?clone : bool
(* Defaults:
        let _clone = defaultArg clone true
*)
-> ErlTuple

Parameters

items
Type: Online System.Collections.Generic List IErlObject
clone (Optional)
Type: Online System Boolean
See Also
ErlTuple Class
ErlTuple Members
ErlTuple Overload
NFX.Erlang Namespace


ErlTuple Fields

ErlTuple Fields NFX Class Library

The ErlTuple type exposes the following members.
Fields
 | Name | Description
Protected field | m_Items | The index of this atom in the global atom table (Inherited from ErlTupleBase.)
Back to Top
See Also
ErlTuple Class
NFX.Erlang Namespace


ErlTuple Methods

ErlTuple Methods NFX Class Library

The ErlTuple type exposes the following members.
Methods
 | Name | Description
Public method | Add | Add an item to a mutable list. This method must be used only during list construction phase, since it treats the list as a mutable entity (Inherited from ErlTupleBase.)
Public method | Cast T | Return index'th element cast to the given type (Inherited from ErlTupleBase.)
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference) (Inherited from ErlTupleBase.)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the atom is less than obj, positive - greater than the obj (Inherited from ErlTupleBase.)
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the atom is less than obj, positive - greater than the obj (Inherited from ErlTupleBase.)
 | Create |
Public method | Equals(Object) | (Overrides ErlTupleBase Equals(Object).)
Public method | Equals(ErlTuple) | Determine if two Erlang tuples are equal
Public method | Equals(IErlObject) | Determine if two Erlang objects are equal (Overrides ErlTupleBase Equals(IErlObject).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides ErlTupleBase GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeInstance | (Overrides ErlTupleBase MakeInstance .)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern (Inherited from ErlTupleBase.)
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding. (Inherited from ErlTupleBase.)
Public method | Matches | Perform pattern match on this Erlang term without binding any variables (Inherited from ErlTupleBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Subst | (Inherited from ErlTupleBase.)
Public method | ToString | Get the string representation of the list. (Inherited from ErlTupleBase.)
Public method | ToString(Boolean) | (Inherited from ErlTupleBase.)
Public method | Visit TAccumulate | Execute fun for every nested term (Inherited from ErlTupleBase.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone | (Inherited from ErlTupleBase.)
Explicit interface implemetation | IEnumerable IErlObject GetEnumerator | (Inherited from ErlTupleBase.)
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from ErlTupleBase.)
Back to Top
See Also
ErlTuple Class
NFX.Erlang Namespace


ErlTuple.Create Method

ErlTuple Create Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ErlTuple Create(
    params Object[] items
)
public static ErlTuple Create(
    params Object[] items
)
Public Shared Function Create (
    ParamArray items As Object()
) As ErlTuple
Public Shared Function Create (
    ParamArray items As Object()
) As ErlTuple
public:
static ErlTuple^ Create(
    ... array<Object^>^ items
)
public:
static ErlTuple^ Create(
    ... array<Object^>^ items
)
static member Create :
        items : Object[] -> ErlTuple
static member Create :
        items : Object[] -> ErlTuple

Parameters

items
Type: Online System Object

Return Value

Type: ErlTuple
See Also
ErlTuple Class
ErlTuple Members
NFX.Erlang Namespace


ErlTuple.Equals Method

ErlTuple Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ErlTupleBase Equals(Object).)
Public method | Equals(ErlTuple) | Determine if two Erlang tuples are equal
Public method | Equals(IErlObject) | Determine if two Erlang objects are equal (Overrides ErlTupleBase Equals(IErlObject).)
Back to Top
See Also
ErlTuple Class
ErlTuple Members
NFX.Erlang Namespace


ErlTuple.Equals Method (Object)

ErlTuple Equals Method (Object) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals (
    o As Object
) As Boolean
Public Overrides Function Equals (
    o As Object
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool

Parameters

o
Type: Online System Object

Return Value

Type: Online Boolean
See Also
ErlTuple Class
ErlTuple Members
Equals Overload
NFX.Erlang Namespace


ErlTuple.Equals Method (ErlTuple)

ErlTuple Equals Method (ErlTuple) NFX Class Library

Determine if two Erlang tuples are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    ErlTuple o
)
public bool Equals(
    ErlTuple o
)
Public Function Equals (
    o As ErlTuple
) As Boolean
Public Function Equals (
    o As ErlTuple
) As Boolean
public:
bool Equals(
    ErlTuple^ o
)
public:
bool Equals(
    ErlTuple^ o
)
member Equals :
        o : ErlTuple -> bool
member Equals :
        o : ErlTuple -> bool

Parameters

o
Type: NFX.Erlang ErlTuple

Return Value

Type: Online Boolean
See Also
ErlTuple Class
ErlTuple Members
Equals Overload
NFX.Erlang Namespace


ErlTuple.Equals Method (IErlObject)

ErlTuple Equals Method (IErlObject) NFX Class Library

Determine if two Erlang objects are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    IErlObject o
)
public override bool Equals(
    IErlObject o
)
Public Overrides Function Equals (
    o As IErlObject
) As Boolean
Public Overrides Function Equals (
    o As IErlObject
) As Boolean
public:
virtual bool Equals(
    IErlObject^ o
) override
public:
virtual bool Equals(
    IErlObject^ o
) override
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool

Parameters

o
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
ErlTuple Class
ErlTuple Members
Equals Overload
NFX.Erlang Namespace


ErlTuple.GetHashCode Method

ErlTuple GetHashCode Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
ErlTuple Class
ErlTuple Members
NFX.Erlang Namespace


ErlTuple.MakeInstance Method

ErlTuple MakeInstance Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override ErlTupleBase MakeInstance()
protected override ErlTupleBase MakeInstance()
Protected Overrides Function MakeInstance As ErlTupleBase
Protected Overrides Function MakeInstance As ErlTupleBase
protected:
virtual ErlTupleBase^ MakeInstance() override
protected:
virtual ErlTupleBase^ MakeInstance() override
abstract MakeInstance : unit -> ErlTupleBase
override MakeInstance : unit -> ErlTupleBase
abstract MakeInstance : unit -> ErlTupleBase
override MakeInstance : unit -> ErlTupleBase

Return Value

Type: ErlTupleBase
See Also
ErlTuple Class
ErlTuple Members
NFX.Erlang Namespace


ErlTuple Operators and Type Conversions

ErlTuple Operators and Type Conversions NFX Class Library

The ErlTuple type exposes the following members.
Operators
Name | Description
Equality |
(ErlTuple to List IErlObject ) | Implicit conversion of atom to string
Inequality |
Back to Top
See Also
ErlTuple Class
NFX.Erlang Namespace


ErlTuple.Equality Operator

ErlTuple Equality Operator NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    ErlTuple lhs,
    IErlObject rhs
)
public static bool operator ==(
    ErlTuple lhs,
    IErlObject rhs
)
Public Shared Operator = (
    lhs As ErlTuple,
    rhs As IErlObject
) As Boolean
Public Shared Operator = (
    lhs As ErlTuple,
    rhs As IErlObject
) As Boolean
public:
static bool operator ==(
    ErlTuple^ lhs,
    IErlObject^ rhs
)
public:
static bool operator ==(
    ErlTuple^ lhs,
    IErlObject^ rhs
)
static let inline (=)
        lhs : ErlTuple *
        rhs : IErlObject  : bool
static let inline (=)
        lhs : ErlTuple *
        rhs : IErlObject  : bool

Parameters

lhs
Type: NFX.Erlang ErlTuple
rhs
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean
See Also
ErlTuple Class
ErlTuple Members
NFX.Erlang Namespace


ErlTuple Implicit Conversion (ErlTuple to List(IErlObject))

ErlTuple Conversion (ErlTuple to List IErlObject ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Implicit conversion of atom to string

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static implicit operator List<IErlObject> (
    ErlTuple a
)
public static implicit operator List<IErlObject> (
    ErlTuple a
)
Public Shared Widening Operator CType (
    a As ErlTuple
) As List(Of IErlObject)
Public Shared Widening Operator CType (
    a As ErlTuple
) As List(Of IErlObject)
static implicit operator List<IErlObject^>^ (
    ErlTuple^ a
)
static implicit operator List<IErlObject^>^ (
    ErlTuple^ a
)
F# does not support the declaration of new casting operators.
F# does not support the declaration of new casting operators.

Parameters

a
Type: NFX.Erlang ErlTuple

Return Value

Type: Online List IErlObject
See Also
ErlTuple Class
ErlTuple Members
NFX.Erlang Namespace


ErlTuple.Inequality Operator

ErlTuple Inequality Operator NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    ErlTuple lhs,
    IErlObject rhs
)
public static bool operator !=(
    ErlTuple lhs,
    IErlObject rhs
)
Public Shared Operator <> (
    lhs As ErlTuple,
    rhs As IErlObject
) As Boolean
Public Shared Operator <> (
    lhs As ErlTuple,
    rhs As IErlObject
) As Boolean
public:
static bool operator !=(
    ErlTuple^ lhs,
    IErlObject^ rhs
)
public:
static bool operator !=(
    ErlTuple^ lhs,
    IErlObject^ rhs
)
static let inline (<>)
        lhs : ErlTuple *
        rhs : IErlObject  : bool
static let inline (<>)
        lhs : ErlTuple *
        rhs : IErlObject  : bool

Parameters

lhs
Type: NFX.Erlang ErlTuple
rhs
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean
See Also
ErlTuple Class
ErlTuple Members
NFX.Erlang Namespace


ErlTuple Properties

ErlTuple Properties NFX Class Library

The ErlTuple type exposes the following members.
Properties
Name | Description
Protected property | CloseBracket | (Overrides ErlTupleBase CloseBracket.)
Public property Count
Return number of elements in the container
(Inherited from ErlTupleBase.)
Public property IsScalar
Determines whether the underlying type is scalar or complex (i.e. tuple, list)
(Inherited from ErlTupleBase.)
Public property Item
Return index'th element from the container
(Inherited from ErlTupleBase.)
Protected property | OpenBracket | (Overrides ErlTupleBase OpenBracket.)
Public property | TypeOrder | (Overrides ErlTupleBase TypeOrder.)
Public property Value
Get the list of Erlang terms contained in this object
(Inherited from ErlTupleBase.)
Public property | ValueAsBool | (Inherited from ErlTupleBase.)
Public property | ValueAsByteArray | (Inherited from ErlTupleBase.)
Public property | ValueAsChar | (Inherited from ErlTupleBase.)
Public property ValueAsDateTime
Returns tuple value as DateTime in UTC if the tuple is in the form
View Colorized Copy to Clipboard Print
{MegaSec, Sec, MicroSec}
{MegaSec, Sec, MicroSec}
(Overrides ErlTupleBase ValueAsDateTime.)
Public property | ValueAsDecimal | (Inherited from ErlTupleBase.)
Public property | ValueAsDouble | (Inherited from ErlTupleBase.)
Public property | ValueAsInt | (Inherited from ErlTupleBase.)
Public property | ValueAsLong | (Inherited from ErlTupleBase.)
Public property | ValueAsObject | (Inherited from ErlTupleBase.)
Public property | ValueAsString | (Inherited from ErlTupleBase.)
Public property | ValueAsTimeSpan | (Inherited from ErlTupleBase.)
Back to Top
See Also
ErlTuple Class
NFX.Erlang Namespace


ErlTuple.CloseBracket Property

ErlTuple CloseBracket Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override char CloseBracket { get; }
protected override char CloseBracket { get; }
Protected Overrides ReadOnly Property CloseBracket As Char
    Get
Protected Overrides ReadOnly Property CloseBracket As Char
    Get
protected:
virtual property wchar_t CloseBracket {
    wchar_t get () override;
}
protected:
virtual property wchar_t CloseBracket {
    wchar_t get () override;
}
abstract CloseBracket : char with get
override CloseBracket : char with get
abstract CloseBracket : char with get
override CloseBracket : char with get

Property Value

Type: Online Char
See Also
ErlTuple Class
ErlTuple Members
NFX.Erlang Namespace


ErlTuple.OpenBracket Property

ErlTuple OpenBracket Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override char OpenBracket { get; }
protected override char OpenBracket { get; }
Protected Overrides ReadOnly Property OpenBracket As Char
    Get
Protected Overrides ReadOnly Property OpenBracket As Char
    Get
protected:
virtual property wchar_t OpenBracket {
    wchar_t get () override;
}
protected:
virtual property wchar_t OpenBracket {
    wchar_t get () override;
}
abstract OpenBracket : char with get
override OpenBracket : char with get
abstract OpenBracket : char with get
override OpenBracket : char with get

Property Value

Type: Online Char
See Also
ErlTuple Class
ErlTuple Members
NFX.Erlang Namespace


ErlTuple.TypeOrder Property

ErlTuple TypeOrder Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ErlTypeOrder TypeOrder { get; }
public override ErlTypeOrder TypeOrder { get; }
Public Overrides ReadOnly Property TypeOrder As ErlTypeOrder
    Get
Public Overrides ReadOnly Property TypeOrder As ErlTypeOrder
    Get
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () override;
}
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () override;
}
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get

Property Value

Type: ErlTypeOrder

Implements

IErlObject TypeOrder
See Also
ErlTuple Class
ErlTuple Members
NFX.Erlang Namespace


ErlTuple.ValueAsDateTime Property

ErlTuple ValueAsDateTime Property NFX Class Library

Returns tuple value as DateTime in UTC if the tuple is in the form
View Colorized Copy to Clipboard Print
{MegaSec, Sec, MicroSec}
{MegaSec, Sec, MicroSec}

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override DateTime ValueAsDateTime { get; }
public override DateTime ValueAsDateTime { get; }
Public Overrides ReadOnly Property ValueAsDateTime As DateTime
    Get
Public Overrides ReadOnly Property ValueAsDateTime As DateTime
    Get
public:
virtual property DateTime ValueAsDateTime {
    DateTime get () override;
}
public:
virtual property DateTime ValueAsDateTime {
    DateTime get () override;
}
abstract ValueAsDateTime : DateTime with get
override ValueAsDateTime : DateTime with get
abstract ValueAsDateTime : DateTime with get
override ValueAsDateTime : DateTime with get

Property Value

Type: Online DateTime

Implements

IErlObject ValueAsDateTime
See Also
ErlTuple Class
ErlTuple Members
NFX.Erlang Namespace


ErlTupleBase Class

ErlTupleBase Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Erlang ErlTupleBase
NFX.Erlang ErlList
NFX.Erlang ErlTuple

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class ErlTupleBase : IErlObject<List<IErlObject>>,
    IErlObject, IComparable, IComparable<IErlObject>, IEquatable<IErlObject>,
    ICloneable, IEnumerable<IErlObject>, IEnumerable
public abstract class ErlTupleBase : IErlObject<List<IErlObject>>,
    IErlObject, IComparable, IComparable<IErlObject>, IEquatable<IErlObject>,
    ICloneable, IEnumerable<IErlObject>, IEnumerable
Public MustInherit Class ErlTupleBase
    Implements IErlObject(Of List(Of IErlObject)),
    IErlObject, IComparable, IComparable(Of IErlObject), IEquatable(Of IErlObject),
    ICloneable, IEnumerable(Of IErlObject), IEnumerable
Public MustInherit Class ErlTupleBase
    Implements IErlObject(Of List(Of IErlObject)),
    IErlObject, IComparable, IComparable(Of IErlObject), IEquatable(Of IErlObject),
    ICloneable, IEnumerable(Of IErlObject), IEnumerable
public ref class ErlTupleBase abstract : IErlObject<List<IErlObject^>^>,
    IErlObject, IComparable, IComparable<IErlObject^>, IEquatable<IErlObject^>,
    ICloneable, IEnumerable<IErlObject^>, IEnumerable
public ref class ErlTupleBase abstract : IErlObject<List<IErlObject^>^>,
    IErlObject, IComparable, IComparable<IErlObject^>, IEquatable<IErlObject^>,
    ICloneable, IEnumerable<IErlObject^>, IEnumerable
[<AbstractClassAttribute>]
type ErlTupleBase =
    class
        interface IErlObject<List<IErlObject>>
        interface IErlObject
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
        interface IEnumerable<IErlObject>
        interface IEnumerable
    end
[<AbstractClassAttribute>]
type ErlTupleBase =
    class
        interface IErlObject<List<IErlObject>>
        interface IErlObject
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
        interface IEnumerable<IErlObject>
        interface IEnumerable
    end
See Also
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase Members

ErlTupleBase Members NFX Class Library

The ErlTupleBase type exposes the following members.
Constructors
 | Name | Description
Protected method | ErlTupleBase | Initializes a new instance of the ErlTupleBase class
Public method | ErlTupleBase( Object ) | Initializes a new instance of the ErlTupleBase class
Public method | ErlTupleBase(ErlTupleBase) | Initializes a new instance of the ErlTupleBase class
Public method | ErlTupleBase( IErlObject , Boolean) | Create an Erlang string from the given string
Public method | ErlTupleBase(List IErlObject , Boolean) | Initializes a new instance of the ErlTupleBase class
Back to Top
Methods
 | Name | Description
Public method | Add | Add an item to a mutable list. This method must be used only during list construction phase, since it treats the list as a mutable entity
Public method | Cast T | Return index'th element cast to the given type
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the atom is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the atom is less than obj, positive - greater than the obj
Public method | Equals(Object) | Determine if this instance is equal to the object (Overrides Online Object Equals(Object).)
Public method | Equals(IErlObject) | Determine if two Erlang objects are equal
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Get internal hash code (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeInstance |
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Public method | Matches | Perform pattern match on this Erlang term without binding any variables
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Subst |
Public method | ToString | Get the string representation of the list. (Overrides Online Object ToString .)
Public method | ToString(Boolean) |
Public method | Visit TAccumulate | Execute fun for every nested term
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable IErlObject | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct IErlObject, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax IErlObject, TComparand (Func IErlObject, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax IErlObject, TComparand (Func IErlObject, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin IErlObject, TComparand (Func IErlObject, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin IErlObject, TComparand (Func IErlObject, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault IErlObject | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach IErlObject (Action IErlObject ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach IErlObject (Action IErlObject, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | SkipLast IErlObject | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast IErlObject (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Items | The index of this atom in the global atom table
Back to Top
Properties
 | Name | Description
Protected property | CloseBracket |
Public property | Count | Return number of elements in the container
Public property | IsScalar | Determines whether the underlying type is scalar or complex (i.e. tuple, list)
Public property | Item | Return index'th element from the container
Protected property | OpenBracket |
Public property | TypeOrder |
Public property | Value | Get the list of Erlang terms contained in this object
Public property | ValueAsBool |
Public property | ValueAsByteArray |
Public property | ValueAsChar |
Public property | ValueAsDateTime |
Public property | ValueAsDecimal |
Public property | ValueAsDouble |
Public property | ValueAsInt |
Public property | ValueAsLong |
Public property | ValueAsObject |
Public property | ValueAsString |
Public property | ValueAsTimeSpan |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone |
Explicit interface implemetation | IEnumerable IErlObject GetEnumerator |
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
ErlTupleBase Class
NFX.Erlang Namespace


ErlTupleBase Constructor

ErlTupleBase Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | ErlTupleBase | Initializes a new instance of the ErlTupleBase class
Public method | ErlTupleBase( Object ) | Initializes a new instance of the ErlTupleBase class
Public method | ErlTupleBase(ErlTupleBase) | Initializes a new instance of the ErlTupleBase class
Public method | ErlTupleBase( IErlObject , Boolean) | Create an Erlang string from the given string
Public method | ErlTupleBase(List IErlObject , Boolean) | Initializes a new instance of the ErlTupleBase class
Back to Top
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase Constructor

ErlTupleBase Constructor NFX Class Library

Initializes a new instance of the ErlTupleBase class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ErlTupleBase()
protected ErlTupleBase()
Protected Sub New
Protected Sub New
protected:
ErlTupleBase()
protected:
ErlTupleBase()
new : unit -> ErlTupleBase
new : unit -> ErlTupleBase
See Also
ErlTupleBase Class
ErlTupleBase Members
ErlTupleBase Overload
NFX.Erlang Namespace


ErlTupleBase Constructor (Object[])

ErlTupleBase Constructor ( Object ) NFX Class Library

Initializes a new instance of the ErlTupleBase class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTupleBase(
    params Object[] items
)
public ErlTupleBase(
    params Object[] items
)
Public Sub New (
    ParamArray items As Object()
)
Public Sub New (
    ParamArray items As Object()
)
public:
ErlTupleBase(
    ... array<Object^>^ items
)
public:
ErlTupleBase(
    ... array<Object^>^ items
)
new :
        items : Object[] -> ErlTupleBase
new :
        items : Object[] -> ErlTupleBase

Parameters

items
Type: Online System Object
See Also
ErlTupleBase Class
ErlTupleBase Members
ErlTupleBase Overload
NFX.Erlang Namespace


ErlTupleBase Constructor (ErlTupleBase)

ErlTupleBase Constructor (ErlTupleBase) NFX Class Library

Initializes a new instance of the ErlTupleBase class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTupleBase(
    ErlTupleBase term
)
public ErlTupleBase(
    ErlTupleBase term
)
Public Sub New (
    term As ErlTupleBase
)
Public Sub New (
    term As ErlTupleBase
)
public:
ErlTupleBase(
    ErlTupleBase^ term
)
public:
ErlTupleBase(
    ErlTupleBase^ term
)
new :
        term : ErlTupleBase -> ErlTupleBase
new :
        term : ErlTupleBase -> ErlTupleBase

Parameters

term
Type: NFX.Erlang ErlTupleBase
See Also
ErlTupleBase Class
ErlTupleBase Members
ErlTupleBase Overload
NFX.Erlang Namespace


ErlTupleBase Constructor (IErlObject[], Boolean)

ErlTupleBase Constructor ( IErlObject , Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Create an Erlang string from the given string

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTupleBase(
    IErlObject[] items,
    bool clone = true
)
public ErlTupleBase(
    IErlObject[] items,
    bool clone = true
)
Public Sub New (
    items As IErlObject(),
    Optional clone As Boolean = true
)
Public Sub New (
    items As IErlObject(),
    Optional clone As Boolean = true
)
public:
ErlTupleBase(
    array<IErlObject^>^ items,
    bool clone = true
)
public:
ErlTupleBase(
    array<IErlObject^>^ items,
    bool clone = true
)
new :
        items : IErlObject[] *
        ?clone : bool
(* Defaults:
        let _clone = defaultArg clone true
*)
-> ErlTupleBase
new :
        items : IErlObject[] *
        ?clone : bool
(* Defaults:
        let _clone = defaultArg clone true
*)
-> ErlTupleBase

Parameters

items
Type: NFX.Erlang IErlObject
clone (Optional)
Type: Online System Boolean
See Also
ErlTupleBase Class
ErlTupleBase Members
ErlTupleBase Overload
NFX.Erlang Namespace


ErlTupleBase Constructor (List(IErlObject), Boolean)

ErlTupleBase Constructor (List IErlObject , Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErlTupleBase class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTupleBase(
    List<IErlObject> items,
    bool clone = true
)
public ErlTupleBase(
    List<IErlObject> items,
    bool clone = true
)
Public Sub New (
    items As List(Of IErlObject),
    Optional clone As Boolean = true
)
Public Sub New (
    items As List(Of IErlObject),
    Optional clone As Boolean = true
)
public:
ErlTupleBase(
    List<IErlObject^>^ items,
    bool clone = true
)
public:
ErlTupleBase(
    List<IErlObject^>^ items,
    bool clone = true
)
new :
        items : List<IErlObject> *
        ?clone : bool
(* Defaults:
        let _clone = defaultArg clone true
*)
-> ErlTupleBase
new :
        items : List<IErlObject> *
        ?clone : bool
(* Defaults:
        let _clone = defaultArg clone true
*)
-> ErlTupleBase

Parameters

items
Type: Online System.Collections.Generic List IErlObject
clone (Optional)
Type: Online System Boolean
See Also
ErlTupleBase Class
ErlTupleBase Members
ErlTupleBase Overload
NFX.Erlang Namespace


ErlTupleBase Fields

ErlTupleBase Fields NFX Class Library

The ErlTupleBase type exposes the following members.
Fields
 | Name | Description
Protected field | m_Items | The index of this atom in the global atom table
Back to Top
See Also
ErlTupleBase Class
NFX.Erlang Namespace


ErlTupleBase.m_Items Field

ErlTupleBase m_Items Field NFX Class Library

The index of this atom in the global atom table

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected List<IErlObject> m_Items
protected List<IErlObject> m_Items
Protected m_Items As List(Of IErlObject)
Protected m_Items As List(Of IErlObject)
protected:
List<IErlObject^>^ m_Items
protected:
List<IErlObject^>^ m_Items
val mutable m_Items: List<IErlObject>
val mutable m_Items: List<IErlObject>

Field Value

Type: Online List IErlObject
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase Methods

ErlTupleBase Methods NFX Class Library

The ErlTupleBase type exposes the following members.
Methods
 | Name | Description
Public method | Add | Add an item to a mutable list. This method must be used only during list construction phase, since it treats the list as a mutable entity
Public method | Cast T | Return index'th element cast to the given type
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the atom is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the atom is less than obj, positive - greater than the obj
Public method | Equals(Object) | Determine if this instance is equal to the object (Overrides Online Object Equals(Object).)
Public method | Equals(IErlObject) | Determine if two Erlang objects are equal
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Get internal hash code (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeInstance |
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Public method | Matches | Perform pattern match on this Erlang term without binding any variables
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Subst |
Public method | ToString | Get the string representation of the list. (Overrides Online Object ToString .)
Public method | ToString(Boolean) |
Public method | Visit TAccumulate | Execute fun for every nested term
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable IErlObject | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct IErlObject, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax IErlObject, TComparand (Func IErlObject, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax IErlObject, TComparand (Func IErlObject, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin IErlObject, TComparand (Func IErlObject, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin IErlObject, TComparand (Func IErlObject, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault IErlObject | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach IErlObject (Action IErlObject ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach IErlObject (Action IErlObject, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | SkipLast IErlObject | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast IErlObject (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone |
Explicit interface implemetation | IEnumerable IErlObject GetEnumerator |
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
ErlTupleBase Class
NFX.Erlang Namespace


ErlTupleBase.ICloneable.Clone Method

ErlTupleBase ICloneable Clone Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object ICloneable.Clone()
Object ICloneable.Clone()
Private Function Clone As Object Implements ICloneable.Clone
Private Function Clone As Object Implements ICloneable.Clone
private:
virtual Object^ Clone() sealed = ICloneable::Clone
private:
virtual Object^ Clone() sealed = ICloneable::Clone
private abstract Clone : unit -> Object
private override Clone : unit -> Object
private abstract Clone : unit -> Object
private override Clone : unit -> Object

Return Value

Type: Online Object

Implements

Online ICloneable Clone
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.IEnumerable(IErlObject).GetEnumerator Method

ErlTupleBase IEnumerable IErlObject GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator<IErlObject> IEnumerable<IErlObject>.GetEnumerator()
IEnumerator<IErlObject> IEnumerable<IErlObject>.GetEnumerator()
Private Function GetEnumerator As IEnumerator(Of IErlObject)
    Implements IEnumerable(Of IErlObject).GetEnumerator
Private Function GetEnumerator As IEnumerator(Of IErlObject)
    Implements IEnumerable(Of IErlObject).GetEnumerator
private:
virtual IEnumerator<IErlObject^>^ GetEnumerator() sealed = IEnumerable<IErlObject^>::GetEnumerator
private:
virtual IEnumerator<IErlObject^>^ GetEnumerator() sealed = IEnumerable<IErlObject^>::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator<IErlObject>
private override GetEnumerator : unit -> IEnumerator<IErlObject>
private abstract GetEnumerator : unit -> IEnumerator<IErlObject>
private override GetEnumerator : unit -> IEnumerator<IErlObject>

Return Value

Type: Online IEnumerator IErlObject

Implements

Online IEnumerable T GetEnumerator
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.IEnumerable.GetEnumerator Method

ErlTupleBase IEnumerable GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.Add Method

ErlTupleBase Add Method NFX Class Library

Add an item to a mutable list. This method must be used only during list construction phase, since it treats the list as a mutable entity

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    IErlObject term
)
public void Add(
    IErlObject term
)
Public Sub Add (
    term As IErlObject
)
Public Sub Add (
    term As IErlObject
)
public:
void Add(
    IErlObject^ term
)
public:
void Add(
    IErlObject^ term
)
member Add :
        term : IErlObject -> unit
member Add :
        term : IErlObject -> unit

Parameters

term
Type: NFX.Erlang IErlObject
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.Cast(T) Method

ErlTupleBase Cast T Method NFX Class Library

Return index'th element cast to the given type

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T Cast<T>(
    int index
)
public T Cast<T>(
    int index
)
Public Function Cast(Of T) (
    index As Integer
) As T
Public Function Cast(Of T) (
    index As Integer
) As T
public:
generic<typename T>
T Cast(
    int index
)
public:
generic<typename T>
T Cast(
    int index
)
member Cast :
        index : int -> 'T
member Cast :
        index : int -> 'T

Parameters

index
Type: Online System Int32
Type Parameters
T

Return Value

Type: T
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.Clone Method

ErlTupleBase Clone Method NFX Class Library

Clone an instance of the object (non-scalar immutable objects are copied by reference)

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject Clone()
public IErlObject Clone()
Public Function Clone As IErlObject
Public Function Clone As IErlObject
public:
virtual IErlObject^ Clone() sealed
public:
virtual IErlObject^ Clone() sealed
abstract Clone : unit -> IErlObject
override Clone : unit -> IErlObject
abstract Clone : unit -> IErlObject
override Clone : unit -> IErlObject

Return Value

Type: IErlObject

Implements

IErlObject Clone
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.CompareTo Method

ErlTupleBase CompareTo Method NFX Class Library

Overload List
 | Name | Description
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the atom is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the atom is less than obj, positive - greater than the obj
Back to Top
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.CompareTo Method (Object)

ErlTupleBase CompareTo Method (Object) NFX Class Library

Compare this instance to the object. Negative value means that the atom is less than obj, positive - greater than the obj

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    Object obj
)
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
Public Function CompareTo (
    obj As Object
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
public:
virtual int CompareTo(
    Object^ obj
) sealed
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int

Parameters

obj
Type: Online System Object

Return Value

Type: Online Int32

Implements

Online IComparable CompareTo(Object)
See Also
ErlTupleBase Class
ErlTupleBase Members
CompareTo Overload
NFX.Erlang Namespace


ErlTupleBase.CompareTo Method (IErlObject)

ErlTupleBase CompareTo Method (IErlObject) NFX Class Library

Compare this instance to the IErlObject. Negative value means that the atom is less than obj, positive - greater than the obj

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    IErlObject obj
)
public int CompareTo(
    IErlObject obj
)
Public Function CompareTo (
    obj As IErlObject
) As Integer
Public Function CompareTo (
    obj As IErlObject
) As Integer
public:
virtual int CompareTo(
    IErlObject^ obj
) sealed
public:
virtual int CompareTo(
    IErlObject^ obj
) sealed
abstract CompareTo :
        obj : IErlObject -> int
override CompareTo :
        obj : IErlObject -> int
abstract CompareTo :
        obj : IErlObject -> int
override CompareTo :
        obj : IErlObject -> int

Parameters

obj
Type: NFX.Erlang IErlObject

Return Value

Type: Online Int32

Implements

Online IComparable T CompareTo(T)
See Also
ErlTupleBase Class
ErlTupleBase Members
CompareTo Overload
NFX.Erlang Namespace


ErlTupleBase.Equals Method

ErlTupleBase Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | Determine if this instance is equal to the object (Overrides Online Object Equals(Object).)
Public method | Equals(IErlObject) | Determine if two Erlang objects are equal
Back to Top
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.Equals Method (Object)

ErlTupleBase Equals Method (Object) NFX Class Library

Determine if this instance is equal to the object

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals (
    o As Object
) As Boolean
Public Overrides Function Equals (
    o As Object
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool

Parameters

o
Type: Online System Object

Return Value

Type: Online Boolean
See Also
ErlTupleBase Class
ErlTupleBase Members
Equals Overload
NFX.Erlang Namespace


ErlTupleBase.Equals Method (IErlObject)

ErlTupleBase Equals Method (IErlObject) NFX Class Library

Determine if two Erlang objects are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool Equals(
    IErlObject o
)
public abstract bool Equals(
    IErlObject o
)
Public MustOverride Function Equals (
    o As IErlObject
) As Boolean
Public MustOverride Function Equals (
    o As IErlObject
) As Boolean
public:
virtual bool Equals(
    IErlObject^ o
) abstract
public:
virtual bool Equals(
    IErlObject^ o
) abstract
abstract Equals :
        o : IErlObject -> bool
abstract Equals :
        o : IErlObject -> bool

Parameters

o
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
ErlTupleBase Class
ErlTupleBase Members
Equals Overload
NFX.Erlang Namespace


ErlTupleBase.GetHashCode Method

ErlTupleBase GetHashCode Method NFX Class Library

Get internal hash code

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.MakeInstance Method

ErlTupleBase MakeInstance Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract ErlTupleBase MakeInstance()
protected abstract ErlTupleBase MakeInstance()
Protected MustOverride Function MakeInstance As ErlTupleBase
Protected MustOverride Function MakeInstance As ErlTupleBase
protected:
virtual ErlTupleBase^ MakeInstance() abstract
protected:
virtual ErlTupleBase^ MakeInstance() abstract
abstract MakeInstance : unit -> ErlTupleBase
abstract MakeInstance : unit -> ErlTupleBase

Return Value

Type: ErlTupleBase
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.Match Method

ErlTupleBase Match Method NFX Class Library

Overload List
 | Name | Description
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Back to Top
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.Match Method (IErlObject)

ErlTupleBase Match Method (IErlObject) NFX Class Library

Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlVarBind Match(
    IErlObject pattern
)
public ErlVarBind Match(
    IErlObject pattern
)
Public Function Match (
    pattern As IErlObject
) As ErlVarBind
Public Function Match (
    pattern As IErlObject
) As ErlVarBind
public:
virtual ErlVarBind^ Match(
    IErlObject^ pattern
) sealed
public:
virtual ErlVarBind^ Match(
    IErlObject^ pattern
) sealed
abstract Match :
        pattern : IErlObject -> ErlVarBind
override Match :
        pattern : IErlObject -> ErlVarBind
abstract Match :
        pattern : IErlObject -> ErlVarBind
override Match :
        pattern : IErlObject -> ErlVarBind

Parameters

pattern
Type: NFX.Erlang IErlObject

Return Value

Type: ErlVarBind

Implements

IErlObject Match(IErlObject)
See Also
ErlTupleBase Class
ErlTupleBase Members
Match Overload
NFX.Erlang Namespace


ErlTupleBase.Match Method (IErlObject, ErlVarBind)

ErlTupleBase Match Method (IErlObject, ErlVarBind) NFX Class Library

[This is preliminary documentation and is subject to change.]

Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Match(
    IErlObject pattern,
    ErlVarBind binding
)
public bool Match(
    IErlObject pattern,
    ErlVarBind binding
)
Public Function Match (
    pattern As IErlObject,
    binding As ErlVarBind
) As Boolean
Public Function Match (
    pattern As IErlObject,
    binding As ErlVarBind
) As Boolean
public:
virtual bool Match(
    IErlObject^ pattern,
    ErlVarBind^ binding
) sealed
public:
virtual bool Match(
    IErlObject^ pattern,
    ErlVarBind^ binding
) sealed
abstract Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
override Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
abstract Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
override Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool

Parameters

pattern
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind

Return Value

Type: Online Boolean

Implements

IErlObject Match(IErlObject, ErlVarBind)
See Also
ErlTupleBase Class
ErlTupleBase Members
Match Overload
NFX.Erlang Namespace


ErlTupleBase.Matches Method

ErlTupleBase Matches Method NFX Class Library

Perform pattern match on this Erlang term without binding any variables

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Matches(
    IErlObject pattern
)
public bool Matches(
    IErlObject pattern
)
Public Function Matches (
    pattern As IErlObject
) As Boolean
Public Function Matches (
    pattern As IErlObject
) As Boolean
public:
virtual bool Matches(
    IErlObject^ pattern
) sealed
public:
virtual bool Matches(
    IErlObject^ pattern
) sealed
abstract Matches :
        pattern : IErlObject -> bool
override Matches :
        pattern : IErlObject -> bool
abstract Matches :
        pattern : IErlObject -> bool
override Matches :
        pattern : IErlObject -> bool

Parameters

pattern
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Implements

IErlObject Matches(IErlObject)
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.Subst Method

ErlTupleBase Subst Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Subst(
    ref IErlObject term,
    ErlVarBind binding
)
public bool Subst(
    ref IErlObject term,
    ErlVarBind binding
)
Public Function Subst (
    ByRef term As IErlObject,
    binding As ErlVarBind
) As Boolean
Public Function Subst (
    ByRef term As IErlObject,
    binding As ErlVarBind
) As Boolean
public:
virtual bool Subst(
    IErlObject^% term,
    ErlVarBind^ binding
) sealed
public:
virtual bool Subst(
    IErlObject^% term,
    ErlVarBind^ binding
) sealed
abstract Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
override Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
abstract Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
override Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool

Parameters

term
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind

Return Value

Type: Online Boolean

Implements

IErlObject Subst(IErlObject , ErlVarBind)
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.ToString Method

ErlTupleBase ToString Method NFX Class Library

Overload List
 | Name | Description
Public method | ToString | Get the string representation of the list. (Overrides Online Object ToString .)
Public method | ToString(Boolean) |
Back to Top
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.ToString Method

ErlTupleBase ToString Method NFX Class Library

Get the string representation of the list.

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
ErlTupleBase Class
ErlTupleBase Members
ToString Overload
NFX.Erlang Namespace


ErlTupleBase.ToString Method (Boolean)

ErlTupleBase ToString Method (Boolean) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ToString(
    bool noBrakets
)
public string ToString(
    bool noBrakets
)
Public Function ToString (
    noBrakets As Boolean
) As String
Public Function ToString (
    noBrakets As Boolean
) As String
public:
String^ ToString(
    bool noBrakets
)
public:
String^ ToString(
    bool noBrakets
)
member ToString :
        noBrakets : bool -> string
member ToString :
        noBrakets : bool -> string

Parameters

noBrakets
Type: Online System Boolean

Return Value

Type: Online String
See Also
ErlTupleBase Class
ErlTupleBase Members
ToString Overload
NFX.Erlang Namespace


ErlTupleBase.Visit(TAccumulate) Method

ErlTupleBase Visit TAccumulate Method NFX Class Library

Execute fun for every nested term

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TAccumulate Visit<TAccumulate>(
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
public TAccumulate Visit<TAccumulate>(
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
Public Function Visit(Of TAccumulate) (
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
Public Function Visit(Of TAccumulate) (
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
public:
generic<typename TAccumulate>
virtual TAccumulate Visit(
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
) sealed
public:
generic<typename TAccumulate>
virtual TAccumulate Visit(
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
) sealed
abstract Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
override Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
abstract Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
override Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate

Parameters

acc
Type: TAccumulate
fun
Type: Online System Func TAccumulate, IErlObject, TAccumulate
Type Parameters
TAccumulate

Return Value

Type: TAccumulate

Implements

IErlObject Visit TAccumulate (TAccumulate, Func TAccumulate, IErlObject, TAccumulate )
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase Properties

ErlTupleBase Properties NFX Class Library

The ErlTupleBase type exposes the following members.
Properties
 | Name | Description
Protected property | CloseBracket |
Public property | Count | Return number of elements in the container
Public property | IsScalar | Determines whether the underlying type is scalar or complex (i.e. tuple, list)
Public property | Item | Return index'th element from the container
Protected property | OpenBracket |
Public property | TypeOrder |
Public property | Value | Get the list of Erlang terms contained in this object
Public property | ValueAsBool |
Public property | ValueAsByteArray |
Public property | ValueAsChar |
Public property | ValueAsDateTime |
Public property | ValueAsDecimal |
Public property | ValueAsDouble |
Public property | ValueAsInt |
Public property | ValueAsLong |
Public property | ValueAsObject |
Public property | ValueAsString |
Public property | ValueAsTimeSpan |
Back to Top
See Also
ErlTupleBase Class
NFX.Erlang Namespace


ErlTupleBase.CloseBracket Property

ErlTupleBase CloseBracket Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract char CloseBracket { get; }
protected abstract char CloseBracket { get; }
Protected MustOverride ReadOnly Property CloseBracket As Char
    Get
Protected MustOverride ReadOnly Property CloseBracket As Char
    Get
protected:
virtual property wchar_t CloseBracket {
    wchar_t get () abstract;
}
protected:
virtual property wchar_t CloseBracket {
    wchar_t get () abstract;
}
abstract CloseBracket : char with get
abstract CloseBracket : char with get

Property Value

Type: Online Char
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.Count Property

ErlTupleBase Count Property NFX Class Library

Return number of elements in the container

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
public:
property int Count {
    int get ();
}
member Count : int with get
member Count : int with get

Property Value

Type: Online Int32
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.IsScalar Property

ErlTupleBase IsScalar Property NFX Class Library

Determines whether the underlying type is scalar or complex (i.e. tuple, list)

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsScalar { get; }
public bool IsScalar { get; }
Public ReadOnly Property IsScalar As Boolean
    Get
Public ReadOnly Property IsScalar As Boolean
    Get
public:
virtual property bool IsScalar {
    bool get () sealed;
}
public:
virtual property bool IsScalar {
    bool get () sealed;
}
abstract IsScalar : bool with get
override IsScalar : bool with get
abstract IsScalar : bool with get
override IsScalar : bool with get

Property Value

Type: Online Boolean

Implements

IErlObject IsScalar
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.Item Property

ErlTupleBase Item Property NFX Class Library

Return index'th element from the container

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject this[
    int index
] { get; }
public IErlObject this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As IErlObject
    Get
Public ReadOnly Default Property Item (
    index As Integer
) As IErlObject
    Get
public:
property IErlObject^ default[int index] {
    IErlObject^ get (int index);
}
public:
property IErlObject^ default[int index] {
    IErlObject^ get (int index);
}
member Item : IErlObject with get
member Item : IErlObject with get

Parameters

index
Type: Online System Int32

Property Value

Type: IErlObject
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.OpenBracket Property

ErlTupleBase OpenBracket Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract char OpenBracket { get; }
protected abstract char OpenBracket { get; }
Protected MustOverride ReadOnly Property OpenBracket As Char
    Get
Protected MustOverride ReadOnly Property OpenBracket As Char
    Get
protected:
virtual property wchar_t OpenBracket {
    wchar_t get () abstract;
}
protected:
virtual property wchar_t OpenBracket {
    wchar_t get () abstract;
}
abstract OpenBracket : char with get
abstract OpenBracket : char with get

Property Value

Type: Online Char
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.TypeOrder Property

ErlTupleBase TypeOrder Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract ErlTypeOrder TypeOrder { get; }
public abstract ErlTypeOrder TypeOrder { get; }
Public MustOverride ReadOnly Property TypeOrder As ErlTypeOrder
    Get
Public MustOverride ReadOnly Property TypeOrder As ErlTypeOrder
    Get
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () abstract;
}
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () abstract;
}
abstract TypeOrder : ErlTypeOrder with get
abstract TypeOrder : ErlTypeOrder with get

Property Value

Type: ErlTypeOrder

Implements

IErlObject TypeOrder
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.Value Property

ErlTupleBase Value Property NFX Class Library

Get the list of Erlang terms contained in this object

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<IErlObject> Value { get; internal set; }
public List<IErlObject> Value { get; internal set; }
Public Property Value As List(Of IErlObject)
    Get
    Friend Set
Public Property Value As List(Of IErlObject)
    Get
    Friend Set
public:
virtual property List<IErlObject^>^ Value {
    List<IErlObject^>^ get () sealed;
    internal: void set (List<IErlObject^>^ value) sealed;
}
public:
virtual property List<IErlObject^>^ Value {
    List<IErlObject^>^ get () sealed;
    internal: void set (List<IErlObject^>^ value) sealed;
}
abstract Value : List<IErlObject> with get, internal set
override Value : List<IErlObject> with get, internal set
abstract Value : List<IErlObject> with get, internal set
override Value : List<IErlObject> with get, internal set

Property Value

Type: Online List IErlObject

Implements

IErlObject T Value
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.ValueAsBool Property

ErlTupleBase ValueAsBool Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool ValueAsBool { get; }
public virtual bool ValueAsBool { get; }
Public Overridable ReadOnly Property ValueAsBool As Boolean
    Get
Public Overridable ReadOnly Property ValueAsBool As Boolean
    Get
public:
virtual property bool ValueAsBool {
    bool get ();
}
public:
virtual property bool ValueAsBool {
    bool get ();
}
abstract ValueAsBool : bool with get
override ValueAsBool : bool with get
abstract ValueAsBool : bool with get
override ValueAsBool : bool with get

Property Value

Type: Online Boolean

Implements

IErlObject ValueAsBool
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.ValueAsByteArray Property

ErlTupleBase ValueAsByteArray Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual byte[] ValueAsByteArray { get; }
public virtual byte[] ValueAsByteArray { get; }
Public Overridable ReadOnly Property ValueAsByteArray As Byte()
    Get
Public Overridable ReadOnly Property ValueAsByteArray As Byte()
    Get
public:
virtual property array<unsigned char>^ ValueAsByteArray {
    array<unsigned char>^ get ();
}
public:
virtual property array<unsigned char>^ ValueAsByteArray {
    array<unsigned char>^ get ();
}
abstract ValueAsByteArray : byte[] with get
override ValueAsByteArray : byte[] with get
abstract ValueAsByteArray : byte[] with get
override ValueAsByteArray : byte[] with get

Property Value

Type: Online Byte

Implements

IErlObject ValueAsByteArray
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.ValueAsChar Property

ErlTupleBase ValueAsChar Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual char ValueAsChar { get; }
public virtual char ValueAsChar { get; }
Public Overridable ReadOnly Property ValueAsChar As Char
    Get
Public Overridable ReadOnly Property ValueAsChar As Char
    Get
public:
virtual property wchar_t ValueAsChar {
    wchar_t get ();
}
public:
virtual property wchar_t ValueAsChar {
    wchar_t get ();
}
abstract ValueAsChar : char with get
override ValueAsChar : char with get
abstract ValueAsChar : char with get
override ValueAsChar : char with get

Property Value

Type: Online Char

Implements

IErlObject ValueAsChar
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.ValueAsDateTime Property

ErlTupleBase ValueAsDateTime Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual DateTime ValueAsDateTime { get; }
public virtual DateTime ValueAsDateTime { get; }
Public Overridable ReadOnly Property ValueAsDateTime As DateTime
    Get
Public Overridable ReadOnly Property ValueAsDateTime As DateTime
    Get
public:
virtual property DateTime ValueAsDateTime {
    DateTime get ();
}
public:
virtual property DateTime ValueAsDateTime {
    DateTime get ();
}
abstract ValueAsDateTime : DateTime with get
override ValueAsDateTime : DateTime with get
abstract ValueAsDateTime : DateTime with get
override ValueAsDateTime : DateTime with get

Property Value

Type: Online DateTime

Implements

IErlObject ValueAsDateTime
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.ValueAsDecimal Property

ErlTupleBase ValueAsDecimal Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual decimal ValueAsDecimal { get; }
public virtual decimal ValueAsDecimal { get; }
Public Overridable ReadOnly Property ValueAsDecimal As Decimal
    Get
Public Overridable ReadOnly Property ValueAsDecimal As Decimal
    Get
public:
virtual property Decimal ValueAsDecimal {
    Decimal get ();
}
public:
virtual property Decimal ValueAsDecimal {
    Decimal get ();
}
abstract ValueAsDecimal : decimal with get
override ValueAsDecimal : decimal with get
abstract ValueAsDecimal : decimal with get
override ValueAsDecimal : decimal with get

Property Value

Type: Online Decimal

Implements

IErlObject ValueAsDecimal
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.ValueAsDouble Property

ErlTupleBase ValueAsDouble Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual double ValueAsDouble { get; }
public virtual double ValueAsDouble { get; }
Public Overridable ReadOnly Property ValueAsDouble As Double
    Get
Public Overridable ReadOnly Property ValueAsDouble As Double
    Get
public:
virtual property double ValueAsDouble {
    double get ();
}
public:
virtual property double ValueAsDouble {
    double get ();
}
abstract ValueAsDouble : float with get
override ValueAsDouble : float with get
abstract ValueAsDouble : float with get
override ValueAsDouble : float with get

Property Value

Type: Online Double

Implements

IErlObject ValueAsDouble
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.ValueAsInt Property

ErlTupleBase ValueAsInt Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int ValueAsInt { get; }
public virtual int ValueAsInt { get; }
Public Overridable ReadOnly Property ValueAsInt As Integer
    Get
Public Overridable ReadOnly Property ValueAsInt As Integer
    Get
public:
virtual property int ValueAsInt {
    int get ();
}
public:
virtual property int ValueAsInt {
    int get ();
}
abstract ValueAsInt : int with get
override ValueAsInt : int with get
abstract ValueAsInt : int with get
override ValueAsInt : int with get

Property Value

Type: Online Int32

Implements

IErlObject ValueAsInt
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.ValueAsLong Property

ErlTupleBase ValueAsLong Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual long ValueAsLong { get; }
public virtual long ValueAsLong { get; }
Public Overridable ReadOnly Property ValueAsLong As Long
    Get
Public Overridable ReadOnly Property ValueAsLong As Long
    Get
public:
virtual property long long ValueAsLong {
    long long get ();
}
public:
virtual property long long ValueAsLong {
    long long get ();
}
abstract ValueAsLong : int64 with get
override ValueAsLong : int64 with get
abstract ValueAsLong : int64 with get
override ValueAsLong : int64 with get

Property Value

Type: Online Int64

Implements

IErlObject ValueAsLong
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.ValueAsObject Property

ErlTupleBase ValueAsObject Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object ValueAsObject { get; }
public virtual Object ValueAsObject { get; }
Public Overridable ReadOnly Property ValueAsObject As Object
    Get
Public Overridable ReadOnly Property ValueAsObject As Object
    Get
public:
virtual property Object^ ValueAsObject {
    Object^ get ();
}
public:
virtual property Object^ ValueAsObject {
    Object^ get ();
}
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get

Property Value

Type: Online Object

Implements

IErlObject ValueAsObject
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.ValueAsString Property

ErlTupleBase ValueAsString Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string ValueAsString { get; }
public virtual string ValueAsString { get; }
Public Overridable ReadOnly Property ValueAsString As String
    Get
Public Overridable ReadOnly Property ValueAsString As String
    Get
public:
virtual property String^ ValueAsString {
    String^ get ();
}
public:
virtual property String^ ValueAsString {
    String^ get ();
}
abstract ValueAsString : string with get
override ValueAsString : string with get
abstract ValueAsString : string with get
override ValueAsString : string with get

Property Value

Type: Online String

Implements

IErlObject ValueAsString
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTupleBase.ValueAsTimeSpan Property

ErlTupleBase ValueAsTimeSpan Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual TimeSpan ValueAsTimeSpan { get; }
public virtual TimeSpan ValueAsTimeSpan { get; }
Public Overridable ReadOnly Property ValueAsTimeSpan As TimeSpan
    Get
Public Overridable ReadOnly Property ValueAsTimeSpan As TimeSpan
    Get
public:
virtual property TimeSpan ValueAsTimeSpan {
    TimeSpan get ();
}
public:
virtual property TimeSpan ValueAsTimeSpan {
    TimeSpan get ();
}
abstract ValueAsTimeSpan : TimeSpan with get
override ValueAsTimeSpan : TimeSpan with get
abstract ValueAsTimeSpan : TimeSpan with get
override ValueAsTimeSpan : TimeSpan with get

Property Value

Type: Online TimeSpan

Implements

IErlObject ValueAsTimeSpan
See Also
ErlTupleBase Class
ErlTupleBase Members
NFX.Erlang Namespace


ErlTypeOrder Enumeration

ErlTypeOrder Enumeration NFX Class Library

Defines ordering semantics for Erlang types

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum ErlTypeOrder
public enum ErlTypeOrder
Public Enumeration ErlTypeOrder
Public Enumeration ErlTypeOrder
public enum class ErlTypeOrder
public enum class ErlTypeOrder
type ErlTypeOrder
type ErlTypeOrder
Members
Member name | Value | Description
ErlObject | 0 |
ErlAtom | 1 |
ErlBinary | 2 |
ErlBoolean | 3 |
ErlByte | 4 |
ErlDouble | 5 |
ErlLong | 6 |
ErlList | 7 |
ErlPid | 8 |
ErlPort | 9 |
ErlRef | 10 |
ErlString | 11 |
ErlTuple | 12 |
ErlVar | 13 |
See Also
NFX.Erlang Namespace


ErlVar Structure

ErlVar Structure NFX Class Library

Provides a C# representation of an Erlang variable

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct ErlVar : IErlObject, IComparable,
    IComparable<IErlObject>, IEquatable<IErlObject>, ICloneable
public struct ErlVar : IErlObject, IComparable,
    IComparable<IErlObject>, IEquatable<IErlObject>, ICloneable
Public Structure ErlVar
    Implements IErlObject, IComparable, IComparable(Of IErlObject),
    IEquatable(Of IErlObject), ICloneable
Public Structure ErlVar
    Implements IErlObject, IComparable, IComparable(Of IErlObject),
    IEquatable(Of IErlObject), ICloneable
public value class ErlVar : IErlObject,
    IComparable, IComparable<IErlObject^>, IEquatable<IErlObject^>,
    ICloneable
public value class ErlVar : IErlObject,
    IComparable, IComparable<IErlObject^>, IEquatable<IErlObject^>,
    ICloneable
[<SealedAttribute>]
type ErlVar =
    struct
        interface IErlObject
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
    end
[<SealedAttribute>]
type ErlVar =
    struct
        interface IErlObject
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
    end
See Also
ErlVar Members
NFX.Erlang Namespace


ErlVar Members

ErlVar Members NFX Class Library

The ErlVar type exposes the following members.
Constructors
 | Name | Description
Public method | ErlVar(String) | Create an Erlang named variable
Public method | ErlVar(String, ErlTypeOrder) | Create an Erlang typed named variable
Public method | ErlVar(ErlAtom, ErlTypeOrder) | Create an Erlang typed named variable using ErlAtom as name
Back to Top
Methods
 | Name | Description
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the atom is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the atom is less than obj, positive - greater than the obj
Public method | Equals(Object) | Determine if this var equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(IErlObject) | Determine if two vars are equal
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Get internal hash code (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Public method | Matches | Match this variable with given pattern merely by performing type check
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Subst |
Public method | ToString | Get the printable version of the string contained in this object (Overrides Online ValueType ToString .)
Public method | Visit TAccumulate | Execute fun for every nested term
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | Any |
Public field | ValueType | Type of value stored in this variable
Back to Top
Properties
 | Name | Description
Public property | IsAny |
Public property | IsScalar |
Public property | Name | Variable name
Public property | TypeOrder |
Public property | ValueAsBool |
Public property | ValueAsByteArray |
Public property | ValueAsChar |
Public property | ValueAsDateTime |
Public property | ValueAsDecimal |
Public property | ValueAsDouble |
Public property | ValueAsInt |
Public property | ValueAsLong |
Public property | ValueAsObject |
Public property | ValueAsString |
Public property | ValueAsTimeSpan |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone |
Back to Top
See Also
ErlVar Structure
NFX.Erlang Namespace


ErlVar Constructor

ErlVar Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ErlVar(String) | Create an Erlang named variable
Public method | ErlVar(String, ErlTypeOrder) | Create an Erlang typed named variable
Public method | ErlVar(ErlAtom, ErlTypeOrder) | Create an Erlang typed named variable using ErlAtom as name
Back to Top
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVar Constructor (String)

ErlVar Constructor (String) NFX Class Library

Create an Erlang named variable

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlVar(
    string name
)
public ErlVar(
    string name
)
Public Sub New (
    name As String
)
Public Sub New (
    name As String
)
public:
ErlVar(
    String^ name
)
public:
ErlVar(
    String^ name
)
new :
        name : string -> ErlVar
new :
        name : string -> ErlVar

Parameters

name
Type: Online System String
Variable name
See Also
ErlVar Structure
ErlVar Members
ErlVar Overload
NFX.Erlang Namespace


ErlVar Constructor (String, ErlTypeOrder)

ErlVar Constructor (String, ErlTypeOrder) NFX Class Library

Create an Erlang typed named variable

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlVar(
    string name,
    ErlTypeOrder type
)
public ErlVar(
    string name,
    ErlTypeOrder type
)
Public Sub New (
    name As String,
    type As ErlTypeOrder
)
Public Sub New (
    name As String,
    type As ErlTypeOrder
)
public:
ErlVar(
    String^ name,
    ErlTypeOrder type
)
public:
ErlVar(
    String^ name,
    ErlTypeOrder type
)
new :
        name : string *
        type : ErlTypeOrder -> ErlVar
new :
        name : string *
        type : ErlTypeOrder -> ErlVar

Parameters

name
Type: Online System String
Variable name
type
Type: NFX.Erlang ErlTypeOrder
Value type
See Also
ErlVar Structure
ErlVar Members
ErlVar Overload
NFX.Erlang Namespace


ErlVar Constructor (ErlAtom, ErlTypeOrder)

ErlVar Constructor (ErlAtom, ErlTypeOrder) NFX Class Library

Create an Erlang typed named variable using ErlAtom as name

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlVar(
    ErlAtom name,
    ErlTypeOrder type = ErlTypeOrder.ErlObject
)
public ErlVar(
    ErlAtom name,
    ErlTypeOrder type = ErlTypeOrder.ErlObject
)
Public Sub New (
    name As ErlAtom,
    Optional type As ErlTypeOrder = ErlTypeOrder.ErlObject
)
Public Sub New (
    name As ErlAtom,
    Optional type As ErlTypeOrder = ErlTypeOrder.ErlObject
)
public:
ErlVar(
    ErlAtom name,
    ErlTypeOrder type = ErlTypeOrder::ErlObject
)
public:
ErlVar(
    ErlAtom name,
    ErlTypeOrder type = ErlTypeOrder::ErlObject
)
new :
        name : ErlAtom *
        ?type : ErlTypeOrder
(* Defaults:
        let _type = defaultArg type ErlTypeOrder.ErlObject
*)
-> ErlVar
new :
        name : ErlAtom *
        ?type : ErlTypeOrder
(* Defaults:
        let _type = defaultArg type ErlTypeOrder.ErlObject
*)
-> ErlVar

Parameters

name
Type: NFX.Erlang ErlAtom
Variable name
type (Optional)
Type: NFX.Erlang ErlTypeOrder
Value type
See Also
ErlVar Structure
ErlVar Members
ErlVar Overload
NFX.Erlang Namespace


ErlVar Fields

ErlVar Fields NFX Class Library

The ErlVar type exposes the following members.
Fields
 | Name | Description
 | Any |
Public field | ValueType | Type of value stored in this variable
Back to Top
See Also
ErlVar Structure
NFX.Erlang Namespace


ErlVar.Any Field

ErlVar Any Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly ErlVar Any
public static readonly ErlVar Any
Public Shared ReadOnly Any As ErlVar
Public Shared ReadOnly Any As ErlVar
public:
static initonly ErlVar Any
public:
static initonly ErlVar Any
static val Any: ErlVar
static val Any: ErlVar

Field Value

Type: ErlVar
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVar.ValueType Field

ErlVar ValueType Field NFX Class Library

Type of value stored in this variable

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ErlTypeOrder ValueType
public readonly ErlTypeOrder ValueType
Public ReadOnly ValueType As ErlTypeOrder
Public ReadOnly ValueType As ErlTypeOrder
public:
initonly ErlTypeOrder ValueType
public:
initonly ErlTypeOrder ValueType
val ValueType: ErlTypeOrder
val ValueType: ErlTypeOrder

Field Value

Type: ErlTypeOrder
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVar Methods

ErlVar Methods NFX Class Library

The ErlVar type exposes the following members.
Methods
 | Name | Description
Public method | Clone | Clone an instance of the object (non-scalar immutable objects are copied by reference)
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the atom is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the atom is less than obj, positive - greater than the obj
Public method | Equals(Object) | Determine if this var equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(IErlObject) | Determine if two vars are equal
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | Get internal hash code (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Public method | Matches | Match this variable with given pattern merely by performing type check
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Subst |
Public method | ToString | Get the printable version of the string contained in this object (Overrides Online ValueType ToString .)
Public method | Visit TAccumulate | Execute fun for every nested term
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ICloneable Clone |
Back to Top
See Also
ErlVar Structure
NFX.Erlang Namespace


ErlVar.ICloneable.Clone Method

ErlVar ICloneable Clone Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object ICloneable.Clone()
Object ICloneable.Clone()
Private Function Clone As Object Implements ICloneable.Clone
Private Function Clone As Object Implements ICloneable.Clone
private:
virtual Object^ Clone() sealed = ICloneable::Clone
private:
virtual Object^ Clone() sealed = ICloneable::Clone
private abstract Clone : unit -> Object
private override Clone : unit -> Object
private abstract Clone : unit -> Object
private override Clone : unit -> Object

Return Value

Type: Online Object

Implements

Online ICloneable Clone
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVar.Clone Method

ErlVar Clone Method NFX Class Library

Clone an instance of the object (non-scalar immutable objects are copied by reference)

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject Clone()
public IErlObject Clone()
Public Function Clone As IErlObject
Public Function Clone As IErlObject
public:
virtual IErlObject^ Clone() sealed
public:
virtual IErlObject^ Clone() sealed
abstract Clone : unit -> IErlObject
override Clone : unit -> IErlObject
abstract Clone : unit -> IErlObject
override Clone : unit -> IErlObject

Return Value

Type: IErlObject

Implements

IErlObject Clone
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVar.CompareTo Method

ErlVar CompareTo Method NFX Class Library

Overload List
 | Name | Description
Public method | CompareTo(Object) | Compare this instance to the object. Negative value means that the atom is less than obj, positive - greater than the obj
Public method | CompareTo(IErlObject) | Compare this instance to the IErlObject. Negative value means that the atom is less than obj, positive - greater than the obj
Back to Top
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVar.CompareTo Method (Object)

ErlVar CompareTo Method (Object) NFX Class Library

Compare this instance to the object. Negative value means that the atom is less than obj, positive - greater than the obj

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    Object obj
)
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
Public Function CompareTo (
    obj As Object
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
public:
virtual int CompareTo(
    Object^ obj
) sealed
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int

Parameters

obj
Type: Online System Object

Return Value

Type: Online Int32

Implements

Online IComparable CompareTo(Object)
See Also
ErlVar Structure
ErlVar Members
CompareTo Overload
NFX.Erlang Namespace


ErlVar.CompareTo Method (IErlObject)

ErlVar CompareTo Method (IErlObject) NFX Class Library

Compare this instance to the IErlObject. Negative value means that the atom is less than obj, positive - greater than the obj

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    IErlObject obj
)
public int CompareTo(
    IErlObject obj
)
Public Function CompareTo (
    obj As IErlObject
) As Integer
Public Function CompareTo (
    obj As IErlObject
) As Integer
public:
virtual int CompareTo(
    IErlObject^ obj
) sealed
public:
virtual int CompareTo(
    IErlObject^ obj
) sealed
abstract CompareTo :
        obj : IErlObject -> int
override CompareTo :
        obj : IErlObject -> int
abstract CompareTo :
        obj : IErlObject -> int
override CompareTo :
        obj : IErlObject -> int

Parameters

obj
Type: NFX.Erlang IErlObject

Return Value

Type: Online Int32

Implements

Online IComparable T CompareTo(T)
See Also
ErlVar Structure
ErlVar Members
CompareTo Overload
NFX.Erlang Namespace


ErlVar.Equals Method

ErlVar Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | Determine if this var equals to the object (Overrides Online ValueType Equals(Object).)
Public method | Equals(IErlObject) | Determine if two vars are equal
Back to Top
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVar.Equals Method (Object)

ErlVar Equals Method (Object) NFX Class Library

Determine if this var equals to the object

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object o
)
public override bool Equals(
    Object o
)
Public Overrides Function Equals (
    o As Object
) As Boolean
Public Overrides Function Equals (
    o As Object
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
public:
virtual bool Equals(
    Object^ o
) override
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool

Parameters

o
Type: Online System Object

Return Value

Type: Online Boolean
See Also
ErlVar Structure
ErlVar Members
Equals Overload
NFX.Erlang Namespace


ErlVar.Equals Method (IErlObject)

ErlVar Equals Method (IErlObject) NFX Class Library

Determine if two vars are equal

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    IErlObject o
)
public bool Equals(
    IErlObject o
)
Public Function Equals (
    o As IErlObject
) As Boolean
Public Function Equals (
    o As IErlObject
) As Boolean
public:
virtual bool Equals(
    IErlObject^ o
) sealed
public:
virtual bool Equals(
    IErlObject^ o
) sealed
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool
abstract Equals :
        o : IErlObject -> bool
override Equals :
        o : IErlObject -> bool

Parameters

o
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
ErlVar Structure
ErlVar Members
Equals Overload
NFX.Erlang Namespace


ErlVar.GetHashCode Method

ErlVar GetHashCode Method NFX Class Library

Get internal hash code

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVar.Match Method

ErlVar Match Method NFX Class Library

Overload List
 | Name | Description
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Back to Top
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVar.Match Method (IErlObject)

ErlVar Match Method (IErlObject) NFX Class Library

Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlVarBind Match(
    IErlObject pattern
)
public ErlVarBind Match(
    IErlObject pattern
)
Public Function Match (
    pattern As IErlObject
) As ErlVarBind
Public Function Match (
    pattern As IErlObject
) As ErlVarBind
public:
virtual ErlVarBind^ Match(
    IErlObject^ pattern
) sealed
public:
virtual ErlVarBind^ Match(
    IErlObject^ pattern
) sealed
abstract Match :
        pattern : IErlObject -> ErlVarBind
override Match :
        pattern : IErlObject -> ErlVarBind
abstract Match :
        pattern : IErlObject -> ErlVarBind
override Match :
        pattern : IErlObject -> ErlVarBind

Parameters

pattern
Type: NFX.Erlang IErlObject

Return Value

Type: ErlVarBind

Implements

IErlObject Match(IErlObject)
See Also
ErlVar Structure
ErlVar Members
Match Overload
NFX.Erlang Namespace


ErlVar.Match Method (IErlObject, ErlVarBind)

ErlVar Match Method (IErlObject, ErlVarBind) NFX Class Library

[This is preliminary documentation and is subject to change.]

Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Match(
    IErlObject pattern,
    ErlVarBind binding
)
public bool Match(
    IErlObject pattern,
    ErlVarBind binding
)
Public Function Match (
    pattern As IErlObject,
    binding As ErlVarBind
) As Boolean
Public Function Match (
    pattern As IErlObject,
    binding As ErlVarBind
) As Boolean
public:
virtual bool Match(
    IErlObject^ pattern,
    ErlVarBind^ binding
) sealed
public:
virtual bool Match(
    IErlObject^ pattern,
    ErlVarBind^ binding
) sealed
abstract Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
override Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
abstract Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
override Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool

Parameters

pattern
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind

Return Value

Type: Online Boolean

Implements

IErlObject Match(IErlObject, ErlVarBind)
See Also
ErlVar Structure
ErlVar Members
Match Overload
NFX.Erlang Namespace


ErlVar.Matches Method

ErlVar Matches Method NFX Class Library

Match this variable with given pattern merely by performing type check

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Matches(
    IErlObject pattern
)
public bool Matches(
    IErlObject pattern
)
Public Function Matches (
    pattern As IErlObject
) As Boolean
Public Function Matches (
    pattern As IErlObject
) As Boolean
public:
virtual bool Matches(
    IErlObject^ pattern
) sealed
public:
virtual bool Matches(
    IErlObject^ pattern
) sealed
abstract Matches :
        pattern : IErlObject -> bool
override Matches :
        pattern : IErlObject -> bool
abstract Matches :
        pattern : IErlObject -> bool
override Matches :
        pattern : IErlObject -> bool

Parameters

pattern
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean

Implements

IErlObject Matches(IErlObject)
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVar.Subst Method

ErlVar Subst Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Subst(
    ref IErlObject obj,
    ErlVarBind binding
)
public bool Subst(
    ref IErlObject obj,
    ErlVarBind binding
)
Public Function Subst (
    ByRef obj As IErlObject,
    binding As ErlVarBind
) As Boolean
Public Function Subst (
    ByRef obj As IErlObject,
    binding As ErlVarBind
) As Boolean
public:
virtual bool Subst(
    IErlObject^% obj,
    ErlVarBind^ binding
) sealed
public:
virtual bool Subst(
    IErlObject^% obj,
    ErlVarBind^ binding
) sealed
abstract Subst :
        obj : IErlObject byref *
        binding : ErlVarBind -> bool
override Subst :
        obj : IErlObject byref *
        binding : ErlVarBind -> bool
abstract Subst :
        obj : IErlObject byref *
        binding : ErlVarBind -> bool
override Subst :
        obj : IErlObject byref *
        binding : ErlVarBind -> bool

Parameters

obj
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind

Return Value

Type: Online Boolean

Implements

IErlObject Subst(IErlObject , ErlVarBind)
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVar.ToString Method

ErlVar ToString Method NFX Class Library

Get the printable version of the string contained in this object

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVar.Visit(TAccumulate) Method

ErlVar Visit TAccumulate Method NFX Class Library

Execute fun for every nested term

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TAccumulate Visit<TAccumulate>(
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
public TAccumulate Visit<TAccumulate>(
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
Public Function Visit(Of TAccumulate) (
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
Public Function Visit(Of TAccumulate) (
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
public:
generic<typename TAccumulate>
virtual TAccumulate Visit(
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
) sealed
public:
generic<typename TAccumulate>
virtual TAccumulate Visit(
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
) sealed
abstract Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
override Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
abstract Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
override Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate

Parameters

acc
Type: TAccumulate
fun
Type: Online System Func TAccumulate, IErlObject, TAccumulate
Type Parameters
TAccumulate

Return Value

Type: TAccumulate

Implements

IErlObject Visit TAccumulate (TAccumulate, Func TAccumulate, IErlObject, TAccumulate )
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVar Properties

ErlVar Properties NFX Class Library

The ErlVar type exposes the following members.
Properties
 | Name | Description
Public property | IsAny |
Public property | IsScalar |
Public property | Name | Variable name
Public property | TypeOrder |
Public property | ValueAsBool |
Public property | ValueAsByteArray |
Public property | ValueAsChar |
Public property | ValueAsDateTime |
Public property | ValueAsDecimal |
Public property | ValueAsDouble |
Public property | ValueAsInt |
Public property | ValueAsLong |
Public property | ValueAsObject |
Public property | ValueAsString |
Public property | ValueAsTimeSpan |
Back to Top
See Also
ErlVar Structure
NFX.Erlang Namespace


ErlVar.IsAny Property

ErlVar IsAny Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsAny { get; }
public bool IsAny { get; }
Public ReadOnly Property IsAny As Boolean
    Get
Public ReadOnly Property IsAny As Boolean
    Get
public:
property bool IsAny {
    bool get ();
}
public:
property bool IsAny {
    bool get ();
}
member IsAny : bool with get
member IsAny : bool with get

Property Value

Type: Online Boolean
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVar.IsScalar Property

ErlVar IsScalar Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsScalar { get; }
public bool IsScalar { get; }
Public ReadOnly Property IsScalar As Boolean
    Get
Public ReadOnly Property IsScalar As Boolean
    Get
public:
virtual property bool IsScalar {
    bool get () sealed;
}
public:
virtual property bool IsScalar {
    bool get () sealed;
}
abstract IsScalar : bool with get
override IsScalar : bool with get
abstract IsScalar : bool with get
override IsScalar : bool with get

Property Value

Type: Online Boolean

Implements

IErlObject IsScalar
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVar.Name Property

ErlVar Name Property NFX Class Library

Variable name

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlAtom Name { get; }
public ErlAtom Name { get; }
Public ReadOnly Property Name As ErlAtom
    Get
Public ReadOnly Property Name As ErlAtom
    Get
public:
property ErlAtom Name {
    ErlAtom get ();
}
public:
property ErlAtom Name {
    ErlAtom get ();
}
member Name : ErlAtom with get
member Name : ErlAtom with get

Property Value

Type: ErlAtom
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVar.TypeOrder Property

ErlVar TypeOrder Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlTypeOrder TypeOrder { get; }
public ErlTypeOrder TypeOrder { get; }
Public ReadOnly Property TypeOrder As ErlTypeOrder
    Get
Public ReadOnly Property TypeOrder As ErlTypeOrder
    Get
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () sealed;
}
public:
virtual property ErlTypeOrder TypeOrder {
    ErlTypeOrder get () sealed;
}
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get
abstract TypeOrder : ErlTypeOrder with get
override TypeOrder : ErlTypeOrder with get

Property Value

Type: ErlTypeOrder

Implements

IErlObject TypeOrder
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVar.ValueAsBool Property

ErlVar ValueAsBool Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ValueAsBool { get; }
public bool ValueAsBool { get; }
Public ReadOnly Property ValueAsBool As Boolean
    Get
Public ReadOnly Property ValueAsBool As Boolean
    Get
public:
virtual property bool ValueAsBool {
    bool get () sealed;
}
public:
virtual property bool ValueAsBool {
    bool get () sealed;
}
abstract ValueAsBool : bool with get
override ValueAsBool : bool with get
abstract ValueAsBool : bool with get
override ValueAsBool : bool with get

Property Value

Type: Online Boolean

Implements

IErlObject ValueAsBool
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVar.ValueAsByteArray Property

ErlVar ValueAsByteArray Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] ValueAsByteArray { get; }
public byte[] ValueAsByteArray { get; }
Public ReadOnly Property ValueAsByteArray As Byte()
    Get
Public ReadOnly Property ValueAsByteArray As Byte()
    Get
public:
virtual property array<unsigned char>^ ValueAsByteArray {
    array<unsigned char>^ get () sealed;
}
public:
virtual property array<unsigned char>^ ValueAsByteArray {
    array<unsigned char>^ get () sealed;
}
abstract ValueAsByteArray : byte[] with get
override ValueAsByteArray : byte[] with get
abstract ValueAsByteArray : byte[] with get
override ValueAsByteArray : byte[] with get

Property Value

Type: Online Byte

Implements

IErlObject ValueAsByteArray
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVar.ValueAsChar Property

ErlVar ValueAsChar Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char ValueAsChar { get; }
public char ValueAsChar { get; }
Public ReadOnly Property ValueAsChar As Char
    Get
Public ReadOnly Property ValueAsChar As Char
    Get
public:
virtual property wchar_t ValueAsChar {
    wchar_t get () sealed;
}
public:
virtual property wchar_t ValueAsChar {
    wchar_t get () sealed;
}
abstract ValueAsChar : char with get
override ValueAsChar : char with get
abstract ValueAsChar : char with get
override ValueAsChar : char with get

Property Value

Type: Online Char

Implements

IErlObject ValueAsChar
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVar.ValueAsDateTime Property

ErlVar ValueAsDateTime Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime ValueAsDateTime { get; }
public DateTime ValueAsDateTime { get; }
Public ReadOnly Property ValueAsDateTime As DateTime
    Get
Public ReadOnly Property ValueAsDateTime As DateTime
    Get
public:
virtual property DateTime ValueAsDateTime {
    DateTime get () sealed;
}
public:
virtual property DateTime ValueAsDateTime {
    DateTime get () sealed;
}
abstract ValueAsDateTime : DateTime with get
override ValueAsDateTime : DateTime with get
abstract ValueAsDateTime : DateTime with get
override ValueAsDateTime : DateTime with get

Property Value

Type: Online DateTime

Implements

IErlObject ValueAsDateTime
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVar.ValueAsDecimal Property

ErlVar ValueAsDecimal Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal ValueAsDecimal { get; }
public decimal ValueAsDecimal { get; }
Public ReadOnly Property ValueAsDecimal As Decimal
    Get
Public ReadOnly Property ValueAsDecimal As Decimal
    Get
public:
virtual property Decimal ValueAsDecimal {
    Decimal get () sealed;
}
public:
virtual property Decimal ValueAsDecimal {
    Decimal get () sealed;
}
abstract ValueAsDecimal : decimal with get
override ValueAsDecimal : decimal with get
abstract ValueAsDecimal : decimal with get
override ValueAsDecimal : decimal with get

Property Value

Type: Online Decimal

Implements

IErlObject ValueAsDecimal
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVar.ValueAsDouble Property

ErlVar ValueAsDouble Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double ValueAsDouble { get; }
public double ValueAsDouble { get; }
Public ReadOnly Property ValueAsDouble As Double
    Get
Public ReadOnly Property ValueAsDouble As Double
    Get
public:
virtual property double ValueAsDouble {
    double get () sealed;
}
public:
virtual property double ValueAsDouble {
    double get () sealed;
}
abstract ValueAsDouble : float with get
override ValueAsDouble : float with get
abstract ValueAsDouble : float with get
override ValueAsDouble : float with get

Property Value

Type: Online Double

Implements

IErlObject ValueAsDouble
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVar.ValueAsInt Property

ErlVar ValueAsInt Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ValueAsInt { get; }
public int ValueAsInt { get; }
Public ReadOnly Property ValueAsInt As Integer
    Get
Public ReadOnly Property ValueAsInt As Integer
    Get
public:
virtual property int ValueAsInt {
    int get () sealed;
}
public:
virtual property int ValueAsInt {
    int get () sealed;
}
abstract ValueAsInt : int with get
override ValueAsInt : int with get
abstract ValueAsInt : int with get
override ValueAsInt : int with get

Property Value

Type: Online Int32

Implements

IErlObject ValueAsInt
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVar.ValueAsLong Property

ErlVar ValueAsLong Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long ValueAsLong { get; }
public long ValueAsLong { get; }
Public ReadOnly Property ValueAsLong As Long
    Get
Public ReadOnly Property ValueAsLong As Long
    Get
public:
virtual property long long ValueAsLong {
    long long get () sealed;
}
public:
virtual property long long ValueAsLong {
    long long get () sealed;
}
abstract ValueAsLong : int64 with get
override ValueAsLong : int64 with get
abstract ValueAsLong : int64 with get
override ValueAsLong : int64 with get

Property Value

Type: Online Int64

Implements

IErlObject ValueAsLong
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVar.ValueAsObject Property

ErlVar ValueAsObject Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object ValueAsObject { get; }
public Object ValueAsObject { get; }
Public ReadOnly Property ValueAsObject As Object
    Get
Public ReadOnly Property ValueAsObject As Object
    Get
public:
virtual property Object^ ValueAsObject {
    Object^ get () sealed;
}
public:
virtual property Object^ ValueAsObject {
    Object^ get () sealed;
}
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get

Property Value

Type: Online Object

Implements

IErlObject ValueAsObject
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVar.ValueAsString Property

ErlVar ValueAsString Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ValueAsString { get; }
public string ValueAsString { get; }
Public ReadOnly Property ValueAsString As String
    Get
Public ReadOnly Property ValueAsString As String
    Get
public:
virtual property String^ ValueAsString {
    String^ get () sealed;
}
public:
virtual property String^ ValueAsString {
    String^ get () sealed;
}
abstract ValueAsString : string with get
override ValueAsString : string with get
abstract ValueAsString : string with get
override ValueAsString : string with get

Property Value

Type: Online String

Implements

IErlObject ValueAsString
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVar.ValueAsTimeSpan Property

ErlVar ValueAsTimeSpan Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeSpan ValueAsTimeSpan { get; }
public TimeSpan ValueAsTimeSpan { get; }
Public ReadOnly Property ValueAsTimeSpan As TimeSpan
    Get
Public ReadOnly Property ValueAsTimeSpan As TimeSpan
    Get
public:
virtual property TimeSpan ValueAsTimeSpan {
    TimeSpan get () sealed;
}
public:
virtual property TimeSpan ValueAsTimeSpan {
    TimeSpan get () sealed;
}
abstract ValueAsTimeSpan : TimeSpan with get
override ValueAsTimeSpan : TimeSpan with get
abstract ValueAsTimeSpan : TimeSpan with get
override ValueAsTimeSpan : TimeSpan with get

Property Value

Type: Online TimeSpan

Implements

IErlObject ValueAsTimeSpan
See Also
ErlVar Structure
ErlVar Members
NFX.Erlang Namespace


ErlVarBind Class

ErlVarBind Class NFX Class Library

Dictionary of variables bound to terms
Inheritance Hierarchy
Online System Object
NFX.Erlang ErlVarBind

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ErlVarBind : IEnumerable<KeyValuePair<ErlAtom, IErlObject>>,
    IEnumerable
public class ErlVarBind : IEnumerable<KeyValuePair<ErlAtom, IErlObject>>,
    IEnumerable
Public Class ErlVarBind
    Implements IEnumerable(Of KeyValuePair(Of ErlAtom, IErlObject)),
    IEnumerable
Public Class ErlVarBind
    Implements IEnumerable(Of KeyValuePair(Of ErlAtom, IErlObject)),
    IEnumerable
public ref class ErlVarBind : IEnumerable<KeyValuePair<ErlAtom, IErlObject^>>,
    IEnumerable
public ref class ErlVarBind : IEnumerable<KeyValuePair<ErlAtom, IErlObject^>>,
    IEnumerable
type ErlVarBind =
    class
        interface IEnumerable<KeyValuePair<ErlAtom, IErlObject>>
        interface IEnumerable
    end
type ErlVarBind =
    class
        interface IEnumerable<KeyValuePair<ErlAtom, IErlObject>>
        interface IEnumerable
    end
See Also
ErlVarBind Members
NFX.Erlang Namespace


ErlVarBind Members

ErlVarBind Members NFX Class Library

The ErlVarBind type exposes the following members.
Constructors
 | Name | Description
Public method | ErlVarBind | Initializes a new instance of the ErlVarBind class
Back to Top
Methods
 | Name | Description
Public method | Add(ErlAtom, IErlObject) | Add a variable binding associating value with variable name
Public method | Add(ErlVar, Object) | Add a variable binding converting an object to variable by name
Public method | Add(ErlAtom, ErlTypeOrder, Object) | Add a variable binding associating value with variable name
Public method | Cast T |
Public method | Clear |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Merge |
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable KeyValuePair ErlAtom, IErlObject | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct KeyValuePair ErlAtom, IErlObject , TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair ErlAtom, IErlObject , TComparand (Func KeyValuePair ErlAtom, IErlObject , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair ErlAtom, IErlObject , TComparand (Func KeyValuePair ErlAtom, IErlObject , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair ErlAtom, IErlObject , TComparand (Func KeyValuePair ErlAtom, IErlObject , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair ErlAtom, IErlObject , TComparand (Func KeyValuePair ErlAtom, IErlObject , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault KeyValuePair ErlAtom, IErlObject | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair ErlAtom, IErlObject (Action KeyValuePair ErlAtom, IErlObject ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair ErlAtom, IErlObject (Action KeyValuePair ErlAtom, IErlObject , Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair ErlAtom, IErlObject | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair ErlAtom, IErlObject (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Count |
Public property | Empty |
Public property | Item String |
Public property | Item ErlAtom |
Public property | Item ErlVar |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
ErlVarBind Class
NFX.Erlang Namespace


ErlVarBind Constructor

ErlVarBind Constructor NFX Class Library

Initializes a new instance of the ErlVarBind class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlVarBind()
public ErlVarBind()
Public Sub New
Public Sub New
public:
ErlVarBind()
public:
ErlVarBind()
new : unit -> ErlVarBind
new : unit -> ErlVarBind
See Also
ErlVarBind Class
ErlVarBind Members
NFX.Erlang Namespace


ErlVarBind Methods

ErlVarBind Methods NFX Class Library

The ErlVarBind type exposes the following members.
Methods
 | Name | Description
Public method | Add(ErlAtom, IErlObject) | Add a variable binding associating value with variable name
Public method | Add(ErlVar, Object) | Add a variable binding converting an object to variable by name
Public method | Add(ErlAtom, ErlTypeOrder, Object) | Add a variable binding associating value with variable name
Public method | Cast T |
Public method | Clear |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Merge |
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable KeyValuePair ErlAtom, IErlObject | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct KeyValuePair ErlAtom, IErlObject , TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair ErlAtom, IErlObject , TComparand (Func KeyValuePair ErlAtom, IErlObject , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair ErlAtom, IErlObject , TComparand (Func KeyValuePair ErlAtom, IErlObject , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair ErlAtom, IErlObject , TComparand (Func KeyValuePair ErlAtom, IErlObject , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair ErlAtom, IErlObject , TComparand (Func KeyValuePair ErlAtom, IErlObject , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault KeyValuePair ErlAtom, IErlObject | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair ErlAtom, IErlObject (Action KeyValuePair ErlAtom, IErlObject ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair ErlAtom, IErlObject (Action KeyValuePair ErlAtom, IErlObject , Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair ErlAtom, IErlObject | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair ErlAtom, IErlObject (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
ErlVarBind Class
NFX.Erlang Namespace


ErlVarBind.IEnumerable.GetEnumerator Method

ErlVarBind IEnumerable GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
ErlVarBind Class
ErlVarBind Members
NFX.Erlang Namespace


ErlVarBind.Add Method

ErlVarBind Add Method NFX Class Library

Overload List
 | Name | Description
Public method | Add(ErlAtom, IErlObject) | Add a variable binding associating value with variable name
Public method | Add(ErlVar, Object) | Add a variable binding converting an object to variable by name
Public method | Add(ErlAtom, ErlTypeOrder, Object) | Add a variable binding associating value with variable name
Back to Top
See Also
ErlVarBind Class
ErlVarBind Members
NFX.Erlang Namespace


ErlVarBind.Add Method (ErlAtom, IErlObject)

ErlVarBind Add Method (ErlAtom, IErlObject) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add a variable binding associating value with variable name

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    ErlAtom name,
    IErlObject value
)
public void Add(
    ErlAtom name,
    IErlObject value
)
Public Sub Add (
    name As ErlAtom,
    value As IErlObject
)
Public Sub Add (
    name As ErlAtom,
    value As IErlObject
)
public:
void Add(
    ErlAtom name,
    IErlObject^ value
)
public:
void Add(
    ErlAtom name,
    IErlObject^ value
)
member Add :
        name : ErlAtom *
        value : IErlObject -> unit
member Add :
        name : ErlAtom *
        value : IErlObject -> unit

Parameters

name
Type: NFX.Erlang ErlAtom
Name of the variable
value
Type: NFX.Erlang IErlObject
Value to associate with name
See Also
ErlVarBind Class
ErlVarBind Members
Add Overload
NFX.Erlang Namespace


ErlVarBind.Add Method (ErlVar, Object)

ErlVarBind Add Method (ErlVar, Object) NFX Class Library

Add a variable binding converting an object to variable by name

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    ErlVar var,
    Object o
)
public void Add(
    ErlVar var,
    Object o
)
Public Sub Add (
    var As ErlVar,
    o As Object
)
Public Sub Add (
    var As ErlVar,
    o As Object
)
public:
void Add(
    ErlVar var,
    Object^ o
)
public:
void Add(
    ErlVar var,
    Object^ o
)
member Add :
        var : ErlVar *
        o : Object -> unit
member Add :
        var : ErlVar *
        o : Object -> unit

Parameters

var
Type: NFX.Erlang ErlVar
Name of the variable
o
Type: Online System Object
Value to associate with name
See Also
ErlVarBind Class
ErlVarBind Members
Add Overload
NFX.Erlang Namespace


ErlVarBind.Add Method (ErlAtom, ErlTypeOrder, Object)

ErlVarBind Add Method (ErlAtom, ErlTypeOrder, Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add a variable binding associating value with variable name

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    ErlAtom name,
    ErlTypeOrder et,
    Object o
)
public void Add(
    ErlAtom name,
    ErlTypeOrder et,
    Object o
)
Public Sub Add (
    name As ErlAtom,
    et As ErlTypeOrder,
    o As Object
)
Public Sub Add (
    name As ErlAtom,
    et As ErlTypeOrder,
    o As Object
)
public:
void Add(
    ErlAtom name,
    ErlTypeOrder et,
    Object^ o
)
public:
void Add(
    ErlAtom name,
    ErlTypeOrder et,
    Object^ o
)
member Add :
        name : ErlAtom *
        et : ErlTypeOrder *
        o : Object -> unit
member Add :
        name : ErlAtom *
        et : ErlTypeOrder *
        o : Object -> unit

Parameters

name
Type: NFX.Erlang ErlAtom
Name of the variable
et
Type: NFX.Erlang ErlTypeOrder
Erlang type to use for conversion of the given CLR type
o
Type: Online System Object
Value to associate with name
See Also
ErlVarBind Class
ErlVarBind Members
Add Overload
NFX.Erlang Namespace


ErlVarBind.Cast(T) Method

ErlVarBind Cast T Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T Cast<T>(
    ErlAtom name
)
where T : IErlObject
public T Cast<T>(
    ErlAtom name
)
where T : IErlObject
Public Function Cast(Of T As IErlObject) (
    name As ErlAtom
) As T
Public Function Cast(Of T As IErlObject) (
    name As ErlAtom
) As T
public:
generic<typename T>
where T : IErlObject
T Cast(
    ErlAtom name
)
public:
generic<typename T>
where T : IErlObject
T Cast(
    ErlAtom name
)
member Cast :
        name : ErlAtom -> 'T  when 'T : IErlObject
member Cast :
        name : ErlAtom -> 'T  when 'T : IErlObject

Parameters

name
Type: NFX.Erlang ErlAtom
Type Parameters
T

Return Value

Type: T
See Also
ErlVarBind Class
ErlVarBind Members
NFX.Erlang Namespace


ErlVarBind.Clear Method

ErlVarBind Clear Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
void Clear()
public:
void Clear()
member Clear : unit -> unit
member Clear : unit -> unit
See Also
ErlVarBind Class
ErlVarBind Members
NFX.Erlang Namespace


ErlVarBind.GetEnumerator Method

ErlVarBind GetEnumerator Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<KeyValuePair<ErlAtom, IErlObject>> GetEnumerator()
public IEnumerator<KeyValuePair<ErlAtom, IErlObject>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of ErlAtom, IErlObject))
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of ErlAtom, IErlObject))
public:
virtual IEnumerator<KeyValuePair<ErlAtom, IErlObject^>>^ GetEnumerator() sealed
public:
virtual IEnumerator<KeyValuePair<ErlAtom, IErlObject^>>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<ErlAtom, IErlObject>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<ErlAtom, IErlObject>>
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<ErlAtom, IErlObject>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<ErlAtom, IErlObject>>

Return Value

Type: Online IEnumerator Online KeyValuePair ErlAtom, IErlObject

Implements

Online IEnumerable T GetEnumerator
See Also
ErlVarBind Class
ErlVarBind Members
NFX.Erlang Namespace


ErlVarBind.Merge Method

ErlVarBind Merge Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Merge(
    ErlVarBind other
)
public void Merge(
    ErlVarBind other
)
Public Sub Merge (
    other As ErlVarBind
)
Public Sub Merge (
    other As ErlVarBind
)
public:
void Merge(
    ErlVarBind^ other
)
public:
void Merge(
    ErlVarBind^ other
)
member Merge :
        other : ErlVarBind -> unit
member Merge :
        other : ErlVarBind -> unit

Parameters

other
Type: NFX.Erlang ErlVarBind
See Also
ErlVarBind Class
ErlVarBind Members
NFX.Erlang Namespace


ErlVarBind.ToString Method

ErlVarBind ToString Method NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
ErlVarBind Class
ErlVarBind Members
NFX.Erlang Namespace


ErlVarBind Properties

ErlVarBind Properties NFX Class Library

The ErlVarBind type exposes the following members.
Properties
 | Name | Description
Public property | Count |
Public property | Empty |
Public property | Item String |
Public property | Item ErlAtom |
Public property | Item ErlVar |
Back to Top
See Also
ErlVarBind Class
NFX.Erlang Namespace


ErlVarBind.Count Property

ErlVarBind Count Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
public:
property int Count {
    int get ();
}
member Count : int with get
member Count : int with get

Property Value

Type: Online Int32
See Also
ErlVarBind Class
ErlVarBind Members
NFX.Erlang Namespace


ErlVarBind.Empty Property

ErlVarBind Empty Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Empty { get; }
public bool Empty { get; }
Public ReadOnly Property Empty As Boolean
    Get
Public ReadOnly Property Empty As Boolean
    Get
public:
property bool Empty {
    bool get ();
}
public:
property bool Empty {
    bool get ();
}
member Empty : bool with get
member Empty : bool with get

Property Value

Type: Online Boolean
See Also
ErlVarBind Class
ErlVarBind Members
NFX.Erlang Namespace


ErlVarBind.Item Property

ErlVarBind Item Property NFX Class Library

Overload List
 | Name | Description
Public property | Item String |
Public property | Item ErlAtom |
Public property | Item ErlVar |
Back to Top
See Also
ErlVarBind Class
ErlVarBind Members
NFX.Erlang Namespace


ErlVarBind.Item Property (String)

ErlVarBind Item Property (String) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject this[
    string name
] { get; }
public IErlObject this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As IErlObject
    Get
Public ReadOnly Default Property Item (
    name As String
) As IErlObject
    Get
public:
property IErlObject^ default[String^ name] {
    IErlObject^ get (String^ name);
}
public:
property IErlObject^ default[String^ name] {
    IErlObject^ get (String^ name);
}
member Item : IErlObject with get
member Item : IErlObject with get

Parameters

name
Type: Online System String

Property Value

Type: IErlObject
See Also
ErlVarBind Class
ErlVarBind Members
Item Overload
NFX.Erlang Namespace


ErlVarBind.Item Property (ErlAtom)

ErlVarBind Item Property (ErlAtom) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject this[
    ErlAtom name
] { get; set; }
public IErlObject this[
    ErlAtom name
] { get; set; }
Public Default Property Item (
    name As ErlAtom
) As IErlObject
    Get
    Set
Public Default Property Item (
    name As ErlAtom
) As IErlObject
    Get
    Set
public:
property IErlObject^ default[ErlAtom name] {
    IErlObject^ get (ErlAtom name);
    void set (ErlAtom name, IErlObject^ value);
}
public:
property IErlObject^ default[ErlAtom name] {
    IErlObject^ get (ErlAtom name);
    void set (ErlAtom name, IErlObject^ value);
}
member Item : IErlObject with get, set
member Item : IErlObject with get, set

Parameters

name
Type: NFX.Erlang ErlAtom

Property Value

Type: IErlObject
See Also
ErlVarBind Class
ErlVarBind Members
Item Overload
NFX.Erlang Namespace


ErlVarBind.Item Property (ErlVar)

ErlVarBind Item Property (ErlVar) NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IErlObject this[
    ErlVar name
] { get; }
public IErlObject this[
    ErlVar name
] { get; }
Public ReadOnly Default Property Item (
    name As ErlVar
) As IErlObject
    Get
Public ReadOnly Default Property Item (
    name As ErlVar
) As IErlObject
    Get
public:
property IErlObject^ default[ErlVar name] {
    IErlObject^ get (ErlVar name);
}
public:
property IErlObject^ default[ErlVar name] {
    IErlObject^ get (ErlVar name);
}
member Item : IErlObject with get
member Item : IErlObject with get

Parameters

name
Type: NFX.Erlang ErlVar

Property Value

Type: IErlObject
See Also
ErlVarBind Class
ErlVarBind Members
Item Overload
NFX.Erlang Namespace


IErlObject Interface

IErlObject Interface NFX Class Library

All Erlang terms implement this interface

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IErlObject : IComparable,
    IComparable<IErlObject>, IEquatable<IErlObject>, ICloneable
public interface IErlObject : IComparable,
    IComparable<IErlObject>, IEquatable<IErlObject>, ICloneable
Public Interface IErlObject
    Inherits IComparable, IComparable(Of IErlObject), IEquatable(Of IErlObject),
    ICloneable
Public Interface IErlObject
    Inherits IComparable, IComparable(Of IErlObject), IEquatable(Of IErlObject),
    ICloneable
public interface class IErlObject : IComparable,
    IComparable<IErlObject^>, IEquatable<IErlObject^>, ICloneable
public interface class IErlObject : IComparable,
    IComparable<IErlObject^>, IEquatable<IErlObject^>, ICloneable
type IErlObject =
    interface
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
    end
type IErlObject =
    interface
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
    end
See Also
IErlObject Members
NFX.Erlang Namespace


IErlObject Members

IErlObject Members NFX Class Library

The IErlObject type exposes the following members.
Methods
 | Name | Description
Public method | Online Clone | Creates a new object that is a copy of the current instance. (Inherited from Online ICloneable.)
Public method | Clone | Clone an instance of Erlang object by performing deep copy of non-scalar terms and shallow copy of scalar terms
Public method | Online CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from Online IComparable.)
Public method | Online CompareTo(T) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from Online IComparable IErlObject .)
Public method | Online Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from Online IEquatable IErlObject .)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Public method | Matches | Perform pattern match on this Erlang term without binding any variables
Public method | Subst | Substitute variables in a given Erlang term provided a dictionary of bound values
Public method | Visit TAccumulate | Execute fun for every nested term
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Back to Top
Properties
 | Name | Description
Public property | IsScalar | Determines whether the underlying type is scalar or complex (i.e. tuple, list)
Public property | TypeOrder | Defines order of the Erlang term for comparison purposes
Public property | ValueAsBool |
Public property | ValueAsByteArray |
Public property | ValueAsChar |
Public property | ValueAsDateTime |
Public property | ValueAsDecimal |
Public property | ValueAsDouble |
Public property | ValueAsInt |
Public property | ValueAsLong |
Public property | ValueAsObject |
Public property | ValueAsString |
Public property | ValueAsTimeSpan |
Back to Top
See Also
IErlObject Interface
NFX.Erlang Namespace


IErlObject Methods

IErlObject Methods NFX Class Library

The IErlObject type exposes the following members.
Methods
 | Name | Description
Public method | Online Clone | Creates a new object that is a copy of the current instance. (Inherited from Online ICloneable.)
Public method | Clone | Clone an instance of Erlang object by performing deep copy of non-scalar terms and shallow copy of scalar terms
Public method | Online CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from Online IComparable.)
Public method | Online CompareTo(T) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from Online IComparable IErlObject .)
Public method | Online Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from Online IEquatable IErlObject .)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Public method | Matches | Perform pattern match on this Erlang term without binding any variables
Public method | Subst | Substitute variables in a given Erlang term provided a dictionary of bound values
Public method | Visit TAccumulate | Execute fun for every nested term
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Back to Top
See Also
IErlObject Interface
NFX.Erlang Namespace


IErlObject.Clone Method

IErlObject Clone Method NFX Class Library

Overload List
 | Name | Description
Public method | Online Clone | Creates a new object that is a copy of the current instance. (Inherited from Online ICloneable.)
Public method | Clone | Clone an instance of Erlang object by performing deep copy of non-scalar terms and shallow copy of scalar terms
Back to Top
See Also
IErlObject Interface
IErlObject Members
NFX.Erlang Namespace


IErlObject.Clone Method

IErlObject Clone Method NFX Class Library

Clone an instance of Erlang object by performing deep copy of non-scalar terms and shallow copy of scalar terms

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IErlObject Clone()
IErlObject Clone()
Function Clone As IErlObject
Function Clone As IErlObject
IErlObject^ Clone()
IErlObject^ Clone()
abstract Clone : unit -> IErlObject
abstract Clone : unit -> IErlObject

Return Value

Type: IErlObject
See Also
IErlObject Interface
IErlObject Members
Clone Overload
NFX.Erlang Namespace


IErlObject.Match Method

IErlObject Match Method NFX Class Library

Overload List
 | Name | Description
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.
Back to Top
See Also
IErlObject Interface
IErlObject Members
NFX.Erlang Namespace


IErlObject.Match Method (IErlObject)

IErlObject Match Method (IErlObject) NFX Class Library

Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ErlVarBind Match(
    IErlObject pattern
)
ErlVarBind Match(
    IErlObject pattern
)
Function Match (
    pattern As IErlObject
) As ErlVarBind
Function Match (
    pattern As IErlObject
) As ErlVarBind
ErlVarBind^ Match(
    IErlObject^ pattern
)
ErlVarBind^ Match(
    IErlObject^ pattern
)
abstract Match :
        pattern : IErlObject -> ErlVarBind
abstract Match :
        pattern : IErlObject -> ErlVarBind

Parameters

pattern
Type: NFX.Erlang IErlObject

Return Value

Type: ErlVarBind
See Also
IErlObject Interface
IErlObject Members
Match Overload
NFX.Erlang Namespace


IErlObject.Match Method (IErlObject, ErlVarBind)

IErlObject Match Method (IErlObject, ErlVarBind) NFX Class Library

[This is preliminary documentation and is subject to change.]

Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding.

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Match(
    IErlObject pattern,
    ErlVarBind binding
)
bool Match(
    IErlObject pattern,
    ErlVarBind binding
)
Function Match (
    pattern As IErlObject,
    binding As ErlVarBind
) As Boolean
Function Match (
    pattern As IErlObject,
    binding As ErlVarBind
) As Boolean
bool Match(
    IErlObject^ pattern,
    ErlVarBind^ binding
)
bool Match(
    IErlObject^ pattern,
    ErlVarBind^ binding
)
abstract Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool
abstract Match :
        pattern : IErlObject *
        binding : ErlVarBind -> bool

Parameters

pattern
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind

Return Value

Type: Online Boolean
See Also
IErlObject Interface
IErlObject Members
Match Overload
NFX.Erlang Namespace


IErlObject.Matches Method

IErlObject Matches Method NFX Class Library

Perform pattern match on this Erlang term without binding any variables

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Matches(
    IErlObject pattern
)
bool Matches(
    IErlObject pattern
)
Function Matches (
    pattern As IErlObject
) As Boolean
Function Matches (
    pattern As IErlObject
) As Boolean
bool Matches(
    IErlObject^ pattern
)
bool Matches(
    IErlObject^ pattern
)
abstract Matches :
        pattern : IErlObject -> bool
abstract Matches :
        pattern : IErlObject -> bool

Parameters

pattern
Type: NFX.Erlang IErlObject

Return Value

Type: Online Boolean
See Also
IErlObject Interface
IErlObject Members
NFX.Erlang Namespace


IErlObject.Subst Method

IErlObject Subst Method NFX Class Library

Substitute variables in a given Erlang term provided a dictionary of bound values

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Subst(
    ref IErlObject term,
    ErlVarBind binding
)
bool Subst(
    ref IErlObject term,
    ErlVarBind binding
)
Function Subst (
    ByRef term As IErlObject,
    binding As ErlVarBind
) As Boolean
Function Subst (
    ByRef term As IErlObject,
    binding As ErlVarBind
) As Boolean
bool Subst(
    IErlObject^% term,
    ErlVarBind^ binding
)
bool Subst(
    IErlObject^% term,
    ErlVarBind^ binding
)
abstract Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool
abstract Subst :
        term : IErlObject byref *
        binding : ErlVarBind -> bool

Parameters

term
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind

Return Value

Type: Online Boolean
See Also
IErlObject Interface
IErlObject Members
NFX.Erlang Namespace


IErlObject.Visit(TAccumulate) Method

IErlObject Visit TAccumulate Method NFX Class Library

Execute fun for every nested term

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
TAccumulate Visit<TAccumulate>(
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
TAccumulate Visit<TAccumulate>(
    TAccumulate acc,
    Func<TAccumulate, IErlObject, TAccumulate> fun
)
Function Visit(Of TAccumulate) (
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
Function Visit(Of TAccumulate) (
    acc As TAccumulate,
    fun As Func(Of TAccumulate, IErlObject, TAccumulate)
) As TAccumulate
generic<typename TAccumulate>
TAccumulate Visit(
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
)
generic<typename TAccumulate>
TAccumulate Visit(
    TAccumulate acc,
    Func<TAccumulate, IErlObject^, TAccumulate>^ fun
)
abstract Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate
abstract Visit :
        acc : 'TAccumulate *
        fun : Func<'TAccumulate, IErlObject, 'TAccumulate> -> 'TAccumulate

Parameters

acc
Type: TAccumulate
fun
Type: Online System Func TAccumulate, IErlObject, TAccumulate
Type Parameters
TAccumulate

Return Value

Type: TAccumulate
See Also
IErlObject Interface
IErlObject Members
NFX.Erlang Namespace


IErlObject Properties

IErlObject Properties NFX Class Library

The IErlObject type exposes the following members.
Properties
 | Name | Description
Public property | IsScalar | Determines whether the underlying type is scalar or complex (i.e. tuple, list)
Public property | TypeOrder | Defines order of the Erlang term for comparison purposes
Public property | ValueAsBool |
Public property | ValueAsByteArray |
Public property | ValueAsChar |
Public property | ValueAsDateTime |
Public property | ValueAsDecimal |
Public property | ValueAsDouble |
Public property | ValueAsInt |
Public property | ValueAsLong |
Public property | ValueAsObject |
Public property | ValueAsString |
Public property | ValueAsTimeSpan |
Back to Top
See Also
IErlObject Interface
NFX.Erlang Namespace


IErlObject.IsScalar Property

IErlObject IsScalar Property NFX Class Library

Determines whether the underlying type is scalar or complex (i.e. tuple, list)

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsScalar { get; }
bool IsScalar { get; }
ReadOnly Property IsScalar As Boolean
    Get
ReadOnly Property IsScalar As Boolean
    Get
property bool IsScalar {
    bool get ();
}
property bool IsScalar {
    bool get ();
}
abstract IsScalar : bool with get
abstract IsScalar : bool with get

Property Value

Type: Online Boolean
See Also
IErlObject Interface
IErlObject Members
NFX.Erlang Namespace


IErlObject.TypeOrder Property

IErlObject TypeOrder Property NFX Class Library

Defines order of the Erlang term for comparison purposes

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ErlTypeOrder TypeOrder { get; }
ErlTypeOrder TypeOrder { get; }
ReadOnly Property TypeOrder As ErlTypeOrder
    Get
ReadOnly Property TypeOrder As ErlTypeOrder
    Get
property ErlTypeOrder TypeOrder {
    ErlTypeOrder get ();
}
property ErlTypeOrder TypeOrder {
    ErlTypeOrder get ();
}
abstract TypeOrder : ErlTypeOrder with get
abstract TypeOrder : ErlTypeOrder with get

Property Value

Type: ErlTypeOrder
See Also
IErlObject Interface
IErlObject Members
NFX.Erlang Namespace


IErlObject.ValueAsBool Property

IErlObject ValueAsBool Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool ValueAsBool { get; }
bool ValueAsBool { get; }
ReadOnly Property ValueAsBool As Boolean
    Get
ReadOnly Property ValueAsBool As Boolean
    Get
property bool ValueAsBool {
    bool get ();
}
property bool ValueAsBool {
    bool get ();
}
abstract ValueAsBool : bool with get
abstract ValueAsBool : bool with get

Property Value

Type: Online Boolean
See Also
IErlObject Interface
IErlObject Members
NFX.Erlang Namespace


IErlObject.ValueAsByteArray Property

IErlObject ValueAsByteArray Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
byte[] ValueAsByteArray { get; }
byte[] ValueAsByteArray { get; }
ReadOnly Property ValueAsByteArray As Byte()
    Get
ReadOnly Property ValueAsByteArray As Byte()
    Get
property array<unsigned char>^ ValueAsByteArray {
    array<unsigned char>^ get ();
}
property array<unsigned char>^ ValueAsByteArray {
    array<unsigned char>^ get ();
}
abstract ValueAsByteArray : byte[] with get
abstract ValueAsByteArray : byte[] with get

Property Value

Type: Online Byte
See Also
IErlObject Interface
IErlObject Members
NFX.Erlang Namespace


IErlObject.ValueAsChar Property

IErlObject ValueAsChar Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
char ValueAsChar { get; }
char ValueAsChar { get; }
ReadOnly Property ValueAsChar As Char
    Get
ReadOnly Property ValueAsChar As Char
    Get
property wchar_t ValueAsChar {
    wchar_t get ();
}
property wchar_t ValueAsChar {
    wchar_t get ();
}
abstract ValueAsChar : char with get
abstract ValueAsChar : char with get

Property Value

Type: Online Char
See Also
IErlObject Interface
IErlObject Members
NFX.Erlang Namespace


IErlObject.ValueAsDateTime Property

IErlObject ValueAsDateTime Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
DateTime ValueAsDateTime { get; }
DateTime ValueAsDateTime { get; }
ReadOnly Property ValueAsDateTime As DateTime
    Get
ReadOnly Property ValueAsDateTime As DateTime
    Get
property DateTime ValueAsDateTime {
    DateTime get ();
}
property DateTime ValueAsDateTime {
    DateTime get ();
}
abstract ValueAsDateTime : DateTime with get
abstract ValueAsDateTime : DateTime with get

Property Value

Type: Online DateTime
See Also
IErlObject Interface
IErlObject Members
NFX.Erlang Namespace


IErlObject.ValueAsDecimal Property

IErlObject ValueAsDecimal Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
decimal ValueAsDecimal { get; }
decimal ValueAsDecimal { get; }
ReadOnly Property ValueAsDecimal As Decimal
    Get
ReadOnly Property ValueAsDecimal As Decimal
    Get
property Decimal ValueAsDecimal {
    Decimal get ();
}
property Decimal ValueAsDecimal {
    Decimal get ();
}
abstract ValueAsDecimal : decimal with get
abstract ValueAsDecimal : decimal with get

Property Value

Type: Online Decimal
See Also
IErlObject Interface
IErlObject Members
NFX.Erlang Namespace


IErlObject.ValueAsDouble Property

IErlObject ValueAsDouble Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
double ValueAsDouble { get; }
double ValueAsDouble { get; }
ReadOnly Property ValueAsDouble As Double
    Get
ReadOnly Property ValueAsDouble As Double
    Get
property double ValueAsDouble {
    double get ();
}
property double ValueAsDouble {
    double get ();
}
abstract ValueAsDouble : float with get
abstract ValueAsDouble : float with get

Property Value

Type: Online Double
See Also
IErlObject Interface
IErlObject Members
NFX.Erlang Namespace


IErlObject.ValueAsInt Property

IErlObject ValueAsInt Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int ValueAsInt { get; }
int ValueAsInt { get; }
ReadOnly Property ValueAsInt As Integer
    Get
ReadOnly Property ValueAsInt As Integer
    Get
property int ValueAsInt {
    int get ();
}
property int ValueAsInt {
    int get ();
}
abstract ValueAsInt : int with get
abstract ValueAsInt : int with get

Property Value

Type: Online Int32
See Also
IErlObject Interface
IErlObject Members
NFX.Erlang Namespace


IErlObject.ValueAsLong Property

IErlObject ValueAsLong Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
long ValueAsLong { get; }
long ValueAsLong { get; }
ReadOnly Property ValueAsLong As Long
    Get
ReadOnly Property ValueAsLong As Long
    Get
property long long ValueAsLong {
    long long get ();
}
property long long ValueAsLong {
    long long get ();
}
abstract ValueAsLong : int64 with get
abstract ValueAsLong : int64 with get

Property Value

Type: Online Int64
See Also
IErlObject Interface
IErlObject Members
NFX.Erlang Namespace


IErlObject.ValueAsObject Property

IErlObject ValueAsObject Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object ValueAsObject { get; }
Object ValueAsObject { get; }
ReadOnly Property ValueAsObject As Object
    Get
ReadOnly Property ValueAsObject As Object
    Get
property Object^ ValueAsObject {
    Object^ get ();
}
property Object^ ValueAsObject {
    Object^ get ();
}
abstract ValueAsObject : Object with get
abstract ValueAsObject : Object with get

Property Value

Type: Online Object
See Also
IErlObject Interface
IErlObject Members
NFX.Erlang Namespace


IErlObject.ValueAsString Property

IErlObject ValueAsString Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string ValueAsString { get; }
string ValueAsString { get; }
ReadOnly Property ValueAsString As String
    Get
ReadOnly Property ValueAsString As String
    Get
property String^ ValueAsString {
    String^ get ();
}
property String^ ValueAsString {
    String^ get ();
}
abstract ValueAsString : string with get
abstract ValueAsString : string with get

Property Value

Type: Online String
See Also
IErlObject Interface
IErlObject Members
NFX.Erlang Namespace


IErlObject.ValueAsTimeSpan Property

IErlObject ValueAsTimeSpan Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
TimeSpan ValueAsTimeSpan { get; }
TimeSpan ValueAsTimeSpan { get; }
ReadOnly Property ValueAsTimeSpan As TimeSpan
    Get
ReadOnly Property ValueAsTimeSpan As TimeSpan
    Get
property TimeSpan ValueAsTimeSpan {
    TimeSpan get ();
}
property TimeSpan ValueAsTimeSpan {
    TimeSpan get ();
}
abstract ValueAsTimeSpan : TimeSpan with get
abstract ValueAsTimeSpan : TimeSpan with get

Property Value

Type: Online TimeSpan
See Also
IErlObject Interface
IErlObject Members
NFX.Erlang Namespace


IErlObject(T) Interface

IErlObject T Interface NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IErlObject<T> : IErlObject,
    IComparable, IComparable<IErlObject>, IEquatable<IErlObject>,
    ICloneable
public interface IErlObject<T> : IErlObject,
    IComparable, IComparable<IErlObject>, IEquatable<IErlObject>,
    ICloneable
Public Interface IErlObject(Of T)
    Inherits IErlObject, IComparable, IComparable(Of IErlObject),
    IEquatable(Of IErlObject), ICloneable
Public Interface IErlObject(Of T)
    Inherits IErlObject, IComparable, IComparable(Of IErlObject),
    IEquatable(Of IErlObject), ICloneable
generic<typename T>
public interface class IErlObject : IErlObject,
    IComparable, IComparable<IErlObject^>, IEquatable<IErlObject^>,
    ICloneable
generic<typename T>
public interface class IErlObject : IErlObject,
    IComparable, IComparable<IErlObject^>, IEquatable<IErlObject^>,
    ICloneable
type IErlObject<'T> =
    interface
        interface IErlObject
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
    end
type IErlObject<'T> =
    interface
        interface IErlObject
        interface IComparable
        interface IComparable<IErlObject>
        interface IEquatable<IErlObject>
        interface ICloneable
    end
Type Parameters
T
See Also
IErlObject T Members
NFX.Erlang Namespace


IErlObject(T) Members

IErlObject T Members NFX Class Library

The IErlObject T type exposes the following members.
Methods
 | Name | Description
Public method | Clone | Clone an instance of Erlang object by performing deep copy of non-scalar terms and shallow copy of scalar terms (Inherited from IErlObject.)
Public method | Online Clone | Creates a new object that is a copy of the current instance. (Inherited from Online ICloneable.)
Public method | Online CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from Online IComparable.)
Public method | Online CompareTo(T) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from Online IComparable IErlObject .)
Public method | Online Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from Online IEquatable IErlObject .)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern (Inherited from IErlObject.)
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding. (Inherited from IErlObject.)
Public method | Matches | Perform pattern match on this Erlang term without binding any variables (Inherited from IErlObject.)
Public method | Subst | Substitute variables in a given Erlang term provided a dictionary of bound values (Inherited from IErlObject.)
Public method | Visit TAccumulate | Execute fun for every nested term (Inherited from IErlObject.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Back to Top
Properties
 | Name | Description
Public property | IsScalar | Determines whether the underlying type is scalar or complex (i.e. tuple, list) (Inherited from IErlObject.)
Public property | TypeOrder | Defines order of the Erlang term for comparison purposes (Inherited from IErlObject.)
Public property | Value |
Public property | ValueAsBool | (Inherited from IErlObject.)
Public property | ValueAsByteArray | (Inherited from IErlObject.)
Public property | ValueAsChar | (Inherited from IErlObject.)
Public property | ValueAsDateTime | (Inherited from IErlObject.)
Public property | ValueAsDecimal | (Inherited from IErlObject.)
Public property | ValueAsDouble | (Inherited from IErlObject.)
Public property | ValueAsInt | (Inherited from IErlObject.)
Public property | ValueAsLong | (Inherited from IErlObject.)
Public property | ValueAsObject | (Inherited from IErlObject.)
Public property | ValueAsString | (Inherited from IErlObject.)
Public property | ValueAsTimeSpan | (Inherited from IErlObject.)
Back to Top
See Also
IErlObject T Interface
NFX.Erlang Namespace


IErlObject(T) Methods

IErlObject T Methods NFX Class Library

The IErlObject T type exposes the following members.
Methods
 | Name | Description
Public method | Clone | Clone an instance of Erlang object by performing deep copy of non-scalar terms and shallow copy of scalar terms (Inherited from IErlObject.)
Public method | Online Clone | Creates a new object that is a copy of the current instance. (Inherited from Online ICloneable.)
Public method | Online CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from Online IComparable.)
Public method | Online CompareTo(T) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from Online IComparable IErlObject .)
Public method | Online Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from Online IEquatable IErlObject .)
Public method | Match(IErlObject) | Perform pattern match on this Erlang term returning null if match fails or a dictionary of matched variables bound in the pattern (Inherited from IErlObject.)
Public method | Match(IErlObject, ErlVarBind) | Perform pattern match on this Erlang term, storing matched variables found in the pattern into the binding. (Inherited from IErlObject.)
Public method | Matches | Perform pattern match on this Erlang term without binding any variables (Inherited from IErlObject.)
Public method | Subst | Substitute variables in a given Erlang term provided a dictionary of bound values (Inherited from IErlObject.)
Public method | Visit TAccumulate | Execute fun for every nested term (Inherited from IErlObject.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsType | Tries to convert an Erlang term as specified native type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | IsInt | Determines if Erlang object is of type ErlByte or ErlLong (Defined by ErlObject.)
Public Extension Method | IsNull | Determines if Erlang object is NULL - that is ErlAtom.Undefined or null reference (Defined by ErlObject.)
Public Extension Method | Subst | Substibute all variables in the given object using provided binding and return the resulting object (Defined by ErlObject.)
Back to Top
See Also
IErlObject T Interface
NFX.Erlang Namespace


IErlObject(T) Properties

IErlObject T Properties NFX Class Library

The IErlObject T type exposes the following members.
Properties
 | Name | Description
Public property | IsScalar | Determines whether the underlying type is scalar or complex (i.e. tuple, list) (Inherited from IErlObject.)
Public property | TypeOrder | Defines order of the Erlang term for comparison purposes (Inherited from IErlObject.)
Public property | Value |
Public property | ValueAsBool | (Inherited from IErlObject.)
Public property | ValueAsByteArray | (Inherited from IErlObject.)
Public property | ValueAsChar | (Inherited from IErlObject.)
Public property | ValueAsDateTime | (Inherited from IErlObject.)
Public property | ValueAsDecimal | (Inherited from IErlObject.)
Public property | ValueAsDouble | (Inherited from IErlObject.)
Public property | ValueAsInt | (Inherited from IErlObject.)
Public property | ValueAsLong | (Inherited from IErlObject.)
Public property | ValueAsObject | (Inherited from IErlObject.)
Public property | ValueAsString | (Inherited from IErlObject.)
Public property | ValueAsTimeSpan | (Inherited from IErlObject.)
Back to Top
See Also
IErlObject T Interface
NFX.Erlang Namespace


IErlObject(T).Value Property

IErlObject T Value Property NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
T Value { get; }
T Value { get; }
ReadOnly Property Value As T
    Get
ReadOnly Property Value As T
    Get
property T Value {
    T get ();
}
property T Value {
    T get ();
}
abstract Value : 'T with get
abstract Value : 'T with get

Property Value

Type: T
See Also
IErlObject T Interface
IErlObject T Members
NFX.Erlang Namespace


IErlTransport Interface

IErlTransport Interface NFX Class Library

General interface of TCP transports (i.e. usual TCP channel or SSH tunneled TCP channel)

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IErlTransport : IDisposable
public interface IErlTransport : IDisposable
Public Interface IErlTransport
    Inherits IDisposable
Public Interface IErlTransport
    Inherits IDisposable
public interface class IErlTransport : IDisposable
public interface class IErlTransport : IDisposable
type IErlTransport =
    interface
        interface IDisposable
    end
type IErlTransport =
    interface
        interface IDisposable
    end
See Also
IErlTransport Members
NFX.Erlang Namespace


IErlTransport Members

IErlTransport Members NFX Class Library

The IErlTransport type exposes the following members.
Methods
 | Name | Description
Public method | Close | Close connection
Public method | Connect(String, Int32) | Connects to remote host:port
Public method | Connect(String, Int32, Int32) | Connects to remote host:port with a timeout in milliseconds
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | GetStream | Network stream
Public method | SetSocketOption | Sets cocket options
Back to Top
Properties
 | Name | Description
Public property | ConnectTimeout | ConnectTimeout in milliseconds
Public property | NoDelay | NoDelay socket
Public property | NodeName | Erlang node name
Public property | ReceiveBufferSize | Set receive buffer size
Public property | RemoteEndPoint | Remote endpoint
Public property | SendBufferSize | Set send buffer size
Public property | SSHAuthenticationType | Type of auth on SSH server. Valid values: "PublicKey", "Password".
Public property | SSHPrivateKeyFilePath | Private key file path (only for AuthenticationType = PublicKey) Required SSH2 ENCRYPTED PRIVATE KEY format.
Public property | SSHServerPort | Port of SSH server
Public property | SSHUserName | SSH user name
Back to Top
Events
 | Name | Description
Public event | Trace | Trace event
Back to Top
See Also
IErlTransport Interface
NFX.Erlang Namespace


IErlTransport Methods

IErlTransport Methods NFX Class Library

The IErlTransport type exposes the following members.
Methods
 | Name | Description
Public method | Close | Close connection
Public method | Connect(String, Int32) | Connects to remote host:port
Public method | Connect(String, Int32, Int32) | Connects to remote host:port with a timeout in milliseconds
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | GetStream | Network stream
Public method | SetSocketOption | Sets cocket options
Back to Top
See Also
IErlTransport Interface
NFX.Erlang Namespace


IErlTransport.Close Method

IErlTransport Close Method NFX Class Library

Close connection

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Close()
void Close()
Sub Close
Sub Close
void Close()
void Close()
abstract Close : unit -> unit
abstract Close : unit -> unit
See Also
IErlTransport Interface
IErlTransport Members
NFX.Erlang Namespace


IErlTransport.Connect Method

IErlTransport Connect Method NFX Class Library

Overload List
 | Name | Description
Public method | Connect(String, Int32) | Connects to remote host:port
Public method | Connect(String, Int32, Int32) | Connects to remote host:port with a timeout in milliseconds
Back to Top
See Also
IErlTransport Interface
IErlTransport Members
NFX.Erlang Namespace


IErlTransport.Connect Method (String, Int32)

IErlTransport Connect Method (String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Connects to remote host:port

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Connect(
    string host,
    int port
)
void Connect(
    string host,
    int port
)
Sub Connect (
    host As String,
    port As Integer
)
Sub Connect (
    host As String,
    port As Integer
)
void Connect(
    String^ host,
    int port
)
void Connect(
    String^ host,
    int port
)
abstract Connect :
        host : string *
        port : int -> unit
abstract Connect :
        host : string *
        port : int -> unit

Parameters

host
Type: Online System String
port
Type: Online System Int32
See Also
IErlTransport Interface
IErlTransport Members
Connect Overload
NFX.Erlang Namespace


IErlTransport.Connect Method (String, Int32, Int32)

IErlTransport Connect Method (String, Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Connects to remote host:port with a timeout in milliseconds

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Connect(
    string host,
    int port,
    int timeoutMsec
)
void Connect(
    string host,
    int port,
    int timeoutMsec
)
Sub Connect (
    host As String,
    port As Integer,
    timeoutMsec As Integer
)
Sub Connect (
    host As String,
    port As Integer,
    timeoutMsec As Integer
)
void Connect(
    String^ host,
    int port,
    int timeoutMsec
)
void Connect(
    String^ host,
    int port,
    int timeoutMsec
)
abstract Connect :
        host : string *
        port : int *
        timeoutMsec : int -> unit
abstract Connect :
        host : string *
        port : int *
        timeoutMsec : int -> unit

Parameters

host
Type: Online System String
port
Type: Online System Int32
timeoutMsec
Type: Online System Int32
See Also
IErlTransport Interface
IErlTransport Members
Connect Overload
NFX.Erlang Namespace


IErlTransport.GetStream Method

IErlTransport GetStream Method NFX Class Library

Network stream

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Stream GetStream()
Stream GetStream()
Function GetStream As Stream
Function GetStream As Stream
Stream^ GetStream()
Stream^ GetStream()
abstract GetStream : unit -> Stream
abstract GetStream : unit -> Stream

Return Value

Type: Online Stream
See Also
IErlTransport Interface
IErlTransport Members
NFX.Erlang Namespace


IErlTransport.SetSocketOption Method

IErlTransport SetSocketOption Method NFX Class Library

Sets cocket options

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void SetSocketOption(
    SocketOptionLevel optionLevel,
    SocketOptionName optionName,
    bool optionValue
)
void SetSocketOption(
    SocketOptionLevel optionLevel,
    SocketOptionName optionName,
    bool optionValue
)
Sub SetSocketOption (
    optionLevel As SocketOptionLevel,
    optionName As SocketOptionName,
    optionValue As Boolean
)
Sub SetSocketOption (
    optionLevel As SocketOptionLevel,
    optionName As SocketOptionName,
    optionValue As Boolean
)
void SetSocketOption(
    SocketOptionLevel optionLevel,
    SocketOptionName optionName,
    bool optionValue
)
void SetSocketOption(
    SocketOptionLevel optionLevel,
    SocketOptionName optionName,
    bool optionValue
)
abstract SetSocketOption :
        optionLevel : SocketOptionLevel *
        optionName : SocketOptionName *
        optionValue : bool -> unit
abstract SetSocketOption :
        optionLevel : SocketOptionLevel *
        optionName : SocketOptionName *
        optionValue : bool -> unit

Parameters

optionLevel
Type: Online System.Net.Sockets SocketOptionLevel
optionName
Type: Online System.Net.Sockets SocketOptionName
optionValue
Type: Online System Boolean
See Also
IErlTransport Interface
IErlTransport Members
NFX.Erlang Namespace


IErlTransport Properties

IErlTransport Properties NFX Class Library

The IErlTransport type exposes the following members.
Properties
 | Name | Description
Public property | ConnectTimeout | ConnectTimeout in milliseconds
Public property | NoDelay | NoDelay socket
Public property | NodeName | Erlang node name
Public property | ReceiveBufferSize | Set receive buffer size
Public property | RemoteEndPoint | Remote endpoint
Public property | SendBufferSize | Set send buffer size
Public property | SSHAuthenticationType | Type of auth on SSH server. Valid values: "PublicKey", "Password".
Public property | SSHPrivateKeyFilePath | Private key file path (only for AuthenticationType = PublicKey) Required SSH2 ENCRYPTED PRIVATE KEY format.
Public property | SSHServerPort | Port of SSH server
Public property | SSHUserName | SSH user name
Back to Top
See Also
IErlTransport Interface
NFX.Erlang Namespace


IErlTransport.ConnectTimeout Property

IErlTransport ConnectTimeout Property NFX Class Library

ConnectTimeout in milliseconds

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int ConnectTimeout { get; set; }
int ConnectTimeout { get; set; }
Property ConnectTimeout As Integer
    Get
    Set
Property ConnectTimeout As Integer
    Get
    Set
property int ConnectTimeout {
    int get ();
    void set (int value);
}
property int ConnectTimeout {
    int get ();
    void set (int value);
}
abstract ConnectTimeout : int with get, set
abstract ConnectTimeout : int with get, set

Property Value

Type: Online Int32
See Also
IErlTransport Interface
IErlTransport Members
NFX.Erlang Namespace


IErlTransport.NoDelay Property

IErlTransport NoDelay Property NFX Class Library

NoDelay socket

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool NoDelay { get; set; }
bool NoDelay { get; set; }
Property NoDelay As Boolean
    Get
    Set
Property NoDelay As Boolean
    Get
    Set
property bool NoDelay {
    bool get ();
    void set (bool value);
}
property bool NoDelay {
    bool get ();
    void set (bool value);
}
abstract NoDelay : bool with get, set
abstract NoDelay : bool with get, set

Property Value

Type: Online Boolean
See Also
IErlTransport Interface
IErlTransport Members
NFX.Erlang Namespace


IErlTransport.NodeName Property

IErlTransport NodeName Property NFX Class Library

Erlang node name

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string NodeName { get; set; }
string NodeName { get; set; }
Property NodeName As String
    Get
    Set
Property NodeName As String
    Get
    Set
property String^ NodeName {
    String^ get ();
    void set (String^ value);
}
property String^ NodeName {
    String^ get ();
    void set (String^ value);
}
abstract NodeName : string with get, set
abstract NodeName : string with get, set

Property Value

Type: Online String
See Also
IErlTransport Interface
IErlTransport Members
NFX.Erlang Namespace


IErlTransport.ReceiveBufferSize Property

IErlTransport ReceiveBufferSize Property NFX Class Library

Set receive buffer size

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int ReceiveBufferSize { get; set; }
int ReceiveBufferSize { get; set; }
Property ReceiveBufferSize As Integer
    Get
    Set
Property ReceiveBufferSize As Integer
    Get
    Set
property int ReceiveBufferSize {
    int get ();
    void set (int value);
}
property int ReceiveBufferSize {
    int get ();
    void set (int value);
}
abstract ReceiveBufferSize : int with get, set
abstract ReceiveBufferSize : int with get, set

Property Value

Type: Online Int32
See Also
IErlTransport Interface
IErlTransport Members
NFX.Erlang Namespace


IErlTransport.RemoteEndPoint Property

IErlTransport RemoteEndPoint Property NFX Class Library

Remote endpoint

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
EndPoint RemoteEndPoint { get; }
EndPoint RemoteEndPoint { get; }
ReadOnly Property RemoteEndPoint As EndPoint
    Get
ReadOnly Property RemoteEndPoint As EndPoint
    Get
property EndPoint^ RemoteEndPoint {
    EndPoint^ get ();
}
property EndPoint^ RemoteEndPoint {
    EndPoint^ get ();
}
abstract RemoteEndPoint : EndPoint with get
abstract RemoteEndPoint : EndPoint with get

Property Value

Type: Online EndPoint
See Also
IErlTransport Interface
IErlTransport Members
NFX.Erlang Namespace


IErlTransport.SendBufferSize Property

IErlTransport SendBufferSize Property NFX Class Library

Set send buffer size

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int SendBufferSize { get; set; }
int SendBufferSize { get; set; }
Property SendBufferSize As Integer
    Get
    Set
Property SendBufferSize As Integer
    Get
    Set
property int SendBufferSize {
    int get ();
    void set (int value);
}
property int SendBufferSize {
    int get ();
    void set (int value);
}
abstract SendBufferSize : int with get, set
abstract SendBufferSize : int with get, set

Property Value

Type: Online Int32
See Also
IErlTransport Interface
IErlTransport Members
NFX.Erlang Namespace


IErlTransport.SSHAuthenticationType Property

IErlTransport SSHAuthenticationType Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Type of auth on SSH server. Valid values: "PublicKey", "Password".

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string SSHAuthenticationType { get; set; }
string SSHAuthenticationType { get; set; }
Property SSHAuthenticationType As String
    Get
    Set
Property SSHAuthenticationType As String
    Get
    Set
property String^ SSHAuthenticationType {
    String^ get ();
    void set (String^ value);
}
property String^ SSHAuthenticationType {
    String^ get ();
    void set (String^ value);
}
abstract SSHAuthenticationType : string with get, set
abstract SSHAuthenticationType : string with get, set

Property Value

Type: Online String
See Also
IErlTransport Interface
IErlTransport Members
NFX.Erlang Namespace


IErlTransport.SSHPrivateKeyFilePath Property

IErlTransport SSHPrivateKeyFilePath Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Private key file path (only for AuthenticationType = PublicKey) Required SSH2 ENCRYPTED PRIVATE KEY format.

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string SSHPrivateKeyFilePath { get; set; }
string SSHPrivateKeyFilePath { get; set; }
Property SSHPrivateKeyFilePath As String
    Get
    Set
Property SSHPrivateKeyFilePath As String
    Get
    Set
property String^ SSHPrivateKeyFilePath {
    String^ get ();
    void set (String^ value);
}
property String^ SSHPrivateKeyFilePath {
    String^ get ();
    void set (String^ value);
}
abstract SSHPrivateKeyFilePath : string with get, set
abstract SSHPrivateKeyFilePath : string with get, set

Property Value

Type: Online String
See Also
IErlTransport Interface
IErlTransport Members
NFX.Erlang Namespace


IErlTransport.SSHServerPort Property

IErlTransport SSHServerPort Property NFX Class Library

Port of SSH server

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int SSHServerPort { get; set; }
int SSHServerPort { get; set; }
Property SSHServerPort As Integer
    Get
    Set
Property SSHServerPort As Integer
    Get
    Set
property int SSHServerPort {
    int get ();
    void set (int value);
}
property int SSHServerPort {
    int get ();
    void set (int value);
}
abstract SSHServerPort : int with get, set
abstract SSHServerPort : int with get, set

Property Value

Type: Online Int32
See Also
IErlTransport Interface
IErlTransport Members
NFX.Erlang Namespace


IErlTransport.SSHUserName Property

IErlTransport SSHUserName Property NFX Class Library

SSH user name

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string SSHUserName { get; set; }
string SSHUserName { get; set; }
Property SSHUserName As String
    Get
    Set
Property SSHUserName As String
    Get
    Set
property String^ SSHUserName {
    String^ get ();
    void set (String^ value);
}
property String^ SSHUserName {
    String^ get ();
    void set (String^ value);
}
abstract SSHUserName : string with get, set
abstract SSHUserName : string with get, set

Property Value

Type: Online String
See Also
IErlTransport Interface
IErlTransport Members
NFX.Erlang Namespace


IErlTransport Events

IErlTransport Events NFX Class Library

The IErlTransport type exposes the following members.
Events
 | Name | Description
Public event | Trace | Trace event
Back to Top
See Also
IErlTransport Interface
NFX.Erlang Namespace


IErlTransport.Trace Event

IErlTransport Trace Event NFX Class Library

Trace event

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
event TraceEventHandler Trace
event TraceEventHandler Trace
Event Trace As TraceEventHandler
Event Trace As TraceEventHandler
 event TraceEventHandler^ Trace {
    void add (TraceEventHandler^ value);
    void remove (TraceEventHandler^ value);
}
 event TraceEventHandler^ Trace {
    void add (TraceEventHandler^ value);
    void remove (TraceEventHandler^ value);
}
abstract Trace : IEvent<TraceEventHandler,
    EventArgs>
abstract Trace : IEvent<TraceEventHandler,
    EventArgs>

Value

Type: NFX.Erlang TraceEventHandler
See Also
IErlTransport Interface
IErlTransport Members
NFX.Erlang Namespace


IoOutputEventHandler Delegate

IoOutputEventHandler Delegate NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void IoOutputEventHandler(
    ErlLocalNode sender,
    ErlAtom encoding,
    IErlObject output
)
public delegate void IoOutputEventHandler(
    ErlLocalNode sender,
    ErlAtom encoding,
    IErlObject output
)
Public Delegate Sub IoOutputEventHandler (
    sender As ErlLocalNode,
    encoding As ErlAtom,
    output As IErlObject
)
Public Delegate Sub IoOutputEventHandler (
    sender As ErlLocalNode,
    encoding As ErlAtom,
    output As IErlObject
)
public delegate void IoOutputEventHandler(
    ErlLocalNode^ sender,
    ErlAtom encoding,
    IErlObject^ output
)
public delegate void IoOutputEventHandler(
    ErlLocalNode^ sender,
    ErlAtom encoding,
    IErlObject^ output
)
type IoOutputEventHandler =
    delegate of
        sender : ErlLocalNode *
        encoding : ErlAtom *
        output : IErlObject -> unit
type IoOutputEventHandler =
    delegate of
        sender : ErlLocalNode *
        encoding : ErlAtom *
        output : IErlObject -> unit

Parameters

sender
Type: NFX.Erlang ErlLocalNode
encoding
Type: NFX.Erlang ErlAtom
output
Type: NFX.Erlang IErlObject
See Also
NFX.Erlang Namespace


IQueable Interface

IQueable Interface NFX Class Library

Represents a interface that messages enqueued to ErlMbox must support

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IQueable
public interface IQueable
Public Interface IQueable
Public Interface IQueable
public interface class IQueable
public interface class IQueable
type IQueable =  interface end
type IQueable =  interface end
See Also
NFX.Erlang Namespace


MailboxMsgEventHandler Delegate

MailboxMsgEventHandler Delegate NFX Class Library

Indicates arrival of a message to a given mailbox. The msg is of type ErlMsg, ErlExit, ErlDown, or ErlException.

Return Value

Type: Online Boolean
If returns true, the message is handled, and will not be put in the mailbox's queue. Otherwise, the message will be enqueued in the mailbox's queue.

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate bool MailboxMsgEventHandler(
    ErlMbox mailbox,
    IQueable msg
)
public delegate bool MailboxMsgEventHandler(
    ErlMbox mailbox,
    IQueable msg
)
Public Delegate Function MailboxMsgEventHandler (
    mailbox As ErlMbox,
    msg As IQueable
) As Boolean
Public Delegate Function MailboxMsgEventHandler (
    mailbox As ErlMbox,
    msg As IQueable
) As Boolean
public delegate bool MailboxMsgEventHandler(
    ErlMbox^ mailbox,
    IQueable^ msg
)
public delegate bool MailboxMsgEventHandler(
    ErlMbox^ mailbox,
    IQueable^ msg
)
type MailboxMsgEventHandler =
    delegate of
        mailbox : ErlMbox *
        msg : IQueable -> bool
type MailboxMsgEventHandler =
    delegate of
        mailbox : ErlMbox *
        msg : IQueable -> bool

Parameters

mailbox
Type: NFX.Erlang ErlMbox
msg
Type: NFX.Erlang IQueable

Return Value

Type: Online Boolean
See Also
NFX.Erlang Namespace


NodeStatusChangeEventHandler Delegate

NodeStatusChangeEventHandler Delegate NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void NodeStatusChangeEventHandler(
    ErlLocalNode sender,
    ErlAtom node,
    bool up,
    Object info
)
public delegate void NodeStatusChangeEventHandler(
    ErlLocalNode sender,
    ErlAtom node,
    bool up,
    Object info
)
Public Delegate Sub NodeStatusChangeEventHandler (
    sender As ErlLocalNode,
    node As ErlAtom,
    up As Boolean,
    info As Object
)
Public Delegate Sub NodeStatusChangeEventHandler (
    sender As ErlLocalNode,
    node As ErlAtom,
    up As Boolean,
    info As Object
)
public delegate void NodeStatusChangeEventHandler(
    ErlLocalNode^ sender,
    ErlAtom node,
    bool up,
    Object^ info
)
public delegate void NodeStatusChangeEventHandler(
    ErlLocalNode^ sender,
    ErlAtom node,
    bool up,
    Object^ info
)
type NodeStatusChangeEventHandler =
    delegate of
        sender : ErlLocalNode *
        node : ErlAtom *
        up : bool *
        info : Object -> unit
type NodeStatusChangeEventHandler =
    delegate of
        sender : ErlLocalNode *
        node : ErlAtom *
        up : bool *
        info : Object -> unit

Parameters

sender
Type: NFX.Erlang ErlLocalNode
node
Type: NFX.Erlang ErlAtom
up
Type: Online System Boolean
info
Type: Online System Object
See Also
NFX.Erlang Namespace


NotEnoughDataException Class

NotEnoughDataException Class NFX Class Library

Exception thrown when decoding an Erlang term if there's not enough data in the buffer to construct the term
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Erlang ErlException
NFX.Erlang NotEnoughDataException

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NotEnoughDataException : ErlException
public class NotEnoughDataException : ErlException
Public Class NotEnoughDataException
    Inherits ErlException
Public Class NotEnoughDataException
    Inherits ErlException
public ref class NotEnoughDataException : public ErlException
public ref class NotEnoughDataException : public ErlException
type NotEnoughDataException =
    class
        inherit ErlException
    end
type NotEnoughDataException =
    class
        inherit ErlException
    end
See Also
NotEnoughDataException Members
NFX.Erlang Namespace


NotEnoughDataException Members

NotEnoughDataException Members NFX Class Library

The NotEnoughDataException type exposes the following members.
Constructors
 | Name | Description
Public method | NotEnoughDataException | Initializes a new instance of the NotEnoughDataException class
Public method | NotEnoughDataException(String) | Initializes a new instance of the NotEnoughDataException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
NotEnoughDataException Class
NFX.Erlang Namespace


NotEnoughDataException Constructor

NotEnoughDataException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | NotEnoughDataException | Initializes a new instance of the NotEnoughDataException class
Public method | NotEnoughDataException(String) | Initializes a new instance of the NotEnoughDataException class
Back to Top
See Also
NotEnoughDataException Class
NotEnoughDataException Members
NFX.Erlang Namespace


NotEnoughDataException Constructor

NotEnoughDataException Constructor NFX Class Library

Initializes a new instance of the NotEnoughDataException class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NotEnoughDataException()
public NotEnoughDataException()
Public Sub New
Public Sub New
public:
NotEnoughDataException()
public:
NotEnoughDataException()
new : unit -> NotEnoughDataException
new : unit -> NotEnoughDataException
See Also
NotEnoughDataException Class
NotEnoughDataException Members
NotEnoughDataException Overload
NFX.Erlang Namespace


NotEnoughDataException Constructor (String)

NotEnoughDataException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NotEnoughDataException class

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NotEnoughDataException(
    string reason
)
public NotEnoughDataException(
    string reason
)
Public Sub New (
    reason As String
)
Public Sub New (
    reason As String
)
public:
NotEnoughDataException(
    String^ reason
)
public:
NotEnoughDataException(
    String^ reason
)
new :
        reason : string -> NotEnoughDataException
new :
        reason : string -> NotEnoughDataException

Parameters

reason
Type: Online System String
See Also
NotEnoughDataException Class
NotEnoughDataException Members
NotEnoughDataException Overload
NFX.Erlang Namespace


NotEnoughDataException Methods

NotEnoughDataException Methods NFX Class Library

The NotEnoughDataException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
NotEnoughDataException Class
NFX.Erlang Namespace


NotEnoughDataException Properties

NotEnoughDataException Properties NFX Class Library

The NotEnoughDataException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
NotEnoughDataException Class
NFX.Erlang Namespace


NotEnoughDataException Events

NotEnoughDataException Events NFX Class Library

The NotEnoughDataException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
NotEnoughDataException Class
NFX.Erlang Namespace


PatternMatchFunc Delegate

PatternMatchFunc Delegate NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate IErlObject PatternMatchFunc(
    ErlPatternMatcher..::..Pattern pattern,
    IErlObject term,
    ErlVarBind binding,
    params Object[] args
)
public delegate IErlObject PatternMatchFunc(
    ErlPatternMatcher..::..Pattern pattern,
    IErlObject term,
    ErlVarBind binding,
    params Object[] args
)
Public Delegate Function PatternMatchFunc (
    pattern As ErlPatternMatcher..::..Pattern,
    term As IErlObject,
    binding As ErlVarBind,
    ParamArray args As Object()
) As IErlObject
Public Delegate Function PatternMatchFunc (
    pattern As ErlPatternMatcher..::..Pattern,
    term As IErlObject,
    binding As ErlVarBind,
    ParamArray args As Object()
) As IErlObject
public delegate IErlObject^ PatternMatchFunc(
    ErlPatternMatcher..::..Pattern pattern,
    IErlObject^ term,
    ErlVarBind^ binding,
    ... array<Object^>^ args
)
public delegate IErlObject^ PatternMatchFunc(
    ErlPatternMatcher..::..Pattern pattern,
    IErlObject^ term,
    ErlVarBind^ binding,
    ... array<Object^>^ args
)
type PatternMatchFunc =
    delegate of
        pattern : ErlPatternMatcher..::..Pattern *
        term : IErlObject *
        binding : ErlVarBind *
        args : Object[] -> IErlObject
type PatternMatchFunc =
    delegate of
        pattern : ErlPatternMatcher..::..Pattern *
        term : IErlObject *
        binding : ErlVarBind *
        args : Object[] -> IErlObject

Parameters

pattern
Type: NFX.Erlang ErlPatternMatcher Pattern
term
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind
args
Type: Online System Object

Return Value

Type: IErlObject
See Also
NFX.Erlang Namespace


PatternMatchFunc(TContext) Delegate

PatternMatchFunc TContext Delegate NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate IErlObject PatternMatchFunc<TContext>(
    TContext ctx,
    ErlPatternMatcher..::..Pattern pattern,
    IErlObject term,
    ErlVarBind binding,
    params Object[] args
)
public delegate IErlObject PatternMatchFunc<TContext>(
    TContext ctx,
    ErlPatternMatcher..::..Pattern pattern,
    IErlObject term,
    ErlVarBind binding,
    params Object[] args
)
Public Delegate Function PatternMatchFunc(Of TContext) (
    ctx As TContext,
    pattern As ErlPatternMatcher..::..Pattern,
    term As IErlObject,
    binding As ErlVarBind,
    ParamArray args As Object()
) As IErlObject
Public Delegate Function PatternMatchFunc(Of TContext) (
    ctx As TContext,
    pattern As ErlPatternMatcher..::..Pattern,
    term As IErlObject,
    binding As ErlVarBind,
    ParamArray args As Object()
) As IErlObject
generic<typename TContext>
public delegate IErlObject^ PatternMatchFunc(
    TContext ctx,
    ErlPatternMatcher..::..Pattern pattern,
    IErlObject^ term,
    ErlVarBind^ binding,
    ... array<Object^>^ args
)
generic<typename TContext>
public delegate IErlObject^ PatternMatchFunc(
    TContext ctx,
    ErlPatternMatcher..::..Pattern pattern,
    IErlObject^ term,
    ErlVarBind^ binding,
    ... array<Object^>^ args
)
type PatternMatchFunc =
    delegate of
        ctx : 'TContext *
        pattern : ErlPatternMatcher..::..Pattern *
        term : IErlObject *
        binding : ErlVarBind *
        args : Object[] -> IErlObject
type PatternMatchFunc =
    delegate of
        ctx : 'TContext *
        pattern : ErlPatternMatcher..::..Pattern *
        term : IErlObject *
        binding : ErlVarBind *
        args : Object[] -> IErlObject

Parameters

ctx
Type: TContext
pattern
Type: NFX.Erlang ErlPatternMatcher Pattern
term
Type: NFX.Erlang IErlObject
binding
Type: NFX.Erlang ErlVarBind
args
Type: Online System Object
Type Parameters
TContext

Return Value

Type: IErlObject
See Also
NFX.Erlang Namespace


ReadWriteEventHandler Delegate

ReadWriteEventHandler Delegate NFX Class Library

Delegate called on read/write from socket

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void ReadWriteEventHandler(
    ErlLocalNode sender,
    ErlAbstractConnection con,
    Direction op,
    int lastBytes,
    long totalBytes,
    long totalMsgs
)
public delegate void ReadWriteEventHandler(
    ErlLocalNode sender,
    ErlAbstractConnection con,
    Direction op,
    int lastBytes,
    long totalBytes,
    long totalMsgs
)
Public Delegate Sub ReadWriteEventHandler (
    sender As ErlLocalNode,
    con As ErlAbstractConnection,
    op As Direction,
    lastBytes As Integer,
    totalBytes As Long,
    totalMsgs As Long
)
Public Delegate Sub ReadWriteEventHandler (
    sender As ErlLocalNode,
    con As ErlAbstractConnection,
    op As Direction,
    lastBytes As Integer,
    totalBytes As Long,
    totalMsgs As Long
)
public delegate void ReadWriteEventHandler(
    ErlLocalNode^ sender,
    ErlAbstractConnection^ con,
    Direction op,
    int lastBytes,
    long long totalBytes,
    long long totalMsgs
)
public delegate void ReadWriteEventHandler(
    ErlLocalNode^ sender,
    ErlAbstractConnection^ con,
    Direction op,
    int lastBytes,
    long long totalBytes,
    long long totalMsgs
)
type ReadWriteEventHandler =
    delegate of
        sender : ErlLocalNode *
        con : ErlAbstractConnection *
        op : Direction *
        lastBytes : int *
        totalBytes : int64 *
        totalMsgs : int64 -> unit
type ReadWriteEventHandler =
    delegate of
        sender : ErlLocalNode *
        con : ErlAbstractConnection *
        op : Direction *
        lastBytes : int *
        totalBytes : int64 *
        totalMsgs : int64 -> unit

Parameters

sender
Type: NFX.Erlang ErlLocalNode
con
Type: NFX.Erlang ErlAbstractConnection
op
Type: NFX.Erlang Direction
lastBytes
Type: Online System Int32
totalBytes
Type: Online System Int64
totalMsgs
Type: Online System Int64
See Also
NFX.Erlang Namespace


StringConsts Class

StringConsts Class NFX Class Library

A dictionary of framework text messages. Localization may be done in this class in future
Inheritance Hierarchy
Online System Object
NFX.Erlang StringConsts

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static class StringConsts
internal static class StringConsts
Friend NotInheritable Class StringConsts
Friend NotInheritable Class StringConsts
internal ref class StringConsts abstract sealed
internal ref class StringConsts abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StringConsts =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StringConsts =  class end
See Also
StringConsts Members
NFX.Erlang Namespace


StringConsts Members

StringConsts Members NFX Class Library

The StringConsts type exposes the following members.
Fields
Name | Description
ARGUMENT_ERROR |
CONFIGURATION_NAVIGATION_SECTION_REQUIRED_ERROR |
ERL_ATOM_SIZE_TOO_LONG_ERROR |
ERL_ATOM_TABLE_IS_FULL_ERROR |
ERL_BIG_INTEGER_OVERFLOW_ERROR |
ERL_CANNOT_CLONE_INSTANCE_ERROR |
ERL_CANNOT_CONVERT_TYPES_CYCLE_ERROR |
ERL_CANNOT_CONVERT_TYPES_ERROR |
ERL_CANNOT_READ_FROM_STREAM_ERROR |
ERL_CONFIG_SINGLE_NODE_ERROR |
ERL_CONN_ACCEPT_ERROR |
ERL_CONN_ACCEPT_FROM |
ERL_CONN_ALREADY_CONNECTED_ERROR |
ERL_CONN_CANT_CONNECT_TO_HOST_ERROR |
ERL_CONN_CANT_CONNECT_TO_NODE_ERROR |
ERL_CONN_CANT_RPC_TO_LOCAL_NODE_ERROR |
ERL_CONN_EOF_AFTER_N_BYTES_ERROR |
ERL_CONN_HANDSHAKE_DATA_ERROR |
ERL_CONN_HANDSHAKE_EXT_PIDS_ERROR |
ERL_CONN_HANDSHAKE_FAILED_ERROR |
ERL_CONN_HANDSHAKE_REF_ERROR |
ERL_CONN_INVALID_DATA_FROM_PEER_ERROR |
ERL_CONN_LOCAL_RPC_ERROR |
ERL_CONN_MSG_SIZE_TOO_LONG_ERROR |
ERL_CONN_NO_COMMON_PROTO_ERROR |
ERL_CONN_NOT_CONNECTED_ERROR |
ERL_CONN_PEER_AUTH_ERROR |
ERL_CONN_READ_TOO_SHORT_ERROR |
ERL_CONN_REMOTE_CLOSED_ERROR |
ERL_CONN_TIMEOUT_ERROR |
ERL_CONN_UNAUTH_COOKIE_ERROR |
ERL_CONN_UNKNOWN_REMOTE_NODE_ERROR |
ERL_CONN_UNKNOWN_TAG_ERROR |
ERL_CONN_WRONG_STATUS_ERROR |
ERL_CONNECTION |
ERL_DS_CRUD_RESP_SCH_FLD_COUNT_ERROR |
ERL_DS_CRUD_RESP_SCH_MISMATCH_ERROR |
ERL_DS_CRUD_WRITE_FAILED_ERROR |
ERL_DS_INTERNAL_MAPPING_ERROR |
ERL_DS_INVALID_RESP_PROTOCOL_ERROR |
ERL_DS_QUERY_PARAM_NOT_FOUND_ERROR |
ERL_DS_QUERY_SCRIPT_PARSE_ERROR |
ERL_DS_QUERY_SUBSCR_NOT_FOUND_ERROR |
ERL_DS_QUERY_TMSTAMP_CTX_ABSENT_ERROR |
ERL_DS_QUERY_TMSTAMP_NOT_FOUND_ERROR |
ERL_DS_RPC_EXEC_ERROR |
ERL_DS_SCHEMA_INVALID_VALUE_ERROR |
ERL_DS_SCHEMA_MAP_ERL_TYPE_ERROR |
ERL_DS_SCHEMA_MAP_NOT_KNOWN_ERROR |
ERL_DS_SCHEMA_NOT_KNOWN_ERROR |
ERL_DS_START_REMOTE_ABSENT_ERROR |
ERL_DS_START_REMOTE_DUPLICATE_ERROR |
ERL_EPMD_FAILED_TO_CONNECT_ERROR |
ERL_EPMD_INVALID_PORT_ERROR |
ERL_EPMD_INVALID_RESPONSE_ERROR |
ERL_EPMD_LOOKUP_R4 |
ERL_EPMD_NO_RESPONSE |
ERL_EPMD_NOT_FOUND |
ERL_EPMD_NOT_RESPONDING |
ERL_EPMD_OK |
ERL_EPMD_PORT |
ERL_EPMD_PUBLISH |
ERL_EPMD_UNPUBLISH |
ERL_INVALID_DATA_FORMAT_ERROR |
ERL_INVALID_FORMATTING_CHAR_ERROR |
ERL_INVALID_IO_REQUEST |
ERL_INVALID_MBOX_NAME_ERROR |
ERL_INVALID_MFA_FORMAT_ERROR |
ERL_INVALID_NUMBER_OF_ARGS_ERROR |
ERL_INVALID_RPC_REQUEST_ERROR |
ERL_INVALID_TERM_TYPE_ERROR |
ERL_INVALID_VALUE_CAST_ERROR |
ERL_INVALID_VALUE_ERROR |
ERL_INVALID_VALUE_LENGTH_ERROR |
ERL_INVALID_VALUE_TYPE_ERROR |
ERL_INVALID_VARIABLE_TYPE_ERROR |
ERL_MISSING_VALUE_FOR_ARGUMENT_ERROR |
ERL_PARSING_AT_ERROR |
ERL_REF_ID_ARGUMENT_ERROR |
ERL_STOPPING_SERVER |
ERL_UNBOUND_VARIABLE_ERROR |
ERL_UNSUPPORTED_ELEMENT_TYPE_ERROR |
ERL_UNSUPPORTED_TERM_TYPE_ERROR |
ERL_VALUE_MUST_NOT_BE_NULL_ERROR |
ERL_VALUE_TOO_LARGE_FOR_TYPE_ERROR |
ERL_VARIABLE_INVALID_VALUE_TYPE_ERROR |
ERL_VARIABLE_NOT_FOUND_ERROR |
ERL_WRONG_VALUE_FOR_ARGUMENT_ERROR |
Back to Top
See Also
StringConsts Class
NFX.Erlang Namespace


StringConsts Fields

StringConsts Fields NFX Class Library

The StringConsts type exposes the following members.
Fields
Name | Description
ARGUMENT_ERROR |
CONFIGURATION_NAVIGATION_SECTION_REQUIRED_ERROR |
ERL_ATOM_SIZE_TOO_LONG_ERROR |
ERL_ATOM_TABLE_IS_FULL_ERROR |
ERL_BIG_INTEGER_OVERFLOW_ERROR |
ERL_CANNOT_CLONE_INSTANCE_ERROR |
ERL_CANNOT_CONVERT_TYPES_CYCLE_ERROR |
ERL_CANNOT_CONVERT_TYPES_ERROR |
ERL_CANNOT_READ_FROM_STREAM_ERROR |
ERL_CONFIG_SINGLE_NODE_ERROR |
ERL_CONN_ACCEPT_ERROR |
ERL_CONN_ACCEPT_FROM |
ERL_CONN_ALREADY_CONNECTED_ERROR |
ERL_CONN_CANT_CONNECT_TO_HOST_ERROR |
ERL_CONN_CANT_CONNECT_TO_NODE_ERROR |
ERL_CONN_CANT_RPC_TO_LOCAL_NODE_ERROR |
ERL_CONN_EOF_AFTER_N_BYTES_ERROR |
ERL_CONN_HANDSHAKE_DATA_ERROR |
ERL_CONN_HANDSHAKE_EXT_PIDS_ERROR |
ERL_CONN_HANDSHAKE_FAILED_ERROR |
ERL_CONN_HANDSHAKE_REF_ERROR |
ERL_CONN_INVALID_DATA_FROM_PEER_ERROR |
ERL_CONN_LOCAL_RPC_ERROR |
ERL_CONN_MSG_SIZE_TOO_LONG_ERROR |
ERL_CONN_NO_COMMON_PROTO_ERROR |
ERL_CONN_NOT_CONNECTED_ERROR |
ERL_CONN_PEER_AUTH_ERROR |
ERL_CONN_READ_TOO_SHORT_ERROR |
ERL_CONN_REMOTE_CLOSED_ERROR |
ERL_CONN_TIMEOUT_ERROR |
ERL_CONN_UNAUTH_COOKIE_ERROR |
ERL_CONN_UNKNOWN_REMOTE_NODE_ERROR |
ERL_CONN_UNKNOWN_TAG_ERROR |
ERL_CONN_WRONG_STATUS_ERROR |
ERL_CONNECTION |
ERL_DS_CRUD_RESP_SCH_FLD_COUNT_ERROR |
ERL_DS_CRUD_RESP_SCH_MISMATCH_ERROR |
ERL_DS_CRUD_WRITE_FAILED_ERROR |
ERL_DS_INTERNAL_MAPPING_ERROR |
ERL_DS_INVALID_RESP_PROTOCOL_ERROR |
ERL_DS_QUERY_PARAM_NOT_FOUND_ERROR |
ERL_DS_QUERY_SCRIPT_PARSE_ERROR |
ERL_DS_QUERY_SUBSCR_NOT_FOUND_ERROR |
ERL_DS_QUERY_TMSTAMP_CTX_ABSENT_ERROR |
ERL_DS_QUERY_TMSTAMP_NOT_FOUND_ERROR |
ERL_DS_RPC_EXEC_ERROR |
ERL_DS_SCHEMA_INVALID_VALUE_ERROR |
ERL_DS_SCHEMA_MAP_ERL_TYPE_ERROR |
ERL_DS_SCHEMA_MAP_NOT_KNOWN_ERROR |
ERL_DS_SCHEMA_NOT_KNOWN_ERROR |
ERL_DS_START_REMOTE_ABSENT_ERROR |
ERL_DS_START_REMOTE_DUPLICATE_ERROR |
ERL_EPMD_FAILED_TO_CONNECT_ERROR |
ERL_EPMD_INVALID_PORT_ERROR |
ERL_EPMD_INVALID_RESPONSE_ERROR |
ERL_EPMD_LOOKUP_R4 |
ERL_EPMD_NO_RESPONSE |
ERL_EPMD_NOT_FOUND |
ERL_EPMD_NOT_RESPONDING |
ERL_EPMD_OK |
ERL_EPMD_PORT |
ERL_EPMD_PUBLISH |
ERL_EPMD_UNPUBLISH |
ERL_INVALID_DATA_FORMAT_ERROR |
ERL_INVALID_FORMATTING_CHAR_ERROR |
ERL_INVALID_IO_REQUEST |
ERL_INVALID_MBOX_NAME_ERROR |
ERL_INVALID_MFA_FORMAT_ERROR |
ERL_INVALID_NUMBER_OF_ARGS_ERROR |
ERL_INVALID_RPC_REQUEST_ERROR |
ERL_INVALID_TERM_TYPE_ERROR |
ERL_INVALID_VALUE_CAST_ERROR |
ERL_INVALID_VALUE_ERROR |
ERL_INVALID_VALUE_LENGTH_ERROR |
ERL_INVALID_VALUE_TYPE_ERROR |
ERL_INVALID_VARIABLE_TYPE_ERROR |
ERL_MISSING_VALUE_FOR_ARGUMENT_ERROR |
ERL_PARSING_AT_ERROR |
ERL_REF_ID_ARGUMENT_ERROR |
ERL_STOPPING_SERVER |
ERL_UNBOUND_VARIABLE_ERROR |
ERL_UNSUPPORTED_ELEMENT_TYPE_ERROR |
ERL_UNSUPPORTED_TERM_TYPE_ERROR |
ERL_VALUE_MUST_NOT_BE_NULL_ERROR |
ERL_VALUE_TOO_LARGE_FOR_TYPE_ERROR |
ERL_VARIABLE_INVALID_VALUE_TYPE_ERROR |
ERL_VARIABLE_NOT_FOUND_ERROR |
ERL_WRONG_VALUE_FOR_ARGUMENT_ERROR |
Back to Top
See Also
StringConsts Class
NFX.Erlang Namespace


StringConsts.ARGUMENT_ERROR Field

StringConsts ARGUMENT_ERROR Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ARGUMENT_ERROR
public const string ARGUMENT_ERROR
Public Const ARGUMENT_ERROR As String
Public Const ARGUMENT_ERROR As String
public:
literal String^ ARGUMENT_ERROR
public:
literal String^ ARGUMENT_ERROR
static val mutable ARGUMENT_ERROR: string
static val mutable ARGUMENT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.CONFIGURATION_NAVIGATION_SECTION_REQUIRED_ERROR Field

StringConsts CONFIGURATION_NAVIGATION_SECTION_REQUIRED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIGURATION_NAVIGATION_SECTION_REQUIRED_ERROR
public const string CONFIGURATION_NAVIGATION_SECTION_REQUIRED_ERROR
Public Const CONFIGURATION_NAVIGATION_SECTION_REQUIRED_ERROR As String
Public Const CONFIGURATION_NAVIGATION_SECTION_REQUIRED_ERROR As String
public:
literal String^ CONFIGURATION_NAVIGATION_SECTION_REQUIRED_ERROR
public:
literal String^ CONFIGURATION_NAVIGATION_SECTION_REQUIRED_ERROR
static val mutable CONFIGURATION_NAVIGATION_SECTION_REQUIRED_ERROR: string
static val mutable CONFIGURATION_NAVIGATION_SECTION_REQUIRED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_ATOM_SIZE_TOO_LONG_ERROR Field

StringConsts ERL_ATOM_SIZE_TOO_LONG_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_ATOM_SIZE_TOO_LONG_ERROR
public const string ERL_ATOM_SIZE_TOO_LONG_ERROR
Public Const ERL_ATOM_SIZE_TOO_LONG_ERROR As String
Public Const ERL_ATOM_SIZE_TOO_LONG_ERROR As String
public:
literal String^ ERL_ATOM_SIZE_TOO_LONG_ERROR
public:
literal String^ ERL_ATOM_SIZE_TOO_LONG_ERROR
static val mutable ERL_ATOM_SIZE_TOO_LONG_ERROR: string
static val mutable ERL_ATOM_SIZE_TOO_LONG_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_ATOM_TABLE_IS_FULL_ERROR Field

StringConsts ERL_ATOM_TABLE_IS_FULL_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_ATOM_TABLE_IS_FULL_ERROR
public const string ERL_ATOM_TABLE_IS_FULL_ERROR
Public Const ERL_ATOM_TABLE_IS_FULL_ERROR As String
Public Const ERL_ATOM_TABLE_IS_FULL_ERROR As String
public:
literal String^ ERL_ATOM_TABLE_IS_FULL_ERROR
public:
literal String^ ERL_ATOM_TABLE_IS_FULL_ERROR
static val mutable ERL_ATOM_TABLE_IS_FULL_ERROR: string
static val mutable ERL_ATOM_TABLE_IS_FULL_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_BIG_INTEGER_OVERFLOW_ERROR Field

StringConsts ERL_BIG_INTEGER_OVERFLOW_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_BIG_INTEGER_OVERFLOW_ERROR
public const string ERL_BIG_INTEGER_OVERFLOW_ERROR
Public Const ERL_BIG_INTEGER_OVERFLOW_ERROR As String
Public Const ERL_BIG_INTEGER_OVERFLOW_ERROR As String
public:
literal String^ ERL_BIG_INTEGER_OVERFLOW_ERROR
public:
literal String^ ERL_BIG_INTEGER_OVERFLOW_ERROR
static val mutable ERL_BIG_INTEGER_OVERFLOW_ERROR: string
static val mutable ERL_BIG_INTEGER_OVERFLOW_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CANNOT_CLONE_INSTANCE_ERROR Field

StringConsts ERL_CANNOT_CLONE_INSTANCE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CANNOT_CLONE_INSTANCE_ERROR
public const string ERL_CANNOT_CLONE_INSTANCE_ERROR
Public Const ERL_CANNOT_CLONE_INSTANCE_ERROR As String
Public Const ERL_CANNOT_CLONE_INSTANCE_ERROR As String
public:
literal String^ ERL_CANNOT_CLONE_INSTANCE_ERROR
public:
literal String^ ERL_CANNOT_CLONE_INSTANCE_ERROR
static val mutable ERL_CANNOT_CLONE_INSTANCE_ERROR: string
static val mutable ERL_CANNOT_CLONE_INSTANCE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CANNOT_CONVERT_TYPES_CYCLE_ERROR Field

StringConsts ERL_CANNOT_CONVERT_TYPES_CYCLE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CANNOT_CONVERT_TYPES_CYCLE_ERROR
public const string ERL_CANNOT_CONVERT_TYPES_CYCLE_ERROR
Public Const ERL_CANNOT_CONVERT_TYPES_CYCLE_ERROR As String
Public Const ERL_CANNOT_CONVERT_TYPES_CYCLE_ERROR As String
public:
literal String^ ERL_CANNOT_CONVERT_TYPES_CYCLE_ERROR
public:
literal String^ ERL_CANNOT_CONVERT_TYPES_CYCLE_ERROR
static val mutable ERL_CANNOT_CONVERT_TYPES_CYCLE_ERROR: string
static val mutable ERL_CANNOT_CONVERT_TYPES_CYCLE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CANNOT_CONVERT_TYPES_ERROR Field

StringConsts ERL_CANNOT_CONVERT_TYPES_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CANNOT_CONVERT_TYPES_ERROR
public const string ERL_CANNOT_CONVERT_TYPES_ERROR
Public Const ERL_CANNOT_CONVERT_TYPES_ERROR As String
Public Const ERL_CANNOT_CONVERT_TYPES_ERROR As String
public:
literal String^ ERL_CANNOT_CONVERT_TYPES_ERROR
public:
literal String^ ERL_CANNOT_CONVERT_TYPES_ERROR
static val mutable ERL_CANNOT_CONVERT_TYPES_ERROR: string
static val mutable ERL_CANNOT_CONVERT_TYPES_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CANNOT_READ_FROM_STREAM_ERROR Field

StringConsts ERL_CANNOT_READ_FROM_STREAM_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CANNOT_READ_FROM_STREAM_ERROR
public const string ERL_CANNOT_READ_FROM_STREAM_ERROR
Public Const ERL_CANNOT_READ_FROM_STREAM_ERROR As String
Public Const ERL_CANNOT_READ_FROM_STREAM_ERROR As String
public:
literal String^ ERL_CANNOT_READ_FROM_STREAM_ERROR
public:
literal String^ ERL_CANNOT_READ_FROM_STREAM_ERROR
static val mutable ERL_CANNOT_READ_FROM_STREAM_ERROR: string
static val mutable ERL_CANNOT_READ_FROM_STREAM_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CONFIG_SINGLE_NODE_ERROR Field

StringConsts ERL_CONFIG_SINGLE_NODE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONFIG_SINGLE_NODE_ERROR
public const string ERL_CONFIG_SINGLE_NODE_ERROR
Public Const ERL_CONFIG_SINGLE_NODE_ERROR As String
Public Const ERL_CONFIG_SINGLE_NODE_ERROR As String
public:
literal String^ ERL_CONFIG_SINGLE_NODE_ERROR
public:
literal String^ ERL_CONFIG_SINGLE_NODE_ERROR
static val mutable ERL_CONFIG_SINGLE_NODE_ERROR: string
static val mutable ERL_CONFIG_SINGLE_NODE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CONN_ACCEPT_ERROR Field

StringConsts ERL_CONN_ACCEPT_ERROR Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_ACCEPT_ERROR
public const string ERL_CONN_ACCEPT_ERROR
Public Const ERL_CONN_ACCEPT_ERROR As String
Public Const ERL_CONN_ACCEPT_ERROR As String
public:
literal String^ ERL_CONN_ACCEPT_ERROR
public:
literal String^ ERL_CONN_ACCEPT_ERROR
static val mutable ERL_CONN_ACCEPT_ERROR: string
static val mutable ERL_CONN_ACCEPT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CONN_ACCEPT_FROM Field

StringConsts ERL_CONN_ACCEPT_FROM Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_ACCEPT_FROM
public const string ERL_CONN_ACCEPT_FROM
Public Const ERL_CONN_ACCEPT_FROM As String
Public Const ERL_CONN_ACCEPT_FROM As String
public:
literal String^ ERL_CONN_ACCEPT_FROM
public:
literal String^ ERL_CONN_ACCEPT_FROM
static val mutable ERL_CONN_ACCEPT_FROM: string
static val mutable ERL_CONN_ACCEPT_FROM: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CONN_ALREADY_CONNECTED_ERROR Field

StringConsts ERL_CONN_ALREADY_CONNECTED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_ALREADY_CONNECTED_ERROR
public const string ERL_CONN_ALREADY_CONNECTED_ERROR
Public Const ERL_CONN_ALREADY_CONNECTED_ERROR As String
Public Const ERL_CONN_ALREADY_CONNECTED_ERROR As String
public:
literal String^ ERL_CONN_ALREADY_CONNECTED_ERROR
public:
literal String^ ERL_CONN_ALREADY_CONNECTED_ERROR
static val mutable ERL_CONN_ALREADY_CONNECTED_ERROR: string
static val mutable ERL_CONN_ALREADY_CONNECTED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CONN_CANT_CONNECT_TO_HOST_ERROR Field

StringConsts ERL_CONN_CANT_CONNECT_TO_HOST_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_CANT_CONNECT_TO_HOST_ERROR
public const string ERL_CONN_CANT_CONNECT_TO_HOST_ERROR
Public Const ERL_CONN_CANT_CONNECT_TO_HOST_ERROR As String
Public Const ERL_CONN_CANT_CONNECT_TO_HOST_ERROR As String
public:
literal String^ ERL_CONN_CANT_CONNECT_TO_HOST_ERROR
public:
literal String^ ERL_CONN_CANT_CONNECT_TO_HOST_ERROR
static val mutable ERL_CONN_CANT_CONNECT_TO_HOST_ERROR: string
static val mutable ERL_CONN_CANT_CONNECT_TO_HOST_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CONN_CANT_CONNECT_TO_NODE_ERROR Field

StringConsts ERL_CONN_CANT_CONNECT_TO_NODE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_CANT_CONNECT_TO_NODE_ERROR
public const string ERL_CONN_CANT_CONNECT_TO_NODE_ERROR
Public Const ERL_CONN_CANT_CONNECT_TO_NODE_ERROR As String
Public Const ERL_CONN_CANT_CONNECT_TO_NODE_ERROR As String
public:
literal String^ ERL_CONN_CANT_CONNECT_TO_NODE_ERROR
public:
literal String^ ERL_CONN_CANT_CONNECT_TO_NODE_ERROR
static val mutable ERL_CONN_CANT_CONNECT_TO_NODE_ERROR: string
static val mutable ERL_CONN_CANT_CONNECT_TO_NODE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CONN_CANT_RPC_TO_LOCAL_NODE_ERROR Field

StringConsts ERL_CONN_CANT_RPC_TO_LOCAL_NODE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_CANT_RPC_TO_LOCAL_NODE_ERROR
public const string ERL_CONN_CANT_RPC_TO_LOCAL_NODE_ERROR
Public Const ERL_CONN_CANT_RPC_TO_LOCAL_NODE_ERROR As String
Public Const ERL_CONN_CANT_RPC_TO_LOCAL_NODE_ERROR As String
public:
literal String^ ERL_CONN_CANT_RPC_TO_LOCAL_NODE_ERROR
public:
literal String^ ERL_CONN_CANT_RPC_TO_LOCAL_NODE_ERROR
static val mutable ERL_CONN_CANT_RPC_TO_LOCAL_NODE_ERROR: string
static val mutable ERL_CONN_CANT_RPC_TO_LOCAL_NODE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CONN_EOF_AFTER_N_BYTES_ERROR Field

StringConsts ERL_CONN_EOF_AFTER_N_BYTES_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_EOF_AFTER_N_BYTES_ERROR
public const string ERL_CONN_EOF_AFTER_N_BYTES_ERROR
Public Const ERL_CONN_EOF_AFTER_N_BYTES_ERROR As String
Public Const ERL_CONN_EOF_AFTER_N_BYTES_ERROR As String
public:
literal String^ ERL_CONN_EOF_AFTER_N_BYTES_ERROR
public:
literal String^ ERL_CONN_EOF_AFTER_N_BYTES_ERROR
static val mutable ERL_CONN_EOF_AFTER_N_BYTES_ERROR: string
static val mutable ERL_CONN_EOF_AFTER_N_BYTES_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CONN_HANDSHAKE_DATA_ERROR Field

StringConsts ERL_CONN_HANDSHAKE_DATA_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_HANDSHAKE_DATA_ERROR
public const string ERL_CONN_HANDSHAKE_DATA_ERROR
Public Const ERL_CONN_HANDSHAKE_DATA_ERROR As String
Public Const ERL_CONN_HANDSHAKE_DATA_ERROR As String
public:
literal String^ ERL_CONN_HANDSHAKE_DATA_ERROR
public:
literal String^ ERL_CONN_HANDSHAKE_DATA_ERROR
static val mutable ERL_CONN_HANDSHAKE_DATA_ERROR: string
static val mutable ERL_CONN_HANDSHAKE_DATA_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CONN_HANDSHAKE_EXT_PIDS_ERROR Field

StringConsts ERL_CONN_HANDSHAKE_EXT_PIDS_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_HANDSHAKE_EXT_PIDS_ERROR
public const string ERL_CONN_HANDSHAKE_EXT_PIDS_ERROR
Public Const ERL_CONN_HANDSHAKE_EXT_PIDS_ERROR As String
Public Const ERL_CONN_HANDSHAKE_EXT_PIDS_ERROR As String
public:
literal String^ ERL_CONN_HANDSHAKE_EXT_PIDS_ERROR
public:
literal String^ ERL_CONN_HANDSHAKE_EXT_PIDS_ERROR
static val mutable ERL_CONN_HANDSHAKE_EXT_PIDS_ERROR: string
static val mutable ERL_CONN_HANDSHAKE_EXT_PIDS_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CONN_HANDSHAKE_FAILED_ERROR Field

StringConsts ERL_CONN_HANDSHAKE_FAILED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_HANDSHAKE_FAILED_ERROR
public const string ERL_CONN_HANDSHAKE_FAILED_ERROR
Public Const ERL_CONN_HANDSHAKE_FAILED_ERROR As String
Public Const ERL_CONN_HANDSHAKE_FAILED_ERROR As String
public:
literal String^ ERL_CONN_HANDSHAKE_FAILED_ERROR
public:
literal String^ ERL_CONN_HANDSHAKE_FAILED_ERROR
static val mutable ERL_CONN_HANDSHAKE_FAILED_ERROR: string
static val mutable ERL_CONN_HANDSHAKE_FAILED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CONN_HANDSHAKE_REF_ERROR Field

StringConsts ERL_CONN_HANDSHAKE_REF_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_HANDSHAKE_REF_ERROR
public const string ERL_CONN_HANDSHAKE_REF_ERROR
Public Const ERL_CONN_HANDSHAKE_REF_ERROR As String
Public Const ERL_CONN_HANDSHAKE_REF_ERROR As String
public:
literal String^ ERL_CONN_HANDSHAKE_REF_ERROR
public:
literal String^ ERL_CONN_HANDSHAKE_REF_ERROR
static val mutable ERL_CONN_HANDSHAKE_REF_ERROR: string
static val mutable ERL_CONN_HANDSHAKE_REF_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CONN_INVALID_DATA_FROM_PEER_ERROR Field

StringConsts ERL_CONN_INVALID_DATA_FROM_PEER_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_INVALID_DATA_FROM_PEER_ERROR
public const string ERL_CONN_INVALID_DATA_FROM_PEER_ERROR
Public Const ERL_CONN_INVALID_DATA_FROM_PEER_ERROR As String
Public Const ERL_CONN_INVALID_DATA_FROM_PEER_ERROR As String
public:
literal String^ ERL_CONN_INVALID_DATA_FROM_PEER_ERROR
public:
literal String^ ERL_CONN_INVALID_DATA_FROM_PEER_ERROR
static val mutable ERL_CONN_INVALID_DATA_FROM_PEER_ERROR: string
static val mutable ERL_CONN_INVALID_DATA_FROM_PEER_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CONN_LOCAL_RPC_ERROR Field

StringConsts ERL_CONN_LOCAL_RPC_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_LOCAL_RPC_ERROR
public const string ERL_CONN_LOCAL_RPC_ERROR
Public Const ERL_CONN_LOCAL_RPC_ERROR As String
Public Const ERL_CONN_LOCAL_RPC_ERROR As String
public:
literal String^ ERL_CONN_LOCAL_RPC_ERROR
public:
literal String^ ERL_CONN_LOCAL_RPC_ERROR
static val mutable ERL_CONN_LOCAL_RPC_ERROR: string
static val mutable ERL_CONN_LOCAL_RPC_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CONN_MSG_SIZE_TOO_LONG_ERROR Field

StringConsts ERL_CONN_MSG_SIZE_TOO_LONG_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_MSG_SIZE_TOO_LONG_ERROR
public const string ERL_CONN_MSG_SIZE_TOO_LONG_ERROR
Public Const ERL_CONN_MSG_SIZE_TOO_LONG_ERROR As String
Public Const ERL_CONN_MSG_SIZE_TOO_LONG_ERROR As String
public:
literal String^ ERL_CONN_MSG_SIZE_TOO_LONG_ERROR
public:
literal String^ ERL_CONN_MSG_SIZE_TOO_LONG_ERROR
static val mutable ERL_CONN_MSG_SIZE_TOO_LONG_ERROR: string
static val mutable ERL_CONN_MSG_SIZE_TOO_LONG_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CONN_NO_COMMON_PROTO_ERROR Field

StringConsts ERL_CONN_NO_COMMON_PROTO_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_NO_COMMON_PROTO_ERROR
public const string ERL_CONN_NO_COMMON_PROTO_ERROR
Public Const ERL_CONN_NO_COMMON_PROTO_ERROR As String
Public Const ERL_CONN_NO_COMMON_PROTO_ERROR As String
public:
literal String^ ERL_CONN_NO_COMMON_PROTO_ERROR
public:
literal String^ ERL_CONN_NO_COMMON_PROTO_ERROR
static val mutable ERL_CONN_NO_COMMON_PROTO_ERROR: string
static val mutable ERL_CONN_NO_COMMON_PROTO_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CONN_NOT_CONNECTED_ERROR Field

StringConsts ERL_CONN_NOT_CONNECTED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_NOT_CONNECTED_ERROR
public const string ERL_CONN_NOT_CONNECTED_ERROR
Public Const ERL_CONN_NOT_CONNECTED_ERROR As String
Public Const ERL_CONN_NOT_CONNECTED_ERROR As String
public:
literal String^ ERL_CONN_NOT_CONNECTED_ERROR
public:
literal String^ ERL_CONN_NOT_CONNECTED_ERROR
static val mutable ERL_CONN_NOT_CONNECTED_ERROR: string
static val mutable ERL_CONN_NOT_CONNECTED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CONN_PEER_AUTH_ERROR Field

StringConsts ERL_CONN_PEER_AUTH_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_PEER_AUTH_ERROR
public const string ERL_CONN_PEER_AUTH_ERROR
Public Const ERL_CONN_PEER_AUTH_ERROR As String
Public Const ERL_CONN_PEER_AUTH_ERROR As String
public:
literal String^ ERL_CONN_PEER_AUTH_ERROR
public:
literal String^ ERL_CONN_PEER_AUTH_ERROR
static val mutable ERL_CONN_PEER_AUTH_ERROR: string
static val mutable ERL_CONN_PEER_AUTH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CONN_READ_TOO_SHORT_ERROR Field

StringConsts ERL_CONN_READ_TOO_SHORT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_READ_TOO_SHORT_ERROR
public const string ERL_CONN_READ_TOO_SHORT_ERROR
Public Const ERL_CONN_READ_TOO_SHORT_ERROR As String
Public Const ERL_CONN_READ_TOO_SHORT_ERROR As String
public:
literal String^ ERL_CONN_READ_TOO_SHORT_ERROR
public:
literal String^ ERL_CONN_READ_TOO_SHORT_ERROR
static val mutable ERL_CONN_READ_TOO_SHORT_ERROR: string
static val mutable ERL_CONN_READ_TOO_SHORT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CONN_REMOTE_CLOSED_ERROR Field

StringConsts ERL_CONN_REMOTE_CLOSED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_REMOTE_CLOSED_ERROR
public const string ERL_CONN_REMOTE_CLOSED_ERROR
Public Const ERL_CONN_REMOTE_CLOSED_ERROR As String
Public Const ERL_CONN_REMOTE_CLOSED_ERROR As String
public:
literal String^ ERL_CONN_REMOTE_CLOSED_ERROR
public:
literal String^ ERL_CONN_REMOTE_CLOSED_ERROR
static val mutable ERL_CONN_REMOTE_CLOSED_ERROR: string
static val mutable ERL_CONN_REMOTE_CLOSED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CONN_TIMEOUT_ERROR Field

StringConsts ERL_CONN_TIMEOUT_ERROR Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_TIMEOUT_ERROR
public const string ERL_CONN_TIMEOUT_ERROR
Public Const ERL_CONN_TIMEOUT_ERROR As String
Public Const ERL_CONN_TIMEOUT_ERROR As String
public:
literal String^ ERL_CONN_TIMEOUT_ERROR
public:
literal String^ ERL_CONN_TIMEOUT_ERROR
static val mutable ERL_CONN_TIMEOUT_ERROR: string
static val mutable ERL_CONN_TIMEOUT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CONN_UNAUTH_COOKIE_ERROR Field

StringConsts ERL_CONN_UNAUTH_COOKIE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_UNAUTH_COOKIE_ERROR
public const string ERL_CONN_UNAUTH_COOKIE_ERROR
Public Const ERL_CONN_UNAUTH_COOKIE_ERROR As String
Public Const ERL_CONN_UNAUTH_COOKIE_ERROR As String
public:
literal String^ ERL_CONN_UNAUTH_COOKIE_ERROR
public:
literal String^ ERL_CONN_UNAUTH_COOKIE_ERROR
static val mutable ERL_CONN_UNAUTH_COOKIE_ERROR: string
static val mutable ERL_CONN_UNAUTH_COOKIE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CONN_UNKNOWN_REMOTE_NODE_ERROR Field

StringConsts ERL_CONN_UNKNOWN_REMOTE_NODE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_UNKNOWN_REMOTE_NODE_ERROR
public const string ERL_CONN_UNKNOWN_REMOTE_NODE_ERROR
Public Const ERL_CONN_UNKNOWN_REMOTE_NODE_ERROR As String
Public Const ERL_CONN_UNKNOWN_REMOTE_NODE_ERROR As String
public:
literal String^ ERL_CONN_UNKNOWN_REMOTE_NODE_ERROR
public:
literal String^ ERL_CONN_UNKNOWN_REMOTE_NODE_ERROR
static val mutable ERL_CONN_UNKNOWN_REMOTE_NODE_ERROR: string
static val mutable ERL_CONN_UNKNOWN_REMOTE_NODE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CONN_UNKNOWN_TAG_ERROR Field

StringConsts ERL_CONN_UNKNOWN_TAG_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_UNKNOWN_TAG_ERROR
public const string ERL_CONN_UNKNOWN_TAG_ERROR
Public Const ERL_CONN_UNKNOWN_TAG_ERROR As String
Public Const ERL_CONN_UNKNOWN_TAG_ERROR As String
public:
literal String^ ERL_CONN_UNKNOWN_TAG_ERROR
public:
literal String^ ERL_CONN_UNKNOWN_TAG_ERROR
static val mutable ERL_CONN_UNKNOWN_TAG_ERROR: string
static val mutable ERL_CONN_UNKNOWN_TAG_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CONN_WRONG_STATUS_ERROR Field

StringConsts ERL_CONN_WRONG_STATUS_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONN_WRONG_STATUS_ERROR
public const string ERL_CONN_WRONG_STATUS_ERROR
Public Const ERL_CONN_WRONG_STATUS_ERROR As String
Public Const ERL_CONN_WRONG_STATUS_ERROR As String
public:
literal String^ ERL_CONN_WRONG_STATUS_ERROR
public:
literal String^ ERL_CONN_WRONG_STATUS_ERROR
static val mutable ERL_CONN_WRONG_STATUS_ERROR: string
static val mutable ERL_CONN_WRONG_STATUS_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_CONNECTION Field

StringConsts ERL_CONNECTION Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_CONNECTION
public const string ERL_CONNECTION
Public Const ERL_CONNECTION As String
Public Const ERL_CONNECTION As String
public:
literal String^ ERL_CONNECTION
public:
literal String^ ERL_CONNECTION
static val mutable ERL_CONNECTION: string
static val mutable ERL_CONNECTION: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_DS_CRUD_RESP_SCH_FLD_COUNT_ERROR Field

StringConsts ERL_DS_CRUD_RESP_SCH_FLD_COUNT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_CRUD_RESP_SCH_FLD_COUNT_ERROR
public const string ERL_DS_CRUD_RESP_SCH_FLD_COUNT_ERROR
Public Const ERL_DS_CRUD_RESP_SCH_FLD_COUNT_ERROR As String
Public Const ERL_DS_CRUD_RESP_SCH_FLD_COUNT_ERROR As String
public:
literal String^ ERL_DS_CRUD_RESP_SCH_FLD_COUNT_ERROR
public:
literal String^ ERL_DS_CRUD_RESP_SCH_FLD_COUNT_ERROR
static val mutable ERL_DS_CRUD_RESP_SCH_FLD_COUNT_ERROR: string
static val mutable ERL_DS_CRUD_RESP_SCH_FLD_COUNT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_DS_CRUD_RESP_SCH_MISMATCH_ERROR Field

StringConsts ERL_DS_CRUD_RESP_SCH_MISMATCH_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_CRUD_RESP_SCH_MISMATCH_ERROR
public const string ERL_DS_CRUD_RESP_SCH_MISMATCH_ERROR
Public Const ERL_DS_CRUD_RESP_SCH_MISMATCH_ERROR As String
Public Const ERL_DS_CRUD_RESP_SCH_MISMATCH_ERROR As String
public:
literal String^ ERL_DS_CRUD_RESP_SCH_MISMATCH_ERROR
public:
literal String^ ERL_DS_CRUD_RESP_SCH_MISMATCH_ERROR
static val mutable ERL_DS_CRUD_RESP_SCH_MISMATCH_ERROR: string
static val mutable ERL_DS_CRUD_RESP_SCH_MISMATCH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_DS_CRUD_WRITE_FAILED_ERROR Field

StringConsts ERL_DS_CRUD_WRITE_FAILED_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_CRUD_WRITE_FAILED_ERROR
public const string ERL_DS_CRUD_WRITE_FAILED_ERROR
Public Const ERL_DS_CRUD_WRITE_FAILED_ERROR As String
Public Const ERL_DS_CRUD_WRITE_FAILED_ERROR As String
public:
literal String^ ERL_DS_CRUD_WRITE_FAILED_ERROR
public:
literal String^ ERL_DS_CRUD_WRITE_FAILED_ERROR
static val mutable ERL_DS_CRUD_WRITE_FAILED_ERROR: string
static val mutable ERL_DS_CRUD_WRITE_FAILED_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_DS_INTERNAL_MAPPING_ERROR Field

StringConsts ERL_DS_INTERNAL_MAPPING_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_INTERNAL_MAPPING_ERROR
public const string ERL_DS_INTERNAL_MAPPING_ERROR
Public Const ERL_DS_INTERNAL_MAPPING_ERROR As String
Public Const ERL_DS_INTERNAL_MAPPING_ERROR As String
public:
literal String^ ERL_DS_INTERNAL_MAPPING_ERROR
public:
literal String^ ERL_DS_INTERNAL_MAPPING_ERROR
static val mutable ERL_DS_INTERNAL_MAPPING_ERROR: string
static val mutable ERL_DS_INTERNAL_MAPPING_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_DS_INVALID_RESP_PROTOCOL_ERROR Field

StringConsts ERL_DS_INVALID_RESP_PROTOCOL_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_INVALID_RESP_PROTOCOL_ERROR
public const string ERL_DS_INVALID_RESP_PROTOCOL_ERROR
Public Const ERL_DS_INVALID_RESP_PROTOCOL_ERROR As String
Public Const ERL_DS_INVALID_RESP_PROTOCOL_ERROR As String
public:
literal String^ ERL_DS_INVALID_RESP_PROTOCOL_ERROR
public:
literal String^ ERL_DS_INVALID_RESP_PROTOCOL_ERROR
static val mutable ERL_DS_INVALID_RESP_PROTOCOL_ERROR: string
static val mutable ERL_DS_INVALID_RESP_PROTOCOL_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_DS_QUERY_PARAM_NOT_FOUND_ERROR Field

StringConsts ERL_DS_QUERY_PARAM_NOT_FOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_QUERY_PARAM_NOT_FOUND_ERROR
public const string ERL_DS_QUERY_PARAM_NOT_FOUND_ERROR
Public Const ERL_DS_QUERY_PARAM_NOT_FOUND_ERROR As String
Public Const ERL_DS_QUERY_PARAM_NOT_FOUND_ERROR As String
public:
literal String^ ERL_DS_QUERY_PARAM_NOT_FOUND_ERROR
public:
literal String^ ERL_DS_QUERY_PARAM_NOT_FOUND_ERROR
static val mutable ERL_DS_QUERY_PARAM_NOT_FOUND_ERROR: string
static val mutable ERL_DS_QUERY_PARAM_NOT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_DS_QUERY_SCRIPT_PARSE_ERROR Field

StringConsts ERL_DS_QUERY_SCRIPT_PARSE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_QUERY_SCRIPT_PARSE_ERROR
public const string ERL_DS_QUERY_SCRIPT_PARSE_ERROR
Public Const ERL_DS_QUERY_SCRIPT_PARSE_ERROR As String
Public Const ERL_DS_QUERY_SCRIPT_PARSE_ERROR As String
public:
literal String^ ERL_DS_QUERY_SCRIPT_PARSE_ERROR
public:
literal String^ ERL_DS_QUERY_SCRIPT_PARSE_ERROR
static val mutable ERL_DS_QUERY_SCRIPT_PARSE_ERROR: string
static val mutable ERL_DS_QUERY_SCRIPT_PARSE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_DS_QUERY_SUBSCR_NOT_FOUND_ERROR Field

StringConsts ERL_DS_QUERY_SUBSCR_NOT_FOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_QUERY_SUBSCR_NOT_FOUND_ERROR
public const string ERL_DS_QUERY_SUBSCR_NOT_FOUND_ERROR
Public Const ERL_DS_QUERY_SUBSCR_NOT_FOUND_ERROR As String
Public Const ERL_DS_QUERY_SUBSCR_NOT_FOUND_ERROR As String
public:
literal String^ ERL_DS_QUERY_SUBSCR_NOT_FOUND_ERROR
public:
literal String^ ERL_DS_QUERY_SUBSCR_NOT_FOUND_ERROR
static val mutable ERL_DS_QUERY_SUBSCR_NOT_FOUND_ERROR: string
static val mutable ERL_DS_QUERY_SUBSCR_NOT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_DS_QUERY_TMSTAMP_CTX_ABSENT_ERROR Field

StringConsts ERL_DS_QUERY_TMSTAMP_CTX_ABSENT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_QUERY_TMSTAMP_CTX_ABSENT_ERROR
public const string ERL_DS_QUERY_TMSTAMP_CTX_ABSENT_ERROR
Public Const ERL_DS_QUERY_TMSTAMP_CTX_ABSENT_ERROR As String
Public Const ERL_DS_QUERY_TMSTAMP_CTX_ABSENT_ERROR As String
public:
literal String^ ERL_DS_QUERY_TMSTAMP_CTX_ABSENT_ERROR
public:
literal String^ ERL_DS_QUERY_TMSTAMP_CTX_ABSENT_ERROR
static val mutable ERL_DS_QUERY_TMSTAMP_CTX_ABSENT_ERROR: string
static val mutable ERL_DS_QUERY_TMSTAMP_CTX_ABSENT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_DS_QUERY_TMSTAMP_NOT_FOUND_ERROR Field

StringConsts ERL_DS_QUERY_TMSTAMP_NOT_FOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_QUERY_TMSTAMP_NOT_FOUND_ERROR
public const string ERL_DS_QUERY_TMSTAMP_NOT_FOUND_ERROR
Public Const ERL_DS_QUERY_TMSTAMP_NOT_FOUND_ERROR As String
Public Const ERL_DS_QUERY_TMSTAMP_NOT_FOUND_ERROR As String
public:
literal String^ ERL_DS_QUERY_TMSTAMP_NOT_FOUND_ERROR
public:
literal String^ ERL_DS_QUERY_TMSTAMP_NOT_FOUND_ERROR
static val mutable ERL_DS_QUERY_TMSTAMP_NOT_FOUND_ERROR: string
static val mutable ERL_DS_QUERY_TMSTAMP_NOT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_DS_RPC_EXEC_ERROR Field

StringConsts ERL_DS_RPC_EXEC_ERROR Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_RPC_EXEC_ERROR
public const string ERL_DS_RPC_EXEC_ERROR
Public Const ERL_DS_RPC_EXEC_ERROR As String
Public Const ERL_DS_RPC_EXEC_ERROR As String
public:
literal String^ ERL_DS_RPC_EXEC_ERROR
public:
literal String^ ERL_DS_RPC_EXEC_ERROR
static val mutable ERL_DS_RPC_EXEC_ERROR: string
static val mutable ERL_DS_RPC_EXEC_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_DS_SCHEMA_INVALID_VALUE_ERROR Field

StringConsts ERL_DS_SCHEMA_INVALID_VALUE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_SCHEMA_INVALID_VALUE_ERROR
public const string ERL_DS_SCHEMA_INVALID_VALUE_ERROR
Public Const ERL_DS_SCHEMA_INVALID_VALUE_ERROR As String
Public Const ERL_DS_SCHEMA_INVALID_VALUE_ERROR As String
public:
literal String^ ERL_DS_SCHEMA_INVALID_VALUE_ERROR
public:
literal String^ ERL_DS_SCHEMA_INVALID_VALUE_ERROR
static val mutable ERL_DS_SCHEMA_INVALID_VALUE_ERROR: string
static val mutable ERL_DS_SCHEMA_INVALID_VALUE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_DS_SCHEMA_MAP_ERL_TYPE_ERROR Field

StringConsts ERL_DS_SCHEMA_MAP_ERL_TYPE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_SCHEMA_MAP_ERL_TYPE_ERROR
public const string ERL_DS_SCHEMA_MAP_ERL_TYPE_ERROR
Public Const ERL_DS_SCHEMA_MAP_ERL_TYPE_ERROR As String
Public Const ERL_DS_SCHEMA_MAP_ERL_TYPE_ERROR As String
public:
literal String^ ERL_DS_SCHEMA_MAP_ERL_TYPE_ERROR
public:
literal String^ ERL_DS_SCHEMA_MAP_ERL_TYPE_ERROR
static val mutable ERL_DS_SCHEMA_MAP_ERL_TYPE_ERROR: string
static val mutable ERL_DS_SCHEMA_MAP_ERL_TYPE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_DS_SCHEMA_MAP_NOT_KNOWN_ERROR Field

StringConsts ERL_DS_SCHEMA_MAP_NOT_KNOWN_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_SCHEMA_MAP_NOT_KNOWN_ERROR
public const string ERL_DS_SCHEMA_MAP_NOT_KNOWN_ERROR
Public Const ERL_DS_SCHEMA_MAP_NOT_KNOWN_ERROR As String
Public Const ERL_DS_SCHEMA_MAP_NOT_KNOWN_ERROR As String
public:
literal String^ ERL_DS_SCHEMA_MAP_NOT_KNOWN_ERROR
public:
literal String^ ERL_DS_SCHEMA_MAP_NOT_KNOWN_ERROR
static val mutable ERL_DS_SCHEMA_MAP_NOT_KNOWN_ERROR: string
static val mutable ERL_DS_SCHEMA_MAP_NOT_KNOWN_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_DS_SCHEMA_NOT_KNOWN_ERROR Field

StringConsts ERL_DS_SCHEMA_NOT_KNOWN_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_SCHEMA_NOT_KNOWN_ERROR
public const string ERL_DS_SCHEMA_NOT_KNOWN_ERROR
Public Const ERL_DS_SCHEMA_NOT_KNOWN_ERROR As String
Public Const ERL_DS_SCHEMA_NOT_KNOWN_ERROR As String
public:
literal String^ ERL_DS_SCHEMA_NOT_KNOWN_ERROR
public:
literal String^ ERL_DS_SCHEMA_NOT_KNOWN_ERROR
static val mutable ERL_DS_SCHEMA_NOT_KNOWN_ERROR: string
static val mutable ERL_DS_SCHEMA_NOT_KNOWN_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_DS_START_REMOTE_ABSENT_ERROR Field

StringConsts ERL_DS_START_REMOTE_ABSENT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_START_REMOTE_ABSENT_ERROR
public const string ERL_DS_START_REMOTE_ABSENT_ERROR
Public Const ERL_DS_START_REMOTE_ABSENT_ERROR As String
Public Const ERL_DS_START_REMOTE_ABSENT_ERROR As String
public:
literal String^ ERL_DS_START_REMOTE_ABSENT_ERROR
public:
literal String^ ERL_DS_START_REMOTE_ABSENT_ERROR
static val mutable ERL_DS_START_REMOTE_ABSENT_ERROR: string
static val mutable ERL_DS_START_REMOTE_ABSENT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_DS_START_REMOTE_DUPLICATE_ERROR Field

StringConsts ERL_DS_START_REMOTE_DUPLICATE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_DS_START_REMOTE_DUPLICATE_ERROR
public const string ERL_DS_START_REMOTE_DUPLICATE_ERROR
Public Const ERL_DS_START_REMOTE_DUPLICATE_ERROR As String
Public Const ERL_DS_START_REMOTE_DUPLICATE_ERROR As String
public:
literal String^ ERL_DS_START_REMOTE_DUPLICATE_ERROR
public:
literal String^ ERL_DS_START_REMOTE_DUPLICATE_ERROR
static val mutable ERL_DS_START_REMOTE_DUPLICATE_ERROR: string
static val mutable ERL_DS_START_REMOTE_DUPLICATE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_EPMD_FAILED_TO_CONNECT_ERROR Field

StringConsts ERL_EPMD_FAILED_TO_CONNECT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_EPMD_FAILED_TO_CONNECT_ERROR
public const string ERL_EPMD_FAILED_TO_CONNECT_ERROR
Public Const ERL_EPMD_FAILED_TO_CONNECT_ERROR As String
Public Const ERL_EPMD_FAILED_TO_CONNECT_ERROR As String
public:
literal String^ ERL_EPMD_FAILED_TO_CONNECT_ERROR
public:
literal String^ ERL_EPMD_FAILED_TO_CONNECT_ERROR
static val mutable ERL_EPMD_FAILED_TO_CONNECT_ERROR: string
static val mutable ERL_EPMD_FAILED_TO_CONNECT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_EPMD_INVALID_PORT_ERROR Field

StringConsts ERL_EPMD_INVALID_PORT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_EPMD_INVALID_PORT_ERROR
public const string ERL_EPMD_INVALID_PORT_ERROR
Public Const ERL_EPMD_INVALID_PORT_ERROR As String
Public Const ERL_EPMD_INVALID_PORT_ERROR As String
public:
literal String^ ERL_EPMD_INVALID_PORT_ERROR
public:
literal String^ ERL_EPMD_INVALID_PORT_ERROR
static val mutable ERL_EPMD_INVALID_PORT_ERROR: string
static val mutable ERL_EPMD_INVALID_PORT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_EPMD_INVALID_RESPONSE_ERROR Field

StringConsts ERL_EPMD_INVALID_RESPONSE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_EPMD_INVALID_RESPONSE_ERROR
public const string ERL_EPMD_INVALID_RESPONSE_ERROR
Public Const ERL_EPMD_INVALID_RESPONSE_ERROR As String
Public Const ERL_EPMD_INVALID_RESPONSE_ERROR As String
public:
literal String^ ERL_EPMD_INVALID_RESPONSE_ERROR
public:
literal String^ ERL_EPMD_INVALID_RESPONSE_ERROR
static val mutable ERL_EPMD_INVALID_RESPONSE_ERROR: string
static val mutable ERL_EPMD_INVALID_RESPONSE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_EPMD_LOOKUP_R4 Field

StringConsts ERL_EPMD_LOOKUP_R4 Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_EPMD_LOOKUP_R4
public const string ERL_EPMD_LOOKUP_R4
Public Const ERL_EPMD_LOOKUP_R4 As String
Public Const ERL_EPMD_LOOKUP_R4 As String
public:
literal String^ ERL_EPMD_LOOKUP_R4
public:
literal String^ ERL_EPMD_LOOKUP_R4
static val mutable ERL_EPMD_LOOKUP_R4: string
static val mutable ERL_EPMD_LOOKUP_R4: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_EPMD_NO_RESPONSE Field

StringConsts ERL_EPMD_NO_RESPONSE Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_EPMD_NO_RESPONSE
public const string ERL_EPMD_NO_RESPONSE
Public Const ERL_EPMD_NO_RESPONSE As String
Public Const ERL_EPMD_NO_RESPONSE As String
public:
literal String^ ERL_EPMD_NO_RESPONSE
public:
literal String^ ERL_EPMD_NO_RESPONSE
static val mutable ERL_EPMD_NO_RESPONSE: string
static val mutable ERL_EPMD_NO_RESPONSE: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_EPMD_NOT_FOUND Field

StringConsts ERL_EPMD_NOT_FOUND Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_EPMD_NOT_FOUND
public const string ERL_EPMD_NOT_FOUND
Public Const ERL_EPMD_NOT_FOUND As String
Public Const ERL_EPMD_NOT_FOUND As String
public:
literal String^ ERL_EPMD_NOT_FOUND
public:
literal String^ ERL_EPMD_NOT_FOUND
static val mutable ERL_EPMD_NOT_FOUND: string
static val mutable ERL_EPMD_NOT_FOUND: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_EPMD_NOT_RESPONDING Field

StringConsts ERL_EPMD_NOT_RESPONDING Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_EPMD_NOT_RESPONDING
public const string ERL_EPMD_NOT_RESPONDING
Public Const ERL_EPMD_NOT_RESPONDING As String
Public Const ERL_EPMD_NOT_RESPONDING As String
public:
literal String^ ERL_EPMD_NOT_RESPONDING
public:
literal String^ ERL_EPMD_NOT_RESPONDING
static val mutable ERL_EPMD_NOT_RESPONDING: string
static val mutable ERL_EPMD_NOT_RESPONDING: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_EPMD_OK Field

StringConsts ERL_EPMD_OK Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_EPMD_OK
public const string ERL_EPMD_OK
Public Const ERL_EPMD_OK As String
Public Const ERL_EPMD_OK As String
public:
literal String^ ERL_EPMD_OK
public:
literal String^ ERL_EPMD_OK
static val mutable ERL_EPMD_OK: string
static val mutable ERL_EPMD_OK: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_EPMD_PORT Field

StringConsts ERL_EPMD_PORT Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_EPMD_PORT
public const string ERL_EPMD_PORT
Public Const ERL_EPMD_PORT As String
Public Const ERL_EPMD_PORT As String
public:
literal String^ ERL_EPMD_PORT
public:
literal String^ ERL_EPMD_PORT
static val mutable ERL_EPMD_PORT: string
static val mutable ERL_EPMD_PORT: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_EPMD_PUBLISH Field

StringConsts ERL_EPMD_PUBLISH Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_EPMD_PUBLISH
public const string ERL_EPMD_PUBLISH
Public Const ERL_EPMD_PUBLISH As String
Public Const ERL_EPMD_PUBLISH As String
public:
literal String^ ERL_EPMD_PUBLISH
public:
literal String^ ERL_EPMD_PUBLISH
static val mutable ERL_EPMD_PUBLISH: string
static val mutable ERL_EPMD_PUBLISH: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_EPMD_UNPUBLISH Field

StringConsts ERL_EPMD_UNPUBLISH Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_EPMD_UNPUBLISH
public const string ERL_EPMD_UNPUBLISH
Public Const ERL_EPMD_UNPUBLISH As String
Public Const ERL_EPMD_UNPUBLISH As String
public:
literal String^ ERL_EPMD_UNPUBLISH
public:
literal String^ ERL_EPMD_UNPUBLISH
static val mutable ERL_EPMD_UNPUBLISH: string
static val mutable ERL_EPMD_UNPUBLISH: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_INVALID_DATA_FORMAT_ERROR Field

StringConsts ERL_INVALID_DATA_FORMAT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_INVALID_DATA_FORMAT_ERROR
public const string ERL_INVALID_DATA_FORMAT_ERROR
Public Const ERL_INVALID_DATA_FORMAT_ERROR As String
Public Const ERL_INVALID_DATA_FORMAT_ERROR As String
public:
literal String^ ERL_INVALID_DATA_FORMAT_ERROR
public:
literal String^ ERL_INVALID_DATA_FORMAT_ERROR
static val mutable ERL_INVALID_DATA_FORMAT_ERROR: string
static val mutable ERL_INVALID_DATA_FORMAT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_INVALID_FORMATTING_CHAR_ERROR Field

StringConsts ERL_INVALID_FORMATTING_CHAR_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_INVALID_FORMATTING_CHAR_ERROR
public const string ERL_INVALID_FORMATTING_CHAR_ERROR
Public Const ERL_INVALID_FORMATTING_CHAR_ERROR As String
Public Const ERL_INVALID_FORMATTING_CHAR_ERROR As String
public:
literal String^ ERL_INVALID_FORMATTING_CHAR_ERROR
public:
literal String^ ERL_INVALID_FORMATTING_CHAR_ERROR
static val mutable ERL_INVALID_FORMATTING_CHAR_ERROR: string
static val mutable ERL_INVALID_FORMATTING_CHAR_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_INVALID_IO_REQUEST Field

StringConsts ERL_INVALID_IO_REQUEST Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_INVALID_IO_REQUEST
public const string ERL_INVALID_IO_REQUEST
Public Const ERL_INVALID_IO_REQUEST As String
Public Const ERL_INVALID_IO_REQUEST As String
public:
literal String^ ERL_INVALID_IO_REQUEST
public:
literal String^ ERL_INVALID_IO_REQUEST
static val mutable ERL_INVALID_IO_REQUEST: string
static val mutable ERL_INVALID_IO_REQUEST: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_INVALID_MBOX_NAME_ERROR Field

StringConsts ERL_INVALID_MBOX_NAME_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_INVALID_MBOX_NAME_ERROR
public const string ERL_INVALID_MBOX_NAME_ERROR
Public Const ERL_INVALID_MBOX_NAME_ERROR As String
Public Const ERL_INVALID_MBOX_NAME_ERROR As String
public:
literal String^ ERL_INVALID_MBOX_NAME_ERROR
public:
literal String^ ERL_INVALID_MBOX_NAME_ERROR
static val mutable ERL_INVALID_MBOX_NAME_ERROR: string
static val mutable ERL_INVALID_MBOX_NAME_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_INVALID_MFA_FORMAT_ERROR Field

StringConsts ERL_INVALID_MFA_FORMAT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_INVALID_MFA_FORMAT_ERROR
public const string ERL_INVALID_MFA_FORMAT_ERROR
Public Const ERL_INVALID_MFA_FORMAT_ERROR As String
Public Const ERL_INVALID_MFA_FORMAT_ERROR As String
public:
literal String^ ERL_INVALID_MFA_FORMAT_ERROR
public:
literal String^ ERL_INVALID_MFA_FORMAT_ERROR
static val mutable ERL_INVALID_MFA_FORMAT_ERROR: string
static val mutable ERL_INVALID_MFA_FORMAT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_INVALID_NUMBER_OF_ARGS_ERROR Field

StringConsts ERL_INVALID_NUMBER_OF_ARGS_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_INVALID_NUMBER_OF_ARGS_ERROR
public const string ERL_INVALID_NUMBER_OF_ARGS_ERROR
Public Const ERL_INVALID_NUMBER_OF_ARGS_ERROR As String
Public Const ERL_INVALID_NUMBER_OF_ARGS_ERROR As String
public:
literal String^ ERL_INVALID_NUMBER_OF_ARGS_ERROR
public:
literal String^ ERL_INVALID_NUMBER_OF_ARGS_ERROR
static val mutable ERL_INVALID_NUMBER_OF_ARGS_ERROR: string
static val mutable ERL_INVALID_NUMBER_OF_ARGS_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_INVALID_RPC_REQUEST_ERROR Field

StringConsts ERL_INVALID_RPC_REQUEST_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_INVALID_RPC_REQUEST_ERROR
public const string ERL_INVALID_RPC_REQUEST_ERROR
Public Const ERL_INVALID_RPC_REQUEST_ERROR As String
Public Const ERL_INVALID_RPC_REQUEST_ERROR As String
public:
literal String^ ERL_INVALID_RPC_REQUEST_ERROR
public:
literal String^ ERL_INVALID_RPC_REQUEST_ERROR
static val mutable ERL_INVALID_RPC_REQUEST_ERROR: string
static val mutable ERL_INVALID_RPC_REQUEST_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_INVALID_TERM_TYPE_ERROR Field

StringConsts ERL_INVALID_TERM_TYPE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_INVALID_TERM_TYPE_ERROR
public const string ERL_INVALID_TERM_TYPE_ERROR
Public Const ERL_INVALID_TERM_TYPE_ERROR As String
Public Const ERL_INVALID_TERM_TYPE_ERROR As String
public:
literal String^ ERL_INVALID_TERM_TYPE_ERROR
public:
literal String^ ERL_INVALID_TERM_TYPE_ERROR
static val mutable ERL_INVALID_TERM_TYPE_ERROR: string
static val mutable ERL_INVALID_TERM_TYPE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_INVALID_VALUE_CAST_ERROR Field

StringConsts ERL_INVALID_VALUE_CAST_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_INVALID_VALUE_CAST_ERROR
public const string ERL_INVALID_VALUE_CAST_ERROR
Public Const ERL_INVALID_VALUE_CAST_ERROR As String
Public Const ERL_INVALID_VALUE_CAST_ERROR As String
public:
literal String^ ERL_INVALID_VALUE_CAST_ERROR
public:
literal String^ ERL_INVALID_VALUE_CAST_ERROR
static val mutable ERL_INVALID_VALUE_CAST_ERROR: string
static val mutable ERL_INVALID_VALUE_CAST_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_INVALID_VALUE_ERROR Field

StringConsts ERL_INVALID_VALUE_ERROR Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_INVALID_VALUE_ERROR
public const string ERL_INVALID_VALUE_ERROR
Public Const ERL_INVALID_VALUE_ERROR As String
Public Const ERL_INVALID_VALUE_ERROR As String
public:
literal String^ ERL_INVALID_VALUE_ERROR
public:
literal String^ ERL_INVALID_VALUE_ERROR
static val mutable ERL_INVALID_VALUE_ERROR: string
static val mutable ERL_INVALID_VALUE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_INVALID_VALUE_LENGTH_ERROR Field

StringConsts ERL_INVALID_VALUE_LENGTH_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_INVALID_VALUE_LENGTH_ERROR
public const string ERL_INVALID_VALUE_LENGTH_ERROR
Public Const ERL_INVALID_VALUE_LENGTH_ERROR As String
Public Const ERL_INVALID_VALUE_LENGTH_ERROR As String
public:
literal String^ ERL_INVALID_VALUE_LENGTH_ERROR
public:
literal String^ ERL_INVALID_VALUE_LENGTH_ERROR
static val mutable ERL_INVALID_VALUE_LENGTH_ERROR: string
static val mutable ERL_INVALID_VALUE_LENGTH_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_INVALID_VALUE_TYPE_ERROR Field

StringConsts ERL_INVALID_VALUE_TYPE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_INVALID_VALUE_TYPE_ERROR
public const string ERL_INVALID_VALUE_TYPE_ERROR
Public Const ERL_INVALID_VALUE_TYPE_ERROR As String
Public Const ERL_INVALID_VALUE_TYPE_ERROR As String
public:
literal String^ ERL_INVALID_VALUE_TYPE_ERROR
public:
literal String^ ERL_INVALID_VALUE_TYPE_ERROR
static val mutable ERL_INVALID_VALUE_TYPE_ERROR: string
static val mutable ERL_INVALID_VALUE_TYPE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_INVALID_VARIABLE_TYPE_ERROR Field

StringConsts ERL_INVALID_VARIABLE_TYPE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_INVALID_VARIABLE_TYPE_ERROR
public const string ERL_INVALID_VARIABLE_TYPE_ERROR
Public Const ERL_INVALID_VARIABLE_TYPE_ERROR As String
Public Const ERL_INVALID_VARIABLE_TYPE_ERROR As String
public:
literal String^ ERL_INVALID_VARIABLE_TYPE_ERROR
public:
literal String^ ERL_INVALID_VARIABLE_TYPE_ERROR
static val mutable ERL_INVALID_VARIABLE_TYPE_ERROR: string
static val mutable ERL_INVALID_VARIABLE_TYPE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_MISSING_VALUE_FOR_ARGUMENT_ERROR Field

StringConsts ERL_MISSING_VALUE_FOR_ARGUMENT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_MISSING_VALUE_FOR_ARGUMENT_ERROR
public const string ERL_MISSING_VALUE_FOR_ARGUMENT_ERROR
Public Const ERL_MISSING_VALUE_FOR_ARGUMENT_ERROR As String
Public Const ERL_MISSING_VALUE_FOR_ARGUMENT_ERROR As String
public:
literal String^ ERL_MISSING_VALUE_FOR_ARGUMENT_ERROR
public:
literal String^ ERL_MISSING_VALUE_FOR_ARGUMENT_ERROR
static val mutable ERL_MISSING_VALUE_FOR_ARGUMENT_ERROR: string
static val mutable ERL_MISSING_VALUE_FOR_ARGUMENT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_PARSING_AT_ERROR Field

StringConsts ERL_PARSING_AT_ERROR Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_PARSING_AT_ERROR
public const string ERL_PARSING_AT_ERROR
Public Const ERL_PARSING_AT_ERROR As String
Public Const ERL_PARSING_AT_ERROR As String
public:
literal String^ ERL_PARSING_AT_ERROR
public:
literal String^ ERL_PARSING_AT_ERROR
static val mutable ERL_PARSING_AT_ERROR: string
static val mutable ERL_PARSING_AT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_REF_ID_ARGUMENT_ERROR Field

StringConsts ERL_REF_ID_ARGUMENT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_REF_ID_ARGUMENT_ERROR
public const string ERL_REF_ID_ARGUMENT_ERROR
Public Const ERL_REF_ID_ARGUMENT_ERROR As String
Public Const ERL_REF_ID_ARGUMENT_ERROR As String
public:
literal String^ ERL_REF_ID_ARGUMENT_ERROR
public:
literal String^ ERL_REF_ID_ARGUMENT_ERROR
static val mutable ERL_REF_ID_ARGUMENT_ERROR: string
static val mutable ERL_REF_ID_ARGUMENT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_STOPPING_SERVER Field

StringConsts ERL_STOPPING_SERVER Field NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_STOPPING_SERVER
public const string ERL_STOPPING_SERVER
Public Const ERL_STOPPING_SERVER As String
Public Const ERL_STOPPING_SERVER As String
public:
literal String^ ERL_STOPPING_SERVER
public:
literal String^ ERL_STOPPING_SERVER
static val mutable ERL_STOPPING_SERVER: string
static val mutable ERL_STOPPING_SERVER: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_UNBOUND_VARIABLE_ERROR Field

StringConsts ERL_UNBOUND_VARIABLE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_UNBOUND_VARIABLE_ERROR
public const string ERL_UNBOUND_VARIABLE_ERROR
Public Const ERL_UNBOUND_VARIABLE_ERROR As String
Public Const ERL_UNBOUND_VARIABLE_ERROR As String
public:
literal String^ ERL_UNBOUND_VARIABLE_ERROR
public:
literal String^ ERL_UNBOUND_VARIABLE_ERROR
static val mutable ERL_UNBOUND_VARIABLE_ERROR: string
static val mutable ERL_UNBOUND_VARIABLE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_UNSUPPORTED_ELEMENT_TYPE_ERROR Field

StringConsts ERL_UNSUPPORTED_ELEMENT_TYPE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_UNSUPPORTED_ELEMENT_TYPE_ERROR
public const string ERL_UNSUPPORTED_ELEMENT_TYPE_ERROR
Public Const ERL_UNSUPPORTED_ELEMENT_TYPE_ERROR As String
Public Const ERL_UNSUPPORTED_ELEMENT_TYPE_ERROR As String
public:
literal String^ ERL_UNSUPPORTED_ELEMENT_TYPE_ERROR
public:
literal String^ ERL_UNSUPPORTED_ELEMENT_TYPE_ERROR
static val mutable ERL_UNSUPPORTED_ELEMENT_TYPE_ERROR: string
static val mutable ERL_UNSUPPORTED_ELEMENT_TYPE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_UNSUPPORTED_TERM_TYPE_ERROR Field

StringConsts ERL_UNSUPPORTED_TERM_TYPE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_UNSUPPORTED_TERM_TYPE_ERROR
public const string ERL_UNSUPPORTED_TERM_TYPE_ERROR
Public Const ERL_UNSUPPORTED_TERM_TYPE_ERROR As String
Public Const ERL_UNSUPPORTED_TERM_TYPE_ERROR As String
public:
literal String^ ERL_UNSUPPORTED_TERM_TYPE_ERROR
public:
literal String^ ERL_UNSUPPORTED_TERM_TYPE_ERROR
static val mutable ERL_UNSUPPORTED_TERM_TYPE_ERROR: string
static val mutable ERL_UNSUPPORTED_TERM_TYPE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_VALUE_MUST_NOT_BE_NULL_ERROR Field

StringConsts ERL_VALUE_MUST_NOT_BE_NULL_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_VALUE_MUST_NOT_BE_NULL_ERROR
public const string ERL_VALUE_MUST_NOT_BE_NULL_ERROR
Public Const ERL_VALUE_MUST_NOT_BE_NULL_ERROR As String
Public Const ERL_VALUE_MUST_NOT_BE_NULL_ERROR As String
public:
literal String^ ERL_VALUE_MUST_NOT_BE_NULL_ERROR
public:
literal String^ ERL_VALUE_MUST_NOT_BE_NULL_ERROR
static val mutable ERL_VALUE_MUST_NOT_BE_NULL_ERROR: string
static val mutable ERL_VALUE_MUST_NOT_BE_NULL_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_VALUE_TOO_LARGE_FOR_TYPE_ERROR Field

StringConsts ERL_VALUE_TOO_LARGE_FOR_TYPE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_VALUE_TOO_LARGE_FOR_TYPE_ERROR
public const string ERL_VALUE_TOO_LARGE_FOR_TYPE_ERROR
Public Const ERL_VALUE_TOO_LARGE_FOR_TYPE_ERROR As String
Public Const ERL_VALUE_TOO_LARGE_FOR_TYPE_ERROR As String
public:
literal String^ ERL_VALUE_TOO_LARGE_FOR_TYPE_ERROR
public:
literal String^ ERL_VALUE_TOO_LARGE_FOR_TYPE_ERROR
static val mutable ERL_VALUE_TOO_LARGE_FOR_TYPE_ERROR: string
static val mutable ERL_VALUE_TOO_LARGE_FOR_TYPE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_VARIABLE_INVALID_VALUE_TYPE_ERROR Field

StringConsts ERL_VARIABLE_INVALID_VALUE_TYPE_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_VARIABLE_INVALID_VALUE_TYPE_ERROR
public const string ERL_VARIABLE_INVALID_VALUE_TYPE_ERROR
Public Const ERL_VARIABLE_INVALID_VALUE_TYPE_ERROR As String
Public Const ERL_VARIABLE_INVALID_VALUE_TYPE_ERROR As String
public:
literal String^ ERL_VARIABLE_INVALID_VALUE_TYPE_ERROR
public:
literal String^ ERL_VARIABLE_INVALID_VALUE_TYPE_ERROR
static val mutable ERL_VARIABLE_INVALID_VALUE_TYPE_ERROR: string
static val mutable ERL_VARIABLE_INVALID_VALUE_TYPE_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_VARIABLE_NOT_FOUND_ERROR Field

StringConsts ERL_VARIABLE_NOT_FOUND_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_VARIABLE_NOT_FOUND_ERROR
public const string ERL_VARIABLE_NOT_FOUND_ERROR
Public Const ERL_VARIABLE_NOT_FOUND_ERROR As String
Public Const ERL_VARIABLE_NOT_FOUND_ERROR As String
public:
literal String^ ERL_VARIABLE_NOT_FOUND_ERROR
public:
literal String^ ERL_VARIABLE_NOT_FOUND_ERROR
static val mutable ERL_VARIABLE_NOT_FOUND_ERROR: string
static val mutable ERL_VARIABLE_NOT_FOUND_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


StringConsts.ERL_WRONG_VALUE_FOR_ARGUMENT_ERROR Field

StringConsts ERL_WRONG_VALUE_FOR_ARGUMENT_ERROR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ERL_WRONG_VALUE_FOR_ARGUMENT_ERROR
public const string ERL_WRONG_VALUE_FOR_ARGUMENT_ERROR
Public Const ERL_WRONG_VALUE_FOR_ARGUMENT_ERROR As String
Public Const ERL_WRONG_VALUE_FOR_ARGUMENT_ERROR As String
public:
literal String^ ERL_WRONG_VALUE_FOR_ARGUMENT_ERROR
public:
literal String^ ERL_WRONG_VALUE_FOR_ARGUMENT_ERROR
static val mutable ERL_WRONG_VALUE_FOR_ARGUMENT_ERROR: string
static val mutable ERL_WRONG_VALUE_FOR_ARGUMENT_ERROR: string

Field Value

Type: Online String
See Also
StringConsts Class
StringConsts Members
NFX.Erlang Namespace


TraceEventHandler Delegate

TraceEventHandler Delegate NFX Class Library

Debugging delegate called to be able to record transport-related events

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void TraceEventHandler(
    Object sender,
    ErlTraceLevel type,
    Direction dir,
    string message
)
public delegate void TraceEventHandler(
    Object sender,
    ErlTraceLevel type,
    Direction dir,
    string message
)
Public Delegate Sub TraceEventHandler (
    sender As Object,
    type As ErlTraceLevel,
    dir As Direction,
    message As String
)
Public Delegate Sub TraceEventHandler (
    sender As Object,
    type As ErlTraceLevel,
    dir As Direction,
    message As String
)
public delegate void TraceEventHandler(
    Object^ sender,
    ErlTraceLevel type,
    Direction dir,
    String^ message
)
public delegate void TraceEventHandler(
    Object^ sender,
    ErlTraceLevel type,
    Direction dir,
    String^ message
)
type TraceEventHandler =
    delegate of
        sender : Object *
        type : ErlTraceLevel *
        dir : Direction *
        message : string -> unit
type TraceEventHandler =
    delegate of
        sender : Object *
        type : ErlTraceLevel *
        dir : Direction *
        message : string -> unit

Parameters

sender
Type: Online System Object
Event sender
type
Type: NFX.Erlang ErlTraceLevel
Type of trace event
dir
Type: NFX.Erlang Direction
Event direction (in/out-bound)
message
Type: Online System String
Event detail
See Also
NFX.Erlang Namespace


UnhandledMsgEventHandler Delegate

UnhandledMsgEventHandler Delegate NFX Class Library

Namespace: NFX.Erlang
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void UnhandledMsgEventHandler(
    ErlLocalNode sender,
    ErlConnection conn,
    ErlMsg msg
)
public delegate void UnhandledMsgEventHandler(
    ErlLocalNode sender,
    ErlConnection conn,
    ErlMsg msg
)
Public Delegate Sub UnhandledMsgEventHandler (
    sender As ErlLocalNode,
    conn As ErlConnection,
    msg As ErlMsg
)
Public Delegate Sub UnhandledMsgEventHandler (
    sender As ErlLocalNode,
    conn As ErlConnection,
    msg As ErlMsg
)
public delegate void UnhandledMsgEventHandler(
    ErlLocalNode^ sender,
    ErlConnection^ conn,
    ErlMsg^ msg
)
public delegate void UnhandledMsgEventHandler(
    ErlLocalNode^ sender,
    ErlConnection^ conn,
    ErlMsg^ msg
)
type UnhandledMsgEventHandler =
    delegate of
        sender : ErlLocalNode *
        conn : ErlConnection *
        msg : ErlMsg -> unit
type UnhandledMsgEventHandler =
    delegate of
        sender : ErlLocalNode *
        conn : ErlConnection *
        msg : ErlMsg -> unit

Parameters

sender
Type: NFX.Erlang ErlLocalNode
conn
Type: NFX.Erlang ErlConnection
msg
Type: NFX.Erlang ErlMsg
See Also
NFX.Erlang Namespace


NFX.Erlang.DataAccess Namespace

NFX.Erlang.DataAccess Namespace NFX Class Library

Classes
 | Class | Description
Public class | ErlSchemaUtils |


ErlSchemaUtils Class

ErlSchemaUtils Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Erlang.DataAccess ErlSchemaUtils

Namespace: NFX.Erlang.DataAccess
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class ErlSchemaUtils
public static class ErlSchemaUtils
<ExtensionAttribute>
Public NotInheritable Class ErlSchemaUtils
<ExtensionAttribute>
Public NotInheritable Class ErlSchemaUtils
[ExtensionAttribute]
public ref class ErlSchemaUtils abstract sealed
[ExtensionAttribute]
public ref class ErlSchemaUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ErlSchemaUtils =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ErlSchemaUtils =  class end
See Also
ErlSchemaUtils Members
NFX.Erlang.DataAccess Namespace


ErlSchemaUtils Members

ErlSchemaUtils Members NFX Class Library

The ErlSchemaUtils type exposes the following members.
Methods
Name Description
ToErlObject
Convert Row to a hierarchical term that corresponds to the row's schema. The Erlang term is in the form:
View Colorized Copy to Clipboard Print
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
Update
Convert an Erlang hierarchical term representing a schema to a Row.
Back to Top
See Also
ErlSchemaUtils Class
NFX.Erlang.DataAccess Namespace


ErlSchemaUtils Methods

ErlSchemaUtils Methods NFX Class Library

The ErlSchemaUtils type exposes the following members.
Methods
Name Description
ToErlObject
Convert Row to a hierarchical term that corresponds to the row's schema. The Erlang term is in the form:
View Colorized Copy to Clipboard Print
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
Update
Convert an Erlang hierarchical term representing a schema to a Row.
Back to Top
See Also
ErlSchemaUtils Class
NFX.Erlang.DataAccess Namespace


ErlSchemaUtils.ToErlObject Method

ErlSchemaUtils ToErlObject Method NFX Class Library

Convert Row to a hierarchical term that corresponds to the row's schema. The Erlang term is in the form:
View Colorized Copy to Clipboard Print
{SchemaName::atom(), [{FieldName::atom(), Value}]}.
{SchemaName::atom(), [{FieldName::atom(), Value}]}.

Namespace: NFX.Erlang.DataAccess
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IErlObject ToErlObject(
    this Row row,
    string targetName = null,
    string schemaName = null,
    bool outputDefVals = true
)
public static IErlObject ToErlObject(
    this Row row,
    string targetName = null,
    string schemaName = null,
    bool outputDefVals = true
)
<ExtensionAttribute>
Public Shared Function ToErlObject (
    row As Row,
    Optional targetName As String = Nothing,
    Optional schemaName As String = Nothing,
    Optional outputDefVals As Boolean = true
) As IErlObject
<ExtensionAttribute>
Public Shared Function ToErlObject (
    row As Row,
    Optional targetName As String = Nothing,
    Optional schemaName As String = Nothing,
    Optional outputDefVals As Boolean = true
) As IErlObject
public:
[ExtensionAttribute]
static IErlObject^ ToErlObject(
    Row^ row,
    String^ targetName = nullptr,
    String^ schemaName = nullptr,
    bool outputDefVals = true
)
public:
[ExtensionAttribute]
static IErlObject^ ToErlObject(
    Row^ row,
    String^ targetName = nullptr,
    String^ schemaName = nullptr,
    bool outputDefVals = true
)
static member ToErlObject :
        row : Row *
        ?targetName : string *
        ?schemaName : string *
        ?outputDefVals : bool
(* Defaults:
        let _targetName = defaultArg targetName null
        let _schemaName = defaultArg schemaName null
        let _outputDefVals = defaultArg outputDefVals true
*)
-> IErlObject
static member ToErlObject :
        row : Row *
        ?targetName : string *
        ?schemaName : string *
        ?outputDefVals : bool
(* Defaults:
        let _targetName = defaultArg targetName null
        let _schemaName = defaultArg schemaName null
        let _outputDefVals = defaultArg outputDefVals true
*)
-> IErlObject

Parameters

row
Type: NFX.DataAccess.CRUD Row
Row to convert to Erlang object
targetName (Optional)
Type: Online System String
Target to use to lookup field attributes in the row
schemaName (Optional)
Type: Online System String
Alternative schema name to use for the outermost name of the schema in the output.
outputDefVals (Optional)
Type: Online System Boolean
When false no field values are included in output if they are equal to default values

Return Value

Type: IErlObject

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Row. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ErlSchemaUtils Class
ErlSchemaUtils Members
NFX.Erlang.DataAccess Namespace


ErlSchemaUtils.Update Method

ErlSchemaUtils Update Method NFX Class Library

Convert an Erlang hierarchical term representing a schema to a Row.

Namespace: NFX.Erlang.DataAccess
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Update(
    this Row row,
    IErlObject data,
    Schema schema = null,
    string targetName = null,
    string schemaName = null,
    Registry<Schema> knownSchemas = null
)
public static void Update(
    this Row row,
    IErlObject data,
    Schema schema = null,
    string targetName = null,
    string schemaName = null,
    Registry<Schema> knownSchemas = null
)
<ExtensionAttribute>
Public Shared Sub Update (
    row As Row,
    data As IErlObject,
    Optional schema As Schema = Nothing,
    Optional targetName As String = Nothing,
    Optional schemaName As String = Nothing,
    Optional knownSchemas As Registry(Of Schema) = Nothing
)
<ExtensionAttribute>
Public Shared Sub Update (
    row As Row,
    data As IErlObject,
    Optional schema As Schema = Nothing,
    Optional targetName As String = Nothing,
    Optional schemaName As String = Nothing,
    Optional knownSchemas As Registry(Of Schema) = Nothing
)
public:
[ExtensionAttribute]
static void Update(
    Row^ row,
    IErlObject^ data,
    Schema^ schema = nullptr,
    String^ targetName = nullptr,
    String^ schemaName = nullptr,
    Registry<Schema^>^ knownSchemas = nullptr
)
public:
[ExtensionAttribute]
static void Update(
    Row^ row,
    IErlObject^ data,
    Schema^ schema = nullptr,
    String^ targetName = nullptr,
    String^ schemaName = nullptr,
    Registry<Schema^>^ knownSchemas = nullptr
)
static member Update :
        row : Row *
        data : IErlObject *
        ?schema : Schema *
        ?targetName : string *
        ?schemaName : string *
        ?knownSchemas : Registry<Schema>
(* Defaults:
        let _schema = defaultArg schema null
        let _targetName = defaultArg targetName null
        let _schemaName = defaultArg schemaName null
        let _knownSchemas = defaultArg knownSchemas null
*)
-> unit
static member Update :
        row : Row *
        data : IErlObject *
        ?schema : Schema *
        ?targetName : string *
        ?schemaName : string *
        ?knownSchemas : Registry<Schema>
(* Defaults:
        let _schema = defaultArg schema null
        let _targetName = defaultArg targetName null
        let _schemaName = defaultArg schemaName null
        let _knownSchemas = defaultArg knownSchemas null
*)
-> unit

Parameters

row
Type: NFX.DataAccess.CRUD Row
Row to update
data
Type: NFX.Erlang IErlObject
Data to update row with. The data must be in the form {SchemaName::atom, [{FieldName::atom(), Value}]}.
schema (Optional)
Type: NFX.DataAccess.CRUD Schema
Alternative schema to use in place of row.Schema
targetName (Optional)
Type: Online System String
Name of the target for looking up field attributes
schemaName (Optional)
Type: Online System String
Alternative name of the top-most 'SchemaName' atom used in the "data".
knownSchemas (Optional)
Type: NFX Registry Schema
List of known schemas to use when initializing a field a DynamicRow type.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Row. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ErlSchemaUtils Class
ErlSchemaUtils Members
NFX.Erlang.DataAccess Namespace


NFX.Erlang.Internal Namespace

NFX.Erlang.Internal Namespace NFX Class Library

Internal Erlang-related classes
Classes
 | Class | Description
Protected class | ErlAcceptor | This thread simply listens for incoming connections
Public class | ErlBlockingQueue T |
Protected class | ErlIoServer | I/O server processing distributed I/O operations from remote Erlang nodes
Protected class | ErlMonitors |
Protected class | ErlRpcServer | Server that handles inbound RPC calls
Protected class | MboxRegistry | This class implements a registry of Mailboxes indexed by Name and Pid
Protected class | Parser | Provides compilation of strings to Erlang terms


ErlAcceptor Class

ErlAcceptor Class NFX Class Library

This thread simply listens for incoming connections
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Erlang.Internal ErlAcceptor

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class ErlAcceptor : DisposableObject
internal class ErlAcceptor : DisposableObject
Friend Class ErlAcceptor
    Inherits DisposableObject
Friend Class ErlAcceptor
    Inherits DisposableObject
internal ref class ErlAcceptor : public DisposableObject
internal ref class ErlAcceptor : public DisposableObject
type ErlAcceptor =
    class
        inherit DisposableObject
    end
type ErlAcceptor =
    class
        inherit DisposableObject
    end
See Also
ErlAcceptor Members
NFX.Erlang.Internal Namespace


ErlAcceptor Members

ErlAcceptor Members NFX Class Library

The ErlAcceptor type exposes the following members.
Constructors
 | Name | Description
Public method | ErlAcceptor | Initializes a new instance of the ErlAcceptor class
Back to Top
Methods
 | Name | Description
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Stop |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Port |
Back to Top
See Also
ErlAcceptor Class
NFX.Erlang.Internal Namespace


ErlAcceptor Constructor

ErlAcceptor Constructor NFX Class Library

Initializes a new instance of the ErlAcceptor class

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlAcceptor(
    ErlLocalNode node,
    int port,
    IPAddress address = null
)
public ErlAcceptor(
    ErlLocalNode node,
    int port,
    IPAddress address = null
)
Public Sub New (
    node As ErlLocalNode,
    port As Integer,
    Optional address As IPAddress = Nothing
)
Public Sub New (
    node As ErlLocalNode,
    port As Integer,
    Optional address As IPAddress = Nothing
)
public:
ErlAcceptor(
    ErlLocalNode^ node,
    int port,
    IPAddress^ address = nullptr
)
public:
ErlAcceptor(
    ErlLocalNode^ node,
    int port,
    IPAddress^ address = nullptr
)
new :
        node : ErlLocalNode *
        port : int *
        ?address : IPAddress
(* Defaults:
        let _address = defaultArg address null
*)
-> ErlAcceptor
new :
        node : ErlLocalNode *
        port : int *
        ?address : IPAddress
(* Defaults:
        let _address = defaultArg address null
*)
-> ErlAcceptor

Parameters

node
Type: NFX.Erlang ErlLocalNode
port
Type: Online System Int32
address (Optional)
Type: Online System.Net IPAddress
See Also
ErlAcceptor Class
ErlAcceptor Members
NFX.Erlang.Internal Namespace


ErlAcceptor Methods

ErlAcceptor Methods NFX Class Library

The ErlAcceptor type exposes the following members.
Methods
 | Name | Description
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Stop |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ErlAcceptor Class
NFX.Erlang.Internal Namespace


ErlAcceptor.Destructor Method

ErlAcceptor Destructor Method NFX Class Library

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
ErlAcceptor Class
ErlAcceptor Members
NFX.Erlang.Internal Namespace


ErlAcceptor.Stop Method

ErlAcceptor Stop Method NFX Class Library

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Stop()
public void Stop()
Public Sub Stop
Public Sub Stop
public:
void Stop()
public:
void Stop()
member Stop : unit -> unit
member Stop : unit -> unit
See Also
ErlAcceptor Class
ErlAcceptor Members
NFX.Erlang.Internal Namespace


ErlAcceptor Properties

ErlAcceptor Properties NFX Class Library

The ErlAcceptor type exposes the following members.
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Port |
Back to Top
See Also
ErlAcceptor Class
NFX.Erlang.Internal Namespace


ErlAcceptor.Port Property

ErlAcceptor Port Property NFX Class Library

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Port { get; }
public int Port { get; }
Public ReadOnly Property Port As Integer
    Get
Public ReadOnly Property Port As Integer
    Get
public:
property int Port {
    int get ();
}
public:
property int Port {
    int get ();
}
member Port : int with get
member Port : int with get

Property Value

Type: Online Int32
See Also
ErlAcceptor Class
ErlAcceptor Members
NFX.Erlang.Internal Namespace


ErlBlockingQueue(T) Class

ErlBlockingQueue T Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Erlang.Internal ErlBlockingQueue T

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ErlBlockingQueue<T> : DisposableObject
public class ErlBlockingQueue<T> : DisposableObject
Public Class ErlBlockingQueue(Of T)
    Inherits DisposableObject
Public Class ErlBlockingQueue(Of T)
    Inherits DisposableObject
generic<typename T>
public ref class ErlBlockingQueue : public DisposableObject
generic<typename T>
public ref class ErlBlockingQueue : public DisposableObject
type ErlBlockingQueue<'T> =
    class
        inherit DisposableObject
    end
type ErlBlockingQueue<'T> =
    class
        inherit DisposableObject
    end
Type Parameters
T
See Also
ErlBlockingQueue T Members
NFX.Erlang.Internal Namespace


ErlBlockingQueue(T) Members

ErlBlockingQueue T Members NFX Class Library

The ErlBlockingQueue T type exposes the following members.
Constructors
 | Name | Description
Public method | ErlBlockingQueue T | Initializes a new instance of the ErlBlockingQueue T class
Back to Top
Methods
 | Name | Description
Public method | Clear |
Public method | Dequeue |
Public method | Dequeue(Int32) |
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | Enqueue |
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryDequeue |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Active |
Public property | Count |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Empty |
Public property | Handle | Queue message arrival notification handle
Back to Top
See Also
ErlBlockingQueue T Class
NFX.Erlang.Internal Namespace


ErlBlockingQueue(T) Constructor

ErlBlockingQueue T Constructor NFX Class Library

Initializes a new instance of the ErlBlockingQueue T class

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlBlockingQueue()
public ErlBlockingQueue()
Public Sub New
Public Sub New
public:
ErlBlockingQueue()
public:
ErlBlockingQueue()
new : unit -> ErlBlockingQueue
new : unit -> ErlBlockingQueue
See Also
ErlBlockingQueue T Class
ErlBlockingQueue T Members
NFX.Erlang.Internal Namespace


ErlBlockingQueue(T) Methods

ErlBlockingQueue T Methods NFX Class Library

The ErlBlockingQueue T type exposes the following members.
Methods
 | Name | Description
Public method | Clear |
Public method | Dequeue |
Public method | Dequeue(Int32) |
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | Enqueue |
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryDequeue |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ErlBlockingQueue T Class
NFX.Erlang.Internal Namespace


ErlBlockingQueue(T).Clear Method

ErlBlockingQueue T Clear Method NFX Class Library

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
void Clear()
public:
void Clear()
member Clear : unit -> unit
member Clear : unit -> unit
See Also
ErlBlockingQueue T Class
ErlBlockingQueue T Members
NFX.Erlang.Internal Namespace


ErlBlockingQueue(T).Dequeue Method

ErlBlockingQueue T Dequeue Method NFX Class Library

Overload List
 | Name | Description
Public method | Dequeue |
Public method | Dequeue(Int32) |
Back to Top
See Also
ErlBlockingQueue T Class
ErlBlockingQueue T Members
NFX.Erlang.Internal Namespace


ErlBlockingQueue(T).Dequeue Method

ErlBlockingQueue T Dequeue Method NFX Class Library

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T Dequeue()
public T Dequeue()
Public Function Dequeue As T
Public Function Dequeue As T
public:
T Dequeue()
public:
T Dequeue()
member Dequeue : unit -> 'T
member Dequeue : unit -> 'T

Return Value

Type: T
See Also
ErlBlockingQueue T Class
ErlBlockingQueue T Members
Dequeue Overload
NFX.Erlang.Internal Namespace


ErlBlockingQueue(T).Dequeue Method (Int32)

ErlBlockingQueue T Dequeue Method (Int32) NFX Class Library

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T Dequeue(
    int timeoutMsec
)
public T Dequeue(
    int timeoutMsec
)
Public Function Dequeue (
    timeoutMsec As Integer
) As T
Public Function Dequeue (
    timeoutMsec As Integer
) As T
public:
T Dequeue(
    int timeoutMsec
)
public:
T Dequeue(
    int timeoutMsec
)
member Dequeue :
        timeoutMsec : int -> 'T
member Dequeue :
        timeoutMsec : int -> 'T

Parameters

timeoutMsec
Type: Online System Int32

Return Value

Type: T
See Also
ErlBlockingQueue T Class
ErlBlockingQueue T Members
Dequeue Overload
NFX.Erlang.Internal Namespace


ErlBlockingQueue(T).Destructor Method

ErlBlockingQueue T Destructor Method NFX Class Library

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
ErlBlockingQueue T Class
ErlBlockingQueue T Members
NFX.Erlang.Internal Namespace


ErlBlockingQueue(T).Enqueue Method

ErlBlockingQueue T Enqueue Method NFX Class Library

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Enqueue(
    T data
)
public void Enqueue(
    T data
)
Public Sub Enqueue (
    data As T
)
Public Sub Enqueue (
    data As T
)
public:
void Enqueue(
    T data
)
public:
void Enqueue(
    T data
)
member Enqueue :
        data : 'T -> unit
member Enqueue :
        data : 'T -> unit

Parameters

data
Type: T
See Also
ErlBlockingQueue T Class
ErlBlockingQueue T Members
NFX.Erlang.Internal Namespace


ErlBlockingQueue(T).TryDequeue Method

ErlBlockingQueue T TryDequeue Method NFX Class Library

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TryDequeue(
    ref T value
)
public bool TryDequeue(
    ref T value
)
Public Function TryDequeue (
    ByRef value As T
) As Boolean
Public Function TryDequeue (
    ByRef value As T
) As Boolean
public:
bool TryDequeue(
    T% value
)
public:
bool TryDequeue(
    T% value
)
member TryDequeue :
        value : 'T byref -> bool
member TryDequeue :
        value : 'T byref -> bool

Parameters

value
Type: T

Return Value

Type: Online Boolean
See Also
ErlBlockingQueue T Class
ErlBlockingQueue T Members
NFX.Erlang.Internal Namespace


ErlBlockingQueue(T) Properties

ErlBlockingQueue T Properties NFX Class Library

The ErlBlockingQueue T type exposes the following members.
Properties
 | Name | Description
Public property | Active |
Public property | Count |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Empty |
Public property | Handle | Queue message arrival notification handle
Back to Top
See Also
ErlBlockingQueue T Class
NFX.Erlang.Internal Namespace


ErlBlockingQueue(T).Active Property

ErlBlockingQueue T Active Property NFX Class Library

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Active { get; set; }
public bool Active { get; set; }
Public Property Active As Boolean
    Get
    Set
Public Property Active As Boolean
    Get
    Set
public:
property bool Active {
    bool get ();
    void set (bool value);
}
public:
property bool Active {
    bool get ();
    void set (bool value);
}
member Active : bool with get, set
member Active : bool with get, set

Property Value

Type: Online Boolean
See Also
ErlBlockingQueue T Class
ErlBlockingQueue T Members
NFX.Erlang.Internal Namespace


ErlBlockingQueue(T).Count Property

ErlBlockingQueue T Count Property NFX Class Library

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
public:
property int Count {
    int get ();
}
member Count : int with get
member Count : int with get

Property Value

Type: Online Int32
See Also
ErlBlockingQueue T Class
ErlBlockingQueue T Members
NFX.Erlang.Internal Namespace


ErlBlockingQueue(T).Empty Property

ErlBlockingQueue T Empty Property NFX Class Library

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Empty { get; }
public bool Empty { get; }
Public ReadOnly Property Empty As Boolean
    Get
Public ReadOnly Property Empty As Boolean
    Get
public:
property bool Empty {
    bool get ();
}
public:
property bool Empty {
    bool get ();
}
member Empty : bool with get
member Empty : bool with get

Property Value

Type: Online Boolean
See Also
ErlBlockingQueue T Class
ErlBlockingQueue T Members
NFX.Erlang.Internal Namespace


ErlBlockingQueue(T).Handle Property

ErlBlockingQueue T Handle Property NFX Class Library

Queue message arrival notification handle

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EventWaitHandle Handle { get; }
public EventWaitHandle Handle { get; }
Public ReadOnly Property Handle As EventWaitHandle
    Get
Public ReadOnly Property Handle As EventWaitHandle
    Get
public:
property EventWaitHandle^ Handle {
    EventWaitHandle^ get ();
}
public:
property EventWaitHandle^ Handle {
    EventWaitHandle^ get ();
}
member Handle : EventWaitHandle with get
member Handle : EventWaitHandle with get

Property Value

Type: Online EventWaitHandle
See Also
ErlBlockingQueue T Class
ErlBlockingQueue T Members
NFX.Erlang.Internal Namespace


ErlIoServer Class

ErlIoServer Class NFX Class Library

I/O server processing distributed I/O operations from remote Erlang nodes
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Erlang.Internal ErlIoServer

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class ErlIoServer : DisposableObject
internal class ErlIoServer : DisposableObject
Friend Class ErlIoServer
    Inherits DisposableObject
Friend Class ErlIoServer
    Inherits DisposableObject
internal ref class ErlIoServer : public DisposableObject
internal ref class ErlIoServer : public DisposableObject
type ErlIoServer =
    class
        inherit DisposableObject
    end
type ErlIoServer =
    class
        inherit DisposableObject
    end
Remarks
Online http://erlang.org/doc/apps/stdlib/io_protocol.html
See Also
ErlIoServer Members
NFX.Erlang.Internal Namespace


ErlIoServer Members

ErlIoServer Members NFX Class Library

The ErlIoServer type exposes the following members.
Constructors
 | Name | Description
Public method | ErlIoServer | Initializes a new instance of the ErlIoServer class
Back to Top
Methods
 | Name | Description
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Node |
Public field | Self |
Back to Top
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Back to Top
See Also
ErlIoServer Class
NFX.Erlang.Internal Namespace


ErlIoServer Constructor

ErlIoServer Constructor NFX Class Library

Initializes a new instance of the ErlIoServer class

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlIoServer(
    ErlLocalNode owner
)
public ErlIoServer(
    ErlLocalNode owner
)
Public Sub New (
    owner As ErlLocalNode
)
Public Sub New (
    owner As ErlLocalNode
)
public:
ErlIoServer(
    ErlLocalNode^ owner
)
public:
ErlIoServer(
    ErlLocalNode^ owner
)
new :
        owner : ErlLocalNode -> ErlIoServer
new :
        owner : ErlLocalNode -> ErlIoServer

Parameters

owner
Type: NFX.Erlang ErlLocalNode
See Also
ErlIoServer Class
ErlIoServer Members
NFX.Erlang.Internal Namespace


ErlIoServer Fields

ErlIoServer Fields NFX Class Library

The ErlIoServer type exposes the following members.
Fields
 | Name | Description
Public field | Node |
Public field | Self |
Back to Top
See Also
ErlIoServer Class
NFX.Erlang.Internal Namespace


ErlIoServer.Node Field

ErlIoServer Node Field NFX Class Library

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ErlLocalNode Node
public readonly ErlLocalNode Node
Public ReadOnly Node As ErlLocalNode
Public ReadOnly Node As ErlLocalNode
public:
initonly ErlLocalNode^ Node
public:
initonly ErlLocalNode^ Node
val Node: ErlLocalNode
val Node: ErlLocalNode

Field Value

Type: ErlLocalNode
See Also
ErlIoServer Class
ErlIoServer Members
NFX.Erlang.Internal Namespace


ErlIoServer.Self Field

ErlIoServer Self Field NFX Class Library

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ErlMbox Self
public readonly ErlMbox Self
Public ReadOnly Self As ErlMbox
Public ReadOnly Self As ErlMbox
public:
initonly ErlMbox^ Self
public:
initonly ErlMbox^ Self
val Self: ErlMbox
val Self: ErlMbox

Field Value

Type: ErlMbox
See Also
ErlIoServer Class
ErlIoServer Members
NFX.Erlang.Internal Namespace


ErlIoServer Methods

ErlIoServer Methods NFX Class Library

The ErlIoServer type exposes the following members.
Methods
 | Name | Description
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ErlIoServer Class
NFX.Erlang.Internal Namespace


ErlIoServer.Destructor Method

ErlIoServer Destructor Method NFX Class Library

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
ErlIoServer Class
ErlIoServer Members
NFX.Erlang.Internal Namespace


ErlIoServer Properties

ErlIoServer Properties NFX Class Library

The ErlIoServer type exposes the following members.
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Back to Top
See Also
ErlIoServer Class
NFX.Erlang.Internal Namespace


ErlMonitors Class

ErlMonitors Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Erlang.Internal ErlMonitors

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class ErlMonitors : IEnumerable<KeyValuePair<ErlRef, ErlPid>>,
    IEnumerable
internal class ErlMonitors : IEnumerable<KeyValuePair<ErlRef, ErlPid>>,
    IEnumerable
Friend Class ErlMonitors
    Implements IEnumerable(Of KeyValuePair(Of ErlRef, ErlPid)),
    IEnumerable
Friend Class ErlMonitors
    Implements IEnumerable(Of KeyValuePair(Of ErlRef, ErlPid)),
    IEnumerable
internal ref class ErlMonitors : IEnumerable<KeyValuePair<ErlRef, ErlPid>>,
    IEnumerable
internal ref class ErlMonitors : IEnumerable<KeyValuePair<ErlRef, ErlPid>>,
    IEnumerable
type ErlMonitors =
    class
        interface IEnumerable<KeyValuePair<ErlRef, ErlPid>>
        interface IEnumerable
    end
type ErlMonitors =
    class
        interface IEnumerable<KeyValuePair<ErlRef, ErlPid>>
        interface IEnumerable
    end
See Also
ErlMonitors Members
NFX.Erlang.Internal Namespace


ErlMonitors Members

ErlMonitors Members NFX Class Library

The ErlMonitors type exposes the following members.
Constructors
 | Name | Description
Public method | ErlMonitors | Initializes a new instance of the ErlMonitors class
Back to Top
Methods
 | Name | Description
Public method | Add(ErlAtom) |
Public method | Add(ErlPid) |
Public method | Add(ErlRef, ErlPid) |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove(ErlRef) |
Public method | Remove(ErlRef, ErlPid ) |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable KeyValuePair ErlRef, ErlPid | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct KeyValuePair ErlRef, ErlPid , TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair ErlRef, ErlPid , TComparand (Func KeyValuePair ErlRef, ErlPid , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair ErlRef, ErlPid , TComparand (Func KeyValuePair ErlRef, ErlPid , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair ErlRef, ErlPid , TComparand (Func KeyValuePair ErlRef, ErlPid , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair ErlRef, ErlPid , TComparand (Func KeyValuePair ErlRef, ErlPid , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault KeyValuePair ErlRef, ErlPid | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair ErlRef, ErlPid (Action KeyValuePair ErlRef, ErlPid ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair ErlRef, ErlPid (Action KeyValuePair ErlRef, ErlPid , Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair ErlRef, ErlPid | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair ErlRef, ErlPid (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
ErlMonitors Class
NFX.Erlang.Internal Namespace


ErlMonitors Constructor

ErlMonitors Constructor NFX Class Library

Initializes a new instance of the ErlMonitors class

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlMonitors(
    ErlMbox owner
)
public ErlMonitors(
    ErlMbox owner
)
Public Sub New (
    owner As ErlMbox
)
Public Sub New (
    owner As ErlMbox
)
public:
ErlMonitors(
    ErlMbox^ owner
)
public:
ErlMonitors(
    ErlMbox^ owner
)
new :
        owner : ErlMbox -> ErlMonitors
new :
        owner : ErlMbox -> ErlMonitors

Parameters

owner
Type: NFX.Erlang ErlMbox
See Also
ErlMonitors Class
ErlMonitors Members
NFX.Erlang.Internal Namespace


ErlMonitors Methods

ErlMonitors Methods NFX Class Library

The ErlMonitors type exposes the following members.
Methods
 | Name | Description
Public method | Add(ErlAtom) |
Public method | Add(ErlPid) |
Public method | Add(ErlRef, ErlPid) |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Remove(ErlRef) |
Public method | Remove(ErlRef, ErlPid ) |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable KeyValuePair ErlRef, ErlPid | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct KeyValuePair ErlRef, ErlPid , TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair ErlRef, ErlPid , TComparand (Func KeyValuePair ErlRef, ErlPid , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair ErlRef, ErlPid , TComparand (Func KeyValuePair ErlRef, ErlPid , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair ErlRef, ErlPid , TComparand (Func KeyValuePair ErlRef, ErlPid , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair ErlRef, ErlPid , TComparand (Func KeyValuePair ErlRef, ErlPid , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault KeyValuePair ErlRef, ErlPid | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair ErlRef, ErlPid (Action KeyValuePair ErlRef, ErlPid ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair ErlRef, ErlPid (Action KeyValuePair ErlRef, ErlPid , Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair ErlRef, ErlPid | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair ErlRef, ErlPid (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
ErlMonitors Class
NFX.Erlang.Internal Namespace


ErlMonitors.IEnumerable.GetEnumerator Method

ErlMonitors IEnumerable GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
ErlMonitors Class
ErlMonitors Members
NFX.Erlang.Internal Namespace


ErlMonitors.Add Method

ErlMonitors Add Method NFX Class Library

Overload List
 | Name | Description
Public method | Add(ErlAtom) |
Public method | Add(ErlPid) |
Public method | Add(ErlRef, ErlPid) |
Back to Top
See Also
ErlMonitors Class
ErlMonitors Members
NFX.Erlang.Internal Namespace


ErlMonitors.Add Method (ErlAtom)

ErlMonitors Add Method (ErlAtom) NFX Class Library

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlRef Add(
    ErlAtom node
)
public ErlRef Add(
    ErlAtom node
)
Public Function Add (
    node As ErlAtom
) As ErlRef
Public Function Add (
    node As ErlAtom
) As ErlRef
public:
ErlRef Add(
    ErlAtom node
)
public:
ErlRef Add(
    ErlAtom node
)
member Add :
        node : ErlAtom -> ErlRef
member Add :
        node : ErlAtom -> ErlRef

Parameters

node
Type: NFX.Erlang ErlAtom

Return Value

Type: ErlRef
See Also
ErlMonitors Class
ErlMonitors Members
Add Overload
NFX.Erlang.Internal Namespace


ErlMonitors.Add Method (ErlPid)

ErlMonitors Add Method (ErlPid) NFX Class Library

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlRef Add(
    ErlPid pid
)
public ErlRef Add(
    ErlPid pid
)
Public Function Add (
    pid As ErlPid
) As ErlRef
Public Function Add (
    pid As ErlPid
) As ErlRef
public:
ErlRef Add(
    ErlPid pid
)
public:
ErlRef Add(
    ErlPid pid
)
member Add :
        pid : ErlPid -> ErlRef
member Add :
        pid : ErlPid -> ErlRef

Parameters

pid
Type: NFX.Erlang ErlPid

Return Value

Type: ErlRef
See Also
ErlMonitors Class
ErlMonitors Members
Add Overload
NFX.Erlang.Internal Namespace


ErlMonitors.Add Method (ErlRef, ErlPid)

ErlMonitors Add Method (ErlRef, ErlPid) NFX Class Library

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Add(
    ErlRef eref,
    ErlPid pid
)
public bool Add(
    ErlRef eref,
    ErlPid pid
)
Public Function Add (
    eref As ErlRef,
    pid As ErlPid
) As Boolean
Public Function Add (
    eref As ErlRef,
    pid As ErlPid
) As Boolean
public:
bool Add(
    ErlRef eref,
    ErlPid pid
)
public:
bool Add(
    ErlRef eref,
    ErlPid pid
)
member Add :
        eref : ErlRef *
        pid : ErlPid -> bool
member Add :
        eref : ErlRef *
        pid : ErlPid -> bool

Parameters

eref
Type: NFX.Erlang ErlRef
pid
Type: NFX.Erlang ErlPid

Return Value

Type: Online Boolean
See Also
ErlMonitors Class
ErlMonitors Members
Add Overload
NFX.Erlang.Internal Namespace


ErlMonitors.GetEnumerator Method

ErlMonitors GetEnumerator Method NFX Class Library

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<KeyValuePair<ErlRef, ErlPid>> GetEnumerator()
public IEnumerator<KeyValuePair<ErlRef, ErlPid>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of ErlRef, ErlPid))
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of ErlRef, ErlPid))
public:
virtual IEnumerator<KeyValuePair<ErlRef, ErlPid>>^ GetEnumerator() sealed
public:
virtual IEnumerator<KeyValuePair<ErlRef, ErlPid>>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<ErlRef, ErlPid>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<ErlRef, ErlPid>>
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<ErlRef, ErlPid>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<ErlRef, ErlPid>>

Return Value

Type: Online IEnumerator Online KeyValuePair ErlRef, ErlPid

Implements

Online IEnumerable T GetEnumerator
See Also
ErlMonitors Class
ErlMonitors Members
NFX.Erlang.Internal Namespace


ErlMonitors.Remove Method

ErlMonitors Remove Method NFX Class Library

Overload List
 | Name | Description
Public method | Remove(ErlRef) |
Public method | Remove(ErlRef, ErlPid ) |
Back to Top
See Also
ErlMonitors Class
ErlMonitors Members
NFX.Erlang.Internal Namespace


ErlMonitors.Remove Method (ErlRef)

ErlMonitors Remove Method (ErlRef) NFX Class Library

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Remove(
    ErlRef eref
)
public bool Remove(
    ErlRef eref
)
Public Function Remove (
    eref As ErlRef
) As Boolean
Public Function Remove (
    eref As ErlRef
) As Boolean
public:
bool Remove(
    ErlRef eref
)
public:
bool Remove(
    ErlRef eref
)
member Remove :
        eref : ErlRef -> bool
member Remove :
        eref : ErlRef -> bool

Parameters

eref
Type: NFX.Erlang ErlRef

Return Value

Type: Online Boolean
See Also
ErlMonitors Class
ErlMonitors Members
Remove Overload
NFX.Erlang.Internal Namespace


ErlMonitors.Remove Method (ErlRef, ErlPid)

ErlMonitors Remove Method (ErlRef, ErlPid ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Remove(
    ErlRef eref,
    out ErlPid pid
)
public bool Remove(
    ErlRef eref,
    out ErlPid pid
)
Public Function Remove (
    eref As ErlRef,
    <OutAttribute> ByRef pid As ErlPid
) As Boolean
Public Function Remove (
    eref As ErlRef,
    <OutAttribute> ByRef pid As ErlPid
) As Boolean
public:
bool Remove(
    ErlRef eref,
    [OutAttribute] ErlPid% pid
)
public:
bool Remove(
    ErlRef eref,
    [OutAttribute] ErlPid% pid
)
member Remove :
        eref : ErlRef *
        pid : ErlPid byref -> bool
member Remove :
        eref : ErlRef *
        pid : ErlPid byref -> bool

Parameters

eref
Type: NFX.Erlang ErlRef
pid
Type: NFX.Erlang ErlPid

Return Value

Type: Online Boolean
See Also
ErlMonitors Class
ErlMonitors Members
Remove Overload
NFX.Erlang.Internal Namespace


ErlRpcServer Class

ErlRpcServer Class NFX Class Library

Server that handles inbound RPC calls
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Erlang.Internal ErlRpcServer

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class ErlRpcServer : DisposableObject
internal class ErlRpcServer : DisposableObject
Friend Class ErlRpcServer
    Inherits DisposableObject
Friend Class ErlRpcServer
    Inherits DisposableObject
internal ref class ErlRpcServer : public DisposableObject
internal ref class ErlRpcServer : public DisposableObject
type ErlRpcServer =
    class
        inherit DisposableObject
    end
type ErlRpcServer =
    class
        inherit DisposableObject
    end
See Also
ErlRpcServer Members
NFX.Erlang.Internal Namespace


ErlRpcServer Members

ErlRpcServer Members NFX Class Library

The ErlRpcServer type exposes the following members.
Constructors
 | Name | Description
Public method | ErlRpcServer | Initializes a new instance of the ErlRpcServer class
Back to Top
Methods
 | Name | Description
 | DecodeRPC |
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
 | EncodeRPC(ErlPid, ErlAtom, ErlAtom, ErlList, IErlObject) |
 | EncodeRPC(ErlPid, String, String, ErlList, IErlObject) |
 | EncodeRPCcast(ErlPid, ErlAtom, ErlAtom, ErlList, IErlObject) |
 | EncodeRPCcast(ErlPid, String, String, ErlList, IErlObject) |
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Node |
 | RpcReplyPattern |
Public field | Self |
Back to Top
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Back to Top
See Also
ErlRpcServer Class
NFX.Erlang.Internal Namespace


ErlRpcServer Constructor

ErlRpcServer Constructor NFX Class Library

Initializes a new instance of the ErlRpcServer class

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlRpcServer(
    ErlLocalNode owner
)
public ErlRpcServer(
    ErlLocalNode owner
)
Public Sub New (
    owner As ErlLocalNode
)
Public Sub New (
    owner As ErlLocalNode
)
public:
ErlRpcServer(
    ErlLocalNode^ owner
)
public:
ErlRpcServer(
    ErlLocalNode^ owner
)
new :
        owner : ErlLocalNode -> ErlRpcServer
new :
        owner : ErlLocalNode -> ErlRpcServer

Parameters

owner
Type: NFX.Erlang ErlLocalNode
See Also
ErlRpcServer Class
ErlRpcServer Members
NFX.Erlang.Internal Namespace


ErlRpcServer Fields

ErlRpcServer Fields NFX Class Library

The ErlRpcServer type exposes the following members.
Fields
 | Name | Description
Public field | Node |
 | RpcReplyPattern |
Public field | Self |
Back to Top
See Also
ErlRpcServer Class
NFX.Erlang.Internal Namespace


ErlRpcServer.Node Field

ErlRpcServer Node Field NFX Class Library

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ErlLocalNode Node
public readonly ErlLocalNode Node
Public ReadOnly Node As ErlLocalNode
Public ReadOnly Node As ErlLocalNode
public:
initonly ErlLocalNode^ Node
public:
initonly ErlLocalNode^ Node
val Node: ErlLocalNode
val Node: ErlLocalNode

Field Value

Type: ErlLocalNode
See Also
ErlRpcServer Class
ErlRpcServer Members
NFX.Erlang.Internal Namespace


ErlRpcServer.RpcReplyPattern Field

ErlRpcServer RpcReplyPattern Field NFX Class Library

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static readonly ErlTuple RpcReplyPattern
internal static readonly ErlTuple RpcReplyPattern
Friend Shared ReadOnly RpcReplyPattern As ErlTuple
Friend Shared ReadOnly RpcReplyPattern As ErlTuple
internal:
static initonly ErlTuple^ RpcReplyPattern
internal:
static initonly ErlTuple^ RpcReplyPattern
static val internal RpcReplyPattern: ErlTuple
static val internal RpcReplyPattern: ErlTuple

Field Value

Type: ErlTuple
See Also
ErlRpcServer Class
ErlRpcServer Members
NFX.Erlang.Internal Namespace


ErlRpcServer.Self Field

ErlRpcServer Self Field NFX Class Library

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ErlMbox Self
public readonly ErlMbox Self
Public ReadOnly Self As ErlMbox
Public ReadOnly Self As ErlMbox
public:
initonly ErlMbox^ Self
public:
initonly ErlMbox^ Self
val Self: ErlMbox
val Self: ErlMbox

Field Value

Type: ErlMbox
See Also
ErlRpcServer Class
ErlRpcServer Members
NFX.Erlang.Internal Namespace


ErlRpcServer Methods

ErlRpcServer Methods NFX Class Library

The ErlRpcServer type exposes the following members.
Methods
 | Name | Description
 | DecodeRPC |
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
 | EncodeRPC(ErlPid, ErlAtom, ErlAtom, ErlList, IErlObject) |
 | EncodeRPC(ErlPid, String, String, ErlList, IErlObject) |
 | EncodeRPCcast(ErlPid, ErlAtom, ErlAtom, ErlList, IErlObject) |
 | EncodeRPCcast(ErlPid, String, String, ErlList, IErlObject) |
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ErlRpcServer Class
NFX.Erlang.Internal Namespace


ErlRpcServer.DecodeRPC Method

ErlRpcServer DecodeRPC Method NFX Class Library

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static IErlObject DecodeRPC(
    IErlObject msg
)
internal static IErlObject DecodeRPC(
    IErlObject msg
)
Friend Shared Function DecodeRPC (
    msg As IErlObject
) As IErlObject
Friend Shared Function DecodeRPC (
    msg As IErlObject
) As IErlObject
internal:
static IErlObject^ DecodeRPC(
    IErlObject^ msg
)
internal:
static IErlObject^ DecodeRPC(
    IErlObject^ msg
)
internal static member DecodeRPC :
        msg : IErlObject -> IErlObject
internal static member DecodeRPC :
        msg : IErlObject -> IErlObject

Parameters

msg
Type: NFX.Erlang IErlObject

Return Value

Type: IErlObject
See Also
ErlRpcServer Class
ErlRpcServer Members
NFX.Erlang.Internal Namespace


ErlRpcServer.Destructor Method

ErlRpcServer Destructor Method NFX Class Library

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
ErlRpcServer Class
ErlRpcServer Members
NFX.Erlang.Internal Namespace


ErlRpcServer.EncodeRPC Method

ErlRpcServer EncodeRPC Method NFX Class Library

Overload List
Name | Description
EncodeRPC(ErlPid, ErlAtom, ErlAtom, ErlList, IErlObject) |
EncodeRPC(ErlPid, String, String, ErlList, IErlObject) |
Back to Top
See Also
ErlRpcServer Class
ErlRpcServer Members
NFX.Erlang.Internal Namespace


ErlRpcServer.EncodeRPC Method (ErlPid, ErlAtom, ErlAtom, ErlList, IErlObject)

ErlRpcServer EncodeRPC Method (ErlPid, ErlAtom, ErlAtom, ErlList, IErlObject) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static ErlTuple EncodeRPC(
    ErlPid from,
    ErlAtom mod,
    ErlAtom fun,
    ErlList args,
    IErlObject gleader
)
internal static ErlTuple EncodeRPC(
    ErlPid from,
    ErlAtom mod,
    ErlAtom fun,
    ErlList args,
    IErlObject gleader
)
Friend Shared Function EncodeRPC (
    from As ErlPid,
    mod As ErlAtom,
    fun As ErlAtom,
    args As ErlList,
    gleader As IErlObject
) As ErlTuple
Friend Shared Function EncodeRPC (
    from As ErlPid,
    mod As ErlAtom,
    fun As ErlAtom,
    args As ErlList,
    gleader As IErlObject
) As ErlTuple
internal:
static ErlTuple^ EncodeRPC(
    ErlPid from,
    ErlAtom mod,
    ErlAtom fun,
    ErlList^ args,
    IErlObject^ gleader
)
internal:
static ErlTuple^ EncodeRPC(
    ErlPid from,
    ErlAtom mod,
    ErlAtom fun,
    ErlList^ args,
    IErlObject^ gleader
)
internal static member EncodeRPC :
        from : ErlPid *
        mod : ErlAtom *
        fun : ErlAtom *
        args : ErlList *
        gleader : IErlObject -> ErlTuple
internal static member EncodeRPC :
        from : ErlPid *
        mod : ErlAtom *
        fun : ErlAtom *
        args : ErlList *
        gleader : IErlObject -> ErlTuple

Parameters

from
Type: NFX.Erlang ErlPid
mod
Type: NFX.Erlang ErlAtom
fun
Type: NFX.Erlang ErlAtom
args
Type: NFX.Erlang ErlList
gleader
Type: NFX.Erlang IErlObject

Return Value

Type: ErlTuple
See Also
ErlRpcServer Class
ErlRpcServer Members
EncodeRPC Overload
NFX.Erlang.Internal Namespace


ErlRpcServer.EncodeRPC Method (ErlPid, String, String, ErlList, IErlObject)

ErlRpcServer EncodeRPC Method (ErlPid, String, String, ErlList, IErlObject) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static ErlTuple EncodeRPC(
    ErlPid from,
    string mod,
    string fun,
    ErlList args,
    IErlObject gleader
)
internal static ErlTuple EncodeRPC(
    ErlPid from,
    string mod,
    string fun,
    ErlList args,
    IErlObject gleader
)
Friend Shared Function EncodeRPC (
    from As ErlPid,
    mod As String,
    fun As String,
    args As ErlList,
    gleader As IErlObject
) As ErlTuple
Friend Shared Function EncodeRPC (
    from As ErlPid,
    mod As String,
    fun As String,
    args As ErlList,
    gleader As IErlObject
) As ErlTuple
internal:
static ErlTuple^ EncodeRPC(
    ErlPid from,
    String^ mod,
    String^ fun,
    ErlList^ args,
    IErlObject^ gleader
)
internal:
static ErlTuple^ EncodeRPC(
    ErlPid from,
    String^ mod,
    String^ fun,
    ErlList^ args,
    IErlObject^ gleader
)
internal static member EncodeRPC :
        from : ErlPid *
        mod : string *
        fun : string *
        args : ErlList *
        gleader : IErlObject -> ErlTuple
internal static member EncodeRPC :
        from : ErlPid *
        mod : string *
        fun : string *
        args : ErlList *
        gleader : IErlObject -> ErlTuple

Parameters

from
Type: NFX.Erlang ErlPid
mod
Type: Online System String
fun
Type: Online System String
args
Type: NFX.Erlang ErlList
gleader
Type: NFX.Erlang IErlObject

Return Value

Type: ErlTuple
See Also
ErlRpcServer Class
ErlRpcServer Members
EncodeRPC Overload
NFX.Erlang.Internal Namespace


ErlRpcServer.EncodeRPCcast Method

ErlRpcServer EncodeRPCcast Method NFX Class Library

Overload List
Name | Description
EncodeRPCcast(ErlPid, ErlAtom, ErlAtom, ErlList, IErlObject) |
EncodeRPCcast(ErlPid, String, String, ErlList, IErlObject) |
Back to Top
See Also
ErlRpcServer Class
ErlRpcServer Members
NFX.Erlang.Internal Namespace


ErlRpcServer.EncodeRPCcast Method (ErlPid, ErlAtom, ErlAtom, ErlList, IErlObject)

ErlRpcServer EncodeRPCcast Method (ErlPid, ErlAtom, ErlAtom, ErlList, IErlObject) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static ErlTuple EncodeRPCcast(
    ErlPid from,
    ErlAtom mod,
    ErlAtom fun,
    ErlList args,
    IErlObject gleader
)
internal static ErlTuple EncodeRPCcast(
    ErlPid from,
    ErlAtom mod,
    ErlAtom fun,
    ErlList args,
    IErlObject gleader
)
Friend Shared Function EncodeRPCcast (
    from As ErlPid,
    mod As ErlAtom,
    fun As ErlAtom,
    args As ErlList,
    gleader As IErlObject
) As ErlTuple
Friend Shared Function EncodeRPCcast (
    from As ErlPid,
    mod As ErlAtom,
    fun As ErlAtom,
    args As ErlList,
    gleader As IErlObject
) As ErlTuple
internal:
static ErlTuple^ EncodeRPCcast(
    ErlPid from,
    ErlAtom mod,
    ErlAtom fun,
    ErlList^ args,
    IErlObject^ gleader
)
internal:
static ErlTuple^ EncodeRPCcast(
    ErlPid from,
    ErlAtom mod,
    ErlAtom fun,
    ErlList^ args,
    IErlObject^ gleader
)
internal static member EncodeRPCcast :
        from : ErlPid *
        mod : ErlAtom *
        fun : ErlAtom *
        args : ErlList *
        gleader : IErlObject -> ErlTuple
internal static member EncodeRPCcast :
        from : ErlPid *
        mod : ErlAtom *
        fun : ErlAtom *
        args : ErlList *
        gleader : IErlObject -> ErlTuple

Parameters

from
Type: NFX.Erlang ErlPid
mod
Type: NFX.Erlang ErlAtom
fun
Type: NFX.Erlang ErlAtom
args
Type: NFX.Erlang ErlList
gleader
Type: NFX.Erlang IErlObject

Return Value

Type: ErlTuple
See Also
ErlRpcServer Class
ErlRpcServer Members
EncodeRPCcast Overload
NFX.Erlang.Internal Namespace


ErlRpcServer.EncodeRPCcast Method (ErlPid, String, String, ErlList, IErlObject)

ErlRpcServer EncodeRPCcast Method (ErlPid, String, String, ErlList, IErlObject) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static ErlTuple EncodeRPCcast(
    ErlPid from,
    string mod,
    string fun,
    ErlList args,
    IErlObject gleader
)
internal static ErlTuple EncodeRPCcast(
    ErlPid from,
    string mod,
    string fun,
    ErlList args,
    IErlObject gleader
)
Friend Shared Function EncodeRPCcast (
    from As ErlPid,
    mod As String,
    fun As String,
    args As ErlList,
    gleader As IErlObject
) As ErlTuple
Friend Shared Function EncodeRPCcast (
    from As ErlPid,
    mod As String,
    fun As String,
    args As ErlList,
    gleader As IErlObject
) As ErlTuple
internal:
static ErlTuple^ EncodeRPCcast(
    ErlPid from,
    String^ mod,
    String^ fun,
    ErlList^ args,
    IErlObject^ gleader
)
internal:
static ErlTuple^ EncodeRPCcast(
    ErlPid from,
    String^ mod,
    String^ fun,
    ErlList^ args,
    IErlObject^ gleader
)
internal static member EncodeRPCcast :
        from : ErlPid *
        mod : string *
        fun : string *
        args : ErlList *
        gleader : IErlObject -> ErlTuple
internal static member EncodeRPCcast :
        from : ErlPid *
        mod : string *
        fun : string *
        args : ErlList *
        gleader : IErlObject -> ErlTuple

Parameters

from
Type: NFX.Erlang ErlPid
mod
Type: Online System String
fun
Type: Online System String
args
Type: NFX.Erlang ErlList
gleader
Type: NFX.Erlang IErlObject

Return Value

Type: ErlTuple
See Also
ErlRpcServer Class
ErlRpcServer Members
EncodeRPCcast Overload
NFX.Erlang.Internal Namespace


ErlRpcServer Properties

ErlRpcServer Properties NFX Class Library

The ErlRpcServer type exposes the following members.
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Back to Top
See Also
ErlRpcServer Class
NFX.Erlang.Internal Namespace


MboxRegistry Class

MboxRegistry Class NFX Class Library

This class implements a registry of Mailboxes indexed by Name and Pid
Inheritance Hierarchy
Online System Object
NFX.Erlang.Internal MboxRegistry

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class MboxRegistry : IEnumerable<KeyValuePair<ErlPid, ErlMbox>>,
    IEnumerable
internal class MboxRegistry : IEnumerable<KeyValuePair<ErlPid, ErlMbox>>,
    IEnumerable
Friend Class MboxRegistry
    Implements IEnumerable(Of KeyValuePair(Of ErlPid, ErlMbox)),
    IEnumerable
Friend Class MboxRegistry
    Implements IEnumerable(Of KeyValuePair(Of ErlPid, ErlMbox)),
    IEnumerable
internal ref class MboxRegistry : IEnumerable<KeyValuePair<ErlPid, ErlMbox^>>,
    IEnumerable
internal ref class MboxRegistry : IEnumerable<KeyValuePair<ErlPid, ErlMbox^>>,
    IEnumerable
type MboxRegistry =
    class
        interface IEnumerable<KeyValuePair<ErlPid, ErlMbox>>
        interface IEnumerable
    end
type MboxRegistry =
    class
        interface IEnumerable<KeyValuePair<ErlPid, ErlMbox>>
        interface IEnumerable
    end
See Also
MboxRegistry Members
NFX.Erlang.Internal Namespace


MboxRegistry Members

MboxRegistry Members NFX Class Library

The MboxRegistry type exposes the following members.
Constructors
 | Name | Description
Public method | MboxRegistry | Initializes a new instance of the MboxRegistry class
Back to Top
Methods
 | Name | Description
Protected method | Clear | Clear the registry
Public method | Create(Boolean) | Return a new or unused mailbox from freelist
Public method | Create(ErlAtom) | Create a named mailbox if one is not already registered, otherwise return registered mailbox
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Register(ErlMbox) | Register an unnamed mailbox with the registry
Public method | Register(String, ErlMbox) | Register a named mailbox with the registry. Name must not be empty
Public method | Register(ErlAtom, ErlMbox) | Register a named mailbox with the registry. Name must not be empty
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Unregister | Unregister a mailbox and move it to free-list
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable KeyValuePair ErlPid, ErlMbox | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct KeyValuePair ErlPid, ErlMbox , TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair ErlPid, ErlMbox , TComparand (Func KeyValuePair ErlPid, ErlMbox , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair ErlPid, ErlMbox , TComparand (Func KeyValuePair ErlPid, ErlMbox , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair ErlPid, ErlMbox , TComparand (Func KeyValuePair ErlPid, ErlMbox , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair ErlPid, ErlMbox , TComparand (Func KeyValuePair ErlPid, ErlMbox , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault KeyValuePair ErlPid, ErlMbox | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair ErlPid, ErlMbox (Action KeyValuePair ErlPid, ErlMbox ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair ErlPid, ErlMbox (Action KeyValuePair ErlPid, ErlMbox , Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair ErlPid, ErlMbox | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair ErlPid, ErlMbox (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Item ErlAtom | Look up a mailbox based on its name
Public property | Item ErlPid | Look up a mailbox based on its pid
Public property | Pids |
Public property | RegNames | Return a list of all registered mailboxes
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
MboxRegistry Class
NFX.Erlang.Internal Namespace


MboxRegistry Constructor

MboxRegistry Constructor NFX Class Library

Initializes a new instance of the MboxRegistry class

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MboxRegistry(
    ErlLocalNode enclosingInstance
)
public MboxRegistry(
    ErlLocalNode enclosingInstance
)
Public Sub New (
    enclosingInstance As ErlLocalNode
)
Public Sub New (
    enclosingInstance As ErlLocalNode
)
public:
MboxRegistry(
    ErlLocalNode^ enclosingInstance
)
public:
MboxRegistry(
    ErlLocalNode^ enclosingInstance
)
new :
        enclosingInstance : ErlLocalNode -> MboxRegistry
new :
        enclosingInstance : ErlLocalNode -> MboxRegistry

Parameters

enclosingInstance
Type: NFX.Erlang ErlLocalNode
See Also
MboxRegistry Class
MboxRegistry Members
NFX.Erlang.Internal Namespace


MboxRegistry Methods

MboxRegistry Methods NFX Class Library

The MboxRegistry type exposes the following members.
Methods
 | Name | Description
Protected method | Clear | Clear the registry
Public method | Create(Boolean) | Return a new or unused mailbox from freelist
Public method | Create(ErlAtom) | Create a named mailbox if one is not already registered, otherwise return registered mailbox
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Register(ErlMbox) | Register an unnamed mailbox with the registry
Public method | Register(String, ErlMbox) | Register a named mailbox with the registry. Name must not be empty
Public method | Register(ErlAtom, ErlMbox) | Register a named mailbox with the registry. Name must not be empty
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Unregister | Unregister a mailbox and move it to free-list
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable KeyValuePair ErlPid, ErlMbox | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct KeyValuePair ErlPid, ErlMbox , TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair ErlPid, ErlMbox , TComparand (Func KeyValuePair ErlPid, ErlMbox , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair ErlPid, ErlMbox , TComparand (Func KeyValuePair ErlPid, ErlMbox , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair ErlPid, ErlMbox , TComparand (Func KeyValuePair ErlPid, ErlMbox , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair ErlPid, ErlMbox , TComparand (Func KeyValuePair ErlPid, ErlMbox , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault KeyValuePair ErlPid, ErlMbox | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair ErlPid, ErlMbox (Action KeyValuePair ErlPid, ErlMbox ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair ErlPid, ErlMbox (Action KeyValuePair ErlPid, ErlMbox , Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair ErlPid, ErlMbox | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair ErlPid, ErlMbox (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
MboxRegistry Class
NFX.Erlang.Internal Namespace


MboxRegistry.IEnumerable.GetEnumerator Method

MboxRegistry IEnumerable GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
MboxRegistry Class
MboxRegistry Members
NFX.Erlang.Internal Namespace


MboxRegistry.Clear Method

MboxRegistry Clear Method NFX Class Library

Clear the registry

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Clear()
internal void Clear()
Friend Sub Clear
Friend Sub Clear
internal:
void Clear()
internal:
void Clear()
internal member Clear : unit -> unit
internal member Clear : unit -> unit
See Also
MboxRegistry Class
MboxRegistry Members
NFX.Erlang.Internal Namespace


MboxRegistry.Create Method

MboxRegistry Create Method NFX Class Library

Overload List
 | Name | Description
Public method | Create(Boolean) | Return a new or unused mailbox from freelist
Public method | Create(ErlAtom) | Create a named mailbox if one is not already registered, otherwise return registered mailbox
Back to Top
See Also
MboxRegistry Class
MboxRegistry Members
NFX.Erlang.Internal Namespace


MboxRegistry.Create Method (Boolean)

MboxRegistry Create Method (Boolean) NFX Class Library

Return a new or unused mailbox from freelist

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlMbox Create(
    bool useCache = true
)
public ErlMbox Create(
    bool useCache = true
)
Public Function Create (
    Optional useCache As Boolean = true
) As ErlMbox
Public Function Create (
    Optional useCache As Boolean = true
) As ErlMbox
public:
ErlMbox^ Create(
    bool useCache = true
)
public:
ErlMbox^ Create(
    bool useCache = true
)
member Create :
        ?useCache : bool
(* Defaults:
        let _useCache = defaultArg useCache true
*)
-> ErlMbox
member Create :
        ?useCache : bool
(* Defaults:
        let _useCache = defaultArg useCache true
*)
-> ErlMbox

Parameters

useCache (Optional)
Type: Online System Boolean

Return Value

Type: ErlMbox
See Also
MboxRegistry Class
MboxRegistry Members
Create Overload
NFX.Erlang.Internal Namespace


MboxRegistry.Create Method (ErlAtom)

MboxRegistry Create Method (ErlAtom) NFX Class Library

Create a named mailbox if one is not already registered, otherwise return registered mailbox

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlMbox Create(
    ErlAtom name
)
public ErlMbox Create(
    ErlAtom name
)
Public Function Create (
    name As ErlAtom
) As ErlMbox
Public Function Create (
    name As ErlAtom
) As ErlMbox
public:
ErlMbox^ Create(
    ErlAtom name
)
public:
ErlMbox^ Create(
    ErlAtom name
)
member Create :
        name : ErlAtom -> ErlMbox
member Create :
        name : ErlAtom -> ErlMbox

Parameters

name
Type: NFX.Erlang ErlAtom

Return Value

Type: ErlMbox
See Also
MboxRegistry Class
MboxRegistry Members
Create Overload
NFX.Erlang.Internal Namespace


MboxRegistry.GetEnumerator Method

MboxRegistry GetEnumerator Method NFX Class Library

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<KeyValuePair<ErlPid, ErlMbox>> GetEnumerator()
public IEnumerator<KeyValuePair<ErlPid, ErlMbox>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of ErlPid, ErlMbox))
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of ErlPid, ErlMbox))
public:
virtual IEnumerator<KeyValuePair<ErlPid, ErlMbox^>>^ GetEnumerator() sealed
public:
virtual IEnumerator<KeyValuePair<ErlPid, ErlMbox^>>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<ErlPid, ErlMbox>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<ErlPid, ErlMbox>>
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<ErlPid, ErlMbox>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<ErlPid, ErlMbox>>

Return Value

Type: Online IEnumerator Online KeyValuePair ErlPid, ErlMbox

Implements

Online IEnumerable T GetEnumerator
See Also
MboxRegistry Class
MboxRegistry Members
NFX.Erlang.Internal Namespace


MboxRegistry.Register Method

MboxRegistry Register Method NFX Class Library

Overload List
 | Name | Description
Public method | Register(ErlMbox) | Register an unnamed mailbox with the registry
Public method | Register(String, ErlMbox) | Register a named mailbox with the registry. Name must not be empty
Public method | Register(ErlAtom, ErlMbox) | Register a named mailbox with the registry. Name must not be empty
Back to Top
See Also
MboxRegistry Class
MboxRegistry Members
NFX.Erlang.Internal Namespace


MboxRegistry.Register Method (ErlMbox)

MboxRegistry Register Method (ErlMbox) NFX Class Library

Register an unnamed mailbox with the registry

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Register(
    ErlMbox mbox
)
public bool Register(
    ErlMbox mbox
)
Public Function Register (
    mbox As ErlMbox
) As Boolean
Public Function Register (
    mbox As ErlMbox
) As Boolean
public:
bool Register(
    ErlMbox^ mbox
)
public:
bool Register(
    ErlMbox^ mbox
)
member Register :
        mbox : ErlMbox -> bool
member Register :
        mbox : ErlMbox -> bool

Parameters

mbox
Type: NFX.Erlang ErlMbox

Return Value

Type: Online Boolean
See Also
MboxRegistry Class
MboxRegistry Members
Register Overload
NFX.Erlang.Internal Namespace


MboxRegistry.Register Method (String, ErlMbox)

MboxRegistry Register Method (String, ErlMbox) NFX Class Library

[This is preliminary documentation and is subject to change.]

Register a named mailbox with the registry. Name must not be empty

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Register(
    string name,
    ErlMbox mbox
)
public bool Register(
    string name,
    ErlMbox mbox
)
Public Function Register (
    name As String,
    mbox As ErlMbox
) As Boolean
Public Function Register (
    name As String,
    mbox As ErlMbox
) As Boolean
public:
bool Register(
    String^ name,
    ErlMbox^ mbox
)
public:
bool Register(
    String^ name,
    ErlMbox^ mbox
)
member Register :
        name : string *
        mbox : ErlMbox -> bool
member Register :
        name : string *
        mbox : ErlMbox -> bool

Parameters

name
Type: Online System String
mbox
Type: NFX.Erlang ErlMbox

Return Value

Type: Online Boolean
See Also
MboxRegistry Class
MboxRegistry Members
Register Overload
NFX.Erlang.Internal Namespace


MboxRegistry.Register Method (ErlAtom, ErlMbox)

MboxRegistry Register Method (ErlAtom, ErlMbox) NFX Class Library

[This is preliminary documentation and is subject to change.]

Register a named mailbox with the registry. Name must not be empty

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Register(
    ErlAtom name,
    ErlMbox mbox
)
public bool Register(
    ErlAtom name,
    ErlMbox mbox
)
Public Function Register (
    name As ErlAtom,
    mbox As ErlMbox
) As Boolean
Public Function Register (
    name As ErlAtom,
    mbox As ErlMbox
) As Boolean
public:
bool Register(
    ErlAtom name,
    ErlMbox^ mbox
)
public:
bool Register(
    ErlAtom name,
    ErlMbox^ mbox
)
member Register :
        name : ErlAtom *
        mbox : ErlMbox -> bool
member Register :
        name : ErlAtom *
        mbox : ErlMbox -> bool

Parameters

name
Type: NFX.Erlang ErlAtom
mbox
Type: NFX.Erlang ErlMbox

Return Value

Type: Online Boolean
See Also
MboxRegistry Class
MboxRegistry Members
Register Overload
NFX.Erlang.Internal Namespace


MboxRegistry.Unregister Method

MboxRegistry Unregister Method NFX Class Library

Unregister a mailbox and move it to free-list

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Unregister(
    ErlMbox mbox
)
public void Unregister(
    ErlMbox mbox
)
Public Sub Unregister (
    mbox As ErlMbox
)
Public Sub Unregister (
    mbox As ErlMbox
)
public:
void Unregister(
    ErlMbox^ mbox
)
public:
void Unregister(
    ErlMbox^ mbox
)
member Unregister :
        mbox : ErlMbox -> unit
member Unregister :
        mbox : ErlMbox -> unit

Parameters

mbox
Type: NFX.Erlang ErlMbox
See Also
MboxRegistry Class
MboxRegistry Members
NFX.Erlang.Internal Namespace


MboxRegistry Properties

MboxRegistry Properties NFX Class Library

The MboxRegistry type exposes the following members.
Properties
 | Name | Description
Public property | Item ErlAtom | Look up a mailbox based on its name
Public property | Item ErlPid | Look up a mailbox based on its pid
Public property | Pids |
Public property | RegNames | Return a list of all registered mailboxes
Back to Top
See Also
MboxRegistry Class
NFX.Erlang.Internal Namespace


MboxRegistry.Item Property

MboxRegistry Item Property NFX Class Library

Overload List
 | Name | Description
Public property | Item ErlAtom | Look up a mailbox based on its name
Public property | Item ErlPid | Look up a mailbox based on its pid
Back to Top
See Also
MboxRegistry Class
MboxRegistry Members
NFX.Erlang.Internal Namespace


MboxRegistry.Item Property (ErlAtom)

MboxRegistry Item Property (ErlAtom) NFX Class Library

Look up a mailbox based on its name

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlMbox this[
    ErlAtom name
] { get; }
public ErlMbox this[
    ErlAtom name
] { get; }
Public ReadOnly Default Property Item (
    name As ErlAtom
) As ErlMbox
    Get
Public ReadOnly Default Property Item (
    name As ErlAtom
) As ErlMbox
    Get
public:
property ErlMbox^ default[ErlAtom name] {
    ErlMbox^ get (ErlAtom name);
}
public:
property ErlMbox^ default[ErlAtom name] {
    ErlMbox^ get (ErlAtom name);
}
member Item : ErlMbox with get
member Item : ErlMbox with get

Parameters

name
Type: NFX.Erlang ErlAtom

Return Value

Type: ErlMbox
Mailbox or null if the name is not registered
See Also
MboxRegistry Class
MboxRegistry Members
Item Overload
NFX.Erlang.Internal Namespace


MboxRegistry.Item Property (ErlPid)

MboxRegistry Item Property (ErlPid) NFX Class Library

Look up a mailbox based on its pid

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ErlMbox this[
    ErlPid pid
] { get; }
public ErlMbox this[
    ErlPid pid
] { get; }
Public ReadOnly Default Property Item (
    pid As ErlPid
) As ErlMbox
    Get
Public ReadOnly Default Property Item (
    pid As ErlPid
) As ErlMbox
    Get
public:
property ErlMbox^ default[ErlPid pid] {
    ErlMbox^ get (ErlPid pid);
}
public:
property ErlMbox^ default[ErlPid pid] {
    ErlMbox^ get (ErlPid pid);
}
member Item : ErlMbox with get
member Item : ErlMbox with get

Parameters

pid
Type: NFX.Erlang ErlPid

Return Value

Type: ErlMbox
Mailbox reference or null if the pid is not present on this node
See Also
MboxRegistry Class
MboxRegistry Members
Item Overload
NFX.Erlang.Internal Namespace


MboxRegistry.Pids Property

MboxRegistry Pids Property NFX Class Library

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<ErlPid> Pids { get; }
public IEnumerable<ErlPid> Pids { get; }
Public ReadOnly Property Pids As IEnumerable(Of ErlPid)
    Get
Public ReadOnly Property Pids As IEnumerable(Of ErlPid)
    Get
public:
property IEnumerable<ErlPid>^ Pids {
    IEnumerable<ErlPid>^ get ();
}
public:
property IEnumerable<ErlPid>^ Pids {
    IEnumerable<ErlPid>^ get ();
}
member Pids : IEnumerable<ErlPid> with get
member Pids : IEnumerable<ErlPid> with get

Property Value

Type: Online IEnumerable ErlPid
See Also
MboxRegistry Class
MboxRegistry Members
NFX.Erlang.Internal Namespace


MboxRegistry.RegNames Property

MboxRegistry RegNames Property NFX Class Library

Return a list of all registered mailboxes

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<ErlAtom> RegNames { get; }
public IEnumerable<ErlAtom> RegNames { get; }
Public ReadOnly Property RegNames As IEnumerable(Of ErlAtom)
    Get
Public ReadOnly Property RegNames As IEnumerable(Of ErlAtom)
    Get
public:
property IEnumerable<ErlAtom>^ RegNames {
    IEnumerable<ErlAtom>^ get ();
}
public:
property IEnumerable<ErlAtom>^ RegNames {
    IEnumerable<ErlAtom>^ get ();
}
member RegNames : IEnumerable<ErlAtom> with get
member RegNames : IEnumerable<ErlAtom> with get

Property Value

Type: Online IEnumerable ErlAtom
See Also
MboxRegistry Class
MboxRegistry Members
NFX.Erlang.Internal Namespace


Parser Class

Parser Class NFX Class Library

Provides compilation of strings to Erlang terms
Inheritance Hierarchy
Online System Object
NFX.Erlang.Internal Parser

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class Parser
internal class Parser
Friend Class Parser
Friend Class Parser
internal ref class Parser
internal ref class Parser
type Parser =  class end
type Parser =  class end
See Also
Parser Members
NFX.Erlang.Internal Namespace


Parser Members

Parser Members NFX Class Library

The Parser type exposes the following members.
Constructors
 | Name | Description
Public method | Parser | Initializes a new instance of the Parser class
Back to Top
Methods
Name Description
Public method Online Equals
Determines whether the specified object is equal to the current object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Online Object.)
Format(ErlList)
Substitute variables in a string contained in args[0]. The substitution values begin with args[1]
Format(String, ErlList)
Substitute variables in a fmt string
Format(String, Object )
Substitute variables in a fmt string. The following variables are supported:
~v
Take next argument as string. If the argument is ErlAtom, it's name is used. If the argument is ErlVar it's name is used with the type if the fmt string doesn't have the variable type specification (e.g. A::integer()), or the name is used verbatim, if the variable type is present in the format string. Finally if the argument is not ErlAtom and ErlVar, it's inserted as string verbatim
~w
Format next argument as string
~i
Skip next argument
~c
Format next argument as the character
Public method Online GetHashCode
Serves as the default hash function.
(Inherited from Online Object.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Parse
Compile a string fmt into an Erlang term
ParseMFA
Parses a string representation of an Erlang function call in the form
View Colorized Copy to Clipboard Print
Module:Function(Arg1, ..., Arg)
Module:Function(Arg1, ..., Arg)
View Colorized Copy to Clipboard Print
Module:Function(Arg1, ..., Arg).
Module:Function(Arg1, ..., Arg).
or
Public method Online ToString
Returns a string that represents the current object.
(Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Parser Class
NFX.Erlang.Internal Namespace


Parser Constructor

Parser Constructor NFX Class Library

Initializes a new instance of the Parser class

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Parser()
public Parser()
Public Sub New
Public Sub New
public:
Parser()
public:
Parser()
new : unit -> Parser
new : unit -> Parser
See Also
Parser Class
Parser Members
NFX.Erlang.Internal Namespace


Parser Methods

Parser Methods NFX Class Library

The Parser type exposes the following members.
Methods
Name Description
Public method Online Equals
Determines whether the specified object is equal to the current object.
(Inherited from Online Object.)
Protected method Online Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Online Object.)
Format(ErlList)
Substitute variables in a string contained in args[0]. The substitution values begin with args[1]
Format(String, ErlList)
Substitute variables in a fmt string
Format(String, Object )
Substitute variables in a fmt string. The following variables are supported:
~v
Take next argument as string. If the argument is ErlAtom, it's name is used. If the argument is ErlVar it's name is used with the type if the fmt string doesn't have the variable type specification (e.g. A::integer()), or the name is used verbatim, if the variable type is present in the format string. Finally if the argument is not ErlAtom and ErlVar, it's inserted as string verbatim
~w
Format next argument as string
~i
Skip next argument
~c
Format next argument as the character
Public method Online GetHashCode
Serves as the default hash function.
(Inherited from Online Object.)
Public method Online GetType
Gets the Online Type of the current instance.
(Inherited from Online Object.)
Protected method Online MemberwiseClone
Creates a shallow copy of the current Online Object.
(Inherited from Online Object.)
Parse
Compile a string fmt into an Erlang term
ParseMFA
Parses a string representation of an Erlang function call in the form
View Colorized Copy to Clipboard Print
Module:Function(Arg1, ..., Arg)
Module:Function(Arg1, ..., Arg)
View Colorized Copy to Clipboard Print
Module:Function(Arg1, ..., Arg).
Module:Function(Arg1, ..., Arg).
or
Public method Online ToString
Returns a string that represents the current object.
(Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Parser Class
NFX.Erlang.Internal Namespace


Parser.Format Method

Parser Format Method NFX Class Library

Overload List
Name Description
Format(ErlList)
Substitute variables in a string contained in args[0]. The substitution values begin with args[1]
Format(String, ErlList)
Substitute variables in a fmt string
Format(String, Object )
Substitute variables in a fmt string. The following variables are supported:
~v
Take next argument as string. If the argument is ErlAtom, it's name is used. If the argument is ErlVar it's name is used with the type if the fmt string doesn't have the variable type specification (e.g. A::integer()), or the name is used verbatim, if the variable type is present in the format string. Finally if the argument is not ErlAtom and ErlVar, it's inserted as string verbatim
~w
Format next argument as string
~i
Skip next argument
~c
Format next argument as the character
Back to Top
See Also
Parser Class
Parser Members
NFX.Erlang.Internal Namespace


Parser.Format Method (ErlList)

Parser Format Method (ErlList) NFX Class Library

Substitute variables in a string contained in args[0]. The substitution values begin with args[1]

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static string Format(
    ErlList args
)
internal static string Format(
    ErlList args
)
Friend Shared Function Format (
    args As ErlList
) As String
Friend Shared Function Format (
    args As ErlList
) As String
internal:
static String^ Format(
    ErlList^ args
)
internal:
static String^ Format(
    ErlList^ args
)
internal static member Format :
        args : ErlList -> string
internal static member Format :
        args : ErlList -> string

Parameters

args
Type: NFX.Erlang ErlList

Return Value

Type: Online String
See Also
Parser Class
Parser Members
Format Overload
NFX.Erlang.Internal Namespace


Parser.Format Method (String, ErlList)

Parser Format Method (String, ErlList) NFX Class Library

Substitute variables in a fmt string

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static string Format(
    string fmt,
    ErlList args
)
internal static string Format(
    string fmt,
    ErlList args
)
Friend Shared Function Format (
    fmt As String,
    args As ErlList
) As String
Friend Shared Function Format (
    fmt As String,
    args As ErlList
) As String
internal:
static String^ Format(
    String^ fmt,
    ErlList^ args
)
internal:
static String^ Format(
    String^ fmt,
    ErlList^ args
)
internal static member Format :
        fmt : string *
        args : ErlList -> string
internal static member Format :
        fmt : string *
        args : ErlList -> string

Parameters

fmt
Type: Online System String
Format string containing substitution variables (e.g. '~w')
args
Type: NFX.Erlang ErlList
List of arguments

Return Value

Type: Online String
See Also
Parser Class
Parser Members
Format Overload
NFX.Erlang.Internal Namespace


Parser.Format Method (String, Object[])

Parser Format Method (String, Object ) NFX Class Library

Substitute variables in a fmt string. The following variables are supported:
~v
Take next argument as string. If the argument is ErlAtom, it's name is used. If the argument is ErlVar it's name is used with the type if the fmt string doesn't have the variable type specification (e.g. A::integer()), or the name is used verbatim, if the variable type is present in the format string. Finally if the argument is not ErlAtom and ErlVar, it's inserted as string verbatim
~w
Format next argument as string
~i
Skip next argument
~c
Format next argument as the character

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static string Format(
    string fmt,
    params Object[] args
)
internal static string Format(
    string fmt,
    params Object[] args
)
Friend Shared Function Format (
    fmt As String,
    ParamArray args As Object()
) As String
Friend Shared Function Format (
    fmt As String,
    ParamArray args As Object()
) As String
internal:
static String^ Format(
    String^ fmt,
    ... array<Object^>^ args
)
internal:
static String^ Format(
    String^ fmt,
    ... array<Object^>^ args
)
internal static member Format :
        fmt : string *
        args : Object[] -> string
internal static member Format :
        fmt : string *
        args : Object[] -> string

Parameters

fmt
Type: Online System String
Format string containing substitution variables (e.g. '~w')
args
Type: Online System Object
List of arguments

Return Value

Type: Online String
See Also
Parser Class
Parser Members
Format Overload
NFX.Erlang.Internal Namespace


Parser.Parse Method

Parser Parse Method NFX Class Library

Compile a string fmt into an Erlang term

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static IErlObject Parse(
    string fmt,
    ref int pos,
    ref int argc,
    params Object[] args
)
internal static IErlObject Parse(
    string fmt,
    ref int pos,
    ref int argc,
    params Object[] args
)
Friend Shared Function Parse (
    fmt As String,
    ByRef pos As Integer,
    ByRef argc As Integer,
    ParamArray args As Object()
) As IErlObject
Friend Shared Function Parse (
    fmt As String,
    ByRef pos As Integer,
    ByRef argc As Integer,
    ParamArray args As Object()
) As IErlObject
internal:
static IErlObject^ Parse(
    String^ fmt,
    int% pos,
    int% argc,
    ... array<Object^>^ args
)
internal:
static IErlObject^ Parse(
    String^ fmt,
    int% pos,
    int% argc,
    ... array<Object^>^ args
)
internal static member Parse :
        fmt : string *
        pos : int byref *
        argc : int byref *
        args : Object[] -> IErlObject
internal static member Parse :
        fmt : string *
        pos : int byref *
        argc : int byref *
        args : Object[] -> IErlObject

Parameters

fmt
Type: Online System String
pos
Type: Online System Int32
argc
Type: Online System Int32
args
Type: Online System Object

Return Value

Type: IErlObject
See Also
Parser Class
Parser Members
NFX.Erlang.Internal Namespace


Parser.ParseMFA Method

Parser ParseMFA Method NFX Class Library

Parses a string representation of an Erlang function call in the form
View Colorized Copy to Clipboard Print
Module:Function(Arg1, ..., Arg)
Module:Function(Arg1, ..., Arg)
or
View Colorized Copy to Clipboard Print
Module:Function(Arg1, ..., Arg).
Module:Function(Arg1, ..., Arg).

Namespace: NFX.Erlang.Internal
Assembly: NFX.Erlang (in NFX.Erlang.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static Tuple<ErlAtom, ErlAtom, ErlList> ParseMFA(
    string fmt,
    ref int pos,
    ref int argc,
    params Object[] args
)
internal static Tuple<ErlAtom, ErlAtom, ErlList> ParseMFA(
    string fmt,
    ref int pos,
    ref int argc,
    params Object[] args
)
Friend Shared Function ParseMFA (
    fmt As String,
    ByRef pos As Integer,
    ByRef argc As Integer,
    ParamArray args As Object()
) As Tuple(Of ErlAtom, ErlAtom, ErlList)
Friend Shared Function ParseMFA (
    fmt As String,
    ByRef pos As Integer,
    ByRef argc As Integer,
    ParamArray args As Object()
) As Tuple(Of ErlAtom, ErlAtom, ErlList)
internal:
static Tuple<ErlAtom, ErlAtom, ErlList^>^ ParseMFA(
    String^ fmt,
    int% pos,
    int% argc,
    ... array<Object^>^ args
)
internal:
static Tuple<ErlAtom, ErlAtom, ErlList^>^ ParseMFA(
    String^ fmt,
    int% pos,
    int% argc,
    ... array<Object^>^ args
)
internal static member ParseMFA :
        fmt : string *
        pos : int byref *
        argc : int byref *
        args : Object[] -> Tuple<ErlAtom, ErlAtom, ErlList>
internal static member ParseMFA :
        fmt : string *
        pos : int byref *
        argc : int byref *
        args : Object[] -> Tuple<ErlAtom, ErlAtom, ErlList>

Parameters

fmt
Type: Online System String
string to parse
pos
Type: Online System Int32
starting index
argc
Type: Online System Int32
argument number
args
Type: Online System Object
optional arguments

Return Value

Type: Online Tuple ErlAtom, ErlAtom, ErlList
A 3-element tuple containing Module, Function, Arguments
See Also
Parser Class
Parser Members
NFX.Erlang.Internal Namespace


NFX.Financial Namespace

NFX.Financial Namespace NFX Class Library

Provides various financial functions
Classes
 | Class | Description
Public class | FinancialException | Base exception thrown by the financial-related framework
Public class | TimeValue | Implements time value financial functions such as: PV, NPV, IRR
Structures
 | Structure | Description
Public structure | Amount | Represents monetary amount with currency


Amount Structure

Amount Structure NFX Class Library

Represents monetary amount with currency

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public struct Amount : IEquatable<Amount>,
    IComparable<Amount>, IJSONWritable
[SerializableAttribute]
public struct Amount : IEquatable<Amount>,
    IComparable<Amount>, IJSONWritable
<SerializableAttribute>
Public Structure Amount
    Implements IEquatable(Of Amount), IComparable(Of Amount),
    IJSONWritable
<SerializableAttribute>
Public Structure Amount
    Implements IEquatable(Of Amount), IComparable(Of Amount),
    IJSONWritable
[SerializableAttribute]
public value class Amount : IEquatable<Amount>,
    IComparable<Amount>, IJSONWritable
[SerializableAttribute]
public value class Amount : IEquatable<Amount>,
    IComparable<Amount>, IJSONWritable
[<SealedAttribute>]
[<SerializableAttribute>]
type Amount =
    struct
        interface IEquatable<Amount>
        interface IComparable<Amount>
        interface IJSONWritable
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type Amount =
    struct
        interface IEquatable<Amount>
        interface IComparable<Amount>
        interface IJSONWritable
    end
See Also
Amount Members
NFX.Financial Namespace


Amount Members

Amount Members NFX Class Library

The Amount type exposes the following members.
Constructors
 | Name | Description
Public method | Amount | Initializes a new instance of the Amount class
Back to Top
Methods
 | Name | Description
Public method | CompareTo |
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(Amount) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsSameCurrencyAs | Perfoms case-insensitive currency equality comparison
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Parse |
Public method | ToString | (Overrides Online ValueType ToString .)
 | TryParse |
Public method | WriteAsJSON |
Back to Top
Operators
Name | Description
Addition |
Division(Amount, Decimal) |
Division(Amount, Double) |
Division(Amount, Int32) |
Equality |
GreaterThan |
GreaterThanOrEqual |
Inequality |
LessThan |
LessThanOrEqual |
Multiply(Decimal, Amount) |
Multiply(Double, Amount) |
Multiply(Int32, Amount) |
Multiply(Amount, Decimal) |
Multiply(Amount, Double) |
Multiply(Amount, Int32) |
Subtraction |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | CurrencyISO |
Public property | IsEmpty |
Public property | Value |
Back to Top
See Also
Amount Structure
NFX.Financial Namespace


Amount Constructor

Amount Constructor NFX Class Library

Initializes a new instance of the Amount class

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Amount(
    string currencyISO,
    decimal value
)
public Amount(
    string currencyISO,
    decimal value
)
Public Sub New (
    currencyISO As String,
    value As Decimal
)
Public Sub New (
    currencyISO As String,
    value As Decimal
)
public:
Amount(
    String^ currencyISO,
    Decimal value
)
public:
Amount(
    String^ currencyISO,
    Decimal value
)
new :
        currencyISO : string *
        value : decimal -> Amount
new :
        currencyISO : string *
        value : decimal -> Amount

Parameters

currencyISO
Type: Online System String
value
Type: Online System Decimal
See Also
Amount Structure
Amount Members
NFX.Financial Namespace


Amount Methods

Amount Methods NFX Class Library

The Amount type exposes the following members.
Methods
 | Name | Description
Public method | CompareTo |
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(Amount) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsSameCurrencyAs | Perfoms case-insensitive currency equality comparison
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Parse |
Public method | ToString | (Overrides Online ValueType ToString .)
 | TryParse |
Public method | WriteAsJSON |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Amount Structure
NFX.Financial Namespace


Amount.CompareTo Method

Amount CompareTo Method NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    Amount other
)
public int CompareTo(
    Amount other
)
Public Function CompareTo (
    other As Amount
) As Integer
Public Function CompareTo (
    other As Amount
) As Integer
public:
virtual int CompareTo(
    Amount other
) sealed
public:
virtual int CompareTo(
    Amount other
) sealed
abstract CompareTo :
        other : Amount -> int
override CompareTo :
        other : Amount -> int
abstract CompareTo :
        other : Amount -> int
override CompareTo :
        other : Amount -> int

Parameters

other
Type: NFX.Financial Amount

Return Value

Type: Online Int32

Implements

Online IComparable T CompareTo(T)
See Also
Amount Structure
Amount Members
NFX.Financial Namespace


Amount.Equals Method

Amount Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(Amount) |
Back to Top
See Also
Amount Structure
Amount Members
NFX.Financial Namespace


Amount.Equals Method (Object)

Amount Equals Method (Object) NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
Amount Structure
Amount Members
Equals Overload
NFX.Financial Namespace


Amount.Equals Method (Amount)

Amount Equals Method (Amount) NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    Amount other
)
public bool Equals(
    Amount other
)
Public Function Equals (
    other As Amount
) As Boolean
Public Function Equals (
    other As Amount
) As Boolean
public:
virtual bool Equals(
    Amount other
) sealed
public:
virtual bool Equals(
    Amount other
) sealed
abstract Equals :
        other : Amount -> bool
override Equals :
        other : Amount -> bool
abstract Equals :
        other : Amount -> bool
override Equals :
        other : Amount -> bool

Parameters

other
Type: NFX.Financial Amount

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
Amount Structure
Amount Members
Equals Overload
NFX.Financial Namespace


Amount.GetHashCode Method

Amount GetHashCode Method NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
Amount Structure
Amount Members
NFX.Financial Namespace


Amount.IsSameCurrencyAs Method

Amount IsSameCurrencyAs Method NFX Class Library

Perfoms case-insensitive currency equality comparison

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsSameCurrencyAs(
    Amount other
)
public bool IsSameCurrencyAs(
    Amount other
)
Public Function IsSameCurrencyAs (
    other As Amount
) As Boolean
Public Function IsSameCurrencyAs (
    other As Amount
) As Boolean
public:
bool IsSameCurrencyAs(
    Amount other
)
public:
bool IsSameCurrencyAs(
    Amount other
)
member IsSameCurrencyAs :
        other : Amount -> bool
member IsSameCurrencyAs :
        other : Amount -> bool

Parameters

other
Type: NFX.Financial Amount

Return Value

Type: Online Boolean
See Also
Amount Structure
Amount Members
NFX.Financial Namespace


Amount.Parse Method

Amount Parse Method NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Amount Parse(
    string val
)
public static Amount Parse(
    string val
)
Public Shared Function Parse (
    val As String
) As Amount
Public Shared Function Parse (
    val As String
) As Amount
public:
static Amount Parse(
    String^ val
)
public:
static Amount Parse(
    String^ val
)
static member Parse :
        val : string -> Amount
static member Parse :
        val : string -> Amount

Parameters

val
Type: Online System String

Return Value

Type: Amount
See Also
Amount Structure
Amount Members
NFX.Financial Namespace


Amount.ToString Method

Amount ToString Method NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
Amount Structure
Amount Members
NFX.Financial Namespace


Amount.TryParse Method

Amount TryParse Method NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool TryParse(
    string val,
    out Amount result
)
public static bool TryParse(
    string val,
    out Amount result
)
Public Shared Function TryParse (
    val As String,
    <OutAttribute> ByRef result As Amount
) As Boolean
Public Shared Function TryParse (
    val As String,
    <OutAttribute> ByRef result As Amount
) As Boolean
public:
static bool TryParse(
    String^ val,
    [OutAttribute] Amount% result
)
public:
static bool TryParse(
    String^ val,
    [OutAttribute] Amount% result
)
static member TryParse :
        val : string *
        result : Amount byref -> bool
static member TryParse :
        val : string *
        result : Amount byref -> bool

Parameters

val
Type: Online System String
result
Type: NFX.Financial Amount

Return Value

Type: Online Boolean
See Also
Amount Structure
Amount Members
NFX.Financial Namespace


Amount.WriteAsJSON Method

Amount WriteAsJSON Method NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
nestingLevel
Type: Online System Int32
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Implements

IJSONWritable WriteAsJSON(TextWriter, Int32, JSONWritingOptions)
See Also
Amount Structure
Amount Members
NFX.Financial Namespace


Amount Operators

Amount Operators NFX Class Library

The Amount type exposes the following members.
Operators
Name | Description
Addition |
Division(Amount, Decimal) |
Division(Amount, Double) |
Division(Amount, Int32) |
Equality |
GreaterThan |
GreaterThanOrEqual |
Inequality |
LessThan |
LessThanOrEqual |
Multiply(Decimal, Amount) |
Multiply(Double, Amount) |
Multiply(Int32, Amount) |
Multiply(Amount, Decimal) |
Multiply(Amount, Double) |
Multiply(Amount, Int32) |
Subtraction |
Back to Top
See Also
Amount Structure
NFX.Financial Namespace


Amount.Addition Operator

Amount Addition Operator NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Amount operator +(
    Amount left,
    Amount right
)
public static Amount operator +(
    Amount left,
    Amount right
)
Public Shared Operator + (
    left As Amount,
    right As Amount
) As Amount
Public Shared Operator + (
    left As Amount,
    right As Amount
) As Amount
public:
static Amount operator +(
    Amount left,
    Amount right
)
public:
static Amount operator +(
    Amount left,
    Amount right
)
static let inline (+)
        left : Amount *
        right : Amount  : Amount
static let inline (+)
        left : Amount *
        right : Amount  : Amount

Parameters

left
Type: NFX.Financial Amount
right
Type: NFX.Financial Amount

Return Value

Type: Amount
See Also
Amount Structure
Amount Members
NFX.Financial Namespace


Amount.Division Operator

Amount Division Operator NFX Class Library

Overload List
Name | Description
Division(Amount, Decimal) |
Division(Amount, Double) |
Division(Amount, Int32) |
Back to Top
See Also
Amount Structure
Amount Members
NFX.Financial Namespace


Amount.Division Operator (Amount, Decimal)

Amount Division Operator (Amount, Decimal) NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Amount operator /(
    Amount left,
    decimal right
)
public static Amount operator /(
    Amount left,
    decimal right
)
Public Shared Operator / (
    left As Amount,
    right As Decimal
) As Amount
Public Shared Operator / (
    left As Amount,
    right As Decimal
) As Amount
public:
static Amount operator /(
    Amount left,
    Decimal right
)
public:
static Amount operator /(
    Amount left,
    Decimal right
)
static let inline (/)
        left : Amount *
        right : decimal  : Amount
static let inline (/)
        left : Amount *
        right : decimal  : Amount

Parameters

left
Type: NFX.Financial Amount
right
Type: Online System Decimal

Return Value

Type: Amount
See Also
Amount Structure
Amount Members
Division Overload
NFX.Financial Namespace


Amount.Division Operator (Amount, Double)

Amount Division Operator (Amount, Double) NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Amount operator /(
    Amount left,
    double right
)
public static Amount operator /(
    Amount left,
    double right
)
Public Shared Operator / (
    left As Amount,
    right As Double
) As Amount
Public Shared Operator / (
    left As Amount,
    right As Double
) As Amount
public:
static Amount operator /(
    Amount left,
    double right
)
public:
static Amount operator /(
    Amount left,
    double right
)
static let inline (/)
        left : Amount *
        right : float  : Amount
static let inline (/)
        left : Amount *
        right : float  : Amount

Parameters

left
Type: NFX.Financial Amount
right
Type: Online System Double

Return Value

Type: Amount
See Also
Amount Structure
Amount Members
Division Overload
NFX.Financial Namespace


Amount.Division Operator (Amount, Int32)

Amount Division Operator (Amount, Int32) NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Amount operator /(
    Amount left,
    int right
)
public static Amount operator /(
    Amount left,
    int right
)
Public Shared Operator / (
    left As Amount,
    right As Integer
) As Amount
Public Shared Operator / (
    left As Amount,
    right As Integer
) As Amount
public:
static Amount operator /(
    Amount left,
    int right
)
public:
static Amount operator /(
    Amount left,
    int right
)
static let inline (/)
        left : Amount *
        right : int  : Amount
static let inline (/)
        left : Amount *
        right : int  : Amount

Parameters

left
Type: NFX.Financial Amount
right
Type: Online System Int32

Return Value

Type: Amount
See Also
Amount Structure
Amount Members
Division Overload
NFX.Financial Namespace


Amount.Equality Operator

Amount Equality Operator NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    Amount left,
    Amount right
)
public static bool operator ==(
    Amount left,
    Amount right
)
Public Shared Operator = (
    left As Amount,
    right As Amount
) As Boolean
Public Shared Operator = (
    left As Amount,
    right As Amount
) As Boolean
public:
static bool operator ==(
    Amount left,
    Amount right
)
public:
static bool operator ==(
    Amount left,
    Amount right
)
static let inline (=)
        left : Amount *
        right : Amount  : bool
static let inline (=)
        left : Amount *
        right : Amount  : bool

Parameters

left
Type: NFX.Financial Amount
right
Type: NFX.Financial Amount

Return Value

Type: Online Boolean
See Also
Amount Structure
Amount Members
NFX.Financial Namespace


Amount.GreaterThan Operator

Amount GreaterThan Operator NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator >(
    Amount left,
    Amount right
)
public static bool operator >(
    Amount left,
    Amount right
)
Public Shared Operator > (
    left As Amount,
    right As Amount
) As Boolean
Public Shared Operator > (
    left As Amount,
    right As Amount
) As Boolean
public:
static bool operator >(
    Amount left,
    Amount right
)
public:
static bool operator >(
    Amount left,
    Amount right
)
static let inline (>)
        left : Amount *
        right : Amount  : bool
static let inline (>)
        left : Amount *
        right : Amount  : bool

Parameters

left
Type: NFX.Financial Amount
right
Type: NFX.Financial Amount

Return Value

Type: Online Boolean
See Also
Amount Structure
Amount Members
NFX.Financial Namespace


Amount.GreaterThanOrEqual Operator

Amount GreaterThanOrEqual Operator NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator >=(
    Amount left,
    Amount right
)
public static bool operator >=(
    Amount left,
    Amount right
)
Public Shared Operator >= (
    left As Amount,
    right As Amount
) As Boolean
Public Shared Operator >= (
    left As Amount,
    right As Amount
) As Boolean
public:
static bool operator >=(
    Amount left,
    Amount right
)
public:
static bool operator >=(
    Amount left,
    Amount right
)
static let inline (>=)
        left : Amount *
        right : Amount  : bool
static let inline (>=)
        left : Amount *
        right : Amount  : bool

Parameters

left
Type: NFX.Financial Amount
right
Type: NFX.Financial Amount

Return Value

Type: Online Boolean
See Also
Amount Structure
Amount Members
NFX.Financial Namespace


Amount.Inequality Operator

Amount Inequality Operator NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    Amount left,
    Amount right
)
public static bool operator !=(
    Amount left,
    Amount right
)
Public Shared Operator <> (
    left As Amount,
    right As Amount
) As Boolean
Public Shared Operator <> (
    left As Amount,
    right As Amount
) As Boolean
public:
static bool operator !=(
    Amount left,
    Amount right
)
public:
static bool operator !=(
    Amount left,
    Amount right
)
static let inline (<>)
        left : Amount *
        right : Amount  : bool
static let inline (<>)
        left : Amount *
        right : Amount  : bool

Parameters

left
Type: NFX.Financial Amount
right
Type: NFX.Financial Amount

Return Value

Type: Online Boolean
See Also
Amount Structure
Amount Members
NFX.Financial Namespace


Amount.LessThan Operator

Amount LessThan Operator NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator <(
    Amount left,
    Amount right
)
public static bool operator <(
    Amount left,
    Amount right
)
Public Shared Operator < (
    left As Amount,
    right As Amount
) As Boolean
Public Shared Operator < (
    left As Amount,
    right As Amount
) As Boolean
public:
static bool operator <(
    Amount left,
    Amount right
)
public:
static bool operator <(
    Amount left,
    Amount right
)
static let inline (<)
        left : Amount *
        right : Amount  : bool
static let inline (<)
        left : Amount *
        right : Amount  : bool

Parameters

left
Type: NFX.Financial Amount
right
Type: NFX.Financial Amount

Return Value

Type: Online Boolean
See Also
Amount Structure
Amount Members
NFX.Financial Namespace


Amount.LessThanOrEqual Operator

Amount LessThanOrEqual Operator NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator <=(
    Amount left,
    Amount right
)
public static bool operator <=(
    Amount left,
    Amount right
)
Public Shared Operator <= (
    left As Amount,
    right As Amount
) As Boolean
Public Shared Operator <= (
    left As Amount,
    right As Amount
) As Boolean
public:
static bool operator <=(
    Amount left,
    Amount right
)
public:
static bool operator <=(
    Amount left,
    Amount right
)
static let inline (<=)
        left : Amount *
        right : Amount  : bool
static let inline (<=)
        left : Amount *
        right : Amount  : bool

Parameters

left
Type: NFX.Financial Amount
right
Type: NFX.Financial Amount

Return Value

Type: Online Boolean
See Also
Amount Structure
Amount Members
NFX.Financial Namespace


Amount.Multiply Operator

Amount Multiply Operator NFX Class Library

Overload List
Name | Description
Multiply(Decimal, Amount) |
Multiply(Double, Amount) |
Multiply(Int32, Amount) |
Multiply(Amount, Decimal) |
Multiply(Amount, Double) |
Multiply(Amount, Int32) |
Back to Top
See Also
Amount Structure
Amount Members
NFX.Financial Namespace


Amount.Multiply Operator (Decimal, Amount)

Amount Multiply Operator (Decimal, Amount) NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Amount operator *(
    decimal left,
    Amount right
)
public static Amount operator *(
    decimal left,
    Amount right
)
Public Shared Operator * (
    left As Decimal,
    right As Amount
) As Amount
Public Shared Operator * (
    left As Decimal,
    right As Amount
) As Amount
public:
static Amount operator *(
    Decimal left,
    Amount right
)
public:
static Amount operator *(
    Decimal left,
    Amount right
)
static let inline (*)
        left : decimal *
        right : Amount  : Amount
static let inline (*)
        left : decimal *
        right : Amount  : Amount

Parameters

left
Type: Online System Decimal
right
Type: NFX.Financial Amount

Return Value

Type: Amount
See Also
Amount Structure
Amount Members
Multiply Overload
NFX.Financial Namespace


Amount.Multiply Operator (Double, Amount)

Amount Multiply Operator (Double, Amount) NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Amount operator *(
    double left,
    Amount right
)
public static Amount operator *(
    double left,
    Amount right
)
Public Shared Operator * (
    left As Double,
    right As Amount
) As Amount
Public Shared Operator * (
    left As Double,
    right As Amount
) As Amount
public:
static Amount operator *(
    double left,
    Amount right
)
public:
static Amount operator *(
    double left,
    Amount right
)
static let inline (*)
        left : float *
        right : Amount  : Amount
static let inline (*)
        left : float *
        right : Amount  : Amount

Parameters

left
Type: Online System Double
right
Type: NFX.Financial Amount

Return Value

Type: Amount
See Also
Amount Structure
Amount Members
Multiply Overload
NFX.Financial Namespace


Amount.Multiply Operator (Int32, Amount)

Amount Multiply Operator (Int32, Amount) NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Amount operator *(
    int left,
    Amount right
)
public static Amount operator *(
    int left,
    Amount right
)
Public Shared Operator * (
    left As Integer,
    right As Amount
) As Amount
Public Shared Operator * (
    left As Integer,
    right As Amount
) As Amount
public:
static Amount operator *(
    int left,
    Amount right
)
public:
static Amount operator *(
    int left,
    Amount right
)
static let inline (*)
        left : int *
        right : Amount  : Amount
static let inline (*)
        left : int *
        right : Amount  : Amount

Parameters

left
Type: Online System Int32
right
Type: NFX.Financial Amount

Return Value

Type: Amount
See Also
Amount Structure
Amount Members
Multiply Overload
NFX.Financial Namespace


Amount.Multiply Operator (Amount, Decimal)

Amount Multiply Operator (Amount, Decimal) NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Amount operator *(
    Amount left,
    decimal right
)
public static Amount operator *(
    Amount left,
    decimal right
)
Public Shared Operator * (
    left As Amount,
    right As Decimal
) As Amount
Public Shared Operator * (
    left As Amount,
    right As Decimal
) As Amount
public:
static Amount operator *(
    Amount left,
    Decimal right
)
public:
static Amount operator *(
    Amount left,
    Decimal right
)
static let inline (*)
        left : Amount *
        right : decimal  : Amount
static let inline (*)
        left : Amount *
        right : decimal  : Amount

Parameters

left
Type: NFX.Financial Amount
right
Type: Online System Decimal

Return Value

Type: Amount
See Also
Amount Structure
Amount Members
Multiply Overload
NFX.Financial Namespace


Amount.Multiply Operator (Amount, Double)

Amount Multiply Operator (Amount, Double) NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Amount operator *(
    Amount left,
    double right
)
public static Amount operator *(
    Amount left,
    double right
)
Public Shared Operator * (
    left As Amount,
    right As Double
) As Amount
Public Shared Operator * (
    left As Amount,
    right As Double
) As Amount
public:
static Amount operator *(
    Amount left,
    double right
)
public:
static Amount operator *(
    Amount left,
    double right
)
static let inline (*)
        left : Amount *
        right : float  : Amount
static let inline (*)
        left : Amount *
        right : float  : Amount

Parameters

left
Type: NFX.Financial Amount
right
Type: Online System Double

Return Value

Type: Amount
See Also
Amount Structure
Amount Members
Multiply Overload
NFX.Financial Namespace


Amount.Multiply Operator (Amount, Int32)

Amount Multiply Operator (Amount, Int32) NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Amount operator *(
    Amount left,
    int right
)
public static Amount operator *(
    Amount left,
    int right
)
Public Shared Operator * (
    left As Amount,
    right As Integer
) As Amount
Public Shared Operator * (
    left As Amount,
    right As Integer
) As Amount
public:
static Amount operator *(
    Amount left,
    int right
)
public:
static Amount operator *(
    Amount left,
    int right
)
static let inline (*)
        left : Amount *
        right : int  : Amount
static let inline (*)
        left : Amount *
        right : int  : Amount

Parameters

left
Type: NFX.Financial Amount
right
Type: Online System Int32

Return Value

Type: Amount
See Also
Amount Structure
Amount Members
Multiply Overload
NFX.Financial Namespace


Amount.Subtraction Operator

Amount Subtraction Operator NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Amount operator -(
    Amount left,
    Amount right
)
public static Amount operator -(
    Amount left,
    Amount right
)
Public Shared Operator - (
    left As Amount,
    right As Amount
) As Amount
Public Shared Operator - (
    left As Amount,
    right As Amount
) As Amount
public:
static Amount operator -(
    Amount left,
    Amount right
)
public:
static Amount operator -(
    Amount left,
    Amount right
)
static let inline (-)
        left : Amount *
        right : Amount  : Amount
static let inline (-)
        left : Amount *
        right : Amount  : Amount

Parameters

left
Type: NFX.Financial Amount
right
Type: NFX.Financial Amount

Return Value

Type: Amount
See Also
Amount Structure
Amount Members
NFX.Financial Namespace


Amount Properties

Amount Properties NFX Class Library

The Amount type exposes the following members.
Properties
 | Name | Description
Public property | CurrencyISO |
Public property | IsEmpty |
Public property | Value |
Back to Top
See Also
Amount Structure
NFX.Financial Namespace


Amount.CurrencyISO Property

Amount CurrencyISO Property NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CurrencyISO { get; }
public string CurrencyISO { get; }
Public ReadOnly Property CurrencyISO As String
    Get
Public ReadOnly Property CurrencyISO As String
    Get
public:
property String^ CurrencyISO {
    String^ get ();
}
public:
property String^ CurrencyISO {
    String^ get ();
}
member CurrencyISO : string with get
member CurrencyISO : string with get

Property Value

Type: Online String
See Also
Amount Structure
Amount Members
NFX.Financial Namespace


Amount.IsEmpty Property

Amount IsEmpty Property NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty { get; }
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get
Public ReadOnly Property IsEmpty As Boolean
    Get
public:
property bool IsEmpty {
    bool get ();
}
public:
property bool IsEmpty {
    bool get ();
}
member IsEmpty : bool with get
member IsEmpty : bool with get

Property Value

Type: Online Boolean
See Also
Amount Structure
Amount Members
NFX.Financial Namespace


Amount.Value Property

Amount Value Property NFX Class Library

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal Value { get; }
public decimal Value { get; }
Public ReadOnly Property Value As Decimal
    Get
Public ReadOnly Property Value As Decimal
    Get
public:
property Decimal Value {
    Decimal get ();
}
public:
property Decimal Value {
    Decimal get ();
}
member Value : decimal with get
member Value : decimal with get

Property Value

Type: Online Decimal
See Also
Amount Structure
Amount Members
NFX.Financial Namespace


FinancialException Class

FinancialException Class NFX Class Library

Base exception thrown by the financial-related framework
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Financial FinancialException

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class FinancialException : NFXException
[SerializableAttribute]
public class FinancialException : NFXException
<SerializableAttribute>
Public Class FinancialException
    Inherits NFXException
<SerializableAttribute>
Public Class FinancialException
    Inherits NFXException
[SerializableAttribute]
public ref class FinancialException : public NFXException
[SerializableAttribute]
public ref class FinancialException : public NFXException
[<SerializableAttribute>]
type FinancialException =
    class
        inherit NFXException
    end
[<SerializableAttribute>]
type FinancialException =
    class
        inherit NFXException
    end
See Also
FinancialException Members
NFX.Financial Namespace


FinancialException Members

FinancialException Members NFX Class Library

The FinancialException type exposes the following members.
Constructors
 | Name | Description
Public method | FinancialException | Initializes a new instance of the FinancialException class
Public method | FinancialException(String) | Initializes a new instance of the FinancialException class
Protected method | FinancialException(SerializationInfo, StreamingContext) | Initializes a new instance of the FinancialException class
Public method | FinancialException(String, Exception) | Initializes a new instance of the FinancialException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
FinancialException Class
NFX.Financial Namespace


FinancialException Constructor

FinancialException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | FinancialException | Initializes a new instance of the FinancialException class
Public method | FinancialException(String) | Initializes a new instance of the FinancialException class
Protected method | FinancialException(SerializationInfo, StreamingContext) | Initializes a new instance of the FinancialException class
Public method | FinancialException(String, Exception) | Initializes a new instance of the FinancialException class
Back to Top
See Also
FinancialException Class
FinancialException Members
NFX.Financial Namespace


FinancialException Constructor

FinancialException Constructor NFX Class Library

Initializes a new instance of the FinancialException class

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FinancialException()
public FinancialException()
Public Sub New
Public Sub New
public:
FinancialException()
public:
FinancialException()
new : unit -> FinancialException
new : unit -> FinancialException
See Also
FinancialException Class
FinancialException Members
FinancialException Overload
NFX.Financial Namespace


FinancialException Constructor (String)

FinancialException Constructor (String) NFX Class Library

Initializes a new instance of the FinancialException class

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FinancialException(
    string message
)
public FinancialException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
FinancialException(
    String^ message
)
public:
FinancialException(
    String^ message
)
new :
        message : string -> FinancialException
new :
        message : string -> FinancialException

Parameters

message
Type: Online System String
See Also
FinancialException Class
FinancialException Members
FinancialException Overload
NFX.Financial Namespace


FinancialException Constructor (SerializationInfo, StreamingContext)

FinancialException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FinancialException class

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FinancialException(
    SerializationInfo info,
    StreamingContext context
)
protected FinancialException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
FinancialException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
FinancialException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FinancialException
new :
        info : SerializationInfo *
        context : StreamingContext -> FinancialException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
FinancialException Class
FinancialException Members
FinancialException Overload
NFX.Financial Namespace


FinancialException Constructor (String, Exception)

FinancialException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FinancialException class

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FinancialException(
    string message,
    Exception inner
)
public FinancialException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
FinancialException(
    String^ message,
    Exception^ inner
)
public:
FinancialException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> FinancialException
new :
        message : string *
        inner : Exception -> FinancialException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
FinancialException Class
FinancialException Members
FinancialException Overload
NFX.Financial Namespace


FinancialException Methods

FinancialException Methods NFX Class Library

The FinancialException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
FinancialException Class
NFX.Financial Namespace


FinancialException Properties

FinancialException Properties NFX Class Library

The FinancialException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
FinancialException Class
NFX.Financial Namespace


FinancialException Events

FinancialException Events NFX Class Library

The FinancialException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
FinancialException Class
NFX.Financial Namespace


TimeValue Class

TimeValue Class NFX Class Library

Implements time value financial functions such as: PV, NPV, IRR
Inheritance Hierarchy
Online System Object
NFX.Financial TimeValue

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class TimeValue
public static class TimeValue
Public NotInheritable Class TimeValue
Public NotInheritable Class TimeValue
public ref class TimeValue abstract sealed
public ref class TimeValue abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type TimeValue =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type TimeValue =  class end
See Also
TimeValue Members
NFX.Financial Namespace


TimeValue Members

TimeValue Members NFX Class Library

The TimeValue type exposes the following members.
Methods
Name | Description
FV | Returns future value of presently-valued amount in X number of periods at a certain interest rate
IRR | Calculates the internal rate of return over series of cash flows
NPV | Returns a net present value calculated over series of cashflows
PV | Returns present value of amount returned in X number of periods at a certain interest rate
Back to Top
See Also
TimeValue Class
NFX.Financial Namespace


TimeValue Methods

TimeValue Methods NFX Class Library

The TimeValue type exposes the following members.
Methods
Name | Description
FV | Returns future value of presently-valued amount in X number of periods at a certain interest rate
IRR | Calculates the internal rate of return over series of cash flows
NPV | Returns a net present value calculated over series of cashflows
PV | Returns present value of amount returned in X number of periods at a certain interest rate
Back to Top
See Also
TimeValue Class
NFX.Financial Namespace


TimeValue.FV Method

TimeValue FV Method NFX Class Library

Returns future value of presently-valued amount in X number of periods at a certain interest rate

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static double FV(
    double pv,
    double intRate,
    int periods
)
public static double FV(
    double pv,
    double intRate,
    int periods
)
Public Shared Function FV (
    pv As Double,
    intRate As Double,
    periods As Integer
) As Double
Public Shared Function FV (
    pv As Double,
    intRate As Double,
    periods As Integer
) As Double
public:
static double FV(
    double pv,
    double intRate,
    int periods
)
public:
static double FV(
    double pv,
    double intRate,
    int periods
)
static member FV :
        pv : float *
        intRate : float *
        periods : int -> float
static member FV :
        pv : float *
        intRate : float *
        periods : int -> float

Parameters

pv
Type: Online System Double
Present value
intRate
Type: Online System Double
Interest rate
periods
Type: Online System Int32
Period length

Return Value

Type: Online Double
Future value
Examples
$100 loaned for 1 period at 5% interest per period have future value of $105; same amount loaned for 10 periods at the same rate would have future value of $162.89
See Also
TimeValue Class
TimeValue Members
NFX.Financial Namespace


TimeValue.IRR Method

TimeValue IRR Method NFX Class Library

Calculates the internal rate of return over series of cash flows

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static double IRR(
    IEnumerable<double> cashFlows,
    double estimatedResult
)
public static double IRR(
    IEnumerable<double> cashFlows,
    double estimatedResult
)
Public Shared Function IRR (
    cashFlows As IEnumerable(Of Double),
    estimatedResult As Double
) As Double
Public Shared Function IRR (
    cashFlows As IEnumerable(Of Double),
    estimatedResult As Double
) As Double
public:
static double IRR(
    IEnumerable<double>^ cashFlows,
    double estimatedResult
)
public:
static double IRR(
    IEnumerable<double>^ cashFlows,
    double estimatedResult
)
static member IRR :
        cashFlows : IEnumerable<float> *
        estimatedResult : float -> float
static member IRR :
        cashFlows : IEnumerable<float> *
        estimatedResult : float -> float

Parameters

cashFlows
Type: Online System.Collections.Generic IEnumerable Online Double
estimatedResult
Type: Online System Double

Return Value

Type: Online Double
See Also
TimeValue Class
TimeValue Members
NFX.Financial Namespace


TimeValue.NPV Method

TimeValue NPV Method NFX Class Library

Returns a net present value calculated over series of cashflows

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static double NPV(
    IEnumerable<double> cashFlows,
    double discountRate
)
public static double NPV(
    IEnumerable<double> cashFlows,
    double discountRate
)
Public Shared Function NPV (
    cashFlows As IEnumerable(Of Double),
    discountRate As Double
) As Double
Public Shared Function NPV (
    cashFlows As IEnumerable(Of Double),
    discountRate As Double
) As Double
public:
static double NPV(
    IEnumerable<double>^ cashFlows,
    double discountRate
)
public:
static double NPV(
    IEnumerable<double>^ cashFlows,
    double discountRate
)
static member NPV :
        cashFlows : IEnumerable<float> *
        discountRate : float -> float
static member NPV :
        cashFlows : IEnumerable<float> *
        discountRate : float -> float

Parameters

cashFlows
Type: Online System.Collections.Generic IEnumerable Online Double
A series of net cashflows per period(supplied as a summ of inflows and outflows), usually the first cashflow is an outflow of initial project investment
discountRate
Type: Online System Double
Interest rate used for net cashflow discount

Return Value

Type: Online Double
Net present value
See Also
TimeValue Class
TimeValue Members
NFX.Financial Namespace


TimeValue.PV Method

TimeValue PV Method NFX Class Library

Returns present value of amount returned in X number of periods at a certain interest rate

Namespace: NFX.Financial
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static double PV(
    double fv,
    double intRate,
    int periods
)
public static double PV(
    double fv,
    double intRate,
    int periods
)
Public Shared Function PV (
    fv As Double,
    intRate As Double,
    periods As Integer
) As Double
Public Shared Function PV (
    fv As Double,
    intRate As Double,
    periods As Integer
) As Double
public:
static double PV(
    double fv,
    double intRate,
    int periods
)
public:
static double PV(
    double fv,
    double intRate,
    int periods
)
static member PV :
        fv : float *
        intRate : float *
        periods : int -> float
static member PV :
        fv : float *
        intRate : float *
        periods : int -> float

Parameters

fv
Type: Online System Double
Future value (returned amount in X periods)
intRate
Type: Online System Double
Interest rate per period
periods
Type: Online System Int32
Period length

Return Value

Type: Online Double
Present Value
Examples
Assume that A gives $100 cash to B. B returns the same amount to A in 1 year. Banks give 5% annual rate, therefore present value of this $100 dollar returned is going to be $95.24 - A lost $4.76, because B did not pay any interest and A could have deposited $100 in regular bank instead of giving it to B. Had A charged B 5% interest rate , A would have made money.
See Also
TimeValue Class
TimeValue Members
NFX.Financial Namespace


NFX.Financial.Market Namespace

NFX.Financial.Market Namespace NFX Class Library

Classes
 | Class | Description
Public class | CandleSample | Represents data for a candle sample
Public class | SamplingUtils |
Public class | TimeSeriesSampleBase | Represents a sample of a TimeSeries stream
Interfaces
 | Interface | Description
Public interface | ITimedSample | Represents an interface to an object that has a timestamp
Public interface | ITimeSeriesSample | Represents a sample of a TimeSeries stream
Enumerations
 | Enumeration | Description
Public enumeration | Side |


CandleSample Class

CandleSample Class NFX Class Library

Represents data for a candle sample
Inheritance Hierarchy
Online System Object
NFX.Financial.Market TimeSeriesSampleBase
NFX.Financial.Market CandleSample

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CandleSample : TimeSeriesSampleBase
public class CandleSample : TimeSeriesSampleBase
Public Class CandleSample
    Inherits TimeSeriesSampleBase
Public Class CandleSample
    Inherits TimeSeriesSampleBase
public ref class CandleSample : public TimeSeriesSampleBase
public ref class CandleSample : public TimeSeriesSampleBase
type CandleSample =
    class
        inherit TimeSeriesSampleBase
    end
type CandleSample =
    class
        inherit TimeSeriesSampleBase
    end
See Also
CandleSample Members
NFX.Financial.Market Namespace


CandleSample Members

CandleSample Members NFX Class Library

The CandleSample type exposes the following members.
Constructors
 | Name | Description
Public method | CandleSample | Initializes a new instance of the CandleSample class
Public method | CandleSample(DateTime) | Initializes a new instance of the CandleSample class
Back to Top
Methods
 | Name | Description
Public method | Add | Add a price to current candle sample
Public method | AggregateSample(CandleSample) |
Public method | AggregateSample(ITimeSeriesSample) | (Overrides TimeSeriesSampleBase AggregateSample(ITimeSeriesSample).)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | GenerateRandom | Generates random market candle stream
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeAggregateInstance | (Overrides TimeSeriesSampleBase MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Replace |
Public method | SummarizeAggregation | (Inherited from TimeSeriesSampleBase.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | AssociatedData | Associates an arbitrary data (Inherited from TimeSeriesSampleBase.)
Public property | BuyVolume |
Public property | ClosePrice |
Public property | Count |
Public property | Empty |
Public property | HighPrice |
Public property | LowPrice |
Public property | OpenPrice |
Public property | SellVolume |
Public property | TimeSpanMs | Timespan in MS that this candle covers, may not be always needed
Public property | TimeStamp | (Inherited from TimeSeriesSampleBase.)
Back to Top
See Also
CandleSample Class
NFX.Financial.Market Namespace


CandleSample Constructor

CandleSample Constructor NFX Class Library

Overload List
 | Name | Description
Public method | CandleSample | Initializes a new instance of the CandleSample class
Public method | CandleSample(DateTime) | Initializes a new instance of the CandleSample class
Back to Top
See Also
CandleSample Class
CandleSample Members
NFX.Financial.Market Namespace


CandleSample Constructor

CandleSample Constructor NFX Class Library

Initializes a new instance of the CandleSample class

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CandleSample()
public CandleSample()
Public Sub New
Public Sub New
public:
CandleSample()
public:
CandleSample()
new : unit -> CandleSample
new : unit -> CandleSample
See Also
CandleSample Class
CandleSample Members
CandleSample Overload
NFX.Financial.Market Namespace


CandleSample Constructor (DateTime)

CandleSample Constructor (DateTime) NFX Class Library

Initializes a new instance of the CandleSample class

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CandleSample(
    DateTime timeStamp
)
public CandleSample(
    DateTime timeStamp
)
Public Sub New (
    timeStamp As DateTime
)
Public Sub New (
    timeStamp As DateTime
)
public:
CandleSample(
    DateTime timeStamp
)
public:
CandleSample(
    DateTime timeStamp
)
new :
        timeStamp : DateTime -> CandleSample
new :
        timeStamp : DateTime -> CandleSample

Parameters

timeStamp
Type: Online System DateTime
See Also
CandleSample Class
CandleSample Members
CandleSample Overload
NFX.Financial.Market Namespace


CandleSample Methods

CandleSample Methods NFX Class Library

The CandleSample type exposes the following members.
Methods
 | Name | Description
Public method | Add | Add a price to current candle sample
Public method | AggregateSample(CandleSample) |
Public method | AggregateSample(ITimeSeriesSample) | (Overrides TimeSeriesSampleBase AggregateSample(ITimeSeriesSample).)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | GenerateRandom | Generates random market candle stream
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeAggregateInstance | (Overrides TimeSeriesSampleBase MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Replace |
Public method | SummarizeAggregation | (Inherited from TimeSeriesSampleBase.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CandleSample Class
NFX.Financial.Market Namespace


CandleSample.Add Method

CandleSample Add Method NFX Class Library

Add a price to current candle sample

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    float price,
    long qty = 0
)
public void Add(
    float price,
    long qty = 0
)
Public Sub Add (
    price As Single,
    Optional qty As Long = 0
)
Public Sub Add (
    price As Single,
    Optional qty As Long = 0
)
public:
void Add(
    float price,
    long long qty = 0
)
public:
void Add(
    float price,
    long long qty = 0
)
member Add :
        price : float32 *
        ?qty : int64
(* Defaults:
        let _qty = defaultArg qty 0
*)
-> unit
member Add :
        price : float32 *
        ?qty : int64
(* Defaults:
        let _qty = defaultArg qty 0
*)
-> unit

Parameters

price
Type: Online System Single
Price to be added
qty (Optional)
Type: Online System Int64
Quantity to be added. Use positive values for Buy-side quantity and negative for Sell-side quantity
See Also
CandleSample Class
CandleSample Members
NFX.Financial.Market Namespace


CandleSample.AggregateSample Method

CandleSample AggregateSample Method NFX Class Library

Overload List
 | Name | Description
Public method | AggregateSample(CandleSample) |
Public method | AggregateSample(ITimeSeriesSample) | (Overrides TimeSeriesSampleBase AggregateSample(ITimeSeriesSample).)
Back to Top
See Also
CandleSample Class
CandleSample Members
NFX.Financial.Market Namespace


CandleSample.AggregateSample Method (CandleSample)

CandleSample AggregateSample Method (CandleSample) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AggregateSample(
    CandleSample sample
)
public void AggregateSample(
    CandleSample sample
)
Public Sub AggregateSample (
    sample As CandleSample
)
Public Sub AggregateSample (
    sample As CandleSample
)
public:
void AggregateSample(
    CandleSample^ sample
)
public:
void AggregateSample(
    CandleSample^ sample
)
member AggregateSample :
        sample : CandleSample -> unit
member AggregateSample :
        sample : CandleSample -> unit

Parameters

sample
Type: NFX.Financial.Market CandleSample
See Also
CandleSample Class
CandleSample Members
AggregateSample Overload
NFX.Financial.Market Namespace


CandleSample.AggregateSample Method (ITimeSeriesSample)

CandleSample AggregateSample Method (ITimeSeriesSample) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void AggregateSample(
    ITimeSeriesSample sample
)
public override void AggregateSample(
    ITimeSeriesSample sample
)
Public Overrides Sub AggregateSample (
    sample As ITimeSeriesSample
)
Public Overrides Sub AggregateSample (
    sample As ITimeSeriesSample
)
public:
virtual void AggregateSample(
    ITimeSeriesSample^ sample
) override
public:
virtual void AggregateSample(
    ITimeSeriesSample^ sample
) override
abstract AggregateSample :
        sample : ITimeSeriesSample -> unit
override AggregateSample :
        sample : ITimeSeriesSample -> unit
abstract AggregateSample :
        sample : ITimeSeriesSample -> unit
override AggregateSample :
        sample : ITimeSeriesSample -> unit

Parameters

sample
Type: NFX.Financial.Market ITimeSeriesSample

Implements

ITimeSeriesSample AggregateSample(ITimeSeriesSample)
See Also
CandleSample Class
CandleSample Members
AggregateSample Overload
NFX.Financial.Market Namespace


CandleSample.GenerateRandom Method

CandleSample GenerateRandom Method NFX Class Library

Generates random market candle stream

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static CandleSample[] GenerateRandom(
    int count,
    DateTime startDate,
    int msInterval,
    int msIntervalDeviation,
    int priceDirChangeEvery,
    int priceChangeAccel,
    float currentMidPrice
)
public static CandleSample[] GenerateRandom(
    int count,
    DateTime startDate,
    int msInterval,
    int msIntervalDeviation,
    int priceDirChangeEvery,
    int priceChangeAccel,
    float currentMidPrice
)
Public Shared Function GenerateRandom (
    count As Integer,
    startDate As DateTime,
    msInterval As Integer,
    msIntervalDeviation As Integer,
    priceDirChangeEvery As Integer,
    priceChangeAccel As Integer,
    currentMidPrice As Single
) As CandleSample()
Public Shared Function GenerateRandom (
    count As Integer,
    startDate As DateTime,
    msInterval As Integer,
    msIntervalDeviation As Integer,
    priceDirChangeEvery As Integer,
    priceChangeAccel As Integer,
    currentMidPrice As Single
) As CandleSample()
public:
static array<CandleSample^>^ GenerateRandom(
    int count,
    DateTime startDate,
    int msInterval,
    int msIntervalDeviation,
    int priceDirChangeEvery,
    int priceChangeAccel,
    float currentMidPrice
)
public:
static array<CandleSample^>^ GenerateRandom(
    int count,
    DateTime startDate,
    int msInterval,
    int msIntervalDeviation,
    int priceDirChangeEvery,
    int priceChangeAccel,
    float currentMidPrice
)
static member GenerateRandom :
        count : int *
        startDate : DateTime *
        msInterval : int *
        msIntervalDeviation : int *
        priceDirChangeEvery : int *
        priceChangeAccel : int *
        currentMidPrice : float32 -> CandleSample[]
static member GenerateRandom :
        count : int *
        startDate : DateTime *
        msInterval : int *
        msIntervalDeviation : int *
        priceDirChangeEvery : int *
        priceChangeAccel : int *
        currentMidPrice : float32 -> CandleSample[]

Parameters

count
Type: Online System Int32
startDate
Type: Online System DateTime
msInterval
Type: Online System Int32
msIntervalDeviation
Type: Online System Int32
priceDirChangeEvery
Type: Online System Int32
priceChangeAccel
Type: Online System Int32
currentMidPrice
Type: Online System Single

Return Value

Type: CandleSample
See Also
CandleSample Class
CandleSample Members
NFX.Financial.Market Namespace


CandleSample.MakeAggregateInstance Method

CandleSample MakeAggregateInstance Method NFX Class Library

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ITimeSeriesSample MakeAggregateInstance()
public override ITimeSeriesSample MakeAggregateInstance()
Public Overrides Function MakeAggregateInstance As ITimeSeriesSample
Public Overrides Function MakeAggregateInstance As ITimeSeriesSample
public:
virtual ITimeSeriesSample^ MakeAggregateInstance() override
public:
virtual ITimeSeriesSample^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> ITimeSeriesSample
override MakeAggregateInstance : unit -> ITimeSeriesSample
abstract MakeAggregateInstance : unit -> ITimeSeriesSample
override MakeAggregateInstance : unit -> ITimeSeriesSample

Return Value

Type: ITimeSeriesSample

Implements

ITimeSeriesSample MakeAggregateInstance
See Also
CandleSample Class
CandleSample Members
NFX.Financial.Market Namespace


CandleSample.Replace Method

CandleSample Replace Method NFX Class Library

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Replace(
    CandleSample sample
)
public void Replace(
    CandleSample sample
)
Public Sub Replace (
    sample As CandleSample
)
Public Sub Replace (
    sample As CandleSample
)
public:
void Replace(
    CandleSample^ sample
)
public:
void Replace(
    CandleSample^ sample
)
member Replace :
        sample : CandleSample -> unit
member Replace :
        sample : CandleSample -> unit

Parameters

sample
Type: NFX.Financial.Market CandleSample
See Also
CandleSample Class
CandleSample Members
NFX.Financial.Market Namespace


CandleSample Properties

CandleSample Properties NFX Class Library

The CandleSample type exposes the following members.
Properties
 | Name | Description
Public property | AssociatedData | Associates an arbitrary data (Inherited from TimeSeriesSampleBase.)
Public property | BuyVolume |
Public property | ClosePrice |
Public property | Count |
Public property | Empty |
Public property | HighPrice |
Public property | LowPrice |
Public property | OpenPrice |
Public property | SellVolume |
Public property | TimeSpanMs | Timespan in MS that this candle covers, may not be always needed
Public property | TimeStamp | (Inherited from TimeSeriesSampleBase.)
Back to Top
See Also
CandleSample Class
NFX.Financial.Market Namespace


CandleSample.BuyVolume Property

CandleSample BuyVolume Property NFX Class Library

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long BuyVolume { get; set; }
public long BuyVolume { get; set; }
Public Property BuyVolume As Long
    Get
    Set
Public Property BuyVolume As Long
    Get
    Set
public:
property long long BuyVolume {
    long long get ();
    void set (long long value);
}
public:
property long long BuyVolume {
    long long get ();
    void set (long long value);
}
member BuyVolume : int64 with get, set
member BuyVolume : int64 with get, set

Property Value

Type: Online Int64
See Also
CandleSample Class
CandleSample Members
NFX.Financial.Market Namespace


CandleSample.ClosePrice Property

CandleSample ClosePrice Property NFX Class Library

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float ClosePrice { get; set; }
public float ClosePrice { get; set; }
Public Property ClosePrice As Single
    Get
    Set
Public Property ClosePrice As Single
    Get
    Set
public:
property float ClosePrice {
    float get ();
    void set (float value);
}
public:
property float ClosePrice {
    float get ();
    void set (float value);
}
member ClosePrice : float32 with get, set
member ClosePrice : float32 with get, set

Property Value

Type: Online Single
See Also
CandleSample Class
CandleSample Members
NFX.Financial.Market Namespace


CandleSample.Count Property

CandleSample Count Property NFX Class Library

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; set; }
public int Count { get; set; }
Public Property Count As Integer
    Get
    Set
Public Property Count As Integer
    Get
    Set
public:
property int Count {
    int get ();
    void set (int value);
}
public:
property int Count {
    int get ();
    void set (int value);
}
member Count : int with get, set
member Count : int with get, set

Property Value

Type: Online Int32
See Also
CandleSample Class
CandleSample Members
NFX.Financial.Market Namespace


CandleSample.Empty Property

CandleSample Empty Property NFX Class Library

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Empty { get; }
public bool Empty { get; }
Public ReadOnly Property Empty As Boolean
    Get
Public ReadOnly Property Empty As Boolean
    Get
public:
property bool Empty {
    bool get ();
}
public:
property bool Empty {
    bool get ();
}
member Empty : bool with get
member Empty : bool with get

Property Value

Type: Online Boolean
See Also
CandleSample Class
CandleSample Members
NFX.Financial.Market Namespace


CandleSample.HighPrice Property

CandleSample HighPrice Property NFX Class Library

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float HighPrice { get; set; }
public float HighPrice { get; set; }
Public Property HighPrice As Single
    Get
    Set
Public Property HighPrice As Single
    Get
    Set
public:
property float HighPrice {
    float get ();
    void set (float value);
}
public:
property float HighPrice {
    float get ();
    void set (float value);
}
member HighPrice : float32 with get, set
member HighPrice : float32 with get, set

Property Value

Type: Online Single
See Also
CandleSample Class
CandleSample Members
NFX.Financial.Market Namespace


CandleSample.LowPrice Property

CandleSample LowPrice Property NFX Class Library

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float LowPrice { get; set; }
public float LowPrice { get; set; }
Public Property LowPrice As Single
    Get
    Set
Public Property LowPrice As Single
    Get
    Set
public:
property float LowPrice {
    float get ();
    void set (float value);
}
public:
property float LowPrice {
    float get ();
    void set (float value);
}
member LowPrice : float32 with get, set
member LowPrice : float32 with get, set

Property Value

Type: Online Single
See Also
CandleSample Class
CandleSample Members
NFX.Financial.Market Namespace


CandleSample.OpenPrice Property

CandleSample OpenPrice Property NFX Class Library

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float OpenPrice { get; set; }
public float OpenPrice { get; set; }
Public Property OpenPrice As Single
    Get
    Set
Public Property OpenPrice As Single
    Get
    Set
public:
property float OpenPrice {
    float get ();
    void set (float value);
}
public:
property float OpenPrice {
    float get ();
    void set (float value);
}
member OpenPrice : float32 with get, set
member OpenPrice : float32 with get, set

Property Value

Type: Online Single
See Also
CandleSample Class
CandleSample Members
NFX.Financial.Market Namespace


CandleSample.SellVolume Property

CandleSample SellVolume Property NFX Class Library

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long SellVolume { get; set; }
public long SellVolume { get; set; }
Public Property SellVolume As Long
    Get
    Set
Public Property SellVolume As Long
    Get
    Set
public:
property long long SellVolume {
    long long get ();
    void set (long long value);
}
public:
property long long SellVolume {
    long long get ();
    void set (long long value);
}
member SellVolume : int64 with get, set
member SellVolume : int64 with get, set

Property Value

Type: Online Int64
See Also
CandleSample Class
CandleSample Members
NFX.Financial.Market Namespace


CandleSample.TimeSpanMs Property

CandleSample TimeSpanMs Property NFX Class Library

Timespan in MS that this candle covers, may not be always needed

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long TimeSpanMs { get; set; }
public long TimeSpanMs { get; set; }
Public Property TimeSpanMs As Long
    Get
    Set
Public Property TimeSpanMs As Long
    Get
    Set
public:
property long long TimeSpanMs {
    long long get ();
    void set (long long value);
}
public:
property long long TimeSpanMs {
    long long get ();
    void set (long long value);
}
member TimeSpanMs : int64 with get, set
member TimeSpanMs : int64 with get, set

Property Value

Type: Online Int64
See Also
CandleSample Class
CandleSample Members
NFX.Financial.Market Namespace


ITimedSample Interface

ITimedSample Interface NFX Class Library

Represents an interface to an object that has a timestamp

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ITimedSample
public interface ITimedSample
Public Interface ITimedSample
Public Interface ITimedSample
public interface class ITimedSample
public interface class ITimedSample
type ITimedSample =  interface end
type ITimedSample =  interface end
See Also
ITimedSample Members
NFX.Financial.Market Namespace


ITimedSample Members

ITimedSample Members NFX Class Library

The ITimedSample type exposes the following members.
Properties
 | Name | Description
Public property | TimeStamp | Timestamp of the sample
Back to Top
See Also
ITimedSample Interface
NFX.Financial.Market Namespace


ITimedSample Properties

ITimedSample Properties NFX Class Library

The ITimedSample type exposes the following members.
Properties
 | Name | Description
Public property | TimeStamp | Timestamp of the sample
Back to Top
See Also
ITimedSample Interface
NFX.Financial.Market Namespace


ITimedSample.TimeStamp Property

ITimedSample TimeStamp Property NFX Class Library

Timestamp of the sample

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
DateTime TimeStamp { get; set; }
DateTime TimeStamp { get; set; }
Property TimeStamp As DateTime
    Get
    Set
Property TimeStamp As DateTime
    Get
    Set
property DateTime TimeStamp {
    DateTime get ();
    void set (DateTime value);
}
property DateTime TimeStamp {
    DateTime get ();
    void set (DateTime value);
}
abstract TimeStamp : DateTime with get, set
abstract TimeStamp : DateTime with get, set

Property Value

Type: Online DateTime
See Also
ITimedSample Interface
ITimedSample Members
NFX.Financial.Market Namespace


ITimeSeriesSample Interface

ITimeSeriesSample Interface NFX Class Library

Represents a sample of a TimeSeries stream

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ITimeSeriesSample : ITimedSample
public interface ITimeSeriesSample : ITimedSample
Public Interface ITimeSeriesSample
    Inherits ITimedSample
Public Interface ITimeSeriesSample
    Inherits ITimedSample
public interface class ITimeSeriesSample : ITimedSample
public interface class ITimeSeriesSample : ITimedSample
type ITimeSeriesSample =
    interface
        interface ITimedSample
    end
type ITimeSeriesSample =
    interface
        interface ITimedSample
    end
See Also
ITimeSeriesSample Members
NFX.Financial.Market Namespace


ITimeSeriesSample Members

ITimeSeriesSample Members NFX Class Library

The ITimeSeriesSample type exposes the following members.
Methods
 | Name | Description
Public method | AggregateSample | Adds a sample to this aggregation instance
Public method | MakeAggregateInstance | Makes aggregate instance
Public method | SummarizeAggregation | Summarizes aggregation on this isntance
Back to Top
Properties
 | Name | Description
Public property | AssociatedData | Associates an arbitrary data
Public property | TimeStamp | Timestamp of the sample (Inherited from ITimedSample.)
Back to Top
See Also
ITimeSeriesSample Interface
NFX.Financial.Market Namespace


ITimeSeriesSample Methods

ITimeSeriesSample Methods NFX Class Library

The ITimeSeriesSample type exposes the following members.
Methods
 | Name | Description
Public method | AggregateSample | Adds a sample to this aggregation instance
Public method | MakeAggregateInstance | Makes aggregate instance
Public method | SummarizeAggregation | Summarizes aggregation on this isntance
Back to Top
See Also
ITimeSeriesSample Interface
NFX.Financial.Market Namespace


ITimeSeriesSample.AggregateSample Method

ITimeSeriesSample AggregateSample Method NFX Class Library

Adds a sample to this aggregation instance

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void AggregateSample(
    ITimeSeriesSample sample
)
void AggregateSample(
    ITimeSeriesSample sample
)
Sub AggregateSample (
    sample As ITimeSeriesSample
)
Sub AggregateSample (
    sample As ITimeSeriesSample
)
void AggregateSample(
    ITimeSeriesSample^ sample
)
void AggregateSample(
    ITimeSeriesSample^ sample
)
abstract AggregateSample :
        sample : ITimeSeriesSample -> unit
abstract AggregateSample :
        sample : ITimeSeriesSample -> unit

Parameters

sample
Type: NFX.Financial.Market ITimeSeriesSample
See Also
ITimeSeriesSample Interface
ITimeSeriesSample Members
NFX.Financial.Market Namespace


ITimeSeriesSample.MakeAggregateInstance Method

ITimeSeriesSample MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Makes aggregate instance

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ITimeSeriesSample MakeAggregateInstance()
ITimeSeriesSample MakeAggregateInstance()
Function MakeAggregateInstance As ITimeSeriesSample
Function MakeAggregateInstance As ITimeSeriesSample
ITimeSeriesSample^ MakeAggregateInstance()
ITimeSeriesSample^ MakeAggregateInstance()
abstract MakeAggregateInstance : unit -> ITimeSeriesSample
abstract MakeAggregateInstance : unit -> ITimeSeriesSample

Return Value

Type: ITimeSeriesSample
See Also
ITimeSeriesSample Interface
ITimeSeriesSample Members
NFX.Financial.Market Namespace


ITimeSeriesSample.SummarizeAggregation Method

ITimeSeriesSample SummarizeAggregation Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Summarizes aggregation on this isntance

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void SummarizeAggregation()
void SummarizeAggregation()
Sub SummarizeAggregation
Sub SummarizeAggregation
void SummarizeAggregation()
void SummarizeAggregation()
abstract SummarizeAggregation : unit -> unit
abstract SummarizeAggregation : unit -> unit
See Also
ITimeSeriesSample Interface
ITimeSeriesSample Members
NFX.Financial.Market Namespace


ITimeSeriesSample Properties

ITimeSeriesSample Properties NFX Class Library

The ITimeSeriesSample type exposes the following members.
Properties
 | Name | Description
Public property | AssociatedData | Associates an arbitrary data
Public property | TimeStamp | Timestamp of the sample (Inherited from ITimedSample.)
Back to Top
See Also
ITimeSeriesSample Interface
NFX.Financial.Market Namespace


ITimeSeriesSample.AssociatedData Property

ITimeSeriesSample AssociatedData Property NFX Class Library

Associates an arbitrary data

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object AssociatedData { get; }
Object AssociatedData { get; }
ReadOnly Property AssociatedData As Object
    Get
ReadOnly Property AssociatedData As Object
    Get
property Object^ AssociatedData {
    Object^ get ();
}
property Object^ AssociatedData {
    Object^ get ();
}
abstract AssociatedData : Object with get
abstract AssociatedData : Object with get

Property Value

Type: Online Object
See Also
ITimeSeriesSample Interface
ITimeSeriesSample Members
NFX.Financial.Market Namespace


SamplingUtils Class

SamplingUtils Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Financial.Market SamplingUtils

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class SamplingUtils
public static class SamplingUtils
<ExtensionAttribute>
Public NotInheritable Class SamplingUtils
<ExtensionAttribute>
Public NotInheritable Class SamplingUtils
[ExtensionAttribute]
public ref class SamplingUtils abstract sealed
[ExtensionAttribute]
public ref class SamplingUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SamplingUtils =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SamplingUtils =  class end
See Also
SamplingUtils Members
NFX.Financial.Market Namespace


SamplingUtils Members

SamplingUtils Members NFX Class Library

The SamplingUtils type exposes the following members.
Methods
Name | Description
AggregateHomogeneousSamples | Aggregates source stream of the normally equidistant samples of the same type by the specified factor
SynthesizeCandles(IEnumerable ITimeSeriesSample , UInt32, Action CandleSample, SecDBFileReader QuoteSample, Int32 , Action CandleSample, SecDBFileReader TradeSample, Int32 ) | Synthesizes a stream of candle samples from Quote and Trade samples coming from the market (i.e SecDB file)
SynthesizeCandles T (IEnumerable ITimeSeriesSample , UInt32, Action T, SecDBFileReader QuoteSample, Int32 , Action T, SecDBFileReader TradeSample, Int32 ) | Synthesizes a stream of candle samples from Quote and Trade samples coming from a market data source (i.e SecDB file)
Back to Top
See Also
SamplingUtils Class
NFX.Financial.Market Namespace


SamplingUtils Methods

SamplingUtils Methods NFX Class Library

The SamplingUtils type exposes the following members.
Methods
Name | Description
AggregateHomogeneousSamples | Aggregates source stream of the normally equidistant samples of the same type by the specified factor
SynthesizeCandles(IEnumerable ITimeSeriesSample , UInt32, Action CandleSample, SecDBFileReader QuoteSample, Int32 , Action CandleSample, SecDBFileReader TradeSample, Int32 ) | Synthesizes a stream of candle samples from Quote and Trade samples coming from the market (i.e SecDB file)
SynthesizeCandles T (IEnumerable ITimeSeriesSample , UInt32, Action T, SecDBFileReader QuoteSample, Int32 , Action T, SecDBFileReader TradeSample, Int32 ) | Synthesizes a stream of candle samples from Quote and Trade samples coming from a market data source (i.e SecDB file)
Back to Top
See Also
SamplingUtils Class
NFX.Financial.Market Namespace


SamplingUtils.AggregateHomogeneousSamples Method

SamplingUtils AggregateHomogeneousSamples Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Aggregates source stream of the normally equidistant samples of the same type by the specified factor

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<ITimeSeriesSample> AggregateHomogeneousSamples(
    this IEnumerable<ITimeSeriesSample> source,
    uint times,
    float samplingRateVariationPct = 1f
)
public static IEnumerable<ITimeSeriesSample> AggregateHomogeneousSamples(
    this IEnumerable<ITimeSeriesSample> source,
    uint times,
    float samplingRateVariationPct = 1f
)
<ExtensionAttribute>
Public Shared Function AggregateHomogeneousSamples (
    source As IEnumerable(Of ITimeSeriesSample),
    times As UInteger,
    Optional samplingRateVariationPct As Single = 1F
) As IEnumerable(Of ITimeSeriesSample)
<ExtensionAttribute>
Public Shared Function AggregateHomogeneousSamples (
    source As IEnumerable(Of ITimeSeriesSample),
    times As UInteger,
    Optional samplingRateVariationPct As Single = 1F
) As IEnumerable(Of ITimeSeriesSample)
public:
[ExtensionAttribute]
static IEnumerable<ITimeSeriesSample^>^ AggregateHomogeneousSamples(
    IEnumerable<ITimeSeriesSample^>^ source,
    unsigned int times,
    float samplingRateVariationPct = 1f
)
public:
[ExtensionAttribute]
static IEnumerable<ITimeSeriesSample^>^ AggregateHomogeneousSamples(
    IEnumerable<ITimeSeriesSample^>^ source,
    unsigned int times,
    float samplingRateVariationPct = 1f
)
static member AggregateHomogeneousSamples :
        source : IEnumerable<ITimeSeriesSample> *
        times : uint32 *
        ?samplingRateVariationPct : float32
(* Defaults:
        let _samplingRateVariationPct = defaultArg samplingRateVariationPct 1f
*)
-> IEnumerable<ITimeSeriesSample>
static member AggregateHomogeneousSamples :
        source : IEnumerable<ITimeSeriesSample> *
        times : uint32 *
        ?samplingRateVariationPct : float32
(* Defaults:
        let _samplingRateVariationPct = defaultArg samplingRateVariationPct 1f
*)
-> IEnumerable<ITimeSeriesSample>

Parameters

source
Type: Online System.Collections.Generic IEnumerable ITimeSeriesSample
Source stream
times
Type: Online System UInt32
Factor of aggergation, i.e. 4x means aggregate 4 samples into one
samplingRateVariationPct (Optional)
Type: Online System Single
The allowed variation in timing between samples, once this variation is exceeded the system emits new aggregate

Return Value

Type: Online IEnumerable ITimeSeriesSample
Aggregated sample stream

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online IEnumerable ITimeSeriesSample . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
SamplingUtils Class
SamplingUtils Members
NFX.Financial.Market Namespace


SamplingUtils.SynthesizeCandles Method

SamplingUtils SynthesizeCandles Method NFX Class Library

Overload List
Name | Description
SynthesizeCandles(IEnumerable ITimeSeriesSample , UInt32, Action CandleSample, SecDBFileReader QuoteSample, Int32 , Action CandleSample, SecDBFileReader TradeSample, Int32 ) | Synthesizes a stream of candle samples from Quote and Trade samples coming from the market (i.e SecDB file)
SynthesizeCandles T (IEnumerable ITimeSeriesSample , UInt32, Action T, SecDBFileReader QuoteSample, Int32 , Action T, SecDBFileReader TradeSample, Int32 ) | Synthesizes a stream of candle samples from Quote and Trade samples coming from a market data source (i.e SecDB file)
Back to Top
See Also
SamplingUtils Class
SamplingUtils Members
NFX.Financial.Market Namespace


SamplingUtils.SynthesizeCandles Method (IEnumerable(ITimeSeriesSample), UInt32, Action(CandleSample, SecDBFileReader.QuoteSample, Int32), Action(CandleSample, SecDBFileReader.TradeSample, Int32))

SamplingUtils SynthesizeCandles Method (IEnumerable ITimeSeriesSample , UInt32, Action CandleSample, SecDBFileReader QuoteSample, Int32 , Action CandleSample, SecDBFileReader TradeSample, Int32 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Synthesizes a stream of candle samples from Quote and Trade samples coming from the market (i.e SecDB file)

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<CandleSample> SynthesizeCandles(
    this IEnumerable<ITimeSeriesSample> source,
    uint secSamplingPeriod,
    Action<CandleSample, SecDBFileReader..::..QuoteSample, int> funcQuote = null,
    Action<CandleSample, SecDBFileReader..::..TradeSample, int> funcTrade = null
)
public static IEnumerable<CandleSample> SynthesizeCandles(
    this IEnumerable<ITimeSeriesSample> source,
    uint secSamplingPeriod,
    Action<CandleSample, SecDBFileReader..::..QuoteSample, int> funcQuote = null,
    Action<CandleSample, SecDBFileReader..::..TradeSample, int> funcTrade = null
)
<ExtensionAttribute>
Public Shared Function SynthesizeCandles (
    source As IEnumerable(Of ITimeSeriesSample),
    secSamplingPeriod As UInteger,
    Optional funcQuote As Action(Of CandleSample, SecDBFileReader..::..QuoteSample, Integer) = Nothing,
    Optional funcTrade As Action(Of CandleSample, SecDBFileReader..::..TradeSample, Integer) = Nothing
) As IEnumerable(Of CandleSample)
<ExtensionAttribute>
Public Shared Function SynthesizeCandles (
    source As IEnumerable(Of ITimeSeriesSample),
    secSamplingPeriod As UInteger,
    Optional funcQuote As Action(Of CandleSample, SecDBFileReader..::..QuoteSample, Integer) = Nothing,
    Optional funcTrade As Action(Of CandleSample, SecDBFileReader..::..TradeSample, Integer) = Nothing
) As IEnumerable(Of CandleSample)
public:
[ExtensionAttribute]
static IEnumerable<CandleSample^>^ SynthesizeCandles(
    IEnumerable<ITimeSeriesSample^>^ source,
    unsigned int secSamplingPeriod,
    Action<CandleSample^, SecDBFileReader..::..QuoteSample^, int>^ funcQuote = nullptr,
    Action<CandleSample^, SecDBFileReader..::..TradeSample^, int>^ funcTrade = nullptr
)
public:
[ExtensionAttribute]
static IEnumerable<CandleSample^>^ SynthesizeCandles(
    IEnumerable<ITimeSeriesSample^>^ source,
    unsigned int secSamplingPeriod,
    Action<CandleSample^, SecDBFileReader..::..QuoteSample^, int>^ funcQuote = nullptr,
    Action<CandleSample^, SecDBFileReader..::..TradeSample^, int>^ funcTrade = nullptr
)
static member SynthesizeCandles :
        source : IEnumerable<ITimeSeriesSample> *
        secSamplingPeriod : uint32 *
        ?funcQuote : Action<CandleSample, SecDBFileReader..::..QuoteSample, int> *
        ?funcTrade : Action<CandleSample, SecDBFileReader..::..TradeSample, int>
(* Defaults:
        let _funcQuote = defaultArg funcQuote null
        let _funcTrade = defaultArg funcTrade null
*)
-> IEnumerable<CandleSample>
static member SynthesizeCandles :
        source : IEnumerable<ITimeSeriesSample> *
        secSamplingPeriod : uint32 *
        ?funcQuote : Action<CandleSample, SecDBFileReader..::..QuoteSample, int> *
        ?funcTrade : Action<CandleSample, SecDBFileReader..::..TradeSample, int>
(* Defaults:
        let _funcQuote = defaultArg funcQuote null
        let _funcTrade = defaultArg funcTrade null
*)
-> IEnumerable<CandleSample>

Parameters

source
Type: Online System.Collections.Generic IEnumerable ITimeSeriesSample
Source of market data
secSamplingPeriod
Type: Online System UInt32
The output sampling period
funcQuote (Optional)
Type: Online System Action CandleSample, SecDBFileReader QuoteSample, Online Int32
Aggregation func for Quote, if null default is used which aggregates best bid
funcTrade (Optional)
Type: Online System Action CandleSample, SecDBFileReader TradeSample, Online Int32
Aggregation func for Quote, if null default is used which aggregates buy and sell volumes

Return Value

Type: Online IEnumerable CandleSample
Synthesized candle stream

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online IEnumerable ITimeSeriesSample . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
SamplingUtils Class
SamplingUtils Members
SynthesizeCandles Overload
NFX.Financial.Market Namespace


SamplingUtils.SynthesizeCandles(T) Method (IEnumerable(ITimeSeriesSample), UInt32, Action(T, SecDBFileReader.QuoteSample, Int32), Action(T, SecDBFileReader.TradeSample, Int32))

SamplingUtils SynthesizeCandles T Method (IEnumerable ITimeSeriesSample , UInt32, Action T, SecDBFileReader QuoteSample, Int32 , Action T, SecDBFileReader TradeSample, Int32 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Synthesizes a stream of candle samples from Quote and Trade samples coming from a market data source (i.e SecDB file)

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<T> SynthesizeCandles<T>(
    this IEnumerable<ITimeSeriesSample> source,
    uint secSamplingPeriod,
    Action<T, SecDBFileReader..::..QuoteSample, int> funcQuote,
    Action<T, SecDBFileReader..::..TradeSample, int> funcTrade
)
where T : ITimedSample
public static IEnumerable<T> SynthesizeCandles<T>(
    this IEnumerable<ITimeSeriesSample> source,
    uint secSamplingPeriod,
    Action<T, SecDBFileReader..::..QuoteSample, int> funcQuote,
    Action<T, SecDBFileReader..::..TradeSample, int> funcTrade
)
where T : ITimedSample
<ExtensionAttribute>
Public Shared Function SynthesizeCandles(Of T As ITimedSample) (
    source As IEnumerable(Of ITimeSeriesSample),
    secSamplingPeriod As UInteger,
    funcQuote As Action(Of T, SecDBFileReader..::..QuoteSample, Integer),
    funcTrade As Action(Of T, SecDBFileReader..::..TradeSample, Integer)
) As IEnumerable(Of T)
<ExtensionAttribute>
Public Shared Function SynthesizeCandles(Of T As ITimedSample) (
    source As IEnumerable(Of ITimeSeriesSample),
    secSamplingPeriod As UInteger,
    funcQuote As Action(Of T, SecDBFileReader..::..QuoteSample, Integer),
    funcTrade As Action(Of T, SecDBFileReader..::..TradeSample, Integer)
) As IEnumerable(Of T)
public:
[ExtensionAttribute]
generic<typename T>
where T : ITimedSample
static IEnumerable<T>^ SynthesizeCandles(
    IEnumerable<ITimeSeriesSample^>^ source,
    unsigned int secSamplingPeriod,
    Action<T, SecDBFileReader..::..QuoteSample^, int>^ funcQuote,
    Action<T, SecDBFileReader..::..TradeSample^, int>^ funcTrade
)
public:
[ExtensionAttribute]
generic<typename T>
where T : ITimedSample
static IEnumerable<T>^ SynthesizeCandles(
    IEnumerable<ITimeSeriesSample^>^ source,
    unsigned int secSamplingPeriod,
    Action<T, SecDBFileReader..::..QuoteSample^, int>^ funcQuote,
    Action<T, SecDBFileReader..::..TradeSample^, int>^ funcTrade
)
static member SynthesizeCandles :
        source : IEnumerable<ITimeSeriesSample> *
        secSamplingPeriod : uint32 *
        funcQuote : Action<'T, SecDBFileReader..::..QuoteSample, int> *
        funcTrade : Action<'T, SecDBFileReader..::..TradeSample, int> -> IEnumerable<'T>  when 'T : ITimedSample
static member SynthesizeCandles :
        source : IEnumerable<ITimeSeriesSample> *
        secSamplingPeriod : uint32 *
        funcQuote : Action<'T, SecDBFileReader..::..QuoteSample, int> *
        funcTrade : Action<'T, SecDBFileReader..::..TradeSample, int> -> IEnumerable<'T>  when 'T : ITimedSample

Parameters

source
Type: Online System.Collections.Generic IEnumerable ITimeSeriesSample
Source of market data
secSamplingPeriod
Type: Online System UInt32
The output sampling period
funcQuote
Type: Online System Action T, SecDBFileReader QuoteSample, Online Int32
Aggregation func for Quote, if null default is used which aggregates best bid
funcTrade
Type: Online System Action T, SecDBFileReader TradeSample, Online Int32
Aggregation func for Quote, if null default is used which aggregates buy and sell volumes
Type Parameters
T

Return Value

Type: Online IEnumerable T
Synthesized candle stream

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online IEnumerable ITimeSeriesSample . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
SamplingUtils Class
SamplingUtils Members
SynthesizeCandles Overload
NFX.Financial.Market Namespace


Side Enumeration

Side Enumeration NFX Class Library

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum Side
public enum Side
Public Enumeration Side
Public Enumeration Side
public enum class Side
public enum class Side
type Side
type Side
Members
Member name | Value | Description
Undefined | 0 |
Buy | 1 |
Sell | 2 |
Bid | 1 |
Ask | 2 |
See Also
NFX.Financial.Market Namespace


TimeSeriesSampleBase Class

TimeSeriesSampleBase Class NFX Class Library

Represents a sample of a TimeSeries stream
Inheritance Hierarchy
Online System Object
NFX.Financial.Market TimeSeriesSampleBase
NFX.Financial.Market CandleSample
NFX.Financial.Market.SecDb SecDBFileReader StreamSample

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class TimeSeriesSampleBase : ITimeSeriesSample,
    ITimedSample
public abstract class TimeSeriesSampleBase : ITimeSeriesSample,
    ITimedSample
Public MustInherit Class TimeSeriesSampleBase
    Implements ITimeSeriesSample, ITimedSample
Public MustInherit Class TimeSeriesSampleBase
    Implements ITimeSeriesSample, ITimedSample
public ref class TimeSeriesSampleBase abstract : ITimeSeriesSample,
    ITimedSample
public ref class TimeSeriesSampleBase abstract : ITimeSeriesSample,
    ITimedSample
[<AbstractClassAttribute>]
type TimeSeriesSampleBase =
    class
        interface ITimeSeriesSample
        interface ITimedSample
    end
[<AbstractClassAttribute>]
type TimeSeriesSampleBase =
    class
        interface ITimeSeriesSample
        interface ITimedSample
    end
See Also
TimeSeriesSampleBase Members
NFX.Financial.Market Namespace


TimeSeriesSampleBase Members

TimeSeriesSampleBase Members NFX Class Library

The TimeSeriesSampleBase type exposes the following members.
Constructors
 | Name | Description
Protected method | TimeSeriesSampleBase | Initializes a new instance of the TimeSeriesSampleBase class
Back to Top
Methods
 | Name | Description
Public method | AggregateSample |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeAggregateInstance |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SummarizeAggregation |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | AssociatedData | Associates an arbitrary data
Public property | TimeStamp |
Back to Top
See Also
TimeSeriesSampleBase Class
NFX.Financial.Market Namespace


TimeSeriesSampleBase Constructor

TimeSeriesSampleBase Constructor NFX Class Library

Initializes a new instance of the TimeSeriesSampleBase class

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TimeSeriesSampleBase(
    DateTime timeStamp
)
protected TimeSeriesSampleBase(
    DateTime timeStamp
)
Protected Sub New (
    timeStamp As DateTime
)
Protected Sub New (
    timeStamp As DateTime
)
protected:
TimeSeriesSampleBase(
    DateTime timeStamp
)
protected:
TimeSeriesSampleBase(
    DateTime timeStamp
)
new :
        timeStamp : DateTime -> TimeSeriesSampleBase
new :
        timeStamp : DateTime -> TimeSeriesSampleBase

Parameters

timeStamp
Type: Online System DateTime
See Also
TimeSeriesSampleBase Class
TimeSeriesSampleBase Members
NFX.Financial.Market Namespace


TimeSeriesSampleBase Methods

TimeSeriesSampleBase Methods NFX Class Library

The TimeSeriesSampleBase type exposes the following members.
Methods
 | Name | Description
Public method | AggregateSample |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeAggregateInstance |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SummarizeAggregation |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TimeSeriesSampleBase Class
NFX.Financial.Market Namespace


TimeSeriesSampleBase.AggregateSample Method

TimeSeriesSampleBase AggregateSample Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void AggregateSample(
    ITimeSeriesSample sample
)
public virtual void AggregateSample(
    ITimeSeriesSample sample
)
Public Overridable Sub AggregateSample (
    sample As ITimeSeriesSample
)
Public Overridable Sub AggregateSample (
    sample As ITimeSeriesSample
)
public:
virtual void AggregateSample(
    ITimeSeriesSample^ sample
)
public:
virtual void AggregateSample(
    ITimeSeriesSample^ sample
)
abstract AggregateSample :
        sample : ITimeSeriesSample -> unit
override AggregateSample :
        sample : ITimeSeriesSample -> unit
abstract AggregateSample :
        sample : ITimeSeriesSample -> unit
override AggregateSample :
        sample : ITimeSeriesSample -> unit

Parameters

sample
Type: NFX.Financial.Market ITimeSeriesSample

Implements

ITimeSeriesSample AggregateSample(ITimeSeriesSample)
See Also
TimeSeriesSampleBase Class
TimeSeriesSampleBase Members
NFX.Financial.Market Namespace


TimeSeriesSampleBase.MakeAggregateInstance Method

TimeSeriesSampleBase MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual ITimeSeriesSample MakeAggregateInstance()
public virtual ITimeSeriesSample MakeAggregateInstance()
Public Overridable Function MakeAggregateInstance As ITimeSeriesSample
Public Overridable Function MakeAggregateInstance As ITimeSeriesSample
public:
virtual ITimeSeriesSample^ MakeAggregateInstance()
public:
virtual ITimeSeriesSample^ MakeAggregateInstance()
abstract MakeAggregateInstance : unit -> ITimeSeriesSample
override MakeAggregateInstance : unit -> ITimeSeriesSample
abstract MakeAggregateInstance : unit -> ITimeSeriesSample
override MakeAggregateInstance : unit -> ITimeSeriesSample

Return Value

Type: ITimeSeriesSample

Implements

ITimeSeriesSample MakeAggregateInstance
See Also
TimeSeriesSampleBase Class
TimeSeriesSampleBase Members
NFX.Financial.Market Namespace


TimeSeriesSampleBase.SummarizeAggregation Method

TimeSeriesSampleBase SummarizeAggregation Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SummarizeAggregation()
public virtual void SummarizeAggregation()
Public Overridable Sub SummarizeAggregation
Public Overridable Sub SummarizeAggregation
public:
virtual void SummarizeAggregation()
public:
virtual void SummarizeAggregation()
abstract SummarizeAggregation : unit -> unit
override SummarizeAggregation : unit -> unit
abstract SummarizeAggregation : unit -> unit
override SummarizeAggregation : unit -> unit

Implements

ITimeSeriesSample SummarizeAggregation
See Also
TimeSeriesSampleBase Class
TimeSeriesSampleBase Members
NFX.Financial.Market Namespace


TimeSeriesSampleBase Properties

TimeSeriesSampleBase Properties NFX Class Library

The TimeSeriesSampleBase type exposes the following members.
Properties
 | Name | Description
Public property | AssociatedData | Associates an arbitrary data
Public property | TimeStamp |
Back to Top
See Also
TimeSeriesSampleBase Class
NFX.Financial.Market Namespace


TimeSeriesSampleBase.AssociatedData Property

TimeSeriesSampleBase AssociatedData Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Associates an arbitrary data

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object AssociatedData { get; set; }
public Object AssociatedData { get; set; }
Public Property AssociatedData As Object
    Get
    Set
Public Property AssociatedData As Object
    Get
    Set
public:
virtual property Object^ AssociatedData {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}
public:
virtual property Object^ AssociatedData {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}
abstract AssociatedData : Object with get, set
override AssociatedData : Object with get, set
abstract AssociatedData : Object with get, set
override AssociatedData : Object with get, set

Property Value

Type: Online Object

Implements

ITimeSeriesSample AssociatedData
See Also
TimeSeriesSampleBase Class
TimeSeriesSampleBase Members
NFX.Financial.Market Namespace


TimeSeriesSampleBase.TimeStamp Property

TimeSeriesSampleBase TimeStamp Property NFX Class Library

Namespace: NFX.Financial.Market
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime TimeStamp { get; set; }
public DateTime TimeStamp { get; set; }
Public Property TimeStamp As DateTime
    Get
    Set
Public Property TimeStamp As DateTime
    Get
    Set
public:
virtual property DateTime TimeStamp {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}
public:
virtual property DateTime TimeStamp {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}
abstract TimeStamp : DateTime with get, set
override TimeStamp : DateTime with get, set
abstract TimeStamp : DateTime with get, set
override TimeStamp : DateTime with get, set

Property Value

Type: Online DateTime

Implements

ITimedSample TimeStamp
See Also
TimeSeriesSampleBase Class
TimeSeriesSampleBase Members
NFX.Financial.Market Namespace


NFX.Financial.Market.SecDb Namespace

NFX.Financial.Market.SecDb Namespace NFX Class Library

Classes
 | Class | Description
Public class | SecDBFileReader | Represents SecDB file. This class is thread-safe. See: https://github.com/saleyn/secdb/wiki/Data-Format
Public class | SecDBFileReader InfoSample |
Public class | SecDBFileReader OrderSample |
Public class | SecDBFileReader QuoteSample |
Public class | SecDBFileReader SecondSample |
Public class | SecDBFileReader StreamSample | Base class for all samples
Public class | SecDBFileReader SummarySample |
Public class | SecDBFileReader TradeSample |
Public class | SecDBPrimitives | Facilittates reading SecDB primitive values see: https://github.com/saleyn/secdb/wiki/Data-Format
Structures
 | Structure | Description
Public structure | SecDBFileReader CandleData | Represents OHLC sample from the file
Public structure | SecDBFileReader CandleHeader |
Public structure | SecDBFileReader CandlesMeta |
Public structure | SecDBFileReader FileRequiredHeader | Contains data from the REQUIRED/system protion of the file header
Public structure | SecDBFileReader QuoteSample PxLevel |
Public structure | SecDBFileReader StreamMeta |
Enumerations
 | Enumeration | Description
Public enumeration | SecDBFileReader CompressionType | Denotes compression types. Used in StreamMeta
Public enumeration | SecDBFileReader OrderSample SideType |
Public enumeration | SecDBFileReader StreamID | Denotes stream types (id). Used in StreamMeta
Public enumeration | SecDBFileReader TradeSample AggressorType |
Public enumeration | SecDBFileReader TradeSample SideType |
Public enumeration | StreamID | Denotes stream types (id). Used in StreamMeta


SecDBFileReader Class

SecDBFileReader Class NFX Class Library

Represents SecDB file. This class is thread-safe. See: https://github.com/saleyn/secdb/wiki/Data-Format
Represents SecDB file. This class is thread-safe. See: https://github.com/saleyn/secdb/wiki/Data-Format
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Financial.Market.SecDb SecDBFileReader

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class SecDBFileReader : DisposableObject
public sealed class SecDBFileReader : DisposableObject
Public NotInheritable Class SecDBFileReader
    Inherits DisposableObject
Public NotInheritable Class SecDBFileReader
    Inherits DisposableObject
public ref class SecDBFileReader sealed : public DisposableObject
public ref class SecDBFileReader sealed : public DisposableObject
[<SealedAttribute>]
type SecDBFileReader =
    class
        inherit DisposableObject
    end
[<SealedAttribute>]
type SecDBFileReader =
    class
        inherit DisposableObject
    end
See Also
SecDBFileReader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader Members

SecDBFileReader Members NFX Class Library

The SecDBFileReader type exposes the following members.
Constructors
 | Name | Description
Public method | SecDBFileReader | Initializes a new instance of the SecDBFileReader class
Back to Top
Methods
 | Name | Description
Protected method | Destructor | Override this method to do actual destructor work (Inherited from DisposableObject.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetAllStreamData | Gets all stream data
Public method | GetCandleData(UInt32, DateTime) | Tries to find a candle stream with the specified exact resolution and returns it starting from the specified start time, or returns an empty enumerable if resolution is not available
Public method | GetCandleData(UInt32, Int32) | Tries to find a candle stream with the specified exact resolution skipping the specified number of seconds and returns it, or returns an empty enumerable if resolution is not available
Public method | GetCandleData(SecDBFileReader CandleHeader, DateTime) | Returns candle data at the specified resolution starting at the specified start time
Public method | GetCandleData(SecDBFileReader CandleHeader, Int32) | Returns candle data at the specified resolution skipping the first specified number of seconds
Public method | GetCandleDataAsCandleSamples(UInt32, DateTime) | Tries to find a candle stream returned as CandleSamples with the specified exact resolution starting at the specified start time and returns it, or returns an empty enumerable if resolution is not available
Public method | GetCandleDataAsCandleSamples(UInt32, Int32) | Tries to find a candle stream returned as CandleSamples with the specified exact resolution skipping the specofoed number of seconds and returns it, or returns an empty enumerable if resolution is not available
Public method | GetCandleDataAsCandleSamples(SecDBFileReader CandleHeader, DateTime) | Returns candle data at the specified resolution starting at the specified start time
Public method | GetCandleDataAsCandleSamples(SecDBFileReader CandleHeader, Int32) | Returns candle data at the specified resolution skipping the first specified number of seconds
Public method | GetCandleHeader | Tries to find a CandleHeader with the exact specified resolution or unassigned header
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetStreamData(UInt32, DateTime) | Tries to find a candle stream by resolution and returns stream data starting from the specified UTC start time
Public method | GetStreamData(UInt32, Int32) | Tries to find a candle stream by resolution and return stream data skipping the specified seconds count from data start
Public method | GetStreamData(SecDBFileReader CandleHeader, DateTime) | Gets stream data per candle header index starting from the specified UTC start time
Public method | GetStreamData(SecDBFileReader CandleHeader, Int32) | Gets stream data per candle header index skipping the specified seconds count from data start
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
HDR_DATE |
HDR_DEPTH |
HDR_EXCHANGE |
HDR_INSTRUMENT |
HDR_PRICESTEP |
HDR_SECURITYID |
HDR_SYMBOL |
HDR_UUID |
HDR_VERSION |
Back to Top
Properties
 | Name | Description
Public property | CandlesMetadata | Returns metadata for candles in the file - collection of candle headers
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Headers | File headers dictionary, including the required ones
Public property | StreamsCompressionType |
Public property | StreamsDataOffset |
Public property | StreamsMetas |
Public property | SystemHeader | Returns the required/system portion of the file header
Back to Top
See Also
SecDBFileReader Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader Constructor

SecDBFileReader Constructor NFX Class Library

Initializes a new instance of the SecDBFileReader class

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SecDBFileReader(
    FileSystem fs,
    FileSystemSessionConnectParams conParams,
    string fileName
)
public SecDBFileReader(
    FileSystem fs,
    FileSystemSessionConnectParams conParams,
    string fileName
)
Public Sub New (
    fs As FileSystem,
    conParams As FileSystemSessionConnectParams,
    fileName As String
)
Public Sub New (
    fs As FileSystem,
    conParams As FileSystemSessionConnectParams,
    fileName As String
)
public:
SecDBFileReader(
    FileSystem^ fs,
    FileSystemSessionConnectParams^ conParams,
    String^ fileName
)
public:
SecDBFileReader(
    FileSystem^ fs,
    FileSystemSessionConnectParams^ conParams,
    String^ fileName
)
new :
        fs : FileSystem *
        conParams : FileSystemSessionConnectParams *
        fileName : string -> SecDBFileReader
new :
        fs : FileSystem *
        conParams : FileSystemSessionConnectParams *
        fileName : string -> SecDBFileReader

Parameters

fs
Type: NFX.IO.FileSystem FileSystem
conParams
Type: NFX.IO.FileSystem FileSystemSessionConnectParams
fileName
Type: Online System String
See Also
SecDBFileReader Class
SecDBFileReader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader Fields

SecDBFileReader Fields NFX Class Library

The SecDBFileReader type exposes the following members.
Fields
Name | Description
HDR_DATE |
HDR_DEPTH |
HDR_EXCHANGE |
HDR_INSTRUMENT |
HDR_PRICESTEP |
HDR_SECURITYID |
HDR_SYMBOL |
HDR_UUID |
HDR_VERSION |
Back to Top
See Also
SecDBFileReader Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.HDR_DATE Field

SecDBFileReader HDR_DATE Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HDR_DATE
public const string HDR_DATE
Public Const HDR_DATE As String
Public Const HDR_DATE As String
public:
literal String^ HDR_DATE
public:
literal String^ HDR_DATE
static val mutable HDR_DATE: string
static val mutable HDR_DATE: string

Field Value

Type: Online String
See Also
SecDBFileReader Class
SecDBFileReader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.HDR_DEPTH Field

SecDBFileReader HDR_DEPTH Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HDR_DEPTH
public const string HDR_DEPTH
Public Const HDR_DEPTH As String
Public Const HDR_DEPTH As String
public:
literal String^ HDR_DEPTH
public:
literal String^ HDR_DEPTH
static val mutable HDR_DEPTH: string
static val mutable HDR_DEPTH: string

Field Value

Type: Online String
See Also
SecDBFileReader Class
SecDBFileReader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.HDR_EXCHANGE Field

SecDBFileReader HDR_EXCHANGE Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HDR_EXCHANGE
public const string HDR_EXCHANGE
Public Const HDR_EXCHANGE As String
Public Const HDR_EXCHANGE As String
public:
literal String^ HDR_EXCHANGE
public:
literal String^ HDR_EXCHANGE
static val mutable HDR_EXCHANGE: string
static val mutable HDR_EXCHANGE: string

Field Value

Type: Online String
See Also
SecDBFileReader Class
SecDBFileReader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.HDR_INSTRUMENT Field

SecDBFileReader HDR_INSTRUMENT Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HDR_INSTRUMENT
public const string HDR_INSTRUMENT
Public Const HDR_INSTRUMENT As String
Public Const HDR_INSTRUMENT As String
public:
literal String^ HDR_INSTRUMENT
public:
literal String^ HDR_INSTRUMENT
static val mutable HDR_INSTRUMENT: string
static val mutable HDR_INSTRUMENT: string

Field Value

Type: Online String
See Also
SecDBFileReader Class
SecDBFileReader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.HDR_PRICESTEP Field

SecDBFileReader HDR_PRICESTEP Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HDR_PRICESTEP
public const string HDR_PRICESTEP
Public Const HDR_PRICESTEP As String
Public Const HDR_PRICESTEP As String
public:
literal String^ HDR_PRICESTEP
public:
literal String^ HDR_PRICESTEP
static val mutable HDR_PRICESTEP: string
static val mutable HDR_PRICESTEP: string

Field Value

Type: Online String
See Also
SecDBFileReader Class
SecDBFileReader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.HDR_SECURITYID Field

SecDBFileReader HDR_SECURITYID Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HDR_SECURITYID
public const string HDR_SECURITYID
Public Const HDR_SECURITYID As String
Public Const HDR_SECURITYID As String
public:
literal String^ HDR_SECURITYID
public:
literal String^ HDR_SECURITYID
static val mutable HDR_SECURITYID: string
static val mutable HDR_SECURITYID: string

Field Value

Type: Online String
See Also
SecDBFileReader Class
SecDBFileReader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.HDR_SYMBOL Field

SecDBFileReader HDR_SYMBOL Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HDR_SYMBOL
public const string HDR_SYMBOL
Public Const HDR_SYMBOL As String
Public Const HDR_SYMBOL As String
public:
literal String^ HDR_SYMBOL
public:
literal String^ HDR_SYMBOL
static val mutable HDR_SYMBOL: string
static val mutable HDR_SYMBOL: string

Field Value

Type: Online String
See Also
SecDBFileReader Class
SecDBFileReader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.HDR_UUID Field

SecDBFileReader HDR_UUID Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HDR_UUID
public const string HDR_UUID
Public Const HDR_UUID As String
Public Const HDR_UUID As String
public:
literal String^ HDR_UUID
public:
literal String^ HDR_UUID
static val mutable HDR_UUID: string
static val mutable HDR_UUID: string

Field Value

Type: Online String
See Also
SecDBFileReader Class
SecDBFileReader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.HDR_VERSION Field

SecDBFileReader HDR_VERSION Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HDR_VERSION
public const string HDR_VERSION
Public Const HDR_VERSION As String
Public Const HDR_VERSION As String
public:
literal String^ HDR_VERSION
public:
literal String^ HDR_VERSION
static val mutable HDR_VERSION: string
static val mutable HDR_VERSION: string

Field Value

Type: Online String
See Also
SecDBFileReader Class
SecDBFileReader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader Methods

SecDBFileReader Methods NFX Class Library

The SecDBFileReader type exposes the following members.
Methods
 | Name | Description
Protected method | Destructor | Override this method to do actual destructor work (Inherited from DisposableObject.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetAllStreamData | Gets all stream data
Public method | GetCandleData(UInt32, DateTime) | Tries to find a candle stream with the specified exact resolution and returns it starting from the specified start time, or returns an empty enumerable if resolution is not available
Public method | GetCandleData(UInt32, Int32) | Tries to find a candle stream with the specified exact resolution skipping the specified number of seconds and returns it, or returns an empty enumerable if resolution is not available
Public method | GetCandleData(SecDBFileReader CandleHeader, DateTime) | Returns candle data at the specified resolution starting at the specified start time
Public method | GetCandleData(SecDBFileReader CandleHeader, Int32) | Returns candle data at the specified resolution skipping the first specified number of seconds
Public method | GetCandleDataAsCandleSamples(UInt32, DateTime) | Tries to find a candle stream returned as CandleSamples with the specified exact resolution starting at the specified start time and returns it, or returns an empty enumerable if resolution is not available
Public method | GetCandleDataAsCandleSamples(UInt32, Int32) | Tries to find a candle stream returned as CandleSamples with the specified exact resolution skipping the specofoed number of seconds and returns it, or returns an empty enumerable if resolution is not available
Public method | GetCandleDataAsCandleSamples(SecDBFileReader CandleHeader, DateTime) | Returns candle data at the specified resolution starting at the specified start time
Public method | GetCandleDataAsCandleSamples(SecDBFileReader CandleHeader, Int32) | Returns candle data at the specified resolution skipping the first specified number of seconds
Public method | GetCandleHeader | Tries to find a CandleHeader with the exact specified resolution or unassigned header
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetStreamData(UInt32, DateTime) | Tries to find a candle stream by resolution and returns stream data starting from the specified UTC start time
Public method | GetStreamData(UInt32, Int32) | Tries to find a candle stream by resolution and return stream data skipping the specified seconds count from data start
Public method | GetStreamData(SecDBFileReader CandleHeader, DateTime) | Gets stream data per candle header index starting from the specified UTC start time
Public method | GetStreamData(SecDBFileReader CandleHeader, Int32) | Gets stream data per candle header index skipping the specified seconds count from data start
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SecDBFileReader Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.GetAllStreamData Method

SecDBFileReader GetAllStreamData Method NFX Class Library

Gets all stream data

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<SecDBFileReader..::..StreamSample> GetAllStreamData()
public IEnumerable<SecDBFileReader..::..StreamSample> GetAllStreamData()
Public Function GetAllStreamData As IEnumerable(Of SecDBFileReader..::..StreamSample)
Public Function GetAllStreamData As IEnumerable(Of SecDBFileReader..::..StreamSample)
public:
IEnumerable<SecDBFileReader..::..StreamSample^>^ GetAllStreamData()
public:
IEnumerable<SecDBFileReader..::..StreamSample^>^ GetAllStreamData()
member GetAllStreamData : unit -> IEnumerable<SecDBFileReader..::..StreamSample>
member GetAllStreamData : unit -> IEnumerable<SecDBFileReader..::..StreamSample>

Return Value

Type: Online IEnumerable SecDBFileReader StreamSample
See Also
SecDBFileReader Class
SecDBFileReader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.GetCandleData Method

SecDBFileReader GetCandleData Method NFX Class Library

Overload List
 | Name | Description
Public method | GetCandleData(UInt32, DateTime) | Tries to find a candle stream with the specified exact resolution and returns it starting from the specified start time, or returns an empty enumerable if resolution is not available
Public method | GetCandleData(UInt32, Int32) | Tries to find a candle stream with the specified exact resolution skipping the specified number of seconds and returns it, or returns an empty enumerable if resolution is not available
Public method | GetCandleData(SecDBFileReader CandleHeader, DateTime) | Returns candle data at the specified resolution starting at the specified start time
Public method | GetCandleData(SecDBFileReader CandleHeader, Int32) | Returns candle data at the specified resolution skipping the first specified number of seconds
Back to Top
See Also
SecDBFileReader Class
SecDBFileReader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.GetCandleData Method (UInt32, DateTime)

SecDBFileReader GetCandleData Method (UInt32, DateTime) NFX Class Library

[This is preliminary documentation and is subject to change.]

Tries to find a candle stream with the specified exact resolution and returns it starting from the specified start time, or returns an empty enumerable if resolution is not available

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<SecDBFileReader..::..CandleData> GetCandleData(
    uint resolutionSec,
    DateTime startTimeUTC
)
public IEnumerable<SecDBFileReader..::..CandleData> GetCandleData(
    uint resolutionSec,
    DateTime startTimeUTC
)
Public Function GetCandleData (
    resolutionSec As UInteger,
    startTimeUTC As DateTime
) As IEnumerable(Of SecDBFileReader..::..CandleData)
Public Function GetCandleData (
    resolutionSec As UInteger,
    startTimeUTC As DateTime
) As IEnumerable(Of SecDBFileReader..::..CandleData)
public:
IEnumerable<SecDBFileReader..::..CandleData>^ GetCandleData(
    unsigned int resolutionSec,
    DateTime startTimeUTC
)
public:
IEnumerable<SecDBFileReader..::..CandleData>^ GetCandleData(
    unsigned int resolutionSec,
    DateTime startTimeUTC
)
member GetCandleData :
        resolutionSec : uint32 *
        startTimeUTC : DateTime -> IEnumerable<SecDBFileReader..::..CandleData>
member GetCandleData :
        resolutionSec : uint32 *
        startTimeUTC : DateTime -> IEnumerable<SecDBFileReader..::..CandleData>

Parameters

resolutionSec
Type: Online System UInt32
startTimeUTC
Type: Online System DateTime

Return Value

Type: Online IEnumerable SecDBFileReader CandleData
See Also
SecDBFileReader Class
SecDBFileReader Members
GetCandleData Overload
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.GetCandleData Method (UInt32, Int32)

SecDBFileReader GetCandleData Method (UInt32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Tries to find a candle stream with the specified exact resolution skipping the specified number of seconds and returns it, or returns an empty enumerable if resolution is not available

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<SecDBFileReader..::..CandleData> GetCandleData(
    uint resolutionSec,
    int skipSeconds = 0
)
public IEnumerable<SecDBFileReader..::..CandleData> GetCandleData(
    uint resolutionSec,
    int skipSeconds = 0
)
Public Function GetCandleData (
    resolutionSec As UInteger,
    Optional skipSeconds As Integer = 0
) As IEnumerable(Of SecDBFileReader..::..CandleData)
Public Function GetCandleData (
    resolutionSec As UInteger,
    Optional skipSeconds As Integer = 0
) As IEnumerable(Of SecDBFileReader..::..CandleData)
public:
IEnumerable<SecDBFileReader..::..CandleData>^ GetCandleData(
    unsigned int resolutionSec,
    int skipSeconds = 0
)
public:
IEnumerable<SecDBFileReader..::..CandleData>^ GetCandleData(
    unsigned int resolutionSec,
    int skipSeconds = 0
)
member GetCandleData :
        resolutionSec : uint32 *
        ?skipSeconds : int
(* Defaults:
        let _skipSeconds = defaultArg skipSeconds 0
*)
-> IEnumerable<SecDBFileReader..::..CandleData>
member GetCandleData :
        resolutionSec : uint32 *
        ?skipSeconds : int
(* Defaults:
        let _skipSeconds = defaultArg skipSeconds 0
*)
-> IEnumerable<SecDBFileReader..::..CandleData>

Parameters

resolutionSec
Type: Online System UInt32
skipSeconds (Optional)
Type: Online System Int32

Return Value

Type: Online IEnumerable SecDBFileReader CandleData
See Also
SecDBFileReader Class
SecDBFileReader Members
GetCandleData Overload
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.GetCandleData Method (SecDBFileReader.CandleHeader, DateTime)

SecDBFileReader GetCandleData Method (SecDBFileReader CandleHeader, DateTime) NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns candle data at the specified resolution starting at the specified start time

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<SecDBFileReader..::..CandleData> GetCandleData(
    SecDBFileReader..::..CandleHeader header,
    DateTime startTimeUTC
)
public IEnumerable<SecDBFileReader..::..CandleData> GetCandleData(
    SecDBFileReader..::..CandleHeader header,
    DateTime startTimeUTC
)
Public Function GetCandleData (
    header As SecDBFileReader..::..CandleHeader,
    startTimeUTC As DateTime
) As IEnumerable(Of SecDBFileReader..::..CandleData)
Public Function GetCandleData (
    header As SecDBFileReader..::..CandleHeader,
    startTimeUTC As DateTime
) As IEnumerable(Of SecDBFileReader..::..CandleData)
public:
IEnumerable<SecDBFileReader..::..CandleData>^ GetCandleData(
    SecDBFileReader..::..CandleHeader header,
    DateTime startTimeUTC
)
public:
IEnumerable<SecDBFileReader..::..CandleData>^ GetCandleData(
    SecDBFileReader..::..CandleHeader header,
    DateTime startTimeUTC
)
member GetCandleData :
        header : SecDBFileReader..::..CandleHeader *
        startTimeUTC : DateTime -> IEnumerable<SecDBFileReader..::..CandleData>
member GetCandleData :
        header : SecDBFileReader..::..CandleHeader *
        startTimeUTC : DateTime -> IEnumerable<SecDBFileReader..::..CandleData>

Parameters

header
Type: NFX.Financial.Market.SecDb SecDBFileReader CandleHeader
startTimeUTC
Type: Online System DateTime

Return Value

Type: Online IEnumerable SecDBFileReader CandleData
See Also
SecDBFileReader Class
SecDBFileReader Members
GetCandleData Overload
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.GetCandleData Method (SecDBFileReader.CandleHeader, Int32)

SecDBFileReader GetCandleData Method (SecDBFileReader CandleHeader, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns candle data at the specified resolution skipping the first specified number of seconds

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<SecDBFileReader..::..CandleData> GetCandleData(
    SecDBFileReader..::..CandleHeader header,
    int skipSeconds = 0
)
public IEnumerable<SecDBFileReader..::..CandleData> GetCandleData(
    SecDBFileReader..::..CandleHeader header,
    int skipSeconds = 0
)
Public Function GetCandleData (
    header As SecDBFileReader..::..CandleHeader,
    Optional skipSeconds As Integer = 0
) As IEnumerable(Of SecDBFileReader..::..CandleData)
Public Function GetCandleData (
    header As SecDBFileReader..::..CandleHeader,
    Optional skipSeconds As Integer = 0
) As IEnumerable(Of SecDBFileReader..::..CandleData)
public:
IEnumerable<SecDBFileReader..::..CandleData>^ GetCandleData(
    SecDBFileReader..::..CandleHeader header,
    int skipSeconds = 0
)
public:
IEnumerable<SecDBFileReader..::..CandleData>^ GetCandleData(
    SecDBFileReader..::..CandleHeader header,
    int skipSeconds = 0
)
member GetCandleData :
        header : SecDBFileReader..::..CandleHeader *
        ?skipSeconds : int
(* Defaults:
        let _skipSeconds = defaultArg skipSeconds 0
*)
-> IEnumerable<SecDBFileReader..::..CandleData>
member GetCandleData :
        header : SecDBFileReader..::..CandleHeader *
        ?skipSeconds : int
(* Defaults:
        let _skipSeconds = defaultArg skipSeconds 0
*)
-> IEnumerable<SecDBFileReader..::..CandleData>

Parameters

header
Type: NFX.Financial.Market.SecDb SecDBFileReader CandleHeader
skipSeconds (Optional)
Type: Online System Int32

Return Value

Type: Online IEnumerable SecDBFileReader CandleData
See Also
SecDBFileReader Class
SecDBFileReader Members
GetCandleData Overload
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.GetCandleDataAsCandleSamples Method

SecDBFileReader GetCandleDataAsCandleSamples Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public method | GetCandleDataAsCandleSamples(UInt32, DateTime) | Tries to find a candle stream returned as CandleSamples with the specified exact resolution starting at the specified start time and returns it, or returns an empty enumerable if resolution is not available
Public method | GetCandleDataAsCandleSamples(UInt32, Int32) | Tries to find a candle stream returned as CandleSamples with the specified exact resolution skipping the specofoed number of seconds and returns it, or returns an empty enumerable if resolution is not available
Public method | GetCandleDataAsCandleSamples(SecDBFileReader CandleHeader, DateTime) | Returns candle data at the specified resolution starting at the specified start time
Public method | GetCandleDataAsCandleSamples(SecDBFileReader CandleHeader, Int32) | Returns candle data at the specified resolution skipping the first specified number of seconds
Back to Top
See Also
SecDBFileReader Class
SecDBFileReader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.GetCandleDataAsCandleSamples Method (UInt32, DateTime)

SecDBFileReader GetCandleDataAsCandleSamples Method (UInt32, DateTime) NFX Class Library

[This is preliminary documentation and is subject to change.]

Tries to find a candle stream returned as CandleSamples with the specified exact resolution starting at the specified start time and returns it, or returns an empty enumerable if resolution is not available

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<CandleSample> GetCandleDataAsCandleSamples(
    uint resolutionSec,
    DateTime startTimeUTC
)
public IEnumerable<CandleSample> GetCandleDataAsCandleSamples(
    uint resolutionSec,
    DateTime startTimeUTC
)
Public Function GetCandleDataAsCandleSamples (
    resolutionSec As UInteger,
    startTimeUTC As DateTime
) As IEnumerable(Of CandleSample)
Public Function GetCandleDataAsCandleSamples (
    resolutionSec As UInteger,
    startTimeUTC As DateTime
) As IEnumerable(Of CandleSample)
public:
IEnumerable<CandleSample^>^ GetCandleDataAsCandleSamples(
    unsigned int resolutionSec,
    DateTime startTimeUTC
)
public:
IEnumerable<CandleSample^>^ GetCandleDataAsCandleSamples(
    unsigned int resolutionSec,
    DateTime startTimeUTC
)
member GetCandleDataAsCandleSamples :
        resolutionSec : uint32 *
        startTimeUTC : DateTime -> IEnumerable<CandleSample>
member GetCandleDataAsCandleSamples :
        resolutionSec : uint32 *
        startTimeUTC : DateTime -> IEnumerable<CandleSample>

Parameters

resolutionSec
Type: Online System UInt32
startTimeUTC
Type: Online System DateTime

Return Value

Type: Online IEnumerable CandleSample
See Also
SecDBFileReader Class
SecDBFileReader Members
GetCandleDataAsCandleSamples Overload
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.GetCandleDataAsCandleSamples Method (UInt32, Int32)

SecDBFileReader GetCandleDataAsCandleSamples Method (UInt32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Tries to find a candle stream returned as CandleSamples with the specified exact resolution skipping the specofoed number of seconds and returns it, or returns an empty enumerable if resolution is not available

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<CandleSample> GetCandleDataAsCandleSamples(
    uint resolutionSec,
    int skipSeconds = 0
)
public IEnumerable<CandleSample> GetCandleDataAsCandleSamples(
    uint resolutionSec,
    int skipSeconds = 0
)
Public Function GetCandleDataAsCandleSamples (
    resolutionSec As UInteger,
    Optional skipSeconds As Integer = 0
) As IEnumerable(Of CandleSample)
Public Function GetCandleDataAsCandleSamples (
    resolutionSec As UInteger,
    Optional skipSeconds As Integer = 0
) As IEnumerable(Of CandleSample)
public:
IEnumerable<CandleSample^>^ GetCandleDataAsCandleSamples(
    unsigned int resolutionSec,
    int skipSeconds = 0
)
public:
IEnumerable<CandleSample^>^ GetCandleDataAsCandleSamples(
    unsigned int resolutionSec,
    int skipSeconds = 0
)
member GetCandleDataAsCandleSamples :
        resolutionSec : uint32 *
        ?skipSeconds : int
(* Defaults:
        let _skipSeconds = defaultArg skipSeconds 0
*)
-> IEnumerable<CandleSample>
member GetCandleDataAsCandleSamples :
        resolutionSec : uint32 *
        ?skipSeconds : int
(* Defaults:
        let _skipSeconds = defaultArg skipSeconds 0
*)
-> IEnumerable<CandleSample>

Parameters

resolutionSec
Type: Online System UInt32
skipSeconds (Optional)
Type: Online System Int32

Return Value

Type: Online IEnumerable CandleSample
See Also
SecDBFileReader Class
SecDBFileReader Members
GetCandleDataAsCandleSamples Overload
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.GetCandleDataAsCandleSamples Method (SecDBFileReader.CandleHeader, DateTime)

SecDBFileReader GetCandleDataAsCandleSamples Method (SecDBFileReader CandleHeader, DateTime) NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns candle data at the specified resolution starting at the specified start time

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<CandleSample> GetCandleDataAsCandleSamples(
    SecDBFileReader..::..CandleHeader header,
    DateTime startTimeUTC
)
public IEnumerable<CandleSample> GetCandleDataAsCandleSamples(
    SecDBFileReader..::..CandleHeader header,
    DateTime startTimeUTC
)
Public Function GetCandleDataAsCandleSamples (
    header As SecDBFileReader..::..CandleHeader,
    startTimeUTC As DateTime
) As IEnumerable(Of CandleSample)
Public Function GetCandleDataAsCandleSamples (
    header As SecDBFileReader..::..CandleHeader,
    startTimeUTC As DateTime
) As IEnumerable(Of CandleSample)
public:
IEnumerable<CandleSample^>^ GetCandleDataAsCandleSamples(
    SecDBFileReader..::..CandleHeader header,
    DateTime startTimeUTC
)
public:
IEnumerable<CandleSample^>^ GetCandleDataAsCandleSamples(
    SecDBFileReader..::..CandleHeader header,
    DateTime startTimeUTC
)
member GetCandleDataAsCandleSamples :
        header : SecDBFileReader..::..CandleHeader *
        startTimeUTC : DateTime -> IEnumerable<CandleSample>
member GetCandleDataAsCandleSamples :
        header : SecDBFileReader..::..CandleHeader *
        startTimeUTC : DateTime -> IEnumerable<CandleSample>

Parameters

header
Type: NFX.Financial.Market.SecDb SecDBFileReader CandleHeader
startTimeUTC
Type: Online System DateTime

Return Value

Type: Online IEnumerable CandleSample
See Also
SecDBFileReader Class
SecDBFileReader Members
GetCandleDataAsCandleSamples Overload
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.GetCandleDataAsCandleSamples Method (SecDBFileReader.CandleHeader, Int32)

SecDBFileReader GetCandleDataAsCandleSamples Method (SecDBFileReader CandleHeader, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns candle data at the specified resolution skipping the first specified number of seconds

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<CandleSample> GetCandleDataAsCandleSamples(
    SecDBFileReader..::..CandleHeader header,
    int skipSeconds = 0
)
public IEnumerable<CandleSample> GetCandleDataAsCandleSamples(
    SecDBFileReader..::..CandleHeader header,
    int skipSeconds = 0
)
Public Function GetCandleDataAsCandleSamples (
    header As SecDBFileReader..::..CandleHeader,
    Optional skipSeconds As Integer = 0
) As IEnumerable(Of CandleSample)
Public Function GetCandleDataAsCandleSamples (
    header As SecDBFileReader..::..CandleHeader,
    Optional skipSeconds As Integer = 0
) As IEnumerable(Of CandleSample)
public:
IEnumerable<CandleSample^>^ GetCandleDataAsCandleSamples(
    SecDBFileReader..::..CandleHeader header,
    int skipSeconds = 0
)
public:
IEnumerable<CandleSample^>^ GetCandleDataAsCandleSamples(
    SecDBFileReader..::..CandleHeader header,
    int skipSeconds = 0
)
member GetCandleDataAsCandleSamples :
        header : SecDBFileReader..::..CandleHeader *
        ?skipSeconds : int
(* Defaults:
        let _skipSeconds = defaultArg skipSeconds 0
*)
-> IEnumerable<CandleSample>
member GetCandleDataAsCandleSamples :
        header : SecDBFileReader..::..CandleHeader *
        ?skipSeconds : int
(* Defaults:
        let _skipSeconds = defaultArg skipSeconds 0
*)
-> IEnumerable<CandleSample>

Parameters

header
Type: NFX.Financial.Market.SecDb SecDBFileReader CandleHeader
skipSeconds (Optional)
Type: Online System Int32

Return Value

Type: Online IEnumerable CandleSample
See Also
SecDBFileReader Class
SecDBFileReader Members
GetCandleDataAsCandleSamples Overload
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.GetCandleHeader Method

SecDBFileReader GetCandleHeader Method NFX Class Library

Tries to find a CandleHeader with the exact specified resolution or unassigned header

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SecDBFileReader..::..CandleHeader GetCandleHeader(
    uint resolutionSec
)
public SecDBFileReader..::..CandleHeader GetCandleHeader(
    uint resolutionSec
)
Public Function GetCandleHeader (
    resolutionSec As UInteger
) As SecDBFileReader..::..CandleHeader
Public Function GetCandleHeader (
    resolutionSec As UInteger
) As SecDBFileReader..::..CandleHeader
public:
SecDBFileReader..::..CandleHeader GetCandleHeader(
    unsigned int resolutionSec
)
public:
SecDBFileReader..::..CandleHeader GetCandleHeader(
    unsigned int resolutionSec
)
member GetCandleHeader :
        resolutionSec : uint32 -> SecDBFileReader..::..CandleHeader
member GetCandleHeader :
        resolutionSec : uint32 -> SecDBFileReader..::..CandleHeader

Parameters

resolutionSec
Type: Online System UInt32

Return Value

Type: SecDBFileReader CandleHeader
See Also
SecDBFileReader Class
SecDBFileReader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.GetStreamData Method

SecDBFileReader GetStreamData Method NFX Class Library

Overload List
 | Name | Description
Public method | GetStreamData(UInt32, DateTime) | Tries to find a candle stream by resolution and returns stream data starting from the specified UTC start time
Public method | GetStreamData(UInt32, Int32) | Tries to find a candle stream by resolution and return stream data skipping the specified seconds count from data start
Public method | GetStreamData(SecDBFileReader CandleHeader, DateTime) | Gets stream data per candle header index starting from the specified UTC start time
Public method | GetStreamData(SecDBFileReader CandleHeader, Int32) | Gets stream data per candle header index skipping the specified seconds count from data start
Back to Top
See Also
SecDBFileReader Class
SecDBFileReader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.GetStreamData Method (UInt32, DateTime)

SecDBFileReader GetStreamData Method (UInt32, DateTime) NFX Class Library

[This is preliminary documentation and is subject to change.]

Tries to find a candle stream by resolution and returns stream data starting from the specified UTC start time

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<SecDBFileReader..::..StreamSample> GetStreamData(
    uint resolutionSec,
    DateTime startTimeUTC
)
public IEnumerable<SecDBFileReader..::..StreamSample> GetStreamData(
    uint resolutionSec,
    DateTime startTimeUTC
)
Public Function GetStreamData (
    resolutionSec As UInteger,
    startTimeUTC As DateTime
) As IEnumerable(Of SecDBFileReader..::..StreamSample)
Public Function GetStreamData (
    resolutionSec As UInteger,
    startTimeUTC As DateTime
) As IEnumerable(Of SecDBFileReader..::..StreamSample)
public:
IEnumerable<SecDBFileReader..::..StreamSample^>^ GetStreamData(
    unsigned int resolutionSec,
    DateTime startTimeUTC
)
public:
IEnumerable<SecDBFileReader..::..StreamSample^>^ GetStreamData(
    unsigned int resolutionSec,
    DateTime startTimeUTC
)
member GetStreamData :
        resolutionSec : uint32 *
        startTimeUTC : DateTime -> IEnumerable<SecDBFileReader..::..StreamSample>
member GetStreamData :
        resolutionSec : uint32 *
        startTimeUTC : DateTime -> IEnumerable<SecDBFileReader..::..StreamSample>

Parameters

resolutionSec
Type: Online System UInt32
startTimeUTC
Type: Online System DateTime

Return Value

Type: Online IEnumerable SecDBFileReader StreamSample
See Also
SecDBFileReader Class
SecDBFileReader Members
GetStreamData Overload
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.GetStreamData Method (UInt32, Int32)

SecDBFileReader GetStreamData Method (UInt32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Tries to find a candle stream by resolution and return stream data skipping the specified seconds count from data start

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<SecDBFileReader..::..StreamSample> GetStreamData(
    uint resolutionSec,
    int skipSeconds = 0
)
public IEnumerable<SecDBFileReader..::..StreamSample> GetStreamData(
    uint resolutionSec,
    int skipSeconds = 0
)
Public Function GetStreamData (
    resolutionSec As UInteger,
    Optional skipSeconds As Integer = 0
) As IEnumerable(Of SecDBFileReader..::..StreamSample)
Public Function GetStreamData (
    resolutionSec As UInteger,
    Optional skipSeconds As Integer = 0
) As IEnumerable(Of SecDBFileReader..::..StreamSample)
public:
IEnumerable<SecDBFileReader..::..StreamSample^>^ GetStreamData(
    unsigned int resolutionSec,
    int skipSeconds = 0
)
public:
IEnumerable<SecDBFileReader..::..StreamSample^>^ GetStreamData(
    unsigned int resolutionSec,
    int skipSeconds = 0
)
member GetStreamData :
        resolutionSec : uint32 *
        ?skipSeconds : int
(* Defaults:
        let _skipSeconds = defaultArg skipSeconds 0
*)
-> IEnumerable<SecDBFileReader..::..StreamSample>
member GetStreamData :
        resolutionSec : uint32 *
        ?skipSeconds : int
(* Defaults:
        let _skipSeconds = defaultArg skipSeconds 0
*)
-> IEnumerable<SecDBFileReader..::..StreamSample>

Parameters

resolutionSec
Type: Online System UInt32
skipSeconds (Optional)
Type: Online System Int32

Return Value

Type: Online IEnumerable SecDBFileReader StreamSample
See Also
SecDBFileReader Class
SecDBFileReader Members
GetStreamData Overload
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.GetStreamData Method (SecDBFileReader.CandleHeader, DateTime)

SecDBFileReader GetStreamData Method (SecDBFileReader CandleHeader, DateTime) NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets stream data per candle header index starting from the specified UTC start time

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<SecDBFileReader..::..StreamSample> GetStreamData(
    SecDBFileReader..::..CandleHeader header,
    DateTime startTimeUTC
)
public IEnumerable<SecDBFileReader..::..StreamSample> GetStreamData(
    SecDBFileReader..::..CandleHeader header,
    DateTime startTimeUTC
)
Public Function GetStreamData (
    header As SecDBFileReader..::..CandleHeader,
    startTimeUTC As DateTime
) As IEnumerable(Of SecDBFileReader..::..StreamSample)
Public Function GetStreamData (
    header As SecDBFileReader..::..CandleHeader,
    startTimeUTC As DateTime
) As IEnumerable(Of SecDBFileReader..::..StreamSample)
public:
IEnumerable<SecDBFileReader..::..StreamSample^>^ GetStreamData(
    SecDBFileReader..::..CandleHeader header,
    DateTime startTimeUTC
)
public:
IEnumerable<SecDBFileReader..::..StreamSample^>^ GetStreamData(
    SecDBFileReader..::..CandleHeader header,
    DateTime startTimeUTC
)
member GetStreamData :
        header : SecDBFileReader..::..CandleHeader *
        startTimeUTC : DateTime -> IEnumerable<SecDBFileReader..::..StreamSample>
member GetStreamData :
        header : SecDBFileReader..::..CandleHeader *
        startTimeUTC : DateTime -> IEnumerable<SecDBFileReader..::..StreamSample>

Parameters

header
Type: NFX.Financial.Market.SecDb SecDBFileReader CandleHeader
startTimeUTC
Type: Online System DateTime

Return Value

Type: Online IEnumerable SecDBFileReader StreamSample
See Also
SecDBFileReader Class
SecDBFileReader Members
GetStreamData Overload
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.GetStreamData Method (SecDBFileReader.CandleHeader, Int32)

SecDBFileReader GetStreamData Method (SecDBFileReader CandleHeader, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets stream data per candle header index skipping the specified seconds count from data start

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<SecDBFileReader..::..StreamSample> GetStreamData(
    SecDBFileReader..::..CandleHeader header,
    int skipSeconds = 0
)
public IEnumerable<SecDBFileReader..::..StreamSample> GetStreamData(
    SecDBFileReader..::..CandleHeader header,
    int skipSeconds = 0
)
Public Function GetStreamData (
    header As SecDBFileReader..::..CandleHeader,
    Optional skipSeconds As Integer = 0
) As IEnumerable(Of SecDBFileReader..::..StreamSample)
Public Function GetStreamData (
    header As SecDBFileReader..::..CandleHeader,
    Optional skipSeconds As Integer = 0
) As IEnumerable(Of SecDBFileReader..::..StreamSample)
public:
IEnumerable<SecDBFileReader..::..StreamSample^>^ GetStreamData(
    SecDBFileReader..::..CandleHeader header,
    int skipSeconds = 0
)
public:
IEnumerable<SecDBFileReader..::..StreamSample^>^ GetStreamData(
    SecDBFileReader..::..CandleHeader header,
    int skipSeconds = 0
)
member GetStreamData :
        header : SecDBFileReader..::..CandleHeader *
        ?skipSeconds : int
(* Defaults:
        let _skipSeconds = defaultArg skipSeconds 0
*)
-> IEnumerable<SecDBFileReader..::..StreamSample>
member GetStreamData :
        header : SecDBFileReader..::..CandleHeader *
        ?skipSeconds : int
(* Defaults:
        let _skipSeconds = defaultArg skipSeconds 0
*)
-> IEnumerable<SecDBFileReader..::..StreamSample>

Parameters

header
Type: NFX.Financial.Market.SecDb SecDBFileReader CandleHeader
skipSeconds (Optional)
Type: Online System Int32

Return Value

Type: Online IEnumerable SecDBFileReader StreamSample
See Also
SecDBFileReader Class
SecDBFileReader Members
GetStreamData Overload
NFX.Financial.Market.SecDb Namespace


SecDBFileReader Properties

SecDBFileReader Properties NFX Class Library

The SecDBFileReader type exposes the following members.
Properties
 | Name | Description
Public property | CandlesMetadata | Returns metadata for candles in the file - collection of candle headers
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Headers | File headers dictionary, including the required ones
Public property | StreamsCompressionType |
Public property | StreamsDataOffset |
Public property | StreamsMetas |
Public property | SystemHeader | Returns the required/system portion of the file header
Back to Top
See Also
SecDBFileReader Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandlesMetadata Property

SecDBFileReader CandlesMetadata Property NFX Class Library

Returns metadata for candles in the file - collection of candle headers

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SecDBFileReader..::..CandlesMeta CandlesMetadata { get; }
public SecDBFileReader..::..CandlesMeta CandlesMetadata { get; }
Public ReadOnly Property CandlesMetadata As SecDBFileReader..::..CandlesMeta
    Get
Public ReadOnly Property CandlesMetadata As SecDBFileReader..::..CandlesMeta
    Get
public:
property SecDBFileReader..::..CandlesMeta CandlesMetadata {
    SecDBFileReader..::..CandlesMeta get ();
}
public:
property SecDBFileReader..::..CandlesMeta CandlesMetadata {
    SecDBFileReader..::..CandlesMeta get ();
}
member CandlesMetadata : SecDBFileReader..::..CandlesMeta with get
member CandlesMetadata : SecDBFileReader..::..CandlesMeta with get

Property Value

Type: SecDBFileReader CandlesMeta
See Also
SecDBFileReader Class
SecDBFileReader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.Headers Property

SecDBFileReader Headers Property NFX Class Library

File headers dictionary, including the required ones

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IReadOnlyDictionary<string, string> Headers { get; }
public IReadOnlyDictionary<string, string> Headers { get; }
Public ReadOnly Property Headers As IReadOnlyDictionary(Of String, String)
    Get
Public ReadOnly Property Headers As IReadOnlyDictionary(Of String, String)
    Get
public:
property IReadOnlyDictionary<String^, String^>^ Headers {
    IReadOnlyDictionary<String^, String^>^ get ();
}
public:
property IReadOnlyDictionary<String^, String^>^ Headers {
    IReadOnlyDictionary<String^, String^>^ get ();
}
member Headers : IReadOnlyDictionary<string, string> with get
member Headers : IReadOnlyDictionary<string, string> with get

Property Value

Type: IReadOnlyDictionary Online String, Online String
See Also
SecDBFileReader Class
SecDBFileReader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.StreamsCompressionType Property

SecDBFileReader StreamsCompressionType Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SecDBFileReader..::..CompressionType StreamsCompressionType { get; }
public SecDBFileReader..::..CompressionType StreamsCompressionType { get; }
Public ReadOnly Property StreamsCompressionType As SecDBFileReader..::..CompressionType
    Get
Public ReadOnly Property StreamsCompressionType As SecDBFileReader..::..CompressionType
    Get
public:
property SecDBFileReader..::..CompressionType StreamsCompressionType {
    SecDBFileReader..::..CompressionType get ();
}
public:
property SecDBFileReader..::..CompressionType StreamsCompressionType {
    SecDBFileReader..::..CompressionType get ();
}
member StreamsCompressionType : SecDBFileReader..::..CompressionType with get
member StreamsCompressionType : SecDBFileReader..::..CompressionType with get

Property Value

Type: SecDBFileReader CompressionType
See Also
SecDBFileReader Class
SecDBFileReader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.StreamsDataOffset Property

SecDBFileReader StreamsDataOffset Property NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint StreamsDataOffset { get; }
public uint StreamsDataOffset { get; }
Public ReadOnly Property StreamsDataOffset As UInteger
    Get
Public ReadOnly Property StreamsDataOffset As UInteger
    Get
public:
property unsigned int StreamsDataOffset {
    unsigned int get ();
}
public:
property unsigned int StreamsDataOffset {
    unsigned int get ();
}
member StreamsDataOffset : uint32 with get
member StreamsDataOffset : uint32 with get

Property Value

Type: Online UInt32
See Also
SecDBFileReader Class
SecDBFileReader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.StreamsMetas Property

SecDBFileReader StreamsMetas Property NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SecDBFileReader..::..StreamMeta[] StreamsMetas { get; }
public SecDBFileReader..::..StreamMeta[] StreamsMetas { get; }
Public ReadOnly Property StreamsMetas As SecDBFileReader..::..StreamMeta()
    Get
Public ReadOnly Property StreamsMetas As SecDBFileReader..::..StreamMeta()
    Get
public:
property array<SecDBFileReader..::..StreamMeta>^ StreamsMetas {
    array<SecDBFileReader..::..StreamMeta>^ get ();
}
public:
property array<SecDBFileReader..::..StreamMeta>^ StreamsMetas {
    array<SecDBFileReader..::..StreamMeta>^ get ();
}
member StreamsMetas : SecDBFileReader..::..StreamMeta[] with get
member StreamsMetas : SecDBFileReader..::..StreamMeta[] with get

Property Value

Type: SecDBFileReader StreamMeta
See Also
SecDBFileReader Class
SecDBFileReader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.SystemHeader Property

SecDBFileReader SystemHeader Property NFX Class Library

Returns the required/system portion of the file header

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SecDBFileReader..::..FileRequiredHeader SystemHeader { get; }
public SecDBFileReader..::..FileRequiredHeader SystemHeader { get; }
Public ReadOnly Property SystemHeader As SecDBFileReader..::..FileRequiredHeader
    Get
Public ReadOnly Property SystemHeader As SecDBFileReader..::..FileRequiredHeader
    Get
public:
property SecDBFileReader..::..FileRequiredHeader SystemHeader {
    SecDBFileReader..::..FileRequiredHeader get ();
}
public:
property SecDBFileReader..::..FileRequiredHeader SystemHeader {
    SecDBFileReader..::..FileRequiredHeader get ();
}
member SystemHeader : SecDBFileReader..::..FileRequiredHeader with get
member SystemHeader : SecDBFileReader..::..FileRequiredHeader with get

Property Value

Type: SecDBFileReader FileRequiredHeader
See Also
SecDBFileReader Class
SecDBFileReader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleData Structure

SecDBFileReader CandleData Structure NFX Class Library

Represents OHLC sample from the file

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct CandleData
public struct CandleData
Public Structure CandleData
Public Structure CandleData
public value class CandleData
public value class CandleData
[<SealedAttribute>]
type CandleData =  struct end
[<SealedAttribute>]
type CandleData =  struct end
See Also
SecDBFileReader CandleData Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleData Members

SecDBFileReader CandleData Members NFX Class Library

The SecDBFileReader CandleData type exposes the following members.
Constructors
 | Name | Description
Protected method | SecDBFileReader CandleData | Initializes a new instance of the SecDBFileReader CandleData class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ToCandleSample |
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | BuyVolume |
 | BYTE_SIZE |
Public field | CloseSteps |
Public field | File | File that the header is from
Public field | FirstStreamOffset |
Public field | HighSteps |
Public field | LowSteps |
Public field | OpenSteps |
Public field | SampleNumber |
Public field | SellVolume |
Public field | TimeStamp |
Back to Top
Properties
 | Name | Description
Public property | Close |
Public property | High |
Public property | IsAssigned | True to indicate that struct instance is assigned meaningful data
Public property | Low |
Public property | Open |
Back to Top
See Also
SecDBFileReader CandleData Structure
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleData Constructor

SecDBFileReader CandleData Constructor NFX Class Library

Initializes a new instance of the SecDBFileReader CandleData class

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CandleData(
    SecDBFileReader file,
    int sampleNumber,
    DateTime timestamp,
    Stream stream
)
internal CandleData(
    SecDBFileReader file,
    int sampleNumber,
    DateTime timestamp,
    Stream stream
)
Friend Sub New (
    file As SecDBFileReader,
    sampleNumber As Integer,
    timestamp As DateTime,
    stream As Stream
)
Friend Sub New (
    file As SecDBFileReader,
    sampleNumber As Integer,
    timestamp As DateTime,
    stream As Stream
)
internal:
CandleData(
    SecDBFileReader^ file,
    int sampleNumber,
    DateTime timestamp,
    Stream^ stream
)
internal:
CandleData(
    SecDBFileReader^ file,
    int sampleNumber,
    DateTime timestamp,
    Stream^ stream
)
new :
        file : SecDBFileReader *
        sampleNumber : int *
        timestamp : DateTime *
        stream : Stream -> CandleData
new :
        file : SecDBFileReader *
        sampleNumber : int *
        timestamp : DateTime *
        stream : Stream -> CandleData

Parameters

file
Type: NFX.Financial.Market.SecDb SecDBFileReader
sampleNumber
Type: Online System Int32
timestamp
Type: Online System DateTime
stream
Type: Online System.IO Stream
See Also
SecDBFileReader CandleData Structure
SecDBFileReader CandleData Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleData Fields

SecDBFileReader CandleData Fields NFX Class Library

The SecDBFileReader CandleData type exposes the following members.
Fields
 | Name | Description
Public field | BuyVolume |
 | BYTE_SIZE |
Public field | CloseSteps |
Public field | File | File that the header is from
Public field | FirstStreamOffset |
Public field | HighSteps |
Public field | LowSteps |
Public field | OpenSteps |
Public field | SampleNumber |
Public field | SellVolume |
Public field | TimeStamp |
Back to Top
See Also
SecDBFileReader CandleData Structure
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleData.BuyVolume Field

SecDBFileReader CandleData BuyVolume Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int BuyVolume
public readonly int BuyVolume
Public ReadOnly BuyVolume As Integer
Public ReadOnly BuyVolume As Integer
public:
initonly int BuyVolume
public:
initonly int BuyVolume
val BuyVolume: int
val BuyVolume: int

Field Value

Type: Online Int32
See Also
SecDBFileReader CandleData Structure
SecDBFileReader CandleData Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleData.BYTE_SIZE Field

SecDBFileReader CandleData BYTE_SIZE Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int BYTE_SIZE
public const int BYTE_SIZE
Public Const BYTE_SIZE As Integer
Public Const BYTE_SIZE As Integer
public:
literal int BYTE_SIZE
public:
literal int BYTE_SIZE
static val mutable BYTE_SIZE: int
static val mutable BYTE_SIZE: int

Field Value

Type: Online Int32
See Also
SecDBFileReader CandleData Structure
SecDBFileReader CandleData Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleData.CloseSteps Field

SecDBFileReader CandleData CloseSteps Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int CloseSteps
public readonly int CloseSteps
Public ReadOnly CloseSteps As Integer
Public ReadOnly CloseSteps As Integer
public:
initonly int CloseSteps
public:
initonly int CloseSteps
val CloseSteps: int
val CloseSteps: int

Field Value

Type: Online Int32
See Also
SecDBFileReader CandleData Structure
SecDBFileReader CandleData Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleData.File Field

SecDBFileReader CandleData File Field NFX Class Library

File that the header is from

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SecDBFileReader File
public readonly SecDBFileReader File
Public ReadOnly File As SecDBFileReader
Public ReadOnly File As SecDBFileReader
public:
initonly SecDBFileReader^ File
public:
initonly SecDBFileReader^ File
val File: SecDBFileReader
val File: SecDBFileReader

Field Value

Type: SecDBFileReader
See Also
SecDBFileReader CandleData Structure
SecDBFileReader CandleData Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleData.FirstStreamOffset Field

SecDBFileReader CandleData FirstStreamOffset Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ulong FirstStreamOffset
public readonly ulong FirstStreamOffset
Public ReadOnly FirstStreamOffset As ULong
Public ReadOnly FirstStreamOffset As ULong
public:
initonly unsigned long long FirstStreamOffset
public:
initonly unsigned long long FirstStreamOffset
val FirstStreamOffset: uint64
val FirstStreamOffset: uint64

Field Value

Type: Online UInt64
See Also
SecDBFileReader CandleData Structure
SecDBFileReader CandleData Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleData.HighSteps Field

SecDBFileReader CandleData HighSteps Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int HighSteps
public readonly int HighSteps
Public ReadOnly HighSteps As Integer
Public ReadOnly HighSteps As Integer
public:
initonly int HighSteps
public:
initonly int HighSteps
val HighSteps: int
val HighSteps: int

Field Value

Type: Online Int32
See Also
SecDBFileReader CandleData Structure
SecDBFileReader CandleData Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleData.LowSteps Field

SecDBFileReader CandleData LowSteps Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int LowSteps
public readonly int LowSteps
Public ReadOnly LowSteps As Integer
Public ReadOnly LowSteps As Integer
public:
initonly int LowSteps
public:
initonly int LowSteps
val LowSteps: int
val LowSteps: int

Field Value

Type: Online Int32
See Also
SecDBFileReader CandleData Structure
SecDBFileReader CandleData Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleData.OpenSteps Field

SecDBFileReader CandleData OpenSteps Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int OpenSteps
public readonly int OpenSteps
Public ReadOnly OpenSteps As Integer
Public ReadOnly OpenSteps As Integer
public:
initonly int OpenSteps
public:
initonly int OpenSteps
val OpenSteps: int
val OpenSteps: int

Field Value

Type: Online Int32
See Also
SecDBFileReader CandleData Structure
SecDBFileReader CandleData Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleData.SampleNumber Field

SecDBFileReader CandleData SampleNumber Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int SampleNumber
public readonly int SampleNumber
Public ReadOnly SampleNumber As Integer
Public ReadOnly SampleNumber As Integer
public:
initonly int SampleNumber
public:
initonly int SampleNumber
val SampleNumber: int
val SampleNumber: int

Field Value

Type: Online Int32
See Also
SecDBFileReader CandleData Structure
SecDBFileReader CandleData Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleData.SellVolume Field

SecDBFileReader CandleData SellVolume Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int SellVolume
public readonly int SellVolume
Public ReadOnly SellVolume As Integer
Public ReadOnly SellVolume As Integer
public:
initonly int SellVolume
public:
initonly int SellVolume
val SellVolume: int
val SellVolume: int

Field Value

Type: Online Int32
See Also
SecDBFileReader CandleData Structure
SecDBFileReader CandleData Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleData.TimeStamp Field

SecDBFileReader CandleData TimeStamp Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly DateTime TimeStamp
public readonly DateTime TimeStamp
Public ReadOnly TimeStamp As DateTime
Public ReadOnly TimeStamp As DateTime
public:
initonly DateTime TimeStamp
public:
initonly DateTime TimeStamp
val TimeStamp: DateTime
val TimeStamp: DateTime

Field Value

Type: Online DateTime
See Also
SecDBFileReader CandleData Structure
SecDBFileReader CandleData Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleData Methods

SecDBFileReader CandleData Methods NFX Class Library

The SecDBFileReader CandleData type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ToCandleSample |
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SecDBFileReader CandleData Structure
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleData.ToCandleSample Method

SecDBFileReader CandleData ToCandleSample Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CandleSample ToCandleSample()
internal CandleSample ToCandleSample()
Friend Function ToCandleSample As CandleSample
Friend Function ToCandleSample As CandleSample
internal:
CandleSample^ ToCandleSample()
internal:
CandleSample^ ToCandleSample()
internal member ToCandleSample : unit -> CandleSample
internal member ToCandleSample : unit -> CandleSample

Return Value

Type: CandleSample
See Also
SecDBFileReader CandleData Structure
SecDBFileReader CandleData Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleData Properties

SecDBFileReader CandleData Properties NFX Class Library

The SecDBFileReader CandleData type exposes the following members.
Properties
 | Name | Description
Public property | Close |
Public property | High |
Public property | IsAssigned | True to indicate that struct instance is assigned meaningful data
Public property | Low |
Public property | Open |
Back to Top
See Also
SecDBFileReader CandleData Structure
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleData.Close Property

SecDBFileReader CandleData Close Property NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float Close { get; }
public float Close { get; }
Public ReadOnly Property Close As Single
    Get
Public ReadOnly Property Close As Single
    Get
public:
property float Close {
    float get ();
}
public:
property float Close {
    float get ();
}
member Close : float32 with get
member Close : float32 with get

Property Value

Type: Online Single
See Also
SecDBFileReader CandleData Structure
SecDBFileReader CandleData Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleData.High Property

SecDBFileReader CandleData High Property NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float High { get; }
public float High { get; }
Public ReadOnly Property High As Single
    Get
Public ReadOnly Property High As Single
    Get
public:
property float High {
    float get ();
}
public:
property float High {
    float get ();
}
member High : float32 with get
member High : float32 with get

Property Value

Type: Online Single
See Also
SecDBFileReader CandleData Structure
SecDBFileReader CandleData Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleData.IsAssigned Property

SecDBFileReader CandleData IsAssigned Property NFX Class Library

[This is preliminary documentation and is subject to change.]

True to indicate that struct instance is assigned meaningful data

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsAssigned { get; }
public bool IsAssigned { get; }
Public ReadOnly Property IsAssigned As Boolean
    Get
Public ReadOnly Property IsAssigned As Boolean
    Get
public:
property bool IsAssigned {
    bool get ();
}
public:
property bool IsAssigned {
    bool get ();
}
member IsAssigned : bool with get
member IsAssigned : bool with get

Property Value

Type: Online Boolean
See Also
SecDBFileReader CandleData Structure
SecDBFileReader CandleData Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleData.Low Property

SecDBFileReader CandleData Low Property NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float Low { get; }
public float Low { get; }
Public ReadOnly Property Low As Single
    Get
Public ReadOnly Property Low As Single
    Get
public:
property float Low {
    float get ();
}
public:
property float Low {
    float get ();
}
member Low : float32 with get
member Low : float32 with get

Property Value

Type: Online Single
See Also
SecDBFileReader CandleData Structure
SecDBFileReader CandleData Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleData.Open Property

SecDBFileReader CandleData Open Property NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float Open { get; }
public float Open { get; }
Public ReadOnly Property Open As Single
    Get
Public ReadOnly Property Open As Single
    Get
public:
property float Open {
    float get ();
}
public:
property float Open {
    float get ();
}
member Open : float32 with get
member Open : float32 with get

Property Value

Type: Online Single
See Also
SecDBFileReader CandleData Structure
SecDBFileReader CandleData Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleHeader Structure

SecDBFileReader CandleHeader Structure NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct CandleHeader
public struct CandleHeader
Public Structure CandleHeader
Public Structure CandleHeader
public value class CandleHeader
public value class CandleHeader
[<SealedAttribute>]
type CandleHeader =  struct end
[<SealedAttribute>]
type CandleHeader =  struct end
See Also
SecDBFileReader CandleHeader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleHeader Members

SecDBFileReader CandleHeader Members NFX Class Library

The SecDBFileReader CandleHeader type exposes the following members.
Constructors
 | Name | Description
Protected method | SecDBFileReader CandleHeader | Initializes a new instance of the SecDBFileReader CandleHeader class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | GetSkipSecondsUntil | Returns how many seconds need to be skipped to arrive at the particular date. The negative return means that the supplied data is BEFORE the data start
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | CandleCount | Total candle samples at DataOffset
Public field | DataOffset | Where candle data starts
Public field | File | File that the header is from
Public field | ResolutionSec | Size of candle in seconds
Public field | StartTime | Start time as calculated from StartTimeMidnightOffsetSec
Public field | StartTimeMidnightOffsetSec | Offset since midnight in seconds
Back to Top
Properties
 | Name | Description
Public property | IsAssigned | True to indicate that struct instance is assigned meaningful data
Back to Top
See Also
SecDBFileReader CandleHeader Structure
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleHeader Constructor

SecDBFileReader CandleHeader Constructor NFX Class Library

Initializes a new instance of the SecDBFileReader CandleHeader class

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CandleHeader(
    SecDBFileReader file,
    ushort resolutionSec,
    uint startTimeOffsetSec,
    DateTime startTimeDt,
    uint count,
    uint offset
)
internal CandleHeader(
    SecDBFileReader file,
    ushort resolutionSec,
    uint startTimeOffsetSec,
    DateTime startTimeDt,
    uint count,
    uint offset
)
Friend Sub New (
    file As SecDBFileReader,
    resolutionSec As UShort,
    startTimeOffsetSec As UInteger,
    startTimeDt As DateTime,
    count As UInteger,
    offset As UInteger
)
Friend Sub New (
    file As SecDBFileReader,
    resolutionSec As UShort,
    startTimeOffsetSec As UInteger,
    startTimeDt As DateTime,
    count As UInteger,
    offset As UInteger
)
internal:
CandleHeader(
    SecDBFileReader^ file,
    unsigned short resolutionSec,
    unsigned int startTimeOffsetSec,
    DateTime startTimeDt,
    unsigned int count,
    unsigned int offset
)
internal:
CandleHeader(
    SecDBFileReader^ file,
    unsigned short resolutionSec,
    unsigned int startTimeOffsetSec,
    DateTime startTimeDt,
    unsigned int count,
    unsigned int offset
)
new :
        file : SecDBFileReader *
        resolutionSec : uint16 *
        startTimeOffsetSec : uint32 *
        startTimeDt : DateTime *
        count : uint32 *
        offset : uint32 -> CandleHeader
new :
        file : SecDBFileReader *
        resolutionSec : uint16 *
        startTimeOffsetSec : uint32 *
        startTimeDt : DateTime *
        count : uint32 *
        offset : uint32 -> CandleHeader

Parameters

file
Type: NFX.Financial.Market.SecDb SecDBFileReader
resolutionSec
Type: Online System UInt16
startTimeOffsetSec
Type: Online System UInt32
startTimeDt
Type: Online System DateTime
count
Type: Online System UInt32
offset
Type: Online System UInt32
See Also
SecDBFileReader CandleHeader Structure
SecDBFileReader CandleHeader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleHeader Fields

SecDBFileReader CandleHeader Fields NFX Class Library

The SecDBFileReader CandleHeader type exposes the following members.
Fields
 | Name | Description
Public field | CandleCount | Total candle samples at DataOffset
Public field | DataOffset | Where candle data starts
Public field | File | File that the header is from
Public field | ResolutionSec | Size of candle in seconds
Public field | StartTime | Start time as calculated from StartTimeMidnightOffsetSec
Public field | StartTimeMidnightOffsetSec | Offset since midnight in seconds
Back to Top
See Also
SecDBFileReader CandleHeader Structure
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleHeader.CandleCount Field

SecDBFileReader CandleHeader CandleCount Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Total candle samples at DataOffset

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly uint CandleCount
public readonly uint CandleCount
Public ReadOnly CandleCount As UInteger
Public ReadOnly CandleCount As UInteger
public:
initonly unsigned int CandleCount
public:
initonly unsigned int CandleCount
val CandleCount: uint32
val CandleCount: uint32

Field Value

Type: Online UInt32
See Also
SecDBFileReader CandleHeader Structure
SecDBFileReader CandleHeader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleHeader.DataOffset Field

SecDBFileReader CandleHeader DataOffset Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Where candle data starts

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly uint DataOffset
public readonly uint DataOffset
Public ReadOnly DataOffset As UInteger
Public ReadOnly DataOffset As UInteger
public:
initonly unsigned int DataOffset
public:
initonly unsigned int DataOffset
val DataOffset: uint32
val DataOffset: uint32

Field Value

Type: Online UInt32
See Also
SecDBFileReader CandleHeader Structure
SecDBFileReader CandleHeader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleHeader.File Field

SecDBFileReader CandleHeader File Field NFX Class Library

File that the header is from

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SecDBFileReader File
public readonly SecDBFileReader File
Public ReadOnly File As SecDBFileReader
Public ReadOnly File As SecDBFileReader
public:
initonly SecDBFileReader^ File
public:
initonly SecDBFileReader^ File
val File: SecDBFileReader
val File: SecDBFileReader

Field Value

Type: SecDBFileReader
See Also
SecDBFileReader CandleHeader Structure
SecDBFileReader CandleHeader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleHeader.ResolutionSec Field

SecDBFileReader CandleHeader ResolutionSec Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Size of candle in seconds

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ushort ResolutionSec
public readonly ushort ResolutionSec
Public ReadOnly ResolutionSec As UShort
Public ReadOnly ResolutionSec As UShort
public:
initonly unsigned short ResolutionSec
public:
initonly unsigned short ResolutionSec
val ResolutionSec: uint16
val ResolutionSec: uint16

Field Value

Type: Online UInt16
See Also
SecDBFileReader CandleHeader Structure
SecDBFileReader CandleHeader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleHeader.StartTime Field

SecDBFileReader CandleHeader StartTime Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Start time as calculated from StartTimeMidnightOffsetSec

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly DateTime StartTime
public readonly DateTime StartTime
Public ReadOnly StartTime As DateTime
Public ReadOnly StartTime As DateTime
public:
initonly DateTime StartTime
public:
initonly DateTime StartTime
val StartTime: DateTime
val StartTime: DateTime

Field Value

Type: Online DateTime
See Also
SecDBFileReader CandleHeader Structure
SecDBFileReader CandleHeader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleHeader.StartTimeMidnightOffsetSec Field

SecDBFileReader CandleHeader StartTimeMidnightOffsetSec Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Offset since midnight in seconds

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly uint StartTimeMidnightOffsetSec
public readonly uint StartTimeMidnightOffsetSec
Public ReadOnly StartTimeMidnightOffsetSec As UInteger
Public ReadOnly StartTimeMidnightOffsetSec As UInteger
public:
initonly unsigned int StartTimeMidnightOffsetSec
public:
initonly unsigned int StartTimeMidnightOffsetSec
val StartTimeMidnightOffsetSec: uint32
val StartTimeMidnightOffsetSec: uint32

Field Value

Type: Online UInt32
See Also
SecDBFileReader CandleHeader Structure
SecDBFileReader CandleHeader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleHeader Methods

SecDBFileReader CandleHeader Methods NFX Class Library

The SecDBFileReader CandleHeader type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | GetSkipSecondsUntil | Returns how many seconds need to be skipped to arrive at the particular date. The negative return means that the supplied data is BEFORE the data start
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SecDBFileReader CandleHeader Structure
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleHeader.GetSkipSecondsUntil Method

SecDBFileReader CandleHeader GetSkipSecondsUntil Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns how many seconds need to be skipped to arrive at the particular date. The negative return means that the supplied data is BEFORE the data start

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int GetSkipSecondsUntil(
    DateTime utcDate
)
public int GetSkipSecondsUntil(
    DateTime utcDate
)
Public Function GetSkipSecondsUntil (
    utcDate As DateTime
) As Integer
Public Function GetSkipSecondsUntil (
    utcDate As DateTime
) As Integer
public:
int GetSkipSecondsUntil(
    DateTime utcDate
)
public:
int GetSkipSecondsUntil(
    DateTime utcDate
)
member GetSkipSecondsUntil :
        utcDate : DateTime -> int
member GetSkipSecondsUntil :
        utcDate : DateTime -> int

Parameters

utcDate
Type: Online System DateTime

Return Value

Type: Online Int32
See Also
SecDBFileReader CandleHeader Structure
SecDBFileReader CandleHeader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleHeader Properties

SecDBFileReader CandleHeader Properties NFX Class Library

The SecDBFileReader CandleHeader type exposes the following members.
Properties
 | Name | Description
Public property | IsAssigned | True to indicate that struct instance is assigned meaningful data
Back to Top
See Also
SecDBFileReader CandleHeader Structure
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandleHeader.IsAssigned Property

SecDBFileReader CandleHeader IsAssigned Property NFX Class Library

[This is preliminary documentation and is subject to change.]

True to indicate that struct instance is assigned meaningful data

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsAssigned { get; }
public bool IsAssigned { get; }
Public ReadOnly Property IsAssigned As Boolean
    Get
Public ReadOnly Property IsAssigned As Boolean
    Get
public:
property bool IsAssigned {
    bool get ();
}
public:
property bool IsAssigned {
    bool get ();
}
member IsAssigned : bool with get
member IsAssigned : bool with get

Property Value

Type: Online Boolean
See Also
SecDBFileReader CandleHeader Structure
SecDBFileReader CandleHeader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandlesMeta Structure

SecDBFileReader CandlesMeta Structure NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct CandlesMeta
public struct CandlesMeta
Public Structure CandlesMeta
Public Structure CandlesMeta
public value class CandlesMeta
public value class CandlesMeta
[<SealedAttribute>]
type CandlesMeta =  struct end
[<SealedAttribute>]
type CandlesMeta =  struct end
See Also
SecDBFileReader CandlesMeta Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandlesMeta Members

SecDBFileReader CandlesMeta Members NFX Class Library

The SecDBFileReader CandlesMeta type exposes the following members.
Constructors
 | Name | Description
Protected method | SecDBFileReader CandlesMeta | Initializes a new instance of the SecDBFileReader CandlesMeta class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Candles |
Public field | File |
Back to Top
Properties
 | Name | Description
Public property | Resolutions | Returns resolution available in the file
Back to Top
See Also
SecDBFileReader CandlesMeta Structure
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandlesMeta Constructor

SecDBFileReader CandlesMeta Constructor NFX Class Library

Initializes a new instance of the SecDBFileReader CandlesMeta class

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CandlesMeta(
    SecDBFileReader file,
    SecDBFileReader..::..CandleHeader[] candles
)
internal CandlesMeta(
    SecDBFileReader file,
    SecDBFileReader..::..CandleHeader[] candles
)
Friend Sub New (
    file As SecDBFileReader,
    candles As SecDBFileReader..::..CandleHeader()
)
Friend Sub New (
    file As SecDBFileReader,
    candles As SecDBFileReader..::..CandleHeader()
)
internal:
CandlesMeta(
    SecDBFileReader^ file,
    array<SecDBFileReader..::..CandleHeader>^ candles
)
internal:
CandlesMeta(
    SecDBFileReader^ file,
    array<SecDBFileReader..::..CandleHeader>^ candles
)
new :
        file : SecDBFileReader *
        candles : SecDBFileReader..::..CandleHeader[] -> CandlesMeta
new :
        file : SecDBFileReader *
        candles : SecDBFileReader..::..CandleHeader[] -> CandlesMeta

Parameters

file
Type: NFX.Financial.Market.SecDb SecDBFileReader
candles
Type: NFX.Financial.Market.SecDb SecDBFileReader CandleHeader
See Also
SecDBFileReader CandlesMeta Structure
SecDBFileReader CandlesMeta Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandlesMeta Fields

SecDBFileReader CandlesMeta Fields NFX Class Library

The SecDBFileReader CandlesMeta type exposes the following members.
Fields
 | Name | Description
Public field | Candles |
Public field | File |
Back to Top
See Also
SecDBFileReader CandlesMeta Structure
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandlesMeta.Candles Field

SecDBFileReader CandlesMeta Candles Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SecDBFileReader..::..CandleHeader[] Candles
public readonly SecDBFileReader..::..CandleHeader[] Candles
Public ReadOnly Candles As SecDBFileReader..::..CandleHeader()
Public ReadOnly Candles As SecDBFileReader..::..CandleHeader()
public:
initonly array<SecDBFileReader..::..CandleHeader>^ Candles
public:
initonly array<SecDBFileReader..::..CandleHeader>^ Candles
val Candles: SecDBFileReader..::..CandleHeader[]
val Candles: SecDBFileReader..::..CandleHeader[]

Field Value

Type: SecDBFileReader CandleHeader
See Also
SecDBFileReader CandlesMeta Structure
SecDBFileReader CandlesMeta Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandlesMeta.File Field

SecDBFileReader CandlesMeta File Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SecDBFileReader File
public readonly SecDBFileReader File
Public ReadOnly File As SecDBFileReader
Public ReadOnly File As SecDBFileReader
public:
initonly SecDBFileReader^ File
public:
initonly SecDBFileReader^ File
val File: SecDBFileReader
val File: SecDBFileReader

Field Value

Type: SecDBFileReader
See Also
SecDBFileReader CandlesMeta Structure
SecDBFileReader CandlesMeta Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandlesMeta Methods

SecDBFileReader CandlesMeta Methods NFX Class Library

The SecDBFileReader CandlesMeta type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SecDBFileReader CandlesMeta Structure
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandlesMeta Properties

SecDBFileReader CandlesMeta Properties NFX Class Library

The SecDBFileReader CandlesMeta type exposes the following members.
Properties
 | Name | Description
Public property | Resolutions | Returns resolution available in the file
Back to Top
See Also
SecDBFileReader CandlesMeta Structure
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CandlesMeta.Resolutions Property

SecDBFileReader CandlesMeta Resolutions Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns resolution available in the file

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<ushort> Resolutions { get; }
public IEnumerable<ushort> Resolutions { get; }
Public ReadOnly Property Resolutions As IEnumerable(Of UShort)
    Get
Public ReadOnly Property Resolutions As IEnumerable(Of UShort)
    Get
public:
property IEnumerable<unsigned short>^ Resolutions {
    IEnumerable<unsigned short>^ get ();
}
public:
property IEnumerable<unsigned short>^ Resolutions {
    IEnumerable<unsigned short>^ get ();
}
member Resolutions : IEnumerable<uint16> with get
member Resolutions : IEnumerable<uint16> with get

Property Value

Type: Online IEnumerable Online UInt16
See Also
SecDBFileReader CandlesMeta Structure
SecDBFileReader CandlesMeta Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.CompressionType Enumeration

SecDBFileReader CompressionType Enumeration NFX Class Library

[This is preliminary documentation and is subject to change.]

Denotes compression types. Used in StreamMeta

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum CompressionType
public enum CompressionType
Public Enumeration CompressionType
Public Enumeration CompressionType
public enum class CompressionType
public enum class CompressionType
type CompressionType
type CompressionType
Members
Member name | Value | Description
None | 0 |
GZip | 1 |
See Also
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.FileRequiredHeader Structure

SecDBFileReader FileRequiredHeader Structure NFX Class Library

[This is preliminary documentation and is subject to change.]

Contains data from the REQUIRED/system protion of the file header

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct FileRequiredHeader
public struct FileRequiredHeader
Public Structure FileRequiredHeader
Public Structure FileRequiredHeader
public value class FileRequiredHeader
public value class FileRequiredHeader
[<SealedAttribute>]
type FileRequiredHeader =  struct end
[<SealedAttribute>]
type FileRequiredHeader =  struct end
See Also
SecDBFileReader FileRequiredHeader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.FileRequiredHeader Members

SecDBFileReader FileRequiredHeader Members NFX Class Library

The SecDBFileReader FileRequiredHeader type exposes the following members.
Constructors
 | Name | Description
Protected method | SecDBFileReader FileRequiredHeader | Initializes a new instance of the SecDBFileReader FileRequiredHeader class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Date | UTC date of market data
Public field | Depth | Max depth of market quote levels
Public field | Exchange | Exchange producing market data
Public field | Instrument | Exchange-specific security name
Public field | OriginLocalTimeName | The name of the origin local time zone/location
Public field | OriginLocalTimeOffset | Offset of the origin local time from UTC
Public field | PriceStep | Instrument's minimal price step
Public field | SecurityId | Exchange-specific security ID
Public field | Shebang | .NIX shebang line
Public field | Symbol | Company-specific security name
Public field | UUID | Company-specific unique file ID
Public field | Version | File format version
Back to Top
See Also
SecDBFileReader FileRequiredHeader Structure
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.FileRequiredHeader Constructor

SecDBFileReader FileRequiredHeader Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SecDBFileReader FileRequiredHeader class

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal FileRequiredHeader(
    string shebang,
    IDictionary<string, string> headers
)
internal FileRequiredHeader(
    string shebang,
    IDictionary<string, string> headers
)
Friend Sub New (
    shebang As String,
    headers As IDictionary(Of String, String)
)
Friend Sub New (
    shebang As String,
    headers As IDictionary(Of String, String)
)
internal:
FileRequiredHeader(
    String^ shebang,
    IDictionary<String^, String^>^ headers
)
internal:
FileRequiredHeader(
    String^ shebang,
    IDictionary<String^, String^>^ headers
)
new :
        shebang : string *
        headers : IDictionary<string, string> -> FileRequiredHeader
new :
        shebang : string *
        headers : IDictionary<string, string> -> FileRequiredHeader

Parameters

shebang
Type: Online System String
headers
Type: Online System.Collections.Generic IDictionary Online String, Online String
See Also
SecDBFileReader FileRequiredHeader Structure
SecDBFileReader FileRequiredHeader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.FileRequiredHeader Fields

SecDBFileReader FileRequiredHeader Fields NFX Class Library

The SecDBFileReader FileRequiredHeader type exposes the following members.
Fields
 | Name | Description
Public field | Date | UTC date of market data
Public field | Depth | Max depth of market quote levels
Public field | Exchange | Exchange producing market data
Public field | Instrument | Exchange-specific security name
Public field | OriginLocalTimeName | The name of the origin local time zone/location
Public field | OriginLocalTimeOffset | Offset of the origin local time from UTC
Public field | PriceStep | Instrument's minimal price step
Public field | SecurityId | Exchange-specific security ID
Public field | Shebang | .NIX shebang line
Public field | Symbol | Company-specific security name
Public field | UUID | Company-specific unique file ID
Public field | Version | File format version
Back to Top
See Also
SecDBFileReader FileRequiredHeader Structure
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.FileRequiredHeader.Date Field

SecDBFileReader FileRequiredHeader Date Field NFX Class Library

[This is preliminary documentation and is subject to change.]

UTC date of market data

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly DateTime Date
public readonly DateTime Date
Public ReadOnly Date As DateTime
Public ReadOnly Date As DateTime
public:
initonly DateTime Date
public:
initonly DateTime Date
val Date: DateTime
val Date: DateTime

Field Value

Type: Online DateTime
See Also
SecDBFileReader FileRequiredHeader Structure
SecDBFileReader FileRequiredHeader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.FileRequiredHeader.Depth Field

SecDBFileReader FileRequiredHeader Depth Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Max depth of market quote levels

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Depth
public readonly int Depth
Public ReadOnly Depth As Integer
Public ReadOnly Depth As Integer
public:
initonly int Depth
public:
initonly int Depth
val Depth: int
val Depth: int

Field Value

Type: Online Int32
See Also
SecDBFileReader FileRequiredHeader Structure
SecDBFileReader FileRequiredHeader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.FileRequiredHeader.Exchange Field

SecDBFileReader FileRequiredHeader Exchange Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Exchange producing market data

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Exchange
public readonly string Exchange
Public ReadOnly Exchange As String
Public ReadOnly Exchange As String
public:
initonly String^ Exchange
public:
initonly String^ Exchange
val Exchange: string
val Exchange: string

Field Value

Type: Online String
See Also
SecDBFileReader FileRequiredHeader Structure
SecDBFileReader FileRequiredHeader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.FileRequiredHeader.Instrument Field

SecDBFileReader FileRequiredHeader Instrument Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Exchange-specific security name

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Instrument
public readonly string Instrument
Public ReadOnly Instrument As String
Public ReadOnly Instrument As String
public:
initonly String^ Instrument
public:
initonly String^ Instrument
val Instrument: string
val Instrument: string

Field Value

Type: Online String
See Also
SecDBFileReader FileRequiredHeader Structure
SecDBFileReader FileRequiredHeader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.FileRequiredHeader.OriginLocalTimeName Field

SecDBFileReader FileRequiredHeader OriginLocalTimeName Field NFX Class Library

[This is preliminary documentation and is subject to change.]

The name of the origin local time zone/location

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string OriginLocalTimeName
public readonly string OriginLocalTimeName
Public ReadOnly OriginLocalTimeName As String
Public ReadOnly OriginLocalTimeName As String
public:
initonly String^ OriginLocalTimeName
public:
initonly String^ OriginLocalTimeName
val OriginLocalTimeName: string
val OriginLocalTimeName: string

Field Value

Type: Online String
See Also
SecDBFileReader FileRequiredHeader Structure
SecDBFileReader FileRequiredHeader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.FileRequiredHeader.OriginLocalTimeOffset Field

SecDBFileReader FileRequiredHeader OriginLocalTimeOffset Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Offset of the origin local time from UTC

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly TimeSpan OriginLocalTimeOffset
public readonly TimeSpan OriginLocalTimeOffset
Public ReadOnly OriginLocalTimeOffset As TimeSpan
Public ReadOnly OriginLocalTimeOffset As TimeSpan
public:
initonly TimeSpan OriginLocalTimeOffset
public:
initonly TimeSpan OriginLocalTimeOffset
val OriginLocalTimeOffset: TimeSpan
val OriginLocalTimeOffset: TimeSpan

Field Value

Type: Online TimeSpan
See Also
SecDBFileReader FileRequiredHeader Structure
SecDBFileReader FileRequiredHeader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.FileRequiredHeader.PriceStep Field

SecDBFileReader FileRequiredHeader PriceStep Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Instrument's minimal price step

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly float PriceStep
public readonly float PriceStep
Public ReadOnly PriceStep As Single
Public ReadOnly PriceStep As Single
public:
initonly float PriceStep
public:
initonly float PriceStep
val PriceStep: float32
val PriceStep: float32

Field Value

Type: Online Single
See Also
SecDBFileReader FileRequiredHeader Structure
SecDBFileReader FileRequiredHeader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.FileRequiredHeader.SecurityId Field

SecDBFileReader FileRequiredHeader SecurityId Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Exchange-specific security ID

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string SecurityId
public readonly string SecurityId
Public ReadOnly SecurityId As String
Public ReadOnly SecurityId As String
public:
initonly String^ SecurityId
public:
initonly String^ SecurityId
val SecurityId: string
val SecurityId: string

Field Value

Type: Online String
See Also
SecDBFileReader FileRequiredHeader Structure
SecDBFileReader FileRequiredHeader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.FileRequiredHeader.Shebang Field

SecDBFileReader FileRequiredHeader Shebang Field NFX Class Library

[This is preliminary documentation and is subject to change.]

.NIX shebang line

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Shebang
public readonly string Shebang
Public ReadOnly Shebang As String
Public ReadOnly Shebang As String
public:
initonly String^ Shebang
public:
initonly String^ Shebang
val Shebang: string
val Shebang: string

Field Value

Type: Online String
See Also
SecDBFileReader FileRequiredHeader Structure
SecDBFileReader FileRequiredHeader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.FileRequiredHeader.Symbol Field

SecDBFileReader FileRequiredHeader Symbol Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Company-specific security name

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Symbol
public readonly string Symbol
Public ReadOnly Symbol As String
Public ReadOnly Symbol As String
public:
initonly String^ Symbol
public:
initonly String^ Symbol
val Symbol: string
val Symbol: string

Field Value

Type: Online String
See Also
SecDBFileReader FileRequiredHeader Structure
SecDBFileReader FileRequiredHeader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.FileRequiredHeader.UUID Field

SecDBFileReader FileRequiredHeader UUID Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Company-specific unique file ID

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Guid UUID
public readonly Guid UUID
Public ReadOnly UUID As Guid
Public ReadOnly UUID As Guid
public:
initonly Guid UUID
public:
initonly Guid UUID
val UUID: Guid
val UUID: Guid

Field Value

Type: Online Guid
See Also
SecDBFileReader FileRequiredHeader Structure
SecDBFileReader FileRequiredHeader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.FileRequiredHeader.Version Field

SecDBFileReader FileRequiredHeader Version Field NFX Class Library

[This is preliminary documentation and is subject to change.]

File format version

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Version
public readonly int Version
Public ReadOnly Version As Integer
Public ReadOnly Version As Integer
public:
initonly int Version
public:
initonly int Version
val Version: int
val Version: int

Field Value

Type: Online Int32
See Also
SecDBFileReader FileRequiredHeader Structure
SecDBFileReader FileRequiredHeader Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.FileRequiredHeader Methods

SecDBFileReader FileRequiredHeader Methods NFX Class Library

The SecDBFileReader FileRequiredHeader type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SecDBFileReader FileRequiredHeader Structure
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.InfoSample Class

SecDBFileReader InfoSample Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Financial.Market TimeSeriesSampleBase
NFX.Financial.Market.SecDb SecDBFileReader StreamSample
NFX.Financial.Market.SecDb SecDBFileReader InfoSample

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class InfoSample : SecDBFileReader..::..StreamSample
public class InfoSample : SecDBFileReader..::..StreamSample
Public Class InfoSample
    Inherits SecDBFileReader..::..StreamSample
Public Class InfoSample
    Inherits SecDBFileReader..::..StreamSample
public ref class InfoSample : public SecDBFileReader..::..StreamSample
public ref class InfoSample : public SecDBFileReader..::..StreamSample
type InfoSample =
    class
        inherit SecDBFileReader..::..StreamSample
    end
type InfoSample =
    class
        inherit SecDBFileReader..::..StreamSample
    end
See Also
SecDBFileReader InfoSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.InfoSample Members

SecDBFileReader InfoSample Members NFX Class Library

The SecDBFileReader InfoSample type exposes the following members.
Constructors
 | Name | Description
Protected method | SecDBFileReader InfoSample | Initializes a new instance of the SecDBFileReader InfoSample class
Back to Top
Methods
 | Name | Description
Public method | AggregateSample | (Inherited from TimeSeriesSampleBase.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeAggregateInstance | (Inherited from TimeSeriesSampleBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SummarizeAggregation | (Inherited from TimeSeriesSampleBase.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Body |
Public field | ResID |
Back to Top
Properties
 | Name | Description
Public property | AssociatedData | Associates an arbitrary data (Inherited from TimeSeriesSampleBase.)
Public property | TimeStamp | (Inherited from TimeSeriesSampleBase.)
Back to Top
See Also
SecDBFileReader InfoSample Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.InfoSample Constructor

SecDBFileReader InfoSample Constructor NFX Class Library

Initializes a new instance of the SecDBFileReader InfoSample class

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal InfoSample(
    DateTime ts,
    Stream stream
)
internal InfoSample(
    DateTime ts,
    Stream stream
)
Friend Sub New (
    ts As DateTime,
    stream As Stream
)
Friend Sub New (
    ts As DateTime,
    stream As Stream
)
internal:
InfoSample(
    DateTime ts,
    Stream^ stream
)
internal:
InfoSample(
    DateTime ts,
    Stream^ stream
)
new :
        ts : DateTime *
        stream : Stream -> InfoSample
new :
        ts : DateTime *
        stream : Stream -> InfoSample

Parameters

ts
Type: Online System DateTime
stream
Type: Online System.IO Stream
See Also
SecDBFileReader InfoSample Class
SecDBFileReader InfoSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.InfoSample Fields

SecDBFileReader InfoSample Fields NFX Class Library

The SecDBFileReader InfoSample type exposes the following members.
Fields
 | Name | Description
Public field | Body |
Public field | ResID |
Back to Top
See Also
SecDBFileReader InfoSample Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.InfoSample.Body Field

SecDBFileReader InfoSample Body Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Body
public readonly string Body
Public ReadOnly Body As String
Public ReadOnly Body As String
public:
initonly String^ Body
public:
initonly String^ Body
val Body: string
val Body: string

Field Value

Type: Online String
See Also
SecDBFileReader InfoSample Class
SecDBFileReader InfoSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.InfoSample.ResID Field

SecDBFileReader InfoSample ResID Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ulong ResID
public readonly ulong ResID
Public ReadOnly ResID As ULong
Public ReadOnly ResID As ULong
public:
initonly unsigned long long ResID
public:
initonly unsigned long long ResID
val ResID: uint64
val ResID: uint64

Field Value

Type: Online UInt64
See Also
SecDBFileReader InfoSample Class
SecDBFileReader InfoSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.InfoSample Methods

SecDBFileReader InfoSample Methods NFX Class Library

The SecDBFileReader InfoSample type exposes the following members.
Methods
 | Name | Description
Public method | AggregateSample | (Inherited from TimeSeriesSampleBase.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeAggregateInstance | (Inherited from TimeSeriesSampleBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SummarizeAggregation | (Inherited from TimeSeriesSampleBase.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SecDBFileReader InfoSample Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.InfoSample Properties

SecDBFileReader InfoSample Properties NFX Class Library

The SecDBFileReader InfoSample type exposes the following members.
Properties
 | Name | Description
Public property | AssociatedData | Associates an arbitrary data (Inherited from TimeSeriesSampleBase.)
Public property | TimeStamp | (Inherited from TimeSeriesSampleBase.)
Back to Top
See Also
SecDBFileReader InfoSample Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.OrderSample Class

SecDBFileReader OrderSample Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Financial.Market TimeSeriesSampleBase
NFX.Financial.Market.SecDb SecDBFileReader StreamSample
NFX.Financial.Market.SecDb SecDBFileReader OrderSample

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class OrderSample : SecDBFileReader..::..StreamSample
public class OrderSample : SecDBFileReader..::..StreamSample
Public Class OrderSample
    Inherits SecDBFileReader..::..StreamSample
Public Class OrderSample
    Inherits SecDBFileReader..::..StreamSample
public ref class OrderSample : public SecDBFileReader..::..StreamSample
public ref class OrderSample : public SecDBFileReader..::..StreamSample
type OrderSample =
    class
        inherit SecDBFileReader..::..StreamSample
    end
type OrderSample =
    class
        inherit SecDBFileReader..::..StreamSample
    end
See Also
SecDBFileReader OrderSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.OrderSample Members

SecDBFileReader OrderSample Members NFX Class Library

The SecDBFileReader OrderSample type exposes the following members.
Constructors
 | Name | Description
Protected method | SecDBFileReader OrderSample | Initializes a new instance of the SecDBFileReader OrderSample class
Back to Top
Methods
 | Name | Description
Public method | AggregateSample | (Inherited from TimeSeriesSampleBase.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeAggregateInstance | (Inherited from TimeSeriesSampleBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SummarizeAggregation | (Inherited from TimeSeriesSampleBase.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | CancelAll |
Public field | InternalOrder |
Public field | IsActive |
Public field | IsReplacement |
Public field | IsStopLoss |
Public field | IsTakeProfit |
Public field | OldOrderID |
Public field | OrderID |
Public field | Price |
Public field | PriceStep |
Public field | Qty |
Public field | Side |
Back to Top
Properties
 | Name | Description
Public property | AssociatedData | Associates an arbitrary data (Inherited from TimeSeriesSampleBase.)
Public property | TimeStamp | (Inherited from TimeSeriesSampleBase.)
Back to Top
See Also
SecDBFileReader OrderSample Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.OrderSample Constructor

SecDBFileReader OrderSample Constructor NFX Class Library

Initializes a new instance of the SecDBFileReader OrderSample class

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal OrderSample(
    SecDBFileReader file,
    SecDBFileReader..::..OrderSample ps,
    DateTime ts,
    Stream stream
)
internal OrderSample(
    SecDBFileReader file,
    SecDBFileReader..::..OrderSample ps,
    DateTime ts,
    Stream stream
)
Friend Sub New (
    file As SecDBFileReader,
    ps As SecDBFileReader..::..OrderSample,
    ts As DateTime,
    stream As Stream
)
Friend Sub New (
    file As SecDBFileReader,
    ps As SecDBFileReader..::..OrderSample,
    ts As DateTime,
    stream As Stream
)
internal:
OrderSample(
    SecDBFileReader^ file,
    SecDBFileReader..::..OrderSample^ ps,
    DateTime ts,
    Stream^ stream
)
internal:
OrderSample(
    SecDBFileReader^ file,
    SecDBFileReader..::..OrderSample^ ps,
    DateTime ts,
    Stream^ stream
)
new :
        file : SecDBFileReader *
        ps : SecDBFileReader..::..OrderSample *
        ts : DateTime *
        stream : Stream -> OrderSample
new :
        file : SecDBFileReader *
        ps : SecDBFileReader..::..OrderSample *
        ts : DateTime *
        stream : Stream -> OrderSample

Parameters

file
Type: NFX.Financial.Market.SecDb SecDBFileReader
ps
Type: NFX.Financial.Market.SecDb SecDBFileReader OrderSample
ts
Type: Online System DateTime
stream
Type: Online System.IO Stream
See Also
SecDBFileReader OrderSample Class
SecDBFileReader OrderSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.OrderSample Fields

SecDBFileReader OrderSample Fields NFX Class Library

The SecDBFileReader OrderSample type exposes the following members.
Fields
 | Name | Description
Public field | CancelAll |
Public field | InternalOrder |
Public field | IsActive |
Public field | IsReplacement |
Public field | IsStopLoss |
Public field | IsTakeProfit |
Public field | OldOrderID |
Public field | OrderID |
Public field | Price |
Public field | PriceStep |
Public field | Qty |
Public field | Side |
Back to Top
See Also
SecDBFileReader OrderSample Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.OrderSample.CancelAll Field

SecDBFileReader OrderSample CancelAll Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool CancelAll
public readonly bool CancelAll
Public ReadOnly CancelAll As Boolean
Public ReadOnly CancelAll As Boolean
public:
initonly bool CancelAll
public:
initonly bool CancelAll
val CancelAll: bool
val CancelAll: bool

Field Value

Type: Online Boolean
See Also
SecDBFileReader OrderSample Class
SecDBFileReader OrderSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.OrderSample.InternalOrder Field

SecDBFileReader OrderSample InternalOrder Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool InternalOrder
public readonly bool InternalOrder
Public ReadOnly InternalOrder As Boolean
Public ReadOnly InternalOrder As Boolean
public:
initonly bool InternalOrder
public:
initonly bool InternalOrder
val InternalOrder: bool
val InternalOrder: bool

Field Value

Type: Online Boolean
See Also
SecDBFileReader OrderSample Class
SecDBFileReader OrderSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.OrderSample.IsActive Field

SecDBFileReader OrderSample IsActive Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool IsActive
public readonly bool IsActive
Public ReadOnly IsActive As Boolean
Public ReadOnly IsActive As Boolean
public:
initonly bool IsActive
public:
initonly bool IsActive
val IsActive: bool
val IsActive: bool

Field Value

Type: Online Boolean
See Also
SecDBFileReader OrderSample Class
SecDBFileReader OrderSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.OrderSample.IsReplacement Field

SecDBFileReader OrderSample IsReplacement Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool IsReplacement
public readonly bool IsReplacement
Public ReadOnly IsReplacement As Boolean
Public ReadOnly IsReplacement As Boolean
public:
initonly bool IsReplacement
public:
initonly bool IsReplacement
val IsReplacement: bool
val IsReplacement: bool

Field Value

Type: Online Boolean
See Also
SecDBFileReader OrderSample Class
SecDBFileReader OrderSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.OrderSample.IsStopLoss Field

SecDBFileReader OrderSample IsStopLoss Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool IsStopLoss
public readonly bool IsStopLoss
Public ReadOnly IsStopLoss As Boolean
Public ReadOnly IsStopLoss As Boolean
public:
initonly bool IsStopLoss
public:
initonly bool IsStopLoss
val IsStopLoss: bool
val IsStopLoss: bool

Field Value

Type: Online Boolean
See Also
SecDBFileReader OrderSample Class
SecDBFileReader OrderSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.OrderSample.IsTakeProfit Field

SecDBFileReader OrderSample IsTakeProfit Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool IsTakeProfit
public readonly bool IsTakeProfit
Public ReadOnly IsTakeProfit As Boolean
Public ReadOnly IsTakeProfit As Boolean
public:
initonly bool IsTakeProfit
public:
initonly bool IsTakeProfit
val IsTakeProfit: bool
val IsTakeProfit: bool

Field Value

Type: Online Boolean
See Also
SecDBFileReader OrderSample Class
SecDBFileReader OrderSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.OrderSample.OldOrderID Field

SecDBFileReader OrderSample OldOrderID Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly long OldOrderID
public readonly long OldOrderID
Public ReadOnly OldOrderID As Long
Public ReadOnly OldOrderID As Long
public:
initonly long long OldOrderID
public:
initonly long long OldOrderID
val OldOrderID: int64
val OldOrderID: int64

Field Value

Type: Online Int64
See Also
SecDBFileReader OrderSample Class
SecDBFileReader OrderSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.OrderSample.OrderID Field

SecDBFileReader OrderSample OrderID Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly long OrderID
public readonly long OrderID
Public ReadOnly OrderID As Long
Public ReadOnly OrderID As Long
public:
initonly long long OrderID
public:
initonly long long OrderID
val OrderID: int64
val OrderID: int64

Field Value

Type: Online Int64
See Also
SecDBFileReader OrderSample Class
SecDBFileReader OrderSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.OrderSample.Price Field

SecDBFileReader OrderSample Price Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float Price
public float Price
Public Price As Single
Public Price As Single
public:
float Price
public:
float Price
val mutable Price: float32
val mutable Price: float32

Field Value

Type: Online Single
See Also
SecDBFileReader OrderSample Class
SecDBFileReader OrderSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.OrderSample.PriceStep Field

SecDBFileReader OrderSample PriceStep Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long PriceStep
public long PriceStep
Public PriceStep As Long
Public PriceStep As Long
public:
long long PriceStep
public:
long long PriceStep
val mutable PriceStep: int64
val mutable PriceStep: int64

Field Value

Type: Online Int64
See Also
SecDBFileReader OrderSample Class
SecDBFileReader OrderSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.OrderSample.Qty Field

SecDBFileReader OrderSample Qty Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly long Qty
public readonly long Qty
Public ReadOnly Qty As Long
Public ReadOnly Qty As Long
public:
initonly long long Qty
public:
initonly long long Qty
val Qty: int64
val Qty: int64

Field Value

Type: Online Int64
See Also
SecDBFileReader OrderSample Class
SecDBFileReader OrderSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.OrderSample.Side Field

SecDBFileReader OrderSample Side Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SecDBFileReader..::..OrderSample..::..SideType Side
public readonly SecDBFileReader..::..OrderSample..::..SideType Side
Public ReadOnly Side As SecDBFileReader..::..OrderSample..::..SideType
Public ReadOnly Side As SecDBFileReader..::..OrderSample..::..SideType
public:
initonly SecDBFileReader..::..OrderSample..::..SideType Side
public:
initonly SecDBFileReader..::..OrderSample..::..SideType Side
val Side: SecDBFileReader..::..OrderSample..::..SideType
val Side: SecDBFileReader..::..OrderSample..::..SideType

Field Value

Type: SecDBFileReader OrderSample SideType
See Also
SecDBFileReader OrderSample Class
SecDBFileReader OrderSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.OrderSample Methods

SecDBFileReader OrderSample Methods NFX Class Library

The SecDBFileReader OrderSample type exposes the following members.
Methods
 | Name | Description
Public method | AggregateSample | (Inherited from TimeSeriesSampleBase.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeAggregateInstance | (Inherited from TimeSeriesSampleBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SummarizeAggregation | (Inherited from TimeSeriesSampleBase.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SecDBFileReader OrderSample Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.OrderSample Properties

SecDBFileReader OrderSample Properties NFX Class Library

The SecDBFileReader OrderSample type exposes the following members.
Properties
 | Name | Description
Public property | AssociatedData | Associates an arbitrary data (Inherited from TimeSeriesSampleBase.)
Public property | TimeStamp | (Inherited from TimeSeriesSampleBase.)
Back to Top
See Also
SecDBFileReader OrderSample Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.OrderSample.SideType Enumeration

SecDBFileReader OrderSample SideType Enumeration NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum SideType
public enum SideType
Public Enumeration SideType
Public Enumeration SideType
public enum class SideType
public enum class SideType
type SideType
type SideType
Members
Member name | Value | Description
Buy | 0 |
Sell | 1 |
See Also
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.QuoteSample Class

SecDBFileReader QuoteSample Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Financial.Market TimeSeriesSampleBase
NFX.Financial.Market.SecDb SecDBFileReader StreamSample
NFX.Financial.Market.SecDb SecDBFileReader QuoteSample

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class QuoteSample : SecDBFileReader..::..StreamSample
public class QuoteSample : SecDBFileReader..::..StreamSample
Public Class QuoteSample
    Inherits SecDBFileReader..::..StreamSample
Public Class QuoteSample
    Inherits SecDBFileReader..::..StreamSample
public ref class QuoteSample : public SecDBFileReader..::..StreamSample
public ref class QuoteSample : public SecDBFileReader..::..StreamSample
type QuoteSample =
    class
        inherit SecDBFileReader..::..StreamSample
    end
type QuoteSample =
    class
        inherit SecDBFileReader..::..StreamSample
    end
See Also
SecDBFileReader QuoteSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.QuoteSample Members

SecDBFileReader QuoteSample Members NFX Class Library

The SecDBFileReader QuoteSample type exposes the following members.
Constructors
 | Name | Description
Protected method | SecDBFileReader QuoteSample | Initializes a new instance of the SecDBFileReader QuoteSample class
Back to Top
Methods
 | Name | Description
Public method | AggregateSample | (Inherited from TimeSeriesSampleBase.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeAggregateInstance | (Inherited from TimeSeriesSampleBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SummarizeAggregation | (Inherited from TimeSeriesSampleBase.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | AskCount |
Public field | BidCount |
Public field | PriceLevels |
Back to Top
Properties
 | Name | Description
Public property | Asks |
Public property | AssociatedData | Associates an arbitrary data (Inherited from TimeSeriesSampleBase.)
Public property | Bids |
Public property | TimeStamp | (Inherited from TimeSeriesSampleBase.)
Back to Top
See Also
SecDBFileReader QuoteSample Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.QuoteSample Constructor

SecDBFileReader QuoteSample Constructor NFX Class Library

Initializes a new instance of the SecDBFileReader QuoteSample class

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal QuoteSample(
    SecDBFileReader file,
    SecDBFileReader..::..QuoteSample ps,
    DateTime ts,
    Stream stream
)
internal QuoteSample(
    SecDBFileReader file,
    SecDBFileReader..::..QuoteSample ps,
    DateTime ts,
    Stream stream
)
Friend Sub New (
    file As SecDBFileReader,
    ps As SecDBFileReader..::..QuoteSample,
    ts As DateTime,
    stream As Stream
)
Friend Sub New (
    file As SecDBFileReader,
    ps As SecDBFileReader..::..QuoteSample,
    ts As DateTime,
    stream As Stream
)
internal:
QuoteSample(
    SecDBFileReader^ file,
    SecDBFileReader..::..QuoteSample^ ps,
    DateTime ts,
    Stream^ stream
)
internal:
QuoteSample(
    SecDBFileReader^ file,
    SecDBFileReader..::..QuoteSample^ ps,
    DateTime ts,
    Stream^ stream
)
new :
        file : SecDBFileReader *
        ps : SecDBFileReader..::..QuoteSample *
        ts : DateTime *
        stream : Stream -> QuoteSample
new :
        file : SecDBFileReader *
        ps : SecDBFileReader..::..QuoteSample *
        ts : DateTime *
        stream : Stream -> QuoteSample

Parameters

file
Type: NFX.Financial.Market.SecDb SecDBFileReader
ps
Type: NFX.Financial.Market.SecDb SecDBFileReader QuoteSample
ts
Type: Online System DateTime
stream
Type: Online System.IO Stream
See Also
SecDBFileReader QuoteSample Class
SecDBFileReader QuoteSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.QuoteSample Fields

SecDBFileReader QuoteSample Fields NFX Class Library

The SecDBFileReader QuoteSample type exposes the following members.
Fields
 | Name | Description
Public field | AskCount |
Public field | BidCount |
Public field | PriceLevels |
Back to Top
See Also
SecDBFileReader QuoteSample Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.QuoteSample.AskCount Field

SecDBFileReader QuoteSample AskCount Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int AskCount
public readonly int AskCount
Public ReadOnly AskCount As Integer
Public ReadOnly AskCount As Integer
public:
initonly int AskCount
public:
initonly int AskCount
val AskCount: int
val AskCount: int

Field Value

Type: Online Int32
See Also
SecDBFileReader QuoteSample Class
SecDBFileReader QuoteSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.QuoteSample.BidCount Field

SecDBFileReader QuoteSample BidCount Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int BidCount
public readonly int BidCount
Public ReadOnly BidCount As Integer
Public ReadOnly BidCount As Integer
public:
initonly int BidCount
public:
initonly int BidCount
val BidCount: int
val BidCount: int

Field Value

Type: Online Int32
See Also
SecDBFileReader QuoteSample Class
SecDBFileReader QuoteSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.QuoteSample.PriceLevels Field

SecDBFileReader QuoteSample PriceLevels Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SecDBFileReader..::..QuoteSample..::..PxLevel[] PriceLevels
public readonly SecDBFileReader..::..QuoteSample..::..PxLevel[] PriceLevels
Public ReadOnly PriceLevels As SecDBFileReader..::..QuoteSample..::..PxLevel()
Public ReadOnly PriceLevels As SecDBFileReader..::..QuoteSample..::..PxLevel()
public:
initonly array<SecDBFileReader..::..QuoteSample..::..PxLevel>^ PriceLevels
public:
initonly array<SecDBFileReader..::..QuoteSample..::..PxLevel>^ PriceLevels
val PriceLevels: SecDBFileReader..::..QuoteSample..::..PxLevel[]
val PriceLevels: SecDBFileReader..::..QuoteSample..::..PxLevel[]

Field Value

Type: SecDBFileReader QuoteSample PxLevel
See Also
SecDBFileReader QuoteSample Class
SecDBFileReader QuoteSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.QuoteSample Methods

SecDBFileReader QuoteSample Methods NFX Class Library

The SecDBFileReader QuoteSample type exposes the following members.
Methods
 | Name | Description
Public method | AggregateSample | (Inherited from TimeSeriesSampleBase.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeAggregateInstance | (Inherited from TimeSeriesSampleBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SummarizeAggregation | (Inherited from TimeSeriesSampleBase.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SecDBFileReader QuoteSample Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.QuoteSample Properties

SecDBFileReader QuoteSample Properties NFX Class Library

The SecDBFileReader QuoteSample type exposes the following members.
Properties
 | Name | Description
Public property | Asks |
Public property | AssociatedData | Associates an arbitrary data (Inherited from TimeSeriesSampleBase.)
Public property | Bids |
Public property | TimeStamp | (Inherited from TimeSeriesSampleBase.)
Back to Top
See Also
SecDBFileReader QuoteSample Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.QuoteSample.Asks Property

SecDBFileReader QuoteSample Asks Property NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<SecDBFileReader..::..QuoteSample..::..PxLevel> Asks { get; }
public IEnumerable<SecDBFileReader..::..QuoteSample..::..PxLevel> Asks { get; }
Public ReadOnly Property Asks As IEnumerable(Of SecDBFileReader..::..QuoteSample..::..PxLevel)
    Get
Public ReadOnly Property Asks As IEnumerable(Of SecDBFileReader..::..QuoteSample..::..PxLevel)
    Get
public:
property IEnumerable<SecDBFileReader..::..QuoteSample..::..PxLevel>^ Asks {
    IEnumerable<SecDBFileReader..::..QuoteSample..::..PxLevel>^ get ();
}
public:
property IEnumerable<SecDBFileReader..::..QuoteSample..::..PxLevel>^ Asks {
    IEnumerable<SecDBFileReader..::..QuoteSample..::..PxLevel>^ get ();
}
member Asks : IEnumerable<SecDBFileReader..::..QuoteSample..::..PxLevel> with get
member Asks : IEnumerable<SecDBFileReader..::..QuoteSample..::..PxLevel> with get

Property Value

Type: Online IEnumerable SecDBFileReader QuoteSample PxLevel
See Also
SecDBFileReader QuoteSample Class
SecDBFileReader QuoteSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.QuoteSample.Bids Property

SecDBFileReader QuoteSample Bids Property NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<SecDBFileReader..::..QuoteSample..::..PxLevel> Bids { get; }
public IEnumerable<SecDBFileReader..::..QuoteSample..::..PxLevel> Bids { get; }
Public ReadOnly Property Bids As IEnumerable(Of SecDBFileReader..::..QuoteSample..::..PxLevel)
    Get
Public ReadOnly Property Bids As IEnumerable(Of SecDBFileReader..::..QuoteSample..::..PxLevel)
    Get
public:
property IEnumerable<SecDBFileReader..::..QuoteSample..::..PxLevel>^ Bids {
    IEnumerable<SecDBFileReader..::..QuoteSample..::..PxLevel>^ get ();
}
public:
property IEnumerable<SecDBFileReader..::..QuoteSample..::..PxLevel>^ Bids {
    IEnumerable<SecDBFileReader..::..QuoteSample..::..PxLevel>^ get ();
}
member Bids : IEnumerable<SecDBFileReader..::..QuoteSample..::..PxLevel> with get
member Bids : IEnumerable<SecDBFileReader..::..QuoteSample..::..PxLevel> with get

Property Value

Type: Online IEnumerable SecDBFileReader QuoteSample PxLevel
See Also
SecDBFileReader QuoteSample Class
SecDBFileReader QuoteSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.QuoteSample.PxLevel Structure

SecDBFileReader QuoteSample PxLevel Structure NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct PxLevel
public struct PxLevel
Public Structure PxLevel
Public Structure PxLevel
public value class PxLevel
public value class PxLevel
[<SealedAttribute>]
type PxLevel =  struct end
[<SealedAttribute>]
type PxLevel =  struct end
See Also
SecDBFileReader QuoteSample PxLevel Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.QuoteSample.PxLevel Members

SecDBFileReader QuoteSample PxLevel Members NFX Class Library

[This is preliminary documentation and is subject to change.]

The SecDBFileReader QuoteSample PxLevel type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Price |
Public field | PriceStep |
Public field | Quantity |
Back to Top
See Also
SecDBFileReader QuoteSample PxLevel Structure
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.QuoteSample.PxLevel Fields

SecDBFileReader QuoteSample PxLevel Fields NFX Class Library

The SecDBFileReader QuoteSample PxLevel type exposes the following members.
Fields
 | Name | Description
Public field | Price |
Public field | PriceStep |
Public field | Quantity |
Back to Top
See Also
SecDBFileReader QuoteSample PxLevel Structure
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.QuoteSample.PxLevel.Price Field

SecDBFileReader QuoteSample PxLevel Price Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float Price
public float Price
Public Price As Single
Public Price As Single
public:
float Price
public:
float Price
val mutable Price: float32
val mutable Price: float32

Field Value

Type: Online Single
See Also
SecDBFileReader QuoteSample PxLevel Structure
SecDBFileReader QuoteSample PxLevel Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.QuoteSample.PxLevel.PriceStep Field

SecDBFileReader QuoteSample PxLevel PriceStep Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long PriceStep
public long PriceStep
Public PriceStep As Long
Public PriceStep As Long
public:
long long PriceStep
public:
long long PriceStep
val mutable PriceStep: int64
val mutable PriceStep: int64

Field Value

Type: Online Int64
See Also
SecDBFileReader QuoteSample PxLevel Structure
SecDBFileReader QuoteSample PxLevel Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.QuoteSample.PxLevel.Quantity Field

SecDBFileReader QuoteSample PxLevel Quantity Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long Quantity
public long Quantity
Public Quantity As Long
Public Quantity As Long
public:
long long Quantity
public:
long long Quantity
val mutable Quantity: int64
val mutable Quantity: int64

Field Value

Type: Online Int64
See Also
SecDBFileReader QuoteSample PxLevel Structure
SecDBFileReader QuoteSample PxLevel Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.QuoteSample.PxLevel Methods

SecDBFileReader QuoteSample PxLevel Methods NFX Class Library

[This is preliminary documentation and is subject to change.]

The SecDBFileReader QuoteSample PxLevel type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SecDBFileReader QuoteSample PxLevel Structure
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.SecondSample Class

SecDBFileReader SecondSample Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Financial.Market TimeSeriesSampleBase
NFX.Financial.Market.SecDb SecDBFileReader StreamSample
NFX.Financial.Market.SecDb SecDBFileReader SecondSample

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class SecondSample : SecDBFileReader..::..StreamSample
public sealed class SecondSample : SecDBFileReader..::..StreamSample
Public NotInheritable Class SecondSample
    Inherits SecDBFileReader..::..StreamSample
Public NotInheritable Class SecondSample
    Inherits SecDBFileReader..::..StreamSample
public ref class SecondSample sealed : public SecDBFileReader..::..StreamSample
public ref class SecondSample sealed : public SecDBFileReader..::..StreamSample
[<SealedAttribute>]
type SecondSample =
    class
        inherit SecDBFileReader..::..StreamSample
    end
[<SealedAttribute>]
type SecondSample =
    class
        inherit SecDBFileReader..::..StreamSample
    end
See Also
SecDBFileReader SecondSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.SecondSample Members

SecDBFileReader SecondSample Members NFX Class Library

The SecDBFileReader SecondSample type exposes the following members.
Constructors
 | Name | Description
Protected method | SecDBFileReader SecondSample | Initializes a new instance of the SecDBFileReader SecondSample class
Back to Top
Methods
 | Name | Description
Public method | AggregateSample | (Inherited from TimeSeriesSampleBase.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeAggregateInstance | (Inherited from TimeSeriesSampleBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SummarizeAggregation | (Inherited from TimeSeriesSampleBase.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | AssociatedData | Associates an arbitrary data (Inherited from TimeSeriesSampleBase.)
Public property | TimeStamp | (Inherited from TimeSeriesSampleBase.)
Back to Top
See Also
SecDBFileReader SecondSample Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.SecondSample Constructor

SecDBFileReader SecondSample Constructor NFX Class Library

Initializes a new instance of the SecDBFileReader SecondSample class

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal SecondSample(
    DateTime ts
)
internal SecondSample(
    DateTime ts
)
Friend Sub New (
    ts As DateTime
)
Friend Sub New (
    ts As DateTime
)
internal:
SecondSample(
    DateTime ts
)
internal:
SecondSample(
    DateTime ts
)
new :
        ts : DateTime -> SecondSample
new :
        ts : DateTime -> SecondSample

Parameters

ts
Type: Online System DateTime
See Also
SecDBFileReader SecondSample Class
SecDBFileReader SecondSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.SecondSample Methods

SecDBFileReader SecondSample Methods NFX Class Library

The SecDBFileReader SecondSample type exposes the following members.
Methods
 | Name | Description
Public method | AggregateSample | (Inherited from TimeSeriesSampleBase.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeAggregateInstance | (Inherited from TimeSeriesSampleBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SummarizeAggregation | (Inherited from TimeSeriesSampleBase.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SecDBFileReader SecondSample Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.SecondSample Properties

SecDBFileReader SecondSample Properties NFX Class Library

The SecDBFileReader SecondSample type exposes the following members.
Properties
 | Name | Description
Public property | AssociatedData | Associates an arbitrary data (Inherited from TimeSeriesSampleBase.)
Public property | TimeStamp | (Inherited from TimeSeriesSampleBase.)
Back to Top
See Also
SecDBFileReader SecondSample Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.StreamID Enumeration

SecDBFileReader StreamID Enumeration NFX Class Library

Denotes stream types (id). Used in StreamMeta

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum StreamID
public enum StreamID
Public Enumeration StreamID
Public Enumeration StreamID
public enum class StreamID
public enum class StreamID
type StreamID
type StreamID
Members
Member name | Value | Description
Seconds | 0 |
Quotes | 1 |
Trade | 2 |
Order | 3 |
Summary | 4 |
Info | 5 |
MAX_ID | 5 |
See Also
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.StreamMeta Structure

SecDBFileReader StreamMeta Structure NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct StreamMeta
public struct StreamMeta
Public Structure StreamMeta
Public Structure StreamMeta
public value class StreamMeta
public value class StreamMeta
[<SealedAttribute>]
type StreamMeta =  struct end
[<SealedAttribute>]
type StreamMeta =  struct end
See Also
SecDBFileReader StreamMeta Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.StreamMeta Members

SecDBFileReader StreamMeta Members NFX Class Library

The SecDBFileReader StreamMeta type exposes the following members.
Constructors
 | Name | Description
Protected method | SecDBFileReader StreamMeta | Initializes a new instance of the SecDBFileReader StreamMeta class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | ID |
Back to Top
See Also
SecDBFileReader StreamMeta Structure
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.StreamMeta Constructor

SecDBFileReader StreamMeta Constructor NFX Class Library

Initializes a new instance of the SecDBFileReader StreamMeta class

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal StreamMeta(
    SecDBFileReader..::..StreamID id
)
internal StreamMeta(
    SecDBFileReader..::..StreamID id
)
Friend Sub New (
    id As SecDBFileReader..::..StreamID
)
Friend Sub New (
    id As SecDBFileReader..::..StreamID
)
internal:
StreamMeta(
    SecDBFileReader..::..StreamID id
)
internal:
StreamMeta(
    SecDBFileReader..::..StreamID id
)
new :
        id : SecDBFileReader..::..StreamID -> StreamMeta
new :
        id : SecDBFileReader..::..StreamID -> StreamMeta

Parameters

id
Type: NFX.Financial.Market.SecDb SecDBFileReader StreamID
See Also
SecDBFileReader StreamMeta Structure
SecDBFileReader StreamMeta Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.StreamMeta Fields

SecDBFileReader StreamMeta Fields NFX Class Library

The SecDBFileReader StreamMeta type exposes the following members.
Fields
 | Name | Description
Public field | ID |
Back to Top
See Also
SecDBFileReader StreamMeta Structure
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.StreamMeta.ID Field

SecDBFileReader StreamMeta ID Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SecDBFileReader..::..StreamID ID
public readonly SecDBFileReader..::..StreamID ID
Public ReadOnly ID As SecDBFileReader..::..StreamID
Public ReadOnly ID As SecDBFileReader..::..StreamID
public:
initonly SecDBFileReader..::..StreamID ID
public:
initonly SecDBFileReader..::..StreamID ID
val ID: SecDBFileReader..::..StreamID
val ID: SecDBFileReader..::..StreamID

Field Value

Type: SecDBFileReader StreamID
See Also
SecDBFileReader StreamMeta Structure
SecDBFileReader StreamMeta Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.StreamMeta Methods

SecDBFileReader StreamMeta Methods NFX Class Library

The SecDBFileReader StreamMeta type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SecDBFileReader StreamMeta Structure
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.StreamSample Class

SecDBFileReader StreamSample Class NFX Class Library

Base class for all samples
Inheritance Hierarchy
Online System Object
NFX.Financial.Market TimeSeriesSampleBase
NFX.Financial.Market.SecDb SecDBFileReader StreamSample
NFX.Financial.Market.SecDb SecDBFileReader InfoSample
NFX.Financial.Market.SecDb SecDBFileReader OrderSample
NFX.Financial.Market.SecDb SecDBFileReader QuoteSample
NFX.Financial.Market.SecDb SecDBFileReader SecondSample
NFX.Financial.Market.SecDb SecDBFileReader SummarySample
NFX.Financial.Market.SecDb SecDBFileReader TradeSample

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class StreamSample : TimeSeriesSampleBase
public abstract class StreamSample : TimeSeriesSampleBase
Public MustInherit Class StreamSample
    Inherits TimeSeriesSampleBase
Public MustInherit Class StreamSample
    Inherits TimeSeriesSampleBase
public ref class StreamSample abstract : public TimeSeriesSampleBase
public ref class StreamSample abstract : public TimeSeriesSampleBase
[<AbstractClassAttribute>]
type StreamSample =
    class
        inherit TimeSeriesSampleBase
    end
[<AbstractClassAttribute>]
type StreamSample =
    class
        inherit TimeSeriesSampleBase
    end
See Also
SecDBFileReader StreamSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.StreamSample Members

SecDBFileReader StreamSample Members NFX Class Library

The SecDBFileReader StreamSample type exposes the following members.
Constructors
 | Name | Description
Protected method | SecDBFileReader StreamSample | Initializes a new instance of the SecDBFileReader StreamSample class
Back to Top
Methods
 | Name | Description
Public method | AggregateSample | (Inherited from TimeSeriesSampleBase.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeAggregateInstance | (Inherited from TimeSeriesSampleBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SummarizeAggregation | (Inherited from TimeSeriesSampleBase.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | AssociatedData | Associates an arbitrary data (Inherited from TimeSeriesSampleBase.)
Public property | TimeStamp | (Inherited from TimeSeriesSampleBase.)
Back to Top
See Also
SecDBFileReader StreamSample Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.StreamSample Constructor

SecDBFileReader StreamSample Constructor NFX Class Library

Initializes a new instance of the SecDBFileReader StreamSample class

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected StreamSample(
    DateTime ts
)
protected StreamSample(
    DateTime ts
)
Protected Sub New (
    ts As DateTime
)
Protected Sub New (
    ts As DateTime
)
protected:
StreamSample(
    DateTime ts
)
protected:
StreamSample(
    DateTime ts
)
new :
        ts : DateTime -> StreamSample
new :
        ts : DateTime -> StreamSample

Parameters

ts
Type: Online System DateTime
See Also
SecDBFileReader StreamSample Class
SecDBFileReader StreamSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.StreamSample Methods

SecDBFileReader StreamSample Methods NFX Class Library

The SecDBFileReader StreamSample type exposes the following members.
Methods
 | Name | Description
Public method | AggregateSample | (Inherited from TimeSeriesSampleBase.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeAggregateInstance | (Inherited from TimeSeriesSampleBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SummarizeAggregation | (Inherited from TimeSeriesSampleBase.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SecDBFileReader StreamSample Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.StreamSample Properties

SecDBFileReader StreamSample Properties NFX Class Library

The SecDBFileReader StreamSample type exposes the following members.
Properties
 | Name | Description
Public property | AssociatedData | Associates an arbitrary data (Inherited from TimeSeriesSampleBase.)
Public property | TimeStamp | (Inherited from TimeSeriesSampleBase.)
Back to Top
See Also
SecDBFileReader StreamSample Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.SummarySample Class

SecDBFileReader SummarySample Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Financial.Market TimeSeriesSampleBase
NFX.Financial.Market.SecDb SecDBFileReader StreamSample
NFX.Financial.Market.SecDb SecDBFileReader SummarySample

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SummarySample : SecDBFileReader..::..StreamSample
public class SummarySample : SecDBFileReader..::..StreamSample
Public Class SummarySample
    Inherits SecDBFileReader..::..StreamSample
Public Class SummarySample
    Inherits SecDBFileReader..::..StreamSample
public ref class SummarySample : public SecDBFileReader..::..StreamSample
public ref class SummarySample : public SecDBFileReader..::..StreamSample
type SummarySample =
    class
        inherit SecDBFileReader..::..StreamSample
    end
type SummarySample =
    class
        inherit SecDBFileReader..::..StreamSample
    end
See Also
SecDBFileReader SummarySample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.SummarySample Members

SecDBFileReader SummarySample Members NFX Class Library

The SecDBFileReader SummarySample type exposes the following members.
Constructors
 | Name | Description
Protected method | SecDBFileReader SummarySample | Initializes a new instance of the SecDBFileReader SummarySample class
Back to Top
Methods
 | Name | Description
Public method | AggregateSample | (Inherited from TimeSeriesSampleBase.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeAggregateInstance | (Inherited from TimeSeriesSampleBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SummarizeAggregation | (Inherited from TimeSeriesSampleBase.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | AskQty |
Public field | BidQty |
Public field | IsAskQty |
Public field | IsBidQty |
Public field | IsPositions |
Public field | IsRisk |
Public field | Positions |
Public field | RiskAmt |
Back to Top
Properties
 | Name | Description
Public property | AssociatedData | Associates an arbitrary data (Inherited from TimeSeriesSampleBase.)
Public property | TimeStamp | (Inherited from TimeSeriesSampleBase.)
Back to Top
See Also
SecDBFileReader SummarySample Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.SummarySample Constructor

SecDBFileReader SummarySample Constructor NFX Class Library

Initializes a new instance of the SecDBFileReader SummarySample class

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal SummarySample(
    DateTime ts,
    Stream stream
)
internal SummarySample(
    DateTime ts,
    Stream stream
)
Friend Sub New (
    ts As DateTime,
    stream As Stream
)
Friend Sub New (
    ts As DateTime,
    stream As Stream
)
internal:
SummarySample(
    DateTime ts,
    Stream^ stream
)
internal:
SummarySample(
    DateTime ts,
    Stream^ stream
)
new :
        ts : DateTime *
        stream : Stream -> SummarySample
new :
        ts : DateTime *
        stream : Stream -> SummarySample

Parameters

ts
Type: Online System DateTime
stream
Type: Online System.IO Stream
See Also
SecDBFileReader SummarySample Class
SecDBFileReader SummarySample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.SummarySample Fields

SecDBFileReader SummarySample Fields NFX Class Library

The SecDBFileReader SummarySample type exposes the following members.
Fields
 | Name | Description
Public field | AskQty |
Public field | BidQty |
Public field | IsAskQty |
Public field | IsBidQty |
Public field | IsPositions |
Public field | IsRisk |
Public field | Positions |
Public field | RiskAmt |
Back to Top
See Also
SecDBFileReader SummarySample Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.SummarySample.AskQty Field

SecDBFileReader SummarySample AskQty Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ulong AskQty
public readonly ulong AskQty
Public ReadOnly AskQty As ULong
Public ReadOnly AskQty As ULong
public:
initonly unsigned long long AskQty
public:
initonly unsigned long long AskQty
val AskQty: uint64
val AskQty: uint64

Field Value

Type: Online UInt64
See Also
SecDBFileReader SummarySample Class
SecDBFileReader SummarySample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.SummarySample.BidQty Field

SecDBFileReader SummarySample BidQty Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ulong BidQty
public readonly ulong BidQty
Public ReadOnly BidQty As ULong
Public ReadOnly BidQty As ULong
public:
initonly unsigned long long BidQty
public:
initonly unsigned long long BidQty
val BidQty: uint64
val BidQty: uint64

Field Value

Type: Online UInt64
See Also
SecDBFileReader SummarySample Class
SecDBFileReader SummarySample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.SummarySample.IsAskQty Field

SecDBFileReader SummarySample IsAskQty Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool IsAskQty
public readonly bool IsAskQty
Public ReadOnly IsAskQty As Boolean
Public ReadOnly IsAskQty As Boolean
public:
initonly bool IsAskQty
public:
initonly bool IsAskQty
val IsAskQty: bool
val IsAskQty: bool

Field Value

Type: Online Boolean
See Also
SecDBFileReader SummarySample Class
SecDBFileReader SummarySample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.SummarySample.IsBidQty Field

SecDBFileReader SummarySample IsBidQty Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool IsBidQty
public readonly bool IsBidQty
Public ReadOnly IsBidQty As Boolean
Public ReadOnly IsBidQty As Boolean
public:
initonly bool IsBidQty
public:
initonly bool IsBidQty
val IsBidQty: bool
val IsBidQty: bool

Field Value

Type: Online Boolean
See Also
SecDBFileReader SummarySample Class
SecDBFileReader SummarySample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.SummarySample.IsPositions Field

SecDBFileReader SummarySample IsPositions Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool IsPositions
public readonly bool IsPositions
Public ReadOnly IsPositions As Boolean
Public ReadOnly IsPositions As Boolean
public:
initonly bool IsPositions
public:
initonly bool IsPositions
val IsPositions: bool
val IsPositions: bool

Field Value

Type: Online Boolean
See Also
SecDBFileReader SummarySample Class
SecDBFileReader SummarySample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.SummarySample.IsRisk Field

SecDBFileReader SummarySample IsRisk Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool IsRisk
public readonly bool IsRisk
Public ReadOnly IsRisk As Boolean
Public ReadOnly IsRisk As Boolean
public:
initonly bool IsRisk
public:
initonly bool IsRisk
val IsRisk: bool
val IsRisk: bool

Field Value

Type: Online Boolean
See Also
SecDBFileReader SummarySample Class
SecDBFileReader SummarySample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.SummarySample.Positions Field

SecDBFileReader SummarySample Positions Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly long Positions
public readonly long Positions
Public ReadOnly Positions As Long
Public ReadOnly Positions As Long
public:
initonly long long Positions
public:
initonly long long Positions
val Positions: int64
val Positions: int64

Field Value

Type: Online Int64
See Also
SecDBFileReader SummarySample Class
SecDBFileReader SummarySample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.SummarySample.RiskAmt Field

SecDBFileReader SummarySample RiskAmt Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly double RiskAmt
public readonly double RiskAmt
Public ReadOnly RiskAmt As Double
Public ReadOnly RiskAmt As Double
public:
initonly double RiskAmt
public:
initonly double RiskAmt
val RiskAmt: float
val RiskAmt: float

Field Value

Type: Online Double
See Also
SecDBFileReader SummarySample Class
SecDBFileReader SummarySample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.SummarySample Methods

SecDBFileReader SummarySample Methods NFX Class Library

The SecDBFileReader SummarySample type exposes the following members.
Methods
 | Name | Description
Public method | AggregateSample | (Inherited from TimeSeriesSampleBase.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeAggregateInstance | (Inherited from TimeSeriesSampleBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SummarizeAggregation | (Inherited from TimeSeriesSampleBase.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SecDBFileReader SummarySample Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.SummarySample Properties

SecDBFileReader SummarySample Properties NFX Class Library

The SecDBFileReader SummarySample type exposes the following members.
Properties
 | Name | Description
Public property | AssociatedData | Associates an arbitrary data (Inherited from TimeSeriesSampleBase.)
Public property | TimeStamp | (Inherited from TimeSeriesSampleBase.)
Back to Top
See Also
SecDBFileReader SummarySample Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.TradeSample Class

SecDBFileReader TradeSample Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Financial.Market TimeSeriesSampleBase
NFX.Financial.Market.SecDb SecDBFileReader StreamSample
NFX.Financial.Market.SecDb SecDBFileReader TradeSample

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TradeSample : SecDBFileReader..::..StreamSample
public class TradeSample : SecDBFileReader..::..StreamSample
Public Class TradeSample
    Inherits SecDBFileReader..::..StreamSample
Public Class TradeSample
    Inherits SecDBFileReader..::..StreamSample
public ref class TradeSample : public SecDBFileReader..::..StreamSample
public ref class TradeSample : public SecDBFileReader..::..StreamSample
type TradeSample =
    class
        inherit SecDBFileReader..::..StreamSample
    end
type TradeSample =
    class
        inherit SecDBFileReader..::..StreamSample
    end
See Also
SecDBFileReader TradeSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.TradeSample Members

SecDBFileReader TradeSample Members NFX Class Library

The SecDBFileReader TradeSample type exposes the following members.
Constructors
 | Name | Description
Protected method | SecDBFileReader TradeSample | Initializes a new instance of the SecDBFileReader TradeSample class
Back to Top
Methods
 | Name | Description
Public method | AggregateSample | (Inherited from TimeSeriesSampleBase.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeAggregateInstance | (Inherited from TimeSeriesSampleBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SummarizeAggregation | (Inherited from TimeSeriesSampleBase.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Aggressor |
Public field | InternalTrade |
Public field | IsOrderID |
Public field | IsQty |
Public field | IsTradeID |
Public field | OrderID |
Public field | Price |
Public field | PriceStep |
Public field | Qty |
Public field | Side |
Public field | TradeID |
Back to Top
Properties
 | Name | Description
Public property | AssociatedData | Associates an arbitrary data (Inherited from TimeSeriesSampleBase.)
Public property | TimeStamp | (Inherited from TimeSeriesSampleBase.)
Back to Top
See Also
SecDBFileReader TradeSample Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.TradeSample Constructor

SecDBFileReader TradeSample Constructor NFX Class Library

Initializes a new instance of the SecDBFileReader TradeSample class

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal TradeSample(
    SecDBFileReader file,
    SecDBFileReader..::..TradeSample ps,
    DateTime ts,
    Stream stream
)
internal TradeSample(
    SecDBFileReader file,
    SecDBFileReader..::..TradeSample ps,
    DateTime ts,
    Stream stream
)
Friend Sub New (
    file As SecDBFileReader,
    ps As SecDBFileReader..::..TradeSample,
    ts As DateTime,
    stream As Stream
)
Friend Sub New (
    file As SecDBFileReader,
    ps As SecDBFileReader..::..TradeSample,
    ts As DateTime,
    stream As Stream
)
internal:
TradeSample(
    SecDBFileReader^ file,
    SecDBFileReader..::..TradeSample^ ps,
    DateTime ts,
    Stream^ stream
)
internal:
TradeSample(
    SecDBFileReader^ file,
    SecDBFileReader..::..TradeSample^ ps,
    DateTime ts,
    Stream^ stream
)
new :
        file : SecDBFileReader *
        ps : SecDBFileReader..::..TradeSample *
        ts : DateTime *
        stream : Stream -> TradeSample
new :
        file : SecDBFileReader *
        ps : SecDBFileReader..::..TradeSample *
        ts : DateTime *
        stream : Stream -> TradeSample

Parameters

file
Type: NFX.Financial.Market.SecDb SecDBFileReader
ps
Type: NFX.Financial.Market.SecDb SecDBFileReader TradeSample
ts
Type: Online System DateTime
stream
Type: Online System.IO Stream
See Also
SecDBFileReader TradeSample Class
SecDBFileReader TradeSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.TradeSample Fields

SecDBFileReader TradeSample Fields NFX Class Library

The SecDBFileReader TradeSample type exposes the following members.
Fields
 | Name | Description
Public field | Aggressor |
Public field | InternalTrade |
Public field | IsOrderID |
Public field | IsQty |
Public field | IsTradeID |
Public field | OrderID |
Public field | Price |
Public field | PriceStep |
Public field | Qty |
Public field | Side |
Public field | TradeID |
Back to Top
See Also
SecDBFileReader TradeSample Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.TradeSample.Aggressor Field

SecDBFileReader TradeSample Aggressor Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SecDBFileReader..::..TradeSample..::..AggressorType Aggressor
public readonly SecDBFileReader..::..TradeSample..::..AggressorType Aggressor
Public ReadOnly Aggressor As SecDBFileReader..::..TradeSample..::..AggressorType
Public ReadOnly Aggressor As SecDBFileReader..::..TradeSample..::..AggressorType
public:
initonly SecDBFileReader..::..TradeSample..::..AggressorType Aggressor
public:
initonly SecDBFileReader..::..TradeSample..::..AggressorType Aggressor
val Aggressor: SecDBFileReader..::..TradeSample..::..AggressorType
val Aggressor: SecDBFileReader..::..TradeSample..::..AggressorType

Field Value

Type: SecDBFileReader TradeSample AggressorType
See Also
SecDBFileReader TradeSample Class
SecDBFileReader TradeSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.TradeSample.InternalTrade Field

SecDBFileReader TradeSample InternalTrade Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool InternalTrade
public readonly bool InternalTrade
Public ReadOnly InternalTrade As Boolean
Public ReadOnly InternalTrade As Boolean
public:
initonly bool InternalTrade
public:
initonly bool InternalTrade
val InternalTrade: bool
val InternalTrade: bool

Field Value

Type: Online Boolean
See Also
SecDBFileReader TradeSample Class
SecDBFileReader TradeSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.TradeSample.IsOrderID Field

SecDBFileReader TradeSample IsOrderID Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool IsOrderID
public readonly bool IsOrderID
Public ReadOnly IsOrderID As Boolean
Public ReadOnly IsOrderID As Boolean
public:
initonly bool IsOrderID
public:
initonly bool IsOrderID
val IsOrderID: bool
val IsOrderID: bool

Field Value

Type: Online Boolean
See Also
SecDBFileReader TradeSample Class
SecDBFileReader TradeSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.TradeSample.IsQty Field

SecDBFileReader TradeSample IsQty Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool IsQty
public readonly bool IsQty
Public ReadOnly IsQty As Boolean
Public ReadOnly IsQty As Boolean
public:
initonly bool IsQty
public:
initonly bool IsQty
val IsQty: bool
val IsQty: bool

Field Value

Type: Online Boolean
See Also
SecDBFileReader TradeSample Class
SecDBFileReader TradeSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.TradeSample.IsTradeID Field

SecDBFileReader TradeSample IsTradeID Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool IsTradeID
public readonly bool IsTradeID
Public ReadOnly IsTradeID As Boolean
Public ReadOnly IsTradeID As Boolean
public:
initonly bool IsTradeID
public:
initonly bool IsTradeID
val IsTradeID: bool
val IsTradeID: bool

Field Value

Type: Online Boolean
See Also
SecDBFileReader TradeSample Class
SecDBFileReader TradeSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.TradeSample.OrderID Field

SecDBFileReader TradeSample OrderID Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ulong OrderID
public readonly ulong OrderID
Public ReadOnly OrderID As ULong
Public ReadOnly OrderID As ULong
public:
initonly unsigned long long OrderID
public:
initonly unsigned long long OrderID
val OrderID: uint64
val OrderID: uint64

Field Value

Type: Online UInt64
See Also
SecDBFileReader TradeSample Class
SecDBFileReader TradeSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.TradeSample.Price Field

SecDBFileReader TradeSample Price Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float Price
public float Price
Public Price As Single
Public Price As Single
public:
float Price
public:
float Price
val mutable Price: float32
val mutable Price: float32

Field Value

Type: Online Single
See Also
SecDBFileReader TradeSample Class
SecDBFileReader TradeSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.TradeSample.PriceStep Field

SecDBFileReader TradeSample PriceStep Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long PriceStep
public long PriceStep
Public PriceStep As Long
Public PriceStep As Long
public:
long long PriceStep
public:
long long PriceStep
val mutable PriceStep: int64
val mutable PriceStep: int64

Field Value

Type: Online Int64
See Also
SecDBFileReader TradeSample Class
SecDBFileReader TradeSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.TradeSample.Qty Field

SecDBFileReader TradeSample Qty Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly long Qty
public readonly long Qty
Public ReadOnly Qty As Long
Public ReadOnly Qty As Long
public:
initonly long long Qty
public:
initonly long long Qty
val Qty: int64
val Qty: int64

Field Value

Type: Online Int64
See Also
SecDBFileReader TradeSample Class
SecDBFileReader TradeSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.TradeSample.Side Field

SecDBFileReader TradeSample Side Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SecDBFileReader..::..TradeSample..::..SideType Side
public readonly SecDBFileReader..::..TradeSample..::..SideType Side
Public ReadOnly Side As SecDBFileReader..::..TradeSample..::..SideType
Public ReadOnly Side As SecDBFileReader..::..TradeSample..::..SideType
public:
initonly SecDBFileReader..::..TradeSample..::..SideType Side
public:
initonly SecDBFileReader..::..TradeSample..::..SideType Side
val Side: SecDBFileReader..::..TradeSample..::..SideType
val Side: SecDBFileReader..::..TradeSample..::..SideType

Field Value

Type: SecDBFileReader TradeSample SideType
See Also
SecDBFileReader TradeSample Class
SecDBFileReader TradeSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.TradeSample.TradeID Field

SecDBFileReader TradeSample TradeID Field NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly ulong TradeID
public readonly ulong TradeID
Public ReadOnly TradeID As ULong
Public ReadOnly TradeID As ULong
public:
initonly unsigned long long TradeID
public:
initonly unsigned long long TradeID
val TradeID: uint64
val TradeID: uint64

Field Value

Type: Online UInt64
See Also
SecDBFileReader TradeSample Class
SecDBFileReader TradeSample Members
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.TradeSample Methods

SecDBFileReader TradeSample Methods NFX Class Library

The SecDBFileReader TradeSample type exposes the following members.
Methods
 | Name | Description
Public method | AggregateSample | (Inherited from TimeSeriesSampleBase.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeAggregateInstance | (Inherited from TimeSeriesSampleBase.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SummarizeAggregation | (Inherited from TimeSeriesSampleBase.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SecDBFileReader TradeSample Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.TradeSample Properties

SecDBFileReader TradeSample Properties NFX Class Library

The SecDBFileReader TradeSample type exposes the following members.
Properties
 | Name | Description
Public property | AssociatedData | Associates an arbitrary data (Inherited from TimeSeriesSampleBase.)
Public property | TimeStamp | (Inherited from TimeSeriesSampleBase.)
Back to Top
See Also
SecDBFileReader TradeSample Class
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.TradeSample.AggressorType Enumeration

SecDBFileReader TradeSample AggressorType Enumeration NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum AggressorType
public enum AggressorType
Public Enumeration AggressorType
Public Enumeration AggressorType
public enum class AggressorType
public enum class AggressorType
type AggressorType
type AggressorType
Members
Member name | Value | Description
Undef | 0 |
Agressor | 1 |
Passive | 2 |
See Also
NFX.Financial.Market.SecDb Namespace


SecDBFileReader.TradeSample.SideType Enumeration

SecDBFileReader TradeSample SideType Enumeration NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum SideType
public enum SideType
Public Enumeration SideType
Public Enumeration SideType
public enum class SideType
public enum class SideType
type SideType
type SideType
Members
Member name | Value | Description
Buy | 0 |
Sell | 1 |
See Also
NFX.Financial.Market.SecDb Namespace


SecDBPrimitives Class

SecDBPrimitives Class NFX Class Library

Facilittates reading SecDB primitive values see: https://github.com/saleyn/secdb/wiki/Data-Format
Inheritance Hierarchy
Online System Object
NFX.Financial.Market.SecDb SecDBPrimitives

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class SecDBPrimitives
public static class SecDBPrimitives
Public NotInheritable Class SecDBPrimitives
Public NotInheritable Class SecDBPrimitives
public ref class SecDBPrimitives abstract sealed
public ref class SecDBPrimitives abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SecDBPrimitives =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SecDBPrimitives =  class end
See Also
SecDBPrimitives Members
NFX.Financial.Market.SecDb Namespace


SecDBPrimitives Members

SecDBPrimitives Members NFX Class Library

The SecDBPrimitives type exposes the following members.
Methods
Name | Description
getBuff32 |
ReadByte |
ReadDiffTimeMcs |
ReadDouble |
readFromStream |
ReadInt16 |
ReadInt32 |
ReadInt64 |
ReadMidnightSecond |
ReadSLEB128 |
ReadString |
ReadUInt16 |
ReadUInt32 |
ReadUInt64 |
ReadULEB128 |
Back to Top
See Also
SecDBPrimitives Class
NFX.Financial.Market.SecDb Namespace


SecDBPrimitives Methods

SecDBPrimitives Methods NFX Class Library

The SecDBPrimitives type exposes the following members.
Methods
Name | Description
getBuff32 |
ReadByte |
ReadDiffTimeMcs |
ReadDouble |
readFromStream |
ReadInt16 |
ReadInt32 |
ReadInt64 |
ReadMidnightSecond |
ReadSLEB128 |
ReadString |
ReadUInt16 |
ReadUInt32 |
ReadUInt64 |
ReadULEB128 |
Back to Top
See Also
SecDBPrimitives Class
NFX.Financial.Market.SecDb Namespace


SecDBPrimitives.getBuff32 Method

SecDBPrimitives getBuff32 Method NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static byte[] getBuff32()
internal static byte[] getBuff32()
Friend Shared Function getBuff32 As Byte()
Friend Shared Function getBuff32 As Byte()
internal:
static array<unsigned char>^ getBuff32()
internal:
static array<unsigned char>^ getBuff32()
internal static member getBuff32 : unit -> byte[]
internal static member getBuff32 : unit -> byte[]

Return Value

Type: Online Byte
See Also
SecDBPrimitives Class
SecDBPrimitives Members
NFX.Financial.Market.SecDb Namespace


SecDBPrimitives.ReadByte Method

SecDBPrimitives ReadByte Method NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte ReadByte(
    Stream stream
)
public static byte ReadByte(
    Stream stream
)
Public Shared Function ReadByte (
    stream As Stream
) As Byte
Public Shared Function ReadByte (
    stream As Stream
) As Byte
public:
static unsigned char ReadByte(
    Stream^ stream
)
public:
static unsigned char ReadByte(
    Stream^ stream
)
static member ReadByte :
        stream : Stream -> byte
static member ReadByte :
        stream : Stream -> byte

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online Byte
See Also
SecDBPrimitives Class
SecDBPrimitives Members
NFX.Financial.Market.SecDb Namespace


SecDBPrimitives.ReadDiffTimeMcs Method

SecDBPrimitives ReadDiffTimeMcs Method NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ulong ReadDiffTimeMcs(
    Stream stream
)
public static ulong ReadDiffTimeMcs(
    Stream stream
)
Public Shared Function ReadDiffTimeMcs (
    stream As Stream
) As ULong
Public Shared Function ReadDiffTimeMcs (
    stream As Stream
) As ULong
public:
static unsigned long long ReadDiffTimeMcs(
    Stream^ stream
)
public:
static unsigned long long ReadDiffTimeMcs(
    Stream^ stream
)
static member ReadDiffTimeMcs :
        stream : Stream -> uint64
static member ReadDiffTimeMcs :
        stream : Stream -> uint64

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online UInt64
See Also
SecDBPrimitives Class
SecDBPrimitives Members
NFX.Financial.Market.SecDb Namespace


SecDBPrimitives.ReadDouble Method

SecDBPrimitives ReadDouble Method NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static double ReadDouble(
    Stream stream
)
public static double ReadDouble(
    Stream stream
)
Public Shared Function ReadDouble (
    stream As Stream
) As Double
Public Shared Function ReadDouble (
    stream As Stream
) As Double
public:
static double ReadDouble(
    Stream^ stream
)
public:
static double ReadDouble(
    Stream^ stream
)
static member ReadDouble :
        stream : Stream -> float
static member ReadDouble :
        stream : Stream -> float

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online Double
See Also
SecDBPrimitives Class
SecDBPrimitives Members
NFX.Financial.Market.SecDb Namespace


SecDBPrimitives.readFromStream Method

SecDBPrimitives readFromStream Method NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static int readFromStream(
    Stream stream,
    byte[] buffer,
    int count
)
internal static int readFromStream(
    Stream stream,
    byte[] buffer,
    int count
)
Friend Shared Function readFromStream (
    stream As Stream,
    buffer As Byte(),
    count As Integer
) As Integer
Friend Shared Function readFromStream (
    stream As Stream,
    buffer As Byte(),
    count As Integer
) As Integer
internal:
static int readFromStream(
    Stream^ stream,
    array<unsigned char>^ buffer,
    int count
)
internal:
static int readFromStream(
    Stream^ stream,
    array<unsigned char>^ buffer,
    int count
)
internal static member readFromStream :
        stream : Stream *
        buffer : byte[] *
        count : int -> int
internal static member readFromStream :
        stream : Stream *
        buffer : byte[] *
        count : int -> int

Parameters

stream
Type: Online System.IO Stream
buffer
Type: Online System Byte
count
Type: Online System Int32

Return Value

Type: Online Int32
See Also
SecDBPrimitives Class
SecDBPrimitives Members
NFX.Financial.Market.SecDb Namespace


SecDBPrimitives.ReadInt16 Method

SecDBPrimitives ReadInt16 Method NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static short ReadInt16(
    Stream stream
)
public static short ReadInt16(
    Stream stream
)
Public Shared Function ReadInt16 (
    stream As Stream
) As Short
Public Shared Function ReadInt16 (
    stream As Stream
) As Short
public:
static short ReadInt16(
    Stream^ stream
)
public:
static short ReadInt16(
    Stream^ stream
)
static member ReadInt16 :
        stream : Stream -> int16
static member ReadInt16 :
        stream : Stream -> int16

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online Int16
See Also
SecDBPrimitives Class
SecDBPrimitives Members
NFX.Financial.Market.SecDb Namespace


SecDBPrimitives.ReadInt32 Method

SecDBPrimitives ReadInt32 Method NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int ReadInt32(
    Stream stream
)
public static int ReadInt32(
    Stream stream
)
Public Shared Function ReadInt32 (
    stream As Stream
) As Integer
Public Shared Function ReadInt32 (
    stream As Stream
) As Integer
public:
static int ReadInt32(
    Stream^ stream
)
public:
static int ReadInt32(
    Stream^ stream
)
static member ReadInt32 :
        stream : Stream -> int
static member ReadInt32 :
        stream : Stream -> int

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online Int32
See Also
SecDBPrimitives Class
SecDBPrimitives Members
NFX.Financial.Market.SecDb Namespace


SecDBPrimitives.ReadInt64 Method

SecDBPrimitives ReadInt64 Method NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long ReadInt64(
    Stream stream
)
public static long ReadInt64(
    Stream stream
)
Public Shared Function ReadInt64 (
    stream As Stream
) As Long
Public Shared Function ReadInt64 (
    stream As Stream
) As Long
public:
static long long ReadInt64(
    Stream^ stream
)
public:
static long long ReadInt64(
    Stream^ stream
)
static member ReadInt64 :
        stream : Stream -> int64
static member ReadInt64 :
        stream : Stream -> int64

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online Int64
See Also
SecDBPrimitives Class
SecDBPrimitives Members
NFX.Financial.Market.SecDb Namespace


SecDBPrimitives.ReadMidnightSecond Method

SecDBPrimitives ReadMidnightSecond Method NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int ReadMidnightSecond(
    Stream stream
)
public static int ReadMidnightSecond(
    Stream stream
)
Public Shared Function ReadMidnightSecond (
    stream As Stream
) As Integer
Public Shared Function ReadMidnightSecond (
    stream As Stream
) As Integer
public:
static int ReadMidnightSecond(
    Stream^ stream
)
public:
static int ReadMidnightSecond(
    Stream^ stream
)
static member ReadMidnightSecond :
        stream : Stream -> int
static member ReadMidnightSecond :
        stream : Stream -> int

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online Int32
See Also
SecDBPrimitives Class
SecDBPrimitives Members
NFX.Financial.Market.SecDb Namespace


SecDBPrimitives.ReadSLEB128 Method

SecDBPrimitives ReadSLEB128 Method NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long ReadSLEB128(
    Stream stream
)
public static long ReadSLEB128(
    Stream stream
)
Public Shared Function ReadSLEB128 (
    stream As Stream
) As Long
Public Shared Function ReadSLEB128 (
    stream As Stream
) As Long
public:
static long long ReadSLEB128(
    Stream^ stream
)
public:
static long long ReadSLEB128(
    Stream^ stream
)
static member ReadSLEB128 :
        stream : Stream -> int64
static member ReadSLEB128 :
        stream : Stream -> int64

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online Int64
See Also
SecDBPrimitives Class
SecDBPrimitives Members
NFX.Financial.Market.SecDb Namespace


SecDBPrimitives.ReadString Method

SecDBPrimitives ReadString Method NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ReadString(
    Stream stream
)
public static string ReadString(
    Stream stream
)
Public Shared Function ReadString (
    stream As Stream
) As String
Public Shared Function ReadString (
    stream As Stream
) As String
public:
static String^ ReadString(
    Stream^ stream
)
public:
static String^ ReadString(
    Stream^ stream
)
static member ReadString :
        stream : Stream -> string
static member ReadString :
        stream : Stream -> string

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online String
See Also
SecDBPrimitives Class
SecDBPrimitives Members
NFX.Financial.Market.SecDb Namespace


SecDBPrimitives.ReadUInt16 Method

SecDBPrimitives ReadUInt16 Method NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ushort ReadUInt16(
    Stream stream
)
public static ushort ReadUInt16(
    Stream stream
)
Public Shared Function ReadUInt16 (
    stream As Stream
) As UShort
Public Shared Function ReadUInt16 (
    stream As Stream
) As UShort
public:
static unsigned short ReadUInt16(
    Stream^ stream
)
public:
static unsigned short ReadUInt16(
    Stream^ stream
)
static member ReadUInt16 :
        stream : Stream -> uint16
static member ReadUInt16 :
        stream : Stream -> uint16

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online UInt16
See Also
SecDBPrimitives Class
SecDBPrimitives Members
NFX.Financial.Market.SecDb Namespace


SecDBPrimitives.ReadUInt32 Method

SecDBPrimitives ReadUInt32 Method NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static uint ReadUInt32(
    Stream stream
)
public static uint ReadUInt32(
    Stream stream
)
Public Shared Function ReadUInt32 (
    stream As Stream
) As UInteger
Public Shared Function ReadUInt32 (
    stream As Stream
) As UInteger
public:
static unsigned int ReadUInt32(
    Stream^ stream
)
public:
static unsigned int ReadUInt32(
    Stream^ stream
)
static member ReadUInt32 :
        stream : Stream -> uint32
static member ReadUInt32 :
        stream : Stream -> uint32

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online UInt32
See Also
SecDBPrimitives Class
SecDBPrimitives Members
NFX.Financial.Market.SecDb Namespace


SecDBPrimitives.ReadUInt64 Method

SecDBPrimitives ReadUInt64 Method NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ulong ReadUInt64(
    Stream stream
)
public static ulong ReadUInt64(
    Stream stream
)
Public Shared Function ReadUInt64 (
    stream As Stream
) As ULong
Public Shared Function ReadUInt64 (
    stream As Stream
) As ULong
public:
static unsigned long long ReadUInt64(
    Stream^ stream
)
public:
static unsigned long long ReadUInt64(
    Stream^ stream
)
static member ReadUInt64 :
        stream : Stream -> uint64
static member ReadUInt64 :
        stream : Stream -> uint64

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online UInt64
See Also
SecDBPrimitives Class
SecDBPrimitives Members
NFX.Financial.Market.SecDb Namespace


SecDBPrimitives.ReadULEB128 Method

SecDBPrimitives ReadULEB128 Method NFX Class Library

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ulong ReadULEB128(
    Stream stream
)
public static ulong ReadULEB128(
    Stream stream
)
Public Shared Function ReadULEB128 (
    stream As Stream
) As ULong
Public Shared Function ReadULEB128 (
    stream As Stream
) As ULong
public:
static unsigned long long ReadULEB128(
    Stream^ stream
)
public:
static unsigned long long ReadULEB128(
    Stream^ stream
)
static member ReadULEB128 :
        stream : Stream -> uint64
static member ReadULEB128 :
        stream : Stream -> uint64

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online UInt64
See Also
SecDBPrimitives Class
SecDBPrimitives Members
NFX.Financial.Market.SecDb Namespace


StreamID Enumeration

StreamID Enumeration NFX Class Library

Denotes stream types (id). Used in StreamMeta

Namespace: NFX.Financial.Market.SecDb
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum StreamID
public enum StreamID
Public Enumeration StreamID
Public Enumeration StreamID
public enum class StreamID
public enum class StreamID
type StreamID
type StreamID
Members
Member name | Value | Description
Seconds | 1 |
Quotes | 2 |
Trade | 3 |
Order | 4 |
Summary | 5 |
Message | 6 |
See Also
NFX.Financial.Market.SecDb Namespace


NFX.Geometry Namespace

NFX.Geometry Namespace NFX Class Library

Provides various geometry functions/types like Cartesian utilities and polar coordinate support
Classes
 | Class | Description
Public class | CartesianUtils |
Public class | VectorUtils | Provides helper methods dealing with vector graphics
Structures
 | Structure | Description
Public structure | LatLng | Provides support for Latitude/Longitude logic
Public structure | PolarPoint | Represents a point with polar coordinates
Enumerations
 | Enumeration | Description
Public enumeration | MapDirection | Map direction enumeration aka. North, South, East, etc...


CartesianUtils Class

CartesianUtils Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Geometry CartesianUtils

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class CartesianUtils
public static class CartesianUtils
<ExtensionAttribute>
Public NotInheritable Class CartesianUtils
<ExtensionAttribute>
Public NotInheritable Class CartesianUtils
[ExtensionAttribute]
public ref class CartesianUtils abstract sealed
[ExtensionAttribute]
public ref class CartesianUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CartesianUtils =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CartesianUtils =  class end
See Also
CartesianUtils Members
NFX.Geometry Namespace


CartesianUtils Members

CartesianUtils Members NFX Class Library

The CartesianUtils type exposes the following members.
Methods
Name | Description
AngleToMapDirection | Converts a radian angular coordinate into map direction
AzimuthDeg | Calculates azimuth for vector in degrees
AzimuthOfRadix | Calculates azimuth for vector in degrees
AzimuthRad | Calculates azimuth for vector in rads
CalculatePerimeterViolationArea | Calculates an area of an inner rectangle that violates outside perimeter
Distance(Point, Point) | Calculates distance between two points
Distance(PointF, PointF) | Calculates distance between two points
Distance(Int32, Int32, Int32, Int32) | Calculates distance between two points
Distance(Single, Single, Single, Single) | Calculates distance between two points
FindRayFromRectangleCenterSideIntersection | Returns a point of intersection between a ray cast from the center of a rectangle under certain polar coordinate angle and a rectangle side
MapDirectionToAngle | Converts map direction to angular coordinate in radians
PointToPolarPoint | Converts Point to polar coordinate point
ToDeg | Converts radians into degrees
ToRad | Converts degrees into radians
VectorToPolarPoint | Converts vector in 'x1, y1, x2, y2' representation to polar coordinate point
WrapAngle | Modifies an angle by delta value ensuring that resulting angle is always between 0 and 2Pi
Back to Top
Fields
Name | Description
PI_DEGREES | Represents count of degrees in PI
PI_HALF | Pi/2 constant
PI2 | Pi*2 constant
Back to Top
See Also
CartesianUtils Class
NFX.Geometry Namespace


CartesianUtils Fields

CartesianUtils Fields NFX Class Library

The CartesianUtils type exposes the following members.
Fields
Name | Description
PI_DEGREES | Represents count of degrees in PI
PI_HALF | Pi/2 constant
PI2 | Pi*2 constant
Back to Top
See Also
CartesianUtils Class
NFX.Geometry Namespace


CartesianUtils.PI_DEGREES Field

CartesianUtils PI_DEGREES Field NFX Class Library

Represents count of degrees in PI

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double PI_DEGREES
public const double PI_DEGREES
Public Const PI_DEGREES As Double
Public Const PI_DEGREES As Double
public:
literal double PI_DEGREES
public:
literal double PI_DEGREES
static val mutable PI_DEGREES: float
static val mutable PI_DEGREES: float

Field Value

Type: Online Double
See Also
CartesianUtils Class
CartesianUtils Members
NFX.Geometry Namespace


CartesianUtils.PI_HALF Field

CartesianUtils PI_HALF Field NFX Class Library

Pi/2 constant

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double PI_HALF
public const double PI_HALF
Public Const PI_HALF As Double
Public Const PI_HALF As Double
public:
literal double PI_HALF
public:
literal double PI_HALF
static val mutable PI_HALF: float
static val mutable PI_HALF: float

Field Value

Type: Online Double
See Also
CartesianUtils Class
CartesianUtils Members
NFX.Geometry Namespace


CartesianUtils.PI2 Field

CartesianUtils PI2 Field NFX Class Library

Pi*2 constant

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double PI2
public const double PI2
Public Const PI2 As Double
Public Const PI2 As Double
public:
literal double PI2
public:
literal double PI2
static val mutable PI2: float
static val mutable PI2: float

Field Value

Type: Online Double
See Also
CartesianUtils Class
CartesianUtils Members
NFX.Geometry Namespace


CartesianUtils Methods

CartesianUtils Methods NFX Class Library

The CartesianUtils type exposes the following members.
Methods
Name | Description
AngleToMapDirection | Converts a radian angular coordinate into map direction
AzimuthDeg | Calculates azimuth for vector in degrees
AzimuthOfRadix | Calculates azimuth for vector in degrees
AzimuthRad | Calculates azimuth for vector in rads
CalculatePerimeterViolationArea | Calculates an area of an inner rectangle that violates outside perimeter
Distance(Point, Point) | Calculates distance between two points
Distance(PointF, PointF) | Calculates distance between two points
Distance(Int32, Int32, Int32, Int32) | Calculates distance between two points
Distance(Single, Single, Single, Single) | Calculates distance between two points
FindRayFromRectangleCenterSideIntersection | Returns a point of intersection between a ray cast from the center of a rectangle under certain polar coordinate angle and a rectangle side
MapDirectionToAngle | Converts map direction to angular coordinate in radians
PointToPolarPoint | Converts Point to polar coordinate point
ToDeg | Converts radians into degrees
ToRad | Converts degrees into radians
VectorToPolarPoint | Converts vector in 'x1, y1, x2, y2' representation to polar coordinate point
WrapAngle | Modifies an angle by delta value ensuring that resulting angle is always between 0 and 2Pi
Back to Top
See Also
CartesianUtils Class
NFX.Geometry Namespace


CartesianUtils.AngleToMapDirection Method

CartesianUtils AngleToMapDirection Method NFX Class Library

Converts a radian angular coordinate into map direction

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static MapDirection AngleToMapDirection(
    double angle
)
public static MapDirection AngleToMapDirection(
    double angle
)
Public Shared Function AngleToMapDirection (
    angle As Double
) As MapDirection
Public Shared Function AngleToMapDirection (
    angle As Double
) As MapDirection
public:
static MapDirection AngleToMapDirection(
    double angle
)
public:
static MapDirection AngleToMapDirection(
    double angle
)
static member AngleToMapDirection :
        angle : float -> MapDirection
static member AngleToMapDirection :
        angle : float -> MapDirection

Parameters

angle
Type: Online System Double

Return Value

Type: MapDirection
See Also
CartesianUtils Class
CartesianUtils Members
NFX.Geometry Namespace


CartesianUtils.AzimuthDeg Method

CartesianUtils AzimuthDeg Method NFX Class Library

Calculates azimuth for vector in degrees

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static double AzimuthDeg(
    int centerX,
    int centerY,
    int pointX,
    int pointY
)
public static double AzimuthDeg(
    int centerX,
    int centerY,
    int pointX,
    int pointY
)
Public Shared Function AzimuthDeg (
    centerX As Integer,
    centerY As Integer,
    pointX As Integer,
    pointY As Integer
) As Double
Public Shared Function AzimuthDeg (
    centerX As Integer,
    centerY As Integer,
    pointX As Integer,
    pointY As Integer
) As Double
public:
static double AzimuthDeg(
    int centerX,
    int centerY,
    int pointX,
    int pointY
)
public:
static double AzimuthDeg(
    int centerX,
    int centerY,
    int pointX,
    int pointY
)
static member AzimuthDeg :
        centerX : int *
        centerY : int *
        pointX : int *
        pointY : int -> float
static member AzimuthDeg :
        centerX : int *
        centerY : int *
        pointX : int *
        pointY : int -> float

Parameters

centerX
Type: Online System Int32
centerY
Type: Online System Int32
pointX
Type: Online System Int32
pointY
Type: Online System Int32

Return Value

Type: Online Double
See Also
CartesianUtils Class
CartesianUtils Members
NFX.Geometry Namespace


CartesianUtils.AzimuthOfRadix Method

CartesianUtils AzimuthOfRadix Method NFX Class Library

Calculates azimuth for vector in degrees

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int AzimuthOfRadix(
    int centerX,
    int centerY,
    int pointX,
    int pointY,
    int radix
)
public static int AzimuthOfRadix(
    int centerX,
    int centerY,
    int pointX,
    int pointY,
    int radix
)
Public Shared Function AzimuthOfRadix (
    centerX As Integer,
    centerY As Integer,
    pointX As Integer,
    pointY As Integer,
    radix As Integer
) As Integer
Public Shared Function AzimuthOfRadix (
    centerX As Integer,
    centerY As Integer,
    pointX As Integer,
    pointY As Integer,
    radix As Integer
) As Integer
public:
static int AzimuthOfRadix(
    int centerX,
    int centerY,
    int pointX,
    int pointY,
    int radix
)
public:
static int AzimuthOfRadix(
    int centerX,
    int centerY,
    int pointX,
    int pointY,
    int radix
)
static member AzimuthOfRadix :
        centerX : int *
        centerY : int *
        pointX : int *
        pointY : int *
        radix : int -> int
static member AzimuthOfRadix :
        centerX : int *
        centerY : int *
        pointX : int *
        pointY : int *
        radix : int -> int

Parameters

centerX
Type: Online System Int32
centerY
Type: Online System Int32
pointX
Type: Online System Int32
pointY
Type: Online System Int32
radix
Type: Online System Int32

Return Value

Type: Online Int32
See Also
CartesianUtils Class
CartesianUtils Members
NFX.Geometry Namespace


CartesianUtils.AzimuthRad Method

CartesianUtils AzimuthRad Method NFX Class Library

Calculates azimuth for vector in rads

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static double AzimuthRad(
    int centerX,
    int centerY,
    int pointX,
    int pointY
)
public static double AzimuthRad(
    int centerX,
    int centerY,
    int pointX,
    int pointY
)
Public Shared Function AzimuthRad (
    centerX As Integer,
    centerY As Integer,
    pointX As Integer,
    pointY As Integer
) As Double
Public Shared Function AzimuthRad (
    centerX As Integer,
    centerY As Integer,
    pointX As Integer,
    pointY As Integer
) As Double
public:
static double AzimuthRad(
    int centerX,
    int centerY,
    int pointX,
    int pointY
)
public:
static double AzimuthRad(
    int centerX,
    int centerY,
    int pointX,
    int pointY
)
static member AzimuthRad :
        centerX : int *
        centerY : int *
        pointX : int *
        pointY : int -> float
static member AzimuthRad :
        centerX : int *
        centerY : int *
        pointX : int *
        pointY : int -> float

Parameters

centerX
Type: Online System Int32
centerY
Type: Online System Int32
pointX
Type: Online System Int32
pointY
Type: Online System Int32

Return Value

Type: Online Double
See Also
CartesianUtils Class
CartesianUtils Members
NFX.Geometry Namespace


CartesianUtils.CalculatePerimeterViolationArea Method

CartesianUtils CalculatePerimeterViolationArea Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Calculates an area of an inner rectangle that violates outside perimeter

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int CalculatePerimeterViolationArea(
    Rectangle perimeter,
    Rectangle inner
)
public static int CalculatePerimeterViolationArea(
    Rectangle perimeter,
    Rectangle inner
)
Public Shared Function CalculatePerimeterViolationArea (
    perimeter As Rectangle,
    inner As Rectangle
) As Integer
Public Shared Function CalculatePerimeterViolationArea (
    perimeter As Rectangle,
    inner As Rectangle
) As Integer
public:
static int CalculatePerimeterViolationArea(
    Rectangle perimeter,
    Rectangle inner
)
public:
static int CalculatePerimeterViolationArea(
    Rectangle perimeter,
    Rectangle inner
)
static member CalculatePerimeterViolationArea :
        perimeter : Rectangle *
        inner : Rectangle -> int
static member CalculatePerimeterViolationArea :
        perimeter : Rectangle *
        inner : Rectangle -> int

Parameters

perimeter
Type: Online System.Drawing Rectangle
inner
Type: Online System.Drawing Rectangle

Return Value

Type: Online Int32
See Also
CartesianUtils Class
CartesianUtils Members
NFX.Geometry Namespace


CartesianUtils.Distance Method

CartesianUtils Distance Method NFX Class Library

Overload List
Name | Description
Distance(Point, Point) | Calculates distance between two points
Distance(PointF, PointF) | Calculates distance between two points
Distance(Int32, Int32, Int32, Int32) | Calculates distance between two points
Distance(Single, Single, Single, Single) | Calculates distance between two points
Back to Top
See Also
CartesianUtils Class
CartesianUtils Members
NFX.Geometry Namespace


CartesianUtils.Distance Method (Point, Point)

CartesianUtils Distance Method (Point, Point) NFX Class Library

[This is preliminary documentation and is subject to change.]

Calculates distance between two points

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Distance(
    Point p1,
    Point p2
)
public static int Distance(
    Point p1,
    Point p2
)
Public Shared Function Distance (
    p1 As Point,
    p2 As Point
) As Integer
Public Shared Function Distance (
    p1 As Point,
    p2 As Point
) As Integer
public:
static int Distance(
    Point p1,
    Point p2
)
public:
static int Distance(
    Point p1,
    Point p2
)
static member Distance :
        p1 : Point *
        p2 : Point -> int
static member Distance :
        p1 : Point *
        p2 : Point -> int

Parameters

p1
Type: Online System.Drawing Point
p2
Type: Online System.Drawing Point

Return Value

Type: Online Int32
See Also
CartesianUtils Class
CartesianUtils Members
Distance Overload
NFX.Geometry Namespace


CartesianUtils.Distance Method (PointF, PointF)

CartesianUtils Distance Method (PointF, PointF) NFX Class Library

[This is preliminary documentation and is subject to change.]

Calculates distance between two points

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static float Distance(
    PointF p1,
    PointF p2
)
public static float Distance(
    PointF p1,
    PointF p2
)
Public Shared Function Distance (
    p1 As PointF,
    p2 As PointF
) As Single
Public Shared Function Distance (
    p1 As PointF,
    p2 As PointF
) As Single
public:
static float Distance(
    PointF p1,
    PointF p2
)
public:
static float Distance(
    PointF p1,
    PointF p2
)
static member Distance :
        p1 : PointF *
        p2 : PointF -> float32
static member Distance :
        p1 : PointF *
        p2 : PointF -> float32

Parameters

p1
Type: Online System.Drawing PointF
p2
Type: Online System.Drawing PointF

Return Value

Type: Online Single
See Also
CartesianUtils Class
CartesianUtils Members
Distance Overload
NFX.Geometry Namespace


CartesianUtils.Distance Method (Int32, Int32, Int32, Int32)

CartesianUtils Distance Method (Int32, Int32, Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Calculates distance between two points

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Distance(
    int x1,
    int y1,
    int x2,
    int y2
)
public static int Distance(
    int x1,
    int y1,
    int x2,
    int y2
)
Public Shared Function Distance (
    x1 As Integer,
    y1 As Integer,
    x2 As Integer,
    y2 As Integer
) As Integer
Public Shared Function Distance (
    x1 As Integer,
    y1 As Integer,
    x2 As Integer,
    y2 As Integer
) As Integer
public:
static int Distance(
    int x1,
    int y1,
    int x2,
    int y2
)
public:
static int Distance(
    int x1,
    int y1,
    int x2,
    int y2
)
static member Distance :
        x1 : int *
        y1 : int *
        x2 : int *
        y2 : int -> int
static member Distance :
        x1 : int *
        y1 : int *
        x2 : int *
        y2 : int -> int

Parameters

x1
Type: Online System Int32
y1
Type: Online System Int32
x2
Type: Online System Int32
y2
Type: Online System Int32

Return Value

Type: Online Int32
See Also
CartesianUtils Class
CartesianUtils Members
Distance Overload
NFX.Geometry Namespace


CartesianUtils.Distance Method (Single, Single, Single, Single)

CartesianUtils Distance Method (Single, Single, Single, Single) NFX Class Library

[This is preliminary documentation and is subject to change.]

Calculates distance between two points

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static float Distance(
    float x1,
    float y1,
    float x2,
    float y2
)
public static float Distance(
    float x1,
    float y1,
    float x2,
    float y2
)
Public Shared Function Distance (
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single
) As Single
Public Shared Function Distance (
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single
) As Single
public:
static float Distance(
    float x1,
    float y1,
    float x2,
    float y2
)
public:
static float Distance(
    float x1,
    float y1,
    float x2,
    float y2
)
static member Distance :
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 -> float32
static member Distance :
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 -> float32

Parameters

x1
Type: Online System Single
y1
Type: Online System Single
x2
Type: Online System Single
y2
Type: Online System Single

Return Value

Type: Online Single
See Also
CartesianUtils Class
CartesianUtils Members
Distance Overload
NFX.Geometry Namespace


CartesianUtils.FindRayFromRectangleCenterSideIntersection Method

CartesianUtils FindRayFromRectangleCenterSideIntersection Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns a point of intersection between a ray cast from the center of a rectangle under certain polar coordinate angle and a rectangle side

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Point FindRayFromRectangleCenterSideIntersection(
    Rectangle rect,
    double theta
)
public static Point FindRayFromRectangleCenterSideIntersection(
    Rectangle rect,
    double theta
)
Public Shared Function FindRayFromRectangleCenterSideIntersection (
    rect As Rectangle,
    theta As Double
) As Point
Public Shared Function FindRayFromRectangleCenterSideIntersection (
    rect As Rectangle,
    theta As Double
) As Point
public:
static Point FindRayFromRectangleCenterSideIntersection(
    Rectangle rect,
    double theta
)
public:
static Point FindRayFromRectangleCenterSideIntersection(
    Rectangle rect,
    double theta
)
static member FindRayFromRectangleCenterSideIntersection :
        rect : Rectangle *
        theta : float -> Point
static member FindRayFromRectangleCenterSideIntersection :
        rect : Rectangle *
        theta : float -> Point

Parameters

rect
Type: Online System.Drawing Rectangle
theta
Type: Online System Double

Return Value

Type: Online Point
See Also
CartesianUtils Class
CartesianUtils Members
NFX.Geometry Namespace


CartesianUtils.MapDirectionToAngle Method

CartesianUtils MapDirectionToAngle Method NFX Class Library

Converts map direction to angular coordinate in radians

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static double MapDirectionToAngle(
    MapDirection direction
)
public static double MapDirectionToAngle(
    MapDirection direction
)
Public Shared Function MapDirectionToAngle (
    direction As MapDirection
) As Double
Public Shared Function MapDirectionToAngle (
    direction As MapDirection
) As Double
public:
static double MapDirectionToAngle(
    MapDirection direction
)
public:
static double MapDirectionToAngle(
    MapDirection direction
)
static member MapDirectionToAngle :
        direction : MapDirection -> float
static member MapDirectionToAngle :
        direction : MapDirection -> float

Parameters

direction
Type: NFX.Geometry MapDirection

Return Value

Type: Online Double
See Also
CartesianUtils Class
CartesianUtils Members
NFX.Geometry Namespace


CartesianUtils.PointToPolarPoint Method

CartesianUtils PointToPolarPoint Method NFX Class Library

Converts Point to polar coordinate point

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PolarPoint PointToPolarPoint(
    Point center,
    Point point
)
public static PolarPoint PointToPolarPoint(
    Point center,
    Point point
)
Public Shared Function PointToPolarPoint (
    center As Point,
    point As Point
) As PolarPoint
Public Shared Function PointToPolarPoint (
    center As Point,
    point As Point
) As PolarPoint
public:
static PolarPoint PointToPolarPoint(
    Point center,
    Point point
)
public:
static PolarPoint PointToPolarPoint(
    Point center,
    Point point
)
static member PointToPolarPoint :
        center : Point *
        point : Point -> PolarPoint
static member PointToPolarPoint :
        center : Point *
        point : Point -> PolarPoint

Parameters

center
Type: Online System.Drawing Point
point
Type: Online System.Drawing Point

Return Value

Type: PolarPoint
See Also
CartesianUtils Class
CartesianUtils Members
NFX.Geometry Namespace


CartesianUtils.ToDeg Method

CartesianUtils ToDeg Method NFX Class Library

Converts radians into degrees

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static double ToDeg(
    this double radians
)
public static double ToDeg(
    this double radians
)
<ExtensionAttribute>
Public Shared Function ToDeg (
    radians As Double
) As Double
<ExtensionAttribute>
Public Shared Function ToDeg (
    radians As Double
) As Double
public:
[ExtensionAttribute]
static double ToDeg(
    double radians
)
public:
[ExtensionAttribute]
static double ToDeg(
    double radians
)
static member ToDeg :
        radians : float -> float
static member ToDeg :
        radians : float -> float

Parameters

radians
Type: Online System Double

Return Value

Type: Online Double

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Double. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
CartesianUtils Class
CartesianUtils Members
NFX.Geometry Namespace


CartesianUtils.ToRad Method

CartesianUtils ToRad Method NFX Class Library

Converts degrees into radians

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static double ToRad(
    this double degrees
)
public static double ToRad(
    this double degrees
)
<ExtensionAttribute>
Public Shared Function ToRad (
    degrees As Double
) As Double
<ExtensionAttribute>
Public Shared Function ToRad (
    degrees As Double
) As Double
public:
[ExtensionAttribute]
static double ToRad(
    double degrees
)
public:
[ExtensionAttribute]
static double ToRad(
    double degrees
)
static member ToRad :
        degrees : float -> float
static member ToRad :
        degrees : float -> float

Parameters

degrees
Type: Online System Double

Return Value

Type: Online Double

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Double. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
CartesianUtils Class
CartesianUtils Members
NFX.Geometry Namespace


CartesianUtils.VectorToPolarPoint Method

CartesianUtils VectorToPolarPoint Method NFX Class Library

Converts vector in 'x1, y1, x2, y2' representation to polar coordinate point

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PolarPoint VectorToPolarPoint(
    int centerX,
    int centerY,
    int pointX,
    int pointY
)
public static PolarPoint VectorToPolarPoint(
    int centerX,
    int centerY,
    int pointX,
    int pointY
)
Public Shared Function VectorToPolarPoint (
    centerX As Integer,
    centerY As Integer,
    pointX As Integer,
    pointY As Integer
) As PolarPoint
Public Shared Function VectorToPolarPoint (
    centerX As Integer,
    centerY As Integer,
    pointX As Integer,
    pointY As Integer
) As PolarPoint
public:
static PolarPoint VectorToPolarPoint(
    int centerX,
    int centerY,
    int pointX,
    int pointY
)
public:
static PolarPoint VectorToPolarPoint(
    int centerX,
    int centerY,
    int pointX,
    int pointY
)
static member VectorToPolarPoint :
        centerX : int *
        centerY : int *
        pointX : int *
        pointY : int -> PolarPoint
static member VectorToPolarPoint :
        centerX : int *
        centerY : int *
        pointX : int *
        pointY : int -> PolarPoint

Parameters

centerX
Type: Online System Int32
centerY
Type: Online System Int32
pointX
Type: Online System Int32
pointY
Type: Online System Int32

Return Value

Type: PolarPoint
See Also
CartesianUtils Class
CartesianUtils Members
NFX.Geometry Namespace


CartesianUtils.WrapAngle Method

CartesianUtils WrapAngle Method NFX Class Library

Modifies an angle by delta value ensuring that resulting angle is always between 0 and 2Pi

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static double WrapAngle(
    double angle,
    double delta
)
public static double WrapAngle(
    double angle,
    double delta
)
Public Shared Function WrapAngle (
    angle As Double,
    delta As Double
) As Double
Public Shared Function WrapAngle (
    angle As Double,
    delta As Double
) As Double
public:
static double WrapAngle(
    double angle,
    double delta
)
public:
static double WrapAngle(
    double angle,
    double delta
)
static member WrapAngle :
        angle : float *
        delta : float -> float
static member WrapAngle :
        angle : float *
        delta : float -> float

Parameters

angle
Type: Online System Double
delta
Type: Online System Double

Return Value

Type: Online Double
See Also
CartesianUtils Class
CartesianUtils Members
NFX.Geometry Namespace


LatLng Structure

LatLng Structure NFX Class Library

Provides support for Latitude/Longitude logic

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct LatLng : INamed
public struct LatLng : INamed
Public Structure LatLng
    Implements INamed
Public Structure LatLng
    Implements INamed
public value class LatLng : INamed
public value class LatLng : INamed
[<SealedAttribute>]
type LatLng =
    struct
        interface INamed
    end
[<SealedAttribute>]
type LatLng =
    struct
        interface INamed
    end
See Also
LatLng Members
NFX.Geometry Namespace


LatLng Members

LatLng Members NFX Class Library

The LatLng type exposes the following members.
Constructors
 | Name | Description
Public method | LatLng(String, String) | Initializes a new instance of the LatLng class
Public method | LatLng(Double, Double, String) | Initializes a new instance of the LatLng class
Back to Top
Methods
 | Name | Description
Public method | ComponentToString |
Public method | Equals | (Overrides Online ValueType Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HaversineEarthDistanceKm |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
DEG_TO_RAD |
EARTH_CIRCUMFERENCE_KM |
EARTH_DIAMETER_KM |
EARTH_RADIUS_KM |
MAX_LAT |
MAX_LNG |
MIN_LAT |
MIN_LNG |
Back to Top
Properties
 | Name | Description
Public property | Lat |
Public property | Lng |
Public property | Name |
Public property | RadLat |
Public property | RadLng |
Back to Top
See Also
LatLng Structure
NFX.Geometry Namespace


LatLng Constructor

LatLng Constructor NFX Class Library

Overload List
 | Name | Description
Public method | LatLng(String, String) | Initializes a new instance of the LatLng class
Public method | LatLng(Double, Double, String) | Initializes a new instance of the LatLng class
Back to Top
See Also
LatLng Structure
LatLng Members
NFX.Geometry Namespace


LatLng Constructor (String, String)

LatLng Constructor (String, String) NFX Class Library

Initializes a new instance of the LatLng class

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LatLng(
    string val,
    string name = null
)
public LatLng(
    string val,
    string name = null
)
Public Sub New (
    val As String,
    Optional name As String = Nothing
)
Public Sub New (
    val As String,
    Optional name As String = Nothing
)
public:
LatLng(
    String^ val,
    String^ name = nullptr
)
public:
LatLng(
    String^ val,
    String^ name = nullptr
)
new :
        val : string *
        ?name : string
(* Defaults:
        let _name = defaultArg name null
*)
-> LatLng
new :
        val : string *
        ?name : string
(* Defaults:
        let _name = defaultArg name null
*)
-> LatLng

Parameters

val
Type: Online System String
name (Optional)
Type: Online System String
See Also
LatLng Structure
LatLng Members
LatLng Overload
NFX.Geometry Namespace


LatLng Constructor (Double, Double, String)

LatLng Constructor (Double, Double, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LatLng class

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LatLng(
    double lat,
    double lng,
    string name = null
)
public LatLng(
    double lat,
    double lng,
    string name = null
)
Public Sub New (
    lat As Double,
    lng As Double,
    Optional name As String = Nothing
)
Public Sub New (
    lat As Double,
    lng As Double,
    Optional name As String = Nothing
)
public:
LatLng(
    double lat,
    double lng,
    String^ name = nullptr
)
public:
LatLng(
    double lat,
    double lng,
    String^ name = nullptr
)
new :
        lat : float *
        lng : float *
        ?name : string
(* Defaults:
        let _name = defaultArg name null
*)
-> LatLng
new :
        lat : float *
        lng : float *
        ?name : string
(* Defaults:
        let _name = defaultArg name null
*)
-> LatLng

Parameters

lat
Type: Online System Double
lng
Type: Online System Double
name (Optional)
Type: Online System String
See Also
LatLng Structure
LatLng Members
LatLng Overload
NFX.Geometry Namespace


LatLng Fields

LatLng Fields NFX Class Library

The LatLng type exposes the following members.
Fields
Name | Description
DEG_TO_RAD |
EARTH_CIRCUMFERENCE_KM |
EARTH_DIAMETER_KM |
EARTH_RADIUS_KM |
MAX_LAT |
MAX_LNG |
MIN_LAT |
MIN_LNG |
Back to Top
See Also
LatLng Structure
NFX.Geometry Namespace


LatLng.DEG_TO_RAD Field

LatLng DEG_TO_RAD Field NFX Class Library

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double DEG_TO_RAD
public const double DEG_TO_RAD
Public Const DEG_TO_RAD As Double
Public Const DEG_TO_RAD As Double
public:
literal double DEG_TO_RAD
public:
literal double DEG_TO_RAD
static val mutable DEG_TO_RAD: float
static val mutable DEG_TO_RAD: float

Field Value

Type: Online Double
See Also
LatLng Structure
LatLng Members
NFX.Geometry Namespace


LatLng.EARTH_CIRCUMFERENCE_KM Field

LatLng EARTH_CIRCUMFERENCE_KM Field NFX Class Library

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double EARTH_CIRCUMFERENCE_KM
public const double EARTH_CIRCUMFERENCE_KM
Public Const EARTH_CIRCUMFERENCE_KM As Double
Public Const EARTH_CIRCUMFERENCE_KM As Double
public:
literal double EARTH_CIRCUMFERENCE_KM
public:
literal double EARTH_CIRCUMFERENCE_KM
static val mutable EARTH_CIRCUMFERENCE_KM: float
static val mutable EARTH_CIRCUMFERENCE_KM: float

Field Value

Type: Online Double
See Also
LatLng Structure
LatLng Members
NFX.Geometry Namespace


LatLng.EARTH_DIAMETER_KM Field

LatLng EARTH_DIAMETER_KM Field NFX Class Library

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double EARTH_DIAMETER_KM
public const double EARTH_DIAMETER_KM
Public Const EARTH_DIAMETER_KM As Double
Public Const EARTH_DIAMETER_KM As Double
public:
literal double EARTH_DIAMETER_KM
public:
literal double EARTH_DIAMETER_KM
static val mutable EARTH_DIAMETER_KM: float
static val mutable EARTH_DIAMETER_KM: float

Field Value

Type: Online Double
See Also
LatLng Structure
LatLng Members
NFX.Geometry Namespace


LatLng.EARTH_RADIUS_KM Field

LatLng EARTH_RADIUS_KM Field NFX Class Library

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double EARTH_RADIUS_KM
public const double EARTH_RADIUS_KM
Public Const EARTH_RADIUS_KM As Double
Public Const EARTH_RADIUS_KM As Double
public:
literal double EARTH_RADIUS_KM
public:
literal double EARTH_RADIUS_KM
static val mutable EARTH_RADIUS_KM: float
static val mutable EARTH_RADIUS_KM: float

Field Value

Type: Online Double
See Also
LatLng Structure
LatLng Members
NFX.Geometry Namespace


LatLng.MAX_LAT Field

LatLng MAX_LAT Field NFX Class Library

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double MAX_LAT
public const double MAX_LAT
Public Const MAX_LAT As Double
Public Const MAX_LAT As Double
public:
literal double MAX_LAT
public:
literal double MAX_LAT
static val mutable MAX_LAT: float
static val mutable MAX_LAT: float

Field Value

Type: Online Double
See Also
LatLng Structure
LatLng Members
NFX.Geometry Namespace


LatLng.MAX_LNG Field

LatLng MAX_LNG Field NFX Class Library

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double MAX_LNG
public const double MAX_LNG
Public Const MAX_LNG As Double
Public Const MAX_LNG As Double
public:
literal double MAX_LNG
public:
literal double MAX_LNG
static val mutable MAX_LNG: float
static val mutable MAX_LNG: float

Field Value

Type: Online Double
See Also
LatLng Structure
LatLng Members
NFX.Geometry Namespace


LatLng.MIN_LAT Field

LatLng MIN_LAT Field NFX Class Library

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double MIN_LAT
public const double MIN_LAT
Public Const MIN_LAT As Double
Public Const MIN_LAT As Double
public:
literal double MIN_LAT
public:
literal double MIN_LAT
static val mutable MIN_LAT: float
static val mutable MIN_LAT: float

Field Value

Type: Online Double
See Also
LatLng Structure
LatLng Members
NFX.Geometry Namespace


LatLng.MIN_LNG Field

LatLng MIN_LNG Field NFX Class Library

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double MIN_LNG
public const double MIN_LNG
Public Const MIN_LNG As Double
Public Const MIN_LNG As Double
public:
literal double MIN_LNG
public:
literal double MIN_LNG
static val mutable MIN_LNG: float
static val mutable MIN_LNG: float

Field Value

Type: Online Double
See Also
LatLng Structure
LatLng Members
NFX.Geometry Namespace


LatLng Methods

LatLng Methods NFX Class Library

The LatLng type exposes the following members.
Methods
 | Name | Description
Public method | ComponentToString |
Public method | Equals | (Overrides Online ValueType Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HaversineEarthDistanceKm |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LatLng Structure
NFX.Geometry Namespace


LatLng.ComponentToString Method

LatLng ComponentToString Method NFX Class Library

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ComponentToString(
    double degVal
)
public string ComponentToString(
    double degVal
)
Public Function ComponentToString (
    degVal As Double
) As String
Public Function ComponentToString (
    degVal As Double
) As String
public:
String^ ComponentToString(
    double degVal
)
public:
String^ ComponentToString(
    double degVal
)
member ComponentToString :
        degVal : float -> string
member ComponentToString :
        degVal : float -> string

Parameters

degVal
Type: Online System Double

Return Value

Type: Online String
See Also
LatLng Structure
LatLng Members
NFX.Geometry Namespace


LatLng.Equals Method

LatLng Equals Method NFX Class Library

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
LatLng Structure
LatLng Members
NFX.Geometry Namespace


LatLng.GetHashCode Method

LatLng GetHashCode Method NFX Class Library

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
LatLng Structure
LatLng Members
NFX.Geometry Namespace


LatLng.HaversineEarthDistanceKm Method

LatLng HaversineEarthDistanceKm Method NFX Class Library

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double HaversineEarthDistanceKm(
    LatLng other
)
public double HaversineEarthDistanceKm(
    LatLng other
)
Public Function HaversineEarthDistanceKm (
    other As LatLng
) As Double
Public Function HaversineEarthDistanceKm (
    other As LatLng
) As Double
public:
double HaversineEarthDistanceKm(
    LatLng other
)
public:
double HaversineEarthDistanceKm(
    LatLng other
)
member HaversineEarthDistanceKm :
        other : LatLng -> float
member HaversineEarthDistanceKm :
        other : LatLng -> float

Parameters

other
Type: NFX.Geometry LatLng

Return Value

Type: Online Double
See Also
LatLng Structure
LatLng Members
NFX.Geometry Namespace


LatLng.ToString Method

LatLng ToString Method NFX Class Library

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
LatLng Structure
LatLng Members
NFX.Geometry Namespace


LatLng Properties

LatLng Properties NFX Class Library

The LatLng type exposes the following members.
Properties
 | Name | Description
Public property | Lat |
Public property | Lng |
Public property | Name |
Public property | RadLat |
Public property | RadLng |
Back to Top
See Also
LatLng Structure
NFX.Geometry Namespace


LatLng.Lat Property

LatLng Lat Property NFX Class Library

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double Lat { get; private set; }
public double Lat { get; private set; }
Public Property Lat As Double
    Get
    Private Set
Public Property Lat As Double
    Get
    Private Set
public:
property double Lat {
    double get ();
    private: void set (double value);
}
public:
property double Lat {
    double get ();
    private: void set (double value);
}
member Lat : float with get, private set
member Lat : float with get, private set

Property Value

Type: Online Double
See Also
LatLng Structure
LatLng Members
NFX.Geometry Namespace


LatLng.Lng Property

LatLng Lng Property NFX Class Library

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double Lng { get; private set; }
public double Lng { get; private set; }
Public Property Lng As Double
    Get
    Private Set
Public Property Lng As Double
    Get
    Private Set
public:
property double Lng {
    double get ();
    private: void set (double value);
}
public:
property double Lng {
    double get ();
    private: void set (double value);
}
member Lng : float with get, private set
member Lng : float with get, private set

Property Value

Type: Online Double
See Also
LatLng Structure
LatLng Members
NFX.Geometry Namespace


LatLng.Name Property

LatLng Name Property NFX Class Library

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
LatLng Structure
LatLng Members
NFX.Geometry Namespace


LatLng.RadLat Property

LatLng RadLat Property NFX Class Library

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double RadLat { get; }
public double RadLat { get; }
Public ReadOnly Property RadLat As Double
    Get
Public ReadOnly Property RadLat As Double
    Get
public:
property double RadLat {
    double get ();
}
public:
property double RadLat {
    double get ();
}
member RadLat : float with get
member RadLat : float with get

Property Value

Type: Online Double
See Also
LatLng Structure
LatLng Members
NFX.Geometry Namespace


LatLng.RadLng Property

LatLng RadLng Property NFX Class Library

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double RadLng { get; }
public double RadLng { get; }
Public ReadOnly Property RadLng As Double
    Get
Public ReadOnly Property RadLng As Double
    Get
public:
property double RadLng {
    double get ();
}
public:
property double RadLng {
    double get ();
}
member RadLng : float with get
member RadLng : float with get

Property Value

Type: Online Double
See Also
LatLng Structure
LatLng Members
NFX.Geometry Namespace


MapDirection Enumeration

MapDirection Enumeration NFX Class Library

Map direction enumeration aka. North, South, East, etc...

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum MapDirection
public enum MapDirection
Public Enumeration MapDirection
Public Enumeration MapDirection
public enum class MapDirection
public enum class MapDirection
type MapDirection
type MapDirection
Members
Member name | Value | Description
North | 0 |
NorthEast | 1 |
East | 2 |
SouthEast | 3 |
South | 4 |
SouthWest | 5 |
West | 6 |
NorthWest | 7 |
See Also
NFX.Geometry Namespace


PolarPoint Structure

PolarPoint Structure NFX Class Library

Represents a point with polar coordinates

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct PolarPoint
public struct PolarPoint
Public Structure PolarPoint
Public Structure PolarPoint
public value class PolarPoint
public value class PolarPoint
[<SealedAttribute>]
type PolarPoint =  struct end
[<SealedAttribute>]
type PolarPoint =  struct end
See Also
PolarPoint Members
NFX.Geometry Namespace


PolarPoint Members

PolarPoint Members NFX Class Library

The PolarPoint type exposes the following members.
Constructors
 | Name | Description
Public method | PolarPoint(Double, Double) | Initializes polar coordinates
Public method | PolarPoint(Point, Point) | Initializes polar coordinates from 2-d cartesian coordinates
Public method | PolarPoint(Int32, Int32, Int32, Int32) | Initializes polar coordinates from 2-d cartesian coordinates of 'x1, y1, x2, y2' format
Back to Top
Methods
 | Name | Description
Public method | Equals | (Overrides Online ValueType Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Operators
Name | Description
Equality |
Inequality |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Point | Returns polar coordinate converted to 2-d cartesian coordinates. Coordinates are relative to 0,0 of the angle base vertex
Public property | R | R coordinate component which is coordinate distance from point of coordinates origin
Public property | Theta | Angular azimuth coordinate component. An angle must be between 0 and 2Pi. Note: Due to screen Y coordinate going from top to bottom (in usual orientation) Theta angle may be reversed, that is - be positive in the lower half coordinate plane. Please refer to: http://en.wikipedia.org/wiki/Polar_coordinates
Back to Top
See Also
PolarPoint Structure
NFX.Geometry Namespace


PolarPoint Constructor

PolarPoint Constructor NFX Class Library

Overload List
 | Name | Description
Public method | PolarPoint(Double, Double) | Initializes polar coordinates
Public method | PolarPoint(Point, Point) | Initializes polar coordinates from 2-d cartesian coordinates
Public method | PolarPoint(Int32, Int32, Int32, Int32) | Initializes polar coordinates from 2-d cartesian coordinates of 'x1, y1, x2, y2' format
Back to Top
See Also
PolarPoint Structure
PolarPoint Members
NFX.Geometry Namespace


PolarPoint Constructor (Double, Double)

PolarPoint Constructor (Double, Double) NFX Class Library

Initializes polar coordinates

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PolarPoint(
    double r,
    double theta
)
public PolarPoint(
    double r,
    double theta
)
Public Sub New (
    r As Double,
    theta As Double
)
Public Sub New (
    r As Double,
    theta As Double
)
public:
PolarPoint(
    double r,
    double theta
)
public:
PolarPoint(
    double r,
    double theta
)
new :
        r : float *
        theta : float -> PolarPoint
new :
        r : float *
        theta : float -> PolarPoint

Parameters

r
Type: Online System Double
theta
Type: Online System Double
See Also
PolarPoint Structure
PolarPoint Members
PolarPoint Overload
NFX.Geometry Namespace


PolarPoint Constructor (Point, Point)

PolarPoint Constructor (Point, Point) NFX Class Library

Initializes polar coordinates from 2-d cartesian coordinates

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PolarPoint(
    Point center,
    Point point
)
public PolarPoint(
    Point center,
    Point point
)
Public Sub New (
    center As Point,
    point As Point
)
Public Sub New (
    center As Point,
    point As Point
)
public:
PolarPoint(
    Point center,
    Point point
)
public:
PolarPoint(
    Point center,
    Point point
)
new :
        center : Point *
        point : Point -> PolarPoint
new :
        center : Point *
        point : Point -> PolarPoint

Parameters

center
Type: Online System.Drawing Point
point
Type: Online System.Drawing Point
See Also
PolarPoint Structure
PolarPoint Members
PolarPoint Overload
NFX.Geometry Namespace


PolarPoint Constructor (Int32, Int32, Int32, Int32)

PolarPoint Constructor (Int32, Int32, Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes polar coordinates from 2-d cartesian coordinates of 'x1, y1, x2, y2' format

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PolarPoint(
    int x1,
    int y1,
    int x2,
    int y2
)
public PolarPoint(
    int x1,
    int y1,
    int x2,
    int y2
)
Public Sub New (
    x1 As Integer,
    y1 As Integer,
    x2 As Integer,
    y2 As Integer
)
Public Sub New (
    x1 As Integer,
    y1 As Integer,
    x2 As Integer,
    y2 As Integer
)
public:
PolarPoint(
    int x1,
    int y1,
    int x2,
    int y2
)
public:
PolarPoint(
    int x1,
    int y1,
    int x2,
    int y2
)
new :
        x1 : int *
        y1 : int *
        x2 : int *
        y2 : int -> PolarPoint
new :
        x1 : int *
        y1 : int *
        x2 : int *
        y2 : int -> PolarPoint

Parameters

x1
Type: Online System Int32
y1
Type: Online System Int32
x2
Type: Online System Int32
y2
Type: Online System Int32
See Also
PolarPoint Structure
PolarPoint Members
PolarPoint Overload
NFX.Geometry Namespace


PolarPoint Methods

PolarPoint Methods NFX Class Library

The PolarPoint type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online ValueType Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PolarPoint Structure
NFX.Geometry Namespace


PolarPoint.Equals Method

PolarPoint Equals Method NFX Class Library

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
PolarPoint Structure
PolarPoint Members
NFX.Geometry Namespace


PolarPoint.GetHashCode Method

PolarPoint GetHashCode Method NFX Class Library

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
PolarPoint Structure
PolarPoint Members
NFX.Geometry Namespace


PolarPoint.ToString Method

PolarPoint ToString Method NFX Class Library

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
PolarPoint Structure
PolarPoint Members
NFX.Geometry Namespace


PolarPoint Operators

PolarPoint Operators NFX Class Library

The PolarPoint type exposes the following members.
Operators
Name | Description
Equality |
Inequality |
Back to Top
See Also
PolarPoint Structure
NFX.Geometry Namespace


PolarPoint.Equality Operator

PolarPoint Equality Operator NFX Class Library

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    PolarPoint left,
    PolarPoint right
)
public static bool operator ==(
    PolarPoint left,
    PolarPoint right
)
Public Shared Operator = (
    left As PolarPoint,
    right As PolarPoint
) As Boolean
Public Shared Operator = (
    left As PolarPoint,
    right As PolarPoint
) As Boolean
public:
static bool operator ==(
    PolarPoint left,
    PolarPoint right
)
public:
static bool operator ==(
    PolarPoint left,
    PolarPoint right
)
static let inline (=)
        left : PolarPoint *
        right : PolarPoint  : bool
static let inline (=)
        left : PolarPoint *
        right : PolarPoint  : bool

Parameters

left
Type: NFX.Geometry PolarPoint
right
Type: NFX.Geometry PolarPoint

Return Value

Type: Online Boolean
See Also
PolarPoint Structure
PolarPoint Members
NFX.Geometry Namespace


PolarPoint.Inequality Operator

PolarPoint Inequality Operator NFX Class Library

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    PolarPoint left,
    PolarPoint right
)
public static bool operator !=(
    PolarPoint left,
    PolarPoint right
)
Public Shared Operator <> (
    left As PolarPoint,
    right As PolarPoint
) As Boolean
Public Shared Operator <> (
    left As PolarPoint,
    right As PolarPoint
) As Boolean
public:
static bool operator !=(
    PolarPoint left,
    PolarPoint right
)
public:
static bool operator !=(
    PolarPoint left,
    PolarPoint right
)
static let inline (<>)
        left : PolarPoint *
        right : PolarPoint  : bool
static let inline (<>)
        left : PolarPoint *
        right : PolarPoint  : bool

Parameters

left
Type: NFX.Geometry PolarPoint
right
Type: NFX.Geometry PolarPoint

Return Value

Type: Online Boolean
See Also
PolarPoint Structure
PolarPoint Members
NFX.Geometry Namespace


PolarPoint Properties

PolarPoint Properties NFX Class Library

The PolarPoint type exposes the following members.
Properties
 | Name | Description
Public property | Point | Returns polar coordinate converted to 2-d cartesian coordinates. Coordinates are relative to 0,0 of the angle base vertex
Public property | R | R coordinate component which is coordinate distance from point of coordinates origin
Public property | Theta | Angular azimuth coordinate component. An angle must be between 0 and 2Pi. Note: Due to screen Y coordinate going from top to bottom (in usual orientation) Theta angle may be reversed, that is - be positive in the lower half coordinate plane. Please refer to: http://en.wikipedia.org/wiki/Polar_coordinates
Back to Top
See Also
PolarPoint Structure
NFX.Geometry Namespace


PolarPoint.Point Property

PolarPoint Point Property NFX Class Library

Returns polar coordinate converted to 2-d cartesian coordinates. Coordinates are relative to 0,0 of the angle base vertex

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Point Point { get; }
public Point Point { get; }
Public ReadOnly Property Point As Point
    Get
Public ReadOnly Property Point As Point
    Get
public:
property Point Point {
    Point get ();
}
public:
property Point Point {
    Point get ();
}
member Point : Point with get
member Point : Point with get

Property Value

Type: Online Point
See Also
PolarPoint Structure
PolarPoint Members
NFX.Geometry Namespace


PolarPoint.R Property

PolarPoint R Property NFX Class Library

R coordinate component which is coordinate distance from point of coordinates origin

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double R { get; set; }
public double R { get; set; }
Public Property R As Double
    Get
    Set
Public Property R As Double
    Get
    Set
public:
property double R {
    double get ();
    void set (double value);
}
public:
property double R {
    double get ();
    void set (double value);
}
member R : float with get, set
member R : float with get, set

Property Value

Type: Online Double
See Also
PolarPoint Structure
PolarPoint Members
NFX.Geometry Namespace


PolarPoint.Theta Property

PolarPoint Theta Property NFX Class Library

Angular azimuth coordinate component. An angle must be between 0 and 2Pi. Note: Due to screen Y coordinate going from top to bottom (in usual orientation) Theta angle may be reversed, that is - be positive in the lower half coordinate plane. Please refer to: http://en.wikipedia.org/wiki/Polar_coordinates

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double Theta { get; set; }
public double Theta { get; set; }
Public Property Theta As Double
    Get
    Set
Public Property Theta As Double
    Get
    Set
public:
property double Theta {
    double get ();
    void set (double value);
}
public:
property double Theta {
    double get ();
    void set (double value);
}
member Theta : float with get, set
member Theta : float with get, set

Property Value

Type: Online Double
See Also
PolarPoint Structure
PolarPoint Members
NFX.Geometry Namespace


VectorUtils Class

VectorUtils Class NFX Class Library

Provides helper methods dealing with vector graphics
Inheritance Hierarchy
Online System Object
NFX.Geometry VectorUtils

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class VectorUtils
public static class VectorUtils
Public NotInheritable Class VectorUtils
Public NotInheritable Class VectorUtils
public ref class VectorUtils abstract sealed
public ref class VectorUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type VectorUtils =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type VectorUtils =  class end
See Also
VectorUtils Members
NFX.Geometry Namespace


VectorUtils Members

VectorUtils Members NFX Class Library

The VectorUtils type exposes the following members.
Methods
Name | Description
InflateBalloon(Rectangle , Point , Int32) | Inflates balloon body and target point
InflateBalloon(Rectangle , Point , Int32, Int32) | Inflates balloon body and target point
VectorizeBalloon | Calculates callout balloon vertexes suitable for curve drawing
Back to Top
See Also
VectorUtils Class
NFX.Geometry Namespace


VectorUtils Methods

VectorUtils Methods NFX Class Library

The VectorUtils type exposes the following members.
Methods
Name | Description
InflateBalloon(Rectangle , Point , Int32) | Inflates balloon body and target point
InflateBalloon(Rectangle , Point , Int32, Int32) | Inflates balloon body and target point
VectorizeBalloon | Calculates callout balloon vertexes suitable for curve drawing
Back to Top
See Also
VectorUtils Class
NFX.Geometry Namespace


VectorUtils.InflateBalloon Method

VectorUtils InflateBalloon Method NFX Class Library

Overload List
Name | Description
InflateBalloon(Rectangle , Point , Int32) | Inflates balloon body and target point
InflateBalloon(Rectangle , Point , Int32, Int32) | Inflates balloon body and target point
Back to Top
See Also
VectorUtils Class
VectorUtils Members
NFX.Geometry Namespace


VectorUtils.InflateBalloon Method (Rectangle, Point, Int32)

VectorUtils InflateBalloon Method (Rectangle , Point , Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Inflates balloon body and target point

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void InflateBalloon(
    ref Rectangle body,
    ref Point target,
    int delta
)
public static void InflateBalloon(
    ref Rectangle body,
    ref Point target,
    int delta
)
Public Shared Sub InflateBalloon (
    ByRef body As Rectangle,
    ByRef target As Point,
    delta As Integer
)
Public Shared Sub InflateBalloon (
    ByRef body As Rectangle,
    ByRef target As Point,
    delta As Integer
)
public:
static void InflateBalloon(
    Rectangle% body,
    Point% target,
    int delta
)
public:
static void InflateBalloon(
    Rectangle% body,
    Point% target,
    int delta
)
static member InflateBalloon :
        body : Rectangle byref *
        target : Point byref *
        delta : int -> unit
static member InflateBalloon :
        body : Rectangle byref *
        target : Point byref *
        delta : int -> unit

Parameters

body
Type: Online System.Drawing Rectangle
target
Type: Online System.Drawing Point
delta
Type: Online System Int32
See Also
VectorUtils Class
VectorUtils Members
InflateBalloon Overload
NFX.Geometry Namespace


VectorUtils.InflateBalloon Method (Rectangle, Point, Int32, Int32)

VectorUtils InflateBalloon Method (Rectangle , Point , Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Inflates balloon body and target point

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void InflateBalloon(
    ref Rectangle body,
    ref Point target,
    int deltaBody,
    int deltaTarget
)
public static void InflateBalloon(
    ref Rectangle body,
    ref Point target,
    int deltaBody,
    int deltaTarget
)
Public Shared Sub InflateBalloon (
    ByRef body As Rectangle,
    ByRef target As Point,
    deltaBody As Integer,
    deltaTarget As Integer
)
Public Shared Sub InflateBalloon (
    ByRef body As Rectangle,
    ByRef target As Point,
    deltaBody As Integer,
    deltaTarget As Integer
)
public:
static void InflateBalloon(
    Rectangle% body,
    Point% target,
    int deltaBody,
    int deltaTarget
)
public:
static void InflateBalloon(
    Rectangle% body,
    Point% target,
    int deltaBody,
    int deltaTarget
)
static member InflateBalloon :
        body : Rectangle byref *
        target : Point byref *
        deltaBody : int *
        deltaTarget : int -> unit
static member InflateBalloon :
        body : Rectangle byref *
        target : Point byref *
        deltaBody : int *
        deltaTarget : int -> unit

Parameters

body
Type: Online System.Drawing Rectangle
target
Type: Online System.Drawing Point
deltaBody
Type: Online System Int32
deltaTarget
Type: Online System Int32
See Also
VectorUtils Class
VectorUtils Members
InflateBalloon Overload
NFX.Geometry Namespace


VectorUtils.VectorizeBalloon Method

VectorUtils VectorizeBalloon Method NFX Class Library

Calculates callout balloon vertexes suitable for curve drawing

Namespace: NFX.Geometry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Point[] VectorizeBalloon(
    Rectangle body,
    Point target,
    double legSweep
)
public static Point[] VectorizeBalloon(
    Rectangle body,
    Point target,
    double legSweep
)
Public Shared Function VectorizeBalloon (
    body As Rectangle,
    target As Point,
    legSweep As Double
) As Point()
Public Shared Function VectorizeBalloon (
    body As Rectangle,
    target As Point,
    legSweep As Double
) As Point()
public:
static array<Point>^ VectorizeBalloon(
    Rectangle body,
    Point target,
    double legSweep
)
public:
static array<Point>^ VectorizeBalloon(
    Rectangle body,
    Point target,
    double legSweep
)
static member VectorizeBalloon :
        body : Rectangle *
        target : Point *
        legSweep : float -> Point[]
static member VectorizeBalloon :
        body : Rectangle *
        target : Point *
        legSweep : float -> Point[]

Parameters

body
Type: Online System.Drawing Rectangle
Balloon body coordinates
target
Type: Online System.Drawing Point
A point of balloon leg attachment
legSweep
Type: Online System Double
Length of balloon leg attachment breach at balloon body edge, expressed in radians (arc length). A value such as PI/16 yields good results

Return Value

Type: Online Point
An array of vertex points
See Also
VectorUtils Class
VectorUtils Members
NFX.Geometry Namespace


NFX.Glue Namespace

NFX.Glue Namespace NFX Class Library

Provides master contract stipulations and native implementations for distributed component communication technology. "Glue" is used to glue contract endpoints between hosts
Classes
Class | Description
Public class ArgsMarshallingAttribute
Decorates methods stipulating type of RequestMsg-derivative used for method call arguments marshalling
Public class AuthenticationSupportAttribute
Indicates that contract supports authentication using AuthenticationHeader. When header is passed then Glue server will use its data to set user context through Application.SecurityManager. If this attribute not set then Glue runtime will ignore AuthenticationHeader
Public class Binding
Represents a particular named binding. Binding type defines a protocol by implementing a transport instance management strategy that support particular technology, such as blocking TCP or async ZeroMQ. Binding instance retains state/config information about all transports and has logic for Node's host:service resolution. Bindings are services, meaning - they can have state/threads that manage transport channels that operate under binding
Public class Bindings
A registry of Binding-derived instances
Public class Call
Describes a flow of events originating from a Glue client call
Public class CallReactor
Facilititates execution of asynchronous client calls and their corresponding callback functions. This class introduces callback execution latency and is handy for cases where eventual event flow need to execute regardless of timing. The latency depends on other callback implementation as the reactor services all calls from a single thread
Public class CallSlot
Represents a class that is immediately returned after transport sends RequestMsg. This class provides CallStatus and RequestID properties where the later is used to match the incoming ResponseMsg. CallSlots are kinds of "spirit-less" mailboxes that keep state about the call, but do not posess any threads/call events. Working with CallSlots from calling code's existing thread of execution is the most efficient way of working with Glue (in high load cases), as it does not create extra object instances (tasks do) for asynchronous coordination and continuation. It is possible to obtain an instance of CallSlot.AsTask in which case that instance is registered with the framework-internal reactor so task does complete normally even on timeout, however, in high-throughput apps (10K+ calls per second) this method is not the most efficient one as it allocates additional objects (task, list entry etc.) that eventually increase GC load for long runs. Note: A 3.2 Ghz 4-Core I7 server with 8Gb of ram can easily handle 40K 2-way calls a second (given little business server logic and simple payload). See also: CallReactor class
Public class ClientCallException
Thrown by the Glue framework when clients try to perfom a call but that action fails
Public class ClientEndPoint
Represents an ancestor for client classes that make calls to server endpoints. This and descendant classes are thread safe ONLY for making non-constructing/destructing remote calls, unless ReserveTransport is set to true in which case no operation is thread safe
Public class ClientMsgInspectionException
Thrown by the Glue framework when client message inspector fails with exception
Public class | ClientTransport
Public class | ClientTransport TBinding
Public class ConstructorAttribute
Decorates methods that initialize instance of the server class and retain class instance in the server runtime
Public class DestructorAttribute
Decorates methods that finalize instance of the server class and release class instance in the server runtime
Public class EndPoint
Abstarction of server and client endpoints. And endpoint is a logically-connected entity per: ABC rule - Address/Binding/Contract(s)
Public class GlueComponentService
Provides base functionality for internal glue component implementations
Public class GluedAttribute
Decorates interfaces that represent glued contract points
Public class GlueException
Base exception thrown by the Glue framework
Public class InvalidGlueOperationException
Base exception thrown by the Glue framework when some operations are invoked that do not apply
Public class LifeCycleAttribute
Specifies the instance mode and timeout values for server classes that implement the decorated contract. If server class does not support state then timeout is ignored
Public class MessageSizeException
Exception thrown in client/server when there's an attempt to send a too large message
Public class MsgInspectorConfigurator
Provides general configuration reading logic for message inspectors
Public class | NOPGlue
Public class OneWayAttribute
Decorates methods that do not generate response message after execution. They must return void and if exception occurs it is not reported to the caller
Public class ProtocolException
Exception thrown when there are protocol-related errors like deserialization, request message received when response is expected
Public class Provider
Represents a base type for providers - providers are facades for some low-level implementation that transports use, for example ZeroMQ.
Public class Providers
A registry of Provider-derived instances
Public class RemoteException
Base exception thrown by the Glue framework when remote errors are reported back to caller
Public class ServerCallContext
Provides access to server call context. Use to access Headers
Public class ServerContractException
Exception thrown when server could not get contract
Public class ServerEndPoint
Represents a server endpoint that accepts client requests. This is a sealed class
Public class ServerException
Exception thrown in Glue server
Public class ServerInstanceActivationException
Exception thrown when server instance can not be created
Public class ServerMethodInvocationException
Exception thrown when server can not invoke method
Public class ServerNotRunningException
Exception thrown in Glue server when it shuts down/not running
Public class | Servers
Public class | ServerTransport
Public class | ServerTransport TBinding
Public class StatefulServerInstanceDoesNotExistException
Exception thrown when statful server identified is not found/has expired/timed-out
Public class StatefulServerInstanceLockTimeoutException
Exception thrown when statful server instance is not thread safe and could not be locked before set timeout expired
Public class ThreadSafeAttribute
Indicates that server instance should not be lock()-ed by Glue handler because it is implemented in a thread-safe way. This attribute has no effect for Glue servers that are not [LifeCycle(Stateful)], because they are never locked. Singleton servers must be thread-safe by definition so this attribute is not needed for Singleton servers. If the server is implemented in a thread-safe way, then addition of this attribute may give 15-30% performance boost from Glue runtime when many parallel requests are trying to work with the same instance, however this benefit may be nullified by inefficient user locking code within server implementation. Leaving this attribute out is safer
Protected class TimeoutReactor
Internal class that polls call slots for timeout
Public class Transport
Transports are thread-safe and are intended for use by multiple threads from ClientCallReactor and ServerProcessor when bindings operate in OperationFlow.Asynchronous mode. Transports are acquired by the thread that creates them
Structures
Structure Description
Public structure Future T
Provides a higher-level wrapper around CallSlot returned value by Glue. All property accessors evaluate synchronously on the calling thread. This struct should not be used with One-Way calls or calls that return void
Public structure FutureVoid
Provides a higher-level wrapper around CallSlot returned by Glue. All property accessors evaluate synchronously on the calling thread. This struct should not be used with One-Way calls
Public structure Node
Represents a network node. It is a binding, logical address of a host and a service that host provides Nodes are not contract-dependent. The componets of address are not case-sensitive. The form of the address is:
View Colorized Copy to Clipboard Print
binding://host:service
binding://host:service
. The "host" and "service" segment syntaxes depend on binding and may not contain the ':' char. An example of some 'mytest' binding: 'mytest://adr=1.1.1.1,nic=eth001:job,chat,backup'
Interfaces
 | Interface | Description
Public interface | IClientMsgInspector | Inspects messages on the client side. ClientInspectors may be registered on ClientEndPoint, Binding or Glue levels
Public interface | IGlue | Represents a contract for Glue - a technology that provides asynchronous distributed component interconnection
Public interface | IGlueImplementation |
Public interface | IMsgInspector | Denotes an entity that can inspect messages
Public interface | IServerMsgInspector | Inspects messages on the server side. ServerInspectors may be registered on ServerEndPoint, Binding or Glue levels
Enumerations
 | Enumeration | Description
Public enumeration | CallStatus | Stipulates codes returned for contract calls
Public enumeration | DumpDetail | Message/data dumping detail
Public enumeration | LogSrc | Logging sources - client, server, any
Public enumeration | OperationFlow | Stipulates operation flow kind - sync/async
Public enumeration | ServerInstanceMode | Denotes server instance modes - how server instances relate to calls
Public enumeration | TransportKind | Defines kinds of trasport


ArgsMarshallingAttribute Class

ArgsMarshallingAttribute Class NFX Class Library

Decorates methods stipulating type of RequestMsg-derivative used for method call arguments marshalling
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.Glue ArgsMarshallingAttribute

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.Method, Inherited = false, AllowMultiple = false)]
public class ArgsMarshallingAttribute : Attribute
[AttributeUsageAttribute(AttributeTargets.Method, Inherited = false, AllowMultiple = false)]
public class ArgsMarshallingAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Method, Inherited := false, AllowMultiple := false)>
Public Class ArgsMarshallingAttribute
    Inherits Attribute
<AttributeUsageAttribute(AttributeTargets.Method, Inherited := false, AllowMultiple := false)>
Public Class ArgsMarshallingAttribute
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Method, Inherited = false, AllowMultiple = false)]
public ref class ArgsMarshallingAttribute : public Attribute
[AttributeUsageAttribute(AttributeTargets::Method, Inherited = false, AllowMultiple = false)]
public ref class ArgsMarshallingAttribute : public Attribute
[<AttributeUsageAttribute(AttributeTargets.Method, Inherited = false, AllowMultiple = false)>]
type ArgsMarshallingAttribute =
    class
        inherit Attribute
    end
[<AttributeUsageAttribute(AttributeTargets.Method, Inherited = false, AllowMultiple = false)>]
type ArgsMarshallingAttribute =
    class
        inherit Attribute
    end
See Also
ArgsMarshallingAttribute Members
NFX.Glue Namespace


ArgsMarshallingAttribute Members

ArgsMarshallingAttribute Members NFX Class Library

The ArgsMarshallingAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | ArgsMarshallingAttribute | Initializes a new instance of the ArgsMarshallingAttribute class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | RequestMsgType | Thr type of RequestMsg-derivative used to marshall the request arguments
Back to Top
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
ArgsMarshallingAttribute Class
NFX.Glue Namespace


ArgsMarshallingAttribute Constructor

ArgsMarshallingAttribute Constructor NFX Class Library

Initializes a new instance of the ArgsMarshallingAttribute class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ArgsMarshallingAttribute(
    Type requestMsgType
)
public ArgsMarshallingAttribute(
    Type requestMsgType
)
Public Sub New (
    requestMsgType As Type
)
Public Sub New (
    requestMsgType As Type
)
public:
ArgsMarshallingAttribute(
    Type^ requestMsgType
)
public:
ArgsMarshallingAttribute(
    Type^ requestMsgType
)
new :
        requestMsgType : Type -> ArgsMarshallingAttribute
new :
        requestMsgType : Type -> ArgsMarshallingAttribute

Parameters

requestMsgType
Type: Online System Type
See Also
ArgsMarshallingAttribute Class
ArgsMarshallingAttribute Members
NFX.Glue Namespace


ArgsMarshallingAttribute Fields

ArgsMarshallingAttribute Fields NFX Class Library

The ArgsMarshallingAttribute type exposes the following members.
Fields
 | Name | Description
Public field | RequestMsgType | Thr type of RequestMsg-derivative used to marshall the request arguments
Back to Top
See Also
ArgsMarshallingAttribute Class
NFX.Glue Namespace


ArgsMarshallingAttribute.RequestMsgType Field

ArgsMarshallingAttribute RequestMsgType Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Thr type of RequestMsg-derivative used to marshall the request arguments

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Type RequestMsgType
public readonly Type RequestMsgType
Public ReadOnly RequestMsgType As Type
Public ReadOnly RequestMsgType As Type
public:
initonly Type^ RequestMsgType
public:
initonly Type^ RequestMsgType
val RequestMsgType: Type
val RequestMsgType: Type

Field Value

Type: Online Type
See Also
ArgsMarshallingAttribute Class
ArgsMarshallingAttribute Members
NFX.Glue Namespace


ArgsMarshallingAttribute Methods

ArgsMarshallingAttribute Methods NFX Class Library

The ArgsMarshallingAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ArgsMarshallingAttribute Class
NFX.Glue Namespace


ArgsMarshallingAttribute Properties

ArgsMarshallingAttribute Properties NFX Class Library

The ArgsMarshallingAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
ArgsMarshallingAttribute Class
NFX.Glue Namespace


AuthenticationSupportAttribute Class

AuthenticationSupportAttribute Class NFX Class Library

Indicates that contract supports authentication using AuthenticationHeader. When header is passed then Glue server will use its data to set user context through Application.SecurityManager. If this attribute not set then Glue runtime will ignore AuthenticationHeader
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.Glue AuthenticationSupportAttribute

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.Interface, AllowMultiple = false,
    Inherited = false)]
public class AuthenticationSupportAttribute : Attribute
[AttributeUsageAttribute(AttributeTargets.Interface, AllowMultiple = false,
    Inherited = false)]
public class AuthenticationSupportAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Interface, AllowMultiple := false,
    Inherited := false)>
Public Class AuthenticationSupportAttribute
    Inherits Attribute
<AttributeUsageAttribute(AttributeTargets.Interface, AllowMultiple := false,
    Inherited := false)>
Public Class AuthenticationSupportAttribute
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Interface, AllowMultiple = false,
    Inherited = false)]
public ref class AuthenticationSupportAttribute : public Attribute
[AttributeUsageAttribute(AttributeTargets::Interface, AllowMultiple = false,
    Inherited = false)]
public ref class AuthenticationSupportAttribute : public Attribute
[<AttributeUsageAttribute(AttributeTargets.Interface, AllowMultiple = false,
    Inherited = false)>]
type AuthenticationSupportAttribute =
    class
        inherit Attribute
    end
[<AttributeUsageAttribute(AttributeTargets.Interface, AllowMultiple = false,
    Inherited = false)>]
type AuthenticationSupportAttribute =
    class
        inherit Attribute
    end
See Also
AuthenticationSupportAttribute Members
NFX.Glue Namespace


AuthenticationSupportAttribute Members

AuthenticationSupportAttribute Members NFX Class Library

The AuthenticationSupportAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | AuthenticationSupportAttribute | Initializes a new instance of the AuthenticationSupportAttribute class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
AuthenticationSupportAttribute Class
NFX.Glue Namespace


AuthenticationSupportAttribute Constructor

AuthenticationSupportAttribute Constructor NFX Class Library

Initializes a new instance of the AuthenticationSupportAttribute class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AuthenticationSupportAttribute()
public AuthenticationSupportAttribute()
Public Sub New
Public Sub New
public:
AuthenticationSupportAttribute()
public:
AuthenticationSupportAttribute()
new : unit -> AuthenticationSupportAttribute
new : unit -> AuthenticationSupportAttribute
See Also
AuthenticationSupportAttribute Class
AuthenticationSupportAttribute Members
NFX.Glue Namespace


AuthenticationSupportAttribute Methods

AuthenticationSupportAttribute Methods NFX Class Library

The AuthenticationSupportAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
AuthenticationSupportAttribute Class
NFX.Glue Namespace


AuthenticationSupportAttribute Properties

AuthenticationSupportAttribute Properties NFX Class Library

The AuthenticationSupportAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
AuthenticationSupportAttribute Class
NFX.Glue Namespace


Binding Class

Binding Class NFX Class Library

Represents a particular named binding. Binding type defines a protocol by implementing a transport instance management strategy that support particular technology, such as blocking TCP or async ZeroMQ. Binding instance retains state/config information about all transports and has logic for Node's host:service resolution. Bindings are services, meaning - they can have state/threads that manage transport channels that operate under binding
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service IGlueImplementation
NFX.ServiceModel ServiceWithInstrumentationBase IGlueImplementation
NFX.Glue GlueComponentService
NFX.Glue Binding
NFX.Glue.Native InProcBinding
NFX.Glue.Native MpxBinding
NFX.Glue.Native SyncBinding

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Binding : GlueComponentService
public abstract class Binding : GlueComponentService
Public MustInherit Class Binding
    Inherits GlueComponentService
Public MustInherit Class Binding
    Inherits GlueComponentService
public ref class Binding abstract : public GlueComponentService
public ref class Binding abstract : public GlueComponentService
[<AbstractClassAttribute>]
type Binding =
    class
        inherit GlueComponentService
    end
[<AbstractClassAttribute>]
type Binding =
    class
        inherit GlueComponentService
    end
See Also
Binding Members
NFX.Glue Namespace


Binding Members

Binding Members NFX Class Library

The Binding type exposes the following members.
Constructors
 | Name | Description
Protected method | Binding(String) | Initializes a new instance of the Binding class
Protected method | Binding(IGlueImplementation, String, Provider) | Initializes a new instance of the Binding class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | _Register |
Protected method | _Unregister |
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Protected method | AcquireClientTransportForCall | Returns an instance of transport suitable for a call. The implementation may return existing transport or allocate a new instance. The call is thread-safe
Public method | AreNodesIdentical | Returns true when two nodes represent the same binding, host and service identities. The implementation depends on binding, for example some binding may recognize an optional parameter as part of host segment, however that parameter does not change the identity of the node instance
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and binding runtime are running or throws otherwise
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Protected method | CloseServerEndpoint |
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | ConfigureAndStartNewClientTransport | Override to perform custom transport preparation and launch
Protected method | Destructor | (Overrides Service Destructor .)
Public method | DispatchCall | Dispatches a call allocating new or re-using existing transport if needed. The strategy depends on particular Binding implementation. This call is thread-safe
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | (Overrides Service DoAcceptManagerVisit(Object, DateTime).)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Protected method | DumpMsg(Boolean, Msg, ArraySegment Byte ) | Conditionally dumps message to disk
Protected method | DumpMsg(Boolean, Msg, Func ArraySegment Byte ) | Conditionally dumps message to disk where the data is lazily obtained by calling dataFun
Protected method | DumpMsg(Boolean, Msg, Byte , Int32, Int32) | Conditionally dumps message to disk
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetClientCallStatTimeKey | Extracts necessary information from client:request pair that characterizes the particular call for the purpose of call timing
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | MakeNewClientTransport | Factory method - Override to make an instance of a new client transport suitable for particular binding type
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OpenServerEndpoint |
Protected method | ReleaseClientTransportAfterCall | Releases a transport instance that was acquired for call. The implementation may return this instance back to the pool of available transports or deallocate it. The default implementation releases the instance back to the pool
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | TryGetExistingAcquiredTransportPerRemoteNode | Tries to acquire an available client transport to make a call. This method respects binding/transport settings that impose a limit on the number of open concurrent transports and timeouts for acqusition waiting
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | WriteLog | (Inherited from GlueComponentService.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | ATTR_PATH |
 | ATTR_SLASH_PATH |
 | CLIENT_TRANSPORT_COUNT_WAIT_THRESHOLD_DEFAULT |
 | CLIENT_TRANSPORT_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT |
 | CLIENT_TRANSPORT_IDLE_TIMEOUT_MS_DEFAULT |
 | CLIENT_TRANSPORT_MAX_COUNT_DEFAULT |
 | CLIENT_TRANSPORT_MAX_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT |
 | CONFIG_CLIENT_DUMP_ATTR |
 | CONFIG_CLIENT_TRANSPORT_COUNT_WAIT_THRESHOLD_ATTR |
 | CONFIG_CLIENT_TRANSPORT_EXISTING_ACQUISITION_TIMEOUT_MS_ATTR |
 | CONFIG_CLIENT_TRANSPORT_MAX_COUNT_ATTR |
 | CONFIG_CLIENT_TRANSPORT_MAX_EXISTING_ACQUISITION_TIMEOUT_MS_ATTR |
 | CONFIG_CLIENT_TRANSPORT_SECTION |
 | CONFIG_DUMP_FORMAT_ATTR |
 | CONFIG_DUMP_PATH_ATTR |
 | CONFIG_INSTRUMENT_TRANSPORT_STAT_ATTR |
 | CONFIG_SERVER_DUMP_ATTR |
 | CONFIG_SERVER_TRANSPORT_SECTION |
 | CONFIG_STAT_TIMES_EMA_FACTOR_ATTR |
 | CONFIG_TRANSPORT_IDLE_TIMEOUT_MS_ATTR |
 | DEFAULT_STAT_TIMES_EMA_FACTOR | Defines how much smoothing the timing statistics filter does - the lower the number the more smoothing is done. Smoothing makes stat times insensitive to some seldom delays that may happen every now and then
Protected field | m_ClientTransportAllocatorLocks | Hash table of locks used during new transport allocation, must be prime size
Protected field | m_Provider |
Protected field | m_Transports |
 | MAX_STAT_TIMES_EMA_FACTOR |
 | MIN_STAT_TIMES_EMA_FACTOR |
 | SERVER_TRANSPORT_IDLE_TIMEOUT_MS_DEFAULT |
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ClientDump | Turns on/off client message dumping to disk. Turning on dumping has negative effect on performance and consumes resources
Public property | ClientMsgInspectors | Returns client message inspectors for this instance
Public property | ClientTransportCountWaitThreshold | Sets the threshold, expressed as the number of active client transports per remote address, below which binding will always allocate a new instance of client transport without trying/waiting to acquire an existing one. When this number is exceeded then binding will try to acquire an existing client transport instance for up to ClientTransportExistingAcquisitionTimeoutMs milliseconds. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog
Public property | ClientTransportExistingAcquisitionTimeoutMs | Sets the length of interval for the binding trying to acquire existing client transport instance to make a call. When this interval is exhausted then binding tries to allocate a new client transport per remote address, unless other limits prohibit (max transport count). The value has to be greater or equal to zero. NOTE: this property works in conjunction with ClientTransportCoutWaitThreshold, if the number of active client transports is below ClientTransportCoutWaitThreshold, then binding does not wait and allocates a new client transport right away until ClientTransportCoutWaitThreshold limit is reached, then binding will try to acquire existing transport for ClientTransportExistingAcquisitionTimeoutMs milliseconds. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog
Public property | ClientTransportIdleTimeoutMs | Specifies when client transports get auto-closed. Interval is measured in ms. Zero means indefinite/never closed transport. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog
Public property | ClientTransportMaxCount | Imposes a limit on number of active client transports per remote address. Once this limit is reached the binding will block until it can acquire an existing transport instance. Set value to zero to remove the limit. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog
Public property | ClientTransportMaxExistingAcquisitionTimeoutMs | Imposes a timeout for binding trying to get an existing transport instance per remote address. Binding throws ClientCallException when this timeout is exceeded. A value of zero removes the limit
Public property | ClientTransports | Returns all client transports in the binding stack
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | ConfigNode | Returns configuration node for this named instance
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | DumpMsgFormat | Set the format for message dumping
Public property | DumpPath | Set the path for message dumping. Must be an existing navigable path
Public property | EncodingFormat | Returns name of msg format encoding
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | Glue | (Inherited from GlueComponentService.)
Public property | InstrumentationEnabled | Implements IInstrumentable (Inherited from GlueComponentService.)
Public property | InstrumentClientTransportStat | Defines whether client transport statistics is periodically dumped into instrumentation
Public property | InstrumentServerTransportStat | Defines whether server transport statistics is periodically dumped into instrumentation
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | MeasureStatTimes | Defines whether message processing latency should be measured - i.e. messages time-stamped on arrival
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | OperationFlow | Returns sync/async flow that this binding provides
Public property | Provider |
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | ServerDump | Turns on/off server message dumping to disk. Turning on dumping has negative effect on performance and consumes resources
Public property | ServerMsgInspectors | Returns server message inspectors for this instance
Public property | ServerTransportIdleTimeoutMs | Specifies when server transports get auto-closed. Interval is measured in ms. Zero means indefinite/never closed transport. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog
Public property | ServerTransports | Returns all server transports in the binding stack
Public property | StatTimesEMAFactor | Defines how much smoothing the timing statistics filter does - the lower the number the more smoothing is done. Smoothing makes stat times insensitive to some seldom delays that may happen every now and then
Public property | StatTimeTicks | Returns current time in system frequency-dependent ticks. This property is used to measure accurate times and depends on MeasureStatTimes set to true, otherwise 0 is returned
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | Transports | Returns all transports in the binding stack
Back to Top
See Also
Binding Class
NFX.Glue Namespace


Binding Constructor

Binding Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | Binding(String) | Initializes a new instance of the Binding class
Protected method | Binding(IGlueImplementation, String, Provider) | Initializes a new instance of the Binding class
Back to Top
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding Constructor (String)

Binding Constructor (String) NFX Class Library

Initializes a new instance of the Binding class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Binding(
    string name
)
protected Binding(
    string name
)
Protected Sub New (
    name As String
)
Protected Sub New (
    name As String
)
protected:
Binding(
    String^ name
)
protected:
Binding(
    String^ name
)
new :
        name : string -> Binding
new :
        name : string -> Binding

Parameters

name
Type: Online System String
See Also
Binding Class
Binding Members
Binding Overload
NFX.Glue Namespace


Binding Constructor (IGlueImplementation, String, Provider)

Binding Constructor (IGlueImplementation, String, Provider) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Binding class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Binding(
    IGlueImplementation glue,
    string name = null,
    Provider provider = null
)
protected Binding(
    IGlueImplementation glue,
    string name = null,
    Provider provider = null
)
Protected Sub New (
    glue As IGlueImplementation,
    Optional name As String = Nothing,
    Optional provider As Provider = Nothing
)
Protected Sub New (
    glue As IGlueImplementation,
    Optional name As String = Nothing,
    Optional provider As Provider = Nothing
)
protected:
Binding(
    IGlueImplementation^ glue,
    String^ name = nullptr,
    Provider^ provider = nullptr
)
protected:
Binding(
    IGlueImplementation^ glue,
    String^ name = nullptr,
    Provider^ provider = nullptr
)
new :
        glue : IGlueImplementation *
        ?name : string *
        ?provider : Provider
(* Defaults:
        let _name = defaultArg name null
        let _provider = defaultArg provider null
*)
-> Binding
new :
        glue : IGlueImplementation *
        ?name : string *
        ?provider : Provider
(* Defaults:
        let _name = defaultArg name null
        let _provider = defaultArg provider null
*)
-> Binding

Parameters

glue
Type: NFX.Glue IGlueImplementation
name (Optional)
Type: Online System String
provider (Optional)
Type: NFX.Glue Provider
See Also
Binding Class
Binding Members
Binding Overload
NFX.Glue Namespace


Binding Fields

Binding Fields NFX Class Library

The Binding type exposes the following members.
Fields
 | Name | Description
 | ATTR_PATH |
 | ATTR_SLASH_PATH |
 | CLIENT_TRANSPORT_COUNT_WAIT_THRESHOLD_DEFAULT |
 | CLIENT_TRANSPORT_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT |
 | CLIENT_TRANSPORT_IDLE_TIMEOUT_MS_DEFAULT |
 | CLIENT_TRANSPORT_MAX_COUNT_DEFAULT |
 | CLIENT_TRANSPORT_MAX_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT |
 | CONFIG_CLIENT_DUMP_ATTR |
 | CONFIG_CLIENT_TRANSPORT_COUNT_WAIT_THRESHOLD_ATTR |
 | CONFIG_CLIENT_TRANSPORT_EXISTING_ACQUISITION_TIMEOUT_MS_ATTR |
 | CONFIG_CLIENT_TRANSPORT_MAX_COUNT_ATTR |
 | CONFIG_CLIENT_TRANSPORT_MAX_EXISTING_ACQUISITION_TIMEOUT_MS_ATTR |
 | CONFIG_CLIENT_TRANSPORT_SECTION |
 | CONFIG_DUMP_FORMAT_ATTR |
 | CONFIG_DUMP_PATH_ATTR |
 | CONFIG_INSTRUMENT_TRANSPORT_STAT_ATTR |
 | CONFIG_SERVER_DUMP_ATTR |
 | CONFIG_SERVER_TRANSPORT_SECTION |
 | CONFIG_STAT_TIMES_EMA_FACTOR_ATTR |
 | CONFIG_TRANSPORT_IDLE_TIMEOUT_MS_ATTR |
 | DEFAULT_STAT_TIMES_EMA_FACTOR | Defines how much smoothing the timing statistics filter does - the lower the number the more smoothing is done. Smoothing makes stat times insensitive to some seldom delays that may happen every now and then
Protected field | m_ClientTransportAllocatorLocks | Hash table of locks used during new transport allocation, must be prime size
Protected field | m_Provider |
Protected field | m_Transports |
 | MAX_STAT_TIMES_EMA_FACTOR |
 | MIN_STAT_TIMES_EMA_FACTOR |
 | SERVER_TRANSPORT_IDLE_TIMEOUT_MS_DEFAULT |
Back to Top
See Also
Binding Class
NFX.Glue Namespace


Binding.ATTR_PATH Field

Binding ATTR_PATH Field NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ATTR_PATH
public const string ATTR_PATH
Public Const ATTR_PATH As String
Public Const ATTR_PATH As String
public:
literal String^ ATTR_PATH
public:
literal String^ ATTR_PATH
static val mutable ATTR_PATH: string
static val mutable ATTR_PATH: string

Field Value

Type: Online String
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.ATTR_SLASH_PATH Field

Binding ATTR_SLASH_PATH Field NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ATTR_SLASH_PATH
public const string ATTR_SLASH_PATH
Public Const ATTR_SLASH_PATH As String
Public Const ATTR_SLASH_PATH As String
public:
literal String^ ATTR_SLASH_PATH
public:
literal String^ ATTR_SLASH_PATH
static val mutable ATTR_SLASH_PATH: string
static val mutable ATTR_SLASH_PATH: string

Field Value

Type: Online String
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.CLIENT_TRANSPORT_COUNT_WAIT_THRESHOLD_DEFAULT Field

Binding CLIENT_TRANSPORT_COUNT_WAIT_THRESHOLD_DEFAULT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int CLIENT_TRANSPORT_COUNT_WAIT_THRESHOLD_DEFAULT
public const int CLIENT_TRANSPORT_COUNT_WAIT_THRESHOLD_DEFAULT
Public Const CLIENT_TRANSPORT_COUNT_WAIT_THRESHOLD_DEFAULT As Integer
Public Const CLIENT_TRANSPORT_COUNT_WAIT_THRESHOLD_DEFAULT As Integer
public:
literal int CLIENT_TRANSPORT_COUNT_WAIT_THRESHOLD_DEFAULT
public:
literal int CLIENT_TRANSPORT_COUNT_WAIT_THRESHOLD_DEFAULT
static val mutable CLIENT_TRANSPORT_COUNT_WAIT_THRESHOLD_DEFAULT: int
static val mutable CLIENT_TRANSPORT_COUNT_WAIT_THRESHOLD_DEFAULT: int

Field Value

Type: Online Int32
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.CLIENT_TRANSPORT_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT Field

Binding CLIENT_TRANSPORT_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int CLIENT_TRANSPORT_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT
public const int CLIENT_TRANSPORT_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT
Public Const CLIENT_TRANSPORT_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT As Integer
Public Const CLIENT_TRANSPORT_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT As Integer
public:
literal int CLIENT_TRANSPORT_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT
public:
literal int CLIENT_TRANSPORT_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT
static val mutable CLIENT_TRANSPORT_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT: int
static val mutable CLIENT_TRANSPORT_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT: int

Field Value

Type: Online Int32
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.CLIENT_TRANSPORT_IDLE_TIMEOUT_MS_DEFAULT Field

Binding CLIENT_TRANSPORT_IDLE_TIMEOUT_MS_DEFAULT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int CLIENT_TRANSPORT_IDLE_TIMEOUT_MS_DEFAULT
public const int CLIENT_TRANSPORT_IDLE_TIMEOUT_MS_DEFAULT
Public Const CLIENT_TRANSPORT_IDLE_TIMEOUT_MS_DEFAULT As Integer
Public Const CLIENT_TRANSPORT_IDLE_TIMEOUT_MS_DEFAULT As Integer
public:
literal int CLIENT_TRANSPORT_IDLE_TIMEOUT_MS_DEFAULT
public:
literal int CLIENT_TRANSPORT_IDLE_TIMEOUT_MS_DEFAULT
static val mutable CLIENT_TRANSPORT_IDLE_TIMEOUT_MS_DEFAULT: int
static val mutable CLIENT_TRANSPORT_IDLE_TIMEOUT_MS_DEFAULT: int

Field Value

Type: Online Int32
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.CLIENT_TRANSPORT_MAX_COUNT_DEFAULT Field

Binding CLIENT_TRANSPORT_MAX_COUNT_DEFAULT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int CLIENT_TRANSPORT_MAX_COUNT_DEFAULT
public const int CLIENT_TRANSPORT_MAX_COUNT_DEFAULT
Public Const CLIENT_TRANSPORT_MAX_COUNT_DEFAULT As Integer
Public Const CLIENT_TRANSPORT_MAX_COUNT_DEFAULT As Integer
public:
literal int CLIENT_TRANSPORT_MAX_COUNT_DEFAULT
public:
literal int CLIENT_TRANSPORT_MAX_COUNT_DEFAULT
static val mutable CLIENT_TRANSPORT_MAX_COUNT_DEFAULT: int
static val mutable CLIENT_TRANSPORT_MAX_COUNT_DEFAULT: int

Field Value

Type: Online Int32
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.CLIENT_TRANSPORT_MAX_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT Field

Binding CLIENT_TRANSPORT_MAX_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int CLIENT_TRANSPORT_MAX_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT
public const int CLIENT_TRANSPORT_MAX_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT
Public Const CLIENT_TRANSPORT_MAX_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT As Integer
Public Const CLIENT_TRANSPORT_MAX_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT As Integer
public:
literal int CLIENT_TRANSPORT_MAX_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT
public:
literal int CLIENT_TRANSPORT_MAX_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT
static val mutable CLIENT_TRANSPORT_MAX_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT: int
static val mutable CLIENT_TRANSPORT_MAX_EXISTING_ACQUISITION_TIMEOUT_MS_DEFAULT: int

Field Value

Type: Online Int32
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.CONFIG_CLIENT_DUMP_ATTR Field

Binding CONFIG_CLIENT_DUMP_ATTR Field NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CLIENT_DUMP_ATTR
public const string CONFIG_CLIENT_DUMP_ATTR
Public Const CONFIG_CLIENT_DUMP_ATTR As String
Public Const CONFIG_CLIENT_DUMP_ATTR As String
public:
literal String^ CONFIG_CLIENT_DUMP_ATTR
public:
literal String^ CONFIG_CLIENT_DUMP_ATTR
static val mutable CONFIG_CLIENT_DUMP_ATTR: string
static val mutable CONFIG_CLIENT_DUMP_ATTR: string

Field Value

Type: Online String
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.CONFIG_CLIENT_TRANSPORT_COUNT_WAIT_THRESHOLD_ATTR Field

Binding CONFIG_CLIENT_TRANSPORT_COUNT_WAIT_THRESHOLD_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CLIENT_TRANSPORT_COUNT_WAIT_THRESHOLD_ATTR
public const string CONFIG_CLIENT_TRANSPORT_COUNT_WAIT_THRESHOLD_ATTR
Public Const CONFIG_CLIENT_TRANSPORT_COUNT_WAIT_THRESHOLD_ATTR As String
Public Const CONFIG_CLIENT_TRANSPORT_COUNT_WAIT_THRESHOLD_ATTR As String
public:
literal String^ CONFIG_CLIENT_TRANSPORT_COUNT_WAIT_THRESHOLD_ATTR
public:
literal String^ CONFIG_CLIENT_TRANSPORT_COUNT_WAIT_THRESHOLD_ATTR
static val mutable CONFIG_CLIENT_TRANSPORT_COUNT_WAIT_THRESHOLD_ATTR: string
static val mutable CONFIG_CLIENT_TRANSPORT_COUNT_WAIT_THRESHOLD_ATTR: string

Field Value

Type: Online String
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.CONFIG_CLIENT_TRANSPORT_EXISTING_ACQUISITION_TIMEOUT_MS_ATTR Field

Binding CONFIG_CLIENT_TRANSPORT_EXISTING_ACQUISITION_TIMEOUT_MS_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CLIENT_TRANSPORT_EXISTING_ACQUISITION_TIMEOUT_MS_ATTR
public const string CONFIG_CLIENT_TRANSPORT_EXISTING_ACQUISITION_TIMEOUT_MS_ATTR
Public Const CONFIG_CLIENT_TRANSPORT_EXISTING_ACQUISITION_TIMEOUT_MS_ATTR As String
Public Const CONFIG_CLIENT_TRANSPORT_EXISTING_ACQUISITION_TIMEOUT_MS_ATTR As String
public:
literal String^ CONFIG_CLIENT_TRANSPORT_EXISTING_ACQUISITION_TIMEOUT_MS_ATTR
public:
literal String^ CONFIG_CLIENT_TRANSPORT_EXISTING_ACQUISITION_TIMEOUT_MS_ATTR
static val mutable CONFIG_CLIENT_TRANSPORT_EXISTING_ACQUISITION_TIMEOUT_MS_ATTR: string
static val mutable CONFIG_CLIENT_TRANSPORT_EXISTING_ACQUISITION_TIMEOUT_MS_ATTR: string

Field Value

Type: Online String
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.CONFIG_CLIENT_TRANSPORT_MAX_COUNT_ATTR Field

Binding CONFIG_CLIENT_TRANSPORT_MAX_COUNT_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CLIENT_TRANSPORT_MAX_COUNT_ATTR
public const string CONFIG_CLIENT_TRANSPORT_MAX_COUNT_ATTR
Public Const CONFIG_CLIENT_TRANSPORT_MAX_COUNT_ATTR As String
Public Const CONFIG_CLIENT_TRANSPORT_MAX_COUNT_ATTR As String
public:
literal String^ CONFIG_CLIENT_TRANSPORT_MAX_COUNT_ATTR
public:
literal String^ CONFIG_CLIENT_TRANSPORT_MAX_COUNT_ATTR
static val mutable CONFIG_CLIENT_TRANSPORT_MAX_COUNT_ATTR: string
static val mutable CONFIG_CLIENT_TRANSPORT_MAX_COUNT_ATTR: string

Field Value

Type: Online String
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.CONFIG_CLIENT_TRANSPORT_MAX_EXISTING_ACQUISITION_TIMEOUT_MS_ATTR Field

Binding CONFIG_CLIENT_TRANSPORT_MAX_EXISTING_ACQUISITION_TIMEOUT_MS_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CLIENT_TRANSPORT_MAX_EXISTING_ACQUISITION_TIMEOUT_MS_ATTR
public const string CONFIG_CLIENT_TRANSPORT_MAX_EXISTING_ACQUISITION_TIMEOUT_MS_ATTR
Public Const CONFIG_CLIENT_TRANSPORT_MAX_EXISTING_ACQUISITION_TIMEOUT_MS_ATTR As String
Public Const CONFIG_CLIENT_TRANSPORT_MAX_EXISTING_ACQUISITION_TIMEOUT_MS_ATTR As String
public:
literal String^ CONFIG_CLIENT_TRANSPORT_MAX_EXISTING_ACQUISITION_TIMEOUT_MS_ATTR
public:
literal String^ CONFIG_CLIENT_TRANSPORT_MAX_EXISTING_ACQUISITION_TIMEOUT_MS_ATTR
static val mutable CONFIG_CLIENT_TRANSPORT_MAX_EXISTING_ACQUISITION_TIMEOUT_MS_ATTR: string
static val mutable CONFIG_CLIENT_TRANSPORT_MAX_EXISTING_ACQUISITION_TIMEOUT_MS_ATTR: string

Field Value

Type: Online String
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.CONFIG_CLIENT_TRANSPORT_SECTION Field

Binding CONFIG_CLIENT_TRANSPORT_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CLIENT_TRANSPORT_SECTION
public const string CONFIG_CLIENT_TRANSPORT_SECTION
Public Const CONFIG_CLIENT_TRANSPORT_SECTION As String
Public Const CONFIG_CLIENT_TRANSPORT_SECTION As String
public:
literal String^ CONFIG_CLIENT_TRANSPORT_SECTION
public:
literal String^ CONFIG_CLIENT_TRANSPORT_SECTION
static val mutable CONFIG_CLIENT_TRANSPORT_SECTION: string
static val mutable CONFIG_CLIENT_TRANSPORT_SECTION: string

Field Value

Type: Online String
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.CONFIG_DUMP_FORMAT_ATTR Field

Binding CONFIG_DUMP_FORMAT_ATTR Field NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_DUMP_FORMAT_ATTR
public const string CONFIG_DUMP_FORMAT_ATTR
Public Const CONFIG_DUMP_FORMAT_ATTR As String
Public Const CONFIG_DUMP_FORMAT_ATTR As String
public:
literal String^ CONFIG_DUMP_FORMAT_ATTR
public:
literal String^ CONFIG_DUMP_FORMAT_ATTR
static val mutable CONFIG_DUMP_FORMAT_ATTR: string
static val mutable CONFIG_DUMP_FORMAT_ATTR: string

Field Value

Type: Online String
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.CONFIG_DUMP_PATH_ATTR Field

Binding CONFIG_DUMP_PATH_ATTR Field NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_DUMP_PATH_ATTR
public const string CONFIG_DUMP_PATH_ATTR
Public Const CONFIG_DUMP_PATH_ATTR As String
Public Const CONFIG_DUMP_PATH_ATTR As String
public:
literal String^ CONFIG_DUMP_PATH_ATTR
public:
literal String^ CONFIG_DUMP_PATH_ATTR
static val mutable CONFIG_DUMP_PATH_ATTR: string
static val mutable CONFIG_DUMP_PATH_ATTR: string

Field Value

Type: Online String
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.CONFIG_INSTRUMENT_TRANSPORT_STAT_ATTR Field

Binding CONFIG_INSTRUMENT_TRANSPORT_STAT_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_INSTRUMENT_TRANSPORT_STAT_ATTR
public const string CONFIG_INSTRUMENT_TRANSPORT_STAT_ATTR
Public Const CONFIG_INSTRUMENT_TRANSPORT_STAT_ATTR As String
Public Const CONFIG_INSTRUMENT_TRANSPORT_STAT_ATTR As String
public:
literal String^ CONFIG_INSTRUMENT_TRANSPORT_STAT_ATTR
public:
literal String^ CONFIG_INSTRUMENT_TRANSPORT_STAT_ATTR
static val mutable CONFIG_INSTRUMENT_TRANSPORT_STAT_ATTR: string
static val mutable CONFIG_INSTRUMENT_TRANSPORT_STAT_ATTR: string

Field Value

Type: Online String
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.CONFIG_SERVER_DUMP_ATTR Field

Binding CONFIG_SERVER_DUMP_ATTR Field NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SERVER_DUMP_ATTR
public const string CONFIG_SERVER_DUMP_ATTR
Public Const CONFIG_SERVER_DUMP_ATTR As String
Public Const CONFIG_SERVER_DUMP_ATTR As String
public:
literal String^ CONFIG_SERVER_DUMP_ATTR
public:
literal String^ CONFIG_SERVER_DUMP_ATTR
static val mutable CONFIG_SERVER_DUMP_ATTR: string
static val mutable CONFIG_SERVER_DUMP_ATTR: string

Field Value

Type: Online String
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.CONFIG_SERVER_TRANSPORT_SECTION Field

Binding CONFIG_SERVER_TRANSPORT_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SERVER_TRANSPORT_SECTION
public const string CONFIG_SERVER_TRANSPORT_SECTION
Public Const CONFIG_SERVER_TRANSPORT_SECTION As String
Public Const CONFIG_SERVER_TRANSPORT_SECTION As String
public:
literal String^ CONFIG_SERVER_TRANSPORT_SECTION
public:
literal String^ CONFIG_SERVER_TRANSPORT_SECTION
static val mutable CONFIG_SERVER_TRANSPORT_SECTION: string
static val mutable CONFIG_SERVER_TRANSPORT_SECTION: string

Field Value

Type: Online String
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.CONFIG_STAT_TIMES_EMA_FACTOR_ATTR Field

Binding CONFIG_STAT_TIMES_EMA_FACTOR_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_STAT_TIMES_EMA_FACTOR_ATTR
public const string CONFIG_STAT_TIMES_EMA_FACTOR_ATTR
Public Const CONFIG_STAT_TIMES_EMA_FACTOR_ATTR As String
Public Const CONFIG_STAT_TIMES_EMA_FACTOR_ATTR As String
public:
literal String^ CONFIG_STAT_TIMES_EMA_FACTOR_ATTR
public:
literal String^ CONFIG_STAT_TIMES_EMA_FACTOR_ATTR
static val mutable CONFIG_STAT_TIMES_EMA_FACTOR_ATTR: string
static val mutable CONFIG_STAT_TIMES_EMA_FACTOR_ATTR: string

Field Value

Type: Online String
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.CONFIG_TRANSPORT_IDLE_TIMEOUT_MS_ATTR Field

Binding CONFIG_TRANSPORT_IDLE_TIMEOUT_MS_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_TRANSPORT_IDLE_TIMEOUT_MS_ATTR
public const string CONFIG_TRANSPORT_IDLE_TIMEOUT_MS_ATTR
Public Const CONFIG_TRANSPORT_IDLE_TIMEOUT_MS_ATTR As String
Public Const CONFIG_TRANSPORT_IDLE_TIMEOUT_MS_ATTR As String
public:
literal String^ CONFIG_TRANSPORT_IDLE_TIMEOUT_MS_ATTR
public:
literal String^ CONFIG_TRANSPORT_IDLE_TIMEOUT_MS_ATTR
static val mutable CONFIG_TRANSPORT_IDLE_TIMEOUT_MS_ATTR: string
static val mutable CONFIG_TRANSPORT_IDLE_TIMEOUT_MS_ATTR: string

Field Value

Type: Online String
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.DEFAULT_STAT_TIMES_EMA_FACTOR Field

Binding DEFAULT_STAT_TIMES_EMA_FACTOR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Defines how much smoothing the timing statistics filter does - the lower the number the more smoothing is done. Smoothing makes stat times insensitive to some seldom delays that may happen every now and then

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double DEFAULT_STAT_TIMES_EMA_FACTOR
public const double DEFAULT_STAT_TIMES_EMA_FACTOR
Public Const DEFAULT_STAT_TIMES_EMA_FACTOR As Double
Public Const DEFAULT_STAT_TIMES_EMA_FACTOR As Double
public:
literal double DEFAULT_STAT_TIMES_EMA_FACTOR
public:
literal double DEFAULT_STAT_TIMES_EMA_FACTOR
static val mutable DEFAULT_STAT_TIMES_EMA_FACTOR: float
static val mutable DEFAULT_STAT_TIMES_EMA_FACTOR: float

Field Value

Type: Online Double
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.m_ClientTransportAllocatorLocks Field

Binding m_ClientTransportAllocatorLocks Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Hash table of locks used during new transport allocation, must be prime size

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Object[] m_ClientTransportAllocatorLocks
protected Object[] m_ClientTransportAllocatorLocks
Protected m_ClientTransportAllocatorLocks As Object()
Protected m_ClientTransportAllocatorLocks As Object()
protected:
array<Object^>^ m_ClientTransportAllocatorLocks
protected:
array<Object^>^ m_ClientTransportAllocatorLocks
val mutable m_ClientTransportAllocatorLocks: Object[]
val mutable m_ClientTransportAllocatorLocks: Object[]

Field Value

Type: Online Object
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.m_Provider Field

Binding m_Provider Field NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Provider m_Provider
protected Provider m_Provider
Protected m_Provider As Provider
Protected m_Provider As Provider
protected:
Provider^ m_Provider
protected:
Provider^ m_Provider
val mutable m_Provider: Provider
val mutable m_Provider: Provider

Field Value

Type: Provider
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.m_Transports Field

Binding m_Transports Field NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal List<Transport> m_Transports
internal List<Transport> m_Transports
Friend m_Transports As List(Of Transport)
Friend m_Transports As List(Of Transport)
internal:
List<Transport^>^ m_Transports
internal:
List<Transport^>^ m_Transports
val mutable internal m_Transports: List<Transport>
val mutable internal m_Transports: List<Transport>

Field Value

Type: Online List Transport
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.MAX_STAT_TIMES_EMA_FACTOR Field

Binding MAX_STAT_TIMES_EMA_FACTOR Field NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double MAX_STAT_TIMES_EMA_FACTOR
public const double MAX_STAT_TIMES_EMA_FACTOR
Public Const MAX_STAT_TIMES_EMA_FACTOR As Double
Public Const MAX_STAT_TIMES_EMA_FACTOR As Double
public:
literal double MAX_STAT_TIMES_EMA_FACTOR
public:
literal double MAX_STAT_TIMES_EMA_FACTOR
static val mutable MAX_STAT_TIMES_EMA_FACTOR: float
static val mutable MAX_STAT_TIMES_EMA_FACTOR: float

Field Value

Type: Online Double
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.MIN_STAT_TIMES_EMA_FACTOR Field

Binding MIN_STAT_TIMES_EMA_FACTOR Field NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const double MIN_STAT_TIMES_EMA_FACTOR
public const double MIN_STAT_TIMES_EMA_FACTOR
Public Const MIN_STAT_TIMES_EMA_FACTOR As Double
Public Const MIN_STAT_TIMES_EMA_FACTOR As Double
public:
literal double MIN_STAT_TIMES_EMA_FACTOR
public:
literal double MIN_STAT_TIMES_EMA_FACTOR
static val mutable MIN_STAT_TIMES_EMA_FACTOR: float
static val mutable MIN_STAT_TIMES_EMA_FACTOR: float

Field Value

Type: Online Double
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.SERVER_TRANSPORT_IDLE_TIMEOUT_MS_DEFAULT Field

Binding SERVER_TRANSPORT_IDLE_TIMEOUT_MS_DEFAULT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int SERVER_TRANSPORT_IDLE_TIMEOUT_MS_DEFAULT
public const int SERVER_TRANSPORT_IDLE_TIMEOUT_MS_DEFAULT
Public Const SERVER_TRANSPORT_IDLE_TIMEOUT_MS_DEFAULT As Integer
Public Const SERVER_TRANSPORT_IDLE_TIMEOUT_MS_DEFAULT As Integer
public:
literal int SERVER_TRANSPORT_IDLE_TIMEOUT_MS_DEFAULT
public:
literal int SERVER_TRANSPORT_IDLE_TIMEOUT_MS_DEFAULT
static val mutable SERVER_TRANSPORT_IDLE_TIMEOUT_MS_DEFAULT: int
static val mutable SERVER_TRANSPORT_IDLE_TIMEOUT_MS_DEFAULT: int

Field Value

Type: Online Int32
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding Methods

Binding Methods NFX Class Library

The Binding type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | _Register |
Protected method | _Unregister |
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Protected method | AcquireClientTransportForCall | Returns an instance of transport suitable for a call. The implementation may return existing transport or allocate a new instance. The call is thread-safe
Public method | AreNodesIdentical | Returns true when two nodes represent the same binding, host and service identities. The implementation depends on binding, for example some binding may recognize an optional parameter as part of host segment, however that parameter does not change the identity of the node instance
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and binding runtime are running or throws otherwise
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Protected method | CloseServerEndpoint |
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | ConfigureAndStartNewClientTransport | Override to perform custom transport preparation and launch
Protected method | Destructor | (Overrides Service Destructor .)
Public method | DispatchCall | Dispatches a call allocating new or re-using existing transport if needed. The strategy depends on particular Binding implementation. This call is thread-safe
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | (Overrides Service DoAcceptManagerVisit(Object, DateTime).)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Protected method | DumpMsg(Boolean, Msg, ArraySegment Byte ) | Conditionally dumps message to disk
Protected method | DumpMsg(Boolean, Msg, Func ArraySegment Byte ) | Conditionally dumps message to disk where the data is lazily obtained by calling dataFun
Protected method | DumpMsg(Boolean, Msg, Byte , Int32, Int32) | Conditionally dumps message to disk
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetClientCallStatTimeKey | Extracts necessary information from client:request pair that characterizes the particular call for the purpose of call timing
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | MakeNewClientTransport | Factory method - Override to make an instance of a new client transport suitable for particular binding type
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OpenServerEndpoint |
Protected method | ReleaseClientTransportAfterCall | Releases a transport instance that was acquired for call. The implementation may return this instance back to the pool of available transports or deallocate it. The default implementation releases the instance back to the pool
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | TryGetExistingAcquiredTransportPerRemoteNode | Tries to acquire an available client transport to make a call. This method respects binding/transport settings that impose a limit on the number of open concurrent transports and timeouts for acqusition waiting
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | WriteLog | (Inherited from GlueComponentService.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Binding Class
NFX.Glue Namespace


Binding._Register Method

Binding _Register Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal void _Register(
    Transport transport
)
protected internal void _Register(
    Transport transport
)
Protected Friend Sub _Register (
    transport As Transport
)
Protected Friend Sub _Register (
    transport As Transport
)
protected public:
void _Register(
    Transport^ transport
)
protected public:
void _Register(
    Transport^ transport
)
member _Register :
        transport : Transport -> unit
member _Register :
        transport : Transport -> unit

Parameters

transport
Type: NFX.Glue Transport
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding._Unregister Method

Binding _Unregister Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal void _Unregister(
    Transport transport
)
protected internal void _Unregister(
    Transport transport
)
Protected Friend Sub _Unregister (
    transport As Transport
)
Protected Friend Sub _Unregister (
    transport As Transport
)
protected public:
void _Unregister(
    Transport^ transport
)
protected public:
void _Unregister(
    Transport^ transport
)
member _Unregister :
        transport : Transport -> unit
member _Unregister :
        transport : Transport -> unit

Parameters

transport
Type: NFX.Glue Transport
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.AcquireClientTransportForCall Method

Binding AcquireClientTransportForCall Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns an instance of transport suitable for a call. The implementation may return existing transport or allocate a new instance. The call is thread-safe

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual ClientTransport AcquireClientTransportForCall(
    ClientEndPoint client,
    RequestMsg request
)
protected virtual ClientTransport AcquireClientTransportForCall(
    ClientEndPoint client,
    RequestMsg request
)
Protected Overridable Function AcquireClientTransportForCall (
    client As ClientEndPoint,
    request As RequestMsg
) As ClientTransport
Protected Overridable Function AcquireClientTransportForCall (
    client As ClientEndPoint,
    request As RequestMsg
) As ClientTransport
protected:
virtual ClientTransport^ AcquireClientTransportForCall(
    ClientEndPoint^ client,
    RequestMsg^ request
)
protected:
virtual ClientTransport^ AcquireClientTransportForCall(
    ClientEndPoint^ client,
    RequestMsg^ request
)
abstract AcquireClientTransportForCall :
        client : ClientEndPoint *
        request : RequestMsg -> ClientTransport
override AcquireClientTransportForCall :
        client : ClientEndPoint *
        request : RequestMsg -> ClientTransport
abstract AcquireClientTransportForCall :
        client : ClientEndPoint *
        request : RequestMsg -> ClientTransport
override AcquireClientTransportForCall :
        client : ClientEndPoint *
        request : RequestMsg -> ClientTransport

Parameters

client
Type: NFX.Glue ClientEndPoint
request
Type: NFX.Glue.Protocol RequestMsg

Return Value

Type: ClientTransport
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.AreNodesIdentical Method

Binding AreNodesIdentical Method NFX Class Library

Returns true when two nodes represent the same binding, host and service identities. The implementation depends on binding, for example some binding may recognize an optional parameter as part of host segment, however that parameter does not change the identity of the node instance

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool AreNodesIdentical(
    Node left,
    Node right
)
public abstract bool AreNodesIdentical(
    Node left,
    Node right
)
Public MustOverride Function AreNodesIdentical (
    left As Node,
    right As Node
) As Boolean
Public MustOverride Function AreNodesIdentical (
    left As Node,
    right As Node
) As Boolean
public:
virtual bool AreNodesIdentical(
    Node left,
    Node right
) abstract
public:
virtual bool AreNodesIdentical(
    Node left,
    Node right
) abstract
abstract AreNodesIdentical :
        left : Node *
        right : Node -> bool
abstract AreNodesIdentical :
        left : Node *
        right : Node -> bool

Parameters

left
Type: NFX.Glue Node
right
Type: NFX.Glue Node

Return Value

Type: Online Boolean
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.CheckRunningState Method

Binding CheckRunningState Method NFX Class Library

Ensures that application and binding runtime are running or throws otherwise

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CheckRunningState(
    bool client = true
)
public void CheckRunningState(
    bool client = true
)
Public Sub CheckRunningState (
    Optional client As Boolean = true
)
Public Sub CheckRunningState (
    Optional client As Boolean = true
)
public:
void CheckRunningState(
    bool client = true
)
public:
void CheckRunningState(
    bool client = true
)
member CheckRunningState :
        ?client : bool
(* Defaults:
        let _client = defaultArg client true
*)
-> unit
member CheckRunningState :
        ?client : bool
(* Defaults:
        let _client = defaultArg client true
*)
-> unit

Parameters

client (Optional)
Type: Online System Boolean
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.CloseServerEndpoint Method

Binding CloseServerEndpoint Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract void CloseServerEndpoint(
    ServerEndPoint epoint
)
protected internal abstract void CloseServerEndpoint(
    ServerEndPoint epoint
)
Protected Friend MustOverride Sub CloseServerEndpoint (
    epoint As ServerEndPoint
)
Protected Friend MustOverride Sub CloseServerEndpoint (
    epoint As ServerEndPoint
)
protected public:
virtual void CloseServerEndpoint(
    ServerEndPoint^ epoint
) abstract
protected public:
virtual void CloseServerEndpoint(
    ServerEndPoint^ epoint
) abstract
abstract CloseServerEndpoint :
        epoint : ServerEndPoint -> unit
abstract CloseServerEndpoint :
        epoint : ServerEndPoint -> unit

Parameters

epoint
Type: NFX.Glue ServerEndPoint
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.ConfigureAndStartNewClientTransport Method

Binding ConfigureAndStartNewClientTransport Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to perform custom transport preparation and launch

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void ConfigureAndStartNewClientTransport(
    ClientTransport transport
)
protected virtual void ConfigureAndStartNewClientTransport(
    ClientTransport transport
)
Protected Overridable Sub ConfigureAndStartNewClientTransport (
    transport As ClientTransport
)
Protected Overridable Sub ConfigureAndStartNewClientTransport (
    transport As ClientTransport
)
protected:
virtual void ConfigureAndStartNewClientTransport(
    ClientTransport^ transport
)
protected:
virtual void ConfigureAndStartNewClientTransport(
    ClientTransport^ transport
)
abstract ConfigureAndStartNewClientTransport :
        transport : ClientTransport -> unit
override ConfigureAndStartNewClientTransport :
        transport : ClientTransport -> unit
abstract ConfigureAndStartNewClientTransport :
        transport : ClientTransport -> unit
override ConfigureAndStartNewClientTransport :
        transport : ClientTransport -> unit

Parameters

transport
Type: NFX.Glue ClientTransport
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.Destructor Method

Binding Destructor Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.DispatchCall Method

Binding DispatchCall Method NFX Class Library

Dispatches a call allocating new or re-using existing transport if needed. The strategy depends on particular Binding implementation. This call is thread-safe

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CallSlot DispatchCall(
    ClientEndPoint client,
    RequestMsg request
)
public CallSlot DispatchCall(
    ClientEndPoint client,
    RequestMsg request
)
Public Function DispatchCall (
    client As ClientEndPoint,
    request As RequestMsg
) As CallSlot
Public Function DispatchCall (
    client As ClientEndPoint,
    request As RequestMsg
) As CallSlot
public:
CallSlot^ DispatchCall(
    ClientEndPoint^ client,
    RequestMsg^ request
)
public:
CallSlot^ DispatchCall(
    ClientEndPoint^ client,
    RequestMsg^ request
)
member DispatchCall :
        client : ClientEndPoint *
        request : RequestMsg -> CallSlot
member DispatchCall :
        client : ClientEndPoint *
        request : RequestMsg -> CallSlot

Parameters

client
Type: NFX.Glue ClientEndPoint
request
Type: NFX.Glue.Protocol RequestMsg

Return Value

Type: CallSlot
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.DoAcceptManagerVisit Method

Binding DoAcceptManagerVisit Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoAcceptManagerVisit(
    Object manager,
    DateTime managerNow
)
protected override void DoAcceptManagerVisit(
    Object manager,
    DateTime managerNow
)
Protected Overrides Sub DoAcceptManagerVisit (
    manager As Object,
    managerNow As DateTime
)
Protected Overrides Sub DoAcceptManagerVisit (
    manager As Object,
    managerNow As DateTime
)
protected:
virtual void DoAcceptManagerVisit(
    Object^ manager,
    DateTime managerNow
) override
protected:
virtual void DoAcceptManagerVisit(
    Object^ manager,
    DateTime managerNow
) override
abstract DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit
override DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit
abstract DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit
override DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit

Parameters

manager
Type: Online System Object
managerNow
Type: Online System DateTime
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.DoConfigure Method

Binding DoConfigure Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.DoSignalStop Method

Binding DoSignalStop Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSignalStop()
protected override void DoSignalStop()
Protected Overrides Sub DoSignalStop
Protected Overrides Sub DoSignalStop
protected:
virtual void DoSignalStop() override
protected:
virtual void DoSignalStop() override
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.DoWaitForCompleteStop Method

Binding DoWaitForCompleteStop Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.DumpMsg Method

Binding DumpMsg Method NFX Class Library

Overload List
 | Name | Description
Protected method | DumpMsg(Boolean, Msg, ArraySegment Byte ) | Conditionally dumps message to disk
Protected method | DumpMsg(Boolean, Msg, Func ArraySegment Byte ) | Conditionally dumps message to disk where the data is lazily obtained by calling dataFun
Protected method | DumpMsg(Boolean, Msg, Byte , Int32, Int32) | Conditionally dumps message to disk
Back to Top
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.DumpMsg Method (Boolean, Msg, ArraySegment(Byte))

Binding DumpMsg Method (Boolean, Msg, ArraySegment Byte ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Conditionally dumps message to disk

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal void DumpMsg(
    bool server,
    Msg msg,
    ArraySegment<byte> data
)
protected internal void DumpMsg(
    bool server,
    Msg msg,
    ArraySegment<byte> data
)
Protected Friend Sub DumpMsg (
    server As Boolean,
    msg As Msg,
    data As ArraySegment(Of Byte)
)
Protected Friend Sub DumpMsg (
    server As Boolean,
    msg As Msg,
    data As ArraySegment(Of Byte)
)
protected public:
void DumpMsg(
    bool server,
    Msg^ msg,
    ArraySegment<unsigned char> data
)
protected public:
void DumpMsg(
    bool server,
    Msg^ msg,
    ArraySegment<unsigned char> data
)
member DumpMsg :
        server : bool *
        msg : Msg *
        data : ArraySegment<byte> -> unit
member DumpMsg :
        server : bool *
        msg : Msg *
        data : ArraySegment<byte> -> unit

Parameters

server
Type: Online System Boolean
True for server-side message
msg
Type: NFX.Glue.Protocol Msg
Message that was deserialized/serialized. If null then error happened while deserializing
data
Type: Online System ArraySegment Online Byte
Data
See Also
Binding Class
Binding Members
DumpMsg Overload
NFX.Glue Namespace


Binding.DumpMsg Method (Boolean, Msg, Func(ArraySegment(Byte)))

Binding DumpMsg Method (Boolean, Msg, Func ArraySegment Byte ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Conditionally dumps message to disk where the data is lazily obtained by calling dataFun

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal void DumpMsg(
    bool server,
    Msg msg,
    Func<ArraySegment<byte>> dataFun
)
protected internal void DumpMsg(
    bool server,
    Msg msg,
    Func<ArraySegment<byte>> dataFun
)
Protected Friend Sub DumpMsg (
    server As Boolean,
    msg As Msg,
    dataFun As Func(Of ArraySegment(Of Byte))
)
Protected Friend Sub DumpMsg (
    server As Boolean,
    msg As Msg,
    dataFun As Func(Of ArraySegment(Of Byte))
)
protected public:
void DumpMsg(
    bool server,
    Msg^ msg,
    Func<ArraySegment<unsigned char>>^ dataFun
)
protected public:
void DumpMsg(
    bool server,
    Msg^ msg,
    Func<ArraySegment<unsigned char>>^ dataFun
)
member DumpMsg :
        server : bool *
        msg : Msg *
        dataFun : Func<ArraySegment<byte>> -> unit
member DumpMsg :
        server : bool *
        msg : Msg *
        dataFun : Func<ArraySegment<byte>> -> unit

Parameters

server
Type: Online System Boolean
msg
Type: NFX.Glue.Protocol Msg
dataFun
Type: Online System Func Online ArraySegment Online Byte
See Also
Binding Class
Binding Members
DumpMsg Overload
NFX.Glue Namespace


Binding.DumpMsg Method (Boolean, Msg, Byte[], Int32, Int32)

Binding DumpMsg Method (Boolean, Msg, Byte , Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Conditionally dumps message to disk

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal void DumpMsg(
    bool server,
    Msg msg,
    byte[] buffer,
    int offset,
    int count
)
protected internal void DumpMsg(
    bool server,
    Msg msg,
    byte[] buffer,
    int offset,
    int count
)
Protected Friend Sub DumpMsg (
    server As Boolean,
    msg As Msg,
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
Protected Friend Sub DumpMsg (
    server As Boolean,
    msg As Msg,
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
protected public:
void DumpMsg(
    bool server,
    Msg^ msg,
    array<unsigned char>^ buffer,
    int offset,
    int count
)
protected public:
void DumpMsg(
    bool server,
    Msg^ msg,
    array<unsigned char>^ buffer,
    int offset,
    int count
)
member DumpMsg :
        server : bool *
        msg : Msg *
        buffer : byte[] *
        offset : int *
        count : int -> unit
member DumpMsg :
        server : bool *
        msg : Msg *
        buffer : byte[] *
        offset : int *
        count : int -> unit

Parameters

server
Type: Online System Boolean
True for server-side message
msg
Type: NFX.Glue.Protocol Msg
Message that was deserialized/serialized. If null then error happened while deserializing
buffer
Type: Online System Byte
Message body
offset
Type: Online System Int32
Start index in buffer
count
Type: Online System Int32
Byte size of message body
See Also
Binding Class
Binding Members
DumpMsg Overload
NFX.Glue Namespace


Binding.GetClientCallStatTimeKey Method

Binding GetClientCallStatTimeKey Method NFX Class Library

Extracts necessary information from client:request pair that characterizes the particular call for the purpose of call timing

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string GetClientCallStatTimeKey(
    ClientEndPoint client,
    RequestMsg request
)
public virtual string GetClientCallStatTimeKey(
    ClientEndPoint client,
    RequestMsg request
)
Public Overridable Function GetClientCallStatTimeKey (
    client As ClientEndPoint,
    request As RequestMsg
) As String
Public Overridable Function GetClientCallStatTimeKey (
    client As ClientEndPoint,
    request As RequestMsg
) As String
public:
virtual String^ GetClientCallStatTimeKey(
    ClientEndPoint^ client,
    RequestMsg^ request
)
public:
virtual String^ GetClientCallStatTimeKey(
    ClientEndPoint^ client,
    RequestMsg^ request
)
abstract GetClientCallStatTimeKey :
        client : ClientEndPoint *
        request : RequestMsg -> string
override GetClientCallStatTimeKey :
        client : ClientEndPoint *
        request : RequestMsg -> string
abstract GetClientCallStatTimeKey :
        client : ClientEndPoint *
        request : RequestMsg -> string
override GetClientCallStatTimeKey :
        client : ClientEndPoint *
        request : RequestMsg -> string

Parameters

client
Type: NFX.Glue ClientEndPoint
request
Type: NFX.Glue.Protocol RequestMsg

Return Value

Type: Online String
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.MakeNewClientTransport Method

Binding MakeNewClientTransport Method NFX Class Library

Factory method - Override to make an instance of a new client transport suitable for particular binding type

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract ClientTransport MakeNewClientTransport(
    ClientEndPoint client
)
protected abstract ClientTransport MakeNewClientTransport(
    ClientEndPoint client
)
Protected MustOverride Function MakeNewClientTransport (
    client As ClientEndPoint
) As ClientTransport
Protected MustOverride Function MakeNewClientTransport (
    client As ClientEndPoint
) As ClientTransport
protected:
virtual ClientTransport^ MakeNewClientTransport(
    ClientEndPoint^ client
) abstract
protected:
virtual ClientTransport^ MakeNewClientTransport(
    ClientEndPoint^ client
) abstract
abstract MakeNewClientTransport :
        client : ClientEndPoint -> ClientTransport
abstract MakeNewClientTransport :
        client : ClientEndPoint -> ClientTransport

Parameters

client
Type: NFX.Glue ClientEndPoint

Return Value

Type: ClientTransport
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.OpenServerEndpoint Method

Binding OpenServerEndpoint Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract ServerTransport OpenServerEndpoint(
    ServerEndPoint epoint
)
protected internal abstract ServerTransport OpenServerEndpoint(
    ServerEndPoint epoint
)
Protected Friend MustOverride Function OpenServerEndpoint (
    epoint As ServerEndPoint
) As ServerTransport
Protected Friend MustOverride Function OpenServerEndpoint (
    epoint As ServerEndPoint
) As ServerTransport
protected public:
virtual ServerTransport^ OpenServerEndpoint(
    ServerEndPoint^ epoint
) abstract
protected public:
virtual ServerTransport^ OpenServerEndpoint(
    ServerEndPoint^ epoint
) abstract
abstract OpenServerEndpoint :
        epoint : ServerEndPoint -> ServerTransport
abstract OpenServerEndpoint :
        epoint : ServerEndPoint -> ServerTransport

Parameters

epoint
Type: NFX.Glue ServerEndPoint

Return Value

Type: ServerTransport
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.ReleaseClientTransportAfterCall Method

Binding ReleaseClientTransportAfterCall Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Releases a transport instance that was acquired for call. The implementation may return this instance back to the pool of available transports or deallocate it. The default implementation releases the instance back to the pool

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual void ReleaseClientTransportAfterCall(
    ClientTransport transport
)
protected internal virtual void ReleaseClientTransportAfterCall(
    ClientTransport transport
)
Protected Friend Overridable Sub ReleaseClientTransportAfterCall (
    transport As ClientTransport
)
Protected Friend Overridable Sub ReleaseClientTransportAfterCall (
    transport As ClientTransport
)
protected public:
virtual void ReleaseClientTransportAfterCall(
    ClientTransport^ transport
)
protected public:
virtual void ReleaseClientTransportAfterCall(
    ClientTransport^ transport
)
abstract ReleaseClientTransportAfterCall :
        transport : ClientTransport -> unit
override ReleaseClientTransportAfterCall :
        transport : ClientTransport -> unit
abstract ReleaseClientTransportAfterCall :
        transport : ClientTransport -> unit
override ReleaseClientTransportAfterCall :
        transport : ClientTransport -> unit

Parameters

transport
Type: NFX.Glue ClientTransport
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.TryGetExistingAcquiredTransportPerRemoteNode Method

Binding TryGetExistingAcquiredTransportPerRemoteNode Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Tries to acquire an available client transport to make a call. This method respects binding/transport settings that impose a limit on the number of open concurrent transports and timeouts for acqusition waiting

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual ClientTransport TryGetExistingAcquiredTransportPerRemoteNode(
    Node remoteNode
)
protected virtual ClientTransport TryGetExistingAcquiredTransportPerRemoteNode(
    Node remoteNode
)
Protected Overridable Function TryGetExistingAcquiredTransportPerRemoteNode (
    remoteNode As Node
) As ClientTransport
Protected Overridable Function TryGetExistingAcquiredTransportPerRemoteNode (
    remoteNode As Node
) As ClientTransport
protected:
virtual ClientTransport^ TryGetExistingAcquiredTransportPerRemoteNode(
    Node remoteNode
)
protected:
virtual ClientTransport^ TryGetExistingAcquiredTransportPerRemoteNode(
    Node remoteNode
)
abstract TryGetExistingAcquiredTransportPerRemoteNode :
        remoteNode : Node -> ClientTransport
override TryGetExistingAcquiredTransportPerRemoteNode :
        remoteNode : Node -> ClientTransport
abstract TryGetExistingAcquiredTransportPerRemoteNode :
        remoteNode : Node -> ClientTransport
override TryGetExistingAcquiredTransportPerRemoteNode :
        remoteNode : Node -> ClientTransport

Parameters

remoteNode
Type: NFX.Glue Node
remote node to connect to

Return Value

Type: ClientTransport
Available acquired transport or null
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding Properties

Binding Properties NFX Class Library

The Binding type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ClientDump | Turns on/off client message dumping to disk. Turning on dumping has negative effect on performance and consumes resources
Public property | ClientMsgInspectors | Returns client message inspectors for this instance
Public property | ClientTransportCountWaitThreshold | Sets the threshold, expressed as the number of active client transports per remote address, below which binding will always allocate a new instance of client transport without trying/waiting to acquire an existing one. When this number is exceeded then binding will try to acquire an existing client transport instance for up to ClientTransportExistingAcquisitionTimeoutMs milliseconds. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog
Public property | ClientTransportExistingAcquisitionTimeoutMs | Sets the length of interval for the binding trying to acquire existing client transport instance to make a call. When this interval is exhausted then binding tries to allocate a new client transport per remote address, unless other limits prohibit (max transport count). The value has to be greater or equal to zero. NOTE: this property works in conjunction with ClientTransportCoutWaitThreshold, if the number of active client transports is below ClientTransportCoutWaitThreshold, then binding does not wait and allocates a new client transport right away until ClientTransportCoutWaitThreshold limit is reached, then binding will try to acquire existing transport for ClientTransportExistingAcquisitionTimeoutMs milliseconds. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog
Public property | ClientTransportIdleTimeoutMs | Specifies when client transports get auto-closed. Interval is measured in ms. Zero means indefinite/never closed transport. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog
Public property | ClientTransportMaxCount | Imposes a limit on number of active client transports per remote address. Once this limit is reached the binding will block until it can acquire an existing transport instance. Set value to zero to remove the limit. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog
Public property | ClientTransportMaxExistingAcquisitionTimeoutMs | Imposes a timeout for binding trying to get an existing transport instance per remote address. Binding throws ClientCallException when this timeout is exceeded. A value of zero removes the limit
Public property | ClientTransports | Returns all client transports in the binding stack
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | ConfigNode | Returns configuration node for this named instance
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | DumpMsgFormat | Set the format for message dumping
Public property | DumpPath | Set the path for message dumping. Must be an existing navigable path
Public property | EncodingFormat | Returns name of msg format encoding
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | Glue | (Inherited from GlueComponentService.)
Public property | InstrumentationEnabled | Implements IInstrumentable (Inherited from GlueComponentService.)
Public property | InstrumentClientTransportStat | Defines whether client transport statistics is periodically dumped into instrumentation
Public property | InstrumentServerTransportStat | Defines whether server transport statistics is periodically dumped into instrumentation
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | MeasureStatTimes | Defines whether message processing latency should be measured - i.e. messages time-stamped on arrival
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | OperationFlow | Returns sync/async flow that this binding provides
Public property | Provider |
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | ServerDump | Turns on/off server message dumping to disk. Turning on dumping has negative effect on performance and consumes resources
Public property | ServerMsgInspectors | Returns server message inspectors for this instance
Public property | ServerTransportIdleTimeoutMs | Specifies when server transports get auto-closed. Interval is measured in ms. Zero means indefinite/never closed transport. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog
Public property | ServerTransports | Returns all server transports in the binding stack
Public property | StatTimesEMAFactor | Defines how much smoothing the timing statistics filter does - the lower the number the more smoothing is done. Smoothing makes stat times insensitive to some seldom delays that may happen every now and then
Public property | StatTimeTicks | Returns current time in system frequency-dependent ticks. This property is used to measure accurate times and depends on MeasureStatTimes set to true, otherwise 0 is returned
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | Transports | Returns all transports in the binding stack
Back to Top
See Also
Binding Class
NFX.Glue Namespace


Binding.ClientDump Property

Binding ClientDump Property NFX Class Library

Turns on/off client message dumping to disk. Turning on dumping has negative effect on performance and consumes resources

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute("$client-dump", DumpDetail.None)]
public DumpDetail ClientDump { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute("$client-dump", DumpDetail.None)]
public DumpDetail ClientDump { get; set; }
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute("$client-dump", DumpDetail.None)>
Public Property ClientDump As DumpDetail
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute("$client-dump", DumpDetail.None)>
Public Property ClientDump As DumpDetail
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(L"$client-dump", DumpDetail::None)]
property DumpDetail ClientDump {
    DumpDetail get ();
    void set (DumpDetail value);
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(L"$client-dump", DumpDetail::None)]
property DumpDetail ClientDump {
    DumpDetail get ();
    void set (DumpDetail value);
}
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute("$client-dump", DumpDetail.None)>]
member ClientDump : DumpDetail with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute("$client-dump", DumpDetail.None)>]
member ClientDump : DumpDetail with get, set

Property Value

Type: DumpDetail
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.ClientMsgInspectors Property

Binding ClientMsgInspectors Property NFX Class Library

Returns client message inspectors for this instance

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderedRegistry<IClientMsgInspector> ClientMsgInspectors { get; }
public OrderedRegistry<IClientMsgInspector> ClientMsgInspectors { get; }
Public ReadOnly Property ClientMsgInspectors As OrderedRegistry(Of IClientMsgInspector)
    Get
Public ReadOnly Property ClientMsgInspectors As OrderedRegistry(Of IClientMsgInspector)
    Get
public:
property OrderedRegistry<IClientMsgInspector^>^ ClientMsgInspectors {
    OrderedRegistry<IClientMsgInspector^>^ get ();
}
public:
property OrderedRegistry<IClientMsgInspector^>^ ClientMsgInspectors {
    OrderedRegistry<IClientMsgInspector^>^ get ();
}
member ClientMsgInspectors : OrderedRegistry<IClientMsgInspector> with get
member ClientMsgInspectors : OrderedRegistry<IClientMsgInspector> with get

Property Value

Type: OrderedRegistry IClientMsgInspector
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.ClientTransportCountWaitThreshold Property

Binding ClientTransportCountWaitThreshold Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Sets the threshold, expressed as the number of active client transports per remote address, below which binding will always allocate a new instance of client transport without trying/waiting to acquire an existing one. When this number is exceeded then binding will try to acquire an existing client transport instance for up to ClientTransportExistingAcquisitionTimeoutMs milliseconds. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("client-transport/$count-wait-threshold", 8)]
[ExternalParameterAttribute(new string[] { ... })]
public int ClientTransportCountWaitThreshold { get; set; }
[ConfigAttribute("client-transport/$count-wait-threshold", 8)]
[ExternalParameterAttribute(new string[] { ... })]
public int ClientTransportCountWaitThreshold { get; set; }
<ConfigAttribute("client-transport/$count-wait-threshold", 8)>
<ExternalParameterAttribute(New String() { ... })>
Public Property ClientTransportCountWaitThreshold As Integer
    Get
    Set
<ConfigAttribute("client-transport/$count-wait-threshold", 8)>
<ExternalParameterAttribute(New String() { ... })>
Public Property ClientTransportCountWaitThreshold As Integer
    Get
    Set
public:
[ConfigAttribute(L"client-transport/$count-wait-threshold", 8)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property int ClientTransportCountWaitThreshold {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(L"client-transport/$count-wait-threshold", 8)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property int ClientTransportCountWaitThreshold {
    int get ();
    void set (int value);
}
[<ConfigAttribute("client-transport/$count-wait-threshold", 8)>]
[<ExternalParameterAttribute(new string[] { ... })>]
member ClientTransportCountWaitThreshold : int with get, set
[<ConfigAttribute("client-transport/$count-wait-threshold", 8)>]
[<ExternalParameterAttribute(new string[] { ... })>]
member ClientTransportCountWaitThreshold : int with get, set

Property Value

Type: Online Int32
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.ClientTransportExistingAcquisitionTimeoutMs Property

Binding ClientTransportExistingAcquisitionTimeoutMs Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Sets the length of interval for the binding trying to acquire existing client transport instance to make a call. When this interval is exhausted then binding tries to allocate a new client transport per remote address, unless other limits prohibit (max transport count). The value has to be greater or equal to zero. NOTE: this property works in conjunction with ClientTransportCoutWaitThreshold, if the number of active client transports is below ClientTransportCoutWaitThreshold, then binding does not wait and allocates a new client transport right away until ClientTransportCoutWaitThreshold limit is reached, then binding will try to acquire existing transport for ClientTransportExistingAcquisitionTimeoutMs milliseconds. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("client-transport/$existing-acquisition-timeout-ms",
    100)]
[ExternalParameterAttribute(new string[] { ... })]
public int ClientTransportExistingAcquisitionTimeoutMs { get; set; }
[ConfigAttribute("client-transport/$existing-acquisition-timeout-ms",
    100)]
[ExternalParameterAttribute(new string[] { ... })]
public int ClientTransportExistingAcquisitionTimeoutMs { get; set; }
<ConfigAttribute("client-transport/$existing-acquisition-timeout-ms",
    100)>
<ExternalParameterAttribute(New String() { ... })>
Public Property ClientTransportExistingAcquisitionTimeoutMs As Integer
    Get
    Set
<ConfigAttribute("client-transport/$existing-acquisition-timeout-ms",
    100)>
<ExternalParameterAttribute(New String() { ... })>
Public Property ClientTransportExistingAcquisitionTimeoutMs As Integer
    Get
    Set
public:
[ConfigAttribute(L"client-transport/$existing-acquisition-timeout-ms",
    100)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property int ClientTransportExistingAcquisitionTimeoutMs {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(L"client-transport/$existing-acquisition-timeout-ms",
    100)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property int ClientTransportExistingAcquisitionTimeoutMs {
    int get ();
    void set (int value);
}
[<ConfigAttribute("client-transport/$existing-acquisition-timeout-ms",
    100)>]
[<ExternalParameterAttribute(new string[] { ... })>]
member ClientTransportExistingAcquisitionTimeoutMs : int with get, set
[<ConfigAttribute("client-transport/$existing-acquisition-timeout-ms",
    100)>]
[<ExternalParameterAttribute(new string[] { ... })>]
member ClientTransportExistingAcquisitionTimeoutMs : int with get, set

Property Value

Type: Online Int32
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.ClientTransportIdleTimeoutMs Property

Binding ClientTransportIdleTimeoutMs Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Specifies when client transports get auto-closed. Interval is measured in ms. Zero means indefinite/never closed transport. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute("client-transport/$idle-timeout-ms", 120000)]
public int ClientTransportIdleTimeoutMs { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute("client-transport/$idle-timeout-ms", 120000)]
public int ClientTransportIdleTimeoutMs { get; set; }
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute("client-transport/$idle-timeout-ms", 120000)>
Public Property ClientTransportIdleTimeoutMs As Integer
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute("client-transport/$idle-timeout-ms", 120000)>
Public Property ClientTransportIdleTimeoutMs As Integer
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(L"client-transport/$idle-timeout-ms", 120000)]
property int ClientTransportIdleTimeoutMs {
    int get ();
    void set (int value);
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(L"client-transport/$idle-timeout-ms", 120000)]
property int ClientTransportIdleTimeoutMs {
    int get ();
    void set (int value);
}
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute("client-transport/$idle-timeout-ms", 120000)>]
member ClientTransportIdleTimeoutMs : int with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute("client-transport/$idle-timeout-ms", 120000)>]
member ClientTransportIdleTimeoutMs : int with get, set

Property Value

Type: Online Int32
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.ClientTransportMaxCount Property

Binding ClientTransportMaxCount Property NFX Class Library

Imposes a limit on number of active client transports per remote address. Once this limit is reached the binding will block until it can acquire an existing transport instance. Set value to zero to remove the limit. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("client-transport/$max-count", 0)]
[ExternalParameterAttribute(new string[] { ... })]
public int ClientTransportMaxCount { get; set; }
[ConfigAttribute("client-transport/$max-count", 0)]
[ExternalParameterAttribute(new string[] { ... })]
public int ClientTransportMaxCount { get; set; }
<ConfigAttribute("client-transport/$max-count", 0)>
<ExternalParameterAttribute(New String() { ... })>
Public Property ClientTransportMaxCount As Integer
    Get
    Set
<ConfigAttribute("client-transport/$max-count", 0)>
<ExternalParameterAttribute(New String() { ... })>
Public Property ClientTransportMaxCount As Integer
    Get
    Set
public:
[ConfigAttribute(L"client-transport/$max-count", 0)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property int ClientTransportMaxCount {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(L"client-transport/$max-count", 0)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property int ClientTransportMaxCount {
    int get ();
    void set (int value);
}
[<ConfigAttribute("client-transport/$max-count", 0)>]
[<ExternalParameterAttribute(new string[] { ... })>]
member ClientTransportMaxCount : int with get, set
[<ConfigAttribute("client-transport/$max-count", 0)>]
[<ExternalParameterAttribute(new string[] { ... })>]
member ClientTransportMaxCount : int with get, set

Property Value

Type: Online Int32
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.ClientTransportMaxExistingAcquisitionTimeoutMs Property

Binding ClientTransportMaxExistingAcquisitionTimeoutMs Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Imposes a timeout for binding trying to get an existing transport instance per remote address. Binding throws ClientCallException when this timeout is exceeded. A value of zero removes the limit

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("client-transport/$max-existing-acquisition-timeout-ms",
    15000)]
[ExternalParameterAttribute(new string[] { ... })]
public int ClientTransportMaxExistingAcquisitionTimeoutMs { get; set; }
[ConfigAttribute("client-transport/$max-existing-acquisition-timeout-ms",
    15000)]
[ExternalParameterAttribute(new string[] { ... })]
public int ClientTransportMaxExistingAcquisitionTimeoutMs { get; set; }
<ConfigAttribute("client-transport/$max-existing-acquisition-timeout-ms",
    15000)>
<ExternalParameterAttribute(New String() { ... })>
Public Property ClientTransportMaxExistingAcquisitionTimeoutMs As Integer
    Get
    Set
<ConfigAttribute("client-transport/$max-existing-acquisition-timeout-ms",
    15000)>
<ExternalParameterAttribute(New String() { ... })>
Public Property ClientTransportMaxExistingAcquisitionTimeoutMs As Integer
    Get
    Set
public:
[ConfigAttribute(L"client-transport/$max-existing-acquisition-timeout-ms",
    15000)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property int ClientTransportMaxExistingAcquisitionTimeoutMs {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(L"client-transport/$max-existing-acquisition-timeout-ms",
    15000)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property int ClientTransportMaxExistingAcquisitionTimeoutMs {
    int get ();
    void set (int value);
}
[<ConfigAttribute("client-transport/$max-existing-acquisition-timeout-ms",
    15000)>]
[<ExternalParameterAttribute(new string[] { ... })>]
member ClientTransportMaxExistingAcquisitionTimeoutMs : int with get, set
[<ConfigAttribute("client-transport/$max-existing-acquisition-timeout-ms",
    15000)>]
[<ExternalParameterAttribute(new string[] { ... })>]
member ClientTransportMaxExistingAcquisitionTimeoutMs : int with get, set

Property Value

Type: Online Int32
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.ClientTransports Property

Binding ClientTransports Property NFX Class Library

Returns all client transports in the binding stack

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<ClientTransport> ClientTransports { get; }
public IEnumerable<ClientTransport> ClientTransports { get; }
Public ReadOnly Property ClientTransports As IEnumerable(Of ClientTransport)
    Get
Public ReadOnly Property ClientTransports As IEnumerable(Of ClientTransport)
    Get
public:
property IEnumerable<ClientTransport^>^ ClientTransports {
    IEnumerable<ClientTransport^>^ get ();
}
public:
property IEnumerable<ClientTransport^>^ ClientTransports {
    IEnumerable<ClientTransport^>^ get ();
}
member ClientTransports : IEnumerable<ClientTransport> with get
member ClientTransports : IEnumerable<ClientTransport> with get

Property Value

Type: Online IEnumerable ClientTransport
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.ConfigNode Property

Binding ConfigNode Property NFX Class Library

Returns configuration node for this named instance

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IConfigSectionNode ConfigNode { get; }
public IConfigSectionNode ConfigNode { get; }
Public ReadOnly Property ConfigNode As IConfigSectionNode
    Get
Public ReadOnly Property ConfigNode As IConfigSectionNode
    Get
public:
property IConfigSectionNode^ ConfigNode {
    IConfigSectionNode^ get ();
}
public:
property IConfigSectionNode^ ConfigNode {
    IConfigSectionNode^ get ();
}
member ConfigNode : IConfigSectionNode with get
member ConfigNode : IConfigSectionNode with get

Property Value

Type: IConfigSectionNode
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.DumpMsgFormat Property

Binding DumpMsgFormat Property NFX Class Library

Set the format for message dumping

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$dump-format", DumpFormat.Binary)]
[ExternalParameterAttribute(new string[] { ... })]
public DumpFormat DumpMsgFormat { get; set; }
[ConfigAttribute("$dump-format", DumpFormat.Binary)]
[ExternalParameterAttribute(new string[] { ... })]
public DumpFormat DumpMsgFormat { get; set; }
<ConfigAttribute("$dump-format", DumpFormat.Binary)>
<ExternalParameterAttribute(New String() { ... })>
Public Property DumpMsgFormat As DumpFormat
    Get
    Set
<ConfigAttribute("$dump-format", DumpFormat.Binary)>
<ExternalParameterAttribute(New String() { ... })>
Public Property DumpMsgFormat As DumpFormat
    Get
    Set
public:
[ConfigAttribute(L"$dump-format", DumpFormat::Binary)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property DumpFormat DumpMsgFormat {
    DumpFormat get ();
    void set (DumpFormat value);
}
public:
[ConfigAttribute(L"$dump-format", DumpFormat::Binary)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property DumpFormat DumpMsgFormat {
    DumpFormat get ();
    void set (DumpFormat value);
}
[<ConfigAttribute("$dump-format", DumpFormat.Binary)>]
[<ExternalParameterAttribute(new string[] { ... })>]
member DumpMsgFormat : DumpFormat with get, set
[<ConfigAttribute("$dump-format", DumpFormat.Binary)>]
[<ExternalParameterAttribute(new string[] { ... })>]
member DumpMsgFormat : DumpFormat with get, set

Property Value

Type: DumpFormat
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.DumpPath Property

Binding DumpPath Property NFX Class Library

Set the path for message dumping. Must be an existing navigable path

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$dump-path")]
[ExternalParameterAttribute(new string[] { ... })]
public string DumpPath { get; set; }
[ConfigAttribute("$dump-path")]
[ExternalParameterAttribute(new string[] { ... })]
public string DumpPath { get; set; }
<ConfigAttribute("$dump-path")>
<ExternalParameterAttribute(New String() { ... })>
Public Property DumpPath As String
    Get
    Set
<ConfigAttribute("$dump-path")>
<ExternalParameterAttribute(New String() { ... })>
Public Property DumpPath As String
    Get
    Set
public:
[ConfigAttribute(L"$dump-path")]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property String^ DumpPath {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute(L"$dump-path")]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property String^ DumpPath {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute("$dump-path")>]
[<ExternalParameterAttribute(new string[] { ... })>]
member DumpPath : string with get, set
[<ConfigAttribute("$dump-path")>]
[<ExternalParameterAttribute(new string[] { ... })>]
member DumpPath : string with get, set

Property Value

Type: Online String
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.EncodingFormat Property

Binding EncodingFormat Property NFX Class Library

Returns name of msg format encoding

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string EncodingFormat { get; }
public abstract string EncodingFormat { get; }
Public MustOverride ReadOnly Property EncodingFormat As String
    Get
Public MustOverride ReadOnly Property EncodingFormat As String
    Get
public:
virtual property String^ EncodingFormat {
    String^ get () abstract;
}
public:
virtual property String^ EncodingFormat {
    String^ get () abstract;
}
abstract EncodingFormat : string with get
abstract EncodingFormat : string with get

Property Value

Type: Online String
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.InstrumentClientTransportStat Property

Binding InstrumentClientTransportStat Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Defines whether client transport statistics is periodically dumped into instrumentation

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("client-transport/$instrument-transport-stat")]
[ExternalParameterAttribute(new string[] { ... })]
public bool InstrumentClientTransportStat { get; set; }
[ConfigAttribute("client-transport/$instrument-transport-stat")]
[ExternalParameterAttribute(new string[] { ... })]
public bool InstrumentClientTransportStat { get; set; }
<ConfigAttribute("client-transport/$instrument-transport-stat")>
<ExternalParameterAttribute(New String() { ... })>
Public Property InstrumentClientTransportStat As Boolean
    Get
    Set
<ConfigAttribute("client-transport/$instrument-transport-stat")>
<ExternalParameterAttribute(New String() { ... })>
Public Property InstrumentClientTransportStat As Boolean
    Get
    Set
public:
[ConfigAttribute(L"client-transport/$instrument-transport-stat")]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property bool InstrumentClientTransportStat {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute(L"client-transport/$instrument-transport-stat")]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property bool InstrumentClientTransportStat {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute("client-transport/$instrument-transport-stat")>]
[<ExternalParameterAttribute(new string[] { ... })>]
member InstrumentClientTransportStat : bool with get, set
[<ConfigAttribute("client-transport/$instrument-transport-stat")>]
[<ExternalParameterAttribute(new string[] { ... })>]
member InstrumentClientTransportStat : bool with get, set

Property Value

Type: Online Boolean
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.InstrumentServerTransportStat Property

Binding InstrumentServerTransportStat Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Defines whether server transport statistics is periodically dumped into instrumentation

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("server-transport/$instrument-transport-stat")]
[ExternalParameterAttribute(new string[] { ... })]
public bool InstrumentServerTransportStat { get; set; }
[ConfigAttribute("server-transport/$instrument-transport-stat")]
[ExternalParameterAttribute(new string[] { ... })]
public bool InstrumentServerTransportStat { get; set; }
<ConfigAttribute("server-transport/$instrument-transport-stat")>
<ExternalParameterAttribute(New String() { ... })>
Public Property InstrumentServerTransportStat As Boolean
    Get
    Set
<ConfigAttribute("server-transport/$instrument-transport-stat")>
<ExternalParameterAttribute(New String() { ... })>
Public Property InstrumentServerTransportStat As Boolean
    Get
    Set
public:
[ConfigAttribute(L"server-transport/$instrument-transport-stat")]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property bool InstrumentServerTransportStat {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute(L"server-transport/$instrument-transport-stat")]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property bool InstrumentServerTransportStat {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute("server-transport/$instrument-transport-stat")>]
[<ExternalParameterAttribute(new string[] { ... })>]
member InstrumentServerTransportStat : bool with get, set
[<ConfigAttribute("server-transport/$instrument-transport-stat")>]
[<ExternalParameterAttribute(new string[] { ... })>]
member InstrumentServerTransportStat : bool with get, set

Property Value

Type: Online Boolean
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.MeasureStatTimes Property

Binding MeasureStatTimes Property NFX Class Library

Defines whether message processing latency should be measured - i.e. messages time-stamped on arrival

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public bool MeasureStatTimes { get; set; }
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public bool MeasureStatTimes { get; set; }
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property MeasureStatTimes As Boolean
    Get
    Set
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property MeasureStatTimes As Boolean
    Get
    Set
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property bool MeasureStatTimes {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property bool MeasureStatTimes {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
member MeasureStatTimes : bool with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
member MeasureStatTimes : bool with get, set

Property Value

Type: Online Boolean
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.OperationFlow Property

Binding OperationFlow Property NFX Class Library

Returns sync/async flow that this binding provides

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract OperationFlow OperationFlow { get; }
public abstract OperationFlow OperationFlow { get; }
Public MustOverride ReadOnly Property OperationFlow As OperationFlow
    Get
Public MustOverride ReadOnly Property OperationFlow As OperationFlow
    Get
public:
virtual property OperationFlow OperationFlow {
    OperationFlow get () abstract;
}
public:
virtual property OperationFlow OperationFlow {
    OperationFlow get () abstract;
}
abstract OperationFlow : OperationFlow with get
abstract OperationFlow : OperationFlow with get

Property Value

Type: OperationFlow
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.Provider Property

Binding Provider Property NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Provider Provider { get; }
public Provider Provider { get; }
Public ReadOnly Property Provider As Provider
    Get
Public ReadOnly Property Provider As Provider
    Get
public:
property Provider^ Provider {
    Provider^ get ();
}
public:
property Provider^ Provider {
    Provider^ get ();
}
member Provider : Provider with get
member Provider : Provider with get

Property Value

Type: Provider
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.ServerDump Property

Binding ServerDump Property NFX Class Library

Turns on/off server message dumping to disk. Turning on dumping has negative effect on performance and consumes resources

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$server-dump", DumpDetail.None)]
[ExternalParameterAttribute(new string[] { ... })]
public DumpDetail ServerDump { get; set; }
[ConfigAttribute("$server-dump", DumpDetail.None)]
[ExternalParameterAttribute(new string[] { ... })]
public DumpDetail ServerDump { get; set; }
<ConfigAttribute("$server-dump", DumpDetail.None)>
<ExternalParameterAttribute(New String() { ... })>
Public Property ServerDump As DumpDetail
    Get
    Set
<ConfigAttribute("$server-dump", DumpDetail.None)>
<ExternalParameterAttribute(New String() { ... })>
Public Property ServerDump As DumpDetail
    Get
    Set
public:
[ConfigAttribute(L"$server-dump", DumpDetail::None)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property DumpDetail ServerDump {
    DumpDetail get ();
    void set (DumpDetail value);
}
public:
[ConfigAttribute(L"$server-dump", DumpDetail::None)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property DumpDetail ServerDump {
    DumpDetail get ();
    void set (DumpDetail value);
}
[<ConfigAttribute("$server-dump", DumpDetail.None)>]
[<ExternalParameterAttribute(new string[] { ... })>]
member ServerDump : DumpDetail with get, set
[<ConfigAttribute("$server-dump", DumpDetail.None)>]
[<ExternalParameterAttribute(new string[] { ... })>]
member ServerDump : DumpDetail with get, set

Property Value

Type: DumpDetail
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.ServerMsgInspectors Property

Binding ServerMsgInspectors Property NFX Class Library

Returns server message inspectors for this instance

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderedRegistry<IServerMsgInspector> ServerMsgInspectors { get; }
public OrderedRegistry<IServerMsgInspector> ServerMsgInspectors { get; }
Public ReadOnly Property ServerMsgInspectors As OrderedRegistry(Of IServerMsgInspector)
    Get
Public ReadOnly Property ServerMsgInspectors As OrderedRegistry(Of IServerMsgInspector)
    Get
public:
property OrderedRegistry<IServerMsgInspector^>^ ServerMsgInspectors {
    OrderedRegistry<IServerMsgInspector^>^ get ();
}
public:
property OrderedRegistry<IServerMsgInspector^>^ ServerMsgInspectors {
    OrderedRegistry<IServerMsgInspector^>^ get ();
}
member ServerMsgInspectors : OrderedRegistry<IServerMsgInspector> with get
member ServerMsgInspectors : OrderedRegistry<IServerMsgInspector> with get

Property Value

Type: OrderedRegistry IServerMsgInspector
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.ServerTransportIdleTimeoutMs Property

Binding ServerTransportIdleTimeoutMs Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Specifies when server transports get auto-closed. Interval is measured in ms. Zero means indefinite/never closed transport. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("server-transport/$idle-timeout-ms", 600000)]
[ExternalParameterAttribute(new string[] { ... })]
public int ServerTransportIdleTimeoutMs { get; set; }
[ConfigAttribute("server-transport/$idle-timeout-ms", 600000)]
[ExternalParameterAttribute(new string[] { ... })]
public int ServerTransportIdleTimeoutMs { get; set; }
<ConfigAttribute("server-transport/$idle-timeout-ms", 600000)>
<ExternalParameterAttribute(New String() { ... })>
Public Property ServerTransportIdleTimeoutMs As Integer
    Get
    Set
<ConfigAttribute("server-transport/$idle-timeout-ms", 600000)>
<ExternalParameterAttribute(New String() { ... })>
Public Property ServerTransportIdleTimeoutMs As Integer
    Get
    Set
public:
[ConfigAttribute(L"server-transport/$idle-timeout-ms", 600000)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property int ServerTransportIdleTimeoutMs {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(L"server-transport/$idle-timeout-ms", 600000)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property int ServerTransportIdleTimeoutMs {
    int get ();
    void set (int value);
}
[<ConfigAttribute("server-transport/$idle-timeout-ms", 600000)>]
[<ExternalParameterAttribute(new string[] { ... })>]
member ServerTransportIdleTimeoutMs : int with get, set
[<ConfigAttribute("server-transport/$idle-timeout-ms", 600000)>]
[<ExternalParameterAttribute(new string[] { ... })>]
member ServerTransportIdleTimeoutMs : int with get, set

Property Value

Type: Online Int32
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.ServerTransports Property

Binding ServerTransports Property NFX Class Library

Returns all server transports in the binding stack

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<ServerTransport> ServerTransports { get; }
public IEnumerable<ServerTransport> ServerTransports { get; }
Public ReadOnly Property ServerTransports As IEnumerable(Of ServerTransport)
    Get
Public ReadOnly Property ServerTransports As IEnumerable(Of ServerTransport)
    Get
public:
property IEnumerable<ServerTransport^>^ ServerTransports {
    IEnumerable<ServerTransport^>^ get ();
}
public:
property IEnumerable<ServerTransport^>^ ServerTransports {
    IEnumerable<ServerTransport^>^ get ();
}
member ServerTransports : IEnumerable<ServerTransport> with get
member ServerTransports : IEnumerable<ServerTransport> with get

Property Value

Type: Online IEnumerable ServerTransport
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.StatTimesEMAFactor Property

Binding StatTimesEMAFactor Property NFX Class Library

Defines how much smoothing the timing statistics filter does - the lower the number the more smoothing is done. Smoothing makes stat times insensitive to some seldom delays that may happen every now and then

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute("stat-times-ema-factor", 0.04)]
public double StatTimesEMAFactor { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute("stat-times-ema-factor", 0.04)]
public double StatTimesEMAFactor { get; set; }
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute("stat-times-ema-factor", 0.04)>
Public Property StatTimesEMAFactor As Double
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute("stat-times-ema-factor", 0.04)>
Public Property StatTimesEMAFactor As Double
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(L"stat-times-ema-factor", 0.04)]
property double StatTimesEMAFactor {
    double get ();
    void set (double value);
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(L"stat-times-ema-factor", 0.04)]
property double StatTimesEMAFactor {
    double get ();
    void set (double value);
}
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute("stat-times-ema-factor", 0.04)>]
member StatTimesEMAFactor : float with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute("stat-times-ema-factor", 0.04)>]
member StatTimesEMAFactor : float with get, set

Property Value

Type: Online Double
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.StatTimeTicks Property

Binding StatTimeTicks Property NFX Class Library

Returns current time in system frequency-dependent ticks. This property is used to measure accurate times and depends on MeasureStatTimes set to true, otherwise 0 is returned

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long StatTimeTicks { get; }
public long StatTimeTicks { get; }
Public ReadOnly Property StatTimeTicks As Long
    Get
Public ReadOnly Property StatTimeTicks As Long
    Get
public:
property long long StatTimeTicks {
    long long get ();
}
public:
property long long StatTimeTicks {
    long long get ();
}
member StatTimeTicks : int64 with get
member StatTimeTicks : int64 with get

Property Value

Type: Online Int64
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Binding.Transports Property

Binding Transports Property NFX Class Library

Returns all transports in the binding stack

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Transport> Transports { get; }
public IEnumerable<Transport> Transports { get; }
Public ReadOnly Property Transports As IEnumerable(Of Transport)
    Get
Public ReadOnly Property Transports As IEnumerable(Of Transport)
    Get
public:
property IEnumerable<Transport^>^ Transports {
    IEnumerable<Transport^>^ get ();
}
public:
property IEnumerable<Transport^>^ Transports {
    IEnumerable<Transport^>^ get ();
}
member Transports : IEnumerable<Transport> with get
member Transports : IEnumerable<Transport> with get

Property Value

Type: Online IEnumerable Transport
See Also
Binding Class
Binding Members
NFX.Glue Namespace


Bindings Class

Bindings Class NFX Class Library

A registry of Binding-derived instances
Inheritance Hierarchy
Online System Object
NFX Registry Binding
NFX.Glue Bindings

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Bindings : Registry<Binding>
public class Bindings : Registry<Binding>
Public Class Bindings
    Inherits Registry(Of Binding)
Public Class Bindings
    Inherits Registry(Of Binding)
public ref class Bindings : public Registry<Binding^>
public ref class Bindings : public Registry<Binding^>
type Bindings =
    class
        inherit Registry<Binding>
    end
type Bindings =
    class
        inherit Registry<Binding>
    end
See Also
Bindings Members
NFX.Glue Namespace


Bindings Members

Bindings Members NFX Class Library

The Bindings type exposes the following members.
Constructors
 | Name | Description
Public method | Bindings | Initializes a new instance of the Bindings class
Back to Top
Methods
 | Name | Description
Public method | Clear | Deletes all items from registry (Inherited from Registry T .)
Public method | ContainsName | (Inherited from Registry T .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | (Inherited from Registry T .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetOrRegister TContext (String, Func TContext, T , TContext) | Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency (Inherited from Registry T .)
Public method | GetOrRegister TContext (String, Func TContext, T , TContext, Boolean ) | Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency (Inherited from Registry T .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | JustRegistered | (Inherited from Registry T .)
Protected method | JustReplaced | (Inherited from Registry T .)
Protected method | JustUnregistered | (Inherited from Registry T .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Register | Registers item and returns true if it was registered, false if this named instance already existed in the list (Inherited from Registry T .)
Public method | RegisterOrReplace(T) | Registers item and returns true if it was registered, false if this named instance already existed and was replaced (Inherited from Registry T .)
Public method | RegisterOrReplace(T, T ) | Registers item and returns true if it was registered, false if this named instance already existed and was replaced (Inherited from Registry T .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryGetValue | (Inherited from Registry T .)
Public method | Unregister(String) | Unregisters item by name and returns true if it was unregistered, false if it did not exist (Inherited from Registry T .)
Public method | Unregister(T) | Unregisters item and returns true if it was unregistered, false if it did not exist (Inherited from Registry T .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Sync | (Inherited from Registry T .)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns the number of entries in the registry (Inherited from Registry T .)
Public property | IsCaseSensitive | Returns true if the instance differentiates names by case (Inherited from Registry T .)
Public property | Item | Returns a value by name or null if not found (Inherited from Registry T .)
Public property | Names | (Inherited from Registry T .)
Public property | Values | (Inherited from Registry T .)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Registry T .)
Back to Top
See Also
Bindings Class
NFX.Glue Namespace


Bindings Constructor

Bindings Constructor NFX Class Library

Initializes a new instance of the Bindings class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Bindings()
public Bindings()
Public Sub New
Public Sub New
public:
Bindings()
public:
Bindings()
new : unit -> Bindings
new : unit -> Bindings
See Also
Bindings Class
Bindings Members
NFX.Glue Namespace


Bindings Fields

Bindings Fields NFX Class Library

The Bindings type exposes the following members.
Fields
 | Name | Description
Protected field | m_Sync | (Inherited from Registry T .)
Back to Top
See Also
Bindings Class
NFX.Glue Namespace


Bindings Methods

Bindings Methods NFX Class Library

The Bindings type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Deletes all items from registry (Inherited from Registry T .)
Public method | ContainsName | (Inherited from Registry T .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | (Inherited from Registry T .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetOrRegister TContext (String, Func TContext, T , TContext) | Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency (Inherited from Registry T .)
Public method | GetOrRegister TContext (String, Func TContext, T , TContext, Boolean ) | Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency (Inherited from Registry T .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | JustRegistered | (Inherited from Registry T .)
Protected method | JustReplaced | (Inherited from Registry T .)
Protected method | JustUnregistered | (Inherited from Registry T .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Register | Registers item and returns true if it was registered, false if this named instance already existed in the list (Inherited from Registry T .)
Public method | RegisterOrReplace(T) | Registers item and returns true if it was registered, false if this named instance already existed and was replaced (Inherited from Registry T .)
Public method | RegisterOrReplace(T, T ) | Registers item and returns true if it was registered, false if this named instance already existed and was replaced (Inherited from Registry T .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryGetValue | (Inherited from Registry T .)
Public method | Unregister(String) | Unregisters item by name and returns true if it was unregistered, false if it did not exist (Inherited from Registry T .)
Public method | Unregister(T) | Unregisters item and returns true if it was unregistered, false if it did not exist (Inherited from Registry T .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Registry T .)
Back to Top
See Also
Bindings Class
NFX.Glue Namespace


Bindings Properties

Bindings Properties NFX Class Library

The Bindings type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns the number of entries in the registry (Inherited from Registry T .)
Public property | IsCaseSensitive | Returns true if the instance differentiates names by case (Inherited from Registry T .)
Public property | Item | Returns a value by name or null if not found (Inherited from Registry T .)
Public property | Names | (Inherited from Registry T .)
Public property | Values | (Inherited from Registry T .)
Back to Top
See Also
Bindings Class
NFX.Glue Namespace


Call Class

Call Class NFX Class Library

Describes a flow of events originating from a Glue client call
Inheritance Hierarchy
Online System Object
NFX.Glue Call

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Call
public class Call
Public Class Call
Public Class Call
public ref class Call
public ref class Call
type Call =  class end
type Call =  class end
See Also
Call Members
NFX.Glue Namespace


Call Members

Call Members NFX Class Library

The Call type exposes the following members.
Constructors
 | Name | Description
Public method | Call(CallSlot) | Initializes a new instance of the Call class
Public method | Call(CallSlot, Action CallReactor, Call ) | Initializes a new instance of the Call class
Public method | Call(CallSlot, Object, Action CallReactor, Call, Object ) | Initializes a new instance of the Call class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeCallbackAndFinish |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Reactor |
Back to Top
Properties
 | Name | Description
Public property | CallbackException | Returns exception that was thrown from callback or null if no exception happened
Public property | CallSlot | Returns CallSlot that represents this call
Public property | Context | Retruns call-dependent context object if one was supplied in call .ctor, or null
Public property | Ended | Returns true when call has ended with all attached events/callbacks
Public property | Reactor | Returns the reactor that services this call
Back to Top
See Also
Call Class
NFX.Glue Namespace


Call Constructor

Call Constructor NFX Class Library

Overload List
 | Name | Description
Public method | Call(CallSlot) | Initializes a new instance of the Call class
Public method | Call(CallSlot, Action CallReactor, Call ) | Initializes a new instance of the Call class
Public method | Call(CallSlot, Object, Action CallReactor, Call, Object ) | Initializes a new instance of the Call class
Back to Top
See Also
Call Class
Call Members
NFX.Glue Namespace


Call Constructor (CallSlot)

Call Constructor (CallSlot) NFX Class Library

Initializes a new instance of the Call class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Call(
    CallSlot call
)
public Call(
    CallSlot call
)
Public Sub New (
    call As CallSlot
)
Public Sub New (
    call As CallSlot
)
public:
Call(
    CallSlot^ call
)
public:
Call(
    CallSlot^ call
)
new :
        call : CallSlot -> Call
new :
        call : CallSlot -> Call

Parameters

call
Type: NFX.Glue CallSlot
See Also
Call Class
Call Members
Call Overload
NFX.Glue Namespace


Call Constructor (CallSlot, Action(CallReactor, Call))

Call Constructor (CallSlot, Action CallReactor, Call ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Call class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Call(
    CallSlot call,
    Action<CallReactor, Call> callback
)
public Call(
    CallSlot call,
    Action<CallReactor, Call> callback
)
Public Sub New (
    call As CallSlot,
    callback As Action(Of CallReactor, Call)
)
Public Sub New (
    call As CallSlot,
    callback As Action(Of CallReactor, Call)
)
public:
Call(
    CallSlot^ call,
    Action<CallReactor^, Call^>^ callback
)
public:
Call(
    CallSlot^ call,
    Action<CallReactor^, Call^>^ callback
)
new :
        call : CallSlot *
        callback : Action<CallReactor, Call> -> Call
new :
        call : CallSlot *
        callback : Action<CallReactor, Call> -> Call

Parameters

call
Type: NFX.Glue CallSlot
callback
Type: Online System Action CallReactor, Call
See Also
Call Class
Call Members
Call Overload
NFX.Glue Namespace


Call Constructor (CallSlot, Object, Action(CallReactor, Call, Object))

Call Constructor (CallSlot, Object, Action CallReactor, Call, Object ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Call class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Call(
    CallSlot call,
    Object context,
    Action<CallReactor, Call, Object> callback
)
public Call(
    CallSlot call,
    Object context,
    Action<CallReactor, Call, Object> callback
)
Public Sub New (
    call As CallSlot,
    context As Object,
    callback As Action(Of CallReactor, Call, Object)
)
Public Sub New (
    call As CallSlot,
    context As Object,
    callback As Action(Of CallReactor, Call, Object)
)
public:
Call(
    CallSlot^ call,
    Object^ context,
    Action<CallReactor^, Call^, Object^>^ callback
)
public:
Call(
    CallSlot^ call,
    Object^ context,
    Action<CallReactor^, Call^, Object^>^ callback
)
new :
        call : CallSlot *
        context : Object *
        callback : Action<CallReactor, Call, Object> -> Call
new :
        call : CallSlot *
        context : Object *
        callback : Action<CallReactor, Call, Object> -> Call

Parameters

call
Type: NFX.Glue CallSlot
context
Type: Online System Object
callback
Type: Online System Action CallReactor, Call, Online Object
See Also
Call Class
Call Members
Call Overload
NFX.Glue Namespace


Call Fields

Call Fields NFX Class Library

The Call type exposes the following members.
Fields
 | Name | Description
Protected field | m_Reactor |
Back to Top
See Also
Call Class
NFX.Glue Namespace


Call.m_Reactor Field

Call m_Reactor Field NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CallReactor m_Reactor
internal CallReactor m_Reactor
Friend m_Reactor As CallReactor
Friend m_Reactor As CallReactor
internal:
CallReactor^ m_Reactor
internal:
CallReactor^ m_Reactor
val mutable internal m_Reactor: CallReactor
val mutable internal m_Reactor: CallReactor

Field Value

Type: CallReactor
See Also
Call Class
Call Members
NFX.Glue Namespace


Call Methods

Call Methods NFX Class Library

The Call type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeCallbackAndFinish |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Call Class
NFX.Glue Namespace


Call.MakeCallbackAndFinish Method

Call MakeCallbackAndFinish Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void MakeCallbackAndFinish()
internal void MakeCallbackAndFinish()
Friend Sub MakeCallbackAndFinish
Friend Sub MakeCallbackAndFinish
internal:
void MakeCallbackAndFinish()
internal:
void MakeCallbackAndFinish()
internal member MakeCallbackAndFinish : unit -> unit
internal member MakeCallbackAndFinish : unit -> unit
See Also
Call Class
Call Members
NFX.Glue Namespace


Call Properties

Call Properties NFX Class Library

The Call type exposes the following members.
Properties
 | Name | Description
Public property | CallbackException | Returns exception that was thrown from callback or null if no exception happened
Public property | CallSlot | Returns CallSlot that represents this call
Public property | Context | Retruns call-dependent context object if one was supplied in call .ctor, or null
Public property | Ended | Returns true when call has ended with all attached events/callbacks
Public property | Reactor | Returns the reactor that services this call
Back to Top
See Also
Call Class
NFX.Glue Namespace


Call.CallbackException Property

Call CallbackException Property NFX Class Library

Returns exception that was thrown from callback or null if no exception happened

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Exception CallbackException { get; }
public Exception CallbackException { get; }
Public ReadOnly Property CallbackException As Exception
    Get
Public ReadOnly Property CallbackException As Exception
    Get
public:
property Exception^ CallbackException {
    Exception^ get ();
}
public:
property Exception^ CallbackException {
    Exception^ get ();
}
member CallbackException : Exception with get
member CallbackException : Exception with get

Property Value

Type: Online Exception
See Also
Call Class
Call Members
NFX.Glue Namespace


Call.CallSlot Property

Call CallSlot Property NFX Class Library

Returns CallSlot that represents this call

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CallSlot CallSlot { get; }
public CallSlot CallSlot { get; }
Public ReadOnly Property CallSlot As CallSlot
    Get
Public ReadOnly Property CallSlot As CallSlot
    Get
public:
property CallSlot^ CallSlot {
    CallSlot^ get ();
}
public:
property CallSlot^ CallSlot {
    CallSlot^ get ();
}
member CallSlot : CallSlot with get
member CallSlot : CallSlot with get

Property Value

Type: CallSlot
See Also
Call Class
Call Members
NFX.Glue Namespace


Call.Context Property

Call Context Property NFX Class Library

Retruns call-dependent context object if one was supplied in call .ctor, or null

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Context { get; }
public Object Context { get; }
Public ReadOnly Property Context As Object
    Get
Public ReadOnly Property Context As Object
    Get
public:
property Object^ Context {
    Object^ get ();
}
public:
property Object^ Context {
    Object^ get ();
}
member Context : Object with get
member Context : Object with get

Property Value

Type: Online Object
See Also
Call Class
Call Members
NFX.Glue Namespace


Call.Ended Property

Call Ended Property NFX Class Library

Returns true when call has ended with all attached events/callbacks

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Ended { get; }
public bool Ended { get; }
Public ReadOnly Property Ended As Boolean
    Get
Public ReadOnly Property Ended As Boolean
    Get
public:
property bool Ended {
    bool get ();
}
public:
property bool Ended {
    bool get ();
}
member Ended : bool with get
member Ended : bool with get

Property Value

Type: Online Boolean
See Also
Call Class
Call Members
NFX.Glue Namespace


Call.Reactor Property

Call Reactor Property NFX Class Library

Returns the reactor that services this call

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CallReactor Reactor { get; }
public CallReactor Reactor { get; }
Public ReadOnly Property Reactor As CallReactor
    Get
Public ReadOnly Property Reactor As CallReactor
    Get
public:
property CallReactor^ Reactor {
    CallReactor^ get ();
}
public:
property CallReactor^ Reactor {
    CallReactor^ get ();
}
member Reactor : CallReactor with get
member Reactor : CallReactor with get

Property Value

Type: CallReactor
See Also
Call Class
Call Members
NFX.Glue Namespace


CallReactor Class

CallReactor Class NFX Class Library

Facilititates execution of asynchronous client calls and their corresponding callback functions. This class introduces callback execution latency and is handy for cases where eventual event flow need to execute regardless of timing. The latency depends on other callback implementation as the reactor services all calls from a single thread
Inheritance Hierarchy
Online System Object
NFX.Glue CallReactor

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class CallReactor
public sealed class CallReactor
Public NotInheritable Class CallReactor
Public NotInheritable Class CallReactor
public ref class CallReactor sealed
public ref class CallReactor sealed
[<SealedAttribute>]
type CallReactor =  class end
[<SealedAttribute>]
type CallReactor =  class end
See Also
CallReactor Members
NFX.Glue Namespace


CallReactor Members

CallReactor Members NFX Class Library

The CallReactor type exposes the following members.
Constructors
 | Name | Description
Public method | CallReactor( Call ) | Initializes a new instance of the CallReactor class
Public method | CallReactor(IEnumerable Call ) | Initializes a new instance of the CallReactor class
Public method | CallReactor(Boolean, Call ) | Initializes a new instance of the CallReactor class
Public method | CallReactor(IEnumerable Call , Boolean) | Initializes a new instance of the CallReactor class
Public method | CallReactor(IEnumerable Call , Action CallReactor , Object) | Initializes a new instance of the CallReactor class
Public method | CallReactor(Action CallReactor , Object, Call ) | Initializes a new instance of the CallReactor class
Public method | CallReactor(Boolean, Action CallReactor , Object, Call ) | Initializes a new instance of the CallReactor class
Public method | CallReactor(IEnumerable Call , Boolean, Action CallReactor , Object) | Initializes a new instance of the CallReactor class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Wait | Blocks until all calls managed by this reactor instance have ended
 | WaitAll | Waits for all reactors to finish
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
THREAD_NAME |
THREAD_SLEEP_MSEC |
Back to Top
Properties
 | Name | Description
Public property | Calls | Enumerates all calls that this reactor instance services
Public property | Context | Gets/sets reactor-wide context which is originally supplied in .ctor or null
Public property | Exception | Returns an exception surfaced during reactor operation or null
Public property | Finished | Retunrs true when all calls have finished processing
Back to Top
See Also
CallReactor Class
NFX.Glue Namespace


CallReactor Constructor

CallReactor Constructor NFX Class Library

Overload List
 | Name | Description
Public method | CallReactor( Call ) | Initializes a new instance of the CallReactor class
Public method | CallReactor(IEnumerable Call ) | Initializes a new instance of the CallReactor class
Public method | CallReactor(Boolean, Call ) | Initializes a new instance of the CallReactor class
Public method | CallReactor(IEnumerable Call , Boolean) | Initializes a new instance of the CallReactor class
Public method | CallReactor(IEnumerable Call , Action CallReactor , Object) | Initializes a new instance of the CallReactor class
Public method | CallReactor(Action CallReactor , Object, Call ) | Initializes a new instance of the CallReactor class
Public method | CallReactor(Boolean, Action CallReactor , Object, Call ) | Initializes a new instance of the CallReactor class
Public method | CallReactor(IEnumerable Call , Boolean, Action CallReactor , Object) | Initializes a new instance of the CallReactor class
Back to Top
See Also
CallReactor Class
CallReactor Members
NFX.Glue Namespace


CallReactor Constructor (Call[])

CallReactor Constructor ( Call ) NFX Class Library

Initializes a new instance of the CallReactor class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CallReactor(
    params Call[] calls
)
public CallReactor(
    params Call[] calls
)
Public Sub New (
    ParamArray calls As Call()
)
Public Sub New (
    ParamArray calls As Call()
)
public:
CallReactor(
    ... array<Call^>^ calls
)
public:
CallReactor(
    ... array<Call^>^ calls
)
new :
        calls : Call[] -> CallReactor
new :
        calls : Call[] -> CallReactor

Parameters

calls
Type: NFX.Glue Call
See Also
CallReactor Class
CallReactor Members
CallReactor Overload
NFX.Glue Namespace


CallReactor Constructor (IEnumerable(Call))

CallReactor Constructor (IEnumerable Call ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CallReactor class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CallReactor(
    IEnumerable<Call> calls
)
public CallReactor(
    IEnumerable<Call> calls
)
Public Sub New (
    calls As IEnumerable(Of Call)
)
Public Sub New (
    calls As IEnumerable(Of Call)
)
public:
CallReactor(
    IEnumerable<Call^>^ calls
)
public:
CallReactor(
    IEnumerable<Call^>^ calls
)
new :
        calls : IEnumerable<Call> -> CallReactor
new :
        calls : IEnumerable<Call> -> CallReactor

Parameters

calls
Type: Online System.Collections.Generic IEnumerable Call
See Also
CallReactor Class
CallReactor Members
CallReactor Overload
NFX.Glue Namespace


CallReactor Constructor (Boolean, Call[])

CallReactor Constructor (Boolean, Call ) NFX Class Library

Initializes a new instance of the CallReactor class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CallReactor(
    bool isBackground,
    params Call[] calls
)
public CallReactor(
    bool isBackground,
    params Call[] calls
)
Public Sub New (
    isBackground As Boolean,
    ParamArray calls As Call()
)
Public Sub New (
    isBackground As Boolean,
    ParamArray calls As Call()
)
public:
CallReactor(
    bool isBackground,
    ... array<Call^>^ calls
)
public:
CallReactor(
    bool isBackground,
    ... array<Call^>^ calls
)
new :
        isBackground : bool *
        calls : Call[] -> CallReactor
new :
        isBackground : bool *
        calls : Call[] -> CallReactor

Parameters

isBackground
Type: Online System Boolean
calls
Type: NFX.Glue Call
See Also
CallReactor Class
CallReactor Members
CallReactor Overload
NFX.Glue Namespace


CallReactor Constructor (IEnumerable(Call), Boolean)

CallReactor Constructor (IEnumerable Call , Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CallReactor class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CallReactor(
    IEnumerable<Call> calls,
    bool isBackground
)
public CallReactor(
    IEnumerable<Call> calls,
    bool isBackground
)
Public Sub New (
    calls As IEnumerable(Of Call),
    isBackground As Boolean
)
Public Sub New (
    calls As IEnumerable(Of Call),
    isBackground As Boolean
)
public:
CallReactor(
    IEnumerable<Call^>^ calls,
    bool isBackground
)
public:
CallReactor(
    IEnumerable<Call^>^ calls,
    bool isBackground
)
new :
        calls : IEnumerable<Call> *
        isBackground : bool -> CallReactor
new :
        calls : IEnumerable<Call> *
        isBackground : bool -> CallReactor

Parameters

calls
Type: Online System.Collections.Generic IEnumerable Call
isBackground
Type: Online System Boolean
See Also
CallReactor Class
CallReactor Members
CallReactor Overload
NFX.Glue Namespace


CallReactor Constructor (IEnumerable(Call), Action(CallReactor), Object)

CallReactor Constructor (IEnumerable Call , Action CallReactor , Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CallReactor class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CallReactor(
    IEnumerable<Call> calls,
    Action<CallReactor> finishAction,
    Object context
)
public CallReactor(
    IEnumerable<Call> calls,
    Action<CallReactor> finishAction,
    Object context
)
Public Sub New (
    calls As IEnumerable(Of Call),
    finishAction As Action(Of CallReactor),
    context As Object
)
Public Sub New (
    calls As IEnumerable(Of Call),
    finishAction As Action(Of CallReactor),
    context As Object
)
public:
CallReactor(
    IEnumerable<Call^>^ calls,
    Action<CallReactor^>^ finishAction,
    Object^ context
)
public:
CallReactor(
    IEnumerable<Call^>^ calls,
    Action<CallReactor^>^ finishAction,
    Object^ context
)
new :
        calls : IEnumerable<Call> *
        finishAction : Action<CallReactor> *
        context : Object -> CallReactor
new :
        calls : IEnumerable<Call> *
        finishAction : Action<CallReactor> *
        context : Object -> CallReactor

Parameters

calls
Type: Online System.Collections.Generic IEnumerable Call
finishAction
Type: Online System Action CallReactor
context
Type: Online System Object
See Also
CallReactor Class
CallReactor Members
CallReactor Overload
NFX.Glue Namespace


CallReactor Constructor (Action(CallReactor), Object, Call[])

CallReactor Constructor (Action CallReactor , Object, Call ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CallReactor class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CallReactor(
    Action<CallReactor> finishAction,
    Object context,
    params Call[] calls
)
public CallReactor(
    Action<CallReactor> finishAction,
    Object context,
    params Call[] calls
)
Public Sub New (
    finishAction As Action(Of CallReactor),
    context As Object,
    ParamArray calls As Call()
)
Public Sub New (
    finishAction As Action(Of CallReactor),
    context As Object,
    ParamArray calls As Call()
)
public:
CallReactor(
    Action<CallReactor^>^ finishAction,
    Object^ context,
    ... array<Call^>^ calls
)
public:
CallReactor(
    Action<CallReactor^>^ finishAction,
    Object^ context,
    ... array<Call^>^ calls
)
new :
        finishAction : Action<CallReactor> *
        context : Object *
        calls : Call[] -> CallReactor
new :
        finishAction : Action<CallReactor> *
        context : Object *
        calls : Call[] -> CallReactor

Parameters

finishAction
Type: Online System Action CallReactor
context
Type: Online System Object
calls
Type: NFX.Glue Call
See Also
CallReactor Class
CallReactor Members
CallReactor Overload
NFX.Glue Namespace


CallReactor Constructor (Boolean, Action(CallReactor), Object, Call[])

CallReactor Constructor (Boolean, Action CallReactor , Object, Call ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CallReactor class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CallReactor(
    bool isBackground,
    Action<CallReactor> finishAction,
    Object context,
    params Call[] calls
)
public CallReactor(
    bool isBackground,
    Action<CallReactor> finishAction,
    Object context,
    params Call[] calls
)
Public Sub New (
    isBackground As Boolean,
    finishAction As Action(Of CallReactor),
    context As Object,
    ParamArray calls As Call()
)
Public Sub New (
    isBackground As Boolean,
    finishAction As Action(Of CallReactor),
    context As Object,
    ParamArray calls As Call()
)
public:
CallReactor(
    bool isBackground,
    Action<CallReactor^>^ finishAction,
    Object^ context,
    ... array<Call^>^ calls
)
public:
CallReactor(
    bool isBackground,
    Action<CallReactor^>^ finishAction,
    Object^ context,
    ... array<Call^>^ calls
)
new :
        isBackground : bool *
        finishAction : Action<CallReactor> *
        context : Object *
        calls : Call[] -> CallReactor
new :
        isBackground : bool *
        finishAction : Action<CallReactor> *
        context : Object *
        calls : Call[] -> CallReactor

Parameters

isBackground
Type: Online System Boolean
finishAction
Type: Online System Action CallReactor
context
Type: Online System Object
calls
Type: NFX.Glue Call
See Also
CallReactor Class
CallReactor Members
CallReactor Overload
NFX.Glue Namespace


CallReactor Constructor (IEnumerable(Call), Boolean, Action(CallReactor), Object)

CallReactor Constructor (IEnumerable Call , Boolean, Action CallReactor , Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CallReactor class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CallReactor(
    IEnumerable<Call> calls,
    bool isBackground,
    Action<CallReactor> finishAction,
    Object context
)
public CallReactor(
    IEnumerable<Call> calls,
    bool isBackground,
    Action<CallReactor> finishAction,
    Object context
)
Public Sub New (
    calls As IEnumerable(Of Call),
    isBackground As Boolean,
    finishAction As Action(Of CallReactor),
    context As Object
)
Public Sub New (
    calls As IEnumerable(Of Call),
    isBackground As Boolean,
    finishAction As Action(Of CallReactor),
    context As Object
)
public:
CallReactor(
    IEnumerable<Call^>^ calls,
    bool isBackground,
    Action<CallReactor^>^ finishAction,
    Object^ context
)
public:
CallReactor(
    IEnumerable<Call^>^ calls,
    bool isBackground,
    Action<CallReactor^>^ finishAction,
    Object^ context
)
new :
        calls : IEnumerable<Call> *
        isBackground : bool *
        finishAction : Action<CallReactor> *
        context : Object -> CallReactor
new :
        calls : IEnumerable<Call> *
        isBackground : bool *
        finishAction : Action<CallReactor> *
        context : Object -> CallReactor

Parameters

calls
Type: Online System.Collections.Generic IEnumerable Call
isBackground
Type: Online System Boolean
finishAction
Type: Online System Action CallReactor
context
Type: Online System Object
See Also
CallReactor Class
CallReactor Members
CallReactor Overload
NFX.Glue Namespace


CallReactor Fields

CallReactor Fields NFX Class Library

The CallReactor type exposes the following members.
Fields
Name | Description
THREAD_NAME |
THREAD_SLEEP_MSEC |
Back to Top
See Also
CallReactor Class
NFX.Glue Namespace


CallReactor.THREAD_NAME Field

CallReactor THREAD_NAME Field NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string THREAD_NAME
public const string THREAD_NAME
Public Const THREAD_NAME As String
Public Const THREAD_NAME As String
public:
literal String^ THREAD_NAME
public:
literal String^ THREAD_NAME
static val mutable THREAD_NAME: string
static val mutable THREAD_NAME: string

Field Value

Type: Online String
See Also
CallReactor Class
CallReactor Members
NFX.Glue Namespace


CallReactor.THREAD_SLEEP_MSEC Field

CallReactor THREAD_SLEEP_MSEC Field NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int THREAD_SLEEP_MSEC
public const int THREAD_SLEEP_MSEC
Public Const THREAD_SLEEP_MSEC As Integer
Public Const THREAD_SLEEP_MSEC As Integer
public:
literal int THREAD_SLEEP_MSEC
public:
literal int THREAD_SLEEP_MSEC
static val mutable THREAD_SLEEP_MSEC: int
static val mutable THREAD_SLEEP_MSEC: int

Field Value

Type: Online Int32
See Also
CallReactor Class
CallReactor Members
NFX.Glue Namespace


CallReactor Methods

CallReactor Methods NFX Class Library

The CallReactor type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Wait | Blocks until all calls managed by this reactor instance have ended
 | WaitAll | Waits for all reactors to finish
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CallReactor Class
NFX.Glue Namespace


CallReactor.Wait Method

CallReactor Wait Method NFX Class Library

Blocks until all calls managed by this reactor instance have ended

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Wait()
public void Wait()
Public Sub Wait
Public Sub Wait
public:
void Wait()
public:
void Wait()
member Wait : unit -> unit
member Wait : unit -> unit
See Also
CallReactor Class
CallReactor Members
NFX.Glue Namespace


CallReactor.WaitAll Method

CallReactor WaitAll Method NFX Class Library

Waits for all reactors to finish

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WaitAll(
    IEnumerable<CallReactor> reactors
)
public static void WaitAll(
    IEnumerable<CallReactor> reactors
)
Public Shared Sub WaitAll (
    reactors As IEnumerable(Of CallReactor)
)
Public Shared Sub WaitAll (
    reactors As IEnumerable(Of CallReactor)
)
public:
static void WaitAll(
    IEnumerable<CallReactor^>^ reactors
)
public:
static void WaitAll(
    IEnumerable<CallReactor^>^ reactors
)
static member WaitAll :
        reactors : IEnumerable<CallReactor> -> unit
static member WaitAll :
        reactors : IEnumerable<CallReactor> -> unit

Parameters

reactors
Type: Online System.Collections.Generic IEnumerable CallReactor
See Also
CallReactor Class
CallReactor Members
NFX.Glue Namespace


CallReactor Properties

CallReactor Properties NFX Class Library

The CallReactor type exposes the following members.
Properties
 | Name | Description
Public property | Calls | Enumerates all calls that this reactor instance services
Public property | Context | Gets/sets reactor-wide context which is originally supplied in .ctor or null
Public property | Exception | Returns an exception surfaced during reactor operation or null
Public property | Finished | Retunrs true when all calls have finished processing
Back to Top
See Also
CallReactor Class
NFX.Glue Namespace


CallReactor.Calls Property

CallReactor Calls Property NFX Class Library

Enumerates all calls that this reactor instance services

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Call> Calls { get; }
public IEnumerable<Call> Calls { get; }
Public ReadOnly Property Calls As IEnumerable(Of Call)
    Get
Public ReadOnly Property Calls As IEnumerable(Of Call)
    Get
public:
property IEnumerable<Call^>^ Calls {
    IEnumerable<Call^>^ get ();
}
public:
property IEnumerable<Call^>^ Calls {
    IEnumerable<Call^>^ get ();
}
member Calls : IEnumerable<Call> with get
member Calls : IEnumerable<Call> with get

Property Value

Type: Online IEnumerable Call
See Also
CallReactor Class
CallReactor Members
NFX.Glue Namespace


CallReactor.Context Property

CallReactor Context Property NFX Class Library

Gets/sets reactor-wide context which is originally supplied in .ctor or null

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Context { get; set; }
public Object Context { get; set; }
Public Property Context As Object
    Get
    Set
Public Property Context As Object
    Get
    Set
public:
property Object^ Context {
    Object^ get ();
    void set (Object^ value);
}
public:
property Object^ Context {
    Object^ get ();
    void set (Object^ value);
}
member Context : Object with get, set
member Context : Object with get, set

Property Value

Type: Online Object
See Also
CallReactor Class
CallReactor Members
NFX.Glue Namespace


CallReactor.Exception Property

CallReactor Exception Property NFX Class Library

Returns an exception surfaced during reactor operation or null

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Exception Exception { get; }
public Exception Exception { get; }
Public ReadOnly Property Exception As Exception
    Get
Public ReadOnly Property Exception As Exception
    Get
public:
property Exception^ Exception {
    Exception^ get ();
}
public:
property Exception^ Exception {
    Exception^ get ();
}
member Exception : Exception with get
member Exception : Exception with get

Property Value

Type: Online Exception
See Also
CallReactor Class
CallReactor Members
NFX.Glue Namespace


CallReactor.Finished Property

CallReactor Finished Property NFX Class Library

Retunrs true when all calls have finished processing

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Finished { get; }
public bool Finished { get; }
Public ReadOnly Property Finished As Boolean
    Get
Public ReadOnly Property Finished As Boolean
    Get
public:
property bool Finished {
    bool get ();
}
public:
property bool Finished {
    bool get ();
}
member Finished : bool with get
member Finished : bool with get

Property Value

Type: Online Boolean
See Also
CallReactor Class
CallReactor Members
NFX.Glue Namespace


CallSlot Class

CallSlot Class NFX Class Library

Represents a class that is immediately returned after transport sends RequestMsg. This class provides CallStatus and RequestID properties where the later is used to match the incoming ResponseMsg. CallSlots are kinds of "spirit-less" mailboxes that keep state about the call, but do not posess any threads/call events. Working with CallSlots from calling code's existing thread of execution is the most efficient way of working with Glue (in high load cases), as it does not create extra object instances (tasks do) for asynchronous coordination and continuation. It is possible to obtain an instance of CallSlot.AsTask in which case that instance is registered with the framework-internal reactor so task does complete normally even on timeout, however, in high-throughput apps (10K+ calls per second) this method is not the most efficient one as it allocates additional objects (task, list entry etc.) that eventually increase GC load for long runs. Note: A 3.2 Ghz 4-Core I7 server with 8Gb of ram can easily handle 40K 2-way calls a second (given little business server logic and simple payload). See also: CallReactor class
Inheritance Hierarchy
Online System Object
NFX.Glue CallSlot

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class CallSlot
public sealed class CallSlot
Public NotInheritable Class CallSlot
Public NotInheritable Class CallSlot
public ref class CallSlot sealed
public ref class CallSlot sealed
[<SealedAttribute>]
type CallSlot =  class end
[<SealedAttribute>]
type CallSlot =  class end
See Also
CallSlot Members
NFX.Glue Namespace


CallSlot Members

CallSlot Members NFX Class Library

The CallSlot type exposes the following members.
Constructors
 | Name | Description
Public method | CallSlot(ClientEndPoint, ClientTransport, RequestMsg, CallStatus, Int32) | INTERNAL METHOD. Developers do not call! This constructor is used by an Async binding that delivers response after call slot was created
Public method | CallSlot(ClientEndPoint, ClientTransport, Int64, DateTime, RequestMsg, ResponseMsg, Int32) | INTERNAL METHOD. Developers do not call! This constructor is used by a synchronous binding that delivers response right after sending it. ONLY for OneWayCall = false
Back to Top
Methods
 | Name | Description
Public method | AsTaskReturning TCallResult | Creates a wrapper task around CallSlot.AsTask and returns CallSlot.GetValue() as TCallResult-returning Task. Note: the created wrapper task is not cached
Public method | AsTaskReturningVoid | Creates a wrapper task around CallSlot.AsTask and returns CallSlot.CheckVoidValue() Note: the created wrapper task is not cached
Public method | CheckVoidValue | Checks for a valid void value returned from the other side, that is - gets the response message and checks it for errors, throwing RemoteError exception if one came from server. Accessing this property blocks calling thread until either ResponseMsg arrives or timeout expires. Check 'Available' property not to block. Accessing this method for [OneWay] methods throws.
Protected method | DeliverResponse | Called internally by framework to populate the response message when one asynchronously arrives from transport
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetValue T | Returns a value from the other side, that is - gets the response message and checks it for errors, throwing RemoteError exception if one came from server. Accessing this property blocks calling thread until either ResponseMsg arrives or timeout expires. Check 'Available' property not to block. Accessing this method for [OneWay] methods throws.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | SignalDispatchError | Signal erroneous completion of request dispatching. This method is used by transports that post outgoing message asynchronously
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | DEFAULT_TIMEOUT_MS |
Protected field | m_TaskCompletionSource |
Back to Top
Properties
 | Name | Description
Public property | AsTask | Gets the CallSlot instance as a task that gets completed either instantly for one-way calls or when result arrives or timeout happens. The returned task never gets canceled
Public property | Available | Returns true when response has come and available so no blocking will occur when reading response. This is a non-blocking call. Always returns true for operations marked as [OneWay]
Public property | CallContext | General-purpose property that clients can use for attaching an arbitrary context to this instance. This property has no use in the framework
Public property | CallStatus | Returns current call status. Timeout is returned when response has not arrived from the other side in alotted time. This is a non-blocking call
Public property | Client | Returns client endpoint that initiated this call
Public property | ClientTransport | Returns client transport that this instance is originated from
Public property | DispatchErrorMessage | Optionally returns reason of the dispatch message failure
Public property | OneWay | Indicates that this call does not expect a response message from the server side
Public property | RequestID | Returns request ID for the request that was sent and generated this slot instance
Public property | ResponseMsg | Blocks until response comes or timeout happens. Response message inspection happens in the context of a calling thread
Public property | StartTime | Returns UTC timestamp of call initiation
Public property | StatRoundtripEndTimeTicks | When binding's MeasureStatTimes enabled, returns the operation end (when response arrives) tick count
Public property | StatRoundtripTimeKey | When binding's MeasureStatTimes enabled, returns the name of the stat key
Public property | StatStartTimeTicks | When binding's MeasureStatTimes enabled, returns the operation start tick count
Public property | TimeoutMs | Returns timeout for this instance
Back to Top
See Also
CallSlot Class
NFX.Glue Namespace


CallSlot Constructor

CallSlot Constructor NFX Class Library

Overload List
 | Name | Description
Public method | CallSlot(ClientEndPoint, ClientTransport, RequestMsg, CallStatus, Int32) | INTERNAL METHOD. Developers do not call! This constructor is used by an Async binding that delivers response after call slot was created
Public method | CallSlot(ClientEndPoint, ClientTransport, Int64, DateTime, RequestMsg, ResponseMsg, Int32) | INTERNAL METHOD. Developers do not call! This constructor is used by a synchronous binding that delivers response right after sending it. ONLY for OneWayCall = false
Back to Top
See Also
CallSlot Class
CallSlot Members
NFX.Glue Namespace


CallSlot Constructor (ClientEndPoint, ClientTransport, RequestMsg, CallStatus, Int32)

CallSlot Constructor (ClientEndPoint, ClientTransport, RequestMsg, CallStatus, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

INTERNAL METHOD. Developers do not call! This constructor is used by an Async binding that delivers response after call slot was created

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CallSlot(
    ClientEndPoint client,
    ClientTransport clientTransport,
    RequestMsg request,
    CallStatus status,
    int timeoutMs = 0
)
public CallSlot(
    ClientEndPoint client,
    ClientTransport clientTransport,
    RequestMsg request,
    CallStatus status,
    int timeoutMs = 0
)
Public Sub New (
    client As ClientEndPoint,
    clientTransport As ClientTransport,
    request As RequestMsg,
    status As CallStatus,
    Optional timeoutMs As Integer = 0
)
Public Sub New (
    client As ClientEndPoint,
    clientTransport As ClientTransport,
    request As RequestMsg,
    status As CallStatus,
    Optional timeoutMs As Integer = 0
)
public:
CallSlot(
    ClientEndPoint^ client,
    ClientTransport^ clientTransport,
    RequestMsg^ request,
    CallStatus status,
    int timeoutMs = 0
)
public:
CallSlot(
    ClientEndPoint^ client,
    ClientTransport^ clientTransport,
    RequestMsg^ request,
    CallStatus status,
    int timeoutMs = 0
)
new :
        client : ClientEndPoint *
        clientTransport : ClientTransport *
        request : RequestMsg *
        status : CallStatus *
        ?timeoutMs : int
(* Defaults:
        let _timeoutMs = defaultArg timeoutMs 0
*)
-> CallSlot
new :
        client : ClientEndPoint *
        clientTransport : ClientTransport *
        request : RequestMsg *
        status : CallStatus *
        ?timeoutMs : int
(* Defaults:
        let _timeoutMs = defaultArg timeoutMs 0
*)
-> CallSlot

Parameters

client
Type: NFX.Glue ClientEndPoint
clientTransport
Type: NFX.Glue ClientTransport
request
Type: NFX.Glue.Protocol RequestMsg
status
Type: NFX.Glue CallStatus
timeoutMs (Optional)
Type: Online System Int32
See Also
CallSlot Class
CallSlot Members
CallSlot Overload
NFX.Glue Namespace


CallSlot Constructor (ClientEndPoint, ClientTransport, Int64, DateTime, RequestMsg, ResponseMsg, Int32)

CallSlot Constructor (ClientEndPoint, ClientTransport, Int64, DateTime, RequestMsg, ResponseMsg, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

INTERNAL METHOD. Developers do not call! This constructor is used by a synchronous binding that delivers response right after sending it. ONLY for OneWayCall = false

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CallSlot(
    ClientEndPoint client,
    ClientTransport clientTransport,
    long actualStartTimeTicks,
    DateTime actualStartTimeUtc,
    RequestMsg request,
    ResponseMsg response,
    int timeoutMs
)
public CallSlot(
    ClientEndPoint client,
    ClientTransport clientTransport,
    long actualStartTimeTicks,
    DateTime actualStartTimeUtc,
    RequestMsg request,
    ResponseMsg response,
    int timeoutMs
)
Public Sub New (
    client As ClientEndPoint,
    clientTransport As ClientTransport,
    actualStartTimeTicks As Long,
    actualStartTimeUtc As DateTime,
    request As RequestMsg,
    response As ResponseMsg,
    timeoutMs As Integer
)
Public Sub New (
    client As ClientEndPoint,
    clientTransport As ClientTransport,
    actualStartTimeTicks As Long,
    actualStartTimeUtc As DateTime,
    request As RequestMsg,
    response As ResponseMsg,
    timeoutMs As Integer
)
public:
CallSlot(
    ClientEndPoint^ client,
    ClientTransport^ clientTransport,
    long long actualStartTimeTicks,
    DateTime actualStartTimeUtc,
    RequestMsg^ request,
    ResponseMsg^ response,
    int timeoutMs
)
public:
CallSlot(
    ClientEndPoint^ client,
    ClientTransport^ clientTransport,
    long long actualStartTimeTicks,
    DateTime actualStartTimeUtc,
    RequestMsg^ request,
    ResponseMsg^ response,
    int timeoutMs
)
new :
        client : ClientEndPoint *
        clientTransport : ClientTransport *
        actualStartTimeTicks : int64 *
        actualStartTimeUtc : DateTime *
        request : RequestMsg *
        response : ResponseMsg *
        timeoutMs : int -> CallSlot
new :
        client : ClientEndPoint *
        clientTransport : ClientTransport *
        actualStartTimeTicks : int64 *
        actualStartTimeUtc : DateTime *
        request : RequestMsg *
        response : ResponseMsg *
        timeoutMs : int -> CallSlot

Parameters

client
Type: NFX.Glue ClientEndPoint
clientTransport
Type: NFX.Glue ClientTransport
actualStartTimeTicks
Type: Online System Int64
actualStartTimeUtc
Type: Online System DateTime
request
Type: NFX.Glue.Protocol RequestMsg
response
Type: NFX.Glue.Protocol ResponseMsg
timeoutMs
Type: Online System Int32
See Also
CallSlot Class
CallSlot Members
CallSlot Overload
NFX.Glue Namespace


CallSlot Fields

CallSlot Fields NFX Class Library

The CallSlot type exposes the following members.
Fields
 | Name | Description
 | DEFAULT_TIMEOUT_MS |
Protected field | m_TaskCompletionSource |
Back to Top
See Also
CallSlot Class
NFX.Glue Namespace


CallSlot.DEFAULT_TIMEOUT_MS Field

CallSlot DEFAULT_TIMEOUT_MS Field NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_TIMEOUT_MS
public const int DEFAULT_TIMEOUT_MS
Public Const DEFAULT_TIMEOUT_MS As Integer
Public Const DEFAULT_TIMEOUT_MS As Integer
public:
literal int DEFAULT_TIMEOUT_MS
public:
literal int DEFAULT_TIMEOUT_MS
static val mutable DEFAULT_TIMEOUT_MS: int
static val mutable DEFAULT_TIMEOUT_MS: int

Field Value

Type: Online Int32
See Also
CallSlot Class
CallSlot Members
NFX.Glue Namespace


CallSlot.m_TaskCompletionSource Field

CallSlot m_TaskCompletionSource Field NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal TaskCompletionSource<CallSlot> m_TaskCompletionSource
internal TaskCompletionSource<CallSlot> m_TaskCompletionSource
Friend m_TaskCompletionSource As TaskCompletionSource(Of CallSlot)
Friend m_TaskCompletionSource As TaskCompletionSource(Of CallSlot)
internal:
TaskCompletionSource<CallSlot^>^ m_TaskCompletionSource
internal:
TaskCompletionSource<CallSlot^>^ m_TaskCompletionSource
val mutable internal m_TaskCompletionSource: TaskCompletionSource<CallSlot>
val mutable internal m_TaskCompletionSource: TaskCompletionSource<CallSlot>

Field Value

Type: Online TaskCompletionSource CallSlot
See Also
CallSlot Class
CallSlot Members
NFX.Glue Namespace


CallSlot Methods

CallSlot Methods NFX Class Library

The CallSlot type exposes the following members.
Methods
 | Name | Description
Public method | AsTaskReturning TCallResult | Creates a wrapper task around CallSlot.AsTask and returns CallSlot.GetValue() as TCallResult-returning Task. Note: the created wrapper task is not cached
Public method | AsTaskReturningVoid | Creates a wrapper task around CallSlot.AsTask and returns CallSlot.CheckVoidValue() Note: the created wrapper task is not cached
Public method | CheckVoidValue | Checks for a valid void value returned from the other side, that is - gets the response message and checks it for errors, throwing RemoteError exception if one came from server. Accessing this property blocks calling thread until either ResponseMsg arrives or timeout expires. Check 'Available' property not to block. Accessing this method for [OneWay] methods throws.
Protected method | DeliverResponse | Called internally by framework to populate the response message when one asynchronously arrives from transport
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetValue T | Returns a value from the other side, that is - gets the response message and checks it for errors, throwing RemoteError exception if one came from server. Accessing this property blocks calling thread until either ResponseMsg arrives or timeout expires. Check 'Available' property not to block. Accessing this method for [OneWay] methods throws.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | SignalDispatchError | Signal erroneous completion of request dispatching. This method is used by transports that post outgoing message asynchronously
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CallSlot Class
NFX.Glue Namespace


CallSlot.AsTaskReturning(TCallResult) Method

CallSlot AsTaskReturning TCallResult Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates a wrapper task around CallSlot.AsTask and returns CallSlot.GetValue() as TCallResult-returning Task. Note: the created wrapper task is not cached

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<TCallResult> AsTaskReturning<TCallResult>()
public Task<TCallResult> AsTaskReturning<TCallResult>()
Public Function AsTaskReturning(Of TCallResult) As Task(Of TCallResult)
Public Function AsTaskReturning(Of TCallResult) As Task(Of TCallResult)
public:
generic<typename TCallResult>
Task<TCallResult>^ AsTaskReturning()
public:
generic<typename TCallResult>
Task<TCallResult>^ AsTaskReturning()
member AsTaskReturning : unit -> Task<'TCallResult>
member AsTaskReturning : unit -> Task<'TCallResult>
Type Parameters
TCallResult

Return Value

Type: Online Task TCallResult
See Also
CallSlot Class
CallSlot Members
NFX.Glue Namespace


CallSlot.AsTaskReturningVoid Method

CallSlot AsTaskReturningVoid Method NFX Class Library

Creates a wrapper task around CallSlot.AsTask and returns CallSlot.CheckVoidValue() Note: the created wrapper task is not cached

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task AsTaskReturningVoid()
public Task AsTaskReturningVoid()
Public Function AsTaskReturningVoid As Task
Public Function AsTaskReturningVoid As Task
public:
Task^ AsTaskReturningVoid()
public:
Task^ AsTaskReturningVoid()
member AsTaskReturningVoid : unit -> Task
member AsTaskReturningVoid : unit -> Task

Return Value

Type: Online Task
See Also
CallSlot Class
CallSlot Members
NFX.Glue Namespace


CallSlot.CheckVoidValue Method

CallSlot CheckVoidValue Method NFX Class Library

Checks for a valid void value returned from the other side, that is - gets the response message and checks it for errors, throwing RemoteError exception if one came from server. Accessing this property blocks calling thread until either ResponseMsg arrives or timeout expires. Check 'Available' property not to block. Accessing this method for [OneWay] methods throws.

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CheckVoidValue()
public void CheckVoidValue()
Public Sub CheckVoidValue
Public Sub CheckVoidValue
public:
void CheckVoidValue()
public:
void CheckVoidValue()
member CheckVoidValue : unit -> unit
member CheckVoidValue : unit -> unit
See Also
CallSlot Class
CallSlot Members
NFX.Glue Namespace


CallSlot.DeliverResponse Method

CallSlot DeliverResponse Method NFX Class Library

Called internally by framework to populate the response message when one asynchronously arrives from transport

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void DeliverResponse(
    ResponseMsg response
)
internal void DeliverResponse(
    ResponseMsg response
)
Friend Sub DeliverResponse (
    response As ResponseMsg
)
Friend Sub DeliverResponse (
    response As ResponseMsg
)
internal:
void DeliverResponse(
    ResponseMsg^ response
)
internal:
void DeliverResponse(
    ResponseMsg^ response
)
internal member DeliverResponse :
        response : ResponseMsg -> unit
internal member DeliverResponse :
        response : ResponseMsg -> unit

Parameters

response
Type: NFX.Glue.Protocol ResponseMsg
See Also
CallSlot Class
CallSlot Members
NFX.Glue Namespace


CallSlot.Equals Method

CallSlot Equals Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
CallSlot Class
CallSlot Members
NFX.Glue Namespace


CallSlot.GetHashCode Method

CallSlot GetHashCode Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
CallSlot Class
CallSlot Members
NFX.Glue Namespace


CallSlot.GetValue(T) Method

CallSlot GetValue T Method NFX Class Library

Returns a value from the other side, that is - gets the response message and checks it for errors, throwing RemoteError exception if one came from server. Accessing this property blocks calling thread until either ResponseMsg arrives or timeout expires. Check 'Available' property not to block. Accessing this method for [OneWay] methods throws.

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T GetValue<T>()
public T GetValue<T>()
Public Function GetValue(Of T) As T
Public Function GetValue(Of T) As T
public:
generic<typename T>
T GetValue()
public:
generic<typename T>
T GetValue()
member GetValue : unit -> 'T
member GetValue : unit -> 'T
Type Parameters
T

Return Value

Type: T
See Also
CallSlot Class
CallSlot Members
NFX.Glue Namespace


CallSlot.SignalDispatchError Method

CallSlot SignalDispatchError Method NFX Class Library

Signal erroneous completion of request dispatching. This method is used by transports that post outgoing message asynchronously

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void SignalDispatchError(
    string errorMessage
)
internal void SignalDispatchError(
    string errorMessage
)
Friend Sub SignalDispatchError (
    errorMessage As String
)
Friend Sub SignalDispatchError (
    errorMessage As String
)
internal:
void SignalDispatchError(
    String^ errorMessage
)
internal:
void SignalDispatchError(
    String^ errorMessage
)
internal member SignalDispatchError :
        errorMessage : string -> unit
internal member SignalDispatchError :
        errorMessage : string -> unit

Parameters

errorMessage
Type: Online System String
See Also
CallSlot Class
CallSlot Members
NFX.Glue Namespace


CallSlot.ToString Method

CallSlot ToString Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
CallSlot Class
CallSlot Members
NFX.Glue Namespace


CallSlot Properties

CallSlot Properties NFX Class Library

The CallSlot type exposes the following members.
Properties
 | Name | Description
Public property | AsTask | Gets the CallSlot instance as a task that gets completed either instantly for one-way calls or when result arrives or timeout happens. The returned task never gets canceled
Public property | Available | Returns true when response has come and available so no blocking will occur when reading response. This is a non-blocking call. Always returns true for operations marked as [OneWay]
Public property | CallContext | General-purpose property that clients can use for attaching an arbitrary context to this instance. This property has no use in the framework
Public property | CallStatus | Returns current call status. Timeout is returned when response has not arrived from the other side in alotted time. This is a non-blocking call
Public property | Client | Returns client endpoint that initiated this call
Public property | ClientTransport | Returns client transport that this instance is originated from
Public property | DispatchErrorMessage | Optionally returns reason of the dispatch message failure
Public property | OneWay | Indicates that this call does not expect a response message from the server side
Public property | RequestID | Returns request ID for the request that was sent and generated this slot instance
Public property | ResponseMsg | Blocks until response comes or timeout happens. Response message inspection happens in the context of a calling thread
Public property | StartTime | Returns UTC timestamp of call initiation
Public property | StatRoundtripEndTimeTicks | When binding's MeasureStatTimes enabled, returns the operation end (when response arrives) tick count
Public property | StatRoundtripTimeKey | When binding's MeasureStatTimes enabled, returns the name of the stat key
Public property | StatStartTimeTicks | When binding's MeasureStatTimes enabled, returns the operation start tick count
Public property | TimeoutMs | Returns timeout for this instance
Back to Top
See Also
CallSlot Class
NFX.Glue Namespace


CallSlot.AsTask Property

CallSlot AsTask Property NFX Class Library

Gets the CallSlot instance as a task that gets completed either instantly for one-way calls or when result arrives or timeout happens. The returned task never gets canceled

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<CallSlot> AsTask { get; }
public Task<CallSlot> AsTask { get; }
Public ReadOnly Property AsTask As Task(Of CallSlot)
    Get
Public ReadOnly Property AsTask As Task(Of CallSlot)
    Get
public:
property Task<CallSlot^>^ AsTask {
    Task<CallSlot^>^ get ();
}
public:
property Task<CallSlot^>^ AsTask {
    Task<CallSlot^>^ get ();
}
member AsTask : Task<CallSlot> with get
member AsTask : Task<CallSlot> with get

Property Value

Type: Online Task CallSlot
See Also
CallSlot Class
CallSlot Members
NFX.Glue Namespace


CallSlot.Available Property

CallSlot Available Property NFX Class Library

Returns true when response has come and available so no blocking will occur when reading response. This is a non-blocking call. Always returns true for operations marked as [OneWay]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Available { get; }
public bool Available { get; }
Public ReadOnly Property Available As Boolean
    Get
Public ReadOnly Property Available As Boolean
    Get
public:
property bool Available {
    bool get ();
}
public:
property bool Available {
    bool get ();
}
member Available : bool with get
member Available : bool with get

Property Value

Type: Online Boolean
See Also
CallSlot Class
CallSlot Members
NFX.Glue Namespace


CallSlot.CallContext Property

CallSlot CallContext Property NFX Class Library

General-purpose property that clients can use for attaching an arbitrary context to this instance. This property has no use in the framework

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object CallContext { get; set; }
public Object CallContext { get; set; }
Public Property CallContext As Object
    Get
    Set
Public Property CallContext As Object
    Get
    Set
public:
property Object^ CallContext {
    Object^ get ();
    void set (Object^ value);
}
public:
property Object^ CallContext {
    Object^ get ();
    void set (Object^ value);
}
member CallContext : Object with get, set
member CallContext : Object with get, set

Property Value

Type: Online Object
See Also
CallSlot Class
CallSlot Members
NFX.Glue Namespace


CallSlot.CallStatus Property

CallSlot CallStatus Property NFX Class Library

Returns current call status. Timeout is returned when response has not arrived from the other side in alotted time. This is a non-blocking call

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CallStatus CallStatus { get; }
public CallStatus CallStatus { get; }
Public ReadOnly Property CallStatus As CallStatus
    Get
Public ReadOnly Property CallStatus As CallStatus
    Get
public:
property CallStatus CallStatus {
    CallStatus get ();
}
public:
property CallStatus CallStatus {
    CallStatus get ();
}
member CallStatus : CallStatus with get
member CallStatus : CallStatus with get

Property Value

Type: CallStatus
See Also
CallSlot Class
CallSlot Members
NFX.Glue Namespace


CallSlot.Client Property

CallSlot Client Property NFX Class Library

Returns client endpoint that initiated this call

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ClientEndPoint Client { get; }
public ClientEndPoint Client { get; }
Public ReadOnly Property Client As ClientEndPoint
    Get
Public ReadOnly Property Client As ClientEndPoint
    Get
public:
property ClientEndPoint^ Client {
    ClientEndPoint^ get ();
}
public:
property ClientEndPoint^ Client {
    ClientEndPoint^ get ();
}
member Client : ClientEndPoint with get
member Client : ClientEndPoint with get

Property Value

Type: ClientEndPoint
See Also
CallSlot Class
CallSlot Members
NFX.Glue Namespace


CallSlot.ClientTransport Property

CallSlot ClientTransport Property NFX Class Library

Returns client transport that this instance is originated from

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ClientTransport ClientTransport { get; }
public ClientTransport ClientTransport { get; }
Public ReadOnly Property ClientTransport As ClientTransport
    Get
Public ReadOnly Property ClientTransport As ClientTransport
    Get
public:
property ClientTransport^ ClientTransport {
    ClientTransport^ get ();
}
public:
property ClientTransport^ ClientTransport {
    ClientTransport^ get ();
}
member ClientTransport : ClientTransport with get
member ClientTransport : ClientTransport with get

Property Value

Type: ClientTransport
See Also
CallSlot Class
CallSlot Members
NFX.Glue Namespace


CallSlot.DispatchErrorMessage Property

CallSlot DispatchErrorMessage Property NFX Class Library

Optionally returns reason of the dispatch message failure

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DispatchErrorMessage { get; }
public string DispatchErrorMessage { get; }
Public ReadOnly Property DispatchErrorMessage As String
    Get
Public ReadOnly Property DispatchErrorMessage As String
    Get
public:
property String^ DispatchErrorMessage {
    String^ get ();
}
public:
property String^ DispatchErrorMessage {
    String^ get ();
}
member DispatchErrorMessage : string with get
member DispatchErrorMessage : string with get

Property Value

Type: Online String
See Also
CallSlot Class
CallSlot Members
NFX.Glue Namespace


CallSlot.OneWay Property

CallSlot OneWay Property NFX Class Library

Indicates that this call does not expect a response message from the server side

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool OneWay { get; }
public bool OneWay { get; }
Public ReadOnly Property OneWay As Boolean
    Get
Public ReadOnly Property OneWay As Boolean
    Get
public:
property bool OneWay {
    bool get ();
}
public:
property bool OneWay {
    bool get ();
}
member OneWay : bool with get
member OneWay : bool with get

Property Value

Type: Online Boolean
See Also
CallSlot Class
CallSlot Members
NFX.Glue Namespace


CallSlot.RequestID Property

CallSlot RequestID Property NFX Class Library

Returns request ID for the request that was sent and generated this slot instance

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FID RequestID { get; }
public FID RequestID { get; }
Public ReadOnly Property RequestID As FID
    Get
Public ReadOnly Property RequestID As FID
    Get
public:
property FID RequestID {
    FID get ();
}
public:
property FID RequestID {
    FID get ();
}
member RequestID : FID with get
member RequestID : FID with get

Property Value

Type: FID
See Also
CallSlot Class
CallSlot Members
NFX.Glue Namespace


CallSlot.ResponseMsg Property

CallSlot ResponseMsg Property NFX Class Library

Blocks until response comes or timeout happens. Response message inspection happens in the context of a calling thread

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResponseMsg ResponseMsg { get; }
public ResponseMsg ResponseMsg { get; }
Public ReadOnly Property ResponseMsg As ResponseMsg
    Get
Public ReadOnly Property ResponseMsg As ResponseMsg
    Get
public:
property ResponseMsg^ ResponseMsg {
    ResponseMsg^ get ();
}
public:
property ResponseMsg^ ResponseMsg {
    ResponseMsg^ get ();
}
member ResponseMsg : ResponseMsg with get
member ResponseMsg : ResponseMsg with get

Property Value

Type: ResponseMsg
See Also
CallSlot Class
CallSlot Members
NFX.Glue Namespace


CallSlot.StartTime Property

CallSlot StartTime Property NFX Class Library

Returns UTC timestamp of call initiation

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime StartTime { get; }
public DateTime StartTime { get; }
Public ReadOnly Property StartTime As DateTime
    Get
Public ReadOnly Property StartTime As DateTime
    Get
public:
property DateTime StartTime {
    DateTime get ();
}
public:
property DateTime StartTime {
    DateTime get ();
}
member StartTime : DateTime with get
member StartTime : DateTime with get

Property Value

Type: Online DateTime
See Also
CallSlot Class
CallSlot Members
NFX.Glue Namespace


CallSlot.StatRoundtripEndTimeTicks Property

CallSlot StatRoundtripEndTimeTicks Property NFX Class Library

[This is preliminary documentation and is subject to change.]

When binding's MeasureStatTimes enabled, returns the operation end (when response arrives) tick count

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long StatRoundtripEndTimeTicks { get; }
public long StatRoundtripEndTimeTicks { get; }
Public ReadOnly Property StatRoundtripEndTimeTicks As Long
    Get
Public ReadOnly Property StatRoundtripEndTimeTicks As Long
    Get
public:
property long long StatRoundtripEndTimeTicks {
    long long get ();
}
public:
property long long StatRoundtripEndTimeTicks {
    long long get ();
}
member StatRoundtripEndTimeTicks : int64 with get
member StatRoundtripEndTimeTicks : int64 with get

Property Value

Type: Online Int64
See Also
CallSlot Class
CallSlot Members
NFX.Glue Namespace


CallSlot.StatRoundtripTimeKey Property

CallSlot StatRoundtripTimeKey Property NFX Class Library

When binding's MeasureStatTimes enabled, returns the name of the stat key

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string StatRoundtripTimeKey { get; }
public string StatRoundtripTimeKey { get; }
Public ReadOnly Property StatRoundtripTimeKey As String
    Get
Public ReadOnly Property StatRoundtripTimeKey As String
    Get
public:
property String^ StatRoundtripTimeKey {
    String^ get ();
}
public:
property String^ StatRoundtripTimeKey {
    String^ get ();
}
member StatRoundtripTimeKey : string with get
member StatRoundtripTimeKey : string with get

Property Value

Type: Online String
See Also
CallSlot Class
CallSlot Members
NFX.Glue Namespace


CallSlot.StatStartTimeTicks Property

CallSlot StatStartTimeTicks Property NFX Class Library

When binding's MeasureStatTimes enabled, returns the operation start tick count

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long StatStartTimeTicks { get; }
public long StatStartTimeTicks { get; }
Public ReadOnly Property StatStartTimeTicks As Long
    Get
Public ReadOnly Property StatStartTimeTicks As Long
    Get
public:
property long long StatStartTimeTicks {
    long long get ();
}
public:
property long long StatStartTimeTicks {
    long long get ();
}
member StatStartTimeTicks : int64 with get
member StatStartTimeTicks : int64 with get

Property Value

Type: Online Int64
See Also
CallSlot Class
CallSlot Members
NFX.Glue Namespace


CallSlot.TimeoutMs Property

CallSlot TimeoutMs Property NFX Class Library

Returns timeout for this instance

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int TimeoutMs { get; }
public int TimeoutMs { get; }
Public ReadOnly Property TimeoutMs As Integer
    Get
Public ReadOnly Property TimeoutMs As Integer
    Get
public:
property int TimeoutMs {
    int get ();
}
public:
property int TimeoutMs {
    int get ();
}
member TimeoutMs : int with get
member TimeoutMs : int with get

Property Value

Type: Online Int32
See Also
CallSlot Class
CallSlot Members
NFX.Glue Namespace


CallStatus Enumeration

CallStatus Enumeration NFX Class Library

Stipulates codes returned for contract calls

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum CallStatus
public enum CallStatus
Public Enumeration CallStatus
Public Enumeration CallStatus
public enum class CallStatus
public enum class CallStatus
type CallStatus
type CallStatus
Members
Member name | Value | Description
Dispatched | 0 | Indicates that call was sucessfully queued/dispatched for processing by remote server
DispatchError | 1 | Indicates that operation failed locally because the communication stack is overloaded or some other internal error occured
Timeout | 2 | Indicates that operation timed out before it could be completed
ResponseOK | 3 | Indicates that response came with payload that does not contain error
ResponseError | 4 | Remote server returned response with exception
See Also
NFX.Glue Namespace


ClientCallException Class

ClientCallException Class NFX Class Library

Thrown by the Glue framework when clients try to perfom a call but that action fails
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Glue GlueException
NFX.Glue ClientCallException

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ClientCallException : GlueException
[SerializableAttribute]
public class ClientCallException : GlueException
<SerializableAttribute>
Public Class ClientCallException
    Inherits GlueException
<SerializableAttribute>
Public Class ClientCallException
    Inherits GlueException
[SerializableAttribute]
public ref class ClientCallException : public GlueException
[SerializableAttribute]
public ref class ClientCallException : public GlueException
[<SerializableAttribute>]
type ClientCallException =
    class
        inherit GlueException
    end
[<SerializableAttribute>]
type ClientCallException =
    class
        inherit GlueException
    end
See Also
ClientCallException Members
NFX.Glue Namespace


ClientCallException Members

ClientCallException Members NFX Class Library

The ClientCallException type exposes the following members.
Constructors
 | Name | Description
Public method | ClientCallException(CallStatus) | Initializes a new instance of the ClientCallException class
Protected method | ClientCallException(SerializationInfo, StreamingContext) | Initializes a new instance of the ClientCallException class
Public method | ClientCallException(CallStatus, String) | Initializes a new instance of the ClientCallException class
Public method | ClientCallException(CallStatus, String, Exception) | Initializes a new instance of the ClientCallException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | CallStatus | Returns call status enum
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ClientCallException Class
NFX.Glue Namespace


ClientCallException Constructor

ClientCallException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ClientCallException(CallStatus) | Initializes a new instance of the ClientCallException class
Protected method | ClientCallException(SerializationInfo, StreamingContext) | Initializes a new instance of the ClientCallException class
Public method | ClientCallException(CallStatus, String) | Initializes a new instance of the ClientCallException class
Public method | ClientCallException(CallStatus, String, Exception) | Initializes a new instance of the ClientCallException class
Back to Top
See Also
ClientCallException Class
ClientCallException Members
NFX.Glue Namespace


ClientCallException Constructor (CallStatus)

ClientCallException Constructor (CallStatus) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ClientCallException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ClientCallException(
    CallStatus status
)
public ClientCallException(
    CallStatus status
)
Public Sub New (
    status As CallStatus
)
Public Sub New (
    status As CallStatus
)
public:
ClientCallException(
    CallStatus status
)
public:
ClientCallException(
    CallStatus status
)
new :
        status : CallStatus -> ClientCallException
new :
        status : CallStatus -> ClientCallException

Parameters

status
Type: NFX.Glue CallStatus
See Also
ClientCallException Class
ClientCallException Members
ClientCallException Overload
NFX.Glue Namespace


ClientCallException Constructor (SerializationInfo, StreamingContext)

ClientCallException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ClientCallException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ClientCallException(
    SerializationInfo info,
    StreamingContext context
)
protected ClientCallException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
ClientCallException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
ClientCallException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ClientCallException
new :
        info : SerializationInfo *
        context : StreamingContext -> ClientCallException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
ClientCallException Class
ClientCallException Members
ClientCallException Overload
NFX.Glue Namespace


ClientCallException Constructor (CallStatus, String)

ClientCallException Constructor (CallStatus, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ClientCallException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ClientCallException(
    CallStatus status,
    string message
)
public ClientCallException(
    CallStatus status,
    string message
)
Public Sub New (
    status As CallStatus,
    message As String
)
Public Sub New (
    status As CallStatus,
    message As String
)
public:
ClientCallException(
    CallStatus status,
    String^ message
)
public:
ClientCallException(
    CallStatus status,
    String^ message
)
new :
        status : CallStatus *
        message : string -> ClientCallException
new :
        status : CallStatus *
        message : string -> ClientCallException

Parameters

status
Type: NFX.Glue CallStatus
message
Type: Online System String
See Also
ClientCallException Class
ClientCallException Members
ClientCallException Overload
NFX.Glue Namespace


ClientCallException Constructor (CallStatus, String, Exception)

ClientCallException Constructor (CallStatus, String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ClientCallException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ClientCallException(
    CallStatus status,
    string message,
    Exception inner
)
public ClientCallException(
    CallStatus status,
    string message,
    Exception inner
)
Public Sub New (
    status As CallStatus,
    message As String,
    inner As Exception
)
Public Sub New (
    status As CallStatus,
    message As String,
    inner As Exception
)
public:
ClientCallException(
    CallStatus status,
    String^ message,
    Exception^ inner
)
public:
ClientCallException(
    CallStatus status,
    String^ message,
    Exception^ inner
)
new :
        status : CallStatus *
        message : string *
        inner : Exception -> ClientCallException
new :
        status : CallStatus *
        message : string *
        inner : Exception -> ClientCallException

Parameters

status
Type: NFX.Glue CallStatus
message
Type: Online System String
inner
Type: Online System Exception
See Also
ClientCallException Class
ClientCallException Members
ClientCallException Overload
NFX.Glue Namespace


ClientCallException Methods

ClientCallException Methods NFX Class Library

The ClientCallException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
ClientCallException Class
NFX.Glue Namespace


ClientCallException Properties

ClientCallException Properties NFX Class Library

The ClientCallException type exposes the following members.
Properties
 | Name | Description
Public property | CallStatus | Returns call status enum
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
ClientCallException Class
NFX.Glue Namespace


ClientCallException.CallStatus Property

ClientCallException CallStatus Property NFX Class Library

Returns call status enum

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CallStatus CallStatus { get; }
public CallStatus CallStatus { get; }
Public ReadOnly Property CallStatus As CallStatus
    Get
Public ReadOnly Property CallStatus As CallStatus
    Get
public:
property CallStatus CallStatus {
    CallStatus get ();
}
public:
property CallStatus CallStatus {
    CallStatus get ();
}
member CallStatus : CallStatus with get
member CallStatus : CallStatus with get

Property Value

Type: CallStatus
See Also
ClientCallException Class
ClientCallException Members
NFX.Glue Namespace


ClientCallException Events

ClientCallException Events NFX Class Library

The ClientCallException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ClientCallException Class
NFX.Glue Namespace


ClientEndPoint Class

ClientEndPoint Class NFX Class Library

Represents an ancestor for client classes that make calls to server endpoints. This and descendant classes are thread safe ONLY for making non-constructing/destructing remote calls, unless ReserveTransport is set to true in which case no operation is thread safe
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Glue EndPoint
NFX.Glue ClientEndPoint
NFX.Instrumentation.Telemetry TelemetryReceiverClient

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class ClientEndPoint : EndPoint
public abstract class ClientEndPoint : EndPoint
Public MustInherit Class ClientEndPoint
    Inherits EndPoint
Public MustInherit Class ClientEndPoint
    Inherits EndPoint
public ref class ClientEndPoint abstract : public EndPoint
public ref class ClientEndPoint abstract : public EndPoint
[<AbstractClassAttribute>]
type ClientEndPoint =
    class
        inherit EndPoint
    end
[<AbstractClassAttribute>]
type ClientEndPoint =
    class
        inherit EndPoint
    end
Remarks
This class is not thread safe in general, however Glue allows for concurrent remote calls via the same endpoint instance if the following conditions are met: 1). The endpoint instance has not reserved its transport (ReserveTransport=false) 2). Either remote contract is stateless OR none of the concurrent calls are constructing/destructing remote instance The second condition ensures that stateful remote instance is consistent, otherwise operations may get executed out-of-order in the multithreaded scenario
See Also
ClientEndPoint Members
NFX.Glue Namespace


ClientEndPoint Members

ClientEndPoint Members NFX Class Library

The ClientEndPoint type exposes the following members.
Constructors
 | Name | Description
Public method | ClientEndPoint(String, Binding) | Initializes a new instance of the ClientEndPoint class
Public method | ClientEndPoint(Node, Binding) | Initializes a new instance of the ClientEndPoint class
Public method | ClientEndPoint(IGlue, Node, Binding) | Initializes a new instance of the ClientEndPoint class
Public method | ClientEndPoint(IGlue, String, Binding) | Initializes a new instance of the ClientEndPoint class
Back to Top
Methods
 | Name | Description
Protected method | __setRemoteInstance |
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Protected method | DispatchCall | Dispatches a call into binding passing message through client inspectors on this endpoint
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | ForgetRemoteInstance | Sets RemoteInstance to null. This method is needed when the same instance of client endpoint is used to make subsequent statefull calls to different server instances. Call this method before calling [Constructor]-decorated remote method or making the first call to InstanceLifetime.AutoconstructedStateful servers.
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Binding | (Inherited from EndPoint.)
Protected field | m_Glue | (Inherited from EndPoint.)
Protected field | m_Node | (Inherited from EndPoint.)
Protected field | m_ReservedTransport |
Back to Top
Properties
 | Name | Description
Public property | Binding | Returns a binding of this endpoint. "B" component of the "ABC" rule (Inherited from EndPoint.)
Public property | Contract | Returns a contract type of this endpoint. "C" component of the "ABC" rule
Public property | DispatchTimeoutMs | Specifies timeout for call invocation
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Glue | References glue that this endpoint works under (Inherited from EndPoint.)
Public property | Headers | Returns headers that get attached in every call
Public property | MsgInspectors | Returns client message inspectors for this instance
Public property | Node | Returns a node of this endpoint. "A" component of the "ABC" rule (Inherited from EndPoint.)
Public property | RemoteInstance | Returns a reference to remote instance or null if service is stateless(no instance created)
Public property | ReserveTransport | Indicates whether transport instance should not be released after a call and be reserved per this endpoint instance. Be carefull when setting this property to true as this action can really impede the system performance as transport is reserved until this property is either reset to false or endpoint instance is disposed. Transport reservation reduces call latency and is mostly beneficial in synchronous bindings. Warning: client endpoint with reserved transport is NOT THREAD SAFE for making parallel calls! Set this property to true only when latency is very critical and only 1 dedicated thread is working with this client endpoint instance
Public property | TimeoutMs | Specifies timeout for the whole call
Back to Top
See Also
ClientEndPoint Class
NFX.Glue Namespace


ClientEndPoint Constructor

ClientEndPoint Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ClientEndPoint(String, Binding) | Initializes a new instance of the ClientEndPoint class
Public method | ClientEndPoint(Node, Binding) | Initializes a new instance of the ClientEndPoint class
Public method | ClientEndPoint(IGlue, Node, Binding) | Initializes a new instance of the ClientEndPoint class
Public method | ClientEndPoint(IGlue, String, Binding) | Initializes a new instance of the ClientEndPoint class
Back to Top
See Also
ClientEndPoint Class
ClientEndPoint Members
NFX.Glue Namespace


ClientEndPoint Constructor (String, Binding)

ClientEndPoint Constructor (String, Binding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ClientEndPoint class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ClientEndPoint(
    string node,
    Binding binding = null
)
public ClientEndPoint(
    string node,
    Binding binding = null
)
Public Sub New (
    node As String,
    Optional binding As Binding = Nothing
)
Public Sub New (
    node As String,
    Optional binding As Binding = Nothing
)
public:
ClientEndPoint(
    String^ node,
    Binding^ binding = nullptr
)
public:
ClientEndPoint(
    String^ node,
    Binding^ binding = nullptr
)
new :
        node : string *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> ClientEndPoint
new :
        node : string *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> ClientEndPoint

Parameters

node
Type: Online System String
binding (Optional)
Type: NFX.Glue Binding
See Also
ClientEndPoint Class
ClientEndPoint Members
ClientEndPoint Overload
NFX.Glue Namespace


ClientEndPoint Constructor (Node, Binding)

ClientEndPoint Constructor (Node, Binding) NFX Class Library

Initializes a new instance of the ClientEndPoint class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ClientEndPoint(
    Node node,
    Binding binding = null
)
public ClientEndPoint(
    Node node,
    Binding binding = null
)
Public Sub New (
    node As Node,
    Optional binding As Binding = Nothing
)
Public Sub New (
    node As Node,
    Optional binding As Binding = Nothing
)
public:
ClientEndPoint(
    Node node,
    Binding^ binding = nullptr
)
public:
ClientEndPoint(
    Node node,
    Binding^ binding = nullptr
)
new :
        node : Node *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> ClientEndPoint
new :
        node : Node *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> ClientEndPoint

Parameters

node
Type: NFX.Glue Node
binding (Optional)
Type: NFX.Glue Binding
See Also
ClientEndPoint Class
ClientEndPoint Members
ClientEndPoint Overload
NFX.Glue Namespace


ClientEndPoint Constructor (IGlue, Node, Binding)

ClientEndPoint Constructor (IGlue, Node, Binding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ClientEndPoint class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ClientEndPoint(
    IGlue glue,
    Node node,
    Binding binding = null
)
public ClientEndPoint(
    IGlue glue,
    Node node,
    Binding binding = null
)
Public Sub New (
    glue As IGlue,
    node As Node,
    Optional binding As Binding = Nothing
)
Public Sub New (
    glue As IGlue,
    node As Node,
    Optional binding As Binding = Nothing
)
public:
ClientEndPoint(
    IGlue^ glue,
    Node node,
    Binding^ binding = nullptr
)
public:
ClientEndPoint(
    IGlue^ glue,
    Node node,
    Binding^ binding = nullptr
)
new :
        glue : IGlue *
        node : Node *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> ClientEndPoint
new :
        glue : IGlue *
        node : Node *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> ClientEndPoint

Parameters

glue
Type: NFX.Glue IGlue
node
Type: NFX.Glue Node
binding (Optional)
Type: NFX.Glue Binding
See Also
ClientEndPoint Class
ClientEndPoint Members
ClientEndPoint Overload
NFX.Glue Namespace


ClientEndPoint Constructor (IGlue, String, Binding)

ClientEndPoint Constructor (IGlue, String, Binding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ClientEndPoint class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ClientEndPoint(
    IGlue glue,
    string node,
    Binding binding = null
)
public ClientEndPoint(
    IGlue glue,
    string node,
    Binding binding = null
)
Public Sub New (
    glue As IGlue,
    node As String,
    Optional binding As Binding = Nothing
)
Public Sub New (
    glue As IGlue,
    node As String,
    Optional binding As Binding = Nothing
)
public:
ClientEndPoint(
    IGlue^ glue,
    String^ node,
    Binding^ binding = nullptr
)
public:
ClientEndPoint(
    IGlue^ glue,
    String^ node,
    Binding^ binding = nullptr
)
new :
        glue : IGlue *
        node : string *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> ClientEndPoint
new :
        glue : IGlue *
        node : string *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> ClientEndPoint

Parameters

glue
Type: NFX.Glue IGlue
node
Type: Online System String
binding (Optional)
Type: NFX.Glue Binding
See Also
ClientEndPoint Class
ClientEndPoint Members
ClientEndPoint Overload
NFX.Glue Namespace


ClientEndPoint Fields

ClientEndPoint Fields NFX Class Library

The ClientEndPoint type exposes the following members.
Fields
 | Name | Description
Protected field | m_Binding | (Inherited from EndPoint.)
Protected field | m_Glue | (Inherited from EndPoint.)
Protected field | m_Node | (Inherited from EndPoint.)
Protected field | m_ReservedTransport |
Back to Top
See Also
ClientEndPoint Class
NFX.Glue Namespace


ClientEndPoint.m_ReservedTransport Field

ClientEndPoint m_ReservedTransport Field NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ClientTransport m_ReservedTransport
internal ClientTransport m_ReservedTransport
Friend m_ReservedTransport As ClientTransport
Friend m_ReservedTransport As ClientTransport
internal:
ClientTransport^ m_ReservedTransport
internal:
ClientTransport^ m_ReservedTransport
val mutable internal m_ReservedTransport: ClientTransport
val mutable internal m_ReservedTransport: ClientTransport

Field Value

Type: ClientTransport
See Also
ClientEndPoint Class
ClientEndPoint Members
NFX.Glue Namespace


ClientEndPoint Methods

ClientEndPoint Methods NFX Class Library

The ClientEndPoint type exposes the following members.
Methods
 | Name | Description
Protected method | __setRemoteInstance |
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Protected method | DispatchCall | Dispatches a call into binding passing message through client inspectors on this endpoint
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | ForgetRemoteInstance | Sets RemoteInstance to null. This method is needed when the same instance of client endpoint is used to make subsequent statefull calls to different server instances. Call this method before calling [Constructor]-decorated remote method or making the first call to InstanceLifetime.AutoconstructedStateful servers.
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ClientEndPoint Class
NFX.Glue Namespace


ClientEndPoint.__setRemoteInstance Method

ClientEndPoint __setRemoteInstance Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal void __setRemoteInstance(
    Guid id
)
protected internal void __setRemoteInstance(
    Guid id
)
Protected Friend Sub __setRemoteInstance (
    id As Guid
)
Protected Friend Sub __setRemoteInstance (
    id As Guid
)
protected public:
void __setRemoteInstance(
    Guid id
)
protected public:
void __setRemoteInstance(
    Guid id
)
member __setRemoteInstance :
        id : Guid -> unit
member __setRemoteInstance :
        id : Guid -> unit

Parameters

id
Type: Online System Guid
See Also
ClientEndPoint Class
ClientEndPoint Members
NFX.Glue Namespace


ClientEndPoint.Destructor Method

ClientEndPoint Destructor Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
ClientEndPoint Class
ClientEndPoint Members
NFX.Glue Namespace


ClientEndPoint.DispatchCall Method

ClientEndPoint DispatchCall Method NFX Class Library

Dispatches a call into binding passing message through client inspectors on this endpoint

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CallSlot DispatchCall(
    RequestMsg request
)
protected CallSlot DispatchCall(
    RequestMsg request
)
Protected Function DispatchCall (
    request As RequestMsg
) As CallSlot
Protected Function DispatchCall (
    request As RequestMsg
) As CallSlot
protected:
CallSlot^ DispatchCall(
    RequestMsg^ request
)
protected:
CallSlot^ DispatchCall(
    RequestMsg^ request
)
member DispatchCall :
        request : RequestMsg -> CallSlot
member DispatchCall :
        request : RequestMsg -> CallSlot

Parameters

request
Type: NFX.Glue.Protocol RequestMsg

Return Value

Type: CallSlot
See Also
ClientEndPoint Class
ClientEndPoint Members
NFX.Glue Namespace


ClientEndPoint.ForgetRemoteInstance Method

ClientEndPoint ForgetRemoteInstance Method NFX Class Library

Sets RemoteInstance to null. This method is needed when the same instance of client endpoint is used to make subsequent statefull calls to different server instances. Call this method before calling [Constructor]-decorated remote method or making the first call to InstanceLifetime.AutoconstructedStateful servers.

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ForgetRemoteInstance()
public void ForgetRemoteInstance()
Public Sub ForgetRemoteInstance
Public Sub ForgetRemoteInstance
public:
void ForgetRemoteInstance()
public:
void ForgetRemoteInstance()
member ForgetRemoteInstance : unit -> unit
member ForgetRemoteInstance : unit -> unit
Remarks
The remote instance ID is retained locally even after a call to [Destructor]-decorated remote method. This is needed because a call to destructor may be asynchronous and it may be necessary to know the ID of the instance (that has already died on remote host) after call returns. Call ForgetRemoteInstance() to deterministically nullify the local cached ID.
See Also
ClientEndPoint Class
ClientEndPoint Members
NFX.Glue Namespace


ClientEndPoint.ToString Method

ClientEndPoint ToString Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
ClientEndPoint Class
ClientEndPoint Members
NFX.Glue Namespace


ClientEndPoint Properties

ClientEndPoint Properties NFX Class Library

The ClientEndPoint type exposes the following members.
Properties
 | Name | Description
Public property | Binding | Returns a binding of this endpoint. "B" component of the "ABC" rule (Inherited from EndPoint.)
Public property | Contract | Returns a contract type of this endpoint. "C" component of the "ABC" rule
Public property | DispatchTimeoutMs | Specifies timeout for call invocation
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Glue | References glue that this endpoint works under (Inherited from EndPoint.)
Public property | Headers | Returns headers that get attached in every call
Public property | MsgInspectors | Returns client message inspectors for this instance
Public property | Node | Returns a node of this endpoint. "A" component of the "ABC" rule (Inherited from EndPoint.)
Public property | RemoteInstance | Returns a reference to remote instance or null if service is stateless(no instance created)
Public property | ReserveTransport | Indicates whether transport instance should not be released after a call and be reserved per this endpoint instance. Be carefull when setting this property to true as this action can really impede the system performance as transport is reserved until this property is either reset to false or endpoint instance is disposed. Transport reservation reduces call latency and is mostly beneficial in synchronous bindings. Warning: client endpoint with reserved transport is NOT THREAD SAFE for making parallel calls! Set this property to true only when latency is very critical and only 1 dedicated thread is working with this client endpoint instance
Public property | TimeoutMs | Specifies timeout for the whole call
Back to Top
See Also
ClientEndPoint Class
NFX.Glue Namespace


ClientEndPoint.Contract Property

ClientEndPoint Contract Property NFX Class Library

Returns a contract type of this endpoint. "C" component of the "ABC" rule

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Type Contract { get; }
public abstract Type Contract { get; }
Public MustOverride ReadOnly Property Contract As Type
    Get
Public MustOverride ReadOnly Property Contract As Type
    Get
public:
virtual property Type^ Contract {
    Type^ get () abstract;
}
public:
virtual property Type^ Contract {
    Type^ get () abstract;
}
abstract Contract : Type with get
abstract Contract : Type with get

Property Value

Type: Online Type
See Also
ClientEndPoint Class
ClientEndPoint Members
NFX.Glue Namespace


ClientEndPoint.DispatchTimeoutMs Property

ClientEndPoint DispatchTimeoutMs Property NFX Class Library

Specifies timeout for call invocation

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int DispatchTimeoutMs { get; set; }
public int DispatchTimeoutMs { get; set; }
Public Property DispatchTimeoutMs As Integer
    Get
    Set
Public Property DispatchTimeoutMs As Integer
    Get
    Set
public:
property int DispatchTimeoutMs {
    int get ();
    void set (int value);
}
public:
property int DispatchTimeoutMs {
    int get ();
    void set (int value);
}
member DispatchTimeoutMs : int with get, set
member DispatchTimeoutMs : int with get, set

Property Value

Type: Online Int32
See Also
ClientEndPoint Class
ClientEndPoint Members
NFX.Glue Namespace


ClientEndPoint.Headers Property

ClientEndPoint Headers Property NFX Class Library

Returns headers that get attached in every call

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Headers Headers { get; }
public Headers Headers { get; }
Public ReadOnly Property Headers As Headers
    Get
Public ReadOnly Property Headers As Headers
    Get
public:
property Headers^ Headers {
    Headers^ get ();
}
public:
property Headers^ Headers {
    Headers^ get ();
}
member Headers : Headers with get
member Headers : Headers with get

Property Value

Type: Headers
See Also
ClientEndPoint Class
ClientEndPoint Members
NFX.Glue Namespace


ClientEndPoint.MsgInspectors Property

ClientEndPoint MsgInspectors Property NFX Class Library

Returns client message inspectors for this instance

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderedRegistry<IClientMsgInspector> MsgInspectors { get; }
public OrderedRegistry<IClientMsgInspector> MsgInspectors { get; }
Public ReadOnly Property MsgInspectors As OrderedRegistry(Of IClientMsgInspector)
    Get
Public ReadOnly Property MsgInspectors As OrderedRegistry(Of IClientMsgInspector)
    Get
public:
property OrderedRegistry<IClientMsgInspector^>^ MsgInspectors {
    OrderedRegistry<IClientMsgInspector^>^ get ();
}
public:
property OrderedRegistry<IClientMsgInspector^>^ MsgInspectors {
    OrderedRegistry<IClientMsgInspector^>^ get ();
}
member MsgInspectors : OrderedRegistry<IClientMsgInspector> with get
member MsgInspectors : OrderedRegistry<IClientMsgInspector> with get

Property Value

Type: OrderedRegistry IClientMsgInspector
See Also
ClientEndPoint Class
ClientEndPoint Members
NFX.Glue Namespace


ClientEndPoint.RemoteInstance Property

ClientEndPoint RemoteInstance Property NFX Class Library

Returns a reference to remote instance or null if service is stateless(no instance created)

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<Guid> RemoteInstance { get; }
public Nullable<Guid> RemoteInstance { get; }
Public ReadOnly Property RemoteInstance As Nullable(Of Guid)
    Get
Public ReadOnly Property RemoteInstance As Nullable(Of Guid)
    Get
public:
property Nullable<Guid> RemoteInstance {
    Nullable<Guid> get ();
}
public:
property Nullable<Guid> RemoteInstance {
    Nullable<Guid> get ();
}
member RemoteInstance : Nullable<Guid> with get
member RemoteInstance : Nullable<Guid> with get

Property Value

Type: Online Nullable Online Guid
See Also
ClientEndPoint Class
ClientEndPoint Members
NFX.Glue Namespace


ClientEndPoint.ReserveTransport Property

ClientEndPoint ReserveTransport Property NFX Class Library

Indicates whether transport instance should not be released after a call and be reserved per this endpoint instance. Be carefull when setting this property to true as this action can really impede the system performance as transport is reserved until this property is either reset to false or endpoint instance is disposed. Transport reservation reduces call latency and is mostly beneficial in synchronous bindings. Warning: client endpoint with reserved transport is NOT THREAD SAFE for making parallel calls! Set this property to true only when latency is very critical and only 1 dedicated thread is working with this client endpoint instance

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ReserveTransport { get; set; }
public bool ReserveTransport { get; set; }
Public Property ReserveTransport As Boolean
    Get
    Set
Public Property ReserveTransport As Boolean
    Get
    Set
public:
property bool ReserveTransport {
    bool get ();
    void set (bool value);
}
public:
property bool ReserveTransport {
    bool get ();
    void set (bool value);
}
member ReserveTransport : bool with get, set
member ReserveTransport : bool with get, set

Property Value

Type: Online Boolean
See Also
ClientEndPoint Class
ClientEndPoint Members
NFX.Glue Namespace


ClientEndPoint.TimeoutMs Property

ClientEndPoint TimeoutMs Property NFX Class Library

Specifies timeout for the whole call

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int TimeoutMs { get; set; }
public int TimeoutMs { get; set; }
Public Property TimeoutMs As Integer
    Get
    Set
Public Property TimeoutMs As Integer
    Get
    Set
public:
property int TimeoutMs {
    int get ();
    void set (int value);
}
public:
property int TimeoutMs {
    int get ();
    void set (int value);
}
member TimeoutMs : int with get, set
member TimeoutMs : int with get, set

Property Value

Type: Online Int32
See Also
ClientEndPoint Class
ClientEndPoint Members
NFX.Glue Namespace


ClientMsgInspectionException Class

ClientMsgInspectionException Class NFX Class Library

Thrown by the Glue framework when client message inspector fails with exception
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Glue GlueException
NFX.Glue ClientMsgInspectionException

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ClientMsgInspectionException : GlueException
[SerializableAttribute]
public class ClientMsgInspectionException : GlueException
<SerializableAttribute>
Public Class ClientMsgInspectionException
    Inherits GlueException
<SerializableAttribute>
Public Class ClientMsgInspectionException
    Inherits GlueException
[SerializableAttribute]
public ref class ClientMsgInspectionException : public GlueException
[SerializableAttribute]
public ref class ClientMsgInspectionException : public GlueException
[<SerializableAttribute>]
type ClientMsgInspectionException =
    class
        inherit GlueException
    end
[<SerializableAttribute>]
type ClientMsgInspectionException =
    class
        inherit GlueException
    end
See Also
ClientMsgInspectionException Members
NFX.Glue Namespace


ClientMsgInspectionException Members

ClientMsgInspectionException Members NFX Class Library

The ClientMsgInspectionException type exposes the following members.
Constructors
 | Name | Description
Protected method | ClientMsgInspectionException(SerializationInfo, StreamingContext) | Initializes a new instance of the ClientMsgInspectionException class
Public method | ClientMsgInspectionException(IClientMsgInspector, Exception) | Initializes a new instance of the ClientMsgInspectionException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Inspector | Returns inspector that threw exception
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ClientMsgInspectionException Class
NFX.Glue Namespace


ClientMsgInspectionException Constructor

ClientMsgInspectionException Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | ClientMsgInspectionException(SerializationInfo, StreamingContext) | Initializes a new instance of the ClientMsgInspectionException class
Public method | ClientMsgInspectionException(IClientMsgInspector, Exception) | Initializes a new instance of the ClientMsgInspectionException class
Back to Top
See Also
ClientMsgInspectionException Class
ClientMsgInspectionException Members
NFX.Glue Namespace


ClientMsgInspectionException Constructor (SerializationInfo, StreamingContext)

ClientMsgInspectionException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ClientMsgInspectionException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ClientMsgInspectionException(
    SerializationInfo info,
    StreamingContext context
)
protected ClientMsgInspectionException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
ClientMsgInspectionException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
ClientMsgInspectionException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ClientMsgInspectionException
new :
        info : SerializationInfo *
        context : StreamingContext -> ClientMsgInspectionException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
ClientMsgInspectionException Class
ClientMsgInspectionException Members
ClientMsgInspectionException Overload
NFX.Glue Namespace


ClientMsgInspectionException Constructor (IClientMsgInspector, Exception)

ClientMsgInspectionException Constructor (IClientMsgInspector, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ClientMsgInspectionException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ClientMsgInspectionException(
    IClientMsgInspector inspector,
    Exception error
)
public ClientMsgInspectionException(
    IClientMsgInspector inspector,
    Exception error
)
Public Sub New (
    inspector As IClientMsgInspector,
    error As Exception
)
Public Sub New (
    inspector As IClientMsgInspector,
    error As Exception
)
public:
ClientMsgInspectionException(
    IClientMsgInspector^ inspector,
    Exception^ error
)
public:
ClientMsgInspectionException(
    IClientMsgInspector^ inspector,
    Exception^ error
)
new :
        inspector : IClientMsgInspector *
        error : Exception -> ClientMsgInspectionException
new :
        inspector : IClientMsgInspector *
        error : Exception -> ClientMsgInspectionException

Parameters

inspector
Type: NFX.Glue IClientMsgInspector
error
Type: Online System Exception
See Also
ClientMsgInspectionException Class
ClientMsgInspectionException Members
ClientMsgInspectionException Overload
NFX.Glue Namespace


ClientMsgInspectionException Methods

ClientMsgInspectionException Methods NFX Class Library

The ClientMsgInspectionException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
ClientMsgInspectionException Class
NFX.Glue Namespace


ClientMsgInspectionException Properties

ClientMsgInspectionException Properties NFX Class Library

The ClientMsgInspectionException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Inspector | Returns inspector that threw exception
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
ClientMsgInspectionException Class
NFX.Glue Namespace


ClientMsgInspectionException.Inspector Property

ClientMsgInspectionException Inspector Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns inspector that threw exception

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IClientMsgInspector Inspector { get; }
public IClientMsgInspector Inspector { get; }
Public ReadOnly Property Inspector As IClientMsgInspector
    Get
Public ReadOnly Property Inspector As IClientMsgInspector
    Get
public:
property IClientMsgInspector^ Inspector {
    IClientMsgInspector^ get ();
}
public:
property IClientMsgInspector^ Inspector {
    IClientMsgInspector^ get ();
}
member Inspector : IClientMsgInspector with get
member Inspector : IClientMsgInspector with get

Property Value

Type: IClientMsgInspector
See Also
ClientMsgInspectionException Class
ClientMsgInspectionException Members
NFX.Glue Namespace


ClientMsgInspectionException Events

ClientMsgInspectionException Events NFX Class Library

The ClientMsgInspectionException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ClientMsgInspectionException Class
NFX.Glue Namespace


ClientTransport Class

ClientTransport Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service Binding
NFX.Glue Transport
NFX.Glue ClientTransport
NFX.Glue ClientTransport TBinding

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class ClientTransport : Transport
public abstract class ClientTransport : Transport
Public MustInherit Class ClientTransport
    Inherits Transport
Public MustInherit Class ClientTransport
    Inherits Transport
public ref class ClientTransport abstract : public Transport
public ref class ClientTransport abstract : public Transport
[<AbstractClassAttribute>]
type ClientTransport =
    class
        inherit Transport
    end
[<AbstractClassAttribute>]
type ClientTransport =
    class
        inherit Transport
    end
See Also
ClientTransport Members
NFX.Glue Namespace


ClientTransport Members

ClientTransport Members NFX Class Library

The ClientTransport type exposes the following members.
Constructors
 | Name | Description
Protected method | ClientTransport | Initializes a new instance of the ClientTransport class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and transport instance are running or throws otherwise (Inherited from Transport.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Transport.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoDumpInstrumentationData | Override to dump instrumentation data, dont forget to call base to dump basic metrics (Inherited from Transport.)
Protected method | DoSendRequest | Override to send a client request into remote endpoint. This is a blocking call for bindings that are OperationFlow.Synchronous and result arrives immediately into CallSlot.
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Inherited from Transport.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | DumpInstrumentationData | Dumps instrumentation data (Inherited from Transport.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Release | Releases transport by setting Acquired flag to false so it can be used by other operations (Inherited from Transport.)
Public method | ResetStats | Resets all statistical counters (Inherited from Transport.)
Public method | SendRequest | Sends a client request into remote endpoint. This is a blocking call for bindings that are OperationFlow.Synchronous and result arrives immediately into CallSlot.
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Protected method | stat_BytesReceived | (Inherited from Transport.)
Protected method | stat_BytesSent | (Inherited from Transport.)
Protected method | stat_Errors | (Inherited from Transport.)
Protected method | stat_MsgReceived | (Inherited from Transport.)
Protected method | stat_MsgSent | (Inherited from Transport.)
Protected method | stat_Time | Processes named time measurement statistical sample by using EMA filter (Inherited from Transport.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryAcquire | A thread-safe operation that tries to acquire(reserve) this instance for exclusive use. Returns true if acqusition succeded, false is this instance is reserved by someone else (Inherited from Transport.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_TransportKind | (Inherited from Transport.)
Back to Top
Properties
 | Name | Description
Public property | Acquired | Returns true when this transport instance has been acquired by some operation and is busy (Inherited from Transport.)
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | Binding | Returns a binding that this transport operates under (Inherited from Transport.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExpirationStart | Returns timestamp when manager touched the instance for last time and no traffic went through it since (Inherited from Transport.)
Public property | Glue | Returns glue implementation that this transport is under (Inherited from Transport.)
Public property | IdleAgeMs | Returns the duration of transport idle period in ms. (Inherited from Transport.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Node | Returns node that this transport services (Inherited from Transport.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | StatBytesReceived | Returns how many bytes were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatBytesSent | Returns how many bytes were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatErrors | Returns how many message processing errors happened since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgReceived | Returns how many messages were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgSent | Returns how many messages were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatTimes | Returns enumerable of named times measured in double second fractions. The returned times are EMA-filtered from supplied individual measurement samples (Inherited from Transport.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransportKind | Reports if this is a server or client transport (Inherited from Transport.)
Back to Top
See Also
ClientTransport Class
NFX.Glue Namespace


ClientTransport Constructor

ClientTransport Constructor NFX Class Library

Initializes a new instance of the ClientTransport class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ClientTransport(
    Binding binding
)
protected ClientTransport(
    Binding binding
)
Protected Sub New (
    binding As Binding
)
Protected Sub New (
    binding As Binding
)
protected:
ClientTransport(
    Binding^ binding
)
protected:
ClientTransport(
    Binding^ binding
)
new :
        binding : Binding -> ClientTransport
new :
        binding : Binding -> ClientTransport

Parameters

binding
Type: NFX.Glue Binding
See Also
ClientTransport Class
ClientTransport Members
NFX.Glue Namespace


ClientTransport Fields

ClientTransport Fields NFX Class Library

The ClientTransport type exposes the following members.
Fields
 | Name | Description
Protected field | m_TransportKind | (Inherited from Transport.)
Back to Top
See Also
ClientTransport Class
NFX.Glue Namespace


ClientTransport Methods

ClientTransport Methods NFX Class Library

The ClientTransport type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and transport instance are running or throws otherwise (Inherited from Transport.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Transport.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoDumpInstrumentationData | Override to dump instrumentation data, dont forget to call base to dump basic metrics (Inherited from Transport.)
Protected method | DoSendRequest | Override to send a client request into remote endpoint. This is a blocking call for bindings that are OperationFlow.Synchronous and result arrives immediately into CallSlot.
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Inherited from Transport.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | DumpInstrumentationData | Dumps instrumentation data (Inherited from Transport.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Release | Releases transport by setting Acquired flag to false so it can be used by other operations (Inherited from Transport.)
Public method | ResetStats | Resets all statistical counters (Inherited from Transport.)
Public method | SendRequest | Sends a client request into remote endpoint. This is a blocking call for bindings that are OperationFlow.Synchronous and result arrives immediately into CallSlot.
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Protected method | stat_BytesReceived | (Inherited from Transport.)
Protected method | stat_BytesSent | (Inherited from Transport.)
Protected method | stat_Errors | (Inherited from Transport.)
Protected method | stat_MsgReceived | (Inherited from Transport.)
Protected method | stat_MsgSent | (Inherited from Transport.)
Protected method | stat_Time | Processes named time measurement statistical sample by using EMA filter (Inherited from Transport.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryAcquire | A thread-safe operation that tries to acquire(reserve) this instance for exclusive use. Returns true if acqusition succeded, false is this instance is reserved by someone else (Inherited from Transport.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ClientTransport Class
NFX.Glue Namespace


ClientTransport.DoSendRequest Method

ClientTransport DoSendRequest Method NFX Class Library

Override to send a client request into remote endpoint. This is a blocking call for bindings that are OperationFlow.Synchronous and result arrives immediately into CallSlot.

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract CallSlot DoSendRequest(
    ClientEndPoint endpoint,
    RequestMsg request,
    CallOptions options
)
protected abstract CallSlot DoSendRequest(
    ClientEndPoint endpoint,
    RequestMsg request,
    CallOptions options
)
Protected MustOverride Function DoSendRequest (
    endpoint As ClientEndPoint,
    request As RequestMsg,
    options As CallOptions
) As CallSlot
Protected MustOverride Function DoSendRequest (
    endpoint As ClientEndPoint,
    request As RequestMsg,
    options As CallOptions
) As CallSlot
protected:
virtual CallSlot^ DoSendRequest(
    ClientEndPoint^ endpoint,
    RequestMsg^ request,
    CallOptions options
) abstract
protected:
virtual CallSlot^ DoSendRequest(
    ClientEndPoint^ endpoint,
    RequestMsg^ request,
    CallOptions options
) abstract
abstract DoSendRequest :
        endpoint : ClientEndPoint *
        request : RequestMsg *
        options : CallOptions -> CallSlot
abstract DoSendRequest :
        endpoint : ClientEndPoint *
        request : RequestMsg *
        options : CallOptions -> CallSlot

Parameters

endpoint
Type: NFX.Glue ClientEndPoint
request
Type: NFX.Glue.Protocol RequestMsg
options
Type: NFX.Glue.Protocol CallOptions

Return Value

Type: CallSlot
See Also
ClientTransport Class
ClientTransport Members
NFX.Glue Namespace


ClientTransport.SendRequest Method

ClientTransport SendRequest Method NFX Class Library

Sends a client request into remote endpoint. This is a blocking call for bindings that are OperationFlow.Synchronous and result arrives immediately into CallSlot.

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CallSlot SendRequest(
    ClientEndPoint endpoint,
    RequestMsg request,
    CallOptions options
)
public CallSlot SendRequest(
    ClientEndPoint endpoint,
    RequestMsg request,
    CallOptions options
)
Public Function SendRequest (
    endpoint As ClientEndPoint,
    request As RequestMsg,
    options As CallOptions
) As CallSlot
Public Function SendRequest (
    endpoint As ClientEndPoint,
    request As RequestMsg,
    options As CallOptions
) As CallSlot
public:
CallSlot^ SendRequest(
    ClientEndPoint^ endpoint,
    RequestMsg^ request,
    CallOptions options
)
public:
CallSlot^ SendRequest(
    ClientEndPoint^ endpoint,
    RequestMsg^ request,
    CallOptions options
)
member SendRequest :
        endpoint : ClientEndPoint *
        request : RequestMsg *
        options : CallOptions -> CallSlot
member SendRequest :
        endpoint : ClientEndPoint *
        request : RequestMsg *
        options : CallOptions -> CallSlot

Parameters

endpoint
Type: NFX.Glue ClientEndPoint
request
Type: NFX.Glue.Protocol RequestMsg
options
Type: NFX.Glue.Protocol CallOptions

Return Value

Type: CallSlot
See Also
ClientTransport Class
ClientTransport Members
NFX.Glue Namespace


ClientTransport Properties

ClientTransport Properties NFX Class Library

The ClientTransport type exposes the following members.
Properties
 | Name | Description
Public property | Acquired | Returns true when this transport instance has been acquired by some operation and is busy (Inherited from Transport.)
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | Binding | Returns a binding that this transport operates under (Inherited from Transport.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExpirationStart | Returns timestamp when manager touched the instance for last time and no traffic went through it since (Inherited from Transport.)
Public property | Glue | Returns glue implementation that this transport is under (Inherited from Transport.)
Public property | IdleAgeMs | Returns the duration of transport idle period in ms. (Inherited from Transport.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Node | Returns node that this transport services (Inherited from Transport.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | StatBytesReceived | Returns how many bytes were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatBytesSent | Returns how many bytes were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatErrors | Returns how many message processing errors happened since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgReceived | Returns how many messages were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgSent | Returns how many messages were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatTimes | Returns enumerable of named times measured in double second fractions. The returned times are EMA-filtered from supplied individual measurement samples (Inherited from Transport.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransportKind | Reports if this is a server or client transport (Inherited from Transport.)
Back to Top
See Also
ClientTransport Class
NFX.Glue Namespace


ClientTransport(TBinding) Class

ClientTransport TBinding Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service Binding
NFX.Glue Transport
NFX.Glue ClientTransport
NFX.Glue ClientTransport TBinding
NFX.Glue.Native InProcClientTransport
NFX.Glue.Native MpxClientTransport
NFX.Glue.Native SyncClientTransport

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class ClientTransport<TBinding> : ClientTransport
where TBinding : Binding
public abstract class ClientTransport<TBinding> : ClientTransport
where TBinding : Binding
Public MustInherit Class ClientTransport(Of TBinding As Binding)
    Inherits ClientTransport
Public MustInherit Class ClientTransport(Of TBinding As Binding)
    Inherits ClientTransport
generic<typename TBinding>
where TBinding : Binding
public ref class ClientTransport abstract : public ClientTransport
generic<typename TBinding>
where TBinding : Binding
public ref class ClientTransport abstract : public ClientTransport
[<AbstractClassAttribute>]
type ClientTransport<'TBinding when 'TBinding : Binding> =
    class
        inherit ClientTransport
    end
[<AbstractClassAttribute>]
type ClientTransport<'TBinding when 'TBinding : Binding> =
    class
        inherit ClientTransport
    end
Type Parameters
TBinding
See Also
ClientTransport TBinding Members
NFX.Glue Namespace


ClientTransport(TBinding) Members

ClientTransport TBinding Members NFX Class Library

The ClientTransport TBinding type exposes the following members.
Constructors
 | Name | Description
Public method | ClientTransport TBinding | Initializes a new instance of the ClientTransport TBinding class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and transport instance are running or throws otherwise (Inherited from Transport.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Transport.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoDumpInstrumentationData | Override to dump instrumentation data, dont forget to call base to dump basic metrics (Inherited from Transport.)
Protected method | DoSendRequest | Override to send a client request into remote endpoint. This is a blocking call for bindings that are OperationFlow.Synchronous and result arrives immediately into CallSlot. (Inherited from ClientTransport.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Inherited from Transport.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | DumpInstrumentationData | Dumps instrumentation data (Inherited from Transport.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Release | Releases transport by setting Acquired flag to false so it can be used by other operations (Inherited from Transport.)
Public method | ResetStats | Resets all statistical counters (Inherited from Transport.)
Public method | SendRequest | Sends a client request into remote endpoint. This is a blocking call for bindings that are OperationFlow.Synchronous and result arrives immediately into CallSlot. (Inherited from ClientTransport.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Protected method | stat_BytesReceived | (Inherited from Transport.)
Protected method | stat_BytesSent | (Inherited from Transport.)
Protected method | stat_Errors | (Inherited from Transport.)
Protected method | stat_MsgReceived | (Inherited from Transport.)
Protected method | stat_MsgSent | (Inherited from Transport.)
Protected method | stat_Time | Processes named time measurement statistical sample by using EMA filter (Inherited from Transport.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryAcquire | A thread-safe operation that tries to acquire(reserve) this instance for exclusive use. Returns true if acqusition succeded, false is this instance is reserved by someone else (Inherited from Transport.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_TransportKind | (Inherited from Transport.)
Back to Top
Properties
 | Name | Description
Public property | Acquired | Returns true when this transport instance has been acquired by some operation and is busy (Inherited from Transport.)
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | Binding |
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExpirationStart | Returns timestamp when manager touched the instance for last time and no traffic went through it since (Inherited from Transport.)
Public property | Glue | Returns glue implementation that this transport is under (Inherited from Transport.)
Public property | IdleAgeMs | Returns the duration of transport idle period in ms. (Inherited from Transport.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Node | Returns node that this transport services (Inherited from Transport.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | StatBytesReceived | Returns how many bytes were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatBytesSent | Returns how many bytes were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatErrors | Returns how many message processing errors happened since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgReceived | Returns how many messages were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgSent | Returns how many messages were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatTimes | Returns enumerable of named times measured in double second fractions. The returned times are EMA-filtered from supplied individual measurement samples (Inherited from Transport.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransportKind | Reports if this is a server or client transport (Inherited from Transport.)
Back to Top
See Also
ClientTransport TBinding Class
NFX.Glue Namespace


ClientTransport(TBinding) Constructor

ClientTransport TBinding Constructor NFX Class Library

Initializes a new instance of the ClientTransport TBinding class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ClientTransport(
    Binding binding
)
public ClientTransport(
    Binding binding
)
Public Sub New (
    binding As Binding
)
Public Sub New (
    binding As Binding
)
public:
ClientTransport(
    Binding^ binding
)
public:
ClientTransport(
    Binding^ binding
)
new :
        binding : Binding -> ClientTransport
new :
        binding : Binding -> ClientTransport

Parameters

binding
Type: NFX.Glue Binding
See Also
ClientTransport TBinding Class
ClientTransport TBinding Members
NFX.Glue Namespace


ClientTransport(TBinding) Fields

ClientTransport TBinding Fields NFX Class Library

The ClientTransport TBinding type exposes the following members.
Fields
 | Name | Description
Protected field | m_TransportKind | (Inherited from Transport.)
Back to Top
See Also
ClientTransport TBinding Class
NFX.Glue Namespace


ClientTransport(TBinding) Methods

ClientTransport TBinding Methods NFX Class Library

The ClientTransport TBinding type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and transport instance are running or throws otherwise (Inherited from Transport.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Transport.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoDumpInstrumentationData | Override to dump instrumentation data, dont forget to call base to dump basic metrics (Inherited from Transport.)
Protected method | DoSendRequest | Override to send a client request into remote endpoint. This is a blocking call for bindings that are OperationFlow.Synchronous and result arrives immediately into CallSlot. (Inherited from ClientTransport.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Inherited from Transport.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | DumpInstrumentationData | Dumps instrumentation data (Inherited from Transport.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Release | Releases transport by setting Acquired flag to false so it can be used by other operations (Inherited from Transport.)
Public method | ResetStats | Resets all statistical counters (Inherited from Transport.)
Public method | SendRequest | Sends a client request into remote endpoint. This is a blocking call for bindings that are OperationFlow.Synchronous and result arrives immediately into CallSlot. (Inherited from ClientTransport.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Protected method | stat_BytesReceived | (Inherited from Transport.)
Protected method | stat_BytesSent | (Inherited from Transport.)
Protected method | stat_Errors | (Inherited from Transport.)
Protected method | stat_MsgReceived | (Inherited from Transport.)
Protected method | stat_MsgSent | (Inherited from Transport.)
Protected method | stat_Time | Processes named time measurement statistical sample by using EMA filter (Inherited from Transport.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryAcquire | A thread-safe operation that tries to acquire(reserve) this instance for exclusive use. Returns true if acqusition succeded, false is this instance is reserved by someone else (Inherited from Transport.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ClientTransport TBinding Class
NFX.Glue Namespace


ClientTransport(TBinding) Properties

ClientTransport TBinding Properties NFX Class Library

The ClientTransport TBinding type exposes the following members.
Properties
 | Name | Description
Public property | Acquired | Returns true when this transport instance has been acquired by some operation and is busy (Inherited from Transport.)
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | Binding |
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExpirationStart | Returns timestamp when manager touched the instance for last time and no traffic went through it since (Inherited from Transport.)
Public property | Glue | Returns glue implementation that this transport is under (Inherited from Transport.)
Public property | IdleAgeMs | Returns the duration of transport idle period in ms. (Inherited from Transport.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Node | Returns node that this transport services (Inherited from Transport.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | StatBytesReceived | Returns how many bytes were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatBytesSent | Returns how many bytes were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatErrors | Returns how many message processing errors happened since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgReceived | Returns how many messages were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgSent | Returns how many messages were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatTimes | Returns enumerable of named times measured in double second fractions. The returned times are EMA-filtered from supplied individual measurement samples (Inherited from Transport.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransportKind | Reports if this is a server or client transport (Inherited from Transport.)
Back to Top
See Also
ClientTransport TBinding Class
NFX.Glue Namespace


ClientTransport(TBinding).Binding Property

ClientTransport TBinding Binding Property NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TBinding Binding { get; }
public TBinding Binding { get; }
Public ReadOnly Property Binding As TBinding
    Get
Public ReadOnly Property Binding As TBinding
    Get
public:
virtual property TBinding Binding {
    TBinding get () sealed;
}
public:
virtual property TBinding Binding {
    TBinding get () sealed;
}
abstract Binding : 'TBinding with get
override Binding : 'TBinding with get
abstract Binding : 'TBinding with get
override Binding : 'TBinding with get

Property Value

Type: TBinding
See Also
ClientTransport TBinding Class
ClientTransport TBinding Members
NFX.Glue Namespace


ConstructorAttribute Class

ConstructorAttribute Class NFX Class Library

Decorates methods that initialize instance of the server class and retain class instance in the server runtime
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.Glue ConstructorAttribute

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.Method, Inherited = false, AllowMultiple = false)]
public class ConstructorAttribute : Attribute
[AttributeUsageAttribute(AttributeTargets.Method, Inherited = false, AllowMultiple = false)]
public class ConstructorAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Method, Inherited := false, AllowMultiple := false)>
Public Class ConstructorAttribute
    Inherits Attribute
<AttributeUsageAttribute(AttributeTargets.Method, Inherited := false, AllowMultiple := false)>
Public Class ConstructorAttribute
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Method, Inherited = false, AllowMultiple = false)]
public ref class ConstructorAttribute : public Attribute
[AttributeUsageAttribute(AttributeTargets::Method, Inherited = false, AllowMultiple = false)]
public ref class ConstructorAttribute : public Attribute
[<AttributeUsageAttribute(AttributeTargets.Method, Inherited = false, AllowMultiple = false)>]
type ConstructorAttribute =
    class
        inherit Attribute
    end
[<AttributeUsageAttribute(AttributeTargets.Method, Inherited = false, AllowMultiple = false)>]
type ConstructorAttribute =
    class
        inherit Attribute
    end
See Also
ConstructorAttribute Members
NFX.Glue Namespace


ConstructorAttribute Members

ConstructorAttribute Members NFX Class Library

The ConstructorAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | ConstructorAttribute | Initializes a new instance of the ConstructorAttribute class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
ConstructorAttribute Class
NFX.Glue Namespace


ConstructorAttribute Constructor

ConstructorAttribute Constructor NFX Class Library

Initializes a new instance of the ConstructorAttribute class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConstructorAttribute()
public ConstructorAttribute()
Public Sub New
Public Sub New
public:
ConstructorAttribute()
public:
ConstructorAttribute()
new : unit -> ConstructorAttribute
new : unit -> ConstructorAttribute
See Also
ConstructorAttribute Class
ConstructorAttribute Members
NFX.Glue Namespace


ConstructorAttribute Methods

ConstructorAttribute Methods NFX Class Library

The ConstructorAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ConstructorAttribute Class
NFX.Glue Namespace


ConstructorAttribute Properties

ConstructorAttribute Properties NFX Class Library

The ConstructorAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
ConstructorAttribute Class
NFX.Glue Namespace


DestructorAttribute Class

DestructorAttribute Class NFX Class Library

Decorates methods that finalize instance of the server class and release class instance in the server runtime
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.Glue DestructorAttribute

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.Method, Inherited = false, AllowMultiple = false)]
public class DestructorAttribute : Attribute
[AttributeUsageAttribute(AttributeTargets.Method, Inherited = false, AllowMultiple = false)]
public class DestructorAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Method, Inherited := false, AllowMultiple := false)>
Public Class DestructorAttribute
    Inherits Attribute
<AttributeUsageAttribute(AttributeTargets.Method, Inherited := false, AllowMultiple := false)>
Public Class DestructorAttribute
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Method, Inherited = false, AllowMultiple = false)]
public ref class DestructorAttribute : public Attribute
[AttributeUsageAttribute(AttributeTargets::Method, Inherited = false, AllowMultiple = false)]
public ref class DestructorAttribute : public Attribute
[<AttributeUsageAttribute(AttributeTargets.Method, Inherited = false, AllowMultiple = false)>]
type DestructorAttribute =
    class
        inherit Attribute
    end
[<AttributeUsageAttribute(AttributeTargets.Method, Inherited = false, AllowMultiple = false)>]
type DestructorAttribute =
    class
        inherit Attribute
    end
See Also
DestructorAttribute Members
NFX.Glue Namespace


DestructorAttribute Members

DestructorAttribute Members NFX Class Library

The DestructorAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | DestructorAttribute | Initializes a new instance of the DestructorAttribute class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
DestructorAttribute Class
NFX.Glue Namespace


DestructorAttribute Constructor

DestructorAttribute Constructor NFX Class Library

Initializes a new instance of the DestructorAttribute class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DestructorAttribute()
public DestructorAttribute()
Public Sub New
Public Sub New
public:
DestructorAttribute()
public:
DestructorAttribute()
new : unit -> DestructorAttribute
new : unit -> DestructorAttribute
See Also
DestructorAttribute Class
DestructorAttribute Members
NFX.Glue Namespace


DestructorAttribute Methods

DestructorAttribute Methods NFX Class Library

The DestructorAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
DestructorAttribute Class
NFX.Glue Namespace


DestructorAttribute Properties

DestructorAttribute Properties NFX Class Library

The DestructorAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
DestructorAttribute Class
NFX.Glue Namespace


DumpDetail Enumeration

DumpDetail Enumeration NFX Class Library

Message/data dumping detail

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[FlagsAttribute]
public enum DumpDetail
[FlagsAttribute]
public enum DumpDetail
<FlagsAttribute>
Public Enumeration DumpDetail
<FlagsAttribute>
Public Enumeration DumpDetail
[FlagsAttribute]
public enum class DumpDetail
[FlagsAttribute]
public enum class DumpDetail
[<FlagsAttribute>]
type DumpDetail
[<FlagsAttribute>]
type DumpDetail
Members
Member name | Value | Description
None | 0 | No dumping
Message | 1 | Message-level dumping
See Also
NFX.Glue Namespace


EndPoint Class

EndPoint Class NFX Class Library

Abstarction of server and client endpoints. And endpoint is a logically-connected entity per: ABC rule - Address/Binding/Contract(s)
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Glue EndPoint
NFX.Glue ClientEndPoint
NFX.Glue ServerEndPoint

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class EndPoint : DisposableObject
public abstract class EndPoint : DisposableObject
Public MustInherit Class EndPoint
    Inherits DisposableObject
Public MustInherit Class EndPoint
    Inherits DisposableObject
public ref class EndPoint abstract : public DisposableObject
public ref class EndPoint abstract : public DisposableObject
[<AbstractClassAttribute>]
type EndPoint =
    class
        inherit DisposableObject
    end
[<AbstractClassAttribute>]
type EndPoint =
    class
        inherit DisposableObject
    end
See Also
EndPoint Members
NFX.Glue Namespace


EndPoint Members

EndPoint Members NFX Class Library

The EndPoint type exposes the following members.
Constructors
 | Name | Description
Protected method | EndPoint(IGlue) | Initializes a new instance of the EndPoint class
Protected method | EndPoint(IGlue, Node, Binding) | Initializes a new instance of the EndPoint class
Back to Top
Methods
 | Name | Description
Protected method | Destructor | Override this method to do actual destructor work (Inherited from DisposableObject.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Binding |
Protected field | m_Glue |
Protected field | m_Node |
Back to Top
Properties
 | Name | Description
Public property | Binding | Returns a binding of this endpoint. "B" component of the "ABC" rule
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Glue | References glue that this endpoint works under
Public property | Node | Returns a node of this endpoint. "A" component of the "ABC" rule
Back to Top
See Also
EndPoint Class
NFX.Glue Namespace


EndPoint Constructor

EndPoint Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | EndPoint(IGlue) | Initializes a new instance of the EndPoint class
Protected method | EndPoint(IGlue, Node, Binding) | Initializes a new instance of the EndPoint class
Back to Top
See Also
EndPoint Class
EndPoint Members
NFX.Glue Namespace


EndPoint Constructor (IGlue)

EndPoint Constructor (IGlue) NFX Class Library

Initializes a new instance of the EndPoint class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected EndPoint(
    IGlue glue
)
protected EndPoint(
    IGlue glue
)
Protected Sub New (
    glue As IGlue
)
Protected Sub New (
    glue As IGlue
)
protected:
EndPoint(
    IGlue^ glue
)
protected:
EndPoint(
    IGlue^ glue
)
new :
        glue : IGlue -> EndPoint
new :
        glue : IGlue -> EndPoint

Parameters

glue
Type: NFX.Glue IGlue
See Also
EndPoint Class
EndPoint Members
EndPoint Overload
NFX.Glue Namespace


EndPoint Constructor (IGlue, Node, Binding)

EndPoint Constructor (IGlue, Node, Binding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the EndPoint class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected EndPoint(
    IGlue glue,
    Node node,
    Binding binding
)
protected EndPoint(
    IGlue glue,
    Node node,
    Binding binding
)
Protected Sub New (
    glue As IGlue,
    node As Node,
    binding As Binding
)
Protected Sub New (
    glue As IGlue,
    node As Node,
    binding As Binding
)
protected:
EndPoint(
    IGlue^ glue,
    Node node,
    Binding^ binding
)
protected:
EndPoint(
    IGlue^ glue,
    Node node,
    Binding^ binding
)
new :
        glue : IGlue *
        node : Node *
        binding : Binding -> EndPoint
new :
        glue : IGlue *
        node : Node *
        binding : Binding -> EndPoint

Parameters

glue
Type: NFX.Glue IGlue
node
Type: NFX.Glue Node
binding
Type: NFX.Glue Binding
See Also
EndPoint Class
EndPoint Members
EndPoint Overload
NFX.Glue Namespace


EndPoint Fields

EndPoint Fields NFX Class Library

The EndPoint type exposes the following members.
Fields
 | Name | Description
Protected field | m_Binding |
Protected field | m_Glue |
Protected field | m_Node |
Back to Top
See Also
EndPoint Class
NFX.Glue Namespace


EndPoint.m_Binding Field

EndPoint m_Binding Field NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Binding m_Binding
protected Binding m_Binding
Protected m_Binding As Binding
Protected m_Binding As Binding
protected:
Binding^ m_Binding
protected:
Binding^ m_Binding
val mutable m_Binding: Binding
val mutable m_Binding: Binding

Field Value

Type: Binding
See Also
EndPoint Class
EndPoint Members
NFX.Glue Namespace


EndPoint.m_Glue Field

EndPoint m_Glue Field NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IGlueImplementation m_Glue
protected IGlueImplementation m_Glue
Protected m_Glue As IGlueImplementation
Protected m_Glue As IGlueImplementation
protected:
IGlueImplementation^ m_Glue
protected:
IGlueImplementation^ m_Glue
val mutable m_Glue: IGlueImplementation
val mutable m_Glue: IGlueImplementation

Field Value

Type: IGlueImplementation
See Also
EndPoint Class
EndPoint Members
NFX.Glue Namespace


EndPoint.m_Node Field

EndPoint m_Node Field NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Node m_Node
protected Node m_Node
Protected m_Node As Node
Protected m_Node As Node
protected:
Node m_Node
protected:
Node m_Node
val mutable m_Node: Node
val mutable m_Node: Node

Field Value

Type: Node
See Also
EndPoint Class
EndPoint Members
NFX.Glue Namespace


EndPoint Methods

EndPoint Methods NFX Class Library

The EndPoint type exposes the following members.
Methods
 | Name | Description
Protected method | Destructor | Override this method to do actual destructor work (Inherited from DisposableObject.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
EndPoint Class
NFX.Glue Namespace


EndPoint Properties

EndPoint Properties NFX Class Library

The EndPoint type exposes the following members.
Properties
 | Name | Description
Public property | Binding | Returns a binding of this endpoint. "B" component of the "ABC" rule
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Glue | References glue that this endpoint works under
Public property | Node | Returns a node of this endpoint. "A" component of the "ABC" rule
Back to Top
See Also
EndPoint Class
NFX.Glue Namespace


EndPoint.Binding Property

EndPoint Binding Property NFX Class Library

Returns a binding of this endpoint. "B" component of the "ABC" rule

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Binding Binding { get; }
public Binding Binding { get; }
Public ReadOnly Property Binding As Binding
    Get
Public ReadOnly Property Binding As Binding
    Get
public:
property Binding^ Binding {
    Binding^ get ();
}
public:
property Binding^ Binding {
    Binding^ get ();
}
member Binding : Binding with get
member Binding : Binding with get

Property Value

Type: Binding
See Also
EndPoint Class
EndPoint Members
NFX.Glue Namespace


EndPoint.Glue Property

EndPoint Glue Property NFX Class Library

References glue that this endpoint works under

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IGlue Glue { get; }
public IGlue Glue { get; }
Public ReadOnly Property Glue As IGlue
    Get
Public ReadOnly Property Glue As IGlue
    Get
public:
property IGlue^ Glue {
    IGlue^ get ();
}
public:
property IGlue^ Glue {
    IGlue^ get ();
}
member Glue : IGlue with get
member Glue : IGlue with get

Property Value

Type: IGlue
See Also
EndPoint Class
EndPoint Members
NFX.Glue Namespace


EndPoint.Node Property

EndPoint Node Property NFX Class Library

Returns a node of this endpoint. "A" component of the "ABC" rule

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Node Node { get; }
public Node Node { get; }
Public ReadOnly Property Node As Node
    Get
Public ReadOnly Property Node As Node
    Get
public:
property Node Node {
    Node get ();
}
public:
property Node Node {
    Node get ();
}
member Node : Node with get
member Node : Node with get

Property Value

Type: Node
See Also
EndPoint Class
EndPoint Members
NFX.Glue Namespace


Future(T) Structure

Future T Structure NFX Class Library

Provides a higher-level wrapper around CallSlot returned value by Glue. All property accessors evaluate synchronously on the calling thread. This struct should not be used with One-Way calls or calls that return void

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct Future<T>
public struct Future<T>
Public Structure Future(Of T)
Public Structure Future(Of T)
generic<typename T>
public value class Future
generic<typename T>
public value class Future
[<SealedAttribute>]
type Future<'T> =  struct end
[<SealedAttribute>]
type Future<'T> =  struct end
Type Parameters
T
See Also
Future T Members
NFX.Glue Namespace


Future(T) Members

Future T Members NFX Class Library

The Future T type exposes the following members.
Constructors
 | Name | Description
Public method | Future T | Initializes a new instance of the Future T class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Call | Returns the underlying CallSlot object
Back to Top
Properties
 | Name | Description
Public property | Available | Non-blocking call that returns true if result arrived, false otherwise
Public property | Value | Blocking call that waits for return value. Use non-blocking Available to see if result arrived
Back to Top
See Also
Future T Structure
NFX.Glue Namespace


Future(T) Constructor

Future T Constructor NFX Class Library

Initializes a new instance of the Future T class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Future(
    CallSlot call
)
public Future(
    CallSlot call
)
Public Sub New (
    call As CallSlot
)
Public Sub New (
    call As CallSlot
)
public:
Future(
    CallSlot^ call
)
public:
Future(
    CallSlot^ call
)
new :
        call : CallSlot -> Future
new :
        call : CallSlot -> Future

Parameters

call
Type: NFX.Glue CallSlot
See Also
Future T Structure
Future T Members
NFX.Glue Namespace


Future(T) Fields

Future T Fields NFX Class Library

The Future T type exposes the following members.
Fields
 | Name | Description
Public field | Call | Returns the underlying CallSlot object
Back to Top
See Also
Future T Structure
NFX.Glue Namespace


Future(T).Call Field

Future T Call Field NFX Class Library

Returns the underlying CallSlot object

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly CallSlot Call
public readonly CallSlot Call
Public ReadOnly Call As CallSlot
Public ReadOnly Call As CallSlot
public:
initonly CallSlot^ Call
public:
initonly CallSlot^ Call
val Call: CallSlot
val Call: CallSlot

Field Value

Type: CallSlot
See Also
Future T Structure
Future T Members
NFX.Glue Namespace


Future(T) Methods

Future T Methods NFX Class Library

The Future T type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Future T Structure
NFX.Glue Namespace


Future(T) Properties

Future T Properties NFX Class Library

The Future T type exposes the following members.
Properties
 | Name | Description
Public property | Available | Non-blocking call that returns true if result arrived, false otherwise
Public property | Value | Blocking call that waits for return value. Use non-blocking Available to see if result arrived
Back to Top
See Also
Future T Structure
NFX.Glue Namespace


Future(T).Available Property

Future T Available Property NFX Class Library

Non-blocking call that returns true if result arrived, false otherwise

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Available { get; }
public bool Available { get; }
Public ReadOnly Property Available As Boolean
    Get
Public ReadOnly Property Available As Boolean
    Get
public:
property bool Available {
    bool get ();
}
public:
property bool Available {
    bool get ();
}
member Available : bool with get
member Available : bool with get

Property Value

Type: Online Boolean
See Also
Future T Structure
Future T Members
NFX.Glue Namespace


Future(T).Value Property

Future T Value Property NFX Class Library

Blocking call that waits for return value. Use non-blocking Available to see if result arrived

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T Value { get; }
public T Value { get; }
Public ReadOnly Property Value As T
    Get
Public ReadOnly Property Value As T
    Get
public:
property T Value {
    T get ();
}
public:
property T Value {
    T get ();
}
member Value : 'T with get
member Value : 'T with get

Property Value

Type: T
See Also
Future T Structure
Future T Members
NFX.Glue Namespace


FutureVoid Structure

FutureVoid Structure NFX Class Library

Provides a higher-level wrapper around CallSlot returned by Glue. All property accessors evaluate synchronously on the calling thread. This struct should not be used with One-Way calls

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct FutureVoid
public struct FutureVoid
Public Structure FutureVoid
Public Structure FutureVoid
public value class FutureVoid
public value class FutureVoid
[<SealedAttribute>]
type FutureVoid =  struct end
[<SealedAttribute>]
type FutureVoid =  struct end
See Also
FutureVoid Members
NFX.Glue Namespace


FutureVoid Members

FutureVoid Members NFX Class Library

The FutureVoid type exposes the following members.
Constructors
 | Name | Description
Public method | FutureVoid | Initializes a new instance of the FutureVoid class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Public method | Wait | Blocking call that waits for call completion. Use non-blocking Available to see if call has completed
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Call | Returns the underlying CallSlot object
Back to Top
Properties
 | Name | Description
Public property | Available | Non-blocking call that returns true if result arrived, false otherwise
Back to Top
See Also
FutureVoid Structure
NFX.Glue Namespace


FutureVoid Constructor

FutureVoid Constructor NFX Class Library

Initializes a new instance of the FutureVoid class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FutureVoid(
    CallSlot call
)
public FutureVoid(
    CallSlot call
)
Public Sub New (
    call As CallSlot
)
Public Sub New (
    call As CallSlot
)
public:
FutureVoid(
    CallSlot^ call
)
public:
FutureVoid(
    CallSlot^ call
)
new :
        call : CallSlot -> FutureVoid
new :
        call : CallSlot -> FutureVoid

Parameters

call
Type: NFX.Glue CallSlot
See Also
FutureVoid Structure
FutureVoid Members
NFX.Glue Namespace


FutureVoid Fields

FutureVoid Fields NFX Class Library

The FutureVoid type exposes the following members.
Fields
 | Name | Description
Public field | Call | Returns the underlying CallSlot object
Back to Top
See Also
FutureVoid Structure
NFX.Glue Namespace


FutureVoid.Call Field

FutureVoid Call Field NFX Class Library

Returns the underlying CallSlot object

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly CallSlot Call
public readonly CallSlot Call
Public ReadOnly Call As CallSlot
Public ReadOnly Call As CallSlot
public:
initonly CallSlot^ Call
public:
initonly CallSlot^ Call
val Call: CallSlot
val Call: CallSlot

Field Value

Type: CallSlot
See Also
FutureVoid Structure
FutureVoid Members
NFX.Glue Namespace


FutureVoid Methods

FutureVoid Methods NFX Class Library

The FutureVoid type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Public method | Wait | Blocking call that waits for call completion. Use non-blocking Available to see if call has completed
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
FutureVoid Structure
NFX.Glue Namespace


FutureVoid.Wait Method

FutureVoid Wait Method NFX Class Library

Blocking call that waits for call completion. Use non-blocking Available to see if call has completed

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Wait()
public void Wait()
Public Sub Wait
Public Sub Wait
public:
void Wait()
public:
void Wait()
member Wait : unit -> unit
member Wait : unit -> unit
See Also
FutureVoid Structure
FutureVoid Members
NFX.Glue Namespace


FutureVoid Properties

FutureVoid Properties NFX Class Library

The FutureVoid type exposes the following members.
Properties
 | Name | Description
Public property | Available | Non-blocking call that returns true if result arrived, false otherwise
Back to Top
See Also
FutureVoid Structure
NFX.Glue Namespace


FutureVoid.Available Property

FutureVoid Available Property NFX Class Library

Non-blocking call that returns true if result arrived, false otherwise

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Available { get; }
public bool Available { get; }
Public ReadOnly Property Available As Boolean
    Get
Public ReadOnly Property Available As Boolean
    Get
public:
property bool Available {
    bool get ();
}
public:
property bool Available {
    bool get ();
}
member Available : bool with get
member Available : bool with get

Property Value

Type: Online Boolean
See Also
FutureVoid Structure
FutureVoid Members
NFX.Glue Namespace


GlueComponentService Class

GlueComponentService Class NFX Class Library

Provides base functionality for internal glue component implementations
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service IGlueImplementation
NFX.ServiceModel ServiceWithInstrumentationBase IGlueImplementation
NFX.Glue GlueComponentService
NFX.Glue Binding
NFX.Glue.Implementation ServerHandler
NFX.Glue Provider

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class GlueComponentService : ServiceWithInstrumentationBase<IGlueImplementation>
public abstract class GlueComponentService : ServiceWithInstrumentationBase<IGlueImplementation>
Public MustInherit Class GlueComponentService
    Inherits ServiceWithInstrumentationBase(Of IGlueImplementation)
Public MustInherit Class GlueComponentService
    Inherits ServiceWithInstrumentationBase(Of IGlueImplementation)
public ref class GlueComponentService abstract : public ServiceWithInstrumentationBase<IGlueImplementation^>
public ref class GlueComponentService abstract : public ServiceWithInstrumentationBase<IGlueImplementation^>
[<AbstractClassAttribute>]
type GlueComponentService =
    class
        inherit ServiceWithInstrumentationBase<IGlueImplementation>
    end
[<AbstractClassAttribute>]
type GlueComponentService =
    class
        inherit ServiceWithInstrumentationBase<IGlueImplementation>
    end
See Also
GlueComponentService Members
NFX.Glue Namespace


GlueComponentService Members

GlueComponentService Members NFX Class Library

The GlueComponentService type exposes the following members.
Constructors
 | Name | Description
Protected method | GlueComponentService(IGlueImplementation) | Initializes a new instance of the GlueComponentService class
Protected method | GlueComponentService(IGlueImplementation, String) | Initializes a new instance of the GlueComponentService class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | WriteLog |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | Glue |
Public property | InstrumentationEnabled | Implements IInstrumentable (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
GlueComponentService Class
NFX.Glue Namespace


GlueComponentService Constructor

GlueComponentService Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | GlueComponentService(IGlueImplementation) | Initializes a new instance of the GlueComponentService class
Protected method | GlueComponentService(IGlueImplementation, String) | Initializes a new instance of the GlueComponentService class
Back to Top
See Also
GlueComponentService Class
GlueComponentService Members
NFX.Glue Namespace


GlueComponentService Constructor (IGlueImplementation)

GlueComponentService Constructor (IGlueImplementation) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the GlueComponentService class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal GlueComponentService(
    IGlueImplementation glue
)
internal GlueComponentService(
    IGlueImplementation glue
)
Friend Sub New (
    glue As IGlueImplementation
)
Friend Sub New (
    glue As IGlueImplementation
)
internal:
GlueComponentService(
    IGlueImplementation^ glue
)
internal:
GlueComponentService(
    IGlueImplementation^ glue
)
new :
        glue : IGlueImplementation -> GlueComponentService
new :
        glue : IGlueImplementation -> GlueComponentService

Parameters

glue
Type: NFX.Glue IGlueImplementation
See Also
GlueComponentService Class
GlueComponentService Members
GlueComponentService Overload
NFX.Glue Namespace


GlueComponentService Constructor (IGlueImplementation, String)

GlueComponentService Constructor (IGlueImplementation, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the GlueComponentService class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected GlueComponentService(
    IGlueImplementation glue,
    string name
)
protected GlueComponentService(
    IGlueImplementation glue,
    string name
)
Protected Sub New (
    glue As IGlueImplementation,
    name As String
)
Protected Sub New (
    glue As IGlueImplementation,
    name As String
)
protected:
GlueComponentService(
    IGlueImplementation^ glue,
    String^ name
)
protected:
GlueComponentService(
    IGlueImplementation^ glue,
    String^ name
)
new :
        glue : IGlueImplementation *
        name : string -> GlueComponentService
new :
        glue : IGlueImplementation *
        name : string -> GlueComponentService

Parameters

glue
Type: NFX.Glue IGlueImplementation
name
Type: Online System String
See Also
GlueComponentService Class
GlueComponentService Members
GlueComponentService Overload
NFX.Glue Namespace


GlueComponentService Methods

GlueComponentService Methods NFX Class Library

The GlueComponentService type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | WriteLog |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GlueComponentService Class
NFX.Glue Namespace


GlueComponentService.WriteLog Method

GlueComponentService WriteLog Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteLog(
    LogSrc source,
    MessageType type,
    string msg,
    string from = null,
    Exception exception = null,
    string pars = null,
    Nullable<Guid> relatedTo = null
)
public void WriteLog(
    LogSrc source,
    MessageType type,
    string msg,
    string from = null,
    Exception exception = null,
    string pars = null,
    Nullable<Guid> relatedTo = null
)
Public Sub WriteLog (
    source As LogSrc,
    type As MessageType,
    msg As String,
    Optional from As String = Nothing,
    Optional exception As Exception = Nothing,
    Optional pars As String = Nothing,
    Optional relatedTo As Nullable(Of Guid) = Nothing
)
Public Sub WriteLog (
    source As LogSrc,
    type As MessageType,
    msg As String,
    Optional from As String = Nothing,
    Optional exception As Exception = Nothing,
    Optional pars As String = Nothing,
    Optional relatedTo As Nullable(Of Guid) = Nothing
)
public:
void WriteLog(
    LogSrc source,
    MessageType type,
    String^ msg,
    String^ from = nullptr,
    Exception^ exception = nullptr,
    String^ pars = nullptr,
    Nullable<Guid> relatedTo = nullptr
)
public:
void WriteLog(
    LogSrc source,
    MessageType type,
    String^ msg,
    String^ from = nullptr,
    Exception^ exception = nullptr,
    String^ pars = nullptr,
    Nullable<Guid> relatedTo = nullptr
)
member WriteLog :
        source : LogSrc *
        type : MessageType *
        msg : string *
        ?from : string *
        ?exception : Exception *
        ?pars : string *
        ?relatedTo : Nullable<Guid>
(* Defaults:
        let _from = defaultArg from null
        let _exception = defaultArg exception null
        let _pars = defaultArg pars null
        let _relatedTo = defaultArg relatedTo null
*)
-> unit
member WriteLog :
        source : LogSrc *
        type : MessageType *
        msg : string *
        ?from : string *
        ?exception : Exception *
        ?pars : string *
        ?relatedTo : Nullable<Guid>
(* Defaults:
        let _from = defaultArg from null
        let _exception = defaultArg exception null
        let _pars = defaultArg pars null
        let _relatedTo = defaultArg relatedTo null
*)
-> unit

Parameters

source
Type: NFX.Glue LogSrc
type
Type: NFX.Log MessageType
msg
Type: Online System String
from (Optional)
Type: Online System String
exception (Optional)
Type: Online System Exception
pars (Optional)
Type: Online System String
relatedTo (Optional)
Type: Online System Nullable Online Guid
See Also
GlueComponentService Class
GlueComponentService Members
NFX.Glue Namespace


GlueComponentService Properties

GlueComponentService Properties NFX Class Library

The GlueComponentService type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | Glue |
Public property | InstrumentationEnabled | Implements IInstrumentable (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
GlueComponentService Class
NFX.Glue Namespace


GlueComponentService.Glue Property

GlueComponentService Glue Property NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IGlueImplementation Glue { get; }
public IGlueImplementation Glue { get; }
Public ReadOnly Property Glue As IGlueImplementation
    Get
Public ReadOnly Property Glue As IGlueImplementation
    Get
public:
property IGlueImplementation^ Glue {
    IGlueImplementation^ get ();
}
public:
property IGlueImplementation^ Glue {
    IGlueImplementation^ get ();
}
member Glue : IGlueImplementation with get
member Glue : IGlueImplementation with get

Property Value

Type: IGlueImplementation
See Also
GlueComponentService Class
GlueComponentService Members
NFX.Glue Namespace


GlueComponentService.InstrumentationEnabled Property

GlueComponentService InstrumentationEnabled Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Implements IInstrumentable

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute(Default = false)]
public override bool InstrumentationEnabled { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute(Default = false)]
public override bool InstrumentationEnabled { get; set; }
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute(Default := false)>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute(Default := false)>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(Default = false)]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(Default = false)]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
abstract InstrumentationEnabled : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
override InstrumentationEnabled : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
abstract InstrumentationEnabled : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
override InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentable InstrumentationEnabled
See Also
GlueComponentService Class
GlueComponentService Members
NFX.Glue Namespace


GluedAttribute Class

GluedAttribute Class NFX Class Library

Decorates interfaces that represent glued contract points
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.Glue GluedAttribute

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.Interface, Inherited = true, AllowMultiple = false)]
public class GluedAttribute : Attribute
[AttributeUsageAttribute(AttributeTargets.Interface, Inherited = true, AllowMultiple = false)]
public class GluedAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Interface, Inherited := true, AllowMultiple := false)>
Public Class GluedAttribute
    Inherits Attribute
<AttributeUsageAttribute(AttributeTargets.Interface, Inherited := true, AllowMultiple := false)>
Public Class GluedAttribute
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Interface, Inherited = true, AllowMultiple = false)]
public ref class GluedAttribute : public Attribute
[AttributeUsageAttribute(AttributeTargets::Interface, Inherited = true, AllowMultiple = false)]
public ref class GluedAttribute : public Attribute
[<AttributeUsageAttribute(AttributeTargets.Interface, Inherited = true, AllowMultiple = false)>]
type GluedAttribute =
    class
        inherit Attribute
    end
[<AttributeUsageAttribute(AttributeTargets.Interface, Inherited = true, AllowMultiple = false)>]
type GluedAttribute =
    class
        inherit Attribute
    end
See Also
GluedAttribute Members
NFX.Glue Namespace


GluedAttribute Members

GluedAttribute Members NFX Class Library

The GluedAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | GluedAttribute | Initializes a new instance of the GluedAttribute class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
GluedAttribute Class
NFX.Glue Namespace


GluedAttribute Constructor

GluedAttribute Constructor NFX Class Library

Initializes a new instance of the GluedAttribute class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GluedAttribute()
public GluedAttribute()
Public Sub New
Public Sub New
public:
GluedAttribute()
public:
GluedAttribute()
new : unit -> GluedAttribute
new : unit -> GluedAttribute
See Also
GluedAttribute Class
GluedAttribute Members
NFX.Glue Namespace


GluedAttribute Methods

GluedAttribute Methods NFX Class Library

The GluedAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GluedAttribute Class
NFX.Glue Namespace


GluedAttribute Properties

GluedAttribute Properties NFX Class Library

The GluedAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
GluedAttribute Class
NFX.Glue Namespace


GlueException Class

GlueException Class NFX Class Library

Base exception thrown by the Glue framework
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Glue GlueException
NFX.Glue ClientCallException
NFX.Glue ClientMsgInspectionException
NFX.Glue InvalidGlueOperationException
NFX.Glue ProtocolException
NFX.Glue RemoteException
NFX.Glue ServerException

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GlueException : NFXException
[SerializableAttribute]
public class GlueException : NFXException
<SerializableAttribute>
Public Class GlueException
    Inherits NFXException
<SerializableAttribute>
Public Class GlueException
    Inherits NFXException
[SerializableAttribute]
public ref class GlueException : public NFXException
[SerializableAttribute]
public ref class GlueException : public NFXException
[<SerializableAttribute>]
type GlueException =
    class
        inherit NFXException
    end
[<SerializableAttribute>]
type GlueException =
    class
        inherit NFXException
    end
See Also
GlueException Members
NFX.Glue Namespace


GlueException Members

GlueException Members NFX Class Library

The GlueException type exposes the following members.
Constructors
 | Name | Description
Public method | GlueException | Initializes a new instance of the GlueException class
Public method | GlueException(String) | Initializes a new instance of the GlueException class
Protected method | GlueException(SerializationInfo, StreamingContext) | Initializes a new instance of the GlueException class
Public method | GlueException(String, Exception) | Initializes a new instance of the GlueException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
GlueException Class
NFX.Glue Namespace


GlueException Constructor

GlueException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | GlueException | Initializes a new instance of the GlueException class
Public method | GlueException(String) | Initializes a new instance of the GlueException class
Protected method | GlueException(SerializationInfo, StreamingContext) | Initializes a new instance of the GlueException class
Public method | GlueException(String, Exception) | Initializes a new instance of the GlueException class
Back to Top
See Also
GlueException Class
GlueException Members
NFX.Glue Namespace


GlueException Constructor

GlueException Constructor NFX Class Library

Initializes a new instance of the GlueException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlueException()
public GlueException()
Public Sub New
Public Sub New
public:
GlueException()
public:
GlueException()
new : unit -> GlueException
new : unit -> GlueException
See Also
GlueException Class
GlueException Members
GlueException Overload
NFX.Glue Namespace


GlueException Constructor (String)

GlueException Constructor (String) NFX Class Library

Initializes a new instance of the GlueException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlueException(
    string message
)
public GlueException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
GlueException(
    String^ message
)
public:
GlueException(
    String^ message
)
new :
        message : string -> GlueException
new :
        message : string -> GlueException

Parameters

message
Type: Online System String
See Also
GlueException Class
GlueException Members
GlueException Overload
NFX.Glue Namespace


GlueException Constructor (SerializationInfo, StreamingContext)

GlueException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the GlueException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected GlueException(
    SerializationInfo info,
    StreamingContext context
)
protected GlueException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
GlueException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
GlueException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> GlueException
new :
        info : SerializationInfo *
        context : StreamingContext -> GlueException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
GlueException Class
GlueException Members
GlueException Overload
NFX.Glue Namespace


GlueException Constructor (String, Exception)

GlueException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the GlueException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlueException(
    string message,
    Exception inner
)
public GlueException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
GlueException(
    String^ message,
    Exception^ inner
)
public:
GlueException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> GlueException
new :
        message : string *
        inner : Exception -> GlueException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
GlueException Class
GlueException Members
GlueException Overload
NFX.Glue Namespace


GlueException Methods

GlueException Methods NFX Class Library

The GlueException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
GlueException Class
NFX.Glue Namespace


GlueException Properties

GlueException Properties NFX Class Library

The GlueException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
GlueException Class
NFX.Glue Namespace


GlueException Events

GlueException Events NFX Class Library

The GlueException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
GlueException Class
NFX.Glue Namespace


IClientMsgInspector Interface

IClientMsgInspector Interface NFX Class Library

Inspects messages on the client side. ClientInspectors may be registered on ClientEndPoint, Binding or Glue levels

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IClientMsgInspector : IMsgInspector,
    INamed, IOrdered, IConfigurable
public interface IClientMsgInspector : IMsgInspector,
    INamed, IOrdered, IConfigurable
Public Interface IClientMsgInspector
    Inherits IMsgInspector, INamed, IOrdered, IConfigurable
Public Interface IClientMsgInspector
    Inherits IMsgInspector, INamed, IOrdered, IConfigurable
public interface class IClientMsgInspector : IMsgInspector,
    INamed, IOrdered, IConfigurable
public interface class IClientMsgInspector : IMsgInspector,
    INamed, IOrdered, IConfigurable
type IClientMsgInspector =
    interface
        interface IMsgInspector
        interface INamed
        interface IOrdered
        interface IConfigurable
    end
type IClientMsgInspector =
    interface
        interface IMsgInspector
        interface INamed
        interface IOrdered
        interface IConfigurable
    end
See Also
IClientMsgInspector Members
NFX.Glue Namespace


IClientMsgInspector Members

IClientMsgInspector Members NFX Class Library

The IClientMsgInspector type exposes the following members.
Methods
 | Name | Description
Public method | ClientDeliverResponse | Intercepts server response message before it arrives into CallSlot and optionaly allows to change it
Public method | ClientDispatchCall | Intercepts client call during dispatch and optionaly allows to change the RequestMsg
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Back to Top
Properties
 | Name | Description
Public property | Name | (Inherited from INamed.)
Public property | Order | (Inherited from IOrdered.)
Back to Top
See Also
IClientMsgInspector Interface
NFX.Glue Namespace


IClientMsgInspector Methods

IClientMsgInspector Methods NFX Class Library

The IClientMsgInspector type exposes the following members.
Methods
 | Name | Description
Public method | ClientDeliverResponse | Intercepts server response message before it arrives into CallSlot and optionaly allows to change it
Public method | ClientDispatchCall | Intercepts client call during dispatch and optionaly allows to change the RequestMsg
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Back to Top
See Also
IClientMsgInspector Interface
NFX.Glue Namespace


IClientMsgInspector.ClientDeliverResponse Method

IClientMsgInspector ClientDeliverResponse Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Intercepts server response message before it arrives into CallSlot and optionaly allows to change it

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ResponseMsg ClientDeliverResponse(
    CallSlot callSlot,
    ResponseMsg response
)
ResponseMsg ClientDeliverResponse(
    CallSlot callSlot,
    ResponseMsg response
)
Function ClientDeliverResponse (
    callSlot As CallSlot,
    response As ResponseMsg
) As ResponseMsg
Function ClientDeliverResponse (
    callSlot As CallSlot,
    response As ResponseMsg
) As ResponseMsg
ResponseMsg^ ClientDeliverResponse(
    CallSlot^ callSlot,
    ResponseMsg^ response
)
ResponseMsg^ ClientDeliverResponse(
    CallSlot^ callSlot,
    ResponseMsg^ response
)
abstract ClientDeliverResponse :
        callSlot : CallSlot *
        response : ResponseMsg -> ResponseMsg
abstract ClientDeliverResponse :
        callSlot : CallSlot *
        response : ResponseMsg -> ResponseMsg

Parameters

callSlot
Type: NFX.Glue CallSlot
response
Type: NFX.Glue.Protocol ResponseMsg

Return Value

Type: ResponseMsg
See Also
IClientMsgInspector Interface
IClientMsgInspector Members
NFX.Glue Namespace


IClientMsgInspector.ClientDispatchCall Method

IClientMsgInspector ClientDispatchCall Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Intercepts client call during dispatch and optionaly allows to change the RequestMsg

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
RequestMsg ClientDispatchCall(
    ClientEndPoint endpoint,
    RequestMsg request
)
RequestMsg ClientDispatchCall(
    ClientEndPoint endpoint,
    RequestMsg request
)
Function ClientDispatchCall (
    endpoint As ClientEndPoint,
    request As RequestMsg
) As RequestMsg
Function ClientDispatchCall (
    endpoint As ClientEndPoint,
    request As RequestMsg
) As RequestMsg
RequestMsg^ ClientDispatchCall(
    ClientEndPoint^ endpoint,
    RequestMsg^ request
)
RequestMsg^ ClientDispatchCall(
    ClientEndPoint^ endpoint,
    RequestMsg^ request
)
abstract ClientDispatchCall :
        endpoint : ClientEndPoint *
        request : RequestMsg -> RequestMsg
abstract ClientDispatchCall :
        endpoint : ClientEndPoint *
        request : RequestMsg -> RequestMsg

Parameters

endpoint
Type: NFX.Glue ClientEndPoint
request
Type: NFX.Glue.Protocol RequestMsg

Return Value

Type: RequestMsg
See Also
IClientMsgInspector Interface
IClientMsgInspector Members
NFX.Glue Namespace


IClientMsgInspector Properties

IClientMsgInspector Properties NFX Class Library

The IClientMsgInspector type exposes the following members.
Properties
 | Name | Description
Public property | Name | (Inherited from INamed.)
Public property | Order | (Inherited from IOrdered.)
Back to Top
See Also
IClientMsgInspector Interface
NFX.Glue Namespace


IGlue Interface

IGlue Interface NFX Class Library

Represents a contract for Glue - a technology that provides asynchronous distributed component interconnection

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IGlue : IApplicationComponent, IDisposable,
    ILocalizedTimeProvider
public interface IGlue : IApplicationComponent, IDisposable,
    ILocalizedTimeProvider
Public Interface IGlue
    Inherits IApplicationComponent, IDisposable, ILocalizedTimeProvider
Public Interface IGlue
    Inherits IApplicationComponent, IDisposable, ILocalizedTimeProvider
public interface class IGlue : IApplicationComponent,
    IDisposable, ILocalizedTimeProvider
public interface class IGlue : IApplicationComponent,
    IDisposable, ILocalizedTimeProvider
type IGlue =
    interface
        interface IApplicationComponent
        interface IDisposable
        interface ILocalizedTimeProvider
    end
type IGlue =
    interface
        interface IApplicationComponent
        interface IDisposable
        interface ILocalizedTimeProvider
    end
See Also
IGlue Members
NFX.Glue Namespace


IGlue Members

IGlue Members NFX Class Library

The IGlue type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | GetNodeBinding(String) | Retrieves a binding for node and throws if such binding is not known
Public method | GetNodeBinding(Node) | Retrieves a binding for node and throws if such binding is not known
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Back to Top
Properties
 | Name | Description
Public property | Bindings | Performs binding lookup by name
Public property | ClientLogLevel | Determines how much information should be logged about client-side operations
Public property | ClientMsgInspectors | Registry of inspectors that deal with client-side messages
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | DefaultDispatchTimeoutMs | Specifies default ms timout for call dispatch only
Public property | DefaultTimeoutMs | Specified default ms timeout for the calls
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from ILocalizedTimeProvider.)
Public property | Providers | Performs provider lookup by name
Public property | ServerInstanceLockTimeoutMs | Specifies ms timout for non-threadsafe server instance lock
Public property | ServerLogLevel | Determines how much information should be logged about server-side operations
Public property | ServerMsgInspectors | Registry of inspectors that deal with server-side messages
Public property | Servers | Performs ServerEndPoint lookup by name
Public property | TimeLocation | Returns the location (Inherited from ILocalizedTimeProvider.)
Back to Top
See Also
IGlue Interface
NFX.Glue Namespace


IGlue Methods

IGlue Methods NFX Class Library

The IGlue type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | GetNodeBinding(String) | Retrieves a binding for node and throws if such binding is not known
Public method | GetNodeBinding(Node) | Retrieves a binding for node and throws if such binding is not known
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Back to Top
See Also
IGlue Interface
NFX.Glue Namespace


IGlue.GetNodeBinding Method

IGlue GetNodeBinding Method NFX Class Library

Overload List
 | Name | Description
Public method | GetNodeBinding(String) | Retrieves a binding for node and throws if such binding is not known
Public method | GetNodeBinding(Node) | Retrieves a binding for node and throws if such binding is not known
Back to Top
See Also
IGlue Interface
IGlue Members
NFX.Glue Namespace


IGlue.GetNodeBinding Method (String)

IGlue GetNodeBinding Method (String) NFX Class Library

Retrieves a binding for node and throws if such binding is not known

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Binding GetNodeBinding(
    string node
)
Binding GetNodeBinding(
    string node
)
Function GetNodeBinding (
    node As String
) As Binding
Function GetNodeBinding (
    node As String
) As Binding
Binding^ GetNodeBinding(
    String^ node
)
Binding^ GetNodeBinding(
    String^ node
)
abstract GetNodeBinding :
        node : string -> Binding
abstract GetNodeBinding :
        node : string -> Binding

Parameters

node
Type: Online System String

Return Value

Type: Binding
See Also
IGlue Interface
IGlue Members
GetNodeBinding Overload
NFX.Glue Namespace


IGlue.GetNodeBinding Method (Node)

IGlue GetNodeBinding Method (Node) NFX Class Library

Retrieves a binding for node and throws if such binding is not known

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Binding GetNodeBinding(
    Node node
)
Binding GetNodeBinding(
    Node node
)
Function GetNodeBinding (
    node As Node
) As Binding
Function GetNodeBinding (
    node As Node
) As Binding
Binding^ GetNodeBinding(
    Node node
)
Binding^ GetNodeBinding(
    Node node
)
abstract GetNodeBinding :
        node : Node -> Binding
abstract GetNodeBinding :
        node : Node -> Binding

Parameters

node
Type: NFX.Glue Node

Return Value

Type: Binding
See Also
IGlue Interface
IGlue Members
GetNodeBinding Overload
NFX.Glue Namespace


IGlue Properties

IGlue Properties NFX Class Library

The IGlue type exposes the following members.
Properties
 | Name | Description
Public property | Bindings | Performs binding lookup by name
Public property | ClientLogLevel | Determines how much information should be logged about client-side operations
Public property | ClientMsgInspectors | Registry of inspectors that deal with client-side messages
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | DefaultDispatchTimeoutMs | Specifies default ms timout for call dispatch only
Public property | DefaultTimeoutMs | Specified default ms timeout for the calls
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from ILocalizedTimeProvider.)
Public property | Providers | Performs provider lookup by name
Public property | ServerInstanceLockTimeoutMs | Specifies ms timout for non-threadsafe server instance lock
Public property | ServerLogLevel | Determines how much information should be logged about server-side operations
Public property | ServerMsgInspectors | Registry of inspectors that deal with server-side messages
Public property | Servers | Performs ServerEndPoint lookup by name
Public property | TimeLocation | Returns the location (Inherited from ILocalizedTimeProvider.)
Back to Top
See Also
IGlue Interface
NFX.Glue Namespace


IGlue.Bindings Property

IGlue Bindings Property NFX Class Library

Performs binding lookup by name

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IRegistry<Binding> Bindings { get; }
IRegistry<Binding> Bindings { get; }
ReadOnly Property Bindings As IRegistry(Of Binding)
    Get
ReadOnly Property Bindings As IRegistry(Of Binding)
    Get
property IRegistry<Binding^>^ Bindings {
    IRegistry<Binding^>^ get ();
}
property IRegistry<Binding^>^ Bindings {
    IRegistry<Binding^>^ get ();
}
abstract Bindings : IRegistry<Binding> with get
abstract Bindings : IRegistry<Binding> with get

Property Value

Type: IRegistry Binding
See Also
IGlue Interface
IGlue Members
NFX.Glue Namespace


IGlue.ClientLogLevel Property

IGlue ClientLogLevel Property NFX Class Library

Determines how much information should be logged about client-side operations

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
MessageType ClientLogLevel { get; set; }
MessageType ClientLogLevel { get; set; }
Property ClientLogLevel As MessageType
    Get
    Set
Property ClientLogLevel As MessageType
    Get
    Set
property MessageType ClientLogLevel {
    MessageType get ();
    void set (MessageType value);
}
property MessageType ClientLogLevel {
    MessageType get ();
    void set (MessageType value);
}
abstract ClientLogLevel : MessageType with get, set
abstract ClientLogLevel : MessageType with get, set

Property Value

Type: MessageType
See Also
IGlue Interface
IGlue Members
NFX.Glue Namespace


IGlue.ClientMsgInspectors Property

IGlue ClientMsgInspectors Property NFX Class Library

Registry of inspectors that deal with client-side messages

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
OrderedRegistry<IClientMsgInspector> ClientMsgInspectors { get; }
OrderedRegistry<IClientMsgInspector> ClientMsgInspectors { get; }
ReadOnly Property ClientMsgInspectors As OrderedRegistry(Of IClientMsgInspector)
    Get
ReadOnly Property ClientMsgInspectors As OrderedRegistry(Of IClientMsgInspector)
    Get
property OrderedRegistry<IClientMsgInspector^>^ ClientMsgInspectors {
    OrderedRegistry<IClientMsgInspector^>^ get ();
}
property OrderedRegistry<IClientMsgInspector^>^ ClientMsgInspectors {
    OrderedRegistry<IClientMsgInspector^>^ get ();
}
abstract ClientMsgInspectors : OrderedRegistry<IClientMsgInspector> with get
abstract ClientMsgInspectors : OrderedRegistry<IClientMsgInspector> with get

Property Value

Type: OrderedRegistry IClientMsgInspector
See Also
IGlue Interface
IGlue Members
NFX.Glue Namespace


IGlue.DefaultDispatchTimeoutMs Property

IGlue DefaultDispatchTimeoutMs Property NFX Class Library

Specifies default ms timout for call dispatch only

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int DefaultDispatchTimeoutMs { get; set; }
int DefaultDispatchTimeoutMs { get; set; }
Property DefaultDispatchTimeoutMs As Integer
    Get
    Set
Property DefaultDispatchTimeoutMs As Integer
    Get
    Set
property int DefaultDispatchTimeoutMs {
    int get ();
    void set (int value);
}
property int DefaultDispatchTimeoutMs {
    int get ();
    void set (int value);
}
abstract DefaultDispatchTimeoutMs : int with get, set
abstract DefaultDispatchTimeoutMs : int with get, set

Property Value

Type: Online Int32
See Also
IGlue Interface
IGlue Members
NFX.Glue Namespace


IGlue.DefaultTimeoutMs Property

IGlue DefaultTimeoutMs Property NFX Class Library

Specified default ms timeout for the calls

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int DefaultTimeoutMs { get; set; }
int DefaultTimeoutMs { get; set; }
Property DefaultTimeoutMs As Integer
    Get
    Set
Property DefaultTimeoutMs As Integer
    Get
    Set
property int DefaultTimeoutMs {
    int get ();
    void set (int value);
}
property int DefaultTimeoutMs {
    int get ();
    void set (int value);
}
abstract DefaultTimeoutMs : int with get, set
abstract DefaultTimeoutMs : int with get, set

Property Value

Type: Online Int32
See Also
IGlue Interface
IGlue Members
NFX.Glue Namespace


IGlue.Providers Property

IGlue Providers Property NFX Class Library

Performs provider lookup by name

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IRegistry<Provider> Providers { get; }
IRegistry<Provider> Providers { get; }
ReadOnly Property Providers As IRegistry(Of Provider)
    Get
ReadOnly Property Providers As IRegistry(Of Provider)
    Get
property IRegistry<Provider^>^ Providers {
    IRegistry<Provider^>^ get ();
}
property IRegistry<Provider^>^ Providers {
    IRegistry<Provider^>^ get ();
}
abstract Providers : IRegistry<Provider> with get
abstract Providers : IRegistry<Provider> with get

Property Value

Type: IRegistry Provider
See Also
IGlue Interface
IGlue Members
NFX.Glue Namespace


IGlue.ServerInstanceLockTimeoutMs Property

IGlue ServerInstanceLockTimeoutMs Property NFX Class Library

Specifies ms timout for non-threadsafe server instance lock

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int ServerInstanceLockTimeoutMs { get; set; }
int ServerInstanceLockTimeoutMs { get; set; }
Property ServerInstanceLockTimeoutMs As Integer
    Get
    Set
Property ServerInstanceLockTimeoutMs As Integer
    Get
    Set
property int ServerInstanceLockTimeoutMs {
    int get ();
    void set (int value);
}
property int ServerInstanceLockTimeoutMs {
    int get ();
    void set (int value);
}
abstract ServerInstanceLockTimeoutMs : int with get, set
abstract ServerInstanceLockTimeoutMs : int with get, set

Property Value

Type: Online Int32
See Also
IGlue Interface
IGlue Members
NFX.Glue Namespace


IGlue.ServerLogLevel Property

IGlue ServerLogLevel Property NFX Class Library

Determines how much information should be logged about server-side operations

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
MessageType ServerLogLevel { get; set; }
MessageType ServerLogLevel { get; set; }
Property ServerLogLevel As MessageType
    Get
    Set
Property ServerLogLevel As MessageType
    Get
    Set
property MessageType ServerLogLevel {
    MessageType get ();
    void set (MessageType value);
}
property MessageType ServerLogLevel {
    MessageType get ();
    void set (MessageType value);
}
abstract ServerLogLevel : MessageType with get, set
abstract ServerLogLevel : MessageType with get, set

Property Value

Type: MessageType
See Also
IGlue Interface
IGlue Members
NFX.Glue Namespace


IGlue.ServerMsgInspectors Property

IGlue ServerMsgInspectors Property NFX Class Library

Registry of inspectors that deal with server-side messages

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
OrderedRegistry<IServerMsgInspector> ServerMsgInspectors { get; }
OrderedRegistry<IServerMsgInspector> ServerMsgInspectors { get; }
ReadOnly Property ServerMsgInspectors As OrderedRegistry(Of IServerMsgInspector)
    Get
ReadOnly Property ServerMsgInspectors As OrderedRegistry(Of IServerMsgInspector)
    Get
property OrderedRegistry<IServerMsgInspector^>^ ServerMsgInspectors {
    OrderedRegistry<IServerMsgInspector^>^ get ();
}
property OrderedRegistry<IServerMsgInspector^>^ ServerMsgInspectors {
    OrderedRegistry<IServerMsgInspector^>^ get ();
}
abstract ServerMsgInspectors : OrderedRegistry<IServerMsgInspector> with get
abstract ServerMsgInspectors : OrderedRegistry<IServerMsgInspector> with get

Property Value

Type: OrderedRegistry IServerMsgInspector
See Also
IGlue Interface
IGlue Members
NFX.Glue Namespace


IGlue.Servers Property

IGlue Servers Property NFX Class Library

Performs ServerEndPoint lookup by name

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IRegistry<ServerEndPoint> Servers { get; }
IRegistry<ServerEndPoint> Servers { get; }
ReadOnly Property Servers As IRegistry(Of ServerEndPoint)
    Get
ReadOnly Property Servers As IRegistry(Of ServerEndPoint)
    Get
property IRegistry<ServerEndPoint^>^ Servers {
    IRegistry<ServerEndPoint^>^ get ();
}
property IRegistry<ServerEndPoint^>^ Servers {
    IRegistry<ServerEndPoint^>^ get ();
}
abstract Servers : IRegistry<ServerEndPoint> with get
abstract Servers : IRegistry<ServerEndPoint> with get

Property Value

Type: IRegistry ServerEndPoint
See Also
IGlue Interface
IGlue Members
NFX.Glue Namespace


IGlueImplementation Interface

IGlueImplementation Interface NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IGlueImplementation : IGlue,
    IApplicationComponent, ILocalizedTimeProvider, IDisposable, IConfigurable, IInstrumentable,
    IExternallyParameterized
public interface IGlueImplementation : IGlue,
    IApplicationComponent, ILocalizedTimeProvider, IDisposable, IConfigurable, IInstrumentable,
    IExternallyParameterized
Public Interface IGlueImplementation
    Inherits IGlue, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
Public Interface IGlueImplementation
    Inherits IGlue, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
public interface class IGlueImplementation : IGlue,
    IApplicationComponent, ILocalizedTimeProvider, IDisposable, IConfigurable, IInstrumentable,
    IExternallyParameterized
public interface class IGlueImplementation : IGlue,
    IApplicationComponent, ILocalizedTimeProvider, IDisposable, IConfigurable, IInstrumentable,
    IExternallyParameterized
type IGlueImplementation =
    interface
        interface IGlue
        interface IApplicationComponent
        interface ILocalizedTimeProvider
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
type IGlueImplementation =
    interface
        interface IGlue
        interface IApplicationComponent
        interface ILocalizedTimeProvider
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
IGlueImplementation Members
NFX.Glue Namespace


IGlueImplementation Members

IGlueImplementation Members NFX Class Library

The IGlueImplementation type exposes the following members.
Methods
 | Name | Description
Public method | ClientDeliverAsyncResponse |
Public method | ClientDispatchedRequest |
Public method | ClientDispatchingRequest |
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Public method | GetNodeBinding(String) | Retrieves a binding for node and throws if such binding is not known (Inherited from IGlue.)
Public method | GetNodeBinding(Node) | Retrieves a binding for node and throws if such binding is not known (Inherited from IGlue.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | RegisterBinding |
Public method | RegisterProvider |
Public method | RegisterServerEndpoint |
Public method | ServerDispatchRequest | Asynchronously dispatch client request
Public method | ServerHandleRequest | Handle client request synchronously
Public method | ServerHandleRequestFailure | Handle failure of client request synchronously
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | UnregisterBinding |
Public method | UnregisterProvider |
Public method | UnregisterServerEndpoint |
Back to Top
Properties
 | Name | Description
Public property | BindingConfigurations |
Public property | Bindings | Performs binding lookup by name (Inherited from IGlue.)
Public property | BindingsConfigurationSection |
Public property | ClientLogLevel | Determines how much information should be logged about client-side operations (Inherited from IGlue.)
Public property | ClientMsgInspectors | Registry of inspectors that deal with client-side messages (Inherited from IGlue.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | DefaultDispatchTimeoutMs | Specifies default ms timout for call dispatch only (Inherited from IGlue.)
Public property | DefaultTimeoutMs | Specified default ms timeout for the calls (Inherited from IGlue.)
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | GlueConfiguration |
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from ILocalizedTimeProvider.)
Public property | ProviderConfigurations |
Public property | Providers | Performs provider lookup by name (Inherited from IGlue.)
Public property | ProvidersConfigurationSection |
Public property | ServerConfigurations |
Public property | ServerInstanceLockTimeoutMs | Specifies ms timout for non-threadsafe server instance lock (Inherited from IGlue.)
Public property | ServerLogLevel | Determines how much information should be logged about server-side operations (Inherited from IGlue.)
Public property | ServerMsgInspectors | Registry of inspectors that deal with server-side messages (Inherited from IGlue.)
Public property | Servers | Performs ServerEndPoint lookup by name (Inherited from IGlue.)
Public property | ServersConfigurationSection |
Public property | TimeLocation | Returns the location (Inherited from ILocalizedTimeProvider.)
Back to Top
See Also
IGlueImplementation Interface
NFX.Glue Namespace


IGlueImplementation Methods

IGlueImplementation Methods NFX Class Library

The IGlueImplementation type exposes the following members.
Methods
 | Name | Description
Public method | ClientDeliverAsyncResponse |
Public method | ClientDispatchedRequest |
Public method | ClientDispatchingRequest |
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Public method | GetNodeBinding(String) | Retrieves a binding for node and throws if such binding is not known (Inherited from IGlue.)
Public method | GetNodeBinding(Node) | Retrieves a binding for node and throws if such binding is not known (Inherited from IGlue.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | RegisterBinding |
Public method | RegisterProvider |
Public method | RegisterServerEndpoint |
Public method | ServerDispatchRequest | Asynchronously dispatch client request
Public method | ServerHandleRequest | Handle client request synchronously
Public method | ServerHandleRequestFailure | Handle failure of client request synchronously
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | UnregisterBinding |
Public method | UnregisterProvider |
Public method | UnregisterServerEndpoint |
Back to Top
See Also
IGlueImplementation Interface
NFX.Glue Namespace


IGlueImplementation.ClientDeliverAsyncResponse Method

IGlueImplementation ClientDeliverAsyncResponse Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ClientDeliverAsyncResponse(
    ResponseMsg response
)
void ClientDeliverAsyncResponse(
    ResponseMsg response
)
Sub ClientDeliverAsyncResponse (
    response As ResponseMsg
)
Sub ClientDeliverAsyncResponse (
    response As ResponseMsg
)
void ClientDeliverAsyncResponse(
    ResponseMsg^ response
)
void ClientDeliverAsyncResponse(
    ResponseMsg^ response
)
abstract ClientDeliverAsyncResponse :
        response : ResponseMsg -> unit
abstract ClientDeliverAsyncResponse :
        response : ResponseMsg -> unit

Parameters

response
Type: NFX.Glue.Protocol ResponseMsg
See Also
IGlueImplementation Interface
IGlueImplementation Members
NFX.Glue Namespace


IGlueImplementation.ClientDispatchedRequest Method

IGlueImplementation ClientDispatchedRequest Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ClientDispatchedRequest(
    ClientEndPoint client,
    RequestMsg request,
    CallSlot callSlot
)
void ClientDispatchedRequest(
    ClientEndPoint client,
    RequestMsg request,
    CallSlot callSlot
)
Sub ClientDispatchedRequest (
    client As ClientEndPoint,
    request As RequestMsg,
    callSlot As CallSlot
)
Sub ClientDispatchedRequest (
    client As ClientEndPoint,
    request As RequestMsg,
    callSlot As CallSlot
)
void ClientDispatchedRequest(
    ClientEndPoint^ client,
    RequestMsg^ request,
    CallSlot^ callSlot
)
void ClientDispatchedRequest(
    ClientEndPoint^ client,
    RequestMsg^ request,
    CallSlot^ callSlot
)
abstract ClientDispatchedRequest :
        client : ClientEndPoint *
        request : RequestMsg *
        callSlot : CallSlot -> unit
abstract ClientDispatchedRequest :
        client : ClientEndPoint *
        request : RequestMsg *
        callSlot : CallSlot -> unit

Parameters

client
Type: NFX.Glue ClientEndPoint
request
Type: NFX.Glue.Protocol RequestMsg
callSlot
Type: NFX.Glue CallSlot
See Also
IGlueImplementation Interface
IGlueImplementation Members
NFX.Glue Namespace


IGlueImplementation.ClientDispatchingRequest Method

IGlueImplementation ClientDispatchingRequest Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
RequestMsg ClientDispatchingRequest(
    ClientEndPoint client,
    RequestMsg request
)
RequestMsg ClientDispatchingRequest(
    ClientEndPoint client,
    RequestMsg request
)
Function ClientDispatchingRequest (
    client As ClientEndPoint,
    request As RequestMsg
) As RequestMsg
Function ClientDispatchingRequest (
    client As ClientEndPoint,
    request As RequestMsg
) As RequestMsg
RequestMsg^ ClientDispatchingRequest(
    ClientEndPoint^ client,
    RequestMsg^ request
)
RequestMsg^ ClientDispatchingRequest(
    ClientEndPoint^ client,
    RequestMsg^ request
)
abstract ClientDispatchingRequest :
        client : ClientEndPoint *
        request : RequestMsg -> RequestMsg
abstract ClientDispatchingRequest :
        client : ClientEndPoint *
        request : RequestMsg -> RequestMsg

Parameters

client
Type: NFX.Glue ClientEndPoint
request
Type: NFX.Glue.Protocol RequestMsg

Return Value

Type: RequestMsg
See Also
IGlueImplementation Interface
IGlueImplementation Members
NFX.Glue Namespace


IGlueImplementation.RegisterBinding Method

IGlueImplementation RegisterBinding Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void RegisterBinding(
    Binding b
)
void RegisterBinding(
    Binding b
)
Sub RegisterBinding (
    b As Binding
)
Sub RegisterBinding (
    b As Binding
)
void RegisterBinding(
    Binding^ b
)
void RegisterBinding(
    Binding^ b
)
abstract RegisterBinding :
        b : Binding -> unit
abstract RegisterBinding :
        b : Binding -> unit

Parameters

b
Type: NFX.Glue Binding
See Also
IGlueImplementation Interface
IGlueImplementation Members
NFX.Glue Namespace


IGlueImplementation.RegisterProvider Method

IGlueImplementation RegisterProvider Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void RegisterProvider(
    Provider p
)
void RegisterProvider(
    Provider p
)
Sub RegisterProvider (
    p As Provider
)
Sub RegisterProvider (
    p As Provider
)
void RegisterProvider(
    Provider^ p
)
void RegisterProvider(
    Provider^ p
)
abstract RegisterProvider :
        p : Provider -> unit
abstract RegisterProvider :
        p : Provider -> unit

Parameters

p
Type: NFX.Glue Provider
See Also
IGlueImplementation Interface
IGlueImplementation Members
NFX.Glue Namespace


IGlueImplementation.RegisterServerEndpoint Method

IGlueImplementation RegisterServerEndpoint Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void RegisterServerEndpoint(
    ServerEndPoint ep
)
void RegisterServerEndpoint(
    ServerEndPoint ep
)
Sub RegisterServerEndpoint (
    ep As ServerEndPoint
)
Sub RegisterServerEndpoint (
    ep As ServerEndPoint
)
void RegisterServerEndpoint(
    ServerEndPoint^ ep
)
void RegisterServerEndpoint(
    ServerEndPoint^ ep
)
abstract RegisterServerEndpoint :
        ep : ServerEndPoint -> unit
abstract RegisterServerEndpoint :
        ep : ServerEndPoint -> unit

Parameters

ep
Type: NFX.Glue ServerEndPoint
See Also
IGlueImplementation Interface
IGlueImplementation Members
NFX.Glue Namespace


IGlueImplementation.ServerDispatchRequest Method

IGlueImplementation ServerDispatchRequest Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Asynchronously dispatch client request

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ServerDispatchRequest(
    RequestMsg request
)
void ServerDispatchRequest(
    RequestMsg request
)
Sub ServerDispatchRequest (
    request As RequestMsg
)
Sub ServerDispatchRequest (
    request As RequestMsg
)
void ServerDispatchRequest(
    RequestMsg^ request
)
void ServerDispatchRequest(
    RequestMsg^ request
)
abstract ServerDispatchRequest :
        request : RequestMsg -> unit
abstract ServerDispatchRequest :
        request : RequestMsg -> unit

Parameters

request
Type: NFX.Glue.Protocol RequestMsg
See Also
IGlueImplementation Interface
IGlueImplementation Members
NFX.Glue Namespace


IGlueImplementation.ServerHandleRequest Method

IGlueImplementation ServerHandleRequest Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Handle client request synchronously

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ResponseMsg ServerHandleRequest(
    RequestMsg request
)
ResponseMsg ServerHandleRequest(
    RequestMsg request
)
Function ServerHandleRequest (
    request As RequestMsg
) As ResponseMsg
Function ServerHandleRequest (
    request As RequestMsg
) As ResponseMsg
ResponseMsg^ ServerHandleRequest(
    RequestMsg^ request
)
ResponseMsg^ ServerHandleRequest(
    RequestMsg^ request
)
abstract ServerHandleRequest :
        request : RequestMsg -> ResponseMsg
abstract ServerHandleRequest :
        request : RequestMsg -> ResponseMsg

Parameters

request
Type: NFX.Glue.Protocol RequestMsg

Return Value

Type: ResponseMsg
See Also
IGlueImplementation Interface
IGlueImplementation Members
NFX.Glue Namespace


IGlueImplementation.ServerHandleRequestFailure Method

IGlueImplementation ServerHandleRequestFailure Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Handle failure of client request synchronously

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ResponseMsg ServerHandleRequestFailure(
    FID reqID,
    bool oneWay,
    Exception failure,
    Object bindingSpecCtx
)
ResponseMsg ServerHandleRequestFailure(
    FID reqID,
    bool oneWay,
    Exception failure,
    Object bindingSpecCtx
)
Function ServerHandleRequestFailure (
    reqID As FID,
    oneWay As Boolean,
    failure As Exception,
    bindingSpecCtx As Object
) As ResponseMsg
Function ServerHandleRequestFailure (
    reqID As FID,
    oneWay As Boolean,
    failure As Exception,
    bindingSpecCtx As Object
) As ResponseMsg
ResponseMsg^ ServerHandleRequestFailure(
    FID reqID,
    bool oneWay,
    Exception^ failure,
    Object^ bindingSpecCtx
)
ResponseMsg^ ServerHandleRequestFailure(
    FID reqID,
    bool oneWay,
    Exception^ failure,
    Object^ bindingSpecCtx
)
abstract ServerHandleRequestFailure :
        reqID : FID *
        oneWay : bool *
        failure : Exception *
        bindingSpecCtx : Object -> ResponseMsg
abstract ServerHandleRequestFailure :
        reqID : FID *
        oneWay : bool *
        failure : Exception *
        bindingSpecCtx : Object -> ResponseMsg

Parameters

reqID
Type: NFX FID
oneWay
Type: Online System Boolean
failure
Type: Online System Exception
bindingSpecCtx
Type: Online System Object

Return Value

Type: ResponseMsg
See Also
IGlueImplementation Interface
IGlueImplementation Members
NFX.Glue Namespace


IGlueImplementation.UnregisterBinding Method

IGlueImplementation UnregisterBinding Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void UnregisterBinding(
    Binding b
)
void UnregisterBinding(
    Binding b
)
Sub UnregisterBinding (
    b As Binding
)
Sub UnregisterBinding (
    b As Binding
)
void UnregisterBinding(
    Binding^ b
)
void UnregisterBinding(
    Binding^ b
)
abstract UnregisterBinding :
        b : Binding -> unit
abstract UnregisterBinding :
        b : Binding -> unit

Parameters

b
Type: NFX.Glue Binding
See Also
IGlueImplementation Interface
IGlueImplementation Members
NFX.Glue Namespace


IGlueImplementation.UnregisterProvider Method

IGlueImplementation UnregisterProvider Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void UnregisterProvider(
    Provider p
)
void UnregisterProvider(
    Provider p
)
Sub UnregisterProvider (
    p As Provider
)
Sub UnregisterProvider (
    p As Provider
)
void UnregisterProvider(
    Provider^ p
)
void UnregisterProvider(
    Provider^ p
)
abstract UnregisterProvider :
        p : Provider -> unit
abstract UnregisterProvider :
        p : Provider -> unit

Parameters

p
Type: NFX.Glue Provider
See Also
IGlueImplementation Interface
IGlueImplementation Members
NFX.Glue Namespace


IGlueImplementation.UnregisterServerEndpoint Method

IGlueImplementation UnregisterServerEndpoint Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void UnregisterServerEndpoint(
    ServerEndPoint ep
)
void UnregisterServerEndpoint(
    ServerEndPoint ep
)
Sub UnregisterServerEndpoint (
    ep As ServerEndPoint
)
Sub UnregisterServerEndpoint (
    ep As ServerEndPoint
)
void UnregisterServerEndpoint(
    ServerEndPoint^ ep
)
void UnregisterServerEndpoint(
    ServerEndPoint^ ep
)
abstract UnregisterServerEndpoint :
        ep : ServerEndPoint -> unit
abstract UnregisterServerEndpoint :
        ep : ServerEndPoint -> unit

Parameters

ep
Type: NFX.Glue ServerEndPoint
See Also
IGlueImplementation Interface
IGlueImplementation Members
NFX.Glue Namespace


IGlueImplementation Properties

IGlueImplementation Properties NFX Class Library

The IGlueImplementation type exposes the following members.
Properties
 | Name | Description
Public property | BindingConfigurations |
Public property | Bindings | Performs binding lookup by name (Inherited from IGlue.)
Public property | BindingsConfigurationSection |
Public property | ClientLogLevel | Determines how much information should be logged about client-side operations (Inherited from IGlue.)
Public property | ClientMsgInspectors | Registry of inspectors that deal with client-side messages (Inherited from IGlue.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | DefaultDispatchTimeoutMs | Specifies default ms timout for call dispatch only (Inherited from IGlue.)
Public property | DefaultTimeoutMs | Specified default ms timeout for the calls (Inherited from IGlue.)
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | GlueConfiguration |
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from ILocalizedTimeProvider.)
Public property | ProviderConfigurations |
Public property | Providers | Performs provider lookup by name (Inherited from IGlue.)
Public property | ProvidersConfigurationSection |
Public property | ServerConfigurations |
Public property | ServerInstanceLockTimeoutMs | Specifies ms timout for non-threadsafe server instance lock (Inherited from IGlue.)
Public property | ServerLogLevel | Determines how much information should be logged about server-side operations (Inherited from IGlue.)
Public property | ServerMsgInspectors | Registry of inspectors that deal with server-side messages (Inherited from IGlue.)
Public property | Servers | Performs ServerEndPoint lookup by name (Inherited from IGlue.)
Public property | ServersConfigurationSection |
Public property | TimeLocation | Returns the location (Inherited from ILocalizedTimeProvider.)
Back to Top
See Also
IGlueImplementation Interface
NFX.Glue Namespace


IGlueImplementation.BindingConfigurations Property

IGlueImplementation BindingConfigurations Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<IConfigSectionNode> BindingConfigurations { get; }
IEnumerable<IConfigSectionNode> BindingConfigurations { get; }
ReadOnly Property BindingConfigurations As IEnumerable(Of IConfigSectionNode)
    Get
ReadOnly Property BindingConfigurations As IEnumerable(Of IConfigSectionNode)
    Get
property IEnumerable<IConfigSectionNode^>^ BindingConfigurations {
    IEnumerable<IConfigSectionNode^>^ get ();
}
property IEnumerable<IConfigSectionNode^>^ BindingConfigurations {
    IEnumerable<IConfigSectionNode^>^ get ();
}
abstract BindingConfigurations : IEnumerable<IConfigSectionNode> with get
abstract BindingConfigurations : IEnumerable<IConfigSectionNode> with get

Property Value

Type: Online IEnumerable IConfigSectionNode
See Also
IGlueImplementation Interface
IGlueImplementation Members
NFX.Glue Namespace


IGlueImplementation.BindingsConfigurationSection Property

IGlueImplementation BindingsConfigurationSection Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IConfigSectionNode BindingsConfigurationSection { get; }
IConfigSectionNode BindingsConfigurationSection { get; }
ReadOnly Property BindingsConfigurationSection As IConfigSectionNode
    Get
ReadOnly Property BindingsConfigurationSection As IConfigSectionNode
    Get
property IConfigSectionNode^ BindingsConfigurationSection {
    IConfigSectionNode^ get ();
}
property IConfigSectionNode^ BindingsConfigurationSection {
    IConfigSectionNode^ get ();
}
abstract BindingsConfigurationSection : IConfigSectionNode with get
abstract BindingsConfigurationSection : IConfigSectionNode with get

Property Value

Type: IConfigSectionNode
See Also
IGlueImplementation Interface
IGlueImplementation Members
NFX.Glue Namespace


IGlueImplementation.GlueConfiguration Property

IGlueImplementation GlueConfiguration Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IConfigSectionNode GlueConfiguration { get; }
IConfigSectionNode GlueConfiguration { get; }
ReadOnly Property GlueConfiguration As IConfigSectionNode
    Get
ReadOnly Property GlueConfiguration As IConfigSectionNode
    Get
property IConfigSectionNode^ GlueConfiguration {
    IConfigSectionNode^ get ();
}
property IConfigSectionNode^ GlueConfiguration {
    IConfigSectionNode^ get ();
}
abstract GlueConfiguration : IConfigSectionNode with get
abstract GlueConfiguration : IConfigSectionNode with get

Property Value

Type: IConfigSectionNode
See Also
IGlueImplementation Interface
IGlueImplementation Members
NFX.Glue Namespace


IGlueImplementation.ProviderConfigurations Property

IGlueImplementation ProviderConfigurations Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<IConfigSectionNode> ProviderConfigurations { get; }
IEnumerable<IConfigSectionNode> ProviderConfigurations { get; }
ReadOnly Property ProviderConfigurations As IEnumerable(Of IConfigSectionNode)
    Get
ReadOnly Property ProviderConfigurations As IEnumerable(Of IConfigSectionNode)
    Get
property IEnumerable<IConfigSectionNode^>^ ProviderConfigurations {
    IEnumerable<IConfigSectionNode^>^ get ();
}
property IEnumerable<IConfigSectionNode^>^ ProviderConfigurations {
    IEnumerable<IConfigSectionNode^>^ get ();
}
abstract ProviderConfigurations : IEnumerable<IConfigSectionNode> with get
abstract ProviderConfigurations : IEnumerable<IConfigSectionNode> with get

Property Value

Type: Online IEnumerable IConfigSectionNode
See Also
IGlueImplementation Interface
IGlueImplementation Members
NFX.Glue Namespace


IGlueImplementation.ProvidersConfigurationSection Property

IGlueImplementation ProvidersConfigurationSection Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IConfigSectionNode ProvidersConfigurationSection { get; }
IConfigSectionNode ProvidersConfigurationSection { get; }
ReadOnly Property ProvidersConfigurationSection As IConfigSectionNode
    Get
ReadOnly Property ProvidersConfigurationSection As IConfigSectionNode
    Get
property IConfigSectionNode^ ProvidersConfigurationSection {
    IConfigSectionNode^ get ();
}
property IConfigSectionNode^ ProvidersConfigurationSection {
    IConfigSectionNode^ get ();
}
abstract ProvidersConfigurationSection : IConfigSectionNode with get
abstract ProvidersConfigurationSection : IConfigSectionNode with get

Property Value

Type: IConfigSectionNode
See Also
IGlueImplementation Interface
IGlueImplementation Members
NFX.Glue Namespace


IGlueImplementation.ServerConfigurations Property

IGlueImplementation ServerConfigurations Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<IConfigSectionNode> ServerConfigurations { get; }
IEnumerable<IConfigSectionNode> ServerConfigurations { get; }
ReadOnly Property ServerConfigurations As IEnumerable(Of IConfigSectionNode)
    Get
ReadOnly Property ServerConfigurations As IEnumerable(Of IConfigSectionNode)
    Get
property IEnumerable<IConfigSectionNode^>^ ServerConfigurations {
    IEnumerable<IConfigSectionNode^>^ get ();
}
property IEnumerable<IConfigSectionNode^>^ ServerConfigurations {
    IEnumerable<IConfigSectionNode^>^ get ();
}
abstract ServerConfigurations : IEnumerable<IConfigSectionNode> with get
abstract ServerConfigurations : IEnumerable<IConfigSectionNode> with get

Property Value

Type: Online IEnumerable IConfigSectionNode
See Also
IGlueImplementation Interface
IGlueImplementation Members
NFX.Glue Namespace


IGlueImplementation.ServersConfigurationSection Property

IGlueImplementation ServersConfigurationSection Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IConfigSectionNode ServersConfigurationSection { get; }
IConfigSectionNode ServersConfigurationSection { get; }
ReadOnly Property ServersConfigurationSection As IConfigSectionNode
    Get
ReadOnly Property ServersConfigurationSection As IConfigSectionNode
    Get
property IConfigSectionNode^ ServersConfigurationSection {
    IConfigSectionNode^ get ();
}
property IConfigSectionNode^ ServersConfigurationSection {
    IConfigSectionNode^ get ();
}
abstract ServersConfigurationSection : IConfigSectionNode with get
abstract ServersConfigurationSection : IConfigSectionNode with get

Property Value

Type: IConfigSectionNode
See Also
IGlueImplementation Interface
IGlueImplementation Members
NFX.Glue Namespace


IMsgInspector Interface

IMsgInspector Interface NFX Class Library

Denotes an entity that can inspect messages

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IMsgInspector : INamed,
    IOrdered, IConfigurable
public interface IMsgInspector : INamed,
    IOrdered, IConfigurable
Public Interface IMsgInspector
    Inherits INamed, IOrdered, IConfigurable
Public Interface IMsgInspector
    Inherits INamed, IOrdered, IConfigurable
public interface class IMsgInspector : INamed,
    IOrdered, IConfigurable
public interface class IMsgInspector : INamed,
    IOrdered, IConfigurable
type IMsgInspector =
    interface
        interface INamed
        interface IOrdered
        interface IConfigurable
    end
type IMsgInspector =
    interface
        interface INamed
        interface IOrdered
        interface IConfigurable
    end
See Also
IMsgInspector Members
NFX.Glue Namespace


IMsgInspector Members

IMsgInspector Members NFX Class Library

The IMsgInspector type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Back to Top
Properties
 | Name | Description
Public property | Name | (Inherited from INamed.)
Public property | Order | (Inherited from IOrdered.)
Back to Top
See Also
IMsgInspector Interface
NFX.Glue Namespace


IMsgInspector Methods

IMsgInspector Methods NFX Class Library

The IMsgInspector type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Back to Top
See Also
IMsgInspector Interface
NFX.Glue Namespace


IMsgInspector Properties

IMsgInspector Properties NFX Class Library

The IMsgInspector type exposes the following members.
Properties
 | Name | Description
Public property | Name | (Inherited from INamed.)
Public property | Order | (Inherited from IOrdered.)
Back to Top
See Also
IMsgInspector Interface
NFX.Glue Namespace


InvalidGlueOperationException Class

InvalidGlueOperationException Class NFX Class Library

Base exception thrown by the Glue framework when some operations are invoked that do not apply
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Glue GlueException
NFX.Glue InvalidGlueOperationException

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class InvalidGlueOperationException : GlueException
[SerializableAttribute]
public class InvalidGlueOperationException : GlueException
<SerializableAttribute>
Public Class InvalidGlueOperationException
    Inherits GlueException
<SerializableAttribute>
Public Class InvalidGlueOperationException
    Inherits GlueException
[SerializableAttribute]
public ref class InvalidGlueOperationException : public GlueException
[SerializableAttribute]
public ref class InvalidGlueOperationException : public GlueException
[<SerializableAttribute>]
type InvalidGlueOperationException =
    class
        inherit GlueException
    end
[<SerializableAttribute>]
type InvalidGlueOperationException =
    class
        inherit GlueException
    end
See Also
InvalidGlueOperationException Members
NFX.Glue Namespace


InvalidGlueOperationException Members

InvalidGlueOperationException Members NFX Class Library

The InvalidGlueOperationException type exposes the following members.
Constructors
 | Name | Description
Public method | InvalidGlueOperationException | Initializes a new instance of the InvalidGlueOperationException class
Public method | InvalidGlueOperationException(String) | Initializes a new instance of the InvalidGlueOperationException class
Protected method | InvalidGlueOperationException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidGlueOperationException class
Public method | InvalidGlueOperationException(String, Exception) | Initializes a new instance of the InvalidGlueOperationException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
InvalidGlueOperationException Class
NFX.Glue Namespace


InvalidGlueOperationException Constructor

InvalidGlueOperationException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | InvalidGlueOperationException | Initializes a new instance of the InvalidGlueOperationException class
Public method | InvalidGlueOperationException(String) | Initializes a new instance of the InvalidGlueOperationException class
Protected method | InvalidGlueOperationException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidGlueOperationException class
Public method | InvalidGlueOperationException(String, Exception) | Initializes a new instance of the InvalidGlueOperationException class
Back to Top
See Also
InvalidGlueOperationException Class
InvalidGlueOperationException Members
NFX.Glue Namespace


InvalidGlueOperationException Constructor

InvalidGlueOperationException Constructor NFX Class Library

Initializes a new instance of the InvalidGlueOperationException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InvalidGlueOperationException()
public InvalidGlueOperationException()
Public Sub New
Public Sub New
public:
InvalidGlueOperationException()
public:
InvalidGlueOperationException()
new : unit -> InvalidGlueOperationException
new : unit -> InvalidGlueOperationException
See Also
InvalidGlueOperationException Class
InvalidGlueOperationException Members
InvalidGlueOperationException Overload
NFX.Glue Namespace


InvalidGlueOperationException Constructor (String)

InvalidGlueOperationException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the InvalidGlueOperationException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InvalidGlueOperationException(
    string message
)
public InvalidGlueOperationException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
InvalidGlueOperationException(
    String^ message
)
public:
InvalidGlueOperationException(
    String^ message
)
new :
        message : string -> InvalidGlueOperationException
new :
        message : string -> InvalidGlueOperationException

Parameters

message
Type: Online System String
See Also
InvalidGlueOperationException Class
InvalidGlueOperationException Members
InvalidGlueOperationException Overload
NFX.Glue Namespace


InvalidGlueOperationException Constructor (SerializationInfo, StreamingContext)

InvalidGlueOperationException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the InvalidGlueOperationException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected InvalidGlueOperationException(
    SerializationInfo info,
    StreamingContext context
)
protected InvalidGlueOperationException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
InvalidGlueOperationException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
InvalidGlueOperationException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> InvalidGlueOperationException
new :
        info : SerializationInfo *
        context : StreamingContext -> InvalidGlueOperationException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
InvalidGlueOperationException Class
InvalidGlueOperationException Members
InvalidGlueOperationException Overload
NFX.Glue Namespace


InvalidGlueOperationException Constructor (String, Exception)

InvalidGlueOperationException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the InvalidGlueOperationException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InvalidGlueOperationException(
    string message,
    Exception inner
)
public InvalidGlueOperationException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
InvalidGlueOperationException(
    String^ message,
    Exception^ inner
)
public:
InvalidGlueOperationException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> InvalidGlueOperationException
new :
        message : string *
        inner : Exception -> InvalidGlueOperationException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
InvalidGlueOperationException Class
InvalidGlueOperationException Members
InvalidGlueOperationException Overload
NFX.Glue Namespace


InvalidGlueOperationException Methods

InvalidGlueOperationException Methods NFX Class Library

The InvalidGlueOperationException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
InvalidGlueOperationException Class
NFX.Glue Namespace


InvalidGlueOperationException Properties

InvalidGlueOperationException Properties NFX Class Library

The InvalidGlueOperationException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
InvalidGlueOperationException Class
NFX.Glue Namespace


InvalidGlueOperationException Events

InvalidGlueOperationException Events NFX Class Library

The InvalidGlueOperationException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
InvalidGlueOperationException Class
NFX.Glue Namespace


IServerMsgInspector Interface

IServerMsgInspector Interface NFX Class Library

Inspects messages on the server side. ServerInspectors may be registered on ServerEndPoint, Binding or Glue levels

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IServerMsgInspector : IMsgInspector,
    INamed, IOrdered, IConfigurable
public interface IServerMsgInspector : IMsgInspector,
    INamed, IOrdered, IConfigurable
Public Interface IServerMsgInspector
    Inherits IMsgInspector, INamed, IOrdered, IConfigurable
Public Interface IServerMsgInspector
    Inherits IMsgInspector, INamed, IOrdered, IConfigurable
public interface class IServerMsgInspector : IMsgInspector,
    INamed, IOrdered, IConfigurable
public interface class IServerMsgInspector : IMsgInspector,
    INamed, IOrdered, IConfigurable
type IServerMsgInspector =
    interface
        interface IMsgInspector
        interface INamed
        interface IOrdered
        interface IConfigurable
    end
type IServerMsgInspector =
    interface
        interface IMsgInspector
        interface INamed
        interface IOrdered
        interface IConfigurable
    end
See Also
IServerMsgInspector Members
NFX.Glue Namespace


IServerMsgInspector Members

IServerMsgInspector Members NFX Class Library

The IServerMsgInspector type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | ServerDispatchRequest | Intercepts RequestMsg that arrived from particular ServerEndPoint and optionaly allows to change it
Public method | ServerReturnResponse | Intercepts ResponseMsg generated by server before it is sent to client and optionaly allows to change it
Back to Top
Properties
 | Name | Description
Public property | Name | (Inherited from INamed.)
Public property | Order | (Inherited from IOrdered.)
Back to Top
See Also
IServerMsgInspector Interface
NFX.Glue Namespace


IServerMsgInspector Methods

IServerMsgInspector Methods NFX Class Library

The IServerMsgInspector type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | ServerDispatchRequest | Intercepts RequestMsg that arrived from particular ServerEndPoint and optionaly allows to change it
Public method | ServerReturnResponse | Intercepts ResponseMsg generated by server before it is sent to client and optionaly allows to change it
Back to Top
See Also
IServerMsgInspector Interface
NFX.Glue Namespace


IServerMsgInspector.ServerDispatchRequest Method

IServerMsgInspector ServerDispatchRequest Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Intercepts RequestMsg that arrived from particular ServerEndPoint and optionaly allows to change it

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
RequestMsg ServerDispatchRequest(
    ServerEndPoint endpoint,
    RequestMsg request
)
RequestMsg ServerDispatchRequest(
    ServerEndPoint endpoint,
    RequestMsg request
)
Function ServerDispatchRequest (
    endpoint As ServerEndPoint,
    request As RequestMsg
) As RequestMsg
Function ServerDispatchRequest (
    endpoint As ServerEndPoint,
    request As RequestMsg
) As RequestMsg
RequestMsg^ ServerDispatchRequest(
    ServerEndPoint^ endpoint,
    RequestMsg^ request
)
RequestMsg^ ServerDispatchRequest(
    ServerEndPoint^ endpoint,
    RequestMsg^ request
)
abstract ServerDispatchRequest :
        endpoint : ServerEndPoint *
        request : RequestMsg -> RequestMsg
abstract ServerDispatchRequest :
        endpoint : ServerEndPoint *
        request : RequestMsg -> RequestMsg

Parameters

endpoint
Type: NFX.Glue ServerEndPoint
request
Type: NFX.Glue.Protocol RequestMsg

Return Value

Type: RequestMsg
See Also
IServerMsgInspector Interface
IServerMsgInspector Members
NFX.Glue Namespace


IServerMsgInspector.ServerReturnResponse Method

IServerMsgInspector ServerReturnResponse Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Intercepts ResponseMsg generated by server before it is sent to client and optionaly allows to change it

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ResponseMsg ServerReturnResponse(
    ServerEndPoint endpoint,
    RequestMsg request,
    ResponseMsg response
)
ResponseMsg ServerReturnResponse(
    ServerEndPoint endpoint,
    RequestMsg request,
    ResponseMsg response
)
Function ServerReturnResponse (
    endpoint As ServerEndPoint,
    request As RequestMsg,
    response As ResponseMsg
) As ResponseMsg
Function ServerReturnResponse (
    endpoint As ServerEndPoint,
    request As RequestMsg,
    response As ResponseMsg
) As ResponseMsg
ResponseMsg^ ServerReturnResponse(
    ServerEndPoint^ endpoint,
    RequestMsg^ request,
    ResponseMsg^ response
)
ResponseMsg^ ServerReturnResponse(
    ServerEndPoint^ endpoint,
    RequestMsg^ request,
    ResponseMsg^ response
)
abstract ServerReturnResponse :
        endpoint : ServerEndPoint *
        request : RequestMsg *
        response : ResponseMsg -> ResponseMsg
abstract ServerReturnResponse :
        endpoint : ServerEndPoint *
        request : RequestMsg *
        response : ResponseMsg -> ResponseMsg

Parameters

endpoint
Type: NFX.Glue ServerEndPoint
request
Type: NFX.Glue.Protocol RequestMsg
response
Type: NFX.Glue.Protocol ResponseMsg

Return Value

Type: ResponseMsg
See Also
IServerMsgInspector Interface
IServerMsgInspector Members
NFX.Glue Namespace


IServerMsgInspector Properties

IServerMsgInspector Properties NFX Class Library

The IServerMsgInspector type exposes the following members.
Properties
 | Name | Description
Public property | Name | (Inherited from INamed.)
Public property | Order | (Inherited from IOrdered.)
Back to Top
See Also
IServerMsgInspector Interface
NFX.Glue Namespace


LifeCycleAttribute Class

LifeCycleAttribute Class NFX Class Library

Specifies the instance mode and timeout values for server classes that implement the decorated contract. If server class does not support state then timeout is ignored
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.Glue LifeCycleAttribute

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.Interface, Inherited = false, AllowMultiple = false)]
public class LifeCycleAttribute : Attribute
[AttributeUsageAttribute(AttributeTargets.Interface, Inherited = false, AllowMultiple = false)]
public class LifeCycleAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Interface, Inherited := false, AllowMultiple := false)>
Public Class LifeCycleAttribute
    Inherits Attribute
<AttributeUsageAttribute(AttributeTargets.Interface, Inherited := false, AllowMultiple := false)>
Public Class LifeCycleAttribute
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Interface, Inherited = false, AllowMultiple = false)]
public ref class LifeCycleAttribute : public Attribute
[AttributeUsageAttribute(AttributeTargets::Interface, Inherited = false, AllowMultiple = false)]
public ref class LifeCycleAttribute : public Attribute
[<AttributeUsageAttribute(AttributeTargets.Interface, Inherited = false, AllowMultiple = false)>]
type LifeCycleAttribute =
    class
        inherit Attribute
    end
[<AttributeUsageAttribute(AttributeTargets.Interface, Inherited = false, AllowMultiple = false)>]
type LifeCycleAttribute =
    class
        inherit Attribute
    end
See Also
LifeCycleAttribute Members
NFX.Glue Namespace


LifeCycleAttribute Members

LifeCycleAttribute Members NFX Class Library

The LifeCycleAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | LifeCycleAttribute | Initializes a new instance of the LifeCycleAttribute class
Public method | LifeCycleAttribute(ServerInstanceMode) | Initializes a new instance of the LifeCycleAttribute class
Public method | LifeCycleAttribute(ServerInstanceMode, Int32) | Initializes a new instance of the LifeCycleAttribute class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Mode |
Public property | TimeoutMs |
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
LifeCycleAttribute Class
NFX.Glue Namespace


LifeCycleAttribute Constructor

LifeCycleAttribute Constructor NFX Class Library

Overload List
 | Name | Description
Public method | LifeCycleAttribute | Initializes a new instance of the LifeCycleAttribute class
Public method | LifeCycleAttribute(ServerInstanceMode) | Initializes a new instance of the LifeCycleAttribute class
Public method | LifeCycleAttribute(ServerInstanceMode, Int32) | Initializes a new instance of the LifeCycleAttribute class
Back to Top
See Also
LifeCycleAttribute Class
LifeCycleAttribute Members
NFX.Glue Namespace


LifeCycleAttribute Constructor

LifeCycleAttribute Constructor NFX Class Library

Initializes a new instance of the LifeCycleAttribute class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LifeCycleAttribute()
public LifeCycleAttribute()
Public Sub New
Public Sub New
public:
LifeCycleAttribute()
public:
LifeCycleAttribute()
new : unit -> LifeCycleAttribute
new : unit -> LifeCycleAttribute
See Also
LifeCycleAttribute Class
LifeCycleAttribute Members
LifeCycleAttribute Overload
NFX.Glue Namespace


LifeCycleAttribute Constructor (ServerInstanceMode)

LifeCycleAttribute Constructor (ServerInstanceMode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LifeCycleAttribute class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LifeCycleAttribute(
    ServerInstanceMode mode
)
public LifeCycleAttribute(
    ServerInstanceMode mode
)
Public Sub New (
    mode As ServerInstanceMode
)
Public Sub New (
    mode As ServerInstanceMode
)
public:
LifeCycleAttribute(
    ServerInstanceMode mode
)
public:
LifeCycleAttribute(
    ServerInstanceMode mode
)
new :
        mode : ServerInstanceMode -> LifeCycleAttribute
new :
        mode : ServerInstanceMode -> LifeCycleAttribute

Parameters

mode
Type: NFX.Glue ServerInstanceMode
See Also
LifeCycleAttribute Class
LifeCycleAttribute Members
LifeCycleAttribute Overload
NFX.Glue Namespace


LifeCycleAttribute Constructor (ServerInstanceMode, Int32)

LifeCycleAttribute Constructor (ServerInstanceMode, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LifeCycleAttribute class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LifeCycleAttribute(
    ServerInstanceMode mode,
    int timeoutMs
)
public LifeCycleAttribute(
    ServerInstanceMode mode,
    int timeoutMs
)
Public Sub New (
    mode As ServerInstanceMode,
    timeoutMs As Integer
)
Public Sub New (
    mode As ServerInstanceMode,
    timeoutMs As Integer
)
public:
LifeCycleAttribute(
    ServerInstanceMode mode,
    int timeoutMs
)
public:
LifeCycleAttribute(
    ServerInstanceMode mode,
    int timeoutMs
)
new :
        mode : ServerInstanceMode *
        timeoutMs : int -> LifeCycleAttribute
new :
        mode : ServerInstanceMode *
        timeoutMs : int -> LifeCycleAttribute

Parameters

mode
Type: NFX.Glue ServerInstanceMode
timeoutMs
Type: Online System Int32
See Also
LifeCycleAttribute Class
LifeCycleAttribute Members
LifeCycleAttribute Overload
NFX.Glue Namespace


LifeCycleAttribute Methods

LifeCycleAttribute Methods NFX Class Library

The LifeCycleAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LifeCycleAttribute Class
NFX.Glue Namespace


LifeCycleAttribute Properties

LifeCycleAttribute Properties NFX Class Library

The LifeCycleAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Mode |
Public property | TimeoutMs |
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
LifeCycleAttribute Class
NFX.Glue Namespace


LifeCycleAttribute.Mode Property

LifeCycleAttribute Mode Property NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerInstanceMode Mode { get; set; }
public ServerInstanceMode Mode { get; set; }
Public Property Mode As ServerInstanceMode
    Get
    Set
Public Property Mode As ServerInstanceMode
    Get
    Set
public:
property ServerInstanceMode Mode {
    ServerInstanceMode get ();
    void set (ServerInstanceMode value);
}
public:
property ServerInstanceMode Mode {
    ServerInstanceMode get ();
    void set (ServerInstanceMode value);
}
member Mode : ServerInstanceMode with get, set
member Mode : ServerInstanceMode with get, set

Property Value

Type: ServerInstanceMode
See Also
LifeCycleAttribute Class
LifeCycleAttribute Members
NFX.Glue Namespace


LifeCycleAttribute.TimeoutMs Property

LifeCycleAttribute TimeoutMs Property NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int TimeoutMs { get; set; }
public int TimeoutMs { get; set; }
Public Property TimeoutMs As Integer
    Get
    Set
Public Property TimeoutMs As Integer
    Get
    Set
public:
property int TimeoutMs {
    int get ();
    void set (int value);
}
public:
property int TimeoutMs {
    int get ();
    void set (int value);
}
member TimeoutMs : int with get, set
member TimeoutMs : int with get, set

Property Value

Type: Online Int32
See Also
LifeCycleAttribute Class
LifeCycleAttribute Members
NFX.Glue Namespace


LogSrc Enumeration

LogSrc Enumeration NFX Class Library

Logging sources - client, server, any

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum LogSrc
public enum LogSrc
Public Enumeration LogSrc
Public Enumeration LogSrc
public enum class LogSrc
public enum class LogSrc
type LogSrc
type LogSrc
Members
Member name | Value | Description
Any | 0 |
Client | 1 |
Server | 2 |
See Also
NFX.Glue Namespace


MessageSizeException Class

MessageSizeException Class NFX Class Library

Exception thrown in client/server when there's an attempt to send a too large message
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Glue GlueException
NFX.Glue ProtocolException
NFX.Glue MessageSizeException

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class MessageSizeException : ProtocolException
[SerializableAttribute]
public class MessageSizeException : ProtocolException
<SerializableAttribute>
Public Class MessageSizeException
    Inherits ProtocolException
<SerializableAttribute>
Public Class MessageSizeException
    Inherits ProtocolException
[SerializableAttribute]
public ref class MessageSizeException : public ProtocolException
[SerializableAttribute]
public ref class MessageSizeException : public ProtocolException
[<SerializableAttribute>]
type MessageSizeException =
    class
        inherit ProtocolException
    end
[<SerializableAttribute>]
type MessageSizeException =
    class
        inherit ProtocolException
    end
See Also
MessageSizeException Members
NFX.Glue Namespace


MessageSizeException Members

MessageSizeException Members NFX Class Library

The MessageSizeException type exposes the following members.
Constructors
 | Name | Description
Protected method | MessageSizeException(SerializationInfo, StreamingContext) | Initializes a new instance of the MessageSizeException class
Public method | MessageSizeException(Int32, Int32, String, Boolean) | Initializes a new instance of the MessageSizeException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | CloseChannel | Returns true when error is not recoverable on the existing channel and it needs to be closed (Inherited from ProtocolException.)
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
MessageSizeException Class
NFX.Glue Namespace


MessageSizeException Constructor

MessageSizeException Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | MessageSizeException(SerializationInfo, StreamingContext) | Initializes a new instance of the MessageSizeException class
Public method | MessageSizeException(Int32, Int32, String, Boolean) | Initializes a new instance of the MessageSizeException class
Back to Top
See Also
MessageSizeException Class
MessageSizeException Members
NFX.Glue Namespace


MessageSizeException Constructor (SerializationInfo, StreamingContext)

MessageSizeException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MessageSizeException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MessageSizeException(
    SerializationInfo info,
    StreamingContext context
)
protected MessageSizeException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
MessageSizeException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
MessageSizeException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> MessageSizeException
new :
        info : SerializationInfo *
        context : StreamingContext -> MessageSizeException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
MessageSizeException Class
MessageSizeException Members
MessageSizeException Overload
NFX.Glue Namespace


MessageSizeException Constructor (Int32, Int32, String, Boolean)

MessageSizeException Constructor (Int32, Int32, String, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MessageSizeException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageSizeException(
    int size,
    int limit,
    string operation,
    bool closeChannel = false
)
public MessageSizeException(
    int size,
    int limit,
    string operation,
    bool closeChannel = false
)
Public Sub New (
    size As Integer,
    limit As Integer,
    operation As String,
    Optional closeChannel As Boolean = false
)
Public Sub New (
    size As Integer,
    limit As Integer,
    operation As String,
    Optional closeChannel As Boolean = false
)
public:
MessageSizeException(
    int size,
    int limit,
    String^ operation,
    bool closeChannel = false
)
public:
MessageSizeException(
    int size,
    int limit,
    String^ operation,
    bool closeChannel = false
)
new :
        size : int *
        limit : int *
        operation : string *
        ?closeChannel : bool
(* Defaults:
        let _closeChannel = defaultArg closeChannel false
*)
-> MessageSizeException
new :
        size : int *
        limit : int *
        operation : string *
        ?closeChannel : bool
(* Defaults:
        let _closeChannel = defaultArg closeChannel false
*)
-> MessageSizeException

Parameters

size
Type: Online System Int32
limit
Type: Online System Int32
operation
Type: Online System String
closeChannel (Optional)
Type: Online System Boolean
See Also
MessageSizeException Class
MessageSizeException Members
MessageSizeException Overload
NFX.Glue Namespace


MessageSizeException Methods

MessageSizeException Methods NFX Class Library

The MessageSizeException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
MessageSizeException Class
NFX.Glue Namespace


MessageSizeException Properties

MessageSizeException Properties NFX Class Library

The MessageSizeException type exposes the following members.
Properties
 | Name | Description
Public property | CloseChannel | Returns true when error is not recoverable on the existing channel and it needs to be closed (Inherited from ProtocolException.)
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
MessageSizeException Class
NFX.Glue Namespace


MessageSizeException Events

MessageSizeException Events NFX Class Library

The MessageSizeException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
MessageSizeException Class
NFX.Glue Namespace


MsgInspectorConfigurator Class

MsgInspectorConfigurator Class NFX Class Library

Provides general configuration reading logic for message inspectors
Inheritance Hierarchy
Online System Object
NFX.Glue MsgInspectorConfigurator

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class MsgInspectorConfigurator
public static class MsgInspectorConfigurator
Public NotInheritable Class MsgInspectorConfigurator
Public NotInheritable Class MsgInspectorConfigurator
public ref class MsgInspectorConfigurator abstract sealed
public ref class MsgInspectorConfigurator abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MsgInspectorConfigurator =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MsgInspectorConfigurator =  class end
See Also
MsgInspectorConfigurator Members
NFX.Glue Namespace


MsgInspectorConfigurator Members

MsgInspectorConfigurator Members NFX Class Library

The MsgInspectorConfigurator type exposes the following members.
Methods
Name | Description
ConfigureClientInspectors |
ConfigureServerInspectors |
Back to Top
Fields
Name | Description
CONFIG_CLIENT_INSPECTORS_SECTION |
CONFIG_INSPECTOR_SECTION |
CONFIG_NAME_ATTR |
CONFIG_POSITION_ATTR |
CONFIG_SERVER_INSPECTORS_SECTION |
Back to Top
See Also
MsgInspectorConfigurator Class
NFX.Glue Namespace


MsgInspectorConfigurator Fields

MsgInspectorConfigurator Fields NFX Class Library

The MsgInspectorConfigurator type exposes the following members.
Fields
Name | Description
CONFIG_CLIENT_INSPECTORS_SECTION |
CONFIG_INSPECTOR_SECTION |
CONFIG_NAME_ATTR |
CONFIG_POSITION_ATTR |
CONFIG_SERVER_INSPECTORS_SECTION |
Back to Top
See Also
MsgInspectorConfigurator Class
NFX.Glue Namespace


MsgInspectorConfigurator.CONFIG_CLIENT_INSPECTORS_SECTION Field

MsgInspectorConfigurator CONFIG_CLIENT_INSPECTORS_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CLIENT_INSPECTORS_SECTION
public const string CONFIG_CLIENT_INSPECTORS_SECTION
Public Const CONFIG_CLIENT_INSPECTORS_SECTION As String
Public Const CONFIG_CLIENT_INSPECTORS_SECTION As String
public:
literal String^ CONFIG_CLIENT_INSPECTORS_SECTION
public:
literal String^ CONFIG_CLIENT_INSPECTORS_SECTION
static val mutable CONFIG_CLIENT_INSPECTORS_SECTION: string
static val mutable CONFIG_CLIENT_INSPECTORS_SECTION: string

Field Value

Type: Online String
See Also
MsgInspectorConfigurator Class
MsgInspectorConfigurator Members
NFX.Glue Namespace


MsgInspectorConfigurator.CONFIG_INSPECTOR_SECTION Field

MsgInspectorConfigurator CONFIG_INSPECTOR_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_INSPECTOR_SECTION
public const string CONFIG_INSPECTOR_SECTION
Public Const CONFIG_INSPECTOR_SECTION As String
Public Const CONFIG_INSPECTOR_SECTION As String
public:
literal String^ CONFIG_INSPECTOR_SECTION
public:
literal String^ CONFIG_INSPECTOR_SECTION
static val mutable CONFIG_INSPECTOR_SECTION: string
static val mutable CONFIG_INSPECTOR_SECTION: string

Field Value

Type: Online String
See Also
MsgInspectorConfigurator Class
MsgInspectorConfigurator Members
NFX.Glue Namespace


MsgInspectorConfigurator.CONFIG_NAME_ATTR Field

MsgInspectorConfigurator CONFIG_NAME_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_NAME_ATTR
public const string CONFIG_NAME_ATTR
Public Const CONFIG_NAME_ATTR As String
Public Const CONFIG_NAME_ATTR As String
public:
literal String^ CONFIG_NAME_ATTR
public:
literal String^ CONFIG_NAME_ATTR
static val mutable CONFIG_NAME_ATTR: string
static val mutable CONFIG_NAME_ATTR: string

Field Value

Type: Online String
See Also
MsgInspectorConfigurator Class
MsgInspectorConfigurator Members
NFX.Glue Namespace


MsgInspectorConfigurator.CONFIG_POSITION_ATTR Field

MsgInspectorConfigurator CONFIG_POSITION_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_POSITION_ATTR
public const string CONFIG_POSITION_ATTR
Public Const CONFIG_POSITION_ATTR As String
Public Const CONFIG_POSITION_ATTR As String
public:
literal String^ CONFIG_POSITION_ATTR
public:
literal String^ CONFIG_POSITION_ATTR
static val mutable CONFIG_POSITION_ATTR: string
static val mutable CONFIG_POSITION_ATTR: string

Field Value

Type: Online String
See Also
MsgInspectorConfigurator Class
MsgInspectorConfigurator Members
NFX.Glue Namespace


MsgInspectorConfigurator.CONFIG_SERVER_INSPECTORS_SECTION Field

MsgInspectorConfigurator CONFIG_SERVER_INSPECTORS_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SERVER_INSPECTORS_SECTION
public const string CONFIG_SERVER_INSPECTORS_SECTION
Public Const CONFIG_SERVER_INSPECTORS_SECTION As String
Public Const CONFIG_SERVER_INSPECTORS_SECTION As String
public:
literal String^ CONFIG_SERVER_INSPECTORS_SECTION
public:
literal String^ CONFIG_SERVER_INSPECTORS_SECTION
static val mutable CONFIG_SERVER_INSPECTORS_SECTION: string
static val mutable CONFIG_SERVER_INSPECTORS_SECTION: string

Field Value

Type: Online String
See Also
MsgInspectorConfigurator Class
MsgInspectorConfigurator Members
NFX.Glue Namespace


MsgInspectorConfigurator Methods

MsgInspectorConfigurator Methods NFX Class Library

The MsgInspectorConfigurator type exposes the following members.
Methods
Name | Description
ConfigureClientInspectors |
ConfigureServerInspectors |
Back to Top
See Also
MsgInspectorConfigurator Class
NFX.Glue Namespace


MsgInspectorConfigurator.ConfigureClientInspectors Method

MsgInspectorConfigurator ConfigureClientInspectors Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ConfigureClientInspectors(
    Registry<IClientMsgInspector> registry,
    IConfigSectionNode node
)
public static void ConfigureClientInspectors(
    Registry<IClientMsgInspector> registry,
    IConfigSectionNode node
)
Public Shared Sub ConfigureClientInspectors (
    registry As Registry(Of IClientMsgInspector),
    node As IConfigSectionNode
)
Public Shared Sub ConfigureClientInspectors (
    registry As Registry(Of IClientMsgInspector),
    node As IConfigSectionNode
)
public:
static void ConfigureClientInspectors(
    Registry<IClientMsgInspector^>^ registry,
    IConfigSectionNode^ node
)
public:
static void ConfigureClientInspectors(
    Registry<IClientMsgInspector^>^ registry,
    IConfigSectionNode^ node
)
static member ConfigureClientInspectors :
        registry : Registry<IClientMsgInspector> *
        node : IConfigSectionNode -> unit
static member ConfigureClientInspectors :
        registry : Registry<IClientMsgInspector> *
        node : IConfigSectionNode -> unit

Parameters

registry
Type: NFX Registry IClientMsgInspector
node
Type: NFX.Environment IConfigSectionNode
See Also
MsgInspectorConfigurator Class
MsgInspectorConfigurator Members
NFX.Glue Namespace


MsgInspectorConfigurator.ConfigureServerInspectors Method

MsgInspectorConfigurator ConfigureServerInspectors Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ConfigureServerInspectors(
    Registry<IServerMsgInspector> registry,
    IConfigSectionNode node
)
public static void ConfigureServerInspectors(
    Registry<IServerMsgInspector> registry,
    IConfigSectionNode node
)
Public Shared Sub ConfigureServerInspectors (
    registry As Registry(Of IServerMsgInspector),
    node As IConfigSectionNode
)
Public Shared Sub ConfigureServerInspectors (
    registry As Registry(Of IServerMsgInspector),
    node As IConfigSectionNode
)
public:
static void ConfigureServerInspectors(
    Registry<IServerMsgInspector^>^ registry,
    IConfigSectionNode^ node
)
public:
static void ConfigureServerInspectors(
    Registry<IServerMsgInspector^>^ registry,
    IConfigSectionNode^ node
)
static member ConfigureServerInspectors :
        registry : Registry<IServerMsgInspector> *
        node : IConfigSectionNode -> unit
static member ConfigureServerInspectors :
        registry : Registry<IServerMsgInspector> *
        node : IConfigSectionNode -> unit

Parameters

registry
Type: NFX Registry IServerMsgInspector
node
Type: NFX.Environment IConfigSectionNode
See Also
MsgInspectorConfigurator Class
MsgInspectorConfigurator Members
NFX.Glue Namespace


Node Structure

Node Structure NFX Class Library

Represents a network node. It is a binding, logical address of a host and a service that host provides Nodes are not contract-dependent. The componets of address are not case-sensitive. The form of the address is:
View Colorized Copy to Clipboard Print
binding://host:service
binding://host:service
. The "host" and "service" segment syntaxes depend on binding and may not contain the ':' char. An example of some 'mytest' binding: 'mytest://adr=1.1.1.1,nic=eth001:job,chat,backup'

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public struct Node : INamed
[SerializableAttribute]
public struct Node : INamed
<SerializableAttribute>
Public Structure Node
    Implements INamed
<SerializableAttribute>
Public Structure Node
    Implements INamed
[SerializableAttribute]
public value class Node : INamed
[SerializableAttribute]
public value class Node : INamed
[<SealedAttribute>]
[<SerializableAttribute>]
type Node =
    struct
        interface INamed
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type Node =
    struct
        interface INamed
    end
See Also
Node Members
NFX.Glue Namespace


Node Members

Node Members NFX Class Library

The Node type exposes the following members.
Constructors
Name Description
Public method Node
Inits a node struct. It is a binding, logical address of a host and a service that host provides Nodes are not contract-dependent. The componets of address are not case-sensitive. The form of the address is:
View Colorized Copy to Clipboard Print
binding://host:service
binding://host:service
. The "host" and "service" segment syntaxes depend on binding and may not contain the ':' char. An example of some 'mytest' binding: 'mytest://adr=1.1.1.1,nic=eth001:job,chat,backup'
Back to Top
Methods
 | Name | Description
Public method | Equals | (Overrides Online ValueType Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
BINDING_SEPARATOR |
SERVICE_SEPARATOR |
Back to Top
Properties
Name Description
Public property Assigned
Returns true when struct has some data assigned i.e. connect string is specified
Public property Binding
Gets binding portion of ConnectString. This value selects binding adapter
Public property ConnectString
Gets a connection string - a structured URL-like connection descriptor that identifies a host along with binding and service. The componets of address are not case-sensitive. The form of the address is:
View Colorized Copy to Clipboard Print
binding://host:service
binding://host:service
. The "host" and "service" segment syntaxes depend on binding and may not contain the ':' char. An example of some 'mytest' binding: 'mytest://adr=1.1.1.1,nic=eth001:job,chat,backup'
Public property Host
Gets host portion of ConnectString. This value may have a structure of its own which is understood by binding adapter
Public property Name
INamed shortcut to ConnectString
Public property Service
Gets service/port portion of ConnectString. This value may have a structure of its own which is understood by binding adapter
Back to Top
See Also
Node Structure
NFX.Glue Namespace


Node Constructor

Node Constructor NFX Class Library

Inits a node struct. It is a binding, logical address of a host and a service that host provides Nodes are not contract-dependent. The componets of address are not case-sensitive. The form of the address is:
View Colorized Copy to Clipboard Print
binding://host:service
binding://host:service
. The "host" and "service" segment syntaxes depend on binding and may not contain the ':' char. An example of some 'mytest' binding: 'mytest://adr=1.1.1.1,nic=eth001:job,chat,backup'

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Node(
    string connectString
)
public Node(
    string connectString
)
Public Sub New (
    connectString As String
)
Public Sub New (
    connectString As String
)
public:
Node(
    String^ connectString
)
public:
Node(
    String^ connectString
)
new :
        connectString : string -> Node
new :
        connectString : string -> Node

Parameters

connectString
Type: Online System String
See Also
Node Structure
Node Members
NFX.Glue Namespace


Node Fields

Node Fields NFX Class Library

The Node type exposes the following members.
Fields
Name | Description
BINDING_SEPARATOR |
SERVICE_SEPARATOR |
Back to Top
See Also
Node Structure
NFX.Glue Namespace


Node.BINDING_SEPARATOR Field

Node BINDING_SEPARATOR Field NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BINDING_SEPARATOR
public const string BINDING_SEPARATOR
Public Const BINDING_SEPARATOR As String
Public Const BINDING_SEPARATOR As String
public:
literal String^ BINDING_SEPARATOR
public:
literal String^ BINDING_SEPARATOR
static val mutable BINDING_SEPARATOR: string
static val mutable BINDING_SEPARATOR: string

Field Value

Type: Online String
See Also
Node Structure
Node Members
NFX.Glue Namespace


Node.SERVICE_SEPARATOR Field

Node SERVICE_SEPARATOR Field NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SERVICE_SEPARATOR
public const string SERVICE_SEPARATOR
Public Const SERVICE_SEPARATOR As String
Public Const SERVICE_SEPARATOR As String
public:
literal String^ SERVICE_SEPARATOR
public:
literal String^ SERVICE_SEPARATOR
static val mutable SERVICE_SEPARATOR: string
static val mutable SERVICE_SEPARATOR: string

Field Value

Type: Online String
See Also
Node Structure
Node Members
NFX.Glue Namespace


Node Methods

Node Methods NFX Class Library

The Node type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online ValueType Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Node Structure
NFX.Glue Namespace


Node.Equals Method

Node Equals Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
Node Structure
Node Members
NFX.Glue Namespace


Node.GetHashCode Method

Node GetHashCode Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
Node Structure
Node Members
NFX.Glue Namespace


Node.ToString Method

Node ToString Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
Node Structure
Node Members
NFX.Glue Namespace


Node Properties

Node Properties NFX Class Library

The Node type exposes the following members.
Properties
Name Description
Public property Assigned
Returns true when struct has some data assigned i.e. connect string is specified
Public property Binding
Gets binding portion of ConnectString. This value selects binding adapter
Public property ConnectString
Gets a connection string - a structured URL-like connection descriptor that identifies a host along with binding and service. The componets of address are not case-sensitive. The form of the address is:
View Colorized Copy to Clipboard Print
binding://host:service
binding://host:service
. The "host" and "service" segment syntaxes depend on binding and may not contain the ':' char. An example of some 'mytest' binding: 'mytest://adr=1.1.1.1,nic=eth001:job,chat,backup'
Public property Host
Gets host portion of ConnectString. This value may have a structure of its own which is understood by binding adapter
Public property Name
INamed shortcut to ConnectString
Public property Service
Gets service/port portion of ConnectString. This value may have a structure of its own which is understood by binding adapter
Back to Top
See Also
Node Structure
NFX.Glue Namespace


Node.Assigned Property

Node Assigned Property NFX Class Library

Returns true when struct has some data assigned i.e. connect string is specified

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Assigned { get; }
public bool Assigned { get; }
Public ReadOnly Property Assigned As Boolean
    Get
Public ReadOnly Property Assigned As Boolean
    Get
public:
property bool Assigned {
    bool get ();
}
public:
property bool Assigned {
    bool get ();
}
member Assigned : bool with get
member Assigned : bool with get

Property Value

Type: Online Boolean
See Also
Node Structure
Node Members
NFX.Glue Namespace


Node.Binding Property

Node Binding Property NFX Class Library

Gets binding portion of ConnectString. This value selects binding adapter

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Binding { get; }
public string Binding { get; }
Public ReadOnly Property Binding As String
    Get
Public ReadOnly Property Binding As String
    Get
public:
property String^ Binding {
    String^ get ();
}
public:
property String^ Binding {
    String^ get ();
}
member Binding : string with get
member Binding : string with get

Property Value

Type: Online String
See Also
Node Structure
Node Members
NFX.Glue Namespace


Node.ConnectString Property

Node ConnectString Property NFX Class Library

Gets a connection string - a structured URL-like connection descriptor that identifies a host along with binding and service. The componets of address are not case-sensitive. The form of the address is:
View Colorized Copy to Clipboard Print
binding://host:service
binding://host:service
. The "host" and "service" segment syntaxes depend on binding and may not contain the ':' char. An example of some 'mytest' binding: 'mytest://adr=1.1.1.1,nic=eth001:job,chat,backup'

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ConnectString { get; }
public string ConnectString { get; }
Public ReadOnly Property ConnectString As String
    Get
Public ReadOnly Property ConnectString As String
    Get
public:
property String^ ConnectString {
    String^ get ();
}
public:
property String^ ConnectString {
    String^ get ();
}
member ConnectString : string with get
member ConnectString : string with get

Property Value

Type: Online String
See Also
Node Structure
Node Members
NFX.Glue Namespace


Node.Host Property

Node Host Property NFX Class Library

Gets host portion of ConnectString. This value may have a structure of its own which is understood by binding adapter

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Host { get; }
public string Host { get; }
Public ReadOnly Property Host As String
    Get
Public ReadOnly Property Host As String
    Get
public:
property String^ Host {
    String^ get ();
}
public:
property String^ Host {
    String^ get ();
}
member Host : string with get
member Host : string with get

Property Value

Type: Online String
See Also
Node Structure
Node Members
NFX.Glue Namespace


Node.Name Property

Node Name Property NFX Class Library

INamed shortcut to ConnectString

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
Node Structure
Node Members
NFX.Glue Namespace


Node.Service Property

Node Service Property NFX Class Library

Gets service/port portion of ConnectString. This value may have a structure of its own which is understood by binding adapter

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Service { get; }
public string Service { get; }
Public ReadOnly Property Service As String
    Get
Public ReadOnly Property Service As String
    Get
public:
property String^ Service {
    String^ get ();
}
public:
property String^ Service {
    String^ get ();
}
member Service : string with get
member Service : string with get

Property Value

Type: Online String
See Also
Node Structure
Node Members
NFX.Glue Namespace


NOPGlue Class

NOPGlue Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Glue NOPGlue

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NOPGlue : ApplicationComponent, IGlueImplementation,
    IGlue, IApplicationComponent, ILocalizedTimeProvider, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
public class NOPGlue : ApplicationComponent, IGlueImplementation,
    IGlue, IApplicationComponent, ILocalizedTimeProvider, IDisposable, IConfigurable,
    IInstrumentable, IExternallyParameterized
Public Class NOPGlue
    Inherits ApplicationComponent
    Implements IGlueImplementation, IGlue, IApplicationComponent, ILocalizedTimeProvider,
    IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
Public Class NOPGlue
    Inherits ApplicationComponent
    Implements IGlueImplementation, IGlue, IApplicationComponent, ILocalizedTimeProvider,
    IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
public ref class NOPGlue : public ApplicationComponent,
    IGlueImplementation, IGlue, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
public ref class NOPGlue : public ApplicationComponent,
    IGlueImplementation, IGlue, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
type NOPGlue =
    class
        inherit ApplicationComponent
        interface IGlueImplementation
        interface IGlue
        interface IApplicationComponent
        interface ILocalizedTimeProvider
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
type NOPGlue =
    class
        inherit ApplicationComponent
        interface IGlueImplementation
        interface IGlue
        interface IApplicationComponent
        interface ILocalizedTimeProvider
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
NOPGlue Members
NFX.Glue Namespace


NOPGlue Members

NOPGlue Members NFX Class Library

The NOPGlue type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | ClientDeliverAsyncResponse |
Public method | ClientDispatchedRequest |
Public method | ClientDispatchingRequest |
Public method | Configure |
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter |
Public method | ExternalParametersForGroups |
Public method | ExternalSetParameter |
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetNodeBinding(String) |
Public method | GetNodeBinding(Node) |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegisterBinding |
Public method | RegisterProvider |
Public method | RegisterServerEndpoint |
Public method | ServerDispatchRequest |
Public method | ServerHandleRequest |
Public method | ServerHandleRequestFailure |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime |
Public method | UnregisterBinding |
Public method | UnregisterProvider |
Public method | UnregisterServerEndpoint |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Application |
Public property | BindingConfigurations |
Public property | Bindings |
Public property | BindingsConfigurationSection |
Public property | ClientLogLevel |
Public property | ClientMsgInspectors |
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DefaultDispatchTimeoutMs |
Public property | DefaultTimeoutMs |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters |
Public property | GlueConfiguration |
 | Instance |
Public property | InstrumentationEnabled |
Public property | LocalizedTime |
Public property | ProviderConfigurations |
Public property | Providers |
Public property | ProvidersConfigurationSection |
Public property | ServerConfigurations |
Public property | ServerInstanceLockTimeoutMs |
Public property | ServerLogLevel |
Public property | ServerMsgInspectors |
Public property | Servers |
Public property | ServersConfigurationSection |
Public property | TimeLocation |
Back to Top
See Also
NOPGlue Class
NFX.Glue Namespace


NOPGlue Methods

NOPGlue Methods NFX Class Library

The NOPGlue type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | ClientDeliverAsyncResponse |
Public method | ClientDispatchedRequest |
Public method | ClientDispatchingRequest |
Public method | Configure |
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter |
Public method | ExternalParametersForGroups |
Public method | ExternalSetParameter |
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetNodeBinding(String) |
Public method | GetNodeBinding(Node) |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegisterBinding |
Public method | RegisterProvider |
Public method | RegisterServerEndpoint |
Public method | ServerDispatchRequest |
Public method | ServerHandleRequest |
Public method | ServerHandleRequestFailure |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime |
Public method | UnregisterBinding |
Public method | UnregisterProvider |
Public method | UnregisterServerEndpoint |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NOPGlue Class
NFX.Glue Namespace


NOPGlue.ClientDeliverAsyncResponse Method

NOPGlue ClientDeliverAsyncResponse Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ClientDeliverAsyncResponse(
    ResponseMsg response
)
public void ClientDeliverAsyncResponse(
    ResponseMsg response
)
Public Sub ClientDeliverAsyncResponse (
    response As ResponseMsg
)
Public Sub ClientDeliverAsyncResponse (
    response As ResponseMsg
)
public:
virtual void ClientDeliverAsyncResponse(
    ResponseMsg^ response
) sealed
public:
virtual void ClientDeliverAsyncResponse(
    ResponseMsg^ response
) sealed
abstract ClientDeliverAsyncResponse :
        response : ResponseMsg -> unit
override ClientDeliverAsyncResponse :
        response : ResponseMsg -> unit
abstract ClientDeliverAsyncResponse :
        response : ResponseMsg -> unit
override ClientDeliverAsyncResponse :
        response : ResponseMsg -> unit

Parameters

response
Type: NFX.Glue.Protocol ResponseMsg

Implements

IGlueImplementation ClientDeliverAsyncResponse(ResponseMsg)
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.ClientDispatchedRequest Method

NOPGlue ClientDispatchedRequest Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ClientDispatchedRequest(
    ClientEndPoint client,
    RequestMsg request,
    CallSlot callSlot
)
public void ClientDispatchedRequest(
    ClientEndPoint client,
    RequestMsg request,
    CallSlot callSlot
)
Public Sub ClientDispatchedRequest (
    client As ClientEndPoint,
    request As RequestMsg,
    callSlot As CallSlot
)
Public Sub ClientDispatchedRequest (
    client As ClientEndPoint,
    request As RequestMsg,
    callSlot As CallSlot
)
public:
virtual void ClientDispatchedRequest(
    ClientEndPoint^ client,
    RequestMsg^ request,
    CallSlot^ callSlot
) sealed
public:
virtual void ClientDispatchedRequest(
    ClientEndPoint^ client,
    RequestMsg^ request,
    CallSlot^ callSlot
) sealed
abstract ClientDispatchedRequest :
        client : ClientEndPoint *
        request : RequestMsg *
        callSlot : CallSlot -> unit
override ClientDispatchedRequest :
        client : ClientEndPoint *
        request : RequestMsg *
        callSlot : CallSlot -> unit
abstract ClientDispatchedRequest :
        client : ClientEndPoint *
        request : RequestMsg *
        callSlot : CallSlot -> unit
override ClientDispatchedRequest :
        client : ClientEndPoint *
        request : RequestMsg *
        callSlot : CallSlot -> unit

Parameters

client
Type: NFX.Glue ClientEndPoint
request
Type: NFX.Glue.Protocol RequestMsg
callSlot
Type: NFX.Glue CallSlot

Implements

IGlueImplementation ClientDispatchedRequest(ClientEndPoint, RequestMsg, CallSlot)
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.ClientDispatchingRequest Method

NOPGlue ClientDispatchingRequest Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RequestMsg ClientDispatchingRequest(
    ClientEndPoint client,
    RequestMsg request
)
public RequestMsg ClientDispatchingRequest(
    ClientEndPoint client,
    RequestMsg request
)
Public Function ClientDispatchingRequest (
    client As ClientEndPoint,
    request As RequestMsg
) As RequestMsg
Public Function ClientDispatchingRequest (
    client As ClientEndPoint,
    request As RequestMsg
) As RequestMsg
public:
virtual RequestMsg^ ClientDispatchingRequest(
    ClientEndPoint^ client,
    RequestMsg^ request
) sealed
public:
virtual RequestMsg^ ClientDispatchingRequest(
    ClientEndPoint^ client,
    RequestMsg^ request
) sealed
abstract ClientDispatchingRequest :
        client : ClientEndPoint *
        request : RequestMsg -> RequestMsg
override ClientDispatchingRequest :
        client : ClientEndPoint *
        request : RequestMsg -> RequestMsg
abstract ClientDispatchingRequest :
        client : ClientEndPoint *
        request : RequestMsg -> RequestMsg
override ClientDispatchingRequest :
        client : ClientEndPoint *
        request : RequestMsg -> RequestMsg

Parameters

client
Type: NFX.Glue ClientEndPoint
request
Type: NFX.Glue.Protocol RequestMsg

Return Value

Type: RequestMsg

Implements

IGlueImplementation ClientDispatchingRequest(ClientEndPoint, RequestMsg)
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.Configure Method

NOPGlue Configure Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode node
)
public void Configure(
    IConfigSectionNode node
)
Public Sub Configure (
    node As IConfigSectionNode
)
Public Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.ExternalGetParameter Method

NOPGlue ExternalGetParameter Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
public bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
Public Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
Public Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
) sealed
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
) sealed
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalGetParameter(String, Object , String )
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.ExternalParametersForGroups Method

NOPGlue ExternalParametersForGroups Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
public IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
Public Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
Public Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
) sealed
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
) sealed
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>

Parameters

groups
Type: Online System String

Return Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParametersForGroups( String )
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.ExternalSetParameter Method

NOPGlue ExternalSetParameter Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
public bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
Public Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
Public Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
) sealed
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
) sealed
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalSetParameter(String, Object, String )
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.GetNodeBinding Method

NOPGlue GetNodeBinding Method NFX Class Library

Overload List
 | Name | Description
Public method | GetNodeBinding(String) |
Public method | GetNodeBinding(Node) |
Back to Top
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.GetNodeBinding Method (String)

NOPGlue GetNodeBinding Method (String) NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Binding GetNodeBinding(
    string node
)
public Binding GetNodeBinding(
    string node
)
Public Function GetNodeBinding (
    node As String
) As Binding
Public Function GetNodeBinding (
    node As String
) As Binding
public:
virtual Binding^ GetNodeBinding(
    String^ node
) sealed
public:
virtual Binding^ GetNodeBinding(
    String^ node
) sealed
abstract GetNodeBinding :
        node : string -> Binding
override GetNodeBinding :
        node : string -> Binding
abstract GetNodeBinding :
        node : string -> Binding
override GetNodeBinding :
        node : string -> Binding

Parameters

node
Type: Online System String

Return Value

Type: Binding

Implements

IGlue GetNodeBinding(String)
See Also
NOPGlue Class
NOPGlue Members
GetNodeBinding Overload
NFX.Glue Namespace


NOPGlue.GetNodeBinding Method (Node)

NOPGlue GetNodeBinding Method (Node) NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Binding GetNodeBinding(
    Node node
)
public Binding GetNodeBinding(
    Node node
)
Public Function GetNodeBinding (
    node As Node
) As Binding
Public Function GetNodeBinding (
    node As Node
) As Binding
public:
virtual Binding^ GetNodeBinding(
    Node node
) sealed
public:
virtual Binding^ GetNodeBinding(
    Node node
) sealed
abstract GetNodeBinding :
        node : Node -> Binding
override GetNodeBinding :
        node : Node -> Binding
abstract GetNodeBinding :
        node : Node -> Binding
override GetNodeBinding :
        node : Node -> Binding

Parameters

node
Type: NFX.Glue Node

Return Value

Type: Binding

Implements

IGlue GetNodeBinding(Node)
See Also
NOPGlue Class
NOPGlue Members
GetNodeBinding Overload
NFX.Glue Namespace


NOPGlue.LocalizedTimeToUniversalTime Method

NOPGlue LocalizedTimeToUniversalTime Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
public DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
Public Function LocalizedTimeToUniversalTime (
    local As DateTime
) As DateTime
Public Function LocalizedTimeToUniversalTime (
    local As DateTime
) As DateTime
public:
virtual DateTime LocalizedTimeToUniversalTime(
    DateTime local
) sealed
public:
virtual DateTime LocalizedTimeToUniversalTime(
    DateTime local
) sealed
abstract LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
override LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
abstract LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
override LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime

Parameters

local
Type: Online System DateTime

Return Value

Type: Online DateTime

Implements

ILocalizedTimeProvider LocalizedTimeToUniversalTime(DateTime)
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.RegisterBinding Method

NOPGlue RegisterBinding Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RegisterBinding(
    Binding b
)
public void RegisterBinding(
    Binding b
)
Public Sub RegisterBinding (
    b As Binding
)
Public Sub RegisterBinding (
    b As Binding
)
public:
virtual void RegisterBinding(
    Binding^ b
) sealed
public:
virtual void RegisterBinding(
    Binding^ b
) sealed
abstract RegisterBinding :
        b : Binding -> unit
override RegisterBinding :
        b : Binding -> unit
abstract RegisterBinding :
        b : Binding -> unit
override RegisterBinding :
        b : Binding -> unit

Parameters

b
Type: NFX.Glue Binding

Implements

IGlueImplementation RegisterBinding(Binding)
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.RegisterProvider Method

NOPGlue RegisterProvider Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RegisterProvider(
    Provider p
)
public void RegisterProvider(
    Provider p
)
Public Sub RegisterProvider (
    p As Provider
)
Public Sub RegisterProvider (
    p As Provider
)
public:
virtual void RegisterProvider(
    Provider^ p
) sealed
public:
virtual void RegisterProvider(
    Provider^ p
) sealed
abstract RegisterProvider :
        p : Provider -> unit
override RegisterProvider :
        p : Provider -> unit
abstract RegisterProvider :
        p : Provider -> unit
override RegisterProvider :
        p : Provider -> unit

Parameters

p
Type: NFX.Glue Provider

Implements

IGlueImplementation RegisterProvider(Provider)
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.RegisterServerEndpoint Method

NOPGlue RegisterServerEndpoint Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RegisterServerEndpoint(
    ServerEndPoint ep
)
public void RegisterServerEndpoint(
    ServerEndPoint ep
)
Public Sub RegisterServerEndpoint (
    ep As ServerEndPoint
)
Public Sub RegisterServerEndpoint (
    ep As ServerEndPoint
)
public:
virtual void RegisterServerEndpoint(
    ServerEndPoint^ ep
) sealed
public:
virtual void RegisterServerEndpoint(
    ServerEndPoint^ ep
) sealed
abstract RegisterServerEndpoint :
        ep : ServerEndPoint -> unit
override RegisterServerEndpoint :
        ep : ServerEndPoint -> unit
abstract RegisterServerEndpoint :
        ep : ServerEndPoint -> unit
override RegisterServerEndpoint :
        ep : ServerEndPoint -> unit

Parameters

ep
Type: NFX.Glue ServerEndPoint

Implements

IGlueImplementation RegisterServerEndpoint(ServerEndPoint)
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.ServerDispatchRequest Method

NOPGlue ServerDispatchRequest Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ServerDispatchRequest(
    RequestMsg request
)
public void ServerDispatchRequest(
    RequestMsg request
)
Public Sub ServerDispatchRequest (
    request As RequestMsg
)
Public Sub ServerDispatchRequest (
    request As RequestMsg
)
public:
virtual void ServerDispatchRequest(
    RequestMsg^ request
) sealed
public:
virtual void ServerDispatchRequest(
    RequestMsg^ request
) sealed
abstract ServerDispatchRequest :
        request : RequestMsg -> unit
override ServerDispatchRequest :
        request : RequestMsg -> unit
abstract ServerDispatchRequest :
        request : RequestMsg -> unit
override ServerDispatchRequest :
        request : RequestMsg -> unit

Parameters

request
Type: NFX.Glue.Protocol RequestMsg

Implements

IGlueImplementation ServerDispatchRequest(RequestMsg)
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.ServerHandleRequest Method

NOPGlue ServerHandleRequest Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResponseMsg ServerHandleRequest(
    RequestMsg request
)
public ResponseMsg ServerHandleRequest(
    RequestMsg request
)
Public Function ServerHandleRequest (
    request As RequestMsg
) As ResponseMsg
Public Function ServerHandleRequest (
    request As RequestMsg
) As ResponseMsg
public:
virtual ResponseMsg^ ServerHandleRequest(
    RequestMsg^ request
) sealed
public:
virtual ResponseMsg^ ServerHandleRequest(
    RequestMsg^ request
) sealed
abstract ServerHandleRequest :
        request : RequestMsg -> ResponseMsg
override ServerHandleRequest :
        request : RequestMsg -> ResponseMsg
abstract ServerHandleRequest :
        request : RequestMsg -> ResponseMsg
override ServerHandleRequest :
        request : RequestMsg -> ResponseMsg

Parameters

request
Type: NFX.Glue.Protocol RequestMsg

Return Value

Type: ResponseMsg

Implements

IGlueImplementation ServerHandleRequest(RequestMsg)
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.ServerHandleRequestFailure Method

NOPGlue ServerHandleRequestFailure Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResponseMsg ServerHandleRequestFailure(
    FID reqID,
    bool oneWay,
    Exception failure,
    Object bindingSpecCtx
)
public ResponseMsg ServerHandleRequestFailure(
    FID reqID,
    bool oneWay,
    Exception failure,
    Object bindingSpecCtx
)
Public Function ServerHandleRequestFailure (
    reqID As FID,
    oneWay As Boolean,
    failure As Exception,
    bindingSpecCtx As Object
) As ResponseMsg
Public Function ServerHandleRequestFailure (
    reqID As FID,
    oneWay As Boolean,
    failure As Exception,
    bindingSpecCtx As Object
) As ResponseMsg
public:
virtual ResponseMsg^ ServerHandleRequestFailure(
    FID reqID,
    bool oneWay,
    Exception^ failure,
    Object^ bindingSpecCtx
) sealed
public:
virtual ResponseMsg^ ServerHandleRequestFailure(
    FID reqID,
    bool oneWay,
    Exception^ failure,
    Object^ bindingSpecCtx
) sealed
abstract ServerHandleRequestFailure :
        reqID : FID *
        oneWay : bool *
        failure : Exception *
        bindingSpecCtx : Object -> ResponseMsg
override ServerHandleRequestFailure :
        reqID : FID *
        oneWay : bool *
        failure : Exception *
        bindingSpecCtx : Object -> ResponseMsg
abstract ServerHandleRequestFailure :
        reqID : FID *
        oneWay : bool *
        failure : Exception *
        bindingSpecCtx : Object -> ResponseMsg
override ServerHandleRequestFailure :
        reqID : FID *
        oneWay : bool *
        failure : Exception *
        bindingSpecCtx : Object -> ResponseMsg

Parameters

reqID
Type: NFX FID
oneWay
Type: Online System Boolean
failure
Type: Online System Exception
bindingSpecCtx
Type: Online System Object

Return Value

Type: ResponseMsg

Implements

IGlueImplementation ServerHandleRequestFailure(FID, Boolean, Exception, Object)
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.UniversalTimeToLocalizedTime Method

NOPGlue UniversalTimeToLocalizedTime Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
public DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
Public Function UniversalTimeToLocalizedTime (
    utc As DateTime
) As DateTime
Public Function UniversalTimeToLocalizedTime (
    utc As DateTime
) As DateTime
public:
virtual DateTime UniversalTimeToLocalizedTime(
    DateTime utc
) sealed
public:
virtual DateTime UniversalTimeToLocalizedTime(
    DateTime utc
) sealed
abstract UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
override UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
abstract UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
override UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime

Parameters

utc
Type: Online System DateTime

Return Value

Type: Online DateTime

Implements

ILocalizedTimeProvider UniversalTimeToLocalizedTime(DateTime)
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.UnregisterBinding Method

NOPGlue UnregisterBinding Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void UnregisterBinding(
    Binding b
)
public void UnregisterBinding(
    Binding b
)
Public Sub UnregisterBinding (
    b As Binding
)
Public Sub UnregisterBinding (
    b As Binding
)
public:
virtual void UnregisterBinding(
    Binding^ b
) sealed
public:
virtual void UnregisterBinding(
    Binding^ b
) sealed
abstract UnregisterBinding :
        b : Binding -> unit
override UnregisterBinding :
        b : Binding -> unit
abstract UnregisterBinding :
        b : Binding -> unit
override UnregisterBinding :
        b : Binding -> unit

Parameters

b
Type: NFX.Glue Binding

Implements

IGlueImplementation UnregisterBinding(Binding)
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.UnregisterProvider Method

NOPGlue UnregisterProvider Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void UnregisterProvider(
    Provider p
)
public void UnregisterProvider(
    Provider p
)
Public Sub UnregisterProvider (
    p As Provider
)
Public Sub UnregisterProvider (
    p As Provider
)
public:
virtual void UnregisterProvider(
    Provider^ p
) sealed
public:
virtual void UnregisterProvider(
    Provider^ p
) sealed
abstract UnregisterProvider :
        p : Provider -> unit
override UnregisterProvider :
        p : Provider -> unit
abstract UnregisterProvider :
        p : Provider -> unit
override UnregisterProvider :
        p : Provider -> unit

Parameters

p
Type: NFX.Glue Provider

Implements

IGlueImplementation UnregisterProvider(Provider)
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.UnregisterServerEndpoint Method

NOPGlue UnregisterServerEndpoint Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void UnregisterServerEndpoint(
    ServerEndPoint ep
)
public void UnregisterServerEndpoint(
    ServerEndPoint ep
)
Public Sub UnregisterServerEndpoint (
    ep As ServerEndPoint
)
Public Sub UnregisterServerEndpoint (
    ep As ServerEndPoint
)
public:
virtual void UnregisterServerEndpoint(
    ServerEndPoint^ ep
) sealed
public:
virtual void UnregisterServerEndpoint(
    ServerEndPoint^ ep
) sealed
abstract UnregisterServerEndpoint :
        ep : ServerEndPoint -> unit
override UnregisterServerEndpoint :
        ep : ServerEndPoint -> unit
abstract UnregisterServerEndpoint :
        ep : ServerEndPoint -> unit
override UnregisterServerEndpoint :
        ep : ServerEndPoint -> unit

Parameters

ep
Type: NFX.Glue ServerEndPoint

Implements

IGlueImplementation UnregisterServerEndpoint(ServerEndPoint)
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue Properties

NOPGlue Properties NFX Class Library

The NOPGlue type exposes the following members.
Properties
 | Name | Description
Public property | Application |
Public property | BindingConfigurations |
Public property | Bindings |
Public property | BindingsConfigurationSection |
Public property | ClientLogLevel |
Public property | ClientMsgInspectors |
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DefaultDispatchTimeoutMs |
Public property | DefaultTimeoutMs |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters |
Public property | GlueConfiguration |
 | Instance |
Public property | InstrumentationEnabled |
Public property | LocalizedTime |
Public property | ProviderConfigurations |
Public property | Providers |
Public property | ProvidersConfigurationSection |
Public property | ServerConfigurations |
Public property | ServerInstanceLockTimeoutMs |
Public property | ServerLogLevel |
Public property | ServerMsgInspectors |
Public property | Servers |
Public property | ServersConfigurationSection |
Public property | TimeLocation |
Back to Top
See Also
NOPGlue Class
NFX.Glue Namespace


NOPGlue.Application Property

NOPGlue Application Property NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IApplication Application { get; }
public IApplication Application { get; }
Public ReadOnly Property Application As IApplication
    Get
Public ReadOnly Property Application As IApplication
    Get
public:
property IApplication^ Application {
    IApplication^ get ();
}
public:
property IApplication^ Application {
    IApplication^ get ();
}
member Application : IApplication with get
member Application : IApplication with get

Property Value

Type: IApplication
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.BindingConfigurations Property

NOPGlue BindingConfigurations Property NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<IConfigSectionNode> BindingConfigurations { get; }
public IEnumerable<IConfigSectionNode> BindingConfigurations { get; }
Public ReadOnly Property BindingConfigurations As IEnumerable(Of IConfigSectionNode)
    Get
Public ReadOnly Property BindingConfigurations As IEnumerable(Of IConfigSectionNode)
    Get
public:
virtual property IEnumerable<IConfigSectionNode^>^ BindingConfigurations {
    IEnumerable<IConfigSectionNode^>^ get () sealed;
}
public:
virtual property IEnumerable<IConfigSectionNode^>^ BindingConfigurations {
    IEnumerable<IConfigSectionNode^>^ get () sealed;
}
abstract BindingConfigurations : IEnumerable<IConfigSectionNode> with get
override BindingConfigurations : IEnumerable<IConfigSectionNode> with get
abstract BindingConfigurations : IEnumerable<IConfigSectionNode> with get
override BindingConfigurations : IEnumerable<IConfigSectionNode> with get

Property Value

Type: Online IEnumerable IConfigSectionNode

Implements

IGlueImplementation BindingConfigurations
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.Bindings Property

NOPGlue Bindings Property NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<Binding> Bindings { get; }
public IRegistry<Binding> Bindings { get; }
Public ReadOnly Property Bindings As IRegistry(Of Binding)
    Get
Public ReadOnly Property Bindings As IRegistry(Of Binding)
    Get
public:
virtual property IRegistry<Binding^>^ Bindings {
    IRegistry<Binding^>^ get () sealed;
}
public:
virtual property IRegistry<Binding^>^ Bindings {
    IRegistry<Binding^>^ get () sealed;
}
abstract Bindings : IRegistry<Binding> with get
override Bindings : IRegistry<Binding> with get
abstract Bindings : IRegistry<Binding> with get
override Bindings : IRegistry<Binding> with get

Property Value

Type: IRegistry Binding

Implements

IGlue Bindings
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.BindingsConfigurationSection Property

NOPGlue BindingsConfigurationSection Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IConfigSectionNode BindingsConfigurationSection { get; }
public IConfigSectionNode BindingsConfigurationSection { get; }
Public ReadOnly Property BindingsConfigurationSection As IConfigSectionNode
    Get
Public ReadOnly Property BindingsConfigurationSection As IConfigSectionNode
    Get
public:
virtual property IConfigSectionNode^ BindingsConfigurationSection {
    IConfigSectionNode^ get () sealed;
}
public:
virtual property IConfigSectionNode^ BindingsConfigurationSection {
    IConfigSectionNode^ get () sealed;
}
abstract BindingsConfigurationSection : IConfigSectionNode with get
override BindingsConfigurationSection : IConfigSectionNode with get
abstract BindingsConfigurationSection : IConfigSectionNode with get
override BindingsConfigurationSection : IConfigSectionNode with get

Property Value

Type: IConfigSectionNode

Implements

IGlueImplementation BindingsConfigurationSection
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.ClientLogLevel Property

NOPGlue ClientLogLevel Property NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageType ClientLogLevel { get; set; }
public MessageType ClientLogLevel { get; set; }
Public Property ClientLogLevel As MessageType
    Get
    Set
Public Property ClientLogLevel As MessageType
    Get
    Set
public:
virtual property MessageType ClientLogLevel {
    MessageType get () sealed;
    void set (MessageType value) sealed;
}
public:
virtual property MessageType ClientLogLevel {
    MessageType get () sealed;
    void set (MessageType value) sealed;
}
abstract ClientLogLevel : MessageType with get, set
override ClientLogLevel : MessageType with get, set
abstract ClientLogLevel : MessageType with get, set
override ClientLogLevel : MessageType with get, set

Property Value

Type: MessageType

Implements

IGlue ClientLogLevel
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.ClientMsgInspectors Property

NOPGlue ClientMsgInspectors Property NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderedRegistry<IClientMsgInspector> ClientMsgInspectors { get; }
public OrderedRegistry<IClientMsgInspector> ClientMsgInspectors { get; }
Public ReadOnly Property ClientMsgInspectors As OrderedRegistry(Of IClientMsgInspector)
    Get
Public ReadOnly Property ClientMsgInspectors As OrderedRegistry(Of IClientMsgInspector)
    Get
public:
virtual property OrderedRegistry<IClientMsgInspector^>^ ClientMsgInspectors {
    OrderedRegistry<IClientMsgInspector^>^ get () sealed;
}
public:
virtual property OrderedRegistry<IClientMsgInspector^>^ ClientMsgInspectors {
    OrderedRegistry<IClientMsgInspector^>^ get () sealed;
}
abstract ClientMsgInspectors : OrderedRegistry<IClientMsgInspector> with get
override ClientMsgInspectors : OrderedRegistry<IClientMsgInspector> with get
abstract ClientMsgInspectors : OrderedRegistry<IClientMsgInspector> with get
override ClientMsgInspectors : OrderedRegistry<IClientMsgInspector> with get

Property Value

Type: OrderedRegistry IClientMsgInspector

Implements

IGlue ClientMsgInspectors
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.DefaultDispatchTimeoutMs Property

NOPGlue DefaultDispatchTimeoutMs Property NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int DefaultDispatchTimeoutMs { get; set; }
public int DefaultDispatchTimeoutMs { get; set; }
Public Property DefaultDispatchTimeoutMs As Integer
    Get
    Set
Public Property DefaultDispatchTimeoutMs As Integer
    Get
    Set
public:
virtual property int DefaultDispatchTimeoutMs {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int DefaultDispatchTimeoutMs {
    int get () sealed;
    void set (int value) sealed;
}
abstract DefaultDispatchTimeoutMs : int with get, set
override DefaultDispatchTimeoutMs : int with get, set
abstract DefaultDispatchTimeoutMs : int with get, set
override DefaultDispatchTimeoutMs : int with get, set

Property Value

Type: Online Int32

Implements

IGlue DefaultDispatchTimeoutMs
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.DefaultTimeoutMs Property

NOPGlue DefaultTimeoutMs Property NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int DefaultTimeoutMs { get; set; }
public int DefaultTimeoutMs { get; set; }
Public Property DefaultTimeoutMs As Integer
    Get
    Set
Public Property DefaultTimeoutMs As Integer
    Get
    Set
public:
virtual property int DefaultTimeoutMs {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int DefaultTimeoutMs {
    int get () sealed;
    void set (int value) sealed;
}
abstract DefaultTimeoutMs : int with get, set
override DefaultTimeoutMs : int with get, set
abstract DefaultTimeoutMs : int with get, set
override DefaultTimeoutMs : int with get, set

Property Value

Type: Online Int32

Implements

IGlue DefaultTimeoutMs
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.ExternalParameters Property

NOPGlue ExternalParameters Property NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
public IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
Public ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
Public ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get () sealed;
}
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get () sealed;
}
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get

Property Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParameters
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.GlueConfiguration Property

NOPGlue GlueConfiguration Property NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IConfigSectionNode GlueConfiguration { get; }
public IConfigSectionNode GlueConfiguration { get; }
Public ReadOnly Property GlueConfiguration As IConfigSectionNode
    Get
Public ReadOnly Property GlueConfiguration As IConfigSectionNode
    Get
public:
virtual property IConfigSectionNode^ GlueConfiguration {
    IConfigSectionNode^ get () sealed;
}
public:
virtual property IConfigSectionNode^ GlueConfiguration {
    IConfigSectionNode^ get () sealed;
}
abstract GlueConfiguration : IConfigSectionNode with get
override GlueConfiguration : IConfigSectionNode with get
abstract GlueConfiguration : IConfigSectionNode with get
override GlueConfiguration : IConfigSectionNode with get

Property Value

Type: IConfigSectionNode

Implements

IGlueImplementation GlueConfiguration
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.Instance Property

NOPGlue Instance Property NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NOPGlue Instance { get; }
public static NOPGlue Instance { get; }
Public Shared ReadOnly Property Instance As NOPGlue
    Get
Public Shared ReadOnly Property Instance As NOPGlue
    Get
public:
static property NOPGlue^ Instance {
    NOPGlue^ get ();
}
public:
static property NOPGlue^ Instance {
    NOPGlue^ get ();
}
static member Instance : NOPGlue with get
static member Instance : NOPGlue with get

Property Value

Type: NOPGlue
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.InstrumentationEnabled Property

NOPGlue InstrumentationEnabled Property NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool InstrumentationEnabled { get; set; }
public bool InstrumentationEnabled { get; set; }
Public Property InstrumentationEnabled As Boolean
    Get
    Set
Public Property InstrumentationEnabled As Boolean
    Get
    Set
public:
virtual property bool InstrumentationEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool InstrumentationEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract InstrumentationEnabled : bool with get, set
override InstrumentationEnabled : bool with get, set
abstract InstrumentationEnabled : bool with get, set
override InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentable InstrumentationEnabled
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.LocalizedTime Property

NOPGlue LocalizedTime Property NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime LocalizedTime { get; }
public DateTime LocalizedTime { get; }
Public ReadOnly Property LocalizedTime As DateTime
    Get
Public ReadOnly Property LocalizedTime As DateTime
    Get
public:
virtual property DateTime LocalizedTime {
    DateTime get () sealed;
}
public:
virtual property DateTime LocalizedTime {
    DateTime get () sealed;
}
abstract LocalizedTime : DateTime with get
override LocalizedTime : DateTime with get
abstract LocalizedTime : DateTime with get
override LocalizedTime : DateTime with get

Property Value

Type: Online DateTime

Implements

ILocalizedTimeProvider LocalizedTime
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.ProviderConfigurations Property

NOPGlue ProviderConfigurations Property NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<IConfigSectionNode> ProviderConfigurations { get; }
public IEnumerable<IConfigSectionNode> ProviderConfigurations { get; }
Public ReadOnly Property ProviderConfigurations As IEnumerable(Of IConfigSectionNode)
    Get
Public ReadOnly Property ProviderConfigurations As IEnumerable(Of IConfigSectionNode)
    Get
public:
virtual property IEnumerable<IConfigSectionNode^>^ ProviderConfigurations {
    IEnumerable<IConfigSectionNode^>^ get () sealed;
}
public:
virtual property IEnumerable<IConfigSectionNode^>^ ProviderConfigurations {
    IEnumerable<IConfigSectionNode^>^ get () sealed;
}
abstract ProviderConfigurations : IEnumerable<IConfigSectionNode> with get
override ProviderConfigurations : IEnumerable<IConfigSectionNode> with get
abstract ProviderConfigurations : IEnumerable<IConfigSectionNode> with get
override ProviderConfigurations : IEnumerable<IConfigSectionNode> with get

Property Value

Type: Online IEnumerable IConfigSectionNode

Implements

IGlueImplementation ProviderConfigurations
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.Providers Property

NOPGlue Providers Property NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<Provider> Providers { get; }
public IRegistry<Provider> Providers { get; }
Public ReadOnly Property Providers As IRegistry(Of Provider)
    Get
Public ReadOnly Property Providers As IRegistry(Of Provider)
    Get
public:
virtual property IRegistry<Provider^>^ Providers {
    IRegistry<Provider^>^ get () sealed;
}
public:
virtual property IRegistry<Provider^>^ Providers {
    IRegistry<Provider^>^ get () sealed;
}
abstract Providers : IRegistry<Provider> with get
override Providers : IRegistry<Provider> with get
abstract Providers : IRegistry<Provider> with get
override Providers : IRegistry<Provider> with get

Property Value

Type: IRegistry Provider

Implements

IGlue Providers
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.ProvidersConfigurationSection Property

NOPGlue ProvidersConfigurationSection Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IConfigSectionNode ProvidersConfigurationSection { get; }
public IConfigSectionNode ProvidersConfigurationSection { get; }
Public ReadOnly Property ProvidersConfigurationSection As IConfigSectionNode
    Get
Public ReadOnly Property ProvidersConfigurationSection As IConfigSectionNode
    Get
public:
virtual property IConfigSectionNode^ ProvidersConfigurationSection {
    IConfigSectionNode^ get () sealed;
}
public:
virtual property IConfigSectionNode^ ProvidersConfigurationSection {
    IConfigSectionNode^ get () sealed;
}
abstract ProvidersConfigurationSection : IConfigSectionNode with get
override ProvidersConfigurationSection : IConfigSectionNode with get
abstract ProvidersConfigurationSection : IConfigSectionNode with get
override ProvidersConfigurationSection : IConfigSectionNode with get

Property Value

Type: IConfigSectionNode

Implements

IGlueImplementation ProvidersConfigurationSection
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.ServerConfigurations Property

NOPGlue ServerConfigurations Property NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<IConfigSectionNode> ServerConfigurations { get; }
public IEnumerable<IConfigSectionNode> ServerConfigurations { get; }
Public ReadOnly Property ServerConfigurations As IEnumerable(Of IConfigSectionNode)
    Get
Public ReadOnly Property ServerConfigurations As IEnumerable(Of IConfigSectionNode)
    Get
public:
virtual property IEnumerable<IConfigSectionNode^>^ ServerConfigurations {
    IEnumerable<IConfigSectionNode^>^ get () sealed;
}
public:
virtual property IEnumerable<IConfigSectionNode^>^ ServerConfigurations {
    IEnumerable<IConfigSectionNode^>^ get () sealed;
}
abstract ServerConfigurations : IEnumerable<IConfigSectionNode> with get
override ServerConfigurations : IEnumerable<IConfigSectionNode> with get
abstract ServerConfigurations : IEnumerable<IConfigSectionNode> with get
override ServerConfigurations : IEnumerable<IConfigSectionNode> with get

Property Value

Type: Online IEnumerable IConfigSectionNode

Implements

IGlueImplementation ServerConfigurations
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.ServerInstanceLockTimeoutMs Property

NOPGlue ServerInstanceLockTimeoutMs Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ServerInstanceLockTimeoutMs { get; set; }
public int ServerInstanceLockTimeoutMs { get; set; }
Public Property ServerInstanceLockTimeoutMs As Integer
    Get
    Set
Public Property ServerInstanceLockTimeoutMs As Integer
    Get
    Set
public:
virtual property int ServerInstanceLockTimeoutMs {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int ServerInstanceLockTimeoutMs {
    int get () sealed;
    void set (int value) sealed;
}
abstract ServerInstanceLockTimeoutMs : int with get, set
override ServerInstanceLockTimeoutMs : int with get, set
abstract ServerInstanceLockTimeoutMs : int with get, set
override ServerInstanceLockTimeoutMs : int with get, set

Property Value

Type: Online Int32

Implements

IGlue ServerInstanceLockTimeoutMs
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.ServerLogLevel Property

NOPGlue ServerLogLevel Property NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageType ServerLogLevel { get; set; }
public MessageType ServerLogLevel { get; set; }
Public Property ServerLogLevel As MessageType
    Get
    Set
Public Property ServerLogLevel As MessageType
    Get
    Set
public:
virtual property MessageType ServerLogLevel {
    MessageType get () sealed;
    void set (MessageType value) sealed;
}
public:
virtual property MessageType ServerLogLevel {
    MessageType get () sealed;
    void set (MessageType value) sealed;
}
abstract ServerLogLevel : MessageType with get, set
override ServerLogLevel : MessageType with get, set
abstract ServerLogLevel : MessageType with get, set
override ServerLogLevel : MessageType with get, set

Property Value

Type: MessageType

Implements

IGlue ServerLogLevel
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.ServerMsgInspectors Property

NOPGlue ServerMsgInspectors Property NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderedRegistry<IServerMsgInspector> ServerMsgInspectors { get; }
public OrderedRegistry<IServerMsgInspector> ServerMsgInspectors { get; }
Public ReadOnly Property ServerMsgInspectors As OrderedRegistry(Of IServerMsgInspector)
    Get
Public ReadOnly Property ServerMsgInspectors As OrderedRegistry(Of IServerMsgInspector)
    Get
public:
virtual property OrderedRegistry<IServerMsgInspector^>^ ServerMsgInspectors {
    OrderedRegistry<IServerMsgInspector^>^ get () sealed;
}
public:
virtual property OrderedRegistry<IServerMsgInspector^>^ ServerMsgInspectors {
    OrderedRegistry<IServerMsgInspector^>^ get () sealed;
}
abstract ServerMsgInspectors : OrderedRegistry<IServerMsgInspector> with get
override ServerMsgInspectors : OrderedRegistry<IServerMsgInspector> with get
abstract ServerMsgInspectors : OrderedRegistry<IServerMsgInspector> with get
override ServerMsgInspectors : OrderedRegistry<IServerMsgInspector> with get

Property Value

Type: OrderedRegistry IServerMsgInspector

Implements

IGlue ServerMsgInspectors
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.Servers Property

NOPGlue Servers Property NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<ServerEndPoint> Servers { get; }
public IRegistry<ServerEndPoint> Servers { get; }
Public ReadOnly Property Servers As IRegistry(Of ServerEndPoint)
    Get
Public ReadOnly Property Servers As IRegistry(Of ServerEndPoint)
    Get
public:
virtual property IRegistry<ServerEndPoint^>^ Servers {
    IRegistry<ServerEndPoint^>^ get () sealed;
}
public:
virtual property IRegistry<ServerEndPoint^>^ Servers {
    IRegistry<ServerEndPoint^>^ get () sealed;
}
abstract Servers : IRegistry<ServerEndPoint> with get
override Servers : IRegistry<ServerEndPoint> with get
abstract Servers : IRegistry<ServerEndPoint> with get
override Servers : IRegistry<ServerEndPoint> with get

Property Value

Type: IRegistry ServerEndPoint

Implements

IGlue Servers
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.ServersConfigurationSection Property

NOPGlue ServersConfigurationSection Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IConfigSectionNode ServersConfigurationSection { get; }
public IConfigSectionNode ServersConfigurationSection { get; }
Public ReadOnly Property ServersConfigurationSection As IConfigSectionNode
    Get
Public ReadOnly Property ServersConfigurationSection As IConfigSectionNode
    Get
public:
virtual property IConfigSectionNode^ ServersConfigurationSection {
    IConfigSectionNode^ get () sealed;
}
public:
virtual property IConfigSectionNode^ ServersConfigurationSection {
    IConfigSectionNode^ get () sealed;
}
abstract ServersConfigurationSection : IConfigSectionNode with get
override ServersConfigurationSection : IConfigSectionNode with get
abstract ServersConfigurationSection : IConfigSectionNode with get
override ServersConfigurationSection : IConfigSectionNode with get

Property Value

Type: IConfigSectionNode

Implements

IGlueImplementation ServersConfigurationSection
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


NOPGlue.TimeLocation Property

NOPGlue TimeLocation Property NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeLocation TimeLocation { get; }
public TimeLocation TimeLocation { get; }
Public ReadOnly Property TimeLocation As TimeLocation
    Get
Public ReadOnly Property TimeLocation As TimeLocation
    Get
public:
virtual property TimeLocation^ TimeLocation {
    TimeLocation^ get () sealed;
}
public:
virtual property TimeLocation^ TimeLocation {
    TimeLocation^ get () sealed;
}
abstract TimeLocation : TimeLocation with get
override TimeLocation : TimeLocation with get
abstract TimeLocation : TimeLocation with get
override TimeLocation : TimeLocation with get

Property Value

Type: TimeLocation

Implements

ILocalizedTimeProvider TimeLocation
See Also
NOPGlue Class
NOPGlue Members
NFX.Glue Namespace


OneWayAttribute Class

OneWayAttribute Class NFX Class Library

Decorates methods that do not generate response message after execution. They must return void and if exception occurs it is not reported to the caller
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.Glue OneWayAttribute

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.Method, Inherited = false, AllowMultiple = false)]
public class OneWayAttribute : Attribute
[AttributeUsageAttribute(AttributeTargets.Method, Inherited = false, AllowMultiple = false)]
public class OneWayAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Method, Inherited := false, AllowMultiple := false)>
Public Class OneWayAttribute
    Inherits Attribute
<AttributeUsageAttribute(AttributeTargets.Method, Inherited := false, AllowMultiple := false)>
Public Class OneWayAttribute
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Method, Inherited = false, AllowMultiple = false)]
public ref class OneWayAttribute : public Attribute
[AttributeUsageAttribute(AttributeTargets::Method, Inherited = false, AllowMultiple = false)]
public ref class OneWayAttribute : public Attribute
[<AttributeUsageAttribute(AttributeTargets.Method, Inherited = false, AllowMultiple = false)>]
type OneWayAttribute =
    class
        inherit Attribute
    end
[<AttributeUsageAttribute(AttributeTargets.Method, Inherited = false, AllowMultiple = false)>]
type OneWayAttribute =
    class
        inherit Attribute
    end
See Also
OneWayAttribute Members
NFX.Glue Namespace


OneWayAttribute Members

OneWayAttribute Members NFX Class Library

The OneWayAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | OneWayAttribute | Initializes a new instance of the OneWayAttribute class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
OneWayAttribute Class
NFX.Glue Namespace


OneWayAttribute Constructor

OneWayAttribute Constructor NFX Class Library

Initializes a new instance of the OneWayAttribute class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OneWayAttribute()
public OneWayAttribute()
Public Sub New
Public Sub New
public:
OneWayAttribute()
public:
OneWayAttribute()
new : unit -> OneWayAttribute
new : unit -> OneWayAttribute
See Also
OneWayAttribute Class
OneWayAttribute Members
NFX.Glue Namespace


OneWayAttribute Methods

OneWayAttribute Methods NFX Class Library

The OneWayAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
OneWayAttribute Class
NFX.Glue Namespace


OneWayAttribute Properties

OneWayAttribute Properties NFX Class Library

The OneWayAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
OneWayAttribute Class
NFX.Glue Namespace


OperationFlow Enumeration

OperationFlow Enumeration NFX Class Library

Stipulates operation flow kind - sync/async

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum OperationFlow
public enum OperationFlow
Public Enumeration OperationFlow
Public Enumeration OperationFlow
public enum class OperationFlow
public enum class OperationFlow
type OperationFlow
type OperationFlow
Members
Member name | Value | Description
Synchronous | 0 | Every operation blocks until it is completed or times out
Asynchronous | 1 | Operations do not block and use reactor to correlate request/responses
See Also
NFX.Glue Namespace


ProtocolException Class

ProtocolException Class NFX Class Library

Exception thrown when there are protocol-related errors like deserialization, request message received when response is expected
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Glue GlueException
NFX.Glue ProtocolException
NFX.Glue MessageSizeException

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ProtocolException : GlueException
[SerializableAttribute]
public class ProtocolException : GlueException
<SerializableAttribute>
Public Class ProtocolException
    Inherits GlueException
<SerializableAttribute>
Public Class ProtocolException
    Inherits GlueException
[SerializableAttribute]
public ref class ProtocolException : public GlueException
[SerializableAttribute]
public ref class ProtocolException : public GlueException
[<SerializableAttribute>]
type ProtocolException =
    class
        inherit GlueException
    end
[<SerializableAttribute>]
type ProtocolException =
    class
        inherit GlueException
    end
See Also
ProtocolException Members
NFX.Glue Namespace


ProtocolException Members

ProtocolException Members NFX Class Library

The ProtocolException type exposes the following members.
Constructors
 | Name | Description
Public method | ProtocolException(Boolean) | Initializes a new instance of the ProtocolException class
Protected method | ProtocolException(SerializationInfo, StreamingContext) | Initializes a new instance of the ProtocolException class
Public method | ProtocolException(String, Boolean) | Initializes a new instance of the ProtocolException class
Public method | ProtocolException(String, Exception, Boolean) | Initializes a new instance of the ProtocolException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | CloseChannel | Returns true when error is not recoverable on the existing channel and it needs to be closed
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ProtocolException Class
NFX.Glue Namespace


ProtocolException Constructor

ProtocolException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ProtocolException(Boolean) | Initializes a new instance of the ProtocolException class
Protected method | ProtocolException(SerializationInfo, StreamingContext) | Initializes a new instance of the ProtocolException class
Public method | ProtocolException(String, Boolean) | Initializes a new instance of the ProtocolException class
Public method | ProtocolException(String, Exception, Boolean) | Initializes a new instance of the ProtocolException class
Back to Top
See Also
ProtocolException Class
ProtocolException Members
NFX.Glue Namespace


ProtocolException Constructor (Boolean)

ProtocolException Constructor (Boolean) NFX Class Library

Initializes a new instance of the ProtocolException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ProtocolException(
    bool closeChannel = false
)
public ProtocolException(
    bool closeChannel = false
)
Public Sub New (
    Optional closeChannel As Boolean = false
)
Public Sub New (
    Optional closeChannel As Boolean = false
)
public:
ProtocolException(
    bool closeChannel = false
)
public:
ProtocolException(
    bool closeChannel = false
)
new :
        ?closeChannel : bool
(* Defaults:
        let _closeChannel = defaultArg closeChannel false
*)
-> ProtocolException
new :
        ?closeChannel : bool
(* Defaults:
        let _closeChannel = defaultArg closeChannel false
*)
-> ProtocolException

Parameters

closeChannel (Optional)
Type: Online System Boolean
See Also
ProtocolException Class
ProtocolException Members
ProtocolException Overload
NFX.Glue Namespace


ProtocolException Constructor (SerializationInfo, StreamingContext)

ProtocolException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ProtocolException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ProtocolException(
    SerializationInfo info,
    StreamingContext context
)
protected ProtocolException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
ProtocolException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
ProtocolException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ProtocolException
new :
        info : SerializationInfo *
        context : StreamingContext -> ProtocolException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
ProtocolException Class
ProtocolException Members
ProtocolException Overload
NFX.Glue Namespace


ProtocolException Constructor (String, Boolean)

ProtocolException Constructor (String, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ProtocolException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ProtocolException(
    string message,
    bool closeChannel = false
)
public ProtocolException(
    string message,
    bool closeChannel = false
)
Public Sub New (
    message As String,
    Optional closeChannel As Boolean = false
)
Public Sub New (
    message As String,
    Optional closeChannel As Boolean = false
)
public:
ProtocolException(
    String^ message,
    bool closeChannel = false
)
public:
ProtocolException(
    String^ message,
    bool closeChannel = false
)
new :
        message : string *
        ?closeChannel : bool
(* Defaults:
        let _closeChannel = defaultArg closeChannel false
*)
-> ProtocolException
new :
        message : string *
        ?closeChannel : bool
(* Defaults:
        let _closeChannel = defaultArg closeChannel false
*)
-> ProtocolException

Parameters

message
Type: Online System String
closeChannel (Optional)
Type: Online System Boolean
See Also
ProtocolException Class
ProtocolException Members
ProtocolException Overload
NFX.Glue Namespace


ProtocolException Constructor (String, Exception, Boolean)

ProtocolException Constructor (String, Exception, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ProtocolException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ProtocolException(
    string message,
    Exception inner,
    bool closeChannel = false
)
public ProtocolException(
    string message,
    Exception inner,
    bool closeChannel = false
)
Public Sub New (
    message As String,
    inner As Exception,
    Optional closeChannel As Boolean = false
)
Public Sub New (
    message As String,
    inner As Exception,
    Optional closeChannel As Boolean = false
)
public:
ProtocolException(
    String^ message,
    Exception^ inner,
    bool closeChannel = false
)
public:
ProtocolException(
    String^ message,
    Exception^ inner,
    bool closeChannel = false
)
new :
        message : string *
        inner : Exception *
        ?closeChannel : bool
(* Defaults:
        let _closeChannel = defaultArg closeChannel false
*)
-> ProtocolException
new :
        message : string *
        inner : Exception *
        ?closeChannel : bool
(* Defaults:
        let _closeChannel = defaultArg closeChannel false
*)
-> ProtocolException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
closeChannel (Optional)
Type: Online System Boolean
See Also
ProtocolException Class
ProtocolException Members
ProtocolException Overload
NFX.Glue Namespace


ProtocolException Methods

ProtocolException Methods NFX Class Library

The ProtocolException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
ProtocolException Class
NFX.Glue Namespace


ProtocolException Properties

ProtocolException Properties NFX Class Library

The ProtocolException type exposes the following members.
Properties
 | Name | Description
Public property | CloseChannel | Returns true when error is not recoverable on the existing channel and it needs to be closed
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
ProtocolException Class
NFX.Glue Namespace


ProtocolException.CloseChannel Property

ProtocolException CloseChannel Property NFX Class Library

Returns true when error is not recoverable on the existing channel and it needs to be closed

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool CloseChannel { get; }
public bool CloseChannel { get; }
Public ReadOnly Property CloseChannel As Boolean
    Get
Public ReadOnly Property CloseChannel As Boolean
    Get
public:
property bool CloseChannel {
    bool get ();
}
public:
property bool CloseChannel {
    bool get ();
}
member CloseChannel : bool with get
member CloseChannel : bool with get

Property Value

Type: Online Boolean
See Also
ProtocolException Class
ProtocolException Members
NFX.Glue Namespace


ProtocolException Events

ProtocolException Events NFX Class Library

The ProtocolException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ProtocolException Class
NFX.Glue Namespace


Provider Class

Provider Class NFX Class Library

Represents a base type for providers - providers are facades for some low-level implementation that transports use, for example ZeroMQ.
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service IGlueImplementation
NFX.ServiceModel ServiceWithInstrumentationBase IGlueImplementation
NFX.Glue GlueComponentService
NFX.Glue Provider

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Provider : GlueComponentService
public abstract class Provider : GlueComponentService
Public MustInherit Class Provider
    Inherits GlueComponentService
Public MustInherit Class Provider
    Inherits GlueComponentService
public ref class Provider abstract : public GlueComponentService
public ref class Provider abstract : public GlueComponentService
[<AbstractClassAttribute>]
type Provider =
    class
        inherit GlueComponentService
    end
[<AbstractClassAttribute>]
type Provider =
    class
        inherit GlueComponentService
    end
See Also
Provider Members
NFX.Glue Namespace


Provider Members

Provider Members NFX Class Library

The Provider type exposes the following members.
Constructors
 | Name | Description
Protected method | Provider(String) | Initializes a new instance of the Provider class
Protected method | Provider(IGlueImplementation, String) | Initializes a new instance of the Provider class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Overrides Service Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | WriteLog | (Inherited from GlueComponentService.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | Glue | (Inherited from GlueComponentService.)
Public property | InstrumentationEnabled | Implements IInstrumentable (Inherited from GlueComponentService.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
Provider Class
NFX.Glue Namespace


Provider Constructor

Provider Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | Provider(String) | Initializes a new instance of the Provider class
Protected method | Provider(IGlueImplementation, String) | Initializes a new instance of the Provider class
Back to Top
See Also
Provider Class
Provider Members
NFX.Glue Namespace


Provider Constructor (String)

Provider Constructor (String) NFX Class Library

Initializes a new instance of the Provider class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Provider(
    string name
)
protected Provider(
    string name
)
Protected Sub New (
    name As String
)
Protected Sub New (
    name As String
)
protected:
Provider(
    String^ name
)
protected:
Provider(
    String^ name
)
new :
        name : string -> Provider
new :
        name : string -> Provider

Parameters

name
Type: Online System String
See Also
Provider Class
Provider Members
Provider Overload
NFX.Glue Namespace


Provider Constructor (IGlueImplementation, String)

Provider Constructor (IGlueImplementation, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Provider class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Provider(
    IGlueImplementation glue,
    string name = null
)
protected Provider(
    IGlueImplementation glue,
    string name = null
)
Protected Sub New (
    glue As IGlueImplementation,
    Optional name As String = Nothing
)
Protected Sub New (
    glue As IGlueImplementation,
    Optional name As String = Nothing
)
protected:
Provider(
    IGlueImplementation^ glue,
    String^ name = nullptr
)
protected:
Provider(
    IGlueImplementation^ glue,
    String^ name = nullptr
)
new :
        glue : IGlueImplementation *
        ?name : string
(* Defaults:
        let _name = defaultArg name null
*)
-> Provider
new :
        glue : IGlueImplementation *
        ?name : string
(* Defaults:
        let _name = defaultArg name null
*)
-> Provider

Parameters

glue
Type: NFX.Glue IGlueImplementation
name (Optional)
Type: Online System String
See Also
Provider Class
Provider Members
Provider Overload
NFX.Glue Namespace


Provider Methods

Provider Methods NFX Class Library

The Provider type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Overrides Service Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | WriteLog | (Inherited from GlueComponentService.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Provider Class
NFX.Glue Namespace


Provider.Destructor Method

Provider Destructor Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
Provider Class
Provider Members
NFX.Glue Namespace


Provider Properties

Provider Properties NFX Class Library

The Provider type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | Glue | (Inherited from GlueComponentService.)
Public property | InstrumentationEnabled | Implements IInstrumentable (Inherited from GlueComponentService.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
Provider Class
NFX.Glue Namespace


Providers Class

Providers Class NFX Class Library

A registry of Provider-derived instances
Inheritance Hierarchy
Online System Object
NFX Registry Provider
NFX.Glue Providers

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Providers : Registry<Provider>
public sealed class Providers : Registry<Provider>
Public NotInheritable Class Providers
    Inherits Registry(Of Provider)
Public NotInheritable Class Providers
    Inherits Registry(Of Provider)
public ref class Providers sealed : public Registry<Provider^>
public ref class Providers sealed : public Registry<Provider^>
[<SealedAttribute>]
type Providers =
    class
        inherit Registry<Provider>
    end
[<SealedAttribute>]
type Providers =
    class
        inherit Registry<Provider>
    end
See Also
Providers Members
NFX.Glue Namespace


Providers Members

Providers Members NFX Class Library

The Providers type exposes the following members.
Constructors
 | Name | Description
Public method | Providers | Initializes a new instance of the Providers class
Back to Top
Methods
 | Name | Description
Public method | Clear | Deletes all items from registry (Inherited from Registry T .)
Public method | ContainsName | (Inherited from Registry T .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | (Inherited from Registry T .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetOrRegister TContext (String, Func TContext, T , TContext) | Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency (Inherited from Registry T .)
Public method | GetOrRegister TContext (String, Func TContext, T , TContext, Boolean ) | Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency (Inherited from Registry T .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | JustRegistered | (Inherited from Registry T .)
Protected method | JustReplaced | (Inherited from Registry T .)
Protected method | JustUnregistered | (Inherited from Registry T .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Register | Registers item and returns true if it was registered, false if this named instance already existed in the list (Inherited from Registry T .)
Public method | RegisterOrReplace(T) | Registers item and returns true if it was registered, false if this named instance already existed and was replaced (Inherited from Registry T .)
Public method | RegisterOrReplace(T, T ) | Registers item and returns true if it was registered, false if this named instance already existed and was replaced (Inherited from Registry T .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryGetValue | (Inherited from Registry T .)
Public method | Unregister(String) | Unregisters item by name and returns true if it was unregistered, false if it did not exist (Inherited from Registry T .)
Public method | Unregister(T) | Unregisters item and returns true if it was unregistered, false if it did not exist (Inherited from Registry T .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Sync | (Inherited from Registry T .)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns the number of entries in the registry (Inherited from Registry T .)
Public property | IsCaseSensitive | Returns true if the instance differentiates names by case (Inherited from Registry T .)
Public property | Item | Returns a value by name or null if not found (Inherited from Registry T .)
Public property | Names | (Inherited from Registry T .)
Public property | Values | (Inherited from Registry T .)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Registry T .)
Back to Top
See Also
Providers Class
NFX.Glue Namespace


Providers Constructor

Providers Constructor NFX Class Library

Initializes a new instance of the Providers class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Providers()
public Providers()
Public Sub New
Public Sub New
public:
Providers()
public:
Providers()
new : unit -> Providers
new : unit -> Providers
See Also
Providers Class
Providers Members
NFX.Glue Namespace


Providers Fields

Providers Fields NFX Class Library

The Providers type exposes the following members.
Fields
 | Name | Description
Protected field | m_Sync | (Inherited from Registry T .)
Back to Top
See Also
Providers Class
NFX.Glue Namespace


Providers Methods

Providers Methods NFX Class Library

The Providers type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Deletes all items from registry (Inherited from Registry T .)
Public method | ContainsName | (Inherited from Registry T .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | (Inherited from Registry T .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetOrRegister TContext (String, Func TContext, T , TContext) | Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency (Inherited from Registry T .)
Public method | GetOrRegister TContext (String, Func TContext, T , TContext, Boolean ) | Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency (Inherited from Registry T .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | JustRegistered | (Inherited from Registry T .)
Protected method | JustReplaced | (Inherited from Registry T .)
Protected method | JustUnregistered | (Inherited from Registry T .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Register | Registers item and returns true if it was registered, false if this named instance already existed in the list (Inherited from Registry T .)
Public method | RegisterOrReplace(T) | Registers item and returns true if it was registered, false if this named instance already existed and was replaced (Inherited from Registry T .)
Public method | RegisterOrReplace(T, T ) | Registers item and returns true if it was registered, false if this named instance already existed and was replaced (Inherited from Registry T .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryGetValue | (Inherited from Registry T .)
Public method | Unregister(String) | Unregisters item by name and returns true if it was unregistered, false if it did not exist (Inherited from Registry T .)
Public method | Unregister(T) | Unregisters item and returns true if it was unregistered, false if it did not exist (Inherited from Registry T .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Registry T .)
Back to Top
See Also
Providers Class
NFX.Glue Namespace


Providers Properties

Providers Properties NFX Class Library

The Providers type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns the number of entries in the registry (Inherited from Registry T .)
Public property | IsCaseSensitive | Returns true if the instance differentiates names by case (Inherited from Registry T .)
Public property | Item | Returns a value by name or null if not found (Inherited from Registry T .)
Public property | Names | (Inherited from Registry T .)
Public property | Values | (Inherited from Registry T .)
Back to Top
See Also
Providers Class
NFX.Glue Namespace


RemoteException Class

RemoteException Class NFX Class Library

Base exception thrown by the Glue framework when remote errors are reported back to caller
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Glue GlueException
NFX.Glue RemoteException

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class RemoteException : GlueException
[SerializableAttribute]
public class RemoteException : GlueException
<SerializableAttribute>
Public Class RemoteException
    Inherits GlueException
<SerializableAttribute>
Public Class RemoteException
    Inherits GlueException
[SerializableAttribute]
public ref class RemoteException : public GlueException
[SerializableAttribute]
public ref class RemoteException : public GlueException
[<SerializableAttribute>]
type RemoteException =
    class
        inherit GlueException
    end
[<SerializableAttribute>]
type RemoteException =
    class
        inherit GlueException
    end
See Also
RemoteException Members
NFX.Glue Namespace


RemoteException Members

RemoteException Members NFX Class Library

The RemoteException type exposes the following members.
Constructors
 | Name | Description
Public method | RemoteException(WrappedExceptionData) | Initializes a new instance of the RemoteException class
Protected method | RemoteException(SerializationInfo, StreamingContext) | Initializes a new instance of the RemoteException class
Public method | RemoteException(String, WrappedExceptionData) | Initializes a new instance of the RemoteException class
Public method | RemoteException(String, WrappedExceptionData, Exception) | Initializes a new instance of the RemoteException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Remote | Returns remote exception data
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
RemoteException Class
NFX.Glue Namespace


RemoteException Constructor

RemoteException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | RemoteException(WrappedExceptionData) | Initializes a new instance of the RemoteException class
Protected method | RemoteException(SerializationInfo, StreamingContext) | Initializes a new instance of the RemoteException class
Public method | RemoteException(String, WrappedExceptionData) | Initializes a new instance of the RemoteException class
Public method | RemoteException(String, WrappedExceptionData, Exception) | Initializes a new instance of the RemoteException class
Back to Top
See Also
RemoteException Class
RemoteException Members
NFX.Glue Namespace


RemoteException Constructor (WrappedExceptionData)

RemoteException Constructor (WrappedExceptionData) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RemoteException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RemoteException(
    WrappedExceptionData data
)
public RemoteException(
    WrappedExceptionData data
)
Public Sub New (
    data As WrappedExceptionData
)
Public Sub New (
    data As WrappedExceptionData
)
public:
RemoteException(
    WrappedExceptionData^ data
)
public:
RemoteException(
    WrappedExceptionData^ data
)
new :
        data : WrappedExceptionData -> RemoteException
new :
        data : WrappedExceptionData -> RemoteException

Parameters

data
Type: NFX WrappedExceptionData
See Also
RemoteException Class
RemoteException Members
RemoteException Overload
NFX.Glue Namespace


RemoteException Constructor (SerializationInfo, StreamingContext)

RemoteException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RemoteException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected RemoteException(
    SerializationInfo info,
    StreamingContext context
)
protected RemoteException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
RemoteException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
RemoteException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> RemoteException
new :
        info : SerializationInfo *
        context : StreamingContext -> RemoteException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
RemoteException Class
RemoteException Members
RemoteException Overload
NFX.Glue Namespace


RemoteException Constructor (String, WrappedExceptionData)

RemoteException Constructor (String, WrappedExceptionData) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RemoteException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RemoteException(
    string message,
    WrappedExceptionData data
)
public RemoteException(
    string message,
    WrappedExceptionData data
)
Public Sub New (
    message As String,
    data As WrappedExceptionData
)
Public Sub New (
    message As String,
    data As WrappedExceptionData
)
public:
RemoteException(
    String^ message,
    WrappedExceptionData^ data
)
public:
RemoteException(
    String^ message,
    WrappedExceptionData^ data
)
new :
        message : string *
        data : WrappedExceptionData -> RemoteException
new :
        message : string *
        data : WrappedExceptionData -> RemoteException

Parameters

message
Type: Online System String
data
Type: NFX WrappedExceptionData
See Also
RemoteException Class
RemoteException Members
RemoteException Overload
NFX.Glue Namespace


RemoteException Constructor (String, WrappedExceptionData, Exception)

RemoteException Constructor (String, WrappedExceptionData, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RemoteException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RemoteException(
    string message,
    WrappedExceptionData data,
    Exception inner
)
public RemoteException(
    string message,
    WrappedExceptionData data,
    Exception inner
)
Public Sub New (
    message As String,
    data As WrappedExceptionData,
    inner As Exception
)
Public Sub New (
    message As String,
    data As WrappedExceptionData,
    inner As Exception
)
public:
RemoteException(
    String^ message,
    WrappedExceptionData^ data,
    Exception^ inner
)
public:
RemoteException(
    String^ message,
    WrappedExceptionData^ data,
    Exception^ inner
)
new :
        message : string *
        data : WrappedExceptionData *
        inner : Exception -> RemoteException
new :
        message : string *
        data : WrappedExceptionData *
        inner : Exception -> RemoteException

Parameters

message
Type: Online System String
data
Type: NFX WrappedExceptionData
inner
Type: Online System Exception
See Also
RemoteException Class
RemoteException Members
RemoteException Overload
NFX.Glue Namespace


RemoteException Methods

RemoteException Methods NFX Class Library

The RemoteException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
RemoteException Class
NFX.Glue Namespace


RemoteException Properties

RemoteException Properties NFX Class Library

The RemoteException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Remote | Returns remote exception data
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
RemoteException Class
NFX.Glue Namespace


RemoteException.Remote Property

RemoteException Remote Property NFX Class Library

Returns remote exception data

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WrappedExceptionData Remote { get; }
public WrappedExceptionData Remote { get; }
Public ReadOnly Property Remote As WrappedExceptionData
    Get
Public ReadOnly Property Remote As WrappedExceptionData
    Get
public:
property WrappedExceptionData^ Remote {
    WrappedExceptionData^ get ();
}
public:
property WrappedExceptionData^ Remote {
    WrappedExceptionData^ get ();
}
member Remote : WrappedExceptionData with get
member Remote : WrappedExceptionData with get

Property Value

Type: WrappedExceptionData
See Also
RemoteException Class
RemoteException Members
NFX.Glue Namespace


RemoteException Events

RemoteException Events NFX Class Library

The RemoteException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
RemoteException Class
NFX.Glue Namespace


ServerCallContext Class

ServerCallContext Class NFX Class Library

Provides access to server call context. Use to access Headers
Inheritance Hierarchy
Online System Object
NFX.Glue ServerCallContext

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class ServerCallContext
public static class ServerCallContext
Public NotInheritable Class ServerCallContext
Public NotInheritable Class ServerCallContext
public ref class ServerCallContext abstract sealed
public ref class ServerCallContext abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ServerCallContext =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ServerCallContext =  class end
See Also
ServerCallContext Members
NFX.Glue Namespace


ServerCallContext Members

ServerCallContext Members NFX Class Library

The ServerCallContext type exposes the following members.
Methods
Name | Description
__ResetThreadLevelContext | Internal framework-only method to clear thread-level context
__SetThreadLevelContext | Internal framework-only method to bind thread-level context
GetResponseHeadersOrNull |
Back to Top
Properties
Name | Description
Request | Returns RequestMsg which is being processed. Access incoming headers through Request.Headers
ResponseHeaders | Returns Headers instance that will be appended to response
Back to Top
See Also
ServerCallContext Class
NFX.Glue Namespace


ServerCallContext Methods

ServerCallContext Methods NFX Class Library

The ServerCallContext type exposes the following members.
Methods
Name | Description
__ResetThreadLevelContext | Internal framework-only method to clear thread-level context
__SetThreadLevelContext | Internal framework-only method to bind thread-level context
GetResponseHeadersOrNull |
Back to Top
See Also
ServerCallContext Class
NFX.Glue Namespace


ServerCallContext.__ResetThreadLevelContext Method

ServerCallContext __ResetThreadLevelContext Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Internal framework-only method to clear thread-level context

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void __ResetThreadLevelContext()
public static void __ResetThreadLevelContext()
Public Shared Sub __ResetThreadLevelContext
Public Shared Sub __ResetThreadLevelContext
public:
static void __ResetThreadLevelContext()
public:
static void __ResetThreadLevelContext()
static member __ResetThreadLevelContext : unit -> unit
static member __ResetThreadLevelContext : unit -> unit
See Also
ServerCallContext Class
ServerCallContext Members
NFX.Glue Namespace


ServerCallContext.__SetThreadLevelContext Method

ServerCallContext __SetThreadLevelContext Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Internal framework-only method to bind thread-level context

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void __SetThreadLevelContext(
    RequestMsg request
)
public static void __SetThreadLevelContext(
    RequestMsg request
)
Public Shared Sub __SetThreadLevelContext (
    request As RequestMsg
)
Public Shared Sub __SetThreadLevelContext (
    request As RequestMsg
)
public:
static void __SetThreadLevelContext(
    RequestMsg^ request
)
public:
static void __SetThreadLevelContext(
    RequestMsg^ request
)
static member __SetThreadLevelContext :
        request : RequestMsg -> unit
static member __SetThreadLevelContext :
        request : RequestMsg -> unit

Parameters

request
Type: NFX.Glue.Protocol RequestMsg
See Also
ServerCallContext Class
ServerCallContext Members
NFX.Glue Namespace


ServerCallContext.GetResponseHeadersOrNull Method

ServerCallContext GetResponseHeadersOrNull Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Headers GetResponseHeadersOrNull()
public static Headers GetResponseHeadersOrNull()
Public Shared Function GetResponseHeadersOrNull As Headers
Public Shared Function GetResponseHeadersOrNull As Headers
public:
static Headers^ GetResponseHeadersOrNull()
public:
static Headers^ GetResponseHeadersOrNull()
static member GetResponseHeadersOrNull : unit -> Headers
static member GetResponseHeadersOrNull : unit -> Headers

Return Value

Type: Headers
See Also
ServerCallContext Class
ServerCallContext Members
NFX.Glue Namespace


ServerCallContext Properties

ServerCallContext Properties NFX Class Library

The ServerCallContext type exposes the following members.
Properties
Name | Description
Request | Returns RequestMsg which is being processed. Access incoming headers through Request.Headers
ResponseHeaders | Returns Headers instance that will be appended to response
Back to Top
See Also
ServerCallContext Class
NFX.Glue Namespace


ServerCallContext.Request Property

ServerCallContext Request Property NFX Class Library

Returns RequestMsg which is being processed. Access incoming headers through Request.Headers

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static RequestMsg Request { get; }
public static RequestMsg Request { get; }
Public Shared ReadOnly Property Request As RequestMsg
    Get
Public Shared ReadOnly Property Request As RequestMsg
    Get
public:
static property RequestMsg^ Request {
    RequestMsg^ get ();
}
public:
static property RequestMsg^ Request {
    RequestMsg^ get ();
}
static member Request : RequestMsg with get
static member Request : RequestMsg with get

Property Value

Type: RequestMsg
See Also
ServerCallContext Class
ServerCallContext Members
NFX.Glue Namespace


ServerCallContext.ResponseHeaders Property

ServerCallContext ResponseHeaders Property NFX Class Library

Returns Headers instance that will be appended to response

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Headers ResponseHeaders { get; }
public static Headers ResponseHeaders { get; }
Public Shared ReadOnly Property ResponseHeaders As Headers
    Get
Public Shared ReadOnly Property ResponseHeaders As Headers
    Get
public:
static property Headers^ ResponseHeaders {
    Headers^ get ();
}
public:
static property Headers^ ResponseHeaders {
    Headers^ get ();
}
static member ResponseHeaders : Headers with get
static member ResponseHeaders : Headers with get

Property Value

Type: Headers
See Also
ServerCallContext Class
ServerCallContext Members
NFX.Glue Namespace


ServerContractException Class

ServerContractException Class NFX Class Library

Exception thrown when server could not get contract
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Glue GlueException
NFX.Glue ServerException
NFX.Glue ServerContractException

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ServerContractException : ServerException
[SerializableAttribute]
public class ServerContractException : ServerException
<SerializableAttribute>
Public Class ServerContractException
    Inherits ServerException
<SerializableAttribute>
Public Class ServerContractException
    Inherits ServerException
[SerializableAttribute]
public ref class ServerContractException : public ServerException
[SerializableAttribute]
public ref class ServerContractException : public ServerException
[<SerializableAttribute>]
type ServerContractException =
    class
        inherit ServerException
    end
[<SerializableAttribute>]
type ServerContractException =
    class
        inherit ServerException
    end
See Also
ServerContractException Members
NFX.Glue Namespace


ServerContractException Members

ServerContractException Members NFX Class Library

The ServerContractException type exposes the following members.
Constructors
 | Name | Description
Public method | ServerContractException | Initializes a new instance of the ServerContractException class
Public method | ServerContractException(String) | Initializes a new instance of the ServerContractException class
Protected method | ServerContractException(SerializationInfo, StreamingContext) | Initializes a new instance of the ServerContractException class
Public method | ServerContractException(String, Exception) | Initializes a new instance of the ServerContractException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ServerContractException Class
NFX.Glue Namespace


ServerContractException Constructor

ServerContractException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ServerContractException | Initializes a new instance of the ServerContractException class
Public method | ServerContractException(String) | Initializes a new instance of the ServerContractException class
Protected method | ServerContractException(SerializationInfo, StreamingContext) | Initializes a new instance of the ServerContractException class
Public method | ServerContractException(String, Exception) | Initializes a new instance of the ServerContractException class
Back to Top
See Also
ServerContractException Class
ServerContractException Members
NFX.Glue Namespace


ServerContractException Constructor

ServerContractException Constructor NFX Class Library

Initializes a new instance of the ServerContractException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerContractException()
public ServerContractException()
Public Sub New
Public Sub New
public:
ServerContractException()
public:
ServerContractException()
new : unit -> ServerContractException
new : unit -> ServerContractException
See Also
ServerContractException Class
ServerContractException Members
ServerContractException Overload
NFX.Glue Namespace


ServerContractException Constructor (String)

ServerContractException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerContractException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerContractException(
    string message
)
public ServerContractException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
ServerContractException(
    String^ message
)
public:
ServerContractException(
    String^ message
)
new :
        message : string -> ServerContractException
new :
        message : string -> ServerContractException

Parameters

message
Type: Online System String
See Also
ServerContractException Class
ServerContractException Members
ServerContractException Overload
NFX.Glue Namespace


ServerContractException Constructor (SerializationInfo, StreamingContext)

ServerContractException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerContractException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerContractException(
    SerializationInfo info,
    StreamingContext context
)
protected ServerContractException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
ServerContractException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
ServerContractException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ServerContractException
new :
        info : SerializationInfo *
        context : StreamingContext -> ServerContractException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
ServerContractException Class
ServerContractException Members
ServerContractException Overload
NFX.Glue Namespace


ServerContractException Constructor (String, Exception)

ServerContractException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerContractException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerContractException(
    string message,
    Exception inner
)
public ServerContractException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
ServerContractException(
    String^ message,
    Exception^ inner
)
public:
ServerContractException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> ServerContractException
new :
        message : string *
        inner : Exception -> ServerContractException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
ServerContractException Class
ServerContractException Members
ServerContractException Overload
NFX.Glue Namespace


ServerContractException Methods

ServerContractException Methods NFX Class Library

The ServerContractException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
ServerContractException Class
NFX.Glue Namespace


ServerContractException Properties

ServerContractException Properties NFX Class Library

The ServerContractException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
ServerContractException Class
NFX.Glue Namespace


ServerContractException Events

ServerContractException Events NFX Class Library

The ServerContractException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ServerContractException Class
NFX.Glue Namespace


ServerEndPoint Class

ServerEndPoint Class NFX Class Library

Represents a server endpoint that accepts client requests. This is a sealed class
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Glue EndPoint
NFX.Glue ServerEndPoint

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ServerEndPoint : EndPoint,
    IConfigurable, INamed
public sealed class ServerEndPoint : EndPoint,
    IConfigurable, INamed
Public NotInheritable Class ServerEndPoint
    Inherits EndPoint
    Implements IConfigurable, INamed
Public NotInheritable Class ServerEndPoint
    Inherits EndPoint
    Implements IConfigurable, INamed
public ref class ServerEndPoint sealed : public EndPoint,
    IConfigurable, INamed
public ref class ServerEndPoint sealed : public EndPoint,
    IConfigurable, INamed
[<SealedAttribute>]
type ServerEndPoint =
    class
        inherit EndPoint
        interface IConfigurable
        interface INamed
    end
[<SealedAttribute>]
type ServerEndPoint =
    class
        inherit EndPoint
        interface IConfigurable
        interface INamed
    end
See Also
ServerEndPoint Members
NFX.Glue Namespace


ServerEndPoint Members

ServerEndPoint Members NFX Class Library

The ServerEndPoint type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerEndPoint(IGlueImplementation, String) | Initializes a new instance of the ServerEndPoint class
Public method | ServerEndPoint(String, IEnumerable Type , Binding) | Initializes a new instance of the ServerEndPoint class
Public method | ServerEndPoint(Node, IEnumerable Type , Binding) | Initializes a new instance of the ServerEndPoint class
Public method | ServerEndPoint(String, Node, IEnumerable Type , Binding) | Initializes a new instance of the ServerEndPoint class
Public method | ServerEndPoint(String, String, IEnumerable Type , Binding) | Initializes a new instance of the ServerEndPoint class
Public method | ServerEndPoint(IGlue, Node, IEnumerable Type , Binding) | Initializes a new instance of the ServerEndPoint class
Public method | ServerEndPoint(IGlue, String, IEnumerable Type , Binding) | Initializes a new instance of the ServerEndPoint class
Public method | ServerEndPoint(IGlue, String, Node, IEnumerable Type , Binding) | Initializes a new instance of the ServerEndPoint class
Public method | ServerEndPoint(IGlue, String, String, IEnumerable Type , Binding) | Initializes a new instance of the ServerEndPoint class
Back to Top
Methods
 | Name | Description
Public method | Close |
Public method | Configure |
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | Opens endpoint by allocating transports (if necessary). ServerEndpoint can be Close() or Dispose() after it was open
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | CONFIG_BINDING_ATTR |
 | CONFIG_CONTRACT_SERVERS_ATTR |
 | CONFIG_NAME_ATTR |
 | CONFIG_NODE_ATTR |
Protected field | m_Binding | (Inherited from EndPoint.)
Protected field | m_ContractImplementers | INTERNAL! Maps ContractType -> ServerImplementing class. This is a cache used not to recompute everything on every call
Protected field | m_Glue | (Inherited from EndPoint.)
Protected field | m_Node | (Inherited from EndPoint.)
Back to Top
Properties
 | Name | Description
Public property | Binding | Returns a binding of this endpoint. "B" component of the "ABC" rule (Inherited from EndPoint.)
Public property | ContractServers | Returns types that implement/serve contracts that this endpoint accepts
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Glue | References glue that this endpoint works under (Inherited from EndPoint.)
Public property | IsOpen | Indicates whether endpoint is open and is accepting incoming requests
Public property | MsgInspectors | Returns server message inspectors for this instance
Public property | Name | Returns name of the endpoint. Named endpoints must be unique in the context, if name was not supplied in .ctor then it is auto-generated
Public property | Node | Returns a node of this endpoint. "A" component of the "ABC" rule (Inherited from EndPoint.)
Public property | Transport | Returns server transport that services this endpoint
Back to Top
See Also
ServerEndPoint Class
NFX.Glue Namespace


ServerEndPoint Constructor

ServerEndPoint Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | ServerEndPoint(IGlueImplementation, String) | Initializes a new instance of the ServerEndPoint class
Public method | ServerEndPoint(String, IEnumerable Type , Binding) | Initializes a new instance of the ServerEndPoint class
Public method | ServerEndPoint(Node, IEnumerable Type , Binding) | Initializes a new instance of the ServerEndPoint class
Public method | ServerEndPoint(String, Node, IEnumerable Type , Binding) | Initializes a new instance of the ServerEndPoint class
Public method | ServerEndPoint(String, String, IEnumerable Type , Binding) | Initializes a new instance of the ServerEndPoint class
Public method | ServerEndPoint(IGlue, Node, IEnumerable Type , Binding) | Initializes a new instance of the ServerEndPoint class
Public method | ServerEndPoint(IGlue, String, IEnumerable Type , Binding) | Initializes a new instance of the ServerEndPoint class
Public method | ServerEndPoint(IGlue, String, Node, IEnumerable Type , Binding) | Initializes a new instance of the ServerEndPoint class
Public method | ServerEndPoint(IGlue, String, String, IEnumerable Type , Binding) | Initializes a new instance of the ServerEndPoint class
Back to Top
See Also
ServerEndPoint Class
ServerEndPoint Members
NFX.Glue Namespace


ServerEndPoint Constructor (IGlueImplementation, String)

ServerEndPoint Constructor (IGlueImplementation, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerEndPoint class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ServerEndPoint(
    IGlueImplementation glue,
    string name
)
internal ServerEndPoint(
    IGlueImplementation glue,
    string name
)
Friend Sub New (
    glue As IGlueImplementation,
    name As String
)
Friend Sub New (
    glue As IGlueImplementation,
    name As String
)
internal:
ServerEndPoint(
    IGlueImplementation^ glue,
    String^ name
)
internal:
ServerEndPoint(
    IGlueImplementation^ glue,
    String^ name
)
new :
        glue : IGlueImplementation *
        name : string -> ServerEndPoint
new :
        glue : IGlueImplementation *
        name : string -> ServerEndPoint

Parameters

glue
Type: NFX.Glue IGlueImplementation
name
Type: Online System String
See Also
ServerEndPoint Class
ServerEndPoint Members
ServerEndPoint Overload
NFX.Glue Namespace


ServerEndPoint Constructor (String, IEnumerable(Type), Binding)

ServerEndPoint Constructor (String, IEnumerable Type , Binding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerEndPoint class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerEndPoint(
    string node,
    IEnumerable<Type> contractServers,
    Binding binding = null
)
public ServerEndPoint(
    string node,
    IEnumerable<Type> contractServers,
    Binding binding = null
)
Public Sub New (
    node As String,
    contractServers As IEnumerable(Of Type),
    Optional binding As Binding = Nothing
)
Public Sub New (
    node As String,
    contractServers As IEnumerable(Of Type),
    Optional binding As Binding = Nothing
)
public:
ServerEndPoint(
    String^ node,
    IEnumerable<Type^>^ contractServers,
    Binding^ binding = nullptr
)
public:
ServerEndPoint(
    String^ node,
    IEnumerable<Type^>^ contractServers,
    Binding^ binding = nullptr
)
new :
        node : string *
        contractServers : IEnumerable<Type> *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> ServerEndPoint
new :
        node : string *
        contractServers : IEnumerable<Type> *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> ServerEndPoint

Parameters

node
Type: Online System String
contractServers
Type: Online System.Collections.Generic IEnumerable Online Type
binding (Optional)
Type: NFX.Glue Binding
See Also
ServerEndPoint Class
ServerEndPoint Members
ServerEndPoint Overload
NFX.Glue Namespace


ServerEndPoint Constructor (Node, IEnumerable(Type), Binding)

ServerEndPoint Constructor (Node, IEnumerable Type , Binding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerEndPoint class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerEndPoint(
    Node node,
    IEnumerable<Type> contractServers,
    Binding binding = null
)
public ServerEndPoint(
    Node node,
    IEnumerable<Type> contractServers,
    Binding binding = null
)
Public Sub New (
    node As Node,
    contractServers As IEnumerable(Of Type),
    Optional binding As Binding = Nothing
)
Public Sub New (
    node As Node,
    contractServers As IEnumerable(Of Type),
    Optional binding As Binding = Nothing
)
public:
ServerEndPoint(
    Node node,
    IEnumerable<Type^>^ contractServers,
    Binding^ binding = nullptr
)
public:
ServerEndPoint(
    Node node,
    IEnumerable<Type^>^ contractServers,
    Binding^ binding = nullptr
)
new :
        node : Node *
        contractServers : IEnumerable<Type> *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> ServerEndPoint
new :
        node : Node *
        contractServers : IEnumerable<Type> *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> ServerEndPoint

Parameters

node
Type: NFX.Glue Node
contractServers
Type: Online System.Collections.Generic IEnumerable Online Type
binding (Optional)
Type: NFX.Glue Binding
See Also
ServerEndPoint Class
ServerEndPoint Members
ServerEndPoint Overload
NFX.Glue Namespace


ServerEndPoint Constructor (String, Node, IEnumerable(Type), Binding)

ServerEndPoint Constructor (String, Node, IEnumerable Type , Binding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerEndPoint class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerEndPoint(
    string name,
    Node node,
    IEnumerable<Type> contractServers,
    Binding binding = null
)
public ServerEndPoint(
    string name,
    Node node,
    IEnumerable<Type> contractServers,
    Binding binding = null
)
Public Sub New (
    name As String,
    node As Node,
    contractServers As IEnumerable(Of Type),
    Optional binding As Binding = Nothing
)
Public Sub New (
    name As String,
    node As Node,
    contractServers As IEnumerable(Of Type),
    Optional binding As Binding = Nothing
)
public:
ServerEndPoint(
    String^ name,
    Node node,
    IEnumerable<Type^>^ contractServers,
    Binding^ binding = nullptr
)
public:
ServerEndPoint(
    String^ name,
    Node node,
    IEnumerable<Type^>^ contractServers,
    Binding^ binding = nullptr
)
new :
        name : string *
        node : Node *
        contractServers : IEnumerable<Type> *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> ServerEndPoint
new :
        name : string *
        node : Node *
        contractServers : IEnumerable<Type> *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> ServerEndPoint

Parameters

name
Type: Online System String
node
Type: NFX.Glue Node
contractServers
Type: Online System.Collections.Generic IEnumerable Online Type
binding (Optional)
Type: NFX.Glue Binding
See Also
ServerEndPoint Class
ServerEndPoint Members
ServerEndPoint Overload
NFX.Glue Namespace


ServerEndPoint Constructor (String, String, IEnumerable(Type), Binding)

ServerEndPoint Constructor (String, String, IEnumerable Type , Binding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerEndPoint class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerEndPoint(
    string name,
    string node,
    IEnumerable<Type> contractServers,
    Binding binding = null
)
public ServerEndPoint(
    string name,
    string node,
    IEnumerable<Type> contractServers,
    Binding binding = null
)
Public Sub New (
    name As String,
    node As String,
    contractServers As IEnumerable(Of Type),
    Optional binding As Binding = Nothing
)
Public Sub New (
    name As String,
    node As String,
    contractServers As IEnumerable(Of Type),
    Optional binding As Binding = Nothing
)
public:
ServerEndPoint(
    String^ name,
    String^ node,
    IEnumerable<Type^>^ contractServers,
    Binding^ binding = nullptr
)
public:
ServerEndPoint(
    String^ name,
    String^ node,
    IEnumerable<Type^>^ contractServers,
    Binding^ binding = nullptr
)
new :
        name : string *
        node : string *
        contractServers : IEnumerable<Type> *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> ServerEndPoint
new :
        name : string *
        node : string *
        contractServers : IEnumerable<Type> *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> ServerEndPoint

Parameters

name
Type: Online System String
node
Type: Online System String
contractServers
Type: Online System.Collections.Generic IEnumerable Online Type
binding (Optional)
Type: NFX.Glue Binding
See Also
ServerEndPoint Class
ServerEndPoint Members
ServerEndPoint Overload
NFX.Glue Namespace


ServerEndPoint Constructor (IGlue, Node, IEnumerable(Type), Binding)

ServerEndPoint Constructor (IGlue, Node, IEnumerable Type , Binding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerEndPoint class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerEndPoint(
    IGlue glue,
    Node node,
    IEnumerable<Type> contractServers,
    Binding binding = null
)
public ServerEndPoint(
    IGlue glue,
    Node node,
    IEnumerable<Type> contractServers,
    Binding binding = null
)
Public Sub New (
    glue As IGlue,
    node As Node,
    contractServers As IEnumerable(Of Type),
    Optional binding As Binding = Nothing
)
Public Sub New (
    glue As IGlue,
    node As Node,
    contractServers As IEnumerable(Of Type),
    Optional binding As Binding = Nothing
)
public:
ServerEndPoint(
    IGlue^ glue,
    Node node,
    IEnumerable<Type^>^ contractServers,
    Binding^ binding = nullptr
)
public:
ServerEndPoint(
    IGlue^ glue,
    Node node,
    IEnumerable<Type^>^ contractServers,
    Binding^ binding = nullptr
)
new :
        glue : IGlue *
        node : Node *
        contractServers : IEnumerable<Type> *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> ServerEndPoint
new :
        glue : IGlue *
        node : Node *
        contractServers : IEnumerable<Type> *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> ServerEndPoint

Parameters

glue
Type: NFX.Glue IGlue
node
Type: NFX.Glue Node
contractServers
Type: Online System.Collections.Generic IEnumerable Online Type
binding (Optional)
Type: NFX.Glue Binding
See Also
ServerEndPoint Class
ServerEndPoint Members
ServerEndPoint Overload
NFX.Glue Namespace


ServerEndPoint Constructor (IGlue, String, IEnumerable(Type), Binding)

ServerEndPoint Constructor (IGlue, String, IEnumerable Type , Binding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerEndPoint class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerEndPoint(
    IGlue glue,
    string node,
    IEnumerable<Type> contractServers,
    Binding binding = null
)
public ServerEndPoint(
    IGlue glue,
    string node,
    IEnumerable<Type> contractServers,
    Binding binding = null
)
Public Sub New (
    glue As IGlue,
    node As String,
    contractServers As IEnumerable(Of Type),
    Optional binding As Binding = Nothing
)
Public Sub New (
    glue As IGlue,
    node As String,
    contractServers As IEnumerable(Of Type),
    Optional binding As Binding = Nothing
)
public:
ServerEndPoint(
    IGlue^ glue,
    String^ node,
    IEnumerable<Type^>^ contractServers,
    Binding^ binding = nullptr
)
public:
ServerEndPoint(
    IGlue^ glue,
    String^ node,
    IEnumerable<Type^>^ contractServers,
    Binding^ binding = nullptr
)
new :
        glue : IGlue *
        node : string *
        contractServers : IEnumerable<Type> *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> ServerEndPoint
new :
        glue : IGlue *
        node : string *
        contractServers : IEnumerable<Type> *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> ServerEndPoint

Parameters

glue
Type: NFX.Glue IGlue
node
Type: Online System String
contractServers
Type: Online System.Collections.Generic IEnumerable Online Type
binding (Optional)
Type: NFX.Glue Binding
See Also
ServerEndPoint Class
ServerEndPoint Members
ServerEndPoint Overload
NFX.Glue Namespace


ServerEndPoint Constructor (IGlue, String, Node, IEnumerable(Type), Binding)

ServerEndPoint Constructor (IGlue, String, Node, IEnumerable Type , Binding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerEndPoint class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerEndPoint(
    IGlue glue,
    string name,
    Node node,
    IEnumerable<Type> contractServers,
    Binding binding = null
)
public ServerEndPoint(
    IGlue glue,
    string name,
    Node node,
    IEnumerable<Type> contractServers,
    Binding binding = null
)
Public Sub New (
    glue As IGlue,
    name As String,
    node As Node,
    contractServers As IEnumerable(Of Type),
    Optional binding As Binding = Nothing
)
Public Sub New (
    glue As IGlue,
    name As String,
    node As Node,
    contractServers As IEnumerable(Of Type),
    Optional binding As Binding = Nothing
)
public:
ServerEndPoint(
    IGlue^ glue,
    String^ name,
    Node node,
    IEnumerable<Type^>^ contractServers,
    Binding^ binding = nullptr
)
public:
ServerEndPoint(
    IGlue^ glue,
    String^ name,
    Node node,
    IEnumerable<Type^>^ contractServers,
    Binding^ binding = nullptr
)
new :
        glue : IGlue *
        name : string *
        node : Node *
        contractServers : IEnumerable<Type> *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> ServerEndPoint
new :
        glue : IGlue *
        name : string *
        node : Node *
        contractServers : IEnumerable<Type> *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> ServerEndPoint

Parameters

glue
Type: NFX.Glue IGlue
name
Type: Online System String
node
Type: NFX.Glue Node
contractServers
Type: Online System.Collections.Generic IEnumerable Online Type
binding (Optional)
Type: NFX.Glue Binding
See Also
ServerEndPoint Class
ServerEndPoint Members
ServerEndPoint Overload
NFX.Glue Namespace


ServerEndPoint Constructor (IGlue, String, String, IEnumerable(Type), Binding)

ServerEndPoint Constructor (IGlue, String, String, IEnumerable Type , Binding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerEndPoint class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerEndPoint(
    IGlue glue,
    string name,
    string node,
    IEnumerable<Type> contractServers,
    Binding binding = null
)
public ServerEndPoint(
    IGlue glue,
    string name,
    string node,
    IEnumerable<Type> contractServers,
    Binding binding = null
)
Public Sub New (
    glue As IGlue,
    name As String,
    node As String,
    contractServers As IEnumerable(Of Type),
    Optional binding As Binding = Nothing
)
Public Sub New (
    glue As IGlue,
    name As String,
    node As String,
    contractServers As IEnumerable(Of Type),
    Optional binding As Binding = Nothing
)
public:
ServerEndPoint(
    IGlue^ glue,
    String^ name,
    String^ node,
    IEnumerable<Type^>^ contractServers,
    Binding^ binding = nullptr
)
public:
ServerEndPoint(
    IGlue^ glue,
    String^ name,
    String^ node,
    IEnumerable<Type^>^ contractServers,
    Binding^ binding = nullptr
)
new :
        glue : IGlue *
        name : string *
        node : string *
        contractServers : IEnumerable<Type> *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> ServerEndPoint
new :
        glue : IGlue *
        name : string *
        node : string *
        contractServers : IEnumerable<Type> *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> ServerEndPoint

Parameters

glue
Type: NFX.Glue IGlue
name
Type: Online System String
node
Type: Online System String
contractServers
Type: Online System.Collections.Generic IEnumerable Online Type
binding (Optional)
Type: NFX.Glue Binding
See Also
ServerEndPoint Class
ServerEndPoint Members
ServerEndPoint Overload
NFX.Glue Namespace


ServerEndPoint Fields

ServerEndPoint Fields NFX Class Library

The ServerEndPoint type exposes the following members.
Fields
 | Name | Description
 | CONFIG_BINDING_ATTR |
 | CONFIG_CONTRACT_SERVERS_ATTR |
 | CONFIG_NAME_ATTR |
 | CONFIG_NODE_ATTR |
Protected field | m_Binding | (Inherited from EndPoint.)
Protected field | m_ContractImplementers | INTERNAL! Maps ContractType -> ServerImplementing class. This is a cache used not to recompute everything on every call
Protected field | m_Glue | (Inherited from EndPoint.)
Protected field | m_Node | (Inherited from EndPoint.)
Back to Top
See Also
ServerEndPoint Class
NFX.Glue Namespace


ServerEndPoint.CONFIG_BINDING_ATTR Field

ServerEndPoint CONFIG_BINDING_ATTR Field NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_BINDING_ATTR
public const string CONFIG_BINDING_ATTR
Public Const CONFIG_BINDING_ATTR As String
Public Const CONFIG_BINDING_ATTR As String
public:
literal String^ CONFIG_BINDING_ATTR
public:
literal String^ CONFIG_BINDING_ATTR
static val mutable CONFIG_BINDING_ATTR: string
static val mutable CONFIG_BINDING_ATTR: string

Field Value

Type: Online String
See Also
ServerEndPoint Class
ServerEndPoint Members
NFX.Glue Namespace


ServerEndPoint.CONFIG_CONTRACT_SERVERS_ATTR Field

ServerEndPoint CONFIG_CONTRACT_SERVERS_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CONTRACT_SERVERS_ATTR
public const string CONFIG_CONTRACT_SERVERS_ATTR
Public Const CONFIG_CONTRACT_SERVERS_ATTR As String
Public Const CONFIG_CONTRACT_SERVERS_ATTR As String
public:
literal String^ CONFIG_CONTRACT_SERVERS_ATTR
public:
literal String^ CONFIG_CONTRACT_SERVERS_ATTR
static val mutable CONFIG_CONTRACT_SERVERS_ATTR: string
static val mutable CONFIG_CONTRACT_SERVERS_ATTR: string

Field Value

Type: Online String
See Also
ServerEndPoint Class
ServerEndPoint Members
NFX.Glue Namespace


ServerEndPoint.CONFIG_NAME_ATTR Field

ServerEndPoint CONFIG_NAME_ATTR Field NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_NAME_ATTR
public const string CONFIG_NAME_ATTR
Public Const CONFIG_NAME_ATTR As String
Public Const CONFIG_NAME_ATTR As String
public:
literal String^ CONFIG_NAME_ATTR
public:
literal String^ CONFIG_NAME_ATTR
static val mutable CONFIG_NAME_ATTR: string
static val mutable CONFIG_NAME_ATTR: string

Field Value

Type: Online String
See Also
ServerEndPoint Class
ServerEndPoint Members
NFX.Glue Namespace


ServerEndPoint.CONFIG_NODE_ATTR Field

ServerEndPoint CONFIG_NODE_ATTR Field NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_NODE_ATTR
public const string CONFIG_NODE_ATTR
Public Const CONFIG_NODE_ATTR As String
Public Const CONFIG_NODE_ATTR As String
public:
literal String^ CONFIG_NODE_ATTR
public:
literal String^ CONFIG_NODE_ATTR
static val mutable CONFIG_NODE_ATTR: string
static val mutable CONFIG_NODE_ATTR: string

Field Value

Type: Online String
See Also
ServerEndPoint Class
ServerEndPoint Members
NFX.Glue Namespace


ServerEndPoint.m_ContractImplementers Field

ServerEndPoint m_ContractImplementers Field NFX Class Library

[This is preliminary documentation and is subject to change.]

INTERNAL! Maps ContractType -> ServerImplementing class. This is a cache used not to recompute everything on every call

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ConcurrentDictionary<Type, ServerHandler..::..serverImplementer> m_ContractImplementers
internal ConcurrentDictionary<Type, ServerHandler..::..serverImplementer> m_ContractImplementers
Friend m_ContractImplementers As ConcurrentDictionary(Of Type, ServerHandler..::..serverImplementer)
Friend m_ContractImplementers As ConcurrentDictionary(Of Type, ServerHandler..::..serverImplementer)
internal:
ConcurrentDictionary<Type^, ServerHandler..::..serverImplementer^>^ m_ContractImplementers
internal:
ConcurrentDictionary<Type^, ServerHandler..::..serverImplementer^>^ m_ContractImplementers
val mutable internal m_ContractImplementers: ConcurrentDictionary<Type, ServerHandler..::..serverImplementer>
val mutable internal m_ContractImplementers: ConcurrentDictionary<Type, ServerHandler..::..serverImplementer>

Field Value

Type: Online ConcurrentDictionary Online Type, ServerHandler serverImplementer
See Also
ServerEndPoint Class
ServerEndPoint Members
NFX.Glue Namespace


ServerEndPoint Methods

ServerEndPoint Methods NFX Class Library

The ServerEndPoint type exposes the following members.
Methods
 | Name | Description
Public method | Close |
Public method | Configure |
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | Opens endpoint by allocating transports (if necessary). ServerEndpoint can be Close() or Dispose() after it was open
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerEndPoint Class
NFX.Glue Namespace


ServerEndPoint.Close Method

ServerEndPoint Close Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Close()
public void Close()
Public Sub Close
Public Sub Close
public:
void Close()
public:
void Close()
member Close : unit -> unit
member Close : unit -> unit
See Also
ServerEndPoint Class
ServerEndPoint Members
NFX.Glue Namespace


ServerEndPoint.Configure Method

ServerEndPoint Configure Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode node
)
public void Configure(
    IConfigSectionNode node
)
Public Sub Configure (
    node As IConfigSectionNode
)
Public Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
ServerEndPoint Class
ServerEndPoint Members
NFX.Glue Namespace


ServerEndPoint.Destructor Method

ServerEndPoint Destructor Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
ServerEndPoint Class
ServerEndPoint Members
NFX.Glue Namespace


ServerEndPoint.Open Method

ServerEndPoint Open Method NFX Class Library

Opens endpoint by allocating transports (if necessary). ServerEndpoint can be Close() or Dispose() after it was open

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Open()
public void Open()
Public Sub Open
Public Sub Open
public:
void Open()
public:
void Open()
member Open : unit -> unit
member Open : unit -> unit
See Also
ServerEndPoint Class
ServerEndPoint Members
NFX.Glue Namespace


ServerEndPoint.ToString Method

ServerEndPoint ToString Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
ServerEndPoint Class
ServerEndPoint Members
NFX.Glue Namespace


ServerEndPoint Properties

ServerEndPoint Properties NFX Class Library

The ServerEndPoint type exposes the following members.
Properties
 | Name | Description
Public property | Binding | Returns a binding of this endpoint. "B" component of the "ABC" rule (Inherited from EndPoint.)
Public property | ContractServers | Returns types that implement/serve contracts that this endpoint accepts
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Glue | References glue that this endpoint works under (Inherited from EndPoint.)
Public property | IsOpen | Indicates whether endpoint is open and is accepting incoming requests
Public property | MsgInspectors | Returns server message inspectors for this instance
Public property | Name | Returns name of the endpoint. Named endpoints must be unique in the context, if name was not supplied in .ctor then it is auto-generated
Public property | Node | Returns a node of this endpoint. "A" component of the "ABC" rule (Inherited from EndPoint.)
Public property | Transport | Returns server transport that services this endpoint
Back to Top
See Also
ServerEndPoint Class
NFX.Glue Namespace


ServerEndPoint.ContractServers Property

ServerEndPoint ContractServers Property NFX Class Library

Returns types that implement/serve contracts that this endpoint accepts

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Type[] ContractServers { get; }
public Type[] ContractServers { get; }
Public ReadOnly Property ContractServers As Type()
    Get
Public ReadOnly Property ContractServers As Type()
    Get
public:
property array<Type^>^ ContractServers {
    array<Type^>^ get ();
}
public:
property array<Type^>^ ContractServers {
    array<Type^>^ get ();
}
member ContractServers : Type[] with get
member ContractServers : Type[] with get

Property Value

Type: Online Type
See Also
ServerEndPoint Class
ServerEndPoint Members
NFX.Glue Namespace


ServerEndPoint.IsOpen Property

ServerEndPoint IsOpen Property NFX Class Library

Indicates whether endpoint is open and is accepting incoming requests

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsOpen { get; }
public bool IsOpen { get; }
Public ReadOnly Property IsOpen As Boolean
    Get
Public ReadOnly Property IsOpen As Boolean
    Get
public:
property bool IsOpen {
    bool get ();
}
public:
property bool IsOpen {
    bool get ();
}
member IsOpen : bool with get
member IsOpen : bool with get

Property Value

Type: Online Boolean
See Also
ServerEndPoint Class
ServerEndPoint Members
NFX.Glue Namespace


ServerEndPoint.MsgInspectors Property

ServerEndPoint MsgInspectors Property NFX Class Library

Returns server message inspectors for this instance

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderedRegistry<IServerMsgInspector> MsgInspectors { get; }
public OrderedRegistry<IServerMsgInspector> MsgInspectors { get; }
Public ReadOnly Property MsgInspectors As OrderedRegistry(Of IServerMsgInspector)
    Get
Public ReadOnly Property MsgInspectors As OrderedRegistry(Of IServerMsgInspector)
    Get
public:
property OrderedRegistry<IServerMsgInspector^>^ MsgInspectors {
    OrderedRegistry<IServerMsgInspector^>^ get ();
}
public:
property OrderedRegistry<IServerMsgInspector^>^ MsgInspectors {
    OrderedRegistry<IServerMsgInspector^>^ get ();
}
member MsgInspectors : OrderedRegistry<IServerMsgInspector> with get
member MsgInspectors : OrderedRegistry<IServerMsgInspector> with get

Property Value

Type: OrderedRegistry IServerMsgInspector
See Also
ServerEndPoint Class
ServerEndPoint Members
NFX.Glue Namespace


ServerEndPoint.Name Property

ServerEndPoint Name Property NFX Class Library

Returns name of the endpoint. Named endpoints must be unique in the context, if name was not supplied in .ctor then it is auto-generated

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
ServerEndPoint Class
ServerEndPoint Members
NFX.Glue Namespace


ServerEndPoint.Transport Property

ServerEndPoint Transport Property NFX Class Library

Returns server transport that services this endpoint

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerTransport Transport { get; }
public ServerTransport Transport { get; }
Public ReadOnly Property Transport As ServerTransport
    Get
Public ReadOnly Property Transport As ServerTransport
    Get
public:
property ServerTransport^ Transport {
    ServerTransport^ get ();
}
public:
property ServerTransport^ Transport {
    ServerTransport^ get ();
}
member Transport : ServerTransport with get
member Transport : ServerTransport with get

Property Value

Type: ServerTransport
See Also
ServerEndPoint Class
ServerEndPoint Members
NFX.Glue Namespace


ServerException Class

ServerException Class NFX Class Library

Exception thrown in Glue server
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Glue GlueException
NFX.Glue ServerException
NFX.Glue ServerContractException
NFX.Glue ServerInstanceActivationException
NFX.Glue ServerMethodInvocationException
NFX.Glue ServerNotRunningException

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class ServerException : GlueException
[SerializableAttribute]
public abstract class ServerException : GlueException
<SerializableAttribute>
Public MustInherit Class ServerException
    Inherits GlueException
<SerializableAttribute>
Public MustInherit Class ServerException
    Inherits GlueException
[SerializableAttribute]
public ref class ServerException abstract : public GlueException
[SerializableAttribute]
public ref class ServerException abstract : public GlueException
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ServerException =
    class
        inherit GlueException
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ServerException =
    class
        inherit GlueException
    end
See Also
ServerException Members
NFX.Glue Namespace


ServerException Members

ServerException Members NFX Class Library

The ServerException type exposes the following members.
Constructors
 | Name | Description
Public method | ServerException | Initializes a new instance of the ServerException class
Public method | ServerException(String) | Initializes a new instance of the ServerException class
Protected method | ServerException(SerializationInfo, StreamingContext) | Initializes a new instance of the ServerException class
Public method | ServerException(String, Exception) | Initializes a new instance of the ServerException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ServerException Class
NFX.Glue Namespace


ServerException Constructor

ServerException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ServerException | Initializes a new instance of the ServerException class
Public method | ServerException(String) | Initializes a new instance of the ServerException class
Protected method | ServerException(SerializationInfo, StreamingContext) | Initializes a new instance of the ServerException class
Public method | ServerException(String, Exception) | Initializes a new instance of the ServerException class
Back to Top
See Also
ServerException Class
ServerException Members
NFX.Glue Namespace


ServerException Constructor

ServerException Constructor NFX Class Library

Initializes a new instance of the ServerException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerException()
public ServerException()
Public Sub New
Public Sub New
public:
ServerException()
public:
ServerException()
new : unit -> ServerException
new : unit -> ServerException
See Also
ServerException Class
ServerException Members
ServerException Overload
NFX.Glue Namespace


ServerException Constructor (String)

ServerException Constructor (String) NFX Class Library

Initializes a new instance of the ServerException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerException(
    string message
)
public ServerException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
ServerException(
    String^ message
)
public:
ServerException(
    String^ message
)
new :
        message : string -> ServerException
new :
        message : string -> ServerException

Parameters

message
Type: Online System String
See Also
ServerException Class
ServerException Members
ServerException Overload
NFX.Glue Namespace


ServerException Constructor (SerializationInfo, StreamingContext)

ServerException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerException(
    SerializationInfo info,
    StreamingContext context
)
protected ServerException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
ServerException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
ServerException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ServerException
new :
        info : SerializationInfo *
        context : StreamingContext -> ServerException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
ServerException Class
ServerException Members
ServerException Overload
NFX.Glue Namespace


ServerException Constructor (String, Exception)

ServerException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerException(
    string message,
    Exception inner
)
public ServerException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
ServerException(
    String^ message,
    Exception^ inner
)
public:
ServerException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> ServerException
new :
        message : string *
        inner : Exception -> ServerException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
ServerException Class
ServerException Members
ServerException Overload
NFX.Glue Namespace


ServerException Methods

ServerException Methods NFX Class Library

The ServerException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
ServerException Class
NFX.Glue Namespace


ServerException Properties

ServerException Properties NFX Class Library

The ServerException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
ServerException Class
NFX.Glue Namespace


ServerException Events

ServerException Events NFX Class Library

The ServerException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ServerException Class
NFX.Glue Namespace


ServerInstanceActivationException Class

ServerInstanceActivationException Class NFX Class Library

Exception thrown when server instance can not be created
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Glue GlueException
NFX.Glue ServerException
NFX.Glue ServerInstanceActivationException
NFX.Glue StatefulServerInstanceDoesNotExistException
NFX.Glue StatefulServerInstanceLockTimeoutException

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ServerInstanceActivationException : ServerException
[SerializableAttribute]
public class ServerInstanceActivationException : ServerException
<SerializableAttribute>
Public Class ServerInstanceActivationException
    Inherits ServerException
<SerializableAttribute>
Public Class ServerInstanceActivationException
    Inherits ServerException
[SerializableAttribute]
public ref class ServerInstanceActivationException : public ServerException
[SerializableAttribute]
public ref class ServerInstanceActivationException : public ServerException
[<SerializableAttribute>]
type ServerInstanceActivationException =
    class
        inherit ServerException
    end
[<SerializableAttribute>]
type ServerInstanceActivationException =
    class
        inherit ServerException
    end
See Also
ServerInstanceActivationException Members
NFX.Glue Namespace


ServerInstanceActivationException Members

ServerInstanceActivationException Members NFX Class Library

The ServerInstanceActivationException type exposes the following members.
Constructors
 | Name | Description
Public method | ServerInstanceActivationException | Initializes a new instance of the ServerInstanceActivationException class
Public method | ServerInstanceActivationException(String) | Initializes a new instance of the ServerInstanceActivationException class
Protected method | ServerInstanceActivationException(SerializationInfo, StreamingContext) | Initializes a new instance of the ServerInstanceActivationException class
Public method | ServerInstanceActivationException(String, Exception) | Initializes a new instance of the ServerInstanceActivationException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ServerInstanceActivationException Class
NFX.Glue Namespace


ServerInstanceActivationException Constructor

ServerInstanceActivationException Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public method | ServerInstanceActivationException | Initializes a new instance of the ServerInstanceActivationException class
Public method | ServerInstanceActivationException(String) | Initializes a new instance of the ServerInstanceActivationException class
Protected method | ServerInstanceActivationException(SerializationInfo, StreamingContext) | Initializes a new instance of the ServerInstanceActivationException class
Public method | ServerInstanceActivationException(String, Exception) | Initializes a new instance of the ServerInstanceActivationException class
Back to Top
See Also
ServerInstanceActivationException Class
ServerInstanceActivationException Members
NFX.Glue Namespace


ServerInstanceActivationException Constructor

ServerInstanceActivationException Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerInstanceActivationException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerInstanceActivationException()
public ServerInstanceActivationException()
Public Sub New
Public Sub New
public:
ServerInstanceActivationException()
public:
ServerInstanceActivationException()
new : unit -> ServerInstanceActivationException
new : unit -> ServerInstanceActivationException
See Also
ServerInstanceActivationException Class
ServerInstanceActivationException Members
ServerInstanceActivationException Overload
NFX.Glue Namespace


ServerInstanceActivationException Constructor (String)

ServerInstanceActivationException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerInstanceActivationException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerInstanceActivationException(
    string message
)
public ServerInstanceActivationException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
ServerInstanceActivationException(
    String^ message
)
public:
ServerInstanceActivationException(
    String^ message
)
new :
        message : string -> ServerInstanceActivationException
new :
        message : string -> ServerInstanceActivationException

Parameters

message
Type: Online System String
See Also
ServerInstanceActivationException Class
ServerInstanceActivationException Members
ServerInstanceActivationException Overload
NFX.Glue Namespace


ServerInstanceActivationException Constructor (SerializationInfo, StreamingContext)

ServerInstanceActivationException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerInstanceActivationException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerInstanceActivationException(
    SerializationInfo info,
    StreamingContext context
)
protected ServerInstanceActivationException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
ServerInstanceActivationException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
ServerInstanceActivationException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ServerInstanceActivationException
new :
        info : SerializationInfo *
        context : StreamingContext -> ServerInstanceActivationException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
ServerInstanceActivationException Class
ServerInstanceActivationException Members
ServerInstanceActivationException Overload
NFX.Glue Namespace


ServerInstanceActivationException Constructor (String, Exception)

ServerInstanceActivationException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerInstanceActivationException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerInstanceActivationException(
    string message,
    Exception inner
)
public ServerInstanceActivationException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
ServerInstanceActivationException(
    String^ message,
    Exception^ inner
)
public:
ServerInstanceActivationException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> ServerInstanceActivationException
new :
        message : string *
        inner : Exception -> ServerInstanceActivationException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
ServerInstanceActivationException Class
ServerInstanceActivationException Members
ServerInstanceActivationException Overload
NFX.Glue Namespace


ServerInstanceActivationException Methods

ServerInstanceActivationException Methods NFX Class Library

The ServerInstanceActivationException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
ServerInstanceActivationException Class
NFX.Glue Namespace


ServerInstanceActivationException Properties

ServerInstanceActivationException Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The ServerInstanceActivationException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
ServerInstanceActivationException Class
NFX.Glue Namespace


ServerInstanceActivationException Events

ServerInstanceActivationException Events NFX Class Library

The ServerInstanceActivationException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ServerInstanceActivationException Class
NFX.Glue Namespace


ServerInstanceMode Enumeration

ServerInstanceMode Enumeration NFX Class Library

Denotes server instance modes - how server instances relate to calls

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum ServerInstanceMode
public enum ServerInstanceMode
Public Enumeration ServerInstanceMode
Public Enumeration ServerInstanceMode
public enum class ServerInstanceMode
public enum class ServerInstanceMode
type ServerInstanceMode
type ServerInstanceMode
Members
Member name | Value | Description
Singleton | 0 | Indicates that the same single process-wide instance will serve all request for particular contract. The server MUST be thread-safe
PerCall | 1 | Indicates that every request for a particular contract will create an instance which will live until the method exits
Stateful | 2 | Indicates that the instance is stateful and will live between a call to [Constructor]-decorated method and [Destructor]-decorated method, or until timeout interval has passed. The implementation may or may not be thread-safe, if it is, then [ThreadSafe] attribute may be used to avoid instance locking
AutoConstructedStateful | 3 | Indicates that the instance is stateful and will live between a call to either [Constructor]-decorated method or first call to any method, and [Destructor]-decorated method or until timeout interval has passed. The implementation may or may not be thread-safe, if it is then [ThreadSafe] attribute may be used to avoid instance locking. This mode is simiar to 'Stateful' but does not require the caller to explicitly call the [Constructor]-decorated method first
See Also
NFX.Glue Namespace


ServerMethodInvocationException Class

ServerMethodInvocationException Class NFX Class Library

Exception thrown when server can not invoke method
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Glue GlueException
NFX.Glue ServerException
NFX.Glue ServerMethodInvocationException

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ServerMethodInvocationException : ServerException
[SerializableAttribute]
public class ServerMethodInvocationException : ServerException
<SerializableAttribute>
Public Class ServerMethodInvocationException
    Inherits ServerException
<SerializableAttribute>
Public Class ServerMethodInvocationException
    Inherits ServerException
[SerializableAttribute]
public ref class ServerMethodInvocationException : public ServerException
[SerializableAttribute]
public ref class ServerMethodInvocationException : public ServerException
[<SerializableAttribute>]
type ServerMethodInvocationException =
    class
        inherit ServerException
    end
[<SerializableAttribute>]
type ServerMethodInvocationException =
    class
        inherit ServerException
    end
See Also
ServerMethodInvocationException Members
NFX.Glue Namespace


ServerMethodInvocationException Members

ServerMethodInvocationException Members NFX Class Library

The ServerMethodInvocationException type exposes the following members.
Constructors
 | Name | Description
Public method | ServerMethodInvocationException | Initializes a new instance of the ServerMethodInvocationException class
Public method | ServerMethodInvocationException(String) | Initializes a new instance of the ServerMethodInvocationException class
Protected method | ServerMethodInvocationException(SerializationInfo, StreamingContext) | Initializes a new instance of the ServerMethodInvocationException class
Public method | ServerMethodInvocationException(String, Exception) | Initializes a new instance of the ServerMethodInvocationException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ServerMethodInvocationException Class
NFX.Glue Namespace


ServerMethodInvocationException Constructor

ServerMethodInvocationException Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public method | ServerMethodInvocationException | Initializes a new instance of the ServerMethodInvocationException class
Public method | ServerMethodInvocationException(String) | Initializes a new instance of the ServerMethodInvocationException class
Protected method | ServerMethodInvocationException(SerializationInfo, StreamingContext) | Initializes a new instance of the ServerMethodInvocationException class
Public method | ServerMethodInvocationException(String, Exception) | Initializes a new instance of the ServerMethodInvocationException class
Back to Top
See Also
ServerMethodInvocationException Class
ServerMethodInvocationException Members
NFX.Glue Namespace


ServerMethodInvocationException Constructor

ServerMethodInvocationException Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerMethodInvocationException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerMethodInvocationException()
public ServerMethodInvocationException()
Public Sub New
Public Sub New
public:
ServerMethodInvocationException()
public:
ServerMethodInvocationException()
new : unit -> ServerMethodInvocationException
new : unit -> ServerMethodInvocationException
See Also
ServerMethodInvocationException Class
ServerMethodInvocationException Members
ServerMethodInvocationException Overload
NFX.Glue Namespace


ServerMethodInvocationException Constructor (String)

ServerMethodInvocationException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerMethodInvocationException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerMethodInvocationException(
    string message
)
public ServerMethodInvocationException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
ServerMethodInvocationException(
    String^ message
)
public:
ServerMethodInvocationException(
    String^ message
)
new :
        message : string -> ServerMethodInvocationException
new :
        message : string -> ServerMethodInvocationException

Parameters

message
Type: Online System String
See Also
ServerMethodInvocationException Class
ServerMethodInvocationException Members
ServerMethodInvocationException Overload
NFX.Glue Namespace


ServerMethodInvocationException Constructor (SerializationInfo, StreamingContext)

ServerMethodInvocationException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerMethodInvocationException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerMethodInvocationException(
    SerializationInfo info,
    StreamingContext context
)
protected ServerMethodInvocationException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
ServerMethodInvocationException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
ServerMethodInvocationException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ServerMethodInvocationException
new :
        info : SerializationInfo *
        context : StreamingContext -> ServerMethodInvocationException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
ServerMethodInvocationException Class
ServerMethodInvocationException Members
ServerMethodInvocationException Overload
NFX.Glue Namespace


ServerMethodInvocationException Constructor (String, Exception)

ServerMethodInvocationException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerMethodInvocationException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerMethodInvocationException(
    string message,
    Exception inner
)
public ServerMethodInvocationException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
ServerMethodInvocationException(
    String^ message,
    Exception^ inner
)
public:
ServerMethodInvocationException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> ServerMethodInvocationException
new :
        message : string *
        inner : Exception -> ServerMethodInvocationException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
ServerMethodInvocationException Class
ServerMethodInvocationException Members
ServerMethodInvocationException Overload
NFX.Glue Namespace


ServerMethodInvocationException Methods

ServerMethodInvocationException Methods NFX Class Library

The ServerMethodInvocationException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
ServerMethodInvocationException Class
NFX.Glue Namespace


ServerMethodInvocationException Properties

ServerMethodInvocationException Properties NFX Class Library

The ServerMethodInvocationException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
ServerMethodInvocationException Class
NFX.Glue Namespace


ServerMethodInvocationException Events

ServerMethodInvocationException Events NFX Class Library

The ServerMethodInvocationException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ServerMethodInvocationException Class
NFX.Glue Namespace


ServerNotRunningException Class

ServerNotRunningException Class NFX Class Library

Exception thrown in Glue server when it shuts down/not running
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Glue GlueException
NFX.Glue ServerException
NFX.Glue ServerNotRunningException

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ServerNotRunningException : ServerException
[SerializableAttribute]
public class ServerNotRunningException : ServerException
<SerializableAttribute>
Public Class ServerNotRunningException
    Inherits ServerException
<SerializableAttribute>
Public Class ServerNotRunningException
    Inherits ServerException
[SerializableAttribute]
public ref class ServerNotRunningException : public ServerException
[SerializableAttribute]
public ref class ServerNotRunningException : public ServerException
[<SerializableAttribute>]
type ServerNotRunningException =
    class
        inherit ServerException
    end
[<SerializableAttribute>]
type ServerNotRunningException =
    class
        inherit ServerException
    end
See Also
ServerNotRunningException Members
NFX.Glue Namespace


ServerNotRunningException Members

ServerNotRunningException Members NFX Class Library

The ServerNotRunningException type exposes the following members.
Constructors
 | Name | Description
Public method | ServerNotRunningException | Initializes a new instance of the ServerNotRunningException class
Public method | ServerNotRunningException(String) | Initializes a new instance of the ServerNotRunningException class
Protected method | ServerNotRunningException(SerializationInfo, StreamingContext) | Initializes a new instance of the ServerNotRunningException class
Public method | ServerNotRunningException(String, Exception) | Initializes a new instance of the ServerNotRunningException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ServerNotRunningException Class
NFX.Glue Namespace


ServerNotRunningException Constructor

ServerNotRunningException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ServerNotRunningException | Initializes a new instance of the ServerNotRunningException class
Public method | ServerNotRunningException(String) | Initializes a new instance of the ServerNotRunningException class
Protected method | ServerNotRunningException(SerializationInfo, StreamingContext) | Initializes a new instance of the ServerNotRunningException class
Public method | ServerNotRunningException(String, Exception) | Initializes a new instance of the ServerNotRunningException class
Back to Top
See Also
ServerNotRunningException Class
ServerNotRunningException Members
NFX.Glue Namespace


ServerNotRunningException Constructor

ServerNotRunningException Constructor NFX Class Library

Initializes a new instance of the ServerNotRunningException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerNotRunningException()
public ServerNotRunningException()
Public Sub New
Public Sub New
public:
ServerNotRunningException()
public:
ServerNotRunningException()
new : unit -> ServerNotRunningException
new : unit -> ServerNotRunningException
See Also
ServerNotRunningException Class
ServerNotRunningException Members
ServerNotRunningException Overload
NFX.Glue Namespace


ServerNotRunningException Constructor (String)

ServerNotRunningException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerNotRunningException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerNotRunningException(
    string message
)
public ServerNotRunningException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
ServerNotRunningException(
    String^ message
)
public:
ServerNotRunningException(
    String^ message
)
new :
        message : string -> ServerNotRunningException
new :
        message : string -> ServerNotRunningException

Parameters

message
Type: Online System String
See Also
ServerNotRunningException Class
ServerNotRunningException Members
ServerNotRunningException Overload
NFX.Glue Namespace


ServerNotRunningException Constructor (SerializationInfo, StreamingContext)

ServerNotRunningException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerNotRunningException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerNotRunningException(
    SerializationInfo info,
    StreamingContext context
)
protected ServerNotRunningException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
ServerNotRunningException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
ServerNotRunningException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ServerNotRunningException
new :
        info : SerializationInfo *
        context : StreamingContext -> ServerNotRunningException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
ServerNotRunningException Class
ServerNotRunningException Members
ServerNotRunningException Overload
NFX.Glue Namespace


ServerNotRunningException Constructor (String, Exception)

ServerNotRunningException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerNotRunningException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerNotRunningException(
    string message,
    Exception inner
)
public ServerNotRunningException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
ServerNotRunningException(
    String^ message,
    Exception^ inner
)
public:
ServerNotRunningException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> ServerNotRunningException
new :
        message : string *
        inner : Exception -> ServerNotRunningException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
ServerNotRunningException Class
ServerNotRunningException Members
ServerNotRunningException Overload
NFX.Glue Namespace


ServerNotRunningException Methods

ServerNotRunningException Methods NFX Class Library

The ServerNotRunningException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
ServerNotRunningException Class
NFX.Glue Namespace


ServerNotRunningException Properties

ServerNotRunningException Properties NFX Class Library

The ServerNotRunningException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
ServerNotRunningException Class
NFX.Glue Namespace


ServerNotRunningException Events

ServerNotRunningException Events NFX Class Library

The ServerNotRunningException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ServerNotRunningException Class
NFX.Glue Namespace


Servers Class

Servers Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX Registry ServerEndPoint
NFX.Glue Servers

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Servers : Registry<ServerEndPoint>
public sealed class Servers : Registry<ServerEndPoint>
Public NotInheritable Class Servers
    Inherits Registry(Of ServerEndPoint)
Public NotInheritable Class Servers
    Inherits Registry(Of ServerEndPoint)
public ref class Servers sealed : public Registry<ServerEndPoint^>
public ref class Servers sealed : public Registry<ServerEndPoint^>
[<SealedAttribute>]
type Servers =
    class
        inherit Registry<ServerEndPoint>
    end
[<SealedAttribute>]
type Servers =
    class
        inherit Registry<ServerEndPoint>
    end
See Also
Servers Members
NFX.Glue Namespace


Servers Members

Servers Members NFX Class Library

The Servers type exposes the following members.
Constructors
 | Name | Description
Public method | Servers | Initializes a new instance of the Servers class
Back to Top
Methods
 | Name | Description
Public method | Clear | Deletes all items from registry (Inherited from Registry T .)
Public method | ContainsName | (Inherited from Registry T .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | (Inherited from Registry T .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetOrRegister TContext (String, Func TContext, T , TContext) | Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency (Inherited from Registry T .)
Public method | GetOrRegister TContext (String, Func TContext, T , TContext, Boolean ) | Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency (Inherited from Registry T .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | JustRegistered | (Inherited from Registry T .)
Protected method | JustReplaced | (Inherited from Registry T .)
Protected method | JustUnregistered | (Inherited from Registry T .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Register | Registers item and returns true if it was registered, false if this named instance already existed in the list (Inherited from Registry T .)
Public method | RegisterOrReplace(T) | Registers item and returns true if it was registered, false if this named instance already existed and was replaced (Inherited from Registry T .)
Public method | RegisterOrReplace(T, T ) | Registers item and returns true if it was registered, false if this named instance already existed and was replaced (Inherited from Registry T .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryGetValue | (Inherited from Registry T .)
Public method | Unregister(String) | Unregisters item by name and returns true if it was unregistered, false if it did not exist (Inherited from Registry T .)
Public method | Unregister(T) | Unregisters item and returns true if it was unregistered, false if it did not exist (Inherited from Registry T .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Sync | (Inherited from Registry T .)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns the number of entries in the registry (Inherited from Registry T .)
Public property | IsCaseSensitive | Returns true if the instance differentiates names by case (Inherited from Registry T .)
Public property | Item | Returns a value by name or null if not found (Inherited from Registry T .)
Public property | Names | (Inherited from Registry T .)
Public property | Values | (Inherited from Registry T .)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Registry T .)
Back to Top
See Also
Servers Class
NFX.Glue Namespace


Servers Constructor

Servers Constructor NFX Class Library

Initializes a new instance of the Servers class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Servers()
public Servers()
Public Sub New
Public Sub New
public:
Servers()
public:
Servers()
new : unit -> Servers
new : unit -> Servers
See Also
Servers Class
Servers Members
NFX.Glue Namespace


Servers Fields

Servers Fields NFX Class Library

The Servers type exposes the following members.
Fields
 | Name | Description
Protected field | m_Sync | (Inherited from Registry T .)
Back to Top
See Also
Servers Class
NFX.Glue Namespace


Servers Methods

Servers Methods NFX Class Library

The Servers type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Deletes all items from registry (Inherited from Registry T .)
Public method | ContainsName | (Inherited from Registry T .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator | (Inherited from Registry T .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetOrRegister TContext (String, Func TContext, T , TContext) | Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency (Inherited from Registry T .)
Public method | GetOrRegister TContext (String, Func TContext, T , TContext, Boolean ) | Tries to find an item by name, and returns it if it is found, otherwise calls a factory function supplying context value and registers the obtained new item. The first lookup is performed in a lock-free way and if an item is found then it is immediately returned. The second check and factory call operation is performed atomically under the lock to ensure consistency (Inherited from Registry T .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | JustRegistered | (Inherited from Registry T .)
Protected method | JustReplaced | (Inherited from Registry T .)
Protected method | JustUnregistered | (Inherited from Registry T .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Register | Registers item and returns true if it was registered, false if this named instance already existed in the list (Inherited from Registry T .)
Public method | RegisterOrReplace(T) | Registers item and returns true if it was registered, false if this named instance already existed and was replaced (Inherited from Registry T .)
Public method | RegisterOrReplace(T, T ) | Registers item and returns true if it was registered, false if this named instance already existed and was replaced (Inherited from Registry T .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryGetValue | (Inherited from Registry T .)
Public method | Unregister(String) | Unregisters item by name and returns true if it was unregistered, false if it did not exist (Inherited from Registry T .)
Public method | Unregister(T) | Unregisters item and returns true if it was unregistered, false if it did not exist (Inherited from Registry T .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Registry T .)
Back to Top
See Also
Servers Class
NFX.Glue Namespace


Servers Properties

Servers Properties NFX Class Library

The Servers type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns the number of entries in the registry (Inherited from Registry T .)
Public property | IsCaseSensitive | Returns true if the instance differentiates names by case (Inherited from Registry T .)
Public property | Item | Returns a value by name or null if not found (Inherited from Registry T .)
Public property | Names | (Inherited from Registry T .)
Public property | Values | (Inherited from Registry T .)
Back to Top
See Also
Servers Class
NFX.Glue Namespace


ServerTransport Class

ServerTransport Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service Binding
NFX.Glue Transport
NFX.Glue ServerTransport
NFX.Glue ServerTransport TBinding

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class ServerTransport : Transport
public abstract class ServerTransport : Transport
Public MustInherit Class ServerTransport
    Inherits Transport
Public MustInherit Class ServerTransport
    Inherits Transport
public ref class ServerTransport abstract : public Transport
public ref class ServerTransport abstract : public Transport
[<AbstractClassAttribute>]
type ServerTransport =
    class
        inherit Transport
    end
[<AbstractClassAttribute>]
type ServerTransport =
    class
        inherit Transport
    end
See Also
ServerTransport Members
NFX.Glue Namespace


ServerTransport Members

ServerTransport Members NFX Class Library

The ServerTransport type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerTransport(Binding, ServerEndPoint) | Creates an instance of listener transport
Protected method | ServerTransport(Binding, ServerTransport) | Creates instance of a transport that resulted from connection accept by listener. Not all technologies support listener/child transports (TCP does)
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and transport instance are running or throws otherwise (Inherited from Transport.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Transport.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoDumpInstrumentationData | Override to dump instrumentation data, dont forget to call base to dump basic metrics (Inherited from Transport.)
Protected method | DoSendResponse | Override to send a response into remote client endpoint
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Inherited from Transport.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | DumpInstrumentationData | Dumps instrumentation data (Inherited from Transport.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Release | Releases transport by setting Acquired flag to false so it can be used by other operations (Inherited from Transport.)
Public method | ResetStats | Resets all statistical counters (Inherited from Transport.)
Public method | SendResponse | Sends a response into remote client endpoint
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Protected method | stat_BytesReceived | (Inherited from Transport.)
Protected method | stat_BytesSent | (Inherited from Transport.)
Protected method | stat_Errors | (Inherited from Transport.)
Protected method | stat_MsgReceived | (Inherited from Transport.)
Protected method | stat_MsgSent | (Inherited from Transport.)
Protected method | stat_Time | Processes named time measurement statistical sample by using EMA filter (Inherited from Transport.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryAcquire | A thread-safe operation that tries to acquire(reserve) this instance for exclusive use. Returns true if acqusition succeded, false is this instance is reserved by someone else (Inherited from Transport.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_TransportKind | (Inherited from Transport.)
Back to Top
Properties
 | Name | Description
Public property | Acquired | Returns true when this transport instance has been acquired by some operation and is busy (Inherited from Transport.)
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | Binding | Returns a binding that this transport operates under (Inherited from Transport.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExpirationStart | Returns timestamp when manager touched the instance for last time and no traffic went through it since (Inherited from Transport.)
Public property | Glue | Returns glue implementation that this transport is under (Inherited from Transport.)
Public property | IdleAgeMs | Returns the duration of transport idle period in ms. (Inherited from Transport.)
Public property | IsListener | Indicates whether this instance is the one that accepts connections. Depending on implementation listeners may allocate other transports after they accept incoming connect request (i.e. TCP)
Public property | Listener | Returns a listener transport that opened this one. If this is a listener transport then returns null. Not all technologies support listener/child transports (TCP does)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Node | Returns node that this transport services (Inherited from Transport.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | ServerEndpoint | Returns server endpoint instance that opened this transport
Public property | StatBytesReceived | Returns how many bytes were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatBytesSent | Returns how many bytes were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatErrors | Returns how many message processing errors happened since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgReceived | Returns how many messages were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgSent | Returns how many messages were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatTimes | Returns enumerable of named times measured in double second fractions. The returned times are EMA-filtered from supplied individual measurement samples (Inherited from Transport.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransportKind | Reports if this is a server or client transport (Inherited from Transport.)
Back to Top
See Also
ServerTransport Class
NFX.Glue Namespace


ServerTransport Constructor

ServerTransport Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | ServerTransport(Binding, ServerEndPoint) | Creates an instance of listener transport
Protected method | ServerTransport(Binding, ServerTransport) | Creates instance of a transport that resulted from connection accept by listener. Not all technologies support listener/child transports (TCP does)
Back to Top
See Also
ServerTransport Class
ServerTransport Members
NFX.Glue Namespace


ServerTransport Constructor (Binding, ServerEndPoint)

ServerTransport Constructor (Binding, ServerEndPoint) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates an instance of listener transport

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerTransport(
    Binding binding,
    ServerEndPoint serverEndpoint
)
protected ServerTransport(
    Binding binding,
    ServerEndPoint serverEndpoint
)
Protected Sub New (
    binding As Binding,
    serverEndpoint As ServerEndPoint
)
Protected Sub New (
    binding As Binding,
    serverEndpoint As ServerEndPoint
)
protected:
ServerTransport(
    Binding^ binding,
    ServerEndPoint^ serverEndpoint
)
protected:
ServerTransport(
    Binding^ binding,
    ServerEndPoint^ serverEndpoint
)
new :
        binding : Binding *
        serverEndpoint : ServerEndPoint -> ServerTransport
new :
        binding : Binding *
        serverEndpoint : ServerEndPoint -> ServerTransport

Parameters

binding
Type: NFX.Glue Binding
serverEndpoint
Type: NFX.Glue ServerEndPoint
See Also
ServerTransport Class
ServerTransport Members
ServerTransport Overload
NFX.Glue Namespace


ServerTransport Constructor (Binding, ServerTransport)

ServerTransport Constructor (Binding, ServerTransport) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates instance of a transport that resulted from connection accept by listener. Not all technologies support listener/child transports (TCP does)

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerTransport(
    Binding binding,
    ServerTransport listener
)
protected ServerTransport(
    Binding binding,
    ServerTransport listener
)
Protected Sub New (
    binding As Binding,
    listener As ServerTransport
)
Protected Sub New (
    binding As Binding,
    listener As ServerTransport
)
protected:
ServerTransport(
    Binding^ binding,
    ServerTransport^ listener
)
protected:
ServerTransport(
    Binding^ binding,
    ServerTransport^ listener
)
new :
        binding : Binding *
        listener : ServerTransport -> ServerTransport
new :
        binding : Binding *
        listener : ServerTransport -> ServerTransport

Parameters

binding
Type: NFX.Glue Binding
listener
Type: NFX.Glue ServerTransport
See Also
ServerTransport Class
ServerTransport Members
ServerTransport Overload
NFX.Glue Namespace


ServerTransport Fields

ServerTransport Fields NFX Class Library

The ServerTransport type exposes the following members.
Fields
 | Name | Description
Protected field | m_TransportKind | (Inherited from Transport.)
Back to Top
See Also
ServerTransport Class
NFX.Glue Namespace


ServerTransport Methods

ServerTransport Methods NFX Class Library

The ServerTransport type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and transport instance are running or throws otherwise (Inherited from Transport.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Transport.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoDumpInstrumentationData | Override to dump instrumentation data, dont forget to call base to dump basic metrics (Inherited from Transport.)
Protected method | DoSendResponse | Override to send a response into remote client endpoint
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Inherited from Transport.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | DumpInstrumentationData | Dumps instrumentation data (Inherited from Transport.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Release | Releases transport by setting Acquired flag to false so it can be used by other operations (Inherited from Transport.)
Public method | ResetStats | Resets all statistical counters (Inherited from Transport.)
Public method | SendResponse | Sends a response into remote client endpoint
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Protected method | stat_BytesReceived | (Inherited from Transport.)
Protected method | stat_BytesSent | (Inherited from Transport.)
Protected method | stat_Errors | (Inherited from Transport.)
Protected method | stat_MsgReceived | (Inherited from Transport.)
Protected method | stat_MsgSent | (Inherited from Transport.)
Protected method | stat_Time | Processes named time measurement statistical sample by using EMA filter (Inherited from Transport.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryAcquire | A thread-safe operation that tries to acquire(reserve) this instance for exclusive use. Returns true if acqusition succeded, false is this instance is reserved by someone else (Inherited from Transport.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerTransport Class
NFX.Glue Namespace


ServerTransport.DoSendResponse Method

ServerTransport DoSendResponse Method NFX Class Library

Override to send a response into remote client endpoint

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract bool DoSendResponse(
    ResponseMsg response
)
protected abstract bool DoSendResponse(
    ResponseMsg response
)
Protected MustOverride Function DoSendResponse (
    response As ResponseMsg
) As Boolean
Protected MustOverride Function DoSendResponse (
    response As ResponseMsg
) As Boolean
protected:
virtual bool DoSendResponse(
    ResponseMsg^ response
) abstract
protected:
virtual bool DoSendResponse(
    ResponseMsg^ response
) abstract
abstract DoSendResponse :
        response : ResponseMsg -> bool
abstract DoSendResponse :
        response : ResponseMsg -> bool

Parameters

response
Type: NFX.Glue.Protocol ResponseMsg

Return Value

Type: Online Boolean
See Also
ServerTransport Class
ServerTransport Members
NFX.Glue Namespace


ServerTransport.SendResponse Method

ServerTransport SendResponse Method NFX Class Library

Sends a response into remote client endpoint

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SendResponse(
    ResponseMsg response
)
public bool SendResponse(
    ResponseMsg response
)
Public Function SendResponse (
    response As ResponseMsg
) As Boolean
Public Function SendResponse (
    response As ResponseMsg
) As Boolean
public:
bool SendResponse(
    ResponseMsg^ response
)
public:
bool SendResponse(
    ResponseMsg^ response
)
member SendResponse :
        response : ResponseMsg -> bool
member SendResponse :
        response : ResponseMsg -> bool

Parameters

response
Type: NFX.Glue.Protocol ResponseMsg

Return Value

Type: Online Boolean
See Also
ServerTransport Class
ServerTransport Members
NFX.Glue Namespace


ServerTransport Properties

ServerTransport Properties NFX Class Library

The ServerTransport type exposes the following members.
Properties
 | Name | Description
Public property | Acquired | Returns true when this transport instance has been acquired by some operation and is busy (Inherited from Transport.)
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | Binding | Returns a binding that this transport operates under (Inherited from Transport.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExpirationStart | Returns timestamp when manager touched the instance for last time and no traffic went through it since (Inherited from Transport.)
Public property | Glue | Returns glue implementation that this transport is under (Inherited from Transport.)
Public property | IdleAgeMs | Returns the duration of transport idle period in ms. (Inherited from Transport.)
Public property | IsListener | Indicates whether this instance is the one that accepts connections. Depending on implementation listeners may allocate other transports after they accept incoming connect request (i.e. TCP)
Public property | Listener | Returns a listener transport that opened this one. If this is a listener transport then returns null. Not all technologies support listener/child transports (TCP does)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Node | Returns node that this transport services (Inherited from Transport.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | ServerEndpoint | Returns server endpoint instance that opened this transport
Public property | StatBytesReceived | Returns how many bytes were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatBytesSent | Returns how many bytes were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatErrors | Returns how many message processing errors happened since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgReceived | Returns how many messages were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgSent | Returns how many messages were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatTimes | Returns enumerable of named times measured in double second fractions. The returned times are EMA-filtered from supplied individual measurement samples (Inherited from Transport.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransportKind | Reports if this is a server or client transport (Inherited from Transport.)
Back to Top
See Also
ServerTransport Class
NFX.Glue Namespace


ServerTransport.IsListener Property

ServerTransport IsListener Property NFX Class Library

Indicates whether this instance is the one that accepts connections. Depending on implementation listeners may allocate other transports after they accept incoming connect request (i.e. TCP)

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsListener { get; }
public bool IsListener { get; }
Public ReadOnly Property IsListener As Boolean
    Get
Public ReadOnly Property IsListener As Boolean
    Get
public:
property bool IsListener {
    bool get ();
}
public:
property bool IsListener {
    bool get ();
}
member IsListener : bool with get
member IsListener : bool with get

Property Value

Type: Online Boolean
See Also
ServerTransport Class
ServerTransport Members
NFX.Glue Namespace


ServerTransport.Listener Property

ServerTransport Listener Property NFX Class Library

Returns a listener transport that opened this one. If this is a listener transport then returns null. Not all technologies support listener/child transports (TCP does)

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerTransport Listener { get; }
public ServerTransport Listener { get; }
Public ReadOnly Property Listener As ServerTransport
    Get
Public ReadOnly Property Listener As ServerTransport
    Get
public:
property ServerTransport^ Listener {
    ServerTransport^ get ();
}
public:
property ServerTransport^ Listener {
    ServerTransport^ get ();
}
member Listener : ServerTransport with get
member Listener : ServerTransport with get

Property Value

Type: ServerTransport
See Also
ServerTransport Class
ServerTransport Members
NFX.Glue Namespace


ServerTransport.ServerEndpoint Property

ServerTransport ServerEndpoint Property NFX Class Library

Returns server endpoint instance that opened this transport

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerEndPoint ServerEndpoint { get; }
public ServerEndPoint ServerEndpoint { get; }
Public ReadOnly Property ServerEndpoint As ServerEndPoint
    Get
Public ReadOnly Property ServerEndpoint As ServerEndPoint
    Get
public:
property ServerEndPoint^ ServerEndpoint {
    ServerEndPoint^ get ();
}
public:
property ServerEndPoint^ ServerEndpoint {
    ServerEndPoint^ get ();
}
member ServerEndpoint : ServerEndPoint with get
member ServerEndpoint : ServerEndPoint with get

Property Value

Type: ServerEndPoint
See Also
ServerTransport Class
ServerTransport Members
NFX.Glue Namespace


ServerTransport(TBinding) Class

ServerTransport TBinding Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service Binding
NFX.Glue Transport
NFX.Glue ServerTransport
NFX.Glue ServerTransport TBinding
NFX.Glue.Native InProcServerTransport
NFX.Glue.Native MpxServerTransport
NFX.Glue.Native SyncServerTransport

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class ServerTransport<TBinding> : ServerTransport
where TBinding : Binding
public abstract class ServerTransport<TBinding> : ServerTransport
where TBinding : Binding
Public MustInherit Class ServerTransport(Of TBinding As Binding)
    Inherits ServerTransport
Public MustInherit Class ServerTransport(Of TBinding As Binding)
    Inherits ServerTransport
generic<typename TBinding>
where TBinding : Binding
public ref class ServerTransport abstract : public ServerTransport
generic<typename TBinding>
where TBinding : Binding
public ref class ServerTransport abstract : public ServerTransport
[<AbstractClassAttribute>]
type ServerTransport<'TBinding when 'TBinding : Binding> =
    class
        inherit ServerTransport
    end
[<AbstractClassAttribute>]
type ServerTransport<'TBinding when 'TBinding : Binding> =
    class
        inherit ServerTransport
    end
Type Parameters
TBinding
See Also
ServerTransport TBinding Members
NFX.Glue Namespace


ServerTransport(TBinding) Members

ServerTransport TBinding Members NFX Class Library

The ServerTransport TBinding type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerTransport TBinding (Binding, ServerEndPoint) | Creates an instance of listener transport
Protected method | ServerTransport TBinding (Binding, ServerTransport) | Creates instance of a transport that resulted from connection accept by listener. Not all technologies support listener/child transports (TCP does)
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and transport instance are running or throws otherwise (Inherited from Transport.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Transport.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoDumpInstrumentationData | Override to dump instrumentation data, dont forget to call base to dump basic metrics (Inherited from Transport.)
Protected method | DoSendResponse | Override to send a response into remote client endpoint (Inherited from ServerTransport.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Inherited from Transport.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | DumpInstrumentationData | Dumps instrumentation data (Inherited from Transport.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Release | Releases transport by setting Acquired flag to false so it can be used by other operations (Inherited from Transport.)
Public method | ResetStats | Resets all statistical counters (Inherited from Transport.)
Public method | SendResponse | Sends a response into remote client endpoint (Inherited from ServerTransport.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Protected method | stat_BytesReceived | (Inherited from Transport.)
Protected method | stat_BytesSent | (Inherited from Transport.)
Protected method | stat_Errors | (Inherited from Transport.)
Protected method | stat_MsgReceived | (Inherited from Transport.)
Protected method | stat_MsgSent | (Inherited from Transport.)
Protected method | stat_Time | Processes named time measurement statistical sample by using EMA filter (Inherited from Transport.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryAcquire | A thread-safe operation that tries to acquire(reserve) this instance for exclusive use. Returns true if acqusition succeded, false is this instance is reserved by someone else (Inherited from Transport.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_TransportKind | (Inherited from Transport.)
Back to Top
Properties
 | Name | Description
Public property | Acquired | Returns true when this transport instance has been acquired by some operation and is busy (Inherited from Transport.)
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | Binding |
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExpirationStart | Returns timestamp when manager touched the instance for last time and no traffic went through it since (Inherited from Transport.)
Public property | Glue | Returns glue implementation that this transport is under (Inherited from Transport.)
Public property | IdleAgeMs | Returns the duration of transport idle period in ms. (Inherited from Transport.)
Public property | IsListener | Indicates whether this instance is the one that accepts connections. Depending on implementation listeners may allocate other transports after they accept incoming connect request (i.e. TCP) (Inherited from ServerTransport.)
Public property | Listener | Returns a listener transport that opened this one. If this is a listener transport then returns null. Not all technologies support listener/child transports (TCP does) (Inherited from ServerTransport.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Node | Returns node that this transport services (Inherited from Transport.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | ServerEndpoint | Returns server endpoint instance that opened this transport (Inherited from ServerTransport.)
Public property | StatBytesReceived | Returns how many bytes were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatBytesSent | Returns how many bytes were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatErrors | Returns how many message processing errors happened since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgReceived | Returns how many messages were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgSent | Returns how many messages were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatTimes | Returns enumerable of named times measured in double second fractions. The returned times are EMA-filtered from supplied individual measurement samples (Inherited from Transport.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransportKind | Reports if this is a server or client transport (Inherited from Transport.)
Back to Top
See Also
ServerTransport TBinding Class
NFX.Glue Namespace


ServerTransport(TBinding) Constructor

ServerTransport TBinding Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | ServerTransport TBinding (Binding, ServerEndPoint) | Creates an instance of listener transport
Protected method | ServerTransport TBinding (Binding, ServerTransport) | Creates instance of a transport that resulted from connection accept by listener. Not all technologies support listener/child transports (TCP does)
Back to Top
See Also
ServerTransport TBinding Class
ServerTransport TBinding Members
NFX.Glue Namespace


ServerTransport(TBinding) Constructor (Binding, ServerEndPoint)

ServerTransport TBinding Constructor (Binding, ServerEndPoint) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates an instance of listener transport

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerTransport(
    Binding binding,
    ServerEndPoint serverEndpoint
)
protected ServerTransport(
    Binding binding,
    ServerEndPoint serverEndpoint
)
Protected Sub New (
    binding As Binding,
    serverEndpoint As ServerEndPoint
)
Protected Sub New (
    binding As Binding,
    serverEndpoint As ServerEndPoint
)
protected:
ServerTransport(
    Binding^ binding,
    ServerEndPoint^ serverEndpoint
)
protected:
ServerTransport(
    Binding^ binding,
    ServerEndPoint^ serverEndpoint
)
new :
        binding : Binding *
        serverEndpoint : ServerEndPoint -> ServerTransport
new :
        binding : Binding *
        serverEndpoint : ServerEndPoint -> ServerTransport

Parameters

binding
Type: NFX.Glue Binding
serverEndpoint
Type: NFX.Glue ServerEndPoint
See Also
ServerTransport TBinding Class
ServerTransport TBinding Members
ServerTransport TBinding Overload
NFX.Glue Namespace


ServerTransport(TBinding) Constructor (Binding, ServerTransport)

ServerTransport TBinding Constructor (Binding, ServerTransport) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates instance of a transport that resulted from connection accept by listener. Not all technologies support listener/child transports (TCP does)

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerTransport(
    Binding binding,
    ServerTransport listener
)
protected ServerTransport(
    Binding binding,
    ServerTransport listener
)
Protected Sub New (
    binding As Binding,
    listener As ServerTransport
)
Protected Sub New (
    binding As Binding,
    listener As ServerTransport
)
protected:
ServerTransport(
    Binding^ binding,
    ServerTransport^ listener
)
protected:
ServerTransport(
    Binding^ binding,
    ServerTransport^ listener
)
new :
        binding : Binding *
        listener : ServerTransport -> ServerTransport
new :
        binding : Binding *
        listener : ServerTransport -> ServerTransport

Parameters

binding
Type: NFX.Glue Binding
listener
Type: NFX.Glue ServerTransport
See Also
ServerTransport TBinding Class
ServerTransport TBinding Members
ServerTransport TBinding Overload
NFX.Glue Namespace


ServerTransport(TBinding) Fields

ServerTransport TBinding Fields NFX Class Library

The ServerTransport TBinding type exposes the following members.
Fields
 | Name | Description
Protected field | m_TransportKind | (Inherited from Transport.)
Back to Top
See Also
ServerTransport TBinding Class
NFX.Glue Namespace


ServerTransport(TBinding) Methods

ServerTransport TBinding Methods NFX Class Library

The ServerTransport TBinding type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and transport instance are running or throws otherwise (Inherited from Transport.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Transport.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoDumpInstrumentationData | Override to dump instrumentation data, dont forget to call base to dump basic metrics (Inherited from Transport.)
Protected method | DoSendResponse | Override to send a response into remote client endpoint (Inherited from ServerTransport.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Inherited from Transport.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | DumpInstrumentationData | Dumps instrumentation data (Inherited from Transport.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Release | Releases transport by setting Acquired flag to false so it can be used by other operations (Inherited from Transport.)
Public method | ResetStats | Resets all statistical counters (Inherited from Transport.)
Public method | SendResponse | Sends a response into remote client endpoint (Inherited from ServerTransport.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Protected method | stat_BytesReceived | (Inherited from Transport.)
Protected method | stat_BytesSent | (Inherited from Transport.)
Protected method | stat_Errors | (Inherited from Transport.)
Protected method | stat_MsgReceived | (Inherited from Transport.)
Protected method | stat_MsgSent | (Inherited from Transport.)
Protected method | stat_Time | Processes named time measurement statistical sample by using EMA filter (Inherited from Transport.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryAcquire | A thread-safe operation that tries to acquire(reserve) this instance for exclusive use. Returns true if acqusition succeded, false is this instance is reserved by someone else (Inherited from Transport.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerTransport TBinding Class
NFX.Glue Namespace


ServerTransport(TBinding) Properties

ServerTransport TBinding Properties NFX Class Library

The ServerTransport TBinding type exposes the following members.
Properties
 | Name | Description
Public property | Acquired | Returns true when this transport instance has been acquired by some operation and is busy (Inherited from Transport.)
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | Binding |
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExpirationStart | Returns timestamp when manager touched the instance for last time and no traffic went through it since (Inherited from Transport.)
Public property | Glue | Returns glue implementation that this transport is under (Inherited from Transport.)
Public property | IdleAgeMs | Returns the duration of transport idle period in ms. (Inherited from Transport.)
Public property | IsListener | Indicates whether this instance is the one that accepts connections. Depending on implementation listeners may allocate other transports after they accept incoming connect request (i.e. TCP) (Inherited from ServerTransport.)
Public property | Listener | Returns a listener transport that opened this one. If this is a listener transport then returns null. Not all technologies support listener/child transports (TCP does) (Inherited from ServerTransport.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Node | Returns node that this transport services (Inherited from Transport.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | ServerEndpoint | Returns server endpoint instance that opened this transport (Inherited from ServerTransport.)
Public property | StatBytesReceived | Returns how many bytes were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatBytesSent | Returns how many bytes were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatErrors | Returns how many message processing errors happened since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgReceived | Returns how many messages were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgSent | Returns how many messages were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatTimes | Returns enumerable of named times measured in double second fractions. The returned times are EMA-filtered from supplied individual measurement samples (Inherited from Transport.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransportKind | Reports if this is a server or client transport (Inherited from Transport.)
Back to Top
See Also
ServerTransport TBinding Class
NFX.Glue Namespace


ServerTransport(TBinding).Binding Property

ServerTransport TBinding Binding Property NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TBinding Binding { get; }
public TBinding Binding { get; }
Public ReadOnly Property Binding As TBinding
    Get
Public ReadOnly Property Binding As TBinding
    Get
public:
virtual property TBinding Binding {
    TBinding get () sealed;
}
public:
virtual property TBinding Binding {
    TBinding get () sealed;
}
abstract Binding : 'TBinding with get
override Binding : 'TBinding with get
abstract Binding : 'TBinding with get
override Binding : 'TBinding with get

Property Value

Type: TBinding
See Also
ServerTransport TBinding Class
ServerTransport TBinding Members
NFX.Glue Namespace


StatefulServerInstanceDoesNotExistException Class

StatefulServerInstanceDoesNotExistException Class NFX Class Library

[This is preliminary documentation and is subject to change.]

Exception thrown when statful server identified is not found/has expired/timed-out
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Glue GlueException
NFX.Glue ServerException
NFX.Glue ServerInstanceActivationException
NFX.Glue StatefulServerInstanceDoesNotExistException

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class StatefulServerInstanceDoesNotExistException : ServerInstanceActivationException
[SerializableAttribute]
public class StatefulServerInstanceDoesNotExistException : ServerInstanceActivationException
<SerializableAttribute>
Public Class StatefulServerInstanceDoesNotExistException
    Inherits ServerInstanceActivationException
<SerializableAttribute>
Public Class StatefulServerInstanceDoesNotExistException
    Inherits ServerInstanceActivationException
[SerializableAttribute]
public ref class StatefulServerInstanceDoesNotExistException : public ServerInstanceActivationException
[SerializableAttribute]
public ref class StatefulServerInstanceDoesNotExistException : public ServerInstanceActivationException
[<SerializableAttribute>]
type StatefulServerInstanceDoesNotExistException =
    class
        inherit ServerInstanceActivationException
    end
[<SerializableAttribute>]
type StatefulServerInstanceDoesNotExistException =
    class
        inherit ServerInstanceActivationException
    end
See Also
StatefulServerInstanceDoesNotExistException Members
NFX.Glue Namespace


StatefulServerInstanceDoesNotExistException Members

StatefulServerInstanceDoesNotExistException Members NFX Class Library

[This is preliminary documentation and is subject to change.]

The StatefulServerInstanceDoesNotExistException type exposes the following members.
Constructors
 | Name | Description
Public method | StatefulServerInstanceDoesNotExistException | Initializes a new instance of the StatefulServerInstanceDoesNotExistException class
Public method | StatefulServerInstanceDoesNotExistException(String) | Initializes a new instance of the StatefulServerInstanceDoesNotExistException class
Protected method | StatefulServerInstanceDoesNotExistException(SerializationInfo, StreamingContext) | Initializes a new instance of the StatefulServerInstanceDoesNotExistException class
Public method | StatefulServerInstanceDoesNotExistException(String, Exception) | Initializes a new instance of the StatefulServerInstanceDoesNotExistException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
StatefulServerInstanceDoesNotExistException Class
NFX.Glue Namespace


StatefulServerInstanceDoesNotExistException Constructor

StatefulServerInstanceDoesNotExistException Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public method | StatefulServerInstanceDoesNotExistException | Initializes a new instance of the StatefulServerInstanceDoesNotExistException class
Public method | StatefulServerInstanceDoesNotExistException(String) | Initializes a new instance of the StatefulServerInstanceDoesNotExistException class
Protected method | StatefulServerInstanceDoesNotExistException(SerializationInfo, StreamingContext) | Initializes a new instance of the StatefulServerInstanceDoesNotExistException class
Public method | StatefulServerInstanceDoesNotExistException(String, Exception) | Initializes a new instance of the StatefulServerInstanceDoesNotExistException class
Back to Top
See Also
StatefulServerInstanceDoesNotExistException Class
StatefulServerInstanceDoesNotExistException Members
NFX.Glue Namespace


StatefulServerInstanceDoesNotExistException Constructor

StatefulServerInstanceDoesNotExistException Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the StatefulServerInstanceDoesNotExistException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StatefulServerInstanceDoesNotExistException()
public StatefulServerInstanceDoesNotExistException()
Public Sub New
Public Sub New
public:
StatefulServerInstanceDoesNotExistException()
public:
StatefulServerInstanceDoesNotExistException()
new : unit -> StatefulServerInstanceDoesNotExistException
new : unit -> StatefulServerInstanceDoesNotExistException
See Also
StatefulServerInstanceDoesNotExistException Class
StatefulServerInstanceDoesNotExistException Members
StatefulServerInstanceDoesNotExistException Overload
NFX.Glue Namespace


StatefulServerInstanceDoesNotExistException Constructor (String)

StatefulServerInstanceDoesNotExistException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the StatefulServerInstanceDoesNotExistException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StatefulServerInstanceDoesNotExistException(
    string message
)
public StatefulServerInstanceDoesNotExistException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
StatefulServerInstanceDoesNotExistException(
    String^ message
)
public:
StatefulServerInstanceDoesNotExistException(
    String^ message
)
new :
        message : string -> StatefulServerInstanceDoesNotExistException
new :
        message : string -> StatefulServerInstanceDoesNotExistException

Parameters

message
Type: Online System String
See Also
StatefulServerInstanceDoesNotExistException Class
StatefulServerInstanceDoesNotExistException Members
StatefulServerInstanceDoesNotExistException Overload
NFX.Glue Namespace


StatefulServerInstanceDoesNotExistException Constructor (SerializationInfo, StreamingContext)

StatefulServerInstanceDoesNotExistException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the StatefulServerInstanceDoesNotExistException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected StatefulServerInstanceDoesNotExistException(
    SerializationInfo info,
    StreamingContext context
)
protected StatefulServerInstanceDoesNotExistException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
StatefulServerInstanceDoesNotExistException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
StatefulServerInstanceDoesNotExistException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> StatefulServerInstanceDoesNotExistException
new :
        info : SerializationInfo *
        context : StreamingContext -> StatefulServerInstanceDoesNotExistException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
StatefulServerInstanceDoesNotExistException Class
StatefulServerInstanceDoesNotExistException Members
StatefulServerInstanceDoesNotExistException Overload
NFX.Glue Namespace


StatefulServerInstanceDoesNotExistException Constructor (String, Exception)

StatefulServerInstanceDoesNotExistException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the StatefulServerInstanceDoesNotExistException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StatefulServerInstanceDoesNotExistException(
    string message,
    Exception inner
)
public StatefulServerInstanceDoesNotExistException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
StatefulServerInstanceDoesNotExistException(
    String^ message,
    Exception^ inner
)
public:
StatefulServerInstanceDoesNotExistException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> StatefulServerInstanceDoesNotExistException
new :
        message : string *
        inner : Exception -> StatefulServerInstanceDoesNotExistException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
StatefulServerInstanceDoesNotExistException Class
StatefulServerInstanceDoesNotExistException Members
StatefulServerInstanceDoesNotExistException Overload
NFX.Glue Namespace


StatefulServerInstanceDoesNotExistException Methods

StatefulServerInstanceDoesNotExistException Methods NFX Class Library

[This is preliminary documentation and is subject to change.]

The StatefulServerInstanceDoesNotExistException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
StatefulServerInstanceDoesNotExistException Class
NFX.Glue Namespace


StatefulServerInstanceDoesNotExistException Properties

StatefulServerInstanceDoesNotExistException Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The StatefulServerInstanceDoesNotExistException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
StatefulServerInstanceDoesNotExistException Class
NFX.Glue Namespace


StatefulServerInstanceDoesNotExistException Events

StatefulServerInstanceDoesNotExistException Events NFX Class Library

[This is preliminary documentation and is subject to change.]

The StatefulServerInstanceDoesNotExistException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
StatefulServerInstanceDoesNotExistException Class
NFX.Glue Namespace


StatefulServerInstanceLockTimeoutException Class

StatefulServerInstanceLockTimeoutException Class NFX Class Library

[This is preliminary documentation and is subject to change.]

Exception thrown when statful server instance is not thread safe and could not be locked before set timeout expired
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Glue GlueException
NFX.Glue ServerException
NFX.Glue ServerInstanceActivationException
NFX.Glue StatefulServerInstanceLockTimeoutException

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class StatefulServerInstanceLockTimeoutException : ServerInstanceActivationException
[SerializableAttribute]
public class StatefulServerInstanceLockTimeoutException : ServerInstanceActivationException
<SerializableAttribute>
Public Class StatefulServerInstanceLockTimeoutException
    Inherits ServerInstanceActivationException
<SerializableAttribute>
Public Class StatefulServerInstanceLockTimeoutException
    Inherits ServerInstanceActivationException
[SerializableAttribute]
public ref class StatefulServerInstanceLockTimeoutException : public ServerInstanceActivationException
[SerializableAttribute]
public ref class StatefulServerInstanceLockTimeoutException : public ServerInstanceActivationException
[<SerializableAttribute>]
type StatefulServerInstanceLockTimeoutException =
    class
        inherit ServerInstanceActivationException
    end
[<SerializableAttribute>]
type StatefulServerInstanceLockTimeoutException =
    class
        inherit ServerInstanceActivationException
    end
See Also
StatefulServerInstanceLockTimeoutException Members
NFX.Glue Namespace


StatefulServerInstanceLockTimeoutException Members

StatefulServerInstanceLockTimeoutException Members NFX Class Library

[This is preliminary documentation and is subject to change.]

The StatefulServerInstanceLockTimeoutException type exposes the following members.
Constructors
 | Name | Description
Public method | StatefulServerInstanceLockTimeoutException | Initializes a new instance of the StatefulServerInstanceLockTimeoutException class
Public method | StatefulServerInstanceLockTimeoutException(String) | Initializes a new instance of the StatefulServerInstanceLockTimeoutException class
Protected method | StatefulServerInstanceLockTimeoutException(SerializationInfo, StreamingContext) | Initializes a new instance of the StatefulServerInstanceLockTimeoutException class
Public method | StatefulServerInstanceLockTimeoutException(String, Exception) | Initializes a new instance of the StatefulServerInstanceLockTimeoutException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
StatefulServerInstanceLockTimeoutException Class
NFX.Glue Namespace


StatefulServerInstanceLockTimeoutException Constructor

StatefulServerInstanceLockTimeoutException Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public method | StatefulServerInstanceLockTimeoutException | Initializes a new instance of the StatefulServerInstanceLockTimeoutException class
Public method | StatefulServerInstanceLockTimeoutException(String) | Initializes a new instance of the StatefulServerInstanceLockTimeoutException class
Protected method | StatefulServerInstanceLockTimeoutException(SerializationInfo, StreamingContext) | Initializes a new instance of the StatefulServerInstanceLockTimeoutException class
Public method | StatefulServerInstanceLockTimeoutException(String, Exception) | Initializes a new instance of the StatefulServerInstanceLockTimeoutException class
Back to Top
See Also
StatefulServerInstanceLockTimeoutException Class
StatefulServerInstanceLockTimeoutException Members
NFX.Glue Namespace


StatefulServerInstanceLockTimeoutException Constructor

StatefulServerInstanceLockTimeoutException Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the StatefulServerInstanceLockTimeoutException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StatefulServerInstanceLockTimeoutException()
public StatefulServerInstanceLockTimeoutException()
Public Sub New
Public Sub New
public:
StatefulServerInstanceLockTimeoutException()
public:
StatefulServerInstanceLockTimeoutException()
new : unit -> StatefulServerInstanceLockTimeoutException
new : unit -> StatefulServerInstanceLockTimeoutException
See Also
StatefulServerInstanceLockTimeoutException Class
StatefulServerInstanceLockTimeoutException Members
StatefulServerInstanceLockTimeoutException Overload
NFX.Glue Namespace


StatefulServerInstanceLockTimeoutException Constructor (String)

StatefulServerInstanceLockTimeoutException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the StatefulServerInstanceLockTimeoutException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StatefulServerInstanceLockTimeoutException(
    string message
)
public StatefulServerInstanceLockTimeoutException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
StatefulServerInstanceLockTimeoutException(
    String^ message
)
public:
StatefulServerInstanceLockTimeoutException(
    String^ message
)
new :
        message : string -> StatefulServerInstanceLockTimeoutException
new :
        message : string -> StatefulServerInstanceLockTimeoutException

Parameters

message
Type: Online System String
See Also
StatefulServerInstanceLockTimeoutException Class
StatefulServerInstanceLockTimeoutException Members
StatefulServerInstanceLockTimeoutException Overload
NFX.Glue Namespace


StatefulServerInstanceLockTimeoutException Constructor (SerializationInfo, StreamingContext)

StatefulServerInstanceLockTimeoutException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the StatefulServerInstanceLockTimeoutException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected StatefulServerInstanceLockTimeoutException(
    SerializationInfo info,
    StreamingContext context
)
protected StatefulServerInstanceLockTimeoutException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
StatefulServerInstanceLockTimeoutException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
StatefulServerInstanceLockTimeoutException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> StatefulServerInstanceLockTimeoutException
new :
        info : SerializationInfo *
        context : StreamingContext -> StatefulServerInstanceLockTimeoutException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
StatefulServerInstanceLockTimeoutException Class
StatefulServerInstanceLockTimeoutException Members
StatefulServerInstanceLockTimeoutException Overload
NFX.Glue Namespace


StatefulServerInstanceLockTimeoutException Constructor (String, Exception)

StatefulServerInstanceLockTimeoutException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the StatefulServerInstanceLockTimeoutException class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StatefulServerInstanceLockTimeoutException(
    string message,
    Exception inner
)
public StatefulServerInstanceLockTimeoutException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
StatefulServerInstanceLockTimeoutException(
    String^ message,
    Exception^ inner
)
public:
StatefulServerInstanceLockTimeoutException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> StatefulServerInstanceLockTimeoutException
new :
        message : string *
        inner : Exception -> StatefulServerInstanceLockTimeoutException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
StatefulServerInstanceLockTimeoutException Class
StatefulServerInstanceLockTimeoutException Members
StatefulServerInstanceLockTimeoutException Overload
NFX.Glue Namespace


StatefulServerInstanceLockTimeoutException Methods

StatefulServerInstanceLockTimeoutException Methods NFX Class Library

[This is preliminary documentation and is subject to change.]

The StatefulServerInstanceLockTimeoutException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
StatefulServerInstanceLockTimeoutException Class
NFX.Glue Namespace


StatefulServerInstanceLockTimeoutException Properties

StatefulServerInstanceLockTimeoutException Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The StatefulServerInstanceLockTimeoutException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
StatefulServerInstanceLockTimeoutException Class
NFX.Glue Namespace


StatefulServerInstanceLockTimeoutException Events

StatefulServerInstanceLockTimeoutException Events NFX Class Library

[This is preliminary documentation and is subject to change.]

The StatefulServerInstanceLockTimeoutException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
StatefulServerInstanceLockTimeoutException Class
NFX.Glue Namespace


ThreadSafeAttribute Class

ThreadSafeAttribute Class NFX Class Library

Indicates that server instance should not be lock()-ed by Glue handler because it is implemented in a thread-safe way. This attribute has no effect for Glue servers that are not [LifeCycle(Stateful)], because they are never locked. Singleton servers must be thread-safe by definition so this attribute is not needed for Singleton servers. If the server is implemented in a thread-safe way, then addition of this attribute may give 15-30% performance boost from Glue runtime when many parallel requests are trying to work with the same instance, however this benefit may be nullified by inefficient user locking code within server implementation. Leaving this attribute out is safer
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.Glue ThreadSafeAttribute

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false, Inherited = false)]
public class ThreadSafeAttribute : Attribute
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false, Inherited = false)]
public class ThreadSafeAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := false, Inherited := false)>
Public Class ThreadSafeAttribute
    Inherits Attribute
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := false, Inherited := false)>
Public Class ThreadSafeAttribute
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = false, Inherited = false)]
public ref class ThreadSafeAttribute : public Attribute
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = false, Inherited = false)]
public ref class ThreadSafeAttribute : public Attribute
[<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false, Inherited = false)>]
type ThreadSafeAttribute =
    class
        inherit Attribute
    end
[<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false, Inherited = false)>]
type ThreadSafeAttribute =
    class
        inherit Attribute
    end
See Also
ThreadSafeAttribute Members
NFX.Glue Namespace


ThreadSafeAttribute Members

ThreadSafeAttribute Members NFX Class Library

The ThreadSafeAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | ThreadSafeAttribute | Initializes a new instance of the ThreadSafeAttribute class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
ThreadSafeAttribute Class
NFX.Glue Namespace


ThreadSafeAttribute Constructor

ThreadSafeAttribute Constructor NFX Class Library

Initializes a new instance of the ThreadSafeAttribute class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ThreadSafeAttribute()
public ThreadSafeAttribute()
Public Sub New
Public Sub New
public:
ThreadSafeAttribute()
public:
ThreadSafeAttribute()
new : unit -> ThreadSafeAttribute
new : unit -> ThreadSafeAttribute
See Also
ThreadSafeAttribute Class
ThreadSafeAttribute Members
NFX.Glue Namespace


ThreadSafeAttribute Methods

ThreadSafeAttribute Methods NFX Class Library

The ThreadSafeAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ThreadSafeAttribute Class
NFX.Glue Namespace


ThreadSafeAttribute Properties

ThreadSafeAttribute Properties NFX Class Library

The ThreadSafeAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
ThreadSafeAttribute Class
NFX.Glue Namespace


TimeoutReactor Class

TimeoutReactor Class NFX Class Library

Internal class that polls call slots for timeout
Inheritance Hierarchy
Online System Object
NFX.Glue TimeoutReactor

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static class TimeoutReactor
internal static class TimeoutReactor
Friend NotInheritable Class TimeoutReactor
Friend NotInheritable Class TimeoutReactor
internal ref class TimeoutReactor abstract sealed
internal ref class TimeoutReactor abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type TimeoutReactor =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type TimeoutReactor =  class end
See Also
TimeoutReactor Members
NFX.Glue Namespace


TimeoutReactor Members

TimeoutReactor Members NFX Class Library

The TimeoutReactor type exposes the following members.
Methods
Name | Description
Subscribe |
Back to Top
See Also
TimeoutReactor Class
NFX.Glue Namespace


TimeoutReactor Methods

TimeoutReactor Methods NFX Class Library

The TimeoutReactor type exposes the following members.
Methods
Name | Description
Subscribe |
Back to Top
See Also
TimeoutReactor Class
NFX.Glue Namespace


TimeoutReactor.Subscribe Method

TimeoutReactor Subscribe Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Subscribe(
    CallSlot call
)
public static void Subscribe(
    CallSlot call
)
Public Shared Sub Subscribe (
    call As CallSlot
)
Public Shared Sub Subscribe (
    call As CallSlot
)
public:
static void Subscribe(
    CallSlot^ call
)
public:
static void Subscribe(
    CallSlot^ call
)
static member Subscribe :
        call : CallSlot -> unit
static member Subscribe :
        call : CallSlot -> unit

Parameters

call
Type: NFX.Glue CallSlot
See Also
TimeoutReactor Class
TimeoutReactor Members
NFX.Glue Namespace


Transport Class

Transport Class NFX Class Library

Transports are thread-safe and are intended for use by multiple threads from ClientCallReactor and ServerProcessor when bindings operate in OperationFlow.Asynchronous mode. Transports are acquired by the thread that creates them
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service Binding
NFX.Glue Transport
NFX.Glue ClientTransport
NFX.Glue ServerTransport

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Transport : Service<Binding>
public abstract class Transport : Service<Binding>
Public MustInherit Class Transport
    Inherits Service(Of Binding)
Public MustInherit Class Transport
    Inherits Service(Of Binding)
public ref class Transport abstract : public Service<Binding^>
public ref class Transport abstract : public Service<Binding^>
[<AbstractClassAttribute>]
type Transport =
    class
        inherit Service<Binding>
    end
[<AbstractClassAttribute>]
type Transport =
    class
        inherit Service<Binding>
    end
See Also
Transport Members
NFX.Glue Namespace


Transport Members

Transport Members NFX Class Library

The Transport type exposes the following members.
Constructors
 | Name | Description
Protected method | Transport | Initializes a new instance of the Transport class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and transport instance are running or throws otherwise
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Overrides Service Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoDumpInstrumentationData | Override to dump instrumentation data, dont forget to call base to dump basic metrics
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | DumpInstrumentationData | Dumps instrumentation data
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Release | Releases transport by setting Acquired flag to false so it can be used by other operations
Public method | ResetStats | Resets all statistical counters
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Protected method | stat_BytesReceived |
Protected method | stat_BytesSent |
Protected method | stat_Errors |
Protected method | stat_MsgReceived |
Protected method | stat_MsgSent |
Protected method | stat_Time | Processes named time measurement statistical sample by using EMA filter
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryAcquire | A thread-safe operation that tries to acquire(reserve) this instance for exclusive use. Returns true if acqusition succeded, false is this instance is reserved by someone else
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_TransportKind |
Back to Top
Properties
 | Name | Description
Public property | Acquired | Returns true when this transport instance has been acquired by some operation and is busy
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | Binding | Returns a binding that this transport operates under
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExpirationStart | Returns timestamp when manager touched the instance for last time and no traffic went through it since
Public property | Glue | Returns glue implementation that this transport is under
Public property | IdleAgeMs | Returns the duration of transport idle period in ms.
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Node | Returns node that this transport services
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | StatBytesReceived | Returns how many bytes were received since .ctor or last ResetStats() call
Public property | StatBytesSent | Returns how many bytes were sent since .ctor or last ResetStats() call
Public property | StatErrors | Returns how many message processing errors happened since .ctor or last ResetStats() call
Public property | StatMsgReceived | Returns how many messages were received since .ctor or last ResetStats() call
Public property | StatMsgSent | Returns how many messages were sent since .ctor or last ResetStats() call
Public property | StatTimes | Returns enumerable of named times measured in double second fractions. The returned times are EMA-filtered from supplied individual measurement samples
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransportKind | Reports if this is a server or client transport
Back to Top
See Also
Transport Class
NFX.Glue Namespace


Transport Constructor

Transport Constructor NFX Class Library

Initializes a new instance of the Transport class

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Transport(
    Binding binding,
    TransportKind kind
)
protected Transport(
    Binding binding,
    TransportKind kind
)
Protected Sub New (
    binding As Binding,
    kind As TransportKind
)
Protected Sub New (
    binding As Binding,
    kind As TransportKind
)
protected:
Transport(
    Binding^ binding,
    TransportKind kind
)
protected:
Transport(
    Binding^ binding,
    TransportKind kind
)
new :
        binding : Binding *
        kind : TransportKind -> Transport
new :
        binding : Binding *
        kind : TransportKind -> Transport

Parameters

binding
Type: NFX.Glue Binding
kind
Type: NFX.Glue TransportKind
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport Fields

Transport Fields NFX Class Library

The Transport type exposes the following members.
Fields
 | Name | Description
Protected field | m_TransportKind |
Back to Top
See Also
Transport Class
NFX.Glue Namespace


Transport.m_TransportKind Field

Transport m_TransportKind Field NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TransportKind m_TransportKind
protected TransportKind m_TransportKind
Protected m_TransportKind As TransportKind
Protected m_TransportKind As TransportKind
protected:
TransportKind m_TransportKind
protected:
TransportKind m_TransportKind
val mutable m_TransportKind: TransportKind
val mutable m_TransportKind: TransportKind

Field Value

Type: TransportKind
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport Methods

Transport Methods NFX Class Library

The Transport type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and transport instance are running or throws otherwise
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Overrides Service Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoDumpInstrumentationData | Override to dump instrumentation data, dont forget to call base to dump basic metrics
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | DumpInstrumentationData | Dumps instrumentation data
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Release | Releases transport by setting Acquired flag to false so it can be used by other operations
Public method | ResetStats | Resets all statistical counters
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Protected method | stat_BytesReceived |
Protected method | stat_BytesSent |
Protected method | stat_Errors |
Protected method | stat_MsgReceived |
Protected method | stat_MsgSent |
Protected method | stat_Time | Processes named time measurement statistical sample by using EMA filter
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryAcquire | A thread-safe operation that tries to acquire(reserve) this instance for exclusive use. Returns true if acqusition succeded, false is this instance is reserved by someone else
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Transport Class
NFX.Glue Namespace


Transport.CheckRunningState Method

Transport CheckRunningState Method NFX Class Library

Ensures that application and transport instance are running or throws otherwise

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CheckRunningState()
public void CheckRunningState()
Public Sub CheckRunningState
Public Sub CheckRunningState
public:
void CheckRunningState()
public:
void CheckRunningState()
member CheckRunningState : unit -> unit
member CheckRunningState : unit -> unit
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport.Destructor Method

Transport Destructor Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport.DoDumpInstrumentationData Method

Transport DoDumpInstrumentationData Method NFX Class Library

Override to dump instrumentation data, dont forget to call base to dump basic metrics

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoDumpInstrumentationData()
protected virtual void DoDumpInstrumentationData()
Protected Overridable Sub DoDumpInstrumentationData
Protected Overridable Sub DoDumpInstrumentationData
protected:
virtual void DoDumpInstrumentationData()
protected:
virtual void DoDumpInstrumentationData()
abstract DoDumpInstrumentationData : unit -> unit
override DoDumpInstrumentationData : unit -> unit
abstract DoDumpInstrumentationData : unit -> unit
override DoDumpInstrumentationData : unit -> unit
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport.DoStart Method

Transport DoStart Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport.DumpInstrumentationData Method

Transport DumpInstrumentationData Method NFX Class Library

Dumps instrumentation data

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DumpInstrumentationData()
public void DumpInstrumentationData()
Public Sub DumpInstrumentationData
Public Sub DumpInstrumentationData
public:
void DumpInstrumentationData()
public:
void DumpInstrumentationData()
member DumpInstrumentationData : unit -> unit
member DumpInstrumentationData : unit -> unit
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport.Release Method

Transport Release Method NFX Class Library

Releases transport by setting Acquired flag to false so it can be used by other operations

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Release()
public void Release()
Public Sub Release
Public Sub Release
public:
void Release()
public:
void Release()
member Release : unit -> unit
member Release : unit -> unit
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport.ResetStats Method

Transport ResetStats Method NFX Class Library

Resets all statistical counters

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ResetStats()
public void ResetStats()
Public Sub ResetStats
Public Sub ResetStats
public:
void ResetStats()
public:
void ResetStats()
member ResetStats : unit -> unit
member ResetStats : unit -> unit
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport.stat_BytesReceived Method

Transport stat_BytesReceived Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal void stat_BytesReceived(
    long val
)
protected internal void stat_BytesReceived(
    long val
)
Protected Friend Sub stat_BytesReceived (
    val As Long
)
Protected Friend Sub stat_BytesReceived (
    val As Long
)
protected public:
void stat_BytesReceived(
    long long val
)
protected public:
void stat_BytesReceived(
    long long val
)
member stat_BytesReceived :
        val : int64 -> unit
member stat_BytesReceived :
        val : int64 -> unit

Parameters

val
Type: Online System Int64
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport.stat_BytesSent Method

Transport stat_BytesSent Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal void stat_BytesSent(
    long val
)
protected internal void stat_BytesSent(
    long val
)
Protected Friend Sub stat_BytesSent (
    val As Long
)
Protected Friend Sub stat_BytesSent (
    val As Long
)
protected public:
void stat_BytesSent(
    long long val
)
protected public:
void stat_BytesSent(
    long long val
)
member stat_BytesSent :
        val : int64 -> unit
member stat_BytesSent :
        val : int64 -> unit

Parameters

val
Type: Online System Int64
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport.stat_Errors Method

Transport stat_Errors Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal void stat_Errors()
protected internal void stat_Errors()
Protected Friend Sub stat_Errors
Protected Friend Sub stat_Errors
protected public:
void stat_Errors()
protected public:
void stat_Errors()
member stat_Errors : unit -> unit
member stat_Errors : unit -> unit
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport.stat_MsgReceived Method

Transport stat_MsgReceived Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal void stat_MsgReceived(
    long count = 1
)
protected internal void stat_MsgReceived(
    long count = 1
)
Protected Friend Sub stat_MsgReceived (
    Optional count As Long = 1
)
Protected Friend Sub stat_MsgReceived (
    Optional count As Long = 1
)
protected public:
void stat_MsgReceived(
    long long count = 1
)
protected public:
void stat_MsgReceived(
    long long count = 1
)
member stat_MsgReceived :
        ?count : int64
(* Defaults:
        let _count = defaultArg count 1
*)
-> unit
member stat_MsgReceived :
        ?count : int64
(* Defaults:
        let _count = defaultArg count 1
*)
-> unit

Parameters

count (Optional)
Type: Online System Int64
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport.stat_MsgSent Method

Transport stat_MsgSent Method NFX Class Library

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal void stat_MsgSent()
protected internal void stat_MsgSent()
Protected Friend Sub stat_MsgSent
Protected Friend Sub stat_MsgSent
protected public:
void stat_MsgSent()
protected public:
void stat_MsgSent()
member stat_MsgSent : unit -> unit
member stat_MsgSent : unit -> unit
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport.stat_Time Method

Transport stat_Time Method NFX Class Library

Processes named time measurement statistical sample by using EMA filter

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal void stat_Time(
    string key,
    long ticks
)
protected internal void stat_Time(
    string key,
    long ticks
)
Protected Friend Sub stat_Time (
    key As String,
    ticks As Long
)
Protected Friend Sub stat_Time (
    key As String,
    ticks As Long
)
protected public:
void stat_Time(
    String^ key,
    long long ticks
)
protected public:
void stat_Time(
    String^ key,
    long long ticks
)
member stat_Time :
        key : string *
        ticks : int64 -> unit
member stat_Time :
        key : string *
        ticks : int64 -> unit

Parameters

key
Type: Online System String
Name of time measurement key
ticks
Type: Online System Int64
Duration in ticks
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport.TryAcquire Method

Transport TryAcquire Method NFX Class Library

A thread-safe operation that tries to acquire(reserve) this instance for exclusive use. Returns true if acqusition succeded, false is this instance is reserved by someone else

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TryAcquire()
public bool TryAcquire()
Public Function TryAcquire As Boolean
Public Function TryAcquire As Boolean
public:
bool TryAcquire()
public:
bool TryAcquire()
member TryAcquire : unit -> bool
member TryAcquire : unit -> bool

Return Value

Type: Online Boolean
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport Properties

Transport Properties NFX Class Library

The Transport type exposes the following members.
Properties
 | Name | Description
Public property | Acquired | Returns true when this transport instance has been acquired by some operation and is busy
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | Binding | Returns a binding that this transport operates under
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExpirationStart | Returns timestamp when manager touched the instance for last time and no traffic went through it since
Public property | Glue | Returns glue implementation that this transport is under
Public property | IdleAgeMs | Returns the duration of transport idle period in ms.
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Node | Returns node that this transport services
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | StatBytesReceived | Returns how many bytes were received since .ctor or last ResetStats() call
Public property | StatBytesSent | Returns how many bytes were sent since .ctor or last ResetStats() call
Public property | StatErrors | Returns how many message processing errors happened since .ctor or last ResetStats() call
Public property | StatMsgReceived | Returns how many messages were received since .ctor or last ResetStats() call
Public property | StatMsgSent | Returns how many messages were sent since .ctor or last ResetStats() call
Public property | StatTimes | Returns enumerable of named times measured in double second fractions. The returned times are EMA-filtered from supplied individual measurement samples
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransportKind | Reports if this is a server or client transport
Back to Top
See Also
Transport Class
NFX.Glue Namespace


Transport.Acquired Property

Transport Acquired Property NFX Class Library

Returns true when this transport instance has been acquired by some operation and is busy

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Acquired { get; }
public bool Acquired { get; }
Public ReadOnly Property Acquired As Boolean
    Get
Public ReadOnly Property Acquired As Boolean
    Get
public:
property bool Acquired {
    bool get ();
}
public:
property bool Acquired {
    bool get ();
}
member Acquired : bool with get
member Acquired : bool with get

Property Value

Type: Online Boolean
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport.Binding Property

Transport Binding Property NFX Class Library

Returns a binding that this transport operates under

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Binding Binding { get; }
public Binding Binding { get; }
Public ReadOnly Property Binding As Binding
    Get
Public ReadOnly Property Binding As Binding
    Get
public:
property Binding^ Binding {
    Binding^ get ();
}
public:
property Binding^ Binding {
    Binding^ get ();
}
member Binding : Binding with get
member Binding : Binding with get

Property Value

Type: Binding
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport.ExpirationStart Property

Transport ExpirationStart Property NFX Class Library

Returns timestamp when manager touched the instance for last time and no traffic went through it since

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> ExpirationStart { get; internal set; }
public Nullable<DateTime> ExpirationStart { get; internal set; }
Public Property ExpirationStart As Nullable(Of DateTime)
    Get
    Friend Set
Public Property ExpirationStart As Nullable(Of DateTime)
    Get
    Friend Set
public:
property Nullable<DateTime> ExpirationStart {
    Nullable<DateTime> get ();
    internal: void set (Nullable<DateTime> value);
}
public:
property Nullable<DateTime> ExpirationStart {
    Nullable<DateTime> get ();
    internal: void set (Nullable<DateTime> value);
}
member ExpirationStart : Nullable<DateTime> with get, internal set
member ExpirationStart : Nullable<DateTime> with get, internal set

Property Value

Type: Online Nullable Online DateTime
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport.Glue Property

Transport Glue Property NFX Class Library

Returns glue implementation that this transport is under

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IGlueImplementation Glue { get; }
public IGlueImplementation Glue { get; }
Public ReadOnly Property Glue As IGlueImplementation
    Get
Public ReadOnly Property Glue As IGlueImplementation
    Get
public:
property IGlueImplementation^ Glue {
    IGlueImplementation^ get ();
}
public:
property IGlueImplementation^ Glue {
    IGlueImplementation^ get ();
}
member Glue : IGlueImplementation with get
member Glue : IGlueImplementation with get

Property Value

Type: IGlueImplementation
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport.IdleAgeMs Property

Transport IdleAgeMs Property NFX Class Library

Returns the duration of transport idle period in ms.

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int IdleAgeMs { get; }
public int IdleAgeMs { get; }
Public ReadOnly Property IdleAgeMs As Integer
    Get
Public ReadOnly Property IdleAgeMs As Integer
    Get
public:
property int IdleAgeMs {
    int get ();
}
public:
property int IdleAgeMs {
    int get ();
}
member IdleAgeMs : int with get
member IdleAgeMs : int with get

Property Value

Type: Online Int32
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport.Node Property

Transport Node Property NFX Class Library

Returns node that this transport services

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Node Node { get; protected set; }
public Node Node { get; protected set; }
Public Property Node As Node
    Get
    Protected Set
Public Property Node As Node
    Get
    Protected Set
public:
property Node Node {
    Node get ();
    protected: void set (Node value);
}
public:
property Node Node {
    Node get ();
    protected: void set (Node value);
}
member Node : Node with get, set
member Node : Node with get, set

Property Value

Type: Node
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport.StatBytesReceived Property

Transport StatBytesReceived Property NFX Class Library

Returns how many bytes were received since .ctor or last ResetStats() call

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long StatBytesReceived { get; }
public long StatBytesReceived { get; }
Public ReadOnly Property StatBytesReceived As Long
    Get
Public ReadOnly Property StatBytesReceived As Long
    Get
public:
property long long StatBytesReceived {
    long long get ();
}
public:
property long long StatBytesReceived {
    long long get ();
}
member StatBytesReceived : int64 with get
member StatBytesReceived : int64 with get

Property Value

Type: Online Int64
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport.StatBytesSent Property

Transport StatBytesSent Property NFX Class Library

Returns how many bytes were sent since .ctor or last ResetStats() call

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long StatBytesSent { get; }
public long StatBytesSent { get; }
Public ReadOnly Property StatBytesSent As Long
    Get
Public ReadOnly Property StatBytesSent As Long
    Get
public:
property long long StatBytesSent {
    long long get ();
}
public:
property long long StatBytesSent {
    long long get ();
}
member StatBytesSent : int64 with get
member StatBytesSent : int64 with get

Property Value

Type: Online Int64
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport.StatErrors Property

Transport StatErrors Property NFX Class Library

Returns how many message processing errors happened since .ctor or last ResetStats() call

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long StatErrors { get; }
public long StatErrors { get; }
Public ReadOnly Property StatErrors As Long
    Get
Public ReadOnly Property StatErrors As Long
    Get
public:
property long long StatErrors {
    long long get ();
}
public:
property long long StatErrors {
    long long get ();
}
member StatErrors : int64 with get
member StatErrors : int64 with get

Property Value

Type: Online Int64
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport.StatMsgReceived Property

Transport StatMsgReceived Property NFX Class Library

Returns how many messages were received since .ctor or last ResetStats() call

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long StatMsgReceived { get; }
public long StatMsgReceived { get; }
Public ReadOnly Property StatMsgReceived As Long
    Get
Public ReadOnly Property StatMsgReceived As Long
    Get
public:
property long long StatMsgReceived {
    long long get ();
}
public:
property long long StatMsgReceived {
    long long get ();
}
member StatMsgReceived : int64 with get
member StatMsgReceived : int64 with get

Property Value

Type: Online Int64
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport.StatMsgSent Property

Transport StatMsgSent Property NFX Class Library

Returns how many messages were sent since .ctor or last ResetStats() call

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long StatMsgSent { get; }
public long StatMsgSent { get; }
Public ReadOnly Property StatMsgSent As Long
    Get
Public ReadOnly Property StatMsgSent As Long
    Get
public:
property long long StatMsgSent {
    long long get ();
}
public:
property long long StatMsgSent {
    long long get ();
}
member StatMsgSent : int64 with get
member StatMsgSent : int64 with get

Property Value

Type: Online Int64
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport.StatTimes Property

Transport StatTimes Property NFX Class Library

Returns enumerable of named times measured in double second fractions. The returned times are EMA-filtered from supplied individual measurement samples

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<KeyValuePair<string, double>> StatTimes { get; }
public IEnumerable<KeyValuePair<string, double>> StatTimes { get; }
Public ReadOnly Property StatTimes As IEnumerable(Of KeyValuePair(Of String, Double))
    Get
Public ReadOnly Property StatTimes As IEnumerable(Of KeyValuePair(Of String, Double))
    Get
public:
property IEnumerable<KeyValuePair<String^, double>>^ StatTimes {
    IEnumerable<KeyValuePair<String^, double>>^ get ();
}
public:
property IEnumerable<KeyValuePair<String^, double>>^ StatTimes {
    IEnumerable<KeyValuePair<String^, double>>^ get ();
}
member StatTimes : IEnumerable<KeyValuePair<string, float>> with get
member StatTimes : IEnumerable<KeyValuePair<string, float>> with get

Property Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Double
See Also
Transport Class
Transport Members
NFX.Glue Namespace


Transport.TransportKind Property

Transport TransportKind Property NFX Class Library

Reports if this is a server or client transport

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TransportKind TransportKind { get; }
public TransportKind TransportKind { get; }
Public ReadOnly Property TransportKind As TransportKind
    Get
Public ReadOnly Property TransportKind As TransportKind
    Get
public:
property TransportKind TransportKind {
    TransportKind get ();
}
public:
property TransportKind TransportKind {
    TransportKind get ();
}
member TransportKind : TransportKind with get
member TransportKind : TransportKind with get

Property Value

Type: TransportKind
See Also
Transport Class
Transport Members
NFX.Glue Namespace


TransportKind Enumeration

TransportKind Enumeration NFX Class Library

Defines kinds of trasport

Namespace: NFX.Glue
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum TransportKind
public enum TransportKind
Public Enumeration TransportKind
Public Enumeration TransportKind
public enum class TransportKind
public enum class TransportKind
type TransportKind
type TransportKind
Members
Member name | Value | Description
Server | 0 |
Client | 1 |
See Also
NFX.Glue Namespace


NFX.Glue.Implementation Namespace

NFX.Glue.Implementation Namespace NFX Class Library

Provides default Glue implementation
Classes
 | Class | Description
Protected class | Calls | Provides thread-safe CallSlot registry where items can be gotten and removed by request ID guid
Public class | GlueService | Provides default implementation for IGlue. This is the root context for all other glue objects
Public class | ServerHandler | Executes server work - handles requests synchronously or asynchronously.
Protected class | ServerHandler serverImplementer |
Structures
 | Structure | Description
Public structure | ServerHandler serverImplementer mapping |


Calls Class

Calls Class NFX Class Library

Provides thread-safe CallSlot registry where items can be gotten and removed by request ID guid
Inheritance Hierarchy
Online System Object
NFX.Glue.Implementation Calls

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class Calls
internal class Calls
Friend Class Calls
Friend Class Calls
internal ref class Calls
internal ref class Calls
type Calls =  class end
type Calls =  class end
See Also
Calls Members
NFX.Glue.Implementation Namespace


Calls Members

Calls Members NFX Class Library

The Calls type exposes the following members.
Constructors
 | Name | Description
Public method | Calls | Initializes a new instance of the Calls class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PurgeTimedOutSlots | Deletes CallSlot entries that have already timed-out. Returns count of slots that got removed. This method is thread-safe but may take some time as it has to visit all buckets. Should be called by Glue manager not frequently (i.e. every few minutes)
Public method | Put | Tries to pur CallSlot instance in the internal list if instance with same ID is not already in the list
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryGetAndRemove | Tries to get, return and remove CallSlot instance by its RequestID from the list. Returns null if CallSlot with such an id does not exist and nothing was removed
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Calls Class
NFX.Glue.Implementation Namespace


Calls Constructor

Calls Constructor NFX Class Library

Initializes a new instance of the Calls class

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Calls(
    int bucketCount
)
public Calls(
    int bucketCount
)
Public Sub New (
    bucketCount As Integer
)
Public Sub New (
    bucketCount As Integer
)
public:
Calls(
    int bucketCount
)
public:
Calls(
    int bucketCount
)
new :
        bucketCount : int -> Calls
new :
        bucketCount : int -> Calls

Parameters

bucketCount
Type: Online System Int32
See Also
Calls Class
Calls Members
NFX.Glue.Implementation Namespace


Calls Methods

Calls Methods NFX Class Library

The Calls type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PurgeTimedOutSlots | Deletes CallSlot entries that have already timed-out. Returns count of slots that got removed. This method is thread-safe but may take some time as it has to visit all buckets. Should be called by Glue manager not frequently (i.e. every few minutes)
Public method | Put | Tries to pur CallSlot instance in the internal list if instance with same ID is not already in the list
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryGetAndRemove | Tries to get, return and remove CallSlot instance by its RequestID from the list. Returns null if CallSlot with such an id does not exist and nothing was removed
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Calls Class
NFX.Glue.Implementation Namespace


Calls.PurgeTimedOutSlots Method

Calls PurgeTimedOutSlots Method NFX Class Library

Deletes CallSlot entries that have already timed-out. Returns count of slots that got removed. This method is thread-safe but may take some time as it has to visit all buckets. Should be called by Glue manager not frequently (i.e. every few minutes)

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int PurgeTimedOutSlots()
public int PurgeTimedOutSlots()
Public Function PurgeTimedOutSlots As Integer
Public Function PurgeTimedOutSlots As Integer
public:
int PurgeTimedOutSlots()
public:
int PurgeTimedOutSlots()
member PurgeTimedOutSlots : unit -> int
member PurgeTimedOutSlots : unit -> int

Return Value

Type: Online Int32
See Also
Calls Class
Calls Members
NFX.Glue.Implementation Namespace


Calls.Put Method

Calls Put Method NFX Class Library

Tries to pur CallSlot instance in the internal list if instance with same ID is not already in the list

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Put(
    CallSlot call
)
public void Put(
    CallSlot call
)
Public Sub Put (
    call As CallSlot
)
Public Sub Put (
    call As CallSlot
)
public:
void Put(
    CallSlot^ call
)
public:
void Put(
    CallSlot^ call
)
member Put :
        call : CallSlot -> unit
member Put :
        call : CallSlot -> unit

Parameters

call
Type: NFX.Glue CallSlot
See Also
Calls Class
Calls Members
NFX.Glue.Implementation Namespace


Calls.TryGetAndRemove Method

Calls TryGetAndRemove Method NFX Class Library

Tries to get, return and remove CallSlot instance by its RequestID from the list. Returns null if CallSlot with such an id does not exist and nothing was removed

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CallSlot TryGetAndRemove(
    FID requestID
)
public CallSlot TryGetAndRemove(
    FID requestID
)
Public Function TryGetAndRemove (
    requestID As FID
) As CallSlot
Public Function TryGetAndRemove (
    requestID As FID
) As CallSlot
public:
CallSlot^ TryGetAndRemove(
    FID requestID
)
public:
CallSlot^ TryGetAndRemove(
    FID requestID
)
member TryGetAndRemove :
        requestID : FID -> CallSlot
member TryGetAndRemove :
        requestID : FID -> CallSlot

Parameters

requestID
Type: NFX FID

Return Value

Type: CallSlot
See Also
Calls Class
Calls Members
NFX.Glue.Implementation Namespace


GlueService Class

GlueService Class NFX Class Library

Provides default implementation for IGlue. This is the root context for all other glue objects
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service Online Object
NFX.ServiceModel ServiceWithInstrumentationBase Online Object
NFX.Glue.Implementation GlueService

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigMacroContextAttribute]
public sealed class GlueService : ServiceWithInstrumentationBase<Object>,
    IGlueImplementation, IGlue, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
[ConfigMacroContextAttribute]
public sealed class GlueService : ServiceWithInstrumentationBase<Object>,
    IGlueImplementation, IGlue, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
<ConfigMacroContextAttribute>
Public NotInheritable Class GlueService
    Inherits ServiceWithInstrumentationBase(Of Object)
    Implements IGlueImplementation, IGlue, IApplicationComponent, ILocalizedTimeProvider,
    IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
<ConfigMacroContextAttribute>
Public NotInheritable Class GlueService
    Inherits ServiceWithInstrumentationBase(Of Object)
    Implements IGlueImplementation, IGlue, IApplicationComponent, ILocalizedTimeProvider,
    IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
[ConfigMacroContextAttribute]
public ref class GlueService sealed : public ServiceWithInstrumentationBase<Object^>,
    IGlueImplementation, IGlue, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
[ConfigMacroContextAttribute]
public ref class GlueService sealed : public ServiceWithInstrumentationBase<Object^>,
    IGlueImplementation, IGlue, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
[<SealedAttribute>]
[<ConfigMacroContextAttribute>]
type GlueService =
    class
        inherit ServiceWithInstrumentationBase<Object>
        interface IGlueImplementation
        interface IGlue
        interface IApplicationComponent
        interface ILocalizedTimeProvider
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
[<SealedAttribute>]
[<ConfigMacroContextAttribute>]
type GlueService =
    class
        inherit ServiceWithInstrumentationBase<Object>
        interface IGlueImplementation
        interface IGlue
        interface IApplicationComponent
        interface ILocalizedTimeProvider
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
GlueService Members
NFX.Glue.Implementation Namespace


GlueService Members

GlueService Members NFX Class Library

The GlueService type exposes the following members.
Constructors
 | Name | Description
Public method | GlueService | Initializes a new instance of the GlueService class
Public method | GlueService(Object) | Initializes a new instance of the GlueService class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | ClientDeliverAsyncResponse |
Public method | ClientDispatchedRequest |
Public method | ClientDispatchingRequest |
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetNodeBinding(String) |
Public method | GetNodeBinding(Node) |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegisterBinding |
Public method | RegisterProvider |
Public method | RegisterServerEndpoint |
Public method | ServerDispatchRequest |
Public method | ServerHandleRequest |
Public method | ServerHandleRequestFailure |
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | UnregisterBinding |
Public method | UnregisterProvider |
Public method | UnregisterServerEndpoint |
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | CONFIG_BINDING_SECTION |
 | CONFIG_BINDINGS_SECTION |
 | CONFIG_PROVIDER_ATTR |
 | CONFIG_PROVIDER_SECTION |
 | CONFIG_PROVIDERS_SECTION |
 | CONFIG_SERVER_SECTION |
 | CONFIG_SERVERS_SECTION |
 | CONFIG_TRANSPORT_SECTION |
 | DEFAULT_CLIENT_LOG_LEVEL |
 | DEFAULT_DISPATCH_TIMEOUT_MS |
 | DEFAULT_SERVER_INSTANCE_LOCK_TIMEOUT_MS |
 | DEFAULT_SERVER_LOG_LEVEL |
 | DEFAULT_TIMEOUT_MS |
Protected field | m_Bindings |
Protected field | m_Providers |
Protected field | m_Servers |
 | MINIMUM_SERVER_INSTANCE_LOCK_TIMEOUT_MS |
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | BindingConfigurations |
Public property | Bindings |
Public property | BindingsConfigurationSection |
Public property | ClientLogLevel |
Public property | ClientMsgInspectors | Returns client message inspectors for this instance
Public property | ComponentCommonName | (Overrides ApplicationComponent ComponentCommonName.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DefaultDispatchTimeoutMs |
Public property | DefaultTimeoutMs |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | GlueConfiguration |
Public property | InstrumentationEnabled | Implements IInstrumentable (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | ProviderConfigurations |
Public property | Providers |
Public property | ProvidersConfigurationSection |
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | ServerConfigurations |
Public property | ServerInstanceLockTimeoutMs |
Public property | ServerLogLevel |
Public property | ServerMsgInspectors | Returns server message inspectors for this instance
Public property | Servers |
Public property | ServersConfigurationSection |
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
GlueService Class
NFX.Glue.Implementation Namespace


GlueService Constructor

GlueService Constructor NFX Class Library

Overload List
 | Name | Description
Public method | GlueService | Initializes a new instance of the GlueService class
Public method | GlueService(Object) | Initializes a new instance of the GlueService class
Back to Top
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService Constructor

GlueService Constructor NFX Class Library

Initializes a new instance of the GlueService class

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlueService()
public GlueService()
Public Sub New
Public Sub New
public:
GlueService()
public:
GlueService()
new : unit -> GlueService
new : unit -> GlueService
See Also
GlueService Class
GlueService Members
GlueService Overload
NFX.Glue.Implementation Namespace


GlueService Constructor (Object)

GlueService Constructor (Object) NFX Class Library

Initializes a new instance of the GlueService class

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlueService(
    Object director
)
public GlueService(
    Object director
)
Public Sub New (
    director As Object
)
Public Sub New (
    director As Object
)
public:
GlueService(
    Object^ director
)
public:
GlueService(
    Object^ director
)
new :
        director : Object -> GlueService
new :
        director : Object -> GlueService

Parameters

director
Type: Online System Object
See Also
GlueService Class
GlueService Members
GlueService Overload
NFX.Glue.Implementation Namespace


GlueService Fields

GlueService Fields NFX Class Library

The GlueService type exposes the following members.
Fields
 | Name | Description
 | CONFIG_BINDING_SECTION |
 | CONFIG_BINDINGS_SECTION |
 | CONFIG_PROVIDER_ATTR |
 | CONFIG_PROVIDER_SECTION |
 | CONFIG_PROVIDERS_SECTION |
 | CONFIG_SERVER_SECTION |
 | CONFIG_SERVERS_SECTION |
 | CONFIG_TRANSPORT_SECTION |
 | DEFAULT_CLIENT_LOG_LEVEL |
 | DEFAULT_DISPATCH_TIMEOUT_MS |
 | DEFAULT_SERVER_INSTANCE_LOCK_TIMEOUT_MS |
 | DEFAULT_SERVER_LOG_LEVEL |
 | DEFAULT_TIMEOUT_MS |
Protected field | m_Bindings |
Protected field | m_Providers |
Protected field | m_Servers |
 | MINIMUM_SERVER_INSTANCE_LOCK_TIMEOUT_MS |
Back to Top
See Also
GlueService Class
NFX.Glue.Implementation Namespace


GlueService.CONFIG_BINDING_SECTION Field

GlueService CONFIG_BINDING_SECTION Field NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_BINDING_SECTION
public const string CONFIG_BINDING_SECTION
Public Const CONFIG_BINDING_SECTION As String
Public Const CONFIG_BINDING_SECTION As String
public:
literal String^ CONFIG_BINDING_SECTION
public:
literal String^ CONFIG_BINDING_SECTION
static val mutable CONFIG_BINDING_SECTION: string
static val mutable CONFIG_BINDING_SECTION: string

Field Value

Type: Online String
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.CONFIG_BINDINGS_SECTION Field

GlueService CONFIG_BINDINGS_SECTION Field NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_BINDINGS_SECTION
public const string CONFIG_BINDINGS_SECTION
Public Const CONFIG_BINDINGS_SECTION As String
Public Const CONFIG_BINDINGS_SECTION As String
public:
literal String^ CONFIG_BINDINGS_SECTION
public:
literal String^ CONFIG_BINDINGS_SECTION
static val mutable CONFIG_BINDINGS_SECTION: string
static val mutable CONFIG_BINDINGS_SECTION: string

Field Value

Type: Online String
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.CONFIG_PROVIDER_ATTR Field

GlueService CONFIG_PROVIDER_ATTR Field NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PROVIDER_ATTR
public const string CONFIG_PROVIDER_ATTR
Public Const CONFIG_PROVIDER_ATTR As String
Public Const CONFIG_PROVIDER_ATTR As String
public:
literal String^ CONFIG_PROVIDER_ATTR
public:
literal String^ CONFIG_PROVIDER_ATTR
static val mutable CONFIG_PROVIDER_ATTR: string
static val mutable CONFIG_PROVIDER_ATTR: string

Field Value

Type: Online String
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.CONFIG_PROVIDER_SECTION Field

GlueService CONFIG_PROVIDER_SECTION Field NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PROVIDER_SECTION
public const string CONFIG_PROVIDER_SECTION
Public Const CONFIG_PROVIDER_SECTION As String
Public Const CONFIG_PROVIDER_SECTION As String
public:
literal String^ CONFIG_PROVIDER_SECTION
public:
literal String^ CONFIG_PROVIDER_SECTION
static val mutable CONFIG_PROVIDER_SECTION: string
static val mutable CONFIG_PROVIDER_SECTION: string

Field Value

Type: Online String
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.CONFIG_PROVIDERS_SECTION Field

GlueService CONFIG_PROVIDERS_SECTION Field NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PROVIDERS_SECTION
public const string CONFIG_PROVIDERS_SECTION
Public Const CONFIG_PROVIDERS_SECTION As String
Public Const CONFIG_PROVIDERS_SECTION As String
public:
literal String^ CONFIG_PROVIDERS_SECTION
public:
literal String^ CONFIG_PROVIDERS_SECTION
static val mutable CONFIG_PROVIDERS_SECTION: string
static val mutable CONFIG_PROVIDERS_SECTION: string

Field Value

Type: Online String
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.CONFIG_SERVER_SECTION Field

GlueService CONFIG_SERVER_SECTION Field NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SERVER_SECTION
public const string CONFIG_SERVER_SECTION
Public Const CONFIG_SERVER_SECTION As String
Public Const CONFIG_SERVER_SECTION As String
public:
literal String^ CONFIG_SERVER_SECTION
public:
literal String^ CONFIG_SERVER_SECTION
static val mutable CONFIG_SERVER_SECTION: string
static val mutable CONFIG_SERVER_SECTION: string

Field Value

Type: Online String
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.CONFIG_SERVERS_SECTION Field

GlueService CONFIG_SERVERS_SECTION Field NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SERVERS_SECTION
public const string CONFIG_SERVERS_SECTION
Public Const CONFIG_SERVERS_SECTION As String
Public Const CONFIG_SERVERS_SECTION As String
public:
literal String^ CONFIG_SERVERS_SECTION
public:
literal String^ CONFIG_SERVERS_SECTION
static val mutable CONFIG_SERVERS_SECTION: string
static val mutable CONFIG_SERVERS_SECTION: string

Field Value

Type: Online String
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.CONFIG_TRANSPORT_SECTION Field

GlueService CONFIG_TRANSPORT_SECTION Field NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_TRANSPORT_SECTION
public const string CONFIG_TRANSPORT_SECTION
Public Const CONFIG_TRANSPORT_SECTION As String
Public Const CONFIG_TRANSPORT_SECTION As String
public:
literal String^ CONFIG_TRANSPORT_SECTION
public:
literal String^ CONFIG_TRANSPORT_SECTION
static val mutable CONFIG_TRANSPORT_SECTION: string
static val mutable CONFIG_TRANSPORT_SECTION: string

Field Value

Type: Online String
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.DEFAULT_CLIENT_LOG_LEVEL Field

GlueService DEFAULT_CLIENT_LOG_LEVEL Field NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const MessageType DEFAULT_CLIENT_LOG_LEVEL
public const MessageType DEFAULT_CLIENT_LOG_LEVEL
Public Const DEFAULT_CLIENT_LOG_LEVEL As MessageType
Public Const DEFAULT_CLIENT_LOG_LEVEL As MessageType
public:
literal MessageType DEFAULT_CLIENT_LOG_LEVEL
public:
literal MessageType DEFAULT_CLIENT_LOG_LEVEL
static val mutable DEFAULT_CLIENT_LOG_LEVEL: MessageType
static val mutable DEFAULT_CLIENT_LOG_LEVEL: MessageType

Field Value

Type: MessageType
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.DEFAULT_DISPATCH_TIMEOUT_MS Field

GlueService DEFAULT_DISPATCH_TIMEOUT_MS Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_DISPATCH_TIMEOUT_MS
public const int DEFAULT_DISPATCH_TIMEOUT_MS
Public Const DEFAULT_DISPATCH_TIMEOUT_MS As Integer
Public Const DEFAULT_DISPATCH_TIMEOUT_MS As Integer
public:
literal int DEFAULT_DISPATCH_TIMEOUT_MS
public:
literal int DEFAULT_DISPATCH_TIMEOUT_MS
static val mutable DEFAULT_DISPATCH_TIMEOUT_MS: int
static val mutable DEFAULT_DISPATCH_TIMEOUT_MS: int

Field Value

Type: Online Int32
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.DEFAULT_SERVER_INSTANCE_LOCK_TIMEOUT_MS Field

GlueService DEFAULT_SERVER_INSTANCE_LOCK_TIMEOUT_MS Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_SERVER_INSTANCE_LOCK_TIMEOUT_MS
public const int DEFAULT_SERVER_INSTANCE_LOCK_TIMEOUT_MS
Public Const DEFAULT_SERVER_INSTANCE_LOCK_TIMEOUT_MS As Integer
Public Const DEFAULT_SERVER_INSTANCE_LOCK_TIMEOUT_MS As Integer
public:
literal int DEFAULT_SERVER_INSTANCE_LOCK_TIMEOUT_MS
public:
literal int DEFAULT_SERVER_INSTANCE_LOCK_TIMEOUT_MS
static val mutable DEFAULT_SERVER_INSTANCE_LOCK_TIMEOUT_MS: int
static val mutable DEFAULT_SERVER_INSTANCE_LOCK_TIMEOUT_MS: int

Field Value

Type: Online Int32
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.DEFAULT_SERVER_LOG_LEVEL Field

GlueService DEFAULT_SERVER_LOG_LEVEL Field NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const MessageType DEFAULT_SERVER_LOG_LEVEL
public const MessageType DEFAULT_SERVER_LOG_LEVEL
Public Const DEFAULT_SERVER_LOG_LEVEL As MessageType
Public Const DEFAULT_SERVER_LOG_LEVEL As MessageType
public:
literal MessageType DEFAULT_SERVER_LOG_LEVEL
public:
literal MessageType DEFAULT_SERVER_LOG_LEVEL
static val mutable DEFAULT_SERVER_LOG_LEVEL: MessageType
static val mutable DEFAULT_SERVER_LOG_LEVEL: MessageType

Field Value

Type: MessageType
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.DEFAULT_TIMEOUT_MS Field

GlueService DEFAULT_TIMEOUT_MS Field NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_TIMEOUT_MS
public const int DEFAULT_TIMEOUT_MS
Public Const DEFAULT_TIMEOUT_MS As Integer
Public Const DEFAULT_TIMEOUT_MS As Integer
public:
literal int DEFAULT_TIMEOUT_MS
public:
literal int DEFAULT_TIMEOUT_MS
static val mutable DEFAULT_TIMEOUT_MS: int
static val mutable DEFAULT_TIMEOUT_MS: int

Field Value

Type: Online Int32
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.m_Bindings Field

GlueService m_Bindings Field NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Bindings m_Bindings
internal Bindings m_Bindings
Friend m_Bindings As Bindings
Friend m_Bindings As Bindings
internal:
Bindings^ m_Bindings
internal:
Bindings^ m_Bindings
val mutable internal m_Bindings: Bindings
val mutable internal m_Bindings: Bindings

Field Value

Type: Bindings
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.m_Providers Field

GlueService m_Providers Field NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Providers m_Providers
internal Providers m_Providers
Friend m_Providers As Providers
Friend m_Providers As Providers
internal:
Providers^ m_Providers
internal:
Providers^ m_Providers
val mutable internal m_Providers: Providers
val mutable internal m_Providers: Providers

Field Value

Type: Providers
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.m_Servers Field

GlueService m_Servers Field NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Servers m_Servers
internal Servers m_Servers
Friend m_Servers As Servers
Friend m_Servers As Servers
internal:
Servers^ m_Servers
internal:
Servers^ m_Servers
val mutable internal m_Servers: Servers
val mutable internal m_Servers: Servers

Field Value

Type: Servers
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.MINIMUM_SERVER_INSTANCE_LOCK_TIMEOUT_MS Field

GlueService MINIMUM_SERVER_INSTANCE_LOCK_TIMEOUT_MS Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MINIMUM_SERVER_INSTANCE_LOCK_TIMEOUT_MS
public const int MINIMUM_SERVER_INSTANCE_LOCK_TIMEOUT_MS
Public Const MINIMUM_SERVER_INSTANCE_LOCK_TIMEOUT_MS As Integer
Public Const MINIMUM_SERVER_INSTANCE_LOCK_TIMEOUT_MS As Integer
public:
literal int MINIMUM_SERVER_INSTANCE_LOCK_TIMEOUT_MS
public:
literal int MINIMUM_SERVER_INSTANCE_LOCK_TIMEOUT_MS
static val mutable MINIMUM_SERVER_INSTANCE_LOCK_TIMEOUT_MS: int
static val mutable MINIMUM_SERVER_INSTANCE_LOCK_TIMEOUT_MS: int

Field Value

Type: Online Int32
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService Methods

GlueService Methods NFX Class Library

The GlueService type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | ClientDeliverAsyncResponse |
Public method | ClientDispatchedRequest |
Public method | ClientDispatchingRequest |
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetNodeBinding(String) |
Public method | GetNodeBinding(Node) |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegisterBinding |
Public method | RegisterProvider |
Public method | RegisterServerEndpoint |
Public method | ServerDispatchRequest |
Public method | ServerHandleRequest |
Public method | ServerHandleRequestFailure |
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | UnregisterBinding |
Public method | UnregisterProvider |
Public method | UnregisterServerEndpoint |
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GlueService Class
NFX.Glue.Implementation Namespace


GlueService.ClientDeliverAsyncResponse Method

GlueService ClientDeliverAsyncResponse Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ClientDeliverAsyncResponse(
    ResponseMsg response
)
public void ClientDeliverAsyncResponse(
    ResponseMsg response
)
Public Sub ClientDeliverAsyncResponse (
    response As ResponseMsg
)
Public Sub ClientDeliverAsyncResponse (
    response As ResponseMsg
)
public:
virtual void ClientDeliverAsyncResponse(
    ResponseMsg^ response
) sealed
public:
virtual void ClientDeliverAsyncResponse(
    ResponseMsg^ response
) sealed
abstract ClientDeliverAsyncResponse :
        response : ResponseMsg -> unit
override ClientDeliverAsyncResponse :
        response : ResponseMsg -> unit
abstract ClientDeliverAsyncResponse :
        response : ResponseMsg -> unit
override ClientDeliverAsyncResponse :
        response : ResponseMsg -> unit

Parameters

response
Type: NFX.Glue.Protocol ResponseMsg

Implements

IGlueImplementation ClientDeliverAsyncResponse(ResponseMsg)
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.ClientDispatchedRequest Method

GlueService ClientDispatchedRequest Method NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ClientDispatchedRequest(
    ClientEndPoint client,
    RequestMsg request,
    CallSlot callSlot
)
public void ClientDispatchedRequest(
    ClientEndPoint client,
    RequestMsg request,
    CallSlot callSlot
)
Public Sub ClientDispatchedRequest (
    client As ClientEndPoint,
    request As RequestMsg,
    callSlot As CallSlot
)
Public Sub ClientDispatchedRequest (
    client As ClientEndPoint,
    request As RequestMsg,
    callSlot As CallSlot
)
public:
virtual void ClientDispatchedRequest(
    ClientEndPoint^ client,
    RequestMsg^ request,
    CallSlot^ callSlot
) sealed
public:
virtual void ClientDispatchedRequest(
    ClientEndPoint^ client,
    RequestMsg^ request,
    CallSlot^ callSlot
) sealed
abstract ClientDispatchedRequest :
        client : ClientEndPoint *
        request : RequestMsg *
        callSlot : CallSlot -> unit
override ClientDispatchedRequest :
        client : ClientEndPoint *
        request : RequestMsg *
        callSlot : CallSlot -> unit
abstract ClientDispatchedRequest :
        client : ClientEndPoint *
        request : RequestMsg *
        callSlot : CallSlot -> unit
override ClientDispatchedRequest :
        client : ClientEndPoint *
        request : RequestMsg *
        callSlot : CallSlot -> unit

Parameters

client
Type: NFX.Glue ClientEndPoint
request
Type: NFX.Glue.Protocol RequestMsg
callSlot
Type: NFX.Glue CallSlot

Implements

IGlueImplementation ClientDispatchedRequest(ClientEndPoint, RequestMsg, CallSlot)
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.ClientDispatchingRequest Method

GlueService ClientDispatchingRequest Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RequestMsg ClientDispatchingRequest(
    ClientEndPoint client,
    RequestMsg request
)
public RequestMsg ClientDispatchingRequest(
    ClientEndPoint client,
    RequestMsg request
)
Public Function ClientDispatchingRequest (
    client As ClientEndPoint,
    request As RequestMsg
) As RequestMsg
Public Function ClientDispatchingRequest (
    client As ClientEndPoint,
    request As RequestMsg
) As RequestMsg
public:
virtual RequestMsg^ ClientDispatchingRequest(
    ClientEndPoint^ client,
    RequestMsg^ request
) sealed
public:
virtual RequestMsg^ ClientDispatchingRequest(
    ClientEndPoint^ client,
    RequestMsg^ request
) sealed
abstract ClientDispatchingRequest :
        client : ClientEndPoint *
        request : RequestMsg -> RequestMsg
override ClientDispatchingRequest :
        client : ClientEndPoint *
        request : RequestMsg -> RequestMsg
abstract ClientDispatchingRequest :
        client : ClientEndPoint *
        request : RequestMsg -> RequestMsg
override ClientDispatchingRequest :
        client : ClientEndPoint *
        request : RequestMsg -> RequestMsg

Parameters

client
Type: NFX.Glue ClientEndPoint
request
Type: NFX.Glue.Protocol RequestMsg

Return Value

Type: RequestMsg

Implements

IGlueImplementation ClientDispatchingRequest(ClientEndPoint, RequestMsg)
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.DoConfigure Method

GlueService DoConfigure Method NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.DoSignalStop Method

GlueService DoSignalStop Method NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSignalStop()
protected override void DoSignalStop()
Protected Overrides Sub DoSignalStop
Protected Overrides Sub DoSignalStop
protected:
virtual void DoSignalStop() override
protected:
virtual void DoSignalStop() override
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.DoStart Method

GlueService DoStart Method NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.DoWaitForCompleteStop Method

GlueService DoWaitForCompleteStop Method NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.GetNodeBinding Method

GlueService GetNodeBinding Method NFX Class Library

Overload List
 | Name | Description
Public method | GetNodeBinding(String) |
Public method | GetNodeBinding(Node) |
Back to Top
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.GetNodeBinding Method (String)

GlueService GetNodeBinding Method (String) NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Binding GetNodeBinding(
    string node
)
public Binding GetNodeBinding(
    string node
)
Public Function GetNodeBinding (
    node As String
) As Binding
Public Function GetNodeBinding (
    node As String
) As Binding
public:
virtual Binding^ GetNodeBinding(
    String^ node
) sealed
public:
virtual Binding^ GetNodeBinding(
    String^ node
) sealed
abstract GetNodeBinding :
        node : string -> Binding
override GetNodeBinding :
        node : string -> Binding
abstract GetNodeBinding :
        node : string -> Binding
override GetNodeBinding :
        node : string -> Binding

Parameters

node
Type: Online System String

Return Value

Type: Binding

Implements

IGlue GetNodeBinding(String)
See Also
GlueService Class
GlueService Members
GetNodeBinding Overload
NFX.Glue.Implementation Namespace


GlueService.GetNodeBinding Method (Node)

GlueService GetNodeBinding Method (Node) NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Binding GetNodeBinding(
    Node node
)
public Binding GetNodeBinding(
    Node node
)
Public Function GetNodeBinding (
    node As Node
) As Binding
Public Function GetNodeBinding (
    node As Node
) As Binding
public:
virtual Binding^ GetNodeBinding(
    Node node
) sealed
public:
virtual Binding^ GetNodeBinding(
    Node node
) sealed
abstract GetNodeBinding :
        node : Node -> Binding
override GetNodeBinding :
        node : Node -> Binding
abstract GetNodeBinding :
        node : Node -> Binding
override GetNodeBinding :
        node : Node -> Binding

Parameters

node
Type: NFX.Glue Node

Return Value

Type: Binding

Implements

IGlue GetNodeBinding(Node)
See Also
GlueService Class
GlueService Members
GetNodeBinding Overload
NFX.Glue.Implementation Namespace


GlueService.RegisterBinding Method

GlueService RegisterBinding Method NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RegisterBinding(
    Binding b
)
public void RegisterBinding(
    Binding b
)
Public Sub RegisterBinding (
    b As Binding
)
Public Sub RegisterBinding (
    b As Binding
)
public:
virtual void RegisterBinding(
    Binding^ b
) sealed
public:
virtual void RegisterBinding(
    Binding^ b
) sealed
abstract RegisterBinding :
        b : Binding -> unit
override RegisterBinding :
        b : Binding -> unit
abstract RegisterBinding :
        b : Binding -> unit
override RegisterBinding :
        b : Binding -> unit

Parameters

b
Type: NFX.Glue Binding

Implements

IGlueImplementation RegisterBinding(Binding)
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.RegisterProvider Method

GlueService RegisterProvider Method NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RegisterProvider(
    Provider p
)
public void RegisterProvider(
    Provider p
)
Public Sub RegisterProvider (
    p As Provider
)
Public Sub RegisterProvider (
    p As Provider
)
public:
virtual void RegisterProvider(
    Provider^ p
) sealed
public:
virtual void RegisterProvider(
    Provider^ p
) sealed
abstract RegisterProvider :
        p : Provider -> unit
override RegisterProvider :
        p : Provider -> unit
abstract RegisterProvider :
        p : Provider -> unit
override RegisterProvider :
        p : Provider -> unit

Parameters

p
Type: NFX.Glue Provider

Implements

IGlueImplementation RegisterProvider(Provider)
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.RegisterServerEndpoint Method

GlueService RegisterServerEndpoint Method NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RegisterServerEndpoint(
    ServerEndPoint ep
)
public void RegisterServerEndpoint(
    ServerEndPoint ep
)
Public Sub RegisterServerEndpoint (
    ep As ServerEndPoint
)
Public Sub RegisterServerEndpoint (
    ep As ServerEndPoint
)
public:
virtual void RegisterServerEndpoint(
    ServerEndPoint^ ep
) sealed
public:
virtual void RegisterServerEndpoint(
    ServerEndPoint^ ep
) sealed
abstract RegisterServerEndpoint :
        ep : ServerEndPoint -> unit
override RegisterServerEndpoint :
        ep : ServerEndPoint -> unit
abstract RegisterServerEndpoint :
        ep : ServerEndPoint -> unit
override RegisterServerEndpoint :
        ep : ServerEndPoint -> unit

Parameters

ep
Type: NFX.Glue ServerEndPoint

Implements

IGlueImplementation RegisterServerEndpoint(ServerEndPoint)
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.ServerDispatchRequest Method

GlueService ServerDispatchRequest Method NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ServerDispatchRequest(
    RequestMsg request
)
public void ServerDispatchRequest(
    RequestMsg request
)
Public Sub ServerDispatchRequest (
    request As RequestMsg
)
Public Sub ServerDispatchRequest (
    request As RequestMsg
)
public:
virtual void ServerDispatchRequest(
    RequestMsg^ request
) sealed
public:
virtual void ServerDispatchRequest(
    RequestMsg^ request
) sealed
abstract ServerDispatchRequest :
        request : RequestMsg -> unit
override ServerDispatchRequest :
        request : RequestMsg -> unit
abstract ServerDispatchRequest :
        request : RequestMsg -> unit
override ServerDispatchRequest :
        request : RequestMsg -> unit

Parameters

request
Type: NFX.Glue.Protocol RequestMsg

Implements

IGlueImplementation ServerDispatchRequest(RequestMsg)
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.ServerHandleRequest Method

GlueService ServerHandleRequest Method NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResponseMsg ServerHandleRequest(
    RequestMsg request
)
public ResponseMsg ServerHandleRequest(
    RequestMsg request
)
Public Function ServerHandleRequest (
    request As RequestMsg
) As ResponseMsg
Public Function ServerHandleRequest (
    request As RequestMsg
) As ResponseMsg
public:
virtual ResponseMsg^ ServerHandleRequest(
    RequestMsg^ request
) sealed
public:
virtual ResponseMsg^ ServerHandleRequest(
    RequestMsg^ request
) sealed
abstract ServerHandleRequest :
        request : RequestMsg -> ResponseMsg
override ServerHandleRequest :
        request : RequestMsg -> ResponseMsg
abstract ServerHandleRequest :
        request : RequestMsg -> ResponseMsg
override ServerHandleRequest :
        request : RequestMsg -> ResponseMsg

Parameters

request
Type: NFX.Glue.Protocol RequestMsg

Return Value

Type: ResponseMsg

Implements

IGlueImplementation ServerHandleRequest(RequestMsg)
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.ServerHandleRequestFailure Method

GlueService ServerHandleRequestFailure Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResponseMsg ServerHandleRequestFailure(
    FID reqID,
    bool oneWay,
    Exception failure,
    Object bindingSpecCtx
)
public ResponseMsg ServerHandleRequestFailure(
    FID reqID,
    bool oneWay,
    Exception failure,
    Object bindingSpecCtx
)
Public Function ServerHandleRequestFailure (
    reqID As FID,
    oneWay As Boolean,
    failure As Exception,
    bindingSpecCtx As Object
) As ResponseMsg
Public Function ServerHandleRequestFailure (
    reqID As FID,
    oneWay As Boolean,
    failure As Exception,
    bindingSpecCtx As Object
) As ResponseMsg
public:
virtual ResponseMsg^ ServerHandleRequestFailure(
    FID reqID,
    bool oneWay,
    Exception^ failure,
    Object^ bindingSpecCtx
) sealed
public:
virtual ResponseMsg^ ServerHandleRequestFailure(
    FID reqID,
    bool oneWay,
    Exception^ failure,
    Object^ bindingSpecCtx
) sealed
abstract ServerHandleRequestFailure :
        reqID : FID *
        oneWay : bool *
        failure : Exception *
        bindingSpecCtx : Object -> ResponseMsg
override ServerHandleRequestFailure :
        reqID : FID *
        oneWay : bool *
        failure : Exception *
        bindingSpecCtx : Object -> ResponseMsg
abstract ServerHandleRequestFailure :
        reqID : FID *
        oneWay : bool *
        failure : Exception *
        bindingSpecCtx : Object -> ResponseMsg
override ServerHandleRequestFailure :
        reqID : FID *
        oneWay : bool *
        failure : Exception *
        bindingSpecCtx : Object -> ResponseMsg

Parameters

reqID
Type: NFX FID
oneWay
Type: Online System Boolean
failure
Type: Online System Exception
bindingSpecCtx
Type: Online System Object

Return Value

Type: ResponseMsg

Implements

IGlueImplementation ServerHandleRequestFailure(FID, Boolean, Exception, Object)
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.UnregisterBinding Method

GlueService UnregisterBinding Method NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void UnregisterBinding(
    Binding b
)
public void UnregisterBinding(
    Binding b
)
Public Sub UnregisterBinding (
    b As Binding
)
Public Sub UnregisterBinding (
    b As Binding
)
public:
virtual void UnregisterBinding(
    Binding^ b
) sealed
public:
virtual void UnregisterBinding(
    Binding^ b
) sealed
abstract UnregisterBinding :
        b : Binding -> unit
override UnregisterBinding :
        b : Binding -> unit
abstract UnregisterBinding :
        b : Binding -> unit
override UnregisterBinding :
        b : Binding -> unit

Parameters

b
Type: NFX.Glue Binding

Implements

IGlueImplementation UnregisterBinding(Binding)
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.UnregisterProvider Method

GlueService UnregisterProvider Method NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void UnregisterProvider(
    Provider p
)
public void UnregisterProvider(
    Provider p
)
Public Sub UnregisterProvider (
    p As Provider
)
Public Sub UnregisterProvider (
    p As Provider
)
public:
virtual void UnregisterProvider(
    Provider^ p
) sealed
public:
virtual void UnregisterProvider(
    Provider^ p
) sealed
abstract UnregisterProvider :
        p : Provider -> unit
override UnregisterProvider :
        p : Provider -> unit
abstract UnregisterProvider :
        p : Provider -> unit
override UnregisterProvider :
        p : Provider -> unit

Parameters

p
Type: NFX.Glue Provider

Implements

IGlueImplementation UnregisterProvider(Provider)
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.UnregisterServerEndpoint Method

GlueService UnregisterServerEndpoint Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void UnregisterServerEndpoint(
    ServerEndPoint ep
)
public void UnregisterServerEndpoint(
    ServerEndPoint ep
)
Public Sub UnregisterServerEndpoint (
    ep As ServerEndPoint
)
Public Sub UnregisterServerEndpoint (
    ep As ServerEndPoint
)
public:
virtual void UnregisterServerEndpoint(
    ServerEndPoint^ ep
) sealed
public:
virtual void UnregisterServerEndpoint(
    ServerEndPoint^ ep
) sealed
abstract UnregisterServerEndpoint :
        ep : ServerEndPoint -> unit
override UnregisterServerEndpoint :
        ep : ServerEndPoint -> unit
abstract UnregisterServerEndpoint :
        ep : ServerEndPoint -> unit
override UnregisterServerEndpoint :
        ep : ServerEndPoint -> unit

Parameters

ep
Type: NFX.Glue ServerEndPoint

Implements

IGlueImplementation UnregisterServerEndpoint(ServerEndPoint)
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService Properties

GlueService Properties NFX Class Library

The GlueService type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | BindingConfigurations |
Public property | Bindings |
Public property | BindingsConfigurationSection |
Public property | ClientLogLevel |
Public property | ClientMsgInspectors | Returns client message inspectors for this instance
Public property | ComponentCommonName | (Overrides ApplicationComponent ComponentCommonName.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DefaultDispatchTimeoutMs |
Public property | DefaultTimeoutMs |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | GlueConfiguration |
Public property | InstrumentationEnabled | Implements IInstrumentable (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | ProviderConfigurations |
Public property | Providers |
Public property | ProvidersConfigurationSection |
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | ServerConfigurations |
Public property | ServerInstanceLockTimeoutMs |
Public property | ServerLogLevel |
Public property | ServerMsgInspectors | Returns server message inspectors for this instance
Public property | Servers |
Public property | ServersConfigurationSection |
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
GlueService Class
NFX.Glue.Implementation Namespace


GlueService.BindingConfigurations Property

GlueService BindingConfigurations Property NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<IConfigSectionNode> BindingConfigurations { get; }
public IEnumerable<IConfigSectionNode> BindingConfigurations { get; }
Public ReadOnly Property BindingConfigurations As IEnumerable(Of IConfigSectionNode)
    Get
Public ReadOnly Property BindingConfigurations As IEnumerable(Of IConfigSectionNode)
    Get
public:
virtual property IEnumerable<IConfigSectionNode^>^ BindingConfigurations {
    IEnumerable<IConfigSectionNode^>^ get () sealed;
}
public:
virtual property IEnumerable<IConfigSectionNode^>^ BindingConfigurations {
    IEnumerable<IConfigSectionNode^>^ get () sealed;
}
abstract BindingConfigurations : IEnumerable<IConfigSectionNode> with get
override BindingConfigurations : IEnumerable<IConfigSectionNode> with get
abstract BindingConfigurations : IEnumerable<IConfigSectionNode> with get
override BindingConfigurations : IEnumerable<IConfigSectionNode> with get

Property Value

Type: Online IEnumerable IConfigSectionNode

Implements

IGlueImplementation BindingConfigurations
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.Bindings Property

GlueService Bindings Property NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<Binding> Bindings { get; }
public IRegistry<Binding> Bindings { get; }
Public ReadOnly Property Bindings As IRegistry(Of Binding)
    Get
Public ReadOnly Property Bindings As IRegistry(Of Binding)
    Get
public:
virtual property IRegistry<Binding^>^ Bindings {
    IRegistry<Binding^>^ get () sealed;
}
public:
virtual property IRegistry<Binding^>^ Bindings {
    IRegistry<Binding^>^ get () sealed;
}
abstract Bindings : IRegistry<Binding> with get
override Bindings : IRegistry<Binding> with get
abstract Bindings : IRegistry<Binding> with get
override Bindings : IRegistry<Binding> with get

Property Value

Type: IRegistry Binding

Implements

IGlue Bindings
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.BindingsConfigurationSection Property

GlueService BindingsConfigurationSection Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IConfigSectionNode BindingsConfigurationSection { get; }
public IConfigSectionNode BindingsConfigurationSection { get; }
Public ReadOnly Property BindingsConfigurationSection As IConfigSectionNode
    Get
Public ReadOnly Property BindingsConfigurationSection As IConfigSectionNode
    Get
public:
virtual property IConfigSectionNode^ BindingsConfigurationSection {
    IConfigSectionNode^ get () sealed;
}
public:
virtual property IConfigSectionNode^ BindingsConfigurationSection {
    IConfigSectionNode^ get () sealed;
}
abstract BindingsConfigurationSection : IConfigSectionNode with get
override BindingsConfigurationSection : IConfigSectionNode with get
abstract BindingsConfigurationSection : IConfigSectionNode with get
override BindingsConfigurationSection : IConfigSectionNode with get

Property Value

Type: IConfigSectionNode

Implements

IGlueImplementation BindingsConfigurationSection
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.ClientLogLevel Property

GlueService ClientLogLevel Property NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
public MessageType ClientLogLevel { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
public MessageType ClientLogLevel { get; set; }
<ExternalParameterAttribute(New String() { ... })>
Public Property ClientLogLevel As MessageType
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
Public Property ClientLogLevel As MessageType
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property MessageType ClientLogLevel {
    MessageType get () sealed;
    void set (MessageType value) sealed;
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property MessageType ClientLogLevel {
    MessageType get () sealed;
    void set (MessageType value) sealed;
}
[<ExternalParameterAttribute(new string[] { ... })>]
abstract ClientLogLevel : MessageType with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
override ClientLogLevel : MessageType with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
abstract ClientLogLevel : MessageType with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
override ClientLogLevel : MessageType with get, set

Property Value

Type: MessageType

Implements

IGlue ClientLogLevel
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.ClientMsgInspectors Property

GlueService ClientMsgInspectors Property NFX Class Library

Returns client message inspectors for this instance

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderedRegistry<IClientMsgInspector> ClientMsgInspectors { get; }
public OrderedRegistry<IClientMsgInspector> ClientMsgInspectors { get; }
Public ReadOnly Property ClientMsgInspectors As OrderedRegistry(Of IClientMsgInspector)
    Get
Public ReadOnly Property ClientMsgInspectors As OrderedRegistry(Of IClientMsgInspector)
    Get
public:
virtual property OrderedRegistry<IClientMsgInspector^>^ ClientMsgInspectors {
    OrderedRegistry<IClientMsgInspector^>^ get () sealed;
}
public:
virtual property OrderedRegistry<IClientMsgInspector^>^ ClientMsgInspectors {
    OrderedRegistry<IClientMsgInspector^>^ get () sealed;
}
abstract ClientMsgInspectors : OrderedRegistry<IClientMsgInspector> with get
override ClientMsgInspectors : OrderedRegistry<IClientMsgInspector> with get
abstract ClientMsgInspectors : OrderedRegistry<IClientMsgInspector> with get
override ClientMsgInspectors : OrderedRegistry<IClientMsgInspector> with get

Property Value

Type: OrderedRegistry IClientMsgInspector

Implements

IGlue ClientMsgInspectors
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.ComponentCommonName Property

GlueService ComponentCommonName Property NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ComponentCommonName { get; }
public override string ComponentCommonName { get; }
Public Overrides ReadOnly Property ComponentCommonName As String
    Get
Public Overrides ReadOnly Property ComponentCommonName As String
    Get
public:
virtual property String^ ComponentCommonName {
    String^ get () override;
}
public:
virtual property String^ ComponentCommonName {
    String^ get () override;
}
abstract ComponentCommonName : string with get
override ComponentCommonName : string with get
abstract ComponentCommonName : string with get
override ComponentCommonName : string with get

Property Value

Type: Online String

Implements

IApplicationComponent ComponentCommonName
IApplicationComponent ComponentCommonName
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.DefaultDispatchTimeoutMs Property

GlueService DefaultDispatchTimeoutMs Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
public int DefaultDispatchTimeoutMs { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
public int DefaultDispatchTimeoutMs { get; set; }
<ExternalParameterAttribute(New String() { ... })>
Public Property DefaultDispatchTimeoutMs As Integer
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
Public Property DefaultDispatchTimeoutMs As Integer
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property int DefaultDispatchTimeoutMs {
    int get () sealed;
    void set (int value) sealed;
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property int DefaultDispatchTimeoutMs {
    int get () sealed;
    void set (int value) sealed;
}
[<ExternalParameterAttribute(new string[] { ... })>]
abstract DefaultDispatchTimeoutMs : int with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
override DefaultDispatchTimeoutMs : int with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
abstract DefaultDispatchTimeoutMs : int with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
override DefaultDispatchTimeoutMs : int with get, set

Property Value

Type: Online Int32

Implements

IGlue DefaultDispatchTimeoutMs
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.DefaultTimeoutMs Property

GlueService DefaultTimeoutMs Property NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
public int DefaultTimeoutMs { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
public int DefaultTimeoutMs { get; set; }
<ExternalParameterAttribute(New String() { ... })>
Public Property DefaultTimeoutMs As Integer
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
Public Property DefaultTimeoutMs As Integer
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property int DefaultTimeoutMs {
    int get () sealed;
    void set (int value) sealed;
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property int DefaultTimeoutMs {
    int get () sealed;
    void set (int value) sealed;
}
[<ExternalParameterAttribute(new string[] { ... })>]
abstract DefaultTimeoutMs : int with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
override DefaultTimeoutMs : int with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
abstract DefaultTimeoutMs : int with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
override DefaultTimeoutMs : int with get, set

Property Value

Type: Online Int32

Implements

IGlue DefaultTimeoutMs
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.GlueConfiguration Property

GlueService GlueConfiguration Property NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IConfigSectionNode GlueConfiguration { get; }
public IConfigSectionNode GlueConfiguration { get; }
Public ReadOnly Property GlueConfiguration As IConfigSectionNode
    Get
Public ReadOnly Property GlueConfiguration As IConfigSectionNode
    Get
public:
virtual property IConfigSectionNode^ GlueConfiguration {
    IConfigSectionNode^ get () sealed;
}
public:
virtual property IConfigSectionNode^ GlueConfiguration {
    IConfigSectionNode^ get () sealed;
}
abstract GlueConfiguration : IConfigSectionNode with get
override GlueConfiguration : IConfigSectionNode with get
abstract GlueConfiguration : IConfigSectionNode with get
override GlueConfiguration : IConfigSectionNode with get

Property Value

Type: IConfigSectionNode

Implements

IGlueImplementation GlueConfiguration
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.InstrumentationEnabled Property

GlueService InstrumentationEnabled Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Implements IInstrumentable

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(new string[] { ... })]
public override bool InstrumentationEnabled { get; set; }
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(new string[] { ... })]
public override bool InstrumentationEnabled { get; set; }
<ConfigAttribute(Default := false)>
<ExternalParameterAttribute(New String() { ... })>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
<ConfigAttribute(Default := false)>
<ExternalParameterAttribute(New String() { ... })>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
public:
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
public:
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
abstract InstrumentationEnabled : bool with get, set
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
override InstrumentationEnabled : bool with get, set
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
abstract InstrumentationEnabled : bool with get, set
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
override InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentable InstrumentationEnabled
IInstrumentable InstrumentationEnabled
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.ProviderConfigurations Property

GlueService ProviderConfigurations Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<IConfigSectionNode> ProviderConfigurations { get; }
public IEnumerable<IConfigSectionNode> ProviderConfigurations { get; }
Public ReadOnly Property ProviderConfigurations As IEnumerable(Of IConfigSectionNode)
    Get
Public ReadOnly Property ProviderConfigurations As IEnumerable(Of IConfigSectionNode)
    Get
public:
virtual property IEnumerable<IConfigSectionNode^>^ ProviderConfigurations {
    IEnumerable<IConfigSectionNode^>^ get () sealed;
}
public:
virtual property IEnumerable<IConfigSectionNode^>^ ProviderConfigurations {
    IEnumerable<IConfigSectionNode^>^ get () sealed;
}
abstract ProviderConfigurations : IEnumerable<IConfigSectionNode> with get
override ProviderConfigurations : IEnumerable<IConfigSectionNode> with get
abstract ProviderConfigurations : IEnumerable<IConfigSectionNode> with get
override ProviderConfigurations : IEnumerable<IConfigSectionNode> with get

Property Value

Type: Online IEnumerable IConfigSectionNode

Implements

IGlueImplementation ProviderConfigurations
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.Providers Property

GlueService Providers Property NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<Provider> Providers { get; }
public IRegistry<Provider> Providers { get; }
Public ReadOnly Property Providers As IRegistry(Of Provider)
    Get
Public ReadOnly Property Providers As IRegistry(Of Provider)
    Get
public:
virtual property IRegistry<Provider^>^ Providers {
    IRegistry<Provider^>^ get () sealed;
}
public:
virtual property IRegistry<Provider^>^ Providers {
    IRegistry<Provider^>^ get () sealed;
}
abstract Providers : IRegistry<Provider> with get
override Providers : IRegistry<Provider> with get
abstract Providers : IRegistry<Provider> with get
override Providers : IRegistry<Provider> with get

Property Value

Type: IRegistry Provider

Implements

IGlue Providers
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.ProvidersConfigurationSection Property

GlueService ProvidersConfigurationSection Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IConfigSectionNode ProvidersConfigurationSection { get; }
public IConfigSectionNode ProvidersConfigurationSection { get; }
Public ReadOnly Property ProvidersConfigurationSection As IConfigSectionNode
    Get
Public ReadOnly Property ProvidersConfigurationSection As IConfigSectionNode
    Get
public:
virtual property IConfigSectionNode^ ProvidersConfigurationSection {
    IConfigSectionNode^ get () sealed;
}
public:
virtual property IConfigSectionNode^ ProvidersConfigurationSection {
    IConfigSectionNode^ get () sealed;
}
abstract ProvidersConfigurationSection : IConfigSectionNode with get
override ProvidersConfigurationSection : IConfigSectionNode with get
abstract ProvidersConfigurationSection : IConfigSectionNode with get
override ProvidersConfigurationSection : IConfigSectionNode with get

Property Value

Type: IConfigSectionNode

Implements

IGlueImplementation ProvidersConfigurationSection
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.ServerConfigurations Property

GlueService ServerConfigurations Property NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<IConfigSectionNode> ServerConfigurations { get; }
public IEnumerable<IConfigSectionNode> ServerConfigurations { get; }
Public ReadOnly Property ServerConfigurations As IEnumerable(Of IConfigSectionNode)
    Get
Public ReadOnly Property ServerConfigurations As IEnumerable(Of IConfigSectionNode)
    Get
public:
virtual property IEnumerable<IConfigSectionNode^>^ ServerConfigurations {
    IEnumerable<IConfigSectionNode^>^ get () sealed;
}
public:
virtual property IEnumerable<IConfigSectionNode^>^ ServerConfigurations {
    IEnumerable<IConfigSectionNode^>^ get () sealed;
}
abstract ServerConfigurations : IEnumerable<IConfigSectionNode> with get
override ServerConfigurations : IEnumerable<IConfigSectionNode> with get
abstract ServerConfigurations : IEnumerable<IConfigSectionNode> with get
override ServerConfigurations : IEnumerable<IConfigSectionNode> with get

Property Value

Type: Online IEnumerable IConfigSectionNode

Implements

IGlueImplementation ServerConfigurations
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.ServerInstanceLockTimeoutMs Property

GlueService ServerInstanceLockTimeoutMs Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
public int ServerInstanceLockTimeoutMs { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
public int ServerInstanceLockTimeoutMs { get; set; }
<ExternalParameterAttribute(New String() { ... })>
Public Property ServerInstanceLockTimeoutMs As Integer
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
Public Property ServerInstanceLockTimeoutMs As Integer
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property int ServerInstanceLockTimeoutMs {
    int get () sealed;
    void set (int value) sealed;
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property int ServerInstanceLockTimeoutMs {
    int get () sealed;
    void set (int value) sealed;
}
[<ExternalParameterAttribute(new string[] { ... })>]
abstract ServerInstanceLockTimeoutMs : int with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
override ServerInstanceLockTimeoutMs : int with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
abstract ServerInstanceLockTimeoutMs : int with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
override ServerInstanceLockTimeoutMs : int with get, set

Property Value

Type: Online Int32

Implements

IGlue ServerInstanceLockTimeoutMs
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.ServerLogLevel Property

GlueService ServerLogLevel Property NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
public MessageType ServerLogLevel { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
public MessageType ServerLogLevel { get; set; }
<ExternalParameterAttribute(New String() { ... })>
Public Property ServerLogLevel As MessageType
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
Public Property ServerLogLevel As MessageType
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property MessageType ServerLogLevel {
    MessageType get () sealed;
    void set (MessageType value) sealed;
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property MessageType ServerLogLevel {
    MessageType get () sealed;
    void set (MessageType value) sealed;
}
[<ExternalParameterAttribute(new string[] { ... })>]
abstract ServerLogLevel : MessageType with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
override ServerLogLevel : MessageType with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
abstract ServerLogLevel : MessageType with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
override ServerLogLevel : MessageType with get, set

Property Value

Type: MessageType

Implements

IGlue ServerLogLevel
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.ServerMsgInspectors Property

GlueService ServerMsgInspectors Property NFX Class Library

Returns server message inspectors for this instance

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderedRegistry<IServerMsgInspector> ServerMsgInspectors { get; }
public OrderedRegistry<IServerMsgInspector> ServerMsgInspectors { get; }
Public ReadOnly Property ServerMsgInspectors As OrderedRegistry(Of IServerMsgInspector)
    Get
Public ReadOnly Property ServerMsgInspectors As OrderedRegistry(Of IServerMsgInspector)
    Get
public:
virtual property OrderedRegistry<IServerMsgInspector^>^ ServerMsgInspectors {
    OrderedRegistry<IServerMsgInspector^>^ get () sealed;
}
public:
virtual property OrderedRegistry<IServerMsgInspector^>^ ServerMsgInspectors {
    OrderedRegistry<IServerMsgInspector^>^ get () sealed;
}
abstract ServerMsgInspectors : OrderedRegistry<IServerMsgInspector> with get
override ServerMsgInspectors : OrderedRegistry<IServerMsgInspector> with get
abstract ServerMsgInspectors : OrderedRegistry<IServerMsgInspector> with get
override ServerMsgInspectors : OrderedRegistry<IServerMsgInspector> with get

Property Value

Type: OrderedRegistry IServerMsgInspector

Implements

IGlue ServerMsgInspectors
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.Servers Property

GlueService Servers Property NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<ServerEndPoint> Servers { get; }
public IRegistry<ServerEndPoint> Servers { get; }
Public ReadOnly Property Servers As IRegistry(Of ServerEndPoint)
    Get
Public ReadOnly Property Servers As IRegistry(Of ServerEndPoint)
    Get
public:
virtual property IRegistry<ServerEndPoint^>^ Servers {
    IRegistry<ServerEndPoint^>^ get () sealed;
}
public:
virtual property IRegistry<ServerEndPoint^>^ Servers {
    IRegistry<ServerEndPoint^>^ get () sealed;
}
abstract Servers : IRegistry<ServerEndPoint> with get
override Servers : IRegistry<ServerEndPoint> with get
abstract Servers : IRegistry<ServerEndPoint> with get
override Servers : IRegistry<ServerEndPoint> with get

Property Value

Type: IRegistry ServerEndPoint

Implements

IGlue Servers
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


GlueService.ServersConfigurationSection Property

GlueService ServersConfigurationSection Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IConfigSectionNode ServersConfigurationSection { get; }
public IConfigSectionNode ServersConfigurationSection { get; }
Public ReadOnly Property ServersConfigurationSection As IConfigSectionNode
    Get
Public ReadOnly Property ServersConfigurationSection As IConfigSectionNode
    Get
public:
virtual property IConfigSectionNode^ ServersConfigurationSection {
    IConfigSectionNode^ get () sealed;
}
public:
virtual property IConfigSectionNode^ ServersConfigurationSection {
    IConfigSectionNode^ get () sealed;
}
abstract ServersConfigurationSection : IConfigSectionNode with get
override ServersConfigurationSection : IConfigSectionNode with get
abstract ServersConfigurationSection : IConfigSectionNode with get
override ServersConfigurationSection : IConfigSectionNode with get

Property Value

Type: IConfigSectionNode

Implements

IGlueImplementation ServersConfigurationSection
See Also
GlueService Class
GlueService Members
NFX.Glue.Implementation Namespace


ServerHandler Class

ServerHandler Class NFX Class Library

Executes server work - handles requests synchronously or asynchronously.
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service IGlueImplementation
NFX.ServiceModel ServiceWithInstrumentationBase IGlueImplementation
NFX.Glue GlueComponentService
NFX.Glue.Implementation ServerHandler

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ServerHandler : GlueComponentService
public class ServerHandler : GlueComponentService
Public Class ServerHandler
    Inherits GlueComponentService
Public Class ServerHandler
    Inherits GlueComponentService
public ref class ServerHandler : public GlueComponentService
public ref class ServerHandler : public GlueComponentService
type ServerHandler =
    class
        inherit GlueComponentService
    end
type ServerHandler =
    class
        inherit GlueComponentService
    end
See Also
ServerHandler Members
NFX.Glue.Implementation Namespace


ServerHandler Members

ServerHandler Members NFX Class Library

The ServerHandler type exposes the following members.
Constructors
 | Name | Description
Public method | ServerHandler | Initializes a new instance of the ServerHandler class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HandleRequestAsynchronously | Handles request in the context of ServerHandler thread, replying back to result queue
Public method | HandleRequestFailure | Handles request synchronously in the context of the calling thread. Returns NULL for one-way calls
Public method | HandleRequestSynchronously | Handles request synchronously in the context of the calling thread. Returns NULL for one-way calls
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | WriteLog | (Inherited from GlueComponentService.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
DEFAULT_INSTANCE_TIMEOUT_MS |
GLUE_CTOR_SIGNATURE | Specifies special signature for glue-specific constructors. If a server implementer class implements a public ctor with this signature then it will be called instead of default .ctor. This is useful when server class needs to distinguish Glue allocations from de-serializations and others
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | Glue | (Inherited from GlueComponentService.)
Public property | InstrumentationEnabled | Implements IInstrumentable (Inherited from GlueComponentService.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
ServerHandler Class
NFX.Glue.Implementation Namespace


ServerHandler Constructor

ServerHandler Constructor NFX Class Library

Initializes a new instance of the ServerHandler class

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerHandler(
    IGlueImplementation glue
)
public ServerHandler(
    IGlueImplementation glue
)
Public Sub New (
    glue As IGlueImplementation
)
Public Sub New (
    glue As IGlueImplementation
)
public:
ServerHandler(
    IGlueImplementation^ glue
)
public:
ServerHandler(
    IGlueImplementation^ glue
)
new :
        glue : IGlueImplementation -> ServerHandler
new :
        glue : IGlueImplementation -> ServerHandler

Parameters

glue
Type: NFX.Glue IGlueImplementation
See Also
ServerHandler Class
ServerHandler Members
NFX.Glue.Implementation Namespace


ServerHandler Fields

ServerHandler Fields NFX Class Library

The ServerHandler type exposes the following members.
Fields
Name | Description
DEFAULT_INSTANCE_TIMEOUT_MS |
GLUE_CTOR_SIGNATURE | Specifies special signature for glue-specific constructors. If a server implementer class implements a public ctor with this signature then it will be called instead of default .ctor. This is useful when server class needs to distinguish Glue allocations from de-serializations and others
Back to Top
See Also
ServerHandler Class
NFX.Glue.Implementation Namespace


ServerHandler.DEFAULT_INSTANCE_TIMEOUT_MS Field

ServerHandler DEFAULT_INSTANCE_TIMEOUT_MS Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_INSTANCE_TIMEOUT_MS
public const int DEFAULT_INSTANCE_TIMEOUT_MS
Public Const DEFAULT_INSTANCE_TIMEOUT_MS As Integer
Public Const DEFAULT_INSTANCE_TIMEOUT_MS As Integer
public:
literal int DEFAULT_INSTANCE_TIMEOUT_MS
public:
literal int DEFAULT_INSTANCE_TIMEOUT_MS
static val mutable DEFAULT_INSTANCE_TIMEOUT_MS: int
static val mutable DEFAULT_INSTANCE_TIMEOUT_MS: int

Field Value

Type: Online Int32
See Also
ServerHandler Class
ServerHandler Members
NFX.Glue.Implementation Namespace


ServerHandler.GLUE_CTOR_SIGNATURE Field

ServerHandler GLUE_CTOR_SIGNATURE Field NFX Class Library

Specifies special signature for glue-specific constructors. If a server implementer class implements a public ctor with this signature then it will be called instead of default .ctor. This is useful when server class needs to distinguish Glue allocations from de-serializations and others

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Type[] GLUE_CTOR_SIGNATURE
public static readonly Type[] GLUE_CTOR_SIGNATURE
Public Shared ReadOnly GLUE_CTOR_SIGNATURE As Type()
Public Shared ReadOnly GLUE_CTOR_SIGNATURE As Type()
public:
static initonly array<Type^>^ GLUE_CTOR_SIGNATURE
public:
static initonly array<Type^>^ GLUE_CTOR_SIGNATURE
static val GLUE_CTOR_SIGNATURE: Type[]
static val GLUE_CTOR_SIGNATURE: Type[]

Field Value

Type: Online Type
See Also
ServerHandler Class
ServerHandler Members
NFX.Glue.Implementation Namespace


ServerHandler Methods

ServerHandler Methods NFX Class Library

The ServerHandler type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HandleRequestAsynchronously | Handles request in the context of ServerHandler thread, replying back to result queue
Public method | HandleRequestFailure | Handles request synchronously in the context of the calling thread. Returns NULL for one-way calls
Public method | HandleRequestSynchronously | Handles request synchronously in the context of the calling thread. Returns NULL for one-way calls
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | WriteLog | (Inherited from GlueComponentService.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerHandler Class
NFX.Glue.Implementation Namespace


ServerHandler.DoStart Method

ServerHandler DoStart Method NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
ServerHandler Class
ServerHandler Members
NFX.Glue.Implementation Namespace


ServerHandler.DoWaitForCompleteStop Method

ServerHandler DoWaitForCompleteStop Method NFX Class Library

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
ServerHandler Class
ServerHandler Members
NFX.Glue.Implementation Namespace


ServerHandler.HandleRequestAsynchronously Method

ServerHandler HandleRequestAsynchronously Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Handles request in the context of ServerHandler thread, replying back to result queue

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void HandleRequestAsynchronously(
    RequestMsg request
)
public void HandleRequestAsynchronously(
    RequestMsg request
)
Public Sub HandleRequestAsynchronously (
    request As RequestMsg
)
Public Sub HandleRequestAsynchronously (
    request As RequestMsg
)
public:
void HandleRequestAsynchronously(
    RequestMsg^ request
)
public:
void HandleRequestAsynchronously(
    RequestMsg^ request
)
member HandleRequestAsynchronously :
        request : RequestMsg -> unit
member HandleRequestAsynchronously :
        request : RequestMsg -> unit

Parameters

request
Type: NFX.Glue.Protocol RequestMsg
See Also
ServerHandler Class
ServerHandler Members
NFX.Glue.Implementation Namespace


ServerHandler.HandleRequestFailure Method

ServerHandler HandleRequestFailure Method NFX Class Library

Handles request synchronously in the context of the calling thread. Returns NULL for one-way calls

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResponseMsg HandleRequestFailure(
    FID reqID,
    bool oneWay,
    Exception failure,
    Object bindingSpecCtx
)
public ResponseMsg HandleRequestFailure(
    FID reqID,
    bool oneWay,
    Exception failure,
    Object bindingSpecCtx
)
Public Function HandleRequestFailure (
    reqID As FID,
    oneWay As Boolean,
    failure As Exception,
    bindingSpecCtx As Object
) As ResponseMsg
Public Function HandleRequestFailure (
    reqID As FID,
    oneWay As Boolean,
    failure As Exception,
    bindingSpecCtx As Object
) As ResponseMsg
public:
ResponseMsg^ HandleRequestFailure(
    FID reqID,
    bool oneWay,
    Exception^ failure,
    Object^ bindingSpecCtx
)
public:
ResponseMsg^ HandleRequestFailure(
    FID reqID,
    bool oneWay,
    Exception^ failure,
    Object^ bindingSpecCtx
)
member HandleRequestFailure :
        reqID : FID *
        oneWay : bool *
        failure : Exception *
        bindingSpecCtx : Object -> ResponseMsg
member HandleRequestFailure :
        reqID : FID *
        oneWay : bool *
        failure : Exception *
        bindingSpecCtx : Object -> ResponseMsg

Parameters

reqID
Type: NFX FID
oneWay
Type: Online System Boolean
failure
Type: Online System Exception
bindingSpecCtx
Type: Online System Object

Return Value

Type: ResponseMsg
See Also
ServerHandler Class
ServerHandler Members
NFX.Glue.Implementation Namespace


ServerHandler.HandleRequestSynchronously Method

ServerHandler HandleRequestSynchronously Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Handles request synchronously in the context of the calling thread. Returns NULL for one-way calls

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResponseMsg HandleRequestSynchronously(
    RequestMsg request
)
public ResponseMsg HandleRequestSynchronously(
    RequestMsg request
)
Public Function HandleRequestSynchronously (
    request As RequestMsg
) As ResponseMsg
Public Function HandleRequestSynchronously (
    request As RequestMsg
) As ResponseMsg
public:
ResponseMsg^ HandleRequestSynchronously(
    RequestMsg^ request
)
public:
ResponseMsg^ HandleRequestSynchronously(
    RequestMsg^ request
)
member HandleRequestSynchronously :
        request : RequestMsg -> ResponseMsg
member HandleRequestSynchronously :
        request : RequestMsg -> ResponseMsg

Parameters

request
Type: NFX.Glue.Protocol RequestMsg

Return Value

Type: ResponseMsg
See Also
ServerHandler Class
ServerHandler Members
NFX.Glue.Implementation Namespace


ServerHandler Properties

ServerHandler Properties NFX Class Library

The ServerHandler type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | Glue | (Inherited from GlueComponentService.)
Public property | InstrumentationEnabled | Implements IInstrumentable (Inherited from GlueComponentService.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
ServerHandler Class
NFX.Glue.Implementation Namespace


ServerHandler.serverImplementer Class

ServerHandler serverImplementer Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Glue.Implementation ServerHandler serverImplementer

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class serverImplementer
internal class serverImplementer
Friend Class serverImplementer
Friend Class serverImplementer
internal ref class serverImplementer
internal ref class serverImplementer
type serverImplementer =  class end
type serverImplementer =  class end
See Also
ServerHandler serverImplementer Members
NFX.Glue.Implementation Namespace


ServerHandler.serverImplementer Members

ServerHandler serverImplementer Members NFX Class Library

The ServerHandler serverImplementer type exposes the following members.
Constructors
 | Name | Description
Public method | ServerHandler serverImplementer | Initializes a new instance of the ServerHandler serverImplementer class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SpecToMethodInfos |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | AuthenticationSupport |
Public field | Contract |
Public field | Handler |
Public field | Implementation |
Public field | InstanceMode |
Public field | InstanceTimeoutMs |
Public field | methodMap |
Public field | ServerEndPoint |
Public field | SupportsGlueCtor |
Public field | ThreadSafe |
Back to Top
See Also
ServerHandler serverImplementer Class
NFX.Glue.Implementation Namespace


ServerHandler.serverImplementer Constructor

ServerHandler serverImplementer Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerHandler serverImplementer class

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public serverImplementer(
    ServerHandler handler,
    ServerEndPoint sep,
    Type contract
)
public serverImplementer(
    ServerHandler handler,
    ServerEndPoint sep,
    Type contract
)
Public Sub New (
    handler As ServerHandler,
    sep As ServerEndPoint,
    contract As Type
)
Public Sub New (
    handler As ServerHandler,
    sep As ServerEndPoint,
    contract As Type
)
public:
serverImplementer(
    ServerHandler^ handler,
    ServerEndPoint^ sep,
    Type^ contract
)
public:
serverImplementer(
    ServerHandler^ handler,
    ServerEndPoint^ sep,
    Type^ contract
)
new :
        handler : ServerHandler *
        sep : ServerEndPoint *
        contract : Type -> serverImplementer
new :
        handler : ServerHandler *
        sep : ServerEndPoint *
        contract : Type -> serverImplementer

Parameters

handler
Type: NFX.Glue.Implementation ServerHandler
sep
Type: NFX.Glue ServerEndPoint
contract
Type: Online System Type
See Also
ServerHandler serverImplementer Class
ServerHandler serverImplementer Members
NFX.Glue.Implementation Namespace


ServerHandler.serverImplementer Fields

ServerHandler serverImplementer Fields NFX Class Library

The ServerHandler serverImplementer type exposes the following members.
Fields
 | Name | Description
Public field | AuthenticationSupport |
Public field | Contract |
Public field | Handler |
Public field | Implementation |
Public field | InstanceMode |
Public field | InstanceTimeoutMs |
Public field | methodMap |
Public field | ServerEndPoint |
Public field | SupportsGlueCtor |
Public field | ThreadSafe |
Back to Top
See Also
ServerHandler serverImplementer Class
NFX.Glue.Implementation Namespace


ServerHandler.serverImplementer.AuthenticationSupport Field

ServerHandler serverImplementer AuthenticationSupport Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool AuthenticationSupport
public bool AuthenticationSupport
Public AuthenticationSupport As Boolean
Public AuthenticationSupport As Boolean
public:
bool AuthenticationSupport
public:
bool AuthenticationSupport
val mutable AuthenticationSupport: bool
val mutable AuthenticationSupport: bool

Field Value

Type: Online Boolean
See Also
ServerHandler serverImplementer Class
ServerHandler serverImplementer Members
NFX.Glue.Implementation Namespace


ServerHandler.serverImplementer.Contract Field

ServerHandler serverImplementer Contract Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Type Contract
public Type Contract
Public Contract As Type
Public Contract As Type
public:
Type^ Contract
public:
Type^ Contract
val mutable Contract: Type
val mutable Contract: Type

Field Value

Type: Online Type
See Also
ServerHandler serverImplementer Class
ServerHandler serverImplementer Members
NFX.Glue.Implementation Namespace


ServerHandler.serverImplementer.Handler Field

ServerHandler serverImplementer Handler Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerHandler Handler
public ServerHandler Handler
Public Handler As ServerHandler
Public Handler As ServerHandler
public:
ServerHandler^ Handler
public:
ServerHandler^ Handler
val mutable Handler: ServerHandler
val mutable Handler: ServerHandler

Field Value

Type: ServerHandler
See Also
ServerHandler serverImplementer Class
ServerHandler serverImplementer Members
NFX.Glue.Implementation Namespace


ServerHandler.serverImplementer.Implementation Field

ServerHandler serverImplementer Implementation Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Type Implementation
public Type Implementation
Public Implementation As Type
Public Implementation As Type
public:
Type^ Implementation
public:
Type^ Implementation
val mutable Implementation: Type
val mutable Implementation: Type

Field Value

Type: Online Type
See Also
ServerHandler serverImplementer Class
ServerHandler serverImplementer Members
NFX.Glue.Implementation Namespace


ServerHandler.serverImplementer.InstanceMode Field

ServerHandler serverImplementer InstanceMode Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerInstanceMode InstanceMode
public ServerInstanceMode InstanceMode
Public InstanceMode As ServerInstanceMode
Public InstanceMode As ServerInstanceMode
public:
ServerInstanceMode InstanceMode
public:
ServerInstanceMode InstanceMode
val mutable InstanceMode: ServerInstanceMode
val mutable InstanceMode: ServerInstanceMode

Field Value

Type: ServerInstanceMode
See Also
ServerHandler serverImplementer Class
ServerHandler serverImplementer Members
NFX.Glue.Implementation Namespace


ServerHandler.serverImplementer.InstanceTimeoutMs Field

ServerHandler serverImplementer InstanceTimeoutMs Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int InstanceTimeoutMs
public int InstanceTimeoutMs
Public InstanceTimeoutMs As Integer
Public InstanceTimeoutMs As Integer
public:
int InstanceTimeoutMs
public:
int InstanceTimeoutMs
val mutable InstanceTimeoutMs: int
val mutable InstanceTimeoutMs: int

Field Value

Type: Online Int32
See Also
ServerHandler serverImplementer Class
ServerHandler serverImplementer Members
NFX.Glue.Implementation Namespace


ServerHandler.serverImplementer.methodMap Field

ServerHandler serverImplementer methodMap Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Dictionary<MethodSpec, ServerHandler..::..serverImplementer..::..mapping> methodMap
public Dictionary<MethodSpec, ServerHandler..::..serverImplementer..::..mapping> methodMap
Public methodMap As Dictionary(Of MethodSpec, ServerHandler..::..serverImplementer..::..mapping)
Public methodMap As Dictionary(Of MethodSpec, ServerHandler..::..serverImplementer..::..mapping)
public:
Dictionary<MethodSpec, ServerHandler..::..serverImplementer..::..mapping>^ methodMap
public:
Dictionary<MethodSpec, ServerHandler..::..serverImplementer..::..mapping>^ methodMap
val mutable methodMap: Dictionary<MethodSpec, ServerHandler..::..serverImplementer..::..mapping>
val mutable methodMap: Dictionary<MethodSpec, ServerHandler..::..serverImplementer..::..mapping>

Field Value

Type: Online Dictionary MethodSpec, ServerHandler serverImplementer mapping
See Also
ServerHandler serverImplementer Class
ServerHandler serverImplementer Members
NFX.Glue.Implementation Namespace


ServerHandler.serverImplementer.ServerEndPoint Field

ServerHandler serverImplementer ServerEndPoint Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerEndPoint ServerEndPoint
public ServerEndPoint ServerEndPoint
Public ServerEndPoint As ServerEndPoint
Public ServerEndPoint As ServerEndPoint
public:
ServerEndPoint^ ServerEndPoint
public:
ServerEndPoint^ ServerEndPoint
val mutable ServerEndPoint: ServerEndPoint
val mutable ServerEndPoint: ServerEndPoint

Field Value

Type: ServerEndPoint
See Also
ServerHandler serverImplementer Class
ServerHandler serverImplementer Members
NFX.Glue.Implementation Namespace


ServerHandler.serverImplementer.SupportsGlueCtor Field

ServerHandler serverImplementer SupportsGlueCtor Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsGlueCtor
public bool SupportsGlueCtor
Public SupportsGlueCtor As Boolean
Public SupportsGlueCtor As Boolean
public:
bool SupportsGlueCtor
public:
bool SupportsGlueCtor
val mutable SupportsGlueCtor: bool
val mutable SupportsGlueCtor: bool

Field Value

Type: Online Boolean
See Also
ServerHandler serverImplementer Class
ServerHandler serverImplementer Members
NFX.Glue.Implementation Namespace


ServerHandler.serverImplementer.ThreadSafe Field

ServerHandler serverImplementer ThreadSafe Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ThreadSafe
public bool ThreadSafe
Public ThreadSafe As Boolean
Public ThreadSafe As Boolean
public:
bool ThreadSafe
public:
bool ThreadSafe
val mutable ThreadSafe: bool
val mutable ThreadSafe: bool

Field Value

Type: Online Boolean
See Also
ServerHandler serverImplementer Class
ServerHandler serverImplementer Members
NFX.Glue.Implementation Namespace


ServerHandler.serverImplementer Methods

ServerHandler serverImplementer Methods NFX Class Library

The ServerHandler serverImplementer type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SpecToMethodInfos |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerHandler serverImplementer Class
NFX.Glue.Implementation Namespace


ServerHandler.serverImplementer.SpecToMethodInfos Method

ServerHandler serverImplementer SpecToMethodInfos Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerHandler..::..serverImplementer..::..mapping SpecToMethodInfos(
    MethodSpec spec
)
public ServerHandler..::..serverImplementer..::..mapping SpecToMethodInfos(
    MethodSpec spec
)
Public Function SpecToMethodInfos (
    spec As MethodSpec
) As ServerHandler..::..serverImplementer..::..mapping
Public Function SpecToMethodInfos (
    spec As MethodSpec
) As ServerHandler..::..serverImplementer..::..mapping
public:
ServerHandler..::..serverImplementer..::..mapping SpecToMethodInfos(
    MethodSpec spec
)
public:
ServerHandler..::..serverImplementer..::..mapping SpecToMethodInfos(
    MethodSpec spec
)
member SpecToMethodInfos :
        spec : MethodSpec -> ServerHandler..::..serverImplementer..::..mapping
member SpecToMethodInfos :
        spec : MethodSpec -> ServerHandler..::..serverImplementer..::..mapping

Parameters

spec
Type: NFX.Glue.Protocol MethodSpec

Return Value

Type: ServerHandler serverImplementer mapping
See Also
ServerHandler serverImplementer Class
ServerHandler serverImplementer Members
NFX.Glue.Implementation Namespace


ServerHandler.serverImplementer.mapping Structure

ServerHandler serverImplementer mapping Structure NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct mapping
public struct mapping
Public Structure mapping
Public Structure mapping
public value class mapping
public value class mapping
[<SealedAttribute>]
type mapping =  struct end
[<SealedAttribute>]
type mapping =  struct end
See Also
ServerHandler serverImplementer mapping Members
NFX.Glue.Implementation Namespace


ServerHandler.serverImplementer.mapping Members

ServerHandler serverImplementer mapping Members NFX Class Library

[This is preliminary documentation and is subject to change.]

The ServerHandler serverImplementer mapping type exposes the following members.
Constructors
 | Name | Description
Public method | ServerHandler serverImplementer mapping | Initializes a new instance of the ServerHandler serverImplementer mapping class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | fBody |
Public field | miContract |
Public field | miImplementation |
Back to Top
See Also
ServerHandler serverImplementer mapping Structure
NFX.Glue.Implementation Namespace


ServerHandler.serverImplementer.mapping Constructor

ServerHandler serverImplementer mapping Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerHandler serverImplementer mapping class

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public mapping(
    MethodInfo c,
    MethodInfo i,
    Func<Object, RequestMsg, Object> f
)
public mapping(
    MethodInfo c,
    MethodInfo i,
    Func<Object, RequestMsg, Object> f
)
Public Sub New (
    c As MethodInfo,
    i As MethodInfo,
    f As Func(Of Object, RequestMsg, Object)
)
Public Sub New (
    c As MethodInfo,
    i As MethodInfo,
    f As Func(Of Object, RequestMsg, Object)
)
public:
mapping(
    MethodInfo^ c,
    MethodInfo^ i,
    Func<Object^, RequestMsg^, Object^>^ f
)
public:
mapping(
    MethodInfo^ c,
    MethodInfo^ i,
    Func<Object^, RequestMsg^, Object^>^ f
)
new :
        c : MethodInfo *
        i : MethodInfo *
        f : Func<Object, RequestMsg, Object> -> mapping
new :
        c : MethodInfo *
        i : MethodInfo *
        f : Func<Object, RequestMsg, Object> -> mapping

Parameters

c
Type: Online System.Reflection MethodInfo
i
Type: Online System.Reflection MethodInfo
f
Type: Online System Func Online Object, RequestMsg, Online Object
See Also
ServerHandler serverImplementer mapping Structure
ServerHandler serverImplementer mapping Members
NFX.Glue.Implementation Namespace


ServerHandler.serverImplementer.mapping Fields

ServerHandler serverImplementer mapping Fields NFX Class Library

[This is preliminary documentation and is subject to change.]

The ServerHandler serverImplementer mapping type exposes the following members.
Fields
 | Name | Description
Public field | fBody |
Public field | miContract |
Public field | miImplementation |
Back to Top
See Also
ServerHandler serverImplementer mapping Structure
NFX.Glue.Implementation Namespace


ServerHandler.serverImplementer.mapping.fBody Field

ServerHandler serverImplementer mapping fBody Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Func<Object, RequestMsg, Object> fBody
public Func<Object, RequestMsg, Object> fBody
Public fBody As Func(Of Object, RequestMsg, Object)
Public fBody As Func(Of Object, RequestMsg, Object)
public:
Func<Object^, RequestMsg^, Object^>^ fBody
public:
Func<Object^, RequestMsg^, Object^>^ fBody
val mutable fBody: Func<Object, RequestMsg, Object>
val mutable fBody: Func<Object, RequestMsg, Object>

Field Value

Type: Online Func Online Object, RequestMsg, Online Object
See Also
ServerHandler serverImplementer mapping Structure
ServerHandler serverImplementer mapping Members
NFX.Glue.Implementation Namespace


ServerHandler.serverImplementer.mapping.miContract Field

ServerHandler serverImplementer mapping miContract Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MethodInfo miContract
public MethodInfo miContract
Public miContract As MethodInfo
Public miContract As MethodInfo
public:
MethodInfo^ miContract
public:
MethodInfo^ miContract
val mutable miContract: MethodInfo
val mutable miContract: MethodInfo

Field Value

Type: Online MethodInfo
See Also
ServerHandler serverImplementer mapping Structure
ServerHandler serverImplementer mapping Members
NFX.Glue.Implementation Namespace


ServerHandler.serverImplementer.mapping.miImplementation Field

ServerHandler serverImplementer mapping miImplementation Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Implementation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MethodInfo miImplementation
public MethodInfo miImplementation
Public miImplementation As MethodInfo
Public miImplementation As MethodInfo
public:
MethodInfo^ miImplementation
public:
MethodInfo^ miImplementation
val mutable miImplementation: MethodInfo
val mutable miImplementation: MethodInfo

Field Value

Type: Online MethodInfo
See Also
ServerHandler serverImplementer mapping Structure
ServerHandler serverImplementer mapping Members
NFX.Glue.Implementation Namespace


ServerHandler.serverImplementer.mapping Methods

ServerHandler serverImplementer mapping Methods NFX Class Library

[This is preliminary documentation and is subject to change.]

The ServerHandler serverImplementer mapping type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerHandler serverImplementer mapping Structure
NFX.Glue.Implementation Namespace


NFX.Glue.Instrumentation Namespace

NFX.Glue.Instrumentation Namespace NFX Class Library

Provides instrumentation gauges and events for Glue
Classes
 | Class | Description
Public class | CallSlotNotFoundErrorEvent |
Public class | ClientBytesReceived |
Public class | ClientBytesSent |
Public class | ClientCallRoundtripTime |
Public class | ClientConnectedEvent |
Public class | ClientDeserializationErrorEvent |
Public class | ClientDisconnectedEvent |
Public class | ClientDoubleGauge |
Public class | ClientErrors |
Public class | ClientEvent |
Public class | ClientGauge |
Public class | ClientGotOverMaxMsgSizeErrorEvent |
Public class | ClientMsgReceived |
Public class | ClientMsgSent |
Public class | ClientSerializedOverMaxMsgSizeErrorEvent |
Public class | ClientTimedOutCallSlotsRemoved |
Public class | ClientTotalBytesReceived |
Public class | ClientTotalBytesSent |
Public class | ClientTotalErrors |
Public class | ClientTotalMsgReceived |
Public class | ClientTotalMsgSent |
Public class | ClientTransportCount |
Public class | ClientTransportErrorEvent |
Public class | GlueDoubleGauge |
Public class | GlueEvent |
Public class | GlueLongGauge |
Public class | InactiveClientTransportClosedEvent |
Public class | InactiveServerTransportClosedEvent |
Public class | ServerBytesReceived |
Public class | ServerBytesSent |
Public class | ServerDeserializationErrorEvent |
Public class | ServerErrors |
Public class | ServerEvent |
Public class | ServerGauge |
Public class | ServerGotOverMaxMsgSizeErrorEvent |
Public class | ServerListenerErrorEvent |
Public class | ServerMsgReceived |
Public class | ServerMsgSent |
Public class | ServerSerializedOverMaxMsgSizeErrorEvent |
Public class | ServerTotalBytesReceived |
Public class | ServerTotalBytesSent |
Public class | ServerTotalErrors |
Public class | ServerTotalMsgReceived |
Public class | ServerTotalMsgSent |
Public class | ServerTransportChannelCount |
Public class | ServerTransportCount |
Public class | ServerTransportErrorEvent |


CallSlotNotFoundErrorEvent Class

CallSlotNotFoundErrorEvent Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Event
NFX.Glue.Instrumentation GlueEvent
NFX.Glue.Instrumentation ClientEvent
NFX.Glue.Instrumentation CallSlotNotFoundErrorEvent

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CallSlotNotFoundErrorEvent : ClientEvent,
    IErrorInstrument, IProblemClass, INetInstrument, IIOInstrumentClass, IOperationClass,
    IInstrumentClass
[SerializableAttribute]
public class CallSlotNotFoundErrorEvent : ClientEvent,
    IErrorInstrument, IProblemClass, INetInstrument, IIOInstrumentClass, IOperationClass,
    IInstrumentClass
<SerializableAttribute>
Public Class CallSlotNotFoundErrorEvent
    Inherits ClientEvent
    Implements IErrorInstrument, IProblemClass, INetInstrument, IIOInstrumentClass,
    IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class CallSlotNotFoundErrorEvent
    Inherits ClientEvent
    Implements IErrorInstrument, IProblemClass, INetInstrument, IIOInstrumentClass,
    IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class CallSlotNotFoundErrorEvent : public ClientEvent,
    IErrorInstrument, IProblemClass, INetInstrument, IIOInstrumentClass, IOperationClass,
    IInstrumentClass
[SerializableAttribute]
public ref class CallSlotNotFoundErrorEvent : public ClientEvent,
    IErrorInstrument, IProblemClass, INetInstrument, IIOInstrumentClass, IOperationClass,
    IInstrumentClass
[<SerializableAttribute>]
type CallSlotNotFoundErrorEvent =
    class
        inherit ClientEvent
        interface IErrorInstrument
        interface IProblemClass
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type CallSlotNotFoundErrorEvent =
    class
        inherit ClientEvent
        interface IErrorInstrument
        interface IProblemClass
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
CallSlotNotFoundErrorEvent Members
NFX.Glue.Instrumentation Namespace


CallSlotNotFoundErrorEvent Members

CallSlotNotFoundErrorEvent Members NFX Class Library

The CallSlotNotFoundErrorEvent type exposes the following members.
Constructors
 | Name | Description
Protected method | CallSlotNotFoundErrorEvent | Initializes a new instance of the CallSlotNotFoundErrorEvent class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Happened |
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CallSlotNotFoundErrorEvent Class
NFX.Glue.Instrumentation Namespace


CallSlotNotFoundErrorEvent Constructor

CallSlotNotFoundErrorEvent Constructor NFX Class Library

Initializes a new instance of the CallSlotNotFoundErrorEvent class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CallSlotNotFoundErrorEvent()
protected CallSlotNotFoundErrorEvent()
Protected Sub New
Protected Sub New
protected:
CallSlotNotFoundErrorEvent()
protected:
CallSlotNotFoundErrorEvent()
new : unit -> CallSlotNotFoundErrorEvent
new : unit -> CallSlotNotFoundErrorEvent
See Also
CallSlotNotFoundErrorEvent Class
CallSlotNotFoundErrorEvent Members
NFX.Glue.Instrumentation Namespace


CallSlotNotFoundErrorEvent Fields

CallSlotNotFoundErrorEvent Fields NFX Class Library

The CallSlotNotFoundErrorEvent type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
CallSlotNotFoundErrorEvent Class
NFX.Glue.Instrumentation Namespace


CallSlotNotFoundErrorEvent Methods

CallSlotNotFoundErrorEvent Methods NFX Class Library

The CallSlotNotFoundErrorEvent type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Happened |
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CallSlotNotFoundErrorEvent Class
NFX.Glue.Instrumentation Namespace


CallSlotNotFoundErrorEvent.Happened Method

CallSlotNotFoundErrorEvent Happened Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Happened()
public static void Happened()
Public Shared Sub Happened
Public Shared Sub Happened
public:
static void Happened()
public:
static void Happened()
static member Happened : unit -> unit
static member Happened : unit -> unit
See Also
CallSlotNotFoundErrorEvent Class
CallSlotNotFoundErrorEvent Members
NFX.Glue.Instrumentation Namespace


CallSlotNotFoundErrorEvent.MakeAggregateInstance Method

CallSlotNotFoundErrorEvent MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
CallSlotNotFoundErrorEvent Class
CallSlotNotFoundErrorEvent Members
NFX.Glue.Instrumentation Namespace


CallSlotNotFoundErrorEvent Properties

CallSlotNotFoundErrorEvent Properties NFX Class Library

The CallSlotNotFoundErrorEvent type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CallSlotNotFoundErrorEvent Class
NFX.Glue.Instrumentation Namespace


CallSlotNotFoundErrorEvent.Description Property

CallSlotNotFoundErrorEvent Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
CallSlotNotFoundErrorEvent Class
CallSlotNotFoundErrorEvent Members
NFX.Glue.Instrumentation Namespace


ClientBytesReceived Class

ClientBytesReceived Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Glue.Instrumentation ClientGauge
NFX.Glue.Instrumentation ClientBytesReceived

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ClientBytesReceived : ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class ClientBytesReceived : ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientBytesReceived
    Inherits ClientGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientBytesReceived
    Inherits ClientGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientBytesReceived : public ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientBytesReceived : public ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type ClientBytesReceived =
    class
        inherit ClientGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ClientBytesReceived =
    class
        inherit ClientGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ClientBytesReceived Members
NFX.Glue.Instrumentation Namespace


ClientBytesReceived Members

ClientBytesReceived Members NFX Class Library

The ClientBytesReceived type exposes the following members.
Constructors
 | Name | Description
Protected method | ClientBytesReceived | Initializes a new instance of the ClientBytesReceived class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientBytesReceived Class
NFX.Glue.Instrumentation Namespace


ClientBytesReceived Constructor

ClientBytesReceived Constructor NFX Class Library

Initializes a new instance of the ClientBytesReceived class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ClientBytesReceived(
    string src,
    long value
)
protected ClientBytesReceived(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
ClientBytesReceived(
    String^ src,
    long long value
)
protected:
ClientBytesReceived(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ClientBytesReceived
new :
        src : string *
        value : int64 -> ClientBytesReceived

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ClientBytesReceived Class
ClientBytesReceived Members
NFX.Glue.Instrumentation Namespace


ClientBytesReceived Fields

ClientBytesReceived Fields NFX Class Library

The ClientBytesReceived type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ClientBytesReceived Class
NFX.Glue.Instrumentation Namespace


ClientBytesReceived Methods

ClientBytesReceived Methods NFX Class Library

The ClientBytesReceived type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ClientBytesReceived Class
NFX.Glue.Instrumentation Namespace


ClientBytesReceived.MakeAggregateInstance Method

ClientBytesReceived MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ClientBytesReceived Class
ClientBytesReceived Members
NFX.Glue.Instrumentation Namespace


ClientBytesReceived.Record Method

ClientBytesReceived Record Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    Node node,
    long value
)
public static void Record(
    Node node,
    long value
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
public:
static void Record(
    Node node,
    long long value
)
public:
static void Record(
    Node node,
    long long value
)
static member Record :
        node : Node *
        value : int64 -> unit
static member Record :
        node : Node *
        value : int64 -> unit

Parameters

node
Type: NFX.Glue Node
value
Type: Online System Int64
See Also
ClientBytesReceived Class
ClientBytesReceived Members
NFX.Glue.Instrumentation Namespace


ClientBytesReceived Properties

ClientBytesReceived Properties NFX Class Library

The ClientBytesReceived type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientBytesReceived Class
NFX.Glue.Instrumentation Namespace


ClientBytesReceived.Description Property

ClientBytesReceived Description Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ClientBytesReceived Class
ClientBytesReceived Members
NFX.Glue.Instrumentation Namespace


ClientBytesReceived.ValueUnitName Property

ClientBytesReceived ValueUnitName Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ClientBytesReceived Class
ClientBytesReceived Members
NFX.Glue.Instrumentation Namespace


ClientBytesSent Class

ClientBytesSent Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Glue.Instrumentation ClientGauge
NFX.Glue.Instrumentation ClientBytesSent

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ClientBytesSent : ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class ClientBytesSent : ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientBytesSent
    Inherits ClientGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientBytesSent
    Inherits ClientGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientBytesSent : public ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientBytesSent : public ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type ClientBytesSent =
    class
        inherit ClientGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ClientBytesSent =
    class
        inherit ClientGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ClientBytesSent Members
NFX.Glue.Instrumentation Namespace


ClientBytesSent Members

ClientBytesSent Members NFX Class Library

The ClientBytesSent type exposes the following members.
Constructors
 | Name | Description
Protected method | ClientBytesSent | Initializes a new instance of the ClientBytesSent class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientBytesSent Class
NFX.Glue.Instrumentation Namespace


ClientBytesSent Constructor

ClientBytesSent Constructor NFX Class Library

Initializes a new instance of the ClientBytesSent class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ClientBytesSent(
    string src,
    long value
)
protected ClientBytesSent(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
ClientBytesSent(
    String^ src,
    long long value
)
protected:
ClientBytesSent(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ClientBytesSent
new :
        src : string *
        value : int64 -> ClientBytesSent

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ClientBytesSent Class
ClientBytesSent Members
NFX.Glue.Instrumentation Namespace


ClientBytesSent Fields

ClientBytesSent Fields NFX Class Library

The ClientBytesSent type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ClientBytesSent Class
NFX.Glue.Instrumentation Namespace


ClientBytesSent Methods

ClientBytesSent Methods NFX Class Library

The ClientBytesSent type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ClientBytesSent Class
NFX.Glue.Instrumentation Namespace


ClientBytesSent.MakeAggregateInstance Method

ClientBytesSent MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ClientBytesSent Class
ClientBytesSent Members
NFX.Glue.Instrumentation Namespace


ClientBytesSent.Record Method

ClientBytesSent Record Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    Node node,
    long value
)
public static void Record(
    Node node,
    long value
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
public:
static void Record(
    Node node,
    long long value
)
public:
static void Record(
    Node node,
    long long value
)
static member Record :
        node : Node *
        value : int64 -> unit
static member Record :
        node : Node *
        value : int64 -> unit

Parameters

node
Type: NFX.Glue Node
value
Type: Online System Int64
See Also
ClientBytesSent Class
ClientBytesSent Members
NFX.Glue.Instrumentation Namespace


ClientBytesSent Properties

ClientBytesSent Properties NFX Class Library

The ClientBytesSent type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientBytesSent Class
NFX.Glue.Instrumentation Namespace


ClientBytesSent.Description Property

ClientBytesSent Description Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ClientBytesSent Class
ClientBytesSent Members
NFX.Glue.Instrumentation Namespace


ClientBytesSent.ValueUnitName Property

ClientBytesSent ValueUnitName Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ClientBytesSent Class
ClientBytesSent Members
NFX.Glue.Instrumentation Namespace


ClientCallRoundtripTime Class

ClientCallRoundtripTime Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation DoubleGauge
NFX.Glue.Instrumentation GlueDoubleGauge
NFX.Glue.Instrumentation ClientDoubleGauge
NFX.Glue.Instrumentation ClientCallRoundtripTime

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ClientCallRoundtripTime : ClientDoubleGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class ClientCallRoundtripTime : ClientDoubleGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientCallRoundtripTime
    Inherits ClientDoubleGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientCallRoundtripTime
    Inherits ClientDoubleGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientCallRoundtripTime : public ClientDoubleGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientCallRoundtripTime : public ClientDoubleGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type ClientCallRoundtripTime =
    class
        inherit ClientDoubleGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ClientCallRoundtripTime =
    class
        inherit ClientDoubleGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ClientCallRoundtripTime Members
NFX.Glue.Instrumentation Namespace


ClientCallRoundtripTime Members

ClientCallRoundtripTime Members NFX Class Library

The ClientCallRoundtripTime type exposes the following members.
Constructors
 | Name | Description
Protected method | ClientCallRoundtripTime | Initializes a new instance of the ClientCallRoundtripTime class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from DoubleGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from DoubleGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from DoubleGauge.)
Public property | ValueAsObject | (Inherited from DoubleGauge.)
Public property | ValueUnitName | (Overrides DoubleGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientCallRoundtripTime Class
NFX.Glue.Instrumentation Namespace


ClientCallRoundtripTime Constructor

ClientCallRoundtripTime Constructor NFX Class Library

Initializes a new instance of the ClientCallRoundtripTime class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ClientCallRoundtripTime(
    string src,
    double value
)
protected ClientCallRoundtripTime(
    string src,
    double value
)
Protected Sub New (
    src As String,
    value As Double
)
Protected Sub New (
    src As String,
    value As Double
)
protected:
ClientCallRoundtripTime(
    String^ src,
    double value
)
protected:
ClientCallRoundtripTime(
    String^ src,
    double value
)
new :
        src : string *
        value : float -> ClientCallRoundtripTime
new :
        src : string *
        value : float -> ClientCallRoundtripTime

Parameters

src
Type: Online System String
value
Type: Online System Double
See Also
ClientCallRoundtripTime Class
ClientCallRoundtripTime Members
NFX.Glue.Instrumentation Namespace


ClientCallRoundtripTime Fields

ClientCallRoundtripTime Fields NFX Class Library

The ClientCallRoundtripTime type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ClientCallRoundtripTime Class
NFX.Glue.Instrumentation Namespace


ClientCallRoundtripTime Methods

ClientCallRoundtripTime Methods NFX Class Library

The ClientCallRoundtripTime type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from DoubleGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from DoubleGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ClientCallRoundtripTime Class
NFX.Glue.Instrumentation Namespace


ClientCallRoundtripTime.MakeAggregateInstance Method

ClientCallRoundtripTime MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ClientCallRoundtripTime Class
ClientCallRoundtripTime Members
NFX.Glue.Instrumentation Namespace


ClientCallRoundtripTime.Record Method

ClientCallRoundtripTime Record Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    string key,
    double value
)
public static void Record(
    string key,
    double value
)
Public Shared Sub Record (
    key As String,
    value As Double
)
Public Shared Sub Record (
    key As String,
    value As Double
)
public:
static void Record(
    String^ key,
    double value
)
public:
static void Record(
    String^ key,
    double value
)
static member Record :
        key : string *
        value : float -> unit
static member Record :
        key : string *
        value : float -> unit

Parameters

key
Type: Online System String
value
Type: Online System Double
See Also
ClientCallRoundtripTime Class
ClientCallRoundtripTime Members
NFX.Glue.Instrumentation Namespace


ClientCallRoundtripTime Properties

ClientCallRoundtripTime Properties NFX Class Library

The ClientCallRoundtripTime type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from DoubleGauge.)
Public property | ValueAsObject | (Inherited from DoubleGauge.)
Public property | ValueUnitName | (Overrides DoubleGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientCallRoundtripTime Class
NFX.Glue.Instrumentation Namespace


ClientCallRoundtripTime.Description Property

ClientCallRoundtripTime Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ClientCallRoundtripTime Class
ClientCallRoundtripTime Members
NFX.Glue.Instrumentation Namespace


ClientCallRoundtripTime.ValueUnitName Property

ClientCallRoundtripTime ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ClientCallRoundtripTime Class
ClientCallRoundtripTime Members
NFX.Glue.Instrumentation Namespace


ClientConnectedEvent Class

ClientConnectedEvent Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Event
NFX.Glue.Instrumentation GlueEvent
NFX.Glue.Instrumentation ServerEvent
NFX.Glue.Instrumentation ClientConnectedEvent

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ClientConnectedEvent : ServerEvent,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class ClientConnectedEvent : ServerEvent,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientConnectedEvent
    Inherits ServerEvent
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientConnectedEvent
    Inherits ServerEvent
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientConnectedEvent : public ServerEvent,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientConnectedEvent : public ServerEvent,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type ClientConnectedEvent =
    class
        inherit ServerEvent
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ClientConnectedEvent =
    class
        inherit ServerEvent
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ClientConnectedEvent Members
NFX.Glue.Instrumentation Namespace


ClientConnectedEvent Members

ClientConnectedEvent Members NFX Class Library

The ClientConnectedEvent type exposes the following members.
Constructors
 | Name | Description
Protected method | ClientConnectedEvent | Initializes a new instance of the ClientConnectedEvent class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Happened |
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientConnectedEvent Class
NFX.Glue.Instrumentation Namespace


ClientConnectedEvent Constructor

ClientConnectedEvent Constructor NFX Class Library

Initializes a new instance of the ClientConnectedEvent class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ClientConnectedEvent(
    string from
)
protected ClientConnectedEvent(
    string from
)
Protected Sub New (
    from As String
)
Protected Sub New (
    from As String
)
protected:
ClientConnectedEvent(
    String^ from
)
protected:
ClientConnectedEvent(
    String^ from
)
new :
        from : string -> ClientConnectedEvent
new :
        from : string -> ClientConnectedEvent

Parameters

from
Type: Online System String
See Also
ClientConnectedEvent Class
ClientConnectedEvent Members
NFX.Glue.Instrumentation Namespace


ClientConnectedEvent Fields

ClientConnectedEvent Fields NFX Class Library

The ClientConnectedEvent type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ClientConnectedEvent Class
NFX.Glue.Instrumentation Namespace


ClientConnectedEvent Methods

ClientConnectedEvent Methods NFX Class Library

The ClientConnectedEvent type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Happened |
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ClientConnectedEvent Class
NFX.Glue.Instrumentation Namespace


ClientConnectedEvent.Happened Method

ClientConnectedEvent Happened Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Happened(
    string from
)
public static void Happened(
    string from
)
Public Shared Sub Happened (
    from As String
)
Public Shared Sub Happened (
    from As String
)
public:
static void Happened(
    String^ from
)
public:
static void Happened(
    String^ from
)
static member Happened :
        from : string -> unit
static member Happened :
        from : string -> unit

Parameters

from
Type: Online System String
See Also
ClientConnectedEvent Class
ClientConnectedEvent Members
NFX.Glue.Instrumentation Namespace


ClientConnectedEvent.MakeAggregateInstance Method

ClientConnectedEvent MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ClientConnectedEvent Class
ClientConnectedEvent Members
NFX.Glue.Instrumentation Namespace


ClientConnectedEvent Properties

ClientConnectedEvent Properties NFX Class Library

The ClientConnectedEvent type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientConnectedEvent Class
NFX.Glue.Instrumentation Namespace


ClientConnectedEvent.Description Property

ClientConnectedEvent Description Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ClientConnectedEvent Class
ClientConnectedEvent Members
NFX.Glue.Instrumentation Namespace


ClientDeserializationErrorEvent Class

ClientDeserializationErrorEvent Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Event
NFX.Glue.Instrumentation GlueEvent
NFX.Glue.Instrumentation ClientEvent
NFX.Glue.Instrumentation ClientTransportErrorEvent
NFX.Glue.Instrumentation ClientDeserializationErrorEvent

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ClientDeserializationErrorEvent : ClientTransportErrorEvent
[SerializableAttribute]
public class ClientDeserializationErrorEvent : ClientTransportErrorEvent
<SerializableAttribute>
Public Class ClientDeserializationErrorEvent
    Inherits ClientTransportErrorEvent
<SerializableAttribute>
Public Class ClientDeserializationErrorEvent
    Inherits ClientTransportErrorEvent
[SerializableAttribute]
public ref class ClientDeserializationErrorEvent : public ClientTransportErrorEvent
[SerializableAttribute]
public ref class ClientDeserializationErrorEvent : public ClientTransportErrorEvent
[<SerializableAttribute>]
type ClientDeserializationErrorEvent =
    class
        inherit ClientTransportErrorEvent
    end
[<SerializableAttribute>]
type ClientDeserializationErrorEvent =
    class
        inherit ClientTransportErrorEvent
    end
See Also
ClientDeserializationErrorEvent Members
NFX.Glue.Instrumentation Namespace


ClientDeserializationErrorEvent Members

ClientDeserializationErrorEvent Members NFX Class Library

The ClientDeserializationErrorEvent type exposes the following members.
Constructors
 | Name | Description
Protected method | ClientDeserializationErrorEvent | Initializes a new instance of the ClientDeserializationErrorEvent class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Happened |
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientDeserializationErrorEvent Class
NFX.Glue.Instrumentation Namespace


ClientDeserializationErrorEvent Constructor

ClientDeserializationErrorEvent Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ClientDeserializationErrorEvent class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ClientDeserializationErrorEvent(
    string src
)
protected ClientDeserializationErrorEvent(
    string src
)
Protected Sub New (
    src As String
)
Protected Sub New (
    src As String
)
protected:
ClientDeserializationErrorEvent(
    String^ src
)
protected:
ClientDeserializationErrorEvent(
    String^ src
)
new :
        src : string -> ClientDeserializationErrorEvent
new :
        src : string -> ClientDeserializationErrorEvent

Parameters

src
Type: Online System String
See Also
ClientDeserializationErrorEvent Class
ClientDeserializationErrorEvent Members
NFX.Glue.Instrumentation Namespace


ClientDeserializationErrorEvent Fields

ClientDeserializationErrorEvent Fields NFX Class Library

The ClientDeserializationErrorEvent type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ClientDeserializationErrorEvent Class
NFX.Glue.Instrumentation Namespace


ClientDeserializationErrorEvent Methods

ClientDeserializationErrorEvent Methods NFX Class Library

The ClientDeserializationErrorEvent type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Happened |
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ClientDeserializationErrorEvent Class
NFX.Glue.Instrumentation Namespace


ClientDeserializationErrorEvent.Happened Method

ClientDeserializationErrorEvent Happened Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Happened(
    Node node
)
public static void Happened(
    Node node
)
Public Shared Sub Happened (
    node As Node
)
Public Shared Sub Happened (
    node As Node
)
public:
static void Happened(
    Node node
)
public:
static void Happened(
    Node node
)
static member Happened :
        node : Node -> unit
static member Happened :
        node : Node -> unit

Parameters

node
Type: NFX.Glue Node
See Also
ClientDeserializationErrorEvent Class
ClientDeserializationErrorEvent Members
NFX.Glue.Instrumentation Namespace


ClientDeserializationErrorEvent.MakeAggregateInstance Method

ClientDeserializationErrorEvent MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ClientDeserializationErrorEvent Class
ClientDeserializationErrorEvent Members
NFX.Glue.Instrumentation Namespace


ClientDeserializationErrorEvent Properties

ClientDeserializationErrorEvent Properties NFX Class Library

The ClientDeserializationErrorEvent type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientDeserializationErrorEvent Class
NFX.Glue.Instrumentation Namespace


ClientDeserializationErrorEvent.Description Property

ClientDeserializationErrorEvent Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ClientDeserializationErrorEvent Class
ClientDeserializationErrorEvent Members
NFX.Glue.Instrumentation Namespace


ClientDisconnectedEvent Class

ClientDisconnectedEvent Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Event
NFX.Glue.Instrumentation GlueEvent
NFX.Glue.Instrumentation ServerEvent
NFX.Glue.Instrumentation ClientDisconnectedEvent

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ClientDisconnectedEvent : ServerEvent,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class ClientDisconnectedEvent : ServerEvent,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientDisconnectedEvent
    Inherits ServerEvent
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientDisconnectedEvent
    Inherits ServerEvent
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientDisconnectedEvent : public ServerEvent,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientDisconnectedEvent : public ServerEvent,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type ClientDisconnectedEvent =
    class
        inherit ServerEvent
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ClientDisconnectedEvent =
    class
        inherit ServerEvent
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ClientDisconnectedEvent Members
NFX.Glue.Instrumentation Namespace


ClientDisconnectedEvent Members

ClientDisconnectedEvent Members NFX Class Library

The ClientDisconnectedEvent type exposes the following members.
Constructors
 | Name | Description
Protected method | ClientDisconnectedEvent | Initializes a new instance of the ClientDisconnectedEvent class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Happened |
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientDisconnectedEvent Class
NFX.Glue.Instrumentation Namespace


ClientDisconnectedEvent Constructor

ClientDisconnectedEvent Constructor NFX Class Library

Initializes a new instance of the ClientDisconnectedEvent class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ClientDisconnectedEvent(
    string from
)
protected ClientDisconnectedEvent(
    string from
)
Protected Sub New (
    from As String
)
Protected Sub New (
    from As String
)
protected:
ClientDisconnectedEvent(
    String^ from
)
protected:
ClientDisconnectedEvent(
    String^ from
)
new :
        from : string -> ClientDisconnectedEvent
new :
        from : string -> ClientDisconnectedEvent

Parameters

from
Type: Online System String
See Also
ClientDisconnectedEvent Class
ClientDisconnectedEvent Members
NFX.Glue.Instrumentation Namespace


ClientDisconnectedEvent Fields

ClientDisconnectedEvent Fields NFX Class Library

The ClientDisconnectedEvent type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ClientDisconnectedEvent Class
NFX.Glue.Instrumentation Namespace


ClientDisconnectedEvent Methods

ClientDisconnectedEvent Methods NFX Class Library

The ClientDisconnectedEvent type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Happened |
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ClientDisconnectedEvent Class
NFX.Glue.Instrumentation Namespace


ClientDisconnectedEvent.Happened Method

ClientDisconnectedEvent Happened Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Happened(
    string from
)
public static void Happened(
    string from
)
Public Shared Sub Happened (
    from As String
)
Public Shared Sub Happened (
    from As String
)
public:
static void Happened(
    String^ from
)
public:
static void Happened(
    String^ from
)
static member Happened :
        from : string -> unit
static member Happened :
        from : string -> unit

Parameters

from
Type: Online System String
See Also
ClientDisconnectedEvent Class
ClientDisconnectedEvent Members
NFX.Glue.Instrumentation Namespace


ClientDisconnectedEvent.MakeAggregateInstance Method

ClientDisconnectedEvent MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ClientDisconnectedEvent Class
ClientDisconnectedEvent Members
NFX.Glue.Instrumentation Namespace


ClientDisconnectedEvent Properties

ClientDisconnectedEvent Properties NFX Class Library

The ClientDisconnectedEvent type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientDisconnectedEvent Class
NFX.Glue.Instrumentation Namespace


ClientDisconnectedEvent.Description Property

ClientDisconnectedEvent Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ClientDisconnectedEvent Class
ClientDisconnectedEvent Members
NFX.Glue.Instrumentation Namespace


ClientDoubleGauge Class

ClientDoubleGauge Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation DoubleGauge
NFX.Glue.Instrumentation GlueDoubleGauge
NFX.Glue.Instrumentation ClientDoubleGauge
NFX.Glue.Instrumentation ClientCallRoundtripTime

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class ClientDoubleGauge : GlueDoubleGauge
[SerializableAttribute]
public abstract class ClientDoubleGauge : GlueDoubleGauge
<SerializableAttribute>
Public MustInherit Class ClientDoubleGauge
    Inherits GlueDoubleGauge
<SerializableAttribute>
Public MustInherit Class ClientDoubleGauge
    Inherits GlueDoubleGauge
[SerializableAttribute]
public ref class ClientDoubleGauge abstract : public GlueDoubleGauge
[SerializableAttribute]
public ref class ClientDoubleGauge abstract : public GlueDoubleGauge
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ClientDoubleGauge =
    class
        inherit GlueDoubleGauge
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ClientDoubleGauge =
    class
        inherit GlueDoubleGauge
    end
See Also
ClientDoubleGauge Members
NFX.Glue.Instrumentation Namespace


ClientDoubleGauge Members

ClientDoubleGauge Members NFX Class Library

The ClientDoubleGauge type exposes the following members.
Constructors
 | Name | Description
Protected method | ClientDoubleGauge | Initializes a new instance of the ClientDoubleGauge class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from DoubleGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from DoubleGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from DoubleGauge.)
Public property | ValueAsObject | (Inherited from DoubleGauge.)
Public property | ValueUnitName | (Inherited from DoubleGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientDoubleGauge Class
NFX.Glue.Instrumentation Namespace


ClientDoubleGauge Constructor

ClientDoubleGauge Constructor NFX Class Library

Initializes a new instance of the ClientDoubleGauge class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ClientDoubleGauge(
    string src,
    double value
)
protected ClientDoubleGauge(
    string src,
    double value
)
Protected Sub New (
    src As String,
    value As Double
)
Protected Sub New (
    src As String,
    value As Double
)
protected:
ClientDoubleGauge(
    String^ src,
    double value
)
protected:
ClientDoubleGauge(
    String^ src,
    double value
)
new :
        src : string *
        value : float -> ClientDoubleGauge
new :
        src : string *
        value : float -> ClientDoubleGauge

Parameters

src
Type: Online System String
value
Type: Online System Double
See Also
ClientDoubleGauge Class
ClientDoubleGauge Members
NFX.Glue.Instrumentation Namespace


ClientDoubleGauge Fields

ClientDoubleGauge Fields NFX Class Library

The ClientDoubleGauge type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ClientDoubleGauge Class
NFX.Glue.Instrumentation Namespace


ClientDoubleGauge Methods

ClientDoubleGauge Methods NFX Class Library

The ClientDoubleGauge type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from DoubleGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from DoubleGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ClientDoubleGauge Class
NFX.Glue.Instrumentation Namespace


ClientDoubleGauge Properties

ClientDoubleGauge Properties NFX Class Library

The ClientDoubleGauge type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from DoubleGauge.)
Public property | ValueAsObject | (Inherited from DoubleGauge.)
Public property | ValueUnitName | (Inherited from DoubleGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientDoubleGauge Class
NFX.Glue.Instrumentation Namespace


ClientErrors Class

ClientErrors Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Glue.Instrumentation ClientGauge
NFX.Glue.Instrumentation ClientErrors

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ClientErrors : ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IErrorInstrument, IProblemClass,
    IInstrumentClass
[SerializableAttribute]
public class ClientErrors : ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IErrorInstrument, IProblemClass,
    IInstrumentClass
<SerializableAttribute>
Public Class ClientErrors
    Inherits ClientGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IErrorInstrument,
    IProblemClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientErrors
    Inherits ClientGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IErrorInstrument,
    IProblemClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientErrors : public ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IErrorInstrument, IProblemClass,
    IInstrumentClass
[SerializableAttribute]
public ref class ClientErrors : public ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IErrorInstrument, IProblemClass,
    IInstrumentClass
[<SerializableAttribute>]
type ClientErrors =
    class
        inherit ClientGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IErrorInstrument
        interface IProblemClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ClientErrors =
    class
        inherit ClientGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IErrorInstrument
        interface IProblemClass
        interface IInstrumentClass
    end
See Also
ClientErrors Members
NFX.Glue.Instrumentation Namespace


ClientErrors Members

ClientErrors Members NFX Class Library

The ClientErrors type exposes the following members.
Constructors
 | Name | Description
Protected method | ClientErrors | Initializes a new instance of the ClientErrors class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientErrors Class
NFX.Glue.Instrumentation Namespace


ClientErrors Constructor

ClientErrors Constructor NFX Class Library

Initializes a new instance of the ClientErrors class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ClientErrors(
    string src,
    long value
)
protected ClientErrors(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
ClientErrors(
    String^ src,
    long long value
)
protected:
ClientErrors(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ClientErrors
new :
        src : string *
        value : int64 -> ClientErrors

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ClientErrors Class
ClientErrors Members
NFX.Glue.Instrumentation Namespace


ClientErrors Fields

ClientErrors Fields NFX Class Library

The ClientErrors type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ClientErrors Class
NFX.Glue.Instrumentation Namespace


ClientErrors Methods

ClientErrors Methods NFX Class Library

The ClientErrors type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ClientErrors Class
NFX.Glue.Instrumentation Namespace


ClientErrors.MakeAggregateInstance Method

ClientErrors MakeAggregateInstance Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ClientErrors Class
ClientErrors Members
NFX.Glue.Instrumentation Namespace


ClientErrors.Record Method

ClientErrors Record Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    Node node,
    long value
)
public static void Record(
    Node node,
    long value
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
public:
static void Record(
    Node node,
    long long value
)
public:
static void Record(
    Node node,
    long long value
)
static member Record :
        node : Node *
        value : int64 -> unit
static member Record :
        node : Node *
        value : int64 -> unit

Parameters

node
Type: NFX.Glue Node
value
Type: Online System Int64
See Also
ClientErrors Class
ClientErrors Members
NFX.Glue.Instrumentation Namespace


ClientErrors Properties

ClientErrors Properties NFX Class Library

The ClientErrors type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientErrors Class
NFX.Glue.Instrumentation Namespace


ClientErrors.Description Property

ClientErrors Description Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ClientErrors Class
ClientErrors Members
NFX.Glue.Instrumentation Namespace


ClientErrors.ValueUnitName Property

ClientErrors ValueUnitName Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ClientErrors Class
ClientErrors Members
NFX.Glue.Instrumentation Namespace


ClientEvent Class

ClientEvent Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Event
NFX.Glue.Instrumentation GlueEvent
NFX.Glue.Instrumentation ClientEvent
NFX.Glue.Instrumentation CallSlotNotFoundErrorEvent
NFX.Glue.Instrumentation ClientTransportErrorEvent
NFX.Glue.Instrumentation InactiveClientTransportClosedEvent

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class ClientEvent : GlueEvent
[SerializableAttribute]
public abstract class ClientEvent : GlueEvent
<SerializableAttribute>
Public MustInherit Class ClientEvent
    Inherits GlueEvent
<SerializableAttribute>
Public MustInherit Class ClientEvent
    Inherits GlueEvent
[SerializableAttribute]
public ref class ClientEvent abstract : public GlueEvent
[SerializableAttribute]
public ref class ClientEvent abstract : public GlueEvent
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ClientEvent =
    class
        inherit GlueEvent
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ClientEvent =
    class
        inherit GlueEvent
    end
See Also
ClientEvent Members
NFX.Glue.Instrumentation Namespace


ClientEvent Members

ClientEvent Members NFX Class Library

The ClientEvent type exposes the following members.
Constructors
 | Name | Description
Protected method | ClientEvent | Initializes a new instance of the ClientEvent class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientEvent Class
NFX.Glue.Instrumentation Namespace


ClientEvent Constructor

ClientEvent Constructor NFX Class Library

Initializes a new instance of the ClientEvent class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ClientEvent(
    string src
)
protected ClientEvent(
    string src
)
Protected Sub New (
    src As String
)
Protected Sub New (
    src As String
)
protected:
ClientEvent(
    String^ src
)
protected:
ClientEvent(
    String^ src
)
new :
        src : string -> ClientEvent
new :
        src : string -> ClientEvent

Parameters

src
Type: Online System String
See Also
ClientEvent Class
ClientEvent Members
NFX.Glue.Instrumentation Namespace


ClientEvent Fields

ClientEvent Fields NFX Class Library

The ClientEvent type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ClientEvent Class
NFX.Glue.Instrumentation Namespace


ClientEvent Methods

ClientEvent Methods NFX Class Library

The ClientEvent type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ClientEvent Class
NFX.Glue.Instrumentation Namespace


ClientEvent Properties

ClientEvent Properties NFX Class Library

The ClientEvent type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientEvent Class
NFX.Glue.Instrumentation Namespace


ClientGauge Class

ClientGauge Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Glue.Instrumentation ClientGauge
NFX.Glue.Instrumentation ClientBytesReceived
NFX.Glue.Instrumentation ClientBytesSent
NFX.Glue.Instrumentation ClientErrors
NFX.Glue.Instrumentation ClientMsgReceived
NFX.Glue.Instrumentation ClientMsgSent
NFX.Glue.Instrumentation ClientTimedOutCallSlotsRemoved
NFX.Glue.Instrumentation ClientTotalBytesReceived
NFX.Glue.Instrumentation ClientTotalBytesSent
NFX.Glue.Instrumentation ClientTotalErrors
NFX.Glue.Instrumentation ClientTotalMsgReceived
NFX.Glue.Instrumentation ClientTotalMsgSent
NFX.Glue.Instrumentation ClientTransportCount

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class ClientGauge : GlueLongGauge
[SerializableAttribute]
public abstract class ClientGauge : GlueLongGauge
<SerializableAttribute>
Public MustInherit Class ClientGauge
    Inherits GlueLongGauge
<SerializableAttribute>
Public MustInherit Class ClientGauge
    Inherits GlueLongGauge
[SerializableAttribute]
public ref class ClientGauge abstract : public GlueLongGauge
[SerializableAttribute]
public ref class ClientGauge abstract : public GlueLongGauge
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ClientGauge =
    class
        inherit GlueLongGauge
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ClientGauge =
    class
        inherit GlueLongGauge
    end
See Also
ClientGauge Members
NFX.Glue.Instrumentation Namespace


ClientGauge Members

ClientGauge Members NFX Class Library

The ClientGauge type exposes the following members.
Constructors
 | Name | Description
Protected method | ClientGauge | Initializes a new instance of the ClientGauge class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Inherited from LongGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientGauge Class
NFX.Glue.Instrumentation Namespace


ClientGauge Constructor

ClientGauge Constructor NFX Class Library

Initializes a new instance of the ClientGauge class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ClientGauge(
    string src,
    long value
)
protected ClientGauge(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
ClientGauge(
    String^ src,
    long long value
)
protected:
ClientGauge(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ClientGauge
new :
        src : string *
        value : int64 -> ClientGauge

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ClientGauge Class
ClientGauge Members
NFX.Glue.Instrumentation Namespace


ClientGauge Fields

ClientGauge Fields NFX Class Library

The ClientGauge type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ClientGauge Class
NFX.Glue.Instrumentation Namespace


ClientGauge Methods

ClientGauge Methods NFX Class Library

The ClientGauge type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ClientGauge Class
NFX.Glue.Instrumentation Namespace


ClientGauge Properties

ClientGauge Properties NFX Class Library

The ClientGauge type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Inherited from LongGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientGauge Class
NFX.Glue.Instrumentation Namespace


ClientGotOverMaxMsgSizeErrorEvent Class

ClientGotOverMaxMsgSizeErrorEvent Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Event
NFX.Glue.Instrumentation GlueEvent
NFX.Glue.Instrumentation ClientEvent
NFX.Glue.Instrumentation ClientTransportErrorEvent
NFX.Glue.Instrumentation ClientGotOverMaxMsgSizeErrorEvent

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ClientGotOverMaxMsgSizeErrorEvent : ClientTransportErrorEvent
[SerializableAttribute]
public class ClientGotOverMaxMsgSizeErrorEvent : ClientTransportErrorEvent
<SerializableAttribute>
Public Class ClientGotOverMaxMsgSizeErrorEvent
    Inherits ClientTransportErrorEvent
<SerializableAttribute>
Public Class ClientGotOverMaxMsgSizeErrorEvent
    Inherits ClientTransportErrorEvent
[SerializableAttribute]
public ref class ClientGotOverMaxMsgSizeErrorEvent : public ClientTransportErrorEvent
[SerializableAttribute]
public ref class ClientGotOverMaxMsgSizeErrorEvent : public ClientTransportErrorEvent
[<SerializableAttribute>]
type ClientGotOverMaxMsgSizeErrorEvent =
    class
        inherit ClientTransportErrorEvent
    end
[<SerializableAttribute>]
type ClientGotOverMaxMsgSizeErrorEvent =
    class
        inherit ClientTransportErrorEvent
    end
See Also
ClientGotOverMaxMsgSizeErrorEvent Members
NFX.Glue.Instrumentation Namespace


ClientGotOverMaxMsgSizeErrorEvent Members

ClientGotOverMaxMsgSizeErrorEvent Members NFX Class Library

The ClientGotOverMaxMsgSizeErrorEvent type exposes the following members.
Constructors
 | Name | Description
Protected method | ClientGotOverMaxMsgSizeErrorEvent | Initializes a new instance of the ClientGotOverMaxMsgSizeErrorEvent class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Happened |
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientGotOverMaxMsgSizeErrorEvent Class
NFX.Glue.Instrumentation Namespace


ClientGotOverMaxMsgSizeErrorEvent Constructor

ClientGotOverMaxMsgSizeErrorEvent Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ClientGotOverMaxMsgSizeErrorEvent class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ClientGotOverMaxMsgSizeErrorEvent(
    string src
)
protected ClientGotOverMaxMsgSizeErrorEvent(
    string src
)
Protected Sub New (
    src As String
)
Protected Sub New (
    src As String
)
protected:
ClientGotOverMaxMsgSizeErrorEvent(
    String^ src
)
protected:
ClientGotOverMaxMsgSizeErrorEvent(
    String^ src
)
new :
        src : string -> ClientGotOverMaxMsgSizeErrorEvent
new :
        src : string -> ClientGotOverMaxMsgSizeErrorEvent

Parameters

src
Type: Online System String
See Also
ClientGotOverMaxMsgSizeErrorEvent Class
ClientGotOverMaxMsgSizeErrorEvent Members
NFX.Glue.Instrumentation Namespace


ClientGotOverMaxMsgSizeErrorEvent Fields

ClientGotOverMaxMsgSizeErrorEvent Fields NFX Class Library

The ClientGotOverMaxMsgSizeErrorEvent type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ClientGotOverMaxMsgSizeErrorEvent Class
NFX.Glue.Instrumentation Namespace


ClientGotOverMaxMsgSizeErrorEvent Methods

ClientGotOverMaxMsgSizeErrorEvent Methods NFX Class Library

The ClientGotOverMaxMsgSizeErrorEvent type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Happened |
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ClientGotOverMaxMsgSizeErrorEvent Class
NFX.Glue.Instrumentation Namespace


ClientGotOverMaxMsgSizeErrorEvent.Happened Method

ClientGotOverMaxMsgSizeErrorEvent Happened Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Happened(
    Node node
)
public static void Happened(
    Node node
)
Public Shared Sub Happened (
    node As Node
)
Public Shared Sub Happened (
    node As Node
)
public:
static void Happened(
    Node node
)
public:
static void Happened(
    Node node
)
static member Happened :
        node : Node -> unit
static member Happened :
        node : Node -> unit

Parameters

node
Type: NFX.Glue Node
See Also
ClientGotOverMaxMsgSizeErrorEvent Class
ClientGotOverMaxMsgSizeErrorEvent Members
NFX.Glue.Instrumentation Namespace


ClientGotOverMaxMsgSizeErrorEvent.MakeAggregateInstance Method

ClientGotOverMaxMsgSizeErrorEvent MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ClientGotOverMaxMsgSizeErrorEvent Class
ClientGotOverMaxMsgSizeErrorEvent Members
NFX.Glue.Instrumentation Namespace


ClientGotOverMaxMsgSizeErrorEvent Properties

ClientGotOverMaxMsgSizeErrorEvent Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The ClientGotOverMaxMsgSizeErrorEvent type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientGotOverMaxMsgSizeErrorEvent Class
NFX.Glue.Instrumentation Namespace


ClientGotOverMaxMsgSizeErrorEvent.Description Property

ClientGotOverMaxMsgSizeErrorEvent Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ClientGotOverMaxMsgSizeErrorEvent Class
ClientGotOverMaxMsgSizeErrorEvent Members
NFX.Glue.Instrumentation Namespace


ClientMsgReceived Class

ClientMsgReceived Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Glue.Instrumentation ClientGauge
NFX.Glue.Instrumentation ClientMsgReceived

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ClientMsgReceived : ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class ClientMsgReceived : ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientMsgReceived
    Inherits ClientGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientMsgReceived
    Inherits ClientGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientMsgReceived : public ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientMsgReceived : public ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type ClientMsgReceived =
    class
        inherit ClientGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ClientMsgReceived =
    class
        inherit ClientGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ClientMsgReceived Members
NFX.Glue.Instrumentation Namespace


ClientMsgReceived Members

ClientMsgReceived Members NFX Class Library

The ClientMsgReceived type exposes the following members.
Constructors
 | Name | Description
Protected method | ClientMsgReceived | Initializes a new instance of the ClientMsgReceived class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientMsgReceived Class
NFX.Glue.Instrumentation Namespace


ClientMsgReceived Constructor

ClientMsgReceived Constructor NFX Class Library

Initializes a new instance of the ClientMsgReceived class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ClientMsgReceived(
    string src,
    long value
)
protected ClientMsgReceived(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
ClientMsgReceived(
    String^ src,
    long long value
)
protected:
ClientMsgReceived(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ClientMsgReceived
new :
        src : string *
        value : int64 -> ClientMsgReceived

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ClientMsgReceived Class
ClientMsgReceived Members
NFX.Glue.Instrumentation Namespace


ClientMsgReceived Fields

ClientMsgReceived Fields NFX Class Library

The ClientMsgReceived type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ClientMsgReceived Class
NFX.Glue.Instrumentation Namespace


ClientMsgReceived Methods

ClientMsgReceived Methods NFX Class Library

The ClientMsgReceived type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ClientMsgReceived Class
NFX.Glue.Instrumentation Namespace


ClientMsgReceived.MakeAggregateInstance Method

ClientMsgReceived MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ClientMsgReceived Class
ClientMsgReceived Members
NFX.Glue.Instrumentation Namespace


ClientMsgReceived.Record Method

ClientMsgReceived Record Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    Node node,
    long value
)
public static void Record(
    Node node,
    long value
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
public:
static void Record(
    Node node,
    long long value
)
public:
static void Record(
    Node node,
    long long value
)
static member Record :
        node : Node *
        value : int64 -> unit
static member Record :
        node : Node *
        value : int64 -> unit

Parameters

node
Type: NFX.Glue Node
value
Type: Online System Int64
See Also
ClientMsgReceived Class
ClientMsgReceived Members
NFX.Glue.Instrumentation Namespace


ClientMsgReceived Properties

ClientMsgReceived Properties NFX Class Library

The ClientMsgReceived type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientMsgReceived Class
NFX.Glue.Instrumentation Namespace


ClientMsgReceived.Description Property

ClientMsgReceived Description Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ClientMsgReceived Class
ClientMsgReceived Members
NFX.Glue.Instrumentation Namespace


ClientMsgReceived.ValueUnitName Property

ClientMsgReceived ValueUnitName Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ClientMsgReceived Class
ClientMsgReceived Members
NFX.Glue.Instrumentation Namespace


ClientMsgSent Class

ClientMsgSent Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Glue.Instrumentation ClientGauge
NFX.Glue.Instrumentation ClientMsgSent

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ClientMsgSent : ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class ClientMsgSent : ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientMsgSent
    Inherits ClientGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientMsgSent
    Inherits ClientGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientMsgSent : public ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientMsgSent : public ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type ClientMsgSent =
    class
        inherit ClientGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ClientMsgSent =
    class
        inherit ClientGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ClientMsgSent Members
NFX.Glue.Instrumentation Namespace


ClientMsgSent Members

ClientMsgSent Members NFX Class Library

The ClientMsgSent type exposes the following members.
Constructors
 | Name | Description
Protected method | ClientMsgSent | Initializes a new instance of the ClientMsgSent class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientMsgSent Class
NFX.Glue.Instrumentation Namespace


ClientMsgSent Constructor

ClientMsgSent Constructor NFX Class Library

Initializes a new instance of the ClientMsgSent class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ClientMsgSent(
    string src,
    long value
)
protected ClientMsgSent(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
ClientMsgSent(
    String^ src,
    long long value
)
protected:
ClientMsgSent(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ClientMsgSent
new :
        src : string *
        value : int64 -> ClientMsgSent

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ClientMsgSent Class
ClientMsgSent Members
NFX.Glue.Instrumentation Namespace


ClientMsgSent Fields

ClientMsgSent Fields NFX Class Library

The ClientMsgSent type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ClientMsgSent Class
NFX.Glue.Instrumentation Namespace


ClientMsgSent Methods

ClientMsgSent Methods NFX Class Library

The ClientMsgSent type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ClientMsgSent Class
NFX.Glue.Instrumentation Namespace


ClientMsgSent.MakeAggregateInstance Method

ClientMsgSent MakeAggregateInstance Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ClientMsgSent Class
ClientMsgSent Members
NFX.Glue.Instrumentation Namespace


ClientMsgSent.Record Method

ClientMsgSent Record Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    Node node,
    long value
)
public static void Record(
    Node node,
    long value
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
public:
static void Record(
    Node node,
    long long value
)
public:
static void Record(
    Node node,
    long long value
)
static member Record :
        node : Node *
        value : int64 -> unit
static member Record :
        node : Node *
        value : int64 -> unit

Parameters

node
Type: NFX.Glue Node
value
Type: Online System Int64
See Also
ClientMsgSent Class
ClientMsgSent Members
NFX.Glue.Instrumentation Namespace


ClientMsgSent Properties

ClientMsgSent Properties NFX Class Library

The ClientMsgSent type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientMsgSent Class
NFX.Glue.Instrumentation Namespace


ClientMsgSent.Description Property

ClientMsgSent Description Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ClientMsgSent Class
ClientMsgSent Members
NFX.Glue.Instrumentation Namespace


ClientMsgSent.ValueUnitName Property

ClientMsgSent ValueUnitName Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ClientMsgSent Class
ClientMsgSent Members
NFX.Glue.Instrumentation Namespace


ClientSerializedOverMaxMsgSizeErrorEvent Class

ClientSerializedOverMaxMsgSizeErrorEvent Class NFX Class Library

[This is preliminary documentation and is subject to change.]

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Event
NFX.Glue.Instrumentation GlueEvent
NFX.Glue.Instrumentation ClientEvent
NFX.Glue.Instrumentation ClientTransportErrorEvent
NFX.Glue.Instrumentation ClientSerializedOverMaxMsgSizeErrorEvent

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ClientSerializedOverMaxMsgSizeErrorEvent : ClientTransportErrorEvent
[SerializableAttribute]
public class ClientSerializedOverMaxMsgSizeErrorEvent : ClientTransportErrorEvent
<SerializableAttribute>
Public Class ClientSerializedOverMaxMsgSizeErrorEvent
    Inherits ClientTransportErrorEvent
<SerializableAttribute>
Public Class ClientSerializedOverMaxMsgSizeErrorEvent
    Inherits ClientTransportErrorEvent
[SerializableAttribute]
public ref class ClientSerializedOverMaxMsgSizeErrorEvent : public ClientTransportErrorEvent
[SerializableAttribute]
public ref class ClientSerializedOverMaxMsgSizeErrorEvent : public ClientTransportErrorEvent
[<SerializableAttribute>]
type ClientSerializedOverMaxMsgSizeErrorEvent =
    class
        inherit ClientTransportErrorEvent
    end
[<SerializableAttribute>]
type ClientSerializedOverMaxMsgSizeErrorEvent =
    class
        inherit ClientTransportErrorEvent
    end
See Also
ClientSerializedOverMaxMsgSizeErrorEvent Members
NFX.Glue.Instrumentation Namespace


ClientSerializedOverMaxMsgSizeErrorEvent Members

ClientSerializedOverMaxMsgSizeErrorEvent Members NFX Class Library

[This is preliminary documentation and is subject to change.]

The ClientSerializedOverMaxMsgSizeErrorEvent type exposes the following members.
Constructors
 | Name | Description
Protected method | ClientSerializedOverMaxMsgSizeErrorEvent | Initializes a new instance of the ClientSerializedOverMaxMsgSizeErrorEvent class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Happened |
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientSerializedOverMaxMsgSizeErrorEvent Class
NFX.Glue.Instrumentation Namespace


ClientSerializedOverMaxMsgSizeErrorEvent Constructor

ClientSerializedOverMaxMsgSizeErrorEvent Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ClientSerializedOverMaxMsgSizeErrorEvent class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ClientSerializedOverMaxMsgSizeErrorEvent(
    string src
)
protected ClientSerializedOverMaxMsgSizeErrorEvent(
    string src
)
Protected Sub New (
    src As String
)
Protected Sub New (
    src As String
)
protected:
ClientSerializedOverMaxMsgSizeErrorEvent(
    String^ src
)
protected:
ClientSerializedOverMaxMsgSizeErrorEvent(
    String^ src
)
new :
        src : string -> ClientSerializedOverMaxMsgSizeErrorEvent
new :
        src : string -> ClientSerializedOverMaxMsgSizeErrorEvent

Parameters

src
Type: Online System String
See Also
ClientSerializedOverMaxMsgSizeErrorEvent Class
ClientSerializedOverMaxMsgSizeErrorEvent Members
NFX.Glue.Instrumentation Namespace


ClientSerializedOverMaxMsgSizeErrorEvent Fields

ClientSerializedOverMaxMsgSizeErrorEvent Fields NFX Class Library

[This is preliminary documentation and is subject to change.]

The ClientSerializedOverMaxMsgSizeErrorEvent type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ClientSerializedOverMaxMsgSizeErrorEvent Class
NFX.Glue.Instrumentation Namespace


ClientSerializedOverMaxMsgSizeErrorEvent Methods

ClientSerializedOverMaxMsgSizeErrorEvent Methods NFX Class Library

[This is preliminary documentation and is subject to change.]

The ClientSerializedOverMaxMsgSizeErrorEvent type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Happened |
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ClientSerializedOverMaxMsgSizeErrorEvent Class
NFX.Glue.Instrumentation Namespace


ClientSerializedOverMaxMsgSizeErrorEvent.Happened Method

ClientSerializedOverMaxMsgSizeErrorEvent Happened Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Happened(
    Node node
)
public static void Happened(
    Node node
)
Public Shared Sub Happened (
    node As Node
)
Public Shared Sub Happened (
    node As Node
)
public:
static void Happened(
    Node node
)
public:
static void Happened(
    Node node
)
static member Happened :
        node : Node -> unit
static member Happened :
        node : Node -> unit

Parameters

node
Type: NFX.Glue Node
See Also
ClientSerializedOverMaxMsgSizeErrorEvent Class
ClientSerializedOverMaxMsgSizeErrorEvent Members
NFX.Glue.Instrumentation Namespace


ClientSerializedOverMaxMsgSizeErrorEvent.MakeAggregateInstance Method

ClientSerializedOverMaxMsgSizeErrorEvent MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ClientSerializedOverMaxMsgSizeErrorEvent Class
ClientSerializedOverMaxMsgSizeErrorEvent Members
NFX.Glue.Instrumentation Namespace


ClientSerializedOverMaxMsgSizeErrorEvent Properties

ClientSerializedOverMaxMsgSizeErrorEvent Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The ClientSerializedOverMaxMsgSizeErrorEvent type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientSerializedOverMaxMsgSizeErrorEvent Class
NFX.Glue.Instrumentation Namespace


ClientSerializedOverMaxMsgSizeErrorEvent.Description Property

ClientSerializedOverMaxMsgSizeErrorEvent Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ClientSerializedOverMaxMsgSizeErrorEvent Class
ClientSerializedOverMaxMsgSizeErrorEvent Members
NFX.Glue.Instrumentation Namespace


ClientTimedOutCallSlotsRemoved Class

ClientTimedOutCallSlotsRemoved Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Glue.Instrumentation ClientGauge
NFX.Glue.Instrumentation ClientTimedOutCallSlotsRemoved

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ClientTimedOutCallSlotsRemoved : ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class ClientTimedOutCallSlotsRemoved : ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientTimedOutCallSlotsRemoved
    Inherits ClientGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientTimedOutCallSlotsRemoved
    Inherits ClientGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientTimedOutCallSlotsRemoved : public ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientTimedOutCallSlotsRemoved : public ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type ClientTimedOutCallSlotsRemoved =
    class
        inherit ClientGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ClientTimedOutCallSlotsRemoved =
    class
        inherit ClientGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ClientTimedOutCallSlotsRemoved Members
NFX.Glue.Instrumentation Namespace


ClientTimedOutCallSlotsRemoved Members

ClientTimedOutCallSlotsRemoved Members NFX Class Library

The ClientTimedOutCallSlotsRemoved type exposes the following members.
Constructors
 | Name | Description
Protected method | ClientTimedOutCallSlotsRemoved | Initializes a new instance of the ClientTimedOutCallSlotsRemoved class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientTimedOutCallSlotsRemoved Class
NFX.Glue.Instrumentation Namespace


ClientTimedOutCallSlotsRemoved Constructor

ClientTimedOutCallSlotsRemoved Constructor NFX Class Library

Initializes a new instance of the ClientTimedOutCallSlotsRemoved class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ClientTimedOutCallSlotsRemoved(
    long value
)
protected ClientTimedOutCallSlotsRemoved(
    long value
)
Protected Sub New (
    value As Long
)
Protected Sub New (
    value As Long
)
protected:
ClientTimedOutCallSlotsRemoved(
    long long value
)
protected:
ClientTimedOutCallSlotsRemoved(
    long long value
)
new :
        value : int64 -> ClientTimedOutCallSlotsRemoved
new :
        value : int64 -> ClientTimedOutCallSlotsRemoved

Parameters

value
Type: Online System Int64
See Also
ClientTimedOutCallSlotsRemoved Class
ClientTimedOutCallSlotsRemoved Members
NFX.Glue.Instrumentation Namespace


ClientTimedOutCallSlotsRemoved Fields

ClientTimedOutCallSlotsRemoved Fields NFX Class Library

The ClientTimedOutCallSlotsRemoved type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ClientTimedOutCallSlotsRemoved Class
NFX.Glue.Instrumentation Namespace


ClientTimedOutCallSlotsRemoved Methods

ClientTimedOutCallSlotsRemoved Methods NFX Class Library

The ClientTimedOutCallSlotsRemoved type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ClientTimedOutCallSlotsRemoved Class
NFX.Glue.Instrumentation Namespace


ClientTimedOutCallSlotsRemoved.MakeAggregateInstance Method

ClientTimedOutCallSlotsRemoved MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ClientTimedOutCallSlotsRemoved Class
ClientTimedOutCallSlotsRemoved Members
NFX.Glue.Instrumentation Namespace


ClientTimedOutCallSlotsRemoved.Record Method

ClientTimedOutCallSlotsRemoved Record Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    long value
)
public static void Record(
    long value
)
Public Shared Sub Record (
    value As Long
)
Public Shared Sub Record (
    value As Long
)
public:
static void Record(
    long long value
)
public:
static void Record(
    long long value
)
static member Record :
        value : int64 -> unit
static member Record :
        value : int64 -> unit

Parameters

value
Type: Online System Int64
See Also
ClientTimedOutCallSlotsRemoved Class
ClientTimedOutCallSlotsRemoved Members
NFX.Glue.Instrumentation Namespace


ClientTimedOutCallSlotsRemoved Properties

ClientTimedOutCallSlotsRemoved Properties NFX Class Library

The ClientTimedOutCallSlotsRemoved type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientTimedOutCallSlotsRemoved Class
NFX.Glue.Instrumentation Namespace


ClientTimedOutCallSlotsRemoved.Description Property

ClientTimedOutCallSlotsRemoved Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ClientTimedOutCallSlotsRemoved Class
ClientTimedOutCallSlotsRemoved Members
NFX.Glue.Instrumentation Namespace


ClientTimedOutCallSlotsRemoved.ValueUnitName Property

ClientTimedOutCallSlotsRemoved ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ClientTimedOutCallSlotsRemoved Class
ClientTimedOutCallSlotsRemoved Members
NFX.Glue.Instrumentation Namespace


ClientTotalBytesReceived Class

ClientTotalBytesReceived Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Glue.Instrumentation ClientGauge
NFX.Glue.Instrumentation ClientTotalBytesReceived

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ClientTotalBytesReceived : ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class ClientTotalBytesReceived : ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientTotalBytesReceived
    Inherits ClientGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientTotalBytesReceived
    Inherits ClientGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientTotalBytesReceived : public ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientTotalBytesReceived : public ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type ClientTotalBytesReceived =
    class
        inherit ClientGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ClientTotalBytesReceived =
    class
        inherit ClientGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ClientTotalBytesReceived Members
NFX.Glue.Instrumentation Namespace


ClientTotalBytesReceived Members

ClientTotalBytesReceived Members NFX Class Library

The ClientTotalBytesReceived type exposes the following members.
Constructors
 | Name | Description
Protected method | ClientTotalBytesReceived | Initializes a new instance of the ClientTotalBytesReceived class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientTotalBytesReceived Class
NFX.Glue.Instrumentation Namespace


ClientTotalBytesReceived Constructor

ClientTotalBytesReceived Constructor NFX Class Library

Initializes a new instance of the ClientTotalBytesReceived class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ClientTotalBytesReceived(
    string src,
    long value
)
protected ClientTotalBytesReceived(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
ClientTotalBytesReceived(
    String^ src,
    long long value
)
protected:
ClientTotalBytesReceived(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ClientTotalBytesReceived
new :
        src : string *
        value : int64 -> ClientTotalBytesReceived

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ClientTotalBytesReceived Class
ClientTotalBytesReceived Members
NFX.Glue.Instrumentation Namespace


ClientTotalBytesReceived Fields

ClientTotalBytesReceived Fields NFX Class Library

The ClientTotalBytesReceived type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ClientTotalBytesReceived Class
NFX.Glue.Instrumentation Namespace


ClientTotalBytesReceived Methods

ClientTotalBytesReceived Methods NFX Class Library

The ClientTotalBytesReceived type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ClientTotalBytesReceived Class
NFX.Glue.Instrumentation Namespace


ClientTotalBytesReceived.MakeAggregateInstance Method

ClientTotalBytesReceived MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ClientTotalBytesReceived Class
ClientTotalBytesReceived Members
NFX.Glue.Instrumentation Namespace


ClientTotalBytesReceived.Record Method

ClientTotalBytesReceived Record Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    Node node,
    long value
)
public static void Record(
    Node node,
    long value
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
public:
static void Record(
    Node node,
    long long value
)
public:
static void Record(
    Node node,
    long long value
)
static member Record :
        node : Node *
        value : int64 -> unit
static member Record :
        node : Node *
        value : int64 -> unit

Parameters

node
Type: NFX.Glue Node
value
Type: Online System Int64
See Also
ClientTotalBytesReceived Class
ClientTotalBytesReceived Members
NFX.Glue.Instrumentation Namespace


ClientTotalBytesReceived Properties

ClientTotalBytesReceived Properties NFX Class Library

The ClientTotalBytesReceived type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientTotalBytesReceived Class
NFX.Glue.Instrumentation Namespace


ClientTotalBytesReceived.Description Property

ClientTotalBytesReceived Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ClientTotalBytesReceived Class
ClientTotalBytesReceived Members
NFX.Glue.Instrumentation Namespace


ClientTotalBytesReceived.ValueUnitName Property

ClientTotalBytesReceived ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ClientTotalBytesReceived Class
ClientTotalBytesReceived Members
NFX.Glue.Instrumentation Namespace


ClientTotalBytesSent Class

ClientTotalBytesSent Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Glue.Instrumentation ClientGauge
NFX.Glue.Instrumentation ClientTotalBytesSent

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ClientTotalBytesSent : ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class ClientTotalBytesSent : ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientTotalBytesSent
    Inherits ClientGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientTotalBytesSent
    Inherits ClientGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientTotalBytesSent : public ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientTotalBytesSent : public ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type ClientTotalBytesSent =
    class
        inherit ClientGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ClientTotalBytesSent =
    class
        inherit ClientGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ClientTotalBytesSent Members
NFX.Glue.Instrumentation Namespace


ClientTotalBytesSent Members

ClientTotalBytesSent Members NFX Class Library

The ClientTotalBytesSent type exposes the following members.
Constructors
 | Name | Description
Protected method | ClientTotalBytesSent | Initializes a new instance of the ClientTotalBytesSent class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientTotalBytesSent Class
NFX.Glue.Instrumentation Namespace


ClientTotalBytesSent Constructor

ClientTotalBytesSent Constructor NFX Class Library

Initializes a new instance of the ClientTotalBytesSent class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ClientTotalBytesSent(
    string src,
    long value
)
protected ClientTotalBytesSent(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
ClientTotalBytesSent(
    String^ src,
    long long value
)
protected:
ClientTotalBytesSent(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ClientTotalBytesSent
new :
        src : string *
        value : int64 -> ClientTotalBytesSent

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ClientTotalBytesSent Class
ClientTotalBytesSent Members
NFX.Glue.Instrumentation Namespace


ClientTotalBytesSent Fields

ClientTotalBytesSent Fields NFX Class Library

The ClientTotalBytesSent type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ClientTotalBytesSent Class
NFX.Glue.Instrumentation Namespace


ClientTotalBytesSent Methods

ClientTotalBytesSent Methods NFX Class Library

The ClientTotalBytesSent type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ClientTotalBytesSent Class
NFX.Glue.Instrumentation Namespace


ClientTotalBytesSent.MakeAggregateInstance Method

ClientTotalBytesSent MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ClientTotalBytesSent Class
ClientTotalBytesSent Members
NFX.Glue.Instrumentation Namespace


ClientTotalBytesSent.Record Method

ClientTotalBytesSent Record Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    Node node,
    long value
)
public static void Record(
    Node node,
    long value
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
public:
static void Record(
    Node node,
    long long value
)
public:
static void Record(
    Node node,
    long long value
)
static member Record :
        node : Node *
        value : int64 -> unit
static member Record :
        node : Node *
        value : int64 -> unit

Parameters

node
Type: NFX.Glue Node
value
Type: Online System Int64
See Also
ClientTotalBytesSent Class
ClientTotalBytesSent Members
NFX.Glue.Instrumentation Namespace


ClientTotalBytesSent Properties

ClientTotalBytesSent Properties NFX Class Library

The ClientTotalBytesSent type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientTotalBytesSent Class
NFX.Glue.Instrumentation Namespace


ClientTotalBytesSent.Description Property

ClientTotalBytesSent Description Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ClientTotalBytesSent Class
ClientTotalBytesSent Members
NFX.Glue.Instrumentation Namespace


ClientTotalBytesSent.ValueUnitName Property

ClientTotalBytesSent ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ClientTotalBytesSent Class
ClientTotalBytesSent Members
NFX.Glue.Instrumentation Namespace


ClientTotalErrors Class

ClientTotalErrors Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Glue.Instrumentation ClientGauge
NFX.Glue.Instrumentation ClientTotalErrors

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ClientTotalErrors : ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IErrorInstrument, IProblemClass,
    IInstrumentClass
[SerializableAttribute]
public class ClientTotalErrors : ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IErrorInstrument, IProblemClass,
    IInstrumentClass
<SerializableAttribute>
Public Class ClientTotalErrors
    Inherits ClientGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IErrorInstrument,
    IProblemClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientTotalErrors
    Inherits ClientGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IErrorInstrument,
    IProblemClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientTotalErrors : public ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IErrorInstrument, IProblemClass,
    IInstrumentClass
[SerializableAttribute]
public ref class ClientTotalErrors : public ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IErrorInstrument, IProblemClass,
    IInstrumentClass
[<SerializableAttribute>]
type ClientTotalErrors =
    class
        inherit ClientGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IErrorInstrument
        interface IProblemClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ClientTotalErrors =
    class
        inherit ClientGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IErrorInstrument
        interface IProblemClass
        interface IInstrumentClass
    end
See Also
ClientTotalErrors Members
NFX.Glue.Instrumentation Namespace


ClientTotalErrors Members

ClientTotalErrors Members NFX Class Library

The ClientTotalErrors type exposes the following members.
Constructors
 | Name | Description
Protected method | ClientTotalErrors | Initializes a new instance of the ClientTotalErrors class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientTotalErrors Class
NFX.Glue.Instrumentation Namespace


ClientTotalErrors Constructor

ClientTotalErrors Constructor NFX Class Library

Initializes a new instance of the ClientTotalErrors class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ClientTotalErrors(
    string src,
    long value
)
protected ClientTotalErrors(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
ClientTotalErrors(
    String^ src,
    long long value
)
protected:
ClientTotalErrors(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ClientTotalErrors
new :
        src : string *
        value : int64 -> ClientTotalErrors

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ClientTotalErrors Class
ClientTotalErrors Members
NFX.Glue.Instrumentation Namespace


ClientTotalErrors Fields

ClientTotalErrors Fields NFX Class Library

The ClientTotalErrors type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ClientTotalErrors Class
NFX.Glue.Instrumentation Namespace


ClientTotalErrors Methods

ClientTotalErrors Methods NFX Class Library

The ClientTotalErrors type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ClientTotalErrors Class
NFX.Glue.Instrumentation Namespace


ClientTotalErrors.MakeAggregateInstance Method

ClientTotalErrors MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ClientTotalErrors Class
ClientTotalErrors Members
NFX.Glue.Instrumentation Namespace


ClientTotalErrors.Record Method

ClientTotalErrors Record Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    Node node,
    long value
)
public static void Record(
    Node node,
    long value
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
public:
static void Record(
    Node node,
    long long value
)
public:
static void Record(
    Node node,
    long long value
)
static member Record :
        node : Node *
        value : int64 -> unit
static member Record :
        node : Node *
        value : int64 -> unit

Parameters

node
Type: NFX.Glue Node
value
Type: Online System Int64
See Also
ClientTotalErrors Class
ClientTotalErrors Members
NFX.Glue.Instrumentation Namespace


ClientTotalErrors Properties

ClientTotalErrors Properties NFX Class Library

The ClientTotalErrors type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientTotalErrors Class
NFX.Glue.Instrumentation Namespace


ClientTotalErrors.Description Property

ClientTotalErrors Description Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ClientTotalErrors Class
ClientTotalErrors Members
NFX.Glue.Instrumentation Namespace


ClientTotalErrors.ValueUnitName Property

ClientTotalErrors ValueUnitName Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ClientTotalErrors Class
ClientTotalErrors Members
NFX.Glue.Instrumentation Namespace


ClientTotalMsgReceived Class

ClientTotalMsgReceived Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Glue.Instrumentation ClientGauge
NFX.Glue.Instrumentation ClientTotalMsgReceived

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ClientTotalMsgReceived : ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class ClientTotalMsgReceived : ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientTotalMsgReceived
    Inherits ClientGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientTotalMsgReceived
    Inherits ClientGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientTotalMsgReceived : public ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientTotalMsgReceived : public ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type ClientTotalMsgReceived =
    class
        inherit ClientGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ClientTotalMsgReceived =
    class
        inherit ClientGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ClientTotalMsgReceived Members
NFX.Glue.Instrumentation Namespace


ClientTotalMsgReceived Members

ClientTotalMsgReceived Members NFX Class Library

The ClientTotalMsgReceived type exposes the following members.
Constructors
 | Name | Description
Protected method | ClientTotalMsgReceived | Initializes a new instance of the ClientTotalMsgReceived class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientTotalMsgReceived Class
NFX.Glue.Instrumentation Namespace


ClientTotalMsgReceived Constructor

ClientTotalMsgReceived Constructor NFX Class Library

Initializes a new instance of the ClientTotalMsgReceived class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ClientTotalMsgReceived(
    string src,
    long value
)
protected ClientTotalMsgReceived(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
ClientTotalMsgReceived(
    String^ src,
    long long value
)
protected:
ClientTotalMsgReceived(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ClientTotalMsgReceived
new :
        src : string *
        value : int64 -> ClientTotalMsgReceived

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ClientTotalMsgReceived Class
ClientTotalMsgReceived Members
NFX.Glue.Instrumentation Namespace


ClientTotalMsgReceived Fields

ClientTotalMsgReceived Fields NFX Class Library

The ClientTotalMsgReceived type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ClientTotalMsgReceived Class
NFX.Glue.Instrumentation Namespace


ClientTotalMsgReceived Methods

ClientTotalMsgReceived Methods NFX Class Library

The ClientTotalMsgReceived type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ClientTotalMsgReceived Class
NFX.Glue.Instrumentation Namespace


ClientTotalMsgReceived.MakeAggregateInstance Method

ClientTotalMsgReceived MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ClientTotalMsgReceived Class
ClientTotalMsgReceived Members
NFX.Glue.Instrumentation Namespace


ClientTotalMsgReceived.Record Method

ClientTotalMsgReceived Record Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    Node node,
    long value
)
public static void Record(
    Node node,
    long value
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
public:
static void Record(
    Node node,
    long long value
)
public:
static void Record(
    Node node,
    long long value
)
static member Record :
        node : Node *
        value : int64 -> unit
static member Record :
        node : Node *
        value : int64 -> unit

Parameters

node
Type: NFX.Glue Node
value
Type: Online System Int64
See Also
ClientTotalMsgReceived Class
ClientTotalMsgReceived Members
NFX.Glue.Instrumentation Namespace


ClientTotalMsgReceived Properties

ClientTotalMsgReceived Properties NFX Class Library

The ClientTotalMsgReceived type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientTotalMsgReceived Class
NFX.Glue.Instrumentation Namespace


ClientTotalMsgReceived.Description Property

ClientTotalMsgReceived Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ClientTotalMsgReceived Class
ClientTotalMsgReceived Members
NFX.Glue.Instrumentation Namespace


ClientTotalMsgReceived.ValueUnitName Property

ClientTotalMsgReceived ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ClientTotalMsgReceived Class
ClientTotalMsgReceived Members
NFX.Glue.Instrumentation Namespace


ClientTotalMsgSent Class

ClientTotalMsgSent Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Glue.Instrumentation ClientGauge
NFX.Glue.Instrumentation ClientTotalMsgSent

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ClientTotalMsgSent : ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class ClientTotalMsgSent : ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientTotalMsgSent
    Inherits ClientGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientTotalMsgSent
    Inherits ClientGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientTotalMsgSent : public ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientTotalMsgSent : public ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type ClientTotalMsgSent =
    class
        inherit ClientGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ClientTotalMsgSent =
    class
        inherit ClientGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ClientTotalMsgSent Members
NFX.Glue.Instrumentation Namespace


ClientTotalMsgSent Members

ClientTotalMsgSent Members NFX Class Library

The ClientTotalMsgSent type exposes the following members.
Constructors
 | Name | Description
Protected method | ClientTotalMsgSent | Initializes a new instance of the ClientTotalMsgSent class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientTotalMsgSent Class
NFX.Glue.Instrumentation Namespace


ClientTotalMsgSent Constructor

ClientTotalMsgSent Constructor NFX Class Library

Initializes a new instance of the ClientTotalMsgSent class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ClientTotalMsgSent(
    string src,
    long value
)
protected ClientTotalMsgSent(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
ClientTotalMsgSent(
    String^ src,
    long long value
)
protected:
ClientTotalMsgSent(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ClientTotalMsgSent
new :
        src : string *
        value : int64 -> ClientTotalMsgSent

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ClientTotalMsgSent Class
ClientTotalMsgSent Members
NFX.Glue.Instrumentation Namespace


ClientTotalMsgSent Fields

ClientTotalMsgSent Fields NFX Class Library

The ClientTotalMsgSent type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ClientTotalMsgSent Class
NFX.Glue.Instrumentation Namespace


ClientTotalMsgSent Methods

ClientTotalMsgSent Methods NFX Class Library

The ClientTotalMsgSent type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ClientTotalMsgSent Class
NFX.Glue.Instrumentation Namespace


ClientTotalMsgSent.MakeAggregateInstance Method

ClientTotalMsgSent MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ClientTotalMsgSent Class
ClientTotalMsgSent Members
NFX.Glue.Instrumentation Namespace


ClientTotalMsgSent.Record Method

ClientTotalMsgSent Record Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    Node node,
    long value
)
public static void Record(
    Node node,
    long value
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
public:
static void Record(
    Node node,
    long long value
)
public:
static void Record(
    Node node,
    long long value
)
static member Record :
        node : Node *
        value : int64 -> unit
static member Record :
        node : Node *
        value : int64 -> unit

Parameters

node
Type: NFX.Glue Node
value
Type: Online System Int64
See Also
ClientTotalMsgSent Class
ClientTotalMsgSent Members
NFX.Glue.Instrumentation Namespace


ClientTotalMsgSent Properties

ClientTotalMsgSent Properties NFX Class Library

The ClientTotalMsgSent type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientTotalMsgSent Class
NFX.Glue.Instrumentation Namespace


ClientTotalMsgSent.Description Property

ClientTotalMsgSent Description Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ClientTotalMsgSent Class
ClientTotalMsgSent Members
NFX.Glue.Instrumentation Namespace


ClientTotalMsgSent.ValueUnitName Property

ClientTotalMsgSent ValueUnitName Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ClientTotalMsgSent Class
ClientTotalMsgSent Members
NFX.Glue.Instrumentation Namespace


ClientTransportCount Class

ClientTransportCount Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Glue.Instrumentation ClientGauge
NFX.Glue.Instrumentation ClientTransportCount

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ClientTransportCount : ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class ClientTransportCount : ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientTransportCount
    Inherits ClientGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ClientTransportCount
    Inherits ClientGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientTransportCount : public ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientTransportCount : public ClientGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type ClientTransportCount =
    class
        inherit ClientGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ClientTransportCount =
    class
        inherit ClientGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ClientTransportCount Members
NFX.Glue.Instrumentation Namespace


ClientTransportCount Members

ClientTransportCount Members NFX Class Library

The ClientTransportCount type exposes the following members.
Constructors
 | Name | Description
Protected method | ClientTransportCount | Initializes a new instance of the ClientTransportCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientTransportCount Class
NFX.Glue.Instrumentation Namespace


ClientTransportCount Constructor

ClientTransportCount Constructor NFX Class Library

Initializes a new instance of the ClientTransportCount class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ClientTransportCount(
    string src,
    long value
)
protected ClientTransportCount(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
ClientTransportCount(
    String^ src,
    long long value
)
protected:
ClientTransportCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ClientTransportCount
new :
        src : string *
        value : int64 -> ClientTransportCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ClientTransportCount Class
ClientTransportCount Members
NFX.Glue.Instrumentation Namespace


ClientTransportCount Fields

ClientTransportCount Fields NFX Class Library

The ClientTransportCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ClientTransportCount Class
NFX.Glue.Instrumentation Namespace


ClientTransportCount Methods

ClientTransportCount Methods NFX Class Library

The ClientTransportCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ClientTransportCount Class
NFX.Glue.Instrumentation Namespace


ClientTransportCount.MakeAggregateInstance Method

ClientTransportCount MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ClientTransportCount Class
ClientTransportCount Members
NFX.Glue.Instrumentation Namespace


ClientTransportCount.Record Method

ClientTransportCount Record Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    Node node,
    long value
)
public static void Record(
    Node node,
    long value
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
public:
static void Record(
    Node node,
    long long value
)
public:
static void Record(
    Node node,
    long long value
)
static member Record :
        node : Node *
        value : int64 -> unit
static member Record :
        node : Node *
        value : int64 -> unit

Parameters

node
Type: NFX.Glue Node
value
Type: Online System Int64
See Also
ClientTransportCount Class
ClientTransportCount Members
NFX.Glue.Instrumentation Namespace


ClientTransportCount Properties

ClientTransportCount Properties NFX Class Library

The ClientTransportCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientTransportCount Class
NFX.Glue.Instrumentation Namespace


ClientTransportCount.Description Property

ClientTransportCount Description Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ClientTransportCount Class
ClientTransportCount Members
NFX.Glue.Instrumentation Namespace


ClientTransportCount.ValueUnitName Property

ClientTransportCount ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ClientTransportCount Class
ClientTransportCount Members
NFX.Glue.Instrumentation Namespace


ClientTransportErrorEvent Class

ClientTransportErrorEvent Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Event
NFX.Glue.Instrumentation GlueEvent
NFX.Glue.Instrumentation ClientEvent
NFX.Glue.Instrumentation ClientTransportErrorEvent
NFX.Glue.Instrumentation ClientDeserializationErrorEvent
NFX.Glue.Instrumentation ClientGotOverMaxMsgSizeErrorEvent
NFX.Glue.Instrumentation ClientSerializedOverMaxMsgSizeErrorEvent

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class ClientTransportErrorEvent : ClientEvent,
    IErrorInstrument, IProblemClass, INetInstrument, IIOInstrumentClass, IOperationClass,
    IInstrumentClass
[SerializableAttribute]
public abstract class ClientTransportErrorEvent : ClientEvent,
    IErrorInstrument, IProblemClass, INetInstrument, IIOInstrumentClass, IOperationClass,
    IInstrumentClass
<SerializableAttribute>
Public MustInherit Class ClientTransportErrorEvent
    Inherits ClientEvent
    Implements IErrorInstrument, IProblemClass, INetInstrument, IIOInstrumentClass,
    IOperationClass, IInstrumentClass
<SerializableAttribute>
Public MustInherit Class ClientTransportErrorEvent
    Inherits ClientEvent
    Implements IErrorInstrument, IProblemClass, INetInstrument, IIOInstrumentClass,
    IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ClientTransportErrorEvent abstract : public ClientEvent,
    IErrorInstrument, IProblemClass, INetInstrument, IIOInstrumentClass, IOperationClass,
    IInstrumentClass
[SerializableAttribute]
public ref class ClientTransportErrorEvent abstract : public ClientEvent,
    IErrorInstrument, IProblemClass, INetInstrument, IIOInstrumentClass, IOperationClass,
    IInstrumentClass
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ClientTransportErrorEvent =
    class
        inherit ClientEvent
        interface IErrorInstrument
        interface IProblemClass
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ClientTransportErrorEvent =
    class
        inherit ClientEvent
        interface IErrorInstrument
        interface IProblemClass
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ClientTransportErrorEvent Members
NFX.Glue.Instrumentation Namespace


ClientTransportErrorEvent Members

ClientTransportErrorEvent Members NFX Class Library

The ClientTransportErrorEvent type exposes the following members.
Constructors
 | Name | Description
Protected method | ClientTransportErrorEvent | Initializes a new instance of the ClientTransportErrorEvent class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientTransportErrorEvent Class
NFX.Glue.Instrumentation Namespace


ClientTransportErrorEvent Constructor

ClientTransportErrorEvent Constructor NFX Class Library

Initializes a new instance of the ClientTransportErrorEvent class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ClientTransportErrorEvent(
    string src
)
protected ClientTransportErrorEvent(
    string src
)
Protected Sub New (
    src As String
)
Protected Sub New (
    src As String
)
protected:
ClientTransportErrorEvent(
    String^ src
)
protected:
ClientTransportErrorEvent(
    String^ src
)
new :
        src : string -> ClientTransportErrorEvent
new :
        src : string -> ClientTransportErrorEvent

Parameters

src
Type: Online System String
See Also
ClientTransportErrorEvent Class
ClientTransportErrorEvent Members
NFX.Glue.Instrumentation Namespace


ClientTransportErrorEvent Fields

ClientTransportErrorEvent Fields NFX Class Library

The ClientTransportErrorEvent type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ClientTransportErrorEvent Class
NFX.Glue.Instrumentation Namespace


ClientTransportErrorEvent Methods

ClientTransportErrorEvent Methods NFX Class Library

The ClientTransportErrorEvent type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ClientTransportErrorEvent Class
NFX.Glue.Instrumentation Namespace


ClientTransportErrorEvent Properties

ClientTransportErrorEvent Properties NFX Class Library

The ClientTransportErrorEvent type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ClientTransportErrorEvent Class
NFX.Glue.Instrumentation Namespace


GlueDoubleGauge Class

GlueDoubleGauge Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation DoubleGauge
NFX.Glue.Instrumentation GlueDoubleGauge
NFX.Glue.Instrumentation ClientDoubleGauge

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class GlueDoubleGauge : DoubleGauge
[SerializableAttribute]
public abstract class GlueDoubleGauge : DoubleGauge
<SerializableAttribute>
Public MustInherit Class GlueDoubleGauge
    Inherits DoubleGauge
<SerializableAttribute>
Public MustInherit Class GlueDoubleGauge
    Inherits DoubleGauge
[SerializableAttribute]
public ref class GlueDoubleGauge abstract : public DoubleGauge
[SerializableAttribute]
public ref class GlueDoubleGauge abstract : public DoubleGauge
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type GlueDoubleGauge =
    class
        inherit DoubleGauge
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type GlueDoubleGauge =
    class
        inherit DoubleGauge
    end
See Also
GlueDoubleGauge Members
NFX.Glue.Instrumentation Namespace


GlueDoubleGauge Members

GlueDoubleGauge Members NFX Class Library

The GlueDoubleGauge type exposes the following members.
Constructors
 | Name | Description
Protected method | GlueDoubleGauge | Initializes a new instance of the GlueDoubleGauge class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from DoubleGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from DoubleGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from DoubleGauge.)
Public property | ValueAsObject | (Inherited from DoubleGauge.)
Public property | ValueUnitName | (Inherited from DoubleGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
GlueDoubleGauge Class
NFX.Glue.Instrumentation Namespace


GlueDoubleGauge Constructor

GlueDoubleGauge Constructor NFX Class Library

Initializes a new instance of the GlueDoubleGauge class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected GlueDoubleGauge(
    string src,
    double value
)
protected GlueDoubleGauge(
    string src,
    double value
)
Protected Sub New (
    src As String,
    value As Double
)
Protected Sub New (
    src As String,
    value As Double
)
protected:
GlueDoubleGauge(
    String^ src,
    double value
)
protected:
GlueDoubleGauge(
    String^ src,
    double value
)
new :
        src : string *
        value : float -> GlueDoubleGauge
new :
        src : string *
        value : float -> GlueDoubleGauge

Parameters

src
Type: Online System String
value
Type: Online System Double
See Also
GlueDoubleGauge Class
GlueDoubleGauge Members
NFX.Glue.Instrumentation Namespace


GlueDoubleGauge Fields

GlueDoubleGauge Fields NFX Class Library

The GlueDoubleGauge type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
GlueDoubleGauge Class
NFX.Glue.Instrumentation Namespace


GlueDoubleGauge Methods

GlueDoubleGauge Methods NFX Class Library

The GlueDoubleGauge type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from DoubleGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from DoubleGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GlueDoubleGauge Class
NFX.Glue.Instrumentation Namespace


GlueDoubleGauge Properties

GlueDoubleGauge Properties NFX Class Library

The GlueDoubleGauge type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from DoubleGauge.)
Public property | ValueAsObject | (Inherited from DoubleGauge.)
Public property | ValueUnitName | (Inherited from DoubleGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
GlueDoubleGauge Class
NFX.Glue.Instrumentation Namespace


GlueEvent Class

GlueEvent Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Event
NFX.Glue.Instrumentation GlueEvent
NFX.Glue.Instrumentation ClientEvent
NFX.Glue.Instrumentation ServerEvent

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class GlueEvent : Event
[SerializableAttribute]
public abstract class GlueEvent : Event
<SerializableAttribute>
Public MustInherit Class GlueEvent
    Inherits Event
<SerializableAttribute>
Public MustInherit Class GlueEvent
    Inherits Event
[SerializableAttribute]
public ref class GlueEvent abstract : public Event
[SerializableAttribute]
public ref class GlueEvent abstract : public Event
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type GlueEvent =
    class
        inherit Event
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type GlueEvent =
    class
        inherit Event
    end
See Also
GlueEvent Members
NFX.Glue.Instrumentation Namespace


GlueEvent Members

GlueEvent Members NFX Class Library

The GlueEvent type exposes the following members.
Constructors
 | Name | Description
Protected method | GlueEvent | Initializes a new instance of the GlueEvent class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
GlueEvent Class
NFX.Glue.Instrumentation Namespace


GlueEvent Constructor

GlueEvent Constructor NFX Class Library

Initializes a new instance of the GlueEvent class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected GlueEvent(
    string src
)
protected GlueEvent(
    string src
)
Protected Sub New (
    src As String
)
Protected Sub New (
    src As String
)
protected:
GlueEvent(
    String^ src
)
protected:
GlueEvent(
    String^ src
)
new :
        src : string -> GlueEvent
new :
        src : string -> GlueEvent

Parameters

src
Type: Online System String
See Also
GlueEvent Class
GlueEvent Members
NFX.Glue.Instrumentation Namespace


GlueEvent Fields

GlueEvent Fields NFX Class Library

The GlueEvent type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
GlueEvent Class
NFX.Glue.Instrumentation Namespace


GlueEvent Methods

GlueEvent Methods NFX Class Library

The GlueEvent type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GlueEvent Class
NFX.Glue.Instrumentation Namespace


GlueEvent Properties

GlueEvent Properties NFX Class Library

The GlueEvent type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
GlueEvent Class
NFX.Glue.Instrumentation Namespace


GlueLongGauge Class

GlueLongGauge Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Glue.Instrumentation ClientGauge
NFX.Glue.Instrumentation ServerGauge

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class GlueLongGauge : LongGauge
[SerializableAttribute]
public abstract class GlueLongGauge : LongGauge
<SerializableAttribute>
Public MustInherit Class GlueLongGauge
    Inherits LongGauge
<SerializableAttribute>
Public MustInherit Class GlueLongGauge
    Inherits LongGauge
[SerializableAttribute]
public ref class GlueLongGauge abstract : public LongGauge
[SerializableAttribute]
public ref class GlueLongGauge abstract : public LongGauge
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type GlueLongGauge =
    class
        inherit LongGauge
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type GlueLongGauge =
    class
        inherit LongGauge
    end
See Also
GlueLongGauge Members
NFX.Glue.Instrumentation Namespace


GlueLongGauge Members

GlueLongGauge Members NFX Class Library

The GlueLongGauge type exposes the following members.
Constructors
 | Name | Description
Protected method | GlueLongGauge | Initializes a new instance of the GlueLongGauge class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Inherited from LongGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
GlueLongGauge Class
NFX.Glue.Instrumentation Namespace


GlueLongGauge Constructor

GlueLongGauge Constructor NFX Class Library

Initializes a new instance of the GlueLongGauge class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected GlueLongGauge(
    string src,
    long value
)
protected GlueLongGauge(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
GlueLongGauge(
    String^ src,
    long long value
)
protected:
GlueLongGauge(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> GlueLongGauge
new :
        src : string *
        value : int64 -> GlueLongGauge

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
GlueLongGauge Class
GlueLongGauge Members
NFX.Glue.Instrumentation Namespace


GlueLongGauge Fields

GlueLongGauge Fields NFX Class Library

The GlueLongGauge type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
GlueLongGauge Class
NFX.Glue.Instrumentation Namespace


GlueLongGauge Methods

GlueLongGauge Methods NFX Class Library

The GlueLongGauge type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GlueLongGauge Class
NFX.Glue.Instrumentation Namespace


GlueLongGauge Properties

GlueLongGauge Properties NFX Class Library

The GlueLongGauge type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Inherited from LongGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
GlueLongGauge Class
NFX.Glue.Instrumentation Namespace


InactiveClientTransportClosedEvent Class

InactiveClientTransportClosedEvent Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Event
NFX.Glue.Instrumentation GlueEvent
NFX.Glue.Instrumentation ClientEvent
NFX.Glue.Instrumentation InactiveClientTransportClosedEvent

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class InactiveClientTransportClosedEvent : ClientEvent,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class InactiveClientTransportClosedEvent : ClientEvent,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class InactiveClientTransportClosedEvent
    Inherits ClientEvent
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class InactiveClientTransportClosedEvent
    Inherits ClientEvent
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class InactiveClientTransportClosedEvent : public ClientEvent,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class InactiveClientTransportClosedEvent : public ClientEvent,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type InactiveClientTransportClosedEvent =
    class
        inherit ClientEvent
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type InactiveClientTransportClosedEvent =
    class
        inherit ClientEvent
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
InactiveClientTransportClosedEvent Members
NFX.Glue.Instrumentation Namespace


InactiveClientTransportClosedEvent Members

InactiveClientTransportClosedEvent Members NFX Class Library

The InactiveClientTransportClosedEvent type exposes the following members.
Constructors
 | Name | Description
Protected method | InactiveClientTransportClosedEvent | Initializes a new instance of the InactiveClientTransportClosedEvent class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Happened |
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
InactiveClientTransportClosedEvent Class
NFX.Glue.Instrumentation Namespace


InactiveClientTransportClosedEvent Constructor

InactiveClientTransportClosedEvent Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the InactiveClientTransportClosedEvent class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected InactiveClientTransportClosedEvent(
    string src
)
protected InactiveClientTransportClosedEvent(
    string src
)
Protected Sub New (
    src As String
)
Protected Sub New (
    src As String
)
protected:
InactiveClientTransportClosedEvent(
    String^ src
)
protected:
InactiveClientTransportClosedEvent(
    String^ src
)
new :
        src : string -> InactiveClientTransportClosedEvent
new :
        src : string -> InactiveClientTransportClosedEvent

Parameters

src
Type: Online System String
See Also
InactiveClientTransportClosedEvent Class
InactiveClientTransportClosedEvent Members
NFX.Glue.Instrumentation Namespace


InactiveClientTransportClosedEvent Fields

InactiveClientTransportClosedEvent Fields NFX Class Library

The InactiveClientTransportClosedEvent type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
InactiveClientTransportClosedEvent Class
NFX.Glue.Instrumentation Namespace


InactiveClientTransportClosedEvent Methods

InactiveClientTransportClosedEvent Methods NFX Class Library

The InactiveClientTransportClosedEvent type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Happened |
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
InactiveClientTransportClosedEvent Class
NFX.Glue.Instrumentation Namespace


InactiveClientTransportClosedEvent.Happened Method

InactiveClientTransportClosedEvent Happened Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Happened(
    Node node
)
public static void Happened(
    Node node
)
Public Shared Sub Happened (
    node As Node
)
Public Shared Sub Happened (
    node As Node
)
public:
static void Happened(
    Node node
)
public:
static void Happened(
    Node node
)
static member Happened :
        node : Node -> unit
static member Happened :
        node : Node -> unit

Parameters

node
Type: NFX.Glue Node
See Also
InactiveClientTransportClosedEvent Class
InactiveClientTransportClosedEvent Members
NFX.Glue.Instrumentation Namespace


InactiveClientTransportClosedEvent.MakeAggregateInstance Method

InactiveClientTransportClosedEvent MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
InactiveClientTransportClosedEvent Class
InactiveClientTransportClosedEvent Members
NFX.Glue.Instrumentation Namespace


InactiveClientTransportClosedEvent Properties

InactiveClientTransportClosedEvent Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The InactiveClientTransportClosedEvent type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
InactiveClientTransportClosedEvent Class
NFX.Glue.Instrumentation Namespace


InactiveClientTransportClosedEvent.Description Property

InactiveClientTransportClosedEvent Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
InactiveClientTransportClosedEvent Class
InactiveClientTransportClosedEvent Members
NFX.Glue.Instrumentation Namespace


InactiveServerTransportClosedEvent Class

InactiveServerTransportClosedEvent Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Event
NFX.Glue.Instrumentation GlueEvent
NFX.Glue.Instrumentation ServerEvent
NFX.Glue.Instrumentation InactiveServerTransportClosedEvent

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class InactiveServerTransportClosedEvent : ServerEvent,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class InactiveServerTransportClosedEvent : ServerEvent,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class InactiveServerTransportClosedEvent
    Inherits ServerEvent
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class InactiveServerTransportClosedEvent
    Inherits ServerEvent
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class InactiveServerTransportClosedEvent : public ServerEvent,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class InactiveServerTransportClosedEvent : public ServerEvent,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type InactiveServerTransportClosedEvent =
    class
        inherit ServerEvent
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type InactiveServerTransportClosedEvent =
    class
        inherit ServerEvent
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
InactiveServerTransportClosedEvent Members
NFX.Glue.Instrumentation Namespace


InactiveServerTransportClosedEvent Members

InactiveServerTransportClosedEvent Members NFX Class Library

The InactiveServerTransportClosedEvent type exposes the following members.
Constructors
 | Name | Description
Protected method | InactiveServerTransportClosedEvent | Initializes a new instance of the InactiveServerTransportClosedEvent class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Happened |
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
InactiveServerTransportClosedEvent Class
NFX.Glue.Instrumentation Namespace


InactiveServerTransportClosedEvent Constructor

InactiveServerTransportClosedEvent Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the InactiveServerTransportClosedEvent class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected InactiveServerTransportClosedEvent(
    string src
)
protected InactiveServerTransportClosedEvent(
    string src
)
Protected Sub New (
    src As String
)
Protected Sub New (
    src As String
)
protected:
InactiveServerTransportClosedEvent(
    String^ src
)
protected:
InactiveServerTransportClosedEvent(
    String^ src
)
new :
        src : string -> InactiveServerTransportClosedEvent
new :
        src : string -> InactiveServerTransportClosedEvent

Parameters

src
Type: Online System String
See Also
InactiveServerTransportClosedEvent Class
InactiveServerTransportClosedEvent Members
NFX.Glue.Instrumentation Namespace


InactiveServerTransportClosedEvent Fields

InactiveServerTransportClosedEvent Fields NFX Class Library

The InactiveServerTransportClosedEvent type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
InactiveServerTransportClosedEvent Class
NFX.Glue.Instrumentation Namespace


InactiveServerTransportClosedEvent Methods

InactiveServerTransportClosedEvent Methods NFX Class Library

The InactiveServerTransportClosedEvent type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Happened |
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
InactiveServerTransportClosedEvent Class
NFX.Glue.Instrumentation Namespace


InactiveServerTransportClosedEvent.Happened Method

InactiveServerTransportClosedEvent Happened Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Happened(
    Node node
)
public static void Happened(
    Node node
)
Public Shared Sub Happened (
    node As Node
)
Public Shared Sub Happened (
    node As Node
)
public:
static void Happened(
    Node node
)
public:
static void Happened(
    Node node
)
static member Happened :
        node : Node -> unit
static member Happened :
        node : Node -> unit

Parameters

node
Type: NFX.Glue Node
See Also
InactiveServerTransportClosedEvent Class
InactiveServerTransportClosedEvent Members
NFX.Glue.Instrumentation Namespace


InactiveServerTransportClosedEvent.MakeAggregateInstance Method

InactiveServerTransportClosedEvent MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
InactiveServerTransportClosedEvent Class
InactiveServerTransportClosedEvent Members
NFX.Glue.Instrumentation Namespace


InactiveServerTransportClosedEvent Properties

InactiveServerTransportClosedEvent Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The InactiveServerTransportClosedEvent type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
InactiveServerTransportClosedEvent Class
NFX.Glue.Instrumentation Namespace


InactiveServerTransportClosedEvent.Description Property

InactiveServerTransportClosedEvent Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
InactiveServerTransportClosedEvent Class
InactiveServerTransportClosedEvent Members
NFX.Glue.Instrumentation Namespace


ServerBytesReceived Class

ServerBytesReceived Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Glue.Instrumentation ServerGauge
NFX.Glue.Instrumentation ServerBytesReceived

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ServerBytesReceived : ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class ServerBytesReceived : ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerBytesReceived
    Inherits ServerGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerBytesReceived
    Inherits ServerGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerBytesReceived : public ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerBytesReceived : public ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type ServerBytesReceived =
    class
        inherit ServerGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ServerBytesReceived =
    class
        inherit ServerGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ServerBytesReceived Members
NFX.Glue.Instrumentation Namespace


ServerBytesReceived Members

ServerBytesReceived Members NFX Class Library

The ServerBytesReceived type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerBytesReceived | Initializes a new instance of the ServerBytesReceived class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerBytesReceived Class
NFX.Glue.Instrumentation Namespace


ServerBytesReceived Constructor

ServerBytesReceived Constructor NFX Class Library

Initializes a new instance of the ServerBytesReceived class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerBytesReceived(
    string src,
    long value
)
protected ServerBytesReceived(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
ServerBytesReceived(
    String^ src,
    long long value
)
protected:
ServerBytesReceived(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ServerBytesReceived
new :
        src : string *
        value : int64 -> ServerBytesReceived

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ServerBytesReceived Class
ServerBytesReceived Members
NFX.Glue.Instrumentation Namespace


ServerBytesReceived Fields

ServerBytesReceived Fields NFX Class Library

The ServerBytesReceived type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ServerBytesReceived Class
NFX.Glue.Instrumentation Namespace


ServerBytesReceived Methods

ServerBytesReceived Methods NFX Class Library

The ServerBytesReceived type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerBytesReceived Class
NFX.Glue.Instrumentation Namespace


ServerBytesReceived.MakeAggregateInstance Method

ServerBytesReceived MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ServerBytesReceived Class
ServerBytesReceived Members
NFX.Glue.Instrumentation Namespace


ServerBytesReceived.Record Method

ServerBytesReceived Record Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    Node node,
    long value
)
public static void Record(
    Node node,
    long value
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
public:
static void Record(
    Node node,
    long long value
)
public:
static void Record(
    Node node,
    long long value
)
static member Record :
        node : Node *
        value : int64 -> unit
static member Record :
        node : Node *
        value : int64 -> unit

Parameters

node
Type: NFX.Glue Node
value
Type: Online System Int64
See Also
ServerBytesReceived Class
ServerBytesReceived Members
NFX.Glue.Instrumentation Namespace


ServerBytesReceived Properties

ServerBytesReceived Properties NFX Class Library

The ServerBytesReceived type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerBytesReceived Class
NFX.Glue.Instrumentation Namespace


ServerBytesReceived.Description Property

ServerBytesReceived Description Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ServerBytesReceived Class
ServerBytesReceived Members
NFX.Glue.Instrumentation Namespace


ServerBytesReceived.ValueUnitName Property

ServerBytesReceived ValueUnitName Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ServerBytesReceived Class
ServerBytesReceived Members
NFX.Glue.Instrumentation Namespace


ServerBytesSent Class

ServerBytesSent Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Glue.Instrumentation ServerGauge
NFX.Glue.Instrumentation ServerBytesSent

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ServerBytesSent : ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class ServerBytesSent : ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerBytesSent
    Inherits ServerGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerBytesSent
    Inherits ServerGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerBytesSent : public ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerBytesSent : public ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type ServerBytesSent =
    class
        inherit ServerGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ServerBytesSent =
    class
        inherit ServerGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ServerBytesSent Members
NFX.Glue.Instrumentation Namespace


ServerBytesSent Members

ServerBytesSent Members NFX Class Library

The ServerBytesSent type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerBytesSent | Initializes a new instance of the ServerBytesSent class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerBytesSent Class
NFX.Glue.Instrumentation Namespace


ServerBytesSent Constructor

ServerBytesSent Constructor NFX Class Library

Initializes a new instance of the ServerBytesSent class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerBytesSent(
    string src,
    long value
)
protected ServerBytesSent(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
ServerBytesSent(
    String^ src,
    long long value
)
protected:
ServerBytesSent(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ServerBytesSent
new :
        src : string *
        value : int64 -> ServerBytesSent

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ServerBytesSent Class
ServerBytesSent Members
NFX.Glue.Instrumentation Namespace


ServerBytesSent Fields

ServerBytesSent Fields NFX Class Library

The ServerBytesSent type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ServerBytesSent Class
NFX.Glue.Instrumentation Namespace


ServerBytesSent Methods

ServerBytesSent Methods NFX Class Library

The ServerBytesSent type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerBytesSent Class
NFX.Glue.Instrumentation Namespace


ServerBytesSent.MakeAggregateInstance Method

ServerBytesSent MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ServerBytesSent Class
ServerBytesSent Members
NFX.Glue.Instrumentation Namespace


ServerBytesSent.Record Method

ServerBytesSent Record Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    Node node,
    long value
)
public static void Record(
    Node node,
    long value
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
public:
static void Record(
    Node node,
    long long value
)
public:
static void Record(
    Node node,
    long long value
)
static member Record :
        node : Node *
        value : int64 -> unit
static member Record :
        node : Node *
        value : int64 -> unit

Parameters

node
Type: NFX.Glue Node
value
Type: Online System Int64
See Also
ServerBytesSent Class
ServerBytesSent Members
NFX.Glue.Instrumentation Namespace


ServerBytesSent Properties

ServerBytesSent Properties NFX Class Library

The ServerBytesSent type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerBytesSent Class
NFX.Glue.Instrumentation Namespace


ServerBytesSent.Description Property

ServerBytesSent Description Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ServerBytesSent Class
ServerBytesSent Members
NFX.Glue.Instrumentation Namespace


ServerBytesSent.ValueUnitName Property

ServerBytesSent ValueUnitName Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ServerBytesSent Class
ServerBytesSent Members
NFX.Glue.Instrumentation Namespace


ServerDeserializationErrorEvent Class

ServerDeserializationErrorEvent Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Event
NFX.Glue.Instrumentation GlueEvent
NFX.Glue.Instrumentation ServerEvent
NFX.Glue.Instrumentation ServerTransportErrorEvent
NFX.Glue.Instrumentation ServerDeserializationErrorEvent

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ServerDeserializationErrorEvent : ServerTransportErrorEvent
[SerializableAttribute]
public class ServerDeserializationErrorEvent : ServerTransportErrorEvent
<SerializableAttribute>
Public Class ServerDeserializationErrorEvent
    Inherits ServerTransportErrorEvent
<SerializableAttribute>
Public Class ServerDeserializationErrorEvent
    Inherits ServerTransportErrorEvent
[SerializableAttribute]
public ref class ServerDeserializationErrorEvent : public ServerTransportErrorEvent
[SerializableAttribute]
public ref class ServerDeserializationErrorEvent : public ServerTransportErrorEvent
[<SerializableAttribute>]
type ServerDeserializationErrorEvent =
    class
        inherit ServerTransportErrorEvent
    end
[<SerializableAttribute>]
type ServerDeserializationErrorEvent =
    class
        inherit ServerTransportErrorEvent
    end
See Also
ServerDeserializationErrorEvent Members
NFX.Glue.Instrumentation Namespace


ServerDeserializationErrorEvent Members

ServerDeserializationErrorEvent Members NFX Class Library

The ServerDeserializationErrorEvent type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerDeserializationErrorEvent | Initializes a new instance of the ServerDeserializationErrorEvent class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Happened |
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerDeserializationErrorEvent Class
NFX.Glue.Instrumentation Namespace


ServerDeserializationErrorEvent Constructor

ServerDeserializationErrorEvent Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerDeserializationErrorEvent class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerDeserializationErrorEvent(
    string src
)
protected ServerDeserializationErrorEvent(
    string src
)
Protected Sub New (
    src As String
)
Protected Sub New (
    src As String
)
protected:
ServerDeserializationErrorEvent(
    String^ src
)
protected:
ServerDeserializationErrorEvent(
    String^ src
)
new :
        src : string -> ServerDeserializationErrorEvent
new :
        src : string -> ServerDeserializationErrorEvent

Parameters

src
Type: Online System String
See Also
ServerDeserializationErrorEvent Class
ServerDeserializationErrorEvent Members
NFX.Glue.Instrumentation Namespace


ServerDeserializationErrorEvent Fields

ServerDeserializationErrorEvent Fields NFX Class Library

The ServerDeserializationErrorEvent type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ServerDeserializationErrorEvent Class
NFX.Glue.Instrumentation Namespace


ServerDeserializationErrorEvent Methods

ServerDeserializationErrorEvent Methods NFX Class Library

The ServerDeserializationErrorEvent type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Happened |
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerDeserializationErrorEvent Class
NFX.Glue.Instrumentation Namespace


ServerDeserializationErrorEvent.Happened Method

ServerDeserializationErrorEvent Happened Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Happened(
    Node node
)
public static void Happened(
    Node node
)
Public Shared Sub Happened (
    node As Node
)
Public Shared Sub Happened (
    node As Node
)
public:
static void Happened(
    Node node
)
public:
static void Happened(
    Node node
)
static member Happened :
        node : Node -> unit
static member Happened :
        node : Node -> unit

Parameters

node
Type: NFX.Glue Node
See Also
ServerDeserializationErrorEvent Class
ServerDeserializationErrorEvent Members
NFX.Glue.Instrumentation Namespace


ServerDeserializationErrorEvent.MakeAggregateInstance Method

ServerDeserializationErrorEvent MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ServerDeserializationErrorEvent Class
ServerDeserializationErrorEvent Members
NFX.Glue.Instrumentation Namespace


ServerDeserializationErrorEvent Properties

ServerDeserializationErrorEvent Properties NFX Class Library

The ServerDeserializationErrorEvent type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerDeserializationErrorEvent Class
NFX.Glue.Instrumentation Namespace


ServerDeserializationErrorEvent.Description Property

ServerDeserializationErrorEvent Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ServerDeserializationErrorEvent Class
ServerDeserializationErrorEvent Members
NFX.Glue.Instrumentation Namespace


ServerErrors Class

ServerErrors Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Glue.Instrumentation ServerGauge
NFX.Glue.Instrumentation ServerErrors

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ServerErrors : ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IErrorInstrument, IProblemClass,
    IInstrumentClass
[SerializableAttribute]
public class ServerErrors : ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IErrorInstrument, IProblemClass,
    IInstrumentClass
<SerializableAttribute>
Public Class ServerErrors
    Inherits ServerGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IErrorInstrument,
    IProblemClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerErrors
    Inherits ServerGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IErrorInstrument,
    IProblemClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerErrors : public ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IErrorInstrument, IProblemClass,
    IInstrumentClass
[SerializableAttribute]
public ref class ServerErrors : public ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IErrorInstrument, IProblemClass,
    IInstrumentClass
[<SerializableAttribute>]
type ServerErrors =
    class
        inherit ServerGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IErrorInstrument
        interface IProblemClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ServerErrors =
    class
        inherit ServerGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IErrorInstrument
        interface IProblemClass
        interface IInstrumentClass
    end
See Also
ServerErrors Members
NFX.Glue.Instrumentation Namespace


ServerErrors Members

ServerErrors Members NFX Class Library

The ServerErrors type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerErrors | Initializes a new instance of the ServerErrors class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerErrors Class
NFX.Glue.Instrumentation Namespace


ServerErrors Constructor

ServerErrors Constructor NFX Class Library

Initializes a new instance of the ServerErrors class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerErrors(
    string src,
    long value
)
protected ServerErrors(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
ServerErrors(
    String^ src,
    long long value
)
protected:
ServerErrors(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ServerErrors
new :
        src : string *
        value : int64 -> ServerErrors

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ServerErrors Class
ServerErrors Members
NFX.Glue.Instrumentation Namespace


ServerErrors Fields

ServerErrors Fields NFX Class Library

The ServerErrors type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ServerErrors Class
NFX.Glue.Instrumentation Namespace


ServerErrors Methods

ServerErrors Methods NFX Class Library

The ServerErrors type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerErrors Class
NFX.Glue.Instrumentation Namespace


ServerErrors.MakeAggregateInstance Method

ServerErrors MakeAggregateInstance Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ServerErrors Class
ServerErrors Members
NFX.Glue.Instrumentation Namespace


ServerErrors.Record Method

ServerErrors Record Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    Node node,
    long value
)
public static void Record(
    Node node,
    long value
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
public:
static void Record(
    Node node,
    long long value
)
public:
static void Record(
    Node node,
    long long value
)
static member Record :
        node : Node *
        value : int64 -> unit
static member Record :
        node : Node *
        value : int64 -> unit

Parameters

node
Type: NFX.Glue Node
value
Type: Online System Int64
See Also
ServerErrors Class
ServerErrors Members
NFX.Glue.Instrumentation Namespace


ServerErrors Properties

ServerErrors Properties NFX Class Library

The ServerErrors type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerErrors Class
NFX.Glue.Instrumentation Namespace


ServerErrors.Description Property

ServerErrors Description Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ServerErrors Class
ServerErrors Members
NFX.Glue.Instrumentation Namespace


ServerErrors.ValueUnitName Property

ServerErrors ValueUnitName Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ServerErrors Class
ServerErrors Members
NFX.Glue.Instrumentation Namespace


ServerEvent Class

ServerEvent Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Event
NFX.Glue.Instrumentation GlueEvent
NFX.Glue.Instrumentation ServerEvent
NFX.Glue.Instrumentation ClientConnectedEvent
NFX.Glue.Instrumentation ClientDisconnectedEvent
NFX.Glue.Instrumentation InactiveServerTransportClosedEvent
NFX.Glue.Instrumentation ServerTransportErrorEvent

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class ServerEvent : GlueEvent
[SerializableAttribute]
public abstract class ServerEvent : GlueEvent
<SerializableAttribute>
Public MustInherit Class ServerEvent
    Inherits GlueEvent
<SerializableAttribute>
Public MustInherit Class ServerEvent
    Inherits GlueEvent
[SerializableAttribute]
public ref class ServerEvent abstract : public GlueEvent
[SerializableAttribute]
public ref class ServerEvent abstract : public GlueEvent
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ServerEvent =
    class
        inherit GlueEvent
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ServerEvent =
    class
        inherit GlueEvent
    end
See Also
ServerEvent Members
NFX.Glue.Instrumentation Namespace


ServerEvent Members

ServerEvent Members NFX Class Library

The ServerEvent type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerEvent | Initializes a new instance of the ServerEvent class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerEvent Class
NFX.Glue.Instrumentation Namespace


ServerEvent Constructor

ServerEvent Constructor NFX Class Library

Initializes a new instance of the ServerEvent class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerEvent(
    string src
)
protected ServerEvent(
    string src
)
Protected Sub New (
    src As String
)
Protected Sub New (
    src As String
)
protected:
ServerEvent(
    String^ src
)
protected:
ServerEvent(
    String^ src
)
new :
        src : string -> ServerEvent
new :
        src : string -> ServerEvent

Parameters

src
Type: Online System String
See Also
ServerEvent Class
ServerEvent Members
NFX.Glue.Instrumentation Namespace


ServerEvent Fields

ServerEvent Fields NFX Class Library

The ServerEvent type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ServerEvent Class
NFX.Glue.Instrumentation Namespace


ServerEvent Methods

ServerEvent Methods NFX Class Library

The ServerEvent type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerEvent Class
NFX.Glue.Instrumentation Namespace


ServerEvent Properties

ServerEvent Properties NFX Class Library

The ServerEvent type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerEvent Class
NFX.Glue.Instrumentation Namespace


ServerGauge Class

ServerGauge Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Glue.Instrumentation ServerGauge
NFX.Glue.Instrumentation ServerBytesReceived
NFX.Glue.Instrumentation ServerBytesSent
NFX.Glue.Instrumentation ServerErrors
NFX.Glue.Instrumentation ServerMsgReceived
NFX.Glue.Instrumentation ServerMsgSent
NFX.Glue.Instrumentation ServerTotalBytesReceived
NFX.Glue.Instrumentation ServerTotalBytesSent
NFX.Glue.Instrumentation ServerTotalErrors
NFX.Glue.Instrumentation ServerTotalMsgReceived
NFX.Glue.Instrumentation ServerTotalMsgSent
NFX.Glue.Instrumentation ServerTransportChannelCount
NFX.Glue.Instrumentation ServerTransportCount

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class ServerGauge : GlueLongGauge
[SerializableAttribute]
public abstract class ServerGauge : GlueLongGauge
<SerializableAttribute>
Public MustInherit Class ServerGauge
    Inherits GlueLongGauge
<SerializableAttribute>
Public MustInherit Class ServerGauge
    Inherits GlueLongGauge
[SerializableAttribute]
public ref class ServerGauge abstract : public GlueLongGauge
[SerializableAttribute]
public ref class ServerGauge abstract : public GlueLongGauge
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ServerGauge =
    class
        inherit GlueLongGauge
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ServerGauge =
    class
        inherit GlueLongGauge
    end
See Also
ServerGauge Members
NFX.Glue.Instrumentation Namespace


ServerGauge Members

ServerGauge Members NFX Class Library

The ServerGauge type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerGauge | Initializes a new instance of the ServerGauge class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Inherited from LongGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerGauge Class
NFX.Glue.Instrumentation Namespace


ServerGauge Constructor

ServerGauge Constructor NFX Class Library

Initializes a new instance of the ServerGauge class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerGauge(
    string src,
    long value
)
protected ServerGauge(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
ServerGauge(
    String^ src,
    long long value
)
protected:
ServerGauge(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ServerGauge
new :
        src : string *
        value : int64 -> ServerGauge

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ServerGauge Class
ServerGauge Members
NFX.Glue.Instrumentation Namespace


ServerGauge Fields

ServerGauge Fields NFX Class Library

The ServerGauge type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ServerGauge Class
NFX.Glue.Instrumentation Namespace


ServerGauge Methods

ServerGauge Methods NFX Class Library

The ServerGauge type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerGauge Class
NFX.Glue.Instrumentation Namespace


ServerGauge Properties

ServerGauge Properties NFX Class Library

The ServerGauge type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Inherited from LongGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerGauge Class
NFX.Glue.Instrumentation Namespace


ServerGotOverMaxMsgSizeErrorEvent Class

ServerGotOverMaxMsgSizeErrorEvent Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Event
NFX.Glue.Instrumentation GlueEvent
NFX.Glue.Instrumentation ServerEvent
NFX.Glue.Instrumentation ServerTransportErrorEvent
NFX.Glue.Instrumentation ServerGotOverMaxMsgSizeErrorEvent

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ServerGotOverMaxMsgSizeErrorEvent : ServerTransportErrorEvent
[SerializableAttribute]
public class ServerGotOverMaxMsgSizeErrorEvent : ServerTransportErrorEvent
<SerializableAttribute>
Public Class ServerGotOverMaxMsgSizeErrorEvent
    Inherits ServerTransportErrorEvent
<SerializableAttribute>
Public Class ServerGotOverMaxMsgSizeErrorEvent
    Inherits ServerTransportErrorEvent
[SerializableAttribute]
public ref class ServerGotOverMaxMsgSizeErrorEvent : public ServerTransportErrorEvent
[SerializableAttribute]
public ref class ServerGotOverMaxMsgSizeErrorEvent : public ServerTransportErrorEvent
[<SerializableAttribute>]
type ServerGotOverMaxMsgSizeErrorEvent =
    class
        inherit ServerTransportErrorEvent
    end
[<SerializableAttribute>]
type ServerGotOverMaxMsgSizeErrorEvent =
    class
        inherit ServerTransportErrorEvent
    end
See Also
ServerGotOverMaxMsgSizeErrorEvent Members
NFX.Glue.Instrumentation Namespace


ServerGotOverMaxMsgSizeErrorEvent Members

ServerGotOverMaxMsgSizeErrorEvent Members NFX Class Library

The ServerGotOverMaxMsgSizeErrorEvent type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerGotOverMaxMsgSizeErrorEvent | Initializes a new instance of the ServerGotOverMaxMsgSizeErrorEvent class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Happened |
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerGotOverMaxMsgSizeErrorEvent Class
NFX.Glue.Instrumentation Namespace


ServerGotOverMaxMsgSizeErrorEvent Constructor

ServerGotOverMaxMsgSizeErrorEvent Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerGotOverMaxMsgSizeErrorEvent class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerGotOverMaxMsgSizeErrorEvent(
    string src
)
protected ServerGotOverMaxMsgSizeErrorEvent(
    string src
)
Protected Sub New (
    src As String
)
Protected Sub New (
    src As String
)
protected:
ServerGotOverMaxMsgSizeErrorEvent(
    String^ src
)
protected:
ServerGotOverMaxMsgSizeErrorEvent(
    String^ src
)
new :
        src : string -> ServerGotOverMaxMsgSizeErrorEvent
new :
        src : string -> ServerGotOverMaxMsgSizeErrorEvent

Parameters

src
Type: Online System String
See Also
ServerGotOverMaxMsgSizeErrorEvent Class
ServerGotOverMaxMsgSizeErrorEvent Members
NFX.Glue.Instrumentation Namespace


ServerGotOverMaxMsgSizeErrorEvent Fields

ServerGotOverMaxMsgSizeErrorEvent Fields NFX Class Library

The ServerGotOverMaxMsgSizeErrorEvent type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ServerGotOverMaxMsgSizeErrorEvent Class
NFX.Glue.Instrumentation Namespace


ServerGotOverMaxMsgSizeErrorEvent Methods

ServerGotOverMaxMsgSizeErrorEvent Methods NFX Class Library

The ServerGotOverMaxMsgSizeErrorEvent type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Happened |
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerGotOverMaxMsgSizeErrorEvent Class
NFX.Glue.Instrumentation Namespace


ServerGotOverMaxMsgSizeErrorEvent.Happened Method

ServerGotOverMaxMsgSizeErrorEvent Happened Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Happened(
    Node node
)
public static void Happened(
    Node node
)
Public Shared Sub Happened (
    node As Node
)
Public Shared Sub Happened (
    node As Node
)
public:
static void Happened(
    Node node
)
public:
static void Happened(
    Node node
)
static member Happened :
        node : Node -> unit
static member Happened :
        node : Node -> unit

Parameters

node
Type: NFX.Glue Node
See Also
ServerGotOverMaxMsgSizeErrorEvent Class
ServerGotOverMaxMsgSizeErrorEvent Members
NFX.Glue.Instrumentation Namespace


ServerGotOverMaxMsgSizeErrorEvent.MakeAggregateInstance Method

ServerGotOverMaxMsgSizeErrorEvent MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ServerGotOverMaxMsgSizeErrorEvent Class
ServerGotOverMaxMsgSizeErrorEvent Members
NFX.Glue.Instrumentation Namespace


ServerGotOverMaxMsgSizeErrorEvent Properties

ServerGotOverMaxMsgSizeErrorEvent Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The ServerGotOverMaxMsgSizeErrorEvent type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerGotOverMaxMsgSizeErrorEvent Class
NFX.Glue.Instrumentation Namespace


ServerGotOverMaxMsgSizeErrorEvent.Description Property

ServerGotOverMaxMsgSizeErrorEvent Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ServerGotOverMaxMsgSizeErrorEvent Class
ServerGotOverMaxMsgSizeErrorEvent Members
NFX.Glue.Instrumentation Namespace


ServerListenerErrorEvent Class

ServerListenerErrorEvent Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Event
NFX.Glue.Instrumentation GlueEvent
NFX.Glue.Instrumentation ServerEvent
NFX.Glue.Instrumentation ServerTransportErrorEvent
NFX.Glue.Instrumentation ServerListenerErrorEvent

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ServerListenerErrorEvent : ServerTransportErrorEvent
[SerializableAttribute]
public class ServerListenerErrorEvent : ServerTransportErrorEvent
<SerializableAttribute>
Public Class ServerListenerErrorEvent
    Inherits ServerTransportErrorEvent
<SerializableAttribute>
Public Class ServerListenerErrorEvent
    Inherits ServerTransportErrorEvent
[SerializableAttribute]
public ref class ServerListenerErrorEvent : public ServerTransportErrorEvent
[SerializableAttribute]
public ref class ServerListenerErrorEvent : public ServerTransportErrorEvent
[<SerializableAttribute>]
type ServerListenerErrorEvent =
    class
        inherit ServerTransportErrorEvent
    end
[<SerializableAttribute>]
type ServerListenerErrorEvent =
    class
        inherit ServerTransportErrorEvent
    end
See Also
ServerListenerErrorEvent Members
NFX.Glue.Instrumentation Namespace


ServerListenerErrorEvent Members

ServerListenerErrorEvent Members NFX Class Library

The ServerListenerErrorEvent type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerListenerErrorEvent | Initializes a new instance of the ServerListenerErrorEvent class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Happened |
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerListenerErrorEvent Class
NFX.Glue.Instrumentation Namespace


ServerListenerErrorEvent Constructor

ServerListenerErrorEvent Constructor NFX Class Library

Initializes a new instance of the ServerListenerErrorEvent class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerListenerErrorEvent(
    string src
)
protected ServerListenerErrorEvent(
    string src
)
Protected Sub New (
    src As String
)
Protected Sub New (
    src As String
)
protected:
ServerListenerErrorEvent(
    String^ src
)
protected:
ServerListenerErrorEvent(
    String^ src
)
new :
        src : string -> ServerListenerErrorEvent
new :
        src : string -> ServerListenerErrorEvent

Parameters

src
Type: Online System String
See Also
ServerListenerErrorEvent Class
ServerListenerErrorEvent Members
NFX.Glue.Instrumentation Namespace


ServerListenerErrorEvent Fields

ServerListenerErrorEvent Fields NFX Class Library

The ServerListenerErrorEvent type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ServerListenerErrorEvent Class
NFX.Glue.Instrumentation Namespace


ServerListenerErrorEvent Methods

ServerListenerErrorEvent Methods NFX Class Library

The ServerListenerErrorEvent type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Happened |
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerListenerErrorEvent Class
NFX.Glue.Instrumentation Namespace


ServerListenerErrorEvent.Happened Method

ServerListenerErrorEvent Happened Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Happened(
    Node node
)
public static void Happened(
    Node node
)
Public Shared Sub Happened (
    node As Node
)
Public Shared Sub Happened (
    node As Node
)
public:
static void Happened(
    Node node
)
public:
static void Happened(
    Node node
)
static member Happened :
        node : Node -> unit
static member Happened :
        node : Node -> unit

Parameters

node
Type: NFX.Glue Node
See Also
ServerListenerErrorEvent Class
ServerListenerErrorEvent Members
NFX.Glue.Instrumentation Namespace


ServerListenerErrorEvent.MakeAggregateInstance Method

ServerListenerErrorEvent MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ServerListenerErrorEvent Class
ServerListenerErrorEvent Members
NFX.Glue.Instrumentation Namespace


ServerListenerErrorEvent Properties

ServerListenerErrorEvent Properties NFX Class Library

The ServerListenerErrorEvent type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerListenerErrorEvent Class
NFX.Glue.Instrumentation Namespace


ServerListenerErrorEvent.Description Property

ServerListenerErrorEvent Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ServerListenerErrorEvent Class
ServerListenerErrorEvent Members
NFX.Glue.Instrumentation Namespace


ServerMsgReceived Class

ServerMsgReceived Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Glue.Instrumentation ServerGauge
NFX.Glue.Instrumentation ServerMsgReceived

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ServerMsgReceived : ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class ServerMsgReceived : ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerMsgReceived
    Inherits ServerGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerMsgReceived
    Inherits ServerGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerMsgReceived : public ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerMsgReceived : public ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type ServerMsgReceived =
    class
        inherit ServerGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ServerMsgReceived =
    class
        inherit ServerGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ServerMsgReceived Members
NFX.Glue.Instrumentation Namespace


ServerMsgReceived Members

ServerMsgReceived Members NFX Class Library

The ServerMsgReceived type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerMsgReceived | Initializes a new instance of the ServerMsgReceived class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerMsgReceived Class
NFX.Glue.Instrumentation Namespace


ServerMsgReceived Constructor

ServerMsgReceived Constructor NFX Class Library

Initializes a new instance of the ServerMsgReceived class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerMsgReceived(
    string src,
    long value
)
protected ServerMsgReceived(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
ServerMsgReceived(
    String^ src,
    long long value
)
protected:
ServerMsgReceived(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ServerMsgReceived
new :
        src : string *
        value : int64 -> ServerMsgReceived

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ServerMsgReceived Class
ServerMsgReceived Members
NFX.Glue.Instrumentation Namespace


ServerMsgReceived Fields

ServerMsgReceived Fields NFX Class Library

The ServerMsgReceived type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ServerMsgReceived Class
NFX.Glue.Instrumentation Namespace


ServerMsgReceived Methods

ServerMsgReceived Methods NFX Class Library

The ServerMsgReceived type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerMsgReceived Class
NFX.Glue.Instrumentation Namespace


ServerMsgReceived.MakeAggregateInstance Method

ServerMsgReceived MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ServerMsgReceived Class
ServerMsgReceived Members
NFX.Glue.Instrumentation Namespace


ServerMsgReceived.Record Method

ServerMsgReceived Record Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    Node node,
    long value
)
public static void Record(
    Node node,
    long value
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
public:
static void Record(
    Node node,
    long long value
)
public:
static void Record(
    Node node,
    long long value
)
static member Record :
        node : Node *
        value : int64 -> unit
static member Record :
        node : Node *
        value : int64 -> unit

Parameters

node
Type: NFX.Glue Node
value
Type: Online System Int64
See Also
ServerMsgReceived Class
ServerMsgReceived Members
NFX.Glue.Instrumentation Namespace


ServerMsgReceived Properties

ServerMsgReceived Properties NFX Class Library

The ServerMsgReceived type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerMsgReceived Class
NFX.Glue.Instrumentation Namespace


ServerMsgReceived.Description Property

ServerMsgReceived Description Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ServerMsgReceived Class
ServerMsgReceived Members
NFX.Glue.Instrumentation Namespace


ServerMsgReceived.ValueUnitName Property

ServerMsgReceived ValueUnitName Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ServerMsgReceived Class
ServerMsgReceived Members
NFX.Glue.Instrumentation Namespace


ServerMsgSent Class

ServerMsgSent Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Glue.Instrumentation ServerGauge
NFX.Glue.Instrumentation ServerMsgSent

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ServerMsgSent : ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class ServerMsgSent : ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerMsgSent
    Inherits ServerGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerMsgSent
    Inherits ServerGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerMsgSent : public ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerMsgSent : public ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type ServerMsgSent =
    class
        inherit ServerGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ServerMsgSent =
    class
        inherit ServerGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ServerMsgSent Members
NFX.Glue.Instrumentation Namespace


ServerMsgSent Members

ServerMsgSent Members NFX Class Library

The ServerMsgSent type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerMsgSent | Initializes a new instance of the ServerMsgSent class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerMsgSent Class
NFX.Glue.Instrumentation Namespace


ServerMsgSent Constructor

ServerMsgSent Constructor NFX Class Library

Initializes a new instance of the ServerMsgSent class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerMsgSent(
    string src,
    long value
)
protected ServerMsgSent(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
ServerMsgSent(
    String^ src,
    long long value
)
protected:
ServerMsgSent(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ServerMsgSent
new :
        src : string *
        value : int64 -> ServerMsgSent

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ServerMsgSent Class
ServerMsgSent Members
NFX.Glue.Instrumentation Namespace


ServerMsgSent Fields

ServerMsgSent Fields NFX Class Library

The ServerMsgSent type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ServerMsgSent Class
NFX.Glue.Instrumentation Namespace


ServerMsgSent Methods

ServerMsgSent Methods NFX Class Library

The ServerMsgSent type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerMsgSent Class
NFX.Glue.Instrumentation Namespace


ServerMsgSent.MakeAggregateInstance Method

ServerMsgSent MakeAggregateInstance Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ServerMsgSent Class
ServerMsgSent Members
NFX.Glue.Instrumentation Namespace


ServerMsgSent.Record Method

ServerMsgSent Record Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    Node node,
    long value
)
public static void Record(
    Node node,
    long value
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
public:
static void Record(
    Node node,
    long long value
)
public:
static void Record(
    Node node,
    long long value
)
static member Record :
        node : Node *
        value : int64 -> unit
static member Record :
        node : Node *
        value : int64 -> unit

Parameters

node
Type: NFX.Glue Node
value
Type: Online System Int64
See Also
ServerMsgSent Class
ServerMsgSent Members
NFX.Glue.Instrumentation Namespace


ServerMsgSent Properties

ServerMsgSent Properties NFX Class Library

The ServerMsgSent type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerMsgSent Class
NFX.Glue.Instrumentation Namespace


ServerMsgSent.Description Property

ServerMsgSent Description Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ServerMsgSent Class
ServerMsgSent Members
NFX.Glue.Instrumentation Namespace


ServerMsgSent.ValueUnitName Property

ServerMsgSent ValueUnitName Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ServerMsgSent Class
ServerMsgSent Members
NFX.Glue.Instrumentation Namespace


ServerSerializedOverMaxMsgSizeErrorEvent Class

ServerSerializedOverMaxMsgSizeErrorEvent Class NFX Class Library

[This is preliminary documentation and is subject to change.]

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Event
NFX.Glue.Instrumentation GlueEvent
NFX.Glue.Instrumentation ServerEvent
NFX.Glue.Instrumentation ServerTransportErrorEvent
NFX.Glue.Instrumentation ServerSerializedOverMaxMsgSizeErrorEvent

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ServerSerializedOverMaxMsgSizeErrorEvent : ServerTransportErrorEvent
[SerializableAttribute]
public class ServerSerializedOverMaxMsgSizeErrorEvent : ServerTransportErrorEvent
<SerializableAttribute>
Public Class ServerSerializedOverMaxMsgSizeErrorEvent
    Inherits ServerTransportErrorEvent
<SerializableAttribute>
Public Class ServerSerializedOverMaxMsgSizeErrorEvent
    Inherits ServerTransportErrorEvent
[SerializableAttribute]
public ref class ServerSerializedOverMaxMsgSizeErrorEvent : public ServerTransportErrorEvent
[SerializableAttribute]
public ref class ServerSerializedOverMaxMsgSizeErrorEvent : public ServerTransportErrorEvent
[<SerializableAttribute>]
type ServerSerializedOverMaxMsgSizeErrorEvent =
    class
        inherit ServerTransportErrorEvent
    end
[<SerializableAttribute>]
type ServerSerializedOverMaxMsgSizeErrorEvent =
    class
        inherit ServerTransportErrorEvent
    end
See Also
ServerSerializedOverMaxMsgSizeErrorEvent Members
NFX.Glue.Instrumentation Namespace


ServerSerializedOverMaxMsgSizeErrorEvent Members

ServerSerializedOverMaxMsgSizeErrorEvent Members NFX Class Library

[This is preliminary documentation and is subject to change.]

The ServerSerializedOverMaxMsgSizeErrorEvent type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerSerializedOverMaxMsgSizeErrorEvent | Initializes a new instance of the ServerSerializedOverMaxMsgSizeErrorEvent class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Happened |
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerSerializedOverMaxMsgSizeErrorEvent Class
NFX.Glue.Instrumentation Namespace


ServerSerializedOverMaxMsgSizeErrorEvent Constructor

ServerSerializedOverMaxMsgSizeErrorEvent Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerSerializedOverMaxMsgSizeErrorEvent class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerSerializedOverMaxMsgSizeErrorEvent(
    string src
)
protected ServerSerializedOverMaxMsgSizeErrorEvent(
    string src
)
Protected Sub New (
    src As String
)
Protected Sub New (
    src As String
)
protected:
ServerSerializedOverMaxMsgSizeErrorEvent(
    String^ src
)
protected:
ServerSerializedOverMaxMsgSizeErrorEvent(
    String^ src
)
new :
        src : string -> ServerSerializedOverMaxMsgSizeErrorEvent
new :
        src : string -> ServerSerializedOverMaxMsgSizeErrorEvent

Parameters

src
Type: Online System String
See Also
ServerSerializedOverMaxMsgSizeErrorEvent Class
ServerSerializedOverMaxMsgSizeErrorEvent Members
NFX.Glue.Instrumentation Namespace


ServerSerializedOverMaxMsgSizeErrorEvent Fields

ServerSerializedOverMaxMsgSizeErrorEvent Fields NFX Class Library

[This is preliminary documentation and is subject to change.]

The ServerSerializedOverMaxMsgSizeErrorEvent type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ServerSerializedOverMaxMsgSizeErrorEvent Class
NFX.Glue.Instrumentation Namespace


ServerSerializedOverMaxMsgSizeErrorEvent Methods

ServerSerializedOverMaxMsgSizeErrorEvent Methods NFX Class Library

[This is preliminary documentation and is subject to change.]

The ServerSerializedOverMaxMsgSizeErrorEvent type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Happened |
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerSerializedOverMaxMsgSizeErrorEvent Class
NFX.Glue.Instrumentation Namespace


ServerSerializedOverMaxMsgSizeErrorEvent.Happened Method

ServerSerializedOverMaxMsgSizeErrorEvent Happened Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Happened(
    Node node
)
public static void Happened(
    Node node
)
Public Shared Sub Happened (
    node As Node
)
Public Shared Sub Happened (
    node As Node
)
public:
static void Happened(
    Node node
)
public:
static void Happened(
    Node node
)
static member Happened :
        node : Node -> unit
static member Happened :
        node : Node -> unit

Parameters

node
Type: NFX.Glue Node
See Also
ServerSerializedOverMaxMsgSizeErrorEvent Class
ServerSerializedOverMaxMsgSizeErrorEvent Members
NFX.Glue.Instrumentation Namespace


ServerSerializedOverMaxMsgSizeErrorEvent.MakeAggregateInstance Method

ServerSerializedOverMaxMsgSizeErrorEvent MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ServerSerializedOverMaxMsgSizeErrorEvent Class
ServerSerializedOverMaxMsgSizeErrorEvent Members
NFX.Glue.Instrumentation Namespace


ServerSerializedOverMaxMsgSizeErrorEvent Properties

ServerSerializedOverMaxMsgSizeErrorEvent Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The ServerSerializedOverMaxMsgSizeErrorEvent type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerSerializedOverMaxMsgSizeErrorEvent Class
NFX.Glue.Instrumentation Namespace


ServerSerializedOverMaxMsgSizeErrorEvent.Description Property

ServerSerializedOverMaxMsgSizeErrorEvent Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ServerSerializedOverMaxMsgSizeErrorEvent Class
ServerSerializedOverMaxMsgSizeErrorEvent Members
NFX.Glue.Instrumentation Namespace


ServerTotalBytesReceived Class

ServerTotalBytesReceived Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Glue.Instrumentation ServerGauge
NFX.Glue.Instrumentation ServerTotalBytesReceived

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ServerTotalBytesReceived : ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class ServerTotalBytesReceived : ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerTotalBytesReceived
    Inherits ServerGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerTotalBytesReceived
    Inherits ServerGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerTotalBytesReceived : public ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerTotalBytesReceived : public ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type ServerTotalBytesReceived =
    class
        inherit ServerGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ServerTotalBytesReceived =
    class
        inherit ServerGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ServerTotalBytesReceived Members
NFX.Glue.Instrumentation Namespace


ServerTotalBytesReceived Members

ServerTotalBytesReceived Members NFX Class Library

The ServerTotalBytesReceived type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerTotalBytesReceived | Initializes a new instance of the ServerTotalBytesReceived class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerTotalBytesReceived Class
NFX.Glue.Instrumentation Namespace


ServerTotalBytesReceived Constructor

ServerTotalBytesReceived Constructor NFX Class Library

Initializes a new instance of the ServerTotalBytesReceived class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerTotalBytesReceived(
    string src,
    long value
)
protected ServerTotalBytesReceived(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
ServerTotalBytesReceived(
    String^ src,
    long long value
)
protected:
ServerTotalBytesReceived(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ServerTotalBytesReceived
new :
        src : string *
        value : int64 -> ServerTotalBytesReceived

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ServerTotalBytesReceived Class
ServerTotalBytesReceived Members
NFX.Glue.Instrumentation Namespace


ServerTotalBytesReceived Fields

ServerTotalBytesReceived Fields NFX Class Library

The ServerTotalBytesReceived type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ServerTotalBytesReceived Class
NFX.Glue.Instrumentation Namespace


ServerTotalBytesReceived Methods

ServerTotalBytesReceived Methods NFX Class Library

The ServerTotalBytesReceived type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerTotalBytesReceived Class
NFX.Glue.Instrumentation Namespace


ServerTotalBytesReceived.MakeAggregateInstance Method

ServerTotalBytesReceived MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ServerTotalBytesReceived Class
ServerTotalBytesReceived Members
NFX.Glue.Instrumentation Namespace


ServerTotalBytesReceived.Record Method

ServerTotalBytesReceived Record Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    Node node,
    long value
)
public static void Record(
    Node node,
    long value
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
public:
static void Record(
    Node node,
    long long value
)
public:
static void Record(
    Node node,
    long long value
)
static member Record :
        node : Node *
        value : int64 -> unit
static member Record :
        node : Node *
        value : int64 -> unit

Parameters

node
Type: NFX.Glue Node
value
Type: Online System Int64
See Also
ServerTotalBytesReceived Class
ServerTotalBytesReceived Members
NFX.Glue.Instrumentation Namespace


ServerTotalBytesReceived Properties

ServerTotalBytesReceived Properties NFX Class Library

The ServerTotalBytesReceived type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerTotalBytesReceived Class
NFX.Glue.Instrumentation Namespace


ServerTotalBytesReceived.Description Property

ServerTotalBytesReceived Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ServerTotalBytesReceived Class
ServerTotalBytesReceived Members
NFX.Glue.Instrumentation Namespace


ServerTotalBytesReceived.ValueUnitName Property

ServerTotalBytesReceived ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ServerTotalBytesReceived Class
ServerTotalBytesReceived Members
NFX.Glue.Instrumentation Namespace


ServerTotalBytesSent Class

ServerTotalBytesSent Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Glue.Instrumentation ServerGauge
NFX.Glue.Instrumentation ServerTotalBytesSent

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ServerTotalBytesSent : ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class ServerTotalBytesSent : ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerTotalBytesSent
    Inherits ServerGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerTotalBytesSent
    Inherits ServerGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerTotalBytesSent : public ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerTotalBytesSent : public ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type ServerTotalBytesSent =
    class
        inherit ServerGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ServerTotalBytesSent =
    class
        inherit ServerGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ServerTotalBytesSent Members
NFX.Glue.Instrumentation Namespace


ServerTotalBytesSent Members

ServerTotalBytesSent Members NFX Class Library

The ServerTotalBytesSent type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerTotalBytesSent | Initializes a new instance of the ServerTotalBytesSent class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerTotalBytesSent Class
NFX.Glue.Instrumentation Namespace


ServerTotalBytesSent Constructor

ServerTotalBytesSent Constructor NFX Class Library

Initializes a new instance of the ServerTotalBytesSent class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerTotalBytesSent(
    string src,
    long value
)
protected ServerTotalBytesSent(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
ServerTotalBytesSent(
    String^ src,
    long long value
)
protected:
ServerTotalBytesSent(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ServerTotalBytesSent
new :
        src : string *
        value : int64 -> ServerTotalBytesSent

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ServerTotalBytesSent Class
ServerTotalBytesSent Members
NFX.Glue.Instrumentation Namespace


ServerTotalBytesSent Fields

ServerTotalBytesSent Fields NFX Class Library

The ServerTotalBytesSent type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ServerTotalBytesSent Class
NFX.Glue.Instrumentation Namespace


ServerTotalBytesSent Methods

ServerTotalBytesSent Methods NFX Class Library

The ServerTotalBytesSent type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerTotalBytesSent Class
NFX.Glue.Instrumentation Namespace


ServerTotalBytesSent.MakeAggregateInstance Method

ServerTotalBytesSent MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ServerTotalBytesSent Class
ServerTotalBytesSent Members
NFX.Glue.Instrumentation Namespace


ServerTotalBytesSent.Record Method

ServerTotalBytesSent Record Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    Node node,
    long value
)
public static void Record(
    Node node,
    long value
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
public:
static void Record(
    Node node,
    long long value
)
public:
static void Record(
    Node node,
    long long value
)
static member Record :
        node : Node *
        value : int64 -> unit
static member Record :
        node : Node *
        value : int64 -> unit

Parameters

node
Type: NFX.Glue Node
value
Type: Online System Int64
See Also
ServerTotalBytesSent Class
ServerTotalBytesSent Members
NFX.Glue.Instrumentation Namespace


ServerTotalBytesSent Properties

ServerTotalBytesSent Properties NFX Class Library

The ServerTotalBytesSent type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerTotalBytesSent Class
NFX.Glue.Instrumentation Namespace


ServerTotalBytesSent.Description Property

ServerTotalBytesSent Description Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ServerTotalBytesSent Class
ServerTotalBytesSent Members
NFX.Glue.Instrumentation Namespace


ServerTotalBytesSent.ValueUnitName Property

ServerTotalBytesSent ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ServerTotalBytesSent Class
ServerTotalBytesSent Members
NFX.Glue.Instrumentation Namespace


ServerTotalErrors Class

ServerTotalErrors Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Glue.Instrumentation ServerGauge
NFX.Glue.Instrumentation ServerTotalErrors

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ServerTotalErrors : ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IErrorInstrument, IProblemClass,
    IInstrumentClass
[SerializableAttribute]
public class ServerTotalErrors : ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IErrorInstrument, IProblemClass,
    IInstrumentClass
<SerializableAttribute>
Public Class ServerTotalErrors
    Inherits ServerGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IErrorInstrument,
    IProblemClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerTotalErrors
    Inherits ServerGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IErrorInstrument,
    IProblemClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerTotalErrors : public ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IErrorInstrument, IProblemClass,
    IInstrumentClass
[SerializableAttribute]
public ref class ServerTotalErrors : public ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IErrorInstrument, IProblemClass,
    IInstrumentClass
[<SerializableAttribute>]
type ServerTotalErrors =
    class
        inherit ServerGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IErrorInstrument
        interface IProblemClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ServerTotalErrors =
    class
        inherit ServerGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IErrorInstrument
        interface IProblemClass
        interface IInstrumentClass
    end
See Also
ServerTotalErrors Members
NFX.Glue.Instrumentation Namespace


ServerTotalErrors Members

ServerTotalErrors Members NFX Class Library

The ServerTotalErrors type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerTotalErrors | Initializes a new instance of the ServerTotalErrors class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerTotalErrors Class
NFX.Glue.Instrumentation Namespace


ServerTotalErrors Constructor

ServerTotalErrors Constructor NFX Class Library

Initializes a new instance of the ServerTotalErrors class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerTotalErrors(
    string src,
    long value
)
protected ServerTotalErrors(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
ServerTotalErrors(
    String^ src,
    long long value
)
protected:
ServerTotalErrors(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ServerTotalErrors
new :
        src : string *
        value : int64 -> ServerTotalErrors

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ServerTotalErrors Class
ServerTotalErrors Members
NFX.Glue.Instrumentation Namespace


ServerTotalErrors Fields

ServerTotalErrors Fields NFX Class Library

The ServerTotalErrors type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ServerTotalErrors Class
NFX.Glue.Instrumentation Namespace


ServerTotalErrors Methods

ServerTotalErrors Methods NFX Class Library

The ServerTotalErrors type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerTotalErrors Class
NFX.Glue.Instrumentation Namespace


ServerTotalErrors.MakeAggregateInstance Method

ServerTotalErrors MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ServerTotalErrors Class
ServerTotalErrors Members
NFX.Glue.Instrumentation Namespace


ServerTotalErrors.Record Method

ServerTotalErrors Record Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    Node node,
    long value
)
public static void Record(
    Node node,
    long value
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
public:
static void Record(
    Node node,
    long long value
)
public:
static void Record(
    Node node,
    long long value
)
static member Record :
        node : Node *
        value : int64 -> unit
static member Record :
        node : Node *
        value : int64 -> unit

Parameters

node
Type: NFX.Glue Node
value
Type: Online System Int64
See Also
ServerTotalErrors Class
ServerTotalErrors Members
NFX.Glue.Instrumentation Namespace


ServerTotalErrors Properties

ServerTotalErrors Properties NFX Class Library

The ServerTotalErrors type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerTotalErrors Class
NFX.Glue.Instrumentation Namespace


ServerTotalErrors.Description Property

ServerTotalErrors Description Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ServerTotalErrors Class
ServerTotalErrors Members
NFX.Glue.Instrumentation Namespace


ServerTotalErrors.ValueUnitName Property

ServerTotalErrors ValueUnitName Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ServerTotalErrors Class
ServerTotalErrors Members
NFX.Glue.Instrumentation Namespace


ServerTotalMsgReceived Class

ServerTotalMsgReceived Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Glue.Instrumentation ServerGauge
NFX.Glue.Instrumentation ServerTotalMsgReceived

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ServerTotalMsgReceived : ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class ServerTotalMsgReceived : ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerTotalMsgReceived
    Inherits ServerGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerTotalMsgReceived
    Inherits ServerGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerTotalMsgReceived : public ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerTotalMsgReceived : public ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type ServerTotalMsgReceived =
    class
        inherit ServerGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ServerTotalMsgReceived =
    class
        inherit ServerGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ServerTotalMsgReceived Members
NFX.Glue.Instrumentation Namespace


ServerTotalMsgReceived Members

ServerTotalMsgReceived Members NFX Class Library

The ServerTotalMsgReceived type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerTotalMsgReceived | Initializes a new instance of the ServerTotalMsgReceived class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerTotalMsgReceived Class
NFX.Glue.Instrumentation Namespace


ServerTotalMsgReceived Constructor

ServerTotalMsgReceived Constructor NFX Class Library

Initializes a new instance of the ServerTotalMsgReceived class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerTotalMsgReceived(
    string src,
    long value
)
protected ServerTotalMsgReceived(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
ServerTotalMsgReceived(
    String^ src,
    long long value
)
protected:
ServerTotalMsgReceived(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ServerTotalMsgReceived
new :
        src : string *
        value : int64 -> ServerTotalMsgReceived

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ServerTotalMsgReceived Class
ServerTotalMsgReceived Members
NFX.Glue.Instrumentation Namespace


ServerTotalMsgReceived Fields

ServerTotalMsgReceived Fields NFX Class Library

The ServerTotalMsgReceived type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ServerTotalMsgReceived Class
NFX.Glue.Instrumentation Namespace


ServerTotalMsgReceived Methods

ServerTotalMsgReceived Methods NFX Class Library

The ServerTotalMsgReceived type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerTotalMsgReceived Class
NFX.Glue.Instrumentation Namespace


ServerTotalMsgReceived.MakeAggregateInstance Method

ServerTotalMsgReceived MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ServerTotalMsgReceived Class
ServerTotalMsgReceived Members
NFX.Glue.Instrumentation Namespace


ServerTotalMsgReceived.Record Method

ServerTotalMsgReceived Record Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    Node node,
    long value
)
public static void Record(
    Node node,
    long value
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
public:
static void Record(
    Node node,
    long long value
)
public:
static void Record(
    Node node,
    long long value
)
static member Record :
        node : Node *
        value : int64 -> unit
static member Record :
        node : Node *
        value : int64 -> unit

Parameters

node
Type: NFX.Glue Node
value
Type: Online System Int64
See Also
ServerTotalMsgReceived Class
ServerTotalMsgReceived Members
NFX.Glue.Instrumentation Namespace


ServerTotalMsgReceived Properties

ServerTotalMsgReceived Properties NFX Class Library

The ServerTotalMsgReceived type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerTotalMsgReceived Class
NFX.Glue.Instrumentation Namespace


ServerTotalMsgReceived.Description Property

ServerTotalMsgReceived Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ServerTotalMsgReceived Class
ServerTotalMsgReceived Members
NFX.Glue.Instrumentation Namespace


ServerTotalMsgReceived.ValueUnitName Property

ServerTotalMsgReceived ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ServerTotalMsgReceived Class
ServerTotalMsgReceived Members
NFX.Glue.Instrumentation Namespace


ServerTotalMsgSent Class

ServerTotalMsgSent Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Glue.Instrumentation ServerGauge
NFX.Glue.Instrumentation ServerTotalMsgSent

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ServerTotalMsgSent : ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class ServerTotalMsgSent : ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerTotalMsgSent
    Inherits ServerGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerTotalMsgSent
    Inherits ServerGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerTotalMsgSent : public ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerTotalMsgSent : public ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type ServerTotalMsgSent =
    class
        inherit ServerGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ServerTotalMsgSent =
    class
        inherit ServerGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ServerTotalMsgSent Members
NFX.Glue.Instrumentation Namespace


ServerTotalMsgSent Members

ServerTotalMsgSent Members NFX Class Library

The ServerTotalMsgSent type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerTotalMsgSent | Initializes a new instance of the ServerTotalMsgSent class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerTotalMsgSent Class
NFX.Glue.Instrumentation Namespace


ServerTotalMsgSent Constructor

ServerTotalMsgSent Constructor NFX Class Library

Initializes a new instance of the ServerTotalMsgSent class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerTotalMsgSent(
    string src,
    long value
)
protected ServerTotalMsgSent(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
ServerTotalMsgSent(
    String^ src,
    long long value
)
protected:
ServerTotalMsgSent(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ServerTotalMsgSent
new :
        src : string *
        value : int64 -> ServerTotalMsgSent

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ServerTotalMsgSent Class
ServerTotalMsgSent Members
NFX.Glue.Instrumentation Namespace


ServerTotalMsgSent Fields

ServerTotalMsgSent Fields NFX Class Library

The ServerTotalMsgSent type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ServerTotalMsgSent Class
NFX.Glue.Instrumentation Namespace


ServerTotalMsgSent Methods

ServerTotalMsgSent Methods NFX Class Library

The ServerTotalMsgSent type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerTotalMsgSent Class
NFX.Glue.Instrumentation Namespace


ServerTotalMsgSent.MakeAggregateInstance Method

ServerTotalMsgSent MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ServerTotalMsgSent Class
ServerTotalMsgSent Members
NFX.Glue.Instrumentation Namespace


ServerTotalMsgSent.Record Method

ServerTotalMsgSent Record Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    Node node,
    long value
)
public static void Record(
    Node node,
    long value
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
public:
static void Record(
    Node node,
    long long value
)
public:
static void Record(
    Node node,
    long long value
)
static member Record :
        node : Node *
        value : int64 -> unit
static member Record :
        node : Node *
        value : int64 -> unit

Parameters

node
Type: NFX.Glue Node
value
Type: Online System Int64
See Also
ServerTotalMsgSent Class
ServerTotalMsgSent Members
NFX.Glue.Instrumentation Namespace


ServerTotalMsgSent Properties

ServerTotalMsgSent Properties NFX Class Library

The ServerTotalMsgSent type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerTotalMsgSent Class
NFX.Glue.Instrumentation Namespace


ServerTotalMsgSent.Description Property

ServerTotalMsgSent Description Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ServerTotalMsgSent Class
ServerTotalMsgSent Members
NFX.Glue.Instrumentation Namespace


ServerTotalMsgSent.ValueUnitName Property

ServerTotalMsgSent ValueUnitName Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ServerTotalMsgSent Class
ServerTotalMsgSent Members
NFX.Glue.Instrumentation Namespace


ServerTransportChannelCount Class

ServerTransportChannelCount Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Glue.Instrumentation ServerGauge
NFX.Glue.Instrumentation ServerTransportChannelCount

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ServerTransportChannelCount : ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class ServerTransportChannelCount : ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerTransportChannelCount
    Inherits ServerGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerTransportChannelCount
    Inherits ServerGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerTransportChannelCount : public ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerTransportChannelCount : public ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type ServerTransportChannelCount =
    class
        inherit ServerGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ServerTransportChannelCount =
    class
        inherit ServerGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ServerTransportChannelCount Members
NFX.Glue.Instrumentation Namespace


ServerTransportChannelCount Members

ServerTransportChannelCount Members NFX Class Library

The ServerTransportChannelCount type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerTransportChannelCount | Initializes a new instance of the ServerTransportChannelCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerTransportChannelCount Class
NFX.Glue.Instrumentation Namespace


ServerTransportChannelCount Constructor

ServerTransportChannelCount Constructor NFX Class Library

Initializes a new instance of the ServerTransportChannelCount class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerTransportChannelCount(
    string src,
    long value
)
protected ServerTransportChannelCount(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
ServerTransportChannelCount(
    String^ src,
    long long value
)
protected:
ServerTransportChannelCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ServerTransportChannelCount
new :
        src : string *
        value : int64 -> ServerTransportChannelCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ServerTransportChannelCount Class
ServerTransportChannelCount Members
NFX.Glue.Instrumentation Namespace


ServerTransportChannelCount Fields

ServerTransportChannelCount Fields NFX Class Library

The ServerTransportChannelCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ServerTransportChannelCount Class
NFX.Glue.Instrumentation Namespace


ServerTransportChannelCount Methods

ServerTransportChannelCount Methods NFX Class Library

The ServerTransportChannelCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerTransportChannelCount Class
NFX.Glue.Instrumentation Namespace


ServerTransportChannelCount.MakeAggregateInstance Method

ServerTransportChannelCount MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ServerTransportChannelCount Class
ServerTransportChannelCount Members
NFX.Glue.Instrumentation Namespace


ServerTransportChannelCount.Record Method

ServerTransportChannelCount Record Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    Node node,
    long value
)
public static void Record(
    Node node,
    long value
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
public:
static void Record(
    Node node,
    long long value
)
public:
static void Record(
    Node node,
    long long value
)
static member Record :
        node : Node *
        value : int64 -> unit
static member Record :
        node : Node *
        value : int64 -> unit

Parameters

node
Type: NFX.Glue Node
value
Type: Online System Int64
See Also
ServerTransportChannelCount Class
ServerTransportChannelCount Members
NFX.Glue.Instrumentation Namespace


ServerTransportChannelCount Properties

ServerTransportChannelCount Properties NFX Class Library

The ServerTransportChannelCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerTransportChannelCount Class
NFX.Glue.Instrumentation Namespace


ServerTransportChannelCount.Description Property

ServerTransportChannelCount Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ServerTransportChannelCount Class
ServerTransportChannelCount Members
NFX.Glue.Instrumentation Namespace


ServerTransportChannelCount.ValueUnitName Property

ServerTransportChannelCount ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ServerTransportChannelCount Class
ServerTransportChannelCount Members
NFX.Glue.Instrumentation Namespace


ServerTransportCount Class

ServerTransportCount Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Glue.Instrumentation ServerGauge
NFX.Glue.Instrumentation ServerTransportCount

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ServerTransportCount : ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class ServerTransportCount : ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerTransportCount
    Inherits ServerGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class ServerTransportCount
    Inherits ServerGauge
    Implements INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerTransportCount : public ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerTransportCount : public ServerGauge,
    INetInstrument, IIOInstrumentClass, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type ServerTransportCount =
    class
        inherit ServerGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ServerTransportCount =
    class
        inherit ServerGauge
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ServerTransportCount Members
NFX.Glue.Instrumentation Namespace


ServerTransportCount Members

ServerTransportCount Members NFX Class Library

The ServerTransportCount type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerTransportCount | Initializes a new instance of the ServerTransportCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerTransportCount Class
NFX.Glue.Instrumentation Namespace


ServerTransportCount Constructor

ServerTransportCount Constructor NFX Class Library

Initializes a new instance of the ServerTransportCount class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerTransportCount(
    string src,
    long value
)
protected ServerTransportCount(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
ServerTransportCount(
    String^ src,
    long long value
)
protected:
ServerTransportCount(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> ServerTransportCount
new :
        src : string *
        value : int64 -> ServerTransportCount

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
ServerTransportCount Class
ServerTransportCount Members
NFX.Glue.Instrumentation Namespace


ServerTransportCount Fields

ServerTransportCount Fields NFX Class Library

The ServerTransportCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ServerTransportCount Class
NFX.Glue.Instrumentation Namespace


ServerTransportCount Methods

ServerTransportCount Methods NFX Class Library

The ServerTransportCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerTransportCount Class
NFX.Glue.Instrumentation Namespace


ServerTransportCount.MakeAggregateInstance Method

ServerTransportCount MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ServerTransportCount Class
ServerTransportCount Members
NFX.Glue.Instrumentation Namespace


ServerTransportCount.Record Method

ServerTransportCount Record Method NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    Node node,
    long value
)
public static void Record(
    Node node,
    long value
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
Public Shared Sub Record (
    node As Node,
    value As Long
)
public:
static void Record(
    Node node,
    long long value
)
public:
static void Record(
    Node node,
    long long value
)
static member Record :
        node : Node *
        value : int64 -> unit
static member Record :
        node : Node *
        value : int64 -> unit

Parameters

node
Type: NFX.Glue Node
value
Type: Online System Int64
See Also
ServerTransportCount Class
ServerTransportCount Members
NFX.Glue.Instrumentation Namespace


ServerTransportCount Properties

ServerTransportCount Properties NFX Class Library

The ServerTransportCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerTransportCount Class
NFX.Glue.Instrumentation Namespace


ServerTransportCount.Description Property

ServerTransportCount Description Property NFX Class Library

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ServerTransportCount Class
ServerTransportCount Members
NFX.Glue.Instrumentation Namespace


ServerTransportCount.ValueUnitName Property

ServerTransportCount ValueUnitName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ServerTransportCount Class
ServerTransportCount Members
NFX.Glue.Instrumentation Namespace


ServerTransportErrorEvent Class

ServerTransportErrorEvent Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Event
NFX.Glue.Instrumentation GlueEvent
NFX.Glue.Instrumentation ServerEvent
NFX.Glue.Instrumentation ServerTransportErrorEvent
NFX.Glue.Instrumentation ServerDeserializationErrorEvent
NFX.Glue.Instrumentation ServerGotOverMaxMsgSizeErrorEvent
NFX.Glue.Instrumentation ServerListenerErrorEvent
NFX.Glue.Instrumentation ServerSerializedOverMaxMsgSizeErrorEvent

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class ServerTransportErrorEvent : ServerEvent,
    IErrorInstrument, IProblemClass, INetInstrument, IIOInstrumentClass, IOperationClass,
    IInstrumentClass
[SerializableAttribute]
public abstract class ServerTransportErrorEvent : ServerEvent,
    IErrorInstrument, IProblemClass, INetInstrument, IIOInstrumentClass, IOperationClass,
    IInstrumentClass
<SerializableAttribute>
Public MustInherit Class ServerTransportErrorEvent
    Inherits ServerEvent
    Implements IErrorInstrument, IProblemClass, INetInstrument, IIOInstrumentClass,
    IOperationClass, IInstrumentClass
<SerializableAttribute>
Public MustInherit Class ServerTransportErrorEvent
    Inherits ServerEvent
    Implements IErrorInstrument, IProblemClass, INetInstrument, IIOInstrumentClass,
    IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class ServerTransportErrorEvent abstract : public ServerEvent,
    IErrorInstrument, IProblemClass, INetInstrument, IIOInstrumentClass, IOperationClass,
    IInstrumentClass
[SerializableAttribute]
public ref class ServerTransportErrorEvent abstract : public ServerEvent,
    IErrorInstrument, IProblemClass, INetInstrument, IIOInstrumentClass, IOperationClass,
    IInstrumentClass
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ServerTransportErrorEvent =
    class
        inherit ServerEvent
        interface IErrorInstrument
        interface IProblemClass
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ServerTransportErrorEvent =
    class
        inherit ServerEvent
        interface IErrorInstrument
        interface IProblemClass
        interface INetInstrument
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
ServerTransportErrorEvent Members
NFX.Glue.Instrumentation Namespace


ServerTransportErrorEvent Members

ServerTransportErrorEvent Members NFX Class Library

The ServerTransportErrorEvent type exposes the following members.
Constructors
 | Name | Description
Protected method | ServerTransportErrorEvent | Initializes a new instance of the ServerTransportErrorEvent class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerTransportErrorEvent Class
NFX.Glue.Instrumentation Namespace


ServerTransportErrorEvent Constructor

ServerTransportErrorEvent Constructor NFX Class Library

Initializes a new instance of the ServerTransportErrorEvent class

Namespace: NFX.Glue.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServerTransportErrorEvent(
    string src
)
protected ServerTransportErrorEvent(
    string src
)
Protected Sub New (
    src As String
)
Protected Sub New (
    src As String
)
protected:
ServerTransportErrorEvent(
    String^ src
)
protected:
ServerTransportErrorEvent(
    String^ src
)
new :
        src : string -> ServerTransportErrorEvent
new :
        src : string -> ServerTransportErrorEvent

Parameters

src
Type: Online System String
See Also
ServerTransportErrorEvent Class
ServerTransportErrorEvent Members
NFX.Glue.Instrumentation Namespace


ServerTransportErrorEvent Fields

ServerTransportErrorEvent Fields NFX Class Library

The ServerTransportErrorEvent type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ServerTransportErrorEvent Class
NFX.Glue.Instrumentation Namespace


ServerTransportErrorEvent Methods

ServerTransportErrorEvent Methods NFX Class Library

The ServerTransportErrorEvent type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServerTransportErrorEvent Class
NFX.Glue.Instrumentation Namespace


ServerTransportErrorEvent Properties

ServerTransportErrorEvent Properties NFX Class Library

The ServerTransportErrorEvent type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ServerTransportErrorEvent Class
NFX.Glue.Instrumentation Namespace


NFX.Glue.Native Namespace

NFX.Glue.Native Namespace NFX Class Library

Provides implementations for NFX-native Glue bindings whoch are based on NFX.Serialization and TCP/IP sockets
Classes
 | Class | Description
Protected class | Consts | Constants common to Native/Socket-based family of technologies
Public class | InProcBinding | Provides synchronous communication pattern based on in-memory message exchange without serialization. This binding is usable for interconnection between NFX-native components in the same app domain
Public class | InProcClientTransport | Provides client-side functionality for synchronous communication pattern based on in-memory message exchange without serialization
Public class | InProcServerTransport | Provides server-side functionality for synchronous communication pattern based on in-memory message exchange without serialization
Public class | MemChunk | Represents a stream/writable chunk of memory backed by an array buffer
Public class | MpxBinding | Provides asynchronous communicating pattern based on asynchronous virtual socket. The concrete socket may be based on OS-supported technology i.e. - IO completion ports on Windows
Public class | MpxClientSocket | Represents client-side asynchronous socket. This socket initiates a connection to MpxServerSocket
Public class | MpxClientTransport | Implements asynchronous MPX client transport for MpxBinding
Public class | MpxListener | Represents a server-side listener socket that accepts the calls
Public class | MpxServerSocket | Represents server-side asynchronous socket that clients connect to
Public class | MpxServerTransport | Implements asynchronous MPX server transport for MpxBinding
Public class | MpxSocket TTransport | Base for MpxSockets implementation. An MpxSocket represents an asynchronous bi-directional channel of communication that delivers binary/wire messages of flexible size. The socket is NOT THREAD SAFE for calling Send() from parallel threads. Send() is done synchronously on the calling thread, i.e. the sender waits until the data is written into the OS socket buff. Receive is invoked by internal/system/io thread asynchronously and should not block for long (seconds)
Public class | MpxSocketFactory | Defines factory abstraction that creates socket per particular technology
Public class | MpxWinClientSocket | Implements a MPX client socket using Windows IO completion ports for receive
Public class | MpxWinListener | Implements a MPX socket listener that accepts connections into MpxWinServerSocket
Public class | MpxWinServerSocket | Implements a MPX server socket using Windows IO completion ports for receive
Public class | MpxWinSocketFactory | Factory that makes MpxWin sockets based on Windows-IO completion ports
Protected class | SocketState |
Public class | SyncBinding | Provides synchronous communication pattern based on TCP blocking sockets and Slim serializer for maximum serialization performance and lowest latency. This binding is usable for interconnection between NFX-native components on LANs (i.e. server clusters) in scenarios when low latency is more important than total call invocation throughput
Public class | SyncClientTransport | Provides client-side functionality for synchronous communication pattern based on TCP blocking sockets and Slim serializer for maximum serialization performance and lowest latency. The SyncBinding is usable for interconnection between NFX-native components on LANs (i.e. server clusters) in scenarios when low latency is more important than total call invocation throughput
Public class | SyncServerTransport | Provides server-side functionality for synchronous communication pattern based on TCP blocking sockets and Slim serializer for maximum serialization performance and lowest latency. The SyncBinding is usable for interconnection between NFX-native components on LANs (i.e. server clusters) in scenarios when low latency is more important than total call invocation throughput. SyncServerTransport uses dedicated thread for request processing and is not scalable beyond a few hundred connections by design, however it provides low latency benefit
Structures
 | Structure | Description
Public structure | ClientSite | Represents a client call site identifier which gets generated on client and sent to server upon handshake. This struct identifies the calling client by supplying machine/host name and calling application instance ID
Public structure | WireFrame | This struct defines a frame transmitted as a part of WireMsg which can be used for transport or session management needs
Public structure | WireMsg | Represents a message that is transmitted over the wire:
Interfaces
 | Interface | Description
Public interface | IMpxTransport |
Delegates
 | Delegate | Description
Public delegate | MpxSocketReceiveAction TTransport | Delivers wire msg from another side. DO NOT use WireMsg beyound the implementation of this delegate, if needed make a copy of msg.Data as the memory will be freed after this call returns
Enumerations
 | Enumeration | Description
Public enumeration | FrameType | Type of transport frame message


ClientSite Structure

ClientSite Structure NFX Class Library

Represents a client call site identifier which gets generated on client and sent to server upon handshake. This struct identifies the calling client by supplying machine/host name and calling application instance ID

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public struct ClientSite : INamed
[SerializableAttribute]
public struct ClientSite : INamed
<SerializableAttribute>
Public Structure ClientSite
    Implements INamed
<SerializableAttribute>
Public Structure ClientSite
    Implements INamed
[SerializableAttribute]
public value class ClientSite : INamed
[SerializableAttribute]
public value class ClientSite : INamed
[<SealedAttribute>]
[<SerializableAttribute>]
type ClientSite =
    struct
        interface INamed
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type ClientSite =
    struct
        interface INamed
    end
See Also
ClientSite Members
NFX.Glue.Native Namespace


ClientSite Members

ClientSite Members NFX Class Library

The ClientSite type exposes the following members.
Constructors
 | Name | Description
Public method | ClientSite(Stream) | Deserializes ClientSite from stream. The stream position must be past total size
Public method | ClientSite(String) | Initializes a new instance of the ClientSite class
Back to Top
Methods
 | Name | Description
Public method | Equals | (Overrides Online ValueType Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Serialize | Writes ClientSite into stream including total size in bytes. Returns total size
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
GUID_SIZE |
MachineName | Sets process-global machine name for client site identification. Assign on client to cluster/other machine names, by default the .ctor will use local computer name
MAGIC |
MAX_HOST_NAME_BYTE_LEN |
MAX_STREAM_BYTE_LEN |
TEXT_ENCODING |
Back to Top
Properties
 | Name | Description
Public property | AppInstanceID | Returns instance ID for the calling application container
Public property | Host | Returns host name for where calling application runs
Public property | Name | Returns host name+app instance guid suitable for registry operations
Back to Top
See Also
ClientSite Structure
NFX.Glue.Native Namespace


ClientSite Constructor

ClientSite Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ClientSite(Stream) | Deserializes ClientSite from stream. The stream position must be past total size
Public method | ClientSite(String) | Initializes a new instance of the ClientSite class
Back to Top
See Also
ClientSite Structure
ClientSite Members
NFX.Glue.Native Namespace


ClientSite Constructor (Stream)

ClientSite Constructor (Stream) NFX Class Library

Deserializes ClientSite from stream. The stream position must be past total size

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ClientSite(
    Stream stream
)
public ClientSite(
    Stream stream
)
Public Sub New (
    stream As Stream
)
Public Sub New (
    stream As Stream
)
public:
ClientSite(
    Stream^ stream
)
public:
ClientSite(
    Stream^ stream
)
new :
        stream : Stream -> ClientSite
new :
        stream : Stream -> ClientSite

Parameters

stream
Type: Online System.IO Stream
See Also
ClientSite Structure
ClientSite Members
ClientSite Overload
NFX.Glue.Native Namespace


ClientSite Constructor (String)

ClientSite Constructor (String) NFX Class Library

Initializes a new instance of the ClientSite class

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ClientSite(
    string host
)
public ClientSite(
    string host
)
Public Sub New (
    host As String
)
Public Sub New (
    host As String
)
public:
ClientSite(
    String^ host
)
public:
ClientSite(
    String^ host
)
new :
        host : string -> ClientSite
new :
        host : string -> ClientSite

Parameters

host
Type: Online System String
See Also
ClientSite Structure
ClientSite Members
ClientSite Overload
NFX.Glue.Native Namespace


ClientSite Fields

ClientSite Fields NFX Class Library

The ClientSite type exposes the following members.
Fields
Name | Description
GUID_SIZE |
MachineName | Sets process-global machine name for client site identification. Assign on client to cluster/other machine names, by default the .ctor will use local computer name
MAGIC |
MAX_HOST_NAME_BYTE_LEN |
MAX_STREAM_BYTE_LEN |
TEXT_ENCODING |
Back to Top
See Also
ClientSite Structure
NFX.Glue.Native Namespace


ClientSite.GUID_SIZE Field

ClientSite GUID_SIZE Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int GUID_SIZE
public const int GUID_SIZE
Public Const GUID_SIZE As Integer
Public Const GUID_SIZE As Integer
public:
literal int GUID_SIZE
public:
literal int GUID_SIZE
static val mutable GUID_SIZE: int
static val mutable GUID_SIZE: int

Field Value

Type: Online Int32
See Also
ClientSite Structure
ClientSite Members
NFX.Glue.Native Namespace


ClientSite.MachineName Field

ClientSite MachineName Field NFX Class Library

Sets process-global machine name for client site identification. Assign on client to cluster/other machine names, by default the .ctor will use local computer name

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string MachineName
public static string MachineName
Public Shared MachineName As String
Public Shared MachineName As String
public:
static String^ MachineName
public:
static String^ MachineName
static val mutable MachineName: string
static val mutable MachineName: string

Field Value

Type: Online String
See Also
ClientSite Structure
ClientSite Members
NFX.Glue.Native Namespace


ClientSite.MAGIC Field

ClientSite MAGIC Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAGIC
public const int MAGIC
Public Const MAGIC As Integer
Public Const MAGIC As Integer
public:
literal int MAGIC
public:
literal int MAGIC
static val mutable MAGIC: int
static val mutable MAGIC: int

Field Value

Type: Online Int32
See Also
ClientSite Structure
ClientSite Members
NFX.Glue.Native Namespace


ClientSite.MAX_HOST_NAME_BYTE_LEN Field

ClientSite MAX_HOST_NAME_BYTE_LEN Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_HOST_NAME_BYTE_LEN
public const int MAX_HOST_NAME_BYTE_LEN
Public Const MAX_HOST_NAME_BYTE_LEN As Integer
Public Const MAX_HOST_NAME_BYTE_LEN As Integer
public:
literal int MAX_HOST_NAME_BYTE_LEN
public:
literal int MAX_HOST_NAME_BYTE_LEN
static val mutable MAX_HOST_NAME_BYTE_LEN: int
static val mutable MAX_HOST_NAME_BYTE_LEN: int

Field Value

Type: Online Int32
See Also
ClientSite Structure
ClientSite Members
NFX.Glue.Native Namespace


ClientSite.MAX_STREAM_BYTE_LEN Field

ClientSite MAX_STREAM_BYTE_LEN Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_STREAM_BYTE_LEN
public const int MAX_STREAM_BYTE_LEN
Public Const MAX_STREAM_BYTE_LEN As Integer
Public Const MAX_STREAM_BYTE_LEN As Integer
public:
literal int MAX_STREAM_BYTE_LEN
public:
literal int MAX_STREAM_BYTE_LEN
static val mutable MAX_STREAM_BYTE_LEN: int
static val mutable MAX_STREAM_BYTE_LEN: int

Field Value

Type: Online Int32
See Also
ClientSite Structure
ClientSite Members
NFX.Glue.Native Namespace


ClientSite.TEXT_ENCODING Field

ClientSite TEXT_ENCODING Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Encoding TEXT_ENCODING
public static readonly Encoding TEXT_ENCODING
Public Shared ReadOnly TEXT_ENCODING As Encoding
Public Shared ReadOnly TEXT_ENCODING As Encoding
public:
static initonly Encoding^ TEXT_ENCODING
public:
static initonly Encoding^ TEXT_ENCODING
static val TEXT_ENCODING: Encoding
static val TEXT_ENCODING: Encoding

Field Value

Type: Online Encoding
See Also
ClientSite Structure
ClientSite Members
NFX.Glue.Native Namespace


ClientSite Methods

ClientSite Methods NFX Class Library

The ClientSite type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online ValueType Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Serialize | Writes ClientSite into stream including total size in bytes. Returns total size
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ClientSite Structure
NFX.Glue.Native Namespace


ClientSite.Equals Method

ClientSite Equals Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
ClientSite Structure
ClientSite Members
NFX.Glue.Native Namespace


ClientSite.GetHashCode Method

ClientSite GetHashCode Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
ClientSite Structure
ClientSite Members
NFX.Glue.Native Namespace


ClientSite.Serialize Method

ClientSite Serialize Method NFX Class Library

Writes ClientSite into stream including total size in bytes. Returns total size

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Serialize(
    Stream stream
)
public int Serialize(
    Stream stream
)
Public Function Serialize (
    stream As Stream
) As Integer
Public Function Serialize (
    stream As Stream
) As Integer
public:
int Serialize(
    Stream^ stream
)
public:
int Serialize(
    Stream^ stream
)
member Serialize :
        stream : Stream -> int
member Serialize :
        stream : Stream -> int

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online Int32
See Also
ClientSite Structure
ClientSite Members
NFX.Glue.Native Namespace


ClientSite.ToString Method

ClientSite ToString Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
ClientSite Structure
ClientSite Members
NFX.Glue.Native Namespace


ClientSite Properties

ClientSite Properties NFX Class Library

The ClientSite type exposes the following members.
Properties
 | Name | Description
Public property | AppInstanceID | Returns instance ID for the calling application container
Public property | Host | Returns host name for where calling application runs
Public property | Name | Returns host name+app instance guid suitable for registry operations
Back to Top
See Also
ClientSite Structure
NFX.Glue.Native Namespace


ClientSite.AppInstanceID Property

ClientSite AppInstanceID Property NFX Class Library

Returns instance ID for the calling application container

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid AppInstanceID { get; }
public Guid AppInstanceID { get; }
Public ReadOnly Property AppInstanceID As Guid
    Get
Public ReadOnly Property AppInstanceID As Guid
    Get
public:
property Guid AppInstanceID {
    Guid get ();
}
public:
property Guid AppInstanceID {
    Guid get ();
}
member AppInstanceID : Guid with get
member AppInstanceID : Guid with get

Property Value

Type: Online Guid
See Also
ClientSite Structure
ClientSite Members
NFX.Glue.Native Namespace


ClientSite.Host Property

ClientSite Host Property NFX Class Library

Returns host name for where calling application runs

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Host { get; }
public string Host { get; }
Public ReadOnly Property Host As String
    Get
Public ReadOnly Property Host As String
    Get
public:
property String^ Host {
    String^ get ();
}
public:
property String^ Host {
    String^ get ();
}
member Host : string with get
member Host : string with get

Property Value

Type: Online String
See Also
ClientSite Structure
ClientSite Members
NFX.Glue.Native Namespace


ClientSite.Name Property

ClientSite Name Property NFX Class Library

Returns host name+app instance guid suitable for registry operations

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
ClientSite Structure
ClientSite Members
NFX.Glue.Native Namespace


Consts Class

Consts Class NFX Class Library

Constants common to Native/Socket-based family of technologies
Inheritance Hierarchy
Online System Object
NFX.Glue.Native Consts

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class Consts
internal class Consts
Friend Class Consts
Friend Class Consts
internal ref class Consts
internal ref class Consts
type Consts =  class end
type Consts =  class end
See Also
Consts Members
NFX.Glue.Native Namespace


Consts Members

Consts Members NFX Class Library

The Consts type exposes the following members.
Constructors
 | Name | Description
Public method | Consts | Initializes a new instance of the Consts class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_MAX_MSG_SIZE_ATTR |
CONFIG_RCV_BUF_SIZE_ATTR |
CONFIG_RCV_TIMEOUT_ATTR |
CONFIG_SND_BUF_SIZE_ATTR |
CONFIG_SND_TIMEOUT_ATTR |
DEFAULT_MAX_MSG_SIZE |
DEFAULT_RCV_BUFFER_SIZE |
DEFAULT_SERIALIZER_STREAM_CAPACITY |
DEFAULT_SND_BUFFER_SIZE |
MAX_MSG_SIZE_LOW_BOUND |
PACKET_DELIMITER_LENGTH | Size of the packet delimiting field
SLIM_FORMAT |
Back to Top
See Also
Consts Class
NFX.Glue.Native Namespace


Consts Constructor

Consts Constructor NFX Class Library

Initializes a new instance of the Consts class

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Consts()
public Consts()
Public Sub New
Public Sub New
public:
Consts()
public:
Consts()
new : unit -> Consts
new : unit -> Consts
See Also
Consts Class
Consts Members
NFX.Glue.Native Namespace


Consts Fields

Consts Fields NFX Class Library

The Consts type exposes the following members.
Fields
Name | Description
CONFIG_MAX_MSG_SIZE_ATTR |
CONFIG_RCV_BUF_SIZE_ATTR |
CONFIG_RCV_TIMEOUT_ATTR |
CONFIG_SND_BUF_SIZE_ATTR |
CONFIG_SND_TIMEOUT_ATTR |
DEFAULT_MAX_MSG_SIZE |
DEFAULT_RCV_BUFFER_SIZE |
DEFAULT_SERIALIZER_STREAM_CAPACITY |
DEFAULT_SND_BUFFER_SIZE |
MAX_MSG_SIZE_LOW_BOUND |
PACKET_DELIMITER_LENGTH | Size of the packet delimiting field
SLIM_FORMAT |
Back to Top
See Also
Consts Class
NFX.Glue.Native Namespace


Consts.CONFIG_MAX_MSG_SIZE_ATTR Field

Consts CONFIG_MAX_MSG_SIZE_ATTR Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_MAX_MSG_SIZE_ATTR
public const string CONFIG_MAX_MSG_SIZE_ATTR
Public Const CONFIG_MAX_MSG_SIZE_ATTR As String
Public Const CONFIG_MAX_MSG_SIZE_ATTR As String
public:
literal String^ CONFIG_MAX_MSG_SIZE_ATTR
public:
literal String^ CONFIG_MAX_MSG_SIZE_ATTR
static val mutable CONFIG_MAX_MSG_SIZE_ATTR: string
static val mutable CONFIG_MAX_MSG_SIZE_ATTR: string

Field Value

Type: Online String
See Also
Consts Class
Consts Members
NFX.Glue.Native Namespace


Consts.CONFIG_RCV_BUF_SIZE_ATTR Field

Consts CONFIG_RCV_BUF_SIZE_ATTR Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_RCV_BUF_SIZE_ATTR
public const string CONFIG_RCV_BUF_SIZE_ATTR
Public Const CONFIG_RCV_BUF_SIZE_ATTR As String
Public Const CONFIG_RCV_BUF_SIZE_ATTR As String
public:
literal String^ CONFIG_RCV_BUF_SIZE_ATTR
public:
literal String^ CONFIG_RCV_BUF_SIZE_ATTR
static val mutable CONFIG_RCV_BUF_SIZE_ATTR: string
static val mutable CONFIG_RCV_BUF_SIZE_ATTR: string

Field Value

Type: Online String
See Also
Consts Class
Consts Members
NFX.Glue.Native Namespace


Consts.CONFIG_RCV_TIMEOUT_ATTR Field

Consts CONFIG_RCV_TIMEOUT_ATTR Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_RCV_TIMEOUT_ATTR
public const string CONFIG_RCV_TIMEOUT_ATTR
Public Const CONFIG_RCV_TIMEOUT_ATTR As String
Public Const CONFIG_RCV_TIMEOUT_ATTR As String
public:
literal String^ CONFIG_RCV_TIMEOUT_ATTR
public:
literal String^ CONFIG_RCV_TIMEOUT_ATTR
static val mutable CONFIG_RCV_TIMEOUT_ATTR: string
static val mutable CONFIG_RCV_TIMEOUT_ATTR: string

Field Value

Type: Online String
See Also
Consts Class
Consts Members
NFX.Glue.Native Namespace


Consts.CONFIG_SND_BUF_SIZE_ATTR Field

Consts CONFIG_SND_BUF_SIZE_ATTR Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SND_BUF_SIZE_ATTR
public const string CONFIG_SND_BUF_SIZE_ATTR
Public Const CONFIG_SND_BUF_SIZE_ATTR As String
Public Const CONFIG_SND_BUF_SIZE_ATTR As String
public:
literal String^ CONFIG_SND_BUF_SIZE_ATTR
public:
literal String^ CONFIG_SND_BUF_SIZE_ATTR
static val mutable CONFIG_SND_BUF_SIZE_ATTR: string
static val mutable CONFIG_SND_BUF_SIZE_ATTR: string

Field Value

Type: Online String
See Also
Consts Class
Consts Members
NFX.Glue.Native Namespace


Consts.CONFIG_SND_TIMEOUT_ATTR Field

Consts CONFIG_SND_TIMEOUT_ATTR Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SND_TIMEOUT_ATTR
public const string CONFIG_SND_TIMEOUT_ATTR
Public Const CONFIG_SND_TIMEOUT_ATTR As String
Public Const CONFIG_SND_TIMEOUT_ATTR As String
public:
literal String^ CONFIG_SND_TIMEOUT_ATTR
public:
literal String^ CONFIG_SND_TIMEOUT_ATTR
static val mutable CONFIG_SND_TIMEOUT_ATTR: string
static val mutable CONFIG_SND_TIMEOUT_ATTR: string

Field Value

Type: Online String
See Also
Consts Class
Consts Members
NFX.Glue.Native Namespace


Consts.DEFAULT_MAX_MSG_SIZE Field

Consts DEFAULT_MAX_MSG_SIZE Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_MAX_MSG_SIZE
public const int DEFAULT_MAX_MSG_SIZE
Public Const DEFAULT_MAX_MSG_SIZE As Integer
Public Const DEFAULT_MAX_MSG_SIZE As Integer
public:
literal int DEFAULT_MAX_MSG_SIZE
public:
literal int DEFAULT_MAX_MSG_SIZE
static val mutable DEFAULT_MAX_MSG_SIZE: int
static val mutable DEFAULT_MAX_MSG_SIZE: int

Field Value

Type: Online Int32
See Also
Consts Class
Consts Members
NFX.Glue.Native Namespace


Consts.DEFAULT_RCV_BUFFER_SIZE Field

Consts DEFAULT_RCV_BUFFER_SIZE Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_RCV_BUFFER_SIZE
public const int DEFAULT_RCV_BUFFER_SIZE
Public Const DEFAULT_RCV_BUFFER_SIZE As Integer
Public Const DEFAULT_RCV_BUFFER_SIZE As Integer
public:
literal int DEFAULT_RCV_BUFFER_SIZE
public:
literal int DEFAULT_RCV_BUFFER_SIZE
static val mutable DEFAULT_RCV_BUFFER_SIZE: int
static val mutable DEFAULT_RCV_BUFFER_SIZE: int

Field Value

Type: Online Int32
See Also
Consts Class
Consts Members
NFX.Glue.Native Namespace


Consts.DEFAULT_SERIALIZER_STREAM_CAPACITY Field

Consts DEFAULT_SERIALIZER_STREAM_CAPACITY Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_SERIALIZER_STREAM_CAPACITY
public const int DEFAULT_SERIALIZER_STREAM_CAPACITY
Public Const DEFAULT_SERIALIZER_STREAM_CAPACITY As Integer
Public Const DEFAULT_SERIALIZER_STREAM_CAPACITY As Integer
public:
literal int DEFAULT_SERIALIZER_STREAM_CAPACITY
public:
literal int DEFAULT_SERIALIZER_STREAM_CAPACITY
static val mutable DEFAULT_SERIALIZER_STREAM_CAPACITY: int
static val mutable DEFAULT_SERIALIZER_STREAM_CAPACITY: int

Field Value

Type: Online Int32
See Also
Consts Class
Consts Members
NFX.Glue.Native Namespace


Consts.DEFAULT_SND_BUFFER_SIZE Field

Consts DEFAULT_SND_BUFFER_SIZE Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_SND_BUFFER_SIZE
public const int DEFAULT_SND_BUFFER_SIZE
Public Const DEFAULT_SND_BUFFER_SIZE As Integer
Public Const DEFAULT_SND_BUFFER_SIZE As Integer
public:
literal int DEFAULT_SND_BUFFER_SIZE
public:
literal int DEFAULT_SND_BUFFER_SIZE
static val mutable DEFAULT_SND_BUFFER_SIZE: int
static val mutable DEFAULT_SND_BUFFER_SIZE: int

Field Value

Type: Online Int32
See Also
Consts Class
Consts Members
NFX.Glue.Native Namespace


Consts.MAX_MSG_SIZE_LOW_BOUND Field

Consts MAX_MSG_SIZE_LOW_BOUND Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_MSG_SIZE_LOW_BOUND
public const int MAX_MSG_SIZE_LOW_BOUND
Public Const MAX_MSG_SIZE_LOW_BOUND As Integer
Public Const MAX_MSG_SIZE_LOW_BOUND As Integer
public:
literal int MAX_MSG_SIZE_LOW_BOUND
public:
literal int MAX_MSG_SIZE_LOW_BOUND
static val mutable MAX_MSG_SIZE_LOW_BOUND: int
static val mutable MAX_MSG_SIZE_LOW_BOUND: int

Field Value

Type: Online Int32
See Also
Consts Class
Consts Members
NFX.Glue.Native Namespace


Consts.PACKET_DELIMITER_LENGTH Field

Consts PACKET_DELIMITER_LENGTH Field NFX Class Library

Size of the packet delimiting field

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int PACKET_DELIMITER_LENGTH
public const int PACKET_DELIMITER_LENGTH
Public Const PACKET_DELIMITER_LENGTH As Integer
Public Const PACKET_DELIMITER_LENGTH As Integer
public:
literal int PACKET_DELIMITER_LENGTH
public:
literal int PACKET_DELIMITER_LENGTH
static val mutable PACKET_DELIMITER_LENGTH: int
static val mutable PACKET_DELIMITER_LENGTH: int

Field Value

Type: Online Int32
See Also
Consts Class
Consts Members
NFX.Glue.Native Namespace


Consts.SLIM_FORMAT Field

Consts SLIM_FORMAT Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SLIM_FORMAT
public const string SLIM_FORMAT
Public Const SLIM_FORMAT As String
Public Const SLIM_FORMAT As String
public:
literal String^ SLIM_FORMAT
public:
literal String^ SLIM_FORMAT
static val mutable SLIM_FORMAT: string
static val mutable SLIM_FORMAT: string

Field Value

Type: Online String
See Also
Consts Class
Consts Members
NFX.Glue.Native Namespace


Consts Methods

Consts Methods NFX Class Library

The Consts type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Consts Class
NFX.Glue.Native Namespace


FrameType Enumeration

FrameType Enumeration NFX Class Library

Type of transport frame message

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum FrameType
public enum FrameType
Public Enumeration FrameType
Public Enumeration FrameType
public enum class FrameType
public enum class FrameType
type FrameType
type FrameType
Members
Member name | Value | Description
GlueMsg | 71 | Indicator that following payload is a standard Glue message
Heartbeat | 72 | Indicator of the oneway hartbeat message
Echo | 69 | Indicator that this is an echo request message and sending party awaits the EchoResponse message
EchoResponse | 82 | Indicator that this is an echo response message that sending party awaits after E was sent
Dummy | 68 | Indicator that the payload is a one way dummy and should be ignored. This may be needed for stress testing the network throughput
See Also
NFX.Glue.Native Namespace


IMpxTransport Interface

IMpxTransport Interface NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IMpxTransport
public interface IMpxTransport
Public Interface IMpxTransport
Public Interface IMpxTransport
public interface class IMpxTransport
public interface class IMpxTransport
type IMpxTransport =  interface end
type IMpxTransport =  interface end
See Also
IMpxTransport Members
NFX.Glue.Native Namespace


IMpxTransport Members

IMpxTransport Members NFX Class Library

The IMpxTransport type exposes the following members.
Properties
 | Name | Description
Public property | Binding |
Back to Top
See Also
IMpxTransport Interface
NFX.Glue.Native Namespace


IMpxTransport Properties

IMpxTransport Properties NFX Class Library

The IMpxTransport type exposes the following members.
Properties
 | Name | Description
Public property | Binding |
Back to Top
See Also
IMpxTransport Interface
NFX.Glue.Native Namespace


IMpxTransport.Binding Property

IMpxTransport Binding Property NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
MpxBinding Binding { get; }
MpxBinding Binding { get; }
ReadOnly Property Binding As MpxBinding
    Get
ReadOnly Property Binding As MpxBinding
    Get
property MpxBinding^ Binding {
    MpxBinding^ get ();
}
property MpxBinding^ Binding {
    MpxBinding^ get ();
}
abstract Binding : MpxBinding with get
abstract Binding : MpxBinding with get

Property Value

Type: MpxBinding
See Also
IMpxTransport Interface
IMpxTransport Members
NFX.Glue.Native Namespace


InProcBinding Class

InProcBinding Class NFX Class Library

Provides synchronous communication pattern based on in-memory message exchange without serialization. This binding is usable for interconnection between NFX-native components in the same app domain
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service IGlueImplementation
NFX.ServiceModel ServiceWithInstrumentationBase IGlueImplementation
NFX.Glue GlueComponentService
NFX.Glue Binding
NFX.Glue.Native InProcBinding

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class InProcBinding : Binding
public class InProcBinding : Binding
Public Class InProcBinding
    Inherits Binding
Public Class InProcBinding
    Inherits Binding
public ref class InProcBinding : public Binding
public ref class InProcBinding : public Binding
type InProcBinding =
    class
        inherit Binding
    end
type InProcBinding =
    class
        inherit Binding
    end
See Also
InProcBinding Members
NFX.Glue.Native Namespace


InProcBinding Members

InProcBinding Members NFX Class Library

The InProcBinding type exposes the following members.
Constructors
 | Name | Description
Public method | InProcBinding(String) | Initializes a new instance of the InProcBinding class
Public method | InProcBinding(IGlueImplementation, String) | Initializes a new instance of the InProcBinding class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | _Register | (Inherited from Binding.)
Protected method | _Unregister | (Inherited from Binding.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Protected method | AcquireClientTransportForCall | (Overrides Binding AcquireClientTransportForCall(ClientEndPoint, RequestMsg).)
Public method | AreNodesIdentical | (Overrides Binding AreNodesIdentical(Node, Node).)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and binding runtime are running or throws otherwise (Inherited from Binding.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Protected method | CloseServerEndpoint | (Overrides Binding CloseServerEndpoint(ServerEndPoint).)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | ConfigureAndStartNewClientTransport | Override to perform custom transport preparation and launch (Inherited from Binding.)
Protected method | Destructor | (Inherited from Binding.)
Public method | DispatchCall | Dispatches a call allocating new or re-using existing transport if needed. The strategy depends on particular Binding implementation. This call is thread-safe (Inherited from Binding.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | (Inherited from Binding.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Inherited from Binding.)
Protected method | DoSignalStop | (Inherited from Binding.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | (Inherited from Binding.)
Protected method | DumpMsg(Boolean, Msg, ArraySegment Byte ) | Conditionally dumps message to disk (Inherited from Binding.)
Protected method | DumpMsg(Boolean, Msg, Func ArraySegment Byte ) | Conditionally dumps message to disk where the data is lazily obtained by calling dataFun (Inherited from Binding.)
Protected method | DumpMsg(Boolean, Msg, Byte , Int32, Int32) | Conditionally dumps message to disk (Inherited from Binding.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetClientCallStatTimeKey | Extracts necessary information from client:request pair that characterizes the particular call for the purpose of call timing (Inherited from Binding.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | MakeNewClientTransport | (Overrides Binding MakeNewClientTransport(ClientEndPoint).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OpenServerEndpoint | (Overrides Binding OpenServerEndpoint(ServerEndPoint).)
Protected method | ReleaseClientTransportAfterCall | (Overrides Binding ReleaseClientTransportAfterCall(ClientTransport).)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | TryGetExistingAcquiredTransportPerRemoteNode | Tries to acquire an available client transport to make a call. This method respects binding/transport settings that impose a limit on the number of open concurrent transports and timeouts for acqusition waiting (Inherited from Binding.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | WriteLog | (Inherited from GlueComponentService.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_ClientTransportAllocatorLocks | Hash table of locks used during new transport allocation, must be prime size (Inherited from Binding.)
Protected field | m_Provider | (Inherited from Binding.)
Protected field | m_Transports | (Inherited from Binding.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ClientDump | Turns on/off client message dumping to disk. Turning on dumping has negative effect on performance and consumes resources (Inherited from Binding.)
Public property | ClientMsgInspectors | Returns client message inspectors for this instance (Inherited from Binding.)
Public property | ClientTransportCountWaitThreshold | Sets the threshold, expressed as the number of active client transports per remote address, below which binding will always allocate a new instance of client transport without trying/waiting to acquire an existing one. When this number is exceeded then binding will try to acquire an existing client transport instance for up to ClientTransportExistingAcquisitionTimeoutMs milliseconds. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ClientTransportExistingAcquisitionTimeoutMs | Sets the length of interval for the binding trying to acquire existing client transport instance to make a call. When this interval is exhausted then binding tries to allocate a new client transport per remote address, unless other limits prohibit (max transport count). The value has to be greater or equal to zero. NOTE: this property works in conjunction with ClientTransportCoutWaitThreshold, if the number of active client transports is below ClientTransportCoutWaitThreshold, then binding does not wait and allocates a new client transport right away until ClientTransportCoutWaitThreshold limit is reached, then binding will try to acquire existing transport for ClientTransportExistingAcquisitionTimeoutMs milliseconds. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ClientTransportIdleTimeoutMs | Specifies when client transports get auto-closed. Interval is measured in ms. Zero means indefinite/never closed transport. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ClientTransportMaxCount | Imposes a limit on number of active client transports per remote address. Once this limit is reached the binding will block until it can acquire an existing transport instance. Set value to zero to remove the limit. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ClientTransportMaxExistingAcquisitionTimeoutMs | Imposes a timeout for binding trying to get an existing transport instance per remote address. Binding throws ClientCallException when this timeout is exceeded. A value of zero removes the limit (Inherited from Binding.)
Public property | ClientTransports | Returns all client transports in the binding stack (Inherited from Binding.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | ConfigNode | Returns configuration node for this named instance (Inherited from Binding.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | DumpMsgFormat | Set the format for message dumping (Inherited from Binding.)
Public property | DumpPath | Set the path for message dumping. Must be an existing navigable path (Inherited from Binding.)
Public property | EncodingFormat | (Overrides Binding EncodingFormat.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | Glue | (Inherited from GlueComponentService.)
Public property | InstrumentationEnabled | Implements IInstrumentable (Inherited from GlueComponentService.)
Public property | InstrumentClientTransportStat | Defines whether client transport statistics is periodically dumped into instrumentation (Inherited from Binding.)
Public property | InstrumentServerTransportStat | Defines whether server transport statistics is periodically dumped into instrumentation (Inherited from Binding.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | MeasureStatTimes | Defines whether message processing latency should be measured - i.e. messages time-stamped on arrival (Inherited from Binding.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | OperationFlow | InProc binding is synchronous by definition (Overrides Binding OperationFlow.)
Public property | Provider | (Inherited from Binding.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | ServerDump | Turns on/off server message dumping to disk. Turning on dumping has negative effect on performance and consumes resources (Inherited from Binding.)
Public property | ServerMsgInspectors | Returns server message inspectors for this instance (Inherited from Binding.)
Public property | ServerTransportIdleTimeoutMs | Specifies when server transports get auto-closed. Interval is measured in ms. Zero means indefinite/never closed transport. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ServerTransports | Returns all server transports in the binding stack (Inherited from Binding.)
Public property | StatTimesEMAFactor | Defines how much smoothing the timing statistics filter does - the lower the number the more smoothing is done. Smoothing makes stat times insensitive to some seldom delays that may happen every now and then (Inherited from Binding.)
Public property | StatTimeTicks | Returns current time in system frequency-dependent ticks. This property is used to measure accurate times and depends on MeasureStatTimes set to true, otherwise 0 is returned (Inherited from Binding.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | Transports | Returns all transports in the binding stack (Inherited from Binding.)
Back to Top
See Also
InProcBinding Class
NFX.Glue.Native Namespace


InProcBinding Constructor

InProcBinding Constructor NFX Class Library

Overload List
 | Name | Description
Public method | InProcBinding(String) | Initializes a new instance of the InProcBinding class
Public method | InProcBinding(IGlueImplementation, String) | Initializes a new instance of the InProcBinding class
Back to Top
See Also
InProcBinding Class
InProcBinding Members
NFX.Glue.Native Namespace


InProcBinding Constructor (String)

InProcBinding Constructor (String) NFX Class Library

Initializes a new instance of the InProcBinding class

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InProcBinding(
    string name
)
public InProcBinding(
    string name
)
Public Sub New (
    name As String
)
Public Sub New (
    name As String
)
public:
InProcBinding(
    String^ name
)
public:
InProcBinding(
    String^ name
)
new :
        name : string -> InProcBinding
new :
        name : string -> InProcBinding

Parameters

name
Type: Online System String
See Also
InProcBinding Class
InProcBinding Members
InProcBinding Overload
NFX.Glue.Native Namespace


InProcBinding Constructor (IGlueImplementation, String)

InProcBinding Constructor (IGlueImplementation, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the InProcBinding class

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InProcBinding(
    IGlueImplementation glue,
    string name
)
public InProcBinding(
    IGlueImplementation glue,
    string name
)
Public Sub New (
    glue As IGlueImplementation,
    name As String
)
Public Sub New (
    glue As IGlueImplementation,
    name As String
)
public:
InProcBinding(
    IGlueImplementation^ glue,
    String^ name
)
public:
InProcBinding(
    IGlueImplementation^ glue,
    String^ name
)
new :
        glue : IGlueImplementation *
        name : string -> InProcBinding
new :
        glue : IGlueImplementation *
        name : string -> InProcBinding

Parameters

glue
Type: NFX.Glue IGlueImplementation
name
Type: Online System String
See Also
InProcBinding Class
InProcBinding Members
InProcBinding Overload
NFX.Glue.Native Namespace


InProcBinding Fields

InProcBinding Fields NFX Class Library

The InProcBinding type exposes the following members.
Fields
 | Name | Description
Protected field | m_ClientTransportAllocatorLocks | Hash table of locks used during new transport allocation, must be prime size (Inherited from Binding.)
Protected field | m_Provider | (Inherited from Binding.)
Protected field | m_Transports | (Inherited from Binding.)
Back to Top
See Also
InProcBinding Class
NFX.Glue.Native Namespace


InProcBinding Methods

InProcBinding Methods NFX Class Library

The InProcBinding type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | _Register | (Inherited from Binding.)
Protected method | _Unregister | (Inherited from Binding.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Protected method | AcquireClientTransportForCall | (Overrides Binding AcquireClientTransportForCall(ClientEndPoint, RequestMsg).)
Public method | AreNodesIdentical | (Overrides Binding AreNodesIdentical(Node, Node).)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and binding runtime are running or throws otherwise (Inherited from Binding.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Protected method | CloseServerEndpoint | (Overrides Binding CloseServerEndpoint(ServerEndPoint).)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | ConfigureAndStartNewClientTransport | Override to perform custom transport preparation and launch (Inherited from Binding.)
Protected method | Destructor | (Inherited from Binding.)
Public method | DispatchCall | Dispatches a call allocating new or re-using existing transport if needed. The strategy depends on particular Binding implementation. This call is thread-safe (Inherited from Binding.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | (Inherited from Binding.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Inherited from Binding.)
Protected method | DoSignalStop | (Inherited from Binding.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | (Inherited from Binding.)
Protected method | DumpMsg(Boolean, Msg, ArraySegment Byte ) | Conditionally dumps message to disk (Inherited from Binding.)
Protected method | DumpMsg(Boolean, Msg, Func ArraySegment Byte ) | Conditionally dumps message to disk where the data is lazily obtained by calling dataFun (Inherited from Binding.)
Protected method | DumpMsg(Boolean, Msg, Byte , Int32, Int32) | Conditionally dumps message to disk (Inherited from Binding.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetClientCallStatTimeKey | Extracts necessary information from client:request pair that characterizes the particular call for the purpose of call timing (Inherited from Binding.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | MakeNewClientTransport | (Overrides Binding MakeNewClientTransport(ClientEndPoint).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OpenServerEndpoint | (Overrides Binding OpenServerEndpoint(ServerEndPoint).)
Protected method | ReleaseClientTransportAfterCall | (Overrides Binding ReleaseClientTransportAfterCall(ClientTransport).)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | TryGetExistingAcquiredTransportPerRemoteNode | Tries to acquire an available client transport to make a call. This method respects binding/transport settings that impose a limit on the number of open concurrent transports and timeouts for acqusition waiting (Inherited from Binding.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | WriteLog | (Inherited from GlueComponentService.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
InProcBinding Class
NFX.Glue.Native Namespace


InProcBinding.AcquireClientTransportForCall Method

InProcBinding AcquireClientTransportForCall Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override ClientTransport AcquireClientTransportForCall(
    ClientEndPoint client,
    RequestMsg request
)
protected override ClientTransport AcquireClientTransportForCall(
    ClientEndPoint client,
    RequestMsg request
)
Protected Overrides Function AcquireClientTransportForCall (
    client As ClientEndPoint,
    request As RequestMsg
) As ClientTransport
Protected Overrides Function AcquireClientTransportForCall (
    client As ClientEndPoint,
    request As RequestMsg
) As ClientTransport
protected:
virtual ClientTransport^ AcquireClientTransportForCall(
    ClientEndPoint^ client,
    RequestMsg^ request
) override
protected:
virtual ClientTransport^ AcquireClientTransportForCall(
    ClientEndPoint^ client,
    RequestMsg^ request
) override
abstract AcquireClientTransportForCall :
        client : ClientEndPoint *
        request : RequestMsg -> ClientTransport
override AcquireClientTransportForCall :
        client : ClientEndPoint *
        request : RequestMsg -> ClientTransport
abstract AcquireClientTransportForCall :
        client : ClientEndPoint *
        request : RequestMsg -> ClientTransport
override AcquireClientTransportForCall :
        client : ClientEndPoint *
        request : RequestMsg -> ClientTransport

Parameters

client
Type: NFX.Glue ClientEndPoint
request
Type: NFX.Glue.Protocol RequestMsg

Return Value

Type: ClientTransport
See Also
InProcBinding Class
InProcBinding Members
NFX.Glue.Native Namespace


InProcBinding.AreNodesIdentical Method

InProcBinding AreNodesIdentical Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool AreNodesIdentical(
    Node left,
    Node right
)
public override bool AreNodesIdentical(
    Node left,
    Node right
)
Public Overrides Function AreNodesIdentical (
    left As Node,
    right As Node
) As Boolean
Public Overrides Function AreNodesIdentical (
    left As Node,
    right As Node
) As Boolean
public:
virtual bool AreNodesIdentical(
    Node left,
    Node right
) override
public:
virtual bool AreNodesIdentical(
    Node left,
    Node right
) override
abstract AreNodesIdentical :
        left : Node *
        right : Node -> bool
override AreNodesIdentical :
        left : Node *
        right : Node -> bool
abstract AreNodesIdentical :
        left : Node *
        right : Node -> bool
override AreNodesIdentical :
        left : Node *
        right : Node -> bool

Parameters

left
Type: NFX.Glue Node
right
Type: NFX.Glue Node

Return Value

Type: Online Boolean
See Also
InProcBinding Class
InProcBinding Members
NFX.Glue.Native Namespace


InProcBinding.CloseServerEndpoint Method

InProcBinding CloseServerEndpoint Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void CloseServerEndpoint(
    ServerEndPoint epoint
)
protected internal override void CloseServerEndpoint(
    ServerEndPoint epoint
)
Protected Friend Overrides Sub CloseServerEndpoint (
    epoint As ServerEndPoint
)
Protected Friend Overrides Sub CloseServerEndpoint (
    epoint As ServerEndPoint
)
protected public:
virtual void CloseServerEndpoint(
    ServerEndPoint^ epoint
) override
protected public:
virtual void CloseServerEndpoint(
    ServerEndPoint^ epoint
) override
abstract CloseServerEndpoint :
        epoint : ServerEndPoint -> unit
override CloseServerEndpoint :
        epoint : ServerEndPoint -> unit
abstract CloseServerEndpoint :
        epoint : ServerEndPoint -> unit
override CloseServerEndpoint :
        epoint : ServerEndPoint -> unit

Parameters

epoint
Type: NFX.Glue ServerEndPoint
See Also
InProcBinding Class
InProcBinding Members
NFX.Glue.Native Namespace


InProcBinding.MakeNewClientTransport Method

InProcBinding MakeNewClientTransport Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override ClientTransport MakeNewClientTransport(
    ClientEndPoint client
)
protected override ClientTransport MakeNewClientTransport(
    ClientEndPoint client
)
Protected Overrides Function MakeNewClientTransport (
    client As ClientEndPoint
) As ClientTransport
Protected Overrides Function MakeNewClientTransport (
    client As ClientEndPoint
) As ClientTransport
protected:
virtual ClientTransport^ MakeNewClientTransport(
    ClientEndPoint^ client
) override
protected:
virtual ClientTransport^ MakeNewClientTransport(
    ClientEndPoint^ client
) override
abstract MakeNewClientTransport :
        client : ClientEndPoint -> ClientTransport
override MakeNewClientTransport :
        client : ClientEndPoint -> ClientTransport
abstract MakeNewClientTransport :
        client : ClientEndPoint -> ClientTransport
override MakeNewClientTransport :
        client : ClientEndPoint -> ClientTransport

Parameters

client
Type: NFX.Glue ClientEndPoint

Return Value

Type: ClientTransport
See Also
InProcBinding Class
InProcBinding Members
NFX.Glue.Native Namespace


InProcBinding.OpenServerEndpoint Method

InProcBinding OpenServerEndpoint Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override ServerTransport OpenServerEndpoint(
    ServerEndPoint epoint
)
protected internal override ServerTransport OpenServerEndpoint(
    ServerEndPoint epoint
)
Protected Friend Overrides Function OpenServerEndpoint (
    epoint As ServerEndPoint
) As ServerTransport
Protected Friend Overrides Function OpenServerEndpoint (
    epoint As ServerEndPoint
) As ServerTransport
protected public:
virtual ServerTransport^ OpenServerEndpoint(
    ServerEndPoint^ epoint
) override
protected public:
virtual ServerTransport^ OpenServerEndpoint(
    ServerEndPoint^ epoint
) override
abstract OpenServerEndpoint :
        epoint : ServerEndPoint -> ServerTransport
override OpenServerEndpoint :
        epoint : ServerEndPoint -> ServerTransport
abstract OpenServerEndpoint :
        epoint : ServerEndPoint -> ServerTransport
override OpenServerEndpoint :
        epoint : ServerEndPoint -> ServerTransport

Parameters

epoint
Type: NFX.Glue ServerEndPoint

Return Value

Type: ServerTransport
See Also
InProcBinding Class
InProcBinding Members
NFX.Glue.Native Namespace


InProcBinding.ReleaseClientTransportAfterCall Method

InProcBinding ReleaseClientTransportAfterCall Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void ReleaseClientTransportAfterCall(
    ClientTransport transport
)
protected internal override void ReleaseClientTransportAfterCall(
    ClientTransport transport
)
Protected Friend Overrides Sub ReleaseClientTransportAfterCall (
    transport As ClientTransport
)
Protected Friend Overrides Sub ReleaseClientTransportAfterCall (
    transport As ClientTransport
)
protected public:
virtual void ReleaseClientTransportAfterCall(
    ClientTransport^ transport
) override
protected public:
virtual void ReleaseClientTransportAfterCall(
    ClientTransport^ transport
) override
abstract ReleaseClientTransportAfterCall :
        transport : ClientTransport -> unit
override ReleaseClientTransportAfterCall :
        transport : ClientTransport -> unit
abstract ReleaseClientTransportAfterCall :
        transport : ClientTransport -> unit
override ReleaseClientTransportAfterCall :
        transport : ClientTransport -> unit

Parameters

transport
Type: NFX.Glue ClientTransport
See Also
InProcBinding Class
InProcBinding Members
NFX.Glue.Native Namespace


InProcBinding Properties

InProcBinding Properties NFX Class Library

The InProcBinding type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ClientDump | Turns on/off client message dumping to disk. Turning on dumping has negative effect on performance and consumes resources (Inherited from Binding.)
Public property | ClientMsgInspectors | Returns client message inspectors for this instance (Inherited from Binding.)
Public property | ClientTransportCountWaitThreshold | Sets the threshold, expressed as the number of active client transports per remote address, below which binding will always allocate a new instance of client transport without trying/waiting to acquire an existing one. When this number is exceeded then binding will try to acquire an existing client transport instance for up to ClientTransportExistingAcquisitionTimeoutMs milliseconds. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ClientTransportExistingAcquisitionTimeoutMs | Sets the length of interval for the binding trying to acquire existing client transport instance to make a call. When this interval is exhausted then binding tries to allocate a new client transport per remote address, unless other limits prohibit (max transport count). The value has to be greater or equal to zero. NOTE: this property works in conjunction with ClientTransportCoutWaitThreshold, if the number of active client transports is below ClientTransportCoutWaitThreshold, then binding does not wait and allocates a new client transport right away until ClientTransportCoutWaitThreshold limit is reached, then binding will try to acquire existing transport for ClientTransportExistingAcquisitionTimeoutMs milliseconds. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ClientTransportIdleTimeoutMs | Specifies when client transports get auto-closed. Interval is measured in ms. Zero means indefinite/never closed transport. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ClientTransportMaxCount | Imposes a limit on number of active client transports per remote address. Once this limit is reached the binding will block until it can acquire an existing transport instance. Set value to zero to remove the limit. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ClientTransportMaxExistingAcquisitionTimeoutMs | Imposes a timeout for binding trying to get an existing transport instance per remote address. Binding throws ClientCallException when this timeout is exceeded. A value of zero removes the limit (Inherited from Binding.)
Public property | ClientTransports | Returns all client transports in the binding stack (Inherited from Binding.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | ConfigNode | Returns configuration node for this named instance (Inherited from Binding.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | DumpMsgFormat | Set the format for message dumping (Inherited from Binding.)
Public property | DumpPath | Set the path for message dumping. Must be an existing navigable path (Inherited from Binding.)
Public property | EncodingFormat | (Overrides Binding EncodingFormat.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | Glue | (Inherited from GlueComponentService.)
Public property | InstrumentationEnabled | Implements IInstrumentable (Inherited from GlueComponentService.)
Public property | InstrumentClientTransportStat | Defines whether client transport statistics is periodically dumped into instrumentation (Inherited from Binding.)
Public property | InstrumentServerTransportStat | Defines whether server transport statistics is periodically dumped into instrumentation (Inherited from Binding.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | MeasureStatTimes | Defines whether message processing latency should be measured - i.e. messages time-stamped on arrival (Inherited from Binding.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | OperationFlow | InProc binding is synchronous by definition (Overrides Binding OperationFlow.)
Public property | Provider | (Inherited from Binding.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | ServerDump | Turns on/off server message dumping to disk. Turning on dumping has negative effect on performance and consumes resources (Inherited from Binding.)
Public property | ServerMsgInspectors | Returns server message inspectors for this instance (Inherited from Binding.)
Public property | ServerTransportIdleTimeoutMs | Specifies when server transports get auto-closed. Interval is measured in ms. Zero means indefinite/never closed transport. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ServerTransports | Returns all server transports in the binding stack (Inherited from Binding.)
Public property | StatTimesEMAFactor | Defines how much smoothing the timing statistics filter does - the lower the number the more smoothing is done. Smoothing makes stat times insensitive to some seldom delays that may happen every now and then (Inherited from Binding.)
Public property | StatTimeTicks | Returns current time in system frequency-dependent ticks. This property is used to measure accurate times and depends on MeasureStatTimes set to true, otherwise 0 is returned (Inherited from Binding.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | Transports | Returns all transports in the binding stack (Inherited from Binding.)
Back to Top
See Also
InProcBinding Class
NFX.Glue.Native Namespace


InProcBinding.EncodingFormat Property

InProcBinding EncodingFormat Property NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string EncodingFormat { get; }
public override string EncodingFormat { get; }
Public Overrides ReadOnly Property EncodingFormat As String
    Get
Public Overrides ReadOnly Property EncodingFormat As String
    Get
public:
virtual property String^ EncodingFormat {
    String^ get () override;
}
public:
virtual property String^ EncodingFormat {
    String^ get () override;
}
abstract EncodingFormat : string with get
override EncodingFormat : string with get
abstract EncodingFormat : string with get
override EncodingFormat : string with get

Property Value

Type: Online String
See Also
InProcBinding Class
InProcBinding Members
NFX.Glue.Native Namespace


InProcBinding.OperationFlow Property

InProcBinding OperationFlow Property NFX Class Library

InProc binding is synchronous by definition

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override OperationFlow OperationFlow { get; }
public override OperationFlow OperationFlow { get; }
Public Overrides ReadOnly Property OperationFlow As OperationFlow
    Get
Public Overrides ReadOnly Property OperationFlow As OperationFlow
    Get
public:
virtual property OperationFlow OperationFlow {
    OperationFlow get () override;
}
public:
virtual property OperationFlow OperationFlow {
    OperationFlow get () override;
}
abstract OperationFlow : OperationFlow with get
override OperationFlow : OperationFlow with get
abstract OperationFlow : OperationFlow with get
override OperationFlow : OperationFlow with get

Property Value

Type: OperationFlow
See Also
InProcBinding Class
InProcBinding Members
NFX.Glue.Native Namespace


InProcClientTransport Class

InProcClientTransport Class NFX Class Library

Provides client-side functionality for synchronous communication pattern based on in-memory message exchange without serialization
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service Binding
NFX.Glue Transport
NFX.Glue ClientTransport
NFX.Glue ClientTransport InProcBinding
NFX.Glue.Native InProcClientTransport

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class InProcClientTransport : ClientTransport<InProcBinding>
public class InProcClientTransport : ClientTransport<InProcBinding>
Public Class InProcClientTransport
    Inherits ClientTransport(Of InProcBinding)
Public Class InProcClientTransport
    Inherits ClientTransport(Of InProcBinding)
public ref class InProcClientTransport : public ClientTransport<InProcBinding^>
public ref class InProcClientTransport : public ClientTransport<InProcBinding^>
type InProcClientTransport =
    class
        inherit ClientTransport<InProcBinding>
    end
type InProcClientTransport =
    class
        inherit ClientTransport<InProcBinding>
    end
See Also
InProcClientTransport Members
NFX.Glue.Native Namespace


InProcClientTransport Members

InProcClientTransport Members NFX Class Library

The InProcClientTransport type exposes the following members.
Constructors
 | Name | Description
Public method | InProcClientTransport | Initializes a new instance of the InProcClientTransport class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and transport instance are running or throws otherwise (Inherited from Transport.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Transport.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoDumpInstrumentationData | Override to dump instrumentation data, dont forget to call base to dump basic metrics (Inherited from Transport.)
Protected method | DoSendRequest | (Overrides ClientTransport DoSendRequest(ClientEndPoint, RequestMsg, CallOptions).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Inherited from Transport.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | DumpInstrumentationData | Dumps instrumentation data (Inherited from Transport.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Release | Releases transport by setting Acquired flag to false so it can be used by other operations (Inherited from Transport.)
Public method | ResetStats | Resets all statistical counters (Inherited from Transport.)
Public method | SendRequest | Sends a client request into remote endpoint. This is a blocking call for bindings that are OperationFlow.Synchronous and result arrives immediately into CallSlot. (Inherited from ClientTransport.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Protected method | stat_BytesReceived | (Inherited from Transport.)
Protected method | stat_BytesSent | (Inherited from Transport.)
Protected method | stat_Errors | (Inherited from Transport.)
Protected method | stat_MsgReceived | (Inherited from Transport.)
Protected method | stat_MsgSent | (Inherited from Transport.)
Protected method | stat_Time | Processes named time measurement statistical sample by using EMA filter (Inherited from Transport.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryAcquire | A thread-safe operation that tries to acquire(reserve) this instance for exclusive use. Returns true if acqusition succeded, false is this instance is reserved by someone else (Inherited from Transport.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_TransportKind | (Inherited from Transport.)
Back to Top
Properties
 | Name | Description
Public property | Acquired | Returns true when this transport instance has been acquired by some operation and is busy (Inherited from Transport.)
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | Binding | (Inherited from ClientTransport TBinding .)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExpirationStart | Returns timestamp when manager touched the instance for last time and no traffic went through it since (Inherited from Transport.)
Public property | Glue | Returns glue implementation that this transport is under (Inherited from Transport.)
Public property | IdleAgeMs | Returns the duration of transport idle period in ms. (Inherited from Transport.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Node | Returns node that this transport services (Inherited from Transport.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | StatBytesReceived | Returns how many bytes were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatBytesSent | Returns how many bytes were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatErrors | Returns how many message processing errors happened since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgReceived | Returns how many messages were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgSent | Returns how many messages were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatTimes | Returns enumerable of named times measured in double second fractions. The returned times are EMA-filtered from supplied individual measurement samples (Inherited from Transport.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransportKind | Reports if this is a server or client transport (Inherited from Transport.)
Back to Top
See Also
InProcClientTransport Class
NFX.Glue.Native Namespace


InProcClientTransport Constructor

InProcClientTransport Constructor NFX Class Library

Initializes a new instance of the InProcClientTransport class

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InProcClientTransport(
    InProcBinding binding,
    Node node
)
public InProcClientTransport(
    InProcBinding binding,
    Node node
)
Public Sub New (
    binding As InProcBinding,
    node As Node
)
Public Sub New (
    binding As InProcBinding,
    node As Node
)
public:
InProcClientTransport(
    InProcBinding^ binding,
    Node node
)
public:
InProcClientTransport(
    InProcBinding^ binding,
    Node node
)
new :
        binding : InProcBinding *
        node : Node -> InProcClientTransport
new :
        binding : InProcBinding *
        node : Node -> InProcClientTransport

Parameters

binding
Type: NFX.Glue.Native InProcBinding
node
Type: NFX.Glue Node
See Also
InProcClientTransport Class
InProcClientTransport Members
NFX.Glue.Native Namespace


InProcClientTransport Fields

InProcClientTransport Fields NFX Class Library

The InProcClientTransport type exposes the following members.
Fields
 | Name | Description
Protected field | m_TransportKind | (Inherited from Transport.)
Back to Top
See Also
InProcClientTransport Class
NFX.Glue.Native Namespace


InProcClientTransport Methods

InProcClientTransport Methods NFX Class Library

The InProcClientTransport type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and transport instance are running or throws otherwise (Inherited from Transport.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Transport.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoDumpInstrumentationData | Override to dump instrumentation data, dont forget to call base to dump basic metrics (Inherited from Transport.)
Protected method | DoSendRequest | (Overrides ClientTransport DoSendRequest(ClientEndPoint, RequestMsg, CallOptions).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Inherited from Transport.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | DumpInstrumentationData | Dumps instrumentation data (Inherited from Transport.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Release | Releases transport by setting Acquired flag to false so it can be used by other operations (Inherited from Transport.)
Public method | ResetStats | Resets all statistical counters (Inherited from Transport.)
Public method | SendRequest | Sends a client request into remote endpoint. This is a blocking call for bindings that are OperationFlow.Synchronous and result arrives immediately into CallSlot. (Inherited from ClientTransport.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Protected method | stat_BytesReceived | (Inherited from Transport.)
Protected method | stat_BytesSent | (Inherited from Transport.)
Protected method | stat_Errors | (Inherited from Transport.)
Protected method | stat_MsgReceived | (Inherited from Transport.)
Protected method | stat_MsgSent | (Inherited from Transport.)
Protected method | stat_Time | Processes named time measurement statistical sample by using EMA filter (Inherited from Transport.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryAcquire | A thread-safe operation that tries to acquire(reserve) this instance for exclusive use. Returns true if acqusition succeded, false is this instance is reserved by someone else (Inherited from Transport.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
InProcClientTransport Class
NFX.Glue.Native Namespace


InProcClientTransport.DoSendRequest Method

InProcClientTransport DoSendRequest Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override CallSlot DoSendRequest(
    ClientEndPoint endpoint,
    RequestMsg request,
    CallOptions options
)
protected override CallSlot DoSendRequest(
    ClientEndPoint endpoint,
    RequestMsg request,
    CallOptions options
)
Protected Overrides Function DoSendRequest (
    endpoint As ClientEndPoint,
    request As RequestMsg,
    options As CallOptions
) As CallSlot
Protected Overrides Function DoSendRequest (
    endpoint As ClientEndPoint,
    request As RequestMsg,
    options As CallOptions
) As CallSlot
protected:
virtual CallSlot^ DoSendRequest(
    ClientEndPoint^ endpoint,
    RequestMsg^ request,
    CallOptions options
) override
protected:
virtual CallSlot^ DoSendRequest(
    ClientEndPoint^ endpoint,
    RequestMsg^ request,
    CallOptions options
) override
abstract DoSendRequest :
        endpoint : ClientEndPoint *
        request : RequestMsg *
        options : CallOptions -> CallSlot
override DoSendRequest :
        endpoint : ClientEndPoint *
        request : RequestMsg *
        options : CallOptions -> CallSlot
abstract DoSendRequest :
        endpoint : ClientEndPoint *
        request : RequestMsg *
        options : CallOptions -> CallSlot
override DoSendRequest :
        endpoint : ClientEndPoint *
        request : RequestMsg *
        options : CallOptions -> CallSlot

Parameters

endpoint
Type: NFX.Glue ClientEndPoint
request
Type: NFX.Glue.Protocol RequestMsg
options
Type: NFX.Glue.Protocol CallOptions

Return Value

Type: CallSlot
See Also
InProcClientTransport Class
InProcClientTransport Members
NFX.Glue.Native Namespace


InProcClientTransport Properties

InProcClientTransport Properties NFX Class Library

The InProcClientTransport type exposes the following members.
Properties
 | Name | Description
Public property | Acquired | Returns true when this transport instance has been acquired by some operation and is busy (Inherited from Transport.)
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | Binding | (Inherited from ClientTransport TBinding .)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExpirationStart | Returns timestamp when manager touched the instance for last time and no traffic went through it since (Inherited from Transport.)
Public property | Glue | Returns glue implementation that this transport is under (Inherited from Transport.)
Public property | IdleAgeMs | Returns the duration of transport idle period in ms. (Inherited from Transport.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Node | Returns node that this transport services (Inherited from Transport.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | StatBytesReceived | Returns how many bytes were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatBytesSent | Returns how many bytes were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatErrors | Returns how many message processing errors happened since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgReceived | Returns how many messages were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgSent | Returns how many messages were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatTimes | Returns enumerable of named times measured in double second fractions. The returned times are EMA-filtered from supplied individual measurement samples (Inherited from Transport.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransportKind | Reports if this is a server or client transport (Inherited from Transport.)
Back to Top
See Also
InProcClientTransport Class
NFX.Glue.Native Namespace


InProcServerTransport Class

InProcServerTransport Class NFX Class Library

Provides server-side functionality for synchronous communication pattern based on in-memory message exchange without serialization
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service Binding
NFX.Glue Transport
NFX.Glue ServerTransport
NFX.Glue ServerTransport InProcBinding
NFX.Glue.Native InProcServerTransport

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class InProcServerTransport : ServerTransport<InProcBinding>
public class InProcServerTransport : ServerTransport<InProcBinding>
Public Class InProcServerTransport
    Inherits ServerTransport(Of InProcBinding)
Public Class InProcServerTransport
    Inherits ServerTransport(Of InProcBinding)
public ref class InProcServerTransport : public ServerTransport<InProcBinding^>
public ref class InProcServerTransport : public ServerTransport<InProcBinding^>
type InProcServerTransport =
    class
        inherit ServerTransport<InProcBinding>
    end
type InProcServerTransport =
    class
        inherit ServerTransport<InProcBinding>
    end
See Also
InProcServerTransport Members
NFX.Glue.Native Namespace


InProcServerTransport Members

InProcServerTransport Members NFX Class Library

The InProcServerTransport type exposes the following members.
Constructors
 | Name | Description
Public method | InProcServerTransport | Initializes a new instance of the InProcServerTransport class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and transport instance are running or throws otherwise (Inherited from Transport.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Transport.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoDumpInstrumentationData | Override to dump instrumentation data, dont forget to call base to dump basic metrics (Inherited from Transport.)
Protected method | DoSendResponse | (Overrides ServerTransport DoSendResponse(ResponseMsg).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Inherited from Transport.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | DumpInstrumentationData | Dumps instrumentation data (Inherited from Transport.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Release | Releases transport by setting Acquired flag to false so it can be used by other operations (Inherited from Transport.)
Public method | ResetStats | Resets all statistical counters (Inherited from Transport.)
Public method | SendResponse | Sends a response into remote client endpoint (Inherited from ServerTransport.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Protected method | stat_BytesReceived | (Inherited from Transport.)
Protected method | stat_BytesSent | (Inherited from Transport.)
Protected method | stat_Errors | (Inherited from Transport.)
Protected method | stat_MsgReceived | (Inherited from Transport.)
Protected method | stat_MsgSent | (Inherited from Transport.)
Protected method | stat_Time | Processes named time measurement statistical sample by using EMA filter (Inherited from Transport.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryAcquire | A thread-safe operation that tries to acquire(reserve) this instance for exclusive use. Returns true if acqusition succeded, false is this instance is reserved by someone else (Inherited from Transport.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_TransportKind | (Inherited from Transport.)
Back to Top
Properties
 | Name | Description
Public property | Acquired | Returns true when this transport instance has been acquired by some operation and is busy (Inherited from Transport.)
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | Binding | (Inherited from ServerTransport TBinding .)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExpirationStart | Returns timestamp when manager touched the instance for last time and no traffic went through it since (Inherited from Transport.)
Public property | Glue | Returns glue implementation that this transport is under (Inherited from Transport.)
Public property | IdleAgeMs | Returns the duration of transport idle period in ms. (Inherited from Transport.)
Public property | IsListener | Indicates whether this instance is the one that accepts connections. Depending on implementation listeners may allocate other transports after they accept incoming connect request (i.e. TCP) (Inherited from ServerTransport.)
Public property | Listener | Returns a listener transport that opened this one. If this is a listener transport then returns null. Not all technologies support listener/child transports (TCP does) (Inherited from ServerTransport.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Node | Returns node that this transport services (Inherited from Transport.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | ServerEndpoint | Returns server endpoint instance that opened this transport (Inherited from ServerTransport.)
Public property | StatBytesReceived | Returns how many bytes were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatBytesSent | Returns how many bytes were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatErrors | Returns how many message processing errors happened since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgReceived | Returns how many messages were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgSent | Returns how many messages were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatTimes | Returns enumerable of named times measured in double second fractions. The returned times are EMA-filtered from supplied individual measurement samples (Inherited from Transport.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransportKind | Reports if this is a server or client transport (Inherited from Transport.)
Back to Top
See Also
InProcServerTransport Class
NFX.Glue.Native Namespace


InProcServerTransport Constructor

InProcServerTransport Constructor NFX Class Library

Initializes a new instance of the InProcServerTransport class

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InProcServerTransport(
    InProcBinding binding,
    ServerEndPoint serverEndpoint
)
public InProcServerTransport(
    InProcBinding binding,
    ServerEndPoint serverEndpoint
)
Public Sub New (
    binding As InProcBinding,
    serverEndpoint As ServerEndPoint
)
Public Sub New (
    binding As InProcBinding,
    serverEndpoint As ServerEndPoint
)
public:
InProcServerTransport(
    InProcBinding^ binding,
    ServerEndPoint^ serverEndpoint
)
public:
InProcServerTransport(
    InProcBinding^ binding,
    ServerEndPoint^ serverEndpoint
)
new :
        binding : InProcBinding *
        serverEndpoint : ServerEndPoint -> InProcServerTransport
new :
        binding : InProcBinding *
        serverEndpoint : ServerEndPoint -> InProcServerTransport

Parameters

binding
Type: NFX.Glue.Native InProcBinding
serverEndpoint
Type: NFX.Glue ServerEndPoint
See Also
InProcServerTransport Class
InProcServerTransport Members
NFX.Glue.Native Namespace


InProcServerTransport Fields

InProcServerTransport Fields NFX Class Library

The InProcServerTransport type exposes the following members.
Fields
 | Name | Description
Protected field | m_TransportKind | (Inherited from Transport.)
Back to Top
See Also
InProcServerTransport Class
NFX.Glue.Native Namespace


InProcServerTransport Methods

InProcServerTransport Methods NFX Class Library

The InProcServerTransport type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and transport instance are running or throws otherwise (Inherited from Transport.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Transport.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoDumpInstrumentationData | Override to dump instrumentation data, dont forget to call base to dump basic metrics (Inherited from Transport.)
Protected method | DoSendResponse | (Overrides ServerTransport DoSendResponse(ResponseMsg).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Inherited from Transport.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | DumpInstrumentationData | Dumps instrumentation data (Inherited from Transport.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Release | Releases transport by setting Acquired flag to false so it can be used by other operations (Inherited from Transport.)
Public method | ResetStats | Resets all statistical counters (Inherited from Transport.)
Public method | SendResponse | Sends a response into remote client endpoint (Inherited from ServerTransport.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Protected method | stat_BytesReceived | (Inherited from Transport.)
Protected method | stat_BytesSent | (Inherited from Transport.)
Protected method | stat_Errors | (Inherited from Transport.)
Protected method | stat_MsgReceived | (Inherited from Transport.)
Protected method | stat_MsgSent | (Inherited from Transport.)
Protected method | stat_Time | Processes named time measurement statistical sample by using EMA filter (Inherited from Transport.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryAcquire | A thread-safe operation that tries to acquire(reserve) this instance for exclusive use. Returns true if acqusition succeded, false is this instance is reserved by someone else (Inherited from Transport.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
InProcServerTransport Class
NFX.Glue.Native Namespace


InProcServerTransport.DoSendResponse Method

InProcServerTransport DoSendResponse Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool DoSendResponse(
    ResponseMsg response
)
protected override bool DoSendResponse(
    ResponseMsg response
)
Protected Overrides Function DoSendResponse (
    response As ResponseMsg
) As Boolean
Protected Overrides Function DoSendResponse (
    response As ResponseMsg
) As Boolean
protected:
virtual bool DoSendResponse(
    ResponseMsg^ response
) override
protected:
virtual bool DoSendResponse(
    ResponseMsg^ response
) override
abstract DoSendResponse :
        response : ResponseMsg -> bool
override DoSendResponse :
        response : ResponseMsg -> bool
abstract DoSendResponse :
        response : ResponseMsg -> bool
override DoSendResponse :
        response : ResponseMsg -> bool

Parameters

response
Type: NFX.Glue.Protocol ResponseMsg

Return Value

Type: Online Boolean
See Also
InProcServerTransport Class
InProcServerTransport Members
NFX.Glue.Native Namespace


InProcServerTransport Properties

InProcServerTransport Properties NFX Class Library

The InProcServerTransport type exposes the following members.
Properties
 | Name | Description
Public property | Acquired | Returns true when this transport instance has been acquired by some operation and is busy (Inherited from Transport.)
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | Binding | (Inherited from ServerTransport TBinding .)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExpirationStart | Returns timestamp when manager touched the instance for last time and no traffic went through it since (Inherited from Transport.)
Public property | Glue | Returns glue implementation that this transport is under (Inherited from Transport.)
Public property | IdleAgeMs | Returns the duration of transport idle period in ms. (Inherited from Transport.)
Public property | IsListener | Indicates whether this instance is the one that accepts connections. Depending on implementation listeners may allocate other transports after they accept incoming connect request (i.e. TCP) (Inherited from ServerTransport.)
Public property | Listener | Returns a listener transport that opened this one. If this is a listener transport then returns null. Not all technologies support listener/child transports (TCP does) (Inherited from ServerTransport.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Node | Returns node that this transport services (Inherited from Transport.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | ServerEndpoint | Returns server endpoint instance that opened this transport (Inherited from ServerTransport.)
Public property | StatBytesReceived | Returns how many bytes were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatBytesSent | Returns how many bytes were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatErrors | Returns how many message processing errors happened since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgReceived | Returns how many messages were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgSent | Returns how many messages were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatTimes | Returns enumerable of named times measured in double second fractions. The returned times are EMA-filtered from supplied individual measurement samples (Inherited from Transport.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransportKind | Reports if this is a server or client transport (Inherited from Transport.)
Back to Top
See Also
InProcServerTransport Class
NFX.Glue.Native Namespace


MemChunk Class

MemChunk Class NFX Class Library

Represents a stream/writable chunk of memory backed by an array buffer
Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.IO Stream
Online System.IO MemoryStream
NFX.Glue.Native MemChunk

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MemChunk : MemoryStream
public class MemChunk : MemoryStream
Public Class MemChunk
    Inherits MemoryStream
Public Class MemChunk
    Inherits MemoryStream
public ref class MemChunk : public MemoryStream
public ref class MemChunk : public MemoryStream
type MemChunk =
    class
        inherit MemoryStream
    end
type MemChunk =
    class
        inherit MemoryStream
    end
See Also
MemChunk Members
NFX.Glue.Native Namespace


MemChunk Members

MemChunk Members NFX Class Library

The MemChunk type exposes the following members.
Constructors
 | Name | Description
Public method | MemChunk | Initializes a new instance of the MemChunk class
Back to Top
Methods
 | Name | Description
Public method | Online BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads all the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Online MemoryStream.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Protected method | Online CreateWaitHandle | Obsolete. Allocates a Online WaitHandle object. (Inherited from Online Stream.)
Public method | Online Dispose | Releases all resources used by the Online Stream. (Inherited from Online Stream.)
Protected method | Online Dispose(Boolean) | Releases the unmanaged resources used by the Online MemoryStream class and optionally releases the managed resources. (Inherited from Online MemoryStream.)
Public method | Online EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Flush | Overrides the Online Flush method so that no action is performed. (Inherited from Online MemoryStream.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Online Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, and monitors cancellation requests. (Inherited from Online MemoryStream.)
Public method | Online GetBuffer | Returns the array of unsigned bytes from which this stream was created. (Inherited from Online MemoryStream.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Online Stream.)
Public method | Online Read | Reads a block of bytes from the current stream and writes the data to a buffer. (Inherited from Online MemoryStream.)
Public method | ReadAsync( Byte , Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Online Stream.)
Public method | ReadAsync( Byte , Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Online MemoryStream.)
Public method | Online ReadByte | Reads a byte from the current stream. (Inherited from Online MemoryStream.)
Public method | Online Seek | Sets the position within the current stream to the specified value. (Inherited from Online MemoryStream.)
Public method | Online SetLength | Sets the length of the current stream to the specified value. (Inherited from Online MemoryStream.)
Public method | Online ToArray | Writes the stream contents to a byte array, regardless of the Online Position property. (Inherited from Online MemoryStream.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online Write | Writes a block of bytes to the current stream using data read from a buffer. (Inherited from Online MemoryStream.)
Public method | WriteAsync( Byte , Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Online Stream.)
Public method | WriteAsync( Byte , Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Online MemoryStream.)
Public method | Online WriteByte | Writes a byte to the current stream at the current position. (Inherited from Online MemoryStream.)
Public method | Online WriteTo | Writes the entire contents of this memory stream to another stream. (Inherited from Online MemoryStream.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsCharEnumerable | (Defined by IOMiscUtils.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Public Extension Method | ReadBEInt32 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEShort | Reads a short encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUInt64 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUShort | Reads an ushort encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadSLEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadSLEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | WriteBEInt32 | Writes an integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEShort | Writes a short encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUInt64 | Writes an unsigned long integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUShort | Writes an ushort encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteSLEB128(Int64, Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteSLEB128(Int64, Int32 , Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, UInt32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, Int32 , UInt32) | Overloaded. (Defined by LEB128.)
Back to Top
Fields
 | Name | Description
Protected field | _LastReleaseUtc | Whan was the chunk released to the pool for the last time
Protected field | Acquired | True if chunk is taken out of pool by some socket
Protected field | stat_MaxLength | Used for statistics/tracking
Protected field | stat_MaxUsedPosition | Used for statistics/tracking
Back to Top
Properties
 | Name | Description
Public property | Online CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from Online MemoryStream.)
Public property | Online CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from Online MemoryStream.)
Public property | Online CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Online Stream.)
Public property | Online CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from Online MemoryStream.)
Public property | Online Capacity | Gets or sets the number of bytes allocated for this stream. (Inherited from Online MemoryStream.)
Public property | Online Length | Gets the length of the stream in bytes. (Inherited from Online MemoryStream.)
Public property | Online Position | Gets or sets the current position within the stream. (Inherited from Online MemoryStream.)
Public property | Online ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Online Stream.)
Public property | Online WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Online Stream.)
Back to Top
See Also
MemChunk Class
NFX.Glue.Native Namespace


MemChunk Constructor

MemChunk Constructor NFX Class Library

Initializes a new instance of the MemChunk class

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MemChunk(
    int capacity
)
public MemChunk(
    int capacity
)
Public Sub New (
    capacity As Integer
)
Public Sub New (
    capacity As Integer
)
public:
MemChunk(
    int capacity
)
public:
MemChunk(
    int capacity
)
new :
        capacity : int -> MemChunk
new :
        capacity : int -> MemChunk

Parameters

capacity
Type: Online System Int32
See Also
MemChunk Class
MemChunk Members
NFX.Glue.Native Namespace


MemChunk Fields

MemChunk Fields NFX Class Library

The MemChunk type exposes the following members.
Fields
 | Name | Description
Protected field | _LastReleaseUtc | Whan was the chunk released to the pool for the last time
Protected field | Acquired | True if chunk is taken out of pool by some socket
Protected field | stat_MaxLength | Used for statistics/tracking
Protected field | stat_MaxUsedPosition | Used for statistics/tracking
Back to Top
See Also
MemChunk Class
NFX.Glue.Native Namespace


MemChunk._LastReleaseUtc Field

MemChunk _LastReleaseUtc Field NFX Class Library

Whan was the chunk released to the pool for the last time

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal DateTime _LastReleaseUtc
internal DateTime _LastReleaseUtc
Friend _LastReleaseUtc As DateTime
Friend _LastReleaseUtc As DateTime
internal:
DateTime _LastReleaseUtc
internal:
DateTime _LastReleaseUtc
val mutable internal _LastReleaseUtc: DateTime
val mutable internal _LastReleaseUtc: DateTime

Field Value

Type: Online DateTime
See Also
MemChunk Class
MemChunk Members
NFX.Glue.Native Namespace


MemChunk.Acquired Field

MemChunk Acquired Field NFX Class Library

True if chunk is taken out of pool by some socket

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal bool Acquired
internal bool Acquired
Friend Acquired As Boolean
Friend Acquired As Boolean
internal:
bool Acquired
internal:
bool Acquired
val mutable internal Acquired: bool
val mutable internal Acquired: bool

Field Value

Type: Online Boolean
See Also
MemChunk Class
MemChunk Members
NFX.Glue.Native Namespace


MemChunk.stat_MaxLength Field

MemChunk stat_MaxLength Field NFX Class Library

Used for statistics/tracking

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int stat_MaxLength
internal int stat_MaxLength
Friend stat_MaxLength As Integer
Friend stat_MaxLength As Integer
internal:
int stat_MaxLength
internal:
int stat_MaxLength
val mutable internal stat_MaxLength: int
val mutable internal stat_MaxLength: int

Field Value

Type: Online Int32
See Also
MemChunk Class
MemChunk Members
NFX.Glue.Native Namespace


MemChunk.stat_MaxUsedPosition Field

MemChunk stat_MaxUsedPosition Field NFX Class Library

Used for statistics/tracking

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int stat_MaxUsedPosition
internal int stat_MaxUsedPosition
Friend stat_MaxUsedPosition As Integer
Friend stat_MaxUsedPosition As Integer
internal:
int stat_MaxUsedPosition
internal:
int stat_MaxUsedPosition
val mutable internal stat_MaxUsedPosition: int
val mutable internal stat_MaxUsedPosition: int

Field Value

Type: Online Int32
See Also
MemChunk Class
MemChunk Members
NFX.Glue.Native Namespace


MemChunk Methods

MemChunk Methods NFX Class Library

The MemChunk type exposes the following members.
Methods
 | Name | Description
Public method | Online BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads all the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Online MemoryStream.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Protected method | Online CreateWaitHandle | Obsolete. Allocates a Online WaitHandle object. (Inherited from Online Stream.)
Public method | Online Dispose | Releases all resources used by the Online Stream. (Inherited from Online Stream.)
Protected method | Online Dispose(Boolean) | Releases the unmanaged resources used by the Online MemoryStream class and optionally releases the managed resources. (Inherited from Online MemoryStream.)
Public method | Online EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Flush | Overrides the Online Flush method so that no action is performed. (Inherited from Online MemoryStream.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Online Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, and monitors cancellation requests. (Inherited from Online MemoryStream.)
Public method | Online GetBuffer | Returns the array of unsigned bytes from which this stream was created. (Inherited from Online MemoryStream.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Online Stream.)
Public method | Online Read | Reads a block of bytes from the current stream and writes the data to a buffer. (Inherited from Online MemoryStream.)
Public method | ReadAsync( Byte , Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Online Stream.)
Public method | ReadAsync( Byte , Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Online MemoryStream.)
Public method | Online ReadByte | Reads a byte from the current stream. (Inherited from Online MemoryStream.)
Public method | Online Seek | Sets the position within the current stream to the specified value. (Inherited from Online MemoryStream.)
Public method | Online SetLength | Sets the length of the current stream to the specified value. (Inherited from Online MemoryStream.)
Public method | Online ToArray | Writes the stream contents to a byte array, regardless of the Online Position property. (Inherited from Online MemoryStream.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online Write | Writes a block of bytes to the current stream using data read from a buffer. (Inherited from Online MemoryStream.)
Public method | WriteAsync( Byte , Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Online Stream.)
Public method | WriteAsync( Byte , Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Online MemoryStream.)
Public method | Online WriteByte | Writes a byte to the current stream at the current position. (Inherited from Online MemoryStream.)
Public method | Online WriteTo | Writes the entire contents of this memory stream to another stream. (Inherited from Online MemoryStream.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsCharEnumerable | (Defined by IOMiscUtils.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Public Extension Method | ReadBEInt32 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEShort | Reads a short encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUInt64 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUShort | Reads an ushort encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadSLEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadSLEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | WriteBEInt32 | Writes an integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEShort | Writes a short encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUInt64 | Writes an unsigned long integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUShort | Writes an ushort encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteSLEB128(Int64, Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteSLEB128(Int64, Int32 , Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, UInt32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, Int32 , UInt32) | Overloaded. (Defined by LEB128.)
Back to Top
See Also
MemChunk Class
NFX.Glue.Native Namespace


MemChunk Properties

MemChunk Properties NFX Class Library

The MemChunk type exposes the following members.
Properties
 | Name | Description
Public property | Online CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from Online MemoryStream.)
Public property | Online CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from Online MemoryStream.)
Public property | Online CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Online Stream.)
Public property | Online CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from Online MemoryStream.)
Public property | Online Capacity | Gets or sets the number of bytes allocated for this stream. (Inherited from Online MemoryStream.)
Public property | Online Length | Gets the length of the stream in bytes. (Inherited from Online MemoryStream.)
Public property | Online Position | Gets or sets the current position within the stream. (Inherited from Online MemoryStream.)
Public property | Online ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Online Stream.)
Public property | Online WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Online Stream.)
Back to Top
See Also
MemChunk Class
NFX.Glue.Native Namespace


MpxBinding Class

MpxBinding Class NFX Class Library

Provides asynchronous communicating pattern based on asynchronous virtual socket. The concrete socket may be based on OS-supported technology i.e. - IO completion ports on Windows
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service IGlueImplementation
NFX.ServiceModel ServiceWithInstrumentationBase IGlueImplementation
NFX.Glue GlueComponentService
NFX.Glue Binding
NFX.Glue.Native MpxBinding

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class MpxBinding : Binding
public sealed class MpxBinding : Binding
Public NotInheritable Class MpxBinding
    Inherits Binding
Public NotInheritable Class MpxBinding
    Inherits Binding
public ref class MpxBinding sealed : public Binding
public ref class MpxBinding sealed : public Binding
[<SealedAttribute>]
type MpxBinding =
    class
        inherit Binding
    end
[<SealedAttribute>]
type MpxBinding =
    class
        inherit Binding
    end
See Also
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding Members

MpxBinding Members NFX Class Library

The MpxBinding type exposes the following members.
Constructors
 | Name | Description
Public method | MpxBinding(String) | Initializes a new instance of the MpxBinding class
Public method | MpxBinding(IGlueImplementation, String) | Initializes a new instance of the MpxBinding class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | _Register | (Inherited from Binding.)
Protected method | _Unregister | (Inherited from Binding.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Protected method | AcquireClientTransportForCall | Returns an instance of transport suitable for a call. The implementation may return existing transport or allocate a new instance. The call is thread-safe (Inherited from Binding.)
Public method | AreNodesIdentical | (Overrides Binding AreNodesIdentical(Node, Node).)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and binding runtime are running or throws otherwise (Inherited from Binding.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Protected method | CloseServerEndpoint | (Overrides Binding CloseServerEndpoint(ServerEndPoint).)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | ConfigureAndStartNewClientTransport | Override to perform custom transport preparation and launch (Inherited from Binding.)
Protected method | Destructor | (Inherited from Binding.)
Public method | DispatchCall | Dispatches a call allocating new or re-using existing transport if needed. The strategy depends on particular Binding implementation. This call is thread-safe (Inherited from Binding.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | (Overrides Binding DoAcceptManagerVisit(Object, DateTime).)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Binding DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | (Inherited from Binding.)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Binding DoWaitForCompleteStop .)
Protected method | DumpMsg(Boolean, Msg, ArraySegment Byte ) | Conditionally dumps message to disk (Inherited from Binding.)
Protected method | DumpMsg(Boolean, Msg, Func ArraySegment Byte ) | Conditionally dumps message to disk where the data is lazily obtained by calling dataFun (Inherited from Binding.)
Protected method | DumpMsg(Boolean, Msg, Byte , Int32, Int32) | Conditionally dumps message to disk (Inherited from Binding.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetClientCallStatTimeKey | Extracts necessary information from client:request pair that characterizes the particular call for the purpose of call timing (Inherited from Binding.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | MakeNewClientTransport | (Overrides Binding MakeNewClientTransport(ClientEndPoint).)
Protected method | MakeOrReuseChunk | Fetches available existing chunk from cache or creates a new one. Called by new sockets by incipient connections
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OpenServerEndpoint | (Overrides Binding OpenServerEndpoint(ServerEndPoint).)
Protected method | ReleaseChunk |
Protected method | ReleaseClientTransportAfterCall | Releases a transport instance that was acquired for call. The implementation may return this instance back to the pool of available transports or deallocate it. The default implementation releases the instance back to the pool (Inherited from Binding.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
 | ToIPEndPoint |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | TryGetExistingAcquiredTransportPerRemoteNode | Tries to acquire an available client transport to make a call. This method respects binding/transport settings that impose a limit on the number of open concurrent transports and timeouts for acqusition waiting (Inherited from Binding.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | WriteLog | (Inherited from GlueComponentService.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | CONFIG_SOCKET_FACTORY_SECT |
 | DEFAULT_IDLE_CHUNK_LIFE_SEC |
 | DEFAULT_MAX_CHUNK_POOL_COUNT |
 | DEFAULT_PORT |
 | DEFAULT_RCV_TIMEOUT |
 | DEFAULT_SND_TIMEOUT |
 | DEFAULT_SOCKET_LINGER_SEC |
Protected field | m_ClientTransportAllocatorLocks | Hash table of locks used during new transport allocation, must be prime size (Inherited from Binding.)
Protected field | m_Provider | (Inherited from Binding.)
Protected field | m_Transports | (Inherited from Binding.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ClientDump | Turns on/off client message dumping to disk. Turning on dumping has negative effect on performance and consumes resources (Inherited from Binding.)
Public property | ClientMsgInspectors | Returns client message inspectors for this instance (Inherited from Binding.)
Public property | ClientReceiveBufferSize |
Public property | ClientReceiveTimeout |
Public property | ClientSendBufferSize |
Public property | ClientSendTimeout |
Public property | ClientTransportCountWaitThreshold | Sets the threshold, expressed as the number of active client transports per remote address, below which binding will always allocate a new instance of client transport without trying/waiting to acquire an existing one. When this number is exceeded then binding will try to acquire an existing client transport instance for up to ClientTransportExistingAcquisitionTimeoutMs milliseconds. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ClientTransportExistingAcquisitionTimeoutMs | Sets the length of interval for the binding trying to acquire existing client transport instance to make a call. When this interval is exhausted then binding tries to allocate a new client transport per remote address, unless other limits prohibit (max transport count). The value has to be greater or equal to zero. NOTE: this property works in conjunction with ClientTransportCoutWaitThreshold, if the number of active client transports is below ClientTransportCoutWaitThreshold, then binding does not wait and allocates a new client transport right away until ClientTransportCoutWaitThreshold limit is reached, then binding will try to acquire existing transport for ClientTransportExistingAcquisitionTimeoutMs milliseconds. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ClientTransportIdleTimeoutMs | Specifies when client transports get auto-closed. Interval is measured in ms. Zero means indefinite/never closed transport. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ClientTransportMaxCount | Imposes a limit on number of active client transports per remote address. Once this limit is reached the binding will block until it can acquire an existing transport instance. Set value to zero to remove the limit. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ClientTransportMaxExistingAcquisitionTimeoutMs | Imposes a timeout for binding trying to get an existing transport instance per remote address. Binding throws ClientCallException when this timeout is exceeded. A value of zero removes the limit (Inherited from Binding.)
Public property | ClientTransports | Returns all client transports in the binding stack (Inherited from Binding.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | ConfigNode | Returns configuration node for this named instance (Inherited from Binding.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | DumpMsgFormat | Set the format for message dumping (Inherited from Binding.)
Public property | DumpPath | Set the path for message dumping. Must be an existing navigable path (Inherited from Binding.)
Public property | EncodingFormat | (Overrides Binding EncodingFormat.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | Glue | (Inherited from GlueComponentService.)
Public property | IdleChunkLifeSec | Specifies the maximum length of life of an unused memory chunk in the pool. The idle chunk will be evicted after this interval. This setting is common for both server and client as they share the same pool
Public property | InstrumentationEnabled | Implements IInstrumentable (Inherited from GlueComponentService.)
Public property | InstrumentClientTransportStat | Defines whether client transport statistics is periodically dumped into instrumentation (Inherited from Binding.)
Public property | InstrumentServerTransportStat | Defines whether server transport statistics is periodically dumped into instrumentation (Inherited from Binding.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | MaxChunkPoolCount | Imposes a limit on how many memory chunks can be stored in free chunk pool. The chunks can be resued for making new connections. This setting is common for both server and client as they share the same pool
Public property | MaxMsgSize | Imposes a limit on maximum message size in bytes
Public property | MeasureStatTimes | Defines whether message processing latency should be measured - i.e. messages time-stamped on arrival (Inherited from Binding.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | OperationFlow | Mpx binding is always async by definition (Overrides Binding OperationFlow.)
Public property | Provider | (Inherited from Binding.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Protected property | Serializer |
Public property | ServerDump | Turns on/off server message dumping to disk. Turning on dumping has negative effect on performance and consumes resources (Inherited from Binding.)
Public property | ServerMsgInspectors | Returns server message inspectors for this instance (Inherited from Binding.)
Public property | ServerReceiveBufferSize |
Public property | ServerReceiveTimeout |
Public property | ServerSendBufferSize |
Public property | ServerSendTimeout |
Public property | ServerTransportIdleTimeoutMs | Specifies when server transports get auto-closed. Interval is measured in ms. Zero means indefinite/never closed transport. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ServerTransports | Returns all server transports in the binding stack (Inherited from Binding.)
Public property | SocketFactory | Returns factory used to make new socket instances per particular technology
Public property | SocketLingerSec | Sets socket linger options. This setting is common for both server and client as they have the same channel semantics
Public property | StatTimesEMAFactor | Defines how much smoothing the timing statistics filter does - the lower the number the more smoothing is done. Smoothing makes stat times insensitive to some seldom delays that may happen every now and then (Inherited from Binding.)
Public property | StatTimeTicks | Returns current time in system frequency-dependent ticks. This property is used to measure accurate times and depends on MeasureStatTimes set to true, otherwise 0 is returned (Inherited from Binding.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | Transports | Returns all transports in the binding stack (Inherited from Binding.)
Back to Top
See Also
MpxBinding Class
NFX.Glue.Native Namespace


MpxBinding Constructor

MpxBinding Constructor NFX Class Library

Overload List
 | Name | Description
Public method | MpxBinding(String) | Initializes a new instance of the MpxBinding class
Public method | MpxBinding(IGlueImplementation, String) | Initializes a new instance of the MpxBinding class
Back to Top
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding Constructor (String)

MpxBinding Constructor (String) NFX Class Library

Initializes a new instance of the MpxBinding class

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MpxBinding(
    string name
)
public MpxBinding(
    string name
)
Public Sub New (
    name As String
)
Public Sub New (
    name As String
)
public:
MpxBinding(
    String^ name
)
public:
MpxBinding(
    String^ name
)
new :
        name : string -> MpxBinding
new :
        name : string -> MpxBinding

Parameters

name
Type: Online System String
See Also
MpxBinding Class
MpxBinding Members
MpxBinding Overload
NFX.Glue.Native Namespace


MpxBinding Constructor (IGlueImplementation, String)

MpxBinding Constructor (IGlueImplementation, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MpxBinding class

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MpxBinding(
    IGlueImplementation glue,
    string name
)
public MpxBinding(
    IGlueImplementation glue,
    string name
)
Public Sub New (
    glue As IGlueImplementation,
    name As String
)
Public Sub New (
    glue As IGlueImplementation,
    name As String
)
public:
MpxBinding(
    IGlueImplementation^ glue,
    String^ name
)
public:
MpxBinding(
    IGlueImplementation^ glue,
    String^ name
)
new :
        glue : IGlueImplementation *
        name : string -> MpxBinding
new :
        glue : IGlueImplementation *
        name : string -> MpxBinding

Parameters

glue
Type: NFX.Glue IGlueImplementation
name
Type: Online System String
See Also
MpxBinding Class
MpxBinding Members
MpxBinding Overload
NFX.Glue.Native Namespace


MpxBinding Fields

MpxBinding Fields NFX Class Library

The MpxBinding type exposes the following members.
Fields
 | Name | Description
 | CONFIG_SOCKET_FACTORY_SECT |
 | DEFAULT_IDLE_CHUNK_LIFE_SEC |
 | DEFAULT_MAX_CHUNK_POOL_COUNT |
 | DEFAULT_PORT |
 | DEFAULT_RCV_TIMEOUT |
 | DEFAULT_SND_TIMEOUT |
 | DEFAULT_SOCKET_LINGER_SEC |
Protected field | m_ClientTransportAllocatorLocks | Hash table of locks used during new transport allocation, must be prime size (Inherited from Binding.)
Protected field | m_Provider | (Inherited from Binding.)
Protected field | m_Transports | (Inherited from Binding.)
Back to Top
See Also
MpxBinding Class
NFX.Glue.Native Namespace


MpxBinding.CONFIG_SOCKET_FACTORY_SECT Field

MpxBinding CONFIG_SOCKET_FACTORY_SECT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SOCKET_FACTORY_SECT
public const string CONFIG_SOCKET_FACTORY_SECT
Public Const CONFIG_SOCKET_FACTORY_SECT As String
Public Const CONFIG_SOCKET_FACTORY_SECT As String
public:
literal String^ CONFIG_SOCKET_FACTORY_SECT
public:
literal String^ CONFIG_SOCKET_FACTORY_SECT
static val mutable CONFIG_SOCKET_FACTORY_SECT: string
static val mutable CONFIG_SOCKET_FACTORY_SECT: string

Field Value

Type: Online String
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.DEFAULT_IDLE_CHUNK_LIFE_SEC Field

MpxBinding DEFAULT_IDLE_CHUNK_LIFE_SEC Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_IDLE_CHUNK_LIFE_SEC
public const int DEFAULT_IDLE_CHUNK_LIFE_SEC
Public Const DEFAULT_IDLE_CHUNK_LIFE_SEC As Integer
Public Const DEFAULT_IDLE_CHUNK_LIFE_SEC As Integer
public:
literal int DEFAULT_IDLE_CHUNK_LIFE_SEC
public:
literal int DEFAULT_IDLE_CHUNK_LIFE_SEC
static val mutable DEFAULT_IDLE_CHUNK_LIFE_SEC: int
static val mutable DEFAULT_IDLE_CHUNK_LIFE_SEC: int

Field Value

Type: Online Int32
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.DEFAULT_MAX_CHUNK_POOL_COUNT Field

MpxBinding DEFAULT_MAX_CHUNK_POOL_COUNT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_MAX_CHUNK_POOL_COUNT
public const int DEFAULT_MAX_CHUNK_POOL_COUNT
Public Const DEFAULT_MAX_CHUNK_POOL_COUNT As Integer
Public Const DEFAULT_MAX_CHUNK_POOL_COUNT As Integer
public:
literal int DEFAULT_MAX_CHUNK_POOL_COUNT
public:
literal int DEFAULT_MAX_CHUNK_POOL_COUNT
static val mutable DEFAULT_MAX_CHUNK_POOL_COUNT: int
static val mutable DEFAULT_MAX_CHUNK_POOL_COUNT: int

Field Value

Type: Online Int32
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.DEFAULT_PORT Field

MpxBinding DEFAULT_PORT Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_PORT
public const int DEFAULT_PORT
Public Const DEFAULT_PORT As Integer
Public Const DEFAULT_PORT As Integer
public:
literal int DEFAULT_PORT
public:
literal int DEFAULT_PORT
static val mutable DEFAULT_PORT: int
static val mutable DEFAULT_PORT: int

Field Value

Type: Online Int32
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.DEFAULT_RCV_TIMEOUT Field

MpxBinding DEFAULT_RCV_TIMEOUT Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_RCV_TIMEOUT
public const int DEFAULT_RCV_TIMEOUT
Public Const DEFAULT_RCV_TIMEOUT As Integer
Public Const DEFAULT_RCV_TIMEOUT As Integer
public:
literal int DEFAULT_RCV_TIMEOUT
public:
literal int DEFAULT_RCV_TIMEOUT
static val mutable DEFAULT_RCV_TIMEOUT: int
static val mutable DEFAULT_RCV_TIMEOUT: int

Field Value

Type: Online Int32
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.DEFAULT_SND_TIMEOUT Field

MpxBinding DEFAULT_SND_TIMEOUT Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_SND_TIMEOUT
public const int DEFAULT_SND_TIMEOUT
Public Const DEFAULT_SND_TIMEOUT As Integer
Public Const DEFAULT_SND_TIMEOUT As Integer
public:
literal int DEFAULT_SND_TIMEOUT
public:
literal int DEFAULT_SND_TIMEOUT
static val mutable DEFAULT_SND_TIMEOUT: int
static val mutable DEFAULT_SND_TIMEOUT: int

Field Value

Type: Online Int32
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.DEFAULT_SOCKET_LINGER_SEC Field

MpxBinding DEFAULT_SOCKET_LINGER_SEC Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_SOCKET_LINGER_SEC
public const int DEFAULT_SOCKET_LINGER_SEC
Public Const DEFAULT_SOCKET_LINGER_SEC As Integer
Public Const DEFAULT_SOCKET_LINGER_SEC As Integer
public:
literal int DEFAULT_SOCKET_LINGER_SEC
public:
literal int DEFAULT_SOCKET_LINGER_SEC
static val mutable DEFAULT_SOCKET_LINGER_SEC: int
static val mutable DEFAULT_SOCKET_LINGER_SEC: int

Field Value

Type: Online Int32
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding Methods

MpxBinding Methods NFX Class Library

The MpxBinding type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | _Register | (Inherited from Binding.)
Protected method | _Unregister | (Inherited from Binding.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Protected method | AcquireClientTransportForCall | Returns an instance of transport suitable for a call. The implementation may return existing transport or allocate a new instance. The call is thread-safe (Inherited from Binding.)
Public method | AreNodesIdentical | (Overrides Binding AreNodesIdentical(Node, Node).)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and binding runtime are running or throws otherwise (Inherited from Binding.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Protected method | CloseServerEndpoint | (Overrides Binding CloseServerEndpoint(ServerEndPoint).)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | ConfigureAndStartNewClientTransport | Override to perform custom transport preparation and launch (Inherited from Binding.)
Protected method | Destructor | (Inherited from Binding.)
Public method | DispatchCall | Dispatches a call allocating new or re-using existing transport if needed. The strategy depends on particular Binding implementation. This call is thread-safe (Inherited from Binding.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | (Overrides Binding DoAcceptManagerVisit(Object, DateTime).)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Binding DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | (Inherited from Binding.)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Binding DoWaitForCompleteStop .)
Protected method | DumpMsg(Boolean, Msg, ArraySegment Byte ) | Conditionally dumps message to disk (Inherited from Binding.)
Protected method | DumpMsg(Boolean, Msg, Func ArraySegment Byte ) | Conditionally dumps message to disk where the data is lazily obtained by calling dataFun (Inherited from Binding.)
Protected method | DumpMsg(Boolean, Msg, Byte , Int32, Int32) | Conditionally dumps message to disk (Inherited from Binding.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetClientCallStatTimeKey | Extracts necessary information from client:request pair that characterizes the particular call for the purpose of call timing (Inherited from Binding.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | MakeNewClientTransport | (Overrides Binding MakeNewClientTransport(ClientEndPoint).)
Protected method | MakeOrReuseChunk | Fetches available existing chunk from cache or creates a new one. Called by new sockets by incipient connections
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OpenServerEndpoint | (Overrides Binding OpenServerEndpoint(ServerEndPoint).)
Protected method | ReleaseChunk |
Protected method | ReleaseClientTransportAfterCall | Releases a transport instance that was acquired for call. The implementation may return this instance back to the pool of available transports or deallocate it. The default implementation releases the instance back to the pool (Inherited from Binding.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
 | ToIPEndPoint |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | TryGetExistingAcquiredTransportPerRemoteNode | Tries to acquire an available client transport to make a call. This method respects binding/transport settings that impose a limit on the number of open concurrent transports and timeouts for acqusition waiting (Inherited from Binding.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | WriteLog | (Inherited from GlueComponentService.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MpxBinding Class
NFX.Glue.Native Namespace


MpxBinding.AreNodesIdentical Method

MpxBinding AreNodesIdentical Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool AreNodesIdentical(
    Node left,
    Node right
)
public override bool AreNodesIdentical(
    Node left,
    Node right
)
Public Overrides Function AreNodesIdentical (
    left As Node,
    right As Node
) As Boolean
Public Overrides Function AreNodesIdentical (
    left As Node,
    right As Node
) As Boolean
public:
virtual bool AreNodesIdentical(
    Node left,
    Node right
) override
public:
virtual bool AreNodesIdentical(
    Node left,
    Node right
) override
abstract AreNodesIdentical :
        left : Node *
        right : Node -> bool
override AreNodesIdentical :
        left : Node *
        right : Node -> bool
abstract AreNodesIdentical :
        left : Node *
        right : Node -> bool
override AreNodesIdentical :
        left : Node *
        right : Node -> bool

Parameters

left
Type: NFX.Glue Node
right
Type: NFX.Glue Node

Return Value

Type: Online Boolean
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.CloseServerEndpoint Method

MpxBinding CloseServerEndpoint Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void CloseServerEndpoint(
    ServerEndPoint epoint
)
protected internal override void CloseServerEndpoint(
    ServerEndPoint epoint
)
Protected Friend Overrides Sub CloseServerEndpoint (
    epoint As ServerEndPoint
)
Protected Friend Overrides Sub CloseServerEndpoint (
    epoint As ServerEndPoint
)
protected public:
virtual void CloseServerEndpoint(
    ServerEndPoint^ epoint
) override
protected public:
virtual void CloseServerEndpoint(
    ServerEndPoint^ epoint
) override
abstract CloseServerEndpoint :
        epoint : ServerEndPoint -> unit
override CloseServerEndpoint :
        epoint : ServerEndPoint -> unit
abstract CloseServerEndpoint :
        epoint : ServerEndPoint -> unit
override CloseServerEndpoint :
        epoint : ServerEndPoint -> unit

Parameters

epoint
Type: NFX.Glue ServerEndPoint
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.DoAcceptManagerVisit Method

MpxBinding DoAcceptManagerVisit Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoAcceptManagerVisit(
    Object manager,
    DateTime managerNow
)
protected override void DoAcceptManagerVisit(
    Object manager,
    DateTime managerNow
)
Protected Overrides Sub DoAcceptManagerVisit (
    manager As Object,
    managerNow As DateTime
)
Protected Overrides Sub DoAcceptManagerVisit (
    manager As Object,
    managerNow As DateTime
)
protected:
virtual void DoAcceptManagerVisit(
    Object^ manager,
    DateTime managerNow
) override
protected:
virtual void DoAcceptManagerVisit(
    Object^ manager,
    DateTime managerNow
) override
abstract DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit
override DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit
abstract DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit
override DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit

Parameters

manager
Type: Online System Object
managerNow
Type: Online System DateTime
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.DoConfigure Method

MpxBinding DoConfigure Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.DoStart Method

MpxBinding DoStart Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.DoWaitForCompleteStop Method

MpxBinding DoWaitForCompleteStop Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.MakeNewClientTransport Method

MpxBinding MakeNewClientTransport Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override ClientTransport MakeNewClientTransport(
    ClientEndPoint client
)
protected override ClientTransport MakeNewClientTransport(
    ClientEndPoint client
)
Protected Overrides Function MakeNewClientTransport (
    client As ClientEndPoint
) As ClientTransport
Protected Overrides Function MakeNewClientTransport (
    client As ClientEndPoint
) As ClientTransport
protected:
virtual ClientTransport^ MakeNewClientTransport(
    ClientEndPoint^ client
) override
protected:
virtual ClientTransport^ MakeNewClientTransport(
    ClientEndPoint^ client
) override
abstract MakeNewClientTransport :
        client : ClientEndPoint -> ClientTransport
override MakeNewClientTransport :
        client : ClientEndPoint -> ClientTransport
abstract MakeNewClientTransport :
        client : ClientEndPoint -> ClientTransport
override MakeNewClientTransport :
        client : ClientEndPoint -> ClientTransport

Parameters

client
Type: NFX.Glue ClientEndPoint

Return Value

Type: ClientTransport
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.MakeOrReuseChunk Method

MpxBinding MakeOrReuseChunk Method NFX Class Library

Fetches available existing chunk from cache or creates a new one. Called by new sockets by incipient connections

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal MemChunk MakeOrReuseChunk()
internal MemChunk MakeOrReuseChunk()
Friend Function MakeOrReuseChunk As MemChunk
Friend Function MakeOrReuseChunk As MemChunk
internal:
MemChunk^ MakeOrReuseChunk()
internal:
MemChunk^ MakeOrReuseChunk()
internal member MakeOrReuseChunk : unit -> MemChunk
internal member MakeOrReuseChunk : unit -> MemChunk

Return Value

Type: MemChunk
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.OpenServerEndpoint Method

MpxBinding OpenServerEndpoint Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override ServerTransport OpenServerEndpoint(
    ServerEndPoint epoint
)
protected internal override ServerTransport OpenServerEndpoint(
    ServerEndPoint epoint
)
Protected Friend Overrides Function OpenServerEndpoint (
    epoint As ServerEndPoint
) As ServerTransport
Protected Friend Overrides Function OpenServerEndpoint (
    epoint As ServerEndPoint
) As ServerTransport
protected public:
virtual ServerTransport^ OpenServerEndpoint(
    ServerEndPoint^ epoint
) override
protected public:
virtual ServerTransport^ OpenServerEndpoint(
    ServerEndPoint^ epoint
) override
abstract OpenServerEndpoint :
        epoint : ServerEndPoint -> ServerTransport
override OpenServerEndpoint :
        epoint : ServerEndPoint -> ServerTransport
abstract OpenServerEndpoint :
        epoint : ServerEndPoint -> ServerTransport
override OpenServerEndpoint :
        epoint : ServerEndPoint -> ServerTransport

Parameters

epoint
Type: NFX.Glue ServerEndPoint

Return Value

Type: ServerTransport
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.ReleaseChunk Method

MpxBinding ReleaseChunk Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void ReleaseChunk(
    MemChunk chunk
)
internal void ReleaseChunk(
    MemChunk chunk
)
Friend Sub ReleaseChunk (
    chunk As MemChunk
)
Friend Sub ReleaseChunk (
    chunk As MemChunk
)
internal:
void ReleaseChunk(
    MemChunk^ chunk
)
internal:
void ReleaseChunk(
    MemChunk^ chunk
)
internal member ReleaseChunk :
        chunk : MemChunk -> unit
internal member ReleaseChunk :
        chunk : MemChunk -> unit

Parameters

chunk
Type: NFX.Glue.Native MemChunk
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.ToIPEndPoint Method

MpxBinding ToIPEndPoint Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static IPEndPoint ToIPEndPoint(
    Node node
)
internal static IPEndPoint ToIPEndPoint(
    Node node
)
Friend Shared Function ToIPEndPoint (
    node As Node
) As IPEndPoint
Friend Shared Function ToIPEndPoint (
    node As Node
) As IPEndPoint
internal:
static IPEndPoint^ ToIPEndPoint(
    Node node
)
internal:
static IPEndPoint^ ToIPEndPoint(
    Node node
)
internal static member ToIPEndPoint :
        node : Node -> IPEndPoint
internal static member ToIPEndPoint :
        node : Node -> IPEndPoint

Parameters

node
Type: NFX.Glue Node

Return Value

Type: Online IPEndPoint
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding Properties

MpxBinding Properties NFX Class Library

The MpxBinding type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ClientDump | Turns on/off client message dumping to disk. Turning on dumping has negative effect on performance and consumes resources (Inherited from Binding.)
Public property | ClientMsgInspectors | Returns client message inspectors for this instance (Inherited from Binding.)
Public property | ClientReceiveBufferSize |
Public property | ClientReceiveTimeout |
Public property | ClientSendBufferSize |
Public property | ClientSendTimeout |
Public property | ClientTransportCountWaitThreshold | Sets the threshold, expressed as the number of active client transports per remote address, below which binding will always allocate a new instance of client transport without trying/waiting to acquire an existing one. When this number is exceeded then binding will try to acquire an existing client transport instance for up to ClientTransportExistingAcquisitionTimeoutMs milliseconds. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ClientTransportExistingAcquisitionTimeoutMs | Sets the length of interval for the binding trying to acquire existing client transport instance to make a call. When this interval is exhausted then binding tries to allocate a new client transport per remote address, unless other limits prohibit (max transport count). The value has to be greater or equal to zero. NOTE: this property works in conjunction with ClientTransportCoutWaitThreshold, if the number of active client transports is below ClientTransportCoutWaitThreshold, then binding does not wait and allocates a new client transport right away until ClientTransportCoutWaitThreshold limit is reached, then binding will try to acquire existing transport for ClientTransportExistingAcquisitionTimeoutMs milliseconds. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ClientTransportIdleTimeoutMs | Specifies when client transports get auto-closed. Interval is measured in ms. Zero means indefinite/never closed transport. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ClientTransportMaxCount | Imposes a limit on number of active client transports per remote address. Once this limit is reached the binding will block until it can acquire an existing transport instance. Set value to zero to remove the limit. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ClientTransportMaxExistingAcquisitionTimeoutMs | Imposes a timeout for binding trying to get an existing transport instance per remote address. Binding throws ClientCallException when this timeout is exceeded. A value of zero removes the limit (Inherited from Binding.)
Public property | ClientTransports | Returns all client transports in the binding stack (Inherited from Binding.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | ConfigNode | Returns configuration node for this named instance (Inherited from Binding.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | DumpMsgFormat | Set the format for message dumping (Inherited from Binding.)
Public property | DumpPath | Set the path for message dumping. Must be an existing navigable path (Inherited from Binding.)
Public property | EncodingFormat | (Overrides Binding EncodingFormat.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | Glue | (Inherited from GlueComponentService.)
Public property | IdleChunkLifeSec | Specifies the maximum length of life of an unused memory chunk in the pool. The idle chunk will be evicted after this interval. This setting is common for both server and client as they share the same pool
Public property | InstrumentationEnabled | Implements IInstrumentable (Inherited from GlueComponentService.)
Public property | InstrumentClientTransportStat | Defines whether client transport statistics is periodically dumped into instrumentation (Inherited from Binding.)
Public property | InstrumentServerTransportStat | Defines whether server transport statistics is periodically dumped into instrumentation (Inherited from Binding.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | MaxChunkPoolCount | Imposes a limit on how many memory chunks can be stored in free chunk pool. The chunks can be resued for making new connections. This setting is common for both server and client as they share the same pool
Public property | MaxMsgSize | Imposes a limit on maximum message size in bytes
Public property | MeasureStatTimes | Defines whether message processing latency should be measured - i.e. messages time-stamped on arrival (Inherited from Binding.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | OperationFlow | Mpx binding is always async by definition (Overrides Binding OperationFlow.)
Public property | Provider | (Inherited from Binding.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Protected property | Serializer |
Public property | ServerDump | Turns on/off server message dumping to disk. Turning on dumping has negative effect on performance and consumes resources (Inherited from Binding.)
Public property | ServerMsgInspectors | Returns server message inspectors for this instance (Inherited from Binding.)
Public property | ServerReceiveBufferSize |
Public property | ServerReceiveTimeout |
Public property | ServerSendBufferSize |
Public property | ServerSendTimeout |
Public property | ServerTransportIdleTimeoutMs | Specifies when server transports get auto-closed. Interval is measured in ms. Zero means indefinite/never closed transport. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ServerTransports | Returns all server transports in the binding stack (Inherited from Binding.)
Public property | SocketFactory | Returns factory used to make new socket instances per particular technology
Public property | SocketLingerSec | Sets socket linger options. This setting is common for both server and client as they have the same channel semantics
Public property | StatTimesEMAFactor | Defines how much smoothing the timing statistics filter does - the lower the number the more smoothing is done. Smoothing makes stat times insensitive to some seldom delays that may happen every now and then (Inherited from Binding.)
Public property | StatTimeTicks | Returns current time in system frequency-dependent ticks. This property is used to measure accurate times and depends on MeasureStatTimes set to true, otherwise 0 is returned (Inherited from Binding.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | Transports | Returns all transports in the binding stack (Inherited from Binding.)
Back to Top
See Also
MpxBinding Class
NFX.Glue.Native Namespace


MpxBinding.ClientReceiveBufferSize Property

MpxBinding ClientReceiveBufferSize Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("client-transport/$rcv-buf-size", 16384)]
public int ClientReceiveBufferSize { get; set; }
[ConfigAttribute("client-transport/$rcv-buf-size", 16384)]
public int ClientReceiveBufferSize { get; set; }
<ConfigAttribute("client-transport/$rcv-buf-size", 16384)>
Public Property ClientReceiveBufferSize As Integer
    Get
    Set
<ConfigAttribute("client-transport/$rcv-buf-size", 16384)>
Public Property ClientReceiveBufferSize As Integer
    Get
    Set
public:
[ConfigAttribute(L"client-transport/$rcv-buf-size", 16384)]
property int ClientReceiveBufferSize {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(L"client-transport/$rcv-buf-size", 16384)]
property int ClientReceiveBufferSize {
    int get ();
    void set (int value);
}
[<ConfigAttribute("client-transport/$rcv-buf-size", 16384)>]
member ClientReceiveBufferSize : int with get, set
[<ConfigAttribute("client-transport/$rcv-buf-size", 16384)>]
member ClientReceiveBufferSize : int with get, set

Property Value

Type: Online Int32
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.ClientReceiveTimeout Property

MpxBinding ClientReceiveTimeout Property NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("client-transport/$rcv-timeout", 0)]
public int ClientReceiveTimeout { get; set; }
[ConfigAttribute("client-transport/$rcv-timeout", 0)]
public int ClientReceiveTimeout { get; set; }
<ConfigAttribute("client-transport/$rcv-timeout", 0)>
Public Property ClientReceiveTimeout As Integer
    Get
    Set
<ConfigAttribute("client-transport/$rcv-timeout", 0)>
Public Property ClientReceiveTimeout As Integer
    Get
    Set
public:
[ConfigAttribute(L"client-transport/$rcv-timeout", 0)]
property int ClientReceiveTimeout {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(L"client-transport/$rcv-timeout", 0)]
property int ClientReceiveTimeout {
    int get ();
    void set (int value);
}
[<ConfigAttribute("client-transport/$rcv-timeout", 0)>]
member ClientReceiveTimeout : int with get, set
[<ConfigAttribute("client-transport/$rcv-timeout", 0)>]
member ClientReceiveTimeout : int with get, set

Property Value

Type: Online Int32
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.ClientSendBufferSize Property

MpxBinding ClientSendBufferSize Property NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("client-transport/$snd-buf-size", 16384)]
public int ClientSendBufferSize { get; set; }
[ConfigAttribute("client-transport/$snd-buf-size", 16384)]
public int ClientSendBufferSize { get; set; }
<ConfigAttribute("client-transport/$snd-buf-size", 16384)>
Public Property ClientSendBufferSize As Integer
    Get
    Set
<ConfigAttribute("client-transport/$snd-buf-size", 16384)>
Public Property ClientSendBufferSize As Integer
    Get
    Set
public:
[ConfigAttribute(L"client-transport/$snd-buf-size", 16384)]
property int ClientSendBufferSize {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(L"client-transport/$snd-buf-size", 16384)]
property int ClientSendBufferSize {
    int get ();
    void set (int value);
}
[<ConfigAttribute("client-transport/$snd-buf-size", 16384)>]
member ClientSendBufferSize : int with get, set
[<ConfigAttribute("client-transport/$snd-buf-size", 16384)>]
member ClientSendBufferSize : int with get, set

Property Value

Type: Online Int32
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.ClientSendTimeout Property

MpxBinding ClientSendTimeout Property NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("client-transport/$snd-timeout", 0)]
public int ClientSendTimeout { get; set; }
[ConfigAttribute("client-transport/$snd-timeout", 0)]
public int ClientSendTimeout { get; set; }
<ConfigAttribute("client-transport/$snd-timeout", 0)>
Public Property ClientSendTimeout As Integer
    Get
    Set
<ConfigAttribute("client-transport/$snd-timeout", 0)>
Public Property ClientSendTimeout As Integer
    Get
    Set
public:
[ConfigAttribute(L"client-transport/$snd-timeout", 0)]
property int ClientSendTimeout {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(L"client-transport/$snd-timeout", 0)]
property int ClientSendTimeout {
    int get ();
    void set (int value);
}
[<ConfigAttribute("client-transport/$snd-timeout", 0)>]
member ClientSendTimeout : int with get, set
[<ConfigAttribute("client-transport/$snd-timeout", 0)>]
member ClientSendTimeout : int with get, set

Property Value

Type: Online Int32
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.EncodingFormat Property

MpxBinding EncodingFormat Property NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string EncodingFormat { get; }
public override string EncodingFormat { get; }
Public Overrides ReadOnly Property EncodingFormat As String
    Get
Public Overrides ReadOnly Property EncodingFormat As String
    Get
public:
virtual property String^ EncodingFormat {
    String^ get () override;
}
public:
virtual property String^ EncodingFormat {
    String^ get () override;
}
abstract EncodingFormat : string with get
override EncodingFormat : string with get
abstract EncodingFormat : string with get
override EncodingFormat : string with get

Property Value

Type: Online String
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.IdleChunkLifeSec Property

MpxBinding IdleChunkLifeSec Property NFX Class Library

Specifies the maximum length of life of an unused memory chunk in the pool. The idle chunk will be evicted after this interval. This setting is common for both server and client as they share the same pool

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(null, 600)]
public int IdleChunkLifeSec { get; set; }
[ConfigAttribute(null, 600)]
public int IdleChunkLifeSec { get; set; }
<ConfigAttribute(Nothing, 600)>
Public Property IdleChunkLifeSec As Integer
    Get
    Set
<ConfigAttribute(Nothing, 600)>
Public Property IdleChunkLifeSec As Integer
    Get
    Set
public:
[ConfigAttribute(nullptr, 600)]
property int IdleChunkLifeSec {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(nullptr, 600)]
property int IdleChunkLifeSec {
    int get ();
    void set (int value);
}
[<ConfigAttribute(null, 600)>]
member IdleChunkLifeSec : int with get, set
[<ConfigAttribute(null, 600)>]
member IdleChunkLifeSec : int with get, set

Property Value

Type: Online Int32
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.MaxChunkPoolCount Property

MpxBinding MaxChunkPoolCount Property NFX Class Library

Imposes a limit on how many memory chunks can be stored in free chunk pool. The chunks can be resued for making new connections. This setting is common for both server and client as they share the same pool

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(null, 1024)]
public int MaxChunkPoolCount { get; set; }
[ConfigAttribute(null, 1024)]
public int MaxChunkPoolCount { get; set; }
<ConfigAttribute(Nothing, 1024)>
Public Property MaxChunkPoolCount As Integer
    Get
    Set
<ConfigAttribute(Nothing, 1024)>
Public Property MaxChunkPoolCount As Integer
    Get
    Set
public:
[ConfigAttribute(nullptr, 1024)]
property int MaxChunkPoolCount {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(nullptr, 1024)]
property int MaxChunkPoolCount {
    int get ();
    void set (int value);
}
[<ConfigAttribute(null, 1024)>]
member MaxChunkPoolCount : int with get, set
[<ConfigAttribute(null, 1024)>]
member MaxChunkPoolCount : int with get, set

Property Value

Type: Online Int32
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.MaxMsgSize Property

MpxBinding MaxMsgSize Property NFX Class Library

Imposes a limit on maximum message size in bytes

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$max-msg-size", 524288)]
public int MaxMsgSize { get; set; }
[ConfigAttribute("$max-msg-size", 524288)]
public int MaxMsgSize { get; set; }
<ConfigAttribute("$max-msg-size", 524288)>
Public Property MaxMsgSize As Integer
    Get
    Set
<ConfigAttribute("$max-msg-size", 524288)>
Public Property MaxMsgSize As Integer
    Get
    Set
public:
[ConfigAttribute(L"$max-msg-size", 524288)]
property int MaxMsgSize {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(L"$max-msg-size", 524288)]
property int MaxMsgSize {
    int get ();
    void set (int value);
}
[<ConfigAttribute("$max-msg-size", 524288)>]
member MaxMsgSize : int with get, set
[<ConfigAttribute("$max-msg-size", 524288)>]
member MaxMsgSize : int with get, set

Property Value

Type: Online Int32
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.OperationFlow Property

MpxBinding OperationFlow Property NFX Class Library

Mpx binding is always async by definition

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override OperationFlow OperationFlow { get; }
public override OperationFlow OperationFlow { get; }
Public Overrides ReadOnly Property OperationFlow As OperationFlow
    Get
Public Overrides ReadOnly Property OperationFlow As OperationFlow
    Get
public:
virtual property OperationFlow OperationFlow {
    OperationFlow get () override;
}
public:
virtual property OperationFlow OperationFlow {
    OperationFlow get () override;
}
abstract OperationFlow : OperationFlow with get
override OperationFlow : OperationFlow with get
abstract OperationFlow : OperationFlow with get
override OperationFlow : OperationFlow with get

Property Value

Type: OperationFlow
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.Serializer Property

MpxBinding Serializer Property NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ISerializer Serializer { get; }
internal ISerializer Serializer { get; }
Friend ReadOnly Property Serializer As ISerializer
    Get
Friend ReadOnly Property Serializer As ISerializer
    Get
internal:
property ISerializer^ Serializer {
    ISerializer^ get ();
}
internal:
property ISerializer^ Serializer {
    ISerializer^ get ();
}
internal member Serializer : ISerializer with get
internal member Serializer : ISerializer with get

Property Value

Type: ISerializer
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.ServerReceiveBufferSize Property

MpxBinding ServerReceiveBufferSize Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("server-transport/$rcv-buf-size", 16384)]
public int ServerReceiveBufferSize { get; set; }
[ConfigAttribute("server-transport/$rcv-buf-size", 16384)]
public int ServerReceiveBufferSize { get; set; }
<ConfigAttribute("server-transport/$rcv-buf-size", 16384)>
Public Property ServerReceiveBufferSize As Integer
    Get
    Set
<ConfigAttribute("server-transport/$rcv-buf-size", 16384)>
Public Property ServerReceiveBufferSize As Integer
    Get
    Set
public:
[ConfigAttribute(L"server-transport/$rcv-buf-size", 16384)]
property int ServerReceiveBufferSize {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(L"server-transport/$rcv-buf-size", 16384)]
property int ServerReceiveBufferSize {
    int get ();
    void set (int value);
}
[<ConfigAttribute("server-transport/$rcv-buf-size", 16384)>]
member ServerReceiveBufferSize : int with get, set
[<ConfigAttribute("server-transport/$rcv-buf-size", 16384)>]
member ServerReceiveBufferSize : int with get, set

Property Value

Type: Online Int32
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.ServerReceiveTimeout Property

MpxBinding ServerReceiveTimeout Property NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("server-transport/$rcv-timeout", 0)]
public int ServerReceiveTimeout { get; set; }
[ConfigAttribute("server-transport/$rcv-timeout", 0)]
public int ServerReceiveTimeout { get; set; }
<ConfigAttribute("server-transport/$rcv-timeout", 0)>
Public Property ServerReceiveTimeout As Integer
    Get
    Set
<ConfigAttribute("server-transport/$rcv-timeout", 0)>
Public Property ServerReceiveTimeout As Integer
    Get
    Set
public:
[ConfigAttribute(L"server-transport/$rcv-timeout", 0)]
property int ServerReceiveTimeout {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(L"server-transport/$rcv-timeout", 0)]
property int ServerReceiveTimeout {
    int get ();
    void set (int value);
}
[<ConfigAttribute("server-transport/$rcv-timeout", 0)>]
member ServerReceiveTimeout : int with get, set
[<ConfigAttribute("server-transport/$rcv-timeout", 0)>]
member ServerReceiveTimeout : int with get, set

Property Value

Type: Online Int32
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.ServerSendBufferSize Property

MpxBinding ServerSendBufferSize Property NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("server-transport/$snd-buf-size", 16384)]
public int ServerSendBufferSize { get; set; }
[ConfigAttribute("server-transport/$snd-buf-size", 16384)]
public int ServerSendBufferSize { get; set; }
<ConfigAttribute("server-transport/$snd-buf-size", 16384)>
Public Property ServerSendBufferSize As Integer
    Get
    Set
<ConfigAttribute("server-transport/$snd-buf-size", 16384)>
Public Property ServerSendBufferSize As Integer
    Get
    Set
public:
[ConfigAttribute(L"server-transport/$snd-buf-size", 16384)]
property int ServerSendBufferSize {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(L"server-transport/$snd-buf-size", 16384)]
property int ServerSendBufferSize {
    int get ();
    void set (int value);
}
[<ConfigAttribute("server-transport/$snd-buf-size", 16384)>]
member ServerSendBufferSize : int with get, set
[<ConfigAttribute("server-transport/$snd-buf-size", 16384)>]
member ServerSendBufferSize : int with get, set

Property Value

Type: Online Int32
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.ServerSendTimeout Property

MpxBinding ServerSendTimeout Property NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("server-transport/$snd-timeout", 0)]
public int ServerSendTimeout { get; set; }
[ConfigAttribute("server-transport/$snd-timeout", 0)]
public int ServerSendTimeout { get; set; }
<ConfigAttribute("server-transport/$snd-timeout", 0)>
Public Property ServerSendTimeout As Integer
    Get
    Set
<ConfigAttribute("server-transport/$snd-timeout", 0)>
Public Property ServerSendTimeout As Integer
    Get
    Set
public:
[ConfigAttribute(L"server-transport/$snd-timeout", 0)]
property int ServerSendTimeout {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(L"server-transport/$snd-timeout", 0)]
property int ServerSendTimeout {
    int get ();
    void set (int value);
}
[<ConfigAttribute("server-transport/$snd-timeout", 0)>]
member ServerSendTimeout : int with get, set
[<ConfigAttribute("server-transport/$snd-timeout", 0)>]
member ServerSendTimeout : int with get, set

Property Value

Type: Online Int32
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.SocketFactory Property

MpxBinding SocketFactory Property NFX Class Library

Returns factory used to make new socket instances per particular technology

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MpxSocketFactory SocketFactory { get; }
public MpxSocketFactory SocketFactory { get; }
Public ReadOnly Property SocketFactory As MpxSocketFactory
    Get
Public ReadOnly Property SocketFactory As MpxSocketFactory
    Get
public:
property MpxSocketFactory^ SocketFactory {
    MpxSocketFactory^ get ();
}
public:
property MpxSocketFactory^ SocketFactory {
    MpxSocketFactory^ get ();
}
member SocketFactory : MpxSocketFactory with get
member SocketFactory : MpxSocketFactory with get

Property Value

Type: MpxSocketFactory
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxBinding.SocketLingerSec Property

MpxBinding SocketLingerSec Property NFX Class Library

Sets socket linger options. This setting is common for both server and client as they have the same channel semantics

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(null, 3)]
public int SocketLingerSec { get; set; }
[ConfigAttribute(null, 3)]
public int SocketLingerSec { get; set; }
<ConfigAttribute(Nothing, 3)>
Public Property SocketLingerSec As Integer
    Get
    Set
<ConfigAttribute(Nothing, 3)>
Public Property SocketLingerSec As Integer
    Get
    Set
public:
[ConfigAttribute(nullptr, 3)]
property int SocketLingerSec {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(nullptr, 3)]
property int SocketLingerSec {
    int get ();
    void set (int value);
}
[<ConfigAttribute(null, 3)>]
member SocketLingerSec : int with get, set
[<ConfigAttribute(null, 3)>]
member SocketLingerSec : int with get, set

Property Value

Type: Online Int32
See Also
MpxBinding Class
MpxBinding Members
NFX.Glue.Native Namespace


MpxClientSocket Class

MpxClientSocket Class NFX Class Library

Represents client-side asynchronous socket. This socket initiates a connection to MpxServerSocket
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Glue.Native MpxSocket MpxClientTransport
NFX.Glue.Native MpxClientSocket
NFX.Glue.Native MpxWinClientSocket

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class MpxClientSocket : MpxSocket<MpxClientTransport>
public abstract class MpxClientSocket : MpxSocket<MpxClientTransport>
Public MustInherit Class MpxClientSocket
    Inherits MpxSocket(Of MpxClientTransport)
Public MustInherit Class MpxClientSocket
    Inherits MpxSocket(Of MpxClientTransport)
public ref class MpxClientSocket abstract : public MpxSocket<MpxClientTransport^>
public ref class MpxClientSocket abstract : public MpxSocket<MpxClientTransport^>
[<AbstractClassAttribute>]
type MpxClientSocket =
    class
        inherit MpxSocket<MpxClientTransport>
    end
[<AbstractClassAttribute>]
type MpxClientSocket =
    class
        inherit MpxSocket<MpxClientTransport>
    end
See Also
MpxClientSocket Members
NFX.Glue.Native Namespace


MpxClientSocket Members

MpxClientSocket Members NFX Class Library

The MpxClientSocket type exposes the following members.
Constructors
 | Name | Description
Protected method | MpxClientSocket | Initializes a new instance of the MpxClientSocket class
Back to Top
Methods
 | Name | Description
Public method | AcceptManagerVisit | Override to perform maintenance i.e. trim excessive m_SendChunk size etc.. This method is called by Glue/Binding/Transport runtime. Also resets last last idle manager visit timestamp which is used for socket closing (Inherited from MpxSocket TTransport .)
Protected method | Destructor | (Inherited from MpxSocket TTransport .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoReleaseMemChunksAfterAsyncOperations | Do not call this method, override only when freeing more than 2 standard chunks (send/recv) (Inherited from MpxSocket TTransport .)
Protected method | DoSend | (Inherited from MpxSocket TTransport .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSendChunk | Reserves a chunk of memory of the suggested size for network send operation. The buffer must be released by a call to ReleaseSendBuffer(). Keep in mind that this method is NOT RE-ENTRANT by this or any other thread until corresponding ReleaseSendChunk() is called. MpxSocket is not thread safe for sends in general. (Inherited from MpxSocket TTransport .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeReceive | Calls ReceiveAction callback guarding for possible unhandled receive action errors (Inherited from MpxSocket TTransport .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReleaseMemChunksAfterAsyncOperations | Releases socket memory chunks. This method MUST BE called AFTER all pending async IO is done, otherwise the chunks may get released to the pool and get corrupted by the prior operation (Inherited from MpxSocket TTransport .)
Public method | ReleaseSendChunk | Releases previously reserved buffer, i.e. may trim excess allocation after a large message (Inherited from MpxSocket TTransport .)
Public method | Send | Adds the specified socket msg to the outgoing stack. This is a synchronous blocking call that executes until the data is written into socket stack (but not necessarily delivered). If send error occurs then socket is marked as !Active (Disposed) (Inherited from MpxSocket TTransport .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_ClientSite | (Inherited from MpxSocket TTransport .)
Protected field | m_Disposing | (Inherited from MpxSocket TTransport .)
Protected field | m_EndPoint | (Inherited from MpxSocket TTransport .)
Protected field | m_LastIdleManagerVisit | (Inherited from MpxSocket TTransport .)
Protected field | m_ReceiveChunk | (Inherited from MpxSocket TTransport .)
Protected field | m_SendChunk | (Inherited from MpxSocket TTransport .)
Protected field | m_Socket | (Inherited from MpxSocket TTransport .)
Protected field | m_Transport | (Inherited from MpxSocket TTransport .)
Back to Top
Properties
 | Name | Description
Public property | Active | True when socket is not disposing and runtime is not shutting down (Inherited from MpxSocket TTransport .)
Public property | ClientSite | Returns client site for the computer that initiated the call. Server socket returns the transmitted value from client. Client socket returns the one that was sent to server upon handshake (Inherited from MpxSocket TTransport .)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndPoint | Returns IP End point that this socket services, remote server for client socket and remote client for server sockets (Inherited from MpxSocket TTransport .)
Public property | LastIdleManagerVisit | Returns timestamp of last manager visit since then no traffic came through. Null indicates that traffic came though and socket has not been idle since last visit. Manager is an extrenal visitor that closes idle sockets (Inherited from MpxSocket TTransport .)
Public property | Socket | Returns the underlying socket (Inherited from MpxSocket TTransport .)
Public property | Transport | Returns transport that this socket is under (Inherited from MpxSocket TTransport .)
Back to Top
See Also
MpxClientSocket Class
NFX.Glue.Native Namespace


MpxClientSocket Constructor

MpxClientSocket Constructor NFX Class Library

Initializes a new instance of the MpxClientSocket class

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal MpxClientSocket(
    MpxClientTransport transport,
    IPEndPoint remoteServer,
    ClientSite clientSite,
    MpxSocketReceiveAction<MpxClientTransport> receiveAction
)
protected internal MpxClientSocket(
    MpxClientTransport transport,
    IPEndPoint remoteServer,
    ClientSite clientSite,
    MpxSocketReceiveAction<MpxClientTransport> receiveAction
)
Protected Friend Sub New (
    transport As MpxClientTransport,
    remoteServer As IPEndPoint,
    clientSite As ClientSite,
    receiveAction As MpxSocketReceiveAction(Of MpxClientTransport)
)
Protected Friend Sub New (
    transport As MpxClientTransport,
    remoteServer As IPEndPoint,
    clientSite As ClientSite,
    receiveAction As MpxSocketReceiveAction(Of MpxClientTransport)
)
protected public:
MpxClientSocket(
    MpxClientTransport^ transport,
    IPEndPoint^ remoteServer,
    ClientSite clientSite,
    MpxSocketReceiveAction<MpxClientTransport^>^ receiveAction
)
protected public:
MpxClientSocket(
    MpxClientTransport^ transport,
    IPEndPoint^ remoteServer,
    ClientSite clientSite,
    MpxSocketReceiveAction<MpxClientTransport^>^ receiveAction
)
new :
        transport : MpxClientTransport *
        remoteServer : IPEndPoint *
        clientSite : ClientSite *
        receiveAction : MpxSocketReceiveAction<MpxClientTransport> -> MpxClientSocket
new :
        transport : MpxClientTransport *
        remoteServer : IPEndPoint *
        clientSite : ClientSite *
        receiveAction : MpxSocketReceiveAction<MpxClientTransport> -> MpxClientSocket

Parameters

transport
Type: NFX.Glue.Native MpxClientTransport
remoteServer
Type: Online System.Net IPEndPoint
clientSite
Type: NFX.Glue.Native ClientSite
receiveAction
Type: NFX.Glue.Native MpxSocketReceiveAction MpxClientTransport
See Also
MpxClientSocket Class
MpxClientSocket Members
NFX.Glue.Native Namespace


MpxClientSocket Fields

MpxClientSocket Fields NFX Class Library

The MpxClientSocket type exposes the following members.
Fields
 | Name | Description
Protected field | m_ClientSite | (Inherited from MpxSocket TTransport .)
Protected field | m_Disposing | (Inherited from MpxSocket TTransport .)
Protected field | m_EndPoint | (Inherited from MpxSocket TTransport .)
Protected field | m_LastIdleManagerVisit | (Inherited from MpxSocket TTransport .)
Protected field | m_ReceiveChunk | (Inherited from MpxSocket TTransport .)
Protected field | m_SendChunk | (Inherited from MpxSocket TTransport .)
Protected field | m_Socket | (Inherited from MpxSocket TTransport .)
Protected field | m_Transport | (Inherited from MpxSocket TTransport .)
Back to Top
See Also
MpxClientSocket Class
NFX.Glue.Native Namespace


MpxClientSocket Methods

MpxClientSocket Methods NFX Class Library

The MpxClientSocket type exposes the following members.
Methods
 | Name | Description
Public method | AcceptManagerVisit | Override to perform maintenance i.e. trim excessive m_SendChunk size etc.. This method is called by Glue/Binding/Transport runtime. Also resets last last idle manager visit timestamp which is used for socket closing (Inherited from MpxSocket TTransport .)
Protected method | Destructor | (Inherited from MpxSocket TTransport .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoReleaseMemChunksAfterAsyncOperations | Do not call this method, override only when freeing more than 2 standard chunks (send/recv) (Inherited from MpxSocket TTransport .)
Protected method | DoSend | (Inherited from MpxSocket TTransport .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSendChunk | Reserves a chunk of memory of the suggested size for network send operation. The buffer must be released by a call to ReleaseSendBuffer(). Keep in mind that this method is NOT RE-ENTRANT by this or any other thread until corresponding ReleaseSendChunk() is called. MpxSocket is not thread safe for sends in general. (Inherited from MpxSocket TTransport .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeReceive | Calls ReceiveAction callback guarding for possible unhandled receive action errors (Inherited from MpxSocket TTransport .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReleaseMemChunksAfterAsyncOperations | Releases socket memory chunks. This method MUST BE called AFTER all pending async IO is done, otherwise the chunks may get released to the pool and get corrupted by the prior operation (Inherited from MpxSocket TTransport .)
Public method | ReleaseSendChunk | Releases previously reserved buffer, i.e. may trim excess allocation after a large message (Inherited from MpxSocket TTransport .)
Public method | Send | Adds the specified socket msg to the outgoing stack. This is a synchronous blocking call that executes until the data is written into socket stack (but not necessarily delivered). If send error occurs then socket is marked as !Active (Disposed) (Inherited from MpxSocket TTransport .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MpxClientSocket Class
NFX.Glue.Native Namespace


MpxClientSocket Properties

MpxClientSocket Properties NFX Class Library

The MpxClientSocket type exposes the following members.
Properties
 | Name | Description
Public property | Active | True when socket is not disposing and runtime is not shutting down (Inherited from MpxSocket TTransport .)
Public property | ClientSite | Returns client site for the computer that initiated the call. Server socket returns the transmitted value from client. Client socket returns the one that was sent to server upon handshake (Inherited from MpxSocket TTransport .)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndPoint | Returns IP End point that this socket services, remote server for client socket and remote client for server sockets (Inherited from MpxSocket TTransport .)
Public property | LastIdleManagerVisit | Returns timestamp of last manager visit since then no traffic came through. Null indicates that traffic came though and socket has not been idle since last visit. Manager is an extrenal visitor that closes idle sockets (Inherited from MpxSocket TTransport .)
Public property | Socket | Returns the underlying socket (Inherited from MpxSocket TTransport .)
Public property | Transport | Returns transport that this socket is under (Inherited from MpxSocket TTransport .)
Back to Top
See Also
MpxClientSocket Class
NFX.Glue.Native Namespace


MpxClientTransport Class

MpxClientTransport Class NFX Class Library

Implements asynchronous MPX client transport for MpxBinding
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service Binding
NFX.Glue Transport
NFX.Glue ClientTransport
NFX.Glue ClientTransport MpxBinding
NFX.Glue.Native MpxClientTransport

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class MpxClientTransport : ClientTransport<MpxBinding>,
    IMpxTransport
public sealed class MpxClientTransport : ClientTransport<MpxBinding>,
    IMpxTransport
Public NotInheritable Class MpxClientTransport
    Inherits ClientTransport(Of MpxBinding)
    Implements IMpxTransport
Public NotInheritable Class MpxClientTransport
    Inherits ClientTransport(Of MpxBinding)
    Implements IMpxTransport
public ref class MpxClientTransport sealed : public ClientTransport<MpxBinding^>,
    IMpxTransport
public ref class MpxClientTransport sealed : public ClientTransport<MpxBinding^>,
    IMpxTransport
[<SealedAttribute>]
type MpxClientTransport =
    class
        inherit ClientTransport<MpxBinding>
        interface IMpxTransport
    end
[<SealedAttribute>]
type MpxClientTransport =
    class
        inherit ClientTransport<MpxBinding>
        interface IMpxTransport
    end
See Also
MpxClientTransport Members
NFX.Glue.Native Namespace


MpxClientTransport Members

MpxClientTransport Members NFX Class Library

The MpxClientTransport type exposes the following members.
Constructors
 | Name | Description
Public method | MpxClientTransport | Initializes a new instance of the MpxClientTransport class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and transport instance are running or throws otherwise (Inherited from Transport.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Transport.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoDumpInstrumentationData | Override to dump instrumentation data, dont forget to call base to dump basic metrics (Inherited from Transport.)
Protected method | DoSendRequest | (Overrides ClientTransport DoSendRequest(ClientEndPoint, RequestMsg, CallOptions).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides Transport DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | DumpInstrumentationData | Dumps instrumentation data (Inherited from Transport.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Release | Releases transport by setting Acquired flag to false so it can be used by other operations (Inherited from Transport.)
Public method | ResetStats | Resets all statistical counters (Inherited from Transport.)
Public method | SendRequest | Sends a client request into remote endpoint. This is a blocking call for bindings that are OperationFlow.Synchronous and result arrives immediately into CallSlot. (Inherited from ClientTransport.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Protected method | stat_BytesReceived | (Inherited from Transport.)
Protected method | stat_BytesSent | (Inherited from Transport.)
Protected method | stat_Errors | (Inherited from Transport.)
Protected method | stat_MsgReceived | (Inherited from Transport.)
Protected method | stat_MsgSent | (Inherited from Transport.)
Protected method | stat_Time | Processes named time measurement statistical sample by using EMA filter (Inherited from Transport.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryAcquire | A thread-safe operation that tries to acquire(reserve) this instance for exclusive use. Returns true if acqusition succeded, false is this instance is reserved by someone else (Inherited from Transport.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_TransportKind | (Inherited from Transport.)
Back to Top
Properties
 | Name | Description
Public property | Acquired | Returns true when this transport instance has been acquired by some operation and is busy (Inherited from Transport.)
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | Binding | (Inherited from ClientTransport TBinding .)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExpirationStart | Returns timestamp when manager touched the instance for last time and no traffic went through it since (Inherited from Transport.)
Public property | Glue | Returns glue implementation that this transport is under (Inherited from Transport.)
Public property | IdleAgeMs | Returns the duration of transport idle period in ms. (Inherited from Transport.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Node | Returns node that this transport services (Inherited from Transport.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | StatBytesReceived | Returns how many bytes were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatBytesSent | Returns how many bytes were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatErrors | Returns how many message processing errors happened since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgReceived | Returns how many messages were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgSent | Returns how many messages were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatTimes | Returns enumerable of named times measured in double second fractions. The returned times are EMA-filtered from supplied individual measurement samples (Inherited from Transport.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransportKind | Reports if this is a server or client transport (Inherited from Transport.)
Back to Top
See Also
MpxClientTransport Class
NFX.Glue.Native Namespace


MpxClientTransport Constructor

MpxClientTransport Constructor NFX Class Library

Initializes a new instance of the MpxClientTransport class

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MpxClientTransport(
    MpxBinding binding,
    Node node
)
public MpxClientTransport(
    MpxBinding binding,
    Node node
)
Public Sub New (
    binding As MpxBinding,
    node As Node
)
Public Sub New (
    binding As MpxBinding,
    node As Node
)
public:
MpxClientTransport(
    MpxBinding^ binding,
    Node node
)
public:
MpxClientTransport(
    MpxBinding^ binding,
    Node node
)
new :
        binding : MpxBinding *
        node : Node -> MpxClientTransport
new :
        binding : MpxBinding *
        node : Node -> MpxClientTransport

Parameters

binding
Type: NFX.Glue.Native MpxBinding
node
Type: NFX.Glue Node
See Also
MpxClientTransport Class
MpxClientTransport Members
NFX.Glue.Native Namespace


MpxClientTransport Fields

MpxClientTransport Fields NFX Class Library

The MpxClientTransport type exposes the following members.
Fields
 | Name | Description
Protected field | m_TransportKind | (Inherited from Transport.)
Back to Top
See Also
MpxClientTransport Class
NFX.Glue.Native Namespace


MpxClientTransport Methods

MpxClientTransport Methods NFX Class Library

The MpxClientTransport type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and transport instance are running or throws otherwise (Inherited from Transport.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Transport.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoDumpInstrumentationData | Override to dump instrumentation data, dont forget to call base to dump basic metrics (Inherited from Transport.)
Protected method | DoSendRequest | (Overrides ClientTransport DoSendRequest(ClientEndPoint, RequestMsg, CallOptions).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides Transport DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | DumpInstrumentationData | Dumps instrumentation data (Inherited from Transport.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Release | Releases transport by setting Acquired flag to false so it can be used by other operations (Inherited from Transport.)
Public method | ResetStats | Resets all statistical counters (Inherited from Transport.)
Public method | SendRequest | Sends a client request into remote endpoint. This is a blocking call for bindings that are OperationFlow.Synchronous and result arrives immediately into CallSlot. (Inherited from ClientTransport.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Protected method | stat_BytesReceived | (Inherited from Transport.)
Protected method | stat_BytesSent | (Inherited from Transport.)
Protected method | stat_Errors | (Inherited from Transport.)
Protected method | stat_MsgReceived | (Inherited from Transport.)
Protected method | stat_MsgSent | (Inherited from Transport.)
Protected method | stat_Time | Processes named time measurement statistical sample by using EMA filter (Inherited from Transport.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryAcquire | A thread-safe operation that tries to acquire(reserve) this instance for exclusive use. Returns true if acqusition succeded, false is this instance is reserved by someone else (Inherited from Transport.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MpxClientTransport Class
NFX.Glue.Native Namespace


MpxClientTransport.DoSendRequest Method

MpxClientTransport DoSendRequest Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override CallSlot DoSendRequest(
    ClientEndPoint endpoint,
    RequestMsg request,
    CallOptions options
)
protected override CallSlot DoSendRequest(
    ClientEndPoint endpoint,
    RequestMsg request,
    CallOptions options
)
Protected Overrides Function DoSendRequest (
    endpoint As ClientEndPoint,
    request As RequestMsg,
    options As CallOptions
) As CallSlot
Protected Overrides Function DoSendRequest (
    endpoint As ClientEndPoint,
    request As RequestMsg,
    options As CallOptions
) As CallSlot
protected:
virtual CallSlot^ DoSendRequest(
    ClientEndPoint^ endpoint,
    RequestMsg^ request,
    CallOptions options
) override
protected:
virtual CallSlot^ DoSendRequest(
    ClientEndPoint^ endpoint,
    RequestMsg^ request,
    CallOptions options
) override
abstract DoSendRequest :
        endpoint : ClientEndPoint *
        request : RequestMsg *
        options : CallOptions -> CallSlot
override DoSendRequest :
        endpoint : ClientEndPoint *
        request : RequestMsg *
        options : CallOptions -> CallSlot
abstract DoSendRequest :
        endpoint : ClientEndPoint *
        request : RequestMsg *
        options : CallOptions -> CallSlot
override DoSendRequest :
        endpoint : ClientEndPoint *
        request : RequestMsg *
        options : CallOptions -> CallSlot

Parameters

endpoint
Type: NFX.Glue ClientEndPoint
request
Type: NFX.Glue.Protocol RequestMsg
options
Type: NFX.Glue.Protocol CallOptions

Return Value

Type: CallSlot
See Also
MpxClientTransport Class
MpxClientTransport Members
NFX.Glue.Native Namespace


MpxClientTransport.DoStart Method

MpxClientTransport DoStart Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
MpxClientTransport Class
MpxClientTransport Members
NFX.Glue.Native Namespace


MpxClientTransport.DoWaitForCompleteStop Method

MpxClientTransport DoWaitForCompleteStop Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
MpxClientTransport Class
MpxClientTransport Members
NFX.Glue.Native Namespace


MpxClientTransport Properties

MpxClientTransport Properties NFX Class Library

The MpxClientTransport type exposes the following members.
Properties
 | Name | Description
Public property | Acquired | Returns true when this transport instance has been acquired by some operation and is busy (Inherited from Transport.)
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | Binding | (Inherited from ClientTransport TBinding .)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExpirationStart | Returns timestamp when manager touched the instance for last time and no traffic went through it since (Inherited from Transport.)
Public property | Glue | Returns glue implementation that this transport is under (Inherited from Transport.)
Public property | IdleAgeMs | Returns the duration of transport idle period in ms. (Inherited from Transport.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Node | Returns node that this transport services (Inherited from Transport.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | StatBytesReceived | Returns how many bytes were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatBytesSent | Returns how many bytes were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatErrors | Returns how many message processing errors happened since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgReceived | Returns how many messages were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgSent | Returns how many messages were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatTimes | Returns enumerable of named times measured in double second fractions. The returned times are EMA-filtered from supplied individual measurement samples (Inherited from Transport.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransportKind | Reports if this is a server or client transport (Inherited from Transport.)
Back to Top
See Also
MpxClientTransport Class
NFX.Glue.Native Namespace


MpxListener Class

MpxListener Class NFX Class Library

Represents a server-side listener socket that accepts the calls
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Glue.Native MpxListener
NFX.Glue.Native MpxWinListener

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class MpxListener : DisposableObject
public abstract class MpxListener : DisposableObject
Public MustInherit Class MpxListener
    Inherits DisposableObject
Public MustInherit Class MpxListener
    Inherits DisposableObject
public ref class MpxListener abstract : public DisposableObject
public ref class MpxListener abstract : public DisposableObject
[<AbstractClassAttribute>]
type MpxListener =
    class
        inherit DisposableObject
    end
[<AbstractClassAttribute>]
type MpxListener =
    class
        inherit DisposableObject
    end
See Also
MpxListener Members
NFX.Glue.Native Namespace


MpxListener Members

MpxListener Members NFX Class Library

The MpxListener type exposes the following members.
Constructors
 | Name | Description
Protected method | MpxListener | Initializes a new instance of the MpxListener class
Back to Top
Methods
 | Name | Description
Protected method | Destructor | Override this method to do actual destructor work (Inherited from DisposableObject.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_EndPoint |
Protected field | m_SocketReceiveAction |
Back to Top
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndPoint | Returns IP End point that this listener listens on
Public property | Transport | Returns transpoirt that this listener listens under
Back to Top
See Also
MpxListener Class
NFX.Glue.Native Namespace


MpxListener Constructor

MpxListener Constructor NFX Class Library

Initializes a new instance of the MpxListener class

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal MpxListener(
    MpxServerTransport transport,
    IPEndPoint listenEndPoint,
    MpxSocketReceiveAction<MpxServerTransport> socketReceiveAction
)
protected internal MpxListener(
    MpxServerTransport transport,
    IPEndPoint listenEndPoint,
    MpxSocketReceiveAction<MpxServerTransport> socketReceiveAction
)
Protected Friend Sub New (
    transport As MpxServerTransport,
    listenEndPoint As IPEndPoint,
    socketReceiveAction As MpxSocketReceiveAction(Of MpxServerTransport)
)
Protected Friend Sub New (
    transport As MpxServerTransport,
    listenEndPoint As IPEndPoint,
    socketReceiveAction As MpxSocketReceiveAction(Of MpxServerTransport)
)
protected public:
MpxListener(
    MpxServerTransport^ transport,
    IPEndPoint^ listenEndPoint,
    MpxSocketReceiveAction<MpxServerTransport^>^ socketReceiveAction
)
protected public:
MpxListener(
    MpxServerTransport^ transport,
    IPEndPoint^ listenEndPoint,
    MpxSocketReceiveAction<MpxServerTransport^>^ socketReceiveAction
)
new :
        transport : MpxServerTransport *
        listenEndPoint : IPEndPoint *
        socketReceiveAction : MpxSocketReceiveAction<MpxServerTransport> -> MpxListener
new :
        transport : MpxServerTransport *
        listenEndPoint : IPEndPoint *
        socketReceiveAction : MpxSocketReceiveAction<MpxServerTransport> -> MpxListener

Parameters

transport
Type: NFX.Glue.Native MpxServerTransport
listenEndPoint
Type: Online System.Net IPEndPoint
socketReceiveAction
Type: NFX.Glue.Native MpxSocketReceiveAction MpxServerTransport
See Also
MpxListener Class
MpxListener Members
NFX.Glue.Native Namespace


MpxListener Fields

MpxListener Fields NFX Class Library

The MpxListener type exposes the following members.
Fields
 | Name | Description
Protected field | m_EndPoint |
Protected field | m_SocketReceiveAction |
Back to Top
See Also
MpxListener Class
NFX.Glue.Native Namespace


MpxListener.m_EndPoint Field

MpxListener m_EndPoint Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected readonly IPEndPoint m_EndPoint
protected readonly IPEndPoint m_EndPoint
Protected ReadOnly m_EndPoint As IPEndPoint
Protected ReadOnly m_EndPoint As IPEndPoint
protected:
initonly IPEndPoint^ m_EndPoint
protected:
initonly IPEndPoint^ m_EndPoint
val m_EndPoint: IPEndPoint
val m_EndPoint: IPEndPoint

Field Value

Type: Online IPEndPoint
See Also
MpxListener Class
MpxListener Members
NFX.Glue.Native Namespace


MpxListener.m_SocketReceiveAction Field

MpxListener m_SocketReceiveAction Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected readonly MpxSocketReceiveAction<MpxServerTransport> m_SocketReceiveAction
protected readonly MpxSocketReceiveAction<MpxServerTransport> m_SocketReceiveAction
Protected ReadOnly m_SocketReceiveAction As MpxSocketReceiveAction(Of MpxServerTransport)
Protected ReadOnly m_SocketReceiveAction As MpxSocketReceiveAction(Of MpxServerTransport)
protected:
initonly MpxSocketReceiveAction<MpxServerTransport^>^ m_SocketReceiveAction
protected:
initonly MpxSocketReceiveAction<MpxServerTransport^>^ m_SocketReceiveAction
val m_SocketReceiveAction: MpxSocketReceiveAction<MpxServerTransport>
val m_SocketReceiveAction: MpxSocketReceiveAction<MpxServerTransport>

Field Value

Type: MpxSocketReceiveAction MpxServerTransport
See Also
MpxListener Class
MpxListener Members
NFX.Glue.Native Namespace


MpxListener Methods

MpxListener Methods NFX Class Library

The MpxListener type exposes the following members.
Methods
 | Name | Description
Protected method | Destructor | Override this method to do actual destructor work (Inherited from DisposableObject.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MpxListener Class
NFX.Glue.Native Namespace


MpxListener Properties

MpxListener Properties NFX Class Library

The MpxListener type exposes the following members.
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndPoint | Returns IP End point that this listener listens on
Public property | Transport | Returns transpoirt that this listener listens under
Back to Top
See Also
MpxListener Class
NFX.Glue.Native Namespace


MpxListener.EndPoint Property

MpxListener EndPoint Property NFX Class Library

Returns IP End point that this listener listens on

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IPEndPoint EndPoint { get; }
public IPEndPoint EndPoint { get; }
Public ReadOnly Property EndPoint As IPEndPoint
    Get
Public ReadOnly Property EndPoint As IPEndPoint
    Get
public:
property IPEndPoint^ EndPoint {
    IPEndPoint^ get ();
}
public:
property IPEndPoint^ EndPoint {
    IPEndPoint^ get ();
}
member EndPoint : IPEndPoint with get
member EndPoint : IPEndPoint with get

Property Value

Type: Online IPEndPoint
See Also
MpxListener Class
MpxListener Members
NFX.Glue.Native Namespace


MpxListener.Transport Property

MpxListener Transport Property NFX Class Library

Returns transpoirt that this listener listens under

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MpxServerTransport Transport { get; }
public MpxServerTransport Transport { get; }
Public ReadOnly Property Transport As MpxServerTransport
    Get
Public ReadOnly Property Transport As MpxServerTransport
    Get
public:
property MpxServerTransport^ Transport {
    MpxServerTransport^ get ();
}
public:
property MpxServerTransport^ Transport {
    MpxServerTransport^ get ();
}
member Transport : MpxServerTransport with get
member Transport : MpxServerTransport with get

Property Value

Type: MpxServerTransport
See Also
MpxListener Class
MpxListener Members
NFX.Glue.Native Namespace


MpxServerSocket Class

MpxServerSocket Class NFX Class Library

Represents server-side asynchronous socket that clients connect to
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Glue.Native MpxSocket MpxServerTransport
NFX.Glue.Native MpxServerSocket
NFX.Glue.Native MpxWinServerSocket

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class MpxServerSocket : MpxSocket<MpxServerTransport>
public abstract class MpxServerSocket : MpxSocket<MpxServerTransport>
Public MustInherit Class MpxServerSocket
    Inherits MpxSocket(Of MpxServerTransport)
Public MustInherit Class MpxServerSocket
    Inherits MpxSocket(Of MpxServerTransport)
public ref class MpxServerSocket abstract : public MpxSocket<MpxServerTransport^>
public ref class MpxServerSocket abstract : public MpxSocket<MpxServerTransport^>
[<AbstractClassAttribute>]
type MpxServerSocket =
    class
        inherit MpxSocket<MpxServerTransport>
    end
[<AbstractClassAttribute>]
type MpxServerSocket =
    class
        inherit MpxSocket<MpxServerTransport>
    end
See Also
MpxServerSocket Members
NFX.Glue.Native Namespace


MpxServerSocket Members

MpxServerSocket Members NFX Class Library

The MpxServerSocket type exposes the following members.
Constructors
 | Name | Description
Protected method | MpxServerSocket | Initializes a new instance of the MpxServerSocket class
Back to Top
Methods
 | Name | Description
Public method | AcceptManagerVisit | (Overrides MpxSocket TTransport AcceptManagerVisit(DateTime).)
Protected method | Destructor | (Overrides MpxSocket TTransport Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoReleaseMemChunksAfterAsyncOperations | Do not call this method, override only when freeing more than 2 standard chunks (send/recv) (Inherited from MpxSocket TTransport .)
Protected method | DoSend | (Inherited from MpxSocket TTransport .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSendChunk | Reserves a chunk of memory of the suggested size for network send operation. The buffer must be released by a call to ReleaseSendBuffer(). Keep in mind that this method is NOT RE-ENTRANT by this or any other thread until corresponding ReleaseSendChunk() is called. MpxSocket is not thread safe for sends in general. (Inherited from MpxSocket TTransport .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeReceive | Calls ReceiveAction callback guarding for possible unhandled receive action errors (Inherited from MpxSocket TTransport .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReleaseMemChunksAfterAsyncOperations | Releases socket memory chunks. This method MUST BE called AFTER all pending async IO is done, otherwise the chunks may get released to the pool and get corrupted by the prior operation (Inherited from MpxSocket TTransport .)
Public method | ReleaseSendChunk | Releases previously reserved buffer, i.e. may trim excess allocation after a large message (Inherited from MpxSocket TTransport .)
Public method | Send | Adds the specified socket msg to the outgoing stack. This is a synchronous blocking call that executes until the data is written into socket stack (but not necessarily delivered). If send error occurs then socket is marked as !Active (Disposed) (Inherited from MpxSocket TTransport .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_ClientSite | (Inherited from MpxSocket TTransport .)
Protected field | m_Disposing | (Inherited from MpxSocket TTransport .)
Protected field | m_EndPoint | (Inherited from MpxSocket TTransport .)
Protected field | m_LastIdleManagerVisit | (Inherited from MpxSocket TTransport .)
Protected field | m_ReceiveChunk | (Inherited from MpxSocket TTransport .)
Protected field | m_SendChunk | (Inherited from MpxSocket TTransport .)
Protected field | m_Socket | (Inherited from MpxSocket TTransport .)
Protected field | m_Transport | (Inherited from MpxSocket TTransport .)
Back to Top
Properties
 | Name | Description
Public property | Active | True when socket is not disposing and runtime is not shutting down (Inherited from MpxSocket TTransport .)
Public property | ClientSite | Returns client site for the computer that initiated the call. Server socket returns the transmitted value from client. Client socket returns the one that was sent to server upon handshake (Inherited from MpxSocket TTransport .)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndPoint | Returns IP End point that this socket services, remote server for client socket and remote client for server sockets (Inherited from MpxSocket TTransport .)
Public property | LastIdleManagerVisit | Returns timestamp of last manager visit since then no traffic came through. Null indicates that traffic came though and socket has not been idle since last visit. Manager is an extrenal visitor that closes idle sockets (Inherited from MpxSocket TTransport .)
Public property | Listener | Returns listener socket that initiated/opened this server socket
Public property | Socket | Returns the underlying socket (Inherited from MpxSocket TTransport .)
Public property | Transport | Returns transport that this socket is under (Inherited from MpxSocket TTransport .)
Back to Top
See Also
MpxServerSocket Class
NFX.Glue.Native Namespace


MpxServerSocket Constructor

MpxServerSocket Constructor NFX Class Library

Initializes a new instance of the MpxServerSocket class

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal MpxServerSocket(
    MpxListener listener,
    IPEndPoint clientEndPoint,
    ClientSite clientSite,
    MpxSocketReceiveAction<MpxServerTransport> receiveAction
)
protected internal MpxServerSocket(
    MpxListener listener,
    IPEndPoint clientEndPoint,
    ClientSite clientSite,
    MpxSocketReceiveAction<MpxServerTransport> receiveAction
)
Protected Friend Sub New (
    listener As MpxListener,
    clientEndPoint As IPEndPoint,
    clientSite As ClientSite,
    receiveAction As MpxSocketReceiveAction(Of MpxServerTransport)
)
Protected Friend Sub New (
    listener As MpxListener,
    clientEndPoint As IPEndPoint,
    clientSite As ClientSite,
    receiveAction As MpxSocketReceiveAction(Of MpxServerTransport)
)
protected public:
MpxServerSocket(
    MpxListener^ listener,
    IPEndPoint^ clientEndPoint,
    ClientSite clientSite,
    MpxSocketReceiveAction<MpxServerTransport^>^ receiveAction
)
protected public:
MpxServerSocket(
    MpxListener^ listener,
    IPEndPoint^ clientEndPoint,
    ClientSite clientSite,
    MpxSocketReceiveAction<MpxServerTransport^>^ receiveAction
)
new :
        listener : MpxListener *
        clientEndPoint : IPEndPoint *
        clientSite : ClientSite *
        receiveAction : MpxSocketReceiveAction<MpxServerTransport> -> MpxServerSocket
new :
        listener : MpxListener *
        clientEndPoint : IPEndPoint *
        clientSite : ClientSite *
        receiveAction : MpxSocketReceiveAction<MpxServerTransport> -> MpxServerSocket

Parameters

listener
Type: NFX.Glue.Native MpxListener
clientEndPoint
Type: Online System.Net IPEndPoint
clientSite
Type: NFX.Glue.Native ClientSite
receiveAction
Type: NFX.Glue.Native MpxSocketReceiveAction MpxServerTransport
See Also
MpxServerSocket Class
MpxServerSocket Members
NFX.Glue.Native Namespace


MpxServerSocket Fields

MpxServerSocket Fields NFX Class Library

The MpxServerSocket type exposes the following members.
Fields
 | Name | Description
Protected field | m_ClientSite | (Inherited from MpxSocket TTransport .)
Protected field | m_Disposing | (Inherited from MpxSocket TTransport .)
Protected field | m_EndPoint | (Inherited from MpxSocket TTransport .)
Protected field | m_LastIdleManagerVisit | (Inherited from MpxSocket TTransport .)
Protected field | m_ReceiveChunk | (Inherited from MpxSocket TTransport .)
Protected field | m_SendChunk | (Inherited from MpxSocket TTransport .)
Protected field | m_Socket | (Inherited from MpxSocket TTransport .)
Protected field | m_Transport | (Inherited from MpxSocket TTransport .)
Back to Top
See Also
MpxServerSocket Class
NFX.Glue.Native Namespace


MpxServerSocket Methods

MpxServerSocket Methods NFX Class Library

The MpxServerSocket type exposes the following members.
Methods
 | Name | Description
Public method | AcceptManagerVisit | (Overrides MpxSocket TTransport AcceptManagerVisit(DateTime).)
Protected method | Destructor | (Overrides MpxSocket TTransport Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoReleaseMemChunksAfterAsyncOperations | Do not call this method, override only when freeing more than 2 standard chunks (send/recv) (Inherited from MpxSocket TTransport .)
Protected method | DoSend | (Inherited from MpxSocket TTransport .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSendChunk | Reserves a chunk of memory of the suggested size for network send operation. The buffer must be released by a call to ReleaseSendBuffer(). Keep in mind that this method is NOT RE-ENTRANT by this or any other thread until corresponding ReleaseSendChunk() is called. MpxSocket is not thread safe for sends in general. (Inherited from MpxSocket TTransport .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeReceive | Calls ReceiveAction callback guarding for possible unhandled receive action errors (Inherited from MpxSocket TTransport .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReleaseMemChunksAfterAsyncOperations | Releases socket memory chunks. This method MUST BE called AFTER all pending async IO is done, otherwise the chunks may get released to the pool and get corrupted by the prior operation (Inherited from MpxSocket TTransport .)
Public method | ReleaseSendChunk | Releases previously reserved buffer, i.e. may trim excess allocation after a large message (Inherited from MpxSocket TTransport .)
Public method | Send | Adds the specified socket msg to the outgoing stack. This is a synchronous blocking call that executes until the data is written into socket stack (but not necessarily delivered). If send error occurs then socket is marked as !Active (Disposed) (Inherited from MpxSocket TTransport .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MpxServerSocket Class
NFX.Glue.Native Namespace


MpxServerSocket.AcceptManagerVisit Method

MpxServerSocket AcceptManagerVisit Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void AcceptManagerVisit(
    DateTime when
)
public override void AcceptManagerVisit(
    DateTime when
)
Public Overrides Sub AcceptManagerVisit (
    when As DateTime
)
Public Overrides Sub AcceptManagerVisit (
    when As DateTime
)
public:
virtual void AcceptManagerVisit(
    DateTime when
) override
public:
virtual void AcceptManagerVisit(
    DateTime when
) override
abstract AcceptManagerVisit :
        when : DateTime -> unit
override AcceptManagerVisit :
        when : DateTime -> unit
abstract AcceptManagerVisit :
        when : DateTime -> unit
override AcceptManagerVisit :
        when : DateTime -> unit

Parameters

when
Type: Online System DateTime
See Also
MpxServerSocket Class
MpxServerSocket Members
NFX.Glue.Native Namespace


MpxServerSocket.Destructor Method

MpxServerSocket Destructor Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
MpxServerSocket Class
MpxServerSocket Members
NFX.Glue.Native Namespace


MpxServerSocket Properties

MpxServerSocket Properties NFX Class Library

The MpxServerSocket type exposes the following members.
Properties
 | Name | Description
Public property | Active | True when socket is not disposing and runtime is not shutting down (Inherited from MpxSocket TTransport .)
Public property | ClientSite | Returns client site for the computer that initiated the call. Server socket returns the transmitted value from client. Client socket returns the one that was sent to server upon handshake (Inherited from MpxSocket TTransport .)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndPoint | Returns IP End point that this socket services, remote server for client socket and remote client for server sockets (Inherited from MpxSocket TTransport .)
Public property | LastIdleManagerVisit | Returns timestamp of last manager visit since then no traffic came through. Null indicates that traffic came though and socket has not been idle since last visit. Manager is an extrenal visitor that closes idle sockets (Inherited from MpxSocket TTransport .)
Public property | Listener | Returns listener socket that initiated/opened this server socket
Public property | Socket | Returns the underlying socket (Inherited from MpxSocket TTransport .)
Public property | Transport | Returns transport that this socket is under (Inherited from MpxSocket TTransport .)
Back to Top
See Also
MpxServerSocket Class
NFX.Glue.Native Namespace


MpxServerSocket.Listener Property

MpxServerSocket Listener Property NFX Class Library

Returns listener socket that initiated/opened this server socket

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MpxListener Listener { get; }
public MpxListener Listener { get; }
Public ReadOnly Property Listener As MpxListener
    Get
Public ReadOnly Property Listener As MpxListener
    Get
public:
property MpxListener^ Listener {
    MpxListener^ get ();
}
public:
property MpxListener^ Listener {
    MpxListener^ get ();
}
member Listener : MpxListener with get
member Listener : MpxListener with get

Property Value

Type: MpxListener
See Also
MpxServerSocket Class
MpxServerSocket Members
NFX.Glue.Native Namespace


MpxServerTransport Class

MpxServerTransport Class NFX Class Library

Implements asynchronous MPX server transport for MpxBinding
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service Binding
NFX.Glue Transport
NFX.Glue ServerTransport
NFX.Glue ServerTransport MpxBinding
NFX.Glue.Native MpxServerTransport

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class MpxServerTransport : ServerTransport<MpxBinding>,
    IMpxTransport
public sealed class MpxServerTransport : ServerTransport<MpxBinding>,
    IMpxTransport
Public NotInheritable Class MpxServerTransport
    Inherits ServerTransport(Of MpxBinding)
    Implements IMpxTransport
Public NotInheritable Class MpxServerTransport
    Inherits ServerTransport(Of MpxBinding)
    Implements IMpxTransport
public ref class MpxServerTransport sealed : public ServerTransport<MpxBinding^>,
    IMpxTransport
public ref class MpxServerTransport sealed : public ServerTransport<MpxBinding^>,
    IMpxTransport
[<SealedAttribute>]
type MpxServerTransport =
    class
        inherit ServerTransport<MpxBinding>
        interface IMpxTransport
    end
[<SealedAttribute>]
type MpxServerTransport =
    class
        inherit ServerTransport<MpxBinding>
        interface IMpxTransport
    end
See Also
MpxServerTransport Members
NFX.Glue.Native Namespace


MpxServerTransport Members

MpxServerTransport Members NFX Class Library

The MpxServerTransport type exposes the following members.
Constructors
 | Name | Description
Public method | MpxServerTransport | Allocates a listener transport
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and transport instance are running or throws otherwise (Inherited from Transport.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Protected method | ClientSiteConnected | Notifies the transport that site connection has arrived so the transport may allocate some site/socket-specific state. Called from listener
Protected method | ClientSiteDisconnected | Notifies the transport that site connection has closed/broke so the transport may de-allocate some site/socket-specific state. Called from listener
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Transport.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | (Overrides Service DoAcceptManagerVisit(Object, DateTime).)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoDumpInstrumentationData | (Overrides Transport DoDumpInstrumentationData .)
Protected method | DoSendResponse | (Overrides ServerTransport DoSendResponse(ResponseMsg).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides Transport DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | DumpInstrumentationData | Dumps instrumentation data (Inherited from Transport.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Release | Releases transport by setting Acquired flag to false so it can be used by other operations (Inherited from Transport.)
Public method | ResetStats | Resets all statistical counters (Inherited from Transport.)
Public method | SendResponse | Sends a response into remote client endpoint (Inherited from ServerTransport.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Protected method | stat_BytesReceived | (Inherited from Transport.)
Protected method | stat_BytesSent | (Inherited from Transport.)
Protected method | stat_Errors | (Inherited from Transport.)
Protected method | stat_MsgReceived | (Inherited from Transport.)
Protected method | stat_MsgSent | (Inherited from Transport.)
Protected method | stat_Time | Processes named time measurement statistical sample by using EMA filter (Inherited from Transport.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryAcquire | A thread-safe operation that tries to acquire(reserve) this instance for exclusive use. Returns true if acqusition succeded, false is this instance is reserved by someone else (Inherited from Transport.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_OpenChannels |
Protected field | m_TransportKind | (Inherited from Transport.)
Back to Top
Properties
 | Name | Description
Public property | Acquired | Returns true when this transport instance has been acquired by some operation and is busy (Inherited from Transport.)
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | Binding | (Inherited from ServerTransport TBinding .)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExpirationStart | Returns timestamp when manager touched the instance for last time and no traffic went through it since (Inherited from Transport.)
Public property | Glue | Returns glue implementation that this transport is under (Inherited from Transport.)
Public property | IdleAgeMs | Returns the duration of transport idle period in ms. (Inherited from Transport.)
Public property | IsListener | Indicates whether this instance is the one that accepts connections. Depending on implementation listeners may allocate other transports after they accept incoming connect request (i.e. TCP) (Inherited from ServerTransport.)
Public property | Listener | Returns a listener transport that opened this one. If this is a listener transport then returns null. Not all technologies support listener/child transports (TCP does) (Inherited from ServerTransport.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Node | Returns node that this transport services (Inherited from Transport.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | ServerEndpoint | Returns server endpoint instance that opened this transport (Inherited from ServerTransport.)
Public property | StatBytesReceived | Returns how many bytes were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatBytesSent | Returns how many bytes were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatErrors | Returns how many message processing errors happened since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgReceived | Returns how many messages were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgSent | Returns how many messages were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatTimes | Returns enumerable of named times measured in double second fractions. The returned times are EMA-filtered from supplied individual measurement samples (Inherited from Transport.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransportKind | Reports if this is a server or client transport (Inherited from Transport.)
Back to Top
See Also
MpxServerTransport Class
NFX.Glue.Native Namespace


MpxServerTransport Constructor

MpxServerTransport Constructor NFX Class Library

Allocates a listener transport

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MpxServerTransport(
    MpxBinding binding,
    ServerEndPoint serverEndpoint,
    IPAddress localAddr,
    int port
)
public MpxServerTransport(
    MpxBinding binding,
    ServerEndPoint serverEndpoint,
    IPAddress localAddr,
    int port
)
Public Sub New (
    binding As MpxBinding,
    serverEndpoint As ServerEndPoint,
    localAddr As IPAddress,
    port As Integer
)
Public Sub New (
    binding As MpxBinding,
    serverEndpoint As ServerEndPoint,
    localAddr As IPAddress,
    port As Integer
)
public:
MpxServerTransport(
    MpxBinding^ binding,
    ServerEndPoint^ serverEndpoint,
    IPAddress^ localAddr,
    int port
)
public:
MpxServerTransport(
    MpxBinding^ binding,
    ServerEndPoint^ serverEndpoint,
    IPAddress^ localAddr,
    int port
)
new :
        binding : MpxBinding *
        serverEndpoint : ServerEndPoint *
        localAddr : IPAddress *
        port : int -> MpxServerTransport
new :
        binding : MpxBinding *
        serverEndpoint : ServerEndPoint *
        localAddr : IPAddress *
        port : int -> MpxServerTransport

Parameters

binding
Type: NFX.Glue.Native MpxBinding
serverEndpoint
Type: NFX.Glue ServerEndPoint
localAddr
Type: Online System.Net IPAddress
port
Type: Online System Int32
See Also
MpxServerTransport Class
MpxServerTransport Members
NFX.Glue.Native Namespace


MpxServerTransport Fields

MpxServerTransport Fields NFX Class Library

The MpxServerTransport type exposes the following members.
Fields
 | Name | Description
Protected field | m_OpenChannels |
Protected field | m_TransportKind | (Inherited from Transport.)
Back to Top
See Also
MpxServerTransport Class
NFX.Glue.Native Namespace


MpxServerTransport.m_OpenChannels Field

MpxServerTransport m_OpenChannels Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int m_OpenChannels
internal int m_OpenChannels
Friend m_OpenChannels As Integer
Friend m_OpenChannels As Integer
internal:
int m_OpenChannels
internal:
int m_OpenChannels
val mutable internal m_OpenChannels: int
val mutable internal m_OpenChannels: int

Field Value

Type: Online Int32
See Also
MpxServerTransport Class
MpxServerTransport Members
NFX.Glue.Native Namespace


MpxServerTransport Methods

MpxServerTransport Methods NFX Class Library

The MpxServerTransport type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and transport instance are running or throws otherwise (Inherited from Transport.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Protected method | ClientSiteConnected | Notifies the transport that site connection has arrived so the transport may allocate some site/socket-specific state. Called from listener
Protected method | ClientSiteDisconnected | Notifies the transport that site connection has closed/broke so the transport may de-allocate some site/socket-specific state. Called from listener
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Transport.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | (Overrides Service DoAcceptManagerVisit(Object, DateTime).)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoDumpInstrumentationData | (Overrides Transport DoDumpInstrumentationData .)
Protected method | DoSendResponse | (Overrides ServerTransport DoSendResponse(ResponseMsg).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides Transport DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | DumpInstrumentationData | Dumps instrumentation data (Inherited from Transport.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Release | Releases transport by setting Acquired flag to false so it can be used by other operations (Inherited from Transport.)
Public method | ResetStats | Resets all statistical counters (Inherited from Transport.)
Public method | SendResponse | Sends a response into remote client endpoint (Inherited from ServerTransport.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Protected method | stat_BytesReceived | (Inherited from Transport.)
Protected method | stat_BytesSent | (Inherited from Transport.)
Protected method | stat_Errors | (Inherited from Transport.)
Protected method | stat_MsgReceived | (Inherited from Transport.)
Protected method | stat_MsgSent | (Inherited from Transport.)
Protected method | stat_Time | Processes named time measurement statistical sample by using EMA filter (Inherited from Transport.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryAcquire | A thread-safe operation that tries to acquire(reserve) this instance for exclusive use. Returns true if acqusition succeded, false is this instance is reserved by someone else (Inherited from Transport.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MpxServerTransport Class
NFX.Glue.Native Namespace


MpxServerTransport.ClientSiteConnected Method

MpxServerTransport ClientSiteConnected Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Notifies the transport that site connection has arrived so the transport may allocate some site/socket-specific state. Called from listener

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void ClientSiteConnected(
    MpxServerSocket socket
)
internal void ClientSiteConnected(
    MpxServerSocket socket
)
Friend Sub ClientSiteConnected (
    socket As MpxServerSocket
)
Friend Sub ClientSiteConnected (
    socket As MpxServerSocket
)
internal:
void ClientSiteConnected(
    MpxServerSocket^ socket
)
internal:
void ClientSiteConnected(
    MpxServerSocket^ socket
)
internal member ClientSiteConnected :
        socket : MpxServerSocket -> unit
internal member ClientSiteConnected :
        socket : MpxServerSocket -> unit

Parameters

socket
Type: NFX.Glue.Native MpxServerSocket
See Also
MpxServerTransport Class
MpxServerTransport Members
NFX.Glue.Native Namespace


MpxServerTransport.ClientSiteDisconnected Method

MpxServerTransport ClientSiteDisconnected Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Notifies the transport that site connection has closed/broke so the transport may de-allocate some site/socket-specific state. Called from listener

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void ClientSiteDisconnected(
    MpxServerSocket socket
)
internal void ClientSiteDisconnected(
    MpxServerSocket socket
)
Friend Sub ClientSiteDisconnected (
    socket As MpxServerSocket
)
Friend Sub ClientSiteDisconnected (
    socket As MpxServerSocket
)
internal:
void ClientSiteDisconnected(
    MpxServerSocket^ socket
)
internal:
void ClientSiteDisconnected(
    MpxServerSocket^ socket
)
internal member ClientSiteDisconnected :
        socket : MpxServerSocket -> unit
internal member ClientSiteDisconnected :
        socket : MpxServerSocket -> unit

Parameters

socket
Type: NFX.Glue.Native MpxServerSocket
See Also
MpxServerTransport Class
MpxServerTransport Members
NFX.Glue.Native Namespace


MpxServerTransport.DoAcceptManagerVisit Method

MpxServerTransport DoAcceptManagerVisit Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoAcceptManagerVisit(
    Object manager,
    DateTime managerNow
)
protected override void DoAcceptManagerVisit(
    Object manager,
    DateTime managerNow
)
Protected Overrides Sub DoAcceptManagerVisit (
    manager As Object,
    managerNow As DateTime
)
Protected Overrides Sub DoAcceptManagerVisit (
    manager As Object,
    managerNow As DateTime
)
protected:
virtual void DoAcceptManagerVisit(
    Object^ manager,
    DateTime managerNow
) override
protected:
virtual void DoAcceptManagerVisit(
    Object^ manager,
    DateTime managerNow
) override
abstract DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit
override DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit
abstract DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit
override DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit

Parameters

manager
Type: Online System Object
managerNow
Type: Online System DateTime
See Also
MpxServerTransport Class
MpxServerTransport Members
NFX.Glue.Native Namespace


MpxServerTransport.DoDumpInstrumentationData Method

MpxServerTransport DoDumpInstrumentationData Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoDumpInstrumentationData()
protected override void DoDumpInstrumentationData()
Protected Overrides Sub DoDumpInstrumentationData
Protected Overrides Sub DoDumpInstrumentationData
protected:
virtual void DoDumpInstrumentationData() override
protected:
virtual void DoDumpInstrumentationData() override
abstract DoDumpInstrumentationData : unit -> unit
override DoDumpInstrumentationData : unit -> unit
abstract DoDumpInstrumentationData : unit -> unit
override DoDumpInstrumentationData : unit -> unit
See Also
MpxServerTransport Class
MpxServerTransport Members
NFX.Glue.Native Namespace


MpxServerTransport.DoSendResponse Method

MpxServerTransport DoSendResponse Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool DoSendResponse(
    ResponseMsg response
)
protected override bool DoSendResponse(
    ResponseMsg response
)
Protected Overrides Function DoSendResponse (
    response As ResponseMsg
) As Boolean
Protected Overrides Function DoSendResponse (
    response As ResponseMsg
) As Boolean
protected:
virtual bool DoSendResponse(
    ResponseMsg^ response
) override
protected:
virtual bool DoSendResponse(
    ResponseMsg^ response
) override
abstract DoSendResponse :
        response : ResponseMsg -> bool
override DoSendResponse :
        response : ResponseMsg -> bool
abstract DoSendResponse :
        response : ResponseMsg -> bool
override DoSendResponse :
        response : ResponseMsg -> bool

Parameters

response
Type: NFX.Glue.Protocol ResponseMsg

Return Value

Type: Online Boolean
See Also
MpxServerTransport Class
MpxServerTransport Members
NFX.Glue.Native Namespace


MpxServerTransport.DoStart Method

MpxServerTransport DoStart Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
MpxServerTransport Class
MpxServerTransport Members
NFX.Glue.Native Namespace


MpxServerTransport.DoWaitForCompleteStop Method

MpxServerTransport DoWaitForCompleteStop Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
MpxServerTransport Class
MpxServerTransport Members
NFX.Glue.Native Namespace


MpxServerTransport Properties

MpxServerTransport Properties NFX Class Library

The MpxServerTransport type exposes the following members.
Properties
 | Name | Description
Public property | Acquired | Returns true when this transport instance has been acquired by some operation and is busy (Inherited from Transport.)
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | Binding | (Inherited from ServerTransport TBinding .)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExpirationStart | Returns timestamp when manager touched the instance for last time and no traffic went through it since (Inherited from Transport.)
Public property | Glue | Returns glue implementation that this transport is under (Inherited from Transport.)
Public property | IdleAgeMs | Returns the duration of transport idle period in ms. (Inherited from Transport.)
Public property | IsListener | Indicates whether this instance is the one that accepts connections. Depending on implementation listeners may allocate other transports after they accept incoming connect request (i.e. TCP) (Inherited from ServerTransport.)
Public property | Listener | Returns a listener transport that opened this one. If this is a listener transport then returns null. Not all technologies support listener/child transports (TCP does) (Inherited from ServerTransport.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Node | Returns node that this transport services (Inherited from Transport.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | ServerEndpoint | Returns server endpoint instance that opened this transport (Inherited from ServerTransport.)
Public property | StatBytesReceived | Returns how many bytes were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatBytesSent | Returns how many bytes were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatErrors | Returns how many message processing errors happened since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgReceived | Returns how many messages were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgSent | Returns how many messages were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatTimes | Returns enumerable of named times measured in double second fractions. The returned times are EMA-filtered from supplied individual measurement samples (Inherited from Transport.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransportKind | Reports if this is a server or client transport (Inherited from Transport.)
Back to Top
See Also
MpxServerTransport Class
NFX.Glue.Native Namespace


MpxSocket(TTransport) Class

MpxSocket TTransport Class NFX Class Library

Base for MpxSockets implementation. An MpxSocket represents an asynchronous bi-directional channel of communication that delivers binary/wire messages of flexible size. The socket is NOT THREAD SAFE for calling Send() from parallel threads. Send() is done synchronously on the calling thread, i.e. the sender waits until the data is written into the OS socket buff. Receive is invoked by internal/system/io thread asynchronously and should not block for long (seconds)
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Glue.Native MpxSocket TTransport
NFX.Glue.Native MpxClientSocket
NFX.Glue.Native MpxServerSocket

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class MpxSocket<TTransport> : DisposableObject
where TTransport : Transport, IMpxTransport
public abstract class MpxSocket<TTransport> : DisposableObject
where TTransport : Transport, IMpxTransport
Public MustInherit Class MpxSocket(Of TTransport As {Transport, IMpxTransport})
    Inherits DisposableObject
Public MustInherit Class MpxSocket(Of TTransport As {Transport, IMpxTransport})
    Inherits DisposableObject
generic<typename TTransport>
where TTransport : Transport, IMpxTransport
public ref class MpxSocket abstract : public DisposableObject
generic<typename TTransport>
where TTransport : Transport, IMpxTransport
public ref class MpxSocket abstract : public DisposableObject
[<AbstractClassAttribute>]
type MpxSocket<'TTransport when 'TTransport : Transport and IMpxTransport> =
    class
        inherit DisposableObject
    end
[<AbstractClassAttribute>]
type MpxSocket<'TTransport when 'TTransport : Transport and IMpxTransport> =
    class
        inherit DisposableObject
    end
Type Parameters
TTransport
See Also
MpxSocket TTransport Members
NFX.Glue.Native Namespace


MpxSocket(TTransport) Members

MpxSocket TTransport Members NFX Class Library

The MpxSocket TTransport type exposes the following members.
Constructors
 | Name | Description
Protected method | MpxSocket TTransport | Initializes a new instance of the MpxSocket TTransport class
Back to Top
Methods
 | Name | Description
Public method | AcceptManagerVisit | Override to perform maintenance i.e. trim excessive m_SendChunk size etc.. This method is called by Glue/Binding/Transport runtime. Also resets last last idle manager visit timestamp which is used for socket closing
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoReleaseMemChunksAfterAsyncOperations | Do not call this method, override only when freeing more than 2 standard chunks (send/recv)
Protected method | DoSend |
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSendChunk | Reserves a chunk of memory of the suggested size for network send operation. The buffer must be released by a call to ReleaseSendBuffer(). Keep in mind that this method is NOT RE-ENTRANT by this or any other thread until corresponding ReleaseSendChunk() is called. MpxSocket is not thread safe for sends in general.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeReceive | Calls ReceiveAction callback guarding for possible unhandled receive action errors
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReleaseMemChunksAfterAsyncOperations | Releases socket memory chunks. This method MUST BE called AFTER all pending async IO is done, otherwise the chunks may get released to the pool and get corrupted by the prior operation
Public method | ReleaseSendChunk | Releases previously reserved buffer, i.e. may trim excess allocation after a large message
Public method | Send | Adds the specified socket msg to the outgoing stack. This is a synchronous blocking call that executes until the data is written into socket stack (but not necessarily delivered). If send error occurs then socket is marked as !Active (Disposed)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_ClientSite |
Protected field | m_Disposing |
Protected field | m_EndPoint |
Protected field | m_LastIdleManagerVisit |
Protected field | m_ReceiveChunk |
Protected field | m_SendChunk |
Protected field | m_Socket |
Protected field | m_Transport |
Back to Top
Properties
 | Name | Description
Public property | Active | True when socket is not disposing and runtime is not shutting down
Public property | ClientSite | Returns client site for the computer that initiated the call. Server socket returns the transmitted value from client. Client socket returns the one that was sent to server upon handshake
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndPoint | Returns IP End point that this socket services, remote server for client socket and remote client for server sockets
Public property | LastIdleManagerVisit | Returns timestamp of last manager visit since then no traffic came through. Null indicates that traffic came though and socket has not been idle since last visit. Manager is an extrenal visitor that closes idle sockets
Public property | Socket | Returns the underlying socket
Public property | Transport | Returns transport that this socket is under
Back to Top
See Also
MpxSocket TTransport Class
NFX.Glue.Native Namespace


MpxSocket(TTransport) Constructor

MpxSocket TTransport Constructor NFX Class Library

Initializes a new instance of the MpxSocket TTransport class

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MpxSocket(
    TTransport transport,
    IPEndPoint endPoint,
    ClientSite clientSite,
    MpxSocketReceiveAction<TTransport> receiveAction
)
protected MpxSocket(
    TTransport transport,
    IPEndPoint endPoint,
    ClientSite clientSite,
    MpxSocketReceiveAction<TTransport> receiveAction
)
Protected Sub New (
    transport As TTransport,
    endPoint As IPEndPoint,
    clientSite As ClientSite,
    receiveAction As MpxSocketReceiveAction(Of TTransport)
)
Protected Sub New (
    transport As TTransport,
    endPoint As IPEndPoint,
    clientSite As ClientSite,
    receiveAction As MpxSocketReceiveAction(Of TTransport)
)
protected:
MpxSocket(
    TTransport transport,
    IPEndPoint^ endPoint,
    ClientSite clientSite,
    MpxSocketReceiveAction<TTransport>^ receiveAction
)
protected:
MpxSocket(
    TTransport transport,
    IPEndPoint^ endPoint,
    ClientSite clientSite,
    MpxSocketReceiveAction<TTransport>^ receiveAction
)
new :
        transport : 'TTransport *
        endPoint : IPEndPoint *
        clientSite : ClientSite *
        receiveAction : MpxSocketReceiveAction<'TTransport> -> MpxSocket
new :
        transport : 'TTransport *
        endPoint : IPEndPoint *
        clientSite : ClientSite *
        receiveAction : MpxSocketReceiveAction<'TTransport> -> MpxSocket

Parameters

transport
Type: TTransport
endPoint
Type: Online System.Net IPEndPoint
clientSite
Type: NFX.Glue.Native ClientSite
receiveAction
Type: NFX.Glue.Native MpxSocketReceiveAction TTransport
See Also
MpxSocket TTransport Class
MpxSocket TTransport Members
NFX.Glue.Native Namespace


MpxSocket(TTransport) Fields

MpxSocket TTransport Fields NFX Class Library

The MpxSocket TTransport type exposes the following members.
Fields
 | Name | Description
Protected field | m_ClientSite |
Protected field | m_Disposing |
Protected field | m_EndPoint |
Protected field | m_LastIdleManagerVisit |
Protected field | m_ReceiveChunk |
Protected field | m_SendChunk |
Protected field | m_Socket |
Protected field | m_Transport |
Back to Top
See Also
MpxSocket TTransport Class
NFX.Glue.Native Namespace


MpxSocket(TTransport).m_ClientSite Field

MpxSocket TTransport m_ClientSite Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected readonly ClientSite m_ClientSite
protected readonly ClientSite m_ClientSite
Protected ReadOnly m_ClientSite As ClientSite
Protected ReadOnly m_ClientSite As ClientSite
protected:
initonly ClientSite m_ClientSite
protected:
initonly ClientSite m_ClientSite
val m_ClientSite: ClientSite
val m_ClientSite: ClientSite

Field Value

Type: ClientSite
See Also
MpxSocket TTransport Class
MpxSocket TTransport Members
NFX.Glue.Native Namespace


MpxSocket(TTransport).m_Disposing Field

MpxSocket TTransport m_Disposing Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool m_Disposing
protected bool m_Disposing
Protected m_Disposing As Boolean
Protected m_Disposing As Boolean
protected:
bool m_Disposing
protected:
bool m_Disposing
val mutable m_Disposing: bool
val mutable m_Disposing: bool

Field Value

Type: Online Boolean
See Also
MpxSocket TTransport Class
MpxSocket TTransport Members
NFX.Glue.Native Namespace


MpxSocket(TTransport).m_EndPoint Field

MpxSocket TTransport m_EndPoint Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected readonly IPEndPoint m_EndPoint
protected readonly IPEndPoint m_EndPoint
Protected ReadOnly m_EndPoint As IPEndPoint
Protected ReadOnly m_EndPoint As IPEndPoint
protected:
initonly IPEndPoint^ m_EndPoint
protected:
initonly IPEndPoint^ m_EndPoint
val m_EndPoint: IPEndPoint
val m_EndPoint: IPEndPoint

Field Value

Type: Online IPEndPoint
See Also
MpxSocket TTransport Class
MpxSocket TTransport Members
NFX.Glue.Native Namespace


MpxSocket(TTransport).m_LastIdleManagerVisit Field

MpxSocket TTransport m_LastIdleManagerVisit Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Nullable<DateTime> m_LastIdleManagerVisit
protected Nullable<DateTime> m_LastIdleManagerVisit
Protected m_LastIdleManagerVisit As Nullable(Of DateTime)
Protected m_LastIdleManagerVisit As Nullable(Of DateTime)
protected:
Nullable<DateTime> m_LastIdleManagerVisit
protected:
Nullable<DateTime> m_LastIdleManagerVisit
val mutable m_LastIdleManagerVisit: Nullable<DateTime>
val mutable m_LastIdleManagerVisit: Nullable<DateTime>

Field Value

Type: Online Nullable Online DateTime
See Also
MpxSocket TTransport Class
MpxSocket TTransport Members
NFX.Glue.Native Namespace


MpxSocket(TTransport).m_ReceiveChunk Field

MpxSocket TTransport m_ReceiveChunk Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MemChunk m_ReceiveChunk
protected MemChunk m_ReceiveChunk
Protected m_ReceiveChunk As MemChunk
Protected m_ReceiveChunk As MemChunk
protected:
MemChunk^ m_ReceiveChunk
protected:
MemChunk^ m_ReceiveChunk
val mutable m_ReceiveChunk: MemChunk
val mutable m_ReceiveChunk: MemChunk

Field Value

Type: MemChunk
See Also
MpxSocket TTransport Class
MpxSocket TTransport Members
NFX.Glue.Native Namespace


MpxSocket(TTransport).m_SendChunk Field

MpxSocket TTransport m_SendChunk Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MemChunk m_SendChunk
protected MemChunk m_SendChunk
Protected m_SendChunk As MemChunk
Protected m_SendChunk As MemChunk
protected:
MemChunk^ m_SendChunk
protected:
MemChunk^ m_SendChunk
val mutable m_SendChunk: MemChunk
val mutable m_SendChunk: MemChunk

Field Value

Type: MemChunk
See Also
MpxSocket TTransport Class
MpxSocket TTransport Members
NFX.Glue.Native Namespace


MpxSocket(TTransport).m_Socket Field

MpxSocket TTransport m_Socket Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Socket m_Socket
protected Socket m_Socket
Protected m_Socket As Socket
Protected m_Socket As Socket
protected:
Socket^ m_Socket
protected:
Socket^ m_Socket
val mutable m_Socket: Socket
val mutable m_Socket: Socket

Field Value

Type: Online Socket
See Also
MpxSocket TTransport Class
MpxSocket TTransport Members
NFX.Glue.Native Namespace


MpxSocket(TTransport).m_Transport Field

MpxSocket TTransport m_Transport Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected readonly TTransport m_Transport
protected readonly TTransport m_Transport
Protected ReadOnly m_Transport As TTransport
Protected ReadOnly m_Transport As TTransport
protected:
initonly TTransport m_Transport
protected:
initonly TTransport m_Transport
val m_Transport: 'TTransport
val m_Transport: 'TTransport

Field Value

Type: TTransport
See Also
MpxSocket TTransport Class
MpxSocket TTransport Members
NFX.Glue.Native Namespace


MpxSocket(TTransport) Methods

MpxSocket TTransport Methods NFX Class Library

The MpxSocket TTransport type exposes the following members.
Methods
 | Name | Description
Public method | AcceptManagerVisit | Override to perform maintenance i.e. trim excessive m_SendChunk size etc.. This method is called by Glue/Binding/Transport runtime. Also resets last last idle manager visit timestamp which is used for socket closing
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoReleaseMemChunksAfterAsyncOperations | Do not call this method, override only when freeing more than 2 standard chunks (send/recv)
Protected method | DoSend |
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSendChunk | Reserves a chunk of memory of the suggested size for network send operation. The buffer must be released by a call to ReleaseSendBuffer(). Keep in mind that this method is NOT RE-ENTRANT by this or any other thread until corresponding ReleaseSendChunk() is called. MpxSocket is not thread safe for sends in general.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeReceive | Calls ReceiveAction callback guarding for possible unhandled receive action errors
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReleaseMemChunksAfterAsyncOperations | Releases socket memory chunks. This method MUST BE called AFTER all pending async IO is done, otherwise the chunks may get released to the pool and get corrupted by the prior operation
Public method | ReleaseSendChunk | Releases previously reserved buffer, i.e. may trim excess allocation after a large message
Public method | Send | Adds the specified socket msg to the outgoing stack. This is a synchronous blocking call that executes until the data is written into socket stack (but not necessarily delivered). If send error occurs then socket is marked as !Active (Disposed)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MpxSocket TTransport Class
NFX.Glue.Native Namespace


MpxSocket(TTransport).AcceptManagerVisit Method

MpxSocket TTransport AcceptManagerVisit Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to perform maintenance i.e. trim excessive m_SendChunk size etc.. This method is called by Glue/Binding/Transport runtime. Also resets last last idle manager visit timestamp which is used for socket closing

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void AcceptManagerVisit(
    DateTime when
)
public virtual void AcceptManagerVisit(
    DateTime when
)
Public Overridable Sub AcceptManagerVisit (
    when As DateTime
)
Public Overridable Sub AcceptManagerVisit (
    when As DateTime
)
public:
virtual void AcceptManagerVisit(
    DateTime when
)
public:
virtual void AcceptManagerVisit(
    DateTime when
)
abstract AcceptManagerVisit :
        when : DateTime -> unit
override AcceptManagerVisit :
        when : DateTime -> unit
abstract AcceptManagerVisit :
        when : DateTime -> unit
override AcceptManagerVisit :
        when : DateTime -> unit

Parameters

when
Type: Online System DateTime
See Also
MpxSocket TTransport Class
MpxSocket TTransport Members
NFX.Glue.Native Namespace


MpxSocket(TTransport).Destructor Method

MpxSocket TTransport Destructor Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
MpxSocket TTransport Class
MpxSocket TTransport Members
NFX.Glue.Native Namespace


MpxSocket(TTransport).DoReleaseMemChunksAfterAsyncOperations Method

MpxSocket TTransport DoReleaseMemChunksAfterAsyncOperations Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Do not call this method, override only when freeing more than 2 standard chunks (send/recv)

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoReleaseMemChunksAfterAsyncOperations()
protected virtual void DoReleaseMemChunksAfterAsyncOperations()
Protected Overridable Sub DoReleaseMemChunksAfterAsyncOperations
Protected Overridable Sub DoReleaseMemChunksAfterAsyncOperations
protected:
virtual void DoReleaseMemChunksAfterAsyncOperations()
protected:
virtual void DoReleaseMemChunksAfterAsyncOperations()
abstract DoReleaseMemChunksAfterAsyncOperations : unit -> unit
override DoReleaseMemChunksAfterAsyncOperations : unit -> unit
abstract DoReleaseMemChunksAfterAsyncOperations : unit -> unit
override DoReleaseMemChunksAfterAsyncOperations : unit -> unit
See Also
MpxSocket TTransport Class
MpxSocket TTransport Members
NFX.Glue.Native Namespace


MpxSocket(TTransport).DoSend Method

MpxSocket TTransport DoSend Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void DoSend(
    WireMsg data
)
protected abstract void DoSend(
    WireMsg data
)
Protected MustOverride Sub DoSend (
    data As WireMsg
)
Protected MustOverride Sub DoSend (
    data As WireMsg
)
protected:
virtual void DoSend(
    WireMsg data
) abstract
protected:
virtual void DoSend(
    WireMsg data
) abstract
abstract DoSend :
        data : WireMsg -> unit
abstract DoSend :
        data : WireMsg -> unit

Parameters

data
Type: NFX.Glue.Native WireMsg
See Also
MpxSocket TTransport Class
MpxSocket TTransport Members
NFX.Glue.Native Namespace


MpxSocket(TTransport).GetSendChunk Method

MpxSocket TTransport GetSendChunk Method NFX Class Library

Reserves a chunk of memory of the suggested size for network send operation. The buffer must be released by a call to ReleaseSendBuffer(). Keep in mind that this method is NOT RE-ENTRANT by this or any other thread until corresponding ReleaseSendChunk() is called. MpxSocket is not thread safe for sends in general.

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual MemChunk GetSendChunk(
    int desiredSize = 0
)
public virtual MemChunk GetSendChunk(
    int desiredSize = 0
)
Public Overridable Function GetSendChunk (
    Optional desiredSize As Integer = 0
) As MemChunk
Public Overridable Function GetSendChunk (
    Optional desiredSize As Integer = 0
) As MemChunk
public:
virtual MemChunk^ GetSendChunk(
    int desiredSize = 0
)
public:
virtual MemChunk^ GetSendChunk(
    int desiredSize = 0
)
abstract GetSendChunk :
        ?desiredSize : int
(* Defaults:
        let _desiredSize = defaultArg desiredSize 0
*)
-> MemChunk
override GetSendChunk :
        ?desiredSize : int
(* Defaults:
        let _desiredSize = defaultArg desiredSize 0
*)
-> MemChunk
abstract GetSendChunk :
        ?desiredSize : int
(* Defaults:
        let _desiredSize = defaultArg desiredSize 0
*)
-> MemChunk
override GetSendChunk :
        ?desiredSize : int
(* Defaults:
        let _desiredSize = defaultArg desiredSize 0
*)
-> MemChunk

Parameters

desiredSize (Optional)
Type: Online System Int32

Return Value

Type: MemChunk
See Also
MpxSocket TTransport Class
MpxSocket TTransport Members
NFX.Glue.Native Namespace


MpxSocket(TTransport).InvokeReceive Method

MpxSocket TTransport InvokeReceive Method NFX Class Library

Calls ReceiveAction callback guarding for possible unhandled receive action errors

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void InvokeReceive(
    WireMsg msg
)
protected void InvokeReceive(
    WireMsg msg
)
Protected Sub InvokeReceive (
    msg As WireMsg
)
Protected Sub InvokeReceive (
    msg As WireMsg
)
protected:
void InvokeReceive(
    WireMsg msg
)
protected:
void InvokeReceive(
    WireMsg msg
)
member InvokeReceive :
        msg : WireMsg -> unit
member InvokeReceive :
        msg : WireMsg -> unit

Parameters

msg
Type: NFX.Glue.Native WireMsg
See Also
MpxSocket TTransport Class
MpxSocket TTransport Members
NFX.Glue.Native Namespace


MpxSocket(TTransport).ReleaseMemChunksAfterAsyncOperations Method

MpxSocket TTransport ReleaseMemChunksAfterAsyncOperations Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Releases socket memory chunks. This method MUST BE called AFTER all pending async IO is done, otherwise the chunks may get released to the pool and get corrupted by the prior operation

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void ReleaseMemChunksAfterAsyncOperations()
protected void ReleaseMemChunksAfterAsyncOperations()
Protected Sub ReleaseMemChunksAfterAsyncOperations
Protected Sub ReleaseMemChunksAfterAsyncOperations
protected:
void ReleaseMemChunksAfterAsyncOperations()
protected:
void ReleaseMemChunksAfterAsyncOperations()
member ReleaseMemChunksAfterAsyncOperations : unit -> unit
member ReleaseMemChunksAfterAsyncOperations : unit -> unit
See Also
MpxSocket TTransport Class
MpxSocket TTransport Members
NFX.Glue.Native Namespace


MpxSocket(TTransport).ReleaseSendChunk Method

MpxSocket TTransport ReleaseSendChunk Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Releases previously reserved buffer, i.e. may trim excess allocation after a large message

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void ReleaseSendChunk()
public virtual void ReleaseSendChunk()
Public Overridable Sub ReleaseSendChunk
Public Overridable Sub ReleaseSendChunk
public:
virtual void ReleaseSendChunk()
public:
virtual void ReleaseSendChunk()
abstract ReleaseSendChunk : unit -> unit
override ReleaseSendChunk : unit -> unit
abstract ReleaseSendChunk : unit -> unit
override ReleaseSendChunk : unit -> unit
See Also
MpxSocket TTransport Class
MpxSocket TTransport Members
NFX.Glue.Native Namespace


MpxSocket(TTransport).Send Method

MpxSocket TTransport Send Method NFX Class Library

Adds the specified socket msg to the outgoing stack. This is a synchronous blocking call that executes until the data is written into socket stack (but not necessarily delivered). If send error occurs then socket is marked as !Active (Disposed)

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Send(
    WireMsg data
)
public void Send(
    WireMsg data
)
Public Sub Send (
    data As WireMsg
)
Public Sub Send (
    data As WireMsg
)
public:
void Send(
    WireMsg data
)
public:
void Send(
    WireMsg data
)
member Send :
        data : WireMsg -> unit
member Send :
        data : WireMsg -> unit

Parameters

data
Type: NFX.Glue.Native WireMsg
See Also
MpxSocket TTransport Class
MpxSocket TTransport Members
NFX.Glue.Native Namespace


MpxSocket(TTransport) Properties

MpxSocket TTransport Properties NFX Class Library

The MpxSocket TTransport type exposes the following members.
Properties
 | Name | Description
Public property | Active | True when socket is not disposing and runtime is not shutting down
Public property | ClientSite | Returns client site for the computer that initiated the call. Server socket returns the transmitted value from client. Client socket returns the one that was sent to server upon handshake
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndPoint | Returns IP End point that this socket services, remote server for client socket and remote client for server sockets
Public property | LastIdleManagerVisit | Returns timestamp of last manager visit since then no traffic came through. Null indicates that traffic came though and socket has not been idle since last visit. Manager is an extrenal visitor that closes idle sockets
Public property | Socket | Returns the underlying socket
Public property | Transport | Returns transport that this socket is under
Back to Top
See Also
MpxSocket TTransport Class
NFX.Glue.Native Namespace


MpxSocket(TTransport).Active Property

MpxSocket TTransport Active Property NFX Class Library

True when socket is not disposing and runtime is not shutting down

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Active { get; }
public bool Active { get; }
Public ReadOnly Property Active As Boolean
    Get
Public ReadOnly Property Active As Boolean
    Get
public:
property bool Active {
    bool get ();
}
public:
property bool Active {
    bool get ();
}
member Active : bool with get
member Active : bool with get

Property Value

Type: Online Boolean
See Also
MpxSocket TTransport Class
MpxSocket TTransport Members
NFX.Glue.Native Namespace


MpxSocket(TTransport).ClientSite Property

MpxSocket TTransport ClientSite Property NFX Class Library

Returns client site for the computer that initiated the call. Server socket returns the transmitted value from client. Client socket returns the one that was sent to server upon handshake

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ClientSite ClientSite { get; }
public ClientSite ClientSite { get; }
Public ReadOnly Property ClientSite As ClientSite
    Get
Public ReadOnly Property ClientSite As ClientSite
    Get
public:
property ClientSite ClientSite {
    ClientSite get ();
}
public:
property ClientSite ClientSite {
    ClientSite get ();
}
member ClientSite : ClientSite with get
member ClientSite : ClientSite with get

Property Value

Type: ClientSite
See Also
MpxSocket TTransport Class
MpxSocket TTransport Members
NFX.Glue.Native Namespace


MpxSocket(TTransport).EndPoint Property

MpxSocket TTransport EndPoint Property NFX Class Library

Returns IP End point that this socket services, remote server for client socket and remote client for server sockets

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IPEndPoint EndPoint { get; }
public IPEndPoint EndPoint { get; }
Public ReadOnly Property EndPoint As IPEndPoint
    Get
Public ReadOnly Property EndPoint As IPEndPoint
    Get
public:
property IPEndPoint^ EndPoint {
    IPEndPoint^ get ();
}
public:
property IPEndPoint^ EndPoint {
    IPEndPoint^ get ();
}
member EndPoint : IPEndPoint with get
member EndPoint : IPEndPoint with get

Property Value

Type: Online IPEndPoint
See Also
MpxSocket TTransport Class
MpxSocket TTransport Members
NFX.Glue.Native Namespace


MpxSocket(TTransport).LastIdleManagerVisit Property

MpxSocket TTransport LastIdleManagerVisit Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns timestamp of last manager visit since then no traffic came through. Null indicates that traffic came though and socket has not been idle since last visit. Manager is an extrenal visitor that closes idle sockets

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> LastIdleManagerVisit { get; }
public Nullable<DateTime> LastIdleManagerVisit { get; }
Public ReadOnly Property LastIdleManagerVisit As Nullable(Of DateTime)
    Get
Public ReadOnly Property LastIdleManagerVisit As Nullable(Of DateTime)
    Get
public:
property Nullable<DateTime> LastIdleManagerVisit {
    Nullable<DateTime> get ();
}
public:
property Nullable<DateTime> LastIdleManagerVisit {
    Nullable<DateTime> get ();
}
member LastIdleManagerVisit : Nullable<DateTime> with get
member LastIdleManagerVisit : Nullable<DateTime> with get

Property Value

Type: Online Nullable Online DateTime
See Also
MpxSocket TTransport Class
MpxSocket TTransport Members
NFX.Glue.Native Namespace


MpxSocket(TTransport).Socket Property

MpxSocket TTransport Socket Property NFX Class Library

Returns the underlying socket

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Socket Socket { get; }
public Socket Socket { get; }
Public ReadOnly Property Socket As Socket
    Get
Public ReadOnly Property Socket As Socket
    Get
public:
property Socket^ Socket {
    Socket^ get ();
}
public:
property Socket^ Socket {
    Socket^ get ();
}
member Socket : Socket with get
member Socket : Socket with get

Property Value

Type: Online Socket
See Also
MpxSocket TTransport Class
MpxSocket TTransport Members
NFX.Glue.Native Namespace


MpxSocket(TTransport).Transport Property

MpxSocket TTransport Transport Property NFX Class Library

Returns transport that this socket is under

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TTransport Transport { get; }
public TTransport Transport { get; }
Public ReadOnly Property Transport As TTransport
    Get
Public ReadOnly Property Transport As TTransport
    Get
public:
property TTransport Transport {
    TTransport get ();
}
public:
property TTransport Transport {
    TTransport get ();
}
member Transport : 'TTransport with get
member Transport : 'TTransport with get

Property Value

Type: TTransport
See Also
MpxSocket TTransport Class
MpxSocket TTransport Members
NFX.Glue.Native Namespace


MpxSocketFactory Class

MpxSocketFactory Class NFX Class Library

Defines factory abstraction that creates socket per particular technology
Inheritance Hierarchy
Online System Object
NFX.Glue.Native MpxSocketFactory
NFX.Glue.Native MpxWinSocketFactory

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class MpxSocketFactory : IConfigurable
public abstract class MpxSocketFactory : IConfigurable
Public MustInherit Class MpxSocketFactory
    Implements IConfigurable
Public MustInherit Class MpxSocketFactory
    Implements IConfigurable
public ref class MpxSocketFactory abstract : IConfigurable
public ref class MpxSocketFactory abstract : IConfigurable
[<AbstractClassAttribute>]
type MpxSocketFactory =
    class
        interface IConfigurable
    end
[<AbstractClassAttribute>]
type MpxSocketFactory =
    class
        interface IConfigurable
    end
See Also
MpxSocketFactory Members
NFX.Glue.Native Namespace


MpxSocketFactory Members

MpxSocketFactory Members NFX Class Library

The MpxSocketFactory type exposes the following members.
Constructors
 | Name | Description
Protected method | MpxSocketFactory | Initializes a new instance of the MpxSocketFactory class
Back to Top
Methods
 | Name | Description
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeClientSocket |
Public method | MakeListener |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MpxSocketFactory Class
NFX.Glue.Native Namespace


MpxSocketFactory Constructor

MpxSocketFactory Constructor NFX Class Library

Initializes a new instance of the MpxSocketFactory class

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected MpxSocketFactory()
protected MpxSocketFactory()
Protected Sub New
Protected Sub New
protected:
MpxSocketFactory()
protected:
MpxSocketFactory()
new : unit -> MpxSocketFactory
new : unit -> MpxSocketFactory
See Also
MpxSocketFactory Class
MpxSocketFactory Members
NFX.Glue.Native Namespace


MpxSocketFactory Methods

MpxSocketFactory Methods NFX Class Library

The MpxSocketFactory type exposes the following members.
Methods
 | Name | Description
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeClientSocket |
Public method | MakeListener |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MpxSocketFactory Class
NFX.Glue.Native Namespace


MpxSocketFactory.Configure Method

MpxSocketFactory Configure Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Configure(
    IConfigSectionNode node
)
public abstract void Configure(
    IConfigSectionNode node
)
Public MustOverride Sub Configure (
    node As IConfigSectionNode
)
Public MustOverride Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) abstract
public:
virtual void Configure(
    IConfigSectionNode^ node
) abstract
abstract Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
MpxSocketFactory Class
MpxSocketFactory Members
NFX.Glue.Native Namespace


MpxSocketFactory.MakeClientSocket Method

MpxSocketFactory MakeClientSocket Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract MpxClientSocket MakeClientSocket(
    MpxClientTransport transport,
    IPEndPoint remoteServer,
    ClientSite clientSite,
    MpxSocketReceiveAction<MpxClientTransport> receiveAction
)
public abstract MpxClientSocket MakeClientSocket(
    MpxClientTransport transport,
    IPEndPoint remoteServer,
    ClientSite clientSite,
    MpxSocketReceiveAction<MpxClientTransport> receiveAction
)
Public MustOverride Function MakeClientSocket (
    transport As MpxClientTransport,
    remoteServer As IPEndPoint,
    clientSite As ClientSite,
    receiveAction As MpxSocketReceiveAction(Of MpxClientTransport)
) As MpxClientSocket
Public MustOverride Function MakeClientSocket (
    transport As MpxClientTransport,
    remoteServer As IPEndPoint,
    clientSite As ClientSite,
    receiveAction As MpxSocketReceiveAction(Of MpxClientTransport)
) As MpxClientSocket
public:
virtual MpxClientSocket^ MakeClientSocket(
    MpxClientTransport^ transport,
    IPEndPoint^ remoteServer,
    ClientSite clientSite,
    MpxSocketReceiveAction<MpxClientTransport^>^ receiveAction
) abstract
public:
virtual MpxClientSocket^ MakeClientSocket(
    MpxClientTransport^ transport,
    IPEndPoint^ remoteServer,
    ClientSite clientSite,
    MpxSocketReceiveAction<MpxClientTransport^>^ receiveAction
) abstract
abstract MakeClientSocket :
        transport : MpxClientTransport *
        remoteServer : IPEndPoint *
        clientSite : ClientSite *
        receiveAction : MpxSocketReceiveAction<MpxClientTransport> -> MpxClientSocket
abstract MakeClientSocket :
        transport : MpxClientTransport *
        remoteServer : IPEndPoint *
        clientSite : ClientSite *
        receiveAction : MpxSocketReceiveAction<MpxClientTransport> -> MpxClientSocket

Parameters

transport
Type: NFX.Glue.Native MpxClientTransport
remoteServer
Type: Online System.Net IPEndPoint
clientSite
Type: NFX.Glue.Native ClientSite
receiveAction
Type: NFX.Glue.Native MpxSocketReceiveAction MpxClientTransport

Return Value

Type: MpxClientSocket
See Also
MpxSocketFactory Class
MpxSocketFactory Members
NFX.Glue.Native Namespace


MpxSocketFactory.MakeListener Method

MpxSocketFactory MakeListener Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract MpxListener MakeListener(
    MpxServerTransport transport,
    IPEndPoint listenEndPoint,
    MpxSocketReceiveAction<MpxServerTransport> socketReceiveAction
)
public abstract MpxListener MakeListener(
    MpxServerTransport transport,
    IPEndPoint listenEndPoint,
    MpxSocketReceiveAction<MpxServerTransport> socketReceiveAction
)
Public MustOverride Function MakeListener (
    transport As MpxServerTransport,
    listenEndPoint As IPEndPoint,
    socketReceiveAction As MpxSocketReceiveAction(Of MpxServerTransport)
) As MpxListener
Public MustOverride Function MakeListener (
    transport As MpxServerTransport,
    listenEndPoint As IPEndPoint,
    socketReceiveAction As MpxSocketReceiveAction(Of MpxServerTransport)
) As MpxListener
public:
virtual MpxListener^ MakeListener(
    MpxServerTransport^ transport,
    IPEndPoint^ listenEndPoint,
    MpxSocketReceiveAction<MpxServerTransport^>^ socketReceiveAction
) abstract
public:
virtual MpxListener^ MakeListener(
    MpxServerTransport^ transport,
    IPEndPoint^ listenEndPoint,
    MpxSocketReceiveAction<MpxServerTransport^>^ socketReceiveAction
) abstract
abstract MakeListener :
        transport : MpxServerTransport *
        listenEndPoint : IPEndPoint *
        socketReceiveAction : MpxSocketReceiveAction<MpxServerTransport> -> MpxListener
abstract MakeListener :
        transport : MpxServerTransport *
        listenEndPoint : IPEndPoint *
        socketReceiveAction : MpxSocketReceiveAction<MpxServerTransport> -> MpxListener

Parameters

transport
Type: NFX.Glue.Native MpxServerTransport
listenEndPoint
Type: Online System.Net IPEndPoint
socketReceiveAction
Type: NFX.Glue.Native MpxSocketReceiveAction MpxServerTransport

Return Value

Type: MpxListener
See Also
MpxSocketFactory Class
MpxSocketFactory Members
NFX.Glue.Native Namespace


MpxSocketReceiveAction(TTransport) Delegate

MpxSocketReceiveAction TTransport Delegate NFX Class Library

Delivers wire msg from another side. DO NOT use WireMsg beyound the implementation of this delegate, if needed make a copy of msg.Data as the memory will be freed after this call returns

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void MpxSocketReceiveAction<TTransport>(
    MpxSocket<TTransport> sender,
    WireMsg msg
)
where TTransport : Transport, IMpxTransport
public delegate void MpxSocketReceiveAction<TTransport>(
    MpxSocket<TTransport> sender,
    WireMsg msg
)
where TTransport : Transport, IMpxTransport
Public Delegate Sub MpxSocketReceiveAction(Of TTransport As {Transport, IMpxTransport}) (
    sender As MpxSocket(Of TTransport),
    msg As WireMsg
)
Public Delegate Sub MpxSocketReceiveAction(Of TTransport As {Transport, IMpxTransport}) (
    sender As MpxSocket(Of TTransport),
    msg As WireMsg
)
generic<typename TTransport>
where TTransport : Transport, IMpxTransport
public delegate void MpxSocketReceiveAction(
    MpxSocket<TTransport>^ sender,
    WireMsg msg
)
generic<typename TTransport>
where TTransport : Transport, IMpxTransport
public delegate void MpxSocketReceiveAction(
    MpxSocket<TTransport>^ sender,
    WireMsg msg
)
type MpxSocketReceiveAction =
    delegate of
        sender : MpxSocket<'TTransport> *
        msg : WireMsg -> unit
type MpxSocketReceiveAction =
    delegate of
        sender : MpxSocket<'TTransport> *
        msg : WireMsg -> unit

Parameters

sender
Type: NFX.Glue.Native MpxSocket TTransport
msg
Type: NFX.Glue.Native WireMsg
Type Parameters
TTransport
See Also
NFX.Glue.Native Namespace


MpxWinClientSocket Class

MpxWinClientSocket Class NFX Class Library

Implements a MPX client socket using Windows IO completion ports for receive
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Glue.Native MpxSocket MpxClientTransport
NFX.Glue.Native MpxClientSocket
NFX.Glue.Native MpxWinClientSocket

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class MpxWinClientSocket : MpxClientSocket
public sealed class MpxWinClientSocket : MpxClientSocket
Public NotInheritable Class MpxWinClientSocket
    Inherits MpxClientSocket
Public NotInheritable Class MpxWinClientSocket
    Inherits MpxClientSocket
public ref class MpxWinClientSocket sealed : public MpxClientSocket
public ref class MpxWinClientSocket sealed : public MpxClientSocket
[<SealedAttribute>]
type MpxWinClientSocket =
    class
        inherit MpxClientSocket
    end
[<SealedAttribute>]
type MpxWinClientSocket =
    class
        inherit MpxClientSocket
    end
See Also
MpxWinClientSocket Members
NFX.Glue.Native Namespace


MpxWinClientSocket Members

MpxWinClientSocket Members NFX Class Library

The MpxWinClientSocket type exposes the following members.
Constructors
 | Name | Description
Protected method | MpxWinClientSocket | Initializes a new instance of the MpxWinClientSocket class
Back to Top
Methods
 | Name | Description
Public method | AcceptManagerVisit | Override to perform maintenance i.e. trim excessive m_SendChunk size etc.. This method is called by Glue/Binding/Transport runtime. Also resets last last idle manager visit timestamp which is used for socket closing (Inherited from MpxSocket TTransport .)
Protected method | Destructor | (Overrides MpxSocket TTransport Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoReleaseMemChunksAfterAsyncOperations | Do not call this method, override only when freeing more than 2 standard chunks (send/recv) (Inherited from MpxSocket TTransport .)
Protected method | DoSend | (Overrides MpxSocket TTransport DoSend(WireMsg).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSendChunk | Reserves a chunk of memory of the suggested size for network send operation. The buffer must be released by a call to ReleaseSendBuffer(). Keep in mind that this method is NOT RE-ENTRANT by this or any other thread until corresponding ReleaseSendChunk() is called. MpxSocket is not thread safe for sends in general. (Inherited from MpxSocket TTransport .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeReceive | Calls ReceiveAction callback guarding for possible unhandled receive action errors (Inherited from MpxSocket TTransport .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReleaseMemChunksAfterAsyncOperations | Releases socket memory chunks. This method MUST BE called AFTER all pending async IO is done, otherwise the chunks may get released to the pool and get corrupted by the prior operation (Inherited from MpxSocket TTransport .)
Public method | ReleaseSendChunk | Releases previously reserved buffer, i.e. may trim excess allocation after a large message (Inherited from MpxSocket TTransport .)
Public method | Send | Adds the specified socket msg to the outgoing stack. This is a synchronous blocking call that executes until the data is written into socket stack (but not necessarily delivered). If send error occurs then socket is marked as !Active (Disposed) (Inherited from MpxSocket TTransport .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_ClientSite | (Inherited from MpxSocket TTransport .)
Protected field | m_Disposing | (Inherited from MpxSocket TTransport .)
Protected field | m_EndPoint | (Inherited from MpxSocket TTransport .)
Protected field | m_LastIdleManagerVisit | (Inherited from MpxSocket TTransport .)
Protected field | m_ReceiveChunk | (Inherited from MpxSocket TTransport .)
Protected field | m_SendChunk | (Inherited from MpxSocket TTransport .)
Protected field | m_Socket | (Inherited from MpxSocket TTransport .)
Protected field | m_Transport | (Inherited from MpxSocket TTransport .)
Back to Top
Properties
 | Name | Description
Public property | Active | True when socket is not disposing and runtime is not shutting down (Inherited from MpxSocket TTransport .)
Public property | ClientSite | Returns client site for the computer that initiated the call. Server socket returns the transmitted value from client. Client socket returns the one that was sent to server upon handshake (Inherited from MpxSocket TTransport .)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndPoint | Returns IP End point that this socket services, remote server for client socket and remote client for server sockets (Inherited from MpxSocket TTransport .)
Public property | LastIdleManagerVisit | Returns timestamp of last manager visit since then no traffic came through. Null indicates that traffic came though and socket has not been idle since last visit. Manager is an extrenal visitor that closes idle sockets (Inherited from MpxSocket TTransport .)
Public property | Socket | Returns the underlying socket (Inherited from MpxSocket TTransport .)
Public property | Transport | Returns transport that this socket is under (Inherited from MpxSocket TTransport .)
Back to Top
See Also
MpxWinClientSocket Class
NFX.Glue.Native Namespace


MpxWinClientSocket Constructor

MpxWinClientSocket Constructor NFX Class Library

Initializes a new instance of the MpxWinClientSocket class

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal MpxWinClientSocket(
    MpxClientTransport transport,
    IPEndPoint remoteServer,
    ClientSite clientSite,
    MpxSocketReceiveAction<MpxClientTransport> receiveAction
)
internal MpxWinClientSocket(
    MpxClientTransport transport,
    IPEndPoint remoteServer,
    ClientSite clientSite,
    MpxSocketReceiveAction<MpxClientTransport> receiveAction
)
Friend Sub New (
    transport As MpxClientTransport,
    remoteServer As IPEndPoint,
    clientSite As ClientSite,
    receiveAction As MpxSocketReceiveAction(Of MpxClientTransport)
)
Friend Sub New (
    transport As MpxClientTransport,
    remoteServer As IPEndPoint,
    clientSite As ClientSite,
    receiveAction As MpxSocketReceiveAction(Of MpxClientTransport)
)
internal:
MpxWinClientSocket(
    MpxClientTransport^ transport,
    IPEndPoint^ remoteServer,
    ClientSite clientSite,
    MpxSocketReceiveAction<MpxClientTransport^>^ receiveAction
)
internal:
MpxWinClientSocket(
    MpxClientTransport^ transport,
    IPEndPoint^ remoteServer,
    ClientSite clientSite,
    MpxSocketReceiveAction<MpxClientTransport^>^ receiveAction
)
new :
        transport : MpxClientTransport *
        remoteServer : IPEndPoint *
        clientSite : ClientSite *
        receiveAction : MpxSocketReceiveAction<MpxClientTransport> -> MpxWinClientSocket
new :
        transport : MpxClientTransport *
        remoteServer : IPEndPoint *
        clientSite : ClientSite *
        receiveAction : MpxSocketReceiveAction<MpxClientTransport> -> MpxWinClientSocket

Parameters

transport
Type: NFX.Glue.Native MpxClientTransport
remoteServer
Type: Online System.Net IPEndPoint
clientSite
Type: NFX.Glue.Native ClientSite
receiveAction
Type: NFX.Glue.Native MpxSocketReceiveAction MpxClientTransport
See Also
MpxWinClientSocket Class
MpxWinClientSocket Members
NFX.Glue.Native Namespace


MpxWinClientSocket Fields

MpxWinClientSocket Fields NFX Class Library

The MpxWinClientSocket type exposes the following members.
Fields
 | Name | Description
Protected field | m_ClientSite | (Inherited from MpxSocket TTransport .)
Protected field | m_Disposing | (Inherited from MpxSocket TTransport .)
Protected field | m_EndPoint | (Inherited from MpxSocket TTransport .)
Protected field | m_LastIdleManagerVisit | (Inherited from MpxSocket TTransport .)
Protected field | m_ReceiveChunk | (Inherited from MpxSocket TTransport .)
Protected field | m_SendChunk | (Inherited from MpxSocket TTransport .)
Protected field | m_Socket | (Inherited from MpxSocket TTransport .)
Protected field | m_Transport | (Inherited from MpxSocket TTransport .)
Back to Top
See Also
MpxWinClientSocket Class
NFX.Glue.Native Namespace


MpxWinClientSocket Methods

MpxWinClientSocket Methods NFX Class Library

The MpxWinClientSocket type exposes the following members.
Methods
 | Name | Description
Public method | AcceptManagerVisit | Override to perform maintenance i.e. trim excessive m_SendChunk size etc.. This method is called by Glue/Binding/Transport runtime. Also resets last last idle manager visit timestamp which is used for socket closing (Inherited from MpxSocket TTransport .)
Protected method | Destructor | (Overrides MpxSocket TTransport Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoReleaseMemChunksAfterAsyncOperations | Do not call this method, override only when freeing more than 2 standard chunks (send/recv) (Inherited from MpxSocket TTransport .)
Protected method | DoSend | (Overrides MpxSocket TTransport DoSend(WireMsg).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSendChunk | Reserves a chunk of memory of the suggested size for network send operation. The buffer must be released by a call to ReleaseSendBuffer(). Keep in mind that this method is NOT RE-ENTRANT by this or any other thread until corresponding ReleaseSendChunk() is called. MpxSocket is not thread safe for sends in general. (Inherited from MpxSocket TTransport .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeReceive | Calls ReceiveAction callback guarding for possible unhandled receive action errors (Inherited from MpxSocket TTransport .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReleaseMemChunksAfterAsyncOperations | Releases socket memory chunks. This method MUST BE called AFTER all pending async IO is done, otherwise the chunks may get released to the pool and get corrupted by the prior operation (Inherited from MpxSocket TTransport .)
Public method | ReleaseSendChunk | Releases previously reserved buffer, i.e. may trim excess allocation after a large message (Inherited from MpxSocket TTransport .)
Public method | Send | Adds the specified socket msg to the outgoing stack. This is a synchronous blocking call that executes until the data is written into socket stack (but not necessarily delivered). If send error occurs then socket is marked as !Active (Disposed) (Inherited from MpxSocket TTransport .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MpxWinClientSocket Class
NFX.Glue.Native Namespace


MpxWinClientSocket.Destructor Method

MpxWinClientSocket Destructor Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
MpxWinClientSocket Class
MpxWinClientSocket Members
NFX.Glue.Native Namespace


MpxWinClientSocket.DoSend Method

MpxWinClientSocket DoSend Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSend(
    WireMsg data
)
protected override void DoSend(
    WireMsg data
)
Protected Overrides Sub DoSend (
    data As WireMsg
)
Protected Overrides Sub DoSend (
    data As WireMsg
)
protected:
virtual void DoSend(
    WireMsg data
) override
protected:
virtual void DoSend(
    WireMsg data
) override
abstract DoSend :
        data : WireMsg -> unit
override DoSend :
        data : WireMsg -> unit
abstract DoSend :
        data : WireMsg -> unit
override DoSend :
        data : WireMsg -> unit

Parameters

data
Type: NFX.Glue.Native WireMsg
See Also
MpxWinClientSocket Class
MpxWinClientSocket Members
NFX.Glue.Native Namespace


MpxWinClientSocket Properties

MpxWinClientSocket Properties NFX Class Library

The MpxWinClientSocket type exposes the following members.
Properties
 | Name | Description
Public property | Active | True when socket is not disposing and runtime is not shutting down (Inherited from MpxSocket TTransport .)
Public property | ClientSite | Returns client site for the computer that initiated the call. Server socket returns the transmitted value from client. Client socket returns the one that was sent to server upon handshake (Inherited from MpxSocket TTransport .)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndPoint | Returns IP End point that this socket services, remote server for client socket and remote client for server sockets (Inherited from MpxSocket TTransport .)
Public property | LastIdleManagerVisit | Returns timestamp of last manager visit since then no traffic came through. Null indicates that traffic came though and socket has not been idle since last visit. Manager is an extrenal visitor that closes idle sockets (Inherited from MpxSocket TTransport .)
Public property | Socket | Returns the underlying socket (Inherited from MpxSocket TTransport .)
Public property | Transport | Returns transport that this socket is under (Inherited from MpxSocket TTransport .)
Back to Top
See Also
MpxWinClientSocket Class
NFX.Glue.Native Namespace


MpxWinListener Class

MpxWinListener Class NFX Class Library

Implements a MPX socket listener that accepts connections into MpxWinServerSocket
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Glue.Native MpxListener
NFX.Glue.Native MpxWinListener

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class MpxWinListener : MpxListener
public sealed class MpxWinListener : MpxListener
Public NotInheritable Class MpxWinListener
    Inherits MpxListener
Public NotInheritable Class MpxWinListener
    Inherits MpxListener
public ref class MpxWinListener sealed : public MpxListener
public ref class MpxWinListener sealed : public MpxListener
[<SealedAttribute>]
type MpxWinListener =
    class
        inherit MpxListener
    end
[<SealedAttribute>]
type MpxWinListener =
    class
        inherit MpxListener
    end
See Also
MpxWinListener Members
NFX.Glue.Native Namespace


MpxWinListener Members

MpxWinListener Members NFX Class Library

The MpxWinListener type exposes the following members.
Constructors
 | Name | Description
Protected method | MpxWinListener | Initializes a new instance of the MpxWinListener class
Back to Top
Methods
 | Name | Description
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_EndPoint | (Inherited from MpxListener.)
Protected field | m_SocketReceiveAction | (Inherited from MpxListener.)
 | THREAD_NAME |
Back to Top
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndPoint | Returns IP End point that this listener listens on (Inherited from MpxListener.)
Public property | Transport | Returns transpoirt that this listener listens under (Inherited from MpxListener.)
Back to Top
See Also
MpxWinListener Class
NFX.Glue.Native Namespace


MpxWinListener Constructor

MpxWinListener Constructor NFX Class Library

Initializes a new instance of the MpxWinListener class

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal MpxWinListener(
    MpxServerTransport transport,
    IPEndPoint listenEndPoint,
    MpxSocketReceiveAction<MpxServerTransport> socketReceiveAction
)
internal MpxWinListener(
    MpxServerTransport transport,
    IPEndPoint listenEndPoint,
    MpxSocketReceiveAction<MpxServerTransport> socketReceiveAction
)
Friend Sub New (
    transport As MpxServerTransport,
    listenEndPoint As IPEndPoint,
    socketReceiveAction As MpxSocketReceiveAction(Of MpxServerTransport)
)
Friend Sub New (
    transport As MpxServerTransport,
    listenEndPoint As IPEndPoint,
    socketReceiveAction As MpxSocketReceiveAction(Of MpxServerTransport)
)
internal:
MpxWinListener(
    MpxServerTransport^ transport,
    IPEndPoint^ listenEndPoint,
    MpxSocketReceiveAction<MpxServerTransport^>^ socketReceiveAction
)
internal:
MpxWinListener(
    MpxServerTransport^ transport,
    IPEndPoint^ listenEndPoint,
    MpxSocketReceiveAction<MpxServerTransport^>^ socketReceiveAction
)
new :
        transport : MpxServerTransport *
        listenEndPoint : IPEndPoint *
        socketReceiveAction : MpxSocketReceiveAction<MpxServerTransport> -> MpxWinListener
new :
        transport : MpxServerTransport *
        listenEndPoint : IPEndPoint *
        socketReceiveAction : MpxSocketReceiveAction<MpxServerTransport> -> MpxWinListener

Parameters

transport
Type: NFX.Glue.Native MpxServerTransport
listenEndPoint
Type: Online System.Net IPEndPoint
socketReceiveAction
Type: NFX.Glue.Native MpxSocketReceiveAction MpxServerTransport
See Also
MpxWinListener Class
MpxWinListener Members
NFX.Glue.Native Namespace


MpxWinListener Fields

MpxWinListener Fields NFX Class Library

The MpxWinListener type exposes the following members.
Fields
 | Name | Description
Protected field | m_EndPoint | (Inherited from MpxListener.)
Protected field | m_SocketReceiveAction | (Inherited from MpxListener.)
 | THREAD_NAME |
Back to Top
See Also
MpxWinListener Class
NFX.Glue.Native Namespace


MpxWinListener.THREAD_NAME Field

MpxWinListener THREAD_NAME Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string THREAD_NAME
public const string THREAD_NAME
Public Const THREAD_NAME As String
Public Const THREAD_NAME As String
public:
literal String^ THREAD_NAME
public:
literal String^ THREAD_NAME
static val mutable THREAD_NAME: string
static val mutable THREAD_NAME: string

Field Value

Type: Online String
See Also
MpxWinListener Class
MpxWinListener Members
NFX.Glue.Native Namespace


MpxWinListener Methods

MpxWinListener Methods NFX Class Library

The MpxWinListener type exposes the following members.
Methods
 | Name | Description
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MpxWinListener Class
NFX.Glue.Native Namespace


MpxWinListener.Destructor Method

MpxWinListener Destructor Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
MpxWinListener Class
MpxWinListener Members
NFX.Glue.Native Namespace


MpxWinListener Properties

MpxWinListener Properties NFX Class Library

The MpxWinListener type exposes the following members.
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndPoint | Returns IP End point that this listener listens on (Inherited from MpxListener.)
Public property | Transport | Returns transpoirt that this listener listens under (Inherited from MpxListener.)
Back to Top
See Also
MpxWinListener Class
NFX.Glue.Native Namespace


MpxWinServerSocket Class

MpxWinServerSocket Class NFX Class Library

Implements a MPX server socket using Windows IO completion ports for receive
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Glue.Native MpxSocket MpxServerTransport
NFX.Glue.Native MpxServerSocket
NFX.Glue.Native MpxWinServerSocket

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class MpxWinServerSocket : MpxServerSocket
public sealed class MpxWinServerSocket : MpxServerSocket
Public NotInheritable Class MpxWinServerSocket
    Inherits MpxServerSocket
Public NotInheritable Class MpxWinServerSocket
    Inherits MpxServerSocket
public ref class MpxWinServerSocket sealed : public MpxServerSocket
public ref class MpxWinServerSocket sealed : public MpxServerSocket
[<SealedAttribute>]
type MpxWinServerSocket =
    class
        inherit MpxServerSocket
    end
[<SealedAttribute>]
type MpxWinServerSocket =
    class
        inherit MpxServerSocket
    end
See Also
MpxWinServerSocket Members
NFX.Glue.Native Namespace


MpxWinServerSocket Members

MpxWinServerSocket Members NFX Class Library

The MpxWinServerSocket type exposes the following members.
Constructors
 | Name | Description
Protected method | MpxWinServerSocket | Initializes a new instance of the MpxWinServerSocket class
Back to Top
Methods
 | Name | Description
Public method | AcceptManagerVisit | (Inherited from MpxServerSocket.)
Protected method | Destructor | (Overrides MpxServerSocket Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoReleaseMemChunksAfterAsyncOperations | Do not call this method, override only when freeing more than 2 standard chunks (send/recv) (Inherited from MpxSocket TTransport .)
Protected method | DoSend | (Overrides MpxSocket TTransport DoSend(WireMsg).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSendChunk | Reserves a chunk of memory of the suggested size for network send operation. The buffer must be released by a call to ReleaseSendBuffer(). Keep in mind that this method is NOT RE-ENTRANT by this or any other thread until corresponding ReleaseSendChunk() is called. MpxSocket is not thread safe for sends in general. (Inherited from MpxSocket TTransport .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeReceive | Calls ReceiveAction callback guarding for possible unhandled receive action errors (Inherited from MpxSocket TTransport .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReleaseMemChunksAfterAsyncOperations | Releases socket memory chunks. This method MUST BE called AFTER all pending async IO is done, otherwise the chunks may get released to the pool and get corrupted by the prior operation (Inherited from MpxSocket TTransport .)
Public method | ReleaseSendChunk | Releases previously reserved buffer, i.e. may trim excess allocation after a large message (Inherited from MpxSocket TTransport .)
Public method | Send | Adds the specified socket msg to the outgoing stack. This is a synchronous blocking call that executes until the data is written into socket stack (but not necessarily delivered). If send error occurs then socket is marked as !Active (Disposed) (Inherited from MpxSocket TTransport .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_ClientSite | (Inherited from MpxSocket TTransport .)
Protected field | m_Disposing | (Inherited from MpxSocket TTransport .)
Protected field | m_EndPoint | (Inherited from MpxSocket TTransport .)
Protected field | m_LastIdleManagerVisit | (Inherited from MpxSocket TTransport .)
Protected field | m_ReceiveChunk | (Inherited from MpxSocket TTransport .)
Protected field | m_SendChunk | (Inherited from MpxSocket TTransport .)
Protected field | m_Socket | (Inherited from MpxSocket TTransport .)
Protected field | m_Transport | (Inherited from MpxSocket TTransport .)
Back to Top
Properties
 | Name | Description
Public property | Active | True when socket is not disposing and runtime is not shutting down (Inherited from MpxSocket TTransport .)
Public property | ClientSite | Returns client site for the computer that initiated the call. Server socket returns the transmitted value from client. Client socket returns the one that was sent to server upon handshake (Inherited from MpxSocket TTransport .)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndPoint | Returns IP End point that this socket services, remote server for client socket and remote client for server sockets (Inherited from MpxSocket TTransport .)
Public property | LastIdleManagerVisit | Returns timestamp of last manager visit since then no traffic came through. Null indicates that traffic came though and socket has not been idle since last visit. Manager is an extrenal visitor that closes idle sockets (Inherited from MpxSocket TTransport .)
Public property | Listener | Returns listener socket that initiated/opened this server socket (Inherited from MpxServerSocket.)
Public property | Socket | Returns the underlying socket (Inherited from MpxSocket TTransport .)
Public property | Transport | Returns transport that this socket is under (Inherited from MpxSocket TTransport .)
Back to Top
See Also
MpxWinServerSocket Class
NFX.Glue.Native Namespace


MpxWinServerSocket Constructor

MpxWinServerSocket Constructor NFX Class Library

Initializes a new instance of the MpxWinServerSocket class

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal MpxWinServerSocket(
    MpxListener listener,
    TcpClient client,
    ClientSite clientSite,
    MpxSocketReceiveAction<MpxServerTransport> receiveAction
)
internal MpxWinServerSocket(
    MpxListener listener,
    TcpClient client,
    ClientSite clientSite,
    MpxSocketReceiveAction<MpxServerTransport> receiveAction
)
Friend Sub New (
    listener As MpxListener,
    client As TcpClient,
    clientSite As ClientSite,
    receiveAction As MpxSocketReceiveAction(Of MpxServerTransport)
)
Friend Sub New (
    listener As MpxListener,
    client As TcpClient,
    clientSite As ClientSite,
    receiveAction As MpxSocketReceiveAction(Of MpxServerTransport)
)
internal:
MpxWinServerSocket(
    MpxListener^ listener,
    TcpClient^ client,
    ClientSite clientSite,
    MpxSocketReceiveAction<MpxServerTransport^>^ receiveAction
)
internal:
MpxWinServerSocket(
    MpxListener^ listener,
    TcpClient^ client,
    ClientSite clientSite,
    MpxSocketReceiveAction<MpxServerTransport^>^ receiveAction
)
new :
        listener : MpxListener *
        client : TcpClient *
        clientSite : ClientSite *
        receiveAction : MpxSocketReceiveAction<MpxServerTransport> -> MpxWinServerSocket
new :
        listener : MpxListener *
        client : TcpClient *
        clientSite : ClientSite *
        receiveAction : MpxSocketReceiveAction<MpxServerTransport> -> MpxWinServerSocket

Parameters

listener
Type: NFX.Glue.Native MpxListener
client
Type: Online System.Net.Sockets TcpClient
clientSite
Type: NFX.Glue.Native ClientSite
receiveAction
Type: NFX.Glue.Native MpxSocketReceiveAction MpxServerTransport
See Also
MpxWinServerSocket Class
MpxWinServerSocket Members
NFX.Glue.Native Namespace


MpxWinServerSocket Fields

MpxWinServerSocket Fields NFX Class Library

The MpxWinServerSocket type exposes the following members.
Fields
 | Name | Description
Protected field | m_ClientSite | (Inherited from MpxSocket TTransport .)
Protected field | m_Disposing | (Inherited from MpxSocket TTransport .)
Protected field | m_EndPoint | (Inherited from MpxSocket TTransport .)
Protected field | m_LastIdleManagerVisit | (Inherited from MpxSocket TTransport .)
Protected field | m_ReceiveChunk | (Inherited from MpxSocket TTransport .)
Protected field | m_SendChunk | (Inherited from MpxSocket TTransport .)
Protected field | m_Socket | (Inherited from MpxSocket TTransport .)
Protected field | m_Transport | (Inherited from MpxSocket TTransport .)
Back to Top
See Also
MpxWinServerSocket Class
NFX.Glue.Native Namespace


MpxWinServerSocket Methods

MpxWinServerSocket Methods NFX Class Library

The MpxWinServerSocket type exposes the following members.
Methods
 | Name | Description
Public method | AcceptManagerVisit | (Inherited from MpxServerSocket.)
Protected method | Destructor | (Overrides MpxServerSocket Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoReleaseMemChunksAfterAsyncOperations | Do not call this method, override only when freeing more than 2 standard chunks (send/recv) (Inherited from MpxSocket TTransport .)
Protected method | DoSend | (Overrides MpxSocket TTransport DoSend(WireMsg).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetSendChunk | Reserves a chunk of memory of the suggested size for network send operation. The buffer must be released by a call to ReleaseSendBuffer(). Keep in mind that this method is NOT RE-ENTRANT by this or any other thread until corresponding ReleaseSendChunk() is called. MpxSocket is not thread safe for sends in general. (Inherited from MpxSocket TTransport .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | InvokeReceive | Calls ReceiveAction callback guarding for possible unhandled receive action errors (Inherited from MpxSocket TTransport .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReleaseMemChunksAfterAsyncOperations | Releases socket memory chunks. This method MUST BE called AFTER all pending async IO is done, otherwise the chunks may get released to the pool and get corrupted by the prior operation (Inherited from MpxSocket TTransport .)
Public method | ReleaseSendChunk | Releases previously reserved buffer, i.e. may trim excess allocation after a large message (Inherited from MpxSocket TTransport .)
Public method | Send | Adds the specified socket msg to the outgoing stack. This is a synchronous blocking call that executes until the data is written into socket stack (but not necessarily delivered). If send error occurs then socket is marked as !Active (Disposed) (Inherited from MpxSocket TTransport .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MpxWinServerSocket Class
NFX.Glue.Native Namespace


MpxWinServerSocket.Destructor Method

MpxWinServerSocket Destructor Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
MpxWinServerSocket Class
MpxWinServerSocket Members
NFX.Glue.Native Namespace


MpxWinServerSocket.DoSend Method

MpxWinServerSocket DoSend Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSend(
    WireMsg data
)
protected override void DoSend(
    WireMsg data
)
Protected Overrides Sub DoSend (
    data As WireMsg
)
Protected Overrides Sub DoSend (
    data As WireMsg
)
protected:
virtual void DoSend(
    WireMsg data
) override
protected:
virtual void DoSend(
    WireMsg data
) override
abstract DoSend :
        data : WireMsg -> unit
override DoSend :
        data : WireMsg -> unit
abstract DoSend :
        data : WireMsg -> unit
override DoSend :
        data : WireMsg -> unit

Parameters

data
Type: NFX.Glue.Native WireMsg
See Also
MpxWinServerSocket Class
MpxWinServerSocket Members
NFX.Glue.Native Namespace


MpxWinServerSocket Properties

MpxWinServerSocket Properties NFX Class Library

The MpxWinServerSocket type exposes the following members.
Properties
 | Name | Description
Public property | Active | True when socket is not disposing and runtime is not shutting down (Inherited from MpxSocket TTransport .)
Public property | ClientSite | Returns client site for the computer that initiated the call. Server socket returns the transmitted value from client. Client socket returns the one that was sent to server upon handshake (Inherited from MpxSocket TTransport .)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndPoint | Returns IP End point that this socket services, remote server for client socket and remote client for server sockets (Inherited from MpxSocket TTransport .)
Public property | LastIdleManagerVisit | Returns timestamp of last manager visit since then no traffic came through. Null indicates that traffic came though and socket has not been idle since last visit. Manager is an extrenal visitor that closes idle sockets (Inherited from MpxSocket TTransport .)
Public property | Listener | Returns listener socket that initiated/opened this server socket (Inherited from MpxServerSocket.)
Public property | Socket | Returns the underlying socket (Inherited from MpxSocket TTransport .)
Public property | Transport | Returns transport that this socket is under (Inherited from MpxSocket TTransport .)
Back to Top
See Also
MpxWinServerSocket Class
NFX.Glue.Native Namespace


MpxWinSocketFactory Class

MpxWinSocketFactory Class NFX Class Library

Factory that makes MpxWin sockets based on Windows-IO completion ports
Inheritance Hierarchy
Online System Object
NFX.Glue.Native MpxSocketFactory
NFX.Glue.Native MpxWinSocketFactory

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class MpxWinSocketFactory : MpxSocketFactory
public sealed class MpxWinSocketFactory : MpxSocketFactory
Public NotInheritable Class MpxWinSocketFactory
    Inherits MpxSocketFactory
Public NotInheritable Class MpxWinSocketFactory
    Inherits MpxSocketFactory
public ref class MpxWinSocketFactory sealed : public MpxSocketFactory
public ref class MpxWinSocketFactory sealed : public MpxSocketFactory
[<SealedAttribute>]
type MpxWinSocketFactory =
    class
        inherit MpxSocketFactory
    end
[<SealedAttribute>]
type MpxWinSocketFactory =
    class
        inherit MpxSocketFactory
    end
See Also
MpxWinSocketFactory Members
NFX.Glue.Native Namespace


MpxWinSocketFactory Members

MpxWinSocketFactory Members NFX Class Library

The MpxWinSocketFactory type exposes the following members.
Constructors
 | Name | Description
Public method | MpxWinSocketFactory | Initializes a new instance of the MpxWinSocketFactory class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Overrides MpxSocketFactory Configure(IConfigSectionNode).)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeClientSocket | (Overrides MpxSocketFactory MakeClientSocket(MpxClientTransport, IPEndPoint, ClientSite, MpxSocketReceiveAction MpxClientTransport ).)
Public method | MakeListener | (Overrides MpxSocketFactory MakeListener(MpxServerTransport, IPEndPoint, MpxSocketReceiveAction MpxServerTransport ).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MpxWinSocketFactory Class
NFX.Glue.Native Namespace


MpxWinSocketFactory Constructor

MpxWinSocketFactory Constructor NFX Class Library

Initializes a new instance of the MpxWinSocketFactory class

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MpxWinSocketFactory()
public MpxWinSocketFactory()
Public Sub New
Public Sub New
public:
MpxWinSocketFactory()
public:
MpxWinSocketFactory()
new : unit -> MpxWinSocketFactory
new : unit -> MpxWinSocketFactory
See Also
MpxWinSocketFactory Class
MpxWinSocketFactory Members
NFX.Glue.Native Namespace


MpxWinSocketFactory Methods

MpxWinSocketFactory Methods NFX Class Library

The MpxWinSocketFactory type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Overrides MpxSocketFactory Configure(IConfigSectionNode).)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeClientSocket | (Overrides MpxSocketFactory MakeClientSocket(MpxClientTransport, IPEndPoint, ClientSite, MpxSocketReceiveAction MpxClientTransport ).)
Public method | MakeListener | (Overrides MpxSocketFactory MakeListener(MpxServerTransport, IPEndPoint, MpxSocketReceiveAction MpxServerTransport ).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MpxWinSocketFactory Class
NFX.Glue.Native Namespace


MpxWinSocketFactory.Configure Method

MpxWinSocketFactory Configure Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Configure(
    IConfigSectionNode node
)
public override void Configure(
    IConfigSectionNode node
)
Public Overrides Sub Configure (
    node As IConfigSectionNode
)
Public Overrides Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) override
public:
virtual void Configure(
    IConfigSectionNode^ node
) override
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
MpxWinSocketFactory Class
MpxWinSocketFactory Members
NFX.Glue.Native Namespace


MpxWinSocketFactory.MakeClientSocket Method

MpxWinSocketFactory MakeClientSocket Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override MpxClientSocket MakeClientSocket(
    MpxClientTransport transport,
    IPEndPoint remoteServer,
    ClientSite clientSite,
    MpxSocketReceiveAction<MpxClientTransport> receiveAction
)
public override MpxClientSocket MakeClientSocket(
    MpxClientTransport transport,
    IPEndPoint remoteServer,
    ClientSite clientSite,
    MpxSocketReceiveAction<MpxClientTransport> receiveAction
)
Public Overrides Function MakeClientSocket (
    transport As MpxClientTransport,
    remoteServer As IPEndPoint,
    clientSite As ClientSite,
    receiveAction As MpxSocketReceiveAction(Of MpxClientTransport)
) As MpxClientSocket
Public Overrides Function MakeClientSocket (
    transport As MpxClientTransport,
    remoteServer As IPEndPoint,
    clientSite As ClientSite,
    receiveAction As MpxSocketReceiveAction(Of MpxClientTransport)
) As MpxClientSocket
public:
virtual MpxClientSocket^ MakeClientSocket(
    MpxClientTransport^ transport,
    IPEndPoint^ remoteServer,
    ClientSite clientSite,
    MpxSocketReceiveAction<MpxClientTransport^>^ receiveAction
) override
public:
virtual MpxClientSocket^ MakeClientSocket(
    MpxClientTransport^ transport,
    IPEndPoint^ remoteServer,
    ClientSite clientSite,
    MpxSocketReceiveAction<MpxClientTransport^>^ receiveAction
) override
abstract MakeClientSocket :
        transport : MpxClientTransport *
        remoteServer : IPEndPoint *
        clientSite : ClientSite *
        receiveAction : MpxSocketReceiveAction<MpxClientTransport> -> MpxClientSocket
override MakeClientSocket :
        transport : MpxClientTransport *
        remoteServer : IPEndPoint *
        clientSite : ClientSite *
        receiveAction : MpxSocketReceiveAction<MpxClientTransport> -> MpxClientSocket
abstract MakeClientSocket :
        transport : MpxClientTransport *
        remoteServer : IPEndPoint *
        clientSite : ClientSite *
        receiveAction : MpxSocketReceiveAction<MpxClientTransport> -> MpxClientSocket
override MakeClientSocket :
        transport : MpxClientTransport *
        remoteServer : IPEndPoint *
        clientSite : ClientSite *
        receiveAction : MpxSocketReceiveAction<MpxClientTransport> -> MpxClientSocket

Parameters

transport
Type: NFX.Glue.Native MpxClientTransport
remoteServer
Type: Online System.Net IPEndPoint
clientSite
Type: NFX.Glue.Native ClientSite
receiveAction
Type: NFX.Glue.Native MpxSocketReceiveAction MpxClientTransport

Return Value

Type: MpxClientSocket
See Also
MpxWinSocketFactory Class
MpxWinSocketFactory Members
NFX.Glue.Native Namespace


MpxWinSocketFactory.MakeListener Method

MpxWinSocketFactory MakeListener Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override MpxListener MakeListener(
    MpxServerTransport transport,
    IPEndPoint listenEndPoint,
    MpxSocketReceiveAction<MpxServerTransport> socketReceiveAction
)
public override MpxListener MakeListener(
    MpxServerTransport transport,
    IPEndPoint listenEndPoint,
    MpxSocketReceiveAction<MpxServerTransport> socketReceiveAction
)
Public Overrides Function MakeListener (
    transport As MpxServerTransport,
    listenEndPoint As IPEndPoint,
    socketReceiveAction As MpxSocketReceiveAction(Of MpxServerTransport)
) As MpxListener
Public Overrides Function MakeListener (
    transport As MpxServerTransport,
    listenEndPoint As IPEndPoint,
    socketReceiveAction As MpxSocketReceiveAction(Of MpxServerTransport)
) As MpxListener
public:
virtual MpxListener^ MakeListener(
    MpxServerTransport^ transport,
    IPEndPoint^ listenEndPoint,
    MpxSocketReceiveAction<MpxServerTransport^>^ socketReceiveAction
) override
public:
virtual MpxListener^ MakeListener(
    MpxServerTransport^ transport,
    IPEndPoint^ listenEndPoint,
    MpxSocketReceiveAction<MpxServerTransport^>^ socketReceiveAction
) override
abstract MakeListener :
        transport : MpxServerTransport *
        listenEndPoint : IPEndPoint *
        socketReceiveAction : MpxSocketReceiveAction<MpxServerTransport> -> MpxListener
override MakeListener :
        transport : MpxServerTransport *
        listenEndPoint : IPEndPoint *
        socketReceiveAction : MpxSocketReceiveAction<MpxServerTransport> -> MpxListener
abstract MakeListener :
        transport : MpxServerTransport *
        listenEndPoint : IPEndPoint *
        socketReceiveAction : MpxSocketReceiveAction<MpxServerTransport> -> MpxListener
override MakeListener :
        transport : MpxServerTransport *
        listenEndPoint : IPEndPoint *
        socketReceiveAction : MpxSocketReceiveAction<MpxServerTransport> -> MpxListener

Parameters

transport
Type: NFX.Glue.Native MpxServerTransport
listenEndPoint
Type: Online System.Net IPEndPoint
socketReceiveAction
Type: NFX.Glue.Native MpxSocketReceiveAction MpxServerTransport

Return Value

Type: MpxListener
See Also
MpxWinSocketFactory Class
MpxWinSocketFactory Members
NFX.Glue.Native Namespace


SocketState Class

SocketState Class NFX Class Library

Inheritance Hierarchy
Online System Object
Online System EventArgs
Online System.Net.Sockets SocketAsyncEventArgs
NFX.Glue.Native SocketState

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal sealed class SocketState : SocketAsyncEventArgs
internal sealed class SocketState : SocketAsyncEventArgs
Friend NotInheritable Class SocketState
    Inherits SocketAsyncEventArgs
Friend NotInheritable Class SocketState
    Inherits SocketAsyncEventArgs
internal ref class SocketState sealed : public SocketAsyncEventArgs
internal ref class SocketState sealed : public SocketAsyncEventArgs
[<SealedAttribute>]
type SocketState =
    class
        inherit SocketAsyncEventArgs
    end
[<SealedAttribute>]
type SocketState =
    class
        inherit SocketAsyncEventArgs
    end
See Also
SocketState Members
NFX.Glue.Native Namespace


SocketState Members

SocketState Members NFX Class Library

The SocketState type exposes the following members.
Constructors
 | Name | Description
Public method | SocketState | Initializes a new instance of the SocketState class
Back to Top
Methods
 | Name | Description
Public method | Online Dispose | (Inherited from Online SocketAsyncEventArgs.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | (Inherited from Online SocketAsyncEventArgs.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online OnCompleted | (Inherited from Online SocketAsyncEventArgs.)
Public method | Reset |
Public method | Online SetBuffer(Int32, Int32) | (Inherited from Online SocketAsyncEventArgs.)
Public method | Online SetBuffer( Byte , Int32, Int32) | (Inherited from Online SocketAsyncEventArgs.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | WireMsgSize |
Back to Top
Properties
 | Name | Description
Public property | Online AcceptSocket | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online Buffer | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online BufferList | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online BytesTransferred | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online ConnectByNameError | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online ConnectSocket | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online Count | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online DisconnectReuseSocket | (Inherited from Online SocketAsyncEventArgs.)
Public property | HasMsgSize |
Public property | Online LastOperation | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online Offset | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online ReceiveMessageFromPacketInfo | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online RemoteEndPoint | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online SendPacketsElements | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online SendPacketsFlags | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online SendPacketsSendSize | (Inherited from Online SocketAsyncEventArgs.)
Public property | SocketClientAccessPolicyProtocol | Obsolete. Gets or sets the protocol to use to download the socket client access policy file. (Inherited from Online SocketAsyncEventArgs.)
Public property | Online SocketError | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online SocketFlags | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online UserToken | (Inherited from Online SocketAsyncEventArgs.)
Back to Top
Events
 | Name | Description
Public event | Online Completed | (Inherited from Online SocketAsyncEventArgs.)
Back to Top
See Also
SocketState Class
NFX.Glue.Native Namespace


SocketState Constructor

SocketState Constructor NFX Class Library

Initializes a new instance of the SocketState class

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SocketState(
    Socket socket,
    byte[] buffer
)
public SocketState(
    Socket socket,
    byte[] buffer
)
Public Sub New (
    socket As Socket,
    buffer As Byte()
)
Public Sub New (
    socket As Socket,
    buffer As Byte()
)
public:
SocketState(
    Socket^ socket,
    array<unsigned char>^ buffer
)
public:
SocketState(
    Socket^ socket,
    array<unsigned char>^ buffer
)
new :
        socket : Socket *
        buffer : byte[] -> SocketState
new :
        socket : Socket *
        buffer : byte[] -> SocketState

Parameters

socket
Type: Online System.Net.Sockets Socket
buffer
Type: Online System Byte
See Also
SocketState Class
SocketState Members
NFX.Glue.Native Namespace


SocketState Fields

SocketState Fields NFX Class Library

The SocketState type exposes the following members.
Fields
 | Name | Description
Public field | WireMsgSize |
Back to Top
See Also
SocketState Class
NFX.Glue.Native Namespace


SocketState.WireMsgSize Field

SocketState WireMsgSize Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int WireMsgSize
public int WireMsgSize
Public WireMsgSize As Integer
Public WireMsgSize As Integer
public:
int WireMsgSize
public:
int WireMsgSize
val mutable WireMsgSize: int
val mutable WireMsgSize: int

Field Value

Type: Online Int32
See Also
SocketState Class
SocketState Members
NFX.Glue.Native Namespace


SocketState Methods

SocketState Methods NFX Class Library

The SocketState type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | (Inherited from Online SocketAsyncEventArgs.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | (Inherited from Online SocketAsyncEventArgs.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online OnCompleted | (Inherited from Online SocketAsyncEventArgs.)
Public method | Reset |
Public method | Online SetBuffer(Int32, Int32) | (Inherited from Online SocketAsyncEventArgs.)
Public method | Online SetBuffer( Byte , Int32, Int32) | (Inherited from Online SocketAsyncEventArgs.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SocketState Class
NFX.Glue.Native Namespace


SocketState.Reset Method

SocketState Reset Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Reset()
public void Reset()
Public Sub Reset
Public Sub Reset
public:
void Reset()
public:
void Reset()
member Reset : unit -> unit
member Reset : unit -> unit
See Also
SocketState Class
SocketState Members
NFX.Glue.Native Namespace


SocketState Properties

SocketState Properties NFX Class Library

The SocketState type exposes the following members.
Properties
 | Name | Description
Public property | Online AcceptSocket | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online Buffer | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online BufferList | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online BytesTransferred | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online ConnectByNameError | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online ConnectSocket | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online Count | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online DisconnectReuseSocket | (Inherited from Online SocketAsyncEventArgs.)
Public property | HasMsgSize |
Public property | Online LastOperation | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online Offset | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online ReceiveMessageFromPacketInfo | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online RemoteEndPoint | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online SendPacketsElements | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online SendPacketsFlags | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online SendPacketsSendSize | (Inherited from Online SocketAsyncEventArgs.)
Public property | SocketClientAccessPolicyProtocol | Obsolete. Gets or sets the protocol to use to download the socket client access policy file. (Inherited from Online SocketAsyncEventArgs.)
Public property | Online SocketError | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online SocketFlags | (Inherited from Online SocketAsyncEventArgs.)
Public property | Online UserToken | (Inherited from Online SocketAsyncEventArgs.)
Back to Top
See Also
SocketState Class
NFX.Glue.Native Namespace


SocketState.HasMsgSize Property

SocketState HasMsgSize Property NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasMsgSize { get; }
public bool HasMsgSize { get; }
Public ReadOnly Property HasMsgSize As Boolean
    Get
Public ReadOnly Property HasMsgSize As Boolean
    Get
public:
property bool HasMsgSize {
    bool get ();
}
public:
property bool HasMsgSize {
    bool get ();
}
member HasMsgSize : bool with get
member HasMsgSize : bool with get

Property Value

Type: Online Boolean
See Also
SocketState Class
SocketState Members
NFX.Glue.Native Namespace


SocketState Events

SocketState Events NFX Class Library

The SocketState type exposes the following members.
Events
 | Name | Description
Public event | Online Completed | (Inherited from Online SocketAsyncEventArgs.)
Back to Top
See Also
SocketState Class
NFX.Glue.Native Namespace


SyncBinding Class

SyncBinding Class NFX Class Library

Provides synchronous communication pattern based on TCP blocking sockets and Slim serializer for maximum serialization performance and lowest latency. This binding is usable for interconnection between NFX-native components on LANs (i.e. server clusters) in scenarios when low latency is more important than total call invocation throughput
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service IGlueImplementation
NFX.ServiceModel ServiceWithInstrumentationBase IGlueImplementation
NFX.Glue GlueComponentService
NFX.Glue Binding
NFX.Glue.Native SyncBinding

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SyncBinding : Binding
public class SyncBinding : Binding
Public Class SyncBinding
    Inherits Binding
Public Class SyncBinding
    Inherits Binding
public ref class SyncBinding : public Binding
public ref class SyncBinding : public Binding
type SyncBinding =
    class
        inherit Binding
    end
type SyncBinding =
    class
        inherit Binding
    end
See Also
SyncBinding Members
NFX.Glue.Native Namespace


SyncBinding Members

SyncBinding Members NFX Class Library

The SyncBinding type exposes the following members.
Constructors
 | Name | Description
Public method | SyncBinding(String) | Initializes a new instance of the SyncBinding class
Public method | SyncBinding(IGlueImplementation, String) | Initializes a new instance of the SyncBinding class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | _Register | (Inherited from Binding.)
Protected method | _Unregister | (Inherited from Binding.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Protected method | AcquireClientTransportForCall | Returns an instance of transport suitable for a call. The implementation may return existing transport or allocate a new instance. The call is thread-safe (Inherited from Binding.)
Public method | AreNodesIdentical | (Overrides Binding AreNodesIdentical(Node, Node).)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and binding runtime are running or throws otherwise (Inherited from Binding.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Protected method | CloseServerEndpoint | (Overrides Binding CloseServerEndpoint(ServerEndPoint).)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | ConfigureAndStartNewClientTransport | Override to perform custom transport preparation and launch (Inherited from Binding.)
Protected method | Destructor | (Inherited from Binding.)
Public method | DispatchCall | Dispatches a call allocating new or re-using existing transport if needed. The strategy depends on particular Binding implementation. This call is thread-safe (Inherited from Binding.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | (Inherited from Binding.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Inherited from Binding.)
Protected method | DoSignalStop | (Inherited from Binding.)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Binding DoWaitForCompleteStop .)
Protected method | DumpMsg(Boolean, Msg, ArraySegment Byte ) | Conditionally dumps message to disk (Inherited from Binding.)
Protected method | DumpMsg(Boolean, Msg, Func ArraySegment Byte ) | Conditionally dumps message to disk where the data is lazily obtained by calling dataFun (Inherited from Binding.)
Protected method | DumpMsg(Boolean, Msg, Byte , Int32, Int32) | Conditionally dumps message to disk (Inherited from Binding.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetClientCallStatTimeKey | Extracts necessary information from client:request pair that characterizes the particular call for the purpose of call timing (Inherited from Binding.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | MakeNewClientTransport | (Overrides Binding MakeNewClientTransport(ClientEndPoint).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OpenServerEndpoint | (Overrides Binding OpenServerEndpoint(ServerEndPoint).)
Protected method | ReleaseClientTransportAfterCall | Releases a transport instance that was acquired for call. The implementation may return this instance back to the pool of available transports or deallocate it. The default implementation releases the instance back to the pool (Inherited from Binding.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
 | socketRead |
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
 | ToIPEndPoint |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | TryGetExistingAcquiredTransportPerRemoteNode | Tries to acquire an available client transport to make a call. This method respects binding/transport settings that impose a limit on the number of open concurrent transports and timeouts for acqusition waiting (Inherited from Binding.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | WriteLog | (Inherited from GlueComponentService.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | DEFAULT_PORT |
 | DEFAULT_RCV_TIMEOUT |
 | DEFAULT_SND_TIMEOUT |
 | KNOWN_SERIALIZER_TYPES |
Protected field | m_ClientTransportAllocatorLocks | Hash table of locks used during new transport allocation, must be prime size (Inherited from Binding.)
Protected field | m_Provider | (Inherited from Binding.)
Protected field | m_Transports | (Inherited from Binding.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ClientDump | Turns on/off client message dumping to disk. Turning on dumping has negative effect on performance and consumes resources (Inherited from Binding.)
Public property | ClientMsgInspectors | Returns client message inspectors for this instance (Inherited from Binding.)
Public property | ClientReceiveBufferSize |
Public property | ClientReceiveTimeout |
Public property | ClientSendBufferSize |
Public property | ClientSendTimeout |
Public property | ClientTransportCountWaitThreshold | Sets the threshold, expressed as the number of active client transports per remote address, below which binding will always allocate a new instance of client transport without trying/waiting to acquire an existing one. When this number is exceeded then binding will try to acquire an existing client transport instance for up to ClientTransportExistingAcquisitionTimeoutMs milliseconds. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ClientTransportExistingAcquisitionTimeoutMs | Sets the length of interval for the binding trying to acquire existing client transport instance to make a call. When this interval is exhausted then binding tries to allocate a new client transport per remote address, unless other limits prohibit (max transport count). The value has to be greater or equal to zero. NOTE: this property works in conjunction with ClientTransportCoutWaitThreshold, if the number of active client transports is below ClientTransportCoutWaitThreshold, then binding does not wait and allocates a new client transport right away until ClientTransportCoutWaitThreshold limit is reached, then binding will try to acquire existing transport for ClientTransportExistingAcquisitionTimeoutMs milliseconds. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ClientTransportIdleTimeoutMs | Specifies when client transports get auto-closed. Interval is measured in ms. Zero means indefinite/never closed transport. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ClientTransportMaxCount | Imposes a limit on number of active client transports per remote address. Once this limit is reached the binding will block until it can acquire an existing transport instance. Set value to zero to remove the limit. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ClientTransportMaxExistingAcquisitionTimeoutMs | Imposes a timeout for binding trying to get an existing transport instance per remote address. Binding throws ClientCallException when this timeout is exceeded. A value of zero removes the limit (Inherited from Binding.)
Public property | ClientTransports | Returns all client transports in the binding stack (Inherited from Binding.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | ConfigNode | Returns configuration node for this named instance (Inherited from Binding.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | DumpMsgFormat | Set the format for message dumping (Inherited from Binding.)
Public property | DumpPath | Set the path for message dumping. Must be an existing navigable path (Inherited from Binding.)
Public property | EncodingFormat | (Overrides Binding EncodingFormat.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | Glue | (Inherited from GlueComponentService.)
Public property | InstrumentationEnabled | Implements IInstrumentable (Inherited from GlueComponentService.)
Public property | InstrumentClientTransportStat | Defines whether client transport statistics is periodically dumped into instrumentation (Inherited from Binding.)
Public property | InstrumentServerTransportStat | Defines whether server transport statistics is periodically dumped into instrumentation (Inherited from Binding.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | MaxMsgSize | Imposes a limit on maximum message size in bytes
Public property | MeasureStatTimes | Defines whether message processing latency should be measured - i.e. messages time-stamped on arrival (Inherited from Binding.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | OperationFlow | Sync binding is synchronous by definition (Overrides Binding OperationFlow.)
Public property | Provider | (Inherited from Binding.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | ServerDump | Turns on/off server message dumping to disk. Turning on dumping has negative effect on performance and consumes resources (Inherited from Binding.)
Public property | ServerMsgInspectors | Returns server message inspectors for this instance (Inherited from Binding.)
Public property | ServerReceiveBufferSize |
Public property | ServerReceiveTimeout |
Public property | ServerSendBufferSize |
Public property | ServerSendTimeout |
Public property | ServerTransportIdleTimeoutMs | Specifies when server transports get auto-closed. Interval is measured in ms. Zero means indefinite/never closed transport. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ServerTransports | Returns all server transports in the binding stack (Inherited from Binding.)
Public property | StatTimesEMAFactor | Defines how much smoothing the timing statistics filter does - the lower the number the more smoothing is done. Smoothing makes stat times insensitive to some seldom delays that may happen every now and then (Inherited from Binding.)
Public property | StatTimeTicks | Returns current time in system frequency-dependent ticks. This property is used to measure accurate times and depends on MeasureStatTimes set to true, otherwise 0 is returned (Inherited from Binding.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | Transports | Returns all transports in the binding stack (Inherited from Binding.)
Back to Top
See Also
SyncBinding Class
NFX.Glue.Native Namespace


SyncBinding Constructor

SyncBinding Constructor NFX Class Library

Overload List
 | Name | Description
Public method | SyncBinding(String) | Initializes a new instance of the SyncBinding class
Public method | SyncBinding(IGlueImplementation, String) | Initializes a new instance of the SyncBinding class
Back to Top
See Also
SyncBinding Class
SyncBinding Members
NFX.Glue.Native Namespace


SyncBinding Constructor (String)

SyncBinding Constructor (String) NFX Class Library

Initializes a new instance of the SyncBinding class

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SyncBinding(
    string name
)
public SyncBinding(
    string name
)
Public Sub New (
    name As String
)
Public Sub New (
    name As String
)
public:
SyncBinding(
    String^ name
)
public:
SyncBinding(
    String^ name
)
new :
        name : string -> SyncBinding
new :
        name : string -> SyncBinding

Parameters

name
Type: Online System String
See Also
SyncBinding Class
SyncBinding Members
SyncBinding Overload
NFX.Glue.Native Namespace


SyncBinding Constructor (IGlueImplementation, String)

SyncBinding Constructor (IGlueImplementation, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SyncBinding class

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SyncBinding(
    IGlueImplementation glue,
    string name
)
public SyncBinding(
    IGlueImplementation glue,
    string name
)
Public Sub New (
    glue As IGlueImplementation,
    name As String
)
Public Sub New (
    glue As IGlueImplementation,
    name As String
)
public:
SyncBinding(
    IGlueImplementation^ glue,
    String^ name
)
public:
SyncBinding(
    IGlueImplementation^ glue,
    String^ name
)
new :
        glue : IGlueImplementation *
        name : string -> SyncBinding
new :
        glue : IGlueImplementation *
        name : string -> SyncBinding

Parameters

glue
Type: NFX.Glue IGlueImplementation
name
Type: Online System String
See Also
SyncBinding Class
SyncBinding Members
SyncBinding Overload
NFX.Glue.Native Namespace


SyncBinding Fields

SyncBinding Fields NFX Class Library

The SyncBinding type exposes the following members.
Fields
 | Name | Description
 | DEFAULT_PORT |
 | DEFAULT_RCV_TIMEOUT |
 | DEFAULT_SND_TIMEOUT |
 | KNOWN_SERIALIZER_TYPES |
Protected field | m_ClientTransportAllocatorLocks | Hash table of locks used during new transport allocation, must be prime size (Inherited from Binding.)
Protected field | m_Provider | (Inherited from Binding.)
Protected field | m_Transports | (Inherited from Binding.)
Back to Top
See Also
SyncBinding Class
NFX.Glue.Native Namespace


SyncBinding.DEFAULT_PORT Field

SyncBinding DEFAULT_PORT Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_PORT
public const int DEFAULT_PORT
Public Const DEFAULT_PORT As Integer
Public Const DEFAULT_PORT As Integer
public:
literal int DEFAULT_PORT
public:
literal int DEFAULT_PORT
static val mutable DEFAULT_PORT: int
static val mutable DEFAULT_PORT: int

Field Value

Type: Online Int32
See Also
SyncBinding Class
SyncBinding Members
NFX.Glue.Native Namespace


SyncBinding.DEFAULT_RCV_TIMEOUT Field

SyncBinding DEFAULT_RCV_TIMEOUT Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_RCV_TIMEOUT
public const int DEFAULT_RCV_TIMEOUT
Public Const DEFAULT_RCV_TIMEOUT As Integer
Public Const DEFAULT_RCV_TIMEOUT As Integer
public:
literal int DEFAULT_RCV_TIMEOUT
public:
literal int DEFAULT_RCV_TIMEOUT
static val mutable DEFAULT_RCV_TIMEOUT: int
static val mutable DEFAULT_RCV_TIMEOUT: int

Field Value

Type: Online Int32
See Also
SyncBinding Class
SyncBinding Members
NFX.Glue.Native Namespace


SyncBinding.DEFAULT_SND_TIMEOUT Field

SyncBinding DEFAULT_SND_TIMEOUT Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_SND_TIMEOUT
public const int DEFAULT_SND_TIMEOUT
Public Const DEFAULT_SND_TIMEOUT As Integer
Public Const DEFAULT_SND_TIMEOUT As Integer
public:
literal int DEFAULT_SND_TIMEOUT
public:
literal int DEFAULT_SND_TIMEOUT
static val mutable DEFAULT_SND_TIMEOUT: int
static val mutable DEFAULT_SND_TIMEOUT: int

Field Value

Type: Online Int32
See Also
SyncBinding Class
SyncBinding Members
NFX.Glue.Native Namespace


SyncBinding.KNOWN_SERIALIZER_TYPES Field

SyncBinding KNOWN_SERIALIZER_TYPES Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly TypeRegistry KNOWN_SERIALIZER_TYPES
public static readonly TypeRegistry KNOWN_SERIALIZER_TYPES
Public Shared ReadOnly KNOWN_SERIALIZER_TYPES As TypeRegistry
Public Shared ReadOnly KNOWN_SERIALIZER_TYPES As TypeRegistry
public:
static initonly TypeRegistry^ KNOWN_SERIALIZER_TYPES
public:
static initonly TypeRegistry^ KNOWN_SERIALIZER_TYPES
static val KNOWN_SERIALIZER_TYPES: TypeRegistry
static val KNOWN_SERIALIZER_TYPES: TypeRegistry

Field Value

Type: TypeRegistry
See Also
SyncBinding Class
SyncBinding Members
NFX.Glue.Native Namespace


SyncBinding Methods

SyncBinding Methods NFX Class Library

The SyncBinding type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | _Register | (Inherited from Binding.)
Protected method | _Unregister | (Inherited from Binding.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Protected method | AcquireClientTransportForCall | Returns an instance of transport suitable for a call. The implementation may return existing transport or allocate a new instance. The call is thread-safe (Inherited from Binding.)
Public method | AreNodesIdentical | (Overrides Binding AreNodesIdentical(Node, Node).)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and binding runtime are running or throws otherwise (Inherited from Binding.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Protected method | CloseServerEndpoint | (Overrides Binding CloseServerEndpoint(ServerEndPoint).)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | ConfigureAndStartNewClientTransport | Override to perform custom transport preparation and launch (Inherited from Binding.)
Protected method | Destructor | (Inherited from Binding.)
Public method | DispatchCall | Dispatches a call allocating new or re-using existing transport if needed. The strategy depends on particular Binding implementation. This call is thread-safe (Inherited from Binding.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | (Inherited from Binding.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Inherited from Binding.)
Protected method | DoSignalStop | (Inherited from Binding.)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Binding DoWaitForCompleteStop .)
Protected method | DumpMsg(Boolean, Msg, ArraySegment Byte ) | Conditionally dumps message to disk (Inherited from Binding.)
Protected method | DumpMsg(Boolean, Msg, Func ArraySegment Byte ) | Conditionally dumps message to disk where the data is lazily obtained by calling dataFun (Inherited from Binding.)
Protected method | DumpMsg(Boolean, Msg, Byte , Int32, Int32) | Conditionally dumps message to disk (Inherited from Binding.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetClientCallStatTimeKey | Extracts necessary information from client:request pair that characterizes the particular call for the purpose of call timing (Inherited from Binding.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | MakeNewClientTransport | (Overrides Binding MakeNewClientTransport(ClientEndPoint).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | OpenServerEndpoint | (Overrides Binding OpenServerEndpoint(ServerEndPoint).)
Protected method | ReleaseClientTransportAfterCall | Releases a transport instance that was acquired for call. The implementation may return this instance back to the pool of available transports or deallocate it. The default implementation releases the instance back to the pool (Inherited from Binding.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
 | socketRead |
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
 | ToIPEndPoint |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | TryGetExistingAcquiredTransportPerRemoteNode | Tries to acquire an available client transport to make a call. This method respects binding/transport settings that impose a limit on the number of open concurrent transports and timeouts for acqusition waiting (Inherited from Binding.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | WriteLog | (Inherited from GlueComponentService.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SyncBinding Class
NFX.Glue.Native Namespace


SyncBinding.AreNodesIdentical Method

SyncBinding AreNodesIdentical Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool AreNodesIdentical(
    Node left,
    Node right
)
public override bool AreNodesIdentical(
    Node left,
    Node right
)
Public Overrides Function AreNodesIdentical (
    left As Node,
    right As Node
) As Boolean
Public Overrides Function AreNodesIdentical (
    left As Node,
    right As Node
) As Boolean
public:
virtual bool AreNodesIdentical(
    Node left,
    Node right
) override
public:
virtual bool AreNodesIdentical(
    Node left,
    Node right
) override
abstract AreNodesIdentical :
        left : Node *
        right : Node -> bool
override AreNodesIdentical :
        left : Node *
        right : Node -> bool
abstract AreNodesIdentical :
        left : Node *
        right : Node -> bool
override AreNodesIdentical :
        left : Node *
        right : Node -> bool

Parameters

left
Type: NFX.Glue Node
right
Type: NFX.Glue Node

Return Value

Type: Online Boolean
See Also
SyncBinding Class
SyncBinding Members
NFX.Glue.Native Namespace


SyncBinding.CloseServerEndpoint Method

SyncBinding CloseServerEndpoint Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void CloseServerEndpoint(
    ServerEndPoint epoint
)
protected internal override void CloseServerEndpoint(
    ServerEndPoint epoint
)
Protected Friend Overrides Sub CloseServerEndpoint (
    epoint As ServerEndPoint
)
Protected Friend Overrides Sub CloseServerEndpoint (
    epoint As ServerEndPoint
)
protected public:
virtual void CloseServerEndpoint(
    ServerEndPoint^ epoint
) override
protected public:
virtual void CloseServerEndpoint(
    ServerEndPoint^ epoint
) override
abstract CloseServerEndpoint :
        epoint : ServerEndPoint -> unit
override CloseServerEndpoint :
        epoint : ServerEndPoint -> unit
abstract CloseServerEndpoint :
        epoint : ServerEndPoint -> unit
override CloseServerEndpoint :
        epoint : ServerEndPoint -> unit

Parameters

epoint
Type: NFX.Glue ServerEndPoint
See Also
SyncBinding Class
SyncBinding Members
NFX.Glue.Native Namespace


SyncBinding.DoStart Method

SyncBinding DoStart Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
SyncBinding Class
SyncBinding Members
NFX.Glue.Native Namespace


SyncBinding.DoWaitForCompleteStop Method

SyncBinding DoWaitForCompleteStop Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
SyncBinding Class
SyncBinding Members
NFX.Glue.Native Namespace


SyncBinding.MakeNewClientTransport Method

SyncBinding MakeNewClientTransport Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override ClientTransport MakeNewClientTransport(
    ClientEndPoint client
)
protected override ClientTransport MakeNewClientTransport(
    ClientEndPoint client
)
Protected Overrides Function MakeNewClientTransport (
    client As ClientEndPoint
) As ClientTransport
Protected Overrides Function MakeNewClientTransport (
    client As ClientEndPoint
) As ClientTransport
protected:
virtual ClientTransport^ MakeNewClientTransport(
    ClientEndPoint^ client
) override
protected:
virtual ClientTransport^ MakeNewClientTransport(
    ClientEndPoint^ client
) override
abstract MakeNewClientTransport :
        client : ClientEndPoint -> ClientTransport
override MakeNewClientTransport :
        client : ClientEndPoint -> ClientTransport
abstract MakeNewClientTransport :
        client : ClientEndPoint -> ClientTransport
override MakeNewClientTransport :
        client : ClientEndPoint -> ClientTransport

Parameters

client
Type: NFX.Glue ClientEndPoint

Return Value

Type: ClientTransport
See Also
SyncBinding Class
SyncBinding Members
NFX.Glue.Native Namespace


SyncBinding.OpenServerEndpoint Method

SyncBinding OpenServerEndpoint Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override ServerTransport OpenServerEndpoint(
    ServerEndPoint epoint
)
protected internal override ServerTransport OpenServerEndpoint(
    ServerEndPoint epoint
)
Protected Friend Overrides Function OpenServerEndpoint (
    epoint As ServerEndPoint
) As ServerTransport
Protected Friend Overrides Function OpenServerEndpoint (
    epoint As ServerEndPoint
) As ServerTransport
protected public:
virtual ServerTransport^ OpenServerEndpoint(
    ServerEndPoint^ epoint
) override
protected public:
virtual ServerTransport^ OpenServerEndpoint(
    ServerEndPoint^ epoint
) override
abstract OpenServerEndpoint :
        epoint : ServerEndPoint -> ServerTransport
override OpenServerEndpoint :
        epoint : ServerEndPoint -> ServerTransport
abstract OpenServerEndpoint :
        epoint : ServerEndPoint -> ServerTransport
override OpenServerEndpoint :
        epoint : ServerEndPoint -> ServerTransport

Parameters

epoint
Type: NFX.Glue ServerEndPoint

Return Value

Type: ServerTransport
See Also
SyncBinding Class
SyncBinding Members
NFX.Glue.Native Namespace


SyncBinding.socketRead Method

SyncBinding socketRead Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static void socketRead(
    NetworkStream nets,
    byte[] buffer,
    int offset,
    int total
)
internal static void socketRead(
    NetworkStream nets,
    byte[] buffer,
    int offset,
    int total
)
Friend Shared Sub socketRead (
    nets As NetworkStream,
    buffer As Byte(),
    offset As Integer,
    total As Integer
)
Friend Shared Sub socketRead (
    nets As NetworkStream,
    buffer As Byte(),
    offset As Integer,
    total As Integer
)
internal:
static void socketRead(
    NetworkStream^ nets,
    array<unsigned char>^ buffer,
    int offset,
    int total
)
internal:
static void socketRead(
    NetworkStream^ nets,
    array<unsigned char>^ buffer,
    int offset,
    int total
)
internal static member socketRead :
        nets : NetworkStream *
        buffer : byte[] *
        offset : int *
        total : int -> unit
internal static member socketRead :
        nets : NetworkStream *
        buffer : byte[] *
        offset : int *
        total : int -> unit

Parameters

nets
Type: Online System.Net.Sockets NetworkStream
buffer
Type: Online System Byte
offset
Type: Online System Int32
total
Type: Online System Int32
See Also
SyncBinding Class
SyncBinding Members
NFX.Glue.Native Namespace


SyncBinding.ToIPEndPoint Method

SyncBinding ToIPEndPoint Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static IPEndPoint ToIPEndPoint(
    Node node
)
internal static IPEndPoint ToIPEndPoint(
    Node node
)
Friend Shared Function ToIPEndPoint (
    node As Node
) As IPEndPoint
Friend Shared Function ToIPEndPoint (
    node As Node
) As IPEndPoint
internal:
static IPEndPoint^ ToIPEndPoint(
    Node node
)
internal:
static IPEndPoint^ ToIPEndPoint(
    Node node
)
internal static member ToIPEndPoint :
        node : Node -> IPEndPoint
internal static member ToIPEndPoint :
        node : Node -> IPEndPoint

Parameters

node
Type: NFX.Glue Node

Return Value

Type: Online IPEndPoint
See Also
SyncBinding Class
SyncBinding Members
NFX.Glue.Native Namespace


SyncBinding Properties

SyncBinding Properties NFX Class Library

The SyncBinding type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ClientDump | Turns on/off client message dumping to disk. Turning on dumping has negative effect on performance and consumes resources (Inherited from Binding.)
Public property | ClientMsgInspectors | Returns client message inspectors for this instance (Inherited from Binding.)
Public property | ClientReceiveBufferSize |
Public property | ClientReceiveTimeout |
Public property | ClientSendBufferSize |
Public property | ClientSendTimeout |
Public property | ClientTransportCountWaitThreshold | Sets the threshold, expressed as the number of active client transports per remote address, below which binding will always allocate a new instance of client transport without trying/waiting to acquire an existing one. When this number is exceeded then binding will try to acquire an existing client transport instance for up to ClientTransportExistingAcquisitionTimeoutMs milliseconds. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ClientTransportExistingAcquisitionTimeoutMs | Sets the length of interval for the binding trying to acquire existing client transport instance to make a call. When this interval is exhausted then binding tries to allocate a new client transport per remote address, unless other limits prohibit (max transport count). The value has to be greater or equal to zero. NOTE: this property works in conjunction with ClientTransportCoutWaitThreshold, if the number of active client transports is below ClientTransportCoutWaitThreshold, then binding does not wait and allocates a new client transport right away until ClientTransportCoutWaitThreshold limit is reached, then binding will try to acquire existing transport for ClientTransportExistingAcquisitionTimeoutMs milliseconds. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ClientTransportIdleTimeoutMs | Specifies when client transports get auto-closed. Interval is measured in ms. Zero means indefinite/never closed transport. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ClientTransportMaxCount | Imposes a limit on number of active client transports per remote address. Once this limit is reached the binding will block until it can acquire an existing transport instance. Set value to zero to remove the limit. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ClientTransportMaxExistingAcquisitionTimeoutMs | Imposes a timeout for binding trying to get an existing transport instance per remote address. Binding throws ClientCallException when this timeout is exceeded. A value of zero removes the limit (Inherited from Binding.)
Public property | ClientTransports | Returns all client transports in the binding stack (Inherited from Binding.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | ConfigNode | Returns configuration node for this named instance (Inherited from Binding.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | DumpMsgFormat | Set the format for message dumping (Inherited from Binding.)
Public property | DumpPath | Set the path for message dumping. Must be an existing navigable path (Inherited from Binding.)
Public property | EncodingFormat | (Overrides Binding EncodingFormat.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | Glue | (Inherited from GlueComponentService.)
Public property | InstrumentationEnabled | Implements IInstrumentable (Inherited from GlueComponentService.)
Public property | InstrumentClientTransportStat | Defines whether client transport statistics is periodically dumped into instrumentation (Inherited from Binding.)
Public property | InstrumentServerTransportStat | Defines whether server transport statistics is periodically dumped into instrumentation (Inherited from Binding.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | MaxMsgSize | Imposes a limit on maximum message size in bytes
Public property | MeasureStatTimes | Defines whether message processing latency should be measured - i.e. messages time-stamped on arrival (Inherited from Binding.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | OperationFlow | Sync binding is synchronous by definition (Overrides Binding OperationFlow.)
Public property | Provider | (Inherited from Binding.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | ServerDump | Turns on/off server message dumping to disk. Turning on dumping has negative effect on performance and consumes resources (Inherited from Binding.)
Public property | ServerMsgInspectors | Returns server message inspectors for this instance (Inherited from Binding.)
Public property | ServerReceiveBufferSize |
Public property | ServerReceiveTimeout |
Public property | ServerSendBufferSize |
Public property | ServerSendTimeout |
Public property | ServerTransportIdleTimeoutMs | Specifies when server transports get auto-closed. Interval is measured in ms. Zero means indefinite/never closed transport. For more info, see 'NFX.Glue: Client Call Concurrency' topic in manual/blog (Inherited from Binding.)
Public property | ServerTransports | Returns all server transports in the binding stack (Inherited from Binding.)
Public property | StatTimesEMAFactor | Defines how much smoothing the timing statistics filter does - the lower the number the more smoothing is done. Smoothing makes stat times insensitive to some seldom delays that may happen every now and then (Inherited from Binding.)
Public property | StatTimeTicks | Returns current time in system frequency-dependent ticks. This property is used to measure accurate times and depends on MeasureStatTimes set to true, otherwise 0 is returned (Inherited from Binding.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | Transports | Returns all transports in the binding stack (Inherited from Binding.)
Back to Top
See Also
SyncBinding Class
NFX.Glue.Native Namespace


SyncBinding.ClientReceiveBufferSize Property

SyncBinding ClientReceiveBufferSize Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("client-transport/$rcv-buf-size", 16384)]
public int ClientReceiveBufferSize { get; set; }
[ConfigAttribute("client-transport/$rcv-buf-size", 16384)]
public int ClientReceiveBufferSize { get; set; }
<ConfigAttribute("client-transport/$rcv-buf-size", 16384)>
Public Property ClientReceiveBufferSize As Integer
    Get
    Set
<ConfigAttribute("client-transport/$rcv-buf-size", 16384)>
Public Property ClientReceiveBufferSize As Integer
    Get
    Set
public:
[ConfigAttribute(L"client-transport/$rcv-buf-size", 16384)]
property int ClientReceiveBufferSize {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(L"client-transport/$rcv-buf-size", 16384)]
property int ClientReceiveBufferSize {
    int get ();
    void set (int value);
}
[<ConfigAttribute("client-transport/$rcv-buf-size", 16384)>]
member ClientReceiveBufferSize : int with get, set
[<ConfigAttribute("client-transport/$rcv-buf-size", 16384)>]
member ClientReceiveBufferSize : int with get, set

Property Value

Type: Online Int32
See Also
SyncBinding Class
SyncBinding Members
NFX.Glue.Native Namespace


SyncBinding.ClientReceiveTimeout Property

SyncBinding ClientReceiveTimeout Property NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("client-transport/$rcv-timeout", 0)]
public int ClientReceiveTimeout { get; set; }
[ConfigAttribute("client-transport/$rcv-timeout", 0)]
public int ClientReceiveTimeout { get; set; }
<ConfigAttribute("client-transport/$rcv-timeout", 0)>
Public Property ClientReceiveTimeout As Integer
    Get
    Set
<ConfigAttribute("client-transport/$rcv-timeout", 0)>
Public Property ClientReceiveTimeout As Integer
    Get
    Set
public:
[ConfigAttribute(L"client-transport/$rcv-timeout", 0)]
property int ClientReceiveTimeout {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(L"client-transport/$rcv-timeout", 0)]
property int ClientReceiveTimeout {
    int get ();
    void set (int value);
}
[<ConfigAttribute("client-transport/$rcv-timeout", 0)>]
member ClientReceiveTimeout : int with get, set
[<ConfigAttribute("client-transport/$rcv-timeout", 0)>]
member ClientReceiveTimeout : int with get, set

Property Value

Type: Online Int32
See Also
SyncBinding Class
SyncBinding Members
NFX.Glue.Native Namespace


SyncBinding.ClientSendBufferSize Property

SyncBinding ClientSendBufferSize Property NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("client-transport/$snd-buf-size", 16384)]
public int ClientSendBufferSize { get; set; }
[ConfigAttribute("client-transport/$snd-buf-size", 16384)]
public int ClientSendBufferSize { get; set; }
<ConfigAttribute("client-transport/$snd-buf-size", 16384)>
Public Property ClientSendBufferSize As Integer
    Get
    Set
<ConfigAttribute("client-transport/$snd-buf-size", 16384)>
Public Property ClientSendBufferSize As Integer
    Get
    Set
public:
[ConfigAttribute(L"client-transport/$snd-buf-size", 16384)]
property int ClientSendBufferSize {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(L"client-transport/$snd-buf-size", 16384)]
property int ClientSendBufferSize {
    int get ();
    void set (int value);
}
[<ConfigAttribute("client-transport/$snd-buf-size", 16384)>]
member ClientSendBufferSize : int with get, set
[<ConfigAttribute("client-transport/$snd-buf-size", 16384)>]
member ClientSendBufferSize : int with get, set

Property Value

Type: Online Int32
See Also
SyncBinding Class
SyncBinding Members
NFX.Glue.Native Namespace


SyncBinding.ClientSendTimeout Property

SyncBinding ClientSendTimeout Property NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("client-transport/$snd-timeout", 0)]
public int ClientSendTimeout { get; set; }
[ConfigAttribute("client-transport/$snd-timeout", 0)]
public int ClientSendTimeout { get; set; }
<ConfigAttribute("client-transport/$snd-timeout", 0)>
Public Property ClientSendTimeout As Integer
    Get
    Set
<ConfigAttribute("client-transport/$snd-timeout", 0)>
Public Property ClientSendTimeout As Integer
    Get
    Set
public:
[ConfigAttribute(L"client-transport/$snd-timeout", 0)]
property int ClientSendTimeout {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(L"client-transport/$snd-timeout", 0)]
property int ClientSendTimeout {
    int get ();
    void set (int value);
}
[<ConfigAttribute("client-transport/$snd-timeout", 0)>]
member ClientSendTimeout : int with get, set
[<ConfigAttribute("client-transport/$snd-timeout", 0)>]
member ClientSendTimeout : int with get, set

Property Value

Type: Online Int32
See Also
SyncBinding Class
SyncBinding Members
NFX.Glue.Native Namespace


SyncBinding.EncodingFormat Property

SyncBinding EncodingFormat Property NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string EncodingFormat { get; }
public override string EncodingFormat { get; }
Public Overrides ReadOnly Property EncodingFormat As String
    Get
Public Overrides ReadOnly Property EncodingFormat As String
    Get
public:
virtual property String^ EncodingFormat {
    String^ get () override;
}
public:
virtual property String^ EncodingFormat {
    String^ get () override;
}
abstract EncodingFormat : string with get
override EncodingFormat : string with get
abstract EncodingFormat : string with get
override EncodingFormat : string with get

Property Value

Type: Online String
See Also
SyncBinding Class
SyncBinding Members
NFX.Glue.Native Namespace


SyncBinding.MaxMsgSize Property

SyncBinding MaxMsgSize Property NFX Class Library

Imposes a limit on maximum message size in bytes

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$max-msg-size", 524288)]
public int MaxMsgSize { get; set; }
[ConfigAttribute("$max-msg-size", 524288)]
public int MaxMsgSize { get; set; }
<ConfigAttribute("$max-msg-size", 524288)>
Public Property MaxMsgSize As Integer
    Get
    Set
<ConfigAttribute("$max-msg-size", 524288)>
Public Property MaxMsgSize As Integer
    Get
    Set
public:
[ConfigAttribute(L"$max-msg-size", 524288)]
property int MaxMsgSize {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(L"$max-msg-size", 524288)]
property int MaxMsgSize {
    int get ();
    void set (int value);
}
[<ConfigAttribute("$max-msg-size", 524288)>]
member MaxMsgSize : int with get, set
[<ConfigAttribute("$max-msg-size", 524288)>]
member MaxMsgSize : int with get, set

Property Value

Type: Online Int32
See Also
SyncBinding Class
SyncBinding Members
NFX.Glue.Native Namespace


SyncBinding.OperationFlow Property

SyncBinding OperationFlow Property NFX Class Library

Sync binding is synchronous by definition

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override OperationFlow OperationFlow { get; }
public override OperationFlow OperationFlow { get; }
Public Overrides ReadOnly Property OperationFlow As OperationFlow
    Get
Public Overrides ReadOnly Property OperationFlow As OperationFlow
    Get
public:
virtual property OperationFlow OperationFlow {
    OperationFlow get () override;
}
public:
virtual property OperationFlow OperationFlow {
    OperationFlow get () override;
}
abstract OperationFlow : OperationFlow with get
override OperationFlow : OperationFlow with get
abstract OperationFlow : OperationFlow with get
override OperationFlow : OperationFlow with get

Property Value

Type: OperationFlow
See Also
SyncBinding Class
SyncBinding Members
NFX.Glue.Native Namespace


SyncBinding.ServerReceiveBufferSize Property

SyncBinding ServerReceiveBufferSize Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("server-transport/$rcv-buf-size", 16384)]
public int ServerReceiveBufferSize { get; set; }
[ConfigAttribute("server-transport/$rcv-buf-size", 16384)]
public int ServerReceiveBufferSize { get; set; }
<ConfigAttribute("server-transport/$rcv-buf-size", 16384)>
Public Property ServerReceiveBufferSize As Integer
    Get
    Set
<ConfigAttribute("server-transport/$rcv-buf-size", 16384)>
Public Property ServerReceiveBufferSize As Integer
    Get
    Set
public:
[ConfigAttribute(L"server-transport/$rcv-buf-size", 16384)]
property int ServerReceiveBufferSize {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(L"server-transport/$rcv-buf-size", 16384)]
property int ServerReceiveBufferSize {
    int get ();
    void set (int value);
}
[<ConfigAttribute("server-transport/$rcv-buf-size", 16384)>]
member ServerReceiveBufferSize : int with get, set
[<ConfigAttribute("server-transport/$rcv-buf-size", 16384)>]
member ServerReceiveBufferSize : int with get, set

Property Value

Type: Online Int32
See Also
SyncBinding Class
SyncBinding Members
NFX.Glue.Native Namespace


SyncBinding.ServerReceiveTimeout Property

SyncBinding ServerReceiveTimeout Property NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("server-transport/$rcv-timeout", 0)]
public int ServerReceiveTimeout { get; set; }
[ConfigAttribute("server-transport/$rcv-timeout", 0)]
public int ServerReceiveTimeout { get; set; }
<ConfigAttribute("server-transport/$rcv-timeout", 0)>
Public Property ServerReceiveTimeout As Integer
    Get
    Set
<ConfigAttribute("server-transport/$rcv-timeout", 0)>
Public Property ServerReceiveTimeout As Integer
    Get
    Set
public:
[ConfigAttribute(L"server-transport/$rcv-timeout", 0)]
property int ServerReceiveTimeout {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(L"server-transport/$rcv-timeout", 0)]
property int ServerReceiveTimeout {
    int get ();
    void set (int value);
}
[<ConfigAttribute("server-transport/$rcv-timeout", 0)>]
member ServerReceiveTimeout : int with get, set
[<ConfigAttribute("server-transport/$rcv-timeout", 0)>]
member ServerReceiveTimeout : int with get, set

Property Value

Type: Online Int32
See Also
SyncBinding Class
SyncBinding Members
NFX.Glue.Native Namespace


SyncBinding.ServerSendBufferSize Property

SyncBinding ServerSendBufferSize Property NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("server-transport/$snd-buf-size", 16384)]
public int ServerSendBufferSize { get; set; }
[ConfigAttribute("server-transport/$snd-buf-size", 16384)]
public int ServerSendBufferSize { get; set; }
<ConfigAttribute("server-transport/$snd-buf-size", 16384)>
Public Property ServerSendBufferSize As Integer
    Get
    Set
<ConfigAttribute("server-transport/$snd-buf-size", 16384)>
Public Property ServerSendBufferSize As Integer
    Get
    Set
public:
[ConfigAttribute(L"server-transport/$snd-buf-size", 16384)]
property int ServerSendBufferSize {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(L"server-transport/$snd-buf-size", 16384)]
property int ServerSendBufferSize {
    int get ();
    void set (int value);
}
[<ConfigAttribute("server-transport/$snd-buf-size", 16384)>]
member ServerSendBufferSize : int with get, set
[<ConfigAttribute("server-transport/$snd-buf-size", 16384)>]
member ServerSendBufferSize : int with get, set

Property Value

Type: Online Int32
See Also
SyncBinding Class
SyncBinding Members
NFX.Glue.Native Namespace


SyncBinding.ServerSendTimeout Property

SyncBinding ServerSendTimeout Property NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("server-transport/$snd-timeout", 0)]
public int ServerSendTimeout { get; set; }
[ConfigAttribute("server-transport/$snd-timeout", 0)]
public int ServerSendTimeout { get; set; }
<ConfigAttribute("server-transport/$snd-timeout", 0)>
Public Property ServerSendTimeout As Integer
    Get
    Set
<ConfigAttribute("server-transport/$snd-timeout", 0)>
Public Property ServerSendTimeout As Integer
    Get
    Set
public:
[ConfigAttribute(L"server-transport/$snd-timeout", 0)]
property int ServerSendTimeout {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(L"server-transport/$snd-timeout", 0)]
property int ServerSendTimeout {
    int get ();
    void set (int value);
}
[<ConfigAttribute("server-transport/$snd-timeout", 0)>]
member ServerSendTimeout : int with get, set
[<ConfigAttribute("server-transport/$snd-timeout", 0)>]
member ServerSendTimeout : int with get, set

Property Value

Type: Online Int32
See Also
SyncBinding Class
SyncBinding Members
NFX.Glue.Native Namespace


SyncClientTransport Class

SyncClientTransport Class NFX Class Library

Provides client-side functionality for synchronous communication pattern based on TCP blocking sockets and Slim serializer for maximum serialization performance and lowest latency. The SyncBinding is usable for interconnection between NFX-native components on LANs (i.e. server clusters) in scenarios when low latency is more important than total call invocation throughput
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service Binding
NFX.Glue Transport
NFX.Glue ClientTransport
NFX.Glue ClientTransport SyncBinding
NFX.Glue.Native SyncClientTransport

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SyncClientTransport : ClientTransport<SyncBinding>
public class SyncClientTransport : ClientTransport<SyncBinding>
Public Class SyncClientTransport
    Inherits ClientTransport(Of SyncBinding)
Public Class SyncClientTransport
    Inherits ClientTransport(Of SyncBinding)
public ref class SyncClientTransport : public ClientTransport<SyncBinding^>
public ref class SyncClientTransport : public ClientTransport<SyncBinding^>
type SyncClientTransport =
    class
        inherit ClientTransport<SyncBinding>
    end
type SyncClientTransport =
    class
        inherit ClientTransport<SyncBinding>
    end
See Also
SyncClientTransport Members
NFX.Glue.Native Namespace


SyncClientTransport Members

SyncClientTransport Members NFX Class Library

The SyncClientTransport type exposes the following members.
Constructors
 | Name | Description
Public method | SyncClientTransport | Initializes a new instance of the SyncClientTransport class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and transport instance are running or throws otherwise (Inherited from Transport.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Transport.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoDumpInstrumentationData | Override to dump instrumentation data, dont forget to call base to dump basic metrics (Inherited from Transport.)
Protected method | DoSendRequest | (Overrides ClientTransport DoSendRequest(ClientEndPoint, RequestMsg, CallOptions).)
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | (Overrides Transport DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | DumpInstrumentationData | Dumps instrumentation data (Inherited from Transport.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Release | Releases transport by setting Acquired flag to false so it can be used by other operations (Inherited from Transport.)
Public method | ResetStats | Resets all statistical counters (Inherited from Transport.)
Public method | SendRequest | Sends a client request into remote endpoint. This is a blocking call for bindings that are OperationFlow.Synchronous and result arrives immediately into CallSlot. (Inherited from ClientTransport.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Protected method | stat_BytesReceived | (Inherited from Transport.)
Protected method | stat_BytesSent | (Inherited from Transport.)
Protected method | stat_Errors | (Inherited from Transport.)
Protected method | stat_MsgReceived | (Inherited from Transport.)
Protected method | stat_MsgSent | (Inherited from Transport.)
Protected method | stat_Time | Processes named time measurement statistical sample by using EMA filter (Inherited from Transport.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryAcquire | A thread-safe operation that tries to acquire(reserve) this instance for exclusive use. Returns true if acqusition succeded, false is this instance is reserved by someone else (Inherited from Transport.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_TransportKind | (Inherited from Transport.)
Back to Top
Properties
 | Name | Description
Public property | Acquired | Returns true when this transport instance has been acquired by some operation and is busy (Inherited from Transport.)
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | Binding | (Inherited from ClientTransport TBinding .)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExpirationStart | Returns timestamp when manager touched the instance for last time and no traffic went through it since (Inherited from Transport.)
Public property | Glue | Returns glue implementation that this transport is under (Inherited from Transport.)
Public property | IdleAgeMs | Returns the duration of transport idle period in ms. (Inherited from Transport.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Node | Returns node that this transport services (Inherited from Transport.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | StatBytesReceived | Returns how many bytes were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatBytesSent | Returns how many bytes were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatErrors | Returns how many message processing errors happened since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgReceived | Returns how many messages were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgSent | Returns how many messages were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatTimes | Returns enumerable of named times measured in double second fractions. The returned times are EMA-filtered from supplied individual measurement samples (Inherited from Transport.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransportKind | Reports if this is a server or client transport (Inherited from Transport.)
Back to Top
See Also
SyncClientTransport Class
NFX.Glue.Native Namespace


SyncClientTransport Constructor

SyncClientTransport Constructor NFX Class Library

Initializes a new instance of the SyncClientTransport class

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SyncClientTransport(
    SyncBinding binding,
    Node node
)
public SyncClientTransport(
    SyncBinding binding,
    Node node
)
Public Sub New (
    binding As SyncBinding,
    node As Node
)
Public Sub New (
    binding As SyncBinding,
    node As Node
)
public:
SyncClientTransport(
    SyncBinding^ binding,
    Node node
)
public:
SyncClientTransport(
    SyncBinding^ binding,
    Node node
)
new :
        binding : SyncBinding *
        node : Node -> SyncClientTransport
new :
        binding : SyncBinding *
        node : Node -> SyncClientTransport

Parameters

binding
Type: NFX.Glue.Native SyncBinding
node
Type: NFX.Glue Node
See Also
SyncClientTransport Class
SyncClientTransport Members
NFX.Glue.Native Namespace


SyncClientTransport Fields

SyncClientTransport Fields NFX Class Library

The SyncClientTransport type exposes the following members.
Fields
 | Name | Description
Protected field | m_TransportKind | (Inherited from Transport.)
Back to Top
See Also
SyncClientTransport Class
NFX.Glue.Native Namespace


SyncClientTransport Methods

SyncClientTransport Methods NFX Class Library

The SyncClientTransport type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and transport instance are running or throws otherwise (Inherited from Transport.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Transport.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoDumpInstrumentationData | Override to dump instrumentation data, dont forget to call base to dump basic metrics (Inherited from Transport.)
Protected method | DoSendRequest | (Overrides ClientTransport DoSendRequest(ClientEndPoint, RequestMsg, CallOptions).)
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | (Overrides Transport DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | DumpInstrumentationData | Dumps instrumentation data (Inherited from Transport.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Release | Releases transport by setting Acquired flag to false so it can be used by other operations (Inherited from Transport.)
Public method | ResetStats | Resets all statistical counters (Inherited from Transport.)
Public method | SendRequest | Sends a client request into remote endpoint. This is a blocking call for bindings that are OperationFlow.Synchronous and result arrives immediately into CallSlot. (Inherited from ClientTransport.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Protected method | stat_BytesReceived | (Inherited from Transport.)
Protected method | stat_BytesSent | (Inherited from Transport.)
Protected method | stat_Errors | (Inherited from Transport.)
Protected method | stat_MsgReceived | (Inherited from Transport.)
Protected method | stat_MsgSent | (Inherited from Transport.)
Protected method | stat_Time | Processes named time measurement statistical sample by using EMA filter (Inherited from Transport.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryAcquire | A thread-safe operation that tries to acquire(reserve) this instance for exclusive use. Returns true if acqusition succeded, false is this instance is reserved by someone else (Inherited from Transport.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SyncClientTransport Class
NFX.Glue.Native Namespace


SyncClientTransport.DoSendRequest Method

SyncClientTransport DoSendRequest Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override CallSlot DoSendRequest(
    ClientEndPoint endpoint,
    RequestMsg request,
    CallOptions options
)
protected override CallSlot DoSendRequest(
    ClientEndPoint endpoint,
    RequestMsg request,
    CallOptions options
)
Protected Overrides Function DoSendRequest (
    endpoint As ClientEndPoint,
    request As RequestMsg,
    options As CallOptions
) As CallSlot
Protected Overrides Function DoSendRequest (
    endpoint As ClientEndPoint,
    request As RequestMsg,
    options As CallOptions
) As CallSlot
protected:
virtual CallSlot^ DoSendRequest(
    ClientEndPoint^ endpoint,
    RequestMsg^ request,
    CallOptions options
) override
protected:
virtual CallSlot^ DoSendRequest(
    ClientEndPoint^ endpoint,
    RequestMsg^ request,
    CallOptions options
) override
abstract DoSendRequest :
        endpoint : ClientEndPoint *
        request : RequestMsg *
        options : CallOptions -> CallSlot
override DoSendRequest :
        endpoint : ClientEndPoint *
        request : RequestMsg *
        options : CallOptions -> CallSlot
abstract DoSendRequest :
        endpoint : ClientEndPoint *
        request : RequestMsg *
        options : CallOptions -> CallSlot
override DoSendRequest :
        endpoint : ClientEndPoint *
        request : RequestMsg *
        options : CallOptions -> CallSlot

Parameters

endpoint
Type: NFX.Glue ClientEndPoint
request
Type: NFX.Glue.Protocol RequestMsg
options
Type: NFX.Glue.Protocol CallOptions

Return Value

Type: CallSlot
See Also
SyncClientTransport Class
SyncClientTransport Members
NFX.Glue.Native Namespace


SyncClientTransport.DoSignalStop Method

SyncClientTransport DoSignalStop Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSignalStop()
protected override void DoSignalStop()
Protected Overrides Sub DoSignalStop
Protected Overrides Sub DoSignalStop
protected:
virtual void DoSignalStop() override
protected:
virtual void DoSignalStop() override
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
See Also
SyncClientTransport Class
SyncClientTransport Members
NFX.Glue.Native Namespace


SyncClientTransport.DoStart Method

SyncClientTransport DoStart Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
SyncClientTransport Class
SyncClientTransport Members
NFX.Glue.Native Namespace


SyncClientTransport.DoWaitForCompleteStop Method

SyncClientTransport DoWaitForCompleteStop Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
SyncClientTransport Class
SyncClientTransport Members
NFX.Glue.Native Namespace


SyncClientTransport Properties

SyncClientTransport Properties NFX Class Library

The SyncClientTransport type exposes the following members.
Properties
 | Name | Description
Public property | Acquired | Returns true when this transport instance has been acquired by some operation and is busy (Inherited from Transport.)
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | Binding | (Inherited from ClientTransport TBinding .)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExpirationStart | Returns timestamp when manager touched the instance for last time and no traffic went through it since (Inherited from Transport.)
Public property | Glue | Returns glue implementation that this transport is under (Inherited from Transport.)
Public property | IdleAgeMs | Returns the duration of transport idle period in ms. (Inherited from Transport.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Node | Returns node that this transport services (Inherited from Transport.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | StatBytesReceived | Returns how many bytes were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatBytesSent | Returns how many bytes were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatErrors | Returns how many message processing errors happened since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgReceived | Returns how many messages were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgSent | Returns how many messages were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatTimes | Returns enumerable of named times measured in double second fractions. The returned times are EMA-filtered from supplied individual measurement samples (Inherited from Transport.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransportKind | Reports if this is a server or client transport (Inherited from Transport.)
Back to Top
See Also
SyncClientTransport Class
NFX.Glue.Native Namespace


SyncServerTransport Class

SyncServerTransport Class NFX Class Library

Provides server-side functionality for synchronous communication pattern based on TCP blocking sockets and Slim serializer for maximum serialization performance and lowest latency. The SyncBinding is usable for interconnection between NFX-native components on LANs (i.e. server clusters) in scenarios when low latency is more important than total call invocation throughput. SyncServerTransport uses dedicated thread for request processing and is not scalable beyond a few hundred connections by design, however it provides low latency benefit
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service Binding
NFX.Glue Transport
NFX.Glue ServerTransport
NFX.Glue ServerTransport SyncBinding
NFX.Glue.Native SyncServerTransport

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SyncServerTransport : ServerTransport<SyncBinding>
public class SyncServerTransport : ServerTransport<SyncBinding>
Public Class SyncServerTransport
    Inherits ServerTransport(Of SyncBinding)
Public Class SyncServerTransport
    Inherits ServerTransport(Of SyncBinding)
public ref class SyncServerTransport : public ServerTransport<SyncBinding^>
public ref class SyncServerTransport : public ServerTransport<SyncBinding^>
type SyncServerTransport =
    class
        inherit ServerTransport<SyncBinding>
    end
type SyncServerTransport =
    class
        inherit ServerTransport<SyncBinding>
    end
See Also
SyncServerTransport Members
NFX.Glue.Native Namespace


SyncServerTransport Members

SyncServerTransport Members NFX Class Library

The SyncServerTransport type exposes the following members.
Constructors
 | Name | Description
Public method | SyncServerTransport | Allocates a listener transport
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and transport instance are running or throws otherwise (Inherited from Transport.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Transport.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoDumpInstrumentationData | (Overrides Transport DoDumpInstrumentationData .)
Protected method | DoSendResponse | (Overrides ServerTransport DoSendResponse(ResponseMsg).)
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | (Overrides Transport DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | DumpInstrumentationData | Dumps instrumentation data (Inherited from Transport.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Release | Releases transport by setting Acquired flag to false so it can be used by other operations (Inherited from Transport.)
Public method | ResetStats | Resets all statistical counters (Inherited from Transport.)
Public method | SendResponse | Sends a response into remote client endpoint (Inherited from ServerTransport.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Protected method | stat_BytesReceived | (Inherited from Transport.)
Protected method | stat_BytesSent | (Inherited from Transport.)
Protected method | stat_Errors | (Inherited from Transport.)
Protected method | stat_MsgReceived | (Inherited from Transport.)
Protected method | stat_MsgSent | (Inherited from Transport.)
Protected method | stat_Time | Processes named time measurement statistical sample by using EMA filter (Inherited from Transport.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryAcquire | A thread-safe operation that tries to acquire(reserve) this instance for exclusive use. Returns true if acqusition succeded, false is this instance is reserved by someone else (Inherited from Transport.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_TransportKind | (Inherited from Transport.)
 | THREAD_NAME |
Back to Top
Properties
 | Name | Description
Public property | Acquired | Returns true when this transport instance has been acquired by some operation and is busy (Inherited from Transport.)
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | Binding | (Inherited from ServerTransport TBinding .)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExpirationStart | Returns timestamp when manager touched the instance for last time and no traffic went through it since (Inherited from Transport.)
Public property | Glue | Returns glue implementation that this transport is under (Inherited from Transport.)
Public property | IdleAgeMs | Returns the duration of transport idle period in ms. (Inherited from Transport.)
Public property | IsListener | Indicates whether this instance is the one that accepts connections. Depending on implementation listeners may allocate other transports after they accept incoming connect request (i.e. TCP) (Inherited from ServerTransport.)
Public property | Listener | Returns a listener transport that opened this one. If this is a listener transport then returns null. Not all technologies support listener/child transports (TCP does) (Inherited from ServerTransport.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Node | Returns node that this transport services (Inherited from Transport.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | ServerEndpoint | Returns server endpoint instance that opened this transport (Inherited from ServerTransport.)
Public property | StatBytesReceived | Returns how many bytes were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatBytesSent | Returns how many bytes were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatErrors | Returns how many message processing errors happened since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgReceived | Returns how many messages were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgSent | Returns how many messages were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatTimes | Returns enumerable of named times measured in double second fractions. The returned times are EMA-filtered from supplied individual measurement samples (Inherited from Transport.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransportKind | Reports if this is a server or client transport (Inherited from Transport.)
Back to Top
See Also
SyncServerTransport Class
NFX.Glue.Native Namespace


SyncServerTransport Constructor

SyncServerTransport Constructor NFX Class Library

Allocates a listener transport

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SyncServerTransport(
    SyncBinding binding,
    ServerEndPoint serverEndpoint,
    IPAddress localAddr,
    int port
)
public SyncServerTransport(
    SyncBinding binding,
    ServerEndPoint serverEndpoint,
    IPAddress localAddr,
    int port
)
Public Sub New (
    binding As SyncBinding,
    serverEndpoint As ServerEndPoint,
    localAddr As IPAddress,
    port As Integer
)
Public Sub New (
    binding As SyncBinding,
    serverEndpoint As ServerEndPoint,
    localAddr As IPAddress,
    port As Integer
)
public:
SyncServerTransport(
    SyncBinding^ binding,
    ServerEndPoint^ serverEndpoint,
    IPAddress^ localAddr,
    int port
)
public:
SyncServerTransport(
    SyncBinding^ binding,
    ServerEndPoint^ serverEndpoint,
    IPAddress^ localAddr,
    int port
)
new :
        binding : SyncBinding *
        serverEndpoint : ServerEndPoint *
        localAddr : IPAddress *
        port : int -> SyncServerTransport
new :
        binding : SyncBinding *
        serverEndpoint : ServerEndPoint *
        localAddr : IPAddress *
        port : int -> SyncServerTransport

Parameters

binding
Type: NFX.Glue.Native SyncBinding
serverEndpoint
Type: NFX.Glue ServerEndPoint
localAddr
Type: Online System.Net IPAddress
port
Type: Online System Int32
See Also
SyncServerTransport Class
SyncServerTransport Members
NFX.Glue.Native Namespace


SyncServerTransport Fields

SyncServerTransport Fields NFX Class Library

The SyncServerTransport type exposes the following members.
Fields
 | Name | Description
Protected field | m_TransportKind | (Inherited from Transport.)
 | THREAD_NAME |
Back to Top
See Also
SyncServerTransport Class
NFX.Glue.Native Namespace


SyncServerTransport.THREAD_NAME Field

SyncServerTransport THREAD_NAME Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string THREAD_NAME
public const string THREAD_NAME
Public Const THREAD_NAME As String
Public Const THREAD_NAME As String
public:
literal String^ THREAD_NAME
public:
literal String^ THREAD_NAME
static val mutable THREAD_NAME: string
static val mutable THREAD_NAME: string

Field Value

Type: Online String
See Also
SyncServerTransport Class
SyncServerTransport Members
NFX.Glue.Native Namespace


SyncServerTransport Methods

SyncServerTransport Methods NFX Class Library

The SyncServerTransport type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Public method | CheckRunningState | Ensures that application and transport instance are running or throws otherwise (Inherited from Transport.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Transport.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoDumpInstrumentationData | (Overrides Transport DoDumpInstrumentationData .)
Protected method | DoSendResponse | (Overrides ServerTransport DoSendResponse(ResponseMsg).)
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | (Overrides Transport DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | DumpInstrumentationData | Dumps instrumentation data (Inherited from Transport.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Release | Releases transport by setting Acquired flag to false so it can be used by other operations (Inherited from Transport.)
Public method | ResetStats | Resets all statistical counters (Inherited from Transport.)
Public method | SendResponse | Sends a response into remote client endpoint (Inherited from ServerTransport.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Protected method | stat_BytesReceived | (Inherited from Transport.)
Protected method | stat_BytesSent | (Inherited from Transport.)
Protected method | stat_Errors | (Inherited from Transport.)
Protected method | stat_MsgReceived | (Inherited from Transport.)
Protected method | stat_MsgSent | (Inherited from Transport.)
Protected method | stat_Time | Processes named time measurement statistical sample by using EMA filter (Inherited from Transport.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryAcquire | A thread-safe operation that tries to acquire(reserve) this instance for exclusive use. Returns true if acqusition succeded, false is this instance is reserved by someone else (Inherited from Transport.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SyncServerTransport Class
NFX.Glue.Native Namespace


SyncServerTransport.DoDumpInstrumentationData Method

SyncServerTransport DoDumpInstrumentationData Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoDumpInstrumentationData()
protected override void DoDumpInstrumentationData()
Protected Overrides Sub DoDumpInstrumentationData
Protected Overrides Sub DoDumpInstrumentationData
protected:
virtual void DoDumpInstrumentationData() override
protected:
virtual void DoDumpInstrumentationData() override
abstract DoDumpInstrumentationData : unit -> unit
override DoDumpInstrumentationData : unit -> unit
abstract DoDumpInstrumentationData : unit -> unit
override DoDumpInstrumentationData : unit -> unit
See Also
SyncServerTransport Class
SyncServerTransport Members
NFX.Glue.Native Namespace


SyncServerTransport.DoSendResponse Method

SyncServerTransport DoSendResponse Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool DoSendResponse(
    ResponseMsg response
)
protected override bool DoSendResponse(
    ResponseMsg response
)
Protected Overrides Function DoSendResponse (
    response As ResponseMsg
) As Boolean
Protected Overrides Function DoSendResponse (
    response As ResponseMsg
) As Boolean
protected:
virtual bool DoSendResponse(
    ResponseMsg^ response
) override
protected:
virtual bool DoSendResponse(
    ResponseMsg^ response
) override
abstract DoSendResponse :
        response : ResponseMsg -> bool
override DoSendResponse :
        response : ResponseMsg -> bool
abstract DoSendResponse :
        response : ResponseMsg -> bool
override DoSendResponse :
        response : ResponseMsg -> bool

Parameters

response
Type: NFX.Glue.Protocol ResponseMsg

Return Value

Type: Online Boolean
See Also
SyncServerTransport Class
SyncServerTransport Members
NFX.Glue.Native Namespace


SyncServerTransport.DoSignalStop Method

SyncServerTransport DoSignalStop Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSignalStop()
protected override void DoSignalStop()
Protected Overrides Sub DoSignalStop
Protected Overrides Sub DoSignalStop
protected:
virtual void DoSignalStop() override
protected:
virtual void DoSignalStop() override
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
See Also
SyncServerTransport Class
SyncServerTransport Members
NFX.Glue.Native Namespace


SyncServerTransport.DoStart Method

SyncServerTransport DoStart Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
SyncServerTransport Class
SyncServerTransport Members
NFX.Glue.Native Namespace


SyncServerTransport.DoWaitForCompleteStop Method

SyncServerTransport DoWaitForCompleteStop Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
SyncServerTransport Class
SyncServerTransport Members
NFX.Glue.Native Namespace


SyncServerTransport Properties

SyncServerTransport Properties NFX Class Library

The SyncServerTransport type exposes the following members.
Properties
 | Name | Description
Public property | Acquired | Returns true when this transport instance has been acquired by some operation and is busy (Inherited from Transport.)
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | Binding | (Inherited from ServerTransport TBinding .)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExpirationStart | Returns timestamp when manager touched the instance for last time and no traffic went through it since (Inherited from Transport.)
Public property | Glue | Returns glue implementation that this transport is under (Inherited from Transport.)
Public property | IdleAgeMs | Returns the duration of transport idle period in ms. (Inherited from Transport.)
Public property | IsListener | Indicates whether this instance is the one that accepts connections. Depending on implementation listeners may allocate other transports after they accept incoming connect request (i.e. TCP) (Inherited from ServerTransport.)
Public property | Listener | Returns a listener transport that opened this one. If this is a listener transport then returns null. Not all technologies support listener/child transports (TCP does) (Inherited from ServerTransport.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Node | Returns node that this transport services (Inherited from Transport.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | ServerEndpoint | Returns server endpoint instance that opened this transport (Inherited from ServerTransport.)
Public property | StatBytesReceived | Returns how many bytes were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatBytesSent | Returns how many bytes were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatErrors | Returns how many message processing errors happened since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgReceived | Returns how many messages were received since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatMsgSent | Returns how many messages were sent since .ctor or last ResetStats() call (Inherited from Transport.)
Public property | StatTimes | Returns enumerable of named times measured in double second fractions. The returned times are EMA-filtered from supplied individual measurement samples (Inherited from Transport.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | TransportKind | Reports if this is a server or client transport (Inherited from Transport.)
Back to Top
See Also
SyncServerTransport Class
NFX.Glue.Native Namespace


WireFrame Structure

WireFrame Structure NFX Class Library

This struct defines a frame transmitted as a part of WireMsg which can be used for transport or session management needs

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct WireFrame
public struct WireFrame
Public Structure WireFrame
Public Structure WireFrame
public value class WireFrame
public value class WireFrame
[<SealedAttribute>]
type WireFrame =  struct end
[<SealedAttribute>]
type WireFrame =  struct end
Remarks
Frame Content: ----------------------------------------- MAGIC ushort 2 byte - 0xABBA VESRION byte 1 byte TYPE {G|H|E|R|D} 1 byte FORMAT int32BE 4 bytes ONEWAY {0|!0} 1 byte REQID FID 8 bytes HDRSLEN int32BE 4 bytes ------------ 21 bytes HDRSCONTENT utf8_char[x] HDRSLEN bytes ----------------------------------------- 21 + HDRSLEN bytes total size
See Also
WireFrame Members
NFX.Glue.Native Namespace


WireFrame Members

WireFrame Members NFX Class Library

The WireFrame type exposes the following members.
Constructors
 | Name | Description
Public method | WireFrame(Stream) | Reconstruct (deserializes) frame from the stream. May throw on error
Public method | WireFrame(Int32, Boolean, FID, String) | Initializes a new instance of the WireFrame class
Public method | WireFrame(FrameType, Int32, Boolean, FID, String) | Initializes a new instance of the WireFrame class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Serialize | Serialize the frame to the given stream returning the byte size of the frame
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
FID_LENGTH |
FRAME_LENGTH |
HEADERS_ENCODING |
MAGIC |
MAX_HEADERS_BYTE_LENGTH |
SLIM_FORMAT |
VERSION |
Back to Top
Properties
 | Name | Description
Public property | Format | Format used for payload encoding, use FORMAT_SLIM as a default constant
Public property | Headers | Optional frame headers parsed from XML HeadersContent
Public property | HeadersContent | Optional frame headers content - an unparsed XML string
Public property | Length | The total byte size of the frame that includes the length of headers (if any)
Public property | OneWay | True if the requesting party does not expect a response
Public property | RequestID | RequestID of the request in following message or echo response message
Public property | Type | Returns type of this frame
Back to Top
See Also
WireFrame Structure
NFX.Glue.Native Namespace


WireFrame Constructor

WireFrame Constructor NFX Class Library

Overload List
 | Name | Description
Public method | WireFrame(Stream) | Reconstruct (deserializes) frame from the stream. May throw on error
Public method | WireFrame(Int32, Boolean, FID, String) | Initializes a new instance of the WireFrame class
Public method | WireFrame(FrameType, Int32, Boolean, FID, String) | Initializes a new instance of the WireFrame class
Back to Top
See Also
WireFrame Structure
WireFrame Members
NFX.Glue.Native Namespace


WireFrame Constructor (Stream)

WireFrame Constructor (Stream) NFX Class Library

Reconstruct (deserializes) frame from the stream. May throw on error

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WireFrame(
    Stream stream
)
public WireFrame(
    Stream stream
)
Public Sub New (
    stream As Stream
)
Public Sub New (
    stream As Stream
)
public:
WireFrame(
    Stream^ stream
)
public:
WireFrame(
    Stream^ stream
)
new :
        stream : Stream -> WireFrame
new :
        stream : Stream -> WireFrame

Parameters

stream
Type: Online System.IO Stream
See Also
WireFrame Structure
WireFrame Members
WireFrame Overload
NFX.Glue.Native Namespace


WireFrame Constructor (Int32, Boolean, FID, String)

WireFrame Constructor (Int32, Boolean, FID, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the WireFrame class

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WireFrame(
    int format,
    bool oneWay,
    FID reqID,
    string headersContent = null
)
public WireFrame(
    int format,
    bool oneWay,
    FID reqID,
    string headersContent = null
)
Public Sub New (
    format As Integer,
    oneWay As Boolean,
    reqID As FID,
    Optional headersContent As String = Nothing
)
Public Sub New (
    format As Integer,
    oneWay As Boolean,
    reqID As FID,
    Optional headersContent As String = Nothing
)
public:
WireFrame(
    int format,
    bool oneWay,
    FID reqID,
    String^ headersContent = nullptr
)
public:
WireFrame(
    int format,
    bool oneWay,
    FID reqID,
    String^ headersContent = nullptr
)
new :
        format : int *
        oneWay : bool *
        reqID : FID *
        ?headersContent : string
(* Defaults:
        let _headersContent = defaultArg headersContent null
*)
-> WireFrame
new :
        format : int *
        oneWay : bool *
        reqID : FID *
        ?headersContent : string
(* Defaults:
        let _headersContent = defaultArg headersContent null
*)
-> WireFrame

Parameters

format
Type: Online System Int32
oneWay
Type: Online System Boolean
reqID
Type: NFX FID
headersContent (Optional)
Type: Online System String
See Also
WireFrame Structure
WireFrame Members
WireFrame Overload
NFX.Glue.Native Namespace


WireFrame Constructor (FrameType, Int32, Boolean, FID, String)

WireFrame Constructor (FrameType, Int32, Boolean, FID, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the WireFrame class

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WireFrame(
    FrameType type,
    int format,
    bool oneWay,
    FID reqID,
    string headersContent = null
)
public WireFrame(
    FrameType type,
    int format,
    bool oneWay,
    FID reqID,
    string headersContent = null
)
Public Sub New (
    type As FrameType,
    format As Integer,
    oneWay As Boolean,
    reqID As FID,
    Optional headersContent As String = Nothing
)
Public Sub New (
    type As FrameType,
    format As Integer,
    oneWay As Boolean,
    reqID As FID,
    Optional headersContent As String = Nothing
)
public:
WireFrame(
    FrameType type,
    int format,
    bool oneWay,
    FID reqID,
    String^ headersContent = nullptr
)
public:
WireFrame(
    FrameType type,
    int format,
    bool oneWay,
    FID reqID,
    String^ headersContent = nullptr
)
new :
        type : FrameType *
        format : int *
        oneWay : bool *
        reqID : FID *
        ?headersContent : string
(* Defaults:
        let _headersContent = defaultArg headersContent null
*)
-> WireFrame
new :
        type : FrameType *
        format : int *
        oneWay : bool *
        reqID : FID *
        ?headersContent : string
(* Defaults:
        let _headersContent = defaultArg headersContent null
*)
-> WireFrame

Parameters

type
Type: NFX.Glue.Native FrameType
format
Type: Online System Int32
oneWay
Type: Online System Boolean
reqID
Type: NFX FID
headersContent (Optional)
Type: Online System String
See Also
WireFrame Structure
WireFrame Members
WireFrame Overload
NFX.Glue.Native Namespace


WireFrame Fields

WireFrame Fields NFX Class Library

The WireFrame type exposes the following members.
Fields
Name | Description
FID_LENGTH |
FRAME_LENGTH |
HEADERS_ENCODING |
MAGIC |
MAX_HEADERS_BYTE_LENGTH |
SLIM_FORMAT |
VERSION |
Back to Top
See Also
WireFrame Structure
NFX.Glue.Native Namespace


WireFrame.FID_LENGTH Field

WireFrame FID_LENGTH Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const byte FID_LENGTH
public const byte FID_LENGTH
Public Const FID_LENGTH As Byte
Public Const FID_LENGTH As Byte
public:
literal unsigned char FID_LENGTH
public:
literal unsigned char FID_LENGTH
static val mutable FID_LENGTH: byte
static val mutable FID_LENGTH: byte

Field Value

Type: Online Byte
See Also
WireFrame Structure
WireFrame Members
NFX.Glue.Native Namespace


WireFrame.FRAME_LENGTH Field

WireFrame FRAME_LENGTH Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const byte FRAME_LENGTH
public const byte FRAME_LENGTH
Public Const FRAME_LENGTH As Byte
Public Const FRAME_LENGTH As Byte
public:
literal unsigned char FRAME_LENGTH
public:
literal unsigned char FRAME_LENGTH
static val mutable FRAME_LENGTH: byte
static val mutable FRAME_LENGTH: byte

Field Value

Type: Online Byte
See Also
WireFrame Structure
WireFrame Members
NFX.Glue.Native Namespace


WireFrame.HEADERS_ENCODING Field

WireFrame HEADERS_ENCODING Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Encoding HEADERS_ENCODING
public static readonly Encoding HEADERS_ENCODING
Public Shared ReadOnly HEADERS_ENCODING As Encoding
Public Shared ReadOnly HEADERS_ENCODING As Encoding
public:
static initonly Encoding^ HEADERS_ENCODING
public:
static initonly Encoding^ HEADERS_ENCODING
static val HEADERS_ENCODING: Encoding
static val HEADERS_ENCODING: Encoding

Field Value

Type: Online Encoding
See Also
WireFrame Structure
WireFrame Members
NFX.Glue.Native Namespace


WireFrame.MAGIC Field

WireFrame MAGIC Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const ushort MAGIC
public const ushort MAGIC
Public Const MAGIC As UShort
Public Const MAGIC As UShort
public:
literal unsigned short MAGIC
public:
literal unsigned short MAGIC
static val mutable MAGIC: uint16
static val mutable MAGIC: uint16

Field Value

Type: Online UInt16
See Also
WireFrame Structure
WireFrame Members
NFX.Glue.Native Namespace


WireFrame.MAX_HEADERS_BYTE_LENGTH Field

WireFrame MAX_HEADERS_BYTE_LENGTH Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_HEADERS_BYTE_LENGTH
public const int MAX_HEADERS_BYTE_LENGTH
Public Const MAX_HEADERS_BYTE_LENGTH As Integer
Public Const MAX_HEADERS_BYTE_LENGTH As Integer
public:
literal int MAX_HEADERS_BYTE_LENGTH
public:
literal int MAX_HEADERS_BYTE_LENGTH
static val mutable MAX_HEADERS_BYTE_LENGTH: int
static val mutable MAX_HEADERS_BYTE_LENGTH: int

Field Value

Type: Online Int32
See Also
WireFrame Structure
WireFrame Members
NFX.Glue.Native Namespace


WireFrame.SLIM_FORMAT Field

WireFrame SLIM_FORMAT Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int SLIM_FORMAT
public const int SLIM_FORMAT
Public Const SLIM_FORMAT As Integer
Public Const SLIM_FORMAT As Integer
public:
literal int SLIM_FORMAT
public:
literal int SLIM_FORMAT
static val mutable SLIM_FORMAT: int
static val mutable SLIM_FORMAT: int

Field Value

Type: Online Int32
See Also
WireFrame Structure
WireFrame Members
NFX.Glue.Native Namespace


WireFrame.VERSION Field

WireFrame VERSION Field NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const byte VERSION
public const byte VERSION
Public Const VERSION As Byte
Public Const VERSION As Byte
public:
literal unsigned char VERSION
public:
literal unsigned char VERSION
static val mutable VERSION: byte
static val mutable VERSION: byte

Field Value

Type: Online Byte
See Also
WireFrame Structure
WireFrame Members
NFX.Glue.Native Namespace


WireFrame Methods

WireFrame Methods NFX Class Library

The WireFrame type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Serialize | Serialize the frame to the given stream returning the byte size of the frame
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WireFrame Structure
NFX.Glue.Native Namespace


WireFrame.Serialize Method

WireFrame Serialize Method NFX Class Library

Serialize the frame to the given stream returning the byte size of the frame

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Serialize(
    Stream stream
)
public int Serialize(
    Stream stream
)
Public Function Serialize (
    stream As Stream
) As Integer
Public Function Serialize (
    stream As Stream
) As Integer
public:
int Serialize(
    Stream^ stream
)
public:
int Serialize(
    Stream^ stream
)
member Serialize :
        stream : Stream -> int
member Serialize :
        stream : Stream -> int

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online Int32
See Also
WireFrame Structure
WireFrame Members
NFX.Glue.Native Namespace


WireFrame.ToString Method

WireFrame ToString Method NFX Class Library

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
WireFrame Structure
WireFrame Members
NFX.Glue.Native Namespace


WireFrame Properties

WireFrame Properties NFX Class Library

The WireFrame type exposes the following members.
Properties
 | Name | Description
Public property | Format | Format used for payload encoding, use FORMAT_SLIM as a default constant
Public property | Headers | Optional frame headers parsed from XML HeadersContent
Public property | HeadersContent | Optional frame headers content - an unparsed XML string
Public property | Length | The total byte size of the frame that includes the length of headers (if any)
Public property | OneWay | True if the requesting party does not expect a response
Public property | RequestID | RequestID of the request in following message or echo response message
Public property | Type | Returns type of this frame
Back to Top
See Also
WireFrame Structure
NFX.Glue.Native Namespace


WireFrame.Format Property

WireFrame Format Property NFX Class Library

Format used for payload encoding, use FORMAT_SLIM as a default constant

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Format { get; }
public int Format { get; }
Public ReadOnly Property Format As Integer
    Get
Public ReadOnly Property Format As Integer
    Get
public:
property int Format {
    int get ();
}
public:
property int Format {
    int get ();
}
member Format : int with get
member Format : int with get

Property Value

Type: Online Int32
See Also
WireFrame Structure
WireFrame Members
NFX.Glue.Native Namespace


WireFrame.Headers Property

WireFrame Headers Property NFX Class Library

Optional frame headers parsed from XML HeadersContent

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IConfigSectionNode Headers { get; }
public IConfigSectionNode Headers { get; }
Public ReadOnly Property Headers As IConfigSectionNode
    Get
Public ReadOnly Property Headers As IConfigSectionNode
    Get
public:
property IConfigSectionNode^ Headers {
    IConfigSectionNode^ get ();
}
public:
property IConfigSectionNode^ Headers {
    IConfigSectionNode^ get ();
}
member Headers : IConfigSectionNode with get
member Headers : IConfigSectionNode with get

Property Value

Type: IConfigSectionNode
See Also
WireFrame Structure
WireFrame Members
NFX.Glue.Native Namespace


WireFrame.HeadersContent Property

WireFrame HeadersContent Property NFX Class Library

Optional frame headers content - an unparsed XML string

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string HeadersContent { get; }
public string HeadersContent { get; }
Public ReadOnly Property HeadersContent As String
    Get
Public ReadOnly Property HeadersContent As String
    Get
public:
property String^ HeadersContent {
    String^ get ();
}
public:
property String^ HeadersContent {
    String^ get ();
}
member HeadersContent : string with get
member HeadersContent : string with get

Property Value

Type: Online String
See Also
WireFrame Structure
WireFrame Members
NFX.Glue.Native Namespace


WireFrame.Length Property

WireFrame Length Property NFX Class Library

The total byte size of the frame that includes the length of headers (if any)

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Length { get; }
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get
Public ReadOnly Property Length As Integer
    Get
public:
property int Length {
    int get ();
}
public:
property int Length {
    int get ();
}
member Length : int with get
member Length : int with get

Property Value

Type: Online Int32
See Also
WireFrame Structure
WireFrame Members
NFX.Glue.Native Namespace


WireFrame.OneWay Property

WireFrame OneWay Property NFX Class Library

True if the requesting party does not expect a response

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool OneWay { get; private set; }
public bool OneWay { get; private set; }
Public Property OneWay As Boolean
    Get
    Private Set
Public Property OneWay As Boolean
    Get
    Private Set
public:
property bool OneWay {
    bool get ();
    private: void set (bool value);
}
public:
property bool OneWay {
    bool get ();
    private: void set (bool value);
}
member OneWay : bool with get, private set
member OneWay : bool with get, private set

Property Value

Type: Online Boolean
See Also
WireFrame Structure
WireFrame Members
NFX.Glue.Native Namespace


WireFrame.RequestID Property

WireFrame RequestID Property NFX Class Library

RequestID of the request in following message or echo response message

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FID RequestID { get; private set; }
public FID RequestID { get; private set; }
Public Property RequestID As FID
    Get
    Private Set
Public Property RequestID As FID
    Get
    Private Set
public:
property FID RequestID {
    FID get ();
    private: void set (FID value);
}
public:
property FID RequestID {
    FID get ();
    private: void set (FID value);
}
member RequestID : FID with get, private set
member RequestID : FID with get, private set

Property Value

Type: FID
See Also
WireFrame Structure
WireFrame Members
NFX.Glue.Native Namespace


WireFrame.Type Property

WireFrame Type Property NFX Class Library

Returns type of this frame

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FrameType Type { get; }
public FrameType Type { get; }
Public ReadOnly Property Type As FrameType
    Get
Public ReadOnly Property Type As FrameType
    Get
public:
property FrameType Type {
    FrameType get ();
}
public:
property FrameType Type {
    FrameType get ();
}
member Type : FrameType with get
member Type : FrameType with get

Property Value

Type: FrameType
See Also
WireFrame Structure
WireFrame Members
NFX.Glue.Native Namespace


WireMsg Structure

WireMsg Structure NFX Class Library

Represents a message that is transmitted over the wire:

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct WireMsg
public struct WireMsg
Public Structure WireMsg
Public Structure WireMsg
public value class WireMsg
public value class WireMsg
[<SealedAttribute>]
type WireMsg =  struct end
[<SealedAttribute>]
type WireMsg =  struct end
Remarks
Wire Msg gets serialized like so: +----+ | +----------------------------------------------+---------+ | +-------+ |Size| | | Frame Content | Hdrs... | | | GlueM | +----+ | +----------------------------------------------+---------+ | +-------+ ^ \----------------------+---------------------------------/ ^ | | | | | +-- Msg data (payload) , i.e. Glue message body | +----------------------------- Transport Frame with optional var length headers +-------------------------------------------------------- Total msg size 4 bytes
See Also
WireMsg Members
NFX.Glue.Native Namespace


WireMsg Members

WireMsg Members NFX Class Library

The WireMsg type exposes the following members.
Constructors
 | Name | Description
Public method | WireMsg | Creates WireMsg around pre-filled memory chunk that includes msg size - first 4 bytes
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Public method | UpdateBufferStats | Update buffers statistics
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Data | Returns the data chunk received/sent from/to socket INCLUDING the total size (first 4 bytes BEint32)
Back to Top
Properties
 | Name | Description
Public property | Buffer | Returns data byte buffer
Public property | BufferUsedSize | Returns data byte buffer use count, i.w. the buffer may be physically larger, however only BufferUsedSize must be transmitted
Public property | Frame | Returns frame serialized in data
Back to Top
See Also
WireMsg Structure
NFX.Glue.Native Namespace


WireMsg Constructor

WireMsg Constructor NFX Class Library

Creates WireMsg around pre-filled memory chunk that includes msg size - first 4 bytes

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WireMsg(
    MemChunk data
)
public WireMsg(
    MemChunk data
)
Public Sub New (
    data As MemChunk
)
Public Sub New (
    data As MemChunk
)
public:
WireMsg(
    MemChunk^ data
)
public:
WireMsg(
    MemChunk^ data
)
new :
        data : MemChunk -> WireMsg
new :
        data : MemChunk -> WireMsg

Parameters

data
Type: NFX.Glue.Native MemChunk
See Also
WireMsg Structure
WireMsg Members
NFX.Glue.Native Namespace


WireMsg Fields

WireMsg Fields NFX Class Library

The WireMsg type exposes the following members.
Fields
 | Name | Description
Public field | Data | Returns the data chunk received/sent from/to socket INCLUDING the total size (first 4 bytes BEint32)
Back to Top
See Also
WireMsg Structure
NFX.Glue.Native Namespace


WireMsg.Data Field

WireMsg Data Field NFX Class Library

Returns the data chunk received/sent from/to socket INCLUDING the total size (first 4 bytes BEint32)

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly MemChunk Data
public readonly MemChunk Data
Public ReadOnly Data As MemChunk
Public ReadOnly Data As MemChunk
public:
initonly MemChunk^ Data
public:
initonly MemChunk^ Data
val Data: MemChunk
val Data: MemChunk

Field Value

Type: MemChunk
See Also
WireMsg Structure
WireMsg Members
NFX.Glue.Native Namespace


WireMsg Methods

WireMsg Methods NFX Class Library

The WireMsg type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Public method | UpdateBufferStats | Update buffers statistics
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WireMsg Structure
NFX.Glue.Native Namespace


WireMsg.UpdateBufferStats Method

WireMsg UpdateBufferStats Method NFX Class Library

Update buffers statistics

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void UpdateBufferStats()
public void UpdateBufferStats()
Public Sub UpdateBufferStats
Public Sub UpdateBufferStats
public:
void UpdateBufferStats()
public:
void UpdateBufferStats()
member UpdateBufferStats : unit -> unit
member UpdateBufferStats : unit -> unit
See Also
WireMsg Structure
WireMsg Members
NFX.Glue.Native Namespace


WireMsg Properties

WireMsg Properties NFX Class Library

The WireMsg type exposes the following members.
Properties
 | Name | Description
Public property | Buffer | Returns data byte buffer
Public property | BufferUsedSize | Returns data byte buffer use count, i.w. the buffer may be physically larger, however only BufferUsedSize must be transmitted
Public property | Frame | Returns frame serialized in data
Back to Top
See Also
WireMsg Structure
NFX.Glue.Native Namespace


WireMsg.Buffer Property

WireMsg Buffer Property NFX Class Library

Returns data byte buffer

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] Buffer { get; }
public byte[] Buffer { get; }
Public ReadOnly Property Buffer As Byte()
    Get
Public ReadOnly Property Buffer As Byte()
    Get
public:
property array<unsigned char>^ Buffer {
    array<unsigned char>^ get ();
}
public:
property array<unsigned char>^ Buffer {
    array<unsigned char>^ get ();
}
member Buffer : byte[] with get
member Buffer : byte[] with get

Property Value

Type: Online Byte
See Also
WireMsg Structure
WireMsg Members
NFX.Glue.Native Namespace


WireMsg.BufferUsedSize Property

WireMsg BufferUsedSize Property NFX Class Library

Returns data byte buffer use count, i.w. the buffer may be physically larger, however only BufferUsedSize must be transmitted

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int BufferUsedSize { get; }
public int BufferUsedSize { get; }
Public ReadOnly Property BufferUsedSize As Integer
    Get
Public ReadOnly Property BufferUsedSize As Integer
    Get
public:
property int BufferUsedSize {
    int get ();
}
public:
property int BufferUsedSize {
    int get ();
}
member BufferUsedSize : int with get
member BufferUsedSize : int with get

Property Value

Type: Online Int32
See Also
WireMsg Structure
WireMsg Members
NFX.Glue.Native Namespace


WireMsg.Frame Property

WireMsg Frame Property NFX Class Library

Returns frame serialized in data

Namespace: NFX.Glue.Native
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WireFrame Frame { get; internal set; }
public WireFrame Frame { get; internal set; }
Public Property Frame As WireFrame
    Get
    Friend Set
Public Property Frame As WireFrame
    Get
    Friend Set
public:
property WireFrame Frame {
    WireFrame get ();
    internal: void set (WireFrame value);
}
public:
property WireFrame Frame {
    WireFrame get ();
    internal: void set (WireFrame value);
}
member Frame : WireFrame with get, internal set
member Frame : WireFrame with get, internal set

Property Value

Type: WireFrame
See Also
WireMsg Structure
WireMsg Members
NFX.Glue.Native Namespace


NFX.Glue.Protocol Namespace

NFX.Glue.Protocol Namespace NFX Class Library

Defines protocol headers and messages for Glue
Classes
 | Class | Description
Public class | AuthenticationHeader | Marshalls user authentication information
Public class | HashUtils | Hash helpers used by Glue protocol for type resolution
Public class | Header | Represents a header base - custom headers must inherit from this class
Public class | HeaderConfigurator | Provides general configuration reading logic for headers. Note: This class is not invoked by default glue runtime, so default application configurations that include header injections will be ignored unless this class is specifically called from code. This is because conf-based header injection is a rare case that may need to be controlled by a particular application
Public class | Headers | List of headers
Public class | Msg | Represents a message base that requests and responses derive from. Messages are exchanged between glued tiers
Public class | RequestAnyMsg | Represents request msg that marshalls arguments as object[]. Although the most convenient and simple, this way of working with glue is slower than using RequestTypedMsg which needs to be derived-from for every method
Public class | RequestMsg | This message is sent from client to server and contains contract type, method specification and invocation arguments which are either included as object[] if RequestAnyMsg is used or inlined in RequestMsg- typed derivative for speed to avoid boxing
Public class | ResponseMsg | Represents a response message sent by called party
Structures
 | Structure | Description
Public structure | CallOptions | Specifies additional options for call like timeouts
Public structure | MethodSpec | Method specification for marshalling method information between glued peers
Public structure | TypeSpec | Type specification for marshalling contract types between glued peers


AuthenticationHeader Class

AuthenticationHeader Class NFX Class Library

Marshalls user authentication information
Inheritance Hierarchy
Online System Object
NFX.Glue.Protocol Header
NFX.Glue.Protocol AuthenticationHeader

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class AuthenticationHeader : Header
[SerializableAttribute]
public sealed class AuthenticationHeader : Header
<SerializableAttribute>
Public NotInheritable Class AuthenticationHeader
    Inherits Header
<SerializableAttribute>
Public NotInheritable Class AuthenticationHeader
    Inherits Header
[SerializableAttribute]
public ref class AuthenticationHeader sealed : public Header
[SerializableAttribute]
public ref class AuthenticationHeader sealed : public Header
[<SealedAttribute>]
[<SerializableAttribute>]
type AuthenticationHeader =
    class
        inherit Header
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type AuthenticationHeader =
    class
        inherit Header
    end
See Also
AuthenticationHeader Members
NFX.Glue.Protocol Namespace


AuthenticationHeader Members

AuthenticationHeader Members NFX Class Library

The AuthenticationHeader type exposes the following members.
Constructors
 | Name | Description
Public method | AuthenticationHeader(AuthenticationToken) | Initializes a new instance of the AuthenticationHeader class
Public method | AuthenticationHeader(Credentials) | Inits header with Credentials instance. Note: passing IDPasswordCredentials over public wire is not a good practice, pass AuthenticationToken instead
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Credentials | Returns Credentials
Public property | Token | Returns AuthenticationToken
Back to Top
See Also
AuthenticationHeader Class
NFX.Glue.Protocol Namespace


AuthenticationHeader Constructor

AuthenticationHeader Constructor NFX Class Library

Overload List
 | Name | Description
Public method | AuthenticationHeader(AuthenticationToken) | Initializes a new instance of the AuthenticationHeader class
Public method | AuthenticationHeader(Credentials) | Inits header with Credentials instance. Note: passing IDPasswordCredentials over public wire is not a good practice, pass AuthenticationToken instead
Back to Top
See Also
AuthenticationHeader Class
AuthenticationHeader Members
NFX.Glue.Protocol Namespace


AuthenticationHeader Constructor (AuthenticationToken)

AuthenticationHeader Constructor (AuthenticationToken) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AuthenticationHeader class

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AuthenticationHeader(
    AuthenticationToken token
)
public AuthenticationHeader(
    AuthenticationToken token
)
Public Sub New (
    token As AuthenticationToken
)
Public Sub New (
    token As AuthenticationToken
)
public:
AuthenticationHeader(
    AuthenticationToken token
)
public:
AuthenticationHeader(
    AuthenticationToken token
)
new :
        token : AuthenticationToken -> AuthenticationHeader
new :
        token : AuthenticationToken -> AuthenticationHeader

Parameters

token
Type: NFX.Security AuthenticationToken
See Also
AuthenticationHeader Class
AuthenticationHeader Members
AuthenticationHeader Overload
NFX.Glue.Protocol Namespace


AuthenticationHeader Constructor (Credentials)

AuthenticationHeader Constructor (Credentials) NFX Class Library

[This is preliminary documentation and is subject to change.]

Inits header with Credentials instance. Note: passing IDPasswordCredentials over public wire is not a good practice, pass AuthenticationToken instead

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AuthenticationHeader(
    Credentials credentials
)
public AuthenticationHeader(
    Credentials credentials
)
Public Sub New (
    credentials As Credentials
)
Public Sub New (
    credentials As Credentials
)
public:
AuthenticationHeader(
    Credentials^ credentials
)
public:
AuthenticationHeader(
    Credentials^ credentials
)
new :
        credentials : Credentials -> AuthenticationHeader
new :
        credentials : Credentials -> AuthenticationHeader

Parameters

credentials
Type: NFX.Security Credentials
See Also
AuthenticationHeader Class
AuthenticationHeader Members
AuthenticationHeader Overload
NFX.Glue.Protocol Namespace


AuthenticationHeader Methods

AuthenticationHeader Methods NFX Class Library

The AuthenticationHeader type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
AuthenticationHeader Class
NFX.Glue.Protocol Namespace


AuthenticationHeader Properties

AuthenticationHeader Properties NFX Class Library

The AuthenticationHeader type exposes the following members.
Properties
 | Name | Description
Public property | Credentials | Returns Credentials
Public property | Token | Returns AuthenticationToken
Back to Top
See Also
AuthenticationHeader Class
NFX.Glue.Protocol Namespace


AuthenticationHeader.Credentials Property

AuthenticationHeader Credentials Property NFX Class Library

Returns Credentials

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Credentials Credentials { get; }
public Credentials Credentials { get; }
Public ReadOnly Property Credentials As Credentials
    Get
Public ReadOnly Property Credentials As Credentials
    Get
public:
property Credentials^ Credentials {
    Credentials^ get ();
}
public:
property Credentials^ Credentials {
    Credentials^ get ();
}
member Credentials : Credentials with get
member Credentials : Credentials with get

Property Value

Type: Credentials
See Also
AuthenticationHeader Class
AuthenticationHeader Members
NFX.Glue.Protocol Namespace


AuthenticationHeader.Token Property

AuthenticationHeader Token Property NFX Class Library

Returns AuthenticationToken

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AuthenticationToken Token { get; }
public AuthenticationToken Token { get; }
Public ReadOnly Property Token As AuthenticationToken
    Get
Public ReadOnly Property Token As AuthenticationToken
    Get
public:
property AuthenticationToken Token {
    AuthenticationToken get ();
}
public:
property AuthenticationToken Token {
    AuthenticationToken get ();
}
member Token : AuthenticationToken with get
member Token : AuthenticationToken with get

Property Value

Type: AuthenticationToken
See Also
AuthenticationHeader Class
AuthenticationHeader Members
NFX.Glue.Protocol Namespace


CallOptions Structure

CallOptions Structure NFX Class Library

Specifies additional options for call like timeouts

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct CallOptions
public struct CallOptions
Public Structure CallOptions
Public Structure CallOptions
public value class CallOptions
public value class CallOptions
[<SealedAttribute>]
type CallOptions =  struct end
[<SealedAttribute>]
type CallOptions =  struct end
See Also
CallOptions Members
NFX.Glue.Protocol Namespace


CallOptions Members

CallOptions Members NFX Class Library

The CallOptions type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | DispatchTimeoutMs |
Public field | TimeoutMs |
Back to Top
See Also
CallOptions Structure
NFX.Glue.Protocol Namespace


CallOptions Fields

CallOptions Fields NFX Class Library

The CallOptions type exposes the following members.
Fields
 | Name | Description
Public field | DispatchTimeoutMs |
Public field | TimeoutMs |
Back to Top
See Also
CallOptions Structure
NFX.Glue.Protocol Namespace


CallOptions.DispatchTimeoutMs Field

CallOptions DispatchTimeoutMs Field NFX Class Library

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int DispatchTimeoutMs
public int DispatchTimeoutMs
Public DispatchTimeoutMs As Integer
Public DispatchTimeoutMs As Integer
public:
int DispatchTimeoutMs
public:
int DispatchTimeoutMs
val mutable DispatchTimeoutMs: int
val mutable DispatchTimeoutMs: int

Field Value

Type: Online Int32
See Also
CallOptions Structure
CallOptions Members
NFX.Glue.Protocol Namespace


CallOptions.TimeoutMs Field

CallOptions TimeoutMs Field NFX Class Library

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int TimeoutMs
public int TimeoutMs
Public TimeoutMs As Integer
Public TimeoutMs As Integer
public:
int TimeoutMs
public:
int TimeoutMs
val mutable TimeoutMs: int
val mutable TimeoutMs: int

Field Value

Type: Online Int32
See Also
CallOptions Structure
CallOptions Members
NFX.Glue.Protocol Namespace


CallOptions Methods

CallOptions Methods NFX Class Library

The CallOptions type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CallOptions Structure
NFX.Glue.Protocol Namespace


HashUtils Class

HashUtils Class NFX Class Library

Hash helpers used by Glue protocol for type resolution
Inheritance Hierarchy
Online System Object
NFX.Glue.Protocol HashUtils

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class HashUtils
public static class HashUtils
Public NotInheritable Class HashUtils
Public NotInheritable Class HashUtils
public ref class HashUtils abstract sealed
public ref class HashUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type HashUtils =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type HashUtils =  class end
See Also
HashUtils Members
NFX.Glue.Protocol Namespace


HashUtils Members

HashUtils Members NFX Class Library

The HashUtils type exposes the following members.
Methods
Name | Description
StringIDHash | Converts string identifier into uint64 stable hash that does not depend on a platform. This functions optimized for hashing identifiers/type names
TypeHash | Returns stable ulong hash for a type that does not depend on a platform
Back to Top
See Also
HashUtils Class
NFX.Glue.Protocol Namespace


HashUtils Methods

HashUtils Methods NFX Class Library

The HashUtils type exposes the following members.
Methods
Name | Description
StringIDHash | Converts string identifier into uint64 stable hash that does not depend on a platform. This functions optimized for hashing identifiers/type names
TypeHash | Returns stable ulong hash for a type that does not depend on a platform
Back to Top
See Also
HashUtils Class
NFX.Glue.Protocol Namespace


HashUtils.StringIDHash Method

HashUtils StringIDHash Method NFX Class Library

Converts string identifier into uint64 stable hash that does not depend on a platform. This functions optimized for hashing identifiers/type names

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ulong StringIDHash(
    string id
)
public static ulong StringIDHash(
    string id
)
Public Shared Function StringIDHash (
    id As String
) As ULong
Public Shared Function StringIDHash (
    id As String
) As ULong
public:
static unsigned long long StringIDHash(
    String^ id
)
public:
static unsigned long long StringIDHash(
    String^ id
)
static member StringIDHash :
        id : string -> uint64
static member StringIDHash :
        id : string -> uint64

Parameters

id
Type: Online System String

Return Value

Type: Online UInt64
See Also
HashUtils Class
HashUtils Members
NFX.Glue.Protocol Namespace


HashUtils.TypeHash Method

HashUtils TypeHash Method NFX Class Library

Returns stable ulong hash for a type that does not depend on a platform

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ulong TypeHash(
    Type type
)
public static ulong TypeHash(
    Type type
)
Public Shared Function TypeHash (
    type As Type
) As ULong
Public Shared Function TypeHash (
    type As Type
) As ULong
public:
static unsigned long long TypeHash(
    Type^ type
)
public:
static unsigned long long TypeHash(
    Type^ type
)
static member TypeHash :
        type : Type -> uint64
static member TypeHash :
        type : Type -> uint64

Parameters

type
Type: Online System Type

Return Value

Type: Online UInt64
See Also
HashUtils Class
HashUtils Members
NFX.Glue.Protocol Namespace


Header Class

Header Class NFX Class Library

Represents a header base - custom headers must inherit from this class
Inheritance Hierarchy
Online System Object
NFX.Glue.Protocol Header
NFX.Glue.Protocol AuthenticationHeader

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class Header
[SerializableAttribute]
public abstract class Header
<SerializableAttribute>
Public MustInherit Class Header
<SerializableAttribute>
Public MustInherit Class Header
[SerializableAttribute]
public ref class Header abstract
[SerializableAttribute]
public ref class Header abstract
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type Header =  class end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type Header =  class end
See Also
Header Members
NFX.Glue.Protocol Namespace


Header Members

Header Members NFX Class Library

The Header type exposes the following members.
Constructors
 | Name | Description
Protected method | Header | Initializes a new instance of the Header class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Header Class
NFX.Glue.Protocol Namespace


Header Constructor

Header Constructor NFX Class Library

Initializes a new instance of the Header class

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Header()
protected Header()
Protected Sub New
Protected Sub New
protected:
Header()
protected:
Header()
new : unit -> Header
new : unit -> Header
See Also
Header Class
Header Members
NFX.Glue.Protocol Namespace


Header Methods

Header Methods NFX Class Library

The Header type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Header Class
NFX.Glue.Protocol Namespace


HeaderConfigurator Class

HeaderConfigurator Class NFX Class Library

Provides general configuration reading logic for headers. Note: This class is not invoked by default glue runtime, so default application configurations that include header injections will be ignored unless this class is specifically called from code. This is because conf-based header injection is a rare case that may need to be controlled by a particular application
Inheritance Hierarchy
Online System Object
NFX.Glue.Protocol HeaderConfigurator

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class HeaderConfigurator
public static class HeaderConfigurator
Public NotInheritable Class HeaderConfigurator
Public NotInheritable Class HeaderConfigurator
public ref class HeaderConfigurator abstract sealed
public ref class HeaderConfigurator abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type HeaderConfigurator =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type HeaderConfigurator =  class end
See Also
HeaderConfigurator Members
NFX.Glue.Protocol Namespace


HeaderConfigurator Members

HeaderConfigurator Members NFX Class Library

The HeaderConfigurator type exposes the following members.
Methods
Name | Description
ConfigureHeaders |
Back to Top
Fields
Name | Description
CONFIG_HEADER_SECTION |
CONFIG_HEADERS_SECTION |
Back to Top
See Also
HeaderConfigurator Class
NFX.Glue.Protocol Namespace


HeaderConfigurator Fields

HeaderConfigurator Fields NFX Class Library

The HeaderConfigurator type exposes the following members.
Fields
Name | Description
CONFIG_HEADER_SECTION |
CONFIG_HEADERS_SECTION |
Back to Top
See Also
HeaderConfigurator Class
NFX.Glue.Protocol Namespace


HeaderConfigurator.CONFIG_HEADER_SECTION Field

HeaderConfigurator CONFIG_HEADER_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_HEADER_SECTION
public const string CONFIG_HEADER_SECTION
Public Const CONFIG_HEADER_SECTION As String
Public Const CONFIG_HEADER_SECTION As String
public:
literal String^ CONFIG_HEADER_SECTION
public:
literal String^ CONFIG_HEADER_SECTION
static val mutable CONFIG_HEADER_SECTION: string
static val mutable CONFIG_HEADER_SECTION: string

Field Value

Type: Online String
See Also
HeaderConfigurator Class
HeaderConfigurator Members
NFX.Glue.Protocol Namespace


HeaderConfigurator.CONFIG_HEADERS_SECTION Field

HeaderConfigurator CONFIG_HEADERS_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_HEADERS_SECTION
public const string CONFIG_HEADERS_SECTION
Public Const CONFIG_HEADERS_SECTION As String
Public Const CONFIG_HEADERS_SECTION As String
public:
literal String^ CONFIG_HEADERS_SECTION
public:
literal String^ CONFIG_HEADERS_SECTION
static val mutable CONFIG_HEADERS_SECTION: string
static val mutable CONFIG_HEADERS_SECTION: string

Field Value

Type: Online String
See Also
HeaderConfigurator Class
HeaderConfigurator Members
NFX.Glue.Protocol Namespace


HeaderConfigurator Methods

HeaderConfigurator Methods NFX Class Library

The HeaderConfigurator type exposes the following members.
Methods
Name | Description
ConfigureHeaders |
Back to Top
See Also
HeaderConfigurator Class
NFX.Glue.Protocol Namespace


HeaderConfigurator.ConfigureHeaders Method

HeaderConfigurator ConfigureHeaders Method NFX Class Library

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ConfigureHeaders(
    IList<Header> headers,
    IConfigSectionNode node
)
public static void ConfigureHeaders(
    IList<Header> headers,
    IConfigSectionNode node
)
Public Shared Sub ConfigureHeaders (
    headers As IList(Of Header),
    node As IConfigSectionNode
)
Public Shared Sub ConfigureHeaders (
    headers As IList(Of Header),
    node As IConfigSectionNode
)
public:
static void ConfigureHeaders(
    IList<Header^>^ headers,
    IConfigSectionNode^ node
)
public:
static void ConfigureHeaders(
    IList<Header^>^ headers,
    IConfigSectionNode^ node
)
static member ConfigureHeaders :
        headers : IList<Header> *
        node : IConfigSectionNode -> unit
static member ConfigureHeaders :
        headers : IList<Header> *
        node : IConfigSectionNode -> unit

Parameters

headers
Type: Online System.Collections.Generic IList Header
node
Type: NFX.Environment IConfigSectionNode
See Also
HeaderConfigurator Class
HeaderConfigurator Members
NFX.Glue.Protocol Namespace


Headers Class

Headers Class NFX Class Library

List of headers
Inheritance Hierarchy
Online System Object
Online System.Collections.Generic List Header
NFX.Glue.Protocol Headers

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class Headers : List<Header>
[SerializableAttribute]
public sealed class Headers : List<Header>
<SerializableAttribute>
Public NotInheritable Class Headers
    Inherits List(Of Header)
<SerializableAttribute>
Public NotInheritable Class Headers
    Inherits List(Of Header)
[SerializableAttribute]
public ref class Headers sealed : public List<Header^>
[SerializableAttribute]
public ref class Headers sealed : public List<Header^>
[<SealedAttribute>]
[<SerializableAttribute>]
type Headers =
    class
        inherit List<Header>
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type Headers =
    class
        inherit List<Header>
    end
See Also
Headers Members
NFX.Glue.Protocol Namespace


Headers Members

Headers Members NFX Class Library

The Headers type exposes the following members.
Constructors
 | Name | Description
Public method | Headers | Initializes a new instance of the Headers class
Back to Top
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List Header .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List Header .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List Header .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List Header .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Header .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Header .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List Header .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List Header .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List Header .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List Header .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Header .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Header .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List Header .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List Header .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Header .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Header .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Header .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Header .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List Header .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Header .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Header .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Header .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List Header .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List Header .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List Header .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Header .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Header .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Header .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List Header .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List Header .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Header .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Header .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Header .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List Header .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Header .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List Header .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List Header .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List Header .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List Header .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List Header .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List Header .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List Header .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List Header .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List Header .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List Header .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List Header .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List Header .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List Header .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List Header .)
Back to Top
See Also
Headers Class
NFX.Glue.Protocol Namespace


Headers Constructor

Headers Constructor NFX Class Library

Initializes a new instance of the Headers class

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Headers()
public Headers()
Public Sub New
Public Sub New
public:
Headers()
public:
Headers()
new : unit -> Headers
new : unit -> Headers
See Also
Headers Class
Headers Members
NFX.Glue.Protocol Namespace


Headers Methods

Headers Methods NFX Class Library

The Headers type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List Header .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List Header .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List Header .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List Header .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Header .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Header .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List Header .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List Header .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List Header .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List Header .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Header .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Header .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List Header .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List Header .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Header .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Header .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Header .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Header .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List Header .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Header .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Header .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Header .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List Header .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List Header .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List Header .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Header .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Header .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Header .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List Header .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List Header .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Header .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Header .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Header .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List Header .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Header .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List Header .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List Header .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List Header .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List Header .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List Header .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List Header .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List Header .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List Header .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List Header .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List Header .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List Header .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Headers Class
NFX.Glue.Protocol Namespace


Headers Properties

Headers Properties NFX Class Library

The Headers type exposes the following members.
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List Header .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List Header .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List Header .)
Back to Top
See Also
Headers Class
NFX.Glue.Protocol Namespace


MethodSpec Structure

MethodSpec Structure NFX Class Library

Method specification for marshalling method information between glued peers

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public struct MethodSpec
[SerializableAttribute]
public struct MethodSpec
<SerializableAttribute>
Public Structure MethodSpec
<SerializableAttribute>
Public Structure MethodSpec
[SerializableAttribute]
public value class MethodSpec
[SerializableAttribute]
public value class MethodSpec
[<SealedAttribute>]
[<SerializableAttribute>]
type MethodSpec =  struct end
[<SealedAttribute>]
[<SerializableAttribute>]
type MethodSpec =  struct end
See Also
MethodSpec Members
NFX.Glue.Protocol Namespace


MethodSpec Members

MethodSpec Members NFX Class Library

The MethodSpec type exposes the following members.
Constructors
 | Name | Description
Public method | MethodSpec | Initializes a new instance of the MethodSpec class
Back to Top
Methods
 | Name | Description
Public method | Equals | (Overrides Online ValueType Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Operators
Name | Description
Equality |
Inequality |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Hash |
Protected field | m_MethodName |
Protected field | m_ReturnType |
Protected field | m_Signature |
Back to Top
Properties
 | Name | Description
Public property | Hash |
Public property | MethodName |
Public property | ReturnType |
Public property | Signature |
Back to Top
See Also
MethodSpec Structure
NFX.Glue.Protocol Namespace


MethodSpec Constructor

MethodSpec Constructor NFX Class Library

Initializes a new instance of the MethodSpec class

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MethodSpec(
    MethodInfo mi
)
public MethodSpec(
    MethodInfo mi
)
Public Sub New (
    mi As MethodInfo
)
Public Sub New (
    mi As MethodInfo
)
public:
MethodSpec(
    MethodInfo^ mi
)
public:
MethodSpec(
    MethodInfo^ mi
)
new :
        mi : MethodInfo -> MethodSpec
new :
        mi : MethodInfo -> MethodSpec

Parameters

mi
Type: Online System.Reflection MethodInfo
See Also
MethodSpec Structure
MethodSpec Members
NFX.Glue.Protocol Namespace


MethodSpec Fields

MethodSpec Fields NFX Class Library

The MethodSpec type exposes the following members.
Fields
 | Name | Description
Protected field | m_Hash |
Protected field | m_MethodName |
Protected field | m_ReturnType |
Protected field | m_Signature |
Back to Top
See Also
MethodSpec Structure
NFX.Glue.Protocol Namespace


MethodSpec.m_Hash Field

MethodSpec m_Hash Field NFX Class Library

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ulong m_Hash
internal ulong m_Hash
Friend m_Hash As ULong
Friend m_Hash As ULong
internal:
unsigned long long m_Hash
internal:
unsigned long long m_Hash
val mutable internal m_Hash: uint64
val mutable internal m_Hash: uint64

Field Value

Type: Online UInt64
See Also
MethodSpec Structure
MethodSpec Members
NFX.Glue.Protocol Namespace


MethodSpec.m_MethodName Field

MethodSpec m_MethodName Field NFX Class Library

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal string m_MethodName
internal string m_MethodName
Friend m_MethodName As String
Friend m_MethodName As String
internal:
String^ m_MethodName
internal:
String^ m_MethodName
val mutable internal m_MethodName: string
val mutable internal m_MethodName: string

Field Value

Type: Online String
See Also
MethodSpec Structure
MethodSpec Members
NFX.Glue.Protocol Namespace


MethodSpec.m_ReturnType Field

MethodSpec m_ReturnType Field NFX Class Library

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ulong m_ReturnType
internal ulong m_ReturnType
Friend m_ReturnType As ULong
Friend m_ReturnType As ULong
internal:
unsigned long long m_ReturnType
internal:
unsigned long long m_ReturnType
val mutable internal m_ReturnType: uint64
val mutable internal m_ReturnType: uint64

Field Value

Type: Online UInt64
See Also
MethodSpec Structure
MethodSpec Members
NFX.Glue.Protocol Namespace


MethodSpec.m_Signature Field

MethodSpec m_Signature Field NFX Class Library

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal byte[] m_Signature
internal byte[] m_Signature
Friend m_Signature As Byte()
Friend m_Signature As Byte()
internal:
array<unsigned char>^ m_Signature
internal:
array<unsigned char>^ m_Signature
val mutable internal m_Signature: byte[]
val mutable internal m_Signature: byte[]

Field Value

Type: Online Byte
See Also
MethodSpec Structure
MethodSpec Members
NFX.Glue.Protocol Namespace


MethodSpec Methods

MethodSpec Methods NFX Class Library

The MethodSpec type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online ValueType Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MethodSpec Structure
NFX.Glue.Protocol Namespace


MethodSpec.Equals Method

MethodSpec Equals Method NFX Class Library

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
MethodSpec Structure
MethodSpec Members
NFX.Glue.Protocol Namespace


MethodSpec.GetHashCode Method

MethodSpec GetHashCode Method NFX Class Library

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
MethodSpec Structure
MethodSpec Members
NFX.Glue.Protocol Namespace


MethodSpec.ToString Method

MethodSpec ToString Method NFX Class Library

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
MethodSpec Structure
MethodSpec Members
NFX.Glue.Protocol Namespace


MethodSpec Operators

MethodSpec Operators NFX Class Library

The MethodSpec type exposes the following members.
Operators
Name | Description
Equality |
Inequality |
Back to Top
See Also
MethodSpec Structure
NFX.Glue.Protocol Namespace


MethodSpec.Equality Operator

MethodSpec Equality Operator NFX Class Library

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    MethodSpec left,
    MethodSpec right
)
public static bool operator ==(
    MethodSpec left,
    MethodSpec right
)
Public Shared Operator = (
    left As MethodSpec,
    right As MethodSpec
) As Boolean
Public Shared Operator = (
    left As MethodSpec,
    right As MethodSpec
) As Boolean
public:
static bool operator ==(
    MethodSpec left,
    MethodSpec right
)
public:
static bool operator ==(
    MethodSpec left,
    MethodSpec right
)
static let inline (=)
        left : MethodSpec *
        right : MethodSpec  : bool
static let inline (=)
        left : MethodSpec *
        right : MethodSpec  : bool

Parameters

left
Type: NFX.Glue.Protocol MethodSpec
right
Type: NFX.Glue.Protocol MethodSpec

Return Value

Type: Online Boolean
See Also
MethodSpec Structure
MethodSpec Members
NFX.Glue.Protocol Namespace


MethodSpec.Inequality Operator

MethodSpec Inequality Operator NFX Class Library

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    MethodSpec left,
    MethodSpec right
)
public static bool operator !=(
    MethodSpec left,
    MethodSpec right
)
Public Shared Operator <> (
    left As MethodSpec,
    right As MethodSpec
) As Boolean
Public Shared Operator <> (
    left As MethodSpec,
    right As MethodSpec
) As Boolean
public:
static bool operator !=(
    MethodSpec left,
    MethodSpec right
)
public:
static bool operator !=(
    MethodSpec left,
    MethodSpec right
)
static let inline (<>)
        left : MethodSpec *
        right : MethodSpec  : bool
static let inline (<>)
        left : MethodSpec *
        right : MethodSpec  : bool

Parameters

left
Type: NFX.Glue.Protocol MethodSpec
right
Type: NFX.Glue.Protocol MethodSpec

Return Value

Type: Online Boolean
See Also
MethodSpec Structure
MethodSpec Members
NFX.Glue.Protocol Namespace


MethodSpec Properties

MethodSpec Properties NFX Class Library

The MethodSpec type exposes the following members.
Properties
 | Name | Description
Public property | Hash |
Public property | MethodName |
Public property | ReturnType |
Public property | Signature |
Back to Top
See Also
MethodSpec Structure
NFX.Glue.Protocol Namespace


MethodSpec.Hash Property

MethodSpec Hash Property NFX Class Library

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong Hash { get; }
public ulong Hash { get; }
Public ReadOnly Property Hash As ULong
    Get
Public ReadOnly Property Hash As ULong
    Get
public:
property unsigned long long Hash {
    unsigned long long get ();
}
public:
property unsigned long long Hash {
    unsigned long long get ();
}
member Hash : uint64 with get
member Hash : uint64 with get

Property Value

Type: Online UInt64
See Also
MethodSpec Structure
MethodSpec Members
NFX.Glue.Protocol Namespace


MethodSpec.MethodName Property

MethodSpec MethodName Property NFX Class Library

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MethodName { get; }
public string MethodName { get; }
Public ReadOnly Property MethodName As String
    Get
Public ReadOnly Property MethodName As String
    Get
public:
property String^ MethodName {
    String^ get ();
}
public:
property String^ MethodName {
    String^ get ();
}
member MethodName : string with get
member MethodName : string with get

Property Value

Type: Online String
See Also
MethodSpec Structure
MethodSpec Members
NFX.Glue.Protocol Namespace


MethodSpec.ReturnType Property

MethodSpec ReturnType Property NFX Class Library

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong ReturnType { get; }
public ulong ReturnType { get; }
Public ReadOnly Property ReturnType As ULong
    Get
Public ReadOnly Property ReturnType As ULong
    Get
public:
property unsigned long long ReturnType {
    unsigned long long get ();
}
public:
property unsigned long long ReturnType {
    unsigned long long get ();
}
member ReturnType : uint64 with get
member ReturnType : uint64 with get

Property Value

Type: Online UInt64
See Also
MethodSpec Structure
MethodSpec Members
NFX.Glue.Protocol Namespace


MethodSpec.Signature Property

MethodSpec Signature Property NFX Class Library

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] Signature { get; }
public byte[] Signature { get; }
Public ReadOnly Property Signature As Byte()
    Get
Public ReadOnly Property Signature As Byte()
    Get
public:
property array<unsigned char>^ Signature {
    array<unsigned char>^ get ();
}
public:
property array<unsigned char>^ Signature {
    array<unsigned char>^ get ();
}
member Signature : byte[] with get
member Signature : byte[] with get

Property Value

Type: Online Byte
See Also
MethodSpec Structure
MethodSpec Members
NFX.Glue.Protocol Namespace


Msg Class

Msg Class NFX Class Library

Represents a message base that requests and responses derive from. Messages are exchanged between glued tiers
Inheritance Hierarchy
Online System Object
NFX.Glue.Protocol Msg
NFX.Glue.Protocol RequestMsg
NFX.Glue.Protocol ResponseMsg

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class Msg
[SerializableAttribute]
public abstract class Msg
<SerializableAttribute>
Public MustInherit Class Msg
<SerializableAttribute>
Public MustInherit Class Msg
[SerializableAttribute]
public ref class Msg abstract
[SerializableAttribute]
public ref class Msg abstract
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type Msg =  class end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type Msg =  class end
See Also
Msg Members
NFX.Glue.Protocol Namespace


Msg Members

Msg Members NFX Class Library

The Msg type exposes the following members.
Constructors
 | Name | Description
Protected method | Msg | Constructs new message and allocates unique ID
Back to Top
Methods
 | Name | Description
Public method | __SetArrivalTimeStampTicks | Framework method not for developers. Sets arrival ticks stamp. Usually called from transport
Public method | __SetBindingSpecificContext(Object) | Internal method not to be called by app developers. Called from custom bindings to inject binding-specific context
Public method | __SetBindingSpecificContext(Msg) | Internal method not to be called by app developers. Called from custom bindings to inject binding-specific context
Public method | CloneState | Clones message state from another message instance. State includes binding-specific context and optionally headers and correlation data
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Headers |
Protected field | m_ID |
Back to Top
Properties
 | Name | Description
Public property | ArrivalTimeStamp | Returns arrival timestamp expressed in ticks, that is - when message just arrived before its processing started by Glue (before deserialization). This property allows for glue-internal latency assessment
Public property | BindingSpecificContext | Returns a binding-specific context object which is used for message processing/routing by binding. This property value is not serialized and used internally by Glue framework. Not all bindings use/need this property
Public property | CorrelationData | Arbitrary named object collection that can be used to correlate messages and/or attach extra data. This field is NOT transmitted over wire nor is it used by the framework. Message inspectors may use this property at their own discretion, for example in cases when the same inspector type is registered on multiple levels (endpoint, binding, glue), inspectors may check this property to execute only once per message. The collection is lazily allocated at the first reference attempt
Public property | HasCorrelationData | Returns true when this message contains header data
Public property | HasHeaders | Returns true when this message contains header data
Public property | Headers | Returns a list of headers that this message contains
Public property | ID | Returns a unique ID for this message
Public property | RequestID | Returns request ID that relates to this message instance. It is the message ID for RequestMsg and related message ID for ResponseMsg
Back to Top
See Also
Msg Class
NFX.Glue.Protocol Namespace


Msg Constructor

Msg Constructor NFX Class Library

Constructs new message and allocates unique ID

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Msg()
protected Msg()
Protected Sub New
Protected Sub New
protected:
Msg()
protected:
Msg()
new : unit -> Msg
new : unit -> Msg
See Also
Msg Class
Msg Members
NFX.Glue.Protocol Namespace


Msg Fields

Msg Fields NFX Class Library

The Msg type exposes the following members.
Fields
 | Name | Description
Protected field | m_Headers |
Protected field | m_ID |
Back to Top
See Also
Msg Class
NFX.Glue.Protocol Namespace


Msg.m_Headers Field

Msg m_Headers Field NFX Class Library

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Headers m_Headers
internal Headers m_Headers
Friend m_Headers As Headers
Friend m_Headers As Headers
internal:
Headers^ m_Headers
internal:
Headers^ m_Headers
val mutable internal m_Headers: Headers
val mutable internal m_Headers: Headers

Field Value

Type: Headers
See Also
Msg Class
Msg Members
NFX.Glue.Protocol Namespace


Msg.m_ID Field

Msg m_ID Field NFX Class Library

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal FID m_ID
internal FID m_ID
Friend m_ID As FID
Friend m_ID As FID
internal:
FID m_ID
internal:
FID m_ID
val mutable internal m_ID: FID
val mutable internal m_ID: FID

Field Value

Type: FID
See Also
Msg Class
Msg Members
NFX.Glue.Protocol Namespace


Msg Methods

Msg Methods NFX Class Library

The Msg type exposes the following members.
Methods
 | Name | Description
Public method | __SetArrivalTimeStampTicks | Framework method not for developers. Sets arrival ticks stamp. Usually called from transport
Public method | __SetBindingSpecificContext(Object) | Internal method not to be called by app developers. Called from custom bindings to inject binding-specific context
Public method | __SetBindingSpecificContext(Msg) | Internal method not to be called by app developers. Called from custom bindings to inject binding-specific context
Public method | CloneState | Clones message state from another message instance. State includes binding-specific context and optionally headers and correlation data
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Msg Class
NFX.Glue.Protocol Namespace


Msg.__SetArrivalTimeStampTicks Method

Msg __SetArrivalTimeStampTicks Method NFX Class Library

Framework method not for developers. Sets arrival ticks stamp. Usually called from transport

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void __SetArrivalTimeStampTicks(
    long value
)
public void __SetArrivalTimeStampTicks(
    long value
)
Public Sub __SetArrivalTimeStampTicks (
    value As Long
)
Public Sub __SetArrivalTimeStampTicks (
    value As Long
)
public:
void __SetArrivalTimeStampTicks(
    long long value
)
public:
void __SetArrivalTimeStampTicks(
    long long value
)
member __SetArrivalTimeStampTicks :
        value : int64 -> unit
member __SetArrivalTimeStampTicks :
        value : int64 -> unit

Parameters

value
Type: Online System Int64
See Also
Msg Class
Msg Members
NFX.Glue.Protocol Namespace


Msg.__SetBindingSpecificContext Method

Msg __SetBindingSpecificContext Method NFX Class Library

Overload List
 | Name | Description
Public method | __SetBindingSpecificContext(Object) | Internal method not to be called by app developers. Called from custom bindings to inject binding-specific context
Public method | __SetBindingSpecificContext(Msg) | Internal method not to be called by app developers. Called from custom bindings to inject binding-specific context
Back to Top
See Also
Msg Class
Msg Members
NFX.Glue.Protocol Namespace


Msg.__SetBindingSpecificContext Method (Object)

Msg __SetBindingSpecificContext Method (Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Internal method not to be called by app developers. Called from custom bindings to inject binding-specific context

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void __SetBindingSpecificContext(
    Object context
)
public void __SetBindingSpecificContext(
    Object context
)
Public Sub __SetBindingSpecificContext (
    context As Object
)
Public Sub __SetBindingSpecificContext (
    context As Object
)
public:
void __SetBindingSpecificContext(
    Object^ context
)
public:
void __SetBindingSpecificContext(
    Object^ context
)
member __SetBindingSpecificContext :
        context : Object -> unit
member __SetBindingSpecificContext :
        context : Object -> unit

Parameters

context
Type: Online System Object
See Also
Msg Class
Msg Members
__SetBindingSpecificContext Overload
NFX.Glue.Protocol Namespace


Msg.__SetBindingSpecificContext Method (Msg)

Msg __SetBindingSpecificContext Method (Msg) NFX Class Library

[This is preliminary documentation and is subject to change.]

Internal method not to be called by app developers. Called from custom bindings to inject binding-specific context

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void __SetBindingSpecificContext(
    Msg other
)
public void __SetBindingSpecificContext(
    Msg other
)
Public Sub __SetBindingSpecificContext (
    other As Msg
)
Public Sub __SetBindingSpecificContext (
    other As Msg
)
public:
void __SetBindingSpecificContext(
    Msg^ other
)
public:
void __SetBindingSpecificContext(
    Msg^ other
)
member __SetBindingSpecificContext :
        other : Msg -> unit
member __SetBindingSpecificContext :
        other : Msg -> unit

Parameters

other
Type: NFX.Glue.Protocol Msg
See Also
Msg Class
Msg Members
__SetBindingSpecificContext Overload
NFX.Glue.Protocol Namespace


Msg.CloneState Method

Msg CloneState Method NFX Class Library

Clones message state from another message instance. State includes binding-specific context and optionally headers and correlation data

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CloneState(
    Msg from,
    bool cloneHeaders = true,
    bool cloneCorrelation = true
)
public void CloneState(
    Msg from,
    bool cloneHeaders = true,
    bool cloneCorrelation = true
)
Public Sub CloneState (
    from As Msg,
    Optional cloneHeaders As Boolean = true,
    Optional cloneCorrelation As Boolean = true
)
Public Sub CloneState (
    from As Msg,
    Optional cloneHeaders As Boolean = true,
    Optional cloneCorrelation As Boolean = true
)
public:
void CloneState(
    Msg^ from,
    bool cloneHeaders = true,
    bool cloneCorrelation = true
)
public:
void CloneState(
    Msg^ from,
    bool cloneHeaders = true,
    bool cloneCorrelation = true
)
member CloneState :
        from : Msg *
        ?cloneHeaders : bool *
        ?cloneCorrelation : bool
(* Defaults:
        let _cloneHeaders = defaultArg cloneHeaders true
        let _cloneCorrelation = defaultArg cloneCorrelation true
*)
-> unit
member CloneState :
        from : Msg *
        ?cloneHeaders : bool *
        ?cloneCorrelation : bool
(* Defaults:
        let _cloneHeaders = defaultArg cloneHeaders true
        let _cloneCorrelation = defaultArg cloneCorrelation true
*)
-> unit

Parameters

from
Type: NFX.Glue.Protocol Msg
cloneHeaders (Optional)
Type: Online System Boolean
cloneCorrelation (Optional)
Type: Online System Boolean
See Also
Msg Class
Msg Members
NFX.Glue.Protocol Namespace


Msg.ToString Method

Msg ToString Method NFX Class Library

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
Msg Class
Msg Members
NFX.Glue.Protocol Namespace


Msg Properties

Msg Properties NFX Class Library

The Msg type exposes the following members.
Properties
 | Name | Description
Public property | ArrivalTimeStamp | Returns arrival timestamp expressed in ticks, that is - when message just arrived before its processing started by Glue (before deserialization). This property allows for glue-internal latency assessment
Public property | BindingSpecificContext | Returns a binding-specific context object which is used for message processing/routing by binding. This property value is not serialized and used internally by Glue framework. Not all bindings use/need this property
Public property | CorrelationData | Arbitrary named object collection that can be used to correlate messages and/or attach extra data. This field is NOT transmitted over wire nor is it used by the framework. Message inspectors may use this property at their own discretion, for example in cases when the same inspector type is registered on multiple levels (endpoint, binding, glue), inspectors may check this property to execute only once per message. The collection is lazily allocated at the first reference attempt
Public property | HasCorrelationData | Returns true when this message contains header data
Public property | HasHeaders | Returns true when this message contains header data
Public property | Headers | Returns a list of headers that this message contains
Public property | ID | Returns a unique ID for this message
Public property | RequestID | Returns request ID that relates to this message instance. It is the message ID for RequestMsg and related message ID for ResponseMsg
Back to Top
See Also
Msg Class
NFX.Glue.Protocol Namespace


Msg.ArrivalTimeStamp Property

Msg ArrivalTimeStamp Property NFX Class Library

Returns arrival timestamp expressed in ticks, that is - when message just arrived before its processing started by Glue (before deserialization). This property allows for glue-internal latency assessment

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long ArrivalTimeStamp { get; }
public long ArrivalTimeStamp { get; }
Public ReadOnly Property ArrivalTimeStamp As Long
    Get
Public ReadOnly Property ArrivalTimeStamp As Long
    Get
public:
property long long ArrivalTimeStamp {
    long long get ();
}
public:
property long long ArrivalTimeStamp {
    long long get ();
}
member ArrivalTimeStamp : int64 with get
member ArrivalTimeStamp : int64 with get

Property Value

Type: Online Int64
See Also
Msg Class
Msg Members
NFX.Glue.Protocol Namespace


Msg.BindingSpecificContext Property

Msg BindingSpecificContext Property NFX Class Library

Returns a binding-specific context object which is used for message processing/routing by binding. This property value is not serialized and used internally by Glue framework. Not all bindings use/need this property

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object BindingSpecificContext { get; }
public Object BindingSpecificContext { get; }
Public ReadOnly Property BindingSpecificContext As Object
    Get
Public ReadOnly Property BindingSpecificContext As Object
    Get
public:
property Object^ BindingSpecificContext {
    Object^ get ();
}
public:
property Object^ BindingSpecificContext {
    Object^ get ();
}
member BindingSpecificContext : Object with get
member BindingSpecificContext : Object with get

Property Value

Type: Online Object
See Also
Msg Class
Msg Members
NFX.Glue.Protocol Namespace


Msg.CorrelationData Property

Msg CorrelationData Property NFX Class Library

Arbitrary named object collection that can be used to correlate messages and/or attach extra data. This field is NOT transmitted over wire nor is it used by the framework. Message inspectors may use this property at their own discretion, for example in cases when the same inspector type is registered on multiple levels (endpoint, binding, glue), inspectors may check this property to execute only once per message. The collection is lazily allocated at the first reference attempt

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Dictionary<string, Object> CorrelationData { get; }
public Dictionary<string, Object> CorrelationData { get; }
Public ReadOnly Property CorrelationData As Dictionary(Of String, Object)
    Get
Public ReadOnly Property CorrelationData As Dictionary(Of String, Object)
    Get
public:
property Dictionary<String^, Object^>^ CorrelationData {
    Dictionary<String^, Object^>^ get ();
}
public:
property Dictionary<String^, Object^>^ CorrelationData {
    Dictionary<String^, Object^>^ get ();
}
member CorrelationData : Dictionary<string, Object> with get
member CorrelationData : Dictionary<string, Object> with get

Property Value

Type: Online Dictionary Online String, Online Object
See Also
Msg Class
Msg Members
NFX.Glue.Protocol Namespace


Msg.HasCorrelationData Property

Msg HasCorrelationData Property NFX Class Library

Returns true when this message contains header data

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasCorrelationData { get; }
public bool HasCorrelationData { get; }
Public ReadOnly Property HasCorrelationData As Boolean
    Get
Public ReadOnly Property HasCorrelationData As Boolean
    Get
public:
property bool HasCorrelationData {
    bool get ();
}
public:
property bool HasCorrelationData {
    bool get ();
}
member HasCorrelationData : bool with get
member HasCorrelationData : bool with get

Property Value

Type: Online Boolean
See Also
Msg Class
Msg Members
NFX.Glue.Protocol Namespace


Msg.HasHeaders Property

Msg HasHeaders Property NFX Class Library

Returns true when this message contains header data

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasHeaders { get; }
public bool HasHeaders { get; }
Public ReadOnly Property HasHeaders As Boolean
    Get
Public ReadOnly Property HasHeaders As Boolean
    Get
public:
property bool HasHeaders {
    bool get ();
}
public:
property bool HasHeaders {
    bool get ();
}
member HasHeaders : bool with get
member HasHeaders : bool with get

Property Value

Type: Online Boolean
See Also
Msg Class
Msg Members
NFX.Glue.Protocol Namespace


Msg.Headers Property

Msg Headers Property NFX Class Library

Returns a list of headers that this message contains

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Headers Headers { get; set; }
public Headers Headers { get; set; }
Public Property Headers As Headers
    Get
    Set
Public Property Headers As Headers
    Get
    Set
public:
property Headers^ Headers {
    Headers^ get ();
    void set (Headers^ value);
}
public:
property Headers^ Headers {
    Headers^ get ();
    void set (Headers^ value);
}
member Headers : Headers with get, set
member Headers : Headers with get, set

Property Value

Type: Headers
See Also
Msg Class
Msg Members
NFX.Glue.Protocol Namespace


Msg.ID Property

Msg ID Property NFX Class Library

Returns a unique ID for this message

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FID ID { get; }
public FID ID { get; }
Public ReadOnly Property ID As FID
    Get
Public ReadOnly Property ID As FID
    Get
public:
property FID ID {
    FID get ();
}
public:
property FID ID {
    FID get ();
}
member ID : FID with get
member ID : FID with get

Property Value

Type: FID
See Also
Msg Class
Msg Members
NFX.Glue.Protocol Namespace


Msg.RequestID Property

Msg RequestID Property NFX Class Library

Returns request ID that relates to this message instance. It is the message ID for RequestMsg and related message ID for ResponseMsg

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract FID RequestID { get; }
public abstract FID RequestID { get; }
Public MustOverride ReadOnly Property RequestID As FID
    Get
Public MustOverride ReadOnly Property RequestID As FID
    Get
public:
virtual property FID RequestID {
    FID get () abstract;
}
public:
virtual property FID RequestID {
    FID get () abstract;
}
abstract RequestID : FID with get
abstract RequestID : FID with get

Property Value

Type: FID
See Also
Msg Class
Msg Members
NFX.Glue.Protocol Namespace


RequestAnyMsg Class

RequestAnyMsg Class NFX Class Library

Represents request msg that marshalls arguments as object[]. Although the most convenient and simple, this way of working with glue is slower than using RequestTypedMsg which needs to be derived-from for every method
Inheritance Hierarchy
Online System Object
NFX.Glue.Protocol Msg
NFX.Glue.Protocol RequestMsg
NFX.Glue.Protocol RequestAnyMsg

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class RequestAnyMsg : RequestMsg
public sealed class RequestAnyMsg : RequestMsg
Public NotInheritable Class RequestAnyMsg
    Inherits RequestMsg
Public NotInheritable Class RequestAnyMsg
    Inherits RequestMsg
public ref class RequestAnyMsg sealed : public RequestMsg
public ref class RequestAnyMsg sealed : public RequestMsg
[<SealedAttribute>]
type RequestAnyMsg =
    class
        inherit RequestMsg
    end
[<SealedAttribute>]
type RequestAnyMsg =
    class
        inherit RequestMsg
    end
See Also
RequestAnyMsg Members
NFX.Glue.Protocol Namespace


RequestAnyMsg Members

RequestAnyMsg Members NFX Class Library

The RequestAnyMsg type exposes the following members.
Constructors
 | Name | Description
Public method | RequestAnyMsg(MethodInfo, Nullable Guid , Object ) | Constructs request message from method information and arguments for call invocation. This constructor is slower as it uses reflection
Public method | RequestAnyMsg(TypeSpec, MethodSpec, Boolean, Nullable Guid , Object ) | Constructs request message from pre-computed specs obtained by reflection. This constructor is the fastest as it does not use reflection
Public method | RequestAnyMsg(RequestMsg, MethodInfo, Nullable Guid , Object , Boolean, Boolean) | This .ctor is handy for message inspectors. Creates a substitute message for the original one with new values. Binding-specific context is cloned and headers/correlation data are cloned conditionaly
Public method | RequestAnyMsg(RequestMsg, TypeSpec, MethodSpec, Boolean, Nullable Guid , Object , Boolean, Boolean) | This .ctor is handy for message inspectors. Creates a substitute message for the original one with new values. Binding-specific context is cloned and headers/correlation data are cloned conditionaly
Back to Top
Methods
 | Name | Description
Public method | __SetArrivalTimeStampTicks | Framework method not for developers. Sets arrival ticks stamp. Usually called from transport (Inherited from Msg.)
Public method | __SetBindingSpecificContext(Object) | Internal method not to be called by app developers. Called from custom bindings to inject binding-specific context (Inherited from Msg.)
Public method | __SetBindingSpecificContext(Msg) | Internal method not to be called by app developers. Called from custom bindings to inject binding-specific context (Inherited from Msg.)
Public method | __setServerTransport | Implementation-specific internal method not to be used by developers (Inherited from RequestMsg.)
Public method | CloneState | Clones message state from another message instance. State includes binding-specific context and optionally headers and correlation data (Inherited from Msg.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from Msg.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Headers | (Inherited from Msg.)
Protected field | m_ID | (Inherited from Msg.)
Protected field | m_ServerTransport | (Inherited from RequestMsg.)
Back to Top
Properties
 | Name | Description
Public property | Arguments | Returns call arguments
Public property | ArrivalTimeStamp | Returns arrival timestamp expressed in ticks, that is - when message just arrived before its processing started by Glue (before deserialization). This property allows for glue-internal latency assessment (Inherited from Msg.)
Public property | BindingSpecificContext | Returns a binding-specific context object which is used for message processing/routing by binding. This property value is not serialized and used internally by Glue framework. Not all bindings use/need this property (Inherited from Msg.)
Public property | Contract | Returns contract type that this call belongs to. This property throws if actual specified type can not be found (Inherited from RequestMsg.)
Public property | ContractSpec | Returns contract type spec that this call belongs to (Inherited from RequestMsg.)
Public property | CorrelationData | Arbitrary named object collection that can be used to correlate messages and/or attach extra data. This field is NOT transmitted over wire nor is it used by the framework. Message inspectors may use this property at their own discretion, for example in cases when the same inspector type is registered on multiple levels (endpoint, binding, glue), inspectors may check this property to execute only once per message. The collection is lazily allocated at the first reference attempt (Inherited from Msg.)
Public property | HasCorrelationData | Returns true when this message contains header data (Inherited from Msg.)
Public property | HasHeaders | Returns true when this message contains header data (Inherited from Msg.)
Public property | Headers | Returns a list of headers that this message contains (Inherited from Msg.)
Public property | ID | Returns a unique ID for this message (Inherited from Msg.)
Public property | Method | Gets a method specification to be invoked on the other side (Inherited from RequestMsg.)
Public property | MethodName | Gets a name of method to be invoked on the other side (Inherited from RequestMsg.)
Public property | OneWay | Indicates that no response is expected (Inherited from RequestMsg.)
Public property | RemoteInstance | If server is stateful then this property contains remote instance ID (Inherited from RequestMsg.)
Public property | RequestID | Returns request ID for this instance. Every request is uniquely identified (Inherited from RequestMsg.)
Public property | ServerTransport | Returns transport that this request arrived through. Property is to be used only on server (Inherited from RequestMsg.)
Public property | Session | Session reference that can be used to pass session object that was already determined by transport (i.e. HttpServerTransport) into Glue server handler. This property is NOT transmitted/serialized over wire (Inherited from RequestMsg.)
Back to Top
See Also
RequestAnyMsg Class
NFX.Glue.Protocol Namespace


RequestAnyMsg Constructor

RequestAnyMsg Constructor NFX Class Library

Overload List
 | Name | Description
Public method | RequestAnyMsg(MethodInfo, Nullable Guid , Object ) | Constructs request message from method information and arguments for call invocation. This constructor is slower as it uses reflection
Public method | RequestAnyMsg(TypeSpec, MethodSpec, Boolean, Nullable Guid , Object ) | Constructs request message from pre-computed specs obtained by reflection. This constructor is the fastest as it does not use reflection
Public method | RequestAnyMsg(RequestMsg, MethodInfo, Nullable Guid , Object , Boolean, Boolean) | This .ctor is handy for message inspectors. Creates a substitute message for the original one with new values. Binding-specific context is cloned and headers/correlation data are cloned conditionaly
Public method | RequestAnyMsg(RequestMsg, TypeSpec, MethodSpec, Boolean, Nullable Guid , Object , Boolean, Boolean) | This .ctor is handy for message inspectors. Creates a substitute message for the original one with new values. Binding-specific context is cloned and headers/correlation data are cloned conditionaly
Back to Top
See Also
RequestAnyMsg Class
RequestAnyMsg Members
NFX.Glue.Protocol Namespace


RequestAnyMsg Constructor (MethodInfo, Nullable(Guid), Object[])

RequestAnyMsg Constructor (MethodInfo, Nullable Guid , Object ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Constructs request message from method information and arguments for call invocation. This constructor is slower as it uses reflection

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RequestAnyMsg(
    MethodInfo method,
    Nullable<Guid> instance,
    Object[] args
)
public RequestAnyMsg(
    MethodInfo method,
    Nullable<Guid> instance,
    Object[] args
)
Public Sub New (
    method As MethodInfo,
    instance As Nullable(Of Guid),
    args As Object()
)
Public Sub New (
    method As MethodInfo,
    instance As Nullable(Of Guid),
    args As Object()
)
public:
RequestAnyMsg(
    MethodInfo^ method,
    Nullable<Guid> instance,
    array<Object^>^ args
)
public:
RequestAnyMsg(
    MethodInfo^ method,
    Nullable<Guid> instance,
    array<Object^>^ args
)
new :
        method : MethodInfo *
        instance : Nullable<Guid> *
        args : Object[] -> RequestAnyMsg
new :
        method : MethodInfo *
        instance : Nullable<Guid> *
        args : Object[] -> RequestAnyMsg

Parameters

method
Type: Online System.Reflection MethodInfo
instance
Type: Online System Nullable Online Guid
args
Type: Online System Object
See Also
RequestAnyMsg Class
RequestAnyMsg Members
RequestAnyMsg Overload
NFX.Glue.Protocol Namespace


RequestAnyMsg Constructor (TypeSpec, MethodSpec, Boolean, Nullable(Guid), Object[])

RequestAnyMsg Constructor (TypeSpec, MethodSpec, Boolean, Nullable Guid , Object ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Constructs request message from pre-computed specs obtained by reflection. This constructor is the fastest as it does not use reflection

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RequestAnyMsg(
    TypeSpec contract,
    MethodSpec method,
    bool oneWay,
    Nullable<Guid> instance,
    Object[] args
)
public RequestAnyMsg(
    TypeSpec contract,
    MethodSpec method,
    bool oneWay,
    Nullable<Guid> instance,
    Object[] args
)
Public Sub New (
    contract As TypeSpec,
    method As MethodSpec,
    oneWay As Boolean,
    instance As Nullable(Of Guid),
    args As Object()
)
Public Sub New (
    contract As TypeSpec,
    method As MethodSpec,
    oneWay As Boolean,
    instance As Nullable(Of Guid),
    args As Object()
)
public:
RequestAnyMsg(
    TypeSpec contract,
    MethodSpec method,
    bool oneWay,
    Nullable<Guid> instance,
    array<Object^>^ args
)
public:
RequestAnyMsg(
    TypeSpec contract,
    MethodSpec method,
    bool oneWay,
    Nullable<Guid> instance,
    array<Object^>^ args
)
new :
        contract : TypeSpec *
        method : MethodSpec *
        oneWay : bool *
        instance : Nullable<Guid> *
        args : Object[] -> RequestAnyMsg
new :
        contract : TypeSpec *
        method : MethodSpec *
        oneWay : bool *
        instance : Nullable<Guid> *
        args : Object[] -> RequestAnyMsg

Parameters

contract
Type: NFX.Glue.Protocol TypeSpec
method
Type: NFX.Glue.Protocol MethodSpec
oneWay
Type: Online System Boolean
instance
Type: Online System Nullable Online Guid
args
Type: Online System Object
See Also
RequestAnyMsg Class
RequestAnyMsg Members
RequestAnyMsg Overload
NFX.Glue.Protocol Namespace


RequestAnyMsg Constructor (RequestMsg, MethodInfo, Nullable(Guid), Object[], Boolean, Boolean)

RequestAnyMsg Constructor (RequestMsg, MethodInfo, Nullable Guid , Object , Boolean, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

This .ctor is handy for message inspectors. Creates a substitute message for the original one with new values. Binding-specific context is cloned and headers/correlation data are cloned conditionaly

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RequestAnyMsg(
    RequestMsg inspectedOriginal,
    MethodInfo method,
    Nullable<Guid> instance,
    Object[] args,
    bool cloneHeaders = true,
    bool cloneCorrelation = true
)
public RequestAnyMsg(
    RequestMsg inspectedOriginal,
    MethodInfo method,
    Nullable<Guid> instance,
    Object[] args,
    bool cloneHeaders = true,
    bool cloneCorrelation = true
)
Public Sub New (
    inspectedOriginal As RequestMsg,
    method As MethodInfo,
    instance As Nullable(Of Guid),
    args As Object(),
    Optional cloneHeaders As Boolean = true,
    Optional cloneCorrelation As Boolean = true
)
Public Sub New (
    inspectedOriginal As RequestMsg,
    method As MethodInfo,
    instance As Nullable(Of Guid),
    args As Object(),
    Optional cloneHeaders As Boolean = true,
    Optional cloneCorrelation As Boolean = true
)
public:
RequestAnyMsg(
    RequestMsg^ inspectedOriginal,
    MethodInfo^ method,
    Nullable<Guid> instance,
    array<Object^>^ args,
    bool cloneHeaders = true,
    bool cloneCorrelation = true
)
public:
RequestAnyMsg(
    RequestMsg^ inspectedOriginal,
    MethodInfo^ method,
    Nullable<Guid> instance,
    array<Object^>^ args,
    bool cloneHeaders = true,
    bool cloneCorrelation = true
)
new :
        inspectedOriginal : RequestMsg *
        method : MethodInfo *
        instance : Nullable<Guid> *
        args : Object[] *
        ?cloneHeaders : bool *
        ?cloneCorrelation : bool
(* Defaults:
        let _cloneHeaders = defaultArg cloneHeaders true
        let _cloneCorrelation = defaultArg cloneCorrelation true
*)
-> RequestAnyMsg
new :
        inspectedOriginal : RequestMsg *
        method : MethodInfo *
        instance : Nullable<Guid> *
        args : Object[] *
        ?cloneHeaders : bool *
        ?cloneCorrelation : bool
(* Defaults:
        let _cloneHeaders = defaultArg cloneHeaders true
        let _cloneCorrelation = defaultArg cloneCorrelation true
*)
-> RequestAnyMsg

Parameters

inspectedOriginal
Type: NFX.Glue.Protocol RequestMsg
method
Type: Online System.Reflection MethodInfo
instance
Type: Online System Nullable Online Guid
args
Type: Online System Object
cloneHeaders (Optional)
Type: Online System Boolean
cloneCorrelation (Optional)
Type: Online System Boolean
See Also
RequestAnyMsg Class
RequestAnyMsg Members
RequestAnyMsg Overload
NFX.Glue.Protocol Namespace


RequestAnyMsg Constructor (RequestMsg, TypeSpec, MethodSpec, Boolean, Nullable(Guid), Object[], Boolean, Boolean)

RequestAnyMsg Constructor (RequestMsg, TypeSpec, MethodSpec, Boolean, Nullable Guid , Object , Boolean, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

This .ctor is handy for message inspectors. Creates a substitute message for the original one with new values. Binding-specific context is cloned and headers/correlation data are cloned conditionaly

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RequestAnyMsg(
    RequestMsg inspectedOriginal,
    TypeSpec contract,
    MethodSpec method,
    bool oneWay,
    Nullable<Guid> instance,
    Object[] args,
    bool cloneHeaders = true,
    bool cloneCorrelation = true
)
public RequestAnyMsg(
    RequestMsg inspectedOriginal,
    TypeSpec contract,
    MethodSpec method,
    bool oneWay,
    Nullable<Guid> instance,
    Object[] args,
    bool cloneHeaders = true,
    bool cloneCorrelation = true
)
Public Sub New (
    inspectedOriginal As RequestMsg,
    contract As TypeSpec,
    method As MethodSpec,
    oneWay As Boolean,
    instance As Nullable(Of Guid),
    args As Object(),
    Optional cloneHeaders As Boolean = true,
    Optional cloneCorrelation As Boolean = true
)
Public Sub New (
    inspectedOriginal As RequestMsg,
    contract As TypeSpec,
    method As MethodSpec,
    oneWay As Boolean,
    instance As Nullable(Of Guid),
    args As Object(),
    Optional cloneHeaders As Boolean = true,
    Optional cloneCorrelation As Boolean = true
)
public:
RequestAnyMsg(
    RequestMsg^ inspectedOriginal,
    TypeSpec contract,
    MethodSpec method,
    bool oneWay,
    Nullable<Guid> instance,
    array<Object^>^ args,
    bool cloneHeaders = true,
    bool cloneCorrelation = true
)
public:
RequestAnyMsg(
    RequestMsg^ inspectedOriginal,
    TypeSpec contract,
    MethodSpec method,
    bool oneWay,
    Nullable<Guid> instance,
    array<Object^>^ args,
    bool cloneHeaders = true,
    bool cloneCorrelation = true
)
new :
        inspectedOriginal : RequestMsg *
        contract : TypeSpec *
        method : MethodSpec *
        oneWay : bool *
        instance : Nullable<Guid> *
        args : Object[] *
        ?cloneHeaders : bool *
        ?cloneCorrelation : bool
(* Defaults:
        let _cloneHeaders = defaultArg cloneHeaders true
        let _cloneCorrelation = defaultArg cloneCorrelation true
*)
-> RequestAnyMsg
new :
        inspectedOriginal : RequestMsg *
        contract : TypeSpec *
        method : MethodSpec *
        oneWay : bool *
        instance : Nullable<Guid> *
        args : Object[] *
        ?cloneHeaders : bool *
        ?cloneCorrelation : bool
(* Defaults:
        let _cloneHeaders = defaultArg cloneHeaders true
        let _cloneCorrelation = defaultArg cloneCorrelation true
*)
-> RequestAnyMsg

Parameters

inspectedOriginal
Type: NFX.Glue.Protocol RequestMsg
contract
Type: NFX.Glue.Protocol TypeSpec
method
Type: NFX.Glue.Protocol MethodSpec
oneWay
Type: Online System Boolean
instance
Type: Online System Nullable Online Guid
args
Type: Online System Object
cloneHeaders (Optional)
Type: Online System Boolean
cloneCorrelation (Optional)
Type: Online System Boolean
See Also
RequestAnyMsg Class
RequestAnyMsg Members
RequestAnyMsg Overload
NFX.Glue.Protocol Namespace


RequestAnyMsg Fields

RequestAnyMsg Fields NFX Class Library

The RequestAnyMsg type exposes the following members.
Fields
 | Name | Description
Protected field | m_Headers | (Inherited from Msg.)
Protected field | m_ID | (Inherited from Msg.)
Protected field | m_ServerTransport | (Inherited from RequestMsg.)
Back to Top
See Also
RequestAnyMsg Class
NFX.Glue.Protocol Namespace


RequestAnyMsg Methods

RequestAnyMsg Methods NFX Class Library

The RequestAnyMsg type exposes the following members.
Methods
 | Name | Description
Public method | __SetArrivalTimeStampTicks | Framework method not for developers. Sets arrival ticks stamp. Usually called from transport (Inherited from Msg.)
Public method | __SetBindingSpecificContext(Object) | Internal method not to be called by app developers. Called from custom bindings to inject binding-specific context (Inherited from Msg.)
Public method | __SetBindingSpecificContext(Msg) | Internal method not to be called by app developers. Called from custom bindings to inject binding-specific context (Inherited from Msg.)
Public method | __setServerTransport | Implementation-specific internal method not to be used by developers (Inherited from RequestMsg.)
Public method | CloneState | Clones message state from another message instance. State includes binding-specific context and optionally headers and correlation data (Inherited from Msg.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from Msg.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
RequestAnyMsg Class
NFX.Glue.Protocol Namespace


RequestAnyMsg Properties

RequestAnyMsg Properties NFX Class Library

The RequestAnyMsg type exposes the following members.
Properties
 | Name | Description
Public property | Arguments | Returns call arguments
Public property | ArrivalTimeStamp | Returns arrival timestamp expressed in ticks, that is - when message just arrived before its processing started by Glue (before deserialization). This property allows for glue-internal latency assessment (Inherited from Msg.)
Public property | BindingSpecificContext | Returns a binding-specific context object which is used for message processing/routing by binding. This property value is not serialized and used internally by Glue framework. Not all bindings use/need this property (Inherited from Msg.)
Public property | Contract | Returns contract type that this call belongs to. This property throws if actual specified type can not be found (Inherited from RequestMsg.)
Public property | ContractSpec | Returns contract type spec that this call belongs to (Inherited from RequestMsg.)
Public property | CorrelationData | Arbitrary named object collection that can be used to correlate messages and/or attach extra data. This field is NOT transmitted over wire nor is it used by the framework. Message inspectors may use this property at their own discretion, for example in cases when the same inspector type is registered on multiple levels (endpoint, binding, glue), inspectors may check this property to execute only once per message. The collection is lazily allocated at the first reference attempt (Inherited from Msg.)
Public property | HasCorrelationData | Returns true when this message contains header data (Inherited from Msg.)
Public property | HasHeaders | Returns true when this message contains header data (Inherited from Msg.)
Public property | Headers | Returns a list of headers that this message contains (Inherited from Msg.)
Public property | ID | Returns a unique ID for this message (Inherited from Msg.)
Public property | Method | Gets a method specification to be invoked on the other side (Inherited from RequestMsg.)
Public property | MethodName | Gets a name of method to be invoked on the other side (Inherited from RequestMsg.)
Public property | OneWay | Indicates that no response is expected (Inherited from RequestMsg.)
Public property | RemoteInstance | If server is stateful then this property contains remote instance ID (Inherited from RequestMsg.)
Public property | RequestID | Returns request ID for this instance. Every request is uniquely identified (Inherited from RequestMsg.)
Public property | ServerTransport | Returns transport that this request arrived through. Property is to be used only on server (Inherited from RequestMsg.)
Public property | Session | Session reference that can be used to pass session object that was already determined by transport (i.e. HttpServerTransport) into Glue server handler. This property is NOT transmitted/serialized over wire (Inherited from RequestMsg.)
Back to Top
See Also
RequestAnyMsg Class
NFX.Glue.Protocol Namespace


RequestAnyMsg.Arguments Property

RequestAnyMsg Arguments Property NFX Class Library

Returns call arguments

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object[] Arguments { get; }
public Object[] Arguments { get; }
Public ReadOnly Property Arguments As Object()
    Get
Public ReadOnly Property Arguments As Object()
    Get
public:
property array<Object^>^ Arguments {
    array<Object^>^ get ();
}
public:
property array<Object^>^ Arguments {
    array<Object^>^ get ();
}
member Arguments : Object[] with get
member Arguments : Object[] with get

Property Value

Type: Online Object
See Also
RequestAnyMsg Class
RequestAnyMsg Members
NFX.Glue.Protocol Namespace


RequestMsg Class

RequestMsg Class NFX Class Library

This message is sent from client to server and contains contract type, method specification and invocation arguments which are either included as object[] if RequestAnyMsg is used or inlined in RequestMsg- typed derivative for speed to avoid boxing
Inheritance Hierarchy
Online System Object
NFX.Glue.Protocol Msg
NFX.Glue.Protocol RequestMsg
NFX.Glue.Protocol RequestAnyMsg

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class RequestMsg : Msg
[SerializableAttribute]
public abstract class RequestMsg : Msg
<SerializableAttribute>
Public MustInherit Class RequestMsg
    Inherits Msg
<SerializableAttribute>
Public MustInherit Class RequestMsg
    Inherits Msg
[SerializableAttribute]
public ref class RequestMsg abstract : public Msg
[SerializableAttribute]
public ref class RequestMsg abstract : public Msg
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type RequestMsg =
    class
        inherit Msg
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type RequestMsg =
    class
        inherit Msg
    end
See Also
RequestMsg Members
NFX.Glue.Protocol Namespace


RequestMsg Members

RequestMsg Members NFX Class Library

The RequestMsg type exposes the following members.
Constructors
 | Name | Description
Protected method | RequestMsg(MethodInfo, Nullable Guid ) | Constructs request message from method information and arguments for call invocation. This constructor is slower as it uses reflection
Protected method | RequestMsg(TypeSpec, MethodSpec, Boolean, Nullable Guid ) | Constructs request message from pre-computed specs obtained by reflection. This constructor is the fastest as it does not use reflection
Protected method | RequestMsg(RequestMsg, MethodInfo, Nullable Guid , Boolean, Boolean) | This .ctor is handy for message inspectors. Creates a substitute message for the original one with new values. Binding-specific context is cloned and headers/correlation data are cloned conditionaly
Protected method | RequestMsg(RequestMsg, TypeSpec, MethodSpec, Boolean, Nullable Guid , Boolean, Boolean) | This .ctor is handy for message inspectors. Creates a substitute message for the original one with new values. Binding-specific context is cloned and headers/correlation data are cloned conditionaly
Back to Top
Methods
 | Name | Description
Public method | __SetArrivalTimeStampTicks | Framework method not for developers. Sets arrival ticks stamp. Usually called from transport (Inherited from Msg.)
Public method | __SetBindingSpecificContext(Object) | Internal method not to be called by app developers. Called from custom bindings to inject binding-specific context (Inherited from Msg.)
Public method | __SetBindingSpecificContext(Msg) | Internal method not to be called by app developers. Called from custom bindings to inject binding-specific context (Inherited from Msg.)
Public method | __setServerTransport | Implementation-specific internal method not to be used by developers
Public method | CloneState | Clones message state from another message instance. State includes binding-specific context and optionally headers and correlation data (Inherited from Msg.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from Msg.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Headers | (Inherited from Msg.)
Protected field | m_ID | (Inherited from Msg.)
Protected field | m_ServerTransport |
Back to Top
Properties
 | Name | Description
Public property | ArrivalTimeStamp | Returns arrival timestamp expressed in ticks, that is - when message just arrived before its processing started by Glue (before deserialization). This property allows for glue-internal latency assessment (Inherited from Msg.)
Public property | BindingSpecificContext | Returns a binding-specific context object which is used for message processing/routing by binding. This property value is not serialized and used internally by Glue framework. Not all bindings use/need this property (Inherited from Msg.)
Public property | Contract | Returns contract type that this call belongs to. This property throws if actual specified type can not be found
Public property | ContractSpec | Returns contract type spec that this call belongs to
Public property | CorrelationData | Arbitrary named object collection that can be used to correlate messages and/or attach extra data. This field is NOT transmitted over wire nor is it used by the framework. Message inspectors may use this property at their own discretion, for example in cases when the same inspector type is registered on multiple levels (endpoint, binding, glue), inspectors may check this property to execute only once per message. The collection is lazily allocated at the first reference attempt (Inherited from Msg.)
Public property | HasCorrelationData | Returns true when this message contains header data (Inherited from Msg.)
Public property | HasHeaders | Returns true when this message contains header data (Inherited from Msg.)
Public property | Headers | Returns a list of headers that this message contains (Inherited from Msg.)
Public property | ID | Returns a unique ID for this message (Inherited from Msg.)
Public property | Method | Gets a method specification to be invoked on the other side
Public property | MethodName | Gets a name of method to be invoked on the other side
Public property | OneWay | Indicates that no response is expected
Public property | RemoteInstance | If server is stateful then this property contains remote instance ID
Public property | RequestID | Returns request ID for this instance. Every request is uniquely identified (Overrides Msg RequestID.)
Public property | ServerTransport | Returns transport that this request arrived through. Property is to be used only on server
Public property | Session | Session reference that can be used to pass session object that was already determined by transport (i.e. HttpServerTransport) into Glue server handler. This property is NOT transmitted/serialized over wire
Back to Top
See Also
RequestMsg Class
NFX.Glue.Protocol Namespace


RequestMsg Constructor

RequestMsg Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | RequestMsg(MethodInfo, Nullable Guid ) | Constructs request message from method information and arguments for call invocation. This constructor is slower as it uses reflection
Protected method | RequestMsg(TypeSpec, MethodSpec, Boolean, Nullable Guid ) | Constructs request message from pre-computed specs obtained by reflection. This constructor is the fastest as it does not use reflection
Protected method | RequestMsg(RequestMsg, MethodInfo, Nullable Guid , Boolean, Boolean) | This .ctor is handy for message inspectors. Creates a substitute message for the original one with new values. Binding-specific context is cloned and headers/correlation data are cloned conditionaly
Protected method | RequestMsg(RequestMsg, TypeSpec, MethodSpec, Boolean, Nullable Guid , Boolean, Boolean) | This .ctor is handy for message inspectors. Creates a substitute message for the original one with new values. Binding-specific context is cloned and headers/correlation data are cloned conditionaly
Back to Top
See Also
RequestMsg Class
RequestMsg Members
NFX.Glue.Protocol Namespace


RequestMsg Constructor (MethodInfo, Nullable(Guid))

RequestMsg Constructor (MethodInfo, Nullable Guid ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Constructs request message from method information and arguments for call invocation. This constructor is slower as it uses reflection

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected RequestMsg(
    MethodInfo method,
    Nullable<Guid> instance
)
protected RequestMsg(
    MethodInfo method,
    Nullable<Guid> instance
)
Protected Sub New (
    method As MethodInfo,
    instance As Nullable(Of Guid)
)
Protected Sub New (
    method As MethodInfo,
    instance As Nullable(Of Guid)
)
protected:
RequestMsg(
    MethodInfo^ method,
    Nullable<Guid> instance
)
protected:
RequestMsg(
    MethodInfo^ method,
    Nullable<Guid> instance
)
new :
        method : MethodInfo *
        instance : Nullable<Guid> -> RequestMsg
new :
        method : MethodInfo *
        instance : Nullable<Guid> -> RequestMsg

Parameters

method
Type: Online System.Reflection MethodInfo
instance
Type: Online System Nullable Online Guid
See Also
RequestMsg Class
RequestMsg Members
RequestMsg Overload
NFX.Glue.Protocol Namespace


RequestMsg Constructor (TypeSpec, MethodSpec, Boolean, Nullable(Guid))

RequestMsg Constructor (TypeSpec, MethodSpec, Boolean, Nullable Guid ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Constructs request message from pre-computed specs obtained by reflection. This constructor is the fastest as it does not use reflection

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected RequestMsg(
    TypeSpec contract,
    MethodSpec method,
    bool oneWay,
    Nullable<Guid> instance
)
protected RequestMsg(
    TypeSpec contract,
    MethodSpec method,
    bool oneWay,
    Nullable<Guid> instance
)
Protected Sub New (
    contract As TypeSpec,
    method As MethodSpec,
    oneWay As Boolean,
    instance As Nullable(Of Guid)
)
Protected Sub New (
    contract As TypeSpec,
    method As MethodSpec,
    oneWay As Boolean,
    instance As Nullable(Of Guid)
)
protected:
RequestMsg(
    TypeSpec contract,
    MethodSpec method,
    bool oneWay,
    Nullable<Guid> instance
)
protected:
RequestMsg(
    TypeSpec contract,
    MethodSpec method,
    bool oneWay,
    Nullable<Guid> instance
)
new :
        contract : TypeSpec *
        method : MethodSpec *
        oneWay : bool *
        instance : Nullable<Guid> -> RequestMsg
new :
        contract : TypeSpec *
        method : MethodSpec *
        oneWay : bool *
        instance : Nullable<Guid> -> RequestMsg

Parameters

contract
Type: NFX.Glue.Protocol TypeSpec
method
Type: NFX.Glue.Protocol MethodSpec
oneWay
Type: Online System Boolean
instance
Type: Online System Nullable Online Guid
See Also
RequestMsg Class
RequestMsg Members
RequestMsg Overload
NFX.Glue.Protocol Namespace


RequestMsg Constructor (RequestMsg, MethodInfo, Nullable(Guid), Boolean, Boolean)

RequestMsg Constructor (RequestMsg, MethodInfo, Nullable Guid , Boolean, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

This .ctor is handy for message inspectors. Creates a substitute message for the original one with new values. Binding-specific context is cloned and headers/correlation data are cloned conditionaly

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected RequestMsg(
    RequestMsg inspectedOriginal,
    MethodInfo method,
    Nullable<Guid> instance,
    bool cloneHeaders = true,
    bool cloneCorrelation = true
)
protected RequestMsg(
    RequestMsg inspectedOriginal,
    MethodInfo method,
    Nullable<Guid> instance,
    bool cloneHeaders = true,
    bool cloneCorrelation = true
)
Protected Sub New (
    inspectedOriginal As RequestMsg,
    method As MethodInfo,
    instance As Nullable(Of Guid),
    Optional cloneHeaders As Boolean = true,
    Optional cloneCorrelation As Boolean = true
)
Protected Sub New (
    inspectedOriginal As RequestMsg,
    method As MethodInfo,
    instance As Nullable(Of Guid),
    Optional cloneHeaders As Boolean = true,
    Optional cloneCorrelation As Boolean = true
)
protected:
RequestMsg(
    RequestMsg^ inspectedOriginal,
    MethodInfo^ method,
    Nullable<Guid> instance,
    bool cloneHeaders = true,
    bool cloneCorrelation = true
)
protected:
RequestMsg(
    RequestMsg^ inspectedOriginal,
    MethodInfo^ method,
    Nullable<Guid> instance,
    bool cloneHeaders = true,
    bool cloneCorrelation = true
)
new :
        inspectedOriginal : RequestMsg *
        method : MethodInfo *
        instance : Nullable<Guid> *
        ?cloneHeaders : bool *
        ?cloneCorrelation : bool
(* Defaults:
        let _cloneHeaders = defaultArg cloneHeaders true
        let _cloneCorrelation = defaultArg cloneCorrelation true
*)
-> RequestMsg
new :
        inspectedOriginal : RequestMsg *
        method : MethodInfo *
        instance : Nullable<Guid> *
        ?cloneHeaders : bool *
        ?cloneCorrelation : bool
(* Defaults:
        let _cloneHeaders = defaultArg cloneHeaders true
        let _cloneCorrelation = defaultArg cloneCorrelation true
*)
-> RequestMsg

Parameters

inspectedOriginal
Type: NFX.Glue.Protocol RequestMsg
method
Type: Online System.Reflection MethodInfo
instance
Type: Online System Nullable Online Guid
cloneHeaders (Optional)
Type: Online System Boolean
cloneCorrelation (Optional)
Type: Online System Boolean
See Also
RequestMsg Class
RequestMsg Members
RequestMsg Overload
NFX.Glue.Protocol Namespace


RequestMsg Constructor (RequestMsg, TypeSpec, MethodSpec, Boolean, Nullable(Guid), Boolean, Boolean)

RequestMsg Constructor (RequestMsg, TypeSpec, MethodSpec, Boolean, Nullable Guid , Boolean, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

This .ctor is handy for message inspectors. Creates a substitute message for the original one with new values. Binding-specific context is cloned and headers/correlation data are cloned conditionaly

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected RequestMsg(
    RequestMsg inspectedOriginal,
    TypeSpec contract,
    MethodSpec method,
    bool oneWay,
    Nullable<Guid> instance,
    bool cloneHeaders = true,
    bool cloneCorrelation = true
)
protected RequestMsg(
    RequestMsg inspectedOriginal,
    TypeSpec contract,
    MethodSpec method,
    bool oneWay,
    Nullable<Guid> instance,
    bool cloneHeaders = true,
    bool cloneCorrelation = true
)
Protected Sub New (
    inspectedOriginal As RequestMsg,
    contract As TypeSpec,
    method As MethodSpec,
    oneWay As Boolean,
    instance As Nullable(Of Guid),
    Optional cloneHeaders As Boolean = true,
    Optional cloneCorrelation As Boolean = true
)
Protected Sub New (
    inspectedOriginal As RequestMsg,
    contract As TypeSpec,
    method As MethodSpec,
    oneWay As Boolean,
    instance As Nullable(Of Guid),
    Optional cloneHeaders As Boolean = true,
    Optional cloneCorrelation As Boolean = true
)
protected:
RequestMsg(
    RequestMsg^ inspectedOriginal,
    TypeSpec contract,
    MethodSpec method,
    bool oneWay,
    Nullable<Guid> instance,
    bool cloneHeaders = true,
    bool cloneCorrelation = true
)
protected:
RequestMsg(
    RequestMsg^ inspectedOriginal,
    TypeSpec contract,
    MethodSpec method,
    bool oneWay,
    Nullable<Guid> instance,
    bool cloneHeaders = true,
    bool cloneCorrelation = true
)
new :
        inspectedOriginal : RequestMsg *
        contract : TypeSpec *
        method : MethodSpec *
        oneWay : bool *
        instance : Nullable<Guid> *
        ?cloneHeaders : bool *
        ?cloneCorrelation : bool
(* Defaults:
        let _cloneHeaders = defaultArg cloneHeaders true
        let _cloneCorrelation = defaultArg cloneCorrelation true
*)
-> RequestMsg
new :
        inspectedOriginal : RequestMsg *
        contract : TypeSpec *
        method : MethodSpec *
        oneWay : bool *
        instance : Nullable<Guid> *
        ?cloneHeaders : bool *
        ?cloneCorrelation : bool
(* Defaults:
        let _cloneHeaders = defaultArg cloneHeaders true
        let _cloneCorrelation = defaultArg cloneCorrelation true
*)
-> RequestMsg

Parameters

inspectedOriginal
Type: NFX.Glue.Protocol RequestMsg
contract
Type: NFX.Glue.Protocol TypeSpec
method
Type: NFX.Glue.Protocol MethodSpec
oneWay
Type: Online System Boolean
instance
Type: Online System Nullable Online Guid
cloneHeaders (Optional)
Type: Online System Boolean
cloneCorrelation (Optional)
Type: Online System Boolean
See Also
RequestMsg Class
RequestMsg Members
RequestMsg Overload
NFX.Glue.Protocol Namespace


RequestMsg Fields

RequestMsg Fields NFX Class Library

The RequestMsg type exposes the following members.
Fields
 | Name | Description
Protected field | m_Headers | (Inherited from Msg.)
Protected field | m_ID | (Inherited from Msg.)
Protected field | m_ServerTransport |
Back to Top
See Also
RequestMsg Class
NFX.Glue.Protocol Namespace


RequestMsg.m_ServerTransport Field

RequestMsg m_ServerTransport Field NFX Class Library

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[NonSerializedAttribute]
protected ServerTransport m_ServerTransport
[NonSerializedAttribute]
protected ServerTransport m_ServerTransport
<NonSerializedAttribute>
Protected m_ServerTransport As ServerTransport
<NonSerializedAttribute>
Protected m_ServerTransport As ServerTransport
protected:
[NonSerializedAttribute]
ServerTransport^ m_ServerTransport
protected:
[NonSerializedAttribute]
ServerTransport^ m_ServerTransport
[<NonSerializedAttribute>]
val mutable m_ServerTransport: ServerTransport
[<NonSerializedAttribute>]
val mutable m_ServerTransport: ServerTransport

Field Value

Type: ServerTransport
See Also
RequestMsg Class
RequestMsg Members
NFX.Glue.Protocol Namespace


RequestMsg Methods

RequestMsg Methods NFX Class Library

The RequestMsg type exposes the following members.
Methods
 | Name | Description
Public method | __SetArrivalTimeStampTicks | Framework method not for developers. Sets arrival ticks stamp. Usually called from transport (Inherited from Msg.)
Public method | __SetBindingSpecificContext(Object) | Internal method not to be called by app developers. Called from custom bindings to inject binding-specific context (Inherited from Msg.)
Public method | __SetBindingSpecificContext(Msg) | Internal method not to be called by app developers. Called from custom bindings to inject binding-specific context (Inherited from Msg.)
Public method | __setServerTransport | Implementation-specific internal method not to be used by developers
Public method | CloneState | Clones message state from another message instance. State includes binding-specific context and optionally headers and correlation data (Inherited from Msg.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from Msg.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
RequestMsg Class
NFX.Glue.Protocol Namespace


RequestMsg.__setServerTransport Method

RequestMsg __setServerTransport Method NFX Class Library

Implementation-specific internal method not to be used by developers

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void __setServerTransport(
    ServerTransport t
)
public void __setServerTransport(
    ServerTransport t
)
Public Sub __setServerTransport (
    t As ServerTransport
)
Public Sub __setServerTransport (
    t As ServerTransport
)
public:
void __setServerTransport(
    ServerTransport^ t
)
public:
void __setServerTransport(
    ServerTransport^ t
)
member __setServerTransport :
        t : ServerTransport -> unit
member __setServerTransport :
        t : ServerTransport -> unit

Parameters

t
Type: NFX.Glue ServerTransport
See Also
RequestMsg Class
RequestMsg Members
NFX.Glue.Protocol Namespace


RequestMsg Properties

RequestMsg Properties NFX Class Library

The RequestMsg type exposes the following members.
Properties
 | Name | Description
Public property | ArrivalTimeStamp | Returns arrival timestamp expressed in ticks, that is - when message just arrived before its processing started by Glue (before deserialization). This property allows for glue-internal latency assessment (Inherited from Msg.)
Public property | BindingSpecificContext | Returns a binding-specific context object which is used for message processing/routing by binding. This property value is not serialized and used internally by Glue framework. Not all bindings use/need this property (Inherited from Msg.)
Public property | Contract | Returns contract type that this call belongs to. This property throws if actual specified type can not be found
Public property | ContractSpec | Returns contract type spec that this call belongs to
Public property | CorrelationData | Arbitrary named object collection that can be used to correlate messages and/or attach extra data. This field is NOT transmitted over wire nor is it used by the framework. Message inspectors may use this property at their own discretion, for example in cases when the same inspector type is registered on multiple levels (endpoint, binding, glue), inspectors may check this property to execute only once per message. The collection is lazily allocated at the first reference attempt (Inherited from Msg.)
Public property | HasCorrelationData | Returns true when this message contains header data (Inherited from Msg.)
Public property | HasHeaders | Returns true when this message contains header data (Inherited from Msg.)
Public property | Headers | Returns a list of headers that this message contains (Inherited from Msg.)
Public property | ID | Returns a unique ID for this message (Inherited from Msg.)
Public property | Method | Gets a method specification to be invoked on the other side
Public property | MethodName | Gets a name of method to be invoked on the other side
Public property | OneWay | Indicates that no response is expected
Public property | RemoteInstance | If server is stateful then this property contains remote instance ID
Public property | RequestID | Returns request ID for this instance. Every request is uniquely identified (Overrides Msg RequestID.)
Public property | ServerTransport | Returns transport that this request arrived through. Property is to be used only on server
Public property | Session | Session reference that can be used to pass session object that was already determined by transport (i.e. HttpServerTransport) into Glue server handler. This property is NOT transmitted/serialized over wire
Back to Top
See Also
RequestMsg Class
NFX.Glue.Protocol Namespace


RequestMsg.Contract Property

RequestMsg Contract Property NFX Class Library

Returns contract type that this call belongs to. This property throws if actual specified type can not be found

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Type Contract { get; }
public Type Contract { get; }
Public ReadOnly Property Contract As Type
    Get
Public ReadOnly Property Contract As Type
    Get
public:
property Type^ Contract {
    Type^ get ();
}
public:
property Type^ Contract {
    Type^ get ();
}
member Contract : Type with get
member Contract : Type with get

Property Value

Type: Online Type
See Also
RequestMsg Class
RequestMsg Members
NFX.Glue.Protocol Namespace


RequestMsg.ContractSpec Property

RequestMsg ContractSpec Property NFX Class Library

Returns contract type spec that this call belongs to

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TypeSpec ContractSpec { get; }
public TypeSpec ContractSpec { get; }
Public ReadOnly Property ContractSpec As TypeSpec
    Get
Public ReadOnly Property ContractSpec As TypeSpec
    Get
public:
property TypeSpec ContractSpec {
    TypeSpec get ();
}
public:
property TypeSpec ContractSpec {
    TypeSpec get ();
}
member ContractSpec : TypeSpec with get
member ContractSpec : TypeSpec with get

Property Value

Type: TypeSpec
See Also
RequestMsg Class
RequestMsg Members
NFX.Glue.Protocol Namespace


RequestMsg.Method Property

RequestMsg Method Property NFX Class Library

Gets a method specification to be invoked on the other side

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MethodSpec Method { get; }
public MethodSpec Method { get; }
Public ReadOnly Property Method As MethodSpec
    Get
Public ReadOnly Property Method As MethodSpec
    Get
public:
property MethodSpec Method {
    MethodSpec get ();
}
public:
property MethodSpec Method {
    MethodSpec get ();
}
member Method : MethodSpec with get
member Method : MethodSpec with get

Property Value

Type: MethodSpec
See Also
RequestMsg Class
RequestMsg Members
NFX.Glue.Protocol Namespace


RequestMsg.MethodName Property

RequestMsg MethodName Property NFX Class Library

Gets a name of method to be invoked on the other side

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MethodName { get; }
public string MethodName { get; }
Public ReadOnly Property MethodName As String
    Get
Public ReadOnly Property MethodName As String
    Get
public:
property String^ MethodName {
    String^ get ();
}
public:
property String^ MethodName {
    String^ get ();
}
member MethodName : string with get
member MethodName : string with get

Property Value

Type: Online String
See Also
RequestMsg Class
RequestMsg Members
NFX.Glue.Protocol Namespace


RequestMsg.OneWay Property

RequestMsg OneWay Property NFX Class Library

Indicates that no response is expected

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool OneWay { get; }
public bool OneWay { get; }
Public ReadOnly Property OneWay As Boolean
    Get
Public ReadOnly Property OneWay As Boolean
    Get
public:
property bool OneWay {
    bool get ();
}
public:
property bool OneWay {
    bool get ();
}
member OneWay : bool with get
member OneWay : bool with get

Property Value

Type: Online Boolean
See Also
RequestMsg Class
RequestMsg Members
NFX.Glue.Protocol Namespace


RequestMsg.RemoteInstance Property

RequestMsg RemoteInstance Property NFX Class Library

If server is stateful then this property contains remote instance ID

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<Guid> RemoteInstance { get; }
public Nullable<Guid> RemoteInstance { get; }
Public ReadOnly Property RemoteInstance As Nullable(Of Guid)
    Get
Public ReadOnly Property RemoteInstance As Nullable(Of Guid)
    Get
public:
property Nullable<Guid> RemoteInstance {
    Nullable<Guid> get ();
}
public:
property Nullable<Guid> RemoteInstance {
    Nullable<Guid> get ();
}
member RemoteInstance : Nullable<Guid> with get
member RemoteInstance : Nullable<Guid> with get

Property Value

Type: Online Nullable Online Guid
See Also
RequestMsg Class
RequestMsg Members
NFX.Glue.Protocol Namespace


RequestMsg.RequestID Property

RequestMsg RequestID Property NFX Class Library

Returns request ID for this instance. Every request is uniquely identified

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override FID RequestID { get; }
public override FID RequestID { get; }
Public Overrides ReadOnly Property RequestID As FID
    Get
Public Overrides ReadOnly Property RequestID As FID
    Get
public:
virtual property FID RequestID {
    FID get () override;
}
public:
virtual property FID RequestID {
    FID get () override;
}
abstract RequestID : FID with get
override RequestID : FID with get
abstract RequestID : FID with get
override RequestID : FID with get

Property Value

Type: FID
See Also
RequestMsg Class
RequestMsg Members
NFX.Glue.Protocol Namespace


RequestMsg.ServerTransport Property

RequestMsg ServerTransport Property NFX Class Library

Returns transport that this request arrived through. Property is to be used only on server

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ServerTransport ServerTransport { get; }
public ServerTransport ServerTransport { get; }
Public ReadOnly Property ServerTransport As ServerTransport
    Get
Public ReadOnly Property ServerTransport As ServerTransport
    Get
public:
property ServerTransport^ ServerTransport {
    ServerTransport^ get ();
}
public:
property ServerTransport^ ServerTransport {
    ServerTransport^ get ();
}
member ServerTransport : ServerTransport with get
member ServerTransport : ServerTransport with get

Property Value

Type: ServerTransport
See Also
RequestMsg Class
RequestMsg Members
NFX.Glue.Protocol Namespace


RequestMsg.Session Property

RequestMsg Session Property NFX Class Library

Session reference that can be used to pass session object that was already determined by transport (i.e. HttpServerTransport) into Glue server handler. This property is NOT transmitted/serialized over wire

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ISession Session { get; set; }
public ISession Session { get; set; }
Public Property Session As ISession
    Get
    Set
Public Property Session As ISession
    Get
    Set
public:
property ISession^ Session {
    ISession^ get ();
    void set (ISession^ value);
}
public:
property ISession^ Session {
    ISession^ get ();
    void set (ISession^ value);
}
member Session : ISession with get, set
member Session : ISession with get, set

Property Value

Type: ISession
See Also
RequestMsg Class
RequestMsg Members
NFX.Glue.Protocol Namespace


ResponseMsg Class

ResponseMsg Class NFX Class Library

Represents a response message sent by called party
Inheritance Hierarchy
Online System Object
NFX.Glue.Protocol Msg
NFX.Glue.Protocol ResponseMsg

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class ResponseMsg : Msg
[SerializableAttribute]
public sealed class ResponseMsg : Msg
<SerializableAttribute>
Public NotInheritable Class ResponseMsg
    Inherits Msg
<SerializableAttribute>
Public NotInheritable Class ResponseMsg
    Inherits Msg
[SerializableAttribute]
public ref class ResponseMsg sealed : public Msg
[SerializableAttribute]
public ref class ResponseMsg sealed : public Msg
[<SealedAttribute>]
[<SerializableAttribute>]
type ResponseMsg =
    class
        inherit Msg
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type ResponseMsg =
    class
        inherit Msg
    end
See Also
ResponseMsg Members
NFX.Glue.Protocol Namespace


ResponseMsg Members

ResponseMsg Members NFX Class Library

The ResponseMsg type exposes the following members.
Constructors
 | Name | Description
Public method | ResponseMsg(FID, Object) | Initializes a new instance of the ResponseMsg class
Public method | ResponseMsg(FID, Nullable Guid , Object) | Initializes a new instance of the ResponseMsg class
Public method | ResponseMsg(ResponseMsg, Object, Boolean, Boolean) | This .ctor is handy for message inspectors. Creates a substitute message for the original one with new value. Binding-specific context is cloned and headers/correlation data are cloned conditionaly
Back to Top
Methods
 | Name | Description
Public method | __SetArrivalTimeStampTicks | Framework method not for developers. Sets arrival ticks stamp. Usually called from transport (Inherited from Msg.)
Public method | __SetBindingSpecificContext(Object) | Internal method not to be called by app developers. Called from custom bindings to inject binding-specific context (Inherited from Msg.)
Public method | __SetBindingSpecificContext(Msg) | Internal method not to be called by app developers. Called from custom bindings to inject binding-specific context (Inherited from Msg.)
Public method | CloneState | Clones message state from another message instance. State includes binding-specific context and optionally headers and correlation data (Inherited from Msg.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from Msg.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Headers | (Inherited from Msg.)
Protected field | m_ID | (Inherited from Msg.)
Back to Top
Properties
 | Name | Description
Public property | ArrivalTimeStamp | Returns arrival timestamp expressed in ticks, that is - when message just arrived before its processing started by Glue (before deserialization). This property allows for glue-internal latency assessment (Inherited from Msg.)
Public property | BindingSpecificContext | Returns a binding-specific context object which is used for message processing/routing by binding. This property value is not serialized and used internally by Glue framework. Not all bindings use/need this property (Inherited from Msg.)
Public property | CorrelationData | Arbitrary named object collection that can be used to correlate messages and/or attach extra data. This field is NOT transmitted over wire nor is it used by the framework. Message inspectors may use this property at their own discretion, for example in cases when the same inspector type is registered on multiple levels (endpoint, binding, glue), inspectors may check this property to execute only once per message. The collection is lazily allocated at the first reference attempt (Inherited from Msg.)
Public property | ExceptionData | Returns remote exception data if any
Public property | HasCorrelationData | Returns true when this message contains header data (Inherited from Msg.)
Public property | HasHeaders | Returns true when this message contains header data (Inherited from Msg.)
Public property | Headers | Returns a list of headers that this message contains (Inherited from Msg.)
Public property | ID | Returns a unique ID for this message (Inherited from Msg.)
Public property | OK | Returns true when reponse does not contain remote server exception which is represented by WrappedExceptionData
Public property | RemoteInstance | For stateful servers returns instance ID
Public property | RequestID | Returns request ID this response is for (Overrides Msg RequestID.)
Public property | ReturnValue | Returns return value of the called method. Note: out and ref params are not supported
Back to Top
See Also
ResponseMsg Class
NFX.Glue.Protocol Namespace


ResponseMsg Constructor

ResponseMsg Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ResponseMsg(FID, Object) | Initializes a new instance of the ResponseMsg class
Public method | ResponseMsg(FID, Nullable Guid , Object) | Initializes a new instance of the ResponseMsg class
Public method | ResponseMsg(ResponseMsg, Object, Boolean, Boolean) | This .ctor is handy for message inspectors. Creates a substitute message for the original one with new value. Binding-specific context is cloned and headers/correlation data are cloned conditionaly
Back to Top
See Also
ResponseMsg Class
ResponseMsg Members
NFX.Glue.Protocol Namespace


ResponseMsg Constructor (FID, Object)

ResponseMsg Constructor (FID, Object) NFX Class Library

Initializes a new instance of the ResponseMsg class

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResponseMsg(
    FID requestID,
    Object returnValue
)
public ResponseMsg(
    FID requestID,
    Object returnValue
)
Public Sub New (
    requestID As FID,
    returnValue As Object
)
Public Sub New (
    requestID As FID,
    returnValue As Object
)
public:
ResponseMsg(
    FID requestID,
    Object^ returnValue
)
public:
ResponseMsg(
    FID requestID,
    Object^ returnValue
)
new :
        requestID : FID *
        returnValue : Object -> ResponseMsg
new :
        requestID : FID *
        returnValue : Object -> ResponseMsg

Parameters

requestID
Type: NFX FID
returnValue
Type: Online System Object
See Also
ResponseMsg Class
ResponseMsg Members
ResponseMsg Overload
NFX.Glue.Protocol Namespace


ResponseMsg Constructor (FID, Nullable(Guid), Object)

ResponseMsg Constructor (FID, Nullable Guid , Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ResponseMsg class

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResponseMsg(
    FID requestID,
    Nullable<Guid> instance,
    Object returnValue
)
public ResponseMsg(
    FID requestID,
    Nullable<Guid> instance,
    Object returnValue
)
Public Sub New (
    requestID As FID,
    instance As Nullable(Of Guid),
    returnValue As Object
)
Public Sub New (
    requestID As FID,
    instance As Nullable(Of Guid),
    returnValue As Object
)
public:
ResponseMsg(
    FID requestID,
    Nullable<Guid> instance,
    Object^ returnValue
)
public:
ResponseMsg(
    FID requestID,
    Nullable<Guid> instance,
    Object^ returnValue
)
new :
        requestID : FID *
        instance : Nullable<Guid> *
        returnValue : Object -> ResponseMsg
new :
        requestID : FID *
        instance : Nullable<Guid> *
        returnValue : Object -> ResponseMsg

Parameters

requestID
Type: NFX FID
instance
Type: Online System Nullable Online Guid
returnValue
Type: Online System Object
See Also
ResponseMsg Class
ResponseMsg Members
ResponseMsg Overload
NFX.Glue.Protocol Namespace


ResponseMsg Constructor (ResponseMsg, Object, Boolean, Boolean)

ResponseMsg Constructor (ResponseMsg, Object, Boolean, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

This .ctor is handy for message inspectors. Creates a substitute message for the original one with new value. Binding-specific context is cloned and headers/correlation data are cloned conditionaly

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResponseMsg(
    ResponseMsg inspectedOriginal,
    Object newReturnValue,
    bool cloneHeaders = true,
    bool cloneCorrelation = true
)
public ResponseMsg(
    ResponseMsg inspectedOriginal,
    Object newReturnValue,
    bool cloneHeaders = true,
    bool cloneCorrelation = true
)
Public Sub New (
    inspectedOriginal As ResponseMsg,
    newReturnValue As Object,
    Optional cloneHeaders As Boolean = true,
    Optional cloneCorrelation As Boolean = true
)
Public Sub New (
    inspectedOriginal As ResponseMsg,
    newReturnValue As Object,
    Optional cloneHeaders As Boolean = true,
    Optional cloneCorrelation As Boolean = true
)
public:
ResponseMsg(
    ResponseMsg^ inspectedOriginal,
    Object^ newReturnValue,
    bool cloneHeaders = true,
    bool cloneCorrelation = true
)
public:
ResponseMsg(
    ResponseMsg^ inspectedOriginal,
    Object^ newReturnValue,
    bool cloneHeaders = true,
    bool cloneCorrelation = true
)
new :
        inspectedOriginal : ResponseMsg *
        newReturnValue : Object *
        ?cloneHeaders : bool *
        ?cloneCorrelation : bool
(* Defaults:
        let _cloneHeaders = defaultArg cloneHeaders true
        let _cloneCorrelation = defaultArg cloneCorrelation true
*)
-> ResponseMsg
new :
        inspectedOriginal : ResponseMsg *
        newReturnValue : Object *
        ?cloneHeaders : bool *
        ?cloneCorrelation : bool
(* Defaults:
        let _cloneHeaders = defaultArg cloneHeaders true
        let _cloneCorrelation = defaultArg cloneCorrelation true
*)
-> ResponseMsg

Parameters

inspectedOriginal
Type: NFX.Glue.Protocol ResponseMsg
newReturnValue
Type: Online System Object
cloneHeaders (Optional)
Type: Online System Boolean
cloneCorrelation (Optional)
Type: Online System Boolean
See Also
ResponseMsg Class
ResponseMsg Members
ResponseMsg Overload
NFX.Glue.Protocol Namespace


ResponseMsg Fields

ResponseMsg Fields NFX Class Library

The ResponseMsg type exposes the following members.
Fields
 | Name | Description
Protected field | m_Headers | (Inherited from Msg.)
Protected field | m_ID | (Inherited from Msg.)
Back to Top
See Also
ResponseMsg Class
NFX.Glue.Protocol Namespace


ResponseMsg Methods

ResponseMsg Methods NFX Class Library

The ResponseMsg type exposes the following members.
Methods
 | Name | Description
Public method | __SetArrivalTimeStampTicks | Framework method not for developers. Sets arrival ticks stamp. Usually called from transport (Inherited from Msg.)
Public method | __SetBindingSpecificContext(Object) | Internal method not to be called by app developers. Called from custom bindings to inject binding-specific context (Inherited from Msg.)
Public method | __SetBindingSpecificContext(Msg) | Internal method not to be called by app developers. Called from custom bindings to inject binding-specific context (Inherited from Msg.)
Public method | CloneState | Clones message state from another message instance. State includes binding-specific context and optionally headers and correlation data (Inherited from Msg.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from Msg.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ResponseMsg Class
NFX.Glue.Protocol Namespace


ResponseMsg Properties

ResponseMsg Properties NFX Class Library

The ResponseMsg type exposes the following members.
Properties
 | Name | Description
Public property | ArrivalTimeStamp | Returns arrival timestamp expressed in ticks, that is - when message just arrived before its processing started by Glue (before deserialization). This property allows for glue-internal latency assessment (Inherited from Msg.)
Public property | BindingSpecificContext | Returns a binding-specific context object which is used for message processing/routing by binding. This property value is not serialized and used internally by Glue framework. Not all bindings use/need this property (Inherited from Msg.)
Public property | CorrelationData | Arbitrary named object collection that can be used to correlate messages and/or attach extra data. This field is NOT transmitted over wire nor is it used by the framework. Message inspectors may use this property at their own discretion, for example in cases when the same inspector type is registered on multiple levels (endpoint, binding, glue), inspectors may check this property to execute only once per message. The collection is lazily allocated at the first reference attempt (Inherited from Msg.)
Public property | ExceptionData | Returns remote exception data if any
Public property | HasCorrelationData | Returns true when this message contains header data (Inherited from Msg.)
Public property | HasHeaders | Returns true when this message contains header data (Inherited from Msg.)
Public property | Headers | Returns a list of headers that this message contains (Inherited from Msg.)
Public property | ID | Returns a unique ID for this message (Inherited from Msg.)
Public property | OK | Returns true when reponse does not contain remote server exception which is represented by WrappedExceptionData
Public property | RemoteInstance | For stateful servers returns instance ID
Public property | RequestID | Returns request ID this response is for (Overrides Msg RequestID.)
Public property | ReturnValue | Returns return value of the called method. Note: out and ref params are not supported
Back to Top
See Also
ResponseMsg Class
NFX.Glue.Protocol Namespace


ResponseMsg.ExceptionData Property

ResponseMsg ExceptionData Property NFX Class Library

Returns remote exception data if any

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WrappedExceptionData ExceptionData { get; }
public WrappedExceptionData ExceptionData { get; }
Public ReadOnly Property ExceptionData As WrappedExceptionData
    Get
Public ReadOnly Property ExceptionData As WrappedExceptionData
    Get
public:
property WrappedExceptionData^ ExceptionData {
    WrappedExceptionData^ get ();
}
public:
property WrappedExceptionData^ ExceptionData {
    WrappedExceptionData^ get ();
}
member ExceptionData : WrappedExceptionData with get
member ExceptionData : WrappedExceptionData with get

Property Value

Type: WrappedExceptionData
See Also
ResponseMsg Class
ResponseMsg Members
NFX.Glue.Protocol Namespace


ResponseMsg.OK Property

ResponseMsg OK Property NFX Class Library

Returns true when reponse does not contain remote server exception which is represented by WrappedExceptionData

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool OK { get; }
public bool OK { get; }
Public ReadOnly Property OK As Boolean
    Get
Public ReadOnly Property OK As Boolean
    Get
public:
property bool OK {
    bool get ();
}
public:
property bool OK {
    bool get ();
}
member OK : bool with get
member OK : bool with get

Property Value

Type: Online Boolean
See Also
ResponseMsg Class
ResponseMsg Members
NFX.Glue.Protocol Namespace


ResponseMsg.RemoteInstance Property

ResponseMsg RemoteInstance Property NFX Class Library

For stateful servers returns instance ID

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<Guid> RemoteInstance { get; }
public Nullable<Guid> RemoteInstance { get; }
Public ReadOnly Property RemoteInstance As Nullable(Of Guid)
    Get
Public ReadOnly Property RemoteInstance As Nullable(Of Guid)
    Get
public:
property Nullable<Guid> RemoteInstance {
    Nullable<Guid> get ();
}
public:
property Nullable<Guid> RemoteInstance {
    Nullable<Guid> get ();
}
member RemoteInstance : Nullable<Guid> with get
member RemoteInstance : Nullable<Guid> with get

Property Value

Type: Online Nullable Online Guid
See Also
ResponseMsg Class
ResponseMsg Members
NFX.Glue.Protocol Namespace


ResponseMsg.RequestID Property

ResponseMsg RequestID Property NFX Class Library

Returns request ID this response is for

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override FID RequestID { get; }
public override FID RequestID { get; }
Public Overrides ReadOnly Property RequestID As FID
    Get
Public Overrides ReadOnly Property RequestID As FID
    Get
public:
virtual property FID RequestID {
    FID get () override;
}
public:
virtual property FID RequestID {
    FID get () override;
}
abstract RequestID : FID with get
override RequestID : FID with get
abstract RequestID : FID with get
override RequestID : FID with get

Property Value

Type: FID
See Also
ResponseMsg Class
ResponseMsg Members
NFX.Glue.Protocol Namespace


ResponseMsg.ReturnValue Property

ResponseMsg ReturnValue Property NFX Class Library

Returns return value of the called method. Note: out and ref params are not supported

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object ReturnValue { get; }
public Object ReturnValue { get; }
Public ReadOnly Property ReturnValue As Object
    Get
Public ReadOnly Property ReturnValue As Object
    Get
public:
property Object^ ReturnValue {
    Object^ get ();
}
public:
property Object^ ReturnValue {
    Object^ get ();
}
member ReturnValue : Object with get
member ReturnValue : Object with get

Property Value

Type: Online Object
See Also
ResponseMsg Class
ResponseMsg Members
NFX.Glue.Protocol Namespace


TypeSpec Structure

TypeSpec Structure NFX Class Library

Type specification for marshalling contract types between glued peers

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public struct TypeSpec
[SerializableAttribute]
public struct TypeSpec
<SerializableAttribute>
Public Structure TypeSpec
<SerializableAttribute>
Public Structure TypeSpec
[SerializableAttribute]
public value class TypeSpec
[SerializableAttribute]
public value class TypeSpec
[<SealedAttribute>]
[<SerializableAttribute>]
type TypeSpec =  struct end
[<SealedAttribute>]
[<SerializableAttribute>]
type TypeSpec =  struct end
See Also
TypeSpec Members
NFX.Glue.Protocol Namespace


TypeSpec Members

TypeSpec Members NFX Class Library

The TypeSpec type exposes the following members.
Constructors
 | Name | Description
Public method | TypeSpec | Initializes a new instance of the TypeSpec class
Back to Top
Methods
 | Name | Description
Public method | Equals | (Overrides Online ValueType Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | GetSpecifiedType | Returns the type or throws if it can't be found
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Hash |
Protected field | m_Name |
Back to Top
Properties
 | Name | Description
Public property | Hash |
Public property | Name |
Back to Top
See Also
TypeSpec Structure
NFX.Glue.Protocol Namespace


TypeSpec Constructor

TypeSpec Constructor NFX Class Library

Initializes a new instance of the TypeSpec class

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TypeSpec(
    Type type
)
public TypeSpec(
    Type type
)
Public Sub New (
    type As Type
)
Public Sub New (
    type As Type
)
public:
TypeSpec(
    Type^ type
)
public:
TypeSpec(
    Type^ type
)
new :
        type : Type -> TypeSpec
new :
        type : Type -> TypeSpec

Parameters

type
Type: Online System Type
See Also
TypeSpec Structure
TypeSpec Members
NFX.Glue.Protocol Namespace


TypeSpec Fields

TypeSpec Fields NFX Class Library

The TypeSpec type exposes the following members.
Fields
 | Name | Description
Protected field | m_Hash |
Protected field | m_Name |
Back to Top
See Also
TypeSpec Structure
NFX.Glue.Protocol Namespace


TypeSpec.m_Hash Field

TypeSpec m_Hash Field NFX Class Library

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal ulong m_Hash
internal ulong m_Hash
Friend m_Hash As ULong
Friend m_Hash As ULong
internal:
unsigned long long m_Hash
internal:
unsigned long long m_Hash
val mutable internal m_Hash: uint64
val mutable internal m_Hash: uint64

Field Value

Type: Online UInt64
See Also
TypeSpec Structure
TypeSpec Members
NFX.Glue.Protocol Namespace


TypeSpec.m_Name Field

TypeSpec m_Name Field NFX Class Library

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal string m_Name
internal string m_Name
Friend m_Name As String
Friend m_Name As String
internal:
String^ m_Name
internal:
String^ m_Name
val mutable internal m_Name: string
val mutable internal m_Name: string

Field Value

Type: Online String
See Also
TypeSpec Structure
TypeSpec Members
NFX.Glue.Protocol Namespace


TypeSpec Methods

TypeSpec Methods NFX Class Library

The TypeSpec type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online ValueType Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | GetSpecifiedType | Returns the type or throws if it can't be found
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TypeSpec Structure
NFX.Glue.Protocol Namespace


TypeSpec.Equals Method

TypeSpec Equals Method NFX Class Library

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
TypeSpec Structure
TypeSpec Members
NFX.Glue.Protocol Namespace


TypeSpec.GetHashCode Method

TypeSpec GetHashCode Method NFX Class Library

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
TypeSpec Structure
TypeSpec Members
NFX.Glue.Protocol Namespace


TypeSpec.GetSpecifiedType Method

TypeSpec GetSpecifiedType Method NFX Class Library

Returns the type or throws if it can't be found

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Type GetSpecifiedType()
public Type GetSpecifiedType()
Public Function GetSpecifiedType As Type
Public Function GetSpecifiedType As Type
public:
Type^ GetSpecifiedType()
public:
Type^ GetSpecifiedType()
member GetSpecifiedType : unit -> Type
member GetSpecifiedType : unit -> Type

Return Value

Type: Online Type
The type or throws exception if actual type could not be gotten
See Also
TypeSpec Structure
TypeSpec Members
NFX.Glue.Protocol Namespace


TypeSpec.ToString Method

TypeSpec ToString Method NFX Class Library

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
TypeSpec Structure
TypeSpec Members
NFX.Glue.Protocol Namespace


TypeSpec Properties

TypeSpec Properties NFX Class Library

The TypeSpec type exposes the following members.
Properties
 | Name | Description
Public property | Hash |
Public property | Name |
Back to Top
See Also
TypeSpec Structure
NFX.Glue.Protocol Namespace


TypeSpec.Hash Property

TypeSpec Hash Property NFX Class Library

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong Hash { get; }
public ulong Hash { get; }
Public ReadOnly Property Hash As ULong
    Get
Public ReadOnly Property Hash As ULong
    Get
public:
property unsigned long long Hash {
    unsigned long long get ();
}
public:
property unsigned long long Hash {
    unsigned long long get ();
}
member Hash : uint64 with get
member Hash : uint64 with get

Property Value

Type: Online UInt64
See Also
TypeSpec Structure
TypeSpec Members
NFX.Glue.Protocol Namespace


TypeSpec.Name Property

TypeSpec Name Property NFX Class Library

Namespace: NFX.Glue.Protocol
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
public:
property String^ Name {
    String^ get ();
}
member Name : string with get
member Name : string with get

Property Value

Type: Online String
See Also
TypeSpec Structure
TypeSpec Members
NFX.Glue.Protocol Namespace


NFX.Glue.Tools Namespace

NFX.Glue.Tools Namespace NFX Class Library

Classes
 | Class | Description
Public class | CSharpGluecCompiler | CS Gluec compiler
Public class | GluecCompiler | Generates code from glue contracts


CSharpGluecCompiler Class

CSharpGluecCompiler Class NFX Class Library

CS Gluec compiler
Inheritance Hierarchy
Online System Object
NFX.Glue.Tools GluecCompiler
NFX.Glue.Tools CSharpGluecCompiler

Namespace: NFX.Glue.Tools
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CSharpGluecCompiler : GluecCompiler
public class CSharpGluecCompiler : GluecCompiler
Public Class CSharpGluecCompiler
    Inherits GluecCompiler
Public Class CSharpGluecCompiler
    Inherits GluecCompiler
public ref class CSharpGluecCompiler : public GluecCompiler
public ref class CSharpGluecCompiler : public GluecCompiler
type CSharpGluecCompiler =
    class
        inherit GluecCompiler
    end
type CSharpGluecCompiler =
    class
        inherit GluecCompiler
    end
See Also
CSharpGluecCompiler Members
NFX.Glue.Tools Namespace


CSharpGluecCompiler Members

CSharpGluecCompiler Members NFX Class Library

The CSharpGluecCompiler type exposes the following members.
Constructors
 | Name | Description
Public method | CSharpGluecCompiler | Initializes a new instance of the CSharpGluecCompiler class
Back to Top
Methods
 | Name | Description
Protected method | BeforeClientClass |
Public method | Compile | (Overrides GluecCompiler Compile .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | FileHeader |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetClientInterfaceName |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | TypeToStr |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Assembly | (Inherited from GluecCompiler.)
Back to Top
Properties
 | Name | Description
Public property | ClassSuffix |
Public property | FilePerContract | (Inherited from GluecCompiler.)
Public property | NamespaceFilter | (Inherited from GluecCompiler.)
Public property | Namespaces | (Inherited from GluecCompiler.)
Public property | NamespaceSuffix |
Public property | OutPath | (Inherited from GluecCompiler.)
Public property | RootNamespace |
Back to Top
See Also
CSharpGluecCompiler Class
NFX.Glue.Tools Namespace


CSharpGluecCompiler Constructor

CSharpGluecCompiler Constructor NFX Class Library

Initializes a new instance of the CSharpGluecCompiler class

Namespace: NFX.Glue.Tools
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CSharpGluecCompiler(
    Assembly asm
)
public CSharpGluecCompiler(
    Assembly asm
)
Public Sub New (
    asm As Assembly
)
Public Sub New (
    asm As Assembly
)
public:
CSharpGluecCompiler(
    Assembly^ asm
)
public:
CSharpGluecCompiler(
    Assembly^ asm
)
new :
        asm : Assembly -> CSharpGluecCompiler
new :
        asm : Assembly -> CSharpGluecCompiler

Parameters

asm
Type: Online System.Reflection Assembly
See Also
CSharpGluecCompiler Class
CSharpGluecCompiler Members
NFX.Glue.Tools Namespace


CSharpGluecCompiler Fields

CSharpGluecCompiler Fields NFX Class Library

The CSharpGluecCompiler type exposes the following members.
Fields
 | Name | Description
Protected field | m_Assembly | (Inherited from GluecCompiler.)
Back to Top
See Also
CSharpGluecCompiler Class
NFX.Glue.Tools Namespace


CSharpGluecCompiler Methods

CSharpGluecCompiler Methods NFX Class Library

The CSharpGluecCompiler type exposes the following members.
Methods
 | Name | Description
Protected method | BeforeClientClass |
Public method | Compile | (Overrides GluecCompiler Compile .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | FileHeader |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetClientInterfaceName |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | TypeToStr |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CSharpGluecCompiler Class
NFX.Glue.Tools Namespace


CSharpGluecCompiler.BeforeClientClass Method

CSharpGluecCompiler BeforeClientClass Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Tools
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void BeforeClientClass(
    StringBuilder sb,
    Type tc,
    string cname,
    string iname
)
protected virtual void BeforeClientClass(
    StringBuilder sb,
    Type tc,
    string cname,
    string iname
)
Protected Overridable Sub BeforeClientClass (
    sb As StringBuilder,
    tc As Type,
    cname As String,
    iname As String
)
Protected Overridable Sub BeforeClientClass (
    sb As StringBuilder,
    tc As Type,
    cname As String,
    iname As String
)
protected:
virtual void BeforeClientClass(
    StringBuilder^ sb,
    Type^ tc,
    String^ cname,
    String^ iname
)
protected:
virtual void BeforeClientClass(
    StringBuilder^ sb,
    Type^ tc,
    String^ cname,
    String^ iname
)
abstract BeforeClientClass :
        sb : StringBuilder *
        tc : Type *
        cname : string *
        iname : string -> unit
override BeforeClientClass :
        sb : StringBuilder *
        tc : Type *
        cname : string *
        iname : string -> unit
abstract BeforeClientClass :
        sb : StringBuilder *
        tc : Type *
        cname : string *
        iname : string -> unit
override BeforeClientClass :
        sb : StringBuilder *
        tc : Type *
        cname : string *
        iname : string -> unit

Parameters

sb
Type: Online System.Text StringBuilder
tc
Type: Online System Type
cname
Type: Online System String
iname
Type: Online System String
See Also
CSharpGluecCompiler Class
CSharpGluecCompiler Members
NFX.Glue.Tools Namespace


CSharpGluecCompiler.Compile Method

CSharpGluecCompiler Compile Method NFX Class Library

Namespace: NFX.Glue.Tools
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Compile()
public override void Compile()
Public Overrides Sub Compile
Public Overrides Sub Compile
public:
virtual void Compile() override
public:
virtual void Compile() override
abstract Compile : unit -> unit
override Compile : unit -> unit
abstract Compile : unit -> unit
override Compile : unit -> unit
See Also
CSharpGluecCompiler Class
CSharpGluecCompiler Members
NFX.Glue.Tools Namespace


CSharpGluecCompiler.FileHeader Method

CSharpGluecCompiler FileHeader Method NFX Class Library

Namespace: NFX.Glue.Tools
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual string FileHeader()
protected virtual string FileHeader()
Protected Overridable Function FileHeader As String
Protected Overridable Function FileHeader As String
protected:
virtual String^ FileHeader()
protected:
virtual String^ FileHeader()
abstract FileHeader : unit -> string
override FileHeader : unit -> string
abstract FileHeader : unit -> string
override FileHeader : unit -> string

Return Value

Type: Online String
See Also
CSharpGluecCompiler Class
CSharpGluecCompiler Members
NFX.Glue.Tools Namespace


CSharpGluecCompiler.GetClientInterfaceName Method

CSharpGluecCompiler GetClientInterfaceName Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Tools
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual string GetClientInterfaceName(
    Type tc
)
protected virtual string GetClientInterfaceName(
    Type tc
)
Protected Overridable Function GetClientInterfaceName (
    tc As Type
) As String
Protected Overridable Function GetClientInterfaceName (
    tc As Type
) As String
protected:
virtual String^ GetClientInterfaceName(
    Type^ tc
)
protected:
virtual String^ GetClientInterfaceName(
    Type^ tc
)
abstract GetClientInterfaceName :
        tc : Type -> string
override GetClientInterfaceName :
        tc : Type -> string
abstract GetClientInterfaceName :
        tc : Type -> string
override GetClientInterfaceName :
        tc : Type -> string

Parameters

tc
Type: Online System Type

Return Value

Type: Online String
See Also
CSharpGluecCompiler Class
CSharpGluecCompiler Members
NFX.Glue.Tools Namespace


CSharpGluecCompiler.TypeToStr Method

CSharpGluecCompiler TypeToStr Method NFX Class Library

Namespace: NFX.Glue.Tools
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected string TypeToStr(
    Type type
)
protected string TypeToStr(
    Type type
)
Protected Function TypeToStr (
    type As Type
) As String
Protected Function TypeToStr (
    type As Type
) As String
protected:
String^ TypeToStr(
    Type^ type
)
protected:
String^ TypeToStr(
    Type^ type
)
member TypeToStr :
        type : Type -> string
member TypeToStr :
        type : Type -> string

Parameters

type
Type: Online System Type

Return Value

Type: Online String
See Also
CSharpGluecCompiler Class
CSharpGluecCompiler Members
NFX.Glue.Tools Namespace


CSharpGluecCompiler Properties

CSharpGluecCompiler Properties NFX Class Library

The CSharpGluecCompiler type exposes the following members.
Properties
 | Name | Description
Public property | ClassSuffix |
Public property | FilePerContract | (Inherited from GluecCompiler.)
Public property | NamespaceFilter | (Inherited from GluecCompiler.)
Public property | Namespaces | (Inherited from GluecCompiler.)
Public property | NamespaceSuffix |
Public property | OutPath | (Inherited from GluecCompiler.)
Public property | RootNamespace |
Back to Top
See Also
CSharpGluecCompiler Class
NFX.Glue.Tools Namespace


CSharpGluecCompiler.ClassSuffix Property

CSharpGluecCompiler ClassSuffix Property NFX Class Library

Namespace: NFX.Glue.Tools
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$cl-suffix")]
public string ClassSuffix { get; set; }
[ConfigAttribute("$cl-suffix")]
public string ClassSuffix { get; set; }
<ConfigAttribute("$cl-suffix")>
Public Property ClassSuffix As String
    Get
    Set
<ConfigAttribute("$cl-suffix")>
Public Property ClassSuffix As String
    Get
    Set
public:
[ConfigAttribute(L"$cl-suffix")]
property String^ ClassSuffix {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute(L"$cl-suffix")]
property String^ ClassSuffix {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute("$cl-suffix")>]
member ClassSuffix : string with get, set
[<ConfigAttribute("$cl-suffix")>]
member ClassSuffix : string with get, set

Property Value

Type: Online String
See Also
CSharpGluecCompiler Class
CSharpGluecCompiler Members
NFX.Glue.Tools Namespace


CSharpGluecCompiler.NamespaceSuffix Property

CSharpGluecCompiler NamespaceSuffix Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Glue.Tools
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$ns-suffix")]
public string NamespaceSuffix { get; set; }
[ConfigAttribute("$ns-suffix")]
public string NamespaceSuffix { get; set; }
<ConfigAttribute("$ns-suffix")>
Public Property NamespaceSuffix As String
    Get
    Set
<ConfigAttribute("$ns-suffix")>
Public Property NamespaceSuffix As String
    Get
    Set
public:
[ConfigAttribute(L"$ns-suffix")]
property String^ NamespaceSuffix {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute(L"$ns-suffix")]
property String^ NamespaceSuffix {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute("$ns-suffix")>]
member NamespaceSuffix : string with get, set
[<ConfigAttribute("$ns-suffix")>]
member NamespaceSuffix : string with get, set

Property Value

Type: Online String
See Also
CSharpGluecCompiler Class
CSharpGluecCompiler Members
NFX.Glue.Tools Namespace


CSharpGluecCompiler.RootNamespace Property

CSharpGluecCompiler RootNamespace Property NFX Class Library

Namespace: NFX.Glue.Tools
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$ns-root")]
public string RootNamespace { get; set; }
[ConfigAttribute("$ns-root")]
public string RootNamespace { get; set; }
<ConfigAttribute("$ns-root")>
Public Property RootNamespace As String
    Get
    Set
<ConfigAttribute("$ns-root")>
Public Property RootNamespace As String
    Get
    Set
public:
[ConfigAttribute(L"$ns-root")]
property String^ RootNamespace {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute(L"$ns-root")]
property String^ RootNamespace {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute("$ns-root")>]
member RootNamespace : string with get, set
[<ConfigAttribute("$ns-root")>]
member RootNamespace : string with get, set

Property Value

Type: Online String
See Also
CSharpGluecCompiler Class
CSharpGluecCompiler Members
NFX.Glue.Tools Namespace


GluecCompiler Class

GluecCompiler Class NFX Class Library

Generates code from glue contracts
Inheritance Hierarchy
Online System Object
NFX.Glue.Tools GluecCompiler
NFX.Glue.Tools CSharpGluecCompiler

Namespace: NFX.Glue.Tools
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class GluecCompiler
public abstract class GluecCompiler
Public MustInherit Class GluecCompiler
Public MustInherit Class GluecCompiler
public ref class GluecCompiler abstract
public ref class GluecCompiler abstract
[<AbstractClassAttribute>]
type GluecCompiler =  class end
[<AbstractClassAttribute>]
type GluecCompiler =  class end
See Also
GluecCompiler Members
NFX.Glue.Tools Namespace


GluecCompiler Members

GluecCompiler Members NFX Class Library

The GluecCompiler type exposes the following members.
Constructors
 | Name | Description
Protected method | GluecCompiler | Initializes a new instance of the GluecCompiler class
Back to Top
Methods
 | Name | Description
Public method | Compile |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Assembly |
Back to Top
Properties
 | Name | Description
Public property | FilePerContract |
Public property | NamespaceFilter |
Public property | Namespaces |
Public property | OutPath |
Back to Top
See Also
GluecCompiler Class
NFX.Glue.Tools Namespace


GluecCompiler Constructor

GluecCompiler Constructor NFX Class Library

Initializes a new instance of the GluecCompiler class

Namespace: NFX.Glue.Tools
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected GluecCompiler(
    Assembly asm
)
protected GluecCompiler(
    Assembly asm
)
Protected Sub New (
    asm As Assembly
)
Protected Sub New (
    asm As Assembly
)
protected:
GluecCompiler(
    Assembly^ asm
)
protected:
GluecCompiler(
    Assembly^ asm
)
new :
        asm : Assembly -> GluecCompiler
new :
        asm : Assembly -> GluecCompiler

Parameters

asm
Type: Online System.Reflection Assembly
See Also
GluecCompiler Class
GluecCompiler Members
NFX.Glue.Tools Namespace


GluecCompiler Fields

GluecCompiler Fields NFX Class Library

The GluecCompiler type exposes the following members.
Fields
 | Name | Description
Protected field | m_Assembly |
Back to Top
See Also
GluecCompiler Class
NFX.Glue.Tools Namespace


GluecCompiler.m_Assembly Field

GluecCompiler m_Assembly Field NFX Class Library

Namespace: NFX.Glue.Tools
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Assembly m_Assembly
protected Assembly m_Assembly
Protected m_Assembly As Assembly
Protected m_Assembly As Assembly
protected:
Assembly^ m_Assembly
protected:
Assembly^ m_Assembly
val mutable m_Assembly: Assembly
val mutable m_Assembly: Assembly

Field Value

Type: Online Assembly
See Also
GluecCompiler Class
GluecCompiler Members
NFX.Glue.Tools Namespace


GluecCompiler Methods

GluecCompiler Methods NFX Class Library

The GluecCompiler type exposes the following members.
Methods
 | Name | Description
Public method | Compile |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GluecCompiler Class
NFX.Glue.Tools Namespace


GluecCompiler.Compile Method

GluecCompiler Compile Method NFX Class Library

Namespace: NFX.Glue.Tools
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Compile()
public abstract void Compile()
Public MustOverride Sub Compile
Public MustOverride Sub Compile
public:
virtual void Compile() abstract
public:
virtual void Compile() abstract
abstract Compile : unit -> unit
abstract Compile : unit -> unit
See Also
GluecCompiler Class
GluecCompiler Members
NFX.Glue.Tools Namespace


GluecCompiler Properties

GluecCompiler Properties NFX Class Library

The GluecCompiler type exposes the following members.
Properties
 | Name | Description
Public property | FilePerContract |
Public property | NamespaceFilter |
Public property | Namespaces |
Public property | OutPath |
Back to Top
See Also
GluecCompiler Class
NFX.Glue.Tools Namespace


GluecCompiler.FilePerContract Property

GluecCompiler FilePerContract Property NFX Class Library

Namespace: NFX.Glue.Tools
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$fpc", true)]
public bool FilePerContract { get; set; }
[ConfigAttribute("$fpc", true)]
public bool FilePerContract { get; set; }
<ConfigAttribute("$fpc", true)>
Public Property FilePerContract As Boolean
    Get
    Set
<ConfigAttribute("$fpc", true)>
Public Property FilePerContract As Boolean
    Get
    Set
public:
[ConfigAttribute(L"$fpc", true)]
property bool FilePerContract {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute(L"$fpc", true)]
property bool FilePerContract {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute("$fpc", true)>]
member FilePerContract : bool with get, set
[<ConfigAttribute("$fpc", true)>]
member FilePerContract : bool with get, set

Property Value

Type: Online Boolean
See Also
GluecCompiler Class
GluecCompiler Members
NFX.Glue.Tools Namespace


GluecCompiler.NamespaceFilter Property

GluecCompiler NamespaceFilter Property NFX Class Library

Namespace: NFX.Glue.Tools
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$ns")]
public string NamespaceFilter { get; set; }
[ConfigAttribute("$ns")]
public string NamespaceFilter { get; set; }
<ConfigAttribute("$ns")>
Public Property NamespaceFilter As String
    Get
    Set
<ConfigAttribute("$ns")>
Public Property NamespaceFilter As String
    Get
    Set
public:
[ConfigAttribute(L"$ns")]
property String^ NamespaceFilter {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute(L"$ns")]
property String^ NamespaceFilter {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute("$ns")>]
member NamespaceFilter : string with get, set
[<ConfigAttribute("$ns")>]
member NamespaceFilter : string with get, set

Property Value

Type: Online String
See Also
GluecCompiler Class
GluecCompiler Members
NFX.Glue.Tools Namespace


GluecCompiler.Namespaces Property

GluecCompiler Namespaces Property NFX Class Library

Namespace: NFX.Glue.Tools
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<string> Namespaces { get; }
public IEnumerable<string> Namespaces { get; }
Public ReadOnly Property Namespaces As IEnumerable(Of String)
    Get
Public ReadOnly Property Namespaces As IEnumerable(Of String)
    Get
public:
property IEnumerable<String^>^ Namespaces {
    IEnumerable<String^>^ get ();
}
public:
property IEnumerable<String^>^ Namespaces {
    IEnumerable<String^>^ get ();
}
member Namespaces : IEnumerable<string> with get
member Namespaces : IEnumerable<string> with get

Property Value

Type: Online IEnumerable Online String
See Also
GluecCompiler Class
GluecCompiler Members
NFX.Glue.Tools Namespace


GluecCompiler.OutPath Property

GluecCompiler OutPath Property NFX Class Library

Namespace: NFX.Glue.Tools
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$out")]
public string OutPath { get; set; }
[ConfigAttribute("$out")]
public string OutPath { get; set; }
<ConfigAttribute("$out")>
Public Property OutPath As String
    Get
    Set
<ConfigAttribute("$out")>
Public Property OutPath As String
    Get
    Set
public:
[ConfigAttribute(L"$out")]
property String^ OutPath {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute(L"$out")]
property String^ OutPath {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute("$out")>]
member OutPath : string with get, set
[<ConfigAttribute("$out")>]
member OutPath : string with get, set

Property Value

Type: Online String
See Also
GluecCompiler Class
GluecCompiler Members
NFX.Glue.Tools Namespace


NFX.Health Namespace

NFX.Health Namespace NFX Class Library

Provides classes for application/process health monitoring
Classes
 | Class | Description
Public class | BaseCheck | Base class for all Health Checks. Particular health checks must inherit from this class to be invoked
Public class | CheckList | Represents a list of health checks to be performed. Health checks are classes derived from BaseCheck class and must implement DoRun() method that performs application-specific checking. CheckList obtains a list of Check instances from assemblies supplied to its constructor. Health checks are executed in no predictable order. If particular execution order is necessary then a check has to be written to explicitly coordinate sub-checks. The class is thread safe for all operations.
Public class | CheckResult | Property bag to report health check results
Public class | HealthCheckListException | Thrown by Health.CheckList
Public class | HealthException | Represents general ancestor for exceptions thrown by health checks
Public class | HTMLReporter | Reports health check results as HTML
Public class | Reporter | Base for all reporters - entities that output check list state into TextWriter
Public class | TextReporter | Reports health check results in an plain text format
Public class | XMLReporter | Reports XML health check results
Enumerations
 | Enumeration | Description
Public enumeration | CheckListStatus | Stipulates status for Health.CheckList


BaseCheck Class

BaseCheck Class NFX Class Library

Base class for all Health Checks. Particular health checks must inherit from this class to be invoked
Inheritance Hierarchy
Online System Object
NFX.Health BaseCheck

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("/health-checks")]
public abstract class BaseCheck : IConfigurable
[ConfigAttribute("/health-checks")]
public abstract class BaseCheck : IConfigurable
<ConfigAttribute("/health-checks")>
Public MustInherit Class BaseCheck
    Implements IConfigurable
<ConfigAttribute("/health-checks")>
Public MustInherit Class BaseCheck
    Implements IConfigurable
[ConfigAttribute(L"/health-checks")]
public ref class BaseCheck abstract : IConfigurable
[ConfigAttribute(L"/health-checks")]
public ref class BaseCheck abstract : IConfigurable
[<AbstractClassAttribute>]
[<ConfigAttribute("/health-checks")>]
type BaseCheck =
    class
        interface IConfigurable
    end
[<AbstractClassAttribute>]
[<ConfigAttribute("/health-checks")>]
type BaseCheck =
    class
        interface IConfigurable
    end
See Also
BaseCheck Members
NFX.Health Namespace


BaseCheck Members

BaseCheck Members NFX Class Library

The BaseCheck type exposes the following members.
Constructors
 | Name | Description
Protected method | BaseCheck | Initializes a new instance of the BaseCheck class
Back to Top
Methods
 | Name | Description
Public method | Configure |
Protected method | DoRun | Override to provide particular health check implementation
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Run | Runs the check
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Result | Results property bag may be used for reporting of additional health-check parameters i.e. latency, content size etc...
Back to Top
Properties
 | Name | Description
Public property | CanRun | Indicates whether this check will be executed
Public property | Description | Provides additional textual description of the check
Public property | Name | Provides textual name for this check. Base implementation returns full type name
Back to Top
See Also
BaseCheck Class
NFX.Health Namespace


BaseCheck Constructor

BaseCheck Constructor NFX Class Library

Initializes a new instance of the BaseCheck class

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected BaseCheck()
protected BaseCheck()
Protected Sub New
Protected Sub New
protected:
BaseCheck()
protected:
BaseCheck()
new : unit -> BaseCheck
new : unit -> BaseCheck
See Also
BaseCheck Class
BaseCheck Members
NFX.Health Namespace


BaseCheck Fields

BaseCheck Fields NFX Class Library

The BaseCheck type exposes the following members.
Fields
 | Name | Description
Public field | Result | Results property bag may be used for reporting of additional health-check parameters i.e. latency, content size etc...
Back to Top
See Also
BaseCheck Class
NFX.Health Namespace


BaseCheck.Result Field

BaseCheck Result Field NFX Class Library

Results property bag may be used for reporting of additional health-check parameters i.e. latency, content size etc...

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly CheckResult Result
public readonly CheckResult Result
Public ReadOnly Result As CheckResult
Public ReadOnly Result As CheckResult
public:
initonly CheckResult^ Result
public:
initonly CheckResult^ Result
val Result: CheckResult
val Result: CheckResult

Field Value

Type: CheckResult
See Also
BaseCheck Class
BaseCheck Members
NFX.Health Namespace


BaseCheck Methods

BaseCheck Methods NFX Class Library

The BaseCheck type exposes the following members.
Methods
 | Name | Description
Public method | Configure |
Protected method | DoRun | Override to provide particular health check implementation
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Run | Runs the check
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BaseCheck Class
NFX.Health Namespace


BaseCheck.Configure Method

BaseCheck Configure Method NFX Class Library

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode node
)
public void Configure(
    IConfigSectionNode node
)
Public Sub Configure (
    node As IConfigSectionNode
)
Public Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
BaseCheck Class
BaseCheck Members
NFX.Health Namespace


BaseCheck.DoRun Method

BaseCheck DoRun Method NFX Class Library

Override to provide particular health check implementation

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void DoRun(
    NameValueCollection parameters
)
protected abstract void DoRun(
    NameValueCollection parameters
)
Protected MustOverride Sub DoRun (
    parameters As NameValueCollection
)
Protected MustOverride Sub DoRun (
    parameters As NameValueCollection
)
protected:
virtual void DoRun(
    NameValueCollection^ parameters
) abstract
protected:
virtual void DoRun(
    NameValueCollection^ parameters
) abstract
abstract DoRun :
        parameters : NameValueCollection -> unit
abstract DoRun :
        parameters : NameValueCollection -> unit

Parameters

parameters
Type: Online System.Collections.Specialized NameValueCollection
See Also
BaseCheck Class
BaseCheck Members
NFX.Health Namespace


BaseCheck.Run Method

BaseCheck Run Method NFX Class Library

Runs the check

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Run(
    NameValueCollection parameters
)
internal void Run(
    NameValueCollection parameters
)
Friend Sub Run (
    parameters As NameValueCollection
)
Friend Sub Run (
    parameters As NameValueCollection
)
internal:
void Run(
    NameValueCollection^ parameters
)
internal:
void Run(
    NameValueCollection^ parameters
)
internal member Run :
        parameters : NameValueCollection -> unit
internal member Run :
        parameters : NameValueCollection -> unit

Parameters

parameters
Type: Online System.Collections.Specialized NameValueCollection
See Also
BaseCheck Class
BaseCheck Members
NFX.Health Namespace


BaseCheck Properties

BaseCheck Properties NFX Class Library

The BaseCheck type exposes the following members.
Properties
 | Name | Description
Public property | CanRun | Indicates whether this check will be executed
Public property | Description | Provides additional textual description of the check
Public property | Name | Provides textual name for this check. Base implementation returns full type name
Back to Top
See Also
BaseCheck Class
NFX.Health Namespace


BaseCheck.CanRun Property

BaseCheck CanRun Property NFX Class Library

Indicates whether this check will be executed

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("@assembly@/@type@/$can-run")]
public virtual bool CanRun { get; set; }
[ConfigAttribute("@assembly@/@type@/$can-run")]
public virtual bool CanRun { get; set; }
<ConfigAttribute("@assembly@/@type@/$can-run")>
Public Overridable Property CanRun As Boolean
    Get
    Set
<ConfigAttribute("@assembly@/@type@/$can-run")>
Public Overridable Property CanRun As Boolean
    Get
    Set
public:
[ConfigAttribute(L"@assembly@/@type@/$can-run")]
virtual property bool CanRun {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute(L"@assembly@/@type@/$can-run")]
virtual property bool CanRun {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute("@assembly@/@type@/$can-run")>]
abstract CanRun : bool with get, set
[<ConfigAttribute("@assembly@/@type@/$can-run")>]
override CanRun : bool with get, set
[<ConfigAttribute("@assembly@/@type@/$can-run")>]
abstract CanRun : bool with get, set
[<ConfigAttribute("@assembly@/@type@/$can-run")>]
override CanRun : bool with get, set

Property Value

Type: Online Boolean
See Also
BaseCheck Class
BaseCheck Members
NFX.Health Namespace


BaseCheck.Description Property

BaseCheck Description Property NFX Class Library

Provides additional textual description of the check

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Description { get; }
public virtual string Description { get; }
Public Overridable ReadOnly Property Description As String
    Get
Public Overridable ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get ();
}
public:
virtual property String^ Description {
    String^ get ();
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
BaseCheck Class
BaseCheck Members
NFX.Health Namespace


BaseCheck.Name Property

BaseCheck Name Property NFX Class Library

Provides textual name for this check. Base implementation returns full type name

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Name { get; }
public virtual string Name { get; }
Public Overridable ReadOnly Property Name As String
    Get
Public Overridable ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get ();
}
public:
virtual property String^ Name {
    String^ get ();
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String
See Also
BaseCheck Class
BaseCheck Members
NFX.Health Namespace


CheckList Class

CheckList Class NFX Class Library

Represents a list of health checks to be performed. Health checks are classes derived from BaseCheck class and must implement DoRun() method that performs application-specific checking. CheckList obtains a list of Check instances from assemblies supplied to its constructor. Health checks are executed in no predictable order. If particular execution order is necessary then a check has to be written to explicitly coordinate sub-checks. The class is thread safe for all operations.
Inheritance Hierarchy
Online System Object
NFX.Health CheckList

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class CheckList
public sealed class CheckList
Public NotInheritable Class CheckList
Public NotInheritable Class CheckList
public ref class CheckList sealed
public ref class CheckList sealed
[<SealedAttribute>]
type CheckList =  class end
[<SealedAttribute>]
type CheckList =  class end
See Also
CheckList Members
NFX.Health Namespace


CheckList Members

CheckList Members NFX Class Library

The CheckList type exposes the following members.
Constructors
 | Name | Description
Public method | CheckList(IEnumerable Assembly , ConfigSectionNode) | Initializaes check list from assemblies
Public method | CheckList(String, String, ConfigSectionNode) | Initializaes check list from assembly names separated by semicolons. Optional path will be prepended to every assembly name
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Report | Dumps check results into writer in on of the supported formats
Public method | Run | Runs health checks. Checks are ran in NO PARTICULAR order. This method can not be called twice
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | AllSuccessful | Returns true when all checks have successfuly run
Public property | Checks | Returns health checks
Public property | RunFinish | Returns when run finished
Public property | RunStart | Returns when run started
Public property | Status | Returns current status - whether checks are running or have already been run
Public property | Successful | Returns true when all checks that could be run have successfuly run
Back to Top
See Also
CheckList Class
NFX.Health Namespace


CheckList Constructor

CheckList Constructor NFX Class Library

Overload List
 | Name | Description
Public method | CheckList(IEnumerable Assembly , ConfigSectionNode) | Initializaes check list from assemblies
Public method | CheckList(String, String, ConfigSectionNode) | Initializaes check list from assembly names separated by semicolons. Optional path will be prepended to every assembly name
Back to Top
See Also
CheckList Class
CheckList Members
NFX.Health Namespace


CheckList Constructor (IEnumerable(Assembly), ConfigSectionNode)

CheckList Constructor (IEnumerable Assembly , ConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializaes check list from assemblies

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CheckList(
    IEnumerable<Assembly> checkAssemblies,
    ConfigSectionNode config
)
public CheckList(
    IEnumerable<Assembly> checkAssemblies,
    ConfigSectionNode config
)
Public Sub New (
    checkAssemblies As IEnumerable(Of Assembly),
    config As ConfigSectionNode
)
Public Sub New (
    checkAssemblies As IEnumerable(Of Assembly),
    config As ConfigSectionNode
)
public:
CheckList(
    IEnumerable<Assembly^>^ checkAssemblies,
    ConfigSectionNode^ config
)
public:
CheckList(
    IEnumerable<Assembly^>^ checkAssemblies,
    ConfigSectionNode^ config
)
new :
        checkAssemblies : IEnumerable<Assembly> *
        config : ConfigSectionNode -> CheckList
new :
        checkAssemblies : IEnumerable<Assembly> *
        config : ConfigSectionNode -> CheckList

Parameters

checkAssemblies
Type: Online System.Collections.Generic IEnumerable Online Assembly
config
Type: NFX.Environment ConfigSectionNode
See Also
CheckList Class
CheckList Members
CheckList Overload
NFX.Health Namespace


CheckList Constructor (String, String, ConfigSectionNode)

CheckList Constructor (String, String, ConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializaes check list from assembly names separated by semicolons. Optional path will be prepended to every assembly name

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CheckList(
    string path,
    string checkAssemblies,
    ConfigSectionNode config
)
public CheckList(
    string path,
    string checkAssemblies,
    ConfigSectionNode config
)
Public Sub New (
    path As String,
    checkAssemblies As String,
    config As ConfigSectionNode
)
Public Sub New (
    path As String,
    checkAssemblies As String,
    config As ConfigSectionNode
)
public:
CheckList(
    String^ path,
    String^ checkAssemblies,
    ConfigSectionNode^ config
)
public:
CheckList(
    String^ path,
    String^ checkAssemblies,
    ConfigSectionNode^ config
)
new :
        path : string *
        checkAssemblies : string *
        config : ConfigSectionNode -> CheckList
new :
        path : string *
        checkAssemblies : string *
        config : ConfigSectionNode -> CheckList

Parameters

path
Type: Online System String
checkAssemblies
Type: Online System String
config
Type: NFX.Environment ConfigSectionNode
See Also
CheckList Class
CheckList Members
CheckList Overload
NFX.Health Namespace


CheckList Methods

CheckList Methods NFX Class Library

The CheckList type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Report | Dumps check results into writer in on of the supported formats
Public method | Run | Runs health checks. Checks are ran in NO PARTICULAR order. This method can not be called twice
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CheckList Class
NFX.Health Namespace


CheckList.Report Method

CheckList Report Method NFX Class Library

Dumps check results into writer in on of the supported formats

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Report(
    TextWriter writer,
    string format
)
public string Report(
    TextWriter writer,
    string format
)
Public Function Report (
    writer As TextWriter,
    format As String
) As String
Public Function Report (
    writer As TextWriter,
    format As String
) As String
public:
String^ Report(
    TextWriter^ writer,
    String^ format
)
public:
String^ Report(
    TextWriter^ writer,
    String^ format
)
member Report :
        writer : TextWriter *
        format : string -> string
member Report :
        writer : TextWriter *
        format : string -> string

Parameters

writer
Type: Online System.IO TextWriter
format
Type: Online System String

Return Value

Type: Online String
See Also
CheckList Class
CheckList Members
NFX.Health Namespace


CheckList.Run Method

CheckList Run Method NFX Class Library

Runs health checks. Checks are ran in NO PARTICULAR order. This method can not be called twice

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Run(
    NameValueCollection parameters
)
public void Run(
    NameValueCollection parameters
)
Public Sub Run (
    parameters As NameValueCollection
)
Public Sub Run (
    parameters As NameValueCollection
)
public:
void Run(
    NameValueCollection^ parameters
)
public:
void Run(
    NameValueCollection^ parameters
)
member Run :
        parameters : NameValueCollection -> unit
member Run :
        parameters : NameValueCollection -> unit

Parameters

parameters
Type: Online System.Collections.Specialized NameValueCollection
See Also
CheckList Class
CheckList Members
NFX.Health Namespace


CheckList Properties

CheckList Properties NFX Class Library

The CheckList type exposes the following members.
Properties
 | Name | Description
Public property | AllSuccessful | Returns true when all checks have successfuly run
Public property | Checks | Returns health checks
Public property | RunFinish | Returns when run finished
Public property | RunStart | Returns when run started
Public property | Status | Returns current status - whether checks are running or have already been run
Public property | Successful | Returns true when all checks that could be run have successfuly run
Back to Top
See Also
CheckList Class
NFX.Health Namespace


CheckList.AllSuccessful Property

CheckList AllSuccessful Property NFX Class Library

Returns true when all checks have successfuly run

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool AllSuccessful { get; }
public bool AllSuccessful { get; }
Public ReadOnly Property AllSuccessful As Boolean
    Get
Public ReadOnly Property AllSuccessful As Boolean
    Get
public:
property bool AllSuccessful {
    bool get ();
}
public:
property bool AllSuccessful {
    bool get ();
}
member AllSuccessful : bool with get
member AllSuccessful : bool with get

Property Value

Type: Online Boolean
See Also
CheckList Class
CheckList Members
NFX.Health Namespace


CheckList.Checks Property

CheckList Checks Property NFX Class Library

Returns health checks

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<BaseCheck> Checks { get; }
public IEnumerable<BaseCheck> Checks { get; }
Public ReadOnly Property Checks As IEnumerable(Of BaseCheck)
    Get
Public ReadOnly Property Checks As IEnumerable(Of BaseCheck)
    Get
public:
property IEnumerable<BaseCheck^>^ Checks {
    IEnumerable<BaseCheck^>^ get ();
}
public:
property IEnumerable<BaseCheck^>^ Checks {
    IEnumerable<BaseCheck^>^ get ();
}
member Checks : IEnumerable<BaseCheck> with get
member Checks : IEnumerable<BaseCheck> with get

Property Value

Type: Online IEnumerable BaseCheck
See Also
CheckList Class
CheckList Members
NFX.Health Namespace


CheckList.RunFinish Property

CheckList RunFinish Property NFX Class Library

Returns when run finished

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> RunFinish { get; }
public Nullable<DateTime> RunFinish { get; }
Public ReadOnly Property RunFinish As Nullable(Of DateTime)
    Get
Public ReadOnly Property RunFinish As Nullable(Of DateTime)
    Get
public:
property Nullable<DateTime> RunFinish {
    Nullable<DateTime> get ();
}
public:
property Nullable<DateTime> RunFinish {
    Nullable<DateTime> get ();
}
member RunFinish : Nullable<DateTime> with get
member RunFinish : Nullable<DateTime> with get

Property Value

Type: Online Nullable Online DateTime
See Also
CheckList Class
CheckList Members
NFX.Health Namespace


CheckList.RunStart Property

CheckList RunStart Property NFX Class Library

Returns when run started

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> RunStart { get; }
public Nullable<DateTime> RunStart { get; }
Public ReadOnly Property RunStart As Nullable(Of DateTime)
    Get
Public ReadOnly Property RunStart As Nullable(Of DateTime)
    Get
public:
property Nullable<DateTime> RunStart {
    Nullable<DateTime> get ();
}
public:
property Nullable<DateTime> RunStart {
    Nullable<DateTime> get ();
}
member RunStart : Nullable<DateTime> with get
member RunStart : Nullable<DateTime> with get

Property Value

Type: Online Nullable Online DateTime
See Also
CheckList Class
CheckList Members
NFX.Health Namespace


CheckList.Status Property

CheckList Status Property NFX Class Library

Returns current status - whether checks are running or have already been run

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CheckListStatus Status { get; }
public CheckListStatus Status { get; }
Public ReadOnly Property Status As CheckListStatus
    Get
Public ReadOnly Property Status As CheckListStatus
    Get
public:
property CheckListStatus Status {
    CheckListStatus get ();
}
public:
property CheckListStatus Status {
    CheckListStatus get ();
}
member Status : CheckListStatus with get
member Status : CheckListStatus with get

Property Value

Type: CheckListStatus
See Also
CheckList Class
CheckList Members
NFX.Health Namespace


CheckList.Successful Property

CheckList Successful Property NFX Class Library

Returns true when all checks that could be run have successfuly run

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Successful { get; }
public bool Successful { get; }
Public ReadOnly Property Successful As Boolean
    Get
Public ReadOnly Property Successful As Boolean
    Get
public:
property bool Successful {
    bool get ();
}
public:
property bool Successful {
    bool get ();
}
member Successful : bool with get
member Successful : bool with get

Property Value

Type: Online Boolean
See Also
CheckList Class
CheckList Members
NFX.Health Namespace


CheckListStatus Enumeration

CheckListStatus Enumeration NFX Class Library

Stipulates status for Health.CheckList

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum CheckListStatus
public enum CheckListStatus
Public Enumeration CheckListStatus
Public Enumeration CheckListStatus
public enum class CheckListStatus
public enum class CheckListStatus
type CheckListStatus
type CheckListStatus
Members
Member name | Value | Description
Created | 0 |
Running | 1 |
Run | 2 |
See Also
NFX.Health Namespace


CheckResult Class

CheckResult Class NFX Class Library

Property bag to report health check results
Inheritance Hierarchy
Online System Object
Online System.Collections.Generic Dictionary Online String, Online Object
NFX.Health CheckResult

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CheckResult : Dictionary<string, Object>
public class CheckResult : Dictionary<string, Object>
Public Class CheckResult
    Inherits Dictionary(Of String, Object)
Public Class CheckResult
    Inherits Dictionary(Of String, Object)
public ref class CheckResult : public Dictionary<String^, Object^>
public ref class CheckResult : public Dictionary<String^, Object^>
type CheckResult =
    class
        inherit Dictionary<string, Object>
    end
type CheckResult =
    class
        inherit Dictionary<string, Object>
    end
See Also
CheckResult Members
NFX.Health Namespace


CheckResult Members

CheckResult Members NFX Class Library

The CheckResult type exposes the following members.
Constructors
 | Name | Description
Public method | CheckResult | Initializes a new instance of the CheckResult class
Back to Top
Methods
 | Name | Description
Public method | Online Add | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online Clear | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online ContainsKey | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online ContainsValue | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online Dictionary TKey, TValue instance. (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online Remove | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TryGetValue | (Inherited from Online Dictionary Online String, Online Object .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online Comparer | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Online Count | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Exception | Exception that surfaced during check, consequently failing the check
Public property | Online Item | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Online Keys | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Skipped | Indicates whether check was not run
Public property | Successful | Indicates whether health check succeeded
Public property | Online Values | (Inherited from Online Dictionary Online String, Online Object .)
Back to Top
See Also
CheckResult Class
NFX.Health Namespace


CheckResult Constructor

CheckResult Constructor NFX Class Library

Initializes a new instance of the CheckResult class

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CheckResult()
public CheckResult()
Public Sub New
Public Sub New
public:
CheckResult()
public:
CheckResult()
new : unit -> CheckResult
new : unit -> CheckResult
See Also
CheckResult Class
CheckResult Members
NFX.Health Namespace


CheckResult Methods

CheckResult Methods NFX Class Library

The CheckResult type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online Clear | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online ContainsKey | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online ContainsValue | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online Dictionary TKey, TValue instance. (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online Remove | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TryGetValue | (Inherited from Online Dictionary Online String, Online Object .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CheckResult Class
NFX.Health Namespace


CheckResult Properties

CheckResult Properties NFX Class Library

The CheckResult type exposes the following members.
Properties
 | Name | Description
Public property | Online Comparer | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Online Count | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Exception | Exception that surfaced during check, consequently failing the check
Public property | Online Item | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Online Keys | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Skipped | Indicates whether check was not run
Public property | Successful | Indicates whether health check succeeded
Public property | Online Values | (Inherited from Online Dictionary Online String, Online Object .)
Back to Top
See Also
CheckResult Class
NFX.Health Namespace


CheckResult.Exception Property

CheckResult Exception Property NFX Class Library

Exception that surfaced during check, consequently failing the check

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Exception Exception { get; internal set; }
public Exception Exception { get; internal set; }
Public Property Exception As Exception
    Get
    Friend Set
Public Property Exception As Exception
    Get
    Friend Set
public:
property Exception^ Exception {
    Exception^ get ();
    internal: void set (Exception^ value);
}
public:
property Exception^ Exception {
    Exception^ get ();
    internal: void set (Exception^ value);
}
member Exception : Exception with get, internal set
member Exception : Exception with get, internal set

Property Value

Type: Online Exception
See Also
CheckResult Class
CheckResult Members
NFX.Health Namespace


CheckResult.Skipped Property

CheckResult Skipped Property NFX Class Library

Indicates whether check was not run

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Skipped { get; internal set; }
public bool Skipped { get; internal set; }
Public Property Skipped As Boolean
    Get
    Friend Set
Public Property Skipped As Boolean
    Get
    Friend Set
public:
property bool Skipped {
    bool get ();
    internal: void set (bool value);
}
public:
property bool Skipped {
    bool get ();
    internal: void set (bool value);
}
member Skipped : bool with get, internal set
member Skipped : bool with get, internal set

Property Value

Type: Online Boolean
See Also
CheckResult Class
CheckResult Members
NFX.Health Namespace


CheckResult.Successful Property

CheckResult Successful Property NFX Class Library

Indicates whether health check succeeded

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Successful { get; }
public bool Successful { get; }
Public ReadOnly Property Successful As Boolean
    Get
Public ReadOnly Property Successful As Boolean
    Get
public:
property bool Successful {
    bool get ();
}
public:
property bool Successful {
    bool get ();
}
member Successful : bool with get
member Successful : bool with get

Property Value

Type: Online Boolean
See Also
CheckResult Class
CheckResult Members
NFX.Health Namespace


HealthCheckListException Class

HealthCheckListException Class NFX Class Library

Thrown by Health.CheckList
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Health HealthCheckListException

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class HealthCheckListException : NFXException
[SerializableAttribute]
public class HealthCheckListException : NFXException
<SerializableAttribute>
Public Class HealthCheckListException
    Inherits NFXException
<SerializableAttribute>
Public Class HealthCheckListException
    Inherits NFXException
[SerializableAttribute]
public ref class HealthCheckListException : public NFXException
[SerializableAttribute]
public ref class HealthCheckListException : public NFXException
[<SerializableAttribute>]
type HealthCheckListException =
    class
        inherit NFXException
    end
[<SerializableAttribute>]
type HealthCheckListException =
    class
        inherit NFXException
    end
See Also
HealthCheckListException Members
NFX.Health Namespace


HealthCheckListException Members

HealthCheckListException Members NFX Class Library

The HealthCheckListException type exposes the following members.
Constructors
 | Name | Description
Public method | HealthCheckListException | Initializes a new instance of the HealthCheckListException class
Public method | HealthCheckListException(String) | Initializes a new instance of the HealthCheckListException class
Protected method | HealthCheckListException(SerializationInfo, StreamingContext) | Initializes a new instance of the HealthCheckListException class
Public method | HealthCheckListException(String, Exception) | Initializes a new instance of the HealthCheckListException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
HealthCheckListException Class
NFX.Health Namespace


HealthCheckListException Constructor

HealthCheckListException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | HealthCheckListException | Initializes a new instance of the HealthCheckListException class
Public method | HealthCheckListException(String) | Initializes a new instance of the HealthCheckListException class
Protected method | HealthCheckListException(SerializationInfo, StreamingContext) | Initializes a new instance of the HealthCheckListException class
Public method | HealthCheckListException(String, Exception) | Initializes a new instance of the HealthCheckListException class
Back to Top
See Also
HealthCheckListException Class
HealthCheckListException Members
NFX.Health Namespace


HealthCheckListException Constructor

HealthCheckListException Constructor NFX Class Library

Initializes a new instance of the HealthCheckListException class

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HealthCheckListException()
public HealthCheckListException()
Public Sub New
Public Sub New
public:
HealthCheckListException()
public:
HealthCheckListException()
new : unit -> HealthCheckListException
new : unit -> HealthCheckListException
See Also
HealthCheckListException Class
HealthCheckListException Members
HealthCheckListException Overload
NFX.Health Namespace


HealthCheckListException Constructor (String)

HealthCheckListException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HealthCheckListException class

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HealthCheckListException(
    string message
)
public HealthCheckListException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
HealthCheckListException(
    String^ message
)
public:
HealthCheckListException(
    String^ message
)
new :
        message : string -> HealthCheckListException
new :
        message : string -> HealthCheckListException

Parameters

message
Type: Online System String
See Also
HealthCheckListException Class
HealthCheckListException Members
HealthCheckListException Overload
NFX.Health Namespace


HealthCheckListException Constructor (SerializationInfo, StreamingContext)

HealthCheckListException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HealthCheckListException class

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected HealthCheckListException(
    SerializationInfo info,
    StreamingContext context
)
protected HealthCheckListException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
HealthCheckListException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
HealthCheckListException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> HealthCheckListException
new :
        info : SerializationInfo *
        context : StreamingContext -> HealthCheckListException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
HealthCheckListException Class
HealthCheckListException Members
HealthCheckListException Overload
NFX.Health Namespace


HealthCheckListException Constructor (String, Exception)

HealthCheckListException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HealthCheckListException class

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HealthCheckListException(
    string message,
    Exception inner
)
public HealthCheckListException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
HealthCheckListException(
    String^ message,
    Exception^ inner
)
public:
HealthCheckListException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> HealthCheckListException
new :
        message : string *
        inner : Exception -> HealthCheckListException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
HealthCheckListException Class
HealthCheckListException Members
HealthCheckListException Overload
NFX.Health Namespace


HealthCheckListException Methods

HealthCheckListException Methods NFX Class Library

The HealthCheckListException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
HealthCheckListException Class
NFX.Health Namespace


HealthCheckListException Properties

HealthCheckListException Properties NFX Class Library

The HealthCheckListException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
HealthCheckListException Class
NFX.Health Namespace


HealthCheckListException Events

HealthCheckListException Events NFX Class Library

The HealthCheckListException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
HealthCheckListException Class
NFX.Health Namespace


HealthException Class

HealthException Class NFX Class Library

Represents general ancestor for exceptions thrown by health checks
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Health HealthException

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class HealthException : NFXException
[SerializableAttribute]
public class HealthException : NFXException
<SerializableAttribute>
Public Class HealthException
    Inherits NFXException
<SerializableAttribute>
Public Class HealthException
    Inherits NFXException
[SerializableAttribute]
public ref class HealthException : public NFXException
[SerializableAttribute]
public ref class HealthException : public NFXException
[<SerializableAttribute>]
type HealthException =
    class
        inherit NFXException
    end
[<SerializableAttribute>]
type HealthException =
    class
        inherit NFXException
    end
See Also
HealthException Members
NFX.Health Namespace


HealthException Members

HealthException Members NFX Class Library

The HealthException type exposes the following members.
Constructors
 | Name | Description
Public method | HealthException | Initializes a new instance of the HealthException class
Public method | HealthException(String) | Initializes a new instance of the HealthException class
Protected method | HealthException(SerializationInfo, StreamingContext) | Initializes a new instance of the HealthException class
Public method | HealthException(String, Exception) | Initializes a new instance of the HealthException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
HealthException Class
NFX.Health Namespace


HealthException Constructor

HealthException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | HealthException | Initializes a new instance of the HealthException class
Public method | HealthException(String) | Initializes a new instance of the HealthException class
Protected method | HealthException(SerializationInfo, StreamingContext) | Initializes a new instance of the HealthException class
Public method | HealthException(String, Exception) | Initializes a new instance of the HealthException class
Back to Top
See Also
HealthException Class
HealthException Members
NFX.Health Namespace


HealthException Constructor

HealthException Constructor NFX Class Library

Initializes a new instance of the HealthException class

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HealthException()
public HealthException()
Public Sub New
Public Sub New
public:
HealthException()
public:
HealthException()
new : unit -> HealthException
new : unit -> HealthException
See Also
HealthException Class
HealthException Members
HealthException Overload
NFX.Health Namespace


HealthException Constructor (String)

HealthException Constructor (String) NFX Class Library

Initializes a new instance of the HealthException class

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HealthException(
    string message
)
public HealthException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
HealthException(
    String^ message
)
public:
HealthException(
    String^ message
)
new :
        message : string -> HealthException
new :
        message : string -> HealthException

Parameters

message
Type: Online System String
See Also
HealthException Class
HealthException Members
HealthException Overload
NFX.Health Namespace


HealthException Constructor (SerializationInfo, StreamingContext)

HealthException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HealthException class

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected HealthException(
    SerializationInfo info,
    StreamingContext context
)
protected HealthException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
HealthException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
HealthException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> HealthException
new :
        info : SerializationInfo *
        context : StreamingContext -> HealthException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
HealthException Class
HealthException Members
HealthException Overload
NFX.Health Namespace


HealthException Constructor (String, Exception)

HealthException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HealthException class

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HealthException(
    string message,
    Exception inner
)
public HealthException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
HealthException(
    String^ message,
    Exception^ inner
)
public:
HealthException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> HealthException
new :
        message : string *
        inner : Exception -> HealthException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
HealthException Class
HealthException Members
HealthException Overload
NFX.Health Namespace


HealthException Methods

HealthException Methods NFX Class Library

The HealthException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
HealthException Class
NFX.Health Namespace


HealthException Properties

HealthException Properties NFX Class Library

The HealthException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
HealthException Class
NFX.Health Namespace


HealthException Events

HealthException Events NFX Class Library

The HealthException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
HealthException Class
NFX.Health Namespace


HTMLReporter Class

HTMLReporter Class NFX Class Library

Reports health check results as HTML
Inheritance Hierarchy
Online System Object
NFX.Health Reporter
NFX.Health HTMLReporter

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class HTMLReporter : Reporter
public class HTMLReporter : Reporter
Public Class HTMLReporter
    Inherits Reporter
Public Class HTMLReporter
    Inherits Reporter
public ref class HTMLReporter : public Reporter
public ref class HTMLReporter : public Reporter
type HTMLReporter =
    class
        inherit Reporter
    end
type HTMLReporter =
    class
        inherit Reporter
    end
See Also
HTMLReporter Members
NFX.Health Namespace


HTMLReporter Members

HTMLReporter Members NFX Class Library

The HTMLReporter type exposes the following members.
Constructors
 | Name | Description
Public method | HTMLReporter | Initializes a new instance of the HTMLReporter class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Report | (Overrides Reporter Report(TextWriter).)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | CheckList | (Inherited from Reporter.)
Back to Top
See Also
HTMLReporter Class
NFX.Health Namespace


HTMLReporter Constructor

HTMLReporter Constructor NFX Class Library

Initializes a new instance of the HTMLReporter class

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HTMLReporter(
    CheckList list
)
public HTMLReporter(
    CheckList list
)
Public Sub New (
    list As CheckList
)
Public Sub New (
    list As CheckList
)
public:
HTMLReporter(
    CheckList^ list
)
public:
HTMLReporter(
    CheckList^ list
)
new :
        list : CheckList -> HTMLReporter
new :
        list : CheckList -> HTMLReporter

Parameters

list
Type: NFX.Health CheckList
See Also
HTMLReporter Class
HTMLReporter Members
NFX.Health Namespace


HTMLReporter Methods

HTMLReporter Methods NFX Class Library

The HTMLReporter type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Report | (Overrides Reporter Report(TextWriter).)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
HTMLReporter Class
NFX.Health Namespace


HTMLReporter.Report Method

HTMLReporter Report Method NFX Class Library

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Report(
    TextWriter writer
)
public override void Report(
    TextWriter writer
)
Public Overrides Sub Report (
    writer As TextWriter
)
Public Overrides Sub Report (
    writer As TextWriter
)
public:
virtual void Report(
    TextWriter^ writer
) override
public:
virtual void Report(
    TextWriter^ writer
) override
abstract Report :
        writer : TextWriter -> unit
override Report :
        writer : TextWriter -> unit
abstract Report :
        writer : TextWriter -> unit
override Report :
        writer : TextWriter -> unit

Parameters

writer
Type: Online System.IO TextWriter
See Also
HTMLReporter Class
HTMLReporter Members
NFX.Health Namespace


HTMLReporter Properties

HTMLReporter Properties NFX Class Library

The HTMLReporter type exposes the following members.
Properties
 | Name | Description
Public property | CheckList | (Inherited from Reporter.)
Back to Top
See Also
HTMLReporter Class
NFX.Health Namespace


Reporter Class

Reporter Class NFX Class Library

Base for all reporters - entities that output check list state into TextWriter
Inheritance Hierarchy
Online System Object
NFX.Health Reporter
NFX.Health HTMLReporter
NFX.Health TextReporter
NFX.Health XMLReporter

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Reporter
public abstract class Reporter
Public MustInherit Class Reporter
Public MustInherit Class Reporter
public ref class Reporter abstract
public ref class Reporter abstract
[<AbstractClassAttribute>]
type Reporter =  class end
[<AbstractClassAttribute>]
type Reporter =  class end
See Also
Reporter Members
NFX.Health Namespace


Reporter Members

Reporter Members NFX Class Library

The Reporter type exposes the following members.
Constructors
 | Name | Description
Protected method | Reporter | Initializes a new instance of the Reporter class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Report |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | CheckList |
Back to Top
See Also
Reporter Class
NFX.Health Namespace


Reporter Constructor

Reporter Constructor NFX Class Library

Initializes a new instance of the Reporter class

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Reporter(
    CheckList list
)
protected Reporter(
    CheckList list
)
Protected Sub New (
    list As CheckList
)
Protected Sub New (
    list As CheckList
)
protected:
Reporter(
    CheckList^ list
)
protected:
Reporter(
    CheckList^ list
)
new :
        list : CheckList -> Reporter
new :
        list : CheckList -> Reporter

Parameters

list
Type: NFX.Health CheckList
See Also
Reporter Class
Reporter Members
NFX.Health Namespace


Reporter Methods

Reporter Methods NFX Class Library

The Reporter type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Report |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Reporter Class
NFX.Health Namespace


Reporter.Report Method

Reporter Report Method NFX Class Library

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Report(
    TextWriter writer
)
public abstract void Report(
    TextWriter writer
)
Public MustOverride Sub Report (
    writer As TextWriter
)
Public MustOverride Sub Report (
    writer As TextWriter
)
public:
virtual void Report(
    TextWriter^ writer
) abstract
public:
virtual void Report(
    TextWriter^ writer
) abstract
abstract Report :
        writer : TextWriter -> unit
abstract Report :
        writer : TextWriter -> unit

Parameters

writer
Type: Online System.IO TextWriter
See Also
Reporter Class
Reporter Members
NFX.Health Namespace


Reporter Properties

Reporter Properties NFX Class Library

The Reporter type exposes the following members.
Properties
 | Name | Description
Public property | CheckList |
Back to Top
See Also
Reporter Class
NFX.Health Namespace


Reporter.CheckList Property

Reporter CheckList Property NFX Class Library

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CheckList CheckList { get; }
public CheckList CheckList { get; }
Public ReadOnly Property CheckList As CheckList
    Get
Public ReadOnly Property CheckList As CheckList
    Get
public:
property CheckList^ CheckList {
    CheckList^ get ();
}
public:
property CheckList^ CheckList {
    CheckList^ get ();
}
member CheckList : CheckList with get
member CheckList : CheckList with get

Property Value

Type: CheckList
See Also
Reporter Class
Reporter Members
NFX.Health Namespace


TextReporter Class

TextReporter Class NFX Class Library

Reports health check results in an plain text format
Inheritance Hierarchy
Online System Object
NFX.Health Reporter
NFX.Health TextReporter

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TextReporter : Reporter
public class TextReporter : Reporter
Public Class TextReporter
    Inherits Reporter
Public Class TextReporter
    Inherits Reporter
public ref class TextReporter : public Reporter
public ref class TextReporter : public Reporter
type TextReporter =
    class
        inherit Reporter
    end
type TextReporter =
    class
        inherit Reporter
    end
See Also
TextReporter Members
NFX.Health Namespace


TextReporter Members

TextReporter Members NFX Class Library

The TextReporter type exposes the following members.
Constructors
 | Name | Description
Public method | TextReporter | Initializes a new instance of the TextReporter class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Report | (Overrides Reporter Report(TextWriter).)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | CheckList | (Inherited from Reporter.)
Back to Top
See Also
TextReporter Class
NFX.Health Namespace


TextReporter Constructor

TextReporter Constructor NFX Class Library

Initializes a new instance of the TextReporter class

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TextReporter(
    CheckList list
)
public TextReporter(
    CheckList list
)
Public Sub New (
    list As CheckList
)
Public Sub New (
    list As CheckList
)
public:
TextReporter(
    CheckList^ list
)
public:
TextReporter(
    CheckList^ list
)
new :
        list : CheckList -> TextReporter
new :
        list : CheckList -> TextReporter

Parameters

list
Type: NFX.Health CheckList
See Also
TextReporter Class
TextReporter Members
NFX.Health Namespace


TextReporter Methods

TextReporter Methods NFX Class Library

The TextReporter type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Report | (Overrides Reporter Report(TextWriter).)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TextReporter Class
NFX.Health Namespace


TextReporter.Report Method

TextReporter Report Method NFX Class Library

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Report(
    TextWriter writer
)
public override void Report(
    TextWriter writer
)
Public Overrides Sub Report (
    writer As TextWriter
)
Public Overrides Sub Report (
    writer As TextWriter
)
public:
virtual void Report(
    TextWriter^ writer
) override
public:
virtual void Report(
    TextWriter^ writer
) override
abstract Report :
        writer : TextWriter -> unit
override Report :
        writer : TextWriter -> unit
abstract Report :
        writer : TextWriter -> unit
override Report :
        writer : TextWriter -> unit

Parameters

writer
Type: Online System.IO TextWriter
See Also
TextReporter Class
TextReporter Members
NFX.Health Namespace


TextReporter Properties

TextReporter Properties NFX Class Library

The TextReporter type exposes the following members.
Properties
 | Name | Description
Public property | CheckList | (Inherited from Reporter.)
Back to Top
See Also
TextReporter Class
NFX.Health Namespace


XMLReporter Class

XMLReporter Class NFX Class Library

Reports XML health check results
Inheritance Hierarchy
Online System Object
NFX.Health Reporter
NFX.Health XMLReporter

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class XMLReporter : Reporter
public class XMLReporter : Reporter
Public Class XMLReporter
    Inherits Reporter
Public Class XMLReporter
    Inherits Reporter
public ref class XMLReporter : public Reporter
public ref class XMLReporter : public Reporter
type XMLReporter =
    class
        inherit Reporter
    end
type XMLReporter =
    class
        inherit Reporter
    end
See Also
XMLReporter Members
NFX.Health Namespace


XMLReporter Members

XMLReporter Members NFX Class Library

The XMLReporter type exposes the following members.
Constructors
 | Name | Description
Public method | XMLReporter | Initializes a new instance of the XMLReporter class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Report | (Overrides Reporter Report(TextWriter).)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | CheckList | (Inherited from Reporter.)
Back to Top
See Also
XMLReporter Class
NFX.Health Namespace


XMLReporter Constructor

XMLReporter Constructor NFX Class Library

Initializes a new instance of the XMLReporter class

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public XMLReporter(
    CheckList list
)
public XMLReporter(
    CheckList list
)
Public Sub New (
    list As CheckList
)
Public Sub New (
    list As CheckList
)
public:
XMLReporter(
    CheckList^ list
)
public:
XMLReporter(
    CheckList^ list
)
new :
        list : CheckList -> XMLReporter
new :
        list : CheckList -> XMLReporter

Parameters

list
Type: NFX.Health CheckList
See Also
XMLReporter Class
XMLReporter Members
NFX.Health Namespace


XMLReporter Methods

XMLReporter Methods NFX Class Library

The XMLReporter type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Report | (Overrides Reporter Report(TextWriter).)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
XMLReporter Class
NFX.Health Namespace


XMLReporter.Report Method

XMLReporter Report Method NFX Class Library

Namespace: NFX.Health
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Report(
    TextWriter writer
)
public override void Report(
    TextWriter writer
)
Public Overrides Sub Report (
    writer As TextWriter
)
Public Overrides Sub Report (
    writer As TextWriter
)
public:
virtual void Report(
    TextWriter^ writer
) override
public:
virtual void Report(
    TextWriter^ writer
) override
abstract Report :
        writer : TextWriter -> unit
override Report :
        writer : TextWriter -> unit
abstract Report :
        writer : TextWriter -> unit
override Report :
        writer : TextWriter -> unit

Parameters

writer
Type: Online System.IO TextWriter
See Also
XMLReporter Class
XMLReporter Members
NFX.Health Namespace


XMLReporter Properties

XMLReporter Properties NFX Class Library

The XMLReporter type exposes the following members.
Properties
 | Name | Description
Public property | CheckList | (Inherited from Reporter.)
Back to Top
See Also
XMLReporter Class
NFX.Health Namespace


NFX.Instrumentation Namespace

NFX.Instrumentation Namespace NFX Class Library

Provides base types for Instrumentation: gauges, events, providers
Classes
 | Class | Description
Public class | AmountGauge | Represents a general-purpose financial Amount measurement datum
Public class | Datum | Base class for single measurement events (datums) reported to instrumentation
Protected class | DatumBag | Internal concurrent bag used for instrumentation data aggregation
Public class | DecimalGauge | Represents a general-purpose decimal measurement datum
Public class | DoubleGauge | Represents a general-purpose double measurement datum
Public class | Event | Represents a base for events that happen so instrumentation can calculate event counts and rates of occurence
Public class | ExceptionEvent | Represents an exception event recorded by instrumentation
Public class | Gauge | Represents a base for gauges - events of measurement of some values
Public class | InstrumentationProvider | Defines a base provider for InstrumentationService
Public class | InstrumentationService | Implements IInstrumentation. This service aggregates data by type,source and sends result into provider
Public class | InstrumentViewGroup | Denotes interface types that participate in instrumentation data grouping. Records that implement several classification interfaces which are decorated by this attribute get listed in each decorated interface/group
Public class | LogInstrumentationProvider | Represents a provider that writes aggregated datums to log
Public class | LongGauge | Represents a general-purpose long integer measurement datum
Public class | NOPInstrumentation | Provides IInstrumentation implementation that does nothing
Public class | NOPInstrumentationProvider | Represents a provider that does nothing
Protected class | SrcBucketedData | Internal concurrent dictionary used for instrumentation data aggregation
Protected class | TypeBucketedData | Internal concurrent dictionary used for instrumentation data aggregation
Interfaces
 | Interface | Description
Public interface | IBusinessLogic | A class of operations related to business logic that instrument measures
Public interface | ICacheInstrument | Cache-related operations
Public interface | ICatastropyInstrument | Data of this class indicates an abnormality that will most likely lead to system inability to continue functioning as expected
Public interface | ICPUInstrument | CPU-related operations
Public interface | IDatabaseInstrument | DB-related operations
Public interface | IDiskInstrument | Disk operations (i.e. % drive free)
Public interface | IErrorInstrument | Data of this class indicates a definite abnormality, however the system is going to continue functioning
Public interface | IFinancialLogic | A class of operations related to financial transactions / business logic
Public interface | IGDIDInstrument | GDID-related operations
Public interface | IInstrumentable | Denotes an entity that can be instrumented
Public interface | IInstrumentation | Stipulates instrumentation contract
Public interface | IInstrumentationImplementation | Stipulates instrumentation contract
Public interface | IInstrumentationInstrument | Instruments that measure instrumentation itself
Public interface | IInstrumentClass | Root marker interface for instrumentation data classification. Instruments are primarily classified by their derivation from Datum ancestor, however this interface-based scheme allows for alternate classification (a la multiple inheritance)
Public interface | IIOInstrumentClass | IO-related operations
Public interface | ILockingInstrument | Locking/coordination-related operations
Public interface | IMemoryInstrument | Memory-related operations
Public interface | INetInstrument | Network operations (i.e. sockets)
Public interface | IOperationClass | A class of operations that instrument measures
Public interface | IProblemClass | A class of problem that decorate instrument represents
Public interface | IQueueInstrument | Queue-related operations
Public interface | ISchedulingInstrument | Timer/scheduling-related operations
Public interface | ISecurityInstrument | Security-related operations
Public interface | ISocialLogic | A class of operations related to social operations / business logic
Public interface | IWarningInstrument | Data of this class indicates some abnormality in operation, i.e. "LowDisk"
Public interface | IWebInstrument | Web-related operations
Public interface | IWorkerInstrument | Worker-related operations i.e. Todo queue


AmountGauge Class

AmountGauge Class NFX Class Library

Represents a general-purpose financial Amount measurement datum
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation AmountGauge
NFX.Web.Pay.Instrumentation PayAmountGauge

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class AmountGauge : Gauge,
    IFinancialLogic, IBusinessLogic, IOperationClass, IInstrumentClass
[SerializableAttribute]
public abstract class AmountGauge : Gauge,
    IFinancialLogic, IBusinessLogic, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public MustInherit Class AmountGauge
    Inherits Gauge
    Implements IFinancialLogic, IBusinessLogic, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public MustInherit Class AmountGauge
    Inherits Gauge
    Implements IFinancialLogic, IBusinessLogic, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class AmountGauge abstract : public Gauge,
    IFinancialLogic, IBusinessLogic, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class AmountGauge abstract : public Gauge,
    IFinancialLogic, IBusinessLogic, IOperationClass, IInstrumentClass
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type AmountGauge =
    class
        inherit Gauge
        interface IFinancialLogic
        interface IBusinessLogic
        interface IOperationClass
        interface IInstrumentClass
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type AmountGauge =
    class
        inherit Gauge
        interface IFinancialLogic
        interface IBusinessLogic
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
AmountGauge Members
NFX.Instrumentation Namespace


AmountGauge Members

AmountGauge Members NFX Class Library

The AmountGauge type exposes the following members.
Constructors
 | Name | Description
Protected method | AmountGauge(String, Amount) | Initializes a new instance of the AmountGauge class
Protected method | AmountGauge(String, Amount, DateTime, Boolean) | Initializes a new instance of the AmountGauge class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Overrides Datum AggregateEvent(Datum).)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Overrides Datum SummarizeAggregation .)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | CURRENCY_DELIM |
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | (Overrides Datum PlotValue.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value
Public property | ValueAsObject | (Overrides Datum ValueAsObject.)
Public property | ValueUnitName | (Overrides Datum ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
AmountGauge Class
NFX.Instrumentation Namespace


AmountGauge Constructor

AmountGauge Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | AmountGauge(String, Amount) | Initializes a new instance of the AmountGauge class
Protected method | AmountGauge(String, Amount, DateTime, Boolean) | Initializes a new instance of the AmountGauge class
Back to Top
See Also
AmountGauge Class
AmountGauge Members
NFX.Instrumentation Namespace


AmountGauge Constructor (String, Amount)

AmountGauge Constructor (String, Amount) NFX Class Library

Initializes a new instance of the AmountGauge class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected AmountGauge(
    string source,
    Amount value
)
protected AmountGauge(
    string source,
    Amount value
)
Protected Sub New (
    source As String,
    value As Amount
)
Protected Sub New (
    source As String,
    value As Amount
)
protected:
AmountGauge(
    String^ source,
    Amount value
)
protected:
AmountGauge(
    String^ source,
    Amount value
)
new :
        source : string *
        value : Amount -> AmountGauge
new :
        source : string *
        value : Amount -> AmountGauge

Parameters

source
Type: Online System String
value
Type: NFX.Financial Amount
See Also
AmountGauge Class
AmountGauge Members
AmountGauge Overload
NFX.Instrumentation Namespace


AmountGauge Constructor (String, Amount, DateTime, Boolean)

AmountGauge Constructor (String, Amount, DateTime, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AmountGauge class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected AmountGauge(
    string source,
    Amount value,
    DateTime utcDateTime,
    bool skipSourceConstruction = false
)
protected AmountGauge(
    string source,
    Amount value,
    DateTime utcDateTime,
    bool skipSourceConstruction = false
)
Protected Sub New (
    source As String,
    value As Amount,
    utcDateTime As DateTime,
    Optional skipSourceConstruction As Boolean = false
)
Protected Sub New (
    source As String,
    value As Amount,
    utcDateTime As DateTime,
    Optional skipSourceConstruction As Boolean = false
)
protected:
AmountGauge(
    String^ source,
    Amount value,
    DateTime utcDateTime,
    bool skipSourceConstruction = false
)
protected:
AmountGauge(
    String^ source,
    Amount value,
    DateTime utcDateTime,
    bool skipSourceConstruction = false
)
new :
        source : string *
        value : Amount *
        utcDateTime : DateTime *
        ?skipSourceConstruction : bool
(* Defaults:
        let _skipSourceConstruction = defaultArg skipSourceConstruction false
*)
-> AmountGauge
new :
        source : string *
        value : Amount *
        utcDateTime : DateTime *
        ?skipSourceConstruction : bool
(* Defaults:
        let _skipSourceConstruction = defaultArg skipSourceConstruction false
*)
-> AmountGauge

Parameters

source
Type: Online System String
value
Type: NFX.Financial Amount
utcDateTime
Type: Online System DateTime
skipSourceConstruction (Optional)
Type: Online System Boolean
See Also
AmountGauge Class
AmountGauge Members
AmountGauge Overload
NFX.Instrumentation Namespace


AmountGauge Fields

AmountGauge Fields NFX Class Library

The AmountGauge type exposes the following members.
Fields
 | Name | Description
 | CURRENCY_DELIM |
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
AmountGauge Class
NFX.Instrumentation Namespace


AmountGauge.CURRENCY_DELIM Field

AmountGauge CURRENCY_DELIM Field NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CURRENCY_DELIM
public const string CURRENCY_DELIM
Public Const CURRENCY_DELIM As String
Public Const CURRENCY_DELIM As String
public:
literal String^ CURRENCY_DELIM
public:
literal String^ CURRENCY_DELIM
static val mutable CURRENCY_DELIM: string
static val mutable CURRENCY_DELIM: string

Field Value

Type: Online String
See Also
AmountGauge Class
AmountGauge Members
NFX.Instrumentation Namespace


AmountGauge Methods

AmountGauge Methods NFX Class Library

The AmountGauge type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Overrides Datum AggregateEvent(Datum).)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Overrides Datum SummarizeAggregation .)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
AmountGauge Class
NFX.Instrumentation Namespace


AmountGauge.AggregateEvent Method

AmountGauge AggregateEvent Method NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void AggregateEvent(
    Datum dat
)
protected override void AggregateEvent(
    Datum dat
)
Protected Overrides Sub AggregateEvent (
    dat As Datum
)
Protected Overrides Sub AggregateEvent (
    dat As Datum
)
protected:
virtual void AggregateEvent(
    Datum^ dat
) override
protected:
virtual void AggregateEvent(
    Datum^ dat
) override
abstract AggregateEvent :
        dat : Datum -> unit
override AggregateEvent :
        dat : Datum -> unit
abstract AggregateEvent :
        dat : Datum -> unit
override AggregateEvent :
        dat : Datum -> unit

Parameters

dat
Type: NFX.Instrumentation Datum
See Also
AmountGauge Class
AmountGauge Members
NFX.Instrumentation Namespace


AmountGauge.SummarizeAggregation Method

AmountGauge SummarizeAggregation Method NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void SummarizeAggregation()
protected override void SummarizeAggregation()
Protected Overrides Sub SummarizeAggregation
Protected Overrides Sub SummarizeAggregation
protected:
virtual void SummarizeAggregation() override
protected:
virtual void SummarizeAggregation() override
abstract SummarizeAggregation : unit -> unit
override SummarizeAggregation : unit -> unit
abstract SummarizeAggregation : unit -> unit
override SummarizeAggregation : unit -> unit
See Also
AmountGauge Class
AmountGauge Members
NFX.Instrumentation Namespace


AmountGauge Properties

AmountGauge Properties NFX Class Library

The AmountGauge type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | (Overrides Datum PlotValue.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value
Public property | ValueAsObject | (Overrides Datum ValueAsObject.)
Public property | ValueUnitName | (Overrides Datum ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
AmountGauge Class
NFX.Instrumentation Namespace


AmountGauge.PlotValue Property

AmountGauge PlotValue Property NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object PlotValue { get; }
public override Object PlotValue { get; }
Public Overrides ReadOnly Property PlotValue As Object
    Get
Public Overrides ReadOnly Property PlotValue As Object
    Get
public:
virtual property Object^ PlotValue {
    Object^ get () override;
}
public:
virtual property Object^ PlotValue {
    Object^ get () override;
}
abstract PlotValue : Object with get
override PlotValue : Object with get
abstract PlotValue : Object with get
override PlotValue : Object with get

Property Value

Type: Online Object
See Also
AmountGauge Class
AmountGauge Members
NFX.Instrumentation Namespace


AmountGauge.Value Property

AmountGauge Value Property NFX Class Library

Gets gauge value

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Amount Value { get; }
public Amount Value { get; }
Public ReadOnly Property Value As Amount
    Get
Public ReadOnly Property Value As Amount
    Get
public:
property Amount Value {
    Amount get ();
}
public:
property Amount Value {
    Amount get ();
}
member Value : Amount with get
member Value : Amount with get

Property Value

Type: Amount
See Also
AmountGauge Class
AmountGauge Members
NFX.Instrumentation Namespace


AmountGauge.ValueAsObject Property

AmountGauge ValueAsObject Property NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object ValueAsObject { get; }
public override Object ValueAsObject { get; }
Public Overrides ReadOnly Property ValueAsObject As Object
    Get
Public Overrides ReadOnly Property ValueAsObject As Object
    Get
public:
virtual property Object^ ValueAsObject {
    Object^ get () override;
}
public:
virtual property Object^ ValueAsObject {
    Object^ get () override;
}
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get

Property Value

Type: Online Object
See Also
AmountGauge Class
AmountGauge Members
NFX.Instrumentation Namespace


AmountGauge.ValueUnitName Property

AmountGauge ValueUnitName Property NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
AmountGauge Class
AmountGauge Members
NFX.Instrumentation Namespace


Datum Class

Datum Class NFX Class Library

Base class for single measurement events (datums) reported to instrumentation
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Event
NFX.Instrumentation Gauge

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class Datum : IJSONWritable
[SerializableAttribute]
public abstract class Datum : IJSONWritable
<SerializableAttribute>
Public MustInherit Class Datum
    Implements IJSONWritable
<SerializableAttribute>
Public MustInherit Class Datum
    Implements IJSONWritable
[SerializableAttribute]
public ref class Datum abstract : IJSONWritable
[SerializableAttribute]
public ref class Datum abstract : IJSONWritable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type Datum =
    class
        interface IJSONWritable
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type Datum =
    class
        interface IJSONWritable
    end
See Also
Datum Members
NFX.Instrumentation Namespace


Datum Members

Datum Members NFX Class Library

The Datum type exposes the following members.
Constructors
 | Name | Description
Protected method | Datum | Initializes a new instance of the Datum class
Protected method | Datum(String) | Initializes a new instance of the Datum class
Protected method | Datum(String, DateTime) | Initializes a new instance of the Datum class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one
Protected method | AggregateEvent |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | GetViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency
Protected method | MakeAggregateInstance |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > ""
Protected method | SummarizeAggregation |
Public method | ToString | (Overrides Online Object ToString .)
Public method | WriteAsJSON |
Protected method | WriteJSONFields |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | BUSINESS_SOURCE |
 | FRAMEWORK_SOURCE |
Protected field | m_Count |
Protected field | m_Source |
Protected field | m_UTCEndTime |
Protected field | m_UTCTime |
 | UNSPECIFIED_SOURCE |
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events
Public property | PlotValue | Provides numeric value used for charts
Public property | Rate | Returns rate of occurrence string
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned
Public property | UTCTime | Returns UTC time stamp when event happened
Public property | ValueAsObject | Provides access to value polymorphically
Public property | ValueUnitName | Provides name for units that value is measured in
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency
Back to Top
See Also
Datum Class
NFX.Instrumentation Namespace


Datum Constructor

Datum Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | Datum | Initializes a new instance of the Datum class
Protected method | Datum(String) | Initializes a new instance of the Datum class
Protected method | Datum(String, DateTime) | Initializes a new instance of the Datum class
Back to Top
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


Datum Constructor

Datum Constructor NFX Class Library

Initializes a new instance of the Datum class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Datum()
protected Datum()
Protected Sub New
Protected Sub New
protected:
Datum()
protected:
Datum()
new : unit -> Datum
new : unit -> Datum
See Also
Datum Class
Datum Members
Datum Overload
NFX.Instrumentation Namespace


Datum Constructor (String)

Datum Constructor (String) NFX Class Library

Initializes a new instance of the Datum class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Datum(
    string source
)
protected Datum(
    string source
)
Protected Sub New (
    source As String
)
Protected Sub New (
    source As String
)
protected:
Datum(
    String^ source
)
protected:
Datum(
    String^ source
)
new :
        source : string -> Datum
new :
        source : string -> Datum

Parameters

source
Type: Online System String
See Also
Datum Class
Datum Members
Datum Overload
NFX.Instrumentation Namespace


Datum Constructor (String, DateTime)

Datum Constructor (String, DateTime) NFX Class Library

Initializes a new instance of the Datum class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Datum(
    string source,
    DateTime utcDateTime
)
protected Datum(
    string source,
    DateTime utcDateTime
)
Protected Sub New (
    source As String,
    utcDateTime As DateTime
)
Protected Sub New (
    source As String,
    utcDateTime As DateTime
)
protected:
Datum(
    String^ source,
    DateTime utcDateTime
)
protected:
Datum(
    String^ source,
    DateTime utcDateTime
)
new :
        source : string *
        utcDateTime : DateTime -> Datum
new :
        source : string *
        utcDateTime : DateTime -> Datum

Parameters

source
Type: Online System String
utcDateTime
Type: Online System DateTime
See Also
Datum Class
Datum Members
Datum Overload
NFX.Instrumentation Namespace


Datum Fields

Datum Fields NFX Class Library

The Datum type exposes the following members.
Fields
 | Name | Description
 | BUSINESS_SOURCE |
 | FRAMEWORK_SOURCE |
Protected field | m_Count |
Protected field | m_Source |
Protected field | m_UTCEndTime |
Protected field | m_UTCTime |
 | UNSPECIFIED_SOURCE |
Back to Top
See Also
Datum Class
NFX.Instrumentation Namespace


Datum.BUSINESS_SOURCE Field

Datum BUSINESS_SOURCE Field NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string BUSINESS_SOURCE
public const string BUSINESS_SOURCE
Public Const BUSINESS_SOURCE As String
Public Const BUSINESS_SOURCE As String
public:
literal String^ BUSINESS_SOURCE
public:
literal String^ BUSINESS_SOURCE
static val mutable BUSINESS_SOURCE: string
static val mutable BUSINESS_SOURCE: string

Field Value

Type: Online String
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


Datum.FRAMEWORK_SOURCE Field

Datum FRAMEWORK_SOURCE Field NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FRAMEWORK_SOURCE
public const string FRAMEWORK_SOURCE
Public Const FRAMEWORK_SOURCE As String
Public Const FRAMEWORK_SOURCE As String
public:
literal String^ FRAMEWORK_SOURCE
public:
literal String^ FRAMEWORK_SOURCE
static val mutable FRAMEWORK_SOURCE: string
static val mutable FRAMEWORK_SOURCE: string

Field Value

Type: Online String
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


Datum.m_Count Field

Datum m_Count Field NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int m_Count
protected int m_Count
Protected m_Count As Integer
Protected m_Count As Integer
protected:
int m_Count
protected:
int m_Count
val mutable m_Count: int
val mutable m_Count: int

Field Value

Type: Online Int32
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


Datum.m_Source Field

Datum m_Source Field NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected string m_Source
protected string m_Source
Protected m_Source As String
Protected m_Source As String
protected:
String^ m_Source
protected:
String^ m_Source
val mutable m_Source: string
val mutable m_Source: string

Field Value

Type: Online String
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


Datum.m_UTCEndTime Field

Datum m_UTCEndTime Field NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected DateTime m_UTCEndTime
protected DateTime m_UTCEndTime
Protected m_UTCEndTime As DateTime
Protected m_UTCEndTime As DateTime
protected:
DateTime m_UTCEndTime
protected:
DateTime m_UTCEndTime
val mutable m_UTCEndTime: DateTime
val mutable m_UTCEndTime: DateTime

Field Value

Type: Online DateTime
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


Datum.m_UTCTime Field

Datum m_UTCTime Field NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected DateTime m_UTCTime
protected DateTime m_UTCTime
Protected m_UTCTime As DateTime
Protected m_UTCTime As DateTime
protected:
DateTime m_UTCTime
protected:
DateTime m_UTCTime
val mutable m_UTCTime: DateTime
val mutable m_UTCTime: DateTime

Field Value

Type: Online DateTime
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


Datum.UNSPECIFIED_SOURCE Field

Datum UNSPECIFIED_SOURCE Field NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNSPECIFIED_SOURCE
public const string UNSPECIFIED_SOURCE
Public Const UNSPECIFIED_SOURCE As String
Public Const UNSPECIFIED_SOURCE As String
public:
literal String^ UNSPECIFIED_SOURCE
public:
literal String^ UNSPECIFIED_SOURCE
static val mutable UNSPECIFIED_SOURCE: string
static val mutable UNSPECIFIED_SOURCE: string

Field Value

Type: Online String
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


Datum Methods

Datum Methods NFX Class Library

The Datum type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one
Protected method | AggregateEvent |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | GetViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency
Protected method | MakeAggregateInstance |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > ""
Protected method | SummarizeAggregation |
Public method | ToString | (Overrides Online Object ToString .)
Public method | WriteAsJSON |
Protected method | WriteJSONFields |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Datum Class
NFX.Instrumentation Namespace


Datum.Aggregate Method

Datum Aggregate Method NFX Class Library

Aggregates events, for example from multiple threads into one

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Datum Aggregate(
    IEnumerable<Datum> many
)
public Datum Aggregate(
    IEnumerable<Datum> many
)
Public Function Aggregate (
    many As IEnumerable(Of Datum)
) As Datum
Public Function Aggregate (
    many As IEnumerable(Of Datum)
) As Datum
public:
Datum^ Aggregate(
    IEnumerable<Datum^>^ many
)
public:
Datum^ Aggregate(
    IEnumerable<Datum^>^ many
)
member Aggregate :
        many : IEnumerable<Datum> -> Datum
member Aggregate :
        many : IEnumerable<Datum> -> Datum

Parameters

many
Type: Online System.Collections.Generic IEnumerable Datum

Return Value

Type: Datum
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


Datum.AggregateEvent Method

Datum AggregateEvent Method NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void AggregateEvent(
    Datum dat
)
protected virtual void AggregateEvent(
    Datum dat
)
Protected Overridable Sub AggregateEvent (
    dat As Datum
)
Protected Overridable Sub AggregateEvent (
    dat As Datum
)
protected:
virtual void AggregateEvent(
    Datum^ dat
)
protected:
virtual void AggregateEvent(
    Datum^ dat
)
abstract AggregateEvent :
        dat : Datum -> unit
override AggregateEvent :
        dat : Datum -> unit
abstract AggregateEvent :
        dat : Datum -> unit
override AggregateEvent :
        dat : Datum -> unit

Parameters

dat
Type: NFX.Instrumentation Datum
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


Datum.GetViewGroupInterfaces Method

Datum GetViewGroupInterfaces Method NFX Class Library

Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<Type> GetViewGroupInterfaces(
    Type tDatum
)
public static IEnumerable<Type> GetViewGroupInterfaces(
    Type tDatum
)
Public Shared Function GetViewGroupInterfaces (
    tDatum As Type
) As IEnumerable(Of Type)
Public Shared Function GetViewGroupInterfaces (
    tDatum As Type
) As IEnumerable(Of Type)
public:
static IEnumerable<Type^>^ GetViewGroupInterfaces(
    Type^ tDatum
)
public:
static IEnumerable<Type^>^ GetViewGroupInterfaces(
    Type^ tDatum
)
static member GetViewGroupInterfaces :
        tDatum : Type -> IEnumerable<Type>
static member GetViewGroupInterfaces :
        tDatum : Type -> IEnumerable<Type>

Parameters

tDatum
Type: Online System Type

Return Value

Type: Online IEnumerable Online Type
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


Datum.MakeAggregateInstance Method

Datum MakeAggregateInstance Method NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract Datum MakeAggregateInstance()
protected abstract Datum MakeAggregateInstance()
Protected MustOverride Function MakeAggregateInstance As Datum
Protected MustOverride Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() abstract
protected:
virtual Datum^ MakeAggregateInstance() abstract
abstract MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


Datum.ReduceSourceDetail Method

Datum ReduceSourceDetail Method NFX Class Library

Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > ""

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void ReduceSourceDetail(
    int reductionLevel
)
public virtual void ReduceSourceDetail(
    int reductionLevel
)
Public Overridable Sub ReduceSourceDetail (
    reductionLevel As Integer
)
Public Overridable Sub ReduceSourceDetail (
    reductionLevel As Integer
)
public:
virtual void ReduceSourceDetail(
    int reductionLevel
)
public:
virtual void ReduceSourceDetail(
    int reductionLevel
)
abstract ReduceSourceDetail :
        reductionLevel : int -> unit
override ReduceSourceDetail :
        reductionLevel : int -> unit
abstract ReduceSourceDetail :
        reductionLevel : int -> unit
override ReduceSourceDetail :
        reductionLevel : int -> unit

Parameters

reductionLevel
Type: Online System Int32
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


Datum.SummarizeAggregation Method

Datum SummarizeAggregation Method NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void SummarizeAggregation()
protected virtual void SummarizeAggregation()
Protected Overridable Sub SummarizeAggregation
Protected Overridable Sub SummarizeAggregation
protected:
virtual void SummarizeAggregation()
protected:
virtual void SummarizeAggregation()
abstract SummarizeAggregation : unit -> unit
override SummarizeAggregation : unit -> unit
abstract SummarizeAggregation : unit -> unit
override SummarizeAggregation : unit -> unit
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


Datum.ToString Method

Datum ToString Method NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


Datum.WriteAsJSON Method

Datum WriteAsJSON Method NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
nestingLevel
Type: Online System Int32
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Implements

IJSONWritable WriteAsJSON(TextWriter, Int32, JSONWritingOptions)
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


Datum.WriteJSONFields Method

Datum WriteJSONFields Method NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void WriteJSONFields(
    IDictionary<string, Object> data,
    JSONWritingOptions options
)
protected virtual void WriteJSONFields(
    IDictionary<string, Object> data,
    JSONWritingOptions options
)
Protected Overridable Sub WriteJSONFields (
    data As IDictionary(Of String, Object),
    options As JSONWritingOptions
)
Protected Overridable Sub WriteJSONFields (
    data As IDictionary(Of String, Object),
    options As JSONWritingOptions
)
protected:
virtual void WriteJSONFields(
    IDictionary<String^, Object^>^ data,
    JSONWritingOptions^ options
)
protected:
virtual void WriteJSONFields(
    IDictionary<String^, Object^>^ data,
    JSONWritingOptions^ options
)
abstract WriteJSONFields :
        data : IDictionary<string, Object> *
        options : JSONWritingOptions -> unit
override WriteJSONFields :
        data : IDictionary<string, Object> *
        options : JSONWritingOptions -> unit
abstract WriteJSONFields :
        data : IDictionary<string, Object> *
        options : JSONWritingOptions -> unit
override WriteJSONFields :
        data : IDictionary<string, Object> *
        options : JSONWritingOptions -> unit

Parameters

data
Type: Online System.Collections.Generic IDictionary Online String, Online Object
options
Type: NFX.Serialization.JSON JSONWritingOptions
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


Datum Properties

Datum Properties NFX Class Library

The Datum type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events
Public property | PlotValue | Provides numeric value used for charts
Public property | Rate | Returns rate of occurrence string
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned
Public property | UTCTime | Returns UTC time stamp when event happened
Public property | ValueAsObject | Provides access to value polymorphically
Public property | ValueUnitName | Provides name for units that value is measured in
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency
Back to Top
See Also
Datum Class
NFX.Instrumentation Namespace


Datum.Count Property

Datum Count Property NFX Class Library

Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
public:
property int Count {
    int get ();
}
member Count : int with get
member Count : int with get

Property Value

Type: Online Int32
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


Datum.Description Property

Datum Description Property NFX Class Library

Returns description for data that this datum represents. Base implementation returns full type name of this instance

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Description { get; }
public virtual string Description { get; }
Public Overridable ReadOnly Property Description As String
    Get
Public Overridable ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get ();
}
public:
virtual property String^ Description {
    String^ get ();
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


Datum.IsAggregated Property

Datum IsAggregated Property NFX Class Library

Indicates whether this instance represents a rollup/aggregation of multiple events

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsAggregated { get; }
public bool IsAggregated { get; }
Public ReadOnly Property IsAggregated As Boolean
    Get
Public ReadOnly Property IsAggregated As Boolean
    Get
public:
property bool IsAggregated {
    bool get ();
}
public:
property bool IsAggregated {
    bool get ();
}
member IsAggregated : bool with get
member IsAggregated : bool with get

Property Value

Type: Online Boolean
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


Datum.PlotValue Property

Datum PlotValue Property NFX Class Library

Provides numeric value used for charts

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object PlotValue { get; }
public virtual Object PlotValue { get; }
Public Overridable ReadOnly Property PlotValue As Object
    Get
Public Overridable ReadOnly Property PlotValue As Object
    Get
public:
virtual property Object^ PlotValue {
    Object^ get ();
}
public:
virtual property Object^ PlotValue {
    Object^ get ();
}
abstract PlotValue : Object with get
override PlotValue : Object with get
abstract PlotValue : Object with get
override PlotValue : Object with get

Property Value

Type: Online Object
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


Datum.Rate Property

Datum Rate Property NFX Class Library

Returns rate of occurrence string

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Rate { get; }
public string Rate { get; }
Public ReadOnly Property Rate As String
    Get
Public ReadOnly Property Rate As String
    Get
public:
property String^ Rate {
    String^ get ();
}
public:
property String^ Rate {
    String^ get ();
}
member Rate : string with get
member Rate : string with get

Property Value

Type: Online String
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


Datum.Source Property

Datum Source Property NFX Class Library

Returns datum source. Data are rolled-up by type of recorded datum instances and source

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Source { get; }
public string Source { get; }
Public ReadOnly Property Source As String
    Get
Public ReadOnly Property Source As String
    Get
public:
property String^ Source {
    String^ get ();
}
public:
property String^ Source {
    String^ get ();
}
member Source : string with get
member Source : string with get

Property Value

Type: Online String
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


Datum.UTCEndTime Property

Datum UTCEndTime Property NFX Class Library

Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime UTCEndTime { get; }
public DateTime UTCEndTime { get; }
Public ReadOnly Property UTCEndTime As DateTime
    Get
Public ReadOnly Property UTCEndTime As DateTime
    Get
public:
property DateTime UTCEndTime {
    DateTime get ();
}
public:
property DateTime UTCEndTime {
    DateTime get ();
}
member UTCEndTime : DateTime with get
member UTCEndTime : DateTime with get

Property Value

Type: Online DateTime
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


Datum.UTCTime Property

Datum UTCTime Property NFX Class Library

Returns UTC time stamp when event happened

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime UTCTime { get; }
public DateTime UTCTime { get; }
Public ReadOnly Property UTCTime As DateTime
    Get
Public ReadOnly Property UTCTime As DateTime
    Get
public:
property DateTime UTCTime {
    DateTime get ();
}
public:
property DateTime UTCTime {
    DateTime get ();
}
member UTCTime : DateTime with get
member UTCTime : DateTime with get

Property Value

Type: Online DateTime
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


Datum.ValueAsObject Property

Datum ValueAsObject Property NFX Class Library

Provides access to value polymorphically

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Object ValueAsObject { get; }
public abstract Object ValueAsObject { get; }
Public MustOverride ReadOnly Property ValueAsObject As Object
    Get
Public MustOverride ReadOnly Property ValueAsObject As Object
    Get
public:
virtual property Object^ ValueAsObject {
    Object^ get () abstract;
}
public:
virtual property Object^ ValueAsObject {
    Object^ get () abstract;
}
abstract ValueAsObject : Object with get
abstract ValueAsObject : Object with get

Property Value

Type: Online Object
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


Datum.ValueUnitName Property

Datum ValueUnitName Property NFX Class Library

Provides name for units that value is measured in

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string ValueUnitName { get; }
public abstract string ValueUnitName { get; }
Public MustOverride ReadOnly Property ValueUnitName As String
    Get
Public MustOverride ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () abstract;
}
public:
virtual property String^ ValueUnitName {
    String^ get () abstract;
}
abstract ValueUnitName : string with get
abstract ValueUnitName : string with get

Property Value

Type: Online String
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


Datum.ViewGroupInterfaces Property

Datum ViewGroupInterfaces Property NFX Class Library

Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Type> ViewGroupInterfaces { get; }
public IEnumerable<Type> ViewGroupInterfaces { get; }
Public ReadOnly Property ViewGroupInterfaces As IEnumerable(Of Type)
    Get
Public ReadOnly Property ViewGroupInterfaces As IEnumerable(Of Type)
    Get
public:
property IEnumerable<Type^>^ ViewGroupInterfaces {
    IEnumerable<Type^>^ get ();
}
public:
property IEnumerable<Type^>^ ViewGroupInterfaces {
    IEnumerable<Type^>^ get ();
}
member ViewGroupInterfaces : IEnumerable<Type> with get
member ViewGroupInterfaces : IEnumerable<Type> with get

Property Value

Type: Online IEnumerable Online Type
See Also
Datum Class
Datum Members
NFX.Instrumentation Namespace


DatumBag Class

DatumBag Class NFX Class Library

Internal concurrent bag used for instrumentation data aggregation
Inheritance Hierarchy
Online System Object
Online System.Collections.Concurrent ConcurrentBag Datum
NFX.Instrumentation DatumBag

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class DatumBag : ConcurrentBag<Datum>
internal class DatumBag : ConcurrentBag<Datum>
Friend Class DatumBag
    Inherits ConcurrentBag(Of Datum)
Friend Class DatumBag
    Inherits ConcurrentBag(Of Datum)
internal ref class DatumBag : public ConcurrentBag<Datum^>
internal ref class DatumBag : public ConcurrentBag<Datum^>
type DatumBag =
    class
        inherit ConcurrentBag<Datum>
    end
type DatumBag =
    class
        inherit ConcurrentBag<Datum>
    end
See Also
DatumBag Members
NFX.Instrumentation Namespace


DatumBag Members

DatumBag Members NFX Class Library

The DatumBag type exposes the following members.
Constructors
 | Name | Description
Public method | DatumBag | Initializes a new instance of the DatumBag class
Back to Top
Methods
 | Name | Description
Public method | Online Add | (Inherited from Online ConcurrentBag Datum .)
Public method | Online CopyTo | (Inherited from Online ConcurrentBag Datum .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | (Inherited from Online ConcurrentBag Datum .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToArray | (Inherited from Online ConcurrentBag Datum .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TryPeek | (Inherited from Online ConcurrentBag Datum .)
Public method | Online TryTake | (Inherited from Online ConcurrentBag Datum .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online Count | (Inherited from Online ConcurrentBag Datum .)
Public property | Online IsEmpty | (Inherited from Online ConcurrentBag Datum .)
Back to Top
See Also
DatumBag Class
NFX.Instrumentation Namespace


DatumBag Constructor

DatumBag Constructor NFX Class Library

Initializes a new instance of the DatumBag class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DatumBag()
public DatumBag()
Public Sub New
Public Sub New
public:
DatumBag()
public:
DatumBag()
new : unit -> DatumBag
new : unit -> DatumBag
See Also
DatumBag Class
DatumBag Members
NFX.Instrumentation Namespace


DatumBag Methods

DatumBag Methods NFX Class Library

The DatumBag type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | (Inherited from Online ConcurrentBag Datum .)
Public method | Online CopyTo | (Inherited from Online ConcurrentBag Datum .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | (Inherited from Online ConcurrentBag Datum .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToArray | (Inherited from Online ConcurrentBag Datum .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TryPeek | (Inherited from Online ConcurrentBag Datum .)
Public method | Online TryTake | (Inherited from Online ConcurrentBag Datum .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
DatumBag Class
NFX.Instrumentation Namespace


DatumBag Properties

DatumBag Properties NFX Class Library

The DatumBag type exposes the following members.
Properties
 | Name | Description
Public property | Online Count | (Inherited from Online ConcurrentBag Datum .)
Public property | Online IsEmpty | (Inherited from Online ConcurrentBag Datum .)
Back to Top
See Also
DatumBag Class
NFX.Instrumentation Namespace


DecimalGauge Class

DecimalGauge Class NFX Class Library

Represents a general-purpose decimal measurement datum
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation DecimalGauge

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class DecimalGauge : Gauge
[SerializableAttribute]
public abstract class DecimalGauge : Gauge
<SerializableAttribute>
Public MustInherit Class DecimalGauge
    Inherits Gauge
<SerializableAttribute>
Public MustInherit Class DecimalGauge
    Inherits Gauge
[SerializableAttribute]
public ref class DecimalGauge abstract : public Gauge
[SerializableAttribute]
public ref class DecimalGauge abstract : public Gauge
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type DecimalGauge =
    class
        inherit Gauge
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type DecimalGauge =
    class
        inherit Gauge
    end
See Also
DecimalGauge Members
NFX.Instrumentation Namespace


DecimalGauge Members

DecimalGauge Members NFX Class Library

The DecimalGauge type exposes the following members.
Constructors
 | Name | Description
Protected method | DecimalGauge(String, Decimal) | Initializes a new instance of the DecimalGauge class
Protected method | DecimalGauge(String, Decimal, DateTime) | Initializes a new instance of the DecimalGauge class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Overrides Datum AggregateEvent(Datum).)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Overrides Datum SummarizeAggregation .)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value
Public property | ValueAsObject | (Overrides Datum ValueAsObject.)
Public property | ValueUnitName | (Overrides Datum ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
DecimalGauge Class
NFX.Instrumentation Namespace


DecimalGauge Constructor

DecimalGauge Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | DecimalGauge(String, Decimal) | Initializes a new instance of the DecimalGauge class
Protected method | DecimalGauge(String, Decimal, DateTime) | Initializes a new instance of the DecimalGauge class
Back to Top
See Also
DecimalGauge Class
DecimalGauge Members
NFX.Instrumentation Namespace


DecimalGauge Constructor (String, Decimal)

DecimalGauge Constructor (String, Decimal) NFX Class Library

Initializes a new instance of the DecimalGauge class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected DecimalGauge(
    string source,
    decimal value
)
protected DecimalGauge(
    string source,
    decimal value
)
Protected Sub New (
    source As String,
    value As Decimal
)
Protected Sub New (
    source As String,
    value As Decimal
)
protected:
DecimalGauge(
    String^ source,
    Decimal value
)
protected:
DecimalGauge(
    String^ source,
    Decimal value
)
new :
        source : string *
        value : decimal -> DecimalGauge
new :
        source : string *
        value : decimal -> DecimalGauge

Parameters

source
Type: Online System String
value
Type: Online System Decimal
See Also
DecimalGauge Class
DecimalGauge Members
DecimalGauge Overload
NFX.Instrumentation Namespace


DecimalGauge Constructor (String, Decimal, DateTime)

DecimalGauge Constructor (String, Decimal, DateTime) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DecimalGauge class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected DecimalGauge(
    string source,
    decimal value,
    DateTime utcDateTime
)
protected DecimalGauge(
    string source,
    decimal value,
    DateTime utcDateTime
)
Protected Sub New (
    source As String,
    value As Decimal,
    utcDateTime As DateTime
)
Protected Sub New (
    source As String,
    value As Decimal,
    utcDateTime As DateTime
)
protected:
DecimalGauge(
    String^ source,
    Decimal value,
    DateTime utcDateTime
)
protected:
DecimalGauge(
    String^ source,
    Decimal value,
    DateTime utcDateTime
)
new :
        source : string *
        value : decimal *
        utcDateTime : DateTime -> DecimalGauge
new :
        source : string *
        value : decimal *
        utcDateTime : DateTime -> DecimalGauge

Parameters

source
Type: Online System String
value
Type: Online System Decimal
utcDateTime
Type: Online System DateTime
See Also
DecimalGauge Class
DecimalGauge Members
DecimalGauge Overload
NFX.Instrumentation Namespace


DecimalGauge Fields

DecimalGauge Fields NFX Class Library

The DecimalGauge type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
DecimalGauge Class
NFX.Instrumentation Namespace


DecimalGauge Methods

DecimalGauge Methods NFX Class Library

The DecimalGauge type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Overrides Datum AggregateEvent(Datum).)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Overrides Datum SummarizeAggregation .)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
DecimalGauge Class
NFX.Instrumentation Namespace


DecimalGauge.AggregateEvent Method

DecimalGauge AggregateEvent Method NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void AggregateEvent(
    Datum dat
)
protected override void AggregateEvent(
    Datum dat
)
Protected Overrides Sub AggregateEvent (
    dat As Datum
)
Protected Overrides Sub AggregateEvent (
    dat As Datum
)
protected:
virtual void AggregateEvent(
    Datum^ dat
) override
protected:
virtual void AggregateEvent(
    Datum^ dat
) override
abstract AggregateEvent :
        dat : Datum -> unit
override AggregateEvent :
        dat : Datum -> unit
abstract AggregateEvent :
        dat : Datum -> unit
override AggregateEvent :
        dat : Datum -> unit

Parameters

dat
Type: NFX.Instrumentation Datum
See Also
DecimalGauge Class
DecimalGauge Members
NFX.Instrumentation Namespace


DecimalGauge.SummarizeAggregation Method

DecimalGauge SummarizeAggregation Method NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void SummarizeAggregation()
protected override void SummarizeAggregation()
Protected Overrides Sub SummarizeAggregation
Protected Overrides Sub SummarizeAggregation
protected:
virtual void SummarizeAggregation() override
protected:
virtual void SummarizeAggregation() override
abstract SummarizeAggregation : unit -> unit
override SummarizeAggregation : unit -> unit
abstract SummarizeAggregation : unit -> unit
override SummarizeAggregation : unit -> unit
See Also
DecimalGauge Class
DecimalGauge Members
NFX.Instrumentation Namespace


DecimalGauge Properties

DecimalGauge Properties NFX Class Library

The DecimalGauge type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value
Public property | ValueAsObject | (Overrides Datum ValueAsObject.)
Public property | ValueUnitName | (Overrides Datum ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
DecimalGauge Class
NFX.Instrumentation Namespace


DecimalGauge.Value Property

DecimalGauge Value Property NFX Class Library

Gets gauge value

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal Value { get; }
public decimal Value { get; }
Public ReadOnly Property Value As Decimal
    Get
Public ReadOnly Property Value As Decimal
    Get
public:
property Decimal Value {
    Decimal get ();
}
public:
property Decimal Value {
    Decimal get ();
}
member Value : decimal with get
member Value : decimal with get

Property Value

Type: Online Decimal
See Also
DecimalGauge Class
DecimalGauge Members
NFX.Instrumentation Namespace


DecimalGauge.ValueAsObject Property

DecimalGauge ValueAsObject Property NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object ValueAsObject { get; }
public override Object ValueAsObject { get; }
Public Overrides ReadOnly Property ValueAsObject As Object
    Get
Public Overrides ReadOnly Property ValueAsObject As Object
    Get
public:
virtual property Object^ ValueAsObject {
    Object^ get () override;
}
public:
virtual property Object^ ValueAsObject {
    Object^ get () override;
}
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get

Property Value

Type: Online Object
See Also
DecimalGauge Class
DecimalGauge Members
NFX.Instrumentation Namespace


DecimalGauge.ValueUnitName Property

DecimalGauge ValueUnitName Property NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
DecimalGauge Class
DecimalGauge Members
NFX.Instrumentation Namespace


DoubleGauge Class

DoubleGauge Class NFX Class Library

Represents a general-purpose double measurement datum
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation DoubleGauge
NFX.ApplicationModel.Pile.Instrumentation PileDoubleGauge
NFX.DataAccess.Cache.Instrumentation CacheDoubleGauge
NFX.Glue.Instrumentation GlueDoubleGauge
NFX.OS.Instrumentation OSDoubleGauge
NFX.Wave.Instrumentation WaveDoubleGauge

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class DoubleGauge : Gauge
[SerializableAttribute]
public abstract class DoubleGauge : Gauge
<SerializableAttribute>
Public MustInherit Class DoubleGauge
    Inherits Gauge
<SerializableAttribute>
Public MustInherit Class DoubleGauge
    Inherits Gauge
[SerializableAttribute]
public ref class DoubleGauge abstract : public Gauge
[SerializableAttribute]
public ref class DoubleGauge abstract : public Gauge
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type DoubleGauge =
    class
        inherit Gauge
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type DoubleGauge =
    class
        inherit Gauge
    end
See Also
DoubleGauge Members
NFX.Instrumentation Namespace


DoubleGauge Members

DoubleGauge Members NFX Class Library

The DoubleGauge type exposes the following members.
Constructors
 | Name | Description
Protected method | DoubleGauge(String, Double) | Initializes a new instance of the DoubleGauge class
Protected method | DoubleGauge(String, Double, DateTime) | Initializes a new instance of the DoubleGauge class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Overrides Datum AggregateEvent(Datum).)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Overrides Datum SummarizeAggregation .)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value
Public property | ValueAsObject | (Overrides Datum ValueAsObject.)
Public property | ValueUnitName | (Overrides Datum ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
DoubleGauge Class
NFX.Instrumentation Namespace


DoubleGauge Constructor

DoubleGauge Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | DoubleGauge(String, Double) | Initializes a new instance of the DoubleGauge class
Protected method | DoubleGauge(String, Double, DateTime) | Initializes a new instance of the DoubleGauge class
Back to Top
See Also
DoubleGauge Class
DoubleGauge Members
NFX.Instrumentation Namespace


DoubleGauge Constructor (String, Double)

DoubleGauge Constructor (String, Double) NFX Class Library

Initializes a new instance of the DoubleGauge class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected DoubleGauge(
    string source,
    double value
)
protected DoubleGauge(
    string source,
    double value
)
Protected Sub New (
    source As String,
    value As Double
)
Protected Sub New (
    source As String,
    value As Double
)
protected:
DoubleGauge(
    String^ source,
    double value
)
protected:
DoubleGauge(
    String^ source,
    double value
)
new :
        source : string *
        value : float -> DoubleGauge
new :
        source : string *
        value : float -> DoubleGauge

Parameters

source
Type: Online System String
value
Type: Online System Double
See Also
DoubleGauge Class
DoubleGauge Members
DoubleGauge Overload
NFX.Instrumentation Namespace


DoubleGauge Constructor (String, Double, DateTime)

DoubleGauge Constructor (String, Double, DateTime) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DoubleGauge class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected DoubleGauge(
    string source,
    double value,
    DateTime utcDateTime
)
protected DoubleGauge(
    string source,
    double value,
    DateTime utcDateTime
)
Protected Sub New (
    source As String,
    value As Double,
    utcDateTime As DateTime
)
Protected Sub New (
    source As String,
    value As Double,
    utcDateTime As DateTime
)
protected:
DoubleGauge(
    String^ source,
    double value,
    DateTime utcDateTime
)
protected:
DoubleGauge(
    String^ source,
    double value,
    DateTime utcDateTime
)
new :
        source : string *
        value : float *
        utcDateTime : DateTime -> DoubleGauge
new :
        source : string *
        value : float *
        utcDateTime : DateTime -> DoubleGauge

Parameters

source
Type: Online System String
value
Type: Online System Double
utcDateTime
Type: Online System DateTime
See Also
DoubleGauge Class
DoubleGauge Members
DoubleGauge Overload
NFX.Instrumentation Namespace


DoubleGauge Fields

DoubleGauge Fields NFX Class Library

The DoubleGauge type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
DoubleGauge Class
NFX.Instrumentation Namespace


DoubleGauge Methods

DoubleGauge Methods NFX Class Library

The DoubleGauge type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Overrides Datum AggregateEvent(Datum).)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Overrides Datum SummarizeAggregation .)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
DoubleGauge Class
NFX.Instrumentation Namespace


DoubleGauge.AggregateEvent Method

DoubleGauge AggregateEvent Method NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void AggregateEvent(
    Datum dat
)
protected override void AggregateEvent(
    Datum dat
)
Protected Overrides Sub AggregateEvent (
    dat As Datum
)
Protected Overrides Sub AggregateEvent (
    dat As Datum
)
protected:
virtual void AggregateEvent(
    Datum^ dat
) override
protected:
virtual void AggregateEvent(
    Datum^ dat
) override
abstract AggregateEvent :
        dat : Datum -> unit
override AggregateEvent :
        dat : Datum -> unit
abstract AggregateEvent :
        dat : Datum -> unit
override AggregateEvent :
        dat : Datum -> unit

Parameters

dat
Type: NFX.Instrumentation Datum
See Also
DoubleGauge Class
DoubleGauge Members
NFX.Instrumentation Namespace


DoubleGauge.SummarizeAggregation Method

DoubleGauge SummarizeAggregation Method NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void SummarizeAggregation()
protected override void SummarizeAggregation()
Protected Overrides Sub SummarizeAggregation
Protected Overrides Sub SummarizeAggregation
protected:
virtual void SummarizeAggregation() override
protected:
virtual void SummarizeAggregation() override
abstract SummarizeAggregation : unit -> unit
override SummarizeAggregation : unit -> unit
abstract SummarizeAggregation : unit -> unit
override SummarizeAggregation : unit -> unit
See Also
DoubleGauge Class
DoubleGauge Members
NFX.Instrumentation Namespace


DoubleGauge Properties

DoubleGauge Properties NFX Class Library

The DoubleGauge type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value
Public property | ValueAsObject | (Overrides Datum ValueAsObject.)
Public property | ValueUnitName | (Overrides Datum ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
DoubleGauge Class
NFX.Instrumentation Namespace


DoubleGauge.Value Property

DoubleGauge Value Property NFX Class Library

Gets gauge value

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double Value { get; }
public double Value { get; }
Public ReadOnly Property Value As Double
    Get
Public ReadOnly Property Value As Double
    Get
public:
property double Value {
    double get ();
}
public:
property double Value {
    double get ();
}
member Value : float with get
member Value : float with get

Property Value

Type: Online Double
See Also
DoubleGauge Class
DoubleGauge Members
NFX.Instrumentation Namespace


DoubleGauge.ValueAsObject Property

DoubleGauge ValueAsObject Property NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object ValueAsObject { get; }
public override Object ValueAsObject { get; }
Public Overrides ReadOnly Property ValueAsObject As Object
    Get
Public Overrides ReadOnly Property ValueAsObject As Object
    Get
public:
virtual property Object^ ValueAsObject {
    Object^ get () override;
}
public:
virtual property Object^ ValueAsObject {
    Object^ get () override;
}
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get

Property Value

Type: Online Object
See Also
DoubleGauge Class
DoubleGauge Members
NFX.Instrumentation Namespace


DoubleGauge.ValueUnitName Property

DoubleGauge ValueUnitName Property NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
DoubleGauge Class
DoubleGauge Members
NFX.Instrumentation Namespace


Event Class

Event Class NFX Class Library

Represents a base for events that happen so instrumentation can calculate event counts and rates of occurence
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Event
NFX.ApplicationModel.Pile.Instrumentation CacheEvent
NFX.Glue.Instrumentation GlueEvent
NFX.Instrumentation ExceptionEvent

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Event : Datum
public abstract class Event : Datum
Public MustInherit Class Event
    Inherits Datum
Public MustInherit Class Event
    Inherits Datum
public ref class Event abstract : public Datum
public ref class Event abstract : public Datum
[<AbstractClassAttribute>]
type Event =
    class
        inherit Datum
    end
[<AbstractClassAttribute>]
type Event =
    class
        inherit Datum
    end
See Also
Event Members
NFX.Instrumentation Namespace


Event Members

Event Members NFX Class Library

The Event type exposes the following members.
Constructors
 | Name | Description
Protected method | Event | Initializes a new instance of the Event class
Protected method | Event(String) | Initializes a new instance of the Event class
Protected method | Event(String, DateTime) | Initializes a new instance of the Event class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Overrides Datum ValueAsObject.)
Public property | ValueUnitName | (Overrides Datum ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
Event Class
NFX.Instrumentation Namespace


Event Constructor

Event Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | Event | Initializes a new instance of the Event class
Protected method | Event(String) | Initializes a new instance of the Event class
Protected method | Event(String, DateTime) | Initializes a new instance of the Event class
Back to Top
See Also
Event Class
Event Members
NFX.Instrumentation Namespace


Event Constructor

Event Constructor NFX Class Library

Initializes a new instance of the Event class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Event()
protected Event()
Protected Sub New
Protected Sub New
protected:
Event()
protected:
Event()
new : unit -> Event
new : unit -> Event
See Also
Event Class
Event Members
Event Overload
NFX.Instrumentation Namespace


Event Constructor (String)

Event Constructor (String) NFX Class Library

Initializes a new instance of the Event class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Event(
    string source
)
protected Event(
    string source
)
Protected Sub New (
    source As String
)
Protected Sub New (
    source As String
)
protected:
Event(
    String^ source
)
protected:
Event(
    String^ source
)
new :
        source : string -> Event
new :
        source : string -> Event

Parameters

source
Type: Online System String
See Also
Event Class
Event Members
Event Overload
NFX.Instrumentation Namespace


Event Constructor (String, DateTime)

Event Constructor (String, DateTime) NFX Class Library

Initializes a new instance of the Event class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Event(
    string source,
    DateTime utcDateTime
)
protected Event(
    string source,
    DateTime utcDateTime
)
Protected Sub New (
    source As String,
    utcDateTime As DateTime
)
Protected Sub New (
    source As String,
    utcDateTime As DateTime
)
protected:
Event(
    String^ source,
    DateTime utcDateTime
)
protected:
Event(
    String^ source,
    DateTime utcDateTime
)
new :
        source : string *
        utcDateTime : DateTime -> Event
new :
        source : string *
        utcDateTime : DateTime -> Event

Parameters

source
Type: Online System String
utcDateTime
Type: Online System DateTime
See Also
Event Class
Event Members
Event Overload
NFX.Instrumentation Namespace


Event Fields

Event Fields NFX Class Library

The Event type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
Event Class
NFX.Instrumentation Namespace


Event Methods

Event Methods NFX Class Library

The Event type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Event Class
NFX.Instrumentation Namespace


Event Properties

Event Properties NFX Class Library

The Event type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Overrides Datum ValueAsObject.)
Public property | ValueUnitName | (Overrides Datum ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
Event Class
NFX.Instrumentation Namespace


Event.ValueAsObject Property

Event ValueAsObject Property NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object ValueAsObject { get; }
public override Object ValueAsObject { get; }
Public Overrides ReadOnly Property ValueAsObject As Object
    Get
Public Overrides ReadOnly Property ValueAsObject As Object
    Get
public:
virtual property Object^ ValueAsObject {
    Object^ get () override;
}
public:
virtual property Object^ ValueAsObject {
    Object^ get () override;
}
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get

Property Value

Type: Online Object
See Also
Event Class
Event Members
NFX.Instrumentation Namespace


Event.ValueUnitName Property

Event ValueUnitName Property NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
Event Class
Event Members
NFX.Instrumentation Namespace


ExceptionEvent Class

ExceptionEvent Class NFX Class Library

Represents an exception event recorded by instrumentation
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Event
NFX.Instrumentation ExceptionEvent

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ExceptionEvent : Event,
    IErrorInstrument, IProblemClass, IInstrumentClass
[SerializableAttribute]
public class ExceptionEvent : Event,
    IErrorInstrument, IProblemClass, IInstrumentClass
<SerializableAttribute>
Public Class ExceptionEvent
    Inherits Event
    Implements IErrorInstrument, IProblemClass, IInstrumentClass
<SerializableAttribute>
Public Class ExceptionEvent
    Inherits Event
    Implements IErrorInstrument, IProblemClass, IInstrumentClass
[SerializableAttribute]
public ref class ExceptionEvent : public Event,
    IErrorInstrument, IProblemClass, IInstrumentClass
[SerializableAttribute]
public ref class ExceptionEvent : public Event,
    IErrorInstrument, IProblemClass, IInstrumentClass
[<SerializableAttribute>]
type ExceptionEvent =
    class
        inherit Event
        interface IErrorInstrument
        interface IProblemClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type ExceptionEvent =
    class
        inherit Event
        interface IErrorInstrument
        interface IProblemClass
        interface IInstrumentClass
    end
See Also
ExceptionEvent Members
NFX.Instrumentation Namespace


ExceptionEvent Members

ExceptionEvent Members NFX Class Library

The ExceptionEvent type exposes the following members.
Constructors
 | Name | Description
Protected method | ExceptionEvent(Exception) | Initializes a new instance of the ExceptionEvent class
Protected method | ExceptionEvent(String, Exception) | Initializes a new instance of the ExceptionEvent class
Protected method | ExceptionEvent(String, Exception, DateTime) | Initializes a new instance of the ExceptionEvent class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Overrides Datum AggregateEvent(Datum).)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record(Exception) | Create event from exception instance
 | Record(String, Exception) | Create event from exception instance and source
 | Record(String, Exception, DateTime) | Create event from exception instance as of utcTime
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Overrides Datum SummarizeAggregation .)
Public method | ToString | (Overrides Datum ToString .)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | ExceptionType |
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ExceptionEvent Class
NFX.Instrumentation Namespace


ExceptionEvent Constructor

ExceptionEvent Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | ExceptionEvent(Exception) | Initializes a new instance of the ExceptionEvent class
Protected method | ExceptionEvent(String, Exception) | Initializes a new instance of the ExceptionEvent class
Protected method | ExceptionEvent(String, Exception, DateTime) | Initializes a new instance of the ExceptionEvent class
Back to Top
See Also
ExceptionEvent Class
ExceptionEvent Members
NFX.Instrumentation Namespace


ExceptionEvent Constructor (Exception)

ExceptionEvent Constructor (Exception) NFX Class Library

Initializes a new instance of the ExceptionEvent class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ExceptionEvent(
    Exception error
)
protected ExceptionEvent(
    Exception error
)
Protected Sub New (
    error As Exception
)
Protected Sub New (
    error As Exception
)
protected:
ExceptionEvent(
    Exception^ error
)
protected:
ExceptionEvent(
    Exception^ error
)
new :
        error : Exception -> ExceptionEvent
new :
        error : Exception -> ExceptionEvent

Parameters

error
Type: Online System Exception
See Also
ExceptionEvent Class
ExceptionEvent Members
ExceptionEvent Overload
NFX.Instrumentation Namespace


ExceptionEvent Constructor (String, Exception)

ExceptionEvent Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ExceptionEvent class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ExceptionEvent(
    string source,
    Exception error
)
protected ExceptionEvent(
    string source,
    Exception error
)
Protected Sub New (
    source As String,
    error As Exception
)
Protected Sub New (
    source As String,
    error As Exception
)
protected:
ExceptionEvent(
    String^ source,
    Exception^ error
)
protected:
ExceptionEvent(
    String^ source,
    Exception^ error
)
new :
        source : string *
        error : Exception -> ExceptionEvent
new :
        source : string *
        error : Exception -> ExceptionEvent

Parameters

source
Type: Online System String
error
Type: Online System Exception
See Also
ExceptionEvent Class
ExceptionEvent Members
ExceptionEvent Overload
NFX.Instrumentation Namespace


ExceptionEvent Constructor (String, Exception, DateTime)

ExceptionEvent Constructor (String, Exception, DateTime) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ExceptionEvent class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ExceptionEvent(
    string source,
    Exception error,
    DateTime utcTime
)
protected ExceptionEvent(
    string source,
    Exception error,
    DateTime utcTime
)
Protected Sub New (
    source As String,
    error As Exception,
    utcTime As DateTime
)
Protected Sub New (
    source As String,
    error As Exception,
    utcTime As DateTime
)
protected:
ExceptionEvent(
    String^ source,
    Exception^ error,
    DateTime utcTime
)
protected:
ExceptionEvent(
    String^ source,
    Exception^ error,
    DateTime utcTime
)
new :
        source : string *
        error : Exception *
        utcTime : DateTime -> ExceptionEvent
new :
        source : string *
        error : Exception *
        utcTime : DateTime -> ExceptionEvent

Parameters

source
Type: Online System String
error
Type: Online System Exception
utcTime
Type: Online System DateTime
See Also
ExceptionEvent Class
ExceptionEvent Members
ExceptionEvent Overload
NFX.Instrumentation Namespace


ExceptionEvent Fields

ExceptionEvent Fields NFX Class Library

The ExceptionEvent type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ExceptionEvent Class
NFX.Instrumentation Namespace


ExceptionEvent Methods

ExceptionEvent Methods NFX Class Library

The ExceptionEvent type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Overrides Datum AggregateEvent(Datum).)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record(Exception) | Create event from exception instance
 | Record(String, Exception) | Create event from exception instance and source
 | Record(String, Exception, DateTime) | Create event from exception instance as of utcTime
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Overrides Datum SummarizeAggregation .)
Public method | ToString | (Overrides Datum ToString .)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ExceptionEvent Class
NFX.Instrumentation Namespace


ExceptionEvent.AggregateEvent Method

ExceptionEvent AggregateEvent Method NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void AggregateEvent(
    Datum evt
)
protected override void AggregateEvent(
    Datum evt
)
Protected Overrides Sub AggregateEvent (
    evt As Datum
)
Protected Overrides Sub AggregateEvent (
    evt As Datum
)
protected:
virtual void AggregateEvent(
    Datum^ evt
) override
protected:
virtual void AggregateEvent(
    Datum^ evt
) override
abstract AggregateEvent :
        evt : Datum -> unit
override AggregateEvent :
        evt : Datum -> unit
abstract AggregateEvent :
        evt : Datum -> unit
override AggregateEvent :
        evt : Datum -> unit

Parameters

evt
Type: NFX.Instrumentation Datum
See Also
ExceptionEvent Class
ExceptionEvent Members
NFX.Instrumentation Namespace


ExceptionEvent.MakeAggregateInstance Method

ExceptionEvent MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ExceptionEvent Class
ExceptionEvent Members
NFX.Instrumentation Namespace


ExceptionEvent.Record Method

ExceptionEvent Record Method NFX Class Library

Overload List
Name | Description
Record(Exception) | Create event from exception instance
Record(String, Exception) | Create event from exception instance and source
Record(String, Exception, DateTime) | Create event from exception instance as of utcTime
Back to Top
See Also
ExceptionEvent Class
ExceptionEvent Members
NFX.Instrumentation Namespace


ExceptionEvent.Record Method (Exception)

ExceptionEvent Record Method (Exception) NFX Class Library

Create event from exception instance

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    Exception error
)
public static void Record(
    Exception error
)
Public Shared Sub Record (
    error As Exception
)
Public Shared Sub Record (
    error As Exception
)
public:
static void Record(
    Exception^ error
)
public:
static void Record(
    Exception^ error
)
static member Record :
        error : Exception -> unit
static member Record :
        error : Exception -> unit

Parameters

error
Type: Online System Exception
See Also
ExceptionEvent Class
ExceptionEvent Members
Record Overload
NFX.Instrumentation Namespace


ExceptionEvent.Record Method (String, Exception)

ExceptionEvent Record Method (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Create event from exception instance and source

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    string source,
    Exception error
)
public static void Record(
    string source,
    Exception error
)
Public Shared Sub Record (
    source As String,
    error As Exception
)
Public Shared Sub Record (
    source As String,
    error As Exception
)
public:
static void Record(
    String^ source,
    Exception^ error
)
public:
static void Record(
    String^ source,
    Exception^ error
)
static member Record :
        source : string *
        error : Exception -> unit
static member Record :
        source : string *
        error : Exception -> unit

Parameters

source
Type: Online System String
error
Type: Online System Exception
See Also
ExceptionEvent Class
ExceptionEvent Members
Record Overload
NFX.Instrumentation Namespace


ExceptionEvent.Record Method (String, Exception, DateTime)

ExceptionEvent Record Method (String, Exception, DateTime) NFX Class Library

[This is preliminary documentation and is subject to change.]

Create event from exception instance as of utcTime

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    string source,
    Exception error,
    DateTime utcTime
)
public static void Record(
    string source,
    Exception error,
    DateTime utcTime
)
Public Shared Sub Record (
    source As String,
    error As Exception,
    utcTime As DateTime
)
Public Shared Sub Record (
    source As String,
    error As Exception,
    utcTime As DateTime
)
public:
static void Record(
    String^ source,
    Exception^ error,
    DateTime utcTime
)
public:
static void Record(
    String^ source,
    Exception^ error,
    DateTime utcTime
)
static member Record :
        source : string *
        error : Exception *
        utcTime : DateTime -> unit
static member Record :
        source : string *
        error : Exception *
        utcTime : DateTime -> unit

Parameters

source
Type: Online System String
error
Type: Online System Exception
utcTime
Type: Online System DateTime
See Also
ExceptionEvent Class
ExceptionEvent Members
Record Overload
NFX.Instrumentation Namespace


ExceptionEvent.SummarizeAggregation Method

ExceptionEvent SummarizeAggregation Method NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void SummarizeAggregation()
protected override void SummarizeAggregation()
Protected Overrides Sub SummarizeAggregation
Protected Overrides Sub SummarizeAggregation
protected:
virtual void SummarizeAggregation() override
protected:
virtual void SummarizeAggregation() override
abstract SummarizeAggregation : unit -> unit
override SummarizeAggregation : unit -> unit
abstract SummarizeAggregation : unit -> unit
override SummarizeAggregation : unit -> unit
See Also
ExceptionEvent Class
ExceptionEvent Members
NFX.Instrumentation Namespace


ExceptionEvent.ToString Method

ExceptionEvent ToString Method NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
ExceptionEvent Class
ExceptionEvent Members
NFX.Instrumentation Namespace


ExceptionEvent Properties

ExceptionEvent Properties NFX Class Library

The ExceptionEvent type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | ExceptionType |
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | (Inherited from Event.)
Public property | ValueUnitName | (Inherited from Event.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ExceptionEvent Class
NFX.Instrumentation Namespace


ExceptionEvent.ExceptionType Property

ExceptionEvent ExceptionType Property NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ExceptionType { get; }
public string ExceptionType { get; }
Public ReadOnly Property ExceptionType As String
    Get
Public ReadOnly Property ExceptionType As String
    Get
public:
property String^ ExceptionType {
    String^ get ();
}
public:
property String^ ExceptionType {
    String^ get ();
}
member ExceptionType : string with get
member ExceptionType : string with get

Property Value

Type: Online String
See Also
ExceptionEvent Class
ExceptionEvent Members
NFX.Instrumentation Namespace


Gauge Class

Gauge Class NFX Class Library

Represents a base for gauges - events of measurement of some values
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation AmountGauge
NFX.Instrumentation DecimalGauge
NFX.Instrumentation DoubleGauge
NFX.Instrumentation LongGauge

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Gauge : Datum
public abstract class Gauge : Datum
Public MustInherit Class Gauge
    Inherits Datum
Public MustInherit Class Gauge
    Inherits Datum
public ref class Gauge abstract : public Datum
public ref class Gauge abstract : public Datum
[<AbstractClassAttribute>]
type Gauge =
    class
        inherit Datum
    end
[<AbstractClassAttribute>]
type Gauge =
    class
        inherit Datum
    end
See Also
Gauge Members
NFX.Instrumentation Namespace


Gauge Members

Gauge Members NFX Class Library

The Gauge type exposes the following members.
Constructors
 | Name | Description
Protected method | Gauge | Initializes a new instance of the Gauge class
Protected method | Gauge(String) | Initializes a new instance of the Gauge class
Protected method | Gauge(String, DateTime) | Initializes a new instance of the Gauge class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | Provides access to value polymorphically (Inherited from Datum.)
Public property | ValueUnitName | Provides name for units that value is measured in (Inherited from Datum.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
Gauge Class
NFX.Instrumentation Namespace


Gauge Constructor

Gauge Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | Gauge | Initializes a new instance of the Gauge class
Protected method | Gauge(String) | Initializes a new instance of the Gauge class
Protected method | Gauge(String, DateTime) | Initializes a new instance of the Gauge class
Back to Top
See Also
Gauge Class
Gauge Members
NFX.Instrumentation Namespace


Gauge Constructor

Gauge Constructor NFX Class Library

Initializes a new instance of the Gauge class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Gauge()
protected Gauge()
Protected Sub New
Protected Sub New
protected:
Gauge()
protected:
Gauge()
new : unit -> Gauge
new : unit -> Gauge
See Also
Gauge Class
Gauge Members
Gauge Overload
NFX.Instrumentation Namespace


Gauge Constructor (String)

Gauge Constructor (String) NFX Class Library

Initializes a new instance of the Gauge class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Gauge(
    string source
)
protected Gauge(
    string source
)
Protected Sub New (
    source As String
)
Protected Sub New (
    source As String
)
protected:
Gauge(
    String^ source
)
protected:
Gauge(
    String^ source
)
new :
        source : string -> Gauge
new :
        source : string -> Gauge

Parameters

source
Type: Online System String
See Also
Gauge Class
Gauge Members
Gauge Overload
NFX.Instrumentation Namespace


Gauge Constructor (String, DateTime)

Gauge Constructor (String, DateTime) NFX Class Library

Initializes a new instance of the Gauge class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Gauge(
    string source,
    DateTime utcDateTime
)
protected Gauge(
    string source,
    DateTime utcDateTime
)
Protected Sub New (
    source As String,
    utcDateTime As DateTime
)
Protected Sub New (
    source As String,
    utcDateTime As DateTime
)
protected:
Gauge(
    String^ source,
    DateTime utcDateTime
)
protected:
Gauge(
    String^ source,
    DateTime utcDateTime
)
new :
        source : string *
        utcDateTime : DateTime -> Gauge
new :
        source : string *
        utcDateTime : DateTime -> Gauge

Parameters

source
Type: Online System String
utcDateTime
Type: Online System DateTime
See Also
Gauge Class
Gauge Members
Gauge Overload
NFX.Instrumentation Namespace


Gauge Fields

Gauge Fields NFX Class Library

The Gauge type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
Gauge Class
NFX.Instrumentation Namespace


Gauge Methods

Gauge Methods NFX Class Library

The Gauge type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from Datum.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from Datum.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Gauge Class
NFX.Instrumentation Namespace


Gauge Properties

Gauge Properties NFX Class Library

The Gauge type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | ValueAsObject | Provides access to value polymorphically (Inherited from Datum.)
Public property | ValueUnitName | Provides name for units that value is measured in (Inherited from Datum.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
Gauge Class
NFX.Instrumentation Namespace


IBusinessLogic Interface

IBusinessLogic Interface NFX Class Library

A class of operations related to business logic that instrument measures

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IBusinessLogic : IOperationClass,
    IInstrumentClass
public interface IBusinessLogic : IOperationClass,
    IInstrumentClass
Public Interface IBusinessLogic
    Inherits IOperationClass, IInstrumentClass
Public Interface IBusinessLogic
    Inherits IOperationClass, IInstrumentClass
public interface class IBusinessLogic : IOperationClass,
    IInstrumentClass
public interface class IBusinessLogic : IOperationClass,
    IInstrumentClass
type IBusinessLogic =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
type IBusinessLogic =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
NFX.Instrumentation Namespace


ICacheInstrument Interface

ICacheInstrument Interface NFX Class Library

Cache-related operations

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[InstrumentViewGroup]
public interface ICacheInstrument : IOperationClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface ICacheInstrument : IOperationClass,
    IInstrumentClass
<InstrumentViewGroup>
Public Interface ICacheInstrument
    Inherits IOperationClass, IInstrumentClass
<InstrumentViewGroup>
Public Interface ICacheInstrument
    Inherits IOperationClass, IInstrumentClass
[InstrumentViewGroup]
public interface class ICacheInstrument : IOperationClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface class ICacheInstrument : IOperationClass,
    IInstrumentClass
[<InstrumentViewGroup>]
type ICacheInstrument =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
[<InstrumentViewGroup>]
type ICacheInstrument =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
NFX.Instrumentation Namespace


ICatastropyInstrument Interface

ICatastropyInstrument Interface NFX Class Library

Data of this class indicates an abnormality that will most likely lead to system inability to continue functioning as expected

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[InstrumentViewGroup]
public interface ICatastropyInstrument : IProblemClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface ICatastropyInstrument : IProblemClass,
    IInstrumentClass
<InstrumentViewGroup>
Public Interface ICatastropyInstrument
    Inherits IProblemClass, IInstrumentClass
<InstrumentViewGroup>
Public Interface ICatastropyInstrument
    Inherits IProblemClass, IInstrumentClass
[InstrumentViewGroup]
public interface class ICatastropyInstrument : IProblemClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface class ICatastropyInstrument : IProblemClass,
    IInstrumentClass
[<InstrumentViewGroup>]
type ICatastropyInstrument =
    interface
        interface IProblemClass
        interface IInstrumentClass
    end
[<InstrumentViewGroup>]
type ICatastropyInstrument =
    interface
        interface IProblemClass
        interface IInstrumentClass
    end
See Also
NFX.Instrumentation Namespace


ICPUInstrument Interface

ICPUInstrument Interface NFX Class Library

CPU-related operations

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[InstrumentViewGroup]
public interface ICPUInstrument : IOperationClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface ICPUInstrument : IOperationClass,
    IInstrumentClass
<InstrumentViewGroup>
Public Interface ICPUInstrument
    Inherits IOperationClass, IInstrumentClass
<InstrumentViewGroup>
Public Interface ICPUInstrument
    Inherits IOperationClass, IInstrumentClass
[InstrumentViewGroup]
public interface class ICPUInstrument : IOperationClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface class ICPUInstrument : IOperationClass,
    IInstrumentClass
[<InstrumentViewGroup>]
type ICPUInstrument =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
[<InstrumentViewGroup>]
type ICPUInstrument =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
NFX.Instrumentation Namespace


IDatabaseInstrument Interface

IDatabaseInstrument Interface NFX Class Library

DB-related operations

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[InstrumentViewGroup]
public interface IDatabaseInstrument : IOperationClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface IDatabaseInstrument : IOperationClass,
    IInstrumentClass
<InstrumentViewGroup>
Public Interface IDatabaseInstrument
    Inherits IOperationClass, IInstrumentClass
<InstrumentViewGroup>
Public Interface IDatabaseInstrument
    Inherits IOperationClass, IInstrumentClass
[InstrumentViewGroup]
public interface class IDatabaseInstrument : IOperationClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface class IDatabaseInstrument : IOperationClass,
    IInstrumentClass
[<InstrumentViewGroup>]
type IDatabaseInstrument =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
[<InstrumentViewGroup>]
type IDatabaseInstrument =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
NFX.Instrumentation Namespace


IDiskInstrument Interface

IDiskInstrument Interface NFX Class Library

Disk operations (i.e. % drive free)

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[InstrumentViewGroup]
public interface IDiskInstrument : IIOInstrumentClass,
    IOperationClass, IInstrumentClass
[InstrumentViewGroup]
public interface IDiskInstrument : IIOInstrumentClass,
    IOperationClass, IInstrumentClass
<InstrumentViewGroup>
Public Interface IDiskInstrument
    Inherits IIOInstrumentClass, IOperationClass, IInstrumentClass
<InstrumentViewGroup>
Public Interface IDiskInstrument
    Inherits IIOInstrumentClass, IOperationClass, IInstrumentClass
[InstrumentViewGroup]
public interface class IDiskInstrument : IIOInstrumentClass,
    IOperationClass, IInstrumentClass
[InstrumentViewGroup]
public interface class IDiskInstrument : IIOInstrumentClass,
    IOperationClass, IInstrumentClass
[<InstrumentViewGroup>]
type IDiskInstrument =
    interface
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<InstrumentViewGroup>]
type IDiskInstrument =
    interface
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
NFX.Instrumentation Namespace


IErrorInstrument Interface

IErrorInstrument Interface NFX Class Library

Data of this class indicates a definite abnormality, however the system is going to continue functioning

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[InstrumentViewGroup]
public interface IErrorInstrument : IProblemClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface IErrorInstrument : IProblemClass,
    IInstrumentClass
<InstrumentViewGroup>
Public Interface IErrorInstrument
    Inherits IProblemClass, IInstrumentClass
<InstrumentViewGroup>
Public Interface IErrorInstrument
    Inherits IProblemClass, IInstrumentClass
[InstrumentViewGroup]
public interface class IErrorInstrument : IProblemClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface class IErrorInstrument : IProblemClass,
    IInstrumentClass
[<InstrumentViewGroup>]
type IErrorInstrument =
    interface
        interface IProblemClass
        interface IInstrumentClass
    end
[<InstrumentViewGroup>]
type IErrorInstrument =
    interface
        interface IProblemClass
        interface IInstrumentClass
    end
See Also
NFX.Instrumentation Namespace


IFinancialLogic Interface

IFinancialLogic Interface NFX Class Library

A class of operations related to financial transactions / business logic

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[InstrumentViewGroup]
public interface IFinancialLogic : IBusinessLogic,
    IOperationClass, IInstrumentClass
[InstrumentViewGroup]
public interface IFinancialLogic : IBusinessLogic,
    IOperationClass, IInstrumentClass
<InstrumentViewGroup>
Public Interface IFinancialLogic
    Inherits IBusinessLogic, IOperationClass, IInstrumentClass
<InstrumentViewGroup>
Public Interface IFinancialLogic
    Inherits IBusinessLogic, IOperationClass, IInstrumentClass
[InstrumentViewGroup]
public interface class IFinancialLogic : IBusinessLogic,
    IOperationClass, IInstrumentClass
[InstrumentViewGroup]
public interface class IFinancialLogic : IBusinessLogic,
    IOperationClass, IInstrumentClass
[<InstrumentViewGroup>]
type IFinancialLogic =
    interface
        interface IBusinessLogic
        interface IOperationClass
        interface IInstrumentClass
    end
[<InstrumentViewGroup>]
type IFinancialLogic =
    interface
        interface IBusinessLogic
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
NFX.Instrumentation Namespace


IGDIDInstrument Interface

IGDIDInstrument Interface NFX Class Library

GDID-related operations

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[InstrumentViewGroup]
public interface IGDIDInstrument : IOperationClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface IGDIDInstrument : IOperationClass,
    IInstrumentClass
<InstrumentViewGroup>
Public Interface IGDIDInstrument
    Inherits IOperationClass, IInstrumentClass
<InstrumentViewGroup>
Public Interface IGDIDInstrument
    Inherits IOperationClass, IInstrumentClass
[InstrumentViewGroup]
public interface class IGDIDInstrument : IOperationClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface class IGDIDInstrument : IOperationClass,
    IInstrumentClass
[<InstrumentViewGroup>]
type IGDIDInstrument =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
[<InstrumentViewGroup>]
type IGDIDInstrument =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
NFX.Instrumentation Namespace


IInstrumentable Interface

IInstrumentable Interface NFX Class Library

Denotes an entity that can be instrumented

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IInstrumentable : IExternallyParameterized
public interface IInstrumentable : IExternallyParameterized
Public Interface IInstrumentable
    Inherits IExternallyParameterized
Public Interface IInstrumentable
    Inherits IExternallyParameterized
public interface class IInstrumentable : IExternallyParameterized
public interface class IInstrumentable : IExternallyParameterized
type IInstrumentable =
    interface
        interface IExternallyParameterized
    end
type IInstrumentable =
    interface
        interface IExternallyParameterized
    end
See Also
IInstrumentable Members
NFX.Instrumentation Namespace


IInstrumentable Members

IInstrumentable Members NFX Class Library

The IInstrumentable type exposes the following members.
Methods
 | Name | Description
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Back to Top
Properties
 | Name | Description
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation
Back to Top
See Also
IInstrumentable Interface
NFX.Instrumentation Namespace


IInstrumentable Methods

IInstrumentable Methods NFX Class Library

The IInstrumentable type exposes the following members.
Methods
 | Name | Description
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Back to Top
See Also
IInstrumentable Interface
NFX.Instrumentation Namespace


IInstrumentable Properties

IInstrumentable Properties NFX Class Library

The IInstrumentable type exposes the following members.
Properties
 | Name | Description
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation
Back to Top
See Also
IInstrumentable Interface
NFX.Instrumentation Namespace


IInstrumentable.InstrumentationEnabled Property

IInstrumentable InstrumentationEnabled Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Turns on/off instrumentation

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool InstrumentationEnabled { get; set; }
bool InstrumentationEnabled { get; set; }
Property InstrumentationEnabled As Boolean
    Get
    Set
Property InstrumentationEnabled As Boolean
    Get
    Set
property bool InstrumentationEnabled {
    bool get ();
    void set (bool value);
}
property bool InstrumentationEnabled {
    bool get ();
    void set (bool value);
}
abstract InstrumentationEnabled : bool with get, set
abstract InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean
See Also
IInstrumentable Interface
IInstrumentable Members
NFX.Instrumentation Namespace


IInstrumentation Interface

IInstrumentation Interface NFX Class Library

Stipulates instrumentation contract

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IInstrumentation : IApplicationComponent,
    IDisposable, ILocalizedTimeProvider
public interface IInstrumentation : IApplicationComponent,
    IDisposable, ILocalizedTimeProvider
Public Interface IInstrumentation
    Inherits IApplicationComponent, IDisposable, ILocalizedTimeProvider
Public Interface IInstrumentation
    Inherits IApplicationComponent, IDisposable, ILocalizedTimeProvider
public interface class IInstrumentation : IApplicationComponent,
    IDisposable, ILocalizedTimeProvider
public interface class IInstrumentation : IApplicationComponent,
    IDisposable, ILocalizedTimeProvider
type IInstrumentation =
    interface
        interface IApplicationComponent
        interface IDisposable
        interface ILocalizedTimeProvider
    end
type IInstrumentation =
    interface
        interface IApplicationComponent
        interface IDisposable
        interface ILocalizedTimeProvider
    end
See Also
IInstrumentation Members
NFX.Instrumentation Namespace


IInstrumentation Members

IInstrumentation Members NFX Class Library

The IInstrumentation type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | GetBufferedResults | Returns the specified number of samples from the ring result buffer in the near-chronological order, meaning that data is already sorted by time MOST of the TIME, however sorting is NOT GUARANTEED for all result records returned as enumeration is a lazy procedure that does not make copies/take locks. The enumeration is empty if ResultBufferSize is less or equal to zero entries. If count is less or equal to zero then the system returns all results available.
Public method | GetBufferedResultsSince | Returns samples starting around the the specified UTCdate in the near-chronological order, meaning that data is already sorted by time MOST of the TIME, however sorting is NOT GUARANTEED for all result records returned as enumeration is a lazy procedure that does not make copies/take locks. The enumeration is empty if ResultBufferSize is less or equal to zero entries
Public method | GetDatumTypeSources | Enumerates sources per Datum type ever recorded by the instance. This property may be used to build UIs for instrumentation, i.e. datum type tree. Returned data is NOT ORDERED. Returns default instance so caller may get default description/unit name
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | Record | Records instrumentation datum
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | DataTypes | Enumerates distinct types of Datum ever recorded in the instance. This property may be used to build UIs for instrumentation, i.e. datum type tree. Returned data is NOT ORDERED
Public property | Enabled | Indicates whether instrumentation is enabled
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from ILocalizedTimeProvider.)
Public property | MaxRecordCount | Gets/Sets the maximum record count that this instance can store
Public property | OSInstrumentationIntervalMS | Specifies how often OS instrumentation such as CPU and RAM is sampled. Value of zero disables OS sampling
Public property | Overflown | Returns true to indicate that instrumentation does not have any space left to record more data at the present moment
Public property | ProcessingIntervalMS | Specifies how often aggregation is performed
Public property | RecordCount | Returns current record count in the instance
Public property | ResultBufferSize | Returns the size of the ring buffer where result (aggregated) instrumentation records are kept in memory. The maximum buffer capacity is returned, not how many results have been buffered so far. If this property is less than or equal to zero then result buffering in memory is disabled
Public property | SelfInstrumented | When true, outputs instrumentation data about the self (how many datum buffers, etc.)
Public property | TimeLocation | Returns the location (Inherited from ILocalizedTimeProvider.)
Back to Top
See Also
IInstrumentation Interface
NFX.Instrumentation Namespace


IInstrumentation Methods

IInstrumentation Methods NFX Class Library

The IInstrumentation type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | GetBufferedResults | Returns the specified number of samples from the ring result buffer in the near-chronological order, meaning that data is already sorted by time MOST of the TIME, however sorting is NOT GUARANTEED for all result records returned as enumeration is a lazy procedure that does not make copies/take locks. The enumeration is empty if ResultBufferSize is less or equal to zero entries. If count is less or equal to zero then the system returns all results available.
Public method | GetBufferedResultsSince | Returns samples starting around the the specified UTCdate in the near-chronological order, meaning that data is already sorted by time MOST of the TIME, however sorting is NOT GUARANTEED for all result records returned as enumeration is a lazy procedure that does not make copies/take locks. The enumeration is empty if ResultBufferSize is less or equal to zero entries
Public method | GetDatumTypeSources | Enumerates sources per Datum type ever recorded by the instance. This property may be used to build UIs for instrumentation, i.e. datum type tree. Returned data is NOT ORDERED. Returns default instance so caller may get default description/unit name
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | Record | Records instrumentation datum
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Back to Top
See Also
IInstrumentation Interface
NFX.Instrumentation Namespace


IInstrumentation.GetBufferedResults Method

IInstrumentation GetBufferedResults Method NFX Class Library

Returns the specified number of samples from the ring result buffer in the near-chronological order, meaning that data is already sorted by time MOST of the TIME, however sorting is NOT GUARANTEED for all result records returned as enumeration is a lazy procedure that does not make copies/take locks. The enumeration is empty if ResultBufferSize is less or equal to zero entries. If count is less or equal to zero then the system returns all results available.

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<Datum> GetBufferedResults(
    int count = 0
)
IEnumerable<Datum> GetBufferedResults(
    int count = 0
)
Function GetBufferedResults (
    Optional count As Integer = 0
) As IEnumerable(Of Datum)
Function GetBufferedResults (
    Optional count As Integer = 0
) As IEnumerable(Of Datum)
IEnumerable<Datum^>^ GetBufferedResults(
    int count = 0
)
IEnumerable<Datum^>^ GetBufferedResults(
    int count = 0
)
abstract GetBufferedResults :
        ?count : int
(* Defaults:
        let _count = defaultArg count 0
*)
-> IEnumerable<Datum>
abstract GetBufferedResults :
        ?count : int
(* Defaults:
        let _count = defaultArg count 0
*)
-> IEnumerable<Datum>

Parameters

count (Optional)
Type: Online System Int32

Return Value

Type: Online IEnumerable Datum
See Also
IInstrumentation Interface
IInstrumentation Members
NFX.Instrumentation Namespace


IInstrumentation.GetBufferedResultsSince Method

IInstrumentation GetBufferedResultsSince Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns samples starting around the the specified UTCdate in the near-chronological order, meaning that data is already sorted by time MOST of the TIME, however sorting is NOT GUARANTEED for all result records returned as enumeration is a lazy procedure that does not make copies/take locks. The enumeration is empty if ResultBufferSize is less or equal to zero entries

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<Datum> GetBufferedResultsSince(
    DateTime utcStart
)
IEnumerable<Datum> GetBufferedResultsSince(
    DateTime utcStart
)
Function GetBufferedResultsSince (
    utcStart As DateTime
) As IEnumerable(Of Datum)
Function GetBufferedResultsSince (
    utcStart As DateTime
) As IEnumerable(Of Datum)
IEnumerable<Datum^>^ GetBufferedResultsSince(
    DateTime utcStart
)
IEnumerable<Datum^>^ GetBufferedResultsSince(
    DateTime utcStart
)
abstract GetBufferedResultsSince :
        utcStart : DateTime -> IEnumerable<Datum>
abstract GetBufferedResultsSince :
        utcStart : DateTime -> IEnumerable<Datum>

Parameters

utcStart
Type: Online System DateTime

Return Value

Type: Online IEnumerable Datum
See Also
IInstrumentation Interface
IInstrumentation Members
NFX.Instrumentation Namespace


IInstrumentation.GetDatumTypeSources Method

IInstrumentation GetDatumTypeSources Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Enumerates sources per Datum type ever recorded by the instance. This property may be used to build UIs for instrumentation, i.e. datum type tree. Returned data is NOT ORDERED. Returns default instance so caller may get default description/unit name

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<string> GetDatumTypeSources(
    Type datumType,
    out Datum defaultInstance
)
IEnumerable<string> GetDatumTypeSources(
    Type datumType,
    out Datum defaultInstance
)
Function GetDatumTypeSources (
    datumType As Type,
    <OutAttribute> ByRef defaultInstance As Datum
) As IEnumerable(Of String)
Function GetDatumTypeSources (
    datumType As Type,
    <OutAttribute> ByRef defaultInstance As Datum
) As IEnumerable(Of String)
IEnumerable<String^>^ GetDatumTypeSources(
    Type^ datumType,
    [OutAttribute] Datum^% defaultInstance
)
IEnumerable<String^>^ GetDatumTypeSources(
    Type^ datumType,
    [OutAttribute] Datum^% defaultInstance
)
abstract GetDatumTypeSources :
        datumType : Type *
        defaultInstance : Datum byref -> IEnumerable<string>
abstract GetDatumTypeSources :
        datumType : Type *
        defaultInstance : Datum byref -> IEnumerable<string>

Parameters

datumType
Type: Online System Type
defaultInstance
Type: NFX.Instrumentation Datum

Return Value

Type: Online IEnumerable Online String
See Also
IInstrumentation Interface
IInstrumentation Members
NFX.Instrumentation Namespace


IInstrumentation.Record Method

IInstrumentation Record Method NFX Class Library

Records instrumentation datum

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Record(
    Datum datum
)
void Record(
    Datum datum
)
Sub Record (
    datum As Datum
)
Sub Record (
    datum As Datum
)
void Record(
    Datum^ datum
)
void Record(
    Datum^ datum
)
abstract Record :
        datum : Datum -> unit
abstract Record :
        datum : Datum -> unit

Parameters

datum
Type: NFX.Instrumentation Datum
See Also
IInstrumentation Interface
IInstrumentation Members
NFX.Instrumentation Namespace


IInstrumentation Properties

IInstrumentation Properties NFX Class Library

The IInstrumentation type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | DataTypes | Enumerates distinct types of Datum ever recorded in the instance. This property may be used to build UIs for instrumentation, i.e. datum type tree. Returned data is NOT ORDERED
Public property | Enabled | Indicates whether instrumentation is enabled
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from ILocalizedTimeProvider.)
Public property | MaxRecordCount | Gets/Sets the maximum record count that this instance can store
Public property | OSInstrumentationIntervalMS | Specifies how often OS instrumentation such as CPU and RAM is sampled. Value of zero disables OS sampling
Public property | Overflown | Returns true to indicate that instrumentation does not have any space left to record more data at the present moment
Public property | ProcessingIntervalMS | Specifies how often aggregation is performed
Public property | RecordCount | Returns current record count in the instance
Public property | ResultBufferSize | Returns the size of the ring buffer where result (aggregated) instrumentation records are kept in memory. The maximum buffer capacity is returned, not how many results have been buffered so far. If this property is less than or equal to zero then result buffering in memory is disabled
Public property | SelfInstrumented | When true, outputs instrumentation data about the self (how many datum buffers, etc.)
Public property | TimeLocation | Returns the location (Inherited from ILocalizedTimeProvider.)
Back to Top
See Also
IInstrumentation Interface
NFX.Instrumentation Namespace


IInstrumentation.DataTypes Property

IInstrumentation DataTypes Property NFX Class Library

Enumerates distinct types of Datum ever recorded in the instance. This property may be used to build UIs for instrumentation, i.e. datum type tree. Returned data is NOT ORDERED

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<Type> DataTypes { get; }
IEnumerable<Type> DataTypes { get; }
ReadOnly Property DataTypes As IEnumerable(Of Type)
    Get
ReadOnly Property DataTypes As IEnumerable(Of Type)
    Get
property IEnumerable<Type^>^ DataTypes {
    IEnumerable<Type^>^ get ();
}
property IEnumerable<Type^>^ DataTypes {
    IEnumerable<Type^>^ get ();
}
abstract DataTypes : IEnumerable<Type> with get
abstract DataTypes : IEnumerable<Type> with get

Property Value

Type: Online IEnumerable Online Type
See Also
IInstrumentation Interface
IInstrumentation Members
NFX.Instrumentation Namespace


IInstrumentation.Enabled Property

IInstrumentation Enabled Property NFX Class Library

Indicates whether instrumentation is enabled

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Enabled { get; }
bool Enabled { get; }
ReadOnly Property Enabled As Boolean
    Get
ReadOnly Property Enabled As Boolean
    Get
property bool Enabled {
    bool get ();
}
property bool Enabled {
    bool get ();
}
abstract Enabled : bool with get
abstract Enabled : bool with get

Property Value

Type: Online Boolean
See Also
IInstrumentation Interface
IInstrumentation Members
NFX.Instrumentation Namespace


IInstrumentation.MaxRecordCount Property

IInstrumentation MaxRecordCount Property NFX Class Library

Gets/Sets the maximum record count that this instance can store

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int MaxRecordCount { get; }
int MaxRecordCount { get; }
ReadOnly Property MaxRecordCount As Integer
    Get
ReadOnly Property MaxRecordCount As Integer
    Get
property int MaxRecordCount {
    int get ();
}
property int MaxRecordCount {
    int get ();
}
abstract MaxRecordCount : int with get
abstract MaxRecordCount : int with get

Property Value

Type: Online Int32
See Also
IInstrumentation Interface
IInstrumentation Members
NFX.Instrumentation Namespace


IInstrumentation.OSInstrumentationIntervalMS Property

IInstrumentation OSInstrumentationIntervalMS Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Specifies how often OS instrumentation such as CPU and RAM is sampled. Value of zero disables OS sampling

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int OSInstrumentationIntervalMS { get; }
int OSInstrumentationIntervalMS { get; }
ReadOnly Property OSInstrumentationIntervalMS As Integer
    Get
ReadOnly Property OSInstrumentationIntervalMS As Integer
    Get
property int OSInstrumentationIntervalMS {
    int get ();
}
property int OSInstrumentationIntervalMS {
    int get ();
}
abstract OSInstrumentationIntervalMS : int with get
abstract OSInstrumentationIntervalMS : int with get

Property Value

Type: Online Int32
See Also
IInstrumentation Interface
IInstrumentation Members
NFX.Instrumentation Namespace


IInstrumentation.Overflown Property

IInstrumentation Overflown Property NFX Class Library

Returns true to indicate that instrumentation does not have any space left to record more data at the present moment

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Overflown { get; }
bool Overflown { get; }
ReadOnly Property Overflown As Boolean
    Get
ReadOnly Property Overflown As Boolean
    Get
property bool Overflown {
    bool get ();
}
property bool Overflown {
    bool get ();
}
abstract Overflown : bool with get
abstract Overflown : bool with get

Property Value

Type: Online Boolean
See Also
IInstrumentation Interface
IInstrumentation Members
NFX.Instrumentation Namespace


IInstrumentation.ProcessingIntervalMS Property

IInstrumentation ProcessingIntervalMS Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Specifies how often aggregation is performed

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int ProcessingIntervalMS { get; }
int ProcessingIntervalMS { get; }
ReadOnly Property ProcessingIntervalMS As Integer
    Get
ReadOnly Property ProcessingIntervalMS As Integer
    Get
property int ProcessingIntervalMS {
    int get ();
}
property int ProcessingIntervalMS {
    int get ();
}
abstract ProcessingIntervalMS : int with get
abstract ProcessingIntervalMS : int with get

Property Value

Type: Online Int32
See Also
IInstrumentation Interface
IInstrumentation Members
NFX.Instrumentation Namespace


IInstrumentation.RecordCount Property

IInstrumentation RecordCount Property NFX Class Library

Returns current record count in the instance

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int RecordCount { get; }
int RecordCount { get; }
ReadOnly Property RecordCount As Integer
    Get
ReadOnly Property RecordCount As Integer
    Get
property int RecordCount {
    int get ();
}
property int RecordCount {
    int get ();
}
abstract RecordCount : int with get
abstract RecordCount : int with get

Property Value

Type: Online Int32
See Also
IInstrumentation Interface
IInstrumentation Members
NFX.Instrumentation Namespace


IInstrumentation.ResultBufferSize Property

IInstrumentation ResultBufferSize Property NFX Class Library

Returns the size of the ring buffer where result (aggregated) instrumentation records are kept in memory. The maximum buffer capacity is returned, not how many results have been buffered so far. If this property is less than or equal to zero then result buffering in memory is disabled

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int ResultBufferSize { get; }
int ResultBufferSize { get; }
ReadOnly Property ResultBufferSize As Integer
    Get
ReadOnly Property ResultBufferSize As Integer
    Get
property int ResultBufferSize {
    int get ();
}
property int ResultBufferSize {
    int get ();
}
abstract ResultBufferSize : int with get
abstract ResultBufferSize : int with get

Property Value

Type: Online Int32
See Also
IInstrumentation Interface
IInstrumentation Members
NFX.Instrumentation Namespace


IInstrumentation.SelfInstrumented Property

IInstrumentation SelfInstrumented Property NFX Class Library

When true, outputs instrumentation data about the self (how many datum buffers, etc.)

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool SelfInstrumented { get; }
bool SelfInstrumented { get; }
ReadOnly Property SelfInstrumented As Boolean
    Get
ReadOnly Property SelfInstrumented As Boolean
    Get
property bool SelfInstrumented {
    bool get ();
}
property bool SelfInstrumented {
    bool get ();
}
abstract SelfInstrumented : bool with get
abstract SelfInstrumented : bool with get

Property Value

Type: Online Boolean
See Also
IInstrumentation Interface
IInstrumentation Members
NFX.Instrumentation Namespace


IInstrumentationImplementation Interface

IInstrumentationImplementation Interface NFX Class Library

Stipulates instrumentation contract

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IInstrumentationImplementation : IInstrumentation,
    IApplicationComponent, ILocalizedTimeProvider, IDisposable, IConfigurable, IInstrumentable,
    IExternallyParameterized
public interface IInstrumentationImplementation : IInstrumentation,
    IApplicationComponent, ILocalizedTimeProvider, IDisposable, IConfigurable, IInstrumentable,
    IExternallyParameterized
Public Interface IInstrumentationImplementation
    Inherits IInstrumentation, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
Public Interface IInstrumentationImplementation
    Inherits IInstrumentation, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
public interface class IInstrumentationImplementation : IInstrumentation,
    IApplicationComponent, ILocalizedTimeProvider, IDisposable, IConfigurable, IInstrumentable,
    IExternallyParameterized
public interface class IInstrumentationImplementation : IInstrumentation,
    IApplicationComponent, ILocalizedTimeProvider, IDisposable, IConfigurable, IInstrumentable,
    IExternallyParameterized
type IInstrumentationImplementation =
    interface
        interface IInstrumentation
        interface IApplicationComponent
        interface ILocalizedTimeProvider
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
type IInstrumentationImplementation =
    interface
        interface IInstrumentation
        interface IApplicationComponent
        interface ILocalizedTimeProvider
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
IInstrumentationImplementation Members
NFX.Instrumentation Namespace


IInstrumentationImplementation Members

IInstrumentationImplementation Members NFX Class Library

The IInstrumentationImplementation type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Public method | GetBufferedResults | Returns the specified number of samples from the ring result buffer in the near-chronological order, meaning that data is already sorted by time MOST of the TIME, however sorting is NOT GUARANTEED for all result records returned as enumeration is a lazy procedure that does not make copies/take locks. The enumeration is empty if ResultBufferSize is less or equal to zero entries. If count is less or equal to zero then the system returns all results available. (Inherited from IInstrumentation.)
Public method | GetBufferedResultsSince | Returns samples starting around the the specified UTCdate in the near-chronological order, meaning that data is already sorted by time MOST of the TIME, however sorting is NOT GUARANTEED for all result records returned as enumeration is a lazy procedure that does not make copies/take locks. The enumeration is empty if ResultBufferSize is less or equal to zero entries (Inherited from IInstrumentation.)
Public method | GetDatumTypeSources | Enumerates sources per Datum type ever recorded by the instance. This property may be used to build UIs for instrumentation, i.e. datum type tree. Returned data is NOT ORDERED. Returns default instance so caller may get default description/unit name (Inherited from IInstrumentation.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | Record | Records instrumentation datum (Inherited from IInstrumentation.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | DataTypes | Enumerates distinct types of Datum ever recorded in the instance. This property may be used to build UIs for instrumentation, i.e. datum type tree. Returned data is NOT ORDERED (Inherited from IInstrumentation.)
Public property | Enabled | Indicates whether instrumentation is enabled (Inherited from IInstrumentation.)
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from ILocalizedTimeProvider.)
Public property | MaxRecordCount | Gets/Sets the maximum record count that this instance can store (Inherited from IInstrumentation.)
Public property | OSInstrumentationIntervalMS | Specifies how often OS instrumentation such as CPU and RAM is sampled. Value of zero disables OS sampling (Inherited from IInstrumentation.)
Public property | Overflown | Returns true to indicate that instrumentation does not have any space left to record more data at the present moment (Inherited from IInstrumentation.)
Public property | ProcessingIntervalMS | Specifies how often aggregation is performed (Inherited from IInstrumentation.)
Public property | RecordCount | Returns current record count in the instance (Inherited from IInstrumentation.)
Public property | ResultBufferSize | Returns the size of the ring buffer where result (aggregated) instrumentation records are kept in memory. The maximum buffer capacity is returned, not how many results have been buffered so far. If this property is less than or equal to zero then result buffering in memory is disabled (Inherited from IInstrumentation.)
Public property | SelfInstrumented | When true, outputs instrumentation data about the self (how many datum buffers, etc.) (Inherited from IInstrumentation.)
Public property | TimeLocation | Returns the location (Inherited from ILocalizedTimeProvider.)
Back to Top
See Also
IInstrumentationImplementation Interface
NFX.Instrumentation Namespace


IInstrumentationImplementation Methods

IInstrumentationImplementation Methods NFX Class Library

The IInstrumentationImplementation type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Public method | GetBufferedResults | Returns the specified number of samples from the ring result buffer in the near-chronological order, meaning that data is already sorted by time MOST of the TIME, however sorting is NOT GUARANTEED for all result records returned as enumeration is a lazy procedure that does not make copies/take locks. The enumeration is empty if ResultBufferSize is less or equal to zero entries. If count is less or equal to zero then the system returns all results available. (Inherited from IInstrumentation.)
Public method | GetBufferedResultsSince | Returns samples starting around the the specified UTCdate in the near-chronological order, meaning that data is already sorted by time MOST of the TIME, however sorting is NOT GUARANTEED for all result records returned as enumeration is a lazy procedure that does not make copies/take locks. The enumeration is empty if ResultBufferSize is less or equal to zero entries (Inherited from IInstrumentation.)
Public method | GetDatumTypeSources | Enumerates sources per Datum type ever recorded by the instance. This property may be used to build UIs for instrumentation, i.e. datum type tree. Returned data is NOT ORDERED. Returns default instance so caller may get default description/unit name (Inherited from IInstrumentation.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | Record | Records instrumentation datum (Inherited from IInstrumentation.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Back to Top
See Also
IInstrumentationImplementation Interface
NFX.Instrumentation Namespace


IInstrumentationImplementation Properties

IInstrumentationImplementation Properties NFX Class Library

The IInstrumentationImplementation type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | DataTypes | Enumerates distinct types of Datum ever recorded in the instance. This property may be used to build UIs for instrumentation, i.e. datum type tree. Returned data is NOT ORDERED (Inherited from IInstrumentation.)
Public property | Enabled | Indicates whether instrumentation is enabled (Inherited from IInstrumentation.)
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from ILocalizedTimeProvider.)
Public property | MaxRecordCount | Gets/Sets the maximum record count that this instance can store (Inherited from IInstrumentation.)
Public property | OSInstrumentationIntervalMS | Specifies how often OS instrumentation such as CPU and RAM is sampled. Value of zero disables OS sampling (Inherited from IInstrumentation.)
Public property | Overflown | Returns true to indicate that instrumentation does not have any space left to record more data at the present moment (Inherited from IInstrumentation.)
Public property | ProcessingIntervalMS | Specifies how often aggregation is performed (Inherited from IInstrumentation.)
Public property | RecordCount | Returns current record count in the instance (Inherited from IInstrumentation.)
Public property | ResultBufferSize | Returns the size of the ring buffer where result (aggregated) instrumentation records are kept in memory. The maximum buffer capacity is returned, not how many results have been buffered so far. If this property is less than or equal to zero then result buffering in memory is disabled (Inherited from IInstrumentation.)
Public property | SelfInstrumented | When true, outputs instrumentation data about the self (how many datum buffers, etc.) (Inherited from IInstrumentation.)
Public property | TimeLocation | Returns the location (Inherited from ILocalizedTimeProvider.)
Back to Top
See Also
IInstrumentationImplementation Interface
NFX.Instrumentation Namespace


IInstrumentationInstrument Interface

IInstrumentationInstrument Interface NFX Class Library

Instruments that measure instrumentation itself

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[InstrumentViewGroup]
public interface IInstrumentationInstrument : IOperationClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface IInstrumentationInstrument : IOperationClass,
    IInstrumentClass
<InstrumentViewGroup>
Public Interface IInstrumentationInstrument
    Inherits IOperationClass, IInstrumentClass
<InstrumentViewGroup>
Public Interface IInstrumentationInstrument
    Inherits IOperationClass, IInstrumentClass
[InstrumentViewGroup]
public interface class IInstrumentationInstrument : IOperationClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface class IInstrumentationInstrument : IOperationClass,
    IInstrumentClass
[<InstrumentViewGroup>]
type IInstrumentationInstrument =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
[<InstrumentViewGroup>]
type IInstrumentationInstrument =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
NFX.Instrumentation Namespace


IInstrumentClass Interface

IInstrumentClass Interface NFX Class Library

Root marker interface for instrumentation data classification. Instruments are primarily classified by their derivation from Datum ancestor, however this interface-based scheme allows for alternate classification (a la multiple inheritance)

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IInstrumentClass
public interface IInstrumentClass
Public Interface IInstrumentClass
Public Interface IInstrumentClass
public interface class IInstrumentClass
public interface class IInstrumentClass
type IInstrumentClass =  interface end
type IInstrumentClass =  interface end
See Also
NFX.Instrumentation Namespace


IIOInstrumentClass Interface

IIOInstrumentClass Interface NFX Class Library

IO-related operations

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IIOInstrumentClass : IOperationClass,
    IInstrumentClass
public interface IIOInstrumentClass : IOperationClass,
    IInstrumentClass
Public Interface IIOInstrumentClass
    Inherits IOperationClass, IInstrumentClass
Public Interface IIOInstrumentClass
    Inherits IOperationClass, IInstrumentClass
public interface class IIOInstrumentClass : IOperationClass,
    IInstrumentClass
public interface class IIOInstrumentClass : IOperationClass,
    IInstrumentClass
type IIOInstrumentClass =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
type IIOInstrumentClass =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
NFX.Instrumentation Namespace


ILockingInstrument Interface

ILockingInstrument Interface NFX Class Library

Locking/coordination-related operations

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[InstrumentViewGroup]
public interface ILockingInstrument : IOperationClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface ILockingInstrument : IOperationClass,
    IInstrumentClass
<InstrumentViewGroup>
Public Interface ILockingInstrument
    Inherits IOperationClass, IInstrumentClass
<InstrumentViewGroup>
Public Interface ILockingInstrument
    Inherits IOperationClass, IInstrumentClass
[InstrumentViewGroup]
public interface class ILockingInstrument : IOperationClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface class ILockingInstrument : IOperationClass,
    IInstrumentClass
[<InstrumentViewGroup>]
type ILockingInstrument =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
[<InstrumentViewGroup>]
type ILockingInstrument =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
NFX.Instrumentation Namespace


IMemoryInstrument Interface

IMemoryInstrument Interface NFX Class Library

Memory-related operations

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[InstrumentViewGroup]
public interface IMemoryInstrument : IOperationClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface IMemoryInstrument : IOperationClass,
    IInstrumentClass
<InstrumentViewGroup>
Public Interface IMemoryInstrument
    Inherits IOperationClass, IInstrumentClass
<InstrumentViewGroup>
Public Interface IMemoryInstrument
    Inherits IOperationClass, IInstrumentClass
[InstrumentViewGroup]
public interface class IMemoryInstrument : IOperationClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface class IMemoryInstrument : IOperationClass,
    IInstrumentClass
[<InstrumentViewGroup>]
type IMemoryInstrument =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
[<InstrumentViewGroup>]
type IMemoryInstrument =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
NFX.Instrumentation Namespace


INetInstrument Interface

INetInstrument Interface NFX Class Library

Network operations (i.e. sockets)

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[InstrumentViewGroup]
public interface INetInstrument : IIOInstrumentClass,
    IOperationClass, IInstrumentClass
[InstrumentViewGroup]
public interface INetInstrument : IIOInstrumentClass,
    IOperationClass, IInstrumentClass
<InstrumentViewGroup>
Public Interface INetInstrument
    Inherits IIOInstrumentClass, IOperationClass, IInstrumentClass
<InstrumentViewGroup>
Public Interface INetInstrument
    Inherits IIOInstrumentClass, IOperationClass, IInstrumentClass
[InstrumentViewGroup]
public interface class INetInstrument : IIOInstrumentClass,
    IOperationClass, IInstrumentClass
[InstrumentViewGroup]
public interface class INetInstrument : IIOInstrumentClass,
    IOperationClass, IInstrumentClass
[<InstrumentViewGroup>]
type INetInstrument =
    interface
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
[<InstrumentViewGroup>]
type INetInstrument =
    interface
        interface IIOInstrumentClass
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
NFX.Instrumentation Namespace


InstrumentationProvider Class

InstrumentationProvider Class NFX Class Library

Defines a base provider for InstrumentationService
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service InstrumentationService
NFX.Instrumentation InstrumentationProvider
NFX.Instrumentation LogInstrumentationProvider
NFX.Instrumentation NOPInstrumentationProvider

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class InstrumentationProvider : Service<InstrumentationService>,
    IExternallyParameterized
public abstract class InstrumentationProvider : Service<InstrumentationService>,
    IExternallyParameterized
Public MustInherit Class InstrumentationProvider
    Inherits Service(Of InstrumentationService)
    Implements IExternallyParameterized
Public MustInherit Class InstrumentationProvider
    Inherits Service(Of InstrumentationService)
    Implements IExternallyParameterized
public ref class InstrumentationProvider abstract : public Service<InstrumentationService^>,
    IExternallyParameterized
public ref class InstrumentationProvider abstract : public Service<InstrumentationService^>,
    IExternallyParameterized
[<AbstractClassAttribute>]
type InstrumentationProvider =
    class
        inherit Service<InstrumentationService>
        interface IExternallyParameterized
    end
[<AbstractClassAttribute>]
type InstrumentationProvider =
    class
        inherit Service<InstrumentationService>
        interface IExternallyParameterized
    end
See Also
InstrumentationProvider Members
NFX.Instrumentation Namespace


InstrumentationProvider Members

InstrumentationProvider Members NFX Class Library

The InstrumentationProvider type exposes the following members.
Constructors
 | Name | Description
Protected method | InstrumentationProvider | Initializes a new instance of the InstrumentationProvider class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | Write |
Protected method | WriteLog |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
InstrumentationProvider Class
NFX.Instrumentation Namespace


InstrumentationProvider Constructor

InstrumentationProvider Constructor NFX Class Library

Initializes a new instance of the InstrumentationProvider class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected InstrumentationProvider(
    InstrumentationService director
)
protected InstrumentationProvider(
    InstrumentationService director
)
Protected Sub New (
    director As InstrumentationService
)
Protected Sub New (
    director As InstrumentationService
)
protected:
InstrumentationProvider(
    InstrumentationService^ director
)
protected:
InstrumentationProvider(
    InstrumentationService^ director
)
new :
        director : InstrumentationService -> InstrumentationProvider
new :
        director : InstrumentationService -> InstrumentationProvider

Parameters

director
Type: NFX.Instrumentation InstrumentationService
See Also
InstrumentationProvider Class
InstrumentationProvider Members
NFX.Instrumentation Namespace


InstrumentationProvider Methods

InstrumentationProvider Methods NFX Class Library

The InstrumentationProvider type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | Write |
Protected method | WriteLog |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
InstrumentationProvider Class
NFX.Instrumentation Namespace


InstrumentationProvider.DoConfigure Method

InstrumentationProvider DoConfigure Method NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
InstrumentationProvider Class
InstrumentationProvider Members
NFX.Instrumentation Namespace


InstrumentationProvider.ExternalGetParameter Method

InstrumentationProvider ExternalGetParameter Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets external parameter value returning true if parameter was found

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
public virtual bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
Public Overridable Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
Public Overridable Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
)
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
)
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalGetParameter(String, Object , String )
See Also
InstrumentationProvider Class
InstrumentationProvider Members
NFX.Instrumentation Namespace


InstrumentationProvider.ExternalParametersForGroups Method

InstrumentationProvider ExternalParametersForGroups Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns named parameters that can be used to control this component

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
public virtual IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
Public Overridable Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
Public Overridable Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
)
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
)
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>

Parameters

groups
Type: Online System String

Return Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParametersForGroups( String )
See Also
InstrumentationProvider Class
InstrumentationProvider Members
NFX.Instrumentation Namespace


InstrumentationProvider.ExternalSetParameter Method

InstrumentationProvider ExternalSetParameter Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Sets external parameter value returning true if parameter was found and set

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
public virtual bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
Public Overridable Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
Public Overridable Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
)
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
)
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalSetParameter(String, Object, String )
See Also
InstrumentationProvider Class
InstrumentationProvider Members
NFX.Instrumentation Namespace


InstrumentationProvider.Write Method

InstrumentationProvider Write Method NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    Datum aggregatedDatum
)
public abstract void Write(
    Datum aggregatedDatum
)
Public MustOverride Sub Write (
    aggregatedDatum As Datum
)
Public MustOverride Sub Write (
    aggregatedDatum As Datum
)
public:
virtual void Write(
    Datum^ aggregatedDatum
) abstract
public:
virtual void Write(
    Datum^ aggregatedDatum
) abstract
abstract Write :
        aggregatedDatum : Datum -> unit
abstract Write :
        aggregatedDatum : Datum -> unit

Parameters

aggregatedDatum
Type: NFX.Instrumentation Datum
See Also
InstrumentationProvider Class
InstrumentationProvider Members
NFX.Instrumentation Namespace


InstrumentationProvider.WriteLog Method

InstrumentationProvider WriteLog Method NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void WriteLog(
    MessageType type,
    string message,
    string parameters = null,
    string from = null
)
protected void WriteLog(
    MessageType type,
    string message,
    string parameters = null,
    string from = null
)
Protected Sub WriteLog (
    type As MessageType,
    message As String,
    Optional parameters As String = Nothing,
    Optional from As String = Nothing
)
Protected Sub WriteLog (
    type As MessageType,
    message As String,
    Optional parameters As String = Nothing,
    Optional from As String = Nothing
)
protected:
void WriteLog(
    MessageType type,
    String^ message,
    String^ parameters = nullptr,
    String^ from = nullptr
)
protected:
void WriteLog(
    MessageType type,
    String^ message,
    String^ parameters = nullptr,
    String^ from = nullptr
)
member WriteLog :
        type : MessageType *
        message : string *
        ?parameters : string *
        ?from : string
(* Defaults:
        let _parameters = defaultArg parameters null
        let _from = defaultArg from null
*)
-> unit
member WriteLog :
        type : MessageType *
        message : string *
        ?parameters : string *
        ?from : string
(* Defaults:
        let _parameters = defaultArg parameters null
        let _from = defaultArg from null
*)
-> unit

Parameters

type
Type: NFX.Log MessageType
message
Type: Online System String
parameters (Optional)
Type: Online System String
from (Optional)
Type: Online System String
See Also
InstrumentationProvider Class
InstrumentationProvider Members
NFX.Instrumentation Namespace


InstrumentationProvider Properties

InstrumentationProvider Properties NFX Class Library

The InstrumentationProvider type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
InstrumentationProvider Class
NFX.Instrumentation Namespace


InstrumentationProvider.ExternalParameters Property

InstrumentationProvider ExternalParameters Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns named parameters that can be used to control this component

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
public virtual IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
Public Overridable ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
Public Overridable ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get ();
}
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get ();
}
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get

Property Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParameters
See Also
InstrumentationProvider Class
InstrumentationProvider Members
NFX.Instrumentation Namespace


InstrumentationService Class

InstrumentationService Class NFX Class Library

Implements IInstrumentation. This service aggregates data by type,source and sends result into provider
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service Online Object
NFX.ServiceModel ServiceWithInstrumentationBase Online Object
NFX.Instrumentation InstrumentationService

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigMacroContextAttribute]
public sealed class InstrumentationService : ServiceWithInstrumentationBase<Object>,
    IInstrumentationImplementation, IInstrumentation, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
[ConfigMacroContextAttribute]
public sealed class InstrumentationService : ServiceWithInstrumentationBase<Object>,
    IInstrumentationImplementation, IInstrumentation, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
<ConfigMacroContextAttribute>
Public NotInheritable Class InstrumentationService
    Inherits ServiceWithInstrumentationBase(Of Object)
    Implements IInstrumentationImplementation, IInstrumentation, IApplicationComponent, ILocalizedTimeProvider,
    IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
<ConfigMacroContextAttribute>
Public NotInheritable Class InstrumentationService
    Inherits ServiceWithInstrumentationBase(Of Object)
    Implements IInstrumentationImplementation, IInstrumentation, IApplicationComponent, ILocalizedTimeProvider,
    IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
[ConfigMacroContextAttribute]
public ref class InstrumentationService sealed : public ServiceWithInstrumentationBase<Object^>,
    IInstrumentationImplementation, IInstrumentation, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
[ConfigMacroContextAttribute]
public ref class InstrumentationService sealed : public ServiceWithInstrumentationBase<Object^>,
    IInstrumentationImplementation, IInstrumentation, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
[<SealedAttribute>]
[<ConfigMacroContextAttribute>]
type InstrumentationService =
    class
        inherit ServiceWithInstrumentationBase<Object>
        interface IInstrumentationImplementation
        interface IInstrumentation
        interface IApplicationComponent
        interface ILocalizedTimeProvider
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
[<SealedAttribute>]
[<ConfigMacroContextAttribute>]
type InstrumentationService =
    class
        inherit ServiceWithInstrumentationBase<Object>
        interface IInstrumentationImplementation
        interface IInstrumentation
        interface IApplicationComponent
        interface ILocalizedTimeProvider
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentationService Members

InstrumentationService Members NFX Class Library

The InstrumentationService type exposes the following members.
Constructors
 | Name | Description
Public method | InstrumentationService | Creates a instrumentation service instance
Public method | InstrumentationService(Object) | Creates a instrumentation service instance
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetBufferedResults | Returns the specified number of samples from the ring result buffer in the near-chronological order, meaning that data is already sorted by time MOST of the TIME, however sorting is NOT GUARANTEED for all result records returned as enumeration is a lazy procedure that does not make copies/take locks. The enumeration is empty if ResultBufferSize is less or equal to zero entries. If count is less or equal to zero then the system returns all results available.
Public method | GetBufferedResultsSince | Returns samples starting around the the specified UTCdate in the near-chronological order, meaning that data is already sorted by time MOST of the TIME, however sorting is NOT GUARANTEED for all result records returned as enumeration is a lazy procedure that does not make copies/take locks. The enumeration is empty if ResultBufferSize is less or equal to zero entries
Public method | GetDatumTypeSources | Enumerates sources per Datum type ever recorded by the instance. This property may be used to build UIs for instrumentation, i.e. datum type tree. Returned data is NOT ORDERED
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Record | Records instrumentation datum
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_PROVIDER_SECTION |
DEFAULT_MAX_REC_COUNT |
DEFAULT_RESULT_BUFFER_SIZE |
MAX_RESULT_BUFFER_SIZE |
MAXIMUM_MAX_REC_COUNT |
MINIMUM_MAX_REC_COUNT |
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | (Overrides ApplicationComponent ComponentCommonName.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DataTypes | Enumerates distinct types of Datum ever recorded in the instance. This property may be used to build UIs for instrumentation, i.e. datum type tree. Returned data is NOT ORDERED
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Enabled |
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | InstrumentationEnabled | Shortcut to SelfInstrumented, implements IInstrumentable (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | MaxRecordCount | Gets/Sets the maximum record count that this instance can store
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | OSInstrumentationIntervalMS | Specifies how often OS instrumentation such as CPU and RAM is sampled. Value of zero disables OS sampling
Public property | Overflown | Returns true to indicate that instrumentation does not have any space left to record more data
Public property | ProcessingIntervalMS | Specifies how often aggregation is performed
Public property | Provider | References provider that persists instrumentation data
Public property | RecordCount | Returns current record count in the instance
Public property | ResultBufferSize | Returns the size of the ring buffer where result (aggregated) instrumentation records are kept in memory. The maximum buffer capacity is returned, not how many results have been buffered so far. If this property is less than or equal to zero then result buffering in memory is disabled. This property can be set only on a stopped service
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | SelfInstrumented | When true, outputs instrumentation data about the self (how many datum buffers, etc.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
InstrumentationService Class
NFX.Instrumentation Namespace


InstrumentationService Constructor

InstrumentationService Constructor NFX Class Library

Overload List
 | Name | Description
Public method | InstrumentationService | Creates a instrumentation service instance
Public method | InstrumentationService(Object) | Creates a instrumentation service instance
Back to Top
See Also
InstrumentationService Class
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentationService Constructor

InstrumentationService Constructor NFX Class Library

Creates a instrumentation service instance

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InstrumentationService()
public InstrumentationService()
Public Sub New
Public Sub New
public:
InstrumentationService()
public:
InstrumentationService()
new : unit -> InstrumentationService
new : unit -> InstrumentationService
See Also
InstrumentationService Class
InstrumentationService Members
InstrumentationService Overload
NFX.Instrumentation Namespace


InstrumentationService Constructor (Object)

InstrumentationService Constructor (Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates a instrumentation service instance

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InstrumentationService(
    Object director
)
public InstrumentationService(
    Object director
)
Public Sub New (
    director As Object
)
Public Sub New (
    director As Object
)
public:
InstrumentationService(
    Object^ director
)
public:
InstrumentationService(
    Object^ director
)
new :
        director : Object -> InstrumentationService
new :
        director : Object -> InstrumentationService

Parameters

director
Type: Online System Object
See Also
InstrumentationService Class
InstrumentationService Members
InstrumentationService Overload
NFX.Instrumentation Namespace


InstrumentationService Fields

InstrumentationService Fields NFX Class Library

The InstrumentationService type exposes the following members.
Fields
Name | Description
CONFIG_PROVIDER_SECTION |
DEFAULT_MAX_REC_COUNT |
DEFAULT_RESULT_BUFFER_SIZE |
MAX_RESULT_BUFFER_SIZE |
MAXIMUM_MAX_REC_COUNT |
MINIMUM_MAX_REC_COUNT |
Back to Top
See Also
InstrumentationService Class
NFX.Instrumentation Namespace


InstrumentationService.CONFIG_PROVIDER_SECTION Field

InstrumentationService CONFIG_PROVIDER_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PROVIDER_SECTION
public const string CONFIG_PROVIDER_SECTION
Public Const CONFIG_PROVIDER_SECTION As String
Public Const CONFIG_PROVIDER_SECTION As String
public:
literal String^ CONFIG_PROVIDER_SECTION
public:
literal String^ CONFIG_PROVIDER_SECTION
static val mutable CONFIG_PROVIDER_SECTION: string
static val mutable CONFIG_PROVIDER_SECTION: string

Field Value

Type: Online String
See Also
InstrumentationService Class
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentationService.DEFAULT_MAX_REC_COUNT Field

InstrumentationService DEFAULT_MAX_REC_COUNT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_MAX_REC_COUNT
public const int DEFAULT_MAX_REC_COUNT
Public Const DEFAULT_MAX_REC_COUNT As Integer
Public Const DEFAULT_MAX_REC_COUNT As Integer
public:
literal int DEFAULT_MAX_REC_COUNT
public:
literal int DEFAULT_MAX_REC_COUNT
static val mutable DEFAULT_MAX_REC_COUNT: int
static val mutable DEFAULT_MAX_REC_COUNT: int

Field Value

Type: Online Int32
See Also
InstrumentationService Class
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentationService.DEFAULT_RESULT_BUFFER_SIZE Field

InstrumentationService DEFAULT_RESULT_BUFFER_SIZE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_RESULT_BUFFER_SIZE
public const int DEFAULT_RESULT_BUFFER_SIZE
Public Const DEFAULT_RESULT_BUFFER_SIZE As Integer
Public Const DEFAULT_RESULT_BUFFER_SIZE As Integer
public:
literal int DEFAULT_RESULT_BUFFER_SIZE
public:
literal int DEFAULT_RESULT_BUFFER_SIZE
static val mutable DEFAULT_RESULT_BUFFER_SIZE: int
static val mutable DEFAULT_RESULT_BUFFER_SIZE: int

Field Value

Type: Online Int32
See Also
InstrumentationService Class
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentationService.MAX_RESULT_BUFFER_SIZE Field

InstrumentationService MAX_RESULT_BUFFER_SIZE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_RESULT_BUFFER_SIZE
public const int MAX_RESULT_BUFFER_SIZE
Public Const MAX_RESULT_BUFFER_SIZE As Integer
Public Const MAX_RESULT_BUFFER_SIZE As Integer
public:
literal int MAX_RESULT_BUFFER_SIZE
public:
literal int MAX_RESULT_BUFFER_SIZE
static val mutable MAX_RESULT_BUFFER_SIZE: int
static val mutable MAX_RESULT_BUFFER_SIZE: int

Field Value

Type: Online Int32
See Also
InstrumentationService Class
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentationService.MAXIMUM_MAX_REC_COUNT Field

InstrumentationService MAXIMUM_MAX_REC_COUNT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAXIMUM_MAX_REC_COUNT
public const int MAXIMUM_MAX_REC_COUNT
Public Const MAXIMUM_MAX_REC_COUNT As Integer
Public Const MAXIMUM_MAX_REC_COUNT As Integer
public:
literal int MAXIMUM_MAX_REC_COUNT
public:
literal int MAXIMUM_MAX_REC_COUNT
static val mutable MAXIMUM_MAX_REC_COUNT: int
static val mutable MAXIMUM_MAX_REC_COUNT: int

Field Value

Type: Online Int32
See Also
InstrumentationService Class
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentationService.MINIMUM_MAX_REC_COUNT Field

InstrumentationService MINIMUM_MAX_REC_COUNT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MINIMUM_MAX_REC_COUNT
public const int MINIMUM_MAX_REC_COUNT
Public Const MINIMUM_MAX_REC_COUNT As Integer
Public Const MINIMUM_MAX_REC_COUNT As Integer
public:
literal int MINIMUM_MAX_REC_COUNT
public:
literal int MINIMUM_MAX_REC_COUNT
static val mutable MINIMUM_MAX_REC_COUNT: int
static val mutable MINIMUM_MAX_REC_COUNT: int

Field Value

Type: Online Int32
See Also
InstrumentationService Class
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentationService Methods

InstrumentationService Methods NFX Class Library

The InstrumentationService type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetBufferedResults | Returns the specified number of samples from the ring result buffer in the near-chronological order, meaning that data is already sorted by time MOST of the TIME, however sorting is NOT GUARANTEED for all result records returned as enumeration is a lazy procedure that does not make copies/take locks. The enumeration is empty if ResultBufferSize is less or equal to zero entries. If count is less or equal to zero then the system returns all results available.
Public method | GetBufferedResultsSince | Returns samples starting around the the specified UTCdate in the near-chronological order, meaning that data is already sorted by time MOST of the TIME, however sorting is NOT GUARANTEED for all result records returned as enumeration is a lazy procedure that does not make copies/take locks. The enumeration is empty if ResultBufferSize is less or equal to zero entries
Public method | GetDatumTypeSources | Enumerates sources per Datum type ever recorded by the instance. This property may be used to build UIs for instrumentation, i.e. datum type tree. Returned data is NOT ORDERED
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Record | Records instrumentation datum
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
InstrumentationService Class
NFX.Instrumentation Namespace


InstrumentationService.DoConfigure Method

InstrumentationService DoConfigure Method NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
InstrumentationService Class
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentationService.DoSignalStop Method

InstrumentationService DoSignalStop Method NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSignalStop()
protected override void DoSignalStop()
Protected Overrides Sub DoSignalStop
Protected Overrides Sub DoSignalStop
protected:
virtual void DoSignalStop() override
protected:
virtual void DoSignalStop() override
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
See Also
InstrumentationService Class
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentationService.DoStart Method

InstrumentationService DoStart Method NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
InstrumentationService Class
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentationService.DoWaitForCompleteStop Method

InstrumentationService DoWaitForCompleteStop Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
InstrumentationService Class
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentationService.GetBufferedResults Method

InstrumentationService GetBufferedResults Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns the specified number of samples from the ring result buffer in the near-chronological order, meaning that data is already sorted by time MOST of the TIME, however sorting is NOT GUARANTEED for all result records returned as enumeration is a lazy procedure that does not make copies/take locks. The enumeration is empty if ResultBufferSize is less or equal to zero entries. If count is less or equal to zero then the system returns all results available.

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Datum> GetBufferedResults(
    int count = 0
)
public IEnumerable<Datum> GetBufferedResults(
    int count = 0
)
Public Function GetBufferedResults (
    Optional count As Integer = 0
) As IEnumerable(Of Datum)
Public Function GetBufferedResults (
    Optional count As Integer = 0
) As IEnumerable(Of Datum)
public:
virtual IEnumerable<Datum^>^ GetBufferedResults(
    int count = 0
) sealed
public:
virtual IEnumerable<Datum^>^ GetBufferedResults(
    int count = 0
) sealed
abstract GetBufferedResults :
        ?count : int
(* Defaults:
        let _count = defaultArg count 0
*)
-> IEnumerable<Datum>
override GetBufferedResults :
        ?count : int
(* Defaults:
        let _count = defaultArg count 0
*)
-> IEnumerable<Datum>
abstract GetBufferedResults :
        ?count : int
(* Defaults:
        let _count = defaultArg count 0
*)
-> IEnumerable<Datum>
override GetBufferedResults :
        ?count : int
(* Defaults:
        let _count = defaultArg count 0
*)
-> IEnumerable<Datum>

Parameters

count (Optional)
Type: Online System Int32

Return Value

Type: Online IEnumerable Datum

Implements

IInstrumentation GetBufferedResults(Int32)
See Also
InstrumentationService Class
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentationService.GetBufferedResultsSince Method

InstrumentationService GetBufferedResultsSince Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns samples starting around the the specified UTCdate in the near-chronological order, meaning that data is already sorted by time MOST of the TIME, however sorting is NOT GUARANTEED for all result records returned as enumeration is a lazy procedure that does not make copies/take locks. The enumeration is empty if ResultBufferSize is less or equal to zero entries

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Datum> GetBufferedResultsSince(
    DateTime utcStart
)
public IEnumerable<Datum> GetBufferedResultsSince(
    DateTime utcStart
)
Public Function GetBufferedResultsSince (
    utcStart As DateTime
) As IEnumerable(Of Datum)
Public Function GetBufferedResultsSince (
    utcStart As DateTime
) As IEnumerable(Of Datum)
public:
virtual IEnumerable<Datum^>^ GetBufferedResultsSince(
    DateTime utcStart
) sealed
public:
virtual IEnumerable<Datum^>^ GetBufferedResultsSince(
    DateTime utcStart
) sealed
abstract GetBufferedResultsSince :
        utcStart : DateTime -> IEnumerable<Datum>
override GetBufferedResultsSince :
        utcStart : DateTime -> IEnumerable<Datum>
abstract GetBufferedResultsSince :
        utcStart : DateTime -> IEnumerable<Datum>
override GetBufferedResultsSince :
        utcStart : DateTime -> IEnumerable<Datum>

Parameters

utcStart
Type: Online System DateTime

Return Value

Type: Online IEnumerable Datum

Implements

IInstrumentation GetBufferedResultsSince(DateTime)
See Also
InstrumentationService Class
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentationService.GetDatumTypeSources Method

InstrumentationService GetDatumTypeSources Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Enumerates sources per Datum type ever recorded by the instance. This property may be used to build UIs for instrumentation, i.e. datum type tree. Returned data is NOT ORDERED

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<string> GetDatumTypeSources(
    Type datumType,
    out Datum defaultInstance
)
public IEnumerable<string> GetDatumTypeSources(
    Type datumType,
    out Datum defaultInstance
)
Public Function GetDatumTypeSources (
    datumType As Type,
    <OutAttribute> ByRef defaultInstance As Datum
) As IEnumerable(Of String)
Public Function GetDatumTypeSources (
    datumType As Type,
    <OutAttribute> ByRef defaultInstance As Datum
) As IEnumerable(Of String)
public:
virtual IEnumerable<String^>^ GetDatumTypeSources(
    Type^ datumType,
    [OutAttribute] Datum^% defaultInstance
) sealed
public:
virtual IEnumerable<String^>^ GetDatumTypeSources(
    Type^ datumType,
    [OutAttribute] Datum^% defaultInstance
) sealed
abstract GetDatumTypeSources :
        datumType : Type *
        defaultInstance : Datum byref -> IEnumerable<string>
override GetDatumTypeSources :
        datumType : Type *
        defaultInstance : Datum byref -> IEnumerable<string>
abstract GetDatumTypeSources :
        datumType : Type *
        defaultInstance : Datum byref -> IEnumerable<string>
override GetDatumTypeSources :
        datumType : Type *
        defaultInstance : Datum byref -> IEnumerable<string>

Parameters

datumType
Type: Online System Type
defaultInstance
Type: NFX.Instrumentation Datum

Return Value

Type: Online IEnumerable Online String

Implements

IInstrumentation GetDatumTypeSources(Type, Datum )
See Also
InstrumentationService Class
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentationService.Record Method

InstrumentationService Record Method NFX Class Library

Records instrumentation datum

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Record(
    Datum datum
)
public void Record(
    Datum datum
)
Public Sub Record (
    datum As Datum
)
Public Sub Record (
    datum As Datum
)
public:
virtual void Record(
    Datum^ datum
) sealed
public:
virtual void Record(
    Datum^ datum
) sealed
abstract Record :
        datum : Datum -> unit
override Record :
        datum : Datum -> unit
abstract Record :
        datum : Datum -> unit
override Record :
        datum : Datum -> unit

Parameters

datum
Type: NFX.Instrumentation Datum

Implements

IInstrumentation Record(Datum)
See Also
InstrumentationService Class
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentationService Properties

InstrumentationService Properties NFX Class Library

The InstrumentationService type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | (Overrides ApplicationComponent ComponentCommonName.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DataTypes | Enumerates distinct types of Datum ever recorded in the instance. This property may be used to build UIs for instrumentation, i.e. datum type tree. Returned data is NOT ORDERED
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Enabled |
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | InstrumentationEnabled | Shortcut to SelfInstrumented, implements IInstrumentable (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | MaxRecordCount | Gets/Sets the maximum record count that this instance can store
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | OSInstrumentationIntervalMS | Specifies how often OS instrumentation such as CPU and RAM is sampled. Value of zero disables OS sampling
Public property | Overflown | Returns true to indicate that instrumentation does not have any space left to record more data
Public property | ProcessingIntervalMS | Specifies how often aggregation is performed
Public property | Provider | References provider that persists instrumentation data
Public property | RecordCount | Returns current record count in the instance
Public property | ResultBufferSize | Returns the size of the ring buffer where result (aggregated) instrumentation records are kept in memory. The maximum buffer capacity is returned, not how many results have been buffered so far. If this property is less than or equal to zero then result buffering in memory is disabled. This property can be set only on a stopped service
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | SelfInstrumented | When true, outputs instrumentation data about the self (how many datum buffers, etc.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
InstrumentationService Class
NFX.Instrumentation Namespace


InstrumentationService.ComponentCommonName Property

InstrumentationService ComponentCommonName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ComponentCommonName { get; }
public override string ComponentCommonName { get; }
Public Overrides ReadOnly Property ComponentCommonName As String
    Get
Public Overrides ReadOnly Property ComponentCommonName As String
    Get
public:
virtual property String^ ComponentCommonName {
    String^ get () override;
}
public:
virtual property String^ ComponentCommonName {
    String^ get () override;
}
abstract ComponentCommonName : string with get
override ComponentCommonName : string with get
abstract ComponentCommonName : string with get
override ComponentCommonName : string with get

Property Value

Type: Online String

Implements

IApplicationComponent ComponentCommonName
IApplicationComponent ComponentCommonName
See Also
InstrumentationService Class
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentationService.DataTypes Property

InstrumentationService DataTypes Property NFX Class Library

Enumerates distinct types of Datum ever recorded in the instance. This property may be used to build UIs for instrumentation, i.e. datum type tree. Returned data is NOT ORDERED

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Type> DataTypes { get; }
public IEnumerable<Type> DataTypes { get; }
Public ReadOnly Property DataTypes As IEnumerable(Of Type)
    Get
Public ReadOnly Property DataTypes As IEnumerable(Of Type)
    Get
public:
virtual property IEnumerable<Type^>^ DataTypes {
    IEnumerable<Type^>^ get () sealed;
}
public:
virtual property IEnumerable<Type^>^ DataTypes {
    IEnumerable<Type^>^ get () sealed;
}
abstract DataTypes : IEnumerable<Type> with get
override DataTypes : IEnumerable<Type> with get
abstract DataTypes : IEnumerable<Type> with get
override DataTypes : IEnumerable<Type> with get

Property Value

Type: Online IEnumerable Online Type

Implements

IInstrumentation DataTypes
See Also
InstrumentationService Class
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentationService.Enabled Property

InstrumentationService Enabled Property NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Enabled { get; }
public bool Enabled { get; }
Public ReadOnly Property Enabled As Boolean
    Get
Public ReadOnly Property Enabled As Boolean
    Get
public:
virtual property bool Enabled {
    bool get () sealed;
}
public:
virtual property bool Enabled {
    bool get () sealed;
}
abstract Enabled : bool with get
override Enabled : bool with get
abstract Enabled : bool with get
override Enabled : bool with get

Property Value

Type: Online Boolean

Implements

IInstrumentation Enabled
See Also
InstrumentationService Class
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentationService.InstrumentationEnabled Property

InstrumentationService InstrumentationEnabled Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Shortcut to SelfInstrumented, implements IInstrumentable

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute]
public override bool InstrumentationEnabled { get; set; }
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute]
public override bool InstrumentationEnabled { get; set; }
<ConfigAttribute(Default := false)>
<ExternalParameterAttribute>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
<ConfigAttribute(Default := false)>
<ExternalParameterAttribute>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
public:
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
public:
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute>]
abstract InstrumentationEnabled : bool with get, set
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute>]
override InstrumentationEnabled : bool with get, set
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute>]
abstract InstrumentationEnabled : bool with get, set
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute>]
override InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentable InstrumentationEnabled
IInstrumentable InstrumentationEnabled
See Also
InstrumentationService Class
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentationService.MaxRecordCount Property

InstrumentationService MaxRecordCount Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets/Sets the maximum record count that this instance can store

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(null, 1048576)]
[ExternalParameterAttribute]
public int MaxRecordCount { get; set; }
[ConfigAttribute(null, 1048576)]
[ExternalParameterAttribute]
public int MaxRecordCount { get; set; }
<ConfigAttribute(Nothing, 1048576)>
<ExternalParameterAttribute>
Public Property MaxRecordCount As Integer
    Get
    Set
<ConfigAttribute(Nothing, 1048576)>
<ExternalParameterAttribute>
Public Property MaxRecordCount As Integer
    Get
    Set
public:
[ConfigAttribute(nullptr, 1048576)]
[ExternalParameterAttribute]
virtual property int MaxRecordCount {
    int get () sealed;
    void set (int value) sealed;
}
public:
[ConfigAttribute(nullptr, 1048576)]
[ExternalParameterAttribute]
virtual property int MaxRecordCount {
    int get () sealed;
    void set (int value) sealed;
}
[<ConfigAttribute(null, 1048576)>]
[<ExternalParameterAttribute>]
abstract MaxRecordCount : int with get, set
[<ConfigAttribute(null, 1048576)>]
[<ExternalParameterAttribute>]
override MaxRecordCount : int with get, set
[<ConfigAttribute(null, 1048576)>]
[<ExternalParameterAttribute>]
abstract MaxRecordCount : int with get, set
[<ConfigAttribute(null, 1048576)>]
[<ExternalParameterAttribute>]
override MaxRecordCount : int with get, set

Property Value

Type: Online Int32

Implements

IInstrumentation MaxRecordCount
See Also
InstrumentationService Class
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentationService.OSInstrumentationIntervalMS Property

InstrumentationService OSInstrumentationIntervalMS Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Specifies how often OS instrumentation such as CPU and RAM is sampled. Value of zero disables OS sampling

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute]
[ConfigAttribute("$os-interval-ms|$os-instrumentation-interval-ms")]
public int OSInstrumentationIntervalMS { get; set; }
[ExternalParameterAttribute]
[ConfigAttribute("$os-interval-ms|$os-instrumentation-interval-ms")]
public int OSInstrumentationIntervalMS { get; set; }
<ExternalParameterAttribute>
<ConfigAttribute("$os-interval-ms|$os-instrumentation-interval-ms")>
Public Property OSInstrumentationIntervalMS As Integer
    Get
    Set
<ExternalParameterAttribute>
<ConfigAttribute("$os-interval-ms|$os-instrumentation-interval-ms")>
Public Property OSInstrumentationIntervalMS As Integer
    Get
    Set
public:
[ExternalParameterAttribute]
[ConfigAttribute(L"$os-interval-ms|$os-instrumentation-interval-ms")]
virtual property int OSInstrumentationIntervalMS {
    int get () sealed;
    void set (int value) sealed;
}
public:
[ExternalParameterAttribute]
[ConfigAttribute(L"$os-interval-ms|$os-instrumentation-interval-ms")]
virtual property int OSInstrumentationIntervalMS {
    int get () sealed;
    void set (int value) sealed;
}
[<ExternalParameterAttribute>]
[<ConfigAttribute("$os-interval-ms|$os-instrumentation-interval-ms")>]
abstract OSInstrumentationIntervalMS : int with get, set
[<ExternalParameterAttribute>]
[<ConfigAttribute("$os-interval-ms|$os-instrumentation-interval-ms")>]
override OSInstrumentationIntervalMS : int with get, set
[<ExternalParameterAttribute>]
[<ConfigAttribute("$os-interval-ms|$os-instrumentation-interval-ms")>]
abstract OSInstrumentationIntervalMS : int with get, set
[<ExternalParameterAttribute>]
[<ConfigAttribute("$os-interval-ms|$os-instrumentation-interval-ms")>]
override OSInstrumentationIntervalMS : int with get, set

Property Value

Type: Online Int32

Implements

IInstrumentation OSInstrumentationIntervalMS
See Also
InstrumentationService Class
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentationService.Overflown Property

InstrumentationService Overflown Property NFX Class Library

Returns true to indicate that instrumentation does not have any space left to record more data

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Overflown { get; }
public bool Overflown { get; }
Public ReadOnly Property Overflown As Boolean
    Get
Public ReadOnly Property Overflown As Boolean
    Get
public:
virtual property bool Overflown {
    bool get () sealed;
}
public:
virtual property bool Overflown {
    bool get () sealed;
}
abstract Overflown : bool with get
override Overflown : bool with get
abstract Overflown : bool with get
override Overflown : bool with get

Property Value

Type: Online Boolean

Implements

IInstrumentation Overflown
See Also
InstrumentationService Class
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentationService.ProcessingIntervalMS Property

InstrumentationService ProcessingIntervalMS Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Specifies how often aggregation is performed

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute]
[ConfigAttribute("$processing-interval-ms|$interval-ms", 7000)]
public int ProcessingIntervalMS { get; set; }
[ExternalParameterAttribute]
[ConfigAttribute("$processing-interval-ms|$interval-ms", 7000)]
public int ProcessingIntervalMS { get; set; }
<ExternalParameterAttribute>
<ConfigAttribute("$processing-interval-ms|$interval-ms", 7000)>
Public Property ProcessingIntervalMS As Integer
    Get
    Set
<ExternalParameterAttribute>
<ConfigAttribute("$processing-interval-ms|$interval-ms", 7000)>
Public Property ProcessingIntervalMS As Integer
    Get
    Set
public:
[ExternalParameterAttribute]
[ConfigAttribute(L"$processing-interval-ms|$interval-ms", 7000)]
virtual property int ProcessingIntervalMS {
    int get () sealed;
    void set (int value) sealed;
}
public:
[ExternalParameterAttribute]
[ConfigAttribute(L"$processing-interval-ms|$interval-ms", 7000)]
virtual property int ProcessingIntervalMS {
    int get () sealed;
    void set (int value) sealed;
}
[<ExternalParameterAttribute>]
[<ConfigAttribute("$processing-interval-ms|$interval-ms", 7000)>]
abstract ProcessingIntervalMS : int with get, set
[<ExternalParameterAttribute>]
[<ConfigAttribute("$processing-interval-ms|$interval-ms", 7000)>]
override ProcessingIntervalMS : int with get, set
[<ExternalParameterAttribute>]
[<ConfigAttribute("$processing-interval-ms|$interval-ms", 7000)>]
abstract ProcessingIntervalMS : int with get, set
[<ExternalParameterAttribute>]
[<ConfigAttribute("$processing-interval-ms|$interval-ms", 7000)>]
override ProcessingIntervalMS : int with get, set

Property Value

Type: Online Int32

Implements

IInstrumentation ProcessingIntervalMS
See Also
InstrumentationService Class
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentationService.Provider Property

InstrumentationService Provider Property NFX Class Library

References provider that persists instrumentation data

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InstrumentationProvider Provider { get; set; }
public InstrumentationProvider Provider { get; set; }
Public Property Provider As InstrumentationProvider
    Get
    Set
Public Property Provider As InstrumentationProvider
    Get
    Set
public:
property InstrumentationProvider^ Provider {
    InstrumentationProvider^ get ();
    void set (InstrumentationProvider^ value);
}
public:
property InstrumentationProvider^ Provider {
    InstrumentationProvider^ get ();
    void set (InstrumentationProvider^ value);
}
member Provider : InstrumentationProvider with get, set
member Provider : InstrumentationProvider with get, set

Property Value

Type: InstrumentationProvider
See Also
InstrumentationService Class
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentationService.RecordCount Property

InstrumentationService RecordCount Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns current record count in the instance

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int RecordCount { get; }
public int RecordCount { get; }
Public ReadOnly Property RecordCount As Integer
    Get
Public ReadOnly Property RecordCount As Integer
    Get
public:
virtual property int RecordCount {
    int get () sealed;
}
public:
virtual property int RecordCount {
    int get () sealed;
}
abstract RecordCount : int with get
override RecordCount : int with get
abstract RecordCount : int with get
override RecordCount : int with get

Property Value

Type: Online Int32

Implements

IInstrumentation RecordCount
See Also
InstrumentationService Class
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentationService.ResultBufferSize Property

InstrumentationService ResultBufferSize Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns the size of the ring buffer where result (aggregated) instrumentation records are kept in memory. The maximum buffer capacity is returned, not how many results have been buffered so far. If this property is less than or equal to zero then result buffering in memory is disabled. This property can be set only on a stopped service

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(null, 131072)]
public int ResultBufferSize { get; set; }
[ConfigAttribute(null, 131072)]
public int ResultBufferSize { get; set; }
<ConfigAttribute(Nothing, 131072)>
Public Property ResultBufferSize As Integer
    Get
    Set
<ConfigAttribute(Nothing, 131072)>
Public Property ResultBufferSize As Integer
    Get
    Set
public:
[ConfigAttribute(nullptr, 131072)]
virtual property int ResultBufferSize {
    int get () sealed;
    void set (int value) sealed;
}
public:
[ConfigAttribute(nullptr, 131072)]
virtual property int ResultBufferSize {
    int get () sealed;
    void set (int value) sealed;
}
[<ConfigAttribute(null, 131072)>]
abstract ResultBufferSize : int with get, set
[<ConfigAttribute(null, 131072)>]
override ResultBufferSize : int with get, set
[<ConfigAttribute(null, 131072)>]
abstract ResultBufferSize : int with get, set
[<ConfigAttribute(null, 131072)>]
override ResultBufferSize : int with get, set

Property Value

Type: Online Int32

Implements

IInstrumentation ResultBufferSize
See Also
InstrumentationService Class
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentationService.SelfInstrumented Property

InstrumentationService SelfInstrumented Property NFX Class Library

[This is preliminary documentation and is subject to change.]

When true, outputs instrumentation data about the self (how many datum buffers, etc.)

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$self-instrumented|$instrument-self|$instrumented",
    false)]
public bool SelfInstrumented { get; set; }
[ConfigAttribute("$self-instrumented|$instrument-self|$instrumented",
    false)]
public bool SelfInstrumented { get; set; }
<ConfigAttribute("$self-instrumented|$instrument-self|$instrumented",
    false)>
Public Property SelfInstrumented As Boolean
    Get
    Set
<ConfigAttribute("$self-instrumented|$instrument-self|$instrumented",
    false)>
Public Property SelfInstrumented As Boolean
    Get
    Set
public:
[ConfigAttribute(L"$self-instrumented|$instrument-self|$instrumented",
    false)]
virtual property bool SelfInstrumented {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
[ConfigAttribute(L"$self-instrumented|$instrument-self|$instrumented",
    false)]
virtual property bool SelfInstrumented {
    bool get () sealed;
    void set (bool value) sealed;
}
[<ConfigAttribute("$self-instrumented|$instrument-self|$instrumented",
    false)>]
abstract SelfInstrumented : bool with get, set
[<ConfigAttribute("$self-instrumented|$instrument-self|$instrumented",
    false)>]
override SelfInstrumented : bool with get, set
[<ConfigAttribute("$self-instrumented|$instrument-self|$instrumented",
    false)>]
abstract SelfInstrumented : bool with get, set
[<ConfigAttribute("$self-instrumented|$instrument-self|$instrumented",
    false)>]
override SelfInstrumented : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentation SelfInstrumented
See Also
InstrumentationService Class
InstrumentationService Members
NFX.Instrumentation Namespace


InstrumentViewGroup Class

InstrumentViewGroup Class NFX Class Library

Denotes interface types that participate in instrumentation data grouping. Records that implement several classification interfaces which are decorated by this attribute get listed in each decorated interface/group
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.Instrumentation InstrumentViewGroup

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.Interface, AllowMultiple = false,
    Inherited = false)]
public sealed class InstrumentViewGroup : Attribute
[AttributeUsageAttribute(AttributeTargets.Interface, AllowMultiple = false,
    Inherited = false)]
public sealed class InstrumentViewGroup : Attribute
<AttributeUsageAttribute(AttributeTargets.Interface, AllowMultiple := false,
    Inherited := false)>
Public NotInheritable Class InstrumentViewGroup
    Inherits Attribute
<AttributeUsageAttribute(AttributeTargets.Interface, AllowMultiple := false,
    Inherited := false)>
Public NotInheritable Class InstrumentViewGroup
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Interface, AllowMultiple = false,
    Inherited = false)]
public ref class InstrumentViewGroup sealed : public Attribute
[AttributeUsageAttribute(AttributeTargets::Interface, AllowMultiple = false,
    Inherited = false)]
public ref class InstrumentViewGroup sealed : public Attribute
[<SealedAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Interface, AllowMultiple = false,
    Inherited = false)>]
type InstrumentViewGroup =
    class
        inherit Attribute
    end
[<SealedAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Interface, AllowMultiple = false,
    Inherited = false)>]
type InstrumentViewGroup =
    class
        inherit Attribute
    end
See Also
InstrumentViewGroup Members
NFX.Instrumentation Namespace


InstrumentViewGroup Members

InstrumentViewGroup Members NFX Class Library

The InstrumentViewGroup type exposes the following members.
Constructors
 | Name | Description
Public method | InstrumentViewGroup | Initializes a new instance of the InstrumentViewGroup class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
InstrumentViewGroup Class
NFX.Instrumentation Namespace


InstrumentViewGroup Constructor

InstrumentViewGroup Constructor NFX Class Library

Initializes a new instance of the InstrumentViewGroup class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InstrumentViewGroup()
public InstrumentViewGroup()
Public Sub New
Public Sub New
public:
InstrumentViewGroup()
public:
InstrumentViewGroup()
new : unit -> InstrumentViewGroup
new : unit -> InstrumentViewGroup
See Also
InstrumentViewGroup Class
InstrumentViewGroup Members
NFX.Instrumentation Namespace


InstrumentViewGroup Methods

InstrumentViewGroup Methods NFX Class Library

The InstrumentViewGroup type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
InstrumentViewGroup Class
NFX.Instrumentation Namespace


InstrumentViewGroup Properties

InstrumentViewGroup Properties NFX Class Library

The InstrumentViewGroup type exposes the following members.
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
InstrumentViewGroup Class
NFX.Instrumentation Namespace


IOperationClass Interface

IOperationClass Interface NFX Class Library

A class of operations that instrument measures

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IOperationClass : IInstrumentClass
public interface IOperationClass : IInstrumentClass
Public Interface IOperationClass
    Inherits IInstrumentClass
Public Interface IOperationClass
    Inherits IInstrumentClass
public interface class IOperationClass : IInstrumentClass
public interface class IOperationClass : IInstrumentClass
type IOperationClass =
    interface
        interface IInstrumentClass
    end
type IOperationClass =
    interface
        interface IInstrumentClass
    end
See Also
NFX.Instrumentation Namespace


IProblemClass Interface

IProblemClass Interface NFX Class Library

A class of problem that decorate instrument represents

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IProblemClass : IInstrumentClass
public interface IProblemClass : IInstrumentClass
Public Interface IProblemClass
    Inherits IInstrumentClass
Public Interface IProblemClass
    Inherits IInstrumentClass
public interface class IProblemClass : IInstrumentClass
public interface class IProblemClass : IInstrumentClass
type IProblemClass =
    interface
        interface IInstrumentClass
    end
type IProblemClass =
    interface
        interface IInstrumentClass
    end
See Also
NFX.Instrumentation Namespace


IQueueInstrument Interface

IQueueInstrument Interface NFX Class Library

Queue-related operations

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[InstrumentViewGroup]
public interface IQueueInstrument : IOperationClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface IQueueInstrument : IOperationClass,
    IInstrumentClass
<InstrumentViewGroup>
Public Interface IQueueInstrument
    Inherits IOperationClass, IInstrumentClass
<InstrumentViewGroup>
Public Interface IQueueInstrument
    Inherits IOperationClass, IInstrumentClass
[InstrumentViewGroup]
public interface class IQueueInstrument : IOperationClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface class IQueueInstrument : IOperationClass,
    IInstrumentClass
[<InstrumentViewGroup>]
type IQueueInstrument =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
[<InstrumentViewGroup>]
type IQueueInstrument =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
NFX.Instrumentation Namespace


ISchedulingInstrument Interface

ISchedulingInstrument Interface NFX Class Library

Timer/scheduling-related operations

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[InstrumentViewGroup]
public interface ISchedulingInstrument : IOperationClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface ISchedulingInstrument : IOperationClass,
    IInstrumentClass
<InstrumentViewGroup>
Public Interface ISchedulingInstrument
    Inherits IOperationClass, IInstrumentClass
<InstrumentViewGroup>
Public Interface ISchedulingInstrument
    Inherits IOperationClass, IInstrumentClass
[InstrumentViewGroup]
public interface class ISchedulingInstrument : IOperationClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface class ISchedulingInstrument : IOperationClass,
    IInstrumentClass
[<InstrumentViewGroup>]
type ISchedulingInstrument =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
[<InstrumentViewGroup>]
type ISchedulingInstrument =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
NFX.Instrumentation Namespace


ISecurityInstrument Interface

ISecurityInstrument Interface NFX Class Library

Security-related operations

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[InstrumentViewGroup]
public interface ISecurityInstrument : IOperationClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface ISecurityInstrument : IOperationClass,
    IInstrumentClass
<InstrumentViewGroup>
Public Interface ISecurityInstrument
    Inherits IOperationClass, IInstrumentClass
<InstrumentViewGroup>
Public Interface ISecurityInstrument
    Inherits IOperationClass, IInstrumentClass
[InstrumentViewGroup]
public interface class ISecurityInstrument : IOperationClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface class ISecurityInstrument : IOperationClass,
    IInstrumentClass
[<InstrumentViewGroup>]
type ISecurityInstrument =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
[<InstrumentViewGroup>]
type ISecurityInstrument =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
NFX.Instrumentation Namespace


ISocialLogic Interface

ISocialLogic Interface NFX Class Library

A class of operations related to social operations / business logic

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[InstrumentViewGroup]
public interface ISocialLogic : IBusinessLogic,
    IOperationClass, IInstrumentClass
[InstrumentViewGroup]
public interface ISocialLogic : IBusinessLogic,
    IOperationClass, IInstrumentClass
<InstrumentViewGroup>
Public Interface ISocialLogic
    Inherits IBusinessLogic, IOperationClass, IInstrumentClass
<InstrumentViewGroup>
Public Interface ISocialLogic
    Inherits IBusinessLogic, IOperationClass, IInstrumentClass
[InstrumentViewGroup]
public interface class ISocialLogic : IBusinessLogic,
    IOperationClass, IInstrumentClass
[InstrumentViewGroup]
public interface class ISocialLogic : IBusinessLogic,
    IOperationClass, IInstrumentClass
[<InstrumentViewGroup>]
type ISocialLogic =
    interface
        interface IBusinessLogic
        interface IOperationClass
        interface IInstrumentClass
    end
[<InstrumentViewGroup>]
type ISocialLogic =
    interface
        interface IBusinessLogic
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
NFX.Instrumentation Namespace


IWarningInstrument Interface

IWarningInstrument Interface NFX Class Library

Data of this class indicates some abnormality in operation, i.e. "LowDisk"

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[InstrumentViewGroup]
public interface IWarningInstrument : IProblemClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface IWarningInstrument : IProblemClass,
    IInstrumentClass
<InstrumentViewGroup>
Public Interface IWarningInstrument
    Inherits IProblemClass, IInstrumentClass
<InstrumentViewGroup>
Public Interface IWarningInstrument
    Inherits IProblemClass, IInstrumentClass
[InstrumentViewGroup]
public interface class IWarningInstrument : IProblemClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface class IWarningInstrument : IProblemClass,
    IInstrumentClass
[<InstrumentViewGroup>]
type IWarningInstrument =
    interface
        interface IProblemClass
        interface IInstrumentClass
    end
[<InstrumentViewGroup>]
type IWarningInstrument =
    interface
        interface IProblemClass
        interface IInstrumentClass
    end
See Also
NFX.Instrumentation Namespace


IWebInstrument Interface

IWebInstrument Interface NFX Class Library

Web-related operations

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[InstrumentViewGroup]
public interface IWebInstrument : IOperationClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface IWebInstrument : IOperationClass,
    IInstrumentClass
<InstrumentViewGroup>
Public Interface IWebInstrument
    Inherits IOperationClass, IInstrumentClass
<InstrumentViewGroup>
Public Interface IWebInstrument
    Inherits IOperationClass, IInstrumentClass
[InstrumentViewGroup]
public interface class IWebInstrument : IOperationClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface class IWebInstrument : IOperationClass,
    IInstrumentClass
[<InstrumentViewGroup>]
type IWebInstrument =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
[<InstrumentViewGroup>]
type IWebInstrument =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
NFX.Instrumentation Namespace


IWorkerInstrument Interface

IWorkerInstrument Interface NFX Class Library

Worker-related operations i.e. Todo queue

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[InstrumentViewGroup]
public interface IWorkerInstrument : IOperationClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface IWorkerInstrument : IOperationClass,
    IInstrumentClass
<InstrumentViewGroup>
Public Interface IWorkerInstrument
    Inherits IOperationClass, IInstrumentClass
<InstrumentViewGroup>
Public Interface IWorkerInstrument
    Inherits IOperationClass, IInstrumentClass
[InstrumentViewGroup]
public interface class IWorkerInstrument : IOperationClass,
    IInstrumentClass
[InstrumentViewGroup]
public interface class IWorkerInstrument : IOperationClass,
    IInstrumentClass
[<InstrumentViewGroup>]
type IWorkerInstrument =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
[<InstrumentViewGroup>]
type IWorkerInstrument =
    interface
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
NFX.Instrumentation Namespace


LogInstrumentationProvider Class

LogInstrumentationProvider Class NFX Class Library

Represents a provider that writes aggregated datums to log
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service InstrumentationService
NFX.Instrumentation InstrumentationProvider
NFX.Instrumentation LogInstrumentationProvider
NFX.Instrumentation.Telemetry TelemetryInstrumentationProvider

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LogInstrumentationProvider : InstrumentationProvider
public class LogInstrumentationProvider : InstrumentationProvider
Public Class LogInstrumentationProvider
    Inherits InstrumentationProvider
Public Class LogInstrumentationProvider
    Inherits InstrumentationProvider
public ref class LogInstrumentationProvider : public InstrumentationProvider
public ref class LogInstrumentationProvider : public InstrumentationProvider
type LogInstrumentationProvider =
    class
        inherit InstrumentationProvider
    end
type LogInstrumentationProvider =
    class
        inherit InstrumentationProvider
    end
See Also
LogInstrumentationProvider Members
NFX.Instrumentation Namespace


LogInstrumentationProvider Members

LogInstrumentationProvider Members NFX Class Library

The LogInstrumentationProvider type exposes the following members.
Constructors
 | Name | Description
Public method | LogInstrumentationProvider | Initializes a new instance of the LogInstrumentationProvider class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Inherited from InstrumentationProvider.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from InstrumentationProvider.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from InstrumentationProvider.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from InstrumentationProvider.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | Write | (Overrides InstrumentationProvider Write(Datum).)
Protected method | WriteLog | (Inherited from InstrumentationProvider.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from InstrumentationProvider.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
LogInstrumentationProvider Class
NFX.Instrumentation Namespace


LogInstrumentationProvider Constructor

LogInstrumentationProvider Constructor NFX Class Library

Initializes a new instance of the LogInstrumentationProvider class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LogInstrumentationProvider()
public LogInstrumentationProvider()
Public Sub New
Public Sub New
public:
LogInstrumentationProvider()
public:
LogInstrumentationProvider()
new : unit -> LogInstrumentationProvider
new : unit -> LogInstrumentationProvider
See Also
LogInstrumentationProvider Class
LogInstrumentationProvider Members
NFX.Instrumentation Namespace


LogInstrumentationProvider Methods

LogInstrumentationProvider Methods NFX Class Library

The LogInstrumentationProvider type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Inherited from InstrumentationProvider.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from InstrumentationProvider.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from InstrumentationProvider.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from InstrumentationProvider.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | Write | (Overrides InstrumentationProvider Write(Datum).)
Protected method | WriteLog | (Inherited from InstrumentationProvider.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LogInstrumentationProvider Class
NFX.Instrumentation Namespace


LogInstrumentationProvider.Write Method

LogInstrumentationProvider Write Method NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Datum aggregatedDatum
)
public override void Write(
    Datum aggregatedDatum
)
Public Overrides Sub Write (
    aggregatedDatum As Datum
)
Public Overrides Sub Write (
    aggregatedDatum As Datum
)
public:
virtual void Write(
    Datum^ aggregatedDatum
) override
public:
virtual void Write(
    Datum^ aggregatedDatum
) override
abstract Write :
        aggregatedDatum : Datum -> unit
override Write :
        aggregatedDatum : Datum -> unit
abstract Write :
        aggregatedDatum : Datum -> unit
override Write :
        aggregatedDatum : Datum -> unit

Parameters

aggregatedDatum
Type: NFX.Instrumentation Datum
See Also
LogInstrumentationProvider Class
LogInstrumentationProvider Members
NFX.Instrumentation Namespace


LogInstrumentationProvider Properties

LogInstrumentationProvider Properties NFX Class Library

The LogInstrumentationProvider type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from InstrumentationProvider.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
LogInstrumentationProvider Class
NFX.Instrumentation Namespace


LongGauge Class

LongGauge Class NFX Class Library

Represents a general-purpose long integer measurement datum
Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.ApplicationModel.Pile.Instrumentation PileLongGauge
NFX.DataAccess.Cache.Instrumentation CacheLongGauge
NFX.Glue.Instrumentation GlueLongGauge
NFX.Instrumentation.Self SelfInstrumentationLongGauge
NFX.Log.Instrumentation LogLongGauge
NFX.OS.Instrumentation OSLongGauge
NFX.Time.Instrumentation TimeInstrumentationLongGauge
NFX.Wave.Instrumentation WaveLongGauge
NFX.Web.Messaging.Instrumentation MessagingSinkLongGauge
NFX.Web.Pay.Instrumentation PayLongGauge
NFX.Web.Shipping.Instrumentation ShippingLongGauge
NFX.Web.Social.Instrumentation SocialInstrumentationLongGauge

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class LongGauge : Gauge
[SerializableAttribute]
public abstract class LongGauge : Gauge
<SerializableAttribute>
Public MustInherit Class LongGauge
    Inherits Gauge
<SerializableAttribute>
Public MustInherit Class LongGauge
    Inherits Gauge
[SerializableAttribute]
public ref class LongGauge abstract : public Gauge
[SerializableAttribute]
public ref class LongGauge abstract : public Gauge
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type LongGauge =
    class
        inherit Gauge
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type LongGauge =
    class
        inherit Gauge
    end
See Also
LongGauge Members
NFX.Instrumentation Namespace


LongGauge Members

LongGauge Members NFX Class Library

The LongGauge type exposes the following members.
Constructors
 | Name | Description
Protected method | LongGauge(Int64) | Initializes a new instance of the LongGauge class
Protected method | LongGauge(String, Int64) | Initializes a new instance of the LongGauge class
Protected method | LongGauge(String, Int64, DateTime) | Initializes a new instance of the LongGauge class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Overrides Datum AggregateEvent(Datum).)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Overrides Datum SummarizeAggregation .)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value
Public property | ValueAsObject | (Overrides Datum ValueAsObject.)
Public property | ValueUnitName | (Overrides Datum ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
LongGauge Class
NFX.Instrumentation Namespace


LongGauge Constructor

LongGauge Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | LongGauge(Int64) | Initializes a new instance of the LongGauge class
Protected method | LongGauge(String, Int64) | Initializes a new instance of the LongGauge class
Protected method | LongGauge(String, Int64, DateTime) | Initializes a new instance of the LongGauge class
Back to Top
See Also
LongGauge Class
LongGauge Members
NFX.Instrumentation Namespace


LongGauge Constructor (Int64)

LongGauge Constructor (Int64) NFX Class Library

Initializes a new instance of the LongGauge class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected LongGauge(
    long value
)
protected LongGauge(
    long value
)
Protected Sub New (
    value As Long
)
Protected Sub New (
    value As Long
)
protected:
LongGauge(
    long long value
)
protected:
LongGauge(
    long long value
)
new :
        value : int64 -> LongGauge
new :
        value : int64 -> LongGauge

Parameters

value
Type: Online System Int64
See Also
LongGauge Class
LongGauge Members
LongGauge Overload
NFX.Instrumentation Namespace


LongGauge Constructor (String, Int64)

LongGauge Constructor (String, Int64) NFX Class Library

Initializes a new instance of the LongGauge class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected LongGauge(
    string source,
    long value
)
protected LongGauge(
    string source,
    long value
)
Protected Sub New (
    source As String,
    value As Long
)
Protected Sub New (
    source As String,
    value As Long
)
protected:
LongGauge(
    String^ source,
    long long value
)
protected:
LongGauge(
    String^ source,
    long long value
)
new :
        source : string *
        value : int64 -> LongGauge
new :
        source : string *
        value : int64 -> LongGauge

Parameters

source
Type: Online System String
value
Type: Online System Int64
See Also
LongGauge Class
LongGauge Members
LongGauge Overload
NFX.Instrumentation Namespace


LongGauge Constructor (String, Int64, DateTime)

LongGauge Constructor (String, Int64, DateTime) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LongGauge class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected LongGauge(
    string source,
    long value,
    DateTime utcDateTime
)
protected LongGauge(
    string source,
    long value,
    DateTime utcDateTime
)
Protected Sub New (
    source As String,
    value As Long,
    utcDateTime As DateTime
)
Protected Sub New (
    source As String,
    value As Long,
    utcDateTime As DateTime
)
protected:
LongGauge(
    String^ source,
    long long value,
    DateTime utcDateTime
)
protected:
LongGauge(
    String^ source,
    long long value,
    DateTime utcDateTime
)
new :
        source : string *
        value : int64 *
        utcDateTime : DateTime -> LongGauge
new :
        source : string *
        value : int64 *
        utcDateTime : DateTime -> LongGauge

Parameters

source
Type: Online System String
value
Type: Online System Int64
utcDateTime
Type: Online System DateTime
See Also
LongGauge Class
LongGauge Members
LongGauge Overload
NFX.Instrumentation Namespace


LongGauge Fields

LongGauge Fields NFX Class Library

The LongGauge type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
LongGauge Class
NFX.Instrumentation Namespace


LongGauge Methods

LongGauge Methods NFX Class Library

The LongGauge type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Overrides Datum AggregateEvent(Datum).)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Overrides Datum SummarizeAggregation .)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LongGauge Class
NFX.Instrumentation Namespace


LongGauge.AggregateEvent Method

LongGauge AggregateEvent Method NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void AggregateEvent(
    Datum dat
)
protected override void AggregateEvent(
    Datum dat
)
Protected Overrides Sub AggregateEvent (
    dat As Datum
)
Protected Overrides Sub AggregateEvent (
    dat As Datum
)
protected:
virtual void AggregateEvent(
    Datum^ dat
) override
protected:
virtual void AggregateEvent(
    Datum^ dat
) override
abstract AggregateEvent :
        dat : Datum -> unit
override AggregateEvent :
        dat : Datum -> unit
abstract AggregateEvent :
        dat : Datum -> unit
override AggregateEvent :
        dat : Datum -> unit

Parameters

dat
Type: NFX.Instrumentation Datum
See Also
LongGauge Class
LongGauge Members
NFX.Instrumentation Namespace


LongGauge.SummarizeAggregation Method

LongGauge SummarizeAggregation Method NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void SummarizeAggregation()
protected override void SummarizeAggregation()
Protected Overrides Sub SummarizeAggregation
Protected Overrides Sub SummarizeAggregation
protected:
virtual void SummarizeAggregation() override
protected:
virtual void SummarizeAggregation() override
abstract SummarizeAggregation : unit -> unit
override SummarizeAggregation : unit -> unit
abstract SummarizeAggregation : unit -> unit
override SummarizeAggregation : unit -> unit
See Also
LongGauge Class
LongGauge Members
NFX.Instrumentation Namespace


LongGauge Properties

LongGauge Properties NFX Class Library

The LongGauge type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value
Public property | ValueAsObject | (Overrides Datum ValueAsObject.)
Public property | ValueUnitName | (Overrides Datum ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
LongGauge Class
NFX.Instrumentation Namespace


LongGauge.Value Property

LongGauge Value Property NFX Class Library

Gets gauge value

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long Value { get; }
public long Value { get; }
Public ReadOnly Property Value As Long
    Get
Public ReadOnly Property Value As Long
    Get
public:
property long long Value {
    long long get ();
}
public:
property long long Value {
    long long get ();
}
member Value : int64 with get
member Value : int64 with get

Property Value

Type: Online Int64
See Also
LongGauge Class
LongGauge Members
NFX.Instrumentation Namespace


LongGauge.ValueAsObject Property

LongGauge ValueAsObject Property NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object ValueAsObject { get; }
public override Object ValueAsObject { get; }
Public Overrides ReadOnly Property ValueAsObject As Object
    Get
Public Overrides ReadOnly Property ValueAsObject As Object
    Get
public:
virtual property Object^ ValueAsObject {
    Object^ get () override;
}
public:
virtual property Object^ ValueAsObject {
    Object^ get () override;
}
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get
abstract ValueAsObject : Object with get
override ValueAsObject : Object with get

Property Value

Type: Online Object
See Also
LongGauge Class
LongGauge Members
NFX.Instrumentation Namespace


LongGauge.ValueUnitName Property

LongGauge ValueUnitName Property NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
LongGauge Class
LongGauge Members
NFX.Instrumentation Namespace


NOPInstrumentation Class

NOPInstrumentation Class NFX Class Library

Provides IInstrumentation implementation that does nothing
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Instrumentation NOPInstrumentation

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class NOPInstrumentation : ApplicationComponent,
    IInstrumentationImplementation, IInstrumentation, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
public sealed class NOPInstrumentation : ApplicationComponent,
    IInstrumentationImplementation, IInstrumentation, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
Public NotInheritable Class NOPInstrumentation
    Inherits ApplicationComponent
    Implements IInstrumentationImplementation, IInstrumentation, IApplicationComponent, ILocalizedTimeProvider,
    IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
Public NotInheritable Class NOPInstrumentation
    Inherits ApplicationComponent
    Implements IInstrumentationImplementation, IInstrumentation, IApplicationComponent, ILocalizedTimeProvider,
    IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
public ref class NOPInstrumentation sealed : public ApplicationComponent,
    IInstrumentationImplementation, IInstrumentation, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
public ref class NOPInstrumentation sealed : public ApplicationComponent,
    IInstrumentationImplementation, IInstrumentation, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
[<SealedAttribute>]
type NOPInstrumentation =
    class
        inherit ApplicationComponent
        interface IInstrumentationImplementation
        interface IInstrumentation
        interface IApplicationComponent
        interface ILocalizedTimeProvider
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
[<SealedAttribute>]
type NOPInstrumentation =
    class
        inherit ApplicationComponent
        interface IInstrumentationImplementation
        interface IInstrumentation
        interface IApplicationComponent
        interface ILocalizedTimeProvider
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
NOPInstrumentation Members
NFX.Instrumentation Namespace


NOPInstrumentation Members

NOPInstrumentation Members NFX Class Library

The NOPInstrumentation type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | Configure |
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter |
Public method | ExternalParametersForGroups |
Public method | ExternalSetParameter |
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetBufferedResults |
Public method | GetBufferedResultsSince |
Public method | GetDatumTypeSources |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Record |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DataTypes |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Enabled |
Public property | ExternalParameters |
 | Instance | Returns a singlelton instance of the NOPInstrumentation
Public property | InstrumentationEnabled |
Public property | LocalizedTime |
Public property | MaxRecordCount |
Public property | OSInstrumentationIntervalMS |
Public property | Overflown |
Public property | ProcessingIntervalMS |
Public property | RecordCount |
Public property | ResultBufferSize |
Public property | SelfInstrumented |
Public property | TimeLocation |
Back to Top
See Also
NOPInstrumentation Class
NFX.Instrumentation Namespace


NOPInstrumentation Methods

NOPInstrumentation Methods NFX Class Library

The NOPInstrumentation type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | Configure |
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter |
Public method | ExternalParametersForGroups |
Public method | ExternalSetParameter |
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetBufferedResults |
Public method | GetBufferedResultsSince |
Public method | GetDatumTypeSources |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Record |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NOPInstrumentation Class
NFX.Instrumentation Namespace


NOPInstrumentation.Configure Method

NOPInstrumentation Configure Method NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode node
)
public void Configure(
    IConfigSectionNode node
)
Public Sub Configure (
    node As IConfigSectionNode
)
Public Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
NOPInstrumentation Class
NOPInstrumentation Members
NFX.Instrumentation Namespace


NOPInstrumentation.ExternalGetParameter Method

NOPInstrumentation ExternalGetParameter Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
public bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
Public Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
Public Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
) sealed
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
) sealed
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalGetParameter(String, Object , String )
See Also
NOPInstrumentation Class
NOPInstrumentation Members
NFX.Instrumentation Namespace


NOPInstrumentation.ExternalParametersForGroups Method

NOPInstrumentation ExternalParametersForGroups Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
public IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
Public Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
Public Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
) sealed
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
) sealed
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>

Parameters

groups
Type: Online System String

Return Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParametersForGroups( String )
See Also
NOPInstrumentation Class
NOPInstrumentation Members
NFX.Instrumentation Namespace


NOPInstrumentation.ExternalSetParameter Method

NOPInstrumentation ExternalSetParameter Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
public bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
Public Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
Public Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
) sealed
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
) sealed
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalSetParameter(String, Object, String )
See Also
NOPInstrumentation Class
NOPInstrumentation Members
NFX.Instrumentation Namespace


NOPInstrumentation.GetBufferedResults Method

NOPInstrumentation GetBufferedResults Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Datum> GetBufferedResults(
    int count = 0
)
public IEnumerable<Datum> GetBufferedResults(
    int count = 0
)
Public Function GetBufferedResults (
    Optional count As Integer = 0
) As IEnumerable(Of Datum)
Public Function GetBufferedResults (
    Optional count As Integer = 0
) As IEnumerable(Of Datum)
public:
virtual IEnumerable<Datum^>^ GetBufferedResults(
    int count = 0
) sealed
public:
virtual IEnumerable<Datum^>^ GetBufferedResults(
    int count = 0
) sealed
abstract GetBufferedResults :
        ?count : int
(* Defaults:
        let _count = defaultArg count 0
*)
-> IEnumerable<Datum>
override GetBufferedResults :
        ?count : int
(* Defaults:
        let _count = defaultArg count 0
*)
-> IEnumerable<Datum>
abstract GetBufferedResults :
        ?count : int
(* Defaults:
        let _count = defaultArg count 0
*)
-> IEnumerable<Datum>
override GetBufferedResults :
        ?count : int
(* Defaults:
        let _count = defaultArg count 0
*)
-> IEnumerable<Datum>

Parameters

count (Optional)
Type: Online System Int32

Return Value

Type: Online IEnumerable Datum

Implements

IInstrumentation GetBufferedResults(Int32)
See Also
NOPInstrumentation Class
NOPInstrumentation Members
NFX.Instrumentation Namespace


NOPInstrumentation.GetBufferedResultsSince Method

NOPInstrumentation GetBufferedResultsSince Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Datum> GetBufferedResultsSince(
    DateTime utcDate
)
public IEnumerable<Datum> GetBufferedResultsSince(
    DateTime utcDate
)
Public Function GetBufferedResultsSince (
    utcDate As DateTime
) As IEnumerable(Of Datum)
Public Function GetBufferedResultsSince (
    utcDate As DateTime
) As IEnumerable(Of Datum)
public:
virtual IEnumerable<Datum^>^ GetBufferedResultsSince(
    DateTime utcDate
) sealed
public:
virtual IEnumerable<Datum^>^ GetBufferedResultsSince(
    DateTime utcDate
) sealed
abstract GetBufferedResultsSince :
        utcDate : DateTime -> IEnumerable<Datum>
override GetBufferedResultsSince :
        utcDate : DateTime -> IEnumerable<Datum>
abstract GetBufferedResultsSince :
        utcDate : DateTime -> IEnumerable<Datum>
override GetBufferedResultsSince :
        utcDate : DateTime -> IEnumerable<Datum>

Parameters

utcDate
Type: Online System DateTime

Return Value

Type: Online IEnumerable Datum

Implements

IInstrumentation GetBufferedResultsSince(DateTime)
See Also
NOPInstrumentation Class
NOPInstrumentation Members
NFX.Instrumentation Namespace


NOPInstrumentation.GetDatumTypeSources Method

NOPInstrumentation GetDatumTypeSources Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<string> GetDatumTypeSources(
    Type datumType,
    out Datum defaultInstance
)
public IEnumerable<string> GetDatumTypeSources(
    Type datumType,
    out Datum defaultInstance
)
Public Function GetDatumTypeSources (
    datumType As Type,
    <OutAttribute> ByRef defaultInstance As Datum
) As IEnumerable(Of String)
Public Function GetDatumTypeSources (
    datumType As Type,
    <OutAttribute> ByRef defaultInstance As Datum
) As IEnumerable(Of String)
public:
virtual IEnumerable<String^>^ GetDatumTypeSources(
    Type^ datumType,
    [OutAttribute] Datum^% defaultInstance
) sealed
public:
virtual IEnumerable<String^>^ GetDatumTypeSources(
    Type^ datumType,
    [OutAttribute] Datum^% defaultInstance
) sealed
abstract GetDatumTypeSources :
        datumType : Type *
        defaultInstance : Datum byref -> IEnumerable<string>
override GetDatumTypeSources :
        datumType : Type *
        defaultInstance : Datum byref -> IEnumerable<string>
abstract GetDatumTypeSources :
        datumType : Type *
        defaultInstance : Datum byref -> IEnumerable<string>
override GetDatumTypeSources :
        datumType : Type *
        defaultInstance : Datum byref -> IEnumerable<string>

Parameters

datumType
Type: Online System Type
defaultInstance
Type: NFX.Instrumentation Datum

Return Value

Type: Online IEnumerable Online String

Implements

IInstrumentation GetDatumTypeSources(Type, Datum )
See Also
NOPInstrumentation Class
NOPInstrumentation Members
NFX.Instrumentation Namespace


NOPInstrumentation.LocalizedTimeToUniversalTime Method

NOPInstrumentation LocalizedTimeToUniversalTime Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
public DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
Public Function LocalizedTimeToUniversalTime (
    local As DateTime
) As DateTime
Public Function LocalizedTimeToUniversalTime (
    local As DateTime
) As DateTime
public:
virtual DateTime LocalizedTimeToUniversalTime(
    DateTime local
) sealed
public:
virtual DateTime LocalizedTimeToUniversalTime(
    DateTime local
) sealed
abstract LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
override LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
abstract LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
override LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime

Parameters

local
Type: Online System DateTime

Return Value

Type: Online DateTime

Implements

ILocalizedTimeProvider LocalizedTimeToUniversalTime(DateTime)
See Also
NOPInstrumentation Class
NOPInstrumentation Members
NFX.Instrumentation Namespace


NOPInstrumentation.Record Method

NOPInstrumentation Record Method NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Record(
    Datum datum
)
public void Record(
    Datum datum
)
Public Sub Record (
    datum As Datum
)
Public Sub Record (
    datum As Datum
)
public:
virtual void Record(
    Datum^ datum
) sealed
public:
virtual void Record(
    Datum^ datum
) sealed
abstract Record :
        datum : Datum -> unit
override Record :
        datum : Datum -> unit
abstract Record :
        datum : Datum -> unit
override Record :
        datum : Datum -> unit

Parameters

datum
Type: NFX.Instrumentation Datum

Implements

IInstrumentation Record(Datum)
See Also
NOPInstrumentation Class
NOPInstrumentation Members
NFX.Instrumentation Namespace


NOPInstrumentation.UniversalTimeToLocalizedTime Method

NOPInstrumentation UniversalTimeToLocalizedTime Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
public DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
Public Function UniversalTimeToLocalizedTime (
    utc As DateTime
) As DateTime
Public Function UniversalTimeToLocalizedTime (
    utc As DateTime
) As DateTime
public:
virtual DateTime UniversalTimeToLocalizedTime(
    DateTime utc
) sealed
public:
virtual DateTime UniversalTimeToLocalizedTime(
    DateTime utc
) sealed
abstract UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
override UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
abstract UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
override UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime

Parameters

utc
Type: Online System DateTime

Return Value

Type: Online DateTime

Implements

ILocalizedTimeProvider UniversalTimeToLocalizedTime(DateTime)
See Also
NOPInstrumentation Class
NOPInstrumentation Members
NFX.Instrumentation Namespace


NOPInstrumentation Properties

NOPInstrumentation Properties NFX Class Library

The NOPInstrumentation type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DataTypes |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Enabled |
Public property | ExternalParameters |
 | Instance | Returns a singlelton instance of the NOPInstrumentation
Public property | InstrumentationEnabled |
Public property | LocalizedTime |
Public property | MaxRecordCount |
Public property | OSInstrumentationIntervalMS |
Public property | Overflown |
Public property | ProcessingIntervalMS |
Public property | RecordCount |
Public property | ResultBufferSize |
Public property | SelfInstrumented |
Public property | TimeLocation |
Back to Top
See Also
NOPInstrumentation Class
NFX.Instrumentation Namespace


NOPInstrumentation.DataTypes Property

NOPInstrumentation DataTypes Property NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Type> DataTypes { get; }
public IEnumerable<Type> DataTypes { get; }
Public ReadOnly Property DataTypes As IEnumerable(Of Type)
    Get
Public ReadOnly Property DataTypes As IEnumerable(Of Type)
    Get
public:
virtual property IEnumerable<Type^>^ DataTypes {
    IEnumerable<Type^>^ get () sealed;
}
public:
virtual property IEnumerable<Type^>^ DataTypes {
    IEnumerable<Type^>^ get () sealed;
}
abstract DataTypes : IEnumerable<Type> with get
override DataTypes : IEnumerable<Type> with get
abstract DataTypes : IEnumerable<Type> with get
override DataTypes : IEnumerable<Type> with get

Property Value

Type: Online IEnumerable Online Type

Implements

IInstrumentation DataTypes
See Also
NOPInstrumentation Class
NOPInstrumentation Members
NFX.Instrumentation Namespace


NOPInstrumentation.Enabled Property

NOPInstrumentation Enabled Property NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Enabled { get; }
public bool Enabled { get; }
Public ReadOnly Property Enabled As Boolean
    Get
Public ReadOnly Property Enabled As Boolean
    Get
public:
virtual property bool Enabled {
    bool get () sealed;
}
public:
virtual property bool Enabled {
    bool get () sealed;
}
abstract Enabled : bool with get
override Enabled : bool with get
abstract Enabled : bool with get
override Enabled : bool with get

Property Value

Type: Online Boolean

Implements

IInstrumentation Enabled
See Also
NOPInstrumentation Class
NOPInstrumentation Members
NFX.Instrumentation Namespace


NOPInstrumentation.ExternalParameters Property

NOPInstrumentation ExternalParameters Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
public IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
Public ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
Public ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get () sealed;
}
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get () sealed;
}
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get

Property Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParameters
See Also
NOPInstrumentation Class
NOPInstrumentation Members
NFX.Instrumentation Namespace


NOPInstrumentation.Instance Property

NOPInstrumentation Instance Property NFX Class Library

Returns a singlelton instance of the NOPInstrumentation

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NOPInstrumentation Instance { get; }
public static NOPInstrumentation Instance { get; }
Public Shared ReadOnly Property Instance As NOPInstrumentation
    Get
Public Shared ReadOnly Property Instance As NOPInstrumentation
    Get
public:
static property NOPInstrumentation^ Instance {
    NOPInstrumentation^ get ();
}
public:
static property NOPInstrumentation^ Instance {
    NOPInstrumentation^ get ();
}
static member Instance : NOPInstrumentation with get
static member Instance : NOPInstrumentation with get

Property Value

Type: NOPInstrumentation
See Also
NOPInstrumentation Class
NOPInstrumentation Members
NFX.Instrumentation Namespace


NOPInstrumentation.InstrumentationEnabled Property

NOPInstrumentation InstrumentationEnabled Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool InstrumentationEnabled { get; set; }
public bool InstrumentationEnabled { get; set; }
Public Property InstrumentationEnabled As Boolean
    Get
    Set
Public Property InstrumentationEnabled As Boolean
    Get
    Set
public:
virtual property bool InstrumentationEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
virtual property bool InstrumentationEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract InstrumentationEnabled : bool with get, set
override InstrumentationEnabled : bool with get, set
abstract InstrumentationEnabled : bool with get, set
override InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentable InstrumentationEnabled
See Also
NOPInstrumentation Class
NOPInstrumentation Members
NFX.Instrumentation Namespace


NOPInstrumentation.LocalizedTime Property

NOPInstrumentation LocalizedTime Property NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime LocalizedTime { get; }
public DateTime LocalizedTime { get; }
Public ReadOnly Property LocalizedTime As DateTime
    Get
Public ReadOnly Property LocalizedTime As DateTime
    Get
public:
virtual property DateTime LocalizedTime {
    DateTime get () sealed;
}
public:
virtual property DateTime LocalizedTime {
    DateTime get () sealed;
}
abstract LocalizedTime : DateTime with get
override LocalizedTime : DateTime with get
abstract LocalizedTime : DateTime with get
override LocalizedTime : DateTime with get

Property Value

Type: Online DateTime

Implements

ILocalizedTimeProvider LocalizedTime
See Also
NOPInstrumentation Class
NOPInstrumentation Members
NFX.Instrumentation Namespace


NOPInstrumentation.MaxRecordCount Property

NOPInstrumentation MaxRecordCount Property NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MaxRecordCount { get; set; }
public int MaxRecordCount { get; set; }
Public Property MaxRecordCount As Integer
    Get
    Set
Public Property MaxRecordCount As Integer
    Get
    Set
public:
virtual property int MaxRecordCount {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int MaxRecordCount {
    int get () sealed;
    void set (int value) sealed;
}
abstract MaxRecordCount : int with get, set
override MaxRecordCount : int with get, set
abstract MaxRecordCount : int with get, set
override MaxRecordCount : int with get, set

Property Value

Type: Online Int32

Implements

IInstrumentation MaxRecordCount
See Also
NOPInstrumentation Class
NOPInstrumentation Members
NFX.Instrumentation Namespace


NOPInstrumentation.OSInstrumentationIntervalMS Property

NOPInstrumentation OSInstrumentationIntervalMS Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int OSInstrumentationIntervalMS { get; }
public int OSInstrumentationIntervalMS { get; }
Public ReadOnly Property OSInstrumentationIntervalMS As Integer
    Get
Public ReadOnly Property OSInstrumentationIntervalMS As Integer
    Get
public:
virtual property int OSInstrumentationIntervalMS {
    int get () sealed;
}
public:
virtual property int OSInstrumentationIntervalMS {
    int get () sealed;
}
abstract OSInstrumentationIntervalMS : int with get
override OSInstrumentationIntervalMS : int with get
abstract OSInstrumentationIntervalMS : int with get
override OSInstrumentationIntervalMS : int with get

Property Value

Type: Online Int32

Implements

IInstrumentation OSInstrumentationIntervalMS
See Also
NOPInstrumentation Class
NOPInstrumentation Members
NFX.Instrumentation Namespace


NOPInstrumentation.Overflown Property

NOPInstrumentation Overflown Property NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Overflown { get; }
public bool Overflown { get; }
Public ReadOnly Property Overflown As Boolean
    Get
Public ReadOnly Property Overflown As Boolean
    Get
public:
virtual property bool Overflown {
    bool get () sealed;
}
public:
virtual property bool Overflown {
    bool get () sealed;
}
abstract Overflown : bool with get
override Overflown : bool with get
abstract Overflown : bool with get
override Overflown : bool with get

Property Value

Type: Online Boolean

Implements

IInstrumentation Overflown
See Also
NOPInstrumentation Class
NOPInstrumentation Members
NFX.Instrumentation Namespace


NOPInstrumentation.ProcessingIntervalMS Property

NOPInstrumentation ProcessingIntervalMS Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ProcessingIntervalMS { get; }
public int ProcessingIntervalMS { get; }
Public ReadOnly Property ProcessingIntervalMS As Integer
    Get
Public ReadOnly Property ProcessingIntervalMS As Integer
    Get
public:
virtual property int ProcessingIntervalMS {
    int get () sealed;
}
public:
virtual property int ProcessingIntervalMS {
    int get () sealed;
}
abstract ProcessingIntervalMS : int with get
override ProcessingIntervalMS : int with get
abstract ProcessingIntervalMS : int with get
override ProcessingIntervalMS : int with get

Property Value

Type: Online Int32

Implements

IInstrumentation ProcessingIntervalMS
See Also
NOPInstrumentation Class
NOPInstrumentation Members
NFX.Instrumentation Namespace


NOPInstrumentation.RecordCount Property

NOPInstrumentation RecordCount Property NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int RecordCount { get; }
public int RecordCount { get; }
Public ReadOnly Property RecordCount As Integer
    Get
Public ReadOnly Property RecordCount As Integer
    Get
public:
virtual property int RecordCount {
    int get () sealed;
}
public:
virtual property int RecordCount {
    int get () sealed;
}
abstract RecordCount : int with get
override RecordCount : int with get
abstract RecordCount : int with get
override RecordCount : int with get

Property Value

Type: Online Int32

Implements

IInstrumentation RecordCount
See Also
NOPInstrumentation Class
NOPInstrumentation Members
NFX.Instrumentation Namespace


NOPInstrumentation.ResultBufferSize Property

NOPInstrumentation ResultBufferSize Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ResultBufferSize { get; }
public int ResultBufferSize { get; }
Public ReadOnly Property ResultBufferSize As Integer
    Get
Public ReadOnly Property ResultBufferSize As Integer
    Get
public:
virtual property int ResultBufferSize {
    int get () sealed;
}
public:
virtual property int ResultBufferSize {
    int get () sealed;
}
abstract ResultBufferSize : int with get
override ResultBufferSize : int with get
abstract ResultBufferSize : int with get
override ResultBufferSize : int with get

Property Value

Type: Online Int32

Implements

IInstrumentation ResultBufferSize
See Also
NOPInstrumentation Class
NOPInstrumentation Members
NFX.Instrumentation Namespace


NOPInstrumentation.SelfInstrumented Property

NOPInstrumentation SelfInstrumented Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SelfInstrumented { get; }
public bool SelfInstrumented { get; }
Public ReadOnly Property SelfInstrumented As Boolean
    Get
Public ReadOnly Property SelfInstrumented As Boolean
    Get
public:
virtual property bool SelfInstrumented {
    bool get () sealed;
}
public:
virtual property bool SelfInstrumented {
    bool get () sealed;
}
abstract SelfInstrumented : bool with get
override SelfInstrumented : bool with get
abstract SelfInstrumented : bool with get
override SelfInstrumented : bool with get

Property Value

Type: Online Boolean

Implements

IInstrumentation SelfInstrumented
See Also
NOPInstrumentation Class
NOPInstrumentation Members
NFX.Instrumentation Namespace


NOPInstrumentation.TimeLocation Property

NOPInstrumentation TimeLocation Property NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeLocation TimeLocation { get; }
public TimeLocation TimeLocation { get; }
Public ReadOnly Property TimeLocation As TimeLocation
    Get
Public ReadOnly Property TimeLocation As TimeLocation
    Get
public:
virtual property TimeLocation^ TimeLocation {
    TimeLocation^ get () sealed;
}
public:
virtual property TimeLocation^ TimeLocation {
    TimeLocation^ get () sealed;
}
abstract TimeLocation : TimeLocation with get
override TimeLocation : TimeLocation with get
abstract TimeLocation : TimeLocation with get
override TimeLocation : TimeLocation with get

Property Value

Type: TimeLocation

Implements

ILocalizedTimeProvider TimeLocation
See Also
NOPInstrumentation Class
NOPInstrumentation Members
NFX.Instrumentation Namespace


NOPInstrumentationProvider Class

NOPInstrumentationProvider Class NFX Class Library

Represents a provider that does nothing
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service InstrumentationService
NFX.Instrumentation InstrumentationProvider
NFX.Instrumentation NOPInstrumentationProvider

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NOPInstrumentationProvider : InstrumentationProvider
public class NOPInstrumentationProvider : InstrumentationProvider
Public Class NOPInstrumentationProvider
    Inherits InstrumentationProvider
Public Class NOPInstrumentationProvider
    Inherits InstrumentationProvider
public ref class NOPInstrumentationProvider : public InstrumentationProvider
public ref class NOPInstrumentationProvider : public InstrumentationProvider
type NOPInstrumentationProvider =
    class
        inherit InstrumentationProvider
    end
type NOPInstrumentationProvider =
    class
        inherit InstrumentationProvider
    end
See Also
NOPInstrumentationProvider Members
NFX.Instrumentation Namespace


NOPInstrumentationProvider Members

NOPInstrumentationProvider Members NFX Class Library

The NOPInstrumentationProvider type exposes the following members.
Constructors
 | Name | Description
Public method | NOPInstrumentationProvider | Initializes a new instance of the NOPInstrumentationProvider class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Inherited from InstrumentationProvider.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from InstrumentationProvider.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from InstrumentationProvider.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from InstrumentationProvider.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | Write | (Overrides InstrumentationProvider Write(Datum).)
Protected method | WriteLog | (Inherited from InstrumentationProvider.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from InstrumentationProvider.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
NOPInstrumentationProvider Class
NFX.Instrumentation Namespace


NOPInstrumentationProvider Constructor

NOPInstrumentationProvider Constructor NFX Class Library

Initializes a new instance of the NOPInstrumentationProvider class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NOPInstrumentationProvider()
public NOPInstrumentationProvider()
Public Sub New
Public Sub New
public:
NOPInstrumentationProvider()
public:
NOPInstrumentationProvider()
new : unit -> NOPInstrumentationProvider
new : unit -> NOPInstrumentationProvider
See Also
NOPInstrumentationProvider Class
NOPInstrumentationProvider Members
NFX.Instrumentation Namespace


NOPInstrumentationProvider Methods

NOPInstrumentationProvider Methods NFX Class Library

The NOPInstrumentationProvider type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Inherited from InstrumentationProvider.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from InstrumentationProvider.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from InstrumentationProvider.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from InstrumentationProvider.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | Write | (Overrides InstrumentationProvider Write(Datum).)
Protected method | WriteLog | (Inherited from InstrumentationProvider.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NOPInstrumentationProvider Class
NFX.Instrumentation Namespace


NOPInstrumentationProvider.Write Method

NOPInstrumentationProvider Write Method NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Datum aggregatedDatum
)
public override void Write(
    Datum aggregatedDatum
)
Public Overrides Sub Write (
    aggregatedDatum As Datum
)
Public Overrides Sub Write (
    aggregatedDatum As Datum
)
public:
virtual void Write(
    Datum^ aggregatedDatum
) override
public:
virtual void Write(
    Datum^ aggregatedDatum
) override
abstract Write :
        aggregatedDatum : Datum -> unit
override Write :
        aggregatedDatum : Datum -> unit
abstract Write :
        aggregatedDatum : Datum -> unit
override Write :
        aggregatedDatum : Datum -> unit

Parameters

aggregatedDatum
Type: NFX.Instrumentation Datum
See Also
NOPInstrumentationProvider Class
NOPInstrumentationProvider Members
NFX.Instrumentation Namespace


NOPInstrumentationProvider Properties

NOPInstrumentationProvider Properties NFX Class Library

The NOPInstrumentationProvider type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from InstrumentationProvider.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
NOPInstrumentationProvider Class
NFX.Instrumentation Namespace


SrcBucketedData Class

SrcBucketedData Class NFX Class Library

Internal concurrent dictionary used for instrumentation data aggregation
Inheritance Hierarchy
Online System Object
Online System.Collections.Concurrent ConcurrentDictionary Online String, DatumBag
NFX.Instrumentation SrcBucketedData

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class SrcBucketedData : ConcurrentDictionary<string, DatumBag>
internal class SrcBucketedData : ConcurrentDictionary<string, DatumBag>
Friend Class SrcBucketedData
    Inherits ConcurrentDictionary(Of String, DatumBag)
Friend Class SrcBucketedData
    Inherits ConcurrentDictionary(Of String, DatumBag)
internal ref class SrcBucketedData : public ConcurrentDictionary<String^, DatumBag^>
internal ref class SrcBucketedData : public ConcurrentDictionary<String^, DatumBag^>
type SrcBucketedData =
    class
        inherit ConcurrentDictionary<string, DatumBag>
    end
type SrcBucketedData =
    class
        inherit ConcurrentDictionary<string, DatumBag>
    end
See Also
SrcBucketedData Members
NFX.Instrumentation Namespace


SrcBucketedData Members

SrcBucketedData Members NFX Class Library

The SrcBucketedData type exposes the following members.
Constructors
 | Name | Description
Public method | SrcBucketedData | Initializes a new instance of the SrcBucketedData class
Back to Top
Methods
 | Name | Description
Public method | Online AddOrUpdate(TKey, Func TKey, TValue , Func TKey, TValue, TValue ) | Uses the specified functions to add a key/value pair to the Online ConcurrentDictionary TKey, TValue if the key does not already exist, or to update a key/value pair in the Online ConcurrentDictionary TKey, TValue if the key already exists. (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public method | Online AddOrUpdate(TKey, TValue, Func TKey, TValue, TValue ) | Adds a key/value pair to the Online ConcurrentDictionary TKey, TValue if the key does not already exist, or updates a key/value pair in the Online ConcurrentDictionary TKey, TValue by using the specified function if the key already exists. (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public method | Online Clear | Removes all keys and values from the Online ConcurrentDictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public method | Online ContainsKey | Determines whether the Online ConcurrentDictionary TKey, TValue contains the specified key. (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online ConcurrentDictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetOrAdd(TKey, Func TKey, TValue ) | Adds a key/value pair to the Online ConcurrentDictionary TKey, TValue by using the specified function, if the key does not already exist. (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public method | Online GetOrAdd(TKey, TValue) | Adds a key/value pair to the Online ConcurrentDictionary TKey, TValue if the key does not already exist. (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToArray | Copies the key and value pairs stored in the Online ConcurrentDictionary TKey, TValue to a new array. (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TryAdd | Attempts to add the specified key and value to the Online ConcurrentDictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public method | Online TryGetValue | Attempts to get the value associated with the specified key from the Online ConcurrentDictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public method | Online TryRemove | Attempts to remove and return the value that has the specified key from the Online ConcurrentDictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public method | Online TryUpdate | Compares the existing value for the specified key with a specified value, and if they are equal, updates the key with a third value. (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | DefaultDatum |
Back to Top
Properties
 | Name | Description
Public property | Online Count | Gets the number of key/value pairs contained in the Online ConcurrentDictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public property | Online IsEmpty | Gets a value that indicates whether the Online ConcurrentDictionary TKey, TValue is empty. (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public property | Online Item | Gets or sets the value associated with the specified key. (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public property | Online Keys | Gets a collection containing the keys in the Online Dictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public property | Online Values | Gets a collection that contains the values in the Online Dictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Back to Top
See Also
SrcBucketedData Class
NFX.Instrumentation Namespace


SrcBucketedData Constructor

SrcBucketedData Constructor NFX Class Library

Initializes a new instance of the SrcBucketedData class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SrcBucketedData()
public SrcBucketedData()
Public Sub New
Public Sub New
public:
SrcBucketedData()
public:
SrcBucketedData()
new : unit -> SrcBucketedData
new : unit -> SrcBucketedData
See Also
SrcBucketedData Class
SrcBucketedData Members
NFX.Instrumentation Namespace


SrcBucketedData Fields

SrcBucketedData Fields NFX Class Library

The SrcBucketedData type exposes the following members.
Fields
 | Name | Description
Protected field | DefaultDatum |
Back to Top
See Also
SrcBucketedData Class
NFX.Instrumentation Namespace


SrcBucketedData.DefaultDatum Field

SrcBucketedData DefaultDatum Field NFX Class Library

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Datum DefaultDatum
internal Datum DefaultDatum
Friend DefaultDatum As Datum
Friend DefaultDatum As Datum
internal:
Datum^ DefaultDatum
internal:
Datum^ DefaultDatum
val mutable internal DefaultDatum: Datum
val mutable internal DefaultDatum: Datum

Field Value

Type: Datum
See Also
SrcBucketedData Class
SrcBucketedData Members
NFX.Instrumentation Namespace


SrcBucketedData Methods

SrcBucketedData Methods NFX Class Library

The SrcBucketedData type exposes the following members.
Methods
 | Name | Description
Public method | Online AddOrUpdate(TKey, Func TKey, TValue , Func TKey, TValue, TValue ) | Uses the specified functions to add a key/value pair to the Online ConcurrentDictionary TKey, TValue if the key does not already exist, or to update a key/value pair in the Online ConcurrentDictionary TKey, TValue if the key already exists. (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public method | Online AddOrUpdate(TKey, TValue, Func TKey, TValue, TValue ) | Adds a key/value pair to the Online ConcurrentDictionary TKey, TValue if the key does not already exist, or updates a key/value pair in the Online ConcurrentDictionary TKey, TValue by using the specified function if the key already exists. (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public method | Online Clear | Removes all keys and values from the Online ConcurrentDictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public method | Online ContainsKey | Determines whether the Online ConcurrentDictionary TKey, TValue contains the specified key. (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online ConcurrentDictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetOrAdd(TKey, Func TKey, TValue ) | Adds a key/value pair to the Online ConcurrentDictionary TKey, TValue by using the specified function, if the key does not already exist. (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public method | Online GetOrAdd(TKey, TValue) | Adds a key/value pair to the Online ConcurrentDictionary TKey, TValue if the key does not already exist. (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToArray | Copies the key and value pairs stored in the Online ConcurrentDictionary TKey, TValue to a new array. (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TryAdd | Attempts to add the specified key and value to the Online ConcurrentDictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public method | Online TryGetValue | Attempts to get the value associated with the specified key from the Online ConcurrentDictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public method | Online TryRemove | Attempts to remove and return the value that has the specified key from the Online ConcurrentDictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public method | Online TryUpdate | Compares the existing value for the specified key with a specified value, and if they are equal, updates the key with a third value. (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SrcBucketedData Class
NFX.Instrumentation Namespace


SrcBucketedData Properties

SrcBucketedData Properties NFX Class Library

The SrcBucketedData type exposes the following members.
Properties
 | Name | Description
Public property | Online Count | Gets the number of key/value pairs contained in the Online ConcurrentDictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public property | Online IsEmpty | Gets a value that indicates whether the Online ConcurrentDictionary TKey, TValue is empty. (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public property | Online Item | Gets or sets the value associated with the specified key. (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public property | Online Keys | Gets a collection containing the keys in the Online Dictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Public property | Online Values | Gets a collection that contains the values in the Online Dictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online String, DatumBag .)
Back to Top
See Also
SrcBucketedData Class
NFX.Instrumentation Namespace


TypeBucketedData Class

TypeBucketedData Class NFX Class Library

Internal concurrent dictionary used for instrumentation data aggregation
Inheritance Hierarchy
Online System Object
Online System.Collections.Concurrent ConcurrentDictionary Online Type, SrcBucketedData
NFX.Instrumentation TypeBucketedData

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class TypeBucketedData : ConcurrentDictionary<Type, SrcBucketedData>
internal class TypeBucketedData : ConcurrentDictionary<Type, SrcBucketedData>
Friend Class TypeBucketedData
    Inherits ConcurrentDictionary(Of Type, SrcBucketedData)
Friend Class TypeBucketedData
    Inherits ConcurrentDictionary(Of Type, SrcBucketedData)
internal ref class TypeBucketedData : public ConcurrentDictionary<Type^, SrcBucketedData^>
internal ref class TypeBucketedData : public ConcurrentDictionary<Type^, SrcBucketedData^>
type TypeBucketedData =
    class
        inherit ConcurrentDictionary<Type, SrcBucketedData>
    end
type TypeBucketedData =
    class
        inherit ConcurrentDictionary<Type, SrcBucketedData>
    end
See Also
TypeBucketedData Members
NFX.Instrumentation Namespace


TypeBucketedData Members

TypeBucketedData Members NFX Class Library

The TypeBucketedData type exposes the following members.
Constructors
 | Name | Description
Public method | TypeBucketedData | Initializes a new instance of the TypeBucketedData class
Back to Top
Methods
 | Name | Description
Public method | Online AddOrUpdate(TKey, Func TKey, TValue , Func TKey, TValue, TValue ) | Uses the specified functions to add a key/value pair to the Online ConcurrentDictionary TKey, TValue if the key does not already exist, or to update a key/value pair in the Online ConcurrentDictionary TKey, TValue if the key already exists. (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public method | Online AddOrUpdate(TKey, TValue, Func TKey, TValue, TValue ) | Adds a key/value pair to the Online ConcurrentDictionary TKey, TValue if the key does not already exist, or updates a key/value pair in the Online ConcurrentDictionary TKey, TValue by using the specified function if the key already exists. (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public method | Online Clear | Removes all keys and values from the Online ConcurrentDictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public method | Online ContainsKey | Determines whether the Online ConcurrentDictionary TKey, TValue contains the specified key. (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online ConcurrentDictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetOrAdd(TKey, Func TKey, TValue ) | Adds a key/value pair to the Online ConcurrentDictionary TKey, TValue by using the specified function, if the key does not already exist. (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public method | Online GetOrAdd(TKey, TValue) | Adds a key/value pair to the Online ConcurrentDictionary TKey, TValue if the key does not already exist. (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToArray | Copies the key and value pairs stored in the Online ConcurrentDictionary TKey, TValue to a new array. (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TryAdd | Attempts to add the specified key and value to the Online ConcurrentDictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public method | Online TryGetValue | Attempts to get the value associated with the specified key from the Online ConcurrentDictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public method | Online TryRemove | Attempts to remove and return the value that has the specified key from the Online ConcurrentDictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public method | Online TryUpdate | Compares the existing value for the specified key with a specified value, and if they are equal, updates the key with a third value. (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online Count | Gets the number of key/value pairs contained in the Online ConcurrentDictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public property | Online IsEmpty | Gets a value that indicates whether the Online ConcurrentDictionary TKey, TValue is empty. (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public property | Online Item | Gets or sets the value associated with the specified key. (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public property | Online Keys | Gets a collection containing the keys in the Online Dictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public property | Online Values | Gets a collection that contains the values in the Online Dictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Back to Top
See Also
TypeBucketedData Class
NFX.Instrumentation Namespace


TypeBucketedData Constructor

TypeBucketedData Constructor NFX Class Library

Initializes a new instance of the TypeBucketedData class

Namespace: NFX.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TypeBucketedData()
public TypeBucketedData()
Public Sub New
Public Sub New
public:
TypeBucketedData()
public:
TypeBucketedData()
new : unit -> TypeBucketedData
new : unit -> TypeBucketedData
See Also
TypeBucketedData Class
TypeBucketedData Members
NFX.Instrumentation Namespace


TypeBucketedData Methods

TypeBucketedData Methods NFX Class Library

The TypeBucketedData type exposes the following members.
Methods
 | Name | Description
Public method | Online AddOrUpdate(TKey, Func TKey, TValue , Func TKey, TValue, TValue ) | Uses the specified functions to add a key/value pair to the Online ConcurrentDictionary TKey, TValue if the key does not already exist, or to update a key/value pair in the Online ConcurrentDictionary TKey, TValue if the key already exists. (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public method | Online AddOrUpdate(TKey, TValue, Func TKey, TValue, TValue ) | Adds a key/value pair to the Online ConcurrentDictionary TKey, TValue if the key does not already exist, or updates a key/value pair in the Online ConcurrentDictionary TKey, TValue by using the specified function if the key already exists. (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public method | Online Clear | Removes all keys and values from the Online ConcurrentDictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public method | Online ContainsKey | Determines whether the Online ConcurrentDictionary TKey, TValue contains the specified key. (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online ConcurrentDictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetOrAdd(TKey, Func TKey, TValue ) | Adds a key/value pair to the Online ConcurrentDictionary TKey, TValue by using the specified function, if the key does not already exist. (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public method | Online GetOrAdd(TKey, TValue) | Adds a key/value pair to the Online ConcurrentDictionary TKey, TValue if the key does not already exist. (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToArray | Copies the key and value pairs stored in the Online ConcurrentDictionary TKey, TValue to a new array. (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TryAdd | Attempts to add the specified key and value to the Online ConcurrentDictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public method | Online TryGetValue | Attempts to get the value associated with the specified key from the Online ConcurrentDictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public method | Online TryRemove | Attempts to remove and return the value that has the specified key from the Online ConcurrentDictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public method | Online TryUpdate | Compares the existing value for the specified key with a specified value, and if they are equal, updates the key with a third value. (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TypeBucketedData Class
NFX.Instrumentation Namespace


TypeBucketedData Properties

TypeBucketedData Properties NFX Class Library

The TypeBucketedData type exposes the following members.
Properties
 | Name | Description
Public property | Online Count | Gets the number of key/value pairs contained in the Online ConcurrentDictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public property | Online IsEmpty | Gets a value that indicates whether the Online ConcurrentDictionary TKey, TValue is empty. (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public property | Online Item | Gets or sets the value associated with the specified key. (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public property | Online Keys | Gets a collection containing the keys in the Online Dictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Public property | Online Values | Gets a collection that contains the values in the Online Dictionary TKey, TValue . (Inherited from Online ConcurrentDictionary Online Type, SrcBucketedData .)
Back to Top
See Also
TypeBucketedData Class
NFX.Instrumentation Namespace


NFX.Instrumentation.Analytics Namespace

NFX.Instrumentation.Analytics Namespace NFX Class Library

Provides instrumentation-related classes that facilitate analytical processing - various histograms
Classes
 | Class | Description
Public class | Dimension | Base class of a histogram dimension. of data type TData partitions a range defined by MinValue and MaxValue, by mapping the given value into [0 ... PartitionCount] partitions
Public class | Dimension TData | A dimension of data type TData partitions a range of values by mapping the given value into [0 ... PartitionCount] partitions
Public class | HistData | Helper type representing a dictionary for storing historam data
Public class | Histogram | Base histogram to be used by typed histogram generic derived classes. The histogram holds a dictionary of integer counts for each measurement keys (with number of keys correspondent to the number of dimensions in the histogram).
Public class | Histogram TData1 | One-dimensional histogram for storing number of samples for a given dimension key
Public class | Histogram TData1, TData2 | Two-dimensional histogram for storing number of samples for given dimension keys
Public class | Histogram TData1, TData2, TData3 | Three-dimensional histogram for storing number of samples for given dimension keys
Public class | HistogramEntry | The placeholder of histogram data that represents a sample count for a given set of histogram keys.
Public class | HistogramReporters | Maps histogram data into some other representation (such as text, HTML, etc)
Public class | TimeDimension | A dimension of data type double partitions a range of values by mapping the given value into [0 ... PartitionCount] partitions. This is a helper class for creating a dimension of TimeHistogram
Public class | TimeHistogram | Time measurement 1D histogram aggregates measurements in fractions of a second
Public class | TimeHistogram TData2 | Time measurement 2D histogram aggregates measurements in fractions of a second for a given 1st dimension key.
Public class | TimeHistogram TData2, TData3 | Time measurement 3D histogram aggregates measurements in fractions of a second for a given 1st and 2nd dimension keys.
Structures
 | Structure | Description
Public structure | HistogramKeys | Represents histogram dimension key vector. This class is introduced for performance enhancement vs int[] approach that would have allocated extra object on heap per call
Protected structure | TimeHistogramHelper | Helper class used by TimerHistogram
Interfaces
 | Interface | Description
Public interface | IHistogram | Basic histogram interface to be implemented by all types of instrumentation histograms
Public interface | ITimeHistogram | Histogram for measuring latency
Delegates
 | Delegate | Description
Public delegate | PartitionFunc TData | References a function that maps input value into a partition index in the context of a given Partitioner
Public delegate | PartitionNameFunc | Returns a partition name for a given partition index


Dimension Class

Dimension Class NFX Class Library

Base class of a histogram dimension. of data type TData partitions a range defined by MinValue and MaxValue, by mapping the given value into [0 ... PartitionCount] partitions
Inheritance Hierarchy
Online System Object
NFX.Instrumentation.Analytics Dimension
NFX.Instrumentation.Analytics Dimension TData

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Dimension
public abstract class Dimension
Public MustInherit Class Dimension
Public MustInherit Class Dimension
public ref class Dimension abstract
public ref class Dimension abstract
[<AbstractClassAttribute>]
type Dimension =  class end
[<AbstractClassAttribute>]
type Dimension =  class end
See Also
Dimension Members
NFX.Instrumentation.Analytics Namespace


Dimension Members

Dimension Members NFX Class Library

The Dimension type exposes the following members.
Constructors
 | Name | Description
Public method | Dimension | Creates histogram dimension instance. If partitionFunc is null then DoPartition must be overriden in the derived class
Back to Top
Methods
 | Name | Description
Protected method | DoPartitionName | Override to implement a custom mapping logic to return the names of a given partition when its not passed in the .ctor
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetPartitionName | Returns the name of a partition identified by idx
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | SetIndex |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | DEFAULT_PARTITION_NAMES |
Public field | Name | Provides meaningful name for displaying
Public field | PartitionCount | Number of partitions in
Back to Top
Properties
 | Name | Description
Public property | DataType | Returns the type of data that this instance partitions
Public property | Index | Index of this dimension in the histogram
Back to Top
See Also
Dimension Class
NFX.Instrumentation.Analytics Namespace


Dimension Constructor

Dimension Constructor NFX Class Library

Creates histogram dimension instance. If partitionFunc is null then DoPartition must be overriden in the derived class

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Dimension(
    string name,
    int partCount,
    PartitionNameFunc partitionNameFunc = null
)
public Dimension(
    string name,
    int partCount,
    PartitionNameFunc partitionNameFunc = null
)
Public Sub New (
    name As String,
    partCount As Integer,
    Optional partitionNameFunc As PartitionNameFunc = Nothing
)
Public Sub New (
    name As String,
    partCount As Integer,
    Optional partitionNameFunc As PartitionNameFunc = Nothing
)
public:
Dimension(
    String^ name,
    int partCount,
    PartitionNameFunc^ partitionNameFunc = nullptr
)
public:
Dimension(
    String^ name,
    int partCount,
    PartitionNameFunc^ partitionNameFunc = nullptr
)
new :
        name : string *
        partCount : int *
        ?partitionNameFunc : PartitionNameFunc
(* Defaults:
        let _partitionNameFunc = defaultArg partitionNameFunc null
*)
-> Dimension
new :
        name : string *
        partCount : int *
        ?partitionNameFunc : PartitionNameFunc
(* Defaults:
        let _partitionNameFunc = defaultArg partitionNameFunc null
*)
-> Dimension

Parameters

name
Type: Online System String
Description of this dimension used in reporting
partCount
Type: Online System Int32
Total number of partitions
partitionNameFunc (Optional)
Type: NFX.Instrumentation.Analytics PartitionNameFunc
Used to inject a function in order not to override this class
See Also
Dimension Class
Dimension Members
NFX.Instrumentation.Analytics Namespace


Dimension Fields

Dimension Fields NFX Class Library

The Dimension type exposes the following members.
Fields
 | Name | Description
 | DEFAULT_PARTITION_NAMES |
Public field | Name | Provides meaningful name for displaying
Public field | PartitionCount | Number of partitions in
Back to Top
See Also
Dimension Class
NFX.Instrumentation.Analytics Namespace


Dimension.DEFAULT_PARTITION_NAMES Field

Dimension DEFAULT_PARTITION_NAMES Field NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string[] DEFAULT_PARTITION_NAMES
public static readonly string[] DEFAULT_PARTITION_NAMES
Public Shared ReadOnly DEFAULT_PARTITION_NAMES As String()
Public Shared ReadOnly DEFAULT_PARTITION_NAMES As String()
public:
static initonly array<String^>^ DEFAULT_PARTITION_NAMES
public:
static initonly array<String^>^ DEFAULT_PARTITION_NAMES
static val DEFAULT_PARTITION_NAMES: string[]
static val DEFAULT_PARTITION_NAMES: string[]

Field Value

Type: Online String
See Also
Dimension Class
Dimension Members
NFX.Instrumentation.Analytics Namespace


Dimension.Name Field

Dimension Name Field NFX Class Library

Provides meaningful name for displaying

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Name
public readonly string Name
Public ReadOnly Name As String
Public ReadOnly Name As String
public:
initonly String^ Name
public:
initonly String^ Name
val Name: string
val Name: string

Field Value

Type: Online String
See Also
Dimension Class
Dimension Members
NFX.Instrumentation.Analytics Namespace


Dimension.PartitionCount Field

Dimension PartitionCount Field NFX Class Library

Number of partitions in

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int PartitionCount
public readonly int PartitionCount
Public ReadOnly PartitionCount As Integer
Public ReadOnly PartitionCount As Integer
public:
initonly int PartitionCount
public:
initonly int PartitionCount
val PartitionCount: int
val PartitionCount: int

Field Value

Type: Online Int32
See Also
Dimension Class
Dimension Members
NFX.Instrumentation.Analytics Namespace


Dimension Methods

Dimension Methods NFX Class Library

The Dimension type exposes the following members.
Methods
 | Name | Description
Protected method | DoPartitionName | Override to implement a custom mapping logic to return the names of a given partition when its not passed in the .ctor
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetPartitionName | Returns the name of a partition identified by idx
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | SetIndex |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Dimension Class
NFX.Instrumentation.Analytics Namespace


Dimension.DoPartitionName Method

Dimension DoPartitionName Method NFX Class Library

Override to implement a custom mapping logic to return the names of a given partition when its not passed in the .ctor

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual string DoPartitionName(
    int idx
)
protected virtual string DoPartitionName(
    int idx
)
Protected Overridable Function DoPartitionName (
    idx As Integer
) As String
Protected Overridable Function DoPartitionName (
    idx As Integer
) As String
protected:
virtual String^ DoPartitionName(
    int idx
)
protected:
virtual String^ DoPartitionName(
    int idx
)
abstract DoPartitionName :
        idx : int -> string
override DoPartitionName :
        idx : int -> string
abstract DoPartitionName :
        idx : int -> string
override DoPartitionName :
        idx : int -> string

Parameters

idx
Type: Online System Int32

Return Value

Type: Online String
See Also
Dimension Class
Dimension Members
NFX.Instrumentation.Analytics Namespace


Dimension.GetPartitionName Method

Dimension GetPartitionName Method NFX Class Library

Returns the name of a partition identified by idx

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetPartitionName(
    int idx
)
public string GetPartitionName(
    int idx
)
Public Function GetPartitionName (
    idx As Integer
) As String
Public Function GetPartitionName (
    idx As Integer
) As String
public:
String^ GetPartitionName(
    int idx
)
public:
String^ GetPartitionName(
    int idx
)
member GetPartitionName :
        idx : int -> string
member GetPartitionName :
        idx : int -> string

Parameters

idx
Type: Online System Int32

Return Value

Type: Online String
See Also
Dimension Class
Dimension Members
NFX.Instrumentation.Analytics Namespace


Dimension.SetIndex Method

Dimension SetIndex Method NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void SetIndex(
    int idx
)
internal void SetIndex(
    int idx
)
Friend Sub SetIndex (
    idx As Integer
)
Friend Sub SetIndex (
    idx As Integer
)
internal:
void SetIndex(
    int idx
)
internal:
void SetIndex(
    int idx
)
internal member SetIndex :
        idx : int -> unit
internal member SetIndex :
        idx : int -> unit

Parameters

idx
Type: Online System Int32
See Also
Dimension Class
Dimension Members
NFX.Instrumentation.Analytics Namespace


Dimension Properties

Dimension Properties NFX Class Library

The Dimension type exposes the following members.
Properties
 | Name | Description
Public property | DataType | Returns the type of data that this instance partitions
Public property | Index | Index of this dimension in the histogram
Back to Top
See Also
Dimension Class
NFX.Instrumentation.Analytics Namespace


Dimension.DataType Property

Dimension DataType Property NFX Class Library

Returns the type of data that this instance partitions

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Type DataType { get; }
public abstract Type DataType { get; }
Public MustOverride ReadOnly Property DataType As Type
    Get
Public MustOverride ReadOnly Property DataType As Type
    Get
public:
virtual property Type^ DataType {
    Type^ get () abstract;
}
public:
virtual property Type^ DataType {
    Type^ get () abstract;
}
abstract DataType : Type with get
abstract DataType : Type with get

Property Value

Type: Online Type
See Also
Dimension Class
Dimension Members
NFX.Instrumentation.Analytics Namespace


Dimension.Index Property

Dimension Index Property NFX Class Library

Index of this dimension in the histogram

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Index { get; }
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
Public ReadOnly Property Index As Integer
    Get
public:
property int Index {
    int get ();
}
public:
property int Index {
    int get ();
}
member Index : int with get
member Index : int with get

Property Value

Type: Online Int32
See Also
Dimension Class
Dimension Members
NFX.Instrumentation.Analytics Namespace


Dimension(TData) Class

Dimension TData Class NFX Class Library

A dimension of data type TData partitions a range of values by mapping the given value into [0 ... PartitionCount] partitions
Inheritance Hierarchy
Online System Object
NFX.Instrumentation.Analytics Dimension
NFX.Instrumentation.Analytics Dimension TData
NFX.Instrumentation.Analytics TimeDimension

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Dimension<TData> : Dimension
public class Dimension<TData> : Dimension
Public Class Dimension(Of TData)
    Inherits Dimension
Public Class Dimension(Of TData)
    Inherits Dimension
generic<typename TData>
public ref class Dimension : public Dimension
generic<typename TData>
public ref class Dimension : public Dimension
type Dimension<'TData> =
    class
        inherit Dimension
    end
type Dimension<'TData> =
    class
        inherit Dimension
    end
Type Parameters
TData
See Also
Dimension TData Members
NFX.Instrumentation.Analytics Namespace


Dimension(TData) Members

Dimension TData Members NFX Class Library

The Dimension TData type exposes the following members.
Constructors
 | Name | Description
Public method | Dimension TData | Creates a histogram dimension. If partitionFunc is null then DoPartition must be overriden in the derived class
Back to Top
Methods
 | Name | Description
Protected method | DoPartition | Override to implement a custom partitioning logic in case of class derivation when its not passed in the .ctor
Protected method | DoPartitionName | Override to implement a custom mapping logic to return the names of a given partition when its not passed in the .ctor (Inherited from Dimension.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetPartitionName | Returns the name of a partition identified by idx (Inherited from Dimension.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | SetIndex | (Inherited from Dimension.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_PartitionFunc |
Public field | Name | Provides meaningful name for displaying (Inherited from Dimension.)
Public field | PartitionCount | Number of partitions in (Inherited from Dimension.)
Back to Top
Properties
 | Name | Description
Public property | DataType | Returns the type of data that this instance partitions (Overrides Dimension DataType.)
Public property | Index | Index of this dimension in the histogram (Inherited from Dimension.)
Public property | Item | Maps a value into partition index
Back to Top
See Also
Dimension TData Class
NFX.Instrumentation.Analytics Namespace


Dimension(TData) Constructor

Dimension TData Constructor NFX Class Library

Creates a histogram dimension. If partitionFunc is null then DoPartition must be overriden in the derived class

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Dimension(
    string name,
    int partCount,
    PartitionFunc<TData> partitionFunc = null,
    PartitionNameFunc partitionNameFunc = null
)
public Dimension(
    string name,
    int partCount,
    PartitionFunc<TData> partitionFunc = null,
    PartitionNameFunc partitionNameFunc = null
)
Public Sub New (
    name As String,
    partCount As Integer,
    Optional partitionFunc As PartitionFunc(Of TData) = Nothing,
    Optional partitionNameFunc As PartitionNameFunc = Nothing
)
Public Sub New (
    name As String,
    partCount As Integer,
    Optional partitionFunc As PartitionFunc(Of TData) = Nothing,
    Optional partitionNameFunc As PartitionNameFunc = Nothing
)
public:
Dimension(
    String^ name,
    int partCount,
    PartitionFunc<TData>^ partitionFunc = nullptr,
    PartitionNameFunc^ partitionNameFunc = nullptr
)
public:
Dimension(
    String^ name,
    int partCount,
    PartitionFunc<TData>^ partitionFunc = nullptr,
    PartitionNameFunc^ partitionNameFunc = nullptr
)
new :
        name : string *
        partCount : int *
        ?partitionFunc : PartitionFunc<'TData> *
        ?partitionNameFunc : PartitionNameFunc
(* Defaults:
        let _partitionFunc = defaultArg partitionFunc null
        let _partitionNameFunc = defaultArg partitionNameFunc null
*)
-> Dimension
new :
        name : string *
        partCount : int *
        ?partitionFunc : PartitionFunc<'TData> *
        ?partitionNameFunc : PartitionNameFunc
(* Defaults:
        let _partitionFunc = defaultArg partitionFunc null
        let _partitionNameFunc = defaultArg partitionNameFunc null
*)
-> Dimension

Parameters

name
Type: Online System String
Description of dimension used in reporting
partCount
Type: Online System Int32
Total number of partitions
partitionFunc (Optional)
Type: NFX.Instrumentation.Analytics PartitionFunc TData
Used to inject a function in order not to override this class
partitionNameFunc (Optional)
Type: NFX.Instrumentation.Analytics PartitionNameFunc
Used to inject a function in order not to override this class
See Also
Dimension TData Class
Dimension TData Members
NFX.Instrumentation.Analytics Namespace


Dimension(TData) Fields

Dimension TData Fields NFX Class Library

The Dimension TData type exposes the following members.
Fields
 | Name | Description
Protected field | m_PartitionFunc |
Public field | Name | Provides meaningful name for displaying (Inherited from Dimension.)
Public field | PartitionCount | Number of partitions in (Inherited from Dimension.)
Back to Top
See Also
Dimension TData Class
NFX.Instrumentation.Analytics Namespace


Dimension(TData).m_PartitionFunc Field

Dimension TData m_PartitionFunc Field NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PartitionFunc<TData> m_PartitionFunc
protected PartitionFunc<TData> m_PartitionFunc
Protected m_PartitionFunc As PartitionFunc(Of TData)
Protected m_PartitionFunc As PartitionFunc(Of TData)
protected:
PartitionFunc<TData>^ m_PartitionFunc
protected:
PartitionFunc<TData>^ m_PartitionFunc
val mutable m_PartitionFunc: PartitionFunc<'TData>
val mutable m_PartitionFunc: PartitionFunc<'TData>

Field Value

Type: PartitionFunc TData
See Also
Dimension TData Class
Dimension TData Members
NFX.Instrumentation.Analytics Namespace


Dimension(TData) Methods

Dimension TData Methods NFX Class Library

The Dimension TData type exposes the following members.
Methods
 | Name | Description
Protected method | DoPartition | Override to implement a custom partitioning logic in case of class derivation when its not passed in the .ctor
Protected method | DoPartitionName | Override to implement a custom mapping logic to return the names of a given partition when its not passed in the .ctor (Inherited from Dimension.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetPartitionName | Returns the name of a partition identified by idx (Inherited from Dimension.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | SetIndex | (Inherited from Dimension.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Dimension TData Class
NFX.Instrumentation.Analytics Namespace


Dimension(TData).DoPartition Method

Dimension TData DoPartition Method NFX Class Library

Override to implement a custom partitioning logic in case of class derivation when its not passed in the .ctor

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual int DoPartition(
    TData value
)
protected virtual int DoPartition(
    TData value
)
Protected Overridable Function DoPartition (
    value As TData
) As Integer
Protected Overridable Function DoPartition (
    value As TData
) As Integer
protected:
virtual int DoPartition(
    TData value
)
protected:
virtual int DoPartition(
    TData value
)
abstract DoPartition :
        value : 'TData -> int
override DoPartition :
        value : 'TData -> int
abstract DoPartition :
        value : 'TData -> int
override DoPartition :
        value : 'TData -> int

Parameters

value
Type: TData

Return Value

Type: Online Int32
See Also
Dimension TData Class
Dimension TData Members
NFX.Instrumentation.Analytics Namespace


Dimension(TData) Properties

Dimension TData Properties NFX Class Library

The Dimension TData type exposes the following members.
Properties
 | Name | Description
Public property | DataType | Returns the type of data that this instance partitions (Overrides Dimension DataType.)
Public property | Index | Index of this dimension in the histogram (Inherited from Dimension.)
Public property | Item | Maps a value into partition index
Back to Top
See Also
Dimension TData Class
NFX.Instrumentation.Analytics Namespace


Dimension(TData).DataType Property

Dimension TData DataType Property NFX Class Library

Returns the type of data that this instance partitions

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Type DataType { get; }
public override Type DataType { get; }
Public Overrides ReadOnly Property DataType As Type
    Get
Public Overrides ReadOnly Property DataType As Type
    Get
public:
virtual property Type^ DataType {
    Type^ get () override;
}
public:
virtual property Type^ DataType {
    Type^ get () override;
}
abstract DataType : Type with get
override DataType : Type with get
abstract DataType : Type with get
override DataType : Type with get

Property Value

Type: Online Type
See Also
Dimension TData Class
Dimension TData Members
NFX.Instrumentation.Analytics Namespace


Dimension(TData).Item Property

Dimension TData Item Property NFX Class Library

Maps a value into partition index

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int this[
    TData value
] { get; }
public int this[
    TData value
] { get; }
Public ReadOnly Default Property Item (
    value As TData
) As Integer
    Get
Public ReadOnly Default Property Item (
    value As TData
) As Integer
    Get
public:
property int default[TData value] {
    int get (TData value);
}
public:
property int default[TData value] {
    int get (TData value);
}
member Item : int with get
member Item : int with get

Parameters

value
Type: TData

Property Value

Type: Online Int32
See Also
Dimension TData Class
Dimension TData Members
NFX.Instrumentation.Analytics Namespace


HistData Class

HistData Class NFX Class Library

Helper type representing a dictionary for storing historam data
Inheritance Hierarchy
Online System Object
Online System.Collections.Generic Dictionary HistogramKeys, HistogramEntry
NFX.Instrumentation.Analytics HistData

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class HistData : Dictionary<HistogramKeys, HistogramEntry>
public class HistData : Dictionary<HistogramKeys, HistogramEntry>
Public Class HistData
    Inherits Dictionary(Of HistogramKeys, HistogramEntry)
Public Class HistData
    Inherits Dictionary(Of HistogramKeys, HistogramEntry)
public ref class HistData : public Dictionary<HistogramKeys, HistogramEntry^>
public ref class HistData : public Dictionary<HistogramKeys, HistogramEntry^>
type HistData =
    class
        inherit Dictionary<HistogramKeys, HistogramEntry>
    end
type HistData =
    class
        inherit Dictionary<HistogramKeys, HistogramEntry>
    end
See Also
HistData Members
NFX.Instrumentation.Analytics Namespace


HistData Members

HistData Members NFX Class Library

The HistData type exposes the following members.
Constructors
 | Name | Description
Public method | HistData | Initializes a new instance of the HistData class
Back to Top
Methods
 | Name | Description
Public method | Online Add | (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Public method | Online Clear | (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Public method | Online ContainsKey | (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Public method | Online ContainsValue | (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online Dictionary TKey, TValue instance. (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Public method | Online Remove | (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TryGetValue | (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online Comparer | (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Public property | Online Count | (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Public property | Online Item | (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Public property | Online Keys | (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Public property | Online Values | (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Back to Top
See Also
HistData Class
NFX.Instrumentation.Analytics Namespace


HistData Constructor

HistData Constructor NFX Class Library

Initializes a new instance of the HistData class

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HistData(
    int capacity
)
public HistData(
    int capacity
)
Public Sub New (
    capacity As Integer
)
Public Sub New (
    capacity As Integer
)
public:
HistData(
    int capacity
)
public:
HistData(
    int capacity
)
new :
        capacity : int -> HistData
new :
        capacity : int -> HistData

Parameters

capacity
Type: Online System Int32
See Also
HistData Class
HistData Members
NFX.Instrumentation.Analytics Namespace


HistData Methods

HistData Methods NFX Class Library

The HistData type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Public method | Online Clear | (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Public method | Online ContainsKey | (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Public method | Online ContainsValue | (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online Dictionary TKey, TValue instance. (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Public method | Online Remove | (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TryGetValue | (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
HistData Class
NFX.Instrumentation.Analytics Namespace


HistData Properties

HistData Properties NFX Class Library

The HistData type exposes the following members.
Properties
 | Name | Description
Public property | Online Comparer | (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Public property | Online Count | (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Public property | Online Item | (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Public property | Online Keys | (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Public property | Online Values | (Inherited from Online Dictionary HistogramKeys, HistogramEntry .)
Back to Top
See Also
HistData Class
NFX.Instrumentation.Analytics Namespace


Histogram Class

Histogram Class NFX Class Library

Base histogram to be used by typed histogram generic derived classes. The histogram holds a dictionary of integer counts for each measurement keys (with number of keys correspondent to the number of dimensions in the histogram).
Inheritance Hierarchy
Online System Object
NFX.Instrumentation.Analytics Histogram
NFX.Instrumentation.Analytics Histogram TData1
NFX.Instrumentation.Analytics Histogram TData1, TData2
NFX.Instrumentation.Analytics Histogram TData1, TData2, TData3

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Histogram : IHistogram,
    IEnumerable<HistogramEntry>, IEnumerable
public abstract class Histogram : IHistogram,
    IEnumerable<HistogramEntry>, IEnumerable
Public MustInherit Class Histogram
    Implements IHistogram, IEnumerable(Of HistogramEntry),
    IEnumerable
Public MustInherit Class Histogram
    Implements IHistogram, IEnumerable(Of HistogramEntry),
    IEnumerable
public ref class Histogram abstract : IHistogram,
    IEnumerable<HistogramEntry^>, IEnumerable
public ref class Histogram abstract : IHistogram,
    IEnumerable<HistogramEntry^>, IEnumerable
[<AbstractClassAttribute>]
type Histogram =
    class
        interface IHistogram
        interface IEnumerable<HistogramEntry>
        interface IEnumerable
    end
[<AbstractClassAttribute>]
type Histogram =
    class
        interface IHistogram
        interface IEnumerable<HistogramEntry>
        interface IEnumerable
    end
See Also
Histogram Members
NFX.Instrumentation.Analytics Namespace


Histogram Members

Histogram Members NFX Class Library

The Histogram type exposes the following members.
Constructors
 | Name | Description
Protected method | Histogram | Initializes a new instance of the Histogram class
Back to Top
Methods
 | Name | Description
Public method | Clear | Reset histogram state
Protected method | DoSample |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDimention | Return a dimension of a histogram identified by index
Public method | GetEnumerator |
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | GetPartitionName | Returns the name of a partition in a given histogram dimension
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Public method | TryGet | Try to get the count of samples for the given histogram keys
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable HistogramEntry | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct HistogramEntry, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax HistogramEntry, TComparand (Func HistogramEntry, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax HistogramEntry, TComparand (Func HistogramEntry, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin HistogramEntry, TComparand (Func HistogramEntry, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin HistogramEntry, TComparand (Func HistogramEntry, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault HistogramEntry | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach HistogramEntry (Action HistogramEntry ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach HistogramEntry (Action HistogramEntry, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast HistogramEntry | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast HistogramEntry (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToStringReport | (Defined by HistogramReporters.)
Back to Top
Fields
 | Name | Description
Protected field | m_Data |
Protected field | m_Title |
Protected field | m_TotalSamples |
Back to Top
Properties
 | Name | Description
Public property | DimensionCount | Number of dimensions in this histogram
Public property | Dimensions | Returns the dimension instances of this histogram
Protected property | Item Int32 |
Public property | Item HistogramKeys | Return the count of samples for the given histogram keys
Public property | Title | Histogram title used for displaying purposes
Public property | TotalSamples | Total number of samples in the histogram
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
Histogram Class
NFX.Instrumentation.Analytics Namespace


Histogram Constructor

Histogram Constructor NFX Class Library

Initializes a new instance of the Histogram class

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Histogram(
    string title,
    int dimCount,
    int approxCapacity
)
protected Histogram(
    string title,
    int dimCount,
    int approxCapacity
)
Protected Sub New (
    title As String,
    dimCount As Integer,
    approxCapacity As Integer
)
Protected Sub New (
    title As String,
    dimCount As Integer,
    approxCapacity As Integer
)
protected:
Histogram(
    String^ title,
    int dimCount,
    int approxCapacity
)
protected:
Histogram(
    String^ title,
    int dimCount,
    int approxCapacity
)
new :
        title : string *
        dimCount : int *
        approxCapacity : int -> Histogram
new :
        title : string *
        dimCount : int *
        approxCapacity : int -> Histogram

Parameters

title
Type: Online System String
dimCount
Type: Online System Int32
approxCapacity
Type: Online System Int32
See Also
Histogram Class
Histogram Members
NFX.Instrumentation.Analytics Namespace


Histogram Fields

Histogram Fields NFX Class Library

The Histogram type exposes the following members.
Fields
 | Name | Description
Protected field | m_Data |
Protected field | m_Title |
Protected field | m_TotalSamples |
Back to Top
See Also
Histogram Class
NFX.Instrumentation.Analytics Namespace


Histogram.m_Data Field

Histogram m_Data Field NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected HistData m_Data
protected HistData m_Data
Protected m_Data As HistData
Protected m_Data As HistData
protected:
HistData^ m_Data
protected:
HistData^ m_Data
val mutable m_Data: HistData
val mutable m_Data: HistData

Field Value

Type: HistData
See Also
Histogram Class
Histogram Members
NFX.Instrumentation.Analytics Namespace


Histogram.m_Title Field

Histogram m_Title Field NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected string m_Title
protected string m_Title
Protected m_Title As String
Protected m_Title As String
protected:
String^ m_Title
protected:
String^ m_Title
val mutable m_Title: string
val mutable m_Title: string

Field Value

Type: Online String
See Also
Histogram Class
Histogram Members
NFX.Instrumentation.Analytics Namespace


Histogram.m_TotalSamples Field

Histogram m_TotalSamples Field NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected long m_TotalSamples
protected long m_TotalSamples
Protected m_TotalSamples As Long
Protected m_TotalSamples As Long
protected:
long long m_TotalSamples
protected:
long long m_TotalSamples
val mutable m_TotalSamples: int64
val mutable m_TotalSamples: int64

Field Value

Type: Online Int64
See Also
Histogram Class
Histogram Members
NFX.Instrumentation.Analytics Namespace


Histogram Methods

Histogram Methods NFX Class Library

The Histogram type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Reset histogram state
Protected method | DoSample |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDimention | Return a dimension of a histogram identified by index
Public method | GetEnumerator |
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | GetPartitionName | Returns the name of a partition in a given histogram dimension
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Public method | TryGet | Try to get the count of samples for the given histogram keys
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable HistogramEntry | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct HistogramEntry, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax HistogramEntry, TComparand (Func HistogramEntry, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax HistogramEntry, TComparand (Func HistogramEntry, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin HistogramEntry, TComparand (Func HistogramEntry, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin HistogramEntry, TComparand (Func HistogramEntry, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault HistogramEntry | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach HistogramEntry (Action HistogramEntry ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach HistogramEntry (Action HistogramEntry, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast HistogramEntry | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast HistogramEntry (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToStringReport | (Defined by HistogramReporters.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
Histogram Class
NFX.Instrumentation.Analytics Namespace


Histogram.IEnumerable.GetEnumerator Method

Histogram IEnumerable GetEnumerator Method NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
Histogram Class
Histogram Members
NFX.Instrumentation.Analytics Namespace


Histogram.Clear Method

Histogram Clear Method NFX Class Library

Reset histogram state

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Clear()
public virtual void Clear()
Public Overridable Sub Clear
Public Overridable Sub Clear
public:
virtual void Clear()
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

IHistogram Clear
See Also
Histogram Class
Histogram Members
NFX.Instrumentation.Analytics Namespace


Histogram.DoSample Method

Histogram DoSample Method NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void DoSample(
    HistogramKeys keys
)
internal void DoSample(
    HistogramKeys keys
)
Friend Sub DoSample (
    keys As HistogramKeys
)
Friend Sub DoSample (
    keys As HistogramKeys
)
internal:
void DoSample(
    HistogramKeys keys
)
internal:
void DoSample(
    HistogramKeys keys
)
internal member DoSample :
        keys : HistogramKeys -> unit
internal member DoSample :
        keys : HistogramKeys -> unit

Parameters

keys
Type: NFX.Instrumentation.Analytics HistogramKeys
See Also
Histogram Class
Histogram Members
NFX.Instrumentation.Analytics Namespace


Histogram.GetDimention Method

Histogram GetDimention Method NFX Class Library

Return a dimension of a histogram identified by index

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Dimension GetDimention(
    int dimension
)
public Dimension GetDimention(
    int dimension
)
Public Function GetDimention (
    dimension As Integer
) As Dimension
Public Function GetDimention (
    dimension As Integer
) As Dimension
public:
virtual Dimension^ GetDimention(
    int dimension
) sealed
public:
virtual Dimension^ GetDimention(
    int dimension
) sealed
abstract GetDimention :
        dimension : int -> Dimension
override GetDimention :
        dimension : int -> Dimension
abstract GetDimention :
        dimension : int -> Dimension
override GetDimention :
        dimension : int -> Dimension

Parameters

dimension
Type: Online System Int32

Return Value

Type: Dimension

Implements

IHistogram GetDimention(Int32)
See Also
Histogram Class
Histogram Members
NFX.Instrumentation.Analytics Namespace


Histogram.GetEnumerator Method

Histogram GetEnumerator Method NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<HistogramEntry> GetEnumerator()
public IEnumerator<HistogramEntry> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of HistogramEntry)
Public Function GetEnumerator As IEnumerator(Of HistogramEntry)
public:
virtual IEnumerator<HistogramEntry^>^ GetEnumerator() sealed
public:
virtual IEnumerator<HistogramEntry^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<HistogramEntry>
override GetEnumerator : unit -> IEnumerator<HistogramEntry>
abstract GetEnumerator : unit -> IEnumerator<HistogramEntry>
override GetEnumerator : unit -> IEnumerator<HistogramEntry>

Return Value

Type: Online IEnumerator HistogramEntry

Implements

Online IEnumerable T GetEnumerator
See Also
Histogram Class
Histogram Members
NFX.Instrumentation.Analytics Namespace


Histogram.GetHashCode Method

Histogram GetHashCode Method NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
Histogram Class
Histogram Members
NFX.Instrumentation.Analytics Namespace


Histogram.GetPartitionName Method

Histogram GetPartitionName Method NFX Class Library

Returns the name of a partition in a given histogram dimension

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetPartitionName(
    int dimension,
    int partition
)
public string GetPartitionName(
    int dimension,
    int partition
)
Public Function GetPartitionName (
    dimension As Integer,
    partition As Integer
) As String
Public Function GetPartitionName (
    dimension As Integer,
    partition As Integer
) As String
public:
virtual String^ GetPartitionName(
    int dimension,
    int partition
) sealed
public:
virtual String^ GetPartitionName(
    int dimension,
    int partition
) sealed
abstract GetPartitionName :
        dimension : int *
        partition : int -> string
override GetPartitionName :
        dimension : int *
        partition : int -> string
abstract GetPartitionName :
        dimension : int *
        partition : int -> string
override GetPartitionName :
        dimension : int *
        partition : int -> string

Parameters

dimension
Type: Online System Int32
Dimension index
partition
Type: Online System Int32
Partition index

Return Value

Type: Online String

Implements

IHistogram GetPartitionName(Int32, Int32)
See Also
Histogram Class
Histogram Members
NFX.Instrumentation.Analytics Namespace


Histogram.ToString Method

Histogram ToString Method NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
Histogram Class
Histogram Members
NFX.Instrumentation.Analytics Namespace


Histogram.TryGet Method

Histogram TryGet Method NFX Class Library

Try to get the count of samples for the given histogram keys

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TryGet(
    HistogramKeys keys,
    out int count
)
public bool TryGet(
    HistogramKeys keys,
    out int count
)
Public Function TryGet (
    keys As HistogramKeys,
    <OutAttribute> ByRef count As Integer
) As Boolean
Public Function TryGet (
    keys As HistogramKeys,
    <OutAttribute> ByRef count As Integer
) As Boolean
public:
virtual bool TryGet(
    HistogramKeys keys,
    [OutAttribute] int% count
) sealed
public:
virtual bool TryGet(
    HistogramKeys keys,
    [OutAttribute] int% count
) sealed
abstract TryGet :
        keys : HistogramKeys *
        count : int byref -> bool
override TryGet :
        keys : HistogramKeys *
        count : int byref -> bool
abstract TryGet :
        keys : HistogramKeys *
        count : int byref -> bool
override TryGet :
        keys : HistogramKeys *
        count : int byref -> bool

Parameters

keys
Type: NFX.Instrumentation.Analytics HistogramKeys
count
Type: Online System Int32

Return Value

Type: Online Boolean

Implements

IHistogram TryGet(HistogramKeys, Int32 )
See Also
Histogram Class
Histogram Members
NFX.Instrumentation.Analytics Namespace


Histogram Properties

Histogram Properties NFX Class Library

The Histogram type exposes the following members.
Properties
 | Name | Description
Public property | DimensionCount | Number of dimensions in this histogram
Public property | Dimensions | Returns the dimension instances of this histogram
Protected property | Item Int32 |
Public property | Item HistogramKeys | Return the count of samples for the given histogram keys
Public property | Title | Histogram title used for displaying purposes
Public property | TotalSamples | Total number of samples in the histogram
Back to Top
See Also
Histogram Class
NFX.Instrumentation.Analytics Namespace


Histogram.DimensionCount Property

Histogram DimensionCount Property NFX Class Library

Number of dimensions in this histogram

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int DimensionCount { get; }
public abstract int DimensionCount { get; }
Public MustOverride ReadOnly Property DimensionCount As Integer
    Get
Public MustOverride ReadOnly Property DimensionCount As Integer
    Get
public:
virtual property int DimensionCount {
    int get () abstract;
}
public:
virtual property int DimensionCount {
    int get () abstract;
}
abstract DimensionCount : int with get
abstract DimensionCount : int with get

Property Value

Type: Online Int32

Implements

IHistogram DimensionCount
See Also
Histogram Class
Histogram Members
NFX.Instrumentation.Analytics Namespace


Histogram.Dimensions Property

Histogram Dimensions Property NFX Class Library

Returns the dimension instances of this histogram

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract IEnumerable<Dimension> Dimensions { get; }
public abstract IEnumerable<Dimension> Dimensions { get; }
Public MustOverride ReadOnly Property Dimensions As IEnumerable(Of Dimension)
    Get
Public MustOverride ReadOnly Property Dimensions As IEnumerable(Of Dimension)
    Get
public:
virtual property IEnumerable<Dimension^>^ Dimensions {
    IEnumerable<Dimension^>^ get () abstract;
}
public:
virtual property IEnumerable<Dimension^>^ Dimensions {
    IEnumerable<Dimension^>^ get () abstract;
}
abstract Dimensions : IEnumerable<Dimension> with get
abstract Dimensions : IEnumerable<Dimension> with get

Property Value

Type: Online IEnumerable Dimension

Implements

IHistogram Dimensions
See Also
Histogram Class
Histogram Members
NFX.Instrumentation.Analytics Namespace


Histogram.Item Property

Histogram Item Property NFX Class Library

Overload List
 | Name | Description
Protected property | Item Int32 |
Public property | Item HistogramKeys | Return the count of samples for the given histogram keys
Back to Top
See Also
Histogram Class
Histogram Members
NFX.Instrumentation.Analytics Namespace


Histogram.Item Property (Int32)

Histogram Item Property (Int32) NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Dimension this[
    int dimIndex
] { get; }
protected Dimension this[
    int dimIndex
] { get; }
Protected ReadOnly Default Property Item (
    dimIndex As Integer
) As Dimension
    Get
Protected ReadOnly Default Property Item (
    dimIndex As Integer
) As Dimension
    Get
protected:
property Dimension^ default[int dimIndex] {
    Dimension^ get (int dimIndex);
}
protected:
property Dimension^ default[int dimIndex] {
    Dimension^ get (int dimIndex);
}
member Item : Dimension with get
member Item : Dimension with get

Parameters

dimIndex
Type: Online System Int32

Property Value

Type: Dimension
See Also
Histogram Class
Histogram Members
Item Overload
NFX.Instrumentation.Analytics Namespace


Histogram.Item Property (HistogramKeys)

Histogram Item Property (HistogramKeys) NFX Class Library

Return the count of samples for the given histogram keys

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int this[
    HistogramKeys keys
] { get; }
public int this[
    HistogramKeys keys
] { get; }
Public ReadOnly Default Property Item (
    keys As HistogramKeys
) As Integer
    Get
Public ReadOnly Default Property Item (
    keys As HistogramKeys
) As Integer
    Get
public:
virtual property int default[HistogramKeys keys] {
    int get (HistogramKeys keys) sealed;
}
public:
virtual property int default[HistogramKeys keys] {
    int get (HistogramKeys keys) sealed;
}
abstract Item : int with get
override Item : int with get
abstract Item : int with get
override Item : int with get

Parameters

keys
Type: NFX.Instrumentation.Analytics HistogramKeys

Property Value

Type: Online Int32

Implements

IHistogram Item HistogramKeys
See Also
Histogram Class
Histogram Members
Item Overload
NFX.Instrumentation.Analytics Namespace


Histogram.Title Property

Histogram Title Property NFX Class Library

Histogram title used for displaying purposes

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Title { get; }
public virtual string Title { get; }
Public Overridable ReadOnly Property Title As String
    Get
Public Overridable ReadOnly Property Title As String
    Get
public:
virtual property String^ Title {
    String^ get ();
}
public:
virtual property String^ Title {
    String^ get ();
}
abstract Title : string with get
override Title : string with get
abstract Title : string with get
override Title : string with get

Property Value

Type: Online String

Implements

IHistogram Title
See Also
Histogram Class
Histogram Members
NFX.Instrumentation.Analytics Namespace


Histogram.TotalSamples Property

Histogram TotalSamples Property NFX Class Library

Total number of samples in the histogram

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long TotalSamples { get; }
public long TotalSamples { get; }
Public ReadOnly Property TotalSamples As Long
    Get
Public ReadOnly Property TotalSamples As Long
    Get
public:
virtual property long long TotalSamples {
    long long get () sealed;
}
public:
virtual property long long TotalSamples {
    long long get () sealed;
}
abstract TotalSamples : int64 with get
override TotalSamples : int64 with get
abstract TotalSamples : int64 with get
override TotalSamples : int64 with get

Property Value

Type: Online Int64

Implements

IHistogram TotalSamples
See Also
Histogram Class
Histogram Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1) Class

Histogram TData1 Class NFX Class Library

One-dimensional histogram for storing number of samples for a given dimension key
Inheritance Hierarchy
Online System Object
NFX.Instrumentation.Analytics Histogram
NFX.Instrumentation.Analytics Histogram TData1

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Histogram<TData1> : Histogram
public class Histogram<TData1> : Histogram
Public Class Histogram(Of TData1)
    Inherits Histogram
Public Class Histogram(Of TData1)
    Inherits Histogram
generic<typename TData1>
public ref class Histogram : public Histogram
generic<typename TData1>
public ref class Histogram : public Histogram
type Histogram<'TData1> =
    class
        inherit Histogram
    end
type Histogram<'TData1> =
    class
        inherit Histogram
    end
Type Parameters
TData1
See Also
Histogram TData1 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1) Members

Histogram TData1 Members NFX Class Library

The Histogram TData1 type exposes the following members.
Constructors
 | Name | Description
Public method | Histogram TData1 | Constructs a histogram from a given array of dimensions
Back to Top
Methods
 | Name | Description
Public method | Clear | Reset histogram state (Inherited from Histogram.)
Protected method | DoSample | (Inherited from Histogram.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDimention | Return a dimension of a histogram identified by index (Inherited from Histogram.)
Public method | GetEnumerator | (Inherited from Histogram.)
Public method | GetHashCode | (Inherited from Histogram.)
Public method | GetPartitionName | Returns the name of a partition in a given histogram dimension (Inherited from Histogram.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Keys | Convert a value to HistogramKeys struct
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Sample | Increment histogram statistics for a given dimension value
Public method | ToString | (Inherited from Histogram.)
Public method | TryGet(Int32, Int32 ) | Try to get the sample count associated with the given histogram key. If the key is not present in the histogram dictionary return false
Public method | TryGet(HistogramKeys, Int32 ) | Try to get the count of samples for the given histogram keys (Inherited from Histogram.)
Public method | Value | Returns number of samples collected for a given key. The key is obtained by mapping the given value into the dimension's partition. Return value of 0 indicates that key is not present in the histogram
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Data | (Inherited from Histogram.)
Protected field | m_Dimension1 |
Protected field | m_Title | (Inherited from Histogram.)
Protected field | m_TotalSamples | (Inherited from Histogram.)
Back to Top
Properties
 | Name | Description
Public property | DimensionCount | Number of dimensions in this histogram (Overrides Histogram DimensionCount.)
Public property | Dimensions | (Overrides Histogram Dimensions.)
Public property | Item Int32 | Return the sample count associated with given histogram keys
Public property | Item HistogramKeys | Return the count of samples for the given histogram keys (Inherited from Histogram.)
Public property | Title | Histogram title used for displaying purposes (Inherited from Histogram.)
Public property | TotalSamples | Total number of samples in the histogram (Inherited from Histogram.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Histogram.)
Back to Top
See Also
Histogram TData1 Class
NFX.Instrumentation.Analytics Namespace


Histogram(TData1) Constructor

Histogram TData1 Constructor NFX Class Library

Constructs a histogram from a given array of dimensions

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Histogram(
    string title,
    Dimension<TData1> dimension1
)
public Histogram(
    string title,
    Dimension<TData1> dimension1
)
Public Sub New (
    title As String,
    dimension1 As Dimension(Of TData1)
)
Public Sub New (
    title As String,
    dimension1 As Dimension(Of TData1)
)
public:
Histogram(
    String^ title,
    Dimension<TData1>^ dimension1
)
public:
Histogram(
    String^ title,
    Dimension<TData1>^ dimension1
)
new :
        title : string *
        dimension1 : Dimension<'TData1> -> Histogram
new :
        title : string *
        dimension1 : Dimension<'TData1> -> Histogram

Parameters

title
Type: Online System String
Histogram title used for displaying result
dimension1
Type: NFX.Instrumentation.Analytics Dimension TData1
Dimension of the histogram dimension
See Also
Histogram TData1 Class
Histogram TData1 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1) Fields

Histogram TData1 Fields NFX Class Library

The Histogram TData1 type exposes the following members.
Fields
 | Name | Description
Protected field | m_Data | (Inherited from Histogram.)
Protected field | m_Dimension1 |
Protected field | m_Title | (Inherited from Histogram.)
Protected field | m_TotalSamples | (Inherited from Histogram.)
Back to Top
See Also
Histogram TData1 Class
NFX.Instrumentation.Analytics Namespace


Histogram(TData1).m_Dimension1 Field

Histogram TData1 m_Dimension1 Field NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Dimension<TData1> m_Dimension1
protected Dimension<TData1> m_Dimension1
Protected m_Dimension1 As Dimension(Of TData1)
Protected m_Dimension1 As Dimension(Of TData1)
protected:
Dimension<TData1>^ m_Dimension1
protected:
Dimension<TData1>^ m_Dimension1
val mutable m_Dimension1: Dimension<'TData1>
val mutable m_Dimension1: Dimension<'TData1>

Field Value

Type: Dimension TData1
See Also
Histogram TData1 Class
Histogram TData1 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1) Methods

Histogram TData1 Methods NFX Class Library

The Histogram TData1 type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Reset histogram state (Inherited from Histogram.)
Protected method | DoSample | (Inherited from Histogram.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDimention | Return a dimension of a histogram identified by index (Inherited from Histogram.)
Public method | GetEnumerator | (Inherited from Histogram.)
Public method | GetHashCode | (Inherited from Histogram.)
Public method | GetPartitionName | Returns the name of a partition in a given histogram dimension (Inherited from Histogram.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Keys | Convert a value to HistogramKeys struct
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Sample | Increment histogram statistics for a given dimension value
Public method | ToString | (Inherited from Histogram.)
Public method | TryGet(Int32, Int32 ) | Try to get the sample count associated with the given histogram key. If the key is not present in the histogram dictionary return false
Public method | TryGet(HistogramKeys, Int32 ) | Try to get the count of samples for the given histogram keys (Inherited from Histogram.)
Public method | Value | Returns number of samples collected for a given key. The key is obtained by mapping the given value into the dimension's partition. Return value of 0 indicates that key is not present in the histogram
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Histogram.)
Back to Top
See Also
Histogram TData1 Class
NFX.Instrumentation.Analytics Namespace


Histogram(TData1).Keys Method

Histogram TData1 Keys Method NFX Class Library

Convert a value to HistogramKeys struct

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HistogramKeys Keys(
    TData1 value
)
public HistogramKeys Keys(
    TData1 value
)
Public Function Keys (
    value As TData1
) As HistogramKeys
Public Function Keys (
    value As TData1
) As HistogramKeys
public:
HistogramKeys Keys(
    TData1 value
)
public:
HistogramKeys Keys(
    TData1 value
)
member Keys :
        value : 'TData1 -> HistogramKeys
member Keys :
        value : 'TData1 -> HistogramKeys

Parameters

value
Type: TData1

Return Value

Type: HistogramKeys
See Also
Histogram TData1 Class
Histogram TData1 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1).Sample Method

Histogram TData1 Sample Method NFX Class Library

Increment histogram statistics for a given dimension value

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Sample(
    TData1 value
)
public virtual void Sample(
    TData1 value
)
Public Overridable Sub Sample (
    value As TData1
)
Public Overridable Sub Sample (
    value As TData1
)
public:
virtual void Sample(
    TData1 value
)
public:
virtual void Sample(
    TData1 value
)
abstract Sample :
        value : 'TData1 -> unit
override Sample :
        value : 'TData1 -> unit
abstract Sample :
        value : 'TData1 -> unit
override Sample :
        value : 'TData1 -> unit

Parameters

value
Type: TData1
See Also
Histogram TData1 Class
Histogram TData1 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1).TryGet Method

Histogram TData1 TryGet Method NFX Class Library

Overload List
 | Name | Description
Public method | TryGet(Int32, Int32 ) | Try to get the sample count associated with the given histogram key. If the key is not present in the histogram dictionary return false
Public method | TryGet(HistogramKeys, Int32 ) | Try to get the count of samples for the given histogram keys (Inherited from Histogram.)
Back to Top
See Also
Histogram TData1 Class
Histogram TData1 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1).TryGet Method (Int32, Int32)

Histogram TData1 TryGet Method (Int32, Int32 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Try to get the sample count associated with the given histogram key. If the key is not present in the histogram dictionary return false

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TryGet(
    int key,
    out int count
)
public bool TryGet(
    int key,
    out int count
)
Public Function TryGet (
    key As Integer,
    <OutAttribute> ByRef count As Integer
) As Boolean
Public Function TryGet (
    key As Integer,
    <OutAttribute> ByRef count As Integer
) As Boolean
public:
bool TryGet(
    int key,
    [OutAttribute] int% count
)
public:
bool TryGet(
    int key,
    [OutAttribute] int% count
)
member TryGet :
        key : int *
        count : int byref -> bool
member TryGet :
        key : int *
        count : int byref -> bool

Parameters

key
Type: Online System Int32
count
Type: Online System Int32

Return Value

Type: Online Boolean
See Also
Histogram TData1 Class
Histogram TData1 Members
TryGet Overload
NFX.Instrumentation.Analytics Namespace


Histogram(TData1).Value Method

Histogram TData1 Value Method NFX Class Library

Returns number of samples collected for a given key. The key is obtained by mapping the given value into the dimension's partition. Return value of 0 indicates that key is not present in the histogram

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Value(
    TData1 value
)
public int Value(
    TData1 value
)
Public Function Value (
    value As TData1
) As Integer
Public Function Value (
    value As TData1
) As Integer
public:
int Value(
    TData1 value
)
public:
int Value(
    TData1 value
)
member Value :
        value : 'TData1 -> int
member Value :
        value : 'TData1 -> int

Parameters

value
Type: TData1

Return Value

Type: Online Int32
See Also
Histogram TData1 Class
Histogram TData1 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1) Properties

Histogram TData1 Properties NFX Class Library

The Histogram TData1 type exposes the following members.
Properties
 | Name | Description
Public property | DimensionCount | Number of dimensions in this histogram (Overrides Histogram DimensionCount.)
Public property | Dimensions | (Overrides Histogram Dimensions.)
Public property | Item Int32 | Return the sample count associated with given histogram keys
Public property | Item HistogramKeys | Return the count of samples for the given histogram keys (Inherited from Histogram.)
Public property | Title | Histogram title used for displaying purposes (Inherited from Histogram.)
Public property | TotalSamples | Total number of samples in the histogram (Inherited from Histogram.)
Back to Top
See Also
Histogram TData1 Class
NFX.Instrumentation.Analytics Namespace


Histogram(TData1).DimensionCount Property

Histogram TData1 DimensionCount Property NFX Class Library

Number of dimensions in this histogram

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int DimensionCount { get; }
public override int DimensionCount { get; }
Public Overrides ReadOnly Property DimensionCount As Integer
    Get
Public Overrides ReadOnly Property DimensionCount As Integer
    Get
public:
virtual property int DimensionCount {
    int get () override;
}
public:
virtual property int DimensionCount {
    int get () override;
}
abstract DimensionCount : int with get
override DimensionCount : int with get
abstract DimensionCount : int with get
override DimensionCount : int with get

Property Value

Type: Online Int32

Implements

IHistogram DimensionCount
See Also
Histogram TData1 Class
Histogram TData1 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1).Dimensions Property

Histogram TData1 Dimensions Property NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IEnumerable<Dimension> Dimensions { get; }
public override IEnumerable<Dimension> Dimensions { get; }
Public Overrides ReadOnly Property Dimensions As IEnumerable(Of Dimension)
    Get
Public Overrides ReadOnly Property Dimensions As IEnumerable(Of Dimension)
    Get
public:
virtual property IEnumerable<Dimension^>^ Dimensions {
    IEnumerable<Dimension^>^ get () override;
}
public:
virtual property IEnumerable<Dimension^>^ Dimensions {
    IEnumerable<Dimension^>^ get () override;
}
abstract Dimensions : IEnumerable<Dimension> with get
override Dimensions : IEnumerable<Dimension> with get
abstract Dimensions : IEnumerable<Dimension> with get
override Dimensions : IEnumerable<Dimension> with get

Property Value

Type: Online IEnumerable Dimension

Implements

IHistogram Dimensions
See Also
Histogram TData1 Class
Histogram TData1 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1).Item Property

Histogram TData1 Item Property NFX Class Library

Overload List
 | Name | Description
Public property | Item Int32 | Return the sample count associated with given histogram keys
Public property | Item HistogramKeys | Return the count of samples for the given histogram keys (Inherited from Histogram.)
Back to Top
See Also
Histogram TData1 Class
Histogram TData1 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1).Item Property (Int32)

Histogram TData1 Item Property (Int32) NFX Class Library

Return the sample count associated with given histogram keys

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int this[
    int key
] { get; }
public int this[
    int key
] { get; }
Public ReadOnly Default Property Item (
    key As Integer
) As Integer
    Get
Public ReadOnly Default Property Item (
    key As Integer
) As Integer
    Get
public:
property int default[int key] {
    int get (int key);
}
public:
property int default[int key] {
    int get (int key);
}
member Item : int with get
member Item : int with get

Parameters

key
Type: Online System Int32

Property Value

Type: Online Int32
See Also
Histogram TData1 Class
Histogram TData1 Members
Item Overload
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2) Class

Histogram TData1, TData2 Class NFX Class Library

Two-dimensional histogram for storing number of samples for given dimension keys
Inheritance Hierarchy
Online System Object
NFX.Instrumentation.Analytics Histogram
NFX.Instrumentation.Analytics Histogram TData1, TData2

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Histogram<TData1, TData2> : Histogram
public class Histogram<TData1, TData2> : Histogram
Public Class Histogram(Of TData1, TData2)
    Inherits Histogram
Public Class Histogram(Of TData1, TData2)
    Inherits Histogram
generic<typename TData1, typename TData2>
public ref class Histogram : public Histogram
generic<typename TData1, typename TData2>
public ref class Histogram : public Histogram
type Histogram<'TData1, 'TData2> =
    class
        inherit Histogram
    end
type Histogram<'TData1, 'TData2> =
    class
        inherit Histogram
    end
Type Parameters
TData1
TData2
See Also
Histogram TData1, TData2 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2) Members

Histogram TData1, TData2 Members NFX Class Library

The Histogram TData1, TData2 type exposes the following members.
Constructors
 | Name | Description
Public method | Histogram TData1, TData2 | Constructs a histogram from a given array of dimensions
Back to Top
Methods
 | Name | Description
Public method | Clear | Reset histogram state (Inherited from Histogram.)
Protected method | DoSample | (Inherited from Histogram.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDimention | Return a dimension of a histogram identified by index (Inherited from Histogram.)
Public method | GetEnumerator | (Inherited from Histogram.)
Public method | GetHashCode | (Inherited from Histogram.)
Public method | GetPartitionName | Returns the name of a partition in a given histogram dimension (Inherited from Histogram.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Keys | Convert values to HistogramKeys struct
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Sample | Increment histogram statistics for a given pair of dimension values
Public method | ToString | (Inherited from Histogram.)
Public method | TryGet(HistogramKeys, Int32 ) | Try to get the count of samples for the given histogram keys (Inherited from Histogram.)
Public method | TryGet(Int32, Int32, Int32 ) | Try to get the sample count associated with the given histogram keys. If the keys are not present in the histogram dictionary return false
Public method | Value | Returns number of samples collected for a given key. The key is obtained by mapping the given values into the dimensions' partitions. Return value of 0 indicates that key is not present in the histogram
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Data | (Inherited from Histogram.)
Protected field | m_Dimension1 |
Protected field | m_Dimension2 |
Protected field | m_Title | (Inherited from Histogram.)
Protected field | m_TotalSamples | (Inherited from Histogram.)
Back to Top
Properties
 | Name | Description
Public property | DimensionCount | Number of dimensions in this histogram (Overrides Histogram DimensionCount.)
Public property | Dimensions | (Overrides Histogram Dimensions.)
Protected property | Item Int32 | (Inherited from Histogram.)
Public property | Item HistogramKeys | Return the count of samples for the given histogram keys (Inherited from Histogram.)
Public property | Item Int32, Int32 | Return the sample count associated with given histogram keys
Public property | Title | Histogram title used for displaying purposes (Inherited from Histogram.)
Public property | TotalSamples | Total number of samples in the histogram (Inherited from Histogram.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Histogram.)
Back to Top
See Also
Histogram TData1, TData2 Class
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2) Constructor

Histogram TData1, TData2 Constructor NFX Class Library

Constructs a histogram from a given array of dimensions

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Histogram(
    string title,
    Dimension<TData1> dimension1,
    Dimension<TData2> dimension2
)
public Histogram(
    string title,
    Dimension<TData1> dimension1,
    Dimension<TData2> dimension2
)
Public Sub New (
    title As String,
    dimension1 As Dimension(Of TData1),
    dimension2 As Dimension(Of TData2)
)
Public Sub New (
    title As String,
    dimension1 As Dimension(Of TData1),
    dimension2 As Dimension(Of TData2)
)
public:
Histogram(
    String^ title,
    Dimension<TData1>^ dimension1,
    Dimension<TData2>^ dimension2
)
public:
Histogram(
    String^ title,
    Dimension<TData1>^ dimension1,
    Dimension<TData2>^ dimension2
)
new :
        title : string *
        dimension1 : Dimension<'TData1> *
        dimension2 : Dimension<'TData2> -> Histogram
new :
        title : string *
        dimension1 : Dimension<'TData1> *
        dimension2 : Dimension<'TData2> -> Histogram

Parameters

title
Type: Online System String
Histogram title used for displaying result
dimension1
Type: NFX.Instrumentation.Analytics Dimension TData1
Dimension of the 1st histogram dimension
dimension2
Type: NFX.Instrumentation.Analytics Dimension TData2
Dimension of the 2nd histogram dimension
See Also
Histogram TData1, TData2 Class
Histogram TData1, TData2 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2) Fields

Histogram TData1, TData2 Fields NFX Class Library

The Histogram TData1, TData2 type exposes the following members.
Fields
 | Name | Description
Protected field | m_Data | (Inherited from Histogram.)
Protected field | m_Dimension1 |
Protected field | m_Dimension2 |
Protected field | m_Title | (Inherited from Histogram.)
Protected field | m_TotalSamples | (Inherited from Histogram.)
Back to Top
See Also
Histogram TData1, TData2 Class
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2).m_Dimension1 Field

Histogram TData1, TData2 m_Dimension1 Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Dimension<TData1> m_Dimension1
protected Dimension<TData1> m_Dimension1
Protected m_Dimension1 As Dimension(Of TData1)
Protected m_Dimension1 As Dimension(Of TData1)
protected:
Dimension<TData1>^ m_Dimension1
protected:
Dimension<TData1>^ m_Dimension1
val mutable m_Dimension1: Dimension<'TData1>
val mutable m_Dimension1: Dimension<'TData1>

Field Value

Type: Dimension TData1
See Also
Histogram TData1, TData2 Class
Histogram TData1, TData2 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2).m_Dimension2 Field

Histogram TData1, TData2 m_Dimension2 Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Dimension<TData2> m_Dimension2
protected Dimension<TData2> m_Dimension2
Protected m_Dimension2 As Dimension(Of TData2)
Protected m_Dimension2 As Dimension(Of TData2)
protected:
Dimension<TData2>^ m_Dimension2
protected:
Dimension<TData2>^ m_Dimension2
val mutable m_Dimension2: Dimension<'TData2>
val mutable m_Dimension2: Dimension<'TData2>

Field Value

Type: Dimension TData2
See Also
Histogram TData1, TData2 Class
Histogram TData1, TData2 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2) Methods

Histogram TData1, TData2 Methods NFX Class Library

The Histogram TData1, TData2 type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Reset histogram state (Inherited from Histogram.)
Protected method | DoSample | (Inherited from Histogram.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDimention | Return a dimension of a histogram identified by index (Inherited from Histogram.)
Public method | GetEnumerator | (Inherited from Histogram.)
Public method | GetHashCode | (Inherited from Histogram.)
Public method | GetPartitionName | Returns the name of a partition in a given histogram dimension (Inherited from Histogram.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Keys | Convert values to HistogramKeys struct
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Sample | Increment histogram statistics for a given pair of dimension values
Public method | ToString | (Inherited from Histogram.)
Public method | TryGet(HistogramKeys, Int32 ) | Try to get the count of samples for the given histogram keys (Inherited from Histogram.)
Public method | TryGet(Int32, Int32, Int32 ) | Try to get the sample count associated with the given histogram keys. If the keys are not present in the histogram dictionary return false
Public method | Value | Returns number of samples collected for a given key. The key is obtained by mapping the given values into the dimensions' partitions. Return value of 0 indicates that key is not present in the histogram
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Histogram.)
Back to Top
See Also
Histogram TData1, TData2 Class
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2).Keys Method

Histogram TData1, TData2 Keys Method NFX Class Library

Convert values to HistogramKeys struct

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HistogramKeys Keys(
    TData1 value1,
    TData2 value2
)
public HistogramKeys Keys(
    TData1 value1,
    TData2 value2
)
Public Function Keys (
    value1 As TData1,
    value2 As TData2
) As HistogramKeys
Public Function Keys (
    value1 As TData1,
    value2 As TData2
) As HistogramKeys
public:
HistogramKeys Keys(
    TData1 value1,
    TData2 value2
)
public:
HistogramKeys Keys(
    TData1 value1,
    TData2 value2
)
member Keys :
        value1 : 'TData1 *
        value2 : 'TData2 -> HistogramKeys
member Keys :
        value1 : 'TData1 *
        value2 : 'TData2 -> HistogramKeys

Parameters

value1
Type: TData1
value2
Type: TData2

Return Value

Type: HistogramKeys
See Also
Histogram TData1, TData2 Class
Histogram TData1, TData2 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2).Sample Method

Histogram TData1, TData2 Sample Method NFX Class Library

Increment histogram statistics for a given pair of dimension values

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Sample(
    TData1 value1,
    TData2 value2
)
public virtual void Sample(
    TData1 value1,
    TData2 value2
)
Public Overridable Sub Sample (
    value1 As TData1,
    value2 As TData2
)
Public Overridable Sub Sample (
    value1 As TData1,
    value2 As TData2
)
public:
virtual void Sample(
    TData1 value1,
    TData2 value2
)
public:
virtual void Sample(
    TData1 value1,
    TData2 value2
)
abstract Sample :
        value1 : 'TData1 *
        value2 : 'TData2 -> unit
override Sample :
        value1 : 'TData1 *
        value2 : 'TData2 -> unit
abstract Sample :
        value1 : 'TData1 *
        value2 : 'TData2 -> unit
override Sample :
        value1 : 'TData1 *
        value2 : 'TData2 -> unit

Parameters

value1
Type: TData1
value2
Type: TData2
See Also
Histogram TData1, TData2 Class
Histogram TData1, TData2 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2).TryGet Method

Histogram TData1, TData2 TryGet Method NFX Class Library

Overload List
 | Name | Description
Public method | TryGet(HistogramKeys, Int32 ) | Try to get the count of samples for the given histogram keys (Inherited from Histogram.)
Public method | TryGet(Int32, Int32, Int32 ) | Try to get the sample count associated with the given histogram keys. If the keys are not present in the histogram dictionary return false
Back to Top
See Also
Histogram TData1, TData2 Class
Histogram TData1, TData2 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2).TryGet Method (Int32, Int32, Int32)

Histogram TData1, TData2 TryGet Method (Int32, Int32, Int32 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Try to get the sample count associated with the given histogram keys. If the keys are not present in the histogram dictionary return false

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TryGet(
    int k1,
    int k2,
    out int count
)
public bool TryGet(
    int k1,
    int k2,
    out int count
)
Public Function TryGet (
    k1 As Integer,
    k2 As Integer,
    <OutAttribute> ByRef count As Integer
) As Boolean
Public Function TryGet (
    k1 As Integer,
    k2 As Integer,
    <OutAttribute> ByRef count As Integer
) As Boolean
public:
bool TryGet(
    int k1,
    int k2,
    [OutAttribute] int% count
)
public:
bool TryGet(
    int k1,
    int k2,
    [OutAttribute] int% count
)
member TryGet :
        k1 : int *
        k2 : int *
        count : int byref -> bool
member TryGet :
        k1 : int *
        k2 : int *
        count : int byref -> bool

Parameters

k1
Type: Online System Int32
k2
Type: Online System Int32
count
Type: Online System Int32

Return Value

Type: Online Boolean
See Also
Histogram TData1, TData2 Class
Histogram TData1, TData2 Members
TryGet Overload
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2).Value Method

Histogram TData1, TData2 Value Method NFX Class Library

Returns number of samples collected for a given key. The key is obtained by mapping the given values into the dimensions' partitions. Return value of 0 indicates that key is not present in the histogram

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Value(
    TData1 value1,
    TData2 value2
)
public int Value(
    TData1 value1,
    TData2 value2
)
Public Function Value (
    value1 As TData1,
    value2 As TData2
) As Integer
Public Function Value (
    value1 As TData1,
    value2 As TData2
) As Integer
public:
int Value(
    TData1 value1,
    TData2 value2
)
public:
int Value(
    TData1 value1,
    TData2 value2
)
member Value :
        value1 : 'TData1 *
        value2 : 'TData2 -> int
member Value :
        value1 : 'TData1 *
        value2 : 'TData2 -> int

Parameters

value1
Type: TData1
value2
Type: TData2

Return Value

Type: Online Int32
See Also
Histogram TData1, TData2 Class
Histogram TData1, TData2 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2) Properties

Histogram TData1, TData2 Properties NFX Class Library

The Histogram TData1, TData2 type exposes the following members.
Properties
 | Name | Description
Public property | DimensionCount | Number of dimensions in this histogram (Overrides Histogram DimensionCount.)
Public property | Dimensions | (Overrides Histogram Dimensions.)
Protected property | Item Int32 | (Inherited from Histogram.)
Public property | Item HistogramKeys | Return the count of samples for the given histogram keys (Inherited from Histogram.)
Public property | Item Int32, Int32 | Return the sample count associated with given histogram keys
Public property | Title | Histogram title used for displaying purposes (Inherited from Histogram.)
Public property | TotalSamples | Total number of samples in the histogram (Inherited from Histogram.)
Back to Top
See Also
Histogram TData1, TData2 Class
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2).DimensionCount Property

Histogram TData1, TData2 DimensionCount Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Number of dimensions in this histogram

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int DimensionCount { get; }
public override int DimensionCount { get; }
Public Overrides ReadOnly Property DimensionCount As Integer
    Get
Public Overrides ReadOnly Property DimensionCount As Integer
    Get
public:
virtual property int DimensionCount {
    int get () override;
}
public:
virtual property int DimensionCount {
    int get () override;
}
abstract DimensionCount : int with get
override DimensionCount : int with get
abstract DimensionCount : int with get
override DimensionCount : int with get

Property Value

Type: Online Int32

Implements

IHistogram DimensionCount
See Also
Histogram TData1, TData2 Class
Histogram TData1, TData2 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2).Dimensions Property

Histogram TData1, TData2 Dimensions Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IEnumerable<Dimension> Dimensions { get; }
public override IEnumerable<Dimension> Dimensions { get; }
Public Overrides ReadOnly Property Dimensions As IEnumerable(Of Dimension)
    Get
Public Overrides ReadOnly Property Dimensions As IEnumerable(Of Dimension)
    Get
public:
virtual property IEnumerable<Dimension^>^ Dimensions {
    IEnumerable<Dimension^>^ get () override;
}
public:
virtual property IEnumerable<Dimension^>^ Dimensions {
    IEnumerable<Dimension^>^ get () override;
}
abstract Dimensions : IEnumerable<Dimension> with get
override Dimensions : IEnumerable<Dimension> with get
abstract Dimensions : IEnumerable<Dimension> with get
override Dimensions : IEnumerable<Dimension> with get

Property Value

Type: Online IEnumerable Dimension

Implements

IHistogram Dimensions
See Also
Histogram TData1, TData2 Class
Histogram TData1, TData2 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2).Item Property

Histogram TData1, TData2 Item Property NFX Class Library

Overload List
 | Name | Description
Protected property | Item Int32 | (Inherited from Histogram.)
Public property | Item HistogramKeys | Return the count of samples for the given histogram keys (Inherited from Histogram.)
Public property | Item Int32, Int32 | Return the sample count associated with given histogram keys
Back to Top
See Also
Histogram TData1, TData2 Class
Histogram TData1, TData2 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2).Item Property (Int32, Int32)

Histogram TData1, TData2 Item Property (Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Return the sample count associated with given histogram keys

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int this[
    int k1,
    int k2
] { get; }
public int this[
    int k1,
    int k2
] { get; }
Public ReadOnly Default Property Item (
    k1 As Integer,
    k2 As Integer
) As Integer
    Get
Public ReadOnly Default Property Item (
    k1 As Integer,
    k2 As Integer
) As Integer
    Get
public:
property int default[int k1, int k2] {
    int get (int k1, int k2);
}
public:
property int default[int k1, int k2] {
    int get (int k1, int k2);
}
member Item : int with get
member Item : int with get

Parameters

k1
Type: Online System Int32
k2
Type: Online System Int32

Property Value

Type: Online Int32
See Also
Histogram TData1, TData2 Class
Histogram TData1, TData2 Members
Item Overload
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2, TData3) Class

Histogram TData1, TData2, TData3 Class NFX Class Library

Three-dimensional histogram for storing number of samples for given dimension keys
Inheritance Hierarchy
Online System Object
NFX.Instrumentation.Analytics Histogram
NFX.Instrumentation.Analytics Histogram TData1, TData2, TData3

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Histogram<TData1, TData2, TData3> : Histogram
public class Histogram<TData1, TData2, TData3> : Histogram
Public Class Histogram(Of TData1, TData2, TData3)
    Inherits Histogram
Public Class Histogram(Of TData1, TData2, TData3)
    Inherits Histogram
generic<typename TData1, typename TData2, typename TData3>
public ref class Histogram : public Histogram
generic<typename TData1, typename TData2, typename TData3>
public ref class Histogram : public Histogram
type Histogram<'TData1, 'TData2, 'TData3> =
    class
        inherit Histogram
    end
type Histogram<'TData1, 'TData2, 'TData3> =
    class
        inherit Histogram
    end
Type Parameters
TData1
TData2
TData3
See Also
Histogram TData1, TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2, TData3) Members

Histogram TData1, TData2, TData3 Members NFX Class Library

The Histogram TData1, TData2, TData3 type exposes the following members.
Constructors
 | Name | Description
Public method | Histogram TData1, TData2, TData3 | Constructs a histogram from a given array of dimensions
Back to Top
Methods
 | Name | Description
Public method | Clear | Reset histogram state (Inherited from Histogram.)
Protected method | DoSample | (Inherited from Histogram.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDimention | Return a dimension of a histogram identified by index (Inherited from Histogram.)
Public method | GetEnumerator | (Inherited from Histogram.)
Public method | GetHashCode | (Inherited from Histogram.)
Public method | GetPartitionName | Returns the name of a partition in a given histogram dimension (Inherited from Histogram.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Keys | Convert values to HistogramKeys struct
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Sample | Increment histogram statistics for a given triplet of dimension values
Public method | ToString | (Inherited from Histogram.)
Public method | TryGet(HistogramKeys, Int32 ) | Try to get the count of samples for the given histogram keys (Inherited from Histogram.)
Public method | TryGet(Int32, Int32, Int32, Int32 ) | Try to get the sample count associated with the given histogram keys. If the keys are not present in the histogram dictionary return false
Public method | Value | Returns number of samples collected for a given key. The key is obtained by mapping the given values into the dimensions' partitions. Return value of 0 indicates that key is not present in the histogram
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Data | (Inherited from Histogram.)
Protected field | m_Dimension1 |
Protected field | m_Dimension2 |
Protected field | m_Dimension3 |
Protected field | m_Title | (Inherited from Histogram.)
Protected field | m_TotalSamples | (Inherited from Histogram.)
Back to Top
Properties
 | Name | Description
Public property | DimensionCount | Number of dimensions in this histogram (Overrides Histogram DimensionCount.)
Public property | Dimensions | (Overrides Histogram Dimensions.)
Protected property | Item Int32 | (Inherited from Histogram.)
Public property | Item HistogramKeys | Return the count of samples for the given histogram keys (Inherited from Histogram.)
Public property | Item Int32, Int32, Int32 | Return the sample count associated with given histogram keys
Public property | Title | Histogram title used for displaying purposes (Inherited from Histogram.)
Public property | TotalSamples | Total number of samples in the histogram (Inherited from Histogram.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Histogram.)
Back to Top
See Also
Histogram TData1, TData2, TData3 Class
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2, TData3) Constructor

Histogram TData1, TData2, TData3 Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Constructs a histogram from a given array of dimensions

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Histogram(
    string title,
    Dimension<TData1> dimension1,
    Dimension<TData2> dimension2,
    Dimension<TData3> dimension3
)
public Histogram(
    string title,
    Dimension<TData1> dimension1,
    Dimension<TData2> dimension2,
    Dimension<TData3> dimension3
)
Public Sub New (
    title As String,
    dimension1 As Dimension(Of TData1),
    dimension2 As Dimension(Of TData2),
    dimension3 As Dimension(Of TData3)
)
Public Sub New (
    title As String,
    dimension1 As Dimension(Of TData1),
    dimension2 As Dimension(Of TData2),
    dimension3 As Dimension(Of TData3)
)
public:
Histogram(
    String^ title,
    Dimension<TData1>^ dimension1,
    Dimension<TData2>^ dimension2,
    Dimension<TData3>^ dimension3
)
public:
Histogram(
    String^ title,
    Dimension<TData1>^ dimension1,
    Dimension<TData2>^ dimension2,
    Dimension<TData3>^ dimension3
)
new :
        title : string *
        dimension1 : Dimension<'TData1> *
        dimension2 : Dimension<'TData2> *
        dimension3 : Dimension<'TData3> -> Histogram
new :
        title : string *
        dimension1 : Dimension<'TData1> *
        dimension2 : Dimension<'TData2> *
        dimension3 : Dimension<'TData3> -> Histogram

Parameters

title
Type: Online System String
Histogram title used for displaying result
dimension1
Type: NFX.Instrumentation.Analytics Dimension TData1
Dimension of the 1st histogram dimension
dimension2
Type: NFX.Instrumentation.Analytics Dimension TData2
Dimension of the 2nd histogram dimension
dimension3
Type: NFX.Instrumentation.Analytics Dimension TData3
Dimension of the 3nd histogram dimension
See Also
Histogram TData1, TData2, TData3 Class
Histogram TData1, TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2, TData3) Fields

Histogram TData1, TData2, TData3 Fields NFX Class Library

The Histogram TData1, TData2, TData3 type exposes the following members.
Fields
 | Name | Description
Protected field | m_Data | (Inherited from Histogram.)
Protected field | m_Dimension1 |
Protected field | m_Dimension2 |
Protected field | m_Dimension3 |
Protected field | m_Title | (Inherited from Histogram.)
Protected field | m_TotalSamples | (Inherited from Histogram.)
Back to Top
See Also
Histogram TData1, TData2, TData3 Class
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2, TData3).m_Dimension1 Field

Histogram TData1, TData2, TData3 m_Dimension1 Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Dimension<TData1> m_Dimension1
protected Dimension<TData1> m_Dimension1
Protected m_Dimension1 As Dimension(Of TData1)
Protected m_Dimension1 As Dimension(Of TData1)
protected:
Dimension<TData1>^ m_Dimension1
protected:
Dimension<TData1>^ m_Dimension1
val mutable m_Dimension1: Dimension<'TData1>
val mutable m_Dimension1: Dimension<'TData1>

Field Value

Type: Dimension TData1
See Also
Histogram TData1, TData2, TData3 Class
Histogram TData1, TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2, TData3).m_Dimension2 Field

Histogram TData1, TData2, TData3 m_Dimension2 Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Dimension<TData2> m_Dimension2
protected Dimension<TData2> m_Dimension2
Protected m_Dimension2 As Dimension(Of TData2)
Protected m_Dimension2 As Dimension(Of TData2)
protected:
Dimension<TData2>^ m_Dimension2
protected:
Dimension<TData2>^ m_Dimension2
val mutable m_Dimension2: Dimension<'TData2>
val mutable m_Dimension2: Dimension<'TData2>

Field Value

Type: Dimension TData2
See Also
Histogram TData1, TData2, TData3 Class
Histogram TData1, TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2, TData3).m_Dimension3 Field

Histogram TData1, TData2, TData3 m_Dimension3 Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Dimension<TData3> m_Dimension3
protected Dimension<TData3> m_Dimension3
Protected m_Dimension3 As Dimension(Of TData3)
Protected m_Dimension3 As Dimension(Of TData3)
protected:
Dimension<TData3>^ m_Dimension3
protected:
Dimension<TData3>^ m_Dimension3
val mutable m_Dimension3: Dimension<'TData3>
val mutable m_Dimension3: Dimension<'TData3>

Field Value

Type: Dimension TData3
See Also
Histogram TData1, TData2, TData3 Class
Histogram TData1, TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2, TData3) Methods

Histogram TData1, TData2, TData3 Methods NFX Class Library

The Histogram TData1, TData2, TData3 type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Reset histogram state (Inherited from Histogram.)
Protected method | DoSample | (Inherited from Histogram.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDimention | Return a dimension of a histogram identified by index (Inherited from Histogram.)
Public method | GetEnumerator | (Inherited from Histogram.)
Public method | GetHashCode | (Inherited from Histogram.)
Public method | GetPartitionName | Returns the name of a partition in a given histogram dimension (Inherited from Histogram.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Keys | Convert values to HistogramKeys struct
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Sample | Increment histogram statistics for a given triplet of dimension values
Public method | ToString | (Inherited from Histogram.)
Public method | TryGet(HistogramKeys, Int32 ) | Try to get the count of samples for the given histogram keys (Inherited from Histogram.)
Public method | TryGet(Int32, Int32, Int32, Int32 ) | Try to get the sample count associated with the given histogram keys. If the keys are not present in the histogram dictionary return false
Public method | Value | Returns number of samples collected for a given key. The key is obtained by mapping the given values into the dimensions' partitions. Return value of 0 indicates that key is not present in the histogram
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from Histogram.)
Back to Top
See Also
Histogram TData1, TData2, TData3 Class
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2, TData3).Keys Method

Histogram TData1, TData2, TData3 Keys Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Convert values to HistogramKeys struct

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HistogramKeys Keys(
    TData1 value1,
    TData2 value2,
    TData3 value3
)
public HistogramKeys Keys(
    TData1 value1,
    TData2 value2,
    TData3 value3
)
Public Function Keys (
    value1 As TData1,
    value2 As TData2,
    value3 As TData3
) As HistogramKeys
Public Function Keys (
    value1 As TData1,
    value2 As TData2,
    value3 As TData3
) As HistogramKeys
public:
HistogramKeys Keys(
    TData1 value1,
    TData2 value2,
    TData3 value3
)
public:
HistogramKeys Keys(
    TData1 value1,
    TData2 value2,
    TData3 value3
)
member Keys :
        value1 : 'TData1 *
        value2 : 'TData2 *
        value3 : 'TData3 -> HistogramKeys
member Keys :
        value1 : 'TData1 *
        value2 : 'TData2 *
        value3 : 'TData3 -> HistogramKeys

Parameters

value1
Type: TData1
value2
Type: TData2
value3
Type: TData3

Return Value

Type: HistogramKeys
See Also
Histogram TData1, TData2, TData3 Class
Histogram TData1, TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2, TData3).Sample Method

Histogram TData1, TData2, TData3 Sample Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Increment histogram statistics for a given triplet of dimension values

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Sample(
    TData1 value1,
    TData2 value2,
    TData3 value3
)
public virtual void Sample(
    TData1 value1,
    TData2 value2,
    TData3 value3
)
Public Overridable Sub Sample (
    value1 As TData1,
    value2 As TData2,
    value3 As TData3
)
Public Overridable Sub Sample (
    value1 As TData1,
    value2 As TData2,
    value3 As TData3
)
public:
virtual void Sample(
    TData1 value1,
    TData2 value2,
    TData3 value3
)
public:
virtual void Sample(
    TData1 value1,
    TData2 value2,
    TData3 value3
)
abstract Sample :
        value1 : 'TData1 *
        value2 : 'TData2 *
        value3 : 'TData3 -> unit
override Sample :
        value1 : 'TData1 *
        value2 : 'TData2 *
        value3 : 'TData3 -> unit
abstract Sample :
        value1 : 'TData1 *
        value2 : 'TData2 *
        value3 : 'TData3 -> unit
override Sample :
        value1 : 'TData1 *
        value2 : 'TData2 *
        value3 : 'TData3 -> unit

Parameters

value1
Type: TData1
value2
Type: TData2
value3
Type: TData3
See Also
Histogram TData1, TData2, TData3 Class
Histogram TData1, TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2, TData3).TryGet Method

Histogram TData1, TData2, TData3 TryGet Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public method | TryGet(HistogramKeys, Int32 ) | Try to get the count of samples for the given histogram keys (Inherited from Histogram.)
Public method | TryGet(Int32, Int32, Int32, Int32 ) | Try to get the sample count associated with the given histogram keys. If the keys are not present in the histogram dictionary return false
Back to Top
See Also
Histogram TData1, TData2, TData3 Class
Histogram TData1, TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2, TData3).TryGet Method (Int32, Int32, Int32, Int32)

Histogram TData1, TData2, TData3 TryGet Method (Int32, Int32, Int32, Int32 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Try to get the sample count associated with the given histogram keys. If the keys are not present in the histogram dictionary return false

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TryGet(
    int k1,
    int k2,
    int k3,
    out int count
)
public bool TryGet(
    int k1,
    int k2,
    int k3,
    out int count
)
Public Function TryGet (
    k1 As Integer,
    k2 As Integer,
    k3 As Integer,
    <OutAttribute> ByRef count As Integer
) As Boolean
Public Function TryGet (
    k1 As Integer,
    k2 As Integer,
    k3 As Integer,
    <OutAttribute> ByRef count As Integer
) As Boolean
public:
bool TryGet(
    int k1,
    int k2,
    int k3,
    [OutAttribute] int% count
)
public:
bool TryGet(
    int k1,
    int k2,
    int k3,
    [OutAttribute] int% count
)
member TryGet :
        k1 : int *
        k2 : int *
        k3 : int *
        count : int byref -> bool
member TryGet :
        k1 : int *
        k2 : int *
        k3 : int *
        count : int byref -> bool

Parameters

k1
Type: Online System Int32
k2
Type: Online System Int32
k3
Type: Online System Int32
count
Type: Online System Int32

Return Value

Type: Online Boolean
See Also
Histogram TData1, TData2, TData3 Class
Histogram TData1, TData2, TData3 Members
TryGet Overload
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2, TData3).Value Method

Histogram TData1, TData2, TData3 Value Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns number of samples collected for a given key. The key is obtained by mapping the given values into the dimensions' partitions. Return value of 0 indicates that key is not present in the histogram

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Value(
    TData1 value1,
    TData2 value2,
    TData3 value3
)
public int Value(
    TData1 value1,
    TData2 value2,
    TData3 value3
)
Public Function Value (
    value1 As TData1,
    value2 As TData2,
    value3 As TData3
) As Integer
Public Function Value (
    value1 As TData1,
    value2 As TData2,
    value3 As TData3
) As Integer
public:
int Value(
    TData1 value1,
    TData2 value2,
    TData3 value3
)
public:
int Value(
    TData1 value1,
    TData2 value2,
    TData3 value3
)
member Value :
        value1 : 'TData1 *
        value2 : 'TData2 *
        value3 : 'TData3 -> int
member Value :
        value1 : 'TData1 *
        value2 : 'TData2 *
        value3 : 'TData3 -> int

Parameters

value1
Type: TData1
value2
Type: TData2
value3
Type: TData3

Return Value

Type: Online Int32
See Also
Histogram TData1, TData2, TData3 Class
Histogram TData1, TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2, TData3) Properties

Histogram TData1, TData2, TData3 Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The Histogram TData1, TData2, TData3 type exposes the following members.
Properties
 | Name | Description
Public property | DimensionCount | Number of dimensions in this histogram (Overrides Histogram DimensionCount.)
Public property | Dimensions | (Overrides Histogram Dimensions.)
Protected property | Item Int32 | (Inherited from Histogram.)
Public property | Item HistogramKeys | Return the count of samples for the given histogram keys (Inherited from Histogram.)
Public property | Item Int32, Int32, Int32 | Return the sample count associated with given histogram keys
Public property | Title | Histogram title used for displaying purposes (Inherited from Histogram.)
Public property | TotalSamples | Total number of samples in the histogram (Inherited from Histogram.)
Back to Top
See Also
Histogram TData1, TData2, TData3 Class
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2, TData3).DimensionCount Property

Histogram TData1, TData2, TData3 DimensionCount Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Number of dimensions in this histogram

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int DimensionCount { get; }
public override int DimensionCount { get; }
Public Overrides ReadOnly Property DimensionCount As Integer
    Get
Public Overrides ReadOnly Property DimensionCount As Integer
    Get
public:
virtual property int DimensionCount {
    int get () override;
}
public:
virtual property int DimensionCount {
    int get () override;
}
abstract DimensionCount : int with get
override DimensionCount : int with get
abstract DimensionCount : int with get
override DimensionCount : int with get

Property Value

Type: Online Int32

Implements

IHistogram DimensionCount
See Also
Histogram TData1, TData2, TData3 Class
Histogram TData1, TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2, TData3).Dimensions Property

Histogram TData1, TData2, TData3 Dimensions Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IEnumerable<Dimension> Dimensions { get; }
public override IEnumerable<Dimension> Dimensions { get; }
Public Overrides ReadOnly Property Dimensions As IEnumerable(Of Dimension)
    Get
Public Overrides ReadOnly Property Dimensions As IEnumerable(Of Dimension)
    Get
public:
virtual property IEnumerable<Dimension^>^ Dimensions {
    IEnumerable<Dimension^>^ get () override;
}
public:
virtual property IEnumerable<Dimension^>^ Dimensions {
    IEnumerable<Dimension^>^ get () override;
}
abstract Dimensions : IEnumerable<Dimension> with get
override Dimensions : IEnumerable<Dimension> with get
abstract Dimensions : IEnumerable<Dimension> with get
override Dimensions : IEnumerable<Dimension> with get

Property Value

Type: Online IEnumerable Dimension

Implements

IHistogram Dimensions
See Also
Histogram TData1, TData2, TData3 Class
Histogram TData1, TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2, TData3).Item Property

Histogram TData1, TData2, TData3 Item Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Protected property | Item Int32 | (Inherited from Histogram.)
Public property | Item HistogramKeys | Return the count of samples for the given histogram keys (Inherited from Histogram.)
Public property | Item Int32, Int32, Int32 | Return the sample count associated with given histogram keys
Back to Top
See Also
Histogram TData1, TData2, TData3 Class
Histogram TData1, TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


Histogram(TData1, TData2, TData3).Item Property (Int32, Int32, Int32)

Histogram TData1, TData2, TData3 Item Property (Int32, Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Return the sample count associated with given histogram keys

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int this[
    int k1,
    int k2,
    int k3
] { get; }
public int this[
    int k1,
    int k2,
    int k3
] { get; }
Public ReadOnly Default Property Item (
    k1 As Integer,
    k2 As Integer,
    k3 As Integer
) As Integer
    Get
Public ReadOnly Default Property Item (
    k1 As Integer,
    k2 As Integer,
    k3 As Integer
) As Integer
    Get
public:
property int default[int k1, int k2, int k3] {
    int get (int k1, int k2, int k3);
}
public:
property int default[int k1, int k2, int k3] {
    int get (int k1, int k2, int k3);
}
member Item : int with get
member Item : int with get

Parameters

k1
Type: Online System Int32
k2
Type: Online System Int32
k3
Type: Online System Int32

Property Value

Type: Online Int32
See Also
Histogram TData1, TData2, TData3 Class
Histogram TData1, TData2, TData3 Members
Item Overload
NFX.Instrumentation.Analytics Namespace


HistogramEntry Class

HistogramEntry Class NFX Class Library

The placeholder of histogram data that represents a sample count for a given set of histogram keys.
Inheritance Hierarchy
Online System Object
NFX.Instrumentation.Analytics HistogramEntry

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class HistogramEntry
public class HistogramEntry
Public Class HistogramEntry
Public Class HistogramEntry
public ref class HistogramEntry
public ref class HistogramEntry
type HistogramEntry =  class end
type HistogramEntry =  class end
See Also
HistogramEntry Members
NFX.Instrumentation.Analytics Namespace


HistogramEntry Members

HistogramEntry Members NFX Class Library

The HistogramEntry type exposes the following members.
Constructors
 | Name | Description
Public method | HistogramEntry | Initializes a new instance of the HistogramEntry class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_BucketKeys |
Protected field | m_Count |
Back to Top
Properties
 | Name | Description
Public property | BucketKeys |
Public property | Count |
Back to Top
See Also
HistogramEntry Class
NFX.Instrumentation.Analytics Namespace


HistogramEntry Constructor

HistogramEntry Constructor NFX Class Library

Initializes a new instance of the HistogramEntry class

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HistogramEntry(
    HistogramKeys keys
)
public HistogramEntry(
    HistogramKeys keys
)
Public Sub New (
    keys As HistogramKeys
)
Public Sub New (
    keys As HistogramKeys
)
public:
HistogramEntry(
    HistogramKeys keys
)
public:
HistogramEntry(
    HistogramKeys keys
)
new :
        keys : HistogramKeys -> HistogramEntry
new :
        keys : HistogramKeys -> HistogramEntry

Parameters

keys
Type: NFX.Instrumentation.Analytics HistogramKeys
See Also
HistogramEntry Class
HistogramEntry Members
NFX.Instrumentation.Analytics Namespace


HistogramEntry Fields

HistogramEntry Fields NFX Class Library

The HistogramEntry type exposes the following members.
Fields
 | Name | Description
Protected field | m_BucketKeys |
Protected field | m_Count |
Back to Top
See Also
HistogramEntry Class
NFX.Instrumentation.Analytics Namespace


HistogramEntry.m_BucketKeys Field

HistogramEntry m_BucketKeys Field NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal HistogramKeys m_BucketKeys
internal HistogramKeys m_BucketKeys
Friend m_BucketKeys As HistogramKeys
Friend m_BucketKeys As HistogramKeys
internal:
HistogramKeys m_BucketKeys
internal:
HistogramKeys m_BucketKeys
val mutable internal m_BucketKeys: HistogramKeys
val mutable internal m_BucketKeys: HistogramKeys

Field Value

Type: HistogramKeys
See Also
HistogramEntry Class
HistogramEntry Members
NFX.Instrumentation.Analytics Namespace


HistogramEntry.m_Count Field

HistogramEntry m_Count Field NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int m_Count
internal int m_Count
Friend m_Count As Integer
Friend m_Count As Integer
internal:
int m_Count
internal:
int m_Count
val mutable internal m_Count: int
val mutable internal m_Count: int

Field Value

Type: Online Int32
See Also
HistogramEntry Class
HistogramEntry Members
NFX.Instrumentation.Analytics Namespace


HistogramEntry Methods

HistogramEntry Methods NFX Class Library

The HistogramEntry type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
HistogramEntry Class
NFX.Instrumentation.Analytics Namespace


HistogramEntry Properties

HistogramEntry Properties NFX Class Library

The HistogramEntry type exposes the following members.
Properties
 | Name | Description
Public property | BucketKeys |
Public property | Count |
Back to Top
See Also
HistogramEntry Class
NFX.Instrumentation.Analytics Namespace


HistogramEntry.BucketKeys Property

HistogramEntry BucketKeys Property NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HistogramKeys BucketKeys { get; }
public HistogramKeys BucketKeys { get; }
Public ReadOnly Property BucketKeys As HistogramKeys
    Get
Public ReadOnly Property BucketKeys As HistogramKeys
    Get
public:
property HistogramKeys BucketKeys {
    HistogramKeys get ();
}
public:
property HistogramKeys BucketKeys {
    HistogramKeys get ();
}
member BucketKeys : HistogramKeys with get
member BucketKeys : HistogramKeys with get

Property Value

Type: HistogramKeys
See Also
HistogramEntry Class
HistogramEntry Members
NFX.Instrumentation.Analytics Namespace


HistogramEntry.Count Property

HistogramEntry Count Property NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
public:
property int Count {
    int get ();
}
member Count : int with get
member Count : int with get

Property Value

Type: Online Int32
See Also
HistogramEntry Class
HistogramEntry Members
NFX.Instrumentation.Analytics Namespace


HistogramKeys Structure

HistogramKeys Structure NFX Class Library

Represents histogram dimension key vector. This class is introduced for performance enhancement vs int[] approach that would have allocated extra object on heap per call

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct HistogramKeys : IComparable<HistogramKeys>,
    IComparable
public struct HistogramKeys : IComparable<HistogramKeys>,
    IComparable
Public Structure HistogramKeys
    Implements IComparable(Of HistogramKeys), IComparable
Public Structure HistogramKeys
    Implements IComparable(Of HistogramKeys), IComparable
public value class HistogramKeys : IComparable<HistogramKeys>,
    IComparable
public value class HistogramKeys : IComparable<HistogramKeys>,
    IComparable
[<SealedAttribute>]
type HistogramKeys =
    struct
        interface IComparable<HistogramKeys>
        interface IComparable
    end
[<SealedAttribute>]
type HistogramKeys =
    struct
        interface IComparable<HistogramKeys>
        interface IComparable
    end
See Also
HistogramKeys Members
NFX.Instrumentation.Analytics Namespace


HistogramKeys Members

HistogramKeys Members NFX Class Library

The HistogramKeys type exposes the following members.
Constructors
 | Name | Description
Public method | HistogramKeys(Int32) | Initializes a new instance of the HistogramKeys class
Public method | HistogramKeys(Int32, Int32) | Initializes a new instance of the HistogramKeys class
Public method | HistogramKeys(Int32, Int32, Int32) | Initializes a new instance of the HistogramKeys class
Back to Top
Methods
 | Name | Description
Public method | CompareTo(Object) |
Public method | CompareTo(HistogramKeys) |
Public method | Equals | (Overrides Online ValueType Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Key1 |
Public field | Key2 |
Public field | Key3 |
Back to Top
Properties
 | Name | Description
Public property | Item |
Back to Top
See Also
HistogramKeys Structure
NFX.Instrumentation.Analytics Namespace


HistogramKeys Constructor

HistogramKeys Constructor NFX Class Library

Overload List
 | Name | Description
Public method | HistogramKeys(Int32) | Initializes a new instance of the HistogramKeys class
Public method | HistogramKeys(Int32, Int32) | Initializes a new instance of the HistogramKeys class
Public method | HistogramKeys(Int32, Int32, Int32) | Initializes a new instance of the HistogramKeys class
Back to Top
See Also
HistogramKeys Structure
HistogramKeys Members
NFX.Instrumentation.Analytics Namespace


HistogramKeys Constructor (Int32)

HistogramKeys Constructor (Int32) NFX Class Library

Initializes a new instance of the HistogramKeys class

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HistogramKeys(
    int k1
)
public HistogramKeys(
    int k1
)
Public Sub New (
    k1 As Integer
)
Public Sub New (
    k1 As Integer
)
public:
HistogramKeys(
    int k1
)
public:
HistogramKeys(
    int k1
)
new :
        k1 : int -> HistogramKeys
new :
        k1 : int -> HistogramKeys

Parameters

k1
Type: Online System Int32
See Also
HistogramKeys Structure
HistogramKeys Members
HistogramKeys Overload
NFX.Instrumentation.Analytics Namespace


HistogramKeys Constructor (Int32, Int32)

HistogramKeys Constructor (Int32, Int32) NFX Class Library

Initializes a new instance of the HistogramKeys class

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HistogramKeys(
    int k1,
    int k2
)
public HistogramKeys(
    int k1,
    int k2
)
Public Sub New (
    k1 As Integer,
    k2 As Integer
)
Public Sub New (
    k1 As Integer,
    k2 As Integer
)
public:
HistogramKeys(
    int k1,
    int k2
)
public:
HistogramKeys(
    int k1,
    int k2
)
new :
        k1 : int *
        k2 : int -> HistogramKeys
new :
        k1 : int *
        k2 : int -> HistogramKeys

Parameters

k1
Type: Online System Int32
k2
Type: Online System Int32
See Also
HistogramKeys Structure
HistogramKeys Members
HistogramKeys Overload
NFX.Instrumentation.Analytics Namespace


HistogramKeys Constructor (Int32, Int32, Int32)

HistogramKeys Constructor (Int32, Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HistogramKeys class

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HistogramKeys(
    int k1,
    int k2,
    int k3
)
public HistogramKeys(
    int k1,
    int k2,
    int k3
)
Public Sub New (
    k1 As Integer,
    k2 As Integer,
    k3 As Integer
)
Public Sub New (
    k1 As Integer,
    k2 As Integer,
    k3 As Integer
)
public:
HistogramKeys(
    int k1,
    int k2,
    int k3
)
public:
HistogramKeys(
    int k1,
    int k2,
    int k3
)
new :
        k1 : int *
        k2 : int *
        k3 : int -> HistogramKeys
new :
        k1 : int *
        k2 : int *
        k3 : int -> HistogramKeys

Parameters

k1
Type: Online System Int32
k2
Type: Online System Int32
k3
Type: Online System Int32
See Also
HistogramKeys Structure
HistogramKeys Members
HistogramKeys Overload
NFX.Instrumentation.Analytics Namespace


HistogramKeys Fields

HistogramKeys Fields NFX Class Library

The HistogramKeys type exposes the following members.
Fields
 | Name | Description
Public field | Key1 |
Public field | Key2 |
Public field | Key3 |
Back to Top
See Also
HistogramKeys Structure
NFX.Instrumentation.Analytics Namespace


HistogramKeys.Key1 Field

HistogramKeys Key1 Field NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Key1
public readonly int Key1
Public ReadOnly Key1 As Integer
Public ReadOnly Key1 As Integer
public:
initonly int Key1
public:
initonly int Key1
val Key1: int
val Key1: int

Field Value

Type: Online Int32
See Also
HistogramKeys Structure
HistogramKeys Members
NFX.Instrumentation.Analytics Namespace


HistogramKeys.Key2 Field

HistogramKeys Key2 Field NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Key2
public readonly int Key2
Public ReadOnly Key2 As Integer
Public ReadOnly Key2 As Integer
public:
initonly int Key2
public:
initonly int Key2
val Key2: int
val Key2: int

Field Value

Type: Online Int32
See Also
HistogramKeys Structure
HistogramKeys Members
NFX.Instrumentation.Analytics Namespace


HistogramKeys.Key3 Field

HistogramKeys Key3 Field NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Key3
public readonly int Key3
Public ReadOnly Key3 As Integer
Public ReadOnly Key3 As Integer
public:
initonly int Key3
public:
initonly int Key3
val Key3: int
val Key3: int

Field Value

Type: Online Int32
See Also
HistogramKeys Structure
HistogramKeys Members
NFX.Instrumentation.Analytics Namespace


HistogramKeys Methods

HistogramKeys Methods NFX Class Library

The HistogramKeys type exposes the following members.
Methods
 | Name | Description
Public method | CompareTo(Object) |
Public method | CompareTo(HistogramKeys) |
Public method | Equals | (Overrides Online ValueType Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
HistogramKeys Structure
NFX.Instrumentation.Analytics Namespace


HistogramKeys.CompareTo Method

HistogramKeys CompareTo Method NFX Class Library

Overload List
 | Name | Description
Public method | CompareTo(Object) |
Public method | CompareTo(HistogramKeys) |
Back to Top
See Also
HistogramKeys Structure
HistogramKeys Members
NFX.Instrumentation.Analytics Namespace


HistogramKeys.CompareTo Method (Object)

HistogramKeys CompareTo Method (Object) NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    Object obj
)
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
Public Function CompareTo (
    obj As Object
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
public:
virtual int CompareTo(
    Object^ obj
) sealed
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int

Parameters

obj
Type: Online System Object

Return Value

Type: Online Int32

Implements

Online IComparable CompareTo(Object)
See Also
HistogramKeys Structure
HistogramKeys Members
CompareTo Overload
NFX.Instrumentation.Analytics Namespace


HistogramKeys.CompareTo Method (HistogramKeys)

HistogramKeys CompareTo Method (HistogramKeys) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    HistogramKeys rhs
)
public int CompareTo(
    HistogramKeys rhs
)
Public Function CompareTo (
    rhs As HistogramKeys
) As Integer
Public Function CompareTo (
    rhs As HistogramKeys
) As Integer
public:
virtual int CompareTo(
    HistogramKeys rhs
) sealed
public:
virtual int CompareTo(
    HistogramKeys rhs
) sealed
abstract CompareTo :
        rhs : HistogramKeys -> int
override CompareTo :
        rhs : HistogramKeys -> int
abstract CompareTo :
        rhs : HistogramKeys -> int
override CompareTo :
        rhs : HistogramKeys -> int

Parameters

rhs
Type: NFX.Instrumentation.Analytics HistogramKeys

Return Value

Type: Online Int32

Implements

Online IComparable T CompareTo(T)
See Also
HistogramKeys Structure
HistogramKeys Members
CompareTo Overload
NFX.Instrumentation.Analytics Namespace


HistogramKeys.Equals Method

HistogramKeys Equals Method NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
HistogramKeys Structure
HistogramKeys Members
NFX.Instrumentation.Analytics Namespace


HistogramKeys.GetHashCode Method

HistogramKeys GetHashCode Method NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
HistogramKeys Structure
HistogramKeys Members
NFX.Instrumentation.Analytics Namespace


HistogramKeys.ToString Method

HistogramKeys ToString Method NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
HistogramKeys Structure
HistogramKeys Members
NFX.Instrumentation.Analytics Namespace


HistogramKeys Properties

HistogramKeys Properties NFX Class Library

The HistogramKeys type exposes the following members.
Properties
 | Name | Description
Public property | Item |
Back to Top
See Also
HistogramKeys Structure
NFX.Instrumentation.Analytics Namespace


HistogramKeys.Item Property

HistogramKeys Item Property NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int this[
    int idx
] { get; }
public int this[
    int idx
] { get; }
Public ReadOnly Default Property Item (
    idx As Integer
) As Integer
    Get
Public ReadOnly Default Property Item (
    idx As Integer
) As Integer
    Get
public:
property int default[int idx] {
    int get (int idx);
}
public:
property int default[int idx] {
    int get (int idx);
}
member Item : int with get
member Item : int with get

Parameters

idx
Type: Online System Int32

Property Value

Type: Online Int32
See Also
HistogramKeys Structure
HistogramKeys Members
NFX.Instrumentation.Analytics Namespace


HistogramReporters Class

HistogramReporters Class NFX Class Library

Maps histogram data into some other representation (such as text, HTML, etc)
Inheritance Hierarchy
Online System Object
NFX.Instrumentation.Analytics HistogramReporters

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class HistogramReporters
public static class HistogramReporters
<ExtensionAttribute>
Public NotInheritable Class HistogramReporters
<ExtensionAttribute>
Public NotInheritable Class HistogramReporters
[ExtensionAttribute]
public ref class HistogramReporters abstract sealed
[ExtensionAttribute]
public ref class HistogramReporters abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type HistogramReporters =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type HistogramReporters =  class end
See Also
HistogramReporters Members
NFX.Instrumentation.Analytics Namespace


HistogramReporters Members

HistogramReporters Members NFX Class Library

The HistogramReporters type exposes the following members.
Methods
Name | Description
ToStringReport |
Back to Top
See Also
HistogramReporters Class
NFX.Instrumentation.Analytics Namespace


HistogramReporters Methods

HistogramReporters Methods NFX Class Library

The HistogramReporters type exposes the following members.
Methods
Name | Description
ToStringReport |
Back to Top
See Also
HistogramReporters Class
NFX.Instrumentation.Analytics Namespace


HistogramReporters.ToStringReport Method

HistogramReporters ToStringReport Method NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ToStringReport(
    this IHistogram hist
)
public static string ToStringReport(
    this IHistogram hist
)
<ExtensionAttribute>
Public Shared Function ToStringReport (
    hist As IHistogram
) As String
<ExtensionAttribute>
Public Shared Function ToStringReport (
    hist As IHistogram
) As String
public:
[ExtensionAttribute]
static String^ ToStringReport(
    IHistogram^ hist
)
public:
[ExtensionAttribute]
static String^ ToStringReport(
    IHistogram^ hist
)
static member ToStringReport :
        hist : IHistogram -> string
static member ToStringReport :
        hist : IHistogram -> string

Parameters

hist
Type: NFX.Instrumentation.Analytics IHistogram

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IHistogram. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
HistogramReporters Class
HistogramReporters Members
NFX.Instrumentation.Analytics Namespace


IHistogram Interface

IHistogram Interface NFX Class Library

Basic histogram interface to be implemented by all types of instrumentation histograms

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IHistogram : IEnumerable<HistogramEntry>,
    IEnumerable
public interface IHistogram : IEnumerable<HistogramEntry>,
    IEnumerable
Public Interface IHistogram
    Inherits IEnumerable(Of HistogramEntry), IEnumerable
Public Interface IHistogram
    Inherits IEnumerable(Of HistogramEntry), IEnumerable
public interface class IHistogram : IEnumerable<HistogramEntry^>,
    IEnumerable
public interface class IHistogram : IEnumerable<HistogramEntry^>,
    IEnumerable
type IHistogram =
    interface
        interface IEnumerable<HistogramEntry>
        interface IEnumerable
    end
type IHistogram =
    interface
        interface IEnumerable<HistogramEntry>
        interface IEnumerable
    end
See Also
IHistogram Members
NFX.Instrumentation.Analytics Namespace


IHistogram Members

IHistogram Members NFX Class Library

The IHistogram type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Reset histogram state
Public method | GetDimention | Return a dimension of a histogram identified by index
Public method | Online GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from Online IEnumerable HistogramEntry .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Online IEnumerable.)
Public method | GetPartitionName | Returns the name of a partition in a given histogram dimension
Public method | TryGet | Try to get the count of samples for the given histogram keys
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsLookAheadEnumerable HistogramEntry | (Defined by LookAheadExtensions.)
Public Extension Method | Distinct HistogramEntry, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax HistogramEntry, TComparand (Func HistogramEntry, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax HistogramEntry, TComparand (Func HistogramEntry, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin HistogramEntry, TComparand (Func HistogramEntry, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin HistogramEntry, TComparand (Func HistogramEntry, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault HistogramEntry | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach HistogramEntry (Action HistogramEntry ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach HistogramEntry (Action HistogramEntry, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast HistogramEntry | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast HistogramEntry (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToStringReport | (Defined by HistogramReporters.)
Back to Top
Properties
 | Name | Description
Public property | DimensionCount | Number of dimensions in this histogram
Public property | Dimensions | Returns the dimension instances of this histogram
Public property | Item | Return the count of samples for the given histogram keys
Public property | Title | Histogram title used for displaying purposes
Public property | TotalSamples | Total number of samples in the histogram
Back to Top
See Also
IHistogram Interface
NFX.Instrumentation.Analytics Namespace


IHistogram Methods

IHistogram Methods NFX Class Library

The IHistogram type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Reset histogram state
Public method | GetDimention | Return a dimension of a histogram identified by index
Public method | Online GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from Online IEnumerable HistogramEntry .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Online IEnumerable.)
Public method | GetPartitionName | Returns the name of a partition in a given histogram dimension
Public method | TryGet | Try to get the count of samples for the given histogram keys
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsLookAheadEnumerable HistogramEntry | (Defined by LookAheadExtensions.)
Public Extension Method | Distinct HistogramEntry, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax HistogramEntry, TComparand (Func HistogramEntry, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax HistogramEntry, TComparand (Func HistogramEntry, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin HistogramEntry, TComparand (Func HistogramEntry, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin HistogramEntry, TComparand (Func HistogramEntry, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault HistogramEntry | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach HistogramEntry (Action HistogramEntry ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach HistogramEntry (Action HistogramEntry, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast HistogramEntry | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast HistogramEntry (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToStringReport | (Defined by HistogramReporters.)
Back to Top
See Also
IHistogram Interface
NFX.Instrumentation.Analytics Namespace


IHistogram.Clear Method

IHistogram Clear Method NFX Class Library

Reset histogram state

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Clear()
void Clear()
Sub Clear
Sub Clear
void Clear()
void Clear()
abstract Clear : unit -> unit
abstract Clear : unit -> unit
See Also
IHistogram Interface
IHistogram Members
NFX.Instrumentation.Analytics Namespace


IHistogram.GetDimention Method

IHistogram GetDimention Method NFX Class Library

Return a dimension of a histogram identified by index

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Dimension GetDimention(
    int dimension
)
Dimension GetDimention(
    int dimension
)
Function GetDimention (
    dimension As Integer
) As Dimension
Function GetDimention (
    dimension As Integer
) As Dimension
Dimension^ GetDimention(
    int dimension
)
Dimension^ GetDimention(
    int dimension
)
abstract GetDimention :
        dimension : int -> Dimension
abstract GetDimention :
        dimension : int -> Dimension

Parameters

dimension
Type: Online System Int32

Return Value

Type: Dimension
See Also
IHistogram Interface
IHistogram Members
NFX.Instrumentation.Analytics Namespace


IHistogram.GetPartitionName Method

IHistogram GetPartitionName Method NFX Class Library

Returns the name of a partition in a given histogram dimension

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string GetPartitionName(
    int dimension,
    int partition
)
string GetPartitionName(
    int dimension,
    int partition
)
Function GetPartitionName (
    dimension As Integer,
    partition As Integer
) As String
Function GetPartitionName (
    dimension As Integer,
    partition As Integer
) As String
String^ GetPartitionName(
    int dimension,
    int partition
)
String^ GetPartitionName(
    int dimension,
    int partition
)
abstract GetPartitionName :
        dimension : int *
        partition : int -> string
abstract GetPartitionName :
        dimension : int *
        partition : int -> string

Parameters

dimension
Type: Online System Int32
Dimension index
partition
Type: Online System Int32
Partition index

Return Value

Type: Online String
See Also
IHistogram Interface
IHistogram Members
NFX.Instrumentation.Analytics Namespace


IHistogram.TryGet Method

IHistogram TryGet Method NFX Class Library

Try to get the count of samples for the given histogram keys

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool TryGet(
    HistogramKeys keys,
    out int count
)
bool TryGet(
    HistogramKeys keys,
    out int count
)
Function TryGet (
    keys As HistogramKeys,
    <OutAttribute> ByRef count As Integer
) As Boolean
Function TryGet (
    keys As HistogramKeys,
    <OutAttribute> ByRef count As Integer
) As Boolean
bool TryGet(
    HistogramKeys keys,
    [OutAttribute] int% count
)
bool TryGet(
    HistogramKeys keys,
    [OutAttribute] int% count
)
abstract TryGet :
        keys : HistogramKeys *
        count : int byref -> bool
abstract TryGet :
        keys : HistogramKeys *
        count : int byref -> bool

Parameters

keys
Type: NFX.Instrumentation.Analytics HistogramKeys
count
Type: Online System Int32

Return Value

Type: Online Boolean
See Also
IHistogram Interface
IHistogram Members
NFX.Instrumentation.Analytics Namespace


IHistogram Properties

IHistogram Properties NFX Class Library

The IHistogram type exposes the following members.
Properties
 | Name | Description
Public property | DimensionCount | Number of dimensions in this histogram
Public property | Dimensions | Returns the dimension instances of this histogram
Public property | Item | Return the count of samples for the given histogram keys
Public property | Title | Histogram title used for displaying purposes
Public property | TotalSamples | Total number of samples in the histogram
Back to Top
See Also
IHistogram Interface
NFX.Instrumentation.Analytics Namespace


IHistogram.DimensionCount Property

IHistogram DimensionCount Property NFX Class Library

Number of dimensions in this histogram

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int DimensionCount { get; }
int DimensionCount { get; }
ReadOnly Property DimensionCount As Integer
    Get
ReadOnly Property DimensionCount As Integer
    Get
property int DimensionCount {
    int get ();
}
property int DimensionCount {
    int get ();
}
abstract DimensionCount : int with get
abstract DimensionCount : int with get

Property Value

Type: Online Int32
See Also
IHistogram Interface
IHistogram Members
NFX.Instrumentation.Analytics Namespace


IHistogram.Dimensions Property

IHistogram Dimensions Property NFX Class Library

Returns the dimension instances of this histogram

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<Dimension> Dimensions { get; }
IEnumerable<Dimension> Dimensions { get; }
ReadOnly Property Dimensions As IEnumerable(Of Dimension)
    Get
ReadOnly Property Dimensions As IEnumerable(Of Dimension)
    Get
property IEnumerable<Dimension^>^ Dimensions {
    IEnumerable<Dimension^>^ get ();
}
property IEnumerable<Dimension^>^ Dimensions {
    IEnumerable<Dimension^>^ get ();
}
abstract Dimensions : IEnumerable<Dimension> with get
abstract Dimensions : IEnumerable<Dimension> with get

Property Value

Type: Online IEnumerable Dimension
See Also
IHistogram Interface
IHistogram Members
NFX.Instrumentation.Analytics Namespace


IHistogram.Item Property

IHistogram Item Property NFX Class Library

Return the count of samples for the given histogram keys

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int this[
    HistogramKeys keys
] { get; }
int this[
    HistogramKeys keys
] { get; }
ReadOnly Default Property Item (
    keys As HistogramKeys
) As Integer
    Get
ReadOnly Default Property Item (
    keys As HistogramKeys
) As Integer
    Get
property int default[HistogramKeys keys] {
    int get (HistogramKeys keys);
}
property int default[HistogramKeys keys] {
    int get (HistogramKeys keys);
}
abstract Item : int with get
abstract Item : int with get

Parameters

keys
Type: NFX.Instrumentation.Analytics HistogramKeys

Property Value

Type: Online Int32
See Also
IHistogram Interface
IHistogram Members
NFX.Instrumentation.Analytics Namespace


IHistogram.Title Property

IHistogram Title Property NFX Class Library

Histogram title used for displaying purposes

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Title { get; }
string Title { get; }
ReadOnly Property Title As String
    Get
ReadOnly Property Title As String
    Get
property String^ Title {
    String^ get ();
}
property String^ Title {
    String^ get ();
}
abstract Title : string with get
abstract Title : string with get

Property Value

Type: Online String
See Also
IHistogram Interface
IHistogram Members
NFX.Instrumentation.Analytics Namespace


IHistogram.TotalSamples Property

IHistogram TotalSamples Property NFX Class Library

Total number of samples in the histogram

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
long TotalSamples { get; }
long TotalSamples { get; }
ReadOnly Property TotalSamples As Long
    Get
ReadOnly Property TotalSamples As Long
    Get
property long long TotalSamples {
    long long get ();
}
property long long TotalSamples {
    long long get ();
}
abstract TotalSamples : int64 with get
abstract TotalSamples : int64 with get

Property Value

Type: Online Int64
See Also
IHistogram Interface
IHistogram Members
NFX.Instrumentation.Analytics Namespace


ITimeHistogram Interface

ITimeHistogram Interface NFX Class Library

Histogram for measuring latency

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ITimeHistogram : IHistogram,
    IEnumerable<HistogramEntry>, IEnumerable
public interface ITimeHistogram : IHistogram,
    IEnumerable<HistogramEntry>, IEnumerable
Public Interface ITimeHistogram
    Inherits IHistogram, IEnumerable(Of HistogramEntry), IEnumerable
Public Interface ITimeHistogram
    Inherits IHistogram, IEnumerable(Of HistogramEntry), IEnumerable
public interface class ITimeHistogram : IHistogram,
    IEnumerable<HistogramEntry^>, IEnumerable
public interface class ITimeHistogram : IHistogram,
    IEnumerable<HistogramEntry^>, IEnumerable
type ITimeHistogram =
    interface
        interface IHistogram
        interface IEnumerable<HistogramEntry>
        interface IEnumerable
    end
type ITimeHistogram =
    interface
        interface IHistogram
        interface IEnumerable<HistogramEntry>
        interface IEnumerable
    end
See Also
ITimeHistogram Members
NFX.Instrumentation.Analytics Namespace


ITimeHistogram Members

ITimeHistogram Members NFX Class Library

The ITimeHistogram type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Reset histogram state (Inherited from IHistogram.)
Public method | GetDimention | Return a dimension of a histogram identified by index (Inherited from IHistogram.)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from Online IEnumerable HistogramEntry .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Online IEnumerable.)
Public method | GetPartitionName | Returns the name of a partition in a given histogram dimension (Inherited from IHistogram.)
Public method | Start | Start sample time measurement
Public method | TryGet | Try to get the count of samples for the given histogram keys (Inherited from IHistogram.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsLookAheadEnumerable HistogramEntry | (Defined by LookAheadExtensions.)
Public Extension Method | Distinct HistogramEntry, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax HistogramEntry, TComparand (Func HistogramEntry, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax HistogramEntry, TComparand (Func HistogramEntry, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin HistogramEntry, TComparand (Func HistogramEntry, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin HistogramEntry, TComparand (Func HistogramEntry, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault HistogramEntry | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach HistogramEntry (Action HistogramEntry ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach HistogramEntry (Action HistogramEntry, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast HistogramEntry | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast HistogramEntry (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToStringReport | (Defined by HistogramReporters.)
Back to Top
Properties
 | Name | Description
Public property | AvgTime | Average time of all measured samples
Public property | DimensionCount | Number of dimensions in this histogram (Inherited from IHistogram.)
Public property | Dimensions | Returns the dimension instances of this histogram (Inherited from IHistogram.)
Public property | Item | Return the count of samples for the given histogram keys (Inherited from IHistogram.)
Public property | MaxTime | Maximum time of all measured samples
Public property | MinTime | Minimum time of all measured samples
Public property | Title | Histogram title used for displaying purposes (Inherited from IHistogram.)
Public property | TotalSamples | Total number of samples in the histogram (Inherited from IHistogram.)
Back to Top
See Also
ITimeHistogram Interface
NFX.Instrumentation.Analytics Namespace


ITimeHistogram Methods

ITimeHistogram Methods NFX Class Library

The ITimeHistogram type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Reset histogram state (Inherited from IHistogram.)
Public method | GetDimention | Return a dimension of a histogram identified by index (Inherited from IHistogram.)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from Online IEnumerable HistogramEntry .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Online IEnumerable.)
Public method | GetPartitionName | Returns the name of a partition in a given histogram dimension (Inherited from IHistogram.)
Public method | Start | Start sample time measurement
Public method | TryGet | Try to get the count of samples for the given histogram keys (Inherited from IHistogram.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsLookAheadEnumerable HistogramEntry | (Defined by LookAheadExtensions.)
Public Extension Method | Distinct HistogramEntry, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax HistogramEntry, TComparand (Func HistogramEntry, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax HistogramEntry, TComparand (Func HistogramEntry, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin HistogramEntry, TComparand (Func HistogramEntry, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin HistogramEntry, TComparand (Func HistogramEntry, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault HistogramEntry | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach HistogramEntry (Action HistogramEntry ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach HistogramEntry (Action HistogramEntry, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast HistogramEntry | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast HistogramEntry (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToStringReport | (Defined by HistogramReporters.)
Back to Top
See Also
ITimeHistogram Interface
NFX.Instrumentation.Analytics Namespace


ITimeHistogram.Start Method

ITimeHistogram Start Method NFX Class Library

Start sample time measurement

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Start()
void Start()
Sub Start
Sub Start
void Start()
void Start()
abstract Start : unit -> unit
abstract Start : unit -> unit
See Also
ITimeHistogram Interface
ITimeHistogram Members
NFX.Instrumentation.Analytics Namespace


ITimeHistogram Properties

ITimeHistogram Properties NFX Class Library

The ITimeHistogram type exposes the following members.
Properties
 | Name | Description
Public property | AvgTime | Average time of all measured samples
Public property | DimensionCount | Number of dimensions in this histogram (Inherited from IHistogram.)
Public property | Dimensions | Returns the dimension instances of this histogram (Inherited from IHistogram.)
Public property | Item | Return the count of samples for the given histogram keys (Inherited from IHistogram.)
Public property | MaxTime | Maximum time of all measured samples
Public property | MinTime | Minimum time of all measured samples
Public property | Title | Histogram title used for displaying purposes (Inherited from IHistogram.)
Public property | TotalSamples | Total number of samples in the histogram (Inherited from IHistogram.)
Back to Top
See Also
ITimeHistogram Interface
NFX.Instrumentation.Analytics Namespace


ITimeHistogram.AvgTime Property

ITimeHistogram AvgTime Property NFX Class Library

Average time of all measured samples

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
double AvgTime { get; }
double AvgTime { get; }
ReadOnly Property AvgTime As Double
    Get
ReadOnly Property AvgTime As Double
    Get
property double AvgTime {
    double get ();
}
property double AvgTime {
    double get ();
}
abstract AvgTime : float with get
abstract AvgTime : float with get

Property Value

Type: Online Double
See Also
ITimeHistogram Interface
ITimeHistogram Members
NFX.Instrumentation.Analytics Namespace


ITimeHistogram.MaxTime Property

ITimeHistogram MaxTime Property NFX Class Library

Maximum time of all measured samples

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
double MaxTime { get; }
double MaxTime { get; }
ReadOnly Property MaxTime As Double
    Get
ReadOnly Property MaxTime As Double
    Get
property double MaxTime {
    double get ();
}
property double MaxTime {
    double get ();
}
abstract MaxTime : float with get
abstract MaxTime : float with get

Property Value

Type: Online Double
See Also
ITimeHistogram Interface
ITimeHistogram Members
NFX.Instrumentation.Analytics Namespace


ITimeHistogram.MinTime Property

ITimeHistogram MinTime Property NFX Class Library

Minimum time of all measured samples

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
double MinTime { get; }
double MinTime { get; }
ReadOnly Property MinTime As Double
    Get
ReadOnly Property MinTime As Double
    Get
property double MinTime {
    double get ();
}
property double MinTime {
    double get ();
}
abstract MinTime : float with get
abstract MinTime : float with get

Property Value

Type: Online Double
See Also
ITimeHistogram Interface
ITimeHistogram Members
NFX.Instrumentation.Analytics Namespace


PartitionFunc(TData) Delegate

PartitionFunc TData Delegate NFX Class Library

References a function that maps input value into a partition index in the context of a given Partitioner

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate int PartitionFunc<TData>(
    Dimension<TData> sender,
    TData value
)
public delegate int PartitionFunc<TData>(
    Dimension<TData> sender,
    TData value
)
Public Delegate Function PartitionFunc(Of TData) (
    sender As Dimension(Of TData),
    value As TData
) As Integer
Public Delegate Function PartitionFunc(Of TData) (
    sender As Dimension(Of TData),
    value As TData
) As Integer
generic<typename TData>
public delegate int PartitionFunc(
    Dimension<TData>^ sender,
    TData value
)
generic<typename TData>
public delegate int PartitionFunc(
    Dimension<TData>^ sender,
    TData value
)
type PartitionFunc =
    delegate of
        sender : Dimension<'TData> *
        value : 'TData -> int
type PartitionFunc =
    delegate of
        sender : Dimension<'TData> *
        value : 'TData -> int

Parameters

sender
Type: NFX.Instrumentation.Analytics Dimension TData
value
Type: TData
Type Parameters
TData

Return Value

Type: Online Int32
See Also
NFX.Instrumentation.Analytics Namespace


PartitionNameFunc Delegate

PartitionNameFunc Delegate NFX Class Library

Returns a partition name for a given partition index

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate string PartitionNameFunc(
    int idx
)
public delegate string PartitionNameFunc(
    int idx
)
Public Delegate Function PartitionNameFunc (
    idx As Integer
) As String
Public Delegate Function PartitionNameFunc (
    idx As Integer
) As String
public delegate String^ PartitionNameFunc(
    int idx
)
public delegate String^ PartitionNameFunc(
    int idx
)
type PartitionNameFunc =
    delegate of
        idx : int -> string
type PartitionNameFunc =
    delegate of
        idx : int -> string

Parameters

idx
Type: Online System Int32

Return Value

Type: Online String
See Also
NFX.Instrumentation.Analytics Namespace


TimeDimension Class

TimeDimension Class NFX Class Library

A dimension of data type double partitions a range of values by mapping the given value into [0 ... PartitionCount] partitions. This is a helper class for creating a dimension of TimeHistogram
Inheritance Hierarchy
Online System Object
NFX.Instrumentation.Analytics Dimension
NFX.Instrumentation.Analytics Dimension Online Double
NFX.Instrumentation.Analytics TimeDimension

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TimeDimension : Dimension<double>
public class TimeDimension : Dimension<double>
Public Class TimeDimension
    Inherits Dimension(Of Double)
Public Class TimeDimension
    Inherits Dimension(Of Double)
public ref class TimeDimension : public Dimension<double>
public ref class TimeDimension : public Dimension<double>
type TimeDimension =
    class
        inherit Dimension<float>
    end
type TimeDimension =
    class
        inherit Dimension<float>
    end
See Also
TimeDimension Members
NFX.Instrumentation.Analytics Namespace


TimeDimension Members

TimeDimension Members NFX Class Library

The TimeDimension type exposes the following members.
Constructors
 | Name | Description
Public method | TimeDimension | Creates a histogram dimension. If partitionFunc is null then DoPartition must be overriden in the derived class
Back to Top
Methods
 | Name | Description
Protected method | DoPartition | (Overrides Dimension TData DoPartition(TData).)
Protected method | DoPartitionName | (Overrides Dimension DoPartitionName(Int32).)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetPartitionName | Returns the name of a partition identified by idx (Inherited from Dimension.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | SetIndex | (Inherited from Dimension.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | DEFAULT_PART_COUNT |
Protected field | m_PartitionFunc | (Inherited from Dimension TData .)
Public field | Name | Provides meaningful name for displaying (Inherited from Dimension.)
Public field | PartitionCount | Number of partitions in (Inherited from Dimension.)
Back to Top
Properties
 | Name | Description
Public property | DataType | Returns the type of data that this instance partitions (Inherited from Dimension TData .)
Public property | Index | Index of this dimension in the histogram (Inherited from Dimension.)
Public property | Item | Maps a value into partition index
Back to Top
See Also
TimeDimension Class
NFX.Instrumentation.Analytics Namespace


TimeDimension Constructor

TimeDimension Constructor NFX Class Library

Creates a histogram dimension. If partitionFunc is null then DoPartition must be overriden in the derived class

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeDimension(
    string desc,
    int partCount = 7,
    PartitionFunc<double> partitionFunc = null,
    PartitionNameFunc partitionNameFunc = null
)
public TimeDimension(
    string desc,
    int partCount = 7,
    PartitionFunc<double> partitionFunc = null,
    PartitionNameFunc partitionNameFunc = null
)
Public Sub New (
    desc As String,
    Optional partCount As Integer = 7,
    Optional partitionFunc As PartitionFunc(Of Double) = Nothing,
    Optional partitionNameFunc As PartitionNameFunc = Nothing
)
Public Sub New (
    desc As String,
    Optional partCount As Integer = 7,
    Optional partitionFunc As PartitionFunc(Of Double) = Nothing,
    Optional partitionNameFunc As PartitionNameFunc = Nothing
)
public:
TimeDimension(
    String^ desc,
    int partCount = 7,
    PartitionFunc<double>^ partitionFunc = nullptr,
    PartitionNameFunc^ partitionNameFunc = nullptr
)
public:
TimeDimension(
    String^ desc,
    int partCount = 7,
    PartitionFunc<double>^ partitionFunc = nullptr,
    PartitionNameFunc^ partitionNameFunc = nullptr
)
new :
        desc : string *
        ?partCount : int *
        ?partitionFunc : PartitionFunc<float> *
        ?partitionNameFunc : PartitionNameFunc
(* Defaults:
        let _partCount = defaultArg partCount 7
        let _partitionFunc = defaultArg partitionFunc null
        let _partitionNameFunc = defaultArg partitionNameFunc null
*)
-> TimeDimension
new :
        desc : string *
        ?partCount : int *
        ?partitionFunc : PartitionFunc<float> *
        ?partitionNameFunc : PartitionNameFunc
(* Defaults:
        let _partCount = defaultArg partCount 7
        let _partitionFunc = defaultArg partitionFunc null
        let _partitionNameFunc = defaultArg partitionNameFunc null
*)
-> TimeDimension

Parameters

desc
Type: Online System String
Description of dimension used in reporting
partCount (Optional)
Type: Online System Int32
Total number of partitions
partitionFunc (Optional)
Type: NFX.Instrumentation.Analytics PartitionFunc Online Double
Used to inject a function in order not to override this class
partitionNameFunc (Optional)
Type: NFX.Instrumentation.Analytics PartitionNameFunc
Used to inject a function in order not to override this class
See Also
TimeDimension Class
TimeDimension Members
NFX.Instrumentation.Analytics Namespace


TimeDimension Fields

TimeDimension Fields NFX Class Library

The TimeDimension type exposes the following members.
Fields
 | Name | Description
 | DEFAULT_PART_COUNT |
Protected field | m_PartitionFunc | (Inherited from Dimension TData .)
Public field | Name | Provides meaningful name for displaying (Inherited from Dimension.)
Public field | PartitionCount | Number of partitions in (Inherited from Dimension.)
Back to Top
See Also
TimeDimension Class
NFX.Instrumentation.Analytics Namespace


TimeDimension.DEFAULT_PART_COUNT Field

TimeDimension DEFAULT_PART_COUNT Field NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal const int DEFAULT_PART_COUNT
internal const int DEFAULT_PART_COUNT
Friend Const DEFAULT_PART_COUNT As Integer
Friend Const DEFAULT_PART_COUNT As Integer
internal:
literal int DEFAULT_PART_COUNT
internal:
literal int DEFAULT_PART_COUNT
static val mutable internal DEFAULT_PART_COUNT: int
static val mutable internal DEFAULT_PART_COUNT: int

Field Value

Type: Online Int32
See Also
TimeDimension Class
TimeDimension Members
NFX.Instrumentation.Analytics Namespace


TimeDimension Methods

TimeDimension Methods NFX Class Library

The TimeDimension type exposes the following members.
Methods
 | Name | Description
Protected method | DoPartition | (Overrides Dimension TData DoPartition(TData).)
Protected method | DoPartitionName | (Overrides Dimension DoPartitionName(Int32).)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetPartitionName | Returns the name of a partition identified by idx (Inherited from Dimension.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | SetIndex | (Inherited from Dimension.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TimeDimension Class
NFX.Instrumentation.Analytics Namespace


TimeDimension.DoPartition Method

TimeDimension DoPartition Method NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override int DoPartition(
    double v
)
protected override int DoPartition(
    double v
)
Protected Overrides Function DoPartition (
    v As Double
) As Integer
Protected Overrides Function DoPartition (
    v As Double
) As Integer
protected:
virtual int DoPartition(
    double v
) override
protected:
virtual int DoPartition(
    double v
) override
abstract DoPartition :
        v : float -> int
override DoPartition :
        v : float -> int
abstract DoPartition :
        v : float -> int
override DoPartition :
        v : float -> int

Parameters

v
Type: Online System Double

Return Value

Type: Online Int32
See Also
TimeDimension Class
TimeDimension Members
NFX.Instrumentation.Analytics Namespace


TimeDimension.DoPartitionName Method

TimeDimension DoPartitionName Method NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override string DoPartitionName(
    int i
)
protected override string DoPartitionName(
    int i
)
Protected Overrides Function DoPartitionName (
    i As Integer
) As String
Protected Overrides Function DoPartitionName (
    i As Integer
) As String
protected:
virtual String^ DoPartitionName(
    int i
) override
protected:
virtual String^ DoPartitionName(
    int i
) override
abstract DoPartitionName :
        i : int -> string
override DoPartitionName :
        i : int -> string
abstract DoPartitionName :
        i : int -> string
override DoPartitionName :
        i : int -> string

Parameters

i
Type: Online System Int32

Return Value

Type: Online String
See Also
TimeDimension Class
TimeDimension Members
NFX.Instrumentation.Analytics Namespace


TimeDimension Properties

TimeDimension Properties NFX Class Library

The TimeDimension type exposes the following members.
Properties
 | Name | Description
Public property | DataType | Returns the type of data that this instance partitions (Inherited from Dimension TData .)
Public property | Index | Index of this dimension in the histogram (Inherited from Dimension.)
Public property | Item | Maps a value into partition index
Back to Top
See Also
TimeDimension Class
NFX.Instrumentation.Analytics Namespace


TimeDimension.Item Property

TimeDimension Item Property NFX Class Library

Maps a value into partition index

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int this[
    double value
] { get; }
public int this[
    double value
] { get; }
Public ReadOnly Default Property Item (
    value As Double
) As Integer
    Get
Public ReadOnly Default Property Item (
    value As Double
) As Integer
    Get
public:
property int default[double value] {
    int get (double value);
}
public:
property int default[double value] {
    int get (double value);
}
member Item : int with get
member Item : int with get

Parameters

value
Type: Online System Double

Property Value

Type: Online Int32
See Also
TimeDimension Class
TimeDimension Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram Class

TimeHistogram Class NFX Class Library

Time measurement 1D histogram aggregates measurements in fractions of a second
Inheritance Hierarchy
Online System Object
NFX.Instrumentation.Analytics TimeHistogram

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TimeHistogram : ITimeHistogram,
    IHistogram, IEnumerable<HistogramEntry>, IEnumerable
public class TimeHistogram : ITimeHistogram,
    IHistogram, IEnumerable<HistogramEntry>, IEnumerable
Public Class TimeHistogram
    Implements ITimeHistogram, IHistogram, IEnumerable(Of HistogramEntry),
    IEnumerable
Public Class TimeHistogram
    Implements ITimeHistogram, IHistogram, IEnumerable(Of HistogramEntry),
    IEnumerable
public ref class TimeHistogram : ITimeHistogram,
    IHistogram, IEnumerable<HistogramEntry^>, IEnumerable
public ref class TimeHistogram : ITimeHistogram,
    IHistogram, IEnumerable<HistogramEntry^>, IEnumerable
type TimeHistogram =
    class
        interface ITimeHistogram
        interface IHistogram
        interface IEnumerable<HistogramEntry>
        interface IEnumerable
    end
type TimeHistogram =
    class
        interface ITimeHistogram
        interface IHistogram
        interface IEnumerable<HistogramEntry>
        interface IEnumerable
    end
See Also
TimeHistogram Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram Members

TimeHistogram Members NFX Class Library

The TimeHistogram type exposes the following members.
Constructors
 | Name | Description
Public method | TimeHistogram(String, String, PartitionFunc Double , PartitionNameFunc) | Initializes a new instance of the TimeHistogram class
Public method | TimeHistogram(String, String, Int32, PartitionFunc Double , PartitionNameFunc) | Initializes a new instance of the TimeHistogram class
Back to Top
Methods
 | Name | Description
Public method | Clear | Reset internal histogram state
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDimention | Return a dimension of a histogram identified by index
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetPartitionName | Returns the name of a partition in a given histogram dimension
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Sample | Records time measurement in seconds
Public method | Start | Start sample time measurement
Public method | Stop | Stop sample time measurement started by Start() call
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryGet | Try to get the count of samples for the given histogram keys
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable HistogramEntry | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct HistogramEntry, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax HistogramEntry, TComparand (Func HistogramEntry, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax HistogramEntry, TComparand (Func HistogramEntry, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin HistogramEntry, TComparand (Func HistogramEntry, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin HistogramEntry, TComparand (Func HistogramEntry, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault HistogramEntry | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach HistogramEntry (Action HistogramEntry ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach HistogramEntry (Action HistogramEntry, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast HistogramEntry | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast HistogramEntry (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToStringReport | (Defined by HistogramReporters.)
Back to Top
Properties
 | Name | Description
Public property | AvgTime | Average time of all sample measurements
Public property | DimensionCount | Number of dimensions in this histogram
Public property | Dimensions | Returns the dimension instances of this histogram
Public property | Item | Return the count of samples for the given histogram keys
Public property | MaxTime | Maximum time of all sample measurements
Public property | MinTime | Minimum time of all sample measurements
Public property | TimeFrame | Returns a disposable instance suitable for time measurement in a "using" block
Public property | Title | Histogram title used for displaying purposes
Public property | TotalSamples | Total number of samples in the histogram
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
TimeHistogram Class
NFX.Instrumentation.Analytics Namespace


TimeHistogram Constructor

TimeHistogram Constructor NFX Class Library

Overload List
 | Name | Description
Public method | TimeHistogram(String, String, PartitionFunc Double , PartitionNameFunc) | Initializes a new instance of the TimeHistogram class
Public method | TimeHistogram(String, String, Int32, PartitionFunc Double , PartitionNameFunc) | Initializes a new instance of the TimeHistogram class
Back to Top
See Also
TimeHistogram Class
TimeHistogram Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram Constructor (String, String, PartitionFunc(Double), PartitionNameFunc)

TimeHistogram Constructor (String, String, PartitionFunc Double , PartitionNameFunc) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TimeHistogram class

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeHistogram(
    string title,
    string dim1Name,
    PartitionFunc<double> dim1PartitionFunc = null,
    PartitionNameFunc dim1PartitionNameFunc = null
)
public TimeHistogram(
    string title,
    string dim1Name,
    PartitionFunc<double> dim1PartitionFunc = null,
    PartitionNameFunc dim1PartitionNameFunc = null
)
Public Sub New (
    title As String,
    dim1Name As String,
    Optional dim1PartitionFunc As PartitionFunc(Of Double) = Nothing,
    Optional dim1PartitionNameFunc As PartitionNameFunc = Nothing
)
Public Sub New (
    title As String,
    dim1Name As String,
    Optional dim1PartitionFunc As PartitionFunc(Of Double) = Nothing,
    Optional dim1PartitionNameFunc As PartitionNameFunc = Nothing
)
public:
TimeHistogram(
    String^ title,
    String^ dim1Name,
    PartitionFunc<double>^ dim1PartitionFunc = nullptr,
    PartitionNameFunc^ dim1PartitionNameFunc = nullptr
)
public:
TimeHistogram(
    String^ title,
    String^ dim1Name,
    PartitionFunc<double>^ dim1PartitionFunc = nullptr,
    PartitionNameFunc^ dim1PartitionNameFunc = nullptr
)
new :
        title : string *
        dim1Name : string *
        ?dim1PartitionFunc : PartitionFunc<float> *
        ?dim1PartitionNameFunc : PartitionNameFunc
(* Defaults:
        let _dim1PartitionFunc = defaultArg dim1PartitionFunc null
        let _dim1PartitionNameFunc = defaultArg dim1PartitionNameFunc null
*)
-> TimeHistogram
new :
        title : string *
        dim1Name : string *
        ?dim1PartitionFunc : PartitionFunc<float> *
        ?dim1PartitionNameFunc : PartitionNameFunc
(* Defaults:
        let _dim1PartitionFunc = defaultArg dim1PartitionFunc null
        let _dim1PartitionNameFunc = defaultArg dim1PartitionNameFunc null
*)
-> TimeHistogram

Parameters

title
Type: Online System String
dim1Name
Type: Online System String
dim1PartitionFunc (Optional)
Type: NFX.Instrumentation.Analytics PartitionFunc Online Double
dim1PartitionNameFunc (Optional)
Type: NFX.Instrumentation.Analytics PartitionNameFunc
See Also
TimeHistogram Class
TimeHistogram Members
TimeHistogram Overload
NFX.Instrumentation.Analytics Namespace


TimeHistogram Constructor (String, String, Int32, PartitionFunc(Double), PartitionNameFunc)

TimeHistogram Constructor (String, String, Int32, PartitionFunc Double , PartitionNameFunc) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TimeHistogram class

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeHistogram(
    string title,
    string dim1Name,
    int dim1PartCount,
    PartitionFunc<double> dim1PartitionFunc = null,
    PartitionNameFunc dim1PartitionNameFunc = null
)
public TimeHistogram(
    string title,
    string dim1Name,
    int dim1PartCount,
    PartitionFunc<double> dim1PartitionFunc = null,
    PartitionNameFunc dim1PartitionNameFunc = null
)
Public Sub New (
    title As String,
    dim1Name As String,
    dim1PartCount As Integer,
    Optional dim1PartitionFunc As PartitionFunc(Of Double) = Nothing,
    Optional dim1PartitionNameFunc As PartitionNameFunc = Nothing
)
Public Sub New (
    title As String,
    dim1Name As String,
    dim1PartCount As Integer,
    Optional dim1PartitionFunc As PartitionFunc(Of Double) = Nothing,
    Optional dim1PartitionNameFunc As PartitionNameFunc = Nothing
)
public:
TimeHistogram(
    String^ title,
    String^ dim1Name,
    int dim1PartCount,
    PartitionFunc<double>^ dim1PartitionFunc = nullptr,
    PartitionNameFunc^ dim1PartitionNameFunc = nullptr
)
public:
TimeHistogram(
    String^ title,
    String^ dim1Name,
    int dim1PartCount,
    PartitionFunc<double>^ dim1PartitionFunc = nullptr,
    PartitionNameFunc^ dim1PartitionNameFunc = nullptr
)
new :
        title : string *
        dim1Name : string *
        dim1PartCount : int *
        ?dim1PartitionFunc : PartitionFunc<float> *
        ?dim1PartitionNameFunc : PartitionNameFunc
(* Defaults:
        let _dim1PartitionFunc = defaultArg dim1PartitionFunc null
        let _dim1PartitionNameFunc = defaultArg dim1PartitionNameFunc null
*)
-> TimeHistogram
new :
        title : string *
        dim1Name : string *
        dim1PartCount : int *
        ?dim1PartitionFunc : PartitionFunc<float> *
        ?dim1PartitionNameFunc : PartitionNameFunc
(* Defaults:
        let _dim1PartitionFunc = defaultArg dim1PartitionFunc null
        let _dim1PartitionNameFunc = defaultArg dim1PartitionNameFunc null
*)
-> TimeHistogram

Parameters

title
Type: Online System String
dim1Name
Type: Online System String
dim1PartCount
Type: Online System Int32
dim1PartitionFunc (Optional)
Type: NFX.Instrumentation.Analytics PartitionFunc Online Double
dim1PartitionNameFunc (Optional)
Type: NFX.Instrumentation.Analytics PartitionNameFunc
See Also
TimeHistogram Class
TimeHistogram Members
TimeHistogram Overload
NFX.Instrumentation.Analytics Namespace


TimeHistogram Methods

TimeHistogram Methods NFX Class Library

The TimeHistogram type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Reset internal histogram state
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDimention | Return a dimension of a histogram identified by index
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetPartitionName | Returns the name of a partition in a given histogram dimension
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Sample | Records time measurement in seconds
Public method | Start | Start sample time measurement
Public method | Stop | Stop sample time measurement started by Start() call
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryGet | Try to get the count of samples for the given histogram keys
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable HistogramEntry | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct HistogramEntry, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax HistogramEntry, TComparand (Func HistogramEntry, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax HistogramEntry, TComparand (Func HistogramEntry, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin HistogramEntry, TComparand (Func HistogramEntry, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin HistogramEntry, TComparand (Func HistogramEntry, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault HistogramEntry | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach HistogramEntry (Action HistogramEntry ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach HistogramEntry (Action HistogramEntry, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast HistogramEntry | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast HistogramEntry (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToStringReport | (Defined by HistogramReporters.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
TimeHistogram Class
NFX.Instrumentation.Analytics Namespace


TimeHistogram.IEnumerable.GetEnumerator Method

TimeHistogram IEnumerable GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
TimeHistogram Class
TimeHistogram Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram.Clear Method

TimeHistogram Clear Method NFX Class Library

Reset internal histogram state

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
virtual void Clear() sealed
public:
virtual void Clear() sealed
abstract Clear : unit -> unit
override Clear : unit -> unit
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

IHistogram Clear
See Also
TimeHistogram Class
TimeHistogram Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram.GetDimention Method

TimeHistogram GetDimention Method NFX Class Library

Return a dimension of a histogram identified by index

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Dimension GetDimention(
    int dimension
)
public Dimension GetDimention(
    int dimension
)
Public Function GetDimention (
    dimension As Integer
) As Dimension
Public Function GetDimention (
    dimension As Integer
) As Dimension
public:
virtual Dimension^ GetDimention(
    int dimension
) sealed
public:
virtual Dimension^ GetDimention(
    int dimension
) sealed
abstract GetDimention :
        dimension : int -> Dimension
override GetDimention :
        dimension : int -> Dimension
abstract GetDimention :
        dimension : int -> Dimension
override GetDimention :
        dimension : int -> Dimension

Parameters

dimension
Type: Online System Int32

Return Value

Type: Dimension

Implements

IHistogram GetDimention(Int32)
See Also
TimeHistogram Class
TimeHistogram Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram.GetEnumerator Method

TimeHistogram GetEnumerator Method NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<HistogramEntry> GetEnumerator()
public IEnumerator<HistogramEntry> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of HistogramEntry)
Public Function GetEnumerator As IEnumerator(Of HistogramEntry)
public:
virtual IEnumerator<HistogramEntry^>^ GetEnumerator() sealed
public:
virtual IEnumerator<HistogramEntry^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<HistogramEntry>
override GetEnumerator : unit -> IEnumerator<HistogramEntry>
abstract GetEnumerator : unit -> IEnumerator<HistogramEntry>
override GetEnumerator : unit -> IEnumerator<HistogramEntry>

Return Value

Type: Online IEnumerator HistogramEntry

Implements

Online IEnumerable T GetEnumerator
See Also
TimeHistogram Class
TimeHistogram Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram.GetPartitionName Method

TimeHistogram GetPartitionName Method NFX Class Library

Returns the name of a partition in a given histogram dimension

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetPartitionName(
    int dimension,
    int partition
)
public string GetPartitionName(
    int dimension,
    int partition
)
Public Function GetPartitionName (
    dimension As Integer,
    partition As Integer
) As String
Public Function GetPartitionName (
    dimension As Integer,
    partition As Integer
) As String
public:
virtual String^ GetPartitionName(
    int dimension,
    int partition
) sealed
public:
virtual String^ GetPartitionName(
    int dimension,
    int partition
) sealed
abstract GetPartitionName :
        dimension : int *
        partition : int -> string
override GetPartitionName :
        dimension : int *
        partition : int -> string
abstract GetPartitionName :
        dimension : int *
        partition : int -> string
override GetPartitionName :
        dimension : int *
        partition : int -> string

Parameters

dimension
Type: Online System Int32
Dimension index
partition
Type: Online System Int32
Partition index

Return Value

Type: Online String

Implements

IHistogram GetPartitionName(Int32, Int32)
See Also
TimeHistogram Class
TimeHistogram Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram.Sample Method

TimeHistogram Sample Method NFX Class Library

Records time measurement in seconds

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Sample(
    double secInterval
)
public void Sample(
    double secInterval
)
Public Sub Sample (
    secInterval As Double
)
Public Sub Sample (
    secInterval As Double
)
public:
void Sample(
    double secInterval
)
public:
void Sample(
    double secInterval
)
member Sample :
        secInterval : float -> unit
member Sample :
        secInterval : float -> unit

Parameters

secInterval
Type: Online System Double
See Also
TimeHistogram Class
TimeHistogram Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram.Start Method

TimeHistogram Start Method NFX Class Library

Start sample time measurement

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Start()
public void Start()
Public Sub Start
Public Sub Start
public:
virtual void Start() sealed
public:
virtual void Start() sealed
abstract Start : unit -> unit
override Start : unit -> unit
abstract Start : unit -> unit
override Start : unit -> unit

Implements

ITimeHistogram Start
See Also
TimeHistogram Class
TimeHistogram Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram.Stop Method

TimeHistogram Stop Method NFX Class Library

Stop sample time measurement started by Start() call

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Stop()
public void Stop()
Public Sub Stop
Public Sub Stop
public:
void Stop()
public:
void Stop()
member Stop : unit -> unit
member Stop : unit -> unit
See Also
TimeHistogram Class
TimeHistogram Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram.TryGet Method

TimeHistogram TryGet Method NFX Class Library

Try to get the count of samples for the given histogram keys

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TryGet(
    HistogramKeys keys,
    out int count
)
public bool TryGet(
    HistogramKeys keys,
    out int count
)
Public Function TryGet (
    keys As HistogramKeys,
    <OutAttribute> ByRef count As Integer
) As Boolean
Public Function TryGet (
    keys As HistogramKeys,
    <OutAttribute> ByRef count As Integer
) As Boolean
public:
virtual bool TryGet(
    HistogramKeys keys,
    [OutAttribute] int% count
) sealed
public:
virtual bool TryGet(
    HistogramKeys keys,
    [OutAttribute] int% count
) sealed
abstract TryGet :
        keys : HistogramKeys *
        count : int byref -> bool
override TryGet :
        keys : HistogramKeys *
        count : int byref -> bool
abstract TryGet :
        keys : HistogramKeys *
        count : int byref -> bool
override TryGet :
        keys : HistogramKeys *
        count : int byref -> bool

Parameters

keys
Type: NFX.Instrumentation.Analytics HistogramKeys
count
Type: Online System Int32

Return Value

Type: Online Boolean

Implements

IHistogram TryGet(HistogramKeys, Int32 )
See Also
TimeHistogram Class
TimeHistogram Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram Properties

TimeHistogram Properties NFX Class Library

The TimeHistogram type exposes the following members.
Properties
 | Name | Description
Public property | AvgTime | Average time of all sample measurements
Public property | DimensionCount | Number of dimensions in this histogram
Public property | Dimensions | Returns the dimension instances of this histogram
Public property | Item | Return the count of samples for the given histogram keys
Public property | MaxTime | Maximum time of all sample measurements
Public property | MinTime | Minimum time of all sample measurements
Public property | TimeFrame | Returns a disposable instance suitable for time measurement in a "using" block
Public property | Title | Histogram title used for displaying purposes
Public property | TotalSamples | Total number of samples in the histogram
Back to Top
See Also
TimeHistogram Class
NFX.Instrumentation.Analytics Namespace


TimeHistogram.AvgTime Property

TimeHistogram AvgTime Property NFX Class Library

Average time of all sample measurements

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double AvgTime { get; }
public double AvgTime { get; }
Public ReadOnly Property AvgTime As Double
    Get
Public ReadOnly Property AvgTime As Double
    Get
public:
virtual property double AvgTime {
    double get () sealed;
}
public:
virtual property double AvgTime {
    double get () sealed;
}
abstract AvgTime : float with get
override AvgTime : float with get
abstract AvgTime : float with get
override AvgTime : float with get

Property Value

Type: Online Double

Implements

ITimeHistogram AvgTime
See Also
TimeHistogram Class
TimeHistogram Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram.DimensionCount Property

TimeHistogram DimensionCount Property NFX Class Library

Number of dimensions in this histogram

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int DimensionCount { get; }
public int DimensionCount { get; }
Public ReadOnly Property DimensionCount As Integer
    Get
Public ReadOnly Property DimensionCount As Integer
    Get
public:
virtual property int DimensionCount {
    int get () sealed;
}
public:
virtual property int DimensionCount {
    int get () sealed;
}
abstract DimensionCount : int with get
override DimensionCount : int with get
abstract DimensionCount : int with get
override DimensionCount : int with get

Property Value

Type: Online Int32

Implements

IHistogram DimensionCount
See Also
TimeHistogram Class
TimeHistogram Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram.Dimensions Property

TimeHistogram Dimensions Property NFX Class Library

Returns the dimension instances of this histogram

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Dimension> Dimensions { get; }
public IEnumerable<Dimension> Dimensions { get; }
Public ReadOnly Property Dimensions As IEnumerable(Of Dimension)
    Get
Public ReadOnly Property Dimensions As IEnumerable(Of Dimension)
    Get
public:
virtual property IEnumerable<Dimension^>^ Dimensions {
    IEnumerable<Dimension^>^ get () sealed;
}
public:
virtual property IEnumerable<Dimension^>^ Dimensions {
    IEnumerable<Dimension^>^ get () sealed;
}
abstract Dimensions : IEnumerable<Dimension> with get
override Dimensions : IEnumerable<Dimension> with get
abstract Dimensions : IEnumerable<Dimension> with get
override Dimensions : IEnumerable<Dimension> with get

Property Value

Type: Online IEnumerable Dimension

Implements

IHistogram Dimensions
See Also
TimeHistogram Class
TimeHistogram Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram.Item Property

TimeHistogram Item Property NFX Class Library

Return the count of samples for the given histogram keys

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int this[
    HistogramKeys keys
] { get; }
public int this[
    HistogramKeys keys
] { get; }
Public ReadOnly Default Property Item (
    keys As HistogramKeys
) As Integer
    Get
Public ReadOnly Default Property Item (
    keys As HistogramKeys
) As Integer
    Get
public:
virtual property int default[HistogramKeys keys] {
    int get (HistogramKeys keys) sealed;
}
public:
virtual property int default[HistogramKeys keys] {
    int get (HistogramKeys keys) sealed;
}
abstract Item : int with get
override Item : int with get
abstract Item : int with get
override Item : int with get

Parameters

keys
Type: NFX.Instrumentation.Analytics HistogramKeys

Property Value

Type: Online Int32

Implements

IHistogram Item HistogramKeys
See Also
TimeHistogram Class
TimeHistogram Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram.MaxTime Property

TimeHistogram MaxTime Property NFX Class Library

Maximum time of all sample measurements

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double MaxTime { get; }
public double MaxTime { get; }
Public ReadOnly Property MaxTime As Double
    Get
Public ReadOnly Property MaxTime As Double
    Get
public:
virtual property double MaxTime {
    double get () sealed;
}
public:
virtual property double MaxTime {
    double get () sealed;
}
abstract MaxTime : float with get
override MaxTime : float with get
abstract MaxTime : float with get
override MaxTime : float with get

Property Value

Type: Online Double

Implements

ITimeHistogram MaxTime
See Also
TimeHistogram Class
TimeHistogram Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram.MinTime Property

TimeHistogram MinTime Property NFX Class Library

Minimum time of all sample measurements

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double MinTime { get; }
public double MinTime { get; }
Public ReadOnly Property MinTime As Double
    Get
Public ReadOnly Property MinTime As Double
    Get
public:
virtual property double MinTime {
    double get () sealed;
}
public:
virtual property double MinTime {
    double get () sealed;
}
abstract MinTime : float with get
override MinTime : float with get
abstract MinTime : float with get
override MinTime : float with get

Property Value

Type: Online Double

Implements

ITimeHistogram MinTime
See Also
TimeHistogram Class
TimeHistogram Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram.TimeFrame Property

TimeHistogram TimeFrame Property NFX Class Library

Returns a disposable instance suitable for time measurement in a "using" block

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDisposable TimeFrame { get; }
public IDisposable TimeFrame { get; }
Public ReadOnly Property TimeFrame As IDisposable
    Get
Public ReadOnly Property TimeFrame As IDisposable
    Get
public:
property IDisposable^ TimeFrame {
    IDisposable^ get ();
}
public:
property IDisposable^ TimeFrame {
    IDisposable^ get ();
}
member TimeFrame : IDisposable with get
member TimeFrame : IDisposable with get

Property Value

Type: Online IDisposable
See Also
TimeHistogram Class
TimeHistogram Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram.Title Property

TimeHistogram Title Property NFX Class Library

Histogram title used for displaying purposes

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Title { get; }
public string Title { get; }
Public ReadOnly Property Title As String
    Get
Public ReadOnly Property Title As String
    Get
public:
virtual property String^ Title {
    String^ get () sealed;
}
public:
virtual property String^ Title {
    String^ get () sealed;
}
abstract Title : string with get
override Title : string with get
abstract Title : string with get
override Title : string with get

Property Value

Type: Online String

Implements

IHistogram Title
See Also
TimeHistogram Class
TimeHistogram Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram.TotalSamples Property

TimeHistogram TotalSamples Property NFX Class Library

Total number of samples in the histogram

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long TotalSamples { get; }
public long TotalSamples { get; }
Public ReadOnly Property TotalSamples As Long
    Get
Public ReadOnly Property TotalSamples As Long
    Get
public:
virtual property long long TotalSamples {
    long long get () sealed;
}
public:
virtual property long long TotalSamples {
    long long get () sealed;
}
abstract TotalSamples : int64 with get
override TotalSamples : int64 with get
abstract TotalSamples : int64 with get
override TotalSamples : int64 with get

Property Value

Type: Online Int64

Implements

IHistogram TotalSamples
See Also
TimeHistogram Class
TimeHistogram Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2) Class

TimeHistogram TData2 Class NFX Class Library

Time measurement 2D histogram aggregates measurements in fractions of a second for a given 1st dimension key.
Inheritance Hierarchy
Online System Object
NFX.Instrumentation.Analytics TimeHistogram TData2

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TimeHistogram<TData2> : ITimeHistogram,
    IHistogram, IEnumerable<HistogramEntry>, IEnumerable
public class TimeHistogram<TData2> : ITimeHistogram,
    IHistogram, IEnumerable<HistogramEntry>, IEnumerable
Public Class TimeHistogram(Of TData2)
    Implements ITimeHistogram, IHistogram, IEnumerable(Of HistogramEntry),
    IEnumerable
Public Class TimeHistogram(Of TData2)
    Implements ITimeHistogram, IHistogram, IEnumerable(Of HistogramEntry),
    IEnumerable
generic<typename TData2>
public ref class TimeHistogram : ITimeHistogram,
    IHistogram, IEnumerable<HistogramEntry^>, IEnumerable
generic<typename TData2>
public ref class TimeHistogram : ITimeHistogram,
    IHistogram, IEnumerable<HistogramEntry^>, IEnumerable
type TimeHistogram<'TData2> =
    class
        interface ITimeHistogram
        interface IHistogram
        interface IEnumerable<HistogramEntry>
        interface IEnumerable
    end
type TimeHistogram<'TData2> =
    class
        interface ITimeHistogram
        interface IHistogram
        interface IEnumerable<HistogramEntry>
        interface IEnumerable
    end
Type Parameters
TData2
See Also
TimeHistogram TData2 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2) Members

TimeHistogram TData2 Members NFX Class Library

The TimeHistogram TData2 type exposes the following members.
Constructors
 | Name | Description
Public method | TimeHistogram TData2 (String, String, Dimension TData2 ) | Initializes a new instance of the TimeHistogram TData2 class
Public method | TimeHistogram TData2 (String, String, Int32, Dimension TData2 ) | Initializes a new instance of the TimeHistogram TData2 class
Public method | TimeHistogram TData2 (String, String, Int32, PartitionFunc Double , Dimension TData2 ) | Initializes a new instance of the TimeHistogram TData2 class
Public method | TimeHistogram TData2 (String, String, Int32, PartitionFunc Double , PartitionNameFunc, Dimension TData2 ) | Initializes a new instance of the TimeHistogram TData2 class
Back to Top
Methods
 | Name | Description
Public method | Clear | Reset internal histogram state
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDimention | Return a dimension of a histogram identified by index
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetPartitionName | Returns the name of a partition in a given histogram dimension
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Sample | Records time measurement in seconds
Public method | Start | Start sample time measurement
Public method | Stop | Stop sample time measurement started by Start() call
Public method | TimeFrame | Returns a disposable instance suitable for time measurement in a "using" block
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryGet | Try to get the count of samples for the given histogram keys
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable HistogramEntry | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct HistogramEntry, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax HistogramEntry, TComparand (Func HistogramEntry, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax HistogramEntry, TComparand (Func HistogramEntry, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin HistogramEntry, TComparand (Func HistogramEntry, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin HistogramEntry, TComparand (Func HistogramEntry, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault HistogramEntry | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach HistogramEntry (Action HistogramEntry ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach HistogramEntry (Action HistogramEntry, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast HistogramEntry | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast HistogramEntry (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToStringReport | (Defined by HistogramReporters.)
Back to Top
Properties
 | Name | Description
Public property | AvgTime | Average time of all sample measurements
Public property | DimensionCount | Number of dimensions in this histogram
Public property | Dimensions | Returns the dimension instances of this histogram
Public property | Item | Return the count of samples for the given histogram keys
Public property | MaxTime | Maximum time of all sample measurements
Public property | MinTime | Minimum time of all sample measurements
Public property | Title | Histogram title used for displaying purposes
Public property | TotalSamples | Total number of samples in the histogram
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
TimeHistogram TData2 Class
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2) Constructor

TimeHistogram TData2 Constructor NFX Class Library

Overload List
 | Name | Description
Public method | TimeHistogram TData2 (String, String, Dimension TData2 ) | Initializes a new instance of the TimeHistogram TData2 class
Public method | TimeHistogram TData2 (String, String, Int32, Dimension TData2 ) | Initializes a new instance of the TimeHistogram TData2 class
Public method | TimeHistogram TData2 (String, String, Int32, PartitionFunc Double , Dimension TData2 ) | Initializes a new instance of the TimeHistogram TData2 class
Public method | TimeHistogram TData2 (String, String, Int32, PartitionFunc Double , PartitionNameFunc, Dimension TData2 ) | Initializes a new instance of the TimeHistogram TData2 class
Back to Top
See Also
TimeHistogram TData2 Class
TimeHistogram TData2 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2) Constructor (String, String, Dimension(TData2))

TimeHistogram TData2 Constructor (String, String, Dimension TData2 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TimeHistogram TData2 class

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeHistogram(
    string title,
    string dim1Name,
    Dimension<TData2> dimension2
)
public TimeHistogram(
    string title,
    string dim1Name,
    Dimension<TData2> dimension2
)
Public Sub New (
    title As String,
    dim1Name As String,
    dimension2 As Dimension(Of TData2)
)
Public Sub New (
    title As String,
    dim1Name As String,
    dimension2 As Dimension(Of TData2)
)
public:
TimeHistogram(
    String^ title,
    String^ dim1Name,
    Dimension<TData2>^ dimension2
)
public:
TimeHistogram(
    String^ title,
    String^ dim1Name,
    Dimension<TData2>^ dimension2
)
new :
        title : string *
        dim1Name : string *
        dimension2 : Dimension<'TData2> -> TimeHistogram
new :
        title : string *
        dim1Name : string *
        dimension2 : Dimension<'TData2> -> TimeHistogram

Parameters

title
Type: Online System String
dim1Name
Type: Online System String
dimension2
Type: NFX.Instrumentation.Analytics Dimension TData2
See Also
TimeHistogram TData2 Class
TimeHistogram TData2 Members
TimeHistogram TData2 Overload
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2) Constructor (String, String, Int32, Dimension(TData2))

TimeHistogram TData2 Constructor (String, String, Int32, Dimension TData2 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TimeHistogram TData2 class

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeHistogram(
    string title,
    string dim1Name,
    int dim1PartCount,
    Dimension<TData2> dimension2
)
public TimeHistogram(
    string title,
    string dim1Name,
    int dim1PartCount,
    Dimension<TData2> dimension2
)
Public Sub New (
    title As String,
    dim1Name As String,
    dim1PartCount As Integer,
    dimension2 As Dimension(Of TData2)
)
Public Sub New (
    title As String,
    dim1Name As String,
    dim1PartCount As Integer,
    dimension2 As Dimension(Of TData2)
)
public:
TimeHistogram(
    String^ title,
    String^ dim1Name,
    int dim1PartCount,
    Dimension<TData2>^ dimension2
)
public:
TimeHistogram(
    String^ title,
    String^ dim1Name,
    int dim1PartCount,
    Dimension<TData2>^ dimension2
)
new :
        title : string *
        dim1Name : string *
        dim1PartCount : int *
        dimension2 : Dimension<'TData2> -> TimeHistogram
new :
        title : string *
        dim1Name : string *
        dim1PartCount : int *
        dimension2 : Dimension<'TData2> -> TimeHistogram

Parameters

title
Type: Online System String
dim1Name
Type: Online System String
dim1PartCount
Type: Online System Int32
dimension2
Type: NFX.Instrumentation.Analytics Dimension TData2
See Also
TimeHistogram TData2 Class
TimeHistogram TData2 Members
TimeHistogram TData2 Overload
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2) Constructor (String, String, Int32, PartitionFunc(Double), Dimension(TData2))

TimeHistogram TData2 Constructor (String, String, Int32, PartitionFunc Double , Dimension TData2 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TimeHistogram TData2 class

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeHistogram(
    string title,
    string dim1Name,
    int dim1PartCount,
    PartitionFunc<double> dim1PartitionFunc,
    Dimension<TData2> dimension2
)
public TimeHistogram(
    string title,
    string dim1Name,
    int dim1PartCount,
    PartitionFunc<double> dim1PartitionFunc,
    Dimension<TData2> dimension2
)
Public Sub New (
    title As String,
    dim1Name As String,
    dim1PartCount As Integer,
    dim1PartitionFunc As PartitionFunc(Of Double),
    dimension2 As Dimension(Of TData2)
)
Public Sub New (
    title As String,
    dim1Name As String,
    dim1PartCount As Integer,
    dim1PartitionFunc As PartitionFunc(Of Double),
    dimension2 As Dimension(Of TData2)
)
public:
TimeHistogram(
    String^ title,
    String^ dim1Name,
    int dim1PartCount,
    PartitionFunc<double>^ dim1PartitionFunc,
    Dimension<TData2>^ dimension2
)
public:
TimeHistogram(
    String^ title,
    String^ dim1Name,
    int dim1PartCount,
    PartitionFunc<double>^ dim1PartitionFunc,
    Dimension<TData2>^ dimension2
)
new :
        title : string *
        dim1Name : string *
        dim1PartCount : int *
        dim1PartitionFunc : PartitionFunc<float> *
        dimension2 : Dimension<'TData2> -> TimeHistogram
new :
        title : string *
        dim1Name : string *
        dim1PartCount : int *
        dim1PartitionFunc : PartitionFunc<float> *
        dimension2 : Dimension<'TData2> -> TimeHistogram

Parameters

title
Type: Online System String
dim1Name
Type: Online System String
dim1PartCount
Type: Online System Int32
dim1PartitionFunc
Type: NFX.Instrumentation.Analytics PartitionFunc Online Double
dimension2
Type: NFX.Instrumentation.Analytics Dimension TData2
See Also
TimeHistogram TData2 Class
TimeHistogram TData2 Members
TimeHistogram TData2 Overload
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2) Constructor (String, String, Int32, PartitionFunc(Double), PartitionNameFunc, Dimension(TData2))

TimeHistogram TData2 Constructor (String, String, Int32, PartitionFunc Double , PartitionNameFunc, Dimension TData2 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TimeHistogram TData2 class

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeHistogram(
    string title,
    string dim1Name,
    int dim1PartCount,
    PartitionFunc<double> dim1PartitionFunc,
    PartitionNameFunc dim1PartitionNameFunc,
    Dimension<TData2> dimension2
)
public TimeHistogram(
    string title,
    string dim1Name,
    int dim1PartCount,
    PartitionFunc<double> dim1PartitionFunc,
    PartitionNameFunc dim1PartitionNameFunc,
    Dimension<TData2> dimension2
)
Public Sub New (
    title As String,
    dim1Name As String,
    dim1PartCount As Integer,
    dim1PartitionFunc As PartitionFunc(Of Double),
    dim1PartitionNameFunc As PartitionNameFunc,
    dimension2 As Dimension(Of TData2)
)
Public Sub New (
    title As String,
    dim1Name As String,
    dim1PartCount As Integer,
    dim1PartitionFunc As PartitionFunc(Of Double),
    dim1PartitionNameFunc As PartitionNameFunc,
    dimension2 As Dimension(Of TData2)
)
public:
TimeHistogram(
    String^ title,
    String^ dim1Name,
    int dim1PartCount,
    PartitionFunc<double>^ dim1PartitionFunc,
    PartitionNameFunc^ dim1PartitionNameFunc,
    Dimension<TData2>^ dimension2
)
public:
TimeHistogram(
    String^ title,
    String^ dim1Name,
    int dim1PartCount,
    PartitionFunc<double>^ dim1PartitionFunc,
    PartitionNameFunc^ dim1PartitionNameFunc,
    Dimension<TData2>^ dimension2
)
new :
        title : string *
        dim1Name : string *
        dim1PartCount : int *
        dim1PartitionFunc : PartitionFunc<float> *
        dim1PartitionNameFunc : PartitionNameFunc *
        dimension2 : Dimension<'TData2> -> TimeHistogram
new :
        title : string *
        dim1Name : string *
        dim1PartCount : int *
        dim1PartitionFunc : PartitionFunc<float> *
        dim1PartitionNameFunc : PartitionNameFunc *
        dimension2 : Dimension<'TData2> -> TimeHistogram

Parameters

title
Type: Online System String
dim1Name
Type: Online System String
dim1PartCount
Type: Online System Int32
dim1PartitionFunc
Type: NFX.Instrumentation.Analytics PartitionFunc Online Double
dim1PartitionNameFunc
Type: NFX.Instrumentation.Analytics PartitionNameFunc
dimension2
Type: NFX.Instrumentation.Analytics Dimension TData2
See Also
TimeHistogram TData2 Class
TimeHistogram TData2 Members
TimeHistogram TData2 Overload
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2) Methods

TimeHistogram TData2 Methods NFX Class Library

The TimeHistogram TData2 type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Reset internal histogram state
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDimention | Return a dimension of a histogram identified by index
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetPartitionName | Returns the name of a partition in a given histogram dimension
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Sample | Records time measurement in seconds
Public method | Start | Start sample time measurement
Public method | Stop | Stop sample time measurement started by Start() call
Public method | TimeFrame | Returns a disposable instance suitable for time measurement in a "using" block
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryGet | Try to get the count of samples for the given histogram keys
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable HistogramEntry | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct HistogramEntry, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax HistogramEntry, TComparand (Func HistogramEntry, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax HistogramEntry, TComparand (Func HistogramEntry, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin HistogramEntry, TComparand (Func HistogramEntry, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin HistogramEntry, TComparand (Func HistogramEntry, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault HistogramEntry | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach HistogramEntry (Action HistogramEntry ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach HistogramEntry (Action HistogramEntry, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast HistogramEntry | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast HistogramEntry (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToStringReport | (Defined by HistogramReporters.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
TimeHistogram TData2 Class
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2).IEnumerable.GetEnumerator Method

TimeHistogram TData2 IEnumerable GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
TimeHistogram TData2 Class
TimeHistogram TData2 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2).Clear Method

TimeHistogram TData2 Clear Method NFX Class Library

Reset internal histogram state

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
virtual void Clear() sealed
public:
virtual void Clear() sealed
abstract Clear : unit -> unit
override Clear : unit -> unit
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

IHistogram Clear
See Also
TimeHistogram TData2 Class
TimeHistogram TData2 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2).GetDimention Method

TimeHistogram TData2 GetDimention Method NFX Class Library

Return a dimension of a histogram identified by index

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Dimension GetDimention(
    int dimension
)
public Dimension GetDimention(
    int dimension
)
Public Function GetDimention (
    dimension As Integer
) As Dimension
Public Function GetDimention (
    dimension As Integer
) As Dimension
public:
virtual Dimension^ GetDimention(
    int dimension
) sealed
public:
virtual Dimension^ GetDimention(
    int dimension
) sealed
abstract GetDimention :
        dimension : int -> Dimension
override GetDimention :
        dimension : int -> Dimension
abstract GetDimention :
        dimension : int -> Dimension
override GetDimention :
        dimension : int -> Dimension

Parameters

dimension
Type: Online System Int32

Return Value

Type: Dimension

Implements

IHistogram GetDimention(Int32)
See Also
TimeHistogram TData2 Class
TimeHistogram TData2 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2).GetEnumerator Method

TimeHistogram TData2 GetEnumerator Method NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<HistogramEntry> GetEnumerator()
public IEnumerator<HistogramEntry> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of HistogramEntry)
Public Function GetEnumerator As IEnumerator(Of HistogramEntry)
public:
virtual IEnumerator<HistogramEntry^>^ GetEnumerator() sealed
public:
virtual IEnumerator<HistogramEntry^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<HistogramEntry>
override GetEnumerator : unit -> IEnumerator<HistogramEntry>
abstract GetEnumerator : unit -> IEnumerator<HistogramEntry>
override GetEnumerator : unit -> IEnumerator<HistogramEntry>

Return Value

Type: Online IEnumerator HistogramEntry

Implements

Online IEnumerable T GetEnumerator
See Also
TimeHistogram TData2 Class
TimeHistogram TData2 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2).GetPartitionName Method

TimeHistogram TData2 GetPartitionName Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns the name of a partition in a given histogram dimension

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetPartitionName(
    int dimension,
    int partition
)
public string GetPartitionName(
    int dimension,
    int partition
)
Public Function GetPartitionName (
    dimension As Integer,
    partition As Integer
) As String
Public Function GetPartitionName (
    dimension As Integer,
    partition As Integer
) As String
public:
virtual String^ GetPartitionName(
    int dimension,
    int partition
) sealed
public:
virtual String^ GetPartitionName(
    int dimension,
    int partition
) sealed
abstract GetPartitionName :
        dimension : int *
        partition : int -> string
override GetPartitionName :
        dimension : int *
        partition : int -> string
abstract GetPartitionName :
        dimension : int *
        partition : int -> string
override GetPartitionName :
        dimension : int *
        partition : int -> string

Parameters

dimension
Type: Online System Int32
Dimension index
partition
Type: Online System Int32
Partition index

Return Value

Type: Online String

Implements

IHistogram GetPartitionName(Int32, Int32)
See Also
TimeHistogram TData2 Class
TimeHistogram TData2 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2).Sample Method

TimeHistogram TData2 Sample Method NFX Class Library

Records time measurement in seconds

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Sample(
    double secInterval,
    TData2 dim2Value
)
public void Sample(
    double secInterval,
    TData2 dim2Value
)
Public Sub Sample (
    secInterval As Double,
    dim2Value As TData2
)
Public Sub Sample (
    secInterval As Double,
    dim2Value As TData2
)
public:
void Sample(
    double secInterval,
    TData2 dim2Value
)
public:
void Sample(
    double secInterval,
    TData2 dim2Value
)
member Sample :
        secInterval : float *
        dim2Value : 'TData2 -> unit
member Sample :
        secInterval : float *
        dim2Value : 'TData2 -> unit

Parameters

secInterval
Type: Online System Double
dim2Value
Type: TData2
See Also
TimeHistogram TData2 Class
TimeHistogram TData2 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2).Start Method

TimeHistogram TData2 Start Method NFX Class Library

Start sample time measurement

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Start()
public void Start()
Public Sub Start
Public Sub Start
public:
virtual void Start() sealed
public:
virtual void Start() sealed
abstract Start : unit -> unit
override Start : unit -> unit
abstract Start : unit -> unit
override Start : unit -> unit

Implements

ITimeHistogram Start
See Also
TimeHistogram TData2 Class
TimeHistogram TData2 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2).Stop Method

TimeHistogram TData2 Stop Method NFX Class Library

Stop sample time measurement started by Start() call

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Stop(
    TData2 dim2Value
)
public void Stop(
    TData2 dim2Value
)
Public Sub Stop (
    dim2Value As TData2
)
Public Sub Stop (
    dim2Value As TData2
)
public:
void Stop(
    TData2 dim2Value
)
public:
void Stop(
    TData2 dim2Value
)
member Stop :
        dim2Value : 'TData2 -> unit
member Stop :
        dim2Value : 'TData2 -> unit

Parameters

dim2Value
Type: TData2
See Also
TimeHistogram TData2 Class
TimeHistogram TData2 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2).TimeFrame Method

TimeHistogram TData2 TimeFrame Method NFX Class Library

Returns a disposable instance suitable for time measurement in a "using" block

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDisposable TimeFrame(
    TData2 dim1Value
)
public IDisposable TimeFrame(
    TData2 dim1Value
)
Public Function TimeFrame (
    dim1Value As TData2
) As IDisposable
Public Function TimeFrame (
    dim1Value As TData2
) As IDisposable
public:
IDisposable^ TimeFrame(
    TData2 dim1Value
)
public:
IDisposable^ TimeFrame(
    TData2 dim1Value
)
member TimeFrame :
        dim1Value : 'TData2 -> IDisposable
member TimeFrame :
        dim1Value : 'TData2 -> IDisposable

Parameters

dim1Value
Type: TData2

Return Value

Type: Online IDisposable
See Also
TimeHistogram TData2 Class
TimeHistogram TData2 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2).TryGet Method

TimeHistogram TData2 TryGet Method NFX Class Library

Try to get the count of samples for the given histogram keys

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TryGet(
    HistogramKeys keys,
    out int count
)
public bool TryGet(
    HistogramKeys keys,
    out int count
)
Public Function TryGet (
    keys As HistogramKeys,
    <OutAttribute> ByRef count As Integer
) As Boolean
Public Function TryGet (
    keys As HistogramKeys,
    <OutAttribute> ByRef count As Integer
) As Boolean
public:
virtual bool TryGet(
    HistogramKeys keys,
    [OutAttribute] int% count
) sealed
public:
virtual bool TryGet(
    HistogramKeys keys,
    [OutAttribute] int% count
) sealed
abstract TryGet :
        keys : HistogramKeys *
        count : int byref -> bool
override TryGet :
        keys : HistogramKeys *
        count : int byref -> bool
abstract TryGet :
        keys : HistogramKeys *
        count : int byref -> bool
override TryGet :
        keys : HistogramKeys *
        count : int byref -> bool

Parameters

keys
Type: NFX.Instrumentation.Analytics HistogramKeys
count
Type: Online System Int32

Return Value

Type: Online Boolean

Implements

IHistogram TryGet(HistogramKeys, Int32 )
See Also
TimeHistogram TData2 Class
TimeHistogram TData2 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2) Properties

TimeHistogram TData2 Properties NFX Class Library

The TimeHistogram TData2 type exposes the following members.
Properties
 | Name | Description
Public property | AvgTime | Average time of all sample measurements
Public property | DimensionCount | Number of dimensions in this histogram
Public property | Dimensions | Returns the dimension instances of this histogram
Public property | Item | Return the count of samples for the given histogram keys
Public property | MaxTime | Maximum time of all sample measurements
Public property | MinTime | Minimum time of all sample measurements
Public property | Title | Histogram title used for displaying purposes
Public property | TotalSamples | Total number of samples in the histogram
Back to Top
See Also
TimeHistogram TData2 Class
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2).AvgTime Property

TimeHistogram TData2 AvgTime Property NFX Class Library

Average time of all sample measurements

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double AvgTime { get; }
public double AvgTime { get; }
Public ReadOnly Property AvgTime As Double
    Get
Public ReadOnly Property AvgTime As Double
    Get
public:
virtual property double AvgTime {
    double get () sealed;
}
public:
virtual property double AvgTime {
    double get () sealed;
}
abstract AvgTime : float with get
override AvgTime : float with get
abstract AvgTime : float with get
override AvgTime : float with get

Property Value

Type: Online Double

Implements

ITimeHistogram AvgTime
See Also
TimeHistogram TData2 Class
TimeHistogram TData2 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2).DimensionCount Property

TimeHistogram TData2 DimensionCount Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Number of dimensions in this histogram

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int DimensionCount { get; }
public int DimensionCount { get; }
Public ReadOnly Property DimensionCount As Integer
    Get
Public ReadOnly Property DimensionCount As Integer
    Get
public:
virtual property int DimensionCount {
    int get () sealed;
}
public:
virtual property int DimensionCount {
    int get () sealed;
}
abstract DimensionCount : int with get
override DimensionCount : int with get
abstract DimensionCount : int with get
override DimensionCount : int with get

Property Value

Type: Online Int32

Implements

IHistogram DimensionCount
See Also
TimeHistogram TData2 Class
TimeHistogram TData2 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2).Dimensions Property

TimeHistogram TData2 Dimensions Property NFX Class Library

Returns the dimension instances of this histogram

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Dimension> Dimensions { get; }
public IEnumerable<Dimension> Dimensions { get; }
Public ReadOnly Property Dimensions As IEnumerable(Of Dimension)
    Get
Public ReadOnly Property Dimensions As IEnumerable(Of Dimension)
    Get
public:
virtual property IEnumerable<Dimension^>^ Dimensions {
    IEnumerable<Dimension^>^ get () sealed;
}
public:
virtual property IEnumerable<Dimension^>^ Dimensions {
    IEnumerable<Dimension^>^ get () sealed;
}
abstract Dimensions : IEnumerable<Dimension> with get
override Dimensions : IEnumerable<Dimension> with get
abstract Dimensions : IEnumerable<Dimension> with get
override Dimensions : IEnumerable<Dimension> with get

Property Value

Type: Online IEnumerable Dimension

Implements

IHistogram Dimensions
See Also
TimeHistogram TData2 Class
TimeHistogram TData2 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2).Item Property

TimeHistogram TData2 Item Property NFX Class Library

Return the count of samples for the given histogram keys

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int this[
    HistogramKeys keys
] { get; }
public int this[
    HistogramKeys keys
] { get; }
Public ReadOnly Default Property Item (
    keys As HistogramKeys
) As Integer
    Get
Public ReadOnly Default Property Item (
    keys As HistogramKeys
) As Integer
    Get
public:
virtual property int default[HistogramKeys keys] {
    int get (HistogramKeys keys) sealed;
}
public:
virtual property int default[HistogramKeys keys] {
    int get (HistogramKeys keys) sealed;
}
abstract Item : int with get
override Item : int with get
abstract Item : int with get
override Item : int with get

Parameters

keys
Type: NFX.Instrumentation.Analytics HistogramKeys

Property Value

Type: Online Int32

Implements

IHistogram Item HistogramKeys
See Also
TimeHistogram TData2 Class
TimeHistogram TData2 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2).MaxTime Property

TimeHistogram TData2 MaxTime Property NFX Class Library

Maximum time of all sample measurements

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double MaxTime { get; }
public double MaxTime { get; }
Public ReadOnly Property MaxTime As Double
    Get
Public ReadOnly Property MaxTime As Double
    Get
public:
virtual property double MaxTime {
    double get () sealed;
}
public:
virtual property double MaxTime {
    double get () sealed;
}
abstract MaxTime : float with get
override MaxTime : float with get
abstract MaxTime : float with get
override MaxTime : float with get

Property Value

Type: Online Double

Implements

ITimeHistogram MaxTime
See Also
TimeHistogram TData2 Class
TimeHistogram TData2 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2).MinTime Property

TimeHistogram TData2 MinTime Property NFX Class Library

Minimum time of all sample measurements

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double MinTime { get; }
public double MinTime { get; }
Public ReadOnly Property MinTime As Double
    Get
Public ReadOnly Property MinTime As Double
    Get
public:
virtual property double MinTime {
    double get () sealed;
}
public:
virtual property double MinTime {
    double get () sealed;
}
abstract MinTime : float with get
override MinTime : float with get
abstract MinTime : float with get
override MinTime : float with get

Property Value

Type: Online Double

Implements

ITimeHistogram MinTime
See Also
TimeHistogram TData2 Class
TimeHistogram TData2 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2).Title Property

TimeHistogram TData2 Title Property NFX Class Library

Histogram title used for displaying purposes

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Title { get; }
public string Title { get; }
Public ReadOnly Property Title As String
    Get
Public ReadOnly Property Title As String
    Get
public:
virtual property String^ Title {
    String^ get () sealed;
}
public:
virtual property String^ Title {
    String^ get () sealed;
}
abstract Title : string with get
override Title : string with get
abstract Title : string with get
override Title : string with get

Property Value

Type: Online String

Implements

IHistogram Title
See Also
TimeHistogram TData2 Class
TimeHistogram TData2 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2).TotalSamples Property

TimeHistogram TData2 TotalSamples Property NFX Class Library

Total number of samples in the histogram

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long TotalSamples { get; }
public long TotalSamples { get; }
Public ReadOnly Property TotalSamples As Long
    Get
Public ReadOnly Property TotalSamples As Long
    Get
public:
virtual property long long TotalSamples {
    long long get () sealed;
}
public:
virtual property long long TotalSamples {
    long long get () sealed;
}
abstract TotalSamples : int64 with get
override TotalSamples : int64 with get
abstract TotalSamples : int64 with get
override TotalSamples : int64 with get

Property Value

Type: Online Int64

Implements

IHistogram TotalSamples
See Also
TimeHistogram TData2 Class
TimeHistogram TData2 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2, TData3) Class

TimeHistogram TData2, TData3 Class NFX Class Library

Time measurement 3D histogram aggregates measurements in fractions of a second for a given 1st and 2nd dimension keys.
Inheritance Hierarchy
Online System Object
NFX.Instrumentation.Analytics TimeHistogram TData2, TData3

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TimeHistogram<TData2, TData3> : ITimeHistogram,
    IHistogram, IEnumerable<HistogramEntry>, IEnumerable
public class TimeHistogram<TData2, TData3> : ITimeHistogram,
    IHistogram, IEnumerable<HistogramEntry>, IEnumerable
Public Class TimeHistogram(Of TData2, TData3)
    Implements ITimeHistogram, IHistogram, IEnumerable(Of HistogramEntry),
    IEnumerable
Public Class TimeHistogram(Of TData2, TData3)
    Implements ITimeHistogram, IHistogram, IEnumerable(Of HistogramEntry),
    IEnumerable
generic<typename TData2, typename TData3>
public ref class TimeHistogram : ITimeHistogram,
    IHistogram, IEnumerable<HistogramEntry^>, IEnumerable
generic<typename TData2, typename TData3>
public ref class TimeHistogram : ITimeHistogram,
    IHistogram, IEnumerable<HistogramEntry^>, IEnumerable
type TimeHistogram<'TData2, 'TData3> =
    class
        interface ITimeHistogram
        interface IHistogram
        interface IEnumerable<HistogramEntry>
        interface IEnumerable
    end
type TimeHistogram<'TData2, 'TData3> =
    class
        interface ITimeHistogram
        interface IHistogram
        interface IEnumerable<HistogramEntry>
        interface IEnumerable
    end
Type Parameters
TData2
TData3
See Also
TimeHistogram TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2, TData3) Members

TimeHistogram TData2, TData3 Members NFX Class Library

The TimeHistogram TData2, TData3 type exposes the following members.
Constructors
 | Name | Description
Public method | TimeHistogram TData2, TData3 (String, String, Dimension TData2 , Dimension TData3 ) | Initializes a new instance of the TimeHistogram TData2, TData3 class
Public method | TimeHistogram TData2, TData3 (String, String, Int32, Dimension TData2 , Dimension TData3 ) | Initializes a new instance of the TimeHistogram TData2, TData3 class
Public method | TimeHistogram TData2, TData3 (String, String, Int32, PartitionFunc Double , Dimension TData2 , Dimension TData3 ) | Initializes a new instance of the TimeHistogram TData2, TData3 class
Public method | TimeHistogram TData2, TData3 (String, String, Int32, PartitionFunc Double , PartitionNameFunc, Dimension TData2 , Dimension TData3 ) | Initializes a new instance of the TimeHistogram TData2, TData3 class
Back to Top
Methods
 | Name | Description
Public method | Clear | Reset internal histogram state
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDimention | Return a dimension of a histogram identified by index
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetPartitionName | Returns the name of a partition in a given histogram dimension
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Sample | Records time measurement in seconds
Public method | Start | Start sample time measurement
Public method | Stop | Stop sample time measurement started by Start() call
Public method | TimeFrame | Returns a disposable instance suitable for time measurement in a "using" block
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryGet | Try to get the count of samples for the given histogram keys
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable HistogramEntry | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct HistogramEntry, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax HistogramEntry, TComparand (Func HistogramEntry, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax HistogramEntry, TComparand (Func HistogramEntry, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin HistogramEntry, TComparand (Func HistogramEntry, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin HistogramEntry, TComparand (Func HistogramEntry, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault HistogramEntry | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach HistogramEntry (Action HistogramEntry ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach HistogramEntry (Action HistogramEntry, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast HistogramEntry | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast HistogramEntry (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToStringReport | (Defined by HistogramReporters.)
Back to Top
Properties
 | Name | Description
Public property | AvgTime | Average time of all sample measurements
Public property | DimensionCount | Number of dimensions in this histogram
Public property | Dimensions | Returns the dimension instances of this histogram
Public property | Item | Return the count of samples for the given histogram keys
Public property | MaxTime | Maximum time of all sample measurements
Public property | MinTime | Minimum time of all sample measurements
Public property | Title | Histogram title used for displaying purposes
Public property | TotalSamples | Total number of samples in the histogram
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
TimeHistogram TData2, TData3 Class
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2, TData3) Constructor

TimeHistogram TData2, TData3 Constructor NFX Class Library

Overload List
 | Name | Description
Public method | TimeHistogram TData2, TData3 (String, String, Dimension TData2 , Dimension TData3 ) | Initializes a new instance of the TimeHistogram TData2, TData3 class
Public method | TimeHistogram TData2, TData3 (String, String, Int32, Dimension TData2 , Dimension TData3 ) | Initializes a new instance of the TimeHistogram TData2, TData3 class
Public method | TimeHistogram TData2, TData3 (String, String, Int32, PartitionFunc Double , Dimension TData2 , Dimension TData3 ) | Initializes a new instance of the TimeHistogram TData2, TData3 class
Public method | TimeHistogram TData2, TData3 (String, String, Int32, PartitionFunc Double , PartitionNameFunc, Dimension TData2 , Dimension TData3 ) | Initializes a new instance of the TimeHistogram TData2, TData3 class
Back to Top
See Also
TimeHistogram TData2, TData3 Class
TimeHistogram TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2, TData3) Constructor (String, String, Dimension(TData2), Dimension(TData3))

TimeHistogram TData2, TData3 Constructor (String, String, Dimension TData2 , Dimension TData3 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TimeHistogram TData2, TData3 class

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeHistogram(
    string title,
    string dim1Name,
    Dimension<TData2> dimension2,
    Dimension<TData3> dimension3
)
public TimeHistogram(
    string title,
    string dim1Name,
    Dimension<TData2> dimension2,
    Dimension<TData3> dimension3
)
Public Sub New (
    title As String,
    dim1Name As String,
    dimension2 As Dimension(Of TData2),
    dimension3 As Dimension(Of TData3)
)
Public Sub New (
    title As String,
    dim1Name As String,
    dimension2 As Dimension(Of TData2),
    dimension3 As Dimension(Of TData3)
)
public:
TimeHistogram(
    String^ title,
    String^ dim1Name,
    Dimension<TData2>^ dimension2,
    Dimension<TData3>^ dimension3
)
public:
TimeHistogram(
    String^ title,
    String^ dim1Name,
    Dimension<TData2>^ dimension2,
    Dimension<TData3>^ dimension3
)
new :
        title : string *
        dim1Name : string *
        dimension2 : Dimension<'TData2> *
        dimension3 : Dimension<'TData3> -> TimeHistogram
new :
        title : string *
        dim1Name : string *
        dimension2 : Dimension<'TData2> *
        dimension3 : Dimension<'TData3> -> TimeHistogram

Parameters

title
Type: Online System String
dim1Name
Type: Online System String
dimension2
Type: NFX.Instrumentation.Analytics Dimension TData2
dimension3
Type: NFX.Instrumentation.Analytics Dimension TData3
See Also
TimeHistogram TData2, TData3 Class
TimeHistogram TData2, TData3 Members
TimeHistogram TData2, TData3 Overload
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2, TData3) Constructor (String, String, Int32, Dimension(TData2), Dimension(TData3))

TimeHistogram TData2, TData3 Constructor (String, String, Int32, Dimension TData2 , Dimension TData3 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TimeHistogram TData2, TData3 class

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeHistogram(
    string title,
    string dim1Name,
    int dim1PartCount,
    Dimension<TData2> dimension2,
    Dimension<TData3> dimension3
)
public TimeHistogram(
    string title,
    string dim1Name,
    int dim1PartCount,
    Dimension<TData2> dimension2,
    Dimension<TData3> dimension3
)
Public Sub New (
    title As String,
    dim1Name As String,
    dim1PartCount As Integer,
    dimension2 As Dimension(Of TData2),
    dimension3 As Dimension(Of TData3)
)
Public Sub New (
    title As String,
    dim1Name As String,
    dim1PartCount As Integer,
    dimension2 As Dimension(Of TData2),
    dimension3 As Dimension(Of TData3)
)
public:
TimeHistogram(
    String^ title,
    String^ dim1Name,
    int dim1PartCount,
    Dimension<TData2>^ dimension2,
    Dimension<TData3>^ dimension3
)
public:
TimeHistogram(
    String^ title,
    String^ dim1Name,
    int dim1PartCount,
    Dimension<TData2>^ dimension2,
    Dimension<TData3>^ dimension3
)
new :
        title : string *
        dim1Name : string *
        dim1PartCount : int *
        dimension2 : Dimension<'TData2> *
        dimension3 : Dimension<'TData3> -> TimeHistogram
new :
        title : string *
        dim1Name : string *
        dim1PartCount : int *
        dimension2 : Dimension<'TData2> *
        dimension3 : Dimension<'TData3> -> TimeHistogram

Parameters

title
Type: Online System String
dim1Name
Type: Online System String
dim1PartCount
Type: Online System Int32
dimension2
Type: NFX.Instrumentation.Analytics Dimension TData2
dimension3
Type: NFX.Instrumentation.Analytics Dimension TData3
See Also
TimeHistogram TData2, TData3 Class
TimeHistogram TData2, TData3 Members
TimeHistogram TData2, TData3 Overload
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2, TData3) Constructor (String, String, Int32, PartitionFunc(Double), Dimension(TData2), Dimension(TData3))

TimeHistogram TData2, TData3 Constructor (String, String, Int32, PartitionFunc Double , Dimension TData2 , Dimension TData3 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TimeHistogram TData2, TData3 class

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeHistogram(
    string title,
    string dim1Name,
    int dim1PartCount,
    PartitionFunc<double> dim1PartitionFunc,
    Dimension<TData2> dimension2,
    Dimension<TData3> dimension3
)
public TimeHistogram(
    string title,
    string dim1Name,
    int dim1PartCount,
    PartitionFunc<double> dim1PartitionFunc,
    Dimension<TData2> dimension2,
    Dimension<TData3> dimension3
)
Public Sub New (
    title As String,
    dim1Name As String,
    dim1PartCount As Integer,
    dim1PartitionFunc As PartitionFunc(Of Double),
    dimension2 As Dimension(Of TData2),
    dimension3 As Dimension(Of TData3)
)
Public Sub New (
    title As String,
    dim1Name As String,
    dim1PartCount As Integer,
    dim1PartitionFunc As PartitionFunc(Of Double),
    dimension2 As Dimension(Of TData2),
    dimension3 As Dimension(Of TData3)
)
public:
TimeHistogram(
    String^ title,
    String^ dim1Name,
    int dim1PartCount,
    PartitionFunc<double>^ dim1PartitionFunc,
    Dimension<TData2>^ dimension2,
    Dimension<TData3>^ dimension3
)
public:
TimeHistogram(
    String^ title,
    String^ dim1Name,
    int dim1PartCount,
    PartitionFunc<double>^ dim1PartitionFunc,
    Dimension<TData2>^ dimension2,
    Dimension<TData3>^ dimension3
)
new :
        title : string *
        dim1Name : string *
        dim1PartCount : int *
        dim1PartitionFunc : PartitionFunc<float> *
        dimension2 : Dimension<'TData2> *
        dimension3 : Dimension<'TData3> -> TimeHistogram
new :
        title : string *
        dim1Name : string *
        dim1PartCount : int *
        dim1PartitionFunc : PartitionFunc<float> *
        dimension2 : Dimension<'TData2> *
        dimension3 : Dimension<'TData3> -> TimeHistogram

Parameters

title
Type: Online System String
dim1Name
Type: Online System String
dim1PartCount
Type: Online System Int32
dim1PartitionFunc
Type: NFX.Instrumentation.Analytics PartitionFunc Online Double
dimension2
Type: NFX.Instrumentation.Analytics Dimension TData2
dimension3
Type: NFX.Instrumentation.Analytics Dimension TData3
See Also
TimeHistogram TData2, TData3 Class
TimeHistogram TData2, TData3 Members
TimeHistogram TData2, TData3 Overload
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2, TData3) Constructor (String, String, Int32, PartitionFunc(Double), PartitionNameFunc, Dimension(TData2), Dimension(TData3))

TimeHistogram TData2, TData3 Constructor (String, String, Int32, PartitionFunc Double , PartitionNameFunc, Dimension TData2 , Dimension TData3 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TimeHistogram TData2, TData3 class

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeHistogram(
    string title,
    string dim1Name,
    int dim1PartCount,
    PartitionFunc<double> dim1PartitionFunc,
    PartitionNameFunc dim1PartitionNameFunc,
    Dimension<TData2> dimension2,
    Dimension<TData3> dimension3
)
public TimeHistogram(
    string title,
    string dim1Name,
    int dim1PartCount,
    PartitionFunc<double> dim1PartitionFunc,
    PartitionNameFunc dim1PartitionNameFunc,
    Dimension<TData2> dimension2,
    Dimension<TData3> dimension3
)
Public Sub New (
    title As String,
    dim1Name As String,
    dim1PartCount As Integer,
    dim1PartitionFunc As PartitionFunc(Of Double),
    dim1PartitionNameFunc As PartitionNameFunc,
    dimension2 As Dimension(Of TData2),
    dimension3 As Dimension(Of TData3)
)
Public Sub New (
    title As String,
    dim1Name As String,
    dim1PartCount As Integer,
    dim1PartitionFunc As PartitionFunc(Of Double),
    dim1PartitionNameFunc As PartitionNameFunc,
    dimension2 As Dimension(Of TData2),
    dimension3 As Dimension(Of TData3)
)
public:
TimeHistogram(
    String^ title,
    String^ dim1Name,
    int dim1PartCount,
    PartitionFunc<double>^ dim1PartitionFunc,
    PartitionNameFunc^ dim1PartitionNameFunc,
    Dimension<TData2>^ dimension2,
    Dimension<TData3>^ dimension3
)
public:
TimeHistogram(
    String^ title,
    String^ dim1Name,
    int dim1PartCount,
    PartitionFunc<double>^ dim1PartitionFunc,
    PartitionNameFunc^ dim1PartitionNameFunc,
    Dimension<TData2>^ dimension2,
    Dimension<TData3>^ dimension3
)
new :
        title : string *
        dim1Name : string *
        dim1PartCount : int *
        dim1PartitionFunc : PartitionFunc<float> *
        dim1PartitionNameFunc : PartitionNameFunc *
        dimension2 : Dimension<'TData2> *
        dimension3 : Dimension<'TData3> -> TimeHistogram
new :
        title : string *
        dim1Name : string *
        dim1PartCount : int *
        dim1PartitionFunc : PartitionFunc<float> *
        dim1PartitionNameFunc : PartitionNameFunc *
        dimension2 : Dimension<'TData2> *
        dimension3 : Dimension<'TData3> -> TimeHistogram

Parameters

title
Type: Online System String
dim1Name
Type: Online System String
dim1PartCount
Type: Online System Int32
dim1PartitionFunc
Type: NFX.Instrumentation.Analytics PartitionFunc Online Double
dim1PartitionNameFunc
Type: NFX.Instrumentation.Analytics PartitionNameFunc
dimension2
Type: NFX.Instrumentation.Analytics Dimension TData2
dimension3
Type: NFX.Instrumentation.Analytics Dimension TData3
See Also
TimeHistogram TData2, TData3 Class
TimeHistogram TData2, TData3 Members
TimeHistogram TData2, TData3 Overload
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2, TData3) Methods

TimeHistogram TData2, TData3 Methods NFX Class Library

The TimeHistogram TData2, TData3 type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Reset internal histogram state
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDimention | Return a dimension of a histogram identified by index
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetPartitionName | Returns the name of a partition in a given histogram dimension
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Sample | Records time measurement in seconds
Public method | Start | Start sample time measurement
Public method | Stop | Stop sample time measurement started by Start() call
Public method | TimeFrame | Returns a disposable instance suitable for time measurement in a "using" block
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TryGet | Try to get the count of samples for the given histogram keys
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable HistogramEntry | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct HistogramEntry, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax HistogramEntry, TComparand (Func HistogramEntry, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax HistogramEntry, TComparand (Func HistogramEntry, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin HistogramEntry, TComparand (Func HistogramEntry, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin HistogramEntry, TComparand (Func HistogramEntry, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault HistogramEntry | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach HistogramEntry (Action HistogramEntry ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach HistogramEntry (Action HistogramEntry, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast HistogramEntry | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast HistogramEntry (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToStringReport | (Defined by HistogramReporters.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
TimeHistogram TData2, TData3 Class
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2, TData3).IEnumerable.GetEnumerator Method

TimeHistogram TData2, TData3 IEnumerable GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
TimeHistogram TData2, TData3 Class
TimeHistogram TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2, TData3).Clear Method

TimeHistogram TData2, TData3 Clear Method NFX Class Library

Reset internal histogram state

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
virtual void Clear() sealed
public:
virtual void Clear() sealed
abstract Clear : unit -> unit
override Clear : unit -> unit
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

IHistogram Clear
See Also
TimeHistogram TData2, TData3 Class
TimeHistogram TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2, TData3).GetDimention Method

TimeHistogram TData2, TData3 GetDimention Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Return a dimension of a histogram identified by index

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Dimension GetDimention(
    int dimension
)
public Dimension GetDimention(
    int dimension
)
Public Function GetDimention (
    dimension As Integer
) As Dimension
Public Function GetDimention (
    dimension As Integer
) As Dimension
public:
virtual Dimension^ GetDimention(
    int dimension
) sealed
public:
virtual Dimension^ GetDimention(
    int dimension
) sealed
abstract GetDimention :
        dimension : int -> Dimension
override GetDimention :
        dimension : int -> Dimension
abstract GetDimention :
        dimension : int -> Dimension
override GetDimention :
        dimension : int -> Dimension

Parameters

dimension
Type: Online System Int32

Return Value

Type: Dimension

Implements

IHistogram GetDimention(Int32)
See Also
TimeHistogram TData2, TData3 Class
TimeHistogram TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2, TData3).GetEnumerator Method

TimeHistogram TData2, TData3 GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<HistogramEntry> GetEnumerator()
public IEnumerator<HistogramEntry> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of HistogramEntry)
Public Function GetEnumerator As IEnumerator(Of HistogramEntry)
public:
virtual IEnumerator<HistogramEntry^>^ GetEnumerator() sealed
public:
virtual IEnumerator<HistogramEntry^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<HistogramEntry>
override GetEnumerator : unit -> IEnumerator<HistogramEntry>
abstract GetEnumerator : unit -> IEnumerator<HistogramEntry>
override GetEnumerator : unit -> IEnumerator<HistogramEntry>

Return Value

Type: Online IEnumerator HistogramEntry

Implements

Online IEnumerable T GetEnumerator
See Also
TimeHistogram TData2, TData3 Class
TimeHistogram TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2, TData3).GetPartitionName Method

TimeHistogram TData2, TData3 GetPartitionName Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns the name of a partition in a given histogram dimension

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetPartitionName(
    int dimension,
    int partition
)
public string GetPartitionName(
    int dimension,
    int partition
)
Public Function GetPartitionName (
    dimension As Integer,
    partition As Integer
) As String
Public Function GetPartitionName (
    dimension As Integer,
    partition As Integer
) As String
public:
virtual String^ GetPartitionName(
    int dimension,
    int partition
) sealed
public:
virtual String^ GetPartitionName(
    int dimension,
    int partition
) sealed
abstract GetPartitionName :
        dimension : int *
        partition : int -> string
override GetPartitionName :
        dimension : int *
        partition : int -> string
abstract GetPartitionName :
        dimension : int *
        partition : int -> string
override GetPartitionName :
        dimension : int *
        partition : int -> string

Parameters

dimension
Type: Online System Int32
Dimension index
partition
Type: Online System Int32
Partition index

Return Value

Type: Online String

Implements

IHistogram GetPartitionName(Int32, Int32)
See Also
TimeHistogram TData2, TData3 Class
TimeHistogram TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2, TData3).Sample Method

TimeHistogram TData2, TData3 Sample Method NFX Class Library

Records time measurement in seconds

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Sample(
    double secInterval,
    TData2 dim1Value,
    TData3 dim2Value
)
public void Sample(
    double secInterval,
    TData2 dim1Value,
    TData3 dim2Value
)
Public Sub Sample (
    secInterval As Double,
    dim1Value As TData2,
    dim2Value As TData3
)
Public Sub Sample (
    secInterval As Double,
    dim1Value As TData2,
    dim2Value As TData3
)
public:
void Sample(
    double secInterval,
    TData2 dim1Value,
    TData3 dim2Value
)
public:
void Sample(
    double secInterval,
    TData2 dim1Value,
    TData3 dim2Value
)
member Sample :
        secInterval : float *
        dim1Value : 'TData2 *
        dim2Value : 'TData3 -> unit
member Sample :
        secInterval : float *
        dim1Value : 'TData2 *
        dim2Value : 'TData3 -> unit

Parameters

secInterval
Type: Online System Double
dim1Value
Type: TData2
dim2Value
Type: TData3
See Also
TimeHistogram TData2, TData3 Class
TimeHistogram TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2, TData3).Start Method

TimeHistogram TData2, TData3 Start Method NFX Class Library

Start sample time measurement

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Start()
public void Start()
Public Sub Start
Public Sub Start
public:
virtual void Start() sealed
public:
virtual void Start() sealed
abstract Start : unit -> unit
override Start : unit -> unit
abstract Start : unit -> unit
override Start : unit -> unit

Implements

ITimeHistogram Start
See Also
TimeHistogram TData2, TData3 Class
TimeHistogram TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2, TData3).Stop Method

TimeHistogram TData2, TData3 Stop Method NFX Class Library

Stop sample time measurement started by Start() call

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Stop(
    TData2 dim1Value,
    TData3 dim2Value
)
public void Stop(
    TData2 dim1Value,
    TData3 dim2Value
)
Public Sub Stop (
    dim1Value As TData2,
    dim2Value As TData3
)
Public Sub Stop (
    dim1Value As TData2,
    dim2Value As TData3
)
public:
void Stop(
    TData2 dim1Value,
    TData3 dim2Value
)
public:
void Stop(
    TData2 dim1Value,
    TData3 dim2Value
)
member Stop :
        dim1Value : 'TData2 *
        dim2Value : 'TData3 -> unit
member Stop :
        dim1Value : 'TData2 *
        dim2Value : 'TData3 -> unit

Parameters

dim1Value
Type: TData2
dim2Value
Type: TData3
See Also
TimeHistogram TData2, TData3 Class
TimeHistogram TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2, TData3).TimeFrame Method

TimeHistogram TData2, TData3 TimeFrame Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns a disposable instance suitable for time measurement in a "using" block

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDisposable TimeFrame(
    TData2 dim2Value,
    TData3 dim3Value
)
public IDisposable TimeFrame(
    TData2 dim2Value,
    TData3 dim3Value
)
Public Function TimeFrame (
    dim2Value As TData2,
    dim3Value As TData3
) As IDisposable
Public Function TimeFrame (
    dim2Value As TData2,
    dim3Value As TData3
) As IDisposable
public:
IDisposable^ TimeFrame(
    TData2 dim2Value,
    TData3 dim3Value
)
public:
IDisposable^ TimeFrame(
    TData2 dim2Value,
    TData3 dim3Value
)
member TimeFrame :
        dim2Value : 'TData2 *
        dim3Value : 'TData3 -> IDisposable
member TimeFrame :
        dim2Value : 'TData2 *
        dim3Value : 'TData3 -> IDisposable

Parameters

dim2Value
Type: TData2
dim3Value
Type: TData3

Return Value

Type: Online IDisposable
See Also
TimeHistogram TData2, TData3 Class
TimeHistogram TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2, TData3).TryGet Method

TimeHistogram TData2, TData3 TryGet Method NFX Class Library

Try to get the count of samples for the given histogram keys

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TryGet(
    HistogramKeys keys,
    out int count
)
public bool TryGet(
    HistogramKeys keys,
    out int count
)
Public Function TryGet (
    keys As HistogramKeys,
    <OutAttribute> ByRef count As Integer
) As Boolean
Public Function TryGet (
    keys As HistogramKeys,
    <OutAttribute> ByRef count As Integer
) As Boolean
public:
virtual bool TryGet(
    HistogramKeys keys,
    [OutAttribute] int% count
) sealed
public:
virtual bool TryGet(
    HistogramKeys keys,
    [OutAttribute] int% count
) sealed
abstract TryGet :
        keys : HistogramKeys *
        count : int byref -> bool
override TryGet :
        keys : HistogramKeys *
        count : int byref -> bool
abstract TryGet :
        keys : HistogramKeys *
        count : int byref -> bool
override TryGet :
        keys : HistogramKeys *
        count : int byref -> bool

Parameters

keys
Type: NFX.Instrumentation.Analytics HistogramKeys
count
Type: Online System Int32

Return Value

Type: Online Boolean

Implements

IHistogram TryGet(HistogramKeys, Int32 )
See Also
TimeHistogram TData2, TData3 Class
TimeHistogram TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2, TData3) Properties

TimeHistogram TData2, TData3 Properties NFX Class Library

The TimeHistogram TData2, TData3 type exposes the following members.
Properties
 | Name | Description
Public property | AvgTime | Average time of all sample measurements
Public property | DimensionCount | Number of dimensions in this histogram
Public property | Dimensions | Returns the dimension instances of this histogram
Public property | Item | Return the count of samples for the given histogram keys
Public property | MaxTime | Maximum time of all sample measurements
Public property | MinTime | Minimum time of all sample measurements
Public property | Title | Histogram title used for displaying purposes
Public property | TotalSamples | Total number of samples in the histogram
Back to Top
See Also
TimeHistogram TData2, TData3 Class
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2, TData3).AvgTime Property

TimeHistogram TData2, TData3 AvgTime Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Average time of all sample measurements

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double AvgTime { get; }
public double AvgTime { get; }
Public ReadOnly Property AvgTime As Double
    Get
Public ReadOnly Property AvgTime As Double
    Get
public:
virtual property double AvgTime {
    double get () sealed;
}
public:
virtual property double AvgTime {
    double get () sealed;
}
abstract AvgTime : float with get
override AvgTime : float with get
abstract AvgTime : float with get
override AvgTime : float with get

Property Value

Type: Online Double

Implements

ITimeHistogram AvgTime
See Also
TimeHistogram TData2, TData3 Class
TimeHistogram TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2, TData3).DimensionCount Property

TimeHistogram TData2, TData3 DimensionCount Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Number of dimensions in this histogram

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int DimensionCount { get; }
public int DimensionCount { get; }
Public ReadOnly Property DimensionCount As Integer
    Get
Public ReadOnly Property DimensionCount As Integer
    Get
public:
virtual property int DimensionCount {
    int get () sealed;
}
public:
virtual property int DimensionCount {
    int get () sealed;
}
abstract DimensionCount : int with get
override DimensionCount : int with get
abstract DimensionCount : int with get
override DimensionCount : int with get

Property Value

Type: Online Int32

Implements

IHistogram DimensionCount
See Also
TimeHistogram TData2, TData3 Class
TimeHistogram TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2, TData3).Dimensions Property

TimeHistogram TData2, TData3 Dimensions Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns the dimension instances of this histogram

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Dimension> Dimensions { get; }
public IEnumerable<Dimension> Dimensions { get; }
Public ReadOnly Property Dimensions As IEnumerable(Of Dimension)
    Get
Public ReadOnly Property Dimensions As IEnumerable(Of Dimension)
    Get
public:
virtual property IEnumerable<Dimension^>^ Dimensions {
    IEnumerable<Dimension^>^ get () sealed;
}
public:
virtual property IEnumerable<Dimension^>^ Dimensions {
    IEnumerable<Dimension^>^ get () sealed;
}
abstract Dimensions : IEnumerable<Dimension> with get
override Dimensions : IEnumerable<Dimension> with get
abstract Dimensions : IEnumerable<Dimension> with get
override Dimensions : IEnumerable<Dimension> with get

Property Value

Type: Online IEnumerable Dimension

Implements

IHistogram Dimensions
See Also
TimeHistogram TData2, TData3 Class
TimeHistogram TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2, TData3).Item Property

TimeHistogram TData2, TData3 Item Property NFX Class Library

Return the count of samples for the given histogram keys

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int this[
    HistogramKeys keys
] { get; }
public int this[
    HistogramKeys keys
] { get; }
Public ReadOnly Default Property Item (
    keys As HistogramKeys
) As Integer
    Get
Public ReadOnly Default Property Item (
    keys As HistogramKeys
) As Integer
    Get
public:
virtual property int default[HistogramKeys keys] {
    int get (HistogramKeys keys) sealed;
}
public:
virtual property int default[HistogramKeys keys] {
    int get (HistogramKeys keys) sealed;
}
abstract Item : int with get
override Item : int with get
abstract Item : int with get
override Item : int with get

Parameters

keys
Type: NFX.Instrumentation.Analytics HistogramKeys

Property Value

Type: Online Int32

Implements

IHistogram Item HistogramKeys
See Also
TimeHistogram TData2, TData3 Class
TimeHistogram TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2, TData3).MaxTime Property

TimeHistogram TData2, TData3 MaxTime Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Maximum time of all sample measurements

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double MaxTime { get; }
public double MaxTime { get; }
Public ReadOnly Property MaxTime As Double
    Get
Public ReadOnly Property MaxTime As Double
    Get
public:
virtual property double MaxTime {
    double get () sealed;
}
public:
virtual property double MaxTime {
    double get () sealed;
}
abstract MaxTime : float with get
override MaxTime : float with get
abstract MaxTime : float with get
override MaxTime : float with get

Property Value

Type: Online Double

Implements

ITimeHistogram MaxTime
See Also
TimeHistogram TData2, TData3 Class
TimeHistogram TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2, TData3).MinTime Property

TimeHistogram TData2, TData3 MinTime Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Minimum time of all sample measurements

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double MinTime { get; }
public double MinTime { get; }
Public ReadOnly Property MinTime As Double
    Get
Public ReadOnly Property MinTime As Double
    Get
public:
virtual property double MinTime {
    double get () sealed;
}
public:
virtual property double MinTime {
    double get () sealed;
}
abstract MinTime : float with get
override MinTime : float with get
abstract MinTime : float with get
override MinTime : float with get

Property Value

Type: Online Double

Implements

ITimeHistogram MinTime
See Also
TimeHistogram TData2, TData3 Class
TimeHistogram TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2, TData3).Title Property

TimeHistogram TData2, TData3 Title Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Histogram title used for displaying purposes

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Title { get; }
public string Title { get; }
Public ReadOnly Property Title As String
    Get
Public ReadOnly Property Title As String
    Get
public:
virtual property String^ Title {
    String^ get () sealed;
}
public:
virtual property String^ Title {
    String^ get () sealed;
}
abstract Title : string with get
override Title : string with get
abstract Title : string with get
override Title : string with get

Property Value

Type: Online String

Implements

IHistogram Title
See Also
TimeHistogram TData2, TData3 Class
TimeHistogram TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogram(TData2, TData3).TotalSamples Property

TimeHistogram TData2, TData3 TotalSamples Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Total number of samples in the histogram

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long TotalSamples { get; }
public long TotalSamples { get; }
Public ReadOnly Property TotalSamples As Long
    Get
Public ReadOnly Property TotalSamples As Long
    Get
public:
virtual property long long TotalSamples {
    long long get () sealed;
}
public:
virtual property long long TotalSamples {
    long long get () sealed;
}
abstract TotalSamples : int64 with get
override TotalSamples : int64 with get
abstract TotalSamples : int64 with get
override TotalSamples : int64 with get

Property Value

Type: Online Int64

Implements

IHistogram TotalSamples
See Also
TimeHistogram TData2, TData3 Class
TimeHistogram TData2, TData3 Members
NFX.Instrumentation.Analytics Namespace


TimeHistogramHelper Structure

TimeHistogramHelper Structure NFX Class Library

Helper class used by TimerHistogram

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal struct TimeHistogramHelper
internal struct TimeHistogramHelper
Friend Structure TimeHistogramHelper
Friend Structure TimeHistogramHelper
internal value class TimeHistogramHelper
internal value class TimeHistogramHelper
[<SealedAttribute>]
type TimeHistogramHelper =  struct end
[<SealedAttribute>]
type TimeHistogramHelper =  struct end
See Also
TimeHistogramHelper Members
NFX.Instrumentation.Analytics Namespace


TimeHistogramHelper Members

TimeHistogramHelper Members NFX Class Library

The TimeHistogramHelper type exposes the following members.
Methods
 | Name | Description
Public method | AvgTime |
Public method | Clear | Reset internal histogram state
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Start | Start sample time measurement
Public method | Stop | Stop sample time measurement started by Start() call
Public method | Title | Histogram title used for displaying purposes
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | MaxTime | Maximum time of all sample measurements
Public property | MinTime | Minimum time of all sample measurements
Back to Top
See Also
TimeHistogramHelper Structure
NFX.Instrumentation.Analytics Namespace


TimeHistogramHelper Methods

TimeHistogramHelper Methods NFX Class Library

The TimeHistogramHelper type exposes the following members.
Methods
 | Name | Description
Public method | AvgTime |
Public method | Clear | Reset internal histogram state
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Start | Start sample time measurement
Public method | Stop | Stop sample time measurement started by Start() call
Public method | Title | Histogram title used for displaying purposes
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TimeHistogramHelper Structure
NFX.Instrumentation.Analytics Namespace


TimeHistogramHelper.AvgTime Method

TimeHistogramHelper AvgTime Method NFX Class Library

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double AvgTime(
    long totalSamples
)
public double AvgTime(
    long totalSamples
)
Public Function AvgTime (
    totalSamples As Long
) As Double
Public Function AvgTime (
    totalSamples As Long
) As Double
public:
double AvgTime(
    long long totalSamples
)
public:
double AvgTime(
    long long totalSamples
)
member AvgTime :
        totalSamples : int64 -> float
member AvgTime :
        totalSamples : int64 -> float

Parameters

totalSamples
Type: Online System Int64

Return Value

Type: Online Double
See Also
TimeHistogramHelper Structure
TimeHistogramHelper Members
NFX.Instrumentation.Analytics Namespace


TimeHistogramHelper.Clear Method

TimeHistogramHelper Clear Method NFX Class Library

Reset internal histogram state

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
void Clear()
public:
void Clear()
member Clear : unit -> unit
member Clear : unit -> unit
See Also
TimeHistogramHelper Structure
TimeHistogramHelper Members
NFX.Instrumentation.Analytics Namespace


TimeHistogramHelper.Start Method

TimeHistogramHelper Start Method NFX Class Library

Start sample time measurement

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Start()
public void Start()
Public Sub Start
Public Sub Start
public:
void Start()
public:
void Start()
member Start : unit -> unit
member Start : unit -> unit
See Also
TimeHistogramHelper Structure
TimeHistogramHelper Members
NFX.Instrumentation.Analytics Namespace


TimeHistogramHelper.Stop Method

TimeHistogramHelper Stop Method NFX Class Library

Stop sample time measurement started by Start() call

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double Stop()
public double Stop()
Public Function Stop As Double
Public Function Stop As Double
public:
double Stop()
public:
double Stop()
member Stop : unit -> float
member Stop : unit -> float

Return Value

Type: Online Double
See Also
TimeHistogramHelper Structure
TimeHistogramHelper Members
NFX.Instrumentation.Analytics Namespace


TimeHistogramHelper.Title Method

TimeHistogramHelper Title Method NFX Class Library

Histogram title used for displaying purposes

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Title(
    string prefix,
    long totalSamples
)
public string Title(
    string prefix,
    long totalSamples
)
Public Function Title (
    prefix As String,
    totalSamples As Long
) As String
Public Function Title (
    prefix As String,
    totalSamples As Long
) As String
public:
String^ Title(
    String^ prefix,
    long long totalSamples
)
public:
String^ Title(
    String^ prefix,
    long long totalSamples
)
member Title :
        prefix : string *
        totalSamples : int64 -> string
member Title :
        prefix : string *
        totalSamples : int64 -> string

Parameters

prefix
Type: Online System String
totalSamples
Type: Online System Int64

Return Value

Type: Online String
See Also
TimeHistogramHelper Structure
TimeHistogramHelper Members
NFX.Instrumentation.Analytics Namespace


TimeHistogramHelper Properties

TimeHistogramHelper Properties NFX Class Library

The TimeHistogramHelper type exposes the following members.
Properties
 | Name | Description
Public property | MaxTime | Maximum time of all sample measurements
Public property | MinTime | Minimum time of all sample measurements
Back to Top
See Also
TimeHistogramHelper Structure
NFX.Instrumentation.Analytics Namespace


TimeHistogramHelper.MaxTime Property

TimeHistogramHelper MaxTime Property NFX Class Library

Maximum time of all sample measurements

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double MaxTime { get; }
public double MaxTime { get; }
Public ReadOnly Property MaxTime As Double
    Get
Public ReadOnly Property MaxTime As Double
    Get
public:
property double MaxTime {
    double get ();
}
public:
property double MaxTime {
    double get ();
}
member MaxTime : float with get
member MaxTime : float with get

Property Value

Type: Online Double
See Also
TimeHistogramHelper Structure
TimeHistogramHelper Members
NFX.Instrumentation.Analytics Namespace


TimeHistogramHelper.MinTime Property

TimeHistogramHelper MinTime Property NFX Class Library

Minimum time of all sample measurements

Namespace: NFX.Instrumentation.Analytics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double MinTime { get; }
public double MinTime { get; }
Public ReadOnly Property MinTime As Double
    Get
Public ReadOnly Property MinTime As Double
    Get
public:
property double MinTime {
    double get ();
}
public:
property double MinTime {
    double get ();
}
member MinTime : float with get
member MinTime : float with get

Property Value

Type: Online Double
See Also
TimeHistogramHelper Structure
TimeHistogramHelper Members
NFX.Instrumentation.Analytics Namespace


NFX.Instrumentation.Self Namespace

NFX.Instrumentation.Self Namespace NFX Class Library

Classes
 | Class | Description
Public class | BufferMaxAge |
Public class | ProcessingInterval |
Public class | RecordCount |
Public class | RecordLoad |
Public class | SelfInstrumentationLongGauge |


BufferMaxAge Class

BufferMaxAge Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Instrumentation.Self SelfInstrumentationLongGauge
NFX.Instrumentation.Self BufferMaxAge

Namespace: NFX.Instrumentation.Self
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class BufferMaxAge : SelfInstrumentationLongGauge,
    IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class BufferMaxAge : SelfInstrumentationLongGauge,
    IMemoryInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class BufferMaxAge
    Inherits SelfInstrumentationLongGauge
    Implements IMemoryInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class BufferMaxAge
    Inherits SelfInstrumentationLongGauge
    Implements IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class BufferMaxAge : public SelfInstrumentationLongGauge,
    IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class BufferMaxAge : public SelfInstrumentationLongGauge,
    IMemoryInstrument, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type BufferMaxAge =
    class
        inherit SelfInstrumentationLongGauge
        interface IMemoryInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type BufferMaxAge =
    class
        inherit SelfInstrumentationLongGauge
        interface IMemoryInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
BufferMaxAge Members
NFX.Instrumentation.Self Namespace


BufferMaxAge Members

BufferMaxAge Members NFX Class Library

The BufferMaxAge type exposes the following members.
Constructors
 | Name | Description
Protected method | BufferMaxAge | Initializes a new instance of the BufferMaxAge class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
BufferMaxAge Class
NFX.Instrumentation.Self Namespace


BufferMaxAge Constructor

BufferMaxAge Constructor NFX Class Library

Initializes a new instance of the BufferMaxAge class

Namespace: NFX.Instrumentation.Self
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected BufferMaxAge(
    long value
)
protected BufferMaxAge(
    long value
)
Protected Sub New (
    value As Long
)
Protected Sub New (
    value As Long
)
protected:
BufferMaxAge(
    long long value
)
protected:
BufferMaxAge(
    long long value
)
new :
        value : int64 -> BufferMaxAge
new :
        value : int64 -> BufferMaxAge

Parameters

value
Type: Online System Int64
See Also
BufferMaxAge Class
BufferMaxAge Members
NFX.Instrumentation.Self Namespace


BufferMaxAge Fields

BufferMaxAge Fields NFX Class Library

The BufferMaxAge type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
BufferMaxAge Class
NFX.Instrumentation.Self Namespace


BufferMaxAge Methods

BufferMaxAge Methods NFX Class Library

The BufferMaxAge type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BufferMaxAge Class
NFX.Instrumentation.Self Namespace


BufferMaxAge.MakeAggregateInstance Method

BufferMaxAge MakeAggregateInstance Method NFX Class Library

Namespace: NFX.Instrumentation.Self
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
BufferMaxAge Class
BufferMaxAge Members
NFX.Instrumentation.Self Namespace


BufferMaxAge.Record Method

BufferMaxAge Record Method NFX Class Library

Namespace: NFX.Instrumentation.Self
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    long value
)
public static void Record(
    long value
)
Public Shared Sub Record (
    value As Long
)
Public Shared Sub Record (
    value As Long
)
public:
static void Record(
    long long value
)
public:
static void Record(
    long long value
)
static member Record :
        value : int64 -> unit
static member Record :
        value : int64 -> unit

Parameters

value
Type: Online System Int64
See Also
BufferMaxAge Class
BufferMaxAge Members
NFX.Instrumentation.Self Namespace


BufferMaxAge Properties

BufferMaxAge Properties NFX Class Library

The BufferMaxAge type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
BufferMaxAge Class
NFX.Instrumentation.Self Namespace


BufferMaxAge.Description Property

BufferMaxAge Description Property NFX Class Library

Namespace: NFX.Instrumentation.Self
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
BufferMaxAge Class
BufferMaxAge Members
NFX.Instrumentation.Self Namespace


BufferMaxAge.ValueUnitName Property

BufferMaxAge ValueUnitName Property NFX Class Library

Namespace: NFX.Instrumentation.Self
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
BufferMaxAge Class
BufferMaxAge Members
NFX.Instrumentation.Self Namespace


ProcessingInterval Class

ProcessingInterval Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Instrumentation.Self SelfInstrumentationLongGauge
NFX.Instrumentation.Self ProcessingInterval

Namespace: NFX.Instrumentation.Self
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ProcessingInterval : SelfInstrumentationLongGauge
[SerializableAttribute]
public class ProcessingInterval : SelfInstrumentationLongGauge
<SerializableAttribute>
Public Class ProcessingInterval
    Inherits SelfInstrumentationLongGauge
<SerializableAttribute>
Public Class ProcessingInterval
    Inherits SelfInstrumentationLongGauge
[SerializableAttribute]
public ref class ProcessingInterval : public SelfInstrumentationLongGauge
[SerializableAttribute]
public ref class ProcessingInterval : public SelfInstrumentationLongGauge
[<SerializableAttribute>]
type ProcessingInterval =
    class
        inherit SelfInstrumentationLongGauge
    end
[<SerializableAttribute>]
type ProcessingInterval =
    class
        inherit SelfInstrumentationLongGauge
    end
See Also
ProcessingInterval Members
NFX.Instrumentation.Self Namespace


ProcessingInterval Members

ProcessingInterval Members NFX Class Library

The ProcessingInterval type exposes the following members.
Constructors
 | Name | Description
Protected method | ProcessingInterval | Initializes a new instance of the ProcessingInterval class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ProcessingInterval Class
NFX.Instrumentation.Self Namespace


ProcessingInterval Constructor

ProcessingInterval Constructor NFX Class Library

Initializes a new instance of the ProcessingInterval class

Namespace: NFX.Instrumentation.Self
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ProcessingInterval(
    long value
)
protected ProcessingInterval(
    long value
)
Protected Sub New (
    value As Long
)
Protected Sub New (
    value As Long
)
protected:
ProcessingInterval(
    long long value
)
protected:
ProcessingInterval(
    long long value
)
new :
        value : int64 -> ProcessingInterval
new :
        value : int64 -> ProcessingInterval

Parameters

value
Type: Online System Int64
See Also
ProcessingInterval Class
ProcessingInterval Members
NFX.Instrumentation.Self Namespace


ProcessingInterval Fields

ProcessingInterval Fields NFX Class Library

The ProcessingInterval type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
ProcessingInterval Class
NFX.Instrumentation.Self Namespace


ProcessingInterval Methods

ProcessingInterval Methods NFX Class Library

The ProcessingInterval type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ProcessingInterval Class
NFX.Instrumentation.Self Namespace


ProcessingInterval.MakeAggregateInstance Method

ProcessingInterval MakeAggregateInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation.Self
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
ProcessingInterval Class
ProcessingInterval Members
NFX.Instrumentation.Self Namespace


ProcessingInterval.Record Method

ProcessingInterval Record Method NFX Class Library

Namespace: NFX.Instrumentation.Self
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    long value
)
public static void Record(
    long value
)
Public Shared Sub Record (
    value As Long
)
Public Shared Sub Record (
    value As Long
)
public:
static void Record(
    long long value
)
public:
static void Record(
    long long value
)
static member Record :
        value : int64 -> unit
static member Record :
        value : int64 -> unit

Parameters

value
Type: Online System Int64
See Also
ProcessingInterval Class
ProcessingInterval Members
NFX.Instrumentation.Self Namespace


ProcessingInterval Properties

ProcessingInterval Properties NFX Class Library

The ProcessingInterval type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
ProcessingInterval Class
NFX.Instrumentation.Self Namespace


ProcessingInterval.Description Property

ProcessingInterval Description Property NFX Class Library

Namespace: NFX.Instrumentation.Self
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
ProcessingInterval Class
ProcessingInterval Members
NFX.Instrumentation.Self Namespace


ProcessingInterval.ValueUnitName Property

ProcessingInterval ValueUnitName Property NFX Class Library

Namespace: NFX.Instrumentation.Self
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
ProcessingInterval Class
ProcessingInterval Members
NFX.Instrumentation.Self Namespace


RecordCount Class

RecordCount Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Instrumentation.Self SelfInstrumentationLongGauge
NFX.Instrumentation.Self RecordCount

Namespace: NFX.Instrumentation.Self
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class RecordCount : SelfInstrumentationLongGauge,
    IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class RecordCount : SelfInstrumentationLongGauge,
    IMemoryInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class RecordCount
    Inherits SelfInstrumentationLongGauge
    Implements IMemoryInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class RecordCount
    Inherits SelfInstrumentationLongGauge
    Implements IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class RecordCount : public SelfInstrumentationLongGauge,
    IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class RecordCount : public SelfInstrumentationLongGauge,
    IMemoryInstrument, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type RecordCount =
    class
        inherit SelfInstrumentationLongGauge
        interface IMemoryInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type RecordCount =
    class
        inherit SelfInstrumentationLongGauge
        interface IMemoryInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
RecordCount Members
NFX.Instrumentation.Self Namespace


RecordCount Members

RecordCount Members NFX Class Library

The RecordCount type exposes the following members.
Constructors
 | Name | Description
Protected method | RecordCount | Initializes a new instance of the RecordCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
RecordCount Class
NFX.Instrumentation.Self Namespace


RecordCount Constructor

RecordCount Constructor NFX Class Library

Initializes a new instance of the RecordCount class

Namespace: NFX.Instrumentation.Self
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected RecordCount(
    long value
)
protected RecordCount(
    long value
)
Protected Sub New (
    value As Long
)
Protected Sub New (
    value As Long
)
protected:
RecordCount(
    long long value
)
protected:
RecordCount(
    long long value
)
new :
        value : int64 -> RecordCount
new :
        value : int64 -> RecordCount

Parameters

value
Type: Online System Int64
See Also
RecordCount Class
RecordCount Members
NFX.Instrumentation.Self Namespace


RecordCount Fields

RecordCount Fields NFX Class Library

The RecordCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
RecordCount Class
NFX.Instrumentation.Self Namespace


RecordCount Methods

RecordCount Methods NFX Class Library

The RecordCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
RecordCount Class
NFX.Instrumentation.Self Namespace


RecordCount.MakeAggregateInstance Method

RecordCount MakeAggregateInstance Method NFX Class Library

Namespace: NFX.Instrumentation.Self
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
RecordCount Class
RecordCount Members
NFX.Instrumentation.Self Namespace


RecordCount.Record Method

RecordCount Record Method NFX Class Library

Namespace: NFX.Instrumentation.Self
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    long value
)
public static void Record(
    long value
)
Public Shared Sub Record (
    value As Long
)
Public Shared Sub Record (
    value As Long
)
public:
static void Record(
    long long value
)
public:
static void Record(
    long long value
)
static member Record :
        value : int64 -> unit
static member Record :
        value : int64 -> unit

Parameters

value
Type: Online System Int64
See Also
RecordCount Class
RecordCount Members
NFX.Instrumentation.Self Namespace


RecordCount Properties

RecordCount Properties NFX Class Library

The RecordCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
RecordCount Class
NFX.Instrumentation.Self Namespace


RecordCount.Description Property

RecordCount Description Property NFX Class Library

Namespace: NFX.Instrumentation.Self
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
RecordCount Class
RecordCount Members
NFX.Instrumentation.Self Namespace


RecordCount.ValueUnitName Property

RecordCount ValueUnitName Property NFX Class Library

Namespace: NFX.Instrumentation.Self
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
RecordCount Class
RecordCount Members
NFX.Instrumentation.Self Namespace


RecordLoad Class

RecordLoad Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Instrumentation.Self SelfInstrumentationLongGauge
NFX.Instrumentation.Self RecordLoad

Namespace: NFX.Instrumentation.Self
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class RecordLoad : SelfInstrumentationLongGauge, IMemoryInstrument,
    IOperationClass, IInstrumentClass
[SerializableAttribute]
public class RecordLoad : SelfInstrumentationLongGauge, IMemoryInstrument,
    IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class RecordLoad
    Inherits SelfInstrumentationLongGauge
    Implements IMemoryInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class RecordLoad
    Inherits SelfInstrumentationLongGauge
    Implements IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class RecordLoad : public SelfInstrumentationLongGauge,
    IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class RecordLoad : public SelfInstrumentationLongGauge,
    IMemoryInstrument, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type RecordLoad =
    class
        inherit SelfInstrumentationLongGauge
        interface IMemoryInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type RecordLoad =
    class
        inherit SelfInstrumentationLongGauge
        interface IMemoryInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
RecordLoad Members
NFX.Instrumentation.Self Namespace


RecordLoad Members

RecordLoad Members NFX Class Library

The RecordLoad type exposes the following members.
Constructors
 | Name | Description
Protected method | RecordLoad | Initializes a new instance of the RecordLoad class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
RecordLoad Class
NFX.Instrumentation.Self Namespace


RecordLoad Constructor

RecordLoad Constructor NFX Class Library

Initializes a new instance of the RecordLoad class

Namespace: NFX.Instrumentation.Self
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected RecordLoad(
    long value
)
protected RecordLoad(
    long value
)
Protected Sub New (
    value As Long
)
Protected Sub New (
    value As Long
)
protected:
RecordLoad(
    long long value
)
protected:
RecordLoad(
    long long value
)
new :
        value : int64 -> RecordLoad
new :
        value : int64 -> RecordLoad

Parameters

value
Type: Online System Int64
See Also
RecordLoad Class
RecordLoad Members
NFX.Instrumentation.Self Namespace


RecordLoad Fields

RecordLoad Fields NFX Class Library

The RecordLoad type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
RecordLoad Class
NFX.Instrumentation.Self Namespace


RecordLoad Methods

RecordLoad Methods NFX Class Library

The RecordLoad type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
RecordLoad Class
NFX.Instrumentation.Self Namespace


RecordLoad.MakeAggregateInstance Method

RecordLoad MakeAggregateInstance Method NFX Class Library

Namespace: NFX.Instrumentation.Self
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
RecordLoad Class
RecordLoad Members
NFX.Instrumentation.Self Namespace


RecordLoad.Record Method

RecordLoad Record Method NFX Class Library

Namespace: NFX.Instrumentation.Self
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    long value
)
public static void Record(
    long value
)
Public Shared Sub Record (
    value As Long
)
Public Shared Sub Record (
    value As Long
)
public:
static void Record(
    long long value
)
public:
static void Record(
    long long value
)
static member Record :
        value : int64 -> unit
static member Record :
        value : int64 -> unit

Parameters

value
Type: Online System Int64
See Also
RecordLoad Class
RecordLoad Members
NFX.Instrumentation.Self Namespace


RecordLoad Properties

RecordLoad Properties NFX Class Library

The RecordLoad type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
RecordLoad Class
NFX.Instrumentation.Self Namespace


RecordLoad.Description Property

RecordLoad Description Property NFX Class Library

Namespace: NFX.Instrumentation.Self
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
RecordLoad Class
RecordLoad Members
NFX.Instrumentation.Self Namespace


RecordLoad.ValueUnitName Property

RecordLoad ValueUnitName Property NFX Class Library

Namespace: NFX.Instrumentation.Self
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
RecordLoad Class
RecordLoad Members
NFX.Instrumentation.Self Namespace


SelfInstrumentationLongGauge Class

SelfInstrumentationLongGauge Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Instrumentation.Self SelfInstrumentationLongGauge
NFX.Instrumentation.Self BufferMaxAge
NFX.Instrumentation.Self ProcessingInterval
NFX.Instrumentation.Self RecordCount
NFX.Instrumentation.Self RecordLoad

Namespace: NFX.Instrumentation.Self
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class SelfInstrumentationLongGauge : LongGauge,
    IInstrumentationInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public abstract class SelfInstrumentationLongGauge : LongGauge,
    IInstrumentationInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public MustInherit Class SelfInstrumentationLongGauge
    Inherits LongGauge
    Implements IInstrumentationInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public MustInherit Class SelfInstrumentationLongGauge
    Inherits LongGauge
    Implements IInstrumentationInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class SelfInstrumentationLongGauge abstract : public LongGauge,
    IInstrumentationInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class SelfInstrumentationLongGauge abstract : public LongGauge,
    IInstrumentationInstrument, IOperationClass, IInstrumentClass
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type SelfInstrumentationLongGauge =
    class
        inherit LongGauge
        interface IInstrumentationInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type SelfInstrumentationLongGauge =
    class
        inherit LongGauge
        interface IInstrumentationInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
SelfInstrumentationLongGauge Members
NFX.Instrumentation.Self Namespace


SelfInstrumentationLongGauge Members

SelfInstrumentationLongGauge Members NFX Class Library

The SelfInstrumentationLongGauge type exposes the following members.
Constructors
 | Name | Description
Protected method | SelfInstrumentationLongGauge | Initializes a new instance of the SelfInstrumentationLongGauge class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Inherited from LongGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
SelfInstrumentationLongGauge Class
NFX.Instrumentation.Self Namespace


SelfInstrumentationLongGauge Constructor

SelfInstrumentationLongGauge Constructor NFX Class Library

Initializes a new instance of the SelfInstrumentationLongGauge class

Namespace: NFX.Instrumentation.Self
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected SelfInstrumentationLongGauge(
    long value
)
protected SelfInstrumentationLongGauge(
    long value
)
Protected Sub New (
    value As Long
)
Protected Sub New (
    value As Long
)
protected:
SelfInstrumentationLongGauge(
    long long value
)
protected:
SelfInstrumentationLongGauge(
    long long value
)
new :
        value : int64 -> SelfInstrumentationLongGauge
new :
        value : int64 -> SelfInstrumentationLongGauge

Parameters

value
Type: Online System Int64
See Also
SelfInstrumentationLongGauge Class
SelfInstrumentationLongGauge Members
NFX.Instrumentation.Self Namespace


SelfInstrumentationLongGauge Fields

SelfInstrumentationLongGauge Fields NFX Class Library

The SelfInstrumentationLongGauge type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
SelfInstrumentationLongGauge Class
NFX.Instrumentation.Self Namespace


SelfInstrumentationLongGauge Methods

SelfInstrumentationLongGauge Methods NFX Class Library

The SelfInstrumentationLongGauge type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SelfInstrumentationLongGauge Class
NFX.Instrumentation.Self Namespace


SelfInstrumentationLongGauge Properties

SelfInstrumentationLongGauge Properties NFX Class Library

The SelfInstrumentationLongGauge type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Inherited from LongGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
SelfInstrumentationLongGauge Class
NFX.Instrumentation.Self Namespace


NFX.Instrumentation.Telemetry Namespace

NFX.Instrumentation.Telemetry Namespace NFX Class Library

Provides means for remote acquisition of instrumentation data
Classes
 | Class | Description
Public class | TelemetryInstrumentationProvider | Represents a provider that writes aggregated datums into remote telemetry receiver
Public class | TelemetryReceiverClient | Client for glued contract NFX.Instrumentation.Telemetry.ITelemetryReceiver server. Each contract method has synchronous and asynchronous versions, the later denoted by 'Async_' prefix. May inject client-level inspectors here like so: client.MsgInspectors.Register( new YOUR_CLIENT_INSPECTOR_TYPE());
Interfaces
 | Interface | Description
Public interface | ITelemetryReceiver | Represents a contract for working with remote receiver of telemetry information


ITelemetryReceiver Interface

ITelemetryReceiver Interface NFX Class Library

Represents a contract for working with remote receiver of telemetry information

Namespace: NFX.Instrumentation.Telemetry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[GluedAttribute]
[LifeCycleAttribute(Mode = ServerInstanceMode.Singleton)]
public interface ITelemetryReceiver
[GluedAttribute]
[LifeCycleAttribute(Mode = ServerInstanceMode.Singleton)]
public interface ITelemetryReceiver
<GluedAttribute>
<LifeCycleAttribute(Mode := ServerInstanceMode.Singleton)>
Public Interface ITelemetryReceiver
<GluedAttribute>
<LifeCycleAttribute(Mode := ServerInstanceMode.Singleton)>
Public Interface ITelemetryReceiver
[GluedAttribute]
[LifeCycleAttribute(Mode = ServerInstanceMode::Singleton)]
public interface class ITelemetryReceiver
[GluedAttribute]
[LifeCycleAttribute(Mode = ServerInstanceMode::Singleton)]
public interface class ITelemetryReceiver
[<GluedAttribute>]
[<LifeCycleAttribute(Mode = ServerInstanceMode.Singleton)>]
type ITelemetryReceiver =  interface end
[<GluedAttribute>]
[<LifeCycleAttribute(Mode = ServerInstanceMode.Singleton)>]
type ITelemetryReceiver =  interface end
See Also
ITelemetryReceiver Members
NFX.Instrumentation.Telemetry Namespace


ITelemetryReceiver Members

ITelemetryReceiver Members NFX Class Library

The ITelemetryReceiver type exposes the following members.
Methods
 | Name | Description
Public method | Send | Sends data to remote telemetry receiver
Back to Top
See Also
ITelemetryReceiver Interface
NFX.Instrumentation.Telemetry Namespace


ITelemetryReceiver Methods

ITelemetryReceiver Methods NFX Class Library

The ITelemetryReceiver type exposes the following members.
Methods
 | Name | Description
Public method | Send | Sends data to remote telemetry receiver
Back to Top
See Also
ITelemetryReceiver Interface
NFX.Instrumentation.Telemetry Namespace


ITelemetryReceiver.Send Method

ITelemetryReceiver Send Method NFX Class Library

Sends data to remote telemetry receiver

Namespace: NFX.Instrumentation.Telemetry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[OneWayAttribute]
void Send(
    string siteName,
    Datum data
)
[OneWayAttribute]
void Send(
    string siteName,
    Datum data
)
<OneWayAttribute>
Sub Send (
    siteName As String,
    data As Datum
)
<OneWayAttribute>
Sub Send (
    siteName As String,
    data As Datum
)
[OneWayAttribute]
void Send(
    String^ siteName,
    Datum^ data
)
[OneWayAttribute]
void Send(
    String^ siteName,
    Datum^ data
)
[<OneWayAttribute>]
abstract Send :
        siteName : string *
        data : Datum -> unit
[<OneWayAttribute>]
abstract Send :
        siteName : string *
        data : Datum -> unit

Parameters

siteName
Type: Online System String
the name/identifier of the reporting site
data
Type: NFX.Instrumentation Datum
Telemetry data
See Also
ITelemetryReceiver Interface
ITelemetryReceiver Members
NFX.Instrumentation.Telemetry Namespace


TelemetryInstrumentationProvider Class

TelemetryInstrumentationProvider Class NFX Class Library

Represents a provider that writes aggregated datums into remote telemetry receiver
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service InstrumentationService
NFX.Instrumentation InstrumentationProvider
NFX.Instrumentation LogInstrumentationProvider
NFX.Instrumentation.Telemetry TelemetryInstrumentationProvider

Namespace: NFX.Instrumentation.Telemetry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TelemetryInstrumentationProvider : LogInstrumentationProvider
public class TelemetryInstrumentationProvider : LogInstrumentationProvider
Public Class TelemetryInstrumentationProvider
    Inherits LogInstrumentationProvider
Public Class TelemetryInstrumentationProvider
    Inherits LogInstrumentationProvider
public ref class TelemetryInstrumentationProvider : public LogInstrumentationProvider
public ref class TelemetryInstrumentationProvider : public LogInstrumentationProvider
type TelemetryInstrumentationProvider =
    class
        inherit LogInstrumentationProvider
    end
type TelemetryInstrumentationProvider =
    class
        inherit LogInstrumentationProvider
    end
See Also
TelemetryInstrumentationProvider Members
NFX.Instrumentation.Telemetry Namespace


TelemetryInstrumentationProvider Members

TelemetryInstrumentationProvider Members NFX Class Library

The TelemetryInstrumentationProvider type exposes the following members.
Constructors
 | Name | Description
Public method | TelemetryInstrumentationProvider | Initializes a new instance of the TelemetryInstrumentationProvider class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Overrides Service Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Inherited from InstrumentationProvider.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from InstrumentationProvider.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from InstrumentationProvider.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from InstrumentationProvider.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | Write | (Overrides LogInstrumentationProvider Write(Datum).)
Protected method | WriteLog | (Inherited from InstrumentationProvider.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from InstrumentationProvider.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | ReceiverNode | Provides remote telemetry receiver node
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | SiteName | Provides name for reporting site, if this property is blank then App.Name is used instead
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | UseLog | Determines whether to write to log as well
Back to Top
See Also
TelemetryInstrumentationProvider Class
NFX.Instrumentation.Telemetry Namespace


TelemetryInstrumentationProvider Constructor

TelemetryInstrumentationProvider Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TelemetryInstrumentationProvider class

Namespace: NFX.Instrumentation.Telemetry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TelemetryInstrumentationProvider()
public TelemetryInstrumentationProvider()
Public Sub New
Public Sub New
public:
TelemetryInstrumentationProvider()
public:
TelemetryInstrumentationProvider()
new : unit -> TelemetryInstrumentationProvider
new : unit -> TelemetryInstrumentationProvider
See Also
TelemetryInstrumentationProvider Class
TelemetryInstrumentationProvider Members
NFX.Instrumentation.Telemetry Namespace


TelemetryInstrumentationProvider Methods

TelemetryInstrumentationProvider Methods NFX Class Library

The TelemetryInstrumentationProvider type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Overrides Service Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Inherited from InstrumentationProvider.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from InstrumentationProvider.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from InstrumentationProvider.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from InstrumentationProvider.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | Write | (Overrides LogInstrumentationProvider Write(Datum).)
Protected method | WriteLog | (Inherited from InstrumentationProvider.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TelemetryInstrumentationProvider Class
NFX.Instrumentation.Telemetry Namespace


TelemetryInstrumentationProvider.Destructor Method

TelemetryInstrumentationProvider Destructor Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation.Telemetry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
TelemetryInstrumentationProvider Class
TelemetryInstrumentationProvider Members
NFX.Instrumentation.Telemetry Namespace


TelemetryInstrumentationProvider.Write Method

TelemetryInstrumentationProvider Write Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Instrumentation.Telemetry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Datum aggregatedDatum
)
public override void Write(
    Datum aggregatedDatum
)
Public Overrides Sub Write (
    aggregatedDatum As Datum
)
Public Overrides Sub Write (
    aggregatedDatum As Datum
)
public:
virtual void Write(
    Datum^ aggregatedDatum
) override
public:
virtual void Write(
    Datum^ aggregatedDatum
) override
abstract Write :
        aggregatedDatum : Datum -> unit
override Write :
        aggregatedDatum : Datum -> unit
abstract Write :
        aggregatedDatum : Datum -> unit
override Write :
        aggregatedDatum : Datum -> unit

Parameters

aggregatedDatum
Type: NFX.Instrumentation Datum
See Also
TelemetryInstrumentationProvider Class
TelemetryInstrumentationProvider Members
NFX.Instrumentation.Telemetry Namespace


TelemetryInstrumentationProvider Properties

TelemetryInstrumentationProvider Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The TelemetryInstrumentationProvider type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from InstrumentationProvider.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | ReceiverNode | Provides remote telemetry receiver node
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | SiteName | Provides name for reporting site, if this property is blank then App.Name is used instead
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | UseLog | Determines whether to write to log as well
Back to Top
See Also
TelemetryInstrumentationProvider Class
NFX.Instrumentation.Telemetry Namespace


TelemetryInstrumentationProvider.ReceiverNode Property

TelemetryInstrumentationProvider ReceiverNode Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Provides remote telemetry receiver node

Namespace: NFX.Instrumentation.Telemetry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string ReceiverNode { get; set; }
[ConfigAttribute]
public string ReceiverNode { get; set; }
<ConfigAttribute>
Public Property ReceiverNode As String
    Get
    Set
<ConfigAttribute>
Public Property ReceiverNode As String
    Get
    Set
public:
[ConfigAttribute]
property String^ ReceiverNode {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ ReceiverNode {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member ReceiverNode : string with get, set
[<ConfigAttribute>]
member ReceiverNode : string with get, set

Property Value

Type: Online String
See Also
TelemetryInstrumentationProvider Class
TelemetryInstrumentationProvider Members
NFX.Instrumentation.Telemetry Namespace


TelemetryInstrumentationProvider.SiteName Property

TelemetryInstrumentationProvider SiteName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Provides name for reporting site, if this property is blank then App.Name is used instead

Namespace: NFX.Instrumentation.Telemetry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string SiteName { get; set; }
[ConfigAttribute]
public string SiteName { get; set; }
<ConfigAttribute>
Public Property SiteName As String
    Get
    Set
<ConfigAttribute>
Public Property SiteName As String
    Get
    Set
public:
[ConfigAttribute]
property String^ SiteName {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ SiteName {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member SiteName : string with get, set
[<ConfigAttribute>]
member SiteName : string with get, set

Property Value

Type: Online String
See Also
TelemetryInstrumentationProvider Class
TelemetryInstrumentationProvider Members
NFX.Instrumentation.Telemetry Namespace


TelemetryInstrumentationProvider.UseLog Property

TelemetryInstrumentationProvider UseLog Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Determines whether to write to log as well

Namespace: NFX.Instrumentation.Telemetry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool UseLog { get; set; }
[ConfigAttribute]
public bool UseLog { get; set; }
<ConfigAttribute>
Public Property UseLog As Boolean
    Get
    Set
<ConfigAttribute>
Public Property UseLog As Boolean
    Get
    Set
public:
[ConfigAttribute]
property bool UseLog {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute]
property bool UseLog {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute>]
member UseLog : bool with get, set
[<ConfigAttribute>]
member UseLog : bool with get, set

Property Value

Type: Online Boolean
See Also
TelemetryInstrumentationProvider Class
TelemetryInstrumentationProvider Members
NFX.Instrumentation.Telemetry Namespace


TelemetryReceiverClient Class

TelemetryReceiverClient Class NFX Class Library

Client for glued contract NFX.Instrumentation.Telemetry.ITelemetryReceiver server. Each contract method has synchronous and asynchronous versions, the later denoted by 'Async_' prefix. May inject client-level inspectors here like so: client.MsgInspectors.Register( new YOUR_CLIENT_INSPECTOR_TYPE());
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Glue EndPoint
NFX.Glue ClientEndPoint
NFX.Instrumentation.Telemetry TelemetryReceiverClient

Namespace: NFX.Instrumentation.Telemetry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TelemetryReceiverClient : ClientEndPoint,
    ITelemetryReceiver
public class TelemetryReceiverClient : ClientEndPoint,
    ITelemetryReceiver
Public Class TelemetryReceiverClient
    Inherits ClientEndPoint
    Implements ITelemetryReceiver
Public Class TelemetryReceiverClient
    Inherits ClientEndPoint
    Implements ITelemetryReceiver
public ref class TelemetryReceiverClient : public ClientEndPoint,
    ITelemetryReceiver
public ref class TelemetryReceiverClient : public ClientEndPoint,
    ITelemetryReceiver
type TelemetryReceiverClient =
    class
        inherit ClientEndPoint
        interface ITelemetryReceiver
    end
type TelemetryReceiverClient =
    class
        inherit ClientEndPoint
        interface ITelemetryReceiver
    end
See Also
TelemetryReceiverClient Members
NFX.Instrumentation.Telemetry Namespace


TelemetryReceiverClient Members

TelemetryReceiverClient Members NFX Class Library

The TelemetryReceiverClient type exposes the following members.
Constructors
 | Name | Description
Public method | TelemetryReceiverClient(String, Binding) | Initializes a new instance of the TelemetryReceiverClient class
Public method | TelemetryReceiverClient(Node, Binding) | Initializes a new instance of the TelemetryReceiverClient class
Public method | TelemetryReceiverClient(IGlue, Node, Binding) | Initializes a new instance of the TelemetryReceiverClient class
Public method | TelemetryReceiverClient(IGlue, String, Binding) | Initializes a new instance of the TelemetryReceiverClient class
Back to Top
Methods
 | Name | Description
Protected method | __setRemoteInstance | (Inherited from ClientEndPoint.)
Public method | Async_Send | Asynchronous invoker for 'NFX.Instrumentation.Telemetry.ITelemetryReceiver.Send'. This is a one-way call per contract specification, meaning - the server sends no acknowledgement of this call receipt and there is no result that server could return back to the caller. CallSlot is returned that can be queried for CallStatus, ResponseMsg.
Protected method | Destructor | (Inherited from ClientEndPoint.)
Protected method | DispatchCall | Dispatches a call into binding passing message through client inspectors on this endpoint (Inherited from ClientEndPoint.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | ForgetRemoteInstance | Sets RemoteInstance to null. This method is needed when the same instance of client endpoint is used to make subsequent statefull calls to different server instances. Call this method before calling [Constructor]-decorated remote method or making the first call to InstanceLifetime.AutoconstructedStateful servers. (Inherited from ClientEndPoint.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Send | Synchronous invoker for 'NFX.Instrumentation.Telemetry.ITelemetryReceiver.Send'. This is a one-way call per contract specification, meaning - the server sends no acknowledgement of this call receipt and there is no result that server could return back to the caller. ClientCallException is thrown if the call could not be placed in the outgoing queue.
Public method | ToString | (Inherited from ClientEndPoint.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Binding | (Inherited from EndPoint.)
Protected field | m_Glue | (Inherited from EndPoint.)
Protected field | m_Node | (Inherited from EndPoint.)
Protected field | m_ReservedTransport | (Inherited from ClientEndPoint.)
Back to Top
Properties
 | Name | Description
Public property | Binding | Returns a binding of this endpoint. "B" component of the "ABC" rule (Inherited from EndPoint.)
Public property | Contract | (Overrides ClientEndPoint Contract.)
Public property | DispatchTimeoutMs | Specifies timeout for call invocation (Inherited from ClientEndPoint.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Glue | References glue that this endpoint works under (Inherited from EndPoint.)
Public property | Headers | Returns headers that get attached in every call (Inherited from ClientEndPoint.)
Public property | MsgInspectors | Returns client message inspectors for this instance (Inherited from ClientEndPoint.)
Public property | Node | Returns a node of this endpoint. "A" component of the "ABC" rule (Inherited from EndPoint.)
Public property | RemoteInstance | Returns a reference to remote instance or null if service is stateless(no instance created) (Inherited from ClientEndPoint.)
Public property | ReserveTransport | Indicates whether transport instance should not be released after a call and be reserved per this endpoint instance. Be carefull when setting this property to true as this action can really impede the system performance as transport is reserved until this property is either reset to false or endpoint instance is disposed. Transport reservation reduces call latency and is mostly beneficial in synchronous bindings. Warning: client endpoint with reserved transport is NOT THREAD SAFE for making parallel calls! Set this property to true only when latency is very critical and only 1 dedicated thread is working with this client endpoint instance (Inherited from ClientEndPoint.)
Public property | TimeoutMs | Specifies timeout for the whole call (Inherited from ClientEndPoint.)
Back to Top
See Also
TelemetryReceiverClient Class
NFX.Instrumentation.Telemetry Namespace


TelemetryReceiverClient Constructor

TelemetryReceiverClient Constructor NFX Class Library

Overload List
 | Name | Description
Public method | TelemetryReceiverClient(String, Binding) | Initializes a new instance of the TelemetryReceiverClient class
Public method | TelemetryReceiverClient(Node, Binding) | Initializes a new instance of the TelemetryReceiverClient class
Public method | TelemetryReceiverClient(IGlue, Node, Binding) | Initializes a new instance of the TelemetryReceiverClient class
Public method | TelemetryReceiverClient(IGlue, String, Binding) | Initializes a new instance of the TelemetryReceiverClient class
Back to Top
See Also
TelemetryReceiverClient Class
TelemetryReceiverClient Members
NFX.Instrumentation.Telemetry Namespace


TelemetryReceiverClient Constructor (String, Binding)

TelemetryReceiverClient Constructor (String, Binding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TelemetryReceiverClient class

Namespace: NFX.Instrumentation.Telemetry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TelemetryReceiverClient(
    string node,
    Binding binding = null
)
public TelemetryReceiverClient(
    string node,
    Binding binding = null
)
Public Sub New (
    node As String,
    Optional binding As Binding = Nothing
)
Public Sub New (
    node As String,
    Optional binding As Binding = Nothing
)
public:
TelemetryReceiverClient(
    String^ node,
    Binding^ binding = nullptr
)
public:
TelemetryReceiverClient(
    String^ node,
    Binding^ binding = nullptr
)
new :
        node : string *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> TelemetryReceiverClient
new :
        node : string *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> TelemetryReceiverClient

Parameters

node
Type: Online System String
binding (Optional)
Type: NFX.Glue Binding
See Also
TelemetryReceiverClient Class
TelemetryReceiverClient Members
TelemetryReceiverClient Overload
NFX.Instrumentation.Telemetry Namespace


TelemetryReceiverClient Constructor (Node, Binding)

TelemetryReceiverClient Constructor (Node, Binding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TelemetryReceiverClient class

Namespace: NFX.Instrumentation.Telemetry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TelemetryReceiverClient(
    Node node,
    Binding binding = null
)
public TelemetryReceiverClient(
    Node node,
    Binding binding = null
)
Public Sub New (
    node As Node,
    Optional binding As Binding = Nothing
)
Public Sub New (
    node As Node,
    Optional binding As Binding = Nothing
)
public:
TelemetryReceiverClient(
    Node node,
    Binding^ binding = nullptr
)
public:
TelemetryReceiverClient(
    Node node,
    Binding^ binding = nullptr
)
new :
        node : Node *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> TelemetryReceiverClient
new :
        node : Node *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> TelemetryReceiverClient

Parameters

node
Type: NFX.Glue Node
binding (Optional)
Type: NFX.Glue Binding
See Also
TelemetryReceiverClient Class
TelemetryReceiverClient Members
TelemetryReceiverClient Overload
NFX.Instrumentation.Telemetry Namespace


TelemetryReceiverClient Constructor (IGlue, Node, Binding)

TelemetryReceiverClient Constructor (IGlue, Node, Binding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TelemetryReceiverClient class

Namespace: NFX.Instrumentation.Telemetry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TelemetryReceiverClient(
    IGlue glue,
    Node node,
    Binding binding = null
)
public TelemetryReceiverClient(
    IGlue glue,
    Node node,
    Binding binding = null
)
Public Sub New (
    glue As IGlue,
    node As Node,
    Optional binding As Binding = Nothing
)
Public Sub New (
    glue As IGlue,
    node As Node,
    Optional binding As Binding = Nothing
)
public:
TelemetryReceiverClient(
    IGlue^ glue,
    Node node,
    Binding^ binding = nullptr
)
public:
TelemetryReceiverClient(
    IGlue^ glue,
    Node node,
    Binding^ binding = nullptr
)
new :
        glue : IGlue *
        node : Node *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> TelemetryReceiverClient
new :
        glue : IGlue *
        node : Node *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> TelemetryReceiverClient

Parameters

glue
Type: NFX.Glue IGlue
node
Type: NFX.Glue Node
binding (Optional)
Type: NFX.Glue Binding
See Also
TelemetryReceiverClient Class
TelemetryReceiverClient Members
TelemetryReceiverClient Overload
NFX.Instrumentation.Telemetry Namespace


TelemetryReceiverClient Constructor (IGlue, String, Binding)

TelemetryReceiverClient Constructor (IGlue, String, Binding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TelemetryReceiverClient class

Namespace: NFX.Instrumentation.Telemetry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TelemetryReceiverClient(
    IGlue glue,
    string node,
    Binding binding = null
)
public TelemetryReceiverClient(
    IGlue glue,
    string node,
    Binding binding = null
)
Public Sub New (
    glue As IGlue,
    node As String,
    Optional binding As Binding = Nothing
)
Public Sub New (
    glue As IGlue,
    node As String,
    Optional binding As Binding = Nothing
)
public:
TelemetryReceiverClient(
    IGlue^ glue,
    String^ node,
    Binding^ binding = nullptr
)
public:
TelemetryReceiverClient(
    IGlue^ glue,
    String^ node,
    Binding^ binding = nullptr
)
new :
        glue : IGlue *
        node : string *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> TelemetryReceiverClient
new :
        glue : IGlue *
        node : string *
        ?binding : Binding
(* Defaults:
        let _binding = defaultArg binding null
*)
-> TelemetryReceiverClient

Parameters

glue
Type: NFX.Glue IGlue
node
Type: Online System String
binding (Optional)
Type: NFX.Glue Binding
See Also
TelemetryReceiverClient Class
TelemetryReceiverClient Members
TelemetryReceiverClient Overload
NFX.Instrumentation.Telemetry Namespace


TelemetryReceiverClient Fields

TelemetryReceiverClient Fields NFX Class Library

The TelemetryReceiverClient type exposes the following members.
Fields
 | Name | Description
Protected field | m_Binding | (Inherited from EndPoint.)
Protected field | m_Glue | (Inherited from EndPoint.)
Protected field | m_Node | (Inherited from EndPoint.)
Protected field | m_ReservedTransport | (Inherited from ClientEndPoint.)
Back to Top
See Also
TelemetryReceiverClient Class
NFX.Instrumentation.Telemetry Namespace


TelemetryReceiverClient Methods

TelemetryReceiverClient Methods NFX Class Library

The TelemetryReceiverClient type exposes the following members.
Methods
 | Name | Description
Protected method | __setRemoteInstance | (Inherited from ClientEndPoint.)
Public method | Async_Send | Asynchronous invoker for 'NFX.Instrumentation.Telemetry.ITelemetryReceiver.Send'. This is a one-way call per contract specification, meaning - the server sends no acknowledgement of this call receipt and there is no result that server could return back to the caller. CallSlot is returned that can be queried for CallStatus, ResponseMsg.
Protected method | Destructor | (Inherited from ClientEndPoint.)
Protected method | DispatchCall | Dispatches a call into binding passing message through client inspectors on this endpoint (Inherited from ClientEndPoint.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | ForgetRemoteInstance | Sets RemoteInstance to null. This method is needed when the same instance of client endpoint is used to make subsequent statefull calls to different server instances. Call this method before calling [Constructor]-decorated remote method or making the first call to InstanceLifetime.AutoconstructedStateful servers. (Inherited from ClientEndPoint.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Send | Synchronous invoker for 'NFX.Instrumentation.Telemetry.ITelemetryReceiver.Send'. This is a one-way call per contract specification, meaning - the server sends no acknowledgement of this call receipt and there is no result that server could return back to the caller. ClientCallException is thrown if the call could not be placed in the outgoing queue.
Public method | ToString | (Inherited from ClientEndPoint.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TelemetryReceiverClient Class
NFX.Instrumentation.Telemetry Namespace


TelemetryReceiverClient.Async_Send Method

TelemetryReceiverClient Async_Send Method NFX Class Library

Asynchronous invoker for 'NFX.Instrumentation.Telemetry.ITelemetryReceiver.Send'. This is a one-way call per contract specification, meaning - the server sends no acknowledgement of this call receipt and there is no result that server could return back to the caller. CallSlot is returned that can be queried for CallStatus, ResponseMsg.

Namespace: NFX.Instrumentation.Telemetry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CallSlot Async_Send(
    string siteName,
    Datum data
)
public CallSlot Async_Send(
    string siteName,
    Datum data
)
Public Function Async_Send (
    siteName As String,
    data As Datum
) As CallSlot
Public Function Async_Send (
    siteName As String,
    data As Datum
) As CallSlot
public:
CallSlot^ Async_Send(
    String^ siteName,
    Datum^ data
)
public:
CallSlot^ Async_Send(
    String^ siteName,
    Datum^ data
)
member Async_Send :
        siteName : string *
        data : Datum -> CallSlot
member Async_Send :
        siteName : string *
        data : Datum -> CallSlot

Parameters

siteName
Type: Online System String
data
Type: NFX.Instrumentation Datum

Return Value

Type: CallSlot
See Also
TelemetryReceiverClient Class
TelemetryReceiverClient Members
NFX.Instrumentation.Telemetry Namespace


TelemetryReceiverClient.Send Method

TelemetryReceiverClient Send Method NFX Class Library

Synchronous invoker for 'NFX.Instrumentation.Telemetry.ITelemetryReceiver.Send'. This is a one-way call per contract specification, meaning - the server sends no acknowledgement of this call receipt and there is no result that server could return back to the caller. ClientCallException is thrown if the call could not be placed in the outgoing queue.

Namespace: NFX.Instrumentation.Telemetry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Send(
    string siteName,
    Datum data
)
public void Send(
    string siteName,
    Datum data
)
Public Sub Send (
    siteName As String,
    data As Datum
)
Public Sub Send (
    siteName As String,
    data As Datum
)
public:
virtual void Send(
    String^ siteName,
    Datum^ data
) sealed
public:
virtual void Send(
    String^ siteName,
    Datum^ data
) sealed
abstract Send :
        siteName : string *
        data : Datum -> unit
override Send :
        siteName : string *
        data : Datum -> unit
abstract Send :
        siteName : string *
        data : Datum -> unit
override Send :
        siteName : string *
        data : Datum -> unit

Parameters

siteName
Type: Online System String
data
Type: NFX.Instrumentation Datum

Implements

ITelemetryReceiver Send(String, Datum)
See Also
TelemetryReceiverClient Class
TelemetryReceiverClient Members
NFX.Instrumentation.Telemetry Namespace


TelemetryReceiverClient Properties

TelemetryReceiverClient Properties NFX Class Library

The TelemetryReceiverClient type exposes the following members.
Properties
 | Name | Description
Public property | Binding | Returns a binding of this endpoint. "B" component of the "ABC" rule (Inherited from EndPoint.)
Public property | Contract | (Overrides ClientEndPoint Contract.)
Public property | DispatchTimeoutMs | Specifies timeout for call invocation (Inherited from ClientEndPoint.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Glue | References glue that this endpoint works under (Inherited from EndPoint.)
Public property | Headers | Returns headers that get attached in every call (Inherited from ClientEndPoint.)
Public property | MsgInspectors | Returns client message inspectors for this instance (Inherited from ClientEndPoint.)
Public property | Node | Returns a node of this endpoint. "A" component of the "ABC" rule (Inherited from EndPoint.)
Public property | RemoteInstance | Returns a reference to remote instance or null if service is stateless(no instance created) (Inherited from ClientEndPoint.)
Public property | ReserveTransport | Indicates whether transport instance should not be released after a call and be reserved per this endpoint instance. Be carefull when setting this property to true as this action can really impede the system performance as transport is reserved until this property is either reset to false or endpoint instance is disposed. Transport reservation reduces call latency and is mostly beneficial in synchronous bindings. Warning: client endpoint with reserved transport is NOT THREAD SAFE for making parallel calls! Set this property to true only when latency is very critical and only 1 dedicated thread is working with this client endpoint instance (Inherited from ClientEndPoint.)
Public property | TimeoutMs | Specifies timeout for the whole call (Inherited from ClientEndPoint.)
Back to Top
See Also
TelemetryReceiverClient Class
NFX.Instrumentation.Telemetry Namespace


TelemetryReceiverClient.Contract Property

TelemetryReceiverClient Contract Property NFX Class Library

Namespace: NFX.Instrumentation.Telemetry
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Type Contract { get; }
public override Type Contract { get; }
Public Overrides ReadOnly Property Contract As Type
    Get
Public Overrides ReadOnly Property Contract As Type
    Get
public:
virtual property Type^ Contract {
    Type^ get () override;
}
public:
virtual property Type^ Contract {
    Type^ get () override;
}
abstract Contract : Type with get
override Contract : Type with get
abstract Contract : Type with get
override Contract : Type with get

Property Value

Type: Online Type
See Also
TelemetryReceiverClient Class
TelemetryReceiverClient Members
NFX.Instrumentation.Telemetry Namespace


NFX.Inventorization Namespace

NFX.Inventorization Namespace NFX Class Library

Provides types for code/asset inventory
Classes
 | Class | Description
Public class | BasicInventorization | Performs basic inventorization of Inventory-marked types and their members
Public class | InventorizationException | Base exception thrown by inventorization operations
Public class | InventorizationManager | Performs an inventory scan of supplied assemblies using specified options. Items to be included in result must be tagged with Inventory attribute, otherwise then will be omitted unless OnlyAttributed == false. The scan is performed using options and inventorization strategies. This class is NOT THREAD SAFE
Public class | InventoryAttribute | Defines an inventory-related set of data which is used by automatic code/component discovery such as database schema generation tools and system-global registry servers
Public class | Strategies | Defines a list of inventorization strategies
Interfaces
 | Interface | Description
Public interface | IInventorization | Defines an abstraction of inventorization
Enumerations
 | Enumeration | Description
Public enumeration | SystemConcerns | Designates item concerns
Public enumeration | SystemTiers | Designates system architecture tiers


BasicInventorization Class

BasicInventorization Class NFX Class Library

Performs basic inventorization of Inventory-marked types and their members
Inheritance Hierarchy
Online System Object
NFX.Inventorization BasicInventorization

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class BasicInventorization : IInventorization
public class BasicInventorization : IInventorization
Public Class BasicInventorization
    Implements IInventorization
Public Class BasicInventorization
    Implements IInventorization
public ref class BasicInventorization : IInventorization
public ref class BasicInventorization : IInventorization
type BasicInventorization =
    class
        interface IInventorization
    end
type BasicInventorization =
    class
        interface IInventorization
    end
See Also
BasicInventorization Members
NFX.Inventorization Namespace


BasicInventorization Members

BasicInventorization Members NFX Class Library

The BasicInventorization type exposes the following members.
Constructors
 | Name | Description
Public method | BasicInventorization | Initializes a new instance of the BasicInventorization class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Inventorize |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BasicInventorization Class
NFX.Inventorization Namespace


BasicInventorization Constructor

BasicInventorization Constructor NFX Class Library

Initializes a new instance of the BasicInventorization class

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BasicInventorization()
public BasicInventorization()
Public Sub New
Public Sub New
public:
BasicInventorization()
public:
BasicInventorization()
new : unit -> BasicInventorization
new : unit -> BasicInventorization
See Also
BasicInventorization Class
BasicInventorization Members
NFX.Inventorization Namespace


BasicInventorization Methods

BasicInventorization Methods NFX Class Library

The BasicInventorization type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Inventorize |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BasicInventorization Class
NFX.Inventorization Namespace


BasicInventorization.Inventorize Method

BasicInventorization Inventorize Method NFX Class Library

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Inventorize(
    Type t,
    ConfigSectionNode root
)
public void Inventorize(
    Type t,
    ConfigSectionNode root
)
Public Sub Inventorize (
    t As Type,
    root As ConfigSectionNode
)
Public Sub Inventorize (
    t As Type,
    root As ConfigSectionNode
)
public:
virtual void Inventorize(
    Type^ t,
    ConfigSectionNode^ root
) sealed
public:
virtual void Inventorize(
    Type^ t,
    ConfigSectionNode^ root
) sealed
abstract Inventorize :
        t : Type *
        root : ConfigSectionNode -> unit
override Inventorize :
        t : Type *
        root : ConfigSectionNode -> unit
abstract Inventorize :
        t : Type *
        root : ConfigSectionNode -> unit
override Inventorize :
        t : Type *
        root : ConfigSectionNode -> unit

Parameters

t
Type: Online System Type
root
Type: NFX.Environment ConfigSectionNode

Implements

IInventorization Inventorize(Type, ConfigSectionNode)
See Also
BasicInventorization Class
BasicInventorization Members
NFX.Inventorization Namespace


IInventorization Interface

IInventorization Interface NFX Class Library

Defines an abstraction of inventorization

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IInventorization
public interface IInventorization
Public Interface IInventorization
Public Interface IInventorization
public interface class IInventorization
public interface class IInventorization
type IInventorization =  interface end
type IInventorization =  interface end
See Also
IInventorization Members
NFX.Inventorization Namespace


IInventorization Members

IInventorization Members NFX Class Library

The IInventorization type exposes the following members.
Methods
 | Name | Description
Public method | Inventorize |
Back to Top
See Also
IInventorization Interface
NFX.Inventorization Namespace


IInventorization Methods

IInventorization Methods NFX Class Library

The IInventorization type exposes the following members.
Methods
 | Name | Description
Public method | Inventorize |
Back to Top
See Also
IInventorization Interface
NFX.Inventorization Namespace


IInventorization.Inventorize Method

IInventorization Inventorize Method NFX Class Library

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Inventorize(
    Type t,
    ConfigSectionNode root
)
void Inventorize(
    Type t,
    ConfigSectionNode root
)
Sub Inventorize (
    t As Type,
    root As ConfigSectionNode
)
Sub Inventorize (
    t As Type,
    root As ConfigSectionNode
)
void Inventorize(
    Type^ t,
    ConfigSectionNode^ root
)
void Inventorize(
    Type^ t,
    ConfigSectionNode^ root
)
abstract Inventorize :
        t : Type *
        root : ConfigSectionNode -> unit
abstract Inventorize :
        t : Type *
        root : ConfigSectionNode -> unit

Parameters

t
Type: Online System Type
root
Type: NFX.Environment ConfigSectionNode
See Also
IInventorization Interface
IInventorization Members
NFX.Inventorization Namespace


InventorizationException Class

InventorizationException Class NFX Class Library

Base exception thrown by inventorization operations
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Inventorization InventorizationException

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class InventorizationException : NFXException
[SerializableAttribute]
public class InventorizationException : NFXException
<SerializableAttribute>
Public Class InventorizationException
    Inherits NFXException
<SerializableAttribute>
Public Class InventorizationException
    Inherits NFXException
[SerializableAttribute]
public ref class InventorizationException : public NFXException
[SerializableAttribute]
public ref class InventorizationException : public NFXException
[<SerializableAttribute>]
type InventorizationException =
    class
        inherit NFXException
    end
[<SerializableAttribute>]
type InventorizationException =
    class
        inherit NFXException
    end
See Also
InventorizationException Members
NFX.Inventorization Namespace


InventorizationException Members

InventorizationException Members NFX Class Library

The InventorizationException type exposes the following members.
Constructors
 | Name | Description
Public method | InventorizationException | Initializes a new instance of the InventorizationException class
Public method | InventorizationException(String) | Initializes a new instance of the InventorizationException class
Protected method | InventorizationException(SerializationInfo, StreamingContext) | Initializes a new instance of the InventorizationException class
Public method | InventorizationException(String, Exception) | Initializes a new instance of the InventorizationException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
InventorizationException Class
NFX.Inventorization Namespace


InventorizationException Constructor

InventorizationException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | InventorizationException | Initializes a new instance of the InventorizationException class
Public method | InventorizationException(String) | Initializes a new instance of the InventorizationException class
Protected method | InventorizationException(SerializationInfo, StreamingContext) | Initializes a new instance of the InventorizationException class
Public method | InventorizationException(String, Exception) | Initializes a new instance of the InventorizationException class
Back to Top
See Also
InventorizationException Class
InventorizationException Members
NFX.Inventorization Namespace


InventorizationException Constructor

InventorizationException Constructor NFX Class Library

Initializes a new instance of the InventorizationException class

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InventorizationException()
public InventorizationException()
Public Sub New
Public Sub New
public:
InventorizationException()
public:
InventorizationException()
new : unit -> InventorizationException
new : unit -> InventorizationException
See Also
InventorizationException Class
InventorizationException Members
InventorizationException Overload
NFX.Inventorization Namespace


InventorizationException Constructor (String)

InventorizationException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the InventorizationException class

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InventorizationException(
    string message
)
public InventorizationException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
InventorizationException(
    String^ message
)
public:
InventorizationException(
    String^ message
)
new :
        message : string -> InventorizationException
new :
        message : string -> InventorizationException

Parameters

message
Type: Online System String
See Also
InventorizationException Class
InventorizationException Members
InventorizationException Overload
NFX.Inventorization Namespace


InventorizationException Constructor (SerializationInfo, StreamingContext)

InventorizationException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the InventorizationException class

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected InventorizationException(
    SerializationInfo info,
    StreamingContext context
)
protected InventorizationException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
InventorizationException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
InventorizationException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> InventorizationException
new :
        info : SerializationInfo *
        context : StreamingContext -> InventorizationException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
InventorizationException Class
InventorizationException Members
InventorizationException Overload
NFX.Inventorization Namespace


InventorizationException Constructor (String, Exception)

InventorizationException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the InventorizationException class

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InventorizationException(
    string message,
    Exception inner
)
public InventorizationException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
InventorizationException(
    String^ message,
    Exception^ inner
)
public:
InventorizationException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> InventorizationException
new :
        message : string *
        inner : Exception -> InventorizationException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
InventorizationException Class
InventorizationException Members
InventorizationException Overload
NFX.Inventorization Namespace


InventorizationException Methods

InventorizationException Methods NFX Class Library

The InventorizationException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
InventorizationException Class
NFX.Inventorization Namespace


InventorizationException Properties

InventorizationException Properties NFX Class Library

The InventorizationException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
InventorizationException Class
NFX.Inventorization Namespace


InventorizationException Events

InventorizationException Events NFX Class Library

The InventorizationException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
InventorizationException Class
NFX.Inventorization Namespace


InventorizationManager Class

InventorizationManager Class NFX Class Library

Performs an inventory scan of supplied assemblies using specified options. Items to be included in result must be tagged with Inventory attribute, otherwise then will be omitted unless OnlyAttributed == false. The scan is performed using options and inventorization strategies. This class is NOT THREAD SAFE
Inheritance Hierarchy
Online System Object
NFX.Inventorization InventorizationManager

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class InventorizationManager
public class InventorizationManager
Public Class InventorizationManager
Public Class InventorizationManager
public ref class InventorizationManager
public ref class InventorizationManager
type InventorizationManager =  class end
type InventorizationManager =  class end
See Also
InventorizationManager Members
NFX.Inventorization Namespace


InventorizationManager Members

InventorizationManager Members NFX Class Library

The InventorizationManager type exposes the following members.
Constructors
 | Name | Description
Public method | InventorizationManager(IEnumerable Assembly ) | Initializes a new instance of the InventorizationManager class
Public method | InventorizationManager(IEnumerable String ) | Initializes a new instance of the InventorizationManager class
Public method | InventorizationManager(String, String) | Delimiter assembly names with ';'
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Run | Runs inventorization routine dumping result into config node
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
 | WriteInventoryAttributes | Adds nodes for InventoryAttributes
 | WriteType | Describes type including generic arguments
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
ATTRIBUTES_NODE |
Back to Top
Properties
 | Name | Description
Public property | Concerns | Imposes a filter on system concerns parameter of Inventory attribute
Public property | EndDate | Imposes a filter on EndDate parameter of Inventory attribute
Public property | OnlyAttributed | When true, inventorizes ONLY items that have have Inventory attribute applied. Even if this property is false but some other inventory filter specified, then an item must be Inventory-tagged to be included
Public property | Options | Options for inventorization strategies
Public property | Schema | Imposes a filter on schema parameter of Inventory attribute
Public property | StartDate | Imposes a filter on StartDate parameter of Inventory attribute
Public property | Strategies | References inventorization strategies
Public property | Technology | Imposes a filter on technology parameter of Inventory attribute
Public property | Tiers | Imposes a filter on system tiers parameter of Inventory attribute
Public property | Tool | Imposes a filter on tool parameter of Inventory attribute
Back to Top
See Also
InventorizationManager Class
NFX.Inventorization Namespace


InventorizationManager Constructor

InventorizationManager Constructor NFX Class Library

Overload List
 | Name | Description
Public method | InventorizationManager(IEnumerable Assembly ) | Initializes a new instance of the InventorizationManager class
Public method | InventorizationManager(IEnumerable String ) | Initializes a new instance of the InventorizationManager class
Public method | InventorizationManager(String, String) | Delimiter assembly names with ';'
Back to Top
See Also
InventorizationManager Class
InventorizationManager Members
NFX.Inventorization Namespace


InventorizationManager Constructor (IEnumerable(Assembly))

InventorizationManager Constructor (IEnumerable Assembly ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the InventorizationManager class

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InventorizationManager(
    IEnumerable<Assembly> assemblies
)
public InventorizationManager(
    IEnumerable<Assembly> assemblies
)
Public Sub New (
    assemblies As IEnumerable(Of Assembly)
)
Public Sub New (
    assemblies As IEnumerable(Of Assembly)
)
public:
InventorizationManager(
    IEnumerable<Assembly^>^ assemblies
)
public:
InventorizationManager(
    IEnumerable<Assembly^>^ assemblies
)
new :
        assemblies : IEnumerable<Assembly> -> InventorizationManager
new :
        assemblies : IEnumerable<Assembly> -> InventorizationManager

Parameters

assemblies
Type: Online System.Collections.Generic IEnumerable Online Assembly
See Also
InventorizationManager Class
InventorizationManager Members
InventorizationManager Overload
NFX.Inventorization Namespace


InventorizationManager Constructor (IEnumerable(String))

InventorizationManager Constructor (IEnumerable String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the InventorizationManager class

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InventorizationManager(
    IEnumerable<string> assemblies
)
public InventorizationManager(
    IEnumerable<string> assemblies
)
Public Sub New (
    assemblies As IEnumerable(Of String)
)
Public Sub New (
    assemblies As IEnumerable(Of String)
)
public:
InventorizationManager(
    IEnumerable<String^>^ assemblies
)
public:
InventorizationManager(
    IEnumerable<String^>^ assemblies
)
new :
        assemblies : IEnumerable<string> -> InventorizationManager
new :
        assemblies : IEnumerable<string> -> InventorizationManager

Parameters

assemblies
Type: Online System.Collections.Generic IEnumerable Online String
See Also
InventorizationManager Class
InventorizationManager Members
InventorizationManager Overload
NFX.Inventorization Namespace


InventorizationManager Constructor (String, String)

InventorizationManager Constructor (String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Delimiter assembly names with ';'

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InventorizationManager(
    string assemblies,
    string path = null
)
public InventorizationManager(
    string assemblies,
    string path = null
)
Public Sub New (
    assemblies As String,
    Optional path As String = Nothing
)
Public Sub New (
    assemblies As String,
    Optional path As String = Nothing
)
public:
InventorizationManager(
    String^ assemblies,
    String^ path = nullptr
)
public:
InventorizationManager(
    String^ assemblies,
    String^ path = nullptr
)
new :
        assemblies : string *
        ?path : string
(* Defaults:
        let _path = defaultArg path null
*)
-> InventorizationManager
new :
        assemblies : string *
        ?path : string
(* Defaults:
        let _path = defaultArg path null
*)
-> InventorizationManager

Parameters

assemblies
Type: Online System String
path (Optional)
Type: Online System String
See Also
InventorizationManager Class
InventorizationManager Members
InventorizationManager Overload
NFX.Inventorization Namespace


InventorizationManager Fields

InventorizationManager Fields NFX Class Library

The InventorizationManager type exposes the following members.
Fields
Name | Description
ATTRIBUTES_NODE |
Back to Top
See Also
InventorizationManager Class
NFX.Inventorization Namespace


InventorizationManager.ATTRIBUTES_NODE Field

InventorizationManager ATTRIBUTES_NODE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ATTRIBUTES_NODE
public const string ATTRIBUTES_NODE
Public Const ATTRIBUTES_NODE As String
Public Const ATTRIBUTES_NODE As String
public:
literal String^ ATTRIBUTES_NODE
public:
literal String^ ATTRIBUTES_NODE
static val mutable ATTRIBUTES_NODE: string
static val mutable ATTRIBUTES_NODE: string

Field Value

Type: Online String
See Also
InventorizationManager Class
InventorizationManager Members
NFX.Inventorization Namespace


InventorizationManager Methods

InventorizationManager Methods NFX Class Library

The InventorizationManager type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Run | Runs inventorization routine dumping result into config node
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
 | WriteInventoryAttributes | Adds nodes for InventoryAttributes
 | WriteType | Describes type including generic arguments
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
InventorizationManager Class
NFX.Inventorization Namespace


InventorizationManager.Run Method

InventorizationManager Run Method NFX Class Library

Runs inventorization routine dumping result into config node

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Run(
    ConfigSectionNode root
)
public void Run(
    ConfigSectionNode root
)
Public Sub Run (
    root As ConfigSectionNode
)
Public Sub Run (
    root As ConfigSectionNode
)
public:
void Run(
    ConfigSectionNode^ root
)
public:
void Run(
    ConfigSectionNode^ root
)
member Run :
        root : ConfigSectionNode -> unit
member Run :
        root : ConfigSectionNode -> unit

Parameters

root
Type: NFX.Environment ConfigSectionNode
See Also
InventorizationManager Class
InventorizationManager Members
NFX.Inventorization Namespace


InventorizationManager.WriteInventoryAttributes Method

InventorizationManager WriteInventoryAttributes Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Adds nodes for InventoryAttributes

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteInventoryAttributes(
    IEnumerable<InventoryAttribute> attrs,
    ConfigSectionNode root
)
public static void WriteInventoryAttributes(
    IEnumerable<InventoryAttribute> attrs,
    ConfigSectionNode root
)
Public Shared Sub WriteInventoryAttributes (
    attrs As IEnumerable(Of InventoryAttribute),
    root As ConfigSectionNode
)
Public Shared Sub WriteInventoryAttributes (
    attrs As IEnumerable(Of InventoryAttribute),
    root As ConfigSectionNode
)
public:
static void WriteInventoryAttributes(
    IEnumerable<InventoryAttribute^>^ attrs,
    ConfigSectionNode^ root
)
public:
static void WriteInventoryAttributes(
    IEnumerable<InventoryAttribute^>^ attrs,
    ConfigSectionNode^ root
)
static member WriteInventoryAttributes :
        attrs : IEnumerable<InventoryAttribute> *
        root : ConfigSectionNode -> unit
static member WriteInventoryAttributes :
        attrs : IEnumerable<InventoryAttribute> *
        root : ConfigSectionNode -> unit

Parameters

attrs
Type: Online System.Collections.Generic IEnumerable InventoryAttribute
root
Type: NFX.Environment ConfigSectionNode
See Also
InventorizationManager Class
InventorizationManager Members
NFX.Inventorization Namespace


InventorizationManager.WriteType Method

InventorizationManager WriteType Method NFX Class Library

Describes type including generic arguments

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteType(
    Type t,
    ConfigSectionNode node
)
public static void WriteType(
    Type t,
    ConfigSectionNode node
)
Public Shared Sub WriteType (
    t As Type,
    node As ConfigSectionNode
)
Public Shared Sub WriteType (
    t As Type,
    node As ConfigSectionNode
)
public:
static void WriteType(
    Type^ t,
    ConfigSectionNode^ node
)
public:
static void WriteType(
    Type^ t,
    ConfigSectionNode^ node
)
static member WriteType :
        t : Type *
        node : ConfigSectionNode -> unit
static member WriteType :
        t : Type *
        node : ConfigSectionNode -> unit

Parameters

t
Type: Online System Type
node
Type: NFX.Environment ConfigSectionNode
See Also
InventorizationManager Class
InventorizationManager Members
NFX.Inventorization Namespace


InventorizationManager Properties

InventorizationManager Properties NFX Class Library

The InventorizationManager type exposes the following members.
Properties
 | Name | Description
Public property | Concerns | Imposes a filter on system concerns parameter of Inventory attribute
Public property | EndDate | Imposes a filter on EndDate parameter of Inventory attribute
Public property | OnlyAttributed | When true, inventorizes ONLY items that have have Inventory attribute applied. Even if this property is false but some other inventory filter specified, then an item must be Inventory-tagged to be included
Public property | Options | Options for inventorization strategies
Public property | Schema | Imposes a filter on schema parameter of Inventory attribute
Public property | StartDate | Imposes a filter on StartDate parameter of Inventory attribute
Public property | Strategies | References inventorization strategies
Public property | Technology | Imposes a filter on technology parameter of Inventory attribute
Public property | Tiers | Imposes a filter on system tiers parameter of Inventory attribute
Public property | Tool | Imposes a filter on tool parameter of Inventory attribute
Back to Top
See Also
InventorizationManager Class
NFX.Inventorization Namespace


InventorizationManager.Concerns Property

InventorizationManager Concerns Property NFX Class Library

Imposes a filter on system concerns parameter of Inventory attribute

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$concerns")]
public Nullable<SystemConcerns> Concerns { get; set; }
[ConfigAttribute("$concerns")]
public Nullable<SystemConcerns> Concerns { get; set; }
<ConfigAttribute("$concerns")>
Public Property Concerns As Nullable(Of SystemConcerns)
    Get
    Set
<ConfigAttribute("$concerns")>
Public Property Concerns As Nullable(Of SystemConcerns)
    Get
    Set
public:
[ConfigAttribute(L"$concerns")]
property Nullable<SystemConcerns> Concerns {
    Nullable<SystemConcerns> get ();
    void set (Nullable<SystemConcerns> value);
}
public:
[ConfigAttribute(L"$concerns")]
property Nullable<SystemConcerns> Concerns {
    Nullable<SystemConcerns> get ();
    void set (Nullable<SystemConcerns> value);
}
[<ConfigAttribute("$concerns")>]
member Concerns : Nullable<SystemConcerns> with get, set
[<ConfigAttribute("$concerns")>]
member Concerns : Nullable<SystemConcerns> with get, set

Property Value

Type: Online Nullable SystemConcerns
See Also
InventorizationManager Class
InventorizationManager Members
NFX.Inventorization Namespace


InventorizationManager.EndDate Property

InventorizationManager EndDate Property NFX Class Library

Imposes a filter on EndDate parameter of Inventory attribute

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$enddate")]
public Nullable<DateTime> EndDate { get; set; }
[ConfigAttribute("$enddate")]
public Nullable<DateTime> EndDate { get; set; }
<ConfigAttribute("$enddate")>
Public Property EndDate As Nullable(Of DateTime)
    Get
    Set
<ConfigAttribute("$enddate")>
Public Property EndDate As Nullable(Of DateTime)
    Get
    Set
public:
[ConfigAttribute(L"$enddate")]
property Nullable<DateTime> EndDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
public:
[ConfigAttribute(L"$enddate")]
property Nullable<DateTime> EndDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
[<ConfigAttribute("$enddate")>]
member EndDate : Nullable<DateTime> with get, set
[<ConfigAttribute("$enddate")>]
member EndDate : Nullable<DateTime> with get, set

Property Value

Type: Online Nullable Online DateTime
See Also
InventorizationManager Class
InventorizationManager Members
NFX.Inventorization Namespace


InventorizationManager.OnlyAttributed Property

InventorizationManager OnlyAttributed Property NFX Class Library

[This is preliminary documentation and is subject to change.]

When true, inventorizes ONLY items that have have Inventory attribute applied. Even if this property is false but some other inventory filter specified, then an item must be Inventory-tagged to be included

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$attributed", Default = true)]
public bool OnlyAttributed { get; set; }
[ConfigAttribute("$attributed", Default = true)]
public bool OnlyAttributed { get; set; }
<ConfigAttribute("$attributed", Default := true)>
Public Property OnlyAttributed As Boolean
    Get
    Set
<ConfigAttribute("$attributed", Default := true)>
Public Property OnlyAttributed As Boolean
    Get
    Set
public:
[ConfigAttribute(L"$attributed", Default = true)]
property bool OnlyAttributed {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute(L"$attributed", Default = true)]
property bool OnlyAttributed {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute("$attributed", Default = true)>]
member OnlyAttributed : bool with get, set
[<ConfigAttribute("$attributed", Default = true)>]
member OnlyAttributed : bool with get, set

Property Value

Type: Online Boolean
See Also
InventorizationManager Class
InventorizationManager Members
NFX.Inventorization Namespace


InventorizationManager.Options Property

InventorizationManager Options Property NFX Class Library

Options for inventorization strategies

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IConfigSectionNode Options { get; set; }
public IConfigSectionNode Options { get; set; }
Public Property Options As IConfigSectionNode
    Get
    Set
Public Property Options As IConfigSectionNode
    Get
    Set
public:
property IConfigSectionNode^ Options {
    IConfigSectionNode^ get ();
    void set (IConfigSectionNode^ value);
}
public:
property IConfigSectionNode^ Options {
    IConfigSectionNode^ get ();
    void set (IConfigSectionNode^ value);
}
member Options : IConfigSectionNode with get, set
member Options : IConfigSectionNode with get, set

Property Value

Type: IConfigSectionNode
See Also
InventorizationManager Class
InventorizationManager Members
NFX.Inventorization Namespace


InventorizationManager.Schema Property

InventorizationManager Schema Property NFX Class Library

Imposes a filter on schema parameter of Inventory attribute

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$schema")]
public string Schema { get; set; }
[ConfigAttribute("$schema")]
public string Schema { get; set; }
<ConfigAttribute("$schema")>
Public Property Schema As String
    Get
    Set
<ConfigAttribute("$schema")>
Public Property Schema As String
    Get
    Set
public:
[ConfigAttribute(L"$schema")]
property String^ Schema {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute(L"$schema")]
property String^ Schema {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute("$schema")>]
member Schema : string with get, set
[<ConfigAttribute("$schema")>]
member Schema : string with get, set

Property Value

Type: Online String
See Also
InventorizationManager Class
InventorizationManager Members
NFX.Inventorization Namespace


InventorizationManager.StartDate Property

InventorizationManager StartDate Property NFX Class Library

Imposes a filter on StartDate parameter of Inventory attribute

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$startdate")]
public Nullable<DateTime> StartDate { get; set; }
[ConfigAttribute("$startdate")]
public Nullable<DateTime> StartDate { get; set; }
<ConfigAttribute("$startdate")>
Public Property StartDate As Nullable(Of DateTime)
    Get
    Set
<ConfigAttribute("$startdate")>
Public Property StartDate As Nullable(Of DateTime)
    Get
    Set
public:
[ConfigAttribute(L"$startdate")]
property Nullable<DateTime> StartDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
public:
[ConfigAttribute(L"$startdate")]
property Nullable<DateTime> StartDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
[<ConfigAttribute("$startdate")>]
member StartDate : Nullable<DateTime> with get, set
[<ConfigAttribute("$startdate")>]
member StartDate : Nullable<DateTime> with get, set

Property Value

Type: Online Nullable Online DateTime
See Also
InventorizationManager Class
InventorizationManager Members
NFX.Inventorization Namespace


InventorizationManager.Strategies Property

InventorizationManager Strategies Property NFX Class Library

References inventorization strategies

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Strategies Strategies { get; }
public Strategies Strategies { get; }
Public ReadOnly Property Strategies As Strategies
    Get
Public ReadOnly Property Strategies As Strategies
    Get
public:
property Strategies^ Strategies {
    Strategies^ get ();
}
public:
property Strategies^ Strategies {
    Strategies^ get ();
}
member Strategies : Strategies with get
member Strategies : Strategies with get

Property Value

Type: Strategies
See Also
InventorizationManager Class
InventorizationManager Members
NFX.Inventorization Namespace


InventorizationManager.Technology Property

InventorizationManager Technology Property NFX Class Library

Imposes a filter on technology parameter of Inventory attribute

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$technology")]
public string Technology { get; set; }
[ConfigAttribute("$technology")]
public string Technology { get; set; }
<ConfigAttribute("$technology")>
Public Property Technology As String
    Get
    Set
<ConfigAttribute("$technology")>
Public Property Technology As String
    Get
    Set
public:
[ConfigAttribute(L"$technology")]
property String^ Technology {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute(L"$technology")]
property String^ Technology {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute("$technology")>]
member Technology : string with get, set
[<ConfigAttribute("$technology")>]
member Technology : string with get, set

Property Value

Type: Online String
See Also
InventorizationManager Class
InventorizationManager Members
NFX.Inventorization Namespace


InventorizationManager.Tiers Property

InventorizationManager Tiers Property NFX Class Library

Imposes a filter on system tiers parameter of Inventory attribute

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$tiers")]
public Nullable<SystemTiers> Tiers { get; set; }
[ConfigAttribute("$tiers")]
public Nullable<SystemTiers> Tiers { get; set; }
<ConfigAttribute("$tiers")>
Public Property Tiers As Nullable(Of SystemTiers)
    Get
    Set
<ConfigAttribute("$tiers")>
Public Property Tiers As Nullable(Of SystemTiers)
    Get
    Set
public:
[ConfigAttribute(L"$tiers")]
property Nullable<SystemTiers> Tiers {
    Nullable<SystemTiers> get ();
    void set (Nullable<SystemTiers> value);
}
public:
[ConfigAttribute(L"$tiers")]
property Nullable<SystemTiers> Tiers {
    Nullable<SystemTiers> get ();
    void set (Nullable<SystemTiers> value);
}
[<ConfigAttribute("$tiers")>]
member Tiers : Nullable<SystemTiers> with get, set
[<ConfigAttribute("$tiers")>]
member Tiers : Nullable<SystemTiers> with get, set

Property Value

Type: Online Nullable SystemTiers
See Also
InventorizationManager Class
InventorizationManager Members
NFX.Inventorization Namespace


InventorizationManager.Tool Property

InventorizationManager Tool Property NFX Class Library

Imposes a filter on tool parameter of Inventory attribute

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$tool")]
public string Tool { get; set; }
[ConfigAttribute("$tool")]
public string Tool { get; set; }
<ConfigAttribute("$tool")>
Public Property Tool As String
    Get
    Set
<ConfigAttribute("$tool")>
Public Property Tool As String
    Get
    Set
public:
[ConfigAttribute(L"$tool")]
property String^ Tool {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute(L"$tool")]
property String^ Tool {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute("$tool")>]
member Tool : string with get, set
[<ConfigAttribute("$tool")>]
member Tool : string with get, set

Property Value

Type: Online String
See Also
InventorizationManager Class
InventorizationManager Members
NFX.Inventorization Namespace


InventoryAttribute Class

InventoryAttribute Class NFX Class Library

Defines an inventory-related set of data which is used by automatic code/component discovery such as database schema generation tools and system-global registry servers
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.Inventorization InventoryAttribute

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.All, Inherited = true, AllowMultiple = true)]
public sealed class InventoryAttribute : Attribute
[AttributeUsageAttribute(AttributeTargets.All, Inherited = true, AllowMultiple = true)]
public sealed class InventoryAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.All, Inherited := true, AllowMultiple := true)>
Public NotInheritable Class InventoryAttribute
    Inherits Attribute
<AttributeUsageAttribute(AttributeTargets.All, Inherited := true, AllowMultiple := true)>
Public NotInheritable Class InventoryAttribute
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::All, Inherited = true, AllowMultiple = true)]
public ref class InventoryAttribute sealed : public Attribute
[AttributeUsageAttribute(AttributeTargets::All, Inherited = true, AllowMultiple = true)]
public ref class InventoryAttribute sealed : public Attribute
[<SealedAttribute>]
[<AttributeUsageAttribute(AttributeTargets.All, Inherited = true, AllowMultiple = true)>]
type InventoryAttribute =
    class
        inherit Attribute
    end
[<SealedAttribute>]
[<AttributeUsageAttribute(AttributeTargets.All, Inherited = true, AllowMultiple = true)>]
type InventoryAttribute =
    class
        inherit Attribute
    end
See Also
InventoryAttribute Members
NFX.Inventorization Namespace


InventoryAttribute Members

InventoryAttribute Members NFX Class Library

The InventoryAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | InventoryAttribute | Initializes a new instance of the InventoryAttribute class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Concerns | Indicates what concerns this entry relates to
Public property | EndDate | Provides an optional end date i.e. when this item will be phased out
Public property | Parameters | Parameters for particular inventory entry. This can be used as params for auto-generating tools that scan inventories
Public property | Schema | Provides a name of schema for this item, for example [Inventory(Technology="MongoDB", Schema="UserTransactions")]
Public property | StartDate | Provides an optional start date i.e. when this item will start to be used
Public property | Technology | A type of implementaton that this inventory entry refers to, i.e. "Oracle", "MongoDB", "Riak"
Public property | Tiers | Designates what tier this entry is for
Public property | Tool | Provides an optional name of an applicable tool [Inventory(Tool="ErlangModuleGenerator")]
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
InventoryAttribute Class
NFX.Inventorization Namespace


InventoryAttribute Constructor

InventoryAttribute Constructor NFX Class Library

Initializes a new instance of the InventoryAttribute class

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InventoryAttribute()
public InventoryAttribute()
Public Sub New
Public Sub New
public:
InventoryAttribute()
public:
InventoryAttribute()
new : unit -> InventoryAttribute
new : unit -> InventoryAttribute
See Also
InventoryAttribute Class
InventoryAttribute Members
NFX.Inventorization Namespace


InventoryAttribute Methods

InventoryAttribute Methods NFX Class Library

The InventoryAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
InventoryAttribute Class
NFX.Inventorization Namespace


InventoryAttribute Properties

InventoryAttribute Properties NFX Class Library

The InventoryAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Concerns | Indicates what concerns this entry relates to
Public property | EndDate | Provides an optional end date i.e. when this item will be phased out
Public property | Parameters | Parameters for particular inventory entry. This can be used as params for auto-generating tools that scan inventories
Public property | Schema | Provides a name of schema for this item, for example [Inventory(Technology="MongoDB", Schema="UserTransactions")]
Public property | StartDate | Provides an optional start date i.e. when this item will start to be used
Public property | Technology | A type of implementaton that this inventory entry refers to, i.e. "Oracle", "MongoDB", "Riak"
Public property | Tiers | Designates what tier this entry is for
Public property | Tool | Provides an optional name of an applicable tool [Inventory(Tool="ErlangModuleGenerator")]
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
InventoryAttribute Class
NFX.Inventorization Namespace


InventoryAttribute.Concerns Property

InventoryAttribute Concerns Property NFX Class Library

Indicates what concerns this entry relates to

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SystemConcerns Concerns { get; set; }
public SystemConcerns Concerns { get; set; }
Public Property Concerns As SystemConcerns
    Get
    Set
Public Property Concerns As SystemConcerns
    Get
    Set
public:
property SystemConcerns Concerns {
    SystemConcerns get ();
    void set (SystemConcerns value);
}
public:
property SystemConcerns Concerns {
    SystemConcerns get ();
    void set (SystemConcerns value);
}
member Concerns : SystemConcerns with get, set
member Concerns : SystemConcerns with get, set

Property Value

Type: SystemConcerns
See Also
InventoryAttribute Class
InventoryAttribute Members
NFX.Inventorization Namespace


InventoryAttribute.EndDate Property

InventoryAttribute EndDate Property NFX Class Library

Provides an optional end date i.e. when this item will be phased out

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> EndDate { get; set; }
public Nullable<DateTime> EndDate { get; set; }
Public Property EndDate As Nullable(Of DateTime)
    Get
    Set
Public Property EndDate As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> EndDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
public:
property Nullable<DateTime> EndDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member EndDate : Nullable<DateTime> with get, set
member EndDate : Nullable<DateTime> with get, set

Property Value

Type: Online Nullable Online DateTime
See Also
InventoryAttribute Class
InventoryAttribute Members
NFX.Inventorization Namespace


InventoryAttribute.Parameters Property

InventoryAttribute Parameters Property NFX Class Library

Parameters for particular inventory entry. This can be used as params for auto-generating tools that scan inventories

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Parameters { get; set; }
public string Parameters { get; set; }
Public Property Parameters As String
    Get
    Set
Public Property Parameters As String
    Get
    Set
public:
property String^ Parameters {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Parameters {
    String^ get ();
    void set (String^ value);
}
member Parameters : string with get, set
member Parameters : string with get, set

Property Value

Type: Online String
See Also
InventoryAttribute Class
InventoryAttribute Members
NFX.Inventorization Namespace


InventoryAttribute.Schema Property

InventoryAttribute Schema Property NFX Class Library

Provides a name of schema for this item, for example [Inventory(Technology="MongoDB", Schema="UserTransactions")]

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Schema { get; set; }
public string Schema { get; set; }
Public Property Schema As String
    Get
    Set
Public Property Schema As String
    Get
    Set
public:
property String^ Schema {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Schema {
    String^ get ();
    void set (String^ value);
}
member Schema : string with get, set
member Schema : string with get, set

Property Value

Type: Online String
See Also
InventoryAttribute Class
InventoryAttribute Members
NFX.Inventorization Namespace


InventoryAttribute.StartDate Property

InventoryAttribute StartDate Property NFX Class Library

Provides an optional start date i.e. when this item will start to be used

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> StartDate { get; set; }
public Nullable<DateTime> StartDate { get; set; }
Public Property StartDate As Nullable(Of DateTime)
    Get
    Set
Public Property StartDate As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> StartDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
public:
property Nullable<DateTime> StartDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member StartDate : Nullable<DateTime> with get, set
member StartDate : Nullable<DateTime> with get, set

Property Value

Type: Online Nullable Online DateTime
See Also
InventoryAttribute Class
InventoryAttribute Members
NFX.Inventorization Namespace


InventoryAttribute.Technology Property

InventoryAttribute Technology Property NFX Class Library

A type of implementaton that this inventory entry refers to, i.e. "Oracle", "MongoDB", "Riak"

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Technology { get; set; }
public string Technology { get; set; }
Public Property Technology As String
    Get
    Set
Public Property Technology As String
    Get
    Set
public:
property String^ Technology {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Technology {
    String^ get ();
    void set (String^ value);
}
member Technology : string with get, set
member Technology : string with get, set

Property Value

Type: Online String
See Also
InventoryAttribute Class
InventoryAttribute Members
NFX.Inventorization Namespace


InventoryAttribute.Tiers Property

InventoryAttribute Tiers Property NFX Class Library

Designates what tier this entry is for

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SystemTiers Tiers { get; set; }
public SystemTiers Tiers { get; set; }
Public Property Tiers As SystemTiers
    Get
    Set
Public Property Tiers As SystemTiers
    Get
    Set
public:
property SystemTiers Tiers {
    SystemTiers get ();
    void set (SystemTiers value);
}
public:
property SystemTiers Tiers {
    SystemTiers get ();
    void set (SystemTiers value);
}
member Tiers : SystemTiers with get, set
member Tiers : SystemTiers with get, set

Property Value

Type: SystemTiers
See Also
InventoryAttribute Class
InventoryAttribute Members
NFX.Inventorization Namespace


InventoryAttribute.Tool Property

InventoryAttribute Tool Property NFX Class Library

Provides an optional name of an applicable tool [Inventory(Tool="ErlangModuleGenerator")]

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Tool { get; set; }
public string Tool { get; set; }
Public Property Tool As String
    Get
    Set
Public Property Tool As String
    Get
    Set
public:
property String^ Tool {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Tool {
    String^ get ();
    void set (String^ value);
}
member Tool : string with get, set
member Tool : string with get, set

Property Value

Type: Online String
See Also
InventoryAttribute Class
InventoryAttribute Members
NFX.Inventorization Namespace


Strategies Class

Strategies Class NFX Class Library

Defines a list of inventorization strategies
Inheritance Hierarchy
Online System Object
Online System.Collections.Generic List IInventorization
NFX.Inventorization Strategies

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Strategies : List<IInventorization>
public sealed class Strategies : List<IInventorization>
Public NotInheritable Class Strategies
    Inherits List(Of IInventorization)
Public NotInheritable Class Strategies
    Inherits List(Of IInventorization)
public ref class Strategies sealed : public List<IInventorization^>
public ref class Strategies sealed : public List<IInventorization^>
[<SealedAttribute>]
type Strategies =
    class
        inherit List<IInventorization>
    end
[<SealedAttribute>]
type Strategies =
    class
        inherit List<IInventorization>
    end
See Also
Strategies Members
NFX.Inventorization Namespace


Strategies Members

Strategies Members NFX Class Library

The Strategies type exposes the following members.
Constructors
 | Name | Description
Public method | Strategies | Initializes a new instance of the Strategies class
Back to Top
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List IInventorization .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List IInventorization .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List IInventorization .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List IInventorization .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List IInventorization .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List IInventorization .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List IInventorization .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List IInventorization .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List IInventorization .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List IInventorization .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List IInventorization .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List IInventorization .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List IInventorization .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List IInventorization .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List IInventorization .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List IInventorization .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List IInventorization .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List IInventorization .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List IInventorization .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List IInventorization .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List IInventorization .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List IInventorization .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List IInventorization .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List IInventorization .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List IInventorization .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List IInventorization .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List IInventorization .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List IInventorization .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List IInventorization .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List IInventorization .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List IInventorization .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List IInventorization .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List IInventorization .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List IInventorization .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List IInventorization .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List IInventorization .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List IInventorization .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List IInventorization .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List IInventorization .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List IInventorization .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List IInventorization .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List IInventorization .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List IInventorization .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List IInventorization .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List IInventorization .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List IInventorization .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List IInventorization .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List IInventorization .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List IInventorization .)
Back to Top
See Also
Strategies Class
NFX.Inventorization Namespace


Strategies Constructor

Strategies Constructor NFX Class Library

Initializes a new instance of the Strategies class

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Strategies()
public Strategies()
Public Sub New
Public Sub New
public:
Strategies()
public:
Strategies()
new : unit -> Strategies
new : unit -> Strategies
See Also
Strategies Class
Strategies Members
NFX.Inventorization Namespace


Strategies Methods

Strategies Methods NFX Class Library

The Strategies type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List IInventorization .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List IInventorization .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List IInventorization .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List IInventorization .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List IInventorization .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List IInventorization .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List IInventorization .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List IInventorization .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List IInventorization .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List IInventorization .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List IInventorization .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List IInventorization .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List IInventorization .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List IInventorization .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List IInventorization .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List IInventorization .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List IInventorization .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List IInventorization .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List IInventorization .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List IInventorization .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List IInventorization .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List IInventorization .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List IInventorization .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List IInventorization .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List IInventorization .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List IInventorization .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List IInventorization .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List IInventorization .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List IInventorization .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List IInventorization .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List IInventorization .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List IInventorization .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List IInventorization .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List IInventorization .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List IInventorization .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List IInventorization .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List IInventorization .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List IInventorization .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List IInventorization .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List IInventorization .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List IInventorization .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List IInventorization .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List IInventorization .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List IInventorization .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List IInventorization .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List IInventorization .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Strategies Class
NFX.Inventorization Namespace


Strategies Properties

Strategies Properties NFX Class Library

The Strategies type exposes the following members.
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List IInventorization .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List IInventorization .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List IInventorization .)
Back to Top
See Also
Strategies Class
NFX.Inventorization Namespace


SystemConcerns Enumeration

SystemConcerns Enumeration NFX Class Library

Designates item concerns

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[FlagsAttribute]
public enum SystemConcerns
[FlagsAttribute]
public enum SystemConcerns
<FlagsAttribute>
Public Enumeration SystemConcerns
<FlagsAttribute>
Public Enumeration SystemConcerns
[FlagsAttribute]
public enum class SystemConcerns
[FlagsAttribute]
public enum class SystemConcerns
[<FlagsAttribute>]
type SystemConcerns
[<FlagsAttribute>]
type SystemConcerns
Members
Member name | Value | Description
Unspecified | 0 |
Security | 1 |
Development | 2 |
Testing | 4 |
Deployment | 8 |
Release | 16 |
Testability | 32 |
Configuration | 64 |
Performance | 128 |
Maintainability | 256 |
MissionCriticality | 512 |
Licensing | 1024 |
Features | 2048 |
Requirements | 4096 |
Luck | 8192 |
See Also
NFX.Inventorization Namespace


SystemTiers Enumeration

SystemTiers Enumeration NFX Class Library

Designates system architecture tiers

Namespace: NFX.Inventorization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[FlagsAttribute]
public enum SystemTiers
[FlagsAttribute]
public enum SystemTiers
<FlagsAttribute>
Public Enumeration SystemTiers
<FlagsAttribute>
Public Enumeration SystemTiers
[FlagsAttribute]
public enum class SystemTiers
[FlagsAttribute]
public enum class SystemTiers
[<FlagsAttribute>]
type SystemTiers
[<FlagsAttribute>]
type SystemTiers
Members
Member name | Value | Description
Unspecified | 0 |
GUI | 1 |
AppServer | 2 |
DBServer | 4 |
SystemServer | 8 |
NotificationBus | 32 |
All | 47 |
See Also
NFX.Inventorization Namespace


NFX.IO Namespace

NFX.IO Namespace NFX Class Library

Provides various IO-related functions like error correction and efficient binary streamers
Classes
 | Class | Description
Public class | BufferSegmentReadingStream | Implements a read-only stream wrapper around a segment of byte[]. Unlike MemoryStream, this class allows for use of long indexes and reuse the same stream instance with different byte[].
Public class | ConsoleUtils | Provides various console-helper utilities
Public class | LEB128 | Facilitates int64/uint64 LEB128 encode/decode See https://en.wikipedia.org/wiki/LEB128 See http://llvm.org/docs/doxygen/html/LEB128_8h_source.html
Public class | NFXIOException | Base exception thrown by the IO-related classes
Public class | NonClosingStreamWrap | Implements a stream wrapper that does not close/get disposed. This stream is needed for TextWriter defect that always closes stream in its destructor
Public class | ReadingStreamer | Reads primitives from stream
Public class | SlimFormat | A format that writes into binary files in an efficient way using variable-length integers, strings and meta handles. Developers may derive new formats that support custom serialization of their business-related types. This may increase performance dramatically. For example, in a drawing application a new format may derive from SlimFormat to natively serialize Point and PolarPoint structs to yield faster serialization times. NFX.Serialization.Slim.SlimSlimSerializer is capable of SlimFormat-derived format injection, in which case it will automatically discover new types that are directly supported by the format.
Public class | SlimReader | Reads primitives and other supported types from Slim-format stream. Use factory method of SlimFormat instance to create a new instance of SlimReader class
Public class | SlimWriter | Writes primitives and other supported types to Slim-format stream. Use factory method of SlimFormat instance to create a new instance of SlimWriter class
Public class | Streamer | Represents a base for stream readers and writers. Streamer object instances ARE NOT THREAD-safe
Public class | StreamerFormat | Describes a format - apair of readers/writers along with their capabilities - what types format supports natively
Public class | StreamerFormat TReader, TWriter | Describes a format - apair of readers/writers along with their capabilities. Developers may derive new formats that support custom serialization schemes
Public class | WritingStreamer | Writes primitives to stream
Structures
 | Structure | Description
Public structure | MetaHandle | Represents a tuple of an unsigned integer with optional int or string metadata. If metadata is null then integer is stored by itself in an efficient way. The type is useful for storage of handles/indexes (such as pointer surrogates) with optional description of pointed-to data (such as type information). A special case is reserved for strings which are immutable yet reference types, in which case a special handle INLINED_STRING_HANDLE is set to indicate that "Metadata" really contains string data that this handle should resolve into. Check "IsInlinedString" property to see if string was inlined. Check "IsInlinedValueType" is set to true when a struct/valuetype is inlined and "Metadata" contains type spec
Public structure | VarIntStr | Holds either an integer or a string value. This is useful for metadata, i.e. types, if type is known an integer is sent, otherwise a full type name is sent


BufferSegmentReadingStream Class

BufferSegmentReadingStream Class NFX Class Library

Implements a read-only stream wrapper around a segment of byte[]. Unlike MemoryStream, this class allows for use of long indexes and reuse the same stream instance with different byte[].
Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.IO Stream
NFX.IO BufferSegmentReadingStream

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class BufferSegmentReadingStream : Stream
public sealed class BufferSegmentReadingStream : Stream
Public NotInheritable Class BufferSegmentReadingStream
    Inherits Stream
Public NotInheritable Class BufferSegmentReadingStream
    Inherits Stream
public ref class BufferSegmentReadingStream sealed : public Stream
public ref class BufferSegmentReadingStream sealed : public Stream
[<SealedAttribute>]
type BufferSegmentReadingStream =
    class
        inherit Stream
    end
[<SealedAttribute>]
type BufferSegmentReadingStream =
    class
        inherit Stream
    end
See Also
BufferSegmentReadingStream Members
NFX.IO Namespace


BufferSegmentReadingStream Members

BufferSegmentReadingStream Members NFX Class Library

The BufferSegmentReadingStream type exposes the following members.
Constructors
 | Name | Description
Public method | BufferSegmentReadingStream | Initializes a new instance of the BufferSegmentReadingStream class
Back to Top
Methods
 | Name | Description
Public method | Online BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | BindBuffer | Sets byte[] as stream source
Public method | Close | (Overrides Online Stream Close .)
Public method | Online CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Online Stream.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Protected method | Online CreateWaitHandle | Obsolete. Allocates a Online WaitHandle object. (Inherited from Online Stream.)
Public method | Online Dispose | Releases all resources used by the Online Stream. (Inherited from Online Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the BufferSegmentReadingStream and optionally releases the managed resources (Overrides Online Stream Dispose(Boolean).)
Public method | Online EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Overrides Online Stream Flush .)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Online Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Online Stream.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Online Stream.)
Public method | Read | (Overrides Online Stream Read( Byte , Int32, Int32).)
Public method | ReadAsync( Byte , Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Online Stream.)
Public method | ReadAsync( Byte , Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Online Stream.)
Public method | ReadByte | (Overrides Online Stream ReadByte .)
Public method | Seek | (Overrides Online Stream Seek(Int64, SeekOrigin).)
Public method | SetLength | (Overrides Online Stream SetLength(Int64).)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write | (Overrides Online Stream Write( Byte , Int32, Int32).)
Public method | WriteAsync( Byte , Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Online Stream.)
Public method | WriteAsync( Byte , Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Online Stream.)
Public method | Online WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Online Stream.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsCharEnumerable | (Defined by IOMiscUtils.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Public Extension Method | ReadBEInt32 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEShort | Reads a short encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUInt64 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUShort | Reads an ushort encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadSLEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadSLEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | WriteBEInt32 | Writes an integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEShort | Writes a short encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUInt64 | Writes an unsigned long integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUShort | Writes an ushort encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteSLEB128(Int64, Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteSLEB128(Int64, Int32 , Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, UInt32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, Int32 , UInt32) | Overloaded. (Defined by LEB128.)
Back to Top
Properties
 | Name | Description
Public property | Buffer | Target stream that this stream wraps
Public property | CanRead | (Overrides Online Stream CanRead.)
Public property | CanSeek | (Overrides Online Stream CanSeek.)
Public property | Online CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Online Stream.)
Public property | CanWrite | (Overrides Online Stream CanWrite.)
Public property | Length | (Overrides Online Stream Length.)
Public property | Position | (Overrides Online Stream Position.)
Public property | Online ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Online Stream.)
Public property | Online WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Online Stream.)
Back to Top
See Also
BufferSegmentReadingStream Class
NFX.IO Namespace


BufferSegmentReadingStream Constructor

BufferSegmentReadingStream Constructor NFX Class Library

Initializes a new instance of the BufferSegmentReadingStream class

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BufferSegmentReadingStream()
public BufferSegmentReadingStream()
Public Sub New
Public Sub New
public:
BufferSegmentReadingStream()
public:
BufferSegmentReadingStream()
new : unit -> BufferSegmentReadingStream
new : unit -> BufferSegmentReadingStream
See Also
BufferSegmentReadingStream Class
BufferSegmentReadingStream Members
NFX.IO Namespace


BufferSegmentReadingStream Methods

BufferSegmentReadingStream Methods NFX Class Library

The BufferSegmentReadingStream type exposes the following members.
Methods
 | Name | Description
Public method | Online BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | BindBuffer | Sets byte[] as stream source
Public method | Close | (Overrides Online Stream Close .)
Public method | Online CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Online Stream.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Protected method | Online CreateWaitHandle | Obsolete. Allocates a Online WaitHandle object. (Inherited from Online Stream.)
Public method | Online Dispose | Releases all resources used by the Online Stream. (Inherited from Online Stream.)
Protected method | Dispose(Boolean) | (Overrides Online Stream Dispose(Boolean).)
Public method | Online EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Overrides Online Stream Flush .)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Online Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Online Stream.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Online Stream.)
Public method | Read | (Overrides Online Stream Read( Byte , Int32, Int32).)
Public method | ReadAsync( Byte , Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Online Stream.)
Public method | ReadAsync( Byte , Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Online Stream.)
Public method | ReadByte | (Overrides Online Stream ReadByte .)
Public method | Seek | (Overrides Online Stream Seek(Int64, SeekOrigin).)
Public method | SetLength | (Overrides Online Stream SetLength(Int64).)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write | (Overrides Online Stream Write( Byte , Int32, Int32).)
Public method | WriteAsync( Byte , Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Online Stream.)
Public method | WriteAsync( Byte , Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Online Stream.)
Public method | Online WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Online Stream.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsCharEnumerable | (Defined by IOMiscUtils.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Public Extension Method | ReadBEInt32 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEShort | Reads a short encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUInt64 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUShort | Reads an ushort encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadSLEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadSLEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | WriteBEInt32 | Writes an integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEShort | Writes a short encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUInt64 | Writes an unsigned long integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUShort | Writes an ushort encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteSLEB128(Int64, Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteSLEB128(Int64, Int32 , Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, UInt32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, Int32 , UInt32) | Overloaded. (Defined by LEB128.)
Back to Top
See Also
BufferSegmentReadingStream Class
NFX.IO Namespace


BufferSegmentReadingStream.BindBuffer Method

BufferSegmentReadingStream BindBuffer Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Sets byte[] as stream source

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void BindBuffer(
    byte[] buffer,
    long idxStart,
    long count
)
public void BindBuffer(
    byte[] buffer,
    long idxStart,
    long count
)
Public Sub BindBuffer (
    buffer As Byte(),
    idxStart As Long,
    count As Long
)
Public Sub BindBuffer (
    buffer As Byte(),
    idxStart As Long,
    count As Long
)
public:
void BindBuffer(
    array<unsigned char>^ buffer,
    long long idxStart,
    long long count
)
public:
void BindBuffer(
    array<unsigned char>^ buffer,
    long long idxStart,
    long long count
)
member BindBuffer :
        buffer : byte[] *
        idxStart : int64 *
        count : int64 -> unit
member BindBuffer :
        buffer : byte[] *
        idxStart : int64 *
        count : int64 -> unit

Parameters

buffer
Type: Online System Byte
idxStart
Type: Online System Int64
count
Type: Online System Int64
See Also
BufferSegmentReadingStream Class
BufferSegmentReadingStream Members
NFX.IO Namespace


BufferSegmentReadingStream.Close Method

BufferSegmentReadingStream Close Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Close()
public override void Close()
Public Overrides Sub Close
Public Overrides Sub Close
public:
virtual void Close() override
public:
virtual void Close() override
abstract Close : unit -> unit
override Close : unit -> unit
abstract Close : unit -> unit
override Close : unit -> unit
See Also
BufferSegmentReadingStream Class
BufferSegmentReadingStream Members
NFX.IO Namespace


BufferSegmentReadingStream.Dispose Method

BufferSegmentReadingStream Dispose Method NFX Class Library

Overload List
 | Name | Description
Public method | Online Dispose | Releases all resources used by the Online Stream. (Inherited from Online Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the BufferSegmentReadingStream and optionally releases the managed resources (Overrides Online Stream Dispose(Boolean).)
Back to Top
See Also
BufferSegmentReadingStream Class
BufferSegmentReadingStream Members
NFX.IO Namespace


BufferSegmentReadingStream.Dispose Method (Boolean)

BufferSegmentReadingStream Dispose Method (Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Releases the unmanaged resources used by the BufferSegmentReadingStream and optionally releases the managed resources

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
BufferSegmentReadingStream Class
BufferSegmentReadingStream Members
Dispose Overload
NFX.IO Namespace


BufferSegmentReadingStream.Flush Method

BufferSegmentReadingStream Flush Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Flush()
public override void Flush()
Public Overrides Sub Flush
Public Overrides Sub Flush
public:
virtual void Flush() override
public:
virtual void Flush() override
abstract Flush : unit -> unit
override Flush : unit -> unit
abstract Flush : unit -> unit
override Flush : unit -> unit
See Also
BufferSegmentReadingStream Class
BufferSegmentReadingStream Members
NFX.IO Namespace


BufferSegmentReadingStream.Read Method

BufferSegmentReadingStream Read Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int

Parameters

buffer
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32

Return Value

Type: Online Int32
See Also
BufferSegmentReadingStream Class
BufferSegmentReadingStream Members
NFX.IO Namespace


BufferSegmentReadingStream.ReadByte Method

BufferSegmentReadingStream ReadByte Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int ReadByte()
public override int ReadByte()
Public Overrides Function ReadByte As Integer
Public Overrides Function ReadByte As Integer
public:
virtual int ReadByte() override
public:
virtual int ReadByte() override
abstract ReadByte : unit -> int
override ReadByte : unit -> int
abstract ReadByte : unit -> int
override ReadByte : unit -> int

Return Value

Type: Online Int32
See Also
BufferSegmentReadingStream Class
BufferSegmentReadingStream Members
NFX.IO Namespace


BufferSegmentReadingStream.Seek Method

BufferSegmentReadingStream Seek Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long Seek(
    long offset,
    SeekOrigin origin
)
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64

Parameters

offset
Type: Online System Int64
origin
Type: Online System.IO SeekOrigin

Return Value

Type: Online Int64
See Also
BufferSegmentReadingStream Class
BufferSegmentReadingStream Members
NFX.IO Namespace


BufferSegmentReadingStream.SetLength Method

BufferSegmentReadingStream SetLength Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetLength(
    long value
)
public override void SetLength(
    long value
)
Public Overrides Sub SetLength (
    value As Long
)
Public Overrides Sub SetLength (
    value As Long
)
public:
virtual void SetLength(
    long long value
) override
public:
virtual void SetLength(
    long long value
) override
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit

Parameters

value
Type: Online System Int64
See Also
BufferSegmentReadingStream Class
BufferSegmentReadingStream Members
NFX.IO Namespace


BufferSegmentReadingStream.Write Method

BufferSegmentReadingStream Write Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit

Parameters

buffer
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32
See Also
BufferSegmentReadingStream Class
BufferSegmentReadingStream Members
NFX.IO Namespace


BufferSegmentReadingStream Properties

BufferSegmentReadingStream Properties NFX Class Library

The BufferSegmentReadingStream type exposes the following members.
Properties
 | Name | Description
Public property | Buffer | Target stream that this stream wraps
Public property | CanRead | (Overrides Online Stream CanRead.)
Public property | CanSeek | (Overrides Online Stream CanSeek.)
Public property | Online CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Online Stream.)
Public property | CanWrite | (Overrides Online Stream CanWrite.)
Public property | Length | (Overrides Online Stream Length.)
Public property | Position | (Overrides Online Stream Position.)
Public property | Online ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Online Stream.)
Public property | Online WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Online Stream.)
Back to Top
See Also
BufferSegmentReadingStream Class
NFX.IO Namespace


BufferSegmentReadingStream.Buffer Property

BufferSegmentReadingStream Buffer Property NFX Class Library

Target stream that this stream wraps

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] Buffer { get; }
public byte[] Buffer { get; }
Public ReadOnly Property Buffer As Byte()
    Get
Public ReadOnly Property Buffer As Byte()
    Get
public:
property array<unsigned char>^ Buffer {
    array<unsigned char>^ get ();
}
public:
property array<unsigned char>^ Buffer {
    array<unsigned char>^ get ();
}
member Buffer : byte[] with get
member Buffer : byte[] with get

Property Value

Type: Online Byte
See Also
BufferSegmentReadingStream Class
BufferSegmentReadingStream Members
NFX.IO Namespace


BufferSegmentReadingStream.CanRead Property

BufferSegmentReadingStream CanRead Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool CanRead { get; }
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
    Get
Public Overrides ReadOnly Property CanRead As Boolean
    Get
public:
virtual property bool CanRead {
    bool get () override;
}
public:
virtual property bool CanRead {
    bool get () override;
}
abstract CanRead : bool with get
override CanRead : bool with get
abstract CanRead : bool with get
override CanRead : bool with get

Property Value

Type: Online Boolean
See Also
BufferSegmentReadingStream Class
BufferSegmentReadingStream Members
NFX.IO Namespace


BufferSegmentReadingStream.CanSeek Property

BufferSegmentReadingStream CanSeek Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool CanSeek { get; }
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
public:
virtual property bool CanSeek {
    bool get () override;
}
public:
virtual property bool CanSeek {
    bool get () override;
}
abstract CanSeek : bool with get
override CanSeek : bool with get
abstract CanSeek : bool with get
override CanSeek : bool with get

Property Value

Type: Online Boolean
See Also
BufferSegmentReadingStream Class
BufferSegmentReadingStream Members
NFX.IO Namespace


BufferSegmentReadingStream.CanWrite Property

BufferSegmentReadingStream CanWrite Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool CanWrite { get; }
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
public:
virtual property bool CanWrite {
    bool get () override;
}
public:
virtual property bool CanWrite {
    bool get () override;
}
abstract CanWrite : bool with get
override CanWrite : bool with get
abstract CanWrite : bool with get
override CanWrite : bool with get

Property Value

Type: Online Boolean
See Also
BufferSegmentReadingStream Class
BufferSegmentReadingStream Members
NFX.IO Namespace


BufferSegmentReadingStream.Length Property

BufferSegmentReadingStream Length Property NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long Length { get; }
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
    Get
Public Overrides ReadOnly Property Length As Long
    Get
public:
virtual property long long Length {
    long long get () override;
}
public:
virtual property long long Length {
    long long get () override;
}
abstract Length : int64 with get
override Length : int64 with get
abstract Length : int64 with get
override Length : int64 with get

Property Value

Type: Online Int64
See Also
BufferSegmentReadingStream Class
BufferSegmentReadingStream Members
NFX.IO Namespace


BufferSegmentReadingStream.Position Property

BufferSegmentReadingStream Position Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long Position { get; set; }
public override long Position { get; set; }
Public Overrides Property Position As Long
    Get
    Set
Public Overrides Property Position As Long
    Get
    Set
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
abstract Position : int64 with get, set
override Position : int64 with get, set
abstract Position : int64 with get, set
override Position : int64 with get, set

Property Value

Type: Online Int64
See Also
BufferSegmentReadingStream Class
BufferSegmentReadingStream Members
NFX.IO Namespace


ConsoleUtils Class

ConsoleUtils Class NFX Class Library

Provides various console-helper utilities
Inheritance Hierarchy
Online System Object
NFX.IO ConsoleUtils

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class ConsoleUtils
public static class ConsoleUtils
Public NotInheritable Class ConsoleUtils
Public NotInheritable Class ConsoleUtils
public ref class ConsoleUtils abstract sealed
public ref class ConsoleUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ConsoleUtils =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ConsoleUtils =  class end
See Also
ConsoleUtils Members
NFX.IO Namespace


ConsoleUtils Members

ConsoleUtils Members NFX Class Library

The ConsoleUtils type exposes the following members.
Methods
Name | Description
Error | Shows message with colored error header
Info | Shows message with colored info header
ReadPassword | Reads password from console displaying substitute characters instead of real ones
ReadPasswordToSecureBuffer | Reads password from console displaying substitute characters instead of real ones into a sealed SecureBuffer
Warning | Shows message with colored warning header
WriteMarkupContent(String) | Outputs colored text from content supplied in an HTML-like grammar:
WriteMarkupContent(String, Char, Char) | Outputs colored text from content supplied in an HTML-like grammar
WriteMarkupContentAsHTML(String, Encoding, Char, Char, String, String, String, ConsoleColor, ConsoleColor) |
WriteMarkupContentAsHTML(Stream, String, Encoding, Char, Char, String, String, String, ConsoleColor, ConsoleColor) |
WriteMarkupContentAsHTML(TextWriter, String, Encoding, Char, Char, String, String, String, ConsoleColor, ConsoleColor) |
Back to Top
See Also
ConsoleUtils Class
NFX.IO Namespace


ConsoleUtils Methods

ConsoleUtils Methods NFX Class Library

The ConsoleUtils type exposes the following members.
Methods
Name | Description
Error | Shows message with colored error header
Info | Shows message with colored info header
ReadPassword | Reads password from console displaying substitute characters instead of real ones
ReadPasswordToSecureBuffer | Reads password from console displaying substitute characters instead of real ones into a sealed SecureBuffer
Warning | Shows message with colored warning header
WriteMarkupContent(String) | Outputs colored text from content supplied in an HTML-like grammar:
WriteMarkupContent(String, Char, Char) | Outputs colored text from content supplied in an HTML-like grammar
WriteMarkupContentAsHTML(String, Encoding, Char, Char, String, String, String, ConsoleColor, ConsoleColor) |
WriteMarkupContentAsHTML(Stream, String, Encoding, Char, Char, String, String, String, ConsoleColor, ConsoleColor) |
WriteMarkupContentAsHTML(TextWriter, String, Encoding, Char, Char, String, String, String, ConsoleColor, ConsoleColor) |
Back to Top
See Also
ConsoleUtils Class
NFX.IO Namespace


ConsoleUtils.Error Method

ConsoleUtils Error Method NFX Class Library

Shows message with colored error header

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Error(
    string msg,
    int ln = 0
)
public static void Error(
    string msg,
    int ln = 0
)
Public Shared Sub Error (
    msg As String,
    Optional ln As Integer = 0
)
Public Shared Sub Error (
    msg As String,
    Optional ln As Integer = 0
)
public:
static void Error(
    String^ msg,
    int ln = 0
)
public:
static void Error(
    String^ msg,
    int ln = 0
)
static member Error :
        msg : string *
        ?ln : int
(* Defaults:
        let _ln = defaultArg ln 0
*)
-> unit
static member Error :
        msg : string *
        ?ln : int
(* Defaults:
        let _ln = defaultArg ln 0
*)
-> unit

Parameters

msg
Type: Online System String
ln (Optional)
Type: Online System Int32
See Also
ConsoleUtils Class
ConsoleUtils Members
NFX.IO Namespace


ConsoleUtils.Info Method

ConsoleUtils Info Method NFX Class Library

Shows message with colored info header

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Info(
    string msg,
    int ln = 0
)
public static void Info(
    string msg,
    int ln = 0
)
Public Shared Sub Info (
    msg As String,
    Optional ln As Integer = 0
)
Public Shared Sub Info (
    msg As String,
    Optional ln As Integer = 0
)
public:
static void Info(
    String^ msg,
    int ln = 0
)
public:
static void Info(
    String^ msg,
    int ln = 0
)
static member Info :
        msg : string *
        ?ln : int
(* Defaults:
        let _ln = defaultArg ln 0
*)
-> unit
static member Info :
        msg : string *
        ?ln : int
(* Defaults:
        let _ln = defaultArg ln 0
*)
-> unit

Parameters

msg
Type: Online System String
ln (Optional)
Type: Online System Int32
See Also
ConsoleUtils Class
ConsoleUtils Members
NFX.IO Namespace


ConsoleUtils.ReadPassword Method

ConsoleUtils ReadPassword Method NFX Class Library

Reads password from console displaying substitute characters instead of real ones

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ReadPassword(
    char substitute
)
public static string ReadPassword(
    char substitute
)
Public Shared Function ReadPassword (
    substitute As Char
) As String
Public Shared Function ReadPassword (
    substitute As Char
) As String
public:
static String^ ReadPassword(
    wchar_t substitute
)
public:
static String^ ReadPassword(
    wchar_t substitute
)
static member ReadPassword :
        substitute : char -> string
static member ReadPassword :
        substitute : char -> string

Parameters

substitute
Type: Online System Char

Return Value

Type: Online String
See Also
ConsoleUtils Class
ConsoleUtils Members
NFX.IO Namespace


ConsoleUtils.ReadPasswordToSecureBuffer Method

ConsoleUtils ReadPasswordToSecureBuffer Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Reads password from console displaying substitute characters instead of real ones into a sealed SecureBuffer

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static SecureBuffer ReadPasswordToSecureBuffer(
    char substitute
)
public static SecureBuffer ReadPasswordToSecureBuffer(
    char substitute
)
Public Shared Function ReadPasswordToSecureBuffer (
    substitute As Char
) As SecureBuffer
Public Shared Function ReadPasswordToSecureBuffer (
    substitute As Char
) As SecureBuffer
public:
static SecureBuffer^ ReadPasswordToSecureBuffer(
    wchar_t substitute
)
public:
static SecureBuffer^ ReadPasswordToSecureBuffer(
    wchar_t substitute
)
static member ReadPasswordToSecureBuffer :
        substitute : char -> SecureBuffer
static member ReadPasswordToSecureBuffer :
        substitute : char -> SecureBuffer

Parameters

substitute
Type: Online System Char

Return Value

Type: SecureBuffer
See Also
ConsoleUtils Class
ConsoleUtils Members
NFX.IO Namespace


ConsoleUtils.Warning Method

ConsoleUtils Warning Method NFX Class Library

Shows message with colored warning header

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Warning(
    string msg,
    int ln = 0
)
public static void Warning(
    string msg,
    int ln = 0
)
Public Shared Sub Warning (
    msg As String,
    Optional ln As Integer = 0
)
Public Shared Sub Warning (
    msg As String,
    Optional ln As Integer = 0
)
public:
static void Warning(
    String^ msg,
    int ln = 0
)
public:
static void Warning(
    String^ msg,
    int ln = 0
)
static member Warning :
        msg : string *
        ?ln : int
(* Defaults:
        let _ln = defaultArg ln 0
*)
-> unit
static member Warning :
        msg : string *
        ?ln : int
(* Defaults:
        let _ln = defaultArg ln 0
*)
-> unit

Parameters

msg
Type: Online System String
ln (Optional)
Type: Online System Int32
See Also
ConsoleUtils Class
ConsoleUtils Members
NFX.IO Namespace


ConsoleUtils.WriteMarkupContent Method

ConsoleUtils WriteMarkupContent Method NFX Class Library

Overload List
Name | Description
WriteMarkupContent(String) | Outputs colored text from content supplied in an HTML-like grammar:
WriteMarkupContent(String, Char, Char) | Outputs colored text from content supplied in an HTML-like grammar
Back to Top
See Also
ConsoleUtils Class
ConsoleUtils Members
NFX.IO Namespace


ConsoleUtils.WriteMarkupContent Method (String)

ConsoleUtils WriteMarkupContent Method (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Outputs colored text from content supplied in an HTML-like grammar:

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteMarkupContent(
    string content
)
public static void WriteMarkupContent(
    string content
)
Public Shared Sub WriteMarkupContent (
    content As String
)
Public Shared Sub WriteMarkupContent (
    content As String
)
public:
static void WriteMarkupContent(
    String^ content
)
public:
static void WriteMarkupContent(
    String^ content
)
static member WriteMarkupContent :
        content : string -> unit
static member WriteMarkupContent :
        content : string -> unit

Parameters

content
Type: Online System String
See Also
ConsoleUtils Class
ConsoleUtils Members
WriteMarkupContent Overload
NFX.IO Namespace


ConsoleUtils.WriteMarkupContent Method (String, Char, Char)

ConsoleUtils WriteMarkupContent Method (String, Char, Char) NFX Class Library

[This is preliminary documentation and is subject to change.]

Outputs colored text from content supplied in an HTML-like grammar

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteMarkupContent(
    string content,
    char open,
    char close
)
public static void WriteMarkupContent(
    string content,
    char open,
    char close
)
Public Shared Sub WriteMarkupContent (
    content As String,
    open As Char,
    close As Char
)
Public Shared Sub WriteMarkupContent (
    content As String,
    open As Char,
    close As Char
)
public:
static void WriteMarkupContent(
    String^ content,
    wchar_t open,
    wchar_t close
)
public:
static void WriteMarkupContent(
    String^ content,
    wchar_t open,
    wchar_t close
)
static member WriteMarkupContent :
        content : string *
        open : char *
        close : char -> unit
static member WriteMarkupContent :
        content : string *
        open : char *
        close : char -> unit

Parameters

content
Type: Online System String
open
Type: Online System Char
close
Type: Online System Char
See Also
ConsoleUtils Class
ConsoleUtils Members
WriteMarkupContent Overload
NFX.IO Namespace


ConsoleUtils.WriteMarkupContentAsHTML Method

ConsoleUtils WriteMarkupContentAsHTML Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
Name | Description
WriteMarkupContentAsHTML(String, Encoding, Char, Char, String, String, String, ConsoleColor, ConsoleColor) |
WriteMarkupContentAsHTML(Stream, String, Encoding, Char, Char, String, String, String, ConsoleColor, ConsoleColor) |
WriteMarkupContentAsHTML(TextWriter, String, Encoding, Char, Char, String, String, String, ConsoleColor, ConsoleColor) |
Back to Top
See Also
ConsoleUtils Class
ConsoleUtils Members
NFX.IO Namespace


ConsoleUtils.WriteMarkupContentAsHTML Method (String, Encoding, Char, Char, String, String, String, ConsoleColor, ConsoleColor)

ConsoleUtils WriteMarkupContentAsHTML Method (String, Encoding, Char, Char, String, String, String, ConsoleColor, ConsoleColor) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string WriteMarkupContentAsHTML(
    string content,
    Encoding encoding = null,
    char open = '<',
    char close = '>',
    string mkpPRE = "pre",
    string mkpCssForeColorPrefix = "conForeColor_",
    string mkpCssBackColorPrefix = "conBackColor_",
    ConsoleColor defaultForeColor = ConsoleColor.White,
    ConsoleColor defaultBackColor = ConsoleColor.Black
)
public static string WriteMarkupContentAsHTML(
    string content,
    Encoding encoding = null,
    char open = '<',
    char close = '>',
    string mkpPRE = "pre",
    string mkpCssForeColorPrefix = "conForeColor_",
    string mkpCssBackColorPrefix = "conBackColor_",
    ConsoleColor defaultForeColor = ConsoleColor.White,
    ConsoleColor defaultBackColor = ConsoleColor.Black
)
Public Shared Function WriteMarkupContentAsHTML (
    content As String,
    Optional encoding As Encoding = Nothing,
    Optional open As Char = "<"C,
    Optional close As Char = ">"C,
    Optional mkpPRE As String = "pre",
    Optional mkpCssForeColorPrefix As String = "conForeColor_",
    Optional mkpCssBackColorPrefix As String = "conBackColor_",
    Optional defaultForeColor As ConsoleColor = ConsoleColor.White,
    Optional defaultBackColor As ConsoleColor = ConsoleColor.Black
) As String
Public Shared Function WriteMarkupContentAsHTML (
    content As String,
    Optional encoding As Encoding = Nothing,
    Optional open As Char = "<"C,
    Optional close As Char = ">"C,
    Optional mkpPRE As String = "pre",
    Optional mkpCssForeColorPrefix As String = "conForeColor_",
    Optional mkpCssBackColorPrefix As String = "conBackColor_",
    Optional defaultForeColor As ConsoleColor = ConsoleColor.White,
    Optional defaultBackColor As ConsoleColor = ConsoleColor.Black
) As String
public:
static String^ WriteMarkupContentAsHTML(
    String^ content,
    Encoding^ encoding = nullptr,
    wchar_t open = L'<',
    wchar_t close = L'>',
    String^ mkpPRE = L"pre",
    String^ mkpCssForeColorPrefix = L"conForeColor_",
    String^ mkpCssBackColorPrefix = L"conBackColor_",
    ConsoleColor defaultForeColor = ConsoleColor::White,
    ConsoleColor defaultBackColor = ConsoleColor::Black
)
public:
static String^ WriteMarkupContentAsHTML(
    String^ content,
    Encoding^ encoding = nullptr,
    wchar_t open = L'<',
    wchar_t close = L'>',
    String^ mkpPRE = L"pre",
    String^ mkpCssForeColorPrefix = L"conForeColor_",
    String^ mkpCssBackColorPrefix = L"conBackColor_",
    ConsoleColor defaultForeColor = ConsoleColor::White,
    ConsoleColor defaultBackColor = ConsoleColor::Black
)
static member WriteMarkupContentAsHTML :
        content : string *
        ?encoding : Encoding *
        ?open : char *
        ?close : char *
        ?mkpPRE : string *
        ?mkpCssForeColorPrefix : string *
        ?mkpCssBackColorPrefix : string *
        ?defaultForeColor : ConsoleColor *
        ?defaultBackColor : ConsoleColor
(* Defaults:
        let _encoding = defaultArg encoding null
        let _open = defaultArg open '<'
        let _close = defaultArg close '>'
        let _mkpPRE = defaultArg mkpPRE "pre"
        let _mkpCssForeColorPrefix = defaultArg mkpCssForeColorPrefix "conForeColor_"
        let _mkpCssBackColorPrefix = defaultArg mkpCssBackColorPrefix "conBackColor_"
        let _defaultForeColor = defaultArg defaultForeColor ConsoleColor.White
        let _defaultBackColor = defaultArg defaultBackColor ConsoleColor.Black
*)
-> string
static member WriteMarkupContentAsHTML :
        content : string *
        ?encoding : Encoding *
        ?open : char *
        ?close : char *
        ?mkpPRE : string *
        ?mkpCssForeColorPrefix : string *
        ?mkpCssBackColorPrefix : string *
        ?defaultForeColor : ConsoleColor *
        ?defaultBackColor : ConsoleColor
(* Defaults:
        let _encoding = defaultArg encoding null
        let _open = defaultArg open '<'
        let _close = defaultArg close '>'
        let _mkpPRE = defaultArg mkpPRE "pre"
        let _mkpCssForeColorPrefix = defaultArg mkpCssForeColorPrefix "conForeColor_"
        let _mkpCssBackColorPrefix = defaultArg mkpCssBackColorPrefix "conBackColor_"
        let _defaultForeColor = defaultArg defaultForeColor ConsoleColor.White
        let _defaultBackColor = defaultArg defaultBackColor ConsoleColor.Black
*)
-> string

Parameters

content
Type: Online System String
encoding (Optional)
Type: Online System.Text Encoding
open (Optional)
Type: Online System Char
close (Optional)
Type: Online System Char
mkpPRE (Optional)
Type: Online System String
mkpCssForeColorPrefix (Optional)
Type: Online System String
mkpCssBackColorPrefix (Optional)
Type: Online System String
defaultForeColor (Optional)
Type: Online System ConsoleColor
defaultBackColor (Optional)
Type: Online System ConsoleColor

Return Value

Type: Online String
See Also
ConsoleUtils Class
ConsoleUtils Members
WriteMarkupContentAsHTML Overload
NFX.IO Namespace


ConsoleUtils.WriteMarkupContentAsHTML Method (Stream, String, Encoding, Char, Char, String, String, String, ConsoleColor, ConsoleColor)

ConsoleUtils WriteMarkupContentAsHTML Method (Stream, String, Encoding, Char, Char, String, String, String, ConsoleColor, ConsoleColor) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteMarkupContentAsHTML(
    Stream output,
    string content,
    Encoding encoding = null,
    char open = '<',
    char close = '>',
    string mkpPRE = "pre",
    string mkpCssForeColorPrefix = "conForeColor_",
    string mkpCssBackColorPrefix = "conBackColor_",
    ConsoleColor defaultForeColor = ConsoleColor.White,
    ConsoleColor defaultBackColor = ConsoleColor.Black
)
public static void WriteMarkupContentAsHTML(
    Stream output,
    string content,
    Encoding encoding = null,
    char open = '<',
    char close = '>',
    string mkpPRE = "pre",
    string mkpCssForeColorPrefix = "conForeColor_",
    string mkpCssBackColorPrefix = "conBackColor_",
    ConsoleColor defaultForeColor = ConsoleColor.White,
    ConsoleColor defaultBackColor = ConsoleColor.Black
)
Public Shared Sub WriteMarkupContentAsHTML (
    output As Stream,
    content As String,
    Optional encoding As Encoding = Nothing,
    Optional open As Char = "<"C,
    Optional close As Char = ">"C,
    Optional mkpPRE As String = "pre",
    Optional mkpCssForeColorPrefix As String = "conForeColor_",
    Optional mkpCssBackColorPrefix As String = "conBackColor_",
    Optional defaultForeColor As ConsoleColor = ConsoleColor.White,
    Optional defaultBackColor As ConsoleColor = ConsoleColor.Black
)
Public Shared Sub WriteMarkupContentAsHTML (
    output As Stream,
    content As String,
    Optional encoding As Encoding = Nothing,
    Optional open As Char = "<"C,
    Optional close As Char = ">"C,
    Optional mkpPRE As String = "pre",
    Optional mkpCssForeColorPrefix As String = "conForeColor_",
    Optional mkpCssBackColorPrefix As String = "conBackColor_",
    Optional defaultForeColor As ConsoleColor = ConsoleColor.White,
    Optional defaultBackColor As ConsoleColor = ConsoleColor.Black
)
public:
static void WriteMarkupContentAsHTML(
    Stream^ output,
    String^ content,
    Encoding^ encoding = nullptr,
    wchar_t open = L'<',
    wchar_t close = L'>',
    String^ mkpPRE = L"pre",
    String^ mkpCssForeColorPrefix = L"conForeColor_",
    String^ mkpCssBackColorPrefix = L"conBackColor_",
    ConsoleColor defaultForeColor = ConsoleColor::White,
    ConsoleColor defaultBackColor = ConsoleColor::Black
)
public:
static void WriteMarkupContentAsHTML(
    Stream^ output,
    String^ content,
    Encoding^ encoding = nullptr,
    wchar_t open = L'<',
    wchar_t close = L'>',
    String^ mkpPRE = L"pre",
    String^ mkpCssForeColorPrefix = L"conForeColor_",
    String^ mkpCssBackColorPrefix = L"conBackColor_",
    ConsoleColor defaultForeColor = ConsoleColor::White,
    ConsoleColor defaultBackColor = ConsoleColor::Black
)
static member WriteMarkupContentAsHTML :
        output : Stream *
        content : string *
        ?encoding : Encoding *
        ?open : char *
        ?close : char *
        ?mkpPRE : string *
        ?mkpCssForeColorPrefix : string *
        ?mkpCssBackColorPrefix : string *
        ?defaultForeColor : ConsoleColor *
        ?defaultBackColor : ConsoleColor
(* Defaults:
        let _encoding = defaultArg encoding null
        let _open = defaultArg open '<'
        let _close = defaultArg close '>'
        let _mkpPRE = defaultArg mkpPRE "pre"
        let _mkpCssForeColorPrefix = defaultArg mkpCssForeColorPrefix "conForeColor_"
        let _mkpCssBackColorPrefix = defaultArg mkpCssBackColorPrefix "conBackColor_"
        let _defaultForeColor = defaultArg defaultForeColor ConsoleColor.White
        let _defaultBackColor = defaultArg defaultBackColor ConsoleColor.Black
*)
-> unit
static member WriteMarkupContentAsHTML :
        output : Stream *
        content : string *
        ?encoding : Encoding *
        ?open : char *
        ?close : char *
        ?mkpPRE : string *
        ?mkpCssForeColorPrefix : string *
        ?mkpCssBackColorPrefix : string *
        ?defaultForeColor : ConsoleColor *
        ?defaultBackColor : ConsoleColor
(* Defaults:
        let _encoding = defaultArg encoding null
        let _open = defaultArg open '<'
        let _close = defaultArg close '>'
        let _mkpPRE = defaultArg mkpPRE "pre"
        let _mkpCssForeColorPrefix = defaultArg mkpCssForeColorPrefix "conForeColor_"
        let _mkpCssBackColorPrefix = defaultArg mkpCssBackColorPrefix "conBackColor_"
        let _defaultForeColor = defaultArg defaultForeColor ConsoleColor.White
        let _defaultBackColor = defaultArg defaultBackColor ConsoleColor.Black
*)
-> unit

Parameters

output
Type: Online System.IO Stream
content
Type: Online System String
encoding (Optional)
Type: Online System.Text Encoding
open (Optional)
Type: Online System Char
close (Optional)
Type: Online System Char
mkpPRE (Optional)
Type: Online System String
mkpCssForeColorPrefix (Optional)
Type: Online System String
mkpCssBackColorPrefix (Optional)
Type: Online System String
defaultForeColor (Optional)
Type: Online System ConsoleColor
defaultBackColor (Optional)
Type: Online System ConsoleColor
See Also
ConsoleUtils Class
ConsoleUtils Members
WriteMarkupContentAsHTML Overload
NFX.IO Namespace


ConsoleUtils.WriteMarkupContentAsHTML Method (TextWriter, String, Encoding, Char, Char, String, String, String, ConsoleColor, ConsoleColor)

ConsoleUtils WriteMarkupContentAsHTML Method (TextWriter, String, Encoding, Char, Char, String, String, String, ConsoleColor, ConsoleColor) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteMarkupContentAsHTML(
    TextWriter output,
    string content,
    Encoding encoding = null,
    char open = '<',
    char close = '>',
    string mkpPRE = "pre",
    string mkpCssForeColorPrefix = "conForeColor_",
    string mkpCssBackColorPrefix = "conBackColor_",
    ConsoleColor defaultForeColor = ConsoleColor.White,
    ConsoleColor defaultBackColor = ConsoleColor.Black
)
public static void WriteMarkupContentAsHTML(
    TextWriter output,
    string content,
    Encoding encoding = null,
    char open = '<',
    char close = '>',
    string mkpPRE = "pre",
    string mkpCssForeColorPrefix = "conForeColor_",
    string mkpCssBackColorPrefix = "conBackColor_",
    ConsoleColor defaultForeColor = ConsoleColor.White,
    ConsoleColor defaultBackColor = ConsoleColor.Black
)
Public Shared Sub WriteMarkupContentAsHTML (
    output As TextWriter,
    content As String,
    Optional encoding As Encoding = Nothing,
    Optional open As Char = "<"C,
    Optional close As Char = ">"C,
    Optional mkpPRE As String = "pre",
    Optional mkpCssForeColorPrefix As String = "conForeColor_",
    Optional mkpCssBackColorPrefix As String = "conBackColor_",
    Optional defaultForeColor As ConsoleColor = ConsoleColor.White,
    Optional defaultBackColor As ConsoleColor = ConsoleColor.Black
)
Public Shared Sub WriteMarkupContentAsHTML (
    output As TextWriter,
    content As String,
    Optional encoding As Encoding = Nothing,
    Optional open As Char = "<"C,
    Optional close As Char = ">"C,
    Optional mkpPRE As String = "pre",
    Optional mkpCssForeColorPrefix As String = "conForeColor_",
    Optional mkpCssBackColorPrefix As String = "conBackColor_",
    Optional defaultForeColor As ConsoleColor = ConsoleColor.White,
    Optional defaultBackColor As ConsoleColor = ConsoleColor.Black
)
public:
static void WriteMarkupContentAsHTML(
    TextWriter^ output,
    String^ content,
    Encoding^ encoding = nullptr,
    wchar_t open = L'<',
    wchar_t close = L'>',
    String^ mkpPRE = L"pre",
    String^ mkpCssForeColorPrefix = L"conForeColor_",
    String^ mkpCssBackColorPrefix = L"conBackColor_",
    ConsoleColor defaultForeColor = ConsoleColor::White,
    ConsoleColor defaultBackColor = ConsoleColor::Black
)
public:
static void WriteMarkupContentAsHTML(
    TextWriter^ output,
    String^ content,
    Encoding^ encoding = nullptr,
    wchar_t open = L'<',
    wchar_t close = L'>',
    String^ mkpPRE = L"pre",
    String^ mkpCssForeColorPrefix = L"conForeColor_",
    String^ mkpCssBackColorPrefix = L"conBackColor_",
    ConsoleColor defaultForeColor = ConsoleColor::White,
    ConsoleColor defaultBackColor = ConsoleColor::Black
)
static member WriteMarkupContentAsHTML :
        output : TextWriter *
        content : string *
        ?encoding : Encoding *
        ?open : char *
        ?close : char *
        ?mkpPRE : string *
        ?mkpCssForeColorPrefix : string *
        ?mkpCssBackColorPrefix : string *
        ?defaultForeColor : ConsoleColor *
        ?defaultBackColor : ConsoleColor
(* Defaults:
        let _encoding = defaultArg encoding null
        let _open = defaultArg open '<'
        let _close = defaultArg close '>'
        let _mkpPRE = defaultArg mkpPRE "pre"
        let _mkpCssForeColorPrefix = defaultArg mkpCssForeColorPrefix "conForeColor_"
        let _mkpCssBackColorPrefix = defaultArg mkpCssBackColorPrefix "conBackColor_"
        let _defaultForeColor = defaultArg defaultForeColor ConsoleColor.White
        let _defaultBackColor = defaultArg defaultBackColor ConsoleColor.Black
*)
-> unit
static member WriteMarkupContentAsHTML :
        output : TextWriter *
        content : string *
        ?encoding : Encoding *
        ?open : char *
        ?close : char *
        ?mkpPRE : string *
        ?mkpCssForeColorPrefix : string *
        ?mkpCssBackColorPrefix : string *
        ?defaultForeColor : ConsoleColor *
        ?defaultBackColor : ConsoleColor
(* Defaults:
        let _encoding = defaultArg encoding null
        let _open = defaultArg open '<'
        let _close = defaultArg close '>'
        let _mkpPRE = defaultArg mkpPRE "pre"
        let _mkpCssForeColorPrefix = defaultArg mkpCssForeColorPrefix "conForeColor_"
        let _mkpCssBackColorPrefix = defaultArg mkpCssBackColorPrefix "conBackColor_"
        let _defaultForeColor = defaultArg defaultForeColor ConsoleColor.White
        let _defaultBackColor = defaultArg defaultBackColor ConsoleColor.Black
*)
-> unit

Parameters

output
Type: Online System.IO TextWriter
content
Type: Online System String
encoding (Optional)
Type: Online System.Text Encoding
open (Optional)
Type: Online System Char
close (Optional)
Type: Online System Char
mkpPRE (Optional)
Type: Online System String
mkpCssForeColorPrefix (Optional)
Type: Online System String
mkpCssBackColorPrefix (Optional)
Type: Online System String
defaultForeColor (Optional)
Type: Online System ConsoleColor
defaultBackColor (Optional)
Type: Online System ConsoleColor
See Also
ConsoleUtils Class
ConsoleUtils Members
WriteMarkupContentAsHTML Overload
NFX.IO Namespace


LEB128 Class

LEB128 Class NFX Class Library

Facilitates int64/uint64 LEB128 encode/decode See https://en.wikipedia.org/wiki/LEB128 See http://llvm.org/docs/doxygen/html/LEB128_8h_source.html
Inheritance Hierarchy
Online System Object
NFX.IO LEB128

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class LEB128
public static class LEB128
<ExtensionAttribute>
Public NotInheritable Class LEB128
<ExtensionAttribute>
Public NotInheritable Class LEB128
[ExtensionAttribute]
public ref class LEB128 abstract sealed
[ExtensionAttribute]
public ref class LEB128 abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type LEB128 =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type LEB128 =  class end
See Also
LEB128 Members
NFX.IO Namespace


LEB128 Members

LEB128 Members NFX Class Library

Methods
Name | Description
ReadSLEB128(Stream) |
ReadSLEB128( Byte , Int32) |
ReadSLEB128(Stream, Int32 ) |
ReadSLEB128( Byte , Int32 , Int32) |
ReadULEB128(Stream) |
ReadULEB128( Byte , Int32) |
ReadULEB128(Stream, Int32 ) |
ReadULEB128( Byte , Int32 , Int32) |
WriteSLEB128(Stream, Int64, Int32) |
WriteSLEB128( Byte , Int64, Int32, Int32) |
WriteSLEB128(Stream, Int64, Int32 , Int32) |
WriteSLEB128( Byte , Int64, Int32 , Int32, Int32) |
WriteULEB128(Stream, UInt64, UInt32) |
WriteULEB128( Byte , UInt64, Int32, UInt32) |
WriteULEB128(Stream, UInt64, Int32 , UInt32) |
WriteULEB128( Byte , UInt64, Int32 , Int32, UInt32) |
Back to Top
See Also
LEB128 Class
NFX.IO Namespace


LEB128 Methods

LEB128 Methods NFX Class Library

Methods
Name | Description
ReadSLEB128(Stream) |
ReadSLEB128( Byte , Int32) |
ReadSLEB128(Stream, Int32 ) |
ReadSLEB128( Byte , Int32 , Int32) |
ReadULEB128(Stream) |
ReadULEB128( Byte , Int32) |
ReadULEB128(Stream, Int32 ) |
ReadULEB128( Byte , Int32 , Int32) |
WriteSLEB128(Stream, Int64, Int32) |
WriteSLEB128( Byte , Int64, Int32, Int32) |
WriteSLEB128(Stream, Int64, Int32 , Int32) |
WriteSLEB128( Byte , Int64, Int32 , Int32, Int32) |
WriteULEB128(Stream, UInt64, UInt32) |
WriteULEB128( Byte , UInt64, Int32, UInt32) |
WriteULEB128(Stream, UInt64, Int32 , UInt32) |
WriteULEB128( Byte , UInt64, Int32 , Int32, UInt32) |
Back to Top
See Also
LEB128 Class
NFX.IO Namespace


LEB128.ReadSLEB128 Method

LEB128 ReadSLEB128 Method NFX Class Library

Overload List
Name | Description
ReadSLEB128(Stream) |
ReadSLEB128( Byte , Int32) |
ReadSLEB128(Stream, Int32 ) |
ReadSLEB128( Byte , Int32 , Int32) |
Back to Top
See Also
LEB128 Class
LEB128 Members
NFX.IO Namespace


LEB128.ReadSLEB128 Method (Stream)

LEB128 ReadSLEB128 Method (Stream) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long ReadSLEB128(
    this Stream stream
)
public static long ReadSLEB128(
    this Stream stream
)
<ExtensionAttribute>
Public Shared Function ReadSLEB128 (
    stream As Stream
) As Long
<ExtensionAttribute>
Public Shared Function ReadSLEB128 (
    stream As Stream
) As Long
public:
[ExtensionAttribute]
static long long ReadSLEB128(
    Stream^ stream
)
public:
[ExtensionAttribute]
static long long ReadSLEB128(
    Stream^ stream
)
static member ReadSLEB128 :
        stream : Stream -> int64
static member ReadSLEB128 :
        stream : Stream -> int64

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online Int64

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
LEB128 Class
LEB128 Members
ReadSLEB128 Overload
NFX.IO Namespace


LEB128.ReadSLEB128 Method (Byte[], Int32)

LEB128 ReadSLEB128 Method ( Byte , Int32) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long ReadSLEB128(
    this byte[] buf,
    int idxStart = 0
)
public static long ReadSLEB128(
    this byte[] buf,
    int idxStart = 0
)
<ExtensionAttribute>
Public Shared Function ReadSLEB128 (
    buf As Byte(),
    Optional idxStart As Integer = 0
) As Long
<ExtensionAttribute>
Public Shared Function ReadSLEB128 (
    buf As Byte(),
    Optional idxStart As Integer = 0
) As Long
public:
[ExtensionAttribute]
static long long ReadSLEB128(
    array<unsigned char>^ buf,
    int idxStart = 0
)
public:
[ExtensionAttribute]
static long long ReadSLEB128(
    array<unsigned char>^ buf,
    int idxStart = 0
)
static member ReadSLEB128 :
        buf : byte[] *
        ?idxStart : int
(* Defaults:
        let _idxStart = defaultArg idxStart 0
*)
-> int64
static member ReadSLEB128 :
        buf : byte[] *
        ?idxStart : int
(* Defaults:
        let _idxStart = defaultArg idxStart 0
*)
-> int64

Parameters

buf
Type: Online System Byte
idxStart (Optional)
Type: Online System Int32

Return Value

Type: Online Int64

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
LEB128 Class
LEB128 Members
ReadSLEB128 Overload
NFX.IO Namespace


LEB128.ReadSLEB128 Method (Stream, Int32)

LEB128 ReadSLEB128 Method (Stream, Int32 ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long ReadSLEB128(
    this Stream stream,
    out int count
)
public static long ReadSLEB128(
    this Stream stream,
    out int count
)
<ExtensionAttribute>
Public Shared Function ReadSLEB128 (
    stream As Stream,
    <OutAttribute> ByRef count As Integer
) As Long
<ExtensionAttribute>
Public Shared Function ReadSLEB128 (
    stream As Stream,
    <OutAttribute> ByRef count As Integer
) As Long
public:
[ExtensionAttribute]
static long long ReadSLEB128(
    Stream^ stream,
    [OutAttribute] int% count
)
public:
[ExtensionAttribute]
static long long ReadSLEB128(
    Stream^ stream,
    [OutAttribute] int% count
)
static member ReadSLEB128 :
        stream : Stream *
        count : int byref -> int64
static member ReadSLEB128 :
        stream : Stream *
        count : int byref -> int64

Parameters

stream
Type: Online System.IO Stream
count
Type: Online System Int32

Return Value

Type: Online Int64

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
LEB128 Class
LEB128 Members
ReadSLEB128 Overload
NFX.IO Namespace


LEB128.ReadSLEB128 Method (Byte[], Int32, Int32)

LEB128 ReadSLEB128 Method ( Byte , Int32 , Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long ReadSLEB128(
    this byte[] buf,
    out int count,
    int idxStart = 0
)
public static long ReadSLEB128(
    this byte[] buf,
    out int count,
    int idxStart = 0
)
<ExtensionAttribute>
Public Shared Function ReadSLEB128 (
    buf As Byte(),
    <OutAttribute> ByRef count As Integer,
    Optional idxStart As Integer = 0
) As Long
<ExtensionAttribute>
Public Shared Function ReadSLEB128 (
    buf As Byte(),
    <OutAttribute> ByRef count As Integer,
    Optional idxStart As Integer = 0
) As Long
public:
[ExtensionAttribute]
static long long ReadSLEB128(
    array<unsigned char>^ buf,
    [OutAttribute] int% count,
    int idxStart = 0
)
public:
[ExtensionAttribute]
static long long ReadSLEB128(
    array<unsigned char>^ buf,
    [OutAttribute] int% count,
    int idxStart = 0
)
static member ReadSLEB128 :
        buf : byte[] *
        count : int byref *
        ?idxStart : int
(* Defaults:
        let _idxStart = defaultArg idxStart 0
*)
-> int64
static member ReadSLEB128 :
        buf : byte[] *
        count : int byref *
        ?idxStart : int
(* Defaults:
        let _idxStart = defaultArg idxStart 0
*)
-> int64

Parameters

buf
Type: Online System Byte
count
Type: Online System Int32
idxStart (Optional)
Type: Online System Int32

Return Value

Type: Online Int64

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
LEB128 Class
LEB128 Members
ReadSLEB128 Overload
NFX.IO Namespace


LEB128.ReadULEB128 Method

LEB128 ReadULEB128 Method NFX Class Library

Overload List
Name | Description
ReadULEB128(Stream) |
ReadULEB128( Byte , Int32) |
ReadULEB128(Stream, Int32 ) |
ReadULEB128( Byte , Int32 , Int32) |
Back to Top
See Also
LEB128 Class
LEB128 Members
NFX.IO Namespace


LEB128.ReadULEB128 Method (Stream)

LEB128 ReadULEB128 Method (Stream) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ulong ReadULEB128(
    this Stream stream
)
public static ulong ReadULEB128(
    this Stream stream
)
<ExtensionAttribute>
Public Shared Function ReadULEB128 (
    stream As Stream
) As ULong
<ExtensionAttribute>
Public Shared Function ReadULEB128 (
    stream As Stream
) As ULong
public:
[ExtensionAttribute]
static unsigned long long ReadULEB128(
    Stream^ stream
)
public:
[ExtensionAttribute]
static unsigned long long ReadULEB128(
    Stream^ stream
)
static member ReadULEB128 :
        stream : Stream -> uint64
static member ReadULEB128 :
        stream : Stream -> uint64

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online UInt64

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
LEB128 Class
LEB128 Members
ReadULEB128 Overload
NFX.IO Namespace


LEB128.ReadULEB128 Method (Byte[], Int32)

LEB128 ReadULEB128 Method ( Byte , Int32) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ulong ReadULEB128(
    this byte[] buf,
    int idxStart = 0
)
public static ulong ReadULEB128(
    this byte[] buf,
    int idxStart = 0
)
<ExtensionAttribute>
Public Shared Function ReadULEB128 (
    buf As Byte(),
    Optional idxStart As Integer = 0
) As ULong
<ExtensionAttribute>
Public Shared Function ReadULEB128 (
    buf As Byte(),
    Optional idxStart As Integer = 0
) As ULong
public:
[ExtensionAttribute]
static unsigned long long ReadULEB128(
    array<unsigned char>^ buf,
    int idxStart = 0
)
public:
[ExtensionAttribute]
static unsigned long long ReadULEB128(
    array<unsigned char>^ buf,
    int idxStart = 0
)
static member ReadULEB128 :
        buf : byte[] *
        ?idxStart : int
(* Defaults:
        let _idxStart = defaultArg idxStart 0
*)
-> uint64
static member ReadULEB128 :
        buf : byte[] *
        ?idxStart : int
(* Defaults:
        let _idxStart = defaultArg idxStart 0
*)
-> uint64

Parameters

buf
Type: Online System Byte
idxStart (Optional)
Type: Online System Int32

Return Value

Type: Online UInt64

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
LEB128 Class
LEB128 Members
ReadULEB128 Overload
NFX.IO Namespace


LEB128.ReadULEB128 Method (Stream, Int32)

LEB128 ReadULEB128 Method (Stream, Int32 ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ulong ReadULEB128(
    this Stream stream,
    out int count
)
public static ulong ReadULEB128(
    this Stream stream,
    out int count
)
<ExtensionAttribute>
Public Shared Function ReadULEB128 (
    stream As Stream,
    <OutAttribute> ByRef count As Integer
) As ULong
<ExtensionAttribute>
Public Shared Function ReadULEB128 (
    stream As Stream,
    <OutAttribute> ByRef count As Integer
) As ULong
public:
[ExtensionAttribute]
static unsigned long long ReadULEB128(
    Stream^ stream,
    [OutAttribute] int% count
)
public:
[ExtensionAttribute]
static unsigned long long ReadULEB128(
    Stream^ stream,
    [OutAttribute] int% count
)
static member ReadULEB128 :
        stream : Stream *
        count : int byref -> uint64
static member ReadULEB128 :
        stream : Stream *
        count : int byref -> uint64

Parameters

stream
Type: Online System.IO Stream
count
Type: Online System Int32

Return Value

Type: Online UInt64

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
LEB128 Class
LEB128 Members
ReadULEB128 Overload
NFX.IO Namespace


LEB128.ReadULEB128 Method (Byte[], Int32, Int32)

LEB128 ReadULEB128 Method ( Byte , Int32 , Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ulong ReadULEB128(
    this byte[] buf,
    out int count,
    int idxStart = 0
)
public static ulong ReadULEB128(
    this byte[] buf,
    out int count,
    int idxStart = 0
)
<ExtensionAttribute>
Public Shared Function ReadULEB128 (
    buf As Byte(),
    <OutAttribute> ByRef count As Integer,
    Optional idxStart As Integer = 0
) As ULong
<ExtensionAttribute>
Public Shared Function ReadULEB128 (
    buf As Byte(),
    <OutAttribute> ByRef count As Integer,
    Optional idxStart As Integer = 0
) As ULong
public:
[ExtensionAttribute]
static unsigned long long ReadULEB128(
    array<unsigned char>^ buf,
    [OutAttribute] int% count,
    int idxStart = 0
)
public:
[ExtensionAttribute]
static unsigned long long ReadULEB128(
    array<unsigned char>^ buf,
    [OutAttribute] int% count,
    int idxStart = 0
)
static member ReadULEB128 :
        buf : byte[] *
        count : int byref *
        ?idxStart : int
(* Defaults:
        let _idxStart = defaultArg idxStart 0
*)
-> uint64
static member ReadULEB128 :
        buf : byte[] *
        count : int byref *
        ?idxStart : int
(* Defaults:
        let _idxStart = defaultArg idxStart 0
*)
-> uint64

Parameters

buf
Type: Online System Byte
count
Type: Online System Int32
idxStart (Optional)
Type: Online System Int32

Return Value

Type: Online UInt64

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
LEB128 Class
LEB128 Members
ReadULEB128 Overload
NFX.IO Namespace


LEB128.WriteSLEB128 Method

LEB128 WriteSLEB128 Method NFX Class Library

Overload List
Name | Description
WriteSLEB128(Stream, Int64, Int32) |
WriteSLEB128( Byte , Int64, Int32, Int32) |
WriteSLEB128(Stream, Int64, Int32 , Int32) |
WriteSLEB128( Byte , Int64, Int32 , Int32, Int32) |
Back to Top
See Also
LEB128 Class
LEB128 Members
NFX.IO Namespace


LEB128.WriteSLEB128 Method (Stream, Int64, Int32)

LEB128 WriteSLEB128 Method (Stream, Int64, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteSLEB128(
    this Stream stream,
    long value,
    int padding = 0
)
public static void WriteSLEB128(
    this Stream stream,
    long value,
    int padding = 0
)
<ExtensionAttribute>
Public Shared Sub WriteSLEB128 (
    stream As Stream,
    value As Long,
    Optional padding As Integer = 0
)
<ExtensionAttribute>
Public Shared Sub WriteSLEB128 (
    stream As Stream,
    value As Long,
    Optional padding As Integer = 0
)
public:
[ExtensionAttribute]
static void WriteSLEB128(
    Stream^ stream,
    long long value,
    int padding = 0
)
public:
[ExtensionAttribute]
static void WriteSLEB128(
    Stream^ stream,
    long long value,
    int padding = 0
)
static member WriteSLEB128 :
        stream : Stream *
        value : int64 *
        ?padding : int
(* Defaults:
        let _padding = defaultArg padding 0
*)
-> unit
static member WriteSLEB128 :
        stream : Stream *
        value : int64 *
        ?padding : int
(* Defaults:
        let _padding = defaultArg padding 0
*)
-> unit

Parameters

stream
Type: Online System.IO Stream
value
Type: Online System Int64
padding (Optional)
Type: Online System Int32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
LEB128 Class
LEB128 Members
WriteSLEB128 Overload
NFX.IO Namespace


LEB128.WriteSLEB128 Method (Byte[], Int64, Int32, Int32)

LEB128 WriteSLEB128 Method ( Byte , Int64, Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteSLEB128(
    this byte[] buf,
    long value,
    int idxStart = 0,
    int padding = 0
)
public static void WriteSLEB128(
    this byte[] buf,
    long value,
    int idxStart = 0,
    int padding = 0
)
<ExtensionAttribute>
Public Shared Sub WriteSLEB128 (
    buf As Byte(),
    value As Long,
    Optional idxStart As Integer = 0,
    Optional padding As Integer = 0
)
<ExtensionAttribute>
Public Shared Sub WriteSLEB128 (
    buf As Byte(),
    value As Long,
    Optional idxStart As Integer = 0,
    Optional padding As Integer = 0
)
public:
[ExtensionAttribute]
static void WriteSLEB128(
    array<unsigned char>^ buf,
    long long value,
    int idxStart = 0,
    int padding = 0
)
public:
[ExtensionAttribute]
static void WriteSLEB128(
    array<unsigned char>^ buf,
    long long value,
    int idxStart = 0,
    int padding = 0
)
static member WriteSLEB128 :
        buf : byte[] *
        value : int64 *
        ?idxStart : int *
        ?padding : int
(* Defaults:
        let _idxStart = defaultArg idxStart 0
        let _padding = defaultArg padding 0
*)
-> unit
static member WriteSLEB128 :
        buf : byte[] *
        value : int64 *
        ?idxStart : int *
        ?padding : int
(* Defaults:
        let _idxStart = defaultArg idxStart 0
        let _padding = defaultArg padding 0
*)
-> unit

Parameters

buf
Type: Online System Byte
value
Type: Online System Int64
idxStart (Optional)
Type: Online System Int32
padding (Optional)
Type: Online System Int32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
LEB128 Class
LEB128 Members
WriteSLEB128 Overload
NFX.IO Namespace


LEB128.WriteSLEB128 Method (Stream, Int64, Int32, Int32)

LEB128 WriteSLEB128 Method (Stream, Int64, Int32 , Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteSLEB128(
    this Stream stream,
    long value,
    out int count,
    int padding = 0
)
public static void WriteSLEB128(
    this Stream stream,
    long value,
    out int count,
    int padding = 0
)
<ExtensionAttribute>
Public Shared Sub WriteSLEB128 (
    stream As Stream,
    value As Long,
    <OutAttribute> ByRef count As Integer,
    Optional padding As Integer = 0
)
<ExtensionAttribute>
Public Shared Sub WriteSLEB128 (
    stream As Stream,
    value As Long,
    <OutAttribute> ByRef count As Integer,
    Optional padding As Integer = 0
)
public:
[ExtensionAttribute]
static void WriteSLEB128(
    Stream^ stream,
    long long value,
    [OutAttribute] int% count,
    int padding = 0
)
public:
[ExtensionAttribute]
static void WriteSLEB128(
    Stream^ stream,
    long long value,
    [OutAttribute] int% count,
    int padding = 0
)
static member WriteSLEB128 :
        stream : Stream *
        value : int64 *
        count : int byref *
        ?padding : int
(* Defaults:
        let _padding = defaultArg padding 0
*)
-> unit
static member WriteSLEB128 :
        stream : Stream *
        value : int64 *
        count : int byref *
        ?padding : int
(* Defaults:
        let _padding = defaultArg padding 0
*)
-> unit

Parameters

stream
Type: Online System.IO Stream
value
Type: Online System Int64
count
Type: Online System Int32
padding (Optional)
Type: Online System Int32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
LEB128 Class
LEB128 Members
WriteSLEB128 Overload
NFX.IO Namespace


LEB128.WriteSLEB128 Method (Byte[], Int64, Int32, Int32, Int32)

LEB128 WriteSLEB128 Method ( Byte , Int64, Int32 , Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteSLEB128(
    this byte[] buf,
    long value,
    out int count,
    int idxStart = 0,
    int padding = 0
)
public static void WriteSLEB128(
    this byte[] buf,
    long value,
    out int count,
    int idxStart = 0,
    int padding = 0
)
<ExtensionAttribute>
Public Shared Sub WriteSLEB128 (
    buf As Byte(),
    value As Long,
    <OutAttribute> ByRef count As Integer,
    Optional idxStart As Integer = 0,
    Optional padding As Integer = 0
)
<ExtensionAttribute>
Public Shared Sub WriteSLEB128 (
    buf As Byte(),
    value As Long,
    <OutAttribute> ByRef count As Integer,
    Optional idxStart As Integer = 0,
    Optional padding As Integer = 0
)
public:
[ExtensionAttribute]
static void WriteSLEB128(
    array<unsigned char>^ buf,
    long long value,
    [OutAttribute] int% count,
    int idxStart = 0,
    int padding = 0
)
public:
[ExtensionAttribute]
static void WriteSLEB128(
    array<unsigned char>^ buf,
    long long value,
    [OutAttribute] int% count,
    int idxStart = 0,
    int padding = 0
)
static member WriteSLEB128 :
        buf : byte[] *
        value : int64 *
        count : int byref *
        ?idxStart : int *
        ?padding : int
(* Defaults:
        let _idxStart = defaultArg idxStart 0
        let _padding = defaultArg padding 0
*)
-> unit
static member WriteSLEB128 :
        buf : byte[] *
        value : int64 *
        count : int byref *
        ?idxStart : int *
        ?padding : int
(* Defaults:
        let _idxStart = defaultArg idxStart 0
        let _padding = defaultArg padding 0
*)
-> unit

Parameters

buf
Type: Online System Byte
value
Type: Online System Int64
count
Type: Online System Int32
idxStart (Optional)
Type: Online System Int32
padding (Optional)
Type: Online System Int32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
LEB128 Class
LEB128 Members
WriteSLEB128 Overload
NFX.IO Namespace


LEB128.WriteULEB128 Method

LEB128 WriteULEB128 Method NFX Class Library

Overload List
Name | Description
WriteULEB128(Stream, UInt64, UInt32) |
WriteULEB128( Byte , UInt64, Int32, UInt32) |
WriteULEB128(Stream, UInt64, Int32 , UInt32) |
WriteULEB128( Byte , UInt64, Int32 , Int32, UInt32) |
Back to Top
See Also
LEB128 Class
LEB128 Members
NFX.IO Namespace


LEB128.WriteULEB128 Method (Stream, UInt64, UInt32)

LEB128 WriteULEB128 Method (Stream, UInt64, UInt32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteULEB128(
    this Stream stream,
    ulong value,
    uint padding = 0
)
public static void WriteULEB128(
    this Stream stream,
    ulong value,
    uint padding = 0
)
<ExtensionAttribute>
Public Shared Sub WriteULEB128 (
    stream As Stream,
    value As ULong,
    Optional padding As UInteger = 0
)
<ExtensionAttribute>
Public Shared Sub WriteULEB128 (
    stream As Stream,
    value As ULong,
    Optional padding As UInteger = 0
)
public:
[ExtensionAttribute]
static void WriteULEB128(
    Stream^ stream,
    unsigned long long value,
    unsigned int padding = 0
)
public:
[ExtensionAttribute]
static void WriteULEB128(
    Stream^ stream,
    unsigned long long value,
    unsigned int padding = 0
)
static member WriteULEB128 :
        stream : Stream *
        value : uint64 *
        ?padding : uint32
(* Defaults:
        let _padding = defaultArg padding 0
*)
-> unit
static member WriteULEB128 :
        stream : Stream *
        value : uint64 *
        ?padding : uint32
(* Defaults:
        let _padding = defaultArg padding 0
*)
-> unit

Parameters

stream
Type: Online System.IO Stream
value
Type: Online System UInt64
padding (Optional)
Type: Online System UInt32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
LEB128 Class
LEB128 Members
WriteULEB128 Overload
NFX.IO Namespace


LEB128.WriteULEB128 Method (Byte[], UInt64, Int32, UInt32)

LEB128 WriteULEB128 Method ( Byte , UInt64, Int32, UInt32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteULEB128(
    this byte[] buf,
    ulong value,
    int idxStart = 0,
    uint padding = 0
)
public static void WriteULEB128(
    this byte[] buf,
    ulong value,
    int idxStart = 0,
    uint padding = 0
)
<ExtensionAttribute>
Public Shared Sub WriteULEB128 (
    buf As Byte(),
    value As ULong,
    Optional idxStart As Integer = 0,
    Optional padding As UInteger = 0
)
<ExtensionAttribute>
Public Shared Sub WriteULEB128 (
    buf As Byte(),
    value As ULong,
    Optional idxStart As Integer = 0,
    Optional padding As UInteger = 0
)
public:
[ExtensionAttribute]
static void WriteULEB128(
    array<unsigned char>^ buf,
    unsigned long long value,
    int idxStart = 0,
    unsigned int padding = 0
)
public:
[ExtensionAttribute]
static void WriteULEB128(
    array<unsigned char>^ buf,
    unsigned long long value,
    int idxStart = 0,
    unsigned int padding = 0
)
static member WriteULEB128 :
        buf : byte[] *
        value : uint64 *
        ?idxStart : int *
        ?padding : uint32
(* Defaults:
        let _idxStart = defaultArg idxStart 0
        let _padding = defaultArg padding 0
*)
-> unit
static member WriteULEB128 :
        buf : byte[] *
        value : uint64 *
        ?idxStart : int *
        ?padding : uint32
(* Defaults:
        let _idxStart = defaultArg idxStart 0
        let _padding = defaultArg padding 0
*)
-> unit

Parameters

buf
Type: Online System Byte
value
Type: Online System UInt64
idxStart (Optional)
Type: Online System Int32
padding (Optional)
Type: Online System UInt32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
LEB128 Class
LEB128 Members
WriteULEB128 Overload
NFX.IO Namespace


LEB128.WriteULEB128 Method (Stream, UInt64, Int32, UInt32)

LEB128 WriteULEB128 Method (Stream, UInt64, Int32 , UInt32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteULEB128(
    this Stream stream,
    ulong value,
    out int count,
    uint padding = 0
)
public static void WriteULEB128(
    this Stream stream,
    ulong value,
    out int count,
    uint padding = 0
)
<ExtensionAttribute>
Public Shared Sub WriteULEB128 (
    stream As Stream,
    value As ULong,
    <OutAttribute> ByRef count As Integer,
    Optional padding As UInteger = 0
)
<ExtensionAttribute>
Public Shared Sub WriteULEB128 (
    stream As Stream,
    value As ULong,
    <OutAttribute> ByRef count As Integer,
    Optional padding As UInteger = 0
)
public:
[ExtensionAttribute]
static void WriteULEB128(
    Stream^ stream,
    unsigned long long value,
    [OutAttribute] int% count,
    unsigned int padding = 0
)
public:
[ExtensionAttribute]
static void WriteULEB128(
    Stream^ stream,
    unsigned long long value,
    [OutAttribute] int% count,
    unsigned int padding = 0
)
static member WriteULEB128 :
        stream : Stream *
        value : uint64 *
        count : int byref *
        ?padding : uint32
(* Defaults:
        let _padding = defaultArg padding 0
*)
-> unit
static member WriteULEB128 :
        stream : Stream *
        value : uint64 *
        count : int byref *
        ?padding : uint32
(* Defaults:
        let _padding = defaultArg padding 0
*)
-> unit

Parameters

stream
Type: Online System.IO Stream
value
Type: Online System UInt64
count
Type: Online System Int32
padding (Optional)
Type: Online System UInt32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
LEB128 Class
LEB128 Members
WriteULEB128 Overload
NFX.IO Namespace


LEB128.WriteULEB128 Method (Byte[], UInt64, Int32, Int32, UInt32)

LEB128 WriteULEB128 Method ( Byte , UInt64, Int32 , Int32, UInt32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteULEB128(
    this byte[] buf,
    ulong value,
    out int count,
    int idxStart = 0,
    uint padding = 0
)
public static void WriteULEB128(
    this byte[] buf,
    ulong value,
    out int count,
    int idxStart = 0,
    uint padding = 0
)
<ExtensionAttribute>
Public Shared Sub WriteULEB128 (
    buf As Byte(),
    value As ULong,
    <OutAttribute> ByRef count As Integer,
    Optional idxStart As Integer = 0,
    Optional padding As UInteger = 0
)
<ExtensionAttribute>
Public Shared Sub WriteULEB128 (
    buf As Byte(),
    value As ULong,
    <OutAttribute> ByRef count As Integer,
    Optional idxStart As Integer = 0,
    Optional padding As UInteger = 0
)
public:
[ExtensionAttribute]
static void WriteULEB128(
    array<unsigned char>^ buf,
    unsigned long long value,
    [OutAttribute] int% count,
    int idxStart = 0,
    unsigned int padding = 0
)
public:
[ExtensionAttribute]
static void WriteULEB128(
    array<unsigned char>^ buf,
    unsigned long long value,
    [OutAttribute] int% count,
    int idxStart = 0,
    unsigned int padding = 0
)
static member WriteULEB128 :
        buf : byte[] *
        value : uint64 *
        count : int byref *
        ?idxStart : int *
        ?padding : uint32
(* Defaults:
        let _idxStart = defaultArg idxStart 0
        let _padding = defaultArg padding 0
*)
-> unit
static member WriteULEB128 :
        buf : byte[] *
        value : uint64 *
        count : int byref *
        ?idxStart : int *
        ?padding : uint32
(* Defaults:
        let _idxStart = defaultArg idxStart 0
        let _padding = defaultArg padding 0
*)
-> unit

Parameters

buf
Type: Online System Byte
value
Type: Online System UInt64
count
Type: Online System Int32
idxStart (Optional)
Type: Online System Int32
padding (Optional)
Type: Online System UInt32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
LEB128 Class
LEB128 Members
WriteULEB128 Overload
NFX.IO Namespace


MetaHandle Structure

MetaHandle Structure NFX Class Library

Represents a tuple of an unsigned integer with optional int or string metadata. If metadata is null then integer is stored by itself in an efficient way. The type is useful for storage of handles/indexes (such as pointer surrogates) with optional description of pointed-to data (such as type information). A special case is reserved for strings which are immutable yet reference types, in which case a special handle INLINED_STRING_HANDLE is set to indicate that "Metadata" really contains string data that this handle should resolve into. Check "IsInlinedString" property to see if string was inlined. Check "IsInlinedValueType" is set to true when a struct/valuetype is inlined and "Metadata" contains type spec

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public struct MetaHandle : IEquatable<MetaHandle>
[SerializableAttribute]
public struct MetaHandle : IEquatable<MetaHandle>
<SerializableAttribute>
Public Structure MetaHandle
    Implements IEquatable(Of MetaHandle)
<SerializableAttribute>
Public Structure MetaHandle
    Implements IEquatable(Of MetaHandle)
[SerializableAttribute]
public value class MetaHandle : IEquatable<MetaHandle>
[SerializableAttribute]
public value class MetaHandle : IEquatable<MetaHandle>
[<SealedAttribute>]
[<SerializableAttribute>]
type MetaHandle =
    struct
        interface IEquatable<MetaHandle>
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type MetaHandle =
    struct
        interface IEquatable<MetaHandle>
    end
See Also
MetaHandle Members
NFX.IO Namespace


MetaHandle Members

MetaHandle Members NFX Class Library

The MetaHandle type exposes the following members.
Constructors
 | Name | Description
Public method | MetaHandle(UInt32) | Initializes a new instance of the MetaHandle class
Public method | MetaHandle(Boolean, UInt32) | Initializes a new instance of the MetaHandle class
Public method | MetaHandle(UInt32, Nullable VarIntStr ) | Initializes a new instance of the MetaHandle class
Protected method | MetaHandle(Boolean, UInt32, Nullable VarIntStr ) | Initializes a new instance of the MetaHandle class
Back to Top
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(MetaHandle) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | InlineRefType | Inlines ref type instead of pointer handle
 | InlineString | Inlines string instance instead of pointer handle
 | InlineTypeValue | Inlines type value instead of pointer handle
 | InlineValueType | Inlines value type instead of pointer handle
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | HANDLE_OFFSET |
 | INLINED_REFTYPE_HANDLE |
 | INLINED_STRING_HANDLE |
 | INLINED_TYPEVAL_HANDLE |
 | INLINED_VALUETYPE_HANDLE |
Protected field | m_Handle |
Back to Top
Properties
 | Name | Description
Public property | Handle | Returns handle value. This value is invalid if special conditions such as inlining are true
Public property | IntMetadata |
Public property | IsInlinedRefType | Indicates whether a reference (reference type) instance is inlined right after this handle and Metadata property contains type. This is used for handling of ref types that are natively supported by streamers
Public property | IsInlinedString | Indicates whether a string instance is inlined in Metadata property
Public property | IsInlinedTypeValue | Indicates whether a reference to TYPE is inlined - that is a Metadata parameter points to the value of type (reference to Type)
Public property | IsInlinedValueType | Indicates whether a struct (value type) instance is inlined right after this handle and Metadata property contains type
Public property | Metadata |
Public property | StringMetadata |
Back to Top
See Also
MetaHandle Structure
NFX.IO Namespace


MetaHandle Constructor

MetaHandle Constructor NFX Class Library

Overload List
 | Name | Description
Public method | MetaHandle(UInt32) | Initializes a new instance of the MetaHandle class
Public method | MetaHandle(Boolean, UInt32) | Initializes a new instance of the MetaHandle class
Public method | MetaHandle(UInt32, Nullable VarIntStr ) | Initializes a new instance of the MetaHandle class
Protected method | MetaHandle(Boolean, UInt32, Nullable VarIntStr ) | Initializes a new instance of the MetaHandle class
Back to Top
See Also
MetaHandle Structure
MetaHandle Members
NFX.IO Namespace


MetaHandle Constructor (UInt32)

MetaHandle Constructor (UInt32) NFX Class Library

Initializes a new instance of the MetaHandle class

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MetaHandle(
    uint handle
)
public MetaHandle(
    uint handle
)
Public Sub New (
    handle As UInteger
)
Public Sub New (
    handle As UInteger
)
public:
MetaHandle(
    unsigned int handle
)
public:
MetaHandle(
    unsigned int handle
)
new :
        handle : uint32 -> MetaHandle
new :
        handle : uint32 -> MetaHandle

Parameters

handle
Type: Online System UInt32
See Also
MetaHandle Structure
MetaHandle Members
MetaHandle Overload
NFX.IO Namespace


MetaHandle Constructor (Boolean, UInt32)

MetaHandle Constructor (Boolean, UInt32) NFX Class Library

Initializes a new instance of the MetaHandle class

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MetaHandle(
    bool serializer,
    uint handle
)
public MetaHandle(
    bool serializer,
    uint handle
)
Public Sub New (
    serializer As Boolean,
    handle As UInteger
)
Public Sub New (
    serializer As Boolean,
    handle As UInteger
)
public:
MetaHandle(
    bool serializer,
    unsigned int handle
)
public:
MetaHandle(
    bool serializer,
    unsigned int handle
)
new :
        serializer : bool *
        handle : uint32 -> MetaHandle
new :
        serializer : bool *
        handle : uint32 -> MetaHandle

Parameters

serializer
Type: Online System Boolean
handle
Type: Online System UInt32
See Also
MetaHandle Structure
MetaHandle Members
MetaHandle Overload
NFX.IO Namespace


MetaHandle Constructor (UInt32, Nullable(VarIntStr))

MetaHandle Constructor (UInt32, Nullable VarIntStr ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MetaHandle class

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MetaHandle(
    uint handle,
    Nullable<VarIntStr> metadata
)
public MetaHandle(
    uint handle,
    Nullable<VarIntStr> metadata
)
Public Sub New (
    handle As UInteger,
    metadata As Nullable(Of VarIntStr)
)
Public Sub New (
    handle As UInteger,
    metadata As Nullable(Of VarIntStr)
)
public:
MetaHandle(
    unsigned int handle,
    Nullable<VarIntStr> metadata
)
public:
MetaHandle(
    unsigned int handle,
    Nullable<VarIntStr> metadata
)
new :
        handle : uint32 *
        metadata : Nullable<VarIntStr> -> MetaHandle
new :
        handle : uint32 *
        metadata : Nullable<VarIntStr> -> MetaHandle

Parameters

handle
Type: Online System UInt32
metadata
Type: Online System Nullable VarIntStr
See Also
MetaHandle Structure
MetaHandle Members
MetaHandle Overload
NFX.IO Namespace


MetaHandle Constructor (Boolean, UInt32, Nullable(VarIntStr))

MetaHandle Constructor (Boolean, UInt32, Nullable VarIntStr ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MetaHandle class

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal MetaHandle(
    bool serializer,
    uint handle,
    Nullable<VarIntStr> metadata
)
internal MetaHandle(
    bool serializer,
    uint handle,
    Nullable<VarIntStr> metadata
)
Friend Sub New (
    serializer As Boolean,
    handle As UInteger,
    metadata As Nullable(Of VarIntStr)
)
Friend Sub New (
    serializer As Boolean,
    handle As UInteger,
    metadata As Nullable(Of VarIntStr)
)
internal:
MetaHandle(
    bool serializer,
    unsigned int handle,
    Nullable<VarIntStr> metadata
)
internal:
MetaHandle(
    bool serializer,
    unsigned int handle,
    Nullable<VarIntStr> metadata
)
new :
        serializer : bool *
        handle : uint32 *
        metadata : Nullable<VarIntStr> -> MetaHandle
new :
        serializer : bool *
        handle : uint32 *
        metadata : Nullable<VarIntStr> -> MetaHandle

Parameters

serializer
Type: Online System Boolean
handle
Type: Online System UInt32
metadata
Type: Online System Nullable VarIntStr
See Also
MetaHandle Structure
MetaHandle Members
MetaHandle Overload
NFX.IO Namespace


MetaHandle Fields

MetaHandle Fields NFX Class Library

The MetaHandle type exposes the following members.
Fields
 | Name | Description
 | HANDLE_OFFSET |
 | INLINED_REFTYPE_HANDLE |
 | INLINED_STRING_HANDLE |
 | INLINED_TYPEVAL_HANDLE |
 | INLINED_VALUETYPE_HANDLE |
Protected field | m_Handle |
Back to Top
See Also
MetaHandle Structure
NFX.IO Namespace


MetaHandle.HANDLE_OFFSET Field

MetaHandle HANDLE_OFFSET Field NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal const uint HANDLE_OFFSET
internal const uint HANDLE_OFFSET
Friend Const HANDLE_OFFSET As UInteger
Friend Const HANDLE_OFFSET As UInteger
internal:
literal unsigned int HANDLE_OFFSET
internal:
literal unsigned int HANDLE_OFFSET
static val mutable internal HANDLE_OFFSET: uint32
static val mutable internal HANDLE_OFFSET: uint32

Field Value

Type: Online UInt32
See Also
MetaHandle Structure
MetaHandle Members
NFX.IO Namespace


MetaHandle.INLINED_REFTYPE_HANDLE Field

MetaHandle INLINED_REFTYPE_HANDLE Field NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal const uint INLINED_REFTYPE_HANDLE
internal const uint INLINED_REFTYPE_HANDLE
Friend Const INLINED_REFTYPE_HANDLE As UInteger
Friend Const INLINED_REFTYPE_HANDLE As UInteger
internal:
literal unsigned int INLINED_REFTYPE_HANDLE
internal:
literal unsigned int INLINED_REFTYPE_HANDLE
static val mutable internal INLINED_REFTYPE_HANDLE: uint32
static val mutable internal INLINED_REFTYPE_HANDLE: uint32

Field Value

Type: Online UInt32
See Also
MetaHandle Structure
MetaHandle Members
NFX.IO Namespace


MetaHandle.INLINED_STRING_HANDLE Field

MetaHandle INLINED_STRING_HANDLE Field NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal const uint INLINED_STRING_HANDLE
internal const uint INLINED_STRING_HANDLE
Friend Const INLINED_STRING_HANDLE As UInteger
Friend Const INLINED_STRING_HANDLE As UInteger
internal:
literal unsigned int INLINED_STRING_HANDLE
internal:
literal unsigned int INLINED_STRING_HANDLE
static val mutable internal INLINED_STRING_HANDLE: uint32
static val mutable internal INLINED_STRING_HANDLE: uint32

Field Value

Type: Online UInt32
See Also
MetaHandle Structure
MetaHandle Members
NFX.IO Namespace


MetaHandle.INLINED_TYPEVAL_HANDLE Field

MetaHandle INLINED_TYPEVAL_HANDLE Field NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal const uint INLINED_TYPEVAL_HANDLE
internal const uint INLINED_TYPEVAL_HANDLE
Friend Const INLINED_TYPEVAL_HANDLE As UInteger
Friend Const INLINED_TYPEVAL_HANDLE As UInteger
internal:
literal unsigned int INLINED_TYPEVAL_HANDLE
internal:
literal unsigned int INLINED_TYPEVAL_HANDLE
static val mutable internal INLINED_TYPEVAL_HANDLE: uint32
static val mutable internal INLINED_TYPEVAL_HANDLE: uint32

Field Value

Type: Online UInt32
See Also
MetaHandle Structure
MetaHandle Members
NFX.IO Namespace


MetaHandle.INLINED_VALUETYPE_HANDLE Field

MetaHandle INLINED_VALUETYPE_HANDLE Field NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal const uint INLINED_VALUETYPE_HANDLE
internal const uint INLINED_VALUETYPE_HANDLE
Friend Const INLINED_VALUETYPE_HANDLE As UInteger
Friend Const INLINED_VALUETYPE_HANDLE As UInteger
internal:
literal unsigned int INLINED_VALUETYPE_HANDLE
internal:
literal unsigned int INLINED_VALUETYPE_HANDLE
static val mutable internal INLINED_VALUETYPE_HANDLE: uint32
static val mutable internal INLINED_VALUETYPE_HANDLE: uint32

Field Value

Type: Online UInt32
See Also
MetaHandle Structure
MetaHandle Members
NFX.IO Namespace


MetaHandle.m_Handle Field

MetaHandle m_Handle Field NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal uint m_Handle
internal uint m_Handle
Friend m_Handle As UInteger
Friend m_Handle As UInteger
internal:
unsigned int m_Handle
internal:
unsigned int m_Handle
val mutable internal m_Handle: uint32
val mutable internal m_Handle: uint32

Field Value

Type: Online UInt32
See Also
MetaHandle Structure
MetaHandle Members
NFX.IO Namespace


MetaHandle Methods

MetaHandle Methods NFX Class Library

The MetaHandle type exposes the following members.
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(MetaHandle) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | InlineRefType | Inlines ref type instead of pointer handle
 | InlineString | Inlines string instance instead of pointer handle
 | InlineTypeValue | Inlines type value instead of pointer handle
 | InlineValueType | Inlines value type instead of pointer handle
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MetaHandle Structure
NFX.IO Namespace


MetaHandle.Equals Method

MetaHandle Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(MetaHandle) |
Back to Top
See Also
MetaHandle Structure
MetaHandle Members
NFX.IO Namespace


MetaHandle.Equals Method (Object)

MetaHandle Equals Method (Object) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
MetaHandle Structure
MetaHandle Members
Equals Overload
NFX.IO Namespace


MetaHandle.Equals Method (MetaHandle)

MetaHandle Equals Method (MetaHandle) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    MetaHandle other
)
public bool Equals(
    MetaHandle other
)
Public Function Equals (
    other As MetaHandle
) As Boolean
Public Function Equals (
    other As MetaHandle
) As Boolean
public:
virtual bool Equals(
    MetaHandle other
) sealed
public:
virtual bool Equals(
    MetaHandle other
) sealed
abstract Equals :
        other : MetaHandle -> bool
override Equals :
        other : MetaHandle -> bool
abstract Equals :
        other : MetaHandle -> bool
override Equals :
        other : MetaHandle -> bool

Parameters

other
Type: NFX.IO MetaHandle

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
MetaHandle Structure
MetaHandle Members
Equals Overload
NFX.IO Namespace


MetaHandle.GetHashCode Method

MetaHandle GetHashCode Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
MetaHandle Structure
MetaHandle Members
NFX.IO Namespace


MetaHandle.InlineRefType Method

MetaHandle InlineRefType Method NFX Class Library

Inlines ref type instead of pointer handle

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static MetaHandle InlineRefType(
    Nullable<VarIntStr> inlinedRefType
)
public static MetaHandle InlineRefType(
    Nullable<VarIntStr> inlinedRefType
)
Public Shared Function InlineRefType (
    inlinedRefType As Nullable(Of VarIntStr)
) As MetaHandle
Public Shared Function InlineRefType (
    inlinedRefType As Nullable(Of VarIntStr)
) As MetaHandle
public:
static MetaHandle InlineRefType(
    Nullable<VarIntStr> inlinedRefType
)
public:
static MetaHandle InlineRefType(
    Nullable<VarIntStr> inlinedRefType
)
static member InlineRefType :
        inlinedRefType : Nullable<VarIntStr> -> MetaHandle
static member InlineRefType :
        inlinedRefType : Nullable<VarIntStr> -> MetaHandle

Parameters

inlinedRefType
Type: Online System Nullable VarIntStr

Return Value

Type: MetaHandle
See Also
MetaHandle Structure
MetaHandle Members
NFX.IO Namespace


MetaHandle.InlineString Method

MetaHandle InlineString Method NFX Class Library

Inlines string instance instead of pointer handle

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static MetaHandle InlineString(
    string inlinedString
)
public static MetaHandle InlineString(
    string inlinedString
)
Public Shared Function InlineString (
    inlinedString As String
) As MetaHandle
Public Shared Function InlineString (
    inlinedString As String
) As MetaHandle
public:
static MetaHandle InlineString(
    String^ inlinedString
)
public:
static MetaHandle InlineString(
    String^ inlinedString
)
static member InlineString :
        inlinedString : string -> MetaHandle
static member InlineString :
        inlinedString : string -> MetaHandle

Parameters

inlinedString
Type: Online System String

Return Value

Type: MetaHandle
See Also
MetaHandle Structure
MetaHandle Members
NFX.IO Namespace


MetaHandle.InlineTypeValue Method

MetaHandle InlineTypeValue Method NFX Class Library

Inlines type value instead of pointer handle

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static MetaHandle InlineTypeValue(
    Nullable<VarIntStr> inlinedTypeValue
)
public static MetaHandle InlineTypeValue(
    Nullable<VarIntStr> inlinedTypeValue
)
Public Shared Function InlineTypeValue (
    inlinedTypeValue As Nullable(Of VarIntStr)
) As MetaHandle
Public Shared Function InlineTypeValue (
    inlinedTypeValue As Nullable(Of VarIntStr)
) As MetaHandle
public:
static MetaHandle InlineTypeValue(
    Nullable<VarIntStr> inlinedTypeValue
)
public:
static MetaHandle InlineTypeValue(
    Nullable<VarIntStr> inlinedTypeValue
)
static member InlineTypeValue :
        inlinedTypeValue : Nullable<VarIntStr> -> MetaHandle
static member InlineTypeValue :
        inlinedTypeValue : Nullable<VarIntStr> -> MetaHandle

Parameters

inlinedTypeValue
Type: Online System Nullable VarIntStr

Return Value

Type: MetaHandle
See Also
MetaHandle Structure
MetaHandle Members
NFX.IO Namespace


MetaHandle.InlineValueType Method

MetaHandle InlineValueType Method NFX Class Library

Inlines value type instead of pointer handle

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static MetaHandle InlineValueType(
    Nullable<VarIntStr> inlinedValueType
)
public static MetaHandle InlineValueType(
    Nullable<VarIntStr> inlinedValueType
)
Public Shared Function InlineValueType (
    inlinedValueType As Nullable(Of VarIntStr)
) As MetaHandle
Public Shared Function InlineValueType (
    inlinedValueType As Nullable(Of VarIntStr)
) As MetaHandle
public:
static MetaHandle InlineValueType(
    Nullable<VarIntStr> inlinedValueType
)
public:
static MetaHandle InlineValueType(
    Nullable<VarIntStr> inlinedValueType
)
static member InlineValueType :
        inlinedValueType : Nullable<VarIntStr> -> MetaHandle
static member InlineValueType :
        inlinedValueType : Nullable<VarIntStr> -> MetaHandle

Parameters

inlinedValueType
Type: Online System Nullable VarIntStr

Return Value

Type: MetaHandle
See Also
MetaHandle Structure
MetaHandle Members
NFX.IO Namespace


MetaHandle.ToString Method

MetaHandle ToString Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
MetaHandle Structure
MetaHandle Members
NFX.IO Namespace


MetaHandle Properties

MetaHandle Properties NFX Class Library

The MetaHandle type exposes the following members.
Properties
 | Name | Description
Public property | Handle | Returns handle value. This value is invalid if special conditions such as inlining are true
Public property | IntMetadata |
Public property | IsInlinedRefType | Indicates whether a reference (reference type) instance is inlined right after this handle and Metadata property contains type. This is used for handling of ref types that are natively supported by streamers
Public property | IsInlinedString | Indicates whether a string instance is inlined in Metadata property
Public property | IsInlinedTypeValue | Indicates whether a reference to TYPE is inlined - that is a Metadata parameter points to the value of type (reference to Type)
Public property | IsInlinedValueType | Indicates whether a struct (value type) instance is inlined right after this handle and Metadata property contains type
Public property | Metadata |
Public property | StringMetadata |
Back to Top
See Also
MetaHandle Structure
NFX.IO Namespace


MetaHandle.Handle Property

MetaHandle Handle Property NFX Class Library

Returns handle value. This value is invalid if special conditions such as inlining are true

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint Handle { get; }
public uint Handle { get; }
Public ReadOnly Property Handle As UInteger
    Get
Public ReadOnly Property Handle As UInteger
    Get
public:
property unsigned int Handle {
    unsigned int get ();
}
public:
property unsigned int Handle {
    unsigned int get ();
}
member Handle : uint32 with get
member Handle : uint32 with get

Property Value

Type: Online UInt32
See Also
MetaHandle Structure
MetaHandle Members
NFX.IO Namespace


MetaHandle.IntMetadata Property

MetaHandle IntMetadata Property NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint IntMetadata { get; }
public uint IntMetadata { get; }
Public ReadOnly Property IntMetadata As UInteger
    Get
Public ReadOnly Property IntMetadata As UInteger
    Get
public:
property unsigned int IntMetadata {
    unsigned int get ();
}
public:
property unsigned int IntMetadata {
    unsigned int get ();
}
member IntMetadata : uint32 with get
member IntMetadata : uint32 with get

Property Value

Type: Online UInt32
See Also
MetaHandle Structure
MetaHandle Members
NFX.IO Namespace


MetaHandle.IsInlinedRefType Property

MetaHandle IsInlinedRefType Property NFX Class Library

Indicates whether a reference (reference type) instance is inlined right after this handle and Metadata property contains type. This is used for handling of ref types that are natively supported by streamers

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsInlinedRefType { get; }
public bool IsInlinedRefType { get; }
Public ReadOnly Property IsInlinedRefType As Boolean
    Get
Public ReadOnly Property IsInlinedRefType As Boolean
    Get
public:
property bool IsInlinedRefType {
    bool get ();
}
public:
property bool IsInlinedRefType {
    bool get ();
}
member IsInlinedRefType : bool with get
member IsInlinedRefType : bool with get

Property Value

Type: Online Boolean
See Also
MetaHandle Structure
MetaHandle Members
NFX.IO Namespace


MetaHandle.IsInlinedString Property

MetaHandle IsInlinedString Property NFX Class Library

Indicates whether a string instance is inlined in Metadata property

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsInlinedString { get; }
public bool IsInlinedString { get; }
Public ReadOnly Property IsInlinedString As Boolean
    Get
Public ReadOnly Property IsInlinedString As Boolean
    Get
public:
property bool IsInlinedString {
    bool get ();
}
public:
property bool IsInlinedString {
    bool get ();
}
member IsInlinedString : bool with get
member IsInlinedString : bool with get

Property Value

Type: Online Boolean
See Also
MetaHandle Structure
MetaHandle Members
NFX.IO Namespace


MetaHandle.IsInlinedTypeValue Property

MetaHandle IsInlinedTypeValue Property NFX Class Library

Indicates whether a reference to TYPE is inlined - that is a Metadata parameter points to the value of type (reference to Type)

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsInlinedTypeValue { get; }
public bool IsInlinedTypeValue { get; }
Public ReadOnly Property IsInlinedTypeValue As Boolean
    Get
Public ReadOnly Property IsInlinedTypeValue As Boolean
    Get
public:
property bool IsInlinedTypeValue {
    bool get ();
}
public:
property bool IsInlinedTypeValue {
    bool get ();
}
member IsInlinedTypeValue : bool with get
member IsInlinedTypeValue : bool with get

Property Value

Type: Online Boolean
See Also
MetaHandle Structure
MetaHandle Members
NFX.IO Namespace


MetaHandle.IsInlinedValueType Property

MetaHandle IsInlinedValueType Property NFX Class Library

Indicates whether a struct (value type) instance is inlined right after this handle and Metadata property contains type

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsInlinedValueType { get; }
public bool IsInlinedValueType { get; }
Public ReadOnly Property IsInlinedValueType As Boolean
    Get
Public ReadOnly Property IsInlinedValueType As Boolean
    Get
public:
property bool IsInlinedValueType {
    bool get ();
}
public:
property bool IsInlinedValueType {
    bool get ();
}
member IsInlinedValueType : bool with get
member IsInlinedValueType : bool with get

Property Value

Type: Online Boolean
See Also
MetaHandle Structure
MetaHandle Members
NFX.IO Namespace


MetaHandle.Metadata Property

MetaHandle Metadata Property NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<VarIntStr> Metadata { get; }
public Nullable<VarIntStr> Metadata { get; }
Public ReadOnly Property Metadata As Nullable(Of VarIntStr)
    Get
Public ReadOnly Property Metadata As Nullable(Of VarIntStr)
    Get
public:
property Nullable<VarIntStr> Metadata {
    Nullable<VarIntStr> get ();
}
public:
property Nullable<VarIntStr> Metadata {
    Nullable<VarIntStr> get ();
}
member Metadata : Nullable<VarIntStr> with get
member Metadata : Nullable<VarIntStr> with get

Property Value

Type: Online Nullable VarIntStr
See Also
MetaHandle Structure
MetaHandle Members
NFX.IO Namespace


MetaHandle.StringMetadata Property

MetaHandle StringMetadata Property NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string StringMetadata { get; }
public string StringMetadata { get; }
Public ReadOnly Property StringMetadata As String
    Get
Public ReadOnly Property StringMetadata As String
    Get
public:
property String^ StringMetadata {
    String^ get ();
}
public:
property String^ StringMetadata {
    String^ get ();
}
member StringMetadata : string with get
member StringMetadata : string with get

Property Value

Type: Online String
See Also
MetaHandle Structure
MetaHandle Members
NFX.IO Namespace


NFXIOException Class

NFXIOException Class NFX Class Library

Base exception thrown by the IO-related classes
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.IO NFXIOException

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class NFXIOException : NFXException
[SerializableAttribute]
public class NFXIOException : NFXException
<SerializableAttribute>
Public Class NFXIOException
    Inherits NFXException
<SerializableAttribute>
Public Class NFXIOException
    Inherits NFXException
[SerializableAttribute]
public ref class NFXIOException : public NFXException
[SerializableAttribute]
public ref class NFXIOException : public NFXException
[<SerializableAttribute>]
type NFXIOException =
    class
        inherit NFXException
    end
[<SerializableAttribute>]
type NFXIOException =
    class
        inherit NFXException
    end
See Also
NFXIOException Members
NFX.IO Namespace


NFXIOException Members

NFXIOException Members NFX Class Library

The NFXIOException type exposes the following members.
Constructors
 | Name | Description
Public method | NFXIOException | Initializes a new instance of the NFXIOException class
Public method | NFXIOException(String) | Initializes a new instance of the NFXIOException class
Protected method | NFXIOException(SerializationInfo, StreamingContext) | Initializes a new instance of the NFXIOException class
Public method | NFXIOException(String, Exception) | Initializes a new instance of the NFXIOException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
NFXIOException Class
NFX.IO Namespace


NFXIOException Constructor

NFXIOException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | NFXIOException | Initializes a new instance of the NFXIOException class
Public method | NFXIOException(String) | Initializes a new instance of the NFXIOException class
Protected method | NFXIOException(SerializationInfo, StreamingContext) | Initializes a new instance of the NFXIOException class
Public method | NFXIOException(String, Exception) | Initializes a new instance of the NFXIOException class
Back to Top
See Also
NFXIOException Class
NFXIOException Members
NFX.IO Namespace


NFXIOException Constructor

NFXIOException Constructor NFX Class Library

Initializes a new instance of the NFXIOException class

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NFXIOException()
public NFXIOException()
Public Sub New
Public Sub New
public:
NFXIOException()
public:
NFXIOException()
new : unit -> NFXIOException
new : unit -> NFXIOException
See Also
NFXIOException Class
NFXIOException Members
NFXIOException Overload
NFX.IO Namespace


NFXIOException Constructor (String)

NFXIOException Constructor (String) NFX Class Library

Initializes a new instance of the NFXIOException class

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NFXIOException(
    string message
)
public NFXIOException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
NFXIOException(
    String^ message
)
public:
NFXIOException(
    String^ message
)
new :
        message : string -> NFXIOException
new :
        message : string -> NFXIOException

Parameters

message
Type: Online System String
See Also
NFXIOException Class
NFXIOException Members
NFXIOException Overload
NFX.IO Namespace


NFXIOException Constructor (SerializationInfo, StreamingContext)

NFXIOException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NFXIOException class

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected NFXIOException(
    SerializationInfo info,
    StreamingContext context
)
protected NFXIOException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
NFXIOException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
NFXIOException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> NFXIOException
new :
        info : SerializationInfo *
        context : StreamingContext -> NFXIOException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
NFXIOException Class
NFXIOException Members
NFXIOException Overload
NFX.IO Namespace


NFXIOException Constructor (String, Exception)

NFXIOException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NFXIOException class

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NFXIOException(
    string message,
    Exception inner
)
public NFXIOException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
NFXIOException(
    String^ message,
    Exception^ inner
)
public:
NFXIOException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> NFXIOException
new :
        message : string *
        inner : Exception -> NFXIOException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
NFXIOException Class
NFXIOException Members
NFXIOException Overload
NFX.IO Namespace


NFXIOException Methods

NFXIOException Methods NFX Class Library

The NFXIOException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
NFXIOException Class
NFX.IO Namespace


NFXIOException Properties

NFXIOException Properties NFX Class Library

The NFXIOException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
NFXIOException Class
NFX.IO Namespace


NFXIOException Events

NFXIOException Events NFX Class Library

The NFXIOException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
NFXIOException Class
NFX.IO Namespace


NonClosingStreamWrap Class

NonClosingStreamWrap Class NFX Class Library

Implements a stream wrapper that does not close/get disposed. This stream is needed for TextWriter defect that always closes stream in its destructor
Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.IO Stream
NFX.IO NonClosingStreamWrap

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class NonClosingStreamWrap : Stream
public sealed class NonClosingStreamWrap : Stream
Public NotInheritable Class NonClosingStreamWrap
    Inherits Stream
Public NotInheritable Class NonClosingStreamWrap
    Inherits Stream
public ref class NonClosingStreamWrap sealed : public Stream
public ref class NonClosingStreamWrap sealed : public Stream
[<SealedAttribute>]
type NonClosingStreamWrap =
    class
        inherit Stream
    end
[<SealedAttribute>]
type NonClosingStreamWrap =
    class
        inherit Stream
    end
See Also
NonClosingStreamWrap Members
NFX.IO Namespace


NonClosingStreamWrap Members

NonClosingStreamWrap Members NFX Class Library

The NonClosingStreamWrap type exposes the following members.
Constructors
 | Name | Description
Public method | NonClosingStreamWrap | Allocates a wrapper around some other stream so it can be used with TextWriter that always closes the underlying stream in cases when the underlying stream needs to remain open after TextWriter is done
Back to Top
Methods
 | Name | Description
Public method | Online BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Close | (Overrides Online Stream Close .)
Public method | Online CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Online Stream.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Protected method | Online CreateWaitHandle | Obsolete. Allocates a Online WaitHandle object. (Inherited from Online Stream.)
Public method | Online Dispose | Releases all resources used by the Online Stream. (Inherited from Online Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the NonClosingStreamWrap and optionally releases the managed resources (Overrides Online Stream Dispose(Boolean).)
Public method | Online EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Overrides Online Stream Flush .)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Online Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Online Stream.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Online Stream.)
Public method | Read | (Overrides Online Stream Read( Byte , Int32, Int32).)
Public method | ReadAsync( Byte , Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Online Stream.)
Public method | ReadAsync( Byte , Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Online Stream.)
Public method | Online ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Online Stream.)
Public method | Seek | (Overrides Online Stream Seek(Int64, SeekOrigin).)
Public method | SetLength | (Overrides Online Stream SetLength(Int64).)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write | (Overrides Online Stream Write( Byte , Int32, Int32).)
Public method | WriteAsync( Byte , Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Online Stream.)
Public method | WriteAsync( Byte , Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Online Stream.)
Public method | Online WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Online Stream.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsCharEnumerable | (Defined by IOMiscUtils.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Public Extension Method | ReadBEInt32 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEShort | Reads a short encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUInt64 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUShort | Reads an ushort encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadSLEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadSLEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | WriteBEInt32 | Writes an integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEShort | Writes a short encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUInt64 | Writes an unsigned long integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUShort | Writes an ushort encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteSLEB128(Int64, Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteSLEB128(Int64, Int32 , Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, UInt32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, Int32 , UInt32) | Overloaded. (Defined by LEB128.)
Back to Top
Fields
 | Name | Description
Public field | Target | Target stream that this stream wraps
Back to Top
Properties
 | Name | Description
Public property | CanRead | (Overrides Online Stream CanRead.)
Public property | CanSeek | (Overrides Online Stream CanSeek.)
Public property | Online CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Online Stream.)
Public property | CanWrite | (Overrides Online Stream CanWrite.)
Public property | Length | (Overrides Online Stream Length.)
Public property | Position | (Overrides Online Stream Position.)
Public property | Online ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Online Stream.)
Public property | Online WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Online Stream.)
Back to Top
See Also
NonClosingStreamWrap Class
NFX.IO Namespace


NonClosingStreamWrap Constructor

NonClosingStreamWrap Constructor NFX Class Library

Allocates a wrapper around some other stream so it can be used with TextWriter that always closes the underlying stream in cases when the underlying stream needs to remain open after TextWriter is done

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NonClosingStreamWrap(
    Stream target
)
public NonClosingStreamWrap(
    Stream target
)
Public Sub New (
    target As Stream
)
Public Sub New (
    target As Stream
)
public:
NonClosingStreamWrap(
    Stream^ target
)
public:
NonClosingStreamWrap(
    Stream^ target
)
new :
        target : Stream -> NonClosingStreamWrap
new :
        target : Stream -> NonClosingStreamWrap

Parameters

target
Type: Online System.IO Stream
See Also
NonClosingStreamWrap Class
NonClosingStreamWrap Members
NFX.IO Namespace


NonClosingStreamWrap Fields

NonClosingStreamWrap Fields NFX Class Library

The NonClosingStreamWrap type exposes the following members.
Fields
 | Name | Description
Public field | Target | Target stream that this stream wraps
Back to Top
See Also
NonClosingStreamWrap Class
NFX.IO Namespace


NonClosingStreamWrap.Target Field

NonClosingStreamWrap Target Field NFX Class Library

Target stream that this stream wraps

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Stream Target
public readonly Stream Target
Public ReadOnly Target As Stream
Public ReadOnly Target As Stream
public:
initonly Stream^ Target
public:
initonly Stream^ Target
val Target: Stream
val Target: Stream

Field Value

Type: Online Stream
See Also
NonClosingStreamWrap Class
NonClosingStreamWrap Members
NFX.IO Namespace


NonClosingStreamWrap Methods

NonClosingStreamWrap Methods NFX Class Library

The NonClosingStreamWrap type exposes the following members.
Methods
 | Name | Description
Public method | Online BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Close | (Overrides Online Stream Close .)
Public method | Online CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Online Stream.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Protected method | Online CreateWaitHandle | Obsolete. Allocates a Online WaitHandle object. (Inherited from Online Stream.)
Public method | Online Dispose | Releases all resources used by the Online Stream. (Inherited from Online Stream.)
Protected method | Dispose(Boolean) | (Overrides Online Stream Dispose(Boolean).)
Public method | Online EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Overrides Online Stream Flush .)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Online Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Online Stream.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Online Stream.)
Public method | Read | (Overrides Online Stream Read( Byte , Int32, Int32).)
Public method | ReadAsync( Byte , Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Online Stream.)
Public method | ReadAsync( Byte , Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Online Stream.)
Public method | Online ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Online Stream.)
Public method | Seek | (Overrides Online Stream Seek(Int64, SeekOrigin).)
Public method | SetLength | (Overrides Online Stream SetLength(Int64).)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write | (Overrides Online Stream Write( Byte , Int32, Int32).)
Public method | WriteAsync( Byte , Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Online Stream.)
Public method | WriteAsync( Byte , Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Online Stream.)
Public method | Online WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Online Stream.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsCharEnumerable | (Defined by IOMiscUtils.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Public Extension Method | ReadBEInt32 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEShort | Reads a short encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUInt64 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUShort | Reads an ushort encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadSLEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadSLEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | WriteBEInt32 | Writes an integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEShort | Writes a short encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUInt64 | Writes an unsigned long integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUShort | Writes an ushort encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteSLEB128(Int64, Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteSLEB128(Int64, Int32 , Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, UInt32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, Int32 , UInt32) | Overloaded. (Defined by LEB128.)
Back to Top
See Also
NonClosingStreamWrap Class
NFX.IO Namespace


NonClosingStreamWrap.Close Method

NonClosingStreamWrap Close Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Close()
public override void Close()
Public Overrides Sub Close
Public Overrides Sub Close
public:
virtual void Close() override
public:
virtual void Close() override
abstract Close : unit -> unit
override Close : unit -> unit
abstract Close : unit -> unit
override Close : unit -> unit
See Also
NonClosingStreamWrap Class
NonClosingStreamWrap Members
NFX.IO Namespace


NonClosingStreamWrap.Dispose Method

NonClosingStreamWrap Dispose Method NFX Class Library

Overload List
 | Name | Description
Public method | Online Dispose | Releases all resources used by the Online Stream. (Inherited from Online Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the NonClosingStreamWrap and optionally releases the managed resources (Overrides Online Stream Dispose(Boolean).)
Back to Top
See Also
NonClosingStreamWrap Class
NonClosingStreamWrap Members
NFX.IO Namespace


NonClosingStreamWrap.Dispose Method (Boolean)

NonClosingStreamWrap Dispose Method (Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Releases the unmanaged resources used by the NonClosingStreamWrap and optionally releases the managed resources

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
NonClosingStreamWrap Class
NonClosingStreamWrap Members
Dispose Overload
NFX.IO Namespace


NonClosingStreamWrap.Flush Method

NonClosingStreamWrap Flush Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Flush()
public override void Flush()
Public Overrides Sub Flush
Public Overrides Sub Flush
public:
virtual void Flush() override
public:
virtual void Flush() override
abstract Flush : unit -> unit
override Flush : unit -> unit
abstract Flush : unit -> unit
override Flush : unit -> unit
See Also
NonClosingStreamWrap Class
NonClosingStreamWrap Members
NFX.IO Namespace


NonClosingStreamWrap.Read Method

NonClosingStreamWrap Read Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int

Parameters

buffer
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32

Return Value

Type: Online Int32
See Also
NonClosingStreamWrap Class
NonClosingStreamWrap Members
NFX.IO Namespace


NonClosingStreamWrap.Seek Method

NonClosingStreamWrap Seek Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long Seek(
    long offset,
    SeekOrigin origin
)
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64

Parameters

offset
Type: Online System Int64
origin
Type: Online System.IO SeekOrigin

Return Value

Type: Online Int64
See Also
NonClosingStreamWrap Class
NonClosingStreamWrap Members
NFX.IO Namespace


NonClosingStreamWrap.SetLength Method

NonClosingStreamWrap SetLength Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void SetLength(
    long value
)
public override void SetLength(
    long value
)
Public Overrides Sub SetLength (
    value As Long
)
Public Overrides Sub SetLength (
    value As Long
)
public:
virtual void SetLength(
    long long value
) override
public:
virtual void SetLength(
    long long value
) override
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit

Parameters

value
Type: Online System Int64
See Also
NonClosingStreamWrap Class
NonClosingStreamWrap Members
NFX.IO Namespace


NonClosingStreamWrap.Write Method

NonClosingStreamWrap Write Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit

Parameters

buffer
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32
See Also
NonClosingStreamWrap Class
NonClosingStreamWrap Members
NFX.IO Namespace


NonClosingStreamWrap Properties

NonClosingStreamWrap Properties NFX Class Library

The NonClosingStreamWrap type exposes the following members.
Properties
 | Name | Description
Public property | CanRead | (Overrides Online Stream CanRead.)
Public property | CanSeek | (Overrides Online Stream CanSeek.)
Public property | Online CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Online Stream.)
Public property | CanWrite | (Overrides Online Stream CanWrite.)
Public property | Length | (Overrides Online Stream Length.)
Public property | Position | (Overrides Online Stream Position.)
Public property | Online ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Online Stream.)
Public property | Online WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Online Stream.)
Back to Top
See Also
NonClosingStreamWrap Class
NFX.IO Namespace


NonClosingStreamWrap.CanRead Property

NonClosingStreamWrap CanRead Property NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool CanRead { get; }
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
    Get
Public Overrides ReadOnly Property CanRead As Boolean
    Get
public:
virtual property bool CanRead {
    bool get () override;
}
public:
virtual property bool CanRead {
    bool get () override;
}
abstract CanRead : bool with get
override CanRead : bool with get
abstract CanRead : bool with get
override CanRead : bool with get

Property Value

Type: Online Boolean
See Also
NonClosingStreamWrap Class
NonClosingStreamWrap Members
NFX.IO Namespace


NonClosingStreamWrap.CanSeek Property

NonClosingStreamWrap CanSeek Property NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool CanSeek { get; }
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
public:
virtual property bool CanSeek {
    bool get () override;
}
public:
virtual property bool CanSeek {
    bool get () override;
}
abstract CanSeek : bool with get
override CanSeek : bool with get
abstract CanSeek : bool with get
override CanSeek : bool with get

Property Value

Type: Online Boolean
See Also
NonClosingStreamWrap Class
NonClosingStreamWrap Members
NFX.IO Namespace


NonClosingStreamWrap.CanWrite Property

NonClosingStreamWrap CanWrite Property NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool CanWrite { get; }
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
public:
virtual property bool CanWrite {
    bool get () override;
}
public:
virtual property bool CanWrite {
    bool get () override;
}
abstract CanWrite : bool with get
override CanWrite : bool with get
abstract CanWrite : bool with get
override CanWrite : bool with get

Property Value

Type: Online Boolean
See Also
NonClosingStreamWrap Class
NonClosingStreamWrap Members
NFX.IO Namespace


NonClosingStreamWrap.Length Property

NonClosingStreamWrap Length Property NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long Length { get; }
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
    Get
Public Overrides ReadOnly Property Length As Long
    Get
public:
virtual property long long Length {
    long long get () override;
}
public:
virtual property long long Length {
    long long get () override;
}
abstract Length : int64 with get
override Length : int64 with get
abstract Length : int64 with get
override Length : int64 with get

Property Value

Type: Online Int64
See Also
NonClosingStreamWrap Class
NonClosingStreamWrap Members
NFX.IO Namespace


NonClosingStreamWrap.Position Property

NonClosingStreamWrap Position Property NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long Position { get; set; }
public override long Position { get; set; }
Public Overrides Property Position As Long
    Get
    Set
Public Overrides Property Position As Long
    Get
    Set
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
abstract Position : int64 with get, set
override Position : int64 with get, set
abstract Position : int64 with get, set
override Position : int64 with get, set

Property Value

Type: Online Int64
See Also
NonClosingStreamWrap Class
NonClosingStreamWrap Members
NFX.IO Namespace


ReadingStreamer Class

ReadingStreamer Class NFX Class Library

Reads primitives from stream
Inheritance Hierarchy
Online System Object
NFX.IO Streamer
NFX.IO ReadingStreamer
NFX.IO SlimReader

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[InventoryAttribute(Concerns = SystemConcerns.Unspecified|SystemConcerns.Testing|SystemConcerns.MissionCriticality)]
public abstract class ReadingStreamer : Streamer
[InventoryAttribute(Concerns = SystemConcerns.Unspecified|SystemConcerns.Testing|SystemConcerns.MissionCriticality)]
public abstract class ReadingStreamer : Streamer
<InventoryAttribute(Concerns := SystemConcerns.Unspecified Or SystemConcerns.Testing Or SystemConcerns.MissionCriticality)>
Public MustInherit Class ReadingStreamer
    Inherits Streamer
<InventoryAttribute(Concerns := SystemConcerns.Unspecified Or SystemConcerns.Testing Or SystemConcerns.MissionCriticality)>
Public MustInherit Class ReadingStreamer
    Inherits Streamer
[InventoryAttribute(Concerns = SystemConcerns::Unspecified|SystemConcerns::Testing|SystemConcerns::MissionCriticality)]
public ref class ReadingStreamer abstract : public Streamer
[InventoryAttribute(Concerns = SystemConcerns::Unspecified|SystemConcerns::Testing|SystemConcerns::MissionCriticality)]
public ref class ReadingStreamer abstract : public Streamer
[<AbstractClassAttribute>]
[<InventoryAttribute(Concerns = SystemConcerns.Unspecified|SystemConcerns.Testing|SystemConcerns.MissionCriticality)>]
type ReadingStreamer =
    class
        inherit Streamer
    end
[<AbstractClassAttribute>]
[<InventoryAttribute(Concerns = SystemConcerns.Unspecified|SystemConcerns.Testing|SystemConcerns.MissionCriticality)>]
type ReadingStreamer =
    class
        inherit Streamer
    end
See Also
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer Members

ReadingStreamer Members NFX Class Library

The ReadingStreamer type exposes the following members.
Constructors
 | Name | Description
Protected method | ReadingStreamer | Initializes a new instance of the ReadingStreamer class
Back to Top
Methods
 | Name | Description
Public method | BindStream | Sets the stream as the target for output/input. This call must be coupled with UnbindStream() (Inherited from Streamer.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReadAmount |
Public method | ReadBool |
Public method | ReadByte |
Public method | ReadByteArray |
Public method | ReadChar |
Public method | ReadCharArray |
Public method | ReadDateTime |
Public method | ReadDecimal |
Public method | ReadDecimalArray |
Public method | ReadDouble |
Public method | ReadDoubleArray |
Public method | ReadFID |
Public method | ReadFloat |
Public method | ReadFloatArray |
Protected method | ReadFromStream |
Public method | ReadGDID |
Public method | ReadGuid |
Public method | ReadInt |
Public method | ReadIntArray |
Public method | ReadLong |
Public method | ReadLongArray |
Public method | ReadMetaHandle |
Public method | ReadMethodSpec |
Public method | ReadNLSMap |
Public method | ReadNullableAmount |
Public method | ReadNullableBool |
Public method | ReadNullableByte |
Public method | ReadNullableChar |
Public method | ReadNullableDateTime |
Public method | ReadNullableDecimal |
Public method | ReadNullableDouble |
Public method | ReadNullableFID |
Public method | ReadNullableFloat |
Public method | ReadNullableGDID |
Public method | ReadNullableGuid |
Public method | ReadNullableInt |
Public method | ReadNullableLong |
Public method | ReadNullableMetaHandle |
Public method | ReadNullableNLSMap |
Public method | ReadNullablePilePointer |
Public method | ReadNullableSByte |
Public method | ReadNullableShort |
Public method | ReadNullableTimeSpan |
Public method | ReadNullableUInt |
Public method | ReadNullableULong |
Public method | ReadNullableUShort |
Public method | ReadNullableVarIntStr |
Public method | ReadPilePointer |
Public method | ReadSByte |
Public method | ReadShort |
Public method | ReadString |
Public method | ReadStringArray |
Public method | ReadStringMap |
Public method | ReadTimeSpan |
Public method | ReadTypeSpec |
Public method | ReadUInt |
Public method | ReadULong |
Public method | ReadUShort |
Public method | ReadVarIntStr |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UnbindStream | Unbinds the current stream. This call is coupled with BindStream(stream) (Inherited from Streamer.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Buff32 | (Inherited from Streamer.)
Protected field | m_Encoding | (Inherited from Streamer.)
Protected field | m_Stream | (Inherited from Streamer.)
Back to Top
Properties
 | Name | Description
Public property | Encoding | Returns stream string encoding (Inherited from Streamer.)
Public property | Format | Returns format that this streamer implements (Inherited from Streamer.)
Public property | Stream | Returns underlying stream if it is bound or null (Inherited from Streamer.)
Back to Top
See Also
ReadingStreamer Class
NFX.IO Namespace


ReadingStreamer Constructor

ReadingStreamer Constructor NFX Class Library

Initializes a new instance of the ReadingStreamer class

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ReadingStreamer(
    Encoding encoding = null
)
protected ReadingStreamer(
    Encoding encoding = null
)
Protected Sub New (
    Optional encoding As Encoding = Nothing
)
Protected Sub New (
    Optional encoding As Encoding = Nothing
)
protected:
ReadingStreamer(
    Encoding^ encoding = nullptr
)
protected:
ReadingStreamer(
    Encoding^ encoding = nullptr
)
new :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> ReadingStreamer
new :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> ReadingStreamer

Parameters

encoding (Optional)
Type: Online System.Text Encoding
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer Fields

ReadingStreamer Fields NFX Class Library

The ReadingStreamer type exposes the following members.
Fields
 | Name | Description
Protected field | m_Buff32 | (Inherited from Streamer.)
Protected field | m_Encoding | (Inherited from Streamer.)
Protected field | m_Stream | (Inherited from Streamer.)
Back to Top
See Also
ReadingStreamer Class
NFX.IO Namespace


ReadingStreamer Methods

ReadingStreamer Methods NFX Class Library

The ReadingStreamer type exposes the following members.
Methods
 | Name | Description
Public method | BindStream | Sets the stream as the target for output/input. This call must be coupled with UnbindStream() (Inherited from Streamer.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReadAmount |
Public method | ReadBool |
Public method | ReadByte |
Public method | ReadByteArray |
Public method | ReadChar |
Public method | ReadCharArray |
Public method | ReadDateTime |
Public method | ReadDecimal |
Public method | ReadDecimalArray |
Public method | ReadDouble |
Public method | ReadDoubleArray |
Public method | ReadFID |
Public method | ReadFloat |
Public method | ReadFloatArray |
Protected method | ReadFromStream |
Public method | ReadGDID |
Public method | ReadGuid |
Public method | ReadInt |
Public method | ReadIntArray |
Public method | ReadLong |
Public method | ReadLongArray |
Public method | ReadMetaHandle |
Public method | ReadMethodSpec |
Public method | ReadNLSMap |
Public method | ReadNullableAmount |
Public method | ReadNullableBool |
Public method | ReadNullableByte |
Public method | ReadNullableChar |
Public method | ReadNullableDateTime |
Public method | ReadNullableDecimal |
Public method | ReadNullableDouble |
Public method | ReadNullableFID |
Public method | ReadNullableFloat |
Public method | ReadNullableGDID |
Public method | ReadNullableGuid |
Public method | ReadNullableInt |
Public method | ReadNullableLong |
Public method | ReadNullableMetaHandle |
Public method | ReadNullableNLSMap |
Public method | ReadNullablePilePointer |
Public method | ReadNullableSByte |
Public method | ReadNullableShort |
Public method | ReadNullableTimeSpan |
Public method | ReadNullableUInt |
Public method | ReadNullableULong |
Public method | ReadNullableUShort |
Public method | ReadNullableVarIntStr |
Public method | ReadPilePointer |
Public method | ReadSByte |
Public method | ReadShort |
Public method | ReadString |
Public method | ReadStringArray |
Public method | ReadStringMap |
Public method | ReadTimeSpan |
Public method | ReadTypeSpec |
Public method | ReadUInt |
Public method | ReadULong |
Public method | ReadUShort |
Public method | ReadVarIntStr |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UnbindStream | Unbinds the current stream. This call is coupled with BindStream(stream) (Inherited from Streamer.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ReadingStreamer Class
NFX.IO Namespace


ReadingStreamer.ReadAmount Method

ReadingStreamer ReadAmount Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Amount ReadAmount()
public abstract Amount ReadAmount()
Public MustOverride Function ReadAmount As Amount
Public MustOverride Function ReadAmount As Amount
public:
virtual Amount ReadAmount() abstract
public:
virtual Amount ReadAmount() abstract
abstract ReadAmount : unit -> Amount
abstract ReadAmount : unit -> Amount

Return Value

Type: Amount
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadBool Method

ReadingStreamer ReadBool Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool ReadBool()
public abstract bool ReadBool()
Public MustOverride Function ReadBool As Boolean
Public MustOverride Function ReadBool As Boolean
public:
virtual bool ReadBool() abstract
public:
virtual bool ReadBool() abstract
abstract ReadBool : unit -> bool
abstract ReadBool : unit -> bool

Return Value

Type: Online Boolean
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadByte Method

ReadingStreamer ReadByte Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract byte ReadByte()
public abstract byte ReadByte()
Public MustOverride Function ReadByte As Byte
Public MustOverride Function ReadByte As Byte
public:
virtual unsigned char ReadByte() abstract
public:
virtual unsigned char ReadByte() abstract
abstract ReadByte : unit -> byte
abstract ReadByte : unit -> byte

Return Value

Type: Online Byte
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadByteArray Method

ReadingStreamer ReadByteArray Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract byte[] ReadByteArray()
public abstract byte[] ReadByteArray()
Public MustOverride Function ReadByteArray As Byte()
Public MustOverride Function ReadByteArray As Byte()
public:
virtual array<unsigned char>^ ReadByteArray() abstract
public:
virtual array<unsigned char>^ ReadByteArray() abstract
abstract ReadByteArray : unit -> byte[]
abstract ReadByteArray : unit -> byte[]

Return Value

Type: Online Byte
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadChar Method

ReadingStreamer ReadChar Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract char ReadChar()
public abstract char ReadChar()
Public MustOverride Function ReadChar As Char
Public MustOverride Function ReadChar As Char
public:
virtual wchar_t ReadChar() abstract
public:
virtual wchar_t ReadChar() abstract
abstract ReadChar : unit -> char
abstract ReadChar : unit -> char

Return Value

Type: Online Char
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadCharArray Method

ReadingStreamer ReadCharArray Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract char[] ReadCharArray()
public abstract char[] ReadCharArray()
Public MustOverride Function ReadCharArray As Char()
Public MustOverride Function ReadCharArray As Char()
public:
virtual array<wchar_t>^ ReadCharArray() abstract
public:
virtual array<wchar_t>^ ReadCharArray() abstract
abstract ReadCharArray : unit -> char[]
abstract ReadCharArray : unit -> char[]

Return Value

Type: Online Char
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadDateTime Method

ReadingStreamer ReadDateTime Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract DateTime ReadDateTime()
public abstract DateTime ReadDateTime()
Public MustOverride Function ReadDateTime As DateTime
Public MustOverride Function ReadDateTime As DateTime
public:
virtual DateTime ReadDateTime() abstract
public:
virtual DateTime ReadDateTime() abstract
abstract ReadDateTime : unit -> DateTime
abstract ReadDateTime : unit -> DateTime

Return Value

Type: Online DateTime
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadDecimal Method

ReadingStreamer ReadDecimal Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract decimal ReadDecimal()
public abstract decimal ReadDecimal()
Public MustOverride Function ReadDecimal As Decimal
Public MustOverride Function ReadDecimal As Decimal
public:
virtual Decimal ReadDecimal() abstract
public:
virtual Decimal ReadDecimal() abstract
abstract ReadDecimal : unit -> decimal
abstract ReadDecimal : unit -> decimal

Return Value

Type: Online Decimal
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadDecimalArray Method

ReadingStreamer ReadDecimalArray Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract decimal[] ReadDecimalArray()
public abstract decimal[] ReadDecimalArray()
Public MustOverride Function ReadDecimalArray As Decimal()
Public MustOverride Function ReadDecimalArray As Decimal()
public:
virtual array<Decimal>^ ReadDecimalArray() abstract
public:
virtual array<Decimal>^ ReadDecimalArray() abstract
abstract ReadDecimalArray : unit -> decimal[]
abstract ReadDecimalArray : unit -> decimal[]

Return Value

Type: Online Decimal
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadDouble Method

ReadingStreamer ReadDouble Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract double ReadDouble()
public abstract double ReadDouble()
Public MustOverride Function ReadDouble As Double
Public MustOverride Function ReadDouble As Double
public:
virtual double ReadDouble() abstract
public:
virtual double ReadDouble() abstract
abstract ReadDouble : unit -> float
abstract ReadDouble : unit -> float

Return Value

Type: Online Double
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadDoubleArray Method

ReadingStreamer ReadDoubleArray Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract double[] ReadDoubleArray()
public abstract double[] ReadDoubleArray()
Public MustOverride Function ReadDoubleArray As Double()
Public MustOverride Function ReadDoubleArray As Double()
public:
virtual array<double>^ ReadDoubleArray() abstract
public:
virtual array<double>^ ReadDoubleArray() abstract
abstract ReadDoubleArray : unit -> float[]
abstract ReadDoubleArray : unit -> float[]

Return Value

Type: Online Double
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadFID Method

ReadingStreamer ReadFID Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract FID ReadFID()
public abstract FID ReadFID()
Public MustOverride Function ReadFID As FID
Public MustOverride Function ReadFID As FID
public:
virtual FID ReadFID() abstract
public:
virtual FID ReadFID() abstract
abstract ReadFID : unit -> FID
abstract ReadFID : unit -> FID

Return Value

Type: FID
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadFloat Method

ReadingStreamer ReadFloat Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract float ReadFloat()
public abstract float ReadFloat()
Public MustOverride Function ReadFloat As Single
Public MustOverride Function ReadFloat As Single
public:
virtual float ReadFloat() abstract
public:
virtual float ReadFloat() abstract
abstract ReadFloat : unit -> float32
abstract ReadFloat : unit -> float32

Return Value

Type: Online Single
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadFloatArray Method

ReadingStreamer ReadFloatArray Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract float[] ReadFloatArray()
public abstract float[] ReadFloatArray()
Public MustOverride Function ReadFloatArray As Single()
Public MustOverride Function ReadFloatArray As Single()
public:
virtual array<float>^ ReadFloatArray() abstract
public:
virtual array<float>^ ReadFloatArray() abstract
abstract ReadFloatArray : unit -> float32[]
abstract ReadFloatArray : unit -> float32[]

Return Value

Type: Online Single
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadFromStream Method

ReadingStreamer ReadFromStream Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected int ReadFromStream(
    byte[] buffer,
    int count
)
protected int ReadFromStream(
    byte[] buffer,
    int count
)
Protected Function ReadFromStream (
    buffer As Byte(),
    count As Integer
) As Integer
Protected Function ReadFromStream (
    buffer As Byte(),
    count As Integer
) As Integer
protected:
int ReadFromStream(
    array<unsigned char>^ buffer,
    int count
)
protected:
int ReadFromStream(
    array<unsigned char>^ buffer,
    int count
)
member ReadFromStream :
        buffer : byte[] *
        count : int -> int
member ReadFromStream :
        buffer : byte[] *
        count : int -> int

Parameters

buffer
Type: Online System Byte
count
Type: Online System Int32

Return Value

Type: Online Int32
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadGDID Method

ReadingStreamer ReadGDID Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract GDID ReadGDID()
public abstract GDID ReadGDID()
Public MustOverride Function ReadGDID As GDID
Public MustOverride Function ReadGDID As GDID
public:
virtual GDID ReadGDID() abstract
public:
virtual GDID ReadGDID() abstract
abstract ReadGDID : unit -> GDID
abstract ReadGDID : unit -> GDID

Return Value

Type: GDID
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadGuid Method

ReadingStreamer ReadGuid Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Guid ReadGuid()
public abstract Guid ReadGuid()
Public MustOverride Function ReadGuid As Guid
Public MustOverride Function ReadGuid As Guid
public:
virtual Guid ReadGuid() abstract
public:
virtual Guid ReadGuid() abstract
abstract ReadGuid : unit -> Guid
abstract ReadGuid : unit -> Guid

Return Value

Type: Online Guid
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadInt Method

ReadingStreamer ReadInt Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int ReadInt()
public abstract int ReadInt()
Public MustOverride Function ReadInt As Integer
Public MustOverride Function ReadInt As Integer
public:
virtual int ReadInt() abstract
public:
virtual int ReadInt() abstract
abstract ReadInt : unit -> int
abstract ReadInt : unit -> int

Return Value

Type: Online Int32
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadIntArray Method

ReadingStreamer ReadIntArray Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int[] ReadIntArray()
public abstract int[] ReadIntArray()
Public MustOverride Function ReadIntArray As Integer()
Public MustOverride Function ReadIntArray As Integer()
public:
virtual array<int>^ ReadIntArray() abstract
public:
virtual array<int>^ ReadIntArray() abstract
abstract ReadIntArray : unit -> int[]
abstract ReadIntArray : unit -> int[]

Return Value

Type: Online Int32
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadLong Method

ReadingStreamer ReadLong Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract long ReadLong()
public abstract long ReadLong()
Public MustOverride Function ReadLong As Long
Public MustOverride Function ReadLong As Long
public:
virtual long long ReadLong() abstract
public:
virtual long long ReadLong() abstract
abstract ReadLong : unit -> int64
abstract ReadLong : unit -> int64

Return Value

Type: Online Int64
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadLongArray Method

ReadingStreamer ReadLongArray Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract long[] ReadLongArray()
public abstract long[] ReadLongArray()
Public MustOverride Function ReadLongArray As Long()
Public MustOverride Function ReadLongArray As Long()
public:
virtual array<long long>^ ReadLongArray() abstract
public:
virtual array<long long>^ ReadLongArray() abstract
abstract ReadLongArray : unit -> int64[]
abstract ReadLongArray : unit -> int64[]

Return Value

Type: Online Int64
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadMetaHandle Method

ReadingStreamer ReadMetaHandle Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract MetaHandle ReadMetaHandle()
public abstract MetaHandle ReadMetaHandle()
Public MustOverride Function ReadMetaHandle As MetaHandle
Public MustOverride Function ReadMetaHandle As MetaHandle
public:
virtual MetaHandle ReadMetaHandle() abstract
public:
virtual MetaHandle ReadMetaHandle() abstract
abstract ReadMetaHandle : unit -> MetaHandle
abstract ReadMetaHandle : unit -> MetaHandle

Return Value

Type: MetaHandle
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadMethodSpec Method

ReadingStreamer ReadMethodSpec Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract MethodSpec ReadMethodSpec()
public abstract MethodSpec ReadMethodSpec()
Public MustOverride Function ReadMethodSpec As MethodSpec
Public MustOverride Function ReadMethodSpec As MethodSpec
public:
virtual MethodSpec ReadMethodSpec() abstract
public:
virtual MethodSpec ReadMethodSpec() abstract
abstract ReadMethodSpec : unit -> MethodSpec
abstract ReadMethodSpec : unit -> MethodSpec

Return Value

Type: MethodSpec
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadNLSMap Method

ReadingStreamer ReadNLSMap Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract NLSMap ReadNLSMap()
public abstract NLSMap ReadNLSMap()
Public MustOverride Function ReadNLSMap As NLSMap
Public MustOverride Function ReadNLSMap As NLSMap
public:
virtual NLSMap ReadNLSMap() abstract
public:
virtual NLSMap ReadNLSMap() abstract
abstract ReadNLSMap : unit -> NLSMap
abstract ReadNLSMap : unit -> NLSMap

Return Value

Type: NLSMap
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadNullableAmount Method

ReadingStreamer ReadNullableAmount Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Nullable<Amount> ReadNullableAmount()
public abstract Nullable<Amount> ReadNullableAmount()
Public MustOverride Function ReadNullableAmount As Nullable(Of Amount)
Public MustOverride Function ReadNullableAmount As Nullable(Of Amount)
public:
virtual Nullable<Amount> ReadNullableAmount() abstract
public:
virtual Nullable<Amount> ReadNullableAmount() abstract
abstract ReadNullableAmount : unit -> Nullable<Amount>
abstract ReadNullableAmount : unit -> Nullable<Amount>

Return Value

Type: Online Nullable Amount
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadNullableBool Method

ReadingStreamer ReadNullableBool Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Nullable<bool> ReadNullableBool()
public abstract Nullable<bool> ReadNullableBool()
Public MustOverride Function ReadNullableBool As Nullable(Of Boolean)
Public MustOverride Function ReadNullableBool As Nullable(Of Boolean)
public:
virtual Nullable<bool> ReadNullableBool() abstract
public:
virtual Nullable<bool> ReadNullableBool() abstract
abstract ReadNullableBool : unit -> Nullable<bool>
abstract ReadNullableBool : unit -> Nullable<bool>

Return Value

Type: Online Nullable Online Boolean
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadNullableByte Method

ReadingStreamer ReadNullableByte Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Nullable<byte> ReadNullableByte()
public abstract Nullable<byte> ReadNullableByte()
Public MustOverride Function ReadNullableByte As Nullable(Of Byte)
Public MustOverride Function ReadNullableByte As Nullable(Of Byte)
public:
virtual Nullable<unsigned char> ReadNullableByte() abstract
public:
virtual Nullable<unsigned char> ReadNullableByte() abstract
abstract ReadNullableByte : unit -> Nullable<byte>
abstract ReadNullableByte : unit -> Nullable<byte>

Return Value

Type: Online Nullable Online Byte
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadNullableChar Method

ReadingStreamer ReadNullableChar Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Nullable<char> ReadNullableChar()
public abstract Nullable<char> ReadNullableChar()
Public MustOverride Function ReadNullableChar As Nullable(Of Char)
Public MustOverride Function ReadNullableChar As Nullable(Of Char)
public:
virtual Nullable<wchar_t> ReadNullableChar() abstract
public:
virtual Nullable<wchar_t> ReadNullableChar() abstract
abstract ReadNullableChar : unit -> Nullable<char>
abstract ReadNullableChar : unit -> Nullable<char>

Return Value

Type: Online Nullable Online Char
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadNullableDateTime Method

ReadingStreamer ReadNullableDateTime Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Nullable<DateTime> ReadNullableDateTime()
public abstract Nullable<DateTime> ReadNullableDateTime()
Public MustOverride Function ReadNullableDateTime As Nullable(Of DateTime)
Public MustOverride Function ReadNullableDateTime As Nullable(Of DateTime)
public:
virtual Nullable<DateTime> ReadNullableDateTime() abstract
public:
virtual Nullable<DateTime> ReadNullableDateTime() abstract
abstract ReadNullableDateTime : unit -> Nullable<DateTime>
abstract ReadNullableDateTime : unit -> Nullable<DateTime>

Return Value

Type: Online Nullable Online DateTime
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadNullableDecimal Method

ReadingStreamer ReadNullableDecimal Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Nullable<decimal> ReadNullableDecimal()
public abstract Nullable<decimal> ReadNullableDecimal()
Public MustOverride Function ReadNullableDecimal As Nullable(Of Decimal)
Public MustOverride Function ReadNullableDecimal As Nullable(Of Decimal)
public:
virtual Nullable<Decimal> ReadNullableDecimal() abstract
public:
virtual Nullable<Decimal> ReadNullableDecimal() abstract
abstract ReadNullableDecimal : unit -> Nullable<decimal>
abstract ReadNullableDecimal : unit -> Nullable<decimal>

Return Value

Type: Online Nullable Online Decimal
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadNullableDouble Method

ReadingStreamer ReadNullableDouble Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Nullable<double> ReadNullableDouble()
public abstract Nullable<double> ReadNullableDouble()
Public MustOverride Function ReadNullableDouble As Nullable(Of Double)
Public MustOverride Function ReadNullableDouble As Nullable(Of Double)
public:
virtual Nullable<double> ReadNullableDouble() abstract
public:
virtual Nullable<double> ReadNullableDouble() abstract
abstract ReadNullableDouble : unit -> Nullable<float>
abstract ReadNullableDouble : unit -> Nullable<float>

Return Value

Type: Online Nullable Online Double
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadNullableFID Method

ReadingStreamer ReadNullableFID Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Nullable<FID> ReadNullableFID()
public abstract Nullable<FID> ReadNullableFID()
Public MustOverride Function ReadNullableFID As Nullable(Of FID)
Public MustOverride Function ReadNullableFID As Nullable(Of FID)
public:
virtual Nullable<FID> ReadNullableFID() abstract
public:
virtual Nullable<FID> ReadNullableFID() abstract
abstract ReadNullableFID : unit -> Nullable<FID>
abstract ReadNullableFID : unit -> Nullable<FID>

Return Value

Type: Online Nullable FID
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadNullableFloat Method

ReadingStreamer ReadNullableFloat Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Nullable<float> ReadNullableFloat()
public abstract Nullable<float> ReadNullableFloat()
Public MustOverride Function ReadNullableFloat As Nullable(Of Single)
Public MustOverride Function ReadNullableFloat As Nullable(Of Single)
public:
virtual Nullable<float> ReadNullableFloat() abstract
public:
virtual Nullable<float> ReadNullableFloat() abstract
abstract ReadNullableFloat : unit -> Nullable<float32>
abstract ReadNullableFloat : unit -> Nullable<float32>

Return Value

Type: Online Nullable Online Single
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadNullableGDID Method

ReadingStreamer ReadNullableGDID Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Nullable<GDID> ReadNullableGDID()
public abstract Nullable<GDID> ReadNullableGDID()
Public MustOverride Function ReadNullableGDID As Nullable(Of GDID)
Public MustOverride Function ReadNullableGDID As Nullable(Of GDID)
public:
virtual Nullable<GDID> ReadNullableGDID() abstract
public:
virtual Nullable<GDID> ReadNullableGDID() abstract
abstract ReadNullableGDID : unit -> Nullable<GDID>
abstract ReadNullableGDID : unit -> Nullable<GDID>

Return Value

Type: Online Nullable GDID
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadNullableGuid Method

ReadingStreamer ReadNullableGuid Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Nullable<Guid> ReadNullableGuid()
public abstract Nullable<Guid> ReadNullableGuid()
Public MustOverride Function ReadNullableGuid As Nullable(Of Guid)
Public MustOverride Function ReadNullableGuid As Nullable(Of Guid)
public:
virtual Nullable<Guid> ReadNullableGuid() abstract
public:
virtual Nullable<Guid> ReadNullableGuid() abstract
abstract ReadNullableGuid : unit -> Nullable<Guid>
abstract ReadNullableGuid : unit -> Nullable<Guid>

Return Value

Type: Online Nullable Online Guid
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadNullableInt Method

ReadingStreamer ReadNullableInt Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Nullable<int> ReadNullableInt()
public abstract Nullable<int> ReadNullableInt()
Public MustOverride Function ReadNullableInt As Nullable(Of Integer)
Public MustOverride Function ReadNullableInt As Nullable(Of Integer)
public:
virtual Nullable<int> ReadNullableInt() abstract
public:
virtual Nullable<int> ReadNullableInt() abstract
abstract ReadNullableInt : unit -> Nullable<int>
abstract ReadNullableInt : unit -> Nullable<int>

Return Value

Type: Online Nullable Online Int32
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadNullableLong Method

ReadingStreamer ReadNullableLong Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Nullable<long> ReadNullableLong()
public abstract Nullable<long> ReadNullableLong()
Public MustOverride Function ReadNullableLong As Nullable(Of Long)
Public MustOverride Function ReadNullableLong As Nullable(Of Long)
public:
virtual Nullable<long long> ReadNullableLong() abstract
public:
virtual Nullable<long long> ReadNullableLong() abstract
abstract ReadNullableLong : unit -> Nullable<int64>
abstract ReadNullableLong : unit -> Nullable<int64>

Return Value

Type: Online Nullable Online Int64
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadNullableMetaHandle Method

ReadingStreamer ReadNullableMetaHandle Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Nullable<MetaHandle> ReadNullableMetaHandle()
public abstract Nullable<MetaHandle> ReadNullableMetaHandle()
Public MustOverride Function ReadNullableMetaHandle As Nullable(Of MetaHandle)
Public MustOverride Function ReadNullableMetaHandle As Nullable(Of MetaHandle)
public:
virtual Nullable<MetaHandle> ReadNullableMetaHandle() abstract
public:
virtual Nullable<MetaHandle> ReadNullableMetaHandle() abstract
abstract ReadNullableMetaHandle : unit -> Nullable<MetaHandle>
abstract ReadNullableMetaHandle : unit -> Nullable<MetaHandle>

Return Value

Type: Online Nullable MetaHandle
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadNullableNLSMap Method

ReadingStreamer ReadNullableNLSMap Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Nullable<NLSMap> ReadNullableNLSMap()
public abstract Nullable<NLSMap> ReadNullableNLSMap()
Public MustOverride Function ReadNullableNLSMap As Nullable(Of NLSMap)
Public MustOverride Function ReadNullableNLSMap As Nullable(Of NLSMap)
public:
virtual Nullable<NLSMap> ReadNullableNLSMap() abstract
public:
virtual Nullable<NLSMap> ReadNullableNLSMap() abstract
abstract ReadNullableNLSMap : unit -> Nullable<NLSMap>
abstract ReadNullableNLSMap : unit -> Nullable<NLSMap>

Return Value

Type: Online Nullable NLSMap
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadNullablePilePointer Method

ReadingStreamer ReadNullablePilePointer Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Nullable<PilePointer> ReadNullablePilePointer()
public abstract Nullable<PilePointer> ReadNullablePilePointer()
Public MustOverride Function ReadNullablePilePointer As Nullable(Of PilePointer)
Public MustOverride Function ReadNullablePilePointer As Nullable(Of PilePointer)
public:
virtual Nullable<PilePointer> ReadNullablePilePointer() abstract
public:
virtual Nullable<PilePointer> ReadNullablePilePointer() abstract
abstract ReadNullablePilePointer : unit -> Nullable<PilePointer>
abstract ReadNullablePilePointer : unit -> Nullable<PilePointer>

Return Value

Type: Online Nullable PilePointer
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadNullableSByte Method

ReadingStreamer ReadNullableSByte Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Nullable<sbyte> ReadNullableSByte()
public abstract Nullable<sbyte> ReadNullableSByte()
Public MustOverride Function ReadNullableSByte As Nullable(Of SByte)
Public MustOverride Function ReadNullableSByte As Nullable(Of SByte)
public:
virtual Nullable<signed char> ReadNullableSByte() abstract
public:
virtual Nullable<signed char> ReadNullableSByte() abstract
abstract ReadNullableSByte : unit -> Nullable<sbyte>
abstract ReadNullableSByte : unit -> Nullable<sbyte>

Return Value

Type: Online Nullable Online SByte
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadNullableShort Method

ReadingStreamer ReadNullableShort Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Nullable<short> ReadNullableShort()
public abstract Nullable<short> ReadNullableShort()
Public MustOverride Function ReadNullableShort As Nullable(Of Short)
Public MustOverride Function ReadNullableShort As Nullable(Of Short)
public:
virtual Nullable<short> ReadNullableShort() abstract
public:
virtual Nullable<short> ReadNullableShort() abstract
abstract ReadNullableShort : unit -> Nullable<int16>
abstract ReadNullableShort : unit -> Nullable<int16>

Return Value

Type: Online Nullable Online Int16
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadNullableTimeSpan Method

ReadingStreamer ReadNullableTimeSpan Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Nullable<TimeSpan> ReadNullableTimeSpan()
public abstract Nullable<TimeSpan> ReadNullableTimeSpan()
Public MustOverride Function ReadNullableTimeSpan As Nullable(Of TimeSpan)
Public MustOverride Function ReadNullableTimeSpan As Nullable(Of TimeSpan)
public:
virtual Nullable<TimeSpan> ReadNullableTimeSpan() abstract
public:
virtual Nullable<TimeSpan> ReadNullableTimeSpan() abstract
abstract ReadNullableTimeSpan : unit -> Nullable<TimeSpan>
abstract ReadNullableTimeSpan : unit -> Nullable<TimeSpan>

Return Value

Type: Online Nullable Online TimeSpan
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadNullableUInt Method

ReadingStreamer ReadNullableUInt Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Nullable<uint> ReadNullableUInt()
public abstract Nullable<uint> ReadNullableUInt()
Public MustOverride Function ReadNullableUInt As Nullable(Of UInteger)
Public MustOverride Function ReadNullableUInt As Nullable(Of UInteger)
public:
virtual Nullable<unsigned int> ReadNullableUInt() abstract
public:
virtual Nullable<unsigned int> ReadNullableUInt() abstract
abstract ReadNullableUInt : unit -> Nullable<uint32>
abstract ReadNullableUInt : unit -> Nullable<uint32>

Return Value

Type: Online Nullable Online UInt32
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadNullableULong Method

ReadingStreamer ReadNullableULong Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Nullable<ulong> ReadNullableULong()
public abstract Nullable<ulong> ReadNullableULong()
Public MustOverride Function ReadNullableULong As Nullable(Of ULong)
Public MustOverride Function ReadNullableULong As Nullable(Of ULong)
public:
virtual Nullable<unsigned long long> ReadNullableULong() abstract
public:
virtual Nullable<unsigned long long> ReadNullableULong() abstract
abstract ReadNullableULong : unit -> Nullable<uint64>
abstract ReadNullableULong : unit -> Nullable<uint64>

Return Value

Type: Online Nullable Online UInt64
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadNullableUShort Method

ReadingStreamer ReadNullableUShort Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Nullable<ushort> ReadNullableUShort()
public abstract Nullable<ushort> ReadNullableUShort()
Public MustOverride Function ReadNullableUShort As Nullable(Of UShort)
Public MustOverride Function ReadNullableUShort As Nullable(Of UShort)
public:
virtual Nullable<unsigned short> ReadNullableUShort() abstract
public:
virtual Nullable<unsigned short> ReadNullableUShort() abstract
abstract ReadNullableUShort : unit -> Nullable<uint16>
abstract ReadNullableUShort : unit -> Nullable<uint16>

Return Value

Type: Online Nullable Online UInt16
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadNullableVarIntStr Method

ReadingStreamer ReadNullableVarIntStr Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Nullable<VarIntStr> ReadNullableVarIntStr()
public abstract Nullable<VarIntStr> ReadNullableVarIntStr()
Public MustOverride Function ReadNullableVarIntStr As Nullable(Of VarIntStr)
Public MustOverride Function ReadNullableVarIntStr As Nullable(Of VarIntStr)
public:
virtual Nullable<VarIntStr> ReadNullableVarIntStr() abstract
public:
virtual Nullable<VarIntStr> ReadNullableVarIntStr() abstract
abstract ReadNullableVarIntStr : unit -> Nullable<VarIntStr>
abstract ReadNullableVarIntStr : unit -> Nullable<VarIntStr>

Return Value

Type: Online Nullable VarIntStr
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadPilePointer Method

ReadingStreamer ReadPilePointer Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract PilePointer ReadPilePointer()
public abstract PilePointer ReadPilePointer()
Public MustOverride Function ReadPilePointer As PilePointer
Public MustOverride Function ReadPilePointer As PilePointer
public:
virtual PilePointer ReadPilePointer() abstract
public:
virtual PilePointer ReadPilePointer() abstract
abstract ReadPilePointer : unit -> PilePointer
abstract ReadPilePointer : unit -> PilePointer

Return Value

Type: PilePointer
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadSByte Method

ReadingStreamer ReadSByte Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract sbyte ReadSByte()
public abstract sbyte ReadSByte()
Public MustOverride Function ReadSByte As SByte
Public MustOverride Function ReadSByte As SByte
public:
virtual signed char ReadSByte() abstract
public:
virtual signed char ReadSByte() abstract
abstract ReadSByte : unit -> sbyte
abstract ReadSByte : unit -> sbyte

Return Value

Type: Online SByte
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadShort Method

ReadingStreamer ReadShort Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract short ReadShort()
public abstract short ReadShort()
Public MustOverride Function ReadShort As Short
Public MustOverride Function ReadShort As Short
public:
virtual short ReadShort() abstract
public:
virtual short ReadShort() abstract
abstract ReadShort : unit -> int16
abstract ReadShort : unit -> int16

Return Value

Type: Online Int16
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadString Method

ReadingStreamer ReadString Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string ReadString()
public abstract string ReadString()
Public MustOverride Function ReadString As String
Public MustOverride Function ReadString As String
public:
virtual String^ ReadString() abstract
public:
virtual String^ ReadString() abstract
abstract ReadString : unit -> string
abstract ReadString : unit -> string

Return Value

Type: Online String
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadStringArray Method

ReadingStreamer ReadStringArray Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string[] ReadStringArray()
public abstract string[] ReadStringArray()
Public MustOverride Function ReadStringArray As String()
Public MustOverride Function ReadStringArray As String()
public:
virtual array<String^>^ ReadStringArray() abstract
public:
virtual array<String^>^ ReadStringArray() abstract
abstract ReadStringArray : unit -> string[]
abstract ReadStringArray : unit -> string[]

Return Value

Type: Online String
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadStringMap Method

ReadingStreamer ReadStringMap Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract StringMap ReadStringMap()
public abstract StringMap ReadStringMap()
Public MustOverride Function ReadStringMap As StringMap
Public MustOverride Function ReadStringMap As StringMap
public:
virtual StringMap^ ReadStringMap() abstract
public:
virtual StringMap^ ReadStringMap() abstract
abstract ReadStringMap : unit -> StringMap
abstract ReadStringMap : unit -> StringMap

Return Value

Type: StringMap
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadTimeSpan Method

ReadingStreamer ReadTimeSpan Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract TimeSpan ReadTimeSpan()
public abstract TimeSpan ReadTimeSpan()
Public MustOverride Function ReadTimeSpan As TimeSpan
Public MustOverride Function ReadTimeSpan As TimeSpan
public:
virtual TimeSpan ReadTimeSpan() abstract
public:
virtual TimeSpan ReadTimeSpan() abstract
abstract ReadTimeSpan : unit -> TimeSpan
abstract ReadTimeSpan : unit -> TimeSpan

Return Value

Type: Online TimeSpan
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadTypeSpec Method

ReadingStreamer ReadTypeSpec Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract TypeSpec ReadTypeSpec()
public abstract TypeSpec ReadTypeSpec()
Public MustOverride Function ReadTypeSpec As TypeSpec
Public MustOverride Function ReadTypeSpec As TypeSpec
public:
virtual TypeSpec ReadTypeSpec() abstract
public:
virtual TypeSpec ReadTypeSpec() abstract
abstract ReadTypeSpec : unit -> TypeSpec
abstract ReadTypeSpec : unit -> TypeSpec

Return Value

Type: TypeSpec
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadUInt Method

ReadingStreamer ReadUInt Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract uint ReadUInt()
public abstract uint ReadUInt()
Public MustOverride Function ReadUInt As UInteger
Public MustOverride Function ReadUInt As UInteger
public:
virtual unsigned int ReadUInt() abstract
public:
virtual unsigned int ReadUInt() abstract
abstract ReadUInt : unit -> uint32
abstract ReadUInt : unit -> uint32

Return Value

Type: Online UInt32
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadULong Method

ReadingStreamer ReadULong Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract ulong ReadULong()
public abstract ulong ReadULong()
Public MustOverride Function ReadULong As ULong
Public MustOverride Function ReadULong As ULong
public:
virtual unsigned long long ReadULong() abstract
public:
virtual unsigned long long ReadULong() abstract
abstract ReadULong : unit -> uint64
abstract ReadULong : unit -> uint64

Return Value

Type: Online UInt64
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadUShort Method

ReadingStreamer ReadUShort Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract ushort ReadUShort()
public abstract ushort ReadUShort()
Public MustOverride Function ReadUShort As UShort
Public MustOverride Function ReadUShort As UShort
public:
virtual unsigned short ReadUShort() abstract
public:
virtual unsigned short ReadUShort() abstract
abstract ReadUShort : unit -> uint16
abstract ReadUShort : unit -> uint16

Return Value

Type: Online UInt16
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer.ReadVarIntStr Method

ReadingStreamer ReadVarIntStr Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract VarIntStr ReadVarIntStr()
public abstract VarIntStr ReadVarIntStr()
Public MustOverride Function ReadVarIntStr As VarIntStr
Public MustOverride Function ReadVarIntStr As VarIntStr
public:
virtual VarIntStr ReadVarIntStr() abstract
public:
virtual VarIntStr ReadVarIntStr() abstract
abstract ReadVarIntStr : unit -> VarIntStr
abstract ReadVarIntStr : unit -> VarIntStr

Return Value

Type: VarIntStr
See Also
ReadingStreamer Class
ReadingStreamer Members
NFX.IO Namespace


ReadingStreamer Properties

ReadingStreamer Properties NFX Class Library

The ReadingStreamer type exposes the following members.
Properties
 | Name | Description
Public property | Encoding | Returns stream string encoding (Inherited from Streamer.)
Public property | Format | Returns format that this streamer implements (Inherited from Streamer.)
Public property | Stream | Returns underlying stream if it is bound or null (Inherited from Streamer.)
Back to Top
See Also
ReadingStreamer Class
NFX.IO Namespace


SlimFormat Class

SlimFormat Class NFX Class Library

A format that writes into binary files in an efficient way using variable-length integers, strings and meta handles. Developers may derive new formats that support custom serialization of their business-related types. This may increase performance dramatically. For example, in a drawing application a new format may derive from SlimFormat to natively serialize Point and PolarPoint structs to yield faster serialization times. NFX.Serialization.Slim.SlimSlimSerializer is capable of SlimFormat-derived format injection, in which case it will automatically discover new types that are directly supported by the format.
Inheritance Hierarchy
Online System Object
NFX.IO StreamerFormat
NFX.IO StreamerFormat SlimReader, SlimWriter
NFX.IO SlimFormat

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SlimFormat : StreamerFormat<SlimReader, SlimWriter>
public class SlimFormat : StreamerFormat<SlimReader, SlimWriter>
Public Class SlimFormat
    Inherits StreamerFormat(Of SlimReader, SlimWriter)
Public Class SlimFormat
    Inherits StreamerFormat(Of SlimReader, SlimWriter)
public ref class SlimFormat : public StreamerFormat<SlimReader^, SlimWriter^>
public ref class SlimFormat : public StreamerFormat<SlimReader^, SlimWriter^>
type SlimFormat =
    class
        inherit StreamerFormat<SlimReader, SlimWriter>
    end
type SlimFormat =
    class
        inherit StreamerFormat<SlimReader, SlimWriter>
    end
See Also
SlimFormat Members
NFX.IO Namespace


SlimFormat Members

SlimFormat Members NFX Class Library

The SlimFormat type exposes the following members.
Constructors
 | Name | Description
Protected method | SlimFormat | Initializes a new instance of the SlimFormat class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReadActionForRefType | Returns a function that reads the specified ref type and returns it as object (Inherited from StreamerFormat TReader, TWriter .)
Public method | GetReadActionForType | Returns a function that reads the specified value type and returns it as object (Inherited from StreamerFormat TReader, TWriter .)
Public method | GetReadingStreamer | Makes new reader instance (Inherited from StreamerFormat TReader, TWriter .)
Public method | GetReadMethodForRefType | Returns a method info for reading a certain reference type for this format or null if this type is not directly supported. Use IsRefTypeSupported(type) to see if the ref type is native to this format. (Inherited from StreamerFormat TReader, TWriter .)
Public method | GetReadMethodForType | Returns a method info for reading a certain value type for this format or null if this type is not directly supported. Use IsTypeSupported(type) to see if the type is native to this format. (Inherited from StreamerFormat TReader, TWriter .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetWriteActionForRefType | Returns an action that writes the value of the specified ref type (Inherited from StreamerFormat TReader, TWriter .)
Public method | GetWriteActionForType | Returns an action that writes the value of the specified value type (Inherited from StreamerFormat TReader, TWriter .)
Public method | GetWriteMethodForRefType | Returns a method info for writing a certain ref type for this format. Use IsRefTypeSupported(type) to see if the type is native to this format. (Inherited from StreamerFormat TReader, TWriter .)
Public method | GetWriteMethodForType | Returns a method info for writing a certain value type for this format. Use IsTypeSupported(type) to see if the type is native to this format. (Inherited from StreamerFormat TReader, TWriter .)
Public method | GetWritingStreamer | Makes new writer instance (Inherited from StreamerFormat TReader, TWriter .)
Public method | IsRefTypeSupported | Returns true when the supplied reference type is natively supported by format, that is - when this format can directly write instances of this type without reflection/complex graph walk. (Inherited from StreamerFormat TReader, TWriter .)
Public method | IsTypeSupported | Returns true when the supplied value type is natively supported by format, that is - when this format can directly write instances of this type without reflection/complex graph walk. (Inherited from StreamerFormat TReader, TWriter .)
Public method | MakeReadingStreamer | (Overrides StreamerFormat TReader, TWriter MakeReadingStreamer(Encoding).)
Public method | MakeWritingStreamer | (Overrides StreamerFormat TReader, TWriter MakeWritingStreamer(Encoding).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | MAX_BYTE_ARRAY_LEN |
 | MAX_DECIMAL_ARRAY_LEN |
 | MAX_DOUBLE_ARRAY_LEN |
 | MAX_FLOAT_ARRAY_LEN |
 | MAX_INT_ARRAY_LEN |
 | MAX_LONG_ARRAY_LEN |
 | MAX_STRING_ARRAY_CNT |
Protected field | TypeSchema | Internally references type schema
Back to Top
Properties
 | Name | Description
 | Instance | Returns a singleton format instance
Public property | ReaderType | (Overrides StreamerFormat ReaderType.)
Public property | WriterType | (Overrides StreamerFormat WriterType.)
Back to Top
See Also
SlimFormat Class
NFX.IO Namespace


SlimFormat Constructor

SlimFormat Constructor NFX Class Library

Initializes a new instance of the SlimFormat class

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected SlimFormat()
protected SlimFormat()
Protected Sub New
Protected Sub New
protected:
SlimFormat()
protected:
SlimFormat()
new : unit -> SlimFormat
new : unit -> SlimFormat
See Also
SlimFormat Class
SlimFormat Members
NFX.IO Namespace


SlimFormat Fields

SlimFormat Fields NFX Class Library

The SlimFormat type exposes the following members.
Fields
 | Name | Description
 | MAX_BYTE_ARRAY_LEN |
 | MAX_DECIMAL_ARRAY_LEN |
 | MAX_DOUBLE_ARRAY_LEN |
 | MAX_FLOAT_ARRAY_LEN |
 | MAX_INT_ARRAY_LEN |
 | MAX_LONG_ARRAY_LEN |
 | MAX_STRING_ARRAY_CNT |
Protected field | TypeSchema | Internally references type schema
Back to Top
See Also
SlimFormat Class
NFX.IO Namespace


SlimFormat.MAX_BYTE_ARRAY_LEN Field

SlimFormat MAX_BYTE_ARRAY_LEN Field NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_BYTE_ARRAY_LEN
public const int MAX_BYTE_ARRAY_LEN
Public Const MAX_BYTE_ARRAY_LEN As Integer
Public Const MAX_BYTE_ARRAY_LEN As Integer
public:
literal int MAX_BYTE_ARRAY_LEN
public:
literal int MAX_BYTE_ARRAY_LEN
static val mutable MAX_BYTE_ARRAY_LEN: int
static val mutable MAX_BYTE_ARRAY_LEN: int

Field Value

Type: Online Int32
See Also
SlimFormat Class
SlimFormat Members
NFX.IO Namespace


SlimFormat.MAX_DECIMAL_ARRAY_LEN Field

SlimFormat MAX_DECIMAL_ARRAY_LEN Field NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_DECIMAL_ARRAY_LEN
public const int MAX_DECIMAL_ARRAY_LEN
Public Const MAX_DECIMAL_ARRAY_LEN As Integer
Public Const MAX_DECIMAL_ARRAY_LEN As Integer
public:
literal int MAX_DECIMAL_ARRAY_LEN
public:
literal int MAX_DECIMAL_ARRAY_LEN
static val mutable MAX_DECIMAL_ARRAY_LEN: int
static val mutable MAX_DECIMAL_ARRAY_LEN: int

Field Value

Type: Online Int32
See Also
SlimFormat Class
SlimFormat Members
NFX.IO Namespace


SlimFormat.MAX_DOUBLE_ARRAY_LEN Field

SlimFormat MAX_DOUBLE_ARRAY_LEN Field NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_DOUBLE_ARRAY_LEN
public const int MAX_DOUBLE_ARRAY_LEN
Public Const MAX_DOUBLE_ARRAY_LEN As Integer
Public Const MAX_DOUBLE_ARRAY_LEN As Integer
public:
literal int MAX_DOUBLE_ARRAY_LEN
public:
literal int MAX_DOUBLE_ARRAY_LEN
static val mutable MAX_DOUBLE_ARRAY_LEN: int
static val mutable MAX_DOUBLE_ARRAY_LEN: int

Field Value

Type: Online Int32
See Also
SlimFormat Class
SlimFormat Members
NFX.IO Namespace


SlimFormat.MAX_FLOAT_ARRAY_LEN Field

SlimFormat MAX_FLOAT_ARRAY_LEN Field NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_FLOAT_ARRAY_LEN
public const int MAX_FLOAT_ARRAY_LEN
Public Const MAX_FLOAT_ARRAY_LEN As Integer
Public Const MAX_FLOAT_ARRAY_LEN As Integer
public:
literal int MAX_FLOAT_ARRAY_LEN
public:
literal int MAX_FLOAT_ARRAY_LEN
static val mutable MAX_FLOAT_ARRAY_LEN: int
static val mutable MAX_FLOAT_ARRAY_LEN: int

Field Value

Type: Online Int32
See Also
SlimFormat Class
SlimFormat Members
NFX.IO Namespace


SlimFormat.MAX_INT_ARRAY_LEN Field

SlimFormat MAX_INT_ARRAY_LEN Field NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_INT_ARRAY_LEN
public const int MAX_INT_ARRAY_LEN
Public Const MAX_INT_ARRAY_LEN As Integer
Public Const MAX_INT_ARRAY_LEN As Integer
public:
literal int MAX_INT_ARRAY_LEN
public:
literal int MAX_INT_ARRAY_LEN
static val mutable MAX_INT_ARRAY_LEN: int
static val mutable MAX_INT_ARRAY_LEN: int

Field Value

Type: Online Int32
See Also
SlimFormat Class
SlimFormat Members
NFX.IO Namespace


SlimFormat.MAX_LONG_ARRAY_LEN Field

SlimFormat MAX_LONG_ARRAY_LEN Field NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_LONG_ARRAY_LEN
public const int MAX_LONG_ARRAY_LEN
Public Const MAX_LONG_ARRAY_LEN As Integer
Public Const MAX_LONG_ARRAY_LEN As Integer
public:
literal int MAX_LONG_ARRAY_LEN
public:
literal int MAX_LONG_ARRAY_LEN
static val mutable MAX_LONG_ARRAY_LEN: int
static val mutable MAX_LONG_ARRAY_LEN: int

Field Value

Type: Online Int32
See Also
SlimFormat Class
SlimFormat Members
NFX.IO Namespace


SlimFormat.MAX_STRING_ARRAY_CNT Field

SlimFormat MAX_STRING_ARRAY_CNT Field NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_STRING_ARRAY_CNT
public const int MAX_STRING_ARRAY_CNT
Public Const MAX_STRING_ARRAY_CNT As Integer
Public Const MAX_STRING_ARRAY_CNT As Integer
public:
literal int MAX_STRING_ARRAY_CNT
public:
literal int MAX_STRING_ARRAY_CNT
static val mutable MAX_STRING_ARRAY_CNT: int
static val mutable MAX_STRING_ARRAY_CNT: int

Field Value

Type: Online Int32
See Also
SlimFormat Class
SlimFormat Members
NFX.IO Namespace


SlimFormat.TypeSchema Field

SlimFormat TypeSchema Field NFX Class Library

Internally references type schema

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal readonly TypeSchema TypeSchema
internal readonly TypeSchema TypeSchema
Friend ReadOnly TypeSchema As TypeSchema
Friend ReadOnly TypeSchema As TypeSchema
internal:
initonly TypeSchema^ TypeSchema
internal:
initonly TypeSchema^ TypeSchema
val internal TypeSchema: TypeSchema
val internal TypeSchema: TypeSchema

Field Value

Type: TypeSchema
See Also
SlimFormat Class
SlimFormat Members
NFX.IO Namespace


SlimFormat Methods

SlimFormat Methods NFX Class Library

The SlimFormat type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReadActionForRefType | Returns a function that reads the specified ref type and returns it as object (Inherited from StreamerFormat TReader, TWriter .)
Public method | GetReadActionForType | Returns a function that reads the specified value type and returns it as object (Inherited from StreamerFormat TReader, TWriter .)
Public method | GetReadingStreamer | Makes new reader instance (Inherited from StreamerFormat TReader, TWriter .)
Public method | GetReadMethodForRefType | Returns a method info for reading a certain reference type for this format or null if this type is not directly supported. Use IsRefTypeSupported(type) to see if the ref type is native to this format. (Inherited from StreamerFormat TReader, TWriter .)
Public method | GetReadMethodForType | Returns a method info for reading a certain value type for this format or null if this type is not directly supported. Use IsTypeSupported(type) to see if the type is native to this format. (Inherited from StreamerFormat TReader, TWriter .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetWriteActionForRefType | Returns an action that writes the value of the specified ref type (Inherited from StreamerFormat TReader, TWriter .)
Public method | GetWriteActionForType | Returns an action that writes the value of the specified value type (Inherited from StreamerFormat TReader, TWriter .)
Public method | GetWriteMethodForRefType | Returns a method info for writing a certain ref type for this format. Use IsRefTypeSupported(type) to see if the type is native to this format. (Inherited from StreamerFormat TReader, TWriter .)
Public method | GetWriteMethodForType | Returns a method info for writing a certain value type for this format. Use IsTypeSupported(type) to see if the type is native to this format. (Inherited from StreamerFormat TReader, TWriter .)
Public method | GetWritingStreamer | Makes new writer instance (Inherited from StreamerFormat TReader, TWriter .)
Public method | IsRefTypeSupported | Returns true when the supplied reference type is natively supported by format, that is - when this format can directly write instances of this type without reflection/complex graph walk. (Inherited from StreamerFormat TReader, TWriter .)
Public method | IsTypeSupported | Returns true when the supplied value type is natively supported by format, that is - when this format can directly write instances of this type without reflection/complex graph walk. (Inherited from StreamerFormat TReader, TWriter .)
Public method | MakeReadingStreamer | (Overrides StreamerFormat TReader, TWriter MakeReadingStreamer(Encoding).)
Public method | MakeWritingStreamer | (Overrides StreamerFormat TReader, TWriter MakeWritingStreamer(Encoding).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SlimFormat Class
NFX.IO Namespace


SlimFormat.MakeReadingStreamer Method

SlimFormat MakeReadingStreamer Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override SlimReader MakeReadingStreamer(
    Encoding encoding = null
)
public override SlimReader MakeReadingStreamer(
    Encoding encoding = null
)
Public Overrides Function MakeReadingStreamer (
    Optional encoding As Encoding = Nothing
) As SlimReader
Public Overrides Function MakeReadingStreamer (
    Optional encoding As Encoding = Nothing
) As SlimReader
public:
virtual SlimReader^ MakeReadingStreamer(
    Encoding^ encoding = nullptr
) override
public:
virtual SlimReader^ MakeReadingStreamer(
    Encoding^ encoding = nullptr
) override
abstract MakeReadingStreamer :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> SlimReader
override MakeReadingStreamer :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> SlimReader
abstract MakeReadingStreamer :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> SlimReader
override MakeReadingStreamer :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> SlimReader

Parameters

encoding (Optional)
Type: Online System.Text Encoding

Return Value

Type: SlimReader
See Also
SlimFormat Class
SlimFormat Members
NFX.IO Namespace


SlimFormat.MakeWritingStreamer Method

SlimFormat MakeWritingStreamer Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override SlimWriter MakeWritingStreamer(
    Encoding encoding = null
)
public override SlimWriter MakeWritingStreamer(
    Encoding encoding = null
)
Public Overrides Function MakeWritingStreamer (
    Optional encoding As Encoding = Nothing
) As SlimWriter
Public Overrides Function MakeWritingStreamer (
    Optional encoding As Encoding = Nothing
) As SlimWriter
public:
virtual SlimWriter^ MakeWritingStreamer(
    Encoding^ encoding = nullptr
) override
public:
virtual SlimWriter^ MakeWritingStreamer(
    Encoding^ encoding = nullptr
) override
abstract MakeWritingStreamer :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> SlimWriter
override MakeWritingStreamer :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> SlimWriter
abstract MakeWritingStreamer :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> SlimWriter
override MakeWritingStreamer :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> SlimWriter

Parameters

encoding (Optional)
Type: Online System.Text Encoding

Return Value

Type: SlimWriter
See Also
SlimFormat Class
SlimFormat Members
NFX.IO Namespace


SlimFormat Properties

SlimFormat Properties NFX Class Library

The SlimFormat type exposes the following members.
Properties
 | Name | Description
 | Instance | Returns a singleton format instance
Public property | ReaderType | (Overrides StreamerFormat ReaderType.)
Public property | WriterType | (Overrides StreamerFormat WriterType.)
Back to Top
See Also
SlimFormat Class
NFX.IO Namespace


SlimFormat.Instance Property

SlimFormat Instance Property NFX Class Library

Returns a singleton format instance

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static SlimFormat Instance { get; }
public static SlimFormat Instance { get; }
Public Shared ReadOnly Property Instance As SlimFormat
    Get
Public Shared ReadOnly Property Instance As SlimFormat
    Get
public:
static property SlimFormat^ Instance {
    SlimFormat^ get ();
}
public:
static property SlimFormat^ Instance {
    SlimFormat^ get ();
}
static member Instance : SlimFormat with get
static member Instance : SlimFormat with get

Property Value

Type: SlimFormat
See Also
SlimFormat Class
SlimFormat Members
NFX.IO Namespace


SlimFormat.ReaderType Property

SlimFormat ReaderType Property NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Type ReaderType { get; }
public override Type ReaderType { get; }
Public Overrides ReadOnly Property ReaderType As Type
    Get
Public Overrides ReadOnly Property ReaderType As Type
    Get
public:
virtual property Type^ ReaderType {
    Type^ get () override;
}
public:
virtual property Type^ ReaderType {
    Type^ get () override;
}
abstract ReaderType : Type with get
override ReaderType : Type with get
abstract ReaderType : Type with get
override ReaderType : Type with get

Property Value

Type: Online Type
See Also
SlimFormat Class
SlimFormat Members
NFX.IO Namespace


SlimFormat.WriterType Property

SlimFormat WriterType Property NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Type WriterType { get; }
public override Type WriterType { get; }
Public Overrides ReadOnly Property WriterType As Type
    Get
Public Overrides ReadOnly Property WriterType As Type
    Get
public:
virtual property Type^ WriterType {
    Type^ get () override;
}
public:
virtual property Type^ WriterType {
    Type^ get () override;
}
abstract WriterType : Type with get
override WriterType : Type with get
abstract WriterType : Type with get
override WriterType : Type with get

Property Value

Type: Online Type
See Also
SlimFormat Class
SlimFormat Members
NFX.IO Namespace


SlimReader Class

SlimReader Class NFX Class Library

Reads primitives and other supported types from Slim-format stream. Use factory method of SlimFormat instance to create a new instance of SlimReader class
Inheritance Hierarchy
Online System Object
NFX.IO Streamer
NFX.IO ReadingStreamer
NFX.IO SlimReader

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[InventoryAttribute(Concerns = SystemConcerns.Unspecified|SystemConcerns.Testing|SystemConcerns.MissionCriticality)]
public class SlimReader : ReadingStreamer
[InventoryAttribute(Concerns = SystemConcerns.Unspecified|SystemConcerns.Testing|SystemConcerns.MissionCriticality)]
public class SlimReader : ReadingStreamer
<InventoryAttribute(Concerns := SystemConcerns.Unspecified Or SystemConcerns.Testing Or SystemConcerns.MissionCriticality)>
Public Class SlimReader
    Inherits ReadingStreamer
<InventoryAttribute(Concerns := SystemConcerns.Unspecified Or SystemConcerns.Testing Or SystemConcerns.MissionCriticality)>
Public Class SlimReader
    Inherits ReadingStreamer
[InventoryAttribute(Concerns = SystemConcerns::Unspecified|SystemConcerns::Testing|SystemConcerns::MissionCriticality)]
public ref class SlimReader : public ReadingStreamer
[InventoryAttribute(Concerns = SystemConcerns::Unspecified|SystemConcerns::Testing|SystemConcerns::MissionCriticality)]
public ref class SlimReader : public ReadingStreamer
[<InventoryAttribute(Concerns = SystemConcerns.Unspecified|SystemConcerns.Testing|SystemConcerns.MissionCriticality)>]
type SlimReader =
    class
        inherit ReadingStreamer
    end
[<InventoryAttribute(Concerns = SystemConcerns.Unspecified|SystemConcerns.Testing|SystemConcerns.MissionCriticality)>]
type SlimReader =
    class
        inherit ReadingStreamer
    end
See Also
SlimReader Members
NFX.IO Namespace


SlimReader Members

SlimReader Members NFX Class Library

The SlimReader type exposes the following members.
Constructors
 | Name | Description
Protected method | SlimReader | Initializes a new instance of the SlimReader class
Back to Top
Methods
 | Name | Description
Public method | BindStream | Sets the stream as the target for output/input. This call must be coupled with UnbindStream() (Inherited from Streamer.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReadAmount | (Overrides ReadingStreamer ReadAmount .)
Public method | ReadBool | (Overrides ReadingStreamer ReadBool .)
Public method | ReadByte | (Overrides ReadingStreamer ReadByte .)
Public method | ReadByteArray | (Overrides ReadingStreamer ReadByteArray .)
Public method | ReadChar | (Overrides ReadingStreamer ReadChar .)
Public method | ReadCharArray | (Overrides ReadingStreamer ReadCharArray .)
Public method | ReadDateTime | (Overrides ReadingStreamer ReadDateTime .)
Public method | ReadDecimal | (Overrides ReadingStreamer ReadDecimal .)
Public method | ReadDecimalArray | (Overrides ReadingStreamer ReadDecimalArray .)
Public method | ReadDouble | (Overrides ReadingStreamer ReadDouble .)
Public method | ReadDoubleArray | (Overrides ReadingStreamer ReadDoubleArray .)
Public method | ReadFID | (Overrides ReadingStreamer ReadFID .)
Public method | ReadFloat | (Overrides ReadingStreamer ReadFloat .)
Public method | ReadFloatArray | (Overrides ReadingStreamer ReadFloatArray .)
Protected method | ReadFromStream | (Inherited from ReadingStreamer.)
Public method | ReadGDID | (Overrides ReadingStreamer ReadGDID .)
Public method | ReadGuid | (Overrides ReadingStreamer ReadGuid .)
Public method | ReadInt | (Overrides ReadingStreamer ReadInt .)
Public method | ReadIntArray | (Overrides ReadingStreamer ReadIntArray .)
Public method | ReadLong | (Overrides ReadingStreamer ReadLong .)
Public method | ReadLongArray | (Overrides ReadingStreamer ReadLongArray .)
Public method | ReadMetaHandle | (Overrides ReadingStreamer ReadMetaHandle .)
Public method | ReadMethodSpec | (Overrides ReadingStreamer ReadMethodSpec .)
Public method | ReadNLSMap | (Overrides ReadingStreamer ReadNLSMap .)
Public method | ReadNullableAmount | (Overrides ReadingStreamer ReadNullableAmount .)
Public method | ReadNullableBool | (Overrides ReadingStreamer ReadNullableBool .)
Public method | ReadNullableByte | (Overrides ReadingStreamer ReadNullableByte .)
Public method | ReadNullableChar | (Overrides ReadingStreamer ReadNullableChar .)
Public method | ReadNullableDateTime | (Overrides ReadingStreamer ReadNullableDateTime .)
Public method | ReadNullableDecimal | (Overrides ReadingStreamer ReadNullableDecimal .)
Public method | ReadNullableDouble | (Overrides ReadingStreamer ReadNullableDouble .)
Public method | ReadNullableFID | (Overrides ReadingStreamer ReadNullableFID .)
Public method | ReadNullableFloat | (Overrides ReadingStreamer ReadNullableFloat .)
Public method | ReadNullableGDID | (Overrides ReadingStreamer ReadNullableGDID .)
Public method | ReadNullableGuid | (Overrides ReadingStreamer ReadNullableGuid .)
Public method | ReadNullableInt | (Overrides ReadingStreamer ReadNullableInt .)
Public method | ReadNullableLong | (Overrides ReadingStreamer ReadNullableLong .)
Public method | ReadNullableMetaHandle | (Overrides ReadingStreamer ReadNullableMetaHandle .)
Public method | ReadNullableNLSMap | (Overrides ReadingStreamer ReadNullableNLSMap .)
Public method | ReadNullablePilePointer | (Overrides ReadingStreamer ReadNullablePilePointer .)
Public method | ReadNullableSByte | (Overrides ReadingStreamer ReadNullableSByte .)
Public method | ReadNullableShort | (Overrides ReadingStreamer ReadNullableShort .)
Public method | ReadNullableTimeSpan | (Overrides ReadingStreamer ReadNullableTimeSpan .)
Public method | ReadNullableUInt | (Overrides ReadingStreamer ReadNullableUInt .)
Public method | ReadNullableULong | (Overrides ReadingStreamer ReadNullableULong .)
Public method | ReadNullableUShort | (Overrides ReadingStreamer ReadNullableUShort .)
Public method | ReadNullableVarIntStr | (Overrides ReadingStreamer ReadNullableVarIntStr .)
Public method | ReadPilePointer | (Overrides ReadingStreamer ReadPilePointer .)
Public method | ReadSByte | (Overrides ReadingStreamer ReadSByte .)
Public method | ReadShort | (Overrides ReadingStreamer ReadShort .)
Public method | ReadString | (Overrides ReadingStreamer ReadString .)
Public method | ReadStringArray | (Overrides ReadingStreamer ReadStringArray .)
Public method | ReadStringMap | (Overrides ReadingStreamer ReadStringMap .)
Public method | ReadTimeSpan | (Overrides ReadingStreamer ReadTimeSpan .)
Public method | ReadTypeSpec | (Overrides ReadingStreamer ReadTypeSpec .)
Public method | ReadUInt | (Overrides ReadingStreamer ReadUInt .)
Public method | ReadULong | (Overrides ReadingStreamer ReadULong .)
Public method | ReadUShort | (Overrides ReadingStreamer ReadUShort .)
Public method | ReadVarIntStr | (Overrides ReadingStreamer ReadVarIntStr .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UnbindStream | Unbinds the current stream. This call is coupled with BindStream(stream) (Inherited from Streamer.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Buff32 | (Inherited from Streamer.)
Protected field | m_Encoding | (Inherited from Streamer.)
Protected field | m_Stream | (Inherited from Streamer.)
Back to Top
Properties
 | Name | Description
Public property | Encoding | Returns stream string encoding (Inherited from Streamer.)
Public property | Format | Returns SlimFormat that this reader implements (Overrides Streamer Format.)
Public property | Stream | Returns underlying stream if it is bound or null (Inherited from Streamer.)
Back to Top
See Also
SlimReader Class
NFX.IO Namespace


SlimReader Constructor

SlimReader Constructor NFX Class Library

Initializes a new instance of the SlimReader class

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal SlimReader(
    Encoding encoding = null
)
protected internal SlimReader(
    Encoding encoding = null
)
Protected Friend Sub New (
    Optional encoding As Encoding = Nothing
)
Protected Friend Sub New (
    Optional encoding As Encoding = Nothing
)
protected public:
SlimReader(
    Encoding^ encoding = nullptr
)
protected public:
SlimReader(
    Encoding^ encoding = nullptr
)
new :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> SlimReader
new :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> SlimReader

Parameters

encoding (Optional)
Type: Online System.Text Encoding
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader Fields

SlimReader Fields NFX Class Library

The SlimReader type exposes the following members.
Fields
 | Name | Description
Protected field | m_Buff32 | (Inherited from Streamer.)
Protected field | m_Encoding | (Inherited from Streamer.)
Protected field | m_Stream | (Inherited from Streamer.)
Back to Top
See Also
SlimReader Class
NFX.IO Namespace


SlimReader Methods

SlimReader Methods NFX Class Library

The SlimReader type exposes the following members.
Methods
 | Name | Description
Public method | BindStream | Sets the stream as the target for output/input. This call must be coupled with UnbindStream() (Inherited from Streamer.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReadAmount | (Overrides ReadingStreamer ReadAmount .)
Public method | ReadBool | (Overrides ReadingStreamer ReadBool .)
Public method | ReadByte | (Overrides ReadingStreamer ReadByte .)
Public method | ReadByteArray | (Overrides ReadingStreamer ReadByteArray .)
Public method | ReadChar | (Overrides ReadingStreamer ReadChar .)
Public method | ReadCharArray | (Overrides ReadingStreamer ReadCharArray .)
Public method | ReadDateTime | (Overrides ReadingStreamer ReadDateTime .)
Public method | ReadDecimal | (Overrides ReadingStreamer ReadDecimal .)
Public method | ReadDecimalArray | (Overrides ReadingStreamer ReadDecimalArray .)
Public method | ReadDouble | (Overrides ReadingStreamer ReadDouble .)
Public method | ReadDoubleArray | (Overrides ReadingStreamer ReadDoubleArray .)
Public method | ReadFID | (Overrides ReadingStreamer ReadFID .)
Public method | ReadFloat | (Overrides ReadingStreamer ReadFloat .)
Public method | ReadFloatArray | (Overrides ReadingStreamer ReadFloatArray .)
Protected method | ReadFromStream | (Inherited from ReadingStreamer.)
Public method | ReadGDID | (Overrides ReadingStreamer ReadGDID .)
Public method | ReadGuid | (Overrides ReadingStreamer ReadGuid .)
Public method | ReadInt | (Overrides ReadingStreamer ReadInt .)
Public method | ReadIntArray | (Overrides ReadingStreamer ReadIntArray .)
Public method | ReadLong | (Overrides ReadingStreamer ReadLong .)
Public method | ReadLongArray | (Overrides ReadingStreamer ReadLongArray .)
Public method | ReadMetaHandle | (Overrides ReadingStreamer ReadMetaHandle .)
Public method | ReadMethodSpec | (Overrides ReadingStreamer ReadMethodSpec .)
Public method | ReadNLSMap | (Overrides ReadingStreamer ReadNLSMap .)
Public method | ReadNullableAmount | (Overrides ReadingStreamer ReadNullableAmount .)
Public method | ReadNullableBool | (Overrides ReadingStreamer ReadNullableBool .)
Public method | ReadNullableByte | (Overrides ReadingStreamer ReadNullableByte .)
Public method | ReadNullableChar | (Overrides ReadingStreamer ReadNullableChar .)
Public method | ReadNullableDateTime | (Overrides ReadingStreamer ReadNullableDateTime .)
Public method | ReadNullableDecimal | (Overrides ReadingStreamer ReadNullableDecimal .)
Public method | ReadNullableDouble | (Overrides ReadingStreamer ReadNullableDouble .)
Public method | ReadNullableFID | (Overrides ReadingStreamer ReadNullableFID .)
Public method | ReadNullableFloat | (Overrides ReadingStreamer ReadNullableFloat .)
Public method | ReadNullableGDID | (Overrides ReadingStreamer ReadNullableGDID .)
Public method | ReadNullableGuid | (Overrides ReadingStreamer ReadNullableGuid .)
Public method | ReadNullableInt | (Overrides ReadingStreamer ReadNullableInt .)
Public method | ReadNullableLong | (Overrides ReadingStreamer ReadNullableLong .)
Public method | ReadNullableMetaHandle | (Overrides ReadingStreamer ReadNullableMetaHandle .)
Public method | ReadNullableNLSMap | (Overrides ReadingStreamer ReadNullableNLSMap .)
Public method | ReadNullablePilePointer | (Overrides ReadingStreamer ReadNullablePilePointer .)
Public method | ReadNullableSByte | (Overrides ReadingStreamer ReadNullableSByte .)
Public method | ReadNullableShort | (Overrides ReadingStreamer ReadNullableShort .)
Public method | ReadNullableTimeSpan | (Overrides ReadingStreamer ReadNullableTimeSpan .)
Public method | ReadNullableUInt | (Overrides ReadingStreamer ReadNullableUInt .)
Public method | ReadNullableULong | (Overrides ReadingStreamer ReadNullableULong .)
Public method | ReadNullableUShort | (Overrides ReadingStreamer ReadNullableUShort .)
Public method | ReadNullableVarIntStr | (Overrides ReadingStreamer ReadNullableVarIntStr .)
Public method | ReadPilePointer | (Overrides ReadingStreamer ReadPilePointer .)
Public method | ReadSByte | (Overrides ReadingStreamer ReadSByte .)
Public method | ReadShort | (Overrides ReadingStreamer ReadShort .)
Public method | ReadString | (Overrides ReadingStreamer ReadString .)
Public method | ReadStringArray | (Overrides ReadingStreamer ReadStringArray .)
Public method | ReadStringMap | (Overrides ReadingStreamer ReadStringMap .)
Public method | ReadTimeSpan | (Overrides ReadingStreamer ReadTimeSpan .)
Public method | ReadTypeSpec | (Overrides ReadingStreamer ReadTypeSpec .)
Public method | ReadUInt | (Overrides ReadingStreamer ReadUInt .)
Public method | ReadULong | (Overrides ReadingStreamer ReadULong .)
Public method | ReadUShort | (Overrides ReadingStreamer ReadUShort .)
Public method | ReadVarIntStr | (Overrides ReadingStreamer ReadVarIntStr .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UnbindStream | Unbinds the current stream. This call is coupled with BindStream(stream) (Inherited from Streamer.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SlimReader Class
NFX.IO Namespace


SlimReader.ReadAmount Method

SlimReader ReadAmount Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Amount ReadAmount()
public override Amount ReadAmount()
Public Overrides Function ReadAmount As Amount
Public Overrides Function ReadAmount As Amount
public:
virtual Amount ReadAmount() override
public:
virtual Amount ReadAmount() override
abstract ReadAmount : unit -> Amount
override ReadAmount : unit -> Amount
abstract ReadAmount : unit -> Amount
override ReadAmount : unit -> Amount

Return Value

Type: Amount
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadBool Method

SlimReader ReadBool Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool ReadBool()
public override bool ReadBool()
Public Overrides Function ReadBool As Boolean
Public Overrides Function ReadBool As Boolean
public:
virtual bool ReadBool() override
public:
virtual bool ReadBool() override
abstract ReadBool : unit -> bool
override ReadBool : unit -> bool
abstract ReadBool : unit -> bool
override ReadBool : unit -> bool

Return Value

Type: Online Boolean
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadByte Method

SlimReader ReadByte Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override byte ReadByte()
public override byte ReadByte()
Public Overrides Function ReadByte As Byte
Public Overrides Function ReadByte As Byte
public:
virtual unsigned char ReadByte() override
public:
virtual unsigned char ReadByte() override
abstract ReadByte : unit -> byte
override ReadByte : unit -> byte
abstract ReadByte : unit -> byte
override ReadByte : unit -> byte

Return Value

Type: Online Byte
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadByteArray Method

SlimReader ReadByteArray Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override byte[] ReadByteArray()
public override byte[] ReadByteArray()
Public Overrides Function ReadByteArray As Byte()
Public Overrides Function ReadByteArray As Byte()
public:
virtual array<unsigned char>^ ReadByteArray() override
public:
virtual array<unsigned char>^ ReadByteArray() override
abstract ReadByteArray : unit -> byte[]
override ReadByteArray : unit -> byte[]
abstract ReadByteArray : unit -> byte[]
override ReadByteArray : unit -> byte[]

Return Value

Type: Online Byte
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadChar Method

SlimReader ReadChar Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override char ReadChar()
public override char ReadChar()
Public Overrides Function ReadChar As Char
Public Overrides Function ReadChar As Char
public:
virtual wchar_t ReadChar() override
public:
virtual wchar_t ReadChar() override
abstract ReadChar : unit -> char
override ReadChar : unit -> char
abstract ReadChar : unit -> char
override ReadChar : unit -> char

Return Value

Type: Online Char
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadCharArray Method

SlimReader ReadCharArray Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override char[] ReadCharArray()
public override char[] ReadCharArray()
Public Overrides Function ReadCharArray As Char()
Public Overrides Function ReadCharArray As Char()
public:
virtual array<wchar_t>^ ReadCharArray() override
public:
virtual array<wchar_t>^ ReadCharArray() override
abstract ReadCharArray : unit -> char[]
override ReadCharArray : unit -> char[]
abstract ReadCharArray : unit -> char[]
override ReadCharArray : unit -> char[]

Return Value

Type: Online Char
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadDateTime Method

SlimReader ReadDateTime Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override DateTime ReadDateTime()
public override DateTime ReadDateTime()
Public Overrides Function ReadDateTime As DateTime
Public Overrides Function ReadDateTime As DateTime
public:
virtual DateTime ReadDateTime() override
public:
virtual DateTime ReadDateTime() override
abstract ReadDateTime : unit -> DateTime
override ReadDateTime : unit -> DateTime
abstract ReadDateTime : unit -> DateTime
override ReadDateTime : unit -> DateTime

Return Value

Type: Online DateTime
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadDecimal Method

SlimReader ReadDecimal Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override decimal ReadDecimal()
public override decimal ReadDecimal()
Public Overrides Function ReadDecimal As Decimal
Public Overrides Function ReadDecimal As Decimal
public:
virtual Decimal ReadDecimal() override
public:
virtual Decimal ReadDecimal() override
abstract ReadDecimal : unit -> decimal
override ReadDecimal : unit -> decimal
abstract ReadDecimal : unit -> decimal
override ReadDecimal : unit -> decimal

Return Value

Type: Online Decimal
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadDecimalArray Method

SlimReader ReadDecimalArray Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override decimal[] ReadDecimalArray()
public override decimal[] ReadDecimalArray()
Public Overrides Function ReadDecimalArray As Decimal()
Public Overrides Function ReadDecimalArray As Decimal()
public:
virtual array<Decimal>^ ReadDecimalArray() override
public:
virtual array<Decimal>^ ReadDecimalArray() override
abstract ReadDecimalArray : unit -> decimal[]
override ReadDecimalArray : unit -> decimal[]
abstract ReadDecimalArray : unit -> decimal[]
override ReadDecimalArray : unit -> decimal[]

Return Value

Type: Online Decimal
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadDouble Method

SlimReader ReadDouble Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override double ReadDouble()
public override double ReadDouble()
Public Overrides Function ReadDouble As Double
Public Overrides Function ReadDouble As Double
public:
virtual double ReadDouble() override
public:
virtual double ReadDouble() override
abstract ReadDouble : unit -> float
override ReadDouble : unit -> float
abstract ReadDouble : unit -> float
override ReadDouble : unit -> float

Return Value

Type: Online Double
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadDoubleArray Method

SlimReader ReadDoubleArray Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override double[] ReadDoubleArray()
public override double[] ReadDoubleArray()
Public Overrides Function ReadDoubleArray As Double()
Public Overrides Function ReadDoubleArray As Double()
public:
virtual array<double>^ ReadDoubleArray() override
public:
virtual array<double>^ ReadDoubleArray() override
abstract ReadDoubleArray : unit -> float[]
override ReadDoubleArray : unit -> float[]
abstract ReadDoubleArray : unit -> float[]
override ReadDoubleArray : unit -> float[]

Return Value

Type: Online Double
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadFID Method

SlimReader ReadFID Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override FID ReadFID()
public override FID ReadFID()
Public Overrides Function ReadFID As FID
Public Overrides Function ReadFID As FID
public:
virtual FID ReadFID() override
public:
virtual FID ReadFID() override
abstract ReadFID : unit -> FID
override ReadFID : unit -> FID
abstract ReadFID : unit -> FID
override ReadFID : unit -> FID

Return Value

Type: FID
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadFloat Method

SlimReader ReadFloat Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float ReadFloat()
public override float ReadFloat()
Public Overrides Function ReadFloat As Single
Public Overrides Function ReadFloat As Single
public:
virtual float ReadFloat() override
public:
virtual float ReadFloat() override
abstract ReadFloat : unit -> float32
override ReadFloat : unit -> float32
abstract ReadFloat : unit -> float32
override ReadFloat : unit -> float32

Return Value

Type: Online Single
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadFloatArray Method

SlimReader ReadFloatArray Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override float[] ReadFloatArray()
public override float[] ReadFloatArray()
Public Overrides Function ReadFloatArray As Single()
Public Overrides Function ReadFloatArray As Single()
public:
virtual array<float>^ ReadFloatArray() override
public:
virtual array<float>^ ReadFloatArray() override
abstract ReadFloatArray : unit -> float32[]
override ReadFloatArray : unit -> float32[]
abstract ReadFloatArray : unit -> float32[]
override ReadFloatArray : unit -> float32[]

Return Value

Type: Online Single
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadGDID Method

SlimReader ReadGDID Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override GDID ReadGDID()
public override GDID ReadGDID()
Public Overrides Function ReadGDID As GDID
Public Overrides Function ReadGDID As GDID
public:
virtual GDID ReadGDID() override
public:
virtual GDID ReadGDID() override
abstract ReadGDID : unit -> GDID
override ReadGDID : unit -> GDID
abstract ReadGDID : unit -> GDID
override ReadGDID : unit -> GDID

Return Value

Type: GDID
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadGuid Method

SlimReader ReadGuid Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Guid ReadGuid()
public override Guid ReadGuid()
Public Overrides Function ReadGuid As Guid
Public Overrides Function ReadGuid As Guid
public:
virtual Guid ReadGuid() override
public:
virtual Guid ReadGuid() override
abstract ReadGuid : unit -> Guid
override ReadGuid : unit -> Guid
abstract ReadGuid : unit -> Guid
override ReadGuid : unit -> Guid

Return Value

Type: Online Guid
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadInt Method

SlimReader ReadInt Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int ReadInt()
public override int ReadInt()
Public Overrides Function ReadInt As Integer
Public Overrides Function ReadInt As Integer
public:
virtual int ReadInt() override
public:
virtual int ReadInt() override
abstract ReadInt : unit -> int
override ReadInt : unit -> int
abstract ReadInt : unit -> int
override ReadInt : unit -> int

Return Value

Type: Online Int32
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadIntArray Method

SlimReader ReadIntArray Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int[] ReadIntArray()
public override int[] ReadIntArray()
Public Overrides Function ReadIntArray As Integer()
Public Overrides Function ReadIntArray As Integer()
public:
virtual array<int>^ ReadIntArray() override
public:
virtual array<int>^ ReadIntArray() override
abstract ReadIntArray : unit -> int[]
override ReadIntArray : unit -> int[]
abstract ReadIntArray : unit -> int[]
override ReadIntArray : unit -> int[]

Return Value

Type: Online Int32
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadLong Method

SlimReader ReadLong Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long ReadLong()
public override long ReadLong()
Public Overrides Function ReadLong As Long
Public Overrides Function ReadLong As Long
public:
virtual long long ReadLong() override
public:
virtual long long ReadLong() override
abstract ReadLong : unit -> int64
override ReadLong : unit -> int64
abstract ReadLong : unit -> int64
override ReadLong : unit -> int64

Return Value

Type: Online Int64
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadLongArray Method

SlimReader ReadLongArray Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override long[] ReadLongArray()
public override long[] ReadLongArray()
Public Overrides Function ReadLongArray As Long()
Public Overrides Function ReadLongArray As Long()
public:
virtual array<long long>^ ReadLongArray() override
public:
virtual array<long long>^ ReadLongArray() override
abstract ReadLongArray : unit -> int64[]
override ReadLongArray : unit -> int64[]
abstract ReadLongArray : unit -> int64[]
override ReadLongArray : unit -> int64[]

Return Value

Type: Online Int64
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadMetaHandle Method

SlimReader ReadMetaHandle Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override MetaHandle ReadMetaHandle()
public override MetaHandle ReadMetaHandle()
Public Overrides Function ReadMetaHandle As MetaHandle
Public Overrides Function ReadMetaHandle As MetaHandle
public:
virtual MetaHandle ReadMetaHandle() override
public:
virtual MetaHandle ReadMetaHandle() override
abstract ReadMetaHandle : unit -> MetaHandle
override ReadMetaHandle : unit -> MetaHandle
abstract ReadMetaHandle : unit -> MetaHandle
override ReadMetaHandle : unit -> MetaHandle

Return Value

Type: MetaHandle
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadMethodSpec Method

SlimReader ReadMethodSpec Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override MethodSpec ReadMethodSpec()
public override MethodSpec ReadMethodSpec()
Public Overrides Function ReadMethodSpec As MethodSpec
Public Overrides Function ReadMethodSpec As MethodSpec
public:
virtual MethodSpec ReadMethodSpec() override
public:
virtual MethodSpec ReadMethodSpec() override
abstract ReadMethodSpec : unit -> MethodSpec
override ReadMethodSpec : unit -> MethodSpec
abstract ReadMethodSpec : unit -> MethodSpec
override ReadMethodSpec : unit -> MethodSpec

Return Value

Type: MethodSpec
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadNLSMap Method

SlimReader ReadNLSMap Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override NLSMap ReadNLSMap()
public override NLSMap ReadNLSMap()
Public Overrides Function ReadNLSMap As NLSMap
Public Overrides Function ReadNLSMap As NLSMap
public:
virtual NLSMap ReadNLSMap() override
public:
virtual NLSMap ReadNLSMap() override
abstract ReadNLSMap : unit -> NLSMap
override ReadNLSMap : unit -> NLSMap
abstract ReadNLSMap : unit -> NLSMap
override ReadNLSMap : unit -> NLSMap

Return Value

Type: NLSMap
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadNullableAmount Method

SlimReader ReadNullableAmount Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Nullable<Amount> ReadNullableAmount()
public override Nullable<Amount> ReadNullableAmount()
Public Overrides Function ReadNullableAmount As Nullable(Of Amount)
Public Overrides Function ReadNullableAmount As Nullable(Of Amount)
public:
virtual Nullable<Amount> ReadNullableAmount() override
public:
virtual Nullable<Amount> ReadNullableAmount() override
abstract ReadNullableAmount : unit -> Nullable<Amount>
override ReadNullableAmount : unit -> Nullable<Amount>
abstract ReadNullableAmount : unit -> Nullable<Amount>
override ReadNullableAmount : unit -> Nullable<Amount>

Return Value

Type: Online Nullable Amount
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadNullableBool Method

SlimReader ReadNullableBool Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Nullable<bool> ReadNullableBool()
public override Nullable<bool> ReadNullableBool()
Public Overrides Function ReadNullableBool As Nullable(Of Boolean)
Public Overrides Function ReadNullableBool As Nullable(Of Boolean)
public:
virtual Nullable<bool> ReadNullableBool() override
public:
virtual Nullable<bool> ReadNullableBool() override
abstract ReadNullableBool : unit -> Nullable<bool>
override ReadNullableBool : unit -> Nullable<bool>
abstract ReadNullableBool : unit -> Nullable<bool>
override ReadNullableBool : unit -> Nullable<bool>

Return Value

Type: Online Nullable Online Boolean
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadNullableByte Method

SlimReader ReadNullableByte Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Nullable<byte> ReadNullableByte()
public override Nullable<byte> ReadNullableByte()
Public Overrides Function ReadNullableByte As Nullable(Of Byte)
Public Overrides Function ReadNullableByte As Nullable(Of Byte)
public:
virtual Nullable<unsigned char> ReadNullableByte() override
public:
virtual Nullable<unsigned char> ReadNullableByte() override
abstract ReadNullableByte : unit -> Nullable<byte>
override ReadNullableByte : unit -> Nullable<byte>
abstract ReadNullableByte : unit -> Nullable<byte>
override ReadNullableByte : unit -> Nullable<byte>

Return Value

Type: Online Nullable Online Byte
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadNullableChar Method

SlimReader ReadNullableChar Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Nullable<char> ReadNullableChar()
public override Nullable<char> ReadNullableChar()
Public Overrides Function ReadNullableChar As Nullable(Of Char)
Public Overrides Function ReadNullableChar As Nullable(Of Char)
public:
virtual Nullable<wchar_t> ReadNullableChar() override
public:
virtual Nullable<wchar_t> ReadNullableChar() override
abstract ReadNullableChar : unit -> Nullable<char>
override ReadNullableChar : unit -> Nullable<char>
abstract ReadNullableChar : unit -> Nullable<char>
override ReadNullableChar : unit -> Nullable<char>

Return Value

Type: Online Nullable Online Char
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadNullableDateTime Method

SlimReader ReadNullableDateTime Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Nullable<DateTime> ReadNullableDateTime()
public override Nullable<DateTime> ReadNullableDateTime()
Public Overrides Function ReadNullableDateTime As Nullable(Of DateTime)
Public Overrides Function ReadNullableDateTime As Nullable(Of DateTime)
public:
virtual Nullable<DateTime> ReadNullableDateTime() override
public:
virtual Nullable<DateTime> ReadNullableDateTime() override
abstract ReadNullableDateTime : unit -> Nullable<DateTime>
override ReadNullableDateTime : unit -> Nullable<DateTime>
abstract ReadNullableDateTime : unit -> Nullable<DateTime>
override ReadNullableDateTime : unit -> Nullable<DateTime>

Return Value

Type: Online Nullable Online DateTime
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadNullableDecimal Method

SlimReader ReadNullableDecimal Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Nullable<decimal> ReadNullableDecimal()
public override Nullable<decimal> ReadNullableDecimal()
Public Overrides Function ReadNullableDecimal As Nullable(Of Decimal)
Public Overrides Function ReadNullableDecimal As Nullable(Of Decimal)
public:
virtual Nullable<Decimal> ReadNullableDecimal() override
public:
virtual Nullable<Decimal> ReadNullableDecimal() override
abstract ReadNullableDecimal : unit -> Nullable<decimal>
override ReadNullableDecimal : unit -> Nullable<decimal>
abstract ReadNullableDecimal : unit -> Nullable<decimal>
override ReadNullableDecimal : unit -> Nullable<decimal>

Return Value

Type: Online Nullable Online Decimal
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadNullableDouble Method

SlimReader ReadNullableDouble Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Nullable<double> ReadNullableDouble()
public override Nullable<double> ReadNullableDouble()
Public Overrides Function ReadNullableDouble As Nullable(Of Double)
Public Overrides Function ReadNullableDouble As Nullable(Of Double)
public:
virtual Nullable<double> ReadNullableDouble() override
public:
virtual Nullable<double> ReadNullableDouble() override
abstract ReadNullableDouble : unit -> Nullable<float>
override ReadNullableDouble : unit -> Nullable<float>
abstract ReadNullableDouble : unit -> Nullable<float>
override ReadNullableDouble : unit -> Nullable<float>

Return Value

Type: Online Nullable Online Double
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadNullableFID Method

SlimReader ReadNullableFID Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Nullable<FID> ReadNullableFID()
public override Nullable<FID> ReadNullableFID()
Public Overrides Function ReadNullableFID As Nullable(Of FID)
Public Overrides Function ReadNullableFID As Nullable(Of FID)
public:
virtual Nullable<FID> ReadNullableFID() override
public:
virtual Nullable<FID> ReadNullableFID() override
abstract ReadNullableFID : unit -> Nullable<FID>
override ReadNullableFID : unit -> Nullable<FID>
abstract ReadNullableFID : unit -> Nullable<FID>
override ReadNullableFID : unit -> Nullable<FID>

Return Value

Type: Online Nullable FID
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadNullableFloat Method

SlimReader ReadNullableFloat Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Nullable<float> ReadNullableFloat()
public override Nullable<float> ReadNullableFloat()
Public Overrides Function ReadNullableFloat As Nullable(Of Single)
Public Overrides Function ReadNullableFloat As Nullable(Of Single)
public:
virtual Nullable<float> ReadNullableFloat() override
public:
virtual Nullable<float> ReadNullableFloat() override
abstract ReadNullableFloat : unit -> Nullable<float32>
override ReadNullableFloat : unit -> Nullable<float32>
abstract ReadNullableFloat : unit -> Nullable<float32>
override ReadNullableFloat : unit -> Nullable<float32>

Return Value

Type: Online Nullable Online Single
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadNullableGDID Method

SlimReader ReadNullableGDID Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Nullable<GDID> ReadNullableGDID()
public override Nullable<GDID> ReadNullableGDID()
Public Overrides Function ReadNullableGDID As Nullable(Of GDID)
Public Overrides Function ReadNullableGDID As Nullable(Of GDID)
public:
virtual Nullable<GDID> ReadNullableGDID() override
public:
virtual Nullable<GDID> ReadNullableGDID() override
abstract ReadNullableGDID : unit -> Nullable<GDID>
override ReadNullableGDID : unit -> Nullable<GDID>
abstract ReadNullableGDID : unit -> Nullable<GDID>
override ReadNullableGDID : unit -> Nullable<GDID>

Return Value

Type: Online Nullable GDID
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadNullableGuid Method

SlimReader ReadNullableGuid Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Nullable<Guid> ReadNullableGuid()
public override Nullable<Guid> ReadNullableGuid()
Public Overrides Function ReadNullableGuid As Nullable(Of Guid)
Public Overrides Function ReadNullableGuid As Nullable(Of Guid)
public:
virtual Nullable<Guid> ReadNullableGuid() override
public:
virtual Nullable<Guid> ReadNullableGuid() override
abstract ReadNullableGuid : unit -> Nullable<Guid>
override ReadNullableGuid : unit -> Nullable<Guid>
abstract ReadNullableGuid : unit -> Nullable<Guid>
override ReadNullableGuid : unit -> Nullable<Guid>

Return Value

Type: Online Nullable Online Guid
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadNullableInt Method

SlimReader ReadNullableInt Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Nullable<int> ReadNullableInt()
public override Nullable<int> ReadNullableInt()
Public Overrides Function ReadNullableInt As Nullable(Of Integer)
Public Overrides Function ReadNullableInt As Nullable(Of Integer)
public:
virtual Nullable<int> ReadNullableInt() override
public:
virtual Nullable<int> ReadNullableInt() override
abstract ReadNullableInt : unit -> Nullable<int>
override ReadNullableInt : unit -> Nullable<int>
abstract ReadNullableInt : unit -> Nullable<int>
override ReadNullableInt : unit -> Nullable<int>

Return Value

Type: Online Nullable Online Int32
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadNullableLong Method

SlimReader ReadNullableLong Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Nullable<long> ReadNullableLong()
public override Nullable<long> ReadNullableLong()
Public Overrides Function ReadNullableLong As Nullable(Of Long)
Public Overrides Function ReadNullableLong As Nullable(Of Long)
public:
virtual Nullable<long long> ReadNullableLong() override
public:
virtual Nullable<long long> ReadNullableLong() override
abstract ReadNullableLong : unit -> Nullable<int64>
override ReadNullableLong : unit -> Nullable<int64>
abstract ReadNullableLong : unit -> Nullable<int64>
override ReadNullableLong : unit -> Nullable<int64>

Return Value

Type: Online Nullable Online Int64
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadNullableMetaHandle Method

SlimReader ReadNullableMetaHandle Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Nullable<MetaHandle> ReadNullableMetaHandle()
public override Nullable<MetaHandle> ReadNullableMetaHandle()
Public Overrides Function ReadNullableMetaHandle As Nullable(Of MetaHandle)
Public Overrides Function ReadNullableMetaHandle As Nullable(Of MetaHandle)
public:
virtual Nullable<MetaHandle> ReadNullableMetaHandle() override
public:
virtual Nullable<MetaHandle> ReadNullableMetaHandle() override
abstract ReadNullableMetaHandle : unit -> Nullable<MetaHandle>
override ReadNullableMetaHandle : unit -> Nullable<MetaHandle>
abstract ReadNullableMetaHandle : unit -> Nullable<MetaHandle>
override ReadNullableMetaHandle : unit -> Nullable<MetaHandle>

Return Value

Type: Online Nullable MetaHandle
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadNullableNLSMap Method

SlimReader ReadNullableNLSMap Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Nullable<NLSMap> ReadNullableNLSMap()
public override Nullable<NLSMap> ReadNullableNLSMap()
Public Overrides Function ReadNullableNLSMap As Nullable(Of NLSMap)
Public Overrides Function ReadNullableNLSMap As Nullable(Of NLSMap)
public:
virtual Nullable<NLSMap> ReadNullableNLSMap() override
public:
virtual Nullable<NLSMap> ReadNullableNLSMap() override
abstract ReadNullableNLSMap : unit -> Nullable<NLSMap>
override ReadNullableNLSMap : unit -> Nullable<NLSMap>
abstract ReadNullableNLSMap : unit -> Nullable<NLSMap>
override ReadNullableNLSMap : unit -> Nullable<NLSMap>

Return Value

Type: Online Nullable NLSMap
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadNullablePilePointer Method

SlimReader ReadNullablePilePointer Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Nullable<PilePointer> ReadNullablePilePointer()
public override Nullable<PilePointer> ReadNullablePilePointer()
Public Overrides Function ReadNullablePilePointer As Nullable(Of PilePointer)
Public Overrides Function ReadNullablePilePointer As Nullable(Of PilePointer)
public:
virtual Nullable<PilePointer> ReadNullablePilePointer() override
public:
virtual Nullable<PilePointer> ReadNullablePilePointer() override
abstract ReadNullablePilePointer : unit -> Nullable<PilePointer>
override ReadNullablePilePointer : unit -> Nullable<PilePointer>
abstract ReadNullablePilePointer : unit -> Nullable<PilePointer>
override ReadNullablePilePointer : unit -> Nullable<PilePointer>

Return Value

Type: Online Nullable PilePointer
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadNullableSByte Method

SlimReader ReadNullableSByte Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Nullable<sbyte> ReadNullableSByte()
public override Nullable<sbyte> ReadNullableSByte()
Public Overrides Function ReadNullableSByte As Nullable(Of SByte)
Public Overrides Function ReadNullableSByte As Nullable(Of SByte)
public:
virtual Nullable<signed char> ReadNullableSByte() override
public:
virtual Nullable<signed char> ReadNullableSByte() override
abstract ReadNullableSByte : unit -> Nullable<sbyte>
override ReadNullableSByte : unit -> Nullable<sbyte>
abstract ReadNullableSByte : unit -> Nullable<sbyte>
override ReadNullableSByte : unit -> Nullable<sbyte>

Return Value

Type: Online Nullable Online SByte
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadNullableShort Method

SlimReader ReadNullableShort Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Nullable<short> ReadNullableShort()
public override Nullable<short> ReadNullableShort()
Public Overrides Function ReadNullableShort As Nullable(Of Short)
Public Overrides Function ReadNullableShort As Nullable(Of Short)
public:
virtual Nullable<short> ReadNullableShort() override
public:
virtual Nullable<short> ReadNullableShort() override
abstract ReadNullableShort : unit -> Nullable<int16>
override ReadNullableShort : unit -> Nullable<int16>
abstract ReadNullableShort : unit -> Nullable<int16>
override ReadNullableShort : unit -> Nullable<int16>

Return Value

Type: Online Nullable Online Int16
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadNullableTimeSpan Method

SlimReader ReadNullableTimeSpan Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Nullable<TimeSpan> ReadNullableTimeSpan()
public override Nullable<TimeSpan> ReadNullableTimeSpan()
Public Overrides Function ReadNullableTimeSpan As Nullable(Of TimeSpan)
Public Overrides Function ReadNullableTimeSpan As Nullable(Of TimeSpan)
public:
virtual Nullable<TimeSpan> ReadNullableTimeSpan() override
public:
virtual Nullable<TimeSpan> ReadNullableTimeSpan() override
abstract ReadNullableTimeSpan : unit -> Nullable<TimeSpan>
override ReadNullableTimeSpan : unit -> Nullable<TimeSpan>
abstract ReadNullableTimeSpan : unit -> Nullable<TimeSpan>
override ReadNullableTimeSpan : unit -> Nullable<TimeSpan>

Return Value

Type: Online Nullable Online TimeSpan
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadNullableUInt Method

SlimReader ReadNullableUInt Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Nullable<uint> ReadNullableUInt()
public override Nullable<uint> ReadNullableUInt()
Public Overrides Function ReadNullableUInt As Nullable(Of UInteger)
Public Overrides Function ReadNullableUInt As Nullable(Of UInteger)
public:
virtual Nullable<unsigned int> ReadNullableUInt() override
public:
virtual Nullable<unsigned int> ReadNullableUInt() override
abstract ReadNullableUInt : unit -> Nullable<uint32>
override ReadNullableUInt : unit -> Nullable<uint32>
abstract ReadNullableUInt : unit -> Nullable<uint32>
override ReadNullableUInt : unit -> Nullable<uint32>

Return Value

Type: Online Nullable Online UInt32
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadNullableULong Method

SlimReader ReadNullableULong Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Nullable<ulong> ReadNullableULong()
public override Nullable<ulong> ReadNullableULong()
Public Overrides Function ReadNullableULong As Nullable(Of ULong)
Public Overrides Function ReadNullableULong As Nullable(Of ULong)
public:
virtual Nullable<unsigned long long> ReadNullableULong() override
public:
virtual Nullable<unsigned long long> ReadNullableULong() override
abstract ReadNullableULong : unit -> Nullable<uint64>
override ReadNullableULong : unit -> Nullable<uint64>
abstract ReadNullableULong : unit -> Nullable<uint64>
override ReadNullableULong : unit -> Nullable<uint64>

Return Value

Type: Online Nullable Online UInt64
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadNullableUShort Method

SlimReader ReadNullableUShort Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Nullable<ushort> ReadNullableUShort()
public override Nullable<ushort> ReadNullableUShort()
Public Overrides Function ReadNullableUShort As Nullable(Of UShort)
Public Overrides Function ReadNullableUShort As Nullable(Of UShort)
public:
virtual Nullable<unsigned short> ReadNullableUShort() override
public:
virtual Nullable<unsigned short> ReadNullableUShort() override
abstract ReadNullableUShort : unit -> Nullable<uint16>
override ReadNullableUShort : unit -> Nullable<uint16>
abstract ReadNullableUShort : unit -> Nullable<uint16>
override ReadNullableUShort : unit -> Nullable<uint16>

Return Value

Type: Online Nullable Online UInt16
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadNullableVarIntStr Method

SlimReader ReadNullableVarIntStr Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Nullable<VarIntStr> ReadNullableVarIntStr()
public override Nullable<VarIntStr> ReadNullableVarIntStr()
Public Overrides Function ReadNullableVarIntStr As Nullable(Of VarIntStr)
Public Overrides Function ReadNullableVarIntStr As Nullable(Of VarIntStr)
public:
virtual Nullable<VarIntStr> ReadNullableVarIntStr() override
public:
virtual Nullable<VarIntStr> ReadNullableVarIntStr() override
abstract ReadNullableVarIntStr : unit -> Nullable<VarIntStr>
override ReadNullableVarIntStr : unit -> Nullable<VarIntStr>
abstract ReadNullableVarIntStr : unit -> Nullable<VarIntStr>
override ReadNullableVarIntStr : unit -> Nullable<VarIntStr>

Return Value

Type: Online Nullable VarIntStr
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadPilePointer Method

SlimReader ReadPilePointer Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override PilePointer ReadPilePointer()
public override PilePointer ReadPilePointer()
Public Overrides Function ReadPilePointer As PilePointer
Public Overrides Function ReadPilePointer As PilePointer
public:
virtual PilePointer ReadPilePointer() override
public:
virtual PilePointer ReadPilePointer() override
abstract ReadPilePointer : unit -> PilePointer
override ReadPilePointer : unit -> PilePointer
abstract ReadPilePointer : unit -> PilePointer
override ReadPilePointer : unit -> PilePointer

Return Value

Type: PilePointer
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadSByte Method

SlimReader ReadSByte Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override sbyte ReadSByte()
public override sbyte ReadSByte()
Public Overrides Function ReadSByte As SByte
Public Overrides Function ReadSByte As SByte
public:
virtual signed char ReadSByte() override
public:
virtual signed char ReadSByte() override
abstract ReadSByte : unit -> sbyte
override ReadSByte : unit -> sbyte
abstract ReadSByte : unit -> sbyte
override ReadSByte : unit -> sbyte

Return Value

Type: Online SByte
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadShort Method

SlimReader ReadShort Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override short ReadShort()
public override short ReadShort()
Public Overrides Function ReadShort As Short
Public Overrides Function ReadShort As Short
public:
virtual short ReadShort() override
public:
virtual short ReadShort() override
abstract ReadShort : unit -> int16
override ReadShort : unit -> int16
abstract ReadShort : unit -> int16
override ReadShort : unit -> int16

Return Value

Type: Online Int16
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadString Method

SlimReader ReadString Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ReadString()
public override string ReadString()
Public Overrides Function ReadString As String
Public Overrides Function ReadString As String
public:
virtual String^ ReadString() override
public:
virtual String^ ReadString() override
abstract ReadString : unit -> string
override ReadString : unit -> string
abstract ReadString : unit -> string
override ReadString : unit -> string

Return Value

Type: Online String
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadStringArray Method

SlimReader ReadStringArray Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string[] ReadStringArray()
public override string[] ReadStringArray()
Public Overrides Function ReadStringArray As String()
Public Overrides Function ReadStringArray As String()
public:
virtual array<String^>^ ReadStringArray() override
public:
virtual array<String^>^ ReadStringArray() override
abstract ReadStringArray : unit -> string[]
override ReadStringArray : unit -> string[]
abstract ReadStringArray : unit -> string[]
override ReadStringArray : unit -> string[]

Return Value

Type: Online String
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadStringMap Method

SlimReader ReadStringMap Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override StringMap ReadStringMap()
public override StringMap ReadStringMap()
Public Overrides Function ReadStringMap As StringMap
Public Overrides Function ReadStringMap As StringMap
public:
virtual StringMap^ ReadStringMap() override
public:
virtual StringMap^ ReadStringMap() override
abstract ReadStringMap : unit -> StringMap
override ReadStringMap : unit -> StringMap
abstract ReadStringMap : unit -> StringMap
override ReadStringMap : unit -> StringMap

Return Value

Type: StringMap
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadTimeSpan Method

SlimReader ReadTimeSpan Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TimeSpan ReadTimeSpan()
public override TimeSpan ReadTimeSpan()
Public Overrides Function ReadTimeSpan As TimeSpan
Public Overrides Function ReadTimeSpan As TimeSpan
public:
virtual TimeSpan ReadTimeSpan() override
public:
virtual TimeSpan ReadTimeSpan() override
abstract ReadTimeSpan : unit -> TimeSpan
override ReadTimeSpan : unit -> TimeSpan
abstract ReadTimeSpan : unit -> TimeSpan
override ReadTimeSpan : unit -> TimeSpan

Return Value

Type: Online TimeSpan
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadTypeSpec Method

SlimReader ReadTypeSpec Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TypeSpec ReadTypeSpec()
public override TypeSpec ReadTypeSpec()
Public Overrides Function ReadTypeSpec As TypeSpec
Public Overrides Function ReadTypeSpec As TypeSpec
public:
virtual TypeSpec ReadTypeSpec() override
public:
virtual TypeSpec ReadTypeSpec() override
abstract ReadTypeSpec : unit -> TypeSpec
override ReadTypeSpec : unit -> TypeSpec
abstract ReadTypeSpec : unit -> TypeSpec
override ReadTypeSpec : unit -> TypeSpec

Return Value

Type: TypeSpec
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadUInt Method

SlimReader ReadUInt Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override uint ReadUInt()
public override uint ReadUInt()
Public Overrides Function ReadUInt As UInteger
Public Overrides Function ReadUInt As UInteger
public:
virtual unsigned int ReadUInt() override
public:
virtual unsigned int ReadUInt() override
abstract ReadUInt : unit -> uint32
override ReadUInt : unit -> uint32
abstract ReadUInt : unit -> uint32
override ReadUInt : unit -> uint32

Return Value

Type: Online UInt32
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadULong Method

SlimReader ReadULong Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ulong ReadULong()
public override ulong ReadULong()
Public Overrides Function ReadULong As ULong
Public Overrides Function ReadULong As ULong
public:
virtual unsigned long long ReadULong() override
public:
virtual unsigned long long ReadULong() override
abstract ReadULong : unit -> uint64
override ReadULong : unit -> uint64
abstract ReadULong : unit -> uint64
override ReadULong : unit -> uint64

Return Value

Type: Online UInt64
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadUShort Method

SlimReader ReadUShort Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override ushort ReadUShort()
public override ushort ReadUShort()
Public Overrides Function ReadUShort As UShort
Public Overrides Function ReadUShort As UShort
public:
virtual unsigned short ReadUShort() override
public:
virtual unsigned short ReadUShort() override
abstract ReadUShort : unit -> uint16
override ReadUShort : unit -> uint16
abstract ReadUShort : unit -> uint16
override ReadUShort : unit -> uint16

Return Value

Type: Online UInt16
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader.ReadVarIntStr Method

SlimReader ReadVarIntStr Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override VarIntStr ReadVarIntStr()
public override VarIntStr ReadVarIntStr()
Public Overrides Function ReadVarIntStr As VarIntStr
Public Overrides Function ReadVarIntStr As VarIntStr
public:
virtual VarIntStr ReadVarIntStr() override
public:
virtual VarIntStr ReadVarIntStr() override
abstract ReadVarIntStr : unit -> VarIntStr
override ReadVarIntStr : unit -> VarIntStr
abstract ReadVarIntStr : unit -> VarIntStr
override ReadVarIntStr : unit -> VarIntStr

Return Value

Type: VarIntStr
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimReader Properties

SlimReader Properties NFX Class Library

The SlimReader type exposes the following members.
Properties
 | Name | Description
Public property | Encoding | Returns stream string encoding (Inherited from Streamer.)
Public property | Format | Returns SlimFormat that this reader implements (Overrides Streamer Format.)
Public property | Stream | Returns underlying stream if it is bound or null (Inherited from Streamer.)
Back to Top
See Also
SlimReader Class
NFX.IO Namespace


SlimReader.Format Property

SlimReader Format Property NFX Class Library

Returns SlimFormat that this reader implements

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override StreamerFormat Format { get; }
public override StreamerFormat Format { get; }
Public Overrides ReadOnly Property Format As StreamerFormat
    Get
Public Overrides ReadOnly Property Format As StreamerFormat
    Get
public:
virtual property StreamerFormat^ Format {
    StreamerFormat^ get () override;
}
public:
virtual property StreamerFormat^ Format {
    StreamerFormat^ get () override;
}
abstract Format : StreamerFormat with get
override Format : StreamerFormat with get
abstract Format : StreamerFormat with get
override Format : StreamerFormat with get

Property Value

Type: StreamerFormat
See Also
SlimReader Class
SlimReader Members
NFX.IO Namespace


SlimWriter Class

SlimWriter Class NFX Class Library

Writes primitives and other supported types to Slim-format stream. Use factory method of SlimFormat instance to create a new instance of SlimWriter class
Inheritance Hierarchy
Online System Object
NFX.IO Streamer
NFX.IO WritingStreamer
NFX.IO SlimWriter

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[InventoryAttribute(Concerns = SystemConcerns.Unspecified|SystemConcerns.Testing|SystemConcerns.MissionCriticality)]
public class SlimWriter : WritingStreamer
[InventoryAttribute(Concerns = SystemConcerns.Unspecified|SystemConcerns.Testing|SystemConcerns.MissionCriticality)]
public class SlimWriter : WritingStreamer
<InventoryAttribute(Concerns := SystemConcerns.Unspecified Or SystemConcerns.Testing Or SystemConcerns.MissionCriticality)>
Public Class SlimWriter
    Inherits WritingStreamer
<InventoryAttribute(Concerns := SystemConcerns.Unspecified Or SystemConcerns.Testing Or SystemConcerns.MissionCriticality)>
Public Class SlimWriter
    Inherits WritingStreamer
[InventoryAttribute(Concerns = SystemConcerns::Unspecified|SystemConcerns::Testing|SystemConcerns::MissionCriticality)]
public ref class SlimWriter : public WritingStreamer
[InventoryAttribute(Concerns = SystemConcerns::Unspecified|SystemConcerns::Testing|SystemConcerns::MissionCriticality)]
public ref class SlimWriter : public WritingStreamer
[<InventoryAttribute(Concerns = SystemConcerns.Unspecified|SystemConcerns.Testing|SystemConcerns.MissionCriticality)>]
type SlimWriter =
    class
        inherit WritingStreamer
    end
[<InventoryAttribute(Concerns = SystemConcerns.Unspecified|SystemConcerns.Testing|SystemConcerns.MissionCriticality)>]
type SlimWriter =
    class
        inherit WritingStreamer
    end
See Also
SlimWriter Members
NFX.IO Namespace


SlimWriter Members

SlimWriter Members NFX Class Library

The SlimWriter type exposes the following members.
Constructors
 | Name | Description
Protected method | SlimWriter | Initializes a new instance of the SlimWriter class
Back to Top
Methods
 | Name | Description
Public method | BindStream | Sets the stream as the target for output/input. This call must be coupled with UnbindStream() (Inherited from Streamer.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Overrides WritingStreamer Flush .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UnbindStream | Unbinds the current stream. This call is coupled with BindStream(stream) (Inherited from Streamer.)
Public method | Write(Boolean) | (Overrides WritingStreamer Write(Boolean).)
Public method | Write(Byte) | (Overrides WritingStreamer Write(Byte).)
Public method | Write( Byte ) | (Overrides WritingStreamer Write( Byte ).)
Public method | Write(Char) | (Overrides WritingStreamer Write(Char).)
Public method | Write( Char ) | (Overrides WritingStreamer Write( Char ).)
Public method | Write(DateTime) | (Overrides WritingStreamer Write(DateTime).)
Public method | Write(Decimal) | (Overrides WritingStreamer Write(Decimal).)
Public method | Write( Decimal ) | (Overrides WritingStreamer Write( Decimal ).)
Public method | Write(Double) | (Overrides WritingStreamer Write(Double).)
Public method | Write( Double ) | (Overrides WritingStreamer Write( Double ).)
Public method | Write(Guid) | (Overrides WritingStreamer Write(Guid).)
Public method | Write(Int16) | (Overrides WritingStreamer Write(Int16).)
Public method | Write(Int32) | (Overrides WritingStreamer Write(Int32).)
Public method | Write( Int32 ) | (Overrides WritingStreamer Write( Int32 ).)
Public method | Write(Int64) | (Overrides WritingStreamer Write(Int64).)
Public method | Write( Int64 ) | (Overrides WritingStreamer Write( Int64 ).)
Public method | Write(Nullable Boolean ) | (Overrides WritingStreamer Write(Nullable Boolean ).)
Public method | Write(Nullable Byte ) | (Overrides WritingStreamer Write(Nullable Byte ).)
Public method | Write(Nullable Char ) | (Overrides WritingStreamer Write(Nullable Char ).)
Public method | Write(Nullable DateTime ) | (Overrides WritingStreamer Write(Nullable DateTime ).)
Public method | Write(Nullable Decimal ) | (Overrides WritingStreamer Write(Nullable Decimal ).)
Public method | Write(Nullable Double ) | (Overrides WritingStreamer Write(Nullable Double ).)
Public method | Write(Nullable Guid ) | (Overrides WritingStreamer Write(Nullable Guid ).)
Public method | Write(Nullable Int16 ) | (Overrides WritingStreamer Write(Nullable Int16 ).)
Public method | Write(Nullable Int32 ) | (Overrides WritingStreamer Write(Nullable Int32 ).)
Public method | Write(Nullable Int64 ) | (Overrides WritingStreamer Write(Nullable Int64 ).)
Public method | Write(Nullable SByte ) | (Overrides WritingStreamer Write(Nullable SByte ).)
Public method | Write(Nullable Single ) | (Overrides WritingStreamer Write(Nullable Single ).)
Public method | Write(Nullable TimeSpan ) | (Overrides WritingStreamer Write(Nullable TimeSpan ).)
Public method | Write(Nullable UInt16 ) | (Overrides WritingStreamer Write(Nullable UInt16 ).)
Public method | Write(Nullable UInt32 ) | (Overrides WritingStreamer Write(Nullable UInt32 ).)
Public method | Write(Nullable UInt64 ) | (Overrides WritingStreamer Write(Nullable UInt64 ).)
Public method | Write(SByte) | (Overrides WritingStreamer Write(SByte).)
Public method | Write(Single) | (Overrides WritingStreamer Write(Single).)
Public method | Write( Single ) | (Overrides WritingStreamer Write( Single ).)
Public method | Write(String) | (Overrides WritingStreamer Write(String).)
Public method | Write( String ) | (Overrides WritingStreamer Write( String ).)
Public method | Write(TimeSpan) | (Overrides WritingStreamer Write(TimeSpan).)
Public method | Write(UInt16) | (Overrides WritingStreamer Write(UInt16).)
Public method | Write(UInt32) | (Overrides WritingStreamer Write(UInt32).)
Public method | Write(UInt64) | (Overrides WritingStreamer Write(UInt64).)
Public method | Write(Amount) | (Overrides WritingStreamer Write(Amount).)
Public method | Write(Nullable Amount ) | (Overrides WritingStreamer Write(Nullable Amount ).)
Public method | Write(FID) | (Overrides WritingStreamer Write(FID).)
Public method | Write(Nullable FID ) | (Overrides WritingStreamer Write(Nullable FID ).)
Public method | Write(GDID) | (Overrides WritingStreamer Write(GDID).)
Public method | Write(Nullable GDID ) | (Overrides WritingStreamer Write(Nullable GDID ).)
Public method | Write(MetaHandle) | (Overrides WritingStreamer Write(MetaHandle).)
Public method | Write(Nullable MetaHandle ) | (Overrides WritingStreamer Write(Nullable MetaHandle ).)
Public method | Write(MethodSpec) | (Overrides WritingStreamer Write(MethodSpec).)
Public method | Write(NLSMap) | (Overrides WritingStreamer Write(NLSMap).)
Public method | Write(Nullable NLSMap ) | (Overrides WritingStreamer Write(Nullable NLSMap ).)
Public method | Write(PilePointer) | (Overrides WritingStreamer Write(PilePointer).)
Public method | Write(Nullable PilePointer ) | (Overrides WritingStreamer Write(Nullable PilePointer ).)
Public method | Write(StringMap) | (Overrides WritingStreamer Write(StringMap).)
Public method | Write(TypeSpec) | (Overrides WritingStreamer Write(TypeSpec).)
Public method | Write(VarIntStr) | (Overrides WritingStreamer Write(VarIntStr).)
Public method | Write(Nullable VarIntStr ) | (Overrides WritingStreamer Write(Nullable VarIntStr ).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Buff32 | (Inherited from Streamer.)
Protected field | m_Encoding | (Inherited from Streamer.)
Protected field | m_Stream | (Inherited from Streamer.)
Back to Top
Properties
 | Name | Description
Public property | Encoding | Returns stream string encoding (Inherited from Streamer.)
Public property | Format | Returns SlimFormat that this writer implements (Overrides Streamer Format.)
Public property | Stream | Returns underlying stream if it is bound or null (Inherited from Streamer.)
Back to Top
See Also
SlimWriter Class
NFX.IO Namespace


SlimWriter Constructor

SlimWriter Constructor NFX Class Library

Initializes a new instance of the SlimWriter class

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal SlimWriter(
    Encoding encoding = null
)
protected internal SlimWriter(
    Encoding encoding = null
)
Protected Friend Sub New (
    Optional encoding As Encoding = Nothing
)
Protected Friend Sub New (
    Optional encoding As Encoding = Nothing
)
protected public:
SlimWriter(
    Encoding^ encoding = nullptr
)
protected public:
SlimWriter(
    Encoding^ encoding = nullptr
)
new :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> SlimWriter
new :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> SlimWriter

Parameters

encoding (Optional)
Type: Online System.Text Encoding
See Also
SlimWriter Class
SlimWriter Members
NFX.IO Namespace


SlimWriter Fields

SlimWriter Fields NFX Class Library

The SlimWriter type exposes the following members.
Fields
 | Name | Description
Protected field | m_Buff32 | (Inherited from Streamer.)
Protected field | m_Encoding | (Inherited from Streamer.)
Protected field | m_Stream | (Inherited from Streamer.)
Back to Top
See Also
SlimWriter Class
NFX.IO Namespace


SlimWriter Methods

SlimWriter Methods NFX Class Library

The SlimWriter type exposes the following members.
Methods
 | Name | Description
Public method | BindStream | Sets the stream as the target for output/input. This call must be coupled with UnbindStream() (Inherited from Streamer.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Overrides WritingStreamer Flush .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UnbindStream | Unbinds the current stream. This call is coupled with BindStream(stream) (Inherited from Streamer.)
Public method | Write(Boolean) | (Overrides WritingStreamer Write(Boolean).)
Public method | Write(Byte) | (Overrides WritingStreamer Write(Byte).)
Public method | Write( Byte ) | (Overrides WritingStreamer Write( Byte ).)
Public method | Write(Char) | (Overrides WritingStreamer Write(Char).)
Public method | Write( Char ) | (Overrides WritingStreamer Write( Char ).)
Public method | Write(DateTime) | (Overrides WritingStreamer Write(DateTime).)
Public method | Write(Decimal) | (Overrides WritingStreamer Write(Decimal).)
Public method | Write( Decimal ) | (Overrides WritingStreamer Write( Decimal ).)
Public method | Write(Double) | (Overrides WritingStreamer Write(Double).)
Public method | Write( Double ) | (Overrides WritingStreamer Write( Double ).)
Public method | Write(Guid) | (Overrides WritingStreamer Write(Guid).)
Public method | Write(Int16) | (Overrides WritingStreamer Write(Int16).)
Public method | Write(Int32) | (Overrides WritingStreamer Write(Int32).)
Public method | Write( Int32 ) | (Overrides WritingStreamer Write( Int32 ).)
Public method | Write(Int64) | (Overrides WritingStreamer Write(Int64).)
Public method | Write( Int64 ) | (Overrides WritingStreamer Write( Int64 ).)
Public method | Write(Nullable Boolean ) | (Overrides WritingStreamer Write(Nullable Boolean ).)
Public method | Write(Nullable Byte ) | (Overrides WritingStreamer Write(Nullable Byte ).)
Public method | Write(Nullable Char ) | (Overrides WritingStreamer Write(Nullable Char ).)
Public method | Write(Nullable DateTime ) | (Overrides WritingStreamer Write(Nullable DateTime ).)
Public method | Write(Nullable Decimal ) | (Overrides WritingStreamer Write(Nullable Decimal ).)
Public method | Write(Nullable Double ) | (Overrides WritingStreamer Write(Nullable Double ).)
Public method | Write(Nullable Guid ) | (Overrides WritingStreamer Write(Nullable Guid ).)
Public method | Write(Nullable Int16 ) | (Overrides WritingStreamer Write(Nullable Int16 ).)
Public method | Write(Nullable Int32 ) | (Overrides WritingStreamer Write(Nullable Int32 ).)
Public method | Write(Nullable Int64 ) | (Overrides WritingStreamer Write(Nullable Int64 ).)
Public method | Write(Nullable SByte ) | (Overrides WritingStreamer Write(Nullable SByte ).)
Public method | Write(Nullable Single ) | (Overrides WritingStreamer Write(Nullable Single ).)
Public method | Write(Nullable TimeSpan ) | (Overrides WritingStreamer Write(Nullable TimeSpan ).)
Public method | Write(Nullable UInt16 ) | (Overrides WritingStreamer Write(Nullable UInt16 ).)
Public method | Write(Nullable UInt32 ) | (Overrides WritingStreamer Write(Nullable UInt32 ).)
Public method | Write(Nullable UInt64 ) | (Overrides WritingStreamer Write(Nullable UInt64 ).)
Public method | Write(SByte) | (Overrides WritingStreamer Write(SByte).)
Public method | Write(Single) | (Overrides WritingStreamer Write(Single).)
Public method | Write( Single ) | (Overrides WritingStreamer Write( Single ).)
Public method | Write(String) | (Overrides WritingStreamer Write(String).)
Public method | Write( String ) | (Overrides WritingStreamer Write( String ).)
Public method | Write(TimeSpan) | (Overrides WritingStreamer Write(TimeSpan).)
Public method | Write(UInt16) | (Overrides WritingStreamer Write(UInt16).)
Public method | Write(UInt32) | (Overrides WritingStreamer Write(UInt32).)
Public method | Write(UInt64) | (Overrides WritingStreamer Write(UInt64).)
Public method | Write(Amount) | (Overrides WritingStreamer Write(Amount).)
Public method | Write(Nullable Amount ) | (Overrides WritingStreamer Write(Nullable Amount ).)
Public method | Write(FID) | (Overrides WritingStreamer Write(FID).)
Public method | Write(Nullable FID ) | (Overrides WritingStreamer Write(Nullable FID ).)
Public method | Write(GDID) | (Overrides WritingStreamer Write(GDID).)
Public method | Write(Nullable GDID ) | (Overrides WritingStreamer Write(Nullable GDID ).)
Public method | Write(MetaHandle) | (Overrides WritingStreamer Write(MetaHandle).)
Public method | Write(Nullable MetaHandle ) | (Overrides WritingStreamer Write(Nullable MetaHandle ).)
Public method | Write(MethodSpec) | (Overrides WritingStreamer Write(MethodSpec).)
Public method | Write(NLSMap) | (Overrides WritingStreamer Write(NLSMap).)
Public method | Write(Nullable NLSMap ) | (Overrides WritingStreamer Write(Nullable NLSMap ).)
Public method | Write(PilePointer) | (Overrides WritingStreamer Write(PilePointer).)
Public method | Write(Nullable PilePointer ) | (Overrides WritingStreamer Write(Nullable PilePointer ).)
Public method | Write(StringMap) | (Overrides WritingStreamer Write(StringMap).)
Public method | Write(TypeSpec) | (Overrides WritingStreamer Write(TypeSpec).)
Public method | Write(VarIntStr) | (Overrides WritingStreamer Write(VarIntStr).)
Public method | Write(Nullable VarIntStr ) | (Overrides WritingStreamer Write(Nullable VarIntStr ).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SlimWriter Class
NFX.IO Namespace


SlimWriter.Flush Method

SlimWriter Flush Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Flush()
public override void Flush()
Public Overrides Sub Flush
Public Overrides Sub Flush
public:
virtual void Flush() override
public:
virtual void Flush() override
abstract Flush : unit -> unit
override Flush : unit -> unit
abstract Flush : unit -> unit
override Flush : unit -> unit
See Also
SlimWriter Class
SlimWriter Members
NFX.IO Namespace


SlimWriter.Write Method

SlimWriter Write Method NFX Class Library

Overload List
 | Name | Description
Public method | Write(Boolean) | (Overrides WritingStreamer Write(Boolean).)
Public method | Write(Byte) | (Overrides WritingStreamer Write(Byte).)
Public method | Write( Byte ) | (Overrides WritingStreamer Write( Byte ).)
Public method | Write(Char) | (Overrides WritingStreamer Write(Char).)
Public method | Write( Char ) | (Overrides WritingStreamer Write( Char ).)
Public method | Write(DateTime) | (Overrides WritingStreamer Write(DateTime).)
Public method | Write(Decimal) | (Overrides WritingStreamer Write(Decimal).)
Public method | Write( Decimal ) | (Overrides WritingStreamer Write( Decimal ).)
Public method | Write(Double) | (Overrides WritingStreamer Write(Double).)
Public method | Write( Double ) | (Overrides WritingStreamer Write( Double ).)
Public method | Write(Guid) | (Overrides WritingStreamer Write(Guid).)
Public method | Write(Int16) | (Overrides WritingStreamer Write(Int16).)
Public method | Write(Int32) | (Overrides WritingStreamer Write(Int32).)
Public method | Write( Int32 ) | (Overrides WritingStreamer Write( Int32 ).)
Public method | Write(Int64) | (Overrides WritingStreamer Write(Int64).)
Public method | Write( Int64 ) | (Overrides WritingStreamer Write( Int64 ).)
Public method | Write(Nullable Boolean ) | (Overrides WritingStreamer Write(Nullable Boolean ).)
Public method | Write(Nullable Byte ) | (Overrides WritingStreamer Write(Nullable Byte ).)
Public method | Write(Nullable Char ) | (Overrides WritingStreamer Write(Nullable Char ).)
Public method | Write(Nullable DateTime ) | (Overrides WritingStreamer Write(Nullable DateTime ).)
Public method | Write(Nullable Decimal ) | (Overrides WritingStreamer Write(Nullable Decimal ).)
Public method | Write(Nullable Double ) | (Overrides WritingStreamer Write(Nullable Double ).)
Public method | Write(Nullable Guid ) | (Overrides WritingStreamer Write(Nullable Guid ).)
Public method | Write(Nullable Int16 ) | (Overrides WritingStreamer Write(Nullable Int16 ).)
Public method | Write(Nullable Int32 ) | (Overrides WritingStreamer Write(Nullable Int32 ).)
Public method | Write(Nullable Int64 ) | (Overrides WritingStreamer Write(Nullable Int64 ).)
Public method | Write(Nullable SByte ) | (Overrides WritingStreamer Write(Nullable SByte ).)
Public method | Write(Nullable Single ) | (Overrides WritingStreamer Write(Nullable Single ).)
Public method | Write(Nullable TimeSpan ) | (Overrides WritingStreamer Write(Nullable TimeSpan ).)
Public method | Write(Nullable UInt16 ) | (Overrides WritingStreamer Write(Nullable UInt16 ).)
Public method | Write(Nullable UInt32 ) | (Overrides WritingStreamer Write(Nullable UInt32 ).)
Public method | Write(Nullable UInt64 ) | (Overrides WritingStreamer Write(Nullable UInt64 ).)
Public method | Write(SByte) | (Overrides WritingStreamer Write(SByte).)
Public method | Write(Single) | (Overrides WritingStreamer Write(Single).)
Public method | Write( Single ) | (Overrides WritingStreamer Write( Single ).)
Public method | Write(String) | (Overrides WritingStreamer Write(String).)
Public method | Write( String ) | (Overrides WritingStreamer Write( String ).)
Public method | Write(TimeSpan) | (Overrides WritingStreamer Write(TimeSpan).)
Public method | Write(UInt16) | (Overrides WritingStreamer Write(UInt16).)
Public method | Write(UInt32) | (Overrides WritingStreamer Write(UInt32).)
Public method | Write(UInt64) | (Overrides WritingStreamer Write(UInt64).)
Public method | Write(Amount) | (Overrides WritingStreamer Write(Amount).)
Public method | Write(Nullable Amount ) | (Overrides WritingStreamer Write(Nullable Amount ).)
Public method | Write(FID) | (Overrides WritingStreamer Write(FID).)
Public method | Write(Nullable FID ) | (Overrides WritingStreamer Write(Nullable FID ).)
Public method | Write(GDID) | (Overrides WritingStreamer Write(GDID).)
Public method | Write(Nullable GDID ) | (Overrides WritingStreamer Write(Nullable GDID ).)
Public method | Write(MetaHandle) | (Overrides WritingStreamer Write(MetaHandle).)
Public method | Write(Nullable MetaHandle ) | (Overrides WritingStreamer Write(Nullable MetaHandle ).)
Public method | Write(MethodSpec) | (Overrides WritingStreamer Write(MethodSpec).)
Public method | Write(NLSMap) | (Overrides WritingStreamer Write(NLSMap).)
Public method | Write(Nullable NLSMap ) | (Overrides WritingStreamer Write(Nullable NLSMap ).)
Public method | Write(PilePointer) | (Overrides WritingStreamer Write(PilePointer).)
Public method | Write(Nullable PilePointer ) | (Overrides WritingStreamer Write(Nullable PilePointer ).)
Public method | Write(StringMap) | (Overrides WritingStreamer Write(StringMap).)
Public method | Write(TypeSpec) | (Overrides WritingStreamer Write(TypeSpec).)
Public method | Write(VarIntStr) | (Overrides WritingStreamer Write(VarIntStr).)
Public method | Write(Nullable VarIntStr ) | (Overrides WritingStreamer Write(Nullable VarIntStr ).)
Back to Top
See Also
SlimWriter Class
SlimWriter Members
NFX.IO Namespace


SlimWriter.Write Method (Boolean)

SlimWriter Write Method (Boolean) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    bool value
)
public override void Write(
    bool value
)
Public Overrides Sub Write (
    value As Boolean
)
Public Overrides Sub Write (
    value As Boolean
)
public:
virtual void Write(
    bool value
) override
public:
virtual void Write(
    bool value
) override
abstract Write :
        value : bool -> unit
override Write :
        value : bool -> unit
abstract Write :
        value : bool -> unit
override Write :
        value : bool -> unit

Parameters

value
Type: Online System Boolean
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Byte)

SlimWriter Write Method (Byte) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    byte value
)
public override void Write(
    byte value
)
Public Overrides Sub Write (
    value As Byte
)
Public Overrides Sub Write (
    value As Byte
)
public:
virtual void Write(
    unsigned char value
) override
public:
virtual void Write(
    unsigned char value
) override
abstract Write :
        value : byte -> unit
override Write :
        value : byte -> unit
abstract Write :
        value : byte -> unit
override Write :
        value : byte -> unit

Parameters

value
Type: Online System Byte
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Byte[])

SlimWriter Write Method ( Byte ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    byte[] buffer
)
public override void Write(
    byte[] buffer
)
Public Overrides Sub Write (
    buffer As Byte()
)
Public Overrides Sub Write (
    buffer As Byte()
)
public:
virtual void Write(
    array<unsigned char>^ buffer
) override
public:
virtual void Write(
    array<unsigned char>^ buffer
) override
abstract Write :
        buffer : byte[] -> unit
override Write :
        buffer : byte[] -> unit
abstract Write :
        buffer : byte[] -> unit
override Write :
        buffer : byte[] -> unit

Parameters

buffer
Type: Online System Byte
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Char)

SlimWriter Write Method (Char) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    char ch
)
public override void Write(
    char ch
)
Public Overrides Sub Write (
    ch As Char
)
Public Overrides Sub Write (
    ch As Char
)
public:
virtual void Write(
    wchar_t ch
) override
public:
virtual void Write(
    wchar_t ch
) override
abstract Write :
        ch : char -> unit
override Write :
        ch : char -> unit
abstract Write :
        ch : char -> unit
override Write :
        ch : char -> unit

Parameters

ch
Type: Online System Char
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Char[])

SlimWriter Write Method ( Char ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    char[] buffer
)
public override void Write(
    char[] buffer
)
Public Overrides Sub Write (
    buffer As Char()
)
Public Overrides Sub Write (
    buffer As Char()
)
public:
virtual void Write(
    array<wchar_t>^ buffer
) override
public:
virtual void Write(
    array<wchar_t>^ buffer
) override
abstract Write :
        buffer : char[] -> unit
override Write :
        buffer : char[] -> unit
abstract Write :
        buffer : char[] -> unit
override Write :
        buffer : char[] -> unit

Parameters

buffer
Type: Online System Char
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (DateTime)

SlimWriter Write Method (DateTime) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    DateTime value
)
public override void Write(
    DateTime value
)
Public Overrides Sub Write (
    value As DateTime
)
Public Overrides Sub Write (
    value As DateTime
)
public:
virtual void Write(
    DateTime value
) override
public:
virtual void Write(
    DateTime value
) override
abstract Write :
        value : DateTime -> unit
override Write :
        value : DateTime -> unit
abstract Write :
        value : DateTime -> unit
override Write :
        value : DateTime -> unit

Parameters

value
Type: Online System DateTime
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Decimal)

SlimWriter Write Method (Decimal) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    decimal value
)
public override void Write(
    decimal value
)
Public Overrides Sub Write (
    value As Decimal
)
Public Overrides Sub Write (
    value As Decimal
)
public:
virtual void Write(
    Decimal value
) override
public:
virtual void Write(
    Decimal value
) override
abstract Write :
        value : decimal -> unit
override Write :
        value : decimal -> unit
abstract Write :
        value : decimal -> unit
override Write :
        value : decimal -> unit

Parameters

value
Type: Online System Decimal
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Decimal[])

SlimWriter Write Method ( Decimal ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    decimal[] value
)
public override void Write(
    decimal[] value
)
Public Overrides Sub Write (
    value As Decimal()
)
Public Overrides Sub Write (
    value As Decimal()
)
public:
virtual void Write(
    array<Decimal>^ value
) override
public:
virtual void Write(
    array<Decimal>^ value
) override
abstract Write :
        value : decimal[] -> unit
override Write :
        value : decimal[] -> unit
abstract Write :
        value : decimal[] -> unit
override Write :
        value : decimal[] -> unit

Parameters

value
Type: Online System Decimal
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Double)

SlimWriter Write Method (Double) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    double value
)
public override void Write(
    double value
)
Public Overrides Sub Write (
    value As Double
)
Public Overrides Sub Write (
    value As Double
)
public:
virtual void Write(
    double value
) override
public:
virtual void Write(
    double value
) override
abstract Write :
        value : float -> unit
override Write :
        value : float -> unit
abstract Write :
        value : float -> unit
override Write :
        value : float -> unit

Parameters

value
Type: Online System Double
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Double[])

SlimWriter Write Method ( Double ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    double[] value
)
public override void Write(
    double[] value
)
Public Overrides Sub Write (
    value As Double()
)
Public Overrides Sub Write (
    value As Double()
)
public:
virtual void Write(
    array<double>^ value
) override
public:
virtual void Write(
    array<double>^ value
) override
abstract Write :
        value : float[] -> unit
override Write :
        value : float[] -> unit
abstract Write :
        value : float[] -> unit
override Write :
        value : float[] -> unit

Parameters

value
Type: Online System Double
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Guid)

SlimWriter Write Method (Guid) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Guid value
)
public override void Write(
    Guid value
)
Public Overrides Sub Write (
    value As Guid
)
Public Overrides Sub Write (
    value As Guid
)
public:
virtual void Write(
    Guid value
) override
public:
virtual void Write(
    Guid value
) override
abstract Write :
        value : Guid -> unit
override Write :
        value : Guid -> unit
abstract Write :
        value : Guid -> unit
override Write :
        value : Guid -> unit

Parameters

value
Type: Online System Guid
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Int16)

SlimWriter Write Method (Int16) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    short value
)
public override void Write(
    short value
)
Public Overrides Sub Write (
    value As Short
)
Public Overrides Sub Write (
    value As Short
)
public:
virtual void Write(
    short value
) override
public:
virtual void Write(
    short value
) override
abstract Write :
        value : int16 -> unit
override Write :
        value : int16 -> unit
abstract Write :
        value : int16 -> unit
override Write :
        value : int16 -> unit

Parameters

value
Type: Online System Int16
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Int32)

SlimWriter Write Method (Int32) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    int value
)
public override void Write(
    int value
)
Public Overrides Sub Write (
    value As Integer
)
Public Overrides Sub Write (
    value As Integer
)
public:
virtual void Write(
    int value
) override
public:
virtual void Write(
    int value
) override
abstract Write :
        value : int -> unit
override Write :
        value : int -> unit
abstract Write :
        value : int -> unit
override Write :
        value : int -> unit

Parameters

value
Type: Online System Int32
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Int32[])

SlimWriter Write Method ( Int32 ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    int[] value
)
public override void Write(
    int[] value
)
Public Overrides Sub Write (
    value As Integer()
)
Public Overrides Sub Write (
    value As Integer()
)
public:
virtual void Write(
    array<int>^ value
) override
public:
virtual void Write(
    array<int>^ value
) override
abstract Write :
        value : int[] -> unit
override Write :
        value : int[] -> unit
abstract Write :
        value : int[] -> unit
override Write :
        value : int[] -> unit

Parameters

value
Type: Online System Int32
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Int64)

SlimWriter Write Method (Int64) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    long value
)
public override void Write(
    long value
)
Public Overrides Sub Write (
    value As Long
)
Public Overrides Sub Write (
    value As Long
)
public:
virtual void Write(
    long long value
) override
public:
virtual void Write(
    long long value
) override
abstract Write :
        value : int64 -> unit
override Write :
        value : int64 -> unit
abstract Write :
        value : int64 -> unit
override Write :
        value : int64 -> unit

Parameters

value
Type: Online System Int64
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Int64[])

SlimWriter Write Method ( Int64 ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    long[] value
)
public override void Write(
    long[] value
)
Public Overrides Sub Write (
    value As Long()
)
Public Overrides Sub Write (
    value As Long()
)
public:
virtual void Write(
    array<long long>^ value
) override
public:
virtual void Write(
    array<long long>^ value
) override
abstract Write :
        value : int64[] -> unit
override Write :
        value : int64[] -> unit
abstract Write :
        value : int64[] -> unit
override Write :
        value : int64[] -> unit

Parameters

value
Type: Online System Int64
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Nullable(Boolean))

SlimWriter Write Method (Nullable Boolean ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Nullable<bool> value
)
public override void Write(
    Nullable<bool> value
)
Public Overrides Sub Write (
    value As Nullable(Of Boolean)
)
Public Overrides Sub Write (
    value As Nullable(Of Boolean)
)
public:
virtual void Write(
    Nullable<bool> value
) override
public:
virtual void Write(
    Nullable<bool> value
) override
abstract Write :
        value : Nullable<bool> -> unit
override Write :
        value : Nullable<bool> -> unit
abstract Write :
        value : Nullable<bool> -> unit
override Write :
        value : Nullable<bool> -> unit

Parameters

value
Type: Online System Nullable Online Boolean
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Nullable(Byte))

SlimWriter Write Method (Nullable Byte ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Nullable<byte> value
)
public override void Write(
    Nullable<byte> value
)
Public Overrides Sub Write (
    value As Nullable(Of Byte)
)
Public Overrides Sub Write (
    value As Nullable(Of Byte)
)
public:
virtual void Write(
    Nullable<unsigned char> value
) override
public:
virtual void Write(
    Nullable<unsigned char> value
) override
abstract Write :
        value : Nullable<byte> -> unit
override Write :
        value : Nullable<byte> -> unit
abstract Write :
        value : Nullable<byte> -> unit
override Write :
        value : Nullable<byte> -> unit

Parameters

value
Type: Online System Nullable Online Byte
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Nullable(Char))

SlimWriter Write Method (Nullable Char ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Nullable<char> value
)
public override void Write(
    Nullable<char> value
)
Public Overrides Sub Write (
    value As Nullable(Of Char)
)
Public Overrides Sub Write (
    value As Nullable(Of Char)
)
public:
virtual void Write(
    Nullable<wchar_t> value
) override
public:
virtual void Write(
    Nullable<wchar_t> value
) override
abstract Write :
        value : Nullable<char> -> unit
override Write :
        value : Nullable<char> -> unit
abstract Write :
        value : Nullable<char> -> unit
override Write :
        value : Nullable<char> -> unit

Parameters

value
Type: Online System Nullable Online Char
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Nullable(DateTime))

SlimWriter Write Method (Nullable DateTime ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Nullable<DateTime> value
)
public override void Write(
    Nullable<DateTime> value
)
Public Overrides Sub Write (
    value As Nullable(Of DateTime)
)
Public Overrides Sub Write (
    value As Nullable(Of DateTime)
)
public:
virtual void Write(
    Nullable<DateTime> value
) override
public:
virtual void Write(
    Nullable<DateTime> value
) override
abstract Write :
        value : Nullable<DateTime> -> unit
override Write :
        value : Nullable<DateTime> -> unit
abstract Write :
        value : Nullable<DateTime> -> unit
override Write :
        value : Nullable<DateTime> -> unit

Parameters

value
Type: Online System Nullable Online DateTime
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Nullable(Decimal))

SlimWriter Write Method (Nullable Decimal ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Nullable<decimal> value
)
public override void Write(
    Nullable<decimal> value
)
Public Overrides Sub Write (
    value As Nullable(Of Decimal)
)
Public Overrides Sub Write (
    value As Nullable(Of Decimal)
)
public:
virtual void Write(
    Nullable<Decimal> value
) override
public:
virtual void Write(
    Nullable<Decimal> value
) override
abstract Write :
        value : Nullable<decimal> -> unit
override Write :
        value : Nullable<decimal> -> unit
abstract Write :
        value : Nullable<decimal> -> unit
override Write :
        value : Nullable<decimal> -> unit

Parameters

value
Type: Online System Nullable Online Decimal
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Nullable(Double))

SlimWriter Write Method (Nullable Double ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Nullable<double> value
)
public override void Write(
    Nullable<double> value
)
Public Overrides Sub Write (
    value As Nullable(Of Double)
)
Public Overrides Sub Write (
    value As Nullable(Of Double)
)
public:
virtual void Write(
    Nullable<double> value
) override
public:
virtual void Write(
    Nullable<double> value
) override
abstract Write :
        value : Nullable<float> -> unit
override Write :
        value : Nullable<float> -> unit
abstract Write :
        value : Nullable<float> -> unit
override Write :
        value : Nullable<float> -> unit

Parameters

value
Type: Online System Nullable Online Double
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Nullable(Guid))

SlimWriter Write Method (Nullable Guid ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Nullable<Guid> value
)
public override void Write(
    Nullable<Guid> value
)
Public Overrides Sub Write (
    value As Nullable(Of Guid)
)
Public Overrides Sub Write (
    value As Nullable(Of Guid)
)
public:
virtual void Write(
    Nullable<Guid> value
) override
public:
virtual void Write(
    Nullable<Guid> value
) override
abstract Write :
        value : Nullable<Guid> -> unit
override Write :
        value : Nullable<Guid> -> unit
abstract Write :
        value : Nullable<Guid> -> unit
override Write :
        value : Nullable<Guid> -> unit

Parameters

value
Type: Online System Nullable Online Guid
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Nullable(Int16))

SlimWriter Write Method (Nullable Int16 ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Nullable<short> value
)
public override void Write(
    Nullable<short> value
)
Public Overrides Sub Write (
    value As Nullable(Of Short)
)
Public Overrides Sub Write (
    value As Nullable(Of Short)
)
public:
virtual void Write(
    Nullable<short> value
) override
public:
virtual void Write(
    Nullable<short> value
) override
abstract Write :
        value : Nullable<int16> -> unit
override Write :
        value : Nullable<int16> -> unit
abstract Write :
        value : Nullable<int16> -> unit
override Write :
        value : Nullable<int16> -> unit

Parameters

value
Type: Online System Nullable Online Int16
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Nullable(Int32))

SlimWriter Write Method (Nullable Int32 ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Nullable<int> value
)
public override void Write(
    Nullable<int> value
)
Public Overrides Sub Write (
    value As Nullable(Of Integer)
)
Public Overrides Sub Write (
    value As Nullable(Of Integer)
)
public:
virtual void Write(
    Nullable<int> value
) override
public:
virtual void Write(
    Nullable<int> value
) override
abstract Write :
        value : Nullable<int> -> unit
override Write :
        value : Nullable<int> -> unit
abstract Write :
        value : Nullable<int> -> unit
override Write :
        value : Nullable<int> -> unit

Parameters

value
Type: Online System Nullable Online Int32
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Nullable(Int64))

SlimWriter Write Method (Nullable Int64 ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Nullable<long> value
)
public override void Write(
    Nullable<long> value
)
Public Overrides Sub Write (
    value As Nullable(Of Long)
)
Public Overrides Sub Write (
    value As Nullable(Of Long)
)
public:
virtual void Write(
    Nullable<long long> value
) override
public:
virtual void Write(
    Nullable<long long> value
) override
abstract Write :
        value : Nullable<int64> -> unit
override Write :
        value : Nullable<int64> -> unit
abstract Write :
        value : Nullable<int64> -> unit
override Write :
        value : Nullable<int64> -> unit

Parameters

value
Type: Online System Nullable Online Int64
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Nullable(SByte))

SlimWriter Write Method (Nullable SByte ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Nullable<sbyte> value
)
public override void Write(
    Nullable<sbyte> value
)
Public Overrides Sub Write (
    value As Nullable(Of SByte)
)
Public Overrides Sub Write (
    value As Nullable(Of SByte)
)
public:
virtual void Write(
    Nullable<signed char> value
) override
public:
virtual void Write(
    Nullable<signed char> value
) override
abstract Write :
        value : Nullable<sbyte> -> unit
override Write :
        value : Nullable<sbyte> -> unit
abstract Write :
        value : Nullable<sbyte> -> unit
override Write :
        value : Nullable<sbyte> -> unit

Parameters

value
Type: Online System Nullable Online SByte
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Nullable(Single))

SlimWriter Write Method (Nullable Single ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Nullable<float> value
)
public override void Write(
    Nullable<float> value
)
Public Overrides Sub Write (
    value As Nullable(Of Single)
)
Public Overrides Sub Write (
    value As Nullable(Of Single)
)
public:
virtual void Write(
    Nullable<float> value
) override
public:
virtual void Write(
    Nullable<float> value
) override
abstract Write :
        value : Nullable<float32> -> unit
override Write :
        value : Nullable<float32> -> unit
abstract Write :
        value : Nullable<float32> -> unit
override Write :
        value : Nullable<float32> -> unit

Parameters

value
Type: Online System Nullable Online Single
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Nullable(TimeSpan))

SlimWriter Write Method (Nullable TimeSpan ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Nullable<TimeSpan> value
)
public override void Write(
    Nullable<TimeSpan> value
)
Public Overrides Sub Write (
    value As Nullable(Of TimeSpan)
)
Public Overrides Sub Write (
    value As Nullable(Of TimeSpan)
)
public:
virtual void Write(
    Nullable<TimeSpan> value
) override
public:
virtual void Write(
    Nullable<TimeSpan> value
) override
abstract Write :
        value : Nullable<TimeSpan> -> unit
override Write :
        value : Nullable<TimeSpan> -> unit
abstract Write :
        value : Nullable<TimeSpan> -> unit
override Write :
        value : Nullable<TimeSpan> -> unit

Parameters

value
Type: Online System Nullable Online TimeSpan
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Nullable(UInt16))

SlimWriter Write Method (Nullable UInt16 ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Nullable<ushort> value
)
public override void Write(
    Nullable<ushort> value
)
Public Overrides Sub Write (
    value As Nullable(Of UShort)
)
Public Overrides Sub Write (
    value As Nullable(Of UShort)
)
public:
virtual void Write(
    Nullable<unsigned short> value
) override
public:
virtual void Write(
    Nullable<unsigned short> value
) override
abstract Write :
        value : Nullable<uint16> -> unit
override Write :
        value : Nullable<uint16> -> unit
abstract Write :
        value : Nullable<uint16> -> unit
override Write :
        value : Nullable<uint16> -> unit

Parameters

value
Type: Online System Nullable Online UInt16
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Nullable(UInt32))

SlimWriter Write Method (Nullable UInt32 ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Nullable<uint> value
)
public override void Write(
    Nullable<uint> value
)
Public Overrides Sub Write (
    value As Nullable(Of UInteger)
)
Public Overrides Sub Write (
    value As Nullable(Of UInteger)
)
public:
virtual void Write(
    Nullable<unsigned int> value
) override
public:
virtual void Write(
    Nullable<unsigned int> value
) override
abstract Write :
        value : Nullable<uint32> -> unit
override Write :
        value : Nullable<uint32> -> unit
abstract Write :
        value : Nullable<uint32> -> unit
override Write :
        value : Nullable<uint32> -> unit

Parameters

value
Type: Online System Nullable Online UInt32
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Nullable(UInt64))

SlimWriter Write Method (Nullable UInt64 ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Nullable<ulong> value
)
public override void Write(
    Nullable<ulong> value
)
Public Overrides Sub Write (
    value As Nullable(Of ULong)
)
Public Overrides Sub Write (
    value As Nullable(Of ULong)
)
public:
virtual void Write(
    Nullable<unsigned long long> value
) override
public:
virtual void Write(
    Nullable<unsigned long long> value
) override
abstract Write :
        value : Nullable<uint64> -> unit
override Write :
        value : Nullable<uint64> -> unit
abstract Write :
        value : Nullable<uint64> -> unit
override Write :
        value : Nullable<uint64> -> unit

Parameters

value
Type: Online System Nullable Online UInt64
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (SByte)

SlimWriter Write Method (SByte) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    sbyte value
)
public override void Write(
    sbyte value
)
Public Overrides Sub Write (
    value As SByte
)
Public Overrides Sub Write (
    value As SByte
)
public:
virtual void Write(
    signed char value
) override
public:
virtual void Write(
    signed char value
) override
abstract Write :
        value : sbyte -> unit
override Write :
        value : sbyte -> unit
abstract Write :
        value : sbyte -> unit
override Write :
        value : sbyte -> unit

Parameters

value
Type: Online System SByte
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Single)

SlimWriter Write Method (Single) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    float value
)
public override void Write(
    float value
)
Public Overrides Sub Write (
    value As Single
)
Public Overrides Sub Write (
    value As Single
)
public:
virtual void Write(
    float value
) override
public:
virtual void Write(
    float value
) override
abstract Write :
        value : float32 -> unit
override Write :
        value : float32 -> unit
abstract Write :
        value : float32 -> unit
override Write :
        value : float32 -> unit

Parameters

value
Type: Online System Single
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Single[])

SlimWriter Write Method ( Single ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    float[] value
)
public override void Write(
    float[] value
)
Public Overrides Sub Write (
    value As Single()
)
Public Overrides Sub Write (
    value As Single()
)
public:
virtual void Write(
    array<float>^ value
) override
public:
virtual void Write(
    array<float>^ value
) override
abstract Write :
        value : float32[] -> unit
override Write :
        value : float32[] -> unit
abstract Write :
        value : float32[] -> unit
override Write :
        value : float32[] -> unit

Parameters

value
Type: Online System Single
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (String)

SlimWriter Write Method (String) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    string value
)
public override void Write(
    string value
)
Public Overrides Sub Write (
    value As String
)
Public Overrides Sub Write (
    value As String
)
public:
virtual void Write(
    String^ value
) override
public:
virtual void Write(
    String^ value
) override
abstract Write :
        value : string -> unit
override Write :
        value : string -> unit
abstract Write :
        value : string -> unit
override Write :
        value : string -> unit

Parameters

value
Type: Online System String
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (String[])

SlimWriter Write Method ( String ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    string[] array
)
public override void Write(
    string[] array
)
Public Overrides Sub Write (
    array As String()
)
Public Overrides Sub Write (
    array As String()
)
public:
virtual void Write(
    array<String^>^ array
) override
public:
virtual void Write(
    array<String^>^ array
) override
abstract Write :
        array : string[] -> unit
override Write :
        array : string[] -> unit
abstract Write :
        array : string[] -> unit
override Write :
        array : string[] -> unit

Parameters

array
Type: Online System String
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (TimeSpan)

SlimWriter Write Method (TimeSpan) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    TimeSpan value
)
public override void Write(
    TimeSpan value
)
Public Overrides Sub Write (
    value As TimeSpan
)
Public Overrides Sub Write (
    value As TimeSpan
)
public:
virtual void Write(
    TimeSpan value
) override
public:
virtual void Write(
    TimeSpan value
) override
abstract Write :
        value : TimeSpan -> unit
override Write :
        value : TimeSpan -> unit
abstract Write :
        value : TimeSpan -> unit
override Write :
        value : TimeSpan -> unit

Parameters

value
Type: Online System TimeSpan
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (UInt16)

SlimWriter Write Method (UInt16) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    ushort value
)
public override void Write(
    ushort value
)
Public Overrides Sub Write (
    value As UShort
)
Public Overrides Sub Write (
    value As UShort
)
public:
virtual void Write(
    unsigned short value
) override
public:
virtual void Write(
    unsigned short value
) override
abstract Write :
        value : uint16 -> unit
override Write :
        value : uint16 -> unit
abstract Write :
        value : uint16 -> unit
override Write :
        value : uint16 -> unit

Parameters

value
Type: Online System UInt16
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (UInt32)

SlimWriter Write Method (UInt32) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    uint value
)
public override void Write(
    uint value
)
Public Overrides Sub Write (
    value As UInteger
)
Public Overrides Sub Write (
    value As UInteger
)
public:
virtual void Write(
    unsigned int value
) override
public:
virtual void Write(
    unsigned int value
) override
abstract Write :
        value : uint32 -> unit
override Write :
        value : uint32 -> unit
abstract Write :
        value : uint32 -> unit
override Write :
        value : uint32 -> unit

Parameters

value
Type: Online System UInt32
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (UInt64)

SlimWriter Write Method (UInt64) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    ulong value
)
public override void Write(
    ulong value
)
Public Overrides Sub Write (
    value As ULong
)
Public Overrides Sub Write (
    value As ULong
)
public:
virtual void Write(
    unsigned long long value
) override
public:
virtual void Write(
    unsigned long long value
) override
abstract Write :
        value : uint64 -> unit
override Write :
        value : uint64 -> unit
abstract Write :
        value : uint64 -> unit
override Write :
        value : uint64 -> unit

Parameters

value
Type: Online System UInt64
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Amount)

SlimWriter Write Method (Amount) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Amount value
)
public override void Write(
    Amount value
)
Public Overrides Sub Write (
    value As Amount
)
Public Overrides Sub Write (
    value As Amount
)
public:
virtual void Write(
    Amount value
) override
public:
virtual void Write(
    Amount value
) override
abstract Write :
        value : Amount -> unit
override Write :
        value : Amount -> unit
abstract Write :
        value : Amount -> unit
override Write :
        value : Amount -> unit

Parameters

value
Type: NFX.Financial Amount
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Nullable(Amount))

SlimWriter Write Method (Nullable Amount ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Nullable<Amount> value
)
public override void Write(
    Nullable<Amount> value
)
Public Overrides Sub Write (
    value As Nullable(Of Amount)
)
Public Overrides Sub Write (
    value As Nullable(Of Amount)
)
public:
virtual void Write(
    Nullable<Amount> value
) override
public:
virtual void Write(
    Nullable<Amount> value
) override
abstract Write :
        value : Nullable<Amount> -> unit
override Write :
        value : Nullable<Amount> -> unit
abstract Write :
        value : Nullable<Amount> -> unit
override Write :
        value : Nullable<Amount> -> unit

Parameters

value
Type: Online System Nullable Amount
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (FID)

SlimWriter Write Method (FID) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    FID value
)
public override void Write(
    FID value
)
Public Overrides Sub Write (
    value As FID
)
Public Overrides Sub Write (
    value As FID
)
public:
virtual void Write(
    FID value
) override
public:
virtual void Write(
    FID value
) override
abstract Write :
        value : FID -> unit
override Write :
        value : FID -> unit
abstract Write :
        value : FID -> unit
override Write :
        value : FID -> unit

Parameters

value
Type: NFX FID
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Nullable(FID))

SlimWriter Write Method (Nullable FID ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Nullable<FID> value
)
public override void Write(
    Nullable<FID> value
)
Public Overrides Sub Write (
    value As Nullable(Of FID)
)
Public Overrides Sub Write (
    value As Nullable(Of FID)
)
public:
virtual void Write(
    Nullable<FID> value
) override
public:
virtual void Write(
    Nullable<FID> value
) override
abstract Write :
        value : Nullable<FID> -> unit
override Write :
        value : Nullable<FID> -> unit
abstract Write :
        value : Nullable<FID> -> unit
override Write :
        value : Nullable<FID> -> unit

Parameters

value
Type: Online System Nullable FID
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (GDID)

SlimWriter Write Method (GDID) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    GDID value
)
public override void Write(
    GDID value
)
Public Overrides Sub Write (
    value As GDID
)
Public Overrides Sub Write (
    value As GDID
)
public:
virtual void Write(
    GDID value
) override
public:
virtual void Write(
    GDID value
) override
abstract Write :
        value : GDID -> unit
override Write :
        value : GDID -> unit
abstract Write :
        value : GDID -> unit
override Write :
        value : GDID -> unit

Parameters

value
Type: NFX.DataAccess.Distributed GDID
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Nullable(GDID))

SlimWriter Write Method (Nullable GDID ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Nullable<GDID> value
)
public override void Write(
    Nullable<GDID> value
)
Public Overrides Sub Write (
    value As Nullable(Of GDID)
)
Public Overrides Sub Write (
    value As Nullable(Of GDID)
)
public:
virtual void Write(
    Nullable<GDID> value
) override
public:
virtual void Write(
    Nullable<GDID> value
) override
abstract Write :
        value : Nullable<GDID> -> unit
override Write :
        value : Nullable<GDID> -> unit
abstract Write :
        value : Nullable<GDID> -> unit
override Write :
        value : Nullable<GDID> -> unit

Parameters

value
Type: Online System Nullable GDID
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (MetaHandle)

SlimWriter Write Method (MetaHandle) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    MetaHandle value
)
public override void Write(
    MetaHandle value
)
Public Overrides Sub Write (
    value As MetaHandle
)
Public Overrides Sub Write (
    value As MetaHandle
)
public:
virtual void Write(
    MetaHandle value
) override
public:
virtual void Write(
    MetaHandle value
) override
abstract Write :
        value : MetaHandle -> unit
override Write :
        value : MetaHandle -> unit
abstract Write :
        value : MetaHandle -> unit
override Write :
        value : MetaHandle -> unit

Parameters

value
Type: NFX.IO MetaHandle
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Nullable(MetaHandle))

SlimWriter Write Method (Nullable MetaHandle ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Nullable<MetaHandle> value
)
public override void Write(
    Nullable<MetaHandle> value
)
Public Overrides Sub Write (
    value As Nullable(Of MetaHandle)
)
Public Overrides Sub Write (
    value As Nullable(Of MetaHandle)
)
public:
virtual void Write(
    Nullable<MetaHandle> value
) override
public:
virtual void Write(
    Nullable<MetaHandle> value
) override
abstract Write :
        value : Nullable<MetaHandle> -> unit
override Write :
        value : Nullable<MetaHandle> -> unit
abstract Write :
        value : Nullable<MetaHandle> -> unit
override Write :
        value : Nullable<MetaHandle> -> unit

Parameters

value
Type: Online System Nullable MetaHandle
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (MethodSpec)

SlimWriter Write Method (MethodSpec) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    MethodSpec spec
)
public override void Write(
    MethodSpec spec
)
Public Overrides Sub Write (
    spec As MethodSpec
)
Public Overrides Sub Write (
    spec As MethodSpec
)
public:
virtual void Write(
    MethodSpec spec
) override
public:
virtual void Write(
    MethodSpec spec
) override
abstract Write :
        spec : MethodSpec -> unit
override Write :
        spec : MethodSpec -> unit
abstract Write :
        spec : MethodSpec -> unit
override Write :
        spec : MethodSpec -> unit

Parameters

spec
Type: NFX.Glue.Protocol MethodSpec
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (NLSMap)

SlimWriter Write Method (NLSMap) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    NLSMap map
)
public override void Write(
    NLSMap map
)
Public Overrides Sub Write (
    map As NLSMap
)
Public Overrides Sub Write (
    map As NLSMap
)
public:
virtual void Write(
    NLSMap map
) override
public:
virtual void Write(
    NLSMap map
) override
abstract Write :
        map : NLSMap -> unit
override Write :
        map : NLSMap -> unit
abstract Write :
        map : NLSMap -> unit
override Write :
        map : NLSMap -> unit

Parameters

map
Type: NFX.Serialization.JSON NLSMap
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Nullable(NLSMap))

SlimWriter Write Method (Nullable NLSMap ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Nullable<NLSMap> value
)
public override void Write(
    Nullable<NLSMap> value
)
Public Overrides Sub Write (
    value As Nullable(Of NLSMap)
)
Public Overrides Sub Write (
    value As Nullable(Of NLSMap)
)
public:
virtual void Write(
    Nullable<NLSMap> value
) override
public:
virtual void Write(
    Nullable<NLSMap> value
) override
abstract Write :
        value : Nullable<NLSMap> -> unit
override Write :
        value : Nullable<NLSMap> -> unit
abstract Write :
        value : Nullable<NLSMap> -> unit
override Write :
        value : Nullable<NLSMap> -> unit

Parameters

value
Type: Online System Nullable NLSMap
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (PilePointer)

SlimWriter Write Method (PilePointer) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    PilePointer value
)
public override void Write(
    PilePointer value
)
Public Overrides Sub Write (
    value As PilePointer
)
Public Overrides Sub Write (
    value As PilePointer
)
public:
virtual void Write(
    PilePointer value
) override
public:
virtual void Write(
    PilePointer value
) override
abstract Write :
        value : PilePointer -> unit
override Write :
        value : PilePointer -> unit
abstract Write :
        value : PilePointer -> unit
override Write :
        value : PilePointer -> unit

Parameters

value
Type: NFX.ApplicationModel.Pile PilePointer
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Nullable(PilePointer))

SlimWriter Write Method (Nullable PilePointer ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Nullable<PilePointer> value
)
public override void Write(
    Nullable<PilePointer> value
)
Public Overrides Sub Write (
    value As Nullable(Of PilePointer)
)
Public Overrides Sub Write (
    value As Nullable(Of PilePointer)
)
public:
virtual void Write(
    Nullable<PilePointer> value
) override
public:
virtual void Write(
    Nullable<PilePointer> value
) override
abstract Write :
        value : Nullable<PilePointer> -> unit
override Write :
        value : Nullable<PilePointer> -> unit
abstract Write :
        value : Nullable<PilePointer> -> unit
override Write :
        value : Nullable<PilePointer> -> unit

Parameters

value
Type: Online System Nullable PilePointer
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (StringMap)

SlimWriter Write Method (StringMap) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    StringMap map
)
public override void Write(
    StringMap map
)
Public Overrides Sub Write (
    map As StringMap
)
Public Overrides Sub Write (
    map As StringMap
)
public:
virtual void Write(
    StringMap^ map
) override
public:
virtual void Write(
    StringMap^ map
) override
abstract Write :
        map : StringMap -> unit
override Write :
        map : StringMap -> unit
abstract Write :
        map : StringMap -> unit
override Write :
        map : StringMap -> unit

Parameters

map
Type: NFX.Collections StringMap
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (TypeSpec)

SlimWriter Write Method (TypeSpec) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    TypeSpec spec
)
public override void Write(
    TypeSpec spec
)
Public Overrides Sub Write (
    spec As TypeSpec
)
Public Overrides Sub Write (
    spec As TypeSpec
)
public:
virtual void Write(
    TypeSpec spec
) override
public:
virtual void Write(
    TypeSpec spec
) override
abstract Write :
        spec : TypeSpec -> unit
override Write :
        spec : TypeSpec -> unit
abstract Write :
        spec : TypeSpec -> unit
override Write :
        spec : TypeSpec -> unit

Parameters

spec
Type: NFX.Glue.Protocol TypeSpec
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (VarIntStr)

SlimWriter Write Method (VarIntStr) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    VarIntStr value
)
public override void Write(
    VarIntStr value
)
Public Overrides Sub Write (
    value As VarIntStr
)
Public Overrides Sub Write (
    value As VarIntStr
)
public:
virtual void Write(
    VarIntStr value
) override
public:
virtual void Write(
    VarIntStr value
) override
abstract Write :
        value : VarIntStr -> unit
override Write :
        value : VarIntStr -> unit
abstract Write :
        value : VarIntStr -> unit
override Write :
        value : VarIntStr -> unit

Parameters

value
Type: NFX.IO VarIntStr
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter.Write Method (Nullable(VarIntStr))

SlimWriter Write Method (Nullable VarIntStr ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    Nullable<VarIntStr> value
)
public override void Write(
    Nullable<VarIntStr> value
)
Public Overrides Sub Write (
    value As Nullable(Of VarIntStr)
)
Public Overrides Sub Write (
    value As Nullable(Of VarIntStr)
)
public:
virtual void Write(
    Nullable<VarIntStr> value
) override
public:
virtual void Write(
    Nullable<VarIntStr> value
) override
abstract Write :
        value : Nullable<VarIntStr> -> unit
override Write :
        value : Nullable<VarIntStr> -> unit
abstract Write :
        value : Nullable<VarIntStr> -> unit
override Write :
        value : Nullable<VarIntStr> -> unit

Parameters

value
Type: Online System Nullable VarIntStr
See Also
SlimWriter Class
SlimWriter Members
Write Overload
NFX.IO Namespace


SlimWriter Properties

SlimWriter Properties NFX Class Library

The SlimWriter type exposes the following members.
Properties
 | Name | Description
Public property | Encoding | Returns stream string encoding (Inherited from Streamer.)
Public property | Format | Returns SlimFormat that this writer implements (Overrides Streamer Format.)
Public property | Stream | Returns underlying stream if it is bound or null (Inherited from Streamer.)
Back to Top
See Also
SlimWriter Class
NFX.IO Namespace


SlimWriter.Format Property

SlimWriter Format Property NFX Class Library

Returns SlimFormat that this writer implements

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override StreamerFormat Format { get; }
public override StreamerFormat Format { get; }
Public Overrides ReadOnly Property Format As StreamerFormat
    Get
Public Overrides ReadOnly Property Format As StreamerFormat
    Get
public:
virtual property StreamerFormat^ Format {
    StreamerFormat^ get () override;
}
public:
virtual property StreamerFormat^ Format {
    StreamerFormat^ get () override;
}
abstract Format : StreamerFormat with get
override Format : StreamerFormat with get
abstract Format : StreamerFormat with get
override Format : StreamerFormat with get

Property Value

Type: StreamerFormat
See Also
SlimWriter Class
SlimWriter Members
NFX.IO Namespace


Streamer Class

Streamer Class NFX Class Library

Represents a base for stream readers and writers. Streamer object instances ARE NOT THREAD-safe
Inheritance Hierarchy
Online System Object
NFX.IO Streamer
NFX.IO ReadingStreamer
NFX.IO WritingStreamer

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Streamer
public abstract class Streamer
Public MustInherit Class Streamer
Public MustInherit Class Streamer
public ref class Streamer abstract
public ref class Streamer abstract
[<AbstractClassAttribute>]
type Streamer =  class end
[<AbstractClassAttribute>]
type Streamer =  class end
See Also
Streamer Members
NFX.IO Namespace


Streamer Members

Streamer Members NFX Class Library

The Streamer type exposes the following members.
Constructors
 | Name | Description
Protected method | Streamer | Initializes a new instance of the Streamer class
Back to Top
Methods
 | Name | Description
Public method | BindStream | Sets the stream as the target for output/input. This call must be coupled with UnbindStream()
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UnbindStream | Unbinds the current stream. This call is coupled with BindStream(stream)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Buff32 |
Protected field | m_Encoding |
Protected field | m_Stream |
 | UTF8Encoding |
Back to Top
Properties
 | Name | Description
Public property | Encoding | Returns stream string encoding
Public property | Format | Returns format that this streamer implements
Public property | Stream | Returns underlying stream if it is bound or null
Back to Top
See Also
Streamer Class
NFX.IO Namespace


Streamer Constructor

Streamer Constructor NFX Class Library

Initializes a new instance of the Streamer class

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Streamer(
    Encoding encoding = null
)
protected Streamer(
    Encoding encoding = null
)
Protected Sub New (
    Optional encoding As Encoding = Nothing
)
Protected Sub New (
    Optional encoding As Encoding = Nothing
)
protected:
Streamer(
    Encoding^ encoding = nullptr
)
protected:
Streamer(
    Encoding^ encoding = nullptr
)
new :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> Streamer
new :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> Streamer

Parameters

encoding (Optional)
Type: Online System.Text Encoding
See Also
Streamer Class
Streamer Members
NFX.IO Namespace


Streamer Fields

Streamer Fields NFX Class Library

The Streamer type exposes the following members.
Fields
 | Name | Description
Protected field | m_Buff32 |
Protected field | m_Encoding |
Protected field | m_Stream |
 | UTF8Encoding |
Back to Top
See Also
Streamer Class
NFX.IO Namespace


Streamer.m_Buff32 Field

Streamer m_Buff32 Field NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected byte[] m_Buff32
protected byte[] m_Buff32
Protected m_Buff32 As Byte()
Protected m_Buff32 As Byte()
protected:
array<unsigned char>^ m_Buff32
protected:
array<unsigned char>^ m_Buff32
val mutable m_Buff32: byte[]
val mutable m_Buff32: byte[]

Field Value

Type: Online Byte
See Also
Streamer Class
Streamer Members
NFX.IO Namespace


Streamer.m_Encoding Field

Streamer m_Encoding Field NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Encoding m_Encoding
protected Encoding m_Encoding
Protected m_Encoding As Encoding
Protected m_Encoding As Encoding
protected:
Encoding^ m_Encoding
protected:
Encoding^ m_Encoding
val mutable m_Encoding: Encoding
val mutable m_Encoding: Encoding

Field Value

Type: Online Encoding
See Also
Streamer Class
Streamer Members
NFX.IO Namespace


Streamer.m_Stream Field

Streamer m_Stream Field NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Stream m_Stream
protected Stream m_Stream
Protected m_Stream As Stream
Protected m_Stream As Stream
protected:
Stream^ m_Stream
protected:
Stream^ m_Stream
val mutable m_Stream: Stream
val mutable m_Stream: Stream

Field Value

Type: Online Stream
See Also
Streamer Class
Streamer Members
NFX.IO Namespace


Streamer.UTF8Encoding Field

Streamer UTF8Encoding Field NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly UTF8Encoding UTF8Encoding
public static readonly UTF8Encoding UTF8Encoding
Public Shared ReadOnly UTF8Encoding As UTF8Encoding
Public Shared ReadOnly UTF8Encoding As UTF8Encoding
public:
static initonly UTF8Encoding^ UTF8Encoding
public:
static initonly UTF8Encoding^ UTF8Encoding
static val UTF8Encoding: UTF8Encoding
static val UTF8Encoding: UTF8Encoding

Field Value

Type: Online UTF8Encoding
See Also
Streamer Class
Streamer Members
NFX.IO Namespace


Streamer Methods

Streamer Methods NFX Class Library

The Streamer type exposes the following members.
Methods
 | Name | Description
Public method | BindStream | Sets the stream as the target for output/input. This call must be coupled with UnbindStream()
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UnbindStream | Unbinds the current stream. This call is coupled with BindStream(stream)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Streamer Class
NFX.IO Namespace


Streamer.BindStream Method

Streamer BindStream Method NFX Class Library

Sets the stream as the target for output/input. This call must be coupled with UnbindStream()

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void BindStream(
    Stream stream
)
public void BindStream(
    Stream stream
)
Public Sub BindStream (
    stream As Stream
)
Public Sub BindStream (
    stream As Stream
)
public:
void BindStream(
    Stream^ stream
)
public:
void BindStream(
    Stream^ stream
)
member BindStream :
        stream : Stream -> unit
member BindStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
Streamer Class
Streamer Members
NFX.IO Namespace


Streamer.UnbindStream Method

Streamer UnbindStream Method NFX Class Library

Unbinds the current stream. This call is coupled with BindStream(stream)

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void UnbindStream()
public void UnbindStream()
Public Sub UnbindStream
Public Sub UnbindStream
public:
void UnbindStream()
public:
void UnbindStream()
member UnbindStream : unit -> unit
member UnbindStream : unit -> unit
See Also
Streamer Class
Streamer Members
NFX.IO Namespace


Streamer Properties

Streamer Properties NFX Class Library

The Streamer type exposes the following members.
Properties
 | Name | Description
Public property | Encoding | Returns stream string encoding
Public property | Format | Returns format that this streamer implements
Public property | Stream | Returns underlying stream if it is bound or null
Back to Top
See Also
Streamer Class
NFX.IO Namespace


Streamer.Encoding Property

Streamer Encoding Property NFX Class Library

Returns stream string encoding

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Encoding Encoding { get; }
public Encoding Encoding { get; }
Public ReadOnly Property Encoding As Encoding
    Get
Public ReadOnly Property Encoding As Encoding
    Get
public:
property Encoding^ Encoding {
    Encoding^ get ();
}
public:
property Encoding^ Encoding {
    Encoding^ get ();
}
member Encoding : Encoding with get
member Encoding : Encoding with get

Property Value

Type: Online Encoding
See Also
Streamer Class
Streamer Members
NFX.IO Namespace


Streamer.Format Property

Streamer Format Property NFX Class Library

Returns format that this streamer implements

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract StreamerFormat Format { get; }
public abstract StreamerFormat Format { get; }
Public MustOverride ReadOnly Property Format As StreamerFormat
    Get
Public MustOverride ReadOnly Property Format As StreamerFormat
    Get
public:
virtual property StreamerFormat^ Format {
    StreamerFormat^ get () abstract;
}
public:
virtual property StreamerFormat^ Format {
    StreamerFormat^ get () abstract;
}
abstract Format : StreamerFormat with get
abstract Format : StreamerFormat with get

Property Value

Type: StreamerFormat
See Also
Streamer Class
Streamer Members
NFX.IO Namespace


Streamer.Stream Property

Streamer Stream Property NFX Class Library

Returns underlying stream if it is bound or null

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Stream Stream { get; }
public Stream Stream { get; }
Public ReadOnly Property Stream As Stream
    Get
Public ReadOnly Property Stream As Stream
    Get
public:
property Stream^ Stream {
    Stream^ get ();
}
public:
property Stream^ Stream {
    Stream^ get ();
}
member Stream : Stream with get
member Stream : Stream with get

Property Value

Type: Online Stream
See Also
Streamer Class
Streamer Members
NFX.IO Namespace


StreamerFormat Class

StreamerFormat Class NFX Class Library

Describes a format - apair of readers/writers along with their capabilities - what types format supports natively
Inheritance Hierarchy
Online System Object
NFX.IO StreamerFormat
NFX.IO StreamerFormat TReader, TWriter

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class StreamerFormat
public abstract class StreamerFormat
Public MustInherit Class StreamerFormat
Public MustInherit Class StreamerFormat
public ref class StreamerFormat abstract
public ref class StreamerFormat abstract
[<AbstractClassAttribute>]
type StreamerFormat =  class end
[<AbstractClassAttribute>]
type StreamerFormat =  class end
See Also
StreamerFormat Members
NFX.IO Namespace


StreamerFormat Members

StreamerFormat Members NFX Class Library

The StreamerFormat type exposes the following members.
Constructors
 | Name | Description
Protected method | StreamerFormat | Initializes a new instance of the StreamerFormat class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReadingStreamer | Makes new reader instance
Public method | GetReadMethodForRefType | Returns a method info for reading a certain ref type for this format or null if type is not supported
Public method | GetReadMethodForType | Returns a method info for reading a certain value type for this format or null if type is not supported
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetWriteMethodForRefType | Returns a method info for writing a certain ref type for this format or null if type is not supported
Public method | GetWriteMethodForType | Returns a method info for writing a certain value type for this format or null if type is not supported
Public method | GetWritingStreamer | Makes new writer instance
Public method | IsRefTypeSupported | Returns true when the supplied ref type is natively supported by format
Public method | IsTypeSupported | Returns true when the supplied type is natively supported by format
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ReaderType |
Public property | WriterType |
Back to Top
See Also
StreamerFormat Class
NFX.IO Namespace


StreamerFormat Constructor

StreamerFormat Constructor NFX Class Library

Initializes a new instance of the StreamerFormat class

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected StreamerFormat()
protected StreamerFormat()
Protected Sub New
Protected Sub New
protected:
StreamerFormat()
protected:
StreamerFormat()
new : unit -> StreamerFormat
new : unit -> StreamerFormat
See Also
StreamerFormat Class
StreamerFormat Members
NFX.IO Namespace


StreamerFormat Methods

StreamerFormat Methods NFX Class Library

The StreamerFormat type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReadingStreamer | Makes new reader instance
Public method | GetReadMethodForRefType | Returns a method info for reading a certain ref type for this format or null if type is not supported
Public method | GetReadMethodForType | Returns a method info for reading a certain value type for this format or null if type is not supported
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetWriteMethodForRefType | Returns a method info for writing a certain ref type for this format or null if type is not supported
Public method | GetWriteMethodForType | Returns a method info for writing a certain value type for this format or null if type is not supported
Public method | GetWritingStreamer | Makes new writer instance
Public method | IsRefTypeSupported | Returns true when the supplied ref type is natively supported by format
Public method | IsTypeSupported | Returns true when the supplied type is natively supported by format
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
StreamerFormat Class
NFX.IO Namespace


StreamerFormat.GetReadingStreamer Method

StreamerFormat GetReadingStreamer Method NFX Class Library

Makes new reader instance

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract ReadingStreamer GetReadingStreamer(
    Encoding encoding = null
)
public abstract ReadingStreamer GetReadingStreamer(
    Encoding encoding = null
)
Public MustOverride Function GetReadingStreamer (
    Optional encoding As Encoding = Nothing
) As ReadingStreamer
Public MustOverride Function GetReadingStreamer (
    Optional encoding As Encoding = Nothing
) As ReadingStreamer
public:
virtual ReadingStreamer^ GetReadingStreamer(
    Encoding^ encoding = nullptr
) abstract
public:
virtual ReadingStreamer^ GetReadingStreamer(
    Encoding^ encoding = nullptr
) abstract
abstract GetReadingStreamer :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> ReadingStreamer
abstract GetReadingStreamer :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> ReadingStreamer

Parameters

encoding (Optional)
Type: Online System.Text Encoding

Return Value

Type: ReadingStreamer
See Also
StreamerFormat Class
StreamerFormat Members
NFX.IO Namespace


StreamerFormat.GetReadMethodForRefType Method

StreamerFormat GetReadMethodForRefType Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns a method info for reading a certain ref type for this format or null if type is not supported

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract MethodInfo GetReadMethodForRefType(
    Type t
)
public abstract MethodInfo GetReadMethodForRefType(
    Type t
)
Public MustOverride Function GetReadMethodForRefType (
    t As Type
) As MethodInfo
Public MustOverride Function GetReadMethodForRefType (
    t As Type
) As MethodInfo
public:
virtual MethodInfo^ GetReadMethodForRefType(
    Type^ t
) abstract
public:
virtual MethodInfo^ GetReadMethodForRefType(
    Type^ t
) abstract
abstract GetReadMethodForRefType :
        t : Type -> MethodInfo
abstract GetReadMethodForRefType :
        t : Type -> MethodInfo

Parameters

t
Type: Online System Type

Return Value

Type: Online MethodInfo
See Also
StreamerFormat Class
StreamerFormat Members
NFX.IO Namespace


StreamerFormat.GetReadMethodForType Method

StreamerFormat GetReadMethodForType Method NFX Class Library

Returns a method info for reading a certain value type for this format or null if type is not supported

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract MethodInfo GetReadMethodForType(
    Type t
)
public abstract MethodInfo GetReadMethodForType(
    Type t
)
Public MustOverride Function GetReadMethodForType (
    t As Type
) As MethodInfo
Public MustOverride Function GetReadMethodForType (
    t As Type
) As MethodInfo
public:
virtual MethodInfo^ GetReadMethodForType(
    Type^ t
) abstract
public:
virtual MethodInfo^ GetReadMethodForType(
    Type^ t
) abstract
abstract GetReadMethodForType :
        t : Type -> MethodInfo
abstract GetReadMethodForType :
        t : Type -> MethodInfo

Parameters

t
Type: Online System Type

Return Value

Type: Online MethodInfo
See Also
StreamerFormat Class
StreamerFormat Members
NFX.IO Namespace


StreamerFormat.GetWriteMethodForRefType Method

StreamerFormat GetWriteMethodForRefType Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns a method info for writing a certain ref type for this format or null if type is not supported

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract MethodInfo GetWriteMethodForRefType(
    Type t
)
public abstract MethodInfo GetWriteMethodForRefType(
    Type t
)
Public MustOverride Function GetWriteMethodForRefType (
    t As Type
) As MethodInfo
Public MustOverride Function GetWriteMethodForRefType (
    t As Type
) As MethodInfo
public:
virtual MethodInfo^ GetWriteMethodForRefType(
    Type^ t
) abstract
public:
virtual MethodInfo^ GetWriteMethodForRefType(
    Type^ t
) abstract
abstract GetWriteMethodForRefType :
        t : Type -> MethodInfo
abstract GetWriteMethodForRefType :
        t : Type -> MethodInfo

Parameters

t
Type: Online System Type

Return Value

Type: Online MethodInfo
See Also
StreamerFormat Class
StreamerFormat Members
NFX.IO Namespace


StreamerFormat.GetWriteMethodForType Method

StreamerFormat GetWriteMethodForType Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns a method info for writing a certain value type for this format or null if type is not supported

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract MethodInfo GetWriteMethodForType(
    Type t
)
public abstract MethodInfo GetWriteMethodForType(
    Type t
)
Public MustOverride Function GetWriteMethodForType (
    t As Type
) As MethodInfo
Public MustOverride Function GetWriteMethodForType (
    t As Type
) As MethodInfo
public:
virtual MethodInfo^ GetWriteMethodForType(
    Type^ t
) abstract
public:
virtual MethodInfo^ GetWriteMethodForType(
    Type^ t
) abstract
abstract GetWriteMethodForType :
        t : Type -> MethodInfo
abstract GetWriteMethodForType :
        t : Type -> MethodInfo

Parameters

t
Type: Online System Type

Return Value

Type: Online MethodInfo
See Also
StreamerFormat Class
StreamerFormat Members
NFX.IO Namespace


StreamerFormat.GetWritingStreamer Method

StreamerFormat GetWritingStreamer Method NFX Class Library

Makes new writer instance

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract WritingStreamer GetWritingStreamer(
    Encoding encoding = null
)
public abstract WritingStreamer GetWritingStreamer(
    Encoding encoding = null
)
Public MustOverride Function GetWritingStreamer (
    Optional encoding As Encoding = Nothing
) As WritingStreamer
Public MustOverride Function GetWritingStreamer (
    Optional encoding As Encoding = Nothing
) As WritingStreamer
public:
virtual WritingStreamer^ GetWritingStreamer(
    Encoding^ encoding = nullptr
) abstract
public:
virtual WritingStreamer^ GetWritingStreamer(
    Encoding^ encoding = nullptr
) abstract
abstract GetWritingStreamer :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> WritingStreamer
abstract GetWritingStreamer :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> WritingStreamer

Parameters

encoding (Optional)
Type: Online System.Text Encoding

Return Value

Type: WritingStreamer
See Also
StreamerFormat Class
StreamerFormat Members
NFX.IO Namespace


StreamerFormat.IsRefTypeSupported Method

StreamerFormat IsRefTypeSupported Method NFX Class Library

Returns true when the supplied ref type is natively supported by format

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool IsRefTypeSupported(
    Type t
)
public abstract bool IsRefTypeSupported(
    Type t
)
Public MustOverride Function IsRefTypeSupported (
    t As Type
) As Boolean
Public MustOverride Function IsRefTypeSupported (
    t As Type
) As Boolean
public:
virtual bool IsRefTypeSupported(
    Type^ t
) abstract
public:
virtual bool IsRefTypeSupported(
    Type^ t
) abstract
abstract IsRefTypeSupported :
        t : Type -> bool
abstract IsRefTypeSupported :
        t : Type -> bool

Parameters

t
Type: Online System Type

Return Value

Type: Online Boolean
See Also
StreamerFormat Class
StreamerFormat Members
NFX.IO Namespace


StreamerFormat.IsTypeSupported Method

StreamerFormat IsTypeSupported Method NFX Class Library

Returns true when the supplied type is natively supported by format

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool IsTypeSupported(
    Type t
)
public abstract bool IsTypeSupported(
    Type t
)
Public MustOverride Function IsTypeSupported (
    t As Type
) As Boolean
Public MustOverride Function IsTypeSupported (
    t As Type
) As Boolean
public:
virtual bool IsTypeSupported(
    Type^ t
) abstract
public:
virtual bool IsTypeSupported(
    Type^ t
) abstract
abstract IsTypeSupported :
        t : Type -> bool
abstract IsTypeSupported :
        t : Type -> bool

Parameters

t
Type: Online System Type

Return Value

Type: Online Boolean
See Also
StreamerFormat Class
StreamerFormat Members
NFX.IO Namespace


StreamerFormat Properties

StreamerFormat Properties NFX Class Library

The StreamerFormat type exposes the following members.
Properties
 | Name | Description
Public property | ReaderType |
Public property | WriterType |
Back to Top
See Also
StreamerFormat Class
NFX.IO Namespace


StreamerFormat.ReaderType Property

StreamerFormat ReaderType Property NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Type ReaderType { get; }
public abstract Type ReaderType { get; }
Public MustOverride ReadOnly Property ReaderType As Type
    Get
Public MustOverride ReadOnly Property ReaderType As Type
    Get
public:
virtual property Type^ ReaderType {
    Type^ get () abstract;
}
public:
virtual property Type^ ReaderType {
    Type^ get () abstract;
}
abstract ReaderType : Type with get
abstract ReaderType : Type with get

Property Value

Type: Online Type
See Also
StreamerFormat Class
StreamerFormat Members
NFX.IO Namespace


StreamerFormat.WriterType Property

StreamerFormat WriterType Property NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Type WriterType { get; }
public abstract Type WriterType { get; }
Public MustOverride ReadOnly Property WriterType As Type
    Get
Public MustOverride ReadOnly Property WriterType As Type
    Get
public:
virtual property Type^ WriterType {
    Type^ get () abstract;
}
public:
virtual property Type^ WriterType {
    Type^ get () abstract;
}
abstract WriterType : Type with get
abstract WriterType : Type with get

Property Value

Type: Online Type
See Also
StreamerFormat Class
StreamerFormat Members
NFX.IO Namespace


StreamerFormat(TReader, TWriter) Class

StreamerFormat TReader, TWriter Class NFX Class Library

Describes a format - apair of readers/writers along with their capabilities. Developers may derive new formats that support custom serialization schemes
Inheritance Hierarchy
Online System Object
NFX.IO StreamerFormat
NFX.IO StreamerFormat TReader, TWriter
NFX.IO SlimFormat

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class StreamerFormat<TReader, TWriter> : StreamerFormat
where TReader : ReadingStreamer
where TWriter : WritingStreamer
public abstract class StreamerFormat<TReader, TWriter> : StreamerFormat
where TReader : ReadingStreamer
where TWriter : WritingStreamer
Public MustInherit Class StreamerFormat(Of TReader As ReadingStreamer, TWriter As WritingStreamer)
    Inherits StreamerFormat
Public MustInherit Class StreamerFormat(Of TReader As ReadingStreamer, TWriter As WritingStreamer)
    Inherits StreamerFormat
generic<typename TReader, typename TWriter>
where TReader : ReadingStreamer
where TWriter : WritingStreamer
public ref class StreamerFormat abstract : public StreamerFormat
generic<typename TReader, typename TWriter>
where TReader : ReadingStreamer
where TWriter : WritingStreamer
public ref class StreamerFormat abstract : public StreamerFormat
[<AbstractClassAttribute>]
type StreamerFormat<'TReader, 'TWriter when 'TReader : ReadingStreamer when 'TWriter : WritingStreamer> =
    class
        inherit StreamerFormat
    end
[<AbstractClassAttribute>]
type StreamerFormat<'TReader, 'TWriter when 'TReader : ReadingStreamer when 'TWriter : WritingStreamer> =
    class
        inherit StreamerFormat
    end
Type Parameters
TReader
TWriter
See Also
StreamerFormat TReader, TWriter Members
NFX.IO Namespace


StreamerFormat(TReader, TWriter) Members

StreamerFormat TReader, TWriter Members NFX Class Library

The StreamerFormat TReader, TWriter type exposes the following members.
Constructors
 | Name | Description
Protected method | StreamerFormat TReader, TWriter | Initializes a new instance of the StreamerFormat TReader, TWriter class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReadActionForRefType | Returns a function that reads the specified ref type and returns it as object
Public method | GetReadActionForType | Returns a function that reads the specified value type and returns it as object
Public method | GetReadingStreamer | Makes new reader instance (Overrides StreamerFormat GetReadingStreamer(Encoding).)
Public method | GetReadMethodForRefType | Returns a method info for reading a certain reference type for this format or null if this type is not directly supported. Use IsRefTypeSupported(type) to see if the ref type is native to this format. (Overrides StreamerFormat GetReadMethodForRefType(Type).)
Public method | GetReadMethodForType | Returns a method info for reading a certain value type for this format or null if this type is not directly supported. Use IsTypeSupported(type) to see if the type is native to this format. (Overrides StreamerFormat GetReadMethodForType(Type).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetWriteActionForRefType | Returns an action that writes the value of the specified ref type
Public method | GetWriteActionForType | Returns an action that writes the value of the specified value type
Public method | GetWriteMethodForRefType | Returns a method info for writing a certain ref type for this format. Use IsRefTypeSupported(type) to see if the type is native to this format. (Overrides StreamerFormat GetWriteMethodForRefType(Type).)
Public method | GetWriteMethodForType | Returns a method info for writing a certain value type for this format. Use IsTypeSupported(type) to see if the type is native to this format. (Overrides StreamerFormat GetWriteMethodForType(Type).)
Public method | GetWritingStreamer | Makes new writer instance (Overrides StreamerFormat GetWritingStreamer(Encoding).)
Public method | IsRefTypeSupported | Returns true when the supplied reference type is natively supported by format, that is - when this format can directly write instances of this type without reflection/complex graph walk. (Overrides StreamerFormat IsRefTypeSupported(Type).)
Public method | IsTypeSupported | Returns true when the supplied value type is natively supported by format, that is - when this format can directly write instances of this type without reflection/complex graph walk. (Overrides StreamerFormat IsTypeSupported(Type).)
Public method | MakeReadingStreamer | Makes new reader instance
Public method | MakeWritingStreamer | Makes new writer instance
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ReaderType | (Inherited from StreamerFormat.)
Public property | WriterType | (Inherited from StreamerFormat.)
Back to Top
See Also
StreamerFormat TReader, TWriter Class
NFX.IO Namespace


StreamerFormat(TReader, TWriter) Constructor

StreamerFormat TReader, TWriter Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the StreamerFormat TReader, TWriter class

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected StreamerFormat()
protected StreamerFormat()
Protected Sub New
Protected Sub New
protected:
StreamerFormat()
protected:
StreamerFormat()
new : unit -> StreamerFormat
new : unit -> StreamerFormat
See Also
StreamerFormat TReader, TWriter Class
StreamerFormat TReader, TWriter Members
NFX.IO Namespace


StreamerFormat(TReader, TWriter) Methods

StreamerFormat TReader, TWriter Methods NFX Class Library

The StreamerFormat TReader, TWriter type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReadActionForRefType | Returns a function that reads the specified ref type and returns it as object
Public method | GetReadActionForType | Returns a function that reads the specified value type and returns it as object
Public method | GetReadingStreamer | Makes new reader instance (Overrides StreamerFormat GetReadingStreamer(Encoding).)
Public method | GetReadMethodForRefType | Returns a method info for reading a certain reference type for this format or null if this type is not directly supported. Use IsRefTypeSupported(type) to see if the ref type is native to this format. (Overrides StreamerFormat GetReadMethodForRefType(Type).)
Public method | GetReadMethodForType | Returns a method info for reading a certain value type for this format or null if this type is not directly supported. Use IsTypeSupported(type) to see if the type is native to this format. (Overrides StreamerFormat GetReadMethodForType(Type).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetWriteActionForRefType | Returns an action that writes the value of the specified ref type
Public method | GetWriteActionForType | Returns an action that writes the value of the specified value type
Public method | GetWriteMethodForRefType | Returns a method info for writing a certain ref type for this format. Use IsRefTypeSupported(type) to see if the type is native to this format. (Overrides StreamerFormat GetWriteMethodForRefType(Type).)
Public method | GetWriteMethodForType | Returns a method info for writing a certain value type for this format. Use IsTypeSupported(type) to see if the type is native to this format. (Overrides StreamerFormat GetWriteMethodForType(Type).)
Public method | GetWritingStreamer | Makes new writer instance (Overrides StreamerFormat GetWritingStreamer(Encoding).)
Public method | IsRefTypeSupported | Returns true when the supplied reference type is natively supported by format, that is - when this format can directly write instances of this type without reflection/complex graph walk. (Overrides StreamerFormat IsRefTypeSupported(Type).)
Public method | IsTypeSupported | Returns true when the supplied value type is natively supported by format, that is - when this format can directly write instances of this type without reflection/complex graph walk. (Overrides StreamerFormat IsTypeSupported(Type).)
Public method | MakeReadingStreamer | Makes new reader instance
Public method | MakeWritingStreamer | Makes new writer instance
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
StreamerFormat TReader, TWriter Class
NFX.IO Namespace


StreamerFormat(TReader, TWriter).GetReadActionForRefType Method

StreamerFormat TReader, TWriter GetReadActionForRefType Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns a function that reads the specified ref type and returns it as object

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Func<TReader, Object> GetReadActionForRefType(
    Type t
)
public Func<TReader, Object> GetReadActionForRefType(
    Type t
)
Public Function GetReadActionForRefType (
    t As Type
) As Func(Of TReader, Object)
Public Function GetReadActionForRefType (
    t As Type
) As Func(Of TReader, Object)
public:
Func<TReader, Object^>^ GetReadActionForRefType(
    Type^ t
)
public:
Func<TReader, Object^>^ GetReadActionForRefType(
    Type^ t
)
member GetReadActionForRefType :
        t : Type -> Func<'TReader, Object>
member GetReadActionForRefType :
        t : Type -> Func<'TReader, Object>

Parameters

t
Type: Online System Type

Return Value

Type: Online Func TReader, Online Object
See Also
StreamerFormat TReader, TWriter Class
StreamerFormat TReader, TWriter Members
NFX.IO Namespace


StreamerFormat(TReader, TWriter).GetReadActionForType Method

StreamerFormat TReader, TWriter GetReadActionForType Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns a function that reads the specified value type and returns it as object

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Func<TReader, Object> GetReadActionForType(
    Type t
)
public Func<TReader, Object> GetReadActionForType(
    Type t
)
Public Function GetReadActionForType (
    t As Type
) As Func(Of TReader, Object)
Public Function GetReadActionForType (
    t As Type
) As Func(Of TReader, Object)
public:
Func<TReader, Object^>^ GetReadActionForType(
    Type^ t
)
public:
Func<TReader, Object^>^ GetReadActionForType(
    Type^ t
)
member GetReadActionForType :
        t : Type -> Func<'TReader, Object>
member GetReadActionForType :
        t : Type -> Func<'TReader, Object>

Parameters

t
Type: Online System Type

Return Value

Type: Online Func TReader, Online Object
See Also
StreamerFormat TReader, TWriter Class
StreamerFormat TReader, TWriter Members
NFX.IO Namespace


StreamerFormat(TReader, TWriter).GetReadingStreamer Method

StreamerFormat TReader, TWriter GetReadingStreamer Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Makes new reader instance

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override sealed ReadingStreamer GetReadingStreamer(
    Encoding encoding = null
)
public override sealed ReadingStreamer GetReadingStreamer(
    Encoding encoding = null
)
Public Overrides NotOverridable Function GetReadingStreamer (
    Optional encoding As Encoding = Nothing
) As ReadingStreamer
Public Overrides NotOverridable Function GetReadingStreamer (
    Optional encoding As Encoding = Nothing
) As ReadingStreamer
public:
virtual ReadingStreamer^ GetReadingStreamer(
    Encoding^ encoding = nullptr
) override sealed
public:
virtual ReadingStreamer^ GetReadingStreamer(
    Encoding^ encoding = nullptr
) override sealed
abstract GetReadingStreamer :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> ReadingStreamer
override GetReadingStreamer :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> ReadingStreamer
abstract GetReadingStreamer :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> ReadingStreamer
override GetReadingStreamer :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> ReadingStreamer

Parameters

encoding (Optional)
Type: Online System.Text Encoding

Return Value

Type: ReadingStreamer
See Also
StreamerFormat TReader, TWriter Class
StreamerFormat TReader, TWriter Members
NFX.IO Namespace


StreamerFormat(TReader, TWriter).GetReadMethodForRefType Method

StreamerFormat TReader, TWriter GetReadMethodForRefType Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns a method info for reading a certain reference type for this format or null if this type is not directly supported. Use IsRefTypeSupported(type) to see if the ref type is native to this format.

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override sealed MethodInfo GetReadMethodForRefType(
    Type t
)
public override sealed MethodInfo GetReadMethodForRefType(
    Type t
)
Public Overrides NotOverridable Function GetReadMethodForRefType (
    t As Type
) As MethodInfo
Public Overrides NotOverridable Function GetReadMethodForRefType (
    t As Type
) As MethodInfo
public:
virtual MethodInfo^ GetReadMethodForRefType(
    Type^ t
) override sealed
public:
virtual MethodInfo^ GetReadMethodForRefType(
    Type^ t
) override sealed
abstract GetReadMethodForRefType :
        t : Type -> MethodInfo
override GetReadMethodForRefType :
        t : Type -> MethodInfo
abstract GetReadMethodForRefType :
        t : Type -> MethodInfo
override GetReadMethodForRefType :
        t : Type -> MethodInfo

Parameters

t
Type: Online System Type

Return Value

Type: Online MethodInfo
See Also
StreamerFormat TReader, TWriter Class
StreamerFormat TReader, TWriter Members
NFX.IO Namespace


StreamerFormat(TReader, TWriter).GetReadMethodForType Method

StreamerFormat TReader, TWriter GetReadMethodForType Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns a method info for reading a certain value type for this format or null if this type is not directly supported. Use IsTypeSupported(type) to see if the type is native to this format.

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override sealed MethodInfo GetReadMethodForType(
    Type t
)
public override sealed MethodInfo GetReadMethodForType(
    Type t
)
Public Overrides NotOverridable Function GetReadMethodForType (
    t As Type
) As MethodInfo
Public Overrides NotOverridable Function GetReadMethodForType (
    t As Type
) As MethodInfo
public:
virtual MethodInfo^ GetReadMethodForType(
    Type^ t
) override sealed
public:
virtual MethodInfo^ GetReadMethodForType(
    Type^ t
) override sealed
abstract GetReadMethodForType :
        t : Type -> MethodInfo
override GetReadMethodForType :
        t : Type -> MethodInfo
abstract GetReadMethodForType :
        t : Type -> MethodInfo
override GetReadMethodForType :
        t : Type -> MethodInfo

Parameters

t
Type: Online System Type

Return Value

Type: Online MethodInfo
See Also
StreamerFormat TReader, TWriter Class
StreamerFormat TReader, TWriter Members
NFX.IO Namespace


StreamerFormat(TReader, TWriter).GetWriteActionForRefType Method

StreamerFormat TReader, TWriter GetWriteActionForRefType Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns an action that writes the value of the specified ref type

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Action<TWriter, Object> GetWriteActionForRefType(
    Type t
)
public Action<TWriter, Object> GetWriteActionForRefType(
    Type t
)
Public Function GetWriteActionForRefType (
    t As Type
) As Action(Of TWriter, Object)
Public Function GetWriteActionForRefType (
    t As Type
) As Action(Of TWriter, Object)
public:
Action<TWriter, Object^>^ GetWriteActionForRefType(
    Type^ t
)
public:
Action<TWriter, Object^>^ GetWriteActionForRefType(
    Type^ t
)
member GetWriteActionForRefType :
        t : Type -> Action<'TWriter, Object>
member GetWriteActionForRefType :
        t : Type -> Action<'TWriter, Object>

Parameters

t
Type: Online System Type

Return Value

Type: Online Action TWriter, Online Object
See Also
StreamerFormat TReader, TWriter Class
StreamerFormat TReader, TWriter Members
NFX.IO Namespace


StreamerFormat(TReader, TWriter).GetWriteActionForType Method

StreamerFormat TReader, TWriter GetWriteActionForType Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns an action that writes the value of the specified value type

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Action<TWriter, Object> GetWriteActionForType(
    Type t
)
public Action<TWriter, Object> GetWriteActionForType(
    Type t
)
Public Function GetWriteActionForType (
    t As Type
) As Action(Of TWriter, Object)
Public Function GetWriteActionForType (
    t As Type
) As Action(Of TWriter, Object)
public:
Action<TWriter, Object^>^ GetWriteActionForType(
    Type^ t
)
public:
Action<TWriter, Object^>^ GetWriteActionForType(
    Type^ t
)
member GetWriteActionForType :
        t : Type -> Action<'TWriter, Object>
member GetWriteActionForType :
        t : Type -> Action<'TWriter, Object>

Parameters

t
Type: Online System Type

Return Value

Type: Online Action TWriter, Online Object
See Also
StreamerFormat TReader, TWriter Class
StreamerFormat TReader, TWriter Members
NFX.IO Namespace


StreamerFormat(TReader, TWriter).GetWriteMethodForRefType Method

StreamerFormat TReader, TWriter GetWriteMethodForRefType Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns a method info for writing a certain ref type for this format. Use IsRefTypeSupported(type) to see if the type is native to this format.

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override sealed MethodInfo GetWriteMethodForRefType(
    Type t
)
public override sealed MethodInfo GetWriteMethodForRefType(
    Type t
)
Public Overrides NotOverridable Function GetWriteMethodForRefType (
    t As Type
) As MethodInfo
Public Overrides NotOverridable Function GetWriteMethodForRefType (
    t As Type
) As MethodInfo
public:
virtual MethodInfo^ GetWriteMethodForRefType(
    Type^ t
) override sealed
public:
virtual MethodInfo^ GetWriteMethodForRefType(
    Type^ t
) override sealed
abstract GetWriteMethodForRefType :
        t : Type -> MethodInfo
override GetWriteMethodForRefType :
        t : Type -> MethodInfo
abstract GetWriteMethodForRefType :
        t : Type -> MethodInfo
override GetWriteMethodForRefType :
        t : Type -> MethodInfo

Parameters

t
Type: Online System Type

Return Value

Type: Online MethodInfo
See Also
StreamerFormat TReader, TWriter Class
StreamerFormat TReader, TWriter Members
NFX.IO Namespace


StreamerFormat(TReader, TWriter).GetWriteMethodForType Method

StreamerFormat TReader, TWriter GetWriteMethodForType Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns a method info for writing a certain value type for this format. Use IsTypeSupported(type) to see if the type is native to this format.

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override sealed MethodInfo GetWriteMethodForType(
    Type t
)
public override sealed MethodInfo GetWriteMethodForType(
    Type t
)
Public Overrides NotOverridable Function GetWriteMethodForType (
    t As Type
) As MethodInfo
Public Overrides NotOverridable Function GetWriteMethodForType (
    t As Type
) As MethodInfo
public:
virtual MethodInfo^ GetWriteMethodForType(
    Type^ t
) override sealed
public:
virtual MethodInfo^ GetWriteMethodForType(
    Type^ t
) override sealed
abstract GetWriteMethodForType :
        t : Type -> MethodInfo
override GetWriteMethodForType :
        t : Type -> MethodInfo
abstract GetWriteMethodForType :
        t : Type -> MethodInfo
override GetWriteMethodForType :
        t : Type -> MethodInfo

Parameters

t
Type: Online System Type

Return Value

Type: Online MethodInfo
See Also
StreamerFormat TReader, TWriter Class
StreamerFormat TReader, TWriter Members
NFX.IO Namespace


StreamerFormat(TReader, TWriter).GetWritingStreamer Method

StreamerFormat TReader, TWriter GetWritingStreamer Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Makes new writer instance

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override sealed WritingStreamer GetWritingStreamer(
    Encoding encoding = null
)
public override sealed WritingStreamer GetWritingStreamer(
    Encoding encoding = null
)
Public Overrides NotOverridable Function GetWritingStreamer (
    Optional encoding As Encoding = Nothing
) As WritingStreamer
Public Overrides NotOverridable Function GetWritingStreamer (
    Optional encoding As Encoding = Nothing
) As WritingStreamer
public:
virtual WritingStreamer^ GetWritingStreamer(
    Encoding^ encoding = nullptr
) override sealed
public:
virtual WritingStreamer^ GetWritingStreamer(
    Encoding^ encoding = nullptr
) override sealed
abstract GetWritingStreamer :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> WritingStreamer
override GetWritingStreamer :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> WritingStreamer
abstract GetWritingStreamer :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> WritingStreamer
override GetWritingStreamer :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> WritingStreamer

Parameters

encoding (Optional)
Type: Online System.Text Encoding

Return Value

Type: WritingStreamer
See Also
StreamerFormat TReader, TWriter Class
StreamerFormat TReader, TWriter Members
NFX.IO Namespace


StreamerFormat(TReader, TWriter).IsRefTypeSupported Method

StreamerFormat TReader, TWriter IsRefTypeSupported Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns true when the supplied reference type is natively supported by format, that is - when this format can directly write instances of this type without reflection/complex graph walk.

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsRefTypeSupported(
    Type t
)
public override bool IsRefTypeSupported(
    Type t
)
Public Overrides Function IsRefTypeSupported (
    t As Type
) As Boolean
Public Overrides Function IsRefTypeSupported (
    t As Type
) As Boolean
public:
virtual bool IsRefTypeSupported(
    Type^ t
) override
public:
virtual bool IsRefTypeSupported(
    Type^ t
) override
abstract IsRefTypeSupported :
        t : Type -> bool
override IsRefTypeSupported :
        t : Type -> bool
abstract IsRefTypeSupported :
        t : Type -> bool
override IsRefTypeSupported :
        t : Type -> bool

Parameters

t
Type: Online System Type

Return Value

Type: Online Boolean
See Also
StreamerFormat TReader, TWriter Class
StreamerFormat TReader, TWriter Members
NFX.IO Namespace


StreamerFormat(TReader, TWriter).IsTypeSupported Method

StreamerFormat TReader, TWriter IsTypeSupported Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns true when the supplied value type is natively supported by format, that is - when this format can directly write instances of this type without reflection/complex graph walk.

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IsTypeSupported(
    Type t
)
public override bool IsTypeSupported(
    Type t
)
Public Overrides Function IsTypeSupported (
    t As Type
) As Boolean
Public Overrides Function IsTypeSupported (
    t As Type
) As Boolean
public:
virtual bool IsTypeSupported(
    Type^ t
) override
public:
virtual bool IsTypeSupported(
    Type^ t
) override
abstract IsTypeSupported :
        t : Type -> bool
override IsTypeSupported :
        t : Type -> bool
abstract IsTypeSupported :
        t : Type -> bool
override IsTypeSupported :
        t : Type -> bool

Parameters

t
Type: Online System Type

Return Value

Type: Online Boolean
See Also
StreamerFormat TReader, TWriter Class
StreamerFormat TReader, TWriter Members
NFX.IO Namespace


StreamerFormat(TReader, TWriter).MakeReadingStreamer Method

StreamerFormat TReader, TWriter MakeReadingStreamer Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Makes new reader instance

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract TReader MakeReadingStreamer(
    Encoding encoding = null
)
public abstract TReader MakeReadingStreamer(
    Encoding encoding = null
)
Public MustOverride Function MakeReadingStreamer (
    Optional encoding As Encoding = Nothing
) As TReader
Public MustOverride Function MakeReadingStreamer (
    Optional encoding As Encoding = Nothing
) As TReader
public:
virtual TReader MakeReadingStreamer(
    Encoding^ encoding = nullptr
) abstract
public:
virtual TReader MakeReadingStreamer(
    Encoding^ encoding = nullptr
) abstract
abstract MakeReadingStreamer :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> 'TReader
abstract MakeReadingStreamer :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> 'TReader

Parameters

encoding (Optional)
Type: Online System.Text Encoding

Return Value

Type: TReader
See Also
StreamerFormat TReader, TWriter Class
StreamerFormat TReader, TWriter Members
NFX.IO Namespace


StreamerFormat(TReader, TWriter).MakeWritingStreamer Method

StreamerFormat TReader, TWriter MakeWritingStreamer Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Makes new writer instance

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract TWriter MakeWritingStreamer(
    Encoding encoding = null
)
public abstract TWriter MakeWritingStreamer(
    Encoding encoding = null
)
Public MustOverride Function MakeWritingStreamer (
    Optional encoding As Encoding = Nothing
) As TWriter
Public MustOverride Function MakeWritingStreamer (
    Optional encoding As Encoding = Nothing
) As TWriter
public:
virtual TWriter MakeWritingStreamer(
    Encoding^ encoding = nullptr
) abstract
public:
virtual TWriter MakeWritingStreamer(
    Encoding^ encoding = nullptr
) abstract
abstract MakeWritingStreamer :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> 'TWriter
abstract MakeWritingStreamer :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> 'TWriter

Parameters

encoding (Optional)
Type: Online System.Text Encoding

Return Value

Type: TWriter
See Also
StreamerFormat TReader, TWriter Class
StreamerFormat TReader, TWriter Members
NFX.IO Namespace


StreamerFormat(TReader, TWriter) Properties

StreamerFormat TReader, TWriter Properties NFX Class Library

The StreamerFormat TReader, TWriter type exposes the following members.
Properties
 | Name | Description
Public property | ReaderType | (Inherited from StreamerFormat.)
Public property | WriterType | (Inherited from StreamerFormat.)
Back to Top
See Also
StreamerFormat TReader, TWriter Class
NFX.IO Namespace


VarIntStr Structure

VarIntStr Structure NFX Class Library

Holds either an integer or a string value. This is useful for metadata, i.e. types, if type is known an integer is sent, otherwise a full type name is sent

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public struct VarIntStr : IEquatable<VarIntStr>
[SerializableAttribute]
public struct VarIntStr : IEquatable<VarIntStr>
<SerializableAttribute>
Public Structure VarIntStr
    Implements IEquatable(Of VarIntStr)
<SerializableAttribute>
Public Structure VarIntStr
    Implements IEquatable(Of VarIntStr)
[SerializableAttribute]
public value class VarIntStr : IEquatable<VarIntStr>
[SerializableAttribute]
public value class VarIntStr : IEquatable<VarIntStr>
[<SealedAttribute>]
[<SerializableAttribute>]
type VarIntStr =
    struct
        interface IEquatable<VarIntStr>
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type VarIntStr =
    struct
        interface IEquatable<VarIntStr>
    end
See Also
VarIntStr Members
NFX.IO Namespace


VarIntStr Members

VarIntStr Members NFX Class Library

The VarIntStr type exposes the following members.
Constructors
 | Name | Description
Public method | VarIntStr(String) | Initializes a new instance of the VarIntStr class
Public method | VarIntStr(UInt32) | Initializes a new instance of the VarIntStr class
Back to Top
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(VarIntStr) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | IntValue |
Public field | StringValue |
Back to Top
See Also
VarIntStr Structure
NFX.IO Namespace


VarIntStr Constructor

VarIntStr Constructor NFX Class Library

Overload List
 | Name | Description
Public method | VarIntStr(String) | Initializes a new instance of the VarIntStr class
Public method | VarIntStr(UInt32) | Initializes a new instance of the VarIntStr class
Back to Top
See Also
VarIntStr Structure
VarIntStr Members
NFX.IO Namespace


VarIntStr Constructor (String)

VarIntStr Constructor (String) NFX Class Library

Initializes a new instance of the VarIntStr class

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public VarIntStr(
    string value
)
public VarIntStr(
    string value
)
Public Sub New (
    value As String
)
Public Sub New (
    value As String
)
public:
VarIntStr(
    String^ value
)
public:
VarIntStr(
    String^ value
)
new :
        value : string -> VarIntStr
new :
        value : string -> VarIntStr

Parameters

value
Type: Online System String
See Also
VarIntStr Structure
VarIntStr Members
VarIntStr Overload
NFX.IO Namespace


VarIntStr Constructor (UInt32)

VarIntStr Constructor (UInt32) NFX Class Library

Initializes a new instance of the VarIntStr class

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public VarIntStr(
    uint value
)
public VarIntStr(
    uint value
)
Public Sub New (
    value As UInteger
)
Public Sub New (
    value As UInteger
)
public:
VarIntStr(
    unsigned int value
)
public:
VarIntStr(
    unsigned int value
)
new :
        value : uint32 -> VarIntStr
new :
        value : uint32 -> VarIntStr

Parameters

value
Type: Online System UInt32
See Also
VarIntStr Structure
VarIntStr Members
VarIntStr Overload
NFX.IO Namespace


VarIntStr Fields

VarIntStr Fields NFX Class Library

The VarIntStr type exposes the following members.
Fields
 | Name | Description
Public field | IntValue |
Public field | StringValue |
Back to Top
See Also
VarIntStr Structure
NFX.IO Namespace


VarIntStr.IntValue Field

VarIntStr IntValue Field NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly uint IntValue
public readonly uint IntValue
Public ReadOnly IntValue As UInteger
Public ReadOnly IntValue As UInteger
public:
initonly unsigned int IntValue
public:
initonly unsigned int IntValue
val IntValue: uint32
val IntValue: uint32

Field Value

Type: Online UInt32
See Also
VarIntStr Structure
VarIntStr Members
NFX.IO Namespace


VarIntStr.StringValue Field

VarIntStr StringValue Field NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string StringValue
public readonly string StringValue
Public ReadOnly StringValue As String
Public ReadOnly StringValue As String
public:
initonly String^ StringValue
public:
initonly String^ StringValue
val StringValue: string
val StringValue: string

Field Value

Type: Online String
See Also
VarIntStr Structure
VarIntStr Members
NFX.IO Namespace


VarIntStr Methods

VarIntStr Methods NFX Class Library

The VarIntStr type exposes the following members.
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(VarIntStr) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
VarIntStr Structure
NFX.IO Namespace


VarIntStr.Equals Method

VarIntStr Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(VarIntStr) |
Back to Top
See Also
VarIntStr Structure
VarIntStr Members
NFX.IO Namespace


VarIntStr.Equals Method (Object)

VarIntStr Equals Method (Object) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
VarIntStr Structure
VarIntStr Members
Equals Overload
NFX.IO Namespace


VarIntStr.Equals Method (VarIntStr)

VarIntStr Equals Method (VarIntStr) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    VarIntStr other
)
public bool Equals(
    VarIntStr other
)
Public Function Equals (
    other As VarIntStr
) As Boolean
Public Function Equals (
    other As VarIntStr
) As Boolean
public:
virtual bool Equals(
    VarIntStr other
) sealed
public:
virtual bool Equals(
    VarIntStr other
) sealed
abstract Equals :
        other : VarIntStr -> bool
override Equals :
        other : VarIntStr -> bool
abstract Equals :
        other : VarIntStr -> bool
override Equals :
        other : VarIntStr -> bool

Parameters

other
Type: NFX.IO VarIntStr

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
VarIntStr Structure
VarIntStr Members
Equals Overload
NFX.IO Namespace


VarIntStr.GetHashCode Method

VarIntStr GetHashCode Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
VarIntStr Structure
VarIntStr Members
NFX.IO Namespace


VarIntStr.ToString Method

VarIntStr ToString Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
VarIntStr Structure
VarIntStr Members
NFX.IO Namespace


WritingStreamer Class

WritingStreamer Class NFX Class Library

Writes primitives to stream
Inheritance Hierarchy
Online System Object
NFX.IO Streamer
NFX.IO WritingStreamer
NFX.IO SlimWriter

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[InventoryAttribute(Concerns = SystemConcerns.Unspecified|SystemConcerns.Testing|SystemConcerns.MissionCriticality)]
public abstract class WritingStreamer : Streamer
[InventoryAttribute(Concerns = SystemConcerns.Unspecified|SystemConcerns.Testing|SystemConcerns.MissionCriticality)]
public abstract class WritingStreamer : Streamer
<InventoryAttribute(Concerns := SystemConcerns.Unspecified Or SystemConcerns.Testing Or SystemConcerns.MissionCriticality)>
Public MustInherit Class WritingStreamer
    Inherits Streamer
<InventoryAttribute(Concerns := SystemConcerns.Unspecified Or SystemConcerns.Testing Or SystemConcerns.MissionCriticality)>
Public MustInherit Class WritingStreamer
    Inherits Streamer
[InventoryAttribute(Concerns = SystemConcerns::Unspecified|SystemConcerns::Testing|SystemConcerns::MissionCriticality)]
public ref class WritingStreamer abstract : public Streamer
[InventoryAttribute(Concerns = SystemConcerns::Unspecified|SystemConcerns::Testing|SystemConcerns::MissionCriticality)]
public ref class WritingStreamer abstract : public Streamer
[<AbstractClassAttribute>]
[<InventoryAttribute(Concerns = SystemConcerns.Unspecified|SystemConcerns.Testing|SystemConcerns.MissionCriticality)>]
type WritingStreamer =
    class
        inherit Streamer
    end
[<AbstractClassAttribute>]
[<InventoryAttribute(Concerns = SystemConcerns.Unspecified|SystemConcerns.Testing|SystemConcerns.MissionCriticality)>]
type WritingStreamer =
    class
        inherit Streamer
    end
See Also
WritingStreamer Members
NFX.IO Namespace


WritingStreamer Members

WritingStreamer Members NFX Class Library

The WritingStreamer type exposes the following members.
Constructors
 | Name | Description
Protected method | WritingStreamer | Initializes a new instance of the WritingStreamer class
Back to Top
Methods
 | Name | Description
Public method | BindStream | Sets the stream as the target for output/input. This call must be coupled with UnbindStream() (Inherited from Streamer.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UnbindStream | Unbinds the current stream. This call is coupled with BindStream(stream) (Inherited from Streamer.)
Public method | Write(Boolean) |
Public method | Write(Byte) |
Public method | Write( Byte ) |
Public method | Write(Char) |
Public method | Write( Char ) |
Public method | Write(DateTime) |
Public method | Write(Decimal) |
Public method | Write( Decimal ) |
Public method | Write(Double) |
Public method | Write( Double ) |
Public method | Write(Guid) |
Public method | Write(Int16) |
Public method | Write(Int32) |
Public method | Write( Int32 ) |
Public method | Write(Int64) |
Public method | Write( Int64 ) |
Public method | Write(Nullable Boolean ) |
Public method | Write(Nullable Byte ) |
Public method | Write(Nullable Char ) |
Public method | Write(Nullable DateTime ) |
Public method | Write(Nullable Decimal ) |
Public method | Write(Nullable Double ) |
Public method | Write(Nullable Guid ) |
Public method | Write(Nullable Int16 ) |
Public method | Write(Nullable Int32 ) |
Public method | Write(Nullable Int64 ) |
Public method | Write(Nullable SByte ) |
Public method | Write(Nullable Single ) |
Public method | Write(Nullable TimeSpan ) |
Public method | Write(Nullable UInt16 ) |
Public method | Write(Nullable UInt32 ) |
Public method | Write(Nullable UInt64 ) |
Public method | Write(SByte) |
Public method | Write(Single) |
Public method | Write( Single ) |
Public method | Write(String) |
Public method | Write( String ) |
Public method | Write(TimeSpan) |
Public method | Write(UInt16) |
Public method | Write(UInt32) |
Public method | Write(UInt64) |
Public method | Write(Amount) |
Public method | Write(Nullable Amount ) |
Public method | Write(FID) |
Public method | Write(Nullable FID ) |
Public method | Write(GDID) |
Public method | Write(Nullable GDID ) |
Public method | Write(MetaHandle) |
Public method | Write(Nullable MetaHandle ) |
Public method | Write(MethodSpec) |
Public method | Write(NLSMap) |
Public method | Write(Nullable NLSMap ) |
Public method | Write(PilePointer) |
Public method | Write(Nullable PilePointer ) |
Public method | Write(StringMap) |
Public method | Write(TypeSpec) |
Public method | Write(VarIntStr) |
Public method | Write(Nullable VarIntStr ) |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Buff32 | (Inherited from Streamer.)
Protected field | m_Encoding | (Inherited from Streamer.)
Protected field | m_Stream | (Inherited from Streamer.)
Back to Top
Properties
 | Name | Description
Public property | Encoding | Returns stream string encoding (Inherited from Streamer.)
Public property | Format | Returns format that this streamer implements (Inherited from Streamer.)
Public property | Stream | Returns underlying stream if it is bound or null (Inherited from Streamer.)
Back to Top
See Also
WritingStreamer Class
NFX.IO Namespace


WritingStreamer Constructor

WritingStreamer Constructor NFX Class Library

Initializes a new instance of the WritingStreamer class

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected WritingStreamer(
    Encoding encoding = null
)
protected WritingStreamer(
    Encoding encoding = null
)
Protected Sub New (
    Optional encoding As Encoding = Nothing
)
Protected Sub New (
    Optional encoding As Encoding = Nothing
)
protected:
WritingStreamer(
    Encoding^ encoding = nullptr
)
protected:
WritingStreamer(
    Encoding^ encoding = nullptr
)
new :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> WritingStreamer
new :
        ?encoding : Encoding
(* Defaults:
        let _encoding = defaultArg encoding null
*)
-> WritingStreamer

Parameters

encoding (Optional)
Type: Online System.Text Encoding
See Also
WritingStreamer Class
WritingStreamer Members
NFX.IO Namespace


WritingStreamer Fields

WritingStreamer Fields NFX Class Library

The WritingStreamer type exposes the following members.
Fields
 | Name | Description
Protected field | m_Buff32 | (Inherited from Streamer.)
Protected field | m_Encoding | (Inherited from Streamer.)
Protected field | m_Stream | (Inherited from Streamer.)
Back to Top
See Also
WritingStreamer Class
NFX.IO Namespace


WritingStreamer Methods

WritingStreamer Methods NFX Class Library

The WritingStreamer type exposes the following members.
Methods
 | Name | Description
Public method | BindStream | Sets the stream as the target for output/input. This call must be coupled with UnbindStream() (Inherited from Streamer.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UnbindStream | Unbinds the current stream. This call is coupled with BindStream(stream) (Inherited from Streamer.)
Public method | Write(Boolean) |
Public method | Write(Byte) |
Public method | Write( Byte ) |
Public method | Write(Char) |
Public method | Write( Char ) |
Public method | Write(DateTime) |
Public method | Write(Decimal) |
Public method | Write( Decimal ) |
Public method | Write(Double) |
Public method | Write( Double ) |
Public method | Write(Guid) |
Public method | Write(Int16) |
Public method | Write(Int32) |
Public method | Write( Int32 ) |
Public method | Write(Int64) |
Public method | Write( Int64 ) |
Public method | Write(Nullable Boolean ) |
Public method | Write(Nullable Byte ) |
Public method | Write(Nullable Char ) |
Public method | Write(Nullable DateTime ) |
Public method | Write(Nullable Decimal ) |
Public method | Write(Nullable Double ) |
Public method | Write(Nullable Guid ) |
Public method | Write(Nullable Int16 ) |
Public method | Write(Nullable Int32 ) |
Public method | Write(Nullable Int64 ) |
Public method | Write(Nullable SByte ) |
Public method | Write(Nullable Single ) |
Public method | Write(Nullable TimeSpan ) |
Public method | Write(Nullable UInt16 ) |
Public method | Write(Nullable UInt32 ) |
Public method | Write(Nullable UInt64 ) |
Public method | Write(SByte) |
Public method | Write(Single) |
Public method | Write( Single ) |
Public method | Write(String) |
Public method | Write( String ) |
Public method | Write(TimeSpan) |
Public method | Write(UInt16) |
Public method | Write(UInt32) |
Public method | Write(UInt64) |
Public method | Write(Amount) |
Public method | Write(Nullable Amount ) |
Public method | Write(FID) |
Public method | Write(Nullable FID ) |
Public method | Write(GDID) |
Public method | Write(Nullable GDID ) |
Public method | Write(MetaHandle) |
Public method | Write(Nullable MetaHandle ) |
Public method | Write(MethodSpec) |
Public method | Write(NLSMap) |
Public method | Write(Nullable NLSMap ) |
Public method | Write(PilePointer) |
Public method | Write(Nullable PilePointer ) |
Public method | Write(StringMap) |
Public method | Write(TypeSpec) |
Public method | Write(VarIntStr) |
Public method | Write(Nullable VarIntStr ) |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WritingStreamer Class
NFX.IO Namespace


WritingStreamer.Flush Method

WritingStreamer Flush Method NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Flush()
public abstract void Flush()
Public MustOverride Sub Flush
Public MustOverride Sub Flush
public:
virtual void Flush() abstract
public:
virtual void Flush() abstract
abstract Flush : unit -> unit
abstract Flush : unit -> unit
See Also
WritingStreamer Class
WritingStreamer Members
NFX.IO Namespace


WritingStreamer.Write Method

WritingStreamer Write Method NFX Class Library

Overload List
 | Name | Description
Public method | Write(Boolean) |
Public method | Write(Byte) |
Public method | Write( Byte ) |
Public method | Write(Char) |
Public method | Write( Char ) |
Public method | Write(DateTime) |
Public method | Write(Decimal) |
Public method | Write( Decimal ) |
Public method | Write(Double) |
Public method | Write( Double ) |
Public method | Write(Guid) |
Public method | Write(Int16) |
Public method | Write(Int32) |
Public method | Write( Int32 ) |
Public method | Write(Int64) |
Public method | Write( Int64 ) |
Public method | Write(Nullable Boolean ) |
Public method | Write(Nullable Byte ) |
Public method | Write(Nullable Char ) |
Public method | Write(Nullable DateTime ) |
Public method | Write(Nullable Decimal ) |
Public method | Write(Nullable Double ) |
Public method | Write(Nullable Guid ) |
Public method | Write(Nullable Int16 ) |
Public method | Write(Nullable Int32 ) |
Public method | Write(Nullable Int64 ) |
Public method | Write(Nullable SByte ) |
Public method | Write(Nullable Single ) |
Public method | Write(Nullable TimeSpan ) |
Public method | Write(Nullable UInt16 ) |
Public method | Write(Nullable UInt32 ) |
Public method | Write(Nullable UInt64 ) |
Public method | Write(SByte) |
Public method | Write(Single) |
Public method | Write( Single ) |
Public method | Write(String) |
Public method | Write( String ) |
Public method | Write(TimeSpan) |
Public method | Write(UInt16) |
Public method | Write(UInt32) |
Public method | Write(UInt64) |
Public method | Write(Amount) |
Public method | Write(Nullable Amount ) |
Public method | Write(FID) |
Public method | Write(Nullable FID ) |
Public method | Write(GDID) |
Public method | Write(Nullable GDID ) |
Public method | Write(MetaHandle) |
Public method | Write(Nullable MetaHandle ) |
Public method | Write(MethodSpec) |
Public method | Write(NLSMap) |
Public method | Write(Nullable NLSMap ) |
Public method | Write(PilePointer) |
Public method | Write(Nullable PilePointer ) |
Public method | Write(StringMap) |
Public method | Write(TypeSpec) |
Public method | Write(VarIntStr) |
Public method | Write(Nullable VarIntStr ) |
Back to Top
See Also
WritingStreamer Class
WritingStreamer Members
NFX.IO Namespace


WritingStreamer.Write Method (Boolean)

WritingStreamer Write Method (Boolean) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    bool value
)
public abstract void Write(
    bool value
)
Public MustOverride Sub Write (
    value As Boolean
)
Public MustOverride Sub Write (
    value As Boolean
)
public:
virtual void Write(
    bool value
) abstract
public:
virtual void Write(
    bool value
) abstract
abstract Write :
        value : bool -> unit
abstract Write :
        value : bool -> unit

Parameters

value
Type: Online System Boolean
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Byte)

WritingStreamer Write Method (Byte) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    byte value
)
public abstract void Write(
    byte value
)
Public MustOverride Sub Write (
    value As Byte
)
Public MustOverride Sub Write (
    value As Byte
)
public:
virtual void Write(
    unsigned char value
) abstract
public:
virtual void Write(
    unsigned char value
) abstract
abstract Write :
        value : byte -> unit
abstract Write :
        value : byte -> unit

Parameters

value
Type: Online System Byte
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Byte[])

WritingStreamer Write Method ( Byte ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    byte[] buffer
)
public abstract void Write(
    byte[] buffer
)
Public MustOverride Sub Write (
    buffer As Byte()
)
Public MustOverride Sub Write (
    buffer As Byte()
)
public:
virtual void Write(
    array<unsigned char>^ buffer
) abstract
public:
virtual void Write(
    array<unsigned char>^ buffer
) abstract
abstract Write :
        buffer : byte[] -> unit
abstract Write :
        buffer : byte[] -> unit

Parameters

buffer
Type: Online System Byte
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Char)

WritingStreamer Write Method (Char) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    char ch
)
public abstract void Write(
    char ch
)
Public MustOverride Sub Write (
    ch As Char
)
Public MustOverride Sub Write (
    ch As Char
)
public:
virtual void Write(
    wchar_t ch
) abstract
public:
virtual void Write(
    wchar_t ch
) abstract
abstract Write :
        ch : char -> unit
abstract Write :
        ch : char -> unit

Parameters

ch
Type: Online System Char
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Char[])

WritingStreamer Write Method ( Char ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    char[] buffer
)
public abstract void Write(
    char[] buffer
)
Public MustOverride Sub Write (
    buffer As Char()
)
Public MustOverride Sub Write (
    buffer As Char()
)
public:
virtual void Write(
    array<wchar_t>^ buffer
) abstract
public:
virtual void Write(
    array<wchar_t>^ buffer
) abstract
abstract Write :
        buffer : char[] -> unit
abstract Write :
        buffer : char[] -> unit

Parameters

buffer
Type: Online System Char
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (DateTime)

WritingStreamer Write Method (DateTime) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    DateTime value
)
public abstract void Write(
    DateTime value
)
Public MustOverride Sub Write (
    value As DateTime
)
Public MustOverride Sub Write (
    value As DateTime
)
public:
virtual void Write(
    DateTime value
) abstract
public:
virtual void Write(
    DateTime value
) abstract
abstract Write :
        value : DateTime -> unit
abstract Write :
        value : DateTime -> unit

Parameters

value
Type: Online System DateTime
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Decimal)

WritingStreamer Write Method (Decimal) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    decimal value
)
public abstract void Write(
    decimal value
)
Public MustOverride Sub Write (
    value As Decimal
)
Public MustOverride Sub Write (
    value As Decimal
)
public:
virtual void Write(
    Decimal value
) abstract
public:
virtual void Write(
    Decimal value
) abstract
abstract Write :
        value : decimal -> unit
abstract Write :
        value : decimal -> unit

Parameters

value
Type: Online System Decimal
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Decimal[])

WritingStreamer Write Method ( Decimal ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    decimal[] value
)
public abstract void Write(
    decimal[] value
)
Public MustOverride Sub Write (
    value As Decimal()
)
Public MustOverride Sub Write (
    value As Decimal()
)
public:
virtual void Write(
    array<Decimal>^ value
) abstract
public:
virtual void Write(
    array<Decimal>^ value
) abstract
abstract Write :
        value : decimal[] -> unit
abstract Write :
        value : decimal[] -> unit

Parameters

value
Type: Online System Decimal
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Double)

WritingStreamer Write Method (Double) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    double value
)
public abstract void Write(
    double value
)
Public MustOverride Sub Write (
    value As Double
)
Public MustOverride Sub Write (
    value As Double
)
public:
virtual void Write(
    double value
) abstract
public:
virtual void Write(
    double value
) abstract
abstract Write :
        value : float -> unit
abstract Write :
        value : float -> unit

Parameters

value
Type: Online System Double
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Double[])

WritingStreamer Write Method ( Double ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    double[] value
)
public abstract void Write(
    double[] value
)
Public MustOverride Sub Write (
    value As Double()
)
Public MustOverride Sub Write (
    value As Double()
)
public:
virtual void Write(
    array<double>^ value
) abstract
public:
virtual void Write(
    array<double>^ value
) abstract
abstract Write :
        value : float[] -> unit
abstract Write :
        value : float[] -> unit

Parameters

value
Type: Online System Double
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Guid)

WritingStreamer Write Method (Guid) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    Guid value
)
public abstract void Write(
    Guid value
)
Public MustOverride Sub Write (
    value As Guid
)
Public MustOverride Sub Write (
    value As Guid
)
public:
virtual void Write(
    Guid value
) abstract
public:
virtual void Write(
    Guid value
) abstract
abstract Write :
        value : Guid -> unit
abstract Write :
        value : Guid -> unit

Parameters

value
Type: Online System Guid
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Int16)

WritingStreamer Write Method (Int16) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    short value
)
public abstract void Write(
    short value
)
Public MustOverride Sub Write (
    value As Short
)
Public MustOverride Sub Write (
    value As Short
)
public:
virtual void Write(
    short value
) abstract
public:
virtual void Write(
    short value
) abstract
abstract Write :
        value : int16 -> unit
abstract Write :
        value : int16 -> unit

Parameters

value
Type: Online System Int16
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Int32)

WritingStreamer Write Method (Int32) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    int value
)
public abstract void Write(
    int value
)
Public MustOverride Sub Write (
    value As Integer
)
Public MustOverride Sub Write (
    value As Integer
)
public:
virtual void Write(
    int value
) abstract
public:
virtual void Write(
    int value
) abstract
abstract Write :
        value : int -> unit
abstract Write :
        value : int -> unit

Parameters

value
Type: Online System Int32
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Int32[])

WritingStreamer Write Method ( Int32 ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    int[] value
)
public abstract void Write(
    int[] value
)
Public MustOverride Sub Write (
    value As Integer()
)
Public MustOverride Sub Write (
    value As Integer()
)
public:
virtual void Write(
    array<int>^ value
) abstract
public:
virtual void Write(
    array<int>^ value
) abstract
abstract Write :
        value : int[] -> unit
abstract Write :
        value : int[] -> unit

Parameters

value
Type: Online System Int32
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Int64)

WritingStreamer Write Method (Int64) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    long value
)
public abstract void Write(
    long value
)
Public MustOverride Sub Write (
    value As Long
)
Public MustOverride Sub Write (
    value As Long
)
public:
virtual void Write(
    long long value
) abstract
public:
virtual void Write(
    long long value
) abstract
abstract Write :
        value : int64 -> unit
abstract Write :
        value : int64 -> unit

Parameters

value
Type: Online System Int64
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Int64[])

WritingStreamer Write Method ( Int64 ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    long[] value
)
public abstract void Write(
    long[] value
)
Public MustOverride Sub Write (
    value As Long()
)
Public MustOverride Sub Write (
    value As Long()
)
public:
virtual void Write(
    array<long long>^ value
) abstract
public:
virtual void Write(
    array<long long>^ value
) abstract
abstract Write :
        value : int64[] -> unit
abstract Write :
        value : int64[] -> unit

Parameters

value
Type: Online System Int64
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Nullable(Boolean))

WritingStreamer Write Method (Nullable Boolean ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    Nullable<bool> value
)
public abstract void Write(
    Nullable<bool> value
)
Public MustOverride Sub Write (
    value As Nullable(Of Boolean)
)
Public MustOverride Sub Write (
    value As Nullable(Of Boolean)
)
public:
virtual void Write(
    Nullable<bool> value
) abstract
public:
virtual void Write(
    Nullable<bool> value
) abstract
abstract Write :
        value : Nullable<bool> -> unit
abstract Write :
        value : Nullable<bool> -> unit

Parameters

value
Type: Online System Nullable Online Boolean
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Nullable(Byte))

WritingStreamer Write Method (Nullable Byte ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    Nullable<byte> value
)
public abstract void Write(
    Nullable<byte> value
)
Public MustOverride Sub Write (
    value As Nullable(Of Byte)
)
Public MustOverride Sub Write (
    value As Nullable(Of Byte)
)
public:
virtual void Write(
    Nullable<unsigned char> value
) abstract
public:
virtual void Write(
    Nullable<unsigned char> value
) abstract
abstract Write :
        value : Nullable<byte> -> unit
abstract Write :
        value : Nullable<byte> -> unit

Parameters

value
Type: Online System Nullable Online Byte
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Nullable(Char))

WritingStreamer Write Method (Nullable Char ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    Nullable<char> value
)
public abstract void Write(
    Nullable<char> value
)
Public MustOverride Sub Write (
    value As Nullable(Of Char)
)
Public MustOverride Sub Write (
    value As Nullable(Of Char)
)
public:
virtual void Write(
    Nullable<wchar_t> value
) abstract
public:
virtual void Write(
    Nullable<wchar_t> value
) abstract
abstract Write :
        value : Nullable<char> -> unit
abstract Write :
        value : Nullable<char> -> unit

Parameters

value
Type: Online System Nullable Online Char
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Nullable(DateTime))

WritingStreamer Write Method (Nullable DateTime ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    Nullable<DateTime> value
)
public abstract void Write(
    Nullable<DateTime> value
)
Public MustOverride Sub Write (
    value As Nullable(Of DateTime)
)
Public MustOverride Sub Write (
    value As Nullable(Of DateTime)
)
public:
virtual void Write(
    Nullable<DateTime> value
) abstract
public:
virtual void Write(
    Nullable<DateTime> value
) abstract
abstract Write :
        value : Nullable<DateTime> -> unit
abstract Write :
        value : Nullable<DateTime> -> unit

Parameters

value
Type: Online System Nullable Online DateTime
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Nullable(Decimal))

WritingStreamer Write Method (Nullable Decimal ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    Nullable<decimal> value
)
public abstract void Write(
    Nullable<decimal> value
)
Public MustOverride Sub Write (
    value As Nullable(Of Decimal)
)
Public MustOverride Sub Write (
    value As Nullable(Of Decimal)
)
public:
virtual void Write(
    Nullable<Decimal> value
) abstract
public:
virtual void Write(
    Nullable<Decimal> value
) abstract
abstract Write :
        value : Nullable<decimal> -> unit
abstract Write :
        value : Nullable<decimal> -> unit

Parameters

value
Type: Online System Nullable Online Decimal
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Nullable(Double))

WritingStreamer Write Method (Nullable Double ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    Nullable<double> value
)
public abstract void Write(
    Nullable<double> value
)
Public MustOverride Sub Write (
    value As Nullable(Of Double)
)
Public MustOverride Sub Write (
    value As Nullable(Of Double)
)
public:
virtual void Write(
    Nullable<double> value
) abstract
public:
virtual void Write(
    Nullable<double> value
) abstract
abstract Write :
        value : Nullable<float> -> unit
abstract Write :
        value : Nullable<float> -> unit

Parameters

value
Type: Online System Nullable Online Double
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Nullable(Guid))

WritingStreamer Write Method (Nullable Guid ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    Nullable<Guid> value
)
public abstract void Write(
    Nullable<Guid> value
)
Public MustOverride Sub Write (
    value As Nullable(Of Guid)
)
Public MustOverride Sub Write (
    value As Nullable(Of Guid)
)
public:
virtual void Write(
    Nullable<Guid> value
) abstract
public:
virtual void Write(
    Nullable<Guid> value
) abstract
abstract Write :
        value : Nullable<Guid> -> unit
abstract Write :
        value : Nullable<Guid> -> unit

Parameters

value
Type: Online System Nullable Online Guid
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Nullable(Int16))

WritingStreamer Write Method (Nullable Int16 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    Nullable<short> value
)
public abstract void Write(
    Nullable<short> value
)
Public MustOverride Sub Write (
    value As Nullable(Of Short)
)
Public MustOverride Sub Write (
    value As Nullable(Of Short)
)
public:
virtual void Write(
    Nullable<short> value
) abstract
public:
virtual void Write(
    Nullable<short> value
) abstract
abstract Write :
        value : Nullable<int16> -> unit
abstract Write :
        value : Nullable<int16> -> unit

Parameters

value
Type: Online System Nullable Online Int16
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Nullable(Int32))

WritingStreamer Write Method (Nullable Int32 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    Nullable<int> value
)
public abstract void Write(
    Nullable<int> value
)
Public MustOverride Sub Write (
    value As Nullable(Of Integer)
)
Public MustOverride Sub Write (
    value As Nullable(Of Integer)
)
public:
virtual void Write(
    Nullable<int> value
) abstract
public:
virtual void Write(
    Nullable<int> value
) abstract
abstract Write :
        value : Nullable<int> -> unit
abstract Write :
        value : Nullable<int> -> unit

Parameters

value
Type: Online System Nullable Online Int32
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Nullable(Int64))

WritingStreamer Write Method (Nullable Int64 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    Nullable<long> value
)
public abstract void Write(
    Nullable<long> value
)
Public MustOverride Sub Write (
    value As Nullable(Of Long)
)
Public MustOverride Sub Write (
    value As Nullable(Of Long)
)
public:
virtual void Write(
    Nullable<long long> value
) abstract
public:
virtual void Write(
    Nullable<long long> value
) abstract
abstract Write :
        value : Nullable<int64> -> unit
abstract Write :
        value : Nullable<int64> -> unit

Parameters

value
Type: Online System Nullable Online Int64
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Nullable(SByte))

WritingStreamer Write Method (Nullable SByte ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    Nullable<sbyte> value
)
public abstract void Write(
    Nullable<sbyte> value
)
Public MustOverride Sub Write (
    value As Nullable(Of SByte)
)
Public MustOverride Sub Write (
    value As Nullable(Of SByte)
)
public:
virtual void Write(
    Nullable<signed char> value
) abstract
public:
virtual void Write(
    Nullable<signed char> value
) abstract
abstract Write :
        value : Nullable<sbyte> -> unit
abstract Write :
        value : Nullable<sbyte> -> unit

Parameters

value
Type: Online System Nullable Online SByte
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Nullable(Single))

WritingStreamer Write Method (Nullable Single ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    Nullable<float> value
)
public abstract void Write(
    Nullable<float> value
)
Public MustOverride Sub Write (
    value As Nullable(Of Single)
)
Public MustOverride Sub Write (
    value As Nullable(Of Single)
)
public:
virtual void Write(
    Nullable<float> value
) abstract
public:
virtual void Write(
    Nullable<float> value
) abstract
abstract Write :
        value : Nullable<float32> -> unit
abstract Write :
        value : Nullable<float32> -> unit

Parameters

value
Type: Online System Nullable Online Single
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Nullable(TimeSpan))

WritingStreamer Write Method (Nullable TimeSpan ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    Nullable<TimeSpan> value
)
public abstract void Write(
    Nullable<TimeSpan> value
)
Public MustOverride Sub Write (
    value As Nullable(Of TimeSpan)
)
Public MustOverride Sub Write (
    value As Nullable(Of TimeSpan)
)
public:
virtual void Write(
    Nullable<TimeSpan> value
) abstract
public:
virtual void Write(
    Nullable<TimeSpan> value
) abstract
abstract Write :
        value : Nullable<TimeSpan> -> unit
abstract Write :
        value : Nullable<TimeSpan> -> unit

Parameters

value
Type: Online System Nullable Online TimeSpan
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Nullable(UInt16))

WritingStreamer Write Method (Nullable UInt16 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    Nullable<ushort> value
)
public abstract void Write(
    Nullable<ushort> value
)
Public MustOverride Sub Write (
    value As Nullable(Of UShort)
)
Public MustOverride Sub Write (
    value As Nullable(Of UShort)
)
public:
virtual void Write(
    Nullable<unsigned short> value
) abstract
public:
virtual void Write(
    Nullable<unsigned short> value
) abstract
abstract Write :
        value : Nullable<uint16> -> unit
abstract Write :
        value : Nullable<uint16> -> unit

Parameters

value
Type: Online System Nullable Online UInt16
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Nullable(UInt32))

WritingStreamer Write Method (Nullable UInt32 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    Nullable<uint> value
)
public abstract void Write(
    Nullable<uint> value
)
Public MustOverride Sub Write (
    value As Nullable(Of UInteger)
)
Public MustOverride Sub Write (
    value As Nullable(Of UInteger)
)
public:
virtual void Write(
    Nullable<unsigned int> value
) abstract
public:
virtual void Write(
    Nullable<unsigned int> value
) abstract
abstract Write :
        value : Nullable<uint32> -> unit
abstract Write :
        value : Nullable<uint32> -> unit

Parameters

value
Type: Online System Nullable Online UInt32
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Nullable(UInt64))

WritingStreamer Write Method (Nullable UInt64 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    Nullable<ulong> value
)
public abstract void Write(
    Nullable<ulong> value
)
Public MustOverride Sub Write (
    value As Nullable(Of ULong)
)
Public MustOverride Sub Write (
    value As Nullable(Of ULong)
)
public:
virtual void Write(
    Nullable<unsigned long long> value
) abstract
public:
virtual void Write(
    Nullable<unsigned long long> value
) abstract
abstract Write :
        value : Nullable<uint64> -> unit
abstract Write :
        value : Nullable<uint64> -> unit

Parameters

value
Type: Online System Nullable Online UInt64
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (SByte)

WritingStreamer Write Method (SByte) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    sbyte value
)
public abstract void Write(
    sbyte value
)
Public MustOverride Sub Write (
    value As SByte
)
Public MustOverride Sub Write (
    value As SByte
)
public:
virtual void Write(
    signed char value
) abstract
public:
virtual void Write(
    signed char value
) abstract
abstract Write :
        value : sbyte -> unit
abstract Write :
        value : sbyte -> unit

Parameters

value
Type: Online System SByte
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Single)

WritingStreamer Write Method (Single) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    float value
)
public abstract void Write(
    float value
)
Public MustOverride Sub Write (
    value As Single
)
Public MustOverride Sub Write (
    value As Single
)
public:
virtual void Write(
    float value
) abstract
public:
virtual void Write(
    float value
) abstract
abstract Write :
        value : float32 -> unit
abstract Write :
        value : float32 -> unit

Parameters

value
Type: Online System Single
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Single[])

WritingStreamer Write Method ( Single ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    float[] value
)
public abstract void Write(
    float[] value
)
Public MustOverride Sub Write (
    value As Single()
)
Public MustOverride Sub Write (
    value As Single()
)
public:
virtual void Write(
    array<float>^ value
) abstract
public:
virtual void Write(
    array<float>^ value
) abstract
abstract Write :
        value : float32[] -> unit
abstract Write :
        value : float32[] -> unit

Parameters

value
Type: Online System Single
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (String)

WritingStreamer Write Method (String) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    string value
)
public abstract void Write(
    string value
)
Public MustOverride Sub Write (
    value As String
)
Public MustOverride Sub Write (
    value As String
)
public:
virtual void Write(
    String^ value
) abstract
public:
virtual void Write(
    String^ value
) abstract
abstract Write :
        value : string -> unit
abstract Write :
        value : string -> unit

Parameters

value
Type: Online System String
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (String[])

WritingStreamer Write Method ( String ) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    string[] array
)
public abstract void Write(
    string[] array
)
Public MustOverride Sub Write (
    array As String()
)
Public MustOverride Sub Write (
    array As String()
)
public:
virtual void Write(
    array<String^>^ array
) abstract
public:
virtual void Write(
    array<String^>^ array
) abstract
abstract Write :
        array : string[] -> unit
abstract Write :
        array : string[] -> unit

Parameters

array
Type: Online System String
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (TimeSpan)

WritingStreamer Write Method (TimeSpan) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    TimeSpan value
)
public abstract void Write(
    TimeSpan value
)
Public MustOverride Sub Write (
    value As TimeSpan
)
Public MustOverride Sub Write (
    value As TimeSpan
)
public:
virtual void Write(
    TimeSpan value
) abstract
public:
virtual void Write(
    TimeSpan value
) abstract
abstract Write :
        value : TimeSpan -> unit
abstract Write :
        value : TimeSpan -> unit

Parameters

value
Type: Online System TimeSpan
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (UInt16)

WritingStreamer Write Method (UInt16) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    ushort value
)
public abstract void Write(
    ushort value
)
Public MustOverride Sub Write (
    value As UShort
)
Public MustOverride Sub Write (
    value As UShort
)
public:
virtual void Write(
    unsigned short value
) abstract
public:
virtual void Write(
    unsigned short value
) abstract
abstract Write :
        value : uint16 -> unit
abstract Write :
        value : uint16 -> unit

Parameters

value
Type: Online System UInt16
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (UInt32)

WritingStreamer Write Method (UInt32) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    uint value
)
public abstract void Write(
    uint value
)
Public MustOverride Sub Write (
    value As UInteger
)
Public MustOverride Sub Write (
    value As UInteger
)
public:
virtual void Write(
    unsigned int value
) abstract
public:
virtual void Write(
    unsigned int value
) abstract
abstract Write :
        value : uint32 -> unit
abstract Write :
        value : uint32 -> unit

Parameters

value
Type: Online System UInt32
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (UInt64)

WritingStreamer Write Method (UInt64) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    ulong value
)
public abstract void Write(
    ulong value
)
Public MustOverride Sub Write (
    value As ULong
)
Public MustOverride Sub Write (
    value As ULong
)
public:
virtual void Write(
    unsigned long long value
) abstract
public:
virtual void Write(
    unsigned long long value
) abstract
abstract Write :
        value : uint64 -> unit
abstract Write :
        value : uint64 -> unit

Parameters

value
Type: Online System UInt64
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Amount)

WritingStreamer Write Method (Amount) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    Amount value
)
public abstract void Write(
    Amount value
)
Public MustOverride Sub Write (
    value As Amount
)
Public MustOverride Sub Write (
    value As Amount
)
public:
virtual void Write(
    Amount value
) abstract
public:
virtual void Write(
    Amount value
) abstract
abstract Write :
        value : Amount -> unit
abstract Write :
        value : Amount -> unit

Parameters

value
Type: NFX.Financial Amount
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Nullable(Amount))

WritingStreamer Write Method (Nullable Amount ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    Nullable<Amount> value
)
public abstract void Write(
    Nullable<Amount> value
)
Public MustOverride Sub Write (
    value As Nullable(Of Amount)
)
Public MustOverride Sub Write (
    value As Nullable(Of Amount)
)
public:
virtual void Write(
    Nullable<Amount> value
) abstract
public:
virtual void Write(
    Nullable<Amount> value
) abstract
abstract Write :
        value : Nullable<Amount> -> unit
abstract Write :
        value : Nullable<Amount> -> unit

Parameters

value
Type: Online System Nullable Amount
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (FID)

WritingStreamer Write Method (FID) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    FID value
)
public abstract void Write(
    FID value
)
Public MustOverride Sub Write (
    value As FID
)
Public MustOverride Sub Write (
    value As FID
)
public:
virtual void Write(
    FID value
) abstract
public:
virtual void Write(
    FID value
) abstract
abstract Write :
        value : FID -> unit
abstract Write :
        value : FID -> unit

Parameters

value
Type: NFX FID
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Nullable(FID))

WritingStreamer Write Method (Nullable FID ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    Nullable<FID> value
)
public abstract void Write(
    Nullable<FID> value
)
Public MustOverride Sub Write (
    value As Nullable(Of FID)
)
Public MustOverride Sub Write (
    value As Nullable(Of FID)
)
public:
virtual void Write(
    Nullable<FID> value
) abstract
public:
virtual void Write(
    Nullable<FID> value
) abstract
abstract Write :
        value : Nullable<FID> -> unit
abstract Write :
        value : Nullable<FID> -> unit

Parameters

value
Type: Online System Nullable FID
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (GDID)

WritingStreamer Write Method (GDID) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    GDID value
)
public abstract void Write(
    GDID value
)
Public MustOverride Sub Write (
    value As GDID
)
Public MustOverride Sub Write (
    value As GDID
)
public:
virtual void Write(
    GDID value
) abstract
public:
virtual void Write(
    GDID value
) abstract
abstract Write :
        value : GDID -> unit
abstract Write :
        value : GDID -> unit

Parameters

value
Type: NFX.DataAccess.Distributed GDID
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Nullable(GDID))

WritingStreamer Write Method (Nullable GDID ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    Nullable<GDID> value
)
public abstract void Write(
    Nullable<GDID> value
)
Public MustOverride Sub Write (
    value As Nullable(Of GDID)
)
Public MustOverride Sub Write (
    value As Nullable(Of GDID)
)
public:
virtual void Write(
    Nullable<GDID> value
) abstract
public:
virtual void Write(
    Nullable<GDID> value
) abstract
abstract Write :
        value : Nullable<GDID> -> unit
abstract Write :
        value : Nullable<GDID> -> unit

Parameters

value
Type: Online System Nullable GDID
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (MetaHandle)

WritingStreamer Write Method (MetaHandle) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    MetaHandle value
)
public abstract void Write(
    MetaHandle value
)
Public MustOverride Sub Write (
    value As MetaHandle
)
Public MustOverride Sub Write (
    value As MetaHandle
)
public:
virtual void Write(
    MetaHandle value
) abstract
public:
virtual void Write(
    MetaHandle value
) abstract
abstract Write :
        value : MetaHandle -> unit
abstract Write :
        value : MetaHandle -> unit

Parameters

value
Type: NFX.IO MetaHandle
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Nullable(MetaHandle))

WritingStreamer Write Method (Nullable MetaHandle ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    Nullable<MetaHandle> value
)
public abstract void Write(
    Nullable<MetaHandle> value
)
Public MustOverride Sub Write (
    value As Nullable(Of MetaHandle)
)
Public MustOverride Sub Write (
    value As Nullable(Of MetaHandle)
)
public:
virtual void Write(
    Nullable<MetaHandle> value
) abstract
public:
virtual void Write(
    Nullable<MetaHandle> value
) abstract
abstract Write :
        value : Nullable<MetaHandle> -> unit
abstract Write :
        value : Nullable<MetaHandle> -> unit

Parameters

value
Type: Online System Nullable MetaHandle
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (MethodSpec)

WritingStreamer Write Method (MethodSpec) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    MethodSpec spec
)
public abstract void Write(
    MethodSpec spec
)
Public MustOverride Sub Write (
    spec As MethodSpec
)
Public MustOverride Sub Write (
    spec As MethodSpec
)
public:
virtual void Write(
    MethodSpec spec
) abstract
public:
virtual void Write(
    MethodSpec spec
) abstract
abstract Write :
        spec : MethodSpec -> unit
abstract Write :
        spec : MethodSpec -> unit

Parameters

spec
Type: NFX.Glue.Protocol MethodSpec
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (NLSMap)

WritingStreamer Write Method (NLSMap) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    NLSMap map
)
public abstract void Write(
    NLSMap map
)
Public MustOverride Sub Write (
    map As NLSMap
)
Public MustOverride Sub Write (
    map As NLSMap
)
public:
virtual void Write(
    NLSMap map
) abstract
public:
virtual void Write(
    NLSMap map
) abstract
abstract Write :
        map : NLSMap -> unit
abstract Write :
        map : NLSMap -> unit

Parameters

map
Type: NFX.Serialization.JSON NLSMap
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Nullable(NLSMap))

WritingStreamer Write Method (Nullable NLSMap ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    Nullable<NLSMap> map
)
public abstract void Write(
    Nullable<NLSMap> map
)
Public MustOverride Sub Write (
    map As Nullable(Of NLSMap)
)
Public MustOverride Sub Write (
    map As Nullable(Of NLSMap)
)
public:
virtual void Write(
    Nullable<NLSMap> map
) abstract
public:
virtual void Write(
    Nullable<NLSMap> map
) abstract
abstract Write :
        map : Nullable<NLSMap> -> unit
abstract Write :
        map : Nullable<NLSMap> -> unit

Parameters

map
Type: Online System Nullable NLSMap
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (PilePointer)

WritingStreamer Write Method (PilePointer) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    PilePointer value
)
public abstract void Write(
    PilePointer value
)
Public MustOverride Sub Write (
    value As PilePointer
)
Public MustOverride Sub Write (
    value As PilePointer
)
public:
virtual void Write(
    PilePointer value
) abstract
public:
virtual void Write(
    PilePointer value
) abstract
abstract Write :
        value : PilePointer -> unit
abstract Write :
        value : PilePointer -> unit

Parameters

value
Type: NFX.ApplicationModel.Pile PilePointer
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Nullable(PilePointer))

WritingStreamer Write Method (Nullable PilePointer ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    Nullable<PilePointer> value
)
public abstract void Write(
    Nullable<PilePointer> value
)
Public MustOverride Sub Write (
    value As Nullable(Of PilePointer)
)
Public MustOverride Sub Write (
    value As Nullable(Of PilePointer)
)
public:
virtual void Write(
    Nullable<PilePointer> value
) abstract
public:
virtual void Write(
    Nullable<PilePointer> value
) abstract
abstract Write :
        value : Nullable<PilePointer> -> unit
abstract Write :
        value : Nullable<PilePointer> -> unit

Parameters

value
Type: Online System Nullable PilePointer
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (StringMap)

WritingStreamer Write Method (StringMap) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    StringMap map
)
public abstract void Write(
    StringMap map
)
Public MustOverride Sub Write (
    map As StringMap
)
Public MustOverride Sub Write (
    map As StringMap
)
public:
virtual void Write(
    StringMap^ map
) abstract
public:
virtual void Write(
    StringMap^ map
) abstract
abstract Write :
        map : StringMap -> unit
abstract Write :
        map : StringMap -> unit

Parameters

map
Type: NFX.Collections StringMap
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (TypeSpec)

WritingStreamer Write Method (TypeSpec) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    TypeSpec spec
)
public abstract void Write(
    TypeSpec spec
)
Public MustOverride Sub Write (
    spec As TypeSpec
)
Public MustOverride Sub Write (
    spec As TypeSpec
)
public:
virtual void Write(
    TypeSpec spec
) abstract
public:
virtual void Write(
    TypeSpec spec
) abstract
abstract Write :
        spec : TypeSpec -> unit
abstract Write :
        spec : TypeSpec -> unit

Parameters

spec
Type: NFX.Glue.Protocol TypeSpec
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (VarIntStr)

WritingStreamer Write Method (VarIntStr) NFX Class Library

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    VarIntStr value
)
public abstract void Write(
    VarIntStr value
)
Public MustOverride Sub Write (
    value As VarIntStr
)
Public MustOverride Sub Write (
    value As VarIntStr
)
public:
virtual void Write(
    VarIntStr value
) abstract
public:
virtual void Write(
    VarIntStr value
) abstract
abstract Write :
        value : VarIntStr -> unit
abstract Write :
        value : VarIntStr -> unit

Parameters

value
Type: NFX.IO VarIntStr
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer.Write Method (Nullable(VarIntStr))

WritingStreamer Write Method (Nullable VarIntStr ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    Nullable<VarIntStr> value
)
public abstract void Write(
    Nullable<VarIntStr> value
)
Public MustOverride Sub Write (
    value As Nullable(Of VarIntStr)
)
Public MustOverride Sub Write (
    value As Nullable(Of VarIntStr)
)
public:
virtual void Write(
    Nullable<VarIntStr> value
) abstract
public:
virtual void Write(
    Nullable<VarIntStr> value
) abstract
abstract Write :
        value : Nullable<VarIntStr> -> unit
abstract Write :
        value : Nullable<VarIntStr> -> unit

Parameters

value
Type: Online System Nullable VarIntStr
See Also
WritingStreamer Class
WritingStreamer Members
Write Overload
NFX.IO Namespace


WritingStreamer Properties

WritingStreamer Properties NFX Class Library

The WritingStreamer type exposes the following members.
Properties
 | Name | Description
Public property | Encoding | Returns stream string encoding (Inherited from Streamer.)
Public property | Format | Returns format that this streamer implements (Inherited from Streamer.)
Public property | Stream | Returns underlying stream if it is bound or null (Inherited from Streamer.)
Back to Top
See Also
WritingStreamer Class
NFX.IO Namespace


NFX.IO.ErrorHandling Namespace

NFX.IO.ErrorHandling Namespace NFX Class Library

Provides varios error-correction functions like checksums and polynomial fields
Classes
 | Class | Description
Public class | GaloisField |
Public class | GaloisPolynomial |
Public class | ReedSolomonEncoder |
Structures
 | Structure | Description
Public structure | Adler32 | Implements Adler32 checksum algorithm
Public structure | CRC32 | Implements CRC32 checksum algorithm


Adler32 Structure

Adler32 Structure NFX Class Library

Implements Adler32 checksum algorithm

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct Adler32
public struct Adler32
Public Structure Adler32
Public Structure Adler32
public value class Adler32
public value class Adler32
[<SealedAttribute>]
type Adler32 =  struct end
[<SealedAttribute>]
type Adler32 =  struct end
See Also
Adler32 Members
NFX.IO.ErrorHandling Namespace


Adler32 Members

Adler32 Members NFX Class Library

The Adler32 type exposes the following members.
Methods
 | Name | Description
Public method | Add( Byte ) | Addes byte[] to checksum
Public method | Add(String) | Addes string to checksum
Public method | Add( Byte , Int32, Int32) |
Public method | Add(String, Int32, Int32) |
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | ForBytes | Computes Adler32 for byte array
 | ForEncodedString | Computes Adler32 for encoded string
 | ForString | Computes Adler32 for binary string representation (in-memory)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Value |
Back to Top
See Also
Adler32 Structure
NFX.IO.ErrorHandling Namespace


Adler32 Methods

Adler32 Methods NFX Class Library

The Adler32 type exposes the following members.
Methods
 | Name | Description
Public method | Add( Byte ) | Addes byte[] to checksum
Public method | Add(String) | Addes string to checksum
Public method | Add( Byte , Int32, Int32) |
Public method | Add(String, Int32, Int32) |
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | ForBytes | Computes Adler32 for byte array
 | ForEncodedString | Computes Adler32 for encoded string
 | ForString | Computes Adler32 for binary string representation (in-memory)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Adler32 Structure
NFX.IO.ErrorHandling Namespace


Adler32.Add Method

Adler32 Add Method NFX Class Library

Overload List
 | Name | Description
Public method | Add( Byte ) | Addes byte[] to checksum
Public method | Add(String) | Addes string to checksum
Public method | Add( Byte , Int32, Int32) |
Public method | Add(String, Int32, Int32) |
Back to Top
See Also
Adler32 Structure
Adler32 Members
NFX.IO.ErrorHandling Namespace


Adler32.Add Method (Byte[])

Adler32 Add Method ( Byte ) NFX Class Library

Addes byte[] to checksum

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    byte[] buff
)
public void Add(
    byte[] buff
)
Public Sub Add (
    buff As Byte()
)
Public Sub Add (
    buff As Byte()
)
public:
void Add(
    array<unsigned char>^ buff
)
public:
void Add(
    array<unsigned char>^ buff
)
member Add :
        buff : byte[] -> unit
member Add :
        buff : byte[] -> unit

Parameters

buff
Type: Online System Byte
See Also
Adler32 Structure
Adler32 Members
Add Overload
NFX.IO.ErrorHandling Namespace


Adler32.Add Method (String)

Adler32 Add Method (String) NFX Class Library

Addes string to checksum

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    string buff
)
public void Add(
    string buff
)
Public Sub Add (
    buff As String
)
Public Sub Add (
    buff As String
)
public:
void Add(
    String^ buff
)
public:
void Add(
    String^ buff
)
member Add :
        buff : string -> unit
member Add :
        buff : string -> unit

Parameters

buff
Type: Online System String
See Also
Adler32 Structure
Adler32 Members
Add Overload
NFX.IO.ErrorHandling Namespace


Adler32.Add Method (Byte[], Int32, Int32)

Adler32 Add Method ( Byte , Int32, Int32) NFX Class Library

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    byte[] buff,
    int offset,
    int count
)
public void Add(
    byte[] buff,
    int offset,
    int count
)
Public Sub Add (
    buff As Byte(),
    offset As Integer,
    count As Integer
)
Public Sub Add (
    buff As Byte(),
    offset As Integer,
    count As Integer
)
public:
void Add(
    array<unsigned char>^ buff,
    int offset,
    int count
)
public:
void Add(
    array<unsigned char>^ buff,
    int offset,
    int count
)
member Add :
        buff : byte[] *
        offset : int *
        count : int -> unit
member Add :
        buff : byte[] *
        offset : int *
        count : int -> unit

Parameters

buff
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32
See Also
Adler32 Structure
Adler32 Members
Add Overload
NFX.IO.ErrorHandling Namespace


Adler32.Add Method (String, Int32, Int32)

Adler32 Add Method (String, Int32, Int32) NFX Class Library

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    string buff,
    int offset,
    int count
)
public void Add(
    string buff,
    int offset,
    int count
)
Public Sub Add (
    buff As String,
    offset As Integer,
    count As Integer
)
Public Sub Add (
    buff As String,
    offset As Integer,
    count As Integer
)
public:
void Add(
    String^ buff,
    int offset,
    int count
)
public:
void Add(
    String^ buff,
    int offset,
    int count
)
member Add :
        buff : string *
        offset : int *
        count : int -> unit
member Add :
        buff : string *
        offset : int *
        count : int -> unit

Parameters

buff
Type: Online System String
offset
Type: Online System Int32
count
Type: Online System Int32
See Also
Adler32 Structure
Adler32 Members
Add Overload
NFX.IO.ErrorHandling Namespace


Adler32.ForBytes Method

Adler32 ForBytes Method NFX Class Library

Computes Adler32 for byte array

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static uint ForBytes(
    byte[] buff
)
public static uint ForBytes(
    byte[] buff
)
Public Shared Function ForBytes (
    buff As Byte()
) As UInteger
Public Shared Function ForBytes (
    buff As Byte()
) As UInteger
public:
static unsigned int ForBytes(
    array<unsigned char>^ buff
)
public:
static unsigned int ForBytes(
    array<unsigned char>^ buff
)
static member ForBytes :
        buff : byte[] -> uint32
static member ForBytes :
        buff : byte[] -> uint32

Parameters

buff
Type: Online System Byte

Return Value

Type: Online UInt32
See Also
Adler32 Structure
Adler32 Members
NFX.IO.ErrorHandling Namespace


Adler32.ForEncodedString Method

Adler32 ForEncodedString Method NFX Class Library

Computes Adler32 for encoded string

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static uint ForEncodedString(
    string text,
    Encoding encoding
)
public static uint ForEncodedString(
    string text,
    Encoding encoding
)
Public Shared Function ForEncodedString (
    text As String,
    encoding As Encoding
) As UInteger
Public Shared Function ForEncodedString (
    text As String,
    encoding As Encoding
) As UInteger
public:
static unsigned int ForEncodedString(
    String^ text,
    Encoding^ encoding
)
public:
static unsigned int ForEncodedString(
    String^ text,
    Encoding^ encoding
)
static member ForEncodedString :
        text : string *
        encoding : Encoding -> uint32
static member ForEncodedString :
        text : string *
        encoding : Encoding -> uint32

Parameters

text
Type: Online System String
encoding
Type: Online System.Text Encoding

Return Value

Type: Online UInt32
See Also
Adler32 Structure
Adler32 Members
NFX.IO.ErrorHandling Namespace


Adler32.ForString Method

Adler32 ForString Method NFX Class Library

Computes Adler32 for binary string representation (in-memory)

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static uint ForString(
    string text
)
public static uint ForString(
    string text
)
Public Shared Function ForString (
    text As String
) As UInteger
Public Shared Function ForString (
    text As String
) As UInteger
public:
static unsigned int ForString(
    String^ text
)
public:
static unsigned int ForString(
    String^ text
)
static member ForString :
        text : string -> uint32
static member ForString :
        text : string -> uint32

Parameters

text
Type: Online System String

Return Value

Type: Online UInt32
See Also
Adler32 Structure
Adler32 Members
NFX.IO.ErrorHandling Namespace


Adler32 Properties

Adler32 Properties NFX Class Library

The Adler32 type exposes the following members.
Properties
 | Name | Description
Public property | Value |
Back to Top
See Also
Adler32 Structure
NFX.IO.ErrorHandling Namespace


Adler32.Value Property

Adler32 Value Property NFX Class Library

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint Value { get; }
public uint Value { get; }
Public ReadOnly Property Value As UInteger
    Get
Public ReadOnly Property Value As UInteger
    Get
public:
property unsigned int Value {
    unsigned int get ();
}
public:
property unsigned int Value {
    unsigned int get ();
}
member Value : uint32 with get
member Value : uint32 with get

Property Value

Type: Online UInt32
See Also
Adler32 Structure
Adler32 Members
NFX.IO.ErrorHandling Namespace


CRC32 Structure

CRC32 Structure NFX Class Library

Implements CRC32 checksum algorithm

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct CRC32
public struct CRC32
Public Structure CRC32
Public Structure CRC32
public value class CRC32
public value class CRC32
[<SealedAttribute>]
type CRC32 =  struct end
[<SealedAttribute>]
type CRC32 =  struct end
See Also
CRC32 Members
NFX.IO.ErrorHandling Namespace


CRC32 Members

CRC32 Members NFX Class Library

The CRC32 type exposes the following members.
Methods
 | Name | Description
Public method | Add( Byte ) | Adds byte array into checksum
Public method | Add(Int32) | Adds integer value into checksum
Public method | Add( Byte , Int32, Int32) | Adds byte array into checksum
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | ForBytes | Computes CRC32 for byte array
 | ForEncodedString | Computes CRC32 for string
 | ForString | Computes CRC32 for binary string representation (in-memory)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Value | Returns present checksum for the pushed data
Back to Top
See Also
CRC32 Structure
NFX.IO.ErrorHandling Namespace


CRC32 Methods

CRC32 Methods NFX Class Library

The CRC32 type exposes the following members.
Methods
 | Name | Description
Public method | Add( Byte ) | Adds byte array into checksum
Public method | Add(Int32) | Adds integer value into checksum
Public method | Add( Byte , Int32, Int32) | Adds byte array into checksum
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | ForBytes | Computes CRC32 for byte array
 | ForEncodedString | Computes CRC32 for string
 | ForString | Computes CRC32 for binary string representation (in-memory)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CRC32 Structure
NFX.IO.ErrorHandling Namespace


CRC32.Add Method

CRC32 Add Method NFX Class Library

Overload List
 | Name | Description
Public method | Add( Byte ) | Adds byte array into checksum
Public method | Add(Int32) | Adds integer value into checksum
Public method | Add( Byte , Int32, Int32) | Adds byte array into checksum
Back to Top
See Also
CRC32 Structure
CRC32 Members
NFX.IO.ErrorHandling Namespace


CRC32.Add Method (Byte[])

CRC32 Add Method ( Byte ) NFX Class Library

Adds byte array into checksum

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    byte[] buff
)
public void Add(
    byte[] buff
)
Public Sub Add (
    buff As Byte()
)
Public Sub Add (
    buff As Byte()
)
public:
void Add(
    array<unsigned char>^ buff
)
public:
void Add(
    array<unsigned char>^ buff
)
member Add :
        buff : byte[] -> unit
member Add :
        buff : byte[] -> unit

Parameters

buff
Type: Online System Byte
See Also
CRC32 Structure
CRC32 Members
Add Overload
NFX.IO.ErrorHandling Namespace


CRC32.Add Method (Int32)

CRC32 Add Method (Int32) NFX Class Library

Adds integer value into checksum

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    int value
)
public void Add(
    int value
)
Public Sub Add (
    value As Integer
)
Public Sub Add (
    value As Integer
)
public:
void Add(
    int value
)
public:
void Add(
    int value
)
member Add :
        value : int -> unit
member Add :
        value : int -> unit

Parameters

value
Type: Online System Int32
See Also
CRC32 Structure
CRC32 Members
Add Overload
NFX.IO.ErrorHandling Namespace


CRC32.Add Method (Byte[], Int32, Int32)

CRC32 Add Method ( Byte , Int32, Int32) NFX Class Library

Adds byte array into checksum

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    byte[] buff,
    int idx,
    int length
)
public void Add(
    byte[] buff,
    int idx,
    int length
)
Public Sub Add (
    buff As Byte(),
    idx As Integer,
    length As Integer
)
Public Sub Add (
    buff As Byte(),
    idx As Integer,
    length As Integer
)
public:
void Add(
    array<unsigned char>^ buff,
    int idx,
    int length
)
public:
void Add(
    array<unsigned char>^ buff,
    int idx,
    int length
)
member Add :
        buff : byte[] *
        idx : int *
        length : int -> unit
member Add :
        buff : byte[] *
        idx : int *
        length : int -> unit

Parameters

buff
Type: Online System Byte
idx
Type: Online System Int32
length
Type: Online System Int32
See Also
CRC32 Structure
CRC32 Members
Add Overload
NFX.IO.ErrorHandling Namespace


CRC32.ForBytes Method

CRC32 ForBytes Method NFX Class Library

Computes CRC32 for byte array

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static uint ForBytes(
    byte[] buff
)
public static uint ForBytes(
    byte[] buff
)
Public Shared Function ForBytes (
    buff As Byte()
) As UInteger
Public Shared Function ForBytes (
    buff As Byte()
) As UInteger
public:
static unsigned int ForBytes(
    array<unsigned char>^ buff
)
public:
static unsigned int ForBytes(
    array<unsigned char>^ buff
)
static member ForBytes :
        buff : byte[] -> uint32
static member ForBytes :
        buff : byte[] -> uint32

Parameters

buff
Type: Online System Byte

Return Value

Type: Online UInt32
See Also
CRC32 Structure
CRC32 Members
NFX.IO.ErrorHandling Namespace


CRC32.ForEncodedString Method

CRC32 ForEncodedString Method NFX Class Library

Computes CRC32 for string

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static uint ForEncodedString(
    string text,
    Encoding encoding
)
public static uint ForEncodedString(
    string text,
    Encoding encoding
)
Public Shared Function ForEncodedString (
    text As String,
    encoding As Encoding
) As UInteger
Public Shared Function ForEncodedString (
    text As String,
    encoding As Encoding
) As UInteger
public:
static unsigned int ForEncodedString(
    String^ text,
    Encoding^ encoding
)
public:
static unsigned int ForEncodedString(
    String^ text,
    Encoding^ encoding
)
static member ForEncodedString :
        text : string *
        encoding : Encoding -> uint32
static member ForEncodedString :
        text : string *
        encoding : Encoding -> uint32

Parameters

text
Type: Online System String
encoding
Type: Online System.Text Encoding

Return Value

Type: Online UInt32
See Also
CRC32 Structure
CRC32 Members
NFX.IO.ErrorHandling Namespace


CRC32.ForString Method

CRC32 ForString Method NFX Class Library

Computes CRC32 for binary string representation (in-memory)

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static uint ForString(
    string text
)
public static uint ForString(
    string text
)
Public Shared Function ForString (
    text As String
) As UInteger
Public Shared Function ForString (
    text As String
) As UInteger
public:
static unsigned int ForString(
    String^ text
)
public:
static unsigned int ForString(
    String^ text
)
static member ForString :
        text : string -> uint32
static member ForString :
        text : string -> uint32

Parameters

text
Type: Online System String

Return Value

Type: Online UInt32
See Also
CRC32 Structure
CRC32 Members
NFX.IO.ErrorHandling Namespace


CRC32 Properties

CRC32 Properties NFX Class Library

The CRC32 type exposes the following members.
Properties
 | Name | Description
Public property | Value | Returns present checksum for the pushed data
Back to Top
See Also
CRC32 Structure
NFX.IO.ErrorHandling Namespace


CRC32.Value Property

CRC32 Value Property NFX Class Library

Returns present checksum for the pushed data

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint Value { get; }
public uint Value { get; }
Public ReadOnly Property Value As UInteger
    Get
Public ReadOnly Property Value As UInteger
    Get
public:
property unsigned int Value {
    unsigned int get ();
}
public:
property unsigned int Value {
    unsigned int get ();
}
member Value : uint32 with get
member Value : uint32 with get

Property Value

Type: Online UInt32
See Also
CRC32 Structure
CRC32 Members
NFX.IO.ErrorHandling Namespace


GaloisField Class

GaloisField Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.IO.ErrorHandling GaloisField

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GaloisField
public class GaloisField
Public Class GaloisField
Public Class GaloisField
public ref class GaloisField
public ref class GaloisField
type GaloisField =  class end
type GaloisField =  class end
See Also
GaloisField Members
NFX.IO.ErrorHandling Namespace


GaloisField Members

GaloisField Members NFX Class Library

The GaloisField type exposes the following members.
Constructors
 | Name | Description
Public method | GaloisField | Initializes a new instance of the GaloisField class
Back to Top
Methods
 | Name | Description
 | Add |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Exp |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GenerateMonomial |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Inverse |
Public method | Log |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Multiply |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
QRCODE_256 |
Back to Top
Properties
 | Name | Description
Public property | GeneratorBase |
Public property | Polynomial0 |
Public property | Polynomial1 |
Public property | Size |
Back to Top
See Also
GaloisField Class
NFX.IO.ErrorHandling Namespace


GaloisField Constructor

GaloisField Constructor NFX Class Library

Initializes a new instance of the GaloisField class

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GaloisField(
    int primitive,
    int size,
    int generatorBase
)
public GaloisField(
    int primitive,
    int size,
    int generatorBase
)
Public Sub New (
    primitive As Integer,
    size As Integer,
    generatorBase As Integer
)
Public Sub New (
    primitive As Integer,
    size As Integer,
    generatorBase As Integer
)
public:
GaloisField(
    int primitive,
    int size,
    int generatorBase
)
public:
GaloisField(
    int primitive,
    int size,
    int generatorBase
)
new :
        primitive : int *
        size : int *
        generatorBase : int -> GaloisField
new :
        primitive : int *
        size : int *
        generatorBase : int -> GaloisField

Parameters

primitive
Type: Online System Int32
size
Type: Online System Int32
generatorBase
Type: Online System Int32
See Also
GaloisField Class
GaloisField Members
NFX.IO.ErrorHandling Namespace


GaloisField Fields

GaloisField Fields NFX Class Library

The GaloisField type exposes the following members.
Fields
Name | Description
QRCODE_256 |
Back to Top
See Also
GaloisField Class
NFX.IO.ErrorHandling Namespace


GaloisField.QRCODE_256 Field

GaloisField QRCODE_256 Field NFX Class Library

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly GaloisField QRCODE_256
public static readonly GaloisField QRCODE_256
Public Shared ReadOnly QRCODE_256 As GaloisField
Public Shared ReadOnly QRCODE_256 As GaloisField
public:
static initonly GaloisField^ QRCODE_256
public:
static initonly GaloisField^ QRCODE_256
static val QRCODE_256: GaloisField
static val QRCODE_256: GaloisField

Field Value

Type: GaloisField
See Also
GaloisField Class
GaloisField Members
NFX.IO.ErrorHandling Namespace


GaloisField Methods

GaloisField Methods NFX Class Library

The GaloisField type exposes the following members.
Methods
 | Name | Description
 | Add |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Exp |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GenerateMonomial |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Inverse |
Public method | Log |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Multiply |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GaloisField Class
NFX.IO.ErrorHandling Namespace


GaloisField.Add Method

GaloisField Add Method NFX Class Library

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int Add(
    int a,
    int b
)
public static int Add(
    int a,
    int b
)
Public Shared Function Add (
    a As Integer,
    b As Integer
) As Integer
Public Shared Function Add (
    a As Integer,
    b As Integer
) As Integer
public:
static int Add(
    int a,
    int b
)
public:
static int Add(
    int a,
    int b
)
static member Add :
        a : int *
        b : int -> int
static member Add :
        a : int *
        b : int -> int

Parameters

a
Type: Online System Int32
b
Type: Online System Int32

Return Value

Type: Online Int32
See Also
GaloisField Class
GaloisField Members
NFX.IO.ErrorHandling Namespace


GaloisField.Exp Method

GaloisField Exp Method NFX Class Library

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Exp(
    int a
)
public int Exp(
    int a
)
Public Function Exp (
    a As Integer
) As Integer
Public Function Exp (
    a As Integer
) As Integer
public:
int Exp(
    int a
)
public:
int Exp(
    int a
)
member Exp :
        a : int -> int
member Exp :
        a : int -> int

Parameters

a
Type: Online System Int32

Return Value

Type: Online Int32
See Also
GaloisField Class
GaloisField Members
NFX.IO.ErrorHandling Namespace


GaloisField.GenerateMonomial Method

GaloisField GenerateMonomial Method NFX Class Library

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GaloisPolynomial GenerateMonomial(
    int degree,
    int coefficient
)
public GaloisPolynomial GenerateMonomial(
    int degree,
    int coefficient
)
Public Function GenerateMonomial (
    degree As Integer,
    coefficient As Integer
) As GaloisPolynomial
Public Function GenerateMonomial (
    degree As Integer,
    coefficient As Integer
) As GaloisPolynomial
public:
GaloisPolynomial^ GenerateMonomial(
    int degree,
    int coefficient
)
public:
GaloisPolynomial^ GenerateMonomial(
    int degree,
    int coefficient
)
member GenerateMonomial :
        degree : int *
        coefficient : int -> GaloisPolynomial
member GenerateMonomial :
        degree : int *
        coefficient : int -> GaloisPolynomial

Parameters

degree
Type: Online System Int32
coefficient
Type: Online System Int32

Return Value

Type: GaloisPolynomial
See Also
GaloisField Class
GaloisField Members
NFX.IO.ErrorHandling Namespace


GaloisField.Inverse Method

GaloisField Inverse Method NFX Class Library

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Inverse(
    int a
)
public int Inverse(
    int a
)
Public Function Inverse (
    a As Integer
) As Integer
Public Function Inverse (
    a As Integer
) As Integer
public:
int Inverse(
    int a
)
public:
int Inverse(
    int a
)
member Inverse :
        a : int -> int
member Inverse :
        a : int -> int

Parameters

a
Type: Online System Int32

Return Value

Type: Online Int32
See Also
GaloisField Class
GaloisField Members
NFX.IO.ErrorHandling Namespace


GaloisField.Log Method

GaloisField Log Method NFX Class Library

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Log(
    int a
)
public int Log(
    int a
)
Public Function Log (
    a As Integer
) As Integer
Public Function Log (
    a As Integer
) As Integer
public:
int Log(
    int a
)
public:
int Log(
    int a
)
member Log :
        a : int -> int
member Log :
        a : int -> int

Parameters

a
Type: Online System Int32

Return Value

Type: Online Int32
See Also
GaloisField Class
GaloisField Members
NFX.IO.ErrorHandling Namespace


GaloisField.Multiply Method

GaloisField Multiply Method NFX Class Library

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Multiply(
    int a,
    int b
)
public int Multiply(
    int a,
    int b
)
Public Function Multiply (
    a As Integer,
    b As Integer
) As Integer
Public Function Multiply (
    a As Integer,
    b As Integer
) As Integer
public:
int Multiply(
    int a,
    int b
)
public:
int Multiply(
    int a,
    int b
)
member Multiply :
        a : int *
        b : int -> int
member Multiply :
        a : int *
        b : int -> int

Parameters

a
Type: Online System Int32
b
Type: Online System Int32

Return Value

Type: Online Int32
See Also
GaloisField Class
GaloisField Members
NFX.IO.ErrorHandling Namespace


GaloisField Properties

GaloisField Properties NFX Class Library

The GaloisField type exposes the following members.
Properties
 | Name | Description
Public property | GeneratorBase |
Public property | Polynomial0 |
Public property | Polynomial1 |
Public property | Size |
Back to Top
See Also
GaloisField Class
NFX.IO.ErrorHandling Namespace


GaloisField.GeneratorBase Property

GaloisField GeneratorBase Property NFX Class Library

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int GeneratorBase { get; }
public int GeneratorBase { get; }
Public ReadOnly Property GeneratorBase As Integer
    Get
Public ReadOnly Property GeneratorBase As Integer
    Get
public:
property int GeneratorBase {
    int get ();
}
public:
property int GeneratorBase {
    int get ();
}
member GeneratorBase : int with get
member GeneratorBase : int with get

Property Value

Type: Online Int32
See Also
GaloisField Class
GaloisField Members
NFX.IO.ErrorHandling Namespace


GaloisField.Polynomial0 Property

GaloisField Polynomial0 Property NFX Class Library

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GaloisPolynomial Polynomial0 { get; }
public GaloisPolynomial Polynomial0 { get; }
Public ReadOnly Property Polynomial0 As GaloisPolynomial
    Get
Public ReadOnly Property Polynomial0 As GaloisPolynomial
    Get
public:
property GaloisPolynomial^ Polynomial0 {
    GaloisPolynomial^ get ();
}
public:
property GaloisPolynomial^ Polynomial0 {
    GaloisPolynomial^ get ();
}
member Polynomial0 : GaloisPolynomial with get
member Polynomial0 : GaloisPolynomial with get

Property Value

Type: GaloisPolynomial
See Also
GaloisField Class
GaloisField Members
NFX.IO.ErrorHandling Namespace


GaloisField.Polynomial1 Property

GaloisField Polynomial1 Property NFX Class Library

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GaloisPolynomial Polynomial1 { get; }
public GaloisPolynomial Polynomial1 { get; }
Public ReadOnly Property Polynomial1 As GaloisPolynomial
    Get
Public ReadOnly Property Polynomial1 As GaloisPolynomial
    Get
public:
property GaloisPolynomial^ Polynomial1 {
    GaloisPolynomial^ get ();
}
public:
property GaloisPolynomial^ Polynomial1 {
    GaloisPolynomial^ get ();
}
member Polynomial1 : GaloisPolynomial with get
member Polynomial1 : GaloisPolynomial with get

Property Value

Type: GaloisPolynomial
See Also
GaloisField Class
GaloisField Members
NFX.IO.ErrorHandling Namespace


GaloisField.Size Property

GaloisField Size Property NFX Class Library

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Size { get; }
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
public:
property int Size {
    int get ();
}
member Size : int with get
member Size : int with get

Property Value

Type: Online Int32
See Also
GaloisField Class
GaloisField Members
NFX.IO.ErrorHandling Namespace


GaloisPolynomial Class

GaloisPolynomial Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.IO.ErrorHandling GaloisPolynomial

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GaloisPolynomial
public class GaloisPolynomial
Public Class GaloisPolynomial
Public Class GaloisPolynomial
public ref class GaloisPolynomial
public ref class GaloisPolynomial
type GaloisPolynomial =  class end
type GaloisPolynomial =  class end
See Also
GaloisPolynomial Members
NFX.IO.ErrorHandling Namespace


GaloisPolynomial Members

GaloisPolynomial Members NFX Class Library

The GaloisPolynomial type exposes the following members.
Constructors
 | Name | Description
Public method | GaloisPolynomial | Initializes a new instance of the GaloisPolynomial class
Back to Top
Methods
 | Name | Description
Public method | Add |
Public method | Divide |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Multiply(GaloisPolynomial) |
Public method | Multiply(Int32, Int32) |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Coefficients |
Public property | Degree |
Public property | IsPolynomial0 |
Back to Top
See Also
GaloisPolynomial Class
NFX.IO.ErrorHandling Namespace


GaloisPolynomial Constructor

GaloisPolynomial Constructor NFX Class Library

Initializes a new instance of the GaloisPolynomial class

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GaloisPolynomial(
    GaloisField field,
    int[] coefficients
)
public GaloisPolynomial(
    GaloisField field,
    int[] coefficients
)
Public Sub New (
    field As GaloisField,
    coefficients As Integer()
)
Public Sub New (
    field As GaloisField,
    coefficients As Integer()
)
public:
GaloisPolynomial(
    GaloisField^ field,
    array<int>^ coefficients
)
public:
GaloisPolynomial(
    GaloisField^ field,
    array<int>^ coefficients
)
new :
        field : GaloisField *
        coefficients : int[] -> GaloisPolynomial
new :
        field : GaloisField *
        coefficients : int[] -> GaloisPolynomial

Parameters

field
Type: NFX.IO.ErrorHandling GaloisField
coefficients
Type: Online System Int32
See Also
GaloisPolynomial Class
GaloisPolynomial Members
NFX.IO.ErrorHandling Namespace


GaloisPolynomial Methods

GaloisPolynomial Methods NFX Class Library

The GaloisPolynomial type exposes the following members.
Methods
 | Name | Description
Public method | Add |
Public method | Divide |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Multiply(GaloisPolynomial) |
Public method | Multiply(Int32, Int32) |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GaloisPolynomial Class
NFX.IO.ErrorHandling Namespace


GaloisPolynomial.Add Method

GaloisPolynomial Add Method NFX Class Library

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GaloisPolynomial Add(
    GaloisPolynomial summand
)
public GaloisPolynomial Add(
    GaloisPolynomial summand
)
Public Function Add (
    summand As GaloisPolynomial
) As GaloisPolynomial
Public Function Add (
    summand As GaloisPolynomial
) As GaloisPolynomial
public:
GaloisPolynomial^ Add(
    GaloisPolynomial^ summand
)
public:
GaloisPolynomial^ Add(
    GaloisPolynomial^ summand
)
member Add :
        summand : GaloisPolynomial -> GaloisPolynomial
member Add :
        summand : GaloisPolynomial -> GaloisPolynomial

Parameters

summand
Type: NFX.IO.ErrorHandling GaloisPolynomial

Return Value

Type: GaloisPolynomial
See Also
GaloisPolynomial Class
GaloisPolynomial Members
NFX.IO.ErrorHandling Namespace


GaloisPolynomial.Divide Method

GaloisPolynomial Divide Method NFX Class Library

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Divide(
    GaloisPolynomial divider,
    out GaloisPolynomial quotient,
    out GaloisPolynomial remainder
)
public void Divide(
    GaloisPolynomial divider,
    out GaloisPolynomial quotient,
    out GaloisPolynomial remainder
)
Public Sub Divide (
    divider As GaloisPolynomial,
    <OutAttribute> ByRef quotient As GaloisPolynomial,
    <OutAttribute> ByRef remainder As GaloisPolynomial
)
Public Sub Divide (
    divider As GaloisPolynomial,
    <OutAttribute> ByRef quotient As GaloisPolynomial,
    <OutAttribute> ByRef remainder As GaloisPolynomial
)
public:
void Divide(
    GaloisPolynomial^ divider,
    [OutAttribute] GaloisPolynomial^% quotient,
    [OutAttribute] GaloisPolynomial^% remainder
)
public:
void Divide(
    GaloisPolynomial^ divider,
    [OutAttribute] GaloisPolynomial^% quotient,
    [OutAttribute] GaloisPolynomial^% remainder
)
member Divide :
        divider : GaloisPolynomial *
        quotient : GaloisPolynomial byref *
        remainder : GaloisPolynomial byref -> unit
member Divide :
        divider : GaloisPolynomial *
        quotient : GaloisPolynomial byref *
        remainder : GaloisPolynomial byref -> unit

Parameters

divider
Type: NFX.IO.ErrorHandling GaloisPolynomial
quotient
Type: NFX.IO.ErrorHandling GaloisPolynomial
remainder
Type: NFX.IO.ErrorHandling GaloisPolynomial
See Also
GaloisPolynomial Class
GaloisPolynomial Members
NFX.IO.ErrorHandling Namespace


GaloisPolynomial.Multiply Method

GaloisPolynomial Multiply Method NFX Class Library

Overload List
 | Name | Description
Public method | Multiply(GaloisPolynomial) |
Public method | Multiply(Int32, Int32) |
Back to Top
See Also
GaloisPolynomial Class
GaloisPolynomial Members
NFX.IO.ErrorHandling Namespace


GaloisPolynomial.Multiply Method (GaloisPolynomial)

GaloisPolynomial Multiply Method (GaloisPolynomial) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GaloisPolynomial Multiply(
    GaloisPolynomial factorPolynomial
)
public GaloisPolynomial Multiply(
    GaloisPolynomial factorPolynomial
)
Public Function Multiply (
    factorPolynomial As GaloisPolynomial
) As GaloisPolynomial
Public Function Multiply (
    factorPolynomial As GaloisPolynomial
) As GaloisPolynomial
public:
GaloisPolynomial^ Multiply(
    GaloisPolynomial^ factorPolynomial
)
public:
GaloisPolynomial^ Multiply(
    GaloisPolynomial^ factorPolynomial
)
member Multiply :
        factorPolynomial : GaloisPolynomial -> GaloisPolynomial
member Multiply :
        factorPolynomial : GaloisPolynomial -> GaloisPolynomial

Parameters

factorPolynomial
Type: NFX.IO.ErrorHandling GaloisPolynomial

Return Value

Type: GaloisPolynomial
See Also
GaloisPolynomial Class
GaloisPolynomial Members
Multiply Overload
NFX.IO.ErrorHandling Namespace


GaloisPolynomial.Multiply Method (Int32, Int32)

GaloisPolynomial Multiply Method (Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GaloisPolynomial Multiply(
    int degree,
    int coefficient
)
public GaloisPolynomial Multiply(
    int degree,
    int coefficient
)
Public Function Multiply (
    degree As Integer,
    coefficient As Integer
) As GaloisPolynomial
Public Function Multiply (
    degree As Integer,
    coefficient As Integer
) As GaloisPolynomial
public:
GaloisPolynomial^ Multiply(
    int degree,
    int coefficient
)
public:
GaloisPolynomial^ Multiply(
    int degree,
    int coefficient
)
member Multiply :
        degree : int *
        coefficient : int -> GaloisPolynomial
member Multiply :
        degree : int *
        coefficient : int -> GaloisPolynomial

Parameters

degree
Type: Online System Int32
coefficient
Type: Online System Int32

Return Value

Type: GaloisPolynomial
See Also
GaloisPolynomial Class
GaloisPolynomial Members
Multiply Overload
NFX.IO.ErrorHandling Namespace


GaloisPolynomial Properties

GaloisPolynomial Properties NFX Class Library

The GaloisPolynomial type exposes the following members.
Properties
 | Name | Description
Public property | Coefficients |
Public property | Degree |
Public property | IsPolynomial0 |
Back to Top
See Also
GaloisPolynomial Class
NFX.IO.ErrorHandling Namespace


GaloisPolynomial.Coefficients Property

GaloisPolynomial Coefficients Property NFX Class Library

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int[] Coefficients { get; }
public int[] Coefficients { get; }
Public ReadOnly Property Coefficients As Integer()
    Get
Public ReadOnly Property Coefficients As Integer()
    Get
public:
property array<int>^ Coefficients {
    array<int>^ get ();
}
public:
property array<int>^ Coefficients {
    array<int>^ get ();
}
member Coefficients : int[] with get
member Coefficients : int[] with get

Property Value

Type: Online Int32
See Also
GaloisPolynomial Class
GaloisPolynomial Members
NFX.IO.ErrorHandling Namespace


GaloisPolynomial.Degree Property

GaloisPolynomial Degree Property NFX Class Library

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Degree { get; }
public int Degree { get; }
Public ReadOnly Property Degree As Integer
    Get
Public ReadOnly Property Degree As Integer
    Get
public:
property int Degree {
    int get ();
}
public:
property int Degree {
    int get ();
}
member Degree : int with get
member Degree : int with get

Property Value

Type: Online Int32
See Also
GaloisPolynomial Class
GaloisPolynomial Members
NFX.IO.ErrorHandling Namespace


GaloisPolynomial.IsPolynomial0 Property

GaloisPolynomial IsPolynomial0 Property NFX Class Library

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsPolynomial0 { get; }
public bool IsPolynomial0 { get; }
Public ReadOnly Property IsPolynomial0 As Boolean
    Get
Public ReadOnly Property IsPolynomial0 As Boolean
    Get
public:
property bool IsPolynomial0 {
    bool get ();
}
public:
property bool IsPolynomial0 {
    bool get ();
}
member IsPolynomial0 : bool with get
member IsPolynomial0 : bool with get

Property Value

Type: Online Boolean
See Also
GaloisPolynomial Class
GaloisPolynomial Members
NFX.IO.ErrorHandling Namespace


ReedSolomonEncoder Class

ReedSolomonEncoder Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.IO.ErrorHandling ReedSolomonEncoder

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ReedSolomonEncoder
public class ReedSolomonEncoder
Public Class ReedSolomonEncoder
Public Class ReedSolomonEncoder
public ref class ReedSolomonEncoder
public ref class ReedSolomonEncoder
type ReedSolomonEncoder =  class end
type ReedSolomonEncoder =  class end
See Also
ReedSolomonEncoder Members
NFX.IO.ErrorHandling Namespace


ReedSolomonEncoder Members

ReedSolomonEncoder Members NFX Class Library

The ReedSolomonEncoder type exposes the following members.
Constructors
 | Name | Description
Public method | ReedSolomonEncoder | Initializes a new instance of the ReedSolomonEncoder class
Back to Top
Methods
 | Name | Description
Public method | Encode |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ReedSolomonEncoder Class
NFX.IO.ErrorHandling Namespace


ReedSolomonEncoder Constructor

ReedSolomonEncoder Constructor NFX Class Library

Initializes a new instance of the ReedSolomonEncoder class

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ReedSolomonEncoder(
    GaloisField field
)
public ReedSolomonEncoder(
    GaloisField field
)
Public Sub New (
    field As GaloisField
)
Public Sub New (
    field As GaloisField
)
public:
ReedSolomonEncoder(
    GaloisField^ field
)
public:
ReedSolomonEncoder(
    GaloisField^ field
)
new :
        field : GaloisField -> ReedSolomonEncoder
new :
        field : GaloisField -> ReedSolomonEncoder

Parameters

field
Type: NFX.IO.ErrorHandling GaloisField
See Also
ReedSolomonEncoder Class
ReedSolomonEncoder Members
NFX.IO.ErrorHandling Namespace


ReedSolomonEncoder Methods

ReedSolomonEncoder Methods NFX Class Library

The ReedSolomonEncoder type exposes the following members.
Methods
 | Name | Description
Public method | Encode |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ReedSolomonEncoder Class
NFX.IO.ErrorHandling Namespace


ReedSolomonEncoder.Encode Method

ReedSolomonEncoder Encode Method NFX Class Library

Namespace: NFX.IO.ErrorHandling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Encode(
    int[] src,
    int errorCorrectionLength
)
public void Encode(
    int[] src,
    int errorCorrectionLength
)
Public Sub Encode (
    src As Integer(),
    errorCorrectionLength As Integer
)
Public Sub Encode (
    src As Integer(),
    errorCorrectionLength As Integer
)
public:
void Encode(
    array<int>^ src,
    int errorCorrectionLength
)
public:
void Encode(
    array<int>^ src,
    int errorCorrectionLength
)
member Encode :
        src : int[] *
        errorCorrectionLength : int -> unit
member Encode :
        src : int[] *
        errorCorrectionLength : int -> unit

Parameters

src
Type: Online System Int32
errorCorrectionLength
Type: Online System Int32
See Also
ReedSolomonEncoder Class
ReedSolomonEncoder Members
NFX.IO.ErrorHandling Namespace


NFX.IO.FileSystem Namespace

NFX.IO.FileSystem Namespace NFX Class Library

Provides abstraction for working with varios file systems like Amazon S3, NFTS, FDFS, ACFS
Classes
Class Description
Public class DeleteFilesJob
Represents a job(a scheduled event) which deletes FS files
Public class FileSystem
Provides a base for various file system abstractions. FileSystem abstractions are mostly useful for working with components/classes that may need to inter-operate not only with local file system but also with distributed systems like ApacheHDFS, SVN, GIT, or Aum Cluster Big-Transactional File System (BoltFS). NFX library provides compatibility wrapper 'NFX.IO.FileSystem.Local.LocalFileSystem' for access to local machine file system (which is based on this class and is implemented using a traditional System.IO.* set of classes). The FileSystem abstraction supports the following concepts: versioning, transactions, metadata, security; however it does not guarantee that every implementation is capable of providing all of these functions. Query "GeneralCapabilities" and "InstanceCapabilities" to see what functions are supported by a particular instance. This class is not thread-safe unless stated otherwise on method level, however multiple threads are allowed to obtain their own FileSystemSession object via a call to StartSession() which is thread safe
Public class FileSystemDirectory
Represents a directory item in a file system. This class is NOT thread-safe
Public class FileSystemException
General NFX file system specific exception
Public class FileSystemFile
Represents a file in a file system. This class is NOT thread-safe
Public class FileSystemSession
Represents a user-impersonated session of working with a file system. This class is NOT thread-safe
Public class FileSystemSessionConnectParams
Provides parameters for new sessions establishment
Public class FileSystemSessionItem
Represents an abstraction for items kept in a file system - i.e. directories and files.This class is NOT thread-safe
Public class FileSystemStarter
Represents a starter that launches file systems on startup
Public class FileSystemStream
Represents a stream that can work with contents of FileSystem. This class is NOT thread-safe
Interfaces
 | Interface | Description
Public interface | IFileSystem | Stipulates contract for various file system abstractions. FileSystem abstractions are mostly useful for working with components/classes that may need to inter-operate not only with local file system but also with distributed systems like ApacheHDFS, SVN, GIT, or Aum Cluster File System (ACFS). NFX library provides compatibility wrapper 'NFX.IO.FileSystem.Local.LocalFileSystem' for access to local machine file system (which is based on this class and is implemented using a traditional System.IO.* set of classes). The FileSystem abstraction supports the following concepts: versioning, transactions, metadata, security; however it does not guarantee that every implementation is capable of providing all of these functions. Query "GeneralCapabilities" and "InstanceCapabilities" to see what functions are supported by a particular instance.
Public interface | IFileSystemCapabilities | Supplies capabilities for the file system. The implementation must be thread safe
Public interface | IFileSystemHandle | Denotes a handle for item in a file system. For example: in a distributed system this may be some form of unique file/directory id (i.e. a GUID) or object instance internal to implementation
Public interface | IFileSystemImplementation |
Public interface | IFileSystemTransactionHandle | Denotes a handle for transaction in a file system. For example: in a distributed system this may be an object instance holding information about transaction which is internal to implementation
Public interface | IFileSystemVersion | Decorates entities that represent version for file systems that support versioning
Enumerations
 | Enumeration | Description
Public enumeration | FileSystemDirectory DirCopyFlags |


DeleteFilesJob Class

DeleteFilesJob Class NFX Class Library

Represents a job(a scheduled event) which deletes FS files
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Time Event
NFX.IO.FileSystem DeleteFilesJob

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class DeleteFilesJob : Event
public class DeleteFilesJob : Event
Public Class DeleteFilesJob
    Inherits Event
Public Class DeleteFilesJob
    Inherits Event
public ref class DeleteFilesJob : public Event
public ref class DeleteFilesJob : public Event
type DeleteFilesJob =
    class
        inherit Event
    end
type DeleteFilesJob =
    class
        inherit Event
    end
See Also
DeleteFilesJob Members
NFX.IO.FileSystem Namespace


DeleteFilesJob Members

DeleteFilesJob Members NFX Class Library

The DeleteFilesJob type exposes the following members.
Constructors
 | Name | Description
Public method | DeleteFilesJob(IEventTimer, IConfigSectionNode) | Initializes a new instance of the DeleteFilesJob class
Public method | DeleteFilesJob(IEventTimer, String, Nullable TimeSpan , IConfigSectionNode, FileSystem, FileSystemSessionConnectParams, String) | Initializes a new instance of the DeleteFilesJob class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AdjustDate | Adjusts date time Localized time (Inherited from Event.)
Public method | BindFS |
Public method | Configure | (Overrides Event Configure(IConfigSectionNode).)
Protected method | Destructor | (Overrides Event Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoFire | (Overrides Event DoFire .)
Protected method | DoHandleError | (Overrides Event DoHandleError(Exception).)
Protected method | DoVisit | Override to perform extra status checks (Inherited from Event.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Event.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Event.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Event.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Fire | Calls event regardless of any constraints. Invokes a handler right away if syncInvoke is true or BodyAsyncModel is Sync, otherwise queues the task on a thread pool either as a regular or long-running task depending on BodyAsyncModel (Inherited from Event.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Event.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ResetCallCount | Resets call count counter. If this event has expired it will eventually transition to Started state. Keep in mind that it may expire again if EndDate is set and past due (Inherited from Event.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Event.)
Protected method | VisitAndCheck | Invoked by timer, checks all conditions and fires/expires event depending on the status. Returns true if event was fired, false otherwise (Inherited from Event.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | CONFIG_CONTENT_FS_SECTION |
 | CONFIG_FS_CONNECT_PARAMS_SECTION |
 | CONFIG_FS_ROOT_PATH_ATTR |
Public field | EventHandler | References event handler that handles events. If it is null then only delegate events are called (Inherited from Event.)
Protected field | m_Lock | (Inherited from Event.)
Back to Top
Properties
 | Name | Description
Public property | BodyAsyncModel | Due to IO-nature this job is always executted as a long-running separate task (Overrides Event BodyAsyncModel.)
Public property | CallCount | Returns how many times this event was called (Inherited from Event.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Context | Adds arbitrary context object to the event (Inherited from Event.)
Public property | DeleteEmptyDirs |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Enabled | Specifies whether this event will fire/participate in timer loop (Inherited from Event.)
Public property | EndDate | Specifies when this event will stop firing in the local event time (Inherited from Event.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Event.)
Public property | FileSystem | Returns file system that serves static content for portals
Public property | FileSystemConnectParams |
Public property | FileSystemRootPath | Returns root path for content file system
Public property | Interval | Specifies how often event fires (Inherited from Event.)
Public property | LastCall | Returns when was this event called for the last time in the local event time (Inherited from Event.)
Public property | LastError | Returns the last exception thrown from event handler or nul if no error happened (Inherited from Event.)
Public property | LastModifyAgoHrs |
Public property | LastModifyFrom |
Public property | LastModifyTo |
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Event.)
Public property | LogStats |
Public property | MaxCount | Specifies how many times this event can be called. If less or equal than zero then no limit is set (Inherited from Event.)
Public property | MaxSize |
Public property | MinSize |
Public property | Name | (Inherited from Event.)
Public property | NameExcludePattern |
Public property | NameIncludePattern |
Public property | Recurse |
Public property | StartDate | Specifies when this event will start firing in the local event time (Inherited from Event.)
Public property | Status | (Inherited from Event.)
Public property | TimeLocation | Returns time location that this Event instance operates under. (Inherited from Event.)
Public property | Timer | (Inherited from Event.)
Back to Top
Events
 | Name | Description
Public event | Body | Event body that gets called when the event is due. The body is always invoked ASYNCHRONOUSLY unless Fire(syncronous=true) is called in which case it gets called on a thread that called Fire(true) (Inherited from Event.)
Public event | DefinitionChange | Invoked when one of timer event definition parameters changes. Always called synchronously on the same thread that made a change. Subscribers should not block for long (Inherited from Event.)
Public event | StatusChange | Invoked when timer event status changes. Always called synchronously by the timer thread. Subscribers should not block for long (Inherited from Event.)
Back to Top
See Also
DeleteFilesJob Class
NFX.IO.FileSystem Namespace


DeleteFilesJob Constructor

DeleteFilesJob Constructor NFX Class Library

Overload List
 | Name | Description
Public method | DeleteFilesJob(IEventTimer, IConfigSectionNode) | Initializes a new instance of the DeleteFilesJob class
Public method | DeleteFilesJob(IEventTimer, String, Nullable TimeSpan , IConfigSectionNode, FileSystem, FileSystemSessionConnectParams, String) | Initializes a new instance of the DeleteFilesJob class
Back to Top
See Also
DeleteFilesJob Class
DeleteFilesJob Members
NFX.IO.FileSystem Namespace


DeleteFilesJob Constructor (IEventTimer, IConfigSectionNode)

DeleteFilesJob Constructor (IEventTimer, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DeleteFilesJob class

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DeleteFilesJob(
    IEventTimer timer,
    IConfigSectionNode config
)
public DeleteFilesJob(
    IEventTimer timer,
    IConfigSectionNode config
)
Public Sub New (
    timer As IEventTimer,
    config As IConfigSectionNode
)
Public Sub New (
    timer As IEventTimer,
    config As IConfigSectionNode
)
public:
DeleteFilesJob(
    IEventTimer^ timer,
    IConfigSectionNode^ config
)
public:
DeleteFilesJob(
    IEventTimer^ timer,
    IConfigSectionNode^ config
)
new :
        timer : IEventTimer *
        config : IConfigSectionNode -> DeleteFilesJob
new :
        timer : IEventTimer *
        config : IConfigSectionNode -> DeleteFilesJob

Parameters

timer
Type: NFX.Time IEventTimer
config
Type: NFX.Environment IConfigSectionNode
See Also
DeleteFilesJob Class
DeleteFilesJob Members
DeleteFilesJob Overload
NFX.IO.FileSystem Namespace


DeleteFilesJob Constructor (IEventTimer, String, Nullable(TimeSpan), IConfigSectionNode, FileSystem, FileSystemSessionConnectParams, String)

DeleteFilesJob Constructor (IEventTimer, String, Nullable TimeSpan , IConfigSectionNode, FileSystem, FileSystemSessionConnectParams, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DeleteFilesJob class

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DeleteFilesJob(
    IEventTimer timer,
    string name = null,
    Nullable<TimeSpan> interval = null,
    IConfigSectionNode config = null,
    FileSystem fs = null,
    FileSystemSessionConnectParams fsConnectParams = null,
    string fsRootPath = null
)
public DeleteFilesJob(
    IEventTimer timer,
    string name = null,
    Nullable<TimeSpan> interval = null,
    IConfigSectionNode config = null,
    FileSystem fs = null,
    FileSystemSessionConnectParams fsConnectParams = null,
    string fsRootPath = null
)
Public Sub New (
    timer As IEventTimer,
    Optional name As String = Nothing,
    Optional interval As Nullable(Of TimeSpan) = Nothing,
    Optional config As IConfigSectionNode = Nothing,
    Optional fs As FileSystem = Nothing,
    Optional fsConnectParams As FileSystemSessionConnectParams = Nothing,
    Optional fsRootPath As String = Nothing
)
Public Sub New (
    timer As IEventTimer,
    Optional name As String = Nothing,
    Optional interval As Nullable(Of TimeSpan) = Nothing,
    Optional config As IConfigSectionNode = Nothing,
    Optional fs As FileSystem = Nothing,
    Optional fsConnectParams As FileSystemSessionConnectParams = Nothing,
    Optional fsRootPath As String = Nothing
)
public:
DeleteFilesJob(
    IEventTimer^ timer,
    String^ name = nullptr,
    Nullable<TimeSpan> interval = nullptr,
    IConfigSectionNode^ config = nullptr,
    FileSystem^ fs = nullptr,
    FileSystemSessionConnectParams^ fsConnectParams = nullptr,
    String^ fsRootPath = nullptr
)
public:
DeleteFilesJob(
    IEventTimer^ timer,
    String^ name = nullptr,
    Nullable<TimeSpan> interval = nullptr,
    IConfigSectionNode^ config = nullptr,
    FileSystem^ fs = nullptr,
    FileSystemSessionConnectParams^ fsConnectParams = nullptr,
    String^ fsRootPath = nullptr
)
new :
        timer : IEventTimer *
        ?name : string *
        ?interval : Nullable<TimeSpan> *
        ?config : IConfigSectionNode *
        ?fs : FileSystem *
        ?fsConnectParams : FileSystemSessionConnectParams *
        ?fsRootPath : string
(* Defaults:
        let _name = defaultArg name null
        let _interval = defaultArg interval null
        let _config = defaultArg config null
        let _fs = defaultArg fs null
        let _fsConnectParams = defaultArg fsConnectParams null
        let _fsRootPath = defaultArg fsRootPath null
*)
-> DeleteFilesJob
new :
        timer : IEventTimer *
        ?name : string *
        ?interval : Nullable<TimeSpan> *
        ?config : IConfigSectionNode *
        ?fs : FileSystem *
        ?fsConnectParams : FileSystemSessionConnectParams *
        ?fsRootPath : string
(* Defaults:
        let _name = defaultArg name null
        let _interval = defaultArg interval null
        let _config = defaultArg config null
        let _fs = defaultArg fs null
        let _fsConnectParams = defaultArg fsConnectParams null
        let _fsRootPath = defaultArg fsRootPath null
*)
-> DeleteFilesJob

Parameters

timer
Type: NFX.Time IEventTimer
name (Optional)
Type: Online System String
interval (Optional)
Type: Online System Nullable Online TimeSpan
config (Optional)
Type: NFX.Environment IConfigSectionNode
fs (Optional)
Type: NFX.IO.FileSystem FileSystem
fsConnectParams (Optional)
Type: NFX.IO.FileSystem FileSystemSessionConnectParams
fsRootPath (Optional)
Type: Online System String
See Also
DeleteFilesJob Class
DeleteFilesJob Members
DeleteFilesJob Overload
NFX.IO.FileSystem Namespace


DeleteFilesJob Fields

DeleteFilesJob Fields NFX Class Library

The DeleteFilesJob type exposes the following members.
Fields
 | Name | Description
 | CONFIG_CONTENT_FS_SECTION |
 | CONFIG_FS_CONNECT_PARAMS_SECTION |
 | CONFIG_FS_ROOT_PATH_ATTR |
Public field | EventHandler | References event handler that handles events. If it is null then only delegate events are called (Inherited from Event.)
Protected field | m_Lock | (Inherited from Event.)
Back to Top
See Also
DeleteFilesJob Class
NFX.IO.FileSystem Namespace


DeleteFilesJob.CONFIG_CONTENT_FS_SECTION Field

DeleteFilesJob CONFIG_CONTENT_FS_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CONTENT_FS_SECTION
public const string CONFIG_CONTENT_FS_SECTION
Public Const CONFIG_CONTENT_FS_SECTION As String
Public Const CONFIG_CONTENT_FS_SECTION As String
public:
literal String^ CONFIG_CONTENT_FS_SECTION
public:
literal String^ CONFIG_CONTENT_FS_SECTION
static val mutable CONFIG_CONTENT_FS_SECTION: string
static val mutable CONFIG_CONTENT_FS_SECTION: string

Field Value

Type: Online String
See Also
DeleteFilesJob Class
DeleteFilesJob Members
NFX.IO.FileSystem Namespace


DeleteFilesJob.CONFIG_FS_CONNECT_PARAMS_SECTION Field

DeleteFilesJob CONFIG_FS_CONNECT_PARAMS_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_FS_CONNECT_PARAMS_SECTION
public const string CONFIG_FS_CONNECT_PARAMS_SECTION
Public Const CONFIG_FS_CONNECT_PARAMS_SECTION As String
Public Const CONFIG_FS_CONNECT_PARAMS_SECTION As String
public:
literal String^ CONFIG_FS_CONNECT_PARAMS_SECTION
public:
literal String^ CONFIG_FS_CONNECT_PARAMS_SECTION
static val mutable CONFIG_FS_CONNECT_PARAMS_SECTION: string
static val mutable CONFIG_FS_CONNECT_PARAMS_SECTION: string

Field Value

Type: Online String
See Also
DeleteFilesJob Class
DeleteFilesJob Members
NFX.IO.FileSystem Namespace


DeleteFilesJob.CONFIG_FS_ROOT_PATH_ATTR Field

DeleteFilesJob CONFIG_FS_ROOT_PATH_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_FS_ROOT_PATH_ATTR
public const string CONFIG_FS_ROOT_PATH_ATTR
Public Const CONFIG_FS_ROOT_PATH_ATTR As String
Public Const CONFIG_FS_ROOT_PATH_ATTR As String
public:
literal String^ CONFIG_FS_ROOT_PATH_ATTR
public:
literal String^ CONFIG_FS_ROOT_PATH_ATTR
static val mutable CONFIG_FS_ROOT_PATH_ATTR: string
static val mutable CONFIG_FS_ROOT_PATH_ATTR: string

Field Value

Type: Online String
See Also
DeleteFilesJob Class
DeleteFilesJob Members
NFX.IO.FileSystem Namespace


DeleteFilesJob Methods

DeleteFilesJob Methods NFX Class Library

The DeleteFilesJob type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AdjustDate | Adjusts date time Localized time (Inherited from Event.)
Public method | BindFS |
Public method | Configure | (Overrides Event Configure(IConfigSectionNode).)
Protected method | Destructor | (Overrides Event Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoFire | (Overrides Event DoFire .)
Protected method | DoHandleError | (Overrides Event DoHandleError(Exception).)
Protected method | DoVisit | Override to perform extra status checks (Inherited from Event.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Event.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Event.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Event.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Fire | Calls event regardless of any constraints. Invokes a handler right away if syncInvoke is true or BodyAsyncModel is Sync, otherwise queues the task on a thread pool either as a regular or long-running task depending on BodyAsyncModel (Inherited from Event.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Event.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ResetCallCount | Resets call count counter. If this event has expired it will eventually transition to Started state. Keep in mind that it may expire again if EndDate is set and past due (Inherited from Event.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Event.)
Protected method | VisitAndCheck | Invoked by timer, checks all conditions and fires/expires event depending on the status. Returns true if event was fired, false otherwise (Inherited from Event.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
DeleteFilesJob Class
NFX.IO.FileSystem Namespace


DeleteFilesJob.BindFS Method

DeleteFilesJob BindFS Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void BindFS(
    FileSystem fs,
    FileSystemSessionConnectParams fsConnectParams,
    string fsRootPath
)
public void BindFS(
    FileSystem fs,
    FileSystemSessionConnectParams fsConnectParams,
    string fsRootPath
)
Public Sub BindFS (
    fs As FileSystem,
    fsConnectParams As FileSystemSessionConnectParams,
    fsRootPath As String
)
Public Sub BindFS (
    fs As FileSystem,
    fsConnectParams As FileSystemSessionConnectParams,
    fsRootPath As String
)
public:
void BindFS(
    FileSystem^ fs,
    FileSystemSessionConnectParams^ fsConnectParams,
    String^ fsRootPath
)
public:
void BindFS(
    FileSystem^ fs,
    FileSystemSessionConnectParams^ fsConnectParams,
    String^ fsRootPath
)
member BindFS :
        fs : FileSystem *
        fsConnectParams : FileSystemSessionConnectParams *
        fsRootPath : string -> unit
member BindFS :
        fs : FileSystem *
        fsConnectParams : FileSystemSessionConnectParams *
        fsRootPath : string -> unit

Parameters

fs
Type: NFX.IO.FileSystem FileSystem
fsConnectParams
Type: NFX.IO.FileSystem FileSystemSessionConnectParams
fsRootPath
Type: Online System String
See Also
DeleteFilesJob Class
DeleteFilesJob Members
NFX.IO.FileSystem Namespace


DeleteFilesJob.Configure Method

DeleteFilesJob Configure Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Configure(
    IConfigSectionNode config
)
public override void Configure(
    IConfigSectionNode config
)
Public Overrides Sub Configure (
    config As IConfigSectionNode
)
Public Overrides Sub Configure (
    config As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ config
) override
public:
virtual void Configure(
    IConfigSectionNode^ config
) override
abstract Configure :
        config : IConfigSectionNode -> unit
override Configure :
        config : IConfigSectionNode -> unit
abstract Configure :
        config : IConfigSectionNode -> unit
override Configure :
        config : IConfigSectionNode -> unit

Parameters

config
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
DeleteFilesJob Class
DeleteFilesJob Members
NFX.IO.FileSystem Namespace


DeleteFilesJob.Destructor Method

DeleteFilesJob Destructor Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
DeleteFilesJob Class
DeleteFilesJob Members
NFX.IO.FileSystem Namespace


DeleteFilesJob.DoFire Method

DeleteFilesJob DoFire Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoFire()
protected override void DoFire()
Protected Overrides Sub DoFire
Protected Overrides Sub DoFire
protected:
virtual void DoFire() override
protected:
virtual void DoFire() override
abstract DoFire : unit -> unit
override DoFire : unit -> unit
abstract DoFire : unit -> unit
override DoFire : unit -> unit
See Also
DeleteFilesJob Class
DeleteFilesJob Members
NFX.IO.FileSystem Namespace


DeleteFilesJob.DoHandleError Method

DeleteFilesJob DoHandleError Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoHandleError(
    Exception error
)
protected override void DoHandleError(
    Exception error
)
Protected Overrides Sub DoHandleError (
    error As Exception
)
Protected Overrides Sub DoHandleError (
    error As Exception
)
protected:
virtual void DoHandleError(
    Exception^ error
) override
protected:
virtual void DoHandleError(
    Exception^ error
) override
abstract DoHandleError :
        error : Exception -> unit
override DoHandleError :
        error : Exception -> unit
abstract DoHandleError :
        error : Exception -> unit
override DoHandleError :
        error : Exception -> unit

Parameters

error
Type: Online System Exception
See Also
DeleteFilesJob Class
DeleteFilesJob Members
NFX.IO.FileSystem Namespace


DeleteFilesJob Properties

DeleteFilesJob Properties NFX Class Library

The DeleteFilesJob type exposes the following members.
Properties
 | Name | Description
Public property | BodyAsyncModel | Due to IO-nature this job is always executted as a long-running separate task (Overrides Event BodyAsyncModel.)
Public property | CallCount | Returns how many times this event was called (Inherited from Event.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Context | Adds arbitrary context object to the event (Inherited from Event.)
Public property | DeleteEmptyDirs |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Enabled | Specifies whether this event will fire/participate in timer loop (Inherited from Event.)
Public property | EndDate | Specifies when this event will stop firing in the local event time (Inherited from Event.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Event.)
Public property | FileSystem | Returns file system that serves static content for portals
Public property | FileSystemConnectParams |
Public property | FileSystemRootPath | Returns root path for content file system
Public property | Interval | Specifies how often event fires (Inherited from Event.)
Public property | LastCall | Returns when was this event called for the last time in the local event time (Inherited from Event.)
Public property | LastError | Returns the last exception thrown from event handler or nul if no error happened (Inherited from Event.)
Public property | LastModifyAgoHrs |
Public property | LastModifyFrom |
Public property | LastModifyTo |
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Event.)
Public property | LogStats |
Public property | MaxCount | Specifies how many times this event can be called. If less or equal than zero then no limit is set (Inherited from Event.)
Public property | MaxSize |
Public property | MinSize |
Public property | Name | (Inherited from Event.)
Public property | NameExcludePattern |
Public property | NameIncludePattern |
Public property | Recurse |
Public property | StartDate | Specifies when this event will start firing in the local event time (Inherited from Event.)
Public property | Status | (Inherited from Event.)
Public property | TimeLocation | Returns time location that this Event instance operates under. (Inherited from Event.)
Public property | Timer | (Inherited from Event.)
Back to Top
See Also
DeleteFilesJob Class
NFX.IO.FileSystem Namespace


DeleteFilesJob.BodyAsyncModel Property

DeleteFilesJob BodyAsyncModel Property NFX Class Library

Due to IO-nature this job is always executted as a long-running separate task

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override EventBodyAsyncModel BodyAsyncModel { get; set; }
public override EventBodyAsyncModel BodyAsyncModel { get; set; }
Public Overrides Property BodyAsyncModel As EventBodyAsyncModel
    Get
    Set
Public Overrides Property BodyAsyncModel As EventBodyAsyncModel
    Get
    Set
public:
virtual property EventBodyAsyncModel BodyAsyncModel {
    EventBodyAsyncModel get () override;
    void set (EventBodyAsyncModel value) override;
}
public:
virtual property EventBodyAsyncModel BodyAsyncModel {
    EventBodyAsyncModel get () override;
    void set (EventBodyAsyncModel value) override;
}
abstract BodyAsyncModel : EventBodyAsyncModel with get, set
override BodyAsyncModel : EventBodyAsyncModel with get, set
abstract BodyAsyncModel : EventBodyAsyncModel with get, set
override BodyAsyncModel : EventBodyAsyncModel with get, set

Property Value

Type: EventBodyAsyncModel
See Also
DeleteFilesJob Class
DeleteFilesJob Members
NFX.IO.FileSystem Namespace


DeleteFilesJob.DeleteEmptyDirs Property

DeleteFilesJob DeleteEmptyDirs Property NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool DeleteEmptyDirs { get; set; }
[ConfigAttribute]
public bool DeleteEmptyDirs { get; set; }
<ConfigAttribute>
Public Property DeleteEmptyDirs As Boolean
    Get
    Set
<ConfigAttribute>
Public Property DeleteEmptyDirs As Boolean
    Get
    Set
public:
[ConfigAttribute]
property bool DeleteEmptyDirs {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute]
property bool DeleteEmptyDirs {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute>]
member DeleteEmptyDirs : bool with get, set
[<ConfigAttribute>]
member DeleteEmptyDirs : bool with get, set

Property Value

Type: Online Boolean
See Also
DeleteFilesJob Class
DeleteFilesJob Members
NFX.IO.FileSystem Namespace


DeleteFilesJob.FileSystem Property

DeleteFilesJob FileSystem Property NFX Class Library

Returns file system that serves static content for portals

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IFileSystem FileSystem { get; }
public IFileSystem FileSystem { get; }
Public ReadOnly Property FileSystem As IFileSystem
    Get
Public ReadOnly Property FileSystem As IFileSystem
    Get
public:
property IFileSystem^ FileSystem {
    IFileSystem^ get ();
}
public:
property IFileSystem^ FileSystem {
    IFileSystem^ get ();
}
member FileSystem : IFileSystem with get
member FileSystem : IFileSystem with get

Property Value

Type: IFileSystem
See Also
DeleteFilesJob Class
DeleteFilesJob Members
NFX.IO.FileSystem Namespace


DeleteFilesJob.FileSystemConnectParams Property

DeleteFilesJob FileSystemConnectParams Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSystemSessionConnectParams FileSystemConnectParams { get; }
public FileSystemSessionConnectParams FileSystemConnectParams { get; }
Public ReadOnly Property FileSystemConnectParams As FileSystemSessionConnectParams
    Get
Public ReadOnly Property FileSystemConnectParams As FileSystemSessionConnectParams
    Get
public:
property FileSystemSessionConnectParams^ FileSystemConnectParams {
    FileSystemSessionConnectParams^ get ();
}
public:
property FileSystemSessionConnectParams^ FileSystemConnectParams {
    FileSystemSessionConnectParams^ get ();
}
member FileSystemConnectParams : FileSystemSessionConnectParams with get
member FileSystemConnectParams : FileSystemSessionConnectParams with get

Property Value

Type: FileSystemSessionConnectParams
See Also
DeleteFilesJob Class
DeleteFilesJob Members
NFX.IO.FileSystem Namespace


DeleteFilesJob.FileSystemRootPath Property

DeleteFilesJob FileSystemRootPath Property NFX Class Library

Returns root path for content file system

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string FileSystemRootPath { get; }
public string FileSystemRootPath { get; }
Public ReadOnly Property FileSystemRootPath As String
    Get
Public ReadOnly Property FileSystemRootPath As String
    Get
public:
property String^ FileSystemRootPath {
    String^ get ();
}
public:
property String^ FileSystemRootPath {
    String^ get ();
}
member FileSystemRootPath : string with get
member FileSystemRootPath : string with get

Property Value

Type: Online String
See Also
DeleteFilesJob Class
DeleteFilesJob Members
NFX.IO.FileSystem Namespace


DeleteFilesJob.LastModifyAgoHrs Property

DeleteFilesJob LastModifyAgoHrs Property NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public Nullable<int> LastModifyAgoHrs { get; set; }
[ConfigAttribute]
public Nullable<int> LastModifyAgoHrs { get; set; }
<ConfigAttribute>
Public Property LastModifyAgoHrs As Nullable(Of Integer)
    Get
    Set
<ConfigAttribute>
Public Property LastModifyAgoHrs As Nullable(Of Integer)
    Get
    Set
public:
[ConfigAttribute]
property Nullable<int> LastModifyAgoHrs {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
public:
[ConfigAttribute]
property Nullable<int> LastModifyAgoHrs {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
[<ConfigAttribute>]
member LastModifyAgoHrs : Nullable<int> with get, set
[<ConfigAttribute>]
member LastModifyAgoHrs : Nullable<int> with get, set

Property Value

Type: Online Nullable Online Int32
See Also
DeleteFilesJob Class
DeleteFilesJob Members
NFX.IO.FileSystem Namespace


DeleteFilesJob.LastModifyFrom Property

DeleteFilesJob LastModifyFrom Property NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public Nullable<DateTime> LastModifyFrom { get; set; }
[ConfigAttribute]
public Nullable<DateTime> LastModifyFrom { get; set; }
<ConfigAttribute>
Public Property LastModifyFrom As Nullable(Of DateTime)
    Get
    Set
<ConfigAttribute>
Public Property LastModifyFrom As Nullable(Of DateTime)
    Get
    Set
public:
[ConfigAttribute]
property Nullable<DateTime> LastModifyFrom {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
public:
[ConfigAttribute]
property Nullable<DateTime> LastModifyFrom {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
[<ConfigAttribute>]
member LastModifyFrom : Nullable<DateTime> with get, set
[<ConfigAttribute>]
member LastModifyFrom : Nullable<DateTime> with get, set

Property Value

Type: Online Nullable Online DateTime
See Also
DeleteFilesJob Class
DeleteFilesJob Members
NFX.IO.FileSystem Namespace


DeleteFilesJob.LastModifyTo Property

DeleteFilesJob LastModifyTo Property NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public Nullable<DateTime> LastModifyTo { get; set; }
[ConfigAttribute]
public Nullable<DateTime> LastModifyTo { get; set; }
<ConfigAttribute>
Public Property LastModifyTo As Nullable(Of DateTime)
    Get
    Set
<ConfigAttribute>
Public Property LastModifyTo As Nullable(Of DateTime)
    Get
    Set
public:
[ConfigAttribute]
property Nullable<DateTime> LastModifyTo {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
public:
[ConfigAttribute]
property Nullable<DateTime> LastModifyTo {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
[<ConfigAttribute>]
member LastModifyTo : Nullable<DateTime> with get, set
[<ConfigAttribute>]
member LastModifyTo : Nullable<DateTime> with get, set

Property Value

Type: Online Nullable Online DateTime
See Also
DeleteFilesJob Class
DeleteFilesJob Members
NFX.IO.FileSystem Namespace


DeleteFilesJob.LogStats Property

DeleteFilesJob LogStats Property NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool LogStats { get; set; }
[ConfigAttribute]
public bool LogStats { get; set; }
<ConfigAttribute>
Public Property LogStats As Boolean
    Get
    Set
<ConfigAttribute>
Public Property LogStats As Boolean
    Get
    Set
public:
[ConfigAttribute]
property bool LogStats {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute]
property bool LogStats {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute>]
member LogStats : bool with get, set
[<ConfigAttribute>]
member LogStats : bool with get, set

Property Value

Type: Online Boolean
See Also
DeleteFilesJob Class
DeleteFilesJob Members
NFX.IO.FileSystem Namespace


DeleteFilesJob.MaxSize Property

DeleteFilesJob MaxSize Property NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public Nullable<ulong> MaxSize { get; set; }
[ConfigAttribute]
public Nullable<ulong> MaxSize { get; set; }
<ConfigAttribute>
Public Property MaxSize As Nullable(Of ULong)
    Get
    Set
<ConfigAttribute>
Public Property MaxSize As Nullable(Of ULong)
    Get
    Set
public:
[ConfigAttribute]
property Nullable<unsigned long long> MaxSize {
    Nullable<unsigned long long> get ();
    void set (Nullable<unsigned long long> value);
}
public:
[ConfigAttribute]
property Nullable<unsigned long long> MaxSize {
    Nullable<unsigned long long> get ();
    void set (Nullable<unsigned long long> value);
}
[<ConfigAttribute>]
member MaxSize : Nullable<uint64> with get, set
[<ConfigAttribute>]
member MaxSize : Nullable<uint64> with get, set

Property Value

Type: Online Nullable Online UInt64
See Also
DeleteFilesJob Class
DeleteFilesJob Members
NFX.IO.FileSystem Namespace


DeleteFilesJob.MinSize Property

DeleteFilesJob MinSize Property NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public Nullable<ulong> MinSize { get; set; }
[ConfigAttribute]
public Nullable<ulong> MinSize { get; set; }
<ConfigAttribute>
Public Property MinSize As Nullable(Of ULong)
    Get
    Set
<ConfigAttribute>
Public Property MinSize As Nullable(Of ULong)
    Get
    Set
public:
[ConfigAttribute]
property Nullable<unsigned long long> MinSize {
    Nullable<unsigned long long> get ();
    void set (Nullable<unsigned long long> value);
}
public:
[ConfigAttribute]
property Nullable<unsigned long long> MinSize {
    Nullable<unsigned long long> get ();
    void set (Nullable<unsigned long long> value);
}
[<ConfigAttribute>]
member MinSize : Nullable<uint64> with get, set
[<ConfigAttribute>]
member MinSize : Nullable<uint64> with get, set

Property Value

Type: Online Nullable Online UInt64
See Also
DeleteFilesJob Class
DeleteFilesJob Members
NFX.IO.FileSystem Namespace


DeleteFilesJob.NameExcludePattern Property

DeleteFilesJob NameExcludePattern Property NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string NameExcludePattern { get; set; }
[ConfigAttribute]
public string NameExcludePattern { get; set; }
<ConfigAttribute>
Public Property NameExcludePattern As String
    Get
    Set
<ConfigAttribute>
Public Property NameExcludePattern As String
    Get
    Set
public:
[ConfigAttribute]
property String^ NameExcludePattern {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ NameExcludePattern {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member NameExcludePattern : string with get, set
[<ConfigAttribute>]
member NameExcludePattern : string with get, set

Property Value

Type: Online String
See Also
DeleteFilesJob Class
DeleteFilesJob Members
NFX.IO.FileSystem Namespace


DeleteFilesJob.NameIncludePattern Property

DeleteFilesJob NameIncludePattern Property NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string NameIncludePattern { get; set; }
[ConfigAttribute]
public string NameIncludePattern { get; set; }
<ConfigAttribute>
Public Property NameIncludePattern As String
    Get
    Set
<ConfigAttribute>
Public Property NameIncludePattern As String
    Get
    Set
public:
[ConfigAttribute]
property String^ NameIncludePattern {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ NameIncludePattern {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member NameIncludePattern : string with get, set
[<ConfigAttribute>]
member NameIncludePattern : string with get, set

Property Value

Type: Online String
See Also
DeleteFilesJob Class
DeleteFilesJob Members
NFX.IO.FileSystem Namespace


DeleteFilesJob.Recurse Property

DeleteFilesJob Recurse Property NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool Recurse { get; set; }
[ConfigAttribute]
public bool Recurse { get; set; }
<ConfigAttribute>
Public Property Recurse As Boolean
    Get
    Set
<ConfigAttribute>
Public Property Recurse As Boolean
    Get
    Set
public:
[ConfigAttribute]
property bool Recurse {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute]
property bool Recurse {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute>]
member Recurse : bool with get, set
[<ConfigAttribute>]
member Recurse : bool with get, set

Property Value

Type: Online Boolean
See Also
DeleteFilesJob Class
DeleteFilesJob Members
NFX.IO.FileSystem Namespace


DeleteFilesJob Events

DeleteFilesJob Events NFX Class Library

The DeleteFilesJob type exposes the following members.
Events
 | Name | Description
Public event | Body | Event body that gets called when the event is due. The body is always invoked ASYNCHRONOUSLY unless Fire(syncronous=true) is called in which case it gets called on a thread that called Fire(true) (Inherited from Event.)
Public event | DefinitionChange | Invoked when one of timer event definition parameters changes. Always called synchronously on the same thread that made a change. Subscribers should not block for long (Inherited from Event.)
Public event | StatusChange | Invoked when timer event status changes. Always called synchronously by the timer thread. Subscribers should not block for long (Inherited from Event.)
Back to Top
See Also
DeleteFilesJob Class
NFX.IO.FileSystem Namespace


FileSystem Class

FileSystem Class NFX Class Library

Provides a base for various file system abstractions. FileSystem abstractions are mostly useful for working with components/classes that may need to inter-operate not only with local file system but also with distributed systems like ApacheHDFS, SVN, GIT, or Aum Cluster Big-Transactional File System (BoltFS). NFX library provides compatibility wrapper 'NFX.IO.FileSystem.Local.LocalFileSystem' for access to local machine file system (which is based on this class and is implemented using a traditional System.IO.* set of classes). The FileSystem abstraction supports the following concepts: versioning, transactions, metadata, security; however it does not guarantee that every implementation is capable of providing all of these functions. Query "GeneralCapabilities" and "InstanceCapabilities" to see what functions are supported by a particular instance. This class is not thread-safe unless stated otherwise on method level, however multiple threads are allowed to obtain their own FileSystemSession object via a call to StartSession() which is thread safe
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.IO.FileSystem FileSystem
NFX.IO.FileSystem.GoogleDrive.V2 GoogleDriveFileSystem
NFX.IO.FileSystem.Local LocalFileSystem
NFX.IO.FileSystem.S3.V4 S3V4FileSystem
NFX.IO.FileSystem.SVN SVNFileSystem

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class FileSystem : ApplicationComponent,
    IFileSystemImplementation, IFileSystem, IApplicationComponent, INamed, IDisposable,
    IConfigurable
public abstract class FileSystem : ApplicationComponent,
    IFileSystemImplementation, IFileSystem, IApplicationComponent, INamed, IDisposable,
    IConfigurable
Public MustInherit Class FileSystem
    Inherits ApplicationComponent
    Implements IFileSystemImplementation, IFileSystem, IApplicationComponent, INamed,
    IDisposable, IConfigurable
Public MustInherit Class FileSystem
    Inherits ApplicationComponent
    Implements IFileSystemImplementation, IFileSystem, IApplicationComponent, INamed,
    IDisposable, IConfigurable
public ref class FileSystem abstract : public ApplicationComponent,
    IFileSystemImplementation, IFileSystem, IApplicationComponent, INamed, IDisposable,
    IConfigurable
public ref class FileSystem abstract : public ApplicationComponent,
    IFileSystemImplementation, IFileSystem, IApplicationComponent, INamed, IDisposable,
    IConfigurable
[<AbstractClassAttribute>]
type FileSystem =
    class
        inherit ApplicationComponent
        interface IFileSystemImplementation
        interface IFileSystem
        interface IApplicationComponent
        interface INamed
        interface IDisposable
        interface IConfigurable
    end
[<AbstractClassAttribute>]
type FileSystem =
    class
        inherit ApplicationComponent
        interface IFileSystemImplementation
        interface IFileSystem
        interface IApplicationComponent
        interface INamed
        interface IDisposable
        interface IConfigurable
    end
See Also
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem Members

FileSystem Members NFX Class Library

The FileSystem type exposes the following members.
Constructors
 | Name | Description
Protected method | FileSystem | Initializes a new instance of the FileSystem class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
 | AutoStartSystems | Automatically starts systems designated in config with auto-start attribute
Public method | CombinePaths | Combines two or more path segments joining them using primary file system path separator. This method is thread-safe
Public method | Configure | Configures file system. This method is a part of lifecycle management and is intended to be called only by creating thread (not thread-safe)
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoBeginTransaction | Override in particular file systems that support transactions to begin transaction in specified session. This method may be called by miltiple threads
Protected method | DoBeginTransactionAsync | Async version of DoBeginTransaction(FileSystemSession). This base/default implementation just synchronously calls DoBeginTransaction(FileSystemSession) and returns already completed Task with result returned by DoBeginTransaction(FileSystemSession)
Protected method | DoCheckCanChange | Override in particular file systems to see if item can change, i.e. for file systems that support versioning throw exception if item is in session which "looks" at a sealed/closed version and can not change. This method may be called by miltiple threads
Protected method | DoCheckCanChangeAsync | Async version of DoCheckCanChange(FileSystemSessionItem). This base/default implementation just synchronously calls DoCheckCanChange(FileSystemSessionItem) and returns already completed Task with result returned by DoCheckCanChange(FileSystemSessionItem)
Protected method | DoCommitTransaction | Override in particular file systems that support transactions to commit transaction in specified session. This method may be called by miltiple threads
Protected method | DoCommitTransactionAsync | Async version of DoCommitTransaction(FileSystemSession). This base/default implementation just synchronously calls DoCommitTransaction(FileSystemSession) and returns already completed Task with result returned by DoCommitTransaction(FileSystemSession)
Protected method | DoConfigure | Override to perform custom configuration
Protected method | DoCreateDirectory | Override to create a directory. This method may be called by miltiple threads
Protected method | DoCreateDirectoryAsync | Async version of DoCreateDirectory(FileSystemDirectory, String). This base/default implementation just synchronously calls DoCreateDirectory(FileSystemDirectory, String) and returns already completed Task with result returned by DoCreateDirectory(FileSystemDirectory, String)
Protected method | DoCreateFile(FileSystemDirectory, String, Int32) | Override to create a file. This method may be called by miltiple threads
Protected method | DoCreateFile(FileSystemDirectory, String, String, Boolean) | Override to create a file from local file. This method may be called by miltiple threads
Protected method | DoCreateFileAsync(FileSystemDirectory, String, Int32) | Async version of DoCreateFile(FileSystemDirectory, String, Int32). This base/default implementation just synchronously calls DoCreateFile(FileSystemDirectory, String, Int32) and returns already completed Task with result returned by DoCreateFile(FileSystemDirectory, String, Int32)
Protected method | DoCreateFileAsync(FileSystemDirectory, String, String, Boolean) | Async version of DoCreateFile(FileSystemDirectory, String, String, Boolean). This base/default implementation just synchronously calls DoCreateFile(FileSystemDirectory, String, String, Boolean) and returns already completed Task with result returned by DoCreateFile(FileSystemDirectory, String, String, Boolean)
Protected method | DoDeleteItem | Override to delete item. This method may be called by miltiple threads
Protected method | DoDeleteItemAsync | Async version of DoDeleteItem(FileSystemSessionItem). This base/default implementation just synchronously calls DoDeleteItem(FileSystemSessionItem) and returns already completed Task with result returned by DoDeleteItem(FileSystemSessionItem)
Protected method | DoDirectoryDeepCopyAsync | Implements asynchronous deep copy of folders where destination folder may belong to a different file system. The specifics of implementation may be dictated by particular file systems, i.e.: asynchronous strategies for getting file lists may depend on the particular system.
Protected method | DoFlushAsync |
Protected method | DoGetCreationTimestamp | Override to get item creation timestamp. This method may be called by miltiple threads
Protected method | DoGetCreationUser | Override in particular file systems to get user who created item. This method may be called by miltiple threads
Protected method | DoGetCreationUserAsync | Async version of DoGetCreationUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetCreationUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetCreationUser(FileSystemSessionItem)
Protected method | DoGetFileNames | Override to get file names in directory. If directory is null then root is assumed. This method may be called by miltiple threads
Protected method | DoGetFileNamesAsync | Async version of DoGetFileNames(FileSystemDirectory, Boolean). This base/default implementation just synchronously calls DoGetFileNames(FileSystemDirectory, Boolean) and returns already completed Task with result returned by DoGetFileNames(FileSystemDirectory, Boolean)
Protected method | DoGetFileStream | Override to get file stream. This method may be called by miltiple threads
Protected method | DoGetFileStreamAsync | Async version of DoGetFileStream(FileSystemFile, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetFileStream(FileSystemFile, Action FileSystemStream ) and returns already completed Task with result returned by DoGetFileStream(FileSystemFile, Action FileSystemStream )
Protected method | DoGetItemSize | Override to get the byte size of item (directory or file). This method may be called by miltiple threads
Protected method | DoGetItemSizeAsync | Async version of DoGetItemSize(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetItemSize(FileSystemSessionItem) and returns already completed Task with result returned by DoGetItemSize(FileSystemSessionItem)
Protected method | DoGetLastAccessTimestamp | Override to get item last access timestamp. This method may be called by miltiple threads
Protected method | DoGetLastAccessUser | Override in particular file systems to get user who was the last user accessing the item. This method may be called by miltiple threads
Protected method | DoGetLastAccessUserAsync | Async version of DoGetLastAccessUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetLastAccessUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetLastAccessUser(FileSystemSessionItem)
Protected method | DoGetLatestVersion | Override in particular file systems that support versioning to get latest version object that this session can work with. This method may be called by miltiple threads
Protected method | DoGetLatestVersionAsync | Async version of DoGetLatestVersion(FileSystemSession). This base/default implementation just synchronously calls DoGetLatestVersion(FileSystemSession) and returns already completed Task with result returned by DoGetLatestVersion(FileSystemSession)
Protected method | DoGetMetadataStream | Override to get metadata stream for item (directory or file). This method may be called by miltiple threads
Protected method | DoGetMetadataStreamAsync | Async version of DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ) and returns already completed Task with result returned by DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream )
Protected method | DoGetModificationTimestamp | Override to get item modification timestamp. This method may be called by miltiple threads
Protected method | DoGetModificationUser | Override in particular file systems to get user who was the last user modifying the item. This method may be called by miltiple threads
Protected method | DoGetModificationUserAsync | Async version of DoGetModificationUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetModificationUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetModificationUser(FileSystemSessionItem)
Protected method | DoGetPermissionsStream | Override to get permissions stream for item (directory or file). This method may be called by miltiple threads
Protected method | DoGetPermissionsStreamAsync | Async version of DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ) and returns already completed Task with result returned by DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream )
Protected method | DoGetReadOnly | Override to get item readonly status. This method may be called by miltiple threads
Protected method | DoGetSubDirectoryNames | Override to get subdirectory names of directory. If directory is null then root is assumed. This method may be called by miltiple threads
Protected method | DoGetSubDirectoryNamesAsync | Async version of DoGetSubDirectoryNames(FileSystemDirectory, Boolean). This base/default implementation just synchronously calls DoGetSubDirectoryNames(FileSystemDirectory, Boolean) and returns already completed Task with result returned by DoGetSubDirectoryNames(FileSystemDirectory, Boolean)
Protected method | DoGetVersion | Override in particular file systems that support versioning to get version object for session. This method may be called by miltiple threads
Protected method | DoGetVersionAsync | Async version of DoGetVersion(FileSystemSession). This base/default implementation just synchronously calls DoGetVersion(FileSystemSession) and returns already completed Task with result returned by DoGetVersion(FileSystemSession)
Protected method | DoNavigate | Override to get file or directory from specified path. Return null if item does not exist. This method may be called by miltiple threads
Protected method | DoNavigateAsync | Async version of DoNavigate(FileSystemSession, String). This base/default implementation just synchronously calls DoNavigate(FileSystemSession, String) and returns already completed Task with result returned by DoNavigate(FileSystemSession, String)
Protected method | DoReadAsync |
Protected method | DoRefresh | Override to refresh item state, i.e. re-fetch remote information. This method may be called by miltiple threads
Protected method | DoRefreshAsync | Async version of DoRefreshAsync(FileSystemSessionItem). This base/default implementation just synchronously calls DoRefreshAsync(FileSystemSessionItem) and returns already completed Task with result returned by DoRefreshAsync(FileSystemSessionItem)
Protected method | DoRenameItem | Override to rename item return true on success. This method may be called by miltiple threads
Protected method | DoRenameItemAsync | Async version of DoRenameItem(FileSystemSessionItem, String). This base/default implementation just synchronously calls DoRenameItem(FileSystemSessionItem, String) and returns already completed Task with result returned by DoRenameItem(FileSystemSessionItem, String)
Protected method | DoRollbackTransaction | Override in particular file systems that support transactions to rollback transaction in specified session. This method may be called by miltiple threads
Protected method | DoRollbackTransactionAsync | Async version of DoRollbackTransaction(FileSystemSession). This base/default implementation just synchronously calls DoRollbackTransaction(FileSystemSession) and returns already completed Task with result returned by DoRollbackTransaction(FileSystemSession)
Protected method | DoSetCreationTimestamp | Override to set item creation timestamp. This method may be called by miltiple threads
Protected method | DoSetCreationTimestampAsync | Async version of DoSetCreationTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetCreationTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetCreationTimestamp(FileSystemSessionItem, DateTime)
Protected method | DoSetLastAccessTimestamp | Override to set item last access timestamp. This method may be called by miltiple threads
Protected method | DoSetLastAccessTimestampAsync | Async version of DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime)
Protected method | DoSetModificationTimestamp | Override to set item modification timestamp. This method may be called by miltiple threads
Protected method | DoSetModificationTimestampAsync | Async version of DoSetModificationTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetModificationTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetModificationTimestamp(FileSystemSessionItem, DateTime)
Protected method | DoSetReadOnly | Override to set item readonly status. This method may be called by miltiple threads
Protected method | DoSetReadOnlyAsync | Async version of DoSetReadOnly(FileSystemSessionItem, Boolean). This base/default implementation just synchronously calls DoSetReadOnly(FileSystemSessionItem, Boolean) and returns already completed Task with result returned by DoSetReadOnly(FileSystemSessionItem, Boolean)
Protected method | DoSetVersion | Override in particular file systems that support versioning to set seesion to specific version. This method may be called by miltiple threads
Protected method | DoSetVersionAsync | Async version of DoSetVersion(FileSystemSession, IFileSystemVersion). This base/default implementation just synchronously calls DoSetVersion(FileSystemSession, IFileSystemVersion) and returns already completed Task with result returned by DoSetVersion(FileSystemSession, IFileSystemVersion)
Protected method | DoWriteAsync |
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Make TParam (IConfigSectionNode) |
 | Make TParam (String, String) |
Protected method | MakeSessionConfigParams |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | StartSession | Creates a new session for the user. This method is thread-safe, however the returned FileSystemSession object is not. Every thread must obtain its own session via this method
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | CONFIG_AUTO_START_ATTR |
 | CONFIG_DEFAULT_SESSION_CONNECT_PARAMS_SECTION |
 | CONFIG_FILESYSTEM_SECTION |
 | CONFIG_FILESYSTEMS_SECTION |
 | CONFIG_NAME_ATTR |
Protected field | m_Name |
Protected field | m_Sessions |
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Protected property | DefaultSessionConnectParams |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | GeneralCapabilities | Returns capabilities for this file system in general
Public property | InstanceCapabilities | Returns capabilities for this file system instance, that may or may not be the same as GeneralCapabilities
 | Instances | Returns the read-only registry view of file systems currently activated
Public property | Name | Provides name for file system instance
Public property | Sessions | Returns a list of sessions. This accessor is thread-safe
Back to Top
See Also
FileSystem Class
NFX.IO.FileSystem Namespace


FileSystem Constructor

FileSystem Constructor NFX Class Library

Initializes a new instance of the FileSystem class

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FileSystem(
    string name,
    IConfigSectionNode node = null
)
protected FileSystem(
    string name,
    IConfigSectionNode node = null
)
Protected Sub New (
    name As String,
    Optional node As IConfigSectionNode = Nothing
)
Protected Sub New (
    name As String,
    Optional node As IConfigSectionNode = Nothing
)
protected:
FileSystem(
    String^ name,
    IConfigSectionNode^ node = nullptr
)
protected:
FileSystem(
    String^ name,
    IConfigSectionNode^ node = nullptr
)
new :
        name : string *
        ?node : IConfigSectionNode
(* Defaults:
        let _node = defaultArg node null
*)
-> FileSystem
new :
        name : string *
        ?node : IConfigSectionNode
(* Defaults:
        let _node = defaultArg node null
*)
-> FileSystem

Parameters

name
Type: Online System String
node (Optional)
Type: NFX.Environment IConfigSectionNode
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem Fields

FileSystem Fields NFX Class Library

The FileSystem type exposes the following members.
Fields
 | Name | Description
 | CONFIG_AUTO_START_ATTR |
 | CONFIG_DEFAULT_SESSION_CONNECT_PARAMS_SECTION |
 | CONFIG_FILESYSTEM_SECTION |
 | CONFIG_FILESYSTEMS_SECTION |
 | CONFIG_NAME_ATTR |
Protected field | m_Name |
Protected field | m_Sessions |
Back to Top
See Also
FileSystem Class
NFX.IO.FileSystem Namespace


FileSystem.CONFIG_AUTO_START_ATTR Field

FileSystem CONFIG_AUTO_START_ATTR Field NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_AUTO_START_ATTR
public const string CONFIG_AUTO_START_ATTR
Public Const CONFIG_AUTO_START_ATTR As String
Public Const CONFIG_AUTO_START_ATTR As String
public:
literal String^ CONFIG_AUTO_START_ATTR
public:
literal String^ CONFIG_AUTO_START_ATTR
static val mutable CONFIG_AUTO_START_ATTR: string
static val mutable CONFIG_AUTO_START_ATTR: string

Field Value

Type: Online String
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.CONFIG_DEFAULT_SESSION_CONNECT_PARAMS_SECTION Field

FileSystem CONFIG_DEFAULT_SESSION_CONNECT_PARAMS_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_DEFAULT_SESSION_CONNECT_PARAMS_SECTION
public const string CONFIG_DEFAULT_SESSION_CONNECT_PARAMS_SECTION
Public Const CONFIG_DEFAULT_SESSION_CONNECT_PARAMS_SECTION As String
Public Const CONFIG_DEFAULT_SESSION_CONNECT_PARAMS_SECTION As String
public:
literal String^ CONFIG_DEFAULT_SESSION_CONNECT_PARAMS_SECTION
public:
literal String^ CONFIG_DEFAULT_SESSION_CONNECT_PARAMS_SECTION
static val mutable CONFIG_DEFAULT_SESSION_CONNECT_PARAMS_SECTION: string
static val mutable CONFIG_DEFAULT_SESSION_CONNECT_PARAMS_SECTION: string

Field Value

Type: Online String
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.CONFIG_FILESYSTEM_SECTION Field

FileSystem CONFIG_FILESYSTEM_SECTION Field NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_FILESYSTEM_SECTION
public const string CONFIG_FILESYSTEM_SECTION
Public Const CONFIG_FILESYSTEM_SECTION As String
Public Const CONFIG_FILESYSTEM_SECTION As String
public:
literal String^ CONFIG_FILESYSTEM_SECTION
public:
literal String^ CONFIG_FILESYSTEM_SECTION
static val mutable CONFIG_FILESYSTEM_SECTION: string
static val mutable CONFIG_FILESYSTEM_SECTION: string

Field Value

Type: Online String
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.CONFIG_FILESYSTEMS_SECTION Field

FileSystem CONFIG_FILESYSTEMS_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_FILESYSTEMS_SECTION
public const string CONFIG_FILESYSTEMS_SECTION
Public Const CONFIG_FILESYSTEMS_SECTION As String
Public Const CONFIG_FILESYSTEMS_SECTION As String
public:
literal String^ CONFIG_FILESYSTEMS_SECTION
public:
literal String^ CONFIG_FILESYSTEMS_SECTION
static val mutable CONFIG_FILESYSTEMS_SECTION: string
static val mutable CONFIG_FILESYSTEMS_SECTION: string

Field Value

Type: Online String
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.CONFIG_NAME_ATTR Field

FileSystem CONFIG_NAME_ATTR Field NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_NAME_ATTR
public const string CONFIG_NAME_ATTR
Public Const CONFIG_NAME_ATTR As String
Public Const CONFIG_NAME_ATTR As String
public:
literal String^ CONFIG_NAME_ATTR
public:
literal String^ CONFIG_NAME_ATTR
static val mutable CONFIG_NAME_ATTR: string
static val mutable CONFIG_NAME_ATTR: string

Field Value

Type: Online String
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.m_Name Field

FileSystem m_Name Field NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected readonly string m_Name
protected readonly string m_Name
Protected ReadOnly m_Name As String
Protected ReadOnly m_Name As String
protected:
initonly String^ m_Name
protected:
initonly String^ m_Name
val m_Name: string
val m_Name: string

Field Value

Type: Online String
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.m_Sessions Field

FileSystem m_Sessions Field NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal readonly List<FileSystemSession> m_Sessions
protected internal readonly List<FileSystemSession> m_Sessions
Protected Friend ReadOnly m_Sessions As List(Of FileSystemSession)
Protected Friend ReadOnly m_Sessions As List(Of FileSystemSession)
protected public:
initonly List<FileSystemSession^>^ m_Sessions
protected public:
initonly List<FileSystemSession^>^ m_Sessions
val m_Sessions: List<FileSystemSession>
val m_Sessions: List<FileSystemSession>

Field Value

Type: Online List FileSystemSession
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem Methods

FileSystem Methods NFX Class Library

The FileSystem type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
 | AutoStartSystems | Automatically starts systems designated in config with auto-start attribute
Public method | CombinePaths | Combines two or more path segments joining them using primary file system path separator. This method is thread-safe
Public method | Configure | Configures file system. This method is a part of lifecycle management and is intended to be called only by creating thread (not thread-safe)
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoBeginTransaction | Override in particular file systems that support transactions to begin transaction in specified session. This method may be called by miltiple threads
Protected method | DoBeginTransactionAsync | Async version of DoBeginTransaction(FileSystemSession). This base/default implementation just synchronously calls DoBeginTransaction(FileSystemSession) and returns already completed Task with result returned by DoBeginTransaction(FileSystemSession)
Protected method | DoCheckCanChange | Override in particular file systems to see if item can change, i.e. for file systems that support versioning throw exception if item is in session which "looks" at a sealed/closed version and can not change. This method may be called by miltiple threads
Protected method | DoCheckCanChangeAsync | Async version of DoCheckCanChange(FileSystemSessionItem). This base/default implementation just synchronously calls DoCheckCanChange(FileSystemSessionItem) and returns already completed Task with result returned by DoCheckCanChange(FileSystemSessionItem)
Protected method | DoCommitTransaction | Override in particular file systems that support transactions to commit transaction in specified session. This method may be called by miltiple threads
Protected method | DoCommitTransactionAsync | Async version of DoCommitTransaction(FileSystemSession). This base/default implementation just synchronously calls DoCommitTransaction(FileSystemSession) and returns already completed Task with result returned by DoCommitTransaction(FileSystemSession)
Protected method | DoConfigure | Override to perform custom configuration
Protected method | DoCreateDirectory | Override to create a directory. This method may be called by miltiple threads
Protected method | DoCreateDirectoryAsync | Async version of DoCreateDirectory(FileSystemDirectory, String). This base/default implementation just synchronously calls DoCreateDirectory(FileSystemDirectory, String) and returns already completed Task with result returned by DoCreateDirectory(FileSystemDirectory, String)
Protected method | DoCreateFile(FileSystemDirectory, String, Int32) | Override to create a file. This method may be called by miltiple threads
Protected method | DoCreateFile(FileSystemDirectory, String, String, Boolean) | Override to create a file from local file. This method may be called by miltiple threads
Protected method | DoCreateFileAsync(FileSystemDirectory, String, Int32) | Async version of DoCreateFile(FileSystemDirectory, String, Int32). This base/default implementation just synchronously calls DoCreateFile(FileSystemDirectory, String, Int32) and returns already completed Task with result returned by DoCreateFile(FileSystemDirectory, String, Int32)
Protected method | DoCreateFileAsync(FileSystemDirectory, String, String, Boolean) | Async version of DoCreateFile(FileSystemDirectory, String, String, Boolean). This base/default implementation just synchronously calls DoCreateFile(FileSystemDirectory, String, String, Boolean) and returns already completed Task with result returned by DoCreateFile(FileSystemDirectory, String, String, Boolean)
Protected method | DoDeleteItem | Override to delete item. This method may be called by miltiple threads
Protected method | DoDeleteItemAsync | Async version of DoDeleteItem(FileSystemSessionItem). This base/default implementation just synchronously calls DoDeleteItem(FileSystemSessionItem) and returns already completed Task with result returned by DoDeleteItem(FileSystemSessionItem)
Protected method | DoDirectoryDeepCopyAsync | Implements asynchronous deep copy of folders where destination folder may belong to a different file system. The specifics of implementation may be dictated by particular file systems, i.e.: asynchronous strategies for getting file lists may depend on the particular system.
Protected method | DoFlushAsync |
Protected method | DoGetCreationTimestamp | Override to get item creation timestamp. This method may be called by miltiple threads
Protected method | DoGetCreationUser | Override in particular file systems to get user who created item. This method may be called by miltiple threads
Protected method | DoGetCreationUserAsync | Async version of DoGetCreationUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetCreationUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetCreationUser(FileSystemSessionItem)
Protected method | DoGetFileNames | Override to get file names in directory. If directory is null then root is assumed. This method may be called by miltiple threads
Protected method | DoGetFileNamesAsync | Async version of DoGetFileNames(FileSystemDirectory, Boolean). This base/default implementation just synchronously calls DoGetFileNames(FileSystemDirectory, Boolean) and returns already completed Task with result returned by DoGetFileNames(FileSystemDirectory, Boolean)
Protected method | DoGetFileStream | Override to get file stream. This method may be called by miltiple threads
Protected method | DoGetFileStreamAsync | Async version of DoGetFileStream(FileSystemFile, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetFileStream(FileSystemFile, Action FileSystemStream ) and returns already completed Task with result returned by DoGetFileStream(FileSystemFile, Action FileSystemStream )
Protected method | DoGetItemSize | Override to get the byte size of item (directory or file). This method may be called by miltiple threads
Protected method | DoGetItemSizeAsync | Async version of DoGetItemSize(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetItemSize(FileSystemSessionItem) and returns already completed Task with result returned by DoGetItemSize(FileSystemSessionItem)
Protected method | DoGetLastAccessTimestamp | Override to get item last access timestamp. This method may be called by miltiple threads
Protected method | DoGetLastAccessUser | Override in particular file systems to get user who was the last user accessing the item. This method may be called by miltiple threads
Protected method | DoGetLastAccessUserAsync | Async version of DoGetLastAccessUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetLastAccessUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetLastAccessUser(FileSystemSessionItem)
Protected method | DoGetLatestVersion | Override in particular file systems that support versioning to get latest version object that this session can work with. This method may be called by miltiple threads
Protected method | DoGetLatestVersionAsync | Async version of DoGetLatestVersion(FileSystemSession). This base/default implementation just synchronously calls DoGetLatestVersion(FileSystemSession) and returns already completed Task with result returned by DoGetLatestVersion(FileSystemSession)
Protected method | DoGetMetadataStream | Override to get metadata stream for item (directory or file). This method may be called by miltiple threads
Protected method | DoGetMetadataStreamAsync | Async version of DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ) and returns already completed Task with result returned by DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream )
Protected method | DoGetModificationTimestamp | Override to get item modification timestamp. This method may be called by miltiple threads
Protected method | DoGetModificationUser | Override in particular file systems to get user who was the last user modifying the item. This method may be called by miltiple threads
Protected method | DoGetModificationUserAsync | Async version of DoGetModificationUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetModificationUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetModificationUser(FileSystemSessionItem)
Protected method | DoGetPermissionsStream | Override to get permissions stream for item (directory or file). This method may be called by miltiple threads
Protected method | DoGetPermissionsStreamAsync | Async version of DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ) and returns already completed Task with result returned by DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream )
Protected method | DoGetReadOnly | Override to get item readonly status. This method may be called by miltiple threads
Protected method | DoGetSubDirectoryNames | Override to get subdirectory names of directory. If directory is null then root is assumed. This method may be called by miltiple threads
Protected method | DoGetSubDirectoryNamesAsync | Async version of DoGetSubDirectoryNames(FileSystemDirectory, Boolean). This base/default implementation just synchronously calls DoGetSubDirectoryNames(FileSystemDirectory, Boolean) and returns already completed Task with result returned by DoGetSubDirectoryNames(FileSystemDirectory, Boolean)
Protected method | DoGetVersion | Override in particular file systems that support versioning to get version object for session. This method may be called by miltiple threads
Protected method | DoGetVersionAsync | Async version of DoGetVersion(FileSystemSession). This base/default implementation just synchronously calls DoGetVersion(FileSystemSession) and returns already completed Task with result returned by DoGetVersion(FileSystemSession)
Protected method | DoNavigate | Override to get file or directory from specified path. Return null if item does not exist. This method may be called by miltiple threads
Protected method | DoNavigateAsync | Async version of DoNavigate(FileSystemSession, String). This base/default implementation just synchronously calls DoNavigate(FileSystemSession, String) and returns already completed Task with result returned by DoNavigate(FileSystemSession, String)
Protected method | DoReadAsync |
Protected method | DoRefresh | Override to refresh item state, i.e. re-fetch remote information. This method may be called by miltiple threads
Protected method | DoRefreshAsync | Async version of DoRefreshAsync(FileSystemSessionItem). This base/default implementation just synchronously calls DoRefreshAsync(FileSystemSessionItem) and returns already completed Task with result returned by DoRefreshAsync(FileSystemSessionItem)
Protected method | DoRenameItem | Override to rename item return true on success. This method may be called by miltiple threads
Protected method | DoRenameItemAsync | Async version of DoRenameItem(FileSystemSessionItem, String). This base/default implementation just synchronously calls DoRenameItem(FileSystemSessionItem, String) and returns already completed Task with result returned by DoRenameItem(FileSystemSessionItem, String)
Protected method | DoRollbackTransaction | Override in particular file systems that support transactions to rollback transaction in specified session. This method may be called by miltiple threads
Protected method | DoRollbackTransactionAsync | Async version of DoRollbackTransaction(FileSystemSession). This base/default implementation just synchronously calls DoRollbackTransaction(FileSystemSession) and returns already completed Task with result returned by DoRollbackTransaction(FileSystemSession)
Protected method | DoSetCreationTimestamp | Override to set item creation timestamp. This method may be called by miltiple threads
Protected method | DoSetCreationTimestampAsync | Async version of DoSetCreationTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetCreationTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetCreationTimestamp(FileSystemSessionItem, DateTime)
Protected method | DoSetLastAccessTimestamp | Override to set item last access timestamp. This method may be called by miltiple threads
Protected method | DoSetLastAccessTimestampAsync | Async version of DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime)
Protected method | DoSetModificationTimestamp | Override to set item modification timestamp. This method may be called by miltiple threads
Protected method | DoSetModificationTimestampAsync | Async version of DoSetModificationTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetModificationTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetModificationTimestamp(FileSystemSessionItem, DateTime)
Protected method | DoSetReadOnly | Override to set item readonly status. This method may be called by miltiple threads
Protected method | DoSetReadOnlyAsync | Async version of DoSetReadOnly(FileSystemSessionItem, Boolean). This base/default implementation just synchronously calls DoSetReadOnly(FileSystemSessionItem, Boolean) and returns already completed Task with result returned by DoSetReadOnly(FileSystemSessionItem, Boolean)
Protected method | DoSetVersion | Override in particular file systems that support versioning to set seesion to specific version. This method may be called by miltiple threads
Protected method | DoSetVersionAsync | Async version of DoSetVersion(FileSystemSession, IFileSystemVersion). This base/default implementation just synchronously calls DoSetVersion(FileSystemSession, IFileSystemVersion) and returns already completed Task with result returned by DoSetVersion(FileSystemSession, IFileSystemVersion)
Protected method | DoWriteAsync |
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Make TParam (IConfigSectionNode) |
 | Make TParam (String, String) |
Protected method | MakeSessionConfigParams |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | StartSession | Creates a new session for the user. This method is thread-safe, however the returned FileSystemSession object is not. Every thread must obtain its own session via this method
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
FileSystem Class
NFX.IO.FileSystem Namespace


FileSystem.AutoStartSystems Method

FileSystem AutoStartSystems Method NFX Class Library

Automatically starts systems designated in config with auto-start attribute

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AutoStartSystems()
public static void AutoStartSystems()
Public Shared Sub AutoStartSystems
Public Shared Sub AutoStartSystems
public:
static void AutoStartSystems()
public:
static void AutoStartSystems()
static member AutoStartSystems : unit -> unit
static member AutoStartSystems : unit -> unit
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.CombinePaths Method

FileSystem CombinePaths Method NFX Class Library

Combines two or more path segments joining them using primary file system path separator. This method is thread-safe

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string CombinePaths(
    string first,
    params string[] others
)
public virtual string CombinePaths(
    string first,
    params string[] others
)
Public Overridable Function CombinePaths (
    first As String,
    ParamArray others As String()
) As String
Public Overridable Function CombinePaths (
    first As String,
    ParamArray others As String()
) As String
public:
virtual String^ CombinePaths(
    String^ first,
    ... array<String^>^ others
)
public:
virtual String^ CombinePaths(
    String^ first,
    ... array<String^>^ others
)
abstract CombinePaths :
        first : string *
        others : string[] -> string
override CombinePaths :
        first : string *
        others : string[] -> string
abstract CombinePaths :
        first : string *
        others : string[] -> string
override CombinePaths :
        first : string *
        others : string[] -> string

Parameters

first
Type: Online System String
others
Type: Online System String

Return Value

Type: Online String

Implements

IFileSystem CombinePaths(String, String )
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.Configure Method

FileSystem Configure Method NFX Class Library

Configures file system. This method is a part of lifecycle management and is intended to be called only by creating thread (not thread-safe)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode node
)
public void Configure(
    IConfigSectionNode node
)
Public Sub Configure (
    node As IConfigSectionNode
)
Public Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.Destructor Method

FileSystem Destructor Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoBeginTransaction Method

FileSystem DoBeginTransaction Method NFX Class Library

Override in particular file systems that support transactions to begin transaction in specified session. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual IFileSystemTransactionHandle DoBeginTransaction(
    FileSystemSession session
)
protected internal virtual IFileSystemTransactionHandle DoBeginTransaction(
    FileSystemSession session
)
Protected Friend Overridable Function DoBeginTransaction (
    session As FileSystemSession
) As IFileSystemTransactionHandle
Protected Friend Overridable Function DoBeginTransaction (
    session As FileSystemSession
) As IFileSystemTransactionHandle
protected public:
virtual IFileSystemTransactionHandle^ DoBeginTransaction(
    FileSystemSession^ session
)
protected public:
virtual IFileSystemTransactionHandle^ DoBeginTransaction(
    FileSystemSession^ session
)
abstract DoBeginTransaction :
        session : FileSystemSession -> IFileSystemTransactionHandle
override DoBeginTransaction :
        session : FileSystemSession -> IFileSystemTransactionHandle
abstract DoBeginTransaction :
        session : FileSystemSession -> IFileSystemTransactionHandle
override DoBeginTransaction :
        session : FileSystemSession -> IFileSystemTransactionHandle

Parameters

session
Type: NFX.IO.FileSystem FileSystemSession

Return Value

Type: IFileSystemTransactionHandle
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoBeginTransactionAsync Method

FileSystem DoBeginTransactionAsync Method NFX Class Library

Async version of DoBeginTransaction(FileSystemSession). This base/default implementation just synchronously calls DoBeginTransaction(FileSystemSession) and returns already completed Task with result returned by DoBeginTransaction(FileSystemSession)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task<IFileSystemTransactionHandle> DoBeginTransactionAsync(
    FileSystemSession session
)
protected internal virtual Task<IFileSystemTransactionHandle> DoBeginTransactionAsync(
    FileSystemSession session
)
Protected Friend Overridable Function DoBeginTransactionAsync (
    session As FileSystemSession
) As Task(Of IFileSystemTransactionHandle)
Protected Friend Overridable Function DoBeginTransactionAsync (
    session As FileSystemSession
) As Task(Of IFileSystemTransactionHandle)
protected public:
virtual Task<IFileSystemTransactionHandle^>^ DoBeginTransactionAsync(
    FileSystemSession^ session
)
protected public:
virtual Task<IFileSystemTransactionHandle^>^ DoBeginTransactionAsync(
    FileSystemSession^ session
)
abstract DoBeginTransactionAsync :
        session : FileSystemSession -> Task<IFileSystemTransactionHandle>
override DoBeginTransactionAsync :
        session : FileSystemSession -> Task<IFileSystemTransactionHandle>
abstract DoBeginTransactionAsync :
        session : FileSystemSession -> Task<IFileSystemTransactionHandle>
override DoBeginTransactionAsync :
        session : FileSystemSession -> Task<IFileSystemTransactionHandle>

Parameters

session
Type: NFX.IO.FileSystem FileSystemSession

Return Value

Type: Online Task IFileSystemTransactionHandle
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoCheckCanChange Method

FileSystem DoCheckCanChange Method NFX Class Library

Override in particular file systems to see if item can change, i.e. for file systems that support versioning throw exception if item is in session which "looks" at a sealed/closed version and can not change. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual void DoCheckCanChange(
    FileSystemSessionItem item
)
protected internal virtual void DoCheckCanChange(
    FileSystemSessionItem item
)
Protected Friend Overridable Sub DoCheckCanChange (
    item As FileSystemSessionItem
)
Protected Friend Overridable Sub DoCheckCanChange (
    item As FileSystemSessionItem
)
protected public:
virtual void DoCheckCanChange(
    FileSystemSessionItem^ item
)
protected public:
virtual void DoCheckCanChange(
    FileSystemSessionItem^ item
)
abstract DoCheckCanChange :
        item : FileSystemSessionItem -> unit
override DoCheckCanChange :
        item : FileSystemSessionItem -> unit
abstract DoCheckCanChange :
        item : FileSystemSessionItem -> unit
override DoCheckCanChange :
        item : FileSystemSessionItem -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoCheckCanChangeAsync Method

FileSystem DoCheckCanChangeAsync Method NFX Class Library

Async version of DoCheckCanChange(FileSystemSessionItem). This base/default implementation just synchronously calls DoCheckCanChange(FileSystemSessionItem) and returns already completed Task with result returned by DoCheckCanChange(FileSystemSessionItem)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task DoCheckCanChangeAsync(
    FileSystemSessionItem item
)
protected internal virtual Task DoCheckCanChangeAsync(
    FileSystemSessionItem item
)
Protected Friend Overridable Function DoCheckCanChangeAsync (
    item As FileSystemSessionItem
) As Task
Protected Friend Overridable Function DoCheckCanChangeAsync (
    item As FileSystemSessionItem
) As Task
protected public:
virtual Task^ DoCheckCanChangeAsync(
    FileSystemSessionItem^ item
)
protected public:
virtual Task^ DoCheckCanChangeAsync(
    FileSystemSessionItem^ item
)
abstract DoCheckCanChangeAsync :
        item : FileSystemSessionItem -> Task
override DoCheckCanChangeAsync :
        item : FileSystemSessionItem -> Task
abstract DoCheckCanChangeAsync :
        item : FileSystemSessionItem -> Task
override DoCheckCanChangeAsync :
        item : FileSystemSessionItem -> Task

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online Task
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoCommitTransaction Method

FileSystem DoCommitTransaction Method NFX Class Library

Override in particular file systems that support transactions to commit transaction in specified session. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual void DoCommitTransaction(
    FileSystemSession session
)
protected internal virtual void DoCommitTransaction(
    FileSystemSession session
)
Protected Friend Overridable Sub DoCommitTransaction (
    session As FileSystemSession
)
Protected Friend Overridable Sub DoCommitTransaction (
    session As FileSystemSession
)
protected public:
virtual void DoCommitTransaction(
    FileSystemSession^ session
)
protected public:
virtual void DoCommitTransaction(
    FileSystemSession^ session
)
abstract DoCommitTransaction :
        session : FileSystemSession -> unit
override DoCommitTransaction :
        session : FileSystemSession -> unit
abstract DoCommitTransaction :
        session : FileSystemSession -> unit
override DoCommitTransaction :
        session : FileSystemSession -> unit

Parameters

session
Type: NFX.IO.FileSystem FileSystemSession
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoCommitTransactionAsync Method

FileSystem DoCommitTransactionAsync Method NFX Class Library

Async version of DoCommitTransaction(FileSystemSession). This base/default implementation just synchronously calls DoCommitTransaction(FileSystemSession) and returns already completed Task with result returned by DoCommitTransaction(FileSystemSession)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task DoCommitTransactionAsync(
    FileSystemSession session
)
protected internal virtual Task DoCommitTransactionAsync(
    FileSystemSession session
)
Protected Friend Overridable Function DoCommitTransactionAsync (
    session As FileSystemSession
) As Task
Protected Friend Overridable Function DoCommitTransactionAsync (
    session As FileSystemSession
) As Task
protected public:
virtual Task^ DoCommitTransactionAsync(
    FileSystemSession^ session
)
protected public:
virtual Task^ DoCommitTransactionAsync(
    FileSystemSession^ session
)
abstract DoCommitTransactionAsync :
        session : FileSystemSession -> Task
override DoCommitTransactionAsync :
        session : FileSystemSession -> Task
abstract DoCommitTransactionAsync :
        session : FileSystemSession -> Task
override DoCommitTransactionAsync :
        session : FileSystemSession -> Task

Parameters

session
Type: NFX.IO.FileSystem FileSystemSession

Return Value

Type: Online Task
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoConfigure Method

FileSystem DoConfigure Method NFX Class Library

Override to perform custom configuration

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoConfigure(
    IConfigSectionNode node
)
protected virtual void DoConfigure(
    IConfigSectionNode node
)
Protected Overridable Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overridable Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
)
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoCreateDirectory Method

FileSystem DoCreateDirectory Method NFX Class Library

Override to create a directory. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract FileSystemDirectory DoCreateDirectory(
    FileSystemDirectory dir,
    string name
)
protected internal abstract FileSystemDirectory DoCreateDirectory(
    FileSystemDirectory dir,
    string name
)
Protected Friend MustOverride Function DoCreateDirectory (
    dir As FileSystemDirectory,
    name As String
) As FileSystemDirectory
Protected Friend MustOverride Function DoCreateDirectory (
    dir As FileSystemDirectory,
    name As String
) As FileSystemDirectory
protected public:
virtual FileSystemDirectory^ DoCreateDirectory(
    FileSystemDirectory^ dir,
    String^ name
) abstract
protected public:
virtual FileSystemDirectory^ DoCreateDirectory(
    FileSystemDirectory^ dir,
    String^ name
) abstract
abstract DoCreateDirectory :
        dir : FileSystemDirectory *
        name : string -> FileSystemDirectory
abstract DoCreateDirectory :
        dir : FileSystemDirectory *
        name : string -> FileSystemDirectory

Parameters

dir
Type: NFX.IO.FileSystem FileSystemDirectory
name
Type: Online System String

Return Value

Type: FileSystemDirectory
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoCreateDirectoryAsync Method

FileSystem DoCreateDirectoryAsync Method NFX Class Library

Async version of DoCreateDirectory(FileSystemDirectory, String). This base/default implementation just synchronously calls DoCreateDirectory(FileSystemDirectory, String) and returns already completed Task with result returned by DoCreateDirectory(FileSystemDirectory, String)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task<FileSystemDirectory> DoCreateDirectoryAsync(
    FileSystemDirectory dir,
    string name
)
protected internal virtual Task<FileSystemDirectory> DoCreateDirectoryAsync(
    FileSystemDirectory dir,
    string name
)
Protected Friend Overridable Function DoCreateDirectoryAsync (
    dir As FileSystemDirectory,
    name As String
) As Task(Of FileSystemDirectory)
Protected Friend Overridable Function DoCreateDirectoryAsync (
    dir As FileSystemDirectory,
    name As String
) As Task(Of FileSystemDirectory)
protected public:
virtual Task<FileSystemDirectory^>^ DoCreateDirectoryAsync(
    FileSystemDirectory^ dir,
    String^ name
)
protected public:
virtual Task<FileSystemDirectory^>^ DoCreateDirectoryAsync(
    FileSystemDirectory^ dir,
    String^ name
)
abstract DoCreateDirectoryAsync :
        dir : FileSystemDirectory *
        name : string -> Task<FileSystemDirectory>
override DoCreateDirectoryAsync :
        dir : FileSystemDirectory *
        name : string -> Task<FileSystemDirectory>
abstract DoCreateDirectoryAsync :
        dir : FileSystemDirectory *
        name : string -> Task<FileSystemDirectory>
override DoCreateDirectoryAsync :
        dir : FileSystemDirectory *
        name : string -> Task<FileSystemDirectory>

Parameters

dir
Type: NFX.IO.FileSystem FileSystemDirectory
name
Type: Online System String

Return Value

Type: Online Task FileSystemDirectory
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoCreateFile Method

FileSystem DoCreateFile Method NFX Class Library

Overload List
 | Name | Description
Protected method | DoCreateFile(FileSystemDirectory, String, Int32) | Override to create a file. This method may be called by miltiple threads
Protected method | DoCreateFile(FileSystemDirectory, String, String, Boolean) | Override to create a file from local file. This method may be called by miltiple threads
Back to Top
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoCreateFile Method (FileSystemDirectory, String, Int32)

FileSystem DoCreateFile Method (FileSystemDirectory, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to create a file. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract FileSystemFile DoCreateFile(
    FileSystemDirectory dir,
    string name,
    int size
)
protected internal abstract FileSystemFile DoCreateFile(
    FileSystemDirectory dir,
    string name,
    int size
)
Protected Friend MustOverride Function DoCreateFile (
    dir As FileSystemDirectory,
    name As String,
    size As Integer
) As FileSystemFile
Protected Friend MustOverride Function DoCreateFile (
    dir As FileSystemDirectory,
    name As String,
    size As Integer
) As FileSystemFile
protected public:
virtual FileSystemFile^ DoCreateFile(
    FileSystemDirectory^ dir,
    String^ name,
    int size
) abstract
protected public:
virtual FileSystemFile^ DoCreateFile(
    FileSystemDirectory^ dir,
    String^ name,
    int size
) abstract
abstract DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        size : int -> FileSystemFile
abstract DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        size : int -> FileSystemFile

Parameters

dir
Type: NFX.IO.FileSystem FileSystemDirectory
name
Type: Online System String
size
Type: Online System Int32

Return Value

Type: FileSystemFile
See Also
FileSystem Class
FileSystem Members
DoCreateFile Overload
NFX.IO.FileSystem Namespace


FileSystem.DoCreateFile Method (FileSystemDirectory, String, String, Boolean)

FileSystem DoCreateFile Method (FileSystemDirectory, String, String, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to create a file from local file. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract FileSystemFile DoCreateFile(
    FileSystemDirectory dir,
    string name,
    string localFile,
    bool readOnly
)
protected internal abstract FileSystemFile DoCreateFile(
    FileSystemDirectory dir,
    string name,
    string localFile,
    bool readOnly
)
Protected Friend MustOverride Function DoCreateFile (
    dir As FileSystemDirectory,
    name As String,
    localFile As String,
    readOnly As Boolean
) As FileSystemFile
Protected Friend MustOverride Function DoCreateFile (
    dir As FileSystemDirectory,
    name As String,
    localFile As String,
    readOnly As Boolean
) As FileSystemFile
protected public:
virtual FileSystemFile^ DoCreateFile(
    FileSystemDirectory^ dir,
    String^ name,
    String^ localFile,
    bool readOnly
) abstract
protected public:
virtual FileSystemFile^ DoCreateFile(
    FileSystemDirectory^ dir,
    String^ name,
    String^ localFile,
    bool readOnly
) abstract
abstract DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        localFile : string *
        readOnly : bool -> FileSystemFile
abstract DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        localFile : string *
        readOnly : bool -> FileSystemFile

Parameters

dir
Type: NFX.IO.FileSystem FileSystemDirectory
name
Type: Online System String
localFile
Type: Online System String
readOnly
Type: Online System Boolean

Return Value

Type: FileSystemFile
See Also
FileSystem Class
FileSystem Members
DoCreateFile Overload
NFX.IO.FileSystem Namespace


FileSystem.DoCreateFileAsync Method

FileSystem DoCreateFileAsync Method NFX Class Library

Overload List
 | Name | Description
Protected method | DoCreateFileAsync(FileSystemDirectory, String, Int32) | Async version of DoCreateFile(FileSystemDirectory, String, Int32). This base/default implementation just synchronously calls DoCreateFile(FileSystemDirectory, String, Int32) and returns already completed Task with result returned by DoCreateFile(FileSystemDirectory, String, Int32)
Protected method | DoCreateFileAsync(FileSystemDirectory, String, String, Boolean) | Async version of DoCreateFile(FileSystemDirectory, String, String, Boolean). This base/default implementation just synchronously calls DoCreateFile(FileSystemDirectory, String, String, Boolean) and returns already completed Task with result returned by DoCreateFile(FileSystemDirectory, String, String, Boolean)
Back to Top
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoCreateFileAsync Method (FileSystemDirectory, String, Int32)

FileSystem DoCreateFileAsync Method (FileSystemDirectory, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of DoCreateFile(FileSystemDirectory, String, Int32). This base/default implementation just synchronously calls DoCreateFile(FileSystemDirectory, String, Int32) and returns already completed Task with result returned by DoCreateFile(FileSystemDirectory, String, Int32)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task<FileSystemFile> DoCreateFileAsync(
    FileSystemDirectory dir,
    string name,
    int size
)
protected internal virtual Task<FileSystemFile> DoCreateFileAsync(
    FileSystemDirectory dir,
    string name,
    int size
)
Protected Friend Overridable Function DoCreateFileAsync (
    dir As FileSystemDirectory,
    name As String,
    size As Integer
) As Task(Of FileSystemFile)
Protected Friend Overridable Function DoCreateFileAsync (
    dir As FileSystemDirectory,
    name As String,
    size As Integer
) As Task(Of FileSystemFile)
protected public:
virtual Task<FileSystemFile^>^ DoCreateFileAsync(
    FileSystemDirectory^ dir,
    String^ name,
    int size
)
protected public:
virtual Task<FileSystemFile^>^ DoCreateFileAsync(
    FileSystemDirectory^ dir,
    String^ name,
    int size
)
abstract DoCreateFileAsync :
        dir : FileSystemDirectory *
        name : string *
        size : int -> Task<FileSystemFile>
override DoCreateFileAsync :
        dir : FileSystemDirectory *
        name : string *
        size : int -> Task<FileSystemFile>
abstract DoCreateFileAsync :
        dir : FileSystemDirectory *
        name : string *
        size : int -> Task<FileSystemFile>
override DoCreateFileAsync :
        dir : FileSystemDirectory *
        name : string *
        size : int -> Task<FileSystemFile>

Parameters

dir
Type: NFX.IO.FileSystem FileSystemDirectory
name
Type: Online System String
size
Type: Online System Int32

Return Value

Type: Online Task FileSystemFile
See Also
FileSystem Class
FileSystem Members
DoCreateFileAsync Overload
NFX.IO.FileSystem Namespace


FileSystem.DoCreateFileAsync Method (FileSystemDirectory, String, String, Boolean)

FileSystem DoCreateFileAsync Method (FileSystemDirectory, String, String, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of DoCreateFile(FileSystemDirectory, String, String, Boolean). This base/default implementation just synchronously calls DoCreateFile(FileSystemDirectory, String, String, Boolean) and returns already completed Task with result returned by DoCreateFile(FileSystemDirectory, String, String, Boolean)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task<FileSystemFile> DoCreateFileAsync(
    FileSystemDirectory dir,
    string name,
    string localFile,
    bool readOnly
)
protected internal virtual Task<FileSystemFile> DoCreateFileAsync(
    FileSystemDirectory dir,
    string name,
    string localFile,
    bool readOnly
)
Protected Friend Overridable Function DoCreateFileAsync (
    dir As FileSystemDirectory,
    name As String,
    localFile As String,
    readOnly As Boolean
) As Task(Of FileSystemFile)
Protected Friend Overridable Function DoCreateFileAsync (
    dir As FileSystemDirectory,
    name As String,
    localFile As String,
    readOnly As Boolean
) As Task(Of FileSystemFile)
protected public:
virtual Task<FileSystemFile^>^ DoCreateFileAsync(
    FileSystemDirectory^ dir,
    String^ name,
    String^ localFile,
    bool readOnly
)
protected public:
virtual Task<FileSystemFile^>^ DoCreateFileAsync(
    FileSystemDirectory^ dir,
    String^ name,
    String^ localFile,
    bool readOnly
)
abstract DoCreateFileAsync :
        dir : FileSystemDirectory *
        name : string *
        localFile : string *
        readOnly : bool -> Task<FileSystemFile>
override DoCreateFileAsync :
        dir : FileSystemDirectory *
        name : string *
        localFile : string *
        readOnly : bool -> Task<FileSystemFile>
abstract DoCreateFileAsync :
        dir : FileSystemDirectory *
        name : string *
        localFile : string *
        readOnly : bool -> Task<FileSystemFile>
override DoCreateFileAsync :
        dir : FileSystemDirectory *
        name : string *
        localFile : string *
        readOnly : bool -> Task<FileSystemFile>

Parameters

dir
Type: NFX.IO.FileSystem FileSystemDirectory
name
Type: Online System String
localFile
Type: Online System String
readOnly
Type: Online System Boolean

Return Value

Type: Online Task FileSystemFile
See Also
FileSystem Class
FileSystem Members
DoCreateFileAsync Overload
NFX.IO.FileSystem Namespace


FileSystem.DoDeleteItem Method

FileSystem DoDeleteItem Method NFX Class Library

Override to delete item. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract void DoDeleteItem(
    FileSystemSessionItem item
)
protected internal abstract void DoDeleteItem(
    FileSystemSessionItem item
)
Protected Friend MustOverride Sub DoDeleteItem (
    item As FileSystemSessionItem
)
Protected Friend MustOverride Sub DoDeleteItem (
    item As FileSystemSessionItem
)
protected public:
virtual void DoDeleteItem(
    FileSystemSessionItem^ item
) abstract
protected public:
virtual void DoDeleteItem(
    FileSystemSessionItem^ item
) abstract
abstract DoDeleteItem :
        item : FileSystemSessionItem -> unit
abstract DoDeleteItem :
        item : FileSystemSessionItem -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoDeleteItemAsync Method

FileSystem DoDeleteItemAsync Method NFX Class Library

Async version of DoDeleteItem(FileSystemSessionItem). This base/default implementation just synchronously calls DoDeleteItem(FileSystemSessionItem) and returns already completed Task with result returned by DoDeleteItem(FileSystemSessionItem)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task DoDeleteItemAsync(
    FileSystemSessionItem item
)
protected internal virtual Task DoDeleteItemAsync(
    FileSystemSessionItem item
)
Protected Friend Overridable Function DoDeleteItemAsync (
    item As FileSystemSessionItem
) As Task
Protected Friend Overridable Function DoDeleteItemAsync (
    item As FileSystemSessionItem
) As Task
protected public:
virtual Task^ DoDeleteItemAsync(
    FileSystemSessionItem^ item
)
protected public:
virtual Task^ DoDeleteItemAsync(
    FileSystemSessionItem^ item
)
abstract DoDeleteItemAsync :
        item : FileSystemSessionItem -> Task
override DoDeleteItemAsync :
        item : FileSystemSessionItem -> Task
abstract DoDeleteItemAsync :
        item : FileSystemSessionItem -> Task
override DoDeleteItemAsync :
        item : FileSystemSessionItem -> Task

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online Task
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoDirectoryDeepCopyAsync Method

FileSystem DoDirectoryDeepCopyAsync Method NFX Class Library

Implements asynchronous deep copy of folders where destination folder may belong to a different file system. The specifics of implementation may be dictated by particular file systems, i.e.: asynchronous strategies for getting file lists may depend on the particular system.

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task DoDirectoryDeepCopyAsync(
    FileSystemDirectory dirFrom,
    FileSystemDirectory dirTo,
    FileSystemDirectory..::..DirCopyFlags flags = FileSystemDirectory..::..DirCopyFlags.All,
    int bufferSize = 65536,
    Func<FileSystemSessionItem, bool> filter = null,
    Func<FileSystemSessionItem, bool> cancel = null
)
protected internal virtual Task DoDirectoryDeepCopyAsync(
    FileSystemDirectory dirFrom,
    FileSystemDirectory dirTo,
    FileSystemDirectory..::..DirCopyFlags flags = FileSystemDirectory..::..DirCopyFlags.All,
    int bufferSize = 65536,
    Func<FileSystemSessionItem, bool> filter = null,
    Func<FileSystemSessionItem, bool> cancel = null
)
Protected Friend Overridable Function DoDirectoryDeepCopyAsync (
    dirFrom As FileSystemDirectory,
    dirTo As FileSystemDirectory,
    Optional flags As FileSystemDirectory..::..DirCopyFlags = FileSystemDirectory..::..DirCopyFlags.All,
    Optional bufferSize As Integer = 65536,
    Optional filter As Func(Of FileSystemSessionItem, Boolean) = Nothing,
    Optional cancel As Func(Of FileSystemSessionItem, Boolean) = Nothing
) As Task
Protected Friend Overridable Function DoDirectoryDeepCopyAsync (
    dirFrom As FileSystemDirectory,
    dirTo As FileSystemDirectory,
    Optional flags As FileSystemDirectory..::..DirCopyFlags = FileSystemDirectory..::..DirCopyFlags.All,
    Optional bufferSize As Integer = 65536,
    Optional filter As Func(Of FileSystemSessionItem, Boolean) = Nothing,
    Optional cancel As Func(Of FileSystemSessionItem, Boolean) = Nothing
) As Task
protected public:
virtual Task^ DoDirectoryDeepCopyAsync(
    FileSystemDirectory^ dirFrom,
    FileSystemDirectory^ dirTo,
    FileSystemDirectory..::..DirCopyFlags flags = FileSystemDirectory..::..DirCopyFlags::All,
    int bufferSize = 65536,
    Func<FileSystemSessionItem^, bool>^ filter = nullptr,
    Func<FileSystemSessionItem^, bool>^ cancel = nullptr
)
protected public:
virtual Task^ DoDirectoryDeepCopyAsync(
    FileSystemDirectory^ dirFrom,
    FileSystemDirectory^ dirTo,
    FileSystemDirectory..::..DirCopyFlags flags = FileSystemDirectory..::..DirCopyFlags::All,
    int bufferSize = 65536,
    Func<FileSystemSessionItem^, bool>^ filter = nullptr,
    Func<FileSystemSessionItem^, bool>^ cancel = nullptr
)
abstract DoDirectoryDeepCopyAsync :
        dirFrom : FileSystemDirectory *
        dirTo : FileSystemDirectory *
        ?flags : FileSystemDirectory..::..DirCopyFlags *
        ?bufferSize : int *
        ?filter : Func<FileSystemSessionItem, bool> *
        ?cancel : Func<FileSystemSessionItem, bool>
(* Defaults:
        let _flags = defaultArg flags FileSystemDirectory..::..DirCopyFlags.All
        let _bufferSize = defaultArg bufferSize 65536
        let _filter = defaultArg filter null
        let _cancel = defaultArg cancel null
*)
-> Task
override DoDirectoryDeepCopyAsync :
        dirFrom : FileSystemDirectory *
        dirTo : FileSystemDirectory *
        ?flags : FileSystemDirectory..::..DirCopyFlags *
        ?bufferSize : int *
        ?filter : Func<FileSystemSessionItem, bool> *
        ?cancel : Func<FileSystemSessionItem, bool>
(* Defaults:
        let _flags = defaultArg flags FileSystemDirectory..::..DirCopyFlags.All
        let _bufferSize = defaultArg bufferSize 65536
        let _filter = defaultArg filter null
        let _cancel = defaultArg cancel null
*)
-> Task
abstract DoDirectoryDeepCopyAsync :
        dirFrom : FileSystemDirectory *
        dirTo : FileSystemDirectory *
        ?flags : FileSystemDirectory..::..DirCopyFlags *
        ?bufferSize : int *
        ?filter : Func<FileSystemSessionItem, bool> *
        ?cancel : Func<FileSystemSessionItem, bool>
(* Defaults:
        let _flags = defaultArg flags FileSystemDirectory..::..DirCopyFlags.All
        let _bufferSize = defaultArg bufferSize 65536
        let _filter = defaultArg filter null
        let _cancel = defaultArg cancel null
*)
-> Task
override DoDirectoryDeepCopyAsync :
        dirFrom : FileSystemDirectory *
        dirTo : FileSystemDirectory *
        ?flags : FileSystemDirectory..::..DirCopyFlags *
        ?bufferSize : int *
        ?filter : Func<FileSystemSessionItem, bool> *
        ?cancel : Func<FileSystemSessionItem, bool>
(* Defaults:
        let _flags = defaultArg flags FileSystemDirectory..::..DirCopyFlags.All
        let _bufferSize = defaultArg bufferSize 65536
        let _filter = defaultArg filter null
        let _cancel = defaultArg cancel null
*)
-> Task

Parameters

dirFrom
Type: NFX.IO.FileSystem FileSystemDirectory
dirTo
Type: NFX.IO.FileSystem FileSystemDirectory
flags (Optional)
Type: NFX.IO.FileSystem FileSystemDirectory DirCopyFlags
bufferSize (Optional)
Type: Online System Int32
filter (Optional)
Type: Online System Func FileSystemSessionItem, Online Boolean
cancel (Optional)
Type: Online System Func FileSystemSessionItem, Online Boolean

Return Value

Type: Online Task
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoFlushAsync Method

FileSystem DoFlushAsync Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task DoFlushAsync(
    FileSystemStream stream,
    CancellationToken cancellationToken
)
protected internal virtual Task DoFlushAsync(
    FileSystemStream stream,
    CancellationToken cancellationToken
)
Protected Friend Overridable Function DoFlushAsync (
    stream As FileSystemStream,
    cancellationToken As CancellationToken
) As Task
Protected Friend Overridable Function DoFlushAsync (
    stream As FileSystemStream,
    cancellationToken As CancellationToken
) As Task
protected public:
virtual Task^ DoFlushAsync(
    FileSystemStream^ stream,
    CancellationToken cancellationToken
)
protected public:
virtual Task^ DoFlushAsync(
    FileSystemStream^ stream,
    CancellationToken cancellationToken
)
abstract DoFlushAsync :
        stream : FileSystemStream *
        cancellationToken : CancellationToken -> Task
override DoFlushAsync :
        stream : FileSystemStream *
        cancellationToken : CancellationToken -> Task
abstract DoFlushAsync :
        stream : FileSystemStream *
        cancellationToken : CancellationToken -> Task
override DoFlushAsync :
        stream : FileSystemStream *
        cancellationToken : CancellationToken -> Task

Parameters

stream
Type: NFX.IO.FileSystem FileSystemStream
cancellationToken
Type: Online System.Threading CancellationToken

Return Value

Type: Online Task
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoGetCreationTimestamp Method

FileSystem DoGetCreationTimestamp Method NFX Class Library

Override to get item creation timestamp. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract Nullable<DateTime> DoGetCreationTimestamp(
    FileSystemSessionItem item
)
protected internal abstract Nullable<DateTime> DoGetCreationTimestamp(
    FileSystemSessionItem item
)
Protected Friend MustOverride Function DoGetCreationTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
Protected Friend MustOverride Function DoGetCreationTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
protected public:
virtual Nullable<DateTime> DoGetCreationTimestamp(
    FileSystemSessionItem^ item
) abstract
protected public:
virtual Nullable<DateTime> DoGetCreationTimestamp(
    FileSystemSessionItem^ item
) abstract
abstract DoGetCreationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
abstract DoGetCreationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online Nullable Online DateTime
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoGetCreationUser Method

FileSystem DoGetCreationUser Method NFX Class Library

Override in particular file systems to get user who created item. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual User DoGetCreationUser(
    FileSystemSessionItem item
)
protected internal virtual User DoGetCreationUser(
    FileSystemSessionItem item
)
Protected Friend Overridable Function DoGetCreationUser (
    item As FileSystemSessionItem
) As User
Protected Friend Overridable Function DoGetCreationUser (
    item As FileSystemSessionItem
) As User
protected public:
virtual User^ DoGetCreationUser(
    FileSystemSessionItem^ item
)
protected public:
virtual User^ DoGetCreationUser(
    FileSystemSessionItem^ item
)
abstract DoGetCreationUser :
        item : FileSystemSessionItem -> User
override DoGetCreationUser :
        item : FileSystemSessionItem -> User
abstract DoGetCreationUser :
        item : FileSystemSessionItem -> User
override DoGetCreationUser :
        item : FileSystemSessionItem -> User

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: User
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoGetCreationUserAsync Method

FileSystem DoGetCreationUserAsync Method NFX Class Library

Async version of DoGetCreationUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetCreationUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetCreationUser(FileSystemSessionItem)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task<User> DoGetCreationUserAsync(
    FileSystemSessionItem item
)
protected internal virtual Task<User> DoGetCreationUserAsync(
    FileSystemSessionItem item
)
Protected Friend Overridable Function DoGetCreationUserAsync (
    item As FileSystemSessionItem
) As Task(Of User)
Protected Friend Overridable Function DoGetCreationUserAsync (
    item As FileSystemSessionItem
) As Task(Of User)
protected public:
virtual Task<User^>^ DoGetCreationUserAsync(
    FileSystemSessionItem^ item
)
protected public:
virtual Task<User^>^ DoGetCreationUserAsync(
    FileSystemSessionItem^ item
)
abstract DoGetCreationUserAsync :
        item : FileSystemSessionItem -> Task<User>
override DoGetCreationUserAsync :
        item : FileSystemSessionItem -> Task<User>
abstract DoGetCreationUserAsync :
        item : FileSystemSessionItem -> Task<User>
override DoGetCreationUserAsync :
        item : FileSystemSessionItem -> Task<User>

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online Task User
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoGetFileNames Method

FileSystem DoGetFileNames Method NFX Class Library

Override to get file names in directory. If directory is null then root is assumed. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract IEnumerable<string> DoGetFileNames(
    FileSystemDirectory directory,
    bool recursive
)
protected internal abstract IEnumerable<string> DoGetFileNames(
    FileSystemDirectory directory,
    bool recursive
)
Protected Friend MustOverride Function DoGetFileNames (
    directory As FileSystemDirectory,
    recursive As Boolean
) As IEnumerable(Of String)
Protected Friend MustOverride Function DoGetFileNames (
    directory As FileSystemDirectory,
    recursive As Boolean
) As IEnumerable(Of String)
protected public:
virtual IEnumerable<String^>^ DoGetFileNames(
    FileSystemDirectory^ directory,
    bool recursive
) abstract
protected public:
virtual IEnumerable<String^>^ DoGetFileNames(
    FileSystemDirectory^ directory,
    bool recursive
) abstract
abstract DoGetFileNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>
abstract DoGetFileNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>

Parameters

directory
Type: NFX.IO.FileSystem FileSystemDirectory
recursive
Type: Online System Boolean

Return Value

Type: Online IEnumerable Online String
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoGetFileNamesAsync Method

FileSystem DoGetFileNamesAsync Method NFX Class Library

Async version of DoGetFileNames(FileSystemDirectory, Boolean). This base/default implementation just synchronously calls DoGetFileNames(FileSystemDirectory, Boolean) and returns already completed Task with result returned by DoGetFileNames(FileSystemDirectory, Boolean)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task<IEnumerable<string>> DoGetFileNamesAsync(
    FileSystemDirectory directory,
    bool recursive
)
protected internal virtual Task<IEnumerable<string>> DoGetFileNamesAsync(
    FileSystemDirectory directory,
    bool recursive
)
Protected Friend Overridable Function DoGetFileNamesAsync (
    directory As FileSystemDirectory,
    recursive As Boolean
) As Task(Of IEnumerable(Of String))
Protected Friend Overridable Function DoGetFileNamesAsync (
    directory As FileSystemDirectory,
    recursive As Boolean
) As Task(Of IEnumerable(Of String))
protected public:
virtual Task<IEnumerable<String^>^>^ DoGetFileNamesAsync(
    FileSystemDirectory^ directory,
    bool recursive
)
protected public:
virtual Task<IEnumerable<String^>^>^ DoGetFileNamesAsync(
    FileSystemDirectory^ directory,
    bool recursive
)
abstract DoGetFileNamesAsync :
        directory : FileSystemDirectory *
        recursive : bool -> Task<IEnumerable<string>>
override DoGetFileNamesAsync :
        directory : FileSystemDirectory *
        recursive : bool -> Task<IEnumerable<string>>
abstract DoGetFileNamesAsync :
        directory : FileSystemDirectory *
        recursive : bool -> Task<IEnumerable<string>>
override DoGetFileNamesAsync :
        directory : FileSystemDirectory *
        recursive : bool -> Task<IEnumerable<string>>

Parameters

directory
Type: NFX.IO.FileSystem FileSystemDirectory
recursive
Type: Online System Boolean

Return Value

Type: Online Task Online IEnumerable Online String
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoGetFileStream Method

FileSystem DoGetFileStream Method NFX Class Library

Override to get file stream. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract FileSystemStream DoGetFileStream(
    FileSystemFile file,
    Action<FileSystemStream> disposeAction
)
protected internal abstract FileSystemStream DoGetFileStream(
    FileSystemFile file,
    Action<FileSystemStream> disposeAction
)
Protected Friend MustOverride Function DoGetFileStream (
    file As FileSystemFile,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
Protected Friend MustOverride Function DoGetFileStream (
    file As FileSystemFile,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
protected public:
virtual FileSystemStream^ DoGetFileStream(
    FileSystemFile^ file,
    Action<FileSystemStream^>^ disposeAction
) abstract
protected public:
virtual FileSystemStream^ DoGetFileStream(
    FileSystemFile^ file,
    Action<FileSystemStream^>^ disposeAction
) abstract
abstract DoGetFileStream :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
abstract DoGetFileStream :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> FileSystemStream

Parameters

file
Type: NFX.IO.FileSystem FileSystemFile
disposeAction
Type: Online System Action FileSystemStream

Return Value

Type: FileSystemStream
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoGetFileStreamAsync Method

FileSystem DoGetFileStreamAsync Method NFX Class Library

Async version of DoGetFileStream(FileSystemFile, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetFileStream(FileSystemFile, Action FileSystemStream ) and returns already completed Task with result returned by DoGetFileStream(FileSystemFile, Action FileSystemStream )

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task<FileSystemStream> DoGetFileStreamAsync(
    FileSystemFile file,
    Action<FileSystemStream> disposeAction
)
protected internal virtual Task<FileSystemStream> DoGetFileStreamAsync(
    FileSystemFile file,
    Action<FileSystemStream> disposeAction
)
Protected Friend Overridable Function DoGetFileStreamAsync (
    file As FileSystemFile,
    disposeAction As Action(Of FileSystemStream)
) As Task(Of FileSystemStream)
Protected Friend Overridable Function DoGetFileStreamAsync (
    file As FileSystemFile,
    disposeAction As Action(Of FileSystemStream)
) As Task(Of FileSystemStream)
protected public:
virtual Task<FileSystemStream^>^ DoGetFileStreamAsync(
    FileSystemFile^ file,
    Action<FileSystemStream^>^ disposeAction
)
protected public:
virtual Task<FileSystemStream^>^ DoGetFileStreamAsync(
    FileSystemFile^ file,
    Action<FileSystemStream^>^ disposeAction
)
abstract DoGetFileStreamAsync :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> Task<FileSystemStream>
override DoGetFileStreamAsync :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> Task<FileSystemStream>
abstract DoGetFileStreamAsync :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> Task<FileSystemStream>
override DoGetFileStreamAsync :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> Task<FileSystemStream>

Parameters

file
Type: NFX.IO.FileSystem FileSystemFile
disposeAction
Type: Online System Action FileSystemStream

Return Value

Type: Online Task FileSystemStream
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoGetItemSize Method

FileSystem DoGetItemSize Method NFX Class Library

Override to get the byte size of item (directory or file). This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract ulong DoGetItemSize(
    FileSystemSessionItem item
)
protected internal abstract ulong DoGetItemSize(
    FileSystemSessionItem item
)
Protected Friend MustOverride Function DoGetItemSize (
    item As FileSystemSessionItem
) As ULong
Protected Friend MustOverride Function DoGetItemSize (
    item As FileSystemSessionItem
) As ULong
protected public:
virtual unsigned long long DoGetItemSize(
    FileSystemSessionItem^ item
) abstract
protected public:
virtual unsigned long long DoGetItemSize(
    FileSystemSessionItem^ item
) abstract
abstract DoGetItemSize :
        item : FileSystemSessionItem -> uint64
abstract DoGetItemSize :
        item : FileSystemSessionItem -> uint64

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online UInt64
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoGetItemSizeAsync Method

FileSystem DoGetItemSizeAsync Method NFX Class Library

Async version of DoGetItemSize(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetItemSize(FileSystemSessionItem) and returns already completed Task with result returned by DoGetItemSize(FileSystemSessionItem)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task<ulong> DoGetItemSizeAsync(
    FileSystemSessionItem item
)
protected internal virtual Task<ulong> DoGetItemSizeAsync(
    FileSystemSessionItem item
)
Protected Friend Overridable Function DoGetItemSizeAsync (
    item As FileSystemSessionItem
) As Task(Of ULong)
Protected Friend Overridable Function DoGetItemSizeAsync (
    item As FileSystemSessionItem
) As Task(Of ULong)
protected public:
virtual Task<unsigned long long>^ DoGetItemSizeAsync(
    FileSystemSessionItem^ item
)
protected public:
virtual Task<unsigned long long>^ DoGetItemSizeAsync(
    FileSystemSessionItem^ item
)
abstract DoGetItemSizeAsync :
        item : FileSystemSessionItem -> Task<uint64>
override DoGetItemSizeAsync :
        item : FileSystemSessionItem -> Task<uint64>
abstract DoGetItemSizeAsync :
        item : FileSystemSessionItem -> Task<uint64>
override DoGetItemSizeAsync :
        item : FileSystemSessionItem -> Task<uint64>

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online Task Online UInt64
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoGetLastAccessTimestamp Method

FileSystem DoGetLastAccessTimestamp Method NFX Class Library

Override to get item last access timestamp. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract Nullable<DateTime> DoGetLastAccessTimestamp(
    FileSystemSessionItem item
)
protected internal abstract Nullable<DateTime> DoGetLastAccessTimestamp(
    FileSystemSessionItem item
)
Protected Friend MustOverride Function DoGetLastAccessTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
Protected Friend MustOverride Function DoGetLastAccessTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
protected public:
virtual Nullable<DateTime> DoGetLastAccessTimestamp(
    FileSystemSessionItem^ item
) abstract
protected public:
virtual Nullable<DateTime> DoGetLastAccessTimestamp(
    FileSystemSessionItem^ item
) abstract
abstract DoGetLastAccessTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
abstract DoGetLastAccessTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online Nullable Online DateTime
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoGetLastAccessUser Method

FileSystem DoGetLastAccessUser Method NFX Class Library

Override in particular file systems to get user who was the last user accessing the item. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual User DoGetLastAccessUser(
    FileSystemSessionItem item
)
protected internal virtual User DoGetLastAccessUser(
    FileSystemSessionItem item
)
Protected Friend Overridable Function DoGetLastAccessUser (
    item As FileSystemSessionItem
) As User
Protected Friend Overridable Function DoGetLastAccessUser (
    item As FileSystemSessionItem
) As User
protected public:
virtual User^ DoGetLastAccessUser(
    FileSystemSessionItem^ item
)
protected public:
virtual User^ DoGetLastAccessUser(
    FileSystemSessionItem^ item
)
abstract DoGetLastAccessUser :
        item : FileSystemSessionItem -> User
override DoGetLastAccessUser :
        item : FileSystemSessionItem -> User
abstract DoGetLastAccessUser :
        item : FileSystemSessionItem -> User
override DoGetLastAccessUser :
        item : FileSystemSessionItem -> User

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: User
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoGetLastAccessUserAsync Method

FileSystem DoGetLastAccessUserAsync Method NFX Class Library

Async version of DoGetLastAccessUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetLastAccessUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetLastAccessUser(FileSystemSessionItem)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task<User> DoGetLastAccessUserAsync(
    FileSystemSessionItem item
)
protected internal virtual Task<User> DoGetLastAccessUserAsync(
    FileSystemSessionItem item
)
Protected Friend Overridable Function DoGetLastAccessUserAsync (
    item As FileSystemSessionItem
) As Task(Of User)
Protected Friend Overridable Function DoGetLastAccessUserAsync (
    item As FileSystemSessionItem
) As Task(Of User)
protected public:
virtual Task<User^>^ DoGetLastAccessUserAsync(
    FileSystemSessionItem^ item
)
protected public:
virtual Task<User^>^ DoGetLastAccessUserAsync(
    FileSystemSessionItem^ item
)
abstract DoGetLastAccessUserAsync :
        item : FileSystemSessionItem -> Task<User>
override DoGetLastAccessUserAsync :
        item : FileSystemSessionItem -> Task<User>
abstract DoGetLastAccessUserAsync :
        item : FileSystemSessionItem -> Task<User>
override DoGetLastAccessUserAsync :
        item : FileSystemSessionItem -> Task<User>

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online Task User
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoGetLatestVersion Method

FileSystem DoGetLatestVersion Method NFX Class Library

Override in particular file systems that support versioning to get latest version object that this session can work with. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual IFileSystemVersion DoGetLatestVersion(
    FileSystemSession session
)
protected internal virtual IFileSystemVersion DoGetLatestVersion(
    FileSystemSession session
)
Protected Friend Overridable Function DoGetLatestVersion (
    session As FileSystemSession
) As IFileSystemVersion
Protected Friend Overridable Function DoGetLatestVersion (
    session As FileSystemSession
) As IFileSystemVersion
protected public:
virtual IFileSystemVersion^ DoGetLatestVersion(
    FileSystemSession^ session
)
protected public:
virtual IFileSystemVersion^ DoGetLatestVersion(
    FileSystemSession^ session
)
abstract DoGetLatestVersion :
        session : FileSystemSession -> IFileSystemVersion
override DoGetLatestVersion :
        session : FileSystemSession -> IFileSystemVersion
abstract DoGetLatestVersion :
        session : FileSystemSession -> IFileSystemVersion
override DoGetLatestVersion :
        session : FileSystemSession -> IFileSystemVersion

Parameters

session
Type: NFX.IO.FileSystem FileSystemSession

Return Value

Type: IFileSystemVersion
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoGetLatestVersionAsync Method

FileSystem DoGetLatestVersionAsync Method NFX Class Library

Async version of DoGetLatestVersion(FileSystemSession). This base/default implementation just synchronously calls DoGetLatestVersion(FileSystemSession) and returns already completed Task with result returned by DoGetLatestVersion(FileSystemSession)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task<IFileSystemVersion> DoGetLatestVersionAsync(
    FileSystemSession session
)
protected internal virtual Task<IFileSystemVersion> DoGetLatestVersionAsync(
    FileSystemSession session
)
Protected Friend Overridable Function DoGetLatestVersionAsync (
    session As FileSystemSession
) As Task(Of IFileSystemVersion)
Protected Friend Overridable Function DoGetLatestVersionAsync (
    session As FileSystemSession
) As Task(Of IFileSystemVersion)
protected public:
virtual Task<IFileSystemVersion^>^ DoGetLatestVersionAsync(
    FileSystemSession^ session
)
protected public:
virtual Task<IFileSystemVersion^>^ DoGetLatestVersionAsync(
    FileSystemSession^ session
)
abstract DoGetLatestVersionAsync :
        session : FileSystemSession -> Task<IFileSystemVersion>
override DoGetLatestVersionAsync :
        session : FileSystemSession -> Task<IFileSystemVersion>
abstract DoGetLatestVersionAsync :
        session : FileSystemSession -> Task<IFileSystemVersion>
override DoGetLatestVersionAsync :
        session : FileSystemSession -> Task<IFileSystemVersion>

Parameters

session
Type: NFX.IO.FileSystem FileSystemSession

Return Value

Type: Online Task IFileSystemVersion
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoGetMetadataStream Method

FileSystem DoGetMetadataStream Method NFX Class Library

Override to get metadata stream for item (directory or file). This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract FileSystemStream DoGetMetadataStream(
    FileSystemSessionItem item,
    Action<FileSystemStream> disposeAction
)
protected internal abstract FileSystemStream DoGetMetadataStream(
    FileSystemSessionItem item,
    Action<FileSystemStream> disposeAction
)
Protected Friend MustOverride Function DoGetMetadataStream (
    item As FileSystemSessionItem,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
Protected Friend MustOverride Function DoGetMetadataStream (
    item As FileSystemSessionItem,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
protected public:
virtual FileSystemStream^ DoGetMetadataStream(
    FileSystemSessionItem^ item,
    Action<FileSystemStream^>^ disposeAction
) abstract
protected public:
virtual FileSystemStream^ DoGetMetadataStream(
    FileSystemSessionItem^ item,
    Action<FileSystemStream^>^ disposeAction
) abstract
abstract DoGetMetadataStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
abstract DoGetMetadataStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
disposeAction
Type: Online System Action FileSystemStream

Return Value

Type: FileSystemStream
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoGetMetadataStreamAsync Method

FileSystem DoGetMetadataStreamAsync Method NFX Class Library

Async version of DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ) and returns already completed Task with result returned by DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream )

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task<FileSystemStream> DoGetMetadataStreamAsync(
    FileSystemSessionItem item,
    Action<FileSystemStream> disposeAction
)
protected internal virtual Task<FileSystemStream> DoGetMetadataStreamAsync(
    FileSystemSessionItem item,
    Action<FileSystemStream> disposeAction
)
Protected Friend Overridable Function DoGetMetadataStreamAsync (
    item As FileSystemSessionItem,
    disposeAction As Action(Of FileSystemStream)
) As Task(Of FileSystemStream)
Protected Friend Overridable Function DoGetMetadataStreamAsync (
    item As FileSystemSessionItem,
    disposeAction As Action(Of FileSystemStream)
) As Task(Of FileSystemStream)
protected public:
virtual Task<FileSystemStream^>^ DoGetMetadataStreamAsync(
    FileSystemSessionItem^ item,
    Action<FileSystemStream^>^ disposeAction
)
protected public:
virtual Task<FileSystemStream^>^ DoGetMetadataStreamAsync(
    FileSystemSessionItem^ item,
    Action<FileSystemStream^>^ disposeAction
)
abstract DoGetMetadataStreamAsync :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> Task<FileSystemStream>
override DoGetMetadataStreamAsync :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> Task<FileSystemStream>
abstract DoGetMetadataStreamAsync :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> Task<FileSystemStream>
override DoGetMetadataStreamAsync :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> Task<FileSystemStream>

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
disposeAction
Type: Online System Action FileSystemStream

Return Value

Type: Online Task FileSystemStream
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoGetModificationTimestamp Method

FileSystem DoGetModificationTimestamp Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to get item modification timestamp. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract Nullable<DateTime> DoGetModificationTimestamp(
    FileSystemSessionItem item
)
protected internal abstract Nullable<DateTime> DoGetModificationTimestamp(
    FileSystemSessionItem item
)
Protected Friend MustOverride Function DoGetModificationTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
Protected Friend MustOverride Function DoGetModificationTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
protected public:
virtual Nullable<DateTime> DoGetModificationTimestamp(
    FileSystemSessionItem^ item
) abstract
protected public:
virtual Nullable<DateTime> DoGetModificationTimestamp(
    FileSystemSessionItem^ item
) abstract
abstract DoGetModificationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
abstract DoGetModificationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online Nullable Online DateTime
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoGetModificationUser Method

FileSystem DoGetModificationUser Method NFX Class Library

Override in particular file systems to get user who was the last user modifying the item. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual User DoGetModificationUser(
    FileSystemSessionItem item
)
protected internal virtual User DoGetModificationUser(
    FileSystemSessionItem item
)
Protected Friend Overridable Function DoGetModificationUser (
    item As FileSystemSessionItem
) As User
Protected Friend Overridable Function DoGetModificationUser (
    item As FileSystemSessionItem
) As User
protected public:
virtual User^ DoGetModificationUser(
    FileSystemSessionItem^ item
)
protected public:
virtual User^ DoGetModificationUser(
    FileSystemSessionItem^ item
)
abstract DoGetModificationUser :
        item : FileSystemSessionItem -> User
override DoGetModificationUser :
        item : FileSystemSessionItem -> User
abstract DoGetModificationUser :
        item : FileSystemSessionItem -> User
override DoGetModificationUser :
        item : FileSystemSessionItem -> User

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: User
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoGetModificationUserAsync Method

FileSystem DoGetModificationUserAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of DoGetModificationUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetModificationUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetModificationUser(FileSystemSessionItem)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task<User> DoGetModificationUserAsync(
    FileSystemSessionItem item
)
protected internal virtual Task<User> DoGetModificationUserAsync(
    FileSystemSessionItem item
)
Protected Friend Overridable Function DoGetModificationUserAsync (
    item As FileSystemSessionItem
) As Task(Of User)
Protected Friend Overridable Function DoGetModificationUserAsync (
    item As FileSystemSessionItem
) As Task(Of User)
protected public:
virtual Task<User^>^ DoGetModificationUserAsync(
    FileSystemSessionItem^ item
)
protected public:
virtual Task<User^>^ DoGetModificationUserAsync(
    FileSystemSessionItem^ item
)
abstract DoGetModificationUserAsync :
        item : FileSystemSessionItem -> Task<User>
override DoGetModificationUserAsync :
        item : FileSystemSessionItem -> Task<User>
abstract DoGetModificationUserAsync :
        item : FileSystemSessionItem -> Task<User>
override DoGetModificationUserAsync :
        item : FileSystemSessionItem -> Task<User>

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online Task User
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoGetPermissionsStream Method

FileSystem DoGetPermissionsStream Method NFX Class Library

Override to get permissions stream for item (directory or file). This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract FileSystemStream DoGetPermissionsStream(
    FileSystemSessionItem item,
    Action<FileSystemStream> disposeAction
)
protected internal abstract FileSystemStream DoGetPermissionsStream(
    FileSystemSessionItem item,
    Action<FileSystemStream> disposeAction
)
Protected Friend MustOverride Function DoGetPermissionsStream (
    item As FileSystemSessionItem,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
Protected Friend MustOverride Function DoGetPermissionsStream (
    item As FileSystemSessionItem,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
protected public:
virtual FileSystemStream^ DoGetPermissionsStream(
    FileSystemSessionItem^ item,
    Action<FileSystemStream^>^ disposeAction
) abstract
protected public:
virtual FileSystemStream^ DoGetPermissionsStream(
    FileSystemSessionItem^ item,
    Action<FileSystemStream^>^ disposeAction
) abstract
abstract DoGetPermissionsStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
abstract DoGetPermissionsStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
disposeAction
Type: Online System Action FileSystemStream

Return Value

Type: FileSystemStream
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoGetPermissionsStreamAsync Method

FileSystem DoGetPermissionsStreamAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ) and returns already completed Task with result returned by DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream )

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task<FileSystemStream> DoGetPermissionsStreamAsync(
    FileSystemSessionItem item,
    Action<FileSystemStream> disposeAction
)
protected internal virtual Task<FileSystemStream> DoGetPermissionsStreamAsync(
    FileSystemSessionItem item,
    Action<FileSystemStream> disposeAction
)
Protected Friend Overridable Function DoGetPermissionsStreamAsync (
    item As FileSystemSessionItem,
    disposeAction As Action(Of FileSystemStream)
) As Task(Of FileSystemStream)
Protected Friend Overridable Function DoGetPermissionsStreamAsync (
    item As FileSystemSessionItem,
    disposeAction As Action(Of FileSystemStream)
) As Task(Of FileSystemStream)
protected public:
virtual Task<FileSystemStream^>^ DoGetPermissionsStreamAsync(
    FileSystemSessionItem^ item,
    Action<FileSystemStream^>^ disposeAction
)
protected public:
virtual Task<FileSystemStream^>^ DoGetPermissionsStreamAsync(
    FileSystemSessionItem^ item,
    Action<FileSystemStream^>^ disposeAction
)
abstract DoGetPermissionsStreamAsync :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> Task<FileSystemStream>
override DoGetPermissionsStreamAsync :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> Task<FileSystemStream>
abstract DoGetPermissionsStreamAsync :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> Task<FileSystemStream>
override DoGetPermissionsStreamAsync :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> Task<FileSystemStream>

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
disposeAction
Type: Online System Action FileSystemStream

Return Value

Type: Online Task FileSystemStream
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoGetReadOnly Method

FileSystem DoGetReadOnly Method NFX Class Library

Override to get item readonly status. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract bool DoGetReadOnly(
    FileSystemSessionItem item
)
protected internal abstract bool DoGetReadOnly(
    FileSystemSessionItem item
)
Protected Friend MustOverride Function DoGetReadOnly (
    item As FileSystemSessionItem
) As Boolean
Protected Friend MustOverride Function DoGetReadOnly (
    item As FileSystemSessionItem
) As Boolean
protected public:
virtual bool DoGetReadOnly(
    FileSystemSessionItem^ item
) abstract
protected public:
virtual bool DoGetReadOnly(
    FileSystemSessionItem^ item
) abstract
abstract DoGetReadOnly :
        item : FileSystemSessionItem -> bool
abstract DoGetReadOnly :
        item : FileSystemSessionItem -> bool

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online Boolean
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoGetSubDirectoryNames Method

FileSystem DoGetSubDirectoryNames Method NFX Class Library

Override to get subdirectory names of directory. If directory is null then root is assumed. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract IEnumerable<string> DoGetSubDirectoryNames(
    FileSystemDirectory directory,
    bool recursive
)
protected internal abstract IEnumerable<string> DoGetSubDirectoryNames(
    FileSystemDirectory directory,
    bool recursive
)
Protected Friend MustOverride Function DoGetSubDirectoryNames (
    directory As FileSystemDirectory,
    recursive As Boolean
) As IEnumerable(Of String)
Protected Friend MustOverride Function DoGetSubDirectoryNames (
    directory As FileSystemDirectory,
    recursive As Boolean
) As IEnumerable(Of String)
protected public:
virtual IEnumerable<String^>^ DoGetSubDirectoryNames(
    FileSystemDirectory^ directory,
    bool recursive
) abstract
protected public:
virtual IEnumerable<String^>^ DoGetSubDirectoryNames(
    FileSystemDirectory^ directory,
    bool recursive
) abstract
abstract DoGetSubDirectoryNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>
abstract DoGetSubDirectoryNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>

Parameters

directory
Type: NFX.IO.FileSystem FileSystemDirectory
recursive
Type: Online System Boolean

Return Value

Type: Online IEnumerable Online String
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoGetSubDirectoryNamesAsync Method

FileSystem DoGetSubDirectoryNamesAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of DoGetSubDirectoryNames(FileSystemDirectory, Boolean). This base/default implementation just synchronously calls DoGetSubDirectoryNames(FileSystemDirectory, Boolean) and returns already completed Task with result returned by DoGetSubDirectoryNames(FileSystemDirectory, Boolean)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task<IEnumerable<string>> DoGetSubDirectoryNamesAsync(
    FileSystemDirectory directory,
    bool recursive
)
protected internal virtual Task<IEnumerable<string>> DoGetSubDirectoryNamesAsync(
    FileSystemDirectory directory,
    bool recursive
)
Protected Friend Overridable Function DoGetSubDirectoryNamesAsync (
    directory As FileSystemDirectory,
    recursive As Boolean
) As Task(Of IEnumerable(Of String))
Protected Friend Overridable Function DoGetSubDirectoryNamesAsync (
    directory As FileSystemDirectory,
    recursive As Boolean
) As Task(Of IEnumerable(Of String))
protected public:
virtual Task<IEnumerable<String^>^>^ DoGetSubDirectoryNamesAsync(
    FileSystemDirectory^ directory,
    bool recursive
)
protected public:
virtual Task<IEnumerable<String^>^>^ DoGetSubDirectoryNamesAsync(
    FileSystemDirectory^ directory,
    bool recursive
)
abstract DoGetSubDirectoryNamesAsync :
        directory : FileSystemDirectory *
        recursive : bool -> Task<IEnumerable<string>>
override DoGetSubDirectoryNamesAsync :
        directory : FileSystemDirectory *
        recursive : bool -> Task<IEnumerable<string>>
abstract DoGetSubDirectoryNamesAsync :
        directory : FileSystemDirectory *
        recursive : bool -> Task<IEnumerable<string>>
override DoGetSubDirectoryNamesAsync :
        directory : FileSystemDirectory *
        recursive : bool -> Task<IEnumerable<string>>

Parameters

directory
Type: NFX.IO.FileSystem FileSystemDirectory
recursive
Type: Online System Boolean

Return Value

Type: Online Task Online IEnumerable Online String
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoGetVersion Method

FileSystem DoGetVersion Method NFX Class Library

Override in particular file systems that support versioning to get version object for session. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual IFileSystemVersion DoGetVersion(
    FileSystemSession session
)
protected internal virtual IFileSystemVersion DoGetVersion(
    FileSystemSession session
)
Protected Friend Overridable Function DoGetVersion (
    session As FileSystemSession
) As IFileSystemVersion
Protected Friend Overridable Function DoGetVersion (
    session As FileSystemSession
) As IFileSystemVersion
protected public:
virtual IFileSystemVersion^ DoGetVersion(
    FileSystemSession^ session
)
protected public:
virtual IFileSystemVersion^ DoGetVersion(
    FileSystemSession^ session
)
abstract DoGetVersion :
        session : FileSystemSession -> IFileSystemVersion
override DoGetVersion :
        session : FileSystemSession -> IFileSystemVersion
abstract DoGetVersion :
        session : FileSystemSession -> IFileSystemVersion
override DoGetVersion :
        session : FileSystemSession -> IFileSystemVersion

Parameters

session
Type: NFX.IO.FileSystem FileSystemSession

Return Value

Type: IFileSystemVersion
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoGetVersionAsync Method

FileSystem DoGetVersionAsync Method NFX Class Library

Async version of DoGetVersion(FileSystemSession). This base/default implementation just synchronously calls DoGetVersion(FileSystemSession) and returns already completed Task with result returned by DoGetVersion(FileSystemSession)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task<IFileSystemVersion> DoGetVersionAsync(
    FileSystemSession session
)
protected internal virtual Task<IFileSystemVersion> DoGetVersionAsync(
    FileSystemSession session
)
Protected Friend Overridable Function DoGetVersionAsync (
    session As FileSystemSession
) As Task(Of IFileSystemVersion)
Protected Friend Overridable Function DoGetVersionAsync (
    session As FileSystemSession
) As Task(Of IFileSystemVersion)
protected public:
virtual Task<IFileSystemVersion^>^ DoGetVersionAsync(
    FileSystemSession^ session
)
protected public:
virtual Task<IFileSystemVersion^>^ DoGetVersionAsync(
    FileSystemSession^ session
)
abstract DoGetVersionAsync :
        session : FileSystemSession -> Task<IFileSystemVersion>
override DoGetVersionAsync :
        session : FileSystemSession -> Task<IFileSystemVersion>
abstract DoGetVersionAsync :
        session : FileSystemSession -> Task<IFileSystemVersion>
override DoGetVersionAsync :
        session : FileSystemSession -> Task<IFileSystemVersion>

Parameters

session
Type: NFX.IO.FileSystem FileSystemSession

Return Value

Type: Online Task IFileSystemVersion
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoNavigate Method

FileSystem DoNavigate Method NFX Class Library

Override to get file or directory from specified path. Return null if item does not exist. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract FileSystemSessionItem DoNavigate(
    FileSystemSession session,
    string path
)
protected internal abstract FileSystemSessionItem DoNavigate(
    FileSystemSession session,
    string path
)
Protected Friend MustOverride Function DoNavigate (
    session As FileSystemSession,
    path As String
) As FileSystemSessionItem
Protected Friend MustOverride Function DoNavigate (
    session As FileSystemSession,
    path As String
) As FileSystemSessionItem
protected public:
virtual FileSystemSessionItem^ DoNavigate(
    FileSystemSession^ session,
    String^ path
) abstract
protected public:
virtual FileSystemSessionItem^ DoNavigate(
    FileSystemSession^ session,
    String^ path
) abstract
abstract DoNavigate :
        session : FileSystemSession *
        path : string -> FileSystemSessionItem
abstract DoNavigate :
        session : FileSystemSession *
        path : string -> FileSystemSessionItem

Parameters

session
Type: NFX.IO.FileSystem FileSystemSession
path
Type: Online System String

Return Value

Type: FileSystemSessionItem
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoNavigateAsync Method

FileSystem DoNavigateAsync Method NFX Class Library

Async version of DoNavigate(FileSystemSession, String). This base/default implementation just synchronously calls DoNavigate(FileSystemSession, String) and returns already completed Task with result returned by DoNavigate(FileSystemSession, String)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task<FileSystemSessionItem> DoNavigateAsync(
    FileSystemSession session,
    string path
)
protected internal virtual Task<FileSystemSessionItem> DoNavigateAsync(
    FileSystemSession session,
    string path
)
Protected Friend Overridable Function DoNavigateAsync (
    session As FileSystemSession,
    path As String
) As Task(Of FileSystemSessionItem)
Protected Friend Overridable Function DoNavigateAsync (
    session As FileSystemSession,
    path As String
) As Task(Of FileSystemSessionItem)
protected public:
virtual Task<FileSystemSessionItem^>^ DoNavigateAsync(
    FileSystemSession^ session,
    String^ path
)
protected public:
virtual Task<FileSystemSessionItem^>^ DoNavigateAsync(
    FileSystemSession^ session,
    String^ path
)
abstract DoNavigateAsync :
        session : FileSystemSession *
        path : string -> Task<FileSystemSessionItem>
override DoNavigateAsync :
        session : FileSystemSession *
        path : string -> Task<FileSystemSessionItem>
abstract DoNavigateAsync :
        session : FileSystemSession *
        path : string -> Task<FileSystemSessionItem>
override DoNavigateAsync :
        session : FileSystemSession *
        path : string -> Task<FileSystemSessionItem>

Parameters

session
Type: NFX.IO.FileSystem FileSystemSession
path
Type: Online System String

Return Value

Type: Online Task FileSystemSessionItem
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoReadAsync Method

FileSystem DoReadAsync Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task<int> DoReadAsync(
    FileSystemStream stream,
    byte[] buffer,
    int offset,
    int count,
    CancellationToken ct
)
protected internal virtual Task<int> DoReadAsync(
    FileSystemStream stream,
    byte[] buffer,
    int offset,
    int count,
    CancellationToken ct
)
Protected Friend Overridable Function DoReadAsync (
    stream As FileSystemStream,
    buffer As Byte(),
    offset As Integer,
    count As Integer,
    ct As CancellationToken
) As Task(Of Integer)
Protected Friend Overridable Function DoReadAsync (
    stream As FileSystemStream,
    buffer As Byte(),
    offset As Integer,
    count As Integer,
    ct As CancellationToken
) As Task(Of Integer)
protected public:
virtual Task<int>^ DoReadAsync(
    FileSystemStream^ stream,
    array<unsigned char>^ buffer,
    int offset,
    int count,
    CancellationToken ct
)
protected public:
virtual Task<int>^ DoReadAsync(
    FileSystemStream^ stream,
    array<unsigned char>^ buffer,
    int offset,
    int count,
    CancellationToken ct
)
abstract DoReadAsync :
        stream : FileSystemStream *
        buffer : byte[] *
        offset : int *
        count : int *
        ct : CancellationToken -> Task<int>
override DoReadAsync :
        stream : FileSystemStream *
        buffer : byte[] *
        offset : int *
        count : int *
        ct : CancellationToken -> Task<int>
abstract DoReadAsync :
        stream : FileSystemStream *
        buffer : byte[] *
        offset : int *
        count : int *
        ct : CancellationToken -> Task<int>
override DoReadAsync :
        stream : FileSystemStream *
        buffer : byte[] *
        offset : int *
        count : int *
        ct : CancellationToken -> Task<int>

Parameters

stream
Type: NFX.IO.FileSystem FileSystemStream
buffer
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32
ct
Type: Online System.Threading CancellationToken

Return Value

Type: Online Task Online Int32
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoRefresh Method

FileSystem DoRefresh Method NFX Class Library

Override to refresh item state, i.e. re-fetch remote information. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual void DoRefresh(
    FileSystemSessionItem item
)
protected internal virtual void DoRefresh(
    FileSystemSessionItem item
)
Protected Friend Overridable Sub DoRefresh (
    item As FileSystemSessionItem
)
Protected Friend Overridable Sub DoRefresh (
    item As FileSystemSessionItem
)
protected public:
virtual void DoRefresh(
    FileSystemSessionItem^ item
)
protected public:
virtual void DoRefresh(
    FileSystemSessionItem^ item
)
abstract DoRefresh :
        item : FileSystemSessionItem -> unit
override DoRefresh :
        item : FileSystemSessionItem -> unit
abstract DoRefresh :
        item : FileSystemSessionItem -> unit
override DoRefresh :
        item : FileSystemSessionItem -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoRefreshAsync Method

FileSystem DoRefreshAsync Method NFX Class Library

Async version of DoRefreshAsync(FileSystemSessionItem). This base/default implementation just synchronously calls DoRefreshAsync(FileSystemSessionItem) and returns already completed Task with result returned by DoRefreshAsync(FileSystemSessionItem)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task DoRefreshAsync(
    FileSystemSessionItem item
)
protected internal virtual Task DoRefreshAsync(
    FileSystemSessionItem item
)
Protected Friend Overridable Function DoRefreshAsync (
    item As FileSystemSessionItem
) As Task
Protected Friend Overridable Function DoRefreshAsync (
    item As FileSystemSessionItem
) As Task
protected public:
virtual Task^ DoRefreshAsync(
    FileSystemSessionItem^ item
)
protected public:
virtual Task^ DoRefreshAsync(
    FileSystemSessionItem^ item
)
abstract DoRefreshAsync :
        item : FileSystemSessionItem -> Task
override DoRefreshAsync :
        item : FileSystemSessionItem -> Task
abstract DoRefreshAsync :
        item : FileSystemSessionItem -> Task
override DoRefreshAsync :
        item : FileSystemSessionItem -> Task

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online Task
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoRenameItem Method

FileSystem DoRenameItem Method NFX Class Library

Override to rename item return true on success. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract bool DoRenameItem(
    FileSystemSessionItem item,
    string newName
)
protected internal abstract bool DoRenameItem(
    FileSystemSessionItem item,
    string newName
)
Protected Friend MustOverride Function DoRenameItem (
    item As FileSystemSessionItem,
    newName As String
) As Boolean
Protected Friend MustOverride Function DoRenameItem (
    item As FileSystemSessionItem,
    newName As String
) As Boolean
protected public:
virtual bool DoRenameItem(
    FileSystemSessionItem^ item,
    String^ newName
) abstract
protected public:
virtual bool DoRenameItem(
    FileSystemSessionItem^ item,
    String^ newName
) abstract
abstract DoRenameItem :
        item : FileSystemSessionItem *
        newName : string -> bool
abstract DoRenameItem :
        item : FileSystemSessionItem *
        newName : string -> bool

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
newName
Type: Online System String

Return Value

Type: Online Boolean
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoRenameItemAsync Method

FileSystem DoRenameItemAsync Method NFX Class Library

Async version of DoRenameItem(FileSystemSessionItem, String). This base/default implementation just synchronously calls DoRenameItem(FileSystemSessionItem, String) and returns already completed Task with result returned by DoRenameItem(FileSystemSessionItem, String)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task<bool> DoRenameItemAsync(
    FileSystemSessionItem item,
    string newName
)
protected internal virtual Task<bool> DoRenameItemAsync(
    FileSystemSessionItem item,
    string newName
)
Protected Friend Overridable Function DoRenameItemAsync (
    item As FileSystemSessionItem,
    newName As String
) As Task(Of Boolean)
Protected Friend Overridable Function DoRenameItemAsync (
    item As FileSystemSessionItem,
    newName As String
) As Task(Of Boolean)
protected public:
virtual Task<bool>^ DoRenameItemAsync(
    FileSystemSessionItem^ item,
    String^ newName
)
protected public:
virtual Task<bool>^ DoRenameItemAsync(
    FileSystemSessionItem^ item,
    String^ newName
)
abstract DoRenameItemAsync :
        item : FileSystemSessionItem *
        newName : string -> Task<bool>
override DoRenameItemAsync :
        item : FileSystemSessionItem *
        newName : string -> Task<bool>
abstract DoRenameItemAsync :
        item : FileSystemSessionItem *
        newName : string -> Task<bool>
override DoRenameItemAsync :
        item : FileSystemSessionItem *
        newName : string -> Task<bool>

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
newName
Type: Online System String

Return Value

Type: Online Task Online Boolean
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoRollbackTransaction Method

FileSystem DoRollbackTransaction Method NFX Class Library

Override in particular file systems that support transactions to rollback transaction in specified session. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual void DoRollbackTransaction(
    FileSystemSession session
)
protected internal virtual void DoRollbackTransaction(
    FileSystemSession session
)
Protected Friend Overridable Sub DoRollbackTransaction (
    session As FileSystemSession
)
Protected Friend Overridable Sub DoRollbackTransaction (
    session As FileSystemSession
)
protected public:
virtual void DoRollbackTransaction(
    FileSystemSession^ session
)
protected public:
virtual void DoRollbackTransaction(
    FileSystemSession^ session
)
abstract DoRollbackTransaction :
        session : FileSystemSession -> unit
override DoRollbackTransaction :
        session : FileSystemSession -> unit
abstract DoRollbackTransaction :
        session : FileSystemSession -> unit
override DoRollbackTransaction :
        session : FileSystemSession -> unit

Parameters

session
Type: NFX.IO.FileSystem FileSystemSession
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoRollbackTransactionAsync Method

FileSystem DoRollbackTransactionAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of DoRollbackTransaction(FileSystemSession). This base/default implementation just synchronously calls DoRollbackTransaction(FileSystemSession) and returns already completed Task with result returned by DoRollbackTransaction(FileSystemSession)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task DoRollbackTransactionAsync(
    FileSystemSession session
)
protected internal virtual Task DoRollbackTransactionAsync(
    FileSystemSession session
)
Protected Friend Overridable Function DoRollbackTransactionAsync (
    session As FileSystemSession
) As Task
Protected Friend Overridable Function DoRollbackTransactionAsync (
    session As FileSystemSession
) As Task
protected public:
virtual Task^ DoRollbackTransactionAsync(
    FileSystemSession^ session
)
protected public:
virtual Task^ DoRollbackTransactionAsync(
    FileSystemSession^ session
)
abstract DoRollbackTransactionAsync :
        session : FileSystemSession -> Task
override DoRollbackTransactionAsync :
        session : FileSystemSession -> Task
abstract DoRollbackTransactionAsync :
        session : FileSystemSession -> Task
override DoRollbackTransactionAsync :
        session : FileSystemSession -> Task

Parameters

session
Type: NFX.IO.FileSystem FileSystemSession

Return Value

Type: Online Task
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoSetCreationTimestamp Method

FileSystem DoSetCreationTimestamp Method NFX Class Library

Override to set item creation timestamp. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract void DoSetCreationTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
protected internal abstract void DoSetCreationTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
Protected Friend MustOverride Sub DoSetCreationTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
Protected Friend MustOverride Sub DoSetCreationTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
protected public:
virtual void DoSetCreationTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) abstract
protected public:
virtual void DoSetCreationTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) abstract
abstract DoSetCreationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
abstract DoSetCreationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
timestamp
Type: Online System DateTime
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoSetCreationTimestampAsync Method

FileSystem DoSetCreationTimestampAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of DoSetCreationTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetCreationTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetCreationTimestamp(FileSystemSessionItem, DateTime)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task DoSetCreationTimestampAsync(
    FileSystemSessionItem item,
    DateTime timestamp
)
protected internal virtual Task DoSetCreationTimestampAsync(
    FileSystemSessionItem item,
    DateTime timestamp
)
Protected Friend Overridable Function DoSetCreationTimestampAsync (
    item As FileSystemSessionItem,
    timestamp As DateTime
) As Task
Protected Friend Overridable Function DoSetCreationTimestampAsync (
    item As FileSystemSessionItem,
    timestamp As DateTime
) As Task
protected public:
virtual Task^ DoSetCreationTimestampAsync(
    FileSystemSessionItem^ item,
    DateTime timestamp
)
protected public:
virtual Task^ DoSetCreationTimestampAsync(
    FileSystemSessionItem^ item,
    DateTime timestamp
)
abstract DoSetCreationTimestampAsync :
        item : FileSystemSessionItem *
        timestamp : DateTime -> Task
override DoSetCreationTimestampAsync :
        item : FileSystemSessionItem *
        timestamp : DateTime -> Task
abstract DoSetCreationTimestampAsync :
        item : FileSystemSessionItem *
        timestamp : DateTime -> Task
override DoSetCreationTimestampAsync :
        item : FileSystemSessionItem *
        timestamp : DateTime -> Task

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
timestamp
Type: Online System DateTime

Return Value

Type: Online Task
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoSetLastAccessTimestamp Method

FileSystem DoSetLastAccessTimestamp Method NFX Class Library

Override to set item last access timestamp. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract void DoSetLastAccessTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
protected internal abstract void DoSetLastAccessTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
Protected Friend MustOverride Sub DoSetLastAccessTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
Protected Friend MustOverride Sub DoSetLastAccessTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
protected public:
virtual void DoSetLastAccessTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) abstract
protected public:
virtual void DoSetLastAccessTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) abstract
abstract DoSetLastAccessTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
abstract DoSetLastAccessTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
timestamp
Type: Online System DateTime
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoSetLastAccessTimestampAsync Method

FileSystem DoSetLastAccessTimestampAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task DoSetLastAccessTimestampAsync(
    FileSystemSessionItem item,
    DateTime timestamp
)
protected internal virtual Task DoSetLastAccessTimestampAsync(
    FileSystemSessionItem item,
    DateTime timestamp
)
Protected Friend Overridable Function DoSetLastAccessTimestampAsync (
    item As FileSystemSessionItem,
    timestamp As DateTime
) As Task
Protected Friend Overridable Function DoSetLastAccessTimestampAsync (
    item As FileSystemSessionItem,
    timestamp As DateTime
) As Task
protected public:
virtual Task^ DoSetLastAccessTimestampAsync(
    FileSystemSessionItem^ item,
    DateTime timestamp
)
protected public:
virtual Task^ DoSetLastAccessTimestampAsync(
    FileSystemSessionItem^ item,
    DateTime timestamp
)
abstract DoSetLastAccessTimestampAsync :
        item : FileSystemSessionItem *
        timestamp : DateTime -> Task
override DoSetLastAccessTimestampAsync :
        item : FileSystemSessionItem *
        timestamp : DateTime -> Task
abstract DoSetLastAccessTimestampAsync :
        item : FileSystemSessionItem *
        timestamp : DateTime -> Task
override DoSetLastAccessTimestampAsync :
        item : FileSystemSessionItem *
        timestamp : DateTime -> Task

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
timestamp
Type: Online System DateTime

Return Value

Type: Online Task
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoSetModificationTimestamp Method

FileSystem DoSetModificationTimestamp Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to set item modification timestamp. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract void DoSetModificationTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
protected internal abstract void DoSetModificationTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
Protected Friend MustOverride Sub DoSetModificationTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
Protected Friend MustOverride Sub DoSetModificationTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
protected public:
virtual void DoSetModificationTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) abstract
protected public:
virtual void DoSetModificationTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) abstract
abstract DoSetModificationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
abstract DoSetModificationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
timestamp
Type: Online System DateTime
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoSetModificationTimestampAsync Method

FileSystem DoSetModificationTimestampAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of DoSetModificationTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetModificationTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetModificationTimestamp(FileSystemSessionItem, DateTime)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task DoSetModificationTimestampAsync(
    FileSystemSessionItem item,
    DateTime timestamp
)
protected internal virtual Task DoSetModificationTimestampAsync(
    FileSystemSessionItem item,
    DateTime timestamp
)
Protected Friend Overridable Function DoSetModificationTimestampAsync (
    item As FileSystemSessionItem,
    timestamp As DateTime
) As Task
Protected Friend Overridable Function DoSetModificationTimestampAsync (
    item As FileSystemSessionItem,
    timestamp As DateTime
) As Task
protected public:
virtual Task^ DoSetModificationTimestampAsync(
    FileSystemSessionItem^ item,
    DateTime timestamp
)
protected public:
virtual Task^ DoSetModificationTimestampAsync(
    FileSystemSessionItem^ item,
    DateTime timestamp
)
abstract DoSetModificationTimestampAsync :
        item : FileSystemSessionItem *
        timestamp : DateTime -> Task
override DoSetModificationTimestampAsync :
        item : FileSystemSessionItem *
        timestamp : DateTime -> Task
abstract DoSetModificationTimestampAsync :
        item : FileSystemSessionItem *
        timestamp : DateTime -> Task
override DoSetModificationTimestampAsync :
        item : FileSystemSessionItem *
        timestamp : DateTime -> Task

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
timestamp
Type: Online System DateTime

Return Value

Type: Online Task
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoSetReadOnly Method

FileSystem DoSetReadOnly Method NFX Class Library

Override to set item readonly status. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract void DoSetReadOnly(
    FileSystemSessionItem item,
    bool readOnly
)
protected internal abstract void DoSetReadOnly(
    FileSystemSessionItem item,
    bool readOnly
)
Protected Friend MustOverride Sub DoSetReadOnly (
    item As FileSystemSessionItem,
    readOnly As Boolean
)
Protected Friend MustOverride Sub DoSetReadOnly (
    item As FileSystemSessionItem,
    readOnly As Boolean
)
protected public:
virtual void DoSetReadOnly(
    FileSystemSessionItem^ item,
    bool readOnly
) abstract
protected public:
virtual void DoSetReadOnly(
    FileSystemSessionItem^ item,
    bool readOnly
) abstract
abstract DoSetReadOnly :
        item : FileSystemSessionItem *
        readOnly : bool -> unit
abstract DoSetReadOnly :
        item : FileSystemSessionItem *
        readOnly : bool -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
readOnly
Type: Online System Boolean
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoSetReadOnlyAsync Method

FileSystem DoSetReadOnlyAsync Method NFX Class Library

Async version of DoSetReadOnly(FileSystemSessionItem, Boolean). This base/default implementation just synchronously calls DoSetReadOnly(FileSystemSessionItem, Boolean) and returns already completed Task with result returned by DoSetReadOnly(FileSystemSessionItem, Boolean)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task DoSetReadOnlyAsync(
    FileSystemSessionItem item,
    bool readOnly
)
protected internal virtual Task DoSetReadOnlyAsync(
    FileSystemSessionItem item,
    bool readOnly
)
Protected Friend Overridable Function DoSetReadOnlyAsync (
    item As FileSystemSessionItem,
    readOnly As Boolean
) As Task
Protected Friend Overridable Function DoSetReadOnlyAsync (
    item As FileSystemSessionItem,
    readOnly As Boolean
) As Task
protected public:
virtual Task^ DoSetReadOnlyAsync(
    FileSystemSessionItem^ item,
    bool readOnly
)
protected public:
virtual Task^ DoSetReadOnlyAsync(
    FileSystemSessionItem^ item,
    bool readOnly
)
abstract DoSetReadOnlyAsync :
        item : FileSystemSessionItem *
        readOnly : bool -> Task
override DoSetReadOnlyAsync :
        item : FileSystemSessionItem *
        readOnly : bool -> Task
abstract DoSetReadOnlyAsync :
        item : FileSystemSessionItem *
        readOnly : bool -> Task
override DoSetReadOnlyAsync :
        item : FileSystemSessionItem *
        readOnly : bool -> Task

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
readOnly
Type: Online System Boolean

Return Value

Type: Online Task
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoSetVersion Method

FileSystem DoSetVersion Method NFX Class Library

Override in particular file systems that support versioning to set seesion to specific version. This method may be called by miltiple threads

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual void DoSetVersion(
    FileSystemSession session,
    IFileSystemVersion version
)
protected internal virtual void DoSetVersion(
    FileSystemSession session,
    IFileSystemVersion version
)
Protected Friend Overridable Sub DoSetVersion (
    session As FileSystemSession,
    version As IFileSystemVersion
)
Protected Friend Overridable Sub DoSetVersion (
    session As FileSystemSession,
    version As IFileSystemVersion
)
protected public:
virtual void DoSetVersion(
    FileSystemSession^ session,
    IFileSystemVersion^ version
)
protected public:
virtual void DoSetVersion(
    FileSystemSession^ session,
    IFileSystemVersion^ version
)
abstract DoSetVersion :
        session : FileSystemSession *
        version : IFileSystemVersion -> unit
override DoSetVersion :
        session : FileSystemSession *
        version : IFileSystemVersion -> unit
abstract DoSetVersion :
        session : FileSystemSession *
        version : IFileSystemVersion -> unit
override DoSetVersion :
        session : FileSystemSession *
        version : IFileSystemVersion -> unit

Parameters

session
Type: NFX.IO.FileSystem FileSystemSession
version
Type: NFX.IO.FileSystem IFileSystemVersion
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoSetVersionAsync Method

FileSystem DoSetVersionAsync Method NFX Class Library

Async version of DoSetVersion(FileSystemSession, IFileSystemVersion). This base/default implementation just synchronously calls DoSetVersion(FileSystemSession, IFileSystemVersion) and returns already completed Task with result returned by DoSetVersion(FileSystemSession, IFileSystemVersion)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task DoSetVersionAsync(
    FileSystemSession session,
    IFileSystemVersion version
)
protected internal virtual Task DoSetVersionAsync(
    FileSystemSession session,
    IFileSystemVersion version
)
Protected Friend Overridable Function DoSetVersionAsync (
    session As FileSystemSession,
    version As IFileSystemVersion
) As Task
Protected Friend Overridable Function DoSetVersionAsync (
    session As FileSystemSession,
    version As IFileSystemVersion
) As Task
protected public:
virtual Task^ DoSetVersionAsync(
    FileSystemSession^ session,
    IFileSystemVersion^ version
)
protected public:
virtual Task^ DoSetVersionAsync(
    FileSystemSession^ session,
    IFileSystemVersion^ version
)
abstract DoSetVersionAsync :
        session : FileSystemSession *
        version : IFileSystemVersion -> Task
override DoSetVersionAsync :
        session : FileSystemSession *
        version : IFileSystemVersion -> Task
abstract DoSetVersionAsync :
        session : FileSystemSession *
        version : IFileSystemVersion -> Task
override DoSetVersionAsync :
        session : FileSystemSession *
        version : IFileSystemVersion -> Task

Parameters

session
Type: NFX.IO.FileSystem FileSystemSession
version
Type: NFX.IO.FileSystem IFileSystemVersion

Return Value

Type: Online Task
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.DoWriteAsync Method

FileSystem DoWriteAsync Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual Task DoWriteAsync(
    FileSystemStream stream,
    byte[] buffer,
    int offset,
    int count,
    CancellationToken ct
)
protected internal virtual Task DoWriteAsync(
    FileSystemStream stream,
    byte[] buffer,
    int offset,
    int count,
    CancellationToken ct
)
Protected Friend Overridable Function DoWriteAsync (
    stream As FileSystemStream,
    buffer As Byte(),
    offset As Integer,
    count As Integer,
    ct As CancellationToken
) As Task
Protected Friend Overridable Function DoWriteAsync (
    stream As FileSystemStream,
    buffer As Byte(),
    offset As Integer,
    count As Integer,
    ct As CancellationToken
) As Task
protected public:
virtual Task^ DoWriteAsync(
    FileSystemStream^ stream,
    array<unsigned char>^ buffer,
    int offset,
    int count,
    CancellationToken ct
)
protected public:
virtual Task^ DoWriteAsync(
    FileSystemStream^ stream,
    array<unsigned char>^ buffer,
    int offset,
    int count,
    CancellationToken ct
)
abstract DoWriteAsync :
        stream : FileSystemStream *
        buffer : byte[] *
        offset : int *
        count : int *
        ct : CancellationToken -> Task
override DoWriteAsync :
        stream : FileSystemStream *
        buffer : byte[] *
        offset : int *
        count : int *
        ct : CancellationToken -> Task
abstract DoWriteAsync :
        stream : FileSystemStream *
        buffer : byte[] *
        offset : int *
        count : int *
        ct : CancellationToken -> Task
override DoWriteAsync :
        stream : FileSystemStream *
        buffer : byte[] *
        offset : int *
        count : int *
        ct : CancellationToken -> Task

Parameters

stream
Type: NFX.IO.FileSystem FileSystemStream
buffer
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32
ct
Type: Online System.Threading CancellationToken

Return Value

Type: Online Task
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.Make Method

FileSystem Make Method NFX Class Library

Overload List
Name | Description
Make TParam (IConfigSectionNode) |
Make TParam (String, String) |
Back to Top
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.Make(TParam) Method (IConfigSectionNode)

FileSystem Make TParam Method (IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TParam Make<TParam>(
    IConfigSectionNode node
)
where TParam : FileSystem
public static TParam Make<TParam>(
    IConfigSectionNode node
)
where TParam : FileSystem
Public Shared Function Make(Of TParam As FileSystem) (
    node As IConfigSectionNode
) As TParam
Public Shared Function Make(Of TParam As FileSystem) (
    node As IConfigSectionNode
) As TParam
public:
generic<typename TParam>
where TParam : FileSystem
static TParam Make(
    IConfigSectionNode^ node
)
public:
generic<typename TParam>
where TParam : FileSystem
static TParam Make(
    IConfigSectionNode^ node
)
static member Make :
        node : IConfigSectionNode -> 'TParam  when 'TParam : FileSystem
static member Make :
        node : IConfigSectionNode -> 'TParam  when 'TParam : FileSystem

Parameters

node
Type: NFX.Environment IConfigSectionNode
Type Parameters
TParam

Return Value

Type: TParam
See Also
FileSystem Class
FileSystem Members
Make Overload
NFX.IO.FileSystem Namespace


FileSystem.Make(TParam) Method (String, String)

FileSystem Make TParam Method (String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TParam Make<TParam>(
    string cfgStr,
    string format = "laconf"
)
where TParam : FileSystem
public static TParam Make<TParam>(
    string cfgStr,
    string format = "laconf"
)
where TParam : FileSystem
Public Shared Function Make(Of TParam As FileSystem) (
    cfgStr As String,
    Optional format As String = "laconf"
) As TParam
Public Shared Function Make(Of TParam As FileSystem) (
    cfgStr As String,
    Optional format As String = "laconf"
) As TParam
public:
generic<typename TParam>
where TParam : FileSystem
static TParam Make(
    String^ cfgStr,
    String^ format = L"laconf"
)
public:
generic<typename TParam>
where TParam : FileSystem
static TParam Make(
    String^ cfgStr,
    String^ format = L"laconf"
)
static member Make :
        cfgStr : string *
        ?format : string
(* Defaults:
        let _format = defaultArg format "laconf"
*)
-> 'TParam  when 'TParam : FileSystem
static member Make :
        cfgStr : string *
        ?format : string
(* Defaults:
        let _format = defaultArg format "laconf"
*)
-> 'TParam  when 'TParam : FileSystem

Parameters

cfgStr
Type: Online System String
format (Optional)
Type: Online System String
Type Parameters
TParam

Return Value

Type: TParam
See Also
FileSystem Class
FileSystem Members
Make Overload
NFX.IO.FileSystem Namespace


FileSystem.MakeSessionConfigParams Method

FileSystem MakeSessionConfigParams Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual FileSystemSessionConnectParams MakeSessionConfigParams(
    IConfigSectionNode node
)
protected virtual FileSystemSessionConnectParams MakeSessionConfigParams(
    IConfigSectionNode node
)
Protected Overridable Function MakeSessionConfigParams (
    node As IConfigSectionNode
) As FileSystemSessionConnectParams
Protected Overridable Function MakeSessionConfigParams (
    node As IConfigSectionNode
) As FileSystemSessionConnectParams
protected:
virtual FileSystemSessionConnectParams^ MakeSessionConfigParams(
    IConfigSectionNode^ node
)
protected:
virtual FileSystemSessionConnectParams^ MakeSessionConfigParams(
    IConfigSectionNode^ node
)
abstract MakeSessionConfigParams :
        node : IConfigSectionNode -> FileSystemSessionConnectParams
override MakeSessionConfigParams :
        node : IConfigSectionNode -> FileSystemSessionConnectParams
abstract MakeSessionConfigParams :
        node : IConfigSectionNode -> FileSystemSessionConnectParams
override MakeSessionConfigParams :
        node : IConfigSectionNode -> FileSystemSessionConnectParams

Parameters

node
Type: NFX.Environment IConfigSectionNode

Return Value

Type: FileSystemSessionConnectParams
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.StartSession Method

FileSystem StartSession Method NFX Class Library

Creates a new session for the user. This method is thread-safe, however the returned FileSystemSession object is not. Every thread must obtain its own session via this method

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract FileSystemSession StartSession(
    FileSystemSessionConnectParams cParams = null
)
public abstract FileSystemSession StartSession(
    FileSystemSessionConnectParams cParams = null
)
Public MustOverride Function StartSession (
    Optional cParams As FileSystemSessionConnectParams = Nothing
) As FileSystemSession
Public MustOverride Function StartSession (
    Optional cParams As FileSystemSessionConnectParams = Nothing
) As FileSystemSession
public:
virtual FileSystemSession^ StartSession(
    FileSystemSessionConnectParams^ cParams = nullptr
) abstract
public:
virtual FileSystemSession^ StartSession(
    FileSystemSessionConnectParams^ cParams = nullptr
) abstract
abstract StartSession :
        ?cParams : FileSystemSessionConnectParams
(* Defaults:
        let _cParams = defaultArg cParams null
*)
-> FileSystemSession
abstract StartSession :
        ?cParams : FileSystemSessionConnectParams
(* Defaults:
        let _cParams = defaultArg cParams null
*)
-> FileSystemSession

Parameters

cParams (Optional)
Type: NFX.IO.FileSystem FileSystemSessionConnectParams

Return Value

Type: FileSystemSession

Implements

IFileSystem StartSession(FileSystemSessionConnectParams)
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.ToString Method

FileSystem ToString Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem Properties

FileSystem Properties NFX Class Library

The FileSystem type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Protected property | DefaultSessionConnectParams |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | GeneralCapabilities | Returns capabilities for this file system in general
Public property | InstanceCapabilities | Returns capabilities for this file system instance, that may or may not be the same as GeneralCapabilities
 | Instances | Returns the read-only registry view of file systems currently activated
Public property | Name | Provides name for file system instance
Public property | Sessions | Returns a list of sessions. This accessor is thread-safe
Back to Top
See Also
FileSystem Class
NFX.IO.FileSystem Namespace


FileSystem.DefaultSessionConnectParams Property

FileSystem DefaultSessionConnectParams Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FileSystemSessionConnectParams DefaultSessionConnectParams { get; }
protected FileSystemSessionConnectParams DefaultSessionConnectParams { get; }
Protected ReadOnly Property DefaultSessionConnectParams As FileSystemSessionConnectParams
    Get
Protected ReadOnly Property DefaultSessionConnectParams As FileSystemSessionConnectParams
    Get
protected:
property FileSystemSessionConnectParams^ DefaultSessionConnectParams {
    FileSystemSessionConnectParams^ get ();
}
protected:
property FileSystemSessionConnectParams^ DefaultSessionConnectParams {
    FileSystemSessionConnectParams^ get ();
}
member DefaultSessionConnectParams : FileSystemSessionConnectParams with get
member DefaultSessionConnectParams : FileSystemSessionConnectParams with get

Property Value

Type: FileSystemSessionConnectParams
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.GeneralCapabilities Property

FileSystem GeneralCapabilities Property NFX Class Library

Returns capabilities for this file system in general

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract IFileSystemCapabilities GeneralCapabilities { get; }
public abstract IFileSystemCapabilities GeneralCapabilities { get; }
Public MustOverride ReadOnly Property GeneralCapabilities As IFileSystemCapabilities
    Get
Public MustOverride ReadOnly Property GeneralCapabilities As IFileSystemCapabilities
    Get
public:
virtual property IFileSystemCapabilities^ GeneralCapabilities {
    IFileSystemCapabilities^ get () abstract;
}
public:
virtual property IFileSystemCapabilities^ GeneralCapabilities {
    IFileSystemCapabilities^ get () abstract;
}
abstract GeneralCapabilities : IFileSystemCapabilities with get
abstract GeneralCapabilities : IFileSystemCapabilities with get

Property Value

Type: IFileSystemCapabilities

Implements

IFileSystem GeneralCapabilities
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.InstanceCapabilities Property

FileSystem InstanceCapabilities Property NFX Class Library

Returns capabilities for this file system instance, that may or may not be the same as GeneralCapabilities

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract IFileSystemCapabilities InstanceCapabilities { get; }
public abstract IFileSystemCapabilities InstanceCapabilities { get; }
Public MustOverride ReadOnly Property InstanceCapabilities As IFileSystemCapabilities
    Get
Public MustOverride ReadOnly Property InstanceCapabilities As IFileSystemCapabilities
    Get
public:
virtual property IFileSystemCapabilities^ InstanceCapabilities {
    IFileSystemCapabilities^ get () abstract;
}
public:
virtual property IFileSystemCapabilities^ InstanceCapabilities {
    IFileSystemCapabilities^ get () abstract;
}
abstract InstanceCapabilities : IFileSystemCapabilities with get
abstract InstanceCapabilities : IFileSystemCapabilities with get

Property Value

Type: IFileSystemCapabilities

Implements

IFileSystem InstanceCapabilities
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.Instances Property

FileSystem Instances Property NFX Class Library

Returns the read-only registry view of file systems currently activated

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IRegistry<FileSystem> Instances { get; }
public static IRegistry<FileSystem> Instances { get; }
Public Shared ReadOnly Property Instances As IRegistry(Of FileSystem)
    Get
Public Shared ReadOnly Property Instances As IRegistry(Of FileSystem)
    Get
public:
static property IRegistry<FileSystem^>^ Instances {
    IRegistry<FileSystem^>^ get ();
}
public:
static property IRegistry<FileSystem^>^ Instances {
    IRegistry<FileSystem^>^ get ();
}
static member Instances : IRegistry<FileSystem> with get
static member Instances : IRegistry<FileSystem> with get

Property Value

Type: IRegistry FileSystem
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.Name Property

FileSystem Name Property NFX Class Library

Provides name for file system instance

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystem.Sessions Property

FileSystem Sessions Property NFX Class Library

Returns a list of sessions. This accessor is thread-safe

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<FileSystemSession> Sessions { get; }
public IEnumerable<FileSystemSession> Sessions { get; }
Public ReadOnly Property Sessions As IEnumerable(Of FileSystemSession)
    Get
Public ReadOnly Property Sessions As IEnumerable(Of FileSystemSession)
    Get
public:
virtual property IEnumerable<FileSystemSession^>^ Sessions {
    IEnumerable<FileSystemSession^>^ get () sealed;
}
public:
virtual property IEnumerable<FileSystemSession^>^ Sessions {
    IEnumerable<FileSystemSession^>^ get () sealed;
}
abstract Sessions : IEnumerable<FileSystemSession> with get
override Sessions : IEnumerable<FileSystemSession> with get
abstract Sessions : IEnumerable<FileSystemSession> with get
override Sessions : IEnumerable<FileSystemSession> with get

Property Value

Type: Online IEnumerable FileSystemSession

Implements

IFileSystem Sessions
See Also
FileSystem Class
FileSystem Members
NFX.IO.FileSystem Namespace


FileSystemDirectory Class

FileSystemDirectory Class NFX Class Library

Represents a directory item in a file system. This class is NOT thread-safe
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.IO.FileSystem FileSystemSessionItem
NFX.IO.FileSystem FileSystemDirectory

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class FileSystemDirectory : FileSystemSessionItem
public sealed class FileSystemDirectory : FileSystemSessionItem
Public NotInheritable Class FileSystemDirectory
    Inherits FileSystemSessionItem
Public NotInheritable Class FileSystemDirectory
    Inherits FileSystemSessionItem
public ref class FileSystemDirectory sealed : public FileSystemSessionItem
public ref class FileSystemDirectory sealed : public FileSystemSessionItem
[<SealedAttribute>]
type FileSystemDirectory =
    class
        inherit FileSystemSessionItem
    end
[<SealedAttribute>]
type FileSystemDirectory =
    class
        inherit FileSystemSessionItem
    end
See Also
FileSystemDirectory Members
NFX.IO.FileSystem Namespace


FileSystemDirectory Members

FileSystemDirectory Members NFX Class Library

The FileSystemDirectory type exposes the following members.
Constructors
 | Name | Description
Public method | FileSystemDirectory | Internal method that should not be called by developers
Back to Top
Methods
 | Name | Description
Public method | CheckCanChange | Throws when item can not change (Inherited from FileSystemSessionItem.)
Public method | CheckCanChangeAsync | Async version of CheckCanChange (Inherited from FileSystemSessionItem.)
Public method | CreateDirectory | Creates a directory in this directory
Public method | CreateDirectoryAsync | Async version of CreateDirectory(String)
Public method | CreateFile(String, Int32) | Creates a new file optionally pre-allocating te specified number of bytes
Public method | CreateFile(String, String, Boolean) | Puts local existing file into file system
Public method | CreateFileAsync(String, Int32) | Async version of CreateFile(String, Int32)
Public method | CreateFileAsync(String, String, Boolean) | Async version of CreateFile(String, String, Boolean)
Public method | DeepCopyTo | Performs a deep copy of this directory into another directory that may belong to a different file system. This method allows to copy directory trees between different file systems i.e. from SVN into AmazonS3 or local file system etc.
Public method | DeepCopyToAsync | Async version of DeepCopyTo(...)
Public method | Delete | Deletes this item from file system (Inherited from FileSystemSessionItem.)
Public method | DeleteAsync | Async version of Delete (Inherited from FileSystemSessionItem.)
Protected method | Destructor | (Inherited from FileSystemSessionItem.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetCreationUserAsync | Async version of [P:CreationUser] (Inherited from FileSystemSessionItem.)
Public method | GetFile | Gets file in this directory or null if it does not exist or not a file
Public method | GetFileAsync | Async version of GetFile(String)
Public method | GetFileNamesAsync | Async version of [P:FileNames]
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetItemAsync | Async version of Item(string)
Public method | GetLastAccessUserAsync | Async version of [P:LastAccessUser] (Inherited from FileSystemSessionItem.)
Public method | GetModificationUserAsync | Async version of [P:ModificationUser] (Inherited from FileSystemSessionItem.)
Public method | GetRecursiveFileNamesAsync | Async version of [P:RecursiveFileNames]
Public method | GetRecursiveSubDirectoryNamesAsync | Async version of [P:RecursiveSubDirectoryNames]
Public method | GetSizeAsync | Async version of [P:Size] (Inherited from FileSystemSessionItem.)
Public method | GetSubDirectory | Gets dubdirectory in this directory or null if it does not exist or not a directory
Public method | GetSubDirectoryAsync | Async version of GetFile(String)
Public method | GetSubDirectoryNamesAsync | Async version of [P:SubDirectoryNames]
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Refresh | Refreshes the state represented by this item, i.e. this may re-read attributes from remote file system (Inherited from FileSystemSessionItem.)
Public method | RefreshAsync | Async version of Refresh (Inherited from FileSystemSessionItem.)
Public method | Rename | Renames an item. Check file system capabilities to see if renaming is supported (Inherited from FileSystemSessionItem.)
Public method | RenameAsync | Async version of Rename(String) (Inherited from FileSystemSessionItem.)
Public method | SetCreationTimestampAsync | Async version of [P:CreationTimestamp] (Inherited from FileSystemSessionItem.)
Public method | SetLastAccessTimestampAsync | Async version of [P:LastAccessTimestamp] (Inherited from FileSystemSessionItem.)
Public method | SetModificationTimestampAsync | Async version of [P:ModificationTimestamp] (Inherited from FileSystemSessionItem.)
Public method | SetReadOnlyAsync | Async version of [P:ReadOnly] (Inherited from FileSystemSessionItem.)
Public method | ToString | (Inherited from FileSystemSessionItem.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | GeneratePackagingManifest | Generates packaging manifest for the specified directory. Optionally may specify root node name (Defined by ManifestUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_FileSystem | (Inherited from FileSystemSessionItem.)
Protected field | m_Handle | (Inherited from FileSystemSessionItem.)
Protected field | m_Modified | (Inherited from FileSystemSessionItem.)
Protected field | m_Session | (Inherited from FileSystemSessionItem.)
Back to Top
Properties
 | Name | Description
Public property | CreationTimestamp | Gets/sets UTC creation timestamp (Inherited from FileSystemSessionItem.)
Public property | CreationUser | Gets the user who created this item (Inherited from FileSystemSessionItem.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | FileNames | Returns file names contained in this directory
Public property | FileSystem | Returns filesystem - this is a shortcut to Session.FileSystem (Inherited from FileSystemSessionItem.)
Public property | Handle | Returns file system handle for this entity (Inherited from FileSystemSessionItem.)
Public property | IsReadOnly | Indicates whether this item can change and file system supports modifications (Inherited from FileSystemSessionItem.)
Public property | Item | Navigates to the specified path relative to this directory
Public property | LastAccessTimestamp | Gets/sets UTC last access timestamp (Inherited from FileSystemSessionItem.)
Public property | LastAccessUser | Gets the last user who accessed the item (Inherited from FileSystemSessionItem.)
Public property | MetadataStream | Returns item metadata stream (Inherited from FileSystemSessionItem.)
Public property | ModificationTimestamp | Gets/sets UTC modification timestamp (Inherited from FileSystemSessionItem.)
Public property | ModificationUser | Gets the user who modified this item (Inherited from FileSystemSessionItem.)
Public property | Modified | Indicates whether anything has changed since last transaction has started (Inherited from FileSystemSessionItem.)
Public property | Name | (Inherited from FileSystemSessionItem.)
Public property | ParentPath | Returns path to directory that contains this item (Inherited from FileSystemSessionItem.)
Public property | Path | Returns an absolute path for this item (Inherited from FileSystemSessionItem.)
Public property | PermissionsStream | Returns item permissions stream (Inherited from FileSystemSessionItem.)
Public property | ReadOnly | Gets/sets readonly attribute (Inherited from FileSystemSessionItem.)
Public property | RecursiveFileNames | Returns file names contained in this directory and all subdirectories
Public property | RecursiveSubDirectoryNames | Returns directory names contained in this directory and all subdirectories
Public property | Session | Returns session through which this object was obtained (Inherited from FileSystemSessionItem.)
Public property | Size | Returns the byte size of the item, depending on implementation this property may return approximate sizes for files and directories (i.e in distributed systems) (Inherited from FileSystemSessionItem.)
Public property | SubDirectoryNames | Returns directory names contained in this directory
Back to Top
See Also
FileSystemDirectory Class
NFX.IO.FileSystem Namespace


FileSystemDirectory Constructor

FileSystemDirectory Constructor NFX Class Library

Internal method that should not be called by developers

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSystemDirectory(
    FileSystemSession session,
    string parentPath,
    string name,
    IFileSystemHandle handle
)
public FileSystemDirectory(
    FileSystemSession session,
    string parentPath,
    string name,
    IFileSystemHandle handle
)
Public Sub New (
    session As FileSystemSession,
    parentPath As String,
    name As String,
    handle As IFileSystemHandle
)
Public Sub New (
    session As FileSystemSession,
    parentPath As String,
    name As String,
    handle As IFileSystemHandle
)
public:
FileSystemDirectory(
    FileSystemSession^ session,
    String^ parentPath,
    String^ name,
    IFileSystemHandle^ handle
)
public:
FileSystemDirectory(
    FileSystemSession^ session,
    String^ parentPath,
    String^ name,
    IFileSystemHandle^ handle
)
new :
        session : FileSystemSession *
        parentPath : string *
        name : string *
        handle : IFileSystemHandle -> FileSystemDirectory
new :
        session : FileSystemSession *
        parentPath : string *
        name : string *
        handle : IFileSystemHandle -> FileSystemDirectory

Parameters

session
Type: NFX.IO.FileSystem FileSystemSession
parentPath
Type: Online System String
name
Type: Online System String
handle
Type: NFX.IO.FileSystem IFileSystemHandle
See Also
FileSystemDirectory Class
FileSystemDirectory Members
NFX.IO.FileSystem Namespace


FileSystemDirectory Fields

FileSystemDirectory Fields NFX Class Library

The FileSystemDirectory type exposes the following members.
Fields
 | Name | Description
Protected field | m_FileSystem | (Inherited from FileSystemSessionItem.)
Protected field | m_Handle | (Inherited from FileSystemSessionItem.)
Protected field | m_Modified | (Inherited from FileSystemSessionItem.)
Protected field | m_Session | (Inherited from FileSystemSessionItem.)
Back to Top
See Also
FileSystemDirectory Class
NFX.IO.FileSystem Namespace


FileSystemDirectory Methods

FileSystemDirectory Methods NFX Class Library

The FileSystemDirectory type exposes the following members.
Methods
 | Name | Description
Public method | CheckCanChange | Throws when item can not change (Inherited from FileSystemSessionItem.)
Public method | CheckCanChangeAsync | Async version of CheckCanChange (Inherited from FileSystemSessionItem.)
Public method | CreateDirectory | Creates a directory in this directory
Public method | CreateDirectoryAsync | Async version of CreateDirectory(String)
Public method | CreateFile(String, Int32) | Creates a new file optionally pre-allocating te specified number of bytes
Public method | CreateFile(String, String, Boolean) | Puts local existing file into file system
Public method | CreateFileAsync(String, Int32) | Async version of CreateFile(String, Int32)
Public method | CreateFileAsync(String, String, Boolean) | Async version of CreateFile(String, String, Boolean)
Public method | DeepCopyTo | Performs a deep copy of this directory into another directory that may belong to a different file system. This method allows to copy directory trees between different file systems i.e. from SVN into AmazonS3 or local file system etc.
Public method | DeepCopyToAsync | Async version of DeepCopyTo(...)
Public method | Delete | Deletes this item from file system (Inherited from FileSystemSessionItem.)
Public method | DeleteAsync | Async version of Delete (Inherited from FileSystemSessionItem.)
Protected method | Destructor | (Inherited from FileSystemSessionItem.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetCreationUserAsync | Async version of [P:CreationUser] (Inherited from FileSystemSessionItem.)
Public method | GetFile | Gets file in this directory or null if it does not exist or not a file
Public method | GetFileAsync | Async version of GetFile(String)
Public method | GetFileNamesAsync | Async version of [P:FileNames]
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetItemAsync | Async version of Item(string)
Public method | GetLastAccessUserAsync | Async version of [P:LastAccessUser] (Inherited from FileSystemSessionItem.)
Public method | GetModificationUserAsync | Async version of [P:ModificationUser] (Inherited from FileSystemSessionItem.)
Public method | GetRecursiveFileNamesAsync | Async version of [P:RecursiveFileNames]
Public method | GetRecursiveSubDirectoryNamesAsync | Async version of [P:RecursiveSubDirectoryNames]
Public method | GetSizeAsync | Async version of [P:Size] (Inherited from FileSystemSessionItem.)
Public method | GetSubDirectory | Gets dubdirectory in this directory or null if it does not exist or not a directory
Public method | GetSubDirectoryAsync | Async version of GetFile(String)
Public method | GetSubDirectoryNamesAsync | Async version of [P:SubDirectoryNames]
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Refresh | Refreshes the state represented by this item, i.e. this may re-read attributes from remote file system (Inherited from FileSystemSessionItem.)
Public method | RefreshAsync | Async version of Refresh (Inherited from FileSystemSessionItem.)
Public method | Rename | Renames an item. Check file system capabilities to see if renaming is supported (Inherited from FileSystemSessionItem.)
Public method | RenameAsync | Async version of Rename(String) (Inherited from FileSystemSessionItem.)
Public method | SetCreationTimestampAsync | Async version of [P:CreationTimestamp] (Inherited from FileSystemSessionItem.)
Public method | SetLastAccessTimestampAsync | Async version of [P:LastAccessTimestamp] (Inherited from FileSystemSessionItem.)
Public method | SetModificationTimestampAsync | Async version of [P:ModificationTimestamp] (Inherited from FileSystemSessionItem.)
Public method | SetReadOnlyAsync | Async version of [P:ReadOnly] (Inherited from FileSystemSessionItem.)
Public method | ToString | (Inherited from FileSystemSessionItem.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | GeneratePackagingManifest | Generates packaging manifest for the specified directory. Optionally may specify root node name (Defined by ManifestUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
FileSystemDirectory Class
NFX.IO.FileSystem Namespace


FileSystemDirectory.CreateDirectory Method

FileSystemDirectory CreateDirectory Method NFX Class Library

Creates a directory in this directory

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSystemDirectory CreateDirectory(
    string name
)
public FileSystemDirectory CreateDirectory(
    string name
)
Public Function CreateDirectory (
    name As String
) As FileSystemDirectory
Public Function CreateDirectory (
    name As String
) As FileSystemDirectory
public:
FileSystemDirectory^ CreateDirectory(
    String^ name
)
public:
FileSystemDirectory^ CreateDirectory(
    String^ name
)
member CreateDirectory :
        name : string -> FileSystemDirectory
member CreateDirectory :
        name : string -> FileSystemDirectory

Parameters

name
Type: Online System String

Return Value

Type: FileSystemDirectory
See Also
FileSystemDirectory Class
FileSystemDirectory Members
NFX.IO.FileSystem Namespace


FileSystemDirectory.CreateDirectoryAsync Method

FileSystemDirectory CreateDirectoryAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of CreateDirectory(String)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<FileSystemDirectory> CreateDirectoryAsync(
    string name
)
public Task<FileSystemDirectory> CreateDirectoryAsync(
    string name
)
Public Function CreateDirectoryAsync (
    name As String
) As Task(Of FileSystemDirectory)
Public Function CreateDirectoryAsync (
    name As String
) As Task(Of FileSystemDirectory)
public:
Task<FileSystemDirectory^>^ CreateDirectoryAsync(
    String^ name
)
public:
Task<FileSystemDirectory^>^ CreateDirectoryAsync(
    String^ name
)
member CreateDirectoryAsync :
        name : string -> Task<FileSystemDirectory>
member CreateDirectoryAsync :
        name : string -> Task<FileSystemDirectory>

Parameters

name
Type: Online System String

Return Value

Type: Online Task FileSystemDirectory
See Also
FileSystemDirectory Class
FileSystemDirectory Members
NFX.IO.FileSystem Namespace


FileSystemDirectory.CreateFile Method

FileSystemDirectory CreateFile Method NFX Class Library

Overload List
 | Name | Description
Public method | CreateFile(String, Int32) | Creates a new file optionally pre-allocating te specified number of bytes
Public method | CreateFile(String, String, Boolean) | Puts local existing file into file system
Back to Top
See Also
FileSystemDirectory Class
FileSystemDirectory Members
NFX.IO.FileSystem Namespace


FileSystemDirectory.CreateFile Method (String, Int32)

FileSystemDirectory CreateFile Method (String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates a new file optionally pre-allocating te specified number of bytes

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSystemFile CreateFile(
    string name,
    int size = 0
)
public FileSystemFile CreateFile(
    string name,
    int size = 0
)
Public Function CreateFile (
    name As String,
    Optional size As Integer = 0
) As FileSystemFile
Public Function CreateFile (
    name As String,
    Optional size As Integer = 0
) As FileSystemFile
public:
FileSystemFile^ CreateFile(
    String^ name,
    int size = 0
)
public:
FileSystemFile^ CreateFile(
    String^ name,
    int size = 0
)
member CreateFile :
        name : string *
        ?size : int
(* Defaults:
        let _size = defaultArg size 0
*)
-> FileSystemFile
member CreateFile :
        name : string *
        ?size : int
(* Defaults:
        let _size = defaultArg size 0
*)
-> FileSystemFile

Parameters

name
Type: Online System String
size (Optional)
Type: Online System Int32

Return Value

Type: FileSystemFile
See Also
FileSystemDirectory Class
FileSystemDirectory Members
CreateFile Overload
NFX.IO.FileSystem Namespace


FileSystemDirectory.CreateFile Method (String, String, Boolean)

FileSystemDirectory CreateFile Method (String, String, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Puts local existing file into file system

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSystemFile CreateFile(
    string name,
    string localFilePath,
    bool readOnly = false
)
public FileSystemFile CreateFile(
    string name,
    string localFilePath,
    bool readOnly = false
)
Public Function CreateFile (
    name As String,
    localFilePath As String,
    Optional readOnly As Boolean = false
) As FileSystemFile
Public Function CreateFile (
    name As String,
    localFilePath As String,
    Optional readOnly As Boolean = false
) As FileSystemFile
public:
FileSystemFile^ CreateFile(
    String^ name,
    String^ localFilePath,
    bool readOnly = false
)
public:
FileSystemFile^ CreateFile(
    String^ name,
    String^ localFilePath,
    bool readOnly = false
)
member CreateFile :
        name : string *
        localFilePath : string *
        ?readOnly : bool
(* Defaults:
        let _readOnly = defaultArg readOnly false
*)
-> FileSystemFile
member CreateFile :
        name : string *
        localFilePath : string *
        ?readOnly : bool
(* Defaults:
        let _readOnly = defaultArg readOnly false
*)
-> FileSystemFile

Parameters

name
Type: Online System String
File system file name
localFilePath
Type: Online System String
Local system file name
readOnly (Optional)
Type: Online System Boolean
Indictaes whether the newly created file should be readonly

Return Value

Type: FileSystemFile
FileSystemFile instance
See Also
FileSystemDirectory Class
FileSystemDirectory Members
CreateFile Overload
NFX.IO.FileSystem Namespace


FileSystemDirectory.CreateFileAsync Method

FileSystemDirectory CreateFileAsync Method NFX Class Library

Overload List
 | Name | Description
Public method | CreateFileAsync(String, Int32) | Async version of CreateFile(String, Int32)
Public method | CreateFileAsync(String, String, Boolean) | Async version of CreateFile(String, String, Boolean)
Back to Top
See Also
FileSystemDirectory Class
FileSystemDirectory Members
NFX.IO.FileSystem Namespace


FileSystemDirectory.CreateFileAsync Method (String, Int32)

FileSystemDirectory CreateFileAsync Method (String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of CreateFile(String, Int32)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<FileSystemFile> CreateFileAsync(
    string name,
    int size = 0
)
public Task<FileSystemFile> CreateFileAsync(
    string name,
    int size = 0
)
Public Function CreateFileAsync (
    name As String,
    Optional size As Integer = 0
) As Task(Of FileSystemFile)
Public Function CreateFileAsync (
    name As String,
    Optional size As Integer = 0
) As Task(Of FileSystemFile)
public:
Task<FileSystemFile^>^ CreateFileAsync(
    String^ name,
    int size = 0
)
public:
Task<FileSystemFile^>^ CreateFileAsync(
    String^ name,
    int size = 0
)
member CreateFileAsync :
        name : string *
        ?size : int
(* Defaults:
        let _size = defaultArg size 0
*)
-> Task<FileSystemFile>
member CreateFileAsync :
        name : string *
        ?size : int
(* Defaults:
        let _size = defaultArg size 0
*)
-> Task<FileSystemFile>

Parameters

name
Type: Online System String
size (Optional)
Type: Online System Int32

Return Value

Type: Online Task FileSystemFile
See Also
FileSystemDirectory Class
FileSystemDirectory Members
CreateFileAsync Overload
NFX.IO.FileSystem Namespace


FileSystemDirectory.CreateFileAsync Method (String, String, Boolean)

FileSystemDirectory CreateFileAsync Method (String, String, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of CreateFile(String, String, Boolean)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<FileSystemFile> CreateFileAsync(
    string name,
    string localFilePath,
    bool readOnly = false
)
public Task<FileSystemFile> CreateFileAsync(
    string name,
    string localFilePath,
    bool readOnly = false
)
Public Function CreateFileAsync (
    name As String,
    localFilePath As String,
    Optional readOnly As Boolean = false
) As Task(Of FileSystemFile)
Public Function CreateFileAsync (
    name As String,
    localFilePath As String,
    Optional readOnly As Boolean = false
) As Task(Of FileSystemFile)
public:
Task<FileSystemFile^>^ CreateFileAsync(
    String^ name,
    String^ localFilePath,
    bool readOnly = false
)
public:
Task<FileSystemFile^>^ CreateFileAsync(
    String^ name,
    String^ localFilePath,
    bool readOnly = false
)
member CreateFileAsync :
        name : string *
        localFilePath : string *
        ?readOnly : bool
(* Defaults:
        let _readOnly = defaultArg readOnly false
*)
-> Task<FileSystemFile>
member CreateFileAsync :
        name : string *
        localFilePath : string *
        ?readOnly : bool
(* Defaults:
        let _readOnly = defaultArg readOnly false
*)
-> Task<FileSystemFile>

Parameters

name
Type: Online System String
localFilePath
Type: Online System String
readOnly (Optional)
Type: Online System Boolean

Return Value

Type: Online Task FileSystemFile
See Also
FileSystemDirectory Class
FileSystemDirectory Members
CreateFileAsync Overload
NFX.IO.FileSystem Namespace


FileSystemDirectory.DeepCopyTo Method

FileSystemDirectory DeepCopyTo Method NFX Class Library

Performs a deep copy of this directory into another directory that may belong to a different file system. This method allows to copy directory trees between different file systems i.e. from SVN into AmazonS3 or local file system etc.

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DeepCopyTo(
    FileSystemDirectory target,
    FileSystemDirectory..::..DirCopyFlags flags = FileSystemDirectory..::..DirCopyFlags.All,
    int bufferSize = 65536,
    Func<FileSystemSessionItem, bool> filter = null,
    Func<FileSystemSessionItem, bool> cancel = null
)
public void DeepCopyTo(
    FileSystemDirectory target,
    FileSystemDirectory..::..DirCopyFlags flags = FileSystemDirectory..::..DirCopyFlags.All,
    int bufferSize = 65536,
    Func<FileSystemSessionItem, bool> filter = null,
    Func<FileSystemSessionItem, bool> cancel = null
)
Public Sub DeepCopyTo (
    target As FileSystemDirectory,
    Optional flags As FileSystemDirectory..::..DirCopyFlags = FileSystemDirectory..::..DirCopyFlags.All,
    Optional bufferSize As Integer = 65536,
    Optional filter As Func(Of FileSystemSessionItem, Boolean) = Nothing,
    Optional cancel As Func(Of FileSystemSessionItem, Boolean) = Nothing
)
Public Sub DeepCopyTo (
    target As FileSystemDirectory,
    Optional flags As FileSystemDirectory..::..DirCopyFlags = FileSystemDirectory..::..DirCopyFlags.All,
    Optional bufferSize As Integer = 65536,
    Optional filter As Func(Of FileSystemSessionItem, Boolean) = Nothing,
    Optional cancel As Func(Of FileSystemSessionItem, Boolean) = Nothing
)
public:
void DeepCopyTo(
    FileSystemDirectory^ target,
    FileSystemDirectory..::..DirCopyFlags flags = FileSystemDirectory..::..DirCopyFlags::All,
    int bufferSize = 65536,
    Func<FileSystemSessionItem^, bool>^ filter = nullptr,
    Func<FileSystemSessionItem^, bool>^ cancel = nullptr
)
public:
void DeepCopyTo(
    FileSystemDirectory^ target,
    FileSystemDirectory..::..DirCopyFlags flags = FileSystemDirectory..::..DirCopyFlags::All,
    int bufferSize = 65536,
    Func<FileSystemSessionItem^, bool>^ filter = nullptr,
    Func<FileSystemSessionItem^, bool>^ cancel = nullptr
)
member DeepCopyTo :
        target : FileSystemDirectory *
        ?flags : FileSystemDirectory..::..DirCopyFlags *
        ?bufferSize : int *
        ?filter : Func<FileSystemSessionItem, bool> *
        ?cancel : Func<FileSystemSessionItem, bool>
(* Defaults:
        let _flags = defaultArg flags FileSystemDirectory..::..DirCopyFlags.All
        let _bufferSize = defaultArg bufferSize 65536
        let _filter = defaultArg filter null
        let _cancel = defaultArg cancel null
*)
-> unit
member DeepCopyTo :
        target : FileSystemDirectory *
        ?flags : FileSystemDirectory..::..DirCopyFlags *
        ?bufferSize : int *
        ?filter : Func<FileSystemSessionItem, bool> *
        ?cancel : Func<FileSystemSessionItem, bool>
(* Defaults:
        let _flags = defaultArg flags FileSystemDirectory..::..DirCopyFlags.All
        let _bufferSize = defaultArg bufferSize 65536
        let _filter = defaultArg filter null
        let _cancel = defaultArg cancel null
*)
-> unit

Parameters

target
Type: NFX.IO.FileSystem FileSystemDirectory
Target directory where the files will be placed. It's name does not have to be the same as the source's name
flags (Optional)
Type: NFX.IO.FileSystem FileSystemDirectory DirCopyFlags
Copy flags that specify what to copy
bufferSize (Optional)
Type: Online System Int32
Copy buffer size
filter (Optional)
Type: Online System Func FileSystemSessionItem, Online Boolean
Optional filter function
cancel (Optional)
Type: Online System Func FileSystemSessionItem, Online Boolean
Optional cancellation function. Return true to abort copying
See Also
FileSystemDirectory Class
FileSystemDirectory Members
NFX.IO.FileSystem Namespace


FileSystemDirectory.DeepCopyToAsync Method

FileSystemDirectory DeepCopyToAsync Method NFX Class Library

Async version of DeepCopyTo(...)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task DeepCopyToAsync(
    FileSystemDirectory target,
    FileSystemDirectory..::..DirCopyFlags flags = FileSystemDirectory..::..DirCopyFlags.All,
    int bufferSize = 65536,
    Func<FileSystemSessionItem, bool> filter = null,
    Func<FileSystemSessionItem, bool> cancel = null
)
public Task DeepCopyToAsync(
    FileSystemDirectory target,
    FileSystemDirectory..::..DirCopyFlags flags = FileSystemDirectory..::..DirCopyFlags.All,
    int bufferSize = 65536,
    Func<FileSystemSessionItem, bool> filter = null,
    Func<FileSystemSessionItem, bool> cancel = null
)
Public Function DeepCopyToAsync (
    target As FileSystemDirectory,
    Optional flags As FileSystemDirectory..::..DirCopyFlags = FileSystemDirectory..::..DirCopyFlags.All,
    Optional bufferSize As Integer = 65536,
    Optional filter As Func(Of FileSystemSessionItem, Boolean) = Nothing,
    Optional cancel As Func(Of FileSystemSessionItem, Boolean) = Nothing
) As Task
Public Function DeepCopyToAsync (
    target As FileSystemDirectory,
    Optional flags As FileSystemDirectory..::..DirCopyFlags = FileSystemDirectory..::..DirCopyFlags.All,
    Optional bufferSize As Integer = 65536,
    Optional filter As Func(Of FileSystemSessionItem, Boolean) = Nothing,
    Optional cancel As Func(Of FileSystemSessionItem, Boolean) = Nothing
) As Task
public:
Task^ DeepCopyToAsync(
    FileSystemDirectory^ target,
    FileSystemDirectory..::..DirCopyFlags flags = FileSystemDirectory..::..DirCopyFlags::All,
    int bufferSize = 65536,
    Func<FileSystemSessionItem^, bool>^ filter = nullptr,
    Func<FileSystemSessionItem^, bool>^ cancel = nullptr
)
public:
Task^ DeepCopyToAsync(
    FileSystemDirectory^ target,
    FileSystemDirectory..::..DirCopyFlags flags = FileSystemDirectory..::..DirCopyFlags::All,
    int bufferSize = 65536,
    Func<FileSystemSessionItem^, bool>^ filter = nullptr,
    Func<FileSystemSessionItem^, bool>^ cancel = nullptr
)
member DeepCopyToAsync :
        target : FileSystemDirectory *
        ?flags : FileSystemDirectory..::..DirCopyFlags *
        ?bufferSize : int *
        ?filter : Func<FileSystemSessionItem, bool> *
        ?cancel : Func<FileSystemSessionItem, bool>
(* Defaults:
        let _flags = defaultArg flags FileSystemDirectory..::..DirCopyFlags.All
        let _bufferSize = defaultArg bufferSize 65536
        let _filter = defaultArg filter null
        let _cancel = defaultArg cancel null
*)
-> Task
member DeepCopyToAsync :
        target : FileSystemDirectory *
        ?flags : FileSystemDirectory..::..DirCopyFlags *
        ?bufferSize : int *
        ?filter : Func<FileSystemSessionItem, bool> *
        ?cancel : Func<FileSystemSessionItem, bool>
(* Defaults:
        let _flags = defaultArg flags FileSystemDirectory..::..DirCopyFlags.All
        let _bufferSize = defaultArg bufferSize 65536
        let _filter = defaultArg filter null
        let _cancel = defaultArg cancel null
*)
-> Task

Parameters

target
Type: NFX.IO.FileSystem FileSystemDirectory
flags (Optional)
Type: NFX.IO.FileSystem FileSystemDirectory DirCopyFlags
bufferSize (Optional)
Type: Online System Int32
filter (Optional)
Type: Online System Func FileSystemSessionItem, Online Boolean
cancel (Optional)
Type: Online System Func FileSystemSessionItem, Online Boolean

Return Value

Type: Online Task
See Also
FileSystemDirectory Class
FileSystemDirectory Members
NFX.IO.FileSystem Namespace


FileSystemDirectory.GetFile Method

FileSystemDirectory GetFile Method NFX Class Library

Gets file in this directory or null if it does not exist or not a file

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSystemFile GetFile(
    string name
)
public FileSystemFile GetFile(
    string name
)
Public Function GetFile (
    name As String
) As FileSystemFile
Public Function GetFile (
    name As String
) As FileSystemFile
public:
FileSystemFile^ GetFile(
    String^ name
)
public:
FileSystemFile^ GetFile(
    String^ name
)
member GetFile :
        name : string -> FileSystemFile
member GetFile :
        name : string -> FileSystemFile

Parameters

name
Type: Online System String

Return Value

Type: FileSystemFile
See Also
FileSystemDirectory Class
FileSystemDirectory Members
NFX.IO.FileSystem Namespace


FileSystemDirectory.GetFileAsync Method

FileSystemDirectory GetFileAsync Method NFX Class Library

Async version of GetFile(String)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<FileSystemFile> GetFileAsync(
    string name
)
public Task<FileSystemFile> GetFileAsync(
    string name
)
Public Function GetFileAsync (
    name As String
) As Task(Of FileSystemFile)
Public Function GetFileAsync (
    name As String
) As Task(Of FileSystemFile)
public:
Task<FileSystemFile^>^ GetFileAsync(
    String^ name
)
public:
Task<FileSystemFile^>^ GetFileAsync(
    String^ name
)
member GetFileAsync :
        name : string -> Task<FileSystemFile>
member GetFileAsync :
        name : string -> Task<FileSystemFile>

Parameters

name
Type: Online System String

Return Value

Type: Online Task FileSystemFile
See Also
FileSystemDirectory Class
FileSystemDirectory Members
NFX.IO.FileSystem Namespace


FileSystemDirectory.GetFileNamesAsync Method

FileSystemDirectory GetFileNamesAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of [P:FileNames]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<IEnumerable<string>> GetFileNamesAsync()
public Task<IEnumerable<string>> GetFileNamesAsync()
Public Function GetFileNamesAsync As Task(Of IEnumerable(Of String))
Public Function GetFileNamesAsync As Task(Of IEnumerable(Of String))
public:
Task<IEnumerable<String^>^>^ GetFileNamesAsync()
public:
Task<IEnumerable<String^>^>^ GetFileNamesAsync()
member GetFileNamesAsync : unit -> Task<IEnumerable<string>>
member GetFileNamesAsync : unit -> Task<IEnumerable<string>>

Return Value

Type: Online Task Online IEnumerable Online String
See Also
FileSystemDirectory Class
FileSystemDirectory Members
NFX.IO.FileSystem Namespace


FileSystemDirectory.GetItemAsync Method

FileSystemDirectory GetItemAsync Method NFX Class Library

Async version of Item(string)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<FileSystemSessionItem> GetItemAsync(
    string path
)
public Task<FileSystemSessionItem> GetItemAsync(
    string path
)
Public Function GetItemAsync (
    path As String
) As Task(Of FileSystemSessionItem)
Public Function GetItemAsync (
    path As String
) As Task(Of FileSystemSessionItem)
public:
Task<FileSystemSessionItem^>^ GetItemAsync(
    String^ path
)
public:
Task<FileSystemSessionItem^>^ GetItemAsync(
    String^ path
)
member GetItemAsync :
        path : string -> Task<FileSystemSessionItem>
member GetItemAsync :
        path : string -> Task<FileSystemSessionItem>

Parameters

path
Type: Online System String

Return Value

Type: Online Task FileSystemSessionItem
See Also
FileSystemDirectory Class
FileSystemDirectory Members
NFX.IO.FileSystem Namespace


FileSystemDirectory.GetRecursiveFileNamesAsync Method

FileSystemDirectory GetRecursiveFileNamesAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of [P:RecursiveFileNames]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<IEnumerable<string>> GetRecursiveFileNamesAsync()
public Task<IEnumerable<string>> GetRecursiveFileNamesAsync()
Public Function GetRecursiveFileNamesAsync As Task(Of IEnumerable(Of String))
Public Function GetRecursiveFileNamesAsync As Task(Of IEnumerable(Of String))
public:
Task<IEnumerable<String^>^>^ GetRecursiveFileNamesAsync()
public:
Task<IEnumerable<String^>^>^ GetRecursiveFileNamesAsync()
member GetRecursiveFileNamesAsync : unit -> Task<IEnumerable<string>>
member GetRecursiveFileNamesAsync : unit -> Task<IEnumerable<string>>

Return Value

Type: Online Task Online IEnumerable Online String
See Also
FileSystemDirectory Class
FileSystemDirectory Members
NFX.IO.FileSystem Namespace


FileSystemDirectory.GetRecursiveSubDirectoryNamesAsync Method

FileSystemDirectory GetRecursiveSubDirectoryNamesAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of [P:RecursiveSubDirectoryNames]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<IEnumerable<string>> GetRecursiveSubDirectoryNamesAsync()
public Task<IEnumerable<string>> GetRecursiveSubDirectoryNamesAsync()
Public Function GetRecursiveSubDirectoryNamesAsync As Task(Of IEnumerable(Of String))
Public Function GetRecursiveSubDirectoryNamesAsync As Task(Of IEnumerable(Of String))
public:
Task<IEnumerable<String^>^>^ GetRecursiveSubDirectoryNamesAsync()
public:
Task<IEnumerable<String^>^>^ GetRecursiveSubDirectoryNamesAsync()
member GetRecursiveSubDirectoryNamesAsync : unit -> Task<IEnumerable<string>>
member GetRecursiveSubDirectoryNamesAsync : unit -> Task<IEnumerable<string>>

Return Value

Type: Online Task Online IEnumerable Online String
See Also
FileSystemDirectory Class
FileSystemDirectory Members
NFX.IO.FileSystem Namespace


FileSystemDirectory.GetSubDirectory Method

FileSystemDirectory GetSubDirectory Method NFX Class Library

Gets dubdirectory in this directory or null if it does not exist or not a directory

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSystemDirectory GetSubDirectory(
    string name
)
public FileSystemDirectory GetSubDirectory(
    string name
)
Public Function GetSubDirectory (
    name As String
) As FileSystemDirectory
Public Function GetSubDirectory (
    name As String
) As FileSystemDirectory
public:
FileSystemDirectory^ GetSubDirectory(
    String^ name
)
public:
FileSystemDirectory^ GetSubDirectory(
    String^ name
)
member GetSubDirectory :
        name : string -> FileSystemDirectory
member GetSubDirectory :
        name : string -> FileSystemDirectory

Parameters

name
Type: Online System String

Return Value

Type: FileSystemDirectory
See Also
FileSystemDirectory Class
FileSystemDirectory Members
NFX.IO.FileSystem Namespace


FileSystemDirectory.GetSubDirectoryAsync Method

FileSystemDirectory GetSubDirectoryAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of GetFile(String)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<FileSystemDirectory> GetSubDirectoryAsync(
    string name
)
public Task<FileSystemDirectory> GetSubDirectoryAsync(
    string name
)
Public Function GetSubDirectoryAsync (
    name As String
) As Task(Of FileSystemDirectory)
Public Function GetSubDirectoryAsync (
    name As String
) As Task(Of FileSystemDirectory)
public:
Task<FileSystemDirectory^>^ GetSubDirectoryAsync(
    String^ name
)
public:
Task<FileSystemDirectory^>^ GetSubDirectoryAsync(
    String^ name
)
member GetSubDirectoryAsync :
        name : string -> Task<FileSystemDirectory>
member GetSubDirectoryAsync :
        name : string -> Task<FileSystemDirectory>

Parameters

name
Type: Online System String

Return Value

Type: Online Task FileSystemDirectory
See Also
FileSystemDirectory Class
FileSystemDirectory Members
NFX.IO.FileSystem Namespace


FileSystemDirectory.GetSubDirectoryNamesAsync Method

FileSystemDirectory GetSubDirectoryNamesAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of [P:SubDirectoryNames]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<IEnumerable<string>> GetSubDirectoryNamesAsync()
public Task<IEnumerable<string>> GetSubDirectoryNamesAsync()
Public Function GetSubDirectoryNamesAsync As Task(Of IEnumerable(Of String))
Public Function GetSubDirectoryNamesAsync As Task(Of IEnumerable(Of String))
public:
Task<IEnumerable<String^>^>^ GetSubDirectoryNamesAsync()
public:
Task<IEnumerable<String^>^>^ GetSubDirectoryNamesAsync()
member GetSubDirectoryNamesAsync : unit -> Task<IEnumerable<string>>
member GetSubDirectoryNamesAsync : unit -> Task<IEnumerable<string>>

Return Value

Type: Online Task Online IEnumerable Online String
See Also
FileSystemDirectory Class
FileSystemDirectory Members
NFX.IO.FileSystem Namespace


FileSystemDirectory Properties

FileSystemDirectory Properties NFX Class Library

The FileSystemDirectory type exposes the following members.
Properties
 | Name | Description
Public property | CreationTimestamp | Gets/sets UTC creation timestamp (Inherited from FileSystemSessionItem.)
Public property | CreationUser | Gets the user who created this item (Inherited from FileSystemSessionItem.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | FileNames | Returns file names contained in this directory
Public property | FileSystem | Returns filesystem - this is a shortcut to Session.FileSystem (Inherited from FileSystemSessionItem.)
Public property | Handle | Returns file system handle for this entity (Inherited from FileSystemSessionItem.)
Public property | IsReadOnly | Indicates whether this item can change and file system supports modifications (Inherited from FileSystemSessionItem.)
Public property | Item | Navigates to the specified path relative to this directory
Public property | LastAccessTimestamp | Gets/sets UTC last access timestamp (Inherited from FileSystemSessionItem.)
Public property | LastAccessUser | Gets the last user who accessed the item (Inherited from FileSystemSessionItem.)
Public property | MetadataStream | Returns item metadata stream (Inherited from FileSystemSessionItem.)
Public property | ModificationTimestamp | Gets/sets UTC modification timestamp (Inherited from FileSystemSessionItem.)
Public property | ModificationUser | Gets the user who modified this item (Inherited from FileSystemSessionItem.)
Public property | Modified | Indicates whether anything has changed since last transaction has started (Inherited from FileSystemSessionItem.)
Public property | Name | (Inherited from FileSystemSessionItem.)
Public property | ParentPath | Returns path to directory that contains this item (Inherited from FileSystemSessionItem.)
Public property | Path | Returns an absolute path for this item (Inherited from FileSystemSessionItem.)
Public property | PermissionsStream | Returns item permissions stream (Inherited from FileSystemSessionItem.)
Public property | ReadOnly | Gets/sets readonly attribute (Inherited from FileSystemSessionItem.)
Public property | RecursiveFileNames | Returns file names contained in this directory and all subdirectories
Public property | RecursiveSubDirectoryNames | Returns directory names contained in this directory and all subdirectories
Public property | Session | Returns session through which this object was obtained (Inherited from FileSystemSessionItem.)
Public property | Size | Returns the byte size of the item, depending on implementation this property may return approximate sizes for files and directories (i.e in distributed systems) (Inherited from FileSystemSessionItem.)
Public property | SubDirectoryNames | Returns directory names contained in this directory
Back to Top
See Also
FileSystemDirectory Class
NFX.IO.FileSystem Namespace


FileSystemDirectory.FileNames Property

FileSystemDirectory FileNames Property NFX Class Library

Returns file names contained in this directory

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<string> FileNames { get; }
public IEnumerable<string> FileNames { get; }
Public ReadOnly Property FileNames As IEnumerable(Of String)
    Get
Public ReadOnly Property FileNames As IEnumerable(Of String)
    Get
public:
property IEnumerable<String^>^ FileNames {
    IEnumerable<String^>^ get ();
}
public:
property IEnumerable<String^>^ FileNames {
    IEnumerable<String^>^ get ();
}
member FileNames : IEnumerable<string> with get
member FileNames : IEnumerable<string> with get

Property Value

Type: Online IEnumerable Online String
See Also
FileSystemDirectory Class
FileSystemDirectory Members
NFX.IO.FileSystem Namespace


FileSystemDirectory.Item Property

FileSystemDirectory Item Property NFX Class Library

Navigates to the specified path relative to this directory

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSystemSessionItem this[
    string path
] { get; }
public FileSystemSessionItem this[
    string path
] { get; }
Public ReadOnly Default Property Item (
    path As String
) As FileSystemSessionItem
    Get
Public ReadOnly Default Property Item (
    path As String
) As FileSystemSessionItem
    Get
public:
property FileSystemSessionItem^ default[String^ path] {
    FileSystemSessionItem^ get (String^ path);
}
public:
property FileSystemSessionItem^ default[String^ path] {
    FileSystemSessionItem^ get (String^ path);
}
member Item : FileSystemSessionItem with get
member Item : FileSystemSessionItem with get

Parameters

path
Type: Online System String
Path relative to this directory to navigate to

Return Value

Type: FileSystemSessionItem
FileSystemSessionItem instance - a directory or a file
See Also
FileSystemDirectory Class
FileSystemDirectory Members
NFX.IO.FileSystem Namespace


FileSystemDirectory.RecursiveFileNames Property

FileSystemDirectory RecursiveFileNames Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns file names contained in this directory and all subdirectories

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<string> RecursiveFileNames { get; }
public IEnumerable<string> RecursiveFileNames { get; }
Public ReadOnly Property RecursiveFileNames As IEnumerable(Of String)
    Get
Public ReadOnly Property RecursiveFileNames As IEnumerable(Of String)
    Get
public:
property IEnumerable<String^>^ RecursiveFileNames {
    IEnumerable<String^>^ get ();
}
public:
property IEnumerable<String^>^ RecursiveFileNames {
    IEnumerable<String^>^ get ();
}
member RecursiveFileNames : IEnumerable<string> with get
member RecursiveFileNames : IEnumerable<string> with get

Property Value

Type: Online IEnumerable Online String
See Also
FileSystemDirectory Class
FileSystemDirectory Members
NFX.IO.FileSystem Namespace


FileSystemDirectory.RecursiveSubDirectoryNames Property

FileSystemDirectory RecursiveSubDirectoryNames Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns directory names contained in this directory and all subdirectories

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<string> RecursiveSubDirectoryNames { get; }
public IEnumerable<string> RecursiveSubDirectoryNames { get; }
Public ReadOnly Property RecursiveSubDirectoryNames As IEnumerable(Of String)
    Get
Public ReadOnly Property RecursiveSubDirectoryNames As IEnumerable(Of String)
    Get
public:
property IEnumerable<String^>^ RecursiveSubDirectoryNames {
    IEnumerable<String^>^ get ();
}
public:
property IEnumerable<String^>^ RecursiveSubDirectoryNames {
    IEnumerable<String^>^ get ();
}
member RecursiveSubDirectoryNames : IEnumerable<string> with get
member RecursiveSubDirectoryNames : IEnumerable<string> with get

Property Value

Type: Online IEnumerable Online String
See Also
FileSystemDirectory Class
FileSystemDirectory Members
NFX.IO.FileSystem Namespace


FileSystemDirectory.SubDirectoryNames Property

FileSystemDirectory SubDirectoryNames Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns directory names contained in this directory

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<string> SubDirectoryNames { get; }
public IEnumerable<string> SubDirectoryNames { get; }
Public ReadOnly Property SubDirectoryNames As IEnumerable(Of String)
    Get
Public ReadOnly Property SubDirectoryNames As IEnumerable(Of String)
    Get
public:
property IEnumerable<String^>^ SubDirectoryNames {
    IEnumerable<String^>^ get ();
}
public:
property IEnumerable<String^>^ SubDirectoryNames {
    IEnumerable<String^>^ get ();
}
member SubDirectoryNames : IEnumerable<string> with get
member SubDirectoryNames : IEnumerable<string> with get

Property Value

Type: Online IEnumerable Online String
See Also
FileSystemDirectory Class
FileSystemDirectory Members
NFX.IO.FileSystem Namespace


FileSystemDirectory.DirCopyFlags Enumeration

FileSystemDirectory DirCopyFlags Enumeration NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[FlagsAttribute]
public enum DirCopyFlags
[FlagsAttribute]
public enum DirCopyFlags
<FlagsAttribute>
Public Enumeration DirCopyFlags
<FlagsAttribute>
Public Enumeration DirCopyFlags
[FlagsAttribute]
public enum class DirCopyFlags
[FlagsAttribute]
public enum class DirCopyFlags
[<FlagsAttribute>]
type DirCopyFlags
[<FlagsAttribute>]
type DirCopyFlags
Members
Member name | Value | Description
None | 0 |
Directories | 1 |
Files | 2 |
Security | 4 |
Metadata | 8 |
Timestamps | 16 |
Readonly | 32 |
FilesAndDirsOnly | 3 |
All | 2147483647 |
See Also
NFX.IO.FileSystem Namespace


FileSystemException Class

FileSystemException Class NFX Class Library

General NFX file system specific exception
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.IO.FileSystem FileSystemException

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class FileSystemException : NFXException
public class FileSystemException : NFXException
Public Class FileSystemException
    Inherits NFXException
Public Class FileSystemException
    Inherits NFXException
public ref class FileSystemException : public NFXException
public ref class FileSystemException : public NFXException
type FileSystemException =
    class
        inherit NFXException
    end
type FileSystemException =
    class
        inherit NFXException
    end
See Also
FileSystemException Members
NFX.IO.FileSystem Namespace


FileSystemException Members

FileSystemException Members NFX Class Library

The FileSystemException type exposes the following members.
Constructors
 | Name | Description
Public method | FileSystemException | Initializes a new instance of the FileSystemException class
Public method | FileSystemException(String) | Initializes a new instance of the FileSystemException class
Protected method | FileSystemException(SerializationInfo, StreamingContext) | Initializes a new instance of the FileSystemException class
Public method | FileSystemException(String, Exception) | Initializes a new instance of the FileSystemException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
FileSystemException Class
NFX.IO.FileSystem Namespace


FileSystemException Constructor

FileSystemException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | FileSystemException | Initializes a new instance of the FileSystemException class
Public method | FileSystemException(String) | Initializes a new instance of the FileSystemException class
Protected method | FileSystemException(SerializationInfo, StreamingContext) | Initializes a new instance of the FileSystemException class
Public method | FileSystemException(String, Exception) | Initializes a new instance of the FileSystemException class
Back to Top
See Also
FileSystemException Class
FileSystemException Members
NFX.IO.FileSystem Namespace


FileSystemException Constructor

FileSystemException Constructor NFX Class Library

Initializes a new instance of the FileSystemException class

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSystemException()
public FileSystemException()
Public Sub New
Public Sub New
public:
FileSystemException()
public:
FileSystemException()
new : unit -> FileSystemException
new : unit -> FileSystemException
See Also
FileSystemException Class
FileSystemException Members
FileSystemException Overload
NFX.IO.FileSystem Namespace


FileSystemException Constructor (String)

FileSystemException Constructor (String) NFX Class Library

Initializes a new instance of the FileSystemException class

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSystemException(
    string message
)
public FileSystemException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
FileSystemException(
    String^ message
)
public:
FileSystemException(
    String^ message
)
new :
        message : string -> FileSystemException
new :
        message : string -> FileSystemException

Parameters

message
Type: Online System String
See Also
FileSystemException Class
FileSystemException Members
FileSystemException Overload
NFX.IO.FileSystem Namespace


FileSystemException Constructor (SerializationInfo, StreamingContext)

FileSystemException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FileSystemException class

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FileSystemException(
    SerializationInfo info,
    StreamingContext context
)
protected FileSystemException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
FileSystemException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
FileSystemException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FileSystemException
new :
        info : SerializationInfo *
        context : StreamingContext -> FileSystemException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
FileSystemException Class
FileSystemException Members
FileSystemException Overload
NFX.IO.FileSystem Namespace


FileSystemException Constructor (String, Exception)

FileSystemException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FileSystemException class

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSystemException(
    string message,
    Exception inner
)
public FileSystemException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
FileSystemException(
    String^ message,
    Exception^ inner
)
public:
FileSystemException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> FileSystemException
new :
        message : string *
        inner : Exception -> FileSystemException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
FileSystemException Class
FileSystemException Members
FileSystemException Overload
NFX.IO.FileSystem Namespace


FileSystemException Methods

FileSystemException Methods NFX Class Library

The FileSystemException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
FileSystemException Class
NFX.IO.FileSystem Namespace


FileSystemException Properties

FileSystemException Properties NFX Class Library

The FileSystemException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
FileSystemException Class
NFX.IO.FileSystem Namespace


FileSystemException Events

FileSystemException Events NFX Class Library

The FileSystemException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
FileSystemException Class
NFX.IO.FileSystem Namespace


FileSystemFile Class

FileSystemFile Class NFX Class Library

Represents a file in a file system. This class is NOT thread-safe
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.IO.FileSystem FileSystemSessionItem
NFX.IO.FileSystem FileSystemFile

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class FileSystemFile : FileSystemSessionItem
public sealed class FileSystemFile : FileSystemSessionItem
Public NotInheritable Class FileSystemFile
    Inherits FileSystemSessionItem
Public NotInheritable Class FileSystemFile
    Inherits FileSystemSessionItem
public ref class FileSystemFile sealed : public FileSystemSessionItem
public ref class FileSystemFile sealed : public FileSystemSessionItem
[<SealedAttribute>]
type FileSystemFile =
    class
        inherit FileSystemSessionItem
    end
[<SealedAttribute>]
type FileSystemFile =
    class
        inherit FileSystemSessionItem
    end
See Also
FileSystemFile Members
NFX.IO.FileSystem Namespace


FileSystemFile Members

FileSystemFile Members NFX Class Library

The FileSystemFile type exposes the following members.
Constructors
 | Name | Description
Public method | FileSystemFile | Internal method that should not be called by developers
Back to Top
Methods
 | Name | Description
Public method | CheckCanChange | Throws when item can not change (Inherited from FileSystemSessionItem.)
Public method | CheckCanChangeAsync | Async version of CheckCanChange (Inherited from FileSystemSessionItem.)
Public method | Delete | Deletes this item from file system (Inherited from FileSystemSessionItem.)
Public method | DeleteAsync | Async version of Delete (Inherited from FileSystemSessionItem.)
Protected method | Destructor | (Overrides FileSystemSessionItem Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetCreationUserAsync | Async version of [P:CreationUser] (Inherited from FileSystemSessionItem.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetLastAccessUserAsync | Async version of [P:LastAccessUser] (Inherited from FileSystemSessionItem.)
Public method | GetModificationUserAsync | Async version of [P:ModificationUser] (Inherited from FileSystemSessionItem.)
Public method | GetSizeAsync | Async version of [P:Size] (Inherited from FileSystemSessionItem.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReadAllText | Reads all text from file using byte order mark detection with UTF8 encoding
Public method | ReadAllText(Encoding, Boolean, Int32) | Reads all text from stream using the specified parameters
Public method | ReadAllTextAsync | Async version of ReadAllText
Public method | ReadAllTextAsync(Encoding, Boolean, Int32) | Async version of ReadAllText(Encoding, Boolean, Int32)
Public method | Refresh | Refreshes the state represented by this item, i.e. this may re-read attributes from remote file system (Inherited from FileSystemSessionItem.)
Public method | RefreshAsync | Async version of Refresh (Inherited from FileSystemSessionItem.)
Public method | Rename | Renames an item. Check file system capabilities to see if renaming is supported (Inherited from FileSystemSessionItem.)
Public method | RenameAsync | Async version of Rename(String) (Inherited from FileSystemSessionItem.)
Public method | SetCreationTimestampAsync | Async version of [P:CreationTimestamp] (Inherited from FileSystemSessionItem.)
Public method | SetLastAccessTimestampAsync | Async version of [P:LastAccessTimestamp] (Inherited from FileSystemSessionItem.)
Public method | SetModificationTimestampAsync | Async version of [P:ModificationTimestamp] (Inherited from FileSystemSessionItem.)
Public method | SetReadOnlyAsync | Async version of [P:ReadOnly] (Inherited from FileSystemSessionItem.)
Public method | ToString | (Inherited from FileSystemSessionItem.)
Public method | WriteAllText(String) | Sets file content to supplied string using default UTF8 encoding
Public method | WriteAllText(String, Encoding, Int32) | Sets file content to supplied string using the specified parameters
Public method | WriteAllTextAsync(String) | Async version of WriteAllText(String)
Public method | WriteAllTextAsync(String, Encoding, Int32) | Async version of WriteAllText(String, Encoding, Int32)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_FileSystem | (Inherited from FileSystemSessionItem.)
Protected field | m_Handle | (Inherited from FileSystemSessionItem.)
Protected field | m_Modified | (Inherited from FileSystemSessionItem.)
Protected field | m_Session | (Inherited from FileSystemSessionItem.)
Back to Top
Properties
 | Name | Description
Public property | CreationTimestamp | Gets/sets UTC creation timestamp (Inherited from FileSystemSessionItem.)
Public property | CreationUser | Gets the user who created this item (Inherited from FileSystemSessionItem.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | FileStream | Returns a stream usable for file content access. If the file has not opened stream yet it will be opened and cached
Public property | FileSystem | Returns filesystem - this is a shortcut to Session.FileSystem (Inherited from FileSystemSessionItem.)
Public property | Handle | Returns file system handle for this entity (Inherited from FileSystemSessionItem.)
Public property | IsReadOnly | Indicates whether this item can change and file system supports modifications (Inherited from FileSystemSessionItem.)
Public property | LastAccessTimestamp | Gets/sets UTC last access timestamp (Inherited from FileSystemSessionItem.)
Public property | LastAccessUser | Gets the last user who accessed the item (Inherited from FileSystemSessionItem.)
Public property | MetadataStream | Returns item metadata stream (Inherited from FileSystemSessionItem.)
Public property | ModificationTimestamp | Gets/sets UTC modification timestamp (Inherited from FileSystemSessionItem.)
Public property | ModificationUser | Gets the user who modified this item (Inherited from FileSystemSessionItem.)
Public property | Modified | Indicates whether anything has changed since last transaction has started (Inherited from FileSystemSessionItem.)
Public property | Name | (Inherited from FileSystemSessionItem.)
Public property | ParentPath | Returns path to directory that contains this item (Inherited from FileSystemSessionItem.)
Public property | Path | Returns an absolute path for this item (Inherited from FileSystemSessionItem.)
Public property | PermissionsStream | Returns item permissions stream (Inherited from FileSystemSessionItem.)
Public property | ReadOnly | Gets/sets readonly attribute (Inherited from FileSystemSessionItem.)
Public property | Session | Returns session through which this object was obtained (Inherited from FileSystemSessionItem.)
Public property | Size | Returns the byte size of the item, depending on implementation this property may return approximate sizes for files and directories (i.e in distributed systems) (Inherited from FileSystemSessionItem.)
Back to Top
See Also
FileSystemFile Class
NFX.IO.FileSystem Namespace


FileSystemFile Constructor

FileSystemFile Constructor NFX Class Library

Internal method that should not be called by developers

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSystemFile(
    FileSystemSession session,
    string parentPath,
    string name,
    IFileSystemHandle handle
)
public FileSystemFile(
    FileSystemSession session,
    string parentPath,
    string name,
    IFileSystemHandle handle
)
Public Sub New (
    session As FileSystemSession,
    parentPath As String,
    name As String,
    handle As IFileSystemHandle
)
Public Sub New (
    session As FileSystemSession,
    parentPath As String,
    name As String,
    handle As IFileSystemHandle
)
public:
FileSystemFile(
    FileSystemSession^ session,
    String^ parentPath,
    String^ name,
    IFileSystemHandle^ handle
)
public:
FileSystemFile(
    FileSystemSession^ session,
    String^ parentPath,
    String^ name,
    IFileSystemHandle^ handle
)
new :
        session : FileSystemSession *
        parentPath : string *
        name : string *
        handle : IFileSystemHandle -> FileSystemFile
new :
        session : FileSystemSession *
        parentPath : string *
        name : string *
        handle : IFileSystemHandle -> FileSystemFile

Parameters

session
Type: NFX.IO.FileSystem FileSystemSession
parentPath
Type: Online System String
name
Type: Online System String
handle
Type: NFX.IO.FileSystem IFileSystemHandle
See Also
FileSystemFile Class
FileSystemFile Members
NFX.IO.FileSystem Namespace


FileSystemFile Fields

FileSystemFile Fields NFX Class Library

The FileSystemFile type exposes the following members.
Fields
 | Name | Description
Protected field | m_FileSystem | (Inherited from FileSystemSessionItem.)
Protected field | m_Handle | (Inherited from FileSystemSessionItem.)
Protected field | m_Modified | (Inherited from FileSystemSessionItem.)
Protected field | m_Session | (Inherited from FileSystemSessionItem.)
Back to Top
See Also
FileSystemFile Class
NFX.IO.FileSystem Namespace


FileSystemFile Methods

FileSystemFile Methods NFX Class Library

The FileSystemFile type exposes the following members.
Methods
 | Name | Description
Public method | CheckCanChange | Throws when item can not change (Inherited from FileSystemSessionItem.)
Public method | CheckCanChangeAsync | Async version of CheckCanChange (Inherited from FileSystemSessionItem.)
Public method | Delete | Deletes this item from file system (Inherited from FileSystemSessionItem.)
Public method | DeleteAsync | Async version of Delete (Inherited from FileSystemSessionItem.)
Protected method | Destructor | (Overrides FileSystemSessionItem Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetCreationUserAsync | Async version of [P:CreationUser] (Inherited from FileSystemSessionItem.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetLastAccessUserAsync | Async version of [P:LastAccessUser] (Inherited from FileSystemSessionItem.)
Public method | GetModificationUserAsync | Async version of [P:ModificationUser] (Inherited from FileSystemSessionItem.)
Public method | GetSizeAsync | Async version of [P:Size] (Inherited from FileSystemSessionItem.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReadAllText | Reads all text from file using byte order mark detection with UTF8 encoding
Public method | ReadAllText(Encoding, Boolean, Int32) | Reads all text from stream using the specified parameters
Public method | ReadAllTextAsync | Async version of ReadAllText
Public method | ReadAllTextAsync(Encoding, Boolean, Int32) | Async version of ReadAllText(Encoding, Boolean, Int32)
Public method | Refresh | Refreshes the state represented by this item, i.e. this may re-read attributes from remote file system (Inherited from FileSystemSessionItem.)
Public method | RefreshAsync | Async version of Refresh (Inherited from FileSystemSessionItem.)
Public method | Rename | Renames an item. Check file system capabilities to see if renaming is supported (Inherited from FileSystemSessionItem.)
Public method | RenameAsync | Async version of Rename(String) (Inherited from FileSystemSessionItem.)
Public method | SetCreationTimestampAsync | Async version of [P:CreationTimestamp] (Inherited from FileSystemSessionItem.)
Public method | SetLastAccessTimestampAsync | Async version of [P:LastAccessTimestamp] (Inherited from FileSystemSessionItem.)
Public method | SetModificationTimestampAsync | Async version of [P:ModificationTimestamp] (Inherited from FileSystemSessionItem.)
Public method | SetReadOnlyAsync | Async version of [P:ReadOnly] (Inherited from FileSystemSessionItem.)
Public method | ToString | (Inherited from FileSystemSessionItem.)
Public method | WriteAllText(String) | Sets file content to supplied string using default UTF8 encoding
Public method | WriteAllText(String, Encoding, Int32) | Sets file content to supplied string using the specified parameters
Public method | WriteAllTextAsync(String) | Async version of WriteAllText(String)
Public method | WriteAllTextAsync(String, Encoding, Int32) | Async version of WriteAllText(String, Encoding, Int32)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
FileSystemFile Class
NFX.IO.FileSystem Namespace


FileSystemFile.Destructor Method

FileSystemFile Destructor Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
FileSystemFile Class
FileSystemFile Members
NFX.IO.FileSystem Namespace


FileSystemFile.ReadAllText Method

FileSystemFile ReadAllText Method NFX Class Library

Overload List
 | Name | Description
Public method | ReadAllText | Reads all text from file using byte order mark detection with UTF8 encoding
Public method | ReadAllText(Encoding, Boolean, Int32) | Reads all text from stream using the specified parameters
Back to Top
See Also
FileSystemFile Class
FileSystemFile Members
NFX.IO.FileSystem Namespace


FileSystemFile.ReadAllText Method

FileSystemFile ReadAllText Method NFX Class Library

Reads all text from file using byte order mark detection with UTF8 encoding

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ReadAllText()
public string ReadAllText()
Public Function ReadAllText As String
Public Function ReadAllText As String
public:
String^ ReadAllText()
public:
String^ ReadAllText()
member ReadAllText : unit -> string
member ReadAllText : unit -> string

Return Value

Type: Online String
See Also
FileSystemFile Class
FileSystemFile Members
ReadAllText Overload
NFX.IO.FileSystem Namespace


FileSystemFile.ReadAllText Method (Encoding, Boolean, Int32)

FileSystemFile ReadAllText Method (Encoding, Boolean, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Reads all text from stream using the specified parameters

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ReadAllText(
    Encoding encoding,
    bool detectEncodingFromByteOrderMarks,
    int bufferSize = 1024
)
public string ReadAllText(
    Encoding encoding,
    bool detectEncodingFromByteOrderMarks,
    int bufferSize = 1024
)
Public Function ReadAllText (
    encoding As Encoding,
    detectEncodingFromByteOrderMarks As Boolean,
    Optional bufferSize As Integer = 1024
) As String
Public Function ReadAllText (
    encoding As Encoding,
    detectEncodingFromByteOrderMarks As Boolean,
    Optional bufferSize As Integer = 1024
) As String
public:
String^ ReadAllText(
    Encoding^ encoding,
    bool detectEncodingFromByteOrderMarks,
    int bufferSize = 1024
)
public:
String^ ReadAllText(
    Encoding^ encoding,
    bool detectEncodingFromByteOrderMarks,
    int bufferSize = 1024
)
member ReadAllText :
        encoding : Encoding *
        detectEncodingFromByteOrderMarks : bool *
        ?bufferSize : int
(* Defaults:
        let _bufferSize = defaultArg bufferSize 1024
*)
-> string
member ReadAllText :
        encoding : Encoding *
        detectEncodingFromByteOrderMarks : bool *
        ?bufferSize : int
(* Defaults:
        let _bufferSize = defaultArg bufferSize 1024
*)
-> string

Parameters

encoding
Type: Online System.Text Encoding
detectEncodingFromByteOrderMarks
Type: Online System Boolean
bufferSize (Optional)
Type: Online System Int32

Return Value

Type: Online String
See Also
FileSystemFile Class
FileSystemFile Members
ReadAllText Overload
NFX.IO.FileSystem Namespace


FileSystemFile.ReadAllTextAsync Method

FileSystemFile ReadAllTextAsync Method NFX Class Library

Overload List
 | Name | Description
Public method | ReadAllTextAsync | Async version of ReadAllText
Public method | ReadAllTextAsync(Encoding, Boolean, Int32) | Async version of ReadAllText(Encoding, Boolean, Int32)
Back to Top
See Also
FileSystemFile Class
FileSystemFile Members
NFX.IO.FileSystem Namespace


FileSystemFile.ReadAllTextAsync Method

FileSystemFile ReadAllTextAsync Method NFX Class Library

Async version of ReadAllText

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<string> ReadAllTextAsync()
public Task<string> ReadAllTextAsync()
Public Function ReadAllTextAsync As Task(Of String)
Public Function ReadAllTextAsync As Task(Of String)
public:
Task<String^>^ ReadAllTextAsync()
public:
Task<String^>^ ReadAllTextAsync()
member ReadAllTextAsync : unit -> Task<string>
member ReadAllTextAsync : unit -> Task<string>

Return Value

Type: Online Task Online String
See Also
FileSystemFile Class
FileSystemFile Members
ReadAllTextAsync Overload
NFX.IO.FileSystem Namespace


FileSystemFile.ReadAllTextAsync Method (Encoding, Boolean, Int32)

FileSystemFile ReadAllTextAsync Method (Encoding, Boolean, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of ReadAllText(Encoding, Boolean, Int32)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<string> ReadAllTextAsync(
    Encoding encoding,
    bool detectEncodingFromByteOrderMarks,
    int bufferSize = 1024
)
public Task<string> ReadAllTextAsync(
    Encoding encoding,
    bool detectEncodingFromByteOrderMarks,
    int bufferSize = 1024
)
Public Function ReadAllTextAsync (
    encoding As Encoding,
    detectEncodingFromByteOrderMarks As Boolean,
    Optional bufferSize As Integer = 1024
) As Task(Of String)
Public Function ReadAllTextAsync (
    encoding As Encoding,
    detectEncodingFromByteOrderMarks As Boolean,
    Optional bufferSize As Integer = 1024
) As Task(Of String)
public:
Task<String^>^ ReadAllTextAsync(
    Encoding^ encoding,
    bool detectEncodingFromByteOrderMarks,
    int bufferSize = 1024
)
public:
Task<String^>^ ReadAllTextAsync(
    Encoding^ encoding,
    bool detectEncodingFromByteOrderMarks,
    int bufferSize = 1024
)
member ReadAllTextAsync :
        encoding : Encoding *
        detectEncodingFromByteOrderMarks : bool *
        ?bufferSize : int
(* Defaults:
        let _bufferSize = defaultArg bufferSize 1024
*)
-> Task<string>
member ReadAllTextAsync :
        encoding : Encoding *
        detectEncodingFromByteOrderMarks : bool *
        ?bufferSize : int
(* Defaults:
        let _bufferSize = defaultArg bufferSize 1024
*)
-> Task<string>

Parameters

encoding
Type: Online System.Text Encoding
detectEncodingFromByteOrderMarks
Type: Online System Boolean
bufferSize (Optional)
Type: Online System Int32

Return Value

Type: Online Task Online String
See Also
FileSystemFile Class
FileSystemFile Members
ReadAllTextAsync Overload
NFX.IO.FileSystem Namespace


FileSystemFile.WriteAllText Method

FileSystemFile WriteAllText Method NFX Class Library

Overload List
 | Name | Description
Public method | WriteAllText(String) | Sets file content to supplied string using default UTF8 encoding
Public method | WriteAllText(String, Encoding, Int32) | Sets file content to supplied string using the specified parameters
Back to Top
See Also
FileSystemFile Class
FileSystemFile Members
NFX.IO.FileSystem Namespace


FileSystemFile.WriteAllText Method (String)

FileSystemFile WriteAllText Method (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Sets file content to supplied string using default UTF8 encoding

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteAllText(
    string text
)
public void WriteAllText(
    string text
)
Public Sub WriteAllText (
    text As String
)
Public Sub WriteAllText (
    text As String
)
public:
void WriteAllText(
    String^ text
)
public:
void WriteAllText(
    String^ text
)
member WriteAllText :
        text : string -> unit
member WriteAllText :
        text : string -> unit

Parameters

text
Type: Online System String
See Also
FileSystemFile Class
FileSystemFile Members
WriteAllText Overload
NFX.IO.FileSystem Namespace


FileSystemFile.WriteAllText Method (String, Encoding, Int32)

FileSystemFile WriteAllText Method (String, Encoding, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Sets file content to supplied string using the specified parameters

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteAllText(
    string text,
    Encoding encoding,
    int bufferSize = 1024
)
public void WriteAllText(
    string text,
    Encoding encoding,
    int bufferSize = 1024
)
Public Sub WriteAllText (
    text As String,
    encoding As Encoding,
    Optional bufferSize As Integer = 1024
)
Public Sub WriteAllText (
    text As String,
    encoding As Encoding,
    Optional bufferSize As Integer = 1024
)
public:
void WriteAllText(
    String^ text,
    Encoding^ encoding,
    int bufferSize = 1024
)
public:
void WriteAllText(
    String^ text,
    Encoding^ encoding,
    int bufferSize = 1024
)
member WriteAllText :
        text : string *
        encoding : Encoding *
        ?bufferSize : int
(* Defaults:
        let _bufferSize = defaultArg bufferSize 1024
*)
-> unit
member WriteAllText :
        text : string *
        encoding : Encoding *
        ?bufferSize : int
(* Defaults:
        let _bufferSize = defaultArg bufferSize 1024
*)
-> unit

Parameters

text
Type: Online System String
encoding
Type: Online System.Text Encoding
bufferSize (Optional)
Type: Online System Int32
See Also
FileSystemFile Class
FileSystemFile Members
WriteAllText Overload
NFX.IO.FileSystem Namespace


FileSystemFile.WriteAllTextAsync Method

FileSystemFile WriteAllTextAsync Method NFX Class Library

Overload List
 | Name | Description
Public method | WriteAllTextAsync(String) | Async version of WriteAllText(String)
Public method | WriteAllTextAsync(String, Encoding, Int32) | Async version of WriteAllText(String, Encoding, Int32)
Back to Top
See Also
FileSystemFile Class
FileSystemFile Members
NFX.IO.FileSystem Namespace


FileSystemFile.WriteAllTextAsync Method (String)

FileSystemFile WriteAllTextAsync Method (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of WriteAllText(String)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task WriteAllTextAsync(
    string text
)
public Task WriteAllTextAsync(
    string text
)
Public Function WriteAllTextAsync (
    text As String
) As Task
Public Function WriteAllTextAsync (
    text As String
) As Task
public:
Task^ WriteAllTextAsync(
    String^ text
)
public:
Task^ WriteAllTextAsync(
    String^ text
)
member WriteAllTextAsync :
        text : string -> Task
member WriteAllTextAsync :
        text : string -> Task

Parameters

text
Type: Online System String

Return Value

Type: Online Task
See Also
FileSystemFile Class
FileSystemFile Members
WriteAllTextAsync Overload
NFX.IO.FileSystem Namespace


FileSystemFile.WriteAllTextAsync Method (String, Encoding, Int32)

FileSystemFile WriteAllTextAsync Method (String, Encoding, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of WriteAllText(String, Encoding, Int32)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task WriteAllTextAsync(
    string text,
    Encoding encoding,
    int bufferSize = 1024
)
public Task WriteAllTextAsync(
    string text,
    Encoding encoding,
    int bufferSize = 1024
)
Public Function WriteAllTextAsync (
    text As String,
    encoding As Encoding,
    Optional bufferSize As Integer = 1024
) As Task
Public Function WriteAllTextAsync (
    text As String,
    encoding As Encoding,
    Optional bufferSize As Integer = 1024
) As Task
public:
Task^ WriteAllTextAsync(
    String^ text,
    Encoding^ encoding,
    int bufferSize = 1024
)
public:
Task^ WriteAllTextAsync(
    String^ text,
    Encoding^ encoding,
    int bufferSize = 1024
)
member WriteAllTextAsync :
        text : string *
        encoding : Encoding *
        ?bufferSize : int
(* Defaults:
        let _bufferSize = defaultArg bufferSize 1024
*)
-> Task
member WriteAllTextAsync :
        text : string *
        encoding : Encoding *
        ?bufferSize : int
(* Defaults:
        let _bufferSize = defaultArg bufferSize 1024
*)
-> Task

Parameters

text
Type: Online System String
encoding
Type: Online System.Text Encoding
bufferSize (Optional)
Type: Online System Int32

Return Value

Type: Online Task
See Also
FileSystemFile Class
FileSystemFile Members
WriteAllTextAsync Overload
NFX.IO.FileSystem Namespace


FileSystemFile Properties

FileSystemFile Properties NFX Class Library

The FileSystemFile type exposes the following members.
Properties
 | Name | Description
Public property | CreationTimestamp | Gets/sets UTC creation timestamp (Inherited from FileSystemSessionItem.)
Public property | CreationUser | Gets the user who created this item (Inherited from FileSystemSessionItem.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | FileStream | Returns a stream usable for file content access. If the file has not opened stream yet it will be opened and cached
Public property | FileSystem | Returns filesystem - this is a shortcut to Session.FileSystem (Inherited from FileSystemSessionItem.)
Public property | Handle | Returns file system handle for this entity (Inherited from FileSystemSessionItem.)
Public property | IsReadOnly | Indicates whether this item can change and file system supports modifications (Inherited from FileSystemSessionItem.)
Public property | LastAccessTimestamp | Gets/sets UTC last access timestamp (Inherited from FileSystemSessionItem.)
Public property | LastAccessUser | Gets the last user who accessed the item (Inherited from FileSystemSessionItem.)
Public property | MetadataStream | Returns item metadata stream (Inherited from FileSystemSessionItem.)
Public property | ModificationTimestamp | Gets/sets UTC modification timestamp (Inherited from FileSystemSessionItem.)
Public property | ModificationUser | Gets the user who modified this item (Inherited from FileSystemSessionItem.)
Public property | Modified | Indicates whether anything has changed since last transaction has started (Inherited from FileSystemSessionItem.)
Public property | Name | (Inherited from FileSystemSessionItem.)
Public property | ParentPath | Returns path to directory that contains this item (Inherited from FileSystemSessionItem.)
Public property | Path | Returns an absolute path for this item (Inherited from FileSystemSessionItem.)
Public property | PermissionsStream | Returns item permissions stream (Inherited from FileSystemSessionItem.)
Public property | ReadOnly | Gets/sets readonly attribute (Inherited from FileSystemSessionItem.)
Public property | Session | Returns session through which this object was obtained (Inherited from FileSystemSessionItem.)
Public property | Size | Returns the byte size of the item, depending on implementation this property may return approximate sizes for files and directories (i.e in distributed systems) (Inherited from FileSystemSessionItem.)
Back to Top
See Also
FileSystemFile Class
NFX.IO.FileSystem Namespace


FileSystemFile.FileStream Property

FileSystemFile FileStream Property NFX Class Library

Returns a stream usable for file content access. If the file has not opened stream yet it will be opened and cached

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSystemStream FileStream { get; }
public FileSystemStream FileStream { get; }
Public ReadOnly Property FileStream As FileSystemStream
    Get
Public ReadOnly Property FileStream As FileSystemStream
    Get
public:
property FileSystemStream^ FileStream {
    FileSystemStream^ get ();
}
public:
property FileSystemStream^ FileStream {
    FileSystemStream^ get ();
}
member FileStream : FileSystemStream with get
member FileStream : FileSystemStream with get

Property Value

Type: FileSystemStream
See Also
FileSystemFile Class
FileSystemFile Members
NFX.IO.FileSystem Namespace


FileSystemSession Class

FileSystemSession Class NFX Class Library

Represents a user-impersonated session of working with a file system. This class is NOT thread-safe
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.IO.FileSystem FileSystemSession
NFX.IO.FileSystem.GoogleDrive.V2 GoogleDriveSession
NFX.IO.FileSystem.S3.V4 S3V4FileSystemSession
NFX.IO.FileSystem.SVN SVNFileSystemSession

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class FileSystemSession : DisposableObject,
    INamed
public class FileSystemSession : DisposableObject,
    INamed
Public Class FileSystemSession
    Inherits DisposableObject
    Implements INamed
Public Class FileSystemSession
    Inherits DisposableObject
    Implements INamed
public ref class FileSystemSession : public DisposableObject,
    INamed
public ref class FileSystemSession : public DisposableObject,
    INamed
type FileSystemSession =
    class
        inherit DisposableObject
        interface INamed
    end
type FileSystemSession =
    class
        inherit DisposableObject
        interface INamed
    end
See Also
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession Members

FileSystemSession Members NFX Class Library

The FileSystemSession type exposes the following members.
Constructors
 | Name | Description
Protected method | FileSystemSession | Starts new file system session
Back to Top
Methods
 | Name | Description
Public method | BeginTransaction | Starts a transaction returning its' transaction handle object, otherwise does nothing
Public method | BeginTransactionAsync | Async version of BeginTransaction
Public method | CommitTransaction | Commits active transaction, does nothing otherwise
Public method | CommitTransactionAsync | Async version of CommitTransaction
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetItemAsync | Async version of [P:Item(string)]
Public method | GetLatestVersionAsync | Async version of [P:LatestVersion]
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetVersions | Returns specified number of versions going back from the specific version. This call is thread-safe
Public method | GetVersionsAsync | Async version of GetVersions(IFileSystemVersion, Int32)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RollbackTransaction | Cancels active transaction changes, does nothing otherwise
Public method | RollbackTransactionAsync | Async version of RollbackTransaction
Public method | SetFileSystemVersionAsync | Async version of [P:Version]
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | ValidateConnectParams |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_FileSystem |
Protected field | m_Handle |
Protected field | m_Items |
Protected field | m_Name |
Protected field | m_TransactionHandle |
Protected field | m_User |
Back to Top
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | FileSystem | Returns file system instance that this session operates under
Public property | Handle | Returns file system handle for this session
Public property | Item | Navigates to the specified path
Public property | Items | Returns file system items initialized through this session
Public property | LatestVersion | Returns latest version for file systems that support versioning, null otherwise
Public property | Name | Returns session name
Public property | SecurityManager | Returns security manager that services this file system session. This may be useful in cases when file system implements its own permission structure and user directory
Public property | TransactionHandle | Returns transaction object if transaction has been started or null
Public property | UniqueSequenceProvider | Returns unique sequence provider for the system or null if it is not supported
Public property | User | Returns user that this file system session is for
Public property | Version | Gets/sets version of the file system that this session works against (a changeset that session "sees")
Back to Top
See Also
FileSystemSession Class
NFX.IO.FileSystem Namespace


FileSystemSession Constructor

FileSystemSession Constructor NFX Class Library

Starts new file system session

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal FileSystemSession(
    FileSystem fs,
    IFileSystemHandle handle,
    FileSystemSessionConnectParams cParams
)
protected internal FileSystemSession(
    FileSystem fs,
    IFileSystemHandle handle,
    FileSystemSessionConnectParams cParams
)
Protected Friend Sub New (
    fs As FileSystem,
    handle As IFileSystemHandle,
    cParams As FileSystemSessionConnectParams
)
Protected Friend Sub New (
    fs As FileSystem,
    handle As IFileSystemHandle,
    cParams As FileSystemSessionConnectParams
)
protected public:
FileSystemSession(
    FileSystem^ fs,
    IFileSystemHandle^ handle,
    FileSystemSessionConnectParams^ cParams
)
protected public:
FileSystemSession(
    FileSystem^ fs,
    IFileSystemHandle^ handle,
    FileSystemSessionConnectParams^ cParams
)
new :
        fs : FileSystem *
        handle : IFileSystemHandle *
        cParams : FileSystemSessionConnectParams -> FileSystemSession
new :
        fs : FileSystem *
        handle : IFileSystemHandle *
        cParams : FileSystemSessionConnectParams -> FileSystemSession

Parameters

fs
Type: NFX.IO.FileSystem FileSystem
handle
Type: NFX.IO.FileSystem IFileSystemHandle
cParams
Type: NFX.IO.FileSystem FileSystemSessionConnectParams
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession Fields

FileSystemSession Fields NFX Class Library

The FileSystemSession type exposes the following members.
Fields
 | Name | Description
Protected field | m_FileSystem |
Protected field | m_Handle |
Protected field | m_Items |
Protected field | m_Name |
Protected field | m_TransactionHandle |
Protected field | m_User |
Back to Top
See Also
FileSystemSession Class
NFX.IO.FileSystem Namespace


FileSystemSession.m_FileSystem Field

FileSystemSession m_FileSystem Field NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected readonly FileSystem m_FileSystem
protected readonly FileSystem m_FileSystem
Protected ReadOnly m_FileSystem As FileSystem
Protected ReadOnly m_FileSystem As FileSystem
protected:
initonly FileSystem^ m_FileSystem
protected:
initonly FileSystem^ m_FileSystem
val m_FileSystem: FileSystem
val m_FileSystem: FileSystem

Field Value

Type: FileSystem
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession.m_Handle Field

FileSystemSession m_Handle Field NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected readonly IFileSystemHandle m_Handle
protected readonly IFileSystemHandle m_Handle
Protected ReadOnly m_Handle As IFileSystemHandle
Protected ReadOnly m_Handle As IFileSystemHandle
protected:
initonly IFileSystemHandle^ m_Handle
protected:
initonly IFileSystemHandle^ m_Handle
val m_Handle: IFileSystemHandle
val m_Handle: IFileSystemHandle

Field Value

Type: IFileSystemHandle
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession.m_Items Field

FileSystemSession m_Items Field NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal readonly List<FileSystemSessionItem> m_Items
protected internal readonly List<FileSystemSessionItem> m_Items
Protected Friend ReadOnly m_Items As List(Of FileSystemSessionItem)
Protected Friend ReadOnly m_Items As List(Of FileSystemSessionItem)
protected public:
initonly List<FileSystemSessionItem^>^ m_Items
protected public:
initonly List<FileSystemSessionItem^>^ m_Items
val m_Items: List<FileSystemSessionItem>
val m_Items: List<FileSystemSessionItem>

Field Value

Type: Online List FileSystemSessionItem
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession.m_Name Field

FileSystemSession m_Name Field NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected readonly string m_Name
protected readonly string m_Name
Protected ReadOnly m_Name As String
Protected ReadOnly m_Name As String
protected:
initonly String^ m_Name
protected:
initonly String^ m_Name
val m_Name: string
val m_Name: string

Field Value

Type: Online String
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession.m_TransactionHandle Field

FileSystemSession m_TransactionHandle Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal IFileSystemTransactionHandle m_TransactionHandle
protected internal IFileSystemTransactionHandle m_TransactionHandle
Protected Friend m_TransactionHandle As IFileSystemTransactionHandle
Protected Friend m_TransactionHandle As IFileSystemTransactionHandle
protected public:
IFileSystemTransactionHandle^ m_TransactionHandle
protected public:
IFileSystemTransactionHandle^ m_TransactionHandle
val mutable m_TransactionHandle: IFileSystemTransactionHandle
val mutable m_TransactionHandle: IFileSystemTransactionHandle

Field Value

Type: IFileSystemTransactionHandle
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession.m_User Field

FileSystemSession m_User Field NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected readonly User m_User
protected readonly User m_User
Protected ReadOnly m_User As User
Protected ReadOnly m_User As User
protected:
initonly User^ m_User
protected:
initonly User^ m_User
val m_User: User
val m_User: User

Field Value

Type: User
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession Methods

FileSystemSession Methods NFX Class Library

The FileSystemSession type exposes the following members.
Methods
 | Name | Description
Public method | BeginTransaction | Starts a transaction returning its' transaction handle object, otherwise does nothing
Public method | BeginTransactionAsync | Async version of BeginTransaction
Public method | CommitTransaction | Commits active transaction, does nothing otherwise
Public method | CommitTransactionAsync | Async version of CommitTransaction
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetItemAsync | Async version of [P:Item(string)]
Public method | GetLatestVersionAsync | Async version of [P:LatestVersion]
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetVersions | Returns specified number of versions going back from the specific version. This call is thread-safe
Public method | GetVersionsAsync | Async version of GetVersions(IFileSystemVersion, Int32)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RollbackTransaction | Cancels active transaction changes, does nothing otherwise
Public method | RollbackTransactionAsync | Async version of RollbackTransaction
Public method | SetFileSystemVersionAsync | Async version of [P:Version]
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | ValidateConnectParams |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
FileSystemSession Class
NFX.IO.FileSystem Namespace


FileSystemSession.BeginTransaction Method

FileSystemSession BeginTransaction Method NFX Class Library

Starts a transaction returning its' transaction handle object, otherwise does nothing

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IFileSystemTransactionHandle BeginTransaction()
public IFileSystemTransactionHandle BeginTransaction()
Public Function BeginTransaction As IFileSystemTransactionHandle
Public Function BeginTransaction As IFileSystemTransactionHandle
public:
IFileSystemTransactionHandle^ BeginTransaction()
public:
IFileSystemTransactionHandle^ BeginTransaction()
member BeginTransaction : unit -> IFileSystemTransactionHandle
member BeginTransaction : unit -> IFileSystemTransactionHandle

Return Value

Type: IFileSystemTransactionHandle
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession.BeginTransactionAsync Method

FileSystemSession BeginTransactionAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of BeginTransaction

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<IFileSystemTransactionHandle> BeginTransactionAsync()
public Task<IFileSystemTransactionHandle> BeginTransactionAsync()
Public Function BeginTransactionAsync As Task(Of IFileSystemTransactionHandle)
Public Function BeginTransactionAsync As Task(Of IFileSystemTransactionHandle)
public:
Task<IFileSystemTransactionHandle^>^ BeginTransactionAsync()
public:
Task<IFileSystemTransactionHandle^>^ BeginTransactionAsync()
member BeginTransactionAsync : unit -> Task<IFileSystemTransactionHandle>
member BeginTransactionAsync : unit -> Task<IFileSystemTransactionHandle>

Return Value

Type: Online Task IFileSystemTransactionHandle
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession.CommitTransaction Method

FileSystemSession CommitTransaction Method NFX Class Library

Commits active transaction, does nothing otherwise

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CommitTransaction()
public void CommitTransaction()
Public Sub CommitTransaction
Public Sub CommitTransaction
public:
void CommitTransaction()
public:
void CommitTransaction()
member CommitTransaction : unit -> unit
member CommitTransaction : unit -> unit
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession.CommitTransactionAsync Method

FileSystemSession CommitTransactionAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of CommitTransaction

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task CommitTransactionAsync()
public Task CommitTransactionAsync()
Public Function CommitTransactionAsync As Task
Public Function CommitTransactionAsync As Task
public:
Task^ CommitTransactionAsync()
public:
Task^ CommitTransactionAsync()
member CommitTransactionAsync : unit -> Task
member CommitTransactionAsync : unit -> Task

Return Value

Type: Online Task
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession.Destructor Method

FileSystemSession Destructor Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession.GetItemAsync Method

FileSystemSession GetItemAsync Method NFX Class Library

Async version of [P:Item(string)]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<FileSystemSessionItem> GetItemAsync(
    string path
)
public Task<FileSystemSessionItem> GetItemAsync(
    string path
)
Public Function GetItemAsync (
    path As String
) As Task(Of FileSystemSessionItem)
Public Function GetItemAsync (
    path As String
) As Task(Of FileSystemSessionItem)
public:
Task<FileSystemSessionItem^>^ GetItemAsync(
    String^ path
)
public:
Task<FileSystemSessionItem^>^ GetItemAsync(
    String^ path
)
member GetItemAsync :
        path : string -> Task<FileSystemSessionItem>
member GetItemAsync :
        path : string -> Task<FileSystemSessionItem>

Parameters

path
Type: Online System String

Return Value

Type: Online Task FileSystemSessionItem
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession.GetLatestVersionAsync Method

FileSystemSession GetLatestVersionAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of [P:LatestVersion]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Task<IFileSystemVersion> GetLatestVersionAsync()
public virtual Task<IFileSystemVersion> GetLatestVersionAsync()
Public Overridable Function GetLatestVersionAsync As Task(Of IFileSystemVersion)
Public Overridable Function GetLatestVersionAsync As Task(Of IFileSystemVersion)
public:
virtual Task<IFileSystemVersion^>^ GetLatestVersionAsync()
public:
virtual Task<IFileSystemVersion^>^ GetLatestVersionAsync()
abstract GetLatestVersionAsync : unit -> Task<IFileSystemVersion>
override GetLatestVersionAsync : unit -> Task<IFileSystemVersion>
abstract GetLatestVersionAsync : unit -> Task<IFileSystemVersion>
override GetLatestVersionAsync : unit -> Task<IFileSystemVersion>

Return Value

Type: Online Task IFileSystemVersion
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession.GetVersions Method

FileSystemSession GetVersions Method NFX Class Library

Returns specified number of versions going back from the specific version. This call is thread-safe

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IEnumerable<IFileSystemVersion> GetVersions(
    IFileSystemVersion from,
    int countBack
)
public virtual IEnumerable<IFileSystemVersion> GetVersions(
    IFileSystemVersion from,
    int countBack
)
Public Overridable Function GetVersions (
    from As IFileSystemVersion,
    countBack As Integer
) As IEnumerable(Of IFileSystemVersion)
Public Overridable Function GetVersions (
    from As IFileSystemVersion,
    countBack As Integer
) As IEnumerable(Of IFileSystemVersion)
public:
virtual IEnumerable<IFileSystemVersion^>^ GetVersions(
    IFileSystemVersion^ from,
    int countBack
)
public:
virtual IEnumerable<IFileSystemVersion^>^ GetVersions(
    IFileSystemVersion^ from,
    int countBack
)
abstract GetVersions :
        from : IFileSystemVersion *
        countBack : int -> IEnumerable<IFileSystemVersion>
override GetVersions :
        from : IFileSystemVersion *
        countBack : int -> IEnumerable<IFileSystemVersion>
abstract GetVersions :
        from : IFileSystemVersion *
        countBack : int -> IEnumerable<IFileSystemVersion>
override GetVersions :
        from : IFileSystemVersion *
        countBack : int -> IEnumerable<IFileSystemVersion>

Parameters

from
Type: NFX.IO.FileSystem IFileSystemVersion
countBack
Type: Online System Int32

Return Value

Type: Online IEnumerable IFileSystemVersion
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession.GetVersionsAsync Method

FileSystemSession GetVersionsAsync Method NFX Class Library

Async version of GetVersions(IFileSystemVersion, Int32)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Task<IEnumerable<IFileSystemVersion>> GetVersionsAsync(
    IFileSystemVersion from,
    int countBack
)
public virtual Task<IEnumerable<IFileSystemVersion>> GetVersionsAsync(
    IFileSystemVersion from,
    int countBack
)
Public Overridable Function GetVersionsAsync (
    from As IFileSystemVersion,
    countBack As Integer
) As Task(Of IEnumerable(Of IFileSystemVersion))
Public Overridable Function GetVersionsAsync (
    from As IFileSystemVersion,
    countBack As Integer
) As Task(Of IEnumerable(Of IFileSystemVersion))
public:
virtual Task<IEnumerable<IFileSystemVersion^>^>^ GetVersionsAsync(
    IFileSystemVersion^ from,
    int countBack
)
public:
virtual Task<IEnumerable<IFileSystemVersion^>^>^ GetVersionsAsync(
    IFileSystemVersion^ from,
    int countBack
)
abstract GetVersionsAsync :
        from : IFileSystemVersion *
        countBack : int -> Task<IEnumerable<IFileSystemVersion>>
override GetVersionsAsync :
        from : IFileSystemVersion *
        countBack : int -> Task<IEnumerable<IFileSystemVersion>>
abstract GetVersionsAsync :
        from : IFileSystemVersion *
        countBack : int -> Task<IEnumerable<IFileSystemVersion>>
override GetVersionsAsync :
        from : IFileSystemVersion *
        countBack : int -> Task<IEnumerable<IFileSystemVersion>>

Parameters

from
Type: NFX.IO.FileSystem IFileSystemVersion
countBack
Type: Online System Int32

Return Value

Type: Online Task Online IEnumerable IFileSystemVersion
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession.RollbackTransaction Method

FileSystemSession RollbackTransaction Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Cancels active transaction changes, does nothing otherwise

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RollbackTransaction()
public void RollbackTransaction()
Public Sub RollbackTransaction
Public Sub RollbackTransaction
public:
void RollbackTransaction()
public:
void RollbackTransaction()
member RollbackTransaction : unit -> unit
member RollbackTransaction : unit -> unit
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession.RollbackTransactionAsync Method

FileSystemSession RollbackTransactionAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of RollbackTransaction

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task RollbackTransactionAsync()
public Task RollbackTransactionAsync()
Public Function RollbackTransactionAsync As Task
Public Function RollbackTransactionAsync As Task
public:
Task^ RollbackTransactionAsync()
public:
Task^ RollbackTransactionAsync()
member RollbackTransactionAsync : unit -> Task
member RollbackTransactionAsync : unit -> Task

Return Value

Type: Online Task
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession.SetFileSystemVersionAsync Method

FileSystemSession SetFileSystemVersionAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of [P:Version]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Task SetFileSystemVersionAsync(
    IFileSystemVersion version
)
public virtual Task SetFileSystemVersionAsync(
    IFileSystemVersion version
)
Public Overridable Function SetFileSystemVersionAsync (
    version As IFileSystemVersion
) As Task
Public Overridable Function SetFileSystemVersionAsync (
    version As IFileSystemVersion
) As Task
public:
virtual Task^ SetFileSystemVersionAsync(
    IFileSystemVersion^ version
)
public:
virtual Task^ SetFileSystemVersionAsync(
    IFileSystemVersion^ version
)
abstract SetFileSystemVersionAsync :
        version : IFileSystemVersion -> Task
override SetFileSystemVersionAsync :
        version : IFileSystemVersion -> Task
abstract SetFileSystemVersionAsync :
        version : IFileSystemVersion -> Task
override SetFileSystemVersionAsync :
        version : IFileSystemVersion -> Task

Parameters

version
Type: NFX.IO.FileSystem IFileSystemVersion

Return Value

Type: Online Task
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession.ValidateConnectParams Method

FileSystemSession ValidateConnectParams Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void ValidateConnectParams(
    FileSystemSessionConnectParams cParams
)
protected virtual void ValidateConnectParams(
    FileSystemSessionConnectParams cParams
)
Protected Overridable Sub ValidateConnectParams (
    cParams As FileSystemSessionConnectParams
)
Protected Overridable Sub ValidateConnectParams (
    cParams As FileSystemSessionConnectParams
)
protected:
virtual void ValidateConnectParams(
    FileSystemSessionConnectParams^ cParams
)
protected:
virtual void ValidateConnectParams(
    FileSystemSessionConnectParams^ cParams
)
abstract ValidateConnectParams :
        cParams : FileSystemSessionConnectParams -> unit
override ValidateConnectParams :
        cParams : FileSystemSessionConnectParams -> unit
abstract ValidateConnectParams :
        cParams : FileSystemSessionConnectParams -> unit
override ValidateConnectParams :
        cParams : FileSystemSessionConnectParams -> unit

Parameters

cParams
Type: NFX.IO.FileSystem FileSystemSessionConnectParams
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession Properties

FileSystemSession Properties NFX Class Library

The FileSystemSession type exposes the following members.
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | FileSystem | Returns file system instance that this session operates under
Public property | Handle | Returns file system handle for this session
Public property | Item | Navigates to the specified path
Public property | Items | Returns file system items initialized through this session
Public property | LatestVersion | Returns latest version for file systems that support versioning, null otherwise
Public property | Name | Returns session name
Public property | SecurityManager | Returns security manager that services this file system session. This may be useful in cases when file system implements its own permission structure and user directory
Public property | TransactionHandle | Returns transaction object if transaction has been started or null
Public property | UniqueSequenceProvider | Returns unique sequence provider for the system or null if it is not supported
Public property | User | Returns user that this file system session is for
Public property | Version | Gets/sets version of the file system that this session works against (a changeset that session "sees")
Back to Top
See Also
FileSystemSession Class
NFX.IO.FileSystem Namespace


FileSystemSession.FileSystem Property

FileSystemSession FileSystem Property NFX Class Library

Returns file system instance that this session operates under

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSystem FileSystem { get; }
public FileSystem FileSystem { get; }
Public ReadOnly Property FileSystem As FileSystem
    Get
Public ReadOnly Property FileSystem As FileSystem
    Get
public:
property FileSystem^ FileSystem {
    FileSystem^ get ();
}
public:
property FileSystem^ FileSystem {
    FileSystem^ get ();
}
member FileSystem : FileSystem with get
member FileSystem : FileSystem with get

Property Value

Type: FileSystem
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession.Handle Property

FileSystemSession Handle Property NFX Class Library

Returns file system handle for this session

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IFileSystemHandle Handle { get; }
public IFileSystemHandle Handle { get; }
Public ReadOnly Property Handle As IFileSystemHandle
    Get
Public ReadOnly Property Handle As IFileSystemHandle
    Get
public:
property IFileSystemHandle^ Handle {
    IFileSystemHandle^ get ();
}
public:
property IFileSystemHandle^ Handle {
    IFileSystemHandle^ get ();
}
member Handle : IFileSystemHandle with get
member Handle : IFileSystemHandle with get

Property Value

Type: IFileSystemHandle
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession.Item Property

FileSystemSession Item Property NFX Class Library

Navigates to the specified path

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSystemSessionItem this[
    string path
] { get; }
public FileSystemSessionItem this[
    string path
] { get; }
Public ReadOnly Default Property Item (
    path As String
) As FileSystemSessionItem
    Get
Public ReadOnly Default Property Item (
    path As String
) As FileSystemSessionItem
    Get
public:
property FileSystemSessionItem^ default[String^ path] {
    FileSystemSessionItem^ get (String^ path);
}
public:
property FileSystemSessionItem^ default[String^ path] {
    FileSystemSessionItem^ get (String^ path);
}
member Item : FileSystemSessionItem with get
member Item : FileSystemSessionItem with get

Parameters

path
Type: Online System String
Path to navigate to

Return Value

Type: FileSystemSessionItem
FileSystemSessionItem instance - a directory or a file or null if it does not exist
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession.Items Property

FileSystemSession Items Property NFX Class Library

Returns file system items initialized through this session

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<FileSystemSessionItem> Items { get; }
public IEnumerable<FileSystemSessionItem> Items { get; }
Public ReadOnly Property Items As IEnumerable(Of FileSystemSessionItem)
    Get
Public ReadOnly Property Items As IEnumerable(Of FileSystemSessionItem)
    Get
public:
property IEnumerable<FileSystemSessionItem^>^ Items {
    IEnumerable<FileSystemSessionItem^>^ get ();
}
public:
property IEnumerable<FileSystemSessionItem^>^ Items {
    IEnumerable<FileSystemSessionItem^>^ get ();
}
member Items : IEnumerable<FileSystemSessionItem> with get
member Items : IEnumerable<FileSystemSessionItem> with get

Property Value

Type: Online IEnumerable FileSystemSessionItem
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession.LatestVersion Property

FileSystemSession LatestVersion Property NFX Class Library

Returns latest version for file systems that support versioning, null otherwise

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IFileSystemVersion LatestVersion { get; }
public virtual IFileSystemVersion LatestVersion { get; }
Public Overridable ReadOnly Property LatestVersion As IFileSystemVersion
    Get
Public Overridable ReadOnly Property LatestVersion As IFileSystemVersion
    Get
public:
virtual property IFileSystemVersion^ LatestVersion {
    IFileSystemVersion^ get ();
}
public:
virtual property IFileSystemVersion^ LatestVersion {
    IFileSystemVersion^ get ();
}
abstract LatestVersion : IFileSystemVersion with get
override LatestVersion : IFileSystemVersion with get
abstract LatestVersion : IFileSystemVersion with get
override LatestVersion : IFileSystemVersion with get

Property Value

Type: IFileSystemVersion
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession.Name Property

FileSystemSession Name Property NFX Class Library

Returns session name

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession.SecurityManager Property

FileSystemSession SecurityManager Property NFX Class Library

Returns security manager that services this file system session. This may be useful in cases when file system implements its own permission structure and user directory

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ISecurityManager SecurityManager { get; }
public ISecurityManager SecurityManager { get; }
Public ReadOnly Property SecurityManager As ISecurityManager
    Get
Public ReadOnly Property SecurityManager As ISecurityManager
    Get
public:
property ISecurityManager^ SecurityManager {
    ISecurityManager^ get ();
}
public:
property ISecurityManager^ SecurityManager {
    ISecurityManager^ get ();
}
member SecurityManager : ISecurityManager with get
member SecurityManager : ISecurityManager with get

Property Value

Type: ISecurityManager
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession.TransactionHandle Property

FileSystemSession TransactionHandle Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns transaction object if transaction has been started or null

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IFileSystemTransactionHandle TransactionHandle { get; }
public IFileSystemTransactionHandle TransactionHandle { get; }
Public ReadOnly Property TransactionHandle As IFileSystemTransactionHandle
    Get
Public ReadOnly Property TransactionHandle As IFileSystemTransactionHandle
    Get
public:
property IFileSystemTransactionHandle^ TransactionHandle {
    IFileSystemTransactionHandle^ get ();
}
public:
property IFileSystemTransactionHandle^ TransactionHandle {
    IFileSystemTransactionHandle^ get ();
}
member TransactionHandle : IFileSystemTransactionHandle with get
member TransactionHandle : IFileSystemTransactionHandle with get

Property Value

Type: IFileSystemTransactionHandle
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession.UniqueSequenceProvider Property

FileSystemSession UniqueSequenceProvider Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns unique sequence provider for the system or null if it is not supported

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IUniqueSequenceProvider UniqueSequenceProvider { get; }
public IUniqueSequenceProvider UniqueSequenceProvider { get; }
Public ReadOnly Property UniqueSequenceProvider As IUniqueSequenceProvider
    Get
Public ReadOnly Property UniqueSequenceProvider As IUniqueSequenceProvider
    Get
public:
property IUniqueSequenceProvider^ UniqueSequenceProvider {
    IUniqueSequenceProvider^ get ();
}
public:
property IUniqueSequenceProvider^ UniqueSequenceProvider {
    IUniqueSequenceProvider^ get ();
}
member UniqueSequenceProvider : IUniqueSequenceProvider with get
member UniqueSequenceProvider : IUniqueSequenceProvider with get

Property Value

Type: IUniqueSequenceProvider
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession.User Property

FileSystemSession User Property NFX Class Library

Returns user that this file system session is for

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public User User { get; }
public User User { get; }
Public ReadOnly Property User As User
    Get
Public ReadOnly Property User As User
    Get
public:
property User^ User {
    User^ get ();
}
public:
property User^ User {
    User^ get ();
}
member User : User with get
member User : User with get

Property Value

Type: User
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSession.Version Property

FileSystemSession Version Property NFX Class Library

Gets/sets version of the file system that this session works against (a changeset that session "sees")

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IFileSystemVersion Version { get; set; }
public virtual IFileSystemVersion Version { get; set; }
Public Overridable Property Version As IFileSystemVersion
    Get
    Set
Public Overridable Property Version As IFileSystemVersion
    Get
    Set
public:
virtual property IFileSystemVersion^ Version {
    IFileSystemVersion^ get ();
    void set (IFileSystemVersion^ value);
}
public:
virtual property IFileSystemVersion^ Version {
    IFileSystemVersion^ get ();
    void set (IFileSystemVersion^ value);
}
abstract Version : IFileSystemVersion with get, set
override Version : IFileSystemVersion with get, set
abstract Version : IFileSystemVersion with get, set
override Version : IFileSystemVersion with get, set

Property Value

Type: IFileSystemVersion
See Also
FileSystemSession Class
FileSystemSession Members
NFX.IO.FileSystem Namespace


FileSystemSessionConnectParams Class

FileSystemSessionConnectParams Class NFX Class Library

Provides parameters for new sessions establishment
Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem FileSystemSessionConnectParams
NFX.IO.FileSystem.GoogleDrive GoogleDriveParameters
NFX.IO.FileSystem.S3.V4 S3V4FileSystemSessionConnectParams
NFX.IO.FileSystem.SVN SVNFileSystemSessionConnectParams

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class FileSystemSessionConnectParams : INamed,
    IConfigurable
public class FileSystemSessionConnectParams : INamed,
    IConfigurable
Public Class FileSystemSessionConnectParams
    Implements INamed, IConfigurable
Public Class FileSystemSessionConnectParams
    Implements INamed, IConfigurable
public ref class FileSystemSessionConnectParams : INamed,
    IConfigurable
public ref class FileSystemSessionConnectParams : INamed,
    IConfigurable
type FileSystemSessionConnectParams =
    class
        interface INamed
        interface IConfigurable
    end
type FileSystemSessionConnectParams =
    class
        interface INamed
        interface IConfigurable
    end
See Also
FileSystemSessionConnectParams Members
NFX.IO.FileSystem Namespace


FileSystemSessionConnectParams Members

FileSystemSessionConnectParams Members NFX Class Library

The FileSystemSessionConnectParams type exposes the following members.
Constructors
 | Name | Description
Public method | FileSystemSessionConnectParams | Initializes a new instance of the FileSystemSessionConnectParams class
Public method | FileSystemSessionConnectParams(IConfigSectionNode) | Initializes a new instance of the FileSystemSessionConnectParams class
Public method | FileSystemSessionConnectParams(String, String) | Initializes a new instance of the FileSystemSessionConnectParams class
Back to Top
Methods
 | Name | Description
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Make TParams (IConfigSectionNode) |
 | Make TParams (String, String) |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name |
Public property | User |
Public property | Version |
Back to Top
See Also
FileSystemSessionConnectParams Class
NFX.IO.FileSystem Namespace


FileSystemSessionConnectParams Constructor

FileSystemSessionConnectParams Constructor NFX Class Library

Overload List
 | Name | Description
Public method | FileSystemSessionConnectParams | Initializes a new instance of the FileSystemSessionConnectParams class
Public method | FileSystemSessionConnectParams(IConfigSectionNode) | Initializes a new instance of the FileSystemSessionConnectParams class
Public method | FileSystemSessionConnectParams(String, String) | Initializes a new instance of the FileSystemSessionConnectParams class
Back to Top
See Also
FileSystemSessionConnectParams Class
FileSystemSessionConnectParams Members
NFX.IO.FileSystem Namespace


FileSystemSessionConnectParams Constructor

FileSystemSessionConnectParams Constructor NFX Class Library

Initializes a new instance of the FileSystemSessionConnectParams class

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSystemSessionConnectParams()
public FileSystemSessionConnectParams()
Public Sub New
Public Sub New
public:
FileSystemSessionConnectParams()
public:
FileSystemSessionConnectParams()
new : unit -> FileSystemSessionConnectParams
new : unit -> FileSystemSessionConnectParams
See Also
FileSystemSessionConnectParams Class
FileSystemSessionConnectParams Members
FileSystemSessionConnectParams Overload
NFX.IO.FileSystem Namespace


FileSystemSessionConnectParams Constructor (IConfigSectionNode)

FileSystemSessionConnectParams Constructor (IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FileSystemSessionConnectParams class

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSystemSessionConnectParams(
    IConfigSectionNode node
)
public FileSystemSessionConnectParams(
    IConfigSectionNode node
)
Public Sub New (
    node As IConfigSectionNode
)
Public Sub New (
    node As IConfigSectionNode
)
public:
FileSystemSessionConnectParams(
    IConfigSectionNode^ node
)
public:
FileSystemSessionConnectParams(
    IConfigSectionNode^ node
)
new :
        node : IConfigSectionNode -> FileSystemSessionConnectParams
new :
        node : IConfigSectionNode -> FileSystemSessionConnectParams

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
FileSystemSessionConnectParams Class
FileSystemSessionConnectParams Members
FileSystemSessionConnectParams Overload
NFX.IO.FileSystem Namespace


FileSystemSessionConnectParams Constructor (String, String)

FileSystemSessionConnectParams Constructor (String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FileSystemSessionConnectParams class

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSystemSessionConnectParams(
    string connectString,
    string format = "laconf"
)
public FileSystemSessionConnectParams(
    string connectString,
    string format = "laconf"
)
Public Sub New (
    connectString As String,
    Optional format As String = "laconf"
)
Public Sub New (
    connectString As String,
    Optional format As String = "laconf"
)
public:
FileSystemSessionConnectParams(
    String^ connectString,
    String^ format = L"laconf"
)
public:
FileSystemSessionConnectParams(
    String^ connectString,
    String^ format = L"laconf"
)
new :
        connectString : string *
        ?format : string
(* Defaults:
        let _format = defaultArg format "laconf"
*)
-> FileSystemSessionConnectParams
new :
        connectString : string *
        ?format : string
(* Defaults:
        let _format = defaultArg format "laconf"
*)
-> FileSystemSessionConnectParams

Parameters

connectString
Type: Online System String
format (Optional)
Type: Online System String
See Also
FileSystemSessionConnectParams Class
FileSystemSessionConnectParams Members
FileSystemSessionConnectParams Overload
NFX.IO.FileSystem Namespace


FileSystemSessionConnectParams Methods

FileSystemSessionConnectParams Methods NFX Class Library

The FileSystemSessionConnectParams type exposes the following members.
Methods
 | Name | Description
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | Make TParams (IConfigSectionNode) |
 | Make TParams (String, String) |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
FileSystemSessionConnectParams Class
NFX.IO.FileSystem Namespace


FileSystemSessionConnectParams.Configure Method

FileSystemSessionConnectParams Configure Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Configure(
    IConfigSectionNode node
)
public virtual void Configure(
    IConfigSectionNode node
)
Public Overridable Sub Configure (
    node As IConfigSectionNode
)
Public Overridable Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
)
public:
virtual void Configure(
    IConfigSectionNode^ node
)
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
FileSystemSessionConnectParams Class
FileSystemSessionConnectParams Members
NFX.IO.FileSystem Namespace


FileSystemSessionConnectParams.Make Method

FileSystemSessionConnectParams Make Method NFX Class Library

Overload List
Name | Description
Make TParams (IConfigSectionNode) |
Make TParams (String, String) |
Back to Top
See Also
FileSystemSessionConnectParams Class
FileSystemSessionConnectParams Members
NFX.IO.FileSystem Namespace


FileSystemSessionConnectParams.Make(TParams) Method (IConfigSectionNode)

FileSystemSessionConnectParams Make TParams Method (IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TParams Make<TParams>(
    IConfigSectionNode node
)
where TParams : FileSystemSessionConnectParams
public static TParams Make<TParams>(
    IConfigSectionNode node
)
where TParams : FileSystemSessionConnectParams
Public Shared Function Make(Of TParams As FileSystemSessionConnectParams) (
    node As IConfigSectionNode
) As TParams
Public Shared Function Make(Of TParams As FileSystemSessionConnectParams) (
    node As IConfigSectionNode
) As TParams
public:
generic<typename TParams>
where TParams : FileSystemSessionConnectParams
static TParams Make(
    IConfigSectionNode^ node
)
public:
generic<typename TParams>
where TParams : FileSystemSessionConnectParams
static TParams Make(
    IConfigSectionNode^ node
)
static member Make :
        node : IConfigSectionNode -> 'TParams  when 'TParams : FileSystemSessionConnectParams
static member Make :
        node : IConfigSectionNode -> 'TParams  when 'TParams : FileSystemSessionConnectParams

Parameters

node
Type: NFX.Environment IConfigSectionNode
Type Parameters
TParams

Return Value

Type: TParams
See Also
FileSystemSessionConnectParams Class
FileSystemSessionConnectParams Members
Make Overload
NFX.IO.FileSystem Namespace


FileSystemSessionConnectParams.Make(TParams) Method (String, String)

FileSystemSessionConnectParams Make TParams Method (String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TParams Make<TParams>(
    string connectString,
    string format = "laconf"
)
where TParams : FileSystemSessionConnectParams
public static TParams Make<TParams>(
    string connectString,
    string format = "laconf"
)
where TParams : FileSystemSessionConnectParams
Public Shared Function Make(Of TParams As FileSystemSessionConnectParams) (
    connectString As String,
    Optional format As String = "laconf"
) As TParams
Public Shared Function Make(Of TParams As FileSystemSessionConnectParams) (
    connectString As String,
    Optional format As String = "laconf"
) As TParams
public:
generic<typename TParams>
where TParams : FileSystemSessionConnectParams
static TParams Make(
    String^ connectString,
    String^ format = L"laconf"
)
public:
generic<typename TParams>
where TParams : FileSystemSessionConnectParams
static TParams Make(
    String^ connectString,
    String^ format = L"laconf"
)
static member Make :
        connectString : string *
        ?format : string
(* Defaults:
        let _format = defaultArg format "laconf"
*)
-> 'TParams  when 'TParams : FileSystemSessionConnectParams
static member Make :
        connectString : string *
        ?format : string
(* Defaults:
        let _format = defaultArg format "laconf"
*)
-> 'TParams  when 'TParams : FileSystemSessionConnectParams

Parameters

connectString
Type: Online System String
format (Optional)
Type: Online System String
Type Parameters
TParams

Return Value

Type: TParams
See Also
FileSystemSessionConnectParams Class
FileSystemSessionConnectParams Members
Make Overload
NFX.IO.FileSystem Namespace


FileSystemSessionConnectParams Properties

FileSystemSessionConnectParams Properties NFX Class Library

The FileSystemSessionConnectParams type exposes the following members.
Properties
 | Name | Description
Public property | Name |
Public property | User |
Public property | Version |
Back to Top
See Also
FileSystemSessionConnectParams Class
NFX.IO.FileSystem Namespace


FileSystemSessionConnectParams.Name Property

FileSystemSessionConnectParams Name Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string Name { get; set; }
[ConfigAttribute]
public string Name { get; set; }
<ConfigAttribute>
Public Property Name As String
    Get
    Set
<ConfigAttribute>
Public Property Name As String
    Get
    Set
public:
[ConfigAttribute]
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
[ConfigAttribute]
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
[<ConfigAttribute>]
abstract Name : string with get, set
[<ConfigAttribute>]
override Name : string with get, set
[<ConfigAttribute>]
abstract Name : string with get, set
[<ConfigAttribute>]
override Name : string with get, set

Property Value

Type: Online String

Implements

INamed Name
See Also
FileSystemSessionConnectParams Class
FileSystemSessionConnectParams Members
NFX.IO.FileSystem Namespace


FileSystemSessionConnectParams.User Property

FileSystemSessionConnectParams User Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public User User { get; set; }
public User User { get; set; }
Public Property User As User
    Get
    Set
Public Property User As User
    Get
    Set
public:
property User^ User {
    User^ get ();
    void set (User^ value);
}
public:
property User^ User {
    User^ get ();
    void set (User^ value);
}
member User : User with get, set
member User : User with get, set

Property Value

Type: User
See Also
FileSystemSessionConnectParams Class
FileSystemSessionConnectParams Members
NFX.IO.FileSystem Namespace


FileSystemSessionConnectParams.Version Property

FileSystemSessionConnectParams Version Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IFileSystemVersion Version { get; set; }
public IFileSystemVersion Version { get; set; }
Public Property Version As IFileSystemVersion
    Get
    Set
Public Property Version As IFileSystemVersion
    Get
    Set
public:
property IFileSystemVersion^ Version {
    IFileSystemVersion^ get ();
    void set (IFileSystemVersion^ value);
}
public:
property IFileSystemVersion^ Version {
    IFileSystemVersion^ get ();
    void set (IFileSystemVersion^ value);
}
member Version : IFileSystemVersion with get, set
member Version : IFileSystemVersion with get, set

Property Value

Type: IFileSystemVersion
See Also
FileSystemSessionConnectParams Class
FileSystemSessionConnectParams Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem Class

FileSystemSessionItem Class NFX Class Library

Represents an abstraction for items kept in a file system - i.e. directories and files.This class is NOT thread-safe
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.IO.FileSystem FileSystemSessionItem
NFX.IO.FileSystem FileSystemDirectory
NFX.IO.FileSystem FileSystemFile

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class FileSystemSessionItem : DisposableObject,
    INamed
public abstract class FileSystemSessionItem : DisposableObject,
    INamed
Public MustInherit Class FileSystemSessionItem
    Inherits DisposableObject
    Implements INamed
Public MustInherit Class FileSystemSessionItem
    Inherits DisposableObject
    Implements INamed
public ref class FileSystemSessionItem abstract : public DisposableObject,
    INamed
public ref class FileSystemSessionItem abstract : public DisposableObject,
    INamed
[<AbstractClassAttribute>]
type FileSystemSessionItem =
    class
        inherit DisposableObject
        interface INamed
    end
[<AbstractClassAttribute>]
type FileSystemSessionItem =
    class
        inherit DisposableObject
        interface INamed
    end
See Also
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem Members

FileSystemSessionItem Members NFX Class Library

The FileSystemSessionItem type exposes the following members.
Constructors
 | Name | Description
Protected method | FileSystemSessionItem | Initializes a new instance of the FileSystemSessionItem class
Back to Top
Methods
 | Name | Description
Public method | CheckCanChange | Throws when item can not change
Public method | CheckCanChangeAsync | Async version of CheckCanChange
Public method | Delete | Deletes this item from file system
Public method | DeleteAsync | Async version of Delete
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetCreationUserAsync | Async version of [P:CreationUser]
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetLastAccessUserAsync | Async version of [P:LastAccessUser]
Public method | GetModificationUserAsync | Async version of [P:ModificationUser]
Public method | GetSizeAsync | Async version of [P:Size]
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Refresh | Refreshes the state represented by this item, i.e. this may re-read attributes from remote file system
Public method | RefreshAsync | Async version of Refresh
Public method | Rename | Renames an item. Check file system capabilities to see if renaming is supported
Public method | RenameAsync | Async version of Rename(String)
Public method | SetCreationTimestampAsync | Async version of [P:CreationTimestamp]
Public method | SetLastAccessTimestampAsync | Async version of [P:LastAccessTimestamp]
Public method | SetModificationTimestampAsync | Async version of [P:ModificationTimestamp]
Public method | SetReadOnlyAsync | Async version of [P:ReadOnly]
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_FileSystem |
Protected field | m_Handle |
Protected field | m_Modified |
Protected field | m_Session |
Back to Top
Properties
 | Name | Description
Public property | CreationTimestamp | Gets/sets UTC creation timestamp
Public property | CreationUser | Gets the user who created this item
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | FileSystem | Returns filesystem - this is a shortcut to Session.FileSystem
Public property | Handle | Returns file system handle for this entity
Public property | IsReadOnly | Indicates whether this item can change and file system supports modifications
Public property | LastAccessTimestamp | Gets/sets UTC last access timestamp
Public property | LastAccessUser | Gets the last user who accessed the item
Public property | MetadataStream | Returns item metadata stream
Public property | ModificationTimestamp | Gets/sets UTC modification timestamp
Public property | ModificationUser | Gets the user who modified this item
Public property | Modified | Indicates whether anything has changed since last transaction has started
Public property | Name |
Public property | ParentPath | Returns path to directory that contains this item
Public property | Path | Returns an absolute path for this item
Public property | PermissionsStream | Returns item permissions stream
Public property | ReadOnly | Gets/sets readonly attribute
Public property | Session | Returns session through which this object was obtained
Public property | Size | Returns the byte size of the item, depending on implementation this property may return approximate sizes for files and directories (i.e in distributed systems)
Back to Top
See Also
FileSystemSessionItem Class
NFX.IO.FileSystem Namespace


FileSystemSessionItem Constructor

FileSystemSessionItem Constructor NFX Class Library

Initializes a new instance of the FileSystemSessionItem class

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FileSystemSessionItem(
    FileSystemSession session,
    string parentPath,
    string name,
    IFileSystemHandle handle
)
protected FileSystemSessionItem(
    FileSystemSession session,
    string parentPath,
    string name,
    IFileSystemHandle handle
)
Protected Sub New (
    session As FileSystemSession,
    parentPath As String,
    name As String,
    handle As IFileSystemHandle
)
Protected Sub New (
    session As FileSystemSession,
    parentPath As String,
    name As String,
    handle As IFileSystemHandle
)
protected:
FileSystemSessionItem(
    FileSystemSession^ session,
    String^ parentPath,
    String^ name,
    IFileSystemHandle^ handle
)
protected:
FileSystemSessionItem(
    FileSystemSession^ session,
    String^ parentPath,
    String^ name,
    IFileSystemHandle^ handle
)
new :
        session : FileSystemSession *
        parentPath : string *
        name : string *
        handle : IFileSystemHandle -> FileSystemSessionItem
new :
        session : FileSystemSession *
        parentPath : string *
        name : string *
        handle : IFileSystemHandle -> FileSystemSessionItem

Parameters

session
Type: NFX.IO.FileSystem FileSystemSession
parentPath
Type: Online System String
name
Type: Online System String
handle
Type: NFX.IO.FileSystem IFileSystemHandle
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem Fields

FileSystemSessionItem Fields NFX Class Library

The FileSystemSessionItem type exposes the following members.
Fields
 | Name | Description
Protected field | m_FileSystem |
Protected field | m_Handle |
Protected field | m_Modified |
Protected field | m_Session |
Back to Top
See Also
FileSystemSessionItem Class
NFX.IO.FileSystem Namespace


FileSystemSessionItem.m_FileSystem Field

FileSystemSessionItem m_FileSystem Field NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected readonly FileSystem m_FileSystem
protected readonly FileSystem m_FileSystem
Protected ReadOnly m_FileSystem As FileSystem
Protected ReadOnly m_FileSystem As FileSystem
protected:
initonly FileSystem^ m_FileSystem
protected:
initonly FileSystem^ m_FileSystem
val m_FileSystem: FileSystem
val m_FileSystem: FileSystem

Field Value

Type: FileSystem
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.m_Handle Field

FileSystemSessionItem m_Handle Field NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected readonly IFileSystemHandle m_Handle
protected readonly IFileSystemHandle m_Handle
Protected ReadOnly m_Handle As IFileSystemHandle
Protected ReadOnly m_Handle As IFileSystemHandle
protected:
initonly IFileSystemHandle^ m_Handle
protected:
initonly IFileSystemHandle^ m_Handle
val m_Handle: IFileSystemHandle
val m_Handle: IFileSystemHandle

Field Value

Type: IFileSystemHandle
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.m_Modified Field

FileSystemSessionItem m_Modified Field NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal bool m_Modified
protected internal bool m_Modified
Protected Friend m_Modified As Boolean
Protected Friend m_Modified As Boolean
protected public:
bool m_Modified
protected public:
bool m_Modified
val mutable m_Modified: bool
val mutable m_Modified: bool

Field Value

Type: Online Boolean
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.m_Session Field

FileSystemSessionItem m_Session Field NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected readonly FileSystemSession m_Session
protected readonly FileSystemSession m_Session
Protected ReadOnly m_Session As FileSystemSession
Protected ReadOnly m_Session As FileSystemSession
protected:
initonly FileSystemSession^ m_Session
protected:
initonly FileSystemSession^ m_Session
val m_Session: FileSystemSession
val m_Session: FileSystemSession

Field Value

Type: FileSystemSession
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem Methods

FileSystemSessionItem Methods NFX Class Library

The FileSystemSessionItem type exposes the following members.
Methods
 | Name | Description
Public method | CheckCanChange | Throws when item can not change
Public method | CheckCanChangeAsync | Async version of CheckCanChange
Public method | Delete | Deletes this item from file system
Public method | DeleteAsync | Async version of Delete
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetCreationUserAsync | Async version of [P:CreationUser]
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetLastAccessUserAsync | Async version of [P:LastAccessUser]
Public method | GetModificationUserAsync | Async version of [P:ModificationUser]
Public method | GetSizeAsync | Async version of [P:Size]
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Refresh | Refreshes the state represented by this item, i.e. this may re-read attributes from remote file system
Public method | RefreshAsync | Async version of Refresh
Public method | Rename | Renames an item. Check file system capabilities to see if renaming is supported
Public method | RenameAsync | Async version of Rename(String)
Public method | SetCreationTimestampAsync | Async version of [P:CreationTimestamp]
Public method | SetLastAccessTimestampAsync | Async version of [P:LastAccessTimestamp]
Public method | SetModificationTimestampAsync | Async version of [P:ModificationTimestamp]
Public method | SetReadOnlyAsync | Async version of [P:ReadOnly]
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
FileSystemSessionItem Class
NFX.IO.FileSystem Namespace


FileSystemSessionItem.CheckCanChange Method

FileSystemSessionItem CheckCanChange Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Throws when item can not change

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CheckCanChange()
public void CheckCanChange()
Public Sub CheckCanChange
Public Sub CheckCanChange
public:
void CheckCanChange()
public:
void CheckCanChange()
member CheckCanChange : unit -> unit
member CheckCanChange : unit -> unit
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.CheckCanChangeAsync Method

FileSystemSessionItem CheckCanChangeAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of CheckCanChange

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task CheckCanChangeAsync()
public Task CheckCanChangeAsync()
Public Function CheckCanChangeAsync As Task
Public Function CheckCanChangeAsync As Task
public:
Task^ CheckCanChangeAsync()
public:
Task^ CheckCanChangeAsync()
member CheckCanChangeAsync : unit -> Task
member CheckCanChangeAsync : unit -> Task

Return Value

Type: Online Task
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.Delete Method

FileSystemSessionItem Delete Method NFX Class Library

Deletes this item from file system

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Delete()
public void Delete()
Public Sub Delete
Public Sub Delete
public:
void Delete()
public:
void Delete()
member Delete : unit -> unit
member Delete : unit -> unit
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.DeleteAsync Method

FileSystemSessionItem DeleteAsync Method NFX Class Library

Async version of Delete

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task DeleteAsync()
public Task DeleteAsync()
Public Function DeleteAsync As Task
Public Function DeleteAsync As Task
public:
Task^ DeleteAsync()
public:
Task^ DeleteAsync()
member DeleteAsync : unit -> Task
member DeleteAsync : unit -> Task

Return Value

Type: Online Task
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.Destructor Method

FileSystemSessionItem Destructor Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.GetCreationUserAsync Method

FileSystemSessionItem GetCreationUserAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of [P:CreationUser]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<User> GetCreationUserAsync()
public Task<User> GetCreationUserAsync()
Public Function GetCreationUserAsync As Task(Of User)
Public Function GetCreationUserAsync As Task(Of User)
public:
Task<User^>^ GetCreationUserAsync()
public:
Task<User^>^ GetCreationUserAsync()
member GetCreationUserAsync : unit -> Task<User>
member GetCreationUserAsync : unit -> Task<User>

Return Value

Type: Online Task User
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.GetLastAccessUserAsync Method

FileSystemSessionItem GetLastAccessUserAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of [P:LastAccessUser]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<User> GetLastAccessUserAsync()
public Task<User> GetLastAccessUserAsync()
Public Function GetLastAccessUserAsync As Task(Of User)
Public Function GetLastAccessUserAsync As Task(Of User)
public:
Task<User^>^ GetLastAccessUserAsync()
public:
Task<User^>^ GetLastAccessUserAsync()
member GetLastAccessUserAsync : unit -> Task<User>
member GetLastAccessUserAsync : unit -> Task<User>

Return Value

Type: Online Task User
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.GetModificationUserAsync Method

FileSystemSessionItem GetModificationUserAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of [P:ModificationUser]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<User> GetModificationUserAsync()
public Task<User> GetModificationUserAsync()
Public Function GetModificationUserAsync As Task(Of User)
Public Function GetModificationUserAsync As Task(Of User)
public:
Task<User^>^ GetModificationUserAsync()
public:
Task<User^>^ GetModificationUserAsync()
member GetModificationUserAsync : unit -> Task<User>
member GetModificationUserAsync : unit -> Task<User>

Return Value

Type: Online Task User
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.GetSizeAsync Method

FileSystemSessionItem GetSizeAsync Method NFX Class Library

Async version of [P:Size]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task<ulong> GetSizeAsync()
public Task<ulong> GetSizeAsync()
Public Function GetSizeAsync As Task(Of ULong)
Public Function GetSizeAsync As Task(Of ULong)
public:
Task<unsigned long long>^ GetSizeAsync()
public:
Task<unsigned long long>^ GetSizeAsync()
member GetSizeAsync : unit -> Task<uint64>
member GetSizeAsync : unit -> Task<uint64>

Return Value

Type: Online Task Online UInt64
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.Refresh Method

FileSystemSessionItem Refresh Method NFX Class Library

Refreshes the state represented by this item, i.e. this may re-read attributes from remote file system

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Refresh()
public void Refresh()
Public Sub Refresh
Public Sub Refresh
public:
void Refresh()
public:
void Refresh()
member Refresh : unit -> unit
member Refresh : unit -> unit
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.RefreshAsync Method

FileSystemSessionItem RefreshAsync Method NFX Class Library

Async version of Refresh

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task RefreshAsync()
public Task RefreshAsync()
Public Function RefreshAsync As Task
Public Function RefreshAsync As Task
public:
Task^ RefreshAsync()
public:
Task^ RefreshAsync()
member RefreshAsync : unit -> Task
member RefreshAsync : unit -> Task

Return Value

Type: Online Task
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.Rename Method

FileSystemSessionItem Rename Method NFX Class Library

Renames an item. Check file system capabilities to see if renaming is supported

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Rename(
    string newName
)
public void Rename(
    string newName
)
Public Sub Rename (
    newName As String
)
Public Sub Rename (
    newName As String
)
public:
void Rename(
    String^ newName
)
public:
void Rename(
    String^ newName
)
member Rename :
        newName : string -> unit
member Rename :
        newName : string -> unit

Parameters

newName
Type: Online System String
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.RenameAsync Method

FileSystemSessionItem RenameAsync Method NFX Class Library

Async version of Rename(String)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task RenameAsync(
    string newName
)
public Task RenameAsync(
    string newName
)
Public Function RenameAsync (
    newName As String
) As Task
Public Function RenameAsync (
    newName As String
) As Task
public:
Task^ RenameAsync(
    String^ newName
)
public:
Task^ RenameAsync(
    String^ newName
)
member RenameAsync :
        newName : string -> Task
member RenameAsync :
        newName : string -> Task

Parameters

newName
Type: Online System String

Return Value

Type: Online Task
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.SetCreationTimestampAsync Method

FileSystemSessionItem SetCreationTimestampAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of [P:CreationTimestamp]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task SetCreationTimestampAsync(
    DateTime timestamp
)
public Task SetCreationTimestampAsync(
    DateTime timestamp
)
Public Function SetCreationTimestampAsync (
    timestamp As DateTime
) As Task
Public Function SetCreationTimestampAsync (
    timestamp As DateTime
) As Task
public:
Task^ SetCreationTimestampAsync(
    DateTime timestamp
)
public:
Task^ SetCreationTimestampAsync(
    DateTime timestamp
)
member SetCreationTimestampAsync :
        timestamp : DateTime -> Task
member SetCreationTimestampAsync :
        timestamp : DateTime -> Task

Parameters

timestamp
Type: Online System DateTime

Return Value

Type: Online Task
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.SetLastAccessTimestampAsync Method

FileSystemSessionItem SetLastAccessTimestampAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of [P:LastAccessTimestamp]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task SetLastAccessTimestampAsync(
    DateTime timestamp
)
public Task SetLastAccessTimestampAsync(
    DateTime timestamp
)
Public Function SetLastAccessTimestampAsync (
    timestamp As DateTime
) As Task
Public Function SetLastAccessTimestampAsync (
    timestamp As DateTime
) As Task
public:
Task^ SetLastAccessTimestampAsync(
    DateTime timestamp
)
public:
Task^ SetLastAccessTimestampAsync(
    DateTime timestamp
)
member SetLastAccessTimestampAsync :
        timestamp : DateTime -> Task
member SetLastAccessTimestampAsync :
        timestamp : DateTime -> Task

Parameters

timestamp
Type: Online System DateTime

Return Value

Type: Online Task
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.SetModificationTimestampAsync Method

FileSystemSessionItem SetModificationTimestampAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of [P:ModificationTimestamp]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task SetModificationTimestampAsync(
    DateTime timestamp
)
public Task SetModificationTimestampAsync(
    DateTime timestamp
)
Public Function SetModificationTimestampAsync (
    timestamp As DateTime
) As Task
Public Function SetModificationTimestampAsync (
    timestamp As DateTime
) As Task
public:
Task^ SetModificationTimestampAsync(
    DateTime timestamp
)
public:
Task^ SetModificationTimestampAsync(
    DateTime timestamp
)
member SetModificationTimestampAsync :
        timestamp : DateTime -> Task
member SetModificationTimestampAsync :
        timestamp : DateTime -> Task

Parameters

timestamp
Type: Online System DateTime

Return Value

Type: Online Task
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.SetReadOnlyAsync Method

FileSystemSessionItem SetReadOnlyAsync Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Async version of [P:ReadOnly]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Task SetReadOnlyAsync(
    bool readOnly
)
public Task SetReadOnlyAsync(
    bool readOnly
)
Public Function SetReadOnlyAsync (
    readOnly As Boolean
) As Task
Public Function SetReadOnlyAsync (
    readOnly As Boolean
) As Task
public:
Task^ SetReadOnlyAsync(
    bool readOnly
)
public:
Task^ SetReadOnlyAsync(
    bool readOnly
)
member SetReadOnlyAsync :
        readOnly : bool -> Task
member SetReadOnlyAsync :
        readOnly : bool -> Task

Parameters

readOnly
Type: Online System Boolean

Return Value

Type: Online Task
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.ToString Method

FileSystemSessionItem ToString Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem Properties

FileSystemSessionItem Properties NFX Class Library

The FileSystemSessionItem type exposes the following members.
Properties
 | Name | Description
Public property | CreationTimestamp | Gets/sets UTC creation timestamp
Public property | CreationUser | Gets the user who created this item
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | FileSystem | Returns filesystem - this is a shortcut to Session.FileSystem
Public property | Handle | Returns file system handle for this entity
Public property | IsReadOnly | Indicates whether this item can change and file system supports modifications
Public property | LastAccessTimestamp | Gets/sets UTC last access timestamp
Public property | LastAccessUser | Gets the last user who accessed the item
Public property | MetadataStream | Returns item metadata stream
Public property | ModificationTimestamp | Gets/sets UTC modification timestamp
Public property | ModificationUser | Gets the user who modified this item
Public property | Modified | Indicates whether anything has changed since last transaction has started
Public property | Name |
Public property | ParentPath | Returns path to directory that contains this item
Public property | Path | Returns an absolute path for this item
Public property | PermissionsStream | Returns item permissions stream
Public property | ReadOnly | Gets/sets readonly attribute
Public property | Session | Returns session through which this object was obtained
Public property | Size | Returns the byte size of the item, depending on implementation this property may return approximate sizes for files and directories (i.e in distributed systems)
Back to Top
See Also
FileSystemSessionItem Class
NFX.IO.FileSystem Namespace


FileSystemSessionItem.CreationTimestamp Property

FileSystemSessionItem CreationTimestamp Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets/sets UTC creation timestamp

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> CreationTimestamp { get; set; }
public Nullable<DateTime> CreationTimestamp { get; set; }
Public Property CreationTimestamp As Nullable(Of DateTime)
    Get
    Set
Public Property CreationTimestamp As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> CreationTimestamp {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
public:
property Nullable<DateTime> CreationTimestamp {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member CreationTimestamp : Nullable<DateTime> with get, set
member CreationTimestamp : Nullable<DateTime> with get, set

Property Value

Type: Online Nullable Online DateTime
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.CreationUser Property

FileSystemSessionItem CreationUser Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets the user who created this item

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public User CreationUser { get; }
public User CreationUser { get; }
Public ReadOnly Property CreationUser As User
    Get
Public ReadOnly Property CreationUser As User
    Get
public:
property User^ CreationUser {
    User^ get ();
}
public:
property User^ CreationUser {
    User^ get ();
}
member CreationUser : User with get
member CreationUser : User with get

Property Value

Type: User
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.FileSystem Property

FileSystemSessionItem FileSystem Property NFX Class Library

Returns filesystem - this is a shortcut to Session.FileSystem

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSystem FileSystem { get; }
public FileSystem FileSystem { get; }
Public ReadOnly Property FileSystem As FileSystem
    Get
Public ReadOnly Property FileSystem As FileSystem
    Get
public:
property FileSystem^ FileSystem {
    FileSystem^ get ();
}
public:
property FileSystem^ FileSystem {
    FileSystem^ get ();
}
member FileSystem : FileSystem with get
member FileSystem : FileSystem with get

Property Value

Type: FileSystem
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.Handle Property

FileSystemSessionItem Handle Property NFX Class Library

Returns file system handle for this entity

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IFileSystemHandle Handle { get; }
public IFileSystemHandle Handle { get; }
Public ReadOnly Property Handle As IFileSystemHandle
    Get
Public ReadOnly Property Handle As IFileSystemHandle
    Get
public:
property IFileSystemHandle^ Handle {
    IFileSystemHandle^ get ();
}
public:
property IFileSystemHandle^ Handle {
    IFileSystemHandle^ get ();
}
member Handle : IFileSystemHandle with get
member Handle : IFileSystemHandle with get

Property Value

Type: IFileSystemHandle
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.IsReadOnly Property

FileSystemSessionItem IsReadOnly Property NFX Class Library

Indicates whether this item can change and file system supports modifications

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsReadOnly { get; }
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}
public:
property bool IsReadOnly {
    bool get ();
}
member IsReadOnly : bool with get
member IsReadOnly : bool with get

Property Value

Type: Online Boolean
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.LastAccessTimestamp Property

FileSystemSessionItem LastAccessTimestamp Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets/sets UTC last access timestamp

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> LastAccessTimestamp { get; set; }
public Nullable<DateTime> LastAccessTimestamp { get; set; }
Public Property LastAccessTimestamp As Nullable(Of DateTime)
    Get
    Set
Public Property LastAccessTimestamp As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> LastAccessTimestamp {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
public:
property Nullable<DateTime> LastAccessTimestamp {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member LastAccessTimestamp : Nullable<DateTime> with get, set
member LastAccessTimestamp : Nullable<DateTime> with get, set

Property Value

Type: Online Nullable Online DateTime
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.LastAccessUser Property

FileSystemSessionItem LastAccessUser Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets the last user who accessed the item

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public User LastAccessUser { get; }
public User LastAccessUser { get; }
Public ReadOnly Property LastAccessUser As User
    Get
Public ReadOnly Property LastAccessUser As User
    Get
public:
property User^ LastAccessUser {
    User^ get ();
}
public:
property User^ LastAccessUser {
    User^ get ();
}
member LastAccessUser : User with get
member LastAccessUser : User with get

Property Value

Type: User
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.MetadataStream Property

FileSystemSessionItem MetadataStream Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns item metadata stream

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSystemStream MetadataStream { get; }
public FileSystemStream MetadataStream { get; }
Public ReadOnly Property MetadataStream As FileSystemStream
    Get
Public ReadOnly Property MetadataStream As FileSystemStream
    Get
public:
property FileSystemStream^ MetadataStream {
    FileSystemStream^ get ();
}
public:
property FileSystemStream^ MetadataStream {
    FileSystemStream^ get ();
}
member MetadataStream : FileSystemStream with get
member MetadataStream : FileSystemStream with get

Property Value

Type: FileSystemStream
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.ModificationTimestamp Property

FileSystemSessionItem ModificationTimestamp Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets/sets UTC modification timestamp

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> ModificationTimestamp { get; set; }
public Nullable<DateTime> ModificationTimestamp { get; set; }
Public Property ModificationTimestamp As Nullable(Of DateTime)
    Get
    Set
Public Property ModificationTimestamp As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> ModificationTimestamp {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
public:
property Nullable<DateTime> ModificationTimestamp {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member ModificationTimestamp : Nullable<DateTime> with get, set
member ModificationTimestamp : Nullable<DateTime> with get, set

Property Value

Type: Online Nullable Online DateTime
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.ModificationUser Property

FileSystemSessionItem ModificationUser Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets the user who modified this item

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public User ModificationUser { get; }
public User ModificationUser { get; }
Public ReadOnly Property ModificationUser As User
    Get
Public ReadOnly Property ModificationUser As User
    Get
public:
property User^ ModificationUser {
    User^ get ();
}
public:
property User^ ModificationUser {
    User^ get ();
}
member ModificationUser : User with get
member ModificationUser : User with get

Property Value

Type: User
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.Modified Property

FileSystemSessionItem Modified Property NFX Class Library

Indicates whether anything has changed since last transaction has started

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Modified { get; }
public bool Modified { get; }
Public ReadOnly Property Modified As Boolean
    Get
Public ReadOnly Property Modified As Boolean
    Get
public:
property bool Modified {
    bool get ();
}
public:
property bool Modified {
    bool get ();
}
member Modified : bool with get
member Modified : bool with get

Property Value

Type: Online Boolean
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.Name Property

FileSystemSessionItem Name Property NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
Public Property Name As String
    Get
    Set
Public Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Name : string with get, set
override Name : string with get, set
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: Online String

Implements

INamed Name
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.ParentPath Property

FileSystemSessionItem ParentPath Property NFX Class Library

Returns path to directory that contains this item

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ParentPath { get; }
public string ParentPath { get; }
Public ReadOnly Property ParentPath As String
    Get
Public ReadOnly Property ParentPath As String
    Get
public:
property String^ ParentPath {
    String^ get ();
}
public:
property String^ ParentPath {
    String^ get ();
}
member ParentPath : string with get
member ParentPath : string with get

Property Value

Type: Online String
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.Path Property

FileSystemSessionItem Path Property NFX Class Library

Returns an absolute path for this item

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Path { get; }
public string Path { get; }
Public ReadOnly Property Path As String
    Get
Public ReadOnly Property Path As String
    Get
public:
property String^ Path {
    String^ get ();
}
public:
property String^ Path {
    String^ get ();
}
member Path : string with get
member Path : string with get

Property Value

Type: Online String
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.PermissionsStream Property

FileSystemSessionItem PermissionsStream Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns item permissions stream

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSystemStream PermissionsStream { get; }
public FileSystemStream PermissionsStream { get; }
Public ReadOnly Property PermissionsStream As FileSystemStream
    Get
Public ReadOnly Property PermissionsStream As FileSystemStream
    Get
public:
property FileSystemStream^ PermissionsStream {
    FileSystemStream^ get ();
}
public:
property FileSystemStream^ PermissionsStream {
    FileSystemStream^ get ();
}
member PermissionsStream : FileSystemStream with get
member PermissionsStream : FileSystemStream with get

Property Value

Type: FileSystemStream
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.ReadOnly Property

FileSystemSessionItem ReadOnly Property NFX Class Library

Gets/sets readonly attribute

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ReadOnly { get; set; }
public bool ReadOnly { get; set; }
Public Property ReadOnly As Boolean
    Get
    Set
Public Property ReadOnly As Boolean
    Get
    Set
public:
property bool ReadOnly {
    bool get ();
    void set (bool value);
}
public:
property bool ReadOnly {
    bool get ();
    void set (bool value);
}
member ReadOnly : bool with get, set
member ReadOnly : bool with get, set

Property Value

Type: Online Boolean
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.Session Property

FileSystemSessionItem Session Property NFX Class Library

Returns session through which this object was obtained

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSystemSession Session { get; }
public FileSystemSession Session { get; }
Public ReadOnly Property Session As FileSystemSession
    Get
Public ReadOnly Property Session As FileSystemSession
    Get
public:
property FileSystemSession^ Session {
    FileSystemSession^ get ();
}
public:
property FileSystemSession^ Session {
    FileSystemSession^ get ();
}
member Session : FileSystemSession with get
member Session : FileSystemSession with get

Property Value

Type: FileSystemSession
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemSessionItem.Size Property

FileSystemSessionItem Size Property NFX Class Library

Returns the byte size of the item, depending on implementation this property may return approximate sizes for files and directories (i.e in distributed systems)

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong Size { get; }
public ulong Size { get; }
Public ReadOnly Property Size As ULong
    Get
Public ReadOnly Property Size As ULong
    Get
public:
property unsigned long long Size {
    unsigned long long get ();
}
public:
property unsigned long long Size {
    unsigned long long get ();
}
member Size : uint64 with get
member Size : uint64 with get

Property Value

Type: Online UInt64
See Also
FileSystemSessionItem Class
FileSystemSessionItem Members
NFX.IO.FileSystem Namespace


FileSystemStarter Class

FileSystemStarter Class NFX Class Library

Represents a starter that launches file systems on startup
Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem FileSystemStarter

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class FileSystemStarter : IApplicationStarter,
    IConfigurable, INamed
public sealed class FileSystemStarter : IApplicationStarter,
    IConfigurable, INamed
Public NotInheritable Class FileSystemStarter
    Implements IApplicationStarter, IConfigurable, INamed
Public NotInheritable Class FileSystemStarter
    Implements IApplicationStarter, IConfigurable, INamed
public ref class FileSystemStarter sealed : IApplicationStarter,
    IConfigurable, INamed
public ref class FileSystemStarter sealed : IApplicationStarter,
    IConfigurable, INamed
[<SealedAttribute>]
type FileSystemStarter =
    class
        interface IApplicationStarter
        interface IConfigurable
        interface INamed
    end
[<SealedAttribute>]
type FileSystemStarter =
    class
        interface IApplicationStarter
        interface IConfigurable
        interface INamed
    end
See Also
FileSystemStarter Members
NFX.IO.FileSystem Namespace


FileSystemStarter Members

FileSystemStarter Members NFX Class Library

The FileSystemStarter type exposes the following members.
Constructors
 | Name | Description
Public method | FileSystemStarter | Initializes a new instance of the FileSystemStarter class
Back to Top
Methods
 | Name | Description
Public method | ApplicationStartAfterInit |
Public method | ApplicationStartBeforeInit |
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationStartBreakOnException |
Public property | Name |
Back to Top
See Also
FileSystemStarter Class
NFX.IO.FileSystem Namespace


FileSystemStarter Constructor

FileSystemStarter Constructor NFX Class Library

Initializes a new instance of the FileSystemStarter class

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSystemStarter()
public FileSystemStarter()
Public Sub New
Public Sub New
public:
FileSystemStarter()
public:
FileSystemStarter()
new : unit -> FileSystemStarter
new : unit -> FileSystemStarter
See Also
FileSystemStarter Class
FileSystemStarter Members
NFX.IO.FileSystem Namespace


FileSystemStarter Methods

FileSystemStarter Methods NFX Class Library

The FileSystemStarter type exposes the following members.
Methods
 | Name | Description
Public method | ApplicationStartAfterInit |
Public method | ApplicationStartBeforeInit |
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
FileSystemStarter Class
NFX.IO.FileSystem Namespace


FileSystemStarter.ApplicationStartAfterInit Method

FileSystemStarter ApplicationStartAfterInit Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ApplicationStartAfterInit(
    IApplication application
)
public void ApplicationStartAfterInit(
    IApplication application
)
Public Sub ApplicationStartAfterInit (
    application As IApplication
)
Public Sub ApplicationStartAfterInit (
    application As IApplication
)
public:
virtual void ApplicationStartAfterInit(
    IApplication^ application
) sealed
public:
virtual void ApplicationStartAfterInit(
    IApplication^ application
) sealed
abstract ApplicationStartAfterInit :
        application : IApplication -> unit
override ApplicationStartAfterInit :
        application : IApplication -> unit
abstract ApplicationStartAfterInit :
        application : IApplication -> unit
override ApplicationStartAfterInit :
        application : IApplication -> unit

Parameters

application
Type: NFX.ApplicationModel IApplication

Implements

IApplicationStarter ApplicationStartAfterInit(IApplication)
See Also
FileSystemStarter Class
FileSystemStarter Members
NFX.IO.FileSystem Namespace


FileSystemStarter.ApplicationStartBeforeInit Method

FileSystemStarter ApplicationStartBeforeInit Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ApplicationStartBeforeInit(
    IApplication application
)
public void ApplicationStartBeforeInit(
    IApplication application
)
Public Sub ApplicationStartBeforeInit (
    application As IApplication
)
Public Sub ApplicationStartBeforeInit (
    application As IApplication
)
public:
virtual void ApplicationStartBeforeInit(
    IApplication^ application
) sealed
public:
virtual void ApplicationStartBeforeInit(
    IApplication^ application
) sealed
abstract ApplicationStartBeforeInit :
        application : IApplication -> unit
override ApplicationStartBeforeInit :
        application : IApplication -> unit
abstract ApplicationStartBeforeInit :
        application : IApplication -> unit
override ApplicationStartBeforeInit :
        application : IApplication -> unit

Parameters

application
Type: NFX.ApplicationModel IApplication

Implements

IApplicationStarter ApplicationStartBeforeInit(IApplication)
See Also
FileSystemStarter Class
FileSystemStarter Members
NFX.IO.FileSystem Namespace


FileSystemStarter.Configure Method

FileSystemStarter Configure Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode node
)
public void Configure(
    IConfigSectionNode node
)
Public Sub Configure (
    node As IConfigSectionNode
)
Public Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
FileSystemStarter Class
FileSystemStarter Members
NFX.IO.FileSystem Namespace


FileSystemStarter Properties

FileSystemStarter Properties NFX Class Library

The FileSystemStarter type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationStartBreakOnException |
Public property | Name |
Back to Top
See Also
FileSystemStarter Class
NFX.IO.FileSystem Namespace


FileSystemStarter.ApplicationStartBreakOnException Property

FileSystemStarter ApplicationStartBreakOnException Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool ApplicationStartBreakOnException { get; set; }
[ConfigAttribute]
public bool ApplicationStartBreakOnException { get; set; }
<ConfigAttribute>
Public Property ApplicationStartBreakOnException As Boolean
    Get
    Set
<ConfigAttribute>
Public Property ApplicationStartBreakOnException As Boolean
    Get
    Set
public:
[ConfigAttribute]
virtual property bool ApplicationStartBreakOnException {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
[ConfigAttribute]
virtual property bool ApplicationStartBreakOnException {
    bool get () sealed;
    void set (bool value) sealed;
}
[<ConfigAttribute>]
abstract ApplicationStartBreakOnException : bool with get, set
[<ConfigAttribute>]
override ApplicationStartBreakOnException : bool with get, set
[<ConfigAttribute>]
abstract ApplicationStartBreakOnException : bool with get, set
[<ConfigAttribute>]
override ApplicationStartBreakOnException : bool with get, set

Property Value

Type: Online Boolean

Implements

IApplicationStarter ApplicationStartBreakOnException
See Also
FileSystemStarter Class
FileSystemStarter Members
NFX.IO.FileSystem Namespace


FileSystemStarter.Name Property

FileSystemStarter Name Property NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string Name { get; set; }
[ConfigAttribute]
public string Name { get; set; }
<ConfigAttribute>
Public Property Name As String
    Get
    Set
<ConfigAttribute>
Public Property Name As String
    Get
    Set
public:
[ConfigAttribute]
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
[ConfigAttribute]
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
[<ConfigAttribute>]
abstract Name : string with get, set
[<ConfigAttribute>]
override Name : string with get, set
[<ConfigAttribute>]
abstract Name : string with get, set
[<ConfigAttribute>]
override Name : string with get, set

Property Value

Type: Online String

Implements

INamed Name
See Also
FileSystemStarter Class
FileSystemStarter Members
NFX.IO.FileSystem Namespace


FileSystemStream Class

FileSystemStream Class NFX Class Library

Represents a stream that can work with contents of FileSystem. This class is NOT thread-safe
Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.IO Stream
NFX.IO.FileSystem FileSystemStream
NFX.IO.FileSystem.GoogleDrive.V2 GoogleDriveStream
NFX.IO.FileSystem.Local LocalFileSystemStream
NFX.IO.FileSystem.S3.V4 S3V4FileSystemStream
NFX.IO.FileSystem.SVN SVNFileSystemStream

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class FileSystemStream : Stream
public abstract class FileSystemStream : Stream
Public MustInherit Class FileSystemStream
    Inherits Stream
Public MustInherit Class FileSystemStream
    Inherits Stream
public ref class FileSystemStream abstract : public Stream
public ref class FileSystemStream abstract : public Stream
[<AbstractClassAttribute>]
type FileSystemStream =
    class
        inherit Stream
    end
[<AbstractClassAttribute>]
type FileSystemStream =
    class
        inherit Stream
    end
See Also
FileSystemStream Members
NFX.IO.FileSystem Namespace


FileSystemStream Members

FileSystemStream Members NFX Class Library

The FileSystemStream type exposes the following members.
Constructors
 | Name | Description
Protected method | FileSystemStream | Initializes a new instance of the FileSystemStream class
Back to Top
Methods
 | Name | Description
Public method | Online BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Online Stream.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Protected method | Online CreateWaitHandle | Obsolete. Allocates a Online WaitHandle object. (Inherited from Online Stream.)
Public method | Online Dispose | Releases all resources used by the Online Stream. (Inherited from Online Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FileSystemStream and optionally releases the managed resources (Overrides Online Stream Dispose(Boolean).)
Protected method | DoFlush |
Protected method | DoGetLength |
Protected method | DoGetPosition |
Protected method | DoRead |
Protected method | DoSeek |
Protected method | DoSetLength |
Protected method | DoSetPosition |
Protected method | DoWrite |
Public method | Online EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Overrides Online Stream Flush .)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Online Stream.)
Public method | FlushAsync(CancellationToken) | (Overrides StreamFlushAsync(CancellationToken).)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Online Stream.)
Public method | Read | (Overrides Online Stream Read( Byte , Int32, Int32).)
Public method | ReadAsync( Byte , Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Online Stream.)
Public method | ReadAsync( Byte , Int32, Int32, CancellationToken) | (Overrides StreamReadAsync( Byte , Int32, Int32, CancellationToken).)
Public method | Online ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Online Stream.)
Public method | Seek | (Overrides Online Stream Seek(Int64, SeekOrigin).)
Public method | SetLength | (Overrides Online Stream SetLength(Int64).)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write | (Overrides Online Stream Write( Byte , Int32, Int32).)
Public method | WriteAsync( Byte , Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Online Stream.)
Public method | WriteAsync( Byte , Int32, Int32, CancellationToken) | (Overrides StreamWriteAsync( Byte , Int32, Int32, CancellationToken).)
Public method | Online WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Online Stream.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsCharEnumerable | (Defined by IOMiscUtils.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Public Extension Method | ReadBEInt32 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEShort | Reads a short encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUInt64 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUShort | Reads an ushort encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadSLEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadSLEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | WriteBEInt32 | Writes an integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEShort | Writes a short encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUInt64 | Writes an unsigned long integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUShort | Writes an ushort encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteSLEB128(Int64, Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteSLEB128(Int64, Int32 , Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, UInt32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, Int32 , UInt32) | Overloaded. (Defined by LEB128.)
Back to Top
Fields
 | Name | Description
Public field | Item | Item that this stream is for
Back to Top
Properties
 | Name | Description
Public property | CanRead | (Overrides Online Stream CanRead.)
Public property | CanSeek | (Overrides Online Stream CanSeek.)
Public property | Online CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Online Stream.)
Public property | CanWrite | (Overrides Online Stream CanWrite.)
Public property | Length | (Overrides Online Stream Length.)
Public property | Position | (Overrides Online Stream Position.)
Public property | Online ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Online Stream.)
Public property | Online WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Online Stream.)
Back to Top
See Also
FileSystemStream Class
NFX.IO.FileSystem Namespace


FileSystemStream Constructor

FileSystemStream Constructor NFX Class Library

Initializes a new instance of the FileSystemStream class

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FileSystemStream(
    FileSystemSessionItem item,
    Action<FileSystemStream> disposeAction
)
protected FileSystemStream(
    FileSystemSessionItem item,
    Action<FileSystemStream> disposeAction
)
Protected Sub New (
    item As FileSystemSessionItem,
    disposeAction As Action(Of FileSystemStream)
)
Protected Sub New (
    item As FileSystemSessionItem,
    disposeAction As Action(Of FileSystemStream)
)
protected:
FileSystemStream(
    FileSystemSessionItem^ item,
    Action<FileSystemStream^>^ disposeAction
)
protected:
FileSystemStream(
    FileSystemSessionItem^ item,
    Action<FileSystemStream^>^ disposeAction
)
new :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
new :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
disposeAction
Type: Online System Action FileSystemStream
See Also
FileSystemStream Class
FileSystemStream Members
NFX.IO.FileSystem Namespace


FileSystemStream Fields

FileSystemStream Fields NFX Class Library

The FileSystemStream type exposes the following members.
Fields
 | Name | Description
Public field | Item | Item that this stream is for
Back to Top
See Also
FileSystemStream Class
NFX.IO.FileSystem Namespace


FileSystemStream.Item Field

FileSystemStream Item Field NFX Class Library

Item that this stream is for

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly FileSystemSessionItem Item
public readonly FileSystemSessionItem Item
Public ReadOnly Item As FileSystemSessionItem
Public ReadOnly Item As FileSystemSessionItem
public:
initonly FileSystemSessionItem^ Item
public:
initonly FileSystemSessionItem^ Item
val Item: FileSystemSessionItem
val Item: FileSystemSessionItem

Field Value

Type: FileSystemSessionItem
See Also
FileSystemStream Class
FileSystemStream Members
NFX.IO.FileSystem Namespace


FileSystemStream Methods

FileSystemStream Methods NFX Class Library

The FileSystemStream type exposes the following members.
Methods
 | Name | Description
Public method | Online BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Online Stream.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Protected method | Online CreateWaitHandle | Obsolete. Allocates a Online WaitHandle object. (Inherited from Online Stream.)
Public method | Online Dispose | Releases all resources used by the Online Stream. (Inherited from Online Stream.)
Protected method | Dispose(Boolean) | (Overrides Online Stream Dispose(Boolean).)
Protected method | DoFlush |
Protected method | DoGetLength |
Protected method | DoGetPosition |
Protected method | DoRead |
Protected method | DoSeek |
Protected method | DoSetLength |
Protected method | DoSetPosition |
Protected method | DoWrite |
Public method | Online EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Overrides Online Stream Flush .)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Online Stream.)
Public method | FlushAsync(CancellationToken) | (Overrides StreamFlushAsync(CancellationToken).)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Online Stream.)
Public method | Read | (Overrides Online Stream Read( Byte , Int32, Int32).)
Public method | ReadAsync( Byte , Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Online Stream.)
Public method | ReadAsync( Byte , Int32, Int32, CancellationToken) | (Overrides StreamReadAsync( Byte , Int32, Int32, CancellationToken).)
Public method | Online ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Online Stream.)
Public method | Seek | (Overrides Online Stream Seek(Int64, SeekOrigin).)
Public method | SetLength | (Overrides Online Stream SetLength(Int64).)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write | (Overrides Online Stream Write( Byte , Int32, Int32).)
Public method | WriteAsync( Byte , Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Online Stream.)
Public method | WriteAsync( Byte , Int32, Int32, CancellationToken) | (Overrides StreamWriteAsync( Byte , Int32, Int32, CancellationToken).)
Public method | Online WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Online Stream.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsCharEnumerable | (Defined by IOMiscUtils.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Public Extension Method | ReadBEInt32 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEShort | Reads a short encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUInt64 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUShort | Reads an ushort encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadSLEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadSLEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | WriteBEInt32 | Writes an integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEShort | Writes a short encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUInt64 | Writes an unsigned long integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUShort | Writes an ushort encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteSLEB128(Int64, Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteSLEB128(Int64, Int32 , Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, UInt32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, Int32 , UInt32) | Overloaded. (Defined by LEB128.)
Back to Top
See Also
FileSystemStream Class
NFX.IO.FileSystem Namespace


FileSystemStream.Dispose Method

FileSystemStream Dispose Method NFX Class Library

Overload List
 | Name | Description
Public method | Online Dispose | Releases all resources used by the Online Stream. (Inherited from Online Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FileSystemStream and optionally releases the managed resources (Overrides Online Stream Dispose(Boolean).)
Back to Top
See Also
FileSystemStream Class
FileSystemStream Members
NFX.IO.FileSystem Namespace


FileSystemStream.Dispose Method (Boolean)

FileSystemStream Dispose Method (Boolean) NFX Class Library

Releases the unmanaged resources used by the FileSystemStream and optionally releases the managed resources

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
FileSystemStream Class
FileSystemStream Members
Dispose Overload
NFX.IO.FileSystem Namespace


FileSystemStream.DoFlush Method

FileSystemStream DoFlush Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void DoFlush()
protected abstract void DoFlush()
Protected MustOverride Sub DoFlush
Protected MustOverride Sub DoFlush
protected:
virtual void DoFlush() abstract
protected:
virtual void DoFlush() abstract
abstract DoFlush : unit -> unit
abstract DoFlush : unit -> unit
See Also
FileSystemStream Class
FileSystemStream Members
NFX.IO.FileSystem Namespace


FileSystemStream.DoGetLength Method

FileSystemStream DoGetLength Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract long DoGetLength()
protected abstract long DoGetLength()
Protected MustOverride Function DoGetLength As Long
Protected MustOverride Function DoGetLength As Long
protected:
virtual long long DoGetLength() abstract
protected:
virtual long long DoGetLength() abstract
abstract DoGetLength : unit -> int64
abstract DoGetLength : unit -> int64

Return Value

Type: Online Int64
See Also
FileSystemStream Class
FileSystemStream Members
NFX.IO.FileSystem Namespace


FileSystemStream.DoGetPosition Method

FileSystemStream DoGetPosition Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract long DoGetPosition()
protected abstract long DoGetPosition()
Protected MustOverride Function DoGetPosition As Long
Protected MustOverride Function DoGetPosition As Long
protected:
virtual long long DoGetPosition() abstract
protected:
virtual long long DoGetPosition() abstract
abstract DoGetPosition : unit -> int64
abstract DoGetPosition : unit -> int64

Return Value

Type: Online Int64
See Also
FileSystemStream Class
FileSystemStream Members
NFX.IO.FileSystem Namespace


FileSystemStream.DoRead Method

FileSystemStream DoRead Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract int DoRead(
    byte[] buffer,
    int offset,
    int count
)
protected abstract int DoRead(
    byte[] buffer,
    int offset,
    int count
)
Protected MustOverride Function DoRead (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
Protected MustOverride Function DoRead (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
protected:
virtual int DoRead(
    array<unsigned char>^ buffer,
    int offset,
    int count
) abstract
protected:
virtual int DoRead(
    array<unsigned char>^ buffer,
    int offset,
    int count
) abstract
abstract DoRead :
        buffer : byte[] *
        offset : int *
        count : int -> int
abstract DoRead :
        buffer : byte[] *
        offset : int *
        count : int -> int

Parameters

buffer
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32

Return Value

Type: Online Int32
See Also
FileSystemStream Class
FileSystemStream Members
NFX.IO.FileSystem Namespace


FileSystemStream.DoSeek Method

FileSystemStream DoSeek Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract long DoSeek(
    long offset,
    SeekOrigin origin
)
protected abstract long DoSeek(
    long offset,
    SeekOrigin origin
)
Protected MustOverride Function DoSeek (
    offset As Long,
    origin As SeekOrigin
) As Long
Protected MustOverride Function DoSeek (
    offset As Long,
    origin As SeekOrigin
) As Long
protected:
virtual long long DoSeek(
    long long offset,
    SeekOrigin origin
) abstract
protected:
virtual long long DoSeek(
    long long offset,
    SeekOrigin origin
) abstract
abstract DoSeek :
        offset : int64 *
        origin : SeekOrigin -> int64
abstract DoSeek :
        offset : int64 *
        origin : SeekOrigin -> int64

Parameters

offset
Type: Online System Int64
origin
Type: Online System.IO SeekOrigin

Return Value

Type: Online Int64
See Also
FileSystemStream Class
FileSystemStream Members
NFX.IO.FileSystem Namespace


FileSystemStream.DoSetLength Method

FileSystemStream DoSetLength Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void DoSetLength(
    long value
)
protected abstract void DoSetLength(
    long value
)
Protected MustOverride Sub DoSetLength (
    value As Long
)
Protected MustOverride Sub DoSetLength (
    value As Long
)
protected:
virtual void DoSetLength(
    long long value
) abstract
protected:
virtual void DoSetLength(
    long long value
) abstract
abstract DoSetLength :
        value : int64 -> unit
abstract DoSetLength :
        value : int64 -> unit

Parameters

value
Type: Online System Int64
See Also
FileSystemStream Class
FileSystemStream Members
NFX.IO.FileSystem Namespace


FileSystemStream.DoSetPosition Method

FileSystemStream DoSetPosition Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void DoSetPosition(
    long position
)
protected abstract void DoSetPosition(
    long position
)
Protected MustOverride Sub DoSetPosition (
    position As Long
)
Protected MustOverride Sub DoSetPosition (
    position As Long
)
protected:
virtual void DoSetPosition(
    long long position
) abstract
protected:
virtual void DoSetPosition(
    long long position
) abstract
abstract DoSetPosition :
        position : int64 -> unit
abstract DoSetPosition :
        position : int64 -> unit

Parameters

position
Type: Online System Int64
See Also
FileSystemStream Class
FileSystemStream Members
NFX.IO.FileSystem Namespace


FileSystemStream.DoWrite Method

FileSystemStream DoWrite Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void DoWrite(
    byte[] buffer,
    int offset,
    int count
)
protected abstract void DoWrite(
    byte[] buffer,
    int offset,
    int count
)
Protected MustOverride Sub DoWrite (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
Protected MustOverride Sub DoWrite (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
protected:
virtual void DoWrite(
    array<unsigned char>^ buffer,
    int offset,
    int count
) abstract
protected:
virtual void DoWrite(
    array<unsigned char>^ buffer,
    int offset,
    int count
) abstract
abstract DoWrite :
        buffer : byte[] *
        offset : int *
        count : int -> unit
abstract DoWrite :
        buffer : byte[] *
        offset : int *
        count : int -> unit

Parameters

buffer
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32
See Also
FileSystemStream Class
FileSystemStream Members
NFX.IO.FileSystem Namespace


FileSystemStream.Flush Method

FileSystemStream Flush Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override sealed void Flush()
public override sealed void Flush()
Public Overrides NotOverridable Sub Flush
Public Overrides NotOverridable Sub Flush
public:
virtual void Flush() override sealed
public:
virtual void Flush() override sealed
abstract Flush : unit -> unit
override Flush : unit -> unit
abstract Flush : unit -> unit
override Flush : unit -> unit
See Also
FileSystemStream Class
FileSystemStream Members
NFX.IO.FileSystem Namespace


FileSystemStream.FlushAsync Method

FileSystemStream FlushAsync Method NFX Class Library

Overload List
 | Name | Description
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Online Stream.)
Public method | FlushAsync(CancellationToken) | (Overrides StreamFlushAsync(CancellationToken).)
Back to Top
See Also
FileSystemStream Class
FileSystemStream Members
NFX.IO.FileSystem Namespace


FileSystemStream.FlushAsync Method (CancellationToken)

FileSystemStream FlushAsync Method (CancellationToken) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override sealed Task FlushAsync(
    CancellationToken ct
)
public override sealed Task FlushAsync(
    CancellationToken ct
)
Public Overrides NotOverridable Function FlushAsync (
    ct As CancellationToken
) As Task
Public Overrides NotOverridable Function FlushAsync (
    ct As CancellationToken
) As Task
public:
virtual Task^ FlushAsync(
    CancellationToken ct
) override sealed
public:
virtual Task^ FlushAsync(
    CancellationToken ct
) override sealed
abstract FlushAsync :
        ct : CancellationToken -> Task
override FlushAsync :
        ct : CancellationToken -> Task
abstract FlushAsync :
        ct : CancellationToken -> Task
override FlushAsync :
        ct : CancellationToken -> Task

Parameters

ct
Type: Online System.Threading CancellationToken

Return Value

Type: Online Task
See Also
FileSystemStream Class
FileSystemStream Members
FlushAsync Overload
NFX.IO.FileSystem Namespace


FileSystemStream.Read Method

FileSystemStream Read Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override sealed int Read(
    byte[] buffer,
    int offset,
    int count
)
public override sealed int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides NotOverridable Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
Public Overrides NotOverridable Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override sealed
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override sealed
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int

Parameters

buffer
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32

Return Value

Type: Online Int32
See Also
FileSystemStream Class
FileSystemStream Members
NFX.IO.FileSystem Namespace


FileSystemStream.ReadAsync Method

FileSystemStream ReadAsync Method NFX Class Library

Overload List
 | Name | Description
Public method | ReadAsync( Byte , Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Online Stream.)
Public method | ReadAsync( Byte , Int32, Int32, CancellationToken) | (Overrides StreamReadAsync( Byte , Int32, Int32, CancellationToken).)
Back to Top
See Also
FileSystemStream Class
FileSystemStream Members
NFX.IO.FileSystem Namespace


FileSystemStream.ReadAsync Method (Byte[], Int32, Int32, CancellationToken)

FileSystemStream ReadAsync Method ( Byte , Int32, Int32, CancellationToken) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override sealed Task<int> ReadAsync(
    byte[] buffer,
    int offset,
    int count,
    CancellationToken cancellationToken
)
public override sealed Task<int> ReadAsync(
    byte[] buffer,
    int offset,
    int count,
    CancellationToken cancellationToken
)
Public Overrides NotOverridable Function ReadAsync (
    buffer As Byte(),
    offset As Integer,
    count As Integer,
    cancellationToken As CancellationToken
) As Task(Of Integer)
Public Overrides NotOverridable Function ReadAsync (
    buffer As Byte(),
    offset As Integer,
    count As Integer,
    cancellationToken As CancellationToken
) As Task(Of Integer)
public:
virtual Task<int>^ ReadAsync(
    array<unsigned char>^ buffer,
    int offset,
    int count,
    CancellationToken cancellationToken
) override sealed
public:
virtual Task<int>^ ReadAsync(
    array<unsigned char>^ buffer,
    int offset,
    int count,
    CancellationToken cancellationToken
) override sealed
abstract ReadAsync :
        buffer : byte[] *
        offset : int *
        count : int *
        cancellationToken : CancellationToken -> Task<int>
override ReadAsync :
        buffer : byte[] *
        offset : int *
        count : int *
        cancellationToken : CancellationToken -> Task<int>
abstract ReadAsync :
        buffer : byte[] *
        offset : int *
        count : int *
        cancellationToken : CancellationToken -> Task<int>
override ReadAsync :
        buffer : byte[] *
        offset : int *
        count : int *
        cancellationToken : CancellationToken -> Task<int>

Parameters

buffer
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32
cancellationToken
Type: Online System.Threading CancellationToken

Return Value

Type: Online Task Online Int32
See Also
FileSystemStream Class
FileSystemStream Members
ReadAsync Overload
NFX.IO.FileSystem Namespace


FileSystemStream.Seek Method

FileSystemStream Seek Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override sealed long Seek(
    long offset,
    SeekOrigin origin
)
public override sealed long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides NotOverridable Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
Public Overrides NotOverridable Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override sealed
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override sealed
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64

Parameters

offset
Type: Online System Int64
origin
Type: Online System.IO SeekOrigin

Return Value

Type: Online Int64
See Also
FileSystemStream Class
FileSystemStream Members
NFX.IO.FileSystem Namespace


FileSystemStream.SetLength Method

FileSystemStream SetLength Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override sealed void SetLength(
    long value
)
public override sealed void SetLength(
    long value
)
Public Overrides NotOverridable Sub SetLength (
    value As Long
)
Public Overrides NotOverridable Sub SetLength (
    value As Long
)
public:
virtual void SetLength(
    long long value
) override sealed
public:
virtual void SetLength(
    long long value
) override sealed
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit

Parameters

value
Type: Online System Int64
See Also
FileSystemStream Class
FileSystemStream Members
NFX.IO.FileSystem Namespace


FileSystemStream.Write Method

FileSystemStream Write Method NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override sealed void Write(
    byte[] buffer,
    int offset,
    int count
)
public override sealed void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides NotOverridable Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
Public Overrides NotOverridable Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override sealed
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override sealed
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit

Parameters

buffer
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32
See Also
FileSystemStream Class
FileSystemStream Members
NFX.IO.FileSystem Namespace


FileSystemStream.WriteAsync Method

FileSystemStream WriteAsync Method NFX Class Library

Overload List
 | Name | Description
Public method | WriteAsync( Byte , Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Online Stream.)
Public method | WriteAsync( Byte , Int32, Int32, CancellationToken) | (Overrides StreamWriteAsync( Byte , Int32, Int32, CancellationToken).)
Back to Top
See Also
FileSystemStream Class
FileSystemStream Members
NFX.IO.FileSystem Namespace


FileSystemStream.WriteAsync Method (Byte[], Int32, Int32, CancellationToken)

FileSystemStream WriteAsync Method ( Byte , Int32, Int32, CancellationToken) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override sealed Task WriteAsync(
    byte[] buffer,
    int offset,
    int count,
    CancellationToken cancellationToken
)
public override sealed Task WriteAsync(
    byte[] buffer,
    int offset,
    int count,
    CancellationToken cancellationToken
)
Public Overrides NotOverridable Function WriteAsync (
    buffer As Byte(),
    offset As Integer,
    count As Integer,
    cancellationToken As CancellationToken
) As Task
Public Overrides NotOverridable Function WriteAsync (
    buffer As Byte(),
    offset As Integer,
    count As Integer,
    cancellationToken As CancellationToken
) As Task
public:
virtual Task^ WriteAsync(
    array<unsigned char>^ buffer,
    int offset,
    int count,
    CancellationToken cancellationToken
) override sealed
public:
virtual Task^ WriteAsync(
    array<unsigned char>^ buffer,
    int offset,
    int count,
    CancellationToken cancellationToken
) override sealed
abstract WriteAsync :
        buffer : byte[] *
        offset : int *
        count : int *
        cancellationToken : CancellationToken -> Task
override WriteAsync :
        buffer : byte[] *
        offset : int *
        count : int *
        cancellationToken : CancellationToken -> Task
abstract WriteAsync :
        buffer : byte[] *
        offset : int *
        count : int *
        cancellationToken : CancellationToken -> Task
override WriteAsync :
        buffer : byte[] *
        offset : int *
        count : int *
        cancellationToken : CancellationToken -> Task

Parameters

buffer
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32
cancellationToken
Type: Online System.Threading CancellationToken

Return Value

Type: Online Task
See Also
FileSystemStream Class
FileSystemStream Members
WriteAsync Overload
NFX.IO.FileSystem Namespace


FileSystemStream Properties

FileSystemStream Properties NFX Class Library

The FileSystemStream type exposes the following members.
Properties
 | Name | Description
Public property | CanRead | (Overrides Online Stream CanRead.)
Public property | CanSeek | (Overrides Online Stream CanSeek.)
Public property | Online CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Online Stream.)
Public property | CanWrite | (Overrides Online Stream CanWrite.)
Public property | Length | (Overrides Online Stream Length.)
Public property | Position | (Overrides Online Stream Position.)
Public property | Online ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Online Stream.)
Public property | Online WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Online Stream.)
Back to Top
See Also
FileSystemStream Class
NFX.IO.FileSystem Namespace


FileSystemStream.CanRead Property

FileSystemStream CanRead Property NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool CanRead { get; }
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
    Get
Public Overrides ReadOnly Property CanRead As Boolean
    Get
public:
virtual property bool CanRead {
    bool get () override;
}
public:
virtual property bool CanRead {
    bool get () override;
}
abstract CanRead : bool with get
override CanRead : bool with get
abstract CanRead : bool with get
override CanRead : bool with get

Property Value

Type: Online Boolean
See Also
FileSystemStream Class
FileSystemStream Members
NFX.IO.FileSystem Namespace


FileSystemStream.CanSeek Property

FileSystemStream CanSeek Property NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool CanSeek { get; }
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
public:
virtual property bool CanSeek {
    bool get () override;
}
public:
virtual property bool CanSeek {
    bool get () override;
}
abstract CanSeek : bool with get
override CanSeek : bool with get
abstract CanSeek : bool with get
override CanSeek : bool with get

Property Value

Type: Online Boolean
See Also
FileSystemStream Class
FileSystemStream Members
NFX.IO.FileSystem Namespace


FileSystemStream.CanWrite Property

FileSystemStream CanWrite Property NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool CanWrite { get; }
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
public:
virtual property bool CanWrite {
    bool get () override;
}
public:
virtual property bool CanWrite {
    bool get () override;
}
abstract CanWrite : bool with get
override CanWrite : bool with get
abstract CanWrite : bool with get
override CanWrite : bool with get

Property Value

Type: Online Boolean
See Also
FileSystemStream Class
FileSystemStream Members
NFX.IO.FileSystem Namespace


FileSystemStream.Length Property

FileSystemStream Length Property NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override sealed long Length { get; }
public override sealed long Length { get; }
Public Overrides NotOverridable ReadOnly Property Length As Long
    Get
Public Overrides NotOverridable ReadOnly Property Length As Long
    Get
public:
virtual property long long Length {
    long long get () override sealed;
}
public:
virtual property long long Length {
    long long get () override sealed;
}
abstract Length : int64 with get
override Length : int64 with get
abstract Length : int64 with get
override Length : int64 with get

Property Value

Type: Online Int64
See Also
FileSystemStream Class
FileSystemStream Members
NFX.IO.FileSystem Namespace


FileSystemStream.Position Property

FileSystemStream Position Property NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override sealed long Position { get; set; }
public override sealed long Position { get; set; }
Public Overrides NotOverridable Property Position As Long
    Get
    Set
Public Overrides NotOverridable Property Position As Long
    Get
    Set
public:
virtual property long long Position {
    long long get () override sealed;
    void set (long long value) override sealed;
}
public:
virtual property long long Position {
    long long get () override sealed;
    void set (long long value) override sealed;
}
abstract Position : int64 with get, set
override Position : int64 with get, set
abstract Position : int64 with get, set
override Position : int64 with get, set

Property Value

Type: Online Int64
See Also
FileSystemStream Class
FileSystemStream Members
NFX.IO.FileSystem Namespace


IFileSystem Interface

IFileSystem Interface NFX Class Library

Stipulates contract for various file system abstractions. FileSystem abstractions are mostly useful for working with components/classes that may need to inter-operate not only with local file system but also with distributed systems like ApacheHDFS, SVN, GIT, or Aum Cluster File System (ACFS). NFX library provides compatibility wrapper 'NFX.IO.FileSystem.Local.LocalFileSystem' for access to local machine file system (which is based on this class and is implemented using a traditional System.IO.* set of classes). The FileSystem abstraction supports the following concepts: versioning, transactions, metadata, security; however it does not guarantee that every implementation is capable of providing all of these functions. Query "GeneralCapabilities" and "InstanceCapabilities" to see what functions are supported by a particular instance.

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IFileSystem : IApplicationComponent,
    INamed, IDisposable
public interface IFileSystem : IApplicationComponent,
    INamed, IDisposable
Public Interface IFileSystem
    Inherits IApplicationComponent, INamed, IDisposable
Public Interface IFileSystem
    Inherits IApplicationComponent, INamed, IDisposable
public interface class IFileSystem : IApplicationComponent,
    INamed, IDisposable
public interface class IFileSystem : IApplicationComponent,
    INamed, IDisposable
type IFileSystem =
    interface
        interface IApplicationComponent
        interface INamed
        interface IDisposable
    end
type IFileSystem =
    interface
        interface IApplicationComponent
        interface INamed
        interface IDisposable
    end
See Also
IFileSystem Members
NFX.IO.FileSystem Namespace


IFileSystem Members

IFileSystem Members NFX Class Library

The IFileSystem type exposes the following members.
Methods
 | Name | Description
Public method | CombinePaths | Combines two or more path segments joining them using primary file system path separator
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | StartSession | Creates a new session for the specified user and version
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | GeneralCapabilities | Returns capabilities for this file system in general
Public property | InstanceCapabilities | Returns capabilities for this file system instance, that may or may not be the same as GeneralCapabilities
Public property | Name | (Inherited from INamed.)
Public property | Sessions | Returns a list of sessions
Back to Top
See Also
IFileSystem Interface
NFX.IO.FileSystem Namespace


IFileSystem Methods

IFileSystem Methods NFX Class Library

The IFileSystem type exposes the following members.
Methods
 | Name | Description
Public method | CombinePaths | Combines two or more path segments joining them using primary file system path separator
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | StartSession | Creates a new session for the specified user and version
Back to Top
See Also
IFileSystem Interface
NFX.IO.FileSystem Namespace


IFileSystem.CombinePaths Method

IFileSystem CombinePaths Method NFX Class Library

Combines two or more path segments joining them using primary file system path separator

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string CombinePaths(
    string first,
    params string[] others
)
string CombinePaths(
    string first,
    params string[] others
)
Function CombinePaths (
    first As String,
    ParamArray others As String()
) As String
Function CombinePaths (
    first As String,
    ParamArray others As String()
) As String
String^ CombinePaths(
    String^ first,
    ... array<String^>^ others
)
String^ CombinePaths(
    String^ first,
    ... array<String^>^ others
)
abstract CombinePaths :
        first : string *
        others : string[] -> string
abstract CombinePaths :
        first : string *
        others : string[] -> string

Parameters

first
Type: Online System String
others
Type: Online System String

Return Value

Type: Online String
See Also
IFileSystem Interface
IFileSystem Members
NFX.IO.FileSystem Namespace


IFileSystem.StartSession Method

IFileSystem StartSession Method NFX Class Library

Creates a new session for the specified user and version

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
FileSystemSession StartSession(
    FileSystemSessionConnectParams cParams
)
FileSystemSession StartSession(
    FileSystemSessionConnectParams cParams
)
Function StartSession (
    cParams As FileSystemSessionConnectParams
) As FileSystemSession
Function StartSession (
    cParams As FileSystemSessionConnectParams
) As FileSystemSession
FileSystemSession^ StartSession(
    FileSystemSessionConnectParams^ cParams
)
FileSystemSession^ StartSession(
    FileSystemSessionConnectParams^ cParams
)
abstract StartSession :
        cParams : FileSystemSessionConnectParams -> FileSystemSession
abstract StartSession :
        cParams : FileSystemSessionConnectParams -> FileSystemSession

Parameters

cParams
Type: NFX.IO.FileSystem FileSystemSessionConnectParams

Return Value

Type: FileSystemSession
See Also
IFileSystem Interface
IFileSystem Members
NFX.IO.FileSystem Namespace


IFileSystem Properties

IFileSystem Properties NFX Class Library

The IFileSystem type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | GeneralCapabilities | Returns capabilities for this file system in general
Public property | InstanceCapabilities | Returns capabilities for this file system instance, that may or may not be the same as GeneralCapabilities
Public property | Name | (Inherited from INamed.)
Public property | Sessions | Returns a list of sessions
Back to Top
See Also
IFileSystem Interface
NFX.IO.FileSystem Namespace


IFileSystem.GeneralCapabilities Property

IFileSystem GeneralCapabilities Property NFX Class Library

Returns capabilities for this file system in general

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IFileSystemCapabilities GeneralCapabilities { get; }
IFileSystemCapabilities GeneralCapabilities { get; }
ReadOnly Property GeneralCapabilities As IFileSystemCapabilities
    Get
ReadOnly Property GeneralCapabilities As IFileSystemCapabilities
    Get
property IFileSystemCapabilities^ GeneralCapabilities {
    IFileSystemCapabilities^ get ();
}
property IFileSystemCapabilities^ GeneralCapabilities {
    IFileSystemCapabilities^ get ();
}
abstract GeneralCapabilities : IFileSystemCapabilities with get
abstract GeneralCapabilities : IFileSystemCapabilities with get

Property Value

Type: IFileSystemCapabilities
See Also
IFileSystem Interface
IFileSystem Members
NFX.IO.FileSystem Namespace


IFileSystem.InstanceCapabilities Property

IFileSystem InstanceCapabilities Property NFX Class Library

Returns capabilities for this file system instance, that may or may not be the same as GeneralCapabilities

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IFileSystemCapabilities InstanceCapabilities { get; }
IFileSystemCapabilities InstanceCapabilities { get; }
ReadOnly Property InstanceCapabilities As IFileSystemCapabilities
    Get
ReadOnly Property InstanceCapabilities As IFileSystemCapabilities
    Get
property IFileSystemCapabilities^ InstanceCapabilities {
    IFileSystemCapabilities^ get ();
}
property IFileSystemCapabilities^ InstanceCapabilities {
    IFileSystemCapabilities^ get ();
}
abstract InstanceCapabilities : IFileSystemCapabilities with get
abstract InstanceCapabilities : IFileSystemCapabilities with get

Property Value

Type: IFileSystemCapabilities
See Also
IFileSystem Interface
IFileSystem Members
NFX.IO.FileSystem Namespace


IFileSystem.Sessions Property

IFileSystem Sessions Property NFX Class Library

Returns a list of sessions

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<FileSystemSession> Sessions { get; }
IEnumerable<FileSystemSession> Sessions { get; }
ReadOnly Property Sessions As IEnumerable(Of FileSystemSession)
    Get
ReadOnly Property Sessions As IEnumerable(Of FileSystemSession)
    Get
property IEnumerable<FileSystemSession^>^ Sessions {
    IEnumerable<FileSystemSession^>^ get ();
}
property IEnumerable<FileSystemSession^>^ Sessions {
    IEnumerable<FileSystemSession^>^ get ();
}
abstract Sessions : IEnumerable<FileSystemSession> with get
abstract Sessions : IEnumerable<FileSystemSession> with get

Property Value

Type: Online IEnumerable FileSystemSession
See Also
IFileSystem Interface
IFileSystem Members
NFX.IO.FileSystem Namespace


IFileSystemCapabilities Interface

IFileSystemCapabilities Interface NFX Class Library

Supplies capabilities for the file system. The implementation must be thread safe

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IFileSystemCapabilities
public interface IFileSystemCapabilities
Public Interface IFileSystemCapabilities
Public Interface IFileSystemCapabilities
public interface class IFileSystemCapabilities
public interface class IFileSystemCapabilities
type IFileSystemCapabilities =  interface end
type IFileSystemCapabilities =  interface end
See Also
IFileSystemCapabilities Members
NFX.IO.FileSystem Namespace


IFileSystemCapabilities Members

IFileSystemCapabilities Members NFX Class Library

The IFileSystemCapabilities type exposes the following members.
Properties
 | Name | Description
Public property | IsReadonly | Indicates whether file system supports modification of its files and structure
Public property | MaxDirectoryNameLength | Returns maximum allowed length of a directory name
Public property | MaxFileNameLength | Returns maximum allowed length of a file name
Public property | MaxFilePathLength | Returns maximum allowed length of the whole path that includes directory name/s and/or separator chars and/or file name
Public property | MaxFileSize | Returns the maximum size of a file
Public property | PathSeparatorCharacters | Returns understood path separator characters
Public property | SupportsAsyncronousAPI | Defines if this FileSystem implements Async methods in real asynchronous manner. By default asynchronous methods are actually executed syncronously and return Task with execution result or exception
Public property | SupportsCreationTimestamps |
Public property | SupportsCreationUserNames |
Public property | SupportsCustomMetadata | Indicates whether the file system supports custom metadata for files and folders
Public property | SupportsDirectoryRenaming |
Public property | SupportsDirectorySizes |
Public property | SupportsFileModification |
Public property | SupportsFileRenaming |
Public property | SupportsFileSizes |
Public property | SupportsLastAccessTimestamps |
Public property | SupportsLastAccessUserNames |
Public property | SupportsModificationTimestamps |
Public property | SupportsModificationUserNames |
Public property | SupportsReadonlyDirectories |
Public property | SupportsReadonlyFiles |
Public property | SupportsSecurity | Indicates whether the file system supports security permissions
Public property | SupportsStreamSeek |
Public property | SupportsTransactions | Indicates whether a file system supports transactions
Public property | SupportsVersioning | Indicates whether a file system supports versioning
Back to Top
See Also
IFileSystemCapabilities Interface
NFX.IO.FileSystem Namespace


IFileSystemCapabilities Properties

IFileSystemCapabilities Properties NFX Class Library

The IFileSystemCapabilities type exposes the following members.
Properties
 | Name | Description
Public property | IsReadonly | Indicates whether file system supports modification of its files and structure
Public property | MaxDirectoryNameLength | Returns maximum allowed length of a directory name
Public property | MaxFileNameLength | Returns maximum allowed length of a file name
Public property | MaxFilePathLength | Returns maximum allowed length of the whole path that includes directory name/s and/or separator chars and/or file name
Public property | MaxFileSize | Returns the maximum size of a file
Public property | PathSeparatorCharacters | Returns understood path separator characters
Public property | SupportsAsyncronousAPI | Defines if this FileSystem implements Async methods in real asynchronous manner. By default asynchronous methods are actually executed syncronously and return Task with execution result or exception
Public property | SupportsCreationTimestamps |
Public property | SupportsCreationUserNames |
Public property | SupportsCustomMetadata | Indicates whether the file system supports custom metadata for files and folders
Public property | SupportsDirectoryRenaming |
Public property | SupportsDirectorySizes |
Public property | SupportsFileModification |
Public property | SupportsFileRenaming |
Public property | SupportsFileSizes |
Public property | SupportsLastAccessTimestamps |
Public property | SupportsLastAccessUserNames |
Public property | SupportsModificationTimestamps |
Public property | SupportsModificationUserNames |
Public property | SupportsReadonlyDirectories |
Public property | SupportsReadonlyFiles |
Public property | SupportsSecurity | Indicates whether the file system supports security permissions
Public property | SupportsStreamSeek |
Public property | SupportsTransactions | Indicates whether a file system supports transactions
Public property | SupportsVersioning | Indicates whether a file system supports versioning
Back to Top
See Also
IFileSystemCapabilities Interface
NFX.IO.FileSystem Namespace


IFileSystemCapabilities.IsReadonly Property

IFileSystemCapabilities IsReadonly Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Indicates whether file system supports modification of its files and structure

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsReadonly { get; }
bool IsReadonly { get; }
ReadOnly Property IsReadonly As Boolean
    Get
ReadOnly Property IsReadonly As Boolean
    Get
property bool IsReadonly {
    bool get ();
}
property bool IsReadonly {
    bool get ();
}
abstract IsReadonly : bool with get
abstract IsReadonly : bool with get

Property Value

Type: Online Boolean
See Also
IFileSystemCapabilities Interface
IFileSystemCapabilities Members
NFX.IO.FileSystem Namespace


IFileSystemCapabilities.MaxDirectoryNameLength Property

IFileSystemCapabilities MaxDirectoryNameLength Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns maximum allowed length of a directory name

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int MaxDirectoryNameLength { get; }
int MaxDirectoryNameLength { get; }
ReadOnly Property MaxDirectoryNameLength As Integer
    Get
ReadOnly Property MaxDirectoryNameLength As Integer
    Get
property int MaxDirectoryNameLength {
    int get ();
}
property int MaxDirectoryNameLength {
    int get ();
}
abstract MaxDirectoryNameLength : int with get
abstract MaxDirectoryNameLength : int with get

Property Value

Type: Online Int32
See Also
IFileSystemCapabilities Interface
IFileSystemCapabilities Members
NFX.IO.FileSystem Namespace


IFileSystemCapabilities.MaxFileNameLength Property

IFileSystemCapabilities MaxFileNameLength Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns maximum allowed length of a file name

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int MaxFileNameLength { get; }
int MaxFileNameLength { get; }
ReadOnly Property MaxFileNameLength As Integer
    Get
ReadOnly Property MaxFileNameLength As Integer
    Get
property int MaxFileNameLength {
    int get ();
}
property int MaxFileNameLength {
    int get ();
}
abstract MaxFileNameLength : int with get
abstract MaxFileNameLength : int with get

Property Value

Type: Online Int32
See Also
IFileSystemCapabilities Interface
IFileSystemCapabilities Members
NFX.IO.FileSystem Namespace


IFileSystemCapabilities.MaxFilePathLength Property

IFileSystemCapabilities MaxFilePathLength Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns maximum allowed length of the whole path that includes directory name/s and/or separator chars and/or file name

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int MaxFilePathLength { get; }
int MaxFilePathLength { get; }
ReadOnly Property MaxFilePathLength As Integer
    Get
ReadOnly Property MaxFilePathLength As Integer
    Get
property int MaxFilePathLength {
    int get ();
}
property int MaxFilePathLength {
    int get ();
}
abstract MaxFilePathLength : int with get
abstract MaxFilePathLength : int with get

Property Value

Type: Online Int32
See Also
IFileSystemCapabilities Interface
IFileSystemCapabilities Members
NFX.IO.FileSystem Namespace


IFileSystemCapabilities.MaxFileSize Property

IFileSystemCapabilities MaxFileSize Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns the maximum size of a file

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ulong MaxFileSize { get; }
ulong MaxFileSize { get; }
ReadOnly Property MaxFileSize As ULong
    Get
ReadOnly Property MaxFileSize As ULong
    Get
property unsigned long long MaxFileSize {
    unsigned long long get ();
}
property unsigned long long MaxFileSize {
    unsigned long long get ();
}
abstract MaxFileSize : uint64 with get
abstract MaxFileSize : uint64 with get

Property Value

Type: Online UInt64
See Also
IFileSystemCapabilities Interface
IFileSystemCapabilities Members
NFX.IO.FileSystem Namespace


IFileSystemCapabilities.PathSeparatorCharacters Property

IFileSystemCapabilities PathSeparatorCharacters Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns understood path separator characters

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
char[] PathSeparatorCharacters { get; }
char[] PathSeparatorCharacters { get; }
ReadOnly Property PathSeparatorCharacters As Char()
    Get
ReadOnly Property PathSeparatorCharacters As Char()
    Get
property array<wchar_t>^ PathSeparatorCharacters {
    array<wchar_t>^ get ();
}
property array<wchar_t>^ PathSeparatorCharacters {
    array<wchar_t>^ get ();
}
abstract PathSeparatorCharacters : char[] with get
abstract PathSeparatorCharacters : char[] with get

Property Value

Type: Online Char
See Also
IFileSystemCapabilities Interface
IFileSystemCapabilities Members
NFX.IO.FileSystem Namespace


IFileSystemCapabilities.SupportsAsyncronousAPI Property

IFileSystemCapabilities SupportsAsyncronousAPI Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Defines if this FileSystem implements Async methods in real asynchronous manner. By default asynchronous methods are actually executed syncronously and return Task with execution result or exception

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool SupportsAsyncronousAPI { get; }
bool SupportsAsyncronousAPI { get; }
ReadOnly Property SupportsAsyncronousAPI As Boolean
    Get
ReadOnly Property SupportsAsyncronousAPI As Boolean
    Get
property bool SupportsAsyncronousAPI {
    bool get ();
}
property bool SupportsAsyncronousAPI {
    bool get ();
}
abstract SupportsAsyncronousAPI : bool with get
abstract SupportsAsyncronousAPI : bool with get

Property Value

Type: Online Boolean
See Also
IFileSystemCapabilities Interface
IFileSystemCapabilities Members
NFX.IO.FileSystem Namespace


IFileSystemCapabilities.SupportsCreationTimestamps Property

IFileSystemCapabilities SupportsCreationTimestamps Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool SupportsCreationTimestamps { get; }
bool SupportsCreationTimestamps { get; }
ReadOnly Property SupportsCreationTimestamps As Boolean
    Get
ReadOnly Property SupportsCreationTimestamps As Boolean
    Get
property bool SupportsCreationTimestamps {
    bool get ();
}
property bool SupportsCreationTimestamps {
    bool get ();
}
abstract SupportsCreationTimestamps : bool with get
abstract SupportsCreationTimestamps : bool with get

Property Value

Type: Online Boolean
See Also
IFileSystemCapabilities Interface
IFileSystemCapabilities Members
NFX.IO.FileSystem Namespace


IFileSystemCapabilities.SupportsCreationUserNames Property

IFileSystemCapabilities SupportsCreationUserNames Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool SupportsCreationUserNames { get; }
bool SupportsCreationUserNames { get; }
ReadOnly Property SupportsCreationUserNames As Boolean
    Get
ReadOnly Property SupportsCreationUserNames As Boolean
    Get
property bool SupportsCreationUserNames {
    bool get ();
}
property bool SupportsCreationUserNames {
    bool get ();
}
abstract SupportsCreationUserNames : bool with get
abstract SupportsCreationUserNames : bool with get

Property Value

Type: Online Boolean
See Also
IFileSystemCapabilities Interface
IFileSystemCapabilities Members
NFX.IO.FileSystem Namespace


IFileSystemCapabilities.SupportsCustomMetadata Property

IFileSystemCapabilities SupportsCustomMetadata Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Indicates whether the file system supports custom metadata for files and folders

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool SupportsCustomMetadata { get; }
bool SupportsCustomMetadata { get; }
ReadOnly Property SupportsCustomMetadata As Boolean
    Get
ReadOnly Property SupportsCustomMetadata As Boolean
    Get
property bool SupportsCustomMetadata {
    bool get ();
}
property bool SupportsCustomMetadata {
    bool get ();
}
abstract SupportsCustomMetadata : bool with get
abstract SupportsCustomMetadata : bool with get

Property Value

Type: Online Boolean
See Also
IFileSystemCapabilities Interface
IFileSystemCapabilities Members
NFX.IO.FileSystem Namespace


IFileSystemCapabilities.SupportsDirectoryRenaming Property

IFileSystemCapabilities SupportsDirectoryRenaming Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool SupportsDirectoryRenaming { get; }
bool SupportsDirectoryRenaming { get; }
ReadOnly Property SupportsDirectoryRenaming As Boolean
    Get
ReadOnly Property SupportsDirectoryRenaming As Boolean
    Get
property bool SupportsDirectoryRenaming {
    bool get ();
}
property bool SupportsDirectoryRenaming {
    bool get ();
}
abstract SupportsDirectoryRenaming : bool with get
abstract SupportsDirectoryRenaming : bool with get

Property Value

Type: Online Boolean
See Also
IFileSystemCapabilities Interface
IFileSystemCapabilities Members
NFX.IO.FileSystem Namespace


IFileSystemCapabilities.SupportsDirectorySizes Property

IFileSystemCapabilities SupportsDirectorySizes Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool SupportsDirectorySizes { get; }
bool SupportsDirectorySizes { get; }
ReadOnly Property SupportsDirectorySizes As Boolean
    Get
ReadOnly Property SupportsDirectorySizes As Boolean
    Get
property bool SupportsDirectorySizes {
    bool get ();
}
property bool SupportsDirectorySizes {
    bool get ();
}
abstract SupportsDirectorySizes : bool with get
abstract SupportsDirectorySizes : bool with get

Property Value

Type: Online Boolean
See Also
IFileSystemCapabilities Interface
IFileSystemCapabilities Members
NFX.IO.FileSystem Namespace


IFileSystemCapabilities.SupportsFileModification Property

IFileSystemCapabilities SupportsFileModification Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool SupportsFileModification { get; }
bool SupportsFileModification { get; }
ReadOnly Property SupportsFileModification As Boolean
    Get
ReadOnly Property SupportsFileModification As Boolean
    Get
property bool SupportsFileModification {
    bool get ();
}
property bool SupportsFileModification {
    bool get ();
}
abstract SupportsFileModification : bool with get
abstract SupportsFileModification : bool with get

Property Value

Type: Online Boolean
See Also
IFileSystemCapabilities Interface
IFileSystemCapabilities Members
NFX.IO.FileSystem Namespace


IFileSystemCapabilities.SupportsFileRenaming Property

IFileSystemCapabilities SupportsFileRenaming Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool SupportsFileRenaming { get; }
bool SupportsFileRenaming { get; }
ReadOnly Property SupportsFileRenaming As Boolean
    Get
ReadOnly Property SupportsFileRenaming As Boolean
    Get
property bool SupportsFileRenaming {
    bool get ();
}
property bool SupportsFileRenaming {
    bool get ();
}
abstract SupportsFileRenaming : bool with get
abstract SupportsFileRenaming : bool with get

Property Value

Type: Online Boolean
See Also
IFileSystemCapabilities Interface
IFileSystemCapabilities Members
NFX.IO.FileSystem Namespace


IFileSystemCapabilities.SupportsFileSizes Property

IFileSystemCapabilities SupportsFileSizes Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool SupportsFileSizes { get; }
bool SupportsFileSizes { get; }
ReadOnly Property SupportsFileSizes As Boolean
    Get
ReadOnly Property SupportsFileSizes As Boolean
    Get
property bool SupportsFileSizes {
    bool get ();
}
property bool SupportsFileSizes {
    bool get ();
}
abstract SupportsFileSizes : bool with get
abstract SupportsFileSizes : bool with get

Property Value

Type: Online Boolean
See Also
IFileSystemCapabilities Interface
IFileSystemCapabilities Members
NFX.IO.FileSystem Namespace


IFileSystemCapabilities.SupportsLastAccessTimestamps Property

IFileSystemCapabilities SupportsLastAccessTimestamps Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool SupportsLastAccessTimestamps { get; }
bool SupportsLastAccessTimestamps { get; }
ReadOnly Property SupportsLastAccessTimestamps As Boolean
    Get
ReadOnly Property SupportsLastAccessTimestamps As Boolean
    Get
property bool SupportsLastAccessTimestamps {
    bool get ();
}
property bool SupportsLastAccessTimestamps {
    bool get ();
}
abstract SupportsLastAccessTimestamps : bool with get
abstract SupportsLastAccessTimestamps : bool with get

Property Value

Type: Online Boolean
See Also
IFileSystemCapabilities Interface
IFileSystemCapabilities Members
NFX.IO.FileSystem Namespace


IFileSystemCapabilities.SupportsLastAccessUserNames Property

IFileSystemCapabilities SupportsLastAccessUserNames Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool SupportsLastAccessUserNames { get; }
bool SupportsLastAccessUserNames { get; }
ReadOnly Property SupportsLastAccessUserNames As Boolean
    Get
ReadOnly Property SupportsLastAccessUserNames As Boolean
    Get
property bool SupportsLastAccessUserNames {
    bool get ();
}
property bool SupportsLastAccessUserNames {
    bool get ();
}
abstract SupportsLastAccessUserNames : bool with get
abstract SupportsLastAccessUserNames : bool with get

Property Value

Type: Online Boolean
See Also
IFileSystemCapabilities Interface
IFileSystemCapabilities Members
NFX.IO.FileSystem Namespace


IFileSystemCapabilities.SupportsModificationTimestamps Property

IFileSystemCapabilities SupportsModificationTimestamps Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool SupportsModificationTimestamps { get; }
bool SupportsModificationTimestamps { get; }
ReadOnly Property SupportsModificationTimestamps As Boolean
    Get
ReadOnly Property SupportsModificationTimestamps As Boolean
    Get
property bool SupportsModificationTimestamps {
    bool get ();
}
property bool SupportsModificationTimestamps {
    bool get ();
}
abstract SupportsModificationTimestamps : bool with get
abstract SupportsModificationTimestamps : bool with get

Property Value

Type: Online Boolean
See Also
IFileSystemCapabilities Interface
IFileSystemCapabilities Members
NFX.IO.FileSystem Namespace


IFileSystemCapabilities.SupportsModificationUserNames Property

IFileSystemCapabilities SupportsModificationUserNames Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool SupportsModificationUserNames { get; }
bool SupportsModificationUserNames { get; }
ReadOnly Property SupportsModificationUserNames As Boolean
    Get
ReadOnly Property SupportsModificationUserNames As Boolean
    Get
property bool SupportsModificationUserNames {
    bool get ();
}
property bool SupportsModificationUserNames {
    bool get ();
}
abstract SupportsModificationUserNames : bool with get
abstract SupportsModificationUserNames : bool with get

Property Value

Type: Online Boolean
See Also
IFileSystemCapabilities Interface
IFileSystemCapabilities Members
NFX.IO.FileSystem Namespace


IFileSystemCapabilities.SupportsReadonlyDirectories Property

IFileSystemCapabilities SupportsReadonlyDirectories Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool SupportsReadonlyDirectories { get; }
bool SupportsReadonlyDirectories { get; }
ReadOnly Property SupportsReadonlyDirectories As Boolean
    Get
ReadOnly Property SupportsReadonlyDirectories As Boolean
    Get
property bool SupportsReadonlyDirectories {
    bool get ();
}
property bool SupportsReadonlyDirectories {
    bool get ();
}
abstract SupportsReadonlyDirectories : bool with get
abstract SupportsReadonlyDirectories : bool with get

Property Value

Type: Online Boolean
See Also
IFileSystemCapabilities Interface
IFileSystemCapabilities Members
NFX.IO.FileSystem Namespace


IFileSystemCapabilities.SupportsReadonlyFiles Property

IFileSystemCapabilities SupportsReadonlyFiles Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool SupportsReadonlyFiles { get; }
bool SupportsReadonlyFiles { get; }
ReadOnly Property SupportsReadonlyFiles As Boolean
    Get
ReadOnly Property SupportsReadonlyFiles As Boolean
    Get
property bool SupportsReadonlyFiles {
    bool get ();
}
property bool SupportsReadonlyFiles {
    bool get ();
}
abstract SupportsReadonlyFiles : bool with get
abstract SupportsReadonlyFiles : bool with get

Property Value

Type: Online Boolean
See Also
IFileSystemCapabilities Interface
IFileSystemCapabilities Members
NFX.IO.FileSystem Namespace


IFileSystemCapabilities.SupportsSecurity Property

IFileSystemCapabilities SupportsSecurity Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Indicates whether the file system supports security permissions

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool SupportsSecurity { get; }
bool SupportsSecurity { get; }
ReadOnly Property SupportsSecurity As Boolean
    Get
ReadOnly Property SupportsSecurity As Boolean
    Get
property bool SupportsSecurity {
    bool get ();
}
property bool SupportsSecurity {
    bool get ();
}
abstract SupportsSecurity : bool with get
abstract SupportsSecurity : bool with get

Property Value

Type: Online Boolean
See Also
IFileSystemCapabilities Interface
IFileSystemCapabilities Members
NFX.IO.FileSystem Namespace


IFileSystemCapabilities.SupportsStreamSeek Property

IFileSystemCapabilities SupportsStreamSeek Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool SupportsStreamSeek { get; }
bool SupportsStreamSeek { get; }
ReadOnly Property SupportsStreamSeek As Boolean
    Get
ReadOnly Property SupportsStreamSeek As Boolean
    Get
property bool SupportsStreamSeek {
    bool get ();
}
property bool SupportsStreamSeek {
    bool get ();
}
abstract SupportsStreamSeek : bool with get
abstract SupportsStreamSeek : bool with get

Property Value

Type: Online Boolean
See Also
IFileSystemCapabilities Interface
IFileSystemCapabilities Members
NFX.IO.FileSystem Namespace


IFileSystemCapabilities.SupportsTransactions Property

IFileSystemCapabilities SupportsTransactions Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Indicates whether a file system supports transactions

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool SupportsTransactions { get; }
bool SupportsTransactions { get; }
ReadOnly Property SupportsTransactions As Boolean
    Get
ReadOnly Property SupportsTransactions As Boolean
    Get
property bool SupportsTransactions {
    bool get ();
}
property bool SupportsTransactions {
    bool get ();
}
abstract SupportsTransactions : bool with get
abstract SupportsTransactions : bool with get

Property Value

Type: Online Boolean
See Also
IFileSystemCapabilities Interface
IFileSystemCapabilities Members
NFX.IO.FileSystem Namespace


IFileSystemCapabilities.SupportsVersioning Property

IFileSystemCapabilities SupportsVersioning Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Indicates whether a file system supports versioning

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool SupportsVersioning { get; }
bool SupportsVersioning { get; }
ReadOnly Property SupportsVersioning As Boolean
    Get
ReadOnly Property SupportsVersioning As Boolean
    Get
property bool SupportsVersioning {
    bool get ();
}
property bool SupportsVersioning {
    bool get ();
}
abstract SupportsVersioning : bool with get
abstract SupportsVersioning : bool with get

Property Value

Type: Online Boolean
See Also
IFileSystemCapabilities Interface
IFileSystemCapabilities Members
NFX.IO.FileSystem Namespace


IFileSystemHandle Interface

IFileSystemHandle Interface NFX Class Library

Denotes a handle for item in a file system. For example: in a distributed system this may be some form of unique file/directory id (i.e. a GUID) or object instance internal to implementation

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IFileSystemHandle
public interface IFileSystemHandle
Public Interface IFileSystemHandle
Public Interface IFileSystemHandle
public interface class IFileSystemHandle
public interface class IFileSystemHandle
type IFileSystemHandle =  interface end
type IFileSystemHandle =  interface end
See Also
NFX.IO.FileSystem Namespace


IFileSystemImplementation Interface

IFileSystemImplementation Interface NFX Class Library

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IFileSystemImplementation : IFileSystem,
    IApplicationComponent, INamed, IDisposable, IConfigurable
public interface IFileSystemImplementation : IFileSystem,
    IApplicationComponent, INamed, IDisposable, IConfigurable
Public Interface IFileSystemImplementation
    Inherits IFileSystem, IApplicationComponent, INamed, IDisposable,
    IConfigurable
Public Interface IFileSystemImplementation
    Inherits IFileSystem, IApplicationComponent, INamed, IDisposable,
    IConfigurable
public interface class IFileSystemImplementation : IFileSystem,
    IApplicationComponent, INamed, IDisposable, IConfigurable
public interface class IFileSystemImplementation : IFileSystem,
    IApplicationComponent, INamed, IDisposable, IConfigurable
type IFileSystemImplementation =
    interface
        interface IFileSystem
        interface IApplicationComponent
        interface INamed
        interface IDisposable
        interface IConfigurable
    end
type IFileSystemImplementation =
    interface
        interface IFileSystem
        interface IApplicationComponent
        interface INamed
        interface IDisposable
        interface IConfigurable
    end
See Also
IFileSystemImplementation Members
NFX.IO.FileSystem Namespace


IFileSystemImplementation Members

IFileSystemImplementation Members NFX Class Library

The IFileSystemImplementation type exposes the following members.
Methods
 | Name | Description
Public method | CombinePaths | Combines two or more path segments joining them using primary file system path separator (Inherited from IFileSystem.)
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | StartSession | Creates a new session for the specified user and version (Inherited from IFileSystem.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | GeneralCapabilities | Returns capabilities for this file system in general (Inherited from IFileSystem.)
Public property | InstanceCapabilities | Returns capabilities for this file system instance, that may or may not be the same as GeneralCapabilities (Inherited from IFileSystem.)
Public property | Name | (Inherited from INamed.)
Public property | Sessions | Returns a list of sessions (Inherited from IFileSystem.)
Back to Top
See Also
IFileSystemImplementation Interface
NFX.IO.FileSystem Namespace


IFileSystemImplementation Methods

IFileSystemImplementation Methods NFX Class Library

The IFileSystemImplementation type exposes the following members.
Methods
 | Name | Description
Public method | CombinePaths | Combines two or more path segments joining them using primary file system path separator (Inherited from IFileSystem.)
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | StartSession | Creates a new session for the specified user and version (Inherited from IFileSystem.)
Back to Top
See Also
IFileSystemImplementation Interface
NFX.IO.FileSystem Namespace


IFileSystemImplementation Properties

IFileSystemImplementation Properties NFX Class Library

The IFileSystemImplementation type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | GeneralCapabilities | Returns capabilities for this file system in general (Inherited from IFileSystem.)
Public property | InstanceCapabilities | Returns capabilities for this file system instance, that may or may not be the same as GeneralCapabilities (Inherited from IFileSystem.)
Public property | Name | (Inherited from INamed.)
Public property | Sessions | Returns a list of sessions (Inherited from IFileSystem.)
Back to Top
See Also
IFileSystemImplementation Interface
NFX.IO.FileSystem Namespace


IFileSystemTransactionHandle Interface

IFileSystemTransactionHandle Interface NFX Class Library

Denotes a handle for transaction in a file system. For example: in a distributed system this may be an object instance holding information about transaction which is internal to implementation

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IFileSystemTransactionHandle
public interface IFileSystemTransactionHandle
Public Interface IFileSystemTransactionHandle
Public Interface IFileSystemTransactionHandle
public interface class IFileSystemTransactionHandle
public interface class IFileSystemTransactionHandle
type IFileSystemTransactionHandle =  interface end
type IFileSystemTransactionHandle =  interface end
See Also
NFX.IO.FileSystem Namespace


IFileSystemVersion Interface

IFileSystemVersion Interface NFX Class Library

Decorates entities that represent version for file systems that support versioning

Namespace: NFX.IO.FileSystem
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IFileSystemVersion : INamed
public interface IFileSystemVersion : INamed
Public Interface IFileSystemVersion
    Inherits INamed
Public Interface IFileSystemVersion
    Inherits INamed
public interface class IFileSystemVersion : INamed
public interface class IFileSystemVersion : INamed
type IFileSystemVersion =
    interface
        interface INamed
    end
type IFileSystemVersion =
    interface
        interface INamed
    end
See Also
IFileSystemVersion Members
NFX.IO.FileSystem Namespace


IFileSystemVersion Members

IFileSystemVersion Members NFX Class Library

The IFileSystemVersion type exposes the following members.
Properties
 | Name | Description
Public property | Name | (Inherited from INamed.)
Back to Top
See Also
IFileSystemVersion Interface
NFX.IO.FileSystem Namespace


IFileSystemVersion Properties

IFileSystemVersion Properties NFX Class Library

The IFileSystemVersion type exposes the following members.
Properties
 | Name | Description
Public property | Name | (Inherited from INamed.)
Back to Top
See Also
IFileSystemVersion Interface
NFX.IO.FileSystem Namespace


NFX.IO.FileSystem.GoogleDrive Namespace

NFX.IO.FileSystem.GoogleDrive Namespace NFX Class Library

Classes
 | Class | Description
Protected class | Ensure |
Protected class | Extensions |
Public class | GoogleDriveCredentials | Google Drive credentials
Protected class | GoogleDriveMimeType | Google Drive Mime Types
Public class | GoogleDriveParameters |
Protected class | GoogleDrivePath | Methods for working with paths


Ensure Class

Ensure Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.GoogleDrive Ensure

Namespace: NFX.IO.FileSystem.GoogleDrive
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static class Ensure
internal static class Ensure
Friend NotInheritable Class Ensure
Friend NotInheritable Class Ensure
internal ref class Ensure abstract sealed
internal ref class Ensure abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Ensure =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Ensure =  class end
See Also
Ensure Members
NFX.IO.FileSystem.GoogleDrive Namespace


Ensure Members

Ensure Members NFX Class Library

The Ensure type exposes the following members.
Methods
Name | Description
NotNull |
Back to Top
See Also
Ensure Class
NFX.IO.FileSystem.GoogleDrive Namespace


Ensure Methods

Ensure Methods NFX Class Library

The Ensure type exposes the following members.
Methods
Name | Description
NotNull |
Back to Top
See Also
Ensure Class
NFX.IO.FileSystem.GoogleDrive Namespace


Ensure.NotNull Method

Ensure NotNull Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void NotNull(
    Object value,
    string name
)
public static void NotNull(
    Object value,
    string name
)
Public Shared Sub NotNull (
    value As Object,
    name As String
)
Public Shared Sub NotNull (
    value As Object,
    name As String
)
public:
static void NotNull(
    Object^ value,
    String^ name
)
public:
static void NotNull(
    Object^ value,
    String^ name
)
static member NotNull :
        value : Object *
        name : string -> unit
static member NotNull :
        value : Object *
        name : string -> unit

Parameters

value
Type: Online System Object
name
Type: Online System String
See Also
Ensure Class
Ensure Members
NFX.IO.FileSystem.GoogleDrive Namespace


Extensions Class

Extensions Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.GoogleDrive Extensions

Namespace: NFX.IO.FileSystem.GoogleDrive
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static class Extensions
internal static class Extensions
<ExtensionAttribute>
Friend NotInheritable Class Extensions
<ExtensionAttribute>
Friend NotInheritable Class Extensions
[ExtensionAttribute]
internal ref class Extensions abstract sealed
[ExtensionAttribute]
internal ref class Extensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Extensions =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Extensions =  class end
See Also
Extensions Members
NFX.IO.FileSystem.GoogleDrive Namespace


Extensions Members

Extensions Members NFX Class Library

The Extensions type exposes the following members.
Methods
Name | Description
FormatUri |
GetJsonAsDynamic |
GetString |
ToFormEncoded |
ToStream |
Back to Top
See Also
Extensions Class
NFX.IO.FileSystem.GoogleDrive Namespace


Extensions Methods

Extensions Methods NFX Class Library

The Extensions type exposes the following members.
Methods
Name | Description
FormatUri |
GetJsonAsDynamic |
GetString |
ToFormEncoded |
ToStream |
Back to Top
See Also
Extensions Class
NFX.IO.FileSystem.GoogleDrive Namespace


Extensions.FormatUri Method

Extensions FormatUri Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Uri FormatUri(
    this string template,
    params Object[] args
)
public static Uri FormatUri(
    this string template,
    params Object[] args
)
<ExtensionAttribute>
Public Shared Function FormatUri (
    template As String,
    ParamArray args As Object()
) As Uri
<ExtensionAttribute>
Public Shared Function FormatUri (
    template As String,
    ParamArray args As Object()
) As Uri
public:
[ExtensionAttribute]
static Uri^ FormatUri(
    String^ template,
    ... array<Object^>^ args
)
public:
[ExtensionAttribute]
static Uri^ FormatUri(
    String^ template,
    ... array<Object^>^ args
)
static member FormatUri :
        template : string *
        args : Object[] -> Uri
static member FormatUri :
        template : string *
        args : Object[] -> Uri

Parameters

template
Type: Online System String
args
Type: Online System Object

Return Value

Type: Online Uri

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
Extensions Class
Extensions Members
NFX.IO.FileSystem.GoogleDrive Namespace


Extensions.GetJsonAsDynamic Method

Extensions GetJsonAsDynamic Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Object GetJsonAsDynamic(
    this HttpWebResponse res
)
public static Object GetJsonAsDynamic(
    this HttpWebResponse res
)
<ExtensionAttribute>
Public Shared Function GetJsonAsDynamic (
    res As HttpWebResponse
) As Object
<ExtensionAttribute>
Public Shared Function GetJsonAsDynamic (
    res As HttpWebResponse
) As Object
public:
[ExtensionAttribute]
static Object^ GetJsonAsDynamic(
    HttpWebResponse^ res
)
public:
[ExtensionAttribute]
static Object^ GetJsonAsDynamic(
    HttpWebResponse^ res
)
static member GetJsonAsDynamic :
        res : HttpWebResponse -> Object
static member GetJsonAsDynamic :
        res : HttpWebResponse -> Object

Parameters

res
Type: Online System.Net HttpWebResponse

Return Value

Type: Online Object

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online HttpWebResponse. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
Extensions Class
Extensions Members
NFX.IO.FileSystem.GoogleDrive Namespace


Extensions.GetString Method

Extensions GetString Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetString(
    this HttpWebResponse res
)
public static string GetString(
    this HttpWebResponse res
)
<ExtensionAttribute>
Public Shared Function GetString (
    res As HttpWebResponse
) As String
<ExtensionAttribute>
Public Shared Function GetString (
    res As HttpWebResponse
) As String
public:
[ExtensionAttribute]
static String^ GetString(
    HttpWebResponse^ res
)
public:
[ExtensionAttribute]
static String^ GetString(
    HttpWebResponse^ res
)
static member GetString :
        res : HttpWebResponse -> string
static member GetString :
        res : HttpWebResponse -> string

Parameters

res
Type: Online System.Net HttpWebResponse

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online HttpWebResponse. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
Extensions Class
Extensions Members
NFX.IO.FileSystem.GoogleDrive Namespace


Extensions.ToFormEncoded Method

Extensions ToFormEncoded Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ToFormEncoded(
    this GoogleDriveRequestBody data
)
public static string ToFormEncoded(
    this GoogleDriveRequestBody data
)
<ExtensionAttribute>
Public Shared Function ToFormEncoded (
    data As GoogleDriveRequestBody
) As String
<ExtensionAttribute>
Public Shared Function ToFormEncoded (
    data As GoogleDriveRequestBody
) As String
public:
[ExtensionAttribute]
static String^ ToFormEncoded(
    GoogleDriveRequestBody^ data
)
public:
[ExtensionAttribute]
static String^ ToFormEncoded(
    GoogleDriveRequestBody^ data
)
static member ToFormEncoded :
        data : GoogleDriveRequestBody -> string
static member ToFormEncoded :
        data : GoogleDriveRequestBody -> string

Parameters

data
Type: NFX.IO.FileSystem.GoogleDrive.V2 GoogleDriveRequestBody

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type GoogleDriveRequestBody. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
Extensions Class
Extensions Members
NFX.IO.FileSystem.GoogleDrive Namespace


Extensions.ToStream Method

Extensions ToStream Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Stream ToStream(
    this string value
)
public static Stream ToStream(
    this string value
)
<ExtensionAttribute>
Public Shared Function ToStream (
    value As String
) As Stream
<ExtensionAttribute>
Public Shared Function ToStream (
    value As String
) As Stream
public:
[ExtensionAttribute]
static Stream^ ToStream(
    String^ value
)
public:
[ExtensionAttribute]
static Stream^ ToStream(
    String^ value
)
static member ToStream :
        value : string -> Stream
static member ToStream :
        value : string -> Stream

Parameters

value
Type: Online System String

Return Value

Type: Online Stream

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
Extensions Class
Extensions Members
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDriveCredentials Class

GoogleDriveCredentials Class NFX Class Library

Google Drive credentials
Inheritance Hierarchy
Online System Object
NFX.Security Credentials
NFX.IO.FileSystem.GoogleDrive GoogleDriveCredentials

Namespace: NFX.IO.FileSystem.GoogleDrive
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GoogleDriveCredentials : Credentials
public class GoogleDriveCredentials : Credentials
Public Class GoogleDriveCredentials
    Inherits Credentials
Public Class GoogleDriveCredentials
    Inherits Credentials
public ref class GoogleDriveCredentials : public Credentials
public ref class GoogleDriveCredentials : public Credentials
type GoogleDriveCredentials =
    class
        inherit Credentials
    end
type GoogleDriveCredentials =
    class
        inherit Credentials
    end
See Also
GoogleDriveCredentials Members
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDriveCredentials Members

GoogleDriveCredentials Members NFX Class Library

The GoogleDriveCredentials type exposes the following members.
Constructors
 | Name | Description
Public method | GoogleDriveCredentials | Initializes a new instance of the GoogleDriveCredentials class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Forget | Deletes sensitive information (such as password). This method is mostly used on client (vs. server) to prevent process memory-inspection attack. Its is usually called right after Login() was called. Implementers may consider forcing post-factum GC.Collect() on all generations to make sure that orphaned memory buff with sensitive information, that remains in RAM even after all references are killed, gets compacted; consequently, this method may take considerable time to execute. (Inherited from Credentials.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Email |
Public property | Forgotten | Indicates whether Forget() was called on this instance (Inherited from Credentials.)
Back to Top
See Also
GoogleDriveCredentials Class
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDriveCredentials Constructor

GoogleDriveCredentials Constructor NFX Class Library

Initializes a new instance of the GoogleDriveCredentials class

Namespace: NFX.IO.FileSystem.GoogleDrive
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GoogleDriveCredentials(
    string email
)
public GoogleDriveCredentials(
    string email
)
Public Sub New (
    email As String
)
Public Sub New (
    email As String
)
public:
GoogleDriveCredentials(
    String^ email
)
public:
GoogleDriveCredentials(
    String^ email
)
new :
        email : string -> GoogleDriveCredentials
new :
        email : string -> GoogleDriveCredentials

Parameters

email
Type: Online System String
See Also
GoogleDriveCredentials Class
GoogleDriveCredentials Members
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDriveCredentials Methods

GoogleDriveCredentials Methods NFX Class Library

The GoogleDriveCredentials type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Forget | Deletes sensitive information (such as password). This method is mostly used on client (vs. server) to prevent process memory-inspection attack. Its is usually called right after Login() was called. Implementers may consider forcing post-factum GC.Collect() on all generations to make sure that orphaned memory buff with sensitive information, that remains in RAM even after all references are killed, gets compacted; consequently, this method may take considerable time to execute. (Inherited from Credentials.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GoogleDriveCredentials Class
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDriveCredentials Properties

GoogleDriveCredentials Properties NFX Class Library

The GoogleDriveCredentials type exposes the following members.
Properties
 | Name | Description
Public property | Email |
Public property | Forgotten | Indicates whether Forget() was called on this instance (Inherited from Credentials.)
Back to Top
See Also
GoogleDriveCredentials Class
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDriveCredentials.Email Property

GoogleDriveCredentials Email Property NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Email { get; set; }
public string Email { get; set; }
Public Property Email As String
    Get
    Set
Public Property Email As String
    Get
    Set
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}
member Email : string with get, set
member Email : string with get, set

Property Value

Type: Online String
See Also
GoogleDriveCredentials Class
GoogleDriveCredentials Members
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDriveMimeType Class

GoogleDriveMimeType Class NFX Class Library

Google Drive Mime Types
Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.GoogleDrive GoogleDriveMimeType

Namespace: NFX.IO.FileSystem.GoogleDrive
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static class GoogleDriveMimeType
internal static class GoogleDriveMimeType
Friend NotInheritable Class GoogleDriveMimeType
Friend NotInheritable Class GoogleDriveMimeType
internal ref class GoogleDriveMimeType abstract sealed
internal ref class GoogleDriveMimeType abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GoogleDriveMimeType =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GoogleDriveMimeType =  class end
See Also
GoogleDriveMimeType Members
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDriveMimeType Members

GoogleDriveMimeType Members NFX Class Library

The GoogleDriveMimeType type exposes the following members.
Fields
Name | Description
FOLDER |
Back to Top
See Also
GoogleDriveMimeType Class
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDriveMimeType Fields

GoogleDriveMimeType Fields NFX Class Library

The GoogleDriveMimeType type exposes the following members.
Fields
Name | Description
FOLDER |
Back to Top
See Also
GoogleDriveMimeType Class
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDriveMimeType.FOLDER Field

GoogleDriveMimeType FOLDER Field NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string FOLDER
public static readonly string FOLDER
Public Shared ReadOnly FOLDER As String
Public Shared ReadOnly FOLDER As String
public:
static initonly String^ FOLDER
public:
static initonly String^ FOLDER
static val FOLDER: string
static val FOLDER: string

Field Value

Type: Online String
See Also
GoogleDriveMimeType Class
GoogleDriveMimeType Members
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDriveParameters Class

GoogleDriveParameters Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem FileSystemSessionConnectParams
NFX.IO.FileSystem.GoogleDrive GoogleDriveParameters

Namespace: NFX.IO.FileSystem.GoogleDrive
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GoogleDriveParameters : FileSystemSessionConnectParams
public class GoogleDriveParameters : FileSystemSessionConnectParams
Public Class GoogleDriveParameters
    Inherits FileSystemSessionConnectParams
Public Class GoogleDriveParameters
    Inherits FileSystemSessionConnectParams
public ref class GoogleDriveParameters : public FileSystemSessionConnectParams
public ref class GoogleDriveParameters : public FileSystemSessionConnectParams
type GoogleDriveParameters =
    class
        inherit FileSystemSessionConnectParams
    end
type GoogleDriveParameters =
    class
        inherit FileSystemSessionConnectParams
    end
See Also
GoogleDriveParameters Members
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDriveParameters Members

GoogleDriveParameters Members NFX Class Library

The GoogleDriveParameters type exposes the following members.
Constructors
 | Name | Description
Public method | GoogleDriveParameters | Initializes a new instance of the GoogleDriveParameters class
Public method | GoogleDriveParameters(IConfigSectionNode) | Initializes a new instance of the GoogleDriveParameters class
Public method | GoogleDriveParameters(String, String) | Initializes a new instance of the GoogleDriveParameters class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Overrides FileSystemSessionConnectParams Configure(IConfigSectionNode).)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_CERT_PATH_ATTR |
CONFIG_EMAIL_ATTR |
Back to Top
Properties
 | Name | Description
Public property | Attempts |
Public property | CertPath |
Public property | Name | (Inherited from FileSystemSessionConnectParams.)
Public property | TimeoutMs |
Public property | User | (Inherited from FileSystemSessionConnectParams.)
Public property | Version | (Inherited from FileSystemSessionConnectParams.)
Back to Top
See Also
GoogleDriveParameters Class
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDriveParameters Constructor

GoogleDriveParameters Constructor NFX Class Library

Overload List
 | Name | Description
Public method | GoogleDriveParameters | Initializes a new instance of the GoogleDriveParameters class
Public method | GoogleDriveParameters(IConfigSectionNode) | Initializes a new instance of the GoogleDriveParameters class
Public method | GoogleDriveParameters(String, String) | Initializes a new instance of the GoogleDriveParameters class
Back to Top
See Also
GoogleDriveParameters Class
GoogleDriveParameters Members
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDriveParameters Constructor

GoogleDriveParameters Constructor NFX Class Library

Initializes a new instance of the GoogleDriveParameters class

Namespace: NFX.IO.FileSystem.GoogleDrive
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GoogleDriveParameters()
public GoogleDriveParameters()
Public Sub New
Public Sub New
public:
GoogleDriveParameters()
public:
GoogleDriveParameters()
new : unit -> GoogleDriveParameters
new : unit -> GoogleDriveParameters
See Also
GoogleDriveParameters Class
GoogleDriveParameters Members
GoogleDriveParameters Overload
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDriveParameters Constructor (IConfigSectionNode)

GoogleDriveParameters Constructor (IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the GoogleDriveParameters class

Namespace: NFX.IO.FileSystem.GoogleDrive
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GoogleDriveParameters(
    IConfigSectionNode node
)
public GoogleDriveParameters(
    IConfigSectionNode node
)
Public Sub New (
    node As IConfigSectionNode
)
Public Sub New (
    node As IConfigSectionNode
)
public:
GoogleDriveParameters(
    IConfigSectionNode^ node
)
public:
GoogleDriveParameters(
    IConfigSectionNode^ node
)
new :
        node : IConfigSectionNode -> GoogleDriveParameters
new :
        node : IConfigSectionNode -> GoogleDriveParameters

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
GoogleDriveParameters Class
GoogleDriveParameters Members
GoogleDriveParameters Overload
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDriveParameters Constructor (String, String)

GoogleDriveParameters Constructor (String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the GoogleDriveParameters class

Namespace: NFX.IO.FileSystem.GoogleDrive
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GoogleDriveParameters(
    string connectStr,
    string format = "laconf"
)
public GoogleDriveParameters(
    string connectStr,
    string format = "laconf"
)
Public Sub New (
    connectStr As String,
    Optional format As String = "laconf"
)
Public Sub New (
    connectStr As String,
    Optional format As String = "laconf"
)
public:
GoogleDriveParameters(
    String^ connectStr,
    String^ format = L"laconf"
)
public:
GoogleDriveParameters(
    String^ connectStr,
    String^ format = L"laconf"
)
new :
        connectStr : string *
        ?format : string
(* Defaults:
        let _format = defaultArg format "laconf"
*)
-> GoogleDriveParameters
new :
        connectStr : string *
        ?format : string
(* Defaults:
        let _format = defaultArg format "laconf"
*)
-> GoogleDriveParameters

Parameters

connectStr
Type: Online System String
format (Optional)
Type: Online System String
See Also
GoogleDriveParameters Class
GoogleDriveParameters Members
GoogleDriveParameters Overload
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDriveParameters Fields

GoogleDriveParameters Fields NFX Class Library

The GoogleDriveParameters type exposes the following members.
Fields
Name | Description
CONFIG_CERT_PATH_ATTR |
CONFIG_EMAIL_ATTR |
Back to Top
See Also
GoogleDriveParameters Class
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDriveParameters.CONFIG_CERT_PATH_ATTR Field

GoogleDriveParameters CONFIG_CERT_PATH_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CERT_PATH_ATTR
public const string CONFIG_CERT_PATH_ATTR
Public Const CONFIG_CERT_PATH_ATTR As String
Public Const CONFIG_CERT_PATH_ATTR As String
public:
literal String^ CONFIG_CERT_PATH_ATTR
public:
literal String^ CONFIG_CERT_PATH_ATTR
static val mutable CONFIG_CERT_PATH_ATTR: string
static val mutable CONFIG_CERT_PATH_ATTR: string

Field Value

Type: Online String
See Also
GoogleDriveParameters Class
GoogleDriveParameters Members
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDriveParameters.CONFIG_EMAIL_ATTR Field

GoogleDriveParameters CONFIG_EMAIL_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_EMAIL_ATTR
public const string CONFIG_EMAIL_ATTR
Public Const CONFIG_EMAIL_ATTR As String
Public Const CONFIG_EMAIL_ATTR As String
public:
literal String^ CONFIG_EMAIL_ATTR
public:
literal String^ CONFIG_EMAIL_ATTR
static val mutable CONFIG_EMAIL_ATTR: string
static val mutable CONFIG_EMAIL_ATTR: string

Field Value

Type: Online String
See Also
GoogleDriveParameters Class
GoogleDriveParameters Members
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDriveParameters Methods

GoogleDriveParameters Methods NFX Class Library

The GoogleDriveParameters type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Overrides FileSystemSessionConnectParams Configure(IConfigSectionNode).)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GoogleDriveParameters Class
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDriveParameters.Configure Method

GoogleDriveParameters Configure Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Configure(
    IConfigSectionNode node
)
public override void Configure(
    IConfigSectionNode node
)
Public Overrides Sub Configure (
    node As IConfigSectionNode
)
Public Overrides Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) override
public:
virtual void Configure(
    IConfigSectionNode^ node
) override
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
GoogleDriveParameters Class
GoogleDriveParameters Members
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDriveParameters Properties

GoogleDriveParameters Properties NFX Class Library

The GoogleDriveParameters type exposes the following members.
Properties
 | Name | Description
Public property | Attempts |
Public property | CertPath |
Public property | Name | (Inherited from FileSystemSessionConnectParams.)
Public property | TimeoutMs |
Public property | User | (Inherited from FileSystemSessionConnectParams.)
Public property | Version | (Inherited from FileSystemSessionConnectParams.)
Back to Top
See Also
GoogleDriveParameters Class
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDriveParameters.Attempts Property

GoogleDriveParameters Attempts Property NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int Attempts { get; set; }
[ConfigAttribute]
public int Attempts { get; set; }
<ConfigAttribute>
Public Property Attempts As Integer
    Get
    Set
<ConfigAttribute>
Public Property Attempts As Integer
    Get
    Set
public:
[ConfigAttribute]
property int Attempts {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute]
property int Attempts {
    int get ();
    void set (int value);
}
[<ConfigAttribute>]
member Attempts : int with get, set
[<ConfigAttribute>]
member Attempts : int with get, set

Property Value

Type: Online Int32
See Also
GoogleDriveParameters Class
GoogleDriveParameters Members
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDriveParameters.CertPath Property

GoogleDriveParameters CertPath Property NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string CertPath { get; set; }
[ConfigAttribute]
public string CertPath { get; set; }
<ConfigAttribute>
Public Property CertPath As String
    Get
    Set
<ConfigAttribute>
Public Property CertPath As String
    Get
    Set
public:
[ConfigAttribute]
property String^ CertPath {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ CertPath {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member CertPath : string with get, set
[<ConfigAttribute>]
member CertPath : string with get, set

Property Value

Type: Online String
See Also
GoogleDriveParameters Class
GoogleDriveParameters Members
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDriveParameters.TimeoutMs Property

GoogleDriveParameters TimeoutMs Property NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int TimeoutMs { get; set; }
[ConfigAttribute]
public int TimeoutMs { get; set; }
<ConfigAttribute>
Public Property TimeoutMs As Integer
    Get
    Set
<ConfigAttribute>
Public Property TimeoutMs As Integer
    Get
    Set
public:
[ConfigAttribute]
property int TimeoutMs {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute]
property int TimeoutMs {
    int get ();
    void set (int value);
}
[<ConfigAttribute>]
member TimeoutMs : int with get, set
[<ConfigAttribute>]
member TimeoutMs : int with get, set

Property Value

Type: Online Int32
See Also
GoogleDriveParameters Class
GoogleDriveParameters Members
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDrivePath Class

GoogleDrivePath Class NFX Class Library

Methods for working with paths
Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.GoogleDrive GoogleDrivePath

Namespace: NFX.IO.FileSystem.GoogleDrive
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static class GoogleDrivePath
internal static class GoogleDrivePath
Friend NotInheritable Class GoogleDrivePath
Friend NotInheritable Class GoogleDrivePath
internal ref class GoogleDrivePath abstract sealed
internal ref class GoogleDrivePath abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GoogleDrivePath =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GoogleDrivePath =  class end
See Also
GoogleDrivePath Members
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDrivePath Members

GoogleDrivePath Members NFX Class Library

The GoogleDrivePath type exposes the following members.
Methods
Name | Description
GetParentPath |
Split |
Back to Top
See Also
GoogleDrivePath Class
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDrivePath Methods

GoogleDrivePath Methods NFX Class Library

The GoogleDrivePath type exposes the following members.
Methods
Name | Description
GetParentPath |
Split |
Back to Top
See Also
GoogleDrivePath Class
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDrivePath.GetParentPath Method

GoogleDrivePath GetParentPath Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetParentPath(
    string path
)
public static string GetParentPath(
    string path
)
Public Shared Function GetParentPath (
    path As String
) As String
Public Shared Function GetParentPath (
    path As String
) As String
public:
static String^ GetParentPath(
    String^ path
)
public:
static String^ GetParentPath(
    String^ path
)
static member GetParentPath :
        path : string -> string
static member GetParentPath :
        path : string -> string

Parameters

path
Type: Online System String

Return Value

Type: Online String
See Also
GoogleDrivePath Class
GoogleDrivePath Members
NFX.IO.FileSystem.GoogleDrive Namespace


GoogleDrivePath.Split Method

GoogleDrivePath Split Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string[] Split(
    string path
)
public static string[] Split(
    string path
)
Public Shared Function Split (
    path As String
) As String()
Public Shared Function Split (
    path As String
) As String()
public:
static array<String^>^ Split(
    String^ path
)
public:
static array<String^>^ Split(
    String^ path
)
static member Split :
        path : string -> string[]
static member Split :
        path : string -> string[]

Parameters

path
Type: Online System String

Return Value

Type: Online String
See Also
GoogleDrivePath Class
GoogleDrivePath Members
NFX.IO.FileSystem.GoogleDrive Namespace


NFX.IO.FileSystem.GoogleDrive.Auth Namespace

NFX.IO.FileSystem.GoogleDrive.Auth Namespace NFX Class Library

[This is preliminary documentation and is subject to change.]

Classes
 | Class | Description
Public class | JsonWebToken | JWT (https://developers.google.com/identity/protocols/OAuth2ServiceAccount). A JWT is composed of three parts: a header, a claim set, and a signature. The header and claim set are JSON objects. These JSON objects are serialized to UTF-8 bytes, then encoded using the Base64url encoding. This encoding provides resilience against encoding changes due to repeated encoding operations. The header, claim set, and signature are concatenated together with a period (.) character. {Base64url encoded header}.{Base64url encoded claim set}.{Base64url encoded signature}


JsonWebToken Class

JsonWebToken Class NFX Class Library

JWT (https://developers.google.com/identity/protocols/OAuth2ServiceAccount). A JWT is composed of three parts: a header, a claim set, and a signature. The header and claim set are JSON objects. These JSON objects are serialized to UTF-8 bytes, then encoded using the Base64url encoding. This encoding provides resilience against encoding changes due to repeated encoding operations. The header, claim set, and signature are concatenated together with a period (.) character. {Base64url encoded header}.{Base64url encoded claim set}.{Base64url encoded signature}
Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.GoogleDrive.Auth JsonWebToken

Namespace: NFX.IO.FileSystem.GoogleDrive.Auth
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class JsonWebToken
public class JsonWebToken
Public Class JsonWebToken
Public Class JsonWebToken
public ref class JsonWebToken
public ref class JsonWebToken
type JsonWebToken =  class end
type JsonWebToken =  class end
See Also
JsonWebToken Members
NFX.IO.FileSystem.GoogleDrive.Auth Namespace


JsonWebToken Members

JsonWebToken Members NFX Class Library

The JsonWebToken type exposes the following members.
Constructors
 | Name | Description
Public method | JsonWebToken | Initializes a new instance of the JsonWebToken class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Refresh |
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
GRANT_TYPE |
Back to Top
See Also
JsonWebToken Class
NFX.IO.FileSystem.GoogleDrive.Auth Namespace


JsonWebToken Constructor

JsonWebToken Constructor NFX Class Library

Initializes a new instance of the JsonWebToken class

Namespace: NFX.IO.FileSystem.GoogleDrive.Auth
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JsonWebToken(
    string email,
    string certPath
)
public JsonWebToken(
    string email,
    string certPath
)
Public Sub New (
    email As String,
    certPath As String
)
Public Sub New (
    email As String,
    certPath As String
)
public:
JsonWebToken(
    String^ email,
    String^ certPath
)
public:
JsonWebToken(
    String^ email,
    String^ certPath
)
new :
        email : string *
        certPath : string -> JsonWebToken
new :
        email : string *
        certPath : string -> JsonWebToken

Parameters

email
Type: Online System String
certPath
Type: Online System String
See Also
JsonWebToken Class
JsonWebToken Members
NFX.IO.FileSystem.GoogleDrive.Auth Namespace


JsonWebToken Fields

JsonWebToken Fields NFX Class Library

The JsonWebToken type exposes the following members.
Fields
Name | Description
GRANT_TYPE |
Back to Top
See Also
JsonWebToken Class
NFX.IO.FileSystem.GoogleDrive.Auth Namespace


JsonWebToken.GRANT_TYPE Field

JsonWebToken GRANT_TYPE Field NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.Auth
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string GRANT_TYPE
public static readonly string GRANT_TYPE
Public Shared ReadOnly GRANT_TYPE As String
Public Shared ReadOnly GRANT_TYPE As String
public:
static initonly String^ GRANT_TYPE
public:
static initonly String^ GRANT_TYPE
static val GRANT_TYPE: string
static val GRANT_TYPE: string

Field Value

Type: Online String
See Also
JsonWebToken Class
JsonWebToken Members
NFX.IO.FileSystem.GoogleDrive.Auth Namespace


JsonWebToken Methods

JsonWebToken Methods NFX Class Library

The JsonWebToken type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Refresh |
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
JsonWebToken Class
NFX.IO.FileSystem.GoogleDrive.Auth Namespace


JsonWebToken.Refresh Method

JsonWebToken Refresh Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.Auth
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Refresh()
public void Refresh()
Public Sub Refresh
Public Sub Refresh
public:
void Refresh()
public:
void Refresh()
member Refresh : unit -> unit
member Refresh : unit -> unit
See Also
JsonWebToken Class
JsonWebToken Members
NFX.IO.FileSystem.GoogleDrive.Auth Namespace


JsonWebToken.ToString Method

JsonWebToken ToString Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.Auth
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
JsonWebToken Class
JsonWebToken Members
NFX.IO.FileSystem.GoogleDrive.Auth Namespace


NFX.IO.FileSystem.GoogleDrive.V2 Namespace

NFX.IO.FileSystem.GoogleDrive.V2 Namespace NFX Class Library

Classes
 | Class | Description
Protected class | ApiUrls | Google Drive REST API URLs
Public class | GoogleDriveCapabilities |
Public class | GoogleDriveClient | Google Drive REST API wrapper.
Public class | GoogleDriveFileSystem | Implements FileSystem for Google Drive
Public class | GoogleDriveHandle | Google Drive file handle
Protected class | GoogleDriveRequestBody | Represents a request to Google Drive REST API
Public class | GoogleDriveSession |
Public class | GoogleDriveStream |
Protected class | Metadata | Google Drive metadata fields


ApiUrls Class

ApiUrls Class NFX Class Library

Google Drive REST API URLs
Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.GoogleDrive.V2 ApiUrls

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static class ApiUrls
internal static class ApiUrls
Friend NotInheritable Class ApiUrls
Friend NotInheritable Class ApiUrls
internal ref class ApiUrls abstract sealed
internal ref class ApiUrls abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ApiUrls =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ApiUrls =  class end
See Also
ApiUrls Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


ApiUrls Members

ApiUrls Members NFX Class Library

The ApiUrls type exposes the following members.
Methods
Name | Description
Download |
Drive |
FileById |
FileByName |
Files |
Files(String) |
GoogleApi |
Rename |
SetModifiedDate |
Subfolders |
Token |
Update |
Upload |
Back to Top
See Also
ApiUrls Class
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


ApiUrls Methods

ApiUrls Methods NFX Class Library

The ApiUrls type exposes the following members.
Methods
Name | Description
Download |
Drive |
FileById |
FileByName |
Files |
Files(String) |
GoogleApi |
Rename |
SetModifiedDate |
Subfolders |
Token |
Update |
Upload |
Back to Top
See Also
ApiUrls Class
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


ApiUrls.Download Method

ApiUrls Download Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Uri Download(
    string id
)
public static Uri Download(
    string id
)
Public Shared Function Download (
    id As String
) As Uri
Public Shared Function Download (
    id As String
) As Uri
public:
static Uri^ Download(
    String^ id
)
public:
static Uri^ Download(
    String^ id
)
static member Download :
        id : string -> Uri
static member Download :
        id : string -> Uri

Parameters

id
Type: Online System String

Return Value

Type: Online Uri
See Also
ApiUrls Class
ApiUrls Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


ApiUrls.Drive Method

ApiUrls Drive Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Uri Drive()
public static Uri Drive()
Public Shared Function Drive As Uri
Public Shared Function Drive As Uri
public:
static Uri^ Drive()
public:
static Uri^ Drive()
static member Drive : unit -> Uri
static member Drive : unit -> Uri

Return Value

Type: Online Uri
See Also
ApiUrls Class
ApiUrls Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


ApiUrls.FileById Method

ApiUrls FileById Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Uri FileById(
    string id
)
public static Uri FileById(
    string id
)
Public Shared Function FileById (
    id As String
) As Uri
Public Shared Function FileById (
    id As String
) As Uri
public:
static Uri^ FileById(
    String^ id
)
public:
static Uri^ FileById(
    String^ id
)
static member FileById :
        id : string -> Uri
static member FileById :
        id : string -> Uri

Parameters

id
Type: Online System String

Return Value

Type: Online Uri
See Also
ApiUrls Class
ApiUrls Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


ApiUrls.FileByName Method

ApiUrls FileByName Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Uri FileByName(
    string parentId,
    string name
)
public static Uri FileByName(
    string parentId,
    string name
)
Public Shared Function FileByName (
    parentId As String,
    name As String
) As Uri
Public Shared Function FileByName (
    parentId As String,
    name As String
) As Uri
public:
static Uri^ FileByName(
    String^ parentId,
    String^ name
)
public:
static Uri^ FileByName(
    String^ parentId,
    String^ name
)
static member FileByName :
        parentId : string *
        name : string -> Uri
static member FileByName :
        parentId : string *
        name : string -> Uri

Parameters

parentId
Type: Online System String
name
Type: Online System String

Return Value

Type: Online Uri
See Also
ApiUrls Class
ApiUrls Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


ApiUrls.Files Method

ApiUrls Files Method NFX Class Library

Overload List
Name | Description
Files |
Files(String) |
Back to Top
See Also
ApiUrls Class
ApiUrls Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


ApiUrls.Files Method

ApiUrls Files Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Uri Files()
public static Uri Files()
Public Shared Function Files As Uri
Public Shared Function Files As Uri
public:
static Uri^ Files()
public:
static Uri^ Files()
static member Files : unit -> Uri
static member Files : unit -> Uri

Return Value

Type: Online Uri
See Also
ApiUrls Class
ApiUrls Members
Files Overload
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


ApiUrls.Files Method (String)

ApiUrls Files Method (String) NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Uri Files(
    string parentId
)
public static Uri Files(
    string parentId
)
Public Shared Function Files (
    parentId As String
) As Uri
Public Shared Function Files (
    parentId As String
) As Uri
public:
static Uri^ Files(
    String^ parentId
)
public:
static Uri^ Files(
    String^ parentId
)
static member Files :
        parentId : string -> Uri
static member Files :
        parentId : string -> Uri

Parameters

parentId
Type: Online System String

Return Value

Type: Online Uri
See Also
ApiUrls Class
ApiUrls Members
Files Overload
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


ApiUrls.GoogleApi Method

ApiUrls GoogleApi Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Uri GoogleApi()
public static Uri GoogleApi()
Public Shared Function GoogleApi As Uri
Public Shared Function GoogleApi As Uri
public:
static Uri^ GoogleApi()
public:
static Uri^ GoogleApi()
static member GoogleApi : unit -> Uri
static member GoogleApi : unit -> Uri

Return Value

Type: Online Uri
See Also
ApiUrls Class
ApiUrls Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


ApiUrls.Rename Method

ApiUrls Rename Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Uri Rename(
    string id
)
public static Uri Rename(
    string id
)
Public Shared Function Rename (
    id As String
) As Uri
Public Shared Function Rename (
    id As String
) As Uri
public:
static Uri^ Rename(
    String^ id
)
public:
static Uri^ Rename(
    String^ id
)
static member Rename :
        id : string -> Uri
static member Rename :
        id : string -> Uri

Parameters

id
Type: Online System String

Return Value

Type: Online Uri
See Also
ApiUrls Class
ApiUrls Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


ApiUrls.SetModifiedDate Method

ApiUrls SetModifiedDate Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Uri SetModifiedDate(
    string id
)
public static Uri SetModifiedDate(
    string id
)
Public Shared Function SetModifiedDate (
    id As String
) As Uri
Public Shared Function SetModifiedDate (
    id As String
) As Uri
public:
static Uri^ SetModifiedDate(
    String^ id
)
public:
static Uri^ SetModifiedDate(
    String^ id
)
static member SetModifiedDate :
        id : string -> Uri
static member SetModifiedDate :
        id : string -> Uri

Parameters

id
Type: Online System String

Return Value

Type: Online Uri
See Also
ApiUrls Class
ApiUrls Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


ApiUrls.Subfolders Method

ApiUrls Subfolders Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Uri Subfolders(
    string parentId
)
public static Uri Subfolders(
    string parentId
)
Public Shared Function Subfolders (
    parentId As String
) As Uri
Public Shared Function Subfolders (
    parentId As String
) As Uri
public:
static Uri^ Subfolders(
    String^ parentId
)
public:
static Uri^ Subfolders(
    String^ parentId
)
static member Subfolders :
        parentId : string -> Uri
static member Subfolders :
        parentId : string -> Uri

Parameters

parentId
Type: Online System String

Return Value

Type: Online Uri
See Also
ApiUrls Class
ApiUrls Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


ApiUrls.Token Method

ApiUrls Token Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Uri Token()
public static Uri Token()
Public Shared Function Token As Uri
Public Shared Function Token As Uri
public:
static Uri^ Token()
public:
static Uri^ Token()
static member Token : unit -> Uri
static member Token : unit -> Uri

Return Value

Type: Online Uri
See Also
ApiUrls Class
ApiUrls Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


ApiUrls.Update Method

ApiUrls Update Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Uri Update(
    string id
)
public static Uri Update(
    string id
)
Public Shared Function Update (
    id As String
) As Uri
Public Shared Function Update (
    id As String
) As Uri
public:
static Uri^ Update(
    String^ id
)
public:
static Uri^ Update(
    String^ id
)
static member Update :
        id : string -> Uri
static member Update :
        id : string -> Uri

Parameters

id
Type: Online System String

Return Value

Type: Online Uri
See Also
ApiUrls Class
ApiUrls Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


ApiUrls.Upload Method

ApiUrls Upload Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Uri Upload()
public static Uri Upload()
Public Shared Function Upload As Uri
Public Shared Function Upload As Uri
public:
static Uri^ Upload()
public:
static Uri^ Upload()
static member Upload : unit -> Uri
static member Upload : unit -> Uri

Return Value

Type: Online Uri
See Also
ApiUrls Class
ApiUrls Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities Class

GoogleDriveCapabilities Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.GoogleDrive.V2 GoogleDriveCapabilities

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GoogleDriveCapabilities : IFileSystemCapabilities
public class GoogleDriveCapabilities : IFileSystemCapabilities
Public Class GoogleDriveCapabilities
    Implements IFileSystemCapabilities
Public Class GoogleDriveCapabilities
    Implements IFileSystemCapabilities
public ref class GoogleDriveCapabilities : IFileSystemCapabilities
public ref class GoogleDriveCapabilities : IFileSystemCapabilities
type GoogleDriveCapabilities =
    class
        interface IFileSystemCapabilities
    end
type GoogleDriveCapabilities =
    class
        interface IFileSystemCapabilities
    end
See Also
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities Members

GoogleDriveCapabilities Members NFX Class Library

The GoogleDriveCapabilities type exposes the following members.
Constructors
 | Name | Description
Public method | GoogleDriveCapabilities | Initializes a new instance of the GoogleDriveCapabilities class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
 | Instance |
Public property | IsReadonly |
Public property | MaxDirectoryNameLength |
Public property | MaxFileNameLength |
Public property | MaxFilePathLength |
Public property | MaxFileSize |
Public property | PathSeparatorCharacters |
Public property | SupportsAsyncronousAPI |
Public property | SupportsCreationTimestamps |
Public property | SupportsCreationUserNames |
Public property | SupportsCustomMetadata |
Public property | SupportsDirectoryRenaming |
Public property | SupportsDirectorySizes |
Public property | SupportsFileModification |
Public property | SupportsFileRenaming |
Public property | SupportsFileSizes |
Public property | SupportsLastAccessTimestamps |
Public property | SupportsLastAccessUserNames |
Public property | SupportsModificationTimestamps |
Public property | SupportsModificationUserNames |
Public property | SupportsReadonlyDirectories |
Public property | SupportsReadonlyFiles |
Public property | SupportsSecurity |
Public property | SupportsStreamSeek |
Public property | SupportsTransactions |
Public property | SupportsVersioning |
Back to Top
See Also
GoogleDriveCapabilities Class
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities Constructor

GoogleDriveCapabilities Constructor NFX Class Library

Initializes a new instance of the GoogleDriveCapabilities class

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GoogleDriveCapabilities()
public GoogleDriveCapabilities()
Public Sub New
Public Sub New
public:
GoogleDriveCapabilities()
public:
GoogleDriveCapabilities()
new : unit -> GoogleDriveCapabilities
new : unit -> GoogleDriveCapabilities
See Also
GoogleDriveCapabilities Class
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities Methods

GoogleDriveCapabilities Methods NFX Class Library

The GoogleDriveCapabilities type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GoogleDriveCapabilities Class
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities Properties

GoogleDriveCapabilities Properties NFX Class Library

The GoogleDriveCapabilities type exposes the following members.
Properties
 | Name | Description
 | Instance |
Public property | IsReadonly |
Public property | MaxDirectoryNameLength |
Public property | MaxFileNameLength |
Public property | MaxFilePathLength |
Public property | MaxFileSize |
Public property | PathSeparatorCharacters |
Public property | SupportsAsyncronousAPI |
Public property | SupportsCreationTimestamps |
Public property | SupportsCreationUserNames |
Public property | SupportsCustomMetadata |
Public property | SupportsDirectoryRenaming |
Public property | SupportsDirectorySizes |
Public property | SupportsFileModification |
Public property | SupportsFileRenaming |
Public property | SupportsFileSizes |
Public property | SupportsLastAccessTimestamps |
Public property | SupportsLastAccessUserNames |
Public property | SupportsModificationTimestamps |
Public property | SupportsModificationUserNames |
Public property | SupportsReadonlyDirectories |
Public property | SupportsReadonlyFiles |
Public property | SupportsSecurity |
Public property | SupportsStreamSeek |
Public property | SupportsTransactions |
Public property | SupportsVersioning |
Back to Top
See Also
GoogleDriveCapabilities Class
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities.Instance Property

GoogleDriveCapabilities Instance Property NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static GoogleDriveCapabilities Instance { get; }
public static GoogleDriveCapabilities Instance { get; }
Public Shared ReadOnly Property Instance As GoogleDriveCapabilities
    Get
Public Shared ReadOnly Property Instance As GoogleDriveCapabilities
    Get
public:
static property GoogleDriveCapabilities^ Instance {
    GoogleDriveCapabilities^ get ();
}
public:
static property GoogleDriveCapabilities^ Instance {
    GoogleDriveCapabilities^ get ();
}
static member Instance : GoogleDriveCapabilities with get
static member Instance : GoogleDriveCapabilities with get

Property Value

Type: GoogleDriveCapabilities
See Also
GoogleDriveCapabilities Class
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities.IsReadonly Property

GoogleDriveCapabilities IsReadonly Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsReadonly { get; }
public bool IsReadonly { get; }
Public ReadOnly Property IsReadonly As Boolean
    Get
Public ReadOnly Property IsReadonly As Boolean
    Get
public:
virtual property bool IsReadonly {
    bool get () sealed;
}
public:
virtual property bool IsReadonly {
    bool get () sealed;
}
abstract IsReadonly : bool with get
override IsReadonly : bool with get
abstract IsReadonly : bool with get
override IsReadonly : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities IsReadonly
See Also
GoogleDriveCapabilities Class
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities.MaxDirectoryNameLength Property

GoogleDriveCapabilities MaxDirectoryNameLength Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MaxDirectoryNameLength { get; }
public int MaxDirectoryNameLength { get; }
Public ReadOnly Property MaxDirectoryNameLength As Integer
    Get
Public ReadOnly Property MaxDirectoryNameLength As Integer
    Get
public:
virtual property int MaxDirectoryNameLength {
    int get () sealed;
}
public:
virtual property int MaxDirectoryNameLength {
    int get () sealed;
}
abstract MaxDirectoryNameLength : int with get
override MaxDirectoryNameLength : int with get
abstract MaxDirectoryNameLength : int with get
override MaxDirectoryNameLength : int with get

Property Value

Type: Online Int32

Implements

IFileSystemCapabilities MaxDirectoryNameLength
See Also
GoogleDriveCapabilities Class
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities.MaxFileNameLength Property

GoogleDriveCapabilities MaxFileNameLength Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MaxFileNameLength { get; }
public int MaxFileNameLength { get; }
Public ReadOnly Property MaxFileNameLength As Integer
    Get
Public ReadOnly Property MaxFileNameLength As Integer
    Get
public:
virtual property int MaxFileNameLength {
    int get () sealed;
}
public:
virtual property int MaxFileNameLength {
    int get () sealed;
}
abstract MaxFileNameLength : int with get
override MaxFileNameLength : int with get
abstract MaxFileNameLength : int with get
override MaxFileNameLength : int with get

Property Value

Type: Online Int32

Implements

IFileSystemCapabilities MaxFileNameLength
See Also
GoogleDriveCapabilities Class
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities.MaxFilePathLength Property

GoogleDriveCapabilities MaxFilePathLength Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MaxFilePathLength { get; }
public int MaxFilePathLength { get; }
Public ReadOnly Property MaxFilePathLength As Integer
    Get
Public ReadOnly Property MaxFilePathLength As Integer
    Get
public:
virtual property int MaxFilePathLength {
    int get () sealed;
}
public:
virtual property int MaxFilePathLength {
    int get () sealed;
}
abstract MaxFilePathLength : int with get
override MaxFilePathLength : int with get
abstract MaxFilePathLength : int with get
override MaxFilePathLength : int with get

Property Value

Type: Online Int32

Implements

IFileSystemCapabilities MaxFilePathLength
See Also
GoogleDriveCapabilities Class
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities.MaxFileSize Property

GoogleDriveCapabilities MaxFileSize Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong MaxFileSize { get; }
public ulong MaxFileSize { get; }
Public ReadOnly Property MaxFileSize As ULong
    Get
Public ReadOnly Property MaxFileSize As ULong
    Get
public:
virtual property unsigned long long MaxFileSize {
    unsigned long long get () sealed;
}
public:
virtual property unsigned long long MaxFileSize {
    unsigned long long get () sealed;
}
abstract MaxFileSize : uint64 with get
override MaxFileSize : uint64 with get
abstract MaxFileSize : uint64 with get
override MaxFileSize : uint64 with get

Property Value

Type: Online UInt64

Implements

IFileSystemCapabilities MaxFileSize
See Also
GoogleDriveCapabilities Class
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities.PathSeparatorCharacters Property

GoogleDriveCapabilities PathSeparatorCharacters Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char[] PathSeparatorCharacters { get; }
public char[] PathSeparatorCharacters { get; }
Public ReadOnly Property PathSeparatorCharacters As Char()
    Get
Public ReadOnly Property PathSeparatorCharacters As Char()
    Get
public:
virtual property array<wchar_t>^ PathSeparatorCharacters {
    array<wchar_t>^ get () sealed;
}
public:
virtual property array<wchar_t>^ PathSeparatorCharacters {
    array<wchar_t>^ get () sealed;
}
abstract PathSeparatorCharacters : char[] with get
override PathSeparatorCharacters : char[] with get
abstract PathSeparatorCharacters : char[] with get
override PathSeparatorCharacters : char[] with get

Property Value

Type: Online Char

Implements

IFileSystemCapabilities PathSeparatorCharacters
See Also
GoogleDriveCapabilities Class
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities.SupportsAsyncronousAPI Property

GoogleDriveCapabilities SupportsAsyncronousAPI Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsAsyncronousAPI { get; }
public bool SupportsAsyncronousAPI { get; }
Public ReadOnly Property SupportsAsyncronousAPI As Boolean
    Get
Public ReadOnly Property SupportsAsyncronousAPI As Boolean
    Get
public:
virtual property bool SupportsAsyncronousAPI {
    bool get () sealed;
}
public:
virtual property bool SupportsAsyncronousAPI {
    bool get () sealed;
}
abstract SupportsAsyncronousAPI : bool with get
override SupportsAsyncronousAPI : bool with get
abstract SupportsAsyncronousAPI : bool with get
override SupportsAsyncronousAPI : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsAsyncronousAPI
See Also
GoogleDriveCapabilities Class
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities.SupportsCreationTimestamps Property

GoogleDriveCapabilities SupportsCreationTimestamps Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsCreationTimestamps { get; }
public bool SupportsCreationTimestamps { get; }
Public ReadOnly Property SupportsCreationTimestamps As Boolean
    Get
Public ReadOnly Property SupportsCreationTimestamps As Boolean
    Get
public:
virtual property bool SupportsCreationTimestamps {
    bool get () sealed;
}
public:
virtual property bool SupportsCreationTimestamps {
    bool get () sealed;
}
abstract SupportsCreationTimestamps : bool with get
override SupportsCreationTimestamps : bool with get
abstract SupportsCreationTimestamps : bool with get
override SupportsCreationTimestamps : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsCreationTimestamps
See Also
GoogleDriveCapabilities Class
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities.SupportsCreationUserNames Property

GoogleDriveCapabilities SupportsCreationUserNames Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsCreationUserNames { get; }
public bool SupportsCreationUserNames { get; }
Public ReadOnly Property SupportsCreationUserNames As Boolean
    Get
Public ReadOnly Property SupportsCreationUserNames As Boolean
    Get
public:
virtual property bool SupportsCreationUserNames {
    bool get () sealed;
}
public:
virtual property bool SupportsCreationUserNames {
    bool get () sealed;
}
abstract SupportsCreationUserNames : bool with get
override SupportsCreationUserNames : bool with get
abstract SupportsCreationUserNames : bool with get
override SupportsCreationUserNames : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsCreationUserNames
See Also
GoogleDriveCapabilities Class
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities.SupportsCustomMetadata Property

GoogleDriveCapabilities SupportsCustomMetadata Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsCustomMetadata { get; }
public bool SupportsCustomMetadata { get; }
Public ReadOnly Property SupportsCustomMetadata As Boolean
    Get
Public ReadOnly Property SupportsCustomMetadata As Boolean
    Get
public:
virtual property bool SupportsCustomMetadata {
    bool get () sealed;
}
public:
virtual property bool SupportsCustomMetadata {
    bool get () sealed;
}
abstract SupportsCustomMetadata : bool with get
override SupportsCustomMetadata : bool with get
abstract SupportsCustomMetadata : bool with get
override SupportsCustomMetadata : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsCustomMetadata
See Also
GoogleDriveCapabilities Class
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities.SupportsDirectoryRenaming Property

GoogleDriveCapabilities SupportsDirectoryRenaming Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsDirectoryRenaming { get; }
public bool SupportsDirectoryRenaming { get; }
Public ReadOnly Property SupportsDirectoryRenaming As Boolean
    Get
Public ReadOnly Property SupportsDirectoryRenaming As Boolean
    Get
public:
virtual property bool SupportsDirectoryRenaming {
    bool get () sealed;
}
public:
virtual property bool SupportsDirectoryRenaming {
    bool get () sealed;
}
abstract SupportsDirectoryRenaming : bool with get
override SupportsDirectoryRenaming : bool with get
abstract SupportsDirectoryRenaming : bool with get
override SupportsDirectoryRenaming : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsDirectoryRenaming
See Also
GoogleDriveCapabilities Class
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities.SupportsDirectorySizes Property

GoogleDriveCapabilities SupportsDirectorySizes Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsDirectorySizes { get; }
public bool SupportsDirectorySizes { get; }
Public ReadOnly Property SupportsDirectorySizes As Boolean
    Get
Public ReadOnly Property SupportsDirectorySizes As Boolean
    Get
public:
virtual property bool SupportsDirectorySizes {
    bool get () sealed;
}
public:
virtual property bool SupportsDirectorySizes {
    bool get () sealed;
}
abstract SupportsDirectorySizes : bool with get
override SupportsDirectorySizes : bool with get
abstract SupportsDirectorySizes : bool with get
override SupportsDirectorySizes : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsDirectorySizes
See Also
GoogleDriveCapabilities Class
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities.SupportsFileModification Property

GoogleDriveCapabilities SupportsFileModification Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsFileModification { get; }
public bool SupportsFileModification { get; }
Public ReadOnly Property SupportsFileModification As Boolean
    Get
Public ReadOnly Property SupportsFileModification As Boolean
    Get
public:
virtual property bool SupportsFileModification {
    bool get () sealed;
}
public:
virtual property bool SupportsFileModification {
    bool get () sealed;
}
abstract SupportsFileModification : bool with get
override SupportsFileModification : bool with get
abstract SupportsFileModification : bool with get
override SupportsFileModification : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsFileModification
See Also
GoogleDriveCapabilities Class
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities.SupportsFileRenaming Property

GoogleDriveCapabilities SupportsFileRenaming Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsFileRenaming { get; }
public bool SupportsFileRenaming { get; }
Public ReadOnly Property SupportsFileRenaming As Boolean
    Get
Public ReadOnly Property SupportsFileRenaming As Boolean
    Get
public:
virtual property bool SupportsFileRenaming {
    bool get () sealed;
}
public:
virtual property bool SupportsFileRenaming {
    bool get () sealed;
}
abstract SupportsFileRenaming : bool with get
override SupportsFileRenaming : bool with get
abstract SupportsFileRenaming : bool with get
override SupportsFileRenaming : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsFileRenaming
See Also
GoogleDriveCapabilities Class
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities.SupportsFileSizes Property

GoogleDriveCapabilities SupportsFileSizes Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsFileSizes { get; }
public bool SupportsFileSizes { get; }
Public ReadOnly Property SupportsFileSizes As Boolean
    Get
Public ReadOnly Property SupportsFileSizes As Boolean
    Get
public:
virtual property bool SupportsFileSizes {
    bool get () sealed;
}
public:
virtual property bool SupportsFileSizes {
    bool get () sealed;
}
abstract SupportsFileSizes : bool with get
override SupportsFileSizes : bool with get
abstract SupportsFileSizes : bool with get
override SupportsFileSizes : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsFileSizes
See Also
GoogleDriveCapabilities Class
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities.SupportsLastAccessTimestamps Property

GoogleDriveCapabilities SupportsLastAccessTimestamps Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsLastAccessTimestamps { get; }
public bool SupportsLastAccessTimestamps { get; }
Public ReadOnly Property SupportsLastAccessTimestamps As Boolean
    Get
Public ReadOnly Property SupportsLastAccessTimestamps As Boolean
    Get
public:
virtual property bool SupportsLastAccessTimestamps {
    bool get () sealed;
}
public:
virtual property bool SupportsLastAccessTimestamps {
    bool get () sealed;
}
abstract SupportsLastAccessTimestamps : bool with get
override SupportsLastAccessTimestamps : bool with get
abstract SupportsLastAccessTimestamps : bool with get
override SupportsLastAccessTimestamps : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsLastAccessTimestamps
See Also
GoogleDriveCapabilities Class
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities.SupportsLastAccessUserNames Property

GoogleDriveCapabilities SupportsLastAccessUserNames Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsLastAccessUserNames { get; }
public bool SupportsLastAccessUserNames { get; }
Public ReadOnly Property SupportsLastAccessUserNames As Boolean
    Get
Public ReadOnly Property SupportsLastAccessUserNames As Boolean
    Get
public:
virtual property bool SupportsLastAccessUserNames {
    bool get () sealed;
}
public:
virtual property bool SupportsLastAccessUserNames {
    bool get () sealed;
}
abstract SupportsLastAccessUserNames : bool with get
override SupportsLastAccessUserNames : bool with get
abstract SupportsLastAccessUserNames : bool with get
override SupportsLastAccessUserNames : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsLastAccessUserNames
See Also
GoogleDriveCapabilities Class
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities.SupportsModificationTimestamps Property

GoogleDriveCapabilities SupportsModificationTimestamps Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsModificationTimestamps { get; }
public bool SupportsModificationTimestamps { get; }
Public ReadOnly Property SupportsModificationTimestamps As Boolean
    Get
Public ReadOnly Property SupportsModificationTimestamps As Boolean
    Get
public:
virtual property bool SupportsModificationTimestamps {
    bool get () sealed;
}
public:
virtual property bool SupportsModificationTimestamps {
    bool get () sealed;
}
abstract SupportsModificationTimestamps : bool with get
override SupportsModificationTimestamps : bool with get
abstract SupportsModificationTimestamps : bool with get
override SupportsModificationTimestamps : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsModificationTimestamps
See Also
GoogleDriveCapabilities Class
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities.SupportsModificationUserNames Property

GoogleDriveCapabilities SupportsModificationUserNames Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsModificationUserNames { get; }
public bool SupportsModificationUserNames { get; }
Public ReadOnly Property SupportsModificationUserNames As Boolean
    Get
Public ReadOnly Property SupportsModificationUserNames As Boolean
    Get
public:
virtual property bool SupportsModificationUserNames {
    bool get () sealed;
}
public:
virtual property bool SupportsModificationUserNames {
    bool get () sealed;
}
abstract SupportsModificationUserNames : bool with get
override SupportsModificationUserNames : bool with get
abstract SupportsModificationUserNames : bool with get
override SupportsModificationUserNames : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsModificationUserNames
See Also
GoogleDriveCapabilities Class
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities.SupportsReadonlyDirectories Property

GoogleDriveCapabilities SupportsReadonlyDirectories Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsReadonlyDirectories { get; }
public bool SupportsReadonlyDirectories { get; }
Public ReadOnly Property SupportsReadonlyDirectories As Boolean
    Get
Public ReadOnly Property SupportsReadonlyDirectories As Boolean
    Get
public:
virtual property bool SupportsReadonlyDirectories {
    bool get () sealed;
}
public:
virtual property bool SupportsReadonlyDirectories {
    bool get () sealed;
}
abstract SupportsReadonlyDirectories : bool with get
override SupportsReadonlyDirectories : bool with get
abstract SupportsReadonlyDirectories : bool with get
override SupportsReadonlyDirectories : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsReadonlyDirectories
See Also
GoogleDriveCapabilities Class
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities.SupportsReadonlyFiles Property

GoogleDriveCapabilities SupportsReadonlyFiles Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsReadonlyFiles { get; }
public bool SupportsReadonlyFiles { get; }
Public ReadOnly Property SupportsReadonlyFiles As Boolean
    Get
Public ReadOnly Property SupportsReadonlyFiles As Boolean
    Get
public:
virtual property bool SupportsReadonlyFiles {
    bool get () sealed;
}
public:
virtual property bool SupportsReadonlyFiles {
    bool get () sealed;
}
abstract SupportsReadonlyFiles : bool with get
override SupportsReadonlyFiles : bool with get
abstract SupportsReadonlyFiles : bool with get
override SupportsReadonlyFiles : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsReadonlyFiles
See Also
GoogleDriveCapabilities Class
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities.SupportsSecurity Property

GoogleDriveCapabilities SupportsSecurity Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsSecurity { get; }
public bool SupportsSecurity { get; }
Public ReadOnly Property SupportsSecurity As Boolean
    Get
Public ReadOnly Property SupportsSecurity As Boolean
    Get
public:
virtual property bool SupportsSecurity {
    bool get () sealed;
}
public:
virtual property bool SupportsSecurity {
    bool get () sealed;
}
abstract SupportsSecurity : bool with get
override SupportsSecurity : bool with get
abstract SupportsSecurity : bool with get
override SupportsSecurity : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsSecurity
See Also
GoogleDriveCapabilities Class
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities.SupportsStreamSeek Property

GoogleDriveCapabilities SupportsStreamSeek Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsStreamSeek { get; }
public bool SupportsStreamSeek { get; }
Public ReadOnly Property SupportsStreamSeek As Boolean
    Get
Public ReadOnly Property SupportsStreamSeek As Boolean
    Get
public:
virtual property bool SupportsStreamSeek {
    bool get () sealed;
}
public:
virtual property bool SupportsStreamSeek {
    bool get () sealed;
}
abstract SupportsStreamSeek : bool with get
override SupportsStreamSeek : bool with get
abstract SupportsStreamSeek : bool with get
override SupportsStreamSeek : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsStreamSeek
See Also
GoogleDriveCapabilities Class
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities.SupportsTransactions Property

GoogleDriveCapabilities SupportsTransactions Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsTransactions { get; }
public bool SupportsTransactions { get; }
Public ReadOnly Property SupportsTransactions As Boolean
    Get
Public ReadOnly Property SupportsTransactions As Boolean
    Get
public:
virtual property bool SupportsTransactions {
    bool get () sealed;
}
public:
virtual property bool SupportsTransactions {
    bool get () sealed;
}
abstract SupportsTransactions : bool with get
override SupportsTransactions : bool with get
abstract SupportsTransactions : bool with get
override SupportsTransactions : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsTransactions
See Also
GoogleDriveCapabilities Class
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveCapabilities.SupportsVersioning Property

GoogleDriveCapabilities SupportsVersioning Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsVersioning { get; }
public bool SupportsVersioning { get; }
Public ReadOnly Property SupportsVersioning As Boolean
    Get
Public ReadOnly Property SupportsVersioning As Boolean
    Get
public:
virtual property bool SupportsVersioning {
    bool get () sealed;
}
public:
virtual property bool SupportsVersioning {
    bool get () sealed;
}
abstract SupportsVersioning : bool with get
override SupportsVersioning : bool with get
abstract SupportsVersioning : bool with get
override SupportsVersioning : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsVersioning
See Also
GoogleDriveCapabilities Class
GoogleDriveCapabilities Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveClient Class

GoogleDriveClient Class NFX Class Library

Google Drive REST API wrapper.
Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.GoogleDrive.V2 GoogleDriveClient

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GoogleDriveClient
public class GoogleDriveClient
Public Class GoogleDriveClient
Public Class GoogleDriveClient
public ref class GoogleDriveClient
public ref class GoogleDriveClient
type GoogleDriveClient =  class end
type GoogleDriveClient =  class end
See Also
GoogleDriveClient Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveClient Members

GoogleDriveClient Members NFX Class Library

The GoogleDriveClient type exposes the following members.
Constructors
 | Name | Description
Public method | GoogleDriveClient(String, String) | Initializes a new instance of the GoogleDriveClient class
Public method | GoogleDriveClient(String, String, Int32, Int32) | Initializes a new instance of the GoogleDriveClient class
Back to Top
Methods
 | Name | Description
Public method | CreateDirectory | Creates a directory
Public method | CreateFile(String, String) | Creates a file
Public method | CreateFile(String, String, Stream) | Creates a file
Public method | Delete | Deletes an item
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FileExists | Checks whether the specified file exists
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FolderExists | Checks whether the specified folder exists
Public method | GetDirectories | Returns directory names contained in the spicifed directory
Public method | GetFile | Gets a file by ID
Public method | GetFiles | Returns files contained in the spicifed directory
Public method | GetHandle | Gets a handle for the specified file or folder.
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetItemInfoById |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rename | Renames a file/folder by its ID
Public method | SetModifiedDate | Sets modification timestamp
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UpdateFile | Updates content of a file by file ID
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GoogleDriveClient Class
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveClient Constructor

GoogleDriveClient Constructor NFX Class Library

Overload List
 | Name | Description
Public method | GoogleDriveClient(String, String) | Initializes a new instance of the GoogleDriveClient class
Public method | GoogleDriveClient(String, String, Int32, Int32) | Initializes a new instance of the GoogleDriveClient class
Back to Top
See Also
GoogleDriveClient Class
GoogleDriveClient Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveClient Constructor (String, String)

GoogleDriveClient Constructor (String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the GoogleDriveClient class

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GoogleDriveClient(
    string email,
    string certPath
)
public GoogleDriveClient(
    string email,
    string certPath
)
Public Sub New (
    email As String,
    certPath As String
)
Public Sub New (
    email As String,
    certPath As String
)
public:
GoogleDriveClient(
    String^ email,
    String^ certPath
)
public:
GoogleDriveClient(
    String^ email,
    String^ certPath
)
new :
        email : string *
        certPath : string -> GoogleDriveClient
new :
        email : string *
        certPath : string -> GoogleDriveClient

Parameters

email
Type: Online System String
certPath
Type: Online System String
See Also
GoogleDriveClient Class
GoogleDriveClient Members
GoogleDriveClient Overload
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveClient Constructor (String, String, Int32, Int32)

GoogleDriveClient Constructor (String, String, Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the GoogleDriveClient class

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GoogleDriveClient(
    string email,
    string certPath,
    int timeout,
    int attempts
)
public GoogleDriveClient(
    string email,
    string certPath,
    int timeout,
    int attempts
)
Public Sub New (
    email As String,
    certPath As String,
    timeout As Integer,
    attempts As Integer
)
Public Sub New (
    email As String,
    certPath As String,
    timeout As Integer,
    attempts As Integer
)
public:
GoogleDriveClient(
    String^ email,
    String^ certPath,
    int timeout,
    int attempts
)
public:
GoogleDriveClient(
    String^ email,
    String^ certPath,
    int timeout,
    int attempts
)
new :
        email : string *
        certPath : string *
        timeout : int *
        attempts : int -> GoogleDriveClient
new :
        email : string *
        certPath : string *
        timeout : int *
        attempts : int -> GoogleDriveClient

Parameters

email
Type: Online System String
certPath
Type: Online System String
timeout
Type: Online System Int32
attempts
Type: Online System Int32
See Also
GoogleDriveClient Class
GoogleDriveClient Members
GoogleDriveClient Overload
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveClient Methods

GoogleDriveClient Methods NFX Class Library

The GoogleDriveClient type exposes the following members.
Methods
 | Name | Description
Public method | CreateDirectory | Creates a directory
Public method | CreateFile(String, String) | Creates a file
Public method | CreateFile(String, String, Stream) | Creates a file
Public method | Delete | Deletes an item
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FileExists | Checks whether the specified file exists
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FolderExists | Checks whether the specified folder exists
Public method | GetDirectories | Returns directory names contained in the spicifed directory
Public method | GetFile | Gets a file by ID
Public method | GetFiles | Returns files contained in the spicifed directory
Public method | GetHandle | Gets a handle for the specified file or folder.
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetItemInfoById |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Rename | Renames a file/folder by its ID
Public method | SetModifiedDate | Sets modification timestamp
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UpdateFile | Updates content of a file by file ID
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GoogleDriveClient Class
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveClient.CreateDirectory Method

GoogleDriveClient CreateDirectory Method NFX Class Library

Creates a directory

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GoogleDriveHandle CreateDirectory(
    string parentId,
    string name
)
public GoogleDriveHandle CreateDirectory(
    string parentId,
    string name
)
Public Function CreateDirectory (
    parentId As String,
    name As String
) As GoogleDriveHandle
Public Function CreateDirectory (
    parentId As String,
    name As String
) As GoogleDriveHandle
public:
GoogleDriveHandle^ CreateDirectory(
    String^ parentId,
    String^ name
)
public:
GoogleDriveHandle^ CreateDirectory(
    String^ parentId,
    String^ name
)
member CreateDirectory :
        parentId : string *
        name : string -> GoogleDriveHandle
member CreateDirectory :
        parentId : string *
        name : string -> GoogleDriveHandle

Parameters

parentId
Type: Online System String
name
Type: Online System String

Return Value

Type: GoogleDriveHandle
See Also
GoogleDriveClient Class
GoogleDriveClient Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveClient.CreateFile Method

GoogleDriveClient CreateFile Method NFX Class Library

Overload List
 | Name | Description
Public method | CreateFile(String, String) | Creates a file
Public method | CreateFile(String, String, Stream) | Creates a file
Back to Top
See Also
GoogleDriveClient Class
GoogleDriveClient Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveClient.CreateFile Method (String, String)

GoogleDriveClient CreateFile Method (String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates a file

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GoogleDriveHandle CreateFile(
    string parentId,
    string name
)
public GoogleDriveHandle CreateFile(
    string parentId,
    string name
)
Public Function CreateFile (
    parentId As String,
    name As String
) As GoogleDriveHandle
Public Function CreateFile (
    parentId As String,
    name As String
) As GoogleDriveHandle
public:
GoogleDriveHandle^ CreateFile(
    String^ parentId,
    String^ name
)
public:
GoogleDriveHandle^ CreateFile(
    String^ parentId,
    String^ name
)
member CreateFile :
        parentId : string *
        name : string -> GoogleDriveHandle
member CreateFile :
        parentId : string *
        name : string -> GoogleDriveHandle

Parameters

parentId
Type: Online System String
name
Type: Online System String

Return Value

Type: GoogleDriveHandle
See Also
GoogleDriveClient Class
GoogleDriveClient Members
CreateFile Overload
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveClient.CreateFile Method (String, String, Stream)

GoogleDriveClient CreateFile Method (String, String, Stream) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates a file

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GoogleDriveHandle CreateFile(
    string parentId,
    string name,
    Stream stream
)
public GoogleDriveHandle CreateFile(
    string parentId,
    string name,
    Stream stream
)
Public Function CreateFile (
    parentId As String,
    name As String,
    stream As Stream
) As GoogleDriveHandle
Public Function CreateFile (
    parentId As String,
    name As String,
    stream As Stream
) As GoogleDriveHandle
public:
GoogleDriveHandle^ CreateFile(
    String^ parentId,
    String^ name,
    Stream^ stream
)
public:
GoogleDriveHandle^ CreateFile(
    String^ parentId,
    String^ name,
    Stream^ stream
)
member CreateFile :
        parentId : string *
        name : string *
        stream : Stream -> GoogleDriveHandle
member CreateFile :
        parentId : string *
        name : string *
        stream : Stream -> GoogleDriveHandle

Parameters

parentId
Type: Online System String
name
Type: Online System String
stream
Type: Online System.IO Stream

Return Value

Type: GoogleDriveHandle
See Also
GoogleDriveClient Class
GoogleDriveClient Members
CreateFile Overload
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveClient.Delete Method

GoogleDriveClient Delete Method NFX Class Library

Deletes an item

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Delete(
    string id
)
public void Delete(
    string id
)
Public Sub Delete (
    id As String
)
Public Sub Delete (
    id As String
)
public:
void Delete(
    String^ id
)
public:
void Delete(
    String^ id
)
member Delete :
        id : string -> unit
member Delete :
        id : string -> unit

Parameters

id
Type: Online System String
See Also
GoogleDriveClient Class
GoogleDriveClient Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveClient.FileExists Method

GoogleDriveClient FileExists Method NFX Class Library

Checks whether the specified file exists

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool FileExists(
    string path
)
public bool FileExists(
    string path
)
Public Function FileExists (
    path As String
) As Boolean
Public Function FileExists (
    path As String
) As Boolean
public:
bool FileExists(
    String^ path
)
public:
bool FileExists(
    String^ path
)
member FileExists :
        path : string -> bool
member FileExists :
        path : string -> bool

Parameters

path
Type: Online System String

Return Value

Type: Online Boolean
See Also
GoogleDriveClient Class
GoogleDriveClient Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveClient.FolderExists Method

GoogleDriveClient FolderExists Method NFX Class Library

Checks whether the specified folder exists

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool FolderExists(
    string path
)
public bool FolderExists(
    string path
)
Public Function FolderExists (
    path As String
) As Boolean
Public Function FolderExists (
    path As String
) As Boolean
public:
bool FolderExists(
    String^ path
)
public:
bool FolderExists(
    String^ path
)
member FolderExists :
        path : string -> bool
member FolderExists :
        path : string -> bool

Parameters

path
Type: Online System String

Return Value

Type: Online Boolean
See Also
GoogleDriveClient Class
GoogleDriveClient Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveClient.GetDirectories Method

GoogleDriveClient GetDirectories Method NFX Class Library

Returns directory names contained in the spicifed directory

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<string> GetDirectories(
    string path,
    bool recursive
)
public IEnumerable<string> GetDirectories(
    string path,
    bool recursive
)
Public Function GetDirectories (
    path As String,
    recursive As Boolean
) As IEnumerable(Of String)
Public Function GetDirectories (
    path As String,
    recursive As Boolean
) As IEnumerable(Of String)
public:
IEnumerable<String^>^ GetDirectories(
    String^ path,
    bool recursive
)
public:
IEnumerable<String^>^ GetDirectories(
    String^ path,
    bool recursive
)
member GetDirectories :
        path : string *
        recursive : bool -> IEnumerable<string>
member GetDirectories :
        path : string *
        recursive : bool -> IEnumerable<string>

Parameters

path
Type: Online System String
recursive
Type: Online System Boolean

Return Value

Type: Online IEnumerable Online String
See Also
GoogleDriveClient Class
GoogleDriveClient Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveClient.GetFile Method

GoogleDriveClient GetFile Method NFX Class Library

Gets a file by ID

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void GetFile(
    string id,
    Stream stream
)
public void GetFile(
    string id,
    Stream stream
)
Public Sub GetFile (
    id As String,
    stream As Stream
)
Public Sub GetFile (
    id As String,
    stream As Stream
)
public:
void GetFile(
    String^ id,
    Stream^ stream
)
public:
void GetFile(
    String^ id,
    Stream^ stream
)
member GetFile :
        id : string *
        stream : Stream -> unit
member GetFile :
        id : string *
        stream : Stream -> unit

Parameters

id
Type: Online System String
stream
Type: Online System.IO Stream
See Also
GoogleDriveClient Class
GoogleDriveClient Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveClient.GetFiles Method

GoogleDriveClient GetFiles Method NFX Class Library

Returns files contained in the spicifed directory

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<GoogleDriveHandle> GetFiles(
    string parentId,
    bool recursive
)
public IEnumerable<GoogleDriveHandle> GetFiles(
    string parentId,
    bool recursive
)
Public Function GetFiles (
    parentId As String,
    recursive As Boolean
) As IEnumerable(Of GoogleDriveHandle)
Public Function GetFiles (
    parentId As String,
    recursive As Boolean
) As IEnumerable(Of GoogleDriveHandle)
public:
IEnumerable<GoogleDriveHandle^>^ GetFiles(
    String^ parentId,
    bool recursive
)
public:
IEnumerable<GoogleDriveHandle^>^ GetFiles(
    String^ parentId,
    bool recursive
)
member GetFiles :
        parentId : string *
        recursive : bool -> IEnumerable<GoogleDriveHandle>
member GetFiles :
        parentId : string *
        recursive : bool -> IEnumerable<GoogleDriveHandle>

Parameters

parentId
Type: Online System String
recursive
Type: Online System Boolean

Return Value

Type: Online IEnumerable GoogleDriveHandle
See Also
GoogleDriveClient Class
GoogleDriveClient Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveClient.GetHandle Method

GoogleDriveClient GetHandle Method NFX Class Library

Gets a handle for the specified file or folder.

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GoogleDriveHandle GetHandle(
    string path
)
public GoogleDriveHandle GetHandle(
    string path
)
Public Function GetHandle (
    path As String
) As GoogleDriveHandle
Public Function GetHandle (
    path As String
) As GoogleDriveHandle
public:
GoogleDriveHandle^ GetHandle(
    String^ path
)
public:
GoogleDriveHandle^ GetHandle(
    String^ path
)
member GetHandle :
        path : string -> GoogleDriveHandle
member GetHandle :
        path : string -> GoogleDriveHandle

Parameters

path
Type: Online System String

Return Value

Type: GoogleDriveHandle
See Also
GoogleDriveClient Class
GoogleDriveClient Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveClient.GetItemInfoById Method

GoogleDriveClient GetItemInfoById Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GoogleDriveHandle GetItemInfoById(
    string id
)
public GoogleDriveHandle GetItemInfoById(
    string id
)
Public Function GetItemInfoById (
    id As String
) As GoogleDriveHandle
Public Function GetItemInfoById (
    id As String
) As GoogleDriveHandle
public:
GoogleDriveHandle^ GetItemInfoById(
    String^ id
)
public:
GoogleDriveHandle^ GetItemInfoById(
    String^ id
)
member GetItemInfoById :
        id : string -> GoogleDriveHandle
member GetItemInfoById :
        id : string -> GoogleDriveHandle

Parameters

id
Type: Online System String

Return Value

Type: GoogleDriveHandle
See Also
GoogleDriveClient Class
GoogleDriveClient Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveClient.Rename Method

GoogleDriveClient Rename Method NFX Class Library

Renames a file/folder by its ID

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Rename(
    string id,
    string name
)
public void Rename(
    string id,
    string name
)
Public Sub Rename (
    id As String,
    name As String
)
Public Sub Rename (
    id As String,
    name As String
)
public:
void Rename(
    String^ id,
    String^ name
)
public:
void Rename(
    String^ id,
    String^ name
)
member Rename :
        id : string *
        name : string -> unit
member Rename :
        id : string *
        name : string -> unit

Parameters

id
Type: Online System String
name
Type: Online System String
See Also
GoogleDriveClient Class
GoogleDriveClient Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveClient.SetModifiedDate Method

GoogleDriveClient SetModifiedDate Method NFX Class Library

Sets modification timestamp

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetModifiedDate(
    string id,
    DateTime date
)
public void SetModifiedDate(
    string id,
    DateTime date
)
Public Sub SetModifiedDate (
    id As String,
    date As DateTime
)
Public Sub SetModifiedDate (
    id As String,
    date As DateTime
)
public:
void SetModifiedDate(
    String^ id,
    DateTime date
)
public:
void SetModifiedDate(
    String^ id,
    DateTime date
)
member SetModifiedDate :
        id : string *
        date : DateTime -> unit
member SetModifiedDate :
        id : string *
        date : DateTime -> unit

Parameters

id
Type: Online System String
date
Type: Online System DateTime
See Also
GoogleDriveClient Class
GoogleDriveClient Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveClient.UpdateFile Method

GoogleDriveClient UpdateFile Method NFX Class Library

Updates content of a file by file ID

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GoogleDriveHandle UpdateFile(
    string id,
    Stream stream
)
public GoogleDriveHandle UpdateFile(
    string id,
    Stream stream
)
Public Function UpdateFile (
    id As String,
    stream As Stream
) As GoogleDriveHandle
Public Function UpdateFile (
    id As String,
    stream As Stream
) As GoogleDriveHandle
public:
GoogleDriveHandle^ UpdateFile(
    String^ id,
    Stream^ stream
)
public:
GoogleDriveHandle^ UpdateFile(
    String^ id,
    Stream^ stream
)
member UpdateFile :
        id : string *
        stream : Stream -> GoogleDriveHandle
member UpdateFile :
        id : string *
        stream : Stream -> GoogleDriveHandle

Parameters

id
Type: Online System String
stream
Type: Online System.IO Stream

Return Value

Type: GoogleDriveHandle
See Also
GoogleDriveClient Class
GoogleDriveClient Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem Class

GoogleDriveFileSystem Class NFX Class Library

Implements FileSystem for Google Drive
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.IO.FileSystem FileSystem
NFX.IO.FileSystem.GoogleDrive.V2 GoogleDriveFileSystem

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GoogleDriveFileSystem : FileSystem
public class GoogleDriveFileSystem : FileSystem
Public Class GoogleDriveFileSystem
    Inherits FileSystem
Public Class GoogleDriveFileSystem
    Inherits FileSystem
public ref class GoogleDriveFileSystem : public FileSystem
public ref class GoogleDriveFileSystem : public FileSystem
type GoogleDriveFileSystem =
    class
        inherit FileSystem
    end
type GoogleDriveFileSystem =
    class
        inherit FileSystem
    end
See Also
GoogleDriveFileSystem Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem Members

GoogleDriveFileSystem Members NFX Class Library

The GoogleDriveFileSystem type exposes the following members.
Constructors
 | Name | Description
Public method | GoogleDriveFileSystem | Initializes a new instance of the GoogleDriveFileSystem class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | CombinePaths | Combines two or more path segments joining them using primary file system path separator. This method is thread-safe (Inherited from FileSystem.)
Public method | Configure | Configures file system. This method is a part of lifecycle management and is intended to be called only by creating thread (not thread-safe) (Inherited from FileSystem.)
Protected method | Destructor | (Inherited from FileSystem.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoBeginTransaction | Override in particular file systems that support transactions to begin transaction in specified session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoBeginTransactionAsync | Async version of DoBeginTransaction(FileSystemSession). This base/default implementation just synchronously calls DoBeginTransaction(FileSystemSession) and returns already completed Task with result returned by DoBeginTransaction(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoCheckCanChange | Override in particular file systems to see if item can change, i.e. for file systems that support versioning throw exception if item is in session which "looks" at a sealed/closed version and can not change. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoCheckCanChangeAsync | Async version of DoCheckCanChange(FileSystemSessionItem). This base/default implementation just synchronously calls DoCheckCanChange(FileSystemSessionItem) and returns already completed Task with result returned by DoCheckCanChange(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoCommitTransaction | Override in particular file systems that support transactions to commit transaction in specified session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoCommitTransactionAsync | Async version of DoCommitTransaction(FileSystemSession). This base/default implementation just synchronously calls DoCommitTransaction(FileSystemSession) and returns already completed Task with result returned by DoCommitTransaction(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoConfigure | Override to perform custom configuration (Inherited from FileSystem.)
Protected method | DoCreateDirectory | (Overrides FileSystem DoCreateDirectory(FileSystemDirectory, String).)
Protected method | DoCreateDirectoryAsync | Async version of DoCreateDirectory(FileSystemDirectory, String). This base/default implementation just synchronously calls DoCreateDirectory(FileSystemDirectory, String) and returns already completed Task with result returned by DoCreateDirectory(FileSystemDirectory, String) (Inherited from FileSystem.)
Protected method | DoCreateFile(FileSystemDirectory, String, Int32) | (Overrides FileSystem DoCreateFile(FileSystemDirectory, String, Int32).)
Protected method | DoCreateFile(FileSystemDirectory, String, String, Boolean) | (Overrides FileSystem DoCreateFile(FileSystemDirectory, String, String, Boolean).)
Protected method | DoCreateFileAsync(FileSystemDirectory, String, Int32) | Async version of DoCreateFile(FileSystemDirectory, String, Int32). This base/default implementation just synchronously calls DoCreateFile(FileSystemDirectory, String, Int32) and returns already completed Task with result returned by DoCreateFile(FileSystemDirectory, String, Int32) (Inherited from FileSystem.)
Protected method | DoCreateFileAsync(FileSystemDirectory, String, String, Boolean) | Async version of DoCreateFile(FileSystemDirectory, String, String, Boolean). This base/default implementation just synchronously calls DoCreateFile(FileSystemDirectory, String, String, Boolean) and returns already completed Task with result returned by DoCreateFile(FileSystemDirectory, String, String, Boolean) (Inherited from FileSystem.)
Protected method | DoDeleteItem | (Overrides FileSystem DoDeleteItem(FileSystemSessionItem).)
Protected method | DoDeleteItemAsync | Async version of DoDeleteItem(FileSystemSessionItem). This base/default implementation just synchronously calls DoDeleteItem(FileSystemSessionItem) and returns already completed Task with result returned by DoDeleteItem(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoDirectoryDeepCopyAsync | Implements asynchronous deep copy of folders where destination folder may belong to a different file system. The specifics of implementation may be dictated by particular file systems, i.e.: asynchronous strategies for getting file lists may depend on the particular system. (Inherited from FileSystem.)
Protected method | DoFlushAsync | (Inherited from FileSystem.)
Protected method | DoGetCreationTimestamp | (Overrides FileSystem DoGetCreationTimestamp(FileSystemSessionItem).)
Protected method | DoGetCreationUser | Override in particular file systems to get user who created item. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetCreationUserAsync | Async version of DoGetCreationUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetCreationUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetCreationUser(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetFileNames | (Overrides FileSystem DoGetFileNames(FileSystemDirectory, Boolean).)
Protected method | DoGetFileNamesAsync | Async version of DoGetFileNames(FileSystemDirectory, Boolean). This base/default implementation just synchronously calls DoGetFileNames(FileSystemDirectory, Boolean) and returns already completed Task with result returned by DoGetFileNames(FileSystemDirectory, Boolean) (Inherited from FileSystem.)
Protected method | DoGetFileStream | (Overrides FileSystem DoGetFileStream(FileSystemFile, Action FileSystemStream ).)
Protected method | DoGetFileStreamAsync | Async version of DoGetFileStream(FileSystemFile, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetFileStream(FileSystemFile, Action FileSystemStream ) and returns already completed Task with result returned by DoGetFileStream(FileSystemFile, Action FileSystemStream ) (Inherited from FileSystem.)
Protected method | DoGetItemSize | (Overrides FileSystem DoGetItemSize(FileSystemSessionItem).)
Protected method | DoGetItemSizeAsync | Async version of DoGetItemSize(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetItemSize(FileSystemSessionItem) and returns already completed Task with result returned by DoGetItemSize(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetLastAccessTimestamp | (Overrides FileSystem DoGetLastAccessTimestamp(FileSystemSessionItem).)
Protected method | DoGetLastAccessUser | Override in particular file systems to get user who was the last user accessing the item. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetLastAccessUserAsync | Async version of DoGetLastAccessUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetLastAccessUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetLastAccessUser(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetLatestVersion | Override in particular file systems that support versioning to get latest version object that this session can work with. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetLatestVersionAsync | Async version of DoGetLatestVersion(FileSystemSession). This base/default implementation just synchronously calls DoGetLatestVersion(FileSystemSession) and returns already completed Task with result returned by DoGetLatestVersion(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoGetMetadataStream | (Overrides FileSystem DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ).)
Protected method | DoGetMetadataStreamAsync | Async version of DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ) and returns already completed Task with result returned by DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ) (Inherited from FileSystem.)
Protected method | DoGetModificationTimestamp | (Overrides FileSystem DoGetModificationTimestamp(FileSystemSessionItem).)
Protected method | DoGetModificationUser | Override in particular file systems to get user who was the last user modifying the item. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetModificationUserAsync | Async version of DoGetModificationUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetModificationUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetModificationUser(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetPermissionsStream | (Overrides FileSystem DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ).)
Protected method | DoGetPermissionsStreamAsync | Async version of DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ) and returns already completed Task with result returned by DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ) (Inherited from FileSystem.)
Protected method | DoGetReadOnly | (Overrides FileSystem DoGetReadOnly(FileSystemSessionItem).)
Protected method | DoGetSubDirectoryNames | (Overrides FileSystem DoGetSubDirectoryNames(FileSystemDirectory, Boolean).)
Protected method | DoGetSubDirectoryNamesAsync | Async version of DoGetSubDirectoryNames(FileSystemDirectory, Boolean). This base/default implementation just synchronously calls DoGetSubDirectoryNames(FileSystemDirectory, Boolean) and returns already completed Task with result returned by DoGetSubDirectoryNames(FileSystemDirectory, Boolean) (Inherited from FileSystem.)
Protected method | DoGetVersion | Override in particular file systems that support versioning to get version object for session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetVersionAsync | Async version of DoGetVersion(FileSystemSession). This base/default implementation just synchronously calls DoGetVersion(FileSystemSession) and returns already completed Task with result returned by DoGetVersion(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoNavigate | (Overrides FileSystem DoNavigate(FileSystemSession, String).)
Protected method | DoNavigateAsync | Async version of DoNavigate(FileSystemSession, String). This base/default implementation just synchronously calls DoNavigate(FileSystemSession, String) and returns already completed Task with result returned by DoNavigate(FileSystemSession, String) (Inherited from FileSystem.)
Protected method | DoReadAsync | (Inherited from FileSystem.)
Protected method | DoRefresh | Override to refresh item state, i.e. re-fetch remote information. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoRefreshAsync | Async version of DoRefreshAsync(FileSystemSessionItem). This base/default implementation just synchronously calls DoRefreshAsync(FileSystemSessionItem) and returns already completed Task with result returned by DoRefreshAsync(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoRenameItem | (Overrides FileSystem DoRenameItem(FileSystemSessionItem, String).)
Protected method | DoRenameItemAsync | Async version of DoRenameItem(FileSystemSessionItem, String). This base/default implementation just synchronously calls DoRenameItem(FileSystemSessionItem, String) and returns already completed Task with result returned by DoRenameItem(FileSystemSessionItem, String) (Inherited from FileSystem.)
Protected method | DoRollbackTransaction | Override in particular file systems that support transactions to rollback transaction in specified session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoRollbackTransactionAsync | Async version of DoRollbackTransaction(FileSystemSession). This base/default implementation just synchronously calls DoRollbackTransaction(FileSystemSession) and returns already completed Task with result returned by DoRollbackTransaction(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoSetCreationTimestamp | (Overrides FileSystem DoSetCreationTimestamp(FileSystemSessionItem, DateTime).)
Protected method | DoSetCreationTimestampAsync | Async version of DoSetCreationTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetCreationTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetCreationTimestamp(FileSystemSessionItem, DateTime) (Inherited from FileSystem.)
Protected method | DoSetLastAccessTimestamp | (Overrides FileSystem DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime).)
Protected method | DoSetLastAccessTimestampAsync | Async version of DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime) (Inherited from FileSystem.)
Protected method | DoSetModificationTimestamp | (Overrides FileSystem DoSetModificationTimestamp(FileSystemSessionItem, DateTime).)
Protected method | DoSetModificationTimestampAsync | Async version of DoSetModificationTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetModificationTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetModificationTimestamp(FileSystemSessionItem, DateTime) (Inherited from FileSystem.)
Protected method | DoSetReadOnly | (Overrides FileSystem DoSetReadOnly(FileSystemSessionItem, Boolean).)
Protected method | DoSetReadOnlyAsync | Async version of DoSetReadOnly(FileSystemSessionItem, Boolean). This base/default implementation just synchronously calls DoSetReadOnly(FileSystemSessionItem, Boolean) and returns already completed Task with result returned by DoSetReadOnly(FileSystemSessionItem, Boolean) (Inherited from FileSystem.)
Protected method | DoSetVersion | Override in particular file systems that support versioning to set seesion to specific version. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoSetVersionAsync | Async version of DoSetVersion(FileSystemSession, IFileSystemVersion). This base/default implementation just synchronously calls DoSetVersion(FileSystemSession, IFileSystemVersion) and returns already completed Task with result returned by DoSetVersion(FileSystemSession, IFileSystemVersion) (Inherited from FileSystem.)
Protected method | DoWriteAsync | (Inherited from FileSystem.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeSessionConfigParams | (Inherited from FileSystem.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | StartSession(FileSystemSessionConnectParams) | (Overrides FileSystem StartSession(FileSystemSessionConnectParams).)
Public method | StartSession(GoogleDriveParameters) |
Public method | ToString | (Inherited from FileSystem.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Name | (Inherited from FileSystem.)
Protected field | m_Sessions | (Inherited from FileSystem.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Protected property | DefaultSessionConnectParams | (Inherited from FileSystem.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | GeneralCapabilities | (Overrides FileSystem GeneralCapabilities.)
Public property | InstanceCapabilities | (Overrides FileSystem InstanceCapabilities.)
Public property | Name | Provides name for file system instance (Inherited from FileSystem.)
Public property | Sessions | Returns a list of sessions. This accessor is thread-safe (Inherited from FileSystem.)
Back to Top
See Also
GoogleDriveFileSystem Class
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem Constructor

GoogleDriveFileSystem Constructor NFX Class Library

Initializes a new instance of the GoogleDriveFileSystem class

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GoogleDriveFileSystem(
    string name,
    IConfigSectionNode node = null
)
public GoogleDriveFileSystem(
    string name,
    IConfigSectionNode node = null
)
Public Sub New (
    name As String,
    Optional node As IConfigSectionNode = Nothing
)
Public Sub New (
    name As String,
    Optional node As IConfigSectionNode = Nothing
)
public:
GoogleDriveFileSystem(
    String^ name,
    IConfigSectionNode^ node = nullptr
)
public:
GoogleDriveFileSystem(
    String^ name,
    IConfigSectionNode^ node = nullptr
)
new :
        name : string *
        ?node : IConfigSectionNode
(* Defaults:
        let _node = defaultArg node null
*)
-> GoogleDriveFileSystem
new :
        name : string *
        ?node : IConfigSectionNode
(* Defaults:
        let _node = defaultArg node null
*)
-> GoogleDriveFileSystem

Parameters

name
Type: Online System String
node (Optional)
Type: NFX.Environment IConfigSectionNode
See Also
GoogleDriveFileSystem Class
GoogleDriveFileSystem Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem Fields

GoogleDriveFileSystem Fields NFX Class Library

The GoogleDriveFileSystem type exposes the following members.
Fields
 | Name | Description
Protected field | m_Name | (Inherited from FileSystem.)
Protected field | m_Sessions | (Inherited from FileSystem.)
Back to Top
See Also
GoogleDriveFileSystem Class
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem Methods

GoogleDriveFileSystem Methods NFX Class Library

The GoogleDriveFileSystem type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | CombinePaths | Combines two or more path segments joining them using primary file system path separator. This method is thread-safe (Inherited from FileSystem.)
Public method | Configure | Configures file system. This method is a part of lifecycle management and is intended to be called only by creating thread (not thread-safe) (Inherited from FileSystem.)
Protected method | Destructor | (Inherited from FileSystem.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoBeginTransaction | Override in particular file systems that support transactions to begin transaction in specified session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoBeginTransactionAsync | Async version of DoBeginTransaction(FileSystemSession). This base/default implementation just synchronously calls DoBeginTransaction(FileSystemSession) and returns already completed Task with result returned by DoBeginTransaction(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoCheckCanChange | Override in particular file systems to see if item can change, i.e. for file systems that support versioning throw exception if item is in session which "looks" at a sealed/closed version and can not change. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoCheckCanChangeAsync | Async version of DoCheckCanChange(FileSystemSessionItem). This base/default implementation just synchronously calls DoCheckCanChange(FileSystemSessionItem) and returns already completed Task with result returned by DoCheckCanChange(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoCommitTransaction | Override in particular file systems that support transactions to commit transaction in specified session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoCommitTransactionAsync | Async version of DoCommitTransaction(FileSystemSession). This base/default implementation just synchronously calls DoCommitTransaction(FileSystemSession) and returns already completed Task with result returned by DoCommitTransaction(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoConfigure | Override to perform custom configuration (Inherited from FileSystem.)
Protected method | DoCreateDirectory | (Overrides FileSystem DoCreateDirectory(FileSystemDirectory, String).)
Protected method | DoCreateDirectoryAsync | Async version of DoCreateDirectory(FileSystemDirectory, String). This base/default implementation just synchronously calls DoCreateDirectory(FileSystemDirectory, String) and returns already completed Task with result returned by DoCreateDirectory(FileSystemDirectory, String) (Inherited from FileSystem.)
Protected method | DoCreateFile(FileSystemDirectory, String, Int32) | (Overrides FileSystem DoCreateFile(FileSystemDirectory, String, Int32).)
Protected method | DoCreateFile(FileSystemDirectory, String, String, Boolean) | (Overrides FileSystem DoCreateFile(FileSystemDirectory, String, String, Boolean).)
Protected method | DoCreateFileAsync(FileSystemDirectory, String, Int32) | Async version of DoCreateFile(FileSystemDirectory, String, Int32). This base/default implementation just synchronously calls DoCreateFile(FileSystemDirectory, String, Int32) and returns already completed Task with result returned by DoCreateFile(FileSystemDirectory, String, Int32) (Inherited from FileSystem.)
Protected method | DoCreateFileAsync(FileSystemDirectory, String, String, Boolean) | Async version of DoCreateFile(FileSystemDirectory, String, String, Boolean). This base/default implementation just synchronously calls DoCreateFile(FileSystemDirectory, String, String, Boolean) and returns already completed Task with result returned by DoCreateFile(FileSystemDirectory, String, String, Boolean) (Inherited from FileSystem.)
Protected method | DoDeleteItem | (Overrides FileSystem DoDeleteItem(FileSystemSessionItem).)
Protected method | DoDeleteItemAsync | Async version of DoDeleteItem(FileSystemSessionItem). This base/default implementation just synchronously calls DoDeleteItem(FileSystemSessionItem) and returns already completed Task with result returned by DoDeleteItem(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoDirectoryDeepCopyAsync | Implements asynchronous deep copy of folders where destination folder may belong to a different file system. The specifics of implementation may be dictated by particular file systems, i.e.: asynchronous strategies for getting file lists may depend on the particular system. (Inherited from FileSystem.)
Protected method | DoFlushAsync | (Inherited from FileSystem.)
Protected method | DoGetCreationTimestamp | (Overrides FileSystem DoGetCreationTimestamp(FileSystemSessionItem).)
Protected method | DoGetCreationUser | Override in particular file systems to get user who created item. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetCreationUserAsync | Async version of DoGetCreationUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetCreationUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetCreationUser(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetFileNames | (Overrides FileSystem DoGetFileNames(FileSystemDirectory, Boolean).)
Protected method | DoGetFileNamesAsync | Async version of DoGetFileNames(FileSystemDirectory, Boolean). This base/default implementation just synchronously calls DoGetFileNames(FileSystemDirectory, Boolean) and returns already completed Task with result returned by DoGetFileNames(FileSystemDirectory, Boolean) (Inherited from FileSystem.)
Protected method | DoGetFileStream | (Overrides FileSystem DoGetFileStream(FileSystemFile, Action FileSystemStream ).)
Protected method | DoGetFileStreamAsync | Async version of DoGetFileStream(FileSystemFile, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetFileStream(FileSystemFile, Action FileSystemStream ) and returns already completed Task with result returned by DoGetFileStream(FileSystemFile, Action FileSystemStream ) (Inherited from FileSystem.)
Protected method | DoGetItemSize | (Overrides FileSystem DoGetItemSize(FileSystemSessionItem).)
Protected method | DoGetItemSizeAsync | Async version of DoGetItemSize(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetItemSize(FileSystemSessionItem) and returns already completed Task with result returned by DoGetItemSize(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetLastAccessTimestamp | (Overrides FileSystem DoGetLastAccessTimestamp(FileSystemSessionItem).)
Protected method | DoGetLastAccessUser | Override in particular file systems to get user who was the last user accessing the item. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetLastAccessUserAsync | Async version of DoGetLastAccessUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetLastAccessUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetLastAccessUser(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetLatestVersion | Override in particular file systems that support versioning to get latest version object that this session can work with. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetLatestVersionAsync | Async version of DoGetLatestVersion(FileSystemSession). This base/default implementation just synchronously calls DoGetLatestVersion(FileSystemSession) and returns already completed Task with result returned by DoGetLatestVersion(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoGetMetadataStream | (Overrides FileSystem DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ).)
Protected method | DoGetMetadataStreamAsync | Async version of DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ) and returns already completed Task with result returned by DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ) (Inherited from FileSystem.)
Protected method | DoGetModificationTimestamp | (Overrides FileSystem DoGetModificationTimestamp(FileSystemSessionItem).)
Protected method | DoGetModificationUser | Override in particular file systems to get user who was the last user modifying the item. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetModificationUserAsync | Async version of DoGetModificationUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetModificationUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetModificationUser(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetPermissionsStream | (Overrides FileSystem DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ).)
Protected method | DoGetPermissionsStreamAsync | Async version of DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ) and returns already completed Task with result returned by DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ) (Inherited from FileSystem.)
Protected method | DoGetReadOnly | (Overrides FileSystem DoGetReadOnly(FileSystemSessionItem).)
Protected method | DoGetSubDirectoryNames | (Overrides FileSystem DoGetSubDirectoryNames(FileSystemDirectory, Boolean).)
Protected method | DoGetSubDirectoryNamesAsync | Async version of DoGetSubDirectoryNames(FileSystemDirectory, Boolean). This base/default implementation just synchronously calls DoGetSubDirectoryNames(FileSystemDirectory, Boolean) and returns already completed Task with result returned by DoGetSubDirectoryNames(FileSystemDirectory, Boolean) (Inherited from FileSystem.)
Protected method | DoGetVersion | Override in particular file systems that support versioning to get version object for session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetVersionAsync | Async version of DoGetVersion(FileSystemSession). This base/default implementation just synchronously calls DoGetVersion(FileSystemSession) and returns already completed Task with result returned by DoGetVersion(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoNavigate | (Overrides FileSystem DoNavigate(FileSystemSession, String).)
Protected method | DoNavigateAsync | Async version of DoNavigate(FileSystemSession, String). This base/default implementation just synchronously calls DoNavigate(FileSystemSession, String) and returns already completed Task with result returned by DoNavigate(FileSystemSession, String) (Inherited from FileSystem.)
Protected method | DoReadAsync | (Inherited from FileSystem.)
Protected method | DoRefresh | Override to refresh item state, i.e. re-fetch remote information. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoRefreshAsync | Async version of DoRefreshAsync(FileSystemSessionItem). This base/default implementation just synchronously calls DoRefreshAsync(FileSystemSessionItem) and returns already completed Task with result returned by DoRefreshAsync(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoRenameItem | (Overrides FileSystem DoRenameItem(FileSystemSessionItem, String).)
Protected method | DoRenameItemAsync | Async version of DoRenameItem(FileSystemSessionItem, String). This base/default implementation just synchronously calls DoRenameItem(FileSystemSessionItem, String) and returns already completed Task with result returned by DoRenameItem(FileSystemSessionItem, String) (Inherited from FileSystem.)
Protected method | DoRollbackTransaction | Override in particular file systems that support transactions to rollback transaction in specified session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoRollbackTransactionAsync | Async version of DoRollbackTransaction(FileSystemSession). This base/default implementation just synchronously calls DoRollbackTransaction(FileSystemSession) and returns already completed Task with result returned by DoRollbackTransaction(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoSetCreationTimestamp | (Overrides FileSystem DoSetCreationTimestamp(FileSystemSessionItem, DateTime).)
Protected method | DoSetCreationTimestampAsync | Async version of DoSetCreationTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetCreationTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetCreationTimestamp(FileSystemSessionItem, DateTime) (Inherited from FileSystem.)
Protected method | DoSetLastAccessTimestamp | (Overrides FileSystem DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime).)
Protected method | DoSetLastAccessTimestampAsync | Async version of DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime) (Inherited from FileSystem.)
Protected method | DoSetModificationTimestamp | (Overrides FileSystem DoSetModificationTimestamp(FileSystemSessionItem, DateTime).)
Protected method | DoSetModificationTimestampAsync | Async version of DoSetModificationTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetModificationTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetModificationTimestamp(FileSystemSessionItem, DateTime) (Inherited from FileSystem.)
Protected method | DoSetReadOnly | (Overrides FileSystem DoSetReadOnly(FileSystemSessionItem, Boolean).)
Protected method | DoSetReadOnlyAsync | Async version of DoSetReadOnly(FileSystemSessionItem, Boolean). This base/default implementation just synchronously calls DoSetReadOnly(FileSystemSessionItem, Boolean) and returns already completed Task with result returned by DoSetReadOnly(FileSystemSessionItem, Boolean) (Inherited from FileSystem.)
Protected method | DoSetVersion | Override in particular file systems that support versioning to set seesion to specific version. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoSetVersionAsync | Async version of DoSetVersion(FileSystemSession, IFileSystemVersion). This base/default implementation just synchronously calls DoSetVersion(FileSystemSession, IFileSystemVersion) and returns already completed Task with result returned by DoSetVersion(FileSystemSession, IFileSystemVersion) (Inherited from FileSystem.)
Protected method | DoWriteAsync | (Inherited from FileSystem.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeSessionConfigParams | (Inherited from FileSystem.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | StartSession(FileSystemSessionConnectParams) | (Overrides FileSystem StartSession(FileSystemSessionConnectParams).)
Public method | StartSession(GoogleDriveParameters) |
Public method | ToString | (Inherited from FileSystem.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GoogleDriveFileSystem Class
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem.DoCreateDirectory Method

GoogleDriveFileSystem DoCreateDirectory Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemDirectory DoCreateDirectory(
    FileSystemDirectory dir,
    string name
)
protected internal override FileSystemDirectory DoCreateDirectory(
    FileSystemDirectory dir,
    string name
)
Protected Friend Overrides Function DoCreateDirectory (
    dir As FileSystemDirectory,
    name As String
) As FileSystemDirectory
Protected Friend Overrides Function DoCreateDirectory (
    dir As FileSystemDirectory,
    name As String
) As FileSystemDirectory
protected public:
virtual FileSystemDirectory^ DoCreateDirectory(
    FileSystemDirectory^ dir,
    String^ name
) override
protected public:
virtual FileSystemDirectory^ DoCreateDirectory(
    FileSystemDirectory^ dir,
    String^ name
) override
abstract DoCreateDirectory :
        dir : FileSystemDirectory *
        name : string -> FileSystemDirectory
override DoCreateDirectory :
        dir : FileSystemDirectory *
        name : string -> FileSystemDirectory
abstract DoCreateDirectory :
        dir : FileSystemDirectory *
        name : string -> FileSystemDirectory
override DoCreateDirectory :
        dir : FileSystemDirectory *
        name : string -> FileSystemDirectory

Parameters

dir
Type: NFX.IO.FileSystem FileSystemDirectory
name
Type: Online System String

Return Value

Type: FileSystemDirectory
See Also
GoogleDriveFileSystem Class
GoogleDriveFileSystem Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem.DoCreateFile Method

GoogleDriveFileSystem DoCreateFile Method NFX Class Library

Overload List
 | Name | Description
Protected method | DoCreateFile(FileSystemDirectory, String, Int32) | (Overrides FileSystem DoCreateFile(FileSystemDirectory, String, Int32).)
Protected method | DoCreateFile(FileSystemDirectory, String, String, Boolean) | (Overrides FileSystem DoCreateFile(FileSystemDirectory, String, String, Boolean).)
Back to Top
See Also
GoogleDriveFileSystem Class
GoogleDriveFileSystem Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem.DoCreateFile Method (FileSystemDirectory, String, Int32)

GoogleDriveFileSystem DoCreateFile Method (FileSystemDirectory, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemFile DoCreateFile(
    FileSystemDirectory dir,
    string name,
    int size
)
protected internal override FileSystemFile DoCreateFile(
    FileSystemDirectory dir,
    string name,
    int size
)
Protected Friend Overrides Function DoCreateFile (
    dir As FileSystemDirectory,
    name As String,
    size As Integer
) As FileSystemFile
Protected Friend Overrides Function DoCreateFile (
    dir As FileSystemDirectory,
    name As String,
    size As Integer
) As FileSystemFile
protected public:
virtual FileSystemFile^ DoCreateFile(
    FileSystemDirectory^ dir,
    String^ name,
    int size
) override
protected public:
virtual FileSystemFile^ DoCreateFile(
    FileSystemDirectory^ dir,
    String^ name,
    int size
) override
abstract DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        size : int -> FileSystemFile
override DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        size : int -> FileSystemFile
abstract DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        size : int -> FileSystemFile
override DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        size : int -> FileSystemFile

Parameters

dir
Type: NFX.IO.FileSystem FileSystemDirectory
name
Type: Online System String
size
Type: Online System Int32

Return Value

Type: FileSystemFile
See Also
GoogleDriveFileSystem Class
GoogleDriveFileSystem Members
DoCreateFile Overload
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem.DoCreateFile Method (FileSystemDirectory, String, String, Boolean)

GoogleDriveFileSystem DoCreateFile Method (FileSystemDirectory, String, String, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemFile DoCreateFile(
    FileSystemDirectory dir,
    string name,
    string localFile,
    bool readOnly
)
protected internal override FileSystemFile DoCreateFile(
    FileSystemDirectory dir,
    string name,
    string localFile,
    bool readOnly
)
Protected Friend Overrides Function DoCreateFile (
    dir As FileSystemDirectory,
    name As String,
    localFile As String,
    readOnly As Boolean
) As FileSystemFile
Protected Friend Overrides Function DoCreateFile (
    dir As FileSystemDirectory,
    name As String,
    localFile As String,
    readOnly As Boolean
) As FileSystemFile
protected public:
virtual FileSystemFile^ DoCreateFile(
    FileSystemDirectory^ dir,
    String^ name,
    String^ localFile,
    bool readOnly
) override
protected public:
virtual FileSystemFile^ DoCreateFile(
    FileSystemDirectory^ dir,
    String^ name,
    String^ localFile,
    bool readOnly
) override
abstract DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        localFile : string *
        readOnly : bool -> FileSystemFile
override DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        localFile : string *
        readOnly : bool -> FileSystemFile
abstract DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        localFile : string *
        readOnly : bool -> FileSystemFile
override DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        localFile : string *
        readOnly : bool -> FileSystemFile

Parameters

dir
Type: NFX.IO.FileSystem FileSystemDirectory
name
Type: Online System String
localFile
Type: Online System String
readOnly
Type: Online System Boolean

Return Value

Type: FileSystemFile
See Also
GoogleDriveFileSystem Class
GoogleDriveFileSystem Members
DoCreateFile Overload
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem.DoDeleteItem Method

GoogleDriveFileSystem DoDeleteItem Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoDeleteItem(
    FileSystemSessionItem item
)
protected internal override void DoDeleteItem(
    FileSystemSessionItem item
)
Protected Friend Overrides Sub DoDeleteItem (
    item As FileSystemSessionItem
)
Protected Friend Overrides Sub DoDeleteItem (
    item As FileSystemSessionItem
)
protected public:
virtual void DoDeleteItem(
    FileSystemSessionItem^ item
) override
protected public:
virtual void DoDeleteItem(
    FileSystemSessionItem^ item
) override
abstract DoDeleteItem :
        item : FileSystemSessionItem -> unit
override DoDeleteItem :
        item : FileSystemSessionItem -> unit
abstract DoDeleteItem :
        item : FileSystemSessionItem -> unit
override DoDeleteItem :
        item : FileSystemSessionItem -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
See Also
GoogleDriveFileSystem Class
GoogleDriveFileSystem Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem.DoGetCreationTimestamp Method

GoogleDriveFileSystem DoGetCreationTimestamp Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override Nullable<DateTime> DoGetCreationTimestamp(
    FileSystemSessionItem item
)
protected internal override Nullable<DateTime> DoGetCreationTimestamp(
    FileSystemSessionItem item
)
Protected Friend Overrides Function DoGetCreationTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
Protected Friend Overrides Function DoGetCreationTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
protected public:
virtual Nullable<DateTime> DoGetCreationTimestamp(
    FileSystemSessionItem^ item
) override
protected public:
virtual Nullable<DateTime> DoGetCreationTimestamp(
    FileSystemSessionItem^ item
) override
abstract DoGetCreationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
override DoGetCreationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
abstract DoGetCreationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
override DoGetCreationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online Nullable Online DateTime
See Also
GoogleDriveFileSystem Class
GoogleDriveFileSystem Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem.DoGetFileNames Method

GoogleDriveFileSystem DoGetFileNames Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override IEnumerable<string> DoGetFileNames(
    FileSystemDirectory directory,
    bool recursive
)
protected internal override IEnumerable<string> DoGetFileNames(
    FileSystemDirectory directory,
    bool recursive
)
Protected Friend Overrides Function DoGetFileNames (
    directory As FileSystemDirectory,
    recursive As Boolean
) As IEnumerable(Of String)
Protected Friend Overrides Function DoGetFileNames (
    directory As FileSystemDirectory,
    recursive As Boolean
) As IEnumerable(Of String)
protected public:
virtual IEnumerable<String^>^ DoGetFileNames(
    FileSystemDirectory^ directory,
    bool recursive
) override
protected public:
virtual IEnumerable<String^>^ DoGetFileNames(
    FileSystemDirectory^ directory,
    bool recursive
) override
abstract DoGetFileNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>
override DoGetFileNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>
abstract DoGetFileNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>
override DoGetFileNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>

Parameters

directory
Type: NFX.IO.FileSystem FileSystemDirectory
recursive
Type: Online System Boolean

Return Value

Type: Online IEnumerable Online String
See Also
GoogleDriveFileSystem Class
GoogleDriveFileSystem Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem.DoGetFileStream Method

GoogleDriveFileSystem DoGetFileStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemStream DoGetFileStream(
    FileSystemFile file,
    Action<FileSystemStream> disposeAction
)
protected internal override FileSystemStream DoGetFileStream(
    FileSystemFile file,
    Action<FileSystemStream> disposeAction
)
Protected Friend Overrides Function DoGetFileStream (
    file As FileSystemFile,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
Protected Friend Overrides Function DoGetFileStream (
    file As FileSystemFile,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
protected public:
virtual FileSystemStream^ DoGetFileStream(
    FileSystemFile^ file,
    Action<FileSystemStream^>^ disposeAction
) override
protected public:
virtual FileSystemStream^ DoGetFileStream(
    FileSystemFile^ file,
    Action<FileSystemStream^>^ disposeAction
) override
abstract DoGetFileStream :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
override DoGetFileStream :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
abstract DoGetFileStream :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
override DoGetFileStream :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> FileSystemStream

Parameters

file
Type: NFX.IO.FileSystem FileSystemFile
disposeAction
Type: Online System Action FileSystemStream

Return Value

Type: FileSystemStream
See Also
GoogleDriveFileSystem Class
GoogleDriveFileSystem Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem.DoGetItemSize Method

GoogleDriveFileSystem DoGetItemSize Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override ulong DoGetItemSize(
    FileSystemSessionItem item
)
protected internal override ulong DoGetItemSize(
    FileSystemSessionItem item
)
Protected Friend Overrides Function DoGetItemSize (
    item As FileSystemSessionItem
) As ULong
Protected Friend Overrides Function DoGetItemSize (
    item As FileSystemSessionItem
) As ULong
protected public:
virtual unsigned long long DoGetItemSize(
    FileSystemSessionItem^ item
) override
protected public:
virtual unsigned long long DoGetItemSize(
    FileSystemSessionItem^ item
) override
abstract DoGetItemSize :
        item : FileSystemSessionItem -> uint64
override DoGetItemSize :
        item : FileSystemSessionItem -> uint64
abstract DoGetItemSize :
        item : FileSystemSessionItem -> uint64
override DoGetItemSize :
        item : FileSystemSessionItem -> uint64

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online UInt64
See Also
GoogleDriveFileSystem Class
GoogleDriveFileSystem Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem.DoGetLastAccessTimestamp Method

GoogleDriveFileSystem DoGetLastAccessTimestamp Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override Nullable<DateTime> DoGetLastAccessTimestamp(
    FileSystemSessionItem item
)
protected internal override Nullable<DateTime> DoGetLastAccessTimestamp(
    FileSystemSessionItem item
)
Protected Friend Overrides Function DoGetLastAccessTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
Protected Friend Overrides Function DoGetLastAccessTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
protected public:
virtual Nullable<DateTime> DoGetLastAccessTimestamp(
    FileSystemSessionItem^ item
) override
protected public:
virtual Nullable<DateTime> DoGetLastAccessTimestamp(
    FileSystemSessionItem^ item
) override
abstract DoGetLastAccessTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
override DoGetLastAccessTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
abstract DoGetLastAccessTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
override DoGetLastAccessTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online Nullable Online DateTime
See Also
GoogleDriveFileSystem Class
GoogleDriveFileSystem Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem.DoGetMetadataStream Method

GoogleDriveFileSystem DoGetMetadataStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemStream DoGetMetadataStream(
    FileSystemSessionItem item,
    Action<FileSystemStream> disposeAction
)
protected internal override FileSystemStream DoGetMetadataStream(
    FileSystemSessionItem item,
    Action<FileSystemStream> disposeAction
)
Protected Friend Overrides Function DoGetMetadataStream (
    item As FileSystemSessionItem,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
Protected Friend Overrides Function DoGetMetadataStream (
    item As FileSystemSessionItem,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
protected public:
virtual FileSystemStream^ DoGetMetadataStream(
    FileSystemSessionItem^ item,
    Action<FileSystemStream^>^ disposeAction
) override
protected public:
virtual FileSystemStream^ DoGetMetadataStream(
    FileSystemSessionItem^ item,
    Action<FileSystemStream^>^ disposeAction
) override
abstract DoGetMetadataStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
override DoGetMetadataStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
abstract DoGetMetadataStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
override DoGetMetadataStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
disposeAction
Type: Online System Action FileSystemStream

Return Value

Type: FileSystemStream
See Also
GoogleDriveFileSystem Class
GoogleDriveFileSystem Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem.DoGetModificationTimestamp Method

GoogleDriveFileSystem DoGetModificationTimestamp Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override Nullable<DateTime> DoGetModificationTimestamp(
    FileSystemSessionItem item
)
protected internal override Nullable<DateTime> DoGetModificationTimestamp(
    FileSystemSessionItem item
)
Protected Friend Overrides Function DoGetModificationTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
Protected Friend Overrides Function DoGetModificationTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
protected public:
virtual Nullable<DateTime> DoGetModificationTimestamp(
    FileSystemSessionItem^ item
) override
protected public:
virtual Nullable<DateTime> DoGetModificationTimestamp(
    FileSystemSessionItem^ item
) override
abstract DoGetModificationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
override DoGetModificationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
abstract DoGetModificationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
override DoGetModificationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online Nullable Online DateTime
See Also
GoogleDriveFileSystem Class
GoogleDriveFileSystem Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem.DoGetPermissionsStream Method

GoogleDriveFileSystem DoGetPermissionsStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemStream DoGetPermissionsStream(
    FileSystemSessionItem item,
    Action<FileSystemStream> disposeAction
)
protected internal override FileSystemStream DoGetPermissionsStream(
    FileSystemSessionItem item,
    Action<FileSystemStream> disposeAction
)
Protected Friend Overrides Function DoGetPermissionsStream (
    item As FileSystemSessionItem,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
Protected Friend Overrides Function DoGetPermissionsStream (
    item As FileSystemSessionItem,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
protected public:
virtual FileSystemStream^ DoGetPermissionsStream(
    FileSystemSessionItem^ item,
    Action<FileSystemStream^>^ disposeAction
) override
protected public:
virtual FileSystemStream^ DoGetPermissionsStream(
    FileSystemSessionItem^ item,
    Action<FileSystemStream^>^ disposeAction
) override
abstract DoGetPermissionsStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
override DoGetPermissionsStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
abstract DoGetPermissionsStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
override DoGetPermissionsStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
disposeAction
Type: Online System Action FileSystemStream

Return Value

Type: FileSystemStream
See Also
GoogleDriveFileSystem Class
GoogleDriveFileSystem Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem.DoGetReadOnly Method

GoogleDriveFileSystem DoGetReadOnly Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override bool DoGetReadOnly(
    FileSystemSessionItem item
)
protected internal override bool DoGetReadOnly(
    FileSystemSessionItem item
)
Protected Friend Overrides Function DoGetReadOnly (
    item As FileSystemSessionItem
) As Boolean
Protected Friend Overrides Function DoGetReadOnly (
    item As FileSystemSessionItem
) As Boolean
protected public:
virtual bool DoGetReadOnly(
    FileSystemSessionItem^ item
) override
protected public:
virtual bool DoGetReadOnly(
    FileSystemSessionItem^ item
) override
abstract DoGetReadOnly :
        item : FileSystemSessionItem -> bool
override DoGetReadOnly :
        item : FileSystemSessionItem -> bool
abstract DoGetReadOnly :
        item : FileSystemSessionItem -> bool
override DoGetReadOnly :
        item : FileSystemSessionItem -> bool

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online Boolean
See Also
GoogleDriveFileSystem Class
GoogleDriveFileSystem Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem.DoGetSubDirectoryNames Method

GoogleDriveFileSystem DoGetSubDirectoryNames Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override IEnumerable<string> DoGetSubDirectoryNames(
    FileSystemDirectory directory,
    bool recursive
)
protected internal override IEnumerable<string> DoGetSubDirectoryNames(
    FileSystemDirectory directory,
    bool recursive
)
Protected Friend Overrides Function DoGetSubDirectoryNames (
    directory As FileSystemDirectory,
    recursive As Boolean
) As IEnumerable(Of String)
Protected Friend Overrides Function DoGetSubDirectoryNames (
    directory As FileSystemDirectory,
    recursive As Boolean
) As IEnumerable(Of String)
protected public:
virtual IEnumerable<String^>^ DoGetSubDirectoryNames(
    FileSystemDirectory^ directory,
    bool recursive
) override
protected public:
virtual IEnumerable<String^>^ DoGetSubDirectoryNames(
    FileSystemDirectory^ directory,
    bool recursive
) override
abstract DoGetSubDirectoryNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>
override DoGetSubDirectoryNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>
abstract DoGetSubDirectoryNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>
override DoGetSubDirectoryNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>

Parameters

directory
Type: NFX.IO.FileSystem FileSystemDirectory
recursive
Type: Online System Boolean

Return Value

Type: Online IEnumerable Online String
See Also
GoogleDriveFileSystem Class
GoogleDriveFileSystem Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem.DoNavigate Method

GoogleDriveFileSystem DoNavigate Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemSessionItem DoNavigate(
    FileSystemSession session,
    string path
)
protected internal override FileSystemSessionItem DoNavigate(
    FileSystemSession session,
    string path
)
Protected Friend Overrides Function DoNavigate (
    session As FileSystemSession,
    path As String
) As FileSystemSessionItem
Protected Friend Overrides Function DoNavigate (
    session As FileSystemSession,
    path As String
) As FileSystemSessionItem
protected public:
virtual FileSystemSessionItem^ DoNavigate(
    FileSystemSession^ session,
    String^ path
) override
protected public:
virtual FileSystemSessionItem^ DoNavigate(
    FileSystemSession^ session,
    String^ path
) override
abstract DoNavigate :
        session : FileSystemSession *
        path : string -> FileSystemSessionItem
override DoNavigate :
        session : FileSystemSession *
        path : string -> FileSystemSessionItem
abstract DoNavigate :
        session : FileSystemSession *
        path : string -> FileSystemSessionItem
override DoNavigate :
        session : FileSystemSession *
        path : string -> FileSystemSessionItem

Parameters

session
Type: NFX.IO.FileSystem FileSystemSession
path
Type: Online System String

Return Value

Type: FileSystemSessionItem
See Also
GoogleDriveFileSystem Class
GoogleDriveFileSystem Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem.DoRenameItem Method

GoogleDriveFileSystem DoRenameItem Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override bool DoRenameItem(
    FileSystemSessionItem item,
    string newName
)
protected internal override bool DoRenameItem(
    FileSystemSessionItem item,
    string newName
)
Protected Friend Overrides Function DoRenameItem (
    item As FileSystemSessionItem,
    newName As String
) As Boolean
Protected Friend Overrides Function DoRenameItem (
    item As FileSystemSessionItem,
    newName As String
) As Boolean
protected public:
virtual bool DoRenameItem(
    FileSystemSessionItem^ item,
    String^ newName
) override
protected public:
virtual bool DoRenameItem(
    FileSystemSessionItem^ item,
    String^ newName
) override
abstract DoRenameItem :
        item : FileSystemSessionItem *
        newName : string -> bool
override DoRenameItem :
        item : FileSystemSessionItem *
        newName : string -> bool
abstract DoRenameItem :
        item : FileSystemSessionItem *
        newName : string -> bool
override DoRenameItem :
        item : FileSystemSessionItem *
        newName : string -> bool

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
newName
Type: Online System String

Return Value

Type: Online Boolean
See Also
GoogleDriveFileSystem Class
GoogleDriveFileSystem Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem.DoSetCreationTimestamp Method

GoogleDriveFileSystem DoSetCreationTimestamp Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoSetCreationTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
protected internal override void DoSetCreationTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
Protected Friend Overrides Sub DoSetCreationTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
Protected Friend Overrides Sub DoSetCreationTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
protected public:
virtual void DoSetCreationTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) override
protected public:
virtual void DoSetCreationTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) override
abstract DoSetCreationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
override DoSetCreationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
abstract DoSetCreationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
override DoSetCreationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
timestamp
Type: Online System DateTime
See Also
GoogleDriveFileSystem Class
GoogleDriveFileSystem Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem.DoSetLastAccessTimestamp Method

GoogleDriveFileSystem DoSetLastAccessTimestamp Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoSetLastAccessTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
protected internal override void DoSetLastAccessTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
Protected Friend Overrides Sub DoSetLastAccessTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
Protected Friend Overrides Sub DoSetLastAccessTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
protected public:
virtual void DoSetLastAccessTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) override
protected public:
virtual void DoSetLastAccessTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) override
abstract DoSetLastAccessTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
override DoSetLastAccessTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
abstract DoSetLastAccessTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
override DoSetLastAccessTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
timestamp
Type: Online System DateTime
See Also
GoogleDriveFileSystem Class
GoogleDriveFileSystem Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem.DoSetModificationTimestamp Method

GoogleDriveFileSystem DoSetModificationTimestamp Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoSetModificationTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
protected internal override void DoSetModificationTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
Protected Friend Overrides Sub DoSetModificationTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
Protected Friend Overrides Sub DoSetModificationTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
protected public:
virtual void DoSetModificationTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) override
protected public:
virtual void DoSetModificationTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) override
abstract DoSetModificationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
override DoSetModificationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
abstract DoSetModificationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
override DoSetModificationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
timestamp
Type: Online System DateTime
See Also
GoogleDriveFileSystem Class
GoogleDriveFileSystem Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem.DoSetReadOnly Method

GoogleDriveFileSystem DoSetReadOnly Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoSetReadOnly(
    FileSystemSessionItem item,
    bool readOnly
)
protected internal override void DoSetReadOnly(
    FileSystemSessionItem item,
    bool readOnly
)
Protected Friend Overrides Sub DoSetReadOnly (
    item As FileSystemSessionItem,
    readOnly As Boolean
)
Protected Friend Overrides Sub DoSetReadOnly (
    item As FileSystemSessionItem,
    readOnly As Boolean
)
protected public:
virtual void DoSetReadOnly(
    FileSystemSessionItem^ item,
    bool readOnly
) override
protected public:
virtual void DoSetReadOnly(
    FileSystemSessionItem^ item,
    bool readOnly
) override
abstract DoSetReadOnly :
        item : FileSystemSessionItem *
        readOnly : bool -> unit
override DoSetReadOnly :
        item : FileSystemSessionItem *
        readOnly : bool -> unit
abstract DoSetReadOnly :
        item : FileSystemSessionItem *
        readOnly : bool -> unit
override DoSetReadOnly :
        item : FileSystemSessionItem *
        readOnly : bool -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
readOnly
Type: Online System Boolean
See Also
GoogleDriveFileSystem Class
GoogleDriveFileSystem Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem.StartSession Method

GoogleDriveFileSystem StartSession Method NFX Class Library

Overload List
 | Name | Description
Public method | StartSession(FileSystemSessionConnectParams) | (Overrides FileSystem StartSession(FileSystemSessionConnectParams).)
Public method | StartSession(GoogleDriveParameters) |
Back to Top
See Also
GoogleDriveFileSystem Class
GoogleDriveFileSystem Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem.StartSession Method (FileSystemSessionConnectParams)

GoogleDriveFileSystem StartSession Method (FileSystemSessionConnectParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override FileSystemSession StartSession(
    FileSystemSessionConnectParams cParams = null
)
public override FileSystemSession StartSession(
    FileSystemSessionConnectParams cParams = null
)
Public Overrides Function StartSession (
    Optional cParams As FileSystemSessionConnectParams = Nothing
) As FileSystemSession
Public Overrides Function StartSession (
    Optional cParams As FileSystemSessionConnectParams = Nothing
) As FileSystemSession
public:
virtual FileSystemSession^ StartSession(
    FileSystemSessionConnectParams^ cParams = nullptr
) override
public:
virtual FileSystemSession^ StartSession(
    FileSystemSessionConnectParams^ cParams = nullptr
) override
abstract StartSession :
        ?cParams : FileSystemSessionConnectParams
(* Defaults:
        let _cParams = defaultArg cParams null
*)
-> FileSystemSession
override StartSession :
        ?cParams : FileSystemSessionConnectParams
(* Defaults:
        let _cParams = defaultArg cParams null
*)
-> FileSystemSession
abstract StartSession :
        ?cParams : FileSystemSessionConnectParams
(* Defaults:
        let _cParams = defaultArg cParams null
*)
-> FileSystemSession
override StartSession :
        ?cParams : FileSystemSessionConnectParams
(* Defaults:
        let _cParams = defaultArg cParams null
*)
-> FileSystemSession

Parameters

cParams (Optional)
Type: NFX.IO.FileSystem FileSystemSessionConnectParams

Return Value

Type: FileSystemSession

Implements

IFileSystem StartSession(FileSystemSessionConnectParams)
See Also
GoogleDriveFileSystem Class
GoogleDriveFileSystem Members
StartSession Overload
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem.StartSession Method (GoogleDriveParameters)

GoogleDriveFileSystem StartSession Method (GoogleDriveParameters) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GoogleDriveSession StartSession(
    GoogleDriveParameters cParams = null
)
public GoogleDriveSession StartSession(
    GoogleDriveParameters cParams = null
)
Public Function StartSession (
    Optional cParams As GoogleDriveParameters = Nothing
) As GoogleDriveSession
Public Function StartSession (
    Optional cParams As GoogleDriveParameters = Nothing
) As GoogleDriveSession
public:
GoogleDriveSession^ StartSession(
    GoogleDriveParameters^ cParams = nullptr
)
public:
GoogleDriveSession^ StartSession(
    GoogleDriveParameters^ cParams = nullptr
)
member StartSession :
        ?cParams : GoogleDriveParameters
(* Defaults:
        let _cParams = defaultArg cParams null
*)
-> GoogleDriveSession
member StartSession :
        ?cParams : GoogleDriveParameters
(* Defaults:
        let _cParams = defaultArg cParams null
*)
-> GoogleDriveSession

Parameters

cParams (Optional)
Type: NFX.IO.FileSystem.GoogleDrive GoogleDriveParameters

Return Value

Type: GoogleDriveSession
See Also
GoogleDriveFileSystem Class
GoogleDriveFileSystem Members
StartSession Overload
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem Properties

GoogleDriveFileSystem Properties NFX Class Library

The GoogleDriveFileSystem type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Protected property | DefaultSessionConnectParams | (Inherited from FileSystem.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | GeneralCapabilities | (Overrides FileSystem GeneralCapabilities.)
Public property | InstanceCapabilities | (Overrides FileSystem InstanceCapabilities.)
Public property | Name | Provides name for file system instance (Inherited from FileSystem.)
Public property | Sessions | Returns a list of sessions. This accessor is thread-safe (Inherited from FileSystem.)
Back to Top
See Also
GoogleDriveFileSystem Class
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem.GeneralCapabilities Property

GoogleDriveFileSystem GeneralCapabilities Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IFileSystemCapabilities GeneralCapabilities { get; }
public override IFileSystemCapabilities GeneralCapabilities { get; }
Public Overrides ReadOnly Property GeneralCapabilities As IFileSystemCapabilities
    Get
Public Overrides ReadOnly Property GeneralCapabilities As IFileSystemCapabilities
    Get
public:
virtual property IFileSystemCapabilities^ GeneralCapabilities {
    IFileSystemCapabilities^ get () override;
}
public:
virtual property IFileSystemCapabilities^ GeneralCapabilities {
    IFileSystemCapabilities^ get () override;
}
abstract GeneralCapabilities : IFileSystemCapabilities with get
override GeneralCapabilities : IFileSystemCapabilities with get
abstract GeneralCapabilities : IFileSystemCapabilities with get
override GeneralCapabilities : IFileSystemCapabilities with get

Property Value

Type: IFileSystemCapabilities

Implements

IFileSystem GeneralCapabilities
See Also
GoogleDriveFileSystem Class
GoogleDriveFileSystem Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveFileSystem.InstanceCapabilities Property

GoogleDriveFileSystem InstanceCapabilities Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IFileSystemCapabilities InstanceCapabilities { get; }
public override IFileSystemCapabilities InstanceCapabilities { get; }
Public Overrides ReadOnly Property InstanceCapabilities As IFileSystemCapabilities
    Get
Public Overrides ReadOnly Property InstanceCapabilities As IFileSystemCapabilities
    Get
public:
virtual property IFileSystemCapabilities^ InstanceCapabilities {
    IFileSystemCapabilities^ get () override;
}
public:
virtual property IFileSystemCapabilities^ InstanceCapabilities {
    IFileSystemCapabilities^ get () override;
}
abstract InstanceCapabilities : IFileSystemCapabilities with get
override InstanceCapabilities : IFileSystemCapabilities with get
abstract InstanceCapabilities : IFileSystemCapabilities with get
override InstanceCapabilities : IFileSystemCapabilities with get

Property Value

Type: IFileSystemCapabilities

Implements

IFileSystem InstanceCapabilities
See Also
GoogleDriveFileSystem Class
GoogleDriveFileSystem Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveHandle Class

GoogleDriveHandle Class NFX Class Library

Google Drive file handle
Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.GoogleDrive.V2 GoogleDriveHandle

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GoogleDriveHandle : IFileSystemHandle
public class GoogleDriveHandle : IFileSystemHandle
Public Class GoogleDriveHandle
    Implements IFileSystemHandle
Public Class GoogleDriveHandle
    Implements IFileSystemHandle
public ref class GoogleDriveHandle : IFileSystemHandle
public ref class GoogleDriveHandle : IFileSystemHandle
type GoogleDriveHandle =
    class
        interface IFileSystemHandle
    end
type GoogleDriveHandle =
    class
        interface IFileSystemHandle
    end
See Also
GoogleDriveHandle Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveHandle Members

GoogleDriveHandle Members NFX Class Library

The GoogleDriveHandle type exposes the following members.
Constructors
 | Name | Description
Public method | GoogleDriveHandle | Initializes a new instance of the GoogleDriveHandle class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | CreatedDate |
Public property | Id |
Public property | IsFolder |
Public property | IsReadOnly |
Public property | ModifiedDate |
Public property | Name |
Public property | Size |
Back to Top
See Also
GoogleDriveHandle Class
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveHandle Constructor

GoogleDriveHandle Constructor NFX Class Library

Initializes a new instance of the GoogleDriveHandle class

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GoogleDriveHandle(
    JSONDataMap info
)
public GoogleDriveHandle(
    JSONDataMap info
)
Public Sub New (
    info As JSONDataMap
)
Public Sub New (
    info As JSONDataMap
)
public:
GoogleDriveHandle(
    JSONDataMap^ info
)
public:
GoogleDriveHandle(
    JSONDataMap^ info
)
new :
        info : JSONDataMap -> GoogleDriveHandle
new :
        info : JSONDataMap -> GoogleDriveHandle

Parameters

info
Type: NFX.Serialization.JSON JSONDataMap
See Also
GoogleDriveHandle Class
GoogleDriveHandle Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveHandle Methods

GoogleDriveHandle Methods NFX Class Library

The GoogleDriveHandle type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GoogleDriveHandle Class
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveHandle Properties

GoogleDriveHandle Properties NFX Class Library

The GoogleDriveHandle type exposes the following members.
Properties
 | Name | Description
Public property | CreatedDate |
Public property | Id |
Public property | IsFolder |
Public property | IsReadOnly |
Public property | ModifiedDate |
Public property | Name |
Public property | Size |
Back to Top
See Also
GoogleDriveHandle Class
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveHandle.CreatedDate Property

GoogleDriveHandle CreatedDate Property NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime CreatedDate { get; set; }
public DateTime CreatedDate { get; set; }
Public Property CreatedDate As DateTime
    Get
    Set
Public Property CreatedDate As DateTime
    Get
    Set
public:
property DateTime CreatedDate {
    DateTime get ();
    void set (DateTime value);
}
public:
property DateTime CreatedDate {
    DateTime get ();
    void set (DateTime value);
}
member CreatedDate : DateTime with get, set
member CreatedDate : DateTime with get, set

Property Value

Type: Online DateTime
See Also
GoogleDriveHandle Class
GoogleDriveHandle Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveHandle.Id Property

GoogleDriveHandle Id Property NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Id { get; set; }
public string Id { get; set; }
Public Property Id As String
    Get
    Set
Public Property Id As String
    Get
    Set
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
member Id : string with get, set
member Id : string with get, set

Property Value

Type: Online String
See Also
GoogleDriveHandle Class
GoogleDriveHandle Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveHandle.IsFolder Property

GoogleDriveHandle IsFolder Property NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsFolder { get; set; }
public bool IsFolder { get; set; }
Public Property IsFolder As Boolean
    Get
    Set
Public Property IsFolder As Boolean
    Get
    Set
public:
property bool IsFolder {
    bool get ();
    void set (bool value);
}
public:
property bool IsFolder {
    bool get ();
    void set (bool value);
}
member IsFolder : bool with get, set
member IsFolder : bool with get, set

Property Value

Type: Online Boolean
See Also
GoogleDriveHandle Class
GoogleDriveHandle Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveHandle.IsReadOnly Property

GoogleDriveHandle IsReadOnly Property NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsReadOnly { get; set; }
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set
Public Property IsReadOnly As Boolean
    Get
    Set
public:
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}
public:
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}
member IsReadOnly : bool with get, set
member IsReadOnly : bool with get, set

Property Value

Type: Online Boolean
See Also
GoogleDriveHandle Class
GoogleDriveHandle Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveHandle.ModifiedDate Property

GoogleDriveHandle ModifiedDate Property NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime ModifiedDate { get; set; }
public DateTime ModifiedDate { get; set; }
Public Property ModifiedDate As DateTime
    Get
    Set
Public Property ModifiedDate As DateTime
    Get
    Set
public:
property DateTime ModifiedDate {
    DateTime get ();
    void set (DateTime value);
}
public:
property DateTime ModifiedDate {
    DateTime get ();
    void set (DateTime value);
}
member ModifiedDate : DateTime with get, set
member ModifiedDate : DateTime with get, set

Property Value

Type: Online DateTime
See Also
GoogleDriveHandle Class
GoogleDriveHandle Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveHandle.Name Property

GoogleDriveHandle Name Property NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
Public Property Name As String
    Get
    Set
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set
member Name : string with get, set

Property Value

Type: Online String
See Also
GoogleDriveHandle Class
GoogleDriveHandle Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveHandle.Size Property

GoogleDriveHandle Size Property NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong Size { get; set; }
public ulong Size { get; set; }
Public Property Size As ULong
    Get
    Set
Public Property Size As ULong
    Get
    Set
public:
property unsigned long long Size {
    unsigned long long get ();
    void set (unsigned long long value);
}
public:
property unsigned long long Size {
    unsigned long long get ();
    void set (unsigned long long value);
}
member Size : uint64 with get, set
member Size : uint64 with get, set

Property Value

Type: Online UInt64
See Also
GoogleDriveHandle Class
GoogleDriveHandle Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveRequestBody Class

GoogleDriveRequestBody Class NFX Class Library

Represents a request to Google Drive REST API
Inheritance Hierarchy
Online System Object
Online System.Collections.Generic Dictionary Online String, Online Object
NFX.IO.FileSystem.GoogleDrive.V2 GoogleDriveRequestBody

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class GoogleDriveRequestBody : Dictionary<string, Object>
internal class GoogleDriveRequestBody : Dictionary<string, Object>
Friend Class GoogleDriveRequestBody
    Inherits Dictionary(Of String, Object)
Friend Class GoogleDriveRequestBody
    Inherits Dictionary(Of String, Object)
internal ref class GoogleDriveRequestBody : public Dictionary<String^, Object^>
internal ref class GoogleDriveRequestBody : public Dictionary<String^, Object^>
type GoogleDriveRequestBody =
    class
        inherit Dictionary<string, Object>
    end
type GoogleDriveRequestBody =
    class
        inherit Dictionary<string, Object>
    end
See Also
GoogleDriveRequestBody Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveRequestBody Members

GoogleDriveRequestBody Members NFX Class Library

The GoogleDriveRequestBody type exposes the following members.
Constructors
 | Name | Description
Public method | GoogleDriveRequestBody | Initializes a new instance of the GoogleDriveRequestBody class
Back to Top
Methods
 | Name | Description
Public method | Online Add | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online Clear | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online ContainsKey | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online ContainsValue | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online Dictionary TKey, TValue instance. (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online Remove | (Inherited from Online Dictionary Online String, Online Object .)
Public method | SetMimeType |
Public method | SetModifiedDate |
Public method | SetParent |
Public method | SetTitle |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TryGetValue | (Inherited from Online Dictionary Online String, Online Object .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToFormEncoded | (Defined by Extensions.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online Comparer | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Online Count | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Online Item | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Online Keys | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Online Values | (Inherited from Online Dictionary Online String, Online Object .)
Back to Top
See Also
GoogleDriveRequestBody Class
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveRequestBody Constructor

GoogleDriveRequestBody Constructor NFX Class Library

Initializes a new instance of the GoogleDriveRequestBody class

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GoogleDriveRequestBody()
public GoogleDriveRequestBody()
Public Sub New
Public Sub New
public:
GoogleDriveRequestBody()
public:
GoogleDriveRequestBody()
new : unit -> GoogleDriveRequestBody
new : unit -> GoogleDriveRequestBody
See Also
GoogleDriveRequestBody Class
GoogleDriveRequestBody Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveRequestBody Methods

GoogleDriveRequestBody Methods NFX Class Library

The GoogleDriveRequestBody type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online Clear | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online ContainsKey | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online ContainsValue | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online Dictionary TKey, TValue instance. (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online Remove | (Inherited from Online Dictionary Online String, Online Object .)
Public method | SetMimeType |
Public method | SetModifiedDate |
Public method | SetParent |
Public method | SetTitle |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TryGetValue | (Inherited from Online Dictionary Online String, Online Object .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToFormEncoded | (Defined by Extensions.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GoogleDriveRequestBody Class
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveRequestBody.SetMimeType Method

GoogleDriveRequestBody SetMimeType Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetMimeType(
    string mimeType
)
public void SetMimeType(
    string mimeType
)
Public Sub SetMimeType (
    mimeType As String
)
Public Sub SetMimeType (
    mimeType As String
)
public:
void SetMimeType(
    String^ mimeType
)
public:
void SetMimeType(
    String^ mimeType
)
member SetMimeType :
        mimeType : string -> unit
member SetMimeType :
        mimeType : string -> unit

Parameters

mimeType
Type: Online System String
See Also
GoogleDriveRequestBody Class
GoogleDriveRequestBody Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveRequestBody.SetModifiedDate Method

GoogleDriveRequestBody SetModifiedDate Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetModifiedDate(
    DateTime date
)
public void SetModifiedDate(
    DateTime date
)
Public Sub SetModifiedDate (
    date As DateTime
)
Public Sub SetModifiedDate (
    date As DateTime
)
public:
void SetModifiedDate(
    DateTime date
)
public:
void SetModifiedDate(
    DateTime date
)
member SetModifiedDate :
        date : DateTime -> unit
member SetModifiedDate :
        date : DateTime -> unit

Parameters

date
Type: Online System DateTime
See Also
GoogleDriveRequestBody Class
GoogleDriveRequestBody Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveRequestBody.SetParent Method

GoogleDriveRequestBody SetParent Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetParent(
    string parentId
)
public void SetParent(
    string parentId
)
Public Sub SetParent (
    parentId As String
)
Public Sub SetParent (
    parentId As String
)
public:
void SetParent(
    String^ parentId
)
public:
void SetParent(
    String^ parentId
)
member SetParent :
        parentId : string -> unit
member SetParent :
        parentId : string -> unit

Parameters

parentId
Type: Online System String
See Also
GoogleDriveRequestBody Class
GoogleDriveRequestBody Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveRequestBody.SetTitle Method

GoogleDriveRequestBody SetTitle Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetTitle(
    string title
)
public void SetTitle(
    string title
)
Public Sub SetTitle (
    title As String
)
Public Sub SetTitle (
    title As String
)
public:
void SetTitle(
    String^ title
)
public:
void SetTitle(
    String^ title
)
member SetTitle :
        title : string -> unit
member SetTitle :
        title : string -> unit

Parameters

title
Type: Online System String
See Also
GoogleDriveRequestBody Class
GoogleDriveRequestBody Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveRequestBody Properties

GoogleDriveRequestBody Properties NFX Class Library

The GoogleDriveRequestBody type exposes the following members.
Properties
 | Name | Description
Public property | Online Comparer | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Online Count | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Online Item | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Online Keys | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Online Values | (Inherited from Online Dictionary Online String, Online Object .)
Back to Top
See Also
GoogleDriveRequestBody Class
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveSession Class

GoogleDriveSession Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.IO.FileSystem FileSystemSession
NFX.IO.FileSystem.GoogleDrive.V2 GoogleDriveSession

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GoogleDriveSession : FileSystemSession
public class GoogleDriveSession : FileSystemSession
Public Class GoogleDriveSession
    Inherits FileSystemSession
Public Class GoogleDriveSession
    Inherits FileSystemSession
public ref class GoogleDriveSession : public FileSystemSession
public ref class GoogleDriveSession : public FileSystemSession
type GoogleDriveSession =
    class
        inherit FileSystemSession
    end
type GoogleDriveSession =
    class
        inherit FileSystemSession
    end
See Also
GoogleDriveSession Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveSession Members

GoogleDriveSession Members NFX Class Library

The GoogleDriveSession type exposes the following members.
Constructors
 | Name | Description
Protected method | GoogleDriveSession | Initializes a new instance of the GoogleDriveSession class
Back to Top
Methods
 | Name | Description
Public method | BeginTransaction | Starts a transaction returning its' transaction handle object, otherwise does nothing (Inherited from FileSystemSession.)
Public method | BeginTransactionAsync | Async version of BeginTransaction (Inherited from FileSystemSession.)
Public method | CommitTransaction | Commits active transaction, does nothing otherwise (Inherited from FileSystemSession.)
Public method | CommitTransactionAsync | Async version of CommitTransaction (Inherited from FileSystemSession.)
Protected method | Destructor | (Inherited from FileSystemSession.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetItemAsync | Async version of [P:Item(string)] (Inherited from FileSystemSession.)
Public method | GetLatestVersionAsync | Async version of [P:LatestVersion] (Inherited from FileSystemSession.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetVersions | Returns specified number of versions going back from the specific version. This call is thread-safe (Inherited from FileSystemSession.)
Public method | GetVersionsAsync | Async version of GetVersions(IFileSystemVersion, Int32) (Inherited from FileSystemSession.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RollbackTransaction | Cancels active transaction changes, does nothing otherwise (Inherited from FileSystemSession.)
Public method | RollbackTransactionAsync | Async version of RollbackTransaction (Inherited from FileSystemSession.)
Public method | SetFileSystemVersionAsync | Async version of [P:Version] (Inherited from FileSystemSession.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | ValidateConnectParams | (Inherited from FileSystemSession.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_FileSystem | (Inherited from FileSystemSession.)
Protected field | m_Handle | (Inherited from FileSystemSession.)
Protected field | m_Items | (Inherited from FileSystemSession.)
Protected field | m_Name | (Inherited from FileSystemSession.)
Protected field | m_TransactionHandle | (Inherited from FileSystemSession.)
Protected field | m_User | (Inherited from FileSystemSession.)
Back to Top
Properties
 | Name | Description
Public property | Client |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | FileSystem | Returns file system instance that this session operates under (Inherited from FileSystemSession.)
Public property | Handle | Returns file system handle for this session (Inherited from FileSystemSession.)
Public property | Item | Navigates to the specified path (Inherited from FileSystemSession.)
Public property | Items | Returns file system items initialized through this session (Inherited from FileSystemSession.)
Public property | LatestVersion | Returns latest version for file systems that support versioning, null otherwise (Inherited from FileSystemSession.)
Public property | Name | Returns session name (Inherited from FileSystemSession.)
Public property | SecurityManager | Returns security manager that services this file system session. This may be useful in cases when file system implements its own permission structure and user directory (Inherited from FileSystemSession.)
Public property | TransactionHandle | Returns transaction object if transaction has been started or null (Inherited from FileSystemSession.)
Public property | UniqueSequenceProvider | Returns unique sequence provider for the system or null if it is not supported (Inherited from FileSystemSession.)
Public property | User | Returns user that this file system session is for (Inherited from FileSystemSession.)
Public property | Version | Gets/sets version of the file system that this session works against (a changeset that session "sees") (Inherited from FileSystemSession.)
Back to Top
See Also
GoogleDriveSession Class
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveSession Constructor

GoogleDriveSession Constructor NFX Class Library

Initializes a new instance of the GoogleDriveSession class

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal GoogleDriveSession(
    GoogleDriveFileSystem fs,
    IFileSystemHandle handle,
    GoogleDriveParameters cParams
)
protected internal GoogleDriveSession(
    GoogleDriveFileSystem fs,
    IFileSystemHandle handle,
    GoogleDriveParameters cParams
)
Protected Friend Sub New (
    fs As GoogleDriveFileSystem,
    handle As IFileSystemHandle,
    cParams As GoogleDriveParameters
)
Protected Friend Sub New (
    fs As GoogleDriveFileSystem,
    handle As IFileSystemHandle,
    cParams As GoogleDriveParameters
)
protected public:
GoogleDriveSession(
    GoogleDriveFileSystem^ fs,
    IFileSystemHandle^ handle,
    GoogleDriveParameters^ cParams
)
protected public:
GoogleDriveSession(
    GoogleDriveFileSystem^ fs,
    IFileSystemHandle^ handle,
    GoogleDriveParameters^ cParams
)
new :
        fs : GoogleDriveFileSystem *
        handle : IFileSystemHandle *
        cParams : GoogleDriveParameters -> GoogleDriveSession
new :
        fs : GoogleDriveFileSystem *
        handle : IFileSystemHandle *
        cParams : GoogleDriveParameters -> GoogleDriveSession

Parameters

fs
Type: NFX.IO.FileSystem.GoogleDrive.V2 GoogleDriveFileSystem
handle
Type: NFX.IO.FileSystem IFileSystemHandle
cParams
Type: NFX.IO.FileSystem.GoogleDrive GoogleDriveParameters
See Also
GoogleDriveSession Class
GoogleDriveSession Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveSession Fields

GoogleDriveSession Fields NFX Class Library

The GoogleDriveSession type exposes the following members.
Fields
 | Name | Description
Protected field | m_FileSystem | (Inherited from FileSystemSession.)
Protected field | m_Handle | (Inherited from FileSystemSession.)
Protected field | m_Items | (Inherited from FileSystemSession.)
Protected field | m_Name | (Inherited from FileSystemSession.)
Protected field | m_TransactionHandle | (Inherited from FileSystemSession.)
Protected field | m_User | (Inherited from FileSystemSession.)
Back to Top
See Also
GoogleDriveSession Class
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveSession Methods

GoogleDriveSession Methods NFX Class Library

The GoogleDriveSession type exposes the following members.
Methods
 | Name | Description
Public method | BeginTransaction | Starts a transaction returning its' transaction handle object, otherwise does nothing (Inherited from FileSystemSession.)
Public method | BeginTransactionAsync | Async version of BeginTransaction (Inherited from FileSystemSession.)
Public method | CommitTransaction | Commits active transaction, does nothing otherwise (Inherited from FileSystemSession.)
Public method | CommitTransactionAsync | Async version of CommitTransaction (Inherited from FileSystemSession.)
Protected method | Destructor | (Inherited from FileSystemSession.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetItemAsync | Async version of [P:Item(string)] (Inherited from FileSystemSession.)
Public method | GetLatestVersionAsync | Async version of [P:LatestVersion] (Inherited from FileSystemSession.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetVersions | Returns specified number of versions going back from the specific version. This call is thread-safe (Inherited from FileSystemSession.)
Public method | GetVersionsAsync | Async version of GetVersions(IFileSystemVersion, Int32) (Inherited from FileSystemSession.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RollbackTransaction | Cancels active transaction changes, does nothing otherwise (Inherited from FileSystemSession.)
Public method | RollbackTransactionAsync | Async version of RollbackTransaction (Inherited from FileSystemSession.)
Public method | SetFileSystemVersionAsync | Async version of [P:Version] (Inherited from FileSystemSession.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | ValidateConnectParams | (Inherited from FileSystemSession.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GoogleDriveSession Class
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveSession Properties

GoogleDriveSession Properties NFX Class Library

The GoogleDriveSession type exposes the following members.
Properties
 | Name | Description
Public property | Client |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | FileSystem | Returns file system instance that this session operates under (Inherited from FileSystemSession.)
Public property | Handle | Returns file system handle for this session (Inherited from FileSystemSession.)
Public property | Item | Navigates to the specified path (Inherited from FileSystemSession.)
Public property | Items | Returns file system items initialized through this session (Inherited from FileSystemSession.)
Public property | LatestVersion | Returns latest version for file systems that support versioning, null otherwise (Inherited from FileSystemSession.)
Public property | Name | Returns session name (Inherited from FileSystemSession.)
Public property | SecurityManager | Returns security manager that services this file system session. This may be useful in cases when file system implements its own permission structure and user directory (Inherited from FileSystemSession.)
Public property | TransactionHandle | Returns transaction object if transaction has been started or null (Inherited from FileSystemSession.)
Public property | UniqueSequenceProvider | Returns unique sequence provider for the system or null if it is not supported (Inherited from FileSystemSession.)
Public property | User | Returns user that this file system session is for (Inherited from FileSystemSession.)
Public property | Version | Gets/sets version of the file system that this session works against (a changeset that session "sees") (Inherited from FileSystemSession.)
Back to Top
See Also
GoogleDriveSession Class
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveSession.Client Property

GoogleDriveSession Client Property NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GoogleDriveClient Client { get; private set; }
public GoogleDriveClient Client { get; private set; }
Public Property Client As GoogleDriveClient
    Get
    Private Set
Public Property Client As GoogleDriveClient
    Get
    Private Set
public:
property GoogleDriveClient^ Client {
    GoogleDriveClient^ get ();
    private: void set (GoogleDriveClient^ value);
}
public:
property GoogleDriveClient^ Client {
    GoogleDriveClient^ get ();
    private: void set (GoogleDriveClient^ value);
}
member Client : GoogleDriveClient with get, private set
member Client : GoogleDriveClient with get, private set

Property Value

Type: GoogleDriveClient
See Also
GoogleDriveSession Class
GoogleDriveSession Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveStream Class

GoogleDriveStream Class NFX Class Library

Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.IO Stream
NFX.IO.FileSystem FileSystemStream
NFX.IO.FileSystem.GoogleDrive.V2 GoogleDriveStream

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class GoogleDriveStream : FileSystemStream
public class GoogleDriveStream : FileSystemStream
Public Class GoogleDriveStream
    Inherits FileSystemStream
Public Class GoogleDriveStream
    Inherits FileSystemStream
public ref class GoogleDriveStream : public FileSystemStream
public ref class GoogleDriveStream : public FileSystemStream
type GoogleDriveStream =
    class
        inherit FileSystemStream
    end
type GoogleDriveStream =
    class
        inherit FileSystemStream
    end
See Also
GoogleDriveStream Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveStream Members

GoogleDriveStream Members NFX Class Library

The GoogleDriveStream type exposes the following members.
Constructors
 | Name | Description
Public method | GoogleDriveStream | Initializes a new instance of the GoogleDriveStream class
Back to Top
Methods
 | Name | Description
Public method | Online BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Online Stream.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Protected method | Online CreateWaitHandle | Obsolete. Allocates a Online WaitHandle object. (Inherited from Online Stream.)
Public method | Online Dispose | Releases all resources used by the Online Stream. (Inherited from Online Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the GoogleDriveStream and optionally releases the managed resources (Overrides FileSystemStream Dispose(Boolean).)
Protected method | DoFlush | (Overrides FileSystemStream DoFlush .)
Protected method | DoGetLength | (Overrides FileSystemStream DoGetLength .)
Protected method | DoGetPosition | (Overrides FileSystemStream DoGetPosition .)
Protected method | DoRead | (Overrides FileSystemStream DoRead( Byte , Int32, Int32).)
Protected method | DoSeek | (Overrides FileSystemStream DoSeek(Int64, SeekOrigin).)
Protected method | DoSetLength | (Overrides FileSystemStream DoSetLength(Int64).)
Protected method | DoSetPosition | (Overrides FileSystemStream DoSetPosition(Int64).)
Protected method | DoWrite | (Overrides FileSystemStream DoWrite( Byte , Int32, Int32).)
Public method | Online EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Inherited from FileSystemStream.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Online Stream.)
Public method | FlushAsync(CancellationToken) | (Inherited from FileSystemStream.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Online Stream.)
Public method | Read | (Inherited from FileSystemStream.)
Public method | ReadAsync( Byte , Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Online Stream.)
Public method | ReadAsync( Byte , Int32, Int32, CancellationToken) | (Inherited from FileSystemStream.)
Public method | Online ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Online Stream.)
Public method | Seek | (Inherited from FileSystemStream.)
Public method | SetLength | (Inherited from FileSystemStream.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write | (Inherited from FileSystemStream.)
Public method | WriteAsync( Byte , Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Online Stream.)
Public method | WriteAsync( Byte , Int32, Int32, CancellationToken) | (Inherited from FileSystemStream.)
Public method | Online WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Online Stream.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsCharEnumerable | (Defined by IOMiscUtils.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Public Extension Method | ReadBEInt32 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEShort | Reads a short encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUInt64 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUShort | Reads an ushort encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadSLEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadSLEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | WriteBEInt32 | Writes an integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEShort | Writes a short encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUInt64 | Writes an unsigned long integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUShort | Writes an ushort encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteSLEB128(Int64, Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteSLEB128(Int64, Int32 , Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, UInt32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, Int32 , UInt32) | Overloaded. (Defined by LEB128.)
Back to Top
Fields
 | Name | Description
Public field | Item | Item that this stream is for (Inherited from FileSystemStream.)
Back to Top
Properties
 | Name | Description
Public property | CanRead | (Inherited from FileSystemStream.)
Public property | CanSeek | (Inherited from FileSystemStream.)
Public property | Online CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Online Stream.)
Public property | CanWrite | (Inherited from FileSystemStream.)
Public property | Length | (Inherited from FileSystemStream.)
Public property | Position | (Inherited from FileSystemStream.)
Public property | Online ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Online Stream.)
Public property | Online WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Online Stream.)
Back to Top
See Also
GoogleDriveStream Class
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveStream Constructor

GoogleDriveStream Constructor NFX Class Library

Initializes a new instance of the GoogleDriveStream class

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GoogleDriveStream(
    FileSystemFile file,
    Action<FileSystemStream> disposeAction
)
public GoogleDriveStream(
    FileSystemFile file,
    Action<FileSystemStream> disposeAction
)
Public Sub New (
    file As FileSystemFile,
    disposeAction As Action(Of FileSystemStream)
)
Public Sub New (
    file As FileSystemFile,
    disposeAction As Action(Of FileSystemStream)
)
public:
GoogleDriveStream(
    FileSystemFile^ file,
    Action<FileSystemStream^>^ disposeAction
)
public:
GoogleDriveStream(
    FileSystemFile^ file,
    Action<FileSystemStream^>^ disposeAction
)
new :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> GoogleDriveStream
new :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> GoogleDriveStream

Parameters

file
Type: NFX.IO.FileSystem FileSystemFile
disposeAction
Type: Online System Action FileSystemStream
See Also
GoogleDriveStream Class
GoogleDriveStream Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveStream Fields

GoogleDriveStream Fields NFX Class Library

The GoogleDriveStream type exposes the following members.
Fields
 | Name | Description
Public field | Item | Item that this stream is for (Inherited from FileSystemStream.)
Back to Top
See Also
GoogleDriveStream Class
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveStream Methods

GoogleDriveStream Methods NFX Class Library

The GoogleDriveStream type exposes the following members.
Methods
 | Name | Description
Public method | Online BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Online Stream.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Protected method | Online CreateWaitHandle | Obsolete. Allocates a Online WaitHandle object. (Inherited from Online Stream.)
Public method | Online Dispose | Releases all resources used by the Online Stream. (Inherited from Online Stream.)
Protected method | Dispose(Boolean) | (Overrides FileSystemStream Dispose(Boolean).)
Protected method | DoFlush | (Overrides FileSystemStream DoFlush .)
Protected method | DoGetLength | (Overrides FileSystemStream DoGetLength .)
Protected method | DoGetPosition | (Overrides FileSystemStream DoGetPosition .)
Protected method | DoRead | (Overrides FileSystemStream DoRead( Byte , Int32, Int32).)
Protected method | DoSeek | (Overrides FileSystemStream DoSeek(Int64, SeekOrigin).)
Protected method | DoSetLength | (Overrides FileSystemStream DoSetLength(Int64).)
Protected method | DoSetPosition | (Overrides FileSystemStream DoSetPosition(Int64).)
Protected method | DoWrite | (Overrides FileSystemStream DoWrite( Byte , Int32, Int32).)
Public method | Online EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Inherited from FileSystemStream.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Online Stream.)
Public method | FlushAsync(CancellationToken) | (Inherited from FileSystemStream.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Online Stream.)
Public method | Read | (Inherited from FileSystemStream.)
Public method | ReadAsync( Byte , Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Online Stream.)
Public method | ReadAsync( Byte , Int32, Int32, CancellationToken) | (Inherited from FileSystemStream.)
Public method | Online ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Online Stream.)
Public method | Seek | (Inherited from FileSystemStream.)
Public method | SetLength | (Inherited from FileSystemStream.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write | (Inherited from FileSystemStream.)
Public method | WriteAsync( Byte , Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Online Stream.)
Public method | WriteAsync( Byte , Int32, Int32, CancellationToken) | (Inherited from FileSystemStream.)
Public method | Online WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Online Stream.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsCharEnumerable | (Defined by IOMiscUtils.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Public Extension Method | ReadBEInt32 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEShort | Reads a short encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUInt64 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUShort | Reads an ushort encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadSLEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadSLEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | WriteBEInt32 | Writes an integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEShort | Writes a short encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUInt64 | Writes an unsigned long integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUShort | Writes an ushort encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteSLEB128(Int64, Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteSLEB128(Int64, Int32 , Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, UInt32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, Int32 , UInt32) | Overloaded. (Defined by LEB128.)
Back to Top
See Also
GoogleDriveStream Class
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveStream.Dispose Method

GoogleDriveStream Dispose Method NFX Class Library

Overload List
 | Name | Description
Public method | Online Dispose | Releases all resources used by the Online Stream. (Inherited from Online Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the GoogleDriveStream and optionally releases the managed resources (Overrides FileSystemStream Dispose(Boolean).)
Back to Top
See Also
GoogleDriveStream Class
GoogleDriveStream Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveStream.Dispose Method (Boolean)

GoogleDriveStream Dispose Method (Boolean) NFX Class Library

Releases the unmanaged resources used by the GoogleDriveStream and optionally releases the managed resources

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
GoogleDriveStream Class
GoogleDriveStream Members
Dispose Overload
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveStream.DoFlush Method

GoogleDriveStream DoFlush Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoFlush()
protected override void DoFlush()
Protected Overrides Sub DoFlush
Protected Overrides Sub DoFlush
protected:
virtual void DoFlush() override
protected:
virtual void DoFlush() override
abstract DoFlush : unit -> unit
override DoFlush : unit -> unit
abstract DoFlush : unit -> unit
override DoFlush : unit -> unit
See Also
GoogleDriveStream Class
GoogleDriveStream Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveStream.DoGetLength Method

GoogleDriveStream DoGetLength Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override long DoGetLength()
protected override long DoGetLength()
Protected Overrides Function DoGetLength As Long
Protected Overrides Function DoGetLength As Long
protected:
virtual long long DoGetLength() override
protected:
virtual long long DoGetLength() override
abstract DoGetLength : unit -> int64
override DoGetLength : unit -> int64
abstract DoGetLength : unit -> int64
override DoGetLength : unit -> int64

Return Value

Type: Online Int64
See Also
GoogleDriveStream Class
GoogleDriveStream Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveStream.DoGetPosition Method

GoogleDriveStream DoGetPosition Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override long DoGetPosition()
protected override long DoGetPosition()
Protected Overrides Function DoGetPosition As Long
Protected Overrides Function DoGetPosition As Long
protected:
virtual long long DoGetPosition() override
protected:
virtual long long DoGetPosition() override
abstract DoGetPosition : unit -> int64
override DoGetPosition : unit -> int64
abstract DoGetPosition : unit -> int64
override DoGetPosition : unit -> int64

Return Value

Type: Online Int64
See Also
GoogleDriveStream Class
GoogleDriveStream Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveStream.DoRead Method

GoogleDriveStream DoRead Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override int DoRead(
    byte[] buffer,
    int offset,
    int count
)
protected override int DoRead(
    byte[] buffer,
    int offset,
    int count
)
Protected Overrides Function DoRead (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
Protected Overrides Function DoRead (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
protected:
virtual int DoRead(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
protected:
virtual int DoRead(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract DoRead :
        buffer : byte[] *
        offset : int *
        count : int -> int
override DoRead :
        buffer : byte[] *
        offset : int *
        count : int -> int
abstract DoRead :
        buffer : byte[] *
        offset : int *
        count : int -> int
override DoRead :
        buffer : byte[] *
        offset : int *
        count : int -> int

Parameters

buffer
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32

Return Value

Type: Online Int32
See Also
GoogleDriveStream Class
GoogleDriveStream Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveStream.DoSeek Method

GoogleDriveStream DoSeek Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override long DoSeek(
    long offset,
    SeekOrigin origin
)
protected override long DoSeek(
    long offset,
    SeekOrigin origin
)
Protected Overrides Function DoSeek (
    offset As Long,
    origin As SeekOrigin
) As Long
Protected Overrides Function DoSeek (
    offset As Long,
    origin As SeekOrigin
) As Long
protected:
virtual long long DoSeek(
    long long offset,
    SeekOrigin origin
) override
protected:
virtual long long DoSeek(
    long long offset,
    SeekOrigin origin
) override
abstract DoSeek :
        offset : int64 *
        origin : SeekOrigin -> int64
override DoSeek :
        offset : int64 *
        origin : SeekOrigin -> int64
abstract DoSeek :
        offset : int64 *
        origin : SeekOrigin -> int64
override DoSeek :
        offset : int64 *
        origin : SeekOrigin -> int64

Parameters

offset
Type: Online System Int64
origin
Type: Online System.IO SeekOrigin

Return Value

Type: Online Int64
See Also
GoogleDriveStream Class
GoogleDriveStream Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveStream.DoSetLength Method

GoogleDriveStream DoSetLength Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSetLength(
    long value
)
protected override void DoSetLength(
    long value
)
Protected Overrides Sub DoSetLength (
    value As Long
)
Protected Overrides Sub DoSetLength (
    value As Long
)
protected:
virtual void DoSetLength(
    long long value
) override
protected:
virtual void DoSetLength(
    long long value
) override
abstract DoSetLength :
        value : int64 -> unit
override DoSetLength :
        value : int64 -> unit
abstract DoSetLength :
        value : int64 -> unit
override DoSetLength :
        value : int64 -> unit

Parameters

value
Type: Online System Int64
See Also
GoogleDriveStream Class
GoogleDriveStream Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveStream.DoSetPosition Method

GoogleDriveStream DoSetPosition Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSetPosition(
    long position
)
protected override void DoSetPosition(
    long position
)
Protected Overrides Sub DoSetPosition (
    position As Long
)
Protected Overrides Sub DoSetPosition (
    position As Long
)
protected:
virtual void DoSetPosition(
    long long position
) override
protected:
virtual void DoSetPosition(
    long long position
) override
abstract DoSetPosition :
        position : int64 -> unit
override DoSetPosition :
        position : int64 -> unit
abstract DoSetPosition :
        position : int64 -> unit
override DoSetPosition :
        position : int64 -> unit

Parameters

position
Type: Online System Int64
See Also
GoogleDriveStream Class
GoogleDriveStream Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveStream.DoWrite Method

GoogleDriveStream DoWrite Method NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWrite(
    byte[] buffer,
    int offset,
    int count
)
protected override void DoWrite(
    byte[] buffer,
    int offset,
    int count
)
Protected Overrides Sub DoWrite (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
Protected Overrides Sub DoWrite (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
protected:
virtual void DoWrite(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
protected:
virtual void DoWrite(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract DoWrite :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override DoWrite :
        buffer : byte[] *
        offset : int *
        count : int -> unit
abstract DoWrite :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override DoWrite :
        buffer : byte[] *
        offset : int *
        count : int -> unit

Parameters

buffer
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32
See Also
GoogleDriveStream Class
GoogleDriveStream Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


GoogleDriveStream Properties

GoogleDriveStream Properties NFX Class Library

The GoogleDriveStream type exposes the following members.
Properties
 | Name | Description
Public property | CanRead | (Inherited from FileSystemStream.)
Public property | CanSeek | (Inherited from FileSystemStream.)
Public property | Online CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Online Stream.)
Public property | CanWrite | (Inherited from FileSystemStream.)
Public property | Length | (Inherited from FileSystemStream.)
Public property | Position | (Inherited from FileSystemStream.)
Public property | Online ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Online Stream.)
Public property | Online WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Online Stream.)
Back to Top
See Also
GoogleDriveStream Class
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


Metadata Class

Metadata Class NFX Class Library

Google Drive metadata fields
Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.GoogleDrive.V2 Metadata

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static class Metadata
internal static class Metadata
Friend NotInheritable Class Metadata
Friend NotInheritable Class Metadata
internal ref class Metadata abstract sealed
internal ref class Metadata abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Metadata =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Metadata =  class end
See Also
Metadata Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


Metadata Members

Metadata Members NFX Class Library

The Metadata type exposes the following members.
Fields
Name | Description
ACCESS_TOKEN |
ASSERTION |
CREATED_DATE |
EDITABLE |
FILE_SIZE |
GRANT_TYPE |
ID |
ITEMS |
MIME_TYPE |
MODIFIED_DATE |
PARENTS |
TITLE |
Back to Top
See Also
Metadata Class
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


Metadata Fields

Metadata Fields NFX Class Library

The Metadata type exposes the following members.
Fields
Name | Description
ACCESS_TOKEN |
ASSERTION |
CREATED_DATE |
EDITABLE |
FILE_SIZE |
GRANT_TYPE |
ID |
ITEMS |
MIME_TYPE |
MODIFIED_DATE |
PARENTS |
TITLE |
Back to Top
See Also
Metadata Class
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


Metadata.ACCESS_TOKEN Field

Metadata ACCESS_TOKEN Field NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string ACCESS_TOKEN
public static readonly string ACCESS_TOKEN
Public Shared ReadOnly ACCESS_TOKEN As String
Public Shared ReadOnly ACCESS_TOKEN As String
public:
static initonly String^ ACCESS_TOKEN
public:
static initonly String^ ACCESS_TOKEN
static val ACCESS_TOKEN: string
static val ACCESS_TOKEN: string

Field Value

Type: Online String
See Also
Metadata Class
Metadata Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


Metadata.ASSERTION Field

Metadata ASSERTION Field NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string ASSERTION
public static readonly string ASSERTION
Public Shared ReadOnly ASSERTION As String
Public Shared ReadOnly ASSERTION As String
public:
static initonly String^ ASSERTION
public:
static initonly String^ ASSERTION
static val ASSERTION: string
static val ASSERTION: string

Field Value

Type: Online String
See Also
Metadata Class
Metadata Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


Metadata.CREATED_DATE Field

Metadata CREATED_DATE Field NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string CREATED_DATE
public static readonly string CREATED_DATE
Public Shared ReadOnly CREATED_DATE As String
Public Shared ReadOnly CREATED_DATE As String
public:
static initonly String^ CREATED_DATE
public:
static initonly String^ CREATED_DATE
static val CREATED_DATE: string
static val CREATED_DATE: string

Field Value

Type: Online String
See Also
Metadata Class
Metadata Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


Metadata.EDITABLE Field

Metadata EDITABLE Field NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string EDITABLE
public static readonly string EDITABLE
Public Shared ReadOnly EDITABLE As String
Public Shared ReadOnly EDITABLE As String
public:
static initonly String^ EDITABLE
public:
static initonly String^ EDITABLE
static val EDITABLE: string
static val EDITABLE: string

Field Value

Type: Online String
See Also
Metadata Class
Metadata Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


Metadata.FILE_SIZE Field

Metadata FILE_SIZE Field NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string FILE_SIZE
public static readonly string FILE_SIZE
Public Shared ReadOnly FILE_SIZE As String
Public Shared ReadOnly FILE_SIZE As String
public:
static initonly String^ FILE_SIZE
public:
static initonly String^ FILE_SIZE
static val FILE_SIZE: string
static val FILE_SIZE: string

Field Value

Type: Online String
See Also
Metadata Class
Metadata Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


Metadata.GRANT_TYPE Field

Metadata GRANT_TYPE Field NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string GRANT_TYPE
public static readonly string GRANT_TYPE
Public Shared ReadOnly GRANT_TYPE As String
Public Shared ReadOnly GRANT_TYPE As String
public:
static initonly String^ GRANT_TYPE
public:
static initonly String^ GRANT_TYPE
static val GRANT_TYPE: string
static val GRANT_TYPE: string

Field Value

Type: Online String
See Also
Metadata Class
Metadata Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


Metadata.ID Field

Metadata ID Field NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string ID
public static readonly string ID
Public Shared ReadOnly ID As String
Public Shared ReadOnly ID As String
public:
static initonly String^ ID
public:
static initonly String^ ID
static val ID: string
static val ID: string

Field Value

Type: Online String
See Also
Metadata Class
Metadata Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


Metadata.ITEMS Field

Metadata ITEMS Field NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string ITEMS
public static readonly string ITEMS
Public Shared ReadOnly ITEMS As String
Public Shared ReadOnly ITEMS As String
public:
static initonly String^ ITEMS
public:
static initonly String^ ITEMS
static val ITEMS: string
static val ITEMS: string

Field Value

Type: Online String
See Also
Metadata Class
Metadata Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


Metadata.MIME_TYPE Field

Metadata MIME_TYPE Field NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string MIME_TYPE
public static readonly string MIME_TYPE
Public Shared ReadOnly MIME_TYPE As String
Public Shared ReadOnly MIME_TYPE As String
public:
static initonly String^ MIME_TYPE
public:
static initonly String^ MIME_TYPE
static val MIME_TYPE: string
static val MIME_TYPE: string

Field Value

Type: Online String
See Also
Metadata Class
Metadata Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


Metadata.MODIFIED_DATE Field

Metadata MODIFIED_DATE Field NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string MODIFIED_DATE
public static readonly string MODIFIED_DATE
Public Shared ReadOnly MODIFIED_DATE As String
Public Shared ReadOnly MODIFIED_DATE As String
public:
static initonly String^ MODIFIED_DATE
public:
static initonly String^ MODIFIED_DATE
static val MODIFIED_DATE: string
static val MODIFIED_DATE: string

Field Value

Type: Online String
See Also
Metadata Class
Metadata Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


Metadata.PARENTS Field

Metadata PARENTS Field NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string PARENTS
public static readonly string PARENTS
Public Shared ReadOnly PARENTS As String
Public Shared ReadOnly PARENTS As String
public:
static initonly String^ PARENTS
public:
static initonly String^ PARENTS
static val PARENTS: string
static val PARENTS: string

Field Value

Type: Online String
See Also
Metadata Class
Metadata Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


Metadata.TITLE Field

Metadata TITLE Field NFX Class Library

Namespace: NFX.IO.FileSystem.GoogleDrive.V2
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string TITLE
public static readonly string TITLE
Public Shared ReadOnly TITLE As String
Public Shared ReadOnly TITLE As String
public:
static initonly String^ TITLE
public:
static initonly String^ TITLE
static val TITLE: string
static val TITLE: string

Field Value

Type: Online String
See Also
Metadata Class
Metadata Members
NFX.IO.FileSystem.GoogleDrive.V2 Namespace


NFX.IO.FileSystem.Local Namespace

NFX.IO.FileSystem.Local Namespace NFX Class Library

Provides local file system implementation
Classes
 | Class | Description
Public class | LocalFileSystem | Implements NFX.IO.FileSystem support around local machine file system. This is needed for components that may need to work with various file systems i.e. Apache HDFS or Aum Cluster File System (ACFS). This particular implementation uses traditional System.IO.* and does not support transactions, versioning, metadata and NFX security
Protected class | LocalFileSystem FSH |
Public class | LocalFileSystemCapabilities | Describes local file system capabilities
Protected class | LocalFileSystemStream |


LocalFileSystem Class

LocalFileSystem Class NFX Class Library

Implements NFX.IO.FileSystem support around local machine file system. This is needed for components that may need to work with various file systems i.e. Apache HDFS or Aum Cluster File System (ACFS). This particular implementation uses traditional System.IO.* and does not support transactions, versioning, metadata and NFX security
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.IO.FileSystem FileSystem
NFX.IO.FileSystem.Local LocalFileSystem

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class LocalFileSystem : FileSystem
public sealed class LocalFileSystem : FileSystem
Public NotInheritable Class LocalFileSystem
    Inherits FileSystem
Public NotInheritable Class LocalFileSystem
    Inherits FileSystem
public ref class LocalFileSystem sealed : public FileSystem
public ref class LocalFileSystem sealed : public FileSystem
[<SealedAttribute>]
type LocalFileSystem =
    class
        inherit FileSystem
    end
[<SealedAttribute>]
type LocalFileSystem =
    class
        inherit FileSystem
    end
See Also
LocalFileSystem Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem Members

LocalFileSystem Members NFX Class Library

The LocalFileSystem type exposes the following members.
Constructors
 | Name | Description
Public method | LocalFileSystem | Initializes a new instance of the LocalFileSystem class
Public method | LocalFileSystem(String, IConfigSectionNode) | Initializes a new instance of the LocalFileSystem class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | CombinePaths | Combines two or more path segments joining them using primary file system path separator. This method is thread-safe (Inherited from FileSystem.)
Public method | Configure | Configures file system. This method is a part of lifecycle management and is intended to be called only by creating thread (not thread-safe) (Inherited from FileSystem.)
Protected method | Destructor | (Inherited from FileSystem.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoBeginTransaction | Override in particular file systems that support transactions to begin transaction in specified session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoBeginTransactionAsync | Async version of DoBeginTransaction(FileSystemSession). This base/default implementation just synchronously calls DoBeginTransaction(FileSystemSession) and returns already completed Task with result returned by DoBeginTransaction(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoCheckCanChange | Override in particular file systems to see if item can change, i.e. for file systems that support versioning throw exception if item is in session which "looks" at a sealed/closed version and can not change. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoCheckCanChangeAsync | Async version of DoCheckCanChange(FileSystemSessionItem). This base/default implementation just synchronously calls DoCheckCanChange(FileSystemSessionItem) and returns already completed Task with result returned by DoCheckCanChange(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoCommitTransaction | Override in particular file systems that support transactions to commit transaction in specified session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoCommitTransactionAsync | Async version of DoCommitTransaction(FileSystemSession). This base/default implementation just synchronously calls DoCommitTransaction(FileSystemSession) and returns already completed Task with result returned by DoCommitTransaction(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoConfigure | Override to perform custom configuration (Inherited from FileSystem.)
Protected method | DoCreateDirectory | (Overrides FileSystem DoCreateDirectory(FileSystemDirectory, String).)
Protected method | DoCreateDirectoryAsync | Async version of DoCreateDirectory(FileSystemDirectory, String). This base/default implementation just synchronously calls DoCreateDirectory(FileSystemDirectory, String) and returns already completed Task with result returned by DoCreateDirectory(FileSystemDirectory, String) (Inherited from FileSystem.)
Protected method | DoCreateFile(FileSystemDirectory, String, Int32) | (Overrides FileSystem DoCreateFile(FileSystemDirectory, String, Int32).)
Protected method | DoCreateFile(FileSystemDirectory, String, String, Boolean) | (Overrides FileSystem DoCreateFile(FileSystemDirectory, String, String, Boolean).)
Protected method | DoCreateFileAsync(FileSystemDirectory, String, Int32) | Async version of DoCreateFile(FileSystemDirectory, String, Int32). This base/default implementation just synchronously calls DoCreateFile(FileSystemDirectory, String, Int32) and returns already completed Task with result returned by DoCreateFile(FileSystemDirectory, String, Int32) (Inherited from FileSystem.)
Protected method | DoCreateFileAsync(FileSystemDirectory, String, String, Boolean) | Async version of DoCreateFile(FileSystemDirectory, String, String, Boolean). This base/default implementation just synchronously calls DoCreateFile(FileSystemDirectory, String, String, Boolean) and returns already completed Task with result returned by DoCreateFile(FileSystemDirectory, String, String, Boolean) (Inherited from FileSystem.)
Protected method | DoDeleteItem | (Overrides FileSystem DoDeleteItem(FileSystemSessionItem).)
Protected method | DoDeleteItemAsync | Async version of DoDeleteItem(FileSystemSessionItem). This base/default implementation just synchronously calls DoDeleteItem(FileSystemSessionItem) and returns already completed Task with result returned by DoDeleteItem(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoDirectoryDeepCopyAsync | Implements asynchronous deep copy of folders where destination folder may belong to a different file system. The specifics of implementation may be dictated by particular file systems, i.e.: asynchronous strategies for getting file lists may depend on the particular system. (Inherited from FileSystem.)
Protected method | DoFlushAsync | (Inherited from FileSystem.)
Protected method | DoGetCreationTimestamp | (Overrides FileSystem DoGetCreationTimestamp(FileSystemSessionItem).)
Protected method | DoGetCreationUser | Override in particular file systems to get user who created item. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetCreationUserAsync | Async version of DoGetCreationUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetCreationUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetCreationUser(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetFileNames | (Overrides FileSystem DoGetFileNames(FileSystemDirectory, Boolean).)
Protected method | DoGetFileNamesAsync | Async version of DoGetFileNames(FileSystemDirectory, Boolean). This base/default implementation just synchronously calls DoGetFileNames(FileSystemDirectory, Boolean) and returns already completed Task with result returned by DoGetFileNames(FileSystemDirectory, Boolean) (Inherited from FileSystem.)
Protected method | DoGetFileStream | (Overrides FileSystem DoGetFileStream(FileSystemFile, Action FileSystemStream ).)
Protected method | DoGetFileStreamAsync | Async version of DoGetFileStream(FileSystemFile, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetFileStream(FileSystemFile, Action FileSystemStream ) and returns already completed Task with result returned by DoGetFileStream(FileSystemFile, Action FileSystemStream ) (Inherited from FileSystem.)
Protected method | DoGetItemSize | (Overrides FileSystem DoGetItemSize(FileSystemSessionItem).)
Protected method | DoGetItemSizeAsync | Async version of DoGetItemSize(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetItemSize(FileSystemSessionItem) and returns already completed Task with result returned by DoGetItemSize(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetLastAccessTimestamp | (Overrides FileSystem DoGetLastAccessTimestamp(FileSystemSessionItem).)
Protected method | DoGetLastAccessUser | Override in particular file systems to get user who was the last user accessing the item. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetLastAccessUserAsync | Async version of DoGetLastAccessUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetLastAccessUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetLastAccessUser(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetLatestVersion | Override in particular file systems that support versioning to get latest version object that this session can work with. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetLatestVersionAsync | Async version of DoGetLatestVersion(FileSystemSession). This base/default implementation just synchronously calls DoGetLatestVersion(FileSystemSession) and returns already completed Task with result returned by DoGetLatestVersion(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoGetMetadataStream | (Overrides FileSystem DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ).)
Protected method | DoGetMetadataStreamAsync | Async version of DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ) and returns already completed Task with result returned by DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ) (Inherited from FileSystem.)
Protected method | DoGetModificationTimestamp | (Overrides FileSystem DoGetModificationTimestamp(FileSystemSessionItem).)
Protected method | DoGetModificationUser | Override in particular file systems to get user who was the last user modifying the item. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetModificationUserAsync | Async version of DoGetModificationUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetModificationUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetModificationUser(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetPermissionsStream | (Overrides FileSystem DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ).)
Protected method | DoGetPermissionsStreamAsync | Async version of DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ) and returns already completed Task with result returned by DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ) (Inherited from FileSystem.)
Protected method | DoGetReadOnly | (Overrides FileSystem DoGetReadOnly(FileSystemSessionItem).)
Protected method | DoGetSubDirectoryNames | (Overrides FileSystem DoGetSubDirectoryNames(FileSystemDirectory, Boolean).)
Protected method | DoGetSubDirectoryNamesAsync | Async version of DoGetSubDirectoryNames(FileSystemDirectory, Boolean). This base/default implementation just synchronously calls DoGetSubDirectoryNames(FileSystemDirectory, Boolean) and returns already completed Task with result returned by DoGetSubDirectoryNames(FileSystemDirectory, Boolean) (Inherited from FileSystem.)
Protected method | DoGetVersion | Override in particular file systems that support versioning to get version object for session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetVersionAsync | Async version of DoGetVersion(FileSystemSession). This base/default implementation just synchronously calls DoGetVersion(FileSystemSession) and returns already completed Task with result returned by DoGetVersion(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoNavigate | (Overrides FileSystem DoNavigate(FileSystemSession, String).)
Protected method | DoNavigateAsync | Async version of DoNavigate(FileSystemSession, String). This base/default implementation just synchronously calls DoNavigate(FileSystemSession, String) and returns already completed Task with result returned by DoNavigate(FileSystemSession, String) (Inherited from FileSystem.)
Protected method | DoReadAsync | (Inherited from FileSystem.)
Protected method | DoRefresh | (Overrides FileSystem DoRefresh(FileSystemSessionItem).)
Protected method | DoRefreshAsync | Async version of DoRefreshAsync(FileSystemSessionItem). This base/default implementation just synchronously calls DoRefreshAsync(FileSystemSessionItem) and returns already completed Task with result returned by DoRefreshAsync(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoRenameItem | (Overrides FileSystem DoRenameItem(FileSystemSessionItem, String).)
Protected method | DoRenameItemAsync | Async version of DoRenameItem(FileSystemSessionItem, String). This base/default implementation just synchronously calls DoRenameItem(FileSystemSessionItem, String) and returns already completed Task with result returned by DoRenameItem(FileSystemSessionItem, String) (Inherited from FileSystem.)
Protected method | DoRollbackTransaction | Override in particular file systems that support transactions to rollback transaction in specified session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoRollbackTransactionAsync | Async version of DoRollbackTransaction(FileSystemSession). This base/default implementation just synchronously calls DoRollbackTransaction(FileSystemSession) and returns already completed Task with result returned by DoRollbackTransaction(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoSetCreationTimestamp | (Overrides FileSystem DoSetCreationTimestamp(FileSystemSessionItem, DateTime).)
Protected method | DoSetCreationTimestampAsync | Async version of DoSetCreationTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetCreationTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetCreationTimestamp(FileSystemSessionItem, DateTime) (Inherited from FileSystem.)
Protected method | DoSetLastAccessTimestamp | (Overrides FileSystem DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime).)
Protected method | DoSetLastAccessTimestampAsync | Async version of DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime) (Inherited from FileSystem.)
Protected method | DoSetModificationTimestamp | (Overrides FileSystem DoSetModificationTimestamp(FileSystemSessionItem, DateTime).)
Protected method | DoSetModificationTimestampAsync | Async version of DoSetModificationTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetModificationTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetModificationTimestamp(FileSystemSessionItem, DateTime) (Inherited from FileSystem.)
Protected method | DoSetReadOnly | (Overrides FileSystem DoSetReadOnly(FileSystemSessionItem, Boolean).)
Protected method | DoSetReadOnlyAsync | Async version of DoSetReadOnly(FileSystemSessionItem, Boolean). This base/default implementation just synchronously calls DoSetReadOnly(FileSystemSessionItem, Boolean) and returns already completed Task with result returned by DoSetReadOnly(FileSystemSessionItem, Boolean) (Inherited from FileSystem.)
Protected method | DoSetVersion | Override in particular file systems that support versioning to set seesion to specific version. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoSetVersionAsync | Async version of DoSetVersion(FileSystemSession, IFileSystemVersion). This base/default implementation just synchronously calls DoSetVersion(FileSystemSession, IFileSystemVersion) and returns already completed Task with result returned by DoSetVersion(FileSystemSession, IFileSystemVersion) (Inherited from FileSystem.)
Protected method | DoWriteAsync | (Inherited from FileSystem.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeSessionConfigParams | (Inherited from FileSystem.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | StartSession | (Overrides FileSystem StartSession(FileSystemSessionConnectParams).)
Public method | ToString | (Inherited from FileSystem.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Name | (Inherited from FileSystem.)
Protected field | m_Sessions | (Inherited from FileSystem.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | (Overrides ApplicationComponent ComponentCommonName.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Protected property | DefaultSessionConnectParams | (Inherited from FileSystem.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | GeneralCapabilities | (Overrides FileSystem GeneralCapabilities.)
Public property | InstanceCapabilities | (Overrides FileSystem InstanceCapabilities.)
Public property | Name | Provides name for file system instance (Inherited from FileSystem.)
Public property | Sessions | Returns a list of sessions. This accessor is thread-safe (Inherited from FileSystem.)
Back to Top
See Also
LocalFileSystem Class
NFX.IO.FileSystem.Local Namespace


LocalFileSystem Constructor

LocalFileSystem Constructor NFX Class Library

Overload List
 | Name | Description
Public method | LocalFileSystem | Initializes a new instance of the LocalFileSystem class
Public method | LocalFileSystem(String, IConfigSectionNode) | Initializes a new instance of the LocalFileSystem class
Back to Top
See Also
LocalFileSystem Class
LocalFileSystem Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem Constructor

LocalFileSystem Constructor NFX Class Library

Initializes a new instance of the LocalFileSystem class

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LocalFileSystem()
public LocalFileSystem()
Public Sub New
Public Sub New
public:
LocalFileSystem()
public:
LocalFileSystem()
new : unit -> LocalFileSystem
new : unit -> LocalFileSystem
See Also
LocalFileSystem Class
LocalFileSystem Members
LocalFileSystem Overload
NFX.IO.FileSystem.Local Namespace


LocalFileSystem Constructor (String, IConfigSectionNode)

LocalFileSystem Constructor (String, IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LocalFileSystem class

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LocalFileSystem(
    string name,
    IConfigSectionNode node = null
)
public LocalFileSystem(
    string name,
    IConfigSectionNode node = null
)
Public Sub New (
    name As String,
    Optional node As IConfigSectionNode = Nothing
)
Public Sub New (
    name As String,
    Optional node As IConfigSectionNode = Nothing
)
public:
LocalFileSystem(
    String^ name,
    IConfigSectionNode^ node = nullptr
)
public:
LocalFileSystem(
    String^ name,
    IConfigSectionNode^ node = nullptr
)
new :
        name : string *
        ?node : IConfigSectionNode
(* Defaults:
        let _node = defaultArg node null
*)
-> LocalFileSystem
new :
        name : string *
        ?node : IConfigSectionNode
(* Defaults:
        let _node = defaultArg node null
*)
-> LocalFileSystem

Parameters

name
Type: Online System String
node (Optional)
Type: NFX.Environment IConfigSectionNode
See Also
LocalFileSystem Class
LocalFileSystem Members
LocalFileSystem Overload
NFX.IO.FileSystem.Local Namespace


LocalFileSystem Fields

LocalFileSystem Fields NFX Class Library

The LocalFileSystem type exposes the following members.
Fields
 | Name | Description
Protected field | m_Name | (Inherited from FileSystem.)
Protected field | m_Sessions | (Inherited from FileSystem.)
Back to Top
See Also
LocalFileSystem Class
NFX.IO.FileSystem.Local Namespace


LocalFileSystem Methods

LocalFileSystem Methods NFX Class Library

The LocalFileSystem type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | CombinePaths | Combines two or more path segments joining them using primary file system path separator. This method is thread-safe (Inherited from FileSystem.)
Public method | Configure | Configures file system. This method is a part of lifecycle management and is intended to be called only by creating thread (not thread-safe) (Inherited from FileSystem.)
Protected method | Destructor | (Inherited from FileSystem.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoBeginTransaction | Override in particular file systems that support transactions to begin transaction in specified session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoBeginTransactionAsync | Async version of DoBeginTransaction(FileSystemSession). This base/default implementation just synchronously calls DoBeginTransaction(FileSystemSession) and returns already completed Task with result returned by DoBeginTransaction(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoCheckCanChange | Override in particular file systems to see if item can change, i.e. for file systems that support versioning throw exception if item is in session which "looks" at a sealed/closed version and can not change. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoCheckCanChangeAsync | Async version of DoCheckCanChange(FileSystemSessionItem). This base/default implementation just synchronously calls DoCheckCanChange(FileSystemSessionItem) and returns already completed Task with result returned by DoCheckCanChange(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoCommitTransaction | Override in particular file systems that support transactions to commit transaction in specified session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoCommitTransactionAsync | Async version of DoCommitTransaction(FileSystemSession). This base/default implementation just synchronously calls DoCommitTransaction(FileSystemSession) and returns already completed Task with result returned by DoCommitTransaction(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoConfigure | Override to perform custom configuration (Inherited from FileSystem.)
Protected method | DoCreateDirectory | (Overrides FileSystem DoCreateDirectory(FileSystemDirectory, String).)
Protected method | DoCreateDirectoryAsync | Async version of DoCreateDirectory(FileSystemDirectory, String). This base/default implementation just synchronously calls DoCreateDirectory(FileSystemDirectory, String) and returns already completed Task with result returned by DoCreateDirectory(FileSystemDirectory, String) (Inherited from FileSystem.)
Protected method | DoCreateFile(FileSystemDirectory, String, Int32) | (Overrides FileSystem DoCreateFile(FileSystemDirectory, String, Int32).)
Protected method | DoCreateFile(FileSystemDirectory, String, String, Boolean) | (Overrides FileSystem DoCreateFile(FileSystemDirectory, String, String, Boolean).)
Protected method | DoCreateFileAsync(FileSystemDirectory, String, Int32) | Async version of DoCreateFile(FileSystemDirectory, String, Int32). This base/default implementation just synchronously calls DoCreateFile(FileSystemDirectory, String, Int32) and returns already completed Task with result returned by DoCreateFile(FileSystemDirectory, String, Int32) (Inherited from FileSystem.)
Protected method | DoCreateFileAsync(FileSystemDirectory, String, String, Boolean) | Async version of DoCreateFile(FileSystemDirectory, String, String, Boolean). This base/default implementation just synchronously calls DoCreateFile(FileSystemDirectory, String, String, Boolean) and returns already completed Task with result returned by DoCreateFile(FileSystemDirectory, String, String, Boolean) (Inherited from FileSystem.)
Protected method | DoDeleteItem | (Overrides FileSystem DoDeleteItem(FileSystemSessionItem).)
Protected method | DoDeleteItemAsync | Async version of DoDeleteItem(FileSystemSessionItem). This base/default implementation just synchronously calls DoDeleteItem(FileSystemSessionItem) and returns already completed Task with result returned by DoDeleteItem(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoDirectoryDeepCopyAsync | Implements asynchronous deep copy of folders where destination folder may belong to a different file system. The specifics of implementation may be dictated by particular file systems, i.e.: asynchronous strategies for getting file lists may depend on the particular system. (Inherited from FileSystem.)
Protected method | DoFlushAsync | (Inherited from FileSystem.)
Protected method | DoGetCreationTimestamp | (Overrides FileSystem DoGetCreationTimestamp(FileSystemSessionItem).)
Protected method | DoGetCreationUser | Override in particular file systems to get user who created item. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetCreationUserAsync | Async version of DoGetCreationUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetCreationUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetCreationUser(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetFileNames | (Overrides FileSystem DoGetFileNames(FileSystemDirectory, Boolean).)
Protected method | DoGetFileNamesAsync | Async version of DoGetFileNames(FileSystemDirectory, Boolean). This base/default implementation just synchronously calls DoGetFileNames(FileSystemDirectory, Boolean) and returns already completed Task with result returned by DoGetFileNames(FileSystemDirectory, Boolean) (Inherited from FileSystem.)
Protected method | DoGetFileStream | (Overrides FileSystem DoGetFileStream(FileSystemFile, Action FileSystemStream ).)
Protected method | DoGetFileStreamAsync | Async version of DoGetFileStream(FileSystemFile, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetFileStream(FileSystemFile, Action FileSystemStream ) and returns already completed Task with result returned by DoGetFileStream(FileSystemFile, Action FileSystemStream ) (Inherited from FileSystem.)
Protected method | DoGetItemSize | (Overrides FileSystem DoGetItemSize(FileSystemSessionItem).)
Protected method | DoGetItemSizeAsync | Async version of DoGetItemSize(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetItemSize(FileSystemSessionItem) and returns already completed Task with result returned by DoGetItemSize(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetLastAccessTimestamp | (Overrides FileSystem DoGetLastAccessTimestamp(FileSystemSessionItem).)
Protected method | DoGetLastAccessUser | Override in particular file systems to get user who was the last user accessing the item. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetLastAccessUserAsync | Async version of DoGetLastAccessUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetLastAccessUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetLastAccessUser(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetLatestVersion | Override in particular file systems that support versioning to get latest version object that this session can work with. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetLatestVersionAsync | Async version of DoGetLatestVersion(FileSystemSession). This base/default implementation just synchronously calls DoGetLatestVersion(FileSystemSession) and returns already completed Task with result returned by DoGetLatestVersion(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoGetMetadataStream | (Overrides FileSystem DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ).)
Protected method | DoGetMetadataStreamAsync | Async version of DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ) and returns already completed Task with result returned by DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ) (Inherited from FileSystem.)
Protected method | DoGetModificationTimestamp | (Overrides FileSystem DoGetModificationTimestamp(FileSystemSessionItem).)
Protected method | DoGetModificationUser | Override in particular file systems to get user who was the last user modifying the item. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetModificationUserAsync | Async version of DoGetModificationUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetModificationUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetModificationUser(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetPermissionsStream | (Overrides FileSystem DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ).)
Protected method | DoGetPermissionsStreamAsync | Async version of DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ) and returns already completed Task with result returned by DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ) (Inherited from FileSystem.)
Protected method | DoGetReadOnly | (Overrides FileSystem DoGetReadOnly(FileSystemSessionItem).)
Protected method | DoGetSubDirectoryNames | (Overrides FileSystem DoGetSubDirectoryNames(FileSystemDirectory, Boolean).)
Protected method | DoGetSubDirectoryNamesAsync | Async version of DoGetSubDirectoryNames(FileSystemDirectory, Boolean). This base/default implementation just synchronously calls DoGetSubDirectoryNames(FileSystemDirectory, Boolean) and returns already completed Task with result returned by DoGetSubDirectoryNames(FileSystemDirectory, Boolean) (Inherited from FileSystem.)
Protected method | DoGetVersion | Override in particular file systems that support versioning to get version object for session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetVersionAsync | Async version of DoGetVersion(FileSystemSession). This base/default implementation just synchronously calls DoGetVersion(FileSystemSession) and returns already completed Task with result returned by DoGetVersion(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoNavigate | (Overrides FileSystem DoNavigate(FileSystemSession, String).)
Protected method | DoNavigateAsync | Async version of DoNavigate(FileSystemSession, String). This base/default implementation just synchronously calls DoNavigate(FileSystemSession, String) and returns already completed Task with result returned by DoNavigate(FileSystemSession, String) (Inherited from FileSystem.)
Protected method | DoReadAsync | (Inherited from FileSystem.)
Protected method | DoRefresh | (Overrides FileSystem DoRefresh(FileSystemSessionItem).)
Protected method | DoRefreshAsync | Async version of DoRefreshAsync(FileSystemSessionItem). This base/default implementation just synchronously calls DoRefreshAsync(FileSystemSessionItem) and returns already completed Task with result returned by DoRefreshAsync(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoRenameItem | (Overrides FileSystem DoRenameItem(FileSystemSessionItem, String).)
Protected method | DoRenameItemAsync | Async version of DoRenameItem(FileSystemSessionItem, String). This base/default implementation just synchronously calls DoRenameItem(FileSystemSessionItem, String) and returns already completed Task with result returned by DoRenameItem(FileSystemSessionItem, String) (Inherited from FileSystem.)
Protected method | DoRollbackTransaction | Override in particular file systems that support transactions to rollback transaction in specified session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoRollbackTransactionAsync | Async version of DoRollbackTransaction(FileSystemSession). This base/default implementation just synchronously calls DoRollbackTransaction(FileSystemSession) and returns already completed Task with result returned by DoRollbackTransaction(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoSetCreationTimestamp | (Overrides FileSystem DoSetCreationTimestamp(FileSystemSessionItem, DateTime).)
Protected method | DoSetCreationTimestampAsync | Async version of DoSetCreationTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetCreationTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetCreationTimestamp(FileSystemSessionItem, DateTime) (Inherited from FileSystem.)
Protected method | DoSetLastAccessTimestamp | (Overrides FileSystem DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime).)
Protected method | DoSetLastAccessTimestampAsync | Async version of DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime) (Inherited from FileSystem.)
Protected method | DoSetModificationTimestamp | (Overrides FileSystem DoSetModificationTimestamp(FileSystemSessionItem, DateTime).)
Protected method | DoSetModificationTimestampAsync | Async version of DoSetModificationTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetModificationTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetModificationTimestamp(FileSystemSessionItem, DateTime) (Inherited from FileSystem.)
Protected method | DoSetReadOnly | (Overrides FileSystem DoSetReadOnly(FileSystemSessionItem, Boolean).)
Protected method | DoSetReadOnlyAsync | Async version of DoSetReadOnly(FileSystemSessionItem, Boolean). This base/default implementation just synchronously calls DoSetReadOnly(FileSystemSessionItem, Boolean) and returns already completed Task with result returned by DoSetReadOnly(FileSystemSessionItem, Boolean) (Inherited from FileSystem.)
Protected method | DoSetVersion | Override in particular file systems that support versioning to set seesion to specific version. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoSetVersionAsync | Async version of DoSetVersion(FileSystemSession, IFileSystemVersion). This base/default implementation just synchronously calls DoSetVersion(FileSystemSession, IFileSystemVersion) and returns already completed Task with result returned by DoSetVersion(FileSystemSession, IFileSystemVersion) (Inherited from FileSystem.)
Protected method | DoWriteAsync | (Inherited from FileSystem.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeSessionConfigParams | (Inherited from FileSystem.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | StartSession | (Overrides FileSystem StartSession(FileSystemSessionConnectParams).)
Public method | ToString | (Inherited from FileSystem.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LocalFileSystem Class
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.DoCreateDirectory Method

LocalFileSystem DoCreateDirectory Method NFX Class Library

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemDirectory DoCreateDirectory(
    FileSystemDirectory dir,
    string name
)
protected internal override FileSystemDirectory DoCreateDirectory(
    FileSystemDirectory dir,
    string name
)
Protected Friend Overrides Function DoCreateDirectory (
    dir As FileSystemDirectory,
    name As String
) As FileSystemDirectory
Protected Friend Overrides Function DoCreateDirectory (
    dir As FileSystemDirectory,
    name As String
) As FileSystemDirectory
protected public:
virtual FileSystemDirectory^ DoCreateDirectory(
    FileSystemDirectory^ dir,
    String^ name
) override
protected public:
virtual FileSystemDirectory^ DoCreateDirectory(
    FileSystemDirectory^ dir,
    String^ name
) override
abstract DoCreateDirectory :
        dir : FileSystemDirectory *
        name : string -> FileSystemDirectory
override DoCreateDirectory :
        dir : FileSystemDirectory *
        name : string -> FileSystemDirectory
abstract DoCreateDirectory :
        dir : FileSystemDirectory *
        name : string -> FileSystemDirectory
override DoCreateDirectory :
        dir : FileSystemDirectory *
        name : string -> FileSystemDirectory

Parameters

dir
Type: NFX.IO.FileSystem FileSystemDirectory
name
Type: Online System String

Return Value

Type: FileSystemDirectory
See Also
LocalFileSystem Class
LocalFileSystem Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.DoCreateFile Method

LocalFileSystem DoCreateFile Method NFX Class Library

Overload List
 | Name | Description
Protected method | DoCreateFile(FileSystemDirectory, String, Int32) | (Overrides FileSystem DoCreateFile(FileSystemDirectory, String, Int32).)
Protected method | DoCreateFile(FileSystemDirectory, String, String, Boolean) | (Overrides FileSystem DoCreateFile(FileSystemDirectory, String, String, Boolean).)
Back to Top
See Also
LocalFileSystem Class
LocalFileSystem Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.DoCreateFile Method (FileSystemDirectory, String, Int32)

LocalFileSystem DoCreateFile Method (FileSystemDirectory, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemFile DoCreateFile(
    FileSystemDirectory dir,
    string name,
    int size
)
protected internal override FileSystemFile DoCreateFile(
    FileSystemDirectory dir,
    string name,
    int size
)
Protected Friend Overrides Function DoCreateFile (
    dir As FileSystemDirectory,
    name As String,
    size As Integer
) As FileSystemFile
Protected Friend Overrides Function DoCreateFile (
    dir As FileSystemDirectory,
    name As String,
    size As Integer
) As FileSystemFile
protected public:
virtual FileSystemFile^ DoCreateFile(
    FileSystemDirectory^ dir,
    String^ name,
    int size
) override
protected public:
virtual FileSystemFile^ DoCreateFile(
    FileSystemDirectory^ dir,
    String^ name,
    int size
) override
abstract DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        size : int -> FileSystemFile
override DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        size : int -> FileSystemFile
abstract DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        size : int -> FileSystemFile
override DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        size : int -> FileSystemFile

Parameters

dir
Type: NFX.IO.FileSystem FileSystemDirectory
name
Type: Online System String
size
Type: Online System Int32

Return Value

Type: FileSystemFile
See Also
LocalFileSystem Class
LocalFileSystem Members
DoCreateFile Overload
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.DoCreateFile Method (FileSystemDirectory, String, String, Boolean)

LocalFileSystem DoCreateFile Method (FileSystemDirectory, String, String, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemFile DoCreateFile(
    FileSystemDirectory dir,
    string name,
    string localFile,
    bool readOnly
)
protected internal override FileSystemFile DoCreateFile(
    FileSystemDirectory dir,
    string name,
    string localFile,
    bool readOnly
)
Protected Friend Overrides Function DoCreateFile (
    dir As FileSystemDirectory,
    name As String,
    localFile As String,
    readOnly As Boolean
) As FileSystemFile
Protected Friend Overrides Function DoCreateFile (
    dir As FileSystemDirectory,
    name As String,
    localFile As String,
    readOnly As Boolean
) As FileSystemFile
protected public:
virtual FileSystemFile^ DoCreateFile(
    FileSystemDirectory^ dir,
    String^ name,
    String^ localFile,
    bool readOnly
) override
protected public:
virtual FileSystemFile^ DoCreateFile(
    FileSystemDirectory^ dir,
    String^ name,
    String^ localFile,
    bool readOnly
) override
abstract DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        localFile : string *
        readOnly : bool -> FileSystemFile
override DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        localFile : string *
        readOnly : bool -> FileSystemFile
abstract DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        localFile : string *
        readOnly : bool -> FileSystemFile
override DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        localFile : string *
        readOnly : bool -> FileSystemFile

Parameters

dir
Type: NFX.IO.FileSystem FileSystemDirectory
name
Type: Online System String
localFile
Type: Online System String
readOnly
Type: Online System Boolean

Return Value

Type: FileSystemFile
See Also
LocalFileSystem Class
LocalFileSystem Members
DoCreateFile Overload
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.DoDeleteItem Method

LocalFileSystem DoDeleteItem Method NFX Class Library

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoDeleteItem(
    FileSystemSessionItem item
)
protected internal override void DoDeleteItem(
    FileSystemSessionItem item
)
Protected Friend Overrides Sub DoDeleteItem (
    item As FileSystemSessionItem
)
Protected Friend Overrides Sub DoDeleteItem (
    item As FileSystemSessionItem
)
protected public:
virtual void DoDeleteItem(
    FileSystemSessionItem^ item
) override
protected public:
virtual void DoDeleteItem(
    FileSystemSessionItem^ item
) override
abstract DoDeleteItem :
        item : FileSystemSessionItem -> unit
override DoDeleteItem :
        item : FileSystemSessionItem -> unit
abstract DoDeleteItem :
        item : FileSystemSessionItem -> unit
override DoDeleteItem :
        item : FileSystemSessionItem -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
See Also
LocalFileSystem Class
LocalFileSystem Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.DoGetCreationTimestamp Method

LocalFileSystem DoGetCreationTimestamp Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override Nullable<DateTime> DoGetCreationTimestamp(
    FileSystemSessionItem item
)
protected internal override Nullable<DateTime> DoGetCreationTimestamp(
    FileSystemSessionItem item
)
Protected Friend Overrides Function DoGetCreationTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
Protected Friend Overrides Function DoGetCreationTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
protected public:
virtual Nullable<DateTime> DoGetCreationTimestamp(
    FileSystemSessionItem^ item
) override
protected public:
virtual Nullable<DateTime> DoGetCreationTimestamp(
    FileSystemSessionItem^ item
) override
abstract DoGetCreationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
override DoGetCreationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
abstract DoGetCreationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
override DoGetCreationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online Nullable Online DateTime
See Also
LocalFileSystem Class
LocalFileSystem Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.DoGetFileNames Method

LocalFileSystem DoGetFileNames Method NFX Class Library

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override IEnumerable<string> DoGetFileNames(
    FileSystemDirectory directory,
    bool recursive
)
protected internal override IEnumerable<string> DoGetFileNames(
    FileSystemDirectory directory,
    bool recursive
)
Protected Friend Overrides Function DoGetFileNames (
    directory As FileSystemDirectory,
    recursive As Boolean
) As IEnumerable(Of String)
Protected Friend Overrides Function DoGetFileNames (
    directory As FileSystemDirectory,
    recursive As Boolean
) As IEnumerable(Of String)
protected public:
virtual IEnumerable<String^>^ DoGetFileNames(
    FileSystemDirectory^ directory,
    bool recursive
) override
protected public:
virtual IEnumerable<String^>^ DoGetFileNames(
    FileSystemDirectory^ directory,
    bool recursive
) override
abstract DoGetFileNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>
override DoGetFileNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>
abstract DoGetFileNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>
override DoGetFileNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>

Parameters

directory
Type: NFX.IO.FileSystem FileSystemDirectory
recursive
Type: Online System Boolean

Return Value

Type: Online IEnumerable Online String
See Also
LocalFileSystem Class
LocalFileSystem Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.DoGetFileStream Method

LocalFileSystem DoGetFileStream Method NFX Class Library

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemStream DoGetFileStream(
    FileSystemFile file,
    Action<FileSystemStream> disposeAction
)
protected internal override FileSystemStream DoGetFileStream(
    FileSystemFile file,
    Action<FileSystemStream> disposeAction
)
Protected Friend Overrides Function DoGetFileStream (
    file As FileSystemFile,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
Protected Friend Overrides Function DoGetFileStream (
    file As FileSystemFile,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
protected public:
virtual FileSystemStream^ DoGetFileStream(
    FileSystemFile^ file,
    Action<FileSystemStream^>^ disposeAction
) override
protected public:
virtual FileSystemStream^ DoGetFileStream(
    FileSystemFile^ file,
    Action<FileSystemStream^>^ disposeAction
) override
abstract DoGetFileStream :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
override DoGetFileStream :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
abstract DoGetFileStream :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
override DoGetFileStream :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> FileSystemStream

Parameters

file
Type: NFX.IO.FileSystem FileSystemFile
disposeAction
Type: Online System Action FileSystemStream

Return Value

Type: FileSystemStream
See Also
LocalFileSystem Class
LocalFileSystem Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.DoGetItemSize Method

LocalFileSystem DoGetItemSize Method NFX Class Library

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override ulong DoGetItemSize(
    FileSystemSessionItem item
)
protected internal override ulong DoGetItemSize(
    FileSystemSessionItem item
)
Protected Friend Overrides Function DoGetItemSize (
    item As FileSystemSessionItem
) As ULong
Protected Friend Overrides Function DoGetItemSize (
    item As FileSystemSessionItem
) As ULong
protected public:
virtual unsigned long long DoGetItemSize(
    FileSystemSessionItem^ item
) override
protected public:
virtual unsigned long long DoGetItemSize(
    FileSystemSessionItem^ item
) override
abstract DoGetItemSize :
        item : FileSystemSessionItem -> uint64
override DoGetItemSize :
        item : FileSystemSessionItem -> uint64
abstract DoGetItemSize :
        item : FileSystemSessionItem -> uint64
override DoGetItemSize :
        item : FileSystemSessionItem -> uint64

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online UInt64
See Also
LocalFileSystem Class
LocalFileSystem Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.DoGetLastAccessTimestamp Method

LocalFileSystem DoGetLastAccessTimestamp Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override Nullable<DateTime> DoGetLastAccessTimestamp(
    FileSystemSessionItem item
)
protected internal override Nullable<DateTime> DoGetLastAccessTimestamp(
    FileSystemSessionItem item
)
Protected Friend Overrides Function DoGetLastAccessTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
Protected Friend Overrides Function DoGetLastAccessTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
protected public:
virtual Nullable<DateTime> DoGetLastAccessTimestamp(
    FileSystemSessionItem^ item
) override
protected public:
virtual Nullable<DateTime> DoGetLastAccessTimestamp(
    FileSystemSessionItem^ item
) override
abstract DoGetLastAccessTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
override DoGetLastAccessTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
abstract DoGetLastAccessTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
override DoGetLastAccessTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online Nullable Online DateTime
See Also
LocalFileSystem Class
LocalFileSystem Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.DoGetMetadataStream Method

LocalFileSystem DoGetMetadataStream Method NFX Class Library

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemStream DoGetMetadataStream(
    FileSystemSessionItem item,
    Action<FileSystemStream> disposeAction
)
protected internal override FileSystemStream DoGetMetadataStream(
    FileSystemSessionItem item,
    Action<FileSystemStream> disposeAction
)
Protected Friend Overrides Function DoGetMetadataStream (
    item As FileSystemSessionItem,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
Protected Friend Overrides Function DoGetMetadataStream (
    item As FileSystemSessionItem,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
protected public:
virtual FileSystemStream^ DoGetMetadataStream(
    FileSystemSessionItem^ item,
    Action<FileSystemStream^>^ disposeAction
) override
protected public:
virtual FileSystemStream^ DoGetMetadataStream(
    FileSystemSessionItem^ item,
    Action<FileSystemStream^>^ disposeAction
) override
abstract DoGetMetadataStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
override DoGetMetadataStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
abstract DoGetMetadataStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
override DoGetMetadataStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
disposeAction
Type: Online System Action FileSystemStream

Return Value

Type: FileSystemStream
See Also
LocalFileSystem Class
LocalFileSystem Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.DoGetModificationTimestamp Method

LocalFileSystem DoGetModificationTimestamp Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override Nullable<DateTime> DoGetModificationTimestamp(
    FileSystemSessionItem item
)
protected internal override Nullable<DateTime> DoGetModificationTimestamp(
    FileSystemSessionItem item
)
Protected Friend Overrides Function DoGetModificationTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
Protected Friend Overrides Function DoGetModificationTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
protected public:
virtual Nullable<DateTime> DoGetModificationTimestamp(
    FileSystemSessionItem^ item
) override
protected public:
virtual Nullable<DateTime> DoGetModificationTimestamp(
    FileSystemSessionItem^ item
) override
abstract DoGetModificationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
override DoGetModificationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
abstract DoGetModificationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
override DoGetModificationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online Nullable Online DateTime
See Also
LocalFileSystem Class
LocalFileSystem Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.DoGetPermissionsStream Method

LocalFileSystem DoGetPermissionsStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemStream DoGetPermissionsStream(
    FileSystemSessionItem item,
    Action<FileSystemStream> disposeAction
)
protected internal override FileSystemStream DoGetPermissionsStream(
    FileSystemSessionItem item,
    Action<FileSystemStream> disposeAction
)
Protected Friend Overrides Function DoGetPermissionsStream (
    item As FileSystemSessionItem,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
Protected Friend Overrides Function DoGetPermissionsStream (
    item As FileSystemSessionItem,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
protected public:
virtual FileSystemStream^ DoGetPermissionsStream(
    FileSystemSessionItem^ item,
    Action<FileSystemStream^>^ disposeAction
) override
protected public:
virtual FileSystemStream^ DoGetPermissionsStream(
    FileSystemSessionItem^ item,
    Action<FileSystemStream^>^ disposeAction
) override
abstract DoGetPermissionsStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
override DoGetPermissionsStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
abstract DoGetPermissionsStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
override DoGetPermissionsStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
disposeAction
Type: Online System Action FileSystemStream

Return Value

Type: FileSystemStream
See Also
LocalFileSystem Class
LocalFileSystem Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.DoGetReadOnly Method

LocalFileSystem DoGetReadOnly Method NFX Class Library

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override bool DoGetReadOnly(
    FileSystemSessionItem item
)
protected internal override bool DoGetReadOnly(
    FileSystemSessionItem item
)
Protected Friend Overrides Function DoGetReadOnly (
    item As FileSystemSessionItem
) As Boolean
Protected Friend Overrides Function DoGetReadOnly (
    item As FileSystemSessionItem
) As Boolean
protected public:
virtual bool DoGetReadOnly(
    FileSystemSessionItem^ item
) override
protected public:
virtual bool DoGetReadOnly(
    FileSystemSessionItem^ item
) override
abstract DoGetReadOnly :
        item : FileSystemSessionItem -> bool
override DoGetReadOnly :
        item : FileSystemSessionItem -> bool
abstract DoGetReadOnly :
        item : FileSystemSessionItem -> bool
override DoGetReadOnly :
        item : FileSystemSessionItem -> bool

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online Boolean
See Also
LocalFileSystem Class
LocalFileSystem Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.DoGetSubDirectoryNames Method

LocalFileSystem DoGetSubDirectoryNames Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override IEnumerable<string> DoGetSubDirectoryNames(
    FileSystemDirectory directory,
    bool recursive
)
protected internal override IEnumerable<string> DoGetSubDirectoryNames(
    FileSystemDirectory directory,
    bool recursive
)
Protected Friend Overrides Function DoGetSubDirectoryNames (
    directory As FileSystemDirectory,
    recursive As Boolean
) As IEnumerable(Of String)
Protected Friend Overrides Function DoGetSubDirectoryNames (
    directory As FileSystemDirectory,
    recursive As Boolean
) As IEnumerable(Of String)
protected public:
virtual IEnumerable<String^>^ DoGetSubDirectoryNames(
    FileSystemDirectory^ directory,
    bool recursive
) override
protected public:
virtual IEnumerable<String^>^ DoGetSubDirectoryNames(
    FileSystemDirectory^ directory,
    bool recursive
) override
abstract DoGetSubDirectoryNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>
override DoGetSubDirectoryNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>
abstract DoGetSubDirectoryNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>
override DoGetSubDirectoryNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>

Parameters

directory
Type: NFX.IO.FileSystem FileSystemDirectory
recursive
Type: Online System Boolean

Return Value

Type: Online IEnumerable Online String
See Also
LocalFileSystem Class
LocalFileSystem Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.DoNavigate Method

LocalFileSystem DoNavigate Method NFX Class Library

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemSessionItem DoNavigate(
    FileSystemSession session,
    string path
)
protected internal override FileSystemSessionItem DoNavigate(
    FileSystemSession session,
    string path
)
Protected Friend Overrides Function DoNavigate (
    session As FileSystemSession,
    path As String
) As FileSystemSessionItem
Protected Friend Overrides Function DoNavigate (
    session As FileSystemSession,
    path As String
) As FileSystemSessionItem
protected public:
virtual FileSystemSessionItem^ DoNavigate(
    FileSystemSession^ session,
    String^ path
) override
protected public:
virtual FileSystemSessionItem^ DoNavigate(
    FileSystemSession^ session,
    String^ path
) override
abstract DoNavigate :
        session : FileSystemSession *
        path : string -> FileSystemSessionItem
override DoNavigate :
        session : FileSystemSession *
        path : string -> FileSystemSessionItem
abstract DoNavigate :
        session : FileSystemSession *
        path : string -> FileSystemSessionItem
override DoNavigate :
        session : FileSystemSession *
        path : string -> FileSystemSessionItem

Parameters

session
Type: NFX.IO.FileSystem FileSystemSession
path
Type: Online System String

Return Value

Type: FileSystemSessionItem
See Also
LocalFileSystem Class
LocalFileSystem Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.DoRefresh Method

LocalFileSystem DoRefresh Method NFX Class Library

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoRefresh(
    FileSystemSessionItem item
)
protected internal override void DoRefresh(
    FileSystemSessionItem item
)
Protected Friend Overrides Sub DoRefresh (
    item As FileSystemSessionItem
)
Protected Friend Overrides Sub DoRefresh (
    item As FileSystemSessionItem
)
protected public:
virtual void DoRefresh(
    FileSystemSessionItem^ item
) override
protected public:
virtual void DoRefresh(
    FileSystemSessionItem^ item
) override
abstract DoRefresh :
        item : FileSystemSessionItem -> unit
override DoRefresh :
        item : FileSystemSessionItem -> unit
abstract DoRefresh :
        item : FileSystemSessionItem -> unit
override DoRefresh :
        item : FileSystemSessionItem -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
See Also
LocalFileSystem Class
LocalFileSystem Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.DoRenameItem Method

LocalFileSystem DoRenameItem Method NFX Class Library

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override bool DoRenameItem(
    FileSystemSessionItem item,
    string newName
)
protected internal override bool DoRenameItem(
    FileSystemSessionItem item,
    string newName
)
Protected Friend Overrides Function DoRenameItem (
    item As FileSystemSessionItem,
    newName As String
) As Boolean
Protected Friend Overrides Function DoRenameItem (
    item As FileSystemSessionItem,
    newName As String
) As Boolean
protected public:
virtual bool DoRenameItem(
    FileSystemSessionItem^ item,
    String^ newName
) override
protected public:
virtual bool DoRenameItem(
    FileSystemSessionItem^ item,
    String^ newName
) override
abstract DoRenameItem :
        item : FileSystemSessionItem *
        newName : string -> bool
override DoRenameItem :
        item : FileSystemSessionItem *
        newName : string -> bool
abstract DoRenameItem :
        item : FileSystemSessionItem *
        newName : string -> bool
override DoRenameItem :
        item : FileSystemSessionItem *
        newName : string -> bool

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
newName
Type: Online System String

Return Value

Type: Online Boolean
See Also
LocalFileSystem Class
LocalFileSystem Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.DoSetCreationTimestamp Method

LocalFileSystem DoSetCreationTimestamp Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoSetCreationTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
protected internal override void DoSetCreationTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
Protected Friend Overrides Sub DoSetCreationTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
Protected Friend Overrides Sub DoSetCreationTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
protected public:
virtual void DoSetCreationTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) override
protected public:
virtual void DoSetCreationTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) override
abstract DoSetCreationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
override DoSetCreationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
abstract DoSetCreationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
override DoSetCreationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
timestamp
Type: Online System DateTime
See Also
LocalFileSystem Class
LocalFileSystem Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.DoSetLastAccessTimestamp Method

LocalFileSystem DoSetLastAccessTimestamp Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoSetLastAccessTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
protected internal override void DoSetLastAccessTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
Protected Friend Overrides Sub DoSetLastAccessTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
Protected Friend Overrides Sub DoSetLastAccessTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
protected public:
virtual void DoSetLastAccessTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) override
protected public:
virtual void DoSetLastAccessTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) override
abstract DoSetLastAccessTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
override DoSetLastAccessTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
abstract DoSetLastAccessTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
override DoSetLastAccessTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
timestamp
Type: Online System DateTime
See Also
LocalFileSystem Class
LocalFileSystem Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.DoSetModificationTimestamp Method

LocalFileSystem DoSetModificationTimestamp Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoSetModificationTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
protected internal override void DoSetModificationTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
Protected Friend Overrides Sub DoSetModificationTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
Protected Friend Overrides Sub DoSetModificationTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
protected public:
virtual void DoSetModificationTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) override
protected public:
virtual void DoSetModificationTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) override
abstract DoSetModificationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
override DoSetModificationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
abstract DoSetModificationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
override DoSetModificationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
timestamp
Type: Online System DateTime
See Also
LocalFileSystem Class
LocalFileSystem Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.DoSetReadOnly Method

LocalFileSystem DoSetReadOnly Method NFX Class Library

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoSetReadOnly(
    FileSystemSessionItem item,
    bool readOnly
)
protected internal override void DoSetReadOnly(
    FileSystemSessionItem item,
    bool readOnly
)
Protected Friend Overrides Sub DoSetReadOnly (
    item As FileSystemSessionItem,
    readOnly As Boolean
)
Protected Friend Overrides Sub DoSetReadOnly (
    item As FileSystemSessionItem,
    readOnly As Boolean
)
protected public:
virtual void DoSetReadOnly(
    FileSystemSessionItem^ item,
    bool readOnly
) override
protected public:
virtual void DoSetReadOnly(
    FileSystemSessionItem^ item,
    bool readOnly
) override
abstract DoSetReadOnly :
        item : FileSystemSessionItem *
        readOnly : bool -> unit
override DoSetReadOnly :
        item : FileSystemSessionItem *
        readOnly : bool -> unit
abstract DoSetReadOnly :
        item : FileSystemSessionItem *
        readOnly : bool -> unit
override DoSetReadOnly :
        item : FileSystemSessionItem *
        readOnly : bool -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
readOnly
Type: Online System Boolean
See Also
LocalFileSystem Class
LocalFileSystem Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.StartSession Method

LocalFileSystem StartSession Method NFX Class Library

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override FileSystemSession StartSession(
    FileSystemSessionConnectParams cParams = null
)
public override FileSystemSession StartSession(
    FileSystemSessionConnectParams cParams = null
)
Public Overrides Function StartSession (
    Optional cParams As FileSystemSessionConnectParams = Nothing
) As FileSystemSession
Public Overrides Function StartSession (
    Optional cParams As FileSystemSessionConnectParams = Nothing
) As FileSystemSession
public:
virtual FileSystemSession^ StartSession(
    FileSystemSessionConnectParams^ cParams = nullptr
) override
public:
virtual FileSystemSession^ StartSession(
    FileSystemSessionConnectParams^ cParams = nullptr
) override
abstract StartSession :
        ?cParams : FileSystemSessionConnectParams
(* Defaults:
        let _cParams = defaultArg cParams null
*)
-> FileSystemSession
override StartSession :
        ?cParams : FileSystemSessionConnectParams
(* Defaults:
        let _cParams = defaultArg cParams null
*)
-> FileSystemSession
abstract StartSession :
        ?cParams : FileSystemSessionConnectParams
(* Defaults:
        let _cParams = defaultArg cParams null
*)
-> FileSystemSession
override StartSession :
        ?cParams : FileSystemSessionConnectParams
(* Defaults:
        let _cParams = defaultArg cParams null
*)
-> FileSystemSession

Parameters

cParams (Optional)
Type: NFX.IO.FileSystem FileSystemSessionConnectParams

Return Value

Type: FileSystemSession

Implements

IFileSystem StartSession(FileSystemSessionConnectParams)
See Also
LocalFileSystem Class
LocalFileSystem Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem Properties

LocalFileSystem Properties NFX Class Library

The LocalFileSystem type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | (Overrides ApplicationComponent ComponentCommonName.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Protected property | DefaultSessionConnectParams | (Inherited from FileSystem.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | GeneralCapabilities | (Overrides FileSystem GeneralCapabilities.)
Public property | InstanceCapabilities | (Overrides FileSystem InstanceCapabilities.)
Public property | Name | Provides name for file system instance (Inherited from FileSystem.)
Public property | Sessions | Returns a list of sessions. This accessor is thread-safe (Inherited from FileSystem.)
Back to Top
See Also
LocalFileSystem Class
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.ComponentCommonName Property

LocalFileSystem ComponentCommonName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ComponentCommonName { get; }
public override string ComponentCommonName { get; }
Public Overrides ReadOnly Property ComponentCommonName As String
    Get
Public Overrides ReadOnly Property ComponentCommonName As String
    Get
public:
virtual property String^ ComponentCommonName {
    String^ get () override;
}
public:
virtual property String^ ComponentCommonName {
    String^ get () override;
}
abstract ComponentCommonName : string with get
override ComponentCommonName : string with get
abstract ComponentCommonName : string with get
override ComponentCommonName : string with get

Property Value

Type: Online String

Implements

IApplicationComponent ComponentCommonName
See Also
LocalFileSystem Class
LocalFileSystem Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.GeneralCapabilities Property

LocalFileSystem GeneralCapabilities Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IFileSystemCapabilities GeneralCapabilities { get; }
public override IFileSystemCapabilities GeneralCapabilities { get; }
Public Overrides ReadOnly Property GeneralCapabilities As IFileSystemCapabilities
    Get
Public Overrides ReadOnly Property GeneralCapabilities As IFileSystemCapabilities
    Get
public:
virtual property IFileSystemCapabilities^ GeneralCapabilities {
    IFileSystemCapabilities^ get () override;
}
public:
virtual property IFileSystemCapabilities^ GeneralCapabilities {
    IFileSystemCapabilities^ get () override;
}
abstract GeneralCapabilities : IFileSystemCapabilities with get
override GeneralCapabilities : IFileSystemCapabilities with get
abstract GeneralCapabilities : IFileSystemCapabilities with get
override GeneralCapabilities : IFileSystemCapabilities with get

Property Value

Type: IFileSystemCapabilities

Implements

IFileSystem GeneralCapabilities
See Also
LocalFileSystem Class
LocalFileSystem Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.InstanceCapabilities Property

LocalFileSystem InstanceCapabilities Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IFileSystemCapabilities InstanceCapabilities { get; }
public override IFileSystemCapabilities InstanceCapabilities { get; }
Public Overrides ReadOnly Property InstanceCapabilities As IFileSystemCapabilities
    Get
Public Overrides ReadOnly Property InstanceCapabilities As IFileSystemCapabilities
    Get
public:
virtual property IFileSystemCapabilities^ InstanceCapabilities {
    IFileSystemCapabilities^ get () override;
}
public:
virtual property IFileSystemCapabilities^ InstanceCapabilities {
    IFileSystemCapabilities^ get () override;
}
abstract InstanceCapabilities : IFileSystemCapabilities with get
override InstanceCapabilities : IFileSystemCapabilities with get
abstract InstanceCapabilities : IFileSystemCapabilities with get
override InstanceCapabilities : IFileSystemCapabilities with get

Property Value

Type: IFileSystemCapabilities

Implements

IFileSystem InstanceCapabilities
See Also
LocalFileSystem Class
LocalFileSystem Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.FSH Class

LocalFileSystem FSH Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.Local LocalFileSystem FSH

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class FSH : IFileSystemHandle
internal class FSH : IFileSystemHandle
Friend Class FSH
    Implements IFileSystemHandle
Friend Class FSH
    Implements IFileSystemHandle
internal ref class FSH : IFileSystemHandle
internal ref class FSH : IFileSystemHandle
type FSH =
    class
        interface IFileSystemHandle
    end
type FSH =
    class
        interface IFileSystemHandle
    end
See Also
LocalFileSystem FSH Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.FSH Members

LocalFileSystem FSH Members NFX Class Library

The LocalFileSystem FSH type exposes the following members.
Constructors
 | Name | Description
Public method | LocalFileSystem FSH | Initializes a new instance of the LocalFileSystem FSH class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | m_Info |
Back to Top
See Also
LocalFileSystem FSH Class
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.FSH Constructor

LocalFileSystem FSH Constructor NFX Class Library

Initializes a new instance of the LocalFileSystem FSH class

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FSH()
public FSH()
Public Sub New
Public Sub New
public:
FSH()
public:
FSH()
new : unit -> FSH
new : unit -> FSH
See Also
LocalFileSystem FSH Class
LocalFileSystem FSH Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.FSH Fields

LocalFileSystem FSH Fields NFX Class Library

The LocalFileSystem FSH type exposes the following members.
Fields
 | Name | Description
Public field | m_Info |
Back to Top
See Also
LocalFileSystem FSH Class
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.FSH.m_Info Field

LocalFileSystem FSH m_Info Field NFX Class Library

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileSystemInfo m_Info
public FileSystemInfo m_Info
Public m_Info As FileSystemInfo
Public m_Info As FileSystemInfo
public:
FileSystemInfo^ m_Info
public:
FileSystemInfo^ m_Info
val mutable m_Info: FileSystemInfo
val mutable m_Info: FileSystemInfo

Field Value

Type: Online FileSystemInfo
See Also
LocalFileSystem FSH Class
LocalFileSystem FSH Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystem.FSH Methods

LocalFileSystem FSH Methods NFX Class Library

The LocalFileSystem FSH type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LocalFileSystem FSH Class
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities Class

LocalFileSystemCapabilities Class NFX Class Library

Describes local file system capabilities
Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.Local LocalFileSystemCapabilities

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class LocalFileSystemCapabilities : IFileSystemCapabilities
public sealed class LocalFileSystemCapabilities : IFileSystemCapabilities
Public NotInheritable Class LocalFileSystemCapabilities
    Implements IFileSystemCapabilities
Public NotInheritable Class LocalFileSystemCapabilities
    Implements IFileSystemCapabilities
public ref class LocalFileSystemCapabilities sealed : IFileSystemCapabilities
public ref class LocalFileSystemCapabilities sealed : IFileSystemCapabilities
[<SealedAttribute>]
type LocalFileSystemCapabilities =
    class
        interface IFileSystemCapabilities
    end
[<SealedAttribute>]
type LocalFileSystemCapabilities =
    class
        interface IFileSystemCapabilities
    end
See Also
LocalFileSystemCapabilities Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities Members

LocalFileSystemCapabilities Members NFX Class Library

The LocalFileSystemCapabilities type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
 | Instance |
Public property | IsReadonly |
Public property | MaxDirectoryNameLength |
Public property | MaxFileNameLength |
Public property | MaxFilePathLength |
Public property | MaxFileSize |
Public property | PathSeparatorCharacters |
Public property | SupportsAsyncronousAPI |
Public property | SupportsCreationTimestamps |
Public property | SupportsCreationUserNames |
Public property | SupportsCustomMetadata |
Public property | SupportsDirectoryRenaming |
Public property | SupportsDirectorySizes |
Public property | SupportsFileModification |
Public property | SupportsFileRenaming |
Public property | SupportsFileSizes |
Public property | SupportsLastAccessTimestamps |
Public property | SupportsLastAccessUserNames |
Public property | SupportsModificationTimestamps |
Public property | SupportsModificationUserNames |
Public property | SupportsReadonlyDirectories |
Public property | SupportsReadonlyFiles |
Public property | SupportsSecurity |
Public property | SupportsStreamSeek |
Public property | SupportsTransactions |
Public property | SupportsVersioning |
Back to Top
See Also
LocalFileSystemCapabilities Class
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities Methods

LocalFileSystemCapabilities Methods NFX Class Library

The LocalFileSystemCapabilities type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LocalFileSystemCapabilities Class
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities Properties

LocalFileSystemCapabilities Properties NFX Class Library

The LocalFileSystemCapabilities type exposes the following members.
Properties
 | Name | Description
 | Instance |
Public property | IsReadonly |
Public property | MaxDirectoryNameLength |
Public property | MaxFileNameLength |
Public property | MaxFilePathLength |
Public property | MaxFileSize |
Public property | PathSeparatorCharacters |
Public property | SupportsAsyncronousAPI |
Public property | SupportsCreationTimestamps |
Public property | SupportsCreationUserNames |
Public property | SupportsCustomMetadata |
Public property | SupportsDirectoryRenaming |
Public property | SupportsDirectorySizes |
Public property | SupportsFileModification |
Public property | SupportsFileRenaming |
Public property | SupportsFileSizes |
Public property | SupportsLastAccessTimestamps |
Public property | SupportsLastAccessUserNames |
Public property | SupportsModificationTimestamps |
Public property | SupportsModificationUserNames |
Public property | SupportsReadonlyDirectories |
Public property | SupportsReadonlyFiles |
Public property | SupportsSecurity |
Public property | SupportsStreamSeek |
Public property | SupportsTransactions |
Public property | SupportsVersioning |
Back to Top
See Also
LocalFileSystemCapabilities Class
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities.Instance Property

LocalFileSystemCapabilities Instance Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static LocalFileSystemCapabilities Instance { get; }
public static LocalFileSystemCapabilities Instance { get; }
Public Shared ReadOnly Property Instance As LocalFileSystemCapabilities
    Get
Public Shared ReadOnly Property Instance As LocalFileSystemCapabilities
    Get
public:
static property LocalFileSystemCapabilities^ Instance {
    LocalFileSystemCapabilities^ get ();
}
public:
static property LocalFileSystemCapabilities^ Instance {
    LocalFileSystemCapabilities^ get ();
}
static member Instance : LocalFileSystemCapabilities with get
static member Instance : LocalFileSystemCapabilities with get

Property Value

Type: LocalFileSystemCapabilities
See Also
LocalFileSystemCapabilities Class
LocalFileSystemCapabilities Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities.IsReadonly Property

LocalFileSystemCapabilities IsReadonly Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsReadonly { get; }
public bool IsReadonly { get; }
Public ReadOnly Property IsReadonly As Boolean
    Get
Public ReadOnly Property IsReadonly As Boolean
    Get
public:
virtual property bool IsReadonly {
    bool get () sealed;
}
public:
virtual property bool IsReadonly {
    bool get () sealed;
}
abstract IsReadonly : bool with get
override IsReadonly : bool with get
abstract IsReadonly : bool with get
override IsReadonly : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities IsReadonly
See Also
LocalFileSystemCapabilities Class
LocalFileSystemCapabilities Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities.MaxDirectoryNameLength Property

LocalFileSystemCapabilities MaxDirectoryNameLength Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MaxDirectoryNameLength { get; }
public int MaxDirectoryNameLength { get; }
Public ReadOnly Property MaxDirectoryNameLength As Integer
    Get
Public ReadOnly Property MaxDirectoryNameLength As Integer
    Get
public:
virtual property int MaxDirectoryNameLength {
    int get () sealed;
}
public:
virtual property int MaxDirectoryNameLength {
    int get () sealed;
}
abstract MaxDirectoryNameLength : int with get
override MaxDirectoryNameLength : int with get
abstract MaxDirectoryNameLength : int with get
override MaxDirectoryNameLength : int with get

Property Value

Type: Online Int32

Implements

IFileSystemCapabilities MaxDirectoryNameLength
See Also
LocalFileSystemCapabilities Class
LocalFileSystemCapabilities Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities.MaxFileNameLength Property

LocalFileSystemCapabilities MaxFileNameLength Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MaxFileNameLength { get; }
public int MaxFileNameLength { get; }
Public ReadOnly Property MaxFileNameLength As Integer
    Get
Public ReadOnly Property MaxFileNameLength As Integer
    Get
public:
virtual property int MaxFileNameLength {
    int get () sealed;
}
public:
virtual property int MaxFileNameLength {
    int get () sealed;
}
abstract MaxFileNameLength : int with get
override MaxFileNameLength : int with get
abstract MaxFileNameLength : int with get
override MaxFileNameLength : int with get

Property Value

Type: Online Int32

Implements

IFileSystemCapabilities MaxFileNameLength
See Also
LocalFileSystemCapabilities Class
LocalFileSystemCapabilities Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities.MaxFilePathLength Property

LocalFileSystemCapabilities MaxFilePathLength Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MaxFilePathLength { get; }
public int MaxFilePathLength { get; }
Public ReadOnly Property MaxFilePathLength As Integer
    Get
Public ReadOnly Property MaxFilePathLength As Integer
    Get
public:
virtual property int MaxFilePathLength {
    int get () sealed;
}
public:
virtual property int MaxFilePathLength {
    int get () sealed;
}
abstract MaxFilePathLength : int with get
override MaxFilePathLength : int with get
abstract MaxFilePathLength : int with get
override MaxFilePathLength : int with get

Property Value

Type: Online Int32

Implements

IFileSystemCapabilities MaxFilePathLength
See Also
LocalFileSystemCapabilities Class
LocalFileSystemCapabilities Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities.MaxFileSize Property

LocalFileSystemCapabilities MaxFileSize Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong MaxFileSize { get; }
public ulong MaxFileSize { get; }
Public ReadOnly Property MaxFileSize As ULong
    Get
Public ReadOnly Property MaxFileSize As ULong
    Get
public:
virtual property unsigned long long MaxFileSize {
    unsigned long long get () sealed;
}
public:
virtual property unsigned long long MaxFileSize {
    unsigned long long get () sealed;
}
abstract MaxFileSize : uint64 with get
override MaxFileSize : uint64 with get
abstract MaxFileSize : uint64 with get
override MaxFileSize : uint64 with get

Property Value

Type: Online UInt64

Implements

IFileSystemCapabilities MaxFileSize
See Also
LocalFileSystemCapabilities Class
LocalFileSystemCapabilities Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities.PathSeparatorCharacters Property

LocalFileSystemCapabilities PathSeparatorCharacters Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char[] PathSeparatorCharacters { get; }
public char[] PathSeparatorCharacters { get; }
Public ReadOnly Property PathSeparatorCharacters As Char()
    Get
Public ReadOnly Property PathSeparatorCharacters As Char()
    Get
public:
virtual property array<wchar_t>^ PathSeparatorCharacters {
    array<wchar_t>^ get () sealed;
}
public:
virtual property array<wchar_t>^ PathSeparatorCharacters {
    array<wchar_t>^ get () sealed;
}
abstract PathSeparatorCharacters : char[] with get
override PathSeparatorCharacters : char[] with get
abstract PathSeparatorCharacters : char[] with get
override PathSeparatorCharacters : char[] with get

Property Value

Type: Online Char

Implements

IFileSystemCapabilities PathSeparatorCharacters
See Also
LocalFileSystemCapabilities Class
LocalFileSystemCapabilities Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities.SupportsAsyncronousAPI Property

LocalFileSystemCapabilities SupportsAsyncronousAPI Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsAsyncronousAPI { get; }
public bool SupportsAsyncronousAPI { get; }
Public ReadOnly Property SupportsAsyncronousAPI As Boolean
    Get
Public ReadOnly Property SupportsAsyncronousAPI As Boolean
    Get
public:
virtual property bool SupportsAsyncronousAPI {
    bool get () sealed;
}
public:
virtual property bool SupportsAsyncronousAPI {
    bool get () sealed;
}
abstract SupportsAsyncronousAPI : bool with get
override SupportsAsyncronousAPI : bool with get
abstract SupportsAsyncronousAPI : bool with get
override SupportsAsyncronousAPI : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsAsyncronousAPI
See Also
LocalFileSystemCapabilities Class
LocalFileSystemCapabilities Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities.SupportsCreationTimestamps Property

LocalFileSystemCapabilities SupportsCreationTimestamps Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsCreationTimestamps { get; }
public bool SupportsCreationTimestamps { get; }
Public ReadOnly Property SupportsCreationTimestamps As Boolean
    Get
Public ReadOnly Property SupportsCreationTimestamps As Boolean
    Get
public:
virtual property bool SupportsCreationTimestamps {
    bool get () sealed;
}
public:
virtual property bool SupportsCreationTimestamps {
    bool get () sealed;
}
abstract SupportsCreationTimestamps : bool with get
override SupportsCreationTimestamps : bool with get
abstract SupportsCreationTimestamps : bool with get
override SupportsCreationTimestamps : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsCreationTimestamps
See Also
LocalFileSystemCapabilities Class
LocalFileSystemCapabilities Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities.SupportsCreationUserNames Property

LocalFileSystemCapabilities SupportsCreationUserNames Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsCreationUserNames { get; }
public bool SupportsCreationUserNames { get; }
Public ReadOnly Property SupportsCreationUserNames As Boolean
    Get
Public ReadOnly Property SupportsCreationUserNames As Boolean
    Get
public:
virtual property bool SupportsCreationUserNames {
    bool get () sealed;
}
public:
virtual property bool SupportsCreationUserNames {
    bool get () sealed;
}
abstract SupportsCreationUserNames : bool with get
override SupportsCreationUserNames : bool with get
abstract SupportsCreationUserNames : bool with get
override SupportsCreationUserNames : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsCreationUserNames
See Also
LocalFileSystemCapabilities Class
LocalFileSystemCapabilities Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities.SupportsCustomMetadata Property

LocalFileSystemCapabilities SupportsCustomMetadata Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsCustomMetadata { get; }
public bool SupportsCustomMetadata { get; }
Public ReadOnly Property SupportsCustomMetadata As Boolean
    Get
Public ReadOnly Property SupportsCustomMetadata As Boolean
    Get
public:
virtual property bool SupportsCustomMetadata {
    bool get () sealed;
}
public:
virtual property bool SupportsCustomMetadata {
    bool get () sealed;
}
abstract SupportsCustomMetadata : bool with get
override SupportsCustomMetadata : bool with get
abstract SupportsCustomMetadata : bool with get
override SupportsCustomMetadata : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsCustomMetadata
See Also
LocalFileSystemCapabilities Class
LocalFileSystemCapabilities Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities.SupportsDirectoryRenaming Property

LocalFileSystemCapabilities SupportsDirectoryRenaming Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsDirectoryRenaming { get; }
public bool SupportsDirectoryRenaming { get; }
Public ReadOnly Property SupportsDirectoryRenaming As Boolean
    Get
Public ReadOnly Property SupportsDirectoryRenaming As Boolean
    Get
public:
virtual property bool SupportsDirectoryRenaming {
    bool get () sealed;
}
public:
virtual property bool SupportsDirectoryRenaming {
    bool get () sealed;
}
abstract SupportsDirectoryRenaming : bool with get
override SupportsDirectoryRenaming : bool with get
abstract SupportsDirectoryRenaming : bool with get
override SupportsDirectoryRenaming : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsDirectoryRenaming
See Also
LocalFileSystemCapabilities Class
LocalFileSystemCapabilities Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities.SupportsDirectorySizes Property

LocalFileSystemCapabilities SupportsDirectorySizes Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsDirectorySizes { get; }
public bool SupportsDirectorySizes { get; }
Public ReadOnly Property SupportsDirectorySizes As Boolean
    Get
Public ReadOnly Property SupportsDirectorySizes As Boolean
    Get
public:
virtual property bool SupportsDirectorySizes {
    bool get () sealed;
}
public:
virtual property bool SupportsDirectorySizes {
    bool get () sealed;
}
abstract SupportsDirectorySizes : bool with get
override SupportsDirectorySizes : bool with get
abstract SupportsDirectorySizes : bool with get
override SupportsDirectorySizes : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsDirectorySizes
See Also
LocalFileSystemCapabilities Class
LocalFileSystemCapabilities Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities.SupportsFileModification Property

LocalFileSystemCapabilities SupportsFileModification Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsFileModification { get; }
public bool SupportsFileModification { get; }
Public ReadOnly Property SupportsFileModification As Boolean
    Get
Public ReadOnly Property SupportsFileModification As Boolean
    Get
public:
virtual property bool SupportsFileModification {
    bool get () sealed;
}
public:
virtual property bool SupportsFileModification {
    bool get () sealed;
}
abstract SupportsFileModification : bool with get
override SupportsFileModification : bool with get
abstract SupportsFileModification : bool with get
override SupportsFileModification : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsFileModification
See Also
LocalFileSystemCapabilities Class
LocalFileSystemCapabilities Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities.SupportsFileRenaming Property

LocalFileSystemCapabilities SupportsFileRenaming Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsFileRenaming { get; }
public bool SupportsFileRenaming { get; }
Public ReadOnly Property SupportsFileRenaming As Boolean
    Get
Public ReadOnly Property SupportsFileRenaming As Boolean
    Get
public:
virtual property bool SupportsFileRenaming {
    bool get () sealed;
}
public:
virtual property bool SupportsFileRenaming {
    bool get () sealed;
}
abstract SupportsFileRenaming : bool with get
override SupportsFileRenaming : bool with get
abstract SupportsFileRenaming : bool with get
override SupportsFileRenaming : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsFileRenaming
See Also
LocalFileSystemCapabilities Class
LocalFileSystemCapabilities Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities.SupportsFileSizes Property

LocalFileSystemCapabilities SupportsFileSizes Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsFileSizes { get; }
public bool SupportsFileSizes { get; }
Public ReadOnly Property SupportsFileSizes As Boolean
    Get
Public ReadOnly Property SupportsFileSizes As Boolean
    Get
public:
virtual property bool SupportsFileSizes {
    bool get () sealed;
}
public:
virtual property bool SupportsFileSizes {
    bool get () sealed;
}
abstract SupportsFileSizes : bool with get
override SupportsFileSizes : bool with get
abstract SupportsFileSizes : bool with get
override SupportsFileSizes : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsFileSizes
See Also
LocalFileSystemCapabilities Class
LocalFileSystemCapabilities Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities.SupportsLastAccessTimestamps Property

LocalFileSystemCapabilities SupportsLastAccessTimestamps Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsLastAccessTimestamps { get; }
public bool SupportsLastAccessTimestamps { get; }
Public ReadOnly Property SupportsLastAccessTimestamps As Boolean
    Get
Public ReadOnly Property SupportsLastAccessTimestamps As Boolean
    Get
public:
virtual property bool SupportsLastAccessTimestamps {
    bool get () sealed;
}
public:
virtual property bool SupportsLastAccessTimestamps {
    bool get () sealed;
}
abstract SupportsLastAccessTimestamps : bool with get
override SupportsLastAccessTimestamps : bool with get
abstract SupportsLastAccessTimestamps : bool with get
override SupportsLastAccessTimestamps : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsLastAccessTimestamps
See Also
LocalFileSystemCapabilities Class
LocalFileSystemCapabilities Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities.SupportsLastAccessUserNames Property

LocalFileSystemCapabilities SupportsLastAccessUserNames Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsLastAccessUserNames { get; }
public bool SupportsLastAccessUserNames { get; }
Public ReadOnly Property SupportsLastAccessUserNames As Boolean
    Get
Public ReadOnly Property SupportsLastAccessUserNames As Boolean
    Get
public:
virtual property bool SupportsLastAccessUserNames {
    bool get () sealed;
}
public:
virtual property bool SupportsLastAccessUserNames {
    bool get () sealed;
}
abstract SupportsLastAccessUserNames : bool with get
override SupportsLastAccessUserNames : bool with get
abstract SupportsLastAccessUserNames : bool with get
override SupportsLastAccessUserNames : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsLastAccessUserNames
See Also
LocalFileSystemCapabilities Class
LocalFileSystemCapabilities Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities.SupportsModificationTimestamps Property

LocalFileSystemCapabilities SupportsModificationTimestamps Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsModificationTimestamps { get; }
public bool SupportsModificationTimestamps { get; }
Public ReadOnly Property SupportsModificationTimestamps As Boolean
    Get
Public ReadOnly Property SupportsModificationTimestamps As Boolean
    Get
public:
virtual property bool SupportsModificationTimestamps {
    bool get () sealed;
}
public:
virtual property bool SupportsModificationTimestamps {
    bool get () sealed;
}
abstract SupportsModificationTimestamps : bool with get
override SupportsModificationTimestamps : bool with get
abstract SupportsModificationTimestamps : bool with get
override SupportsModificationTimestamps : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsModificationTimestamps
See Also
LocalFileSystemCapabilities Class
LocalFileSystemCapabilities Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities.SupportsModificationUserNames Property

LocalFileSystemCapabilities SupportsModificationUserNames Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsModificationUserNames { get; }
public bool SupportsModificationUserNames { get; }
Public ReadOnly Property SupportsModificationUserNames As Boolean
    Get
Public ReadOnly Property SupportsModificationUserNames As Boolean
    Get
public:
virtual property bool SupportsModificationUserNames {
    bool get () sealed;
}
public:
virtual property bool SupportsModificationUserNames {
    bool get () sealed;
}
abstract SupportsModificationUserNames : bool with get
override SupportsModificationUserNames : bool with get
abstract SupportsModificationUserNames : bool with get
override SupportsModificationUserNames : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsModificationUserNames
See Also
LocalFileSystemCapabilities Class
LocalFileSystemCapabilities Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities.SupportsReadonlyDirectories Property

LocalFileSystemCapabilities SupportsReadonlyDirectories Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsReadonlyDirectories { get; }
public bool SupportsReadonlyDirectories { get; }
Public ReadOnly Property SupportsReadonlyDirectories As Boolean
    Get
Public ReadOnly Property SupportsReadonlyDirectories As Boolean
    Get
public:
virtual property bool SupportsReadonlyDirectories {
    bool get () sealed;
}
public:
virtual property bool SupportsReadonlyDirectories {
    bool get () sealed;
}
abstract SupportsReadonlyDirectories : bool with get
override SupportsReadonlyDirectories : bool with get
abstract SupportsReadonlyDirectories : bool with get
override SupportsReadonlyDirectories : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsReadonlyDirectories
See Also
LocalFileSystemCapabilities Class
LocalFileSystemCapabilities Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities.SupportsReadonlyFiles Property

LocalFileSystemCapabilities SupportsReadonlyFiles Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsReadonlyFiles { get; }
public bool SupportsReadonlyFiles { get; }
Public ReadOnly Property SupportsReadonlyFiles As Boolean
    Get
Public ReadOnly Property SupportsReadonlyFiles As Boolean
    Get
public:
virtual property bool SupportsReadonlyFiles {
    bool get () sealed;
}
public:
virtual property bool SupportsReadonlyFiles {
    bool get () sealed;
}
abstract SupportsReadonlyFiles : bool with get
override SupportsReadonlyFiles : bool with get
abstract SupportsReadonlyFiles : bool with get
override SupportsReadonlyFiles : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsReadonlyFiles
See Also
LocalFileSystemCapabilities Class
LocalFileSystemCapabilities Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities.SupportsSecurity Property

LocalFileSystemCapabilities SupportsSecurity Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsSecurity { get; }
public bool SupportsSecurity { get; }
Public ReadOnly Property SupportsSecurity As Boolean
    Get
Public ReadOnly Property SupportsSecurity As Boolean
    Get
public:
virtual property bool SupportsSecurity {
    bool get () sealed;
}
public:
virtual property bool SupportsSecurity {
    bool get () sealed;
}
abstract SupportsSecurity : bool with get
override SupportsSecurity : bool with get
abstract SupportsSecurity : bool with get
override SupportsSecurity : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsSecurity
See Also
LocalFileSystemCapabilities Class
LocalFileSystemCapabilities Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities.SupportsStreamSeek Property

LocalFileSystemCapabilities SupportsStreamSeek Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsStreamSeek { get; }
public bool SupportsStreamSeek { get; }
Public ReadOnly Property SupportsStreamSeek As Boolean
    Get
Public ReadOnly Property SupportsStreamSeek As Boolean
    Get
public:
virtual property bool SupportsStreamSeek {
    bool get () sealed;
}
public:
virtual property bool SupportsStreamSeek {
    bool get () sealed;
}
abstract SupportsStreamSeek : bool with get
override SupportsStreamSeek : bool with get
abstract SupportsStreamSeek : bool with get
override SupportsStreamSeek : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsStreamSeek
See Also
LocalFileSystemCapabilities Class
LocalFileSystemCapabilities Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities.SupportsTransactions Property

LocalFileSystemCapabilities SupportsTransactions Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsTransactions { get; }
public bool SupportsTransactions { get; }
Public ReadOnly Property SupportsTransactions As Boolean
    Get
Public ReadOnly Property SupportsTransactions As Boolean
    Get
public:
virtual property bool SupportsTransactions {
    bool get () sealed;
}
public:
virtual property bool SupportsTransactions {
    bool get () sealed;
}
abstract SupportsTransactions : bool with get
override SupportsTransactions : bool with get
abstract SupportsTransactions : bool with get
override SupportsTransactions : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsTransactions
See Also
LocalFileSystemCapabilities Class
LocalFileSystemCapabilities Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemCapabilities.SupportsVersioning Property

LocalFileSystemCapabilities SupportsVersioning Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsVersioning { get; }
public bool SupportsVersioning { get; }
Public ReadOnly Property SupportsVersioning As Boolean
    Get
Public ReadOnly Property SupportsVersioning As Boolean
    Get
public:
virtual property bool SupportsVersioning {
    bool get () sealed;
}
public:
virtual property bool SupportsVersioning {
    bool get () sealed;
}
abstract SupportsVersioning : bool with get
override SupportsVersioning : bool with get
abstract SupportsVersioning : bool with get
override SupportsVersioning : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsVersioning
See Also
LocalFileSystemCapabilities Class
LocalFileSystemCapabilities Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemStream Class

LocalFileSystemStream Class NFX Class Library

Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.IO Stream
NFX.IO.FileSystem FileSystemStream
NFX.IO.FileSystem.Local LocalFileSystemStream

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class LocalFileSystemStream : FileSystemStream
internal class LocalFileSystemStream : FileSystemStream
Friend Class LocalFileSystemStream
    Inherits FileSystemStream
Friend Class LocalFileSystemStream
    Inherits FileSystemStream
internal ref class LocalFileSystemStream : public FileSystemStream
internal ref class LocalFileSystemStream : public FileSystemStream
type LocalFileSystemStream =
    class
        inherit FileSystemStream
    end
type LocalFileSystemStream =
    class
        inherit FileSystemStream
    end
See Also
LocalFileSystemStream Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemStream Members

LocalFileSystemStream Members NFX Class Library

The LocalFileSystemStream type exposes the following members.
Constructors
 | Name | Description
Public method | LocalFileSystemStream | Initializes a new instance of the LocalFileSystemStream class
Back to Top
Methods
 | Name | Description
Public method | Online BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Online Stream.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Protected method | Online CreateWaitHandle | Obsolete. Allocates a Online WaitHandle object. (Inherited from Online Stream.)
Public method | Online Dispose | Releases all resources used by the Online Stream. (Inherited from Online Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the LocalFileSystemStream and optionally releases the managed resources (Overrides FileSystemStream Dispose(Boolean).)
Protected method | DoFlush | (Overrides FileSystemStream DoFlush .)
Protected method | DoGetLength | (Overrides FileSystemStream DoGetLength .)
Protected method | DoGetPosition | (Overrides FileSystemStream DoGetPosition .)
Protected method | DoRead | (Overrides FileSystemStream DoRead( Byte , Int32, Int32).)
Protected method | DoSeek | (Overrides FileSystemStream DoSeek(Int64, SeekOrigin).)
Protected method | DoSetLength | (Overrides FileSystemStream DoSetLength(Int64).)
Protected method | DoSetPosition | (Overrides FileSystemStream DoSetPosition(Int64).)
Protected method | DoWrite | (Overrides FileSystemStream DoWrite( Byte , Int32, Int32).)
Public method | Online EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Inherited from FileSystemStream.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Online Stream.)
Public method | FlushAsync(CancellationToken) | (Inherited from FileSystemStream.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Online Stream.)
Public method | Read | (Inherited from FileSystemStream.)
Public method | ReadAsync( Byte , Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Online Stream.)
Public method | ReadAsync( Byte , Int32, Int32, CancellationToken) | (Inherited from FileSystemStream.)
Public method | Online ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Online Stream.)
Public method | Seek | (Inherited from FileSystemStream.)
Public method | SetLength | (Inherited from FileSystemStream.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write | (Inherited from FileSystemStream.)
Public method | WriteAsync( Byte , Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Online Stream.)
Public method | WriteAsync( Byte , Int32, Int32, CancellationToken) | (Inherited from FileSystemStream.)
Public method | Online WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Online Stream.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsCharEnumerable | (Defined by IOMiscUtils.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Public Extension Method | ReadBEInt32 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEShort | Reads a short encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUInt64 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUShort | Reads an ushort encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadSLEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadSLEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | WriteBEInt32 | Writes an integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEShort | Writes a short encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUInt64 | Writes an unsigned long integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUShort | Writes an ushort encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteSLEB128(Int64, Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteSLEB128(Int64, Int32 , Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, UInt32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, Int32 , UInt32) | Overloaded. (Defined by LEB128.)
Back to Top
Fields
 | Name | Description
Public field | Item | Item that this stream is for (Inherited from FileSystemStream.)
Back to Top
Properties
 | Name | Description
Public property | CanRead | (Inherited from FileSystemStream.)
Public property | CanSeek | (Inherited from FileSystemStream.)
Public property | Online CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Online Stream.)
Public property | CanWrite | (Inherited from FileSystemStream.)
Public property | Length | (Inherited from FileSystemStream.)
Public property | Position | (Inherited from FileSystemStream.)
Public property | Online ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Online Stream.)
Public property | Online WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Online Stream.)
Back to Top
See Also
LocalFileSystemStream Class
NFX.IO.FileSystem.Local Namespace


LocalFileSystemStream Constructor

LocalFileSystemStream Constructor NFX Class Library

Initializes a new instance of the LocalFileSystemStream class

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LocalFileSystemStream(
    FileSystemFile file,
    Action<FileSystemStream> disposeAction
)
public LocalFileSystemStream(
    FileSystemFile file,
    Action<FileSystemStream> disposeAction
)
Public Sub New (
    file As FileSystemFile,
    disposeAction As Action(Of FileSystemStream)
)
Public Sub New (
    file As FileSystemFile,
    disposeAction As Action(Of FileSystemStream)
)
public:
LocalFileSystemStream(
    FileSystemFile^ file,
    Action<FileSystemStream^>^ disposeAction
)
public:
LocalFileSystemStream(
    FileSystemFile^ file,
    Action<FileSystemStream^>^ disposeAction
)
new :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> LocalFileSystemStream
new :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> LocalFileSystemStream

Parameters

file
Type: NFX.IO.FileSystem FileSystemFile
disposeAction
Type: Online System Action FileSystemStream
See Also
LocalFileSystemStream Class
LocalFileSystemStream Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemStream Fields

LocalFileSystemStream Fields NFX Class Library

The LocalFileSystemStream type exposes the following members.
Fields
 | Name | Description
Public field | Item | Item that this stream is for (Inherited from FileSystemStream.)
Back to Top
See Also
LocalFileSystemStream Class
NFX.IO.FileSystem.Local Namespace


LocalFileSystemStream Methods

LocalFileSystemStream Methods NFX Class Library

The LocalFileSystemStream type exposes the following members.
Methods
 | Name | Description
Public method | Online BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Online Stream.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Protected method | Online CreateWaitHandle | Obsolete. Allocates a Online WaitHandle object. (Inherited from Online Stream.)
Public method | Online Dispose | Releases all resources used by the Online Stream. (Inherited from Online Stream.)
Protected method | Dispose(Boolean) | (Overrides FileSystemStream Dispose(Boolean).)
Protected method | DoFlush | (Overrides FileSystemStream DoFlush .)
Protected method | DoGetLength | (Overrides FileSystemStream DoGetLength .)
Protected method | DoGetPosition | (Overrides FileSystemStream DoGetPosition .)
Protected method | DoRead | (Overrides FileSystemStream DoRead( Byte , Int32, Int32).)
Protected method | DoSeek | (Overrides FileSystemStream DoSeek(Int64, SeekOrigin).)
Protected method | DoSetLength | (Overrides FileSystemStream DoSetLength(Int64).)
Protected method | DoSetPosition | (Overrides FileSystemStream DoSetPosition(Int64).)
Protected method | DoWrite | (Overrides FileSystemStream DoWrite( Byte , Int32, Int32).)
Public method | Online EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Inherited from FileSystemStream.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Online Stream.)
Public method | FlushAsync(CancellationToken) | (Inherited from FileSystemStream.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Online Stream.)
Public method | Read | (Inherited from FileSystemStream.)
Public method | ReadAsync( Byte , Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Online Stream.)
Public method | ReadAsync( Byte , Int32, Int32, CancellationToken) | (Inherited from FileSystemStream.)
Public method | Online ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Online Stream.)
Public method | Seek | (Inherited from FileSystemStream.)
Public method | SetLength | (Inherited from FileSystemStream.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write | (Inherited from FileSystemStream.)
Public method | WriteAsync( Byte , Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Online Stream.)
Public method | WriteAsync( Byte , Int32, Int32, CancellationToken) | (Inherited from FileSystemStream.)
Public method | Online WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Online Stream.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsCharEnumerable | (Defined by IOMiscUtils.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Public Extension Method | ReadBEInt32 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEShort | Reads a short encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUInt64 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUShort | Reads an ushort encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadSLEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadSLEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | WriteBEInt32 | Writes an integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEShort | Writes a short encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUInt64 | Writes an unsigned long integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUShort | Writes an ushort encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteSLEB128(Int64, Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteSLEB128(Int64, Int32 , Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, UInt32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, Int32 , UInt32) | Overloaded. (Defined by LEB128.)
Back to Top
See Also
LocalFileSystemStream Class
NFX.IO.FileSystem.Local Namespace


LocalFileSystemStream.Dispose Method

LocalFileSystemStream Dispose Method NFX Class Library

Overload List
 | Name | Description
Public method | Online Dispose | Releases all resources used by the Online Stream. (Inherited from Online Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the LocalFileSystemStream and optionally releases the managed resources (Overrides FileSystemStream Dispose(Boolean).)
Back to Top
See Also
LocalFileSystemStream Class
LocalFileSystemStream Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemStream.Dispose Method (Boolean)

LocalFileSystemStream Dispose Method (Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Releases the unmanaged resources used by the LocalFileSystemStream and optionally releases the managed resources

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
LocalFileSystemStream Class
LocalFileSystemStream Members
Dispose Overload
NFX.IO.FileSystem.Local Namespace


LocalFileSystemStream.DoFlush Method

LocalFileSystemStream DoFlush Method NFX Class Library

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoFlush()
protected override void DoFlush()
Protected Overrides Sub DoFlush
Protected Overrides Sub DoFlush
protected:
virtual void DoFlush() override
protected:
virtual void DoFlush() override
abstract DoFlush : unit -> unit
override DoFlush : unit -> unit
abstract DoFlush : unit -> unit
override DoFlush : unit -> unit
See Also
LocalFileSystemStream Class
LocalFileSystemStream Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemStream.DoGetLength Method

LocalFileSystemStream DoGetLength Method NFX Class Library

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override long DoGetLength()
protected override long DoGetLength()
Protected Overrides Function DoGetLength As Long
Protected Overrides Function DoGetLength As Long
protected:
virtual long long DoGetLength() override
protected:
virtual long long DoGetLength() override
abstract DoGetLength : unit -> int64
override DoGetLength : unit -> int64
abstract DoGetLength : unit -> int64
override DoGetLength : unit -> int64

Return Value

Type: Online Int64
See Also
LocalFileSystemStream Class
LocalFileSystemStream Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemStream.DoGetPosition Method

LocalFileSystemStream DoGetPosition Method NFX Class Library

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override long DoGetPosition()
protected override long DoGetPosition()
Protected Overrides Function DoGetPosition As Long
Protected Overrides Function DoGetPosition As Long
protected:
virtual long long DoGetPosition() override
protected:
virtual long long DoGetPosition() override
abstract DoGetPosition : unit -> int64
override DoGetPosition : unit -> int64
abstract DoGetPosition : unit -> int64
override DoGetPosition : unit -> int64

Return Value

Type: Online Int64
See Also
LocalFileSystemStream Class
LocalFileSystemStream Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemStream.DoRead Method

LocalFileSystemStream DoRead Method NFX Class Library

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override int DoRead(
    byte[] buffer,
    int offset,
    int count
)
protected override int DoRead(
    byte[] buffer,
    int offset,
    int count
)
Protected Overrides Function DoRead (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
Protected Overrides Function DoRead (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
protected:
virtual int DoRead(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
protected:
virtual int DoRead(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract DoRead :
        buffer : byte[] *
        offset : int *
        count : int -> int
override DoRead :
        buffer : byte[] *
        offset : int *
        count : int -> int
abstract DoRead :
        buffer : byte[] *
        offset : int *
        count : int -> int
override DoRead :
        buffer : byte[] *
        offset : int *
        count : int -> int

Parameters

buffer
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32

Return Value

Type: Online Int32
See Also
LocalFileSystemStream Class
LocalFileSystemStream Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemStream.DoSeek Method

LocalFileSystemStream DoSeek Method NFX Class Library

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override long DoSeek(
    long offset,
    SeekOrigin origin
)
protected override long DoSeek(
    long offset,
    SeekOrigin origin
)
Protected Overrides Function DoSeek (
    offset As Long,
    origin As SeekOrigin
) As Long
Protected Overrides Function DoSeek (
    offset As Long,
    origin As SeekOrigin
) As Long
protected:
virtual long long DoSeek(
    long long offset,
    SeekOrigin origin
) override
protected:
virtual long long DoSeek(
    long long offset,
    SeekOrigin origin
) override
abstract DoSeek :
        offset : int64 *
        origin : SeekOrigin -> int64
override DoSeek :
        offset : int64 *
        origin : SeekOrigin -> int64
abstract DoSeek :
        offset : int64 *
        origin : SeekOrigin -> int64
override DoSeek :
        offset : int64 *
        origin : SeekOrigin -> int64

Parameters

offset
Type: Online System Int64
origin
Type: Online System.IO SeekOrigin

Return Value

Type: Online Int64
See Also
LocalFileSystemStream Class
LocalFileSystemStream Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemStream.DoSetLength Method

LocalFileSystemStream DoSetLength Method NFX Class Library

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSetLength(
    long value
)
protected override void DoSetLength(
    long value
)
Protected Overrides Sub DoSetLength (
    value As Long
)
Protected Overrides Sub DoSetLength (
    value As Long
)
protected:
virtual void DoSetLength(
    long long value
) override
protected:
virtual void DoSetLength(
    long long value
) override
abstract DoSetLength :
        value : int64 -> unit
override DoSetLength :
        value : int64 -> unit
abstract DoSetLength :
        value : int64 -> unit
override DoSetLength :
        value : int64 -> unit

Parameters

value
Type: Online System Int64
See Also
LocalFileSystemStream Class
LocalFileSystemStream Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemStream.DoSetPosition Method

LocalFileSystemStream DoSetPosition Method NFX Class Library

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSetPosition(
    long position
)
protected override void DoSetPosition(
    long position
)
Protected Overrides Sub DoSetPosition (
    position As Long
)
Protected Overrides Sub DoSetPosition (
    position As Long
)
protected:
virtual void DoSetPosition(
    long long position
) override
protected:
virtual void DoSetPosition(
    long long position
) override
abstract DoSetPosition :
        position : int64 -> unit
override DoSetPosition :
        position : int64 -> unit
abstract DoSetPosition :
        position : int64 -> unit
override DoSetPosition :
        position : int64 -> unit

Parameters

position
Type: Online System Int64
See Also
LocalFileSystemStream Class
LocalFileSystemStream Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemStream.DoWrite Method

LocalFileSystemStream DoWrite Method NFX Class Library

Namespace: NFX.IO.FileSystem.Local
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWrite(
    byte[] buffer,
    int offset,
    int count
)
protected override void DoWrite(
    byte[] buffer,
    int offset,
    int count
)
Protected Overrides Sub DoWrite (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
Protected Overrides Sub DoWrite (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
protected:
virtual void DoWrite(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
protected:
virtual void DoWrite(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract DoWrite :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override DoWrite :
        buffer : byte[] *
        offset : int *
        count : int -> unit
abstract DoWrite :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override DoWrite :
        buffer : byte[] *
        offset : int *
        count : int -> unit

Parameters

buffer
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32
See Also
LocalFileSystemStream Class
LocalFileSystemStream Members
NFX.IO.FileSystem.Local Namespace


LocalFileSystemStream Properties

LocalFileSystemStream Properties NFX Class Library

The LocalFileSystemStream type exposes the following members.
Properties
 | Name | Description
Public property | CanRead | (Inherited from FileSystemStream.)
Public property | CanSeek | (Inherited from FileSystemStream.)
Public property | Online CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Online Stream.)
Public property | CanWrite | (Inherited from FileSystemStream.)
Public property | Length | (Inherited from FileSystemStream.)
Public property | Position | (Inherited from FileSystemStream.)
Public property | Online ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Online Stream.)
Public property | Online WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Online Stream.)
Back to Top
See Also
LocalFileSystemStream Class
NFX.IO.FileSystem.Local Namespace


NFX.IO.FileSystem.Packaging Namespace

NFX.IO.FileSystem.Packaging Namespace NFX Class Library

Classes
 | Class | Description
Public class | LocalInstallation | Represents the local installation - facilitates working with locally installed packages
Public class | LocalInstallation PackageInfo | Provides package descriptor
Public class | ManifestUtils | Provides utilities for manifest generation


LocalInstallation Class

LocalInstallation Class NFX Class Library

Represents the local installation - facilitates working with locally installed packages
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.IO.FileSystem.Packaging LocalInstallation

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LocalInstallation : DisposableObject
public class LocalInstallation : DisposableObject
Public Class LocalInstallation
    Inherits DisposableObject
Public Class LocalInstallation
    Inherits DisposableObject
public ref class LocalInstallation : public DisposableObject
public ref class LocalInstallation : public DisposableObject
type LocalInstallation =
    class
        inherit DisposableObject
    end
type LocalInstallation =
    class
        inherit DisposableObject
    end
See Also
LocalInstallation Members
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation Members

LocalInstallation Members NFX Class Library

The LocalInstallation type exposes the following members.
Constructors
 | Name | Description
Public method | LocalInstallation | Initializes local installation, tries to read local manifest from rootPath or localManifestDir if it is !=null
Back to Top
Methods
 | Name | Description
Public method | BeginInstallation | Starts the installation so InstallPackage() can be called
Public method | CheckLocalAndInstallIfNeeded | Checks local installation first for missing of different packages and if there are no differences then returns false, otherwise re-installs all packages defined by in install-set locally and returns true. Pass force=true to re-install regardless of manifest comparison (false by default)
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EndInstallation | Updates local installation manifest if changes have been made (Modified=true)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | FindMissingOrDifferentPackage | Finds a package form the install set which is either missing on local machine or is not the same as the one in installSet. Returns the package info from install set
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | InstallPackage | Unconditionally installs a package - copies a set of files contained in the FileSystemDirectory assigning it some mnemonic name
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | InstallationStarted | Returns true to indicate that BeginInstallation() has been called
Public property | Item | Returns installed package manifest by name or null
Public property | Modified | Returns true to indicate that local installation has changed as the result of package installation
Public property | PackageManifests | Gets package manifests
Public property | PackageNames | Gets package names
Public property | RootPath | Root path of the installation
Back to Top
See Also
LocalInstallation Class
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation Constructor

LocalInstallation Constructor NFX Class Library

Initializes local installation, tries to read local manifest from rootPath or localManifestDir if it is !=null

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LocalInstallation(
    string rootPath,
    string localManifestDir = null
)
public LocalInstallation(
    string rootPath,
    string localManifestDir = null
)
Public Sub New (
    rootPath As String,
    Optional localManifestDir As String = Nothing
)
Public Sub New (
    rootPath As String,
    Optional localManifestDir As String = Nothing
)
public:
LocalInstallation(
    String^ rootPath,
    String^ localManifestDir = nullptr
)
public:
LocalInstallation(
    String^ rootPath,
    String^ localManifestDir = nullptr
)
new :
        rootPath : string *
        ?localManifestDir : string
(* Defaults:
        let _localManifestDir = defaultArg localManifestDir null
*)
-> LocalInstallation
new :
        rootPath : string *
        ?localManifestDir : string
(* Defaults:
        let _localManifestDir = defaultArg localManifestDir null
*)
-> LocalInstallation

Parameters

rootPath
Type: Online System String
localManifestDir (Optional)
Type: Online System String
See Also
LocalInstallation Class
LocalInstallation Members
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation Methods

LocalInstallation Methods NFX Class Library

The LocalInstallation type exposes the following members.
Methods
 | Name | Description
Public method | BeginInstallation | Starts the installation so InstallPackage() can be called
Public method | CheckLocalAndInstallIfNeeded | Checks local installation first for missing of different packages and if there are no differences then returns false, otherwise re-installs all packages defined by in install-set locally and returns true. Pass force=true to re-install regardless of manifest comparison (false by default)
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EndInstallation | Updates local installation manifest if changes have been made (Modified=true)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | FindMissingOrDifferentPackage | Finds a package form the install set which is either missing on local machine or is not the same as the one in installSet. Returns the package info from install set
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | InstallPackage | Unconditionally installs a package - copies a set of files contained in the FileSystemDirectory assigning it some mnemonic name
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LocalInstallation Class
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation.BeginInstallation Method

LocalInstallation BeginInstallation Method NFX Class Library

Starts the installation so InstallPackage() can be called

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void BeginInstallation()
public void BeginInstallation()
Public Sub BeginInstallation
Public Sub BeginInstallation
public:
void BeginInstallation()
public:
void BeginInstallation()
member BeginInstallation : unit -> unit
member BeginInstallation : unit -> unit
See Also
LocalInstallation Class
LocalInstallation Members
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation.CheckLocalAndInstallIfNeeded Method

LocalInstallation CheckLocalAndInstallIfNeeded Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Checks local installation first for missing of different packages and if there are no differences then returns false, otherwise re-installs all packages defined by in install-set locally and returns true. Pass force=true to re-install regardless of manifest comparison (false by default)

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool CheckLocalAndInstallIfNeeded(
    IEnumerable<LocalInstallation..::..PackageInfo> installSet,
    bool force = false
)
public bool CheckLocalAndInstallIfNeeded(
    IEnumerable<LocalInstallation..::..PackageInfo> installSet,
    bool force = false
)
Public Function CheckLocalAndInstallIfNeeded (
    installSet As IEnumerable(Of LocalInstallation..::..PackageInfo),
    Optional force As Boolean = false
) As Boolean
Public Function CheckLocalAndInstallIfNeeded (
    installSet As IEnumerable(Of LocalInstallation..::..PackageInfo),
    Optional force As Boolean = false
) As Boolean
public:
bool CheckLocalAndInstallIfNeeded(
    IEnumerable<LocalInstallation..::..PackageInfo^>^ installSet,
    bool force = false
)
public:
bool CheckLocalAndInstallIfNeeded(
    IEnumerable<LocalInstallation..::..PackageInfo^>^ installSet,
    bool force = false
)
member CheckLocalAndInstallIfNeeded :
        installSet : IEnumerable<LocalInstallation..::..PackageInfo> *
        ?force : bool
(* Defaults:
        let _force = defaultArg force false
*)
-> bool
member CheckLocalAndInstallIfNeeded :
        installSet : IEnumerable<LocalInstallation..::..PackageInfo> *
        ?force : bool
(* Defaults:
        let _force = defaultArg force false
*)
-> bool

Parameters

installSet
Type: Online System.Collections.Generic IEnumerable LocalInstallation PackageInfo
force (Optional)
Type: Online System Boolean

Return Value

Type: Online Boolean
See Also
LocalInstallation Class
LocalInstallation Members
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation.Destructor Method

LocalInstallation Destructor Method NFX Class Library

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
LocalInstallation Class
LocalInstallation Members
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation.EndInstallation Method

LocalInstallation EndInstallation Method NFX Class Library

Updates local installation manifest if changes have been made (Modified=true)

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void EndInstallation()
public void EndInstallation()
Public Sub EndInstallation
Public Sub EndInstallation
public:
void EndInstallation()
public:
void EndInstallation()
member EndInstallation : unit -> unit
member EndInstallation : unit -> unit
See Also
LocalInstallation Class
LocalInstallation Members
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation.FindMissingOrDifferentPackage Method

LocalInstallation FindMissingOrDifferentPackage Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Finds a package form the install set which is either missing on local machine or is not the same as the one in installSet. Returns the package info from install set

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LocalInstallation..::..PackageInfo FindMissingOrDifferentPackage(
    IEnumerable<LocalInstallation..::..PackageInfo> installSet
)
public LocalInstallation..::..PackageInfo FindMissingOrDifferentPackage(
    IEnumerable<LocalInstallation..::..PackageInfo> installSet
)
Public Function FindMissingOrDifferentPackage (
    installSet As IEnumerable(Of LocalInstallation..::..PackageInfo)
) As LocalInstallation..::..PackageInfo
Public Function FindMissingOrDifferentPackage (
    installSet As IEnumerable(Of LocalInstallation..::..PackageInfo)
) As LocalInstallation..::..PackageInfo
public:
LocalInstallation..::..PackageInfo^ FindMissingOrDifferentPackage(
    IEnumerable<LocalInstallation..::..PackageInfo^>^ installSet
)
public:
LocalInstallation..::..PackageInfo^ FindMissingOrDifferentPackage(
    IEnumerable<LocalInstallation..::..PackageInfo^>^ installSet
)
member FindMissingOrDifferentPackage :
        installSet : IEnumerable<LocalInstallation..::..PackageInfo> -> LocalInstallation..::..PackageInfo
member FindMissingOrDifferentPackage :
        installSet : IEnumerable<LocalInstallation..::..PackageInfo> -> LocalInstallation..::..PackageInfo

Parameters

installSet
Type: Online System.Collections.Generic IEnumerable LocalInstallation PackageInfo

Return Value

Type: LocalInstallation PackageInfo
See Also
LocalInstallation Class
LocalInstallation Members
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation.InstallPackage Method

LocalInstallation InstallPackage Method NFX Class Library

Unconditionally installs a package - copies a set of files contained in the FileSystemDirectory assigning it some mnemonic name

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void InstallPackage(
    LocalInstallation..::..PackageInfo package
)
public void InstallPackage(
    LocalInstallation..::..PackageInfo package
)
Public Sub InstallPackage (
    package As LocalInstallation..::..PackageInfo
)
Public Sub InstallPackage (
    package As LocalInstallation..::..PackageInfo
)
public:
void InstallPackage(
    LocalInstallation..::..PackageInfo^ package
)
public:
void InstallPackage(
    LocalInstallation..::..PackageInfo^ package
)
member InstallPackage :
        package : LocalInstallation..::..PackageInfo -> unit
member InstallPackage :
        package : LocalInstallation..::..PackageInfo -> unit

Parameters

package
Type: NFX.IO.FileSystem.Packaging LocalInstallation PackageInfo
See Also
LocalInstallation Class
LocalInstallation Members
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation Properties

LocalInstallation Properties NFX Class Library

The LocalInstallation type exposes the following members.
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | InstallationStarted | Returns true to indicate that BeginInstallation() has been called
Public property | Item | Returns installed package manifest by name or null
Public property | Modified | Returns true to indicate that local installation has changed as the result of package installation
Public property | PackageManifests | Gets package manifests
Public property | PackageNames | Gets package names
Public property | RootPath | Root path of the installation
Back to Top
See Also
LocalInstallation Class
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation.InstallationStarted Property

LocalInstallation InstallationStarted Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns true to indicate that BeginInstallation() has been called

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool InstallationStarted { get; }
public bool InstallationStarted { get; }
Public ReadOnly Property InstallationStarted As Boolean
    Get
Public ReadOnly Property InstallationStarted As Boolean
    Get
public:
property bool InstallationStarted {
    bool get ();
}
public:
property bool InstallationStarted {
    bool get ();
}
member InstallationStarted : bool with get
member InstallationStarted : bool with get

Property Value

Type: Online Boolean
See Also
LocalInstallation Class
LocalInstallation Members
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation.Item Property

LocalInstallation Item Property NFX Class Library

Returns installed package manifest by name or null

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IConfigSectionNode this[
    string name
] { get; }
public IConfigSectionNode this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As IConfigSectionNode
    Get
Public ReadOnly Default Property Item (
    name As String
) As IConfigSectionNode
    Get
public:
property IConfigSectionNode^ default[String^ name] {
    IConfigSectionNode^ get (String^ name);
}
public:
property IConfigSectionNode^ default[String^ name] {
    IConfigSectionNode^ get (String^ name);
}
member Item : IConfigSectionNode with get
member Item : IConfigSectionNode with get

Parameters

name
Type: Online System String

Property Value

Type: IConfigSectionNode
See Also
LocalInstallation Class
LocalInstallation Members
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation.Modified Property

LocalInstallation Modified Property NFX Class Library

Returns true to indicate that local installation has changed as the result of package installation

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Modified { get; }
public bool Modified { get; }
Public ReadOnly Property Modified As Boolean
    Get
Public ReadOnly Property Modified As Boolean
    Get
public:
property bool Modified {
    bool get ();
}
public:
property bool Modified {
    bool get ();
}
member Modified : bool with get
member Modified : bool with get

Property Value

Type: Online Boolean
See Also
LocalInstallation Class
LocalInstallation Members
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation.PackageManifests Property

LocalInstallation PackageManifests Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets package manifests

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<IConfigSectionNode> PackageManifests { get; }
public IEnumerable<IConfigSectionNode> PackageManifests { get; }
Public ReadOnly Property PackageManifests As IEnumerable(Of IConfigSectionNode)
    Get
Public ReadOnly Property PackageManifests As IEnumerable(Of IConfigSectionNode)
    Get
public:
property IEnumerable<IConfigSectionNode^>^ PackageManifests {
    IEnumerable<IConfigSectionNode^>^ get ();
}
public:
property IEnumerable<IConfigSectionNode^>^ PackageManifests {
    IEnumerable<IConfigSectionNode^>^ get ();
}
member PackageManifests : IEnumerable<IConfigSectionNode> with get
member PackageManifests : IEnumerable<IConfigSectionNode> with get

Property Value

Type: Online IEnumerable IConfigSectionNode
See Also
LocalInstallation Class
LocalInstallation Members
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation.PackageNames Property

LocalInstallation PackageNames Property NFX Class Library

Gets package names

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<string> PackageNames { get; }
public IEnumerable<string> PackageNames { get; }
Public ReadOnly Property PackageNames As IEnumerable(Of String)
    Get
Public ReadOnly Property PackageNames As IEnumerable(Of String)
    Get
public:
property IEnumerable<String^>^ PackageNames {
    IEnumerable<String^>^ get ();
}
public:
property IEnumerable<String^>^ PackageNames {
    IEnumerable<String^>^ get ();
}
member PackageNames : IEnumerable<string> with get
member PackageNames : IEnumerable<string> with get

Property Value

Type: Online IEnumerable Online String
See Also
LocalInstallation Class
LocalInstallation Members
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation.RootPath Property

LocalInstallation RootPath Property NFX Class Library

Root path of the installation

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string RootPath { get; }
public string RootPath { get; }
Public ReadOnly Property RootPath As String
    Get
Public ReadOnly Property RootPath As String
    Get
public:
property String^ RootPath {
    String^ get ();
}
public:
property String^ RootPath {
    String^ get ();
}
member RootPath : string with get
member RootPath : string with get

Property Value

Type: Online String
See Also
LocalInstallation Class
LocalInstallation Members
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation.PackageInfo Class

LocalInstallation PackageInfo Class NFX Class Library

Provides package descriptor
Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.Packaging LocalInstallation PackageInfo

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PackageInfo
public class PackageInfo
Public Class PackageInfo
Public Class PackageInfo
public ref class PackageInfo
public ref class PackageInfo
type PackageInfo =  class end
type PackageInfo =  class end
See Also
LocalInstallation PackageInfo Members
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation.PackageInfo Members

LocalInstallation PackageInfo Members NFX Class Library

The LocalInstallation PackageInfo type exposes the following members.
Constructors
 | Name | Description
Public method | LocalInstallation PackageInfo | Provides package descriptor
Back to Top
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Manifest |
Public field | Name |
Public field | RelativePath |
Public field | Source |
Back to Top
See Also
LocalInstallation PackageInfo Class
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation.PackageInfo Constructor

LocalInstallation PackageInfo Constructor NFX Class Library

Provides package descriptor

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PackageInfo(
    string name,
    FileSystemDirectory source,
    string relPath
)
public PackageInfo(
    string name,
    FileSystemDirectory source,
    string relPath
)
Public Sub New (
    name As String,
    source As FileSystemDirectory,
    relPath As String
)
Public Sub New (
    name As String,
    source As FileSystemDirectory,
    relPath As String
)
public:
PackageInfo(
    String^ name,
    FileSystemDirectory^ source,
    String^ relPath
)
public:
PackageInfo(
    String^ name,
    FileSystemDirectory^ source,
    String^ relPath
)
new :
        name : string *
        source : FileSystemDirectory *
        relPath : string -> PackageInfo
new :
        name : string *
        source : FileSystemDirectory *
        relPath : string -> PackageInfo

Parameters

name
Type: Online System String
Mnemonic name of the package (i.e. application name)
source
Type: NFX.IO.FileSystem FileSystemDirectory
Source directory where to take files from
relPath
Type: Online System String
Relative path which is appended to the root path where files will be placed
See Also
LocalInstallation PackageInfo Class
LocalInstallation PackageInfo Members
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation.PackageInfo Fields

LocalInstallation PackageInfo Fields NFX Class Library

The LocalInstallation PackageInfo type exposes the following members.
Fields
 | Name | Description
Public field | Manifest |
Public field | Name |
Public field | RelativePath |
Public field | Source |
Back to Top
See Also
LocalInstallation PackageInfo Class
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation.PackageInfo.Manifest Field

LocalInstallation PackageInfo Manifest Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly IConfigSectionNode Manifest
public readonly IConfigSectionNode Manifest
Public ReadOnly Manifest As IConfigSectionNode
Public ReadOnly Manifest As IConfigSectionNode
public:
initonly IConfigSectionNode^ Manifest
public:
initonly IConfigSectionNode^ Manifest
val Manifest: IConfigSectionNode
val Manifest: IConfigSectionNode

Field Value

Type: IConfigSectionNode
See Also
LocalInstallation PackageInfo Class
LocalInstallation PackageInfo Members
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation.PackageInfo.Name Field

LocalInstallation PackageInfo Name Field NFX Class Library

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Name
public readonly string Name
Public ReadOnly Name As String
Public ReadOnly Name As String
public:
initonly String^ Name
public:
initonly String^ Name
val Name: string
val Name: string

Field Value

Type: Online String
See Also
LocalInstallation PackageInfo Class
LocalInstallation PackageInfo Members
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation.PackageInfo.RelativePath Field

LocalInstallation PackageInfo RelativePath Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string RelativePath
public readonly string RelativePath
Public ReadOnly RelativePath As String
Public ReadOnly RelativePath As String
public:
initonly String^ RelativePath
public:
initonly String^ RelativePath
val RelativePath: string
val RelativePath: string

Field Value

Type: Online String
See Also
LocalInstallation PackageInfo Class
LocalInstallation PackageInfo Members
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation.PackageInfo.Source Field

LocalInstallation PackageInfo Source Field NFX Class Library

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly FileSystemDirectory Source
public readonly FileSystemDirectory Source
Public ReadOnly Source As FileSystemDirectory
Public ReadOnly Source As FileSystemDirectory
public:
initonly FileSystemDirectory^ Source
public:
initonly FileSystemDirectory^ Source
val Source: FileSystemDirectory
val Source: FileSystemDirectory

Field Value

Type: FileSystemDirectory
See Also
LocalInstallation PackageInfo Class
LocalInstallation PackageInfo Members
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation.PackageInfo Methods

LocalInstallation PackageInfo Methods NFX Class Library

The LocalInstallation PackageInfo type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LocalInstallation PackageInfo Class
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation.PackageInfo.Equals Method

LocalInstallation PackageInfo Equals Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
LocalInstallation PackageInfo Class
LocalInstallation PackageInfo Members
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation.PackageInfo.GetHashCode Method

LocalInstallation PackageInfo GetHashCode Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
LocalInstallation PackageInfo Class
LocalInstallation PackageInfo Members
NFX.IO.FileSystem.Packaging Namespace


LocalInstallation.PackageInfo.ToString Method

LocalInstallation PackageInfo ToString Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
LocalInstallation PackageInfo Class
LocalInstallation PackageInfo Members
NFX.IO.FileSystem.Packaging Namespace


ManifestUtils Class

ManifestUtils Class NFX Class Library

Provides utilities for manifest generation
Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.Packaging ManifestUtils

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class ManifestUtils
public static class ManifestUtils
<ExtensionAttribute>
Public NotInheritable Class ManifestUtils
<ExtensionAttribute>
Public NotInheritable Class ManifestUtils
[ExtensionAttribute]
public ref class ManifestUtils abstract sealed
[ExtensionAttribute]
public ref class ManifestUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ManifestUtils =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ManifestUtils =  class end
See Also
ManifestUtils Members
NFX.IO.FileSystem.Packaging Namespace


ManifestUtils Members

ManifestUtils Members NFX Class Library

The ManifestUtils type exposes the following members.
Methods
Name | Description
GeneratePackagingManifest | Generates packaging manifest for the specified directory. Optionally may specify root node name
HasTheSameContent | Returns true when both config nodes represents the same manifest - that is the same file structure
Back to Top
Fields
Name | Description
CONFIG_CSUM_ATTR |
CONFIG_DIR_SECTION |
CONFIG_FILE_SECTION |
CONFIG_LOCAL_PATH_ATTR |
CONFIG_NAME_ATTR |
CONFIG_PACKAGE_SECTION |
CONFIG_PACKAGES_SECTION |
CONFIG_SIZE_ATTR |
MANIFEST_FILE_NAME |
Back to Top
See Also
ManifestUtils Class
NFX.IO.FileSystem.Packaging Namespace


ManifestUtils Fields

ManifestUtils Fields NFX Class Library

The ManifestUtils type exposes the following members.
Fields
Name | Description
CONFIG_CSUM_ATTR |
CONFIG_DIR_SECTION |
CONFIG_FILE_SECTION |
CONFIG_LOCAL_PATH_ATTR |
CONFIG_NAME_ATTR |
CONFIG_PACKAGE_SECTION |
CONFIG_PACKAGES_SECTION |
CONFIG_SIZE_ATTR |
MANIFEST_FILE_NAME |
Back to Top
See Also
ManifestUtils Class
NFX.IO.FileSystem.Packaging Namespace


ManifestUtils.CONFIG_CSUM_ATTR Field

ManifestUtils CONFIG_CSUM_ATTR Field NFX Class Library

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CSUM_ATTR
public const string CONFIG_CSUM_ATTR
Public Const CONFIG_CSUM_ATTR As String
Public Const CONFIG_CSUM_ATTR As String
public:
literal String^ CONFIG_CSUM_ATTR
public:
literal String^ CONFIG_CSUM_ATTR
static val mutable CONFIG_CSUM_ATTR: string
static val mutable CONFIG_CSUM_ATTR: string

Field Value

Type: Online String
See Also
ManifestUtils Class
ManifestUtils Members
NFX.IO.FileSystem.Packaging Namespace


ManifestUtils.CONFIG_DIR_SECTION Field

ManifestUtils CONFIG_DIR_SECTION Field NFX Class Library

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_DIR_SECTION
public const string CONFIG_DIR_SECTION
Public Const CONFIG_DIR_SECTION As String
Public Const CONFIG_DIR_SECTION As String
public:
literal String^ CONFIG_DIR_SECTION
public:
literal String^ CONFIG_DIR_SECTION
static val mutable CONFIG_DIR_SECTION: string
static val mutable CONFIG_DIR_SECTION: string

Field Value

Type: Online String
See Also
ManifestUtils Class
ManifestUtils Members
NFX.IO.FileSystem.Packaging Namespace


ManifestUtils.CONFIG_FILE_SECTION Field

ManifestUtils CONFIG_FILE_SECTION Field NFX Class Library

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_FILE_SECTION
public const string CONFIG_FILE_SECTION
Public Const CONFIG_FILE_SECTION As String
Public Const CONFIG_FILE_SECTION As String
public:
literal String^ CONFIG_FILE_SECTION
public:
literal String^ CONFIG_FILE_SECTION
static val mutable CONFIG_FILE_SECTION: string
static val mutable CONFIG_FILE_SECTION: string

Field Value

Type: Online String
See Also
ManifestUtils Class
ManifestUtils Members
NFX.IO.FileSystem.Packaging Namespace


ManifestUtils.CONFIG_LOCAL_PATH_ATTR Field

ManifestUtils CONFIG_LOCAL_PATH_ATTR Field NFX Class Library

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_LOCAL_PATH_ATTR
public const string CONFIG_LOCAL_PATH_ATTR
Public Const CONFIG_LOCAL_PATH_ATTR As String
Public Const CONFIG_LOCAL_PATH_ATTR As String
public:
literal String^ CONFIG_LOCAL_PATH_ATTR
public:
literal String^ CONFIG_LOCAL_PATH_ATTR
static val mutable CONFIG_LOCAL_PATH_ATTR: string
static val mutable CONFIG_LOCAL_PATH_ATTR: string

Field Value

Type: Online String
See Also
ManifestUtils Class
ManifestUtils Members
NFX.IO.FileSystem.Packaging Namespace


ManifestUtils.CONFIG_NAME_ATTR Field

ManifestUtils CONFIG_NAME_ATTR Field NFX Class Library

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_NAME_ATTR
public const string CONFIG_NAME_ATTR
Public Const CONFIG_NAME_ATTR As String
Public Const CONFIG_NAME_ATTR As String
public:
literal String^ CONFIG_NAME_ATTR
public:
literal String^ CONFIG_NAME_ATTR
static val mutable CONFIG_NAME_ATTR: string
static val mutable CONFIG_NAME_ATTR: string

Field Value

Type: Online String
See Also
ManifestUtils Class
ManifestUtils Members
NFX.IO.FileSystem.Packaging Namespace


ManifestUtils.CONFIG_PACKAGE_SECTION Field

ManifestUtils CONFIG_PACKAGE_SECTION Field NFX Class Library

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PACKAGE_SECTION
public const string CONFIG_PACKAGE_SECTION
Public Const CONFIG_PACKAGE_SECTION As String
Public Const CONFIG_PACKAGE_SECTION As String
public:
literal String^ CONFIG_PACKAGE_SECTION
public:
literal String^ CONFIG_PACKAGE_SECTION
static val mutable CONFIG_PACKAGE_SECTION: string
static val mutable CONFIG_PACKAGE_SECTION: string

Field Value

Type: Online String
See Also
ManifestUtils Class
ManifestUtils Members
NFX.IO.FileSystem.Packaging Namespace


ManifestUtils.CONFIG_PACKAGES_SECTION Field

ManifestUtils CONFIG_PACKAGES_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PACKAGES_SECTION
public const string CONFIG_PACKAGES_SECTION
Public Const CONFIG_PACKAGES_SECTION As String
Public Const CONFIG_PACKAGES_SECTION As String
public:
literal String^ CONFIG_PACKAGES_SECTION
public:
literal String^ CONFIG_PACKAGES_SECTION
static val mutable CONFIG_PACKAGES_SECTION: string
static val mutable CONFIG_PACKAGES_SECTION: string

Field Value

Type: Online String
See Also
ManifestUtils Class
ManifestUtils Members
NFX.IO.FileSystem.Packaging Namespace


ManifestUtils.CONFIG_SIZE_ATTR Field

ManifestUtils CONFIG_SIZE_ATTR Field NFX Class Library

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SIZE_ATTR
public const string CONFIG_SIZE_ATTR
Public Const CONFIG_SIZE_ATTR As String
Public Const CONFIG_SIZE_ATTR As String
public:
literal String^ CONFIG_SIZE_ATTR
public:
literal String^ CONFIG_SIZE_ATTR
static val mutable CONFIG_SIZE_ATTR: string
static val mutable CONFIG_SIZE_ATTR: string

Field Value

Type: Online String
See Also
ManifestUtils Class
ManifestUtils Members
NFX.IO.FileSystem.Packaging Namespace


ManifestUtils.MANIFEST_FILE_NAME Field

ManifestUtils MANIFEST_FILE_NAME Field NFX Class Library

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string MANIFEST_FILE_NAME
public const string MANIFEST_FILE_NAME
Public Const MANIFEST_FILE_NAME As String
Public Const MANIFEST_FILE_NAME As String
public:
literal String^ MANIFEST_FILE_NAME
public:
literal String^ MANIFEST_FILE_NAME
static val mutable MANIFEST_FILE_NAME: string
static val mutable MANIFEST_FILE_NAME: string

Field Value

Type: Online String
See Also
ManifestUtils Class
ManifestUtils Members
NFX.IO.FileSystem.Packaging Namespace


ManifestUtils Methods

ManifestUtils Methods NFX Class Library

The ManifestUtils type exposes the following members.
Methods
Name | Description
GeneratePackagingManifest | Generates packaging manifest for the specified directory. Optionally may specify root node name
HasTheSameContent | Returns true when both config nodes represents the same manifest - that is the same file structure
Back to Top
See Also
ManifestUtils Class
NFX.IO.FileSystem.Packaging Namespace


ManifestUtils.GeneratePackagingManifest Method

ManifestUtils GeneratePackagingManifest Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Generates packaging manifest for the specified directory. Optionally may specify root node name

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ConfigSectionNode GeneratePackagingManifest(
    this FileSystemDirectory directory,
    string rootNodeName = null,
    string packageName = null,
    string packageLocalPath = null
)
public static ConfigSectionNode GeneratePackagingManifest(
    this FileSystemDirectory directory,
    string rootNodeName = null,
    string packageName = null,
    string packageLocalPath = null
)
<ExtensionAttribute>
Public Shared Function GeneratePackagingManifest (
    directory As FileSystemDirectory,
    Optional rootNodeName As String = Nothing,
    Optional packageName As String = Nothing,
    Optional packageLocalPath As String = Nothing
) As ConfigSectionNode
<ExtensionAttribute>
Public Shared Function GeneratePackagingManifest (
    directory As FileSystemDirectory,
    Optional rootNodeName As String = Nothing,
    Optional packageName As String = Nothing,
    Optional packageLocalPath As String = Nothing
) As ConfigSectionNode
public:
[ExtensionAttribute]
static ConfigSectionNode^ GeneratePackagingManifest(
    FileSystemDirectory^ directory,
    String^ rootNodeName = nullptr,
    String^ packageName = nullptr,
    String^ packageLocalPath = nullptr
)
public:
[ExtensionAttribute]
static ConfigSectionNode^ GeneratePackagingManifest(
    FileSystemDirectory^ directory,
    String^ rootNodeName = nullptr,
    String^ packageName = nullptr,
    String^ packageLocalPath = nullptr
)
static member GeneratePackagingManifest :
        directory : FileSystemDirectory *
        ?rootNodeName : string *
        ?packageName : string *
        ?packageLocalPath : string
(* Defaults:
        let _rootNodeName = defaultArg rootNodeName null
        let _packageName = defaultArg packageName null
        let _packageLocalPath = defaultArg packageLocalPath null
*)
-> ConfigSectionNode
static member GeneratePackagingManifest :
        directory : FileSystemDirectory *
        ?rootNodeName : string *
        ?packageName : string *
        ?packageLocalPath : string
(* Defaults:
        let _rootNodeName = defaultArg rootNodeName null
        let _packageName = defaultArg packageName null
        let _packageLocalPath = defaultArg packageLocalPath null
*)
-> ConfigSectionNode

Parameters

directory
Type: NFX.IO.FileSystem FileSystemDirectory
Source directory to generate manifest for
rootNodeName (Optional)
Type: Online System String
Name of root manifest node, if omitted then 'package' is defaulted
packageName (Optional)
Type: Online System String
Optional 'name' attribute value under root node
packageLocalPath (Optional)
Type: Online System String
Optional 'local-path' attribute value under root node

Return Value

Type: ConfigSectionNode

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type FileSystemDirectory. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ManifestUtils Class
ManifestUtils Members
NFX.IO.FileSystem.Packaging Namespace


ManifestUtils.HasTheSameContent Method

ManifestUtils HasTheSameContent Method NFX Class Library

Returns true when both config nodes represents the same manifest - that is the same file structure

Namespace: NFX.IO.FileSystem.Packaging
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool HasTheSameContent(
    this IConfigSectionNode master,
    IConfigSectionNode comparand,
    bool oneWay = false
)
public static bool HasTheSameContent(
    this IConfigSectionNode master,
    IConfigSectionNode comparand,
    bool oneWay = false
)
<ExtensionAttribute>
Public Shared Function HasTheSameContent (
    master As IConfigSectionNode,
    comparand As IConfigSectionNode,
    Optional oneWay As Boolean = false
) As Boolean
<ExtensionAttribute>
Public Shared Function HasTheSameContent (
    master As IConfigSectionNode,
    comparand As IConfigSectionNode,
    Optional oneWay As Boolean = false
) As Boolean
public:
[ExtensionAttribute]
static bool HasTheSameContent(
    IConfigSectionNode^ master,
    IConfigSectionNode^ comparand,
    bool oneWay = false
)
public:
[ExtensionAttribute]
static bool HasTheSameContent(
    IConfigSectionNode^ master,
    IConfigSectionNode^ comparand,
    bool oneWay = false
)
static member HasTheSameContent :
        master : IConfigSectionNode *
        comparand : IConfigSectionNode *
        ?oneWay : bool
(* Defaults:
        let _oneWay = defaultArg oneWay false
*)
-> bool
static member HasTheSameContent :
        master : IConfigSectionNode *
        comparand : IConfigSectionNode *
        ?oneWay : bool
(* Defaults:
        let _oneWay = defaultArg oneWay false
*)
-> bool

Parameters

master
Type: NFX.Environment IConfigSectionNode
Master sample copy
comparand
Type: NFX.Environment IConfigSectionNode
The second manifest being compared to the master
oneWay (Optional)
Type: Online System Boolean
If true iterates on master, so extra files in comparand will not be detected. False by default in whoch case iterates on master first then on comparand

Return Value

Type: Online Boolean
True when comparand has all files/directories that the master lists

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IConfigSectionNode. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
ManifestUtils Class
ManifestUtils Members
NFX.IO.FileSystem.Packaging Namespace


NFX.IO.FileSystem.S3 Namespace

NFX.IO.FileSystem.S3 Namespace NFX Class Library

Classes
 | Class | Description
Public class | S3Credentials | Represents Amazon S3 credentials (access key and secret key)


S3Credentials Class

S3Credentials Class NFX Class Library

Represents Amazon S3 credentials (access key and secret key)
Inheritance Hierarchy
Online System Object
NFX.Security Credentials
NFX.IO.FileSystem.S3 S3Credentials

Namespace: NFX.IO.FileSystem.S3
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class S3Credentials : Credentials
[SerializableAttribute]
public class S3Credentials : Credentials
<SerializableAttribute>
Public Class S3Credentials
    Inherits Credentials
<SerializableAttribute>
Public Class S3Credentials
    Inherits Credentials
[SerializableAttribute]
public ref class S3Credentials : public Credentials
[SerializableAttribute]
public ref class S3Credentials : public Credentials
[<SerializableAttribute>]
type S3Credentials =
    class
        inherit Credentials
    end
[<SerializableAttribute>]
type S3Credentials =
    class
        inherit Credentials
    end
See Also
S3Credentials Members
NFX.IO.FileSystem.S3 Namespace


S3Credentials Members

S3Credentials Members NFX Class Library

The S3Credentials type exposes the following members.
Constructors
 | Name | Description
Public method | S3Credentials | Initializes a new instance of the S3Credentials class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Forget | Deletes sensitive information (such as password). This method is mostly used on client (vs. server) to prevent process memory-inspection attack. Its is usually called right after Login() was called. Implementers may consider forcing post-factum GC.Collect() on all generations to make sure that orphaned memory buff with sensitive information, that remains in RAM even after all references are killed, gets compacted; consequently, this method may take considerable time to execute. (Inherited from Credentials.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | AccessKey |
Public property | Forgotten | Indicates whether Forget() was called on this instance (Inherited from Credentials.)
Public property | SecretKey |
Back to Top
See Also
S3Credentials Class
NFX.IO.FileSystem.S3 Namespace


S3Credentials Constructor

S3Credentials Constructor NFX Class Library

Initializes a new instance of the S3Credentials class

Namespace: NFX.IO.FileSystem.S3
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public S3Credentials(
    string accessKey,
    string secretKey
)
public S3Credentials(
    string accessKey,
    string secretKey
)
Public Sub New (
    accessKey As String,
    secretKey As String
)
Public Sub New (
    accessKey As String,
    secretKey As String
)
public:
S3Credentials(
    String^ accessKey,
    String^ secretKey
)
public:
S3Credentials(
    String^ accessKey,
    String^ secretKey
)
new :
        accessKey : string *
        secretKey : string -> S3Credentials
new :
        accessKey : string *
        secretKey : string -> S3Credentials

Parameters

accessKey
Type: Online System String
secretKey
Type: Online System String
See Also
S3Credentials Class
S3Credentials Members
NFX.IO.FileSystem.S3 Namespace


S3Credentials Methods

S3Credentials Methods NFX Class Library

The S3Credentials type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Forget | Deletes sensitive information (such as password). This method is mostly used on client (vs. server) to prevent process memory-inspection attack. Its is usually called right after Login() was called. Implementers may consider forcing post-factum GC.Collect() on all generations to make sure that orphaned memory buff with sensitive information, that remains in RAM even after all references are killed, gets compacted; consequently, this method may take considerable time to execute. (Inherited from Credentials.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
S3Credentials Class
NFX.IO.FileSystem.S3 Namespace


S3Credentials.ToString Method

S3Credentials ToString Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
S3Credentials Class
S3Credentials Members
NFX.IO.FileSystem.S3 Namespace


S3Credentials Properties

S3Credentials Properties NFX Class Library

The S3Credentials type exposes the following members.
Properties
 | Name | Description
Public property | AccessKey |
Public property | Forgotten | Indicates whether Forget() was called on this instance (Inherited from Credentials.)
Public property | SecretKey |
Back to Top
See Also
S3Credentials Class
NFX.IO.FileSystem.S3 Namespace


S3Credentials.AccessKey Property

S3Credentials AccessKey Property NFX Class Library

Namespace: NFX.IO.FileSystem.S3
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AccessKey { get; }
public string AccessKey { get; }
Public ReadOnly Property AccessKey As String
    Get
Public ReadOnly Property AccessKey As String
    Get
public:
property String^ AccessKey {
    String^ get ();
}
public:
property String^ AccessKey {
    String^ get ();
}
member AccessKey : string with get
member AccessKey : string with get

Property Value

Type: Online String
See Also
S3Credentials Class
S3Credentials Members
NFX.IO.FileSystem.S3 Namespace


S3Credentials.SecretKey Property

S3Credentials SecretKey Property NFX Class Library

Namespace: NFX.IO.FileSystem.S3
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SecretKey { get; }
public string SecretKey { get; }
Public ReadOnly Property SecretKey As String
    Get
Public ReadOnly Property SecretKey As String
    Get
public:
property String^ SecretKey {
    String^ get ();
}
public:
property String^ SecretKey {
    String^ get ();
}
member SecretKey : string with get
member SecretKey : string with get

Property Value

Type: Online String
See Also
S3Credentials Class
S3Credentials Members
NFX.IO.FileSystem.S3 Namespace


NFX.IO.FileSystem.S3.V4 Namespace

NFX.IO.FileSystem.S3.V4 Namespace NFX Class Library

Classes
 | Class | Description
Public class | S3V4 |
Public class | S3V4FileSystem | Implements FileSystem for Amazon S3
Public class | S3V4FileSystem S3V4FSH |
Public class | S3V4FileSystemCapabilities |
Public class | S3V4FileSystemSession | Provides S3 (v4) file system connection session
Public class | S3V4FileSystemSessionConnectParams | Provides connection parameters specific for Amazon S3 V4
Public class | S3V4FileSystemStream |
Public class | S3V4HttpHelpers |
Protected class | S3V4ListBucketItem |
Protected class | S3V4ListBucketResult |
Public class | S3V4URI |


S3V4 Class

S3V4 Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.S3.V4 S3V4

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class S3V4
public class S3V4
Public Class S3V4
Public Class S3V4
public ref class S3V4
public ref class S3V4
type S3V4 =  class end
type S3V4 =  class end
See Also
S3V4 Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4 Members

S3V4 Members NFX Class Library

The S3V4 type exposes the following members.
Constructors
 | Name | Description
Public method | S3V4 | Initializes a new instance of the S3V4 class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
 | FileExists(S3V4URI, String, String, Int32) |
 | FileExists(String, String, String, String, String, Int32) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | FolderExists(S3V4URI, String, String, Int32) |
 | FolderExists(String, String, String, String, String, Int32) |
 | GetFile(S3V4URI, String, String, Stream, Int32) |
 | GetFile(String, String, String, String, String, Stream, Int32) |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
 | GetItemMetadata(S3V4URI, String, String, Int32) |
 | GetItemMetadata(String, String, String, String, String, Int32) |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | ItemExists(S3V4URI, String, String, Int32) |
 | ItemExists(String, String, String, String, String, Int32) |
 | ListBucket(S3V4URI, String, String, Int32, String, String, Nullable Int32 ) |
 | ListBucket(String, String, String, String, String, Int32, String, String, Nullable Int32 ) |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | PutFile(S3V4URI, String, String, Stream, Int32) |
 | PutFile(String, String, String, String, String, Stream, Int32) |
 | PutFolder(S3V4URI, String, String, Int32) |
 | PutFolder(String, String, String, String, String, Int32) |
 | PutItem |
 | RemoveFile(S3V4URI, String, String, Int32) |
 | RemoveFile(String, String, String, String, String, Int32) |
 | RemoveFolder(S3V4URI, String, String, Int32) |
 | RemoveFolder(String, String, String, String, String, Int32) |
 | RemoveItem(S3V4URI, String, String, Int32) |
 | RemoveItem(String, String, String, String, String, Int32) |
 | SetACL |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
S3V4 Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4 Constructor

S3V4 Constructor NFX Class Library

Initializes a new instance of the S3V4 class

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public S3V4()
public S3V4()
Public Sub New
Public Sub New
public:
S3V4()
public:
S3V4()
new : unit -> S3V4
new : unit -> S3V4
See Also
S3V4 Class
S3V4 Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4 Methods

S3V4 Methods NFX Class Library

The S3V4 type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
 | FileExists(S3V4URI, String, String, Int32) |
 | FileExists(String, String, String, String, String, Int32) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | FolderExists(S3V4URI, String, String, Int32) |
 | FolderExists(String, String, String, String, String, Int32) |
 | GetFile(S3V4URI, String, String, Stream, Int32) |
 | GetFile(String, String, String, String, String, Stream, Int32) |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
 | GetItemMetadata(S3V4URI, String, String, Int32) |
 | GetItemMetadata(String, String, String, String, String, Int32) |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | ItemExists(S3V4URI, String, String, Int32) |
 | ItemExists(String, String, String, String, String, Int32) |
 | ListBucket(S3V4URI, String, String, Int32, String, String, Nullable Int32 ) |
 | ListBucket(String, String, String, String, String, Int32, String, String, Nullable Int32 ) |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | PutFile(S3V4URI, String, String, Stream, Int32) |
 | PutFile(String, String, String, String, String, Stream, Int32) |
 | PutFolder(S3V4URI, String, String, Int32) |
 | PutFolder(String, String, String, String, String, Int32) |
 | PutItem |
 | RemoveFile(S3V4URI, String, String, Int32) |
 | RemoveFile(String, String, String, String, String, Int32) |
 | RemoveFolder(S3V4URI, String, String, Int32) |
 | RemoveFolder(String, String, String, String, String, Int32) |
 | RemoveItem(S3V4URI, String, String, Int32) |
 | RemoveItem(String, String, String, String, String, Int32) |
 | SetACL |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
S3V4 Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.FileExists Method

S3V4 FileExists Method NFX Class Library

Overload List
Name | Description
FileExists(S3V4URI, String, String, Int32) |
FileExists(String, String, String, String, String, Int32) |
Back to Top
See Also
S3V4 Class
S3V4 Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.FileExists Method (S3V4URI, String, String, Int32)

S3V4 FileExists Method (S3V4URI, String, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool FileExists(
    S3V4URI uri,
    string accessKey,
    string secretKey,
    int timeoutMs
)
public static bool FileExists(
    S3V4URI uri,
    string accessKey,
    string secretKey,
    int timeoutMs
)
Public Shared Function FileExists (
    uri As S3V4URI,
    accessKey As String,
    secretKey As String,
    timeoutMs As Integer
) As Boolean
Public Shared Function FileExists (
    uri As S3V4URI,
    accessKey As String,
    secretKey As String,
    timeoutMs As Integer
) As Boolean
public:
static bool FileExists(
    S3V4URI^ uri,
    String^ accessKey,
    String^ secretKey,
    int timeoutMs
)
public:
static bool FileExists(
    S3V4URI^ uri,
    String^ accessKey,
    String^ secretKey,
    int timeoutMs
)
static member FileExists :
        uri : S3V4URI *
        accessKey : string *
        secretKey : string *
        timeoutMs : int -> bool
static member FileExists :
        uri : S3V4URI *
        accessKey : string *
        secretKey : string *
        timeoutMs : int -> bool

Parameters

uri
Type: NFX.IO.FileSystem.S3.V4 S3V4URI
accessKey
Type: Online System String
secretKey
Type: Online System String
timeoutMs
Type: Online System Int32

Return Value

Type: Online Boolean
See Also
S3V4 Class
S3V4 Members
FileExists Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.FileExists Method (String, String, String, String, String, Int32)

S3V4 FileExists Method (String, String, String, String, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool FileExists(
    string itemLocalPath,
    string accessKey,
    string secretKey,
    string bucket,
    string region,
    int timeoutMs
)
public static bool FileExists(
    string itemLocalPath,
    string accessKey,
    string secretKey,
    string bucket,
    string region,
    int timeoutMs
)
Public Shared Function FileExists (
    itemLocalPath As String,
    accessKey As String,
    secretKey As String,
    bucket As String,
    region As String,
    timeoutMs As Integer
) As Boolean
Public Shared Function FileExists (
    itemLocalPath As String,
    accessKey As String,
    secretKey As String,
    bucket As String,
    region As String,
    timeoutMs As Integer
) As Boolean
public:
static bool FileExists(
    String^ itemLocalPath,
    String^ accessKey,
    String^ secretKey,
    String^ bucket,
    String^ region,
    int timeoutMs
)
public:
static bool FileExists(
    String^ itemLocalPath,
    String^ accessKey,
    String^ secretKey,
    String^ bucket,
    String^ region,
    int timeoutMs
)
static member FileExists :
        itemLocalPath : string *
        accessKey : string *
        secretKey : string *
        bucket : string *
        region : string *
        timeoutMs : int -> bool
static member FileExists :
        itemLocalPath : string *
        accessKey : string *
        secretKey : string *
        bucket : string *
        region : string *
        timeoutMs : int -> bool

Parameters

itemLocalPath
Type: Online System String
accessKey
Type: Online System String
secretKey
Type: Online System String
bucket
Type: Online System String
region
Type: Online System String
timeoutMs
Type: Online System Int32

Return Value

Type: Online Boolean
See Also
S3V4 Class
S3V4 Members
FileExists Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.FolderExists Method

S3V4 FolderExists Method NFX Class Library

Overload List
Name | Description
FolderExists(S3V4URI, String, String, Int32) |
FolderExists(String, String, String, String, String, Int32) |
Back to Top
See Also
S3V4 Class
S3V4 Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.FolderExists Method (S3V4URI, String, String, Int32)

S3V4 FolderExists Method (S3V4URI, String, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool FolderExists(
    S3V4URI uri,
    string accessKey,
    string secretKey,
    int timeoutMs
)
public static bool FolderExists(
    S3V4URI uri,
    string accessKey,
    string secretKey,
    int timeoutMs
)
Public Shared Function FolderExists (
    uri As S3V4URI,
    accessKey As String,
    secretKey As String,
    timeoutMs As Integer
) As Boolean
Public Shared Function FolderExists (
    uri As S3V4URI,
    accessKey As String,
    secretKey As String,
    timeoutMs As Integer
) As Boolean
public:
static bool FolderExists(
    S3V4URI^ uri,
    String^ accessKey,
    String^ secretKey,
    int timeoutMs
)
public:
static bool FolderExists(
    S3V4URI^ uri,
    String^ accessKey,
    String^ secretKey,
    int timeoutMs
)
static member FolderExists :
        uri : S3V4URI *
        accessKey : string *
        secretKey : string *
        timeoutMs : int -> bool
static member FolderExists :
        uri : S3V4URI *
        accessKey : string *
        secretKey : string *
        timeoutMs : int -> bool

Parameters

uri
Type: NFX.IO.FileSystem.S3.V4 S3V4URI
accessKey
Type: Online System String
secretKey
Type: Online System String
timeoutMs
Type: Online System Int32

Return Value

Type: Online Boolean
See Also
S3V4 Class
S3V4 Members
FolderExists Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.FolderExists Method (String, String, String, String, String, Int32)

S3V4 FolderExists Method (String, String, String, String, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool FolderExists(
    string itemLocalPath,
    string accessKey,
    string secretKey,
    string bucket,
    string region,
    int timeoutMs
)
public static bool FolderExists(
    string itemLocalPath,
    string accessKey,
    string secretKey,
    string bucket,
    string region,
    int timeoutMs
)
Public Shared Function FolderExists (
    itemLocalPath As String,
    accessKey As String,
    secretKey As String,
    bucket As String,
    region As String,
    timeoutMs As Integer
) As Boolean
Public Shared Function FolderExists (
    itemLocalPath As String,
    accessKey As String,
    secretKey As String,
    bucket As String,
    region As String,
    timeoutMs As Integer
) As Boolean
public:
static bool FolderExists(
    String^ itemLocalPath,
    String^ accessKey,
    String^ secretKey,
    String^ bucket,
    String^ region,
    int timeoutMs
)
public:
static bool FolderExists(
    String^ itemLocalPath,
    String^ accessKey,
    String^ secretKey,
    String^ bucket,
    String^ region,
    int timeoutMs
)
static member FolderExists :
        itemLocalPath : string *
        accessKey : string *
        secretKey : string *
        bucket : string *
        region : string *
        timeoutMs : int -> bool
static member FolderExists :
        itemLocalPath : string *
        accessKey : string *
        secretKey : string *
        bucket : string *
        region : string *
        timeoutMs : int -> bool

Parameters

itemLocalPath
Type: Online System String
accessKey
Type: Online System String
secretKey
Type: Online System String
bucket
Type: Online System String
region
Type: Online System String
timeoutMs
Type: Online System Int32

Return Value

Type: Online Boolean
See Also
S3V4 Class
S3V4 Members
FolderExists Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.GetFile Method

S3V4 GetFile Method NFX Class Library

Overload List
Name | Description
GetFile(S3V4URI, String, String, Stream, Int32) |
GetFile(String, String, String, String, String, Stream, Int32) |
Back to Top
See Also
S3V4 Class
S3V4 Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.GetFile Method (S3V4URI, String, String, Stream, Int32)

S3V4 GetFile Method (S3V4URI, String, String, Stream, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void GetFile(
    S3V4URI uri,
    string accessKey,
    string secretKey,
    Stream stream,
    int timeoutMs
)
public static void GetFile(
    S3V4URI uri,
    string accessKey,
    string secretKey,
    Stream stream,
    int timeoutMs
)
Public Shared Sub GetFile (
    uri As S3V4URI,
    accessKey As String,
    secretKey As String,
    stream As Stream,
    timeoutMs As Integer
)
Public Shared Sub GetFile (
    uri As S3V4URI,
    accessKey As String,
    secretKey As String,
    stream As Stream,
    timeoutMs As Integer
)
public:
static void GetFile(
    S3V4URI^ uri,
    String^ accessKey,
    String^ secretKey,
    Stream^ stream,
    int timeoutMs
)
public:
static void GetFile(
    S3V4URI^ uri,
    String^ accessKey,
    String^ secretKey,
    Stream^ stream,
    int timeoutMs
)
static member GetFile :
        uri : S3V4URI *
        accessKey : string *
        secretKey : string *
        stream : Stream *
        timeoutMs : int -> unit
static member GetFile :
        uri : S3V4URI *
        accessKey : string *
        secretKey : string *
        stream : Stream *
        timeoutMs : int -> unit

Parameters

uri
Type: NFX.IO.FileSystem.S3.V4 S3V4URI
accessKey
Type: Online System String
secretKey
Type: Online System String
stream
Type: Online System.IO Stream
timeoutMs
Type: Online System Int32
See Also
S3V4 Class
S3V4 Members
GetFile Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.GetFile Method (String, String, String, String, String, Stream, Int32)

S3V4 GetFile Method (String, String, String, String, String, Stream, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void GetFile(
    string itemLocalPath,
    string accessKey,
    string secretKey,
    string bucket,
    string region,
    Stream stream,
    int timeoutMs
)
public static void GetFile(
    string itemLocalPath,
    string accessKey,
    string secretKey,
    string bucket,
    string region,
    Stream stream,
    int timeoutMs
)
Public Shared Sub GetFile (
    itemLocalPath As String,
    accessKey As String,
    secretKey As String,
    bucket As String,
    region As String,
    stream As Stream,
    timeoutMs As Integer
)
Public Shared Sub GetFile (
    itemLocalPath As String,
    accessKey As String,
    secretKey As String,
    bucket As String,
    region As String,
    stream As Stream,
    timeoutMs As Integer
)
public:
static void GetFile(
    String^ itemLocalPath,
    String^ accessKey,
    String^ secretKey,
    String^ bucket,
    String^ region,
    Stream^ stream,
    int timeoutMs
)
public:
static void GetFile(
    String^ itemLocalPath,
    String^ accessKey,
    String^ secretKey,
    String^ bucket,
    String^ region,
    Stream^ stream,
    int timeoutMs
)
static member GetFile :
        itemLocalPath : string *
        accessKey : string *
        secretKey : string *
        bucket : string *
        region : string *
        stream : Stream *
        timeoutMs : int -> unit
static member GetFile :
        itemLocalPath : string *
        accessKey : string *
        secretKey : string *
        bucket : string *
        region : string *
        stream : Stream *
        timeoutMs : int -> unit

Parameters

itemLocalPath
Type: Online System String
accessKey
Type: Online System String
secretKey
Type: Online System String
bucket
Type: Online System String
region
Type: Online System String
stream
Type: Online System.IO Stream
timeoutMs
Type: Online System Int32
See Also
S3V4 Class
S3V4 Members
GetFile Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.GetItemMetadata Method

S3V4 GetItemMetadata Method NFX Class Library

Overload List
Name | Description
GetItemMetadata(S3V4URI, String, String, Int32) |
GetItemMetadata(String, String, String, String, String, Int32) |
Back to Top
See Also
S3V4 Class
S3V4 Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.GetItemMetadata Method (S3V4URI, String, String, Int32)

S3V4 GetItemMetadata Method (S3V4URI, String, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IDictionary<string, string> GetItemMetadata(
    S3V4URI uri,
    string accessKey,
    string secretKey,
    int timeoutMs
)
public static IDictionary<string, string> GetItemMetadata(
    S3V4URI uri,
    string accessKey,
    string secretKey,
    int timeoutMs
)
Public Shared Function GetItemMetadata (
    uri As S3V4URI,
    accessKey As String,
    secretKey As String,
    timeoutMs As Integer
) As IDictionary(Of String, String)
Public Shared Function GetItemMetadata (
    uri As S3V4URI,
    accessKey As String,
    secretKey As String,
    timeoutMs As Integer
) As IDictionary(Of String, String)
public:
static IDictionary<String^, String^>^ GetItemMetadata(
    S3V4URI^ uri,
    String^ accessKey,
    String^ secretKey,
    int timeoutMs
)
public:
static IDictionary<String^, String^>^ GetItemMetadata(
    S3V4URI^ uri,
    String^ accessKey,
    String^ secretKey,
    int timeoutMs
)
static member GetItemMetadata :
        uri : S3V4URI *
        accessKey : string *
        secretKey : string *
        timeoutMs : int -> IDictionary<string, string>
static member GetItemMetadata :
        uri : S3V4URI *
        accessKey : string *
        secretKey : string *
        timeoutMs : int -> IDictionary<string, string>

Parameters

uri
Type: NFX.IO.FileSystem.S3.V4 S3V4URI
accessKey
Type: Online System String
secretKey
Type: Online System String
timeoutMs
Type: Online System Int32

Return Value

Type: Online IDictionary Online String, Online String
See Also
S3V4 Class
S3V4 Members
GetItemMetadata Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.GetItemMetadata Method (String, String, String, String, String, Int32)

S3V4 GetItemMetadata Method (String, String, String, String, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IDictionary<string, string> GetItemMetadata(
    string itemLocalPath,
    string accessKey,
    string secretKey,
    string bucket,
    string region,
    int timeoutMs
)
public static IDictionary<string, string> GetItemMetadata(
    string itemLocalPath,
    string accessKey,
    string secretKey,
    string bucket,
    string region,
    int timeoutMs
)
Public Shared Function GetItemMetadata (
    itemLocalPath As String,
    accessKey As String,
    secretKey As String,
    bucket As String,
    region As String,
    timeoutMs As Integer
) As IDictionary(Of String, String)
Public Shared Function GetItemMetadata (
    itemLocalPath As String,
    accessKey As String,
    secretKey As String,
    bucket As String,
    region As String,
    timeoutMs As Integer
) As IDictionary(Of String, String)
public:
static IDictionary<String^, String^>^ GetItemMetadata(
    String^ itemLocalPath,
    String^ accessKey,
    String^ secretKey,
    String^ bucket,
    String^ region,
    int timeoutMs
)
public:
static IDictionary<String^, String^>^ GetItemMetadata(
    String^ itemLocalPath,
    String^ accessKey,
    String^ secretKey,
    String^ bucket,
    String^ region,
    int timeoutMs
)
static member GetItemMetadata :
        itemLocalPath : string *
        accessKey : string *
        secretKey : string *
        bucket : string *
        region : string *
        timeoutMs : int -> IDictionary<string, string>
static member GetItemMetadata :
        itemLocalPath : string *
        accessKey : string *
        secretKey : string *
        bucket : string *
        region : string *
        timeoutMs : int -> IDictionary<string, string>

Parameters

itemLocalPath
Type: Online System String
accessKey
Type: Online System String
secretKey
Type: Online System String
bucket
Type: Online System String
region
Type: Online System String
timeoutMs
Type: Online System Int32

Return Value

Type: Online IDictionary Online String, Online String
See Also
S3V4 Class
S3V4 Members
GetItemMetadata Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.ItemExists Method

S3V4 ItemExists Method NFX Class Library

Overload List
Name | Description
ItemExists(S3V4URI, String, String, Int32) |
ItemExists(String, String, String, String, String, Int32) |
Back to Top
See Also
S3V4 Class
S3V4 Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.ItemExists Method (S3V4URI, String, String, Int32)

S3V4 ItemExists Method (S3V4URI, String, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool ItemExists(
    S3V4URI uri,
    string accessKey,
    string secretKey,
    int timeoutMs
)
public static bool ItemExists(
    S3V4URI uri,
    string accessKey,
    string secretKey,
    int timeoutMs
)
Public Shared Function ItemExists (
    uri As S3V4URI,
    accessKey As String,
    secretKey As String,
    timeoutMs As Integer
) As Boolean
Public Shared Function ItemExists (
    uri As S3V4URI,
    accessKey As String,
    secretKey As String,
    timeoutMs As Integer
) As Boolean
public:
static bool ItemExists(
    S3V4URI^ uri,
    String^ accessKey,
    String^ secretKey,
    int timeoutMs
)
public:
static bool ItemExists(
    S3V4URI^ uri,
    String^ accessKey,
    String^ secretKey,
    int timeoutMs
)
static member ItemExists :
        uri : S3V4URI *
        accessKey : string *
        secretKey : string *
        timeoutMs : int -> bool
static member ItemExists :
        uri : S3V4URI *
        accessKey : string *
        secretKey : string *
        timeoutMs : int -> bool

Parameters

uri
Type: NFX.IO.FileSystem.S3.V4 S3V4URI
accessKey
Type: Online System String
secretKey
Type: Online System String
timeoutMs
Type: Online System Int32

Return Value

Type: Online Boolean
See Also
S3V4 Class
S3V4 Members
ItemExists Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.ItemExists Method (String, String, String, String, String, Int32)

S3V4 ItemExists Method (String, String, String, String, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool ItemExists(
    string itemLocalPath,
    string accessKey,
    string secretKey,
    string bucket,
    string region,
    int timeoutMs
)
public static bool ItemExists(
    string itemLocalPath,
    string accessKey,
    string secretKey,
    string bucket,
    string region,
    int timeoutMs
)
Public Shared Function ItemExists (
    itemLocalPath As String,
    accessKey As String,
    secretKey As String,
    bucket As String,
    region As String,
    timeoutMs As Integer
) As Boolean
Public Shared Function ItemExists (
    itemLocalPath As String,
    accessKey As String,
    secretKey As String,
    bucket As String,
    region As String,
    timeoutMs As Integer
) As Boolean
public:
static bool ItemExists(
    String^ itemLocalPath,
    String^ accessKey,
    String^ secretKey,
    String^ bucket,
    String^ region,
    int timeoutMs
)
public:
static bool ItemExists(
    String^ itemLocalPath,
    String^ accessKey,
    String^ secretKey,
    String^ bucket,
    String^ region,
    int timeoutMs
)
static member ItemExists :
        itemLocalPath : string *
        accessKey : string *
        secretKey : string *
        bucket : string *
        region : string *
        timeoutMs : int -> bool
static member ItemExists :
        itemLocalPath : string *
        accessKey : string *
        secretKey : string *
        bucket : string *
        region : string *
        timeoutMs : int -> bool

Parameters

itemLocalPath
Type: Online System String
accessKey
Type: Online System String
secretKey
Type: Online System String
bucket
Type: Online System String
region
Type: Online System String
timeoutMs
Type: Online System Int32

Return Value

Type: Online Boolean
See Also
S3V4 Class
S3V4 Members
ItemExists Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.ListBucket Method

S3V4 ListBucket Method NFX Class Library

Overload List
Name | Description
ListBucket(S3V4URI, String, String, Int32, String, String, Nullable Int32 ) |
ListBucket(String, String, String, String, String, Int32, String, String, Nullable Int32 ) |
Back to Top
See Also
S3V4 Class
S3V4 Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.ListBucket Method (S3V4URI, String, String, Int32, String, String, Nullable(Int32))

S3V4 ListBucket Method (S3V4URI, String, String, Int32, String, String, Nullable Int32 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ListBucket(
    S3V4URI uri,
    string accessKey,
    string secretKey,
    int timeoutMs,
    string prefix = null,
    string marker = null,
    Nullable<int> maxKeys = null
)
public static string ListBucket(
    S3V4URI uri,
    string accessKey,
    string secretKey,
    int timeoutMs,
    string prefix = null,
    string marker = null,
    Nullable<int> maxKeys = null
)
Public Shared Function ListBucket (
    uri As S3V4URI,
    accessKey As String,
    secretKey As String,
    timeoutMs As Integer,
    Optional prefix As String = Nothing,
    Optional marker As String = Nothing,
    Optional maxKeys As Nullable(Of Integer) = Nothing
) As String
Public Shared Function ListBucket (
    uri As S3V4URI,
    accessKey As String,
    secretKey As String,
    timeoutMs As Integer,
    Optional prefix As String = Nothing,
    Optional marker As String = Nothing,
    Optional maxKeys As Nullable(Of Integer) = Nothing
) As String
public:
static String^ ListBucket(
    S3V4URI^ uri,
    String^ accessKey,
    String^ secretKey,
    int timeoutMs,
    String^ prefix = nullptr,
    String^ marker = nullptr,
    Nullable<int> maxKeys = nullptr
)
public:
static String^ ListBucket(
    S3V4URI^ uri,
    String^ accessKey,
    String^ secretKey,
    int timeoutMs,
    String^ prefix = nullptr,
    String^ marker = nullptr,
    Nullable<int> maxKeys = nullptr
)
static member ListBucket :
        uri : S3V4URI *
        accessKey : string *
        secretKey : string *
        timeoutMs : int *
        ?prefix : string *
        ?marker : string *
        ?maxKeys : Nullable<int>
(* Defaults:
        let _prefix = defaultArg prefix null
        let _marker = defaultArg marker null
        let _maxKeys = defaultArg maxKeys null
*)
-> string
static member ListBucket :
        uri : S3V4URI *
        accessKey : string *
        secretKey : string *
        timeoutMs : int *
        ?prefix : string *
        ?marker : string *
        ?maxKeys : Nullable<int>
(* Defaults:
        let _prefix = defaultArg prefix null
        let _marker = defaultArg marker null
        let _maxKeys = defaultArg maxKeys null
*)
-> string

Parameters

uri
Type: NFX.IO.FileSystem.S3.V4 S3V4URI
accessKey
Type: Online System String
secretKey
Type: Online System String
timeoutMs
Type: Online System Int32
prefix (Optional)
Type: Online System String
marker (Optional)
Type: Online System String
maxKeys (Optional)
Type: Online System Nullable Online Int32

Return Value

Type: Online String
See Also
S3V4 Class
S3V4 Members
ListBucket Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.ListBucket Method (String, String, String, String, String, Int32, String, String, Nullable(Int32))

S3V4 ListBucket Method (String, String, String, String, String, Int32, String, String, Nullable Int32 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ListBucket(
    string itemLocalPath,
    string accessKey,
    string secretKey,
    string bucket,
    string region,
    int timeoutMs,
    string prefix = null,
    string marker = null,
    Nullable<int> maxKeys = null
)
public static string ListBucket(
    string itemLocalPath,
    string accessKey,
    string secretKey,
    string bucket,
    string region,
    int timeoutMs,
    string prefix = null,
    string marker = null,
    Nullable<int> maxKeys = null
)
Public Shared Function ListBucket (
    itemLocalPath As String,
    accessKey As String,
    secretKey As String,
    bucket As String,
    region As String,
    timeoutMs As Integer,
    Optional prefix As String = Nothing,
    Optional marker As String = Nothing,
    Optional maxKeys As Nullable(Of Integer) = Nothing
) As String
Public Shared Function ListBucket (
    itemLocalPath As String,
    accessKey As String,
    secretKey As String,
    bucket As String,
    region As String,
    timeoutMs As Integer,
    Optional prefix As String = Nothing,
    Optional marker As String = Nothing,
    Optional maxKeys As Nullable(Of Integer) = Nothing
) As String
public:
static String^ ListBucket(
    String^ itemLocalPath,
    String^ accessKey,
    String^ secretKey,
    String^ bucket,
    String^ region,
    int timeoutMs,
    String^ prefix = nullptr,
    String^ marker = nullptr,
    Nullable<int> maxKeys = nullptr
)
public:
static String^ ListBucket(
    String^ itemLocalPath,
    String^ accessKey,
    String^ secretKey,
    String^ bucket,
    String^ region,
    int timeoutMs,
    String^ prefix = nullptr,
    String^ marker = nullptr,
    Nullable<int> maxKeys = nullptr
)
static member ListBucket :
        itemLocalPath : string *
        accessKey : string *
        secretKey : string *
        bucket : string *
        region : string *
        timeoutMs : int *
        ?prefix : string *
        ?marker : string *
        ?maxKeys : Nullable<int>
(* Defaults:
        let _prefix = defaultArg prefix null
        let _marker = defaultArg marker null
        let _maxKeys = defaultArg maxKeys null
*)
-> string
static member ListBucket :
        itemLocalPath : string *
        accessKey : string *
        secretKey : string *
        bucket : string *
        region : string *
        timeoutMs : int *
        ?prefix : string *
        ?marker : string *
        ?maxKeys : Nullable<int>
(* Defaults:
        let _prefix = defaultArg prefix null
        let _marker = defaultArg marker null
        let _maxKeys = defaultArg maxKeys null
*)
-> string

Parameters

itemLocalPath
Type: Online System String
accessKey
Type: Online System String
secretKey
Type: Online System String
bucket
Type: Online System String
region
Type: Online System String
timeoutMs
Type: Online System Int32
prefix (Optional)
Type: Online System String
marker (Optional)
Type: Online System String
maxKeys (Optional)
Type: Online System Nullable Online Int32

Return Value

Type: Online String
See Also
S3V4 Class
S3V4 Members
ListBucket Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.PutFile Method

S3V4 PutFile Method NFX Class Library

Overload List
Name | Description
PutFile(S3V4URI, String, String, Stream, Int32) |
PutFile(String, String, String, String, String, Stream, Int32) |
Back to Top
See Also
S3V4 Class
S3V4 Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.PutFile Method (S3V4URI, String, String, Stream, Int32)

S3V4 PutFile Method (S3V4URI, String, String, Stream, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string PutFile(
    S3V4URI uri,
    string accessKey,
    string secretKey,
    Stream contentStream,
    int timeoutMs
)
public static string PutFile(
    S3V4URI uri,
    string accessKey,
    string secretKey,
    Stream contentStream,
    int timeoutMs
)
Public Shared Function PutFile (
    uri As S3V4URI,
    accessKey As String,
    secretKey As String,
    contentStream As Stream,
    timeoutMs As Integer
) As String
Public Shared Function PutFile (
    uri As S3V4URI,
    accessKey As String,
    secretKey As String,
    contentStream As Stream,
    timeoutMs As Integer
) As String
public:
static String^ PutFile(
    S3V4URI^ uri,
    String^ accessKey,
    String^ secretKey,
    Stream^ contentStream,
    int timeoutMs
)
public:
static String^ PutFile(
    S3V4URI^ uri,
    String^ accessKey,
    String^ secretKey,
    Stream^ contentStream,
    int timeoutMs
)
static member PutFile :
        uri : S3V4URI *
        accessKey : string *
        secretKey : string *
        contentStream : Stream *
        timeoutMs : int -> string
static member PutFile :
        uri : S3V4URI *
        accessKey : string *
        secretKey : string *
        contentStream : Stream *
        timeoutMs : int -> string

Parameters

uri
Type: NFX.IO.FileSystem.S3.V4 S3V4URI
accessKey
Type: Online System String
secretKey
Type: Online System String
contentStream
Type: Online System.IO Stream
timeoutMs
Type: Online System Int32

Return Value

Type: Online String
See Also
S3V4 Class
S3V4 Members
PutFile Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.PutFile Method (String, String, String, String, String, Stream, Int32)

S3V4 PutFile Method (String, String, String, String, String, Stream, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string PutFile(
    string itemLocalPath,
    string accessKey,
    string secretKey,
    string bucket,
    string region,
    Stream contentStream,
    int timeoutMs
)
public static string PutFile(
    string itemLocalPath,
    string accessKey,
    string secretKey,
    string bucket,
    string region,
    Stream contentStream,
    int timeoutMs
)
Public Shared Function PutFile (
    itemLocalPath As String,
    accessKey As String,
    secretKey As String,
    bucket As String,
    region As String,
    contentStream As Stream,
    timeoutMs As Integer
) As String
Public Shared Function PutFile (
    itemLocalPath As String,
    accessKey As String,
    secretKey As String,
    bucket As String,
    region As String,
    contentStream As Stream,
    timeoutMs As Integer
) As String
public:
static String^ PutFile(
    String^ itemLocalPath,
    String^ accessKey,
    String^ secretKey,
    String^ bucket,
    String^ region,
    Stream^ contentStream,
    int timeoutMs
)
public:
static String^ PutFile(
    String^ itemLocalPath,
    String^ accessKey,
    String^ secretKey,
    String^ bucket,
    String^ region,
    Stream^ contentStream,
    int timeoutMs
)
static member PutFile :
        itemLocalPath : string *
        accessKey : string *
        secretKey : string *
        bucket : string *
        region : string *
        contentStream : Stream *
        timeoutMs : int -> string
static member PutFile :
        itemLocalPath : string *
        accessKey : string *
        secretKey : string *
        bucket : string *
        region : string *
        contentStream : Stream *
        timeoutMs : int -> string

Parameters

itemLocalPath
Type: Online System String
accessKey
Type: Online System String
secretKey
Type: Online System String
bucket
Type: Online System String
region
Type: Online System String
contentStream
Type: Online System.IO Stream
timeoutMs
Type: Online System Int32

Return Value

Type: Online String
See Also
S3V4 Class
S3V4 Members
PutFile Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.PutFolder Method

S3V4 PutFolder Method NFX Class Library

Overload List
Name | Description
PutFolder(S3V4URI, String, String, Int32) |
PutFolder(String, String, String, String, String, Int32) |
Back to Top
See Also
S3V4 Class
S3V4 Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.PutFolder Method (S3V4URI, String, String, Int32)

S3V4 PutFolder Method (S3V4URI, String, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string PutFolder(
    S3V4URI uri,
    string accessKey,
    string secretKey,
    int timeoutMs
)
public static string PutFolder(
    S3V4URI uri,
    string accessKey,
    string secretKey,
    int timeoutMs
)
Public Shared Function PutFolder (
    uri As S3V4URI,
    accessKey As String,
    secretKey As String,
    timeoutMs As Integer
) As String
Public Shared Function PutFolder (
    uri As S3V4URI,
    accessKey As String,
    secretKey As String,
    timeoutMs As Integer
) As String
public:
static String^ PutFolder(
    S3V4URI^ uri,
    String^ accessKey,
    String^ secretKey,
    int timeoutMs
)
public:
static String^ PutFolder(
    S3V4URI^ uri,
    String^ accessKey,
    String^ secretKey,
    int timeoutMs
)
static member PutFolder :
        uri : S3V4URI *
        accessKey : string *
        secretKey : string *
        timeoutMs : int -> string
static member PutFolder :
        uri : S3V4URI *
        accessKey : string *
        secretKey : string *
        timeoutMs : int -> string

Parameters

uri
Type: NFX.IO.FileSystem.S3.V4 S3V4URI
accessKey
Type: Online System String
secretKey
Type: Online System String
timeoutMs
Type: Online System Int32

Return Value

Type: Online String
See Also
S3V4 Class
S3V4 Members
PutFolder Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.PutFolder Method (String, String, String, String, String, Int32)

S3V4 PutFolder Method (String, String, String, String, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string PutFolder(
    string itemLocalPath,
    string accessKey,
    string secretKey,
    string bucket,
    string region,
    int timeoutMs
)
public static string PutFolder(
    string itemLocalPath,
    string accessKey,
    string secretKey,
    string bucket,
    string region,
    int timeoutMs
)
Public Shared Function PutFolder (
    itemLocalPath As String,
    accessKey As String,
    secretKey As String,
    bucket As String,
    region As String,
    timeoutMs As Integer
) As String
Public Shared Function PutFolder (
    itemLocalPath As String,
    accessKey As String,
    secretKey As String,
    bucket As String,
    region As String,
    timeoutMs As Integer
) As String
public:
static String^ PutFolder(
    String^ itemLocalPath,
    String^ accessKey,
    String^ secretKey,
    String^ bucket,
    String^ region,
    int timeoutMs
)
public:
static String^ PutFolder(
    String^ itemLocalPath,
    String^ accessKey,
    String^ secretKey,
    String^ bucket,
    String^ region,
    int timeoutMs
)
static member PutFolder :
        itemLocalPath : string *
        accessKey : string *
        secretKey : string *
        bucket : string *
        region : string *
        timeoutMs : int -> string
static member PutFolder :
        itemLocalPath : string *
        accessKey : string *
        secretKey : string *
        bucket : string *
        region : string *
        timeoutMs : int -> string

Parameters

itemLocalPath
Type: Online System String
accessKey
Type: Online System String
secretKey
Type: Online System String
bucket
Type: Online System String
region
Type: Online System String
timeoutMs
Type: Online System Int32

Return Value

Type: Online String
See Also
S3V4 Class
S3V4 Members
PutFolder Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.PutItem Method

S3V4 PutItem Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string PutItem(
    string itemLocalPath,
    string accessKey,
    string secretKey,
    string bucket,
    string region,
    Stream contentStream,
    int timeoutMs
)
public static string PutItem(
    string itemLocalPath,
    string accessKey,
    string secretKey,
    string bucket,
    string region,
    Stream contentStream,
    int timeoutMs
)
Public Shared Function PutItem (
    itemLocalPath As String,
    accessKey As String,
    secretKey As String,
    bucket As String,
    region As String,
    contentStream As Stream,
    timeoutMs As Integer
) As String
Public Shared Function PutItem (
    itemLocalPath As String,
    accessKey As String,
    secretKey As String,
    bucket As String,
    region As String,
    contentStream As Stream,
    timeoutMs As Integer
) As String
public:
static String^ PutItem(
    String^ itemLocalPath,
    String^ accessKey,
    String^ secretKey,
    String^ bucket,
    String^ region,
    Stream^ contentStream,
    int timeoutMs
)
public:
static String^ PutItem(
    String^ itemLocalPath,
    String^ accessKey,
    String^ secretKey,
    String^ bucket,
    String^ region,
    Stream^ contentStream,
    int timeoutMs
)
static member PutItem :
        itemLocalPath : string *
        accessKey : string *
        secretKey : string *
        bucket : string *
        region : string *
        contentStream : Stream *
        timeoutMs : int -> string
static member PutItem :
        itemLocalPath : string *
        accessKey : string *
        secretKey : string *
        bucket : string *
        region : string *
        contentStream : Stream *
        timeoutMs : int -> string

Parameters

itemLocalPath
Type: Online System String
accessKey
Type: Online System String
secretKey
Type: Online System String
bucket
Type: Online System String
region
Type: Online System String
contentStream
Type: Online System.IO Stream
timeoutMs
Type: Online System Int32

Return Value

Type: Online String
See Also
S3V4 Class
S3V4 Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.RemoveFile Method

S3V4 RemoveFile Method NFX Class Library

Overload List
Name | Description
RemoveFile(S3V4URI, String, String, Int32) |
RemoveFile(String, String, String, String, String, Int32) |
Back to Top
See Also
S3V4 Class
S3V4 Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.RemoveFile Method (S3V4URI, String, String, Int32)

S3V4 RemoveFile Method (S3V4URI, String, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void RemoveFile(
    S3V4URI uri,
    string accessKey,
    string secretKey,
    int timeoutMs
)
public static void RemoveFile(
    S3V4URI uri,
    string accessKey,
    string secretKey,
    int timeoutMs
)
Public Shared Sub RemoveFile (
    uri As S3V4URI,
    accessKey As String,
    secretKey As String,
    timeoutMs As Integer
)
Public Shared Sub RemoveFile (
    uri As S3V4URI,
    accessKey As String,
    secretKey As String,
    timeoutMs As Integer
)
public:
static void RemoveFile(
    S3V4URI^ uri,
    String^ accessKey,
    String^ secretKey,
    int timeoutMs
)
public:
static void RemoveFile(
    S3V4URI^ uri,
    String^ accessKey,
    String^ secretKey,
    int timeoutMs
)
static member RemoveFile :
        uri : S3V4URI *
        accessKey : string *
        secretKey : string *
        timeoutMs : int -> unit
static member RemoveFile :
        uri : S3V4URI *
        accessKey : string *
        secretKey : string *
        timeoutMs : int -> unit

Parameters

uri
Type: NFX.IO.FileSystem.S3.V4 S3V4URI
accessKey
Type: Online System String
secretKey
Type: Online System String
timeoutMs
Type: Online System Int32
See Also
S3V4 Class
S3V4 Members
RemoveFile Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.RemoveFile Method (String, String, String, String, String, Int32)

S3V4 RemoveFile Method (String, String, String, String, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void RemoveFile(
    string itemLocalPath,
    string accessKey,
    string secretKey,
    string bucket,
    string region,
    int timeoutMs
)
public static void RemoveFile(
    string itemLocalPath,
    string accessKey,
    string secretKey,
    string bucket,
    string region,
    int timeoutMs
)
Public Shared Sub RemoveFile (
    itemLocalPath As String,
    accessKey As String,
    secretKey As String,
    bucket As String,
    region As String,
    timeoutMs As Integer
)
Public Shared Sub RemoveFile (
    itemLocalPath As String,
    accessKey As String,
    secretKey As String,
    bucket As String,
    region As String,
    timeoutMs As Integer
)
public:
static void RemoveFile(
    String^ itemLocalPath,
    String^ accessKey,
    String^ secretKey,
    String^ bucket,
    String^ region,
    int timeoutMs
)
public:
static void RemoveFile(
    String^ itemLocalPath,
    String^ accessKey,
    String^ secretKey,
    String^ bucket,
    String^ region,
    int timeoutMs
)
static member RemoveFile :
        itemLocalPath : string *
        accessKey : string *
        secretKey : string *
        bucket : string *
        region : string *
        timeoutMs : int -> unit
static member RemoveFile :
        itemLocalPath : string *
        accessKey : string *
        secretKey : string *
        bucket : string *
        region : string *
        timeoutMs : int -> unit

Parameters

itemLocalPath
Type: Online System String
accessKey
Type: Online System String
secretKey
Type: Online System String
bucket
Type: Online System String
region
Type: Online System String
timeoutMs
Type: Online System Int32
See Also
S3V4 Class
S3V4 Members
RemoveFile Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.RemoveFolder Method

S3V4 RemoveFolder Method NFX Class Library

Overload List
Name | Description
RemoveFolder(S3V4URI, String, String, Int32) |
RemoveFolder(String, String, String, String, String, Int32) |
Back to Top
See Also
S3V4 Class
S3V4 Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.RemoveFolder Method (S3V4URI, String, String, Int32)

S3V4 RemoveFolder Method (S3V4URI, String, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void RemoveFolder(
    S3V4URI uri,
    string accessKey,
    string secretKey,
    int timeoutMs
)
public static void RemoveFolder(
    S3V4URI uri,
    string accessKey,
    string secretKey,
    int timeoutMs
)
Public Shared Sub RemoveFolder (
    uri As S3V4URI,
    accessKey As String,
    secretKey As String,
    timeoutMs As Integer
)
Public Shared Sub RemoveFolder (
    uri As S3V4URI,
    accessKey As String,
    secretKey As String,
    timeoutMs As Integer
)
public:
static void RemoveFolder(
    S3V4URI^ uri,
    String^ accessKey,
    String^ secretKey,
    int timeoutMs
)
public:
static void RemoveFolder(
    S3V4URI^ uri,
    String^ accessKey,
    String^ secretKey,
    int timeoutMs
)
static member RemoveFolder :
        uri : S3V4URI *
        accessKey : string *
        secretKey : string *
        timeoutMs : int -> unit
static member RemoveFolder :
        uri : S3V4URI *
        accessKey : string *
        secretKey : string *
        timeoutMs : int -> unit

Parameters

uri
Type: NFX.IO.FileSystem.S3.V4 S3V4URI
accessKey
Type: Online System String
secretKey
Type: Online System String
timeoutMs
Type: Online System Int32
See Also
S3V4 Class
S3V4 Members
RemoveFolder Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.RemoveFolder Method (String, String, String, String, String, Int32)

S3V4 RemoveFolder Method (String, String, String, String, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void RemoveFolder(
    string itemLocalPath,
    string accessKey,
    string secretKey,
    string bucket,
    string region,
    int timeoutMs
)
public static void RemoveFolder(
    string itemLocalPath,
    string accessKey,
    string secretKey,
    string bucket,
    string region,
    int timeoutMs
)
Public Shared Sub RemoveFolder (
    itemLocalPath As String,
    accessKey As String,
    secretKey As String,
    bucket As String,
    region As String,
    timeoutMs As Integer
)
Public Shared Sub RemoveFolder (
    itemLocalPath As String,
    accessKey As String,
    secretKey As String,
    bucket As String,
    region As String,
    timeoutMs As Integer
)
public:
static void RemoveFolder(
    String^ itemLocalPath,
    String^ accessKey,
    String^ secretKey,
    String^ bucket,
    String^ region,
    int timeoutMs
)
public:
static void RemoveFolder(
    String^ itemLocalPath,
    String^ accessKey,
    String^ secretKey,
    String^ bucket,
    String^ region,
    int timeoutMs
)
static member RemoveFolder :
        itemLocalPath : string *
        accessKey : string *
        secretKey : string *
        bucket : string *
        region : string *
        timeoutMs : int -> unit
static member RemoveFolder :
        itemLocalPath : string *
        accessKey : string *
        secretKey : string *
        bucket : string *
        region : string *
        timeoutMs : int -> unit

Parameters

itemLocalPath
Type: Online System String
accessKey
Type: Online System String
secretKey
Type: Online System String
bucket
Type: Online System String
region
Type: Online System String
timeoutMs
Type: Online System Int32
See Also
S3V4 Class
S3V4 Members
RemoveFolder Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.RemoveItem Method

S3V4 RemoveItem Method NFX Class Library

Overload List
Name | Description
RemoveItem(S3V4URI, String, String, Int32) |
RemoveItem(String, String, String, String, String, Int32) |
Back to Top
See Also
S3V4 Class
S3V4 Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.RemoveItem Method (S3V4URI, String, String, Int32)

S3V4 RemoveItem Method (S3V4URI, String, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void RemoveItem(
    S3V4URI uri,
    string accessKey,
    string secretKey,
    int timeoutMs
)
public static void RemoveItem(
    S3V4URI uri,
    string accessKey,
    string secretKey,
    int timeoutMs
)
Public Shared Sub RemoveItem (
    uri As S3V4URI,
    accessKey As String,
    secretKey As String,
    timeoutMs As Integer
)
Public Shared Sub RemoveItem (
    uri As S3V4URI,
    accessKey As String,
    secretKey As String,
    timeoutMs As Integer
)
public:
static void RemoveItem(
    S3V4URI^ uri,
    String^ accessKey,
    String^ secretKey,
    int timeoutMs
)
public:
static void RemoveItem(
    S3V4URI^ uri,
    String^ accessKey,
    String^ secretKey,
    int timeoutMs
)
static member RemoveItem :
        uri : S3V4URI *
        accessKey : string *
        secretKey : string *
        timeoutMs : int -> unit
static member RemoveItem :
        uri : S3V4URI *
        accessKey : string *
        secretKey : string *
        timeoutMs : int -> unit

Parameters

uri
Type: NFX.IO.FileSystem.S3.V4 S3V4URI
accessKey
Type: Online System String
secretKey
Type: Online System String
timeoutMs
Type: Online System Int32
See Also
S3V4 Class
S3V4 Members
RemoveItem Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.RemoveItem Method (String, String, String, String, String, Int32)

S3V4 RemoveItem Method (String, String, String, String, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void RemoveItem(
    string itemLocalPath,
    string accessKey,
    string secretKey,
    string bucket,
    string region,
    int timeoutMs
)
public static void RemoveItem(
    string itemLocalPath,
    string accessKey,
    string secretKey,
    string bucket,
    string region,
    int timeoutMs
)
Public Shared Sub RemoveItem (
    itemLocalPath As String,
    accessKey As String,
    secretKey As String,
    bucket As String,
    region As String,
    timeoutMs As Integer
)
Public Shared Sub RemoveItem (
    itemLocalPath As String,
    accessKey As String,
    secretKey As String,
    bucket As String,
    region As String,
    timeoutMs As Integer
)
public:
static void RemoveItem(
    String^ itemLocalPath,
    String^ accessKey,
    String^ secretKey,
    String^ bucket,
    String^ region,
    int timeoutMs
)
public:
static void RemoveItem(
    String^ itemLocalPath,
    String^ accessKey,
    String^ secretKey,
    String^ bucket,
    String^ region,
    int timeoutMs
)
static member RemoveItem :
        itemLocalPath : string *
        accessKey : string *
        secretKey : string *
        bucket : string *
        region : string *
        timeoutMs : int -> unit
static member RemoveItem :
        itemLocalPath : string *
        accessKey : string *
        secretKey : string *
        bucket : string *
        region : string *
        timeoutMs : int -> unit

Parameters

itemLocalPath
Type: Online System String
accessKey
Type: Online System String
secretKey
Type: Online System String
bucket
Type: Online System String
region
Type: Online System String
timeoutMs
Type: Online System Int32
See Also
S3V4 Class
S3V4 Members
RemoveItem Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4.SetACL Method

S3V4 SetACL Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void SetACL(
    string itemLocalPath,
    string accessKey,
    string secretKey,
    string bucket,
    string region,
    string acl,
    int timeoutMs
)
public static void SetACL(
    string itemLocalPath,
    string accessKey,
    string secretKey,
    string bucket,
    string region,
    string acl,
    int timeoutMs
)
Public Shared Sub SetACL (
    itemLocalPath As String,
    accessKey As String,
    secretKey As String,
    bucket As String,
    region As String,
    acl As String,
    timeoutMs As Integer
)
Public Shared Sub SetACL (
    itemLocalPath As String,
    accessKey As String,
    secretKey As String,
    bucket As String,
    region As String,
    acl As String,
    timeoutMs As Integer
)
public:
static void SetACL(
    String^ itemLocalPath,
    String^ accessKey,
    String^ secretKey,
    String^ bucket,
    String^ region,
    String^ acl,
    int timeoutMs
)
public:
static void SetACL(
    String^ itemLocalPath,
    String^ accessKey,
    String^ secretKey,
    String^ bucket,
    String^ region,
    String^ acl,
    int timeoutMs
)
static member SetACL :
        itemLocalPath : string *
        accessKey : string *
        secretKey : string *
        bucket : string *
        region : string *
        acl : string *
        timeoutMs : int -> unit
static member SetACL :
        itemLocalPath : string *
        accessKey : string *
        secretKey : string *
        bucket : string *
        region : string *
        acl : string *
        timeoutMs : int -> unit

Parameters

itemLocalPath
Type: Online System String
accessKey
Type: Online System String
secretKey
Type: Online System String
bucket
Type: Online System String
region
Type: Online System String
acl
Type: Online System String
timeoutMs
Type: Online System Int32
See Also
S3V4 Class
S3V4 Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem Class

S3V4FileSystem Class NFX Class Library

Implements FileSystem for Amazon S3
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.IO.FileSystem FileSystem
NFX.IO.FileSystem.S3.V4 S3V4FileSystem

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class S3V4FileSystem : FileSystem
public class S3V4FileSystem : FileSystem
Public Class S3V4FileSystem
    Inherits FileSystem
Public Class S3V4FileSystem
    Inherits FileSystem
public ref class S3V4FileSystem : public FileSystem
public ref class S3V4FileSystem : public FileSystem
type S3V4FileSystem =
    class
        inherit FileSystem
    end
type S3V4FileSystem =
    class
        inherit FileSystem
    end
See Also
S3V4FileSystem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem Members

S3V4FileSystem Members NFX Class Library

The S3V4FileSystem type exposes the following members.
Constructors
 | Name | Description
Public method | S3V4FileSystem | Initializes a new instance of the S3V4FileSystem class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | CombinePaths | Combines two or more path segments joining them using primary file system path separator. This method is thread-safe (Inherited from FileSystem.)
Public method | Configure | Configures file system. This method is a part of lifecycle management and is intended to be called only by creating thread (not thread-safe) (Inherited from FileSystem.)
Protected method | Destructor | (Inherited from FileSystem.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoBeginTransaction | Override in particular file systems that support transactions to begin transaction in specified session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoBeginTransactionAsync | Async version of DoBeginTransaction(FileSystemSession). This base/default implementation just synchronously calls DoBeginTransaction(FileSystemSession) and returns already completed Task with result returned by DoBeginTransaction(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoCheckCanChange | Override in particular file systems to see if item can change, i.e. for file systems that support versioning throw exception if item is in session which "looks" at a sealed/closed version and can not change. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoCheckCanChangeAsync | Async version of DoCheckCanChange(FileSystemSessionItem). This base/default implementation just synchronously calls DoCheckCanChange(FileSystemSessionItem) and returns already completed Task with result returned by DoCheckCanChange(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoCommitTransaction | Override in particular file systems that support transactions to commit transaction in specified session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoCommitTransactionAsync | Async version of DoCommitTransaction(FileSystemSession). This base/default implementation just synchronously calls DoCommitTransaction(FileSystemSession) and returns already completed Task with result returned by DoCommitTransaction(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoConfigure | Override to perform custom configuration (Inherited from FileSystem.)
Protected method | DoCreateDirectory | (Overrides FileSystem DoCreateDirectory(FileSystemDirectory, String).)
Protected method | DoCreateDirectoryAsync | Async version of DoCreateDirectory(FileSystemDirectory, String). This base/default implementation just synchronously calls DoCreateDirectory(FileSystemDirectory, String) and returns already completed Task with result returned by DoCreateDirectory(FileSystemDirectory, String) (Inherited from FileSystem.)
Protected method | DoCreateFile(FileSystemDirectory, String, Int32) | (Overrides FileSystem DoCreateFile(FileSystemDirectory, String, Int32).)
Protected method | DoCreateFile(FileSystemDirectory, String, String, Boolean) | (Overrides FileSystem DoCreateFile(FileSystemDirectory, String, String, Boolean).)
Protected method | DoCreateFileAsync(FileSystemDirectory, String, Int32) | Async version of DoCreateFile(FileSystemDirectory, String, Int32). This base/default implementation just synchronously calls DoCreateFile(FileSystemDirectory, String, Int32) and returns already completed Task with result returned by DoCreateFile(FileSystemDirectory, String, Int32) (Inherited from FileSystem.)
Protected method | DoCreateFileAsync(FileSystemDirectory, String, String, Boolean) | Async version of DoCreateFile(FileSystemDirectory, String, String, Boolean). This base/default implementation just synchronously calls DoCreateFile(FileSystemDirectory, String, String, Boolean) and returns already completed Task with result returned by DoCreateFile(FileSystemDirectory, String, String, Boolean) (Inherited from FileSystem.)
Protected method | DoDeleteItem | (Overrides FileSystem DoDeleteItem(FileSystemSessionItem).)
Protected method | DoDeleteItemAsync | Async version of DoDeleteItem(FileSystemSessionItem). This base/default implementation just synchronously calls DoDeleteItem(FileSystemSessionItem) and returns already completed Task with result returned by DoDeleteItem(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoDirectoryDeepCopyAsync | Implements asynchronous deep copy of folders where destination folder may belong to a different file system. The specifics of implementation may be dictated by particular file systems, i.e.: asynchronous strategies for getting file lists may depend on the particular system. (Inherited from FileSystem.)
Protected method | DoFlushAsync | (Inherited from FileSystem.)
Protected method | DoGetCreationTimestamp | (Overrides FileSystem DoGetCreationTimestamp(FileSystemSessionItem).)
Protected method | DoGetCreationUser | Override in particular file systems to get user who created item. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetCreationUserAsync | Async version of DoGetCreationUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetCreationUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetCreationUser(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetFileNames | (Overrides FileSystem DoGetFileNames(FileSystemDirectory, Boolean).)
Protected method | DoGetFileNamesAsync | Async version of DoGetFileNames(FileSystemDirectory, Boolean). This base/default implementation just synchronously calls DoGetFileNames(FileSystemDirectory, Boolean) and returns already completed Task with result returned by DoGetFileNames(FileSystemDirectory, Boolean) (Inherited from FileSystem.)
Protected method | DoGetFileStream | (Overrides FileSystem DoGetFileStream(FileSystemFile, Action FileSystemStream ).)
Protected method | DoGetFileStreamAsync | Async version of DoGetFileStream(FileSystemFile, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetFileStream(FileSystemFile, Action FileSystemStream ) and returns already completed Task with result returned by DoGetFileStream(FileSystemFile, Action FileSystemStream ) (Inherited from FileSystem.)
Protected method | DoGetItemSize | (Overrides FileSystem DoGetItemSize(FileSystemSessionItem).)
Protected method | DoGetItemSizeAsync | Async version of DoGetItemSize(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetItemSize(FileSystemSessionItem) and returns already completed Task with result returned by DoGetItemSize(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetLastAccessTimestamp | (Overrides FileSystem DoGetLastAccessTimestamp(FileSystemSessionItem).)
Protected method | DoGetLastAccessUser | Override in particular file systems to get user who was the last user accessing the item. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetLastAccessUserAsync | Async version of DoGetLastAccessUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetLastAccessUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetLastAccessUser(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetLatestVersion | Override in particular file systems that support versioning to get latest version object that this session can work with. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetLatestVersionAsync | Async version of DoGetLatestVersion(FileSystemSession). This base/default implementation just synchronously calls DoGetLatestVersion(FileSystemSession) and returns already completed Task with result returned by DoGetLatestVersion(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoGetMetadataStream | (Overrides FileSystem DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ).)
Protected method | DoGetMetadataStreamAsync | Async version of DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ) and returns already completed Task with result returned by DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ) (Inherited from FileSystem.)
Protected method | DoGetModificationTimestamp | (Overrides FileSystem DoGetModificationTimestamp(FileSystemSessionItem).)
Protected method | DoGetModificationUser | Override in particular file systems to get user who was the last user modifying the item. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetModificationUserAsync | Async version of DoGetModificationUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetModificationUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetModificationUser(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetPermissionsStream | (Overrides FileSystem DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ).)
Protected method | DoGetPermissionsStreamAsync | Async version of DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ) and returns already completed Task with result returned by DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ) (Inherited from FileSystem.)
Protected method | DoGetReadOnly | (Overrides FileSystem DoGetReadOnly(FileSystemSessionItem).)
Protected method | DoGetSubDirectoryNames | (Overrides FileSystem DoGetSubDirectoryNames(FileSystemDirectory, Boolean).)
Protected method | DoGetSubDirectoryNamesAsync | Async version of DoGetSubDirectoryNames(FileSystemDirectory, Boolean). This base/default implementation just synchronously calls DoGetSubDirectoryNames(FileSystemDirectory, Boolean) and returns already completed Task with result returned by DoGetSubDirectoryNames(FileSystemDirectory, Boolean) (Inherited from FileSystem.)
Protected method | DoGetVersion | Override in particular file systems that support versioning to get version object for session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetVersionAsync | Async version of DoGetVersion(FileSystemSession). This base/default implementation just synchronously calls DoGetVersion(FileSystemSession) and returns already completed Task with result returned by DoGetVersion(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoNavigate | (Overrides FileSystem DoNavigate(FileSystemSession, String).)
Protected method | DoNavigateAsync | Async version of DoNavigate(FileSystemSession, String). This base/default implementation just synchronously calls DoNavigate(FileSystemSession, String) and returns already completed Task with result returned by DoNavigate(FileSystemSession, String) (Inherited from FileSystem.)
Protected method | DoReadAsync | (Inherited from FileSystem.)
Protected method | DoRefresh | Override to refresh item state, i.e. re-fetch remote information. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoRefreshAsync | Async version of DoRefreshAsync(FileSystemSessionItem). This base/default implementation just synchronously calls DoRefreshAsync(FileSystemSessionItem) and returns already completed Task with result returned by DoRefreshAsync(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoRenameItem | (Overrides FileSystem DoRenameItem(FileSystemSessionItem, String).)
Protected method | DoRenameItemAsync | Async version of DoRenameItem(FileSystemSessionItem, String). This base/default implementation just synchronously calls DoRenameItem(FileSystemSessionItem, String) and returns already completed Task with result returned by DoRenameItem(FileSystemSessionItem, String) (Inherited from FileSystem.)
Protected method | DoRollbackTransaction | Override in particular file systems that support transactions to rollback transaction in specified session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoRollbackTransactionAsync | Async version of DoRollbackTransaction(FileSystemSession). This base/default implementation just synchronously calls DoRollbackTransaction(FileSystemSession) and returns already completed Task with result returned by DoRollbackTransaction(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoSetCreationTimestamp | (Overrides FileSystem DoSetCreationTimestamp(FileSystemSessionItem, DateTime).)
Protected method | DoSetCreationTimestampAsync | Async version of DoSetCreationTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetCreationTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetCreationTimestamp(FileSystemSessionItem, DateTime) (Inherited from FileSystem.)
Protected method | DoSetLastAccessTimestamp | (Overrides FileSystem DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime).)
Protected method | DoSetLastAccessTimestampAsync | Async version of DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime) (Inherited from FileSystem.)
Protected method | DoSetModificationTimestamp | (Overrides FileSystem DoSetModificationTimestamp(FileSystemSessionItem, DateTime).)
Protected method | DoSetModificationTimestampAsync | Async version of DoSetModificationTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetModificationTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetModificationTimestamp(FileSystemSessionItem, DateTime) (Inherited from FileSystem.)
Protected method | DoSetReadOnly | (Overrides FileSystem DoSetReadOnly(FileSystemSessionItem, Boolean).)
Protected method | DoSetReadOnlyAsync | Async version of DoSetReadOnly(FileSystemSessionItem, Boolean). This base/default implementation just synchronously calls DoSetReadOnly(FileSystemSessionItem, Boolean) and returns already completed Task with result returned by DoSetReadOnly(FileSystemSessionItem, Boolean) (Inherited from FileSystem.)
Protected method | DoSetVersion | Override in particular file systems that support versioning to set seesion to specific version. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoSetVersionAsync | Async version of DoSetVersion(FileSystemSession, IFileSystemVersion). This base/default implementation just synchronously calls DoSetVersion(FileSystemSession, IFileSystemVersion) and returns already completed Task with result returned by DoSetVersion(FileSystemSession, IFileSystemVersion) (Inherited from FileSystem.)
Protected method | DoWriteAsync | (Inherited from FileSystem.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeSessionConfigParams | (Overrides FileSystem MakeSessionConfigParams(IConfigSectionNode).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | StartSession(FileSystemSessionConnectParams) | (Overrides FileSystem StartSession(FileSystemSessionConnectParams).)
Public method | StartSession(S3V4FileSystemSessionConnectParams) |
Public method | ToString | (Inherited from FileSystem.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Name | (Inherited from FileSystem.)
Protected field | m_Sessions | (Inherited from FileSystem.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | (Overrides ApplicationComponent ComponentCommonName.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Protected property | DefaultSessionConnectParams | (Inherited from FileSystem.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | GeneralCapabilities | (Overrides FileSystem GeneralCapabilities.)
Public property | InstanceCapabilities | (Overrides FileSystem InstanceCapabilities.)
Public property | Name | Provides name for file system instance (Inherited from FileSystem.)
Public property | Sessions | Returns a list of sessions. This accessor is thread-safe (Inherited from FileSystem.)
Back to Top
See Also
S3V4FileSystem Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem Constructor

S3V4FileSystem Constructor NFX Class Library

Initializes a new instance of the S3V4FileSystem class

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public S3V4FileSystem(
    string name,
    IConfigSectionNode node = null
)
public S3V4FileSystem(
    string name,
    IConfigSectionNode node = null
)
Public Sub New (
    name As String,
    Optional node As IConfigSectionNode = Nothing
)
Public Sub New (
    name As String,
    Optional node As IConfigSectionNode = Nothing
)
public:
S3V4FileSystem(
    String^ name,
    IConfigSectionNode^ node = nullptr
)
public:
S3V4FileSystem(
    String^ name,
    IConfigSectionNode^ node = nullptr
)
new :
        name : string *
        ?node : IConfigSectionNode
(* Defaults:
        let _node = defaultArg node null
*)
-> S3V4FileSystem
new :
        name : string *
        ?node : IConfigSectionNode
(* Defaults:
        let _node = defaultArg node null
*)
-> S3V4FileSystem

Parameters

name
Type: Online System String
node (Optional)
Type: NFX.Environment IConfigSectionNode
See Also
S3V4FileSystem Class
S3V4FileSystem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem Fields

S3V4FileSystem Fields NFX Class Library

The S3V4FileSystem type exposes the following members.
Fields
 | Name | Description
Protected field | m_Name | (Inherited from FileSystem.)
Protected field | m_Sessions | (Inherited from FileSystem.)
Back to Top
See Also
S3V4FileSystem Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem Methods

S3V4FileSystem Methods NFX Class Library

The S3V4FileSystem type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | CombinePaths | Combines two or more path segments joining them using primary file system path separator. This method is thread-safe (Inherited from FileSystem.)
Public method | Configure | Configures file system. This method is a part of lifecycle management and is intended to be called only by creating thread (not thread-safe) (Inherited from FileSystem.)
Protected method | Destructor | (Inherited from FileSystem.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoBeginTransaction | Override in particular file systems that support transactions to begin transaction in specified session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoBeginTransactionAsync | Async version of DoBeginTransaction(FileSystemSession). This base/default implementation just synchronously calls DoBeginTransaction(FileSystemSession) and returns already completed Task with result returned by DoBeginTransaction(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoCheckCanChange | Override in particular file systems to see if item can change, i.e. for file systems that support versioning throw exception if item is in session which "looks" at a sealed/closed version and can not change. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoCheckCanChangeAsync | Async version of DoCheckCanChange(FileSystemSessionItem). This base/default implementation just synchronously calls DoCheckCanChange(FileSystemSessionItem) and returns already completed Task with result returned by DoCheckCanChange(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoCommitTransaction | Override in particular file systems that support transactions to commit transaction in specified session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoCommitTransactionAsync | Async version of DoCommitTransaction(FileSystemSession). This base/default implementation just synchronously calls DoCommitTransaction(FileSystemSession) and returns already completed Task with result returned by DoCommitTransaction(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoConfigure | Override to perform custom configuration (Inherited from FileSystem.)
Protected method | DoCreateDirectory | (Overrides FileSystem DoCreateDirectory(FileSystemDirectory, String).)
Protected method | DoCreateDirectoryAsync | Async version of DoCreateDirectory(FileSystemDirectory, String). This base/default implementation just synchronously calls DoCreateDirectory(FileSystemDirectory, String) and returns already completed Task with result returned by DoCreateDirectory(FileSystemDirectory, String) (Inherited from FileSystem.)
Protected method | DoCreateFile(FileSystemDirectory, String, Int32) | (Overrides FileSystem DoCreateFile(FileSystemDirectory, String, Int32).)
Protected method | DoCreateFile(FileSystemDirectory, String, String, Boolean) | (Overrides FileSystem DoCreateFile(FileSystemDirectory, String, String, Boolean).)
Protected method | DoCreateFileAsync(FileSystemDirectory, String, Int32) | Async version of DoCreateFile(FileSystemDirectory, String, Int32). This base/default implementation just synchronously calls DoCreateFile(FileSystemDirectory, String, Int32) and returns already completed Task with result returned by DoCreateFile(FileSystemDirectory, String, Int32) (Inherited from FileSystem.)
Protected method | DoCreateFileAsync(FileSystemDirectory, String, String, Boolean) | Async version of DoCreateFile(FileSystemDirectory, String, String, Boolean). This base/default implementation just synchronously calls DoCreateFile(FileSystemDirectory, String, String, Boolean) and returns already completed Task with result returned by DoCreateFile(FileSystemDirectory, String, String, Boolean) (Inherited from FileSystem.)
Protected method | DoDeleteItem | (Overrides FileSystem DoDeleteItem(FileSystemSessionItem).)
Protected method | DoDeleteItemAsync | Async version of DoDeleteItem(FileSystemSessionItem). This base/default implementation just synchronously calls DoDeleteItem(FileSystemSessionItem) and returns already completed Task with result returned by DoDeleteItem(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoDirectoryDeepCopyAsync | Implements asynchronous deep copy of folders where destination folder may belong to a different file system. The specifics of implementation may be dictated by particular file systems, i.e.: asynchronous strategies for getting file lists may depend on the particular system. (Inherited from FileSystem.)
Protected method | DoFlushAsync | (Inherited from FileSystem.)
Protected method | DoGetCreationTimestamp | (Overrides FileSystem DoGetCreationTimestamp(FileSystemSessionItem).)
Protected method | DoGetCreationUser | Override in particular file systems to get user who created item. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetCreationUserAsync | Async version of DoGetCreationUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetCreationUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetCreationUser(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetFileNames | (Overrides FileSystem DoGetFileNames(FileSystemDirectory, Boolean).)
Protected method | DoGetFileNamesAsync | Async version of DoGetFileNames(FileSystemDirectory, Boolean). This base/default implementation just synchronously calls DoGetFileNames(FileSystemDirectory, Boolean) and returns already completed Task with result returned by DoGetFileNames(FileSystemDirectory, Boolean) (Inherited from FileSystem.)
Protected method | DoGetFileStream | (Overrides FileSystem DoGetFileStream(FileSystemFile, Action FileSystemStream ).)
Protected method | DoGetFileStreamAsync | Async version of DoGetFileStream(FileSystemFile, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetFileStream(FileSystemFile, Action FileSystemStream ) and returns already completed Task with result returned by DoGetFileStream(FileSystemFile, Action FileSystemStream ) (Inherited from FileSystem.)
Protected method | DoGetItemSize | (Overrides FileSystem DoGetItemSize(FileSystemSessionItem).)
Protected method | DoGetItemSizeAsync | Async version of DoGetItemSize(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetItemSize(FileSystemSessionItem) and returns already completed Task with result returned by DoGetItemSize(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetLastAccessTimestamp | (Overrides FileSystem DoGetLastAccessTimestamp(FileSystemSessionItem).)
Protected method | DoGetLastAccessUser | Override in particular file systems to get user who was the last user accessing the item. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetLastAccessUserAsync | Async version of DoGetLastAccessUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetLastAccessUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetLastAccessUser(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetLatestVersion | Override in particular file systems that support versioning to get latest version object that this session can work with. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetLatestVersionAsync | Async version of DoGetLatestVersion(FileSystemSession). This base/default implementation just synchronously calls DoGetLatestVersion(FileSystemSession) and returns already completed Task with result returned by DoGetLatestVersion(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoGetMetadataStream | (Overrides FileSystem DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ).)
Protected method | DoGetMetadataStreamAsync | Async version of DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ) and returns already completed Task with result returned by DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ) (Inherited from FileSystem.)
Protected method | DoGetModificationTimestamp | (Overrides FileSystem DoGetModificationTimestamp(FileSystemSessionItem).)
Protected method | DoGetModificationUser | Override in particular file systems to get user who was the last user modifying the item. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetModificationUserAsync | Async version of DoGetModificationUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetModificationUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetModificationUser(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetPermissionsStream | (Overrides FileSystem DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ).)
Protected method | DoGetPermissionsStreamAsync | Async version of DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ) and returns already completed Task with result returned by DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ) (Inherited from FileSystem.)
Protected method | DoGetReadOnly | (Overrides FileSystem DoGetReadOnly(FileSystemSessionItem).)
Protected method | DoGetSubDirectoryNames | (Overrides FileSystem DoGetSubDirectoryNames(FileSystemDirectory, Boolean).)
Protected method | DoGetSubDirectoryNamesAsync | Async version of DoGetSubDirectoryNames(FileSystemDirectory, Boolean). This base/default implementation just synchronously calls DoGetSubDirectoryNames(FileSystemDirectory, Boolean) and returns already completed Task with result returned by DoGetSubDirectoryNames(FileSystemDirectory, Boolean) (Inherited from FileSystem.)
Protected method | DoGetVersion | Override in particular file systems that support versioning to get version object for session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetVersionAsync | Async version of DoGetVersion(FileSystemSession). This base/default implementation just synchronously calls DoGetVersion(FileSystemSession) and returns already completed Task with result returned by DoGetVersion(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoNavigate | (Overrides FileSystem DoNavigate(FileSystemSession, String).)
Protected method | DoNavigateAsync | Async version of DoNavigate(FileSystemSession, String). This base/default implementation just synchronously calls DoNavigate(FileSystemSession, String) and returns already completed Task with result returned by DoNavigate(FileSystemSession, String) (Inherited from FileSystem.)
Protected method | DoReadAsync | (Inherited from FileSystem.)
Protected method | DoRefresh | Override to refresh item state, i.e. re-fetch remote information. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoRefreshAsync | Async version of DoRefreshAsync(FileSystemSessionItem). This base/default implementation just synchronously calls DoRefreshAsync(FileSystemSessionItem) and returns already completed Task with result returned by DoRefreshAsync(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoRenameItem | (Overrides FileSystem DoRenameItem(FileSystemSessionItem, String).)
Protected method | DoRenameItemAsync | Async version of DoRenameItem(FileSystemSessionItem, String). This base/default implementation just synchronously calls DoRenameItem(FileSystemSessionItem, String) and returns already completed Task with result returned by DoRenameItem(FileSystemSessionItem, String) (Inherited from FileSystem.)
Protected method | DoRollbackTransaction | Override in particular file systems that support transactions to rollback transaction in specified session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoRollbackTransactionAsync | Async version of DoRollbackTransaction(FileSystemSession). This base/default implementation just synchronously calls DoRollbackTransaction(FileSystemSession) and returns already completed Task with result returned by DoRollbackTransaction(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoSetCreationTimestamp | (Overrides FileSystem DoSetCreationTimestamp(FileSystemSessionItem, DateTime).)
Protected method | DoSetCreationTimestampAsync | Async version of DoSetCreationTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetCreationTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetCreationTimestamp(FileSystemSessionItem, DateTime) (Inherited from FileSystem.)
Protected method | DoSetLastAccessTimestamp | (Overrides FileSystem DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime).)
Protected method | DoSetLastAccessTimestampAsync | Async version of DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime) (Inherited from FileSystem.)
Protected method | DoSetModificationTimestamp | (Overrides FileSystem DoSetModificationTimestamp(FileSystemSessionItem, DateTime).)
Protected method | DoSetModificationTimestampAsync | Async version of DoSetModificationTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetModificationTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetModificationTimestamp(FileSystemSessionItem, DateTime) (Inherited from FileSystem.)
Protected method | DoSetReadOnly | (Overrides FileSystem DoSetReadOnly(FileSystemSessionItem, Boolean).)
Protected method | DoSetReadOnlyAsync | Async version of DoSetReadOnly(FileSystemSessionItem, Boolean). This base/default implementation just synchronously calls DoSetReadOnly(FileSystemSessionItem, Boolean) and returns already completed Task with result returned by DoSetReadOnly(FileSystemSessionItem, Boolean) (Inherited from FileSystem.)
Protected method | DoSetVersion | Override in particular file systems that support versioning to set seesion to specific version. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoSetVersionAsync | Async version of DoSetVersion(FileSystemSession, IFileSystemVersion). This base/default implementation just synchronously calls DoSetVersion(FileSystemSession, IFileSystemVersion) and returns already completed Task with result returned by DoSetVersion(FileSystemSession, IFileSystemVersion) (Inherited from FileSystem.)
Protected method | DoWriteAsync | (Inherited from FileSystem.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeSessionConfigParams | (Overrides FileSystem MakeSessionConfigParams(IConfigSectionNode).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | StartSession(FileSystemSessionConnectParams) | (Overrides FileSystem StartSession(FileSystemSessionConnectParams).)
Public method | StartSession(S3V4FileSystemSessionConnectParams) |
Public method | ToString | (Inherited from FileSystem.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
S3V4FileSystem Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.DoCreateDirectory Method

S3V4FileSystem DoCreateDirectory Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemDirectory DoCreateDirectory(
    FileSystemDirectory dir,
    string name
)
protected internal override FileSystemDirectory DoCreateDirectory(
    FileSystemDirectory dir,
    string name
)
Protected Friend Overrides Function DoCreateDirectory (
    dir As FileSystemDirectory,
    name As String
) As FileSystemDirectory
Protected Friend Overrides Function DoCreateDirectory (
    dir As FileSystemDirectory,
    name As String
) As FileSystemDirectory
protected public:
virtual FileSystemDirectory^ DoCreateDirectory(
    FileSystemDirectory^ dir,
    String^ name
) override
protected public:
virtual FileSystemDirectory^ DoCreateDirectory(
    FileSystemDirectory^ dir,
    String^ name
) override
abstract DoCreateDirectory :
        dir : FileSystemDirectory *
        name : string -> FileSystemDirectory
override DoCreateDirectory :
        dir : FileSystemDirectory *
        name : string -> FileSystemDirectory
abstract DoCreateDirectory :
        dir : FileSystemDirectory *
        name : string -> FileSystemDirectory
override DoCreateDirectory :
        dir : FileSystemDirectory *
        name : string -> FileSystemDirectory

Parameters

dir
Type: NFX.IO.FileSystem FileSystemDirectory
name
Type: Online System String

Return Value

Type: FileSystemDirectory
See Also
S3V4FileSystem Class
S3V4FileSystem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.DoCreateFile Method

S3V4FileSystem DoCreateFile Method NFX Class Library

Overload List
 | Name | Description
Protected method | DoCreateFile(FileSystemDirectory, String, Int32) | (Overrides FileSystem DoCreateFile(FileSystemDirectory, String, Int32).)
Protected method | DoCreateFile(FileSystemDirectory, String, String, Boolean) | (Overrides FileSystem DoCreateFile(FileSystemDirectory, String, String, Boolean).)
Back to Top
See Also
S3V4FileSystem Class
S3V4FileSystem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.DoCreateFile Method (FileSystemDirectory, String, Int32)

S3V4FileSystem DoCreateFile Method (FileSystemDirectory, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemFile DoCreateFile(
    FileSystemDirectory dir,
    string name,
    int size
)
protected internal override FileSystemFile DoCreateFile(
    FileSystemDirectory dir,
    string name,
    int size
)
Protected Friend Overrides Function DoCreateFile (
    dir As FileSystemDirectory,
    name As String,
    size As Integer
) As FileSystemFile
Protected Friend Overrides Function DoCreateFile (
    dir As FileSystemDirectory,
    name As String,
    size As Integer
) As FileSystemFile
protected public:
virtual FileSystemFile^ DoCreateFile(
    FileSystemDirectory^ dir,
    String^ name,
    int size
) override
protected public:
virtual FileSystemFile^ DoCreateFile(
    FileSystemDirectory^ dir,
    String^ name,
    int size
) override
abstract DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        size : int -> FileSystemFile
override DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        size : int -> FileSystemFile
abstract DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        size : int -> FileSystemFile
override DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        size : int -> FileSystemFile

Parameters

dir
Type: NFX.IO.FileSystem FileSystemDirectory
name
Type: Online System String
size
Type: Online System Int32

Return Value

Type: FileSystemFile
See Also
S3V4FileSystem Class
S3V4FileSystem Members
DoCreateFile Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.DoCreateFile Method (FileSystemDirectory, String, String, Boolean)

S3V4FileSystem DoCreateFile Method (FileSystemDirectory, String, String, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemFile DoCreateFile(
    FileSystemDirectory dir,
    string name,
    string localFile,
    bool readOnly
)
protected internal override FileSystemFile DoCreateFile(
    FileSystemDirectory dir,
    string name,
    string localFile,
    bool readOnly
)
Protected Friend Overrides Function DoCreateFile (
    dir As FileSystemDirectory,
    name As String,
    localFile As String,
    readOnly As Boolean
) As FileSystemFile
Protected Friend Overrides Function DoCreateFile (
    dir As FileSystemDirectory,
    name As String,
    localFile As String,
    readOnly As Boolean
) As FileSystemFile
protected public:
virtual FileSystemFile^ DoCreateFile(
    FileSystemDirectory^ dir,
    String^ name,
    String^ localFile,
    bool readOnly
) override
protected public:
virtual FileSystemFile^ DoCreateFile(
    FileSystemDirectory^ dir,
    String^ name,
    String^ localFile,
    bool readOnly
) override
abstract DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        localFile : string *
        readOnly : bool -> FileSystemFile
override DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        localFile : string *
        readOnly : bool -> FileSystemFile
abstract DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        localFile : string *
        readOnly : bool -> FileSystemFile
override DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        localFile : string *
        readOnly : bool -> FileSystemFile

Parameters

dir
Type: NFX.IO.FileSystem FileSystemDirectory
name
Type: Online System String
localFile
Type: Online System String
readOnly
Type: Online System Boolean

Return Value

Type: FileSystemFile
See Also
S3V4FileSystem Class
S3V4FileSystem Members
DoCreateFile Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.DoDeleteItem Method

S3V4FileSystem DoDeleteItem Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoDeleteItem(
    FileSystemSessionItem item
)
protected internal override void DoDeleteItem(
    FileSystemSessionItem item
)
Protected Friend Overrides Sub DoDeleteItem (
    item As FileSystemSessionItem
)
Protected Friend Overrides Sub DoDeleteItem (
    item As FileSystemSessionItem
)
protected public:
virtual void DoDeleteItem(
    FileSystemSessionItem^ item
) override
protected public:
virtual void DoDeleteItem(
    FileSystemSessionItem^ item
) override
abstract DoDeleteItem :
        item : FileSystemSessionItem -> unit
override DoDeleteItem :
        item : FileSystemSessionItem -> unit
abstract DoDeleteItem :
        item : FileSystemSessionItem -> unit
override DoDeleteItem :
        item : FileSystemSessionItem -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
See Also
S3V4FileSystem Class
S3V4FileSystem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.DoGetCreationTimestamp Method

S3V4FileSystem DoGetCreationTimestamp Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override Nullable<DateTime> DoGetCreationTimestamp(
    FileSystemSessionItem item
)
protected internal override Nullable<DateTime> DoGetCreationTimestamp(
    FileSystemSessionItem item
)
Protected Friend Overrides Function DoGetCreationTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
Protected Friend Overrides Function DoGetCreationTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
protected public:
virtual Nullable<DateTime> DoGetCreationTimestamp(
    FileSystemSessionItem^ item
) override
protected public:
virtual Nullable<DateTime> DoGetCreationTimestamp(
    FileSystemSessionItem^ item
) override
abstract DoGetCreationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
override DoGetCreationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
abstract DoGetCreationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
override DoGetCreationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online Nullable Online DateTime
See Also
S3V4FileSystem Class
S3V4FileSystem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.DoGetFileNames Method

S3V4FileSystem DoGetFileNames Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override IEnumerable<string> DoGetFileNames(
    FileSystemDirectory directory,
    bool recursive
)
protected internal override IEnumerable<string> DoGetFileNames(
    FileSystemDirectory directory,
    bool recursive
)
Protected Friend Overrides Function DoGetFileNames (
    directory As FileSystemDirectory,
    recursive As Boolean
) As IEnumerable(Of String)
Protected Friend Overrides Function DoGetFileNames (
    directory As FileSystemDirectory,
    recursive As Boolean
) As IEnumerable(Of String)
protected public:
virtual IEnumerable<String^>^ DoGetFileNames(
    FileSystemDirectory^ directory,
    bool recursive
) override
protected public:
virtual IEnumerable<String^>^ DoGetFileNames(
    FileSystemDirectory^ directory,
    bool recursive
) override
abstract DoGetFileNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>
override DoGetFileNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>
abstract DoGetFileNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>
override DoGetFileNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>

Parameters

directory
Type: NFX.IO.FileSystem FileSystemDirectory
recursive
Type: Online System Boolean

Return Value

Type: Online IEnumerable Online String
See Also
S3V4FileSystem Class
S3V4FileSystem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.DoGetFileStream Method

S3V4FileSystem DoGetFileStream Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemStream DoGetFileStream(
    FileSystemFile file,
    Action<FileSystemStream> disposeAction
)
protected internal override FileSystemStream DoGetFileStream(
    FileSystemFile file,
    Action<FileSystemStream> disposeAction
)
Protected Friend Overrides Function DoGetFileStream (
    file As FileSystemFile,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
Protected Friend Overrides Function DoGetFileStream (
    file As FileSystemFile,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
protected public:
virtual FileSystemStream^ DoGetFileStream(
    FileSystemFile^ file,
    Action<FileSystemStream^>^ disposeAction
) override
protected public:
virtual FileSystemStream^ DoGetFileStream(
    FileSystemFile^ file,
    Action<FileSystemStream^>^ disposeAction
) override
abstract DoGetFileStream :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
override DoGetFileStream :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
abstract DoGetFileStream :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
override DoGetFileStream :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> FileSystemStream

Parameters

file
Type: NFX.IO.FileSystem FileSystemFile
disposeAction
Type: Online System Action FileSystemStream

Return Value

Type: FileSystemStream
See Also
S3V4FileSystem Class
S3V4FileSystem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.DoGetItemSize Method

S3V4FileSystem DoGetItemSize Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override ulong DoGetItemSize(
    FileSystemSessionItem item
)
protected internal override ulong DoGetItemSize(
    FileSystemSessionItem item
)
Protected Friend Overrides Function DoGetItemSize (
    item As FileSystemSessionItem
) As ULong
Protected Friend Overrides Function DoGetItemSize (
    item As FileSystemSessionItem
) As ULong
protected public:
virtual unsigned long long DoGetItemSize(
    FileSystemSessionItem^ item
) override
protected public:
virtual unsigned long long DoGetItemSize(
    FileSystemSessionItem^ item
) override
abstract DoGetItemSize :
        item : FileSystemSessionItem -> uint64
override DoGetItemSize :
        item : FileSystemSessionItem -> uint64
abstract DoGetItemSize :
        item : FileSystemSessionItem -> uint64
override DoGetItemSize :
        item : FileSystemSessionItem -> uint64

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online UInt64
See Also
S3V4FileSystem Class
S3V4FileSystem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.DoGetLastAccessTimestamp Method

S3V4FileSystem DoGetLastAccessTimestamp Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override Nullable<DateTime> DoGetLastAccessTimestamp(
    FileSystemSessionItem item
)
protected internal override Nullable<DateTime> DoGetLastAccessTimestamp(
    FileSystemSessionItem item
)
Protected Friend Overrides Function DoGetLastAccessTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
Protected Friend Overrides Function DoGetLastAccessTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
protected public:
virtual Nullable<DateTime> DoGetLastAccessTimestamp(
    FileSystemSessionItem^ item
) override
protected public:
virtual Nullable<DateTime> DoGetLastAccessTimestamp(
    FileSystemSessionItem^ item
) override
abstract DoGetLastAccessTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
override DoGetLastAccessTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
abstract DoGetLastAccessTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
override DoGetLastAccessTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online Nullable Online DateTime
See Also
S3V4FileSystem Class
S3V4FileSystem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.DoGetMetadataStream Method

S3V4FileSystem DoGetMetadataStream Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemStream DoGetMetadataStream(
    FileSystemSessionItem item,
    Action<FileSystemStream> disposeAction
)
protected internal override FileSystemStream DoGetMetadataStream(
    FileSystemSessionItem item,
    Action<FileSystemStream> disposeAction
)
Protected Friend Overrides Function DoGetMetadataStream (
    item As FileSystemSessionItem,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
Protected Friend Overrides Function DoGetMetadataStream (
    item As FileSystemSessionItem,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
protected public:
virtual FileSystemStream^ DoGetMetadataStream(
    FileSystemSessionItem^ item,
    Action<FileSystemStream^>^ disposeAction
) override
protected public:
virtual FileSystemStream^ DoGetMetadataStream(
    FileSystemSessionItem^ item,
    Action<FileSystemStream^>^ disposeAction
) override
abstract DoGetMetadataStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
override DoGetMetadataStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
abstract DoGetMetadataStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
override DoGetMetadataStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
disposeAction
Type: Online System Action FileSystemStream

Return Value

Type: FileSystemStream
See Also
S3V4FileSystem Class
S3V4FileSystem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.DoGetModificationTimestamp Method

S3V4FileSystem DoGetModificationTimestamp Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override Nullable<DateTime> DoGetModificationTimestamp(
    FileSystemSessionItem item
)
protected internal override Nullable<DateTime> DoGetModificationTimestamp(
    FileSystemSessionItem item
)
Protected Friend Overrides Function DoGetModificationTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
Protected Friend Overrides Function DoGetModificationTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
protected public:
virtual Nullable<DateTime> DoGetModificationTimestamp(
    FileSystemSessionItem^ item
) override
protected public:
virtual Nullable<DateTime> DoGetModificationTimestamp(
    FileSystemSessionItem^ item
) override
abstract DoGetModificationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
override DoGetModificationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
abstract DoGetModificationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
override DoGetModificationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online Nullable Online DateTime
See Also
S3V4FileSystem Class
S3V4FileSystem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.DoGetPermissionsStream Method

S3V4FileSystem DoGetPermissionsStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemStream DoGetPermissionsStream(
    FileSystemSessionItem item,
    Action<FileSystemStream> disposeAction
)
protected internal override FileSystemStream DoGetPermissionsStream(
    FileSystemSessionItem item,
    Action<FileSystemStream> disposeAction
)
Protected Friend Overrides Function DoGetPermissionsStream (
    item As FileSystemSessionItem,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
Protected Friend Overrides Function DoGetPermissionsStream (
    item As FileSystemSessionItem,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
protected public:
virtual FileSystemStream^ DoGetPermissionsStream(
    FileSystemSessionItem^ item,
    Action<FileSystemStream^>^ disposeAction
) override
protected public:
virtual FileSystemStream^ DoGetPermissionsStream(
    FileSystemSessionItem^ item,
    Action<FileSystemStream^>^ disposeAction
) override
abstract DoGetPermissionsStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
override DoGetPermissionsStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
abstract DoGetPermissionsStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
override DoGetPermissionsStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
disposeAction
Type: Online System Action FileSystemStream

Return Value

Type: FileSystemStream
See Also
S3V4FileSystem Class
S3V4FileSystem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.DoGetReadOnly Method

S3V4FileSystem DoGetReadOnly Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override bool DoGetReadOnly(
    FileSystemSessionItem item
)
protected internal override bool DoGetReadOnly(
    FileSystemSessionItem item
)
Protected Friend Overrides Function DoGetReadOnly (
    item As FileSystemSessionItem
) As Boolean
Protected Friend Overrides Function DoGetReadOnly (
    item As FileSystemSessionItem
) As Boolean
protected public:
virtual bool DoGetReadOnly(
    FileSystemSessionItem^ item
) override
protected public:
virtual bool DoGetReadOnly(
    FileSystemSessionItem^ item
) override
abstract DoGetReadOnly :
        item : FileSystemSessionItem -> bool
override DoGetReadOnly :
        item : FileSystemSessionItem -> bool
abstract DoGetReadOnly :
        item : FileSystemSessionItem -> bool
override DoGetReadOnly :
        item : FileSystemSessionItem -> bool

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online Boolean
See Also
S3V4FileSystem Class
S3V4FileSystem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.DoGetSubDirectoryNames Method

S3V4FileSystem DoGetSubDirectoryNames Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override IEnumerable<string> DoGetSubDirectoryNames(
    FileSystemDirectory directory,
    bool recursive
)
protected internal override IEnumerable<string> DoGetSubDirectoryNames(
    FileSystemDirectory directory,
    bool recursive
)
Protected Friend Overrides Function DoGetSubDirectoryNames (
    directory As FileSystemDirectory,
    recursive As Boolean
) As IEnumerable(Of String)
Protected Friend Overrides Function DoGetSubDirectoryNames (
    directory As FileSystemDirectory,
    recursive As Boolean
) As IEnumerable(Of String)
protected public:
virtual IEnumerable<String^>^ DoGetSubDirectoryNames(
    FileSystemDirectory^ directory,
    bool recursive
) override
protected public:
virtual IEnumerable<String^>^ DoGetSubDirectoryNames(
    FileSystemDirectory^ directory,
    bool recursive
) override
abstract DoGetSubDirectoryNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>
override DoGetSubDirectoryNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>
abstract DoGetSubDirectoryNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>
override DoGetSubDirectoryNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>

Parameters

directory
Type: NFX.IO.FileSystem FileSystemDirectory
recursive
Type: Online System Boolean

Return Value

Type: Online IEnumerable Online String
See Also
S3V4FileSystem Class
S3V4FileSystem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.DoNavigate Method

S3V4FileSystem DoNavigate Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemSessionItem DoNavigate(
    FileSystemSession session,
    string path
)
protected internal override FileSystemSessionItem DoNavigate(
    FileSystemSession session,
    string path
)
Protected Friend Overrides Function DoNavigate (
    session As FileSystemSession,
    path As String
) As FileSystemSessionItem
Protected Friend Overrides Function DoNavigate (
    session As FileSystemSession,
    path As String
) As FileSystemSessionItem
protected public:
virtual FileSystemSessionItem^ DoNavigate(
    FileSystemSession^ session,
    String^ path
) override
protected public:
virtual FileSystemSessionItem^ DoNavigate(
    FileSystemSession^ session,
    String^ path
) override
abstract DoNavigate :
        session : FileSystemSession *
        path : string -> FileSystemSessionItem
override DoNavigate :
        session : FileSystemSession *
        path : string -> FileSystemSessionItem
abstract DoNavigate :
        session : FileSystemSession *
        path : string -> FileSystemSessionItem
override DoNavigate :
        session : FileSystemSession *
        path : string -> FileSystemSessionItem

Parameters

session
Type: NFX.IO.FileSystem FileSystemSession
path
Type: Online System String

Return Value

Type: FileSystemSessionItem
See Also
S3V4FileSystem Class
S3V4FileSystem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.DoRenameItem Method

S3V4FileSystem DoRenameItem Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override bool DoRenameItem(
    FileSystemSessionItem item,
    string newName
)
protected internal override bool DoRenameItem(
    FileSystemSessionItem item,
    string newName
)
Protected Friend Overrides Function DoRenameItem (
    item As FileSystemSessionItem,
    newName As String
) As Boolean
Protected Friend Overrides Function DoRenameItem (
    item As FileSystemSessionItem,
    newName As String
) As Boolean
protected public:
virtual bool DoRenameItem(
    FileSystemSessionItem^ item,
    String^ newName
) override
protected public:
virtual bool DoRenameItem(
    FileSystemSessionItem^ item,
    String^ newName
) override
abstract DoRenameItem :
        item : FileSystemSessionItem *
        newName : string -> bool
override DoRenameItem :
        item : FileSystemSessionItem *
        newName : string -> bool
abstract DoRenameItem :
        item : FileSystemSessionItem *
        newName : string -> bool
override DoRenameItem :
        item : FileSystemSessionItem *
        newName : string -> bool

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
newName
Type: Online System String

Return Value

Type: Online Boolean
See Also
S3V4FileSystem Class
S3V4FileSystem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.DoSetCreationTimestamp Method

S3V4FileSystem DoSetCreationTimestamp Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoSetCreationTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
protected internal override void DoSetCreationTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
Protected Friend Overrides Sub DoSetCreationTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
Protected Friend Overrides Sub DoSetCreationTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
protected public:
virtual void DoSetCreationTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) override
protected public:
virtual void DoSetCreationTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) override
abstract DoSetCreationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
override DoSetCreationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
abstract DoSetCreationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
override DoSetCreationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
timestamp
Type: Online System DateTime
See Also
S3V4FileSystem Class
S3V4FileSystem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.DoSetLastAccessTimestamp Method

S3V4FileSystem DoSetLastAccessTimestamp Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoSetLastAccessTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
protected internal override void DoSetLastAccessTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
Protected Friend Overrides Sub DoSetLastAccessTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
Protected Friend Overrides Sub DoSetLastAccessTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
protected public:
virtual void DoSetLastAccessTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) override
protected public:
virtual void DoSetLastAccessTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) override
abstract DoSetLastAccessTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
override DoSetLastAccessTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
abstract DoSetLastAccessTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
override DoSetLastAccessTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
timestamp
Type: Online System DateTime
See Also
S3V4FileSystem Class
S3V4FileSystem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.DoSetModificationTimestamp Method

S3V4FileSystem DoSetModificationTimestamp Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoSetModificationTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
protected internal override void DoSetModificationTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
Protected Friend Overrides Sub DoSetModificationTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
Protected Friend Overrides Sub DoSetModificationTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
protected public:
virtual void DoSetModificationTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) override
protected public:
virtual void DoSetModificationTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) override
abstract DoSetModificationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
override DoSetModificationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
abstract DoSetModificationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
override DoSetModificationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
timestamp
Type: Online System DateTime
See Also
S3V4FileSystem Class
S3V4FileSystem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.DoSetReadOnly Method

S3V4FileSystem DoSetReadOnly Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoSetReadOnly(
    FileSystemSessionItem item,
    bool readOnly
)
protected internal override void DoSetReadOnly(
    FileSystemSessionItem item,
    bool readOnly
)
Protected Friend Overrides Sub DoSetReadOnly (
    item As FileSystemSessionItem,
    readOnly As Boolean
)
Protected Friend Overrides Sub DoSetReadOnly (
    item As FileSystemSessionItem,
    readOnly As Boolean
)
protected public:
virtual void DoSetReadOnly(
    FileSystemSessionItem^ item,
    bool readOnly
) override
protected public:
virtual void DoSetReadOnly(
    FileSystemSessionItem^ item,
    bool readOnly
) override
abstract DoSetReadOnly :
        item : FileSystemSessionItem *
        readOnly : bool -> unit
override DoSetReadOnly :
        item : FileSystemSessionItem *
        readOnly : bool -> unit
abstract DoSetReadOnly :
        item : FileSystemSessionItem *
        readOnly : bool -> unit
override DoSetReadOnly :
        item : FileSystemSessionItem *
        readOnly : bool -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
readOnly
Type: Online System Boolean
See Also
S3V4FileSystem Class
S3V4FileSystem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.MakeSessionConfigParams Method

S3V4FileSystem MakeSessionConfigParams Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override FileSystemSessionConnectParams MakeSessionConfigParams(
    IConfigSectionNode node
)
protected override FileSystemSessionConnectParams MakeSessionConfigParams(
    IConfigSectionNode node
)
Protected Overrides Function MakeSessionConfigParams (
    node As IConfigSectionNode
) As FileSystemSessionConnectParams
Protected Overrides Function MakeSessionConfigParams (
    node As IConfigSectionNode
) As FileSystemSessionConnectParams
protected:
virtual FileSystemSessionConnectParams^ MakeSessionConfigParams(
    IConfigSectionNode^ node
) override
protected:
virtual FileSystemSessionConnectParams^ MakeSessionConfigParams(
    IConfigSectionNode^ node
) override
abstract MakeSessionConfigParams :
        node : IConfigSectionNode -> FileSystemSessionConnectParams
override MakeSessionConfigParams :
        node : IConfigSectionNode -> FileSystemSessionConnectParams
abstract MakeSessionConfigParams :
        node : IConfigSectionNode -> FileSystemSessionConnectParams
override MakeSessionConfigParams :
        node : IConfigSectionNode -> FileSystemSessionConnectParams

Parameters

node
Type: NFX.Environment IConfigSectionNode

Return Value

Type: FileSystemSessionConnectParams
See Also
S3V4FileSystem Class
S3V4FileSystem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.StartSession Method

S3V4FileSystem StartSession Method NFX Class Library

Overload List
 | Name | Description
Public method | StartSession(FileSystemSessionConnectParams) | (Overrides FileSystem StartSession(FileSystemSessionConnectParams).)
Public method | StartSession(S3V4FileSystemSessionConnectParams) |
Back to Top
See Also
S3V4FileSystem Class
S3V4FileSystem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.StartSession Method (FileSystemSessionConnectParams)

S3V4FileSystem StartSession Method (FileSystemSessionConnectParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override FileSystemSession StartSession(
    FileSystemSessionConnectParams cParams = null
)
public override FileSystemSession StartSession(
    FileSystemSessionConnectParams cParams = null
)
Public Overrides Function StartSession (
    Optional cParams As FileSystemSessionConnectParams = Nothing
) As FileSystemSession
Public Overrides Function StartSession (
    Optional cParams As FileSystemSessionConnectParams = Nothing
) As FileSystemSession
public:
virtual FileSystemSession^ StartSession(
    FileSystemSessionConnectParams^ cParams = nullptr
) override
public:
virtual FileSystemSession^ StartSession(
    FileSystemSessionConnectParams^ cParams = nullptr
) override
abstract StartSession :
        ?cParams : FileSystemSessionConnectParams
(* Defaults:
        let _cParams = defaultArg cParams null
*)
-> FileSystemSession
override StartSession :
        ?cParams : FileSystemSessionConnectParams
(* Defaults:
        let _cParams = defaultArg cParams null
*)
-> FileSystemSession
abstract StartSession :
        ?cParams : FileSystemSessionConnectParams
(* Defaults:
        let _cParams = defaultArg cParams null
*)
-> FileSystemSession
override StartSession :
        ?cParams : FileSystemSessionConnectParams
(* Defaults:
        let _cParams = defaultArg cParams null
*)
-> FileSystemSession

Parameters

cParams (Optional)
Type: NFX.IO.FileSystem FileSystemSessionConnectParams

Return Value

Type: FileSystemSession

Implements

IFileSystem StartSession(FileSystemSessionConnectParams)
See Also
S3V4FileSystem Class
S3V4FileSystem Members
StartSession Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.StartSession Method (S3V4FileSystemSessionConnectParams)

S3V4FileSystem StartSession Method (S3V4FileSystemSessionConnectParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public S3V4FileSystemSession StartSession(
    S3V4FileSystemSessionConnectParams cParams
)
public S3V4FileSystemSession StartSession(
    S3V4FileSystemSessionConnectParams cParams
)
Public Function StartSession (
    cParams As S3V4FileSystemSessionConnectParams
) As S3V4FileSystemSession
Public Function StartSession (
    cParams As S3V4FileSystemSessionConnectParams
) As S3V4FileSystemSession
public:
S3V4FileSystemSession^ StartSession(
    S3V4FileSystemSessionConnectParams^ cParams
)
public:
S3V4FileSystemSession^ StartSession(
    S3V4FileSystemSessionConnectParams^ cParams
)
member StartSession :
        cParams : S3V4FileSystemSessionConnectParams -> S3V4FileSystemSession
member StartSession :
        cParams : S3V4FileSystemSessionConnectParams -> S3V4FileSystemSession

Parameters

cParams
Type: NFX.IO.FileSystem.S3.V4 S3V4FileSystemSessionConnectParams

Return Value

Type: S3V4FileSystemSession
See Also
S3V4FileSystem Class
S3V4FileSystem Members
StartSession Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem Properties

S3V4FileSystem Properties NFX Class Library

The S3V4FileSystem type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | (Overrides ApplicationComponent ComponentCommonName.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Protected property | DefaultSessionConnectParams | (Inherited from FileSystem.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | GeneralCapabilities | (Overrides FileSystem GeneralCapabilities.)
Public property | InstanceCapabilities | (Overrides FileSystem InstanceCapabilities.)
Public property | Name | Provides name for file system instance (Inherited from FileSystem.)
Public property | Sessions | Returns a list of sessions. This accessor is thread-safe (Inherited from FileSystem.)
Back to Top
See Also
S3V4FileSystem Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.ComponentCommonName Property

S3V4FileSystem ComponentCommonName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ComponentCommonName { get; }
public override string ComponentCommonName { get; }
Public Overrides ReadOnly Property ComponentCommonName As String
    Get
Public Overrides ReadOnly Property ComponentCommonName As String
    Get
public:
virtual property String^ ComponentCommonName {
    String^ get () override;
}
public:
virtual property String^ ComponentCommonName {
    String^ get () override;
}
abstract ComponentCommonName : string with get
override ComponentCommonName : string with get
abstract ComponentCommonName : string with get
override ComponentCommonName : string with get

Property Value

Type: Online String

Implements

IApplicationComponent ComponentCommonName
See Also
S3V4FileSystem Class
S3V4FileSystem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.GeneralCapabilities Property

S3V4FileSystem GeneralCapabilities Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IFileSystemCapabilities GeneralCapabilities { get; }
public override IFileSystemCapabilities GeneralCapabilities { get; }
Public Overrides ReadOnly Property GeneralCapabilities As IFileSystemCapabilities
    Get
Public Overrides ReadOnly Property GeneralCapabilities As IFileSystemCapabilities
    Get
public:
virtual property IFileSystemCapabilities^ GeneralCapabilities {
    IFileSystemCapabilities^ get () override;
}
public:
virtual property IFileSystemCapabilities^ GeneralCapabilities {
    IFileSystemCapabilities^ get () override;
}
abstract GeneralCapabilities : IFileSystemCapabilities with get
override GeneralCapabilities : IFileSystemCapabilities with get
abstract GeneralCapabilities : IFileSystemCapabilities with get
override GeneralCapabilities : IFileSystemCapabilities with get

Property Value

Type: IFileSystemCapabilities

Implements

IFileSystem GeneralCapabilities
See Also
S3V4FileSystem Class
S3V4FileSystem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.InstanceCapabilities Property

S3V4FileSystem InstanceCapabilities Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IFileSystemCapabilities InstanceCapabilities { get; }
public override IFileSystemCapabilities InstanceCapabilities { get; }
Public Overrides ReadOnly Property InstanceCapabilities As IFileSystemCapabilities
    Get
Public Overrides ReadOnly Property InstanceCapabilities As IFileSystemCapabilities
    Get
public:
virtual property IFileSystemCapabilities^ InstanceCapabilities {
    IFileSystemCapabilities^ get () override;
}
public:
virtual property IFileSystemCapabilities^ InstanceCapabilities {
    IFileSystemCapabilities^ get () override;
}
abstract InstanceCapabilities : IFileSystemCapabilities with get
override InstanceCapabilities : IFileSystemCapabilities with get
abstract InstanceCapabilities : IFileSystemCapabilities with get
override InstanceCapabilities : IFileSystemCapabilities with get

Property Value

Type: IFileSystemCapabilities

Implements

IFileSystem InstanceCapabilities
See Also
S3V4FileSystem Class
S3V4FileSystem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.S3V4FSH Class

S3V4FileSystem S3V4FSH Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.S3.V4 S3V4FileSystem S3V4FSH

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class S3V4FSH : IFileSystemHandle
public class S3V4FSH : IFileSystemHandle
Public Class S3V4FSH
    Implements IFileSystemHandle
Public Class S3V4FSH
    Implements IFileSystemHandle
public ref class S3V4FSH : IFileSystemHandle
public ref class S3V4FSH : IFileSystemHandle
type S3V4FSH =
    class
        interface IFileSystemHandle
    end
type S3V4FSH =
    class
        interface IFileSystemHandle
    end
See Also
S3V4FileSystem S3V4FSH Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.S3V4FSH Members

S3V4FileSystem S3V4FSH Members NFX Class Library

The S3V4FileSystem S3V4FSH type exposes the following members.
Constructors
 | Name | Description
Public method | S3V4FileSystem S3V4FSH(String) | Initializes a new instance of the S3V4FileSystem S3V4FSH class
Public method | S3V4FileSystem S3V4FSH(S3V4URI) | Initializes a new instance of the S3V4FileSystem S3V4FSH class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | SeparateLocalPath |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Name |
Public field | Parent |
Public field | Path |
Public field | Uri |
Back to Top
See Also
S3V4FileSystem S3V4FSH Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.S3V4FSH Constructor

S3V4FileSystem S3V4FSH Constructor NFX Class Library

Overload List
 | Name | Description
Public method | S3V4FileSystem S3V4FSH(String) | Initializes a new instance of the S3V4FileSystem S3V4FSH class
Public method | S3V4FileSystem S3V4FSH(S3V4URI) | Initializes a new instance of the S3V4FileSystem S3V4FSH class
Back to Top
See Also
S3V4FileSystem S3V4FSH Class
S3V4FileSystem S3V4FSH Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.S3V4FSH Constructor (String)

S3V4FileSystem S3V4FSH Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the S3V4FileSystem S3V4FSH class

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public S3V4FSH(
    string itemPath
)
public S3V4FSH(
    string itemPath
)
Public Sub New (
    itemPath As String
)
Public Sub New (
    itemPath As String
)
public:
S3V4FSH(
    String^ itemPath
)
public:
S3V4FSH(
    String^ itemPath
)
new :
        itemPath : string -> S3V4FSH
new :
        itemPath : string -> S3V4FSH

Parameters

itemPath
Type: Online System String
See Also
S3V4FileSystem S3V4FSH Class
S3V4FileSystem S3V4FSH Members
S3V4FileSystem S3V4FSH Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.S3V4FSH Constructor (S3V4URI)

S3V4FileSystem S3V4FSH Constructor (S3V4URI) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the S3V4FileSystem S3V4FSH class

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public S3V4FSH(
    S3V4URI uri
)
public S3V4FSH(
    S3V4URI uri
)
Public Sub New (
    uri As S3V4URI
)
Public Sub New (
    uri As S3V4URI
)
public:
S3V4FSH(
    S3V4URI^ uri
)
public:
S3V4FSH(
    S3V4URI^ uri
)
new :
        uri : S3V4URI -> S3V4FSH
new :
        uri : S3V4URI -> S3V4FSH

Parameters

uri
Type: NFX.IO.FileSystem.S3.V4 S3V4URI
See Also
S3V4FileSystem S3V4FSH Class
S3V4FileSystem S3V4FSH Members
S3V4FileSystem S3V4FSH Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.S3V4FSH Fields

S3V4FileSystem S3V4FSH Fields NFX Class Library

The S3V4FileSystem S3V4FSH type exposes the following members.
Fields
 | Name | Description
Public field | Name |
Public field | Parent |
Public field | Path |
Public field | Uri |
Back to Top
See Also
S3V4FileSystem S3V4FSH Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.S3V4FSH.Name Field

S3V4FileSystem S3V4FSH Name Field NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Name
public readonly string Name
Public ReadOnly Name As String
Public ReadOnly Name As String
public:
initonly String^ Name
public:
initonly String^ Name
val Name: string
val Name: string

Field Value

Type: Online String
See Also
S3V4FileSystem S3V4FSH Class
S3V4FileSystem S3V4FSH Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.S3V4FSH.Parent Field

S3V4FileSystem S3V4FSH Parent Field NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Parent
public readonly string Parent
Public ReadOnly Parent As String
Public ReadOnly Parent As String
public:
initonly String^ Parent
public:
initonly String^ Parent
val Parent: string
val Parent: string

Field Value

Type: Online String
See Also
S3V4FileSystem S3V4FSH Class
S3V4FileSystem S3V4FSH Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.S3V4FSH.Path Field

S3V4FileSystem S3V4FSH Path Field NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Path
public readonly string Path
Public ReadOnly Path As String
Public ReadOnly Path As String
public:
initonly String^ Path
public:
initonly String^ Path
val Path: string
val Path: string

Field Value

Type: Online String
See Also
S3V4FileSystem S3V4FSH Class
S3V4FileSystem S3V4FSH Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.S3V4FSH.Uri Field

S3V4FileSystem S3V4FSH Uri Field NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly S3V4URI Uri
public readonly S3V4URI Uri
Public ReadOnly Uri As S3V4URI
Public ReadOnly Uri As S3V4URI
public:
initonly S3V4URI^ Uri
public:
initonly S3V4URI^ Uri
val Uri: S3V4URI
val Uri: S3V4URI

Field Value

Type: S3V4URI
See Also
S3V4FileSystem S3V4FSH Class
S3V4FileSystem S3V4FSH Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.S3V4FSH Methods

S3V4FileSystem S3V4FSH Methods NFX Class Library

The S3V4FileSystem S3V4FSH type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | SeparateLocalPath |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
S3V4FileSystem S3V4FSH Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystem.S3V4FSH.SeparateLocalPath Method

S3V4FileSystem S3V4FSH SeparateLocalPath Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void SeparateLocalPath(
    string localPath,
    out string parentPath,
    out string name
)
public static void SeparateLocalPath(
    string localPath,
    out string parentPath,
    out string name
)
Public Shared Sub SeparateLocalPath (
    localPath As String,
    <OutAttribute> ByRef parentPath As String,
    <OutAttribute> ByRef name As String
)
Public Shared Sub SeparateLocalPath (
    localPath As String,
    <OutAttribute> ByRef parentPath As String,
    <OutAttribute> ByRef name As String
)
public:
static void SeparateLocalPath(
    String^ localPath,
    [OutAttribute] String^% parentPath,
    [OutAttribute] String^% name
)
public:
static void SeparateLocalPath(
    String^ localPath,
    [OutAttribute] String^% parentPath,
    [OutAttribute] String^% name
)
static member SeparateLocalPath :
        localPath : string *
        parentPath : string byref *
        name : string byref -> unit
static member SeparateLocalPath :
        localPath : string *
        parentPath : string byref *
        name : string byref -> unit

Parameters

localPath
Type: Online System String
parentPath
Type: Online System String
name
Type: Online System String
See Also
S3V4FileSystem S3V4FSH Class
S3V4FileSystem S3V4FSH Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities Class

S3V4FileSystemCapabilities Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.S3.V4 S3V4FileSystemCapabilities

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class S3V4FileSystemCapabilities : IFileSystemCapabilities
public class S3V4FileSystemCapabilities : IFileSystemCapabilities
Public Class S3V4FileSystemCapabilities
    Implements IFileSystemCapabilities
Public Class S3V4FileSystemCapabilities
    Implements IFileSystemCapabilities
public ref class S3V4FileSystemCapabilities : IFileSystemCapabilities
public ref class S3V4FileSystemCapabilities : IFileSystemCapabilities
type S3V4FileSystemCapabilities =
    class
        interface IFileSystemCapabilities
    end
type S3V4FileSystemCapabilities =
    class
        interface IFileSystemCapabilities
    end
See Also
S3V4FileSystemCapabilities Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities Members

S3V4FileSystemCapabilities Members NFX Class Library

The S3V4FileSystemCapabilities type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
 | Instance |
Public property | IsReadonly |
Public property | MaxDirectoryNameLength |
Public property | MaxFileNameLength |
Public property | MaxFilePathLength |
Public property | MaxFileSize |
Public property | PathSeparatorCharacters |
Public property | SupportsAsyncronousAPI |
Public property | SupportsCreationTimestamps |
Public property | SupportsCreationUserNames |
Public property | SupportsCustomMetadata |
Public property | SupportsDirectoryRenaming |
Public property | SupportsDirectorySizes |
Public property | SupportsFileModification |
Public property | SupportsFileRenaming |
Public property | SupportsFileSizes |
Public property | SupportsLastAccessTimestamps |
Public property | SupportsLastAccessUserNames |
Public property | SupportsModificationTimestamps |
Public property | SupportsModificationUserNames |
Public property | SupportsReadonlyDirectories |
Public property | SupportsReadonlyFiles |
Public property | SupportsSecurity |
Public property | SupportsStreamSeek |
Public property | SupportsTransactions |
Public property | SupportsVersioning |
Back to Top
See Also
S3V4FileSystemCapabilities Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities Methods

S3V4FileSystemCapabilities Methods NFX Class Library

The S3V4FileSystemCapabilities type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
S3V4FileSystemCapabilities Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities Properties

S3V4FileSystemCapabilities Properties NFX Class Library

The S3V4FileSystemCapabilities type exposes the following members.
Properties
 | Name | Description
 | Instance |
Public property | IsReadonly |
Public property | MaxDirectoryNameLength |
Public property | MaxFileNameLength |
Public property | MaxFilePathLength |
Public property | MaxFileSize |
Public property | PathSeparatorCharacters |
Public property | SupportsAsyncronousAPI |
Public property | SupportsCreationTimestamps |
Public property | SupportsCreationUserNames |
Public property | SupportsCustomMetadata |
Public property | SupportsDirectoryRenaming |
Public property | SupportsDirectorySizes |
Public property | SupportsFileModification |
Public property | SupportsFileRenaming |
Public property | SupportsFileSizes |
Public property | SupportsLastAccessTimestamps |
Public property | SupportsLastAccessUserNames |
Public property | SupportsModificationTimestamps |
Public property | SupportsModificationUserNames |
Public property | SupportsReadonlyDirectories |
Public property | SupportsReadonlyFiles |
Public property | SupportsSecurity |
Public property | SupportsStreamSeek |
Public property | SupportsTransactions |
Public property | SupportsVersioning |
Back to Top
See Also
S3V4FileSystemCapabilities Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities.Instance Property

S3V4FileSystemCapabilities Instance Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static S3V4FileSystemCapabilities Instance { get; }
public static S3V4FileSystemCapabilities Instance { get; }
Public Shared ReadOnly Property Instance As S3V4FileSystemCapabilities
    Get
Public Shared ReadOnly Property Instance As S3V4FileSystemCapabilities
    Get
public:
static property S3V4FileSystemCapabilities^ Instance {
    S3V4FileSystemCapabilities^ get ();
}
public:
static property S3V4FileSystemCapabilities^ Instance {
    S3V4FileSystemCapabilities^ get ();
}
static member Instance : S3V4FileSystemCapabilities with get
static member Instance : S3V4FileSystemCapabilities with get

Property Value

Type: S3V4FileSystemCapabilities
See Also
S3V4FileSystemCapabilities Class
S3V4FileSystemCapabilities Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities.IsReadonly Property

S3V4FileSystemCapabilities IsReadonly Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsReadonly { get; }
public bool IsReadonly { get; }
Public ReadOnly Property IsReadonly As Boolean
    Get
Public ReadOnly Property IsReadonly As Boolean
    Get
public:
virtual property bool IsReadonly {
    bool get () sealed;
}
public:
virtual property bool IsReadonly {
    bool get () sealed;
}
abstract IsReadonly : bool with get
override IsReadonly : bool with get
abstract IsReadonly : bool with get
override IsReadonly : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities IsReadonly
See Also
S3V4FileSystemCapabilities Class
S3V4FileSystemCapabilities Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities.MaxDirectoryNameLength Property

S3V4FileSystemCapabilities MaxDirectoryNameLength Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MaxDirectoryNameLength { get; }
public int MaxDirectoryNameLength { get; }
Public ReadOnly Property MaxDirectoryNameLength As Integer
    Get
Public ReadOnly Property MaxDirectoryNameLength As Integer
    Get
public:
virtual property int MaxDirectoryNameLength {
    int get () sealed;
}
public:
virtual property int MaxDirectoryNameLength {
    int get () sealed;
}
abstract MaxDirectoryNameLength : int with get
override MaxDirectoryNameLength : int with get
abstract MaxDirectoryNameLength : int with get
override MaxDirectoryNameLength : int with get

Property Value

Type: Online Int32

Implements

IFileSystemCapabilities MaxDirectoryNameLength
See Also
S3V4FileSystemCapabilities Class
S3V4FileSystemCapabilities Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities.MaxFileNameLength Property

S3V4FileSystemCapabilities MaxFileNameLength Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MaxFileNameLength { get; }
public int MaxFileNameLength { get; }
Public ReadOnly Property MaxFileNameLength As Integer
    Get
Public ReadOnly Property MaxFileNameLength As Integer
    Get
public:
virtual property int MaxFileNameLength {
    int get () sealed;
}
public:
virtual property int MaxFileNameLength {
    int get () sealed;
}
abstract MaxFileNameLength : int with get
override MaxFileNameLength : int with get
abstract MaxFileNameLength : int with get
override MaxFileNameLength : int with get

Property Value

Type: Online Int32

Implements

IFileSystemCapabilities MaxFileNameLength
See Also
S3V4FileSystemCapabilities Class
S3V4FileSystemCapabilities Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities.MaxFilePathLength Property

S3V4FileSystemCapabilities MaxFilePathLength Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MaxFilePathLength { get; }
public int MaxFilePathLength { get; }
Public ReadOnly Property MaxFilePathLength As Integer
    Get
Public ReadOnly Property MaxFilePathLength As Integer
    Get
public:
virtual property int MaxFilePathLength {
    int get () sealed;
}
public:
virtual property int MaxFilePathLength {
    int get () sealed;
}
abstract MaxFilePathLength : int with get
override MaxFilePathLength : int with get
abstract MaxFilePathLength : int with get
override MaxFilePathLength : int with get

Property Value

Type: Online Int32

Implements

IFileSystemCapabilities MaxFilePathLength
See Also
S3V4FileSystemCapabilities Class
S3V4FileSystemCapabilities Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities.MaxFileSize Property

S3V4FileSystemCapabilities MaxFileSize Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong MaxFileSize { get; }
public ulong MaxFileSize { get; }
Public ReadOnly Property MaxFileSize As ULong
    Get
Public ReadOnly Property MaxFileSize As ULong
    Get
public:
virtual property unsigned long long MaxFileSize {
    unsigned long long get () sealed;
}
public:
virtual property unsigned long long MaxFileSize {
    unsigned long long get () sealed;
}
abstract MaxFileSize : uint64 with get
override MaxFileSize : uint64 with get
abstract MaxFileSize : uint64 with get
override MaxFileSize : uint64 with get

Property Value

Type: Online UInt64

Implements

IFileSystemCapabilities MaxFileSize
See Also
S3V4FileSystemCapabilities Class
S3V4FileSystemCapabilities Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities.PathSeparatorCharacters Property

S3V4FileSystemCapabilities PathSeparatorCharacters Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char[] PathSeparatorCharacters { get; }
public char[] PathSeparatorCharacters { get; }
Public ReadOnly Property PathSeparatorCharacters As Char()
    Get
Public ReadOnly Property PathSeparatorCharacters As Char()
    Get
public:
virtual property array<wchar_t>^ PathSeparatorCharacters {
    array<wchar_t>^ get () sealed;
}
public:
virtual property array<wchar_t>^ PathSeparatorCharacters {
    array<wchar_t>^ get () sealed;
}
abstract PathSeparatorCharacters : char[] with get
override PathSeparatorCharacters : char[] with get
abstract PathSeparatorCharacters : char[] with get
override PathSeparatorCharacters : char[] with get

Property Value

Type: Online Char

Implements

IFileSystemCapabilities PathSeparatorCharacters
See Also
S3V4FileSystemCapabilities Class
S3V4FileSystemCapabilities Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities.SupportsAsyncronousAPI Property

S3V4FileSystemCapabilities SupportsAsyncronousAPI Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsAsyncronousAPI { get; }
public bool SupportsAsyncronousAPI { get; }
Public ReadOnly Property SupportsAsyncronousAPI As Boolean
    Get
Public ReadOnly Property SupportsAsyncronousAPI As Boolean
    Get
public:
virtual property bool SupportsAsyncronousAPI {
    bool get () sealed;
}
public:
virtual property bool SupportsAsyncronousAPI {
    bool get () sealed;
}
abstract SupportsAsyncronousAPI : bool with get
override SupportsAsyncronousAPI : bool with get
abstract SupportsAsyncronousAPI : bool with get
override SupportsAsyncronousAPI : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsAsyncronousAPI
See Also
S3V4FileSystemCapabilities Class
S3V4FileSystemCapabilities Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities.SupportsCreationTimestamps Property

S3V4FileSystemCapabilities SupportsCreationTimestamps Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsCreationTimestamps { get; }
public bool SupportsCreationTimestamps { get; }
Public ReadOnly Property SupportsCreationTimestamps As Boolean
    Get
Public ReadOnly Property SupportsCreationTimestamps As Boolean
    Get
public:
virtual property bool SupportsCreationTimestamps {
    bool get () sealed;
}
public:
virtual property bool SupportsCreationTimestamps {
    bool get () sealed;
}
abstract SupportsCreationTimestamps : bool with get
override SupportsCreationTimestamps : bool with get
abstract SupportsCreationTimestamps : bool with get
override SupportsCreationTimestamps : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsCreationTimestamps
See Also
S3V4FileSystemCapabilities Class
S3V4FileSystemCapabilities Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities.SupportsCreationUserNames Property

S3V4FileSystemCapabilities SupportsCreationUserNames Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsCreationUserNames { get; }
public bool SupportsCreationUserNames { get; }
Public ReadOnly Property SupportsCreationUserNames As Boolean
    Get
Public ReadOnly Property SupportsCreationUserNames As Boolean
    Get
public:
virtual property bool SupportsCreationUserNames {
    bool get () sealed;
}
public:
virtual property bool SupportsCreationUserNames {
    bool get () sealed;
}
abstract SupportsCreationUserNames : bool with get
override SupportsCreationUserNames : bool with get
abstract SupportsCreationUserNames : bool with get
override SupportsCreationUserNames : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsCreationUserNames
See Also
S3V4FileSystemCapabilities Class
S3V4FileSystemCapabilities Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities.SupportsCustomMetadata Property

S3V4FileSystemCapabilities SupportsCustomMetadata Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsCustomMetadata { get; }
public bool SupportsCustomMetadata { get; }
Public ReadOnly Property SupportsCustomMetadata As Boolean
    Get
Public ReadOnly Property SupportsCustomMetadata As Boolean
    Get
public:
virtual property bool SupportsCustomMetadata {
    bool get () sealed;
}
public:
virtual property bool SupportsCustomMetadata {
    bool get () sealed;
}
abstract SupportsCustomMetadata : bool with get
override SupportsCustomMetadata : bool with get
abstract SupportsCustomMetadata : bool with get
override SupportsCustomMetadata : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsCustomMetadata
See Also
S3V4FileSystemCapabilities Class
S3V4FileSystemCapabilities Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities.SupportsDirectoryRenaming Property

S3V4FileSystemCapabilities SupportsDirectoryRenaming Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsDirectoryRenaming { get; }
public bool SupportsDirectoryRenaming { get; }
Public ReadOnly Property SupportsDirectoryRenaming As Boolean
    Get
Public ReadOnly Property SupportsDirectoryRenaming As Boolean
    Get
public:
virtual property bool SupportsDirectoryRenaming {
    bool get () sealed;
}
public:
virtual property bool SupportsDirectoryRenaming {
    bool get () sealed;
}
abstract SupportsDirectoryRenaming : bool with get
override SupportsDirectoryRenaming : bool with get
abstract SupportsDirectoryRenaming : bool with get
override SupportsDirectoryRenaming : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsDirectoryRenaming
See Also
S3V4FileSystemCapabilities Class
S3V4FileSystemCapabilities Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities.SupportsDirectorySizes Property

S3V4FileSystemCapabilities SupportsDirectorySizes Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsDirectorySizes { get; }
public bool SupportsDirectorySizes { get; }
Public ReadOnly Property SupportsDirectorySizes As Boolean
    Get
Public ReadOnly Property SupportsDirectorySizes As Boolean
    Get
public:
virtual property bool SupportsDirectorySizes {
    bool get () sealed;
}
public:
virtual property bool SupportsDirectorySizes {
    bool get () sealed;
}
abstract SupportsDirectorySizes : bool with get
override SupportsDirectorySizes : bool with get
abstract SupportsDirectorySizes : bool with get
override SupportsDirectorySizes : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsDirectorySizes
See Also
S3V4FileSystemCapabilities Class
S3V4FileSystemCapabilities Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities.SupportsFileModification Property

S3V4FileSystemCapabilities SupportsFileModification Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsFileModification { get; }
public bool SupportsFileModification { get; }
Public ReadOnly Property SupportsFileModification As Boolean
    Get
Public ReadOnly Property SupportsFileModification As Boolean
    Get
public:
virtual property bool SupportsFileModification {
    bool get () sealed;
}
public:
virtual property bool SupportsFileModification {
    bool get () sealed;
}
abstract SupportsFileModification : bool with get
override SupportsFileModification : bool with get
abstract SupportsFileModification : bool with get
override SupportsFileModification : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsFileModification
See Also
S3V4FileSystemCapabilities Class
S3V4FileSystemCapabilities Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities.SupportsFileRenaming Property

S3V4FileSystemCapabilities SupportsFileRenaming Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsFileRenaming { get; }
public bool SupportsFileRenaming { get; }
Public ReadOnly Property SupportsFileRenaming As Boolean
    Get
Public ReadOnly Property SupportsFileRenaming As Boolean
    Get
public:
virtual property bool SupportsFileRenaming {
    bool get () sealed;
}
public:
virtual property bool SupportsFileRenaming {
    bool get () sealed;
}
abstract SupportsFileRenaming : bool with get
override SupportsFileRenaming : bool with get
abstract SupportsFileRenaming : bool with get
override SupportsFileRenaming : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsFileRenaming
See Also
S3V4FileSystemCapabilities Class
S3V4FileSystemCapabilities Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities.SupportsFileSizes Property

S3V4FileSystemCapabilities SupportsFileSizes Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsFileSizes { get; }
public bool SupportsFileSizes { get; }
Public ReadOnly Property SupportsFileSizes As Boolean
    Get
Public ReadOnly Property SupportsFileSizes As Boolean
    Get
public:
virtual property bool SupportsFileSizes {
    bool get () sealed;
}
public:
virtual property bool SupportsFileSizes {
    bool get () sealed;
}
abstract SupportsFileSizes : bool with get
override SupportsFileSizes : bool with get
abstract SupportsFileSizes : bool with get
override SupportsFileSizes : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsFileSizes
See Also
S3V4FileSystemCapabilities Class
S3V4FileSystemCapabilities Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities.SupportsLastAccessTimestamps Property

S3V4FileSystemCapabilities SupportsLastAccessTimestamps Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsLastAccessTimestamps { get; }
public bool SupportsLastAccessTimestamps { get; }
Public ReadOnly Property SupportsLastAccessTimestamps As Boolean
    Get
Public ReadOnly Property SupportsLastAccessTimestamps As Boolean
    Get
public:
virtual property bool SupportsLastAccessTimestamps {
    bool get () sealed;
}
public:
virtual property bool SupportsLastAccessTimestamps {
    bool get () sealed;
}
abstract SupportsLastAccessTimestamps : bool with get
override SupportsLastAccessTimestamps : bool with get
abstract SupportsLastAccessTimestamps : bool with get
override SupportsLastAccessTimestamps : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsLastAccessTimestamps
See Also
S3V4FileSystemCapabilities Class
S3V4FileSystemCapabilities Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities.SupportsLastAccessUserNames Property

S3V4FileSystemCapabilities SupportsLastAccessUserNames Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsLastAccessUserNames { get; }
public bool SupportsLastAccessUserNames { get; }
Public ReadOnly Property SupportsLastAccessUserNames As Boolean
    Get
Public ReadOnly Property SupportsLastAccessUserNames As Boolean
    Get
public:
virtual property bool SupportsLastAccessUserNames {
    bool get () sealed;
}
public:
virtual property bool SupportsLastAccessUserNames {
    bool get () sealed;
}
abstract SupportsLastAccessUserNames : bool with get
override SupportsLastAccessUserNames : bool with get
abstract SupportsLastAccessUserNames : bool with get
override SupportsLastAccessUserNames : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsLastAccessUserNames
See Also
S3V4FileSystemCapabilities Class
S3V4FileSystemCapabilities Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities.SupportsModificationTimestamps Property

S3V4FileSystemCapabilities SupportsModificationTimestamps Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsModificationTimestamps { get; }
public bool SupportsModificationTimestamps { get; }
Public ReadOnly Property SupportsModificationTimestamps As Boolean
    Get
Public ReadOnly Property SupportsModificationTimestamps As Boolean
    Get
public:
virtual property bool SupportsModificationTimestamps {
    bool get () sealed;
}
public:
virtual property bool SupportsModificationTimestamps {
    bool get () sealed;
}
abstract SupportsModificationTimestamps : bool with get
override SupportsModificationTimestamps : bool with get
abstract SupportsModificationTimestamps : bool with get
override SupportsModificationTimestamps : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsModificationTimestamps
See Also
S3V4FileSystemCapabilities Class
S3V4FileSystemCapabilities Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities.SupportsModificationUserNames Property

S3V4FileSystemCapabilities SupportsModificationUserNames Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsModificationUserNames { get; }
public bool SupportsModificationUserNames { get; }
Public ReadOnly Property SupportsModificationUserNames As Boolean
    Get
Public ReadOnly Property SupportsModificationUserNames As Boolean
    Get
public:
virtual property bool SupportsModificationUserNames {
    bool get () sealed;
}
public:
virtual property bool SupportsModificationUserNames {
    bool get () sealed;
}
abstract SupportsModificationUserNames : bool with get
override SupportsModificationUserNames : bool with get
abstract SupportsModificationUserNames : bool with get
override SupportsModificationUserNames : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsModificationUserNames
See Also
S3V4FileSystemCapabilities Class
S3V4FileSystemCapabilities Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities.SupportsReadonlyDirectories Property

S3V4FileSystemCapabilities SupportsReadonlyDirectories Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsReadonlyDirectories { get; }
public bool SupportsReadonlyDirectories { get; }
Public ReadOnly Property SupportsReadonlyDirectories As Boolean
    Get
Public ReadOnly Property SupportsReadonlyDirectories As Boolean
    Get
public:
virtual property bool SupportsReadonlyDirectories {
    bool get () sealed;
}
public:
virtual property bool SupportsReadonlyDirectories {
    bool get () sealed;
}
abstract SupportsReadonlyDirectories : bool with get
override SupportsReadonlyDirectories : bool with get
abstract SupportsReadonlyDirectories : bool with get
override SupportsReadonlyDirectories : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsReadonlyDirectories
See Also
S3V4FileSystemCapabilities Class
S3V4FileSystemCapabilities Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities.SupportsReadonlyFiles Property

S3V4FileSystemCapabilities SupportsReadonlyFiles Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsReadonlyFiles { get; }
public bool SupportsReadonlyFiles { get; }
Public ReadOnly Property SupportsReadonlyFiles As Boolean
    Get
Public ReadOnly Property SupportsReadonlyFiles As Boolean
    Get
public:
virtual property bool SupportsReadonlyFiles {
    bool get () sealed;
}
public:
virtual property bool SupportsReadonlyFiles {
    bool get () sealed;
}
abstract SupportsReadonlyFiles : bool with get
override SupportsReadonlyFiles : bool with get
abstract SupportsReadonlyFiles : bool with get
override SupportsReadonlyFiles : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsReadonlyFiles
See Also
S3V4FileSystemCapabilities Class
S3V4FileSystemCapabilities Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities.SupportsSecurity Property

S3V4FileSystemCapabilities SupportsSecurity Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsSecurity { get; }
public bool SupportsSecurity { get; }
Public ReadOnly Property SupportsSecurity As Boolean
    Get
Public ReadOnly Property SupportsSecurity As Boolean
    Get
public:
virtual property bool SupportsSecurity {
    bool get () sealed;
}
public:
virtual property bool SupportsSecurity {
    bool get () sealed;
}
abstract SupportsSecurity : bool with get
override SupportsSecurity : bool with get
abstract SupportsSecurity : bool with get
override SupportsSecurity : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsSecurity
See Also
S3V4FileSystemCapabilities Class
S3V4FileSystemCapabilities Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities.SupportsStreamSeek Property

S3V4FileSystemCapabilities SupportsStreamSeek Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsStreamSeek { get; }
public bool SupportsStreamSeek { get; }
Public ReadOnly Property SupportsStreamSeek As Boolean
    Get
Public ReadOnly Property SupportsStreamSeek As Boolean
    Get
public:
virtual property bool SupportsStreamSeek {
    bool get () sealed;
}
public:
virtual property bool SupportsStreamSeek {
    bool get () sealed;
}
abstract SupportsStreamSeek : bool with get
override SupportsStreamSeek : bool with get
abstract SupportsStreamSeek : bool with get
override SupportsStreamSeek : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsStreamSeek
See Also
S3V4FileSystemCapabilities Class
S3V4FileSystemCapabilities Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities.SupportsTransactions Property

S3V4FileSystemCapabilities SupportsTransactions Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsTransactions { get; }
public bool SupportsTransactions { get; }
Public ReadOnly Property SupportsTransactions As Boolean
    Get
Public ReadOnly Property SupportsTransactions As Boolean
    Get
public:
virtual property bool SupportsTransactions {
    bool get () sealed;
}
public:
virtual property bool SupportsTransactions {
    bool get () sealed;
}
abstract SupportsTransactions : bool with get
override SupportsTransactions : bool with get
abstract SupportsTransactions : bool with get
override SupportsTransactions : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsTransactions
See Also
S3V4FileSystemCapabilities Class
S3V4FileSystemCapabilities Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemCapabilities.SupportsVersioning Property

S3V4FileSystemCapabilities SupportsVersioning Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsVersioning { get; }
public bool SupportsVersioning { get; }
Public ReadOnly Property SupportsVersioning As Boolean
    Get
Public ReadOnly Property SupportsVersioning As Boolean
    Get
public:
virtual property bool SupportsVersioning {
    bool get () sealed;
}
public:
virtual property bool SupportsVersioning {
    bool get () sealed;
}
abstract SupportsVersioning : bool with get
override SupportsVersioning : bool with get
abstract SupportsVersioning : bool with get
override SupportsVersioning : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsVersioning
See Also
S3V4FileSystemCapabilities Class
S3V4FileSystemCapabilities Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSession Class

S3V4FileSystemSession Class NFX Class Library

Provides S3 (v4) file system connection session
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.IO.FileSystem FileSystemSession
NFX.IO.FileSystem.S3.V4 S3V4FileSystemSession

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class S3V4FileSystemSession : FileSystemSession
public class S3V4FileSystemSession : FileSystemSession
Public Class S3V4FileSystemSession
    Inherits FileSystemSession
Public Class S3V4FileSystemSession
    Inherits FileSystemSession
public ref class S3V4FileSystemSession : public FileSystemSession
public ref class S3V4FileSystemSession : public FileSystemSession
type S3V4FileSystemSession =
    class
        inherit FileSystemSession
    end
type S3V4FileSystemSession =
    class
        inherit FileSystemSession
    end
See Also
S3V4FileSystemSession Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSession Members

S3V4FileSystemSession Members NFX Class Library

The S3V4FileSystemSession type exposes the following members.
Constructors
 | Name | Description
Protected method | S3V4FileSystemSession | Initializes a new instance of the S3V4FileSystemSession class
Back to Top
Methods
 | Name | Description
Public method | BeginTransaction | Starts a transaction returning its' transaction handle object, otherwise does nothing (Inherited from FileSystemSession.)
Public method | BeginTransactionAsync | Async version of BeginTransaction (Inherited from FileSystemSession.)
Public method | CommitTransaction | Commits active transaction, does nothing otherwise (Inherited from FileSystemSession.)
Public method | CommitTransactionAsync | Async version of CommitTransaction (Inherited from FileSystemSession.)
Protected method | Destructor | (Inherited from FileSystemSession.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetItemAsync | Async version of [P:Item(string)] (Inherited from FileSystemSession.)
Public method | GetLatestVersionAsync | Async version of [P:LatestVersion] (Inherited from FileSystemSession.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetVersions | Returns specified number of versions going back from the specific version. This call is thread-safe (Inherited from FileSystemSession.)
Public method | GetVersionsAsync | Async version of GetVersions(IFileSystemVersion, Int32) (Inherited from FileSystemSession.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RollbackTransaction | Cancels active transaction changes, does nothing otherwise (Inherited from FileSystemSession.)
Public method | RollbackTransactionAsync | Async version of RollbackTransaction (Inherited from FileSystemSession.)
Public method | SetFileSystemVersionAsync | Async version of [P:Version] (Inherited from FileSystemSession.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | ValidateConnectParams | (Overrides FileSystemSession ValidateConnectParams(FileSystemSessionConnectParams).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_FileSystem | (Inherited from FileSystemSession.)
Protected field | m_Handle | (Inherited from FileSystemSession.)
Protected field | m_Items | (Inherited from FileSystemSession.)
Protected field | m_Name | (Inherited from FileSystemSession.)
Protected field | m_TransactionHandle | (Inherited from FileSystemSession.)
Protected field | m_User | (Inherited from FileSystemSession.)
Back to Top
Properties
 | Name | Description
Public property | AccessKey | Extracts AccessKey from User
Public property | Bucket | Amazon S3 bucket (i.e. bucket01)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | FileSystem | Returns file system instance that this session operates under (Inherited from FileSystemSession.)
Public property | Handle | Returns file system handle for this session (Inherited from FileSystemSession.)
Public property | Item | Navigates to the specified path (Inherited from FileSystemSession.)
Public property | Items | Returns file system items initialized through this session (Inherited from FileSystemSession.)
Public property | LatestVersion | Returns latest version for file systems that support versioning, null otherwise (Inherited from FileSystemSession.)
Public property | Name | Returns session name (Inherited from FileSystemSession.)
Public property | Region | Amazon S3 region (i.e. us-west-2)
Public property | SecretKey | Extracts SecretKey from User
Public property | SecurityManager | Returns security manager that services this file system session. This may be useful in cases when file system implements its own permission structure and user directory (Inherited from FileSystemSession.)
Public property | TimeoutMs | Request timeout in milliseconds
Public property | TransactionHandle | Returns transaction object if transaction has been started or null (Inherited from FileSystemSession.)
Public property | UniqueSequenceProvider | Returns unique sequence provider for the system or null if it is not supported (Inherited from FileSystemSession.)
Public property | User | Returns user that this file system session is for (Inherited from FileSystemSession.)
Public property | Version | Gets/sets version of the file system that this session works against (a changeset that session "sees") (Inherited from FileSystemSession.)
Back to Top
See Also
S3V4FileSystemSession Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSession Constructor

S3V4FileSystemSession Constructor NFX Class Library

Initializes a new instance of the S3V4FileSystemSession class

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal S3V4FileSystemSession(
    S3V4FileSystem fs,
    IFileSystemHandle handle,
    S3V4FileSystemSessionConnectParams cParams
)
protected internal S3V4FileSystemSession(
    S3V4FileSystem fs,
    IFileSystemHandle handle,
    S3V4FileSystemSessionConnectParams cParams
)
Protected Friend Sub New (
    fs As S3V4FileSystem,
    handle As IFileSystemHandle,
    cParams As S3V4FileSystemSessionConnectParams
)
Protected Friend Sub New (
    fs As S3V4FileSystem,
    handle As IFileSystemHandle,
    cParams As S3V4FileSystemSessionConnectParams
)
protected public:
S3V4FileSystemSession(
    S3V4FileSystem^ fs,
    IFileSystemHandle^ handle,
    S3V4FileSystemSessionConnectParams^ cParams
)
protected public:
S3V4FileSystemSession(
    S3V4FileSystem^ fs,
    IFileSystemHandle^ handle,
    S3V4FileSystemSessionConnectParams^ cParams
)
new :
        fs : S3V4FileSystem *
        handle : IFileSystemHandle *
        cParams : S3V4FileSystemSessionConnectParams -> S3V4FileSystemSession
new :
        fs : S3V4FileSystem *
        handle : IFileSystemHandle *
        cParams : S3V4FileSystemSessionConnectParams -> S3V4FileSystemSession

Parameters

fs
Type: NFX.IO.FileSystem.S3.V4 S3V4FileSystem
handle
Type: NFX.IO.FileSystem IFileSystemHandle
cParams
Type: NFX.IO.FileSystem.S3.V4 S3V4FileSystemSessionConnectParams
See Also
S3V4FileSystemSession Class
S3V4FileSystemSession Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSession Fields

S3V4FileSystemSession Fields NFX Class Library

The S3V4FileSystemSession type exposes the following members.
Fields
 | Name | Description
Protected field | m_FileSystem | (Inherited from FileSystemSession.)
Protected field | m_Handle | (Inherited from FileSystemSession.)
Protected field | m_Items | (Inherited from FileSystemSession.)
Protected field | m_Name | (Inherited from FileSystemSession.)
Protected field | m_TransactionHandle | (Inherited from FileSystemSession.)
Protected field | m_User | (Inherited from FileSystemSession.)
Back to Top
See Also
S3V4FileSystemSession Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSession Methods

S3V4FileSystemSession Methods NFX Class Library

The S3V4FileSystemSession type exposes the following members.
Methods
 | Name | Description
Public method | BeginTransaction | Starts a transaction returning its' transaction handle object, otherwise does nothing (Inherited from FileSystemSession.)
Public method | BeginTransactionAsync | Async version of BeginTransaction (Inherited from FileSystemSession.)
Public method | CommitTransaction | Commits active transaction, does nothing otherwise (Inherited from FileSystemSession.)
Public method | CommitTransactionAsync | Async version of CommitTransaction (Inherited from FileSystemSession.)
Protected method | Destructor | (Inherited from FileSystemSession.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetItemAsync | Async version of [P:Item(string)] (Inherited from FileSystemSession.)
Public method | GetLatestVersionAsync | Async version of [P:LatestVersion] (Inherited from FileSystemSession.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetVersions | Returns specified number of versions going back from the specific version. This call is thread-safe (Inherited from FileSystemSession.)
Public method | GetVersionsAsync | Async version of GetVersions(IFileSystemVersion, Int32) (Inherited from FileSystemSession.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RollbackTransaction | Cancels active transaction changes, does nothing otherwise (Inherited from FileSystemSession.)
Public method | RollbackTransactionAsync | Async version of RollbackTransaction (Inherited from FileSystemSession.)
Public method | SetFileSystemVersionAsync | Async version of [P:Version] (Inherited from FileSystemSession.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | ValidateConnectParams | (Overrides FileSystemSession ValidateConnectParams(FileSystemSessionConnectParams).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
S3V4FileSystemSession Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSession.ValidateConnectParams Method

S3V4FileSystemSession ValidateConnectParams Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void ValidateConnectParams(
    FileSystemSessionConnectParams cParams
)
protected override void ValidateConnectParams(
    FileSystemSessionConnectParams cParams
)
Protected Overrides Sub ValidateConnectParams (
    cParams As FileSystemSessionConnectParams
)
Protected Overrides Sub ValidateConnectParams (
    cParams As FileSystemSessionConnectParams
)
protected:
virtual void ValidateConnectParams(
    FileSystemSessionConnectParams^ cParams
) override
protected:
virtual void ValidateConnectParams(
    FileSystemSessionConnectParams^ cParams
) override
abstract ValidateConnectParams :
        cParams : FileSystemSessionConnectParams -> unit
override ValidateConnectParams :
        cParams : FileSystemSessionConnectParams -> unit
abstract ValidateConnectParams :
        cParams : FileSystemSessionConnectParams -> unit
override ValidateConnectParams :
        cParams : FileSystemSessionConnectParams -> unit

Parameters

cParams
Type: NFX.IO.FileSystem FileSystemSessionConnectParams
See Also
S3V4FileSystemSession Class
S3V4FileSystemSession Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSession Properties

S3V4FileSystemSession Properties NFX Class Library

The S3V4FileSystemSession type exposes the following members.
Properties
 | Name | Description
Public property | AccessKey | Extracts AccessKey from User
Public property | Bucket | Amazon S3 bucket (i.e. bucket01)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | FileSystem | Returns file system instance that this session operates under (Inherited from FileSystemSession.)
Public property | Handle | Returns file system handle for this session (Inherited from FileSystemSession.)
Public property | Item | Navigates to the specified path (Inherited from FileSystemSession.)
Public property | Items | Returns file system items initialized through this session (Inherited from FileSystemSession.)
Public property | LatestVersion | Returns latest version for file systems that support versioning, null otherwise (Inherited from FileSystemSession.)
Public property | Name | Returns session name (Inherited from FileSystemSession.)
Public property | Region | Amazon S3 region (i.e. us-west-2)
Public property | SecretKey | Extracts SecretKey from User
Public property | SecurityManager | Returns security manager that services this file system session. This may be useful in cases when file system implements its own permission structure and user directory (Inherited from FileSystemSession.)
Public property | TimeoutMs | Request timeout in milliseconds
Public property | TransactionHandle | Returns transaction object if transaction has been started or null (Inherited from FileSystemSession.)
Public property | UniqueSequenceProvider | Returns unique sequence provider for the system or null if it is not supported (Inherited from FileSystemSession.)
Public property | User | Returns user that this file system session is for (Inherited from FileSystemSession.)
Public property | Version | Gets/sets version of the file system that this session works against (a changeset that session "sees") (Inherited from FileSystemSession.)
Back to Top
See Also
S3V4FileSystemSession Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSession.AccessKey Property

S3V4FileSystemSession AccessKey Property NFX Class Library

Extracts AccessKey from User

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AccessKey { get; }
public string AccessKey { get; }
Public ReadOnly Property AccessKey As String
    Get
Public ReadOnly Property AccessKey As String
    Get
public:
property String^ AccessKey {
    String^ get ();
}
public:
property String^ AccessKey {
    String^ get ();
}
member AccessKey : string with get
member AccessKey : string with get

Property Value

Type: Online String
See Also
S3V4FileSystemSession Class
S3V4FileSystemSession Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSession.Bucket Property

S3V4FileSystemSession Bucket Property NFX Class Library

Amazon S3 bucket (i.e. bucket01)

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Bucket { get; }
public string Bucket { get; }
Public ReadOnly Property Bucket As String
    Get
Public ReadOnly Property Bucket As String
    Get
public:
property String^ Bucket {
    String^ get ();
}
public:
property String^ Bucket {
    String^ get ();
}
member Bucket : string with get
member Bucket : string with get

Property Value

Type: Online String
See Also
S3V4FileSystemSession Class
S3V4FileSystemSession Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSession.Region Property

S3V4FileSystemSession Region Property NFX Class Library

Amazon S3 region (i.e. us-west-2)

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Region { get; }
public string Region { get; }
Public ReadOnly Property Region As String
    Get
Public ReadOnly Property Region As String
    Get
public:
property String^ Region {
    String^ get ();
}
public:
property String^ Region {
    String^ get ();
}
member Region : string with get
member Region : string with get

Property Value

Type: Online String
See Also
S3V4FileSystemSession Class
S3V4FileSystemSession Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSession.SecretKey Property

S3V4FileSystemSession SecretKey Property NFX Class Library

Extracts SecretKey from User

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SecretKey { get; }
public string SecretKey { get; }
Public ReadOnly Property SecretKey As String
    Get
Public ReadOnly Property SecretKey As String
    Get
public:
property String^ SecretKey {
    String^ get ();
}
public:
property String^ SecretKey {
    String^ get ();
}
member SecretKey : string with get
member SecretKey : string with get

Property Value

Type: Online String
See Also
S3V4FileSystemSession Class
S3V4FileSystemSession Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSession.TimeoutMs Property

S3V4FileSystemSession TimeoutMs Property NFX Class Library

Request timeout in milliseconds

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int TimeoutMs { get; }
public int TimeoutMs { get; }
Public ReadOnly Property TimeoutMs As Integer
    Get
Public ReadOnly Property TimeoutMs As Integer
    Get
public:
property int TimeoutMs {
    int get ();
}
public:
property int TimeoutMs {
    int get ();
}
member TimeoutMs : int with get
member TimeoutMs : int with get

Property Value

Type: Online Int32
See Also
S3V4FileSystemSession Class
S3V4FileSystemSession Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSessionConnectParams Class

S3V4FileSystemSessionConnectParams Class NFX Class Library

Provides connection parameters specific for Amazon S3 V4
Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem FileSystemSessionConnectParams
NFX.IO.FileSystem.S3.V4 S3V4FileSystemSessionConnectParams

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class S3V4FileSystemSessionConnectParams : FileSystemSessionConnectParams
public class S3V4FileSystemSessionConnectParams : FileSystemSessionConnectParams
Public Class S3V4FileSystemSessionConnectParams
    Inherits FileSystemSessionConnectParams
Public Class S3V4FileSystemSessionConnectParams
    Inherits FileSystemSessionConnectParams
public ref class S3V4FileSystemSessionConnectParams : public FileSystemSessionConnectParams
public ref class S3V4FileSystemSessionConnectParams : public FileSystemSessionConnectParams
type S3V4FileSystemSessionConnectParams =
    class
        inherit FileSystemSessionConnectParams
    end
type S3V4FileSystemSessionConnectParams =
    class
        inherit FileSystemSessionConnectParams
    end
See Also
S3V4FileSystemSessionConnectParams Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSessionConnectParams Members

S3V4FileSystemSessionConnectParams Members NFX Class Library

The S3V4FileSystemSessionConnectParams type exposes the following members.
Constructors
 | Name | Description
Public method | S3V4FileSystemSessionConnectParams | Initializes a new instance of the S3V4FileSystemSessionConnectParams class
Public method | S3V4FileSystemSessionConnectParams(IConfigSectionNode) | Initializes a new instance of the S3V4FileSystemSessionConnectParams class
Public method | S3V4FileSystemSessionConnectParams(String, String) | Initializes a new instance of the S3V4FileSystemSessionConnectParams class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Overrides FileSystemSessionConnectParams Configure(IConfigSectionNode).)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_ACCESSKEY_ATTR |
CONFIG_BUCKET_ATTR |
CONFIG_REGION_ATTR |
CONFIG_SECRETKEY_ATTR |
CONFIG_TIMEOUT_MS_ATTR |
Back to Top
Properties
 | Name | Description
Public property | Bucket | AWS S3 bucket (i.e. bucket01)
Public property | Name | (Inherited from FileSystemSessionConnectParams.)
Public property | Region | AWS S3 bucket region (i.e. us-west-2)
Public property | TimeoutMs | Request timeout milliseconds
Public property | User | (Inherited from FileSystemSessionConnectParams.)
Public property | Version | (Inherited from FileSystemSessionConnectParams.)
Back to Top
See Also
S3V4FileSystemSessionConnectParams Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSessionConnectParams Constructor

S3V4FileSystemSessionConnectParams Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public method | S3V4FileSystemSessionConnectParams | Initializes a new instance of the S3V4FileSystemSessionConnectParams class
Public method | S3V4FileSystemSessionConnectParams(IConfigSectionNode) | Initializes a new instance of the S3V4FileSystemSessionConnectParams class
Public method | S3V4FileSystemSessionConnectParams(String, String) | Initializes a new instance of the S3V4FileSystemSessionConnectParams class
Back to Top
See Also
S3V4FileSystemSessionConnectParams Class
S3V4FileSystemSessionConnectParams Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSessionConnectParams Constructor

S3V4FileSystemSessionConnectParams Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the S3V4FileSystemSessionConnectParams class

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public S3V4FileSystemSessionConnectParams()
public S3V4FileSystemSessionConnectParams()
Public Sub New
Public Sub New
public:
S3V4FileSystemSessionConnectParams()
public:
S3V4FileSystemSessionConnectParams()
new : unit -> S3V4FileSystemSessionConnectParams
new : unit -> S3V4FileSystemSessionConnectParams
See Also
S3V4FileSystemSessionConnectParams Class
S3V4FileSystemSessionConnectParams Members
S3V4FileSystemSessionConnectParams Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSessionConnectParams Constructor (IConfigSectionNode)

S3V4FileSystemSessionConnectParams Constructor (IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the S3V4FileSystemSessionConnectParams class

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public S3V4FileSystemSessionConnectParams(
    IConfigSectionNode node
)
public S3V4FileSystemSessionConnectParams(
    IConfigSectionNode node
)
Public Sub New (
    node As IConfigSectionNode
)
Public Sub New (
    node As IConfigSectionNode
)
public:
S3V4FileSystemSessionConnectParams(
    IConfigSectionNode^ node
)
public:
S3V4FileSystemSessionConnectParams(
    IConfigSectionNode^ node
)
new :
        node : IConfigSectionNode -> S3V4FileSystemSessionConnectParams
new :
        node : IConfigSectionNode -> S3V4FileSystemSessionConnectParams

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
S3V4FileSystemSessionConnectParams Class
S3V4FileSystemSessionConnectParams Members
S3V4FileSystemSessionConnectParams Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSessionConnectParams Constructor (String, String)

S3V4FileSystemSessionConnectParams Constructor (String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the S3V4FileSystemSessionConnectParams class

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public S3V4FileSystemSessionConnectParams(
    string connectStr,
    string format = "laconf"
)
public S3V4FileSystemSessionConnectParams(
    string connectStr,
    string format = "laconf"
)
Public Sub New (
    connectStr As String,
    Optional format As String = "laconf"
)
Public Sub New (
    connectStr As String,
    Optional format As String = "laconf"
)
public:
S3V4FileSystemSessionConnectParams(
    String^ connectStr,
    String^ format = L"laconf"
)
public:
S3V4FileSystemSessionConnectParams(
    String^ connectStr,
    String^ format = L"laconf"
)
new :
        connectStr : string *
        ?format : string
(* Defaults:
        let _format = defaultArg format "laconf"
*)
-> S3V4FileSystemSessionConnectParams
new :
        connectStr : string *
        ?format : string
(* Defaults:
        let _format = defaultArg format "laconf"
*)
-> S3V4FileSystemSessionConnectParams

Parameters

connectStr
Type: Online System String
format (Optional)
Type: Online System String
See Also
S3V4FileSystemSessionConnectParams Class
S3V4FileSystemSessionConnectParams Members
S3V4FileSystemSessionConnectParams Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSessionConnectParams Fields

S3V4FileSystemSessionConnectParams Fields NFX Class Library

The S3V4FileSystemSessionConnectParams type exposes the following members.
Fields
Name | Description
CONFIG_ACCESSKEY_ATTR |
CONFIG_BUCKET_ATTR |
CONFIG_REGION_ATTR |
CONFIG_SECRETKEY_ATTR |
CONFIG_TIMEOUT_MS_ATTR |
Back to Top
See Also
S3V4FileSystemSessionConnectParams Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSessionConnectParams.CONFIG_ACCESSKEY_ATTR Field

S3V4FileSystemSessionConnectParams CONFIG_ACCESSKEY_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_ACCESSKEY_ATTR
public const string CONFIG_ACCESSKEY_ATTR
Public Const CONFIG_ACCESSKEY_ATTR As String
Public Const CONFIG_ACCESSKEY_ATTR As String
public:
literal String^ CONFIG_ACCESSKEY_ATTR
public:
literal String^ CONFIG_ACCESSKEY_ATTR
static val mutable CONFIG_ACCESSKEY_ATTR: string
static val mutable CONFIG_ACCESSKEY_ATTR: string

Field Value

Type: Online String
See Also
S3V4FileSystemSessionConnectParams Class
S3V4FileSystemSessionConnectParams Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSessionConnectParams.CONFIG_BUCKET_ATTR Field

S3V4FileSystemSessionConnectParams CONFIG_BUCKET_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_BUCKET_ATTR
public const string CONFIG_BUCKET_ATTR
Public Const CONFIG_BUCKET_ATTR As String
Public Const CONFIG_BUCKET_ATTR As String
public:
literal String^ CONFIG_BUCKET_ATTR
public:
literal String^ CONFIG_BUCKET_ATTR
static val mutable CONFIG_BUCKET_ATTR: string
static val mutable CONFIG_BUCKET_ATTR: string

Field Value

Type: Online String
See Also
S3V4FileSystemSessionConnectParams Class
S3V4FileSystemSessionConnectParams Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSessionConnectParams.CONFIG_REGION_ATTR Field

S3V4FileSystemSessionConnectParams CONFIG_REGION_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_REGION_ATTR
public const string CONFIG_REGION_ATTR
Public Const CONFIG_REGION_ATTR As String
Public Const CONFIG_REGION_ATTR As String
public:
literal String^ CONFIG_REGION_ATTR
public:
literal String^ CONFIG_REGION_ATTR
static val mutable CONFIG_REGION_ATTR: string
static val mutable CONFIG_REGION_ATTR: string

Field Value

Type: Online String
See Also
S3V4FileSystemSessionConnectParams Class
S3V4FileSystemSessionConnectParams Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSessionConnectParams.CONFIG_SECRETKEY_ATTR Field

S3V4FileSystemSessionConnectParams CONFIG_SECRETKEY_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SECRETKEY_ATTR
public const string CONFIG_SECRETKEY_ATTR
Public Const CONFIG_SECRETKEY_ATTR As String
Public Const CONFIG_SECRETKEY_ATTR As String
public:
literal String^ CONFIG_SECRETKEY_ATTR
public:
literal String^ CONFIG_SECRETKEY_ATTR
static val mutable CONFIG_SECRETKEY_ATTR: string
static val mutable CONFIG_SECRETKEY_ATTR: string

Field Value

Type: Online String
See Also
S3V4FileSystemSessionConnectParams Class
S3V4FileSystemSessionConnectParams Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSessionConnectParams.CONFIG_TIMEOUT_MS_ATTR Field

S3V4FileSystemSessionConnectParams CONFIG_TIMEOUT_MS_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_TIMEOUT_MS_ATTR
public const string CONFIG_TIMEOUT_MS_ATTR
Public Const CONFIG_TIMEOUT_MS_ATTR As String
Public Const CONFIG_TIMEOUT_MS_ATTR As String
public:
literal String^ CONFIG_TIMEOUT_MS_ATTR
public:
literal String^ CONFIG_TIMEOUT_MS_ATTR
static val mutable CONFIG_TIMEOUT_MS_ATTR: string
static val mutable CONFIG_TIMEOUT_MS_ATTR: string

Field Value

Type: Online String
See Also
S3V4FileSystemSessionConnectParams Class
S3V4FileSystemSessionConnectParams Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSessionConnectParams Methods

S3V4FileSystemSessionConnectParams Methods NFX Class Library

The S3V4FileSystemSessionConnectParams type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Overrides FileSystemSessionConnectParams Configure(IConfigSectionNode).)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
S3V4FileSystemSessionConnectParams Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSessionConnectParams.Configure Method

S3V4FileSystemSessionConnectParams Configure Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Configure(
    IConfigSectionNode node
)
public override void Configure(
    IConfigSectionNode node
)
Public Overrides Sub Configure (
    node As IConfigSectionNode
)
Public Overrides Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) override
public:
virtual void Configure(
    IConfigSectionNode^ node
) override
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
S3V4FileSystemSessionConnectParams Class
S3V4FileSystemSessionConnectParams Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSessionConnectParams Properties

S3V4FileSystemSessionConnectParams Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The S3V4FileSystemSessionConnectParams type exposes the following members.
Properties
 | Name | Description
Public property | Bucket | AWS S3 bucket (i.e. bucket01)
Public property | Name | (Inherited from FileSystemSessionConnectParams.)
Public property | Region | AWS S3 bucket region (i.e. us-west-2)
Public property | TimeoutMs | Request timeout milliseconds
Public property | User | (Inherited from FileSystemSessionConnectParams.)
Public property | Version | (Inherited from FileSystemSessionConnectParams.)
Back to Top
See Also
S3V4FileSystemSessionConnectParams Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSessionConnectParams.Bucket Property

S3V4FileSystemSessionConnectParams Bucket Property NFX Class Library

[This is preliminary documentation and is subject to change.]

AWS S3 bucket (i.e. bucket01)

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string Bucket { get; set; }
[ConfigAttribute]
public string Bucket { get; set; }
<ConfigAttribute>
Public Property Bucket As String
    Get
    Set
<ConfigAttribute>
Public Property Bucket As String
    Get
    Set
public:
[ConfigAttribute]
property String^ Bucket {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ Bucket {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member Bucket : string with get, set
[<ConfigAttribute>]
member Bucket : string with get, set

Property Value

Type: Online String
See Also
S3V4FileSystemSessionConnectParams Class
S3V4FileSystemSessionConnectParams Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSessionConnectParams.Region Property

S3V4FileSystemSessionConnectParams Region Property NFX Class Library

[This is preliminary documentation and is subject to change.]

AWS S3 bucket region (i.e. us-west-2)

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string Region { get; set; }
[ConfigAttribute]
public string Region { get; set; }
<ConfigAttribute>
Public Property Region As String
    Get
    Set
<ConfigAttribute>
Public Property Region As String
    Get
    Set
public:
[ConfigAttribute]
property String^ Region {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ Region {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member Region : string with get, set
[<ConfigAttribute>]
member Region : string with get, set

Property Value

Type: Online String
See Also
S3V4FileSystemSessionConnectParams Class
S3V4FileSystemSessionConnectParams Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemSessionConnectParams.TimeoutMs Property

S3V4FileSystemSessionConnectParams TimeoutMs Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Request timeout milliseconds

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int TimeoutMs { get; set; }
[ConfigAttribute]
public int TimeoutMs { get; set; }
<ConfigAttribute>
Public Property TimeoutMs As Integer
    Get
    Set
<ConfigAttribute>
Public Property TimeoutMs As Integer
    Get
    Set
public:
[ConfigAttribute]
property int TimeoutMs {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute]
property int TimeoutMs {
    int get ();
    void set (int value);
}
[<ConfigAttribute>]
member TimeoutMs : int with get, set
[<ConfigAttribute>]
member TimeoutMs : int with get, set

Property Value

Type: Online Int32
See Also
S3V4FileSystemSessionConnectParams Class
S3V4FileSystemSessionConnectParams Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemStream Class

S3V4FileSystemStream Class NFX Class Library

Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.IO Stream
NFX.IO.FileSystem FileSystemStream
NFX.IO.FileSystem.S3.V4 S3V4FileSystemStream

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class S3V4FileSystemStream : FileSystemStream
public class S3V4FileSystemStream : FileSystemStream
Public Class S3V4FileSystemStream
    Inherits FileSystemStream
Public Class S3V4FileSystemStream
    Inherits FileSystemStream
public ref class S3V4FileSystemStream : public FileSystemStream
public ref class S3V4FileSystemStream : public FileSystemStream
type S3V4FileSystemStream =
    class
        inherit FileSystemStream
    end
type S3V4FileSystemStream =
    class
        inherit FileSystemStream
    end
See Also
S3V4FileSystemStream Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemStream Members

S3V4FileSystemStream Members NFX Class Library

The S3V4FileSystemStream type exposes the following members.
Constructors
 | Name | Description
Public method | S3V4FileSystemStream | Initializes a new instance of the S3V4FileSystemStream class
Back to Top
Methods
 | Name | Description
Public method | Online BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Online Stream.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Protected method | Online CreateWaitHandle | Obsolete. Allocates a Online WaitHandle object. (Inherited from Online Stream.)
Public method | Online Dispose | Releases all resources used by the Online Stream. (Inherited from Online Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the S3V4FileSystemStream and optionally releases the managed resources (Overrides FileSystemStream Dispose(Boolean).)
Protected method | DoFlush | (Overrides FileSystemStream DoFlush .)
Protected method | DoGetLength | (Overrides FileSystemStream DoGetLength .)
Protected method | DoGetPosition | (Overrides FileSystemStream DoGetPosition .)
Protected method | DoRead | (Overrides FileSystemStream DoRead( Byte , Int32, Int32).)
Protected method | DoSeek | (Overrides FileSystemStream DoSeek(Int64, SeekOrigin).)
Protected method | DoSetLength | (Overrides FileSystemStream DoSetLength(Int64).)
Protected method | DoSetPosition | (Overrides FileSystemStream DoSetPosition(Int64).)
Protected method | DoWrite | (Overrides FileSystemStream DoWrite( Byte , Int32, Int32).)
Public method | Online EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Inherited from FileSystemStream.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Online Stream.)
Public method | FlushAsync(CancellationToken) | (Inherited from FileSystemStream.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Online Stream.)
Public method | Read | (Inherited from FileSystemStream.)
Public method | ReadAsync( Byte , Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Online Stream.)
Public method | ReadAsync( Byte , Int32, Int32, CancellationToken) | (Inherited from FileSystemStream.)
Public method | Online ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Online Stream.)
Public method | Seek | (Inherited from FileSystemStream.)
Public method | SetLength | (Inherited from FileSystemStream.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write | (Inherited from FileSystemStream.)
Public method | WriteAsync( Byte , Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Online Stream.)
Public method | WriteAsync( Byte , Int32, Int32, CancellationToken) | (Inherited from FileSystemStream.)
Public method | Online WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Online Stream.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsCharEnumerable | (Defined by IOMiscUtils.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Public Extension Method | ReadBEInt32 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEShort | Reads a short encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUInt64 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUShort | Reads an ushort encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadSLEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadSLEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | WriteBEInt32 | Writes an integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEShort | Writes a short encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUInt64 | Writes an unsigned long integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUShort | Writes an ushort encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteSLEB128(Int64, Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteSLEB128(Int64, Int32 , Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, UInt32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, Int32 , UInt32) | Overloaded. (Defined by LEB128.)
Back to Top
Fields
 | Name | Description
Public field | Item | Item that this stream is for (Inherited from FileSystemStream.)
Back to Top
Properties
 | Name | Description
Public property | CanRead | (Inherited from FileSystemStream.)
Public property | CanSeek | (Inherited from FileSystemStream.)
Public property | Online CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Online Stream.)
Public property | CanWrite | (Inherited from FileSystemStream.)
Public property | Length | (Inherited from FileSystemStream.)
Public property | Position | (Inherited from FileSystemStream.)
Public property | Online ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Online Stream.)
Public property | Online WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Online Stream.)
Back to Top
See Also
S3V4FileSystemStream Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemStream Constructor

S3V4FileSystemStream Constructor NFX Class Library

Initializes a new instance of the S3V4FileSystemStream class

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public S3V4FileSystemStream(
    FileSystemFile file,
    Action<FileSystemStream> disposeAction,
    int timeoutMs
)
public S3V4FileSystemStream(
    FileSystemFile file,
    Action<FileSystemStream> disposeAction,
    int timeoutMs
)
Public Sub New (
    file As FileSystemFile,
    disposeAction As Action(Of FileSystemStream),
    timeoutMs As Integer
)
Public Sub New (
    file As FileSystemFile,
    disposeAction As Action(Of FileSystemStream),
    timeoutMs As Integer
)
public:
S3V4FileSystemStream(
    FileSystemFile^ file,
    Action<FileSystemStream^>^ disposeAction,
    int timeoutMs
)
public:
S3V4FileSystemStream(
    FileSystemFile^ file,
    Action<FileSystemStream^>^ disposeAction,
    int timeoutMs
)
new :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> *
        timeoutMs : int -> S3V4FileSystemStream
new :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> *
        timeoutMs : int -> S3V4FileSystemStream

Parameters

file
Type: NFX.IO.FileSystem FileSystemFile
disposeAction
Type: Online System Action FileSystemStream
timeoutMs
Type: Online System Int32
See Also
S3V4FileSystemStream Class
S3V4FileSystemStream Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemStream Fields

S3V4FileSystemStream Fields NFX Class Library

The S3V4FileSystemStream type exposes the following members.
Fields
 | Name | Description
Public field | Item | Item that this stream is for (Inherited from FileSystemStream.)
Back to Top
See Also
S3V4FileSystemStream Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemStream Methods

S3V4FileSystemStream Methods NFX Class Library

The S3V4FileSystemStream type exposes the following members.
Methods
 | Name | Description
Public method | Online BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Online Stream.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Protected method | Online CreateWaitHandle | Obsolete. Allocates a Online WaitHandle object. (Inherited from Online Stream.)
Public method | Online Dispose | Releases all resources used by the Online Stream. (Inherited from Online Stream.)
Protected method | Dispose(Boolean) | (Overrides FileSystemStream Dispose(Boolean).)
Protected method | DoFlush | (Overrides FileSystemStream DoFlush .)
Protected method | DoGetLength | (Overrides FileSystemStream DoGetLength .)
Protected method | DoGetPosition | (Overrides FileSystemStream DoGetPosition .)
Protected method | DoRead | (Overrides FileSystemStream DoRead( Byte , Int32, Int32).)
Protected method | DoSeek | (Overrides FileSystemStream DoSeek(Int64, SeekOrigin).)
Protected method | DoSetLength | (Overrides FileSystemStream DoSetLength(Int64).)
Protected method | DoSetPosition | (Overrides FileSystemStream DoSetPosition(Int64).)
Protected method | DoWrite | (Overrides FileSystemStream DoWrite( Byte , Int32, Int32).)
Public method | Online EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Inherited from FileSystemStream.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Online Stream.)
Public method | FlushAsync(CancellationToken) | (Inherited from FileSystemStream.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Online Stream.)
Public method | Read | (Inherited from FileSystemStream.)
Public method | ReadAsync( Byte , Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Online Stream.)
Public method | ReadAsync( Byte , Int32, Int32, CancellationToken) | (Inherited from FileSystemStream.)
Public method | Online ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Online Stream.)
Public method | Seek | (Inherited from FileSystemStream.)
Public method | SetLength | (Inherited from FileSystemStream.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write | (Inherited from FileSystemStream.)
Public method | WriteAsync( Byte , Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Online Stream.)
Public method | WriteAsync( Byte , Int32, Int32, CancellationToken) | (Inherited from FileSystemStream.)
Public method | Online WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Online Stream.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsCharEnumerable | (Defined by IOMiscUtils.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Public Extension Method | ReadBEInt32 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEShort | Reads a short encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUInt64 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUShort | Reads an ushort encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadSLEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadSLEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | WriteBEInt32 | Writes an integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEShort | Writes a short encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUInt64 | Writes an unsigned long integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUShort | Writes an ushort encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteSLEB128(Int64, Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteSLEB128(Int64, Int32 , Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, UInt32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, Int32 , UInt32) | Overloaded. (Defined by LEB128.)
Back to Top
See Also
S3V4FileSystemStream Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemStream.Dispose Method

S3V4FileSystemStream Dispose Method NFX Class Library

Overload List
 | Name | Description
Public method | Online Dispose | Releases all resources used by the Online Stream. (Inherited from Online Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the S3V4FileSystemStream and optionally releases the managed resources (Overrides FileSystemStream Dispose(Boolean).)
Back to Top
See Also
S3V4FileSystemStream Class
S3V4FileSystemStream Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemStream.Dispose Method (Boolean)

S3V4FileSystemStream Dispose Method (Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Releases the unmanaged resources used by the S3V4FileSystemStream and optionally releases the managed resources

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
S3V4FileSystemStream Class
S3V4FileSystemStream Members
Dispose Overload
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemStream.DoFlush Method

S3V4FileSystemStream DoFlush Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoFlush()
protected override void DoFlush()
Protected Overrides Sub DoFlush
Protected Overrides Sub DoFlush
protected:
virtual void DoFlush() override
protected:
virtual void DoFlush() override
abstract DoFlush : unit -> unit
override DoFlush : unit -> unit
abstract DoFlush : unit -> unit
override DoFlush : unit -> unit
See Also
S3V4FileSystemStream Class
S3V4FileSystemStream Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemStream.DoGetLength Method

S3V4FileSystemStream DoGetLength Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override long DoGetLength()
protected override long DoGetLength()
Protected Overrides Function DoGetLength As Long
Protected Overrides Function DoGetLength As Long
protected:
virtual long long DoGetLength() override
protected:
virtual long long DoGetLength() override
abstract DoGetLength : unit -> int64
override DoGetLength : unit -> int64
abstract DoGetLength : unit -> int64
override DoGetLength : unit -> int64

Return Value

Type: Online Int64
See Also
S3V4FileSystemStream Class
S3V4FileSystemStream Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemStream.DoGetPosition Method

S3V4FileSystemStream DoGetPosition Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override long DoGetPosition()
protected override long DoGetPosition()
Protected Overrides Function DoGetPosition As Long
Protected Overrides Function DoGetPosition As Long
protected:
virtual long long DoGetPosition() override
protected:
virtual long long DoGetPosition() override
abstract DoGetPosition : unit -> int64
override DoGetPosition : unit -> int64
abstract DoGetPosition : unit -> int64
override DoGetPosition : unit -> int64

Return Value

Type: Online Int64
See Also
S3V4FileSystemStream Class
S3V4FileSystemStream Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemStream.DoRead Method

S3V4FileSystemStream DoRead Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override int DoRead(
    byte[] buffer,
    int offset,
    int count
)
protected override int DoRead(
    byte[] buffer,
    int offset,
    int count
)
Protected Overrides Function DoRead (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
Protected Overrides Function DoRead (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
protected:
virtual int DoRead(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
protected:
virtual int DoRead(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract DoRead :
        buffer : byte[] *
        offset : int *
        count : int -> int
override DoRead :
        buffer : byte[] *
        offset : int *
        count : int -> int
abstract DoRead :
        buffer : byte[] *
        offset : int *
        count : int -> int
override DoRead :
        buffer : byte[] *
        offset : int *
        count : int -> int

Parameters

buffer
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32

Return Value

Type: Online Int32
See Also
S3V4FileSystemStream Class
S3V4FileSystemStream Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemStream.DoSeek Method

S3V4FileSystemStream DoSeek Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override long DoSeek(
    long offset,
    SeekOrigin origin
)
protected override long DoSeek(
    long offset,
    SeekOrigin origin
)
Protected Overrides Function DoSeek (
    offset As Long,
    origin As SeekOrigin
) As Long
Protected Overrides Function DoSeek (
    offset As Long,
    origin As SeekOrigin
) As Long
protected:
virtual long long DoSeek(
    long long offset,
    SeekOrigin origin
) override
protected:
virtual long long DoSeek(
    long long offset,
    SeekOrigin origin
) override
abstract DoSeek :
        offset : int64 *
        origin : SeekOrigin -> int64
override DoSeek :
        offset : int64 *
        origin : SeekOrigin -> int64
abstract DoSeek :
        offset : int64 *
        origin : SeekOrigin -> int64
override DoSeek :
        offset : int64 *
        origin : SeekOrigin -> int64

Parameters

offset
Type: Online System Int64
origin
Type: Online System.IO SeekOrigin

Return Value

Type: Online Int64
See Also
S3V4FileSystemStream Class
S3V4FileSystemStream Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemStream.DoSetLength Method

S3V4FileSystemStream DoSetLength Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSetLength(
    long value
)
protected override void DoSetLength(
    long value
)
Protected Overrides Sub DoSetLength (
    value As Long
)
Protected Overrides Sub DoSetLength (
    value As Long
)
protected:
virtual void DoSetLength(
    long long value
) override
protected:
virtual void DoSetLength(
    long long value
) override
abstract DoSetLength :
        value : int64 -> unit
override DoSetLength :
        value : int64 -> unit
abstract DoSetLength :
        value : int64 -> unit
override DoSetLength :
        value : int64 -> unit

Parameters

value
Type: Online System Int64
See Also
S3V4FileSystemStream Class
S3V4FileSystemStream Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemStream.DoSetPosition Method

S3V4FileSystemStream DoSetPosition Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSetPosition(
    long position
)
protected override void DoSetPosition(
    long position
)
Protected Overrides Sub DoSetPosition (
    position As Long
)
Protected Overrides Sub DoSetPosition (
    position As Long
)
protected:
virtual void DoSetPosition(
    long long position
) override
protected:
virtual void DoSetPosition(
    long long position
) override
abstract DoSetPosition :
        position : int64 -> unit
override DoSetPosition :
        position : int64 -> unit
abstract DoSetPosition :
        position : int64 -> unit
override DoSetPosition :
        position : int64 -> unit

Parameters

position
Type: Online System Int64
See Also
S3V4FileSystemStream Class
S3V4FileSystemStream Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemStream.DoWrite Method

S3V4FileSystemStream DoWrite Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWrite(
    byte[] buffer,
    int offset,
    int count
)
protected override void DoWrite(
    byte[] buffer,
    int offset,
    int count
)
Protected Overrides Sub DoWrite (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
Protected Overrides Sub DoWrite (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
protected:
virtual void DoWrite(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
protected:
virtual void DoWrite(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract DoWrite :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override DoWrite :
        buffer : byte[] *
        offset : int *
        count : int -> unit
abstract DoWrite :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override DoWrite :
        buffer : byte[] *
        offset : int *
        count : int -> unit

Parameters

buffer
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32
See Also
S3V4FileSystemStream Class
S3V4FileSystemStream Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4FileSystemStream Properties

S3V4FileSystemStream Properties NFX Class Library

The S3V4FileSystemStream type exposes the following members.
Properties
 | Name | Description
Public property | CanRead | (Inherited from FileSystemStream.)
Public property | CanSeek | (Inherited from FileSystemStream.)
Public property | Online CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Online Stream.)
Public property | CanWrite | (Inherited from FileSystemStream.)
Public property | Length | (Inherited from FileSystemStream.)
Public property | Position | (Inherited from FileSystemStream.)
Public property | Online ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Online Stream.)
Public property | Online WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Online Stream.)
Back to Top
See Also
S3V4FileSystemStream Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4HttpHelpers Class

S3V4HttpHelpers Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.S3.V4 S3V4HttpHelpers

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class S3V4HttpHelpers
public static class S3V4HttpHelpers
<ExtensionAttribute>
Public NotInheritable Class S3V4HttpHelpers
<ExtensionAttribute>
Public NotInheritable Class S3V4HttpHelpers
[ExtensionAttribute]
public ref class S3V4HttpHelpers abstract sealed
[ExtensionAttribute]
public ref class S3V4HttpHelpers abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type S3V4HttpHelpers =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type S3V4HttpHelpers =  class end
See Also
S3V4HttpHelpers Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4HttpHelpers Members

S3V4HttpHelpers Members NFX Class Library

The S3V4HttpHelpers type exposes the following members.
Methods
Name | Description
ConstructWebRequest |
FilterHeaders |
GetHeaders |
GetResponseBytes |
GetResponseStr |
Back to Top
See Also
S3V4HttpHelpers Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4HttpHelpers Methods

S3V4HttpHelpers Methods NFX Class Library

The S3V4HttpHelpers type exposes the following members.
Methods
Name | Description
ConstructWebRequest |
FilterHeaders |
GetHeaders |
GetResponseBytes |
GetResponseStr |
Back to Top
See Also
S3V4HttpHelpers Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4HttpHelpers.ConstructWebRequest Method

S3V4HttpHelpers ConstructWebRequest Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static HttpWebRequest ConstructWebRequest(
    this Uri uri,
    string method,
    Stream contentStream,
    IDictionary<string, string> headers,
    int timeout = 0
)
public static HttpWebRequest ConstructWebRequest(
    this Uri uri,
    string method,
    Stream contentStream,
    IDictionary<string, string> headers,
    int timeout = 0
)
<ExtensionAttribute>
Public Shared Function ConstructWebRequest (
    uri As Uri,
    method As String,
    contentStream As Stream,
    headers As IDictionary(Of String, String),
    Optional timeout As Integer = 0
) As HttpWebRequest
<ExtensionAttribute>
Public Shared Function ConstructWebRequest (
    uri As Uri,
    method As String,
    contentStream As Stream,
    headers As IDictionary(Of String, String),
    Optional timeout As Integer = 0
) As HttpWebRequest
public:
[ExtensionAttribute]
static HttpWebRequest^ ConstructWebRequest(
    Uri^ uri,
    String^ method,
    Stream^ contentStream,
    IDictionary<String^, String^>^ headers,
    int timeout = 0
)
public:
[ExtensionAttribute]
static HttpWebRequest^ ConstructWebRequest(
    Uri^ uri,
    String^ method,
    Stream^ contentStream,
    IDictionary<String^, String^>^ headers,
    int timeout = 0
)
static member ConstructWebRequest :
        uri : Uri *
        method : string *
        contentStream : Stream *
        headers : IDictionary<string, string> *
        ?timeout : int
(* Defaults:
        let _timeout = defaultArg timeout 0
*)
-> HttpWebRequest
static member ConstructWebRequest :
        uri : Uri *
        method : string *
        contentStream : Stream *
        headers : IDictionary<string, string> *
        ?timeout : int
(* Defaults:
        let _timeout = defaultArg timeout 0
*)
-> HttpWebRequest

Parameters

uri
Type: Online System Uri
method
Type: Online System String
contentStream
Type: Online System.IO Stream
headers
Type: Online System.Collections.Generic IDictionary Online String, Online String
timeout (Optional)
Type: Online System Int32

Return Value

Type: Online HttpWebRequest

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Uri. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
S3V4HttpHelpers Class
S3V4HttpHelpers Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4HttpHelpers.FilterHeaders Method

S3V4HttpHelpers FilterHeaders Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IDictionary<string, string> FilterHeaders(
    this IDictionary<string, string> headers
)
public static IDictionary<string, string> FilterHeaders(
    this IDictionary<string, string> headers
)
<ExtensionAttribute>
Public Shared Function FilterHeaders (
    headers As IDictionary(Of String, String)
) As IDictionary(Of String, String)
<ExtensionAttribute>
Public Shared Function FilterHeaders (
    headers As IDictionary(Of String, String)
) As IDictionary(Of String, String)
public:
[ExtensionAttribute]
static IDictionary<String^, String^>^ FilterHeaders(
    IDictionary<String^, String^>^ headers
)
public:
[ExtensionAttribute]
static IDictionary<String^, String^>^ FilterHeaders(
    IDictionary<String^, String^>^ headers
)
static member FilterHeaders :
        headers : IDictionary<string, string> -> IDictionary<string, string>
static member FilterHeaders :
        headers : IDictionary<string, string> -> IDictionary<string, string>

Parameters

headers
Type: Online System.Collections.Generic IDictionary Online String, Online String

Return Value

Type: Online IDictionary Online String, Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online IDictionary Online String, Online String . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
S3V4HttpHelpers Class
S3V4HttpHelpers Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4HttpHelpers.GetHeaders Method

S3V4HttpHelpers GetHeaders Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IDictionary<string, string> GetHeaders(
    this HttpWebRequest request,
    HttpStatusCode successStatus = HttpStatusCode.OK
)
public static IDictionary<string, string> GetHeaders(
    this HttpWebRequest request,
    HttpStatusCode successStatus = HttpStatusCode.OK
)
<ExtensionAttribute>
Public Shared Function GetHeaders (
    request As HttpWebRequest,
    Optional successStatus As HttpStatusCode = HttpStatusCode.OK
) As IDictionary(Of String, String)
<ExtensionAttribute>
Public Shared Function GetHeaders (
    request As HttpWebRequest,
    Optional successStatus As HttpStatusCode = HttpStatusCode.OK
) As IDictionary(Of String, String)
public:
[ExtensionAttribute]
static IDictionary<String^, String^>^ GetHeaders(
    HttpWebRequest^ request,
    HttpStatusCode successStatus = HttpStatusCode::OK
)
public:
[ExtensionAttribute]
static IDictionary<String^, String^>^ GetHeaders(
    HttpWebRequest^ request,
    HttpStatusCode successStatus = HttpStatusCode::OK
)
static member GetHeaders :
        request : HttpWebRequest *
        ?successStatus : HttpStatusCode
(* Defaults:
        let _successStatus = defaultArg successStatus HttpStatusCode.OK
*)
-> IDictionary<string, string>
static member GetHeaders :
        request : HttpWebRequest *
        ?successStatus : HttpStatusCode
(* Defaults:
        let _successStatus = defaultArg successStatus HttpStatusCode.OK
*)
-> IDictionary<string, string>

Parameters

request
Type: Online System.Net HttpWebRequest
successStatus (Optional)
Type: Online System.Net HttpStatusCode

Return Value

Type: Online IDictionary Online String, Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online HttpWebRequest. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
S3V4HttpHelpers Class
S3V4HttpHelpers Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4HttpHelpers.GetResponseBytes Method

S3V4HttpHelpers GetResponseBytes Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void GetResponseBytes(
    this HttpWebRequest request,
    Stream stream
)
public static void GetResponseBytes(
    this HttpWebRequest request,
    Stream stream
)
<ExtensionAttribute>
Public Shared Sub GetResponseBytes (
    request As HttpWebRequest,
    stream As Stream
)
<ExtensionAttribute>
Public Shared Sub GetResponseBytes (
    request As HttpWebRequest,
    stream As Stream
)
public:
[ExtensionAttribute]
static void GetResponseBytes(
    HttpWebRequest^ request,
    Stream^ stream
)
public:
[ExtensionAttribute]
static void GetResponseBytes(
    HttpWebRequest^ request,
    Stream^ stream
)
static member GetResponseBytes :
        request : HttpWebRequest *
        stream : Stream -> unit
static member GetResponseBytes :
        request : HttpWebRequest *
        stream : Stream -> unit

Parameters

request
Type: Online System.Net HttpWebRequest
stream
Type: Online System.IO Stream

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online HttpWebRequest. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
S3V4HttpHelpers Class
S3V4HttpHelpers Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4HttpHelpers.GetResponseStr Method

S3V4HttpHelpers GetResponseStr Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetResponseStr(
    this HttpWebRequest request
)
public static string GetResponseStr(
    this HttpWebRequest request
)
<ExtensionAttribute>
Public Shared Function GetResponseStr (
    request As HttpWebRequest
) As String
<ExtensionAttribute>
Public Shared Function GetResponseStr (
    request As HttpWebRequest
) As String
public:
[ExtensionAttribute]
static String^ GetResponseStr(
    HttpWebRequest^ request
)
public:
[ExtensionAttribute]
static String^ GetResponseStr(
    HttpWebRequest^ request
)
static member GetResponseStr :
        request : HttpWebRequest -> string
static member GetResponseStr :
        request : HttpWebRequest -> string

Parameters

request
Type: Online System.Net HttpWebRequest

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online HttpWebRequest. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
S3V4HttpHelpers Class
S3V4HttpHelpers Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4ListBucketItem Class

S3V4ListBucketItem Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.S3.V4 S3V4ListBucketItem

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class S3V4ListBucketItem
internal class S3V4ListBucketItem
Friend Class S3V4ListBucketItem
Friend Class S3V4ListBucketItem
internal ref class S3V4ListBucketItem
internal ref class S3V4ListBucketItem
type S3V4ListBucketItem =  class end
type S3V4ListBucketItem =  class end
See Also
S3V4ListBucketItem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4ListBucketItem Members

S3V4ListBucketItem Members NFX Class Library

The S3V4ListBucketItem type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | FromXElement |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ETag |
Public property | IsFolder |
Public property | IsNested |
Public property | ItemName |
Public property | Key |
Public property | LastModified |
Public property | Size |
Back to Top
See Also
S3V4ListBucketItem Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4ListBucketItem Methods

S3V4ListBucketItem Methods NFX Class Library

The S3V4ListBucketItem type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | FromXElement |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
S3V4ListBucketItem Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4ListBucketItem.FromXElement Method

S3V4ListBucketItem FromXElement Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static S3V4ListBucketItem FromXElement(
    XElement contentElement,
    string prefix
)
public static S3V4ListBucketItem FromXElement(
    XElement contentElement,
    string prefix
)
Public Shared Function FromXElement (
    contentElement As XElement,
    prefix As String
) As S3V4ListBucketItem
Public Shared Function FromXElement (
    contentElement As XElement,
    prefix As String
) As S3V4ListBucketItem
public:
static S3V4ListBucketItem^ FromXElement(
    XElement^ contentElement,
    String^ prefix
)
public:
static S3V4ListBucketItem^ FromXElement(
    XElement^ contentElement,
    String^ prefix
)
static member FromXElement :
        contentElement : XElement *
        prefix : string -> S3V4ListBucketItem
static member FromXElement :
        contentElement : XElement *
        prefix : string -> S3V4ListBucketItem

Parameters

contentElement
Type: Online System.Xml.Linq XElement
prefix
Type: Online System String

Return Value

Type: S3V4ListBucketItem
See Also
S3V4ListBucketItem Class
S3V4ListBucketItem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4ListBucketItem.ToString Method

S3V4ListBucketItem ToString Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
S3V4ListBucketItem Class
S3V4ListBucketItem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4ListBucketItem Properties

S3V4ListBucketItem Properties NFX Class Library

The S3V4ListBucketItem type exposes the following members.
Properties
 | Name | Description
Public property | ETag |
Public property | IsFolder |
Public property | IsNested |
Public property | ItemName |
Public property | Key |
Public property | LastModified |
Public property | Size |
Back to Top
See Also
S3V4ListBucketItem Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4ListBucketItem.ETag Property

S3V4ListBucketItem ETag Property NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ETag { get; private set; }
public string ETag { get; private set; }
Public Property ETag As String
    Get
    Private Set
Public Property ETag As String
    Get
    Private Set
public:
property String^ ETag {
    String^ get ();
    private: void set (String^ value);
}
public:
property String^ ETag {
    String^ get ();
    private: void set (String^ value);
}
member ETag : string with get, private set
member ETag : string with get, private set

Property Value

Type: Online String
See Also
S3V4ListBucketItem Class
S3V4ListBucketItem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4ListBucketItem.IsFolder Property

S3V4ListBucketItem IsFolder Property NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsFolder { get; private set; }
public bool IsFolder { get; private set; }
Public Property IsFolder As Boolean
    Get
    Private Set
Public Property IsFolder As Boolean
    Get
    Private Set
public:
property bool IsFolder {
    bool get ();
    private: void set (bool value);
}
public:
property bool IsFolder {
    bool get ();
    private: void set (bool value);
}
member IsFolder : bool with get, private set
member IsFolder : bool with get, private set

Property Value

Type: Online Boolean
See Also
S3V4ListBucketItem Class
S3V4ListBucketItem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4ListBucketItem.IsNested Property

S3V4ListBucketItem IsNested Property NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsNested { get; private set; }
public bool IsNested { get; private set; }
Public Property IsNested As Boolean
    Get
    Private Set
Public Property IsNested As Boolean
    Get
    Private Set
public:
property bool IsNested {
    bool get ();
    private: void set (bool value);
}
public:
property bool IsNested {
    bool get ();
    private: void set (bool value);
}
member IsNested : bool with get, private set
member IsNested : bool with get, private set

Property Value

Type: Online Boolean
See Also
S3V4ListBucketItem Class
S3V4ListBucketItem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4ListBucketItem.ItemName Property

S3V4ListBucketItem ItemName Property NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ItemName { get; private set; }
public string ItemName { get; private set; }
Public Property ItemName As String
    Get
    Private Set
Public Property ItemName As String
    Get
    Private Set
public:
property String^ ItemName {
    String^ get ();
    private: void set (String^ value);
}
public:
property String^ ItemName {
    String^ get ();
    private: void set (String^ value);
}
member ItemName : string with get, private set
member ItemName : string with get, private set

Property Value

Type: Online String
See Also
S3V4ListBucketItem Class
S3V4ListBucketItem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4ListBucketItem.Key Property

S3V4ListBucketItem Key Property NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Key { get; private set; }
public string Key { get; private set; }
Public Property Key As String
    Get
    Private Set
Public Property Key As String
    Get
    Private Set
public:
property String^ Key {
    String^ get ();
    private: void set (String^ value);
}
public:
property String^ Key {
    String^ get ();
    private: void set (String^ value);
}
member Key : string with get, private set
member Key : string with get, private set

Property Value

Type: Online String
See Also
S3V4ListBucketItem Class
S3V4ListBucketItem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4ListBucketItem.LastModified Property

S3V4ListBucketItem LastModified Property NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime LastModified { get; private set; }
public DateTime LastModified { get; private set; }
Public Property LastModified As DateTime
    Get
    Private Set
Public Property LastModified As DateTime
    Get
    Private Set
public:
property DateTime LastModified {
    DateTime get ();
    private: void set (DateTime value);
}
public:
property DateTime LastModified {
    DateTime get ();
    private: void set (DateTime value);
}
member LastModified : DateTime with get, private set
member LastModified : DateTime with get, private set

Property Value

Type: Online DateTime
See Also
S3V4ListBucketItem Class
S3V4ListBucketItem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4ListBucketItem.Size Property

S3V4ListBucketItem Size Property NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong Size { get; private set; }
public ulong Size { get; private set; }
Public Property Size As ULong
    Get
    Private Set
Public Property Size As ULong
    Get
    Private Set
public:
property unsigned long long Size {
    unsigned long long get ();
    private: void set (unsigned long long value);
}
public:
property unsigned long long Size {
    unsigned long long get ();
    private: void set (unsigned long long value);
}
member Size : uint64 with get, private set
member Size : uint64 with get, private set

Property Value

Type: Online UInt64
See Also
S3V4ListBucketItem Class
S3V4ListBucketItem Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4ListBucketResult Class

S3V4ListBucketResult Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.S3.V4 S3V4ListBucketResult

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class S3V4ListBucketResult
internal class S3V4ListBucketResult
Friend Class S3V4ListBucketResult
Friend Class S3V4ListBucketResult
internal ref class S3V4ListBucketResult
internal ref class S3V4ListBucketResult
type S3V4ListBucketResult =  class end
type S3V4ListBucketResult =  class end
See Also
S3V4ListBucketResult Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4ListBucketResult Members

S3V4ListBucketResult Members NFX Class Library

The S3V4ListBucketResult type exposes the following members.
Methods
 | Name | Description
Public method | AddXML |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | FromXML |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | IsTruncated |
Public property | Items |
Back to Top
See Also
S3V4ListBucketResult Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4ListBucketResult Methods

S3V4ListBucketResult Methods NFX Class Library

The S3V4ListBucketResult type exposes the following members.
Methods
 | Name | Description
Public method | AddXML |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | FromXML |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
S3V4ListBucketResult Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4ListBucketResult.AddXML Method

S3V4ListBucketResult AddXML Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddXML(
    string xml
)
public void AddXML(
    string xml
)
Public Sub AddXML (
    xml As String
)
Public Sub AddXML (
    xml As String
)
public:
void AddXML(
    String^ xml
)
public:
void AddXML(
    String^ xml
)
member AddXML :
        xml : string -> unit
member AddXML :
        xml : string -> unit

Parameters

xml
Type: Online System String
See Also
S3V4ListBucketResult Class
S3V4ListBucketResult Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4ListBucketResult.FromXML Method

S3V4ListBucketResult FromXML Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static S3V4ListBucketResult FromXML(
    string xml
)
public static S3V4ListBucketResult FromXML(
    string xml
)
Public Shared Function FromXML (
    xml As String
) As S3V4ListBucketResult
Public Shared Function FromXML (
    xml As String
) As S3V4ListBucketResult
public:
static S3V4ListBucketResult^ FromXML(
    String^ xml
)
public:
static S3V4ListBucketResult^ FromXML(
    String^ xml
)
static member FromXML :
        xml : string -> S3V4ListBucketResult
static member FromXML :
        xml : string -> S3V4ListBucketResult

Parameters

xml
Type: Online System String

Return Value

Type: S3V4ListBucketResult
See Also
S3V4ListBucketResult Class
S3V4ListBucketResult Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4ListBucketResult Properties

S3V4ListBucketResult Properties NFX Class Library

The S3V4ListBucketResult type exposes the following members.
Properties
 | Name | Description
Public property | IsTruncated |
Public property | Items |
Back to Top
See Also
S3V4ListBucketResult Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4ListBucketResult.IsTruncated Property

S3V4ListBucketResult IsTruncated Property NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsTruncated { get; }
public bool IsTruncated { get; }
Public ReadOnly Property IsTruncated As Boolean
    Get
Public ReadOnly Property IsTruncated As Boolean
    Get
public:
property bool IsTruncated {
    bool get ();
}
public:
property bool IsTruncated {
    bool get ();
}
member IsTruncated : bool with get
member IsTruncated : bool with get

Property Value

Type: Online Boolean
See Also
S3V4ListBucketResult Class
S3V4ListBucketResult Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4ListBucketResult.Items Property

S3V4ListBucketResult Items Property NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<S3V4ListBucketItem> Items { get; }
public List<S3V4ListBucketItem> Items { get; }
Public ReadOnly Property Items As List(Of S3V4ListBucketItem)
    Get
Public ReadOnly Property Items As List(Of S3V4ListBucketItem)
    Get
public:
property List<S3V4ListBucketItem^>^ Items {
    List<S3V4ListBucketItem^>^ get ();
}
public:
property List<S3V4ListBucketItem^>^ Items {
    List<S3V4ListBucketItem^>^ get ();
}
member Items : List<S3V4ListBucketItem> with get
member Items : List<S3V4ListBucketItem> with get

Property Value

Type: Online List S3V4ListBucketItem
See Also
S3V4ListBucketResult Class
S3V4ListBucketResult Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4URI Class

S3V4URI Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.S3.V4 S3V4URI

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class S3V4URI
public class S3V4URI
Public Class S3V4URI
Public Class S3V4URI
public ref class S3V4URI
public ref class S3V4URI
type S3V4URI =  class end
type S3V4URI =  class end
See Also
S3V4URI Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4URI Members

S3V4URI Members NFX Class Library

The S3V4URI type exposes the following members.
Constructors
 | Name | Description
Public method | S3V4URI | Initializes a new instance of the S3V4URI class
Back to Top
Methods
 | Name | Description
 | CreateFile |
 | CreateFolder |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Bucket |
Public property | LocalName |
Public property | LocalPath |
Public property | ParentPath |
Public property | Path |
Public property | QueryParams |
Public property | Region |
Back to Top
See Also
S3V4URI Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4URI Constructor

S3V4URI Constructor NFX Class Library

Initializes a new instance of the S3V4URI class

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public S3V4URI(
    string path
)
public S3V4URI(
    string path
)
Public Sub New (
    path As String
)
Public Sub New (
    path As String
)
public:
S3V4URI(
    String^ path
)
public:
S3V4URI(
    String^ path
)
new :
        path : string -> S3V4URI
new :
        path : string -> S3V4URI

Parameters

path
Type: Online System String
See Also
S3V4URI Class
S3V4URI Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4URI Methods

S3V4URI Methods NFX Class Library

The S3V4URI type exposes the following members.
Methods
 | Name | Description
 | CreateFile |
 | CreateFolder |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
S3V4URI Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4URI.CreateFile Method

S3V4URI CreateFile Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static S3V4URI CreateFile(
    string path
)
public static S3V4URI CreateFile(
    string path
)
Public Shared Function CreateFile (
    path As String
) As S3V4URI
Public Shared Function CreateFile (
    path As String
) As S3V4URI
public:
static S3V4URI^ CreateFile(
    String^ path
)
public:
static S3V4URI^ CreateFile(
    String^ path
)
static member CreateFile :
        path : string -> S3V4URI
static member CreateFile :
        path : string -> S3V4URI

Parameters

path
Type: Online System String

Return Value

Type: S3V4URI
See Also
S3V4URI Class
S3V4URI Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4URI.CreateFolder Method

S3V4URI CreateFolder Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static S3V4URI CreateFolder(
    string path
)
public static S3V4URI CreateFolder(
    string path
)
Public Shared Function CreateFolder (
    path As String
) As S3V4URI
Public Shared Function CreateFolder (
    path As String
) As S3V4URI
public:
static S3V4URI^ CreateFolder(
    String^ path
)
public:
static S3V4URI^ CreateFolder(
    String^ path
)
static member CreateFolder :
        path : string -> S3V4URI
static member CreateFolder :
        path : string -> S3V4URI

Parameters

path
Type: Online System String

Return Value

Type: S3V4URI
See Also
S3V4URI Class
S3V4URI Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4URI Properties

S3V4URI Properties NFX Class Library

The S3V4URI type exposes the following members.
Properties
 | Name | Description
Public property | Bucket |
Public property | LocalName |
Public property | LocalPath |
Public property | ParentPath |
Public property | Path |
Public property | QueryParams |
Public property | Region |
Back to Top
See Also
S3V4URI Class
NFX.IO.FileSystem.S3.V4 Namespace


S3V4URI.Bucket Property

S3V4URI Bucket Property NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Bucket { get; }
public string Bucket { get; }
Public ReadOnly Property Bucket As String
    Get
Public ReadOnly Property Bucket As String
    Get
public:
property String^ Bucket {
    String^ get ();
}
public:
property String^ Bucket {
    String^ get ();
}
member Bucket : string with get
member Bucket : string with get

Property Value

Type: Online String
See Also
S3V4URI Class
S3V4URI Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4URI.LocalName Property

S3V4URI LocalName Property NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string LocalName { get; }
public string LocalName { get; }
Public ReadOnly Property LocalName As String
    Get
Public ReadOnly Property LocalName As String
    Get
public:
property String^ LocalName {
    String^ get ();
}
public:
property String^ LocalName {
    String^ get ();
}
member LocalName : string with get
member LocalName : string with get

Property Value

Type: Online String
See Also
S3V4URI Class
S3V4URI Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4URI.LocalPath Property

S3V4URI LocalPath Property NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string LocalPath { get; }
public string LocalPath { get; }
Public ReadOnly Property LocalPath As String
    Get
Public ReadOnly Property LocalPath As String
    Get
public:
property String^ LocalPath {
    String^ get ();
}
public:
property String^ LocalPath {
    String^ get ();
}
member LocalPath : string with get
member LocalPath : string with get

Property Value

Type: Online String
See Also
S3V4URI Class
S3V4URI Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4URI.ParentPath Property

S3V4URI ParentPath Property NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ParentPath { get; }
public string ParentPath { get; }
Public ReadOnly Property ParentPath As String
    Get
Public ReadOnly Property ParentPath As String
    Get
public:
property String^ ParentPath {
    String^ get ();
}
public:
property String^ ParentPath {
    String^ get ();
}
member ParentPath : string with get
member ParentPath : string with get

Property Value

Type: Online String
See Also
S3V4URI Class
S3V4URI Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4URI.Path Property

S3V4URI Path Property NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Path { get; }
public string Path { get; }
Public ReadOnly Property Path As String
    Get
Public ReadOnly Property Path As String
    Get
public:
property String^ Path {
    String^ get ();
}
public:
property String^ Path {
    String^ get ();
}
member Path : string with get
member Path : string with get

Property Value

Type: Online String
See Also
S3V4URI Class
S3V4URI Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4URI.QueryParams Property

S3V4URI QueryParams Property NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<string, string> QueryParams { get; }
public IDictionary<string, string> QueryParams { get; }
Public ReadOnly Property QueryParams As IDictionary(Of String, String)
    Get
Public ReadOnly Property QueryParams As IDictionary(Of String, String)
    Get
public:
property IDictionary<String^, String^>^ QueryParams {
    IDictionary<String^, String^>^ get ();
}
public:
property IDictionary<String^, String^>^ QueryParams {
    IDictionary<String^, String^>^ get ();
}
member QueryParams : IDictionary<string, string> with get
member QueryParams : IDictionary<string, string> with get

Property Value

Type: Online IDictionary Online String, Online String
See Also
S3V4URI Class
S3V4URI Members
NFX.IO.FileSystem.S3.V4 Namespace


S3V4URI.Region Property

S3V4URI Region Property NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Region { get; }
public string Region { get; }
Public ReadOnly Property Region As String
    Get
Public ReadOnly Property Region As String
    Get
public:
property String^ Region {
    String^ get ();
}
public:
property String^ Region {
    String^ get ();
}
member Region : string with get
member Region : string with get

Property Value

Type: Online String
See Also
S3V4URI Class
S3V4URI Members
NFX.IO.FileSystem.S3.V4 Namespace


NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace

NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace NFX Class Library

Classes
 | Class | Description
Public class | S3V4Helpers | Implements helpers methods for Amazon S3
Public class | S3V4Signer | Handles S3V4 signing routines
Public class | S3V4URLHelpers |


S3V4Helpers Class

S3V4Helpers Class NFX Class Library

Implements helpers methods for Amazon S3
Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.S3.V4.S3V4Sign S3V4Helpers

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class S3V4Helpers
public static class S3V4Helpers
<ExtensionAttribute>
Public NotInheritable Class S3V4Helpers
<ExtensionAttribute>
Public NotInheritable Class S3V4Helpers
[ExtensionAttribute]
public ref class S3V4Helpers abstract sealed
[ExtensionAttribute]
public ref class S3V4Helpers abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type S3V4Helpers =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type S3V4Helpers =  class end
See Also
S3V4Helpers Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Helpers Members

S3V4Helpers Members NFX Class Library

The S3V4Helpers type exposes the following members.
Methods
Name | Description
GetS3AbsoolutePath | Returns absolute path of S3 Uri
S3Bytes | Converts string into UTF8 byte array encoded representation
S3DateString | Converts DateTime into appropriate S3 date string representation
S3DateTimeString | Converts DateTime into appropriate S3 datetime string representation
ToHexString | Converts byte array into appropriate string hexadecimal representation
Back to Top
Fields
Name | Description
DATESTRING_FORMAT |
ISO8601_DATESTRING_FORMAT |
Back to Top
See Also
S3V4Helpers Class
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Helpers Fields

S3V4Helpers Fields NFX Class Library

The S3V4Helpers type exposes the following members.
Fields
Name | Description
DATESTRING_FORMAT |
ISO8601_DATESTRING_FORMAT |
Back to Top
See Also
S3V4Helpers Class
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Helpers.DATESTRING_FORMAT Field

S3V4Helpers DATESTRING_FORMAT Field NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DATESTRING_FORMAT
public const string DATESTRING_FORMAT
Public Const DATESTRING_FORMAT As String
Public Const DATESTRING_FORMAT As String
public:
literal String^ DATESTRING_FORMAT
public:
literal String^ DATESTRING_FORMAT
static val mutable DATESTRING_FORMAT: string
static val mutable DATESTRING_FORMAT: string

Field Value

Type: Online String
See Also
S3V4Helpers Class
S3V4Helpers Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Helpers.ISO8601_DATESTRING_FORMAT Field

S3V4Helpers ISO8601_DATESTRING_FORMAT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ISO8601_DATESTRING_FORMAT
public const string ISO8601_DATESTRING_FORMAT
Public Const ISO8601_DATESTRING_FORMAT As String
Public Const ISO8601_DATESTRING_FORMAT As String
public:
literal String^ ISO8601_DATESTRING_FORMAT
public:
literal String^ ISO8601_DATESTRING_FORMAT
static val mutable ISO8601_DATESTRING_FORMAT: string
static val mutable ISO8601_DATESTRING_FORMAT: string

Field Value

Type: Online String
See Also
S3V4Helpers Class
S3V4Helpers Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Helpers Methods

S3V4Helpers Methods NFX Class Library

The S3V4Helpers type exposes the following members.
Methods
Name | Description
GetS3AbsoolutePath | Returns absolute path of S3 Uri
S3Bytes | Converts string into UTF8 byte array encoded representation
S3DateString | Converts DateTime into appropriate S3 date string representation
S3DateTimeString | Converts DateTime into appropriate S3 datetime string representation
ToHexString | Converts byte array into appropriate string hexadecimal representation
Back to Top
See Also
S3V4Helpers Class
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Helpers.GetS3AbsoolutePath Method

S3V4Helpers GetS3AbsoolutePath Method NFX Class Library

Returns absolute path of S3 Uri

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetS3AbsoolutePath(
    this Uri uri
)
public static string GetS3AbsoolutePath(
    this Uri uri
)
<ExtensionAttribute>
Public Shared Function GetS3AbsoolutePath (
    uri As Uri
) As String
<ExtensionAttribute>
Public Shared Function GetS3AbsoolutePath (
    uri As Uri
) As String
public:
[ExtensionAttribute]
static String^ GetS3AbsoolutePath(
    Uri^ uri
)
public:
[ExtensionAttribute]
static String^ GetS3AbsoolutePath(
    Uri^ uri
)
static member GetS3AbsoolutePath :
        uri : Uri -> string
static member GetS3AbsoolutePath :
        uri : Uri -> string

Parameters

uri
Type: Online System Uri

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Uri. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
S3V4Helpers Class
S3V4Helpers Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Helpers.S3Bytes Method

S3V4Helpers S3Bytes Method NFX Class Library

Converts string into UTF8 byte array encoded representation

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte[] S3Bytes(
    this string str
)
public static byte[] S3Bytes(
    this string str
)
<ExtensionAttribute>
Public Shared Function S3Bytes (
    str As String
) As Byte()
<ExtensionAttribute>
Public Shared Function S3Bytes (
    str As String
) As Byte()
public:
[ExtensionAttribute]
static array<unsigned char>^ S3Bytes(
    String^ str
)
public:
[ExtensionAttribute]
static array<unsigned char>^ S3Bytes(
    String^ str
)
static member S3Bytes :
        str : string -> byte[]
static member S3Bytes :
        str : string -> byte[]

Parameters

str
Type: Online System String

Return Value

Type: Online Byte

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
S3V4Helpers Class
S3V4Helpers Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Helpers.S3DateString Method

S3V4Helpers S3DateString Method NFX Class Library

Converts DateTime into appropriate S3 date string representation

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string S3DateString(
    this DateTime date
)
public static string S3DateString(
    this DateTime date
)
<ExtensionAttribute>
Public Shared Function S3DateString (
    date As DateTime
) As String
<ExtensionAttribute>
Public Shared Function S3DateString (
    date As DateTime
) As String
public:
[ExtensionAttribute]
static String^ S3DateString(
    DateTime date
)
public:
[ExtensionAttribute]
static String^ S3DateString(
    DateTime date
)
static member S3DateString :
        date : DateTime -> string
static member S3DateString :
        date : DateTime -> string

Parameters

date
Type: Online System DateTime

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
S3V4Helpers Class
S3V4Helpers Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Helpers.S3DateTimeString Method

S3V4Helpers S3DateTimeString Method NFX Class Library

Converts DateTime into appropriate S3 datetime string representation

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string S3DateTimeString(
    this DateTime date
)
public static string S3DateTimeString(
    this DateTime date
)
<ExtensionAttribute>
Public Shared Function S3DateTimeString (
    date As DateTime
) As String
<ExtensionAttribute>
Public Shared Function S3DateTimeString (
    date As DateTime
) As String
public:
[ExtensionAttribute]
static String^ S3DateTimeString(
    DateTime date
)
public:
[ExtensionAttribute]
static String^ S3DateTimeString(
    DateTime date
)
static member S3DateTimeString :
        date : DateTime -> string
static member S3DateTimeString :
        date : DateTime -> string

Parameters

date
Type: Online System DateTime

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
S3V4Helpers Class
S3V4Helpers Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Helpers.ToHexString Method

S3V4Helpers ToHexString Method NFX Class Library

Converts byte array into appropriate string hexadecimal representation

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ToHexString(
    this byte[] bytes,
    bool lowerCase = true
)
public static string ToHexString(
    this byte[] bytes,
    bool lowerCase = true
)
<ExtensionAttribute>
Public Shared Function ToHexString (
    bytes As Byte(),
    Optional lowerCase As Boolean = true
) As String
<ExtensionAttribute>
Public Shared Function ToHexString (
    bytes As Byte(),
    Optional lowerCase As Boolean = true
) As String
public:
[ExtensionAttribute]
static String^ ToHexString(
    array<unsigned char>^ bytes,
    bool lowerCase = true
)
public:
[ExtensionAttribute]
static String^ ToHexString(
    array<unsigned char>^ bytes,
    bool lowerCase = true
)
static member ToHexString :
        bytes : byte[] *
        ?lowerCase : bool
(* Defaults:
        let _lowerCase = defaultArg lowerCase true
*)
-> string
static member ToHexString :
        bytes : byte[] *
        ?lowerCase : bool
(* Defaults:
        let _lowerCase = defaultArg lowerCase true
*)
-> string

Parameters

bytes
Type: Online System Byte
lowerCase (Optional)
Type: Online System Boolean

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
S3V4Helpers Class
S3V4Helpers Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer Class

S3V4Signer Class NFX Class Library

Handles S3V4 signing routines
Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.S3.V4.S3V4Sign S3V4Signer

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class S3V4Signer
public class S3V4Signer
Public Class S3V4Signer
Public Class S3V4Signer
public ref class S3V4Signer
public ref class S3V4Signer
type S3V4Signer =  class end
type S3V4Signer =  class end
See Also
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer Members

S3V4Signer Members NFX Class Library

The S3V4Signer type exposes the following members.
Constructors
 | Name | Description
Public method | S3V4Signer | Initializes a new instance of the S3V4Signer class
Back to Top
Methods
 | Name | Description
Public method | Calculate |
Public method | ComputeHash | Calculates SHA256 hash of given string. Returns haxadecimal string representation of hash
Public method | ComputeKeyedHash | Calculates hash of data by key
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAutorization | Returns authorization header content
 | GetCanonicalRequest | Returns string representing S3V4 call in canonized form
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetScope | Returns "scope" (S3 V4 term) of given region
Public method | GetScopedSigningKey | Calculates signing key for given secret, timestamp and region
Public method | GetStringToSign | Returns string which must be signed
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
AND |
AWS4_ALGORITHM |
COLON |
EMPTY_BODY_SHA256 |
HMACSHA256 |
NEWLINE |
S3SERVICE |
SCHEME |
SEMICOLON |
SHA256 |
TERMINATOR |
X_AMZ_CONTENT_SHA256 |
X_AMZ_DATE |
Back to Top
Properties
 | Name | Description
Public property | AccessKey | Call access key
Public property | Bucket | Call bucket
Public property | ContentStream | Call content stream
Public property | Headers | Call http headers (readonly)
Public property | ItemLocalPath | Call item local path
Public property | Method | Call method (i.e. GET)
Public property | QueryParams | Call query params
Public property | Region | Call region
Public property | RequestDateTime | Call timestamp
Public property | SecretKey | Call secret key
Public property | Uri | Call Uri (readonly)
Back to Top
See Also
S3V4Signer Class
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer Constructor

S3V4Signer Constructor NFX Class Library

Initializes a new instance of the S3V4Signer class

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public S3V4Signer()
public S3V4Signer()
Public Sub New
Public Sub New
public:
S3V4Signer()
public:
S3V4Signer()
new : unit -> S3V4Signer
new : unit -> S3V4Signer
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer Fields

S3V4Signer Fields NFX Class Library

The S3V4Signer type exposes the following members.
Fields
Name | Description
AND |
AWS4_ALGORITHM |
COLON |
EMPTY_BODY_SHA256 |
HMACSHA256 |
NEWLINE |
S3SERVICE |
SCHEME |
SEMICOLON |
SHA256 |
TERMINATOR |
X_AMZ_CONTENT_SHA256 |
X_AMZ_DATE |
Back to Top
See Also
S3V4Signer Class
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.AND Field

S3V4Signer AND Field NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string AND
public const string AND
Public Const AND As String
Public Const AND As String
public:
literal String^ AND
public:
literal String^ AND
static val mutable AND: string
static val mutable AND: string

Field Value

Type: Online String
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.AWS4_ALGORITHM Field

S3V4Signer AWS4_ALGORITHM Field NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string AWS4_ALGORITHM
public const string AWS4_ALGORITHM
Public Const AWS4_ALGORITHM As String
Public Const AWS4_ALGORITHM As String
public:
literal String^ AWS4_ALGORITHM
public:
literal String^ AWS4_ALGORITHM
static val mutable AWS4_ALGORITHM: string
static val mutable AWS4_ALGORITHM: string

Field Value

Type: Online String
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.COLON Field

S3V4Signer COLON Field NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string COLON
public const string COLON
Public Const COLON As String
Public Const COLON As String
public:
literal String^ COLON
public:
literal String^ COLON
static val mutable COLON: string
static val mutable COLON: string

Field Value

Type: Online String
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.EMPTY_BODY_SHA256 Field

S3V4Signer EMPTY_BODY_SHA256 Field NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string EMPTY_BODY_SHA256
public const string EMPTY_BODY_SHA256
Public Const EMPTY_BODY_SHA256 As String
Public Const EMPTY_BODY_SHA256 As String
public:
literal String^ EMPTY_BODY_SHA256
public:
literal String^ EMPTY_BODY_SHA256
static val mutable EMPTY_BODY_SHA256: string
static val mutable EMPTY_BODY_SHA256: string

Field Value

Type: Online String
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.HMACSHA256 Field

S3V4Signer HMACSHA256 Field NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HMACSHA256
public const string HMACSHA256
Public Const HMACSHA256 As String
Public Const HMACSHA256 As String
public:
literal String^ HMACSHA256
public:
literal String^ HMACSHA256
static val mutable HMACSHA256: string
static val mutable HMACSHA256: string

Field Value

Type: Online String
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.NEWLINE Field

S3V4Signer NEWLINE Field NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string NEWLINE
public const string NEWLINE
Public Const NEWLINE As String
Public Const NEWLINE As String
public:
literal String^ NEWLINE
public:
literal String^ NEWLINE
static val mutable NEWLINE: string
static val mutable NEWLINE: string

Field Value

Type: Online String
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.S3SERVICE Field

S3V4Signer S3SERVICE Field NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string S3SERVICE
public const string S3SERVICE
Public Const S3SERVICE As String
Public Const S3SERVICE As String
public:
literal String^ S3SERVICE
public:
literal String^ S3SERVICE
static val mutable S3SERVICE: string
static val mutable S3SERVICE: string

Field Value

Type: Online String
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.SCHEME Field

S3V4Signer SCHEME Field NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SCHEME
public const string SCHEME
Public Const SCHEME As String
Public Const SCHEME As String
public:
literal String^ SCHEME
public:
literal String^ SCHEME
static val mutable SCHEME: string
static val mutable SCHEME: string

Field Value

Type: Online String
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.SEMICOLON Field

S3V4Signer SEMICOLON Field NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SEMICOLON
public const string SEMICOLON
Public Const SEMICOLON As String
Public Const SEMICOLON As String
public:
literal String^ SEMICOLON
public:
literal String^ SEMICOLON
static val mutable SEMICOLON: string
static val mutable SEMICOLON: string

Field Value

Type: Online String
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.SHA256 Field

S3V4Signer SHA256 Field NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SHA256
public const string SHA256
Public Const SHA256 As String
Public Const SHA256 As String
public:
literal String^ SHA256
public:
literal String^ SHA256
static val mutable SHA256: string
static val mutable SHA256: string

Field Value

Type: Online String
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.TERMINATOR Field

S3V4Signer TERMINATOR Field NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string TERMINATOR
public const string TERMINATOR
Public Const TERMINATOR As String
Public Const TERMINATOR As String
public:
literal String^ TERMINATOR
public:
literal String^ TERMINATOR
static val mutable TERMINATOR: string
static val mutable TERMINATOR: string

Field Value

Type: Online String
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.X_AMZ_CONTENT_SHA256 Field

S3V4Signer X_AMZ_CONTENT_SHA256 Field NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string X_AMZ_CONTENT_SHA256
public const string X_AMZ_CONTENT_SHA256
Public Const X_AMZ_CONTENT_SHA256 As String
Public Const X_AMZ_CONTENT_SHA256 As String
public:
literal String^ X_AMZ_CONTENT_SHA256
public:
literal String^ X_AMZ_CONTENT_SHA256
static val mutable X_AMZ_CONTENT_SHA256: string
static val mutable X_AMZ_CONTENT_SHA256: string

Field Value

Type: Online String
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.X_AMZ_DATE Field

S3V4Signer X_AMZ_DATE Field NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string X_AMZ_DATE
public const string X_AMZ_DATE
Public Const X_AMZ_DATE As String
Public Const X_AMZ_DATE As String
public:
literal String^ X_AMZ_DATE
public:
literal String^ X_AMZ_DATE
static val mutable X_AMZ_DATE: string
static val mutable X_AMZ_DATE: string

Field Value

Type: Online String
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer Methods

S3V4Signer Methods NFX Class Library

The S3V4Signer type exposes the following members.
Methods
 | Name | Description
Public method | Calculate |
Public method | ComputeHash | Calculates SHA256 hash of given string. Returns haxadecimal string representation of hash
Public method | ComputeKeyedHash | Calculates hash of data by key
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAutorization | Returns authorization header content
 | GetCanonicalRequest | Returns string representing S3V4 call in canonized form
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetScope | Returns "scope" (S3 V4 term) of given region
Public method | GetScopedSigningKey | Calculates signing key for given secret, timestamp and region
Public method | GetStringToSign | Returns string which must be signed
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
S3V4Signer Class
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.Calculate Method

S3V4Signer Calculate Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<string, string> Calculate()
public IDictionary<string, string> Calculate()
Public Function Calculate As IDictionary(Of String, String)
Public Function Calculate As IDictionary(Of String, String)
public:
IDictionary<String^, String^>^ Calculate()
public:
IDictionary<String^, String^>^ Calculate()
member Calculate : unit -> IDictionary<string, string>
member Calculate : unit -> IDictionary<string, string>

Return Value

Type: Online IDictionary Online String, Online String
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.ComputeHash Method

S3V4Signer ComputeHash Method NFX Class Library

Calculates SHA256 hash of given string. Returns haxadecimal string representation of hash

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ComputeHash(
    string str
)
public string ComputeHash(
    string str
)
Public Function ComputeHash (
    str As String
) As String
Public Function ComputeHash (
    str As String
) As String
public:
String^ ComputeHash(
    String^ str
)
public:
String^ ComputeHash(
    String^ str
)
member ComputeHash :
        str : string -> string
member ComputeHash :
        str : string -> string

Parameters

str
Type: Online System String

Return Value

Type: Online String
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.ComputeKeyedHash Method

S3V4Signer ComputeKeyedHash Method NFX Class Library

Calculates hash of data by key

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] ComputeKeyedHash(
    byte[] key,
    byte[] data
)
public byte[] ComputeKeyedHash(
    byte[] key,
    byte[] data
)
Public Function ComputeKeyedHash (
    key As Byte(),
    data As Byte()
) As Byte()
Public Function ComputeKeyedHash (
    key As Byte(),
    data As Byte()
) As Byte()
public:
array<unsigned char>^ ComputeKeyedHash(
    array<unsigned char>^ key,
    array<unsigned char>^ data
)
public:
array<unsigned char>^ ComputeKeyedHash(
    array<unsigned char>^ key,
    array<unsigned char>^ data
)
member ComputeKeyedHash :
        key : byte[] *
        data : byte[] -> byte[]
member ComputeKeyedHash :
        key : byte[] *
        data : byte[] -> byte[]

Parameters

key
Type: Online System Byte
data
Type: Online System Byte

Return Value

Type: Online Byte
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.GetAutorization Method

S3V4Signer GetAutorization Method NFX Class Library

Returns authorization header content

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetAutorization(
    string accessKey,
    string scope,
    string signedHeaders,
    string signature
)
public string GetAutorization(
    string accessKey,
    string scope,
    string signedHeaders,
    string signature
)
Public Function GetAutorization (
    accessKey As String,
    scope As String,
    signedHeaders As String,
    signature As String
) As String
Public Function GetAutorization (
    accessKey As String,
    scope As String,
    signedHeaders As String,
    signature As String
) As String
public:
String^ GetAutorization(
    String^ accessKey,
    String^ scope,
    String^ signedHeaders,
    String^ signature
)
public:
String^ GetAutorization(
    String^ accessKey,
    String^ scope,
    String^ signedHeaders,
    String^ signature
)
member GetAutorization :
        accessKey : string *
        scope : string *
        signedHeaders : string *
        signature : string -> string
member GetAutorization :
        accessKey : string *
        scope : string *
        signedHeaders : string *
        signature : string -> string

Parameters

accessKey
Type: Online System String
scope
Type: Online System String
signedHeaders
Type: Online System String
signature
Type: Online System String

Return Value

Type: Online String
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.GetCanonicalRequest Method

S3V4Signer GetCanonicalRequest Method NFX Class Library

Returns string representing S3V4 call in canonized form

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetCanonicalRequest(
    string method,
    Uri uri,
    IDictionary<string, string> headers,
    IDictionary<string, string> queryParameters = null,
    string hashedPayload = "e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855"
)
public static string GetCanonicalRequest(
    string method,
    Uri uri,
    IDictionary<string, string> headers,
    IDictionary<string, string> queryParameters = null,
    string hashedPayload = "e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855"
)
Public Shared Function GetCanonicalRequest (
    method As String,
    uri As Uri,
    headers As IDictionary(Of String, String),
    Optional queryParameters As IDictionary(Of String, String) = Nothing,
    Optional hashedPayload As String = "e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855"
) As String
Public Shared Function GetCanonicalRequest (
    method As String,
    uri As Uri,
    headers As IDictionary(Of String, String),
    Optional queryParameters As IDictionary(Of String, String) = Nothing,
    Optional hashedPayload As String = "e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855"
) As String
public:
static String^ GetCanonicalRequest(
    String^ method,
    Uri^ uri,
    IDictionary<String^, String^>^ headers,
    IDictionary<String^, String^>^ queryParameters = nullptr,
    String^ hashedPayload = L"e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855"
)
public:
static String^ GetCanonicalRequest(
    String^ method,
    Uri^ uri,
    IDictionary<String^, String^>^ headers,
    IDictionary<String^, String^>^ queryParameters = nullptr,
    String^ hashedPayload = L"e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855"
)
static member GetCanonicalRequest :
        method : string *
        uri : Uri *
        headers : IDictionary<string, string> *
        ?queryParameters : IDictionary<string, string> *
        ?hashedPayload : string
(* Defaults:
        let _queryParameters = defaultArg queryParameters null
        let _hashedPayload = defaultArg hashedPayload "e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855"
*)
-> string
static member GetCanonicalRequest :
        method : string *
        uri : Uri *
        headers : IDictionary<string, string> *
        ?queryParameters : IDictionary<string, string> *
        ?hashedPayload : string
(* Defaults:
        let _queryParameters = defaultArg queryParameters null
        let _hashedPayload = defaultArg hashedPayload "e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855"
*)
-> string

Parameters

method
Type: Online System String
uri
Type: Online System Uri
headers
Type: Online System.Collections.Generic IDictionary Online String, Online String
queryParameters (Optional)
Type: Online System.Collections.Generic IDictionary Online String, Online String
hashedPayload (Optional)
Type: Online System String

Return Value

Type: Online String
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.GetScope Method

S3V4Signer GetScope Method NFX Class Library

Returns "scope" (S3 V4 term) of given region

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetScope(
    DateTime date,
    string region
)
public string GetScope(
    DateTime date,
    string region
)
Public Function GetScope (
    date As DateTime,
    region As String
) As String
Public Function GetScope (
    date As DateTime,
    region As String
) As String
public:
String^ GetScope(
    DateTime date,
    String^ region
)
public:
String^ GetScope(
    DateTime date,
    String^ region
)
member GetScope :
        date : DateTime *
        region : string -> string
member GetScope :
        date : DateTime *
        region : string -> string

Parameters

date
Type: Online System DateTime
region
Type: Online System String

Return Value

Type: Online String
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.GetScopedSigningKey Method

S3V4Signer GetScopedSigningKey Method NFX Class Library

Calculates signing key for given secret, timestamp and region

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] GetScopedSigningKey(
    string secretKey,
    DateTime date,
    string region
)
public byte[] GetScopedSigningKey(
    string secretKey,
    DateTime date,
    string region
)
Public Function GetScopedSigningKey (
    secretKey As String,
    date As DateTime,
    region As String
) As Byte()
Public Function GetScopedSigningKey (
    secretKey As String,
    date As DateTime,
    region As String
) As Byte()
public:
array<unsigned char>^ GetScopedSigningKey(
    String^ secretKey,
    DateTime date,
    String^ region
)
public:
array<unsigned char>^ GetScopedSigningKey(
    String^ secretKey,
    DateTime date,
    String^ region
)
member GetScopedSigningKey :
        secretKey : string *
        date : DateTime *
        region : string -> byte[]
member GetScopedSigningKey :
        secretKey : string *
        date : DateTime *
        region : string -> byte[]

Parameters

secretKey
Type: Online System String
date
Type: Online System DateTime
region
Type: Online System String

Return Value

Type: Online Byte
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.GetStringToSign Method

S3V4Signer GetStringToSign Method NFX Class Library

Returns string which must be signed

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetStringToSign(
    DateTime date,
    string region,
    string canonicalRequestStr,
    string scope
)
public string GetStringToSign(
    DateTime date,
    string region,
    string canonicalRequestStr,
    string scope
)
Public Function GetStringToSign (
    date As DateTime,
    region As String,
    canonicalRequestStr As String,
    scope As String
) As String
Public Function GetStringToSign (
    date As DateTime,
    region As String,
    canonicalRequestStr As String,
    scope As String
) As String
public:
String^ GetStringToSign(
    DateTime date,
    String^ region,
    String^ canonicalRequestStr,
    String^ scope
)
public:
String^ GetStringToSign(
    DateTime date,
    String^ region,
    String^ canonicalRequestStr,
    String^ scope
)
member GetStringToSign :
        date : DateTime *
        region : string *
        canonicalRequestStr : string *
        scope : string -> string
member GetStringToSign :
        date : DateTime *
        region : string *
        canonicalRequestStr : string *
        scope : string -> string

Parameters

date
Type: Online System DateTime
region
Type: Online System String
canonicalRequestStr
Type: Online System String
scope
Type: Online System String

Return Value

Type: Online String
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer Properties

S3V4Signer Properties NFX Class Library

The S3V4Signer type exposes the following members.
Properties
 | Name | Description
Public property | AccessKey | Call access key
Public property | Bucket | Call bucket
Public property | ContentStream | Call content stream
Public property | Headers | Call http headers (readonly)
Public property | ItemLocalPath | Call item local path
Public property | Method | Call method (i.e. GET)
Public property | QueryParams | Call query params
Public property | Region | Call region
Public property | RequestDateTime | Call timestamp
Public property | SecretKey | Call secret key
Public property | Uri | Call Uri (readonly)
Back to Top
See Also
S3V4Signer Class
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.AccessKey Property

S3V4Signer AccessKey Property NFX Class Library

Call access key

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AccessKey { set; }
public string AccessKey { set; }
Public WriteOnly Property AccessKey As String
    Set
Public WriteOnly Property AccessKey As String
    Set
public:
property String^ AccessKey {
    void set (String^ value);
}
public:
property String^ AccessKey {
    void set (String^ value);
}
member AccessKey : string with set
member AccessKey : string with set

Property Value

Type: Online String
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.Bucket Property

S3V4Signer Bucket Property NFX Class Library

Call bucket

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Bucket { set; }
public string Bucket { set; }
Public WriteOnly Property Bucket As String
    Set
Public WriteOnly Property Bucket As String
    Set
public:
property String^ Bucket {
    void set (String^ value);
}
public:
property String^ Bucket {
    void set (String^ value);
}
member Bucket : string with set
member Bucket : string with set

Property Value

Type: Online String
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.ContentStream Property

S3V4Signer ContentStream Property NFX Class Library

Call content stream

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Stream ContentStream { set; }
public Stream ContentStream { set; }
Public WriteOnly Property ContentStream As Stream
    Set
Public WriteOnly Property ContentStream As Stream
    Set
public:
property Stream^ ContentStream {
    void set (Stream^ value);
}
public:
property Stream^ ContentStream {
    void set (Stream^ value);
}
member ContentStream : Stream with set
member ContentStream : Stream with set

Property Value

Type: Online Stream
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.Headers Property

S3V4Signer Headers Property NFX Class Library

Call http headers (readonly)

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<string, string> Headers { get; }
public IDictionary<string, string> Headers { get; }
Public ReadOnly Property Headers As IDictionary(Of String, String)
    Get
Public ReadOnly Property Headers As IDictionary(Of String, String)
    Get
public:
property IDictionary<String^, String^>^ Headers {
    IDictionary<String^, String^>^ get ();
}
public:
property IDictionary<String^, String^>^ Headers {
    IDictionary<String^, String^>^ get ();
}
member Headers : IDictionary<string, string> with get
member Headers : IDictionary<string, string> with get

Property Value

Type: Online IDictionary Online String, Online String
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.ItemLocalPath Property

S3V4Signer ItemLocalPath Property NFX Class Library

Call item local path

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ItemLocalPath { set; }
public string ItemLocalPath { set; }
Public WriteOnly Property ItemLocalPath As String
    Set
Public WriteOnly Property ItemLocalPath As String
    Set
public:
property String^ ItemLocalPath {
    void set (String^ value);
}
public:
property String^ ItemLocalPath {
    void set (String^ value);
}
member ItemLocalPath : string with set
member ItemLocalPath : string with set

Property Value

Type: Online String
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.Method Property

S3V4Signer Method Property NFX Class Library

Call method (i.e. GET)

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Method { set; }
public string Method { set; }
Public WriteOnly Property Method As String
    Set
Public WriteOnly Property Method As String
    Set
public:
property String^ Method {
    void set (String^ value);
}
public:
property String^ Method {
    void set (String^ value);
}
member Method : string with set
member Method : string with set

Property Value

Type: Online String
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.QueryParams Property

S3V4Signer QueryParams Property NFX Class Library

Call query params

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<string, string> QueryParams { set; }
public IDictionary<string, string> QueryParams { set; }
Public WriteOnly Property QueryParams As IDictionary(Of String, String)
    Set
Public WriteOnly Property QueryParams As IDictionary(Of String, String)
    Set
public:
property IDictionary<String^, String^>^ QueryParams {
    void set (IDictionary<String^, String^>^ value);
}
public:
property IDictionary<String^, String^>^ QueryParams {
    void set (IDictionary<String^, String^>^ value);
}
member QueryParams : IDictionary<string, string> with set
member QueryParams : IDictionary<string, string> with set

Property Value

Type: Online IDictionary Online String, Online String
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.Region Property

S3V4Signer Region Property NFX Class Library

Call region

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Region { set; }
public string Region { set; }
Public WriteOnly Property Region As String
    Set
Public WriteOnly Property Region As String
    Set
public:
property String^ Region {
    void set (String^ value);
}
public:
property String^ Region {
    void set (String^ value);
}
member Region : string with set
member Region : string with set

Property Value

Type: Online String
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.RequestDateTime Property

S3V4Signer RequestDateTime Property NFX Class Library

Call timestamp

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<DateTime> RequestDateTime { set; }
public Nullable<DateTime> RequestDateTime { set; }
Public WriteOnly Property RequestDateTime As Nullable(Of DateTime)
    Set
Public WriteOnly Property RequestDateTime As Nullable(Of DateTime)
    Set
public:
property Nullable<DateTime> RequestDateTime {
    void set (Nullable<DateTime> value);
}
public:
property Nullable<DateTime> RequestDateTime {
    void set (Nullable<DateTime> value);
}
member RequestDateTime : Nullable<DateTime> with set
member RequestDateTime : Nullable<DateTime> with set

Property Value

Type: Online Nullable Online DateTime
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.SecretKey Property

S3V4Signer SecretKey Property NFX Class Library

Call secret key

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SecretKey { set; }
public string SecretKey { set; }
Public WriteOnly Property SecretKey As String
    Set
Public WriteOnly Property SecretKey As String
    Set
public:
property String^ SecretKey {
    void set (String^ value);
}
public:
property String^ SecretKey {
    void set (String^ value);
}
member SecretKey : string with set
member SecretKey : string with set

Property Value

Type: Online String
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4Signer.Uri Property

S3V4Signer Uri Property NFX Class Library

Call Uri (readonly)

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Uri Uri { get; }
public Uri Uri { get; }
Public ReadOnly Property Uri As Uri
    Get
Public ReadOnly Property Uri As Uri
    Get
public:
property Uri^ Uri {
    Uri^ get ();
}
public:
property Uri^ Uri {
    Uri^ get ();
}
member Uri : Uri with get
member Uri : Uri with get

Property Value

Type: Online Uri
See Also
S3V4Signer Class
S3V4Signer Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4URLHelpers Class

S3V4URLHelpers Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.S3.V4.S3V4Sign S3V4URLHelpers

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class S3V4URLHelpers
public static class S3V4URLHelpers
<ExtensionAttribute>
Public NotInheritable Class S3V4URLHelpers
<ExtensionAttribute>
Public NotInheritable Class S3V4URLHelpers
[ExtensionAttribute]
public ref class S3V4URLHelpers abstract sealed
[ExtensionAttribute]
public ref class S3V4URLHelpers abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type S3V4URLHelpers =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type S3V4URLHelpers =  class end
See Also
S3V4URLHelpers Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4URLHelpers Members

S3V4URLHelpers Members NFX Class Library

The S3V4URLHelpers type exposes the following members.
Methods
Name | Description
CreateURI |
CreateURIString |
GetDomainURL |
GetLocalName |
GetParentURL |
Parse(String, String , String , String ) |
Parse(String, String , String , String , IDictionary String, String ) |
Parse(Uri, String , String , String , IDictionary String, String ) |
ToDirectoryPath |
Back to Top
Fields
Name | Description
US_EAST_1 |
Back to Top
See Also
S3V4URLHelpers Class
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4URLHelpers Fields

S3V4URLHelpers Fields NFX Class Library

The S3V4URLHelpers type exposes the following members.
Fields
Name | Description
US_EAST_1 |
Back to Top
See Also
S3V4URLHelpers Class
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4URLHelpers.US_EAST_1 Field

S3V4URLHelpers US_EAST_1 Field NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string US_EAST_1
public const string US_EAST_1
Public Const US_EAST_1 As String
Public Const US_EAST_1 As String
public:
literal String^ US_EAST_1
public:
literal String^ US_EAST_1
static val mutable US_EAST_1: string
static val mutable US_EAST_1: string

Field Value

Type: Online String
See Also
S3V4URLHelpers Class
S3V4URLHelpers Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4URLHelpers Methods

S3V4URLHelpers Methods NFX Class Library

The S3V4URLHelpers type exposes the following members.
Methods
Name | Description
CreateURI |
CreateURIString |
GetDomainURL |
GetLocalName |
GetParentURL |
Parse(String, String , String , String ) |
Parse(String, String , String , String , IDictionary String, String ) |
Parse(Uri, String , String , String , IDictionary String, String ) |
ToDirectoryPath |
Back to Top
See Also
S3V4URLHelpers Class
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4URLHelpers.CreateURI Method

S3V4URLHelpers CreateURI Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Uri CreateURI(
    string region = null,
    string bucketName = null,
    string itemRelativePath = null,
    IDictionary<string, string> parameters = null
)
public static Uri CreateURI(
    string region = null,
    string bucketName = null,
    string itemRelativePath = null,
    IDictionary<string, string> parameters = null
)
Public Shared Function CreateURI (
    Optional region As String = Nothing,
    Optional bucketName As String = Nothing,
    Optional itemRelativePath As String = Nothing,
    Optional parameters As IDictionary(Of String, String) = Nothing
) As Uri
Public Shared Function CreateURI (
    Optional region As String = Nothing,
    Optional bucketName As String = Nothing,
    Optional itemRelativePath As String = Nothing,
    Optional parameters As IDictionary(Of String, String) = Nothing
) As Uri
public:
static Uri^ CreateURI(
    String^ region = nullptr,
    String^ bucketName = nullptr,
    String^ itemRelativePath = nullptr,
    IDictionary<String^, String^>^ parameters = nullptr
)
public:
static Uri^ CreateURI(
    String^ region = nullptr,
    String^ bucketName = nullptr,
    String^ itemRelativePath = nullptr,
    IDictionary<String^, String^>^ parameters = nullptr
)
static member CreateURI :
        ?region : string *
        ?bucketName : string *
        ?itemRelativePath : string *
        ?parameters : IDictionary<string, string>
(* Defaults:
        let _region = defaultArg region null
        let _bucketName = defaultArg bucketName null
        let _itemRelativePath = defaultArg itemRelativePath null
        let _parameters = defaultArg parameters null
*)
-> Uri
static member CreateURI :
        ?region : string *
        ?bucketName : string *
        ?itemRelativePath : string *
        ?parameters : IDictionary<string, string>
(* Defaults:
        let _region = defaultArg region null
        let _bucketName = defaultArg bucketName null
        let _itemRelativePath = defaultArg itemRelativePath null
        let _parameters = defaultArg parameters null
*)
-> Uri

Parameters

region (Optional)
Type: Online System String
bucketName (Optional)
Type: Online System String
itemRelativePath (Optional)
Type: Online System String
parameters (Optional)
Type: Online System.Collections.Generic IDictionary Online String, Online String

Return Value

Type: Online Uri
See Also
S3V4URLHelpers Class
S3V4URLHelpers Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4URLHelpers.CreateURIString Method

S3V4URLHelpers CreateURIString Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string CreateURIString(
    string region = null,
    string bucketName = null,
    string itemRelativePath = null,
    IDictionary<string, string> parameters = null
)
public static string CreateURIString(
    string region = null,
    string bucketName = null,
    string itemRelativePath = null,
    IDictionary<string, string> parameters = null
)
Public Shared Function CreateURIString (
    Optional region As String = Nothing,
    Optional bucketName As String = Nothing,
    Optional itemRelativePath As String = Nothing,
    Optional parameters As IDictionary(Of String, String) = Nothing
) As String
Public Shared Function CreateURIString (
    Optional region As String = Nothing,
    Optional bucketName As String = Nothing,
    Optional itemRelativePath As String = Nothing,
    Optional parameters As IDictionary(Of String, String) = Nothing
) As String
public:
static String^ CreateURIString(
    String^ region = nullptr,
    String^ bucketName = nullptr,
    String^ itemRelativePath = nullptr,
    IDictionary<String^, String^>^ parameters = nullptr
)
public:
static String^ CreateURIString(
    String^ region = nullptr,
    String^ bucketName = nullptr,
    String^ itemRelativePath = nullptr,
    IDictionary<String^, String^>^ parameters = nullptr
)
static member CreateURIString :
        ?region : string *
        ?bucketName : string *
        ?itemRelativePath : string *
        ?parameters : IDictionary<string, string>
(* Defaults:
        let _region = defaultArg region null
        let _bucketName = defaultArg bucketName null
        let _itemRelativePath = defaultArg itemRelativePath null
        let _parameters = defaultArg parameters null
*)
-> string
static member CreateURIString :
        ?region : string *
        ?bucketName : string *
        ?itemRelativePath : string *
        ?parameters : IDictionary<string, string>
(* Defaults:
        let _region = defaultArg region null
        let _bucketName = defaultArg bucketName null
        let _itemRelativePath = defaultArg itemRelativePath null
        let _parameters = defaultArg parameters null
*)
-> string

Parameters

region (Optional)
Type: Online System String
bucketName (Optional)
Type: Online System String
itemRelativePath (Optional)
Type: Online System String
parameters (Optional)
Type: Online System.Collections.Generic IDictionary Online String, Online String

Return Value

Type: Online String
See Also
S3V4URLHelpers Class
S3V4URLHelpers Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4URLHelpers.GetDomainURL Method

S3V4URLHelpers GetDomainURL Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetDomainURL(
    this Uri uri
)
public static string GetDomainURL(
    this Uri uri
)
<ExtensionAttribute>
Public Shared Function GetDomainURL (
    uri As Uri
) As String
<ExtensionAttribute>
Public Shared Function GetDomainURL (
    uri As Uri
) As String
public:
[ExtensionAttribute]
static String^ GetDomainURL(
    Uri^ uri
)
public:
[ExtensionAttribute]
static String^ GetDomainURL(
    Uri^ uri
)
static member GetDomainURL :
        uri : Uri -> string
static member GetDomainURL :
        uri : Uri -> string

Parameters

uri
Type: Online System Uri

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Uri. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
S3V4URLHelpers Class
S3V4URLHelpers Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4URLHelpers.GetLocalName Method

S3V4URLHelpers GetLocalName Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetLocalName(
    this Uri uri
)
public static string GetLocalName(
    this Uri uri
)
<ExtensionAttribute>
Public Shared Function GetLocalName (
    uri As Uri
) As String
<ExtensionAttribute>
Public Shared Function GetLocalName (
    uri As Uri
) As String
public:
[ExtensionAttribute]
static String^ GetLocalName(
    Uri^ uri
)
public:
[ExtensionAttribute]
static String^ GetLocalName(
    Uri^ uri
)
static member GetLocalName :
        uri : Uri -> string
static member GetLocalName :
        uri : Uri -> string

Parameters

uri
Type: Online System Uri

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Uri. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
S3V4URLHelpers Class
S3V4URLHelpers Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4URLHelpers.GetParentURL Method

S3V4URLHelpers GetParentURL Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetParentURL(
    this Uri uri
)
public static string GetParentURL(
    this Uri uri
)
<ExtensionAttribute>
Public Shared Function GetParentURL (
    uri As Uri
) As String
<ExtensionAttribute>
Public Shared Function GetParentURL (
    uri As Uri
) As String
public:
[ExtensionAttribute]
static String^ GetParentURL(
    Uri^ uri
)
public:
[ExtensionAttribute]
static String^ GetParentURL(
    Uri^ uri
)
static member GetParentURL :
        uri : Uri -> string
static member GetParentURL :
        uri : Uri -> string

Parameters

uri
Type: Online System Uri

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Uri. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
S3V4URLHelpers Class
S3V4URLHelpers Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4URLHelpers.Parse Method

S3V4URLHelpers Parse Method NFX Class Library

Overload List
Name | Description
Parse(String, String , String , String ) |
Parse(String, String , String , String , IDictionary String, String ) |
Parse(Uri, String , String , String , IDictionary String, String ) |
Back to Top
See Also
S3V4URLHelpers Class
S3V4URLHelpers Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4URLHelpers.Parse Method (String, String, String, String)

S3V4URLHelpers Parse Method (String, String , String , String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Parse(
    string path,
    out string bucket,
    out string region,
    out string itemLocalPath
)
public static void Parse(
    string path,
    out string bucket,
    out string region,
    out string itemLocalPath
)
Public Shared Sub Parse (
    path As String,
    <OutAttribute> ByRef bucket As String,
    <OutAttribute> ByRef region As String,
    <OutAttribute> ByRef itemLocalPath As String
)
Public Shared Sub Parse (
    path As String,
    <OutAttribute> ByRef bucket As String,
    <OutAttribute> ByRef region As String,
    <OutAttribute> ByRef itemLocalPath As String
)
public:
static void Parse(
    String^ path,
    [OutAttribute] String^% bucket,
    [OutAttribute] String^% region,
    [OutAttribute] String^% itemLocalPath
)
public:
static void Parse(
    String^ path,
    [OutAttribute] String^% bucket,
    [OutAttribute] String^% region,
    [OutAttribute] String^% itemLocalPath
)
static member Parse :
        path : string *
        bucket : string byref *
        region : string byref *
        itemLocalPath : string byref -> unit
static member Parse :
        path : string *
        bucket : string byref *
        region : string byref *
        itemLocalPath : string byref -> unit

Parameters

path
Type: Online System String
bucket
Type: Online System String
region
Type: Online System String
itemLocalPath
Type: Online System String
See Also
S3V4URLHelpers Class
S3V4URLHelpers Members
Parse Overload
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4URLHelpers.Parse Method (String, String, String, String, IDictionary(String, String))

S3V4URLHelpers Parse Method (String, String , String , String , IDictionary String, String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Parse(
    string path,
    out string bucket,
    out string region,
    out string itemLocalPath,
    out IDictionary<string, string> queryParams
)
public static void Parse(
    string path,
    out string bucket,
    out string region,
    out string itemLocalPath,
    out IDictionary<string, string> queryParams
)
Public Shared Sub Parse (
    path As String,
    <OutAttribute> ByRef bucket As String,
    <OutAttribute> ByRef region As String,
    <OutAttribute> ByRef itemLocalPath As String,
    <OutAttribute> ByRef queryParams As IDictionary(Of String, String)
)
Public Shared Sub Parse (
    path As String,
    <OutAttribute> ByRef bucket As String,
    <OutAttribute> ByRef region As String,
    <OutAttribute> ByRef itemLocalPath As String,
    <OutAttribute> ByRef queryParams As IDictionary(Of String, String)
)
public:
static void Parse(
    String^ path,
    [OutAttribute] String^% bucket,
    [OutAttribute] String^% region,
    [OutAttribute] String^% itemLocalPath,
    [OutAttribute] IDictionary<String^, String^>^% queryParams
)
public:
static void Parse(
    String^ path,
    [OutAttribute] String^% bucket,
    [OutAttribute] String^% region,
    [OutAttribute] String^% itemLocalPath,
    [OutAttribute] IDictionary<String^, String^>^% queryParams
)
static member Parse :
        path : string *
        bucket : string byref *
        region : string byref *
        itemLocalPath : string byref *
        queryParams : IDictionary<string, string> byref -> unit
static member Parse :
        path : string *
        bucket : string byref *
        region : string byref *
        itemLocalPath : string byref *
        queryParams : IDictionary<string, string> byref -> unit

Parameters

path
Type: Online System String
bucket
Type: Online System String
region
Type: Online System String
itemLocalPath
Type: Online System String
queryParams
Type: Online System.Collections.Generic IDictionary Online String, Online String
See Also
S3V4URLHelpers Class
S3V4URLHelpers Members
Parse Overload
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4URLHelpers.Parse Method (Uri, String, String, String, IDictionary(String, String))

S3V4URLHelpers Parse Method (Uri, String , String , String , IDictionary String, String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Parse(
    Uri uri,
    out string bucket,
    out string region,
    out string itemLocalPath,
    out IDictionary<string, string> queryParams
)
public static void Parse(
    Uri uri,
    out string bucket,
    out string region,
    out string itemLocalPath,
    out IDictionary<string, string> queryParams
)
Public Shared Sub Parse (
    uri As Uri,
    <OutAttribute> ByRef bucket As String,
    <OutAttribute> ByRef region As String,
    <OutAttribute> ByRef itemLocalPath As String,
    <OutAttribute> ByRef queryParams As IDictionary(Of String, String)
)
Public Shared Sub Parse (
    uri As Uri,
    <OutAttribute> ByRef bucket As String,
    <OutAttribute> ByRef region As String,
    <OutAttribute> ByRef itemLocalPath As String,
    <OutAttribute> ByRef queryParams As IDictionary(Of String, String)
)
public:
static void Parse(
    Uri^ uri,
    [OutAttribute] String^% bucket,
    [OutAttribute] String^% region,
    [OutAttribute] String^% itemLocalPath,
    [OutAttribute] IDictionary<String^, String^>^% queryParams
)
public:
static void Parse(
    Uri^ uri,
    [OutAttribute] String^% bucket,
    [OutAttribute] String^% region,
    [OutAttribute] String^% itemLocalPath,
    [OutAttribute] IDictionary<String^, String^>^% queryParams
)
static member Parse :
        uri : Uri *
        bucket : string byref *
        region : string byref *
        itemLocalPath : string byref *
        queryParams : IDictionary<string, string> byref -> unit
static member Parse :
        uri : Uri *
        bucket : string byref *
        region : string byref *
        itemLocalPath : string byref *
        queryParams : IDictionary<string, string> byref -> unit

Parameters

uri
Type: Online System Uri
bucket
Type: Online System String
region
Type: Online System String
itemLocalPath
Type: Online System String
queryParams
Type: Online System.Collections.Generic IDictionary Online String, Online String
See Also
S3V4URLHelpers Class
S3V4URLHelpers Members
Parse Overload
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


S3V4URLHelpers.ToDirectoryPath Method

S3V4URLHelpers ToDirectoryPath Method NFX Class Library

Namespace: NFX.IO.FileSystem.S3.V4.S3V4Sign
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ToDirectoryPath(
    this string itemLocalPath
)
public static string ToDirectoryPath(
    this string itemLocalPath
)
<ExtensionAttribute>
Public Shared Function ToDirectoryPath (
    itemLocalPath As String
) As String
<ExtensionAttribute>
Public Shared Function ToDirectoryPath (
    itemLocalPath As String
) As String
public:
[ExtensionAttribute]
static String^ ToDirectoryPath(
    String^ itemLocalPath
)
public:
[ExtensionAttribute]
static String^ ToDirectoryPath(
    String^ itemLocalPath
)
static member ToDirectoryPath :
        itemLocalPath : string -> string
static member ToDirectoryPath :
        itemLocalPath : string -> string

Parameters

itemLocalPath
Type: Online System String

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
S3V4URLHelpers Class
S3V4URLHelpers Members
NFX.IO.FileSystem.S3.V4.S3V4Sign Namespace


NFX.IO.FileSystem.SVN Namespace

NFX.IO.FileSystem.SVN Namespace NFX Class Library

Classes
 | Class | Description
Public class | SVNFileSystem | Implements FileSystem for SVN. WebDAV protocol is used so reading methods only are implemented
Public class | SVNFileSystem SVNFSH |
Public class | SVNFileSystemCapabilities |
Public class | SVNFileSystemSession | Provides SVN file system connection session
Public class | SVNFileSystemSessionConnectParams | Provides connection parameters specific to SVNFIleSystemSession
Public class | SVNFileSystemStream |
Public class | WebDAV | Facilitates read-only tasks with WebDAV compliant SVN server. This class is NOT thread-safe
Public class | WebDAV Directory | Represents a directory in remote Dav catalog
Public class | WebDAV File | Represents a file in the remote Dav catalog
Public class | WebDAV Item | General ancestor for items in remote Dav catalog, such as files and directories
Public class | WebDAV Version | Represents a version of items in the remote Dav catalog


SVNFileSystem Class

SVNFileSystem Class NFX Class Library

Implements FileSystem for SVN. WebDAV protocol is used so reading methods only are implemented
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.IO.FileSystem FileSystem
NFX.IO.FileSystem.SVN SVNFileSystem

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SVNFileSystem : FileSystem
public class SVNFileSystem : FileSystem
Public Class SVNFileSystem
    Inherits FileSystem
Public Class SVNFileSystem
    Inherits FileSystem
public ref class SVNFileSystem : public FileSystem
public ref class SVNFileSystem : public FileSystem
type SVNFileSystem =
    class
        inherit FileSystem
    end
type SVNFileSystem =
    class
        inherit FileSystem
    end
See Also
SVNFileSystem Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem Members

SVNFileSystem Members NFX Class Library

The SVNFileSystem type exposes the following members.
Constructors
 | Name | Description
Public method | SVNFileSystem | Initializes a new instance of the SVNFileSystem class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | CombinePaths | Combines two or more path segments joining them using primary file system path separator. This method is thread-safe (Inherited from FileSystem.)
Public method | Configure | Configures file system. This method is a part of lifecycle management and is intended to be called only by creating thread (not thread-safe) (Inherited from FileSystem.)
Protected method | Destructor | (Inherited from FileSystem.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoBeginTransaction | Override in particular file systems that support transactions to begin transaction in specified session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoBeginTransactionAsync | Async version of DoBeginTransaction(FileSystemSession). This base/default implementation just synchronously calls DoBeginTransaction(FileSystemSession) and returns already completed Task with result returned by DoBeginTransaction(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoCheckCanChange | Override in particular file systems to see if item can change, i.e. for file systems that support versioning throw exception if item is in session which "looks" at a sealed/closed version and can not change. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoCheckCanChangeAsync | Async version of DoCheckCanChange(FileSystemSessionItem). This base/default implementation just synchronously calls DoCheckCanChange(FileSystemSessionItem) and returns already completed Task with result returned by DoCheckCanChange(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoCommitTransaction | Override in particular file systems that support transactions to commit transaction in specified session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoCommitTransactionAsync | Async version of DoCommitTransaction(FileSystemSession). This base/default implementation just synchronously calls DoCommitTransaction(FileSystemSession) and returns already completed Task with result returned by DoCommitTransaction(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoConfigure | Override to perform custom configuration (Inherited from FileSystem.)
Protected method | DoCreateDirectory | (Overrides FileSystem DoCreateDirectory(FileSystemDirectory, String).)
Protected method | DoCreateDirectoryAsync | Async version of DoCreateDirectory(FileSystemDirectory, String). This base/default implementation just synchronously calls DoCreateDirectory(FileSystemDirectory, String) and returns already completed Task with result returned by DoCreateDirectory(FileSystemDirectory, String) (Inherited from FileSystem.)
Protected method | DoCreateFile(FileSystemDirectory, String, Int32) | (Overrides FileSystem DoCreateFile(FileSystemDirectory, String, Int32).)
Protected method | DoCreateFile(FileSystemDirectory, String, String, Boolean) | (Overrides FileSystem DoCreateFile(FileSystemDirectory, String, String, Boolean).)
Protected method | DoCreateFileAsync(FileSystemDirectory, String, Int32) | Async version of DoCreateFile(FileSystemDirectory, String, Int32). This base/default implementation just synchronously calls DoCreateFile(FileSystemDirectory, String, Int32) and returns already completed Task with result returned by DoCreateFile(FileSystemDirectory, String, Int32) (Inherited from FileSystem.)
Protected method | DoCreateFileAsync(FileSystemDirectory, String, String, Boolean) | Async version of DoCreateFile(FileSystemDirectory, String, String, Boolean). This base/default implementation just synchronously calls DoCreateFile(FileSystemDirectory, String, String, Boolean) and returns already completed Task with result returned by DoCreateFile(FileSystemDirectory, String, String, Boolean) (Inherited from FileSystem.)
Protected method | DoDeleteItem | (Overrides FileSystem DoDeleteItem(FileSystemSessionItem).)
Protected method | DoDeleteItemAsync | Async version of DoDeleteItem(FileSystemSessionItem). This base/default implementation just synchronously calls DoDeleteItem(FileSystemSessionItem) and returns already completed Task with result returned by DoDeleteItem(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoDirectoryDeepCopyAsync | Implements asynchronous deep copy of folders where destination folder may belong to a different file system. The specifics of implementation may be dictated by particular file systems, i.e.: asynchronous strategies for getting file lists may depend on the particular system. (Inherited from FileSystem.)
Protected method | DoFlushAsync | (Inherited from FileSystem.)
Protected method | DoGetCreationTimestamp | (Overrides FileSystem DoGetCreationTimestamp(FileSystemSessionItem).)
Protected method | DoGetCreationUser | Override in particular file systems to get user who created item. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetCreationUserAsync | Async version of DoGetCreationUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetCreationUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetCreationUser(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetFileNames | (Overrides FileSystem DoGetFileNames(FileSystemDirectory, Boolean).)
Protected method | DoGetFileNamesAsync | Async version of DoGetFileNames(FileSystemDirectory, Boolean). This base/default implementation just synchronously calls DoGetFileNames(FileSystemDirectory, Boolean) and returns already completed Task with result returned by DoGetFileNames(FileSystemDirectory, Boolean) (Inherited from FileSystem.)
Protected method | DoGetFileStream | (Overrides FileSystem DoGetFileStream(FileSystemFile, Action FileSystemStream ).)
Protected method | DoGetFileStreamAsync | Async version of DoGetFileStream(FileSystemFile, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetFileStream(FileSystemFile, Action FileSystemStream ) and returns already completed Task with result returned by DoGetFileStream(FileSystemFile, Action FileSystemStream ) (Inherited from FileSystem.)
Protected method | DoGetItemSize | (Overrides FileSystem DoGetItemSize(FileSystemSessionItem).)
Protected method | DoGetItemSizeAsync | Async version of DoGetItemSize(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetItemSize(FileSystemSessionItem) and returns already completed Task with result returned by DoGetItemSize(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetLastAccessTimestamp | (Overrides FileSystem DoGetLastAccessTimestamp(FileSystemSessionItem).)
Protected method | DoGetLastAccessUser | Override in particular file systems to get user who was the last user accessing the item. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetLastAccessUserAsync | Async version of DoGetLastAccessUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetLastAccessUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetLastAccessUser(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetLatestVersion | Override in particular file systems that support versioning to get latest version object that this session can work with. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetLatestVersionAsync | Async version of DoGetLatestVersion(FileSystemSession). This base/default implementation just synchronously calls DoGetLatestVersion(FileSystemSession) and returns already completed Task with result returned by DoGetLatestVersion(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoGetMetadataStream | (Overrides FileSystem DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ).)
Protected method | DoGetMetadataStreamAsync | Async version of DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ) and returns already completed Task with result returned by DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ) (Inherited from FileSystem.)
Protected method | DoGetModificationTimestamp | (Overrides FileSystem DoGetModificationTimestamp(FileSystemSessionItem).)
Protected method | DoGetModificationUser | Override in particular file systems to get user who was the last user modifying the item. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetModificationUserAsync | Async version of DoGetModificationUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetModificationUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetModificationUser(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetPermissionsStream | (Overrides FileSystem DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ).)
Protected method | DoGetPermissionsStreamAsync | Async version of DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ) and returns already completed Task with result returned by DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ) (Inherited from FileSystem.)
Protected method | DoGetReadOnly | (Overrides FileSystem DoGetReadOnly(FileSystemSessionItem).)
Protected method | DoGetSubDirectoryNames | (Overrides FileSystem DoGetSubDirectoryNames(FileSystemDirectory, Boolean).)
Protected method | DoGetSubDirectoryNamesAsync | Async version of DoGetSubDirectoryNames(FileSystemDirectory, Boolean). This base/default implementation just synchronously calls DoGetSubDirectoryNames(FileSystemDirectory, Boolean) and returns already completed Task with result returned by DoGetSubDirectoryNames(FileSystemDirectory, Boolean) (Inherited from FileSystem.)
Protected method | DoGetVersion | Override in particular file systems that support versioning to get version object for session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetVersionAsync | Async version of DoGetVersion(FileSystemSession). This base/default implementation just synchronously calls DoGetVersion(FileSystemSession) and returns already completed Task with result returned by DoGetVersion(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoNavigate | (Overrides FileSystem DoNavigate(FileSystemSession, String).)
Protected method | DoNavigateAsync | Async version of DoNavigate(FileSystemSession, String). This base/default implementation just synchronously calls DoNavigate(FileSystemSession, String) and returns already completed Task with result returned by DoNavigate(FileSystemSession, String) (Inherited from FileSystem.)
Protected method | DoReadAsync | (Inherited from FileSystem.)
Protected method | DoRefresh | Override to refresh item state, i.e. re-fetch remote information. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoRefreshAsync | Async version of DoRefreshAsync(FileSystemSessionItem). This base/default implementation just synchronously calls DoRefreshAsync(FileSystemSessionItem) and returns already completed Task with result returned by DoRefreshAsync(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoRenameItem | (Overrides FileSystem DoRenameItem(FileSystemSessionItem, String).)
Protected method | DoRenameItemAsync | Async version of DoRenameItem(FileSystemSessionItem, String). This base/default implementation just synchronously calls DoRenameItem(FileSystemSessionItem, String) and returns already completed Task with result returned by DoRenameItem(FileSystemSessionItem, String) (Inherited from FileSystem.)
Protected method | DoRollbackTransaction | Override in particular file systems that support transactions to rollback transaction in specified session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoRollbackTransactionAsync | Async version of DoRollbackTransaction(FileSystemSession). This base/default implementation just synchronously calls DoRollbackTransaction(FileSystemSession) and returns already completed Task with result returned by DoRollbackTransaction(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoSetCreationTimestamp | (Overrides FileSystem DoSetCreationTimestamp(FileSystemSessionItem, DateTime).)
Protected method | DoSetCreationTimestampAsync | Async version of DoSetCreationTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetCreationTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetCreationTimestamp(FileSystemSessionItem, DateTime) (Inherited from FileSystem.)
Protected method | DoSetLastAccessTimestamp | (Overrides FileSystem DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime).)
Protected method | DoSetLastAccessTimestampAsync | Async version of DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime) (Inherited from FileSystem.)
Protected method | DoSetModificationTimestamp | (Overrides FileSystem DoSetModificationTimestamp(FileSystemSessionItem, DateTime).)
Protected method | DoSetModificationTimestampAsync | Async version of DoSetModificationTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetModificationTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetModificationTimestamp(FileSystemSessionItem, DateTime) (Inherited from FileSystem.)
Protected method | DoSetReadOnly | (Overrides FileSystem DoSetReadOnly(FileSystemSessionItem, Boolean).)
Protected method | DoSetReadOnlyAsync | Async version of DoSetReadOnly(FileSystemSessionItem, Boolean). This base/default implementation just synchronously calls DoSetReadOnly(FileSystemSessionItem, Boolean) and returns already completed Task with result returned by DoSetReadOnly(FileSystemSessionItem, Boolean) (Inherited from FileSystem.)
Protected method | DoSetVersion | Override in particular file systems that support versioning to set seesion to specific version. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoSetVersionAsync | Async version of DoSetVersion(FileSystemSession, IFileSystemVersion). This base/default implementation just synchronously calls DoSetVersion(FileSystemSession, IFileSystemVersion) and returns already completed Task with result returned by DoSetVersion(FileSystemSession, IFileSystemVersion) (Inherited from FileSystem.)
Protected method | DoWriteAsync | (Inherited from FileSystem.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeSessionConfigParams | (Overrides FileSystem MakeSessionConfigParams(IConfigSectionNode).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | StartSession(FileSystemSessionConnectParams) | (Overrides FileSystem StartSession(FileSystemSessionConnectParams).)
Public method | StartSession(SVNFileSystemSessionConnectParams) |
Public method | ToString | (Inherited from FileSystem.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Name | (Inherited from FileSystem.)
Protected field | m_Sessions | (Inherited from FileSystem.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | (Overrides ApplicationComponent ComponentCommonName.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Protected property | DefaultSessionConnectParams | (Inherited from FileSystem.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | GeneralCapabilities | (Overrides FileSystem GeneralCapabilities.)
Public property | InstanceCapabilities | (Overrides FileSystem InstanceCapabilities.)
Public property | Name | Provides name for file system instance (Inherited from FileSystem.)
Public property | Sessions | Returns a list of sessions. This accessor is thread-safe (Inherited from FileSystem.)
Back to Top
See Also
SVNFileSystem Class
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem Constructor

SVNFileSystem Constructor NFX Class Library

Initializes a new instance of the SVNFileSystem class

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SVNFileSystem(
    string name,
    IConfigSectionNode node = null
)
public SVNFileSystem(
    string name,
    IConfigSectionNode node = null
)
Public Sub New (
    name As String,
    Optional node As IConfigSectionNode = Nothing
)
Public Sub New (
    name As String,
    Optional node As IConfigSectionNode = Nothing
)
public:
SVNFileSystem(
    String^ name,
    IConfigSectionNode^ node = nullptr
)
public:
SVNFileSystem(
    String^ name,
    IConfigSectionNode^ node = nullptr
)
new :
        name : string *
        ?node : IConfigSectionNode
(* Defaults:
        let _node = defaultArg node null
*)
-> SVNFileSystem
new :
        name : string *
        ?node : IConfigSectionNode
(* Defaults:
        let _node = defaultArg node null
*)
-> SVNFileSystem

Parameters

name
Type: Online System String
node (Optional)
Type: NFX.Environment IConfigSectionNode
See Also
SVNFileSystem Class
SVNFileSystem Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem Fields

SVNFileSystem Fields NFX Class Library

The SVNFileSystem type exposes the following members.
Fields
 | Name | Description
Protected field | m_Name | (Inherited from FileSystem.)
Protected field | m_Sessions | (Inherited from FileSystem.)
Back to Top
See Also
SVNFileSystem Class
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem Methods

SVNFileSystem Methods NFX Class Library

The SVNFileSystem type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | CombinePaths | Combines two or more path segments joining them using primary file system path separator. This method is thread-safe (Inherited from FileSystem.)
Public method | Configure | Configures file system. This method is a part of lifecycle management and is intended to be called only by creating thread (not thread-safe) (Inherited from FileSystem.)
Protected method | Destructor | (Inherited from FileSystem.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoBeginTransaction | Override in particular file systems that support transactions to begin transaction in specified session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoBeginTransactionAsync | Async version of DoBeginTransaction(FileSystemSession). This base/default implementation just synchronously calls DoBeginTransaction(FileSystemSession) and returns already completed Task with result returned by DoBeginTransaction(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoCheckCanChange | Override in particular file systems to see if item can change, i.e. for file systems that support versioning throw exception if item is in session which "looks" at a sealed/closed version and can not change. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoCheckCanChangeAsync | Async version of DoCheckCanChange(FileSystemSessionItem). This base/default implementation just synchronously calls DoCheckCanChange(FileSystemSessionItem) and returns already completed Task with result returned by DoCheckCanChange(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoCommitTransaction | Override in particular file systems that support transactions to commit transaction in specified session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoCommitTransactionAsync | Async version of DoCommitTransaction(FileSystemSession). This base/default implementation just synchronously calls DoCommitTransaction(FileSystemSession) and returns already completed Task with result returned by DoCommitTransaction(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoConfigure | Override to perform custom configuration (Inherited from FileSystem.)
Protected method | DoCreateDirectory | (Overrides FileSystem DoCreateDirectory(FileSystemDirectory, String).)
Protected method | DoCreateDirectoryAsync | Async version of DoCreateDirectory(FileSystemDirectory, String). This base/default implementation just synchronously calls DoCreateDirectory(FileSystemDirectory, String) and returns already completed Task with result returned by DoCreateDirectory(FileSystemDirectory, String) (Inherited from FileSystem.)
Protected method | DoCreateFile(FileSystemDirectory, String, Int32) | (Overrides FileSystem DoCreateFile(FileSystemDirectory, String, Int32).)
Protected method | DoCreateFile(FileSystemDirectory, String, String, Boolean) | (Overrides FileSystem DoCreateFile(FileSystemDirectory, String, String, Boolean).)
Protected method | DoCreateFileAsync(FileSystemDirectory, String, Int32) | Async version of DoCreateFile(FileSystemDirectory, String, Int32). This base/default implementation just synchronously calls DoCreateFile(FileSystemDirectory, String, Int32) and returns already completed Task with result returned by DoCreateFile(FileSystemDirectory, String, Int32) (Inherited from FileSystem.)
Protected method | DoCreateFileAsync(FileSystemDirectory, String, String, Boolean) | Async version of DoCreateFile(FileSystemDirectory, String, String, Boolean). This base/default implementation just synchronously calls DoCreateFile(FileSystemDirectory, String, String, Boolean) and returns already completed Task with result returned by DoCreateFile(FileSystemDirectory, String, String, Boolean) (Inherited from FileSystem.)
Protected method | DoDeleteItem | (Overrides FileSystem DoDeleteItem(FileSystemSessionItem).)
Protected method | DoDeleteItemAsync | Async version of DoDeleteItem(FileSystemSessionItem). This base/default implementation just synchronously calls DoDeleteItem(FileSystemSessionItem) and returns already completed Task with result returned by DoDeleteItem(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoDirectoryDeepCopyAsync | Implements asynchronous deep copy of folders where destination folder may belong to a different file system. The specifics of implementation may be dictated by particular file systems, i.e.: asynchronous strategies for getting file lists may depend on the particular system. (Inherited from FileSystem.)
Protected method | DoFlushAsync | (Inherited from FileSystem.)
Protected method | DoGetCreationTimestamp | (Overrides FileSystem DoGetCreationTimestamp(FileSystemSessionItem).)
Protected method | DoGetCreationUser | Override in particular file systems to get user who created item. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetCreationUserAsync | Async version of DoGetCreationUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetCreationUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetCreationUser(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetFileNames | (Overrides FileSystem DoGetFileNames(FileSystemDirectory, Boolean).)
Protected method | DoGetFileNamesAsync | Async version of DoGetFileNames(FileSystemDirectory, Boolean). This base/default implementation just synchronously calls DoGetFileNames(FileSystemDirectory, Boolean) and returns already completed Task with result returned by DoGetFileNames(FileSystemDirectory, Boolean) (Inherited from FileSystem.)
Protected method | DoGetFileStream | (Overrides FileSystem DoGetFileStream(FileSystemFile, Action FileSystemStream ).)
Protected method | DoGetFileStreamAsync | Async version of DoGetFileStream(FileSystemFile, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetFileStream(FileSystemFile, Action FileSystemStream ) and returns already completed Task with result returned by DoGetFileStream(FileSystemFile, Action FileSystemStream ) (Inherited from FileSystem.)
Protected method | DoGetItemSize | (Overrides FileSystem DoGetItemSize(FileSystemSessionItem).)
Protected method | DoGetItemSizeAsync | Async version of DoGetItemSize(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetItemSize(FileSystemSessionItem) and returns already completed Task with result returned by DoGetItemSize(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetLastAccessTimestamp | (Overrides FileSystem DoGetLastAccessTimestamp(FileSystemSessionItem).)
Protected method | DoGetLastAccessUser | Override in particular file systems to get user who was the last user accessing the item. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetLastAccessUserAsync | Async version of DoGetLastAccessUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetLastAccessUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetLastAccessUser(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetLatestVersion | Override in particular file systems that support versioning to get latest version object that this session can work with. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetLatestVersionAsync | Async version of DoGetLatestVersion(FileSystemSession). This base/default implementation just synchronously calls DoGetLatestVersion(FileSystemSession) and returns already completed Task with result returned by DoGetLatestVersion(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoGetMetadataStream | (Overrides FileSystem DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ).)
Protected method | DoGetMetadataStreamAsync | Async version of DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ) and returns already completed Task with result returned by DoGetMetadataStream(FileSystemSessionItem, Action FileSystemStream ) (Inherited from FileSystem.)
Protected method | DoGetModificationTimestamp | (Overrides FileSystem DoGetModificationTimestamp(FileSystemSessionItem).)
Protected method | DoGetModificationUser | Override in particular file systems to get user who was the last user modifying the item. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetModificationUserAsync | Async version of DoGetModificationUser(FileSystemSessionItem). This base/default implementation just synchronously calls DoGetModificationUser(FileSystemSessionItem) and returns already completed Task with result returned by DoGetModificationUser(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoGetPermissionsStream | (Overrides FileSystem DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ).)
Protected method | DoGetPermissionsStreamAsync | Async version of DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ). This base/default implementation just synchronously calls DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ) and returns already completed Task with result returned by DoGetPermissionsStream(FileSystemSessionItem, Action FileSystemStream ) (Inherited from FileSystem.)
Protected method | DoGetReadOnly | (Overrides FileSystem DoGetReadOnly(FileSystemSessionItem).)
Protected method | DoGetSubDirectoryNames | (Overrides FileSystem DoGetSubDirectoryNames(FileSystemDirectory, Boolean).)
Protected method | DoGetSubDirectoryNamesAsync | Async version of DoGetSubDirectoryNames(FileSystemDirectory, Boolean). This base/default implementation just synchronously calls DoGetSubDirectoryNames(FileSystemDirectory, Boolean) and returns already completed Task with result returned by DoGetSubDirectoryNames(FileSystemDirectory, Boolean) (Inherited from FileSystem.)
Protected method | DoGetVersion | Override in particular file systems that support versioning to get version object for session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoGetVersionAsync | Async version of DoGetVersion(FileSystemSession). This base/default implementation just synchronously calls DoGetVersion(FileSystemSession) and returns already completed Task with result returned by DoGetVersion(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoNavigate | (Overrides FileSystem DoNavigate(FileSystemSession, String).)
Protected method | DoNavigateAsync | Async version of DoNavigate(FileSystemSession, String). This base/default implementation just synchronously calls DoNavigate(FileSystemSession, String) and returns already completed Task with result returned by DoNavigate(FileSystemSession, String) (Inherited from FileSystem.)
Protected method | DoReadAsync | (Inherited from FileSystem.)
Protected method | DoRefresh | Override to refresh item state, i.e. re-fetch remote information. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoRefreshAsync | Async version of DoRefreshAsync(FileSystemSessionItem). This base/default implementation just synchronously calls DoRefreshAsync(FileSystemSessionItem) and returns already completed Task with result returned by DoRefreshAsync(FileSystemSessionItem) (Inherited from FileSystem.)
Protected method | DoRenameItem | (Overrides FileSystem DoRenameItem(FileSystemSessionItem, String).)
Protected method | DoRenameItemAsync | Async version of DoRenameItem(FileSystemSessionItem, String). This base/default implementation just synchronously calls DoRenameItem(FileSystemSessionItem, String) and returns already completed Task with result returned by DoRenameItem(FileSystemSessionItem, String) (Inherited from FileSystem.)
Protected method | DoRollbackTransaction | Override in particular file systems that support transactions to rollback transaction in specified session. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoRollbackTransactionAsync | Async version of DoRollbackTransaction(FileSystemSession). This base/default implementation just synchronously calls DoRollbackTransaction(FileSystemSession) and returns already completed Task with result returned by DoRollbackTransaction(FileSystemSession) (Inherited from FileSystem.)
Protected method | DoSetCreationTimestamp | (Overrides FileSystem DoSetCreationTimestamp(FileSystemSessionItem, DateTime).)
Protected method | DoSetCreationTimestampAsync | Async version of DoSetCreationTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetCreationTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetCreationTimestamp(FileSystemSessionItem, DateTime) (Inherited from FileSystem.)
Protected method | DoSetLastAccessTimestamp | (Overrides FileSystem DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime).)
Protected method | DoSetLastAccessTimestampAsync | Async version of DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetLastAccessTimestamp(FileSystemSessionItem, DateTime) (Inherited from FileSystem.)
Protected method | DoSetModificationTimestamp | (Overrides FileSystem DoSetModificationTimestamp(FileSystemSessionItem, DateTime).)
Protected method | DoSetModificationTimestampAsync | Async version of DoSetModificationTimestamp(FileSystemSessionItem, DateTime). This base/default implementation just synchronously calls DoSetModificationTimestamp(FileSystemSessionItem, DateTime) and returns already completed Task with result returned by DoSetModificationTimestamp(FileSystemSessionItem, DateTime) (Inherited from FileSystem.)
Protected method | DoSetReadOnly | (Overrides FileSystem DoSetReadOnly(FileSystemSessionItem, Boolean).)
Protected method | DoSetReadOnlyAsync | Async version of DoSetReadOnly(FileSystemSessionItem, Boolean). This base/default implementation just synchronously calls DoSetReadOnly(FileSystemSessionItem, Boolean) and returns already completed Task with result returned by DoSetReadOnly(FileSystemSessionItem, Boolean) (Inherited from FileSystem.)
Protected method | DoSetVersion | Override in particular file systems that support versioning to set seesion to specific version. This method may be called by miltiple threads (Inherited from FileSystem.)
Protected method | DoSetVersionAsync | Async version of DoSetVersion(FileSystemSession, IFileSystemVersion). This base/default implementation just synchronously calls DoSetVersion(FileSystemSession, IFileSystemVersion) and returns already completed Task with result returned by DoSetVersion(FileSystemSession, IFileSystemVersion) (Inherited from FileSystem.)
Protected method | DoWriteAsync | (Inherited from FileSystem.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeSessionConfigParams | (Overrides FileSystem MakeSessionConfigParams(IConfigSectionNode).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | StartSession(FileSystemSessionConnectParams) | (Overrides FileSystem StartSession(FileSystemSessionConnectParams).)
Public method | StartSession(SVNFileSystemSessionConnectParams) |
Public method | ToString | (Inherited from FileSystem.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SVNFileSystem Class
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.DoCreateDirectory Method

SVNFileSystem DoCreateDirectory Method NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemDirectory DoCreateDirectory(
    FileSystemDirectory dir,
    string name
)
protected internal override FileSystemDirectory DoCreateDirectory(
    FileSystemDirectory dir,
    string name
)
Protected Friend Overrides Function DoCreateDirectory (
    dir As FileSystemDirectory,
    name As String
) As FileSystemDirectory
Protected Friend Overrides Function DoCreateDirectory (
    dir As FileSystemDirectory,
    name As String
) As FileSystemDirectory
protected public:
virtual FileSystemDirectory^ DoCreateDirectory(
    FileSystemDirectory^ dir,
    String^ name
) override
protected public:
virtual FileSystemDirectory^ DoCreateDirectory(
    FileSystemDirectory^ dir,
    String^ name
) override
abstract DoCreateDirectory :
        dir : FileSystemDirectory *
        name : string -> FileSystemDirectory
override DoCreateDirectory :
        dir : FileSystemDirectory *
        name : string -> FileSystemDirectory
abstract DoCreateDirectory :
        dir : FileSystemDirectory *
        name : string -> FileSystemDirectory
override DoCreateDirectory :
        dir : FileSystemDirectory *
        name : string -> FileSystemDirectory

Parameters

dir
Type: NFX.IO.FileSystem FileSystemDirectory
name
Type: Online System String

Return Value

Type: FileSystemDirectory
See Also
SVNFileSystem Class
SVNFileSystem Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.DoCreateFile Method

SVNFileSystem DoCreateFile Method NFX Class Library

Overload List
 | Name | Description
Protected method | DoCreateFile(FileSystemDirectory, String, Int32) | (Overrides FileSystem DoCreateFile(FileSystemDirectory, String, Int32).)
Protected method | DoCreateFile(FileSystemDirectory, String, String, Boolean) | (Overrides FileSystem DoCreateFile(FileSystemDirectory, String, String, Boolean).)
Back to Top
See Also
SVNFileSystem Class
SVNFileSystem Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.DoCreateFile Method (FileSystemDirectory, String, Int32)

SVNFileSystem DoCreateFile Method (FileSystemDirectory, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemFile DoCreateFile(
    FileSystemDirectory dir,
    string name,
    int size
)
protected internal override FileSystemFile DoCreateFile(
    FileSystemDirectory dir,
    string name,
    int size
)
Protected Friend Overrides Function DoCreateFile (
    dir As FileSystemDirectory,
    name As String,
    size As Integer
) As FileSystemFile
Protected Friend Overrides Function DoCreateFile (
    dir As FileSystemDirectory,
    name As String,
    size As Integer
) As FileSystemFile
protected public:
virtual FileSystemFile^ DoCreateFile(
    FileSystemDirectory^ dir,
    String^ name,
    int size
) override
protected public:
virtual FileSystemFile^ DoCreateFile(
    FileSystemDirectory^ dir,
    String^ name,
    int size
) override
abstract DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        size : int -> FileSystemFile
override DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        size : int -> FileSystemFile
abstract DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        size : int -> FileSystemFile
override DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        size : int -> FileSystemFile

Parameters

dir
Type: NFX.IO.FileSystem FileSystemDirectory
name
Type: Online System String
size
Type: Online System Int32

Return Value

Type: FileSystemFile
See Also
SVNFileSystem Class
SVNFileSystem Members
DoCreateFile Overload
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.DoCreateFile Method (FileSystemDirectory, String, String, Boolean)

SVNFileSystem DoCreateFile Method (FileSystemDirectory, String, String, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemFile DoCreateFile(
    FileSystemDirectory dir,
    string name,
    string localFile,
    bool readOnly
)
protected internal override FileSystemFile DoCreateFile(
    FileSystemDirectory dir,
    string name,
    string localFile,
    bool readOnly
)
Protected Friend Overrides Function DoCreateFile (
    dir As FileSystemDirectory,
    name As String,
    localFile As String,
    readOnly As Boolean
) As FileSystemFile
Protected Friend Overrides Function DoCreateFile (
    dir As FileSystemDirectory,
    name As String,
    localFile As String,
    readOnly As Boolean
) As FileSystemFile
protected public:
virtual FileSystemFile^ DoCreateFile(
    FileSystemDirectory^ dir,
    String^ name,
    String^ localFile,
    bool readOnly
) override
protected public:
virtual FileSystemFile^ DoCreateFile(
    FileSystemDirectory^ dir,
    String^ name,
    String^ localFile,
    bool readOnly
) override
abstract DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        localFile : string *
        readOnly : bool -> FileSystemFile
override DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        localFile : string *
        readOnly : bool -> FileSystemFile
abstract DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        localFile : string *
        readOnly : bool -> FileSystemFile
override DoCreateFile :
        dir : FileSystemDirectory *
        name : string *
        localFile : string *
        readOnly : bool -> FileSystemFile

Parameters

dir
Type: NFX.IO.FileSystem FileSystemDirectory
name
Type: Online System String
localFile
Type: Online System String
readOnly
Type: Online System Boolean

Return Value

Type: FileSystemFile
See Also
SVNFileSystem Class
SVNFileSystem Members
DoCreateFile Overload
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.DoDeleteItem Method

SVNFileSystem DoDeleteItem Method NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoDeleteItem(
    FileSystemSessionItem item
)
protected internal override void DoDeleteItem(
    FileSystemSessionItem item
)
Protected Friend Overrides Sub DoDeleteItem (
    item As FileSystemSessionItem
)
Protected Friend Overrides Sub DoDeleteItem (
    item As FileSystemSessionItem
)
protected public:
virtual void DoDeleteItem(
    FileSystemSessionItem^ item
) override
protected public:
virtual void DoDeleteItem(
    FileSystemSessionItem^ item
) override
abstract DoDeleteItem :
        item : FileSystemSessionItem -> unit
override DoDeleteItem :
        item : FileSystemSessionItem -> unit
abstract DoDeleteItem :
        item : FileSystemSessionItem -> unit
override DoDeleteItem :
        item : FileSystemSessionItem -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
See Also
SVNFileSystem Class
SVNFileSystem Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.DoGetCreationTimestamp Method

SVNFileSystem DoGetCreationTimestamp Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override Nullable<DateTime> DoGetCreationTimestamp(
    FileSystemSessionItem item
)
protected internal override Nullable<DateTime> DoGetCreationTimestamp(
    FileSystemSessionItem item
)
Protected Friend Overrides Function DoGetCreationTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
Protected Friend Overrides Function DoGetCreationTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
protected public:
virtual Nullable<DateTime> DoGetCreationTimestamp(
    FileSystemSessionItem^ item
) override
protected public:
virtual Nullable<DateTime> DoGetCreationTimestamp(
    FileSystemSessionItem^ item
) override
abstract DoGetCreationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
override DoGetCreationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
abstract DoGetCreationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
override DoGetCreationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online Nullable Online DateTime
See Also
SVNFileSystem Class
SVNFileSystem Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.DoGetFileNames Method

SVNFileSystem DoGetFileNames Method NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override IEnumerable<string> DoGetFileNames(
    FileSystemDirectory directory,
    bool recursive
)
protected internal override IEnumerable<string> DoGetFileNames(
    FileSystemDirectory directory,
    bool recursive
)
Protected Friend Overrides Function DoGetFileNames (
    directory As FileSystemDirectory,
    recursive As Boolean
) As IEnumerable(Of String)
Protected Friend Overrides Function DoGetFileNames (
    directory As FileSystemDirectory,
    recursive As Boolean
) As IEnumerable(Of String)
protected public:
virtual IEnumerable<String^>^ DoGetFileNames(
    FileSystemDirectory^ directory,
    bool recursive
) override
protected public:
virtual IEnumerable<String^>^ DoGetFileNames(
    FileSystemDirectory^ directory,
    bool recursive
) override
abstract DoGetFileNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>
override DoGetFileNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>
abstract DoGetFileNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>
override DoGetFileNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>

Parameters

directory
Type: NFX.IO.FileSystem FileSystemDirectory
recursive
Type: Online System Boolean

Return Value

Type: Online IEnumerable Online String
See Also
SVNFileSystem Class
SVNFileSystem Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.DoGetFileStream Method

SVNFileSystem DoGetFileStream Method NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemStream DoGetFileStream(
    FileSystemFile file,
    Action<FileSystemStream> disposeAction
)
protected internal override FileSystemStream DoGetFileStream(
    FileSystemFile file,
    Action<FileSystemStream> disposeAction
)
Protected Friend Overrides Function DoGetFileStream (
    file As FileSystemFile,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
Protected Friend Overrides Function DoGetFileStream (
    file As FileSystemFile,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
protected public:
virtual FileSystemStream^ DoGetFileStream(
    FileSystemFile^ file,
    Action<FileSystemStream^>^ disposeAction
) override
protected public:
virtual FileSystemStream^ DoGetFileStream(
    FileSystemFile^ file,
    Action<FileSystemStream^>^ disposeAction
) override
abstract DoGetFileStream :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
override DoGetFileStream :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
abstract DoGetFileStream :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
override DoGetFileStream :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> FileSystemStream

Parameters

file
Type: NFX.IO.FileSystem FileSystemFile
disposeAction
Type: Online System Action FileSystemStream

Return Value

Type: FileSystemStream
See Also
SVNFileSystem Class
SVNFileSystem Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.DoGetItemSize Method

SVNFileSystem DoGetItemSize Method NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override ulong DoGetItemSize(
    FileSystemSessionItem item
)
protected internal override ulong DoGetItemSize(
    FileSystemSessionItem item
)
Protected Friend Overrides Function DoGetItemSize (
    item As FileSystemSessionItem
) As ULong
Protected Friend Overrides Function DoGetItemSize (
    item As FileSystemSessionItem
) As ULong
protected public:
virtual unsigned long long DoGetItemSize(
    FileSystemSessionItem^ item
) override
protected public:
virtual unsigned long long DoGetItemSize(
    FileSystemSessionItem^ item
) override
abstract DoGetItemSize :
        item : FileSystemSessionItem -> uint64
override DoGetItemSize :
        item : FileSystemSessionItem -> uint64
abstract DoGetItemSize :
        item : FileSystemSessionItem -> uint64
override DoGetItemSize :
        item : FileSystemSessionItem -> uint64

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online UInt64
See Also
SVNFileSystem Class
SVNFileSystem Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.DoGetLastAccessTimestamp Method

SVNFileSystem DoGetLastAccessTimestamp Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override Nullable<DateTime> DoGetLastAccessTimestamp(
    FileSystemSessionItem item
)
protected internal override Nullable<DateTime> DoGetLastAccessTimestamp(
    FileSystemSessionItem item
)
Protected Friend Overrides Function DoGetLastAccessTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
Protected Friend Overrides Function DoGetLastAccessTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
protected public:
virtual Nullable<DateTime> DoGetLastAccessTimestamp(
    FileSystemSessionItem^ item
) override
protected public:
virtual Nullable<DateTime> DoGetLastAccessTimestamp(
    FileSystemSessionItem^ item
) override
abstract DoGetLastAccessTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
override DoGetLastAccessTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
abstract DoGetLastAccessTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
override DoGetLastAccessTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online Nullable Online DateTime
See Also
SVNFileSystem Class
SVNFileSystem Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.DoGetMetadataStream Method

SVNFileSystem DoGetMetadataStream Method NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemStream DoGetMetadataStream(
    FileSystemSessionItem item,
    Action<FileSystemStream> disposeAction
)
protected internal override FileSystemStream DoGetMetadataStream(
    FileSystemSessionItem item,
    Action<FileSystemStream> disposeAction
)
Protected Friend Overrides Function DoGetMetadataStream (
    item As FileSystemSessionItem,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
Protected Friend Overrides Function DoGetMetadataStream (
    item As FileSystemSessionItem,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
protected public:
virtual FileSystemStream^ DoGetMetadataStream(
    FileSystemSessionItem^ item,
    Action<FileSystemStream^>^ disposeAction
) override
protected public:
virtual FileSystemStream^ DoGetMetadataStream(
    FileSystemSessionItem^ item,
    Action<FileSystemStream^>^ disposeAction
) override
abstract DoGetMetadataStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
override DoGetMetadataStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
abstract DoGetMetadataStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
override DoGetMetadataStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
disposeAction
Type: Online System Action FileSystemStream

Return Value

Type: FileSystemStream
See Also
SVNFileSystem Class
SVNFileSystem Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.DoGetModificationTimestamp Method

SVNFileSystem DoGetModificationTimestamp Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override Nullable<DateTime> DoGetModificationTimestamp(
    FileSystemSessionItem item
)
protected internal override Nullable<DateTime> DoGetModificationTimestamp(
    FileSystemSessionItem item
)
Protected Friend Overrides Function DoGetModificationTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
Protected Friend Overrides Function DoGetModificationTimestamp (
    item As FileSystemSessionItem
) As Nullable(Of DateTime)
protected public:
virtual Nullable<DateTime> DoGetModificationTimestamp(
    FileSystemSessionItem^ item
) override
protected public:
virtual Nullable<DateTime> DoGetModificationTimestamp(
    FileSystemSessionItem^ item
) override
abstract DoGetModificationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
override DoGetModificationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
abstract DoGetModificationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>
override DoGetModificationTimestamp :
        item : FileSystemSessionItem -> Nullable<DateTime>

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online Nullable Online DateTime
See Also
SVNFileSystem Class
SVNFileSystem Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.DoGetPermissionsStream Method

SVNFileSystem DoGetPermissionsStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemStream DoGetPermissionsStream(
    FileSystemSessionItem item,
    Action<FileSystemStream> disposeAction
)
protected internal override FileSystemStream DoGetPermissionsStream(
    FileSystemSessionItem item,
    Action<FileSystemStream> disposeAction
)
Protected Friend Overrides Function DoGetPermissionsStream (
    item As FileSystemSessionItem,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
Protected Friend Overrides Function DoGetPermissionsStream (
    item As FileSystemSessionItem,
    disposeAction As Action(Of FileSystemStream)
) As FileSystemStream
protected public:
virtual FileSystemStream^ DoGetPermissionsStream(
    FileSystemSessionItem^ item,
    Action<FileSystemStream^>^ disposeAction
) override
protected public:
virtual FileSystemStream^ DoGetPermissionsStream(
    FileSystemSessionItem^ item,
    Action<FileSystemStream^>^ disposeAction
) override
abstract DoGetPermissionsStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
override DoGetPermissionsStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
abstract DoGetPermissionsStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream
override DoGetPermissionsStream :
        item : FileSystemSessionItem *
        disposeAction : Action<FileSystemStream> -> FileSystemStream

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
disposeAction
Type: Online System Action FileSystemStream

Return Value

Type: FileSystemStream
See Also
SVNFileSystem Class
SVNFileSystem Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.DoGetReadOnly Method

SVNFileSystem DoGetReadOnly Method NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override bool DoGetReadOnly(
    FileSystemSessionItem item
)
protected internal override bool DoGetReadOnly(
    FileSystemSessionItem item
)
Protected Friend Overrides Function DoGetReadOnly (
    item As FileSystemSessionItem
) As Boolean
Protected Friend Overrides Function DoGetReadOnly (
    item As FileSystemSessionItem
) As Boolean
protected public:
virtual bool DoGetReadOnly(
    FileSystemSessionItem^ item
) override
protected public:
virtual bool DoGetReadOnly(
    FileSystemSessionItem^ item
) override
abstract DoGetReadOnly :
        item : FileSystemSessionItem -> bool
override DoGetReadOnly :
        item : FileSystemSessionItem -> bool
abstract DoGetReadOnly :
        item : FileSystemSessionItem -> bool
override DoGetReadOnly :
        item : FileSystemSessionItem -> bool

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem

Return Value

Type: Online Boolean
See Also
SVNFileSystem Class
SVNFileSystem Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.DoGetSubDirectoryNames Method

SVNFileSystem DoGetSubDirectoryNames Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override IEnumerable<string> DoGetSubDirectoryNames(
    FileSystemDirectory directory,
    bool recursive
)
protected internal override IEnumerable<string> DoGetSubDirectoryNames(
    FileSystemDirectory directory,
    bool recursive
)
Protected Friend Overrides Function DoGetSubDirectoryNames (
    directory As FileSystemDirectory,
    recursive As Boolean
) As IEnumerable(Of String)
Protected Friend Overrides Function DoGetSubDirectoryNames (
    directory As FileSystemDirectory,
    recursive As Boolean
) As IEnumerable(Of String)
protected public:
virtual IEnumerable<String^>^ DoGetSubDirectoryNames(
    FileSystemDirectory^ directory,
    bool recursive
) override
protected public:
virtual IEnumerable<String^>^ DoGetSubDirectoryNames(
    FileSystemDirectory^ directory,
    bool recursive
) override
abstract DoGetSubDirectoryNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>
override DoGetSubDirectoryNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>
abstract DoGetSubDirectoryNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>
override DoGetSubDirectoryNames :
        directory : FileSystemDirectory *
        recursive : bool -> IEnumerable<string>

Parameters

directory
Type: NFX.IO.FileSystem FileSystemDirectory
recursive
Type: Online System Boolean

Return Value

Type: Online IEnumerable Online String
See Also
SVNFileSystem Class
SVNFileSystem Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.DoNavigate Method

SVNFileSystem DoNavigate Method NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override FileSystemSessionItem DoNavigate(
    FileSystemSession session,
    string path
)
protected internal override FileSystemSessionItem DoNavigate(
    FileSystemSession session,
    string path
)
Protected Friend Overrides Function DoNavigate (
    session As FileSystemSession,
    path As String
) As FileSystemSessionItem
Protected Friend Overrides Function DoNavigate (
    session As FileSystemSession,
    path As String
) As FileSystemSessionItem
protected public:
virtual FileSystemSessionItem^ DoNavigate(
    FileSystemSession^ session,
    String^ path
) override
protected public:
virtual FileSystemSessionItem^ DoNavigate(
    FileSystemSession^ session,
    String^ path
) override
abstract DoNavigate :
        session : FileSystemSession *
        path : string -> FileSystemSessionItem
override DoNavigate :
        session : FileSystemSession *
        path : string -> FileSystemSessionItem
abstract DoNavigate :
        session : FileSystemSession *
        path : string -> FileSystemSessionItem
override DoNavigate :
        session : FileSystemSession *
        path : string -> FileSystemSessionItem

Parameters

session
Type: NFX.IO.FileSystem FileSystemSession
path
Type: Online System String

Return Value

Type: FileSystemSessionItem
See Also
SVNFileSystem Class
SVNFileSystem Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.DoRenameItem Method

SVNFileSystem DoRenameItem Method NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override bool DoRenameItem(
    FileSystemSessionItem item,
    string newName
)
protected internal override bool DoRenameItem(
    FileSystemSessionItem item,
    string newName
)
Protected Friend Overrides Function DoRenameItem (
    item As FileSystemSessionItem,
    newName As String
) As Boolean
Protected Friend Overrides Function DoRenameItem (
    item As FileSystemSessionItem,
    newName As String
) As Boolean
protected public:
virtual bool DoRenameItem(
    FileSystemSessionItem^ item,
    String^ newName
) override
protected public:
virtual bool DoRenameItem(
    FileSystemSessionItem^ item,
    String^ newName
) override
abstract DoRenameItem :
        item : FileSystemSessionItem *
        newName : string -> bool
override DoRenameItem :
        item : FileSystemSessionItem *
        newName : string -> bool
abstract DoRenameItem :
        item : FileSystemSessionItem *
        newName : string -> bool
override DoRenameItem :
        item : FileSystemSessionItem *
        newName : string -> bool

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
newName
Type: Online System String

Return Value

Type: Online Boolean
See Also
SVNFileSystem Class
SVNFileSystem Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.DoSetCreationTimestamp Method

SVNFileSystem DoSetCreationTimestamp Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoSetCreationTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
protected internal override void DoSetCreationTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
Protected Friend Overrides Sub DoSetCreationTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
Protected Friend Overrides Sub DoSetCreationTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
protected public:
virtual void DoSetCreationTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) override
protected public:
virtual void DoSetCreationTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) override
abstract DoSetCreationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
override DoSetCreationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
abstract DoSetCreationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
override DoSetCreationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
timestamp
Type: Online System DateTime
See Also
SVNFileSystem Class
SVNFileSystem Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.DoSetLastAccessTimestamp Method

SVNFileSystem DoSetLastAccessTimestamp Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoSetLastAccessTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
protected internal override void DoSetLastAccessTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
Protected Friend Overrides Sub DoSetLastAccessTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
Protected Friend Overrides Sub DoSetLastAccessTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
protected public:
virtual void DoSetLastAccessTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) override
protected public:
virtual void DoSetLastAccessTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) override
abstract DoSetLastAccessTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
override DoSetLastAccessTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
abstract DoSetLastAccessTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
override DoSetLastAccessTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
timestamp
Type: Online System DateTime
See Also
SVNFileSystem Class
SVNFileSystem Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.DoSetModificationTimestamp Method

SVNFileSystem DoSetModificationTimestamp Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoSetModificationTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
protected internal override void DoSetModificationTimestamp(
    FileSystemSessionItem item,
    DateTime timestamp
)
Protected Friend Overrides Sub DoSetModificationTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
Protected Friend Overrides Sub DoSetModificationTimestamp (
    item As FileSystemSessionItem,
    timestamp As DateTime
)
protected public:
virtual void DoSetModificationTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) override
protected public:
virtual void DoSetModificationTimestamp(
    FileSystemSessionItem^ item,
    DateTime timestamp
) override
abstract DoSetModificationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
override DoSetModificationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
abstract DoSetModificationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit
override DoSetModificationTimestamp :
        item : FileSystemSessionItem *
        timestamp : DateTime -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
timestamp
Type: Online System DateTime
See Also
SVNFileSystem Class
SVNFileSystem Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.DoSetReadOnly Method

SVNFileSystem DoSetReadOnly Method NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoSetReadOnly(
    FileSystemSessionItem item,
    bool readOnly
)
protected internal override void DoSetReadOnly(
    FileSystemSessionItem item,
    bool readOnly
)
Protected Friend Overrides Sub DoSetReadOnly (
    item As FileSystemSessionItem,
    readOnly As Boolean
)
Protected Friend Overrides Sub DoSetReadOnly (
    item As FileSystemSessionItem,
    readOnly As Boolean
)
protected public:
virtual void DoSetReadOnly(
    FileSystemSessionItem^ item,
    bool readOnly
) override
protected public:
virtual void DoSetReadOnly(
    FileSystemSessionItem^ item,
    bool readOnly
) override
abstract DoSetReadOnly :
        item : FileSystemSessionItem *
        readOnly : bool -> unit
override DoSetReadOnly :
        item : FileSystemSessionItem *
        readOnly : bool -> unit
abstract DoSetReadOnly :
        item : FileSystemSessionItem *
        readOnly : bool -> unit
override DoSetReadOnly :
        item : FileSystemSessionItem *
        readOnly : bool -> unit

Parameters

item
Type: NFX.IO.FileSystem FileSystemSessionItem
readOnly
Type: Online System Boolean
See Also
SVNFileSystem Class
SVNFileSystem Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.MakeSessionConfigParams Method

SVNFileSystem MakeSessionConfigParams Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override FileSystemSessionConnectParams MakeSessionConfigParams(
    IConfigSectionNode node
)
protected override FileSystemSessionConnectParams MakeSessionConfigParams(
    IConfigSectionNode node
)
Protected Overrides Function MakeSessionConfigParams (
    node As IConfigSectionNode
) As FileSystemSessionConnectParams
Protected Overrides Function MakeSessionConfigParams (
    node As IConfigSectionNode
) As FileSystemSessionConnectParams
protected:
virtual FileSystemSessionConnectParams^ MakeSessionConfigParams(
    IConfigSectionNode^ node
) override
protected:
virtual FileSystemSessionConnectParams^ MakeSessionConfigParams(
    IConfigSectionNode^ node
) override
abstract MakeSessionConfigParams :
        node : IConfigSectionNode -> FileSystemSessionConnectParams
override MakeSessionConfigParams :
        node : IConfigSectionNode -> FileSystemSessionConnectParams
abstract MakeSessionConfigParams :
        node : IConfigSectionNode -> FileSystemSessionConnectParams
override MakeSessionConfigParams :
        node : IConfigSectionNode -> FileSystemSessionConnectParams

Parameters

node
Type: NFX.Environment IConfigSectionNode

Return Value

Type: FileSystemSessionConnectParams
See Also
SVNFileSystem Class
SVNFileSystem Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.StartSession Method

SVNFileSystem StartSession Method NFX Class Library

Overload List
 | Name | Description
Public method | StartSession(FileSystemSessionConnectParams) | (Overrides FileSystem StartSession(FileSystemSessionConnectParams).)
Public method | StartSession(SVNFileSystemSessionConnectParams) |
Back to Top
See Also
SVNFileSystem Class
SVNFileSystem Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.StartSession Method (FileSystemSessionConnectParams)

SVNFileSystem StartSession Method (FileSystemSessionConnectParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override FileSystemSession StartSession(
    FileSystemSessionConnectParams cParams = null
)
public override FileSystemSession StartSession(
    FileSystemSessionConnectParams cParams = null
)
Public Overrides Function StartSession (
    Optional cParams As FileSystemSessionConnectParams = Nothing
) As FileSystemSession
Public Overrides Function StartSession (
    Optional cParams As FileSystemSessionConnectParams = Nothing
) As FileSystemSession
public:
virtual FileSystemSession^ StartSession(
    FileSystemSessionConnectParams^ cParams = nullptr
) override
public:
virtual FileSystemSession^ StartSession(
    FileSystemSessionConnectParams^ cParams = nullptr
) override
abstract StartSession :
        ?cParams : FileSystemSessionConnectParams
(* Defaults:
        let _cParams = defaultArg cParams null
*)
-> FileSystemSession
override StartSession :
        ?cParams : FileSystemSessionConnectParams
(* Defaults:
        let _cParams = defaultArg cParams null
*)
-> FileSystemSession
abstract StartSession :
        ?cParams : FileSystemSessionConnectParams
(* Defaults:
        let _cParams = defaultArg cParams null
*)
-> FileSystemSession
override StartSession :
        ?cParams : FileSystemSessionConnectParams
(* Defaults:
        let _cParams = defaultArg cParams null
*)
-> FileSystemSession

Parameters

cParams (Optional)
Type: NFX.IO.FileSystem FileSystemSessionConnectParams

Return Value

Type: FileSystemSession

Implements

IFileSystem StartSession(FileSystemSessionConnectParams)
See Also
SVNFileSystem Class
SVNFileSystem Members
StartSession Overload
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.StartSession Method (SVNFileSystemSessionConnectParams)

SVNFileSystem StartSession Method (SVNFileSystemSessionConnectParams) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SVNFileSystemSession StartSession(
    SVNFileSystemSessionConnectParams cParams
)
public SVNFileSystemSession StartSession(
    SVNFileSystemSessionConnectParams cParams
)
Public Function StartSession (
    cParams As SVNFileSystemSessionConnectParams
) As SVNFileSystemSession
Public Function StartSession (
    cParams As SVNFileSystemSessionConnectParams
) As SVNFileSystemSession
public:
SVNFileSystemSession^ StartSession(
    SVNFileSystemSessionConnectParams^ cParams
)
public:
SVNFileSystemSession^ StartSession(
    SVNFileSystemSessionConnectParams^ cParams
)
member StartSession :
        cParams : SVNFileSystemSessionConnectParams -> SVNFileSystemSession
member StartSession :
        cParams : SVNFileSystemSessionConnectParams -> SVNFileSystemSession

Parameters

cParams
Type: NFX.IO.FileSystem.SVN SVNFileSystemSessionConnectParams

Return Value

Type: SVNFileSystemSession
See Also
SVNFileSystem Class
SVNFileSystem Members
StartSession Overload
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem Properties

SVNFileSystem Properties NFX Class Library

The SVNFileSystem type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | (Overrides ApplicationComponent ComponentCommonName.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Protected property | DefaultSessionConnectParams | (Inherited from FileSystem.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | GeneralCapabilities | (Overrides FileSystem GeneralCapabilities.)
Public property | InstanceCapabilities | (Overrides FileSystem InstanceCapabilities.)
Public property | Name | Provides name for file system instance (Inherited from FileSystem.)
Public property | Sessions | Returns a list of sessions. This accessor is thread-safe (Inherited from FileSystem.)
Back to Top
See Also
SVNFileSystem Class
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.ComponentCommonName Property

SVNFileSystem ComponentCommonName Property NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ComponentCommonName { get; }
public override string ComponentCommonName { get; }
Public Overrides ReadOnly Property ComponentCommonName As String
    Get
Public Overrides ReadOnly Property ComponentCommonName As String
    Get
public:
virtual property String^ ComponentCommonName {
    String^ get () override;
}
public:
virtual property String^ ComponentCommonName {
    String^ get () override;
}
abstract ComponentCommonName : string with get
override ComponentCommonName : string with get
abstract ComponentCommonName : string with get
override ComponentCommonName : string with get

Property Value

Type: Online String

Implements

IApplicationComponent ComponentCommonName
See Also
SVNFileSystem Class
SVNFileSystem Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.GeneralCapabilities Property

SVNFileSystem GeneralCapabilities Property NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IFileSystemCapabilities GeneralCapabilities { get; }
public override IFileSystemCapabilities GeneralCapabilities { get; }
Public Overrides ReadOnly Property GeneralCapabilities As IFileSystemCapabilities
    Get
Public Overrides ReadOnly Property GeneralCapabilities As IFileSystemCapabilities
    Get
public:
virtual property IFileSystemCapabilities^ GeneralCapabilities {
    IFileSystemCapabilities^ get () override;
}
public:
virtual property IFileSystemCapabilities^ GeneralCapabilities {
    IFileSystemCapabilities^ get () override;
}
abstract GeneralCapabilities : IFileSystemCapabilities with get
override GeneralCapabilities : IFileSystemCapabilities with get
abstract GeneralCapabilities : IFileSystemCapabilities with get
override GeneralCapabilities : IFileSystemCapabilities with get

Property Value

Type: IFileSystemCapabilities

Implements

IFileSystem GeneralCapabilities
See Also
SVNFileSystem Class
SVNFileSystem Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.InstanceCapabilities Property

SVNFileSystem InstanceCapabilities Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IFileSystemCapabilities InstanceCapabilities { get; }
public override IFileSystemCapabilities InstanceCapabilities { get; }
Public Overrides ReadOnly Property InstanceCapabilities As IFileSystemCapabilities
    Get
Public Overrides ReadOnly Property InstanceCapabilities As IFileSystemCapabilities
    Get
public:
virtual property IFileSystemCapabilities^ InstanceCapabilities {
    IFileSystemCapabilities^ get () override;
}
public:
virtual property IFileSystemCapabilities^ InstanceCapabilities {
    IFileSystemCapabilities^ get () override;
}
abstract InstanceCapabilities : IFileSystemCapabilities with get
override InstanceCapabilities : IFileSystemCapabilities with get
abstract InstanceCapabilities : IFileSystemCapabilities with get
override InstanceCapabilities : IFileSystemCapabilities with get

Property Value

Type: IFileSystemCapabilities

Implements

IFileSystem InstanceCapabilities
See Also
SVNFileSystem Class
SVNFileSystem Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.SVNFSH Class

SVNFileSystem SVNFSH Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.SVN SVNFileSystem SVNFSH

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SVNFSH : IFileSystemHandle
public class SVNFSH : IFileSystemHandle
Public Class SVNFSH
    Implements IFileSystemHandle
Public Class SVNFSH
    Implements IFileSystemHandle
public ref class SVNFSH : IFileSystemHandle
public ref class SVNFSH : IFileSystemHandle
type SVNFSH =
    class
        interface IFileSystemHandle
    end
type SVNFSH =
    class
        interface IFileSystemHandle
    end
See Also
SVNFileSystem SVNFSH Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.SVNFSH Members

SVNFileSystem SVNFSH Members NFX Class Library

The SVNFileSystem SVNFSH type exposes the following members.
Constructors
 | Name | Description
Public method | SVNFileSystem SVNFSH | Initializes a new instance of the SVNFileSystem SVNFSH class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Item |
Back to Top
See Also
SVNFileSystem SVNFSH Class
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.SVNFSH Constructor

SVNFileSystem SVNFSH Constructor NFX Class Library

Initializes a new instance of the SVNFileSystem SVNFSH class

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SVNFSH(
    WebDAV..::..Item item
)
public SVNFSH(
    WebDAV..::..Item item
)
Public Sub New (
    item As WebDAV..::..Item
)
Public Sub New (
    item As WebDAV..::..Item
)
public:
SVNFSH(
    WebDAV..::..Item^ item
)
public:
SVNFSH(
    WebDAV..::..Item^ item
)
new :
        item : WebDAV..::..Item -> SVNFSH
new :
        item : WebDAV..::..Item -> SVNFSH

Parameters

item
Type: NFX.IO.FileSystem.SVN WebDAV Item
See Also
SVNFileSystem SVNFSH Class
SVNFileSystem SVNFSH Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.SVNFSH Fields

SVNFileSystem SVNFSH Fields NFX Class Library

The SVNFileSystem SVNFSH type exposes the following members.
Fields
 | Name | Description
Public field | Item |
Back to Top
See Also
SVNFileSystem SVNFSH Class
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.SVNFSH.Item Field

SVNFileSystem SVNFSH Item Field NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly WebDAV..::..Item Item
public readonly WebDAV..::..Item Item
Public ReadOnly Item As WebDAV..::..Item
Public ReadOnly Item As WebDAV..::..Item
public:
initonly WebDAV..::..Item^ Item
public:
initonly WebDAV..::..Item^ Item
val Item: WebDAV..::..Item
val Item: WebDAV..::..Item

Field Value

Type: WebDAV Item
See Also
SVNFileSystem SVNFSH Class
SVNFileSystem SVNFSH Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystem.SVNFSH Methods

SVNFileSystem SVNFSH Methods NFX Class Library

The SVNFileSystem SVNFSH type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SVNFileSystem SVNFSH Class
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities Class

SVNFileSystemCapabilities Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.SVN SVNFileSystemCapabilities

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SVNFileSystemCapabilities : IFileSystemCapabilities
public class SVNFileSystemCapabilities : IFileSystemCapabilities
Public Class SVNFileSystemCapabilities
    Implements IFileSystemCapabilities
Public Class SVNFileSystemCapabilities
    Implements IFileSystemCapabilities
public ref class SVNFileSystemCapabilities : IFileSystemCapabilities
public ref class SVNFileSystemCapabilities : IFileSystemCapabilities
type SVNFileSystemCapabilities =
    class
        interface IFileSystemCapabilities
    end
type SVNFileSystemCapabilities =
    class
        interface IFileSystemCapabilities
    end
See Also
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities Members

SVNFileSystemCapabilities Members NFX Class Library

The SVNFileSystemCapabilities type exposes the following members.
Constructors
 | Name | Description
Public method | SVNFileSystemCapabilities | Initializes a new instance of the SVNFileSystemCapabilities class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
PATH_SEPARATORS |
Back to Top
Properties
 | Name | Description
 | Instance |
Public property | IsReadonly |
Public property | MaxDirectoryNameLength |
Public property | MaxFileNameLength |
Public property | MaxFilePathLength |
Public property | MaxFileSize |
Public property | PathSeparatorCharacters |
Public property | SupportsAsyncronousAPI |
Public property | SupportsCreationTimestamps |
Public property | SupportsCreationUserNames |
Public property | SupportsCustomMetadata |
Public property | SupportsDirectoryRenaming |
Public property | SupportsDirectorySizes |
Public property | SupportsFileModification |
Public property | SupportsFileRenaming |
Public property | SupportsFileSizes |
Public property | SupportsLastAccessTimestamps |
Public property | SupportsLastAccessUserNames |
Public property | SupportsModificationTimestamps |
Public property | SupportsModificationUserNames |
Public property | SupportsReadonlyDirectories |
Public property | SupportsReadonlyFiles |
Public property | SupportsSecurity |
Public property | SupportsStreamSeek |
Public property | SupportsTransactions |
Public property | SupportsVersioning |
Back to Top
See Also
SVNFileSystemCapabilities Class
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities Constructor

SVNFileSystemCapabilities Constructor NFX Class Library

Initializes a new instance of the SVNFileSystemCapabilities class

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SVNFileSystemCapabilities()
public SVNFileSystemCapabilities()
Public Sub New
Public Sub New
public:
SVNFileSystemCapabilities()
public:
SVNFileSystemCapabilities()
new : unit -> SVNFileSystemCapabilities
new : unit -> SVNFileSystemCapabilities
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities Fields

SVNFileSystemCapabilities Fields NFX Class Library

The SVNFileSystemCapabilities type exposes the following members.
Fields
Name | Description
PATH_SEPARATORS |
Back to Top
See Also
SVNFileSystemCapabilities Class
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities.PATH_SEPARATORS Field

SVNFileSystemCapabilities PATH_SEPARATORS Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static readonly char[] PATH_SEPARATORS
internal static readonly char[] PATH_SEPARATORS
Friend Shared ReadOnly PATH_SEPARATORS As Char()
Friend Shared ReadOnly PATH_SEPARATORS As Char()
internal:
static initonly array<wchar_t>^ PATH_SEPARATORS
internal:
static initonly array<wchar_t>^ PATH_SEPARATORS
static val internal PATH_SEPARATORS: char[]
static val internal PATH_SEPARATORS: char[]

Field Value

Type: Online Char
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities Methods

SVNFileSystemCapabilities Methods NFX Class Library

The SVNFileSystemCapabilities type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SVNFileSystemCapabilities Class
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities Properties

SVNFileSystemCapabilities Properties NFX Class Library

The SVNFileSystemCapabilities type exposes the following members.
Properties
 | Name | Description
 | Instance |
Public property | IsReadonly |
Public property | MaxDirectoryNameLength |
Public property | MaxFileNameLength |
Public property | MaxFilePathLength |
Public property | MaxFileSize |
Public property | PathSeparatorCharacters |
Public property | SupportsAsyncronousAPI |
Public property | SupportsCreationTimestamps |
Public property | SupportsCreationUserNames |
Public property | SupportsCustomMetadata |
Public property | SupportsDirectoryRenaming |
Public property | SupportsDirectorySizes |
Public property | SupportsFileModification |
Public property | SupportsFileRenaming |
Public property | SupportsFileSizes |
Public property | SupportsLastAccessTimestamps |
Public property | SupportsLastAccessUserNames |
Public property | SupportsModificationTimestamps |
Public property | SupportsModificationUserNames |
Public property | SupportsReadonlyDirectories |
Public property | SupportsReadonlyFiles |
Public property | SupportsSecurity |
Public property | SupportsStreamSeek |
Public property | SupportsTransactions |
Public property | SupportsVersioning |
Back to Top
See Also
SVNFileSystemCapabilities Class
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities.Instance Property

SVNFileSystemCapabilities Instance Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static SVNFileSystemCapabilities Instance { get; }
public static SVNFileSystemCapabilities Instance { get; }
Public Shared ReadOnly Property Instance As SVNFileSystemCapabilities
    Get
Public Shared ReadOnly Property Instance As SVNFileSystemCapabilities
    Get
public:
static property SVNFileSystemCapabilities^ Instance {
    SVNFileSystemCapabilities^ get ();
}
public:
static property SVNFileSystemCapabilities^ Instance {
    SVNFileSystemCapabilities^ get ();
}
static member Instance : SVNFileSystemCapabilities with get
static member Instance : SVNFileSystemCapabilities with get

Property Value

Type: SVNFileSystemCapabilities
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities.IsReadonly Property

SVNFileSystemCapabilities IsReadonly Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsReadonly { get; }
public bool IsReadonly { get; }
Public ReadOnly Property IsReadonly As Boolean
    Get
Public ReadOnly Property IsReadonly As Boolean
    Get
public:
virtual property bool IsReadonly {
    bool get () sealed;
}
public:
virtual property bool IsReadonly {
    bool get () sealed;
}
abstract IsReadonly : bool with get
override IsReadonly : bool with get
abstract IsReadonly : bool with get
override IsReadonly : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities IsReadonly
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities.MaxDirectoryNameLength Property

SVNFileSystemCapabilities MaxDirectoryNameLength Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MaxDirectoryNameLength { get; }
public int MaxDirectoryNameLength { get; }
Public ReadOnly Property MaxDirectoryNameLength As Integer
    Get
Public ReadOnly Property MaxDirectoryNameLength As Integer
    Get
public:
virtual property int MaxDirectoryNameLength {
    int get () sealed;
}
public:
virtual property int MaxDirectoryNameLength {
    int get () sealed;
}
abstract MaxDirectoryNameLength : int with get
override MaxDirectoryNameLength : int with get
abstract MaxDirectoryNameLength : int with get
override MaxDirectoryNameLength : int with get

Property Value

Type: Online Int32

Implements

IFileSystemCapabilities MaxDirectoryNameLength
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities.MaxFileNameLength Property

SVNFileSystemCapabilities MaxFileNameLength Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MaxFileNameLength { get; }
public int MaxFileNameLength { get; }
Public ReadOnly Property MaxFileNameLength As Integer
    Get
Public ReadOnly Property MaxFileNameLength As Integer
    Get
public:
virtual property int MaxFileNameLength {
    int get () sealed;
}
public:
virtual property int MaxFileNameLength {
    int get () sealed;
}
abstract MaxFileNameLength : int with get
override MaxFileNameLength : int with get
abstract MaxFileNameLength : int with get
override MaxFileNameLength : int with get

Property Value

Type: Online Int32

Implements

IFileSystemCapabilities MaxFileNameLength
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities.MaxFilePathLength Property

SVNFileSystemCapabilities MaxFilePathLength Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MaxFilePathLength { get; }
public int MaxFilePathLength { get; }
Public ReadOnly Property MaxFilePathLength As Integer
    Get
Public ReadOnly Property MaxFilePathLength As Integer
    Get
public:
virtual property int MaxFilePathLength {
    int get () sealed;
}
public:
virtual property int MaxFilePathLength {
    int get () sealed;
}
abstract MaxFilePathLength : int with get
override MaxFilePathLength : int with get
abstract MaxFilePathLength : int with get
override MaxFilePathLength : int with get

Property Value

Type: Online Int32

Implements

IFileSystemCapabilities MaxFilePathLength
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities.MaxFileSize Property

SVNFileSystemCapabilities MaxFileSize Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong MaxFileSize { get; }
public ulong MaxFileSize { get; }
Public ReadOnly Property MaxFileSize As ULong
    Get
Public ReadOnly Property MaxFileSize As ULong
    Get
public:
virtual property unsigned long long MaxFileSize {
    unsigned long long get () sealed;
}
public:
virtual property unsigned long long MaxFileSize {
    unsigned long long get () sealed;
}
abstract MaxFileSize : uint64 with get
override MaxFileSize : uint64 with get
abstract MaxFileSize : uint64 with get
override MaxFileSize : uint64 with get

Property Value

Type: Online UInt64

Implements

IFileSystemCapabilities MaxFileSize
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities.PathSeparatorCharacters Property

SVNFileSystemCapabilities PathSeparatorCharacters Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char[] PathSeparatorCharacters { get; }
public char[] PathSeparatorCharacters { get; }
Public ReadOnly Property PathSeparatorCharacters As Char()
    Get
Public ReadOnly Property PathSeparatorCharacters As Char()
    Get
public:
virtual property array<wchar_t>^ PathSeparatorCharacters {
    array<wchar_t>^ get () sealed;
}
public:
virtual property array<wchar_t>^ PathSeparatorCharacters {
    array<wchar_t>^ get () sealed;
}
abstract PathSeparatorCharacters : char[] with get
override PathSeparatorCharacters : char[] with get
abstract PathSeparatorCharacters : char[] with get
override PathSeparatorCharacters : char[] with get

Property Value

Type: Online Char

Implements

IFileSystemCapabilities PathSeparatorCharacters
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities.SupportsAsyncronousAPI Property

SVNFileSystemCapabilities SupportsAsyncronousAPI Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsAsyncronousAPI { get; }
public bool SupportsAsyncronousAPI { get; }
Public ReadOnly Property SupportsAsyncronousAPI As Boolean
    Get
Public ReadOnly Property SupportsAsyncronousAPI As Boolean
    Get
public:
virtual property bool SupportsAsyncronousAPI {
    bool get () sealed;
}
public:
virtual property bool SupportsAsyncronousAPI {
    bool get () sealed;
}
abstract SupportsAsyncronousAPI : bool with get
override SupportsAsyncronousAPI : bool with get
abstract SupportsAsyncronousAPI : bool with get
override SupportsAsyncronousAPI : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsAsyncronousAPI
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities.SupportsCreationTimestamps Property

SVNFileSystemCapabilities SupportsCreationTimestamps Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsCreationTimestamps { get; }
public bool SupportsCreationTimestamps { get; }
Public ReadOnly Property SupportsCreationTimestamps As Boolean
    Get
Public ReadOnly Property SupportsCreationTimestamps As Boolean
    Get
public:
virtual property bool SupportsCreationTimestamps {
    bool get () sealed;
}
public:
virtual property bool SupportsCreationTimestamps {
    bool get () sealed;
}
abstract SupportsCreationTimestamps : bool with get
override SupportsCreationTimestamps : bool with get
abstract SupportsCreationTimestamps : bool with get
override SupportsCreationTimestamps : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsCreationTimestamps
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities.SupportsCreationUserNames Property

SVNFileSystemCapabilities SupportsCreationUserNames Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsCreationUserNames { get; }
public bool SupportsCreationUserNames { get; }
Public ReadOnly Property SupportsCreationUserNames As Boolean
    Get
Public ReadOnly Property SupportsCreationUserNames As Boolean
    Get
public:
virtual property bool SupportsCreationUserNames {
    bool get () sealed;
}
public:
virtual property bool SupportsCreationUserNames {
    bool get () sealed;
}
abstract SupportsCreationUserNames : bool with get
override SupportsCreationUserNames : bool with get
abstract SupportsCreationUserNames : bool with get
override SupportsCreationUserNames : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsCreationUserNames
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities.SupportsCustomMetadata Property

SVNFileSystemCapabilities SupportsCustomMetadata Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsCustomMetadata { get; }
public bool SupportsCustomMetadata { get; }
Public ReadOnly Property SupportsCustomMetadata As Boolean
    Get
Public ReadOnly Property SupportsCustomMetadata As Boolean
    Get
public:
virtual property bool SupportsCustomMetadata {
    bool get () sealed;
}
public:
virtual property bool SupportsCustomMetadata {
    bool get () sealed;
}
abstract SupportsCustomMetadata : bool with get
override SupportsCustomMetadata : bool with get
abstract SupportsCustomMetadata : bool with get
override SupportsCustomMetadata : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsCustomMetadata
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities.SupportsDirectoryRenaming Property

SVNFileSystemCapabilities SupportsDirectoryRenaming Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsDirectoryRenaming { get; }
public bool SupportsDirectoryRenaming { get; }
Public ReadOnly Property SupportsDirectoryRenaming As Boolean
    Get
Public ReadOnly Property SupportsDirectoryRenaming As Boolean
    Get
public:
virtual property bool SupportsDirectoryRenaming {
    bool get () sealed;
}
public:
virtual property bool SupportsDirectoryRenaming {
    bool get () sealed;
}
abstract SupportsDirectoryRenaming : bool with get
override SupportsDirectoryRenaming : bool with get
abstract SupportsDirectoryRenaming : bool with get
override SupportsDirectoryRenaming : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsDirectoryRenaming
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities.SupportsDirectorySizes Property

SVNFileSystemCapabilities SupportsDirectorySizes Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsDirectorySizes { get; }
public bool SupportsDirectorySizes { get; }
Public ReadOnly Property SupportsDirectorySizes As Boolean
    Get
Public ReadOnly Property SupportsDirectorySizes As Boolean
    Get
public:
virtual property bool SupportsDirectorySizes {
    bool get () sealed;
}
public:
virtual property bool SupportsDirectorySizes {
    bool get () sealed;
}
abstract SupportsDirectorySizes : bool with get
override SupportsDirectorySizes : bool with get
abstract SupportsDirectorySizes : bool with get
override SupportsDirectorySizes : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsDirectorySizes
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities.SupportsFileModification Property

SVNFileSystemCapabilities SupportsFileModification Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsFileModification { get; }
public bool SupportsFileModification { get; }
Public ReadOnly Property SupportsFileModification As Boolean
    Get
Public ReadOnly Property SupportsFileModification As Boolean
    Get
public:
virtual property bool SupportsFileModification {
    bool get () sealed;
}
public:
virtual property bool SupportsFileModification {
    bool get () sealed;
}
abstract SupportsFileModification : bool with get
override SupportsFileModification : bool with get
abstract SupportsFileModification : bool with get
override SupportsFileModification : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsFileModification
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities.SupportsFileRenaming Property

SVNFileSystemCapabilities SupportsFileRenaming Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsFileRenaming { get; }
public bool SupportsFileRenaming { get; }
Public ReadOnly Property SupportsFileRenaming As Boolean
    Get
Public ReadOnly Property SupportsFileRenaming As Boolean
    Get
public:
virtual property bool SupportsFileRenaming {
    bool get () sealed;
}
public:
virtual property bool SupportsFileRenaming {
    bool get () sealed;
}
abstract SupportsFileRenaming : bool with get
override SupportsFileRenaming : bool with get
abstract SupportsFileRenaming : bool with get
override SupportsFileRenaming : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsFileRenaming
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities.SupportsFileSizes Property

SVNFileSystemCapabilities SupportsFileSizes Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsFileSizes { get; }
public bool SupportsFileSizes { get; }
Public ReadOnly Property SupportsFileSizes As Boolean
    Get
Public ReadOnly Property SupportsFileSizes As Boolean
    Get
public:
virtual property bool SupportsFileSizes {
    bool get () sealed;
}
public:
virtual property bool SupportsFileSizes {
    bool get () sealed;
}
abstract SupportsFileSizes : bool with get
override SupportsFileSizes : bool with get
abstract SupportsFileSizes : bool with get
override SupportsFileSizes : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsFileSizes
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities.SupportsLastAccessTimestamps Property

SVNFileSystemCapabilities SupportsLastAccessTimestamps Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsLastAccessTimestamps { get; }
public bool SupportsLastAccessTimestamps { get; }
Public ReadOnly Property SupportsLastAccessTimestamps As Boolean
    Get
Public ReadOnly Property SupportsLastAccessTimestamps As Boolean
    Get
public:
virtual property bool SupportsLastAccessTimestamps {
    bool get () sealed;
}
public:
virtual property bool SupportsLastAccessTimestamps {
    bool get () sealed;
}
abstract SupportsLastAccessTimestamps : bool with get
override SupportsLastAccessTimestamps : bool with get
abstract SupportsLastAccessTimestamps : bool with get
override SupportsLastAccessTimestamps : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsLastAccessTimestamps
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities.SupportsLastAccessUserNames Property

SVNFileSystemCapabilities SupportsLastAccessUserNames Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsLastAccessUserNames { get; }
public bool SupportsLastAccessUserNames { get; }
Public ReadOnly Property SupportsLastAccessUserNames As Boolean
    Get
Public ReadOnly Property SupportsLastAccessUserNames As Boolean
    Get
public:
virtual property bool SupportsLastAccessUserNames {
    bool get () sealed;
}
public:
virtual property bool SupportsLastAccessUserNames {
    bool get () sealed;
}
abstract SupportsLastAccessUserNames : bool with get
override SupportsLastAccessUserNames : bool with get
abstract SupportsLastAccessUserNames : bool with get
override SupportsLastAccessUserNames : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsLastAccessUserNames
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities.SupportsModificationTimestamps Property

SVNFileSystemCapabilities SupportsModificationTimestamps Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsModificationTimestamps { get; }
public bool SupportsModificationTimestamps { get; }
Public ReadOnly Property SupportsModificationTimestamps As Boolean
    Get
Public ReadOnly Property SupportsModificationTimestamps As Boolean
    Get
public:
virtual property bool SupportsModificationTimestamps {
    bool get () sealed;
}
public:
virtual property bool SupportsModificationTimestamps {
    bool get () sealed;
}
abstract SupportsModificationTimestamps : bool with get
override SupportsModificationTimestamps : bool with get
abstract SupportsModificationTimestamps : bool with get
override SupportsModificationTimestamps : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsModificationTimestamps
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities.SupportsModificationUserNames Property

SVNFileSystemCapabilities SupportsModificationUserNames Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsModificationUserNames { get; }
public bool SupportsModificationUserNames { get; }
Public ReadOnly Property SupportsModificationUserNames As Boolean
    Get
Public ReadOnly Property SupportsModificationUserNames As Boolean
    Get
public:
virtual property bool SupportsModificationUserNames {
    bool get () sealed;
}
public:
virtual property bool SupportsModificationUserNames {
    bool get () sealed;
}
abstract SupportsModificationUserNames : bool with get
override SupportsModificationUserNames : bool with get
abstract SupportsModificationUserNames : bool with get
override SupportsModificationUserNames : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsModificationUserNames
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities.SupportsReadonlyDirectories Property

SVNFileSystemCapabilities SupportsReadonlyDirectories Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsReadonlyDirectories { get; }
public bool SupportsReadonlyDirectories { get; }
Public ReadOnly Property SupportsReadonlyDirectories As Boolean
    Get
Public ReadOnly Property SupportsReadonlyDirectories As Boolean
    Get
public:
virtual property bool SupportsReadonlyDirectories {
    bool get () sealed;
}
public:
virtual property bool SupportsReadonlyDirectories {
    bool get () sealed;
}
abstract SupportsReadonlyDirectories : bool with get
override SupportsReadonlyDirectories : bool with get
abstract SupportsReadonlyDirectories : bool with get
override SupportsReadonlyDirectories : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsReadonlyDirectories
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities.SupportsReadonlyFiles Property

SVNFileSystemCapabilities SupportsReadonlyFiles Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsReadonlyFiles { get; }
public bool SupportsReadonlyFiles { get; }
Public ReadOnly Property SupportsReadonlyFiles As Boolean
    Get
Public ReadOnly Property SupportsReadonlyFiles As Boolean
    Get
public:
virtual property bool SupportsReadonlyFiles {
    bool get () sealed;
}
public:
virtual property bool SupportsReadonlyFiles {
    bool get () sealed;
}
abstract SupportsReadonlyFiles : bool with get
override SupportsReadonlyFiles : bool with get
abstract SupportsReadonlyFiles : bool with get
override SupportsReadonlyFiles : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsReadonlyFiles
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities.SupportsSecurity Property

SVNFileSystemCapabilities SupportsSecurity Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsSecurity { get; }
public bool SupportsSecurity { get; }
Public ReadOnly Property SupportsSecurity As Boolean
    Get
Public ReadOnly Property SupportsSecurity As Boolean
    Get
public:
virtual property bool SupportsSecurity {
    bool get () sealed;
}
public:
virtual property bool SupportsSecurity {
    bool get () sealed;
}
abstract SupportsSecurity : bool with get
override SupportsSecurity : bool with get
abstract SupportsSecurity : bool with get
override SupportsSecurity : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsSecurity
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities.SupportsStreamSeek Property

SVNFileSystemCapabilities SupportsStreamSeek Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsStreamSeek { get; }
public bool SupportsStreamSeek { get; }
Public ReadOnly Property SupportsStreamSeek As Boolean
    Get
Public ReadOnly Property SupportsStreamSeek As Boolean
    Get
public:
virtual property bool SupportsStreamSeek {
    bool get () sealed;
}
public:
virtual property bool SupportsStreamSeek {
    bool get () sealed;
}
abstract SupportsStreamSeek : bool with get
override SupportsStreamSeek : bool with get
abstract SupportsStreamSeek : bool with get
override SupportsStreamSeek : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsStreamSeek
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities.SupportsTransactions Property

SVNFileSystemCapabilities SupportsTransactions Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsTransactions { get; }
public bool SupportsTransactions { get; }
Public ReadOnly Property SupportsTransactions As Boolean
    Get
Public ReadOnly Property SupportsTransactions As Boolean
    Get
public:
virtual property bool SupportsTransactions {
    bool get () sealed;
}
public:
virtual property bool SupportsTransactions {
    bool get () sealed;
}
abstract SupportsTransactions : bool with get
override SupportsTransactions : bool with get
abstract SupportsTransactions : bool with get
override SupportsTransactions : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsTransactions
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemCapabilities.SupportsVersioning Property

SVNFileSystemCapabilities SupportsVersioning Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SupportsVersioning { get; }
public bool SupportsVersioning { get; }
Public ReadOnly Property SupportsVersioning As Boolean
    Get
Public ReadOnly Property SupportsVersioning As Boolean
    Get
public:
virtual property bool SupportsVersioning {
    bool get () sealed;
}
public:
virtual property bool SupportsVersioning {
    bool get () sealed;
}
abstract SupportsVersioning : bool with get
override SupportsVersioning : bool with get
abstract SupportsVersioning : bool with get
override SupportsVersioning : bool with get

Property Value

Type: Online Boolean

Implements

IFileSystemCapabilities SupportsVersioning
See Also
SVNFileSystemCapabilities Class
SVNFileSystemCapabilities Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSession Class

SVNFileSystemSession Class NFX Class Library

Provides SVN file system connection session
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.IO.FileSystem FileSystemSession
NFX.IO.FileSystem.SVN SVNFileSystemSession

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class SVNFileSystemSession : FileSystemSession
public sealed class SVNFileSystemSession : FileSystemSession
Public NotInheritable Class SVNFileSystemSession
    Inherits FileSystemSession
Public NotInheritable Class SVNFileSystemSession
    Inherits FileSystemSession
public ref class SVNFileSystemSession sealed : public FileSystemSession
public ref class SVNFileSystemSession sealed : public FileSystemSession
[<SealedAttribute>]
type SVNFileSystemSession =
    class
        inherit FileSystemSession
    end
[<SealedAttribute>]
type SVNFileSystemSession =
    class
        inherit FileSystemSession
    end
See Also
SVNFileSystemSession Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSession Members

SVNFileSystemSession Members NFX Class Library

The SVNFileSystemSession type exposes the following members.
Constructors
 | Name | Description
Protected method | SVNFileSystemSession | Initializes a new instance of the SVNFileSystemSession class
Back to Top
Methods
 | Name | Description
Public method | BeginTransaction | Starts a transaction returning its' transaction handle object, otherwise does nothing (Inherited from FileSystemSession.)
Public method | BeginTransactionAsync | Async version of BeginTransaction (Inherited from FileSystemSession.)
Public method | CommitTransaction | Commits active transaction, does nothing otherwise (Inherited from FileSystemSession.)
Public method | CommitTransactionAsync | Async version of CommitTransaction (Inherited from FileSystemSession.)
Protected method | Destructor | (Inherited from FileSystemSession.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetItemAsync | Async version of [P:Item(string)] (Inherited from FileSystemSession.)
Public method | GetLatestVersionAsync | Async version of [P:LatestVersion] (Inherited from FileSystemSession.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetVersions | (Overrides FileSystemSession GetVersions(IFileSystemVersion, Int32).)
Public method | GetVersionsAsync | Async version of GetVersions(IFileSystemVersion, Int32) (Inherited from FileSystemSession.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RollbackTransaction | Cancels active transaction changes, does nothing otherwise (Inherited from FileSystemSession.)
Public method | RollbackTransactionAsync | Async version of RollbackTransaction (Inherited from FileSystemSession.)
Public method | SetFileSystemVersionAsync | Async version of [P:Version] (Inherited from FileSystemSession.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | ValidateConnectParams | (Overrides FileSystemSession ValidateConnectParams(FileSystemSessionConnectParams).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_FileSystem | (Inherited from FileSystemSession.)
Protected field | m_Handle | (Inherited from FileSystemSession.)
Protected field | m_Items | (Inherited from FileSystemSession.)
Protected field | m_Name | (Inherited from FileSystemSession.)
Protected field | m_TransactionHandle | (Inherited from FileSystemSession.)
Protected field | m_User | (Inherited from FileSystemSession.)
Back to Top
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | FileSystem | Returns file system instance that this session operates under (Inherited from FileSystemSession.)
Public property | Handle | Returns file system handle for this session (Inherited from FileSystemSession.)
Public property | Item | Navigates to the specified path (Inherited from FileSystemSession.)
Public property | Items | Returns file system items initialized through this session (Inherited from FileSystemSession.)
Public property | LatestVersion | (Overrides FileSystemSession LatestVersion.)
Public property | Name | Returns session name (Inherited from FileSystemSession.)
Public property | SecurityManager | Returns security manager that services this file system session. This may be useful in cases when file system implements its own permission structure and user directory (Inherited from FileSystemSession.)
Public property | ServerURL | SVN Server URL i.e. 'http://assembla.com/svn/myRepository'
Public property | TransactionHandle | Returns transaction object if transaction has been started or null (Inherited from FileSystemSession.)
Public property | UniqueSequenceProvider | Returns unique sequence provider for the system or null if it is not supported (Inherited from FileSystemSession.)
Public property | User | Returns user that this file system session is for (Inherited from FileSystemSession.)
Public property | UserID | Extracts user ID from User
Public property | UserPassword | Extracts user Password from User
Public property | Version | (Overrides FileSystemSession Version.)
Public property | WebDAV |
Back to Top
See Also
SVNFileSystemSession Class
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSession Constructor

SVNFileSystemSession Constructor NFX Class Library

Initializes a new instance of the SVNFileSystemSession class

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal SVNFileSystemSession(
    SVNFileSystem fs,
    IFileSystemHandle handle,
    SVNFileSystemSessionConnectParams cParams
)
internal SVNFileSystemSession(
    SVNFileSystem fs,
    IFileSystemHandle handle,
    SVNFileSystemSessionConnectParams cParams
)
Friend Sub New (
    fs As SVNFileSystem,
    handle As IFileSystemHandle,
    cParams As SVNFileSystemSessionConnectParams
)
Friend Sub New (
    fs As SVNFileSystem,
    handle As IFileSystemHandle,
    cParams As SVNFileSystemSessionConnectParams
)
internal:
SVNFileSystemSession(
    SVNFileSystem^ fs,
    IFileSystemHandle^ handle,
    SVNFileSystemSessionConnectParams^ cParams
)
internal:
SVNFileSystemSession(
    SVNFileSystem^ fs,
    IFileSystemHandle^ handle,
    SVNFileSystemSessionConnectParams^ cParams
)
new :
        fs : SVNFileSystem *
        handle : IFileSystemHandle *
        cParams : SVNFileSystemSessionConnectParams -> SVNFileSystemSession
new :
        fs : SVNFileSystem *
        handle : IFileSystemHandle *
        cParams : SVNFileSystemSessionConnectParams -> SVNFileSystemSession

Parameters

fs
Type: NFX.IO.FileSystem.SVN SVNFileSystem
handle
Type: NFX.IO.FileSystem IFileSystemHandle
cParams
Type: NFX.IO.FileSystem.SVN SVNFileSystemSessionConnectParams
See Also
SVNFileSystemSession Class
SVNFileSystemSession Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSession Fields

SVNFileSystemSession Fields NFX Class Library

The SVNFileSystemSession type exposes the following members.
Fields
 | Name | Description
Protected field | m_FileSystem | (Inherited from FileSystemSession.)
Protected field | m_Handle | (Inherited from FileSystemSession.)
Protected field | m_Items | (Inherited from FileSystemSession.)
Protected field | m_Name | (Inherited from FileSystemSession.)
Protected field | m_TransactionHandle | (Inherited from FileSystemSession.)
Protected field | m_User | (Inherited from FileSystemSession.)
Back to Top
See Also
SVNFileSystemSession Class
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSession Methods

SVNFileSystemSession Methods NFX Class Library

The SVNFileSystemSession type exposes the following members.
Methods
 | Name | Description
Public method | BeginTransaction | Starts a transaction returning its' transaction handle object, otherwise does nothing (Inherited from FileSystemSession.)
Public method | BeginTransactionAsync | Async version of BeginTransaction (Inherited from FileSystemSession.)
Public method | CommitTransaction | Commits active transaction, does nothing otherwise (Inherited from FileSystemSession.)
Public method | CommitTransactionAsync | Async version of CommitTransaction (Inherited from FileSystemSession.)
Protected method | Destructor | (Inherited from FileSystemSession.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetItemAsync | Async version of [P:Item(string)] (Inherited from FileSystemSession.)
Public method | GetLatestVersionAsync | Async version of [P:LatestVersion] (Inherited from FileSystemSession.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetVersions | (Overrides FileSystemSession GetVersions(IFileSystemVersion, Int32).)
Public method | GetVersionsAsync | Async version of GetVersions(IFileSystemVersion, Int32) (Inherited from FileSystemSession.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RollbackTransaction | Cancels active transaction changes, does nothing otherwise (Inherited from FileSystemSession.)
Public method | RollbackTransactionAsync | Async version of RollbackTransaction (Inherited from FileSystemSession.)
Public method | SetFileSystemVersionAsync | Async version of [P:Version] (Inherited from FileSystemSession.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | ValidateConnectParams | (Overrides FileSystemSession ValidateConnectParams(FileSystemSessionConnectParams).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SVNFileSystemSession Class
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSession.GetVersions Method

SVNFileSystemSession GetVersions Method NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IEnumerable<IFileSystemVersion> GetVersions(
    IFileSystemVersion from,
    int countBack
)
public override IEnumerable<IFileSystemVersion> GetVersions(
    IFileSystemVersion from,
    int countBack
)
Public Overrides Function GetVersions (
    from As IFileSystemVersion,
    countBack As Integer
) As IEnumerable(Of IFileSystemVersion)
Public Overrides Function GetVersions (
    from As IFileSystemVersion,
    countBack As Integer
) As IEnumerable(Of IFileSystemVersion)
public:
virtual IEnumerable<IFileSystemVersion^>^ GetVersions(
    IFileSystemVersion^ from,
    int countBack
) override
public:
virtual IEnumerable<IFileSystemVersion^>^ GetVersions(
    IFileSystemVersion^ from,
    int countBack
) override
abstract GetVersions :
        from : IFileSystemVersion *
        countBack : int -> IEnumerable<IFileSystemVersion>
override GetVersions :
        from : IFileSystemVersion *
        countBack : int -> IEnumerable<IFileSystemVersion>
abstract GetVersions :
        from : IFileSystemVersion *
        countBack : int -> IEnumerable<IFileSystemVersion>
override GetVersions :
        from : IFileSystemVersion *
        countBack : int -> IEnumerable<IFileSystemVersion>

Parameters

from
Type: NFX.IO.FileSystem IFileSystemVersion
countBack
Type: Online System Int32

Return Value

Type: Online IEnumerable IFileSystemVersion
See Also
SVNFileSystemSession Class
SVNFileSystemSession Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSession.ValidateConnectParams Method

SVNFileSystemSession ValidateConnectParams Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void ValidateConnectParams(
    FileSystemSessionConnectParams cParams
)
protected override void ValidateConnectParams(
    FileSystemSessionConnectParams cParams
)
Protected Overrides Sub ValidateConnectParams (
    cParams As FileSystemSessionConnectParams
)
Protected Overrides Sub ValidateConnectParams (
    cParams As FileSystemSessionConnectParams
)
protected:
virtual void ValidateConnectParams(
    FileSystemSessionConnectParams^ cParams
) override
protected:
virtual void ValidateConnectParams(
    FileSystemSessionConnectParams^ cParams
) override
abstract ValidateConnectParams :
        cParams : FileSystemSessionConnectParams -> unit
override ValidateConnectParams :
        cParams : FileSystemSessionConnectParams -> unit
abstract ValidateConnectParams :
        cParams : FileSystemSessionConnectParams -> unit
override ValidateConnectParams :
        cParams : FileSystemSessionConnectParams -> unit

Parameters

cParams
Type: NFX.IO.FileSystem FileSystemSessionConnectParams
See Also
SVNFileSystemSession Class
SVNFileSystemSession Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSession Properties

SVNFileSystemSession Properties NFX Class Library

The SVNFileSystemSession type exposes the following members.
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | FileSystem | Returns file system instance that this session operates under (Inherited from FileSystemSession.)
Public property | Handle | Returns file system handle for this session (Inherited from FileSystemSession.)
Public property | Item | Navigates to the specified path (Inherited from FileSystemSession.)
Public property | Items | Returns file system items initialized through this session (Inherited from FileSystemSession.)
Public property | LatestVersion | (Overrides FileSystemSession LatestVersion.)
Public property | Name | Returns session name (Inherited from FileSystemSession.)
Public property | SecurityManager | Returns security manager that services this file system session. This may be useful in cases when file system implements its own permission structure and user directory (Inherited from FileSystemSession.)
Public property | ServerURL | SVN Server URL i.e. 'http://assembla.com/svn/myRepository'
Public property | TransactionHandle | Returns transaction object if transaction has been started or null (Inherited from FileSystemSession.)
Public property | UniqueSequenceProvider | Returns unique sequence provider for the system or null if it is not supported (Inherited from FileSystemSession.)
Public property | User | Returns user that this file system session is for (Inherited from FileSystemSession.)
Public property | UserID | Extracts user ID from User
Public property | UserPassword | Extracts user Password from User
Public property | Version | (Overrides FileSystemSession Version.)
Public property | WebDAV |
Back to Top
See Also
SVNFileSystemSession Class
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSession.LatestVersion Property

SVNFileSystemSession LatestVersion Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IFileSystemVersion LatestVersion { get; }
public override IFileSystemVersion LatestVersion { get; }
Public Overrides ReadOnly Property LatestVersion As IFileSystemVersion
    Get
Public Overrides ReadOnly Property LatestVersion As IFileSystemVersion
    Get
public:
virtual property IFileSystemVersion^ LatestVersion {
    IFileSystemVersion^ get () override;
}
public:
virtual property IFileSystemVersion^ LatestVersion {
    IFileSystemVersion^ get () override;
}
abstract LatestVersion : IFileSystemVersion with get
override LatestVersion : IFileSystemVersion with get
abstract LatestVersion : IFileSystemVersion with get
override LatestVersion : IFileSystemVersion with get

Property Value

Type: IFileSystemVersion
See Also
SVNFileSystemSession Class
SVNFileSystemSession Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSession.ServerURL Property

SVNFileSystemSession ServerURL Property NFX Class Library

SVN Server URL i.e. 'http://assembla.com/svn/myRepository'

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ServerURL { get; }
public string ServerURL { get; }
Public ReadOnly Property ServerURL As String
    Get
Public ReadOnly Property ServerURL As String
    Get
public:
property String^ ServerURL {
    String^ get ();
}
public:
property String^ ServerURL {
    String^ get ();
}
member ServerURL : string with get
member ServerURL : string with get

Property Value

Type: Online String
See Also
SVNFileSystemSession Class
SVNFileSystemSession Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSession.UserID Property

SVNFileSystemSession UserID Property NFX Class Library

Extracts user ID from User

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string UserID { get; }
public string UserID { get; }
Public ReadOnly Property UserID As String
    Get
Public ReadOnly Property UserID As String
    Get
public:
property String^ UserID {
    String^ get ();
}
public:
property String^ UserID {
    String^ get ();
}
member UserID : string with get
member UserID : string with get

Property Value

Type: Online String
See Also
SVNFileSystemSession Class
SVNFileSystemSession Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSession.UserPassword Property

SVNFileSystemSession UserPassword Property NFX Class Library

Extracts user Password from User

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string UserPassword { get; }
public string UserPassword { get; }
Public ReadOnly Property UserPassword As String
    Get
Public ReadOnly Property UserPassword As String
    Get
public:
property String^ UserPassword {
    String^ get ();
}
public:
property String^ UserPassword {
    String^ get ();
}
member UserPassword : string with get
member UserPassword : string with get

Property Value

Type: Online String
See Also
SVNFileSystemSession Class
SVNFileSystemSession Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSession.Version Property

SVNFileSystemSession Version Property NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IFileSystemVersion Version { get; set; }
public override IFileSystemVersion Version { get; set; }
Public Overrides Property Version As IFileSystemVersion
    Get
    Set
Public Overrides Property Version As IFileSystemVersion
    Get
    Set
public:
virtual property IFileSystemVersion^ Version {
    IFileSystemVersion^ get () override;
    void set (IFileSystemVersion^ value) override;
}
public:
virtual property IFileSystemVersion^ Version {
    IFileSystemVersion^ get () override;
    void set (IFileSystemVersion^ value) override;
}
abstract Version : IFileSystemVersion with get, set
override Version : IFileSystemVersion with get, set
abstract Version : IFileSystemVersion with get, set
override Version : IFileSystemVersion with get, set

Property Value

Type: IFileSystemVersion
See Also
SVNFileSystemSession Class
SVNFileSystemSession Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSession.WebDAV Property

SVNFileSystemSession WebDAV Property NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WebDAV WebDAV { get; }
public WebDAV WebDAV { get; }
Public ReadOnly Property WebDAV As WebDAV
    Get
Public ReadOnly Property WebDAV As WebDAV
    Get
public:
property WebDAV^ WebDAV {
    WebDAV^ get ();
}
public:
property WebDAV^ WebDAV {
    WebDAV^ get ();
}
member WebDAV : WebDAV with get
member WebDAV : WebDAV with get

Property Value

Type: WebDAV
See Also
SVNFileSystemSession Class
SVNFileSystemSession Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSessionConnectParams Class

SVNFileSystemSessionConnectParams Class NFX Class Library

Provides connection parameters specific to SVNFIleSystemSession
Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem FileSystemSessionConnectParams
NFX.IO.FileSystem.SVN SVNFileSystemSessionConnectParams

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SVNFileSystemSessionConnectParams : FileSystemSessionConnectParams
public class SVNFileSystemSessionConnectParams : FileSystemSessionConnectParams
Public Class SVNFileSystemSessionConnectParams
    Inherits FileSystemSessionConnectParams
Public Class SVNFileSystemSessionConnectParams
    Inherits FileSystemSessionConnectParams
public ref class SVNFileSystemSessionConnectParams : public FileSystemSessionConnectParams
public ref class SVNFileSystemSessionConnectParams : public FileSystemSessionConnectParams
type SVNFileSystemSessionConnectParams =
    class
        inherit FileSystemSessionConnectParams
    end
type SVNFileSystemSessionConnectParams =
    class
        inherit FileSystemSessionConnectParams
    end
See Also
SVNFileSystemSessionConnectParams Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSessionConnectParams Members

SVNFileSystemSessionConnectParams Members NFX Class Library

The SVNFileSystemSessionConnectParams type exposes the following members.
Constructors
 | Name | Description
Public method | SVNFileSystemSessionConnectParams | Initializes a new instance of the SVNFileSystemSessionConnectParams class
Public method | SVNFileSystemSessionConnectParams(IConfigSectionNode) | Initializes a new instance of the SVNFileSystemSessionConnectParams class
Public method | SVNFileSystemSessionConnectParams(String, String) | Initializes a new instance of the SVNFileSystemSessionConnectParams class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Overrides FileSystemSessionConnectParams Configure(IConfigSectionNode).)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_SERVERURL_ATTR |
CONFIG_TIMEOUT_MS_ATTR |
CONFIG_UNAME_ATTR |
CONFIG_UPWD_ATTR |
Back to Top
Properties
 | Name | Description
Public property | Name | (Inherited from FileSystemSessionConnectParams.)
Public property | ServerURL | SVN Server URL i.e. 'http://assembla.com/svn/myRepository'
Public property | TimeoutMs | Request timeout milliseconds
Public property | User | (Inherited from FileSystemSessionConnectParams.)
Public property | Version | (Inherited from FileSystemSessionConnectParams.)
Back to Top
See Also
SVNFileSystemSessionConnectParams Class
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSessionConnectParams Constructor

SVNFileSystemSessionConnectParams Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public method | SVNFileSystemSessionConnectParams | Initializes a new instance of the SVNFileSystemSessionConnectParams class
Public method | SVNFileSystemSessionConnectParams(IConfigSectionNode) | Initializes a new instance of the SVNFileSystemSessionConnectParams class
Public method | SVNFileSystemSessionConnectParams(String, String) | Initializes a new instance of the SVNFileSystemSessionConnectParams class
Back to Top
See Also
SVNFileSystemSessionConnectParams Class
SVNFileSystemSessionConnectParams Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSessionConnectParams Constructor

SVNFileSystemSessionConnectParams Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SVNFileSystemSessionConnectParams class

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SVNFileSystemSessionConnectParams()
public SVNFileSystemSessionConnectParams()
Public Sub New
Public Sub New
public:
SVNFileSystemSessionConnectParams()
public:
SVNFileSystemSessionConnectParams()
new : unit -> SVNFileSystemSessionConnectParams
new : unit -> SVNFileSystemSessionConnectParams
See Also
SVNFileSystemSessionConnectParams Class
SVNFileSystemSessionConnectParams Members
SVNFileSystemSessionConnectParams Overload
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSessionConnectParams Constructor (IConfigSectionNode)

SVNFileSystemSessionConnectParams Constructor (IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SVNFileSystemSessionConnectParams class

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SVNFileSystemSessionConnectParams(
    IConfigSectionNode node
)
public SVNFileSystemSessionConnectParams(
    IConfigSectionNode node
)
Public Sub New (
    node As IConfigSectionNode
)
Public Sub New (
    node As IConfigSectionNode
)
public:
SVNFileSystemSessionConnectParams(
    IConfigSectionNode^ node
)
public:
SVNFileSystemSessionConnectParams(
    IConfigSectionNode^ node
)
new :
        node : IConfigSectionNode -> SVNFileSystemSessionConnectParams
new :
        node : IConfigSectionNode -> SVNFileSystemSessionConnectParams

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
SVNFileSystemSessionConnectParams Class
SVNFileSystemSessionConnectParams Members
SVNFileSystemSessionConnectParams Overload
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSessionConnectParams Constructor (String, String)

SVNFileSystemSessionConnectParams Constructor (String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SVNFileSystemSessionConnectParams class

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SVNFileSystemSessionConnectParams(
    string connectString,
    string format = "laconf"
)
public SVNFileSystemSessionConnectParams(
    string connectString,
    string format = "laconf"
)
Public Sub New (
    connectString As String,
    Optional format As String = "laconf"
)
Public Sub New (
    connectString As String,
    Optional format As String = "laconf"
)
public:
SVNFileSystemSessionConnectParams(
    String^ connectString,
    String^ format = L"laconf"
)
public:
SVNFileSystemSessionConnectParams(
    String^ connectString,
    String^ format = L"laconf"
)
new :
        connectString : string *
        ?format : string
(* Defaults:
        let _format = defaultArg format "laconf"
*)
-> SVNFileSystemSessionConnectParams
new :
        connectString : string *
        ?format : string
(* Defaults:
        let _format = defaultArg format "laconf"
*)
-> SVNFileSystemSessionConnectParams

Parameters

connectString
Type: Online System String
format (Optional)
Type: Online System String
See Also
SVNFileSystemSessionConnectParams Class
SVNFileSystemSessionConnectParams Members
SVNFileSystemSessionConnectParams Overload
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSessionConnectParams Fields

SVNFileSystemSessionConnectParams Fields NFX Class Library

The SVNFileSystemSessionConnectParams type exposes the following members.
Fields
Name | Description
CONFIG_SERVERURL_ATTR |
CONFIG_TIMEOUT_MS_ATTR |
CONFIG_UNAME_ATTR |
CONFIG_UPWD_ATTR |
Back to Top
See Also
SVNFileSystemSessionConnectParams Class
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSessionConnectParams.CONFIG_SERVERURL_ATTR Field

SVNFileSystemSessionConnectParams CONFIG_SERVERURL_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SERVERURL_ATTR
public const string CONFIG_SERVERURL_ATTR
Public Const CONFIG_SERVERURL_ATTR As String
Public Const CONFIG_SERVERURL_ATTR As String
public:
literal String^ CONFIG_SERVERURL_ATTR
public:
literal String^ CONFIG_SERVERURL_ATTR
static val mutable CONFIG_SERVERURL_ATTR: string
static val mutable CONFIG_SERVERURL_ATTR: string

Field Value

Type: Online String
See Also
SVNFileSystemSessionConnectParams Class
SVNFileSystemSessionConnectParams Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSessionConnectParams.CONFIG_TIMEOUT_MS_ATTR Field

SVNFileSystemSessionConnectParams CONFIG_TIMEOUT_MS_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_TIMEOUT_MS_ATTR
public const string CONFIG_TIMEOUT_MS_ATTR
Public Const CONFIG_TIMEOUT_MS_ATTR As String
Public Const CONFIG_TIMEOUT_MS_ATTR As String
public:
literal String^ CONFIG_TIMEOUT_MS_ATTR
public:
literal String^ CONFIG_TIMEOUT_MS_ATTR
static val mutable CONFIG_TIMEOUT_MS_ATTR: string
static val mutable CONFIG_TIMEOUT_MS_ATTR: string

Field Value

Type: Online String
See Also
SVNFileSystemSessionConnectParams Class
SVNFileSystemSessionConnectParams Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSessionConnectParams.CONFIG_UNAME_ATTR Field

SVNFileSystemSessionConnectParams CONFIG_UNAME_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_UNAME_ATTR
public const string CONFIG_UNAME_ATTR
Public Const CONFIG_UNAME_ATTR As String
Public Const CONFIG_UNAME_ATTR As String
public:
literal String^ CONFIG_UNAME_ATTR
public:
literal String^ CONFIG_UNAME_ATTR
static val mutable CONFIG_UNAME_ATTR: string
static val mutable CONFIG_UNAME_ATTR: string

Field Value

Type: Online String
See Also
SVNFileSystemSessionConnectParams Class
SVNFileSystemSessionConnectParams Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSessionConnectParams.CONFIG_UPWD_ATTR Field

SVNFileSystemSessionConnectParams CONFIG_UPWD_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_UPWD_ATTR
public const string CONFIG_UPWD_ATTR
Public Const CONFIG_UPWD_ATTR As String
Public Const CONFIG_UPWD_ATTR As String
public:
literal String^ CONFIG_UPWD_ATTR
public:
literal String^ CONFIG_UPWD_ATTR
static val mutable CONFIG_UPWD_ATTR: string
static val mutable CONFIG_UPWD_ATTR: string

Field Value

Type: Online String
See Also
SVNFileSystemSessionConnectParams Class
SVNFileSystemSessionConnectParams Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSessionConnectParams Methods

SVNFileSystemSessionConnectParams Methods NFX Class Library

The SVNFileSystemSessionConnectParams type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Overrides FileSystemSessionConnectParams Configure(IConfigSectionNode).)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SVNFileSystemSessionConnectParams Class
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSessionConnectParams.Configure Method

SVNFileSystemSessionConnectParams Configure Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Configure(
    IConfigSectionNode node
)
public override void Configure(
    IConfigSectionNode node
)
Public Overrides Sub Configure (
    node As IConfigSectionNode
)
Public Overrides Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) override
public:
virtual void Configure(
    IConfigSectionNode^ node
) override
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
SVNFileSystemSessionConnectParams Class
SVNFileSystemSessionConnectParams Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSessionConnectParams Properties

SVNFileSystemSessionConnectParams Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The SVNFileSystemSessionConnectParams type exposes the following members.
Properties
 | Name | Description
Public property | Name | (Inherited from FileSystemSessionConnectParams.)
Public property | ServerURL | SVN Server URL i.e. 'http://assembla.com/svn/myRepository'
Public property | TimeoutMs | Request timeout milliseconds
Public property | User | (Inherited from FileSystemSessionConnectParams.)
Public property | Version | (Inherited from FileSystemSessionConnectParams.)
Back to Top
See Also
SVNFileSystemSessionConnectParams Class
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSessionConnectParams.ServerURL Property

SVNFileSystemSessionConnectParams ServerURL Property NFX Class Library

[This is preliminary documentation and is subject to change.]

SVN Server URL i.e. 'http://assembla.com/svn/myRepository'

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string ServerURL { get; set; }
[ConfigAttribute]
public string ServerURL { get; set; }
<ConfigAttribute>
Public Property ServerURL As String
    Get
    Set
<ConfigAttribute>
Public Property ServerURL As String
    Get
    Set
public:
[ConfigAttribute]
property String^ ServerURL {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ ServerURL {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member ServerURL : string with get, set
[<ConfigAttribute>]
member ServerURL : string with get, set

Property Value

Type: Online String
See Also
SVNFileSystemSessionConnectParams Class
SVNFileSystemSessionConnectParams Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemSessionConnectParams.TimeoutMs Property

SVNFileSystemSessionConnectParams TimeoutMs Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Request timeout milliseconds

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int TimeoutMs { get; set; }
[ConfigAttribute]
public int TimeoutMs { get; set; }
<ConfigAttribute>
Public Property TimeoutMs As Integer
    Get
    Set
<ConfigAttribute>
Public Property TimeoutMs As Integer
    Get
    Set
public:
[ConfigAttribute]
property int TimeoutMs {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute]
property int TimeoutMs {
    int get ();
    void set (int value);
}
[<ConfigAttribute>]
member TimeoutMs : int with get, set
[<ConfigAttribute>]
member TimeoutMs : int with get, set

Property Value

Type: Online Int32
See Also
SVNFileSystemSessionConnectParams Class
SVNFileSystemSessionConnectParams Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemStream Class

SVNFileSystemStream Class NFX Class Library

Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.IO Stream
NFX.IO.FileSystem FileSystemStream
NFX.IO.FileSystem.SVN SVNFileSystemStream

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SVNFileSystemStream : FileSystemStream
public class SVNFileSystemStream : FileSystemStream
Public Class SVNFileSystemStream
    Inherits FileSystemStream
Public Class SVNFileSystemStream
    Inherits FileSystemStream
public ref class SVNFileSystemStream : public FileSystemStream
public ref class SVNFileSystemStream : public FileSystemStream
type SVNFileSystemStream =
    class
        inherit FileSystemStream
    end
type SVNFileSystemStream =
    class
        inherit FileSystemStream
    end
See Also
SVNFileSystemStream Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemStream Members

SVNFileSystemStream Members NFX Class Library

The SVNFileSystemStream type exposes the following members.
Constructors
 | Name | Description
Public method | SVNFileSystemStream | Initializes a new instance of the SVNFileSystemStream class
Back to Top
Methods
 | Name | Description
Public method | Online BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Online Stream.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Protected method | Online CreateWaitHandle | Obsolete. Allocates a Online WaitHandle object. (Inherited from Online Stream.)
Public method | Online Dispose | Releases all resources used by the Online Stream. (Inherited from Online Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the SVNFileSystemStream and optionally releases the managed resources (Overrides FileSystemStream Dispose(Boolean).)
Protected method | DoFlush | (Overrides FileSystemStream DoFlush .)
Protected method | DoGetLength | (Overrides FileSystemStream DoGetLength .)
Protected method | DoGetPosition | (Overrides FileSystemStream DoGetPosition .)
Protected method | DoRead | (Overrides FileSystemStream DoRead( Byte , Int32, Int32).)
Protected method | DoSeek | (Overrides FileSystemStream DoSeek(Int64, SeekOrigin).)
Protected method | DoSetLength | (Overrides FileSystemStream DoSetLength(Int64).)
Protected method | DoSetPosition | (Overrides FileSystemStream DoSetPosition(Int64).)
Protected method | DoWrite | (Overrides FileSystemStream DoWrite( Byte , Int32, Int32).)
Public method | Online EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Inherited from FileSystemStream.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Online Stream.)
Public method | FlushAsync(CancellationToken) | (Inherited from FileSystemStream.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Online Stream.)
Public method | Read | (Inherited from FileSystemStream.)
Public method | ReadAsync( Byte , Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Online Stream.)
Public method | ReadAsync( Byte , Int32, Int32, CancellationToken) | (Inherited from FileSystemStream.)
Public method | Online ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Online Stream.)
Public method | Seek | (Inherited from FileSystemStream.)
Public method | SetLength | (Inherited from FileSystemStream.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write | (Inherited from FileSystemStream.)
Public method | WriteAsync( Byte , Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Online Stream.)
Public method | WriteAsync( Byte , Int32, Int32, CancellationToken) | (Inherited from FileSystemStream.)
Public method | Online WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Online Stream.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsCharEnumerable | (Defined by IOMiscUtils.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Public Extension Method | ReadBEInt32 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEShort | Reads a short encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUInt64 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUShort | Reads an ushort encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadSLEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadSLEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | WriteBEInt32 | Writes an integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEShort | Writes a short encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUInt64 | Writes an unsigned long integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUShort | Writes an ushort encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteSLEB128(Int64, Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteSLEB128(Int64, Int32 , Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, UInt32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, Int32 , UInt32) | Overloaded. (Defined by LEB128.)
Back to Top
Fields
 | Name | Description
Public field | Item | Item that this stream is for (Inherited from FileSystemStream.)
Back to Top
Properties
 | Name | Description
Public property | CanRead | (Inherited from FileSystemStream.)
Public property | CanSeek | (Inherited from FileSystemStream.)
Public property | Online CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Online Stream.)
Public property | CanWrite | (Inherited from FileSystemStream.)
Public property | Length | (Inherited from FileSystemStream.)
Public property | Position | (Inherited from FileSystemStream.)
Public property | Online ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Online Stream.)
Public property | Online WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Online Stream.)
Back to Top
See Also
SVNFileSystemStream Class
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemStream Constructor

SVNFileSystemStream Constructor NFX Class Library

Initializes a new instance of the SVNFileSystemStream class

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SVNFileSystemStream(
    FileSystemFile file,
    Action<FileSystemStream> disposeAction
)
public SVNFileSystemStream(
    FileSystemFile file,
    Action<FileSystemStream> disposeAction
)
Public Sub New (
    file As FileSystemFile,
    disposeAction As Action(Of FileSystemStream)
)
Public Sub New (
    file As FileSystemFile,
    disposeAction As Action(Of FileSystemStream)
)
public:
SVNFileSystemStream(
    FileSystemFile^ file,
    Action<FileSystemStream^>^ disposeAction
)
public:
SVNFileSystemStream(
    FileSystemFile^ file,
    Action<FileSystemStream^>^ disposeAction
)
new :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> SVNFileSystemStream
new :
        file : FileSystemFile *
        disposeAction : Action<FileSystemStream> -> SVNFileSystemStream

Parameters

file
Type: NFX.IO.FileSystem FileSystemFile
disposeAction
Type: Online System Action FileSystemStream
See Also
SVNFileSystemStream Class
SVNFileSystemStream Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemStream Fields

SVNFileSystemStream Fields NFX Class Library

The SVNFileSystemStream type exposes the following members.
Fields
 | Name | Description
Public field | Item | Item that this stream is for (Inherited from FileSystemStream.)
Back to Top
See Also
SVNFileSystemStream Class
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemStream Methods

SVNFileSystemStream Methods NFX Class Library

The SVNFileSystemStream type exposes the following members.
Methods
 | Name | Description
Public method | Online BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | Online CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Online Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Online Stream.)
Public method | Online CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from Online MarshalByRefObject.)
Protected method | Online CreateWaitHandle | Obsolete. Allocates a Online WaitHandle object. (Inherited from Online Stream.)
Public method | Online Dispose | Releases all resources used by the Online Stream. (Inherited from Online Stream.)
Protected method | Dispose(Boolean) | (Overrides FileSystemStream Dispose(Boolean).)
Protected method | DoFlush | (Overrides FileSystemStream DoFlush .)
Protected method | DoGetLength | (Overrides FileSystemStream DoGetLength .)
Protected method | DoGetPosition | (Overrides FileSystemStream DoGetPosition .)
Protected method | DoRead | (Overrides FileSystemStream DoRead( Byte , Int32, Int32).)
Protected method | DoSeek | (Overrides FileSystemStream DoSeek(Int64, SeekOrigin).)
Protected method | DoSetLength | (Overrides FileSystemStream DoSetLength(Int64).)
Protected method | DoSetPosition | (Overrides FileSystemStream DoSetPosition(Int64).)
Protected method | DoWrite | (Overrides FileSystemStream DoWrite( Byte , Int32, Int32).)
Public method | Online EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync( Byte , Int32, Int32) instead; see the Remarks section.) (Inherited from Online Stream.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush | (Inherited from FileSystemStream.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Online Stream.)
Public method | FlushAsync(CancellationToken) | (Inherited from FileSystemStream.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from Online MarshalByRefObject.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Online MemberwiseClone(Boolean) | Creates a shallow copy of the current Online MarshalByRefObject object. (Inherited from Online MarshalByRefObject.)
Protected method | Online ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Online Stream.)
Public method | Read | (Inherited from FileSystemStream.)
Public method | ReadAsync( Byte , Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Online Stream.)
Public method | ReadAsync( Byte , Int32, Int32, CancellationToken) | (Inherited from FileSystemStream.)
Public method | Online ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Online Stream.)
Public method | Seek | (Inherited from FileSystemStream.)
Public method | SetLength | (Inherited from FileSystemStream.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write | (Inherited from FileSystemStream.)
Public method | WriteAsync( Byte , Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Online Stream.)
Public method | WriteAsync( Byte , Int32, Int32, CancellationToken) | (Inherited from FileSystemStream.)
Public method | Online WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Online Stream.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsCharEnumerable | (Defined by IOMiscUtils.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | JSONToDataObject | Deserializes JSON content into IJSONDataObject (Defined by JSONExtensions.)
Public Extension Method | JSONToDynamic | Deserializes JSON content into dynamic JSON object (Defined by JSONExtensions.)
Public Extension Method | ReadBEInt32 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEShort | Reads a short encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUInt64 | Reads an integer encoded as big endian from buffer at the specified index (Defined by IOMiscUtils.)
Public Extension Method | ReadBEUShort | Reads an ushort encoded as big endian from stream (Defined by IOMiscUtils.)
Public Extension Method | ReadSLEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadSLEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128 | Overloaded. (Defined by LEB128.)
Public Extension Method | ReadULEB128(Int32 ) | Overloaded. (Defined by LEB128.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | WriteBEInt32 | Writes an integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEShort | Writes a short encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUInt64 | Writes an unsigned long integer encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteBEUShort | Writes an ushort encoded as big endian to the given stream (Defined by IOMiscUtils.)
Public Extension Method | WriteSLEB128(Int64, Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteSLEB128(Int64, Int32 , Int32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, UInt32) | Overloaded. (Defined by LEB128.)
Public Extension Method | WriteULEB128(UInt64, Int32 , UInt32) | Overloaded. (Defined by LEB128.)
Back to Top
See Also
SVNFileSystemStream Class
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemStream.Dispose Method

SVNFileSystemStream Dispose Method NFX Class Library

Overload List
 | Name | Description
Public method | Online Dispose | Releases all resources used by the Online Stream. (Inherited from Online Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the SVNFileSystemStream and optionally releases the managed resources (Overrides FileSystemStream Dispose(Boolean).)
Back to Top
See Also
SVNFileSystemStream Class
SVNFileSystemStream Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemStream.Dispose Method (Boolean)

SVNFileSystemStream Dispose Method (Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Releases the unmanaged resources used by the SVNFileSystemStream and optionally releases the managed resources

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Dispose(
    bool disposing
)
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: Online System Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also
SVNFileSystemStream Class
SVNFileSystemStream Members
Dispose Overload
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemStream.DoFlush Method

SVNFileSystemStream DoFlush Method NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoFlush()
protected override void DoFlush()
Protected Overrides Sub DoFlush
Protected Overrides Sub DoFlush
protected:
virtual void DoFlush() override
protected:
virtual void DoFlush() override
abstract DoFlush : unit -> unit
override DoFlush : unit -> unit
abstract DoFlush : unit -> unit
override DoFlush : unit -> unit
See Also
SVNFileSystemStream Class
SVNFileSystemStream Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemStream.DoGetLength Method

SVNFileSystemStream DoGetLength Method NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override long DoGetLength()
protected override long DoGetLength()
Protected Overrides Function DoGetLength As Long
Protected Overrides Function DoGetLength As Long
protected:
virtual long long DoGetLength() override
protected:
virtual long long DoGetLength() override
abstract DoGetLength : unit -> int64
override DoGetLength : unit -> int64
abstract DoGetLength : unit -> int64
override DoGetLength : unit -> int64

Return Value

Type: Online Int64
See Also
SVNFileSystemStream Class
SVNFileSystemStream Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemStream.DoGetPosition Method

SVNFileSystemStream DoGetPosition Method NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override long DoGetPosition()
protected override long DoGetPosition()
Protected Overrides Function DoGetPosition As Long
Protected Overrides Function DoGetPosition As Long
protected:
virtual long long DoGetPosition() override
protected:
virtual long long DoGetPosition() override
abstract DoGetPosition : unit -> int64
override DoGetPosition : unit -> int64
abstract DoGetPosition : unit -> int64
override DoGetPosition : unit -> int64

Return Value

Type: Online Int64
See Also
SVNFileSystemStream Class
SVNFileSystemStream Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemStream.DoRead Method

SVNFileSystemStream DoRead Method NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override int DoRead(
    byte[] buffer,
    int offset,
    int count
)
protected override int DoRead(
    byte[] buffer,
    int offset,
    int count
)
Protected Overrides Function DoRead (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
Protected Overrides Function DoRead (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
protected:
virtual int DoRead(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
protected:
virtual int DoRead(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract DoRead :
        buffer : byte[] *
        offset : int *
        count : int -> int
override DoRead :
        buffer : byte[] *
        offset : int *
        count : int -> int
abstract DoRead :
        buffer : byte[] *
        offset : int *
        count : int -> int
override DoRead :
        buffer : byte[] *
        offset : int *
        count : int -> int

Parameters

buffer
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32

Return Value

Type: Online Int32
See Also
SVNFileSystemStream Class
SVNFileSystemStream Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemStream.DoSeek Method

SVNFileSystemStream DoSeek Method NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override long DoSeek(
    long offset,
    SeekOrigin origin
)
protected override long DoSeek(
    long offset,
    SeekOrigin origin
)
Protected Overrides Function DoSeek (
    offset As Long,
    origin As SeekOrigin
) As Long
Protected Overrides Function DoSeek (
    offset As Long,
    origin As SeekOrigin
) As Long
protected:
virtual long long DoSeek(
    long long offset,
    SeekOrigin origin
) override
protected:
virtual long long DoSeek(
    long long offset,
    SeekOrigin origin
) override
abstract DoSeek :
        offset : int64 *
        origin : SeekOrigin -> int64
override DoSeek :
        offset : int64 *
        origin : SeekOrigin -> int64
abstract DoSeek :
        offset : int64 *
        origin : SeekOrigin -> int64
override DoSeek :
        offset : int64 *
        origin : SeekOrigin -> int64

Parameters

offset
Type: Online System Int64
origin
Type: Online System.IO SeekOrigin

Return Value

Type: Online Int64
See Also
SVNFileSystemStream Class
SVNFileSystemStream Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemStream.DoSetLength Method

SVNFileSystemStream DoSetLength Method NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSetLength(
    long value
)
protected override void DoSetLength(
    long value
)
Protected Overrides Sub DoSetLength (
    value As Long
)
Protected Overrides Sub DoSetLength (
    value As Long
)
protected:
virtual void DoSetLength(
    long long value
) override
protected:
virtual void DoSetLength(
    long long value
) override
abstract DoSetLength :
        value : int64 -> unit
override DoSetLength :
        value : int64 -> unit
abstract DoSetLength :
        value : int64 -> unit
override DoSetLength :
        value : int64 -> unit

Parameters

value
Type: Online System Int64
See Also
SVNFileSystemStream Class
SVNFileSystemStream Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemStream.DoSetPosition Method

SVNFileSystemStream DoSetPosition Method NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSetPosition(
    long position
)
protected override void DoSetPosition(
    long position
)
Protected Overrides Sub DoSetPosition (
    position As Long
)
Protected Overrides Sub DoSetPosition (
    position As Long
)
protected:
virtual void DoSetPosition(
    long long position
) override
protected:
virtual void DoSetPosition(
    long long position
) override
abstract DoSetPosition :
        position : int64 -> unit
override DoSetPosition :
        position : int64 -> unit
abstract DoSetPosition :
        position : int64 -> unit
override DoSetPosition :
        position : int64 -> unit

Parameters

position
Type: Online System Int64
See Also
SVNFileSystemStream Class
SVNFileSystemStream Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemStream.DoWrite Method

SVNFileSystemStream DoWrite Method NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWrite(
    byte[] buffer,
    int offset,
    int count
)
protected override void DoWrite(
    byte[] buffer,
    int offset,
    int count
)
Protected Overrides Sub DoWrite (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
Protected Overrides Sub DoWrite (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
protected:
virtual void DoWrite(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
protected:
virtual void DoWrite(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract DoWrite :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override DoWrite :
        buffer : byte[] *
        offset : int *
        count : int -> unit
abstract DoWrite :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override DoWrite :
        buffer : byte[] *
        offset : int *
        count : int -> unit

Parameters

buffer
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32
See Also
SVNFileSystemStream Class
SVNFileSystemStream Members
NFX.IO.FileSystem.SVN Namespace


SVNFileSystemStream Properties

SVNFileSystemStream Properties NFX Class Library

The SVNFileSystemStream type exposes the following members.
Properties
 | Name | Description
Public property | CanRead | (Inherited from FileSystemStream.)
Public property | CanSeek | (Inherited from FileSystemStream.)
Public property | Online CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Online Stream.)
Public property | CanWrite | (Inherited from FileSystemStream.)
Public property | Length | (Inherited from FileSystemStream.)
Public property | Position | (Inherited from FileSystemStream.)
Public property | Online ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Online Stream.)
Public property | Online WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Online Stream.)
Back to Top
See Also
SVNFileSystemStream Class
NFX.IO.FileSystem.SVN Namespace


WebDAV Class

WebDAV Class NFX Class Library

Facilitates read-only tasks with WebDAV compliant SVN server. This class is NOT thread-safe
Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.SVN WebDAV

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class WebDAV
public sealed class WebDAV
Public NotInheritable Class WebDAV
Public NotInheritable Class WebDAV
public ref class WebDAV sealed
public ref class WebDAV sealed
[<SealedAttribute>]
type WebDAV =  class end
[<SealedAttribute>]
type WebDAV =  class end
See Also
WebDAV Members
NFX.IO.FileSystem.SVN Namespace


WebDAV Members

WebDAV Members NFX Class Library

The WebDAV type exposes the following members.
Constructors
 | Name | Description
Public method | WebDAV | Initializes a new instance of the WebDAV class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAbsoluteItemPath | Returns the absolute path of the item
Protected method | getFileContent |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetHeadRootVersion | Retrieves the latest head version
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | GetVersions | Retrieves a list of versions contained in the remote Dav catalog
Protected method | listDirectoryContent |
Public method | ListVersions | Lists the specified number of versions contained in remote Dav catalog
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Refresh | Refreshes the state of the object by purging cached items (forgets root dir)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | CurrentVersion | Get or sets current version
Public property | Root | Returns top-level directory as of root Uri mount point
Public property | RootUri | The top-most URL of the remote repository
Public property | TimeoutMs | Gets timeout for call, if zero then actual timeout is taken from WebSettings
Public property | UName | Gets current user name or empty when user is not set
Public property | UPwd | Gets current user password or empty when user is not set
Back to Top
See Also
WebDAV Class
NFX.IO.FileSystem.SVN Namespace


WebDAV Constructor

WebDAV Constructor NFX Class Library

Initializes a new instance of the WebDAV class

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WebDAV(
    string rootURL,
    int timeoutMs = 0,
    string uName = null,
    string uPwd = null,
    WebDAV..::..Version version = null
)
public WebDAV(
    string rootURL,
    int timeoutMs = 0,
    string uName = null,
    string uPwd = null,
    WebDAV..::..Version version = null
)
Public Sub New (
    rootURL As String,
    Optional timeoutMs As Integer = 0,
    Optional uName As String = Nothing,
    Optional uPwd As String = Nothing,
    Optional version As WebDAV..::..Version = Nothing
)
Public Sub New (
    rootURL As String,
    Optional timeoutMs As Integer = 0,
    Optional uName As String = Nothing,
    Optional uPwd As String = Nothing,
    Optional version As WebDAV..::..Version = Nothing
)
public:
WebDAV(
    String^ rootURL,
    int timeoutMs = 0,
    String^ uName = nullptr,
    String^ uPwd = nullptr,
    WebDAV..::..Version^ version = nullptr
)
public:
WebDAV(
    String^ rootURL,
    int timeoutMs = 0,
    String^ uName = nullptr,
    String^ uPwd = nullptr,
    WebDAV..::..Version^ version = nullptr
)
new :
        rootURL : string *
        ?timeoutMs : int *
        ?uName : string *
        ?uPwd : string *
        ?version : WebDAV..::..Version
(* Defaults:
        let _timeoutMs = defaultArg timeoutMs 0
        let _uName = defaultArg uName null
        let _uPwd = defaultArg uPwd null
        let _version = defaultArg version null
*)
-> WebDAV
new :
        rootURL : string *
        ?timeoutMs : int *
        ?uName : string *
        ?uPwd : string *
        ?version : WebDAV..::..Version
(* Defaults:
        let _timeoutMs = defaultArg timeoutMs 0
        let _uName = defaultArg uName null
        let _uPwd = defaultArg uPwd null
        let _version = defaultArg version null
*)
-> WebDAV

Parameters

rootURL
Type: Online System String
timeoutMs (Optional)
Type: Online System Int32
uName (Optional)
Type: Online System String
uPwd (Optional)
Type: Online System String
version (Optional)
Type: NFX.IO.FileSystem.SVN WebDAV Version
See Also
WebDAV Class
WebDAV Members
NFX.IO.FileSystem.SVN Namespace


WebDAV Methods

WebDAV Methods NFX Class Library

The WebDAV type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetAbsoluteItemPath | Returns the absolute path of the item
Protected method | getFileContent |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetHeadRootVersion | Retrieves the latest head version
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | GetVersions | Retrieves a list of versions contained in the remote Dav catalog
Protected method | listDirectoryContent |
Public method | ListVersions | Lists the specified number of versions contained in remote Dav catalog
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Refresh | Refreshes the state of the object by purging cached items (forgets root dir)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WebDAV Class
NFX.IO.FileSystem.SVN Namespace


WebDAV.GetAbsoluteItemPath Method

WebDAV GetAbsoluteItemPath Method NFX Class Library

Returns the absolute path of the item

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetAbsoluteItemPath(
    WebDAV..::..Item item
)
public string GetAbsoluteItemPath(
    WebDAV..::..Item item
)
Public Function GetAbsoluteItemPath (
    item As WebDAV..::..Item
) As String
Public Function GetAbsoluteItemPath (
    item As WebDAV..::..Item
) As String
public:
String^ GetAbsoluteItemPath(
    WebDAV..::..Item^ item
)
public:
String^ GetAbsoluteItemPath(
    WebDAV..::..Item^ item
)
member GetAbsoluteItemPath :
        item : WebDAV..::..Item -> string
member GetAbsoluteItemPath :
        item : WebDAV..::..Item -> string

Parameters

item
Type: NFX.IO.FileSystem.SVN WebDAV Item

Return Value

Type: Online String
See Also
WebDAV Class
WebDAV Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.getFileContent Method

WebDAV getFileContent Method NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void getFileContent(
    WebDAV..::..File file,
    Stream stream
)
internal void getFileContent(
    WebDAV..::..File file,
    Stream stream
)
Friend Sub getFileContent (
    file As WebDAV..::..File,
    stream As Stream
)
Friend Sub getFileContent (
    file As WebDAV..::..File,
    stream As Stream
)
internal:
void getFileContent(
    WebDAV..::..File^ file,
    Stream^ stream
)
internal:
void getFileContent(
    WebDAV..::..File^ file,
    Stream^ stream
)
internal member getFileContent :
        file : WebDAV..::..File *
        stream : Stream -> unit
internal member getFileContent :
        file : WebDAV..::..File *
        stream : Stream -> unit

Parameters

file
Type: NFX.IO.FileSystem.SVN WebDAV File
stream
Type: Online System.IO Stream
See Also
WebDAV Class
WebDAV Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.GetHeadRootVersion Method

WebDAV GetHeadRootVersion Method NFX Class Library

Retrieves the latest head version

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WebDAV..::..Version GetHeadRootVersion()
public WebDAV..::..Version GetHeadRootVersion()
Public Function GetHeadRootVersion As WebDAV..::..Version
Public Function GetHeadRootVersion As WebDAV..::..Version
public:
WebDAV..::..Version^ GetHeadRootVersion()
public:
WebDAV..::..Version^ GetHeadRootVersion()
member GetHeadRootVersion : unit -> WebDAV..::..Version
member GetHeadRootVersion : unit -> WebDAV..::..Version

Return Value

Type: WebDAV Version
See Also
WebDAV Class
WebDAV Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.GetVersions Method

WebDAV GetVersions Method NFX Class Library

Retrieves a list of versions contained in the remote Dav catalog

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<WebDAV..::..Version> GetVersions(
    string rootURL,
    string uName,
    string uPwd
)
public static IEnumerable<WebDAV..::..Version> GetVersions(
    string rootURL,
    string uName,
    string uPwd
)
Public Shared Function GetVersions (
    rootURL As String,
    uName As String,
    uPwd As String
) As IEnumerable(Of WebDAV..::..Version)
Public Shared Function GetVersions (
    rootURL As String,
    uName As String,
    uPwd As String
) As IEnumerable(Of WebDAV..::..Version)
public:
static IEnumerable<WebDAV..::..Version^>^ GetVersions(
    String^ rootURL,
    String^ uName,
    String^ uPwd
)
public:
static IEnumerable<WebDAV..::..Version^>^ GetVersions(
    String^ rootURL,
    String^ uName,
    String^ uPwd
)
static member GetVersions :
        rootURL : string *
        uName : string *
        uPwd : string -> IEnumerable<WebDAV..::..Version>
static member GetVersions :
        rootURL : string *
        uName : string *
        uPwd : string -> IEnumerable<WebDAV..::..Version>

Parameters

rootURL
Type: Online System String
uName
Type: Online System String
uPwd
Type: Online System String

Return Value

Type: Online IEnumerable WebDAV Version
See Also
WebDAV Class
WebDAV Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.listDirectoryContent Method

WebDAV listDirectoryContent Method NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal List<WebDAV..::..Item> listDirectoryContent(
    WebDAV..::..Directory dir = null,
    int depth = 1
)
internal List<WebDAV..::..Item> listDirectoryContent(
    WebDAV..::..Directory dir = null,
    int depth = 1
)
Friend Function listDirectoryContent (
    Optional dir As WebDAV..::..Directory = Nothing,
    Optional depth As Integer = 1
) As List(Of WebDAV..::..Item)
Friend Function listDirectoryContent (
    Optional dir As WebDAV..::..Directory = Nothing,
    Optional depth As Integer = 1
) As List(Of WebDAV..::..Item)
internal:
List<WebDAV..::..Item^>^ listDirectoryContent(
    WebDAV..::..Directory^ dir = nullptr,
    int depth = 1
)
internal:
List<WebDAV..::..Item^>^ listDirectoryContent(
    WebDAV..::..Directory^ dir = nullptr,
    int depth = 1
)
internal member listDirectoryContent :
        ?dir : WebDAV..::..Directory *
        ?depth : int
(* Defaults:
        let _dir = defaultArg dir null
        let _depth = defaultArg depth 1
*)
-> List<WebDAV..::..Item>
internal member listDirectoryContent :
        ?dir : WebDAV..::..Directory *
        ?depth : int
(* Defaults:
        let _dir = defaultArg dir null
        let _depth = defaultArg depth 1
*)
-> List<WebDAV..::..Item>

Parameters

dir (Optional)
Type: NFX.IO.FileSystem.SVN WebDAV Directory
depth (Optional)
Type: Online System Int32

Return Value

Type: Online List WebDAV Item
See Also
WebDAV Class
WebDAV Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.ListVersions Method

WebDAV ListVersions Method NFX Class Library

Lists the specified number of versions contained in remote Dav catalog

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<WebDAV..::..Version> ListVersions(
    string startVersion = "1",
    string endVersion = null,
    Nullable<int> limit = null
)
public List<WebDAV..::..Version> ListVersions(
    string startVersion = "1",
    string endVersion = null,
    Nullable<int> limit = null
)
Public Function ListVersions (
    Optional startVersion As String = "1",
    Optional endVersion As String = Nothing,
    Optional limit As Nullable(Of Integer) = Nothing
) As List(Of WebDAV..::..Version)
Public Function ListVersions (
    Optional startVersion As String = "1",
    Optional endVersion As String = Nothing,
    Optional limit As Nullable(Of Integer) = Nothing
) As List(Of WebDAV..::..Version)
public:
List<WebDAV..::..Version^>^ ListVersions(
    String^ startVersion = L"1",
    String^ endVersion = nullptr,
    Nullable<int> limit = nullptr
)
public:
List<WebDAV..::..Version^>^ ListVersions(
    String^ startVersion = L"1",
    String^ endVersion = nullptr,
    Nullable<int> limit = nullptr
)
member ListVersions :
        ?startVersion : string *
        ?endVersion : string *
        ?limit : Nullable<int>
(* Defaults:
        let _startVersion = defaultArg startVersion "1"
        let _endVersion = defaultArg endVersion null
        let _limit = defaultArg limit null
*)
-> List<WebDAV..::..Version>
member ListVersions :
        ?startVersion : string *
        ?endVersion : string *
        ?limit : Nullable<int>
(* Defaults:
        let _startVersion = defaultArg startVersion "1"
        let _endVersion = defaultArg endVersion null
        let _limit = defaultArg limit null
*)
-> List<WebDAV..::..Version>

Parameters

startVersion (Optional)
Type: Online System String
endVersion (Optional)
Type: Online System String
limit (Optional)
Type: Online System Nullable Online Int32

Return Value

Type: Online List WebDAV Version
See Also
WebDAV Class
WebDAV Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Refresh Method

WebDAV Refresh Method NFX Class Library

Refreshes the state of the object by purging cached items (forgets root dir)

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Refresh()
public void Refresh()
Public Sub Refresh
Public Sub Refresh
public:
void Refresh()
public:
void Refresh()
member Refresh : unit -> unit
member Refresh : unit -> unit
See Also
WebDAV Class
WebDAV Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.ToString Method

WebDAV ToString Method NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
WebDAV Class
WebDAV Members
NFX.IO.FileSystem.SVN Namespace


WebDAV Properties

WebDAV Properties NFX Class Library

The WebDAV type exposes the following members.
Properties
 | Name | Description
Public property | CurrentVersion | Get or sets current version
Public property | Root | Returns top-level directory as of root Uri mount point
Public property | RootUri | The top-most URL of the remote repository
Public property | TimeoutMs | Gets timeout for call, if zero then actual timeout is taken from WebSettings
Public property | UName | Gets current user name or empty when user is not set
Public property | UPwd | Gets current user password or empty when user is not set
Back to Top
See Also
WebDAV Class
NFX.IO.FileSystem.SVN Namespace


WebDAV.CurrentVersion Property

WebDAV CurrentVersion Property NFX Class Library

Get or sets current version

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WebDAV..::..Version CurrentVersion { get; set; }
public WebDAV..::..Version CurrentVersion { get; set; }
Public Property CurrentVersion As WebDAV..::..Version
    Get
    Set
Public Property CurrentVersion As WebDAV..::..Version
    Get
    Set
public:
property WebDAV..::..Version^ CurrentVersion {
    WebDAV..::..Version^ get ();
    void set (WebDAV..::..Version^ value);
}
public:
property WebDAV..::..Version^ CurrentVersion {
    WebDAV..::..Version^ get ();
    void set (WebDAV..::..Version^ value);
}
member CurrentVersion : WebDAV..::..Version with get, set
member CurrentVersion : WebDAV..::..Version with get, set

Property Value

Type: WebDAV Version
See Also
WebDAV Class
WebDAV Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Root Property

WebDAV Root Property NFX Class Library

Returns top-level directory as of root Uri mount point

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WebDAV..::..Directory Root { get; }
public WebDAV..::..Directory Root { get; }
Public ReadOnly Property Root As WebDAV..::..Directory
    Get
Public ReadOnly Property Root As WebDAV..::..Directory
    Get
public:
property WebDAV..::..Directory^ Root {
    WebDAV..::..Directory^ get ();
}
public:
property WebDAV..::..Directory^ Root {
    WebDAV..::..Directory^ get ();
}
member Root : WebDAV..::..Directory with get
member Root : WebDAV..::..Directory with get

Property Value

Type: WebDAV Directory
See Also
WebDAV Class
WebDAV Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.RootUri Property

WebDAV RootUri Property NFX Class Library

The top-most URL of the remote repository

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Uri RootUri { get; }
public Uri RootUri { get; }
Public ReadOnly Property RootUri As Uri
    Get
Public ReadOnly Property RootUri As Uri
    Get
public:
property Uri^ RootUri {
    Uri^ get ();
}
public:
property Uri^ RootUri {
    Uri^ get ();
}
member RootUri : Uri with get
member RootUri : Uri with get

Property Value

Type: Online Uri
See Also
WebDAV Class
WebDAV Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.TimeoutMs Property

WebDAV TimeoutMs Property NFX Class Library

Gets timeout for call, if zero then actual timeout is taken from WebSettings

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int TimeoutMs { get; }
public int TimeoutMs { get; }
Public ReadOnly Property TimeoutMs As Integer
    Get
Public ReadOnly Property TimeoutMs As Integer
    Get
public:
property int TimeoutMs {
    int get ();
}
public:
property int TimeoutMs {
    int get ();
}
member TimeoutMs : int with get
member TimeoutMs : int with get

Property Value

Type: Online Int32
See Also
WebDAV Class
WebDAV Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.UName Property

WebDAV UName Property NFX Class Library

Gets current user name or empty when user is not set

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string UName { get; }
public string UName { get; }
Public ReadOnly Property UName As String
    Get
Public ReadOnly Property UName As String
    Get
public:
property String^ UName {
    String^ get ();
}
public:
property String^ UName {
    String^ get ();
}
member UName : string with get
member UName : string with get

Property Value

Type: Online String
See Also
WebDAV Class
WebDAV Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.UPwd Property

WebDAV UPwd Property NFX Class Library

Gets current user password or empty when user is not set

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string UPwd { get; }
public string UPwd { get; }
Public ReadOnly Property UPwd As String
    Get
Public ReadOnly Property UPwd As String
    Get
public:
property String^ UPwd {
    String^ get ();
}
public:
property String^ UPwd {
    String^ get ();
}
member UPwd : string with get
member UPwd : string with get

Property Value

Type: Online String
See Also
WebDAV Class
WebDAV Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Directory Class

WebDAV Directory Class NFX Class Library

Represents a directory in remote Dav catalog
Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.SVN WebDAV Item
NFX.IO.FileSystem.SVN WebDAV Directory

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Directory : WebDAV..::..Item
public sealed class Directory : WebDAV..::..Item
Public NotInheritable Class Directory
    Inherits WebDAV..::..Item
Public NotInheritable Class Directory
    Inherits WebDAV..::..Item
public ref class Directory sealed : public WebDAV..::..Item
public ref class Directory sealed : public WebDAV..::..Item
[<SealedAttribute>]
type Directory =
    class
        inherit WebDAV..::..Item
    end
[<SealedAttribute>]
type Directory =
    class
        inherit WebDAV..::..Item
    end
See Also
WebDAV Directory Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Directory Members

WebDAV Directory Members NFX Class Library

The WebDAV Directory type exposes the following members.
Constructors
 | Name | Description
Protected method | WebDAV Directory | Initializes a new instance of the WebDAV Directory class
Back to Top
Methods
 | Name | Description
Public method | Equals(Object) | (Inherited from WebDAV Item.)
Public method | Equals(WebDAV Item) | (Inherited from WebDAV Item.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Inherited from WebDAV Item.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsSameName | Performs case-sensitive name equality test (Inherited from WebDAV Item.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NavigatePath | Tries to navigate path and returns destination directory, file or null if its not found
Public method | Refresh | Refreshes the internal status of the directory by purging all cached objects
Public method | ToString | (Inherited from WebDAV Item.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | AbsolutePath | Returns absolute path for this item (Inherited from WebDAV Item.)
Public property | Children | Lists subitems contained in this remote Dav directory. Items are fetched lazily and then cached until Refresh() is called
Public property | Client | (Inherited from WebDAV Item.)
Public property | ContentType | Returns content type (e.g. 'text/plainutf-8') (Inherited from WebDAV Item.)
Public property | CreationDate | (Inherited from WebDAV Item.)
Public property | Directories | Lists subdirectories of this directory
Public property | Files | Lists files contained in this directory
Public property | Item | Gets an item contained in this directory by name be it file or directory. Returns NULL if item with such name does not exist
Public property | LastModificationDate | (Inherited from WebDAV Item.)
Public property | Name | (Inherited from WebDAV Item.)
Public property | Parent | Returns parent directory that contains this item or NULL for very root directory (Inherited from WebDAV Item.)
Public property | Path | Returns path relative to root directory (Inherited from WebDAV Item.)
Public property | Version | (Inherited from WebDAV Item.)
Back to Top
See Also
WebDAV Directory Class
NFX.IO.FileSystem.SVN Namespace


WebDAV.Directory Constructor

WebDAV Directory Constructor NFX Class Library

Initializes a new instance of the WebDAV Directory class

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Directory(
    WebDAV client,
    string name,
    string version,
    DateTime creationDate,
    DateTime lastModificationDate,
    string contentType,
    WebDAV..::..Directory parent
)
internal Directory(
    WebDAV client,
    string name,
    string version,
    DateTime creationDate,
    DateTime lastModificationDate,
    string contentType,
    WebDAV..::..Directory parent
)
Friend Sub New (
    client As WebDAV,
    name As String,
    version As String,
    creationDate As DateTime,
    lastModificationDate As DateTime,
    contentType As String,
    parent As WebDAV..::..Directory
)
Friend Sub New (
    client As WebDAV,
    name As String,
    version As String,
    creationDate As DateTime,
    lastModificationDate As DateTime,
    contentType As String,
    parent As WebDAV..::..Directory
)
internal:
Directory(
    WebDAV^ client,
    String^ name,
    String^ version,
    DateTime creationDate,
    DateTime lastModificationDate,
    String^ contentType,
    WebDAV..::..Directory^ parent
)
internal:
Directory(
    WebDAV^ client,
    String^ name,
    String^ version,
    DateTime creationDate,
    DateTime lastModificationDate,
    String^ contentType,
    WebDAV..::..Directory^ parent
)
new :
        client : WebDAV *
        name : string *
        version : string *
        creationDate : DateTime *
        lastModificationDate : DateTime *
        contentType : string *
        parent : WebDAV..::..Directory -> Directory
new :
        client : WebDAV *
        name : string *
        version : string *
        creationDate : DateTime *
        lastModificationDate : DateTime *
        contentType : string *
        parent : WebDAV..::..Directory -> Directory

Parameters

client
Type: NFX.IO.FileSystem.SVN WebDAV
name
Type: Online System String
version
Type: Online System String
creationDate
Type: Online System DateTime
lastModificationDate
Type: Online System DateTime
contentType
Type: Online System String
parent
Type: NFX.IO.FileSystem.SVN WebDAV Directory
See Also
WebDAV Directory Class
WebDAV Directory Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Directory Methods

WebDAV Directory Methods NFX Class Library

The WebDAV Directory type exposes the following members.
Methods
 | Name | Description
Public method | Equals(Object) | (Inherited from WebDAV Item.)
Public method | Equals(WebDAV Item) | (Inherited from WebDAV Item.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Inherited from WebDAV Item.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsSameName | Performs case-sensitive name equality test (Inherited from WebDAV Item.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NavigatePath | Tries to navigate path and returns destination directory, file or null if its not found
Public method | Refresh | Refreshes the internal status of the directory by purging all cached objects
Public method | ToString | (Inherited from WebDAV Item.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WebDAV Directory Class
NFX.IO.FileSystem.SVN Namespace


WebDAV.Directory.NavigatePath Method

WebDAV Directory NavigatePath Method NFX Class Library

Tries to navigate path and returns destination directory, file or null if its not found

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WebDAV..::..Item NavigatePath(
    string path
)
public WebDAV..::..Item NavigatePath(
    string path
)
Public Function NavigatePath (
    path As String
) As WebDAV..::..Item
Public Function NavigatePath (
    path As String
) As WebDAV..::..Item
public:
WebDAV..::..Item^ NavigatePath(
    String^ path
)
public:
WebDAV..::..Item^ NavigatePath(
    String^ path
)
member NavigatePath :
        path : string -> WebDAV..::..Item
member NavigatePath :
        path : string -> WebDAV..::..Item

Parameters

path
Type: Online System String

Return Value

Type: WebDAV Item
See Also
WebDAV Directory Class
WebDAV Directory Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Directory.Refresh Method

WebDAV Directory Refresh Method NFX Class Library

Refreshes the internal status of the directory by purging all cached objects

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Refresh()
public void Refresh()
Public Sub Refresh
Public Sub Refresh
public:
void Refresh()
public:
void Refresh()
member Refresh : unit -> unit
member Refresh : unit -> unit
See Also
WebDAV Directory Class
WebDAV Directory Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Directory Properties

WebDAV Directory Properties NFX Class Library

The WebDAV Directory type exposes the following members.
Properties
 | Name | Description
Public property | AbsolutePath | Returns absolute path for this item (Inherited from WebDAV Item.)
Public property | Children | Lists subitems contained in this remote Dav directory. Items are fetched lazily and then cached until Refresh() is called
Public property | Client | (Inherited from WebDAV Item.)
Public property | ContentType | Returns content type (e.g. 'text/plainutf-8') (Inherited from WebDAV Item.)
Public property | CreationDate | (Inherited from WebDAV Item.)
Public property | Directories | Lists subdirectories of this directory
Public property | Files | Lists files contained in this directory
Public property | Item | Gets an item contained in this directory by name be it file or directory. Returns NULL if item with such name does not exist
Public property | LastModificationDate | (Inherited from WebDAV Item.)
Public property | Name | (Inherited from WebDAV Item.)
Public property | Parent | Returns parent directory that contains this item or NULL for very root directory (Inherited from WebDAV Item.)
Public property | Path | Returns path relative to root directory (Inherited from WebDAV Item.)
Public property | Version | (Inherited from WebDAV Item.)
Back to Top
See Also
WebDAV Directory Class
NFX.IO.FileSystem.SVN Namespace


WebDAV.Directory.Children Property

WebDAV Directory Children Property NFX Class Library

Lists subitems contained in this remote Dav directory. Items are fetched lazily and then cached until Refresh() is called

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<WebDAV..::..Item> Children { get; }
public IEnumerable<WebDAV..::..Item> Children { get; }
Public ReadOnly Property Children As IEnumerable(Of WebDAV..::..Item)
    Get
Public ReadOnly Property Children As IEnumerable(Of WebDAV..::..Item)
    Get
public:
property IEnumerable<WebDAV..::..Item^>^ Children {
    IEnumerable<WebDAV..::..Item^>^ get ();
}
public:
property IEnumerable<WebDAV..::..Item^>^ Children {
    IEnumerable<WebDAV..::..Item^>^ get ();
}
member Children : IEnumerable<WebDAV..::..Item> with get
member Children : IEnumerable<WebDAV..::..Item> with get

Property Value

Type: Online IEnumerable WebDAV Item
See Also
WebDAV Directory Class
WebDAV Directory Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Directory.Directories Property

WebDAV Directory Directories Property NFX Class Library

Lists subdirectories of this directory

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<WebDAV..::..Item> Directories { get; }
public IEnumerable<WebDAV..::..Item> Directories { get; }
Public ReadOnly Property Directories As IEnumerable(Of WebDAV..::..Item)
    Get
Public ReadOnly Property Directories As IEnumerable(Of WebDAV..::..Item)
    Get
public:
property IEnumerable<WebDAV..::..Item^>^ Directories {
    IEnumerable<WebDAV..::..Item^>^ get ();
}
public:
property IEnumerable<WebDAV..::..Item^>^ Directories {
    IEnumerable<WebDAV..::..Item^>^ get ();
}
member Directories : IEnumerable<WebDAV..::..Item> with get
member Directories : IEnumerable<WebDAV..::..Item> with get

Property Value

Type: Online IEnumerable WebDAV Item
See Also
WebDAV Directory Class
WebDAV Directory Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Directory.Files Property

WebDAV Directory Files Property NFX Class Library

Lists files contained in this directory

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<WebDAV..::..Item> Files { get; }
public IEnumerable<WebDAV..::..Item> Files { get; }
Public ReadOnly Property Files As IEnumerable(Of WebDAV..::..Item)
    Get
Public ReadOnly Property Files As IEnumerable(Of WebDAV..::..Item)
    Get
public:
property IEnumerable<WebDAV..::..Item^>^ Files {
    IEnumerable<WebDAV..::..Item^>^ get ();
}
public:
property IEnumerable<WebDAV..::..Item^>^ Files {
    IEnumerable<WebDAV..::..Item^>^ get ();
}
member Files : IEnumerable<WebDAV..::..Item> with get
member Files : IEnumerable<WebDAV..::..Item> with get

Property Value

Type: Online IEnumerable WebDAV Item
See Also
WebDAV Directory Class
WebDAV Directory Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Directory.Item Property

WebDAV Directory Item Property NFX Class Library

Gets an item contained in this directory by name be it file or directory. Returns NULL if item with such name does not exist

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WebDAV..::..Item this[
    string name
] { get; }
public WebDAV..::..Item this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As WebDAV..::..Item
    Get
Public ReadOnly Default Property Item (
    name As String
) As WebDAV..::..Item
    Get
public:
property WebDAV..::..Item^ default[String^ name] {
    WebDAV..::..Item^ get (String^ name);
}
public:
property WebDAV..::..Item^ default[String^ name] {
    WebDAV..::..Item^ get (String^ name);
}
member Item : WebDAV..::..Item with get
member Item : WebDAV..::..Item with get

Parameters

name
Type: Online System String

Property Value

Type: WebDAV Item
See Also
WebDAV Directory Class
WebDAV Directory Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.File Class

WebDAV File Class NFX Class Library

Represents a file in the remote Dav catalog
Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.SVN WebDAV Item
NFX.IO.FileSystem.SVN WebDAV File

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class File : WebDAV..::..Item
public sealed class File : WebDAV..::..Item
Public NotInheritable Class File
    Inherits WebDAV..::..Item
Public NotInheritable Class File
    Inherits WebDAV..::..Item
public ref class File sealed : public WebDAV..::..Item
public ref class File sealed : public WebDAV..::..Item
[<SealedAttribute>]
type File =
    class
        inherit WebDAV..::..Item
    end
[<SealedAttribute>]
type File =
    class
        inherit WebDAV..::..Item
    end
See Also
WebDAV File Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.File Members

WebDAV File Members NFX Class Library

The WebDAV File type exposes the following members.
Constructors
 | Name | Description
Protected method | WebDAV File | Initializes a new instance of the WebDAV File class
Back to Top
Methods
 | Name | Description
Public method | Equals(Object) | (Inherited from WebDAV Item.)
Public method | Equals(WebDAV Item) | (Inherited from WebDAV Item.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetContent | Writes contents of the remote file into a stream. No caching is done
Public method | GetHashCode | (Inherited from WebDAV Item.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsSameName | Performs case-sensitive name equality test (Inherited from WebDAV Item.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from WebDAV Item.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | AbsolutePath | Returns absolute path for this item (Inherited from WebDAV Item.)
Public property | Client | (Inherited from WebDAV Item.)
Public property | ContentType | Returns content type (e.g. 'text/plainutf-8') (Inherited from WebDAV Item.)
Public property | CreationDate | (Inherited from WebDAV Item.)
Public property | LastModificationDate | (Inherited from WebDAV Item.)
Public property | Name | (Inherited from WebDAV Item.)
Public property | Parent | Returns parent directory that contains this item or NULL for very root directory (Inherited from WebDAV Item.)
Public property | Path | Returns path relative to root directory (Inherited from WebDAV Item.)
Public property | Size | Returns 'ContentLength' of this file
Public property | Version | (Inherited from WebDAV Item.)
Back to Top
See Also
WebDAV File Class
NFX.IO.FileSystem.SVN Namespace


WebDAV.File Constructor

WebDAV File Constructor NFX Class Library

Initializes a new instance of the WebDAV File class

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal File(
    WebDAV client,
    string name,
    ulong size,
    string version,
    DateTime creationDate,
    DateTime lastModificationDate,
    string contentType,
    WebDAV..::..Directory parent
)
internal File(
    WebDAV client,
    string name,
    ulong size,
    string version,
    DateTime creationDate,
    DateTime lastModificationDate,
    string contentType,
    WebDAV..::..Directory parent
)
Friend Sub New (
    client As WebDAV,
    name As String,
    size As ULong,
    version As String,
    creationDate As DateTime,
    lastModificationDate As DateTime,
    contentType As String,
    parent As WebDAV..::..Directory
)
Friend Sub New (
    client As WebDAV,
    name As String,
    size As ULong,
    version As String,
    creationDate As DateTime,
    lastModificationDate As DateTime,
    contentType As String,
    parent As WebDAV..::..Directory
)
internal:
File(
    WebDAV^ client,
    String^ name,
    unsigned long long size,
    String^ version,
    DateTime creationDate,
    DateTime lastModificationDate,
    String^ contentType,
    WebDAV..::..Directory^ parent
)
internal:
File(
    WebDAV^ client,
    String^ name,
    unsigned long long size,
    String^ version,
    DateTime creationDate,
    DateTime lastModificationDate,
    String^ contentType,
    WebDAV..::..Directory^ parent
)
new :
        client : WebDAV *
        name : string *
        size : uint64 *
        version : string *
        creationDate : DateTime *
        lastModificationDate : DateTime *
        contentType : string *
        parent : WebDAV..::..Directory -> File
new :
        client : WebDAV *
        name : string *
        size : uint64 *
        version : string *
        creationDate : DateTime *
        lastModificationDate : DateTime *
        contentType : string *
        parent : WebDAV..::..Directory -> File

Parameters

client
Type: NFX.IO.FileSystem.SVN WebDAV
name
Type: Online System String
size
Type: Online System UInt64
version
Type: Online System String
creationDate
Type: Online System DateTime
lastModificationDate
Type: Online System DateTime
contentType
Type: Online System String
parent
Type: NFX.IO.FileSystem.SVN WebDAV Directory
See Also
WebDAV File Class
WebDAV File Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.File Methods

WebDAV File Methods NFX Class Library

The WebDAV File type exposes the following members.
Methods
 | Name | Description
Public method | Equals(Object) | (Inherited from WebDAV Item.)
Public method | Equals(WebDAV Item) | (Inherited from WebDAV Item.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetContent | Writes contents of the remote file into a stream. No caching is done
Public method | GetHashCode | (Inherited from WebDAV Item.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsSameName | Performs case-sensitive name equality test (Inherited from WebDAV Item.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from WebDAV Item.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WebDAV File Class
NFX.IO.FileSystem.SVN Namespace


WebDAV.File.GetContent Method

WebDAV File GetContent Method NFX Class Library

Writes contents of the remote file into a stream. No caching is done

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void GetContent(
    Stream stream
)
public void GetContent(
    Stream stream
)
Public Sub GetContent (
    stream As Stream
)
Public Sub GetContent (
    stream As Stream
)
public:
void GetContent(
    Stream^ stream
)
public:
void GetContent(
    Stream^ stream
)
member GetContent :
        stream : Stream -> unit
member GetContent :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
WebDAV File Class
WebDAV File Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.File Properties

WebDAV File Properties NFX Class Library

The WebDAV File type exposes the following members.
Properties
 | Name | Description
Public property | AbsolutePath | Returns absolute path for this item (Inherited from WebDAV Item.)
Public property | Client | (Inherited from WebDAV Item.)
Public property | ContentType | Returns content type (e.g. 'text/plainutf-8') (Inherited from WebDAV Item.)
Public property | CreationDate | (Inherited from WebDAV Item.)
Public property | LastModificationDate | (Inherited from WebDAV Item.)
Public property | Name | (Inherited from WebDAV Item.)
Public property | Parent | Returns parent directory that contains this item or NULL for very root directory (Inherited from WebDAV Item.)
Public property | Path | Returns path relative to root directory (Inherited from WebDAV Item.)
Public property | Size | Returns 'ContentLength' of this file
Public property | Version | (Inherited from WebDAV Item.)
Back to Top
See Also
WebDAV File Class
NFX.IO.FileSystem.SVN Namespace


WebDAV.File.Size Property

WebDAV File Size Property NFX Class Library

Returns 'ContentLength' of this file

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong Size { get; }
public ulong Size { get; }
Public ReadOnly Property Size As ULong
    Get
Public ReadOnly Property Size As ULong
    Get
public:
property unsigned long long Size {
    unsigned long long get ();
}
public:
property unsigned long long Size {
    unsigned long long get ();
}
member Size : uint64 with get
member Size : uint64 with get

Property Value

Type: Online UInt64
See Also
WebDAV File Class
WebDAV File Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Item Class

WebDAV Item Class NFX Class Library

General ancestor for items in remote Dav catalog, such as files and directories
Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.SVN WebDAV Item
NFX.IO.FileSystem.SVN WebDAV Directory
NFX.IO.FileSystem.SVN WebDAV File

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Item : INamed,
    IEquatable<WebDAV..::..Item>
public abstract class Item : INamed,
    IEquatable<WebDAV..::..Item>
Public MustInherit Class Item
    Implements INamed, IEquatable(Of WebDAV..::..Item)
Public MustInherit Class Item
    Implements INamed, IEquatable(Of WebDAV..::..Item)
public ref class Item abstract : INamed,
    IEquatable<WebDAV..::..Item^>
public ref class Item abstract : INamed,
    IEquatable<WebDAV..::..Item^>
[<AbstractClassAttribute>]
type Item =
    class
        interface INamed
        interface IEquatable<WebDAV..::..Item>
    end
[<AbstractClassAttribute>]
type Item =
    class
        interface INamed
        interface IEquatable<WebDAV..::..Item>
    end
See Also
WebDAV Item Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Item Members

WebDAV Item Members NFX Class Library

The WebDAV Item type exposes the following members.
Constructors
 | Name | Description
Protected method | WebDAV Item | Initializes a new instance of the WebDAV Item class
Back to Top
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online Object Equals(Object).)
Public method | Equals(WebDAV Item) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsSameName | Performs case-sensitive name equality test
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
SEPARATORS |
Back to Top
Properties
 | Name | Description
Public property | AbsolutePath | Returns absolute path for this item
Public property | Client |
Public property | ContentType | Returns content type (e.g. 'text/plainutf-8')
Public property | CreationDate |
Public property | LastModificationDate |
Public property | Name |
Public property | Parent | Returns parent directory that contains this item or NULL for very root directory
Public property | Path | Returns path relative to root directory
Public property | Version |
Back to Top
See Also
WebDAV Item Class
NFX.IO.FileSystem.SVN Namespace


WebDAV.Item Constructor

WebDAV Item Constructor NFX Class Library

Initializes a new instance of the WebDAV Item class

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Item(
    WebDAV client,
    string name,
    string version,
    DateTime creationDate,
    DateTime lastModificationDate,
    string contentType,
    WebDAV..::..Directory parent
)
internal Item(
    WebDAV client,
    string name,
    string version,
    DateTime creationDate,
    DateTime lastModificationDate,
    string contentType,
    WebDAV..::..Directory parent
)
Friend Sub New (
    client As WebDAV,
    name As String,
    version As String,
    creationDate As DateTime,
    lastModificationDate As DateTime,
    contentType As String,
    parent As WebDAV..::..Directory
)
Friend Sub New (
    client As WebDAV,
    name As String,
    version As String,
    creationDate As DateTime,
    lastModificationDate As DateTime,
    contentType As String,
    parent As WebDAV..::..Directory
)
internal:
Item(
    WebDAV^ client,
    String^ name,
    String^ version,
    DateTime creationDate,
    DateTime lastModificationDate,
    String^ contentType,
    WebDAV..::..Directory^ parent
)
internal:
Item(
    WebDAV^ client,
    String^ name,
    String^ version,
    DateTime creationDate,
    DateTime lastModificationDate,
    String^ contentType,
    WebDAV..::..Directory^ parent
)
new :
        client : WebDAV *
        name : string *
        version : string *
        creationDate : DateTime *
        lastModificationDate : DateTime *
        contentType : string *
        parent : WebDAV..::..Directory -> Item
new :
        client : WebDAV *
        name : string *
        version : string *
        creationDate : DateTime *
        lastModificationDate : DateTime *
        contentType : string *
        parent : WebDAV..::..Directory -> Item

Parameters

client
Type: NFX.IO.FileSystem.SVN WebDAV
name
Type: Online System String
version
Type: Online System String
creationDate
Type: Online System DateTime
lastModificationDate
Type: Online System DateTime
contentType
Type: Online System String
parent
Type: NFX.IO.FileSystem.SVN WebDAV Directory
See Also
WebDAV Item Class
WebDAV Item Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Item Fields

WebDAV Item Fields NFX Class Library

The WebDAV Item type exposes the following members.
Fields
Name | Description
SEPARATORS |
Back to Top
See Also
WebDAV Item Class
NFX.IO.FileSystem.SVN Namespace


WebDAV.Item.SEPARATORS Field

WebDAV Item SEPARATORS Field NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static char[] SEPARATORS
internal static char[] SEPARATORS
Friend Shared SEPARATORS As Char()
Friend Shared SEPARATORS As Char()
internal:
static array<wchar_t>^ SEPARATORS
internal:
static array<wchar_t>^ SEPARATORS
static val mutable internal SEPARATORS: char[]
static val mutable internal SEPARATORS: char[]

Field Value

Type: Online Char
See Also
WebDAV Item Class
WebDAV Item Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Item Methods

WebDAV Item Methods NFX Class Library

The WebDAV Item type exposes the following members.
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides Online Object Equals(Object).)
Public method | Equals(WebDAV Item) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IsSameName | Performs case-sensitive name equality test
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WebDAV Item Class
NFX.IO.FileSystem.SVN Namespace


WebDAV.Item.Equals Method

WebDAV Item Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides Online Object Equals(Object).)
Public method | Equals(WebDAV Item) |
Back to Top
See Also
WebDAV Item Class
WebDAV Item Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Item.Equals Method (Object)

WebDAV Item Equals Method (Object) NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
WebDAV Item Class
WebDAV Item Members
Equals Overload
NFX.IO.FileSystem.SVN Namespace


WebDAV.Item.Equals Method (WebDAV.Item)

WebDAV Item Equals Method (WebDAV Item) NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    WebDAV..::..Item other
)
public bool Equals(
    WebDAV..::..Item other
)
Public Function Equals (
    other As WebDAV..::..Item
) As Boolean
Public Function Equals (
    other As WebDAV..::..Item
) As Boolean
public:
virtual bool Equals(
    WebDAV..::..Item^ other
) sealed
public:
virtual bool Equals(
    WebDAV..::..Item^ other
) sealed
abstract Equals :
        other : WebDAV..::..Item -> bool
override Equals :
        other : WebDAV..::..Item -> bool
abstract Equals :
        other : WebDAV..::..Item -> bool
override Equals :
        other : WebDAV..::..Item -> bool

Parameters

other
Type: NFX.IO.FileSystem.SVN WebDAV Item

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
WebDAV Item Class
WebDAV Item Members
Equals Overload
NFX.IO.FileSystem.SVN Namespace


WebDAV.Item.GetHashCode Method

WebDAV Item GetHashCode Method NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
WebDAV Item Class
WebDAV Item Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Item.IsSameName Method

WebDAV Item IsSameName Method NFX Class Library

Performs case-sensitive name equality test

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsSameName(
    string name
)
public bool IsSameName(
    string name
)
Public Function IsSameName (
    name As String
) As Boolean
Public Function IsSameName (
    name As String
) As Boolean
public:
bool IsSameName(
    String^ name
)
public:
bool IsSameName(
    String^ name
)
member IsSameName :
        name : string -> bool
member IsSameName :
        name : string -> bool

Parameters

name
Type: Online System String

Return Value

Type: Online Boolean
See Also
WebDAV Item Class
WebDAV Item Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Item.ToString Method

WebDAV Item ToString Method NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
WebDAV Item Class
WebDAV Item Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Item Properties

WebDAV Item Properties NFX Class Library

The WebDAV Item type exposes the following members.
Properties
 | Name | Description
Public property | AbsolutePath | Returns absolute path for this item
Public property | Client |
Public property | ContentType | Returns content type (e.g. 'text/plainutf-8')
Public property | CreationDate |
Public property | LastModificationDate |
Public property | Name |
Public property | Parent | Returns parent directory that contains this item or NULL for very root directory
Public property | Path | Returns path relative to root directory
Public property | Version |
Back to Top
See Also
WebDAV Item Class
NFX.IO.FileSystem.SVN Namespace


WebDAV.Item.AbsolutePath Property

WebDAV Item AbsolutePath Property NFX Class Library

Returns absolute path for this item

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AbsolutePath { get; }
public string AbsolutePath { get; }
Public ReadOnly Property AbsolutePath As String
    Get
Public ReadOnly Property AbsolutePath As String
    Get
public:
property String^ AbsolutePath {
    String^ get ();
}
public:
property String^ AbsolutePath {
    String^ get ();
}
member AbsolutePath : string with get
member AbsolutePath : string with get

Property Value

Type: Online String
See Also
WebDAV Item Class
WebDAV Item Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Item.Client Property

WebDAV Item Client Property NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WebDAV Client { get; }
public WebDAV Client { get; }
Public ReadOnly Property Client As WebDAV
    Get
Public ReadOnly Property Client As WebDAV
    Get
public:
property WebDAV^ Client {
    WebDAV^ get ();
}
public:
property WebDAV^ Client {
    WebDAV^ get ();
}
member Client : WebDAV with get
member Client : WebDAV with get

Property Value

Type: WebDAV
See Also
WebDAV Item Class
WebDAV Item Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Item.ContentType Property

WebDAV Item ContentType Property NFX Class Library

Returns content type (e.g. 'text/plainutf-8')

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ContentType { get; }
public string ContentType { get; }
Public ReadOnly Property ContentType As String
    Get
Public ReadOnly Property ContentType As String
    Get
public:
property String^ ContentType {
    String^ get ();
}
public:
property String^ ContentType {
    String^ get ();
}
member ContentType : string with get
member ContentType : string with get

Property Value

Type: Online String
See Also
WebDAV Item Class
WebDAV Item Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Item.CreationDate Property

WebDAV Item CreationDate Property NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime CreationDate { get; }
public DateTime CreationDate { get; }
Public ReadOnly Property CreationDate As DateTime
    Get
Public ReadOnly Property CreationDate As DateTime
    Get
public:
property DateTime CreationDate {
    DateTime get ();
}
public:
property DateTime CreationDate {
    DateTime get ();
}
member CreationDate : DateTime with get
member CreationDate : DateTime with get

Property Value

Type: Online DateTime
See Also
WebDAV Item Class
WebDAV Item Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Item.LastModificationDate Property

WebDAV Item LastModificationDate Property NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime LastModificationDate { get; }
public DateTime LastModificationDate { get; }
Public ReadOnly Property LastModificationDate As DateTime
    Get
Public ReadOnly Property LastModificationDate As DateTime
    Get
public:
property DateTime LastModificationDate {
    DateTime get ();
}
public:
property DateTime LastModificationDate {
    DateTime get ();
}
member LastModificationDate : DateTime with get
member LastModificationDate : DateTime with get

Property Value

Type: Online DateTime
See Also
WebDAV Item Class
WebDAV Item Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Item.Name Property

WebDAV Item Name Property NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
WebDAV Item Class
WebDAV Item Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Item.Parent Property

WebDAV Item Parent Property NFX Class Library

Returns parent directory that contains this item or NULL for very root directory

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WebDAV..::..Directory Parent { get; }
public WebDAV..::..Directory Parent { get; }
Public ReadOnly Property Parent As WebDAV..::..Directory
    Get
Public ReadOnly Property Parent As WebDAV..::..Directory
    Get
public:
property WebDAV..::..Directory^ Parent {
    WebDAV..::..Directory^ get ();
}
public:
property WebDAV..::..Directory^ Parent {
    WebDAV..::..Directory^ get ();
}
member Parent : WebDAV..::..Directory with get
member Parent : WebDAV..::..Directory with get

Property Value

Type: WebDAV Directory
See Also
WebDAV Item Class
WebDAV Item Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Item.Path Property

WebDAV Item Path Property NFX Class Library

Returns path relative to root directory

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Path { get; }
public string Path { get; }
Public ReadOnly Property Path As String
    Get
Public ReadOnly Property Path As String
    Get
public:
property String^ Path {
    String^ get ();
}
public:
property String^ Path {
    String^ get ();
}
member Path : string with get
member Path : string with get

Property Value

Type: Online String
See Also
WebDAV Item Class
WebDAV Item Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Item.Version Property

WebDAV Item Version Property NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Version { get; }
public string Version { get; }
Public ReadOnly Property Version As String
    Get
Public ReadOnly Property Version As String
    Get
public:
property String^ Version {
    String^ get ();
}
public:
property String^ Version {
    String^ get ();
}
member Version : string with get
member Version : string with get

Property Value

Type: Online String
See Also
WebDAV Item Class
WebDAV Item Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Version Class

WebDAV Version Class NFX Class Library

Represents a version of items in the remote Dav catalog
Inheritance Hierarchy
Online System Object
NFX.IO.FileSystem.SVN WebDAV Version

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Version : IFileSystemVersion,
    INamed
public sealed class Version : IFileSystemVersion,
    INamed
Public NotInheritable Class Version
    Implements IFileSystemVersion, INamed
Public NotInheritable Class Version
    Implements IFileSystemVersion, INamed
public ref class Version sealed : IFileSystemVersion,
    INamed
public ref class Version sealed : IFileSystemVersion,
    INamed
[<SealedAttribute>]
type Version =
    class
        interface IFileSystemVersion
        interface INamed
    end
[<SealedAttribute>]
type Version =
    class
        interface IFileSystemVersion
        interface INamed
    end
See Also
WebDAV Version Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Version Members

WebDAV Version Members NFX Class Library

The WebDAV Version type exposes the following members.
Constructors
 | Name | Description
Public method | WebDAV Version | Initializes a new instance of the WebDAV Version class
Back to Top
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Comment |
Public property | Creator |
Public property | Date |
Public property | Name |
Back to Top
See Also
WebDAV Version Class
NFX.IO.FileSystem.SVN Namespace


WebDAV.Version Constructor

WebDAV Version Constructor NFX Class Library

Initializes a new instance of the WebDAV Version class

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Version(
    string name,
    string comment,
    string creator,
    DateTime date
)
public Version(
    string name,
    string comment,
    string creator,
    DateTime date
)
Public Sub New (
    name As String,
    comment As String,
    creator As String,
    date As DateTime
)
Public Sub New (
    name As String,
    comment As String,
    creator As String,
    date As DateTime
)
public:
Version(
    String^ name,
    String^ comment,
    String^ creator,
    DateTime date
)
public:
Version(
    String^ name,
    String^ comment,
    String^ creator,
    DateTime date
)
new :
        name : string *
        comment : string *
        creator : string *
        date : DateTime -> Version
new :
        name : string *
        comment : string *
        creator : string *
        date : DateTime -> Version

Parameters

name
Type: Online System String
comment
Type: Online System String
creator
Type: Online System String
date
Type: Online System DateTime
See Also
WebDAV Version Class
WebDAV Version Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Version Methods

WebDAV Version Methods NFX Class Library

The WebDAV Version type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WebDAV Version Class
NFX.IO.FileSystem.SVN Namespace


WebDAV.Version.Equals Method

WebDAV Version Equals Method NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
WebDAV Version Class
WebDAV Version Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Version.GetHashCode Method

WebDAV Version GetHashCode Method NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
WebDAV Version Class
WebDAV Version Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Version.ToString Method

WebDAV Version ToString Method NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
WebDAV Version Class
WebDAV Version Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Version Properties

WebDAV Version Properties NFX Class Library

The WebDAV Version type exposes the following members.
Properties
 | Name | Description
Public property | Comment |
Public property | Creator |
Public property | Date |
Public property | Name |
Back to Top
See Also
WebDAV Version Class
NFX.IO.FileSystem.SVN Namespace


WebDAV.Version.Comment Property

WebDAV Version Comment Property NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Comment { get; }
public string Comment { get; }
Public ReadOnly Property Comment As String
    Get
Public ReadOnly Property Comment As String
    Get
public:
property String^ Comment {
    String^ get ();
}
public:
property String^ Comment {
    String^ get ();
}
member Comment : string with get
member Comment : string with get

Property Value

Type: Online String
See Also
WebDAV Version Class
WebDAV Version Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Version.Creator Property

WebDAV Version Creator Property NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Creator { get; }
public string Creator { get; }
Public ReadOnly Property Creator As String
    Get
Public ReadOnly Property Creator As String
    Get
public:
property String^ Creator {
    String^ get ();
}
public:
property String^ Creator {
    String^ get ();
}
member Creator : string with get
member Creator : string with get

Property Value

Type: Online String
See Also
WebDAV Version Class
WebDAV Version Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Version.Date Property

WebDAV Version Date Property NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime Date { get; }
public DateTime Date { get; }
Public ReadOnly Property Date As DateTime
    Get
Public ReadOnly Property Date As DateTime
    Get
public:
property DateTime Date {
    DateTime get ();
}
public:
property DateTime Date {
    DateTime get ();
}
member Date : DateTime with get
member Date : DateTime with get

Property Value

Type: Online DateTime
See Also
WebDAV Version Class
WebDAV Version Members
NFX.IO.FileSystem.SVN Namespace


WebDAV.Version.Name Property

WebDAV Version Name Property NFX Class Library

Namespace: NFX.IO.FileSystem.SVN
Assembly: NFX.Web (in NFX.Web.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
WebDAV Version Class
WebDAV Version Members
NFX.IO.FileSystem.SVN Namespace


NFX.IO.Net Namespace

NFX.IO.Net Namespace NFX Class Library

Structures
 | Structure | Description
Public structure | IPRange | Provides a reference-free key for matching of IP/net ranges


IPRange Structure

IPRange Structure NFX Class Library

Provides a reference-free key for matching of IP/net ranges

Namespace: NFX.IO.Net
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct IPRange : IEqualityComparer<IPRange>
public struct IPRange : IEqualityComparer<IPRange>
Public Structure IPRange
    Implements IEqualityComparer(Of IPRange)
Public Structure IPRange
    Implements IEqualityComparer(Of IPRange)
public value class IPRange : IEqualityComparer<IPRange>
public value class IPRange : IEqualityComparer<IPRange>
[<SealedAttribute>]
type IPRange =
    struct
        interface IEqualityComparer<IPRange>
    end
[<SealedAttribute>]
type IPRange =
    struct
        interface IEqualityComparer<IPRange>
    end
See Also
IPRange Members
NFX.IO.Net Namespace


IPRange Members

IPRange Members NFX Class Library

The IPRange type exposes the following members.
Constructors
 | Name | Description
Public method | IPRange(IPAddress) | Initializes a new instance of the IPRange class
Public method | IPRange(String) | Initializes a new instance of the IPRange class
Public method | IPRange(IPAddress, Int32) | Initializes a new instance of the IPRange class
Back to Top
Methods
 | Name | Description
Public method | Online Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Public method | Equals(IPRange, IPRange) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | GetHashCode(IPRange) |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
IPRange Structure
NFX.IO.Net Namespace


IPRange Constructor

IPRange Constructor NFX Class Library

Overload List
 | Name | Description
Public method | IPRange(IPAddress) | Initializes a new instance of the IPRange class
Public method | IPRange(String) | Initializes a new instance of the IPRange class
Public method | IPRange(IPAddress, Int32) | Initializes a new instance of the IPRange class
Back to Top
See Also
IPRange Structure
IPRange Members
NFX.IO.Net Namespace


IPRange Constructor (IPAddress)

IPRange Constructor (IPAddress) NFX Class Library

Initializes a new instance of the IPRange class

Namespace: NFX.IO.Net
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IPRange(
    IPAddress ip
)
public IPRange(
    IPAddress ip
)
Public Sub New (
    ip As IPAddress
)
Public Sub New (
    ip As IPAddress
)
public:
IPRange(
    IPAddress^ ip
)
public:
IPRange(
    IPAddress^ ip
)
new :
        ip : IPAddress -> IPRange
new :
        ip : IPAddress -> IPRange

Parameters

ip
Type: Online System.Net IPAddress
See Also
IPRange Structure
IPRange Members
IPRange Overload
NFX.IO.Net Namespace


IPRange Constructor (String)

IPRange Constructor (String) NFX Class Library

Initializes a new instance of the IPRange class

Namespace: NFX.IO.Net
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IPRange(
    string cidr
)
public IPRange(
    string cidr
)
Public Sub New (
    cidr As String
)
Public Sub New (
    cidr As String
)
public:
IPRange(
    String^ cidr
)
public:
IPRange(
    String^ cidr
)
new :
        cidr : string -> IPRange
new :
        cidr : string -> IPRange

Parameters

cidr
Type: Online System String
See Also
IPRange Structure
IPRange Members
IPRange Overload
NFX.IO.Net Namespace


IPRange Constructor (IPAddress, Int32)

IPRange Constructor (IPAddress, Int32) NFX Class Library

Initializes a new instance of the IPRange class

Namespace: NFX.IO.Net
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IPRange(
    IPAddress ip,
    int len
)
public IPRange(
    IPAddress ip,
    int len
)
Public Sub New (
    ip As IPAddress,
    len As Integer
)
Public Sub New (
    ip As IPAddress,
    len As Integer
)
public:
IPRange(
    IPAddress^ ip,
    int len
)
public:
IPRange(
    IPAddress^ ip,
    int len
)
new :
        ip : IPAddress *
        len : int -> IPRange
new :
        ip : IPAddress *
        len : int -> IPRange

Parameters

ip
Type: Online System.Net IPAddress
len
Type: Online System Int32
See Also
IPRange Structure
IPRange Members
IPRange Overload
NFX.IO.Net Namespace


IPRange Methods

IPRange Methods NFX Class Library

The IPRange type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Public method | Equals(IPRange, IPRange) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | GetHashCode(IPRange) |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
IPRange Structure
NFX.IO.Net Namespace


IPRange.Equals Method

IPRange Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Online Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Public method | Equals(IPRange, IPRange) |
Back to Top
See Also
IPRange Structure
IPRange Members
NFX.IO.Net Namespace


IPRange.Equals Method (IPRange, IPRange)

IPRange Equals Method (IPRange, IPRange) NFX Class Library

Namespace: NFX.IO.Net
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    IPRange x,
    IPRange y
)
public bool Equals(
    IPRange x,
    IPRange y
)
Public Function Equals (
    x As IPRange,
    y As IPRange
) As Boolean
Public Function Equals (
    x As IPRange,
    y As IPRange
) As Boolean
public:
virtual bool Equals(
    IPRange x,
    IPRange y
) sealed
public:
virtual bool Equals(
    IPRange x,
    IPRange y
) sealed
abstract Equals :
        x : IPRange *
        y : IPRange -> bool
override Equals :
        x : IPRange *
        y : IPRange -> bool
abstract Equals :
        x : IPRange *
        y : IPRange -> bool
override Equals :
        x : IPRange *
        y : IPRange -> bool

Parameters

x
Type: NFX.IO.Net IPRange
y
Type: NFX.IO.Net IPRange

Return Value

Type: Online Boolean

Implements

Online IEqualityComparer T Equals(T, T)
See Also
IPRange Structure
IPRange Members
Equals Overload
NFX.IO.Net Namespace


IPRange.GetHashCode Method

IPRange GetHashCode Method NFX Class Library

Overload List
 | Name | Description
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | GetHashCode(IPRange) |
Back to Top
See Also
IPRange Structure
IPRange Members
NFX.IO.Net Namespace


IPRange.GetHashCode Method (IPRange)

IPRange GetHashCode Method (IPRange) NFX Class Library

Namespace: NFX.IO.Net
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int GetHashCode(
    IPRange obj
)
public int GetHashCode(
    IPRange obj
)
Public Function GetHashCode (
    obj As IPRange
) As Integer
Public Function GetHashCode (
    obj As IPRange
) As Integer
public:
virtual int GetHashCode(
    IPRange obj
) sealed
public:
virtual int GetHashCode(
    IPRange obj
) sealed
abstract GetHashCode :
        obj : IPRange -> int
override GetHashCode :
        obj : IPRange -> int
abstract GetHashCode :
        obj : IPRange -> int
override GetHashCode :
        obj : IPRange -> int

Parameters

obj
Type: NFX.IO.Net IPRange

Return Value

Type: Online Int32

Implements

Online IEqualityComparer T GetHashCode(T)
See Also
IPRange Structure
IPRange Members
GetHashCode Overload
NFX.IO.Net Namespace


NFX.IO.Net.Gate Namespace

NFX.IO.Net.Gate Namespace NFX Class Library

Classes
 | Class | Description
Public class | Group |
Public class | Group Address | Represents the address node of the group
Public class | NetGate | Represents a network gate - a logical filter of incoming network traffic. Network gate is somewhat similar to a firewall - it allows/denies the int/out traffic based on the set of rules
Public class | NetGate State |
Public class | NetGateException | Throw by NetGate
Public class | NetSiteState | Represents the state of the metwrk site - it can be a particular address or group
Protected class | NetSiteState _value |
Public class | NOPNetGate | Represents an implementation of INetGate that allows all traffic
Public class | Rule | Represents the named rule for NetGate
Public class | VarDef | Provides variable definition - the name and parameters how fast a variable decays - loses its value towards 0 when it gets deleted
Structures
 | Structure | Description
Public structure | GeneralTraffic | Represents general kind of traffic not bound to any particular technology
Public structure | HTTPIncomingTraffic | Represents HTTP traffic that arrives via HttpListener
Interfaces
 | Interface | Description
Public interface | INetGate | Stipulates general contract for nrtwork gates - entities similar to firewall. Network gates allow/deny in/out traffic based on a set of rules
Public interface | INetGateImplementation |
Public interface | ITraffic | Represents a traffic that passes through network gate
Enumerations
 | Enumeration | Description
Public enumeration | GateAction | Allow/Deny
Public enumeration | TrafficDirection |


GateAction Enumeration

GateAction Enumeration NFX Class Library

Allow/Deny

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum GateAction
public enum GateAction
Public Enumeration GateAction
Public Enumeration GateAction
public enum class GateAction
public enum class GateAction
type GateAction
type GateAction
Members
Member name | Value | Description
Deny | 0 |
Allow | 1 |
See Also
NFX.IO.Net.Gate Namespace


GeneralTraffic Structure

GeneralTraffic Structure NFX Class Library

Represents general kind of traffic not bound to any particular technology

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct GeneralTraffic : ITraffic
public struct GeneralTraffic : ITraffic
Public Structure GeneralTraffic
    Implements ITraffic
Public Structure GeneralTraffic
    Implements ITraffic
public value class GeneralTraffic : ITraffic
public value class GeneralTraffic : ITraffic
[<SealedAttribute>]
type GeneralTraffic =
    struct
        interface ITraffic
    end
[<SealedAttribute>]
type GeneralTraffic =
    struct
        interface ITraffic
    end
See Also
GeneralTraffic Members
NFX.IO.Net.Gate Namespace


GeneralTraffic Members

GeneralTraffic Members NFX Class Library

The GeneralTraffic type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Direction |
Public property | FromAddress |
Public property | Items |
Public property | Method |
Public property | RequestURL |
Public property | Service |
Public property | ToAddress |
Back to Top
See Also
GeneralTraffic Structure
NFX.IO.Net.Gate Namespace


GeneralTraffic Methods

GeneralTraffic Methods NFX Class Library

The GeneralTraffic type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GeneralTraffic Structure
NFX.IO.Net.Gate Namespace


GeneralTraffic Properties

GeneralTraffic Properties NFX Class Library

The GeneralTraffic type exposes the following members.
Properties
 | Name | Description
Public property | Direction |
Public property | FromAddress |
Public property | Items |
Public property | Method |
Public property | RequestURL |
Public property | Service |
Public property | ToAddress |
Back to Top
See Also
GeneralTraffic Structure
NFX.IO.Net.Gate Namespace


GeneralTraffic.Direction Property

GeneralTraffic Direction Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TrafficDirection Direction { get; set; }
public TrafficDirection Direction { get; set; }
Public Property Direction As TrafficDirection
    Get
    Set
Public Property Direction As TrafficDirection
    Get
    Set
public:
virtual property TrafficDirection Direction {
    TrafficDirection get () sealed;
    void set (TrafficDirection value) sealed;
}
public:
virtual property TrafficDirection Direction {
    TrafficDirection get () sealed;
    void set (TrafficDirection value) sealed;
}
abstract Direction : TrafficDirection with get, set
override Direction : TrafficDirection with get, set
abstract Direction : TrafficDirection with get, set
override Direction : TrafficDirection with get, set

Property Value

Type: TrafficDirection

Implements

ITraffic Direction
See Also
GeneralTraffic Structure
GeneralTraffic Members
NFX.IO.Net.Gate Namespace


GeneralTraffic.FromAddress Property

GeneralTraffic FromAddress Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string FromAddress { get; set; }
public string FromAddress { get; set; }
Public Property FromAddress As String
    Get
    Set
Public Property FromAddress As String
    Get
    Set
public:
virtual property String^ FromAddress {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ FromAddress {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract FromAddress : string with get, set
override FromAddress : string with get, set
abstract FromAddress : string with get, set
override FromAddress : string with get, set

Property Value

Type: Online String

Implements

ITraffic FromAddress
See Also
GeneralTraffic Structure
GeneralTraffic Members
NFX.IO.Net.Gate Namespace


GeneralTraffic.Items Property

GeneralTraffic Items Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<string, Object> Items { get; set; }
public IDictionary<string, Object> Items { get; set; }
Public Property Items As IDictionary(Of String, Object)
    Get
    Set
Public Property Items As IDictionary(Of String, Object)
    Get
    Set
public:
virtual property IDictionary<String^, Object^>^ Items {
    IDictionary<String^, Object^>^ get () sealed;
    void set (IDictionary<String^, Object^>^ value) sealed;
}
public:
virtual property IDictionary<String^, Object^>^ Items {
    IDictionary<String^, Object^>^ get () sealed;
    void set (IDictionary<String^, Object^>^ value) sealed;
}
abstract Items : IDictionary<string, Object> with get, set
override Items : IDictionary<string, Object> with get, set
abstract Items : IDictionary<string, Object> with get, set
override Items : IDictionary<string, Object> with get, set

Property Value

Type: Online IDictionary Online String, Online Object

Implements

ITraffic Items
See Also
GeneralTraffic Structure
GeneralTraffic Members
NFX.IO.Net.Gate Namespace


GeneralTraffic.Method Property

GeneralTraffic Method Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Method { get; set; }
public string Method { get; set; }
Public Property Method As String
    Get
    Set
Public Property Method As String
    Get
    Set
public:
virtual property String^ Method {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ Method {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Method : string with get, set
override Method : string with get, set
abstract Method : string with get, set
override Method : string with get, set

Property Value

Type: Online String

Implements

ITraffic Method
See Also
GeneralTraffic Structure
GeneralTraffic Members
NFX.IO.Net.Gate Namespace


GeneralTraffic.RequestURL Property

GeneralTraffic RequestURL Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string RequestURL { get; set; }
public string RequestURL { get; set; }
Public Property RequestURL As String
    Get
    Set
Public Property RequestURL As String
    Get
    Set
public:
virtual property String^ RequestURL {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ RequestURL {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract RequestURL : string with get, set
override RequestURL : string with get, set
abstract RequestURL : string with get, set
override RequestURL : string with get, set

Property Value

Type: Online String

Implements

ITraffic RequestURL
See Also
GeneralTraffic Structure
GeneralTraffic Members
NFX.IO.Net.Gate Namespace


GeneralTraffic.Service Property

GeneralTraffic Service Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Service { get; set; }
public string Service { get; set; }
Public Property Service As String
    Get
    Set
Public Property Service As String
    Get
    Set
public:
virtual property String^ Service {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ Service {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Service : string with get, set
override Service : string with get, set
abstract Service : string with get, set
override Service : string with get, set

Property Value

Type: Online String

Implements

ITraffic Service
See Also
GeneralTraffic Structure
GeneralTraffic Members
NFX.IO.Net.Gate Namespace


GeneralTraffic.ToAddress Property

GeneralTraffic ToAddress Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ToAddress { get; set; }
public string ToAddress { get; set; }
Public Property ToAddress As String
    Get
    Set
Public Property ToAddress As String
    Get
    Set
public:
virtual property String^ ToAddress {
    String^ get () sealed;
    void set (String^ value) sealed;
}
public:
virtual property String^ ToAddress {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract ToAddress : string with get, set
override ToAddress : string with get, set
abstract ToAddress : string with get, set
override ToAddress : string with get, set

Property Value

Type: Online String

Implements

ITraffic ToAddress
See Also
GeneralTraffic Structure
GeneralTraffic Members
NFX.IO.Net.Gate Namespace


Group Class

Group Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.IO.Net.Gate Group

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Group : INamed, IOrdered
public class Group : INamed, IOrdered
Public Class Group
    Implements INamed, IOrdered
Public Class Group
    Implements INamed, IOrdered
public ref class Group : INamed, IOrdered
public ref class Group : INamed, IOrdered
type Group =
    class
        interface INamed
        interface IOrdered
    end
type Group =
    class
        interface INamed
        interface IOrdered
    end
See Also
Group Members
NFX.IO.Net.Gate Namespace


Group Members

Group Members NFX Class Library

The Group type exposes the following members.
Constructors
 | Name | Description
Public method | Group(IConfigSectionNode) | Initializes a new instance of the Group class
Public method | Group(String, Int32) | Initializes a new instance of the Group class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match | Tries to find an address in group and returns it or null
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Addresses | Addresses that are part of the group
Public property | Key | Returns group key for lookup in State.NetState object
Public property | Name |
Public property | Order |
Back to Top
See Also
Group Class
NFX.IO.Net.Gate Namespace


Group Constructor

Group Constructor NFX Class Library

Overload List
 | Name | Description
Public method | Group(IConfigSectionNode) | Initializes a new instance of the Group class
Public method | Group(String, Int32) | Initializes a new instance of the Group class
Back to Top
See Also
Group Class
Group Members
NFX.IO.Net.Gate Namespace


Group Constructor (IConfigSectionNode)

Group Constructor (IConfigSectionNode) NFX Class Library

Initializes a new instance of the Group class

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Group(
    IConfigSectionNode node
)
public Group(
    IConfigSectionNode node
)
Public Sub New (
    node As IConfigSectionNode
)
Public Sub New (
    node As IConfigSectionNode
)
public:
Group(
    IConfigSectionNode^ node
)
public:
Group(
    IConfigSectionNode^ node
)
new :
        node : IConfigSectionNode -> Group
new :
        node : IConfigSectionNode -> Group

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
Group Class
Group Members
Group Overload
NFX.IO.Net.Gate Namespace


Group Constructor (String, Int32)

Group Constructor (String, Int32) NFX Class Library

Initializes a new instance of the Group class

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Group(
    string name,
    int order
)
public Group(
    string name,
    int order
)
Public Sub New (
    name As String,
    order As Integer
)
Public Sub New (
    name As String,
    order As Integer
)
public:
Group(
    String^ name,
    int order
)
public:
Group(
    String^ name,
    int order
)
new :
        name : string *
        order : int -> Group
new :
        name : string *
        order : int -> Group

Parameters

name
Type: Online System String
order
Type: Online System Int32
See Also
Group Class
Group Members
Group Overload
NFX.IO.Net.Gate Namespace


Group Methods

Group Methods NFX Class Library

The Group type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match | Tries to find an address in group and returns it or null
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Group Class
NFX.IO.Net.Gate Namespace


Group.Match Method

Group Match Method NFX Class Library

Tries to find an address in group and returns it or null

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Group..::..Address Match(
    string address
)
public Group..::..Address Match(
    string address
)
Public Function Match (
    address As String
) As Group..::..Address
Public Function Match (
    address As String
) As Group..::..Address
public:
Group..::..Address^ Match(
    String^ address
)
public:
Group..::..Address^ Match(
    String^ address
)
member Match :
        address : string -> Group..::..Address
member Match :
        address : string -> Group..::..Address

Parameters

address
Type: Online System String

Return Value

Type: Group Address
See Also
Group Class
Group Members
NFX.IO.Net.Gate Namespace


Group Properties

Group Properties NFX Class Library

The Group type exposes the following members.
Properties
 | Name | Description
Public property | Addresses | Addresses that are part of the group
Public property | Key | Returns group key for lookup in State.NetState object
Public property | Name |
Public property | Order |
Back to Top
See Also
Group Class
NFX.IO.Net.Gate Namespace


Group.Addresses Property

Group Addresses Property NFX Class Library

Addresses that are part of the group

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderedRegistry<Group..::..Address> Addresses { get; }
public OrderedRegistry<Group..::..Address> Addresses { get; }
Public ReadOnly Property Addresses As OrderedRegistry(Of Group..::..Address)
    Get
Public ReadOnly Property Addresses As OrderedRegistry(Of Group..::..Address)
    Get
public:
property OrderedRegistry<Group..::..Address^>^ Addresses {
    OrderedRegistry<Group..::..Address^>^ get ();
}
public:
property OrderedRegistry<Group..::..Address^>^ Addresses {
    OrderedRegistry<Group..::..Address^>^ get ();
}
member Addresses : OrderedRegistry<Group..::..Address> with get
member Addresses : OrderedRegistry<Group..::..Address> with get

Property Value

Type: OrderedRegistry Group Address
See Also
Group Class
Group Members
NFX.IO.Net.Gate Namespace


Group.Key Property

Group Key Property NFX Class Library

Returns group key for lookup in State.NetState object

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Key { get; }
public string Key { get; }
Public ReadOnly Property Key As String
    Get
Public ReadOnly Property Key As String
    Get
public:
property String^ Key {
    String^ get ();
}
public:
property String^ Key {
    String^ get ();
}
member Key : string with get
member Key : string with get

Property Value

Type: Online String
See Also
Group Class
Group Members
NFX.IO.Net.Gate Namespace


Group.Name Property

Group Name Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
Group Class
Group Members
NFX.IO.Net.Gate Namespace


Group.Order Property

Group Order Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Order { get; }
public int Order { get; }
Public ReadOnly Property Order As Integer
    Get
Public ReadOnly Property Order As Integer
    Get
public:
virtual property int Order {
    int get () sealed;
}
public:
virtual property int Order {
    int get () sealed;
}
abstract Order : int with get
override Order : int with get
abstract Order : int with get
override Order : int with get

Property Value

Type: Online Int32

Implements

IOrdered Order
See Also
Group Class
Group Members
NFX.IO.Net.Gate Namespace


Group.Address Class

Group Address Class NFX Class Library

Represents the address node of the group
Inheritance Hierarchy
Online System Object
NFX.IO.Net.Gate Group Address

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Address : INamed, IOrdered
public class Address : INamed, IOrdered
Public Class Address
    Implements INamed, IOrdered
Public Class Address
    Implements INamed, IOrdered
public ref class Address : INamed,
    IOrdered
public ref class Address : INamed,
    IOrdered
type Address =
    class
        interface INamed
        interface IOrdered
    end
type Address =
    class
        interface INamed
        interface IOrdered
    end
See Also
Group Address Members
NFX.IO.Net.Gate Namespace


Group.Address Members

Group Address Members NFX Class Library

The Group Address type exposes the following members.
Constructors
 | Name | Description
Public method | Group Address(IConfigSectionNode) | Initializes a new instance of the Group Address class
Public method | Group Address(String, Int32, String) | Initializes a new instance of the Group Address class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name |
Public property | Order |
Public property | Patterns |
Back to Top
See Also
Group Address Class
NFX.IO.Net.Gate Namespace


Group.Address Constructor

Group Address Constructor NFX Class Library

Overload List
 | Name | Description
Public method | Group Address(IConfigSectionNode) | Initializes a new instance of the Group Address class
Public method | Group Address(String, Int32, String) | Initializes a new instance of the Group Address class
Back to Top
See Also
Group Address Class
Group Address Members
NFX.IO.Net.Gate Namespace


Group.Address Constructor (IConfigSectionNode)

Group Address Constructor (IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Group Address class

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Address(
    IConfigSectionNode node
)
public Address(
    IConfigSectionNode node
)
Public Sub New (
    node As IConfigSectionNode
)
Public Sub New (
    node As IConfigSectionNode
)
public:
Address(
    IConfigSectionNode^ node
)
public:
Address(
    IConfigSectionNode^ node
)
new :
        node : IConfigSectionNode -> Address
new :
        node : IConfigSectionNode -> Address

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
Group Address Class
Group Address Members
Group Address Overload
NFX.IO.Net.Gate Namespace


Group.Address Constructor (String, Int32, String)

Group Address Constructor (String, Int32, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Group Address class

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Address(
    string name,
    int order,
    string patterns
)
public Address(
    string name,
    int order,
    string patterns
)
Public Sub New (
    name As String,
    order As Integer,
    patterns As String
)
Public Sub New (
    name As String,
    order As Integer,
    patterns As String
)
public:
Address(
    String^ name,
    int order,
    String^ patterns
)
public:
Address(
    String^ name,
    int order,
    String^ patterns
)
new :
        name : string *
        order : int *
        patterns : string -> Address
new :
        name : string *
        order : int *
        patterns : string -> Address

Parameters

name
Type: Online System String
order
Type: Online System Int32
patterns
Type: Online System String
See Also
Group Address Class
Group Address Members
Group Address Overload
NFX.IO.Net.Gate Namespace


Group.Address Methods

Group Address Methods NFX Class Library

The Group Address type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Match |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Group Address Class
NFX.IO.Net.Gate Namespace


Group.Address.Match Method

Group Address Match Method NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Match(
    string address
)
public virtual bool Match(
    string address
)
Public Overridable Function Match (
    address As String
) As Boolean
Public Overridable Function Match (
    address As String
) As Boolean
public:
virtual bool Match(
    String^ address
)
public:
virtual bool Match(
    String^ address
)
abstract Match :
        address : string -> bool
override Match :
        address : string -> bool
abstract Match :
        address : string -> bool
override Match :
        address : string -> bool

Parameters

address
Type: Online System String

Return Value

Type: Online Boolean
See Also
Group Address Class
Group Address Members
NFX.IO.Net.Gate Namespace


Group.Address Properties

Group Address Properties NFX Class Library

The Group Address type exposes the following members.
Properties
 | Name | Description
Public property | Name |
Public property | Order |
Public property | Patterns |
Back to Top
See Also
Group Address Class
NFX.IO.Net.Gate Namespace


Group.Address.Name Property

Group Address Name Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
Group Address Class
Group Address Members
NFX.IO.Net.Gate Namespace


Group.Address.Order Property

Group Address Order Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Order { get; }
public int Order { get; }
Public ReadOnly Property Order As Integer
    Get
Public ReadOnly Property Order As Integer
    Get
public:
virtual property int Order {
    int get () sealed;
}
public:
virtual property int Order {
    int get () sealed;
}
abstract Order : int with get
override Order : int with get
abstract Order : int with get
override Order : int with get

Property Value

Type: Online Int32

Implements

IOrdered Order
See Also
Group Address Class
Group Address Members
NFX.IO.Net.Gate Namespace


Group.Address.Patterns Property

Group Address Patterns Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string Patterns { get; set; }
[ConfigAttribute]
public string Patterns { get; set; }
<ConfigAttribute>
Public Property Patterns As String
    Get
    Set
<ConfigAttribute>
Public Property Patterns As String
    Get
    Set
public:
[ConfigAttribute]
property String^ Patterns {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ Patterns {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member Patterns : string with get, set
[<ConfigAttribute>]
member Patterns : string with get, set

Property Value

Type: Online String
See Also
Group Address Class
Group Address Members
NFX.IO.Net.Gate Namespace


HTTPIncomingTraffic Structure

HTTPIncomingTraffic Structure NFX Class Library

Represents HTTP traffic that arrives via HttpListener

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct HTTPIncomingTraffic : ITraffic
public struct HTTPIncomingTraffic : ITraffic
Public Structure HTTPIncomingTraffic
    Implements ITraffic
Public Structure HTTPIncomingTraffic
    Implements ITraffic
public value class HTTPIncomingTraffic : ITraffic
public value class HTTPIncomingTraffic : ITraffic
[<SealedAttribute>]
type HTTPIncomingTraffic =
    struct
        interface ITraffic
    end
[<SealedAttribute>]
type HTTPIncomingTraffic =
    struct
        interface ITraffic
    end
See Also
HTTPIncomingTraffic Members
NFX.IO.Net.Gate Namespace


HTTPIncomingTraffic Members

HTTPIncomingTraffic Members NFX Class Library

The HTTPIncomingTraffic type exposes the following members.
Constructors
 | Name | Description
Public method | HTTPIncomingTraffic | Initializes a new instance of the HTTPIncomingTraffic class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Direction |
Public property | FromAddress |
Public property | Items |
Public property | Method |
Public property | RequestURL |
Public property | Service |
Public property | ToAddress |
Back to Top
See Also
HTTPIncomingTraffic Structure
NFX.IO.Net.Gate Namespace


HTTPIncomingTraffic Constructor

HTTPIncomingTraffic Constructor NFX Class Library

Initializes a new instance of the HTTPIncomingTraffic class

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HTTPIncomingTraffic(
    HttpListenerRequest request,
    string realRemoteAddressHdr = null
)
public HTTPIncomingTraffic(
    HttpListenerRequest request,
    string realRemoteAddressHdr = null
)
Public Sub New (
    request As HttpListenerRequest,
    Optional realRemoteAddressHdr As String = Nothing
)
Public Sub New (
    request As HttpListenerRequest,
    Optional realRemoteAddressHdr As String = Nothing
)
public:
HTTPIncomingTraffic(
    HttpListenerRequest^ request,
    String^ realRemoteAddressHdr = nullptr
)
public:
HTTPIncomingTraffic(
    HttpListenerRequest^ request,
    String^ realRemoteAddressHdr = nullptr
)
new :
        request : HttpListenerRequest *
        ?realRemoteAddressHdr : string
(* Defaults:
        let _realRemoteAddressHdr = defaultArg realRemoteAddressHdr null
*)
-> HTTPIncomingTraffic
new :
        request : HttpListenerRequest *
        ?realRemoteAddressHdr : string
(* Defaults:
        let _realRemoteAddressHdr = defaultArg realRemoteAddressHdr null
*)
-> HTTPIncomingTraffic

Parameters

request
Type: Online System.Net HttpListenerRequest
realRemoteAddressHdr (Optional)
Type: Online System String
See Also
HTTPIncomingTraffic Structure
HTTPIncomingTraffic Members
NFX.IO.Net.Gate Namespace


HTTPIncomingTraffic Methods

HTTPIncomingTraffic Methods NFX Class Library

The HTTPIncomingTraffic type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
HTTPIncomingTraffic Structure
NFX.IO.Net.Gate Namespace


HTTPIncomingTraffic Properties

HTTPIncomingTraffic Properties NFX Class Library

The HTTPIncomingTraffic type exposes the following members.
Properties
 | Name | Description
Public property | Direction |
Public property | FromAddress |
Public property | Items |
Public property | Method |
Public property | RequestURL |
Public property | Service |
Public property | ToAddress |
Back to Top
See Also
HTTPIncomingTraffic Structure
NFX.IO.Net.Gate Namespace


HTTPIncomingTraffic.Direction Property

HTTPIncomingTraffic Direction Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TrafficDirection Direction { get; }
public TrafficDirection Direction { get; }
Public ReadOnly Property Direction As TrafficDirection
    Get
Public ReadOnly Property Direction As TrafficDirection
    Get
public:
virtual property TrafficDirection Direction {
    TrafficDirection get () sealed;
}
public:
virtual property TrafficDirection Direction {
    TrafficDirection get () sealed;
}
abstract Direction : TrafficDirection with get
override Direction : TrafficDirection with get
abstract Direction : TrafficDirection with get
override Direction : TrafficDirection with get

Property Value

Type: TrafficDirection

Implements

ITraffic Direction
See Also
HTTPIncomingTraffic Structure
HTTPIncomingTraffic Members
NFX.IO.Net.Gate Namespace


HTTPIncomingTraffic.FromAddress Property

HTTPIncomingTraffic FromAddress Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string FromAddress { get; }
public string FromAddress { get; }
Public ReadOnly Property FromAddress As String
    Get
Public ReadOnly Property FromAddress As String
    Get
public:
virtual property String^ FromAddress {
    String^ get () sealed;
}
public:
virtual property String^ FromAddress {
    String^ get () sealed;
}
abstract FromAddress : string with get
override FromAddress : string with get
abstract FromAddress : string with get
override FromAddress : string with get

Property Value

Type: Online String

Implements

ITraffic FromAddress
See Also
HTTPIncomingTraffic Structure
HTTPIncomingTraffic Members
NFX.IO.Net.Gate Namespace


HTTPIncomingTraffic.Items Property

HTTPIncomingTraffic Items Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<string, Object> Items { get; }
public IDictionary<string, Object> Items { get; }
Public ReadOnly Property Items As IDictionary(Of String, Object)
    Get
Public ReadOnly Property Items As IDictionary(Of String, Object)
    Get
public:
virtual property IDictionary<String^, Object^>^ Items {
    IDictionary<String^, Object^>^ get () sealed;
}
public:
virtual property IDictionary<String^, Object^>^ Items {
    IDictionary<String^, Object^>^ get () sealed;
}
abstract Items : IDictionary<string, Object> with get
override Items : IDictionary<string, Object> with get
abstract Items : IDictionary<string, Object> with get
override Items : IDictionary<string, Object> with get

Property Value

Type: Online IDictionary Online String, Online Object

Implements

ITraffic Items
See Also
HTTPIncomingTraffic Structure
HTTPIncomingTraffic Members
NFX.IO.Net.Gate Namespace


HTTPIncomingTraffic.Method Property

HTTPIncomingTraffic Method Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Method { get; }
public string Method { get; }
Public ReadOnly Property Method As String
    Get
Public ReadOnly Property Method As String
    Get
public:
virtual property String^ Method {
    String^ get () sealed;
}
public:
virtual property String^ Method {
    String^ get () sealed;
}
abstract Method : string with get
override Method : string with get
abstract Method : string with get
override Method : string with get

Property Value

Type: Online String

Implements

ITraffic Method
See Also
HTTPIncomingTraffic Structure
HTTPIncomingTraffic Members
NFX.IO.Net.Gate Namespace


HTTPIncomingTraffic.RequestURL Property

HTTPIncomingTraffic RequestURL Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string RequestURL { get; }
public string RequestURL { get; }
Public ReadOnly Property RequestURL As String
    Get
Public ReadOnly Property RequestURL As String
    Get
public:
virtual property String^ RequestURL {
    String^ get () sealed;
}
public:
virtual property String^ RequestURL {
    String^ get () sealed;
}
abstract RequestURL : string with get
override RequestURL : string with get
abstract RequestURL : string with get
override RequestURL : string with get

Property Value

Type: Online String

Implements

ITraffic RequestURL
See Also
HTTPIncomingTraffic Structure
HTTPIncomingTraffic Members
NFX.IO.Net.Gate Namespace


HTTPIncomingTraffic.Service Property

HTTPIncomingTraffic Service Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Service { get; }
public string Service { get; }
Public ReadOnly Property Service As String
    Get
Public ReadOnly Property Service As String
    Get
public:
virtual property String^ Service {
    String^ get () sealed;
}
public:
virtual property String^ Service {
    String^ get () sealed;
}
abstract Service : string with get
override Service : string with get
abstract Service : string with get
override Service : string with get

Property Value

Type: Online String

Implements

ITraffic Service
See Also
HTTPIncomingTraffic Structure
HTTPIncomingTraffic Members
NFX.IO.Net.Gate Namespace


HTTPIncomingTraffic.ToAddress Property

HTTPIncomingTraffic ToAddress Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ToAddress { get; }
public string ToAddress { get; }
Public ReadOnly Property ToAddress As String
    Get
Public ReadOnly Property ToAddress As String
    Get
public:
virtual property String^ ToAddress {
    String^ get () sealed;
}
public:
virtual property String^ ToAddress {
    String^ get () sealed;
}
abstract ToAddress : string with get
override ToAddress : string with get
abstract ToAddress : string with get
override ToAddress : string with get

Property Value

Type: Online String

Implements

ITraffic ToAddress
See Also
HTTPIncomingTraffic Structure
HTTPIncomingTraffic Members
NFX.IO.Net.Gate Namespace


INetGate Interface

INetGate Interface NFX Class Library

Stipulates general contract for nrtwork gates - entities similar to firewall. Network gates allow/deny in/out traffic based on a set of rules

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface INetGate : IApplicationComponent,
    IDisposable
public interface INetGate : IApplicationComponent,
    IDisposable
Public Interface INetGate
    Inherits IApplicationComponent, IDisposable
Public Interface INetGate
    Inherits IApplicationComponent, IDisposable
public interface class INetGate : IApplicationComponent,
    IDisposable
public interface class INetGate : IApplicationComponent,
    IDisposable
type INetGate =
    interface
        interface IApplicationComponent
        interface IDisposable
    end
type INetGate =
    interface
        interface IApplicationComponent
        interface IDisposable
    end
See Also
INetGate Members
NFX.IO.Net.Gate Namespace


INetGate Members

INetGate Members NFX Class Library

The INetGate type exposes the following members.
Methods
 | Name | Description
Public method | CheckTraffic(ITraffic) | Checks whether the specified traffic is allowed or denied
Public method | CheckTraffic(ITraffic, Rule ) | Checks whether the specified traffic is allowed or denied. Returns the rule that determined the allow/deny outcome or null when no rule matched
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | IncreaseVariable | Increases the named variable in the network scope which this specified traffic falls under
Public method | SetVariable | Sets the named variable in the network scope which this specified traffic falls under
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | Enabled | When gate is not enabled it allows all traffic bypassing any rules
Back to Top
See Also
INetGate Interface
NFX.IO.Net.Gate Namespace


INetGate Methods

INetGate Methods NFX Class Library

The INetGate type exposes the following members.
Methods
 | Name | Description
Public method | CheckTraffic(ITraffic) | Checks whether the specified traffic is allowed or denied
Public method | CheckTraffic(ITraffic, Rule ) | Checks whether the specified traffic is allowed or denied. Returns the rule that determined the allow/deny outcome or null when no rule matched
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | IncreaseVariable | Increases the named variable in the network scope which this specified traffic falls under
Public method | SetVariable | Sets the named variable in the network scope which this specified traffic falls under
Back to Top
See Also
INetGate Interface
NFX.IO.Net.Gate Namespace


INetGate.CheckTraffic Method

INetGate CheckTraffic Method NFX Class Library

Overload List
 | Name | Description
Public method | CheckTraffic(ITraffic) | Checks whether the specified traffic is allowed or denied
Public method | CheckTraffic(ITraffic, Rule ) | Checks whether the specified traffic is allowed or denied. Returns the rule that determined the allow/deny outcome or null when no rule matched
Back to Top
See Also
INetGate Interface
INetGate Members
NFX.IO.Net.Gate Namespace


INetGate.CheckTraffic Method (ITraffic)

INetGate CheckTraffic Method (ITraffic) NFX Class Library

Checks whether the specified traffic is allowed or denied

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GateAction CheckTraffic(
    ITraffic traffic
)
GateAction CheckTraffic(
    ITraffic traffic
)
Function CheckTraffic (
    traffic As ITraffic
) As GateAction
Function CheckTraffic (
    traffic As ITraffic
) As GateAction
GateAction CheckTraffic(
    ITraffic^ traffic
)
GateAction CheckTraffic(
    ITraffic^ traffic
)
abstract CheckTraffic :
        traffic : ITraffic -> GateAction
abstract CheckTraffic :
        traffic : ITraffic -> GateAction

Parameters

traffic
Type: NFX.IO.Net.Gate ITraffic

Return Value

Type: GateAction
See Also
INetGate Interface
INetGate Members
CheckTraffic Overload
NFX.IO.Net.Gate Namespace


INetGate.CheckTraffic Method (ITraffic, Rule)

INetGate CheckTraffic Method (ITraffic, Rule ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Checks whether the specified traffic is allowed or denied. Returns the rule that determined the allow/deny outcome or null when no rule matched

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
GateAction CheckTraffic(
    ITraffic traffic,
    out Rule rule
)
GateAction CheckTraffic(
    ITraffic traffic,
    out Rule rule
)
Function CheckTraffic (
    traffic As ITraffic,
    <OutAttribute> ByRef rule As Rule
) As GateAction
Function CheckTraffic (
    traffic As ITraffic,
    <OutAttribute> ByRef rule As Rule
) As GateAction
GateAction CheckTraffic(
    ITraffic^ traffic,
    [OutAttribute] Rule^% rule
)
GateAction CheckTraffic(
    ITraffic^ traffic,
    [OutAttribute] Rule^% rule
)
abstract CheckTraffic :
        traffic : ITraffic *
        rule : Rule byref -> GateAction
abstract CheckTraffic :
        traffic : ITraffic *
        rule : Rule byref -> GateAction

Parameters

traffic
Type: NFX.IO.Net.Gate ITraffic
rule
Type: NFX.IO.Net.Gate Rule

Return Value

Type: GateAction
See Also
INetGate Interface
INetGate Members
CheckTraffic Overload
NFX.IO.Net.Gate Namespace


INetGate.IncreaseVariable Method

INetGate IncreaseVariable Method NFX Class Library

Increases the named variable in the network scope which this specified traffic falls under

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void IncreaseVariable(
    TrafficDirection direction,
    string address,
    string varName,
    int value
)
void IncreaseVariable(
    TrafficDirection direction,
    string address,
    string varName,
    int value
)
Sub IncreaseVariable (
    direction As TrafficDirection,
    address As String,
    varName As String,
    value As Integer
)
Sub IncreaseVariable (
    direction As TrafficDirection,
    address As String,
    varName As String,
    value As Integer
)
void IncreaseVariable(
    TrafficDirection direction,
    String^ address,
    String^ varName,
    int value
)
void IncreaseVariable(
    TrafficDirection direction,
    String^ address,
    String^ varName,
    int value
)
abstract IncreaseVariable :
        direction : TrafficDirection *
        address : string *
        varName : string *
        value : int -> unit
abstract IncreaseVariable :
        direction : TrafficDirection *
        address : string *
        varName : string *
        value : int -> unit

Parameters

direction
Type: NFX.IO.Net.Gate TrafficDirection
address
Type: Online System String
varName
Type: Online System String
value
Type: Online System Int32
See Also
INetGate Interface
INetGate Members
NFX.IO.Net.Gate Namespace


INetGate.SetVariable Method

INetGate SetVariable Method NFX Class Library

Sets the named variable in the network scope which this specified traffic falls under

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void SetVariable(
    TrafficDirection direction,
    string address,
    string varName,
    int value
)
void SetVariable(
    TrafficDirection direction,
    string address,
    string varName,
    int value
)
Sub SetVariable (
    direction As TrafficDirection,
    address As String,
    varName As String,
    value As Integer
)
Sub SetVariable (
    direction As TrafficDirection,
    address As String,
    varName As String,
    value As Integer
)
void SetVariable(
    TrafficDirection direction,
    String^ address,
    String^ varName,
    int value
)
void SetVariable(
    TrafficDirection direction,
    String^ address,
    String^ varName,
    int value
)
abstract SetVariable :
        direction : TrafficDirection *
        address : string *
        varName : string *
        value : int -> unit
abstract SetVariable :
        direction : TrafficDirection *
        address : string *
        varName : string *
        value : int -> unit

Parameters

direction
Type: NFX.IO.Net.Gate TrafficDirection
address
Type: Online System String
varName
Type: Online System String
value
Type: Online System Int32
See Also
INetGate Interface
INetGate Members
NFX.IO.Net.Gate Namespace


INetGate Properties

INetGate Properties NFX Class Library

The INetGate type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | Enabled | When gate is not enabled it allows all traffic bypassing any rules
Back to Top
See Also
INetGate Interface
NFX.IO.Net.Gate Namespace


INetGate.Enabled Property

INetGate Enabled Property NFX Class Library

When gate is not enabled it allows all traffic bypassing any rules

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Enabled { get; }
bool Enabled { get; }
ReadOnly Property Enabled As Boolean
    Get
ReadOnly Property Enabled As Boolean
    Get
property bool Enabled {
    bool get ();
}
property bool Enabled {
    bool get ();
}
abstract Enabled : bool with get
abstract Enabled : bool with get

Property Value

Type: Online Boolean
See Also
INetGate Interface
INetGate Members
NFX.IO.Net.Gate Namespace


INetGateImplementation Interface

INetGateImplementation Interface NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface INetGateImplementation : INetGate,
    IApplicationComponent, IDisposable, IConfigurable
public interface INetGateImplementation : INetGate,
    IApplicationComponent, IDisposable, IConfigurable
Public Interface INetGateImplementation
    Inherits INetGate, IApplicationComponent, IDisposable, IConfigurable
Public Interface INetGateImplementation
    Inherits INetGate, IApplicationComponent, IDisposable, IConfigurable
public interface class INetGateImplementation : INetGate,
    IApplicationComponent, IDisposable, IConfigurable
public interface class INetGateImplementation : INetGate,
    IApplicationComponent, IDisposable, IConfigurable
type INetGateImplementation =
    interface
        interface INetGate
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
    end
type INetGateImplementation =
    interface
        interface INetGate
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
    end
See Also
INetGateImplementation Members
NFX.IO.Net.Gate Namespace


INetGateImplementation Members

INetGateImplementation Members NFX Class Library

The INetGateImplementation type exposes the following members.
Methods
 | Name | Description
Public method | CheckTraffic(ITraffic) | Checks whether the specified traffic is allowed or denied (Inherited from INetGate.)
Public method | CheckTraffic(ITraffic, Rule ) | Checks whether the specified traffic is allowed or denied. Returns the rule that determined the allow/deny outcome or null when no rule matched (Inherited from INetGate.)
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | IncreaseVariable | Increases the named variable in the network scope which this specified traffic falls under (Inherited from INetGate.)
Public method | SetVariable | Sets the named variable in the network scope which this specified traffic falls under (Inherited from INetGate.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | Enabled | When gate is not enabled it allows all traffic bypassing any rules (Inherited from INetGate.)
Back to Top
See Also
INetGateImplementation Interface
NFX.IO.Net.Gate Namespace


INetGateImplementation Methods

INetGateImplementation Methods NFX Class Library

The INetGateImplementation type exposes the following members.
Methods
 | Name | Description
Public method | CheckTraffic(ITraffic) | Checks whether the specified traffic is allowed or denied (Inherited from INetGate.)
Public method | CheckTraffic(ITraffic, Rule ) | Checks whether the specified traffic is allowed or denied. Returns the rule that determined the allow/deny outcome or null when no rule matched (Inherited from INetGate.)
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | IncreaseVariable | Increases the named variable in the network scope which this specified traffic falls under (Inherited from INetGate.)
Public method | SetVariable | Sets the named variable in the network scope which this specified traffic falls under (Inherited from INetGate.)
Back to Top
See Also
INetGateImplementation Interface
NFX.IO.Net.Gate Namespace


INetGateImplementation Properties

INetGateImplementation Properties NFX Class Library

The INetGateImplementation type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | Enabled | When gate is not enabled it allows all traffic bypassing any rules (Inherited from INetGate.)
Back to Top
See Also
INetGateImplementation Interface
NFX.IO.Net.Gate Namespace


ITraffic Interface

ITraffic Interface NFX Class Library

Represents a traffic that passes through network gate

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ITraffic
public interface ITraffic
Public Interface ITraffic
Public Interface ITraffic
public interface class ITraffic
public interface class ITraffic
type ITraffic =  interface end
type ITraffic =  interface end
See Also
ITraffic Members
NFX.IO.Net.Gate Namespace


ITraffic Members

ITraffic Members NFX Class Library

The ITraffic type exposes the following members.
Properties
 | Name | Description
Public property | Direction |
Public property | FromAddress |
Public property | Items |
Public property | Method |
Public property | RequestURL |
Public property | Service |
Public property | ToAddress |
Back to Top
See Also
ITraffic Interface
NFX.IO.Net.Gate Namespace


ITraffic Properties

ITraffic Properties NFX Class Library

The ITraffic type exposes the following members.
Properties
 | Name | Description
Public property | Direction |
Public property | FromAddress |
Public property | Items |
Public property | Method |
Public property | RequestURL |
Public property | Service |
Public property | ToAddress |
Back to Top
See Also
ITraffic Interface
NFX.IO.Net.Gate Namespace


ITraffic.Direction Property

ITraffic Direction Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
TrafficDirection Direction { get; }
TrafficDirection Direction { get; }
ReadOnly Property Direction As TrafficDirection
    Get
ReadOnly Property Direction As TrafficDirection
    Get
property TrafficDirection Direction {
    TrafficDirection get ();
}
property TrafficDirection Direction {
    TrafficDirection get ();
}
abstract Direction : TrafficDirection with get
abstract Direction : TrafficDirection with get

Property Value

Type: TrafficDirection
See Also
ITraffic Interface
ITraffic Members
NFX.IO.Net.Gate Namespace


ITraffic.FromAddress Property

ITraffic FromAddress Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string FromAddress { get; }
string FromAddress { get; }
ReadOnly Property FromAddress As String
    Get
ReadOnly Property FromAddress As String
    Get
property String^ FromAddress {
    String^ get ();
}
property String^ FromAddress {
    String^ get ();
}
abstract FromAddress : string with get
abstract FromAddress : string with get

Property Value

Type: Online String
See Also
ITraffic Interface
ITraffic Members
NFX.IO.Net.Gate Namespace


ITraffic.Items Property

ITraffic Items Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IDictionary<string, Object> Items { get; }
IDictionary<string, Object> Items { get; }
ReadOnly Property Items As IDictionary(Of String, Object)
    Get
ReadOnly Property Items As IDictionary(Of String, Object)
    Get
property IDictionary<String^, Object^>^ Items {
    IDictionary<String^, Object^>^ get ();
}
property IDictionary<String^, Object^>^ Items {
    IDictionary<String^, Object^>^ get ();
}
abstract Items : IDictionary<string, Object> with get
abstract Items : IDictionary<string, Object> with get

Property Value

Type: Online IDictionary Online String, Online Object
See Also
ITraffic Interface
ITraffic Members
NFX.IO.Net.Gate Namespace


ITraffic.Method Property

ITraffic Method Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Method { get; }
string Method { get; }
ReadOnly Property Method As String
    Get
ReadOnly Property Method As String
    Get
property String^ Method {
    String^ get ();
}
property String^ Method {
    String^ get ();
}
abstract Method : string with get
abstract Method : string with get

Property Value

Type: Online String
See Also
ITraffic Interface
ITraffic Members
NFX.IO.Net.Gate Namespace


ITraffic.RequestURL Property

ITraffic RequestURL Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string RequestURL { get; }
string RequestURL { get; }
ReadOnly Property RequestURL As String
    Get
ReadOnly Property RequestURL As String
    Get
property String^ RequestURL {
    String^ get ();
}
property String^ RequestURL {
    String^ get ();
}
abstract RequestURL : string with get
abstract RequestURL : string with get

Property Value

Type: Online String
See Also
ITraffic Interface
ITraffic Members
NFX.IO.Net.Gate Namespace


ITraffic.Service Property

ITraffic Service Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string Service { get; }
string Service { get; }
ReadOnly Property Service As String
    Get
ReadOnly Property Service As String
    Get
property String^ Service {
    String^ get ();
}
property String^ Service {
    String^ get ();
}
abstract Service : string with get
abstract Service : string with get

Property Value

Type: Online String
See Also
ITraffic Interface
ITraffic Members
NFX.IO.Net.Gate Namespace


ITraffic.ToAddress Property

ITraffic ToAddress Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string ToAddress { get; }
string ToAddress { get; }
ReadOnly Property ToAddress As String
    Get
ReadOnly Property ToAddress As String
    Get
property String^ ToAddress {
    String^ get ();
}
property String^ ToAddress {
    String^ get ();
}
abstract ToAddress : string with get
abstract ToAddress : string with get

Property Value

Type: Online String
See Also
ITraffic Interface
ITraffic Members
NFX.IO.Net.Gate Namespace


NetGate Class

NetGate Class NFX Class Library

Represents a network gate - a logical filter of incoming network traffic. Network gate is somewhat similar to a firewall - it allows/denies the int/out traffic based on the set of rules
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.IO.Net.Gate NetGate

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NetGate : Service, INetGateImplementation,
    INetGate, IApplicationComponent, IDisposable, IConfigurable
public class NetGate : Service, INetGateImplementation,
    INetGate, IApplicationComponent, IDisposable, IConfigurable
Public Class NetGate
    Inherits Service
    Implements INetGateImplementation, INetGate, IApplicationComponent, IDisposable,
    IConfigurable
Public Class NetGate
    Inherits Service
    Implements INetGateImplementation, INetGate, IApplicationComponent, IDisposable,
    IConfigurable
public ref class NetGate : public Service,
    INetGateImplementation, INetGate, IApplicationComponent, IDisposable, IConfigurable
public ref class NetGate : public Service,
    INetGateImplementation, INetGate, IApplicationComponent, IDisposable, IConfigurable
type NetGate =
    class
        inherit Service
        interface INetGateImplementation
        interface INetGate
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
    end
type NetGate =
    class
        inherit Service
        interface INetGateImplementation
        interface INetGate
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
    end
See Also
NetGate Members
NFX.IO.Net.Gate Namespace


NetGate Members

NetGate Members NFX Class Library

The NetGate type exposes the following members.
Constructors
 | Name | Description
Public method | NetGate | Initializes a new instance of the NetGate class
Public method | NetGate(Object) | Initializes a new instance of the NetGate class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | CheckTraffic(ITraffic) | Checks whether the specified traffic is allowed or denied
Public method | CheckTraffic(ITraffic, Rule ) | Checks whether the specified traffic is allowed or denied. Returns the rule that determined the allow/deny outcome or null when no rule matched
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IncreaseVariable | Increases the named variable in the network scope which this specified traffic falls under
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Log | Facilitates net gate logging
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetVariable | Sets the named variable in the network scope which this specified traffic falls under
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_ADDRESS_SECTION |
CONFIG_DEFAULT_ACTION_ATTR |
CONFIG_GROUP_SECTION |
CONFIG_INCOMING_SECTION |
CONFIG_OUTGOING_SECTION |
CONFIG_RULE_SECTION |
CONFIG_VARDEF_SECTION |
PATTERN_CAPTURE_WC |
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | (Overrides ApplicationComponent ComponentCommonName.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Enabled | Enables/diables the protection. When protection is disabled then all traffic is allowed
Public property | Item | Returns gate state
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
NetGate Class
NFX.IO.Net.Gate Namespace


NetGate Constructor

NetGate Constructor NFX Class Library

Overload List
 | Name | Description
Public method | NetGate | Initializes a new instance of the NetGate class
Public method | NetGate(Object) | Initializes a new instance of the NetGate class
Back to Top
See Also
NetGate Class
NetGate Members
NFX.IO.Net.Gate Namespace


NetGate Constructor

NetGate Constructor NFX Class Library

Initializes a new instance of the NetGate class

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NetGate()
public NetGate()
Public Sub New
Public Sub New
public:
NetGate()
public:
NetGate()
new : unit -> NetGate
new : unit -> NetGate
See Also
NetGate Class
NetGate Members
NetGate Overload
NFX.IO.Net.Gate Namespace


NetGate Constructor (Object)

NetGate Constructor (Object) NFX Class Library

Initializes a new instance of the NetGate class

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NetGate(
    Object director
)
public NetGate(
    Object director
)
Public Sub New (
    director As Object
)
Public Sub New (
    director As Object
)
public:
NetGate(
    Object^ director
)
public:
NetGate(
    Object^ director
)
new :
        director : Object -> NetGate
new :
        director : Object -> NetGate

Parameters

director
Type: Online System Object
See Also
NetGate Class
NetGate Members
NetGate Overload
NFX.IO.Net.Gate Namespace


NetGate Fields

NetGate Fields NFX Class Library

The NetGate type exposes the following members.
Fields
Name | Description
CONFIG_ADDRESS_SECTION |
CONFIG_DEFAULT_ACTION_ATTR |
CONFIG_GROUP_SECTION |
CONFIG_INCOMING_SECTION |
CONFIG_OUTGOING_SECTION |
CONFIG_RULE_SECTION |
CONFIG_VARDEF_SECTION |
PATTERN_CAPTURE_WC |
Back to Top
See Also
NetGate Class
NFX.IO.Net.Gate Namespace


NetGate.CONFIG_ADDRESS_SECTION Field

NetGate CONFIG_ADDRESS_SECTION Field NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_ADDRESS_SECTION
public const string CONFIG_ADDRESS_SECTION
Public Const CONFIG_ADDRESS_SECTION As String
Public Const CONFIG_ADDRESS_SECTION As String
public:
literal String^ CONFIG_ADDRESS_SECTION
public:
literal String^ CONFIG_ADDRESS_SECTION
static val mutable CONFIG_ADDRESS_SECTION: string
static val mutable CONFIG_ADDRESS_SECTION: string

Field Value

Type: Online String
See Also
NetGate Class
NetGate Members
NFX.IO.Net.Gate Namespace


NetGate.CONFIG_DEFAULT_ACTION_ATTR Field

NetGate CONFIG_DEFAULT_ACTION_ATTR Field NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_DEFAULT_ACTION_ATTR
public const string CONFIG_DEFAULT_ACTION_ATTR
Public Const CONFIG_DEFAULT_ACTION_ATTR As String
Public Const CONFIG_DEFAULT_ACTION_ATTR As String
public:
literal String^ CONFIG_DEFAULT_ACTION_ATTR
public:
literal String^ CONFIG_DEFAULT_ACTION_ATTR
static val mutable CONFIG_DEFAULT_ACTION_ATTR: string
static val mutable CONFIG_DEFAULT_ACTION_ATTR: string

Field Value

Type: Online String
See Also
NetGate Class
NetGate Members
NFX.IO.Net.Gate Namespace


NetGate.CONFIG_GROUP_SECTION Field

NetGate CONFIG_GROUP_SECTION Field NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_GROUP_SECTION
public const string CONFIG_GROUP_SECTION
Public Const CONFIG_GROUP_SECTION As String
Public Const CONFIG_GROUP_SECTION As String
public:
literal String^ CONFIG_GROUP_SECTION
public:
literal String^ CONFIG_GROUP_SECTION
static val mutable CONFIG_GROUP_SECTION: string
static val mutable CONFIG_GROUP_SECTION: string

Field Value

Type: Online String
See Also
NetGate Class
NetGate Members
NFX.IO.Net.Gate Namespace


NetGate.CONFIG_INCOMING_SECTION Field

NetGate CONFIG_INCOMING_SECTION Field NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_INCOMING_SECTION
public const string CONFIG_INCOMING_SECTION
Public Const CONFIG_INCOMING_SECTION As String
Public Const CONFIG_INCOMING_SECTION As String
public:
literal String^ CONFIG_INCOMING_SECTION
public:
literal String^ CONFIG_INCOMING_SECTION
static val mutable CONFIG_INCOMING_SECTION: string
static val mutable CONFIG_INCOMING_SECTION: string

Field Value

Type: Online String
See Also
NetGate Class
NetGate Members
NFX.IO.Net.Gate Namespace


NetGate.CONFIG_OUTGOING_SECTION Field

NetGate CONFIG_OUTGOING_SECTION Field NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_OUTGOING_SECTION
public const string CONFIG_OUTGOING_SECTION
Public Const CONFIG_OUTGOING_SECTION As String
Public Const CONFIG_OUTGOING_SECTION As String
public:
literal String^ CONFIG_OUTGOING_SECTION
public:
literal String^ CONFIG_OUTGOING_SECTION
static val mutable CONFIG_OUTGOING_SECTION: string
static val mutable CONFIG_OUTGOING_SECTION: string

Field Value

Type: Online String
See Also
NetGate Class
NetGate Members
NFX.IO.Net.Gate Namespace


NetGate.CONFIG_RULE_SECTION Field

NetGate CONFIG_RULE_SECTION Field NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_RULE_SECTION
public const string CONFIG_RULE_SECTION
Public Const CONFIG_RULE_SECTION As String
Public Const CONFIG_RULE_SECTION As String
public:
literal String^ CONFIG_RULE_SECTION
public:
literal String^ CONFIG_RULE_SECTION
static val mutable CONFIG_RULE_SECTION: string
static val mutable CONFIG_RULE_SECTION: string

Field Value

Type: Online String
See Also
NetGate Class
NetGate Members
NFX.IO.Net.Gate Namespace


NetGate.CONFIG_VARDEF_SECTION Field

NetGate CONFIG_VARDEF_SECTION Field NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_VARDEF_SECTION
public const string CONFIG_VARDEF_SECTION
Public Const CONFIG_VARDEF_SECTION As String
Public Const CONFIG_VARDEF_SECTION As String
public:
literal String^ CONFIG_VARDEF_SECTION
public:
literal String^ CONFIG_VARDEF_SECTION
static val mutable CONFIG_VARDEF_SECTION: string
static val mutable CONFIG_VARDEF_SECTION: string

Field Value

Type: Online String
See Also
NetGate Class
NetGate Members
NFX.IO.Net.Gate Namespace


NetGate.PATTERN_CAPTURE_WC Field

NetGate PATTERN_CAPTURE_WC Field NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PATTERN_CAPTURE_WC
public const string PATTERN_CAPTURE_WC
Public Const PATTERN_CAPTURE_WC As String
Public Const PATTERN_CAPTURE_WC As String
public:
literal String^ PATTERN_CAPTURE_WC
public:
literal String^ PATTERN_CAPTURE_WC
static val mutable PATTERN_CAPTURE_WC: string
static val mutable PATTERN_CAPTURE_WC: string

Field Value

Type: Online String
See Also
NetGate Class
NetGate Members
NFX.IO.Net.Gate Namespace


NetGate Methods

NetGate Methods NFX Class Library

The NetGate type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | CheckTraffic(ITraffic) | Checks whether the specified traffic is allowed or denied
Public method | CheckTraffic(ITraffic, Rule ) | Checks whether the specified traffic is allowed or denied. Returns the rule that determined the allow/deny outcome or null when no rule matched
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IncreaseVariable | Increases the named variable in the network scope which this specified traffic falls under
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Log | Facilitates net gate logging
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetVariable | Sets the named variable in the network scope which this specified traffic falls under
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NetGate Class
NFX.IO.Net.Gate Namespace


NetGate.CheckTraffic Method

NetGate CheckTraffic Method NFX Class Library

Overload List
 | Name | Description
Public method | CheckTraffic(ITraffic) | Checks whether the specified traffic is allowed or denied
Public method | CheckTraffic(ITraffic, Rule ) | Checks whether the specified traffic is allowed or denied. Returns the rule that determined the allow/deny outcome or null when no rule matched
Back to Top
See Also
NetGate Class
NetGate Members
NFX.IO.Net.Gate Namespace


NetGate.CheckTraffic Method (ITraffic)

NetGate CheckTraffic Method (ITraffic) NFX Class Library

Checks whether the specified traffic is allowed or denied

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GateAction CheckTraffic(
    ITraffic traffic
)
public GateAction CheckTraffic(
    ITraffic traffic
)
Public Function CheckTraffic (
    traffic As ITraffic
) As GateAction
Public Function CheckTraffic (
    traffic As ITraffic
) As GateAction
public:
virtual GateAction CheckTraffic(
    ITraffic^ traffic
) sealed
public:
virtual GateAction CheckTraffic(
    ITraffic^ traffic
) sealed
abstract CheckTraffic :
        traffic : ITraffic -> GateAction
override CheckTraffic :
        traffic : ITraffic -> GateAction
abstract CheckTraffic :
        traffic : ITraffic -> GateAction
override CheckTraffic :
        traffic : ITraffic -> GateAction

Parameters

traffic
Type: NFX.IO.Net.Gate ITraffic

Return Value

Type: GateAction

Implements

INetGate CheckTraffic(ITraffic)
See Also
NetGate Class
NetGate Members
CheckTraffic Overload
NFX.IO.Net.Gate Namespace


NetGate.CheckTraffic Method (ITraffic, Rule)

NetGate CheckTraffic Method (ITraffic, Rule ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Checks whether the specified traffic is allowed or denied. Returns the rule that determined the allow/deny outcome or null when no rule matched

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GateAction CheckTraffic(
    ITraffic traffic,
    out Rule rule
)
public GateAction CheckTraffic(
    ITraffic traffic,
    out Rule rule
)
Public Function CheckTraffic (
    traffic As ITraffic,
    <OutAttribute> ByRef rule As Rule
) As GateAction
Public Function CheckTraffic (
    traffic As ITraffic,
    <OutAttribute> ByRef rule As Rule
) As GateAction
public:
virtual GateAction CheckTraffic(
    ITraffic^ traffic,
    [OutAttribute] Rule^% rule
) sealed
public:
virtual GateAction CheckTraffic(
    ITraffic^ traffic,
    [OutAttribute] Rule^% rule
) sealed
abstract CheckTraffic :
        traffic : ITraffic *
        rule : Rule byref -> GateAction
override CheckTraffic :
        traffic : ITraffic *
        rule : Rule byref -> GateAction
abstract CheckTraffic :
        traffic : ITraffic *
        rule : Rule byref -> GateAction
override CheckTraffic :
        traffic : ITraffic *
        rule : Rule byref -> GateAction

Parameters

traffic
Type: NFX.IO.Net.Gate ITraffic
rule
Type: NFX.IO.Net.Gate Rule

Return Value

Type: GateAction

Implements

INetGate CheckTraffic(ITraffic, Rule )
See Also
NetGate Class
NetGate Members
CheckTraffic Overload
NFX.IO.Net.Gate Namespace


NetGate.DoConfigure Method

NetGate DoConfigure Method NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
NetGate Class
NetGate Members
NFX.IO.Net.Gate Namespace


NetGate.DoStart Method

NetGate DoStart Method NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
NetGate Class
NetGate Members
NFX.IO.Net.Gate Namespace


NetGate.DoWaitForCompleteStop Method

NetGate DoWaitForCompleteStop Method NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
NetGate Class
NetGate Members
NFX.IO.Net.Gate Namespace


NetGate.IncreaseVariable Method

NetGate IncreaseVariable Method NFX Class Library

Increases the named variable in the network scope which this specified traffic falls under

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void IncreaseVariable(
    TrafficDirection direction,
    string address,
    string varName,
    int value
)
public virtual void IncreaseVariable(
    TrafficDirection direction,
    string address,
    string varName,
    int value
)
Public Overridable Sub IncreaseVariable (
    direction As TrafficDirection,
    address As String,
    varName As String,
    value As Integer
)
Public Overridable Sub IncreaseVariable (
    direction As TrafficDirection,
    address As String,
    varName As String,
    value As Integer
)
public:
virtual void IncreaseVariable(
    TrafficDirection direction,
    String^ address,
    String^ varName,
    int value
)
public:
virtual void IncreaseVariable(
    TrafficDirection direction,
    String^ address,
    String^ varName,
    int value
)
abstract IncreaseVariable :
        direction : TrafficDirection *
        address : string *
        varName : string *
        value : int -> unit
override IncreaseVariable :
        direction : TrafficDirection *
        address : string *
        varName : string *
        value : int -> unit
abstract IncreaseVariable :
        direction : TrafficDirection *
        address : string *
        varName : string *
        value : int -> unit
override IncreaseVariable :
        direction : TrafficDirection *
        address : string *
        varName : string *
        value : int -> unit

Parameters

direction
Type: NFX.IO.Net.Gate TrafficDirection
address
Type: Online System String
varName
Type: Online System String
value
Type: Online System Int32

Implements

INetGate IncreaseVariable(TrafficDirection, String, String, Int32)
See Also
NetGate Class
NetGate Members
NFX.IO.Net.Gate Namespace


NetGate.Log Method

NetGate Log Method NFX Class Library

Facilitates net gate logging

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void Log(
    MessageType type,
    string text,
    string from = null,
    Exception error = null,
    string pars = null,
    Nullable<Guid> related = null
)
protected void Log(
    MessageType type,
    string text,
    string from = null,
    Exception error = null,
    string pars = null,
    Nullable<Guid> related = null
)
Protected Sub Log (
    type As MessageType,
    text As String,
    Optional from As String = Nothing,
    Optional error As Exception = Nothing,
    Optional pars As String = Nothing,
    Optional related As Nullable(Of Guid) = Nothing
)
Protected Sub Log (
    type As MessageType,
    text As String,
    Optional from As String = Nothing,
    Optional error As Exception = Nothing,
    Optional pars As String = Nothing,
    Optional related As Nullable(Of Guid) = Nothing
)
protected:
void Log(
    MessageType type,
    String^ text,
    String^ from = nullptr,
    Exception^ error = nullptr,
    String^ pars = nullptr,
    Nullable<Guid> related = nullptr
)
protected:
void Log(
    MessageType type,
    String^ text,
    String^ from = nullptr,
    Exception^ error = nullptr,
    String^ pars = nullptr,
    Nullable<Guid> related = nullptr
)
member Log :
        type : MessageType *
        text : string *
        ?from : string *
        ?error : Exception *
        ?pars : string *
        ?related : Nullable<Guid>
(* Defaults:
        let _from = defaultArg from null
        let _error = defaultArg error null
        let _pars = defaultArg pars null
        let _related = defaultArg related null
*)
-> unit
member Log :
        type : MessageType *
        text : string *
        ?from : string *
        ?error : Exception *
        ?pars : string *
        ?related : Nullable<Guid>
(* Defaults:
        let _from = defaultArg from null
        let _error = defaultArg error null
        let _pars = defaultArg pars null
        let _related = defaultArg related null
*)
-> unit

Parameters

type
Type: NFX.Log MessageType
text
Type: Online System String
from (Optional)
Type: Online System String
error (Optional)
Type: Online System Exception
pars (Optional)
Type: Online System String
related (Optional)
Type: Online System Nullable Online Guid
See Also
NetGate Class
NetGate Members
NFX.IO.Net.Gate Namespace


NetGate.SetVariable Method

NetGate SetVariable Method NFX Class Library

Sets the named variable in the network scope which this specified traffic falls under

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetVariable(
    TrafficDirection direction,
    string address,
    string varName,
    int value
)
public virtual void SetVariable(
    TrafficDirection direction,
    string address,
    string varName,
    int value
)
Public Overridable Sub SetVariable (
    direction As TrafficDirection,
    address As String,
    varName As String,
    value As Integer
)
Public Overridable Sub SetVariable (
    direction As TrafficDirection,
    address As String,
    varName As String,
    value As Integer
)
public:
virtual void SetVariable(
    TrafficDirection direction,
    String^ address,
    String^ varName,
    int value
)
public:
virtual void SetVariable(
    TrafficDirection direction,
    String^ address,
    String^ varName,
    int value
)
abstract SetVariable :
        direction : TrafficDirection *
        address : string *
        varName : string *
        value : int -> unit
override SetVariable :
        direction : TrafficDirection *
        address : string *
        varName : string *
        value : int -> unit
abstract SetVariable :
        direction : TrafficDirection *
        address : string *
        varName : string *
        value : int -> unit
override SetVariable :
        direction : TrafficDirection *
        address : string *
        varName : string *
        value : int -> unit

Parameters

direction
Type: NFX.IO.Net.Gate TrafficDirection
address
Type: Online System String
varName
Type: Online System String
value
Type: Online System Int32

Implements

INetGate SetVariable(TrafficDirection, String, String, Int32)
See Also
NetGate Class
NetGate Members
NFX.IO.Net.Gate Namespace


NetGate Properties

NetGate Properties NFX Class Library

The NetGate type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | (Overrides ApplicationComponent ComponentCommonName.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Enabled | Enables/diables the protection. When protection is disabled then all traffic is allowed
Public property | Item | Returns gate state
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
NetGate Class
NFX.IO.Net.Gate Namespace


NetGate.ComponentCommonName Property

NetGate ComponentCommonName Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ComponentCommonName { get; }
public override string ComponentCommonName { get; }
Public Overrides ReadOnly Property ComponentCommonName As String
    Get
Public Overrides ReadOnly Property ComponentCommonName As String
    Get
public:
virtual property String^ ComponentCommonName {
    String^ get () override;
}
public:
virtual property String^ ComponentCommonName {
    String^ get () override;
}
abstract ComponentCommonName : string with get
override ComponentCommonName : string with get
abstract ComponentCommonName : string with get
override ComponentCommonName : string with get

Property Value

Type: Online String

Implements

IApplicationComponent ComponentCommonName
IApplicationComponent ComponentCommonName
See Also
NetGate Class
NetGate Members
NFX.IO.Net.Gate Namespace


NetGate.Enabled Property

NetGate Enabled Property NFX Class Library

Enables/diables the protection. When protection is disabled then all traffic is allowed

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool Enabled { get; set; }
[ConfigAttribute]
public bool Enabled { get; set; }
<ConfigAttribute>
Public Property Enabled As Boolean
    Get
    Set
<ConfigAttribute>
Public Property Enabled As Boolean
    Get
    Set
public:
[ConfigAttribute]
virtual property bool Enabled {
    bool get () sealed;
    void set (bool value) sealed;
}
public:
[ConfigAttribute]
virtual property bool Enabled {
    bool get () sealed;
    void set (bool value) sealed;
}
[<ConfigAttribute>]
abstract Enabled : bool with get, set
[<ConfigAttribute>]
override Enabled : bool with get, set
[<ConfigAttribute>]
abstract Enabled : bool with get, set
[<ConfigAttribute>]
override Enabled : bool with get, set

Property Value

Type: Online Boolean

Implements

INetGate Enabled
See Also
NetGate Class
NetGate Members
NFX.IO.Net.Gate Namespace


NetGate.Item Property

NetGate Item Property NFX Class Library

Returns gate state

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NetGate..::..State this[
    TrafficDirection direction
] { get; }
public NetGate..::..State this[
    TrafficDirection direction
] { get; }
Public ReadOnly Default Property Item (
    direction As TrafficDirection
) As NetGate..::..State
    Get
Public ReadOnly Default Property Item (
    direction As TrafficDirection
) As NetGate..::..State
    Get
public:
property NetGate..::..State^ default[TrafficDirection direction] {
    NetGate..::..State^ get (TrafficDirection direction);
}
public:
property NetGate..::..State^ default[TrafficDirection direction] {
    NetGate..::..State^ get (TrafficDirection direction);
}
member Item : NetGate..::..State with get
member Item : NetGate..::..State with get

Parameters

direction
Type: NFX.IO.Net.Gate TrafficDirection

Property Value

Type: NetGate State
See Also
NetGate Class
NetGate Members
NFX.IO.Net.Gate Namespace


NetGate.State Class

NetGate State Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.IO.Net.Gate NetGate State

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class State
public class State
Public Class State
Public Class State
public ref class State
public ref class State
type State =  class end
type State =  class end
See Also
NetGate State Members
NFX.IO.Net.Gate Namespace


NetGate.State Members

NetGate State Members NFX Class Library

The NetGate State type exposes the following members.
Constructors
 | Name | Description
Protected method | NetGate State | Initializes a new instance of the NetGate State class
Back to Top
Methods
 | Name | Description
Protected method | configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FindGroupForAddress | Returns the first matching group for address, or null
Public method | FindNetSiteStateForAddress | Returns existing NetSiteState object for specified address, first checking group membership or null
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | DefaultAction |
Public field | Gate |
Public field | Groups |
Protected field | NetState |
Public field | Rules |
Public field | VarDefs |
Back to Top
See Also
NetGate State Class
NFX.IO.Net.Gate Namespace


NetGate.State Constructor

NetGate State Constructor NFX Class Library

Initializes a new instance of the NetGate State class

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal State(
    NetGate gate
)
internal State(
    NetGate gate
)
Friend Sub New (
    gate As NetGate
)
Friend Sub New (
    gate As NetGate
)
internal:
State(
    NetGate^ gate
)
internal:
State(
    NetGate^ gate
)
new :
        gate : NetGate -> State
new :
        gate : NetGate -> State

Parameters

gate
Type: NFX.IO.Net.Gate NetGate
See Also
NetGate State Class
NetGate State Members
NFX.IO.Net.Gate Namespace


NetGate.State Fields

NetGate State Fields NFX Class Library

The NetGate State type exposes the following members.
Fields
 | Name | Description
Public field | DefaultAction |
Public field | Gate |
Public field | Groups |
Protected field | NetState |
Public field | Rules |
Public field | VarDefs |
Back to Top
See Also
NetGate State Class
NFX.IO.Net.Gate Namespace


NetGate.State.DefaultAction Field

NetGate State DefaultAction Field NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public GateAction DefaultAction
[ConfigAttribute]
public GateAction DefaultAction
<ConfigAttribute>
Public DefaultAction As GateAction
<ConfigAttribute>
Public DefaultAction As GateAction
public:
[ConfigAttribute]
GateAction DefaultAction
public:
[ConfigAttribute]
GateAction DefaultAction
[<ConfigAttribute>]
val mutable DefaultAction: GateAction
[<ConfigAttribute>]
val mutable DefaultAction: GateAction

Field Value

Type: GateAction
See Also
NetGate State Class
NetGate State Members
NFX.IO.Net.Gate Namespace


NetGate.State.Gate Field

NetGate State Gate Field NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly NetGate Gate
public readonly NetGate Gate
Public ReadOnly Gate As NetGate
Public ReadOnly Gate As NetGate
public:
initonly NetGate^ Gate
public:
initonly NetGate^ Gate
val Gate: NetGate
val Gate: NetGate

Field Value

Type: NetGate
See Also
NetGate State Class
NetGate State Members
NFX.IO.Net.Gate Namespace


NetGate.State.Groups Field

NetGate State Groups Field NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly OrderedRegistry<Group> Groups
public readonly OrderedRegistry<Group> Groups
Public ReadOnly Groups As OrderedRegistry(Of Group)
Public ReadOnly Groups As OrderedRegistry(Of Group)
public:
initonly OrderedRegistry<Group^>^ Groups
public:
initonly OrderedRegistry<Group^>^ Groups
val Groups: OrderedRegistry<Group>
val Groups: OrderedRegistry<Group>

Field Value

Type: OrderedRegistry Group
See Also
NetGate State Class
NetGate State Members
NFX.IO.Net.Gate Namespace


NetGate.State.NetState Field

NetGate State NetState Field NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal readonly ConcurrentDictionary<string, NetSiteState> NetState
internal readonly ConcurrentDictionary<string, NetSiteState> NetState
Friend ReadOnly NetState As ConcurrentDictionary(Of String, NetSiteState)
Friend ReadOnly NetState As ConcurrentDictionary(Of String, NetSiteState)
internal:
initonly ConcurrentDictionary<String^, NetSiteState^>^ NetState
internal:
initonly ConcurrentDictionary<String^, NetSiteState^>^ NetState
val internal NetState: ConcurrentDictionary<string, NetSiteState>
val internal NetState: ConcurrentDictionary<string, NetSiteState>

Field Value

Type: Online ConcurrentDictionary Online String, NetSiteState
See Also
NetGate State Class
NetGate State Members
NFX.IO.Net.Gate Namespace


NetGate.State.Rules Field

NetGate State Rules Field NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly OrderedRegistry<Rule> Rules
public readonly OrderedRegistry<Rule> Rules
Public ReadOnly Rules As OrderedRegistry(Of Rule)
Public ReadOnly Rules As OrderedRegistry(Of Rule)
public:
initonly OrderedRegistry<Rule^>^ Rules
public:
initonly OrderedRegistry<Rule^>^ Rules
val Rules: OrderedRegistry<Rule>
val Rules: OrderedRegistry<Rule>

Field Value

Type: OrderedRegistry Rule
See Also
NetGate State Class
NetGate State Members
NFX.IO.Net.Gate Namespace


NetGate.State.VarDefs Field

NetGate State VarDefs Field NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Registry<VarDef> VarDefs
public readonly Registry<VarDef> VarDefs
Public ReadOnly VarDefs As Registry(Of VarDef)
Public ReadOnly VarDefs As Registry(Of VarDef)
public:
initonly Registry<VarDef^>^ VarDefs
public:
initonly Registry<VarDef^>^ VarDefs
val VarDefs: Registry<VarDef>
val VarDefs: Registry<VarDef>

Field Value

Type: Registry VarDef
See Also
NetGate State Class
NetGate State Members
NFX.IO.Net.Gate Namespace


NetGate.State Methods

NetGate State Methods NFX Class Library

The NetGate State type exposes the following members.
Methods
 | Name | Description
Protected method | configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FindGroupForAddress | Returns the first matching group for address, or null
Public method | FindNetSiteStateForAddress | Returns existing NetSiteState object for specified address, first checking group membership or null
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NetGate State Class
NFX.IO.Net.Gate Namespace


NetGate.State.configure Method

NetGate State configure Method NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void configure(
    IConfigSectionNode node
)
internal void configure(
    IConfigSectionNode node
)
Friend Sub configure (
    node As IConfigSectionNode
)
Friend Sub configure (
    node As IConfigSectionNode
)
internal:
void configure(
    IConfigSectionNode^ node
)
internal:
void configure(
    IConfigSectionNode^ node
)
internal member configure :
        node : IConfigSectionNode -> unit
internal member configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
NetGate State Class
NetGate State Members
NFX.IO.Net.Gate Namespace


NetGate.State.FindGroupForAddress Method

NetGate State FindGroupForAddress Method NFX Class Library

Returns the first matching group for address, or null

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Group FindGroupForAddress(
    string address
)
public Group FindGroupForAddress(
    string address
)
Public Function FindGroupForAddress (
    address As String
) As Group
Public Function FindGroupForAddress (
    address As String
) As Group
public:
Group^ FindGroupForAddress(
    String^ address
)
public:
Group^ FindGroupForAddress(
    String^ address
)
member FindGroupForAddress :
        address : string -> Group
member FindGroupForAddress :
        address : string -> Group

Parameters

address
Type: Online System String

Return Value

Type: Group
See Also
NetGate State Class
NetGate State Members
NFX.IO.Net.Gate Namespace


NetGate.State.FindNetSiteStateForAddress Method

NetGate State FindNetSiteStateForAddress Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns existing NetSiteState object for specified address, first checking group membership or null

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NetSiteState FindNetSiteStateForAddress(
    string address,
    ref Group group
)
public NetSiteState FindNetSiteStateForAddress(
    string address,
    ref Group group
)
Public Function FindNetSiteStateForAddress (
    address As String,
    ByRef group As Group
) As NetSiteState
Public Function FindNetSiteStateForAddress (
    address As String,
    ByRef group As Group
) As NetSiteState
public:
NetSiteState^ FindNetSiteStateForAddress(
    String^ address,
    Group^% group
)
public:
NetSiteState^ FindNetSiteStateForAddress(
    String^ address,
    Group^% group
)
member FindNetSiteStateForAddress :
        address : string *
        group : Group byref -> NetSiteState
member FindNetSiteStateForAddress :
        address : string *
        group : Group byref -> NetSiteState

Parameters

address
Type: Online System String
group
Type: NFX.IO.Net.Gate Group

Return Value

Type: NetSiteState
See Also
NetGate State Class
NetGate State Members
NFX.IO.Net.Gate Namespace


NetGateException Class

NetGateException Class NFX Class Library

Throw by NetGate
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.IO.Net.Gate NetGateException

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class NetGateException : NFXException
[SerializableAttribute]
public class NetGateException : NFXException
<SerializableAttribute>
Public Class NetGateException
    Inherits NFXException
<SerializableAttribute>
Public Class NetGateException
    Inherits NFXException
[SerializableAttribute]
public ref class NetGateException : public NFXException
[SerializableAttribute]
public ref class NetGateException : public NFXException
[<SerializableAttribute>]
type NetGateException =
    class
        inherit NFXException
    end
[<SerializableAttribute>]
type NetGateException =
    class
        inherit NFXException
    end
See Also
NetGateException Members
NFX.IO.Net.Gate Namespace


NetGateException Members

NetGateException Members NFX Class Library

The NetGateException type exposes the following members.
Constructors
 | Name | Description
Public method | NetGateException | Initializes a new instance of the NetGateException class
Public method | NetGateException(String) | Initializes a new instance of the NetGateException class
Protected method | NetGateException(SerializationInfo, StreamingContext) | Initializes a new instance of the NetGateException class
Public method | NetGateException(String, Exception) | Initializes a new instance of the NetGateException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
NetGateException Class
NFX.IO.Net.Gate Namespace


NetGateException Constructor

NetGateException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | NetGateException | Initializes a new instance of the NetGateException class
Public method | NetGateException(String) | Initializes a new instance of the NetGateException class
Protected method | NetGateException(SerializationInfo, StreamingContext) | Initializes a new instance of the NetGateException class
Public method | NetGateException(String, Exception) | Initializes a new instance of the NetGateException class
Back to Top
See Also
NetGateException Class
NetGateException Members
NFX.IO.Net.Gate Namespace


NetGateException Constructor

NetGateException Constructor NFX Class Library

Initializes a new instance of the NetGateException class

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NetGateException()
public NetGateException()
Public Sub New
Public Sub New
public:
NetGateException()
public:
NetGateException()
new : unit -> NetGateException
new : unit -> NetGateException
See Also
NetGateException Class
NetGateException Members
NetGateException Overload
NFX.IO.Net.Gate Namespace


NetGateException Constructor (String)

NetGateException Constructor (String) NFX Class Library

Initializes a new instance of the NetGateException class

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NetGateException(
    string message
)
public NetGateException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
NetGateException(
    String^ message
)
public:
NetGateException(
    String^ message
)
new :
        message : string -> NetGateException
new :
        message : string -> NetGateException

Parameters

message
Type: Online System String
See Also
NetGateException Class
NetGateException Members
NetGateException Overload
NFX.IO.Net.Gate Namespace


NetGateException Constructor (SerializationInfo, StreamingContext)

NetGateException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NetGateException class

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected NetGateException(
    SerializationInfo info,
    StreamingContext context
)
protected NetGateException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
NetGateException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
NetGateException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> NetGateException
new :
        info : SerializationInfo *
        context : StreamingContext -> NetGateException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
NetGateException Class
NetGateException Members
NetGateException Overload
NFX.IO.Net.Gate Namespace


NetGateException Constructor (String, Exception)

NetGateException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NetGateException class

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NetGateException(
    string message,
    Exception inner
)
public NetGateException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
NetGateException(
    String^ message,
    Exception^ inner
)
public:
NetGateException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> NetGateException
new :
        message : string *
        inner : Exception -> NetGateException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
NetGateException Class
NetGateException Members
NetGateException Overload
NFX.IO.Net.Gate Namespace


NetGateException Methods

NetGateException Methods NFX Class Library

The NetGateException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
NetGateException Class
NFX.IO.Net.Gate Namespace


NetGateException Properties

NetGateException Properties NFX Class Library

The NetGateException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
NetGateException Class
NFX.IO.Net.Gate Namespace


NetGateException Events

NetGateException Events NFX Class Library

The NetGateException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
NetGateException Class
NFX.IO.Net.Gate Namespace


NetSiteState Class

NetSiteState Class NFX Class Library

Represents the state of the metwrk site - it can be a particular address or group
Inheritance Hierarchy
Online System Object
NFX.IO.Net.Gate NetSiteState

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class NetSiteState
public sealed class NetSiteState
Public NotInheritable Class NetSiteState
Public NotInheritable Class NetSiteState
public ref class NetSiteState sealed
public ref class NetSiteState sealed
[<SealedAttribute>]
type NetSiteState =  class end
[<SealedAttribute>]
type NetSiteState =  class end
See Also
NetSiteState Members
NFX.IO.Net.Gate Namespace


NetSiteState Members

NetSiteState Members NFX Class Library

The NetSiteState type exposes the following members.
Constructors
 | Name | Description
Protected method | NetSiteState(String) | Initializes a new instance of the NetSiteState class
Protected method | NetSiteState(Group) | Initializes a new instance of the NetSiteState class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Address |
Public field | Group |
Protected field | m_LastTouch |
Protected field | m_Variables |
Back to Top
Properties
 | Name | Description
Public property | Key |
Back to Top
See Also
NetSiteState Class
NFX.IO.Net.Gate Namespace


NetSiteState Constructor

NetSiteState Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | NetSiteState(String) | Initializes a new instance of the NetSiteState class
Protected method | NetSiteState(Group) | Initializes a new instance of the NetSiteState class
Back to Top
See Also
NetSiteState Class
NetSiteState Members
NFX.IO.Net.Gate Namespace


NetSiteState Constructor (String)

NetSiteState Constructor (String) NFX Class Library

Initializes a new instance of the NetSiteState class

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal NetSiteState(
    string addr
)
internal NetSiteState(
    string addr
)
Friend Sub New (
    addr As String
)
Friend Sub New (
    addr As String
)
internal:
NetSiteState(
    String^ addr
)
internal:
NetSiteState(
    String^ addr
)
new :
        addr : string -> NetSiteState
new :
        addr : string -> NetSiteState

Parameters

addr
Type: Online System String
See Also
NetSiteState Class
NetSiteState Members
NetSiteState Overload
NFX.IO.Net.Gate Namespace


NetSiteState Constructor (Group)

NetSiteState Constructor (Group) NFX Class Library

Initializes a new instance of the NetSiteState class

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal NetSiteState(
    Group group
)
internal NetSiteState(
    Group group
)
Friend Sub New (
    group As Group
)
Friend Sub New (
    group As Group
)
internal:
NetSiteState(
    Group^ group
)
internal:
NetSiteState(
    Group^ group
)
new :
        group : Group -> NetSiteState
new :
        group : Group -> NetSiteState

Parameters

group
Type: NFX.IO.Net.Gate Group
See Also
NetSiteState Class
NetSiteState Members
NetSiteState Overload
NFX.IO.Net.Gate Namespace


NetSiteState Fields

NetSiteState Fields NFX Class Library

The NetSiteState type exposes the following members.
Fields
 | Name | Description
Public field | Address |
Public field | Group |
Protected field | m_LastTouch |
Protected field | m_Variables |
Back to Top
See Also
NetSiteState Class
NFX.IO.Net.Gate Namespace


NetSiteState.Address Field

NetSiteState Address Field NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Address
public readonly string Address
Public ReadOnly Address As String
Public ReadOnly Address As String
public:
initonly String^ Address
public:
initonly String^ Address
val Address: string
val Address: string

Field Value

Type: Online String
See Also
NetSiteState Class
NetSiteState Members
NFX.IO.Net.Gate Namespace


NetSiteState.Group Field

NetSiteState Group Field NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Group Group
public readonly Group Group
Public ReadOnly Group As Group
Public ReadOnly Group As Group
public:
initonly Group^ Group
public:
initonly Group^ Group
val Group: Group
val Group: Group

Field Value

Type: Group
See Also
NetSiteState Class
NetSiteState Members
NFX.IO.Net.Gate Namespace


NetSiteState.m_LastTouch Field

NetSiteState m_LastTouch Field NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal DateTime m_LastTouch
internal DateTime m_LastTouch
Friend m_LastTouch As DateTime
Friend m_LastTouch As DateTime
internal:
DateTime m_LastTouch
internal:
DateTime m_LastTouch
val mutable internal m_LastTouch: DateTime
val mutable internal m_LastTouch: DateTime

Field Value

Type: Online DateTime
See Also
NetSiteState Class
NetSiteState Members
NFX.IO.Net.Gate Namespace


NetSiteState.m_Variables Field

NetSiteState m_Variables Field NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal Dictionary<string, NetSiteState..::.._value> m_Variables
internal Dictionary<string, NetSiteState..::.._value> m_Variables
Friend m_Variables As Dictionary(Of String, NetSiteState..::.._value)
Friend m_Variables As Dictionary(Of String, NetSiteState..::.._value)
internal:
Dictionary<String^, NetSiteState..::.._value^>^ m_Variables
internal:
Dictionary<String^, NetSiteState..::.._value^>^ m_Variables
val mutable internal m_Variables: Dictionary<string, NetSiteState..::.._value>
val mutable internal m_Variables: Dictionary<string, NetSiteState..::.._value>

Field Value

Type: Online Dictionary Online String, NetSiteState _value
See Also
NetSiteState Class
NetSiteState Members
NFX.IO.Net.Gate Namespace


NetSiteState Methods

NetSiteState Methods NFX Class Library

The NetSiteState type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NetSiteState Class
NFX.IO.Net.Gate Namespace


NetSiteState Properties

NetSiteState Properties NFX Class Library

The NetSiteState type exposes the following members.
Properties
 | Name | Description
Public property | Key |
Back to Top
See Also
NetSiteState Class
NFX.IO.Net.Gate Namespace


NetSiteState.Key Property

NetSiteState Key Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Key { get; }
public string Key { get; }
Public ReadOnly Property Key As String
    Get
Public ReadOnly Property Key As String
    Get
public:
property String^ Key {
    String^ get ();
}
public:
property String^ Key {
    String^ get ();
}
member Key : string with get
member Key : string with get

Property Value

Type: Online String
See Also
NetSiteState Class
NetSiteState Members
NFX.IO.Net.Gate Namespace


NetSiteState._value Class

NetSiteState _value Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.IO.Net.Gate NetSiteState _value

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class _value
internal class _value
Friend Class _value
Friend Class _value
internal ref class _value
internal ref class _value
type _value =  class end
type _value =  class end
See Also
NetSiteState _value Members
NFX.IO.Net.Gate Namespace


NetSiteState._value Members

NetSiteState _value Members NFX Class Library

The NetSiteState _value type exposes the following members.
Constructors
 | Name | Description
Public method | NetSiteState _value | Initializes a new instance of the NetSiteState _value class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Value |
Back to Top
See Also
NetSiteState _value Class
NFX.IO.Net.Gate Namespace


NetSiteState._value Constructor

NetSiteState _value Constructor NFX Class Library

Initializes a new instance of the NetSiteState _value class

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public _value()
public _value()
Public Sub New
Public Sub New
public:
_value()
public:
_value()
new : unit -> _value
new : unit -> _value
See Also
NetSiteState _value Class
NetSiteState _value Members
NFX.IO.Net.Gate Namespace


NetSiteState._value Fields

NetSiteState _value Fields NFX Class Library

The NetSiteState _value type exposes the following members.
Fields
 | Name | Description
Public field | Value |
Back to Top
See Also
NetSiteState _value Class
NFX.IO.Net.Gate Namespace


NetSiteState._value.Value Field

NetSiteState _value Value Field NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long Value
public long Value
Public Value As Long
Public Value As Long
public:
long long Value
public:
long long Value
val mutable Value: int64
val mutable Value: int64

Field Value

Type: Online Int64
See Also
NetSiteState _value Class
NetSiteState _value Members
NFX.IO.Net.Gate Namespace


NetSiteState._value Methods

NetSiteState _value Methods NFX Class Library

The NetSiteState _value type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NetSiteState _value Class
NFX.IO.Net.Gate Namespace


NOPNetGate Class

NOPNetGate Class NFX Class Library

Represents an implementation of INetGate that allows all traffic
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.IO.Net.Gate NOPNetGate

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NOPNetGate : ApplicationComponent, INetGate,
    IApplicationComponent, IDisposable
public class NOPNetGate : ApplicationComponent, INetGate,
    IApplicationComponent, IDisposable
Public Class NOPNetGate
    Inherits ApplicationComponent
    Implements INetGate, IApplicationComponent, IDisposable
Public Class NOPNetGate
    Inherits ApplicationComponent
    Implements INetGate, IApplicationComponent, IDisposable
public ref class NOPNetGate : public ApplicationComponent,
    INetGate, IApplicationComponent, IDisposable
public ref class NOPNetGate : public ApplicationComponent,
    INetGate, IApplicationComponent, IDisposable
type NOPNetGate =
    class
        inherit ApplicationComponent
        interface INetGate
        interface IApplicationComponent
        interface IDisposable
    end
type NOPNetGate =
    class
        inherit ApplicationComponent
        interface INetGate
        interface IApplicationComponent
        interface IDisposable
    end
See Also
NOPNetGate Members
NFX.IO.Net.Gate Namespace


NOPNetGate Members

NOPNetGate Members NFX Class Library

The NOPNetGate type exposes the following members.
Constructors
 | Name | Description
Protected method | NOPNetGate | Initializes a new instance of the NOPNetGate class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | CheckTraffic(ITraffic) |
Public method | CheckTraffic(ITraffic, Rule ) |
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IncreaseVariable |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetVariable |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
Instance | Default instance of INetGate implementation that allows all traffic
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Enabled |
Back to Top
See Also
NOPNetGate Class
NFX.IO.Net.Gate Namespace


NOPNetGate Constructor

NOPNetGate Constructor NFX Class Library

Initializes a new instance of the NOPNetGate class

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected NOPNetGate()
protected NOPNetGate()
Protected Sub New
Protected Sub New
protected:
NOPNetGate()
protected:
NOPNetGate()
new : unit -> NOPNetGate
new : unit -> NOPNetGate
See Also
NOPNetGate Class
NOPNetGate Members
NFX.IO.Net.Gate Namespace


NOPNetGate Fields

NOPNetGate Fields NFX Class Library

The NOPNetGate type exposes the following members.
Fields
Name | Description
Instance | Default instance of INetGate implementation that allows all traffic
Back to Top
See Also
NOPNetGate Class
NFX.IO.Net.Gate Namespace


NOPNetGate.Instance Field

NOPNetGate Instance Field NFX Class Library

Default instance of INetGate implementation that allows all traffic

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly NOPNetGate Instance
public static readonly NOPNetGate Instance
Public Shared ReadOnly Instance As NOPNetGate
Public Shared ReadOnly Instance As NOPNetGate
public:
static initonly NOPNetGate^ Instance
public:
static initonly NOPNetGate^ Instance
static val Instance: NOPNetGate
static val Instance: NOPNetGate

Field Value

Type: NOPNetGate
See Also
NOPNetGate Class
NOPNetGate Members
NFX.IO.Net.Gate Namespace


NOPNetGate Methods

NOPNetGate Methods NFX Class Library

The NOPNetGate type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | CheckTraffic(ITraffic) |
Public method | CheckTraffic(ITraffic, Rule ) |
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IncreaseVariable |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetVariable |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NOPNetGate Class
NFX.IO.Net.Gate Namespace


NOPNetGate.CheckTraffic Method

NOPNetGate CheckTraffic Method NFX Class Library

Overload List
 | Name | Description
Public method | CheckTraffic(ITraffic) |
Public method | CheckTraffic(ITraffic, Rule ) |
Back to Top
See Also
NOPNetGate Class
NOPNetGate Members
NFX.IO.Net.Gate Namespace


NOPNetGate.CheckTraffic Method (ITraffic)

NOPNetGate CheckTraffic Method (ITraffic) NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GateAction CheckTraffic(
    ITraffic traffic
)
public GateAction CheckTraffic(
    ITraffic traffic
)
Public Function CheckTraffic (
    traffic As ITraffic
) As GateAction
Public Function CheckTraffic (
    traffic As ITraffic
) As GateAction
public:
virtual GateAction CheckTraffic(
    ITraffic^ traffic
) sealed
public:
virtual GateAction CheckTraffic(
    ITraffic^ traffic
) sealed
abstract CheckTraffic :
        traffic : ITraffic -> GateAction
override CheckTraffic :
        traffic : ITraffic -> GateAction
abstract CheckTraffic :
        traffic : ITraffic -> GateAction
override CheckTraffic :
        traffic : ITraffic -> GateAction

Parameters

traffic
Type: NFX.IO.Net.Gate ITraffic

Return Value

Type: GateAction

Implements

INetGate CheckTraffic(ITraffic)
See Also
NOPNetGate Class
NOPNetGate Members
CheckTraffic Overload
NFX.IO.Net.Gate Namespace


NOPNetGate.CheckTraffic Method (ITraffic, Rule)

NOPNetGate CheckTraffic Method (ITraffic, Rule ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GateAction CheckTraffic(
    ITraffic traffic,
    out Rule rule
)
public GateAction CheckTraffic(
    ITraffic traffic,
    out Rule rule
)
Public Function CheckTraffic (
    traffic As ITraffic,
    <OutAttribute> ByRef rule As Rule
) As GateAction
Public Function CheckTraffic (
    traffic As ITraffic,
    <OutAttribute> ByRef rule As Rule
) As GateAction
public:
virtual GateAction CheckTraffic(
    ITraffic^ traffic,
    [OutAttribute] Rule^% rule
) sealed
public:
virtual GateAction CheckTraffic(
    ITraffic^ traffic,
    [OutAttribute] Rule^% rule
) sealed
abstract CheckTraffic :
        traffic : ITraffic *
        rule : Rule byref -> GateAction
override CheckTraffic :
        traffic : ITraffic *
        rule : Rule byref -> GateAction
abstract CheckTraffic :
        traffic : ITraffic *
        rule : Rule byref -> GateAction
override CheckTraffic :
        traffic : ITraffic *
        rule : Rule byref -> GateAction

Parameters

traffic
Type: NFX.IO.Net.Gate ITraffic
rule
Type: NFX.IO.Net.Gate Rule

Return Value

Type: GateAction

Implements

INetGate CheckTraffic(ITraffic, Rule )
See Also
NOPNetGate Class
NOPNetGate Members
CheckTraffic Overload
NFX.IO.Net.Gate Namespace


NOPNetGate.IncreaseVariable Method

NOPNetGate IncreaseVariable Method NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void IncreaseVariable(
    TrafficDirection direction,
    string address,
    string varName,
    int value
)
public void IncreaseVariable(
    TrafficDirection direction,
    string address,
    string varName,
    int value
)
Public Sub IncreaseVariable (
    direction As TrafficDirection,
    address As String,
    varName As String,
    value As Integer
)
Public Sub IncreaseVariable (
    direction As TrafficDirection,
    address As String,
    varName As String,
    value As Integer
)
public:
virtual void IncreaseVariable(
    TrafficDirection direction,
    String^ address,
    String^ varName,
    int value
) sealed
public:
virtual void IncreaseVariable(
    TrafficDirection direction,
    String^ address,
    String^ varName,
    int value
) sealed
abstract IncreaseVariable :
        direction : TrafficDirection *
        address : string *
        varName : string *
        value : int -> unit
override IncreaseVariable :
        direction : TrafficDirection *
        address : string *
        varName : string *
        value : int -> unit
abstract IncreaseVariable :
        direction : TrafficDirection *
        address : string *
        varName : string *
        value : int -> unit
override IncreaseVariable :
        direction : TrafficDirection *
        address : string *
        varName : string *
        value : int -> unit

Parameters

direction
Type: NFX.IO.Net.Gate TrafficDirection
address
Type: Online System String
varName
Type: Online System String
value
Type: Online System Int32

Implements

INetGate IncreaseVariable(TrafficDirection, String, String, Int32)
See Also
NOPNetGate Class
NOPNetGate Members
NFX.IO.Net.Gate Namespace


NOPNetGate.SetVariable Method

NOPNetGate SetVariable Method NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetVariable(
    TrafficDirection direction,
    string address,
    string varName,
    int value
)
public void SetVariable(
    TrafficDirection direction,
    string address,
    string varName,
    int value
)
Public Sub SetVariable (
    direction As TrafficDirection,
    address As String,
    varName As String,
    value As Integer
)
Public Sub SetVariable (
    direction As TrafficDirection,
    address As String,
    varName As String,
    value As Integer
)
public:
virtual void SetVariable(
    TrafficDirection direction,
    String^ address,
    String^ varName,
    int value
) sealed
public:
virtual void SetVariable(
    TrafficDirection direction,
    String^ address,
    String^ varName,
    int value
) sealed
abstract SetVariable :
        direction : TrafficDirection *
        address : string *
        varName : string *
        value : int -> unit
override SetVariable :
        direction : TrafficDirection *
        address : string *
        varName : string *
        value : int -> unit
abstract SetVariable :
        direction : TrafficDirection *
        address : string *
        varName : string *
        value : int -> unit
override SetVariable :
        direction : TrafficDirection *
        address : string *
        varName : string *
        value : int -> unit

Parameters

direction
Type: NFX.IO.Net.Gate TrafficDirection
address
Type: Online System String
varName
Type: Online System String
value
Type: Online System Int32

Implements

INetGate SetVariable(TrafficDirection, String, String, Int32)
See Also
NOPNetGate Class
NOPNetGate Members
NFX.IO.Net.Gate Namespace


NOPNetGate Properties

NOPNetGate Properties NFX Class Library

The NOPNetGate type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Enabled |
Back to Top
See Also
NOPNetGate Class
NFX.IO.Net.Gate Namespace


NOPNetGate.Enabled Property

NOPNetGate Enabled Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Enabled { get; }
public bool Enabled { get; }
Public ReadOnly Property Enabled As Boolean
    Get
Public ReadOnly Property Enabled As Boolean
    Get
public:
virtual property bool Enabled {
    bool get () sealed;
}
public:
virtual property bool Enabled {
    bool get () sealed;
}
abstract Enabled : bool with get
override Enabled : bool with get
abstract Enabled : bool with get
override Enabled : bool with get

Property Value

Type: Online Boolean

Implements

INetGate Enabled
See Also
NOPNetGate Class
NOPNetGate Members
NFX.IO.Net.Gate Namespace


Rule Class

Rule Class NFX Class Library

Represents the named rule for NetGate
Inheritance Hierarchy
Online System Object
NFX.IO.Net.Gate Rule

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Rule : INamed, IOrdered
public class Rule : INamed, IOrdered
Public Class Rule
    Implements INamed, IOrdered
Public Class Rule
    Implements INamed, IOrdered
public ref class Rule : INamed, IOrdered
public ref class Rule : INamed, IOrdered
type Rule =
    class
        interface INamed
        interface IOrdered
    end
type Rule =
    class
        interface INamed
        interface IOrdered
    end
See Also
Rule Members
NFX.IO.Net.Gate Namespace


Rule Members

Rule Members NFX Class Library

The Rule type exposes the following members.
Constructors
 | Name | Description
Public method | Rule(IConfigSectionNode) | Initializes a new instance of the Rule class
Public method | Rule(String, Int32, GateAction) | Initializes a new instance of the Rule class
Back to Top
Methods
 | Name | Description
Public method | Check | Cheks whether the rule is satisfied - all listed conditions are met. May lazily resolve addresses to groups
Protected method | Check_FromAddrs |
Protected method | Check_FromGroups |
Protected method | Check_Methods |
Protected method | Check_Services |
Protected method | Check_ToAddrs |
Protected method | Check_ToGroups |
Protected method | Check_URLFragments |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
LIST_DELIMITERS |
VAR_EXPRESSION_PREFIX |
Back to Top
Properties
 | Name | Description
Public property | Action |
Public property | FromAddrs |
Public property | FromExpression |
Public property | FromGroups |
Public property | Methods |
Public property | Name |
Public property | Order |
Public property | Services |
Public property | ToAddrs |
Public property | ToExpression |
Public property | ToGroups |
Public property | URLFragments |
Back to Top
See Also
Rule Class
NFX.IO.Net.Gate Namespace


Rule Constructor

Rule Constructor NFX Class Library

Overload List
 | Name | Description
Public method | Rule(IConfigSectionNode) | Initializes a new instance of the Rule class
Public method | Rule(String, Int32, GateAction) | Initializes a new instance of the Rule class
Back to Top
See Also
Rule Class
Rule Members
NFX.IO.Net.Gate Namespace


Rule Constructor (IConfigSectionNode)

Rule Constructor (IConfigSectionNode) NFX Class Library

Initializes a new instance of the Rule class

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Rule(
    IConfigSectionNode node
)
public Rule(
    IConfigSectionNode node
)
Public Sub New (
    node As IConfigSectionNode
)
Public Sub New (
    node As IConfigSectionNode
)
public:
Rule(
    IConfigSectionNode^ node
)
public:
Rule(
    IConfigSectionNode^ node
)
new :
        node : IConfigSectionNode -> Rule
new :
        node : IConfigSectionNode -> Rule

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
Rule Class
Rule Members
Rule Overload
NFX.IO.Net.Gate Namespace


Rule Constructor (String, Int32, GateAction)

Rule Constructor (String, Int32, GateAction) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Rule class

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Rule(
    string name,
    int order,
    GateAction action
)
public Rule(
    string name,
    int order,
    GateAction action
)
Public Sub New (
    name As String,
    order As Integer,
    action As GateAction
)
Public Sub New (
    name As String,
    order As Integer,
    action As GateAction
)
public:
Rule(
    String^ name,
    int order,
    GateAction action
)
public:
Rule(
    String^ name,
    int order,
    GateAction action
)
new :
        name : string *
        order : int *
        action : GateAction -> Rule
new :
        name : string *
        order : int *
        action : GateAction -> Rule

Parameters

name
Type: Online System String
order
Type: Online System Int32
action
Type: NFX.IO.Net.Gate GateAction
See Also
Rule Class
Rule Members
Rule Overload
NFX.IO.Net.Gate Namespace


Rule Fields

Rule Fields NFX Class Library

The Rule type exposes the following members.
Fields
Name | Description
LIST_DELIMITERS |
VAR_EXPRESSION_PREFIX |
Back to Top
See Also
Rule Class
NFX.IO.Net.Gate Namespace


Rule.LIST_DELIMITERS Field

Rule LIST_DELIMITERS Field NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly char[] LIST_DELIMITERS
public static readonly char[] LIST_DELIMITERS
Public Shared ReadOnly LIST_DELIMITERS As Char()
Public Shared ReadOnly LIST_DELIMITERS As Char()
public:
static initonly array<wchar_t>^ LIST_DELIMITERS
public:
static initonly array<wchar_t>^ LIST_DELIMITERS
static val LIST_DELIMITERS: char[]
static val LIST_DELIMITERS: char[]

Field Value

Type: Online Char
See Also
Rule Class
Rule Members
NFX.IO.Net.Gate Namespace


Rule.VAR_EXPRESSION_PREFIX Field

Rule VAR_EXPRESSION_PREFIX Field NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string VAR_EXPRESSION_PREFIX
public static string VAR_EXPRESSION_PREFIX
Public Shared VAR_EXPRESSION_PREFIX As String
Public Shared VAR_EXPRESSION_PREFIX As String
public:
static String^ VAR_EXPRESSION_PREFIX
public:
static String^ VAR_EXPRESSION_PREFIX
static val mutable VAR_EXPRESSION_PREFIX: string
static val mutable VAR_EXPRESSION_PREFIX: string

Field Value

Type: Online String
See Also
Rule Class
Rule Members
NFX.IO.Net.Gate Namespace


Rule Methods

Rule Methods NFX Class Library

The Rule type exposes the following members.
Methods
 | Name | Description
Public method | Check | Cheks whether the rule is satisfied - all listed conditions are met. May lazily resolve addresses to groups
Protected method | Check_FromAddrs |
Protected method | Check_FromGroups |
Protected method | Check_Methods |
Protected method | Check_Services |
Protected method | Check_ToAddrs |
Protected method | Check_ToGroups |
Protected method | Check_URLFragments |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Rule Class
NFX.IO.Net.Gate Namespace


Rule.Check Method

Rule Check Method NFX Class Library

Cheks whether the rule is satisfied - all listed conditions are met. May lazily resolve addresses to groups

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Check(
    NetGate..::..State state,
    ITraffic traffic,
    ref Group fromGroup,
    ref Group toGroup
)
public virtual bool Check(
    NetGate..::..State state,
    ITraffic traffic,
    ref Group fromGroup,
    ref Group toGroup
)
Public Overridable Function Check (
    state As NetGate..::..State,
    traffic As ITraffic,
    ByRef fromGroup As Group,
    ByRef toGroup As Group
) As Boolean
Public Overridable Function Check (
    state As NetGate..::..State,
    traffic As ITraffic,
    ByRef fromGroup As Group,
    ByRef toGroup As Group
) As Boolean
public:
virtual bool Check(
    NetGate..::..State^ state,
    ITraffic^ traffic,
    Group^% fromGroup,
    Group^% toGroup
)
public:
virtual bool Check(
    NetGate..::..State^ state,
    ITraffic^ traffic,
    Group^% fromGroup,
    Group^% toGroup
)
abstract Check :
        state : NetGate..::..State *
        traffic : ITraffic *
        fromGroup : Group byref *
        toGroup : Group byref -> bool
override Check :
        state : NetGate..::..State *
        traffic : ITraffic *
        fromGroup : Group byref *
        toGroup : Group byref -> bool
abstract Check :
        state : NetGate..::..State *
        traffic : ITraffic *
        fromGroup : Group byref *
        toGroup : Group byref -> bool
override Check :
        state : NetGate..::..State *
        traffic : ITraffic *
        fromGroup : Group byref *
        toGroup : Group byref -> bool

Parameters

state
Type: NFX.IO.Net.Gate NetGate State
traffic
Type: NFX.IO.Net.Gate ITraffic
fromGroup
Type: NFX.IO.Net.Gate Group
toGroup
Type: NFX.IO.Net.Gate Group

Return Value

Type: Online Boolean
See Also
Rule Class
Rule Members
NFX.IO.Net.Gate Namespace


Rule.Check_FromAddrs Method

Rule Check_FromAddrs Method NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool Check_FromAddrs(
    string address
)
protected virtual bool Check_FromAddrs(
    string address
)
Protected Overridable Function Check_FromAddrs (
    address As String
) As Boolean
Protected Overridable Function Check_FromAddrs (
    address As String
) As Boolean
protected:
virtual bool Check_FromAddrs(
    String^ address
)
protected:
virtual bool Check_FromAddrs(
    String^ address
)
abstract Check_FromAddrs :
        address : string -> bool
override Check_FromAddrs :
        address : string -> bool
abstract Check_FromAddrs :
        address : string -> bool
override Check_FromAddrs :
        address : string -> bool

Parameters

address
Type: Online System String

Return Value

Type: Online Boolean
See Also
Rule Class
Rule Members
NFX.IO.Net.Gate Namespace


Rule.Check_FromGroups Method

Rule Check_FromGroups Method NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool Check_FromGroups(
    string fromGroup
)
protected virtual bool Check_FromGroups(
    string fromGroup
)
Protected Overridable Function Check_FromGroups (
    fromGroup As String
) As Boolean
Protected Overridable Function Check_FromGroups (
    fromGroup As String
) As Boolean
protected:
virtual bool Check_FromGroups(
    String^ fromGroup
)
protected:
virtual bool Check_FromGroups(
    String^ fromGroup
)
abstract Check_FromGroups :
        fromGroup : string -> bool
override Check_FromGroups :
        fromGroup : string -> bool
abstract Check_FromGroups :
        fromGroup : string -> bool
override Check_FromGroups :
        fromGroup : string -> bool

Parameters

fromGroup
Type: Online System String

Return Value

Type: Online Boolean
See Also
Rule Class
Rule Members
NFX.IO.Net.Gate Namespace


Rule.Check_Methods Method

Rule Check_Methods Method NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool Check_Methods(
    string method
)
protected virtual bool Check_Methods(
    string method
)
Protected Overridable Function Check_Methods (
    method As String
) As Boolean
Protected Overridable Function Check_Methods (
    method As String
) As Boolean
protected:
virtual bool Check_Methods(
    String^ method
)
protected:
virtual bool Check_Methods(
    String^ method
)
abstract Check_Methods :
        method : string -> bool
override Check_Methods :
        method : string -> bool
abstract Check_Methods :
        method : string -> bool
override Check_Methods :
        method : string -> bool

Parameters

method
Type: Online System String

Return Value

Type: Online Boolean
See Also
Rule Class
Rule Members
NFX.IO.Net.Gate Namespace


Rule.Check_Services Method

Rule Check_Services Method NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool Check_Services(
    string service
)
protected virtual bool Check_Services(
    string service
)
Protected Overridable Function Check_Services (
    service As String
) As Boolean
Protected Overridable Function Check_Services (
    service As String
) As Boolean
protected:
virtual bool Check_Services(
    String^ service
)
protected:
virtual bool Check_Services(
    String^ service
)
abstract Check_Services :
        service : string -> bool
override Check_Services :
        service : string -> bool
abstract Check_Services :
        service : string -> bool
override Check_Services :
        service : string -> bool

Parameters

service
Type: Online System String

Return Value

Type: Online Boolean
See Also
Rule Class
Rule Members
NFX.IO.Net.Gate Namespace


Rule.Check_ToAddrs Method

Rule Check_ToAddrs Method NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool Check_ToAddrs(
    string address
)
protected virtual bool Check_ToAddrs(
    string address
)
Protected Overridable Function Check_ToAddrs (
    address As String
) As Boolean
Protected Overridable Function Check_ToAddrs (
    address As String
) As Boolean
protected:
virtual bool Check_ToAddrs(
    String^ address
)
protected:
virtual bool Check_ToAddrs(
    String^ address
)
abstract Check_ToAddrs :
        address : string -> bool
override Check_ToAddrs :
        address : string -> bool
abstract Check_ToAddrs :
        address : string -> bool
override Check_ToAddrs :
        address : string -> bool

Parameters

address
Type: Online System String

Return Value

Type: Online Boolean
See Also
Rule Class
Rule Members
NFX.IO.Net.Gate Namespace


Rule.Check_ToGroups Method

Rule Check_ToGroups Method NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool Check_ToGroups(
    string toGroup
)
protected virtual bool Check_ToGroups(
    string toGroup
)
Protected Overridable Function Check_ToGroups (
    toGroup As String
) As Boolean
Protected Overridable Function Check_ToGroups (
    toGroup As String
) As Boolean
protected:
virtual bool Check_ToGroups(
    String^ toGroup
)
protected:
virtual bool Check_ToGroups(
    String^ toGroup
)
abstract Check_ToGroups :
        toGroup : string -> bool
override Check_ToGroups :
        toGroup : string -> bool
abstract Check_ToGroups :
        toGroup : string -> bool
override Check_ToGroups :
        toGroup : string -> bool

Parameters

toGroup
Type: Online System String

Return Value

Type: Online Boolean
See Also
Rule Class
Rule Members
NFX.IO.Net.Gate Namespace


Rule.Check_URLFragments Method

Rule Check_URLFragments Method NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool Check_URLFragments(
    string url
)
protected virtual bool Check_URLFragments(
    string url
)
Protected Overridable Function Check_URLFragments (
    url As String
) As Boolean
Protected Overridable Function Check_URLFragments (
    url As String
) As Boolean
protected:
virtual bool Check_URLFragments(
    String^ url
)
protected:
virtual bool Check_URLFragments(
    String^ url
)
abstract Check_URLFragments :
        url : string -> bool
override Check_URLFragments :
        url : string -> bool
abstract Check_URLFragments :
        url : string -> bool
override Check_URLFragments :
        url : string -> bool

Parameters

url
Type: Online System String

Return Value

Type: Online Boolean
See Also
Rule Class
Rule Members
NFX.IO.Net.Gate Namespace


Rule Properties

Rule Properties NFX Class Library

The Rule type exposes the following members.
Properties
 | Name | Description
Public property | Action |
Public property | FromAddrs |
Public property | FromExpression |
Public property | FromGroups |
Public property | Methods |
Public property | Name |
Public property | Order |
Public property | Services |
Public property | ToAddrs |
Public property | ToExpression |
Public property | ToGroups |
Public property | URLFragments |
Back to Top
See Also
Rule Class
NFX.IO.Net.Gate Namespace


Rule.Action Property

Rule Action Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GateAction Action { get; }
public GateAction Action { get; }
Public ReadOnly Property Action As GateAction
    Get
Public ReadOnly Property Action As GateAction
    Get
public:
property GateAction Action {
    GateAction get ();
}
public:
property GateAction Action {
    GateAction get ();
}
member Action : GateAction with get
member Action : GateAction with get

Property Value

Type: GateAction
See Also
Rule Class
Rule Members
NFX.IO.Net.Gate Namespace


Rule.FromAddrs Property

Rule FromAddrs Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string FromAddrs { get; set; }
[ConfigAttribute]
public string FromAddrs { get; set; }
<ConfigAttribute>
Public Property FromAddrs As String
    Get
    Set
<ConfigAttribute>
Public Property FromAddrs As String
    Get
    Set
public:
[ConfigAttribute]
property String^ FromAddrs {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ FromAddrs {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member FromAddrs : string with get, set
[<ConfigAttribute>]
member FromAddrs : string with get, set

Property Value

Type: Online String
See Also
Rule Class
Rule Members
NFX.IO.Net.Gate Namespace


Rule.FromExpression Property

Rule FromExpression Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string FromExpression { get; set; }
[ConfigAttribute]
public string FromExpression { get; set; }
<ConfigAttribute>
Public Property FromExpression As String
    Get
    Set
<ConfigAttribute>
Public Property FromExpression As String
    Get
    Set
public:
[ConfigAttribute]
property String^ FromExpression {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ FromExpression {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member FromExpression : string with get, set
[<ConfigAttribute>]
member FromExpression : string with get, set

Property Value

Type: Online String
See Also
Rule Class
Rule Members
NFX.IO.Net.Gate Namespace


Rule.FromGroups Property

Rule FromGroups Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string FromGroups { get; set; }
[ConfigAttribute]
public string FromGroups { get; set; }
<ConfigAttribute>
Public Property FromGroups As String
    Get
    Set
<ConfigAttribute>
Public Property FromGroups As String
    Get
    Set
public:
[ConfigAttribute]
property String^ FromGroups {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ FromGroups {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member FromGroups : string with get, set
[<ConfigAttribute>]
member FromGroups : string with get, set

Property Value

Type: Online String
See Also
Rule Class
Rule Members
NFX.IO.Net.Gate Namespace


Rule.Methods Property

Rule Methods Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string Methods { get; set; }
[ConfigAttribute]
public string Methods { get; set; }
<ConfigAttribute>
Public Property Methods As String
    Get
    Set
<ConfigAttribute>
Public Property Methods As String
    Get
    Set
public:
[ConfigAttribute]
property String^ Methods {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ Methods {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member Methods : string with get, set
[<ConfigAttribute>]
member Methods : string with get, set

Property Value

Type: Online String
See Also
Rule Class
Rule Members
NFX.IO.Net.Gate Namespace


Rule.Name Property

Rule Name Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
Rule Class
Rule Members
NFX.IO.Net.Gate Namespace


Rule.Order Property

Rule Order Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Order { get; }
public int Order { get; }
Public ReadOnly Property Order As Integer
    Get
Public ReadOnly Property Order As Integer
    Get
public:
virtual property int Order {
    int get () sealed;
}
public:
virtual property int Order {
    int get () sealed;
}
abstract Order : int with get
override Order : int with get
abstract Order : int with get
override Order : int with get

Property Value

Type: Online Int32

Implements

IOrdered Order
See Also
Rule Class
Rule Members
NFX.IO.Net.Gate Namespace


Rule.Services Property

Rule Services Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string Services { get; set; }
[ConfigAttribute]
public string Services { get; set; }
<ConfigAttribute>
Public Property Services As String
    Get
    Set
<ConfigAttribute>
Public Property Services As String
    Get
    Set
public:
[ConfigAttribute]
property String^ Services {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ Services {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member Services : string with get, set
[<ConfigAttribute>]
member Services : string with get, set

Property Value

Type: Online String
See Also
Rule Class
Rule Members
NFX.IO.Net.Gate Namespace


Rule.ToAddrs Property

Rule ToAddrs Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string ToAddrs { get; set; }
[ConfigAttribute]
public string ToAddrs { get; set; }
<ConfigAttribute>
Public Property ToAddrs As String
    Get
    Set
<ConfigAttribute>
Public Property ToAddrs As String
    Get
    Set
public:
[ConfigAttribute]
property String^ ToAddrs {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ ToAddrs {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member ToAddrs : string with get, set
[<ConfigAttribute>]
member ToAddrs : string with get, set

Property Value

Type: Online String
See Also
Rule Class
Rule Members
NFX.IO.Net.Gate Namespace


Rule.ToExpression Property

Rule ToExpression Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string ToExpression { get; set; }
[ConfigAttribute]
public string ToExpression { get; set; }
<ConfigAttribute>
Public Property ToExpression As String
    Get
    Set
<ConfigAttribute>
Public Property ToExpression As String
    Get
    Set
public:
[ConfigAttribute]
property String^ ToExpression {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ ToExpression {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member ToExpression : string with get, set
[<ConfigAttribute>]
member ToExpression : string with get, set

Property Value

Type: Online String
See Also
Rule Class
Rule Members
NFX.IO.Net.Gate Namespace


Rule.ToGroups Property

Rule ToGroups Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string ToGroups { get; set; }
[ConfigAttribute]
public string ToGroups { get; set; }
<ConfigAttribute>
Public Property ToGroups As String
    Get
    Set
<ConfigAttribute>
Public Property ToGroups As String
    Get
    Set
public:
[ConfigAttribute]
property String^ ToGroups {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ ToGroups {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member ToGroups : string with get, set
[<ConfigAttribute>]
member ToGroups : string with get, set

Property Value

Type: Online String
See Also
Rule Class
Rule Members
NFX.IO.Net.Gate Namespace


Rule.URLFragments Property

Rule URLFragments Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string URLFragments { get; set; }
[ConfigAttribute]
public string URLFragments { get; set; }
<ConfigAttribute>
Public Property URLFragments As String
    Get
    Set
<ConfigAttribute>
Public Property URLFragments As String
    Get
    Set
public:
[ConfigAttribute]
property String^ URLFragments {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ URLFragments {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member URLFragments : string with get, set
[<ConfigAttribute>]
member URLFragments : string with get, set

Property Value

Type: Online String
See Also
Rule Class
Rule Members
NFX.IO.Net.Gate Namespace


TrafficDirection Enumeration

TrafficDirection Enumeration NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum TrafficDirection
public enum TrafficDirection
Public Enumeration TrafficDirection
Public Enumeration TrafficDirection
public enum class TrafficDirection
public enum class TrafficDirection
type TrafficDirection
type TrafficDirection
Members
Member name | Value | Description
Incoming | 0 |
Outgoing | 1 |
See Also
NFX.IO.Net.Gate Namespace


VarDef Class

VarDef Class NFX Class Library

Provides variable definition - the name and parameters how fast a variable decays - loses its value towards 0 when it gets deleted
Inheritance Hierarchy
Online System Object
NFX.IO.Net.Gate VarDef

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class VarDef : INamed
public class VarDef : INamed
Public Class VarDef
    Implements INamed
Public Class VarDef
    Implements INamed
public ref class VarDef : INamed
public ref class VarDef : INamed
type VarDef =
    class
        interface INamed
    end
type VarDef =
    class
        interface INamed
    end
See Also
VarDef Members
NFX.IO.Net.Gate Namespace


VarDef Members

VarDef Members NFX Class Library

The VarDef type exposes the following members.
Constructors
 | Name | Description
Public method | VarDef(String) | Initializes a new instance of the VarDef class
Public method | VarDef(IConfigSectionNode) | Initializes a new instance of the VarDef class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
DEFAULT_DECAY_BY |
DEFAULT_INTERVAL_SEC |
Back to Top
Properties
 | Name | Description
Public property | DecayBy |
Public property | IntervalSec |
Public property | Name |
Back to Top
See Also
VarDef Class
NFX.IO.Net.Gate Namespace


VarDef Constructor

VarDef Constructor NFX Class Library

Overload List
 | Name | Description
Public method | VarDef(String) | Initializes a new instance of the VarDef class
Public method | VarDef(IConfigSectionNode) | Initializes a new instance of the VarDef class
Back to Top
See Also
VarDef Class
VarDef Members
NFX.IO.Net.Gate Namespace


VarDef Constructor (String)

VarDef Constructor (String) NFX Class Library

Initializes a new instance of the VarDef class

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public VarDef(
    string name
)
public VarDef(
    string name
)
Public Sub New (
    name As String
)
Public Sub New (
    name As String
)
public:
VarDef(
    String^ name
)
public:
VarDef(
    String^ name
)
new :
        name : string -> VarDef
new :
        name : string -> VarDef

Parameters

name
Type: Online System String
See Also
VarDef Class
VarDef Members
VarDef Overload
NFX.IO.Net.Gate Namespace


VarDef Constructor (IConfigSectionNode)

VarDef Constructor (IConfigSectionNode) NFX Class Library

Initializes a new instance of the VarDef class

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public VarDef(
    IConfigSectionNode node
)
public VarDef(
    IConfigSectionNode node
)
Public Sub New (
    node As IConfigSectionNode
)
Public Sub New (
    node As IConfigSectionNode
)
public:
VarDef(
    IConfigSectionNode^ node
)
public:
VarDef(
    IConfigSectionNode^ node
)
new :
        node : IConfigSectionNode -> VarDef
new :
        node : IConfigSectionNode -> VarDef

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
VarDef Class
VarDef Members
VarDef Overload
NFX.IO.Net.Gate Namespace


VarDef Fields

VarDef Fields NFX Class Library

The VarDef type exposes the following members.
Fields
Name | Description
DEFAULT_DECAY_BY |
DEFAULT_INTERVAL_SEC |
Back to Top
See Also
VarDef Class
NFX.IO.Net.Gate Namespace


VarDef.DEFAULT_DECAY_BY Field

VarDef DEFAULT_DECAY_BY Field NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_DECAY_BY
public const int DEFAULT_DECAY_BY
Public Const DEFAULT_DECAY_BY As Integer
Public Const DEFAULT_DECAY_BY As Integer
public:
literal int DEFAULT_DECAY_BY
public:
literal int DEFAULT_DECAY_BY
static val mutable DEFAULT_DECAY_BY: int
static val mutable DEFAULT_DECAY_BY: int

Field Value

Type: Online Int32
See Also
VarDef Class
VarDef Members
NFX.IO.Net.Gate Namespace


VarDef.DEFAULT_INTERVAL_SEC Field

VarDef DEFAULT_INTERVAL_SEC Field NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_INTERVAL_SEC
public const int DEFAULT_INTERVAL_SEC
Public Const DEFAULT_INTERVAL_SEC As Integer
Public Const DEFAULT_INTERVAL_SEC As Integer
public:
literal int DEFAULT_INTERVAL_SEC
public:
literal int DEFAULT_INTERVAL_SEC
static val mutable DEFAULT_INTERVAL_SEC: int
static val mutable DEFAULT_INTERVAL_SEC: int

Field Value

Type: Online Int32
See Also
VarDef Class
VarDef Members
NFX.IO.Net.Gate Namespace


VarDef Methods

VarDef Methods NFX Class Library

The VarDef type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
VarDef Class
NFX.IO.Net.Gate Namespace


VarDef Properties

VarDef Properties NFX Class Library

The VarDef type exposes the following members.
Properties
 | Name | Description
Public property | DecayBy |
Public property | IntervalSec |
Public property | Name |
Back to Top
See Also
VarDef Class
NFX.IO.Net.Gate Namespace


VarDef.DecayBy Property

VarDef DecayBy Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int DecayBy { get; set; }
[ConfigAttribute]
public int DecayBy { get; set; }
<ConfigAttribute>
Public Property DecayBy As Integer
    Get
    Set
<ConfigAttribute>
Public Property DecayBy As Integer
    Get
    Set
public:
[ConfigAttribute]
property int DecayBy {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute]
property int DecayBy {
    int get ();
    void set (int value);
}
[<ConfigAttribute>]
member DecayBy : int with get, set
[<ConfigAttribute>]
member DecayBy : int with get, set

Property Value

Type: Online Int32
See Also
VarDef Class
VarDef Members
NFX.IO.Net.Gate Namespace


VarDef.IntervalSec Property

VarDef IntervalSec Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(Default = 10)]
public int IntervalSec { get; set; }
[ConfigAttribute(Default = 10)]
public int IntervalSec { get; set; }
<ConfigAttribute(Default := 10)>
Public Property IntervalSec As Integer
    Get
    Set
<ConfigAttribute(Default := 10)>
Public Property IntervalSec As Integer
    Get
    Set
public:
[ConfigAttribute(Default = 10)]
property int IntervalSec {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(Default = 10)]
property int IntervalSec {
    int get ();
    void set (int value);
}
[<ConfigAttribute(Default = 10)>]
member IntervalSec : int with get, set
[<ConfigAttribute(Default = 10)>]
member IntervalSec : int with get, set

Property Value

Type: Online Int32
See Also
VarDef Class
VarDef Members
NFX.IO.Net.Gate Namespace


VarDef.Name Property

VarDef Name Property NFX Class Library

Namespace: NFX.IO.Net.Gate
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
VarDef Class
VarDef Members
NFX.IO.Net.Gate Namespace


NFX.Log Namespace

NFX.Log Namespace NFX Class Library

Logging services
Classes
 | Class | Description
Public class | LogService | Provides logging services by buffering messages and dispatching them into destinations. This is an asynchronous service, meaning that Write(msg) never blocks for long.
Public class | LogServiceBase | Based class for implementing test and non-test logging services. Destinations may fail and the message will be failed-over into another destination in the same logger as specified by 'failover' attribute of destination. This attribute is also present on service level. Cascading failover is not supported (failover of failovers). Another consideration is that messages get sent into destinations synchronously by internal thread so specifying too many destinations may limit overall LogService throughput. In complex scenarios consider using LogServiceDestination instead.
Public class | LogServiceBase DestinationList |
Public class | Message | Represents a Log message
Public class | MessageFilterExpression | Defines an expression used for log message filtering. Important: it is not a good practice to create many different scopes as it leads to creation of many assemblies dynamically
Protected class | MessageList |
Public class | NOPLog | Represents log that does not do anything
Interfaces
 | Interface | Description
Public interface | ILog | Describes entity capable of being written log information to
Public interface | ILogImplementation | Describes entity capable of being written log information to
Enumerations
 | Enumeration | Description
Public enumeration | MessageType | Stipulates general logging message types like: Info/Warning/Error etc...


ILog Interface

ILog Interface NFX Class Library

Describes entity capable of being written log information to

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ILog : IApplicationComponent, IDisposable,
    ILocalizedTimeProvider
public interface ILog : IApplicationComponent, IDisposable,
    ILocalizedTimeProvider
Public Interface ILog
    Inherits IApplicationComponent, IDisposable, ILocalizedTimeProvider
Public Interface ILog
    Inherits IApplicationComponent, IDisposable, ILocalizedTimeProvider
public interface class ILog : IApplicationComponent,
    IDisposable, ILocalizedTimeProvider
public interface class ILog : IApplicationComponent,
    IDisposable, ILocalizedTimeProvider
type ILog =
    interface
        interface IApplicationComponent
        interface IDisposable
        interface ILocalizedTimeProvider
    end
type ILog =
    interface
        interface IApplicationComponent
        interface IDisposable
        interface ILocalizedTimeProvider
    end
See Also
ILog Members
NFX.Log Namespace


ILog Members

ILog Members NFX Class Library

The ILog type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | Write(Message) |
Public method | Write(Message, Boolean) |
Public method | Write(MessageType, String, String, String) |
Public method | Write(MessageType, String, Boolean, String, String) |
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | LastCatastrophy |
Public property | LastError |
Public property | LastWarning |
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from ILocalizedTimeProvider.)
Public property | TimeLocation | Returns the location (Inherited from ILocalizedTimeProvider.)
Back to Top
See Also
ILog Interface
NFX.Log Namespace


ILog Methods

ILog Methods NFX Class Library

The ILog type exposes the following members.
Methods
 | Name | Description
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | Write(Message) |
Public method | Write(Message, Boolean) |
Public method | Write(MessageType, String, String, String) |
Public method | Write(MessageType, String, Boolean, String, String) |
Back to Top
See Also
ILog Interface
NFX.Log Namespace


ILog.Write Method

ILog Write Method NFX Class Library

Overload List
 | Name | Description
Public method | Write(Message) |
Public method | Write(Message, Boolean) |
Public method | Write(MessageType, String, String, String) |
Public method | Write(MessageType, String, Boolean, String, String) |
Back to Top
See Also
ILog Interface
ILog Members
NFX.Log Namespace


ILog.Write Method (Message)

ILog Write Method (Message) NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Write(
    Message msg
)
void Write(
    Message msg
)
Sub Write (
    msg As Message
)
Sub Write (
    msg As Message
)
void Write(
    Message^ msg
)
void Write(
    Message^ msg
)
abstract Write :
        msg : Message -> unit
abstract Write :
        msg : Message -> unit

Parameters

msg
Type: NFX.Log Message
See Also
ILog Interface
ILog Members
Write Overload
NFX.Log Namespace


ILog.Write Method (Message, Boolean)

ILog Write Method (Message, Boolean) NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Write(
    Message msg,
    bool urgent
)
void Write(
    Message msg,
    bool urgent
)
Sub Write (
    msg As Message,
    urgent As Boolean
)
Sub Write (
    msg As Message,
    urgent As Boolean
)
void Write(
    Message^ msg,
    bool urgent
)
void Write(
    Message^ msg,
    bool urgent
)
abstract Write :
        msg : Message *
        urgent : bool -> unit
abstract Write :
        msg : Message *
        urgent : bool -> unit

Parameters

msg
Type: NFX.Log Message
urgent
Type: Online System Boolean
See Also
ILog Interface
ILog Members
Write Overload
NFX.Log Namespace


ILog.Write Method (MessageType, String, String, String)

ILog Write Method (MessageType, String, String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Write(
    MessageType type,
    string text,
    string topic = null,
    string from = null
)
void Write(
    MessageType type,
    string text,
    string topic = null,
    string from = null
)
Sub Write (
    type As MessageType,
    text As String,
    Optional topic As String = Nothing,
    Optional from As String = Nothing
)
Sub Write (
    type As MessageType,
    text As String,
    Optional topic As String = Nothing,
    Optional from As String = Nothing
)
void Write(
    MessageType type,
    String^ text,
    String^ topic = nullptr,
    String^ from = nullptr
)
void Write(
    MessageType type,
    String^ text,
    String^ topic = nullptr,
    String^ from = nullptr
)
abstract Write :
        type : MessageType *
        text : string *
        ?topic : string *
        ?from : string
(* Defaults:
        let _topic = defaultArg topic null
        let _from = defaultArg from null
*)
-> unit
abstract Write :
        type : MessageType *
        text : string *
        ?topic : string *
        ?from : string
(* Defaults:
        let _topic = defaultArg topic null
        let _from = defaultArg from null
*)
-> unit

Parameters

type
Type: NFX.Log MessageType
text
Type: Online System String
topic (Optional)
Type: Online System String
from (Optional)
Type: Online System String
See Also
ILog Interface
ILog Members
Write Overload
NFX.Log Namespace


ILog.Write Method (MessageType, String, Boolean, String, String)

ILog Write Method (MessageType, String, Boolean, String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Write(
    MessageType type,
    string text,
    bool urgent,
    string topic = null,
    string from = null
)
void Write(
    MessageType type,
    string text,
    bool urgent,
    string topic = null,
    string from = null
)
Sub Write (
    type As MessageType,
    text As String,
    urgent As Boolean,
    Optional topic As String = Nothing,
    Optional from As String = Nothing
)
Sub Write (
    type As MessageType,
    text As String,
    urgent As Boolean,
    Optional topic As String = Nothing,
    Optional from As String = Nothing
)
void Write(
    MessageType type,
    String^ text,
    bool urgent,
    String^ topic = nullptr,
    String^ from = nullptr
)
void Write(
    MessageType type,
    String^ text,
    bool urgent,
    String^ topic = nullptr,
    String^ from = nullptr
)
abstract Write :
        type : MessageType *
        text : string *
        urgent : bool *
        ?topic : string *
        ?from : string
(* Defaults:
        let _topic = defaultArg topic null
        let _from = defaultArg from null
*)
-> unit
abstract Write :
        type : MessageType *
        text : string *
        urgent : bool *
        ?topic : string *
        ?from : string
(* Defaults:
        let _topic = defaultArg topic null
        let _from = defaultArg from null
*)
-> unit

Parameters

type
Type: NFX.Log MessageType
text
Type: Online System String
urgent
Type: Online System Boolean
topic (Optional)
Type: Online System String
from (Optional)
Type: Online System String
See Also
ILog Interface
ILog Members
Write Overload
NFX.Log Namespace


ILog Properties

ILog Properties NFX Class Library

The ILog type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | LastCatastrophy |
Public property | LastError |
Public property | LastWarning |
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from ILocalizedTimeProvider.)
Public property | TimeLocation | Returns the location (Inherited from ILocalizedTimeProvider.)
Back to Top
See Also
ILog Interface
NFX.Log Namespace


ILog.LastCatastrophy Property

ILog LastCatastrophy Property NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Message LastCatastrophy { get; }
Message LastCatastrophy { get; }
ReadOnly Property LastCatastrophy As Message
    Get
ReadOnly Property LastCatastrophy As Message
    Get
property Message^ LastCatastrophy {
    Message^ get ();
}
property Message^ LastCatastrophy {
    Message^ get ();
}
abstract LastCatastrophy : Message with get
abstract LastCatastrophy : Message with get

Property Value

Type: Message
See Also
ILog Interface
ILog Members
NFX.Log Namespace


ILog.LastError Property

ILog LastError Property NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Message LastError { get; }
Message LastError { get; }
ReadOnly Property LastError As Message
    Get
ReadOnly Property LastError As Message
    Get
property Message^ LastError {
    Message^ get ();
}
property Message^ LastError {
    Message^ get ();
}
abstract LastError : Message with get
abstract LastError : Message with get

Property Value

Type: Message
See Also
ILog Interface
ILog Members
NFX.Log Namespace


ILog.LastWarning Property

ILog LastWarning Property NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Message LastWarning { get; }
Message LastWarning { get; }
ReadOnly Property LastWarning As Message
    Get
ReadOnly Property LastWarning As Message
    Get
property Message^ LastWarning {
    Message^ get ();
}
property Message^ LastWarning {
    Message^ get ();
}
abstract LastWarning : Message with get
abstract LastWarning : Message with get

Property Value

Type: Message
See Also
ILog Interface
ILog Members
NFX.Log Namespace


ILogImplementation Interface

ILogImplementation Interface NFX Class Library

Describes entity capable of being written log information to

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ILogImplementation : ILog,
    IApplicationComponent, ILocalizedTimeProvider, IDisposable, IConfigurable, IInstrumentable,
    IExternallyParameterized
public interface ILogImplementation : ILog,
    IApplicationComponent, ILocalizedTimeProvider, IDisposable, IConfigurable, IInstrumentable,
    IExternallyParameterized
Public Interface ILogImplementation
    Inherits ILog, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
Public Interface ILogImplementation
    Inherits ILog, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
public interface class ILogImplementation : ILog,
    IApplicationComponent, ILocalizedTimeProvider, IDisposable, IConfigurable, IInstrumentable,
    IExternallyParameterized
public interface class ILogImplementation : ILog,
    IApplicationComponent, ILocalizedTimeProvider, IDisposable, IConfigurable, IInstrumentable,
    IExternallyParameterized
type ILogImplementation =
    interface
        interface ILog
        interface IApplicationComponent
        interface ILocalizedTimeProvider
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
type ILogImplementation =
    interface
        interface ILog
        interface IApplicationComponent
        interface ILocalizedTimeProvider
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
ILogImplementation Members
NFX.Log Namespace


ILogImplementation Members

ILogImplementation Members NFX Class Library

The ILogImplementation type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | Write(Message) | (Inherited from ILog.)
Public method | Write(Message, Boolean) | (Inherited from ILog.)
Public method | Write(MessageType, String, String, String) | (Inherited from ILog.)
Public method | Write(MessageType, String, Boolean, String, String) | (Inherited from ILog.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | LastCatastrophy | (Inherited from ILog.)
Public property | LastError | (Inherited from ILog.)
Public property | LastWarning | (Inherited from ILog.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from ILocalizedTimeProvider.)
Public property | TimeLocation | Returns the location (Inherited from ILocalizedTimeProvider.)
Back to Top
See Also
ILogImplementation Interface
NFX.Log Namespace


ILogImplementation Methods

ILogImplementation Methods NFX Class Library

The ILogImplementation type exposes the following members.
Methods
 | Name | Description
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from ILocalizedTimeProvider.)
Public method | Write(Message) | (Inherited from ILog.)
Public method | Write(Message, Boolean) | (Inherited from ILog.)
Public method | Write(MessageType, String, String, String) | (Inherited from ILog.)
Public method | Write(MessageType, String, Boolean, String, String) | (Inherited from ILog.)
Back to Top
See Also
ILogImplementation Interface
NFX.Log Namespace


ILogImplementation Properties

ILogImplementation Properties NFX Class Library

The ILogImplementation type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | LastCatastrophy | (Inherited from ILog.)
Public property | LastError | (Inherited from ILog.)
Public property | LastWarning | (Inherited from ILog.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from ILocalizedTimeProvider.)
Public property | TimeLocation | Returns the location (Inherited from ILocalizedTimeProvider.)
Back to Top
See Also
ILogImplementation Interface
NFX.Log Namespace


LogService Class

LogService Class NFX Class Library

Provides logging services by buffering messages and dispatching them into destinations. This is an asynchronous service, meaning that Write(msg) never blocks for long.
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service Online Object
NFX.ServiceModel ServiceWithInstrumentationBase Online Object
NFX.Log LogServiceBase
NFX.Log LogService

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigMacroContextAttribute]
public class LogService : LogServiceBase
[ConfigMacroContextAttribute]
public class LogService : LogServiceBase
<ConfigMacroContextAttribute>
Public Class LogService
    Inherits LogServiceBase
<ConfigMacroContextAttribute>
Public Class LogService
    Inherits LogServiceBase
[ConfigMacroContextAttribute]
public ref class LogService : public LogServiceBase
[ConfigMacroContextAttribute]
public ref class LogService : public LogServiceBase
[<ConfigMacroContextAttribute>]
type LogService =
    class
        inherit LogServiceBase
    end
[<ConfigMacroContextAttribute>]
type LogService =
    class
        inherit LogServiceBase
    end
See Also
LogService Members
NFX.Log Namespace


LogService Members

LogService Members NFX Class Library

The LogService type exposes the following members.
Constructors
 | Name | Description
Public method | LogService | Creates a new logging service instance
Public method | LogService(Service) | Creates a new logging service instance
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from LogServiceBase.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Inherited from LogServiceBase.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides LogServiceBase DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides LogServiceBase DoWaitForCompleteStop .)
Protected method | DoWrite | Writes log message into log (Overrides LogServiceBase DoWrite(Message, Boolean).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | FailoverDestination | When error=null => error cleared. When msg==null => exceptions surfaced from DoPulse() (Inherited from LogServiceBase.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetInstrumentationBuffer | Returns instrumentation buffer if instrumentation enabled (Inherited from LogServiceBase.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Pulse | (Inherited from LogServiceBase.)
Public method | RegisterDestination | Adds a destination to this service active destinations. Negative index to append (Inherited from LogServiceBase.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | UnRegisterDestination | Removes a destiantion from this service active destinations, returns true if destination was found and removed (Inherited from LogServiceBase.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | Write(Message) | Writes log message into log (Inherited from LogServiceBase.)
Public method | Write(Message, Boolean) | Writes log message into log (Inherited from LogServiceBase.)
Public method | Write(MessageType, String, String, String) | Writes log message into log (Inherited from LogServiceBase.)
Public method | Write(MessageType, String, Boolean, String, String) | Writes log message into log (Inherited from LogServiceBase.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | CONFIG_FILEEXTENSION_ATTR |
 | CONFIG_RELIABLE_ATTR |
 | CONFIG_WRITEINTERVAL_ATTR |
Protected field | m_Destinations | (Inherited from LogServiceBase.)
Protected field | m_InstrumentationEnabled | (Inherited from LogServiceBase.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | (Inherited from LogServiceBase.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DefaultFailover | Sets destination name used for failover on the service-level if particular failing destination did not specify its specific failover (Inherited from LogServiceBase.)
Public property | Destinations | Returns registered destinations. This call is thread safe (Inherited from LogServiceBase.)
Public property | DestinationsAreOptional | Indicates whether the service can operate without any destinations registered, i.e. some test loggers may not need any destinations to operate as they synchronously write to some buffer without any extra destinations (Inherited from LogServiceBase.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | FailoverError | Returns last exception that happened during failover. This kind of exceptions is never propagated and always handled (Inherited from LogServiceBase.)
Public property | FailoverErrorDestination | Returns a destination that threw last exception that happened durng failover. This kind of exceptions is never propagated and always handled (Inherited from LogServiceBase.)
Public property | FileExtension | Extension for log files
Public property | InstrumentationBufferSize | (Inherited from LogServiceBase.)
Public property | InstrumentationEnabled | Implements IInstrumentable (Inherited from LogServiceBase.)
Public property | LastCatastrophy | Latches last problematic msg (Inherited from LogServiceBase.)
Public property | LastError | Latches last problematic msg (Inherited from LogServiceBase.)
Public property | LastWarning | Latches last problematic msg (Inherited from LogServiceBase.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Now | Returns localized log time (Inherited from LogServiceBase.)
Public property | Reliable | Determines whether this service blocks on stop longer until all buffered messages have been tried to be dispatched into all destinations. This property is true by default. Certain destinations may take considerable time to fail per message (i.e. database connection timeout), consequently buffered messages processing may delay service stop significantly if this property is true
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | WriteInterval | Determines how often a log should be written to storage. The value of this property must be between 10 and 5000 (milliseconds)
Back to Top
See Also
LogService Class
NFX.Log Namespace


LogService Constructor

LogService Constructor NFX Class Library

Overload List
 | Name | Description
Public method | LogService | Creates a new logging service instance
Public method | LogService(Service) | Creates a new logging service instance
Back to Top
See Also
LogService Class
LogService Members
NFX.Log Namespace


LogService Constructor

LogService Constructor NFX Class Library

Creates a new logging service instance

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LogService()
public LogService()
Public Sub New
Public Sub New
public:
LogService()
public:
LogService()
new : unit -> LogService
new : unit -> LogService
See Also
LogService Class
LogService Members
LogService Overload
NFX.Log Namespace


LogService Constructor (Service)

LogService Constructor (Service) NFX Class Library

Creates a new logging service instance

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LogService(
    Service director = null
)
public LogService(
    Service director = null
)
Public Sub New (
    Optional director As Service = Nothing
)
Public Sub New (
    Optional director As Service = Nothing
)
public:
LogService(
    Service^ director = nullptr
)
public:
LogService(
    Service^ director = nullptr
)
new :
        ?director : Service
(* Defaults:
        let _director = defaultArg director null
*)
-> LogService
new :
        ?director : Service
(* Defaults:
        let _director = defaultArg director null
*)
-> LogService

Parameters

director (Optional)
Type: NFX.ServiceModel Service
See Also
LogService Class
LogService Members
LogService Overload
NFX.Log Namespace


LogService Fields

LogService Fields NFX Class Library

The LogService type exposes the following members.
Fields
 | Name | Description
 | CONFIG_FILEEXTENSION_ATTR |
 | CONFIG_RELIABLE_ATTR |
 | CONFIG_WRITEINTERVAL_ATTR |
Protected field | m_Destinations | (Inherited from LogServiceBase.)
Protected field | m_InstrumentationEnabled | (Inherited from LogServiceBase.)
Back to Top
See Also
LogService Class
NFX.Log Namespace


LogService.CONFIG_FILEEXTENSION_ATTR Field

LogService CONFIG_FILEEXTENSION_ATTR Field NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_FILEEXTENSION_ATTR
public const string CONFIG_FILEEXTENSION_ATTR
Public Const CONFIG_FILEEXTENSION_ATTR As String
Public Const CONFIG_FILEEXTENSION_ATTR As String
public:
literal String^ CONFIG_FILEEXTENSION_ATTR
public:
literal String^ CONFIG_FILEEXTENSION_ATTR
static val mutable CONFIG_FILEEXTENSION_ATTR: string
static val mutable CONFIG_FILEEXTENSION_ATTR: string

Field Value

Type: Online String
See Also
LogService Class
LogService Members
NFX.Log Namespace


LogService.CONFIG_RELIABLE_ATTR Field

LogService CONFIG_RELIABLE_ATTR Field NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_RELIABLE_ATTR
public const string CONFIG_RELIABLE_ATTR
Public Const CONFIG_RELIABLE_ATTR As String
Public Const CONFIG_RELIABLE_ATTR As String
public:
literal String^ CONFIG_RELIABLE_ATTR
public:
literal String^ CONFIG_RELIABLE_ATTR
static val mutable CONFIG_RELIABLE_ATTR: string
static val mutable CONFIG_RELIABLE_ATTR: string

Field Value

Type: Online String
See Also
LogService Class
LogService Members
NFX.Log Namespace


LogService.CONFIG_WRITEINTERVAL_ATTR Field

LogService CONFIG_WRITEINTERVAL_ATTR Field NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_WRITEINTERVAL_ATTR
public const string CONFIG_WRITEINTERVAL_ATTR
Public Const CONFIG_WRITEINTERVAL_ATTR As String
Public Const CONFIG_WRITEINTERVAL_ATTR As String
public:
literal String^ CONFIG_WRITEINTERVAL_ATTR
public:
literal String^ CONFIG_WRITEINTERVAL_ATTR
static val mutable CONFIG_WRITEINTERVAL_ATTR: string
static val mutable CONFIG_WRITEINTERVAL_ATTR: string

Field Value

Type: Online String
See Also
LogService Class
LogService Members
NFX.Log Namespace


LogService Methods

LogService Methods NFX Class Library

The LogService type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from LogServiceBase.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Inherited from LogServiceBase.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides LogServiceBase DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides LogServiceBase DoWaitForCompleteStop .)
Protected method | DoWrite | Writes log message into log (Overrides LogServiceBase DoWrite(Message, Boolean).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | FailoverDestination | When error=null => error cleared. When msg==null => exceptions surfaced from DoPulse() (Inherited from LogServiceBase.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetInstrumentationBuffer | Returns instrumentation buffer if instrumentation enabled (Inherited from LogServiceBase.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Pulse | (Inherited from LogServiceBase.)
Public method | RegisterDestination | Adds a destination to this service active destinations. Negative index to append (Inherited from LogServiceBase.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | UnRegisterDestination | Removes a destiantion from this service active destinations, returns true if destination was found and removed (Inherited from LogServiceBase.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | Write(Message) | Writes log message into log (Inherited from LogServiceBase.)
Public method | Write(Message, Boolean) | Writes log message into log (Inherited from LogServiceBase.)
Public method | Write(MessageType, String, String, String) | Writes log message into log (Inherited from LogServiceBase.)
Public method | Write(MessageType, String, Boolean, String, String) | Writes log message into log (Inherited from LogServiceBase.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LogService Class
NFX.Log Namespace


LogService.DoStart Method

LogService DoStart Method NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
LogService Class
LogService Members
NFX.Log Namespace


LogService.DoWaitForCompleteStop Method

LogService DoWaitForCompleteStop Method NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
LogService Class
LogService Members
NFX.Log Namespace


LogService.DoWrite Method

LogService DoWrite Method NFX Class Library

Writes log message into log

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWrite(
    Message msg,
    bool urgent
)
protected override void DoWrite(
    Message msg,
    bool urgent
)
Protected Overrides Sub DoWrite (
    msg As Message,
    urgent As Boolean
)
Protected Overrides Sub DoWrite (
    msg As Message,
    urgent As Boolean
)
protected:
virtual void DoWrite(
    Message^ msg,
    bool urgent
) override
protected:
virtual void DoWrite(
    Message^ msg,
    bool urgent
) override
abstract DoWrite :
        msg : Message *
        urgent : bool -> unit
override DoWrite :
        msg : Message *
        urgent : bool -> unit
abstract DoWrite :
        msg : Message *
        urgent : bool -> unit
override DoWrite :
        msg : Message *
        urgent : bool -> unit

Parameters

msg
Type: NFX.Log Message
urgent
Type: Online System Boolean
See Also
LogService Class
LogService Members
NFX.Log Namespace


LogService Properties

LogService Properties NFX Class Library

The LogService type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | (Inherited from LogServiceBase.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DefaultFailover | Sets destination name used for failover on the service-level if particular failing destination did not specify its specific failover (Inherited from LogServiceBase.)
Public property | Destinations | Returns registered destinations. This call is thread safe (Inherited from LogServiceBase.)
Public property | DestinationsAreOptional | Indicates whether the service can operate without any destinations registered, i.e. some test loggers may not need any destinations to operate as they synchronously write to some buffer without any extra destinations (Inherited from LogServiceBase.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | FailoverError | Returns last exception that happened during failover. This kind of exceptions is never propagated and always handled (Inherited from LogServiceBase.)
Public property | FailoverErrorDestination | Returns a destination that threw last exception that happened durng failover. This kind of exceptions is never propagated and always handled (Inherited from LogServiceBase.)
Public property | FileExtension | Extension for log files
Public property | InstrumentationBufferSize | (Inherited from LogServiceBase.)
Public property | InstrumentationEnabled | Implements IInstrumentable (Inherited from LogServiceBase.)
Public property | LastCatastrophy | Latches last problematic msg (Inherited from LogServiceBase.)
Public property | LastError | Latches last problematic msg (Inherited from LogServiceBase.)
Public property | LastWarning | Latches last problematic msg (Inherited from LogServiceBase.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Now | Returns localized log time (Inherited from LogServiceBase.)
Public property | Reliable | Determines whether this service blocks on stop longer until all buffered messages have been tried to be dispatched into all destinations. This property is true by default. Certain destinations may take considerable time to fail per message (i.e. database connection timeout), consequently buffered messages processing may delay service stop significantly if this property is true
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Public property | WriteInterval | Determines how often a log should be written to storage. The value of this property must be between 10 and 5000 (milliseconds)
Back to Top
See Also
LogService Class
NFX.Log Namespace


LogService.FileExtension Property

LogService FileExtension Property NFX Class Library

Extension for log files

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute("$file-extension")]
public string FileExtension { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute("$file-extension")]
public string FileExtension { get; set; }
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute("$file-extension")>
Public Property FileExtension As String
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute("$file-extension")>
Public Property FileExtension As String
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(L"$file-extension")]
property String^ FileExtension {
    String^ get ();
    void set (String^ value);
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(L"$file-extension")]
property String^ FileExtension {
    String^ get ();
    void set (String^ value);
}
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute("$file-extension")>]
member FileExtension : string with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute("$file-extension")>]
member FileExtension : string with get, set

Property Value

Type: Online String
See Also
LogService Class
LogService Members
NFX.Log Namespace


LogService.Reliable Property

LogService Reliable Property NFX Class Library

Determines whether this service blocks on stop longer until all buffered messages have been tried to be dispatched into all destinations. This property is true by default. Certain destinations may take considerable time to fail per message (i.e. database connection timeout), consequently buffered messages processing may delay service stop significantly if this property is true

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$reliable", true)]
[ExternalParameterAttribute(new string[] { ... })]
public bool Reliable { get; set; }
[ConfigAttribute("$reliable", true)]
[ExternalParameterAttribute(new string[] { ... })]
public bool Reliable { get; set; }
<ConfigAttribute("$reliable", true)>
<ExternalParameterAttribute(New String() { ... })>
Public Property Reliable As Boolean
    Get
    Set
<ConfigAttribute("$reliable", true)>
<ExternalParameterAttribute(New String() { ... })>
Public Property Reliable As Boolean
    Get
    Set
public:
[ConfigAttribute(L"$reliable", true)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property bool Reliable {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute(L"$reliable", true)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property bool Reliable {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute("$reliable", true)>]
[<ExternalParameterAttribute(new string[] { ... })>]
member Reliable : bool with get, set
[<ConfigAttribute("$reliable", true)>]
[<ExternalParameterAttribute(new string[] { ... })>]
member Reliable : bool with get, set

Property Value

Type: Online Boolean
See Also
LogService Class
LogService Members
NFX.Log Namespace


LogService.WriteInterval Property

LogService WriteInterval Property NFX Class Library

Determines how often a log should be written to storage. The value of this property must be between 10 and 5000 (milliseconds)

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$write-interval-ms", 250)]
[ExternalParameterAttribute(new string[] { ... })]
public int WriteInterval { get; set; }
[ConfigAttribute("$write-interval-ms", 250)]
[ExternalParameterAttribute(new string[] { ... })]
public int WriteInterval { get; set; }
<ConfigAttribute("$write-interval-ms", 250)>
<ExternalParameterAttribute(New String() { ... })>
Public Property WriteInterval As Integer
    Get
    Set
<ConfigAttribute("$write-interval-ms", 250)>
<ExternalParameterAttribute(New String() { ... })>
Public Property WriteInterval As Integer
    Get
    Set
public:
[ConfigAttribute(L"$write-interval-ms", 250)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property int WriteInterval {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(L"$write-interval-ms", 250)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property int WriteInterval {
    int get ();
    void set (int value);
}
[<ConfigAttribute("$write-interval-ms", 250)>]
[<ExternalParameterAttribute(new string[] { ... })>]
member WriteInterval : int with get, set
[<ConfigAttribute("$write-interval-ms", 250)>]
[<ExternalParameterAttribute(new string[] { ... })>]
member WriteInterval : int with get, set

Property Value

Type: Online Int32
See Also
LogService Class
LogService Members
NFX.Log Namespace


LogServiceBase Class

LogServiceBase Class NFX Class Library

Based class for implementing test and non-test logging services. Destinations may fail and the message will be failed-over into another destination in the same logger as specified by 'failover' attribute of destination. This attribute is also present on service level. Cascading failover is not supported (failover of failovers). Another consideration is that messages get sent into destinations synchronously by internal thread so specifying too many destinations may limit overall LogService throughput. In complex scenarios consider using LogServiceDestination instead.
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service Online Object
NFX.ServiceModel ServiceWithInstrumentationBase Online Object
NFX.Log LogServiceBase
NFX.Log LogService

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class LogServiceBase : ServiceWithInstrumentationBase<Object>,
    ILogImplementation, ILog, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
public abstract class LogServiceBase : ServiceWithInstrumentationBase<Object>,
    ILogImplementation, ILog, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
Public MustInherit Class LogServiceBase
    Inherits ServiceWithInstrumentationBase(Of Object)
    Implements ILogImplementation, ILog, IApplicationComponent, ILocalizedTimeProvider,
    IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
Public MustInherit Class LogServiceBase
    Inherits ServiceWithInstrumentationBase(Of Object)
    Implements ILogImplementation, ILog, IApplicationComponent, ILocalizedTimeProvider,
    IDisposable, IConfigurable, IInstrumentable, IExternallyParameterized
public ref class LogServiceBase abstract : public ServiceWithInstrumentationBase<Object^>,
    ILogImplementation, ILog, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
public ref class LogServiceBase abstract : public ServiceWithInstrumentationBase<Object^>,
    ILogImplementation, ILog, IApplicationComponent, ILocalizedTimeProvider, IDisposable,
    IConfigurable, IInstrumentable, IExternallyParameterized
[<AbstractClassAttribute>]
type LogServiceBase =
    class
        inherit ServiceWithInstrumentationBase<Object>
        interface ILogImplementation
        interface ILog
        interface IApplicationComponent
        interface ILocalizedTimeProvider
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
[<AbstractClassAttribute>]
type LogServiceBase =
    class
        inherit ServiceWithInstrumentationBase<Object>
        interface ILogImplementation
        interface ILog
        interface IApplicationComponent
        interface ILocalizedTimeProvider
        interface IDisposable
        interface IConfigurable
        interface IInstrumentable
        interface IExternallyParameterized
    end
See Also
LogServiceBase Members
NFX.Log Namespace


LogServiceBase Members

LogServiceBase Members NFX Class Library

The LogServiceBase type exposes the following members.
Constructors
 | Name | Description
Protected method | LogServiceBase | Creates a new logging service instance
Protected method | LogServiceBase(Service) | Creates a new logging service instance
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Overrides Service Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Protected method | DoWrite | Writes log message into log
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | FailoverDestination | When error=null => error cleared. When msg==null => exceptions surfaced from DoPulse()
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetInstrumentationBuffer | Returns instrumentation buffer if instrumentation enabled
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Pulse |
Public method | RegisterDestination | Adds a destination to this service active destinations. Negative index to append
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | UnRegisterDestination | Removes a destiantion from this service active destinations, returns true if destination was found and removed
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | Write(Message) | Writes log message into log
Public method | Write(Message, Boolean) | Writes log message into log
Public method | Write(MessageType, String, String, String) | Writes log message into log
Public method | Write(MessageType, String, Boolean, String, String) | Writes log message into log
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | CONFIG_DEFAULT_FAILOVER_ATTR |
 | CONFIG_DESTINATION_SECTION |
Protected field | m_Destinations |
Protected field | m_InstrumentationEnabled |
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | (Overrides ApplicationComponent ComponentCommonName.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DefaultFailover | Sets destination name used for failover on the service-level if particular failing destination did not specify its specific failover
Public property | Destinations | Returns registered destinations. This call is thread safe
Public property | DestinationsAreOptional | Indicates whether the service can operate without any destinations registered, i.e. some test loggers may not need any destinations to operate as they synchronously write to some buffer without any extra destinations
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | FailoverError | Returns last exception that happened during failover. This kind of exceptions is never propagated and always handled
Public property | FailoverErrorDestination | Returns a destination that threw last exception that happened durng failover. This kind of exceptions is never propagated and always handled
Public property | InstrumentationBufferSize |
Public property | InstrumentationEnabled | Implements IInstrumentable (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | LastCatastrophy | Latches last problematic msg
Public property | LastError | Latches last problematic msg
Public property | LastWarning | Latches last problematic msg
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Now | Returns localized log time
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
LogServiceBase Class
NFX.Log Namespace


LogServiceBase Constructor

LogServiceBase Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | LogServiceBase | Creates a new logging service instance
Protected method | LogServiceBase(Service) | Creates a new logging service instance
Back to Top
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase Constructor

LogServiceBase Constructor NFX Class Library

Creates a new logging service instance

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected LogServiceBase()
protected LogServiceBase()
Protected Sub New
Protected Sub New
protected:
LogServiceBase()
protected:
LogServiceBase()
new : unit -> LogServiceBase
new : unit -> LogServiceBase
See Also
LogServiceBase Class
LogServiceBase Members
LogServiceBase Overload
NFX.Log Namespace


LogServiceBase Constructor (Service)

LogServiceBase Constructor (Service) NFX Class Library

Creates a new logging service instance

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected LogServiceBase(
    Service director = null
)
protected LogServiceBase(
    Service director = null
)
Protected Sub New (
    Optional director As Service = Nothing
)
Protected Sub New (
    Optional director As Service = Nothing
)
protected:
LogServiceBase(
    Service^ director = nullptr
)
protected:
LogServiceBase(
    Service^ director = nullptr
)
new :
        ?director : Service
(* Defaults:
        let _director = defaultArg director null
*)
-> LogServiceBase
new :
        ?director : Service
(* Defaults:
        let _director = defaultArg director null
*)
-> LogServiceBase

Parameters

director (Optional)
Type: NFX.ServiceModel Service
See Also
LogServiceBase Class
LogServiceBase Members
LogServiceBase Overload
NFX.Log Namespace


LogServiceBase Fields

LogServiceBase Fields NFX Class Library

The LogServiceBase type exposes the following members.
Fields
 | Name | Description
 | CONFIG_DEFAULT_FAILOVER_ATTR |
 | CONFIG_DESTINATION_SECTION |
Protected field | m_Destinations |
Protected field | m_InstrumentationEnabled |
Back to Top
See Also
LogServiceBase Class
NFX.Log Namespace


LogServiceBase.CONFIG_DEFAULT_FAILOVER_ATTR Field

LogServiceBase CONFIG_DEFAULT_FAILOVER_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal const string CONFIG_DEFAULT_FAILOVER_ATTR
internal const string CONFIG_DEFAULT_FAILOVER_ATTR
Friend Const CONFIG_DEFAULT_FAILOVER_ATTR As String
Friend Const CONFIG_DEFAULT_FAILOVER_ATTR As String
internal:
literal String^ CONFIG_DEFAULT_FAILOVER_ATTR
internal:
literal String^ CONFIG_DEFAULT_FAILOVER_ATTR
static val mutable internal CONFIG_DEFAULT_FAILOVER_ATTR: string
static val mutable internal CONFIG_DEFAULT_FAILOVER_ATTR: string

Field Value

Type: Online String
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase.CONFIG_DESTINATION_SECTION Field

LogServiceBase CONFIG_DESTINATION_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal const string CONFIG_DESTINATION_SECTION
internal const string CONFIG_DESTINATION_SECTION
Friend Const CONFIG_DESTINATION_SECTION As String
Friend Const CONFIG_DESTINATION_SECTION As String
internal:
literal String^ CONFIG_DESTINATION_SECTION
internal:
literal String^ CONFIG_DESTINATION_SECTION
static val mutable internal CONFIG_DESTINATION_SECTION: string
static val mutable internal CONFIG_DESTINATION_SECTION: string

Field Value

Type: Online String
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase.m_Destinations Field

LogServiceBase m_Destinations Field NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected LogServiceBase..::..DestinationList m_Destinations
protected LogServiceBase..::..DestinationList m_Destinations
Protected m_Destinations As LogServiceBase..::..DestinationList
Protected m_Destinations As LogServiceBase..::..DestinationList
protected:
LogServiceBase..::..DestinationList^ m_Destinations
protected:
LogServiceBase..::..DestinationList^ m_Destinations
val mutable m_Destinations: LogServiceBase..::..DestinationList
val mutable m_Destinations: LogServiceBase..::..DestinationList

Field Value

Type: LogServiceBase DestinationList
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase.m_InstrumentationEnabled Field

LogServiceBase m_InstrumentationEnabled Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected bool m_InstrumentationEnabled
protected bool m_InstrumentationEnabled
Protected m_InstrumentationEnabled As Boolean
Protected m_InstrumentationEnabled As Boolean
protected:
bool m_InstrumentationEnabled
protected:
bool m_InstrumentationEnabled
val mutable m_InstrumentationEnabled: bool
val mutable m_InstrumentationEnabled: bool

Field Value

Type: Online Boolean
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase Methods

LogServiceBase Methods NFX Class Library

The LogServiceBase type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Overrides Service Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Protected method | DoWrite | Writes log message into log
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | FailoverDestination | When error=null => error cleared. When msg==null => exceptions surfaced from DoPulse()
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetInstrumentationBuffer | Returns instrumentation buffer if instrumentation enabled
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Pulse |
Public method | RegisterDestination | Adds a destination to this service active destinations. Negative index to append
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | UnRegisterDestination | Removes a destiantion from this service active destinations, returns true if destination was found and removed
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Public method | Write(Message) | Writes log message into log
Public method | Write(Message, Boolean) | Writes log message into log
Public method | Write(MessageType, String, String, String) | Writes log message into log
Public method | Write(MessageType, String, Boolean, String, String) | Writes log message into log
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LogServiceBase Class
NFX.Log Namespace


LogServiceBase.Destructor Method

LogServiceBase Destructor Method NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase.DoConfigure Method

LogServiceBase DoConfigure Method NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase.DoStart Method

LogServiceBase DoStart Method NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase.DoWaitForCompleteStop Method

LogServiceBase DoWaitForCompleteStop Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase.DoWrite Method

LogServiceBase DoWrite Method NFX Class Library

Writes log message into log

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void DoWrite(
    Message msg,
    bool urgent
)
protected abstract void DoWrite(
    Message msg,
    bool urgent
)
Protected MustOverride Sub DoWrite (
    msg As Message,
    urgent As Boolean
)
Protected MustOverride Sub DoWrite (
    msg As Message,
    urgent As Boolean
)
protected:
virtual void DoWrite(
    Message^ msg,
    bool urgent
) abstract
protected:
virtual void DoWrite(
    Message^ msg,
    bool urgent
) abstract
abstract DoWrite :
        msg : Message *
        urgent : bool -> unit
abstract DoWrite :
        msg : Message *
        urgent : bool -> unit

Parameters

msg
Type: NFX.Log Message
Message to write
urgent
Type: Online System Boolean
Indicates that the logging service implementation must make an effort to write the message to its destinations urgently
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase.FailoverDestination Method

LogServiceBase FailoverDestination Method NFX Class Library

When error=null => error cleared. When msg==null => exceptions surfaced from DoPulse()

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void FailoverDestination(
    Destination destination,
    Exception error,
    Message msg
)
internal void FailoverDestination(
    Destination destination,
    Exception error,
    Message msg
)
Friend Sub FailoverDestination (
    destination As Destination,
    error As Exception,
    msg As Message
)
Friend Sub FailoverDestination (
    destination As Destination,
    error As Exception,
    msg As Message
)
internal:
void FailoverDestination(
    Destination^ destination,
    Exception^ error,
    Message^ msg
)
internal:
void FailoverDestination(
    Destination^ destination,
    Exception^ error,
    Message^ msg
)
internal member FailoverDestination :
        destination : Destination *
        error : Exception *
        msg : Message -> unit
internal member FailoverDestination :
        destination : Destination *
        error : Exception *
        msg : Message -> unit

Parameters

destination
Type: NFX.Log.Destinations Destination
error
Type: Online System Exception
msg
Type: NFX.Log Message
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase.GetInstrumentationBuffer Method

LogServiceBase GetInstrumentationBuffer Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns instrumentation buffer if instrumentation enabled

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Message> GetInstrumentationBuffer(
    bool asc
)
public IEnumerable<Message> GetInstrumentationBuffer(
    bool asc
)
Public Function GetInstrumentationBuffer (
    asc As Boolean
) As IEnumerable(Of Message)
Public Function GetInstrumentationBuffer (
    asc As Boolean
) As IEnumerable(Of Message)
public:
IEnumerable<Message^>^ GetInstrumentationBuffer(
    bool asc
)
public:
IEnumerable<Message^>^ GetInstrumentationBuffer(
    bool asc
)
member GetInstrumentationBuffer :
        asc : bool -> IEnumerable<Message>
member GetInstrumentationBuffer :
        asc : bool -> IEnumerable<Message>

Parameters

asc
Type: Online System Boolean

Return Value

Type: Online IEnumerable Message
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase.Pulse Method

LogServiceBase Pulse Method NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void Pulse()
protected void Pulse()
Protected Sub Pulse
Protected Sub Pulse
protected:
void Pulse()
protected:
void Pulse()
member Pulse : unit -> unit
member Pulse : unit -> unit
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase.RegisterDestination Method

LogServiceBase RegisterDestination Method NFX Class Library

Adds a destination to this service active destinations. Negative index to append

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RegisterDestination(
    Destination dest,
    int atIdx = -1
)
public void RegisterDestination(
    Destination dest,
    int atIdx = -1
)
Public Sub RegisterDestination (
    dest As Destination,
    Optional atIdx As Integer = -1
)
Public Sub RegisterDestination (
    dest As Destination,
    Optional atIdx As Integer = -1
)
public:
void RegisterDestination(
    Destination^ dest,
    int atIdx = -1
)
public:
void RegisterDestination(
    Destination^ dest,
    int atIdx = -1
)
member RegisterDestination :
        dest : Destination *
        ?atIdx : int
(* Defaults:
        let _atIdx = defaultArg atIdx -1
*)
-> unit
member RegisterDestination :
        dest : Destination *
        ?atIdx : int
(* Defaults:
        let _atIdx = defaultArg atIdx -1
*)
-> unit

Parameters

dest
Type: NFX.Log.Destinations Destination
atIdx (Optional)
Type: Online System Int32
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase.UnRegisterDestination Method

LogServiceBase UnRegisterDestination Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Removes a destiantion from this service active destinations, returns true if destination was found and removed

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool UnRegisterDestination(
    Destination dest
)
public bool UnRegisterDestination(
    Destination dest
)
Public Function UnRegisterDestination (
    dest As Destination
) As Boolean
Public Function UnRegisterDestination (
    dest As Destination
) As Boolean
public:
bool UnRegisterDestination(
    Destination^ dest
)
public:
bool UnRegisterDestination(
    Destination^ dest
)
member UnRegisterDestination :
        dest : Destination -> bool
member UnRegisterDestination :
        dest : Destination -> bool

Parameters

dest
Type: NFX.Log.Destinations Destination

Return Value

Type: Online Boolean
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase.Write Method

LogServiceBase Write Method NFX Class Library

Overload List
 | Name | Description
Public method | Write(Message) | Writes log message into log
Public method | Write(Message, Boolean) | Writes log message into log
Public method | Write(MessageType, String, String, String) | Writes log message into log
Public method | Write(MessageType, String, Boolean, String, String) | Writes log message into log
Back to Top
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase.Write Method (Message)

LogServiceBase Write Method (Message) NFX Class Library

Writes log message into log

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Write(
    Message msg
)
public void Write(
    Message msg
)
Public Sub Write (
    msg As Message
)
Public Sub Write (
    msg As Message
)
public:
virtual void Write(
    Message^ msg
) sealed
public:
virtual void Write(
    Message^ msg
) sealed
abstract Write :
        msg : Message -> unit
override Write :
        msg : Message -> unit
abstract Write :
        msg : Message -> unit
override Write :
        msg : Message -> unit

Parameters

msg
Type: NFX.Log Message
Message to write

Implements

ILog Write(Message)
See Also
LogServiceBase Class
LogServiceBase Members
Write Overload
NFX.Log Namespace


LogServiceBase.Write Method (Message, Boolean)

LogServiceBase Write Method (Message, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes log message into log

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Write(
    Message msg,
    bool urgent
)
public void Write(
    Message msg,
    bool urgent
)
Public Sub Write (
    msg As Message,
    urgent As Boolean
)
Public Sub Write (
    msg As Message,
    urgent As Boolean
)
public:
virtual void Write(
    Message^ msg,
    bool urgent
) sealed
public:
virtual void Write(
    Message^ msg,
    bool urgent
) sealed
abstract Write :
        msg : Message *
        urgent : bool -> unit
override Write :
        msg : Message *
        urgent : bool -> unit
abstract Write :
        msg : Message *
        urgent : bool -> unit
override Write :
        msg : Message *
        urgent : bool -> unit

Parameters

msg
Type: NFX.Log Message
Message to write
urgent
Type: Online System Boolean
Indicates that the logging service implementation must make an effort to write the message to its destinations urgently

Implements

ILog Write(Message, Boolean)
See Also
LogServiceBase Class
LogServiceBase Members
Write Overload
NFX.Log Namespace


LogServiceBase.Write Method (MessageType, String, String, String)

LogServiceBase Write Method (MessageType, String, String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes log message into log

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Write(
    MessageType type,
    string text,
    string topic = null,
    string from = null
)
public void Write(
    MessageType type,
    string text,
    string topic = null,
    string from = null
)
Public Sub Write (
    type As MessageType,
    text As String,
    Optional topic As String = Nothing,
    Optional from As String = Nothing
)
Public Sub Write (
    type As MessageType,
    text As String,
    Optional topic As String = Nothing,
    Optional from As String = Nothing
)
public:
virtual void Write(
    MessageType type,
    String^ text,
    String^ topic = nullptr,
    String^ from = nullptr
) sealed
public:
virtual void Write(
    MessageType type,
    String^ text,
    String^ topic = nullptr,
    String^ from = nullptr
) sealed
abstract Write :
        type : MessageType *
        text : string *
        ?topic : string *
        ?from : string
(* Defaults:
        let _topic = defaultArg topic null
        let _from = defaultArg from null
*)
-> unit
override Write :
        type : MessageType *
        text : string *
        ?topic : string *
        ?from : string
(* Defaults:
        let _topic = defaultArg topic null
        let _from = defaultArg from null
*)
-> unit
abstract Write :
        type : MessageType *
        text : string *
        ?topic : string *
        ?from : string
(* Defaults:
        let _topic = defaultArg topic null
        let _from = defaultArg from null
*)
-> unit
override Write :
        type : MessageType *
        text : string *
        ?topic : string *
        ?from : string
(* Defaults:
        let _topic = defaultArg topic null
        let _from = defaultArg from null
*)
-> unit

Parameters

type
Type: NFX.Log MessageType
text
Type: Online System String
topic (Optional)
Type: Online System String
from (Optional)
Type: Online System String

Implements

ILog Write(MessageType, String, String, String)
See Also
LogServiceBase Class
LogServiceBase Members
Write Overload
NFX.Log Namespace


LogServiceBase.Write Method (MessageType, String, Boolean, String, String)

LogServiceBase Write Method (MessageType, String, Boolean, String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes log message into log

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Write(
    MessageType type,
    string text,
    bool urgent,
    string topic = null,
    string from = null
)
public void Write(
    MessageType type,
    string text,
    bool urgent,
    string topic = null,
    string from = null
)
Public Sub Write (
    type As MessageType,
    text As String,
    urgent As Boolean,
    Optional topic As String = Nothing,
    Optional from As String = Nothing
)
Public Sub Write (
    type As MessageType,
    text As String,
    urgent As Boolean,
    Optional topic As String = Nothing,
    Optional from As String = Nothing
)
public:
virtual void Write(
    MessageType type,
    String^ text,
    bool urgent,
    String^ topic = nullptr,
    String^ from = nullptr
) sealed
public:
virtual void Write(
    MessageType type,
    String^ text,
    bool urgent,
    String^ topic = nullptr,
    String^ from = nullptr
) sealed
abstract Write :
        type : MessageType *
        text : string *
        urgent : bool *
        ?topic : string *
        ?from : string
(* Defaults:
        let _topic = defaultArg topic null
        let _from = defaultArg from null
*)
-> unit
override Write :
        type : MessageType *
        text : string *
        urgent : bool *
        ?topic : string *
        ?from : string
(* Defaults:
        let _topic = defaultArg topic null
        let _from = defaultArg from null
*)
-> unit
abstract Write :
        type : MessageType *
        text : string *
        urgent : bool *
        ?topic : string *
        ?from : string
(* Defaults:
        let _topic = defaultArg topic null
        let _from = defaultArg from null
*)
-> unit
override Write :
        type : MessageType *
        text : string *
        urgent : bool *
        ?topic : string *
        ?from : string
(* Defaults:
        let _topic = defaultArg topic null
        let _from = defaultArg from null
*)
-> unit

Parameters

type
Type: NFX.Log MessageType
text
Type: Online System String
urgent
Type: Online System Boolean
topic (Optional)
Type: Online System String
from (Optional)
Type: Online System String

Implements

ILog Write(MessageType, String, Boolean, String, String)
See Also
LogServiceBase Class
LogServiceBase Members
Write Overload
NFX.Log Namespace


LogServiceBase Properties

LogServiceBase Properties NFX Class Library

The LogServiceBase type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | (Overrides ApplicationComponent ComponentCommonName.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DefaultFailover | Sets destination name used for failover on the service-level if particular failing destination did not specify its specific failover
Public property | Destinations | Returns registered destinations. This call is thread safe
Public property | DestinationsAreOptional | Indicates whether the service can operate without any destinations registered, i.e. some test loggers may not need any destinations to operate as they synchronously write to some buffer without any extra destinations
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | FailoverError | Returns last exception that happened during failover. This kind of exceptions is never propagated and always handled
Public property | FailoverErrorDestination | Returns a destination that threw last exception that happened durng failover. This kind of exceptions is never propagated and always handled
Public property | InstrumentationBufferSize |
Public property | InstrumentationEnabled | Implements IInstrumentable (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | LastCatastrophy | Latches last problematic msg
Public property | LastError | Latches last problematic msg
Public property | LastWarning | Latches last problematic msg
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Now | Returns localized log time
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
LogServiceBase Class
NFX.Log Namespace


LogServiceBase.ComponentCommonName Property

LogServiceBase ComponentCommonName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ComponentCommonName { get; }
public override string ComponentCommonName { get; }
Public Overrides ReadOnly Property ComponentCommonName As String
    Get
Public Overrides ReadOnly Property ComponentCommonName As String
    Get
public:
virtual property String^ ComponentCommonName {
    String^ get () override;
}
public:
virtual property String^ ComponentCommonName {
    String^ get () override;
}
abstract ComponentCommonName : string with get
override ComponentCommonName : string with get
abstract ComponentCommonName : string with get
override ComponentCommonName : string with get

Property Value

Type: Online String

Implements

IApplicationComponent ComponentCommonName
IApplicationComponent ComponentCommonName
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase.DefaultFailover Property

LogServiceBase DefaultFailover Property NFX Class Library

Sets destination name used for failover on the service-level if particular failing destination did not specify its specific failover

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute("$default-failover")]
public string DefaultFailover { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute("$default-failover")]
public string DefaultFailover { get; set; }
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute("$default-failover")>
Public Property DefaultFailover As String
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute("$default-failover")>
Public Property DefaultFailover As String
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(L"$default-failover")]
property String^ DefaultFailover {
    String^ get ();
    void set (String^ value);
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(L"$default-failover")]
property String^ DefaultFailover {
    String^ get ();
    void set (String^ value);
}
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute("$default-failover")>]
member DefaultFailover : string with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute("$default-failover")>]
member DefaultFailover : string with get, set

Property Value

Type: Online String
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase.Destinations Property

LogServiceBase Destinations Property NFX Class Library

Returns registered destinations. This call is thread safe

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Destination> Destinations { get; }
public IEnumerable<Destination> Destinations { get; }
Public ReadOnly Property Destinations As IEnumerable(Of Destination)
    Get
Public ReadOnly Property Destinations As IEnumerable(Of Destination)
    Get
public:
property IEnumerable<Destination^>^ Destinations {
    IEnumerable<Destination^>^ get ();
}
public:
property IEnumerable<Destination^>^ Destinations {
    IEnumerable<Destination^>^ get ();
}
member Destinations : IEnumerable<Destination> with get
member Destinations : IEnumerable<Destination> with get

Property Value

Type: Online IEnumerable Destination
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase.DestinationsAreOptional Property

LogServiceBase DestinationsAreOptional Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Indicates whether the service can operate without any destinations registered, i.e. some test loggers may not need any destinations to operate as they synchronously write to some buffer without any extra destinations

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool DestinationsAreOptional { get; }
public virtual bool DestinationsAreOptional { get; }
Public Overridable ReadOnly Property DestinationsAreOptional As Boolean
    Get
Public Overridable ReadOnly Property DestinationsAreOptional As Boolean
    Get
public:
virtual property bool DestinationsAreOptional {
    bool get ();
}
public:
virtual property bool DestinationsAreOptional {
    bool get ();
}
abstract DestinationsAreOptional : bool with get
override DestinationsAreOptional : bool with get
abstract DestinationsAreOptional : bool with get
override DestinationsAreOptional : bool with get

Property Value

Type: Online Boolean
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase.FailoverError Property

LogServiceBase FailoverError Property NFX Class Library

Returns last exception that happened during failover. This kind of exceptions is never propagated and always handled

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Exception FailoverError { get; }
public Exception FailoverError { get; }
Public ReadOnly Property FailoverError As Exception
    Get
Public ReadOnly Property FailoverError As Exception
    Get
public:
property Exception^ FailoverError {
    Exception^ get ();
}
public:
property Exception^ FailoverError {
    Exception^ get ();
}
member FailoverError : Exception with get
member FailoverError : Exception with get

Property Value

Type: Online Exception
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase.FailoverErrorDestination Property

LogServiceBase FailoverErrorDestination Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns a destination that threw last exception that happened durng failover. This kind of exceptions is never propagated and always handled

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Destination FailoverErrorDestination { get; }
public Destination FailoverErrorDestination { get; }
Public ReadOnly Property FailoverErrorDestination As Destination
    Get
Public ReadOnly Property FailoverErrorDestination As Destination
    Get
public:
property Destination^ FailoverErrorDestination {
    Destination^ get ();
}
public:
property Destination^ FailoverErrorDestination {
    Destination^ get ();
}
member FailoverErrorDestination : Destination with get
member FailoverErrorDestination : Destination with get

Property Value

Type: Destination
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase.InstrumentationBufferSize Property

LogServiceBase InstrumentationBufferSize Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public int InstrumentationBufferSize { get; set; }
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public int InstrumentationBufferSize { get; set; }
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property InstrumentationBufferSize As Integer
    Get
    Set
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property InstrumentationBufferSize As Integer
    Get
    Set
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property int InstrumentationBufferSize {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property int InstrumentationBufferSize {
    int get ();
    void set (int value);
}
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
member InstrumentationBufferSize : int with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
member InstrumentationBufferSize : int with get, set

Property Value

Type: Online Int32
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase.InstrumentationEnabled Property

LogServiceBase InstrumentationEnabled Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Implements IInstrumentable

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute(Default = false)]
public override bool InstrumentationEnabled { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute(Default = false)]
public override bool InstrumentationEnabled { get; set; }
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute(Default := false)>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute(Default := false)>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(Default = false)]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(Default = false)]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
abstract InstrumentationEnabled : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
override InstrumentationEnabled : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
abstract InstrumentationEnabled : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
override InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentable InstrumentationEnabled
IInstrumentable InstrumentationEnabled
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase.LastCatastrophy Property

LogServiceBase LastCatastrophy Property NFX Class Library

Latches last problematic msg

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Message LastCatastrophy { get; }
public Message LastCatastrophy { get; }
Public ReadOnly Property LastCatastrophy As Message
    Get
Public ReadOnly Property LastCatastrophy As Message
    Get
public:
virtual property Message^ LastCatastrophy {
    Message^ get () sealed;
}
public:
virtual property Message^ LastCatastrophy {
    Message^ get () sealed;
}
abstract LastCatastrophy : Message with get
override LastCatastrophy : Message with get
abstract LastCatastrophy : Message with get
override LastCatastrophy : Message with get

Property Value

Type: Message

Implements

ILog LastCatastrophy
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase.LastError Property

LogServiceBase LastError Property NFX Class Library

Latches last problematic msg

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Message LastError { get; }
public Message LastError { get; }
Public ReadOnly Property LastError As Message
    Get
Public ReadOnly Property LastError As Message
    Get
public:
virtual property Message^ LastError {
    Message^ get () sealed;
}
public:
virtual property Message^ LastError {
    Message^ get () sealed;
}
abstract LastError : Message with get
override LastError : Message with get
abstract LastError : Message with get
override LastError : Message with get

Property Value

Type: Message

Implements

ILog LastError
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase.LastWarning Property

LogServiceBase LastWarning Property NFX Class Library

Latches last problematic msg

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Message LastWarning { get; }
public Message LastWarning { get; }
Public ReadOnly Property LastWarning As Message
    Get
Public ReadOnly Property LastWarning As Message
    Get
public:
virtual property Message^ LastWarning {
    Message^ get () sealed;
}
public:
virtual property Message^ LastWarning {
    Message^ get () sealed;
}
abstract LastWarning : Message with get
override LastWarning : Message with get
abstract LastWarning : Message with get
override LastWarning : Message with get

Property Value

Type: Message

Implements

ILog LastWarning
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase.Now Property

LogServiceBase Now Property NFX Class Library

Returns localized log time

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime Now { get; }
public DateTime Now { get; }
Public ReadOnly Property Now As DateTime
    Get
Public ReadOnly Property Now As DateTime
    Get
public:
property DateTime Now {
    DateTime get ();
}
public:
property DateTime Now {
    DateTime get ();
}
member Now : DateTime with get
member Now : DateTime with get

Property Value

Type: Online DateTime
See Also
LogServiceBase Class
LogServiceBase Members
NFX.Log Namespace


LogServiceBase.DestinationList Class

LogServiceBase DestinationList Class NFX Class Library

Inheritance Hierarchy
Online System Object
Online System.Collections.Generic List Destination
NFX.Log LogServiceBase DestinationList

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class DestinationList : List<Destination>
public class DestinationList : List<Destination>
Public Class DestinationList
    Inherits List(Of Destination)
Public Class DestinationList
    Inherits List(Of Destination)
public ref class DestinationList : public List<Destination^>
public ref class DestinationList : public List<Destination^>
type DestinationList =
    class
        inherit List<Destination>
    end
type DestinationList =
    class
        inherit List<Destination>
    end
See Also
LogServiceBase DestinationList Members
NFX.Log Namespace


LogServiceBase.DestinationList Members

LogServiceBase DestinationList Members NFX Class Library

The LogServiceBase DestinationList type exposes the following members.
Constructors
 | Name | Description
Public method | LogServiceBase DestinationList | Initializes a new instance of the LogServiceBase DestinationList class
Back to Top
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List Destination .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List Destination .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List Destination .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List Destination .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Destination .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Destination .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List Destination .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List Destination .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List Destination .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List Destination .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Destination .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Destination .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List Destination .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List Destination .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Destination .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Destination .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Destination .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Destination .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List Destination .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Destination .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Destination .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Destination .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List Destination .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List Destination .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List Destination .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Destination .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Destination .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Destination .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List Destination .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List Destination .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Destination .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Destination .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Destination .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List Destination .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Destination .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List Destination .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List Destination .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List Destination .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List Destination .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List Destination .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List Destination .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List Destination .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List Destination .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List Destination .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List Destination .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List Destination .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List Destination .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List Destination .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List Destination .)
Back to Top
See Also
LogServiceBase DestinationList Class
NFX.Log Namespace


LogServiceBase.DestinationList Constructor

LogServiceBase DestinationList Constructor NFX Class Library

Initializes a new instance of the LogServiceBase DestinationList class

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DestinationList()
public DestinationList()
Public Sub New
Public Sub New
public:
DestinationList()
public:
DestinationList()
new : unit -> DestinationList
new : unit -> DestinationList
See Also
LogServiceBase DestinationList Class
LogServiceBase DestinationList Members
NFX.Log Namespace


LogServiceBase.DestinationList Methods

LogServiceBase DestinationList Methods NFX Class Library

The LogServiceBase DestinationList type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List Destination .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List Destination .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List Destination .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List Destination .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Destination .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Destination .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List Destination .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List Destination .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List Destination .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List Destination .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Destination .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Destination .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List Destination .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List Destination .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Destination .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Destination .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Destination .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Destination .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List Destination .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Destination .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Destination .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Destination .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List Destination .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List Destination .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List Destination .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Destination .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Destination .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Destination .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List Destination .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List Destination .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Destination .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Destination .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Destination .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List Destination .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Destination .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List Destination .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List Destination .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List Destination .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List Destination .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List Destination .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List Destination .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List Destination .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List Destination .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List Destination .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List Destination .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List Destination .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LogServiceBase DestinationList Class
NFX.Log Namespace


LogServiceBase.DestinationList Properties

LogServiceBase DestinationList Properties NFX Class Library

The LogServiceBase DestinationList type exposes the following members.
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List Destination .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List Destination .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List Destination .)
Back to Top
See Also
LogServiceBase DestinationList Class
NFX.Log Namespace


Message Class

Message Class NFX Class Library

Represents a Log message
Inheritance Hierarchy
Online System Object
NFX.Log Message

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class Message
[SerializableAttribute]
public sealed class Message
<SerializableAttribute>
Public NotInheritable Class Message
<SerializableAttribute>
Public NotInheritable Class Message
[SerializableAttribute]
public ref class Message sealed
[SerializableAttribute]
public ref class Message sealed
[<SealedAttribute>]
[<SerializableAttribute>]
type Message =  class end
[<SealedAttribute>]
[<SerializableAttribute>]
type Message =  class end
See Also
Message Members
NFX.Log Namespace


Message Members

Message Members NFX Class Library

The Message type exposes the following members.
Constructors
 | Name | Description
Public method | Message | Initializes a new instance of the Message class
Public method | Message(Object, String, Int32) | Creates message with Parameters supplanted with caller file name and line #
Back to Top
Methods
 | Name | Description
Public method | Clone |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | FormatCallerParams | Supplants the from string with caller as JSON string
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetParamsAsObject |
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
DefaultHostName |
Back to Top
Properties
 | Name | Description
Public property | Exception | Gets/Sets exception associated with message. Set this property EVEN IF the name/text of exception is already included in Text as log destinations may elect to dump the whole stack trace
Public property | From | Gets/Sets logical component ID, such as: class name, method name, process instance, that generated the message. This field is used in the scope of Topic
Public property | Guid | Returns global unique identifier for this particular message
Public property | Host | Gets/Sets host name that generated the message
Public property | Parameters | Gets/Sets a structured parameter bag, this may be used for additional debug info like source file name, additional context etc.
Public property | RelatedTo | Gets/Sets global unique identifier of a message that this message is related to. No referential integrity check is performed
Public property | Source | Gets/Sets message source line number/tracepoint#, this is used in conjunction with From
Public property | Text | Gets/Sets an unstructured message text, the emitting component name must be in From field, not in text. Note about logging errors. Use caught exception.ToMessageWithType() method, then attach the caught exception as Exception property
Public property | TimeStamp | Gets/Sets timestamp when message was generated
Public property | Topic | Gets/Sets a message topic/relation - the name of software concern within the big app, i.e. "Database" or "Security"
Public property | Type | Gets/Sets message type, such as: Info/Warning/Error etc...
Back to Top
See Also
Message Class
NFX.Log Namespace


Message Constructor

Message Constructor NFX Class Library

Overload List
 | Name | Description
Public method | Message | Initializes a new instance of the Message class
Public method | Message(Object, String, Int32) | Creates message with Parameters supplanted with caller file name and line #
Back to Top
See Also
Message Class
Message Members
NFX.Log Namespace


Message Constructor

Message Constructor NFX Class Library

Initializes a new instance of the Message class

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Message()
public Message()
Public Sub New
Public Sub New
public:
Message()
public:
Message()
new : unit -> Message
new : unit -> Message
See Also
Message Class
Message Members
Message Overload
NFX.Log Namespace


Message Constructor (Object, String, Int32)

Message Constructor (Object, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates message with Parameters supplanted with caller file name and line #

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Message(
    Object pars,
    string file = null,
    int line = 0
)
public Message(
    Object pars,
    string file = null,
    int line = 0
)
Public Sub New (
    pars As Object,
    Optional file As String = Nothing,
    Optional line As Integer = 0
)
Public Sub New (
    pars As Object,
    Optional file As String = Nothing,
    Optional line As Integer = 0
)
public:
Message(
    Object^ pars,
    String^ file = nullptr,
    int line = 0
)
public:
Message(
    Object^ pars,
    String^ file = nullptr,
    int line = 0
)
new :
        pars : Object *
        ?file : string *
        ?line : int
(* Defaults:
        let _file = defaultArg file null
        let _line = defaultArg line 0
*)
-> Message
new :
        pars : Object *
        ?file : string *
        ?line : int
(* Defaults:
        let _file = defaultArg file null
        let _line = defaultArg line 0
*)
-> Message

Parameters

pars
Type: Online System Object
file (Optional)
Type: Online System String
line (Optional)
Type: Online System Int32
See Also
Message Class
Message Members
Message Overload
NFX.Log Namespace


Message Fields

Message Fields NFX Class Library

The Message type exposes the following members.
Fields
Name | Description
DefaultHostName |
Back to Top
See Also
Message Class
NFX.Log Namespace


Message.DefaultHostName Field

Message DefaultHostName Field NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string DefaultHostName
public static string DefaultHostName
Public Shared DefaultHostName As String
Public Shared DefaultHostName As String
public:
static String^ DefaultHostName
public:
static String^ DefaultHostName
static val mutable DefaultHostName: string
static val mutable DefaultHostName: string

Field Value

Type: Online String
See Also
Message Class
Message Members
NFX.Log Namespace


Message Methods

Message Methods NFX Class Library

The Message type exposes the following members.
Methods
 | Name | Description
Public method | Clone |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | FormatCallerParams | Supplants the from string with caller as JSON string
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetParamsAsObject |
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Message Class
NFX.Log Namespace


Message.Clone Method

Message Clone Method NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Message Clone()
public Message Clone()
Public Function Clone As Message
Public Function Clone As Message
public:
Message^ Clone()
public:
Message^ Clone()
member Clone : unit -> Message
member Clone : unit -> Message

Return Value

Type: Message
See Also
Message Class
Message Members
NFX.Log Namespace


Message.FormatCallerParams Method

Message FormatCallerParams Method NFX Class Library

Supplants the from string with caller as JSON string

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Object FormatCallerParams(
    Object pars,
    string file = null,
    int line = 0
)
public static Object FormatCallerParams(
    Object pars,
    string file = null,
    int line = 0
)
Public Shared Function FormatCallerParams (
    pars As Object,
    Optional file As String = Nothing,
    Optional line As Integer = 0
) As Object
Public Shared Function FormatCallerParams (
    pars As Object,
    Optional file As String = Nothing,
    Optional line As Integer = 0
) As Object
public:
static Object^ FormatCallerParams(
    Object^ pars,
    String^ file = nullptr,
    int line = 0
)
public:
static Object^ FormatCallerParams(
    Object^ pars,
    String^ file = nullptr,
    int line = 0
)
static member FormatCallerParams :
        pars : Object *
        ?file : string *
        ?line : int
(* Defaults:
        let _file = defaultArg file null
        let _line = defaultArg line 0
*)
-> Object
static member FormatCallerParams :
        pars : Object *
        ?file : string *
        ?line : int
(* Defaults:
        let _file = defaultArg file null
        let _line = defaultArg line 0
*)
-> Object

Parameters

pars
Type: Online System Object
file (Optional)
Type: Online System String
line (Optional)
Type: Online System Int32

Return Value

Type: Online Object
See Also
Message Class
Message Members
NFX.Log Namespace


Message.SetParamsAsObject Method

Message SetParamsAsObject Method NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Message SetParamsAsObject(
    Object p
)
public Message SetParamsAsObject(
    Object p
)
Public Function SetParamsAsObject (
    p As Object
) As Message
Public Function SetParamsAsObject (
    p As Object
) As Message
public:
Message^ SetParamsAsObject(
    Object^ p
)
public:
Message^ SetParamsAsObject(
    Object^ p
)
member SetParamsAsObject :
        p : Object -> Message
member SetParamsAsObject :
        p : Object -> Message

Parameters

p
Type: Online System Object

Return Value

Type: Message
See Also
Message Class
Message Members
NFX.Log Namespace


Message.ToString Method

Message ToString Method NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
Message Class
Message Members
NFX.Log Namespace


Message Properties

Message Properties NFX Class Library

The Message type exposes the following members.
Properties
 | Name | Description
Public property | Exception | Gets/Sets exception associated with message. Set this property EVEN IF the name/text of exception is already included in Text as log destinations may elect to dump the whole stack trace
Public property | From | Gets/Sets logical component ID, such as: class name, method name, process instance, that generated the message. This field is used in the scope of Topic
Public property | Guid | Returns global unique identifier for this particular message
Public property | Host | Gets/Sets host name that generated the message
Public property | Parameters | Gets/Sets a structured parameter bag, this may be used for additional debug info like source file name, additional context etc.
Public property | RelatedTo | Gets/Sets global unique identifier of a message that this message is related to. No referential integrity check is performed
Public property | Source | Gets/Sets message source line number/tracepoint#, this is used in conjunction with From
Public property | Text | Gets/Sets an unstructured message text, the emitting component name must be in From field, not in text. Note about logging errors. Use caught exception.ToMessageWithType() method, then attach the caught exception as Exception property
Public property | TimeStamp | Gets/Sets timestamp when message was generated
Public property | Topic | Gets/Sets a message topic/relation - the name of software concern within the big app, i.e. "Database" or "Security"
Public property | Type | Gets/Sets message type, such as: Info/Warning/Error etc...
Back to Top
See Also
Message Class
NFX.Log Namespace


Message.Exception Property

Message Exception Property NFX Class Library

Gets/Sets exception associated with message. Set this property EVEN IF the name/text of exception is already included in Text as log destinations may elect to dump the whole stack trace

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Exception Exception { get; set; }
public Exception Exception { get; set; }
Public Property Exception As Exception
    Get
    Set
Public Property Exception As Exception
    Get
    Set
public:
property Exception^ Exception {
    Exception^ get ();
    void set (Exception^ value);
}
public:
property Exception^ Exception {
    Exception^ get ();
    void set (Exception^ value);
}
member Exception : Exception with get, set
member Exception : Exception with get, set

Property Value

Type: Online Exception
See Also
Message Class
Message Members
NFX.Log Namespace


Message.From Property

Message From Property NFX Class Library

Gets/Sets logical component ID, such as: class name, method name, process instance, that generated the message. This field is used in the scope of Topic

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string From { get; set; }
public string From { get; set; }
Public Property From As String
    Get
    Set
Public Property From As String
    Get
    Set
public:
property String^ From {
    String^ get ();
    void set (String^ value);
}
public:
property String^ From {
    String^ get ();
    void set (String^ value);
}
member From : string with get, set
member From : string with get, set

Property Value

Type: Online String
See Also
Message Class
Message Members
NFX.Log Namespace


Message.Guid Property

Message Guid Property NFX Class Library

Returns global unique identifier for this particular message

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid Guid { get; }
public Guid Guid { get; }
Public ReadOnly Property Guid As Guid
    Get
Public ReadOnly Property Guid As Guid
    Get
public:
property Guid Guid {
    Guid get ();
}
public:
property Guid Guid {
    Guid get ();
}
member Guid : Guid with get
member Guid : Guid with get

Property Value

Type: Online Guid
See Also
Message Class
Message Members
NFX.Log Namespace


Message.Host Property

Message Host Property NFX Class Library

Gets/Sets host name that generated the message

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Host { get; set; }
public string Host { get; set; }
Public Property Host As String
    Get
    Set
Public Property Host As String
    Get
    Set
public:
property String^ Host {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Host {
    String^ get ();
    void set (String^ value);
}
member Host : string with get, set
member Host : string with get, set

Property Value

Type: Online String
See Also
Message Class
Message Members
NFX.Log Namespace


Message.Parameters Property

Message Parameters Property NFX Class Library

Gets/Sets a structured parameter bag, this may be used for additional debug info like source file name, additional context etc.

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Parameters { get; set; }
public string Parameters { get; set; }
Public Property Parameters As String
    Get
    Set
Public Property Parameters As String
    Get
    Set
public:
property String^ Parameters {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Parameters {
    String^ get ();
    void set (String^ value);
}
member Parameters : string with get, set
member Parameters : string with get, set

Property Value

Type: Online String
See Also
Message Class
Message Members
NFX.Log Namespace


Message.RelatedTo Property

Message RelatedTo Property NFX Class Library

Gets/Sets global unique identifier of a message that this message is related to. No referential integrity check is performed

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Guid RelatedTo { get; set; }
public Guid RelatedTo { get; set; }
Public Property RelatedTo As Guid
    Get
    Set
Public Property RelatedTo As Guid
    Get
    Set
public:
property Guid RelatedTo {
    Guid get ();
    void set (Guid value);
}
public:
property Guid RelatedTo {
    Guid get ();
    void set (Guid value);
}
member RelatedTo : Guid with get, set
member RelatedTo : Guid with get, set

Property Value

Type: Online Guid
See Also
Message Class
Message Members
NFX.Log Namespace


Message.Source Property

Message Source Property NFX Class Library

Gets/Sets message source line number/tracepoint#, this is used in conjunction with From

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Source { get; set; }
public int Source { get; set; }
Public Property Source As Integer
    Get
    Set
Public Property Source As Integer
    Get
    Set
public:
property int Source {
    int get ();
    void set (int value);
}
public:
property int Source {
    int get ();
    void set (int value);
}
member Source : int with get, set
member Source : int with get, set

Property Value

Type: Online Int32
See Also
Message Class
Message Members
NFX.Log Namespace


Message.Text Property

Message Text Property NFX Class Library

Gets/Sets an unstructured message text, the emitting component name must be in From field, not in text. Note about logging errors. Use caught exception.ToMessageWithType() method, then attach the caught exception as Exception property

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Text { get; set; }
public string Text { get; set; }
Public Property Text As String
    Get
    Set
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set
member Text : string with get, set

Property Value

Type: Online String
See Also
Message Class
Message Members
NFX.Log Namespace


Message.TimeStamp Property

Message TimeStamp Property NFX Class Library

Gets/Sets timestamp when message was generated

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime TimeStamp { get; set; }
public DateTime TimeStamp { get; set; }
Public Property TimeStamp As DateTime
    Get
    Set
Public Property TimeStamp As DateTime
    Get
    Set
public:
property DateTime TimeStamp {
    DateTime get ();
    void set (DateTime value);
}
public:
property DateTime TimeStamp {
    DateTime get ();
    void set (DateTime value);
}
member TimeStamp : DateTime with get, set
member TimeStamp : DateTime with get, set

Property Value

Type: Online DateTime
See Also
Message Class
Message Members
NFX.Log Namespace


Message.Topic Property

Message Topic Property NFX Class Library

Gets/Sets a message topic/relation - the name of software concern within the big app, i.e. "Database" or "Security"

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Topic { get; set; }
public string Topic { get; set; }
Public Property Topic As String
    Get
    Set
Public Property Topic As String
    Get
    Set
public:
property String^ Topic {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Topic {
    String^ get ();
    void set (String^ value);
}
member Topic : string with get, set
member Topic : string with get, set

Property Value

Type: Online String
See Also
Message Class
Message Members
NFX.Log Namespace


Message.Type Property

Message Type Property NFX Class Library

Gets/Sets message type, such as: Info/Warning/Error etc...

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageType Type { get; set; }
public MessageType Type { get; set; }
Public Property Type As MessageType
    Get
    Set
Public Property Type As MessageType
    Get
    Set
public:
property MessageType Type {
    MessageType get ();
    void set (MessageType value);
}
public:
property MessageType Type {
    MessageType get ();
    void set (MessageType value);
}
member Type : MessageType with get, set
member Type : MessageType with get, set

Property Value

Type: MessageType
See Also
Message Class
Message Members
NFX.Log Namespace


MessageFilterExpression Class

MessageFilterExpression Class NFX Class Library

Defines an expression used for log message filtering. Important: it is not a good practice to create many different scopes as it leads to creation of many assemblies dynamically
Inheritance Hierarchy
Online System Object
NFX.Parsing CompilingExpressionEvaluator Destination, Online Boolean, Message
NFX.Log MessageFilterExpression

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MessageFilterExpression : CompilingExpressionEvaluator<Destination, bool, Message>
public class MessageFilterExpression : CompilingExpressionEvaluator<Destination, bool, Message>
Public Class MessageFilterExpression
    Inherits CompilingExpressionEvaluator(Of Destination, Boolean, Message)
Public Class MessageFilterExpression
    Inherits CompilingExpressionEvaluator(Of Destination, Boolean, Message)
public ref class MessageFilterExpression : public CompilingExpressionEvaluator<Destination^, bool, Message^>
public ref class MessageFilterExpression : public CompilingExpressionEvaluator<Destination^, bool, Message^>
type MessageFilterExpression =
    class
        inherit CompilingExpressionEvaluator<Destination, bool, Message>
    end
type MessageFilterExpression =
    class
        inherit CompilingExpressionEvaluator<Destination, bool, Message>
    end
See Also
MessageFilterExpression Members
NFX.Log Namespace


MessageFilterExpression Members

MessageFilterExpression Members NFX Class Library

The MessageFilterExpression type exposes the following members.
Constructors
 | Name | Description
Public method | MessageFilterExpression(String) | Creates a new expression in a default logging filter scope. This .ctor will fail if at least one expression from this scope has already been compiled
Public method | MessageFilterExpression(String, String, IEnumerable String , IEnumerable String ) | Use this .ctor to specify a different scope name. Every unique scope name gets compiled into a new assembly, consequently it is not a good practice to create many different scopes. This .ctor will fail if at least one expression from this scope has already been compiled
Back to Top
Methods
 | Name | Description
Public method | Compile | Forces the entire scope compilation now, so no delay is incurred on first call to Evaluate(). (Inherited from CompilingExpressionEvaluator TContext, TResult, TArg .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Evaluate | Evaluates expression using supplied arg in a context. Context is passed as "ctx" and argument as "arg". (Inherited from CompilingExpressionEvaluator TContext, TResult, TArg .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
SCOPE |
Back to Top
Properties
 | Name | Description
Public property | Expression | Returns an original expression as string that is to be evaluated (Inherited from CompilingExpressionEvaluator TContext, TResult, TArg .)
Public property | Scope | Returns a scope (similar to compilation unit / assembly) that this expression is in (Inherited from CompilingExpressionEvaluator TContext, TResult, TArg .)
Back to Top
See Also
MessageFilterExpression Class
NFX.Log Namespace


MessageFilterExpression Constructor

MessageFilterExpression Constructor NFX Class Library

Overload List
 | Name | Description
Public method | MessageFilterExpression(String) | Creates a new expression in a default logging filter scope. This .ctor will fail if at least one expression from this scope has already been compiled
Public method | MessageFilterExpression(String, String, IEnumerable String , IEnumerable String ) | Use this .ctor to specify a different scope name. Every unique scope name gets compiled into a new assembly, consequently it is not a good practice to create many different scopes. This .ctor will fail if at least one expression from this scope has already been compiled
Back to Top
See Also
MessageFilterExpression Class
MessageFilterExpression Members
NFX.Log Namespace


MessageFilterExpression Constructor (String)

MessageFilterExpression Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates a new expression in a default logging filter scope. This .ctor will fail if at least one expression from this scope has already been compiled

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageFilterExpression(
    string expr
)
public MessageFilterExpression(
    string expr
)
Public Sub New (
    expr As String
)
Public Sub New (
    expr As String
)
public:
MessageFilterExpression(
    String^ expr
)
public:
MessageFilterExpression(
    String^ expr
)
new :
        expr : string -> MessageFilterExpression
new :
        expr : string -> MessageFilterExpression

Parameters

expr
Type: Online System String
See Also
MessageFilterExpression Class
MessageFilterExpression Members
MessageFilterExpression Overload
NFX.Log Namespace


MessageFilterExpression Constructor (String, String, IEnumerable(String), IEnumerable(String))

MessageFilterExpression Constructor (String, String, IEnumerable String , IEnumerable String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Use this .ctor to specify a different scope name. Every unique scope name gets compiled into a new assembly, consequently it is not a good practice to create many different scopes. This .ctor will fail if at least one expression from this scope has already been compiled

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageFilterExpression(
    string scope,
    string expr,
    IEnumerable<string> referencedAssemblies = null,
    IEnumerable<string> usings = null
)
public MessageFilterExpression(
    string scope,
    string expr,
    IEnumerable<string> referencedAssemblies = null,
    IEnumerable<string> usings = null
)
Public Sub New (
    scope As String,
    expr As String,
    Optional referencedAssemblies As IEnumerable(Of String) = Nothing,
    Optional usings As IEnumerable(Of String) = Nothing
)
Public Sub New (
    scope As String,
    expr As String,
    Optional referencedAssemblies As IEnumerable(Of String) = Nothing,
    Optional usings As IEnumerable(Of String) = Nothing
)
public:
MessageFilterExpression(
    String^ scope,
    String^ expr,
    IEnumerable<String^>^ referencedAssemblies = nullptr,
    IEnumerable<String^>^ usings = nullptr
)
public:
MessageFilterExpression(
    String^ scope,
    String^ expr,
    IEnumerable<String^>^ referencedAssemblies = nullptr,
    IEnumerable<String^>^ usings = nullptr
)
new :
        scope : string *
        expr : string *
        ?referencedAssemblies : IEnumerable<string> *
        ?usings : IEnumerable<string>
(* Defaults:
        let _referencedAssemblies = defaultArg referencedAssemblies null
        let _usings = defaultArg usings null
*)
-> MessageFilterExpression
new :
        scope : string *
        expr : string *
        ?referencedAssemblies : IEnumerable<string> *
        ?usings : IEnumerable<string>
(* Defaults:
        let _referencedAssemblies = defaultArg referencedAssemblies null
        let _usings = defaultArg usings null
*)
-> MessageFilterExpression

Parameters

scope
Type: Online System String
expr
Type: Online System String
referencedAssemblies (Optional)
Type: Online System.Collections.Generic IEnumerable Online String
usings (Optional)
Type: Online System.Collections.Generic IEnumerable Online String
See Also
MessageFilterExpression Class
MessageFilterExpression Members
MessageFilterExpression Overload
NFX.Log Namespace


MessageFilterExpression Fields

MessageFilterExpression Fields NFX Class Library

The MessageFilterExpression type exposes the following members.
Fields
Name | Description
SCOPE |
Back to Top
See Also
MessageFilterExpression Class
NFX.Log Namespace


MessageFilterExpression.SCOPE Field

MessageFilterExpression SCOPE Field NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SCOPE
public const string SCOPE
Public Const SCOPE As String
Public Const SCOPE As String
public:
literal String^ SCOPE
public:
literal String^ SCOPE
static val mutable SCOPE: string
static val mutable SCOPE: string

Field Value

Type: Online String
See Also
MessageFilterExpression Class
MessageFilterExpression Members
NFX.Log Namespace


MessageFilterExpression Methods

MessageFilterExpression Methods NFX Class Library

The MessageFilterExpression type exposes the following members.
Methods
 | Name | Description
Public method | Compile | Forces the entire scope compilation now, so no delay is incurred on first call to Evaluate(). (Inherited from CompilingExpressionEvaluator TContext, TResult, TArg .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Evaluate | Evaluates expression using supplied arg in a context. Context is passed as "ctx" and argument as "arg". (Inherited from CompilingExpressionEvaluator TContext, TResult, TArg .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MessageFilterExpression Class
NFX.Log Namespace


MessageFilterExpression Properties

MessageFilterExpression Properties NFX Class Library

The MessageFilterExpression type exposes the following members.
Properties
 | Name | Description
Public property | Expression | Returns an original expression as string that is to be evaluated (Inherited from CompilingExpressionEvaluator TContext, TResult, TArg .)
Public property | Scope | Returns a scope (similar to compilation unit / assembly) that this expression is in (Inherited from CompilingExpressionEvaluator TContext, TResult, TArg .)
Back to Top
See Also
MessageFilterExpression Class
NFX.Log Namespace


MessageList Class

MessageList Class NFX Class Library

Inheritance Hierarchy
Online System Object
Online System.Collections.Generic List Message
NFX.Log MessageList

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class MessageList : List<Message>
internal class MessageList : List<Message>
Friend Class MessageList
    Inherits List(Of Message)
Friend Class MessageList
    Inherits List(Of Message)
internal ref class MessageList : public List<Message^>
internal ref class MessageList : public List<Message^>
type MessageList =
    class
        inherit List<Message>
    end
type MessageList =
    class
        inherit List<Message>
    end
See Also
MessageList Members
NFX.Log Namespace


MessageList Members

MessageList Members NFX Class Library

The MessageList type exposes the following members.
Constructors
 | Name | Description
Public method | MessageList | Initializes a new instance of the MessageList class
Public method | MessageList(IEnumerable Message ) | Initializes a new instance of the MessageList class
Back to Top
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List Message .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List Message .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List Message .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List Message .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Message .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Message .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List Message .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List Message .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List Message .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List Message .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Message .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Message .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List Message .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List Message .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Message .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Message .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Message .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Message .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List Message .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Message .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Message .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Message .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List Message .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List Message .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List Message .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Message .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Message .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Message .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List Message .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List Message .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Message .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Message .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Message .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List Message .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Message .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List Message .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List Message .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List Message .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List Message .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List Message .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List Message .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List Message .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List Message .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List Message .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List Message .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List Message .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List Message .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List Message .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List Message .)
Back to Top
See Also
MessageList Class
NFX.Log Namespace


MessageList Constructor

MessageList Constructor NFX Class Library

Overload List
 | Name | Description
Public method | MessageList | Initializes a new instance of the MessageList class
Public method | MessageList(IEnumerable Message ) | Initializes a new instance of the MessageList class
Back to Top
See Also
MessageList Class
MessageList Members
NFX.Log Namespace


MessageList Constructor

MessageList Constructor NFX Class Library

Initializes a new instance of the MessageList class

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageList()
public MessageList()
Public Sub New
Public Sub New
public:
MessageList()
public:
MessageList()
new : unit -> MessageList
new : unit -> MessageList
See Also
MessageList Class
MessageList Members
MessageList Overload
NFX.Log Namespace


MessageList Constructor (IEnumerable(Message))

MessageList Constructor (IEnumerable Message ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MessageList class

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageList(
    IEnumerable<Message> other
)
public MessageList(
    IEnumerable<Message> other
)
Public Sub New (
    other As IEnumerable(Of Message)
)
Public Sub New (
    other As IEnumerable(Of Message)
)
public:
MessageList(
    IEnumerable<Message^>^ other
)
public:
MessageList(
    IEnumerable<Message^>^ other
)
new :
        other : IEnumerable<Message> -> MessageList
new :
        other : IEnumerable<Message> -> MessageList

Parameters

other
Type: Online System.Collections.Generic IEnumerable Message
See Also
MessageList Class
MessageList Members
MessageList Overload
NFX.Log Namespace


MessageList Methods

MessageList Methods NFX Class Library

The MessageList type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List Message .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List Message .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List Message .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List Message .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Message .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Message .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List Message .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List Message .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List Message .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List Message .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Message .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Message .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List Message .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List Message .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Message .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Message .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Message .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Message .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List Message .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Message .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Message .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Message .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List Message .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List Message .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List Message .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Message .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Message .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Message .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List Message .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List Message .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Message .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Message .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Message .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List Message .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Message .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List Message .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List Message .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List Message .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List Message .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List Message .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List Message .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List Message .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List Message .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List Message .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List Message .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List Message .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MessageList Class
NFX.Log Namespace


MessageList Properties

MessageList Properties NFX Class Library

The MessageList type exposes the following members.
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List Message .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List Message .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List Message .)
Back to Top
See Also
MessageList Class
NFX.Log Namespace


MessageType Enumeration

MessageType Enumeration NFX Class Library

Stipulates general logging message types like: Info/Warning/Error etc...

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum MessageType
public enum MessageType
Public Enumeration MessageType
Public Enumeration MessageType
public enum class MessageType
public enum class MessageType
type MessageType
type MessageType
Members
Member name | Value | Description
Debug | 0 | Used in debugging temp code
DebugA | 1 |
DebugB | 2 |
DebugC | 3 |
DebugD | 4 |
DebugSQL | 5 | Emitted by DataStore implementations
DebugGlue | 6 | Emitted by Glue/Net code
DebugZ | 7 | Last debug-related message type for use in debug-related max-level config setting
Trace | 50 | Tracing, no danger to system operation
TraceA | 51 |
TraceB | 52 |
TraceC | 53 |
TraceD | 54 |
TraceSQL | 55 | Emitted by DataStore implementations
TraceGlue | 56 | Emitted by Glue/Net code
TraceErl | 57 | Emitted by Erlang code
TraceZ | 58 | Last trace-related message type for use in trace-related max-level config setting
PerformanceInstrumentation | 90 | Performance/Instrumentation-related message
Info | 100 | Informational message, no danger to system operation
InfoA | 101 |
InfoB | 102 |
InfoC | 103 |
InfoD | 104 |
InfoZ | 105 | Last info-related message type for use in info-related max-level config setting
SecurityAudit | 200 | Permission audit, usualy a result of client user action, no danger to system operation
Notice | 300 | SYSLOG.Notice Events that are unusual but not error conditions - might be summarized in an email to developers or admins to spot potential problems - no immediate action required.
Warning | 400 | Caution - inspect and take action. SYSLOG.Warning, not an error, but indication that an error will occur if action is not taken, e.g. file system 85% full - each item must be resolved within a given time.
Error | 500 | Recoverable error, system will most-likely continue working normally. SYSLOG.Error Non-urgent failures, these should be relayed to developers or admins; each item must be resolved within a given time.
Critical | 600 | SYSLOG.Critical Should be corrected immediately, but indicates failure in a primary system, an example is a loss of a backup ISP connection.
CriticalAlert | 700 | SYSLOG.Alert Should be corrected immediately, therefore notify staff who can fix the problem. An example would be the loss of a primary ISP connection.
Emergency | 1000 | Unrecoverable error, system will most-likely experience major operation disruption. SYSLOG.Emergency - A "panic" condition usually affecting multiple apps/servers/sites. At this level it would usually notify all tech staff on call.
CatastrophicError | 2000 | Unrecoverable error, system will experience major operation disruption. SYSLOG.Emergency - A "panic" condition usually affecting multiple apps/servers/sites. At this level it would usually notify all tech staff on call.
See Also
NFX.Log Namespace


NOPLog Class

NOPLog Class NFX Class Library

Represents log that does not do anything
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Log NOPLog

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class NOPLog : ApplicationComponent,
    ILog, IApplicationComponent, IDisposable, ILocalizedTimeProvider
public sealed class NOPLog : ApplicationComponent,
    ILog, IApplicationComponent, IDisposable, ILocalizedTimeProvider
Public NotInheritable Class NOPLog
    Inherits ApplicationComponent
    Implements ILog, IApplicationComponent, IDisposable, ILocalizedTimeProvider
Public NotInheritable Class NOPLog
    Inherits ApplicationComponent
    Implements ILog, IApplicationComponent, IDisposable, ILocalizedTimeProvider
public ref class NOPLog sealed : public ApplicationComponent,
    ILog, IApplicationComponent, IDisposable, ILocalizedTimeProvider
public ref class NOPLog sealed : public ApplicationComponent,
    ILog, IApplicationComponent, IDisposable, ILocalizedTimeProvider
[<SealedAttribute>]
type NOPLog =
    class
        inherit ApplicationComponent
        interface ILog
        interface IApplicationComponent
        interface IDisposable
        interface ILocalizedTimeProvider
    end
[<SealedAttribute>]
type NOPLog =
    class
        inherit ApplicationComponent
        interface ILog
        interface IApplicationComponent
        interface IDisposable
        interface ILocalizedTimeProvider
    end
See Also
NOPLog Members
NFX.Log Namespace


NOPLog Members

NOPLog Members NFX Class Library

The NOPLog type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime |
Public method | Write(Message) |
Public method | Write(Message, Boolean) |
Public method | Write(MessageType, String, String, String) |
Public method | Write(MessageType, String, Boolean, String, String) |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
 | Instance | Returns a singlelton instance of the log that does not do anything
Public property | LastCatastrophy |
Public property | LastError |
Public property | LastWarning |
Public property | LocalizedTime |
Public property | TimeLocation |
Back to Top
See Also
NOPLog Class
NFX.Log Namespace


NOPLog Methods

NOPLog Methods NFX Class Library

The NOPLog type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | Destructor | (Inherited from ApplicationComponent.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime |
Public method | Write(Message) |
Public method | Write(Message, Boolean) |
Public method | Write(MessageType, String, String, String) |
Public method | Write(MessageType, String, Boolean, String, String) |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NOPLog Class
NFX.Log Namespace


NOPLog.LocalizedTimeToUniversalTime Method

NOPLog LocalizedTimeToUniversalTime Method NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
public DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
Public Function LocalizedTimeToUniversalTime (
    local As DateTime
) As DateTime
Public Function LocalizedTimeToUniversalTime (
    local As DateTime
) As DateTime
public:
virtual DateTime LocalizedTimeToUniversalTime(
    DateTime local
) sealed
public:
virtual DateTime LocalizedTimeToUniversalTime(
    DateTime local
) sealed
abstract LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
override LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
abstract LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
override LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime

Parameters

local
Type: Online System DateTime

Return Value

Type: Online DateTime

Implements

ILocalizedTimeProvider LocalizedTimeToUniversalTime(DateTime)
See Also
NOPLog Class
NOPLog Members
NFX.Log Namespace


NOPLog.UniversalTimeToLocalizedTime Method

NOPLog UniversalTimeToLocalizedTime Method NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
public DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
Public Function UniversalTimeToLocalizedTime (
    utc As DateTime
) As DateTime
Public Function UniversalTimeToLocalizedTime (
    utc As DateTime
) As DateTime
public:
virtual DateTime UniversalTimeToLocalizedTime(
    DateTime utc
) sealed
public:
virtual DateTime UniversalTimeToLocalizedTime(
    DateTime utc
) sealed
abstract UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
override UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
abstract UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
override UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime

Parameters

utc
Type: Online System DateTime

Return Value

Type: Online DateTime

Implements

ILocalizedTimeProvider UniversalTimeToLocalizedTime(DateTime)
See Also
NOPLog Class
NOPLog Members
NFX.Log Namespace


NOPLog.Write Method

NOPLog Write Method NFX Class Library

Overload List
 | Name | Description
Public method | Write(Message) |
Public method | Write(Message, Boolean) |
Public method | Write(MessageType, String, String, String) |
Public method | Write(MessageType, String, Boolean, String, String) |
Back to Top
See Also
NOPLog Class
NOPLog Members
NFX.Log Namespace


NOPLog.Write Method (Message)

NOPLog Write Method (Message) NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Write(
    Message msg
)
public void Write(
    Message msg
)
Public Sub Write (
    msg As Message
)
Public Sub Write (
    msg As Message
)
public:
virtual void Write(
    Message^ msg
) sealed
public:
virtual void Write(
    Message^ msg
) sealed
abstract Write :
        msg : Message -> unit
override Write :
        msg : Message -> unit
abstract Write :
        msg : Message -> unit
override Write :
        msg : Message -> unit

Parameters

msg
Type: NFX.Log Message

Implements

ILog Write(Message)
See Also
NOPLog Class
NOPLog Members
Write Overload
NFX.Log Namespace


NOPLog.Write Method (Message, Boolean)

NOPLog Write Method (Message, Boolean) NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Write(
    Message msg,
    bool urgent
)
public void Write(
    Message msg,
    bool urgent
)
Public Sub Write (
    msg As Message,
    urgent As Boolean
)
Public Sub Write (
    msg As Message,
    urgent As Boolean
)
public:
virtual void Write(
    Message^ msg,
    bool urgent
) sealed
public:
virtual void Write(
    Message^ msg,
    bool urgent
) sealed
abstract Write :
        msg : Message *
        urgent : bool -> unit
override Write :
        msg : Message *
        urgent : bool -> unit
abstract Write :
        msg : Message *
        urgent : bool -> unit
override Write :
        msg : Message *
        urgent : bool -> unit

Parameters

msg
Type: NFX.Log Message
urgent
Type: Online System Boolean

Implements

ILog Write(Message, Boolean)
See Also
NOPLog Class
NOPLog Members
Write Overload
NFX.Log Namespace


NOPLog.Write Method (MessageType, String, String, String)

NOPLog Write Method (MessageType, String, String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Write(
    MessageType type,
    string text,
    string topic = null,
    string from = null
)
public void Write(
    MessageType type,
    string text,
    string topic = null,
    string from = null
)
Public Sub Write (
    type As MessageType,
    text As String,
    Optional topic As String = Nothing,
    Optional from As String = Nothing
)
Public Sub Write (
    type As MessageType,
    text As String,
    Optional topic As String = Nothing,
    Optional from As String = Nothing
)
public:
virtual void Write(
    MessageType type,
    String^ text,
    String^ topic = nullptr,
    String^ from = nullptr
) sealed
public:
virtual void Write(
    MessageType type,
    String^ text,
    String^ topic = nullptr,
    String^ from = nullptr
) sealed
abstract Write :
        type : MessageType *
        text : string *
        ?topic : string *
        ?from : string
(* Defaults:
        let _topic = defaultArg topic null
        let _from = defaultArg from null
*)
-> unit
override Write :
        type : MessageType *
        text : string *
        ?topic : string *
        ?from : string
(* Defaults:
        let _topic = defaultArg topic null
        let _from = defaultArg from null
*)
-> unit
abstract Write :
        type : MessageType *
        text : string *
        ?topic : string *
        ?from : string
(* Defaults:
        let _topic = defaultArg topic null
        let _from = defaultArg from null
*)
-> unit
override Write :
        type : MessageType *
        text : string *
        ?topic : string *
        ?from : string
(* Defaults:
        let _topic = defaultArg topic null
        let _from = defaultArg from null
*)
-> unit

Parameters

type
Type: NFX.Log MessageType
text
Type: Online System String
topic (Optional)
Type: Online System String
from (Optional)
Type: Online System String

Implements

ILog Write(MessageType, String, String, String)
See Also
NOPLog Class
NOPLog Members
Write Overload
NFX.Log Namespace


NOPLog.Write Method (MessageType, String, Boolean, String, String)

NOPLog Write Method (MessageType, String, Boolean, String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Write(
    MessageType type,
    string text,
    bool urgent,
    string topic = null,
    string from = null
)
public void Write(
    MessageType type,
    string text,
    bool urgent,
    string topic = null,
    string from = null
)
Public Sub Write (
    type As MessageType,
    text As String,
    urgent As Boolean,
    Optional topic As String = Nothing,
    Optional from As String = Nothing
)
Public Sub Write (
    type As MessageType,
    text As String,
    urgent As Boolean,
    Optional topic As String = Nothing,
    Optional from As String = Nothing
)
public:
virtual void Write(
    MessageType type,
    String^ text,
    bool urgent,
    String^ topic = nullptr,
    String^ from = nullptr
) sealed
public:
virtual void Write(
    MessageType type,
    String^ text,
    bool urgent,
    String^ topic = nullptr,
    String^ from = nullptr
) sealed
abstract Write :
        type : MessageType *
        text : string *
        urgent : bool *
        ?topic : string *
        ?from : string
(* Defaults:
        let _topic = defaultArg topic null
        let _from = defaultArg from null
*)
-> unit
override Write :
        type : MessageType *
        text : string *
        urgent : bool *
        ?topic : string *
        ?from : string
(* Defaults:
        let _topic = defaultArg topic null
        let _from = defaultArg from null
*)
-> unit
abstract Write :
        type : MessageType *
        text : string *
        urgent : bool *
        ?topic : string *
        ?from : string
(* Defaults:
        let _topic = defaultArg topic null
        let _from = defaultArg from null
*)
-> unit
override Write :
        type : MessageType *
        text : string *
        urgent : bool *
        ?topic : string *
        ?from : string
(* Defaults:
        let _topic = defaultArg topic null
        let _from = defaultArg from null
*)
-> unit

Parameters

type
Type: NFX.Log MessageType
text
Type: Online System String
urgent
Type: Online System Boolean
topic (Optional)
Type: Online System String
from (Optional)
Type: Online System String

Implements

ILog Write(MessageType, String, Boolean, String, String)
See Also
NOPLog Class
NOPLog Members
Write Overload
NFX.Log Namespace


NOPLog Properties

NOPLog Properties NFX Class Library

The NOPLog type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
 | Instance | Returns a singlelton instance of the log that does not do anything
Public property | LastCatastrophy |
Public property | LastError |
Public property | LastWarning |
Public property | LocalizedTime |
Public property | TimeLocation |
Back to Top
See Also
NOPLog Class
NFX.Log Namespace


NOPLog.Instance Property

NOPLog Instance Property NFX Class Library

Returns a singlelton instance of the log that does not do anything

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NOPLog Instance { get; }
public static NOPLog Instance { get; }
Public Shared ReadOnly Property Instance As NOPLog
    Get
Public Shared ReadOnly Property Instance As NOPLog
    Get
public:
static property NOPLog^ Instance {
    NOPLog^ get ();
}
public:
static property NOPLog^ Instance {
    NOPLog^ get ();
}
static member Instance : NOPLog with get
static member Instance : NOPLog with get

Property Value

Type: NOPLog
See Also
NOPLog Class
NOPLog Members
NFX.Log Namespace


NOPLog.LastCatastrophy Property

NOPLog LastCatastrophy Property NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Message LastCatastrophy { get; }
public Message LastCatastrophy { get; }
Public ReadOnly Property LastCatastrophy As Message
    Get
Public ReadOnly Property LastCatastrophy As Message
    Get
public:
virtual property Message^ LastCatastrophy {
    Message^ get () sealed;
}
public:
virtual property Message^ LastCatastrophy {
    Message^ get () sealed;
}
abstract LastCatastrophy : Message with get
override LastCatastrophy : Message with get
abstract LastCatastrophy : Message with get
override LastCatastrophy : Message with get

Property Value

Type: Message

Implements

ILog LastCatastrophy
See Also
NOPLog Class
NOPLog Members
NFX.Log Namespace


NOPLog.LastError Property

NOPLog LastError Property NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Message LastError { get; }
public Message LastError { get; }
Public ReadOnly Property LastError As Message
    Get
Public ReadOnly Property LastError As Message
    Get
public:
virtual property Message^ LastError {
    Message^ get () sealed;
}
public:
virtual property Message^ LastError {
    Message^ get () sealed;
}
abstract LastError : Message with get
override LastError : Message with get
abstract LastError : Message with get
override LastError : Message with get

Property Value

Type: Message

Implements

ILog LastError
See Also
NOPLog Class
NOPLog Members
NFX.Log Namespace


NOPLog.LastWarning Property

NOPLog LastWarning Property NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Message LastWarning { get; }
public Message LastWarning { get; }
Public ReadOnly Property LastWarning As Message
    Get
Public ReadOnly Property LastWarning As Message
    Get
public:
virtual property Message^ LastWarning {
    Message^ get () sealed;
}
public:
virtual property Message^ LastWarning {
    Message^ get () sealed;
}
abstract LastWarning : Message with get
override LastWarning : Message with get
abstract LastWarning : Message with get
override LastWarning : Message with get

Property Value

Type: Message

Implements

ILog LastWarning
See Also
NOPLog Class
NOPLog Members
NFX.Log Namespace


NOPLog.LocalizedTime Property

NOPLog LocalizedTime Property NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime LocalizedTime { get; }
public DateTime LocalizedTime { get; }
Public ReadOnly Property LocalizedTime As DateTime
    Get
Public ReadOnly Property LocalizedTime As DateTime
    Get
public:
virtual property DateTime LocalizedTime {
    DateTime get () sealed;
}
public:
virtual property DateTime LocalizedTime {
    DateTime get () sealed;
}
abstract LocalizedTime : DateTime with get
override LocalizedTime : DateTime with get
abstract LocalizedTime : DateTime with get
override LocalizedTime : DateTime with get

Property Value

Type: Online DateTime

Implements

ILocalizedTimeProvider LocalizedTime
See Also
NOPLog Class
NOPLog Members
NFX.Log Namespace


NOPLog.TimeLocation Property

NOPLog TimeLocation Property NFX Class Library

Namespace: NFX.Log
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeLocation TimeLocation { get; }
public TimeLocation TimeLocation { get; }
Public ReadOnly Property TimeLocation As TimeLocation
    Get
Public ReadOnly Property TimeLocation As TimeLocation
    Get
public:
virtual property TimeLocation^ TimeLocation {
    TimeLocation^ get () sealed;
}
public:
virtual property TimeLocation^ TimeLocation {
    TimeLocation^ get () sealed;
}
abstract TimeLocation : TimeLocation with get
override TimeLocation : TimeLocation with get
abstract TimeLocation : TimeLocation with get
override TimeLocation : TimeLocation with get

Property Value

Type: TimeLocation

Implements

ILocalizedTimeProvider TimeLocation
See Also
NOPLog Class
NOPLog Members
NFX.Log Namespace


NFX.Log.Bin Namespace

NFX.Log.Bin Namespace NFX Class Library

Classes
 | Class | Description
Public class | BinLogException | Base exception thrown by the binlog-related framework
Protected class | Format | Facilittates reading primitive values from stream
Public class | LogCorruption | Denotes a special surrogate structure that indicates log corruption
Public class | LogReader | Provides abstraction for binary object log readers. Use Open(stream method) to obtain the instance of the reader type appropriate for particular content. This class is NOT thread safe
Public class | LogUTCTimeStamp | Denotes a special surrogate structure that wraps DatTime in log. These structures get inserted in log automatically by binary log writers to indicate te point in time
Public class | LogWriter |
Public class | SlimLogReader | Reads bin log in Slim format. The format does not support object versioning however it is very efficient in both space and speed
Public class | SlimLogWriter | Writes bin log in Slim format. The format does not support object versioning however it is very efficient in both space and speed
Interfaces
 | Interface | Description
Public interface | ILogMetadata | Denotes entities that represent metadata - extra information about data such as timestamps and corruptions
Enumerations
 | Enumeration | Description
Public enumeration | Format PageHeaderReadStatus |


BinLogException Class

BinLogException Class NFX Class Library

Base exception thrown by the binlog-related framework
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Log.Bin BinLogException

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class BinLogException : NFXException
[SerializableAttribute]
public class BinLogException : NFXException
<SerializableAttribute>
Public Class BinLogException
    Inherits NFXException
<SerializableAttribute>
Public Class BinLogException
    Inherits NFXException
[SerializableAttribute]
public ref class BinLogException : public NFXException
[SerializableAttribute]
public ref class BinLogException : public NFXException
[<SerializableAttribute>]
type BinLogException =
    class
        inherit NFXException
    end
[<SerializableAttribute>]
type BinLogException =
    class
        inherit NFXException
    end
See Also
BinLogException Members
NFX.Log.Bin Namespace


BinLogException Members

BinLogException Members NFX Class Library

The BinLogException type exposes the following members.
Constructors
 | Name | Description
Public method | BinLogException | Initializes a new instance of the BinLogException class
Public method | BinLogException(String) | Initializes a new instance of the BinLogException class
Protected method | BinLogException(SerializationInfo, StreamingContext) | Initializes a new instance of the BinLogException class
Public method | BinLogException(String, Exception) | Initializes a new instance of the BinLogException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
BinLogException Class
NFX.Log.Bin Namespace


BinLogException Constructor

BinLogException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | BinLogException | Initializes a new instance of the BinLogException class
Public method | BinLogException(String) | Initializes a new instance of the BinLogException class
Protected method | BinLogException(SerializationInfo, StreamingContext) | Initializes a new instance of the BinLogException class
Public method | BinLogException(String, Exception) | Initializes a new instance of the BinLogException class
Back to Top
See Also
BinLogException Class
BinLogException Members
NFX.Log.Bin Namespace


BinLogException Constructor

BinLogException Constructor NFX Class Library

Initializes a new instance of the BinLogException class

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BinLogException()
public BinLogException()
Public Sub New
Public Sub New
public:
BinLogException()
public:
BinLogException()
new : unit -> BinLogException
new : unit -> BinLogException
See Also
BinLogException Class
BinLogException Members
BinLogException Overload
NFX.Log.Bin Namespace


BinLogException Constructor (String)

BinLogException Constructor (String) NFX Class Library

Initializes a new instance of the BinLogException class

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BinLogException(
    string message
)
public BinLogException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
BinLogException(
    String^ message
)
public:
BinLogException(
    String^ message
)
new :
        message : string -> BinLogException
new :
        message : string -> BinLogException

Parameters

message
Type: Online System String
See Also
BinLogException Class
BinLogException Members
BinLogException Overload
NFX.Log.Bin Namespace


BinLogException Constructor (SerializationInfo, StreamingContext)

BinLogException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BinLogException class

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected BinLogException(
    SerializationInfo info,
    StreamingContext context
)
protected BinLogException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
BinLogException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
BinLogException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> BinLogException
new :
        info : SerializationInfo *
        context : StreamingContext -> BinLogException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
BinLogException Class
BinLogException Members
BinLogException Overload
NFX.Log.Bin Namespace


BinLogException Constructor (String, Exception)

BinLogException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BinLogException class

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BinLogException(
    string message,
    Exception inner
)
public BinLogException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
BinLogException(
    String^ message,
    Exception^ inner
)
public:
BinLogException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> BinLogException
new :
        message : string *
        inner : Exception -> BinLogException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
BinLogException Class
BinLogException Members
BinLogException Overload
NFX.Log.Bin Namespace


BinLogException Methods

BinLogException Methods NFX Class Library

The BinLogException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
BinLogException Class
NFX.Log.Bin Namespace


BinLogException Properties

BinLogException Properties NFX Class Library

The BinLogException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
BinLogException Class
NFX.Log.Bin Namespace


BinLogException Events

BinLogException Events NFX Class Library

The BinLogException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
BinLogException Class
NFX.Log.Bin Namespace


Format Class

Format Class NFX Class Library

Facilittates reading primitive values from stream
Inheritance Hierarchy
Online System Object
NFX.Log.Bin Format

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static class Format
internal static class Format
Friend NotInheritable Class Format
Friend NotInheritable Class Format
internal ref class Format abstract sealed
internal ref class Format abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Format =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Format =  class end
See Also
Format Members
NFX.Log.Bin Namespace


Format Members

Format Members NFX Class Library

The Format type exposes the following members.
Methods
Name | Description
getBuff32 |
ReadByte |
readFromStream |
ReadString |
ReadTimeStamp |
TryReadPageHeader |
WritePageHeader |
WriteTimeStamp |
Back to Top
Fields
Name | Description
HEADER |
HEADER_BUF |
PAGE_HEADER |
PAGE_HEADER_SZ |
REC_EOF |
REC_INVALID |
REC_SERIALIZER |
REC_TIMESTAMP |
Back to Top
See Also
Format Class
NFX.Log.Bin Namespace


Format Fields

Format Fields NFX Class Library

The Format type exposes the following members.
Fields
Name | Description
HEADER |
HEADER_BUF |
PAGE_HEADER |
PAGE_HEADER_SZ |
REC_EOF |
REC_INVALID |
REC_SERIALIZER |
REC_TIMESTAMP |
Back to Top
See Also
Format Class
NFX.Log.Bin Namespace


Format.HEADER Field

Format HEADER Field NFX Class Library

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string HEADER
public const string HEADER
Public Const HEADER As String
Public Const HEADER As String
public:
literal String^ HEADER
public:
literal String^ HEADER
static val mutable HEADER: string
static val mutable HEADER: string

Field Value

Type: Online String
See Also
Format Class
Format Members
NFX.Log.Bin Namespace


Format.HEADER_BUF Field

Format HEADER_BUF Field NFX Class Library

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly byte[] HEADER_BUF
public static readonly byte[] HEADER_BUF
Public Shared ReadOnly HEADER_BUF As Byte()
Public Shared ReadOnly HEADER_BUF As Byte()
public:
static initonly array<unsigned char>^ HEADER_BUF
public:
static initonly array<unsigned char>^ HEADER_BUF
static val HEADER_BUF: byte[]
static val HEADER_BUF: byte[]

Field Value

Type: Online Byte
See Also
Format Class
Format Members
NFX.Log.Bin Namespace


Format.PAGE_HEADER Field

Format PAGE_HEADER Field NFX Class Library

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const ulong PAGE_HEADER
public const ulong PAGE_HEADER
Public Const PAGE_HEADER As ULong
Public Const PAGE_HEADER As ULong
public:
literal unsigned long long PAGE_HEADER
public:
literal unsigned long long PAGE_HEADER
static val mutable PAGE_HEADER: uint64
static val mutable PAGE_HEADER: uint64

Field Value

Type: Online UInt64
See Also
Format Class
Format Members
NFX.Log.Bin Namespace


Format.PAGE_HEADER_SZ Field

Format PAGE_HEADER_SZ Field NFX Class Library

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int PAGE_HEADER_SZ
public const int PAGE_HEADER_SZ
Public Const PAGE_HEADER_SZ As Integer
Public Const PAGE_HEADER_SZ As Integer
public:
literal int PAGE_HEADER_SZ
public:
literal int PAGE_HEADER_SZ
static val mutable PAGE_HEADER_SZ: int
static val mutable PAGE_HEADER_SZ: int

Field Value

Type: Online Int32
See Also
Format Class
Format Members
NFX.Log.Bin Namespace


Format.REC_EOF Field

Format REC_EOF Field NFX Class Library

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const byte REC_EOF
public const byte REC_EOF
Public Const REC_EOF As Byte
Public Const REC_EOF As Byte
public:
literal unsigned char REC_EOF
public:
literal unsigned char REC_EOF
static val mutable REC_EOF: byte
static val mutable REC_EOF: byte

Field Value

Type: Online Byte
See Also
Format Class
Format Members
NFX.Log.Bin Namespace


Format.REC_INVALID Field

Format REC_INVALID Field NFX Class Library

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const byte REC_INVALID
public const byte REC_INVALID
Public Const REC_INVALID As Byte
Public Const REC_INVALID As Byte
public:
literal unsigned char REC_INVALID
public:
literal unsigned char REC_INVALID
static val mutable REC_INVALID: byte
static val mutable REC_INVALID: byte

Field Value

Type: Online Byte
See Also
Format Class
Format Members
NFX.Log.Bin Namespace


Format.REC_SERIALIZER Field

Format REC_SERIALIZER Field NFX Class Library

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const byte REC_SERIALIZER
public const byte REC_SERIALIZER
Public Const REC_SERIALIZER As Byte
Public Const REC_SERIALIZER As Byte
public:
literal unsigned char REC_SERIALIZER
public:
literal unsigned char REC_SERIALIZER
static val mutable REC_SERIALIZER: byte
static val mutable REC_SERIALIZER: byte

Field Value

Type: Online Byte
See Also
Format Class
Format Members
NFX.Log.Bin Namespace


Format.REC_TIMESTAMP Field

Format REC_TIMESTAMP Field NFX Class Library

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const byte REC_TIMESTAMP
public const byte REC_TIMESTAMP
Public Const REC_TIMESTAMP As Byte
Public Const REC_TIMESTAMP As Byte
public:
literal unsigned char REC_TIMESTAMP
public:
literal unsigned char REC_TIMESTAMP
static val mutable REC_TIMESTAMP: byte
static val mutable REC_TIMESTAMP: byte

Field Value

Type: Online Byte
See Also
Format Class
Format Members
NFX.Log.Bin Namespace


Format Methods

Format Methods NFX Class Library

The Format type exposes the following members.
Methods
Name | Description
getBuff32 |
ReadByte |
readFromStream |
ReadString |
ReadTimeStamp |
TryReadPageHeader |
WritePageHeader |
WriteTimeStamp |
Back to Top
See Also
Format Class
NFX.Log.Bin Namespace


Format.getBuff32 Method

Format getBuff32 Method NFX Class Library

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static byte[] getBuff32()
internal static byte[] getBuff32()
Friend Shared Function getBuff32 As Byte()
Friend Shared Function getBuff32 As Byte()
internal:
static array<unsigned char>^ getBuff32()
internal:
static array<unsigned char>^ getBuff32()
internal static member getBuff32 : unit -> byte[]
internal static member getBuff32 : unit -> byte[]

Return Value

Type: Online Byte
See Also
Format Class
Format Members
NFX.Log.Bin Namespace


Format.ReadByte Method

Format ReadByte Method NFX Class Library

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte ReadByte(
    Stream stream
)
public static byte ReadByte(
    Stream stream
)
Public Shared Function ReadByte (
    stream As Stream
) As Byte
Public Shared Function ReadByte (
    stream As Stream
) As Byte
public:
static unsigned char ReadByte(
    Stream^ stream
)
public:
static unsigned char ReadByte(
    Stream^ stream
)
static member ReadByte :
        stream : Stream -> byte
static member ReadByte :
        stream : Stream -> byte

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online Byte
See Also
Format Class
Format Members
NFX.Log.Bin Namespace


Format.readFromStream Method

Format readFromStream Method NFX Class Library

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static int readFromStream(
    Stream stream,
    byte[] buffer,
    int count
)
internal static int readFromStream(
    Stream stream,
    byte[] buffer,
    int count
)
Friend Shared Function readFromStream (
    stream As Stream,
    buffer As Byte(),
    count As Integer
) As Integer
Friend Shared Function readFromStream (
    stream As Stream,
    buffer As Byte(),
    count As Integer
) As Integer
internal:
static int readFromStream(
    Stream^ stream,
    array<unsigned char>^ buffer,
    int count
)
internal:
static int readFromStream(
    Stream^ stream,
    array<unsigned char>^ buffer,
    int count
)
internal static member readFromStream :
        stream : Stream *
        buffer : byte[] *
        count : int -> int
internal static member readFromStream :
        stream : Stream *
        buffer : byte[] *
        count : int -> int

Parameters

stream
Type: Online System.IO Stream
buffer
Type: Online System Byte
count
Type: Online System Int32

Return Value

Type: Online Int32
See Also
Format Class
Format Members
NFX.Log.Bin Namespace


Format.ReadString Method

Format ReadString Method NFX Class Library

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ReadString(
    Stream stream
)
public static string ReadString(
    Stream stream
)
Public Shared Function ReadString (
    stream As Stream
) As String
Public Shared Function ReadString (
    stream As Stream
) As String
public:
static String^ ReadString(
    Stream^ stream
)
public:
static String^ ReadString(
    Stream^ stream
)
static member ReadString :
        stream : Stream -> string
static member ReadString :
        stream : Stream -> string

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online String
See Also
Format Class
Format Members
NFX.Log.Bin Namespace


Format.ReadTimeStamp Method

Format ReadTimeStamp Method NFX Class Library

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DateTime ReadTimeStamp(
    Stream stream
)
public static DateTime ReadTimeStamp(
    Stream stream
)
Public Shared Function ReadTimeStamp (
    stream As Stream
) As DateTime
Public Shared Function ReadTimeStamp (
    stream As Stream
) As DateTime
public:
static DateTime ReadTimeStamp(
    Stream^ stream
)
public:
static DateTime ReadTimeStamp(
    Stream^ stream
)
static member ReadTimeStamp :
        stream : Stream -> DateTime
static member ReadTimeStamp :
        stream : Stream -> DateTime

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online DateTime
See Also
Format Class
Format Members
NFX.Log.Bin Namespace


Format.TryReadPageHeader Method

Format TryReadPageHeader Method NFX Class Library

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Format..::..PageHeaderReadStatus TryReadPageHeader(
    Stream stream,
    ref DateTime current
)
public static Format..::..PageHeaderReadStatus TryReadPageHeader(
    Stream stream,
    ref DateTime current
)
Public Shared Function TryReadPageHeader (
    stream As Stream,
    ByRef current As DateTime
) As Format..::..PageHeaderReadStatus
Public Shared Function TryReadPageHeader (
    stream As Stream,
    ByRef current As DateTime
) As Format..::..PageHeaderReadStatus
public:
static Format..::..PageHeaderReadStatus TryReadPageHeader(
    Stream^ stream,
    DateTime% current
)
public:
static Format..::..PageHeaderReadStatus TryReadPageHeader(
    Stream^ stream,
    DateTime% current
)
static member TryReadPageHeader :
        stream : Stream *
        current : DateTime byref -> Format..::..PageHeaderReadStatus
static member TryReadPageHeader :
        stream : Stream *
        current : DateTime byref -> Format..::..PageHeaderReadStatus

Parameters

stream
Type: Online System.IO Stream
current
Type: Online System DateTime

Return Value

Type: Format PageHeaderReadStatus
See Also
Format Class
Format Members
NFX.Log.Bin Namespace


Format.WritePageHeader Method

Format WritePageHeader Method NFX Class Library

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WritePageHeader(
    Stream stream,
    DateTime ts
)
public static void WritePageHeader(
    Stream stream,
    DateTime ts
)
Public Shared Sub WritePageHeader (
    stream As Stream,
    ts As DateTime
)
Public Shared Sub WritePageHeader (
    stream As Stream,
    ts As DateTime
)
public:
static void WritePageHeader(
    Stream^ stream,
    DateTime ts
)
public:
static void WritePageHeader(
    Stream^ stream,
    DateTime ts
)
static member WritePageHeader :
        stream : Stream *
        ts : DateTime -> unit
static member WritePageHeader :
        stream : Stream *
        ts : DateTime -> unit

Parameters

stream
Type: Online System.IO Stream
ts
Type: Online System DateTime
See Also
Format Class
Format Members
NFX.Log.Bin Namespace


Format.WriteTimeStamp Method

Format WriteTimeStamp Method NFX Class Library

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteTimeStamp(
    Stream stream,
    DateTime ts
)
public static void WriteTimeStamp(
    Stream stream,
    DateTime ts
)
Public Shared Sub WriteTimeStamp (
    stream As Stream,
    ts As DateTime
)
Public Shared Sub WriteTimeStamp (
    stream As Stream,
    ts As DateTime
)
public:
static void WriteTimeStamp(
    Stream^ stream,
    DateTime ts
)
public:
static void WriteTimeStamp(
    Stream^ stream,
    DateTime ts
)
static member WriteTimeStamp :
        stream : Stream *
        ts : DateTime -> unit
static member WriteTimeStamp :
        stream : Stream *
        ts : DateTime -> unit

Parameters

stream
Type: Online System.IO Stream
ts
Type: Online System DateTime
See Also
Format Class
Format Members
NFX.Log.Bin Namespace


Format.PageHeaderReadStatus Enumeration

Format PageHeaderReadStatus Enumeration NFX Class Library

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum PageHeaderReadStatus
public enum PageHeaderReadStatus
Public Enumeration PageHeaderReadStatus
Public Enumeration PageHeaderReadStatus
public enum class PageHeaderReadStatus
public enum class PageHeaderReadStatus
type PageHeaderReadStatus
type PageHeaderReadStatus
Members
Member name | Value | Description
OK | 0 |
EOF | 1 |
Corruption | 2 |
See Also
NFX.Log.Bin Namespace


ILogMetadata Interface

ILogMetadata Interface NFX Class Library

Denotes entities that represent metadata - extra information about data such as timestamps and corruptions

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ILogMetadata
public interface ILogMetadata
Public Interface ILogMetadata
Public Interface ILogMetadata
public interface class ILogMetadata
public interface class ILogMetadata
type ILogMetadata =  interface end
type ILogMetadata =  interface end
See Also
NFX.Log.Bin Namespace


LogCorruption Class

LogCorruption Class NFX Class Library

Denotes a special surrogate structure that indicates log corruption
Inheritance Hierarchy
Online System Object
NFX.Log.Bin LogCorruption

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class LogCorruption : ILogMetadata
public sealed class LogCorruption : ILogMetadata
Public NotInheritable Class LogCorruption
    Implements ILogMetadata
Public NotInheritable Class LogCorruption
    Implements ILogMetadata
public ref class LogCorruption sealed : ILogMetadata
public ref class LogCorruption sealed : ILogMetadata
[<SealedAttribute>]
type LogCorruption =
    class
        interface ILogMetadata
    end
[<SealedAttribute>]
type LogCorruption =
    class
        interface ILogMetadata
    end
See Also
LogCorruption Members
NFX.Log.Bin Namespace


LogCorruption Members

LogCorruption Members NFX Class Library

The LogCorruption type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
Instance | Singleton instance of LogCorruption
Back to Top
See Also
LogCorruption Class
NFX.Log.Bin Namespace


LogCorruption Fields

LogCorruption Fields NFX Class Library

The LogCorruption type exposes the following members.
Fields
Name | Description
Instance | Singleton instance of LogCorruption
Back to Top
See Also
LogCorruption Class
NFX.Log.Bin Namespace


LogCorruption.Instance Field

LogCorruption Instance Field NFX Class Library

Singleton instance of LogCorruption

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly LogCorruption Instance
public static readonly LogCorruption Instance
Public Shared ReadOnly Instance As LogCorruption
Public Shared ReadOnly Instance As LogCorruption
public:
static initonly LogCorruption^ Instance
public:
static initonly LogCorruption^ Instance
static val Instance: LogCorruption
static val Instance: LogCorruption

Field Value

Type: LogCorruption
See Also
LogCorruption Class
LogCorruption Members
NFX.Log.Bin Namespace


LogCorruption Methods

LogCorruption Methods NFX Class Library

The LogCorruption type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LogCorruption Class
NFX.Log.Bin Namespace


LogReader Class

LogReader Class NFX Class Library

Provides abstraction for binary object log readers. Use Open(stream method) to obtain the instance of the reader type appropriate for particular content. This class is NOT thread safe
Inheritance Hierarchy
Online System Object
NFX.Log.Bin LogReader
NFX.Log.Bin SlimLogReader

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class LogReader
public abstract class LogReader
Public MustInherit Class LogReader
Public MustInherit Class LogReader
public ref class LogReader abstract
public ref class LogReader abstract
[<AbstractClassAttribute>]
type LogReader =  class end
[<AbstractClassAttribute>]
type LogReader =  class end
See Also
LogReader Members
NFX.Log.Bin Namespace


LogReader Members

LogReader Members NFX Class Library

The LogReader type exposes the following members.
Constructors
 | Name | Description
Protected method | LogReader | Initializes a new instance of the LogReader class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Open | Opens the appropriate reader type from the stream
Public method | read |
Public method | ReadFromAround | Returns the lazy enumerable that fetches data from the point in time, optionally including time stamps
Public method | ReadFromStart | Returns the lazy enumerable that fetches data from the very log start, optionally including time stamps
Public method | seekForTimeStamp |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Stream | Returns the underlying stream
Back to Top
See Also
LogReader Class
NFX.Log.Bin Namespace


LogReader Constructor

LogReader Constructor NFX Class Library

Initializes a new instance of the LogReader class

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected LogReader(
    Stream stream
)
protected LogReader(
    Stream stream
)
Protected Sub New (
    stream As Stream
)
Protected Sub New (
    stream As Stream
)
protected:
LogReader(
    Stream^ stream
)
protected:
LogReader(
    Stream^ stream
)
new :
        stream : Stream -> LogReader
new :
        stream : Stream -> LogReader

Parameters

stream
Type: Online System.IO Stream
See Also
LogReader Class
LogReader Members
NFX.Log.Bin Namespace


LogReader Methods

LogReader Methods NFX Class Library

The LogReader type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Open | Opens the appropriate reader type from the stream
Public method | read |
Public method | ReadFromAround | Returns the lazy enumerable that fetches data from the point in time, optionally including time stamps
Public method | ReadFromStart | Returns the lazy enumerable that fetches data from the very log start, optionally including time stamps
Public method | seekForTimeStamp |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LogReader Class
NFX.Log.Bin Namespace


LogReader.Open Method

LogReader Open Method NFX Class Library

Opens the appropriate reader type from the stream

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static LogReader Open(
    Stream stream
)
public static LogReader Open(
    Stream stream
)
Public Shared Function Open (
    stream As Stream
) As LogReader
Public Shared Function Open (
    stream As Stream
) As LogReader
public:
static LogReader^ Open(
    Stream^ stream
)
public:
static LogReader^ Open(
    Stream^ stream
)
static member Open :
        stream : Stream -> LogReader
static member Open :
        stream : Stream -> LogReader

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: LogReader
See Also
LogReader Class
LogReader Members
NFX.Log.Bin Namespace


LogReader.read Method

LogReader read Method NFX Class Library

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Object> read(
    bool includeMetadata
)
public IEnumerable<Object> read(
    bool includeMetadata
)
Public Function read (
    includeMetadata As Boolean
) As IEnumerable(Of Object)
Public Function read (
    includeMetadata As Boolean
) As IEnumerable(Of Object)
public:
IEnumerable<Object^>^ read(
    bool includeMetadata
)
public:
IEnumerable<Object^>^ read(
    bool includeMetadata
)
member read :
        includeMetadata : bool -> IEnumerable<Object>
member read :
        includeMetadata : bool -> IEnumerable<Object>

Parameters

includeMetadata
Type: Online System Boolean

Return Value

Type: Online IEnumerable Online Object
See Also
LogReader Class
LogReader Members
NFX.Log.Bin Namespace


LogReader.ReadFromAround Method

LogReader ReadFromAround Method NFX Class Library

Returns the lazy enumerable that fetches data from the point in time, optionally including time stamps

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Object> ReadFromAround(
    DateTime startUTC,
    bool includeMetadata = true
)
public IEnumerable<Object> ReadFromAround(
    DateTime startUTC,
    bool includeMetadata = true
)
Public Function ReadFromAround (
    startUTC As DateTime,
    Optional includeMetadata As Boolean = true
) As IEnumerable(Of Object)
Public Function ReadFromAround (
    startUTC As DateTime,
    Optional includeMetadata As Boolean = true
) As IEnumerable(Of Object)
public:
IEnumerable<Object^>^ ReadFromAround(
    DateTime startUTC,
    bool includeMetadata = true
)
public:
IEnumerable<Object^>^ ReadFromAround(
    DateTime startUTC,
    bool includeMetadata = true
)
member ReadFromAround :
        startUTC : DateTime *
        ?includeMetadata : bool
(* Defaults:
        let _includeMetadata = defaultArg includeMetadata true
*)
-> IEnumerable<Object>
member ReadFromAround :
        startUTC : DateTime *
        ?includeMetadata : bool
(* Defaults:
        let _includeMetadata = defaultArg includeMetadata true
*)
-> IEnumerable<Object>

Parameters

startUTC
Type: Online System DateTime
includeMetadata (Optional)
Type: Online System Boolean

Return Value

Type: Online IEnumerable Online Object
See Also
LogReader Class
LogReader Members
NFX.Log.Bin Namespace


LogReader.ReadFromStart Method

LogReader ReadFromStart Method NFX Class Library

Returns the lazy enumerable that fetches data from the very log start, optionally including time stamps

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Object> ReadFromStart(
    bool includeMetadata = true
)
public IEnumerable<Object> ReadFromStart(
    bool includeMetadata = true
)
Public Function ReadFromStart (
    Optional includeMetadata As Boolean = true
) As IEnumerable(Of Object)
Public Function ReadFromStart (
    Optional includeMetadata As Boolean = true
) As IEnumerable(Of Object)
public:
IEnumerable<Object^>^ ReadFromStart(
    bool includeMetadata = true
)
public:
IEnumerable<Object^>^ ReadFromStart(
    bool includeMetadata = true
)
member ReadFromStart :
        ?includeMetadata : bool
(* Defaults:
        let _includeMetadata = defaultArg includeMetadata true
*)
-> IEnumerable<Object>
member ReadFromStart :
        ?includeMetadata : bool
(* Defaults:
        let _includeMetadata = defaultArg includeMetadata true
*)
-> IEnumerable<Object>

Parameters

includeMetadata (Optional)
Type: Online System Boolean

Return Value

Type: Online IEnumerable Online Object
See Also
LogReader Class
LogReader Members
NFX.Log.Bin Namespace


LogReader.seekForTimeStamp Method

LogReader seekForTimeStamp Method NFX Class Library

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void seekForTimeStamp(
    DateTime startUTC
)
public void seekForTimeStamp(
    DateTime startUTC
)
Public Sub seekForTimeStamp (
    startUTC As DateTime
)
Public Sub seekForTimeStamp (
    startUTC As DateTime
)
public:
void seekForTimeStamp(
    DateTime startUTC
)
public:
void seekForTimeStamp(
    DateTime startUTC
)
member seekForTimeStamp :
        startUTC : DateTime -> unit
member seekForTimeStamp :
        startUTC : DateTime -> unit

Parameters

startUTC
Type: Online System DateTime
See Also
LogReader Class
LogReader Members
NFX.Log.Bin Namespace


LogReader Properties

LogReader Properties NFX Class Library

The LogReader type exposes the following members.
Properties
 | Name | Description
Public property | Stream | Returns the underlying stream
Back to Top
See Also
LogReader Class
NFX.Log.Bin Namespace


LogReader.Stream Property

LogReader Stream Property NFX Class Library

Returns the underlying stream

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Stream Stream { get; }
public Stream Stream { get; }
Public ReadOnly Property Stream As Stream
    Get
Public ReadOnly Property Stream As Stream
    Get
public:
property Stream^ Stream {
    Stream^ get ();
}
public:
property Stream^ Stream {
    Stream^ get ();
}
member Stream : Stream with get
member Stream : Stream with get

Property Value

Type: Online Stream
See Also
LogReader Class
LogReader Members
NFX.Log.Bin Namespace


LogUTCTimeStamp Class

LogUTCTimeStamp Class NFX Class Library

Denotes a special surrogate structure that wraps DatTime in log. These structures get inserted in log automatically by binary log writers to indicate te point in time
Inheritance Hierarchy
Online System Object
NFX.Log.Bin LogUTCTimeStamp

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class LogUTCTimeStamp : ILogMetadata
public sealed class LogUTCTimeStamp : ILogMetadata
Public NotInheritable Class LogUTCTimeStamp
    Implements ILogMetadata
Public NotInheritable Class LogUTCTimeStamp
    Implements ILogMetadata
public ref class LogUTCTimeStamp sealed : ILogMetadata
public ref class LogUTCTimeStamp sealed : ILogMetadata
[<SealedAttribute>]
type LogUTCTimeStamp =
    class
        interface ILogMetadata
    end
[<SealedAttribute>]
type LogUTCTimeStamp =
    class
        interface ILogMetadata
    end
See Also
LogUTCTimeStamp Members
NFX.Log.Bin Namespace


LogUTCTimeStamp Members

LogUTCTimeStamp Members NFX Class Library

The LogUTCTimeStamp type exposes the following members.
Constructors
 | Name | Description
Protected method | LogUTCTimeStamp | Initializes a new instance of the LogUTCTimeStamp class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Value |
Back to Top
See Also
LogUTCTimeStamp Class
NFX.Log.Bin Namespace


LogUTCTimeStamp Constructor

LogUTCTimeStamp Constructor NFX Class Library

Initializes a new instance of the LogUTCTimeStamp class

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal LogUTCTimeStamp(
    DateTime utcValue
)
internal LogUTCTimeStamp(
    DateTime utcValue
)
Friend Sub New (
    utcValue As DateTime
)
Friend Sub New (
    utcValue As DateTime
)
internal:
LogUTCTimeStamp(
    DateTime utcValue
)
internal:
LogUTCTimeStamp(
    DateTime utcValue
)
new :
        utcValue : DateTime -> LogUTCTimeStamp
new :
        utcValue : DateTime -> LogUTCTimeStamp

Parameters

utcValue
Type: Online System DateTime
See Also
LogUTCTimeStamp Class
LogUTCTimeStamp Members
NFX.Log.Bin Namespace


LogUTCTimeStamp Fields

LogUTCTimeStamp Fields NFX Class Library

The LogUTCTimeStamp type exposes the following members.
Fields
 | Name | Description
Public field | Value |
Back to Top
See Also
LogUTCTimeStamp Class
NFX.Log.Bin Namespace


LogUTCTimeStamp.Value Field

LogUTCTimeStamp Value Field NFX Class Library

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly DateTime Value
public readonly DateTime Value
Public ReadOnly Value As DateTime
Public ReadOnly Value As DateTime
public:
initonly DateTime Value
public:
initonly DateTime Value
val Value: DateTime
val Value: DateTime

Field Value

Type: Online DateTime
See Also
LogUTCTimeStamp Class
LogUTCTimeStamp Members
NFX.Log.Bin Namespace


LogUTCTimeStamp Methods

LogUTCTimeStamp Methods NFX Class Library

The LogUTCTimeStamp type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LogUTCTimeStamp Class
NFX.Log.Bin Namespace


LogWriter Class

LogWriter Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Log.Bin LogWriter
NFX.Log.Bin SlimLogWriter

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class LogWriter
public abstract class LogWriter
Public MustInherit Class LogWriter
Public MustInherit Class LogWriter
public ref class LogWriter abstract
public ref class LogWriter abstract
[<AbstractClassAttribute>]
type LogWriter =  class end
[<AbstractClassAttribute>]
type LogWriter =  class end
See Also
LogWriter Members
NFX.Log.Bin Namespace


LogWriter Members

LogWriter Members NFX Class Library

The LogWriter type exposes the following members.
Constructors
 | Name | Description
Protected method | LogWriter | Initializes a new instance of the LogWriter class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LogWriter Class
NFX.Log.Bin Namespace


LogWriter Constructor

LogWriter Constructor NFX Class Library

Initializes a new instance of the LogWriter class

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected LogWriter(
    Stream stream
)
protected LogWriter(
    Stream stream
)
Protected Sub New (
    stream As Stream
)
Protected Sub New (
    stream As Stream
)
protected:
LogWriter(
    Stream^ stream
)
protected:
LogWriter(
    Stream^ stream
)
new :
        stream : Stream -> LogWriter
new :
        stream : Stream -> LogWriter

Parameters

stream
Type: Online System.IO Stream
See Also
LogWriter Class
LogWriter Members
NFX.Log.Bin Namespace


LogWriter Methods

LogWriter Methods NFX Class Library

The LogWriter type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LogWriter Class
NFX.Log.Bin Namespace


SlimLogReader Class

SlimLogReader Class NFX Class Library

Reads bin log in Slim format. The format does not support object versioning however it is very efficient in both space and speed
Inheritance Hierarchy
Online System Object
NFX.Log.Bin LogReader
NFX.Log.Bin SlimLogReader

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SlimLogReader : LogReader
public class SlimLogReader : LogReader
Public Class SlimLogReader
    Inherits LogReader
Public Class SlimLogReader
    Inherits LogReader
public ref class SlimLogReader : public LogReader
public ref class SlimLogReader : public LogReader
type SlimLogReader =
    class
        inherit LogReader
    end
type SlimLogReader =
    class
        inherit LogReader
    end
See Also
SlimLogReader Members
NFX.Log.Bin Namespace


SlimLogReader Members

SlimLogReader Members NFX Class Library

The SlimLogReader type exposes the following members.
Constructors
 | Name | Description
Public method | SlimLogReader | Initializes a new instance of the SlimLogReader class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | read | (Inherited from LogReader.)
Public method | ReadFromAround | Returns the lazy enumerable that fetches data from the point in time, optionally including time stamps (Inherited from LogReader.)
Public method | ReadFromStart | Returns the lazy enumerable that fetches data from the very log start, optionally including time stamps (Inherited from LogReader.)
Public method | seekForTimeStamp | (Inherited from LogReader.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Stream | Returns the underlying stream (Inherited from LogReader.)
Back to Top
See Also
SlimLogReader Class
NFX.Log.Bin Namespace


SlimLogReader Constructor

SlimLogReader Constructor NFX Class Library

Initializes a new instance of the SlimLogReader class

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SlimLogReader(
    Stream stream
)
public SlimLogReader(
    Stream stream
)
Public Sub New (
    stream As Stream
)
Public Sub New (
    stream As Stream
)
public:
SlimLogReader(
    Stream^ stream
)
public:
SlimLogReader(
    Stream^ stream
)
new :
        stream : Stream -> SlimLogReader
new :
        stream : Stream -> SlimLogReader

Parameters

stream
Type: Online System.IO Stream
See Also
SlimLogReader Class
SlimLogReader Members
NFX.Log.Bin Namespace


SlimLogReader Methods

SlimLogReader Methods NFX Class Library

The SlimLogReader type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | read | (Inherited from LogReader.)
Public method | ReadFromAround | Returns the lazy enumerable that fetches data from the point in time, optionally including time stamps (Inherited from LogReader.)
Public method | ReadFromStart | Returns the lazy enumerable that fetches data from the very log start, optionally including time stamps (Inherited from LogReader.)
Public method | seekForTimeStamp | (Inherited from LogReader.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SlimLogReader Class
NFX.Log.Bin Namespace


SlimLogReader Properties

SlimLogReader Properties NFX Class Library

The SlimLogReader type exposes the following members.
Properties
 | Name | Description
Public property | Stream | Returns the underlying stream (Inherited from LogReader.)
Back to Top
See Also
SlimLogReader Class
NFX.Log.Bin Namespace


SlimLogWriter Class

SlimLogWriter Class NFX Class Library

Writes bin log in Slim format. The format does not support object versioning however it is very efficient in both space and speed
Inheritance Hierarchy
Online System Object
NFX.Log.Bin LogWriter
NFX.Log.Bin SlimLogWriter

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SlimLogWriter : LogWriter
public class SlimLogWriter : LogWriter
Public Class SlimLogWriter
    Inherits LogWriter
Public Class SlimLogWriter
    Inherits LogWriter
public ref class SlimLogWriter : public LogWriter
public ref class SlimLogWriter : public LogWriter
type SlimLogWriter =
    class
        inherit LogWriter
    end
type SlimLogWriter =
    class
        inherit LogWriter
    end
See Also
SlimLogWriter Members
NFX.Log.Bin Namespace


SlimLogWriter Members

SlimLogWriter Members NFX Class Library

The SlimLogWriter type exposes the following members.
Constructors
 | Name | Description
Public method | SlimLogWriter | Initializes a new instance of the SlimLogWriter class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SlimLogWriter Class
NFX.Log.Bin Namespace


SlimLogWriter Constructor

SlimLogWriter Constructor NFX Class Library

Initializes a new instance of the SlimLogWriter class

Namespace: NFX.Log.Bin
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SlimLogWriter(
    Stream stream
)
public SlimLogWriter(
    Stream stream
)
Public Sub New (
    stream As Stream
)
Public Sub New (
    stream As Stream
)
public:
SlimLogWriter(
    Stream^ stream
)
public:
SlimLogWriter(
    Stream^ stream
)
new :
        stream : Stream -> SlimLogWriter
new :
        stream : Stream -> SlimLogWriter

Parameters

stream
Type: Online System.IO Stream
See Also
SlimLogWriter Class
SlimLogWriter Members
NFX.Log.Bin Namespace


SlimLogWriter Methods

SlimLogWriter Methods NFX Class Library

The SlimLogWriter type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SlimLogWriter Class
NFX.Log.Bin Namespace


NFX.Log.Destinations Namespace

NFX.Log.Destinations Namespace NFX Class Library

Various log destinations/sinks
Classes
 | Class | Description
Public class | CompositeDestination | Provides an abstraction of a wrap around another destinations
Public class | ConsoleDestination | Logs messages in stdio.console
Public class | CSVFileDestination | Provides a CSV file storage log destination implementation
Public class | DebugDestination | Provides a file storage destination implementation for debug and trace logging
Public class | Destination | Represents logging message destination - an abstract entity that messages are written to by LogService. Destinations must be efficient as they block logger thread. They provide failover mechanism when processing can not be completed. Once failed, the processing can try to be resumed after configurable interval. Destinations also provide optional SLA on the time it takes to perform actual message write - once exceeded destination is considered to have failed. Basic efficient filtering is provided for times, dates and levels. Complex C# expression-based filtering is also supported
Public class | Destination LevelsList |
Public class | FileDestination | Provides a file storage destination implementation
Public class | FloodFilter | Implements a destination group that stops message flood
Public class | LogServiceDestination | Implements a destination that is based on another instance of LogService, which provides asynchronous buffering and failover capabilities.
Public class | MemoryBufferDestination | Implements a destination that caches up to specified number of latest log messages in memory
Public class | MongoDBDestination | Implements destination that sends log messages into MongoDB
Public class | NullDestination | Log destination that does not log anything anywhere
Public class | SMTPDestination | Implements log destination that sends emails
Public class | SyslogDestination | Implements destination that sends messages to UNIX syslog using UDP datagrams
Public class | TextFileDestination | Provides a file storage destination implementation
Delegates
 | Delegate | Description
Public delegate | MessageFilterHandler | Delegate for message filtering


CompositeDestination Class

CompositeDestination Class NFX Class Library

Provides an abstraction of a wrap around another destinations
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Log.Destinations Destination
NFX.Log.Destinations CompositeDestination
NFX.Log.Destinations FloodFilter

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CompositeDestination : Destination
public class CompositeDestination : Destination
Public Class CompositeDestination
    Inherits Destination
Public Class CompositeDestination
    Inherits Destination
public ref class CompositeDestination : public Destination
public ref class CompositeDestination : public Destination
type CompositeDestination =
    class
        inherit Destination
    end
type CompositeDestination =
    class
        inherit Destination
    end
See Also
CompositeDestination Members
NFX.Log.Destinations Namespace


CompositeDestination Members

CompositeDestination Members NFX Class Library

The CompositeDestination type exposes the following members.
Constructors
 | Name | Description
Public method | CompositeDestination | Initializes a new instance of the CompositeDestination class
Public method | CompositeDestination( Destination ) | Initializes a new instance of the CompositeDestination class
Public method | CompositeDestination(String, Destination ) | Initializes a new instance of the CompositeDestination class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc | (Inherited from Destination.)
Public method | Close | (Overrides Destination Close .)
Public method | Configure | Configures specified destination (Inherited from Destination.)
Protected method | Destructor | (Overrides Destination Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure | (Overrides Destination DoConfigure(IConfigSectionNode).)
Protected method | DoPulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Protected method | DoSend | (Overrides Destination DoSend(Message).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Destination.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Destination.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | (Overrides Destination Open .)
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Public method | RegisterDestination | Adds a destination to this wrapper
Public method | Send | Sends the message into destination doing filter checks first. (Inherited from Destination.)
Protected method | SendRegularAndFailures | (Inherited from Destination.)
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message (Inherited from Destination.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UnRegisterDestination | Removes a destiantion from this wrapper, returns true if destination was found and removed
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one (Inherited from Destination.)
Public field | Before | Allows to insert a destination right before this one (Inherited from Destination.)
Protected field | m_Name | (Inherited from Destination.)
Protected field | m_Owner | (Inherited from Destination.)
Back to Top
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f (Inherited from Destination.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages (Inherited from Destination.)
Public property | Destinations | Returns destinations that this destination wraps. This call is thread safe
Public property | DirectorLog | (Inherited from Destination.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages (Inherited from Destination.)
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages (Inherited from Destination.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public property | Failover | Sets destination name used for failover of this one (Inherited from Destination.)
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result (Inherited from Destination.)
Public property | FilterMethod | References message filtering method or null (Inherited from Destination.)
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default. (Inherited from Destination.)
Public property | LastError | Returns last error that this destination has encountered (Inherited from Destination.)
Public property | Levels | (Inherited from Destination.)
Public property | MaxLevel | Imposes a maximum log level constraint (Inherited from Destination.)
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy (Inherited from Destination.)
Public property | MinLevel | Imposes a minimum log level constraint (Inherited from Destination.)
Public property | Name | Provides mnemonic destination name (Inherited from Destination.)
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored (Inherited from Destination.)
Public property | Owner | Returns a composite destination that ownes this destination or null (Inherited from Destination.)
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms (Inherited from Destination.)
Public property | Service | References a log service that this destination services (Inherited from Destination.)
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages (Inherited from Destination.)
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages (Inherited from Destination.)
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true (Inherited from Destination.)
Back to Top
See Also
CompositeDestination Class
NFX.Log.Destinations Namespace


CompositeDestination Constructor

CompositeDestination Constructor NFX Class Library

Overload List
 | Name | Description
Public method | CompositeDestination | Initializes a new instance of the CompositeDestination class
Public method | CompositeDestination( Destination ) | Initializes a new instance of the CompositeDestination class
Public method | CompositeDestination(String, Destination ) | Initializes a new instance of the CompositeDestination class
Back to Top
See Also
CompositeDestination Class
CompositeDestination Members
NFX.Log.Destinations Namespace


CompositeDestination Constructor

CompositeDestination Constructor NFX Class Library

Initializes a new instance of the CompositeDestination class

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CompositeDestination()
public CompositeDestination()
Public Sub New
Public Sub New
public:
CompositeDestination()
public:
CompositeDestination()
new : unit -> CompositeDestination
new : unit -> CompositeDestination
See Also
CompositeDestination Class
CompositeDestination Members
CompositeDestination Overload
NFX.Log.Destinations Namespace


CompositeDestination Constructor (Destination[])

CompositeDestination Constructor ( Destination ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CompositeDestination class

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CompositeDestination(
    params Destination[] inner
)
public CompositeDestination(
    params Destination[] inner
)
Public Sub New (
    ParamArray inner As Destination()
)
Public Sub New (
    ParamArray inner As Destination()
)
public:
CompositeDestination(
    ... array<Destination^>^ inner
)
public:
CompositeDestination(
    ... array<Destination^>^ inner
)
new :
        inner : Destination[] -> CompositeDestination
new :
        inner : Destination[] -> CompositeDestination

Parameters

inner
Type: NFX.Log.Destinations Destination
See Also
CompositeDestination Class
CompositeDestination Members
CompositeDestination Overload
NFX.Log.Destinations Namespace


CompositeDestination Constructor (String, Destination[])

CompositeDestination Constructor (String, Destination ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CompositeDestination class

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CompositeDestination(
    string name,
    params Destination[] inner
)
public CompositeDestination(
    string name,
    params Destination[] inner
)
Public Sub New (
    name As String,
    ParamArray inner As Destination()
)
Public Sub New (
    name As String,
    ParamArray inner As Destination()
)
public:
CompositeDestination(
    String^ name,
    ... array<Destination^>^ inner
)
public:
CompositeDestination(
    String^ name,
    ... array<Destination^>^ inner
)
new :
        name : string *
        inner : Destination[] -> CompositeDestination
new :
        name : string *
        inner : Destination[] -> CompositeDestination

Parameters

name
Type: Online System String
inner
Type: NFX.Log.Destinations Destination
See Also
CompositeDestination Class
CompositeDestination Members
CompositeDestination Overload
NFX.Log.Destinations Namespace


CompositeDestination Fields

CompositeDestination Fields NFX Class Library

The CompositeDestination type exposes the following members.
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one (Inherited from Destination.)
Public field | Before | Allows to insert a destination right before this one (Inherited from Destination.)
Protected field | m_Name | (Inherited from Destination.)
Protected field | m_Owner | (Inherited from Destination.)
Back to Top
See Also
CompositeDestination Class
NFX.Log.Destinations Namespace


CompositeDestination Methods

CompositeDestination Methods NFX Class Library

The CompositeDestination type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc | (Inherited from Destination.)
Public method | Close | (Overrides Destination Close .)
Public method | Configure | Configures specified destination (Inherited from Destination.)
Protected method | Destructor | (Overrides Destination Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure | (Overrides Destination DoConfigure(IConfigSectionNode).)
Protected method | DoPulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Protected method | DoSend | (Overrides Destination DoSend(Message).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Destination.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Destination.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | (Overrides Destination Open .)
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Public method | RegisterDestination | Adds a destination to this wrapper
Public method | Send | Sends the message into destination doing filter checks first. (Inherited from Destination.)
Protected method | SendRegularAndFailures | (Inherited from Destination.)
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message (Inherited from Destination.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UnRegisterDestination | Removes a destiantion from this wrapper, returns true if destination was found and removed
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CompositeDestination Class
NFX.Log.Destinations Namespace


CompositeDestination.Close Method

CompositeDestination Close Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Close()
public override void Close()
Public Overrides Sub Close
Public Overrides Sub Close
public:
virtual void Close() override
public:
virtual void Close() override
abstract Close : unit -> unit
override Close : unit -> unit
abstract Close : unit -> unit
override Close : unit -> unit
See Also
CompositeDestination Class
CompositeDestination Members
NFX.Log.Destinations Namespace


CompositeDestination.Destructor Method

CompositeDestination Destructor Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
CompositeDestination Class
CompositeDestination Members
NFX.Log.Destinations Namespace


CompositeDestination.DoConfigure Method

CompositeDestination DoConfigure Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
CompositeDestination Class
CompositeDestination Members
NFX.Log.Destinations Namespace


CompositeDestination.DoSend Method

CompositeDestination DoSend Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoSend(
    Message entry
)
protected internal override void DoSend(
    Message entry
)
Protected Friend Overrides Sub DoSend (
    entry As Message
)
Protected Friend Overrides Sub DoSend (
    entry As Message
)
protected public:
virtual void DoSend(
    Message^ entry
) override
protected public:
virtual void DoSend(
    Message^ entry
) override
abstract DoSend :
        entry : Message -> unit
override DoSend :
        entry : Message -> unit
abstract DoSend :
        entry : Message -> unit
override DoSend :
        entry : Message -> unit

Parameters

entry
Type: NFX.Log Message
See Also
CompositeDestination Class
CompositeDestination Members
NFX.Log.Destinations Namespace


CompositeDestination.Open Method

CompositeDestination Open Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Open()
public override void Open()
Public Overrides Sub Open
Public Overrides Sub Open
public:
virtual void Open() override
public:
virtual void Open() override
abstract Open : unit -> unit
override Open : unit -> unit
abstract Open : unit -> unit
override Open : unit -> unit
See Also
CompositeDestination Class
CompositeDestination Members
NFX.Log.Destinations Namespace


CompositeDestination.RegisterDestination Method

CompositeDestination RegisterDestination Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Adds a destination to this wrapper

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void RegisterDestination(
    Destination dest
)
public void RegisterDestination(
    Destination dest
)
Public Sub RegisterDestination (
    dest As Destination
)
Public Sub RegisterDestination (
    dest As Destination
)
public:
void RegisterDestination(
    Destination^ dest
)
public:
void RegisterDestination(
    Destination^ dest
)
member RegisterDestination :
        dest : Destination -> unit
member RegisterDestination :
        dest : Destination -> unit

Parameters

dest
Type: NFX.Log.Destinations Destination
See Also
CompositeDestination Class
CompositeDestination Members
NFX.Log.Destinations Namespace


CompositeDestination.UnRegisterDestination Method

CompositeDestination UnRegisterDestination Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Removes a destiantion from this wrapper, returns true if destination was found and removed

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool UnRegisterDestination(
    Destination dest
)
public bool UnRegisterDestination(
    Destination dest
)
Public Function UnRegisterDestination (
    dest As Destination
) As Boolean
Public Function UnRegisterDestination (
    dest As Destination
) As Boolean
public:
bool UnRegisterDestination(
    Destination^ dest
)
public:
bool UnRegisterDestination(
    Destination^ dest
)
member UnRegisterDestination :
        dest : Destination -> bool
member UnRegisterDestination :
        dest : Destination -> bool

Parameters

dest
Type: NFX.Log.Destinations Destination

Return Value

Type: Online Boolean
See Also
CompositeDestination Class
CompositeDestination Members
NFX.Log.Destinations Namespace


CompositeDestination Properties

CompositeDestination Properties NFX Class Library

The CompositeDestination type exposes the following members.
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f (Inherited from Destination.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages (Inherited from Destination.)
Public property | Destinations | Returns destinations that this destination wraps. This call is thread safe
Public property | DirectorLog | (Inherited from Destination.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages (Inherited from Destination.)
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages (Inherited from Destination.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public property | Failover | Sets destination name used for failover of this one (Inherited from Destination.)
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result (Inherited from Destination.)
Public property | FilterMethod | References message filtering method or null (Inherited from Destination.)
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default. (Inherited from Destination.)
Public property | LastError | Returns last error that this destination has encountered (Inherited from Destination.)
Public property | Levels | (Inherited from Destination.)
Public property | MaxLevel | Imposes a maximum log level constraint (Inherited from Destination.)
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy (Inherited from Destination.)
Public property | MinLevel | Imposes a minimum log level constraint (Inherited from Destination.)
Public property | Name | Provides mnemonic destination name (Inherited from Destination.)
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored (Inherited from Destination.)
Public property | Owner | Returns a composite destination that ownes this destination or null (Inherited from Destination.)
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms (Inherited from Destination.)
Public property | Service | References a log service that this destination services (Inherited from Destination.)
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages (Inherited from Destination.)
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages (Inherited from Destination.)
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true (Inherited from Destination.)
Back to Top
See Also
CompositeDestination Class
NFX.Log.Destinations Namespace


CompositeDestination.Destinations Property

CompositeDestination Destinations Property NFX Class Library

Returns destinations that this destination wraps. This call is thread safe

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Destination> Destinations { get; }
public IEnumerable<Destination> Destinations { get; }
Public ReadOnly Property Destinations As IEnumerable(Of Destination)
    Get
Public ReadOnly Property Destinations As IEnumerable(Of Destination)
    Get
public:
property IEnumerable<Destination^>^ Destinations {
    IEnumerable<Destination^>^ get ();
}
public:
property IEnumerable<Destination^>^ Destinations {
    IEnumerable<Destination^>^ get ();
}
member Destinations : IEnumerable<Destination> with get
member Destinations : IEnumerable<Destination> with get

Property Value

Type: Online IEnumerable Destination
See Also
CompositeDestination Class
CompositeDestination Members
NFX.Log.Destinations Namespace


ConsoleDestination Class

ConsoleDestination Class NFX Class Library

Logs messages in stdio.console
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Log.Destinations Destination
NFX.Log.Destinations ConsoleDestination

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ConsoleDestination : Destination
public class ConsoleDestination : Destination
Public Class ConsoleDestination
    Inherits Destination
Public Class ConsoleDestination
    Inherits Destination
public ref class ConsoleDestination : public Destination
public ref class ConsoleDestination : public Destination
type ConsoleDestination =
    class
        inherit Destination
    end
type ConsoleDestination =
    class
        inherit Destination
    end
See Also
ConsoleDestination Members
NFX.Log.Destinations Namespace


ConsoleDestination Members

ConsoleDestination Members NFX Class Library

The ConsoleDestination type exposes the following members.
Constructors
 | Name | Description
Public method | ConsoleDestination | Initializes a new instance of the ConsoleDestination class
Public method | ConsoleDestination(String) | Initializes a new instance of the ConsoleDestination class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc | (Inherited from Destination.)
Public method | Close | Deactivates destination (Inherited from Destination.)
Public method | Configure | Configures specified destination (Inherited from Destination.)
Protected method | Destructor | (Inherited from Destination.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure | Override to perform derivative-specific configuration (Inherited from Destination.)
Protected method | DoPulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Protected method | DoSend | (Overrides Destination DoSend(Message).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Destination.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Destination.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | Activates destination by preparing it to start operation (Inherited from Destination.)
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Public method | Send | Sends the message into destination doing filter checks first. (Inherited from Destination.)
Protected method | SendRegularAndFailures | (Inherited from Destination.)
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message (Inherited from Destination.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one (Inherited from Destination.)
Public field | Before | Allows to insert a destination right before this one (Inherited from Destination.)
Protected field | m_Name | (Inherited from Destination.)
Protected field | m_Owner | (Inherited from Destination.)
Back to Top
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f (Inherited from Destination.)
Public property | Colored |
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages (Inherited from Destination.)
Public property | DirectorLog | (Inherited from Destination.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages (Inherited from Destination.)
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages (Inherited from Destination.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public property | Failover | Sets destination name used for failover of this one (Inherited from Destination.)
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result (Inherited from Destination.)
Public property | FilterMethod | References message filtering method or null (Inherited from Destination.)
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default. (Inherited from Destination.)
Public property | LastError | Returns last error that this destination has encountered (Inherited from Destination.)
Public property | Levels | (Inherited from Destination.)
Public property | LogTimeFormat | Time format for log line entries
Public property | MaxLevel | Imposes a maximum log level constraint (Inherited from Destination.)
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy (Inherited from Destination.)
Public property | MinLevel | Imposes a minimum log level constraint (Inherited from Destination.)
Public property | Name | Provides mnemonic destination name (Inherited from Destination.)
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored (Inherited from Destination.)
Public property | Owner | Returns a composite destination that ownes this destination or null (Inherited from Destination.)
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms (Inherited from Destination.)
Public property | Service | References a log service that this destination services (Inherited from Destination.)
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages (Inherited from Destination.)
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages (Inherited from Destination.)
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true (Inherited from Destination.)
Back to Top
See Also
ConsoleDestination Class
NFX.Log.Destinations Namespace


ConsoleDestination Constructor

ConsoleDestination Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ConsoleDestination | Initializes a new instance of the ConsoleDestination class
Public method | ConsoleDestination(String) | Initializes a new instance of the ConsoleDestination class
Back to Top
See Also
ConsoleDestination Class
ConsoleDestination Members
NFX.Log.Destinations Namespace


ConsoleDestination Constructor

ConsoleDestination Constructor NFX Class Library

Initializes a new instance of the ConsoleDestination class

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConsoleDestination()
public ConsoleDestination()
Public Sub New
Public Sub New
public:
ConsoleDestination()
public:
ConsoleDestination()
new : unit -> ConsoleDestination
new : unit -> ConsoleDestination
See Also
ConsoleDestination Class
ConsoleDestination Members
ConsoleDestination Overload
NFX.Log.Destinations Namespace


ConsoleDestination Constructor (String)

ConsoleDestination Constructor (String) NFX Class Library

Initializes a new instance of the ConsoleDestination class

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConsoleDestination(
    string name
)
public ConsoleDestination(
    string name
)
Public Sub New (
    name As String
)
Public Sub New (
    name As String
)
public:
ConsoleDestination(
    String^ name
)
public:
ConsoleDestination(
    String^ name
)
new :
        name : string -> ConsoleDestination
new :
        name : string -> ConsoleDestination

Parameters

name
Type: Online System String
See Also
ConsoleDestination Class
ConsoleDestination Members
ConsoleDestination Overload
NFX.Log.Destinations Namespace


ConsoleDestination Fields

ConsoleDestination Fields NFX Class Library

The ConsoleDestination type exposes the following members.
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one (Inherited from Destination.)
Public field | Before | Allows to insert a destination right before this one (Inherited from Destination.)
Protected field | m_Name | (Inherited from Destination.)
Protected field | m_Owner | (Inherited from Destination.)
Back to Top
See Also
ConsoleDestination Class
NFX.Log.Destinations Namespace


ConsoleDestination Methods

ConsoleDestination Methods NFX Class Library

The ConsoleDestination type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc | (Inherited from Destination.)
Public method | Close | Deactivates destination (Inherited from Destination.)
Public method | Configure | Configures specified destination (Inherited from Destination.)
Protected method | Destructor | (Inherited from Destination.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure | Override to perform derivative-specific configuration (Inherited from Destination.)
Protected method | DoPulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Protected method | DoSend | (Overrides Destination DoSend(Message).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Destination.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Destination.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | Activates destination by preparing it to start operation (Inherited from Destination.)
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Public method | Send | Sends the message into destination doing filter checks first. (Inherited from Destination.)
Protected method | SendRegularAndFailures | (Inherited from Destination.)
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message (Inherited from Destination.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ConsoleDestination Class
NFX.Log.Destinations Namespace


ConsoleDestination.DoSend Method

ConsoleDestination DoSend Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoSend(
    Message msg
)
protected internal override void DoSend(
    Message msg
)
Protected Friend Overrides Sub DoSend (
    msg As Message
)
Protected Friend Overrides Sub DoSend (
    msg As Message
)
protected public:
virtual void DoSend(
    Message^ msg
) override
protected public:
virtual void DoSend(
    Message^ msg
) override
abstract DoSend :
        msg : Message -> unit
override DoSend :
        msg : Message -> unit
abstract DoSend :
        msg : Message -> unit
override DoSend :
        msg : Message -> unit

Parameters

msg
Type: NFX.Log Message
See Also
ConsoleDestination Class
ConsoleDestination Members
NFX.Log.Destinations Namespace


ConsoleDestination Properties

ConsoleDestination Properties NFX Class Library

The ConsoleDestination type exposes the following members.
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f (Inherited from Destination.)
Public property | Colored |
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages (Inherited from Destination.)
Public property | DirectorLog | (Inherited from Destination.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages (Inherited from Destination.)
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages (Inherited from Destination.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public property | Failover | Sets destination name used for failover of this one (Inherited from Destination.)
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result (Inherited from Destination.)
Public property | FilterMethod | References message filtering method or null (Inherited from Destination.)
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default. (Inherited from Destination.)
Public property | LastError | Returns last error that this destination has encountered (Inherited from Destination.)
Public property | Levels | (Inherited from Destination.)
Public property | LogTimeFormat | Time format for log line entries
Public property | MaxLevel | Imposes a maximum log level constraint (Inherited from Destination.)
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy (Inherited from Destination.)
Public property | MinLevel | Imposes a minimum log level constraint (Inherited from Destination.)
Public property | Name | Provides mnemonic destination name (Inherited from Destination.)
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored (Inherited from Destination.)
Public property | Owner | Returns a composite destination that ownes this destination or null (Inherited from Destination.)
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms (Inherited from Destination.)
Public property | Service | References a log service that this destination services (Inherited from Destination.)
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages (Inherited from Destination.)
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages (Inherited from Destination.)
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true (Inherited from Destination.)
Back to Top
See Also
ConsoleDestination Class
NFX.Log.Destinations Namespace


ConsoleDestination.Colored Property

ConsoleDestination Colored Property NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool Colored { get; set; }
[ConfigAttribute]
public bool Colored { get; set; }
<ConfigAttribute>
Public Property Colored As Boolean
    Get
    Set
<ConfigAttribute>
Public Property Colored As Boolean
    Get
    Set
public:
[ConfigAttribute]
property bool Colored {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute]
property bool Colored {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute>]
member Colored : bool with get, set
[<ConfigAttribute>]
member Colored : bool with get, set

Property Value

Type: Online Boolean
See Also
ConsoleDestination Class
ConsoleDestination Members
NFX.Log.Destinations Namespace


ConsoleDestination.LogTimeFormat Property

ConsoleDestination LogTimeFormat Property NFX Class Library

Time format for log line entries

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string LogTimeFormat { get; set; }
[ConfigAttribute]
public string LogTimeFormat { get; set; }
<ConfigAttribute>
Public Property LogTimeFormat As String
    Get
    Set
<ConfigAttribute>
Public Property LogTimeFormat As String
    Get
    Set
public:
[ConfigAttribute]
property String^ LogTimeFormat {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ LogTimeFormat {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member LogTimeFormat : string with get, set
[<ConfigAttribute>]
member LogTimeFormat : string with get, set

Property Value

Type: Online String
See Also
ConsoleDestination Class
ConsoleDestination Members
NFX.Log.Destinations Namespace


CSVFileDestination Class

CSVFileDestination Class NFX Class Library

Provides a CSV file storage log destination implementation
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Log.Destinations Destination
NFX.Log.Destinations FileDestination
NFX.Log.Destinations TextFileDestination
NFX.Log.Destinations CSVFileDestination

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CSVFileDestination : TextFileDestination
public class CSVFileDestination : TextFileDestination
Public Class CSVFileDestination
    Inherits TextFileDestination
Public Class CSVFileDestination
    Inherits TextFileDestination
public ref class CSVFileDestination : public TextFileDestination
public ref class CSVFileDestination : public TextFileDestination
type CSVFileDestination =
    class
        inherit TextFileDestination
    end
type CSVFileDestination =
    class
        inherit TextFileDestination
    end
See Also
CSVFileDestination Members
NFX.Log.Destinations Namespace


CSVFileDestination Members

CSVFileDestination Members NFX Class Library

The CSVFileDestination type exposes the following members.
Constructors
 | Name | Description
Public method | CSVFileDestination | Initializes a new instance of the CSVFileDestination class
Public method | CSVFileDestination(String) | Initializes a new instance of the CSVFileDestination class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc | (Inherited from Destination.)
Public method | Close | (Inherited from FileDestination.)
Public method | Configure | Configures specified destination (Inherited from Destination.)
Protected method | Destructor | (Inherited from Destination.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoCloseStream | (Inherited from TextFileDestination.)
Protected method | DoConfigure | Override to perform derivative-specific configuration (Inherited from Destination.)
Protected method | DoFormatMessage | Spools instance data in CSV format for storage in a file destination (Overrides TextFileDestination DoFormatMessage(Message).)
Protected method | DoOpenStream | (Inherited from TextFileDestination.)
Protected method | DoPulse | (Inherited from TextFileDestination.)
Protected method | DoSend | Override DoFormatMessage() instead (Inherited from FileDestination.)
Protected method | DoWriteMessage | Warning: don't override this method in derived destinations, use DoFormatMessage() instead! (Inherited from TextFileDestination.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Destination.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Destination.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetDestinationFileName | (Inherited from FileDestination.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | MessageToCSVLine |
Public method | Open | (Inherited from FileDestination.)
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Public method | Send | Sends the message into destination doing filter checks first. (Inherited from Destination.)
Protected method | SendRegularAndFailures | (Inherited from Destination.)
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message (Inherited from Destination.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one (Inherited from Destination.)
Public field | Before | Allows to insert a destination right before this one (Inherited from Destination.)
 | DEFAULT_LOG_TIME_FORMAT |
Protected field | m_FileName | (Inherited from FileDestination.)
Protected field | m_Name | (Inherited from Destination.)
Protected field | m_Owner | (Inherited from Destination.)
Protected field | m_Path | (Inherited from FileDestination.)
Protected field | m_Stream | (Inherited from FileDestination.)
Back to Top
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f (Inherited from Destination.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages (Inherited from Destination.)
Protected property | DefaultFileName | (Overrides FileDestination DefaultFileName.)
Public property | DirectorLog | (Inherited from Destination.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages (Inherited from Destination.)
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages (Inherited from Destination.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public property | Failover | Sets destination name used for failover of this one (Inherited from Destination.)
Public property | FileName | File name may include environment variables (e.g. ~home), and use macros to specify time "$(~home)$(@::now fmt=yyyyMMdd utc=false)-$($name).log". Pass "utc=true" argument to use UTC (Inherited from FileDestination.)
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result (Inherited from Destination.)
Public property | FilterMethod | References message filtering method or null (Inherited from Destination.)
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default. (Inherited from Destination.)
Public property | LastError | Returns last error that this destination has encountered (Inherited from Destination.)
Public property | Levels | (Inherited from Destination.)
Public property | LogTimeFormat | Sets time formatting for CSV log line
Public property | MaxLevel | Imposes a maximum log level constraint (Inherited from Destination.)
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy (Inherited from Destination.)
Public property | MinLevel | Imposes a minimum log level constraint (Inherited from Destination.)
Public property | Name | Provides mnemonic destination name (Inherited from Destination.)
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored (Inherited from Destination.)
Public property | Owner | Returns a composite destination that ownes this destination or null (Inherited from Destination.)
Public property | Path | (Inherited from FileDestination.)
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms (Inherited from Destination.)
Public property | Service | References a log service that this destination services (Inherited from Destination.)
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages (Inherited from Destination.)
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages (Inherited from Destination.)
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true (Inherited from Destination.)
Back to Top
See Also
CSVFileDestination Class
NFX.Log.Destinations Namespace


CSVFileDestination Constructor

CSVFileDestination Constructor NFX Class Library

Overload List
 | Name | Description
Public method | CSVFileDestination | Initializes a new instance of the CSVFileDestination class
Public method | CSVFileDestination(String) | Initializes a new instance of the CSVFileDestination class
Back to Top
See Also
CSVFileDestination Class
CSVFileDestination Members
NFX.Log.Destinations Namespace


CSVFileDestination Constructor

CSVFileDestination Constructor NFX Class Library

Initializes a new instance of the CSVFileDestination class

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CSVFileDestination()
public CSVFileDestination()
Public Sub New
Public Sub New
public:
CSVFileDestination()
public:
CSVFileDestination()
new : unit -> CSVFileDestination
new : unit -> CSVFileDestination
See Also
CSVFileDestination Class
CSVFileDestination Members
CSVFileDestination Overload
NFX.Log.Destinations Namespace


CSVFileDestination Constructor (String)

CSVFileDestination Constructor (String) NFX Class Library

Initializes a new instance of the CSVFileDestination class

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CSVFileDestination(
    string name
)
public CSVFileDestination(
    string name
)
Public Sub New (
    name As String
)
Public Sub New (
    name As String
)
public:
CSVFileDestination(
    String^ name
)
public:
CSVFileDestination(
    String^ name
)
new :
        name : string -> CSVFileDestination
new :
        name : string -> CSVFileDestination

Parameters

name
Type: Online System String
See Also
CSVFileDestination Class
CSVFileDestination Members
CSVFileDestination Overload
NFX.Log.Destinations Namespace


CSVFileDestination Fields

CSVFileDestination Fields NFX Class Library

The CSVFileDestination type exposes the following members.
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one (Inherited from Destination.)
Public field | Before | Allows to insert a destination right before this one (Inherited from Destination.)
 | DEFAULT_LOG_TIME_FORMAT |
Protected field | m_FileName | (Inherited from FileDestination.)
Protected field | m_Name | (Inherited from Destination.)
Protected field | m_Owner | (Inherited from Destination.)
Protected field | m_Path | (Inherited from FileDestination.)
Protected field | m_Stream | (Inherited from FileDestination.)
Back to Top
See Also
CSVFileDestination Class
NFX.Log.Destinations Namespace


CSVFileDestination.DEFAULT_LOG_TIME_FORMAT Field

CSVFileDestination DEFAULT_LOG_TIME_FORMAT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_LOG_TIME_FORMAT
public const string DEFAULT_LOG_TIME_FORMAT
Public Const DEFAULT_LOG_TIME_FORMAT As String
Public Const DEFAULT_LOG_TIME_FORMAT As String
public:
literal String^ DEFAULT_LOG_TIME_FORMAT
public:
literal String^ DEFAULT_LOG_TIME_FORMAT
static val mutable DEFAULT_LOG_TIME_FORMAT: string
static val mutable DEFAULT_LOG_TIME_FORMAT: string

Field Value

Type: Online String
See Also
CSVFileDestination Class
CSVFileDestination Members
NFX.Log.Destinations Namespace


CSVFileDestination Methods

CSVFileDestination Methods NFX Class Library

The CSVFileDestination type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc | (Inherited from Destination.)
Public method | Close | (Inherited from FileDestination.)
Public method | Configure | Configures specified destination (Inherited from Destination.)
Protected method | Destructor | (Inherited from Destination.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoCloseStream | (Inherited from TextFileDestination.)
Protected method | DoConfigure | Override to perform derivative-specific configuration (Inherited from Destination.)
Protected method | DoFormatMessage | Spools instance data in CSV format for storage in a file destination (Overrides TextFileDestination DoFormatMessage(Message).)
Protected method | DoOpenStream | (Inherited from TextFileDestination.)
Protected method | DoPulse | (Inherited from TextFileDestination.)
Protected method | DoSend | Override DoFormatMessage() instead (Inherited from FileDestination.)
Protected method | DoWriteMessage | Warning: don't override this method in derived destinations, use DoFormatMessage() instead! (Inherited from TextFileDestination.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Destination.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Destination.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetDestinationFileName | (Inherited from FileDestination.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | MessageToCSVLine |
Public method | Open | (Inherited from FileDestination.)
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Public method | Send | Sends the message into destination doing filter checks first. (Inherited from Destination.)
Protected method | SendRegularAndFailures | (Inherited from Destination.)
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message (Inherited from Destination.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CSVFileDestination Class
NFX.Log.Destinations Namespace


CSVFileDestination.DoFormatMessage Method

CSVFileDestination DoFormatMessage Method NFX Class Library

Spools instance data in CSV format for storage in a file destination

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override string DoFormatMessage(
    Message msg
)
protected override string DoFormatMessage(
    Message msg
)
Protected Overrides Function DoFormatMessage (
    msg As Message
) As String
Protected Overrides Function DoFormatMessage (
    msg As Message
) As String
protected:
virtual String^ DoFormatMessage(
    Message^ msg
) override
protected:
virtual String^ DoFormatMessage(
    Message^ msg
) override
abstract DoFormatMessage :
        msg : Message -> string
override DoFormatMessage :
        msg : Message -> string
abstract DoFormatMessage :
        msg : Message -> string
override DoFormatMessage :
        msg : Message -> string

Parameters

msg
Type: NFX.Log Message

Return Value

Type: Online String
See Also
CSVFileDestination Class
CSVFileDestination Members
NFX.Log.Destinations Namespace


CSVFileDestination.MessageToCSVLine Method

CSVFileDestination MessageToCSVLine Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string MessageToCSVLine(
    Message msg,
    string logTimeFormat = null
)
public static string MessageToCSVLine(
    Message msg,
    string logTimeFormat = null
)
Public Shared Function MessageToCSVLine (
    msg As Message,
    Optional logTimeFormat As String = Nothing
) As String
Public Shared Function MessageToCSVLine (
    msg As Message,
    Optional logTimeFormat As String = Nothing
) As String
public:
static String^ MessageToCSVLine(
    Message^ msg,
    String^ logTimeFormat = nullptr
)
public:
static String^ MessageToCSVLine(
    Message^ msg,
    String^ logTimeFormat = nullptr
)
static member MessageToCSVLine :
        msg : Message *
        ?logTimeFormat : string
(* Defaults:
        let _logTimeFormat = defaultArg logTimeFormat null
*)
-> string
static member MessageToCSVLine :
        msg : Message *
        ?logTimeFormat : string
(* Defaults:
        let _logTimeFormat = defaultArg logTimeFormat null
*)
-> string

Parameters

msg
Type: NFX.Log Message
logTimeFormat (Optional)
Type: Online System String

Return Value

Type: Online String
See Also
CSVFileDestination Class
CSVFileDestination Members
NFX.Log.Destinations Namespace


CSVFileDestination Properties

CSVFileDestination Properties NFX Class Library

The CSVFileDestination type exposes the following members.
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f (Inherited from Destination.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages (Inherited from Destination.)
Protected property | DefaultFileName | (Overrides FileDestination DefaultFileName.)
Public property | DirectorLog | (Inherited from Destination.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages (Inherited from Destination.)
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages (Inherited from Destination.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public property | Failover | Sets destination name used for failover of this one (Inherited from Destination.)
Public property | FileName | File name may include environment variables (e.g. ~home), and use macros to specify time "$(~home)$(@::now fmt=yyyyMMdd utc=false)-$($name).log". Pass "utc=true" argument to use UTC (Inherited from FileDestination.)
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result (Inherited from Destination.)
Public property | FilterMethod | References message filtering method or null (Inherited from Destination.)
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default. (Inherited from Destination.)
Public property | LastError | Returns last error that this destination has encountered (Inherited from Destination.)
Public property | Levels | (Inherited from Destination.)
Public property | LogTimeFormat | Sets time formatting for CSV log line
Public property | MaxLevel | Imposes a maximum log level constraint (Inherited from Destination.)
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy (Inherited from Destination.)
Public property | MinLevel | Imposes a minimum log level constraint (Inherited from Destination.)
Public property | Name | Provides mnemonic destination name (Inherited from Destination.)
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored (Inherited from Destination.)
Public property | Owner | Returns a composite destination that ownes this destination or null (Inherited from Destination.)
Public property | Path | (Inherited from FileDestination.)
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms (Inherited from Destination.)
Public property | Service | References a log service that this destination services (Inherited from Destination.)
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages (Inherited from Destination.)
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages (Inherited from Destination.)
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true (Inherited from Destination.)
Back to Top
See Also
CSVFileDestination Class
NFX.Log.Destinations Namespace


CSVFileDestination.DefaultFileName Property

CSVFileDestination DefaultFileName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override string DefaultFileName { get; }
protected override string DefaultFileName { get; }
Protected Overrides ReadOnly Property DefaultFileName As String
    Get
Protected Overrides ReadOnly Property DefaultFileName As String
    Get
protected:
virtual property String^ DefaultFileName {
    String^ get () override;
}
protected:
virtual property String^ DefaultFileName {
    String^ get () override;
}
abstract DefaultFileName : string with get
override DefaultFileName : string with get
abstract DefaultFileName : string with get
override DefaultFileName : string with get

Property Value

Type: Online String
See Also
CSVFileDestination Class
CSVFileDestination Members
NFX.Log.Destinations Namespace


CSVFileDestination.LogTimeFormat Property

CSVFileDestination LogTimeFormat Property NFX Class Library

Sets time formatting for CSV log line

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string LogTimeFormat { get; set; }
[ConfigAttribute]
public string LogTimeFormat { get; set; }
<ConfigAttribute>
Public Property LogTimeFormat As String
    Get
    Set
<ConfigAttribute>
Public Property LogTimeFormat As String
    Get
    Set
public:
[ConfigAttribute]
property String^ LogTimeFormat {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ LogTimeFormat {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member LogTimeFormat : string with get, set
[<ConfigAttribute>]
member LogTimeFormat : string with get, set

Property Value

Type: Online String
See Also
CSVFileDestination Class
CSVFileDestination Members
NFX.Log.Destinations Namespace


DebugDestination Class

DebugDestination Class NFX Class Library

Provides a file storage destination implementation for debug and trace logging
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Log.Destinations Destination
NFX.Log.Destinations FileDestination
NFX.Log.Destinations TextFileDestination
NFX.Log.Destinations DebugDestination

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class DebugDestination : TextFileDestination
public class DebugDestination : TextFileDestination
Public Class DebugDestination
    Inherits TextFileDestination
Public Class DebugDestination
    Inherits TextFileDestination
public ref class DebugDestination : public TextFileDestination
public ref class DebugDestination : public TextFileDestination
type DebugDestination =
    class
        inherit TextFileDestination
    end
type DebugDestination =
    class
        inherit TextFileDestination
    end
See Also
DebugDestination Members
NFX.Log.Destinations Namespace


DebugDestination Members

DebugDestination Members NFX Class Library

The DebugDestination type exposes the following members.
Constructors
 | Name | Description
Public method | DebugDestination | Initializes a new instance of the DebugDestination class
Public method | DebugDestination(String) | Initializes a new instance of the DebugDestination class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc | (Inherited from Destination.)
Public method | Close | (Inherited from FileDestination.)
Public method | Configure | Configures specified destination (Inherited from Destination.)
Protected method | Destructor | (Inherited from Destination.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoCloseStream | (Inherited from TextFileDestination.)
Protected method | DoConfigure | Override to perform derivative-specific configuration (Inherited from Destination.)
Protected method | DoFormatMessage | (Overrides TextFileDestination DoFormatMessage(Message).)
Protected method | DoOpenStream | (Inherited from TextFileDestination.)
Protected method | DoPulse | (Inherited from TextFileDestination.)
Protected method | DoSend | Override DoFormatMessage() instead (Inherited from FileDestination.)
Protected method | DoWriteMessage | Warning: don't override this method in derived destinations, use DoFormatMessage() instead! (Inherited from TextFileDestination.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Destination.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Destination.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetDestinationFileName | (Inherited from FileDestination.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | (Inherited from FileDestination.)
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Public method | Send | Sends the message into destination doing filter checks first. (Inherited from Destination.)
Protected method | SendRegularAndFailures | (Inherited from Destination.)
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message (Inherited from Destination.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one (Inherited from Destination.)
Public field | Before | Allows to insert a destination right before this one (Inherited from Destination.)
Protected field | m_FileName | (Inherited from FileDestination.)
Protected field | m_Name | (Inherited from Destination.)
Protected field | m_Owner | (Inherited from Destination.)
Protected field | m_Path | (Inherited from FileDestination.)
Protected field | m_Stream | (Inherited from FileDestination.)
Back to Top
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f (Inherited from Destination.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages (Inherited from Destination.)
Protected property | DefaultFileName | (Inherited from FileDestination.)
Public property | DirectorLog | (Inherited from Destination.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages (Inherited from Destination.)
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages (Inherited from Destination.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public property | Failover | Sets destination name used for failover of this one (Inherited from Destination.)
Public property | FileName | File name may include environment variables (e.g. ~home), and use macros to specify time "$(~home)$(@::now fmt=yyyyMMdd utc=false)-$($name).log". Pass "utc=true" argument to use UTC (Inherited from FileDestination.)
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result (Inherited from Destination.)
Public property | FilterMethod | References message filtering method or null (Inherited from Destination.)
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default. (Inherited from Destination.)
Public property | LastError | Returns last error that this destination has encountered (Inherited from Destination.)
Public property | Levels | (Inherited from Destination.)
Public property | MaxLevel | Imposes a maximum log level constraint (Inherited from Destination.)
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy (Inherited from Destination.)
Public property | MinLevel | Imposes a minimum log level constraint (Inherited from Destination.)
Public property | Name | Provides mnemonic destination name (Inherited from Destination.)
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored (Inherited from Destination.)
Public property | Owner | Returns a composite destination that ownes this destination or null (Inherited from Destination.)
Public property | Path | (Inherited from FileDestination.)
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms (Inherited from Destination.)
Public property | Service | References a log service that this destination services (Inherited from Destination.)
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages (Inherited from Destination.)
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages (Inherited from Destination.)
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true (Inherited from Destination.)
Back to Top
See Also
DebugDestination Class
NFX.Log.Destinations Namespace


DebugDestination Constructor

DebugDestination Constructor NFX Class Library

Overload List
 | Name | Description
Public method | DebugDestination | Initializes a new instance of the DebugDestination class
Public method | DebugDestination(String) | Initializes a new instance of the DebugDestination class
Back to Top
See Also
DebugDestination Class
DebugDestination Members
NFX.Log.Destinations Namespace


DebugDestination Constructor

DebugDestination Constructor NFX Class Library

Initializes a new instance of the DebugDestination class

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DebugDestination()
public DebugDestination()
Public Sub New
Public Sub New
public:
DebugDestination()
public:
DebugDestination()
new : unit -> DebugDestination
new : unit -> DebugDestination
See Also
DebugDestination Class
DebugDestination Members
DebugDestination Overload
NFX.Log.Destinations Namespace


DebugDestination Constructor (String)

DebugDestination Constructor (String) NFX Class Library

Initializes a new instance of the DebugDestination class

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DebugDestination(
    string name = null
)
public DebugDestination(
    string name = null
)
Public Sub New (
    Optional name As String = Nothing
)
Public Sub New (
    Optional name As String = Nothing
)
public:
DebugDestination(
    String^ name = nullptr
)
public:
DebugDestination(
    String^ name = nullptr
)
new :
        ?name : string
(* Defaults:
        let _name = defaultArg name null
*)
-> DebugDestination
new :
        ?name : string
(* Defaults:
        let _name = defaultArg name null
*)
-> DebugDestination

Parameters

name (Optional)
Type: Online System String
See Also
DebugDestination Class
DebugDestination Members
DebugDestination Overload
NFX.Log.Destinations Namespace


DebugDestination Fields

DebugDestination Fields NFX Class Library

The DebugDestination type exposes the following members.
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one (Inherited from Destination.)
Public field | Before | Allows to insert a destination right before this one (Inherited from Destination.)
Protected field | m_FileName | (Inherited from FileDestination.)
Protected field | m_Name | (Inherited from Destination.)
Protected field | m_Owner | (Inherited from Destination.)
Protected field | m_Path | (Inherited from FileDestination.)
Protected field | m_Stream | (Inherited from FileDestination.)
Back to Top
See Also
DebugDestination Class
NFX.Log.Destinations Namespace


DebugDestination Methods

DebugDestination Methods NFX Class Library

The DebugDestination type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc | (Inherited from Destination.)
Public method | Close | (Inherited from FileDestination.)
Public method | Configure | Configures specified destination (Inherited from Destination.)
Protected method | Destructor | (Inherited from Destination.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoCloseStream | (Inherited from TextFileDestination.)
Protected method | DoConfigure | Override to perform derivative-specific configuration (Inherited from Destination.)
Protected method | DoFormatMessage | (Overrides TextFileDestination DoFormatMessage(Message).)
Protected method | DoOpenStream | (Inherited from TextFileDestination.)
Protected method | DoPulse | (Inherited from TextFileDestination.)
Protected method | DoSend | Override DoFormatMessage() instead (Inherited from FileDestination.)
Protected method | DoWriteMessage | Warning: don't override this method in derived destinations, use DoFormatMessage() instead! (Inherited from TextFileDestination.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Destination.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Destination.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetDestinationFileName | (Inherited from FileDestination.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | (Inherited from FileDestination.)
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Public method | Send | Sends the message into destination doing filter checks first. (Inherited from Destination.)
Protected method | SendRegularAndFailures | (Inherited from Destination.)
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message (Inherited from Destination.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
DebugDestination Class
NFX.Log.Destinations Namespace


DebugDestination.DoFormatMessage Method

DebugDestination DoFormatMessage Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override string DoFormatMessage(
    Message msg
)
protected override string DoFormatMessage(
    Message msg
)
Protected Overrides Function DoFormatMessage (
    msg As Message
) As String
Protected Overrides Function DoFormatMessage (
    msg As Message
) As String
protected:
virtual String^ DoFormatMessage(
    Message^ msg
) override
protected:
virtual String^ DoFormatMessage(
    Message^ msg
) override
abstract DoFormatMessage :
        msg : Message -> string
override DoFormatMessage :
        msg : Message -> string
abstract DoFormatMessage :
        msg : Message -> string
override DoFormatMessage :
        msg : Message -> string

Parameters

msg
Type: NFX.Log Message

Return Value

Type: Online String
See Also
DebugDestination Class
DebugDestination Members
NFX.Log.Destinations Namespace


DebugDestination Properties

DebugDestination Properties NFX Class Library

The DebugDestination type exposes the following members.
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f (Inherited from Destination.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages (Inherited from Destination.)
Protected property | DefaultFileName | (Inherited from FileDestination.)
Public property | DirectorLog | (Inherited from Destination.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages (Inherited from Destination.)
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages (Inherited from Destination.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public property | Failover | Sets destination name used for failover of this one (Inherited from Destination.)
Public property | FileName | File name may include environment variables (e.g. ~home), and use macros to specify time "$(~home)$(@::now fmt=yyyyMMdd utc=false)-$($name).log". Pass "utc=true" argument to use UTC (Inherited from FileDestination.)
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result (Inherited from Destination.)
Public property | FilterMethod | References message filtering method or null (Inherited from Destination.)
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default. (Inherited from Destination.)
Public property | LastError | Returns last error that this destination has encountered (Inherited from Destination.)
Public property | Levels | (Inherited from Destination.)
Public property | MaxLevel | Imposes a maximum log level constraint (Inherited from Destination.)
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy (Inherited from Destination.)
Public property | MinLevel | Imposes a minimum log level constraint (Inherited from Destination.)
Public property | Name | Provides mnemonic destination name (Inherited from Destination.)
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored (Inherited from Destination.)
Public property | Owner | Returns a composite destination that ownes this destination or null (Inherited from Destination.)
Public property | Path | (Inherited from FileDestination.)
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms (Inherited from Destination.)
Public property | Service | References a log service that this destination services (Inherited from Destination.)
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages (Inherited from Destination.)
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages (Inherited from Destination.)
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true (Inherited from Destination.)
Back to Top
See Also
DebugDestination Class
NFX.Log.Destinations Namespace


Destination Class

Destination Class NFX Class Library

Represents logging message destination - an abstract entity that messages are written to by LogService. Destinations must be efficient as they block logger thread. They provide failover mechanism when processing can not be completed. Once failed, the processing can try to be resumed after configurable interval. Destinations also provide optional SLA on the time it takes to perform actual message write - once exceeded destination is considered to have failed. Basic efficient filtering is provided for times, dates and levels. Complex C# expression-based filtering is also supported
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Log.Destinations Destination
NFX.Log.Destinations CompositeDestination
NFX.Log.Destinations ConsoleDestination
NFX.Log.Destinations FileDestination
NFX.Log.Destinations LogServiceDestination
NFX.Log.Destinations MemoryBufferDestination
NFX.Log.Destinations MongoDBDestination
NFX.Log.Destinations NullDestination
NFX.Log.Destinations SMTPDestination
NFX.Log.Destinations SyslogDestination

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Destination : ApplicationComponent,
    IConfigurable, IExternallyParameterized
public abstract class Destination : ApplicationComponent,
    IConfigurable, IExternallyParameterized
Public MustInherit Class Destination
    Inherits ApplicationComponent
    Implements IConfigurable, IExternallyParameterized
Public MustInherit Class Destination
    Inherits ApplicationComponent
    Implements IConfigurable, IExternallyParameterized
public ref class Destination abstract : public ApplicationComponent,
    IConfigurable, IExternallyParameterized
public ref class Destination abstract : public ApplicationComponent,
    IConfigurable, IExternallyParameterized
[<AbstractClassAttribute>]
type Destination =
    class
        inherit ApplicationComponent
        interface IConfigurable
        interface IExternallyParameterized
    end
[<AbstractClassAttribute>]
type Destination =
    class
        inherit ApplicationComponent
        interface IConfigurable
        interface IExternallyParameterized
    end
See Also
Destination Members
NFX.Log.Destinations Namespace


Destination Members

Destination Members NFX Class Library

The Destination type exposes the following members.
Constructors
 | Name | Description
Public method | Destination | Initializes a new instance of the Destination class
Public method | Destination(String) | Initializes a new instance of the Destination class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc |
Public method | Close | Deactivates destination
Public method | Configure | Configures specified destination
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure | Override to perform derivative-specific configuration
Protected method | DoPulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override to commit internal batching buffers provided by particular destinations
Protected method | DoSend | Performs physical send, i.e. storage in file for FileDestinations
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | Activates destination by preparing it to start operation
 | ParseLevels | Parses levels into a tuple list of level ranges
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations
Public method | Send | Sends the message into destination doing filter checks first.
Protected method | SendRegularAndFailures |
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one
Public field | Before | Allows to insert a destination right before this one
 | CONFIG_DAYS_OF_WEEK_ATTR |
 | CONFIG_END_DATE_ATTR |
 | CONFIG_END_TIME_ATTR |
 | CONFIG_FAILOVER_ATTR |
 | CONFIG_FILTER_ATTR |
 | CONFIG_GENERATE_FAILOVER_MSG_ATTR |
 | CONFIG_LEVELS_ATTR |
 | CONFIG_MAX_LEVEL_ATTR |
 | CONFIG_MAX_PROCESSING_TIME_MS_ATTR |
 | CONFIG_MAX_PROCESSING_TIME_MS_MIN_VALUE |
 | CONFIG_MIN_LEVEL_ATTR |
 | CONFIG_NAME_ATTR |
 | CONFIG_NAME_DEFAULT |
 | CONFIG_ONLY_FAILURES_ATTR |
 | CONFIG_RESTART_PROCESSING_AFTER_MS_ATTR |
 | CONFIG_RESTART_PROCESSING_AFTER_MS_DEFAULT |
 | CONFIG_START_DATE_ATTR |
 | CONFIG_START_TIME_ATTR |
 | CONFIG_TEST_ON_START_ATTR |
Protected field | m_Name |
Protected field | m_Owner |
 | PROCESSING_TIME_EMA_FILTER | Defines how much smoothing the processing time filter does - the lower the number the more smoothing is done. Smoothing makes MaxProcessingTimeMs detection insensitive to some seldom delays that may happen every now and then while destination performs actual write into its sink
Back to Top
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages
Public property | DirectorLog |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages
Public property | ExternalParameters | Returns named parameters that can be used to control this component
Public property | Failover | Sets destination name used for failover of this one
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result
Public property | FilterMethod | References message filtering method or null
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default.
Public property | LastError | Returns last error that this destination has encountered
Public property | Levels |
Public property | MaxLevel | Imposes a maximum log level constraint
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy
Public property | MinLevel | Imposes a minimum log level constraint
Public property | Name | Provides mnemonic destination name
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored
Public property | Owner | Returns a composite destination that ownes this destination or null
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms
Public property | Service | References a log service that this destination services
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true
Back to Top
See Also
Destination Class
NFX.Log.Destinations Namespace


Destination Constructor

Destination Constructor NFX Class Library

Overload List
 | Name | Description
Public method | Destination | Initializes a new instance of the Destination class
Public method | Destination(String) | Initializes a new instance of the Destination class
Back to Top
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination Constructor

Destination Constructor NFX Class Library

Initializes a new instance of the Destination class

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Destination()
public Destination()
Public Sub New
Public Sub New
public:
Destination()
public:
Destination()
new : unit -> Destination
new : unit -> Destination
See Also
Destination Class
Destination Members
Destination Overload
NFX.Log.Destinations Namespace


Destination Constructor (String)

Destination Constructor (String) NFX Class Library

Initializes a new instance of the Destination class

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Destination(
    string name
)
public Destination(
    string name
)
Public Sub New (
    name As String
)
Public Sub New (
    name As String
)
public:
Destination(
    String^ name
)
public:
Destination(
    String^ name
)
new :
        name : string -> Destination
new :
        name : string -> Destination

Parameters

name
Type: Online System String
See Also
Destination Class
Destination Members
Destination Overload
NFX.Log.Destinations Namespace


Destination Fields

Destination Fields NFX Class Library

The Destination type exposes the following members.
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one
Public field | Before | Allows to insert a destination right before this one
 | CONFIG_DAYS_OF_WEEK_ATTR |
 | CONFIG_END_DATE_ATTR |
 | CONFIG_END_TIME_ATTR |
 | CONFIG_FAILOVER_ATTR |
 | CONFIG_FILTER_ATTR |
 | CONFIG_GENERATE_FAILOVER_MSG_ATTR |
 | CONFIG_LEVELS_ATTR |
 | CONFIG_MAX_LEVEL_ATTR |
 | CONFIG_MAX_PROCESSING_TIME_MS_ATTR |
 | CONFIG_MAX_PROCESSING_TIME_MS_MIN_VALUE |
 | CONFIG_MIN_LEVEL_ATTR |
 | CONFIG_NAME_ATTR |
 | CONFIG_NAME_DEFAULT |
 | CONFIG_ONLY_FAILURES_ATTR |
 | CONFIG_RESTART_PROCESSING_AFTER_MS_ATTR |
 | CONFIG_RESTART_PROCESSING_AFTER_MS_DEFAULT |
 | CONFIG_START_DATE_ATTR |
 | CONFIG_START_TIME_ATTR |
 | CONFIG_TEST_ON_START_ATTR |
Protected field | m_Name |
Protected field | m_Owner |
 | PROCESSING_TIME_EMA_FILTER | Defines how much smoothing the processing time filter does - the lower the number the more smoothing is done. Smoothing makes MaxProcessingTimeMs detection insensitive to some seldom delays that may happen every now and then while destination performs actual write into its sink
Back to Top
See Also
Destination Class
NFX.Log.Destinations Namespace


Destination.After Field

Destination After Field NFX Class Library

Allows to insert a destination right after this one

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Destination After
public Destination After
Public After As Destination
Public After As Destination
public:
Destination^ After
public:
Destination^ After
val mutable After: Destination
val mutable After: Destination

Field Value

Type: Destination
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.Before Field

Destination Before Field NFX Class Library

Allows to insert a destination right before this one

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Destination Before
public Destination Before
Public Before As Destination
Public Before As Destination
public:
Destination^ Before
public:
Destination^ Before
val mutable Before: Destination
val mutable Before: Destination

Field Value

Type: Destination
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.CONFIG_DAYS_OF_WEEK_ATTR Field

Destination CONFIG_DAYS_OF_WEEK_ATTR Field NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_DAYS_OF_WEEK_ATTR
public const string CONFIG_DAYS_OF_WEEK_ATTR
Public Const CONFIG_DAYS_OF_WEEK_ATTR As String
Public Const CONFIG_DAYS_OF_WEEK_ATTR As String
public:
literal String^ CONFIG_DAYS_OF_WEEK_ATTR
public:
literal String^ CONFIG_DAYS_OF_WEEK_ATTR
static val mutable CONFIG_DAYS_OF_WEEK_ATTR: string
static val mutable CONFIG_DAYS_OF_WEEK_ATTR: string

Field Value

Type: Online String
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.CONFIG_END_DATE_ATTR Field

Destination CONFIG_END_DATE_ATTR Field NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_END_DATE_ATTR
public const string CONFIG_END_DATE_ATTR
Public Const CONFIG_END_DATE_ATTR As String
Public Const CONFIG_END_DATE_ATTR As String
public:
literal String^ CONFIG_END_DATE_ATTR
public:
literal String^ CONFIG_END_DATE_ATTR
static val mutable CONFIG_END_DATE_ATTR: string
static val mutable CONFIG_END_DATE_ATTR: string

Field Value

Type: Online String
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.CONFIG_END_TIME_ATTR Field

Destination CONFIG_END_TIME_ATTR Field NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_END_TIME_ATTR
public const string CONFIG_END_TIME_ATTR
Public Const CONFIG_END_TIME_ATTR As String
Public Const CONFIG_END_TIME_ATTR As String
public:
literal String^ CONFIG_END_TIME_ATTR
public:
literal String^ CONFIG_END_TIME_ATTR
static val mutable CONFIG_END_TIME_ATTR: string
static val mutable CONFIG_END_TIME_ATTR: string

Field Value

Type: Online String
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.CONFIG_FAILOVER_ATTR Field

Destination CONFIG_FAILOVER_ATTR Field NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_FAILOVER_ATTR
public const string CONFIG_FAILOVER_ATTR
Public Const CONFIG_FAILOVER_ATTR As String
Public Const CONFIG_FAILOVER_ATTR As String
public:
literal String^ CONFIG_FAILOVER_ATTR
public:
literal String^ CONFIG_FAILOVER_ATTR
static val mutable CONFIG_FAILOVER_ATTR: string
static val mutable CONFIG_FAILOVER_ATTR: string

Field Value

Type: Online String
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.CONFIG_FILTER_ATTR Field

Destination CONFIG_FILTER_ATTR Field NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_FILTER_ATTR
public const string CONFIG_FILTER_ATTR
Public Const CONFIG_FILTER_ATTR As String
Public Const CONFIG_FILTER_ATTR As String
public:
literal String^ CONFIG_FILTER_ATTR
public:
literal String^ CONFIG_FILTER_ATTR
static val mutable CONFIG_FILTER_ATTR: string
static val mutable CONFIG_FILTER_ATTR: string

Field Value

Type: Online String
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.CONFIG_GENERATE_FAILOVER_MSG_ATTR Field

Destination CONFIG_GENERATE_FAILOVER_MSG_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_GENERATE_FAILOVER_MSG_ATTR
public const string CONFIG_GENERATE_FAILOVER_MSG_ATTR
Public Const CONFIG_GENERATE_FAILOVER_MSG_ATTR As String
Public Const CONFIG_GENERATE_FAILOVER_MSG_ATTR As String
public:
literal String^ CONFIG_GENERATE_FAILOVER_MSG_ATTR
public:
literal String^ CONFIG_GENERATE_FAILOVER_MSG_ATTR
static val mutable CONFIG_GENERATE_FAILOVER_MSG_ATTR: string
static val mutable CONFIG_GENERATE_FAILOVER_MSG_ATTR: string

Field Value

Type: Online String
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.CONFIG_LEVELS_ATTR Field

Destination CONFIG_LEVELS_ATTR Field NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_LEVELS_ATTR
public const string CONFIG_LEVELS_ATTR
Public Const CONFIG_LEVELS_ATTR As String
Public Const CONFIG_LEVELS_ATTR As String
public:
literal String^ CONFIG_LEVELS_ATTR
public:
literal String^ CONFIG_LEVELS_ATTR
static val mutable CONFIG_LEVELS_ATTR: string
static val mutable CONFIG_LEVELS_ATTR: string

Field Value

Type: Online String
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.CONFIG_MAX_LEVEL_ATTR Field

Destination CONFIG_MAX_LEVEL_ATTR Field NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_MAX_LEVEL_ATTR
public const string CONFIG_MAX_LEVEL_ATTR
Public Const CONFIG_MAX_LEVEL_ATTR As String
Public Const CONFIG_MAX_LEVEL_ATTR As String
public:
literal String^ CONFIG_MAX_LEVEL_ATTR
public:
literal String^ CONFIG_MAX_LEVEL_ATTR
static val mutable CONFIG_MAX_LEVEL_ATTR: string
static val mutable CONFIG_MAX_LEVEL_ATTR: string

Field Value

Type: Online String
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.CONFIG_MAX_PROCESSING_TIME_MS_ATTR Field

Destination CONFIG_MAX_PROCESSING_TIME_MS_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_MAX_PROCESSING_TIME_MS_ATTR
public const string CONFIG_MAX_PROCESSING_TIME_MS_ATTR
Public Const CONFIG_MAX_PROCESSING_TIME_MS_ATTR As String
Public Const CONFIG_MAX_PROCESSING_TIME_MS_ATTR As String
public:
literal String^ CONFIG_MAX_PROCESSING_TIME_MS_ATTR
public:
literal String^ CONFIG_MAX_PROCESSING_TIME_MS_ATTR
static val mutable CONFIG_MAX_PROCESSING_TIME_MS_ATTR: string
static val mutable CONFIG_MAX_PROCESSING_TIME_MS_ATTR: string

Field Value

Type: Online String
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.CONFIG_MAX_PROCESSING_TIME_MS_MIN_VALUE Field

Destination CONFIG_MAX_PROCESSING_TIME_MS_MIN_VALUE Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int CONFIG_MAX_PROCESSING_TIME_MS_MIN_VALUE
public const int CONFIG_MAX_PROCESSING_TIME_MS_MIN_VALUE
Public Const CONFIG_MAX_PROCESSING_TIME_MS_MIN_VALUE As Integer
Public Const CONFIG_MAX_PROCESSING_TIME_MS_MIN_VALUE As Integer
public:
literal int CONFIG_MAX_PROCESSING_TIME_MS_MIN_VALUE
public:
literal int CONFIG_MAX_PROCESSING_TIME_MS_MIN_VALUE
static val mutable CONFIG_MAX_PROCESSING_TIME_MS_MIN_VALUE: int
static val mutable CONFIG_MAX_PROCESSING_TIME_MS_MIN_VALUE: int

Field Value

Type: Online Int32
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.CONFIG_MIN_LEVEL_ATTR Field

Destination CONFIG_MIN_LEVEL_ATTR Field NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_MIN_LEVEL_ATTR
public const string CONFIG_MIN_LEVEL_ATTR
Public Const CONFIG_MIN_LEVEL_ATTR As String
Public Const CONFIG_MIN_LEVEL_ATTR As String
public:
literal String^ CONFIG_MIN_LEVEL_ATTR
public:
literal String^ CONFIG_MIN_LEVEL_ATTR
static val mutable CONFIG_MIN_LEVEL_ATTR: string
static val mutable CONFIG_MIN_LEVEL_ATTR: string

Field Value

Type: Online String
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.CONFIG_NAME_ATTR Field

Destination CONFIG_NAME_ATTR Field NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_NAME_ATTR
public const string CONFIG_NAME_ATTR
Public Const CONFIG_NAME_ATTR As String
Public Const CONFIG_NAME_ATTR As String
public:
literal String^ CONFIG_NAME_ATTR
public:
literal String^ CONFIG_NAME_ATTR
static val mutable CONFIG_NAME_ATTR: string
static val mutable CONFIG_NAME_ATTR: string

Field Value

Type: Online String
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.CONFIG_NAME_DEFAULT Field

Destination CONFIG_NAME_DEFAULT Field NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_NAME_DEFAULT
public const string CONFIG_NAME_DEFAULT
Public Const CONFIG_NAME_DEFAULT As String
Public Const CONFIG_NAME_DEFAULT As String
public:
literal String^ CONFIG_NAME_DEFAULT
public:
literal String^ CONFIG_NAME_DEFAULT
static val mutable CONFIG_NAME_DEFAULT: string
static val mutable CONFIG_NAME_DEFAULT: string

Field Value

Type: Online String
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.CONFIG_ONLY_FAILURES_ATTR Field

Destination CONFIG_ONLY_FAILURES_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_ONLY_FAILURES_ATTR
public const string CONFIG_ONLY_FAILURES_ATTR
Public Const CONFIG_ONLY_FAILURES_ATTR As String
Public Const CONFIG_ONLY_FAILURES_ATTR As String
public:
literal String^ CONFIG_ONLY_FAILURES_ATTR
public:
literal String^ CONFIG_ONLY_FAILURES_ATTR
static val mutable CONFIG_ONLY_FAILURES_ATTR: string
static val mutable CONFIG_ONLY_FAILURES_ATTR: string

Field Value

Type: Online String
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.CONFIG_RESTART_PROCESSING_AFTER_MS_ATTR Field

Destination CONFIG_RESTART_PROCESSING_AFTER_MS_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_RESTART_PROCESSING_AFTER_MS_ATTR
public const string CONFIG_RESTART_PROCESSING_AFTER_MS_ATTR
Public Const CONFIG_RESTART_PROCESSING_AFTER_MS_ATTR As String
Public Const CONFIG_RESTART_PROCESSING_AFTER_MS_ATTR As String
public:
literal String^ CONFIG_RESTART_PROCESSING_AFTER_MS_ATTR
public:
literal String^ CONFIG_RESTART_PROCESSING_AFTER_MS_ATTR
static val mutable CONFIG_RESTART_PROCESSING_AFTER_MS_ATTR: string
static val mutable CONFIG_RESTART_PROCESSING_AFTER_MS_ATTR: string

Field Value

Type: Online String
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.CONFIG_RESTART_PROCESSING_AFTER_MS_DEFAULT Field

Destination CONFIG_RESTART_PROCESSING_AFTER_MS_DEFAULT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int CONFIG_RESTART_PROCESSING_AFTER_MS_DEFAULT
public const int CONFIG_RESTART_PROCESSING_AFTER_MS_DEFAULT
Public Const CONFIG_RESTART_PROCESSING_AFTER_MS_DEFAULT As Integer
Public Const CONFIG_RESTART_PROCESSING_AFTER_MS_DEFAULT As Integer
public:
literal int CONFIG_RESTART_PROCESSING_AFTER_MS_DEFAULT
public:
literal int CONFIG_RESTART_PROCESSING_AFTER_MS_DEFAULT
static val mutable CONFIG_RESTART_PROCESSING_AFTER_MS_DEFAULT: int
static val mutable CONFIG_RESTART_PROCESSING_AFTER_MS_DEFAULT: int

Field Value

Type: Online Int32
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.CONFIG_START_DATE_ATTR Field

Destination CONFIG_START_DATE_ATTR Field NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_START_DATE_ATTR
public const string CONFIG_START_DATE_ATTR
Public Const CONFIG_START_DATE_ATTR As String
Public Const CONFIG_START_DATE_ATTR As String
public:
literal String^ CONFIG_START_DATE_ATTR
public:
literal String^ CONFIG_START_DATE_ATTR
static val mutable CONFIG_START_DATE_ATTR: string
static val mutable CONFIG_START_DATE_ATTR: string

Field Value

Type: Online String
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.CONFIG_START_TIME_ATTR Field

Destination CONFIG_START_TIME_ATTR Field NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_START_TIME_ATTR
public const string CONFIG_START_TIME_ATTR
Public Const CONFIG_START_TIME_ATTR As String
Public Const CONFIG_START_TIME_ATTR As String
public:
literal String^ CONFIG_START_TIME_ATTR
public:
literal String^ CONFIG_START_TIME_ATTR
static val mutable CONFIG_START_TIME_ATTR: string
static val mutable CONFIG_START_TIME_ATTR: string

Field Value

Type: Online String
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.CONFIG_TEST_ON_START_ATTR Field

Destination CONFIG_TEST_ON_START_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_TEST_ON_START_ATTR
public const string CONFIG_TEST_ON_START_ATTR
Public Const CONFIG_TEST_ON_START_ATTR As String
Public Const CONFIG_TEST_ON_START_ATTR As String
public:
literal String^ CONFIG_TEST_ON_START_ATTR
public:
literal String^ CONFIG_TEST_ON_START_ATTR
static val mutable CONFIG_TEST_ON_START_ATTR: string
static val mutable CONFIG_TEST_ON_START_ATTR: string

Field Value

Type: Online String
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.m_Name Field

Destination m_Name Field NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected string m_Name
protected string m_Name
Protected m_Name As String
Protected m_Name As String
protected:
String^ m_Name
protected:
String^ m_Name
val mutable m_Name: string
val mutable m_Name: string

Field Value

Type: Online String
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.m_Owner Field

Destination m_Owner Field NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal CompositeDestination m_Owner
protected internal CompositeDestination m_Owner
Protected Friend m_Owner As CompositeDestination
Protected Friend m_Owner As CompositeDestination
protected public:
CompositeDestination^ m_Owner
protected public:
CompositeDestination^ m_Owner
val mutable m_Owner: CompositeDestination
val mutable m_Owner: CompositeDestination

Field Value

Type: CompositeDestination
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.PROCESSING_TIME_EMA_FILTER Field

Destination PROCESSING_TIME_EMA_FILTER Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Defines how much smoothing the processing time filter does - the lower the number the more smoothing is done. Smoothing makes MaxProcessingTimeMs detection insensitive to some seldom delays that may happen every now and then while destination performs actual write into its sink

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const float PROCESSING_TIME_EMA_FILTER
public const float PROCESSING_TIME_EMA_FILTER
Public Const PROCESSING_TIME_EMA_FILTER As Single
Public Const PROCESSING_TIME_EMA_FILTER As Single
public:
literal float PROCESSING_TIME_EMA_FILTER
public:
literal float PROCESSING_TIME_EMA_FILTER
static val mutable PROCESSING_TIME_EMA_FILTER: float32
static val mutable PROCESSING_TIME_EMA_FILTER: float32

Field Value

Type: Online Single
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination Methods

Destination Methods NFX Class Library

The Destination type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc |
Public method | Close | Deactivates destination
Public method | Configure | Configures specified destination
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure | Override to perform derivative-specific configuration
Protected method | DoPulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override to commit internal batching buffers provided by particular destinations
Protected method | DoSend | Performs physical send, i.e. storage in file for FileDestinations
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | Activates destination by preparing it to start operation
 | ParseLevels | Parses levels into a tuple list of level ranges
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations
Public method | Send | Sends the message into destination doing filter checks first.
Protected method | SendRegularAndFailures |
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Destination Class
NFX.Log.Destinations Namespace


Destination.__setLogSvc Method

Destination __setLogSvc Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void __setLogSvc(
    LogServiceBase svc
)
internal void __setLogSvc(
    LogServiceBase svc
)
Friend Sub __setLogSvc (
    svc As LogServiceBase
)
Friend Sub __setLogSvc (
    svc As LogServiceBase
)
internal:
void __setLogSvc(
    LogServiceBase^ svc
)
internal:
void __setLogSvc(
    LogServiceBase^ svc
)
internal member __setLogSvc :
        svc : LogServiceBase -> unit
internal member __setLogSvc :
        svc : LogServiceBase -> unit

Parameters

svc
Type: NFX.Log LogServiceBase
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.Close Method

Destination Close Method NFX Class Library

Deactivates destination

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Close()
public virtual void Close()
Public Overridable Sub Close
Public Overridable Sub Close
public:
virtual void Close()
public:
virtual void Close()
abstract Close : unit -> unit
override Close : unit -> unit
abstract Close : unit -> unit
override Close : unit -> unit
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.Configure Method

Destination Configure Method NFX Class Library

Configures specified destination

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode fromNode
)
public void Configure(
    IConfigSectionNode fromNode
)
Public Sub Configure (
    fromNode As IConfigSectionNode
)
Public Sub Configure (
    fromNode As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ fromNode
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ fromNode
) sealed
abstract Configure :
        fromNode : IConfigSectionNode -> unit
override Configure :
        fromNode : IConfigSectionNode -> unit
abstract Configure :
        fromNode : IConfigSectionNode -> unit
override Configure :
        fromNode : IConfigSectionNode -> unit

Parameters

fromNode
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.Destructor Method

Destination Destructor Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.DoConfigure Method

Destination DoConfigure Method NFX Class Library

Override to perform derivative-specific configuration

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoConfigure(
    IConfigSectionNode node
)
protected virtual void DoConfigure(
    IConfigSectionNode node
)
Protected Overridable Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overridable Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
)
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.DoPulse Method

Destination DoPulse Method NFX Class Library

Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override to commit internal batching buffers provided by particular destinations

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal virtual void DoPulse()
protected internal virtual void DoPulse()
Protected Friend Overridable Sub DoPulse
Protected Friend Overridable Sub DoPulse
protected public:
virtual void DoPulse()
protected public:
virtual void DoPulse()
abstract DoPulse : unit -> unit
override DoPulse : unit -> unit
abstract DoPulse : unit -> unit
override DoPulse : unit -> unit
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.DoSend Method

Destination DoSend Method NFX Class Library

Performs physical send, i.e. storage in file for FileDestinations

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract void DoSend(
    Message entry
)
protected internal abstract void DoSend(
    Message entry
)
Protected Friend MustOverride Sub DoSend (
    entry As Message
)
Protected Friend MustOverride Sub DoSend (
    entry As Message
)
protected public:
virtual void DoSend(
    Message^ entry
) abstract
protected public:
virtual void DoSend(
    Message^ entry
) abstract
abstract DoSend :
        entry : Message -> unit
abstract DoSend :
        entry : Message -> unit

Parameters

entry
Type: NFX.Log Message
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.ExternalGetParameter Method

Destination ExternalGetParameter Method NFX Class Library

Gets external parameter value returning true if parameter was found

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
public virtual bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
Public Overridable Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
Public Overridable Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
)
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
)
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalGetParameter(String, Object , String )
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.ExternalParametersForGroups Method

Destination ExternalParametersForGroups Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns named parameters that can be used to control this component

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
public virtual IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
Public Overridable Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
Public Overridable Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
)
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
)
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>

Parameters

groups
Type: Online System String

Return Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParametersForGroups( String )
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.ExternalSetParameter Method

Destination ExternalSetParameter Method NFX Class Library

Sets external parameter value returning true if parameter was found and set

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
public virtual bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
Public Overridable Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
Public Overridable Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
)
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
)
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalSetParameter(String, Object, String )
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.Open Method

Destination Open Method NFX Class Library

Activates destination by preparing it to start operation

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Open()
public virtual void Open()
Public Overridable Sub Open
Public Overridable Sub Open
public:
virtual void Open()
public:
virtual void Open()
abstract Open : unit -> unit
override Open : unit -> unit
abstract Open : unit -> unit
override Open : unit -> unit
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.ParseLevels Method

Destination ParseLevels Method NFX Class Library

Parses levels into a tuple list of level ranges

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Destination..::..LevelsList ParseLevels(
    string levels
)
public static Destination..::..LevelsList ParseLevels(
    string levels
)
Public Shared Function ParseLevels (
    levels As String
) As Destination..::..LevelsList
Public Shared Function ParseLevels (
    levels As String
) As Destination..::..LevelsList
public:
static Destination..::..LevelsList^ ParseLevels(
    String^ levels
)
public:
static Destination..::..LevelsList^ ParseLevels(
    String^ levels
)
static member ParseLevels :
        levels : string -> Destination..::..LevelsList
static member ParseLevels :
        levels : string -> Destination..::..LevelsList

Parameters

levels
Type: Online System String
String representation of levels using ',' or ';' or '|' as range group delimiters, and '-' as range indicators. If first/second bound of the range is empty, the min/max value of that bound is assumed. Examples: "Debug-DebugZ | Error", "-DebugZ | Info | Warning", "Info-", "DebugB-DebugC, Error"

Return Value

Type: Destination LevelsList
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.Pulse Method

Destination Pulse Method NFX Class Library

Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Pulse()
public void Pulse()
Public Sub Pulse
Public Sub Pulse
public:
void Pulse()
public:
void Pulse()
member Pulse : unit -> unit
member Pulse : unit -> unit
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.Send Method

Destination Send Method NFX Class Library

Sends the message into destination doing filter checks first.

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Send(
    Message msg
)
public void Send(
    Message msg
)
Public Sub Send (
    msg As Message
)
Public Sub Send (
    msg As Message
)
public:
void Send(
    Message^ msg
)
public:
void Send(
    Message^ msg
)
member Send :
        msg : Message -> unit
member Send :
        msg : Message -> unit

Parameters

msg
Type: NFX.Log Message
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.SendRegularAndFailures Method

Destination SendRegularAndFailures Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void SendRegularAndFailures(
    Message msg
)
internal void SendRegularAndFailures(
    Message msg
)
Friend Sub SendRegularAndFailures (
    msg As Message
)
Friend Sub SendRegularAndFailures (
    msg As Message
)
internal:
void SendRegularAndFailures(
    Message^ msg
)
internal:
void SendRegularAndFailures(
    Message^ msg
)
internal member SendRegularAndFailures :
        msg : Message -> unit
internal member SendRegularAndFailures :
        msg : Message -> unit

Parameters

msg
Type: NFX.Log Message
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.SetError Method

Destination SetError Method NFX Class Library

Notifies log service of exception that surfaced during processing of a particular message

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void SetError(
    Exception error,
    Message msg
)
protected void SetError(
    Exception error,
    Message msg
)
Protected Sub SetError (
    error As Exception,
    msg As Message
)
Protected Sub SetError (
    error As Exception,
    msg As Message
)
protected:
void SetError(
    Exception^ error,
    Message^ msg
)
protected:
void SetError(
    Exception^ error,
    Message^ msg
)
member SetError :
        error : Exception *
        msg : Message -> unit
member SetError :
        error : Exception *
        msg : Message -> unit

Parameters

error
Type: Online System Exception
msg
Type: NFX.Log Message
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination Properties

Destination Properties NFX Class Library

The Destination type exposes the following members.
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages
Public property | DirectorLog |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages
Public property | ExternalParameters | Returns named parameters that can be used to control this component
Public property | Failover | Sets destination name used for failover of this one
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result
Public property | FilterMethod | References message filtering method or null
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default.
Public property | LastError | Returns last error that this destination has encountered
Public property | Levels |
Public property | MaxLevel | Imposes a maximum log level constraint
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy
Public property | MinLevel | Imposes a minimum log level constraint
Public property | Name | Provides mnemonic destination name
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored
Public property | Owner | Returns a composite destination that ownes this destination or null
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms
Public property | Service | References a log service that this destination services
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true
Back to Top
See Also
Destination Class
NFX.Log.Destinations Namespace


Destination.AverageProcessingTimeMs Property

Destination AverageProcessingTimeMs Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float AverageProcessingTimeMs { get; }
public float AverageProcessingTimeMs { get; }
Public ReadOnly Property AverageProcessingTimeMs As Single
    Get
Public ReadOnly Property AverageProcessingTimeMs As Single
    Get
public:
property float AverageProcessingTimeMs {
    float get ();
}
public:
property float AverageProcessingTimeMs {
    float get ();
}
member AverageProcessingTimeMs : float32 with get
member AverageProcessingTimeMs : float32 with get

Property Value

Type: Online Single
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.DaysOfWeek Property

Destination DaysOfWeek Property NFX Class Library

Imposes a filter on days when this destination handles messages

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$days-of-week")]
[ExternalParameterAttribute(new string[] { ... })]
public Nullable<DaysOfWeek> DaysOfWeek { get; set; }
[ConfigAttribute("$days-of-week")]
[ExternalParameterAttribute(new string[] { ... })]
public Nullable<DaysOfWeek> DaysOfWeek { get; set; }
<ConfigAttribute("$days-of-week")>
<ExternalParameterAttribute(New String() { ... })>
Public Property DaysOfWeek As Nullable(Of DaysOfWeek)
    Get
    Set
<ConfigAttribute("$days-of-week")>
<ExternalParameterAttribute(New String() { ... })>
Public Property DaysOfWeek As Nullable(Of DaysOfWeek)
    Get
    Set
public:
[ConfigAttribute(L"$days-of-week")]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property Nullable<DaysOfWeek> DaysOfWeek {
    Nullable<DaysOfWeek> get ();
    void set (Nullable<DaysOfWeek> value);
}
public:
[ConfigAttribute(L"$days-of-week")]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property Nullable<DaysOfWeek> DaysOfWeek {
    Nullable<DaysOfWeek> get ();
    void set (Nullable<DaysOfWeek> value);
}
[<ConfigAttribute("$days-of-week")>]
[<ExternalParameterAttribute(new string[] { ... })>]
member DaysOfWeek : Nullable<DaysOfWeek> with get, set
[<ConfigAttribute("$days-of-week")>]
[<ExternalParameterAttribute(new string[] { ... })>]
member DaysOfWeek : Nullable<DaysOfWeek> with get, set

Property Value

Type: Online Nullable DaysOfWeek
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.DirectorLog Property

Destination DirectorLog Property NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LogServiceBase DirectorLog { get; }
public LogServiceBase DirectorLog { get; }
Public ReadOnly Property DirectorLog As LogServiceBase
    Get
Public ReadOnly Property DirectorLog As LogServiceBase
    Get
public:
property LogServiceBase^ DirectorLog {
    LogServiceBase^ get ();
}
public:
property LogServiceBase^ DirectorLog {
    LogServiceBase^ get ();
}
member DirectorLog : LogServiceBase with get
member DirectorLog : LogServiceBase with get

Property Value

Type: LogServiceBase
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.EndDate Property

Destination EndDate Property NFX Class Library

Imposes a filter that specifies the ending date and time before which this destination will be processing log messages

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$end-date")]
[ExternalParameterAttribute(new string[] { ... })]
public Nullable<DateTime> EndDate { get; set; }
[ConfigAttribute("$end-date")]
[ExternalParameterAttribute(new string[] { ... })]
public Nullable<DateTime> EndDate { get; set; }
<ConfigAttribute("$end-date")>
<ExternalParameterAttribute(New String() { ... })>
Public Property EndDate As Nullable(Of DateTime)
    Get
    Set
<ConfigAttribute("$end-date")>
<ExternalParameterAttribute(New String() { ... })>
Public Property EndDate As Nullable(Of DateTime)
    Get
    Set
public:
[ConfigAttribute(L"$end-date")]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property Nullable<DateTime> EndDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
public:
[ConfigAttribute(L"$end-date")]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property Nullable<DateTime> EndDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
[<ConfigAttribute("$end-date")>]
[<ExternalParameterAttribute(new string[] { ... })>]
member EndDate : Nullable<DateTime> with get, set
[<ConfigAttribute("$end-date")>]
[<ExternalParameterAttribute(new string[] { ... })>]
member EndDate : Nullable<DateTime> with get, set

Property Value

Type: Online Nullable Online DateTime
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.EndTime Property

Destination EndTime Property NFX Class Library

Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$end-time")]
[ExternalParameterAttribute(new string[] { ... })]
public Nullable<TimeSpan> EndTime { get; set; }
[ConfigAttribute("$end-time")]
[ExternalParameterAttribute(new string[] { ... })]
public Nullable<TimeSpan> EndTime { get; set; }
<ConfigAttribute("$end-time")>
<ExternalParameterAttribute(New String() { ... })>
Public Property EndTime As Nullable(Of TimeSpan)
    Get
    Set
<ConfigAttribute("$end-time")>
<ExternalParameterAttribute(New String() { ... })>
Public Property EndTime As Nullable(Of TimeSpan)
    Get
    Set
public:
[ConfigAttribute(L"$end-time")]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property Nullable<TimeSpan> EndTime {
    Nullable<TimeSpan> get ();
    void set (Nullable<TimeSpan> value);
}
public:
[ConfigAttribute(L"$end-time")]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property Nullable<TimeSpan> EndTime {
    Nullable<TimeSpan> get ();
    void set (Nullable<TimeSpan> value);
}
[<ConfigAttribute("$end-time")>]
[<ExternalParameterAttribute(new string[] { ... })>]
member EndTime : Nullable<TimeSpan> with get, set
[<ConfigAttribute("$end-time")>]
[<ExternalParameterAttribute(new string[] { ... })>]
member EndTime : Nullable<TimeSpan> with get, set

Property Value

Type: Online Nullable Online TimeSpan
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.ExternalParameters Property

Destination ExternalParameters Property NFX Class Library

Returns named parameters that can be used to control this component

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
public virtual IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
Public Overridable ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
Public Overridable ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get ();
}
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get ();
}
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get

Property Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParameters
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.Failover Property

Destination Failover Property NFX Class Library

Sets destination name used for failover of this one

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$failover")]
[ExternalParameterAttribute(new string[] { ... })]
public string Failover { get; set; }
[ConfigAttribute("$failover")]
[ExternalParameterAttribute(new string[] { ... })]
public string Failover { get; set; }
<ConfigAttribute("$failover")>
<ExternalParameterAttribute(New String() { ... })>
Public Property Failover As String
    Get
    Set
<ConfigAttribute("$failover")>
<ExternalParameterAttribute(New String() { ... })>
Public Property Failover As String
    Get
    Set
public:
[ConfigAttribute(L"$failover")]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property String^ Failover {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute(L"$failover")]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property String^ Failover {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute("$failover")>]
[<ExternalParameterAttribute(new string[] { ... })>]
member Failover : string with get, set
[<ConfigAttribute("$failover")>]
[<ExternalParameterAttribute(new string[] { ... })>]
member Failover : string with get, set

Property Value

Type: Online String
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.Filter Property

Destination Filter Property NFX Class Library

Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageFilterExpression Filter { get; set; }
public MessageFilterExpression Filter { get; set; }
Public Property Filter As MessageFilterExpression
    Get
    Set
Public Property Filter As MessageFilterExpression
    Get
    Set
public:
property MessageFilterExpression^ Filter {
    MessageFilterExpression^ get ();
    void set (MessageFilterExpression^ value);
}
public:
property MessageFilterExpression^ Filter {
    MessageFilterExpression^ get ();
    void set (MessageFilterExpression^ value);
}
member Filter : MessageFilterExpression with get, set
member Filter : MessageFilterExpression with get, set

Property Value

Type: MessageFilterExpression
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.FilterMethod Property

Destination FilterMethod Property NFX Class Library

References message filtering method or null

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MessageFilterHandler FilterMethod { get; set; }
public MessageFilterHandler FilterMethod { get; set; }
Public Property FilterMethod As MessageFilterHandler
    Get
    Set
Public Property FilterMethod As MessageFilterHandler
    Get
    Set
public:
property MessageFilterHandler^ FilterMethod {
    MessageFilterHandler^ get ();
    void set (MessageFilterHandler^ value);
}
public:
property MessageFilterHandler^ FilterMethod {
    MessageFilterHandler^ get ();
    void set (MessageFilterHandler^ value);
}
member FilterMethod : MessageFilterHandler with get, set
member FilterMethod : MessageFilterHandler with get, set

Property Value

Type: MessageFilterHandler
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.GenerateFailoverMessages Property

Destination GenerateFailoverMessages Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default.

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$generate-failover-msg")]
[ExternalParameterAttribute(new string[] { ... })]
public bool GenerateFailoverMessages { get; set; }
[ConfigAttribute("$generate-failover-msg")]
[ExternalParameterAttribute(new string[] { ... })]
public bool GenerateFailoverMessages { get; set; }
<ConfigAttribute("$generate-failover-msg")>
<ExternalParameterAttribute(New String() { ... })>
Public Property GenerateFailoverMessages As Boolean
    Get
    Set
<ConfigAttribute("$generate-failover-msg")>
<ExternalParameterAttribute(New String() { ... })>
Public Property GenerateFailoverMessages As Boolean
    Get
    Set
public:
[ConfigAttribute(L"$generate-failover-msg")]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property bool GenerateFailoverMessages {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute(L"$generate-failover-msg")]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property bool GenerateFailoverMessages {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute("$generate-failover-msg")>]
[<ExternalParameterAttribute(new string[] { ... })>]
member GenerateFailoverMessages : bool with get, set
[<ConfigAttribute("$generate-failover-msg")>]
[<ExternalParameterAttribute(new string[] { ... })>]
member GenerateFailoverMessages : bool with get, set

Property Value

Type: Online Boolean
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.LastError Property

Destination LastError Property NFX Class Library

Returns last error that this destination has encountered

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Exception LastError { get; }
public Exception LastError { get; }
Public ReadOnly Property LastError As Exception
    Get
Public ReadOnly Property LastError As Exception
    Get
public:
property Exception^ LastError {
    Exception^ get ();
}
public:
property Exception^ LastError {
    Exception^ get ();
}
member LastError : Exception with get
member LastError : Exception with get

Property Value

Type: Online Exception
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.Levels Property

Destination Levels Property NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Destination..::..LevelsList Levels { get; set; }
public Destination..::..LevelsList Levels { get; set; }
Public Property Levels As Destination..::..LevelsList
    Get
    Set
Public Property Levels As Destination..::..LevelsList
    Get
    Set
public:
property Destination..::..LevelsList^ Levels {
    Destination..::..LevelsList^ get ();
    void set (Destination..::..LevelsList^ value);
}
public:
property Destination..::..LevelsList^ Levels {
    Destination..::..LevelsList^ get ();
    void set (Destination..::..LevelsList^ value);
}
member Levels : Destination..::..LevelsList with get, set
member Levels : Destination..::..LevelsList with get, set

Property Value

Type: Destination LevelsList
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.MaxLevel Property

Destination MaxLevel Property NFX Class Library

Imposes a maximum log level constraint

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$max-level")]
[ExternalParameterAttribute(new string[] { ... })]
public Nullable<MessageType> MaxLevel { get; set; }
[ConfigAttribute("$max-level")]
[ExternalParameterAttribute(new string[] { ... })]
public Nullable<MessageType> MaxLevel { get; set; }
<ConfigAttribute("$max-level")>
<ExternalParameterAttribute(New String() { ... })>
Public Property MaxLevel As Nullable(Of MessageType)
    Get
    Set
<ConfigAttribute("$max-level")>
<ExternalParameterAttribute(New String() { ... })>
Public Property MaxLevel As Nullable(Of MessageType)
    Get
    Set
public:
[ConfigAttribute(L"$max-level")]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property Nullable<MessageType> MaxLevel {
    Nullable<MessageType> get ();
    void set (Nullable<MessageType> value);
}
public:
[ConfigAttribute(L"$max-level")]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property Nullable<MessageType> MaxLevel {
    Nullable<MessageType> get ();
    void set (Nullable<MessageType> value);
}
[<ConfigAttribute("$max-level")>]
[<ExternalParameterAttribute(new string[] { ... })>]
member MaxLevel : Nullable<MessageType> with get, set
[<ConfigAttribute("$max-level")>]
[<ExternalParameterAttribute(new string[] { ... })>]
member MaxLevel : Nullable<MessageType> with get, set

Property Value

Type: Online Nullable MessageType
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.MaxProcessingTimeMs Property

Destination MaxProcessingTimeMs Property NFX Class Library

Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$max-processing-time-ms")]
[ExternalParameterAttribute(new string[] { ... })]
public Nullable<int> MaxProcessingTimeMs { get; set; }
[ConfigAttribute("$max-processing-time-ms")]
[ExternalParameterAttribute(new string[] { ... })]
public Nullable<int> MaxProcessingTimeMs { get; set; }
<ConfigAttribute("$max-processing-time-ms")>
<ExternalParameterAttribute(New String() { ... })>
Public Property MaxProcessingTimeMs As Nullable(Of Integer)
    Get
    Set
<ConfigAttribute("$max-processing-time-ms")>
<ExternalParameterAttribute(New String() { ... })>
Public Property MaxProcessingTimeMs As Nullable(Of Integer)
    Get
    Set
public:
[ConfigAttribute(L"$max-processing-time-ms")]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property Nullable<int> MaxProcessingTimeMs {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
public:
[ConfigAttribute(L"$max-processing-time-ms")]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property Nullable<int> MaxProcessingTimeMs {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
[<ConfigAttribute("$max-processing-time-ms")>]
[<ExternalParameterAttribute(new string[] { ... })>]
member MaxProcessingTimeMs : Nullable<int> with get, set
[<ConfigAttribute("$max-processing-time-ms")>]
[<ExternalParameterAttribute(new string[] { ... })>]
member MaxProcessingTimeMs : Nullable<int> with get, set

Property Value

Type: Online Nullable Online Int32
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.MinLevel Property

Destination MinLevel Property NFX Class Library

Imposes a minimum log level constraint

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute("$min-level")]
public Nullable<MessageType> MinLevel { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute("$min-level")]
public Nullable<MessageType> MinLevel { get; set; }
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute("$min-level")>
Public Property MinLevel As Nullable(Of MessageType)
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute("$min-level")>
Public Property MinLevel As Nullable(Of MessageType)
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(L"$min-level")]
property Nullable<MessageType> MinLevel {
    Nullable<MessageType> get ();
    void set (Nullable<MessageType> value);
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(L"$min-level")]
property Nullable<MessageType> MinLevel {
    Nullable<MessageType> get ();
    void set (Nullable<MessageType> value);
}
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute("$min-level")>]
member MinLevel : Nullable<MessageType> with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute("$min-level")>]
member MinLevel : Nullable<MessageType> with get, set

Property Value

Type: Online Nullable MessageType
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.Name Property

Destination Name Property NFX Class Library

Provides mnemonic destination name

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$name", "Un-named log destination")]
public string Name { get; set; }
[ConfigAttribute("$name", "Un-named log destination")]
public string Name { get; set; }
<ConfigAttribute("$name", "Un-named log destination")>
Public Property Name As String
    Get
    Set
<ConfigAttribute("$name", "Un-named log destination")>
Public Property Name As String
    Get
    Set
public:
[ConfigAttribute(L"$name", L"Un-named log destination")]
property String^ Name {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute(L"$name", L"Un-named log destination")]
property String^ Name {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute("$name", "Un-named log destination")>]
member Name : string with get, set
[<ConfigAttribute("$name", "Un-named log destination")>]
member Name : string with get, set

Property Value

Type: Online String
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.OnlyFailures Property

Destination OnlyFailures Property NFX Class Library

Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute("$only-failures")]
public bool OnlyFailures { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute("$only-failures")]
public bool OnlyFailures { get; set; }
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute("$only-failures")>
Public Property OnlyFailures As Boolean
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute("$only-failures")>
Public Property OnlyFailures As Boolean
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(L"$only-failures")]
property bool OnlyFailures {
    bool get ();
    void set (bool value);
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(L"$only-failures")]
property bool OnlyFailures {
    bool get ();
    void set (bool value);
}
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute("$only-failures")>]
member OnlyFailures : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute("$only-failures")>]
member OnlyFailures : bool with get, set

Property Value

Type: Online Boolean
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.Owner Property

Destination Owner Property NFX Class Library

Returns a composite destination that ownes this destination or null

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CompositeDestination Owner { get; }
public CompositeDestination Owner { get; }
Public ReadOnly Property Owner As CompositeDestination
    Get
Public ReadOnly Property Owner As CompositeDestination
    Get
public:
property CompositeDestination^ Owner {
    CompositeDestination^ get ();
}
public:
property CompositeDestination^ Owner {
    CompositeDestination^ get ();
}
member Owner : CompositeDestination with get
member Owner : CompositeDestination with get

Property Value

Type: CompositeDestination
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.RestartProcessingAfterMs Property

Destination RestartProcessingAfterMs Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute("$restart-processing-after-ms")]
public int RestartProcessingAfterMs { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute("$restart-processing-after-ms")]
public int RestartProcessingAfterMs { get; set; }
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute("$restart-processing-after-ms")>
Public Property RestartProcessingAfterMs As Integer
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute("$restart-processing-after-ms")>
Public Property RestartProcessingAfterMs As Integer
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(L"$restart-processing-after-ms")]
property int RestartProcessingAfterMs {
    int get ();
    void set (int value);
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(L"$restart-processing-after-ms")]
property int RestartProcessingAfterMs {
    int get ();
    void set (int value);
}
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute("$restart-processing-after-ms")>]
member RestartProcessingAfterMs : int with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute("$restart-processing-after-ms")>]
member RestartProcessingAfterMs : int with get, set

Property Value

Type: Online Int32
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.Service Property

Destination Service Property NFX Class Library

References a log service that this destination services

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LogServiceBase Service { get; }
public LogServiceBase Service { get; }
Public ReadOnly Property Service As LogServiceBase
    Get
Public ReadOnly Property Service As LogServiceBase
    Get
public:
property LogServiceBase^ Service {
    LogServiceBase^ get ();
}
public:
property LogServiceBase^ Service {
    LogServiceBase^ get ();
}
member Service : LogServiceBase with get
member Service : LogServiceBase with get

Property Value

Type: LogServiceBase
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.StartDate Property

Destination StartDate Property NFX Class Library

Imposes a filter that specifies the starting date and time after which this destination will start processing log messages

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$start-date")]
[ExternalParameterAttribute(new string[] { ... })]
public Nullable<DateTime> StartDate { get; set; }
[ConfigAttribute("$start-date")]
[ExternalParameterAttribute(new string[] { ... })]
public Nullable<DateTime> StartDate { get; set; }
<ConfigAttribute("$start-date")>
<ExternalParameterAttribute(New String() { ... })>
Public Property StartDate As Nullable(Of DateTime)
    Get
    Set
<ConfigAttribute("$start-date")>
<ExternalParameterAttribute(New String() { ... })>
Public Property StartDate As Nullable(Of DateTime)
    Get
    Set
public:
[ConfigAttribute(L"$start-date")]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property Nullable<DateTime> StartDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
public:
[ConfigAttribute(L"$start-date")]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property Nullable<DateTime> StartDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
[<ConfigAttribute("$start-date")>]
[<ExternalParameterAttribute(new string[] { ... })>]
member StartDate : Nullable<DateTime> with get, set
[<ConfigAttribute("$start-date")>]
[<ExternalParameterAttribute(new string[] { ... })>]
member StartDate : Nullable<DateTime> with get, set

Property Value

Type: Online Nullable Online DateTime
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.StartTime Property

Destination StartTime Property NFX Class Library

Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute("$start-time")]
public Nullable<TimeSpan> StartTime { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute("$start-time")]
public Nullable<TimeSpan> StartTime { get; set; }
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute("$start-time")>
Public Property StartTime As Nullable(Of TimeSpan)
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute("$start-time")>
Public Property StartTime As Nullable(Of TimeSpan)
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(L"$start-time")]
property Nullable<TimeSpan> StartTime {
    Nullable<TimeSpan> get ();
    void set (Nullable<TimeSpan> value);
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(L"$start-time")]
property Nullable<TimeSpan> StartTime {
    Nullable<TimeSpan> get ();
    void set (Nullable<TimeSpan> value);
}
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute("$start-time")>]
member StartTime : Nullable<TimeSpan> with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute("$start-time")>]
member StartTime : Nullable<TimeSpan> with get, set

Property Value

Type: Online Nullable Online TimeSpan
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.TestOnStart Property

Destination TestOnStart Property NFX Class Library

Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$test-on-start")]
public bool TestOnStart { get; set; }
[ConfigAttribute("$test-on-start")]
public bool TestOnStart { get; set; }
<ConfigAttribute("$test-on-start")>
Public Property TestOnStart As Boolean
    Get
    Set
<ConfigAttribute("$test-on-start")>
Public Property TestOnStart As Boolean
    Get
    Set
public:
[ConfigAttribute(L"$test-on-start")]
property bool TestOnStart {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute(L"$test-on-start")]
property bool TestOnStart {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute("$test-on-start")>]
member TestOnStart : bool with get, set
[<ConfigAttribute("$test-on-start")>]
member TestOnStart : bool with get, set

Property Value

Type: Online Boolean
See Also
Destination Class
Destination Members
NFX.Log.Destinations Namespace


Destination.LevelsList Class

Destination LevelsList Class NFX Class Library

Inheritance Hierarchy
Online System Object
Online System.Collections.Generic List Online Tuple MessageType, MessageType
NFX.Log.Destinations Destination LevelsList

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LevelsList : List<Tuple<MessageType, MessageType>>
public class LevelsList : List<Tuple<MessageType, MessageType>>
Public Class LevelsList
    Inherits List(Of Tuple(Of MessageType, MessageType))
Public Class LevelsList
    Inherits List(Of Tuple(Of MessageType, MessageType))
public ref class LevelsList : public List<Tuple<MessageType, MessageType>^>
public ref class LevelsList : public List<Tuple<MessageType, MessageType>^>
type LevelsList =
    class
        inherit List<Tuple<MessageType, MessageType>>
    end
type LevelsList =
    class
        inherit List<Tuple<MessageType, MessageType>>
    end
See Also
Destination LevelsList Members
NFX.Log.Destinations Namespace


Destination.LevelsList Members

Destination LevelsList Members NFX Class Library

The Destination LevelsList type exposes the following members.
Constructors
 | Name | Description
Public method | Destination LevelsList | Initializes a new instance of the Destination LevelsList class
Back to Top
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List Online Tuple MessageType, MessageType .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Online Tuple MessageType, MessageType .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List Online Tuple MessageType, MessageType .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List Online Tuple MessageType, MessageType .)
Back to Top
See Also
Destination LevelsList Class
NFX.Log.Destinations Namespace


Destination.LevelsList Constructor

Destination LevelsList Constructor NFX Class Library

Initializes a new instance of the Destination LevelsList class

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LevelsList()
public LevelsList()
Public Sub New
Public Sub New
public:
LevelsList()
public:
LevelsList()
new : unit -> LevelsList
new : unit -> LevelsList
See Also
Destination LevelsList Class
Destination LevelsList Members
NFX.Log.Destinations Namespace


Destination.LevelsList Methods

Destination LevelsList Methods NFX Class Library

The Destination LevelsList type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List Online Tuple MessageType, MessageType .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Online Tuple MessageType, MessageType .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List Online Tuple MessageType, MessageType .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Destination LevelsList Class
NFX.Log.Destinations Namespace


Destination.LevelsList Properties

Destination LevelsList Properties NFX Class Library

The Destination LevelsList type exposes the following members.
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List Online Tuple MessageType, MessageType .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List Online Tuple MessageType, MessageType .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List Online Tuple MessageType, MessageType .)
Back to Top
See Also
Destination LevelsList Class
NFX.Log.Destinations Namespace


FileDestination Class

FileDestination Class NFX Class Library

Provides a file storage destination implementation
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Log.Destinations Destination
NFX.Log.Destinations FileDestination
NFX.Log.Destinations TextFileDestination

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class FileDestination : Destination
public abstract class FileDestination : Destination
Public MustInherit Class FileDestination
    Inherits Destination
Public MustInherit Class FileDestination
    Inherits Destination
public ref class FileDestination abstract : public Destination
public ref class FileDestination abstract : public Destination
[<AbstractClassAttribute>]
type FileDestination =
    class
        inherit Destination
    end
[<AbstractClassAttribute>]
type FileDestination =
    class
        inherit Destination
    end
See Also
FileDestination Members
NFX.Log.Destinations Namespace


FileDestination Members

FileDestination Members NFX Class Library

The FileDestination type exposes the following members.
Constructors
 | Name | Description
Protected method | FileDestination | Initializes a new instance of the FileDestination class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc | (Inherited from Destination.)
Public method | Close | (Overrides Destination Close .)
Public method | Configure | Configures specified destination (Inherited from Destination.)
Protected method | Destructor | (Inherited from Destination.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoCloseStream | Called just before output stream is closed
Protected method | DoConfigure | Override to perform derivative-specific configuration (Inherited from Destination.)
Protected method | DoOpenStream | Called after output stream has been opened
Protected method | DoPulse | (Overrides Destination DoPulse .)
Protected method | DoSend | Override DoFormatMessage() instead (Overrides Destination DoSend(Message).)
Protected method | DoWriteMessage | Called when message is to be written to stream
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Destination.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Destination.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetDestinationFileName |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | (Overrides Destination Open .)
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Public method | Send | Sends the message into destination doing filter checks first. (Inherited from Destination.)
Protected method | SendRegularAndFailures | (Inherited from Destination.)
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message (Inherited from Destination.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one (Inherited from Destination.)
Public field | Before | Allows to insert a destination right before this one (Inherited from Destination.)
Protected field | m_FileName |
Protected field | m_Name | (Inherited from Destination.)
Protected field | m_Owner | (Inherited from Destination.)
Protected field | m_Path |
Protected field | m_Stream |
Back to Top
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f (Inherited from Destination.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages (Inherited from Destination.)
Protected property | DefaultFileName |
Public property | DirectorLog | (Inherited from Destination.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages (Inherited from Destination.)
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages (Inherited from Destination.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public property | Failover | Sets destination name used for failover of this one (Inherited from Destination.)
Public property | FileName | File name may include environment variables (e.g. ~home), and use macros to specify time "$(~home)$(@::now fmt=yyyyMMdd utc=false)-$($name).log". Pass "utc=true" argument to use UTC
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result (Inherited from Destination.)
Public property | FilterMethod | References message filtering method or null (Inherited from Destination.)
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default. (Inherited from Destination.)
Public property | LastError | Returns last error that this destination has encountered (Inherited from Destination.)
Public property | Levels | (Inherited from Destination.)
Public property | MaxLevel | Imposes a maximum log level constraint (Inherited from Destination.)
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy (Inherited from Destination.)
Public property | MinLevel | Imposes a minimum log level constraint (Inherited from Destination.)
Public property | Name | Provides mnemonic destination name (Inherited from Destination.)
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored (Inherited from Destination.)
Public property | Owner | Returns a composite destination that ownes this destination or null (Inherited from Destination.)
Public property | Path |
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms (Inherited from Destination.)
Public property | Service | References a log service that this destination services (Inherited from Destination.)
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages (Inherited from Destination.)
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages (Inherited from Destination.)
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true (Inherited from Destination.)
Back to Top
See Also
FileDestination Class
NFX.Log.Destinations Namespace


FileDestination Constructor

FileDestination Constructor NFX Class Library

Initializes a new instance of the FileDestination class

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FileDestination(
    string name
)
protected FileDestination(
    string name
)
Protected Sub New (
    name As String
)
Protected Sub New (
    name As String
)
protected:
FileDestination(
    String^ name
)
protected:
FileDestination(
    String^ name
)
new :
        name : string -> FileDestination
new :
        name : string -> FileDestination

Parameters

name
Type: Online System String
See Also
FileDestination Class
FileDestination Members
NFX.Log.Destinations Namespace


FileDestination Fields

FileDestination Fields NFX Class Library

The FileDestination type exposes the following members.
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one (Inherited from Destination.)
Public field | Before | Allows to insert a destination right before this one (Inherited from Destination.)
Protected field | m_FileName |
Protected field | m_Name | (Inherited from Destination.)
Protected field | m_Owner | (Inherited from Destination.)
Protected field | m_Path |
Protected field | m_Stream |
Back to Top
See Also
FileDestination Class
NFX.Log.Destinations Namespace


FileDestination.m_FileName Field

FileDestination m_FileName Field NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected string m_FileName
protected string m_FileName
Protected m_FileName As String
Protected m_FileName As String
protected:
String^ m_FileName
protected:
String^ m_FileName
val mutable m_FileName: string
val mutable m_FileName: string

Field Value

Type: Online String
See Also
FileDestination Class
FileDestination Members
NFX.Log.Destinations Namespace


FileDestination.m_Path Field

FileDestination m_Path Field NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected string m_Path
protected string m_Path
Protected m_Path As String
Protected m_Path As String
protected:
String^ m_Path
protected:
String^ m_Path
val mutable m_Path: string
val mutable m_Path: string

Field Value

Type: Online String
See Also
FileDestination Class
FileDestination Members
NFX.Log.Destinations Namespace


FileDestination.m_Stream Field

FileDestination m_Stream Field NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected FileStream m_Stream
protected FileStream m_Stream
Protected m_Stream As FileStream
Protected m_Stream As FileStream
protected:
FileStream^ m_Stream
protected:
FileStream^ m_Stream
val mutable m_Stream: FileStream
val mutable m_Stream: FileStream

Field Value

Type: Online FileStream
See Also
FileDestination Class
FileDestination Members
NFX.Log.Destinations Namespace


FileDestination Methods

FileDestination Methods NFX Class Library

The FileDestination type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc | (Inherited from Destination.)
Public method | Close | (Overrides Destination Close .)
Public method | Configure | Configures specified destination (Inherited from Destination.)
Protected method | Destructor | (Inherited from Destination.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoCloseStream | Called just before output stream is closed
Protected method | DoConfigure | Override to perform derivative-specific configuration (Inherited from Destination.)
Protected method | DoOpenStream | Called after output stream has been opened
Protected method | DoPulse | (Overrides Destination DoPulse .)
Protected method | DoSend | Override DoFormatMessage() instead (Overrides Destination DoSend(Message).)
Protected method | DoWriteMessage | Called when message is to be written to stream
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Destination.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Destination.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetDestinationFileName |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | (Overrides Destination Open .)
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Public method | Send | Sends the message into destination doing filter checks first. (Inherited from Destination.)
Protected method | SendRegularAndFailures | (Inherited from Destination.)
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message (Inherited from Destination.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
FileDestination Class
NFX.Log.Destinations Namespace


FileDestination.Close Method

FileDestination Close Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Close()
public override void Close()
Public Overrides Sub Close
Public Overrides Sub Close
public:
virtual void Close() override
public:
virtual void Close() override
abstract Close : unit -> unit
override Close : unit -> unit
abstract Close : unit -> unit
override Close : unit -> unit
See Also
FileDestination Class
FileDestination Members
NFX.Log.Destinations Namespace


FileDestination.DoCloseStream Method

FileDestination DoCloseStream Method NFX Class Library

Called just before output stream is closed

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void DoCloseStream()
protected abstract void DoCloseStream()
Protected MustOverride Sub DoCloseStream
Protected MustOverride Sub DoCloseStream
protected:
virtual void DoCloseStream() abstract
protected:
virtual void DoCloseStream() abstract
abstract DoCloseStream : unit -> unit
abstract DoCloseStream : unit -> unit
See Also
FileDestination Class
FileDestination Members
NFX.Log.Destinations Namespace


FileDestination.DoOpenStream Method

FileDestination DoOpenStream Method NFX Class Library

Called after output stream has been opened

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void DoOpenStream()
protected abstract void DoOpenStream()
Protected MustOverride Sub DoOpenStream
Protected MustOverride Sub DoOpenStream
protected:
virtual void DoOpenStream() abstract
protected:
virtual void DoOpenStream() abstract
abstract DoOpenStream : unit -> unit
abstract DoOpenStream : unit -> unit
See Also
FileDestination Class
FileDestination Members
NFX.Log.Destinations Namespace


FileDestination.DoPulse Method

FileDestination DoPulse Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoPulse()
protected internal override void DoPulse()
Protected Friend Overrides Sub DoPulse
Protected Friend Overrides Sub DoPulse
protected public:
virtual void DoPulse() override
protected public:
virtual void DoPulse() override
abstract DoPulse : unit -> unit
override DoPulse : unit -> unit
abstract DoPulse : unit -> unit
override DoPulse : unit -> unit
See Also
FileDestination Class
FileDestination Members
NFX.Log.Destinations Namespace


FileDestination.DoSend Method

FileDestination DoSend Method NFX Class Library

Override DoFormatMessage() instead

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override sealed void DoSend(
    Message msg
)
protected internal override sealed void DoSend(
    Message msg
)
Protected Friend Overrides NotOverridable Sub DoSend (
    msg As Message
)
Protected Friend Overrides NotOverridable Sub DoSend (
    msg As Message
)
protected public:
virtual void DoSend(
    Message^ msg
) override sealed
protected public:
virtual void DoSend(
    Message^ msg
) override sealed
abstract DoSend :
        msg : Message -> unit
override DoSend :
        msg : Message -> unit
abstract DoSend :
        msg : Message -> unit
override DoSend :
        msg : Message -> unit

Parameters

msg
Type: NFX.Log Message
See Also
FileDestination Class
FileDestination Members
NFX.Log.Destinations Namespace


FileDestination.DoWriteMessage Method

FileDestination DoWriteMessage Method NFX Class Library

Called when message is to be written to stream

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void DoWriteMessage(
    Message msg
)
protected abstract void DoWriteMessage(
    Message msg
)
Protected MustOverride Sub DoWriteMessage (
    msg As Message
)
Protected MustOverride Sub DoWriteMessage (
    msg As Message
)
protected:
virtual void DoWriteMessage(
    Message^ msg
) abstract
protected:
virtual void DoWriteMessage(
    Message^ msg
) abstract
abstract DoWriteMessage :
        msg : Message -> unit
abstract DoWriteMessage :
        msg : Message -> unit

Parameters

msg
Type: NFX.Log Message
See Also
FileDestination Class
FileDestination Members
NFX.Log.Destinations Namespace


FileDestination.GetDestinationFileName Method

FileDestination GetDestinationFileName Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual string GetDestinationFileName()
protected virtual string GetDestinationFileName()
Protected Overridable Function GetDestinationFileName As String
Protected Overridable Function GetDestinationFileName As String
protected:
virtual String^ GetDestinationFileName()
protected:
virtual String^ GetDestinationFileName()
abstract GetDestinationFileName : unit -> string
override GetDestinationFileName : unit -> string
abstract GetDestinationFileName : unit -> string
override GetDestinationFileName : unit -> string

Return Value

Type: Online String
See Also
FileDestination Class
FileDestination Members
NFX.Log.Destinations Namespace


FileDestination.Open Method

FileDestination Open Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Open()
public override void Open()
Public Overrides Sub Open
Public Overrides Sub Open
public:
virtual void Open() override
public:
virtual void Open() override
abstract Open : unit -> unit
override Open : unit -> unit
abstract Open : unit -> unit
override Open : unit -> unit
See Also
FileDestination Class
FileDestination Members
NFX.Log.Destinations Namespace


FileDestination Properties

FileDestination Properties NFX Class Library

The FileDestination type exposes the following members.
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f (Inherited from Destination.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages (Inherited from Destination.)
Protected property | DefaultFileName |
Public property | DirectorLog | (Inherited from Destination.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages (Inherited from Destination.)
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages (Inherited from Destination.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public property | Failover | Sets destination name used for failover of this one (Inherited from Destination.)
Public property | FileName | File name may include environment variables (e.g. ~home), and use macros to specify time "$(~home)$(@::now fmt=yyyyMMdd utc=false)-$($name).log". Pass "utc=true" argument to use UTC
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result (Inherited from Destination.)
Public property | FilterMethod | References message filtering method or null (Inherited from Destination.)
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default. (Inherited from Destination.)
Public property | LastError | Returns last error that this destination has encountered (Inherited from Destination.)
Public property | Levels | (Inherited from Destination.)
Public property | MaxLevel | Imposes a maximum log level constraint (Inherited from Destination.)
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy (Inherited from Destination.)
Public property | MinLevel | Imposes a minimum log level constraint (Inherited from Destination.)
Public property | Name | Provides mnemonic destination name (Inherited from Destination.)
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored (Inherited from Destination.)
Public property | Owner | Returns a composite destination that ownes this destination or null (Inherited from Destination.)
Public property | Path |
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms (Inherited from Destination.)
Public property | Service | References a log service that this destination services (Inherited from Destination.)
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages (Inherited from Destination.)
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages (Inherited from Destination.)
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true (Inherited from Destination.)
Back to Top
See Also
FileDestination Class
NFX.Log.Destinations Namespace


FileDestination.DefaultFileName Property

FileDestination DefaultFileName Property NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual string DefaultFileName { get; }
protected virtual string DefaultFileName { get; }
Protected Overridable ReadOnly Property DefaultFileName As String
    Get
Protected Overridable ReadOnly Property DefaultFileName As String
    Get
protected:
virtual property String^ DefaultFileName {
    String^ get ();
}
protected:
virtual property String^ DefaultFileName {
    String^ get ();
}
abstract DefaultFileName : string with get
override DefaultFileName : string with get
abstract DefaultFileName : string with get
override DefaultFileName : string with get

Property Value

Type: Online String
See Also
FileDestination Class
FileDestination Members
NFX.Log.Destinations Namespace


FileDestination.FileName Property

FileDestination FileName Property NFX Class Library

File name may include environment variables (e.g. ~home), and use macros to specify time "$(~home)$(@::now fmt=yyyyMMdd utc=false)-$($name).log". Pass "utc=true" argument to use UTC

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public virtual string FileName { get; set; }
[ConfigAttribute]
public virtual string FileName { get; set; }
<ConfigAttribute>
Public Overridable Property FileName As String
    Get
    Set
<ConfigAttribute>
Public Overridable Property FileName As String
    Get
    Set
public:
[ConfigAttribute]
virtual property String^ FileName {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
virtual property String^ FileName {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
abstract FileName : string with get, set
[<ConfigAttribute>]
override FileName : string with get, set
[<ConfigAttribute>]
abstract FileName : string with get, set
[<ConfigAttribute>]
override FileName : string with get, set

Property Value

Type: Online String
See Also
FileDestination Class
FileDestination Members
NFX.Log.Destinations Namespace


FileDestination.Path Property

FileDestination Path Property NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public virtual string Path { get; set; }
[ConfigAttribute]
public virtual string Path { get; set; }
<ConfigAttribute>
Public Overridable Property Path As String
    Get
    Set
<ConfigAttribute>
Public Overridable Property Path As String
    Get
    Set
public:
[ConfigAttribute]
virtual property String^ Path {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
virtual property String^ Path {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
abstract Path : string with get, set
[<ConfigAttribute>]
override Path : string with get, set
[<ConfigAttribute>]
abstract Path : string with get, set
[<ConfigAttribute>]
override Path : string with get, set

Property Value

Type: Online String
See Also
FileDestination Class
FileDestination Members
NFX.Log.Destinations Namespace


FloodFilter Class

FloodFilter Class NFX Class Library

Implements a destination group that stops message flood
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Log.Destinations Destination
NFX.Log.Destinations CompositeDestination
NFX.Log.Destinations FloodFilter

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class FloodFilter : CompositeDestination
public class FloodFilter : CompositeDestination
Public Class FloodFilter
    Inherits CompositeDestination
Public Class FloodFilter
    Inherits CompositeDestination
public ref class FloodFilter : public CompositeDestination
public ref class FloodFilter : public CompositeDestination
type FloodFilter =
    class
        inherit CompositeDestination
    end
type FloodFilter =
    class
        inherit CompositeDestination
    end
See Also
FloodFilter Members
NFX.Log.Destinations Namespace


FloodFilter Members

FloodFilter Members NFX Class Library

The FloodFilter type exposes the following members.
Constructors
 | Name | Description
Public method | FloodFilter | Creates a filter that prevents message flood
Public method | FloodFilter( Destination ) | Creates a filter that prevents message flood
Public method | FloodFilter(String, Destination ) | Creates a filter that prevents message flood
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc | (Inherited from Destination.)
Public method | Close | (Overrides CompositeDestination Close .)
Public method | Configure | Configures specified destination (Inherited from Destination.)
Protected method | Destructor | (Overrides CompositeDestination Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure | (Inherited from CompositeDestination.)
Protected method | DoPulse | (Overrides Destination DoPulse .)
Protected method | DoSend | (Overrides CompositeDestination DoSend(Message).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Destination.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Destination.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | (Overrides CompositeDestination Open .)
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Public method | RegisterDestination | Adds a destination to this wrapper (Inherited from CompositeDestination.)
Public method | Send | Sends the message into destination doing filter checks first. (Inherited from Destination.)
Protected method | SendRegularAndFailures | (Inherited from Destination.)
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message (Inherited from Destination.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UnRegisterDestination | Removes a destiantion from this wrapper, returns true if destination was found and removed (Inherited from CompositeDestination.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one (Inherited from Destination.)
Public field | Before | Allows to insert a destination right before this one (Inherited from Destination.)
 | DEFAULT_INTERVAL_SEC |
 | DEFAULT_MAX_COUNT |
 | DEFAULT_MAX_TEXT_LENGTH |
Protected field | m_Name | (Inherited from Destination.)
Protected field | m_Owner | (Inherited from Destination.)
 | MAX_MAX_COUNT |
Back to Top
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f (Inherited from Destination.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages (Inherited from Destination.)
Public property | Destinations | Returns destinations that this destination wraps. This call is thread safe (Inherited from CompositeDestination.)
Public property | DirectorLog | (Inherited from Destination.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages (Inherited from Destination.)
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages (Inherited from Destination.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public property | Failover | Sets destination name used for failover of this one (Inherited from Destination.)
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result (Inherited from Destination.)
Public property | FilterMethod | References message filtering method or null (Inherited from Destination.)
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default. (Inherited from Destination.)
Public property | IntervalSec |
Public property | LastError | Returns last error that this destination has encountered (Inherited from Destination.)
Public property | Levels | (Inherited from Destination.)
Public property | MaxCount | Sets how many messages may be batched per interval. If more messages arrive then their data is not going to be logged
Public property | MaxLevel | Imposes a maximum log level constraint (Inherited from Destination.)
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy (Inherited from Destination.)
Public property | MaxTextLength | Imposes a limit in character length of combined message test
Public property | MessageFrom | Determines the message from for message emitted when flood is detected
Public property | MessageSource | Determines the message topic for message emitted when flood is detected
Public property | MessageTopic | Determines the message topic for message emitted when flood is detected
Public property | MessageType | Determines the message type for message emitted when flood is detected
Public property | MinLevel | Imposes a minimum log level constraint (Inherited from Destination.)
Public property | Name | Provides mnemonic destination name (Inherited from Destination.)
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored (Inherited from Destination.)
Public property | Owner | Returns a composite destination that ownes this destination or null (Inherited from Destination.)
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms (Inherited from Destination.)
Public property | Service | References a log service that this destination services (Inherited from Destination.)
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages (Inherited from Destination.)
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages (Inherited from Destination.)
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true (Inherited from Destination.)
Back to Top
See Also
FloodFilter Class
NFX.Log.Destinations Namespace


FloodFilter Constructor

FloodFilter Constructor NFX Class Library

Overload List
 | Name | Description
Public method | FloodFilter | Creates a filter that prevents message flood
Public method | FloodFilter( Destination ) | Creates a filter that prevents message flood
Public method | FloodFilter(String, Destination ) | Creates a filter that prevents message flood
Back to Top
See Also
FloodFilter Class
FloodFilter Members
NFX.Log.Destinations Namespace


FloodFilter Constructor

FloodFilter Constructor NFX Class Library

Creates a filter that prevents message flood

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FloodFilter()
public FloodFilter()
Public Sub New
Public Sub New
public:
FloodFilter()
public:
FloodFilter()
new : unit -> FloodFilter
new : unit -> FloodFilter
See Also
FloodFilter Class
FloodFilter Members
FloodFilter Overload
NFX.Log.Destinations Namespace


FloodFilter Constructor (Destination[])

FloodFilter Constructor ( Destination ) NFX Class Library

Creates a filter that prevents message flood

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FloodFilter(
    params Destination[] inner
)
public FloodFilter(
    params Destination[] inner
)
Public Sub New (
    ParamArray inner As Destination()
)
Public Sub New (
    ParamArray inner As Destination()
)
public:
FloodFilter(
    ... array<Destination^>^ inner
)
public:
FloodFilter(
    ... array<Destination^>^ inner
)
new :
        inner : Destination[] -> FloodFilter
new :
        inner : Destination[] -> FloodFilter

Parameters

inner
Type: NFX.Log.Destinations Destination
See Also
FloodFilter Class
FloodFilter Members
FloodFilter Overload
NFX.Log.Destinations Namespace


FloodFilter Constructor (String, Destination[])

FloodFilter Constructor (String, Destination ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates a filter that prevents message flood

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FloodFilter(
    string name,
    params Destination[] inner
)
public FloodFilter(
    string name,
    params Destination[] inner
)
Public Sub New (
    name As String,
    ParamArray inner As Destination()
)
Public Sub New (
    name As String,
    ParamArray inner As Destination()
)
public:
FloodFilter(
    String^ name,
    ... array<Destination^>^ inner
)
public:
FloodFilter(
    String^ name,
    ... array<Destination^>^ inner
)
new :
        name : string *
        inner : Destination[] -> FloodFilter
new :
        name : string *
        inner : Destination[] -> FloodFilter

Parameters

name
Type: Online System String
inner
Type: NFX.Log.Destinations Destination
See Also
FloodFilter Class
FloodFilter Members
FloodFilter Overload
NFX.Log.Destinations Namespace


FloodFilter Fields

FloodFilter Fields NFX Class Library

The FloodFilter type exposes the following members.
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one (Inherited from Destination.)
Public field | Before | Allows to insert a destination right before this one (Inherited from Destination.)
 | DEFAULT_INTERVAL_SEC |
 | DEFAULT_MAX_COUNT |
 | DEFAULT_MAX_TEXT_LENGTH |
Protected field | m_Name | (Inherited from Destination.)
Protected field | m_Owner | (Inherited from Destination.)
 | MAX_MAX_COUNT |
Back to Top
See Also
FloodFilter Class
NFX.Log.Destinations Namespace


FloodFilter.DEFAULT_INTERVAL_SEC Field

FloodFilter DEFAULT_INTERVAL_SEC Field NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_INTERVAL_SEC
public const int DEFAULT_INTERVAL_SEC
Public Const DEFAULT_INTERVAL_SEC As Integer
Public Const DEFAULT_INTERVAL_SEC As Integer
public:
literal int DEFAULT_INTERVAL_SEC
public:
literal int DEFAULT_INTERVAL_SEC
static val mutable DEFAULT_INTERVAL_SEC: int
static val mutable DEFAULT_INTERVAL_SEC: int

Field Value

Type: Online Int32
See Also
FloodFilter Class
FloodFilter Members
NFX.Log.Destinations Namespace


FloodFilter.DEFAULT_MAX_COUNT Field

FloodFilter DEFAULT_MAX_COUNT Field NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_MAX_COUNT
public const int DEFAULT_MAX_COUNT
Public Const DEFAULT_MAX_COUNT As Integer
Public Const DEFAULT_MAX_COUNT As Integer
public:
literal int DEFAULT_MAX_COUNT
public:
literal int DEFAULT_MAX_COUNT
static val mutable DEFAULT_MAX_COUNT: int
static val mutable DEFAULT_MAX_COUNT: int

Field Value

Type: Online Int32
See Also
FloodFilter Class
FloodFilter Members
NFX.Log.Destinations Namespace


FloodFilter.DEFAULT_MAX_TEXT_LENGTH Field

FloodFilter DEFAULT_MAX_TEXT_LENGTH Field NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_MAX_TEXT_LENGTH
public const int DEFAULT_MAX_TEXT_LENGTH
Public Const DEFAULT_MAX_TEXT_LENGTH As Integer
Public Const DEFAULT_MAX_TEXT_LENGTH As Integer
public:
literal int DEFAULT_MAX_TEXT_LENGTH
public:
literal int DEFAULT_MAX_TEXT_LENGTH
static val mutable DEFAULT_MAX_TEXT_LENGTH: int
static val mutable DEFAULT_MAX_TEXT_LENGTH: int

Field Value

Type: Online Int32
See Also
FloodFilter Class
FloodFilter Members
NFX.Log.Destinations Namespace


FloodFilter.MAX_MAX_COUNT Field

FloodFilter MAX_MAX_COUNT Field NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_MAX_COUNT
public const int MAX_MAX_COUNT
Public Const MAX_MAX_COUNT As Integer
Public Const MAX_MAX_COUNT As Integer
public:
literal int MAX_MAX_COUNT
public:
literal int MAX_MAX_COUNT
static val mutable MAX_MAX_COUNT: int
static val mutable MAX_MAX_COUNT: int

Field Value

Type: Online Int32
See Also
FloodFilter Class
FloodFilter Members
NFX.Log.Destinations Namespace


FloodFilter Methods

FloodFilter Methods NFX Class Library

The FloodFilter type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc | (Inherited from Destination.)
Public method | Close | (Overrides CompositeDestination Close .)
Public method | Configure | Configures specified destination (Inherited from Destination.)
Protected method | Destructor | (Overrides CompositeDestination Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure | (Inherited from CompositeDestination.)
Protected method | DoPulse | (Overrides Destination DoPulse .)
Protected method | DoSend | (Overrides CompositeDestination DoSend(Message).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Destination.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Destination.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | (Overrides CompositeDestination Open .)
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Public method | RegisterDestination | Adds a destination to this wrapper (Inherited from CompositeDestination.)
Public method | Send | Sends the message into destination doing filter checks first. (Inherited from Destination.)
Protected method | SendRegularAndFailures | (Inherited from Destination.)
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message (Inherited from Destination.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UnRegisterDestination | Removes a destiantion from this wrapper, returns true if destination was found and removed (Inherited from CompositeDestination.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
FloodFilter Class
NFX.Log.Destinations Namespace


FloodFilter.Close Method

FloodFilter Close Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Close()
public override void Close()
Public Overrides Sub Close
Public Overrides Sub Close
public:
virtual void Close() override
public:
virtual void Close() override
abstract Close : unit -> unit
override Close : unit -> unit
abstract Close : unit -> unit
override Close : unit -> unit
See Also
FloodFilter Class
FloodFilter Members
NFX.Log.Destinations Namespace


FloodFilter.Destructor Method

FloodFilter Destructor Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
FloodFilter Class
FloodFilter Members
NFX.Log.Destinations Namespace


FloodFilter.DoPulse Method

FloodFilter DoPulse Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoPulse()
protected internal override void DoPulse()
Protected Friend Overrides Sub DoPulse
Protected Friend Overrides Sub DoPulse
protected public:
virtual void DoPulse() override
protected public:
virtual void DoPulse() override
abstract DoPulse : unit -> unit
override DoPulse : unit -> unit
abstract DoPulse : unit -> unit
override DoPulse : unit -> unit
See Also
FloodFilter Class
FloodFilter Members
NFX.Log.Destinations Namespace


FloodFilter.DoSend Method

FloodFilter DoSend Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoSend(
    Message entry
)
protected internal override void DoSend(
    Message entry
)
Protected Friend Overrides Sub DoSend (
    entry As Message
)
Protected Friend Overrides Sub DoSend (
    entry As Message
)
protected public:
virtual void DoSend(
    Message^ entry
) override
protected public:
virtual void DoSend(
    Message^ entry
) override
abstract DoSend :
        entry : Message -> unit
override DoSend :
        entry : Message -> unit
abstract DoSend :
        entry : Message -> unit
override DoSend :
        entry : Message -> unit

Parameters

entry
Type: NFX.Log Message
See Also
FloodFilter Class
FloodFilter Members
NFX.Log.Destinations Namespace


FloodFilter.Open Method

FloodFilter Open Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Open()
public override void Open()
Public Overrides Sub Open
Public Overrides Sub Open
public:
virtual void Open() override
public:
virtual void Open() override
abstract Open : unit -> unit
override Open : unit -> unit
abstract Open : unit -> unit
override Open : unit -> unit
See Also
FloodFilter Class
FloodFilter Members
NFX.Log.Destinations Namespace


FloodFilter Properties

FloodFilter Properties NFX Class Library

The FloodFilter type exposes the following members.
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f (Inherited from Destination.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages (Inherited from Destination.)
Public property | Destinations | Returns destinations that this destination wraps. This call is thread safe (Inherited from CompositeDestination.)
Public property | DirectorLog | (Inherited from Destination.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages (Inherited from Destination.)
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages (Inherited from Destination.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public property | Failover | Sets destination name used for failover of this one (Inherited from Destination.)
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result (Inherited from Destination.)
Public property | FilterMethod | References message filtering method or null (Inherited from Destination.)
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default. (Inherited from Destination.)
Public property | IntervalSec |
Public property | LastError | Returns last error that this destination has encountered (Inherited from Destination.)
Public property | Levels | (Inherited from Destination.)
Public property | MaxCount | Sets how many messages may be batched per interval. If more messages arrive then their data is not going to be logged
Public property | MaxLevel | Imposes a maximum log level constraint (Inherited from Destination.)
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy (Inherited from Destination.)
Public property | MaxTextLength | Imposes a limit in character length of combined message test
Public property | MessageFrom | Determines the message from for message emitted when flood is detected
Public property | MessageSource | Determines the message topic for message emitted when flood is detected
Public property | MessageTopic | Determines the message topic for message emitted when flood is detected
Public property | MessageType | Determines the message type for message emitted when flood is detected
Public property | MinLevel | Imposes a minimum log level constraint (Inherited from Destination.)
Public property | Name | Provides mnemonic destination name (Inherited from Destination.)
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored (Inherited from Destination.)
Public property | Owner | Returns a composite destination that ownes this destination or null (Inherited from Destination.)
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms (Inherited from Destination.)
Public property | Service | References a log service that this destination services (Inherited from Destination.)
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages (Inherited from Destination.)
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages (Inherited from Destination.)
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true (Inherited from Destination.)
Back to Top
See Also
FloodFilter Class
NFX.Log.Destinations Namespace


FloodFilter.IntervalSec Property

FloodFilter IntervalSec Property NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int IntervalSec { get; set; }
[ConfigAttribute]
public int IntervalSec { get; set; }
<ConfigAttribute>
Public Property IntervalSec As Integer
    Get
    Set
<ConfigAttribute>
Public Property IntervalSec As Integer
    Get
    Set
public:
[ConfigAttribute]
property int IntervalSec {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute]
property int IntervalSec {
    int get ();
    void set (int value);
}
[<ConfigAttribute>]
member IntervalSec : int with get, set
[<ConfigAttribute>]
member IntervalSec : int with get, set

Property Value

Type: Online Int32
See Also
FloodFilter Class
FloodFilter Members
NFX.Log.Destinations Namespace


FloodFilter.MaxCount Property

FloodFilter MaxCount Property NFX Class Library

Sets how many messages may be batched per interval. If more messages arrive then their data is not going to be logged

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int MaxCount { get; set; }
[ConfigAttribute]
public int MaxCount { get; set; }
<ConfigAttribute>
Public Property MaxCount As Integer
    Get
    Set
<ConfigAttribute>
Public Property MaxCount As Integer
    Get
    Set
public:
[ConfigAttribute]
property int MaxCount {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute]
property int MaxCount {
    int get ();
    void set (int value);
}
[<ConfigAttribute>]
member MaxCount : int with get, set
[<ConfigAttribute>]
member MaxCount : int with get, set

Property Value

Type: Online Int32
See Also
FloodFilter Class
FloodFilter Members
NFX.Log.Destinations Namespace


FloodFilter.MaxTextLength Property

FloodFilter MaxTextLength Property NFX Class Library

Imposes a limit in character length of combined message test

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int MaxTextLength { get; set; }
[ConfigAttribute]
public int MaxTextLength { get; set; }
<ConfigAttribute>
Public Property MaxTextLength As Integer
    Get
    Set
<ConfigAttribute>
Public Property MaxTextLength As Integer
    Get
    Set
public:
[ConfigAttribute]
property int MaxTextLength {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute]
property int MaxTextLength {
    int get ();
    void set (int value);
}
[<ConfigAttribute>]
member MaxTextLength : int with get, set
[<ConfigAttribute>]
member MaxTextLength : int with get, set

Property Value

Type: Online Int32
See Also
FloodFilter Class
FloodFilter Members
NFX.Log.Destinations Namespace


FloodFilter.MessageFrom Property

FloodFilter MessageFrom Property NFX Class Library

Determines the message from for message emitted when flood is detected

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string MessageFrom { get; set; }
[ConfigAttribute]
public string MessageFrom { get; set; }
<ConfigAttribute>
Public Property MessageFrom As String
    Get
    Set
<ConfigAttribute>
Public Property MessageFrom As String
    Get
    Set
public:
[ConfigAttribute]
property String^ MessageFrom {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ MessageFrom {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member MessageFrom : string with get, set
[<ConfigAttribute>]
member MessageFrom : string with get, set

Property Value

Type: Online String
See Also
FloodFilter Class
FloodFilter Members
NFX.Log.Destinations Namespace


FloodFilter.MessageSource Property

FloodFilter MessageSource Property NFX Class Library

Determines the message topic for message emitted when flood is detected

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int MessageSource { get; set; }
[ConfigAttribute]
public int MessageSource { get; set; }
<ConfigAttribute>
Public Property MessageSource As Integer
    Get
    Set
<ConfigAttribute>
Public Property MessageSource As Integer
    Get
    Set
public:
[ConfigAttribute]
property int MessageSource {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute]
property int MessageSource {
    int get ();
    void set (int value);
}
[<ConfigAttribute>]
member MessageSource : int with get, set
[<ConfigAttribute>]
member MessageSource : int with get, set

Property Value

Type: Online Int32
See Also
FloodFilter Class
FloodFilter Members
NFX.Log.Destinations Namespace


FloodFilter.MessageTopic Property

FloodFilter MessageTopic Property NFX Class Library

Determines the message topic for message emitted when flood is detected

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string MessageTopic { get; set; }
[ConfigAttribute]
public string MessageTopic { get; set; }
<ConfigAttribute>
Public Property MessageTopic As String
    Get
    Set
<ConfigAttribute>
Public Property MessageTopic As String
    Get
    Set
public:
[ConfigAttribute]
property String^ MessageTopic {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ MessageTopic {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member MessageTopic : string with get, set
[<ConfigAttribute>]
member MessageTopic : string with get, set

Property Value

Type: Online String
See Also
FloodFilter Class
FloodFilter Members
NFX.Log.Destinations Namespace


FloodFilter.MessageType Property

FloodFilter MessageType Property NFX Class Library

Determines the message type for message emitted when flood is detected

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public MessageType MessageType { get; set; }
[ConfigAttribute]
public MessageType MessageType { get; set; }
<ConfigAttribute>
Public Property MessageType As MessageType
    Get
    Set
<ConfigAttribute>
Public Property MessageType As MessageType
    Get
    Set
public:
[ConfigAttribute]
property MessageType MessageType {
    MessageType get ();
    void set (MessageType value);
}
public:
[ConfigAttribute]
property MessageType MessageType {
    MessageType get ();
    void set (MessageType value);
}
[<ConfigAttribute>]
member MessageType : MessageType with get, set
[<ConfigAttribute>]
member MessageType : MessageType with get, set

Property Value

Type: MessageType
See Also
FloodFilter Class
FloodFilter Members
NFX.Log.Destinations Namespace


LogServiceDestination Class

LogServiceDestination Class NFX Class Library

Implements a destination that is based on another instance of LogService, which provides asynchronous buffering and failover capabilities.
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Log.Destinations Destination
NFX.Log.Destinations LogServiceDestination

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LogServiceDestination : Destination
public class LogServiceDestination : Destination
Public Class LogServiceDestination
    Inherits Destination
Public Class LogServiceDestination
    Inherits Destination
public ref class LogServiceDestination : public Destination
public ref class LogServiceDestination : public Destination
type LogServiceDestination =
    class
        inherit Destination
    end
type LogServiceDestination =
    class
        inherit Destination
    end
See Also
LogServiceDestination Members
NFX.Log.Destinations Namespace


LogServiceDestination Members

LogServiceDestination Members NFX Class Library

The LogServiceDestination type exposes the following members.
Constructors
 | Name | Description
Public method | LogServiceDestination | Initializes a new instance of the LogServiceDestination class
Public method | LogServiceDestination(String) | Initializes a new instance of the LogServiceDestination class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc | (Inherited from Destination.)
Public method | Close | (Overrides Destination Close .)
Public method | Configure | Configures specified destination (Inherited from Destination.)
Protected method | Destructor | (Overrides Destination Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure | (Overrides Destination DoConfigure(IConfigSectionNode).)
Protected method | DoPulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Protected method | DoSend | (Overrides Destination DoSend(Message).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Destination.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Destination.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | (Overrides Destination Open .)
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Public method | Send | Sends the message into destination doing filter checks first. (Inherited from Destination.)
Protected method | SendRegularAndFailures | (Inherited from Destination.)
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message (Inherited from Destination.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one (Inherited from Destination.)
Public field | Before | Allows to insert a destination right before this one (Inherited from Destination.)
Protected field | m_Name | (Inherited from Destination.)
Protected field | m_Owner | (Inherited from Destination.)
Back to Top
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f (Inherited from Destination.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages (Inherited from Destination.)
Public property | DirectorLog | (Inherited from Destination.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages (Inherited from Destination.)
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages (Inherited from Destination.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public property | Failover | Sets destination name used for failover of this one (Inherited from Destination.)
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result (Inherited from Destination.)
Public property | FilterMethod | References message filtering method or null (Inherited from Destination.)
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default. (Inherited from Destination.)
Public property | LastError | Returns last error that this destination has encountered (Inherited from Destination.)
Public property | Levels | (Inherited from Destination.)
Public property | MaxLevel | Imposes a maximum log level constraint (Inherited from Destination.)
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy (Inherited from Destination.)
Public property | MinLevel | Imposes a minimum log level constraint (Inherited from Destination.)
Public property | Name | Provides mnemonic destination name (Inherited from Destination.)
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored (Inherited from Destination.)
Public property | Owner | Returns a composite destination that ownes this destination or null (Inherited from Destination.)
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms (Inherited from Destination.)
Public property | Service | References a log service that this destination services (Inherited from Destination.)
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages (Inherited from Destination.)
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages (Inherited from Destination.)
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true (Inherited from Destination.)
Back to Top
See Also
LogServiceDestination Class
NFX.Log.Destinations Namespace


LogServiceDestination Constructor

LogServiceDestination Constructor NFX Class Library

Overload List
 | Name | Description
Public method | LogServiceDestination | Initializes a new instance of the LogServiceDestination class
Public method | LogServiceDestination(String) | Initializes a new instance of the LogServiceDestination class
Back to Top
See Also
LogServiceDestination Class
LogServiceDestination Members
NFX.Log.Destinations Namespace


LogServiceDestination Constructor

LogServiceDestination Constructor NFX Class Library

Initializes a new instance of the LogServiceDestination class

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LogServiceDestination()
public LogServiceDestination()
Public Sub New
Public Sub New
public:
LogServiceDestination()
public:
LogServiceDestination()
new : unit -> LogServiceDestination
new : unit -> LogServiceDestination
See Also
LogServiceDestination Class
LogServiceDestination Members
LogServiceDestination Overload
NFX.Log.Destinations Namespace


LogServiceDestination Constructor (String)

LogServiceDestination Constructor (String) NFX Class Library

Initializes a new instance of the LogServiceDestination class

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LogServiceDestination(
    string name
)
public LogServiceDestination(
    string name
)
Public Sub New (
    name As String
)
Public Sub New (
    name As String
)
public:
LogServiceDestination(
    String^ name
)
public:
LogServiceDestination(
    String^ name
)
new :
        name : string -> LogServiceDestination
new :
        name : string -> LogServiceDestination

Parameters

name
Type: Online System String
See Also
LogServiceDestination Class
LogServiceDestination Members
LogServiceDestination Overload
NFX.Log.Destinations Namespace


LogServiceDestination Fields

LogServiceDestination Fields NFX Class Library

The LogServiceDestination type exposes the following members.
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one (Inherited from Destination.)
Public field | Before | Allows to insert a destination right before this one (Inherited from Destination.)
Protected field | m_Name | (Inherited from Destination.)
Protected field | m_Owner | (Inherited from Destination.)
Back to Top
See Also
LogServiceDestination Class
NFX.Log.Destinations Namespace


LogServiceDestination Methods

LogServiceDestination Methods NFX Class Library

The LogServiceDestination type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc | (Inherited from Destination.)
Public method | Close | (Overrides Destination Close .)
Public method | Configure | Configures specified destination (Inherited from Destination.)
Protected method | Destructor | (Overrides Destination Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure | (Overrides Destination DoConfigure(IConfigSectionNode).)
Protected method | DoPulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Protected method | DoSend | (Overrides Destination DoSend(Message).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Destination.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Destination.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | (Overrides Destination Open .)
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Public method | Send | Sends the message into destination doing filter checks first. (Inherited from Destination.)
Protected method | SendRegularAndFailures | (Inherited from Destination.)
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message (Inherited from Destination.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LogServiceDestination Class
NFX.Log.Destinations Namespace


LogServiceDestination.Close Method

LogServiceDestination Close Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Close()
public override void Close()
Public Overrides Sub Close
Public Overrides Sub Close
public:
virtual void Close() override
public:
virtual void Close() override
abstract Close : unit -> unit
override Close : unit -> unit
abstract Close : unit -> unit
override Close : unit -> unit
See Also
LogServiceDestination Class
LogServiceDestination Members
NFX.Log.Destinations Namespace


LogServiceDestination.Destructor Method

LogServiceDestination Destructor Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
LogServiceDestination Class
LogServiceDestination Members
NFX.Log.Destinations Namespace


LogServiceDestination.DoConfigure Method

LogServiceDestination DoConfigure Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
LogServiceDestination Class
LogServiceDestination Members
NFX.Log.Destinations Namespace


LogServiceDestination.DoSend Method

LogServiceDestination DoSend Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoSend(
    Message msg
)
protected internal override void DoSend(
    Message msg
)
Protected Friend Overrides Sub DoSend (
    msg As Message
)
Protected Friend Overrides Sub DoSend (
    msg As Message
)
protected public:
virtual void DoSend(
    Message^ msg
) override
protected public:
virtual void DoSend(
    Message^ msg
) override
abstract DoSend :
        msg : Message -> unit
override DoSend :
        msg : Message -> unit
abstract DoSend :
        msg : Message -> unit
override DoSend :
        msg : Message -> unit

Parameters

msg
Type: NFX.Log Message
See Also
LogServiceDestination Class
LogServiceDestination Members
NFX.Log.Destinations Namespace


LogServiceDestination.Open Method

LogServiceDestination Open Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Open()
public override void Open()
Public Overrides Sub Open
Public Overrides Sub Open
public:
virtual void Open() override
public:
virtual void Open() override
abstract Open : unit -> unit
override Open : unit -> unit
abstract Open : unit -> unit
override Open : unit -> unit
See Also
LogServiceDestination Class
LogServiceDestination Members
NFX.Log.Destinations Namespace


LogServiceDestination Properties

LogServiceDestination Properties NFX Class Library

The LogServiceDestination type exposes the following members.
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f (Inherited from Destination.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages (Inherited from Destination.)
Public property | DirectorLog | (Inherited from Destination.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages (Inherited from Destination.)
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages (Inherited from Destination.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public property | Failover | Sets destination name used for failover of this one (Inherited from Destination.)
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result (Inherited from Destination.)
Public property | FilterMethod | References message filtering method or null (Inherited from Destination.)
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default. (Inherited from Destination.)
Public property | LastError | Returns last error that this destination has encountered (Inherited from Destination.)
Public property | Levels | (Inherited from Destination.)
Public property | MaxLevel | Imposes a maximum log level constraint (Inherited from Destination.)
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy (Inherited from Destination.)
Public property | MinLevel | Imposes a minimum log level constraint (Inherited from Destination.)
Public property | Name | Provides mnemonic destination name (Inherited from Destination.)
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored (Inherited from Destination.)
Public property | Owner | Returns a composite destination that ownes this destination or null (Inherited from Destination.)
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms (Inherited from Destination.)
Public property | Service | References a log service that this destination services (Inherited from Destination.)
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages (Inherited from Destination.)
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages (Inherited from Destination.)
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true (Inherited from Destination.)
Back to Top
See Also
LogServiceDestination Class
NFX.Log.Destinations Namespace


MemoryBufferDestination Class

MemoryBufferDestination Class NFX Class Library

Implements a destination that caches up to specified number of latest log messages in memory
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Log.Destinations Destination
NFX.Log.Destinations MemoryBufferDestination

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class MemoryBufferDestination : Destination
public sealed class MemoryBufferDestination : Destination
Public NotInheritable Class MemoryBufferDestination
    Inherits Destination
Public NotInheritable Class MemoryBufferDestination
    Inherits Destination
public ref class MemoryBufferDestination sealed : public Destination
public ref class MemoryBufferDestination sealed : public Destination
[<SealedAttribute>]
type MemoryBufferDestination =
    class
        inherit Destination
    end
[<SealedAttribute>]
type MemoryBufferDestination =
    class
        inherit Destination
    end
See Also
MemoryBufferDestination Members
NFX.Log.Destinations Namespace


MemoryBufferDestination Members

MemoryBufferDestination Members NFX Class Library

The MemoryBufferDestination type exposes the following members.
Constructors
 | Name | Description
Public method | MemoryBufferDestination | Initializes a new instance of the MemoryBufferDestination class
Public method | MemoryBufferDestination(String) | Initializes a new instance of the MemoryBufferDestination class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc | (Inherited from Destination.)
Public method | ClearBuffer | Deletes all buffered messages
Public method | Close | (Overrides Destination Close .)
Public method | Configure | Configures specified destination (Inherited from Destination.)
Protected method | Destructor | (Overrides Destination Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure | Override to perform derivative-specific configuration (Inherited from Destination.)
Protected method | DoPulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Protected method | DoSend | (Overrides Destination DoSend(Message).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Destination.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Destination.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | (Overrides Destination Open .)
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Public method | Send | Sends the message into destination doing filter checks first. (Inherited from Destination.)
Protected method | SendRegularAndFailures | (Inherited from Destination.)
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message (Inherited from Destination.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one (Inherited from Destination.)
Public field | Before | Allows to insert a destination right before this one (Inherited from Destination.)
 | BUFFER_SIZE_DEFAULT |
Protected field | m_Name | (Inherited from Destination.)
Protected field | m_Owner | (Inherited from Destination.)
Back to Top
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f (Inherited from Destination.)
Public property | Buffered | Returns all buffered log messages, where X = BufferSize property
Public property | BufferedTimeAscending | Returns all buffered log messages ordered by timestamp ascending
Public property | BufferedTimeDescending | Returns all buffered log messages ordered by timestamp descending
Public property | BufferSize |
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages (Inherited from Destination.)
Public property | DirectorLog | (Inherited from Destination.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages (Inherited from Destination.)
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages (Inherited from Destination.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public property | Failover | Sets destination name used for failover of this one (Inherited from Destination.)
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result (Inherited from Destination.)
Public property | FilterMethod | References message filtering method or null (Inherited from Destination.)
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default. (Inherited from Destination.)
Public property | LastError | Returns last error that this destination has encountered (Inherited from Destination.)
Public property | Levels | (Inherited from Destination.)
Public property | MaxLevel | Imposes a maximum log level constraint (Inherited from Destination.)
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy (Inherited from Destination.)
Public property | MinLevel | Imposes a minimum log level constraint (Inherited from Destination.)
Public property | Name | Provides mnemonic destination name (Inherited from Destination.)
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored (Inherited from Destination.)
Public property | Owner | Returns a composite destination that ownes this destination or null (Inherited from Destination.)
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms (Inherited from Destination.)
Public property | Service | References a log service that this destination services (Inherited from Destination.)
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages (Inherited from Destination.)
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages (Inherited from Destination.)
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true (Inherited from Destination.)
Back to Top
See Also
MemoryBufferDestination Class
NFX.Log.Destinations Namespace


MemoryBufferDestination Constructor

MemoryBufferDestination Constructor NFX Class Library

Overload List
 | Name | Description
Public method | MemoryBufferDestination | Initializes a new instance of the MemoryBufferDestination class
Public method | MemoryBufferDestination(String) | Initializes a new instance of the MemoryBufferDestination class
Back to Top
See Also
MemoryBufferDestination Class
MemoryBufferDestination Members
NFX.Log.Destinations Namespace


MemoryBufferDestination Constructor

MemoryBufferDestination Constructor NFX Class Library

Initializes a new instance of the MemoryBufferDestination class

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MemoryBufferDestination()
public MemoryBufferDestination()
Public Sub New
Public Sub New
public:
MemoryBufferDestination()
public:
MemoryBufferDestination()
new : unit -> MemoryBufferDestination
new : unit -> MemoryBufferDestination
See Also
MemoryBufferDestination Class
MemoryBufferDestination Members
MemoryBufferDestination Overload
NFX.Log.Destinations Namespace


MemoryBufferDestination Constructor (String)

MemoryBufferDestination Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MemoryBufferDestination class

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MemoryBufferDestination(
    string name
)
public MemoryBufferDestination(
    string name
)
Public Sub New (
    name As String
)
Public Sub New (
    name As String
)
public:
MemoryBufferDestination(
    String^ name
)
public:
MemoryBufferDestination(
    String^ name
)
new :
        name : string -> MemoryBufferDestination
new :
        name : string -> MemoryBufferDestination

Parameters

name
Type: Online System String
See Also
MemoryBufferDestination Class
MemoryBufferDestination Members
MemoryBufferDestination Overload
NFX.Log.Destinations Namespace


MemoryBufferDestination Fields

MemoryBufferDestination Fields NFX Class Library

The MemoryBufferDestination type exposes the following members.
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one (Inherited from Destination.)
Public field | Before | Allows to insert a destination right before this one (Inherited from Destination.)
 | BUFFER_SIZE_DEFAULT |
Protected field | m_Name | (Inherited from Destination.)
Protected field | m_Owner | (Inherited from Destination.)
Back to Top
See Also
MemoryBufferDestination Class
NFX.Log.Destinations Namespace


MemoryBufferDestination.BUFFER_SIZE_DEFAULT Field

MemoryBufferDestination BUFFER_SIZE_DEFAULT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int BUFFER_SIZE_DEFAULT
public const int BUFFER_SIZE_DEFAULT
Public Const BUFFER_SIZE_DEFAULT As Integer
Public Const BUFFER_SIZE_DEFAULT As Integer
public:
literal int BUFFER_SIZE_DEFAULT
public:
literal int BUFFER_SIZE_DEFAULT
static val mutable BUFFER_SIZE_DEFAULT: int
static val mutable BUFFER_SIZE_DEFAULT: int

Field Value

Type: Online Int32
See Also
MemoryBufferDestination Class
MemoryBufferDestination Members
NFX.Log.Destinations Namespace


MemoryBufferDestination Methods

MemoryBufferDestination Methods NFX Class Library

The MemoryBufferDestination type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc | (Inherited from Destination.)
Public method | ClearBuffer | Deletes all buffered messages
Public method | Close | (Overrides Destination Close .)
Public method | Configure | Configures specified destination (Inherited from Destination.)
Protected method | Destructor | (Overrides Destination Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure | Override to perform derivative-specific configuration (Inherited from Destination.)
Protected method | DoPulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Protected method | DoSend | (Overrides Destination DoSend(Message).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Destination.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Destination.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | (Overrides Destination Open .)
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Public method | Send | Sends the message into destination doing filter checks first. (Inherited from Destination.)
Protected method | SendRegularAndFailures | (Inherited from Destination.)
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message (Inherited from Destination.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MemoryBufferDestination Class
NFX.Log.Destinations Namespace


MemoryBufferDestination.ClearBuffer Method

MemoryBufferDestination ClearBuffer Method NFX Class Library

Deletes all buffered messages

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ClearBuffer()
public void ClearBuffer()
Public Sub ClearBuffer
Public Sub ClearBuffer
public:
void ClearBuffer()
public:
void ClearBuffer()
member ClearBuffer : unit -> unit
member ClearBuffer : unit -> unit
See Also
MemoryBufferDestination Class
MemoryBufferDestination Members
NFX.Log.Destinations Namespace


MemoryBufferDestination.Close Method

MemoryBufferDestination Close Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Close()
public override void Close()
Public Overrides Sub Close
Public Overrides Sub Close
public:
virtual void Close() override
public:
virtual void Close() override
abstract Close : unit -> unit
override Close : unit -> unit
abstract Close : unit -> unit
override Close : unit -> unit
See Also
MemoryBufferDestination Class
MemoryBufferDestination Members
NFX.Log.Destinations Namespace


MemoryBufferDestination.Destructor Method

MemoryBufferDestination Destructor Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
MemoryBufferDestination Class
MemoryBufferDestination Members
NFX.Log.Destinations Namespace


MemoryBufferDestination.DoSend Method

MemoryBufferDestination DoSend Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoSend(
    Message entry
)
protected internal override void DoSend(
    Message entry
)
Protected Friend Overrides Sub DoSend (
    entry As Message
)
Protected Friend Overrides Sub DoSend (
    entry As Message
)
protected public:
virtual void DoSend(
    Message^ entry
) override
protected public:
virtual void DoSend(
    Message^ entry
) override
abstract DoSend :
        entry : Message -> unit
override DoSend :
        entry : Message -> unit
abstract DoSend :
        entry : Message -> unit
override DoSend :
        entry : Message -> unit

Parameters

entry
Type: NFX.Log Message
See Also
MemoryBufferDestination Class
MemoryBufferDestination Members
NFX.Log.Destinations Namespace


MemoryBufferDestination.Open Method

MemoryBufferDestination Open Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Open()
public override void Open()
Public Overrides Sub Open
Public Overrides Sub Open
public:
virtual void Open() override
public:
virtual void Open() override
abstract Open : unit -> unit
override Open : unit -> unit
abstract Open : unit -> unit
override Open : unit -> unit
See Also
MemoryBufferDestination Class
MemoryBufferDestination Members
NFX.Log.Destinations Namespace


MemoryBufferDestination Properties

MemoryBufferDestination Properties NFX Class Library

The MemoryBufferDestination type exposes the following members.
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f (Inherited from Destination.)
Public property | Buffered | Returns all buffered log messages, where X = BufferSize property
Public property | BufferedTimeAscending | Returns all buffered log messages ordered by timestamp ascending
Public property | BufferedTimeDescending | Returns all buffered log messages ordered by timestamp descending
Public property | BufferSize |
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages (Inherited from Destination.)
Public property | DirectorLog | (Inherited from Destination.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages (Inherited from Destination.)
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages (Inherited from Destination.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public property | Failover | Sets destination name used for failover of this one (Inherited from Destination.)
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result (Inherited from Destination.)
Public property | FilterMethod | References message filtering method or null (Inherited from Destination.)
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default. (Inherited from Destination.)
Public property | LastError | Returns last error that this destination has encountered (Inherited from Destination.)
Public property | Levels | (Inherited from Destination.)
Public property | MaxLevel | Imposes a maximum log level constraint (Inherited from Destination.)
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy (Inherited from Destination.)
Public property | MinLevel | Imposes a minimum log level constraint (Inherited from Destination.)
Public property | Name | Provides mnemonic destination name (Inherited from Destination.)
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored (Inherited from Destination.)
Public property | Owner | Returns a composite destination that ownes this destination or null (Inherited from Destination.)
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms (Inherited from Destination.)
Public property | Service | References a log service that this destination services (Inherited from Destination.)
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages (Inherited from Destination.)
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages (Inherited from Destination.)
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true (Inherited from Destination.)
Back to Top
See Also
MemoryBufferDestination Class
NFX.Log.Destinations Namespace


MemoryBufferDestination.Buffered Property

MemoryBufferDestination Buffered Property NFX Class Library

Returns all buffered log messages, where X = BufferSize property

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Message> Buffered { get; }
public IEnumerable<Message> Buffered { get; }
Public ReadOnly Property Buffered As IEnumerable(Of Message)
    Get
Public ReadOnly Property Buffered As IEnumerable(Of Message)
    Get
public:
property IEnumerable<Message^>^ Buffered {
    IEnumerable<Message^>^ get ();
}
public:
property IEnumerable<Message^>^ Buffered {
    IEnumerable<Message^>^ get ();
}
member Buffered : IEnumerable<Message> with get
member Buffered : IEnumerable<Message> with get

Property Value

Type: Online IEnumerable Message
See Also
MemoryBufferDestination Class
MemoryBufferDestination Members
NFX.Log.Destinations Namespace


MemoryBufferDestination.BufferedTimeAscending Property

MemoryBufferDestination BufferedTimeAscending Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns all buffered log messages ordered by timestamp ascending

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Message> BufferedTimeAscending { get; }
public IEnumerable<Message> BufferedTimeAscending { get; }
Public ReadOnly Property BufferedTimeAscending As IEnumerable(Of Message)
    Get
Public ReadOnly Property BufferedTimeAscending As IEnumerable(Of Message)
    Get
public:
property IEnumerable<Message^>^ BufferedTimeAscending {
    IEnumerable<Message^>^ get ();
}
public:
property IEnumerable<Message^>^ BufferedTimeAscending {
    IEnumerable<Message^>^ get ();
}
member BufferedTimeAscending : IEnumerable<Message> with get
member BufferedTimeAscending : IEnumerable<Message> with get

Property Value

Type: Online IEnumerable Message
See Also
MemoryBufferDestination Class
MemoryBufferDestination Members
NFX.Log.Destinations Namespace


MemoryBufferDestination.BufferedTimeDescending Property

MemoryBufferDestination BufferedTimeDescending Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns all buffered log messages ordered by timestamp descending

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Message> BufferedTimeDescending { get; }
public IEnumerable<Message> BufferedTimeDescending { get; }
Public ReadOnly Property BufferedTimeDescending As IEnumerable(Of Message)
    Get
Public ReadOnly Property BufferedTimeDescending As IEnumerable(Of Message)
    Get
public:
property IEnumerable<Message^>^ BufferedTimeDescending {
    IEnumerable<Message^>^ get ();
}
public:
property IEnumerable<Message^>^ BufferedTimeDescending {
    IEnumerable<Message^>^ get ();
}
member BufferedTimeDescending : IEnumerable<Message> with get
member BufferedTimeDescending : IEnumerable<Message> with get

Property Value

Type: Online IEnumerable Message
See Also
MemoryBufferDestination Class
MemoryBufferDestination Members
NFX.Log.Destinations Namespace


MemoryBufferDestination.BufferSize Property

MemoryBufferDestination BufferSize Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public int BufferSize { get; set; }
[ConfigAttribute]
[ExternalParameterAttribute(new string[] { ... })]
public int BufferSize { get; set; }
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property BufferSize As Integer
    Get
    Set
<ConfigAttribute>
<ExternalParameterAttribute(New String() { ... })>
Public Property BufferSize As Integer
    Get
    Set
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property int BufferSize {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
property int BufferSize {
    int get ();
    void set (int value);
}
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
member BufferSize : int with get, set
[<ConfigAttribute>]
[<ExternalParameterAttribute(new string[] { ... })>]
member BufferSize : int with get, set

Property Value

Type: Online Int32
See Also
MemoryBufferDestination Class
MemoryBufferDestination Members
NFX.Log.Destinations Namespace


MessageFilterHandler Delegate

MessageFilterHandler Delegate NFX Class Library

Delegate for message filtering

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate bool MessageFilterHandler(
    Destination destination,
    Message msg
)
public delegate bool MessageFilterHandler(
    Destination destination,
    Message msg
)
Public Delegate Function MessageFilterHandler (
    destination As Destination,
    msg As Message
) As Boolean
Public Delegate Function MessageFilterHandler (
    destination As Destination,
    msg As Message
) As Boolean
public delegate bool MessageFilterHandler(
    Destination^ destination,
    Message^ msg
)
public delegate bool MessageFilterHandler(
    Destination^ destination,
    Message^ msg
)
type MessageFilterHandler =
    delegate of
        destination : Destination *
        msg : Message -> bool
type MessageFilterHandler =
    delegate of
        destination : Destination *
        msg : Message -> bool

Parameters

destination
Type: NFX.Log.Destinations Destination
msg
Type: NFX.Log Message

Return Value

Type: Online Boolean
See Also
NFX.Log.Destinations Namespace


MongoDBDestination Class

MongoDBDestination Class NFX Class Library

Implements destination that sends log messages into MongoDB
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Log.Destinations Destination
NFX.Log.Destinations MongoDBDestination

Namespace: NFX.Log.Destinations
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MongoDBDestination : Destination
public class MongoDBDestination : Destination
Public Class MongoDBDestination
    Inherits Destination
Public Class MongoDBDestination
    Inherits Destination
public ref class MongoDBDestination : public Destination
public ref class MongoDBDestination : public Destination
type MongoDBDestination =
    class
        inherit Destination
    end
type MongoDBDestination =
    class
        inherit Destination
    end
See Also
MongoDBDestination Members
NFX.Log.Destinations Namespace


MongoDBDestination Members

MongoDBDestination Members NFX Class Library

The MongoDBDestination type exposes the following members.
Constructors
 | Name | Description
Public method | MongoDBDestination | Creates a new instance of destination that stores log MongoDB
Public method | MongoDBDestination(String, String, String, String) | Creates a new instance of destination that stores log MongoDB
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc | (Inherited from Destination.)
Public method | Close | Deactivates destination (Inherited from Destination.)
Public method | Configure | Configures specified destination (Inherited from Destination.)
Protected method | Destructor | (Inherited from Destination.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure | (Overrides Destination DoConfigure(IConfigSectionNode).)
Protected method | DoPulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Protected method | DoSend | (Overrides Destination DoSend(Message).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Destination.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Destination.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | (Overrides Destination Open .)
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Public method | Send | Sends the message into destination doing filter checks first. (Inherited from Destination.)
Protected method | SendRegularAndFailures | (Inherited from Destination.)
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message (Inherited from Destination.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one (Inherited from Destination.)
Public field | Before | Allows to insert a destination right before this one (Inherited from Destination.)
Protected field | m_Name | (Inherited from Destination.)
Protected field | m_Owner | (Inherited from Destination.)
Back to Top
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f (Inherited from Destination.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DataStore | Refrences an underlying data store
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages (Inherited from Destination.)
Public property | DirectorLog | (Inherited from Destination.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages (Inherited from Destination.)
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages (Inherited from Destination.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public property | Failover | Sets destination name used for failover of this one (Inherited from Destination.)
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result (Inherited from Destination.)
Public property | FilterMethod | References message filtering method or null (Inherited from Destination.)
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default. (Inherited from Destination.)
Public property | LastError | Returns last error that this destination has encountered (Inherited from Destination.)
Public property | Levels | (Inherited from Destination.)
Public property | MaxLevel | Imposes a maximum log level constraint (Inherited from Destination.)
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy (Inherited from Destination.)
Public property | MinLevel | Imposes a minimum log level constraint (Inherited from Destination.)
Public property | Name | Provides mnemonic destination name (Inherited from Destination.)
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored (Inherited from Destination.)
Public property | Owner | Returns a composite destination that ownes this destination or null (Inherited from Destination.)
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms (Inherited from Destination.)
Public property | Service | References a log service that this destination services (Inherited from Destination.)
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages (Inherited from Destination.)
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages (Inherited from Destination.)
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true (Inherited from Destination.)
Back to Top
See Also
MongoDBDestination Class
NFX.Log.Destinations Namespace


MongoDBDestination Constructor

MongoDBDestination Constructor NFX Class Library

Overload List
 | Name | Description
Public method | MongoDBDestination | Creates a new instance of destination that stores log MongoDB
Public method | MongoDBDestination(String, String, String, String) | Creates a new instance of destination that stores log MongoDB
Back to Top
See Also
MongoDBDestination Class
MongoDBDestination Members
NFX.Log.Destinations Namespace


MongoDBDestination Constructor

MongoDBDestination Constructor NFX Class Library

Creates a new instance of destination that stores log MongoDB

Namespace: NFX.Log.Destinations
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBDestination()
public MongoDBDestination()
Public Sub New
Public Sub New
public:
MongoDBDestination()
public:
MongoDBDestination()
new : unit -> MongoDBDestination
new : unit -> MongoDBDestination
See Also
MongoDBDestination Class
MongoDBDestination Members
MongoDBDestination Overload
NFX.Log.Destinations Namespace


MongoDBDestination Constructor (String, String, String, String)

MongoDBDestination Constructor (String, String, String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates a new instance of destination that stores log MongoDB

Namespace: NFX.Log.Destinations
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBDestination(
    string name,
    string connectString,
    string dbName,
    string collectionName = null
)
public MongoDBDestination(
    string name,
    string connectString,
    string dbName,
    string collectionName = null
)
Public Sub New (
    name As String,
    connectString As String,
    dbName As String,
    Optional collectionName As String = Nothing
)
Public Sub New (
    name As String,
    connectString As String,
    dbName As String,
    Optional collectionName As String = Nothing
)
public:
MongoDBDestination(
    String^ name,
    String^ connectString,
    String^ dbName,
    String^ collectionName = nullptr
)
public:
MongoDBDestination(
    String^ name,
    String^ connectString,
    String^ dbName,
    String^ collectionName = nullptr
)
new :
        name : string *
        connectString : string *
        dbName : string *
        ?collectionName : string
(* Defaults:
        let _collectionName = defaultArg collectionName null
*)
-> MongoDBDestination
new :
        name : string *
        connectString : string *
        dbName : string *
        ?collectionName : string
(* Defaults:
        let _collectionName = defaultArg collectionName null
*)
-> MongoDBDestination

Parameters

name
Type: Online System String
connectString
Type: Online System String
dbName
Type: Online System String
collectionName (Optional)
Type: Online System String
See Also
MongoDBDestination Class
MongoDBDestination Members
MongoDBDestination Overload
NFX.Log.Destinations Namespace


MongoDBDestination Fields

MongoDBDestination Fields NFX Class Library

The MongoDBDestination type exposes the following members.
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one (Inherited from Destination.)
Public field | Before | Allows to insert a destination right before this one (Inherited from Destination.)
Protected field | m_Name | (Inherited from Destination.)
Protected field | m_Owner | (Inherited from Destination.)
Back to Top
See Also
MongoDBDestination Class
NFX.Log.Destinations Namespace


MongoDBDestination Methods

MongoDBDestination Methods NFX Class Library

The MongoDBDestination type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc | (Inherited from Destination.)
Public method | Close | Deactivates destination (Inherited from Destination.)
Public method | Configure | Configures specified destination (Inherited from Destination.)
Protected method | Destructor | (Inherited from Destination.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure | (Overrides Destination DoConfigure(IConfigSectionNode).)
Protected method | DoPulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Protected method | DoSend | (Overrides Destination DoSend(Message).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Destination.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Destination.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | (Overrides Destination Open .)
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Public method | Send | Sends the message into destination doing filter checks first. (Inherited from Destination.)
Protected method | SendRegularAndFailures | (Inherited from Destination.)
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message (Inherited from Destination.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MongoDBDestination Class
NFX.Log.Destinations Namespace


MongoDBDestination.DoConfigure Method

MongoDBDestination DoConfigure Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
MongoDBDestination Class
MongoDBDestination Members
NFX.Log.Destinations Namespace


MongoDBDestination.DoSend Method

MongoDBDestination DoSend Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSend(
    Message entry
)
protected override void DoSend(
    Message entry
)
Protected Overrides Sub DoSend (
    entry As Message
)
Protected Overrides Sub DoSend (
    entry As Message
)
protected:
virtual void DoSend(
    Message^ entry
) override
protected:
virtual void DoSend(
    Message^ entry
) override
abstract DoSend :
        entry : Message -> unit
override DoSend :
        entry : Message -> unit
abstract DoSend :
        entry : Message -> unit
override DoSend :
        entry : Message -> unit

Parameters

entry
Type: NFX.Log Message
See Also
MongoDBDestination Class
MongoDBDestination Members
NFX.Log.Destinations Namespace


MongoDBDestination.Open Method

MongoDBDestination Open Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Open()
public override void Open()
Public Overrides Sub Open
Public Overrides Sub Open
public:
virtual void Open() override
public:
virtual void Open() override
abstract Open : unit -> unit
override Open : unit -> unit
abstract Open : unit -> unit
override Open : unit -> unit
See Also
MongoDBDestination Class
MongoDBDestination Members
NFX.Log.Destinations Namespace


MongoDBDestination Properties

MongoDBDestination Properties NFX Class Library

The MongoDBDestination type exposes the following members.
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f (Inherited from Destination.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DataStore | Refrences an underlying data store
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages (Inherited from Destination.)
Public property | DirectorLog | (Inherited from Destination.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages (Inherited from Destination.)
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages (Inherited from Destination.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public property | Failover | Sets destination name used for failover of this one (Inherited from Destination.)
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result (Inherited from Destination.)
Public property | FilterMethod | References message filtering method or null (Inherited from Destination.)
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default. (Inherited from Destination.)
Public property | LastError | Returns last error that this destination has encountered (Inherited from Destination.)
Public property | Levels | (Inherited from Destination.)
Public property | MaxLevel | Imposes a maximum log level constraint (Inherited from Destination.)
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy (Inherited from Destination.)
Public property | MinLevel | Imposes a minimum log level constraint (Inherited from Destination.)
Public property | Name | Provides mnemonic destination name (Inherited from Destination.)
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored (Inherited from Destination.)
Public property | Owner | Returns a composite destination that ownes this destination or null (Inherited from Destination.)
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms (Inherited from Destination.)
Public property | Service | References a log service that this destination services (Inherited from Destination.)
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages (Inherited from Destination.)
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages (Inherited from Destination.)
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true (Inherited from Destination.)
Back to Top
See Also
MongoDBDestination Class
NFX.Log.Destinations Namespace


MongoDBDestination.DataStore Property

MongoDBDestination DataStore Property NFX Class Library

Refrences an underlying data store

Namespace: NFX.Log.Destinations
Assembly: NFX.MongoDB (in NFX.MongoDB.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MongoDBLogMessageDataStore DataStore { get; }
public MongoDBLogMessageDataStore DataStore { get; }
Public ReadOnly Property DataStore As MongoDBLogMessageDataStore
    Get
Public ReadOnly Property DataStore As MongoDBLogMessageDataStore
    Get
public:
property MongoDBLogMessageDataStore^ DataStore {
    MongoDBLogMessageDataStore^ get ();
}
public:
property MongoDBLogMessageDataStore^ DataStore {
    MongoDBLogMessageDataStore^ get ();
}
member DataStore : MongoDBLogMessageDataStore with get
member DataStore : MongoDBLogMessageDataStore with get

Property Value

Type: MongoDBLogMessageDataStore
See Also
MongoDBDestination Class
MongoDBDestination Members
NFX.Log.Destinations Namespace


NullDestination Class

NullDestination Class NFX Class Library

Log destination that does not log anything anywhere
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Log.Destinations Destination
NFX.Log.Destinations NullDestination

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NullDestination : Destination
public class NullDestination : Destination
Public Class NullDestination
    Inherits Destination
Public Class NullDestination
    Inherits Destination
public ref class NullDestination : public Destination
public ref class NullDestination : public Destination
type NullDestination =
    class
        inherit Destination
    end
type NullDestination =
    class
        inherit Destination
    end
See Also
NullDestination Members
NFX.Log.Destinations Namespace


NullDestination Members

NullDestination Members NFX Class Library

The NullDestination type exposes the following members.
Constructors
 | Name | Description
Public method | NullDestination | Initializes a new instance of the NullDestination class
Public method | NullDestination(String) | Initializes a new instance of the NullDestination class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc | (Inherited from Destination.)
Public method | Close | Deactivates destination (Inherited from Destination.)
Public method | Configure | Configures specified destination (Inherited from Destination.)
Protected method | Destructor | (Inherited from Destination.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure | Override to perform derivative-specific configuration (Inherited from Destination.)
Protected method | DoPulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Protected method | DoSend | (Overrides Destination DoSend(Message).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Destination.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Destination.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | Activates destination by preparing it to start operation (Inherited from Destination.)
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Public method | Send | Sends the message into destination doing filter checks first. (Inherited from Destination.)
Protected method | SendRegularAndFailures | (Inherited from Destination.)
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message (Inherited from Destination.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one (Inherited from Destination.)
Public field | Before | Allows to insert a destination right before this one (Inherited from Destination.)
Protected field | m_Name | (Inherited from Destination.)
Protected field | m_Owner | (Inherited from Destination.)
Back to Top
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f (Inherited from Destination.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages (Inherited from Destination.)
Public property | DirectorLog | (Inherited from Destination.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages (Inherited from Destination.)
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages (Inherited from Destination.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public property | Failover | Sets destination name used for failover of this one (Inherited from Destination.)
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result (Inherited from Destination.)
Public property | FilterMethod | References message filtering method or null (Inherited from Destination.)
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default. (Inherited from Destination.)
Public property | LastError | Returns last error that this destination has encountered (Inherited from Destination.)
Public property | Levels | (Inherited from Destination.)
Public property | MaxLevel | Imposes a maximum log level constraint (Inherited from Destination.)
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy (Inherited from Destination.)
Public property | MinLevel | Imposes a minimum log level constraint (Inherited from Destination.)
Public property | Name | Provides mnemonic destination name (Inherited from Destination.)
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored (Inherited from Destination.)
Public property | Owner | Returns a composite destination that ownes this destination or null (Inherited from Destination.)
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms (Inherited from Destination.)
Public property | Service | References a log service that this destination services (Inherited from Destination.)
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages (Inherited from Destination.)
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages (Inherited from Destination.)
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true (Inherited from Destination.)
Back to Top
See Also
NullDestination Class
NFX.Log.Destinations Namespace


NullDestination Constructor

NullDestination Constructor NFX Class Library

Overload List
 | Name | Description
Public method | NullDestination | Initializes a new instance of the NullDestination class
Public method | NullDestination(String) | Initializes a new instance of the NullDestination class
Back to Top
See Also
NullDestination Class
NullDestination Members
NFX.Log.Destinations Namespace


NullDestination Constructor

NullDestination Constructor NFX Class Library

Initializes a new instance of the NullDestination class

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NullDestination()
public NullDestination()
Public Sub New
Public Sub New
public:
NullDestination()
public:
NullDestination()
new : unit -> NullDestination
new : unit -> NullDestination
See Also
NullDestination Class
NullDestination Members
NullDestination Overload
NFX.Log.Destinations Namespace


NullDestination Constructor (String)

NullDestination Constructor (String) NFX Class Library

Initializes a new instance of the NullDestination class

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NullDestination(
    string name
)
public NullDestination(
    string name
)
Public Sub New (
    name As String
)
Public Sub New (
    name As String
)
public:
NullDestination(
    String^ name
)
public:
NullDestination(
    String^ name
)
new :
        name : string -> NullDestination
new :
        name : string -> NullDestination

Parameters

name
Type: Online System String
See Also
NullDestination Class
NullDestination Members
NullDestination Overload
NFX.Log.Destinations Namespace


NullDestination Fields

NullDestination Fields NFX Class Library

The NullDestination type exposes the following members.
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one (Inherited from Destination.)
Public field | Before | Allows to insert a destination right before this one (Inherited from Destination.)
Protected field | m_Name | (Inherited from Destination.)
Protected field | m_Owner | (Inherited from Destination.)
Back to Top
See Also
NullDestination Class
NFX.Log.Destinations Namespace


NullDestination Methods

NullDestination Methods NFX Class Library

The NullDestination type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc | (Inherited from Destination.)
Public method | Close | Deactivates destination (Inherited from Destination.)
Public method | Configure | Configures specified destination (Inherited from Destination.)
Protected method | Destructor | (Inherited from Destination.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure | Override to perform derivative-specific configuration (Inherited from Destination.)
Protected method | DoPulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Protected method | DoSend | (Overrides Destination DoSend(Message).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Destination.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Destination.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | Activates destination by preparing it to start operation (Inherited from Destination.)
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Public method | Send | Sends the message into destination doing filter checks first. (Inherited from Destination.)
Protected method | SendRegularAndFailures | (Inherited from Destination.)
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message (Inherited from Destination.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NullDestination Class
NFX.Log.Destinations Namespace


NullDestination.DoSend Method

NullDestination DoSend Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoSend(
    Message entry
)
protected internal override void DoSend(
    Message entry
)
Protected Friend Overrides Sub DoSend (
    entry As Message
)
Protected Friend Overrides Sub DoSend (
    entry As Message
)
protected public:
virtual void DoSend(
    Message^ entry
) override
protected public:
virtual void DoSend(
    Message^ entry
) override
abstract DoSend :
        entry : Message -> unit
override DoSend :
        entry : Message -> unit
abstract DoSend :
        entry : Message -> unit
override DoSend :
        entry : Message -> unit

Parameters

entry
Type: NFX.Log Message
See Also
NullDestination Class
NullDestination Members
NFX.Log.Destinations Namespace


NullDestination Properties

NullDestination Properties NFX Class Library

The NullDestination type exposes the following members.
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f (Inherited from Destination.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages (Inherited from Destination.)
Public property | DirectorLog | (Inherited from Destination.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages (Inherited from Destination.)
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages (Inherited from Destination.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public property | Failover | Sets destination name used for failover of this one (Inherited from Destination.)
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result (Inherited from Destination.)
Public property | FilterMethod | References message filtering method or null (Inherited from Destination.)
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default. (Inherited from Destination.)
Public property | LastError | Returns last error that this destination has encountered (Inherited from Destination.)
Public property | Levels | (Inherited from Destination.)
Public property | MaxLevel | Imposes a maximum log level constraint (Inherited from Destination.)
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy (Inherited from Destination.)
Public property | MinLevel | Imposes a minimum log level constraint (Inherited from Destination.)
Public property | Name | Provides mnemonic destination name (Inherited from Destination.)
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored (Inherited from Destination.)
Public property | Owner | Returns a composite destination that ownes this destination or null (Inherited from Destination.)
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms (Inherited from Destination.)
Public property | Service | References a log service that this destination services (Inherited from Destination.)
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages (Inherited from Destination.)
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages (Inherited from Destination.)
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true (Inherited from Destination.)
Back to Top
See Also
NullDestination Class
NFX.Log.Destinations Namespace


SMTPDestination Class

SMTPDestination Class NFX Class Library

Implements log destination that sends emails
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Log.Destinations Destination
NFX.Log.Destinations SMTPDestination

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SMTPDestination : Destination
public class SMTPDestination : Destination
Public Class SMTPDestination
    Inherits Destination
Public Class SMTPDestination
    Inherits Destination
public ref class SMTPDestination : public Destination
public ref class SMTPDestination : public Destination
type SMTPDestination =
    class
        inherit Destination
    end
type SMTPDestination =
    class
        inherit Destination
    end
See Also
SMTPDestination Members
NFX.Log.Destinations Namespace


SMTPDestination Members

SMTPDestination Members NFX Class Library

The SMTPDestination type exposes the following members.
Constructors
 | Name | Description
Public method | SMTPDestination | Creates a new instance of destination that sends EMails
Public method | SMTPDestination(String, String, Int32, Boolean) | Creates a new instance of destination that sends EMails
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc | (Inherited from Destination.)
Public method | Close | (Overrides Destination Close .)
Public method | Configure | Configures specified destination (Inherited from Destination.)
Protected method | Destructor | (Overrides Destination Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure | Override to perform derivative-specific configuration (Inherited from Destination.)
Protected method | DoPulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Protected method | DoSend | (Overrides Destination DoSend(Message).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Destination.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Destination.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | (Overrides Destination Open .)
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Public method | Send | Sends the message into destination doing filter checks first. (Inherited from Destination.)
Protected method | SendRegularAndFailures | (Inherited from Destination.)
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message (Inherited from Destination.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one (Inherited from Destination.)
Public field | Before | Allows to insert a destination right before this one (Inherited from Destination.)
 | DEFAULT_SMTP_PORT |
Protected field | m_Name | (Inherited from Destination.)
Protected field | m_Owner | (Inherited from Destination.)
Back to Top
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f (Inherited from Destination.)
Public property | Body |
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | CredentialsID |
Public property | CredentialsPassword |
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages (Inherited from Destination.)
Public property | DirectorLog | (Inherited from Destination.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages (Inherited from Destination.)
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages (Inherited from Destination.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public property | Failover | Sets destination name used for failover of this one (Inherited from Destination.)
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result (Inherited from Destination.)
Public property | FilterMethod | References message filtering method or null (Inherited from Destination.)
Public property | FromAddress |
Public property | FromName |
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default. (Inherited from Destination.)
Public property | LastError | Returns last error that this destination has encountered (Inherited from Destination.)
Public property | Levels | (Inherited from Destination.)
Public property | MaxLevel | Imposes a maximum log level constraint (Inherited from Destination.)
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy (Inherited from Destination.)
Public property | MinLevel | Imposes a minimum log level constraint (Inherited from Destination.)
Public property | Name | Provides mnemonic destination name (Inherited from Destination.)
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored (Inherited from Destination.)
Public property | Owner | Returns a composite destination that ownes this destination or null (Inherited from Destination.)
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms (Inherited from Destination.)
Public property | Service | References a log service that this destination services (Inherited from Destination.)
Public property | SmtpHost |
Public property | SmtpPort |
Public property | SmtpSSL |
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages (Inherited from Destination.)
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages (Inherited from Destination.)
Public property | Subject |
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true (Inherited from Destination.)
Public property | ToAddress |
Back to Top
See Also
SMTPDestination Class
NFX.Log.Destinations Namespace


SMTPDestination Constructor

SMTPDestination Constructor NFX Class Library

Overload List
 | Name | Description
Public method | SMTPDestination | Creates a new instance of destination that sends EMails
Public method | SMTPDestination(String, String, Int32, Boolean) | Creates a new instance of destination that sends EMails
Back to Top
See Also
SMTPDestination Class
SMTPDestination Members
NFX.Log.Destinations Namespace


SMTPDestination Constructor

SMTPDestination Constructor NFX Class Library

Creates a new instance of destination that sends EMails

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SMTPDestination()
public SMTPDestination()
Public Sub New
Public Sub New
public:
SMTPDestination()
public:
SMTPDestination()
new : unit -> SMTPDestination
new : unit -> SMTPDestination
See Also
SMTPDestination Class
SMTPDestination Members
SMTPDestination Overload
NFX.Log.Destinations Namespace


SMTPDestination Constructor (String, String, Int32, Boolean)

SMTPDestination Constructor (String, String, Int32, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates a new instance of destination that sends EMails

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SMTPDestination(
    string name,
    string host,
    int port,
    bool ssl
)
public SMTPDestination(
    string name,
    string host,
    int port,
    bool ssl
)
Public Sub New (
    name As String,
    host As String,
    port As Integer,
    ssl As Boolean
)
Public Sub New (
    name As String,
    host As String,
    port As Integer,
    ssl As Boolean
)
public:
SMTPDestination(
    String^ name,
    String^ host,
    int port,
    bool ssl
)
public:
SMTPDestination(
    String^ name,
    String^ host,
    int port,
    bool ssl
)
new :
        name : string *
        host : string *
        port : int *
        ssl : bool -> SMTPDestination
new :
        name : string *
        host : string *
        port : int *
        ssl : bool -> SMTPDestination

Parameters

name
Type: Online System String
host
Type: Online System String
port
Type: Online System Int32
ssl
Type: Online System Boolean
See Also
SMTPDestination Class
SMTPDestination Members
SMTPDestination Overload
NFX.Log.Destinations Namespace


SMTPDestination Fields

SMTPDestination Fields NFX Class Library

The SMTPDestination type exposes the following members.
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one (Inherited from Destination.)
Public field | Before | Allows to insert a destination right before this one (Inherited from Destination.)
 | DEFAULT_SMTP_PORT |
Protected field | m_Name | (Inherited from Destination.)
Protected field | m_Owner | (Inherited from Destination.)
Back to Top
See Also
SMTPDestination Class
NFX.Log.Destinations Namespace


SMTPDestination.DEFAULT_SMTP_PORT Field

SMTPDestination DEFAULT_SMTP_PORT Field NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_SMTP_PORT
public const int DEFAULT_SMTP_PORT
Public Const DEFAULT_SMTP_PORT As Integer
Public Const DEFAULT_SMTP_PORT As Integer
public:
literal int DEFAULT_SMTP_PORT
public:
literal int DEFAULT_SMTP_PORT
static val mutable DEFAULT_SMTP_PORT: int
static val mutable DEFAULT_SMTP_PORT: int

Field Value

Type: Online Int32
See Also
SMTPDestination Class
SMTPDestination Members
NFX.Log.Destinations Namespace


SMTPDestination Methods

SMTPDestination Methods NFX Class Library

The SMTPDestination type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc | (Inherited from Destination.)
Public method | Close | (Overrides Destination Close .)
Public method | Configure | Configures specified destination (Inherited from Destination.)
Protected method | Destructor | (Overrides Destination Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure | Override to perform derivative-specific configuration (Inherited from Destination.)
Protected method | DoPulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Protected method | DoSend | (Overrides Destination DoSend(Message).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Destination.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Destination.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | (Overrides Destination Open .)
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Public method | Send | Sends the message into destination doing filter checks first. (Inherited from Destination.)
Protected method | SendRegularAndFailures | (Inherited from Destination.)
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message (Inherited from Destination.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SMTPDestination Class
NFX.Log.Destinations Namespace


SMTPDestination.Close Method

SMTPDestination Close Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Close()
public override void Close()
Public Overrides Sub Close
Public Overrides Sub Close
public:
virtual void Close() override
public:
virtual void Close() override
abstract Close : unit -> unit
override Close : unit -> unit
abstract Close : unit -> unit
override Close : unit -> unit
See Also
SMTPDestination Class
SMTPDestination Members
NFX.Log.Destinations Namespace


SMTPDestination.Destructor Method

SMTPDestination Destructor Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
SMTPDestination Class
SMTPDestination Members
NFX.Log.Destinations Namespace


SMTPDestination.DoSend Method

SMTPDestination DoSend Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoSend(
    Message entry
)
protected internal override void DoSend(
    Message entry
)
Protected Friend Overrides Sub DoSend (
    entry As Message
)
Protected Friend Overrides Sub DoSend (
    entry As Message
)
protected public:
virtual void DoSend(
    Message^ entry
) override
protected public:
virtual void DoSend(
    Message^ entry
) override
abstract DoSend :
        entry : Message -> unit
override DoSend :
        entry : Message -> unit
abstract DoSend :
        entry : Message -> unit
override DoSend :
        entry : Message -> unit

Parameters

entry
Type: NFX.Log Message
See Also
SMTPDestination Class
SMTPDestination Members
NFX.Log.Destinations Namespace


SMTPDestination.Open Method

SMTPDestination Open Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Open()
public override void Open()
Public Overrides Sub Open
Public Overrides Sub Open
public:
virtual void Open() override
public:
virtual void Open() override
abstract Open : unit -> unit
override Open : unit -> unit
abstract Open : unit -> unit
override Open : unit -> unit
See Also
SMTPDestination Class
SMTPDestination Members
NFX.Log.Destinations Namespace


SMTPDestination Properties

SMTPDestination Properties NFX Class Library

The SMTPDestination type exposes the following members.
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f (Inherited from Destination.)
Public property | Body |
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | CredentialsID |
Public property | CredentialsPassword |
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages (Inherited from Destination.)
Public property | DirectorLog | (Inherited from Destination.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages (Inherited from Destination.)
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages (Inherited from Destination.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public property | Failover | Sets destination name used for failover of this one (Inherited from Destination.)
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result (Inherited from Destination.)
Public property | FilterMethod | References message filtering method or null (Inherited from Destination.)
Public property | FromAddress |
Public property | FromName |
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default. (Inherited from Destination.)
Public property | LastError | Returns last error that this destination has encountered (Inherited from Destination.)
Public property | Levels | (Inherited from Destination.)
Public property | MaxLevel | Imposes a maximum log level constraint (Inherited from Destination.)
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy (Inherited from Destination.)
Public property | MinLevel | Imposes a minimum log level constraint (Inherited from Destination.)
Public property | Name | Provides mnemonic destination name (Inherited from Destination.)
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored (Inherited from Destination.)
Public property | Owner | Returns a composite destination that ownes this destination or null (Inherited from Destination.)
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms (Inherited from Destination.)
Public property | Service | References a log service that this destination services (Inherited from Destination.)
Public property | SmtpHost |
Public property | SmtpPort |
Public property | SmtpSSL |
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages (Inherited from Destination.)
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages (Inherited from Destination.)
Public property | Subject |
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true (Inherited from Destination.)
Public property | ToAddress |
Back to Top
See Also
SMTPDestination Class
NFX.Log.Destinations Namespace


SMTPDestination.Body Property

SMTPDestination Body Property NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string Body { get; set; }
[ConfigAttribute]
public string Body { get; set; }
<ConfigAttribute>
Public Property Body As String
    Get
    Set
<ConfigAttribute>
Public Property Body As String
    Get
    Set
public:
[ConfigAttribute]
property String^ Body {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ Body {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member Body : string with get, set
[<ConfigAttribute>]
member Body : string with get, set

Property Value

Type: Online String
See Also
SMTPDestination Class
SMTPDestination Members
NFX.Log.Destinations Namespace


SMTPDestination.CredentialsID Property

SMTPDestination CredentialsID Property NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string CredentialsID { get; set; }
[ConfigAttribute]
public string CredentialsID { get; set; }
<ConfigAttribute>
Public Property CredentialsID As String
    Get
    Set
<ConfigAttribute>
Public Property CredentialsID As String
    Get
    Set
public:
[ConfigAttribute]
property String^ CredentialsID {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ CredentialsID {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member CredentialsID : string with get, set
[<ConfigAttribute>]
member CredentialsID : string with get, set

Property Value

Type: Online String
See Also
SMTPDestination Class
SMTPDestination Members
NFX.Log.Destinations Namespace


SMTPDestination.CredentialsPassword Property

SMTPDestination CredentialsPassword Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string CredentialsPassword { get; set; }
[ConfigAttribute]
public string CredentialsPassword { get; set; }
<ConfigAttribute>
Public Property CredentialsPassword As String
    Get
    Set
<ConfigAttribute>
Public Property CredentialsPassword As String
    Get
    Set
public:
[ConfigAttribute]
property String^ CredentialsPassword {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ CredentialsPassword {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member CredentialsPassword : string with get, set
[<ConfigAttribute>]
member CredentialsPassword : string with get, set

Property Value

Type: Online String
See Also
SMTPDestination Class
SMTPDestination Members
NFX.Log.Destinations Namespace


SMTPDestination.FromAddress Property

SMTPDestination FromAddress Property NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string FromAddress { get; set; }
[ConfigAttribute]
public string FromAddress { get; set; }
<ConfigAttribute>
Public Property FromAddress As String
    Get
    Set
<ConfigAttribute>
Public Property FromAddress As String
    Get
    Set
public:
[ConfigAttribute]
property String^ FromAddress {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ FromAddress {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member FromAddress : string with get, set
[<ConfigAttribute>]
member FromAddress : string with get, set

Property Value

Type: Online String
See Also
SMTPDestination Class
SMTPDestination Members
NFX.Log.Destinations Namespace


SMTPDestination.FromName Property

SMTPDestination FromName Property NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string FromName { get; set; }
[ConfigAttribute]
public string FromName { get; set; }
<ConfigAttribute>
Public Property FromName As String
    Get
    Set
<ConfigAttribute>
Public Property FromName As String
    Get
    Set
public:
[ConfigAttribute]
property String^ FromName {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ FromName {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member FromName : string with get, set
[<ConfigAttribute>]
member FromName : string with get, set

Property Value

Type: Online String
See Also
SMTPDestination Class
SMTPDestination Members
NFX.Log.Destinations Namespace


SMTPDestination.SmtpHost Property

SMTPDestination SmtpHost Property NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string SmtpHost { get; set; }
[ConfigAttribute]
public string SmtpHost { get; set; }
<ConfigAttribute>
Public Property SmtpHost As String
    Get
    Set
<ConfigAttribute>
Public Property SmtpHost As String
    Get
    Set
public:
[ConfigAttribute]
property String^ SmtpHost {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ SmtpHost {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member SmtpHost : string with get, set
[<ConfigAttribute>]
member SmtpHost : string with get, set

Property Value

Type: Online String
See Also
SMTPDestination Class
SMTPDestination Members
NFX.Log.Destinations Namespace


SMTPDestination.SmtpPort Property

SMTPDestination SmtpPort Property NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int SmtpPort { get; set; }
[ConfigAttribute]
public int SmtpPort { get; set; }
<ConfigAttribute>
Public Property SmtpPort As Integer
    Get
    Set
<ConfigAttribute>
Public Property SmtpPort As Integer
    Get
    Set
public:
[ConfigAttribute]
property int SmtpPort {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute]
property int SmtpPort {
    int get ();
    void set (int value);
}
[<ConfigAttribute>]
member SmtpPort : int with get, set
[<ConfigAttribute>]
member SmtpPort : int with get, set

Property Value

Type: Online Int32
See Also
SMTPDestination Class
SMTPDestination Members
NFX.Log.Destinations Namespace


SMTPDestination.SmtpSSL Property

SMTPDestination SmtpSSL Property NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool SmtpSSL { get; set; }
[ConfigAttribute]
public bool SmtpSSL { get; set; }
<ConfigAttribute>
Public Property SmtpSSL As Boolean
    Get
    Set
<ConfigAttribute>
Public Property SmtpSSL As Boolean
    Get
    Set
public:
[ConfigAttribute]
property bool SmtpSSL {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute]
property bool SmtpSSL {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute>]
member SmtpSSL : bool with get, set
[<ConfigAttribute>]
member SmtpSSL : bool with get, set

Property Value

Type: Online Boolean
See Also
SMTPDestination Class
SMTPDestination Members
NFX.Log.Destinations Namespace


SMTPDestination.Subject Property

SMTPDestination Subject Property NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string Subject { get; set; }
[ConfigAttribute]
public string Subject { get; set; }
<ConfigAttribute>
Public Property Subject As String
    Get
    Set
<ConfigAttribute>
Public Property Subject As String
    Get
    Set
public:
[ConfigAttribute]
property String^ Subject {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ Subject {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member Subject : string with get, set
[<ConfigAttribute>]
member Subject : string with get, set

Property Value

Type: Online String
See Also
SMTPDestination Class
SMTPDestination Members
NFX.Log.Destinations Namespace


SMTPDestination.ToAddress Property

SMTPDestination ToAddress Property NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string ToAddress { get; set; }
[ConfigAttribute]
public string ToAddress { get; set; }
<ConfigAttribute>
Public Property ToAddress As String
    Get
    Set
<ConfigAttribute>
Public Property ToAddress As String
    Get
    Set
public:
[ConfigAttribute]
property String^ ToAddress {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ ToAddress {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member ToAddress : string with get, set
[<ConfigAttribute>]
member ToAddress : string with get, set

Property Value

Type: Online String
See Also
SMTPDestination Class
SMTPDestination Members
NFX.Log.Destinations Namespace


SyslogDestination Class

SyslogDestination Class NFX Class Library

Implements destination that sends messages to UNIX syslog using UDP datagrams
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Log.Destinations Destination
NFX.Log.Destinations SyslogDestination

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SyslogDestination : Destination
public class SyslogDestination : Destination
Public Class SyslogDestination
    Inherits Destination
Public Class SyslogDestination
    Inherits Destination
public ref class SyslogDestination : public Destination
public ref class SyslogDestination : public Destination
type SyslogDestination =
    class
        inherit Destination
    end
type SyslogDestination =
    class
        inherit Destination
    end
See Also
SyslogDestination Members
NFX.Log.Destinations Namespace


SyslogDestination Members

SyslogDestination Members NFX Class Library

The SyslogDestination type exposes the following members.
Constructors
 | Name | Description
Public method | SyslogDestination | Creates a new instance of destination that sends messages to .nix SYSLOG
Public method | SyslogDestination(String, String, Int32) | Creates a new instance of destination that sends messages to .nix SYSLOG
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc | (Inherited from Destination.)
Public method | Close | (Overrides Destination Close .)
Public method | Configure | Configures specified destination (Inherited from Destination.)
Protected method | Destructor | (Overrides Destination Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure | (Overrides Destination DoConfigure(IConfigSectionNode).)
Protected method | DoPulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Protected method | DoSend | (Overrides Destination DoSend(Message).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Destination.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Destination.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | Activates destination by preparing it to start operation (Inherited from Destination.)
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Public method | Send | Sends the message into destination doing filter checks first. (Inherited from Destination.)
Protected method | SendRegularAndFailures | (Inherited from Destination.)
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message (Inherited from Destination.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one (Inherited from Destination.)
Public field | Before | Allows to insert a destination right before this one (Inherited from Destination.)
Protected field | m_Name | (Inherited from Destination.)
Protected field | m_Owner | (Inherited from Destination.)
Back to Top
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f (Inherited from Destination.)
Public property | Client | References the underlying syslog client instance
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages (Inherited from Destination.)
Public property | DirectorLog | (Inherited from Destination.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages (Inherited from Destination.)
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages (Inherited from Destination.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public property | Failover | Sets destination name used for failover of this one (Inherited from Destination.)
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result (Inherited from Destination.)
Public property | FilterMethod | References message filtering method or null (Inherited from Destination.)
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default. (Inherited from Destination.)
Public property | LastError | Returns last error that this destination has encountered (Inherited from Destination.)
Public property | Levels | (Inherited from Destination.)
Public property | MaxLevel | Imposes a maximum log level constraint (Inherited from Destination.)
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy (Inherited from Destination.)
Public property | MinLevel | Imposes a minimum log level constraint (Inherited from Destination.)
Public property | Name | Provides mnemonic destination name (Inherited from Destination.)
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored (Inherited from Destination.)
Public property | Owner | Returns a composite destination that ownes this destination or null (Inherited from Destination.)
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms (Inherited from Destination.)
Public property | Service | References a log service that this destination services (Inherited from Destination.)
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages (Inherited from Destination.)
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages (Inherited from Destination.)
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true (Inherited from Destination.)
Back to Top
See Also
SyslogDestination Class
NFX.Log.Destinations Namespace


SyslogDestination Constructor

SyslogDestination Constructor NFX Class Library

Overload List
 | Name | Description
Public method | SyslogDestination | Creates a new instance of destination that sends messages to .nix SYSLOG
Public method | SyslogDestination(String, String, Int32) | Creates a new instance of destination that sends messages to .nix SYSLOG
Back to Top
See Also
SyslogDestination Class
SyslogDestination Members
NFX.Log.Destinations Namespace


SyslogDestination Constructor

SyslogDestination Constructor NFX Class Library

Creates a new instance of destination that sends messages to .nix SYSLOG

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SyslogDestination()
public SyslogDestination()
Public Sub New
Public Sub New
public:
SyslogDestination()
public:
SyslogDestination()
new : unit -> SyslogDestination
new : unit -> SyslogDestination
See Also
SyslogDestination Class
SyslogDestination Members
SyslogDestination Overload
NFX.Log.Destinations Namespace


SyslogDestination Constructor (String, String, Int32)

SyslogDestination Constructor (String, String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates a new instance of destination that sends messages to .nix SYSLOG

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SyslogDestination(
    string name,
    string host,
    int port
)
public SyslogDestination(
    string name,
    string host,
    int port
)
Public Sub New (
    name As String,
    host As String,
    port As Integer
)
Public Sub New (
    name As String,
    host As String,
    port As Integer
)
public:
SyslogDestination(
    String^ name,
    String^ host,
    int port
)
public:
SyslogDestination(
    String^ name,
    String^ host,
    int port
)
new :
        name : string *
        host : string *
        port : int -> SyslogDestination
new :
        name : string *
        host : string *
        port : int -> SyslogDestination

Parameters

name
Type: Online System String
host
Type: Online System String
port
Type: Online System Int32
See Also
SyslogDestination Class
SyslogDestination Members
SyslogDestination Overload
NFX.Log.Destinations Namespace


SyslogDestination Fields

SyslogDestination Fields NFX Class Library

The SyslogDestination type exposes the following members.
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one (Inherited from Destination.)
Public field | Before | Allows to insert a destination right before this one (Inherited from Destination.)
Protected field | m_Name | (Inherited from Destination.)
Protected field | m_Owner | (Inherited from Destination.)
Back to Top
See Also
SyslogDestination Class
NFX.Log.Destinations Namespace


SyslogDestination Methods

SyslogDestination Methods NFX Class Library

The SyslogDestination type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc | (Inherited from Destination.)
Public method | Close | (Overrides Destination Close .)
Public method | Configure | Configures specified destination (Inherited from Destination.)
Protected method | Destructor | (Overrides Destination Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoConfigure | (Overrides Destination DoConfigure(IConfigSectionNode).)
Protected method | DoPulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Protected method | DoSend | (Overrides Destination DoSend(Message).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Destination.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Destination.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | Activates destination by preparing it to start operation (Inherited from Destination.)
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Public method | Send | Sends the message into destination doing filter checks first. (Inherited from Destination.)
Protected method | SendRegularAndFailures | (Inherited from Destination.)
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message (Inherited from Destination.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SyslogDestination Class
NFX.Log.Destinations Namespace


SyslogDestination.Close Method

SyslogDestination Close Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Close()
public override void Close()
Public Overrides Sub Close
Public Overrides Sub Close
public:
virtual void Close() override
public:
virtual void Close() override
abstract Close : unit -> unit
override Close : unit -> unit
abstract Close : unit -> unit
override Close : unit -> unit
See Also
SyslogDestination Class
SyslogDestination Members
NFX.Log.Destinations Namespace


SyslogDestination.Destructor Method

SyslogDestination Destructor Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
SyslogDestination Class
SyslogDestination Members
NFX.Log.Destinations Namespace


SyslogDestination.DoConfigure Method

SyslogDestination DoConfigure Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
SyslogDestination Class
SyslogDestination Members
NFX.Log.Destinations Namespace


SyslogDestination.DoSend Method

SyslogDestination DoSend Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoSend(
    Message entry
)
protected internal override void DoSend(
    Message entry
)
Protected Friend Overrides Sub DoSend (
    entry As Message
)
Protected Friend Overrides Sub DoSend (
    entry As Message
)
protected public:
virtual void DoSend(
    Message^ entry
) override
protected public:
virtual void DoSend(
    Message^ entry
) override
abstract DoSend :
        entry : Message -> unit
override DoSend :
        entry : Message -> unit
abstract DoSend :
        entry : Message -> unit
override DoSend :
        entry : Message -> unit

Parameters

entry
Type: NFX.Log Message
See Also
SyslogDestination Class
SyslogDestination Members
NFX.Log.Destinations Namespace


SyslogDestination Properties

SyslogDestination Properties NFX Class Library

The SyslogDestination type exposes the following members.
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f (Inherited from Destination.)
Public property | Client | References the underlying syslog client instance
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages (Inherited from Destination.)
Public property | DirectorLog | (Inherited from Destination.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages (Inherited from Destination.)
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages (Inherited from Destination.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public property | Failover | Sets destination name used for failover of this one (Inherited from Destination.)
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result (Inherited from Destination.)
Public property | FilterMethod | References message filtering method or null (Inherited from Destination.)
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default. (Inherited from Destination.)
Public property | LastError | Returns last error that this destination has encountered (Inherited from Destination.)
Public property | Levels | (Inherited from Destination.)
Public property | MaxLevel | Imposes a maximum log level constraint (Inherited from Destination.)
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy (Inherited from Destination.)
Public property | MinLevel | Imposes a minimum log level constraint (Inherited from Destination.)
Public property | Name | Provides mnemonic destination name (Inherited from Destination.)
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored (Inherited from Destination.)
Public property | Owner | Returns a composite destination that ownes this destination or null (Inherited from Destination.)
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms (Inherited from Destination.)
Public property | Service | References a log service that this destination services (Inherited from Destination.)
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages (Inherited from Destination.)
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages (Inherited from Destination.)
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true (Inherited from Destination.)
Back to Top
See Also
SyslogDestination Class
NFX.Log.Destinations Namespace


SyslogDestination.Client Property

SyslogDestination Client Property NFX Class Library

References the underlying syslog client instance

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SyslogClient Client { get; }
public SyslogClient Client { get; }
Public ReadOnly Property Client As SyslogClient
    Get
Public ReadOnly Property Client As SyslogClient
    Get
public:
property SyslogClient^ Client {
    SyslogClient^ get ();
}
public:
property SyslogClient^ Client {
    SyslogClient^ get ();
}
member Client : SyslogClient with get
member Client : SyslogClient with get

Property Value

Type: SyslogClient
See Also
SyslogDestination Class
SyslogDestination Members
NFX.Log.Destinations Namespace


TextFileDestination Class

TextFileDestination Class NFX Class Library

Provides a file storage destination implementation
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Log.Destinations Destination
NFX.Log.Destinations FileDestination
NFX.Log.Destinations TextFileDestination
NFX.Log.Destinations CSVFileDestination
NFX.Log.Destinations DebugDestination

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class TextFileDestination : FileDestination
public abstract class TextFileDestination : FileDestination
Public MustInherit Class TextFileDestination
    Inherits FileDestination
Public MustInherit Class TextFileDestination
    Inherits FileDestination
public ref class TextFileDestination abstract : public FileDestination
public ref class TextFileDestination abstract : public FileDestination
[<AbstractClassAttribute>]
type TextFileDestination =
    class
        inherit FileDestination
    end
[<AbstractClassAttribute>]
type TextFileDestination =
    class
        inherit FileDestination
    end
See Also
TextFileDestination Members
NFX.Log.Destinations Namespace


TextFileDestination Members

TextFileDestination Members NFX Class Library

The TextFileDestination type exposes the following members.
Constructors
 | Name | Description
Protected method | TextFileDestination | Initializes a new instance of the TextFileDestination class
Back to Top
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc | (Inherited from Destination.)
Public method | Close | (Inherited from FileDestination.)
Public method | Configure | Configures specified destination (Inherited from Destination.)
Protected method | Destructor | (Inherited from Destination.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoCloseStream | (Overrides FileDestination DoCloseStream .)
Protected method | DoConfigure | Override to perform derivative-specific configuration (Inherited from Destination.)
Protected method | DoFormatMessage | Called when message is to be written to stream
Protected method | DoOpenStream | (Overrides FileDestination DoOpenStream .)
Protected method | DoPulse | (Overrides FileDestination DoPulse .)
Protected method | DoSend | Override DoFormatMessage() instead (Inherited from FileDestination.)
Protected method | DoWriteMessage | Warning: don't override this method in derived destinations, use DoFormatMessage() instead! (Overrides FileDestination DoWriteMessage(Message).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Destination.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Destination.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetDestinationFileName | (Inherited from FileDestination.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | (Inherited from FileDestination.)
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Public method | Send | Sends the message into destination doing filter checks first. (Inherited from Destination.)
Protected method | SendRegularAndFailures | (Inherited from Destination.)
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message (Inherited from Destination.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one (Inherited from Destination.)
Public field | Before | Allows to insert a destination right before this one (Inherited from Destination.)
Protected field | m_FileName | (Inherited from FileDestination.)
Protected field | m_Name | (Inherited from Destination.)
Protected field | m_Owner | (Inherited from Destination.)
Protected field | m_Path | (Inherited from FileDestination.)
Protected field | m_Stream | (Inherited from FileDestination.)
Back to Top
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f (Inherited from Destination.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages (Inherited from Destination.)
Protected property | DefaultFileName | (Inherited from FileDestination.)
Public property | DirectorLog | (Inherited from Destination.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages (Inherited from Destination.)
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages (Inherited from Destination.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public property | Failover | Sets destination name used for failover of this one (Inherited from Destination.)
Public property | FileName | File name may include environment variables (e.g. ~home), and use macros to specify time "$(~home)$(@::now fmt=yyyyMMdd utc=false)-$($name).log". Pass "utc=true" argument to use UTC (Inherited from FileDestination.)
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result (Inherited from Destination.)
Public property | FilterMethod | References message filtering method or null (Inherited from Destination.)
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default. (Inherited from Destination.)
Public property | LastError | Returns last error that this destination has encountered (Inherited from Destination.)
Public property | Levels | (Inherited from Destination.)
Public property | MaxLevel | Imposes a maximum log level constraint (Inherited from Destination.)
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy (Inherited from Destination.)
Public property | MinLevel | Imposes a minimum log level constraint (Inherited from Destination.)
Public property | Name | Provides mnemonic destination name (Inherited from Destination.)
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored (Inherited from Destination.)
Public property | Owner | Returns a composite destination that ownes this destination or null (Inherited from Destination.)
Public property | Path | (Inherited from FileDestination.)
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms (Inherited from Destination.)
Public property | Service | References a log service that this destination services (Inherited from Destination.)
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages (Inherited from Destination.)
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages (Inherited from Destination.)
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true (Inherited from Destination.)
Back to Top
See Also
TextFileDestination Class
NFX.Log.Destinations Namespace


TextFileDestination Constructor

TextFileDestination Constructor NFX Class Library

Initializes a new instance of the TextFileDestination class

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TextFileDestination(
    string name
)
protected TextFileDestination(
    string name
)
Protected Sub New (
    name As String
)
Protected Sub New (
    name As String
)
protected:
TextFileDestination(
    String^ name
)
protected:
TextFileDestination(
    String^ name
)
new :
        name : string -> TextFileDestination
new :
        name : string -> TextFileDestination

Parameters

name
Type: Online System String
See Also
TextFileDestination Class
TextFileDestination Members
NFX.Log.Destinations Namespace


TextFileDestination Fields

TextFileDestination Fields NFX Class Library

The TextFileDestination type exposes the following members.
Fields
 | Name | Description
Public field | After | Allows to insert a destination right after this one (Inherited from Destination.)
Public field | Before | Allows to insert a destination right before this one (Inherited from Destination.)
Protected field | m_FileName | (Inherited from FileDestination.)
Protected field | m_Name | (Inherited from Destination.)
Protected field | m_Owner | (Inherited from Destination.)
Protected field | m_Path | (Inherited from FileDestination.)
Protected field | m_Stream | (Inherited from FileDestination.)
Back to Top
See Also
TextFileDestination Class
NFX.Log.Destinations Namespace


TextFileDestination Methods

TextFileDestination Methods NFX Class Library

The TextFileDestination type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | __setLogSvc | (Inherited from Destination.)
Public method | Close | (Inherited from FileDestination.)
Public method | Configure | Configures specified destination (Inherited from Destination.)
Protected method | Destructor | (Inherited from Destination.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoCloseStream | (Overrides FileDestination DoCloseStream .)
Protected method | DoConfigure | Override to perform derivative-specific configuration (Inherited from Destination.)
Protected method | DoFormatMessage | Called when message is to be written to stream
Protected method | DoOpenStream | (Overrides FileDestination DoOpenStream .)
Protected method | DoPulse | (Overrides FileDestination DoPulse .)
Protected method | DoSend | Override DoFormatMessage() instead (Inherited from FileDestination.)
Protected method | DoWriteMessage | Warning: don't override this method in derived destinations, use DoFormatMessage() instead! (Overrides FileDestination DoWriteMessage(Message).)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from Destination.)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from Destination.)
Protected method | Finalize | (Inherited from DisposableObject.)
Protected method | GetDestinationFileName | (Inherited from FileDestination.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Open | (Inherited from FileDestination.)
Public method | Pulse | Provides periodic notification of destinations from central Log thread even if there are no messages to write. Override DoPulse to commit internal batching buffers provided by particular destinations (Inherited from Destination.)
Public method | Send | Sends the message into destination doing filter checks first. (Inherited from Destination.)
Protected method | SendRegularAndFailures | (Inherited from Destination.)
Protected method | SetError | Notifies log service of exception that surfaced during processing of a particular message (Inherited from Destination.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TextFileDestination Class
NFX.Log.Destinations Namespace


TextFileDestination.DoCloseStream Method

TextFileDestination DoCloseStream Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoCloseStream()
protected override void DoCloseStream()
Protected Overrides Sub DoCloseStream
Protected Overrides Sub DoCloseStream
protected:
virtual void DoCloseStream() override
protected:
virtual void DoCloseStream() override
abstract DoCloseStream : unit -> unit
override DoCloseStream : unit -> unit
abstract DoCloseStream : unit -> unit
override DoCloseStream : unit -> unit
See Also
TextFileDestination Class
TextFileDestination Members
NFX.Log.Destinations Namespace


TextFileDestination.DoFormatMessage Method

TextFileDestination DoFormatMessage Method NFX Class Library

Called when message is to be written to stream

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract string DoFormatMessage(
    Message msg
)
protected abstract string DoFormatMessage(
    Message msg
)
Protected MustOverride Function DoFormatMessage (
    msg As Message
) As String
Protected MustOverride Function DoFormatMessage (
    msg As Message
) As String
protected:
virtual String^ DoFormatMessage(
    Message^ msg
) abstract
protected:
virtual String^ DoFormatMessage(
    Message^ msg
) abstract
abstract DoFormatMessage :
        msg : Message -> string
abstract DoFormatMessage :
        msg : Message -> string

Parameters

msg
Type: NFX.Log Message

Return Value

Type: Online String
See Also
TextFileDestination Class
TextFileDestination Members
NFX.Log.Destinations Namespace


TextFileDestination.DoOpenStream Method

TextFileDestination DoOpenStream Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoOpenStream()
protected override void DoOpenStream()
Protected Overrides Sub DoOpenStream
Protected Overrides Sub DoOpenStream
protected:
virtual void DoOpenStream() override
protected:
virtual void DoOpenStream() override
abstract DoOpenStream : unit -> unit
override DoOpenStream : unit -> unit
abstract DoOpenStream : unit -> unit
override DoOpenStream : unit -> unit
See Also
TextFileDestination Class
TextFileDestination Members
NFX.Log.Destinations Namespace


TextFileDestination.DoPulse Method

TextFileDestination DoPulse Method NFX Class Library

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void DoPulse()
protected internal override void DoPulse()
Protected Friend Overrides Sub DoPulse
Protected Friend Overrides Sub DoPulse
protected public:
virtual void DoPulse() override
protected public:
virtual void DoPulse() override
abstract DoPulse : unit -> unit
override DoPulse : unit -> unit
abstract DoPulse : unit -> unit
override DoPulse : unit -> unit
See Also
TextFileDestination Class
TextFileDestination Members
NFX.Log.Destinations Namespace


TextFileDestination.DoWriteMessage Method

TextFileDestination DoWriteMessage Method NFX Class Library

Warning: don't override this method in derived destinations, use DoFormatMessage() instead!

Namespace: NFX.Log.Destinations
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWriteMessage(
    Message msg
)
protected override void DoWriteMessage(
    Message msg
)
Protected Overrides Sub DoWriteMessage (
    msg As Message
)
Protected Overrides Sub DoWriteMessage (
    msg As Message
)
protected:
virtual void DoWriteMessage(
    Message^ msg
) override
protected:
virtual void DoWriteMessage(
    Message^ msg
) override
abstract DoWriteMessage :
        msg : Message -> unit
override DoWriteMessage :
        msg : Message -> unit
abstract DoWriteMessage :
        msg : Message -> unit
override DoWriteMessage :
        msg : Message -> unit

Parameters

msg
Type: NFX.Log Message
See Also
TextFileDestination Class
TextFileDestination Members
NFX.Log.Destinations Namespace


TextFileDestination Properties

TextFileDestination Properties NFX Class Library

The TextFileDestination type exposes the following members.
Properties
 | Name | Description
Public property | AverageProcessingTimeMs | Returns average time it takes destination implementation to write the log message to actual sink. This property is only computed when MaxProcessingTimeMs limit is imposed, otherwise it returns 0f (Inherited from Destination.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DaysOfWeek | Imposes a filter on days when this destination handles messages (Inherited from Destination.)
Protected property | DefaultFileName | (Inherited from FileDestination.)
Public property | DirectorLog | (Inherited from Destination.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | EndDate | Imposes a filter that specifies the ending date and time before which this destination will be processing log messages (Inherited from Destination.)
Public property | EndTime | Imposes a filter that specifies the ending time of the day before which this destination will be processing log messages (Inherited from Destination.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from Destination.)
Public property | Failover | Sets destination name used for failover of this one (Inherited from Destination.)
Public property | FileName | File name may include environment variables (e.g. ~home), and use macros to specify time "$(~home)$(@::now fmt=yyyyMMdd utc=false)-$($name).log". Pass "utc=true" argument to use UTC (Inherited from FileDestination.)
Public property | Filter | Gets/sets filter expression for this destination. Filter expressions get dynamically compiled into filter assembly, consequently it is not a good practice to create too many different filters. Filters are heavyweight, and it is advisable to use them ONLY WHEN regular destination filtering (using Min/Max levels, dates and times) can not be used to achieve the desired result (Inherited from Destination.)
Public property | FilterMethod | References message filtering method or null (Inherited from Destination.)
Public property | GenerateFailoverMessages | Determines whether additional co-related error message should be generated when this destination fails or when it is used as failover by some other destination. When this property is true an additional error message gets written into failover destination that describes what message caused failure (error is co-related to original) at what destination. False by default. (Inherited from Destination.)
Public property | LastError | Returns last error that this destination has encountered (Inherited from Destination.)
Public property | Levels | (Inherited from Destination.)
Public property | MaxLevel | Imposes a maximum log level constraint (Inherited from Destination.)
Public property | MaxProcessingTimeMs | Imposes a time limit on internal message processing (writing into actual sink) by this destination. If this limit is exceeded, this destination fails and processing is re-tried to be resumed after RestartProcessingAfterMs interval. The minimum value for this property is 25 ms as lower values compromise timer accuracy (Inherited from Destination.)
Public property | MinLevel | Imposes a minimum log level constraint (Inherited from Destination.)
Public property | Name | Provides mnemonic destination name (Inherited from Destination.)
Public property | OnlyFailures | Indicates whether this destination should only process failures - messages that crashed other destinations. When set to true regular messages (dispatched by Send(msg)) are ignored (Inherited from Destination.)
Public property | Owner | Returns a composite destination that ownes this destination or null (Inherited from Destination.)
Public property | Path | (Inherited from FileDestination.)
Public property | RestartProcessingAfterMs | Specifies how much time must pass before processing will be tried to resume after failure. The default value is 60000 ms (Inherited from Destination.)
Public property | Service | References a log service that this destination services (Inherited from Destination.)
Public property | StartDate | Imposes a filter that specifies the starting date and time after which this destination will start processing log messages (Inherited from Destination.)
Public property | StartTime | Imposes a filter that specifies the starting time of the day after which this destination will start processing log messages (Inherited from Destination.)
Public property | TestOnStart | Indicates whether this destination should try to test the underlying sink on startup. For example DB-based destinations will try to connect to server upon log service launch when this property is true (Inherited from Destination.)
Back to Top
See Also
TextFileDestination Class
NFX.Log.Destinations Namespace


NFX.Log.Instrumentation Namespace

NFX.Log.Instrumentation Namespace NFX Class Library

Classes
 | Class | Description
Public class | LogLongGauge |
Public class | LogMsgCount |


LogLongGauge Class

LogLongGauge Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Log.Instrumentation LogLongGauge
NFX.Log.Instrumentation LogMsgCount

Namespace: NFX.Log.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class LogLongGauge : LongGauge,
    IInstrumentationInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public abstract class LogLongGauge : LongGauge,
    IInstrumentationInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public MustInherit Class LogLongGauge
    Inherits LongGauge
    Implements IInstrumentationInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public MustInherit Class LogLongGauge
    Inherits LongGauge
    Implements IInstrumentationInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class LogLongGauge abstract : public LongGauge,
    IInstrumentationInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class LogLongGauge abstract : public LongGauge,
    IInstrumentationInstrument, IOperationClass, IInstrumentClass
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type LogLongGauge =
    class
        inherit LongGauge
        interface IInstrumentationInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type LogLongGauge =
    class
        inherit LongGauge
        interface IInstrumentationInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
LogLongGauge Members
NFX.Log.Instrumentation Namespace


LogLongGauge Members

LogLongGauge Members NFX Class Library

The LogLongGauge type exposes the following members.
Constructors
 | Name | Description
Protected method | LogLongGauge | Initializes a new instance of the LogLongGauge class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Inherited from LongGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
LogLongGauge Class
NFX.Log.Instrumentation Namespace


LogLongGauge Constructor

LogLongGauge Constructor NFX Class Library

Initializes a new instance of the LogLongGauge class

Namespace: NFX.Log.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected LogLongGauge(
    string source,
    long value
)
protected LogLongGauge(
    string source,
    long value
)
Protected Sub New (
    source As String,
    value As Long
)
Protected Sub New (
    source As String,
    value As Long
)
protected:
LogLongGauge(
    String^ source,
    long long value
)
protected:
LogLongGauge(
    String^ source,
    long long value
)
new :
        source : string *
        value : int64 -> LogLongGauge
new :
        source : string *
        value : int64 -> LogLongGauge

Parameters

source
Type: Online System String
value
Type: Online System Int64
See Also
LogLongGauge Class
LogLongGauge Members
NFX.Log.Instrumentation Namespace


LogLongGauge Fields

LogLongGauge Fields NFX Class Library

The LogLongGauge type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
LogLongGauge Class
NFX.Log.Instrumentation Namespace


LogLongGauge Methods

LogLongGauge Methods NFX Class Library

The LogLongGauge type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LogLongGauge Class
NFX.Log.Instrumentation Namespace


LogLongGauge Properties

LogLongGauge Properties NFX Class Library

The LogLongGauge type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Inherited from LongGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
LogLongGauge Class
NFX.Log.Instrumentation Namespace


LogMsgCount Class

LogMsgCount Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.Log.Instrumentation LogLongGauge
NFX.Log.Instrumentation LogMsgCount

Namespace: NFX.Log.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class LogMsgCount : LogLongGauge,
    IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class LogMsgCount : LogLongGauge,
    IMemoryInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class LogMsgCount
    Inherits LogLongGauge
    Implements IMemoryInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class LogMsgCount
    Inherits LogLongGauge
    Implements IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class LogMsgCount : public LogLongGauge,
    IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class LogMsgCount : public LogLongGauge,
    IMemoryInstrument, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type LogMsgCount =
    class
        inherit LogLongGauge
        interface IMemoryInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type LogMsgCount =
    class
        inherit LogLongGauge
        interface IMemoryInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
LogMsgCount Members
NFX.Log.Instrumentation Namespace


LogMsgCount Members

LogMsgCount Members NFX Class Library

The LogMsgCount type exposes the following members.
Constructors
 | Name | Description
Protected method | LogMsgCount | Initializes a new instance of the LogMsgCount class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
LogMsgCount Class
NFX.Log.Instrumentation Namespace


LogMsgCount Constructor

LogMsgCount Constructor NFX Class Library

Initializes a new instance of the LogMsgCount class

Namespace: NFX.Log.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected LogMsgCount(
    string source,
    long value
)
protected LogMsgCount(
    string source,
    long value
)
Protected Sub New (
    source As String,
    value As Long
)
Protected Sub New (
    source As String,
    value As Long
)
protected:
LogMsgCount(
    String^ source,
    long long value
)
protected:
LogMsgCount(
    String^ source,
    long long value
)
new :
        source : string *
        value : int64 -> LogMsgCount
new :
        source : string *
        value : int64 -> LogMsgCount

Parameters

source
Type: Online System String
value
Type: Online System Int64
See Also
LogMsgCount Class
LogMsgCount Members
NFX.Log.Instrumentation Namespace


LogMsgCount Fields

LogMsgCount Fields NFX Class Library

The LogMsgCount type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
LogMsgCount Class
NFX.Log.Instrumentation Namespace


LogMsgCount Methods

LogMsgCount Methods NFX Class Library

The LogMsgCount type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LogMsgCount Class
NFX.Log.Instrumentation Namespace


LogMsgCount.MakeAggregateInstance Method

LogMsgCount MakeAggregateInstance Method NFX Class Library

Namespace: NFX.Log.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
LogMsgCount Class
LogMsgCount Members
NFX.Log.Instrumentation Namespace


LogMsgCount.Record Method

LogMsgCount Record Method NFX Class Library

Namespace: NFX.Log.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    string source,
    long value
)
public static void Record(
    string source,
    long value
)
Public Shared Sub Record (
    source As String,
    value As Long
)
Public Shared Sub Record (
    source As String,
    value As Long
)
public:
static void Record(
    String^ source,
    long long value
)
public:
static void Record(
    String^ source,
    long long value
)
static member Record :
        source : string *
        value : int64 -> unit
static member Record :
        source : string *
        value : int64 -> unit

Parameters

source
Type: Online System String
value
Type: Online System Int64
See Also
LogMsgCount Class
LogMsgCount Members
NFX.Log.Instrumentation Namespace


LogMsgCount Properties

LogMsgCount Properties NFX Class Library

The LogMsgCount type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
LogMsgCount Class
NFX.Log.Instrumentation Namespace


LogMsgCount.Description Property

LogMsgCount Description Property NFX Class Library

Namespace: NFX.Log.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
LogMsgCount Class
LogMsgCount Members
NFX.Log.Instrumentation Namespace


LogMsgCount.ValueUnitName Property

LogMsgCount ValueUnitName Property NFX Class Library

Namespace: NFX.Log.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
LogMsgCount Class
LogMsgCount Members
NFX.Log.Instrumentation Namespace


NFX.Log.Syslog Namespace

NFX.Log.Syslog Namespace NFX Class Library

Provides *nix SYSLOG related classes
Classes
 | Class | Description
Public class | SyslogClient | Implements SYSLOG UDP client
Public class | SyslogMessage | Represents a UNIX-standard SYSLOG message
Enumerations
 | Enumeration | Description
Public enumeration | FacilityLevel | Standard SYSLOG severity levels http://en.wikipedia.org/wiki/Syslog
Public enumeration | SeverityLevel | Standard SYSLOG severity levels http://en.wikipedia.org/wiki/Syslog


FacilityLevel Enumeration

FacilityLevel Enumeration NFX Class Library

Standard SYSLOG severity levels http://en.wikipedia.org/wiki/Syslog

Namespace: NFX.Log.Syslog
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum FacilityLevel
public enum FacilityLevel
Public Enumeration FacilityLevel
Public Enumeration FacilityLevel
public enum class FacilityLevel
public enum class FacilityLevel
type FacilityLevel
type FacilityLevel
Members
Member name | Value | Description
Kernel | 0 |
User | 1 |
Mail | 2 |
Daemon | 3 |
Auth | 4 |
Syslog | 5 |
Lpr | 6 |
News | 7 |
UUCP | 8 |
Cron | 9 |
AuthPriv | 10 |
Ftp | 11 |
Ntp | 12 |
LogAudit | 13 |
LogAlert | 14 |
ClockDaemon | 15 |
Local0 | 16 |
Local1 | 17 |
Local2 | 18 |
Local3 | 19 |
Local4 | 20 |
Local5 | 21 |
Local6 | 22 |
Local7 | 23 |
See Also
NFX.Log.Syslog Namespace


SeverityLevel Enumeration

SeverityLevel Enumeration NFX Class Library

Standard SYSLOG severity levels http://en.wikipedia.org/wiki/Syslog

Namespace: NFX.Log.Syslog
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum SeverityLevel
public enum SeverityLevel
Public Enumeration SeverityLevel
Public Enumeration SeverityLevel
public enum class SeverityLevel
public enum class SeverityLevel
type SeverityLevel
type SeverityLevel
Members
Member name | Value | Description
Emergency | 0 |
Alert | 1 |
Critical | 2 |
Error | 3 |
Warning | 4 |
Notice | 5 |
Information | 6 |
Debug | 7 |
See Also
NFX.Log.Syslog Namespace


SyslogClient Class

SyslogClient Class NFX Class Library

Implements SYSLOG UDP client
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Log.Syslog SyslogClient

Namespace: NFX.Log.Syslog
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class SyslogClient : DisposableObject,
    IConfigurable
public sealed class SyslogClient : DisposableObject,
    IConfigurable
Public NotInheritable Class SyslogClient
    Inherits DisposableObject
    Implements IConfigurable
Public NotInheritable Class SyslogClient
    Inherits DisposableObject
    Implements IConfigurable
public ref class SyslogClient sealed : public DisposableObject,
    IConfigurable
public ref class SyslogClient sealed : public DisposableObject,
    IConfigurable
[<SealedAttribute>]
type SyslogClient =
    class
        inherit DisposableObject
        interface IConfigurable
    end
[<SealedAttribute>]
type SyslogClient =
    class
        inherit DisposableObject
        interface IConfigurable
    end
See Also
SyslogClient Members
NFX.Log.Syslog Namespace


SyslogClient Members

SyslogClient Members NFX Class Library

The SyslogClient type exposes the following members.
Constructors
 | Name | Description
Public method | SyslogClient | Initializes a new instance of the SyslogClient class
Public method | SyslogClient(String) | Initializes a new instance of the SyslogClient class
Public method | SyslogClient(String, Int32) | Initializes a new instance of the SyslogClient class
Back to Top
Methods
 | Name | Description
Public method | Close |
Public method | Configure |
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Send |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
SYSLOG_PORT |
Back to Top
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Host |
Public property | Port |
Back to Top
See Also
SyslogClient Class
NFX.Log.Syslog Namespace


SyslogClient Constructor

SyslogClient Constructor NFX Class Library

Overload List
 | Name | Description
Public method | SyslogClient | Initializes a new instance of the SyslogClient class
Public method | SyslogClient(String) | Initializes a new instance of the SyslogClient class
Public method | SyslogClient(String, Int32) | Initializes a new instance of the SyslogClient class
Back to Top
See Also
SyslogClient Class
SyslogClient Members
NFX.Log.Syslog Namespace


SyslogClient Constructor

SyslogClient Constructor NFX Class Library

Initializes a new instance of the SyslogClient class

Namespace: NFX.Log.Syslog
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SyslogClient()
public SyslogClient()
Public Sub New
Public Sub New
public:
SyslogClient()
public:
SyslogClient()
new : unit -> SyslogClient
new : unit -> SyslogClient
See Also
SyslogClient Class
SyslogClient Members
SyslogClient Overload
NFX.Log.Syslog Namespace


SyslogClient Constructor (String)

SyslogClient Constructor (String) NFX Class Library

Initializes a new instance of the SyslogClient class

Namespace: NFX.Log.Syslog
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SyslogClient(
    string host
)
public SyslogClient(
    string host
)
Public Sub New (
    host As String
)
Public Sub New (
    host As String
)
public:
SyslogClient(
    String^ host
)
public:
SyslogClient(
    String^ host
)
new :
        host : string -> SyslogClient
new :
        host : string -> SyslogClient

Parameters

host
Type: Online System String
See Also
SyslogClient Class
SyslogClient Members
SyslogClient Overload
NFX.Log.Syslog Namespace


SyslogClient Constructor (String, Int32)

SyslogClient Constructor (String, Int32) NFX Class Library

Initializes a new instance of the SyslogClient class

Namespace: NFX.Log.Syslog
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SyslogClient(
    string host,
    int port
)
public SyslogClient(
    string host,
    int port
)
Public Sub New (
    host As String,
    port As Integer
)
Public Sub New (
    host As String,
    port As Integer
)
public:
SyslogClient(
    String^ host,
    int port
)
public:
SyslogClient(
    String^ host,
    int port
)
new :
        host : string *
        port : int -> SyslogClient
new :
        host : string *
        port : int -> SyslogClient

Parameters

host
Type: Online System String
port
Type: Online System Int32
See Also
SyslogClient Class
SyslogClient Members
SyslogClient Overload
NFX.Log.Syslog Namespace


SyslogClient Fields

SyslogClient Fields NFX Class Library

The SyslogClient type exposes the following members.
Fields
Name | Description
SYSLOG_PORT |
Back to Top
See Also
SyslogClient Class
NFX.Log.Syslog Namespace


SyslogClient.SYSLOG_PORT Field

SyslogClient SYSLOG_PORT Field NFX Class Library

Namespace: NFX.Log.Syslog
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int SYSLOG_PORT
public const int SYSLOG_PORT
Public Const SYSLOG_PORT As Integer
Public Const SYSLOG_PORT As Integer
public:
literal int SYSLOG_PORT
public:
literal int SYSLOG_PORT
static val mutable SYSLOG_PORT: int
static val mutable SYSLOG_PORT: int

Field Value

Type: Online Int32
See Also
SyslogClient Class
SyslogClient Members
NFX.Log.Syslog Namespace


SyslogClient Methods

SyslogClient Methods NFX Class Library

The SyslogClient type exposes the following members.
Methods
 | Name | Description
Public method | Close |
Public method | Configure |
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Send |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SyslogClient Class
NFX.Log.Syslog Namespace


SyslogClient.Close Method

SyslogClient Close Method NFX Class Library

Namespace: NFX.Log.Syslog
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Close()
public void Close()
Public Sub Close
Public Sub Close
public:
void Close()
public:
void Close()
member Close : unit -> unit
member Close : unit -> unit
See Also
SyslogClient Class
SyslogClient Members
NFX.Log.Syslog Namespace


SyslogClient.Configure Method

SyslogClient Configure Method NFX Class Library

Namespace: NFX.Log.Syslog
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode node
)
public void Configure(
    IConfigSectionNode node
)
Public Sub Configure (
    node As IConfigSectionNode
)
Public Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
SyslogClient Class
SyslogClient Members
NFX.Log.Syslog Namespace


SyslogClient.Destructor Method

SyslogClient Destructor Method NFX Class Library

Namespace: NFX.Log.Syslog
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
SyslogClient Class
SyslogClient Members
NFX.Log.Syslog Namespace


SyslogClient.Send Method

SyslogClient Send Method NFX Class Library

Namespace: NFX.Log.Syslog
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Send(
    SyslogMessage message
)
public void Send(
    SyslogMessage message
)
Public Sub Send (
    message As SyslogMessage
)
Public Sub Send (
    message As SyslogMessage
)
public:
void Send(
    SyslogMessage^ message
)
public:
void Send(
    SyslogMessage^ message
)
member Send :
        message : SyslogMessage -> unit
member Send :
        message : SyslogMessage -> unit

Parameters

message
Type: NFX.Log.Syslog SyslogMessage
See Also
SyslogClient Class
SyslogClient Members
NFX.Log.Syslog Namespace


SyslogClient Properties

SyslogClient Properties NFX Class Library

The SyslogClient type exposes the following members.
Properties
 | Name | Description
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | Host |
Public property | Port |
Back to Top
See Also
SyslogClient Class
NFX.Log.Syslog Namespace


SyslogClient.Host Property

SyslogClient Host Property NFX Class Library

Namespace: NFX.Log.Syslog
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$host")]
public string Host { get; set; }
[ConfigAttribute("$host")]
public string Host { get; set; }
<ConfigAttribute("$host")>
Public Property Host As String
    Get
    Set
<ConfigAttribute("$host")>
Public Property Host As String
    Get
    Set
public:
[ConfigAttribute(L"$host")]
property String^ Host {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute(L"$host")]
property String^ Host {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute("$host")>]
member Host : string with get, set
[<ConfigAttribute("$host")>]
member Host : string with get, set

Property Value

Type: Online String
See Also
SyslogClient Class
SyslogClient Members
NFX.Log.Syslog Namespace


SyslogClient.Port Property

SyslogClient Port Property NFX Class Library

Namespace: NFX.Log.Syslog
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$port")]
public int Port { get; set; }
[ConfigAttribute("$port")]
public int Port { get; set; }
<ConfigAttribute("$port")>
Public Property Port As Integer
    Get
    Set
<ConfigAttribute("$port")>
Public Property Port As Integer
    Get
    Set
public:
[ConfigAttribute(L"$port")]
property int Port {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(L"$port")]
property int Port {
    int get ();
    void set (int value);
}
[<ConfigAttribute("$port")>]
member Port : int with get, set
[<ConfigAttribute("$port")>]
member Port : int with get, set

Property Value

Type: Online Int32
See Also
SyslogClient Class
SyslogClient Members
NFX.Log.Syslog Namespace


SyslogMessage Class

SyslogMessage Class NFX Class Library

Represents a UNIX-standard SYSLOG message
Inheritance Hierarchy
Online System Object
NFX.Log.Syslog SyslogMessage

Namespace: NFX.Log.Syslog
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class SyslogMessage
public sealed class SyslogMessage
Public NotInheritable Class SyslogMessage
Public NotInheritable Class SyslogMessage
public ref class SyslogMessage sealed
public ref class SyslogMessage sealed
[<SealedAttribute>]
type SyslogMessage =  class end
[<SealedAttribute>]
type SyslogMessage =  class end
See Also
SyslogMessage Members
NFX.Log.Syslog Namespace


SyslogMessage Members

SyslogMessage Members NFX Class Library

The SyslogMessage type exposes the following members.
Constructors
 | Name | Description
Public method | SyslogMessage | Initializes a new instance of the SyslogMessage class
Public method | SyslogMessage(Message) | Initializes a new instance of the SyslogMessage class
Public method | SyslogMessage(FacilityLevel, SeverityLevel, String) | Initializes a new instance of the SyslogMessage class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | FromNFXLogMessageType |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Facility |
Public property | LocalTimeStamp |
Public property | Priority |
Public property | Severity |
Public property | Text |
Back to Top
See Also
SyslogMessage Class
NFX.Log.Syslog Namespace


SyslogMessage Constructor

SyslogMessage Constructor NFX Class Library

Overload List
 | Name | Description
Public method | SyslogMessage | Initializes a new instance of the SyslogMessage class
Public method | SyslogMessage(Message) | Initializes a new instance of the SyslogMessage class
Public method | SyslogMessage(FacilityLevel, SeverityLevel, String) | Initializes a new instance of the SyslogMessage class
Back to Top
See Also
SyslogMessage Class
SyslogMessage Members
NFX.Log.Syslog Namespace


SyslogMessage Constructor

SyslogMessage Constructor NFX Class Library

Initializes a new instance of the SyslogMessage class

Namespace: NFX.Log.Syslog
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SyslogMessage()
public SyslogMessage()
Public Sub New
Public Sub New
public:
SyslogMessage()
public:
SyslogMessage()
new : unit -> SyslogMessage
new : unit -> SyslogMessage
See Also
SyslogMessage Class
SyslogMessage Members
SyslogMessage Overload
NFX.Log.Syslog Namespace


SyslogMessage Constructor (Message)

SyslogMessage Constructor (Message) NFX Class Library

Initializes a new instance of the SyslogMessage class

Namespace: NFX.Log.Syslog
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SyslogMessage(
    Message nfxMsg
)
public SyslogMessage(
    Message nfxMsg
)
Public Sub New (
    nfxMsg As Message
)
Public Sub New (
    nfxMsg As Message
)
public:
SyslogMessage(
    Message^ nfxMsg
)
public:
SyslogMessage(
    Message^ nfxMsg
)
new :
        nfxMsg : Message -> SyslogMessage
new :
        nfxMsg : Message -> SyslogMessage

Parameters

nfxMsg
Type: NFX.Log Message
See Also
SyslogMessage Class
SyslogMessage Members
SyslogMessage Overload
NFX.Log.Syslog Namespace


SyslogMessage Constructor (FacilityLevel, SeverityLevel, String)

SyslogMessage Constructor (FacilityLevel, SeverityLevel, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SyslogMessage class

Namespace: NFX.Log.Syslog
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SyslogMessage(
    FacilityLevel facility,
    SeverityLevel level,
    string text
)
public SyslogMessage(
    FacilityLevel facility,
    SeverityLevel level,
    string text
)
Public Sub New (
    facility As FacilityLevel,
    level As SeverityLevel,
    text As String
)
Public Sub New (
    facility As FacilityLevel,
    level As SeverityLevel,
    text As String
)
public:
SyslogMessage(
    FacilityLevel facility,
    SeverityLevel level,
    String^ text
)
public:
SyslogMessage(
    FacilityLevel facility,
    SeverityLevel level,
    String^ text
)
new :
        facility : FacilityLevel *
        level : SeverityLevel *
        text : string -> SyslogMessage
new :
        facility : FacilityLevel *
        level : SeverityLevel *
        text : string -> SyslogMessage

Parameters

facility
Type: NFX.Log.Syslog FacilityLevel
level
Type: NFX.Log.Syslog SeverityLevel
text
Type: Online System String
See Also
SyslogMessage Class
SyslogMessage Members
SyslogMessage Overload
NFX.Log.Syslog Namespace


SyslogMessage Methods

SyslogMessage Methods NFX Class Library

The SyslogMessage type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | FromNFXLogMessageType |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SyslogMessage Class
NFX.Log.Syslog Namespace


SyslogMessage.FromNFXLogMessageType Method

SyslogMessage FromNFXLogMessageType Method NFX Class Library

Namespace: NFX.Log.Syslog
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static SeverityLevel FromNFXLogMessageType(
    MessageType type
)
public static SeverityLevel FromNFXLogMessageType(
    MessageType type
)
Public Shared Function FromNFXLogMessageType (
    type As MessageType
) As SeverityLevel
Public Shared Function FromNFXLogMessageType (
    type As MessageType
) As SeverityLevel
public:
static SeverityLevel FromNFXLogMessageType(
    MessageType type
)
public:
static SeverityLevel FromNFXLogMessageType(
    MessageType type
)
static member FromNFXLogMessageType :
        type : MessageType -> SeverityLevel
static member FromNFXLogMessageType :
        type : MessageType -> SeverityLevel

Parameters

type
Type: NFX.Log MessageType

Return Value

Type: SeverityLevel
See Also
SyslogMessage Class
SyslogMessage Members
NFX.Log.Syslog Namespace


SyslogMessage Properties

SyslogMessage Properties NFX Class Library

The SyslogMessage type exposes the following members.
Properties
 | Name | Description
Public property | Facility |
Public property | LocalTimeStamp |
Public property | Priority |
Public property | Severity |
Public property | Text |
Back to Top
See Also
SyslogMessage Class
NFX.Log.Syslog Namespace


SyslogMessage.Facility Property

SyslogMessage Facility Property NFX Class Library

Namespace: NFX.Log.Syslog
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FacilityLevel Facility { get; set; }
public FacilityLevel Facility { get; set; }
Public Property Facility As FacilityLevel
    Get
    Set
Public Property Facility As FacilityLevel
    Get
    Set
public:
property FacilityLevel Facility {
    FacilityLevel get ();
    void set (FacilityLevel value);
}
public:
property FacilityLevel Facility {
    FacilityLevel get ();
    void set (FacilityLevel value);
}
member Facility : FacilityLevel with get, set
member Facility : FacilityLevel with get, set

Property Value

Type: FacilityLevel
See Also
SyslogMessage Class
SyslogMessage Members
NFX.Log.Syslog Namespace


SyslogMessage.LocalTimeStamp Property

SyslogMessage LocalTimeStamp Property NFX Class Library

Namespace: NFX.Log.Syslog
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime LocalTimeStamp { get; set; }
public DateTime LocalTimeStamp { get; set; }
Public Property LocalTimeStamp As DateTime
    Get
    Set
Public Property LocalTimeStamp As DateTime
    Get
    Set
public:
property DateTime LocalTimeStamp {
    DateTime get ();
    void set (DateTime value);
}
public:
property DateTime LocalTimeStamp {
    DateTime get ();
    void set (DateTime value);
}
member LocalTimeStamp : DateTime with get, set
member LocalTimeStamp : DateTime with get, set

Property Value

Type: Online DateTime
See Also
SyslogMessage Class
SyslogMessage Members
NFX.Log.Syslog Namespace


SyslogMessage.Priority Property

SyslogMessage Priority Property NFX Class Library

Namespace: NFX.Log.Syslog
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Priority { get; }
public int Priority { get; }
Public ReadOnly Property Priority As Integer
    Get
Public ReadOnly Property Priority As Integer
    Get
public:
property int Priority {
    int get ();
}
public:
property int Priority {
    int get ();
}
member Priority : int with get
member Priority : int with get

Property Value

Type: Online Int32
See Also
SyslogMessage Class
SyslogMessage Members
NFX.Log.Syslog Namespace


SyslogMessage.Severity Property

SyslogMessage Severity Property NFX Class Library

Namespace: NFX.Log.Syslog
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SeverityLevel Severity { get; set; }
public SeverityLevel Severity { get; set; }
Public Property Severity As SeverityLevel
    Get
    Set
Public Property Severity As SeverityLevel
    Get
    Set
public:
property SeverityLevel Severity {
    SeverityLevel get ();
    void set (SeverityLevel value);
}
public:
property SeverityLevel Severity {
    SeverityLevel get ();
    void set (SeverityLevel value);
}
member Severity : SeverityLevel with get, set
member Severity : SeverityLevel with get, set

Property Value

Type: SeverityLevel
See Also
SyslogMessage Class
SyslogMessage Members
NFX.Log.Syslog Namespace


SyslogMessage.Text Property

SyslogMessage Text Property NFX Class Library

Namespace: NFX.Log.Syslog
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Text { get; set; }
public string Text { get; set; }
Public Property Text As String
    Get
    Set
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set
member Text : string with get, set

Property Value

Type: Online String
See Also
SyslogMessage Class
SyslogMessage Members
NFX.Log.Syslog Namespace


NFX.Media.Graphics Namespace

NFX.Media.Graphics Namespace NFX Class Library

Classes
 | Class | Description
Public class | DrawingOutput |


DrawingOutput Class

DrawingOutput Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Media.Graphics DrawingOutput

Namespace: NFX.Media.Graphics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class DrawingOutput : DisposableObject
public class DrawingOutput : DisposableObject
Public Class DrawingOutput
    Inherits DisposableObject
Public Class DrawingOutput
    Inherits DisposableObject
public ref class DrawingOutput : public DisposableObject
public ref class DrawingOutput : public DisposableObject
type DrawingOutput =
    class
        inherit DisposableObject
    end
type DrawingOutput =
    class
        inherit DisposableObject
    end
See Also
DrawingOutput Members
NFX.Media.Graphics Namespace


DrawingOutput Members

DrawingOutput Members NFX Class Library

The DrawingOutput type exposes the following members.
Constructors
 | Name | Description
Public method | DrawingOutput | Initializes a new instance of the DrawingOutput class
Public method | DrawingOutput(Int32, Int32) | Initializes a new instance of the DrawingOutput class
Public method | DrawingOutput(Int32, Int32, Brush) | Initializes a new instance of the DrawingOutput class
Back to Top
Methods
 | Name | Description
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FillRect |
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetPixel |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetDimensions |
Public method | SetPixel |
Public method | SetPixelScaled |
Public method | ToImage |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Bitmap |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Back to Top
See Also
DrawingOutput Class
NFX.Media.Graphics Namespace


DrawingOutput Constructor

DrawingOutput Constructor NFX Class Library

Overload List
 | Name | Description
Public method | DrawingOutput | Initializes a new instance of the DrawingOutput class
Public method | DrawingOutput(Int32, Int32) | Initializes a new instance of the DrawingOutput class
Public method | DrawingOutput(Int32, Int32, Brush) | Initializes a new instance of the DrawingOutput class
Back to Top
See Also
DrawingOutput Class
DrawingOutput Members
NFX.Media.Graphics Namespace


DrawingOutput Constructor

DrawingOutput Constructor NFX Class Library

Initializes a new instance of the DrawingOutput class

Namespace: NFX.Media.Graphics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DrawingOutput()
public DrawingOutput()
Public Sub New
Public Sub New
public:
DrawingOutput()
public:
DrawingOutput()
new : unit -> DrawingOutput
new : unit -> DrawingOutput
See Also
DrawingOutput Class
DrawingOutput Members
DrawingOutput Overload
NFX.Media.Graphics Namespace


DrawingOutput Constructor (Int32, Int32)

DrawingOutput Constructor (Int32, Int32) NFX Class Library

Initializes a new instance of the DrawingOutput class

Namespace: NFX.Media.Graphics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DrawingOutput(
    int width,
    int height
)
public DrawingOutput(
    int width,
    int height
)
Public Sub New (
    width As Integer,
    height As Integer
)
Public Sub New (
    width As Integer,
    height As Integer
)
public:
DrawingOutput(
    int width,
    int height
)
public:
DrawingOutput(
    int width,
    int height
)
new :
        width : int *
        height : int -> DrawingOutput
new :
        width : int *
        height : int -> DrawingOutput

Parameters

width
Type: Online System Int32
height
Type: Online System Int32
See Also
DrawingOutput Class
DrawingOutput Members
DrawingOutput Overload
NFX.Media.Graphics Namespace


DrawingOutput Constructor (Int32, Int32, Brush)

DrawingOutput Constructor (Int32, Int32, Brush) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DrawingOutput class

Namespace: NFX.Media.Graphics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DrawingOutput(
    int width,
    int height,
    Brush fillBrush
)
public DrawingOutput(
    int width,
    int height,
    Brush fillBrush
)
Public Sub New (
    width As Integer,
    height As Integer,
    fillBrush As Brush
)
Public Sub New (
    width As Integer,
    height As Integer,
    fillBrush As Brush
)
public:
DrawingOutput(
    int width,
    int height,
    Brush^ fillBrush
)
public:
DrawingOutput(
    int width,
    int height,
    Brush^ fillBrush
)
new :
        width : int *
        height : int *
        fillBrush : Brush -> DrawingOutput
new :
        width : int *
        height : int *
        fillBrush : Brush -> DrawingOutput

Parameters

width
Type: Online System Int32
height
Type: Online System Int32
fillBrush
Type: Online System.Drawing Brush
See Also
DrawingOutput Class
DrawingOutput Members
DrawingOutput Overload
NFX.Media.Graphics Namespace


DrawingOutput Methods

DrawingOutput Methods NFX Class Library

The DrawingOutput type exposes the following members.
Methods
 | Name | Description
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FillRect |
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetPixel |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SetDimensions |
Public method | SetPixel |
Public method | SetPixelScaled |
Public method | ToImage |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
DrawingOutput Class
NFX.Media.Graphics Namespace


DrawingOutput.Destructor Method

DrawingOutput Destructor Method NFX Class Library

Namespace: NFX.Media.Graphics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
DrawingOutput Class
DrawingOutput Members
NFX.Media.Graphics Namespace


DrawingOutput.FillRect Method

DrawingOutput FillRect Method NFX Class Library

Namespace: NFX.Media.Graphics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void FillRect(
    int x,
    int y,
    int width,
    int height,
    Brush brush
)
public void FillRect(
    int x,
    int y,
    int width,
    int height,
    Brush brush
)
Public Sub FillRect (
    x As Integer,
    y As Integer,
    width As Integer,
    height As Integer,
    brush As Brush
)
Public Sub FillRect (
    x As Integer,
    y As Integer,
    width As Integer,
    height As Integer,
    brush As Brush
)
public:
void FillRect(
    int x,
    int y,
    int width,
    int height,
    Brush^ brush
)
public:
void FillRect(
    int x,
    int y,
    int width,
    int height,
    Brush^ brush
)
member FillRect :
        x : int *
        y : int *
        width : int *
        height : int *
        brush : Brush -> unit
member FillRect :
        x : int *
        y : int *
        width : int *
        height : int *
        brush : Brush -> unit

Parameters

x
Type: Online System Int32
y
Type: Online System Int32
width
Type: Online System Int32
height
Type: Online System Int32
brush
Type: Online System.Drawing Brush
See Also
DrawingOutput Class
DrawingOutput Members
NFX.Media.Graphics Namespace


DrawingOutput.GetPixel Method

DrawingOutput GetPixel Method NFX Class Library

Namespace: NFX.Media.Graphics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Color GetPixel(
    int x,
    int y
)
public Color GetPixel(
    int x,
    int y
)
Public Function GetPixel (
    x As Integer,
    y As Integer
) As Color
Public Function GetPixel (
    x As Integer,
    y As Integer
) As Color
public:
Color GetPixel(
    int x,
    int y
)
public:
Color GetPixel(
    int x,
    int y
)
member GetPixel :
        x : int *
        y : int -> Color
member GetPixel :
        x : int *
        y : int -> Color

Parameters

x
Type: Online System Int32
y
Type: Online System Int32

Return Value

Type: Online Color
See Also
DrawingOutput Class
DrawingOutput Members
NFX.Media.Graphics Namespace


DrawingOutput.SetDimensions Method

DrawingOutput SetDimensions Method NFX Class Library

Namespace: NFX.Media.Graphics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetDimensions(
    int width,
    int height
)
public void SetDimensions(
    int width,
    int height
)
Public Sub SetDimensions (
    width As Integer,
    height As Integer
)
Public Sub SetDimensions (
    width As Integer,
    height As Integer
)
public:
void SetDimensions(
    int width,
    int height
)
public:
void SetDimensions(
    int width,
    int height
)
member SetDimensions :
        width : int *
        height : int -> unit
member SetDimensions :
        width : int *
        height : int -> unit

Parameters

width
Type: Online System Int32
height
Type: Online System Int32
See Also
DrawingOutput Class
DrawingOutput Members
NFX.Media.Graphics Namespace


DrawingOutput.SetPixel Method

DrawingOutput SetPixel Method NFX Class Library

Namespace: NFX.Media.Graphics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetPixel(
    int x,
    int y,
    Color color
)
public void SetPixel(
    int x,
    int y,
    Color color
)
Public Sub SetPixel (
    x As Integer,
    y As Integer,
    color As Color
)
Public Sub SetPixel (
    x As Integer,
    y As Integer,
    color As Color
)
public:
void SetPixel(
    int x,
    int y,
    Color color
)
public:
void SetPixel(
    int x,
    int y,
    Color color
)
member SetPixel :
        x : int *
        y : int *
        color : Color -> unit
member SetPixel :
        x : int *
        y : int *
        color : Color -> unit

Parameters

x
Type: Online System Int32
y
Type: Online System Int32
color
Type: Online System.Drawing Color
See Also
DrawingOutput Class
DrawingOutput Members
NFX.Media.Graphics Namespace


DrawingOutput.SetPixelScaled Method

DrawingOutput SetPixelScaled Method NFX Class Library

Namespace: NFX.Media.Graphics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetPixelScaled(
    int x,
    int y,
    Brush brush,
    int scale = 1
)
public void SetPixelScaled(
    int x,
    int y,
    Brush brush,
    int scale = 1
)
Public Sub SetPixelScaled (
    x As Integer,
    y As Integer,
    brush As Brush,
    Optional scale As Integer = 1
)
Public Sub SetPixelScaled (
    x As Integer,
    y As Integer,
    brush As Brush,
    Optional scale As Integer = 1
)
public:
void SetPixelScaled(
    int x,
    int y,
    Brush^ brush,
    int scale = 1
)
public:
void SetPixelScaled(
    int x,
    int y,
    Brush^ brush,
    int scale = 1
)
member SetPixelScaled :
        x : int *
        y : int *
        brush : Brush *
        ?scale : int
(* Defaults:
        let _scale = defaultArg scale 1
*)
-> unit
member SetPixelScaled :
        x : int *
        y : int *
        brush : Brush *
        ?scale : int
(* Defaults:
        let _scale = defaultArg scale 1
*)
-> unit

Parameters

x
Type: Online System Int32
y
Type: Online System Int32
brush
Type: Online System.Drawing Brush
scale (Optional)
Type: Online System Int32
See Also
DrawingOutput Class
DrawingOutput Members
NFX.Media.Graphics Namespace


DrawingOutput.ToImage Method

DrawingOutput ToImage Method NFX Class Library

Namespace: NFX.Media.Graphics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ToImage(
    Stream s,
    ImageFormat format
)
public void ToImage(
    Stream s,
    ImageFormat format
)
Public Sub ToImage (
    s As Stream,
    format As ImageFormat
)
Public Sub ToImage (
    s As Stream,
    format As ImageFormat
)
public:
void ToImage(
    Stream^ s,
    ImageFormat^ format
)
public:
void ToImage(
    Stream^ s,
    ImageFormat^ format
)
member ToImage :
        s : Stream *
        format : ImageFormat -> unit
member ToImage :
        s : Stream *
        format : ImageFormat -> unit

Parameters

s
Type: Online System.IO Stream
format
Type: Online System.Drawing.Imaging ImageFormat
See Also
DrawingOutput Class
DrawingOutput Members
NFX.Media.Graphics Namespace


DrawingOutput Properties

DrawingOutput Properties NFX Class Library

The DrawingOutput type exposes the following members.
Properties
 | Name | Description
Public property | Bitmap |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Back to Top
See Also
DrawingOutput Class
NFX.Media.Graphics Namespace


DrawingOutput.Bitmap Property

DrawingOutput Bitmap Property NFX Class Library

Namespace: NFX.Media.Graphics
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Bitmap Bitmap { get; }
public Bitmap Bitmap { get; }
Public ReadOnly Property Bitmap As Bitmap
    Get
Public ReadOnly Property Bitmap As Bitmap
    Get
public:
property Bitmap^ Bitmap {
    Bitmap^ get ();
}
public:
property Bitmap^ Bitmap {
    Bitmap^ get ();
}
member Bitmap : Bitmap with get
member Bitmap : Bitmap with get

Property Value

Type: Online Bitmap
See Also
DrawingOutput Class
DrawingOutput Members
NFX.Media.Graphics Namespace


NFX.Media.PDF Namespace

NFX.Media.PDF Namespace NFX Class Library

Classes
 | Class | Description
Public class | Constants |
Protected class | ObjectRepository | Class that generates document-wide unique object Id-s (the class is not thread-safe)
Public class | PdfException | Base exception thrown by the PDF framework
Public class | PdfWriter | Class that aggregates PDF format-specific writing logic
Protected class | ResourceRepository | Class that generates document-wide unique resource Id-s (the class is not thread-safe)


Constants Class

Constants Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Media.PDF Constants

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class Constants
public static class Constants
Public NotInheritable Class Constants
Public NotInheritable Class Constants
public ref class Constants abstract sealed
public ref class Constants abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Constants =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Constants =  class end
See Also
Constants Members
NFX.Media.PDF Namespace


Constants Members

Constants Members NFX Class Library

The Constants type exposes the following members.
Fields
Name | Description
CARRIAGE_RETURN |
DEFAULT_DOCUMENT_VERSION |
DEFAULT_FONT_SIZE |
DEFAULT_LINE_THICKNESS |
DEFAULT_PARAGRAPH_LINE_HEIGHT |
LINE_FEED |
RETURN |
SPACE |
SQRT_TWO |
Back to Top
See Also
Constants Class
NFX.Media.PDF Namespace


Constants Fields

Constants Fields NFX Class Library

The Constants type exposes the following members.
Fields
Name | Description
CARRIAGE_RETURN |
DEFAULT_DOCUMENT_VERSION |
DEFAULT_FONT_SIZE |
DEFAULT_LINE_THICKNESS |
DEFAULT_PARAGRAPH_LINE_HEIGHT |
LINE_FEED |
RETURN |
SPACE |
SQRT_TWO |
Back to Top
See Also
Constants Class
NFX.Media.PDF Namespace


Constants.CARRIAGE_RETURN Field

Constants CARRIAGE_RETURN Field NFX Class Library

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const char CARRIAGE_RETURN
public const char CARRIAGE_RETURN
Public Const CARRIAGE_RETURN As Char
Public Const CARRIAGE_RETURN As Char
public:
literal wchar_t CARRIAGE_RETURN
public:
literal wchar_t CARRIAGE_RETURN
static val mutable CARRIAGE_RETURN: char
static val mutable CARRIAGE_RETURN: char

Field Value

Type: Online Char
See Also
Constants Class
Constants Members
NFX.Media.PDF Namespace


Constants.DEFAULT_DOCUMENT_VERSION Field

Constants DEFAULT_DOCUMENT_VERSION Field NFX Class Library

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_DOCUMENT_VERSION
public const string DEFAULT_DOCUMENT_VERSION
Public Const DEFAULT_DOCUMENT_VERSION As String
Public Const DEFAULT_DOCUMENT_VERSION As String
public:
literal String^ DEFAULT_DOCUMENT_VERSION
public:
literal String^ DEFAULT_DOCUMENT_VERSION
static val mutable DEFAULT_DOCUMENT_VERSION: string
static val mutable DEFAULT_DOCUMENT_VERSION: string

Field Value

Type: Online String
See Also
Constants Class
Constants Members
NFX.Media.PDF Namespace


Constants.DEFAULT_FONT_SIZE Field

Constants DEFAULT_FONT_SIZE Field NFX Class Library

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_FONT_SIZE
public const int DEFAULT_FONT_SIZE
Public Const DEFAULT_FONT_SIZE As Integer
Public Const DEFAULT_FONT_SIZE As Integer
public:
literal int DEFAULT_FONT_SIZE
public:
literal int DEFAULT_FONT_SIZE
static val mutable DEFAULT_FONT_SIZE: int
static val mutable DEFAULT_FONT_SIZE: int

Field Value

Type: Online Int32
See Also
Constants Class
Constants Members
NFX.Media.PDF Namespace


Constants.DEFAULT_LINE_THICKNESS Field

Constants DEFAULT_LINE_THICKNESS Field NFX Class Library

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const float DEFAULT_LINE_THICKNESS
public const float DEFAULT_LINE_THICKNESS
Public Const DEFAULT_LINE_THICKNESS As Single
Public Const DEFAULT_LINE_THICKNESS As Single
public:
literal float DEFAULT_LINE_THICKNESS
public:
literal float DEFAULT_LINE_THICKNESS
static val mutable DEFAULT_LINE_THICKNESS: float32
static val mutable DEFAULT_LINE_THICKNESS: float32

Field Value

Type: Online Single
See Also
Constants Class
Constants Members
NFX.Media.PDF Namespace


Constants.DEFAULT_PARAGRAPH_LINE_HEIGHT Field

Constants DEFAULT_PARAGRAPH_LINE_HEIGHT Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_PARAGRAPH_LINE_HEIGHT
public const int DEFAULT_PARAGRAPH_LINE_HEIGHT
Public Const DEFAULT_PARAGRAPH_LINE_HEIGHT As Integer
Public Const DEFAULT_PARAGRAPH_LINE_HEIGHT As Integer
public:
literal int DEFAULT_PARAGRAPH_LINE_HEIGHT
public:
literal int DEFAULT_PARAGRAPH_LINE_HEIGHT
static val mutable DEFAULT_PARAGRAPH_LINE_HEIGHT: int
static val mutable DEFAULT_PARAGRAPH_LINE_HEIGHT: int

Field Value

Type: Online Int32
See Also
Constants Class
Constants Members
NFX.Media.PDF Namespace


Constants.LINE_FEED Field

Constants LINE_FEED Field NFX Class Library

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const char LINE_FEED
public const char LINE_FEED
Public Const LINE_FEED As Char
Public Const LINE_FEED As Char
public:
literal wchar_t LINE_FEED
public:
literal wchar_t LINE_FEED
static val mutable LINE_FEED: char
static val mutable LINE_FEED: char

Field Value

Type: Online Char
See Also
Constants Class
Constants Members
NFX.Media.PDF Namespace


Constants.RETURN Field

Constants RETURN Field NFX Class Library

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string RETURN
public const string RETURN
Public Const RETURN As String
Public Const RETURN As String
public:
literal String^ RETURN
public:
literal String^ RETURN
static val mutable RETURN: string
static val mutable RETURN: string

Field Value

Type: Online String
See Also
Constants Class
Constants Members
NFX.Media.PDF Namespace


Constants.SPACE Field

Constants SPACE Field NFX Class Library

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SPACE
public const string SPACE
Public Const SPACE As String
Public Const SPACE As String
public:
literal String^ SPACE
public:
literal String^ SPACE
static val mutable SPACE: string
static val mutable SPACE: string

Field Value

Type: Online String
See Also
Constants Class
Constants Members
NFX.Media.PDF Namespace


Constants.SQRT_TWO Field

Constants SQRT_TWO Field NFX Class Library

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const float SQRT_TWO
public const float SQRT_TWO
Public Const SQRT_TWO As Single
Public Const SQRT_TWO As Single
public:
literal float SQRT_TWO
public:
literal float SQRT_TWO
static val mutable SQRT_TWO: float32
static val mutable SQRT_TWO: float32

Field Value

Type: Online Single
See Also
Constants Class
Constants Members
NFX.Media.PDF Namespace


ObjectRepository Class

ObjectRepository Class NFX Class Library

Class that generates document-wide unique object Id-s (the class is not thread-safe)
Inheritance Hierarchy
Online System Object
NFX.Media.PDF ObjectRepository

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class ObjectRepository
internal class ObjectRepository
Friend Class ObjectRepository
Friend Class ObjectRepository
internal ref class ObjectRepository
internal ref class ObjectRepository
type ObjectRepository =  class end
type ObjectRepository =  class end
See Also
ObjectRepository Members
NFX.Media.PDF Namespace


ObjectRepository Members

ObjectRepository Members NFX Class Library

The ObjectRepository type exposes the following members.
Constructors
 | Name | Description
Public method | ObjectRepository | Initializes a new instance of the ObjectRepository class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetObject |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Register |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | CurrentId |
Back to Top
See Also
ObjectRepository Class
NFX.Media.PDF Namespace


ObjectRepository Constructor

ObjectRepository Constructor NFX Class Library

Initializes a new instance of the ObjectRepository class

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ObjectRepository()
public ObjectRepository()
Public Sub New
Public Sub New
public:
ObjectRepository()
public:
ObjectRepository()
new : unit -> ObjectRepository
new : unit -> ObjectRepository
See Also
ObjectRepository Class
ObjectRepository Members
NFX.Media.PDF Namespace


ObjectRepository Methods

ObjectRepository Methods NFX Class Library

The ObjectRepository type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetObject |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | Register |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ObjectRepository Class
NFX.Media.PDF Namespace


ObjectRepository.GetObject Method

ObjectRepository GetObject Method NFX Class Library

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IPdfObject GetObject(
    int id
)
public IPdfObject GetObject(
    int id
)
Public Function GetObject (
    id As Integer
) As IPdfObject
Public Function GetObject (
    id As Integer
) As IPdfObject
public:
IPdfObject^ GetObject(
    int id
)
public:
IPdfObject^ GetObject(
    int id
)
member GetObject :
        id : int -> IPdfObject
member GetObject :
        id : int -> IPdfObject

Parameters

id
Type: Online System Int32

Return Value

Type: IPdfObject
See Also
ObjectRepository Class
ObjectRepository Members
NFX.Media.PDF Namespace


ObjectRepository.Register Method

ObjectRepository Register Method NFX Class Library

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Register(
    IPdfObject pdfObject
)
internal void Register(
    IPdfObject pdfObject
)
Friend Sub Register (
    pdfObject As IPdfObject
)
Friend Sub Register (
    pdfObject As IPdfObject
)
internal:
void Register(
    IPdfObject^ pdfObject
)
internal:
void Register(
    IPdfObject^ pdfObject
)
internal member Register :
        pdfObject : IPdfObject -> unit
internal member Register :
        pdfObject : IPdfObject -> unit

Parameters

pdfObject
Type: NFX.Media.PDF.DocumentModel IPdfObject
See Also
ObjectRepository Class
ObjectRepository Members
NFX.Media.PDF Namespace


ObjectRepository Properties

ObjectRepository Properties NFX Class Library

The ObjectRepository type exposes the following members.
Properties
 | Name | Description
Public property | CurrentId |
Back to Top
See Also
ObjectRepository Class
NFX.Media.PDF Namespace


ObjectRepository.CurrentId Property

ObjectRepository CurrentId Property NFX Class Library

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CurrentId { get; }
public int CurrentId { get; }
Public ReadOnly Property CurrentId As Integer
    Get
Public ReadOnly Property CurrentId As Integer
    Get
public:
property int CurrentId {
    int get ();
}
public:
property int CurrentId {
    int get ();
}
member CurrentId : int with get
member CurrentId : int with get

Property Value

Type: Online Int32
See Also
ObjectRepository Class
ObjectRepository Members
NFX.Media.PDF Namespace


PdfException Class

PdfException Class NFX Class Library

Base exception thrown by the PDF framework
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Media.PDF PdfException

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PdfException : NFXException
[SerializableAttribute]
public class PdfException : NFXException
<SerializableAttribute>
Public Class PdfException
    Inherits NFXException
<SerializableAttribute>
Public Class PdfException
    Inherits NFXException
[SerializableAttribute]
public ref class PdfException : public NFXException
[SerializableAttribute]
public ref class PdfException : public NFXException
[<SerializableAttribute>]
type PdfException =
    class
        inherit NFXException
    end
[<SerializableAttribute>]
type PdfException =
    class
        inherit NFXException
    end
See Also
PdfException Members
NFX.Media.PDF Namespace


PdfException Members

PdfException Members NFX Class Library

The PdfException type exposes the following members.
Constructors
 | Name | Description
Public method | PdfException | Initializes a new instance of the PdfException class
Public method | PdfException(String) | Initializes a new instance of the PdfException class
Protected method | PdfException(SerializationInfo, StreamingContext) | Initializes a new instance of the PdfException class
Public method | PdfException(String, Exception) | Initializes a new instance of the PdfException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
PdfException Class
NFX.Media.PDF Namespace


PdfException Constructor

PdfException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | PdfException | Initializes a new instance of the PdfException class
Public method | PdfException(String) | Initializes a new instance of the PdfException class
Protected method | PdfException(SerializationInfo, StreamingContext) | Initializes a new instance of the PdfException class
Public method | PdfException(String, Exception) | Initializes a new instance of the PdfException class
Back to Top
See Also
PdfException Class
PdfException Members
NFX.Media.PDF Namespace


PdfException Constructor

PdfException Constructor NFX Class Library

Initializes a new instance of the PdfException class

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfException()
public PdfException()
Public Sub New
Public Sub New
public:
PdfException()
public:
PdfException()
new : unit -> PdfException
new : unit -> PdfException
See Also
PdfException Class
PdfException Members
PdfException Overload
NFX.Media.PDF Namespace


PdfException Constructor (String)

PdfException Constructor (String) NFX Class Library

Initializes a new instance of the PdfException class

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfException(
    string message
)
public PdfException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
PdfException(
    String^ message
)
public:
PdfException(
    String^ message
)
new :
        message : string -> PdfException
new :
        message : string -> PdfException

Parameters

message
Type: Online System String
See Also
PdfException Class
PdfException Members
PdfException Overload
NFX.Media.PDF Namespace


PdfException Constructor (SerializationInfo, StreamingContext)

PdfException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PdfException class

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PdfException(
    SerializationInfo info,
    StreamingContext context
)
protected PdfException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
PdfException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
PdfException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PdfException
new :
        info : SerializationInfo *
        context : StreamingContext -> PdfException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
PdfException Class
PdfException Members
PdfException Overload
NFX.Media.PDF Namespace


PdfException Constructor (String, Exception)

PdfException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PdfException class

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfException(
    string message,
    Exception inner
)
public PdfException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
PdfException(
    String^ message,
    Exception^ inner
)
public:
PdfException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> PdfException
new :
        message : string *
        inner : Exception -> PdfException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
PdfException Class
PdfException Members
PdfException Overload
NFX.Media.PDF Namespace


PdfException Methods

PdfException Methods NFX Class Library

The PdfException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
PdfException Class
NFX.Media.PDF Namespace


PdfException Properties

PdfException Properties NFX Class Library

The PdfException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
PdfException Class
NFX.Media.PDF Namespace


PdfException Events

PdfException Events NFX Class Library

The PdfException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
PdfException Class
NFX.Media.PDF Namespace


PdfWriter Class

PdfWriter Class NFX Class Library

Class that aggregates PDF format-specific writing logic
Inheritance Hierarchy
Online System Object
NFX.Media.PDF PdfWriter

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class PdfWriter : IDisposable
public sealed class PdfWriter : IDisposable
Public NotInheritable Class PdfWriter
    Implements IDisposable
Public NotInheritable Class PdfWriter
    Implements IDisposable
public ref class PdfWriter sealed : IDisposable
public ref class PdfWriter sealed : IDisposable
[<SealedAttribute>]
type PdfWriter =
    class
        interface IDisposable
    end
[<SealedAttribute>]
type PdfWriter =
    class
        interface IDisposable
    end
See Also
PdfWriter Members
NFX.Media.PDF Namespace


PdfWriter Members

PdfWriter Members NFX Class Library

The PdfWriter type exposes the following members.
Constructors
 | Name | Description
Public method | PdfWriter | Initializes a new instance of the PdfWriter class
Back to Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the PdfWriter
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | Write(ImageElement) | Writes PDF image element into file stream
Protected method | Write(PathElement) | Writes PDF path into file stream
Public method | Write(PdfDocument) | Writes PDF document into file stream
Protected method | Write(PdfFont) | Writes PDF font into file stream
Protected method | Write(PdfInfo) | Writes PDF info into file stream
Protected method | Write(PdfMeta) |
Protected method | Write(PdfOutlines) | Writes PDF document outlines into file stream
Protected method | Write(PdfPage) | Writes PDF page into file stream
Protected method | Write(PdfPageTree) | Writes PDF document page tree into file stream
Protected method | Write(PdfRoot) | Writes PDF header into file stream
Protected method | Write(PdfTrailer) | Writes PDF document trailer into file stream
Protected method | Write(RectangleElement) | Writes PDF rectangle element into file stream
Protected method | Write(TextElement) | Writes PDF text element into file stream
Protected method | WriteXObject | Writes PDF image xObject element into file stream
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | PrettyFormatting | Insert nonnecessary tabs and returns for a pretty output look file
Back to Top
See Also
PdfWriter Class
NFX.Media.PDF Namespace


PdfWriter Constructor

PdfWriter Constructor NFX Class Library

Initializes a new instance of the PdfWriter class

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfWriter(
    Stream stream
)
public PdfWriter(
    Stream stream
)
Public Sub New (
    stream As Stream
)
Public Sub New (
    stream As Stream
)
public:
PdfWriter(
    Stream^ stream
)
public:
PdfWriter(
    Stream^ stream
)
new :
        stream : Stream -> PdfWriter
new :
        stream : Stream -> PdfWriter

Parameters

stream
Type: Online System.IO Stream
See Also
PdfWriter Class
PdfWriter Members
NFX.Media.PDF Namespace


PdfWriter Methods

PdfWriter Methods NFX Class Library

The PdfWriter type exposes the following members.
Methods
 | Name | Description
Public method | Dispose |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | Write(ImageElement) | Writes PDF image element into file stream
Protected method | Write(PathElement) | Writes PDF path into file stream
Public method | Write(PdfDocument) | Writes PDF document into file stream
Protected method | Write(PdfFont) | Writes PDF font into file stream
Protected method | Write(PdfInfo) | Writes PDF info into file stream
Protected method | Write(PdfMeta) |
Protected method | Write(PdfOutlines) | Writes PDF document outlines into file stream
Protected method | Write(PdfPage) | Writes PDF page into file stream
Protected method | Write(PdfPageTree) | Writes PDF document page tree into file stream
Protected method | Write(PdfRoot) | Writes PDF header into file stream
Protected method | Write(PdfTrailer) | Writes PDF document trailer into file stream
Protected method | Write(RectangleElement) | Writes PDF rectangle element into file stream
Protected method | Write(TextElement) | Writes PDF text element into file stream
Protected method | WriteXObject | Writes PDF image xObject element into file stream
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PdfWriter Class
NFX.Media.PDF Namespace


PdfWriter.Dispose Method

PdfWriter Dispose Method NFX Class Library

Releases all resources used by the PdfWriter

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

Online IDisposable Dispose
See Also
PdfWriter Class
PdfWriter Members
NFX.Media.PDF Namespace


PdfWriter.Write Method

PdfWriter Write Method NFX Class Library

Overload List
 | Name | Description
Protected method | Write(ImageElement) | Writes PDF image element into file stream
Protected method | Write(PathElement) | Writes PDF path into file stream
Public method | Write(PdfDocument) | Writes PDF document into file stream
Protected method | Write(PdfFont) | Writes PDF font into file stream
Protected method | Write(PdfInfo) | Writes PDF info into file stream
Protected method | Write(PdfMeta) |
Protected method | Write(PdfOutlines) | Writes PDF document outlines into file stream
Protected method | Write(PdfPage) | Writes PDF page into file stream
Protected method | Write(PdfPageTree) | Writes PDF document page tree into file stream
Protected method | Write(PdfRoot) | Writes PDF header into file stream
Protected method | Write(PdfTrailer) | Writes PDF document trailer into file stream
Protected method | Write(RectangleElement) | Writes PDF rectangle element into file stream
Protected method | Write(TextElement) | Writes PDF text element into file stream
Back to Top
See Also
PdfWriter Class
PdfWriter Members
NFX.Media.PDF Namespace


PdfWriter.Write Method (ImageElement)

PdfWriter Write Method (ImageElement) NFX Class Library

Writes PDF image element into file stream

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Write(
    ImageElement image
)
internal void Write(
    ImageElement image
)
Friend Sub Write (
    image As ImageElement
)
Friend Sub Write (
    image As ImageElement
)
internal:
void Write(
    ImageElement^ image
)
internal:
void Write(
    ImageElement^ image
)
internal member Write :
        image : ImageElement -> unit
internal member Write :
        image : ImageElement -> unit

Parameters

image
Type: NFX.Media.PDF.Elements ImageElement
PDF image element
See Also
PdfWriter Class
PdfWriter Members
Write Overload
NFX.Media.PDF Namespace


PdfWriter.Write Method (PathElement)

PdfWriter Write Method (PathElement) NFX Class Library

Writes PDF path into file stream

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Write(
    PathElement path
)
internal void Write(
    PathElement path
)
Friend Sub Write (
    path As PathElement
)
Friend Sub Write (
    path As PathElement
)
internal:
void Write(
    PathElement^ path
)
internal:
void Write(
    PathElement^ path
)
internal member Write :
        path : PathElement -> unit
internal member Write :
        path : PathElement -> unit

Parameters

path
Type: NFX.Media.PDF.Elements PathElement
PDF path element
See Also
PdfWriter Class
PdfWriter Members
Write Overload
NFX.Media.PDF Namespace


PdfWriter.Write Method (PdfDocument)

PdfWriter Write Method (PdfDocument) NFX Class Library

Writes PDF document into file stream

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Write(
    PdfDocument document
)
public void Write(
    PdfDocument document
)
Public Sub Write (
    document As PdfDocument
)
Public Sub Write (
    document As PdfDocument
)
public:
void Write(
    PdfDocument^ document
)
public:
void Write(
    PdfDocument^ document
)
member Write :
        document : PdfDocument -> unit
member Write :
        document : PdfDocument -> unit

Parameters

document
Type: NFX.Media.PDF.DocumentModel PdfDocument
PDF document
See Also
PdfWriter Class
PdfWriter Members
Write Overload
NFX.Media.PDF Namespace


PdfWriter.Write Method (PdfFont)

PdfWriter Write Method (PdfFont) NFX Class Library

Writes PDF font into file stream

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Write(
    PdfFont font
)
internal void Write(
    PdfFont font
)
Friend Sub Write (
    font As PdfFont
)
Friend Sub Write (
    font As PdfFont
)
internal:
void Write(
    PdfFont^ font
)
internal:
void Write(
    PdfFont^ font
)
internal member Write :
        font : PdfFont -> unit
internal member Write :
        font : PdfFont -> unit

Parameters

font
Type: NFX.Media.PDF.DocumentModel PdfFont
PDF font
See Also
PdfWriter Class
PdfWriter Members
Write Overload
NFX.Media.PDF Namespace


PdfWriter.Write Method (PdfInfo)

PdfWriter Write Method (PdfInfo) NFX Class Library

Writes PDF info into file stream

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Write(
    PdfInfo info
)
internal void Write(
    PdfInfo info
)
Friend Sub Write (
    info As PdfInfo
)
Friend Sub Write (
    info As PdfInfo
)
internal:
void Write(
    PdfInfo^ info
)
internal:
void Write(
    PdfInfo^ info
)
internal member Write :
        info : PdfInfo -> unit
internal member Write :
        info : PdfInfo -> unit

Parameters

info
Type: NFX.Media.PDF.DocumentModel PdfInfo
PDF document info
See Also
PdfWriter Class
PdfWriter Members
Write Overload
NFX.Media.PDF Namespace


PdfWriter.Write Method (PdfMeta)

PdfWriter Write Method (PdfMeta) NFX Class Library

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Write(
    PdfMeta meta
)
internal void Write(
    PdfMeta meta
)
Friend Sub Write (
    meta As PdfMeta
)
Friend Sub Write (
    meta As PdfMeta
)
internal:
void Write(
    PdfMeta^ meta
)
internal:
void Write(
    PdfMeta^ meta
)
internal member Write :
        meta : PdfMeta -> unit
internal member Write :
        meta : PdfMeta -> unit

Parameters

meta
Type: NFX.Media.PDF.DocumentModel PdfMeta
See Also
PdfWriter Class
PdfWriter Members
Write Overload
NFX.Media.PDF Namespace


PdfWriter.Write Method (PdfOutlines)

PdfWriter Write Method (PdfOutlines) NFX Class Library

Writes PDF document outlines into file stream

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Write(
    PdfOutlines outlines
)
internal void Write(
    PdfOutlines outlines
)
Friend Sub Write (
    outlines As PdfOutlines
)
Friend Sub Write (
    outlines As PdfOutlines
)
internal:
void Write(
    PdfOutlines^ outlines
)
internal:
void Write(
    PdfOutlines^ outlines
)
internal member Write :
        outlines : PdfOutlines -> unit
internal member Write :
        outlines : PdfOutlines -> unit

Parameters

outlines
Type: NFX.Media.PDF.DocumentModel PdfOutlines
PDF document outlines
See Also
PdfWriter Class
PdfWriter Members
Write Overload
NFX.Media.PDF Namespace


PdfWriter.Write Method (PdfPage)

PdfWriter Write Method (PdfPage) NFX Class Library

Writes PDF page into file stream

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Write(
    PdfPage page
)
internal void Write(
    PdfPage page
)
Friend Sub Write (
    page As PdfPage
)
Friend Sub Write (
    page As PdfPage
)
internal:
void Write(
    PdfPage^ page
)
internal:
void Write(
    PdfPage^ page
)
internal member Write :
        page : PdfPage -> unit
internal member Write :
        page : PdfPage -> unit

Parameters

page
Type: NFX.Media.PDF.DocumentModel PdfPage
PDF page
See Also
PdfWriter Class
PdfWriter Members
Write Overload
NFX.Media.PDF Namespace


PdfWriter.Write Method (PdfPageTree)

PdfWriter Write Method (PdfPageTree) NFX Class Library

Writes PDF document page tree into file stream

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Write(
    PdfPageTree pageTree
)
internal void Write(
    PdfPageTree pageTree
)
Friend Sub Write (
    pageTree As PdfPageTree
)
Friend Sub Write (
    pageTree As PdfPageTree
)
internal:
void Write(
    PdfPageTree^ pageTree
)
internal:
void Write(
    PdfPageTree^ pageTree
)
internal member Write :
        pageTree : PdfPageTree -> unit
internal member Write :
        pageTree : PdfPageTree -> unit

Parameters

pageTree
Type: NFX.Media.PDF.DocumentModel PdfPageTree
PDF document page tree
See Also
PdfWriter Class
PdfWriter Members
Write Overload
NFX.Media.PDF Namespace


PdfWriter.Write Method (PdfRoot)

PdfWriter Write Method (PdfRoot) NFX Class Library

Writes PDF header into file stream

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Write(
    PdfRoot root
)
internal void Write(
    PdfRoot root
)
Friend Sub Write (
    root As PdfRoot
)
Friend Sub Write (
    root As PdfRoot
)
internal:
void Write(
    PdfRoot^ root
)
internal:
void Write(
    PdfRoot^ root
)
internal member Write :
        root : PdfRoot -> unit
internal member Write :
        root : PdfRoot -> unit

Parameters

root
Type: NFX.Media.PDF.DocumentModel PdfRoot
PDF document root
See Also
PdfWriter Class
PdfWriter Members
Write Overload
NFX.Media.PDF Namespace


PdfWriter.Write Method (PdfTrailer)

PdfWriter Write Method (PdfTrailer) NFX Class Library

Writes PDF document trailer into file stream

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Write(
    PdfTrailer trailer
)
internal void Write(
    PdfTrailer trailer
)
Friend Sub Write (
    trailer As PdfTrailer
)
Friend Sub Write (
    trailer As PdfTrailer
)
internal:
void Write(
    PdfTrailer^ trailer
)
internal:
void Write(
    PdfTrailer^ trailer
)
internal member Write :
        trailer : PdfTrailer -> unit
internal member Write :
        trailer : PdfTrailer -> unit

Parameters

trailer
Type: NFX.Media.PDF.DocumentModel PdfTrailer
PDF document trailer
See Also
PdfWriter Class
PdfWriter Members
Write Overload
NFX.Media.PDF Namespace


PdfWriter.Write Method (RectangleElement)

PdfWriter Write Method (RectangleElement) NFX Class Library

Writes PDF rectangle element into file stream

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Write(
    RectangleElement rectangle
)
internal void Write(
    RectangleElement rectangle
)
Friend Sub Write (
    rectangle As RectangleElement
)
Friend Sub Write (
    rectangle As RectangleElement
)
internal:
void Write(
    RectangleElement^ rectangle
)
internal:
void Write(
    RectangleElement^ rectangle
)
internal member Write :
        rectangle : RectangleElement -> unit
internal member Write :
        rectangle : RectangleElement -> unit

Parameters

rectangle
Type: NFX.Media.PDF.Elements RectangleElement
PDF rectangle element
See Also
PdfWriter Class
PdfWriter Members
Write Overload
NFX.Media.PDF Namespace


PdfWriter.Write Method (TextElement)

PdfWriter Write Method (TextElement) NFX Class Library

Writes PDF text element into file stream

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void Write(
    TextElement text
)
internal void Write(
    TextElement text
)
Friend Sub Write (
    text As TextElement
)
Friend Sub Write (
    text As TextElement
)
internal:
void Write(
    TextElement^ text
)
internal:
void Write(
    TextElement^ text
)
internal member Write :
        text : TextElement -> unit
internal member Write :
        text : TextElement -> unit

Parameters

text
Type: NFX.Media.PDF.Elements TextElement
PDF text element
See Also
PdfWriter Class
PdfWriter Members
Write Overload
NFX.Media.PDF Namespace


PdfWriter.WriteXObject Method

PdfWriter WriteXObject Method NFX Class Library

Writes PDF image xObject element into file stream

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void WriteXObject(
    ImageElement image
)
internal void WriteXObject(
    ImageElement image
)
Friend Sub WriteXObject (
    image As ImageElement
)
Friend Sub WriteXObject (
    image As ImageElement
)
internal:
void WriteXObject(
    ImageElement^ image
)
internal:
void WriteXObject(
    ImageElement^ image
)
internal member WriteXObject :
        image : ImageElement -> unit
internal member WriteXObject :
        image : ImageElement -> unit

Parameters

image
Type: NFX.Media.PDF.Elements ImageElement
PDF image xObject element
See Also
PdfWriter Class
PdfWriter Members
NFX.Media.PDF Namespace


PdfWriter Properties

PdfWriter Properties NFX Class Library

The PdfWriter type exposes the following members.
Properties
 | Name | Description
Public property | PrettyFormatting | Insert nonnecessary tabs and returns for a pretty output look file
Back to Top
See Also
PdfWriter Class
NFX.Media.PDF Namespace


PdfWriter.PrettyFormatting Property

PdfWriter PrettyFormatting Property NFX Class Library

Insert nonnecessary tabs and returns for a pretty output look file

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool PrettyFormatting { get; set; }
public bool PrettyFormatting { get; set; }
Public Property PrettyFormatting As Boolean
    Get
    Set
Public Property PrettyFormatting As Boolean
    Get
    Set
public:
property bool PrettyFormatting {
    bool get ();
    void set (bool value);
}
public:
property bool PrettyFormatting {
    bool get ();
    void set (bool value);
}
member PrettyFormatting : bool with get, set
member PrettyFormatting : bool with get, set

Property Value

Type: Online Boolean
See Also
PdfWriter Class
PdfWriter Members
NFX.Media.PDF Namespace


ResourceRepository Class

ResourceRepository Class NFX Class Library

Class that generates document-wide unique resource Id-s (the class is not thread-safe)
Inheritance Hierarchy
Online System Object
NFX.Media.PDF ResourceRepository

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class ResourceRepository
internal class ResourceRepository
Friend Class ResourceRepository
Friend Class ResourceRepository
internal ref class ResourceRepository
internal ref class ResourceRepository
type ResourceRepository =  class end
type ResourceRepository =  class end
See Also
ResourceRepository Members
NFX.Media.PDF Namespace


ResourceRepository Members

ResourceRepository Members NFX Class Library

The ResourceRepository type exposes the following members.
Constructors
 | Name | Description
Public method | ResourceRepository | Initializes a new instance of the ResourceRepository class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetObject |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Register |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | CurrentId |
Back to Top
See Also
ResourceRepository Class
NFX.Media.PDF Namespace


ResourceRepository Constructor

ResourceRepository Constructor NFX Class Library

Initializes a new instance of the ResourceRepository class

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResourceRepository()
public ResourceRepository()
Public Sub New
Public Sub New
public:
ResourceRepository()
public:
ResourceRepository()
new : unit -> ResourceRepository
new : unit -> ResourceRepository
See Also
ResourceRepository Class
ResourceRepository Members
NFX.Media.PDF Namespace


ResourceRepository Methods

ResourceRepository Methods NFX Class Library

The ResourceRepository type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetObject |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Register |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ResourceRepository Class
NFX.Media.PDF Namespace


ResourceRepository.GetObject Method

ResourceRepository GetObject Method NFX Class Library

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IPdfResource GetObject(
    int id
)
public IPdfResource GetObject(
    int id
)
Public Function GetObject (
    id As Integer
) As IPdfResource
Public Function GetObject (
    id As Integer
) As IPdfResource
public:
IPdfResource^ GetObject(
    int id
)
public:
IPdfResource^ GetObject(
    int id
)
member GetObject :
        id : int -> IPdfResource
member GetObject :
        id : int -> IPdfResource

Parameters

id
Type: Online System Int32

Return Value

Type: IPdfResource
See Also
ResourceRepository Class
ResourceRepository Members
NFX.Media.PDF Namespace


ResourceRepository.Register Method

ResourceRepository Register Method NFX Class Library

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Register(
    IPdfResource pdfResource
)
public void Register(
    IPdfResource pdfResource
)
Public Sub Register (
    pdfResource As IPdfResource
)
Public Sub Register (
    pdfResource As IPdfResource
)
public:
void Register(
    IPdfResource^ pdfResource
)
public:
void Register(
    IPdfResource^ pdfResource
)
member Register :
        pdfResource : IPdfResource -> unit
member Register :
        pdfResource : IPdfResource -> unit

Parameters

pdfResource
Type: NFX.Media.PDF.DocumentModel IPdfResource
See Also
ResourceRepository Class
ResourceRepository Members
NFX.Media.PDF Namespace


ResourceRepository Properties

ResourceRepository Properties NFX Class Library

The ResourceRepository type exposes the following members.
Properties
 | Name | Description
Public property | CurrentId |
Back to Top
See Also
ResourceRepository Class
NFX.Media.PDF Namespace


ResourceRepository.CurrentId Property

ResourceRepository CurrentId Property NFX Class Library

Namespace: NFX.Media.PDF
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CurrentId { get; }
public int CurrentId { get; }
Public ReadOnly Property CurrentId As Integer
    Get
Public ReadOnly Property CurrentId As Integer
    Get
public:
property int CurrentId {
    int get ();
}
public:
property int CurrentId {
    int get ();
}
member CurrentId : int with get
member CurrentId : int with get

Property Value

Type: Online Int32
See Also
ResourceRepository Class
ResourceRepository Members
NFX.Media.PDF Namespace


NFX.Media.PDF.DocumentModel Namespace

NFX.Media.PDF.DocumentModel Namespace NFX Class Library

Classes
 | Class | Description
Public class | PdfDocument | Model for PDF document
Public class | PdfFont | PDF Font
Protected class | PdfHeader | PDF document header
Public class | PdfInfo | PDF document info
Public class | PdfMeta | PDF document metadata
Public class | PdfObject | PDF document header
Public class | PdfOutlines | PDF document outlines
Public class | PdfPage | PDF Page
Protected class | PdfPageTree | PDF Page Tree document object
Protected class | PdfRoot | PDF document header
Protected class | PdfTrailer | PDF Trailer document object
Interfaces
 | Interface | Description
Protected interface | IPdfObject | Object that can be placed in PDF document
Protected interface | IPdfResource | Object that can be placed in PDF document as a resource
Public interface | IPdfWritable | Represents entities that has string representation in PDF
Protected interface | IPdfXObject | XObject that can be placed in PDF document


IPdfObject Interface

IPdfObject Interface NFX Class Library

Object that can be placed in PDF document

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal interface IPdfObject
internal interface IPdfObject
Friend Interface IPdfObject
Friend Interface IPdfObject
internal interface class IPdfObject
internal interface class IPdfObject
type IPdfObject =  interface end
type IPdfObject =  interface end
See Also
IPdfObject Members
NFX.Media.PDF.DocumentModel Namespace


IPdfObject Members

IPdfObject Members NFX Class Library

The IPdfObject type exposes the following members.
Methods
 | Name | Description
Public method | GetReference | Returns PDF object indirect reference
Back to Top
Properties
 | Name | Description
Public property | ObjectId | Document-wide unique object Id
Back to Top
See Also
IPdfObject Interface
NFX.Media.PDF.DocumentModel Namespace


IPdfObject Methods

IPdfObject Methods NFX Class Library

The IPdfObject type exposes the following members.
Methods
 | Name | Description
Public method | GetReference | Returns PDF object indirect reference
Back to Top
See Also
IPdfObject Interface
NFX.Media.PDF.DocumentModel Namespace


IPdfObject.GetReference Method

IPdfObject GetReference Method NFX Class Library

Returns PDF object indirect reference

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string GetReference()
string GetReference()
Function GetReference As String
Function GetReference As String
String^ GetReference()
String^ GetReference()
abstract GetReference : unit -> string
abstract GetReference : unit -> string

Return Value

Type: Online String
See Also
IPdfObject Interface
IPdfObject Members
NFX.Media.PDF.DocumentModel Namespace


IPdfObject Properties

IPdfObject Properties NFX Class Library

The IPdfObject type exposes the following members.
Properties
 | Name | Description
Public property | ObjectId | Document-wide unique object Id
Back to Top
See Also
IPdfObject Interface
NFX.Media.PDF.DocumentModel Namespace


IPdfObject.ObjectId Property

IPdfObject ObjectId Property NFX Class Library

Document-wide unique object Id

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int ObjectId { get; set; }
int ObjectId { get; set; }
Property ObjectId As Integer
    Get
    Set
Property ObjectId As Integer
    Get
    Set
property int ObjectId {
    int get ();
    void set (int value);
}
property int ObjectId {
    int get ();
    void set (int value);
}
abstract ObjectId : int with get, set
abstract ObjectId : int with get, set

Property Value

Type: Online Int32
See Also
IPdfObject Interface
IPdfObject Members
NFX.Media.PDF.DocumentModel Namespace


IPdfResource Interface

IPdfResource Interface NFX Class Library

Object that can be placed in PDF document as a resource

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal interface IPdfResource
internal interface IPdfResource
Friend Interface IPdfResource
Friend Interface IPdfResource
internal interface class IPdfResource
internal interface class IPdfResource
type IPdfResource =  interface end
type IPdfResource =  interface end
See Also
IPdfResource Members
NFX.Media.PDF.DocumentModel Namespace


IPdfResource Members

IPdfResource Members NFX Class Library

The IPdfResource type exposes the following members.
Methods
 | Name | Description
Public method | GetResourceReference | Returns PDF object indirect reference
Back to Top
Properties
 | Name | Description
Public property | ResourceId | Document-wide unique resource Id
Back to Top
See Also
IPdfResource Interface
NFX.Media.PDF.DocumentModel Namespace


IPdfResource Methods

IPdfResource Methods NFX Class Library

The IPdfResource type exposes the following members.
Methods
 | Name | Description
Public method | GetResourceReference | Returns PDF object indirect reference
Back to Top
See Also
IPdfResource Interface
NFX.Media.PDF.DocumentModel Namespace


IPdfResource.GetResourceReference Method

IPdfResource GetResourceReference Method NFX Class Library

Returns PDF object indirect reference

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string GetResourceReference()
string GetResourceReference()
Function GetResourceReference As String
Function GetResourceReference As String
String^ GetResourceReference()
String^ GetResourceReference()
abstract GetResourceReference : unit -> string
abstract GetResourceReference : unit -> string

Return Value

Type: Online String
See Also
IPdfResource Interface
IPdfResource Members
NFX.Media.PDF.DocumentModel Namespace


IPdfResource Properties

IPdfResource Properties NFX Class Library

The IPdfResource type exposes the following members.
Properties
 | Name | Description
Public property | ResourceId | Document-wide unique resource Id
Back to Top
See Also
IPdfResource Interface
NFX.Media.PDF.DocumentModel Namespace


IPdfResource.ResourceId Property

IPdfResource ResourceId Property NFX Class Library

Document-wide unique resource Id

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int ResourceId { get; set; }
int ResourceId { get; set; }
Property ResourceId As Integer
    Get
    Set
Property ResourceId As Integer
    Get
    Set
property int ResourceId {
    int get ();
    void set (int value);
}
property int ResourceId {
    int get ();
    void set (int value);
}
abstract ResourceId : int with get, set
abstract ResourceId : int with get, set

Property Value

Type: Online Int32
See Also
IPdfResource Interface
IPdfResource Members
NFX.Media.PDF.DocumentModel Namespace


IPdfWritable Interface

IPdfWritable Interface NFX Class Library

Represents entities that has string representation in PDF

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IPdfWritable
public interface IPdfWritable
Public Interface IPdfWritable
Public Interface IPdfWritable
public interface class IPdfWritable
public interface class IPdfWritable
type IPdfWritable =  interface end
type IPdfWritable =  interface end
See Also
IPdfWritable Members
NFX.Media.PDF.DocumentModel Namespace


IPdfWritable Members

IPdfWritable Members NFX Class Library

The IPdfWritable type exposes the following members.
Methods
 | Name | Description
Public method | ToPdfString | Returns PDF string representation
Back to Top
See Also
IPdfWritable Interface
NFX.Media.PDF.DocumentModel Namespace


IPdfWritable Methods

IPdfWritable Methods NFX Class Library

The IPdfWritable type exposes the following members.
Methods
 | Name | Description
Public method | ToPdfString | Returns PDF string representation
Back to Top
See Also
IPdfWritable Interface
NFX.Media.PDF.DocumentModel Namespace


IPdfWritable.ToPdfString Method

IPdfWritable ToPdfString Method NFX Class Library

Returns PDF string representation

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string ToPdfString()
string ToPdfString()
Function ToPdfString As String
Function ToPdfString As String
String^ ToPdfString()
String^ ToPdfString()
abstract ToPdfString : unit -> string
abstract ToPdfString : unit -> string

Return Value

Type: Online String
See Also
IPdfWritable Interface
IPdfWritable Members
NFX.Media.PDF.DocumentModel Namespace


IPdfXObject Interface

IPdfXObject Interface NFX Class Library

XObject that can be placed in PDF document

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal interface IPdfXObject
internal interface IPdfXObject
Friend Interface IPdfXObject
Friend Interface IPdfXObject
internal interface class IPdfXObject
internal interface class IPdfXObject
type IPdfXObject =  interface end
type IPdfXObject =  interface end
See Also
IPdfXObject Members
NFX.Media.PDF.DocumentModel Namespace


IPdfXObject Members

IPdfXObject Members NFX Class Library

The IPdfXObject type exposes the following members.
Methods
 | Name | Description
Public method | GetXReference | Returns PDF x-object indirect reference
Back to Top
Properties
 | Name | Description
Public property | XObjectId | Document-wide unique x-object Id
Back to Top
See Also
IPdfXObject Interface
NFX.Media.PDF.DocumentModel Namespace


IPdfXObject Methods

IPdfXObject Methods NFX Class Library

The IPdfXObject type exposes the following members.
Methods
 | Name | Description
Public method | GetXReference | Returns PDF x-object indirect reference
Back to Top
See Also
IPdfXObject Interface
NFX.Media.PDF.DocumentModel Namespace


IPdfXObject.GetXReference Method

IPdfXObject GetXReference Method NFX Class Library

Returns PDF x-object indirect reference

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string GetXReference()
string GetXReference()
Function GetXReference As String
Function GetXReference As String
String^ GetXReference()
String^ GetXReference()
abstract GetXReference : unit -> string
abstract GetXReference : unit -> string

Return Value

Type: Online String
See Also
IPdfXObject Interface
IPdfXObject Members
NFX.Media.PDF.DocumentModel Namespace


IPdfXObject Properties

IPdfXObject Properties NFX Class Library

The IPdfXObject type exposes the following members.
Properties
 | Name | Description
Public property | XObjectId | Document-wide unique x-object Id
Back to Top
See Also
IPdfXObject Interface
NFX.Media.PDF.DocumentModel Namespace


IPdfXObject.XObjectId Property

IPdfXObject XObjectId Property NFX Class Library

Document-wide unique x-object Id

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int XObjectId { get; set; }
int XObjectId { get; set; }
Property XObjectId As Integer
    Get
    Set
Property XObjectId As Integer
    Get
    Set
property int XObjectId {
    int get ();
    void set (int value);
}
property int XObjectId {
    int get ();
    void set (int value);
}
abstract XObjectId : int with get, set
abstract XObjectId : int with get, set

Property Value

Type: Online Int32
See Also
IPdfXObject Interface
IPdfXObject Members
NFX.Media.PDF.DocumentModel Namespace


PdfDocument Class

PdfDocument Class NFX Class Library

Model for PDF document
Inheritance Hierarchy
Online System Object
NFX.Media.PDF.DocumentModel PdfDocument

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PdfDocument
public class PdfDocument
Public Class PdfDocument
Public Class PdfDocument
public ref class PdfDocument
public ref class PdfDocument
type PdfDocument =  class end
type PdfDocument =  class end
See Also
PdfDocument Members
NFX.Media.PDF.DocumentModel Namespace


PdfDocument Members

PdfDocument Members NFX Class Library

The PdfDocument type exposes the following members.
Constructors
 | Name | Description
Public method | PdfDocument | Initializes a new instance of the PdfDocument class
Back to Top
Methods
 | Name | Description
Public method | AddPage(PdfSize) | Adds new page to document
Public method | AddPage(PdfUnit) | Adds new page to document
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Save | Save document to file
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Fonts | Used fonts
Public property | Info | Document info
Public property | Meta | PDF document meta
Public property | Outlines | Document outlines
Public property | Pages | Document pages
Public property | PageSize | Size for all pages created after it's setting
Protected property | PageTree | Document page tree
Protected property | Root | Document header
Protected property | Trailer | Document trailer
Public property | Unit | User units for all pages created after it's setting (the default user space unit is 1/72 inch)
Back to Top
See Also
PdfDocument Class
NFX.Media.PDF.DocumentModel Namespace


PdfDocument Constructor

PdfDocument Constructor NFX Class Library

Initializes a new instance of the PdfDocument class

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfDocument()
public PdfDocument()
Public Sub New
Public Sub New
public:
PdfDocument()
public:
PdfDocument()
new : unit -> PdfDocument
new : unit -> PdfDocument
See Also
PdfDocument Class
PdfDocument Members
NFX.Media.PDF.DocumentModel Namespace


PdfDocument Methods

PdfDocument Methods NFX Class Library

The PdfDocument type exposes the following members.
Methods
 | Name | Description
Public method | AddPage(PdfSize) | Adds new page to document
Public method | AddPage(PdfUnit) | Adds new page to document
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Save | Save document to file
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PdfDocument Class
NFX.Media.PDF.DocumentModel Namespace


PdfDocument.AddPage Method

PdfDocument AddPage Method NFX Class Library

Overload List
 | Name | Description
Public method | AddPage(PdfSize) | Adds new page to document
Public method | AddPage(PdfUnit) | Adds new page to document
Back to Top
See Also
PdfDocument Class
PdfDocument Members
NFX.Media.PDF.DocumentModel Namespace


PdfDocument.AddPage Method (PdfSize)

PdfDocument AddPage Method (PdfSize) NFX Class Library

Adds new page to document

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfPage AddPage(
    PdfSize size = null
)
public PdfPage AddPage(
    PdfSize size = null
)
Public Function AddPage (
    Optional size As PdfSize = Nothing
) As PdfPage
Public Function AddPage (
    Optional size As PdfSize = Nothing
) As PdfPage
public:
PdfPage^ AddPage(
    PdfSize^ size = nullptr
)
public:
PdfPage^ AddPage(
    PdfSize^ size = nullptr
)
member AddPage :
        ?size : PdfSize
(* Defaults:
        let _size = defaultArg size null
*)
-> PdfPage
member AddPage :
        ?size : PdfSize
(* Defaults:
        let _size = defaultArg size null
*)
-> PdfPage

Parameters

size (Optional)
Type: NFX.Media.PDF.Styling PdfSize

Return Value

Type: PdfPage
Page
See Also
PdfDocument Class
PdfDocument Members
AddPage Overload
NFX.Media.PDF.DocumentModel Namespace


PdfDocument.AddPage Method (PdfUnit)

PdfDocument AddPage Method (PdfUnit) NFX Class Library

Adds new page to document

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfPage AddPage(
    PdfUnit unit
)
public PdfPage AddPage(
    PdfUnit unit
)
Public Function AddPage (
    unit As PdfUnit
) As PdfPage
Public Function AddPage (
    unit As PdfUnit
) As PdfPage
public:
PdfPage^ AddPage(
    PdfUnit^ unit
)
public:
PdfPage^ AddPage(
    PdfUnit^ unit
)
member AddPage :
        unit : PdfUnit -> PdfPage
member AddPage :
        unit : PdfUnit -> PdfPage

Parameters

unit
Type: NFX.Media.PDF.Styling PdfUnit

Return Value

Type: PdfPage
Page
See Also
PdfDocument Class
PdfDocument Members
AddPage Overload
NFX.Media.PDF.DocumentModel Namespace


PdfDocument.Save Method

PdfDocument Save Method NFX Class Library

Save document to file

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Save(
    string filePath
)
public void Save(
    string filePath
)
Public Sub Save (
    filePath As String
)
Public Sub Save (
    filePath As String
)
public:
void Save(
    String^ filePath
)
public:
void Save(
    String^ filePath
)
member Save :
        filePath : string -> unit
member Save :
        filePath : string -> unit

Parameters

filePath
Type: Online System String
File path
See Also
PdfDocument Class
PdfDocument Members
NFX.Media.PDF.DocumentModel Namespace


PdfDocument Properties

PdfDocument Properties NFX Class Library

The PdfDocument type exposes the following members.
Properties
 | Name | Description
Public property | Fonts | Used fonts
Public property | Info | Document info
Public property | Meta | PDF document meta
Public property | Outlines | Document outlines
Public property | Pages | Document pages
Public property | PageSize | Size for all pages created after it's setting
Protected property | PageTree | Document page tree
Protected property | Root | Document header
Protected property | Trailer | Document trailer
Public property | Unit | User units for all pages created after it's setting (the default user space unit is 1/72 inch)
Back to Top
See Also
PdfDocument Class
NFX.Media.PDF.DocumentModel Namespace


PdfDocument.Fonts Property

PdfDocument Fonts Property NFX Class Library

Used fonts

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<PdfFont> Fonts { get; }
public List<PdfFont> Fonts { get; }
Public ReadOnly Property Fonts As List(Of PdfFont)
    Get
Public ReadOnly Property Fonts As List(Of PdfFont)
    Get
public:
property List<PdfFont^>^ Fonts {
    List<PdfFont^>^ get ();
}
public:
property List<PdfFont^>^ Fonts {
    List<PdfFont^>^ get ();
}
member Fonts : List<PdfFont> with get
member Fonts : List<PdfFont> with get

Property Value

Type: Online List PdfFont
See Also
PdfDocument Class
PdfDocument Members
NFX.Media.PDF.DocumentModel Namespace


PdfDocument.Info Property

PdfDocument Info Property NFX Class Library

Document info

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfInfo Info { get; }
public PdfInfo Info { get; }
Public ReadOnly Property Info As PdfInfo
    Get
Public ReadOnly Property Info As PdfInfo
    Get
public:
property PdfInfo^ Info {
    PdfInfo^ get ();
}
public:
property PdfInfo^ Info {
    PdfInfo^ get ();
}
member Info : PdfInfo with get
member Info : PdfInfo with get

Property Value

Type: PdfInfo
See Also
PdfDocument Class
PdfDocument Members
NFX.Media.PDF.DocumentModel Namespace


PdfDocument.Meta Property

PdfDocument Meta Property NFX Class Library

PDF document meta

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfMeta Meta { get; }
public PdfMeta Meta { get; }
Public ReadOnly Property Meta As PdfMeta
    Get
Public ReadOnly Property Meta As PdfMeta
    Get
public:
property PdfMeta^ Meta {
    PdfMeta^ get ();
}
public:
property PdfMeta^ Meta {
    PdfMeta^ get ();
}
member Meta : PdfMeta with get
member Meta : PdfMeta with get

Property Value

Type: PdfMeta
See Also
PdfDocument Class
PdfDocument Members
NFX.Media.PDF.DocumentModel Namespace


PdfDocument.Outlines Property

PdfDocument Outlines Property NFX Class Library

Document outlines

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfOutlines Outlines { get; }
public PdfOutlines Outlines { get; }
Public ReadOnly Property Outlines As PdfOutlines
    Get
Public ReadOnly Property Outlines As PdfOutlines
    Get
public:
property PdfOutlines^ Outlines {
    PdfOutlines^ get ();
}
public:
property PdfOutlines^ Outlines {
    PdfOutlines^ get ();
}
member Outlines : PdfOutlines with get
member Outlines : PdfOutlines with get

Property Value

Type: PdfOutlines
See Also
PdfDocument Class
PdfDocument Members
NFX.Media.PDF.DocumentModel Namespace


PdfDocument.Pages Property

PdfDocument Pages Property NFX Class Library

Document pages

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<PdfPage> Pages { get; }
public List<PdfPage> Pages { get; }
Public ReadOnly Property Pages As List(Of PdfPage)
    Get
Public ReadOnly Property Pages As List(Of PdfPage)
    Get
public:
property List<PdfPage^>^ Pages {
    List<PdfPage^>^ get ();
}
public:
property List<PdfPage^>^ Pages {
    List<PdfPage^>^ get ();
}
member Pages : List<PdfPage> with get
member Pages : List<PdfPage> with get

Property Value

Type: Online List PdfPage
See Also
PdfDocument Class
PdfDocument Members
NFX.Media.PDF.DocumentModel Namespace


PdfDocument.PageSize Property

PdfDocument PageSize Property NFX Class Library

Size for all pages created after it's setting

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfSize PageSize { get; set; }
public PdfSize PageSize { get; set; }
Public Property PageSize As PdfSize
    Get
    Set
Public Property PageSize As PdfSize
    Get
    Set
public:
property PdfSize^ PageSize {
    PdfSize^ get ();
    void set (PdfSize^ value);
}
public:
property PdfSize^ PageSize {
    PdfSize^ get ();
    void set (PdfSize^ value);
}
member PageSize : PdfSize with get, set
member PageSize : PdfSize with get, set

Property Value

Type: PdfSize
See Also
PdfDocument Class
PdfDocument Members
NFX.Media.PDF.DocumentModel Namespace


PdfDocument.PageTree Property

PdfDocument PageTree Property NFX Class Library

Document page tree

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal PdfPageTree PageTree { get; }
internal PdfPageTree PageTree { get; }
Friend ReadOnly Property PageTree As PdfPageTree
    Get
Friend ReadOnly Property PageTree As PdfPageTree
    Get
internal:
property PdfPageTree^ PageTree {
    PdfPageTree^ get ();
}
internal:
property PdfPageTree^ PageTree {
    PdfPageTree^ get ();
}
internal member PageTree : PdfPageTree with get
internal member PageTree : PdfPageTree with get

Property Value

Type: PdfPageTree
See Also
PdfDocument Class
PdfDocument Members
NFX.Media.PDF.DocumentModel Namespace


PdfDocument.Root Property

PdfDocument Root Property NFX Class Library

Document header

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal PdfRoot Root { get; }
internal PdfRoot Root { get; }
Friend ReadOnly Property Root As PdfRoot
    Get
Friend ReadOnly Property Root As PdfRoot
    Get
internal:
property PdfRoot^ Root {
    PdfRoot^ get ();
}
internal:
property PdfRoot^ Root {
    PdfRoot^ get ();
}
internal member Root : PdfRoot with get
internal member Root : PdfRoot with get

Property Value

Type: PdfRoot
See Also
PdfDocument Class
PdfDocument Members
NFX.Media.PDF.DocumentModel Namespace


PdfDocument.Trailer Property

PdfDocument Trailer Property NFX Class Library

Document trailer

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal PdfTrailer Trailer { get; }
internal PdfTrailer Trailer { get; }
Friend ReadOnly Property Trailer As PdfTrailer
    Get
Friend ReadOnly Property Trailer As PdfTrailer
    Get
internal:
property PdfTrailer^ Trailer {
    PdfTrailer^ get ();
}
internal:
property PdfTrailer^ Trailer {
    PdfTrailer^ get ();
}
internal member Trailer : PdfTrailer with get
internal member Trailer : PdfTrailer with get

Property Value

Type: PdfTrailer
See Also
PdfDocument Class
PdfDocument Members
NFX.Media.PDF.DocumentModel Namespace


PdfDocument.Unit Property

PdfDocument Unit Property NFX Class Library

User units for all pages created after it's setting (the default user space unit is 1/72 inch)

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfUnit Unit { get; }
public PdfUnit Unit { get; }
Public ReadOnly Property Unit As PdfUnit
    Get
Public ReadOnly Property Unit As PdfUnit
    Get
public:
property PdfUnit^ Unit {
    PdfUnit^ get ();
}
public:
property PdfUnit^ Unit {
    PdfUnit^ get ();
}
member Unit : PdfUnit with get
member Unit : PdfUnit with get

Property Value

Type: PdfUnit
See Also
PdfDocument Class
PdfDocument Members
NFX.Media.PDF.DocumentModel Namespace


PdfFont Class

PdfFont Class NFX Class Library

PDF Font
Inheritance Hierarchy
Online System Object
NFX.Media.PDF.DocumentModel PdfObject
NFX.Media.PDF.DocumentModel PdfFont

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class PdfFont : PdfObject,
    IPdfResource, INamed
public sealed class PdfFont : PdfObject,
    IPdfResource, INamed
Public NotInheritable Class PdfFont
    Inherits PdfObject
    Implements IPdfResource, INamed
Public NotInheritable Class PdfFont
    Inherits PdfObject
    Implements IPdfResource, INamed
public ref class PdfFont sealed : public PdfObject,
    IPdfResource, INamed
public ref class PdfFont sealed : public PdfObject,
    IPdfResource, INamed
[<SealedAttribute>]
type PdfFont =
    class
        inherit PdfObject
        interface IPdfResource
        interface INamed
    end
[<SealedAttribute>]
type PdfFont =
    class
        inherit PdfObject
        interface IPdfResource
        interface INamed
    end
See Also
PdfFont Members
NFX.Media.PDF.DocumentModel Namespace


PdfFont Members

PdfFont Members NFX Class Library

The PdfFont type exposes the following members.
Methods
 | Name | Description
 | ByName | Returns existing font by name or creates and registers a new one
Public method | Equals(Object) | (Overrides Online Object Equals(Object).)
Public method | Equals(PdfFont) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | GetReference | Returns PDF object indirect reference (Inherited from PdfObject.)
Public method | GetResourceReference | Returns PDF object indirect reference
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
 | Courier |
 | CourierBold |
 | CourierBoldOblique |
 | CourierOblique |
 | Helvetica |
 | HelveticaBold |
 | HelveticaBoldOblique |
 | HelveticaOblique |
Public property | Name | Font name
Public property | ObjectId | Document-wide unique object Id (Inherited from PdfObject.)
Public property | ResourceId | Document-wide unique resource Id
 | Times |
 | TimesBold |
 | TimesBoldItalic |
 | TimesItalic |
Back to Top
See Also
PdfFont Class
NFX.Media.PDF.DocumentModel Namespace


PdfFont Methods

PdfFont Methods NFX Class Library

The PdfFont type exposes the following members.
Methods
 | Name | Description
 | ByName | Returns existing font by name or creates and registers a new one
Public method | Equals(Object) | (Overrides Online Object Equals(Object).)
Public method | Equals(PdfFont) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | GetReference | Returns PDF object indirect reference (Inherited from PdfObject.)
Public method | GetResourceReference | Returns PDF object indirect reference
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PdfFont Class
NFX.Media.PDF.DocumentModel Namespace


PdfFont.ByName Method

PdfFont ByName Method NFX Class Library

Returns existing font by name or creates and registers a new one

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfFont ByName(
    string name
)
public static PdfFont ByName(
    string name
)
Public Shared Function ByName (
    name As String
) As PdfFont
Public Shared Function ByName (
    name As String
) As PdfFont
public:
static PdfFont^ ByName(
    String^ name
)
public:
static PdfFont^ ByName(
    String^ name
)
static member ByName :
        name : string -> PdfFont
static member ByName :
        name : string -> PdfFont

Parameters

name
Type: Online System String

Return Value

Type: PdfFont
See Also
PdfFont Class
PdfFont Members
NFX.Media.PDF.DocumentModel Namespace


PdfFont.Equals Method

PdfFont Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides Online Object Equals(Object).)
Public method | Equals(PdfFont) |
Back to Top
See Also
PdfFont Class
PdfFont Members
NFX.Media.PDF.DocumentModel Namespace


PdfFont.Equals Method (Object)

PdfFont Equals Method (Object) NFX Class Library

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
PdfFont Class
PdfFont Members
Equals Overload
NFX.Media.PDF.DocumentModel Namespace


PdfFont.Equals Method (PdfFont)

PdfFont Equals Method (PdfFont) NFX Class Library

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    PdfFont other
)
public bool Equals(
    PdfFont other
)
Public Function Equals (
    other As PdfFont
) As Boolean
Public Function Equals (
    other As PdfFont
) As Boolean
public:
bool Equals(
    PdfFont^ other
)
public:
bool Equals(
    PdfFont^ other
)
member Equals :
        other : PdfFont -> bool
member Equals :
        other : PdfFont -> bool

Parameters

other
Type: NFX.Media.PDF.DocumentModel PdfFont

Return Value

Type: Online Boolean
See Also
PdfFont Class
PdfFont Members
Equals Overload
NFX.Media.PDF.DocumentModel Namespace


PdfFont.GetHashCode Method

PdfFont GetHashCode Method NFX Class Library

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
PdfFont Class
PdfFont Members
NFX.Media.PDF.DocumentModel Namespace


PdfFont.GetResourceReference Method

PdfFont GetResourceReference Method NFX Class Library

Returns PDF object indirect reference

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetResourceReference()
public string GetResourceReference()
Public Function GetResourceReference As String
Public Function GetResourceReference As String
public:
virtual String^ GetResourceReference() sealed
public:
virtual String^ GetResourceReference() sealed
abstract GetResourceReference : unit -> string
override GetResourceReference : unit -> string
abstract GetResourceReference : unit -> string
override GetResourceReference : unit -> string

Return Value

Type: Online String

Implements

IPdfResource GetResourceReference
See Also
PdfFont Class
PdfFont Members
NFX.Media.PDF.DocumentModel Namespace


PdfFont.ToString Method

PdfFont ToString Method NFX Class Library

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
PdfFont Class
PdfFont Members
NFX.Media.PDF.DocumentModel Namespace


PdfFont Properties

PdfFont Properties NFX Class Library

The PdfFont type exposes the following members.
Properties
 | Name | Description
 | Courier |
 | CourierBold |
 | CourierBoldOblique |
 | CourierOblique |
 | Helvetica |
 | HelveticaBold |
 | HelveticaBoldOblique |
 | HelveticaOblique |
Public property | Name | Font name
Public property | ObjectId | Document-wide unique object Id (Inherited from PdfObject.)
Public property | ResourceId | Document-wide unique resource Id
 | Times |
 | TimesBold |
 | TimesBoldItalic |
 | TimesItalic |
Back to Top
See Also
PdfFont Class
NFX.Media.PDF.DocumentModel Namespace


PdfFont.Courier Property

PdfFont Courier Property NFX Class Library

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfFont Courier { get; }
public static PdfFont Courier { get; }
Public Shared ReadOnly Property Courier As PdfFont
    Get
Public Shared ReadOnly Property Courier As PdfFont
    Get
public:
static property PdfFont^ Courier {
    PdfFont^ get ();
}
public:
static property PdfFont^ Courier {
    PdfFont^ get ();
}
static member Courier : PdfFont with get
static member Courier : PdfFont with get

Property Value

Type: PdfFont
See Also
PdfFont Class
PdfFont Members
NFX.Media.PDF.DocumentModel Namespace


PdfFont.CourierBold Property

PdfFont CourierBold Property NFX Class Library

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfFont CourierBold { get; }
public static PdfFont CourierBold { get; }
Public Shared ReadOnly Property CourierBold As PdfFont
    Get
Public Shared ReadOnly Property CourierBold As PdfFont
    Get
public:
static property PdfFont^ CourierBold {
    PdfFont^ get ();
}
public:
static property PdfFont^ CourierBold {
    PdfFont^ get ();
}
static member CourierBold : PdfFont with get
static member CourierBold : PdfFont with get

Property Value

Type: PdfFont
See Also
PdfFont Class
PdfFont Members
NFX.Media.PDF.DocumentModel Namespace


PdfFont.CourierBoldOblique Property

PdfFont CourierBoldOblique Property NFX Class Library

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfFont CourierBoldOblique { get; }
public static PdfFont CourierBoldOblique { get; }
Public Shared ReadOnly Property CourierBoldOblique As PdfFont
    Get
Public Shared ReadOnly Property CourierBoldOblique As PdfFont
    Get
public:
static property PdfFont^ CourierBoldOblique {
    PdfFont^ get ();
}
public:
static property PdfFont^ CourierBoldOblique {
    PdfFont^ get ();
}
static member CourierBoldOblique : PdfFont with get
static member CourierBoldOblique : PdfFont with get

Property Value

Type: PdfFont
See Also
PdfFont Class
PdfFont Members
NFX.Media.PDF.DocumentModel Namespace


PdfFont.CourierOblique Property

PdfFont CourierOblique Property NFX Class Library

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfFont CourierOblique { get; }
public static PdfFont CourierOblique { get; }
Public Shared ReadOnly Property CourierOblique As PdfFont
    Get
Public Shared ReadOnly Property CourierOblique As PdfFont
    Get
public:
static property PdfFont^ CourierOblique {
    PdfFont^ get ();
}
public:
static property PdfFont^ CourierOblique {
    PdfFont^ get ();
}
static member CourierOblique : PdfFont with get
static member CourierOblique : PdfFont with get

Property Value

Type: PdfFont
See Also
PdfFont Class
PdfFont Members
NFX.Media.PDF.DocumentModel Namespace


PdfFont.Helvetica Property

PdfFont Helvetica Property NFX Class Library

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfFont Helvetica { get; }
public static PdfFont Helvetica { get; }
Public Shared ReadOnly Property Helvetica As PdfFont
    Get
Public Shared ReadOnly Property Helvetica As PdfFont
    Get
public:
static property PdfFont^ Helvetica {
    PdfFont^ get ();
}
public:
static property PdfFont^ Helvetica {
    PdfFont^ get ();
}
static member Helvetica : PdfFont with get
static member Helvetica : PdfFont with get

Property Value

Type: PdfFont
See Also
PdfFont Class
PdfFont Members
NFX.Media.PDF.DocumentModel Namespace


PdfFont.HelveticaBold Property

PdfFont HelveticaBold Property NFX Class Library

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfFont HelveticaBold { get; }
public static PdfFont HelveticaBold { get; }
Public Shared ReadOnly Property HelveticaBold As PdfFont
    Get
Public Shared ReadOnly Property HelveticaBold As PdfFont
    Get
public:
static property PdfFont^ HelveticaBold {
    PdfFont^ get ();
}
public:
static property PdfFont^ HelveticaBold {
    PdfFont^ get ();
}
static member HelveticaBold : PdfFont with get
static member HelveticaBold : PdfFont with get

Property Value

Type: PdfFont
See Also
PdfFont Class
PdfFont Members
NFX.Media.PDF.DocumentModel Namespace


PdfFont.HelveticaBoldOblique Property

PdfFont HelveticaBoldOblique Property NFX Class Library

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfFont HelveticaBoldOblique { get; }
public static PdfFont HelveticaBoldOblique { get; }
Public Shared ReadOnly Property HelveticaBoldOblique As PdfFont
    Get
Public Shared ReadOnly Property HelveticaBoldOblique As PdfFont
    Get
public:
static property PdfFont^ HelveticaBoldOblique {
    PdfFont^ get ();
}
public:
static property PdfFont^ HelveticaBoldOblique {
    PdfFont^ get ();
}
static member HelveticaBoldOblique : PdfFont with get
static member HelveticaBoldOblique : PdfFont with get

Property Value

Type: PdfFont
See Also
PdfFont Class
PdfFont Members
NFX.Media.PDF.DocumentModel Namespace


PdfFont.HelveticaOblique Property

PdfFont HelveticaOblique Property NFX Class Library

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfFont HelveticaOblique { get; }
public static PdfFont HelveticaOblique { get; }
Public Shared ReadOnly Property HelveticaOblique As PdfFont
    Get
Public Shared ReadOnly Property HelveticaOblique As PdfFont
    Get
public:
static property PdfFont^ HelveticaOblique {
    PdfFont^ get ();
}
public:
static property PdfFont^ HelveticaOblique {
    PdfFont^ get ();
}
static member HelveticaOblique : PdfFont with get
static member HelveticaOblique : PdfFont with get

Property Value

Type: PdfFont
See Also
PdfFont Class
PdfFont Members
NFX.Media.PDF.DocumentModel Namespace


PdfFont.Name Property

PdfFont Name Property NFX Class Library

Font name

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
PdfFont Class
PdfFont Members
NFX.Media.PDF.DocumentModel Namespace


PdfFont.ResourceId Property

PdfFont ResourceId Property NFX Class Library

Document-wide unique resource Id

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ResourceId { get; set; }
public int ResourceId { get; set; }
Public Property ResourceId As Integer
    Get
    Set
Public Property ResourceId As Integer
    Get
    Set
public:
virtual property int ResourceId {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int ResourceId {
    int get () sealed;
    void set (int value) sealed;
}
abstract ResourceId : int with get, set
override ResourceId : int with get, set
abstract ResourceId : int with get, set
override ResourceId : int with get, set

Property Value

Type: Online Int32

Implements

IPdfResource ResourceId
See Also
PdfFont Class
PdfFont Members
NFX.Media.PDF.DocumentModel Namespace


PdfFont.Times Property

PdfFont Times Property NFX Class Library

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfFont Times { get; }
public static PdfFont Times { get; }
Public Shared ReadOnly Property Times As PdfFont
    Get
Public Shared ReadOnly Property Times As PdfFont
    Get
public:
static property PdfFont^ Times {
    PdfFont^ get ();
}
public:
static property PdfFont^ Times {
    PdfFont^ get ();
}
static member Times : PdfFont with get
static member Times : PdfFont with get

Property Value

Type: PdfFont
See Also
PdfFont Class
PdfFont Members
NFX.Media.PDF.DocumentModel Namespace


PdfFont.TimesBold Property

PdfFont TimesBold Property NFX Class Library

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfFont TimesBold { get; }
public static PdfFont TimesBold { get; }
Public Shared ReadOnly Property TimesBold As PdfFont
    Get
Public Shared ReadOnly Property TimesBold As PdfFont
    Get
public:
static property PdfFont^ TimesBold {
    PdfFont^ get ();
}
public:
static property PdfFont^ TimesBold {
    PdfFont^ get ();
}
static member TimesBold : PdfFont with get
static member TimesBold : PdfFont with get

Property Value

Type: PdfFont
See Also
PdfFont Class
PdfFont Members
NFX.Media.PDF.DocumentModel Namespace


PdfFont.TimesBoldItalic Property

PdfFont TimesBoldItalic Property NFX Class Library

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfFont TimesBoldItalic { get; }
public static PdfFont TimesBoldItalic { get; }
Public Shared ReadOnly Property TimesBoldItalic As PdfFont
    Get
Public Shared ReadOnly Property TimesBoldItalic As PdfFont
    Get
public:
static property PdfFont^ TimesBoldItalic {
    PdfFont^ get ();
}
public:
static property PdfFont^ TimesBoldItalic {
    PdfFont^ get ();
}
static member TimesBoldItalic : PdfFont with get
static member TimesBoldItalic : PdfFont with get

Property Value

Type: PdfFont
See Also
PdfFont Class
PdfFont Members
NFX.Media.PDF.DocumentModel Namespace


PdfFont.TimesItalic Property

PdfFont TimesItalic Property NFX Class Library

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfFont TimesItalic { get; }
public static PdfFont TimesItalic { get; }
Public Shared ReadOnly Property TimesItalic As PdfFont
    Get
Public Shared ReadOnly Property TimesItalic As PdfFont
    Get
public:
static property PdfFont^ TimesItalic {
    PdfFont^ get ();
}
public:
static property PdfFont^ TimesItalic {
    PdfFont^ get ();
}
static member TimesItalic : PdfFont with get
static member TimesItalic : PdfFont with get

Property Value

Type: PdfFont
See Also
PdfFont Class
PdfFont Members
NFX.Media.PDF.DocumentModel Namespace


PdfHeader Class

PdfHeader Class NFX Class Library

PDF document header
Inheritance Hierarchy
Online System Object
NFX.Media.PDF.DocumentModel PdfObject
NFX.Media.PDF.DocumentModel PdfHeader

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class PdfHeader : PdfObject
internal class PdfHeader : PdfObject
Friend Class PdfHeader
    Inherits PdfObject
Friend Class PdfHeader
    Inherits PdfObject
internal ref class PdfHeader : public PdfObject
internal ref class PdfHeader : public PdfObject
type PdfHeader =
    class
        inherit PdfObject
    end
type PdfHeader =
    class
        inherit PdfObject
    end
See Also
PdfHeader Members
NFX.Media.PDF.DocumentModel Namespace


PdfHeader Members

PdfHeader Members NFX Class Library

The PdfHeader type exposes the following members.
Constructors
 | Name | Description
Public method | PdfHeader | Initializes a new instance of the PdfHeader class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReference | Returns PDF object indirect reference (Inherited from PdfObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | InfoId | Document info's object Id
Public property | ObjectId | Document-wide unique object Id (Inherited from PdfObject.)
Public property | OutlinesId | Document outlines' object Id
Public property | PageTreeId | Document page tree's object Id
Back to Top
See Also
PdfHeader Class
NFX.Media.PDF.DocumentModel Namespace


PdfHeader Constructor

PdfHeader Constructor NFX Class Library

Initializes a new instance of the PdfHeader class

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfHeader()
public PdfHeader()
Public Sub New
Public Sub New
public:
PdfHeader()
public:
PdfHeader()
new : unit -> PdfHeader
new : unit -> PdfHeader
See Also
PdfHeader Class
PdfHeader Members
NFX.Media.PDF.DocumentModel Namespace


PdfHeader Methods

PdfHeader Methods NFX Class Library

The PdfHeader type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReference | Returns PDF object indirect reference (Inherited from PdfObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PdfHeader Class
NFX.Media.PDF.DocumentModel Namespace


PdfHeader Properties

PdfHeader Properties NFX Class Library

The PdfHeader type exposes the following members.
Properties
 | Name | Description
Public property | InfoId | Document info's object Id
Public property | ObjectId | Document-wide unique object Id (Inherited from PdfObject.)
Public property | OutlinesId | Document outlines' object Id
Public property | PageTreeId | Document page tree's object Id
Back to Top
See Also
PdfHeader Class
NFX.Media.PDF.DocumentModel Namespace


PdfHeader.InfoId Property

PdfHeader InfoId Property NFX Class Library

Document info's object Id

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int InfoId { get; set; }
public int InfoId { get; set; }
Public Property InfoId As Integer
    Get
    Set
Public Property InfoId As Integer
    Get
    Set
public:
property int InfoId {
    int get ();
    void set (int value);
}
public:
property int InfoId {
    int get ();
    void set (int value);
}
member InfoId : int with get, set
member InfoId : int with get, set

Property Value

Type: Online Int32
See Also
PdfHeader Class
PdfHeader Members
NFX.Media.PDF.DocumentModel Namespace


PdfHeader.OutlinesId Property

PdfHeader OutlinesId Property NFX Class Library

Document outlines' object Id

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int OutlinesId { get; set; }
public int OutlinesId { get; set; }
Public Property OutlinesId As Integer
    Get
    Set
Public Property OutlinesId As Integer
    Get
    Set
public:
property int OutlinesId {
    int get ();
    void set (int value);
}
public:
property int OutlinesId {
    int get ();
    void set (int value);
}
member OutlinesId : int with get, set
member OutlinesId : int with get, set

Property Value

Type: Online Int32
See Also
PdfHeader Class
PdfHeader Members
NFX.Media.PDF.DocumentModel Namespace


PdfHeader.PageTreeId Property

PdfHeader PageTreeId Property NFX Class Library

Document page tree's object Id

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int PageTreeId { get; set; }
public int PageTreeId { get; set; }
Public Property PageTreeId As Integer
    Get
    Set
Public Property PageTreeId As Integer
    Get
    Set
public:
property int PageTreeId {
    int get ();
    void set (int value);
}
public:
property int PageTreeId {
    int get ();
    void set (int value);
}
member PageTreeId : int with get, set
member PageTreeId : int with get, set

Property Value

Type: Online Int32
See Also
PdfHeader Class
PdfHeader Members
NFX.Media.PDF.DocumentModel Namespace


PdfInfo Class

PdfInfo Class NFX Class Library

PDF document info
Inheritance Hierarchy
Online System Object
NFX.Media.PDF.DocumentModel PdfObject
NFX.Media.PDF.DocumentModel PdfInfo

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PdfInfo : PdfObject
public class PdfInfo : PdfObject
Public Class PdfInfo
    Inherits PdfObject
Public Class PdfInfo
    Inherits PdfObject
public ref class PdfInfo : public PdfObject
public ref class PdfInfo : public PdfObject
type PdfInfo =
    class
        inherit PdfObject
    end
type PdfInfo =
    class
        inherit PdfObject
    end
See Also
PdfInfo Members
NFX.Media.PDF.DocumentModel Namespace


PdfInfo Members

PdfInfo Members NFX Class Library

The PdfInfo type exposes the following members.
Constructors
 | Name | Description
Public method | PdfInfo | Initializes a new instance of the PdfInfo class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReference | Returns PDF object indirect reference (Inherited from PdfObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Author | Document's author
Public property | CreationDate | Document's creation date
Public property | Creator | Document's creator program
Public property | Keywords | Document's keywords
Public property | ModificationDate | Document's modification date
Public property | ObjectId | Document-wide unique object Id (Inherited from PdfObject.)
Public property | Producer | Document's producer (if it started as another program)
Public property | Subject | Document's subject
Public property | Title | Document's title
Back to Top
See Also
PdfInfo Class
NFX.Media.PDF.DocumentModel Namespace


PdfInfo Constructor

PdfInfo Constructor NFX Class Library

Initializes a new instance of the PdfInfo class

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfInfo()
public PdfInfo()
Public Sub New
Public Sub New
public:
PdfInfo()
public:
PdfInfo()
new : unit -> PdfInfo
new : unit -> PdfInfo
See Also
PdfInfo Class
PdfInfo Members
NFX.Media.PDF.DocumentModel Namespace


PdfInfo Methods

PdfInfo Methods NFX Class Library

The PdfInfo type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReference | Returns PDF object indirect reference (Inherited from PdfObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PdfInfo Class
NFX.Media.PDF.DocumentModel Namespace


PdfInfo Properties

PdfInfo Properties NFX Class Library

The PdfInfo type exposes the following members.
Properties
 | Name | Description
Public property | Author | Document's author
Public property | CreationDate | Document's creation date
Public property | Creator | Document's creator program
Public property | Keywords | Document's keywords
Public property | ModificationDate | Document's modification date
Public property | ObjectId | Document-wide unique object Id (Inherited from PdfObject.)
Public property | Producer | Document's producer (if it started as another program)
Public property | Subject | Document's subject
Public property | Title | Document's title
Back to Top
See Also
PdfInfo Class
NFX.Media.PDF.DocumentModel Namespace


PdfInfo.Author Property

PdfInfo Author Property NFX Class Library

Document's author

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Author { get; set; }
public string Author { get; set; }
Public Property Author As String
    Get
    Set
Public Property Author As String
    Get
    Set
public:
property String^ Author {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Author {
    String^ get ();
    void set (String^ value);
}
member Author : string with get, set
member Author : string with get, set

Property Value

Type: Online String
See Also
PdfInfo Class
PdfInfo Members
NFX.Media.PDF.DocumentModel Namespace


PdfInfo.CreationDate Property

PdfInfo CreationDate Property NFX Class Library

Document's creation date

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime CreationDate { get; set; }
public DateTime CreationDate { get; set; }
Public Property CreationDate As DateTime
    Get
    Set
Public Property CreationDate As DateTime
    Get
    Set
public:
property DateTime CreationDate {
    DateTime get ();
    void set (DateTime value);
}
public:
property DateTime CreationDate {
    DateTime get ();
    void set (DateTime value);
}
member CreationDate : DateTime with get, set
member CreationDate : DateTime with get, set

Property Value

Type: Online DateTime
See Also
PdfInfo Class
PdfInfo Members
NFX.Media.PDF.DocumentModel Namespace


PdfInfo.Creator Property

PdfInfo Creator Property NFX Class Library

Document's creator program

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Creator { get; set; }
public string Creator { get; set; }
Public Property Creator As String
    Get
    Set
Public Property Creator As String
    Get
    Set
public:
property String^ Creator {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Creator {
    String^ get ();
    void set (String^ value);
}
member Creator : string with get, set
member Creator : string with get, set

Property Value

Type: Online String
See Also
PdfInfo Class
PdfInfo Members
NFX.Media.PDF.DocumentModel Namespace


PdfInfo.Keywords Property

PdfInfo Keywords Property NFX Class Library

Document's keywords

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Keywords { get; set; }
public string Keywords { get; set; }
Public Property Keywords As String
    Get
    Set
Public Property Keywords As String
    Get
    Set
public:
property String^ Keywords {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Keywords {
    String^ get ();
    void set (String^ value);
}
member Keywords : string with get, set
member Keywords : string with get, set

Property Value

Type: Online String
See Also
PdfInfo Class
PdfInfo Members
NFX.Media.PDF.DocumentModel Namespace


PdfInfo.ModificationDate Property

PdfInfo ModificationDate Property NFX Class Library

Document's modification date

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime ModificationDate { get; set; }
public DateTime ModificationDate { get; set; }
Public Property ModificationDate As DateTime
    Get
    Set
Public Property ModificationDate As DateTime
    Get
    Set
public:
property DateTime ModificationDate {
    DateTime get ();
    void set (DateTime value);
}
public:
property DateTime ModificationDate {
    DateTime get ();
    void set (DateTime value);
}
member ModificationDate : DateTime with get, set
member ModificationDate : DateTime with get, set

Property Value

Type: Online DateTime
See Also
PdfInfo Class
PdfInfo Members
NFX.Media.PDF.DocumentModel Namespace


PdfInfo.Producer Property

PdfInfo Producer Property NFX Class Library

Document's producer (if it started as another program)

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Producer { get; set; }
public string Producer { get; set; }
Public Property Producer As String
    Get
    Set
Public Property Producer As String
    Get
    Set
public:
property String^ Producer {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Producer {
    String^ get ();
    void set (String^ value);
}
member Producer : string with get, set
member Producer : string with get, set

Property Value

Type: Online String
See Also
PdfInfo Class
PdfInfo Members
NFX.Media.PDF.DocumentModel Namespace


PdfInfo.Subject Property

PdfInfo Subject Property NFX Class Library

Document's subject

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Subject { get; set; }
public string Subject { get; set; }
Public Property Subject As String
    Get
    Set
Public Property Subject As String
    Get
    Set
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}
member Subject : string with get, set
member Subject : string with get, set

Property Value

Type: Online String
See Also
PdfInfo Class
PdfInfo Members
NFX.Media.PDF.DocumentModel Namespace


PdfInfo.Title Property

PdfInfo Title Property NFX Class Library

Document's title

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Title { get; set; }
public string Title { get; set; }
Public Property Title As String
    Get
    Set
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set
member Title : string with get, set

Property Value

Type: Online String
See Also
PdfInfo Class
PdfInfo Members
NFX.Media.PDF.DocumentModel Namespace


PdfMeta Class

PdfMeta Class NFX Class Library

PDF document metadata
Inheritance Hierarchy
Online System Object
NFX.Media.PDF.DocumentModel PdfMeta

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PdfMeta
public class PdfMeta
Public Class PdfMeta
Public Class PdfMeta
public ref class PdfMeta
public ref class PdfMeta
type PdfMeta =  class end
type PdfMeta =  class end
See Also
PdfMeta Members
NFX.Media.PDF.DocumentModel Namespace


PdfMeta Members

PdfMeta Members NFX Class Library

The PdfMeta type exposes the following members.
Constructors
 | Name | Description
Public method | PdfMeta | Initializes a new instance of the PdfMeta class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Version | PDF document version
Back to Top
See Also
PdfMeta Class
NFX.Media.PDF.DocumentModel Namespace


PdfMeta Constructor

PdfMeta Constructor NFX Class Library

Initializes a new instance of the PdfMeta class

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfMeta()
public PdfMeta()
Public Sub New
Public Sub New
public:
PdfMeta()
public:
PdfMeta()
new : unit -> PdfMeta
new : unit -> PdfMeta
See Also
PdfMeta Class
PdfMeta Members
NFX.Media.PDF.DocumentModel Namespace


PdfMeta Methods

PdfMeta Methods NFX Class Library

The PdfMeta type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PdfMeta Class
NFX.Media.PDF.DocumentModel Namespace


PdfMeta Properties

PdfMeta Properties NFX Class Library

The PdfMeta type exposes the following members.
Properties
 | Name | Description
Public property | Version | PDF document version
Back to Top
See Also
PdfMeta Class
NFX.Media.PDF.DocumentModel Namespace


PdfMeta.Version Property

PdfMeta Version Property NFX Class Library

PDF document version

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Version { get; set; }
public string Version { get; set; }
Public Property Version As String
    Get
    Set
Public Property Version As String
    Get
    Set
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}
member Version : string with get, set
member Version : string with get, set

Property Value

Type: Online String
See Also
PdfMeta Class
PdfMeta Members
NFX.Media.PDF.DocumentModel Namespace


PdfObject Class

PdfObject Class NFX Class Library

PDF document header
Inheritance Hierarchy
Online System Object
NFX.Media.PDF.DocumentModel PdfObject
NFX.Media.PDF.DocumentModel PdfFont
NFX.Media.PDF.DocumentModel PdfHeader
NFX.Media.PDF.DocumentModel PdfInfo
NFX.Media.PDF.DocumentModel PdfOutlines
NFX.Media.PDF.DocumentModel PdfPage
NFX.Media.PDF.DocumentModel PdfPageTree
NFX.Media.PDF.DocumentModel PdfRoot
NFX.Media.PDF.DocumentModel PdfTrailer
NFX.Media.PDF.Elements PdfElement

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class PdfObject : IPdfObject
public abstract class PdfObject : IPdfObject
Public MustInherit Class PdfObject
    Implements IPdfObject
Public MustInherit Class PdfObject
    Implements IPdfObject
public ref class PdfObject abstract : IPdfObject
public ref class PdfObject abstract : IPdfObject
[<AbstractClassAttribute>]
type PdfObject =
    class
        interface IPdfObject
    end
[<AbstractClassAttribute>]
type PdfObject =
    class
        interface IPdfObject
    end
See Also
PdfObject Members
NFX.Media.PDF.DocumentModel Namespace


PdfObject Members

PdfObject Members NFX Class Library

The PdfObject type exposes the following members.
Constructors
 | Name | Description
Protected method | PdfObject | Initializes a new instance of the PdfObject class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReference | Returns PDF object indirect reference
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ObjectId | Document-wide unique object Id
Back to Top
See Also
PdfObject Class
NFX.Media.PDF.DocumentModel Namespace


PdfObject Constructor

PdfObject Constructor NFX Class Library

Initializes a new instance of the PdfObject class

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PdfObject()
protected PdfObject()
Protected Sub New
Protected Sub New
protected:
PdfObject()
protected:
PdfObject()
new : unit -> PdfObject
new : unit -> PdfObject
See Also
PdfObject Class
PdfObject Members
NFX.Media.PDF.DocumentModel Namespace


PdfObject Methods

PdfObject Methods NFX Class Library

The PdfObject type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReference | Returns PDF object indirect reference
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PdfObject Class
NFX.Media.PDF.DocumentModel Namespace


PdfObject.GetReference Method

PdfObject GetReference Method NFX Class Library

Returns PDF object indirect reference

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetReference()
public string GetReference()
Public Function GetReference As String
Public Function GetReference As String
public:
virtual String^ GetReference() sealed
public:
virtual String^ GetReference() sealed
abstract GetReference : unit -> string
override GetReference : unit -> string
abstract GetReference : unit -> string
override GetReference : unit -> string

Return Value

Type: Online String

Implements

IPdfObject GetReference
See Also
PdfObject Class
PdfObject Members
NFX.Media.PDF.DocumentModel Namespace


PdfObject Properties

PdfObject Properties NFX Class Library

The PdfObject type exposes the following members.
Properties
 | Name | Description
Public property | ObjectId | Document-wide unique object Id
Back to Top
See Also
PdfObject Class
NFX.Media.PDF.DocumentModel Namespace


PdfObject.ObjectId Property

PdfObject ObjectId Property NFX Class Library

Document-wide unique object Id

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ObjectId { get; set; }
public int ObjectId { get; set; }
Public Property ObjectId As Integer
    Get
    Set
Public Property ObjectId As Integer
    Get
    Set
public:
virtual property int ObjectId {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int ObjectId {
    int get () sealed;
    void set (int value) sealed;
}
abstract ObjectId : int with get, set
override ObjectId : int with get, set
abstract ObjectId : int with get, set
override ObjectId : int with get, set

Property Value

Type: Online Int32

Implements

IPdfObject ObjectId
See Also
PdfObject Class
PdfObject Members
NFX.Media.PDF.DocumentModel Namespace


PdfOutlines Class

PdfOutlines Class NFX Class Library

PDF document outlines
Inheritance Hierarchy
Online System Object
NFX.Media.PDF.DocumentModel PdfObject
NFX.Media.PDF.DocumentModel PdfOutlines

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PdfOutlines : PdfObject
public class PdfOutlines : PdfObject
Public Class PdfOutlines
    Inherits PdfObject
Public Class PdfOutlines
    Inherits PdfObject
public ref class PdfOutlines : public PdfObject
public ref class PdfOutlines : public PdfObject
type PdfOutlines =
    class
        inherit PdfObject
    end
type PdfOutlines =
    class
        inherit PdfObject
    end
See Also
PdfOutlines Members
NFX.Media.PDF.DocumentModel Namespace


PdfOutlines Members

PdfOutlines Members NFX Class Library

The PdfOutlines type exposes the following members.
Constructors
 | Name | Description
Public method | PdfOutlines | Initializes a new instance of the PdfOutlines class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReference | Returns PDF object indirect reference (Inherited from PdfObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ObjectId | Document-wide unique object Id (Inherited from PdfObject.)
Back to Top
See Also
PdfOutlines Class
NFX.Media.PDF.DocumentModel Namespace


PdfOutlines Constructor

PdfOutlines Constructor NFX Class Library

Initializes a new instance of the PdfOutlines class

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfOutlines()
public PdfOutlines()
Public Sub New
Public Sub New
public:
PdfOutlines()
public:
PdfOutlines()
new : unit -> PdfOutlines
new : unit -> PdfOutlines
See Also
PdfOutlines Class
PdfOutlines Members
NFX.Media.PDF.DocumentModel Namespace


PdfOutlines Methods

PdfOutlines Methods NFX Class Library

The PdfOutlines type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReference | Returns PDF object indirect reference (Inherited from PdfObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PdfOutlines Class
NFX.Media.PDF.DocumentModel Namespace


PdfOutlines Properties

PdfOutlines Properties NFX Class Library

The PdfOutlines type exposes the following members.
Properties
 | Name | Description
Public property | ObjectId | Document-wide unique object Id (Inherited from PdfObject.)
Back to Top
See Also
PdfOutlines Class
NFX.Media.PDF.DocumentModel Namespace


PdfPage Class

PdfPage Class NFX Class Library

PDF Page
Inheritance Hierarchy
Online System Object
NFX.Media.PDF.DocumentModel PdfObject
NFX.Media.PDF.DocumentModel PdfPage

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PdfPage : PdfObject
public class PdfPage : PdfObject
Public Class PdfPage
    Inherits PdfObject
Public Class PdfPage
    Inherits PdfObject
public ref class PdfPage : public PdfObject
public ref class PdfPage : public PdfObject
type PdfPage =
    class
        inherit PdfObject
    end
type PdfPage =
    class
        inherit PdfObject
    end
See Also
PdfPage Members
NFX.Media.PDF.DocumentModel Namespace


PdfPage Members

PdfPage Members NFX Class Library

The PdfPage type exposes the following members.
Constructors
 | Name | Description
Protected method | PdfPage | Initializes a new instance of the PdfPage class
Back to Top
Methods
 | Name | Description
Public method | Add | Adds PDF element to page's elements collection
Public method | AddCircle(Single, Single, Single, PdfColor) | Add circle primitive to the page
Public method | AddCircle(Single, Single, Single, PdfDrawStyle) | Add circle primitive to the page
Public method | AddCircle(Single, Single, Single, PdfColor, Single) | Add circle primitive to the page
Public method | AddCircle(Single, Single, Single, PdfColor, Single, PdfColor) | Add circle primitive to the page
Public method | AddCircle(Single, Single, Single, PdfColor, Single, PdfColor, PdfLineType) | Add circle primitive to the page
Public method | AddImage(String) | Add image to the page
Public method | AddImage(String, Single, Single) | Add image to the page
Public method | AddLine(Single, Single, Single, Single) | Add line primitive to the page
Public method | AddLine(Single, Single, Single, Single, PdfDrawStyle) | Add line primitive to the page
Public method | AddLine(Single, Single, Single, Single, Single) | Add line primitive to the page
Public method | AddLine(Single, Single, Single, Single, Single, PdfColor) | Add line primitive to the page
Public method | AddLine(Single, Single, Single, Single, Single, PdfColor, PdfLineType) | Add line primitive to the page
Public method | AddPath(Single, Single) | Add path to the page
Public method | AddPath(Single, Single, PdfDrawStyle) | Add path to the page
Public method | AddPath(Single, Single, Single) | Add path to the page
Public method | AddPath(Single, Single, Single, PdfColor) | Add path to the page
Public method | AddPath(Single, Single, Single, PdfColor, PdfLineType) | Add path to the page
Public method | AddRectangle(Single, Single, Single, Single, PdfColor) | Add rectangle primitive to the page
Public method | AddRectangle(Single, Single, Single, Single, PdfDrawStyle) | Add rectangle primitive to the page
Public method | AddRectangle(Single, Single, Single, Single, PdfColor, Single) | Add rectangle primitive to the page
Public method | AddRectangle(Single, Single, Single, Single, PdfColor, Single, PdfColor) | Add rectangle primitive to the page
Public method | AddRectangle(Single, Single, Single, Single, PdfColor, Single, PdfColor, PdfLineType) | Add rectangle primitive to the page
Public method | AddText(String) | Add raw text to the page
Public method | AddText(String, Single, PdfFont) | Add raw text to the page
Public method | AddText(String, Single, PdfFont, PdfColor) | Add raw text to the page
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReference | Returns PDF object indirect reference (Inherited from PdfObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Elements | Page elements
Protected property | Fonts | Fonts used on the page
Public property | Height | Page's height
Public property | ObjectId | Document-wide unique object Id (Inherited from PdfObject.)
Protected property | Parent | Page tree
Public property | UserUnit | User space units (the default user space unit is 1/72 inch)
Public property | Width | Page's width
Back to Top
See Also
PdfPage Class
NFX.Media.PDF.DocumentModel Namespace


PdfPage Constructor

PdfPage Constructor NFX Class Library

Initializes a new instance of the PdfPage class

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal PdfPage(
    PdfPageTree parent,
    PdfSize size
)
internal PdfPage(
    PdfPageTree parent,
    PdfSize size
)
Friend Sub New (
    parent As PdfPageTree,
    size As PdfSize
)
Friend Sub New (
    parent As PdfPageTree,
    size As PdfSize
)
internal:
PdfPage(
    PdfPageTree^ parent,
    PdfSize^ size
)
internal:
PdfPage(
    PdfPageTree^ parent,
    PdfSize^ size
)
new :
        parent : PdfPageTree *
        size : PdfSize -> PdfPage
new :
        parent : PdfPageTree *
        size : PdfSize -> PdfPage

Parameters

parent
Type: NFX.Media.PDF.DocumentModel PdfPageTree
size
Type: NFX.Media.PDF.Styling PdfSize
See Also
PdfPage Class
PdfPage Members
NFX.Media.PDF.DocumentModel Namespace


PdfPage Methods

PdfPage Methods NFX Class Library

The PdfPage type exposes the following members.
Methods
 | Name | Description
Public method | Add | Adds PDF element to page's elements collection
Public method | AddCircle(Single, Single, Single, PdfColor) | Add circle primitive to the page
Public method | AddCircle(Single, Single, Single, PdfDrawStyle) | Add circle primitive to the page
Public method | AddCircle(Single, Single, Single, PdfColor, Single) | Add circle primitive to the page
Public method | AddCircle(Single, Single, Single, PdfColor, Single, PdfColor) | Add circle primitive to the page
Public method | AddCircle(Single, Single, Single, PdfColor, Single, PdfColor, PdfLineType) | Add circle primitive to the page
Public method | AddImage(String) | Add image to the page
Public method | AddImage(String, Single, Single) | Add image to the page
Public method | AddLine(Single, Single, Single, Single) | Add line primitive to the page
Public method | AddLine(Single, Single, Single, Single, PdfDrawStyle) | Add line primitive to the page
Public method | AddLine(Single, Single, Single, Single, Single) | Add line primitive to the page
Public method | AddLine(Single, Single, Single, Single, Single, PdfColor) | Add line primitive to the page
Public method | AddLine(Single, Single, Single, Single, Single, PdfColor, PdfLineType) | Add line primitive to the page
Public method | AddPath(Single, Single) | Add path to the page
Public method | AddPath(Single, Single, PdfDrawStyle) | Add path to the page
Public method | AddPath(Single, Single, Single) | Add path to the page
Public method | AddPath(Single, Single, Single, PdfColor) | Add path to the page
Public method | AddPath(Single, Single, Single, PdfColor, PdfLineType) | Add path to the page
Public method | AddRectangle(Single, Single, Single, Single, PdfColor) | Add rectangle primitive to the page
Public method | AddRectangle(Single, Single, Single, Single, PdfDrawStyle) | Add rectangle primitive to the page
Public method | AddRectangle(Single, Single, Single, Single, PdfColor, Single) | Add rectangle primitive to the page
Public method | AddRectangle(Single, Single, Single, Single, PdfColor, Single, PdfColor) | Add rectangle primitive to the page
Public method | AddRectangle(Single, Single, Single, Single, PdfColor, Single, PdfColor, PdfLineType) | Add rectangle primitive to the page
Public method | AddText(String) | Add raw text to the page
Public method | AddText(String, Single, PdfFont) | Add raw text to the page
Public method | AddText(String, Single, PdfFont, PdfColor) | Add raw text to the page
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReference | Returns PDF object indirect reference (Inherited from PdfObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PdfPage Class
NFX.Media.PDF.DocumentModel Namespace


PdfPage.Add Method

PdfPage Add Method NFX Class Library

Adds PDF element to page's elements collection

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    PdfElement element
)
public void Add(
    PdfElement element
)
Public Sub Add (
    element As PdfElement
)
Public Sub Add (
    element As PdfElement
)
public:
void Add(
    PdfElement^ element
)
public:
void Add(
    PdfElement^ element
)
member Add :
        element : PdfElement -> unit
member Add :
        element : PdfElement -> unit

Parameters

element
Type: NFX.Media.PDF.Elements PdfElement
See Also
PdfPage Class
PdfPage Members
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddCircle Method

PdfPage AddCircle Method NFX Class Library

Overload List
 | Name | Description
Public method | AddCircle(Single, Single, Single, PdfColor) | Add circle primitive to the page
Public method | AddCircle(Single, Single, Single, PdfDrawStyle) | Add circle primitive to the page
Public method | AddCircle(Single, Single, Single, PdfColor, Single) | Add circle primitive to the page
Public method | AddCircle(Single, Single, Single, PdfColor, Single, PdfColor) | Add circle primitive to the page
Public method | AddCircle(Single, Single, Single, PdfColor, Single, PdfColor, PdfLineType) | Add circle primitive to the page
Back to Top
See Also
PdfPage Class
PdfPage Members
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddCircle Method (Single, Single, Single, PdfColor)

PdfPage AddCircle Method (Single, Single, Single, PdfColor) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add circle primitive to the page

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PathElement AddCircle(
    float centerX,
    float centerY,
    float r,
    PdfColor fill
)
public PathElement AddCircle(
    float centerX,
    float centerY,
    float r,
    PdfColor fill
)
Public Function AddCircle (
    centerX As Single,
    centerY As Single,
    r As Single,
    fill As PdfColor
) As PathElement
Public Function AddCircle (
    centerX As Single,
    centerY As Single,
    r As Single,
    fill As PdfColor
) As PathElement
public:
PathElement^ AddCircle(
    float centerX,
    float centerY,
    float r,
    PdfColor^ fill
)
public:
PathElement^ AddCircle(
    float centerX,
    float centerY,
    float r,
    PdfColor^ fill
)
member AddCircle :
        centerX : float32 *
        centerY : float32 *
        r : float32 *
        fill : PdfColor -> PathElement
member AddCircle :
        centerX : float32 *
        centerY : float32 *
        r : float32 *
        fill : PdfColor -> PathElement

Parameters

centerX
Type: Online System Single
centerY
Type: Online System Single
r
Type: Online System Single
fill
Type: NFX.Media.PDF.Styling PdfColor

Return Value

Type: PathElement
See Also
PdfPage Class
PdfPage Members
AddCircle Overload
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddCircle Method (Single, Single, Single, PdfDrawStyle)

PdfPage AddCircle Method (Single, Single, Single, PdfDrawStyle) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add circle primitive to the page

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PathElement AddCircle(
    float centerX,
    float centerY,
    float r,
    PdfDrawStyle borderStyle
)
public PathElement AddCircle(
    float centerX,
    float centerY,
    float r,
    PdfDrawStyle borderStyle
)
Public Function AddCircle (
    centerX As Single,
    centerY As Single,
    r As Single,
    borderStyle As PdfDrawStyle
) As PathElement
Public Function AddCircle (
    centerX As Single,
    centerY As Single,
    r As Single,
    borderStyle As PdfDrawStyle
) As PathElement
public:
PathElement^ AddCircle(
    float centerX,
    float centerY,
    float r,
    PdfDrawStyle^ borderStyle
)
public:
PathElement^ AddCircle(
    float centerX,
    float centerY,
    float r,
    PdfDrawStyle^ borderStyle
)
member AddCircle :
        centerX : float32 *
        centerY : float32 *
        r : float32 *
        borderStyle : PdfDrawStyle -> PathElement
member AddCircle :
        centerX : float32 *
        centerY : float32 *
        r : float32 *
        borderStyle : PdfDrawStyle -> PathElement

Parameters

centerX
Type: Online System Single
centerY
Type: Online System Single
r
Type: Online System Single
borderStyle
Type: NFX.Media.PDF.Styling PdfDrawStyle

Return Value

Type: PathElement
See Also
PdfPage Class
PdfPage Members
AddCircle Overload
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddCircle Method (Single, Single, Single, PdfColor, Single)

PdfPage AddCircle Method (Single, Single, Single, PdfColor, Single) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add circle primitive to the page

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PathElement AddCircle(
    float centerX,
    float centerY,
    float r,
    PdfColor fill,
    float borderThickness
)
public PathElement AddCircle(
    float centerX,
    float centerY,
    float r,
    PdfColor fill,
    float borderThickness
)
Public Function AddCircle (
    centerX As Single,
    centerY As Single,
    r As Single,
    fill As PdfColor,
    borderThickness As Single
) As PathElement
Public Function AddCircle (
    centerX As Single,
    centerY As Single,
    r As Single,
    fill As PdfColor,
    borderThickness As Single
) As PathElement
public:
PathElement^ AddCircle(
    float centerX,
    float centerY,
    float r,
    PdfColor^ fill,
    float borderThickness
)
public:
PathElement^ AddCircle(
    float centerX,
    float centerY,
    float r,
    PdfColor^ fill,
    float borderThickness
)
member AddCircle :
        centerX : float32 *
        centerY : float32 *
        r : float32 *
        fill : PdfColor *
        borderThickness : float32 -> PathElement
member AddCircle :
        centerX : float32 *
        centerY : float32 *
        r : float32 *
        fill : PdfColor *
        borderThickness : float32 -> PathElement

Parameters

centerX
Type: Online System Single
centerY
Type: Online System Single
r
Type: Online System Single
fill
Type: NFX.Media.PDF.Styling PdfColor
borderThickness
Type: Online System Single

Return Value

Type: PathElement
See Also
PdfPage Class
PdfPage Members
AddCircle Overload
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddCircle Method (Single, Single, Single, PdfColor, Single, PdfColor)

PdfPage AddCircle Method (Single, Single, Single, PdfColor, Single, PdfColor) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add circle primitive to the page

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PathElement AddCircle(
    float centerX,
    float centerY,
    float r,
    PdfColor fill,
    float borderThickness,
    PdfColor borderColor
)
public PathElement AddCircle(
    float centerX,
    float centerY,
    float r,
    PdfColor fill,
    float borderThickness,
    PdfColor borderColor
)
Public Function AddCircle (
    centerX As Single,
    centerY As Single,
    r As Single,
    fill As PdfColor,
    borderThickness As Single,
    borderColor As PdfColor
) As PathElement
Public Function AddCircle (
    centerX As Single,
    centerY As Single,
    r As Single,
    fill As PdfColor,
    borderThickness As Single,
    borderColor As PdfColor
) As PathElement
public:
PathElement^ AddCircle(
    float centerX,
    float centerY,
    float r,
    PdfColor^ fill,
    float borderThickness,
    PdfColor^ borderColor
)
public:
PathElement^ AddCircle(
    float centerX,
    float centerY,
    float r,
    PdfColor^ fill,
    float borderThickness,
    PdfColor^ borderColor
)
member AddCircle :
        centerX : float32 *
        centerY : float32 *
        r : float32 *
        fill : PdfColor *
        borderThickness : float32 *
        borderColor : PdfColor -> PathElement
member AddCircle :
        centerX : float32 *
        centerY : float32 *
        r : float32 *
        fill : PdfColor *
        borderThickness : float32 *
        borderColor : PdfColor -> PathElement

Parameters

centerX
Type: Online System Single
centerY
Type: Online System Single
r
Type: Online System Single
fill
Type: NFX.Media.PDF.Styling PdfColor
borderThickness
Type: Online System Single
borderColor
Type: NFX.Media.PDF.Styling PdfColor

Return Value

Type: PathElement
See Also
PdfPage Class
PdfPage Members
AddCircle Overload
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddCircle Method (Single, Single, Single, PdfColor, Single, PdfColor, PdfLineType)

PdfPage AddCircle Method (Single, Single, Single, PdfColor, Single, PdfColor, PdfLineType) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add circle primitive to the page

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PathElement AddCircle(
    float centerX,
    float centerY,
    float r,
    PdfColor fill,
    float borderThickness,
    PdfColor borderColor,
    PdfLineType borderType
)
public PathElement AddCircle(
    float centerX,
    float centerY,
    float r,
    PdfColor fill,
    float borderThickness,
    PdfColor borderColor,
    PdfLineType borderType
)
Public Function AddCircle (
    centerX As Single,
    centerY As Single,
    r As Single,
    fill As PdfColor,
    borderThickness As Single,
    borderColor As PdfColor,
    borderType As PdfLineType
) As PathElement
Public Function AddCircle (
    centerX As Single,
    centerY As Single,
    r As Single,
    fill As PdfColor,
    borderThickness As Single,
    borderColor As PdfColor,
    borderType As PdfLineType
) As PathElement
public:
PathElement^ AddCircle(
    float centerX,
    float centerY,
    float r,
    PdfColor^ fill,
    float borderThickness,
    PdfColor^ borderColor,
    PdfLineType borderType
)
public:
PathElement^ AddCircle(
    float centerX,
    float centerY,
    float r,
    PdfColor^ fill,
    float borderThickness,
    PdfColor^ borderColor,
    PdfLineType borderType
)
member AddCircle :
        centerX : float32 *
        centerY : float32 *
        r : float32 *
        fill : PdfColor *
        borderThickness : float32 *
        borderColor : PdfColor *
        borderType : PdfLineType -> PathElement
member AddCircle :
        centerX : float32 *
        centerY : float32 *
        r : float32 *
        fill : PdfColor *
        borderThickness : float32 *
        borderColor : PdfColor *
        borderType : PdfLineType -> PathElement

Parameters

centerX
Type: Online System Single
centerY
Type: Online System Single
r
Type: Online System Single
fill
Type: NFX.Media.PDF.Styling PdfColor
borderThickness
Type: Online System Single
borderColor
Type: NFX.Media.PDF.Styling PdfColor
borderType
Type: NFX.Media.PDF.Styling PdfLineType

Return Value

Type: PathElement
See Also
PdfPage Class
PdfPage Members
AddCircle Overload
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddImage Method

PdfPage AddImage Method NFX Class Library

Overload List
 | Name | Description
Public method | AddImage(String) | Add image to the page
Public method | AddImage(String, Single, Single) | Add image to the page
Back to Top
See Also
PdfPage Class
PdfPage Members
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddImage Method (String)

PdfPage AddImage Method (String) NFX Class Library

Add image to the page

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ImageElement AddImage(
    string filePath
)
public ImageElement AddImage(
    string filePath
)
Public Function AddImage (
    filePath As String
) As ImageElement
Public Function AddImage (
    filePath As String
) As ImageElement
public:
ImageElement^ AddImage(
    String^ filePath
)
public:
ImageElement^ AddImage(
    String^ filePath
)
member AddImage :
        filePath : string -> ImageElement
member AddImage :
        filePath : string -> ImageElement

Parameters

filePath
Type: Online System String

Return Value

Type: ImageElement
See Also
PdfPage Class
PdfPage Members
AddImage Overload
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddImage Method (String, Single, Single)

PdfPage AddImage Method (String, Single, Single) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add image to the page

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ImageElement AddImage(
    string filePath,
    float width,
    float height
)
public ImageElement AddImage(
    string filePath,
    float width,
    float height
)
Public Function AddImage (
    filePath As String,
    width As Single,
    height As Single
) As ImageElement
Public Function AddImage (
    filePath As String,
    width As Single,
    height As Single
) As ImageElement
public:
ImageElement^ AddImage(
    String^ filePath,
    float width,
    float height
)
public:
ImageElement^ AddImage(
    String^ filePath,
    float width,
    float height
)
member AddImage :
        filePath : string *
        width : float32 *
        height : float32 -> ImageElement
member AddImage :
        filePath : string *
        width : float32 *
        height : float32 -> ImageElement

Parameters

filePath
Type: Online System String
width
Type: Online System Single
height
Type: Online System Single

Return Value

Type: ImageElement
See Also
PdfPage Class
PdfPage Members
AddImage Overload
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddLine Method

PdfPage AddLine Method NFX Class Library

Overload List
 | Name | Description
Public method | AddLine(Single, Single, Single, Single) | Add line primitive to the page
Public method | AddLine(Single, Single, Single, Single, PdfDrawStyle) | Add line primitive to the page
Public method | AddLine(Single, Single, Single, Single, Single) | Add line primitive to the page
Public method | AddLine(Single, Single, Single, Single, Single, PdfColor) | Add line primitive to the page
Public method | AddLine(Single, Single, Single, Single, Single, PdfColor, PdfLineType) | Add line primitive to the page
Back to Top
See Also
PdfPage Class
PdfPage Members
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddLine Method (Single, Single, Single, Single)

PdfPage AddLine Method (Single, Single, Single, Single) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add line primitive to the page

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PathElement AddLine(
    float x1,
    float y1,
    float x2,
    float y2
)
public PathElement AddLine(
    float x1,
    float y1,
    float x2,
    float y2
)
Public Function AddLine (
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single
) As PathElement
Public Function AddLine (
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single
) As PathElement
public:
PathElement^ AddLine(
    float x1,
    float y1,
    float x2,
    float y2
)
public:
PathElement^ AddLine(
    float x1,
    float y1,
    float x2,
    float y2
)
member AddLine :
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 -> PathElement
member AddLine :
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 -> PathElement

Parameters

x1
Type: Online System Single
y1
Type: Online System Single
x2
Type: Online System Single
y2
Type: Online System Single

Return Value

Type: PathElement
See Also
PdfPage Class
PdfPage Members
AddLine Overload
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddLine Method (Single, Single, Single, Single, PdfDrawStyle)

PdfPage AddLine Method (Single, Single, Single, Single, PdfDrawStyle) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add line primitive to the page

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PathElement AddLine(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfDrawStyle style
)
public PathElement AddLine(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfDrawStyle style
)
Public Function AddLine (
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single,
    style As PdfDrawStyle
) As PathElement
Public Function AddLine (
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single,
    style As PdfDrawStyle
) As PathElement
public:
PathElement^ AddLine(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfDrawStyle^ style
)
public:
PathElement^ AddLine(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfDrawStyle^ style
)
member AddLine :
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 *
        style : PdfDrawStyle -> PathElement
member AddLine :
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 *
        style : PdfDrawStyle -> PathElement

Parameters

x1
Type: Online System Single
y1
Type: Online System Single
x2
Type: Online System Single
y2
Type: Online System Single
style
Type: NFX.Media.PDF.Styling PdfDrawStyle

Return Value

Type: PathElement
See Also
PdfPage Class
PdfPage Members
AddLine Overload
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddLine Method (Single, Single, Single, Single, Single)

PdfPage AddLine Method (Single, Single, Single, Single, Single) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add line primitive to the page

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PathElement AddLine(
    float x1,
    float y1,
    float x2,
    float y2,
    float thickness
)
public PathElement AddLine(
    float x1,
    float y1,
    float x2,
    float y2,
    float thickness
)
Public Function AddLine (
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single,
    thickness As Single
) As PathElement
Public Function AddLine (
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single,
    thickness As Single
) As PathElement
public:
PathElement^ AddLine(
    float x1,
    float y1,
    float x2,
    float y2,
    float thickness
)
public:
PathElement^ AddLine(
    float x1,
    float y1,
    float x2,
    float y2,
    float thickness
)
member AddLine :
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 *
        thickness : float32 -> PathElement
member AddLine :
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 *
        thickness : float32 -> PathElement

Parameters

x1
Type: Online System Single
y1
Type: Online System Single
x2
Type: Online System Single
y2
Type: Online System Single
thickness
Type: Online System Single

Return Value

Type: PathElement
See Also
PdfPage Class
PdfPage Members
AddLine Overload
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddLine Method (Single, Single, Single, Single, Single, PdfColor)

PdfPage AddLine Method (Single, Single, Single, Single, Single, PdfColor) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add line primitive to the page

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PathElement AddLine(
    float x1,
    float y1,
    float x2,
    float y2,
    float thickness,
    PdfColor color
)
public PathElement AddLine(
    float x1,
    float y1,
    float x2,
    float y2,
    float thickness,
    PdfColor color
)
Public Function AddLine (
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single,
    thickness As Single,
    color As PdfColor
) As PathElement
Public Function AddLine (
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single,
    thickness As Single,
    color As PdfColor
) As PathElement
public:
PathElement^ AddLine(
    float x1,
    float y1,
    float x2,
    float y2,
    float thickness,
    PdfColor^ color
)
public:
PathElement^ AddLine(
    float x1,
    float y1,
    float x2,
    float y2,
    float thickness,
    PdfColor^ color
)
member AddLine :
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 *
        thickness : float32 *
        color : PdfColor -> PathElement
member AddLine :
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 *
        thickness : float32 *
        color : PdfColor -> PathElement

Parameters

x1
Type: Online System Single
y1
Type: Online System Single
x2
Type: Online System Single
y2
Type: Online System Single
thickness
Type: Online System Single
color
Type: NFX.Media.PDF.Styling PdfColor

Return Value

Type: PathElement
See Also
PdfPage Class
PdfPage Members
AddLine Overload
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddLine Method (Single, Single, Single, Single, Single, PdfColor, PdfLineType)

PdfPage AddLine Method (Single, Single, Single, Single, Single, PdfColor, PdfLineType) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add line primitive to the page

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PathElement AddLine(
    float x1,
    float y1,
    float x2,
    float y2,
    float thickness,
    PdfColor color,
    PdfLineType type
)
public PathElement AddLine(
    float x1,
    float y1,
    float x2,
    float y2,
    float thickness,
    PdfColor color,
    PdfLineType type
)
Public Function AddLine (
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single,
    thickness As Single,
    color As PdfColor,
    type As PdfLineType
) As PathElement
Public Function AddLine (
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single,
    thickness As Single,
    color As PdfColor,
    type As PdfLineType
) As PathElement
public:
PathElement^ AddLine(
    float x1,
    float y1,
    float x2,
    float y2,
    float thickness,
    PdfColor^ color,
    PdfLineType type
)
public:
PathElement^ AddLine(
    float x1,
    float y1,
    float x2,
    float y2,
    float thickness,
    PdfColor^ color,
    PdfLineType type
)
member AddLine :
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 *
        thickness : float32 *
        color : PdfColor *
        type : PdfLineType -> PathElement
member AddLine :
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 *
        thickness : float32 *
        color : PdfColor *
        type : PdfLineType -> PathElement

Parameters

x1
Type: Online System Single
y1
Type: Online System Single
x2
Type: Online System Single
y2
Type: Online System Single
thickness
Type: Online System Single
color
Type: NFX.Media.PDF.Styling PdfColor
type
Type: NFX.Media.PDF.Styling PdfLineType

Return Value

Type: PathElement
See Also
PdfPage Class
PdfPage Members
AddLine Overload
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddPath Method

PdfPage AddPath Method NFX Class Library

Overload List
 | Name | Description
Public method | AddPath(Single, Single) | Add path to the page
Public method | AddPath(Single, Single, PdfDrawStyle) | Add path to the page
Public method | AddPath(Single, Single, Single) | Add path to the page
Public method | AddPath(Single, Single, Single, PdfColor) | Add path to the page
Public method | AddPath(Single, Single, Single, PdfColor, PdfLineType) | Add path to the page
Back to Top
See Also
PdfPage Class
PdfPage Members
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddPath Method (Single, Single)

PdfPage AddPath Method (Single, Single) NFX Class Library

Add path to the page

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PathElement AddPath(
    float x,
    float y
)
public PathElement AddPath(
    float x,
    float y
)
Public Function AddPath (
    x As Single,
    y As Single
) As PathElement
Public Function AddPath (
    x As Single,
    y As Single
) As PathElement
public:
PathElement^ AddPath(
    float x,
    float y
)
public:
PathElement^ AddPath(
    float x,
    float y
)
member AddPath :
        x : float32 *
        y : float32 -> PathElement
member AddPath :
        x : float32 *
        y : float32 -> PathElement

Parameters

x
Type: Online System Single
y
Type: Online System Single

Return Value

Type: PathElement
See Also
PdfPage Class
PdfPage Members
AddPath Overload
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddPath Method (Single, Single, PdfDrawStyle)

PdfPage AddPath Method (Single, Single, PdfDrawStyle) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add path to the page

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PathElement AddPath(
    float x,
    float y,
    PdfDrawStyle style
)
public PathElement AddPath(
    float x,
    float y,
    PdfDrawStyle style
)
Public Function AddPath (
    x As Single,
    y As Single,
    style As PdfDrawStyle
) As PathElement
Public Function AddPath (
    x As Single,
    y As Single,
    style As PdfDrawStyle
) As PathElement
public:
PathElement^ AddPath(
    float x,
    float y,
    PdfDrawStyle^ style
)
public:
PathElement^ AddPath(
    float x,
    float y,
    PdfDrawStyle^ style
)
member AddPath :
        x : float32 *
        y : float32 *
        style : PdfDrawStyle -> PathElement
member AddPath :
        x : float32 *
        y : float32 *
        style : PdfDrawStyle -> PathElement

Parameters

x
Type: Online System Single
y
Type: Online System Single
style
Type: NFX.Media.PDF.Styling PdfDrawStyle

Return Value

Type: PathElement
See Also
PdfPage Class
PdfPage Members
AddPath Overload
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddPath Method (Single, Single, Single)

PdfPage AddPath Method (Single, Single, Single) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add path to the page

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PathElement AddPath(
    float x,
    float y,
    float thickness
)
public PathElement AddPath(
    float x,
    float y,
    float thickness
)
Public Function AddPath (
    x As Single,
    y As Single,
    thickness As Single
) As PathElement
Public Function AddPath (
    x As Single,
    y As Single,
    thickness As Single
) As PathElement
public:
PathElement^ AddPath(
    float x,
    float y,
    float thickness
)
public:
PathElement^ AddPath(
    float x,
    float y,
    float thickness
)
member AddPath :
        x : float32 *
        y : float32 *
        thickness : float32 -> PathElement
member AddPath :
        x : float32 *
        y : float32 *
        thickness : float32 -> PathElement

Parameters

x
Type: Online System Single
y
Type: Online System Single
thickness
Type: Online System Single

Return Value

Type: PathElement
See Also
PdfPage Class
PdfPage Members
AddPath Overload
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddPath Method (Single, Single, Single, PdfColor)

PdfPage AddPath Method (Single, Single, Single, PdfColor) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add path to the page

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PathElement AddPath(
    float x,
    float y,
    float thickness,
    PdfColor color
)
public PathElement AddPath(
    float x,
    float y,
    float thickness,
    PdfColor color
)
Public Function AddPath (
    x As Single,
    y As Single,
    thickness As Single,
    color As PdfColor
) As PathElement
Public Function AddPath (
    x As Single,
    y As Single,
    thickness As Single,
    color As PdfColor
) As PathElement
public:
PathElement^ AddPath(
    float x,
    float y,
    float thickness,
    PdfColor^ color
)
public:
PathElement^ AddPath(
    float x,
    float y,
    float thickness,
    PdfColor^ color
)
member AddPath :
        x : float32 *
        y : float32 *
        thickness : float32 *
        color : PdfColor -> PathElement
member AddPath :
        x : float32 *
        y : float32 *
        thickness : float32 *
        color : PdfColor -> PathElement

Parameters

x
Type: Online System Single
y
Type: Online System Single
thickness
Type: Online System Single
color
Type: NFX.Media.PDF.Styling PdfColor

Return Value

Type: PathElement
See Also
PdfPage Class
PdfPage Members
AddPath Overload
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddPath Method (Single, Single, Single, PdfColor, PdfLineType)

PdfPage AddPath Method (Single, Single, Single, PdfColor, PdfLineType) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add path to the page

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PathElement AddPath(
    float x,
    float y,
    float thickness,
    PdfColor color,
    PdfLineType type
)
public PathElement AddPath(
    float x,
    float y,
    float thickness,
    PdfColor color,
    PdfLineType type
)
Public Function AddPath (
    x As Single,
    y As Single,
    thickness As Single,
    color As PdfColor,
    type As PdfLineType
) As PathElement
Public Function AddPath (
    x As Single,
    y As Single,
    thickness As Single,
    color As PdfColor,
    type As PdfLineType
) As PathElement
public:
PathElement^ AddPath(
    float x,
    float y,
    float thickness,
    PdfColor^ color,
    PdfLineType type
)
public:
PathElement^ AddPath(
    float x,
    float y,
    float thickness,
    PdfColor^ color,
    PdfLineType type
)
member AddPath :
        x : float32 *
        y : float32 *
        thickness : float32 *
        color : PdfColor *
        type : PdfLineType -> PathElement
member AddPath :
        x : float32 *
        y : float32 *
        thickness : float32 *
        color : PdfColor *
        type : PdfLineType -> PathElement

Parameters

x
Type: Online System Single
y
Type: Online System Single
thickness
Type: Online System Single
color
Type: NFX.Media.PDF.Styling PdfColor
type
Type: NFX.Media.PDF.Styling PdfLineType

Return Value

Type: PathElement
See Also
PdfPage Class
PdfPage Members
AddPath Overload
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddRectangle Method

PdfPage AddRectangle Method NFX Class Library

Overload List
 | Name | Description
Public method | AddRectangle(Single, Single, Single, Single, PdfColor) | Add rectangle primitive to the page
Public method | AddRectangle(Single, Single, Single, Single, PdfDrawStyle) | Add rectangle primitive to the page
Public method | AddRectangle(Single, Single, Single, Single, PdfColor, Single) | Add rectangle primitive to the page
Public method | AddRectangle(Single, Single, Single, Single, PdfColor, Single, PdfColor) | Add rectangle primitive to the page
Public method | AddRectangle(Single, Single, Single, Single, PdfColor, Single, PdfColor, PdfLineType) | Add rectangle primitive to the page
Back to Top
See Also
PdfPage Class
PdfPage Members
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddRectangle Method (Single, Single, Single, Single, PdfColor)

PdfPage AddRectangle Method (Single, Single, Single, Single, PdfColor) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add rectangle primitive to the page

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RectangleElement AddRectangle(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfColor fill
)
public RectangleElement AddRectangle(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfColor fill
)
Public Function AddRectangle (
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single,
    fill As PdfColor
) As RectangleElement
Public Function AddRectangle (
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single,
    fill As PdfColor
) As RectangleElement
public:
RectangleElement^ AddRectangle(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfColor^ fill
)
public:
RectangleElement^ AddRectangle(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfColor^ fill
)
member AddRectangle :
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 *
        fill : PdfColor -> RectangleElement
member AddRectangle :
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 *
        fill : PdfColor -> RectangleElement

Parameters

x1
Type: Online System Single
y1
Type: Online System Single
x2
Type: Online System Single
y2
Type: Online System Single
fill
Type: NFX.Media.PDF.Styling PdfColor

Return Value

Type: RectangleElement
See Also
PdfPage Class
PdfPage Members
AddRectangle Overload
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddRectangle Method (Single, Single, Single, Single, PdfDrawStyle)

PdfPage AddRectangle Method (Single, Single, Single, Single, PdfDrawStyle) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add rectangle primitive to the page

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RectangleElement AddRectangle(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfDrawStyle style
)
public RectangleElement AddRectangle(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfDrawStyle style
)
Public Function AddRectangle (
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single,
    style As PdfDrawStyle
) As RectangleElement
Public Function AddRectangle (
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single,
    style As PdfDrawStyle
) As RectangleElement
public:
RectangleElement^ AddRectangle(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfDrawStyle^ style
)
public:
RectangleElement^ AddRectangle(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfDrawStyle^ style
)
member AddRectangle :
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 *
        style : PdfDrawStyle -> RectangleElement
member AddRectangle :
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 *
        style : PdfDrawStyle -> RectangleElement

Parameters

x1
Type: Online System Single
y1
Type: Online System Single
x2
Type: Online System Single
y2
Type: Online System Single
style
Type: NFX.Media.PDF.Styling PdfDrawStyle

Return Value

Type: RectangleElement
See Also
PdfPage Class
PdfPage Members
AddRectangle Overload
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddRectangle Method (Single, Single, Single, Single, PdfColor, Single)

PdfPage AddRectangle Method (Single, Single, Single, Single, PdfColor, Single) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add rectangle primitive to the page

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RectangleElement AddRectangle(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfColor fill,
    float borderThickness
)
public RectangleElement AddRectangle(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfColor fill,
    float borderThickness
)
Public Function AddRectangle (
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single,
    fill As PdfColor,
    borderThickness As Single
) As RectangleElement
Public Function AddRectangle (
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single,
    fill As PdfColor,
    borderThickness As Single
) As RectangleElement
public:
RectangleElement^ AddRectangle(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfColor^ fill,
    float borderThickness
)
public:
RectangleElement^ AddRectangle(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfColor^ fill,
    float borderThickness
)
member AddRectangle :
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 *
        fill : PdfColor *
        borderThickness : float32 -> RectangleElement
member AddRectangle :
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 *
        fill : PdfColor *
        borderThickness : float32 -> RectangleElement

Parameters

x1
Type: Online System Single
y1
Type: Online System Single
x2
Type: Online System Single
y2
Type: Online System Single
fill
Type: NFX.Media.PDF.Styling PdfColor
borderThickness
Type: Online System Single

Return Value

Type: RectangleElement
See Also
PdfPage Class
PdfPage Members
AddRectangle Overload
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddRectangle Method (Single, Single, Single, Single, PdfColor, Single, PdfColor)

PdfPage AddRectangle Method (Single, Single, Single, Single, PdfColor, Single, PdfColor) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add rectangle primitive to the page

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RectangleElement AddRectangle(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfColor fill,
    float borderThickness,
    PdfColor borderColor
)
public RectangleElement AddRectangle(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfColor fill,
    float borderThickness,
    PdfColor borderColor
)
Public Function AddRectangle (
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single,
    fill As PdfColor,
    borderThickness As Single,
    borderColor As PdfColor
) As RectangleElement
Public Function AddRectangle (
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single,
    fill As PdfColor,
    borderThickness As Single,
    borderColor As PdfColor
) As RectangleElement
public:
RectangleElement^ AddRectangle(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfColor^ fill,
    float borderThickness,
    PdfColor^ borderColor
)
public:
RectangleElement^ AddRectangle(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfColor^ fill,
    float borderThickness,
    PdfColor^ borderColor
)
member AddRectangle :
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 *
        fill : PdfColor *
        borderThickness : float32 *
        borderColor : PdfColor -> RectangleElement
member AddRectangle :
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 *
        fill : PdfColor *
        borderThickness : float32 *
        borderColor : PdfColor -> RectangleElement

Parameters

x1
Type: Online System Single
y1
Type: Online System Single
x2
Type: Online System Single
y2
Type: Online System Single
fill
Type: NFX.Media.PDF.Styling PdfColor
borderThickness
Type: Online System Single
borderColor
Type: NFX.Media.PDF.Styling PdfColor

Return Value

Type: RectangleElement
See Also
PdfPage Class
PdfPage Members
AddRectangle Overload
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddRectangle Method (Single, Single, Single, Single, PdfColor, Single, PdfColor, PdfLineType)

PdfPage AddRectangle Method (Single, Single, Single, Single, PdfColor, Single, PdfColor, PdfLineType) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add rectangle primitive to the page

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RectangleElement AddRectangle(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfColor fill,
    float borderThickness,
    PdfColor borderColor,
    PdfLineType borderType
)
public RectangleElement AddRectangle(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfColor fill,
    float borderThickness,
    PdfColor borderColor,
    PdfLineType borderType
)
Public Function AddRectangle (
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single,
    fill As PdfColor,
    borderThickness As Single,
    borderColor As PdfColor,
    borderType As PdfLineType
) As RectangleElement
Public Function AddRectangle (
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single,
    fill As PdfColor,
    borderThickness As Single,
    borderColor As PdfColor,
    borderType As PdfLineType
) As RectangleElement
public:
RectangleElement^ AddRectangle(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfColor^ fill,
    float borderThickness,
    PdfColor^ borderColor,
    PdfLineType borderType
)
public:
RectangleElement^ AddRectangle(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfColor^ fill,
    float borderThickness,
    PdfColor^ borderColor,
    PdfLineType borderType
)
member AddRectangle :
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 *
        fill : PdfColor *
        borderThickness : float32 *
        borderColor : PdfColor *
        borderType : PdfLineType -> RectangleElement
member AddRectangle :
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 *
        fill : PdfColor *
        borderThickness : float32 *
        borderColor : PdfColor *
        borderType : PdfLineType -> RectangleElement

Parameters

x1
Type: Online System Single
y1
Type: Online System Single
x2
Type: Online System Single
y2
Type: Online System Single
fill
Type: NFX.Media.PDF.Styling PdfColor
borderThickness
Type: Online System Single
borderColor
Type: NFX.Media.PDF.Styling PdfColor
borderType
Type: NFX.Media.PDF.Styling PdfLineType

Return Value

Type: RectangleElement
See Also
PdfPage Class
PdfPage Members
AddRectangle Overload
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddText Method

PdfPage AddText Method NFX Class Library

Overload List
 | Name | Description
Public method | AddText(String) | Add raw text to the page
Public method | AddText(String, Single, PdfFont) | Add raw text to the page
Public method | AddText(String, Single, PdfFont, PdfColor) | Add raw text to the page
Back to Top
See Also
PdfPage Class
PdfPage Members
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddText Method (String)

PdfPage AddText Method (String) NFX Class Library

Add raw text to the page

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TextElement AddText(
    string text
)
public TextElement AddText(
    string text
)
Public Function AddText (
    text As String
) As TextElement
Public Function AddText (
    text As String
) As TextElement
public:
TextElement^ AddText(
    String^ text
)
public:
TextElement^ AddText(
    String^ text
)
member AddText :
        text : string -> TextElement
member AddText :
        text : string -> TextElement

Parameters

text
Type: Online System String

Return Value

Type: TextElement
See Also
PdfPage Class
PdfPage Members
AddText Overload
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddText Method (String, Single, PdfFont)

PdfPage AddText Method (String, Single, PdfFont) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add raw text to the page

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TextElement AddText(
    string text,
    float fontSize,
    PdfFont font
)
public TextElement AddText(
    string text,
    float fontSize,
    PdfFont font
)
Public Function AddText (
    text As String,
    fontSize As Single,
    font As PdfFont
) As TextElement
Public Function AddText (
    text As String,
    fontSize As Single,
    font As PdfFont
) As TextElement
public:
TextElement^ AddText(
    String^ text,
    float fontSize,
    PdfFont^ font
)
public:
TextElement^ AddText(
    String^ text,
    float fontSize,
    PdfFont^ font
)
member AddText :
        text : string *
        fontSize : float32 *
        font : PdfFont -> TextElement
member AddText :
        text : string *
        fontSize : float32 *
        font : PdfFont -> TextElement

Parameters

text
Type: Online System String
fontSize
Type: Online System Single
font
Type: NFX.Media.PDF.DocumentModel PdfFont

Return Value

Type: TextElement
See Also
PdfPage Class
PdfPage Members
AddText Overload
NFX.Media.PDF.DocumentModel Namespace


PdfPage.AddText Method (String, Single, PdfFont, PdfColor)

PdfPage AddText Method (String, Single, PdfFont, PdfColor) NFX Class Library

[This is preliminary documentation and is subject to change.]

Add raw text to the page

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TextElement AddText(
    string text,
    float fontSize,
    PdfFont font,
    PdfColor foreground
)
public TextElement AddText(
    string text,
    float fontSize,
    PdfFont font,
    PdfColor foreground
)
Public Function AddText (
    text As String,
    fontSize As Single,
    font As PdfFont,
    foreground As PdfColor
) As TextElement
Public Function AddText (
    text As String,
    fontSize As Single,
    font As PdfFont,
    foreground As PdfColor
) As TextElement
public:
TextElement^ AddText(
    String^ text,
    float fontSize,
    PdfFont^ font,
    PdfColor^ foreground
)
public:
TextElement^ AddText(
    String^ text,
    float fontSize,
    PdfFont^ font,
    PdfColor^ foreground
)
member AddText :
        text : string *
        fontSize : float32 *
        font : PdfFont *
        foreground : PdfColor -> TextElement
member AddText :
        text : string *
        fontSize : float32 *
        font : PdfFont *
        foreground : PdfColor -> TextElement

Parameters

text
Type: Online System String
fontSize
Type: Online System Single
font
Type: NFX.Media.PDF.DocumentModel PdfFont
foreground
Type: NFX.Media.PDF.Styling PdfColor

Return Value

Type: TextElement
See Also
PdfPage Class
PdfPage Members
AddText Overload
NFX.Media.PDF.DocumentModel Namespace


PdfPage Properties

PdfPage Properties NFX Class Library

The PdfPage type exposes the following members.
Properties
 | Name | Description
Public property | Elements | Page elements
Protected property | Fonts | Fonts used on the page
Public property | Height | Page's height
Public property | ObjectId | Document-wide unique object Id (Inherited from PdfObject.)
Protected property | Parent | Page tree
Public property | UserUnit | User space units (the default user space unit is 1/72 inch)
Public property | Width | Page's width
Back to Top
See Also
PdfPage Class
NFX.Media.PDF.DocumentModel Namespace


PdfPage.Elements Property

PdfPage Elements Property NFX Class Library

Page elements

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<PdfElement> Elements { get; }
public List<PdfElement> Elements { get; }
Public ReadOnly Property Elements As List(Of PdfElement)
    Get
Public ReadOnly Property Elements As List(Of PdfElement)
    Get
public:
property List<PdfElement^>^ Elements {
    List<PdfElement^>^ get ();
}
public:
property List<PdfElement^>^ Elements {
    List<PdfElement^>^ get ();
}
member Elements : List<PdfElement> with get
member Elements : List<PdfElement> with get

Property Value

Type: Online List PdfElement
See Also
PdfPage Class
PdfPage Members
NFX.Media.PDF.DocumentModel Namespace


PdfPage.Fonts Property

PdfPage Fonts Property NFX Class Library

Fonts used on the page

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal List<PdfFont> Fonts { get; }
internal List<PdfFont> Fonts { get; }
Friend ReadOnly Property Fonts As List(Of PdfFont)
    Get
Friend ReadOnly Property Fonts As List(Of PdfFont)
    Get
internal:
property List<PdfFont^>^ Fonts {
    List<PdfFont^>^ get ();
}
internal:
property List<PdfFont^>^ Fonts {
    List<PdfFont^>^ get ();
}
internal member Fonts : List<PdfFont> with get
internal member Fonts : List<PdfFont> with get

Property Value

Type: Online List PdfFont
See Also
PdfPage Class
PdfPage Members
NFX.Media.PDF.DocumentModel Namespace


PdfPage.Height Property

PdfPage Height Property NFX Class Library

Page's height

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float Height { get; }
public float Height { get; }
Public ReadOnly Property Height As Single
    Get
Public ReadOnly Property Height As Single
    Get
public:
property float Height {
    float get ();
}
public:
property float Height {
    float get ();
}
member Height : float32 with get
member Height : float32 with get

Property Value

Type: Online Single
See Also
PdfPage Class
PdfPage Members
NFX.Media.PDF.DocumentModel Namespace


PdfPage.Parent Property

PdfPage Parent Property NFX Class Library

Page tree

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal PdfPageTree Parent { get; }
internal PdfPageTree Parent { get; }
Friend ReadOnly Property Parent As PdfPageTree
    Get
Friend ReadOnly Property Parent As PdfPageTree
    Get
internal:
property PdfPageTree^ Parent {
    PdfPageTree^ get ();
}
internal:
property PdfPageTree^ Parent {
    PdfPageTree^ get ();
}
internal member Parent : PdfPageTree with get
internal member Parent : PdfPageTree with get

Property Value

Type: PdfPageTree
See Also
PdfPage Class
PdfPage Members
NFX.Media.PDF.DocumentModel Namespace


PdfPage.UserUnit Property

PdfPage UserUnit Property NFX Class Library

User space units (the default user space unit is 1/72 inch)

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float UserUnit { get; }
public float UserUnit { get; }
Public ReadOnly Property UserUnit As Single
    Get
Public ReadOnly Property UserUnit As Single
    Get
public:
property float UserUnit {
    float get ();
}
public:
property float UserUnit {
    float get ();
}
member UserUnit : float32 with get
member UserUnit : float32 with get

Property Value

Type: Online Single
See Also
PdfPage Class
PdfPage Members
NFX.Media.PDF.DocumentModel Namespace


PdfPage.Width Property

PdfPage Width Property NFX Class Library

Page's width

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float Width { get; }
public float Width { get; }
Public ReadOnly Property Width As Single
    Get
Public ReadOnly Property Width As Single
    Get
public:
property float Width {
    float get ();
}
public:
property float Width {
    float get ();
}
member Width : float32 with get
member Width : float32 with get

Property Value

Type: Online Single
See Also
PdfPage Class
PdfPage Members
NFX.Media.PDF.DocumentModel Namespace


PdfPageTree Class

PdfPageTree Class NFX Class Library

PDF Page Tree document object
Inheritance Hierarchy
Online System Object
NFX.Media.PDF.DocumentModel PdfObject
NFX.Media.PDF.DocumentModel PdfPageTree

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class PdfPageTree : PdfObject
internal class PdfPageTree : PdfObject
Friend Class PdfPageTree
    Inherits PdfObject
Friend Class PdfPageTree
    Inherits PdfObject
internal ref class PdfPageTree : public PdfObject
internal ref class PdfPageTree : public PdfObject
type PdfPageTree =
    class
        inherit PdfObject
    end
type PdfPageTree =
    class
        inherit PdfObject
    end
See Also
PdfPageTree Members
NFX.Media.PDF.DocumentModel Namespace


PdfPageTree Members

PdfPageTree Members NFX Class Library

The PdfPageTree type exposes the following members.
Constructors
 | Name | Description
Public method | PdfPageTree | Initializes a new instance of the PdfPageTree class
Back to Top
Methods
 | Name | Description
Public method | CreatePage | Creates new page and adds it to the page tree
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReference | Returns PDF object indirect reference (Inherited from PdfObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ObjectId | Document-wide unique object Id (Inherited from PdfObject.)
Public property | Pages |
Back to Top
See Also
PdfPageTree Class
NFX.Media.PDF.DocumentModel Namespace


PdfPageTree Constructor

PdfPageTree Constructor NFX Class Library

Initializes a new instance of the PdfPageTree class

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfPageTree()
public PdfPageTree()
Public Sub New
Public Sub New
public:
PdfPageTree()
public:
PdfPageTree()
new : unit -> PdfPageTree
new : unit -> PdfPageTree
See Also
PdfPageTree Class
PdfPageTree Members
NFX.Media.PDF.DocumentModel Namespace


PdfPageTree Methods

PdfPageTree Methods NFX Class Library

The PdfPageTree type exposes the following members.
Methods
 | Name | Description
Public method | CreatePage | Creates new page and adds it to the page tree
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReference | Returns PDF object indirect reference (Inherited from PdfObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PdfPageTree Class
NFX.Media.PDF.DocumentModel Namespace


PdfPageTree.CreatePage Method

PdfPageTree CreatePage Method NFX Class Library

Creates new page and adds it to the page tree

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfPage CreatePage(
    PdfSize size
)
public PdfPage CreatePage(
    PdfSize size
)
Public Function CreatePage (
    size As PdfSize
) As PdfPage
Public Function CreatePage (
    size As PdfSize
) As PdfPage
public:
PdfPage^ CreatePage(
    PdfSize^ size
)
public:
PdfPage^ CreatePage(
    PdfSize^ size
)
member CreatePage :
        size : PdfSize -> PdfPage
member CreatePage :
        size : PdfSize -> PdfPage

Parameters

size
Type: NFX.Media.PDF.Styling PdfSize

Return Value

Type: PdfPage
See Also
PdfPageTree Class
PdfPageTree Members
NFX.Media.PDF.DocumentModel Namespace


PdfPageTree Properties

PdfPageTree Properties NFX Class Library

The PdfPageTree type exposes the following members.
Properties
 | Name | Description
Public property | ObjectId | Document-wide unique object Id (Inherited from PdfObject.)
Public property | Pages |
Back to Top
See Also
PdfPageTree Class
NFX.Media.PDF.DocumentModel Namespace


PdfPageTree.Pages Property

PdfPageTree Pages Property NFX Class Library

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<PdfPage> Pages { get; }
public List<PdfPage> Pages { get; }
Public ReadOnly Property Pages As List(Of PdfPage)
    Get
Public ReadOnly Property Pages As List(Of PdfPage)
    Get
public:
property List<PdfPage^>^ Pages {
    List<PdfPage^>^ get ();
}
public:
property List<PdfPage^>^ Pages {
    List<PdfPage^>^ get ();
}
member Pages : List<PdfPage> with get
member Pages : List<PdfPage> with get

Property Value

Type: Online List PdfPage
See Also
PdfPageTree Class
PdfPageTree Members
NFX.Media.PDF.DocumentModel Namespace


PdfRoot Class

PdfRoot Class NFX Class Library

PDF document header
Inheritance Hierarchy
Online System Object
NFX.Media.PDF.DocumentModel PdfObject
NFX.Media.PDF.DocumentModel PdfRoot

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class PdfRoot : PdfObject
internal class PdfRoot : PdfObject
Friend Class PdfRoot
    Inherits PdfObject
Friend Class PdfRoot
    Inherits PdfObject
internal ref class PdfRoot : public PdfObject
internal ref class PdfRoot : public PdfObject
type PdfRoot =
    class
        inherit PdfObject
    end
type PdfRoot =
    class
        inherit PdfObject
    end
See Also
PdfRoot Members
NFX.Media.PDF.DocumentModel Namespace


PdfRoot Members

PdfRoot Members NFX Class Library

The PdfRoot type exposes the following members.
Constructors
 | Name | Description
Public method | PdfRoot | Initializes a new instance of the PdfRoot class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReference | Returns PDF object indirect reference (Inherited from PdfObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Info | Document info's object Id
Public property | ObjectId | Document-wide unique object Id (Inherited from PdfObject.)
Public property | Outlines | Document outlines' object Id
Public property | PageTree | Document page tree's object Id
Back to Top
See Also
PdfRoot Class
NFX.Media.PDF.DocumentModel Namespace


PdfRoot Constructor

PdfRoot Constructor NFX Class Library

Initializes a new instance of the PdfRoot class

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfRoot()
public PdfRoot()
Public Sub New
Public Sub New
public:
PdfRoot()
public:
PdfRoot()
new : unit -> PdfRoot
new : unit -> PdfRoot
See Also
PdfRoot Class
PdfRoot Members
NFX.Media.PDF.DocumentModel Namespace


PdfRoot Methods

PdfRoot Methods NFX Class Library

The PdfRoot type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReference | Returns PDF object indirect reference (Inherited from PdfObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PdfRoot Class
NFX.Media.PDF.DocumentModel Namespace


PdfRoot Properties

PdfRoot Properties NFX Class Library

The PdfRoot type exposes the following members.
Properties
 | Name | Description
Public property | Info | Document info's object Id
Public property | ObjectId | Document-wide unique object Id (Inherited from PdfObject.)
Public property | Outlines | Document outlines' object Id
Public property | PageTree | Document page tree's object Id
Back to Top
See Also
PdfRoot Class
NFX.Media.PDF.DocumentModel Namespace


PdfRoot.Info Property

PdfRoot Info Property NFX Class Library

Document info's object Id

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfInfo Info { get; set; }
public PdfInfo Info { get; set; }
Public Property Info As PdfInfo
    Get
    Set
Public Property Info As PdfInfo
    Get
    Set
public:
property PdfInfo^ Info {
    PdfInfo^ get ();
    void set (PdfInfo^ value);
}
public:
property PdfInfo^ Info {
    PdfInfo^ get ();
    void set (PdfInfo^ value);
}
member Info : PdfInfo with get, set
member Info : PdfInfo with get, set

Property Value

Type: PdfInfo
See Also
PdfRoot Class
PdfRoot Members
NFX.Media.PDF.DocumentModel Namespace


PdfRoot.Outlines Property

PdfRoot Outlines Property NFX Class Library

Document outlines' object Id

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfOutlines Outlines { get; set; }
public PdfOutlines Outlines { get; set; }
Public Property Outlines As PdfOutlines
    Get
    Set
Public Property Outlines As PdfOutlines
    Get
    Set
public:
property PdfOutlines^ Outlines {
    PdfOutlines^ get ();
    void set (PdfOutlines^ value);
}
public:
property PdfOutlines^ Outlines {
    PdfOutlines^ get ();
    void set (PdfOutlines^ value);
}
member Outlines : PdfOutlines with get, set
member Outlines : PdfOutlines with get, set

Property Value

Type: PdfOutlines
See Also
PdfRoot Class
PdfRoot Members
NFX.Media.PDF.DocumentModel Namespace


PdfRoot.PageTree Property

PdfRoot PageTree Property NFX Class Library

Document page tree's object Id

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfPageTree PageTree { get; set; }
public PdfPageTree PageTree { get; set; }
Public Property PageTree As PdfPageTree
    Get
    Set
Public Property PageTree As PdfPageTree
    Get
    Set
public:
property PdfPageTree^ PageTree {
    PdfPageTree^ get ();
    void set (PdfPageTree^ value);
}
public:
property PdfPageTree^ PageTree {
    PdfPageTree^ get ();
    void set (PdfPageTree^ value);
}
member PageTree : PdfPageTree with get, set
member PageTree : PdfPageTree with get, set

Property Value

Type: PdfPageTree
See Also
PdfRoot Class
PdfRoot Members
NFX.Media.PDF.DocumentModel Namespace


PdfTrailer Class

PdfTrailer Class NFX Class Library

PDF Trailer document object
Inheritance Hierarchy
Online System Object
NFX.Media.PDF.DocumentModel PdfObject
NFX.Media.PDF.DocumentModel PdfTrailer

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class PdfTrailer : PdfObject
internal class PdfTrailer : PdfObject
Friend Class PdfTrailer
    Inherits PdfObject
Friend Class PdfTrailer
    Inherits PdfObject
internal ref class PdfTrailer : public PdfObject
internal ref class PdfTrailer : public PdfObject
type PdfTrailer =
    class
        inherit PdfObject
    end
type PdfTrailer =
    class
        inherit PdfObject
    end
See Also
PdfTrailer Members
NFX.Media.PDF.DocumentModel Namespace


PdfTrailer Members

PdfTrailer Members NFX Class Library

The PdfTrailer type exposes the following members.
Constructors
 | Name | Description
Public method | PdfTrailer | Initializes a new instance of the PdfTrailer class
Back to Top
Methods
 | Name | Description
Public method | AddObjectOffset | Add inserted object offset to offsets collection
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReference | Returns PDF object indirect reference (Inherited from PdfObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | LastObjectId | Id of the last inserted document object
Public property | ObjectId | Document-wide unique object Id (Inherited from PdfObject.)
Public property | ObjectOffsets | Inserted objects offest in PDF format
Public property | Root | PDF document's root
Public property | XRefOffset | The offset of the XREF table
Back to Top
See Also
PdfTrailer Class
NFX.Media.PDF.DocumentModel Namespace


PdfTrailer Constructor

PdfTrailer Constructor NFX Class Library

Initializes a new instance of the PdfTrailer class

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfTrailer()
public PdfTrailer()
Public Sub New
Public Sub New
public:
PdfTrailer()
public:
PdfTrailer()
new : unit -> PdfTrailer
new : unit -> PdfTrailer
See Also
PdfTrailer Class
PdfTrailer Members
NFX.Media.PDF.DocumentModel Namespace


PdfTrailer Methods

PdfTrailer Methods NFX Class Library

The PdfTrailer type exposes the following members.
Methods
 | Name | Description
Public method | AddObjectOffset | Add inserted object offset to offsets collection
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReference | Returns PDF object indirect reference (Inherited from PdfObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PdfTrailer Class
NFX.Media.PDF.DocumentModel Namespace


PdfTrailer.AddObjectOffset Method

PdfTrailer AddObjectOffset Method NFX Class Library

Add inserted object offset to offsets collection

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddObjectOffset(
    long offset
)
public void AddObjectOffset(
    long offset
)
Public Sub AddObjectOffset (
    offset As Long
)
Public Sub AddObjectOffset (
    offset As Long
)
public:
void AddObjectOffset(
    long long offset
)
public:
void AddObjectOffset(
    long long offset
)
member AddObjectOffset :
        offset : int64 -> unit
member AddObjectOffset :
        offset : int64 -> unit

Parameters

offset
Type: Online System Int64
Offset
See Also
PdfTrailer Class
PdfTrailer Members
NFX.Media.PDF.DocumentModel Namespace


PdfTrailer Properties

PdfTrailer Properties NFX Class Library

The PdfTrailer type exposes the following members.
Properties
 | Name | Description
Public property | LastObjectId | Id of the last inserted document object
Public property | ObjectId | Document-wide unique object Id (Inherited from PdfObject.)
Public property | ObjectOffsets | Inserted objects offest in PDF format
Public property | Root | PDF document's root
Public property | XRefOffset | The offset of the XREF table
Back to Top
See Also
PdfTrailer Class
NFX.Media.PDF.DocumentModel Namespace


PdfTrailer.LastObjectId Property

PdfTrailer LastObjectId Property NFX Class Library

Id of the last inserted document object

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int LastObjectId { get; set; }
public int LastObjectId { get; set; }
Public Property LastObjectId As Integer
    Get
    Set
Public Property LastObjectId As Integer
    Get
    Set
public:
property int LastObjectId {
    int get ();
    void set (int value);
}
public:
property int LastObjectId {
    int get ();
    void set (int value);
}
member LastObjectId : int with get, set
member LastObjectId : int with get, set

Property Value

Type: Online Int32
See Also
PdfTrailer Class
PdfTrailer Members
NFX.Media.PDF.DocumentModel Namespace


PdfTrailer.ObjectOffsets Property

PdfTrailer ObjectOffsets Property NFX Class Library

Inserted objects offest in PDF format

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<string> ObjectOffsets { get; }
public List<string> ObjectOffsets { get; }
Public ReadOnly Property ObjectOffsets As List(Of String)
    Get
Public ReadOnly Property ObjectOffsets As List(Of String)
    Get
public:
property List<String^>^ ObjectOffsets {
    List<String^>^ get ();
}
public:
property List<String^>^ ObjectOffsets {
    List<String^>^ get ();
}
member ObjectOffsets : List<string> with get
member ObjectOffsets : List<string> with get

Property Value

Type: Online List Online String
See Also
PdfTrailer Class
PdfTrailer Members
NFX.Media.PDF.DocumentModel Namespace


PdfTrailer.Root Property

PdfTrailer Root Property NFX Class Library

PDF document's root

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfRoot Root { get; set; }
public PdfRoot Root { get; set; }
Public Property Root As PdfRoot
    Get
    Set
Public Property Root As PdfRoot
    Get
    Set
public:
property PdfRoot^ Root {
    PdfRoot^ get ();
    void set (PdfRoot^ value);
}
public:
property PdfRoot^ Root {
    PdfRoot^ get ();
    void set (PdfRoot^ value);
}
member Root : PdfRoot with get, set
member Root : PdfRoot with get, set

Property Value

Type: PdfRoot
See Also
PdfTrailer Class
PdfTrailer Members
NFX.Media.PDF.DocumentModel Namespace


PdfTrailer.XRefOffset Property

PdfTrailer XRefOffset Property NFX Class Library

The offset of the XREF table

Namespace: NFX.Media.PDF.DocumentModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long XRefOffset { get; set; }
public long XRefOffset { get; set; }
Public Property XRefOffset As Long
    Get
    Set
Public Property XRefOffset As Long
    Get
    Set
public:
property long long XRefOffset {
    long long get ();
    void set (long long value);
}
public:
property long long XRefOffset {
    long long get ();
    void set (long long value);
}
member XRefOffset : int64 with get, set
member XRefOffset : int64 with get, set

Property Value

Type: Online Int64
See Also
PdfTrailer Class
PdfTrailer Members
NFX.Media.PDF.DocumentModel Namespace


NFX.Media.PDF.Elements Namespace

NFX.Media.PDF.Elements Namespace NFX Class Library

Classes
 | Class | Description
Public class | BezierPrimitive | PDF Bezier curve primitive as a part of path
Public class | ImageElement | PDF image element
Public class | LinePrimitive | PDF line primitive as a part of path
Public class | PathElement | PDF path element as a collection of path primitives (lines, Bezier curves etc.)
Public class | PathPrimitive | PDF path primitive (a line, Bezier curve,...) as a part of path
Public class | PdfElement | Base class for all PDF primitives
Public class | RectangleElement |
Public class | TextElement | PDF text element


BezierPrimitive Class

BezierPrimitive Class NFX Class Library

PDF Bezier curve primitive as a part of path
Inheritance Hierarchy
Online System Object
NFX.Media.PDF.Elements PathPrimitive
NFX.Media.PDF.Elements BezierPrimitive

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class BezierPrimitive : PathPrimitive
public class BezierPrimitive : PathPrimitive
Public Class BezierPrimitive
    Inherits PathPrimitive
Public Class BezierPrimitive
    Inherits PathPrimitive
public ref class BezierPrimitive : public PathPrimitive
public ref class BezierPrimitive : public PathPrimitive
type BezierPrimitive =
    class
        inherit PathPrimitive
    end
type BezierPrimitive =
    class
        inherit PathPrimitive
    end
See Also
BezierPrimitive Members
NFX.Media.PDF.Elements Namespace


BezierPrimitive Members

BezierPrimitive Members NFX Class Library

The BezierPrimitive type exposes the following members.
Constructors
 | Name | Description
Public method | BezierPrimitive | Initializes a new instance of the BezierPrimitive class
Public method | BezierPrimitive(Single, Single, Single, Single, Single, Single) | Initializes a new instance of the BezierPrimitive class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToPdfString | Returns PDF string representation on the line primitive (Overrides PathPrimitive ToPdfString .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | EndX | X coordinate of Bezier's curve last point
Public property | EndY | Y coordinate of Bezier's curve last point
Public property | FirstControlX | X coordinate of Bezier's curve first control point
Public property | FirstControlY | Y coordinate of Bezier's curve first control point
Public property | SecondControlX | X coordinate of Bezier's curve second control point
Public property | SecondControlY | Y coordinate of Bezier's curve second control point
Back to Top
See Also
BezierPrimitive Class
NFX.Media.PDF.Elements Namespace


BezierPrimitive Constructor

BezierPrimitive Constructor NFX Class Library

Overload List
 | Name | Description
Public method | BezierPrimitive | Initializes a new instance of the BezierPrimitive class
Public method | BezierPrimitive(Single, Single, Single, Single, Single, Single) | Initializes a new instance of the BezierPrimitive class
Back to Top
See Also
BezierPrimitive Class
BezierPrimitive Members
NFX.Media.PDF.Elements Namespace


BezierPrimitive Constructor

BezierPrimitive Constructor NFX Class Library

Initializes a new instance of the BezierPrimitive class

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BezierPrimitive()
public BezierPrimitive()
Public Sub New
Public Sub New
public:
BezierPrimitive()
public:
BezierPrimitive()
new : unit -> BezierPrimitive
new : unit -> BezierPrimitive
See Also
BezierPrimitive Class
BezierPrimitive Members
BezierPrimitive Overload
NFX.Media.PDF.Elements Namespace


BezierPrimitive Constructor (Single, Single, Single, Single, Single, Single)

BezierPrimitive Constructor (Single, Single, Single, Single, Single, Single) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BezierPrimitive class

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BezierPrimitive(
    float firstControlX,
    float firstControlY,
    float secondControlX,
    float secondControlY,
    float endX,
    float endY
)
public BezierPrimitive(
    float firstControlX,
    float firstControlY,
    float secondControlX,
    float secondControlY,
    float endX,
    float endY
)
Public Sub New (
    firstControlX As Single,
    firstControlY As Single,
    secondControlX As Single,
    secondControlY As Single,
    endX As Single,
    endY As Single
)
Public Sub New (
    firstControlX As Single,
    firstControlY As Single,
    secondControlX As Single,
    secondControlY As Single,
    endX As Single,
    endY As Single
)
public:
BezierPrimitive(
    float firstControlX,
    float firstControlY,
    float secondControlX,
    float secondControlY,
    float endX,
    float endY
)
public:
BezierPrimitive(
    float firstControlX,
    float firstControlY,
    float secondControlX,
    float secondControlY,
    float endX,
    float endY
)
new :
        firstControlX : float32 *
        firstControlY : float32 *
        secondControlX : float32 *
        secondControlY : float32 *
        endX : float32 *
        endY : float32 -> BezierPrimitive
new :
        firstControlX : float32 *
        firstControlY : float32 *
        secondControlX : float32 *
        secondControlY : float32 *
        endX : float32 *
        endY : float32 -> BezierPrimitive

Parameters

firstControlX
Type: Online System Single
firstControlY
Type: Online System Single
secondControlX
Type: Online System Single
secondControlY
Type: Online System Single
endX
Type: Online System Single
endY
Type: Online System Single
See Also
BezierPrimitive Class
BezierPrimitive Members
BezierPrimitive Overload
NFX.Media.PDF.Elements Namespace


BezierPrimitive Methods

BezierPrimitive Methods NFX Class Library

The BezierPrimitive type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToPdfString | Returns PDF string representation on the line primitive (Overrides PathPrimitive ToPdfString .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BezierPrimitive Class
NFX.Media.PDF.Elements Namespace


BezierPrimitive.ToPdfString Method

BezierPrimitive ToPdfString Method NFX Class Library

Returns PDF string representation on the line primitive

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToPdfString()
public override string ToPdfString()
Public Overrides Function ToPdfString As String
Public Overrides Function ToPdfString As String
public:
virtual String^ ToPdfString() override
public:
virtual String^ ToPdfString() override
abstract ToPdfString : unit -> string
override ToPdfString : unit -> string
abstract ToPdfString : unit -> string
override ToPdfString : unit -> string

Return Value

Type: Online String

Implements

IPdfWritable ToPdfString
See Also
BezierPrimitive Class
BezierPrimitive Members
NFX.Media.PDF.Elements Namespace


BezierPrimitive Properties

BezierPrimitive Properties NFX Class Library

The BezierPrimitive type exposes the following members.
Properties
 | Name | Description
Public property | EndX | X coordinate of Bezier's curve last point
Public property | EndY | Y coordinate of Bezier's curve last point
Public property | FirstControlX | X coordinate of Bezier's curve first control point
Public property | FirstControlY | Y coordinate of Bezier's curve first control point
Public property | SecondControlX | X coordinate of Bezier's curve second control point
Public property | SecondControlY | Y coordinate of Bezier's curve second control point
Back to Top
See Also
BezierPrimitive Class
NFX.Media.PDF.Elements Namespace


BezierPrimitive.EndX Property

BezierPrimitive EndX Property NFX Class Library

X coordinate of Bezier's curve last point

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float EndX { get; set; }
public float EndX { get; set; }
Public Property EndX As Single
    Get
    Set
Public Property EndX As Single
    Get
    Set
public:
property float EndX {
    float get ();
    void set (float value);
}
public:
property float EndX {
    float get ();
    void set (float value);
}
member EndX : float32 with get, set
member EndX : float32 with get, set

Property Value

Type: Online Single
See Also
BezierPrimitive Class
BezierPrimitive Members
NFX.Media.PDF.Elements Namespace


BezierPrimitive.EndY Property

BezierPrimitive EndY Property NFX Class Library

Y coordinate of Bezier's curve last point

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float EndY { get; set; }
public float EndY { get; set; }
Public Property EndY As Single
    Get
    Set
Public Property EndY As Single
    Get
    Set
public:
property float EndY {
    float get ();
    void set (float value);
}
public:
property float EndY {
    float get ();
    void set (float value);
}
member EndY : float32 with get, set
member EndY : float32 with get, set

Property Value

Type: Online Single
See Also
BezierPrimitive Class
BezierPrimitive Members
NFX.Media.PDF.Elements Namespace


BezierPrimitive.FirstControlX Property

BezierPrimitive FirstControlX Property NFX Class Library

X coordinate of Bezier's curve first control point

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float FirstControlX { get; set; }
public float FirstControlX { get; set; }
Public Property FirstControlX As Single
    Get
    Set
Public Property FirstControlX As Single
    Get
    Set
public:
property float FirstControlX {
    float get ();
    void set (float value);
}
public:
property float FirstControlX {
    float get ();
    void set (float value);
}
member FirstControlX : float32 with get, set
member FirstControlX : float32 with get, set

Property Value

Type: Online Single
See Also
BezierPrimitive Class
BezierPrimitive Members
NFX.Media.PDF.Elements Namespace


BezierPrimitive.FirstControlY Property

BezierPrimitive FirstControlY Property NFX Class Library

Y coordinate of Bezier's curve first control point

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float FirstControlY { get; set; }
public float FirstControlY { get; set; }
Public Property FirstControlY As Single
    Get
    Set
Public Property FirstControlY As Single
    Get
    Set
public:
property float FirstControlY {
    float get ();
    void set (float value);
}
public:
property float FirstControlY {
    float get ();
    void set (float value);
}
member FirstControlY : float32 with get, set
member FirstControlY : float32 with get, set

Property Value

Type: Online Single
See Also
BezierPrimitive Class
BezierPrimitive Members
NFX.Media.PDF.Elements Namespace


BezierPrimitive.SecondControlX Property

BezierPrimitive SecondControlX Property NFX Class Library

X coordinate of Bezier's curve second control point

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float SecondControlX { get; set; }
public float SecondControlX { get; set; }
Public Property SecondControlX As Single
    Get
    Set
Public Property SecondControlX As Single
    Get
    Set
public:
property float SecondControlX {
    float get ();
    void set (float value);
}
public:
property float SecondControlX {
    float get ();
    void set (float value);
}
member SecondControlX : float32 with get, set
member SecondControlX : float32 with get, set

Property Value

Type: Online Single
See Also
BezierPrimitive Class
BezierPrimitive Members
NFX.Media.PDF.Elements Namespace


BezierPrimitive.SecondControlY Property

BezierPrimitive SecondControlY Property NFX Class Library

Y coordinate of Bezier's curve second control point

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float SecondControlY { get; set; }
public float SecondControlY { get; set; }
Public Property SecondControlY As Single
    Get
    Set
Public Property SecondControlY As Single
    Get
    Set
public:
property float SecondControlY {
    float get ();
    void set (float value);
}
public:
property float SecondControlY {
    float get ();
    void set (float value);
}
member SecondControlY : float32 with get, set
member SecondControlY : float32 with get, set

Property Value

Type: Online Single
See Also
BezierPrimitive Class
BezierPrimitive Members
NFX.Media.PDF.Elements Namespace


ImageElement Class

ImageElement Class NFX Class Library

PDF image element
Inheritance Hierarchy
Online System Object
NFX.Media.PDF.DocumentModel PdfObject
NFX.Media.PDF.Elements PdfElement
NFX.Media.PDF.Elements ImageElement

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ImageElement : PdfElement,
    IPdfXObject
public class ImageElement : PdfElement,
    IPdfXObject
Public Class ImageElement
    Inherits PdfElement
    Implements IPdfXObject
Public Class ImageElement
    Inherits PdfElement
    Implements IPdfXObject
public ref class ImageElement : public PdfElement,
    IPdfXObject
public ref class ImageElement : public PdfElement,
    IPdfXObject
type ImageElement =
    class
        inherit PdfElement
        interface IPdfXObject
    end
type ImageElement =
    class
        inherit PdfElement
        interface IPdfXObject
    end
See Also
ImageElement Members
NFX.Media.PDF.Elements Namespace


ImageElement Members

ImageElement Members NFX Class Library

The ImageElement type exposes the following members.
Constructors
 | Name | Description
Public method | ImageElement(String) | Initializes a new instance of the ImageElement class
Public method | ImageElement(String, Single, Single) | Initializes a new instance of the ImageElement class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetCoupledReference |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReference | Returns PDF object indirect reference (Inherited from PdfObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetXReference | Returns PDF x-object indirect reference
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write | Writes element into file stream (Overrides PdfElement Write(PdfWriter).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | BitsPerPixel | Returns image's bits per pixel
Public property | Content | Image bytes
Public property | Height | PDF displayed image height
Public property | ObjectId | Document-wide unique object Id (Inherited from PdfObject.)
Public property | OwnHeight | Image's own height
Public property | OwnWidth | Image's own widht
Public property | Width | PDF displayed image width
Public property | X | X-coordinate (Inherited from PdfElement.)
Public property | XObjectId | Image unique object Id
Public property | Y | Y-coordinate (Inherited from PdfElement.)
Back to Top
See Also
ImageElement Class
NFX.Media.PDF.Elements Namespace


ImageElement Constructor

ImageElement Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ImageElement(String) | Initializes a new instance of the ImageElement class
Public method | ImageElement(String, Single, Single) | Initializes a new instance of the ImageElement class
Back to Top
See Also
ImageElement Class
ImageElement Members
NFX.Media.PDF.Elements Namespace


ImageElement Constructor (String)

ImageElement Constructor (String) NFX Class Library

Initializes a new instance of the ImageElement class

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ImageElement(
    string filePath
)
public ImageElement(
    string filePath
)
Public Sub New (
    filePath As String
)
Public Sub New (
    filePath As String
)
public:
ImageElement(
    String^ filePath
)
public:
ImageElement(
    String^ filePath
)
new :
        filePath : string -> ImageElement
new :
        filePath : string -> ImageElement

Parameters

filePath
Type: Online System String
See Also
ImageElement Class
ImageElement Members
ImageElement Overload
NFX.Media.PDF.Elements Namespace


ImageElement Constructor (String, Single, Single)

ImageElement Constructor (String, Single, Single) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ImageElement class

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ImageElement(
    string filePath,
    float width,
    float height
)
public ImageElement(
    string filePath,
    float width,
    float height
)
Public Sub New (
    filePath As String,
    width As Single,
    height As Single
)
Public Sub New (
    filePath As String,
    width As Single,
    height As Single
)
public:
ImageElement(
    String^ filePath,
    float width,
    float height
)
public:
ImageElement(
    String^ filePath,
    float width,
    float height
)
new :
        filePath : string *
        width : float32 *
        height : float32 -> ImageElement
new :
        filePath : string *
        width : float32 *
        height : float32 -> ImageElement

Parameters

filePath
Type: Online System String
width
Type: Online System Single
height
Type: Online System Single
See Also
ImageElement Class
ImageElement Members
ImageElement Overload
NFX.Media.PDF.Elements Namespace


ImageElement Methods

ImageElement Methods NFX Class Library

The ImageElement type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetCoupledReference |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReference | Returns PDF object indirect reference (Inherited from PdfObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetXReference | Returns PDF x-object indirect reference
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write | Writes element into file stream (Overrides PdfElement Write(PdfWriter).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ImageElement Class
NFX.Media.PDF.Elements Namespace


ImageElement.GetCoupledReference Method

ImageElement GetCoupledReference Method NFX Class Library

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetCoupledReference()
public string GetCoupledReference()
Public Function GetCoupledReference As String
Public Function GetCoupledReference As String
public:
String^ GetCoupledReference()
public:
String^ GetCoupledReference()
member GetCoupledReference : unit -> string
member GetCoupledReference : unit -> string

Return Value

Type: Online String
See Also
ImageElement Class
ImageElement Members
NFX.Media.PDF.Elements Namespace


ImageElement.GetXReference Method

ImageElement GetXReference Method NFX Class Library

Returns PDF x-object indirect reference

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetXReference()
public string GetXReference()
Public Function GetXReference As String
Public Function GetXReference As String
public:
virtual String^ GetXReference() sealed
public:
virtual String^ GetXReference() sealed
abstract GetXReference : unit -> string
override GetXReference : unit -> string
abstract GetXReference : unit -> string
override GetXReference : unit -> string

Return Value

Type: Online String

Implements

IPdfXObject GetXReference
See Also
ImageElement Class
ImageElement Members
NFX.Media.PDF.Elements Namespace


ImageElement.Write Method

ImageElement Write Method NFX Class Library

Writes element into file stream

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    PdfWriter writer
)
public override void Write(
    PdfWriter writer
)
Public Overrides Sub Write (
    writer As PdfWriter
)
Public Overrides Sub Write (
    writer As PdfWriter
)
public:
virtual void Write(
    PdfWriter^ writer
) override
public:
virtual void Write(
    PdfWriter^ writer
) override
abstract Write :
        writer : PdfWriter -> unit
override Write :
        writer : PdfWriter -> unit
abstract Write :
        writer : PdfWriter -> unit
override Write :
        writer : PdfWriter -> unit

Parameters

writer
Type: NFX.Media.PDF PdfWriter
PDF writer

Return Value

Type:
Written bytes count
See Also
ImageElement Class
ImageElement Members
NFX.Media.PDF.Elements Namespace


ImageElement Properties

ImageElement Properties NFX Class Library

The ImageElement type exposes the following members.
Properties
 | Name | Description
Public property | BitsPerPixel | Returns image's bits per pixel
Public property | Content | Image bytes
Public property | Height | PDF displayed image height
Public property | ObjectId | Document-wide unique object Id (Inherited from PdfObject.)
Public property | OwnHeight | Image's own height
Public property | OwnWidth | Image's own widht
Public property | Width | PDF displayed image width
Public property | X | X-coordinate (Inherited from PdfElement.)
Public property | XObjectId | Image unique object Id
Public property | Y | Y-coordinate (Inherited from PdfElement.)
Back to Top
See Also
ImageElement Class
NFX.Media.PDF.Elements Namespace


ImageElement.BitsPerPixel Property

ImageElement BitsPerPixel Property NFX Class Library

Returns image's bits per pixel

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int BitsPerPixel { get; private set; }
public int BitsPerPixel { get; private set; }
Public Property BitsPerPixel As Integer
    Get
    Private Set
Public Property BitsPerPixel As Integer
    Get
    Private Set
public:
property int BitsPerPixel {
    int get ();
    private: void set (int value);
}
public:
property int BitsPerPixel {
    int get ();
    private: void set (int value);
}
member BitsPerPixel : int with get, private set
member BitsPerPixel : int with get, private set

Property Value

Type: Online Int32
See Also
ImageElement Class
ImageElement Members
NFX.Media.PDF.Elements Namespace


ImageElement.Content Property

ImageElement Content Property NFX Class Library

Image bytes

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] Content { get; private set; }
public byte[] Content { get; private set; }
Public Property Content As Byte()
    Get
    Private Set
Public Property Content As Byte()
    Get
    Private Set
public:
property array<unsigned char>^ Content {
    array<unsigned char>^ get ();
    private: void set (array<unsigned char>^ value);
}
public:
property array<unsigned char>^ Content {
    array<unsigned char>^ get ();
    private: void set (array<unsigned char>^ value);
}
member Content : byte[] with get, private set
member Content : byte[] with get, private set

Property Value

Type: Online Byte
See Also
ImageElement Class
ImageElement Members
NFX.Media.PDF.Elements Namespace


ImageElement.Height Property

ImageElement Height Property NFX Class Library

PDF displayed image height

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float Height { get; private set; }
public float Height { get; private set; }
Public Property Height As Single
    Get
    Private Set
Public Property Height As Single
    Get
    Private Set
public:
property float Height {
    float get ();
    private: void set (float value);
}
public:
property float Height {
    float get ();
    private: void set (float value);
}
member Height : float32 with get, private set
member Height : float32 with get, private set

Property Value

Type: Online Single
See Also
ImageElement Class
ImageElement Members
NFX.Media.PDF.Elements Namespace


ImageElement.OwnHeight Property

ImageElement OwnHeight Property NFX Class Library

Image's own height

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float OwnHeight { get; private set; }
public float OwnHeight { get; private set; }
Public Property OwnHeight As Single
    Get
    Private Set
Public Property OwnHeight As Single
    Get
    Private Set
public:
property float OwnHeight {
    float get ();
    private: void set (float value);
}
public:
property float OwnHeight {
    float get ();
    private: void set (float value);
}
member OwnHeight : float32 with get, private set
member OwnHeight : float32 with get, private set

Property Value

Type: Online Single
See Also
ImageElement Class
ImageElement Members
NFX.Media.PDF.Elements Namespace


ImageElement.OwnWidth Property

ImageElement OwnWidth Property NFX Class Library

Image's own widht

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float OwnWidth { get; private set; }
public float OwnWidth { get; private set; }
Public Property OwnWidth As Single
    Get
    Private Set
Public Property OwnWidth As Single
    Get
    Private Set
public:
property float OwnWidth {
    float get ();
    private: void set (float value);
}
public:
property float OwnWidth {
    float get ();
    private: void set (float value);
}
member OwnWidth : float32 with get, private set
member OwnWidth : float32 with get, private set

Property Value

Type: Online Single
See Also
ImageElement Class
ImageElement Members
NFX.Media.PDF.Elements Namespace


ImageElement.Width Property

ImageElement Width Property NFX Class Library

PDF displayed image width

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float Width { get; private set; }
public float Width { get; private set; }
Public Property Width As Single
    Get
    Private Set
Public Property Width As Single
    Get
    Private Set
public:
property float Width {
    float get ();
    private: void set (float value);
}
public:
property float Width {
    float get ();
    private: void set (float value);
}
member Width : float32 with get, private set
member Width : float32 with get, private set

Property Value

Type: Online Single
See Also
ImageElement Class
ImageElement Members
NFX.Media.PDF.Elements Namespace


ImageElement.XObjectId Property

ImageElement XObjectId Property NFX Class Library

Image unique object Id

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int XObjectId { get; set; }
public int XObjectId { get; set; }
Public Property XObjectId As Integer
    Get
    Set
Public Property XObjectId As Integer
    Get
    Set
public:
virtual property int XObjectId {
    int get () sealed;
    void set (int value) sealed;
}
public:
virtual property int XObjectId {
    int get () sealed;
    void set (int value) sealed;
}
abstract XObjectId : int with get, set
override XObjectId : int with get, set
abstract XObjectId : int with get, set
override XObjectId : int with get, set

Property Value

Type: Online Int32

Implements

IPdfXObject XObjectId
See Also
ImageElement Class
ImageElement Members
NFX.Media.PDF.Elements Namespace


LinePrimitive Class

LinePrimitive Class NFX Class Library

PDF line primitive as a part of path
Inheritance Hierarchy
Online System Object
NFX.Media.PDF.Elements PathPrimitive
NFX.Media.PDF.Elements LinePrimitive

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LinePrimitive : PathPrimitive
public class LinePrimitive : PathPrimitive
Public Class LinePrimitive
    Inherits PathPrimitive
Public Class LinePrimitive
    Inherits PathPrimitive
public ref class LinePrimitive : public PathPrimitive
public ref class LinePrimitive : public PathPrimitive
type LinePrimitive =
    class
        inherit PathPrimitive
    end
type LinePrimitive =
    class
        inherit PathPrimitive
    end
See Also
LinePrimitive Members
NFX.Media.PDF.Elements Namespace


LinePrimitive Members

LinePrimitive Members NFX Class Library

The LinePrimitive type exposes the following members.
Constructors
 | Name | Description
Public method | LinePrimitive | Initializes a new instance of the LinePrimitive class
Public method | LinePrimitive(Single, Single) | Initializes a new instance of the LinePrimitive class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToPdfString | Returns PDF string representation on the line primitive (Overrides PathPrimitive ToPdfString .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | EndX | Line's end X coordinate
Public property | EndY | Line's end Y coordinate
Back to Top
See Also
LinePrimitive Class
NFX.Media.PDF.Elements Namespace


LinePrimitive Constructor

LinePrimitive Constructor NFX Class Library

Overload List
 | Name | Description
Public method | LinePrimitive | Initializes a new instance of the LinePrimitive class
Public method | LinePrimitive(Single, Single) | Initializes a new instance of the LinePrimitive class
Back to Top
See Also
LinePrimitive Class
LinePrimitive Members
NFX.Media.PDF.Elements Namespace


LinePrimitive Constructor

LinePrimitive Constructor NFX Class Library

Initializes a new instance of the LinePrimitive class

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LinePrimitive()
public LinePrimitive()
Public Sub New
Public Sub New
public:
LinePrimitive()
public:
LinePrimitive()
new : unit -> LinePrimitive
new : unit -> LinePrimitive
See Also
LinePrimitive Class
LinePrimitive Members
LinePrimitive Overload
NFX.Media.PDF.Elements Namespace


LinePrimitive Constructor (Single, Single)

LinePrimitive Constructor (Single, Single) NFX Class Library

Initializes a new instance of the LinePrimitive class

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LinePrimitive(
    float endX,
    float endY
)
public LinePrimitive(
    float endX,
    float endY
)
Public Sub New (
    endX As Single,
    endY As Single
)
Public Sub New (
    endX As Single,
    endY As Single
)
public:
LinePrimitive(
    float endX,
    float endY
)
public:
LinePrimitive(
    float endX,
    float endY
)
new :
        endX : float32 *
        endY : float32 -> LinePrimitive
new :
        endX : float32 *
        endY : float32 -> LinePrimitive

Parameters

endX
Type: Online System Single
endY
Type: Online System Single
See Also
LinePrimitive Class
LinePrimitive Members
LinePrimitive Overload
NFX.Media.PDF.Elements Namespace


LinePrimitive Methods

LinePrimitive Methods NFX Class Library

The LinePrimitive type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToPdfString | Returns PDF string representation on the line primitive (Overrides PathPrimitive ToPdfString .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
LinePrimitive Class
NFX.Media.PDF.Elements Namespace


LinePrimitive.ToPdfString Method

LinePrimitive ToPdfString Method NFX Class Library

Returns PDF string representation on the line primitive

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToPdfString()
public override string ToPdfString()
Public Overrides Function ToPdfString As String
Public Overrides Function ToPdfString As String
public:
virtual String^ ToPdfString() override
public:
virtual String^ ToPdfString() override
abstract ToPdfString : unit -> string
override ToPdfString : unit -> string
abstract ToPdfString : unit -> string
override ToPdfString : unit -> string

Return Value

Type: Online String

Implements

IPdfWritable ToPdfString
See Also
LinePrimitive Class
LinePrimitive Members
NFX.Media.PDF.Elements Namespace


LinePrimitive Properties

LinePrimitive Properties NFX Class Library

The LinePrimitive type exposes the following members.
Properties
 | Name | Description
Public property | EndX | Line's end X coordinate
Public property | EndY | Line's end Y coordinate
Back to Top
See Also
LinePrimitive Class
NFX.Media.PDF.Elements Namespace


LinePrimitive.EndX Property

LinePrimitive EndX Property NFX Class Library

Line's end X coordinate

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float EndX { get; set; }
public float EndX { get; set; }
Public Property EndX As Single
    Get
    Set
Public Property EndX As Single
    Get
    Set
public:
property float EndX {
    float get ();
    void set (float value);
}
public:
property float EndX {
    float get ();
    void set (float value);
}
member EndX : float32 with get, set
member EndX : float32 with get, set

Property Value

Type: Online Single
See Also
LinePrimitive Class
LinePrimitive Members
NFX.Media.PDF.Elements Namespace


LinePrimitive.EndY Property

LinePrimitive EndY Property NFX Class Library

Line's end Y coordinate

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float EndY { get; set; }
public float EndY { get; set; }
Public Property EndY As Single
    Get
    Set
Public Property EndY As Single
    Get
    Set
public:
property float EndY {
    float get ();
    void set (float value);
}
public:
property float EndY {
    float get ();
    void set (float value);
}
member EndY : float32 with get, set
member EndY : float32 with get, set

Property Value

Type: Online Single
See Also
LinePrimitive Class
LinePrimitive Members
NFX.Media.PDF.Elements Namespace


PathElement Class

PathElement Class NFX Class Library

PDF path element as a collection of path primitives (lines, Bezier curves etc.)
Inheritance Hierarchy
Online System Object
NFX.Media.PDF.DocumentModel PdfObject
NFX.Media.PDF.Elements PdfElement
NFX.Media.PDF.Elements PathElement

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PathElement : PdfElement
public class PathElement : PdfElement
Public Class PathElement
    Inherits PdfElement
Public Class PathElement
    Inherits PdfElement
public ref class PathElement : public PdfElement
public ref class PathElement : public PdfElement
type PathElement =
    class
        inherit PdfElement
    end
type PathElement =
    class
        inherit PdfElement
    end
See Also
PathElement Members
NFX.Media.PDF.Elements Namespace


PathElement Members

PathElement Members NFX Class Library

The PathElement type exposes the following members.
Constructors
 | Name | Description
Public method | PathElement(Single, Single) | Initializes a new instance of the PathElement class
Public method | PathElement(Single, Single, PdfDrawStyle) | Initializes a new instance of the PathElement class
Back to Top
Methods
 | Name | Description
Public method | AddBezier |
Public method | AddLine |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReference | Returns PDF object indirect reference (Inherited from PdfObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write | (Overrides PdfElement Write(PdfWriter).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | IsClosed |
Public property | ObjectId | Document-wide unique object Id (Inherited from PdfObject.)
Public property | Primitives |
Public property | Style |
Public property | X | X-coordinate (Inherited from PdfElement.)
Public property | Y | Y-coordinate (Inherited from PdfElement.)
Back to Top
See Also
PathElement Class
NFX.Media.PDF.Elements Namespace


PathElement Constructor

PathElement Constructor NFX Class Library

Overload List
 | Name | Description
Public method | PathElement(Single, Single) | Initializes a new instance of the PathElement class
Public method | PathElement(Single, Single, PdfDrawStyle) | Initializes a new instance of the PathElement class
Back to Top
See Also
PathElement Class
PathElement Members
NFX.Media.PDF.Elements Namespace


PathElement Constructor (Single, Single)

PathElement Constructor (Single, Single) NFX Class Library

Initializes a new instance of the PathElement class

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PathElement(
    float x,
    float y
)
public PathElement(
    float x,
    float y
)
Public Sub New (
    x As Single,
    y As Single
)
Public Sub New (
    x As Single,
    y As Single
)
public:
PathElement(
    float x,
    float y
)
public:
PathElement(
    float x,
    float y
)
new :
        x : float32 *
        y : float32 -> PathElement
new :
        x : float32 *
        y : float32 -> PathElement

Parameters

x
Type: Online System Single
y
Type: Online System Single
See Also
PathElement Class
PathElement Members
PathElement Overload
NFX.Media.PDF.Elements Namespace


PathElement Constructor (Single, Single, PdfDrawStyle)

PathElement Constructor (Single, Single, PdfDrawStyle) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PathElement class

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PathElement(
    float x,
    float y,
    PdfDrawStyle style
)
public PathElement(
    float x,
    float y,
    PdfDrawStyle style
)
Public Sub New (
    x As Single,
    y As Single,
    style As PdfDrawStyle
)
Public Sub New (
    x As Single,
    y As Single,
    style As PdfDrawStyle
)
public:
PathElement(
    float x,
    float y,
    PdfDrawStyle^ style
)
public:
PathElement(
    float x,
    float y,
    PdfDrawStyle^ style
)
new :
        x : float32 *
        y : float32 *
        style : PdfDrawStyle -> PathElement
new :
        x : float32 *
        y : float32 *
        style : PdfDrawStyle -> PathElement

Parameters

x
Type: Online System Single
y
Type: Online System Single
style
Type: NFX.Media.PDF.Styling PdfDrawStyle
See Also
PathElement Class
PathElement Members
PathElement Overload
NFX.Media.PDF.Elements Namespace


PathElement Methods

PathElement Methods NFX Class Library

The PathElement type exposes the following members.
Methods
 | Name | Description
Public method | AddBezier |
Public method | AddLine |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReference | Returns PDF object indirect reference (Inherited from PdfObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write | (Overrides PdfElement Write(PdfWriter).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PathElement Class
NFX.Media.PDF.Elements Namespace


PathElement.AddBezier Method

PathElement AddBezier Method NFX Class Library

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddBezier(
    float firstControlX,
    float firstControlY,
    float secondControlX,
    float secondControlY,
    float endX,
    float endY
)
public void AddBezier(
    float firstControlX,
    float firstControlY,
    float secondControlX,
    float secondControlY,
    float endX,
    float endY
)
Public Sub AddBezier (
    firstControlX As Single,
    firstControlY As Single,
    secondControlX As Single,
    secondControlY As Single,
    endX As Single,
    endY As Single
)
Public Sub AddBezier (
    firstControlX As Single,
    firstControlY As Single,
    secondControlX As Single,
    secondControlY As Single,
    endX As Single,
    endY As Single
)
public:
void AddBezier(
    float firstControlX,
    float firstControlY,
    float secondControlX,
    float secondControlY,
    float endX,
    float endY
)
public:
void AddBezier(
    float firstControlX,
    float firstControlY,
    float secondControlX,
    float secondControlY,
    float endX,
    float endY
)
member AddBezier :
        firstControlX : float32 *
        firstControlY : float32 *
        secondControlX : float32 *
        secondControlY : float32 *
        endX : float32 *
        endY : float32 -> unit
member AddBezier :
        firstControlX : float32 *
        firstControlY : float32 *
        secondControlX : float32 *
        secondControlY : float32 *
        endX : float32 *
        endY : float32 -> unit

Parameters

firstControlX
Type: Online System Single
firstControlY
Type: Online System Single
secondControlX
Type: Online System Single
secondControlY
Type: Online System Single
endX
Type: Online System Single
endY
Type: Online System Single
See Also
PathElement Class
PathElement Members
NFX.Media.PDF.Elements Namespace


PathElement.AddLine Method

PathElement AddLine Method NFX Class Library

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddLine(
    float endX,
    float endY
)
public void AddLine(
    float endX,
    float endY
)
Public Sub AddLine (
    endX As Single,
    endY As Single
)
Public Sub AddLine (
    endX As Single,
    endY As Single
)
public:
void AddLine(
    float endX,
    float endY
)
public:
void AddLine(
    float endX,
    float endY
)
member AddLine :
        endX : float32 *
        endY : float32 -> unit
member AddLine :
        endX : float32 *
        endY : float32 -> unit

Parameters

endX
Type: Online System Single
endY
Type: Online System Single
See Also
PathElement Class
PathElement Members
NFX.Media.PDF.Elements Namespace


PathElement.Write Method

PathElement Write Method NFX Class Library

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    PdfWriter writer
)
public override void Write(
    PdfWriter writer
)
Public Overrides Sub Write (
    writer As PdfWriter
)
Public Overrides Sub Write (
    writer As PdfWriter
)
public:
virtual void Write(
    PdfWriter^ writer
) override
public:
virtual void Write(
    PdfWriter^ writer
) override
abstract Write :
        writer : PdfWriter -> unit
override Write :
        writer : PdfWriter -> unit
abstract Write :
        writer : PdfWriter -> unit
override Write :
        writer : PdfWriter -> unit

Parameters

writer
Type: NFX.Media.PDF PdfWriter
See Also
PathElement Class
PathElement Members
NFX.Media.PDF.Elements Namespace


PathElement Properties

PathElement Properties NFX Class Library

The PathElement type exposes the following members.
Properties
 | Name | Description
Public property | IsClosed |
Public property | ObjectId | Document-wide unique object Id (Inherited from PdfObject.)
Public property | Primitives |
Public property | Style |
Public property | X | X-coordinate (Inherited from PdfElement.)
Public property | Y | Y-coordinate (Inherited from PdfElement.)
Back to Top
See Also
PathElement Class
NFX.Media.PDF.Elements Namespace


PathElement.IsClosed Property

PathElement IsClosed Property NFX Class Library

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsClosed { get; set; }
public bool IsClosed { get; set; }
Public Property IsClosed As Boolean
    Get
    Set
Public Property IsClosed As Boolean
    Get
    Set
public:
property bool IsClosed {
    bool get ();
    void set (bool value);
}
public:
property bool IsClosed {
    bool get ();
    void set (bool value);
}
member IsClosed : bool with get, set
member IsClosed : bool with get, set

Property Value

Type: Online Boolean
See Also
PathElement Class
PathElement Members
NFX.Media.PDF.Elements Namespace


PathElement.Primitives Property

PathElement Primitives Property NFX Class Library

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<PathPrimitive> Primitives { get; }
public List<PathPrimitive> Primitives { get; }
Public ReadOnly Property Primitives As List(Of PathPrimitive)
    Get
Public ReadOnly Property Primitives As List(Of PathPrimitive)
    Get
public:
property List<PathPrimitive^>^ Primitives {
    List<PathPrimitive^>^ get ();
}
public:
property List<PathPrimitive^>^ Primitives {
    List<PathPrimitive^>^ get ();
}
member Primitives : List<PathPrimitive> with get
member Primitives : List<PathPrimitive> with get

Property Value

Type: Online List PathPrimitive
See Also
PathElement Class
PathElement Members
NFX.Media.PDF.Elements Namespace


PathElement.Style Property

PathElement Style Property NFX Class Library

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfDrawStyle Style { get; set; }
public PdfDrawStyle Style { get; set; }
Public Property Style As PdfDrawStyle
    Get
    Set
Public Property Style As PdfDrawStyle
    Get
    Set
public:
property PdfDrawStyle^ Style {
    PdfDrawStyle^ get ();
    void set (PdfDrawStyle^ value);
}
public:
property PdfDrawStyle^ Style {
    PdfDrawStyle^ get ();
    void set (PdfDrawStyle^ value);
}
member Style : PdfDrawStyle with get, set
member Style : PdfDrawStyle with get, set

Property Value

Type: PdfDrawStyle
See Also
PathElement Class
PathElement Members
NFX.Media.PDF.Elements Namespace


PathPrimitive Class

PathPrimitive Class NFX Class Library

PDF path primitive (a line, Bezier curve,...) as a part of path
Inheritance Hierarchy
Online System Object
NFX.Media.PDF.Elements PathPrimitive
NFX.Media.PDF.Elements BezierPrimitive
NFX.Media.PDF.Elements LinePrimitive

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class PathPrimitive : IPdfWritable
public abstract class PathPrimitive : IPdfWritable
Public MustInherit Class PathPrimitive
    Implements IPdfWritable
Public MustInherit Class PathPrimitive
    Implements IPdfWritable
public ref class PathPrimitive abstract : IPdfWritable
public ref class PathPrimitive abstract : IPdfWritable
[<AbstractClassAttribute>]
type PathPrimitive =
    class
        interface IPdfWritable
    end
[<AbstractClassAttribute>]
type PathPrimitive =
    class
        interface IPdfWritable
    end
See Also
PathPrimitive Members
NFX.Media.PDF.Elements Namespace


PathPrimitive Members

PathPrimitive Members NFX Class Library

The PathPrimitive type exposes the following members.
Constructors
 | Name | Description
Protected method | PathPrimitive | Initializes a new instance of the PathPrimitive class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToPdfString | Returns PDF string representation
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PathPrimitive Class
NFX.Media.PDF.Elements Namespace


PathPrimitive Constructor

PathPrimitive Constructor NFX Class Library

Initializes a new instance of the PathPrimitive class

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PathPrimitive()
protected PathPrimitive()
Protected Sub New
Protected Sub New
protected:
PathPrimitive()
protected:
PathPrimitive()
new : unit -> PathPrimitive
new : unit -> PathPrimitive
See Also
PathPrimitive Class
PathPrimitive Members
NFX.Media.PDF.Elements Namespace


PathPrimitive Methods

PathPrimitive Methods NFX Class Library

The PathPrimitive type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToPdfString | Returns PDF string representation
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PathPrimitive Class
NFX.Media.PDF.Elements Namespace


PathPrimitive.ToPdfString Method

PathPrimitive ToPdfString Method NFX Class Library

Returns PDF string representation

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string ToPdfString()
public abstract string ToPdfString()
Public MustOverride Function ToPdfString As String
Public MustOverride Function ToPdfString As String
public:
virtual String^ ToPdfString() abstract
public:
virtual String^ ToPdfString() abstract
abstract ToPdfString : unit -> string
abstract ToPdfString : unit -> string

Return Value

Type: Online String

Implements

IPdfWritable ToPdfString
See Also
PathPrimitive Class
PathPrimitive Members
NFX.Media.PDF.Elements Namespace


PdfElement Class

PdfElement Class NFX Class Library

Base class for all PDF primitives
Inheritance Hierarchy
Online System Object
NFX.Media.PDF.DocumentModel PdfObject
NFX.Media.PDF.Elements PdfElement
NFX.Media.PDF.Elements ImageElement
NFX.Media.PDF.Elements PathElement
NFX.Media.PDF.Elements RectangleElement
NFX.Media.PDF.Elements TextElement

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class PdfElement : PdfObject
public abstract class PdfElement : PdfObject
Public MustInherit Class PdfElement
    Inherits PdfObject
Public MustInherit Class PdfElement
    Inherits PdfObject
public ref class PdfElement abstract : public PdfObject
public ref class PdfElement abstract : public PdfObject
[<AbstractClassAttribute>]
type PdfElement =
    class
        inherit PdfObject
    end
[<AbstractClassAttribute>]
type PdfElement =
    class
        inherit PdfObject
    end
See Also
PdfElement Members
NFX.Media.PDF.Elements Namespace


PdfElement Members

PdfElement Members NFX Class Library

The PdfElement type exposes the following members.
Constructors
 | Name | Description
Protected method | PdfElement | Initializes a new instance of the PdfElement class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReference | Returns PDF object indirect reference (Inherited from PdfObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write | Writes element into file stream
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ObjectId | Document-wide unique object Id (Inherited from PdfObject.)
Public property | X | X-coordinate
Public property | Y | Y-coordinate
Back to Top
See Also
PdfElement Class
NFX.Media.PDF.Elements Namespace


PdfElement Constructor

PdfElement Constructor NFX Class Library

Initializes a new instance of the PdfElement class

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PdfElement()
protected PdfElement()
Protected Sub New
Protected Sub New
protected:
PdfElement()
protected:
PdfElement()
new : unit -> PdfElement
new : unit -> PdfElement
See Also
PdfElement Class
PdfElement Members
NFX.Media.PDF.Elements Namespace


PdfElement Methods

PdfElement Methods NFX Class Library

The PdfElement type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReference | Returns PDF object indirect reference (Inherited from PdfObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write | Writes element into file stream
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PdfElement Class
NFX.Media.PDF.Elements Namespace


PdfElement.Write Method

PdfElement Write Method NFX Class Library

Writes element into file stream

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void Write(
    PdfWriter writer
)
public abstract void Write(
    PdfWriter writer
)
Public MustOverride Sub Write (
    writer As PdfWriter
)
Public MustOverride Sub Write (
    writer As PdfWriter
)
public:
virtual void Write(
    PdfWriter^ writer
) abstract
public:
virtual void Write(
    PdfWriter^ writer
) abstract
abstract Write :
        writer : PdfWriter -> unit
abstract Write :
        writer : PdfWriter -> unit

Parameters

writer
Type: NFX.Media.PDF PdfWriter
PDF writer
See Also
PdfElement Class
PdfElement Members
NFX.Media.PDF.Elements Namespace


PdfElement Properties

PdfElement Properties NFX Class Library

The PdfElement type exposes the following members.
Properties
 | Name | Description
Public property | ObjectId | Document-wide unique object Id (Inherited from PdfObject.)
Public property | X | X-coordinate
Public property | Y | Y-coordinate
Back to Top
See Also
PdfElement Class
NFX.Media.PDF.Elements Namespace


PdfElement.X Property

PdfElement X Property NFX Class Library

X-coordinate

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float X { get; set; }
public float X { get; set; }
Public Property X As Single
    Get
    Set
Public Property X As Single
    Get
    Set
public:
property float X {
    float get ();
    void set (float value);
}
public:
property float X {
    float get ();
    void set (float value);
}
member X : float32 with get, set
member X : float32 with get, set

Property Value

Type: Online Single
See Also
PdfElement Class
PdfElement Members
NFX.Media.PDF.Elements Namespace


PdfElement.Y Property

PdfElement Y Property NFX Class Library

Y-coordinate

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float Y { get; set; }
public float Y { get; set; }
Public Property Y As Single
    Get
    Set
Public Property Y As Single
    Get
    Set
public:
property float Y {
    float get ();
    void set (float value);
}
public:
property float Y {
    float get ();
    void set (float value);
}
member Y : float32 with get, set
member Y : float32 with get, set

Property Value

Type: Online Single
See Also
PdfElement Class
PdfElement Members
NFX.Media.PDF.Elements Namespace


RectangleElement Class

RectangleElement Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Media.PDF.DocumentModel PdfObject
NFX.Media.PDF.Elements PdfElement
NFX.Media.PDF.Elements RectangleElement

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class RectangleElement : PdfElement
public class RectangleElement : PdfElement
Public Class RectangleElement
    Inherits PdfElement
Public Class RectangleElement
    Inherits PdfElement
public ref class RectangleElement : public PdfElement
public ref class RectangleElement : public PdfElement
type RectangleElement =
    class
        inherit PdfElement
    end
type RectangleElement =
    class
        inherit PdfElement
    end
See Also
RectangleElement Members
NFX.Media.PDF.Elements Namespace


RectangleElement Members

RectangleElement Members NFX Class Library

The RectangleElement type exposes the following members.
Constructors
 | Name | Description
Public method | RectangleElement(Single, Single, Single, Single) | Initializes a new instance of the RectangleElement class
Public method | RectangleElement(Single, Single, Single, Single, PdfDrawStyle) | Initializes a new instance of the RectangleElement class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReference | Returns PDF object indirect reference (Inherited from PdfObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write | (Overrides PdfElement Write(PdfWriter).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ObjectId | Document-wide unique object Id (Inherited from PdfObject.)
Public property | Style |
Public property | X | X-coordinate (Inherited from PdfElement.)
Public property | X1 |
Public property | Y | Y-coordinate (Inherited from PdfElement.)
Public property | Y1 |
Back to Top
See Also
RectangleElement Class
NFX.Media.PDF.Elements Namespace


RectangleElement Constructor

RectangleElement Constructor NFX Class Library

Overload List
 | Name | Description
Public method | RectangleElement(Single, Single, Single, Single) | Initializes a new instance of the RectangleElement class
Public method | RectangleElement(Single, Single, Single, Single, PdfDrawStyle) | Initializes a new instance of the RectangleElement class
Back to Top
See Also
RectangleElement Class
RectangleElement Members
NFX.Media.PDF.Elements Namespace


RectangleElement Constructor (Single, Single, Single, Single)

RectangleElement Constructor (Single, Single, Single, Single) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RectangleElement class

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RectangleElement(
    float x1,
    float y1,
    float x2,
    float y2
)
public RectangleElement(
    float x1,
    float y1,
    float x2,
    float y2
)
Public Sub New (
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single
)
Public Sub New (
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single
)
public:
RectangleElement(
    float x1,
    float y1,
    float x2,
    float y2
)
public:
RectangleElement(
    float x1,
    float y1,
    float x2,
    float y2
)
new :
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 -> RectangleElement
new :
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 -> RectangleElement

Parameters

x1
Type: Online System Single
y1
Type: Online System Single
x2
Type: Online System Single
y2
Type: Online System Single
See Also
RectangleElement Class
RectangleElement Members
RectangleElement Overload
NFX.Media.PDF.Elements Namespace


RectangleElement Constructor (Single, Single, Single, Single, PdfDrawStyle)

RectangleElement Constructor (Single, Single, Single, Single, PdfDrawStyle) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RectangleElement class

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RectangleElement(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfDrawStyle borderStyle
)
public RectangleElement(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfDrawStyle borderStyle
)
Public Sub New (
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single,
    borderStyle As PdfDrawStyle
)
Public Sub New (
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single,
    borderStyle As PdfDrawStyle
)
public:
RectangleElement(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfDrawStyle^ borderStyle
)
public:
RectangleElement(
    float x1,
    float y1,
    float x2,
    float y2,
    PdfDrawStyle^ borderStyle
)
new :
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 *
        borderStyle : PdfDrawStyle -> RectangleElement
new :
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 *
        borderStyle : PdfDrawStyle -> RectangleElement

Parameters

x1
Type: Online System Single
y1
Type: Online System Single
x2
Type: Online System Single
y2
Type: Online System Single
borderStyle
Type: NFX.Media.PDF.Styling PdfDrawStyle
See Also
RectangleElement Class
RectangleElement Members
RectangleElement Overload
NFX.Media.PDF.Elements Namespace


RectangleElement Methods

RectangleElement Methods NFX Class Library

The RectangleElement type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReference | Returns PDF object indirect reference (Inherited from PdfObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write | (Overrides PdfElement Write(PdfWriter).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
RectangleElement Class
NFX.Media.PDF.Elements Namespace


RectangleElement.Write Method

RectangleElement Write Method NFX Class Library

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    PdfWriter writer
)
public override void Write(
    PdfWriter writer
)
Public Overrides Sub Write (
    writer As PdfWriter
)
Public Overrides Sub Write (
    writer As PdfWriter
)
public:
virtual void Write(
    PdfWriter^ writer
) override
public:
virtual void Write(
    PdfWriter^ writer
) override
abstract Write :
        writer : PdfWriter -> unit
override Write :
        writer : PdfWriter -> unit
abstract Write :
        writer : PdfWriter -> unit
override Write :
        writer : PdfWriter -> unit

Parameters

writer
Type: NFX.Media.PDF PdfWriter
See Also
RectangleElement Class
RectangleElement Members
NFX.Media.PDF.Elements Namespace


RectangleElement Properties

RectangleElement Properties NFX Class Library

The RectangleElement type exposes the following members.
Properties
 | Name | Description
Public property | ObjectId | Document-wide unique object Id (Inherited from PdfObject.)
Public property | Style |
Public property | X | X-coordinate (Inherited from PdfElement.)
Public property | X1 |
Public property | Y | Y-coordinate (Inherited from PdfElement.)
Public property | Y1 |
Back to Top
See Also
RectangleElement Class
NFX.Media.PDF.Elements Namespace


RectangleElement.Style Property

RectangleElement Style Property NFX Class Library

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfDrawStyle Style { get; set; }
public PdfDrawStyle Style { get; set; }
Public Property Style As PdfDrawStyle
    Get
    Set
Public Property Style As PdfDrawStyle
    Get
    Set
public:
property PdfDrawStyle^ Style {
    PdfDrawStyle^ get ();
    void set (PdfDrawStyle^ value);
}
public:
property PdfDrawStyle^ Style {
    PdfDrawStyle^ get ();
    void set (PdfDrawStyle^ value);
}
member Style : PdfDrawStyle with get, set
member Style : PdfDrawStyle with get, set

Property Value

Type: PdfDrawStyle
See Also
RectangleElement Class
RectangleElement Members
NFX.Media.PDF.Elements Namespace


RectangleElement.X1 Property

RectangleElement X1 Property NFX Class Library

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float X1 { get; set; }
public float X1 { get; set; }
Public Property X1 As Single
    Get
    Set
Public Property X1 As Single
    Get
    Set
public:
property float X1 {
    float get ();
    void set (float value);
}
public:
property float X1 {
    float get ();
    void set (float value);
}
member X1 : float32 with get, set
member X1 : float32 with get, set

Property Value

Type: Online Single
See Also
RectangleElement Class
RectangleElement Members
NFX.Media.PDF.Elements Namespace


RectangleElement.Y1 Property

RectangleElement Y1 Property NFX Class Library

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float Y1 { get; set; }
public float Y1 { get; set; }
Public Property Y1 As Single
    Get
    Set
Public Property Y1 As Single
    Get
    Set
public:
property float Y1 {
    float get ();
    void set (float value);
}
public:
property float Y1 {
    float get ();
    void set (float value);
}
member Y1 : float32 with get, set
member Y1 : float32 with get, set

Property Value

Type: Online Single
See Also
RectangleElement Class
RectangleElement Members
NFX.Media.PDF.Elements Namespace


TextElement Class

TextElement Class NFX Class Library

PDF text element
Inheritance Hierarchy
Online System Object
NFX.Media.PDF.DocumentModel PdfObject
NFX.Media.PDF.Elements PdfElement
NFX.Media.PDF.Elements TextElement

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TextElement : PdfElement
public class TextElement : PdfElement
Public Class TextElement
    Inherits PdfElement
Public Class TextElement
    Inherits PdfElement
public ref class TextElement : public PdfElement
public ref class TextElement : public PdfElement
type TextElement =
    class
        inherit PdfElement
    end
type TextElement =
    class
        inherit PdfElement
    end
See Also
TextElement Members
NFX.Media.PDF.Elements Namespace


TextElement Members

TextElement Members NFX Class Library

The TextElement type exposes the following members.
Constructors
 | Name | Description
Public method | TextElement(String) | Initializes a new instance of the TextElement class
Public method | TextElement(String, Single, PdfFont) | Initializes a new instance of the TextElement class
Public method | TextElement(String, Single, PdfFont, PdfColor) | Initializes a new instance of the TextElement class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReference | Returns PDF object indirect reference (Inherited from PdfObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write | Writes element into file stream (Overrides PdfElement Write(PdfWriter).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Color | PDF Color
Public property | Content | Text content
Public property | Font | PDF Font
Public property | FontSize | Font size
Public property | ObjectId | Document-wide unique object Id (Inherited from PdfObject.)
Public property | X | X-coordinate (Inherited from PdfElement.)
Public property | Y | Y-coordinate (Inherited from PdfElement.)
Back to Top
See Also
TextElement Class
NFX.Media.PDF.Elements Namespace


TextElement Constructor

TextElement Constructor NFX Class Library

Overload List
 | Name | Description
Public method | TextElement(String) | Initializes a new instance of the TextElement class
Public method | TextElement(String, Single, PdfFont) | Initializes a new instance of the TextElement class
Public method | TextElement(String, Single, PdfFont, PdfColor) | Initializes a new instance of the TextElement class
Back to Top
See Also
TextElement Class
TextElement Members
NFX.Media.PDF.Elements Namespace


TextElement Constructor (String)

TextElement Constructor (String) NFX Class Library

Initializes a new instance of the TextElement class

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TextElement(
    string content
)
public TextElement(
    string content
)
Public Sub New (
    content As String
)
Public Sub New (
    content As String
)
public:
TextElement(
    String^ content
)
public:
TextElement(
    String^ content
)
new :
        content : string -> TextElement
new :
        content : string -> TextElement

Parameters

content
Type: Online System String
See Also
TextElement Class
TextElement Members
TextElement Overload
NFX.Media.PDF.Elements Namespace


TextElement Constructor (String, Single, PdfFont)

TextElement Constructor (String, Single, PdfFont) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TextElement class

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TextElement(
    string content,
    float fontSize,
    PdfFont font
)
public TextElement(
    string content,
    float fontSize,
    PdfFont font
)
Public Sub New (
    content As String,
    fontSize As Single,
    font As PdfFont
)
Public Sub New (
    content As String,
    fontSize As Single,
    font As PdfFont
)
public:
TextElement(
    String^ content,
    float fontSize,
    PdfFont^ font
)
public:
TextElement(
    String^ content,
    float fontSize,
    PdfFont^ font
)
new :
        content : string *
        fontSize : float32 *
        font : PdfFont -> TextElement
new :
        content : string *
        fontSize : float32 *
        font : PdfFont -> TextElement

Parameters

content
Type: Online System String
fontSize
Type: Online System Single
font
Type: NFX.Media.PDF.DocumentModel PdfFont
See Also
TextElement Class
TextElement Members
TextElement Overload
NFX.Media.PDF.Elements Namespace


TextElement Constructor (String, Single, PdfFont, PdfColor)

TextElement Constructor (String, Single, PdfFont, PdfColor) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TextElement class

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TextElement(
    string content,
    float fontSize,
    PdfFont font,
    PdfColor color
)
public TextElement(
    string content,
    float fontSize,
    PdfFont font,
    PdfColor color
)
Public Sub New (
    content As String,
    fontSize As Single,
    font As PdfFont,
    color As PdfColor
)
Public Sub New (
    content As String,
    fontSize As Single,
    font As PdfFont,
    color As PdfColor
)
public:
TextElement(
    String^ content,
    float fontSize,
    PdfFont^ font,
    PdfColor^ color
)
public:
TextElement(
    String^ content,
    float fontSize,
    PdfFont^ font,
    PdfColor^ color
)
new :
        content : string *
        fontSize : float32 *
        font : PdfFont *
        color : PdfColor -> TextElement
new :
        content : string *
        fontSize : float32 *
        font : PdfFont *
        color : PdfColor -> TextElement

Parameters

content
Type: Online System String
fontSize
Type: Online System Single
font
Type: NFX.Media.PDF.DocumentModel PdfFont
color
Type: NFX.Media.PDF.Styling PdfColor
See Also
TextElement Class
TextElement Members
TextElement Overload
NFX.Media.PDF.Elements Namespace


TextElement Methods

TextElement Methods NFX Class Library

The TextElement type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetReference | Returns PDF object indirect reference (Inherited from PdfObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Write | Writes element into file stream (Overrides PdfElement Write(PdfWriter).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TextElement Class
NFX.Media.PDF.Elements Namespace


TextElement.Write Method

TextElement Write Method NFX Class Library

Writes element into file stream

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Write(
    PdfWriter writer
)
public override void Write(
    PdfWriter writer
)
Public Overrides Sub Write (
    writer As PdfWriter
)
Public Overrides Sub Write (
    writer As PdfWriter
)
public:
virtual void Write(
    PdfWriter^ writer
) override
public:
virtual void Write(
    PdfWriter^ writer
) override
abstract Write :
        writer : PdfWriter -> unit
override Write :
        writer : PdfWriter -> unit
abstract Write :
        writer : PdfWriter -> unit
override Write :
        writer : PdfWriter -> unit

Parameters

writer
Type: NFX.Media.PDF PdfWriter
PDF writer

Return Value

Type:
Written bytes count
See Also
TextElement Class
TextElement Members
NFX.Media.PDF.Elements Namespace


TextElement Properties

TextElement Properties NFX Class Library

The TextElement type exposes the following members.
Properties
 | Name | Description
Public property | Color | PDF Color
Public property | Content | Text content
Public property | Font | PDF Font
Public property | FontSize | Font size
Public property | ObjectId | Document-wide unique object Id (Inherited from PdfObject.)
Public property | X | X-coordinate (Inherited from PdfElement.)
Public property | Y | Y-coordinate (Inherited from PdfElement.)
Back to Top
See Also
TextElement Class
NFX.Media.PDF.Elements Namespace


TextElement.Color Property

TextElement Color Property NFX Class Library

PDF Color

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfColor Color { get; set; }
public PdfColor Color { get; set; }
Public Property Color As PdfColor
    Get
    Set
Public Property Color As PdfColor
    Get
    Set
public:
property PdfColor^ Color {
    PdfColor^ get ();
    void set (PdfColor^ value);
}
public:
property PdfColor^ Color {
    PdfColor^ get ();
    void set (PdfColor^ value);
}
member Color : PdfColor with get, set
member Color : PdfColor with get, set

Property Value

Type: PdfColor
See Also
TextElement Class
TextElement Members
NFX.Media.PDF.Elements Namespace


TextElement.Content Property

TextElement Content Property NFX Class Library

Text content

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Content { get; set; }
public string Content { get; set; }
Public Property Content As String
    Get
    Set
Public Property Content As String
    Get
    Set
public:
property String^ Content {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Content {
    String^ get ();
    void set (String^ value);
}
member Content : string with get, set
member Content : string with get, set

Property Value

Type: Online String
See Also
TextElement Class
TextElement Members
NFX.Media.PDF.Elements Namespace


TextElement.Font Property

TextElement Font Property NFX Class Library

PDF Font

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfFont Font { get; set; }
public PdfFont Font { get; set; }
Public Property Font As PdfFont
    Get
    Set
Public Property Font As PdfFont
    Get
    Set
public:
property PdfFont^ Font {
    PdfFont^ get ();
    void set (PdfFont^ value);
}
public:
property PdfFont^ Font {
    PdfFont^ get ();
    void set (PdfFont^ value);
}
member Font : PdfFont with get, set
member Font : PdfFont with get, set

Property Value

Type: PdfFont
See Also
TextElement Class
TextElement Members
NFX.Media.PDF.Elements Namespace


TextElement.FontSize Property

TextElement FontSize Property NFX Class Library

Font size

Namespace: NFX.Media.PDF.Elements
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float FontSize { get; set; }
public float FontSize { get; set; }
Public Property FontSize As Single
    Get
    Set
Public Property FontSize As Single
    Get
    Set
public:
property float FontSize {
    float get ();
    void set (float value);
}
public:
property float FontSize {
    float get ();
    void set (float value);
}
member FontSize : float32 with get, set
member FontSize : float32 with get, set

Property Value

Type: Online Single
See Also
TextElement Class
TextElement Members
NFX.Media.PDF.Elements Namespace


NFX.Media.PDF.Styling Namespace

NFX.Media.PDF.Styling Namespace NFX Class Library

Classes
 | Class | Description
Public class | PdfColor | PDF Color
Public class | PdfDrawStyle | PDF line's style
Public class | PdfPageSize | Page size definitions (ISO and others)
Public class | PdfSize | PDF size with its units
Public class | PdfUnit | Represents a unit of PDF coordinates. Units are relative to standard pdf point, which is 1/72 inch by default. Use ByName() accessor to get/create units, or use one of the stock units: PdfUnit.Inch|Millimeter|Point...
Enumerations
 | Enumeration | Description
Public enumeration | PdfHorizontalAlign | PDF element's horizontal alignment enumeration
Public enumeration | PdfLineType | PDF line's style enumeration


PdfColor Class

PdfColor Class NFX Class Library

PDF Color
Inheritance Hierarchy
Online System Object
NFX.Media.PDF.Styling PdfColor

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PdfColor : IPdfWritable, INamed
public class PdfColor : IPdfWritable, INamed
Public Class PdfColor
    Implements IPdfWritable, INamed
Public Class PdfColor
    Implements IPdfWritable, INamed
public ref class PdfColor : IPdfWritable,
    INamed
public ref class PdfColor : IPdfWritable,
    INamed
type PdfColor =
    class
        interface IPdfWritable
        interface INamed
    end
type PdfColor =
    class
        interface IPdfWritable
        interface INamed
    end
See Also
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor Members

PdfColor Members NFX Class Library

The PdfColor type exposes the following members.
Methods
 | Name | Description
 | ByName(String) | Returns existing color by name or throws if it is not found
 | ByName(String, Byte, Byte, Byte) | Returns existing color by name or creates and registers a new one
Public method | Equals(Object) | (Overrides Online Object Equals(Object).)
Public method | Equals(PdfColor) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToPdfString | Returns PDF string representation
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | B |
 | Black |
 | Blue |
 | Cyan |
 | DarkBlue |
 | DarkCyan |
 | DarkGray |
 | DarkGreen |
 | DarkOrange |
 | DarkPurple |
 | DarkRed |
 | DarkYellow |
Public property | G |
 | Gray |
 | Green |
 | LghtCyan |
 | LghtGray |
 | LightBlue |
 | LightGreen |
 | LightOrange |
 | LightPurple |
 | LightRed |
 | LightYellow |
Public property | Name |
 | Orange |
 | Purple |
Public property | R |
 | Red |
 | White |
 | Yellow |
Back to Top
See Also
PdfColor Class
NFX.Media.PDF.Styling Namespace


PdfColor Methods

PdfColor Methods NFX Class Library

The PdfColor type exposes the following members.
Methods
 | Name | Description
 | ByName(String) | Returns existing color by name or throws if it is not found
 | ByName(String, Byte, Byte, Byte) | Returns existing color by name or creates and registers a new one
Public method | Equals(Object) | (Overrides Online Object Equals(Object).)
Public method | Equals(PdfColor) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToPdfString | Returns PDF string representation
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PdfColor Class
NFX.Media.PDF.Styling Namespace


PdfColor.ByName Method

PdfColor ByName Method NFX Class Library

Overload List
Name | Description
ByName(String) | Returns existing color by name or throws if it is not found
ByName(String, Byte, Byte, Byte) | Returns existing color by name or creates and registers a new one
Back to Top
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.ByName Method (String)

PdfColor ByName Method (String) NFX Class Library

Returns existing color by name or throws if it is not found

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor ByName(
    string name
)
public static PdfColor ByName(
    string name
)
Public Shared Function ByName (
    name As String
) As PdfColor
Public Shared Function ByName (
    name As String
) As PdfColor
public:
static PdfColor^ ByName(
    String^ name
)
public:
static PdfColor^ ByName(
    String^ name
)
static member ByName :
        name : string -> PdfColor
static member ByName :
        name : string -> PdfColor

Parameters

name
Type: Online System String

Return Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
ByName Overload
NFX.Media.PDF.Styling Namespace


PdfColor.ByName Method (String, Byte, Byte, Byte)

PdfColor ByName Method (String, Byte, Byte, Byte) NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns existing color by name or creates and registers a new one

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor ByName(
    string name,
    byte r,
    byte g,
    byte b
)
public static PdfColor ByName(
    string name,
    byte r,
    byte g,
    byte b
)
Public Shared Function ByName (
    name As String,
    r As Byte,
    g As Byte,
    b As Byte
) As PdfColor
Public Shared Function ByName (
    name As String,
    r As Byte,
    g As Byte,
    b As Byte
) As PdfColor
public:
static PdfColor^ ByName(
    String^ name,
    unsigned char r,
    unsigned char g,
    unsigned char b
)
public:
static PdfColor^ ByName(
    String^ name,
    unsigned char r,
    unsigned char g,
    unsigned char b
)
static member ByName :
        name : string *
        r : byte *
        g : byte *
        b : byte -> PdfColor
static member ByName :
        name : string *
        r : byte *
        g : byte *
        b : byte -> PdfColor

Parameters

name
Type: Online System String
r
Type: Online System Byte
g
Type: Online System Byte
b
Type: Online System Byte

Return Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
ByName Overload
NFX.Media.PDF.Styling Namespace


PdfColor.Equals Method

PdfColor Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides Online Object Equals(Object).)
Public method | Equals(PdfColor) |
Back to Top
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.Equals Method (Object)

PdfColor Equals Method (Object) NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
PdfColor Class
PdfColor Members
Equals Overload
NFX.Media.PDF.Styling Namespace


PdfColor.Equals Method (PdfColor)

PdfColor Equals Method (PdfColor) NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    PdfColor other
)
public bool Equals(
    PdfColor other
)
Public Function Equals (
    other As PdfColor
) As Boolean
Public Function Equals (
    other As PdfColor
) As Boolean
public:
bool Equals(
    PdfColor^ other
)
public:
bool Equals(
    PdfColor^ other
)
member Equals :
        other : PdfColor -> bool
member Equals :
        other : PdfColor -> bool

Parameters

other
Type: NFX.Media.PDF.Styling PdfColor

Return Value

Type: Online Boolean
See Also
PdfColor Class
PdfColor Members
Equals Overload
NFX.Media.PDF.Styling Namespace


PdfColor.GetHashCode Method

PdfColor GetHashCode Method NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.ToPdfString Method

PdfColor ToPdfString Method NFX Class Library

Returns PDF string representation

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ToPdfString()
public string ToPdfString()
Public Function ToPdfString As String
Public Function ToPdfString As String
public:
virtual String^ ToPdfString() sealed
public:
virtual String^ ToPdfString() sealed
abstract ToPdfString : unit -> string
override ToPdfString : unit -> string
abstract ToPdfString : unit -> string
override ToPdfString : unit -> string

Return Value

Type: Online String

Implements

IPdfWritable ToPdfString
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.ToString Method

PdfColor ToString Method NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor Properties

PdfColor Properties NFX Class Library

The PdfColor type exposes the following members.
Properties
 | Name | Description
Public property | B |
 | Black |
 | Blue |
 | Cyan |
 | DarkBlue |
 | DarkCyan |
 | DarkGray |
 | DarkGreen |
 | DarkOrange |
 | DarkPurple |
 | DarkRed |
 | DarkYellow |
Public property | G |
 | Gray |
 | Green |
 | LghtCyan |
 | LghtGray |
 | LightBlue |
 | LightGreen |
 | LightOrange |
 | LightPurple |
 | LightRed |
 | LightYellow |
Public property | Name |
 | Orange |
 | Purple |
Public property | R |
 | Red |
 | White |
 | Yellow |
Back to Top
See Also
PdfColor Class
NFX.Media.PDF.Styling Namespace


PdfColor.B Property

PdfColor B Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte B { get; }
public byte B { get; }
Public ReadOnly Property B As Byte
    Get
Public ReadOnly Property B As Byte
    Get
public:
property unsigned char B {
    unsigned char get ();
}
public:
property unsigned char B {
    unsigned char get ();
}
member B : byte with get
member B : byte with get

Property Value

Type: Online Byte
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.Black Property

PdfColor Black Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor Black { get; }
public static PdfColor Black { get; }
Public Shared ReadOnly Property Black As PdfColor
    Get
Public Shared ReadOnly Property Black As PdfColor
    Get
public:
static property PdfColor^ Black {
    PdfColor^ get ();
}
public:
static property PdfColor^ Black {
    PdfColor^ get ();
}
static member Black : PdfColor with get
static member Black : PdfColor with get

Property Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.Blue Property

PdfColor Blue Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor Blue { get; }
public static PdfColor Blue { get; }
Public Shared ReadOnly Property Blue As PdfColor
    Get
Public Shared ReadOnly Property Blue As PdfColor
    Get
public:
static property PdfColor^ Blue {
    PdfColor^ get ();
}
public:
static property PdfColor^ Blue {
    PdfColor^ get ();
}
static member Blue : PdfColor with get
static member Blue : PdfColor with get

Property Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.Cyan Property

PdfColor Cyan Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor Cyan { get; }
public static PdfColor Cyan { get; }
Public Shared ReadOnly Property Cyan As PdfColor
    Get
Public Shared ReadOnly Property Cyan As PdfColor
    Get
public:
static property PdfColor^ Cyan {
    PdfColor^ get ();
}
public:
static property PdfColor^ Cyan {
    PdfColor^ get ();
}
static member Cyan : PdfColor with get
static member Cyan : PdfColor with get

Property Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.DarkBlue Property

PdfColor DarkBlue Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor DarkBlue { get; }
public static PdfColor DarkBlue { get; }
Public Shared ReadOnly Property DarkBlue As PdfColor
    Get
Public Shared ReadOnly Property DarkBlue As PdfColor
    Get
public:
static property PdfColor^ DarkBlue {
    PdfColor^ get ();
}
public:
static property PdfColor^ DarkBlue {
    PdfColor^ get ();
}
static member DarkBlue : PdfColor with get
static member DarkBlue : PdfColor with get

Property Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.DarkCyan Property

PdfColor DarkCyan Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor DarkCyan { get; }
public static PdfColor DarkCyan { get; }
Public Shared ReadOnly Property DarkCyan As PdfColor
    Get
Public Shared ReadOnly Property DarkCyan As PdfColor
    Get
public:
static property PdfColor^ DarkCyan {
    PdfColor^ get ();
}
public:
static property PdfColor^ DarkCyan {
    PdfColor^ get ();
}
static member DarkCyan : PdfColor with get
static member DarkCyan : PdfColor with get

Property Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.DarkGray Property

PdfColor DarkGray Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor DarkGray { get; }
public static PdfColor DarkGray { get; }
Public Shared ReadOnly Property DarkGray As PdfColor
    Get
Public Shared ReadOnly Property DarkGray As PdfColor
    Get
public:
static property PdfColor^ DarkGray {
    PdfColor^ get ();
}
public:
static property PdfColor^ DarkGray {
    PdfColor^ get ();
}
static member DarkGray : PdfColor with get
static member DarkGray : PdfColor with get

Property Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.DarkGreen Property

PdfColor DarkGreen Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor DarkGreen { get; }
public static PdfColor DarkGreen { get; }
Public Shared ReadOnly Property DarkGreen As PdfColor
    Get
Public Shared ReadOnly Property DarkGreen As PdfColor
    Get
public:
static property PdfColor^ DarkGreen {
    PdfColor^ get ();
}
public:
static property PdfColor^ DarkGreen {
    PdfColor^ get ();
}
static member DarkGreen : PdfColor with get
static member DarkGreen : PdfColor with get

Property Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.DarkOrange Property

PdfColor DarkOrange Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor DarkOrange { get; }
public static PdfColor DarkOrange { get; }
Public Shared ReadOnly Property DarkOrange As PdfColor
    Get
Public Shared ReadOnly Property DarkOrange As PdfColor
    Get
public:
static property PdfColor^ DarkOrange {
    PdfColor^ get ();
}
public:
static property PdfColor^ DarkOrange {
    PdfColor^ get ();
}
static member DarkOrange : PdfColor with get
static member DarkOrange : PdfColor with get

Property Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.DarkPurple Property

PdfColor DarkPurple Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor DarkPurple { get; }
public static PdfColor DarkPurple { get; }
Public Shared ReadOnly Property DarkPurple As PdfColor
    Get
Public Shared ReadOnly Property DarkPurple As PdfColor
    Get
public:
static property PdfColor^ DarkPurple {
    PdfColor^ get ();
}
public:
static property PdfColor^ DarkPurple {
    PdfColor^ get ();
}
static member DarkPurple : PdfColor with get
static member DarkPurple : PdfColor with get

Property Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.DarkRed Property

PdfColor DarkRed Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor DarkRed { get; }
public static PdfColor DarkRed { get; }
Public Shared ReadOnly Property DarkRed As PdfColor
    Get
Public Shared ReadOnly Property DarkRed As PdfColor
    Get
public:
static property PdfColor^ DarkRed {
    PdfColor^ get ();
}
public:
static property PdfColor^ DarkRed {
    PdfColor^ get ();
}
static member DarkRed : PdfColor with get
static member DarkRed : PdfColor with get

Property Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.DarkYellow Property

PdfColor DarkYellow Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor DarkYellow { get; }
public static PdfColor DarkYellow { get; }
Public Shared ReadOnly Property DarkYellow As PdfColor
    Get
Public Shared ReadOnly Property DarkYellow As PdfColor
    Get
public:
static property PdfColor^ DarkYellow {
    PdfColor^ get ();
}
public:
static property PdfColor^ DarkYellow {
    PdfColor^ get ();
}
static member DarkYellow : PdfColor with get
static member DarkYellow : PdfColor with get

Property Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.G Property

PdfColor G Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte G { get; }
public byte G { get; }
Public ReadOnly Property G As Byte
    Get
Public ReadOnly Property G As Byte
    Get
public:
property unsigned char G {
    unsigned char get ();
}
public:
property unsigned char G {
    unsigned char get ();
}
member G : byte with get
member G : byte with get

Property Value

Type: Online Byte
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.Gray Property

PdfColor Gray Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor Gray { get; }
public static PdfColor Gray { get; }
Public Shared ReadOnly Property Gray As PdfColor
    Get
Public Shared ReadOnly Property Gray As PdfColor
    Get
public:
static property PdfColor^ Gray {
    PdfColor^ get ();
}
public:
static property PdfColor^ Gray {
    PdfColor^ get ();
}
static member Gray : PdfColor with get
static member Gray : PdfColor with get

Property Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.Green Property

PdfColor Green Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor Green { get; }
public static PdfColor Green { get; }
Public Shared ReadOnly Property Green As PdfColor
    Get
Public Shared ReadOnly Property Green As PdfColor
    Get
public:
static property PdfColor^ Green {
    PdfColor^ get ();
}
public:
static property PdfColor^ Green {
    PdfColor^ get ();
}
static member Green : PdfColor with get
static member Green : PdfColor with get

Property Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.LghtCyan Property

PdfColor LghtCyan Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor LghtCyan { get; }
public static PdfColor LghtCyan { get; }
Public Shared ReadOnly Property LghtCyan As PdfColor
    Get
Public Shared ReadOnly Property LghtCyan As PdfColor
    Get
public:
static property PdfColor^ LghtCyan {
    PdfColor^ get ();
}
public:
static property PdfColor^ LghtCyan {
    PdfColor^ get ();
}
static member LghtCyan : PdfColor with get
static member LghtCyan : PdfColor with get

Property Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.LghtGray Property

PdfColor LghtGray Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor LghtGray { get; }
public static PdfColor LghtGray { get; }
Public Shared ReadOnly Property LghtGray As PdfColor
    Get
Public Shared ReadOnly Property LghtGray As PdfColor
    Get
public:
static property PdfColor^ LghtGray {
    PdfColor^ get ();
}
public:
static property PdfColor^ LghtGray {
    PdfColor^ get ();
}
static member LghtGray : PdfColor with get
static member LghtGray : PdfColor with get

Property Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.LightBlue Property

PdfColor LightBlue Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor LightBlue { get; }
public static PdfColor LightBlue { get; }
Public Shared ReadOnly Property LightBlue As PdfColor
    Get
Public Shared ReadOnly Property LightBlue As PdfColor
    Get
public:
static property PdfColor^ LightBlue {
    PdfColor^ get ();
}
public:
static property PdfColor^ LightBlue {
    PdfColor^ get ();
}
static member LightBlue : PdfColor with get
static member LightBlue : PdfColor with get

Property Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.LightGreen Property

PdfColor LightGreen Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor LightGreen { get; }
public static PdfColor LightGreen { get; }
Public Shared ReadOnly Property LightGreen As PdfColor
    Get
Public Shared ReadOnly Property LightGreen As PdfColor
    Get
public:
static property PdfColor^ LightGreen {
    PdfColor^ get ();
}
public:
static property PdfColor^ LightGreen {
    PdfColor^ get ();
}
static member LightGreen : PdfColor with get
static member LightGreen : PdfColor with get

Property Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.LightOrange Property

PdfColor LightOrange Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor LightOrange { get; }
public static PdfColor LightOrange { get; }
Public Shared ReadOnly Property LightOrange As PdfColor
    Get
Public Shared ReadOnly Property LightOrange As PdfColor
    Get
public:
static property PdfColor^ LightOrange {
    PdfColor^ get ();
}
public:
static property PdfColor^ LightOrange {
    PdfColor^ get ();
}
static member LightOrange : PdfColor with get
static member LightOrange : PdfColor with get

Property Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.LightPurple Property

PdfColor LightPurple Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor LightPurple { get; }
public static PdfColor LightPurple { get; }
Public Shared ReadOnly Property LightPurple As PdfColor
    Get
Public Shared ReadOnly Property LightPurple As PdfColor
    Get
public:
static property PdfColor^ LightPurple {
    PdfColor^ get ();
}
public:
static property PdfColor^ LightPurple {
    PdfColor^ get ();
}
static member LightPurple : PdfColor with get
static member LightPurple : PdfColor with get

Property Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.LightRed Property

PdfColor LightRed Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor LightRed { get; }
public static PdfColor LightRed { get; }
Public Shared ReadOnly Property LightRed As PdfColor
    Get
Public Shared ReadOnly Property LightRed As PdfColor
    Get
public:
static property PdfColor^ LightRed {
    PdfColor^ get ();
}
public:
static property PdfColor^ LightRed {
    PdfColor^ get ();
}
static member LightRed : PdfColor with get
static member LightRed : PdfColor with get

Property Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.LightYellow Property

PdfColor LightYellow Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor LightYellow { get; }
public static PdfColor LightYellow { get; }
Public Shared ReadOnly Property LightYellow As PdfColor
    Get
Public Shared ReadOnly Property LightYellow As PdfColor
    Get
public:
static property PdfColor^ LightYellow {
    PdfColor^ get ();
}
public:
static property PdfColor^ LightYellow {
    PdfColor^ get ();
}
static member LightYellow : PdfColor with get
static member LightYellow : PdfColor with get

Property Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.Name Property

PdfColor Name Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.Orange Property

PdfColor Orange Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor Orange { get; }
public static PdfColor Orange { get; }
Public Shared ReadOnly Property Orange As PdfColor
    Get
Public Shared ReadOnly Property Orange As PdfColor
    Get
public:
static property PdfColor^ Orange {
    PdfColor^ get ();
}
public:
static property PdfColor^ Orange {
    PdfColor^ get ();
}
static member Orange : PdfColor with get
static member Orange : PdfColor with get

Property Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.Purple Property

PdfColor Purple Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor Purple { get; }
public static PdfColor Purple { get; }
Public Shared ReadOnly Property Purple As PdfColor
    Get
Public Shared ReadOnly Property Purple As PdfColor
    Get
public:
static property PdfColor^ Purple {
    PdfColor^ get ();
}
public:
static property PdfColor^ Purple {
    PdfColor^ get ();
}
static member Purple : PdfColor with get
static member Purple : PdfColor with get

Property Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.R Property

PdfColor R Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte R { get; }
public byte R { get; }
Public ReadOnly Property R As Byte
    Get
Public ReadOnly Property R As Byte
    Get
public:
property unsigned char R {
    unsigned char get ();
}
public:
property unsigned char R {
    unsigned char get ();
}
member R : byte with get
member R : byte with get

Property Value

Type: Online Byte
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.Red Property

PdfColor Red Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor Red { get; }
public static PdfColor Red { get; }
Public Shared ReadOnly Property Red As PdfColor
    Get
Public Shared ReadOnly Property Red As PdfColor
    Get
public:
static property PdfColor^ Red {
    PdfColor^ get ();
}
public:
static property PdfColor^ Red {
    PdfColor^ get ();
}
static member Red : PdfColor with get
static member Red : PdfColor with get

Property Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.White Property

PdfColor White Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor White { get; }
public static PdfColor White { get; }
Public Shared ReadOnly Property White As PdfColor
    Get
Public Shared ReadOnly Property White As PdfColor
    Get
public:
static property PdfColor^ White {
    PdfColor^ get ();
}
public:
static property PdfColor^ White {
    PdfColor^ get ();
}
static member White : PdfColor with get
static member White : PdfColor with get

Property Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfColor.Yellow Property

PdfColor Yellow Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfColor Yellow { get; }
public static PdfColor Yellow { get; }
Public Shared ReadOnly Property Yellow As PdfColor
    Get
Public Shared ReadOnly Property Yellow As PdfColor
    Get
public:
static property PdfColor^ Yellow {
    PdfColor^ get ();
}
public:
static property PdfColor^ Yellow {
    PdfColor^ get ();
}
static member Yellow : PdfColor with get
static member Yellow : PdfColor with get

Property Value

Type: PdfColor
See Also
PdfColor Class
PdfColor Members
NFX.Media.PDF.Styling Namespace


PdfDrawStyle Class

PdfDrawStyle Class NFX Class Library

PDF line's style
Inheritance Hierarchy
Online System Object
NFX.Media.PDF.Styling PdfDrawStyle

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PdfDrawStyle : IPdfWritable
public class PdfDrawStyle : IPdfWritable
Public Class PdfDrawStyle
    Implements IPdfWritable
Public Class PdfDrawStyle
    Implements IPdfWritable
public ref class PdfDrawStyle : IPdfWritable
public ref class PdfDrawStyle : IPdfWritable
type PdfDrawStyle =
    class
        interface IPdfWritable
    end
type PdfDrawStyle =
    class
        interface IPdfWritable
    end
See Also
PdfDrawStyle Members
NFX.Media.PDF.Styling Namespace


PdfDrawStyle Members

PdfDrawStyle Members NFX Class Library

The PdfDrawStyle type exposes the following members.
Constructors
 | Name | Description
Public method | PdfDrawStyle | Initializes a new instance of the PdfDrawStyle class
Public method | PdfDrawStyle(Single) | Initializes a new instance of the PdfDrawStyle class
Public method | PdfDrawStyle(PdfColor) | Initializes a new instance of the PdfDrawStyle class
Public method | PdfDrawStyle(Single, PdfColor) | Initializes a new instance of the PdfDrawStyle class
Public method | PdfDrawStyle(Single, PdfColor, PdfLineType) | Initializes a new instance of the PdfDrawStyle class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToPdfString | Returns PDF string representation
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | FillColor |
Public property | StrokeColor |
Public property | StrokeThickness |
Public property | StrokeType |
Back to Top
See Also
PdfDrawStyle Class
NFX.Media.PDF.Styling Namespace


PdfDrawStyle Constructor

PdfDrawStyle Constructor NFX Class Library

Overload List
 | Name | Description
Public method | PdfDrawStyle | Initializes a new instance of the PdfDrawStyle class
Public method | PdfDrawStyle(Single) | Initializes a new instance of the PdfDrawStyle class
Public method | PdfDrawStyle(PdfColor) | Initializes a new instance of the PdfDrawStyle class
Public method | PdfDrawStyle(Single, PdfColor) | Initializes a new instance of the PdfDrawStyle class
Public method | PdfDrawStyle(Single, PdfColor, PdfLineType) | Initializes a new instance of the PdfDrawStyle class
Back to Top
See Also
PdfDrawStyle Class
PdfDrawStyle Members
NFX.Media.PDF.Styling Namespace


PdfDrawStyle Constructor

PdfDrawStyle Constructor NFX Class Library

Initializes a new instance of the PdfDrawStyle class

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfDrawStyle()
public PdfDrawStyle()
Public Sub New
Public Sub New
public:
PdfDrawStyle()
public:
PdfDrawStyle()
new : unit -> PdfDrawStyle
new : unit -> PdfDrawStyle
See Also
PdfDrawStyle Class
PdfDrawStyle Members
PdfDrawStyle Overload
NFX.Media.PDF.Styling Namespace


PdfDrawStyle Constructor (Single)

PdfDrawStyle Constructor (Single) NFX Class Library

Initializes a new instance of the PdfDrawStyle class

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfDrawStyle(
    float strokeThickness
)
public PdfDrawStyle(
    float strokeThickness
)
Public Sub New (
    strokeThickness As Single
)
Public Sub New (
    strokeThickness As Single
)
public:
PdfDrawStyle(
    float strokeThickness
)
public:
PdfDrawStyle(
    float strokeThickness
)
new :
        strokeThickness : float32 -> PdfDrawStyle
new :
        strokeThickness : float32 -> PdfDrawStyle

Parameters

strokeThickness
Type: Online System Single
See Also
PdfDrawStyle Class
PdfDrawStyle Members
PdfDrawStyle Overload
NFX.Media.PDF.Styling Namespace


PdfDrawStyle Constructor (PdfColor)

PdfDrawStyle Constructor (PdfColor) NFX Class Library

Initializes a new instance of the PdfDrawStyle class

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfDrawStyle(
    PdfColor fillColor
)
public PdfDrawStyle(
    PdfColor fillColor
)
Public Sub New (
    fillColor As PdfColor
)
Public Sub New (
    fillColor As PdfColor
)
public:
PdfDrawStyle(
    PdfColor^ fillColor
)
public:
PdfDrawStyle(
    PdfColor^ fillColor
)
new :
        fillColor : PdfColor -> PdfDrawStyle
new :
        fillColor : PdfColor -> PdfDrawStyle

Parameters

fillColor
Type: NFX.Media.PDF.Styling PdfColor
See Also
PdfDrawStyle Class
PdfDrawStyle Members
PdfDrawStyle Overload
NFX.Media.PDF.Styling Namespace


PdfDrawStyle Constructor (Single, PdfColor)

PdfDrawStyle Constructor (Single, PdfColor) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PdfDrawStyle class

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfDrawStyle(
    float strokeThickness,
    PdfColor strokeColor
)
public PdfDrawStyle(
    float strokeThickness,
    PdfColor strokeColor
)
Public Sub New (
    strokeThickness As Single,
    strokeColor As PdfColor
)
Public Sub New (
    strokeThickness As Single,
    strokeColor As PdfColor
)
public:
PdfDrawStyle(
    float strokeThickness,
    PdfColor^ strokeColor
)
public:
PdfDrawStyle(
    float strokeThickness,
    PdfColor^ strokeColor
)
new :
        strokeThickness : float32 *
        strokeColor : PdfColor -> PdfDrawStyle
new :
        strokeThickness : float32 *
        strokeColor : PdfColor -> PdfDrawStyle

Parameters

strokeThickness
Type: Online System Single
strokeColor
Type: NFX.Media.PDF.Styling PdfColor
See Also
PdfDrawStyle Class
PdfDrawStyle Members
PdfDrawStyle Overload
NFX.Media.PDF.Styling Namespace


PdfDrawStyle Constructor (Single, PdfColor, PdfLineType)

PdfDrawStyle Constructor (Single, PdfColor, PdfLineType) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PdfDrawStyle class

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfDrawStyle(
    float strokeThickness,
    PdfColor strokeColor,
    PdfLineType strokeType
)
public PdfDrawStyle(
    float strokeThickness,
    PdfColor strokeColor,
    PdfLineType strokeType
)
Public Sub New (
    strokeThickness As Single,
    strokeColor As PdfColor,
    strokeType As PdfLineType
)
Public Sub New (
    strokeThickness As Single,
    strokeColor As PdfColor,
    strokeType As PdfLineType
)
public:
PdfDrawStyle(
    float strokeThickness,
    PdfColor^ strokeColor,
    PdfLineType strokeType
)
public:
PdfDrawStyle(
    float strokeThickness,
    PdfColor^ strokeColor,
    PdfLineType strokeType
)
new :
        strokeThickness : float32 *
        strokeColor : PdfColor *
        strokeType : PdfLineType -> PdfDrawStyle
new :
        strokeThickness : float32 *
        strokeColor : PdfColor *
        strokeType : PdfLineType -> PdfDrawStyle

Parameters

strokeThickness
Type: Online System Single
strokeColor
Type: NFX.Media.PDF.Styling PdfColor
strokeType
Type: NFX.Media.PDF.Styling PdfLineType
See Also
PdfDrawStyle Class
PdfDrawStyle Members
PdfDrawStyle Overload
NFX.Media.PDF.Styling Namespace


PdfDrawStyle Methods

PdfDrawStyle Methods NFX Class Library

The PdfDrawStyle type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToPdfString | Returns PDF string representation
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PdfDrawStyle Class
NFX.Media.PDF.Styling Namespace


PdfDrawStyle.ToPdfString Method

PdfDrawStyle ToPdfString Method NFX Class Library

Returns PDF string representation

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ToPdfString()
public string ToPdfString()
Public Function ToPdfString As String
Public Function ToPdfString As String
public:
virtual String^ ToPdfString() sealed
public:
virtual String^ ToPdfString() sealed
abstract ToPdfString : unit -> string
override ToPdfString : unit -> string
abstract ToPdfString : unit -> string
override ToPdfString : unit -> string

Return Value

Type: Online String

Implements

IPdfWritable ToPdfString
See Also
PdfDrawStyle Class
PdfDrawStyle Members
NFX.Media.PDF.Styling Namespace


PdfDrawStyle Properties

PdfDrawStyle Properties NFX Class Library

The PdfDrawStyle type exposes the following members.
Properties
 | Name | Description
Public property | FillColor |
Public property | StrokeColor |
Public property | StrokeThickness |
Public property | StrokeType |
Back to Top
See Also
PdfDrawStyle Class
NFX.Media.PDF.Styling Namespace


PdfDrawStyle.FillColor Property

PdfDrawStyle FillColor Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfColor FillColor { get; set; }
public PdfColor FillColor { get; set; }
Public Property FillColor As PdfColor
    Get
    Set
Public Property FillColor As PdfColor
    Get
    Set
public:
property PdfColor^ FillColor {
    PdfColor^ get ();
    void set (PdfColor^ value);
}
public:
property PdfColor^ FillColor {
    PdfColor^ get ();
    void set (PdfColor^ value);
}
member FillColor : PdfColor with get, set
member FillColor : PdfColor with get, set

Property Value

Type: PdfColor
See Also
PdfDrawStyle Class
PdfDrawStyle Members
NFX.Media.PDF.Styling Namespace


PdfDrawStyle.StrokeColor Property

PdfDrawStyle StrokeColor Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfColor StrokeColor { get; set; }
public PdfColor StrokeColor { get; set; }
Public Property StrokeColor As PdfColor
    Get
    Set
Public Property StrokeColor As PdfColor
    Get
    Set
public:
property PdfColor^ StrokeColor {
    PdfColor^ get ();
    void set (PdfColor^ value);
}
public:
property PdfColor^ StrokeColor {
    PdfColor^ get ();
    void set (PdfColor^ value);
}
member StrokeColor : PdfColor with get, set
member StrokeColor : PdfColor with get, set

Property Value

Type: PdfColor
See Also
PdfDrawStyle Class
PdfDrawStyle Members
NFX.Media.PDF.Styling Namespace


PdfDrawStyle.StrokeThickness Property

PdfDrawStyle StrokeThickness Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<float> StrokeThickness { get; set; }
public Nullable<float> StrokeThickness { get; set; }
Public Property StrokeThickness As Nullable(Of Single)
    Get
    Set
Public Property StrokeThickness As Nullable(Of Single)
    Get
    Set
public:
property Nullable<float> StrokeThickness {
    Nullable<float> get ();
    void set (Nullable<float> value);
}
public:
property Nullable<float> StrokeThickness {
    Nullable<float> get ();
    void set (Nullable<float> value);
}
member StrokeThickness : Nullable<float32> with get, set
member StrokeThickness : Nullable<float32> with get, set

Property Value

Type: Online Nullable Online Single
See Also
PdfDrawStyle Class
PdfDrawStyle Members
NFX.Media.PDF.Styling Namespace


PdfDrawStyle.StrokeType Property

PdfDrawStyle StrokeType Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<PdfLineType> StrokeType { get; set; }
public Nullable<PdfLineType> StrokeType { get; set; }
Public Property StrokeType As Nullable(Of PdfLineType)
    Get
    Set
Public Property StrokeType As Nullable(Of PdfLineType)
    Get
    Set
public:
property Nullable<PdfLineType> StrokeType {
    Nullable<PdfLineType> get ();
    void set (Nullable<PdfLineType> value);
}
public:
property Nullable<PdfLineType> StrokeType {
    Nullable<PdfLineType> get ();
    void set (Nullable<PdfLineType> value);
}
member StrokeType : Nullable<PdfLineType> with get, set
member StrokeType : Nullable<PdfLineType> with get, set

Property Value

Type: Online Nullable PdfLineType
See Also
PdfDrawStyle Class
PdfDrawStyle Members
NFX.Media.PDF.Styling Namespace


PdfHorizontalAlign Enumeration

PdfHorizontalAlign Enumeration NFX Class Library

PDF element's horizontal alignment enumeration

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum PdfHorizontalAlign
public enum PdfHorizontalAlign
Public Enumeration PdfHorizontalAlign
Public Enumeration PdfHorizontalAlign
public enum class PdfHorizontalAlign
public enum class PdfHorizontalAlign
type PdfHorizontalAlign
type PdfHorizontalAlign
Members
Member name | Value | Description
Left | 0 |
Center | 1 |
Right | 2 |
See Also
NFX.Media.PDF.Styling Namespace


PdfLineType Enumeration

PdfLineType Enumeration NFX Class Library

PDF line's style enumeration

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum PdfLineType
public enum PdfLineType
Public Enumeration PdfLineType
Public Enumeration PdfLineType
public enum class PdfLineType
public enum class PdfLineType
type PdfLineType
type PdfLineType
Members
Member name | Value | Description
Normal | 0 |
OutlinedThin | 1 |
Outlined | 2 |
OutlinedBold | 3 |
See Also
NFX.Media.PDF.Styling Namespace


PdfPageSize Class

PdfPageSize Class NFX Class Library

Page size definitions (ISO and others)
Inheritance Hierarchy
Online System Object
NFX.Media.PDF.Styling PdfPageSize

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class PdfPageSize
public static class PdfPageSize
Public NotInheritable Class PdfPageSize
Public NotInheritable Class PdfPageSize
public ref class PdfPageSize abstract sealed
public ref class PdfPageSize abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PdfPageSize =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PdfPageSize =  class end
See Also
PdfPageSize Members
NFX.Media.PDF.Styling Namespace


PdfPageSize Members

PdfPageSize Members NFX Class Library

The PdfPageSize type exposes the following members.
Methods
Name | Description
A0 |
A1 |
A2 |
A3 |
A4 |
A5 |
B4 |
B5 |
Default |
Letter |
Back to Top
See Also
PdfPageSize Class
NFX.Media.PDF.Styling Namespace


PdfPageSize Methods

PdfPageSize Methods NFX Class Library

The PdfPageSize type exposes the following members.
Methods
Name | Description
A0 |
A1 |
A2 |
A3 |
A4 |
A5 |
B4 |
B5 |
Default |
Letter |
Back to Top
See Also
PdfPageSize Class
NFX.Media.PDF.Styling Namespace


PdfPageSize.A0 Method

PdfPageSize A0 Method NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfSize A0(
    PdfUnit unit = null
)
public static PdfSize A0(
    PdfUnit unit = null
)
Public Shared Function A0 (
    Optional unit As PdfUnit = Nothing
) As PdfSize
Public Shared Function A0 (
    Optional unit As PdfUnit = Nothing
) As PdfSize
public:
static PdfSize^ A0(
    PdfUnit^ unit = nullptr
)
public:
static PdfSize^ A0(
    PdfUnit^ unit = nullptr
)
static member A0 :
        ?unit : PdfUnit
(* Defaults:
        let _unit = defaultArg unit null
*)
-> PdfSize
static member A0 :
        ?unit : PdfUnit
(* Defaults:
        let _unit = defaultArg unit null
*)
-> PdfSize

Parameters

unit (Optional)
Type: NFX.Media.PDF.Styling PdfUnit

Return Value

Type: PdfSize
See Also
PdfPageSize Class
PdfPageSize Members
NFX.Media.PDF.Styling Namespace


PdfPageSize.A1 Method

PdfPageSize A1 Method NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfSize A1(
    PdfUnit unit = null
)
public static PdfSize A1(
    PdfUnit unit = null
)
Public Shared Function A1 (
    Optional unit As PdfUnit = Nothing
) As PdfSize
Public Shared Function A1 (
    Optional unit As PdfUnit = Nothing
) As PdfSize
public:
static PdfSize^ A1(
    PdfUnit^ unit = nullptr
)
public:
static PdfSize^ A1(
    PdfUnit^ unit = nullptr
)
static member A1 :
        ?unit : PdfUnit
(* Defaults:
        let _unit = defaultArg unit null
*)
-> PdfSize
static member A1 :
        ?unit : PdfUnit
(* Defaults:
        let _unit = defaultArg unit null
*)
-> PdfSize

Parameters

unit (Optional)
Type: NFX.Media.PDF.Styling PdfUnit

Return Value

Type: PdfSize
See Also
PdfPageSize Class
PdfPageSize Members
NFX.Media.PDF.Styling Namespace


PdfPageSize.A2 Method

PdfPageSize A2 Method NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfSize A2(
    PdfUnit unit = null
)
public static PdfSize A2(
    PdfUnit unit = null
)
Public Shared Function A2 (
    Optional unit As PdfUnit = Nothing
) As PdfSize
Public Shared Function A2 (
    Optional unit As PdfUnit = Nothing
) As PdfSize
public:
static PdfSize^ A2(
    PdfUnit^ unit = nullptr
)
public:
static PdfSize^ A2(
    PdfUnit^ unit = nullptr
)
static member A2 :
        ?unit : PdfUnit
(* Defaults:
        let _unit = defaultArg unit null
*)
-> PdfSize
static member A2 :
        ?unit : PdfUnit
(* Defaults:
        let _unit = defaultArg unit null
*)
-> PdfSize

Parameters

unit (Optional)
Type: NFX.Media.PDF.Styling PdfUnit

Return Value

Type: PdfSize
See Also
PdfPageSize Class
PdfPageSize Members
NFX.Media.PDF.Styling Namespace


PdfPageSize.A3 Method

PdfPageSize A3 Method NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfSize A3(
    PdfUnit unit = null
)
public static PdfSize A3(
    PdfUnit unit = null
)
Public Shared Function A3 (
    Optional unit As PdfUnit = Nothing
) As PdfSize
Public Shared Function A3 (
    Optional unit As PdfUnit = Nothing
) As PdfSize
public:
static PdfSize^ A3(
    PdfUnit^ unit = nullptr
)
public:
static PdfSize^ A3(
    PdfUnit^ unit = nullptr
)
static member A3 :
        ?unit : PdfUnit
(* Defaults:
        let _unit = defaultArg unit null
*)
-> PdfSize
static member A3 :
        ?unit : PdfUnit
(* Defaults:
        let _unit = defaultArg unit null
*)
-> PdfSize

Parameters

unit (Optional)
Type: NFX.Media.PDF.Styling PdfUnit

Return Value

Type: PdfSize
See Also
PdfPageSize Class
PdfPageSize Members
NFX.Media.PDF.Styling Namespace


PdfPageSize.A4 Method

PdfPageSize A4 Method NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfSize A4(
    PdfUnit unit = null
)
public static PdfSize A4(
    PdfUnit unit = null
)
Public Shared Function A4 (
    Optional unit As PdfUnit = Nothing
) As PdfSize
Public Shared Function A4 (
    Optional unit As PdfUnit = Nothing
) As PdfSize
public:
static PdfSize^ A4(
    PdfUnit^ unit = nullptr
)
public:
static PdfSize^ A4(
    PdfUnit^ unit = nullptr
)
static member A4 :
        ?unit : PdfUnit
(* Defaults:
        let _unit = defaultArg unit null
*)
-> PdfSize
static member A4 :
        ?unit : PdfUnit
(* Defaults:
        let _unit = defaultArg unit null
*)
-> PdfSize

Parameters

unit (Optional)
Type: NFX.Media.PDF.Styling PdfUnit

Return Value

Type: PdfSize
See Also
PdfPageSize Class
PdfPageSize Members
NFX.Media.PDF.Styling Namespace


PdfPageSize.A5 Method

PdfPageSize A5 Method NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfSize A5(
    PdfUnit unit = null
)
public static PdfSize A5(
    PdfUnit unit = null
)
Public Shared Function A5 (
    Optional unit As PdfUnit = Nothing
) As PdfSize
Public Shared Function A5 (
    Optional unit As PdfUnit = Nothing
) As PdfSize
public:
static PdfSize^ A5(
    PdfUnit^ unit = nullptr
)
public:
static PdfSize^ A5(
    PdfUnit^ unit = nullptr
)
static member A5 :
        ?unit : PdfUnit
(* Defaults:
        let _unit = defaultArg unit null
*)
-> PdfSize
static member A5 :
        ?unit : PdfUnit
(* Defaults:
        let _unit = defaultArg unit null
*)
-> PdfSize

Parameters

unit (Optional)
Type: NFX.Media.PDF.Styling PdfUnit

Return Value

Type: PdfSize
See Also
PdfPageSize Class
PdfPageSize Members
NFX.Media.PDF.Styling Namespace


PdfPageSize.B4 Method

PdfPageSize B4 Method NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfSize B4(
    PdfUnit unit = null
)
public static PdfSize B4(
    PdfUnit unit = null
)
Public Shared Function B4 (
    Optional unit As PdfUnit = Nothing
) As PdfSize
Public Shared Function B4 (
    Optional unit As PdfUnit = Nothing
) As PdfSize
public:
static PdfSize^ B4(
    PdfUnit^ unit = nullptr
)
public:
static PdfSize^ B4(
    PdfUnit^ unit = nullptr
)
static member B4 :
        ?unit : PdfUnit
(* Defaults:
        let _unit = defaultArg unit null
*)
-> PdfSize
static member B4 :
        ?unit : PdfUnit
(* Defaults:
        let _unit = defaultArg unit null
*)
-> PdfSize

Parameters

unit (Optional)
Type: NFX.Media.PDF.Styling PdfUnit

Return Value

Type: PdfSize
See Also
PdfPageSize Class
PdfPageSize Members
NFX.Media.PDF.Styling Namespace


PdfPageSize.B5 Method

PdfPageSize B5 Method NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfSize B5(
    PdfUnit unit = null
)
public static PdfSize B5(
    PdfUnit unit = null
)
Public Shared Function B5 (
    Optional unit As PdfUnit = Nothing
) As PdfSize
Public Shared Function B5 (
    Optional unit As PdfUnit = Nothing
) As PdfSize
public:
static PdfSize^ B5(
    PdfUnit^ unit = nullptr
)
public:
static PdfSize^ B5(
    PdfUnit^ unit = nullptr
)
static member B5 :
        ?unit : PdfUnit
(* Defaults:
        let _unit = defaultArg unit null
*)
-> PdfSize
static member B5 :
        ?unit : PdfUnit
(* Defaults:
        let _unit = defaultArg unit null
*)
-> PdfSize

Parameters

unit (Optional)
Type: NFX.Media.PDF.Styling PdfUnit

Return Value

Type: PdfSize
See Also
PdfPageSize Class
PdfPageSize Members
NFX.Media.PDF.Styling Namespace


PdfPageSize.Default Method

PdfPageSize Default Method NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfSize Default(
    PdfUnit unit = null
)
public static PdfSize Default(
    PdfUnit unit = null
)
Public Shared Function Default (
    Optional unit As PdfUnit = Nothing
) As PdfSize
Public Shared Function Default (
    Optional unit As PdfUnit = Nothing
) As PdfSize
public:
static PdfSize^ Default(
    PdfUnit^ unit = nullptr
)
public:
static PdfSize^ Default(
    PdfUnit^ unit = nullptr
)
static member Default :
        ?unit : PdfUnit
(* Defaults:
        let _unit = defaultArg unit null
*)
-> PdfSize
static member Default :
        ?unit : PdfUnit
(* Defaults:
        let _unit = defaultArg unit null
*)
-> PdfSize

Parameters

unit (Optional)
Type: NFX.Media.PDF.Styling PdfUnit

Return Value

Type: PdfSize
See Also
PdfPageSize Class
PdfPageSize Members
NFX.Media.PDF.Styling Namespace


PdfPageSize.Letter Method

PdfPageSize Letter Method NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfSize Letter(
    PdfUnit unit = null
)
public static PdfSize Letter(
    PdfUnit unit = null
)
Public Shared Function Letter (
    Optional unit As PdfUnit = Nothing
) As PdfSize
Public Shared Function Letter (
    Optional unit As PdfUnit = Nothing
) As PdfSize
public:
static PdfSize^ Letter(
    PdfUnit^ unit = nullptr
)
public:
static PdfSize^ Letter(
    PdfUnit^ unit = nullptr
)
static member Letter :
        ?unit : PdfUnit
(* Defaults:
        let _unit = defaultArg unit null
*)
-> PdfSize
static member Letter :
        ?unit : PdfUnit
(* Defaults:
        let _unit = defaultArg unit null
*)
-> PdfSize

Parameters

unit (Optional)
Type: NFX.Media.PDF.Styling PdfUnit

Return Value

Type: PdfSize
See Also
PdfPageSize Class
PdfPageSize Members
NFX.Media.PDF.Styling Namespace


PdfSize Class

PdfSize Class NFX Class Library

PDF size with its units
Inheritance Hierarchy
Online System Object
NFX.Media.PDF.Styling PdfSize

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class PdfSize
public sealed class PdfSize
Public NotInheritable Class PdfSize
Public NotInheritable Class PdfSize
public ref class PdfSize sealed
public ref class PdfSize sealed
[<SealedAttribute>]
type PdfSize =  class end
[<SealedAttribute>]
type PdfSize =  class end
See Also
PdfSize Members
NFX.Media.PDF.Styling Namespace


PdfSize Members

PdfSize Members NFX Class Library

The PdfSize type exposes the following members.
Constructors
 | Name | Description
Public method | PdfSize | Initializes a new instance of the PdfSize class
Back to Top
Methods
 | Name | Description
Public method | ChangeUnits | Change unit of the size and recalculate height and width
Public method | Equals(Object) | (Overrides Online Object Equals(Object).)
Public method | Equals(PdfSize) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Height | Height measured in values calculated according to Unit property (by default: 1 pt = 1/72 inch)
Public property | Unit | Pdf unit measured in default points (1 pt = 1/72 inch)
Public property | Width | Width measured in values calculated according to Unit property (by default: 1 pt = 1/72 inch)
Back to Top
See Also
PdfSize Class
NFX.Media.PDF.Styling Namespace


PdfSize Constructor

PdfSize Constructor NFX Class Library

Initializes a new instance of the PdfSize class

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfSize(
    PdfUnit unit,
    float width,
    float height
)
public PdfSize(
    PdfUnit unit,
    float width,
    float height
)
Public Sub New (
    unit As PdfUnit,
    width As Single,
    height As Single
)
Public Sub New (
    unit As PdfUnit,
    width As Single,
    height As Single
)
public:
PdfSize(
    PdfUnit^ unit,
    float width,
    float height
)
public:
PdfSize(
    PdfUnit^ unit,
    float width,
    float height
)
new :
        unit : PdfUnit *
        width : float32 *
        height : float32 -> PdfSize
new :
        unit : PdfUnit *
        width : float32 *
        height : float32 -> PdfSize

Parameters

unit
Type: NFX.Media.PDF.Styling PdfUnit
width
Type: Online System Single
height
Type: Online System Single
See Also
PdfSize Class
PdfSize Members
NFX.Media.PDF.Styling Namespace


PdfSize Methods

PdfSize Methods NFX Class Library

The PdfSize type exposes the following members.
Methods
 | Name | Description
Public method | ChangeUnits | Change unit of the size and recalculate height and width
Public method | Equals(Object) | (Overrides Online Object Equals(Object).)
Public method | Equals(PdfSize) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PdfSize Class
NFX.Media.PDF.Styling Namespace


PdfSize.ChangeUnits Method

PdfSize ChangeUnits Method NFX Class Library

Change unit of the size and recalculate height and width

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfSize ChangeUnits(
    PdfUnit unit
)
public PdfSize ChangeUnits(
    PdfUnit unit
)
Public Function ChangeUnits (
    unit As PdfUnit
) As PdfSize
Public Function ChangeUnits (
    unit As PdfUnit
) As PdfSize
public:
PdfSize^ ChangeUnits(
    PdfUnit^ unit
)
public:
PdfSize^ ChangeUnits(
    PdfUnit^ unit
)
member ChangeUnits :
        unit : PdfUnit -> PdfSize
member ChangeUnits :
        unit : PdfUnit -> PdfSize

Parameters

unit
Type: NFX.Media.PDF.Styling PdfUnit
New unit

Return Value

Type: PdfSize
See Also
PdfSize Class
PdfSize Members
NFX.Media.PDF.Styling Namespace


PdfSize.Equals Method

PdfSize Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides Online Object Equals(Object).)
Public method | Equals(PdfSize) |
Back to Top
See Also
PdfSize Class
PdfSize Members
NFX.Media.PDF.Styling Namespace


PdfSize.Equals Method (Object)

PdfSize Equals Method (Object) NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
PdfSize Class
PdfSize Members
Equals Overload
NFX.Media.PDF.Styling Namespace


PdfSize.Equals Method (PdfSize)

PdfSize Equals Method (PdfSize) NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    PdfSize other
)
public bool Equals(
    PdfSize other
)
Public Function Equals (
    other As PdfSize
) As Boolean
Public Function Equals (
    other As PdfSize
) As Boolean
public:
bool Equals(
    PdfSize^ other
)
public:
bool Equals(
    PdfSize^ other
)
member Equals :
        other : PdfSize -> bool
member Equals :
        other : PdfSize -> bool

Parameters

other
Type: NFX.Media.PDF.Styling PdfSize

Return Value

Type: Online Boolean
See Also
PdfSize Class
PdfSize Members
Equals Overload
NFX.Media.PDF.Styling Namespace


PdfSize.GetHashCode Method

PdfSize GetHashCode Method NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
PdfSize Class
PdfSize Members
NFX.Media.PDF.Styling Namespace


PdfSize.ToString Method

PdfSize ToString Method NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
PdfSize Class
PdfSize Members
NFX.Media.PDF.Styling Namespace


PdfSize Properties

PdfSize Properties NFX Class Library

The PdfSize type exposes the following members.
Properties
 | Name | Description
Public property | Height | Height measured in values calculated according to Unit property (by default: 1 pt = 1/72 inch)
Public property | Unit | Pdf unit measured in default points (1 pt = 1/72 inch)
Public property | Width | Width measured in values calculated according to Unit property (by default: 1 pt = 1/72 inch)
Back to Top
See Also
PdfSize Class
NFX.Media.PDF.Styling Namespace


PdfSize.Height Property

PdfSize Height Property NFX Class Library

Height measured in values calculated according to Unit property (by default: 1 pt = 1/72 inch)

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float Height { get; set; }
public float Height { get; set; }
Public Property Height As Single
    Get
    Set
Public Property Height As Single
    Get
    Set
public:
property float Height {
    float get ();
    void set (float value);
}
public:
property float Height {
    float get ();
    void set (float value);
}
member Height : float32 with get, set
member Height : float32 with get, set

Property Value

Type: Online Single
See Also
PdfSize Class
PdfSize Members
NFX.Media.PDF.Styling Namespace


PdfSize.Unit Property

PdfSize Unit Property NFX Class Library

Pdf unit measured in default points (1 pt = 1/72 inch)

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfUnit Unit { get; }
public PdfUnit Unit { get; }
Public ReadOnly Property Unit As PdfUnit
    Get
Public ReadOnly Property Unit As PdfUnit
    Get
public:
property PdfUnit^ Unit {
    PdfUnit^ get ();
}
public:
property PdfUnit^ Unit {
    PdfUnit^ get ();
}
member Unit : PdfUnit with get
member Unit : PdfUnit with get

Property Value

Type: PdfUnit
See Also
PdfSize Class
PdfSize Members
NFX.Media.PDF.Styling Namespace


PdfSize.Width Property

PdfSize Width Property NFX Class Library

Width measured in values calculated according to Unit property (by default: 1 pt = 1/72 inch)

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float Width { get; set; }
public float Width { get; set; }
Public Property Width As Single
    Get
    Set
Public Property Width As Single
    Get
    Set
public:
property float Width {
    float get ();
    void set (float value);
}
public:
property float Width {
    float get ();
    void set (float value);
}
member Width : float32 with get, set
member Width : float32 with get, set

Property Value

Type: Online Single
See Also
PdfSize Class
PdfSize Members
NFX.Media.PDF.Styling Namespace


PdfUnit Class

PdfUnit Class NFX Class Library

Represents a unit of PDF coordinates. Units are relative to standard pdf point, which is 1/72 inch by default. Use ByName() accessor to get/create units, or use one of the stock units: PdfUnit.Inch|Millimeter|Point...
Inheritance Hierarchy
Online System Object
NFX.Media.PDF.Styling PdfUnit

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class PdfUnit : INamed,
    IEquatable<PdfUnit>
public sealed class PdfUnit : INamed,
    IEquatable<PdfUnit>
Public NotInheritable Class PdfUnit
    Implements INamed, IEquatable(Of PdfUnit)
Public NotInheritable Class PdfUnit
    Implements INamed, IEquatable(Of PdfUnit)
public ref class PdfUnit sealed : INamed,
    IEquatable<PdfUnit^>
public ref class PdfUnit sealed : INamed,
    IEquatable<PdfUnit^>
[<SealedAttribute>]
type PdfUnit =
    class
        interface INamed
        interface IEquatable<PdfUnit>
    end
[<SealedAttribute>]
type PdfUnit =
    class
        interface INamed
        interface IEquatable<PdfUnit>
    end
See Also
PdfUnit Members
NFX.Media.PDF.Styling Namespace


PdfUnit Members

PdfUnit Members NFX Class Library

The PdfUnit type exposes the following members.
Methods
 | Name | Description
 | ByName(String) | Returns existing unit by name or throws if it is not found
 | ByName(String, Single) | Returns existing unit by name or creates and registers a new one
Public method | Equals(Object) | (Overrides Online Object Equals(Object).)
Public method | Equals(PdfUnit) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
 | Centimeter |
 | Default |
 | Inch |
 | Millimeter |
Public property | Name |
 | Point |
Public property | Points | Number of default user space units in current unit (1 default user space unit is 1/72 inch)
Back to Top
See Also
PdfUnit Class
NFX.Media.PDF.Styling Namespace


PdfUnit Methods

PdfUnit Methods NFX Class Library

The PdfUnit type exposes the following members.
Methods
 | Name | Description
 | ByName(String) | Returns existing unit by name or throws if it is not found
 | ByName(String, Single) | Returns existing unit by name or creates and registers a new one
Public method | Equals(Object) | (Overrides Online Object Equals(Object).)
Public method | Equals(PdfUnit) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PdfUnit Class
NFX.Media.PDF.Styling Namespace


PdfUnit.ByName Method

PdfUnit ByName Method NFX Class Library

Overload List
Name | Description
ByName(String) | Returns existing unit by name or throws if it is not found
ByName(String, Single) | Returns existing unit by name or creates and registers a new one
Back to Top
See Also
PdfUnit Class
PdfUnit Members
NFX.Media.PDF.Styling Namespace


PdfUnit.ByName Method (String)

PdfUnit ByName Method (String) NFX Class Library

Returns existing unit by name or throws if it is not found

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfUnit ByName(
    string name
)
public static PdfUnit ByName(
    string name
)
Public Shared Function ByName (
    name As String
) As PdfUnit
Public Shared Function ByName (
    name As String
) As PdfUnit
public:
static PdfUnit^ ByName(
    String^ name
)
public:
static PdfUnit^ ByName(
    String^ name
)
static member ByName :
        name : string -> PdfUnit
static member ByName :
        name : string -> PdfUnit

Parameters

name
Type: Online System String

Return Value

Type: PdfUnit
See Also
PdfUnit Class
PdfUnit Members
ByName Overload
NFX.Media.PDF.Styling Namespace


PdfUnit.ByName Method (String, Single)

PdfUnit ByName Method (String, Single) NFX Class Library

Returns existing unit by name or creates and registers a new one

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfUnit ByName(
    string name,
    float points
)
public static PdfUnit ByName(
    string name,
    float points
)
Public Shared Function ByName (
    name As String,
    points As Single
) As PdfUnit
Public Shared Function ByName (
    name As String,
    points As Single
) As PdfUnit
public:
static PdfUnit^ ByName(
    String^ name,
    float points
)
public:
static PdfUnit^ ByName(
    String^ name,
    float points
)
static member ByName :
        name : string *
        points : float32 -> PdfUnit
static member ByName :
        name : string *
        points : float32 -> PdfUnit

Parameters

name
Type: Online System String
points
Type: Online System Single

Return Value

Type: PdfUnit
See Also
PdfUnit Class
PdfUnit Members
ByName Overload
NFX.Media.PDF.Styling Namespace


PdfUnit.Equals Method

PdfUnit Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides Online Object Equals(Object).)
Public method | Equals(PdfUnit) |
Back to Top
See Also
PdfUnit Class
PdfUnit Members
NFX.Media.PDF.Styling Namespace


PdfUnit.Equals Method (Object)

PdfUnit Equals Method (Object) NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
PdfUnit Class
PdfUnit Members
Equals Overload
NFX.Media.PDF.Styling Namespace


PdfUnit.Equals Method (PdfUnit)

PdfUnit Equals Method (PdfUnit) NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    PdfUnit other
)
public bool Equals(
    PdfUnit other
)
Public Function Equals (
    other As PdfUnit
) As Boolean
Public Function Equals (
    other As PdfUnit
) As Boolean
public:
virtual bool Equals(
    PdfUnit^ other
) sealed
public:
virtual bool Equals(
    PdfUnit^ other
) sealed
abstract Equals :
        other : PdfUnit -> bool
override Equals :
        other : PdfUnit -> bool
abstract Equals :
        other : PdfUnit -> bool
override Equals :
        other : PdfUnit -> bool

Parameters

other
Type: NFX.Media.PDF.Styling PdfUnit

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
PdfUnit Class
PdfUnit Members
Equals Overload
NFX.Media.PDF.Styling Namespace


PdfUnit.GetHashCode Method

PdfUnit GetHashCode Method NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
PdfUnit Class
PdfUnit Members
NFX.Media.PDF.Styling Namespace


PdfUnit.ToString Method

PdfUnit ToString Method NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
PdfUnit Class
PdfUnit Members
NFX.Media.PDF.Styling Namespace


PdfUnit Properties

PdfUnit Properties NFX Class Library

The PdfUnit type exposes the following members.
Properties
 | Name | Description
 | Centimeter |
 | Default |
 | Inch |
 | Millimeter |
Public property | Name |
 | Point |
Public property | Points | Number of default user space units in current unit (1 default user space unit is 1/72 inch)
Back to Top
See Also
PdfUnit Class
NFX.Media.PDF.Styling Namespace


PdfUnit.Centimeter Property

PdfUnit Centimeter Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfUnit Centimeter { get; }
public static PdfUnit Centimeter { get; }
Public Shared ReadOnly Property Centimeter As PdfUnit
    Get
Public Shared ReadOnly Property Centimeter As PdfUnit
    Get
public:
static property PdfUnit^ Centimeter {
    PdfUnit^ get ();
}
public:
static property PdfUnit^ Centimeter {
    PdfUnit^ get ();
}
static member Centimeter : PdfUnit with get
static member Centimeter : PdfUnit with get

Property Value

Type: PdfUnit
See Also
PdfUnit Class
PdfUnit Members
NFX.Media.PDF.Styling Namespace


PdfUnit.Default Property

PdfUnit Default Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfUnit Default { get; }
public static PdfUnit Default { get; }
Public Shared ReadOnly Property Default As PdfUnit
    Get
Public Shared ReadOnly Property Default As PdfUnit
    Get
public:
static property PdfUnit^ Default {
    PdfUnit^ get ();
}
public:
static property PdfUnit^ Default {
    PdfUnit^ get ();
}
static member Default : PdfUnit with get
static member Default : PdfUnit with get

Property Value

Type: PdfUnit
See Also
PdfUnit Class
PdfUnit Members
NFX.Media.PDF.Styling Namespace


PdfUnit.Inch Property

PdfUnit Inch Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfUnit Inch { get; }
public static PdfUnit Inch { get; }
Public Shared ReadOnly Property Inch As PdfUnit
    Get
Public Shared ReadOnly Property Inch As PdfUnit
    Get
public:
static property PdfUnit^ Inch {
    PdfUnit^ get ();
}
public:
static property PdfUnit^ Inch {
    PdfUnit^ get ();
}
static member Inch : PdfUnit with get
static member Inch : PdfUnit with get

Property Value

Type: PdfUnit
See Also
PdfUnit Class
PdfUnit Members
NFX.Media.PDF.Styling Namespace


PdfUnit.Millimeter Property

PdfUnit Millimeter Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfUnit Millimeter { get; }
public static PdfUnit Millimeter { get; }
Public Shared ReadOnly Property Millimeter As PdfUnit
    Get
Public Shared ReadOnly Property Millimeter As PdfUnit
    Get
public:
static property PdfUnit^ Millimeter {
    PdfUnit^ get ();
}
public:
static property PdfUnit^ Millimeter {
    PdfUnit^ get ();
}
static member Millimeter : PdfUnit with get
static member Millimeter : PdfUnit with get

Property Value

Type: PdfUnit
See Also
PdfUnit Class
PdfUnit Members
NFX.Media.PDF.Styling Namespace


PdfUnit.Name Property

PdfUnit Name Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
PdfUnit Class
PdfUnit Members
NFX.Media.PDF.Styling Namespace


PdfUnit.Point Property

PdfUnit Point Property NFX Class Library

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PdfUnit Point { get; }
public static PdfUnit Point { get; }
Public Shared ReadOnly Property Point As PdfUnit
    Get
Public Shared ReadOnly Property Point As PdfUnit
    Get
public:
static property PdfUnit^ Point {
    PdfUnit^ get ();
}
public:
static property PdfUnit^ Point {
    PdfUnit^ get ();
}
static member Point : PdfUnit with get
static member Point : PdfUnit with get

Property Value

Type: PdfUnit
See Also
PdfUnit Class
PdfUnit Members
NFX.Media.PDF.Styling Namespace


PdfUnit.Points Property

PdfUnit Points Property NFX Class Library

Number of default user space units in current unit (1 default user space unit is 1/72 inch)

Namespace: NFX.Media.PDF.Styling
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float Points { get; }
public float Points { get; }
Public ReadOnly Property Points As Single
    Get
Public ReadOnly Property Points As Single
    Get
public:
property float Points {
    float get ();
}
public:
property float Points {
    float get ();
}
member Points : float32 with get
member Points : float32 with get

Property Value

Type: Online Single
See Also
PdfUnit Class
PdfUnit Members
NFX.Media.PDF.Styling Namespace


NFX.Media.PDF.Text Namespace

NFX.Media.PDF.Text Namespace NFX Class Library

Classes
 | Class | Description
Protected class | PdfTrivialEncoding | The trivial encoding is simply the identity relation between characters and bytes.
Protected class | PdfUnicodeEncoding | Unicode strings encoding.
Public class | TextAdapter | Utility class for operations with text


PdfTrivialEncoding Class

PdfTrivialEncoding Class NFX Class Library

The trivial encoding is simply the identity relation between characters and bytes.
Inheritance Hierarchy
Online System Object
Online System.Text Encoding
NFX.Media.PDF.Text PdfTrivialEncoding

Namespace: NFX.Media.PDF.Text
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal sealed class PdfTrivialEncoding : Encoding
internal sealed class PdfTrivialEncoding : Encoding
Friend NotInheritable Class PdfTrivialEncoding
    Inherits Encoding
Friend NotInheritable Class PdfTrivialEncoding
    Inherits Encoding
internal ref class PdfTrivialEncoding sealed : public Encoding
internal ref class PdfTrivialEncoding sealed : public Encoding
[<SealedAttribute>]
type PdfTrivialEncoding =
    class
        inherit Encoding
    end
[<SealedAttribute>]
type PdfTrivialEncoding =
    class
        inherit Encoding
    end
See Also
PdfTrivialEncoding Members
NFX.Media.PDF.Text Namespace


PdfTrivialEncoding Members

PdfTrivialEncoding Members NFX Class Library

The PdfTrivialEncoding type exposes the following members.
Constructors
 | Name | Description
Public method | PdfTrivialEncoding | Initializes a new instance of the PdfTrivialEncoding class
Back to Top
Methods
 | Name | Description
Public method | Online Clone | When overridden in a derived class, creates a shallow copy of the current Online Encoding object. (Inherited from Online Encoding.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current instance. (Inherited from Online Encoding.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetByteCount( Char ) | When overridden in a derived class, calculates the number of bytes produced by encoding all the characters in the specified character array. (Inherited from Online Encoding.)
Public method | Online GetByteCount(String) | When overridden in a derived class, calculates the number of bytes produced by encoding the characters in the specified string. (Inherited from Online Encoding.)
Public method | Online GetByteCount(Char*, Int32) | When overridden in a derived class, calculates the number of bytes produced by encoding a set of characters starting at the specified character pointer. (Inherited from Online Encoding.)
Public method | GetByteCount( Char , Int32, Int32) | (Overrides Online Encoding GetByteCount( Char , Int32, Int32).)
Public method | Online GetBytes( Char ) | When overridden in a derived class, encodes all the characters in the specified character array into a sequence of bytes. (Inherited from Online Encoding.)
Public method | Online GetBytes(String) | When overridden in a derived class, encodes all the characters in the specified string into a sequence of bytes. (Inherited from Online Encoding.)
Public method | Online GetBytes( Char , Int32, Int32) | When overridden in a derived class, encodes a set of characters from the specified character array into a sequence of bytes. (Inherited from Online Encoding.)
Public method | Online GetBytes(Char*, Int32, Byte*, Int32) | When overridden in a derived class, encodes a set of characters starting at the specified character pointer into a sequence of bytes that are stored starting at the specified byte pointer. (Inherited from Online Encoding.)
Public method | Online GetBytes(String, Int32, Int32, Byte , Int32) | When overridden in a derived class, encodes a set of characters from the specified string into the specified byte array. (Inherited from Online Encoding.)
Public method | GetBytes( Char , Int32, Int32, Byte , Int32) | (Overrides Online Encoding GetBytes( Char , Int32, Int32, Byte , Int32).)
Public method | Online GetCharCount( Byte ) | When overridden in a derived class, calculates the number of characters produced by decoding all the bytes in the specified byte array. (Inherited from Online Encoding.)
Public method | Online GetCharCount(Byte*, Int32) | When overridden in a derived class, calculates the number of characters produced by decoding a sequence of bytes starting at the specified byte pointer. (Inherited from Online Encoding.)
Public method | GetCharCount( Byte , Int32, Int32) | (Overrides Online Encoding GetCharCount( Byte , Int32, Int32).)
Public method | Online GetChars( Byte ) | When overridden in a derived class, decodes all the bytes in the specified byte array into a set of characters. (Inherited from Online Encoding.)
Public method | Online GetChars( Byte , Int32, Int32) | When overridden in a derived class, decodes a sequence of bytes from the specified byte array into a set of characters. (Inherited from Online Encoding.)
Public method | Online GetChars(Byte*, Int32, Char*, Int32) | When overridden in a derived class, decodes a sequence of bytes starting at the specified byte pointer into a set of characters that are stored starting at the specified character pointer. (Inherited from Online Encoding.)
Public method | GetChars( Byte , Int32, Int32, Char , Int32) | (Overrides Online Encoding GetChars( Byte , Int32, Int32, Char , Int32).)
Public method | Online GetDecoder | When overridden in a derived class, obtains a decoder that converts an encoded sequence of bytes into a sequence of characters. (Inherited from Online Encoding.)
Public method | Online GetEncoder | When overridden in a derived class, obtains an encoder that converts a sequence of Unicode characters into an encoded sequence of bytes. (Inherited from Online Encoding.)
Public method | Online GetHashCode | Returns the hash code for the current instance. (Inherited from Online Encoding.)
Public method | GetMaxByteCount | (Overrides Online Encoding GetMaxByteCount(Int32).)
Public method | GetMaxCharCount | (Overrides Online Encoding GetMaxCharCount(Int32).)
Public method | Online GetPreamble | When overridden in a derived class, returns a sequence of bytes that specifies the encoding used. (Inherited from Online Encoding.)
Public method | Online GetString( Byte ) | When overridden in a derived class, decodes all the bytes in the specified byte array into a string. (Inherited from Online Encoding.)
Public method | Online GetString( Byte , Int32, Int32) | When overridden in a derived class, decodes a sequence of bytes from the specified byte array into a string. (Inherited from Online Encoding.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsAlwaysNormalized | Gets a value indicating whether the current encoding is always normalized, using the default normalization form. (Inherited from Online Encoding.)
Public method | Online IsAlwaysNormalized(NormalizationForm) | When overridden in a derived class, gets a value indicating whether the current encoding is always normalized, using the specified normalization form. (Inherited from Online Encoding.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online BodyName | When overridden in a derived class, gets a name for the current encoding that can be used with mail agent body tags. (Inherited from Online Encoding.)
Public property | Online CodePage | When overridden in a derived class, gets the code page identifier of the current Online Encoding. (Inherited from Online Encoding.)
Public property | Online DecoderFallback | Gets or sets the Online DecoderFallback object for the current Online Encoding object. (Inherited from Online Encoding.)
Public property | Online EncoderFallback | Gets or sets the Online EncoderFallback object for the current Online Encoding object. (Inherited from Online Encoding.)
Public property | Online EncodingName | When overridden in a derived class, gets the human-readable description of the current encoding. (Inherited from Online Encoding.)
Public property | Online HeaderName | When overridden in a derived class, gets a name for the current encoding that can be used with mail agent header tags. (Inherited from Online Encoding.)
Public property | Online IsBrowserDisplay | When overridden in a derived class, gets a value indicating whether the current encoding can be used by browser clients for displaying content. (Inherited from Online Encoding.)
Public property | Online IsBrowserSave | When overridden in a derived class, gets a value indicating whether the current encoding can be used by browser clients for saving content. (Inherited from Online Encoding.)
Public property | Online IsMailNewsDisplay | When overridden in a derived class, gets a value indicating whether the current encoding can be used by mail and news clients for displaying content. (Inherited from Online Encoding.)
Public property | Online IsMailNewsSave | When overridden in a derived class, gets a value indicating whether the current encoding can be used by mail and news clients for saving content. (Inherited from Online Encoding.)
Public property | Online IsReadOnly | When overridden in a derived class, gets a value indicating whether the current encoding is read-only. (Inherited from Online Encoding.)
Public property | Online IsSingleByte | When overridden in a derived class, gets a value indicating whether the current encoding uses single-byte code points. (Inherited from Online Encoding.)
Public property | Online WebName | When overridden in a derived class, gets the name registered with the Internet Assigned Numbers Authority (IANA) for the current encoding. (Inherited from Online Encoding.)
Public property | Online WindowsCodePage | When overridden in a derived class, gets the Windows operating system code page that most closely corresponds to the current encoding. (Inherited from Online Encoding.)
Back to Top
See Also
PdfTrivialEncoding Class
NFX.Media.PDF.Text Namespace


PdfTrivialEncoding Constructor

PdfTrivialEncoding Constructor NFX Class Library

Initializes a new instance of the PdfTrivialEncoding class

Namespace: NFX.Media.PDF.Text
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfTrivialEncoding()
public PdfTrivialEncoding()
Public Sub New
Public Sub New
public:
PdfTrivialEncoding()
public:
PdfTrivialEncoding()
new : unit -> PdfTrivialEncoding
new : unit -> PdfTrivialEncoding
See Also
PdfTrivialEncoding Class
PdfTrivialEncoding Members
NFX.Media.PDF.Text Namespace


PdfTrivialEncoding Methods

PdfTrivialEncoding Methods NFX Class Library

The PdfTrivialEncoding type exposes the following members.
Methods
 | Name | Description
Public method | Online Clone | When overridden in a derived class, creates a shallow copy of the current Online Encoding object. (Inherited from Online Encoding.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current instance. (Inherited from Online Encoding.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetByteCount( Char ) | When overridden in a derived class, calculates the number of bytes produced by encoding all the characters in the specified character array. (Inherited from Online Encoding.)
Public method | Online GetByteCount(String) | When overridden in a derived class, calculates the number of bytes produced by encoding the characters in the specified string. (Inherited from Online Encoding.)
Public method | Online GetByteCount(Char*, Int32) | When overridden in a derived class, calculates the number of bytes produced by encoding a set of characters starting at the specified character pointer. (Inherited from Online Encoding.)
Public method | GetByteCount( Char , Int32, Int32) | (Overrides Online Encoding GetByteCount( Char , Int32, Int32).)
Public method | Online GetBytes( Char ) | When overridden in a derived class, encodes all the characters in the specified character array into a sequence of bytes. (Inherited from Online Encoding.)
Public method | Online GetBytes(String) | When overridden in a derived class, encodes all the characters in the specified string into a sequence of bytes. (Inherited from Online Encoding.)
Public method | Online GetBytes( Char , Int32, Int32) | When overridden in a derived class, encodes a set of characters from the specified character array into a sequence of bytes. (Inherited from Online Encoding.)
Public method | Online GetBytes(Char*, Int32, Byte*, Int32) | When overridden in a derived class, encodes a set of characters starting at the specified character pointer into a sequence of bytes that are stored starting at the specified byte pointer. (Inherited from Online Encoding.)
Public method | Online GetBytes(String, Int32, Int32, Byte , Int32) | When overridden in a derived class, encodes a set of characters from the specified string into the specified byte array. (Inherited from Online Encoding.)
Public method | GetBytes( Char , Int32, Int32, Byte , Int32) | (Overrides Online Encoding GetBytes( Char , Int32, Int32, Byte , Int32).)
Public method | Online GetCharCount( Byte ) | When overridden in a derived class, calculates the number of characters produced by decoding all the bytes in the specified byte array. (Inherited from Online Encoding.)
Public method | Online GetCharCount(Byte*, Int32) | When overridden in a derived class, calculates the number of characters produced by decoding a sequence of bytes starting at the specified byte pointer. (Inherited from Online Encoding.)
Public method | GetCharCount( Byte , Int32, Int32) | (Overrides Online Encoding GetCharCount( Byte , Int32, Int32).)
Public method | Online GetChars( Byte ) | When overridden in a derived class, decodes all the bytes in the specified byte array into a set of characters. (Inherited from Online Encoding.)
Public method | Online GetChars( Byte , Int32, Int32) | When overridden in a derived class, decodes a sequence of bytes from the specified byte array into a set of characters. (Inherited from Online Encoding.)
Public method | Online GetChars(Byte*, Int32, Char*, Int32) | When overridden in a derived class, decodes a sequence of bytes starting at the specified byte pointer into a set of characters that are stored starting at the specified character pointer. (Inherited from Online Encoding.)
Public method | GetChars( Byte , Int32, Int32, Char , Int32) | (Overrides Online Encoding GetChars( Byte , Int32, Int32, Char , Int32).)
Public method | Online GetDecoder | When overridden in a derived class, obtains a decoder that converts an encoded sequence of bytes into a sequence of characters. (Inherited from Online Encoding.)
Public method | Online GetEncoder | When overridden in a derived class, obtains an encoder that converts a sequence of Unicode characters into an encoded sequence of bytes. (Inherited from Online Encoding.)
Public method | Online GetHashCode | Returns the hash code for the current instance. (Inherited from Online Encoding.)
Public method | GetMaxByteCount | (Overrides Online Encoding GetMaxByteCount(Int32).)
Public method | GetMaxCharCount | (Overrides Online Encoding GetMaxCharCount(Int32).)
Public method | Online GetPreamble | When overridden in a derived class, returns a sequence of bytes that specifies the encoding used. (Inherited from Online Encoding.)
Public method | Online GetString( Byte ) | When overridden in a derived class, decodes all the bytes in the specified byte array into a string. (Inherited from Online Encoding.)
Public method | Online GetString( Byte , Int32, Int32) | When overridden in a derived class, decodes a sequence of bytes from the specified byte array into a string. (Inherited from Online Encoding.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsAlwaysNormalized | Gets a value indicating whether the current encoding is always normalized, using the default normalization form. (Inherited from Online Encoding.)
Public method | Online IsAlwaysNormalized(NormalizationForm) | When overridden in a derived class, gets a value indicating whether the current encoding is always normalized, using the specified normalization form. (Inherited from Online Encoding.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PdfTrivialEncoding Class
NFX.Media.PDF.Text Namespace


PdfTrivialEncoding.GetByteCount Method

PdfTrivialEncoding GetByteCount Method NFX Class Library

Overload List
 | Name | Description
Public method | Online GetByteCount( Char ) | When overridden in a derived class, calculates the number of bytes produced by encoding all the characters in the specified character array. (Inherited from Online Encoding.)
Public method | Online GetByteCount(String) | When overridden in a derived class, calculates the number of bytes produced by encoding the characters in the specified string. (Inherited from Online Encoding.)
Public method | Online GetByteCount(Char*, Int32) | When overridden in a derived class, calculates the number of bytes produced by encoding a set of characters starting at the specified character pointer. (Inherited from Online Encoding.)
Public method | GetByteCount( Char , Int32, Int32) | (Overrides Online Encoding GetByteCount( Char , Int32, Int32).)
Back to Top
See Also
PdfTrivialEncoding Class
PdfTrivialEncoding Members
NFX.Media.PDF.Text Namespace


PdfTrivialEncoding.GetByteCount Method (Char[], Int32, Int32)

PdfTrivialEncoding GetByteCount Method ( Char , Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Media.PDF.Text
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetByteCount(
    char[] chars,
    int index,
    int count
)
public override int GetByteCount(
    char[] chars,
    int index,
    int count
)
Public Overrides Function GetByteCount (
    chars As Char(),
    index As Integer,
    count As Integer
) As Integer
Public Overrides Function GetByteCount (
    chars As Char(),
    index As Integer,
    count As Integer
) As Integer
public:
virtual int GetByteCount(
    array<wchar_t>^ chars,
    int index,
    int count
) override
public:
virtual int GetByteCount(
    array<wchar_t>^ chars,
    int index,
    int count
) override
abstract GetByteCount :
        chars : char[] *
        index : int *
        count : int -> int
override GetByteCount :
        chars : char[] *
        index : int *
        count : int -> int
abstract GetByteCount :
        chars : char[] *
        index : int *
        count : int -> int
override GetByteCount :
        chars : char[] *
        index : int *
        count : int -> int

Parameters

chars
Type: Online System Char
index
Type: Online System Int32
count
Type: Online System Int32

Return Value

Type: Online Int32
See Also
PdfTrivialEncoding Class
PdfTrivialEncoding Members
GetByteCount Overload
NFX.Media.PDF.Text Namespace


PdfTrivialEncoding.GetBytes Method

PdfTrivialEncoding GetBytes Method NFX Class Library

Overload List
 | Name | Description
Public method | Online GetBytes( Char ) | When overridden in a derived class, encodes all the characters in the specified character array into a sequence of bytes. (Inherited from Online Encoding.)
Public method | Online GetBytes(String) | When overridden in a derived class, encodes all the characters in the specified string into a sequence of bytes. (Inherited from Online Encoding.)
Public method | Online GetBytes( Char , Int32, Int32) | When overridden in a derived class, encodes a set of characters from the specified character array into a sequence of bytes. (Inherited from Online Encoding.)
Public method | Online GetBytes(Char*, Int32, Byte*, Int32) | When overridden in a derived class, encodes a set of characters starting at the specified character pointer into a sequence of bytes that are stored starting at the specified byte pointer. (Inherited from Online Encoding.)
Public method | Online GetBytes(String, Int32, Int32, Byte , Int32) | When overridden in a derived class, encodes a set of characters from the specified string into the specified byte array. (Inherited from Online Encoding.)
Public method | GetBytes( Char , Int32, Int32, Byte , Int32) | (Overrides Online Encoding GetBytes( Char , Int32, Int32, Byte , Int32).)
Back to Top
See Also
PdfTrivialEncoding Class
PdfTrivialEncoding Members
NFX.Media.PDF.Text Namespace


PdfTrivialEncoding.GetBytes Method (Char[], Int32, Int32, Byte[], Int32)

PdfTrivialEncoding GetBytes Method ( Char , Int32, Int32, Byte , Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Media.PDF.Text
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetBytes(
    char[] chars,
    int charIndex,
    int charCount,
    byte[] bytes,
    int byteIndex
)
public override int GetBytes(
    char[] chars,
    int charIndex,
    int charCount,
    byte[] bytes,
    int byteIndex
)
Public Overrides Function GetBytes (
    chars As Char(),
    charIndex As Integer,
    charCount As Integer,
    bytes As Byte(),
    byteIndex As Integer
) As Integer
Public Overrides Function GetBytes (
    chars As Char(),
    charIndex As Integer,
    charCount As Integer,
    bytes As Byte(),
    byteIndex As Integer
) As Integer
public:
virtual int GetBytes(
    array<wchar_t>^ chars,
    int charIndex,
    int charCount,
    array<unsigned char>^ bytes,
    int byteIndex
) override
public:
virtual int GetBytes(
    array<wchar_t>^ chars,
    int charIndex,
    int charCount,
    array<unsigned char>^ bytes,
    int byteIndex
) override
abstract GetBytes :
        chars : char[] *
        charIndex : int *
        charCount : int *
        bytes : byte[] *
        byteIndex : int -> int
override GetBytes :
        chars : char[] *
        charIndex : int *
        charCount : int *
        bytes : byte[] *
        byteIndex : int -> int
abstract GetBytes :
        chars : char[] *
        charIndex : int *
        charCount : int *
        bytes : byte[] *
        byteIndex : int -> int
override GetBytes :
        chars : char[] *
        charIndex : int *
        charCount : int *
        bytes : byte[] *
        byteIndex : int -> int

Parameters

chars
Type: Online System Char
charIndex
Type: Online System Int32
charCount
Type: Online System Int32
bytes
Type: Online System Byte
byteIndex
Type: Online System Int32

Return Value

Type: Online Int32
See Also
PdfTrivialEncoding Class
PdfTrivialEncoding Members
GetBytes Overload
NFX.Media.PDF.Text Namespace


PdfTrivialEncoding.GetCharCount Method

PdfTrivialEncoding GetCharCount Method NFX Class Library

Overload List
 | Name | Description
Public method | Online GetCharCount( Byte ) | When overridden in a derived class, calculates the number of characters produced by decoding all the bytes in the specified byte array. (Inherited from Online Encoding.)
Public method | Online GetCharCount(Byte*, Int32) | When overridden in a derived class, calculates the number of characters produced by decoding a sequence of bytes starting at the specified byte pointer. (Inherited from Online Encoding.)
Public method | GetCharCount( Byte , Int32, Int32) | (Overrides Online Encoding GetCharCount( Byte , Int32, Int32).)
Back to Top
See Also
PdfTrivialEncoding Class
PdfTrivialEncoding Members
NFX.Media.PDF.Text Namespace


PdfTrivialEncoding.GetCharCount Method (Byte[], Int32, Int32)

PdfTrivialEncoding GetCharCount Method ( Byte , Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Media.PDF.Text
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetCharCount(
    byte[] bytes,
    int index,
    int count
)
public override int GetCharCount(
    byte[] bytes,
    int index,
    int count
)
Public Overrides Function GetCharCount (
    bytes As Byte(),
    index As Integer,
    count As Integer
) As Integer
Public Overrides Function GetCharCount (
    bytes As Byte(),
    index As Integer,
    count As Integer
) As Integer
public:
virtual int GetCharCount(
    array<unsigned char>^ bytes,
    int index,
    int count
) override
public:
virtual int GetCharCount(
    array<unsigned char>^ bytes,
    int index,
    int count
) override
abstract GetCharCount :
        bytes : byte[] *
        index : int *
        count : int -> int
override GetCharCount :
        bytes : byte[] *
        index : int *
        count : int -> int
abstract GetCharCount :
        bytes : byte[] *
        index : int *
        count : int -> int
override GetCharCount :
        bytes : byte[] *
        index : int *
        count : int -> int

Parameters

bytes
Type: Online System Byte
index
Type: Online System Int32
count
Type: Online System Int32

Return Value

Type: Online Int32
See Also
PdfTrivialEncoding Class
PdfTrivialEncoding Members
GetCharCount Overload
NFX.Media.PDF.Text Namespace


PdfTrivialEncoding.GetChars Method

PdfTrivialEncoding GetChars Method NFX Class Library

Overload List
 | Name | Description
Public method | Online GetChars( Byte ) | When overridden in a derived class, decodes all the bytes in the specified byte array into a set of characters. (Inherited from Online Encoding.)
Public method | Online GetChars( Byte , Int32, Int32) | When overridden in a derived class, decodes a sequence of bytes from the specified byte array into a set of characters. (Inherited from Online Encoding.)
Public method | Online GetChars(Byte*, Int32, Char*, Int32) | When overridden in a derived class, decodes a sequence of bytes starting at the specified byte pointer into a set of characters that are stored starting at the specified character pointer. (Inherited from Online Encoding.)
Public method | GetChars( Byte , Int32, Int32, Char , Int32) | (Overrides Online Encoding GetChars( Byte , Int32, Int32, Char , Int32).)
Back to Top
See Also
PdfTrivialEncoding Class
PdfTrivialEncoding Members
NFX.Media.PDF.Text Namespace


PdfTrivialEncoding.GetChars Method (Byte[], Int32, Int32, Char[], Int32)

PdfTrivialEncoding GetChars Method ( Byte , Int32, Int32, Char , Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Media.PDF.Text
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetChars(
    byte[] bytes,
    int byteIndex,
    int byteCount,
    char[] chars,
    int charIndex
)
public override int GetChars(
    byte[] bytes,
    int byteIndex,
    int byteCount,
    char[] chars,
    int charIndex
)
Public Overrides Function GetChars (
    bytes As Byte(),
    byteIndex As Integer,
    byteCount As Integer,
    chars As Char(),
    charIndex As Integer
) As Integer
Public Overrides Function GetChars (
    bytes As Byte(),
    byteIndex As Integer,
    byteCount As Integer,
    chars As Char(),
    charIndex As Integer
) As Integer
public:
virtual int GetChars(
    array<unsigned char>^ bytes,
    int byteIndex,
    int byteCount,
    array<wchar_t>^ chars,
    int charIndex
) override
public:
virtual int GetChars(
    array<unsigned char>^ bytes,
    int byteIndex,
    int byteCount,
    array<wchar_t>^ chars,
    int charIndex
) override
abstract GetChars :
        bytes : byte[] *
        byteIndex : int *
        byteCount : int *
        chars : char[] *
        charIndex : int -> int
override GetChars :
        bytes : byte[] *
        byteIndex : int *
        byteCount : int *
        chars : char[] *
        charIndex : int -> int
abstract GetChars :
        bytes : byte[] *
        byteIndex : int *
        byteCount : int *
        chars : char[] *
        charIndex : int -> int
override GetChars :
        bytes : byte[] *
        byteIndex : int *
        byteCount : int *
        chars : char[] *
        charIndex : int -> int

Parameters

bytes
Type: Online System Byte
byteIndex
Type: Online System Int32
byteCount
Type: Online System Int32
chars
Type: Online System Char
charIndex
Type: Online System Int32

Return Value

Type: Online Int32
See Also
PdfTrivialEncoding Class
PdfTrivialEncoding Members
GetChars Overload
NFX.Media.PDF.Text Namespace


PdfTrivialEncoding.GetMaxByteCount Method

PdfTrivialEncoding GetMaxByteCount Method NFX Class Library

Namespace: NFX.Media.PDF.Text
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetMaxByteCount(
    int charCount
)
public override int GetMaxByteCount(
    int charCount
)
Public Overrides Function GetMaxByteCount (
    charCount As Integer
) As Integer
Public Overrides Function GetMaxByteCount (
    charCount As Integer
) As Integer
public:
virtual int GetMaxByteCount(
    int charCount
) override
public:
virtual int GetMaxByteCount(
    int charCount
) override
abstract GetMaxByteCount :
        charCount : int -> int
override GetMaxByteCount :
        charCount : int -> int
abstract GetMaxByteCount :
        charCount : int -> int
override GetMaxByteCount :
        charCount : int -> int

Parameters

charCount
Type: Online System Int32

Return Value

Type: Online Int32
See Also
PdfTrivialEncoding Class
PdfTrivialEncoding Members
NFX.Media.PDF.Text Namespace


PdfTrivialEncoding.GetMaxCharCount Method

PdfTrivialEncoding GetMaxCharCount Method NFX Class Library

Namespace: NFX.Media.PDF.Text
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetMaxCharCount(
    int byteCount
)
public override int GetMaxCharCount(
    int byteCount
)
Public Overrides Function GetMaxCharCount (
    byteCount As Integer
) As Integer
Public Overrides Function GetMaxCharCount (
    byteCount As Integer
) As Integer
public:
virtual int GetMaxCharCount(
    int byteCount
) override
public:
virtual int GetMaxCharCount(
    int byteCount
) override
abstract GetMaxCharCount :
        byteCount : int -> int
override GetMaxCharCount :
        byteCount : int -> int
abstract GetMaxCharCount :
        byteCount : int -> int
override GetMaxCharCount :
        byteCount : int -> int

Parameters

byteCount
Type: Online System Int32

Return Value

Type: Online Int32
See Also
PdfTrivialEncoding Class
PdfTrivialEncoding Members
NFX.Media.PDF.Text Namespace


PdfTrivialEncoding Properties

PdfTrivialEncoding Properties NFX Class Library

The PdfTrivialEncoding type exposes the following members.
Properties
 | Name | Description
Public property | Online BodyName | When overridden in a derived class, gets a name for the current encoding that can be used with mail agent body tags. (Inherited from Online Encoding.)
Public property | Online CodePage | When overridden in a derived class, gets the code page identifier of the current Online Encoding. (Inherited from Online Encoding.)
Public property | Online DecoderFallback | Gets or sets the Online DecoderFallback object for the current Online Encoding object. (Inherited from Online Encoding.)
Public property | Online EncoderFallback | Gets or sets the Online EncoderFallback object for the current Online Encoding object. (Inherited from Online Encoding.)
Public property | Online EncodingName | When overridden in a derived class, gets the human-readable description of the current encoding. (Inherited from Online Encoding.)
Public property | Online HeaderName | When overridden in a derived class, gets a name for the current encoding that can be used with mail agent header tags. (Inherited from Online Encoding.)
Public property | Online IsBrowserDisplay | When overridden in a derived class, gets a value indicating whether the current encoding can be used by browser clients for displaying content. (Inherited from Online Encoding.)
Public property | Online IsBrowserSave | When overridden in a derived class, gets a value indicating whether the current encoding can be used by browser clients for saving content. (Inherited from Online Encoding.)
Public property | Online IsMailNewsDisplay | When overridden in a derived class, gets a value indicating whether the current encoding can be used by mail and news clients for displaying content. (Inherited from Online Encoding.)
Public property | Online IsMailNewsSave | When overridden in a derived class, gets a value indicating whether the current encoding can be used by mail and news clients for saving content. (Inherited from Online Encoding.)
Public property | Online IsReadOnly | When overridden in a derived class, gets a value indicating whether the current encoding is read-only. (Inherited from Online Encoding.)
Public property | Online IsSingleByte | When overridden in a derived class, gets a value indicating whether the current encoding uses single-byte code points. (Inherited from Online Encoding.)
Public property | Online WebName | When overridden in a derived class, gets the name registered with the Internet Assigned Numbers Authority (IANA) for the current encoding. (Inherited from Online Encoding.)
Public property | Online WindowsCodePage | When overridden in a derived class, gets the Windows operating system code page that most closely corresponds to the current encoding. (Inherited from Online Encoding.)
Back to Top
See Also
PdfTrivialEncoding Class
NFX.Media.PDF.Text Namespace


PdfUnicodeEncoding Class

PdfUnicodeEncoding Class NFX Class Library

Unicode strings encoding.
Inheritance Hierarchy
Online System Object
Online System.Text Encoding
NFX.Media.PDF.Text PdfUnicodeEncoding

Namespace: NFX.Media.PDF.Text
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal sealed class PdfUnicodeEncoding : Encoding
internal sealed class PdfUnicodeEncoding : Encoding
Friend NotInheritable Class PdfUnicodeEncoding
    Inherits Encoding
Friend NotInheritable Class PdfUnicodeEncoding
    Inherits Encoding
internal ref class PdfUnicodeEncoding sealed : public Encoding
internal ref class PdfUnicodeEncoding sealed : public Encoding
[<SealedAttribute>]
type PdfUnicodeEncoding =
    class
        inherit Encoding
    end
[<SealedAttribute>]
type PdfUnicodeEncoding =
    class
        inherit Encoding
    end
See Also
PdfUnicodeEncoding Members
NFX.Media.PDF.Text Namespace


PdfUnicodeEncoding Members

PdfUnicodeEncoding Members NFX Class Library

The PdfUnicodeEncoding type exposes the following members.
Constructors
 | Name | Description
Public method | PdfUnicodeEncoding | Initializes a new instance of the PdfUnicodeEncoding class
Back to Top
Methods
 | Name | Description
Public method | Online Clone | When overridden in a derived class, creates a shallow copy of the current Online Encoding object. (Inherited from Online Encoding.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current instance. (Inherited from Online Encoding.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetByteCount( Char ) | When overridden in a derived class, calculates the number of bytes produced by encoding all the characters in the specified character array. (Inherited from Online Encoding.)
Public method | Online GetByteCount(String) | When overridden in a derived class, calculates the number of bytes produced by encoding the characters in the specified string. (Inherited from Online Encoding.)
Public method | Online GetByteCount(Char*, Int32) | When overridden in a derived class, calculates the number of bytes produced by encoding a set of characters starting at the specified character pointer. (Inherited from Online Encoding.)
Public method | GetByteCount( Char , Int32, Int32) | (Overrides Online Encoding GetByteCount( Char , Int32, Int32).)
Public method | Online GetBytes( Char ) | When overridden in a derived class, encodes all the characters in the specified character array into a sequence of bytes. (Inherited from Online Encoding.)
Public method | Online GetBytes(String) | When overridden in a derived class, encodes all the characters in the specified string into a sequence of bytes. (Inherited from Online Encoding.)
Public method | Online GetBytes( Char , Int32, Int32) | When overridden in a derived class, encodes a set of characters from the specified character array into a sequence of bytes. (Inherited from Online Encoding.)
Public method | Online GetBytes(Char*, Int32, Byte*, Int32) | When overridden in a derived class, encodes a set of characters starting at the specified character pointer into a sequence of bytes that are stored starting at the specified byte pointer. (Inherited from Online Encoding.)
Public method | Online GetBytes(String, Int32, Int32, Byte , Int32) | When overridden in a derived class, encodes a set of characters from the specified string into the specified byte array. (Inherited from Online Encoding.)
Public method | GetBytes( Char , Int32, Int32, Byte , Int32) | (Overrides Online Encoding GetBytes( Char , Int32, Int32, Byte , Int32).)
Public method | Online GetCharCount( Byte ) | When overridden in a derived class, calculates the number of characters produced by decoding all the bytes in the specified byte array. (Inherited from Online Encoding.)
Public method | Online GetCharCount(Byte*, Int32) | When overridden in a derived class, calculates the number of characters produced by decoding a sequence of bytes starting at the specified byte pointer. (Inherited from Online Encoding.)
Public method | GetCharCount( Byte , Int32, Int32) | (Overrides Online Encoding GetCharCount( Byte , Int32, Int32).)
Public method | Online GetChars( Byte ) | When overridden in a derived class, decodes all the bytes in the specified byte array into a set of characters. (Inherited from Online Encoding.)
Public method | Online GetChars( Byte , Int32, Int32) | When overridden in a derived class, decodes a sequence of bytes from the specified byte array into a set of characters. (Inherited from Online Encoding.)
Public method | Online GetChars(Byte*, Int32, Char*, Int32) | When overridden in a derived class, decodes a sequence of bytes starting at the specified byte pointer into a set of characters that are stored starting at the specified character pointer. (Inherited from Online Encoding.)
Public method | GetChars( Byte , Int32, Int32, Char , Int32) | (Overrides Online Encoding GetChars( Byte , Int32, Int32, Char , Int32).)
Public method | Online GetDecoder | When overridden in a derived class, obtains a decoder that converts an encoded sequence of bytes into a sequence of characters. (Inherited from Online Encoding.)
Public method | Online GetEncoder | When overridden in a derived class, obtains an encoder that converts a sequence of Unicode characters into an encoded sequence of bytes. (Inherited from Online Encoding.)
Public method | Online GetHashCode | Returns the hash code for the current instance. (Inherited from Online Encoding.)
Public method | GetMaxByteCount | (Overrides Online Encoding GetMaxByteCount(Int32).)
Public method | GetMaxCharCount | (Overrides Online Encoding GetMaxCharCount(Int32).)
Public method | Online GetPreamble | When overridden in a derived class, returns a sequence of bytes that specifies the encoding used. (Inherited from Online Encoding.)
Public method | Online GetString( Byte ) | When overridden in a derived class, decodes all the bytes in the specified byte array into a string. (Inherited from Online Encoding.)
Public method | Online GetString( Byte , Int32, Int32) | When overridden in a derived class, decodes a sequence of bytes from the specified byte array into a string. (Inherited from Online Encoding.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsAlwaysNormalized | Gets a value indicating whether the current encoding is always normalized, using the default normalization form. (Inherited from Online Encoding.)
Public method | Online IsAlwaysNormalized(NormalizationForm) | When overridden in a derived class, gets a value indicating whether the current encoding is always normalized, using the specified normalization form. (Inherited from Online Encoding.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online BodyName | When overridden in a derived class, gets a name for the current encoding that can be used with mail agent body tags. (Inherited from Online Encoding.)
Public property | Online CodePage | When overridden in a derived class, gets the code page identifier of the current Online Encoding. (Inherited from Online Encoding.)
Public property | Online DecoderFallback | Gets or sets the Online DecoderFallback object for the current Online Encoding object. (Inherited from Online Encoding.)
Public property | Online EncoderFallback | Gets or sets the Online EncoderFallback object for the current Online Encoding object. (Inherited from Online Encoding.)
Public property | Online EncodingName | When overridden in a derived class, gets the human-readable description of the current encoding. (Inherited from Online Encoding.)
Public property | Online HeaderName | When overridden in a derived class, gets a name for the current encoding that can be used with mail agent header tags. (Inherited from Online Encoding.)
Public property | Online IsBrowserDisplay | When overridden in a derived class, gets a value indicating whether the current encoding can be used by browser clients for displaying content. (Inherited from Online Encoding.)
Public property | Online IsBrowserSave | When overridden in a derived class, gets a value indicating whether the current encoding can be used by browser clients for saving content. (Inherited from Online Encoding.)
Public property | Online IsMailNewsDisplay | When overridden in a derived class, gets a value indicating whether the current encoding can be used by mail and news clients for displaying content. (Inherited from Online Encoding.)
Public property | Online IsMailNewsSave | When overridden in a derived class, gets a value indicating whether the current encoding can be used by mail and news clients for saving content. (Inherited from Online Encoding.)
Public property | Online IsReadOnly | When overridden in a derived class, gets a value indicating whether the current encoding is read-only. (Inherited from Online Encoding.)
Public property | Online IsSingleByte | When overridden in a derived class, gets a value indicating whether the current encoding uses single-byte code points. (Inherited from Online Encoding.)
Public property | Online WebName | When overridden in a derived class, gets the name registered with the Internet Assigned Numbers Authority (IANA) for the current encoding. (Inherited from Online Encoding.)
Public property | Online WindowsCodePage | When overridden in a derived class, gets the Windows operating system code page that most closely corresponds to the current encoding. (Inherited from Online Encoding.)
Back to Top
See Also
PdfUnicodeEncoding Class
NFX.Media.PDF.Text Namespace


PdfUnicodeEncoding Constructor

PdfUnicodeEncoding Constructor NFX Class Library

Initializes a new instance of the PdfUnicodeEncoding class

Namespace: NFX.Media.PDF.Text
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PdfUnicodeEncoding()
public PdfUnicodeEncoding()
Public Sub New
Public Sub New
public:
PdfUnicodeEncoding()
public:
PdfUnicodeEncoding()
new : unit -> PdfUnicodeEncoding
new : unit -> PdfUnicodeEncoding
See Also
PdfUnicodeEncoding Class
PdfUnicodeEncoding Members
NFX.Media.PDF.Text Namespace


PdfUnicodeEncoding Methods

PdfUnicodeEncoding Methods NFX Class Library

The PdfUnicodeEncoding type exposes the following members.
Methods
 | Name | Description
Public method | Online Clone | When overridden in a derived class, creates a shallow copy of the current Online Encoding object. (Inherited from Online Encoding.)
Public method | Online Equals | Determines whether the specified Online Object is equal to the current instance. (Inherited from Online Encoding.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetByteCount( Char ) | When overridden in a derived class, calculates the number of bytes produced by encoding all the characters in the specified character array. (Inherited from Online Encoding.)
Public method | Online GetByteCount(String) | When overridden in a derived class, calculates the number of bytes produced by encoding the characters in the specified string. (Inherited from Online Encoding.)
Public method | Online GetByteCount(Char*, Int32) | When overridden in a derived class, calculates the number of bytes produced by encoding a set of characters starting at the specified character pointer. (Inherited from Online Encoding.)
Public method | GetByteCount( Char , Int32, Int32) | (Overrides Online Encoding GetByteCount( Char , Int32, Int32).)
Public method | Online GetBytes( Char ) | When overridden in a derived class, encodes all the characters in the specified character array into a sequence of bytes. (Inherited from Online Encoding.)
Public method | Online GetBytes(String) | When overridden in a derived class, encodes all the characters in the specified string into a sequence of bytes. (Inherited from Online Encoding.)
Public method | Online GetBytes( Char , Int32, Int32) | When overridden in a derived class, encodes a set of characters from the specified character array into a sequence of bytes. (Inherited from Online Encoding.)
Public method | Online GetBytes(Char*, Int32, Byte*, Int32) | When overridden in a derived class, encodes a set of characters starting at the specified character pointer into a sequence of bytes that are stored starting at the specified byte pointer. (Inherited from Online Encoding.)
Public method | Online GetBytes(String, Int32, Int32, Byte , Int32) | When overridden in a derived class, encodes a set of characters from the specified string into the specified byte array. (Inherited from Online Encoding.)
Public method | GetBytes( Char , Int32, Int32, Byte , Int32) | (Overrides Online Encoding GetBytes( Char , Int32, Int32, Byte , Int32).)
Public method | Online GetCharCount( Byte ) | When overridden in a derived class, calculates the number of characters produced by decoding all the bytes in the specified byte array. (Inherited from Online Encoding.)
Public method | Online GetCharCount(Byte*, Int32) | When overridden in a derived class, calculates the number of characters produced by decoding a sequence of bytes starting at the specified byte pointer. (Inherited from Online Encoding.)
Public method | GetCharCount( Byte , Int32, Int32) | (Overrides Online Encoding GetCharCount( Byte , Int32, Int32).)
Public method | Online GetChars( Byte ) | When overridden in a derived class, decodes all the bytes in the specified byte array into a set of characters. (Inherited from Online Encoding.)
Public method | Online GetChars( Byte , Int32, Int32) | When overridden in a derived class, decodes a sequence of bytes from the specified byte array into a set of characters. (Inherited from Online Encoding.)
Public method | Online GetChars(Byte*, Int32, Char*, Int32) | When overridden in a derived class, decodes a sequence of bytes starting at the specified byte pointer into a set of characters that are stored starting at the specified character pointer. (Inherited from Online Encoding.)
Public method | GetChars( Byte , Int32, Int32, Char , Int32) | (Overrides Online Encoding GetChars( Byte , Int32, Int32, Char , Int32).)
Public method | Online GetDecoder | When overridden in a derived class, obtains a decoder that converts an encoded sequence of bytes into a sequence of characters. (Inherited from Online Encoding.)
Public method | Online GetEncoder | When overridden in a derived class, obtains an encoder that converts a sequence of Unicode characters into an encoded sequence of bytes. (Inherited from Online Encoding.)
Public method | Online GetHashCode | Returns the hash code for the current instance. (Inherited from Online Encoding.)
Public method | GetMaxByteCount | (Overrides Online Encoding GetMaxByteCount(Int32).)
Public method | GetMaxCharCount | (Overrides Online Encoding GetMaxCharCount(Int32).)
Public method | Online GetPreamble | When overridden in a derived class, returns a sequence of bytes that specifies the encoding used. (Inherited from Online Encoding.)
Public method | Online GetString( Byte ) | When overridden in a derived class, decodes all the bytes in the specified byte array into a string. (Inherited from Online Encoding.)
Public method | Online GetString( Byte , Int32, Int32) | When overridden in a derived class, decodes a sequence of bytes from the specified byte array into a string. (Inherited from Online Encoding.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsAlwaysNormalized | Gets a value indicating whether the current encoding is always normalized, using the default normalization form. (Inherited from Online Encoding.)
Public method | Online IsAlwaysNormalized(NormalizationForm) | When overridden in a derived class, gets a value indicating whether the current encoding is always normalized, using the specified normalization form. (Inherited from Online Encoding.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PdfUnicodeEncoding Class
NFX.Media.PDF.Text Namespace


PdfUnicodeEncoding.GetByteCount Method

PdfUnicodeEncoding GetByteCount Method NFX Class Library

Overload List
 | Name | Description
Public method | Online GetByteCount( Char ) | When overridden in a derived class, calculates the number of bytes produced by encoding all the characters in the specified character array. (Inherited from Online Encoding.)
Public method | Online GetByteCount(String) | When overridden in a derived class, calculates the number of bytes produced by encoding the characters in the specified string. (Inherited from Online Encoding.)
Public method | Online GetByteCount(Char*, Int32) | When overridden in a derived class, calculates the number of bytes produced by encoding a set of characters starting at the specified character pointer. (Inherited from Online Encoding.)
Public method | GetByteCount( Char , Int32, Int32) | (Overrides Online Encoding GetByteCount( Char , Int32, Int32).)
Back to Top
See Also
PdfUnicodeEncoding Class
PdfUnicodeEncoding Members
NFX.Media.PDF.Text Namespace


PdfUnicodeEncoding.GetByteCount Method (Char[], Int32, Int32)

PdfUnicodeEncoding GetByteCount Method ( Char , Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Media.PDF.Text
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetByteCount(
    char[] chars,
    int index,
    int count
)
public override int GetByteCount(
    char[] chars,
    int index,
    int count
)
Public Overrides Function GetByteCount (
    chars As Char(),
    index As Integer,
    count As Integer
) As Integer
Public Overrides Function GetByteCount (
    chars As Char(),
    index As Integer,
    count As Integer
) As Integer
public:
virtual int GetByteCount(
    array<wchar_t>^ chars,
    int index,
    int count
) override
public:
virtual int GetByteCount(
    array<wchar_t>^ chars,
    int index,
    int count
) override
abstract GetByteCount :
        chars : char[] *
        index : int *
        count : int -> int
override GetByteCount :
        chars : char[] *
        index : int *
        count : int -> int
abstract GetByteCount :
        chars : char[] *
        index : int *
        count : int -> int
override GetByteCount :
        chars : char[] *
        index : int *
        count : int -> int

Parameters

chars
Type: Online System Char
index
Type: Online System Int32
count
Type: Online System Int32

Return Value

Type: Online Int32
See Also
PdfUnicodeEncoding Class
PdfUnicodeEncoding Members
GetByteCount Overload
NFX.Media.PDF.Text Namespace


PdfUnicodeEncoding.GetBytes Method

PdfUnicodeEncoding GetBytes Method NFX Class Library

Overload List
 | Name | Description
Public method | Online GetBytes( Char ) | When overridden in a derived class, encodes all the characters in the specified character array into a sequence of bytes. (Inherited from Online Encoding.)
Public method | Online GetBytes(String) | When overridden in a derived class, encodes all the characters in the specified string into a sequence of bytes. (Inherited from Online Encoding.)
Public method | Online GetBytes( Char , Int32, Int32) | When overridden in a derived class, encodes a set of characters from the specified character array into a sequence of bytes. (Inherited from Online Encoding.)
Public method | Online GetBytes(Char*, Int32, Byte*, Int32) | When overridden in a derived class, encodes a set of characters starting at the specified character pointer into a sequence of bytes that are stored starting at the specified byte pointer. (Inherited from Online Encoding.)
Public method | Online GetBytes(String, Int32, Int32, Byte , Int32) | When overridden in a derived class, encodes a set of characters from the specified string into the specified byte array. (Inherited from Online Encoding.)
Public method | GetBytes( Char , Int32, Int32, Byte , Int32) | (Overrides Online Encoding GetBytes( Char , Int32, Int32, Byte , Int32).)
Back to Top
See Also
PdfUnicodeEncoding Class
PdfUnicodeEncoding Members
NFX.Media.PDF.Text Namespace


PdfUnicodeEncoding.GetBytes Method (Char[], Int32, Int32, Byte[], Int32)

PdfUnicodeEncoding GetBytes Method ( Char , Int32, Int32, Byte , Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Media.PDF.Text
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetBytes(
    char[] chars,
    int charIndex,
    int charCount,
    byte[] bytes,
    int byteIndex
)
public override int GetBytes(
    char[] chars,
    int charIndex,
    int charCount,
    byte[] bytes,
    int byteIndex
)
Public Overrides Function GetBytes (
    chars As Char(),
    charIndex As Integer,
    charCount As Integer,
    bytes As Byte(),
    byteIndex As Integer
) As Integer
Public Overrides Function GetBytes (
    chars As Char(),
    charIndex As Integer,
    charCount As Integer,
    bytes As Byte(),
    byteIndex As Integer
) As Integer
public:
virtual int GetBytes(
    array<wchar_t>^ chars,
    int charIndex,
    int charCount,
    array<unsigned char>^ bytes,
    int byteIndex
) override
public:
virtual int GetBytes(
    array<wchar_t>^ chars,
    int charIndex,
    int charCount,
    array<unsigned char>^ bytes,
    int byteIndex
) override
abstract GetBytes :
        chars : char[] *
        charIndex : int *
        charCount : int *
        bytes : byte[] *
        byteIndex : int -> int
override GetBytes :
        chars : char[] *
        charIndex : int *
        charCount : int *
        bytes : byte[] *
        byteIndex : int -> int
abstract GetBytes :
        chars : char[] *
        charIndex : int *
        charCount : int *
        bytes : byte[] *
        byteIndex : int -> int
override GetBytes :
        chars : char[] *
        charIndex : int *
        charCount : int *
        bytes : byte[] *
        byteIndex : int -> int

Parameters

chars
Type: Online System Char
charIndex
Type: Online System Int32
charCount
Type: Online System Int32
bytes
Type: Online System Byte
byteIndex
Type: Online System Int32

Return Value

Type: Online Int32
See Also
PdfUnicodeEncoding Class
PdfUnicodeEncoding Members
GetBytes Overload
NFX.Media.PDF.Text Namespace


PdfUnicodeEncoding.GetCharCount Method

PdfUnicodeEncoding GetCharCount Method NFX Class Library

Overload List
 | Name | Description
Public method | Online GetCharCount( Byte ) | When overridden in a derived class, calculates the number of characters produced by decoding all the bytes in the specified byte array. (Inherited from Online Encoding.)
Public method | Online GetCharCount(Byte*, Int32) | When overridden in a derived class, calculates the number of characters produced by decoding a sequence of bytes starting at the specified byte pointer. (Inherited from Online Encoding.)
Public method | GetCharCount( Byte , Int32, Int32) | (Overrides Online Encoding GetCharCount( Byte , Int32, Int32).)
Back to Top
See Also
PdfUnicodeEncoding Class
PdfUnicodeEncoding Members
NFX.Media.PDF.Text Namespace


PdfUnicodeEncoding.GetCharCount Method (Byte[], Int32, Int32)

PdfUnicodeEncoding GetCharCount Method ( Byte , Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Media.PDF.Text
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetCharCount(
    byte[] bytes,
    int index,
    int count
)
public override int GetCharCount(
    byte[] bytes,
    int index,
    int count
)
Public Overrides Function GetCharCount (
    bytes As Byte(),
    index As Integer,
    count As Integer
) As Integer
Public Overrides Function GetCharCount (
    bytes As Byte(),
    index As Integer,
    count As Integer
) As Integer
public:
virtual int GetCharCount(
    array<unsigned char>^ bytes,
    int index,
    int count
) override
public:
virtual int GetCharCount(
    array<unsigned char>^ bytes,
    int index,
    int count
) override
abstract GetCharCount :
        bytes : byte[] *
        index : int *
        count : int -> int
override GetCharCount :
        bytes : byte[] *
        index : int *
        count : int -> int
abstract GetCharCount :
        bytes : byte[] *
        index : int *
        count : int -> int
override GetCharCount :
        bytes : byte[] *
        index : int *
        count : int -> int

Parameters

bytes
Type: Online System Byte
index
Type: Online System Int32
count
Type: Online System Int32

Return Value

Type: Online Int32
See Also
PdfUnicodeEncoding Class
PdfUnicodeEncoding Members
GetCharCount Overload
NFX.Media.PDF.Text Namespace


PdfUnicodeEncoding.GetChars Method

PdfUnicodeEncoding GetChars Method NFX Class Library

Overload List
 | Name | Description
Public method | Online GetChars( Byte ) | When overridden in a derived class, decodes all the bytes in the specified byte array into a set of characters. (Inherited from Online Encoding.)
Public method | Online GetChars( Byte , Int32, Int32) | When overridden in a derived class, decodes a sequence of bytes from the specified byte array into a set of characters. (Inherited from Online Encoding.)
Public method | Online GetChars(Byte*, Int32, Char*, Int32) | When overridden in a derived class, decodes a sequence of bytes starting at the specified byte pointer into a set of characters that are stored starting at the specified character pointer. (Inherited from Online Encoding.)
Public method | GetChars( Byte , Int32, Int32, Char , Int32) | (Overrides Online Encoding GetChars( Byte , Int32, Int32, Char , Int32).)
Back to Top
See Also
PdfUnicodeEncoding Class
PdfUnicodeEncoding Members
NFX.Media.PDF.Text Namespace


PdfUnicodeEncoding.GetChars Method (Byte[], Int32, Int32, Char[], Int32)

PdfUnicodeEncoding GetChars Method ( Byte , Int32, Int32, Char , Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Media.PDF.Text
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetChars(
    byte[] bytes,
    int byteIndex,
    int byteCount,
    char[] chars,
    int charIndex
)
public override int GetChars(
    byte[] bytes,
    int byteIndex,
    int byteCount,
    char[] chars,
    int charIndex
)
Public Overrides Function GetChars (
    bytes As Byte(),
    byteIndex As Integer,
    byteCount As Integer,
    chars As Char(),
    charIndex As Integer
) As Integer
Public Overrides Function GetChars (
    bytes As Byte(),
    byteIndex As Integer,
    byteCount As Integer,
    chars As Char(),
    charIndex As Integer
) As Integer
public:
virtual int GetChars(
    array<unsigned char>^ bytes,
    int byteIndex,
    int byteCount,
    array<wchar_t>^ chars,
    int charIndex
) override
public:
virtual int GetChars(
    array<unsigned char>^ bytes,
    int byteIndex,
    int byteCount,
    array<wchar_t>^ chars,
    int charIndex
) override
abstract GetChars :
        bytes : byte[] *
        byteIndex : int *
        byteCount : int *
        chars : char[] *
        charIndex : int -> int
override GetChars :
        bytes : byte[] *
        byteIndex : int *
        byteCount : int *
        chars : char[] *
        charIndex : int -> int
abstract GetChars :
        bytes : byte[] *
        byteIndex : int *
        byteCount : int *
        chars : char[] *
        charIndex : int -> int
override GetChars :
        bytes : byte[] *
        byteIndex : int *
        byteCount : int *
        chars : char[] *
        charIndex : int -> int

Parameters

bytes
Type: Online System Byte
byteIndex
Type: Online System Int32
byteCount
Type: Online System Int32
chars
Type: Online System Char
charIndex
Type: Online System Int32

Return Value

Type: Online Int32
See Also
PdfUnicodeEncoding Class
PdfUnicodeEncoding Members
GetChars Overload
NFX.Media.PDF.Text Namespace


PdfUnicodeEncoding.GetMaxByteCount Method

PdfUnicodeEncoding GetMaxByteCount Method NFX Class Library

Namespace: NFX.Media.PDF.Text
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetMaxByteCount(
    int charCount
)
public override int GetMaxByteCount(
    int charCount
)
Public Overrides Function GetMaxByteCount (
    charCount As Integer
) As Integer
Public Overrides Function GetMaxByteCount (
    charCount As Integer
) As Integer
public:
virtual int GetMaxByteCount(
    int charCount
) override
public:
virtual int GetMaxByteCount(
    int charCount
) override
abstract GetMaxByteCount :
        charCount : int -> int
override GetMaxByteCount :
        charCount : int -> int
abstract GetMaxByteCount :
        charCount : int -> int
override GetMaxByteCount :
        charCount : int -> int

Parameters

charCount
Type: Online System Int32

Return Value

Type: Online Int32
See Also
PdfUnicodeEncoding Class
PdfUnicodeEncoding Members
NFX.Media.PDF.Text Namespace


PdfUnicodeEncoding.GetMaxCharCount Method

PdfUnicodeEncoding GetMaxCharCount Method NFX Class Library

Namespace: NFX.Media.PDF.Text
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetMaxCharCount(
    int byteCount
)
public override int GetMaxCharCount(
    int byteCount
)
Public Overrides Function GetMaxCharCount (
    byteCount As Integer
) As Integer
Public Overrides Function GetMaxCharCount (
    byteCount As Integer
) As Integer
public:
virtual int GetMaxCharCount(
    int byteCount
) override
public:
virtual int GetMaxCharCount(
    int byteCount
) override
abstract GetMaxCharCount :
        byteCount : int -> int
override GetMaxCharCount :
        byteCount : int -> int
abstract GetMaxCharCount :
        byteCount : int -> int
override GetMaxCharCount :
        byteCount : int -> int

Parameters

byteCount
Type: Online System Int32

Return Value

Type: Online Int32
See Also
PdfUnicodeEncoding Class
PdfUnicodeEncoding Members
NFX.Media.PDF.Text Namespace


PdfUnicodeEncoding Properties

PdfUnicodeEncoding Properties NFX Class Library

The PdfUnicodeEncoding type exposes the following members.
Properties
 | Name | Description
Public property | Online BodyName | When overridden in a derived class, gets a name for the current encoding that can be used with mail agent body tags. (Inherited from Online Encoding.)
Public property | Online CodePage | When overridden in a derived class, gets the code page identifier of the current Online Encoding. (Inherited from Online Encoding.)
Public property | Online DecoderFallback | Gets or sets the Online DecoderFallback object for the current Online Encoding object. (Inherited from Online Encoding.)
Public property | Online EncoderFallback | Gets or sets the Online EncoderFallback object for the current Online Encoding object. (Inherited from Online Encoding.)
Public property | Online EncodingName | When overridden in a derived class, gets the human-readable description of the current encoding. (Inherited from Online Encoding.)
Public property | Online HeaderName | When overridden in a derived class, gets a name for the current encoding that can be used with mail agent header tags. (Inherited from Online Encoding.)
Public property | Online IsBrowserDisplay | When overridden in a derived class, gets a value indicating whether the current encoding can be used by browser clients for displaying content. (Inherited from Online Encoding.)
Public property | Online IsBrowserSave | When overridden in a derived class, gets a value indicating whether the current encoding can be used by browser clients for saving content. (Inherited from Online Encoding.)
Public property | Online IsMailNewsDisplay | When overridden in a derived class, gets a value indicating whether the current encoding can be used by mail and news clients for displaying content. (Inherited from Online Encoding.)
Public property | Online IsMailNewsSave | When overridden in a derived class, gets a value indicating whether the current encoding can be used by mail and news clients for saving content. (Inherited from Online Encoding.)
Public property | Online IsReadOnly | When overridden in a derived class, gets a value indicating whether the current encoding is read-only. (Inherited from Online Encoding.)
Public property | Online IsSingleByte | When overridden in a derived class, gets a value indicating whether the current encoding uses single-byte code points. (Inherited from Online Encoding.)
Public property | Online WebName | When overridden in a derived class, gets the name registered with the Internet Assigned Numbers Authority (IANA) for the current encoding. (Inherited from Online Encoding.)
Public property | Online WindowsCodePage | When overridden in a derived class, gets the Windows operating system code page that most closely corresponds to the current encoding. (Inherited from Online Encoding.)
Back to Top
See Also
PdfUnicodeEncoding Class
NFX.Media.PDF.Text Namespace


TextAdapter Class

TextAdapter Class NFX Class Library

Utility class for operations with text
Inheritance Hierarchy
Online System Object
NFX.Media.PDF.Text TextAdapter

Namespace: NFX.Media.PDF.Text
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class TextAdapter
public static class TextAdapter
Public NotInheritable Class TextAdapter
Public NotInheritable Class TextAdapter
public ref class TextAdapter abstract sealed
public ref class TextAdapter abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type TextAdapter =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type TextAdapter =  class end
See Also
TextAdapter Members
NFX.Media.PDF.Text Namespace


TextAdapter Members

TextAdapter Members NFX Class Library

The TextAdapter type exposes the following members.
Methods
Name | Description
FixEscapes |
FormatFloat | Formats given float with a dot as fraction part delimeter and foors it to 4 digits after dot
FormatHexStringLiteral | Converts the specified byte array into a byte array representing a unicode hex string literal.
Back to Top
Properties
Name | Description
TrivialEncoding |
UnicodeEncoding |
Back to Top
See Also
TextAdapter Class
NFX.Media.PDF.Text Namespace


TextAdapter Methods

TextAdapter Methods NFX Class Library

The TextAdapter type exposes the following members.
Methods
Name | Description
FixEscapes |
FormatFloat | Formats given float with a dot as fraction part delimeter and foors it to 4 digits after dot
FormatHexStringLiteral | Converts the specified byte array into a byte array representing a unicode hex string literal.
Back to Top
See Also
TextAdapter Class
NFX.Media.PDF.Text Namespace


TextAdapter.FixEscapes Method

TextAdapter FixEscapes Method NFX Class Library

Namespace: NFX.Media.PDF.Text
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string FixEscapes(
    string text
)
public static string FixEscapes(
    string text
)
Public Shared Function FixEscapes (
    text As String
) As String
Public Shared Function FixEscapes (
    text As String
) As String
public:
static String^ FixEscapes(
    String^ text
)
public:
static String^ FixEscapes(
    String^ text
)
static member FixEscapes :
        text : string -> string
static member FixEscapes :
        text : string -> string

Parameters

text
Type: Online System String

Return Value

Type: Online String
See Also
TextAdapter Class
TextAdapter Members
NFX.Media.PDF.Text Namespace


TextAdapter.FormatFloat Method

TextAdapter FormatFloat Method NFX Class Library

Formats given float with a dot as fraction part delimeter and foors it to 4 digits after dot

Namespace: NFX.Media.PDF.Text
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string FormatFloat(
    double number
)
public static string FormatFloat(
    double number
)
Public Shared Function FormatFloat (
    number As Double
) As String
Public Shared Function FormatFloat (
    number As Double
) As String
public:
static String^ FormatFloat(
    double number
)
public:
static String^ FormatFloat(
    double number
)
static member FormatFloat :
        number : float -> string
static member FormatFloat :
        number : float -> string

Parameters

number
Type: Online System Double

Return Value

Type: Online String
See Also
TextAdapter Class
TextAdapter Members
NFX.Media.PDF.Text Namespace


TextAdapter.FormatHexStringLiteral Method

TextAdapter FormatHexStringLiteral Method NFX Class Library

Converts the specified byte array into a byte array representing a unicode hex string literal.

Namespace: NFX.Media.PDF.Text
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte[] FormatHexStringLiteral(
    byte[] bytes
)
public static byte[] FormatHexStringLiteral(
    byte[] bytes
)
Public Shared Function FormatHexStringLiteral (
    bytes As Byte()
) As Byte()
Public Shared Function FormatHexStringLiteral (
    bytes As Byte()
) As Byte()
public:
static array<unsigned char>^ FormatHexStringLiteral(
    array<unsigned char>^ bytes
)
public:
static array<unsigned char>^ FormatHexStringLiteral(
    array<unsigned char>^ bytes
)
static member FormatHexStringLiteral :
        bytes : byte[] -> byte[]
static member FormatHexStringLiteral :
        bytes : byte[] -> byte[]

Parameters

bytes
Type: Online System Byte
The bytes of the string.

Return Value

Type: Online Byte
The PDF bytes.
See Also
TextAdapter Class
TextAdapter Members
NFX.Media.PDF.Text Namespace


TextAdapter Properties

TextAdapter Properties NFX Class Library

The TextAdapter type exposes the following members.
Properties
Name | Description
TrivialEncoding |
UnicodeEncoding |
Back to Top
See Also
TextAdapter Class
NFX.Media.PDF.Text Namespace


TextAdapter.TrivialEncoding Property

TextAdapter TrivialEncoding Property NFX Class Library

Namespace: NFX.Media.PDF.Text
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Encoding TrivialEncoding { get; }
public static Encoding TrivialEncoding { get; }
Public Shared ReadOnly Property TrivialEncoding As Encoding
    Get
Public Shared ReadOnly Property TrivialEncoding As Encoding
    Get
public:
static property Encoding^ TrivialEncoding {
    Encoding^ get ();
}
public:
static property Encoding^ TrivialEncoding {
    Encoding^ get ();
}
static member TrivialEncoding : Encoding with get
static member TrivialEncoding : Encoding with get

Property Value

Type: Online Encoding
See Also
TextAdapter Class
TextAdapter Members
NFX.Media.PDF.Text Namespace


TextAdapter.UnicodeEncoding Property

TextAdapter UnicodeEncoding Property NFX Class Library

Namespace: NFX.Media.PDF.Text
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Encoding UnicodeEncoding { get; }
public static Encoding UnicodeEncoding { get; }
Public Shared ReadOnly Property UnicodeEncoding As Encoding
    Get
Public Shared ReadOnly Property UnicodeEncoding As Encoding
    Get
public:
static property Encoding^ UnicodeEncoding {
    Encoding^ get ();
}
public:
static property Encoding^ UnicodeEncoding {
    Encoding^ get ();
}
static member UnicodeEncoding : Encoding with get
static member UnicodeEncoding : Encoding with get

Property Value

Type: Online Encoding
See Also
TextAdapter Class
TextAdapter Members
NFX.Media.PDF.Text Namespace


NFX.Media.TagCodes.QR Namespace

NFX.Media.TagCodes.QR Namespace NFX Class Library

Provides functions for working with QR codes
Classes
 | Class | Description
Public class | QRCorrectionLevel |
Public class | QRDataNCorrection |
Public class | QREncoderMatrix |
Public class | QRImageRenderer |
Public class | QRMatrix |
Public class | QRMode |
Public class | QRVersion |
Public class | QRVersion CorrectionBlock |
Public class | QRVersion CorrectionBlockSet |
Enumerations
 | Enumeration | Description
Public enumeration | QRImageRenderer ImageScale |
Public enumeration | QRMode EMode |


QRCorrectionLevel Class

QRCorrectionLevel Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Media.TagCodes.QR QRCorrectionLevel

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class QRCorrectionLevel
public class QRCorrectionLevel
Public Class QRCorrectionLevel
Public Class QRCorrectionLevel
public ref class QRCorrectionLevel
public ref class QRCorrectionLevel
type QRCorrectionLevel =  class end
type QRCorrectionLevel =  class end
See Also
QRCorrectionLevel Members
NFX.Media.TagCodes.QR Namespace


QRCorrectionLevel Members

QRCorrectionLevel Members NFX Class Library

The QRCorrectionLevel type exposes the following members.
Constructors
 | Name | Description
Public method | QRCorrectionLevel | Initializes a new instance of the QRCorrectionLevel class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
 | GetLevels |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | H |
 | L |
 | M |
Public field | MarkerBits |
Public field | Name |
Public field | Ordinal |
 | Q |
Back to Top
See Also
QRCorrectionLevel Class
NFX.Media.TagCodes.QR Namespace


QRCorrectionLevel Constructor

QRCorrectionLevel Constructor NFX Class Library

Initializes a new instance of the QRCorrectionLevel class

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public QRCorrectionLevel(
    string name,
    int ordinal,
    int markerBits
)
public QRCorrectionLevel(
    string name,
    int ordinal,
    int markerBits
)
Public Sub New (
    name As String,
    ordinal As Integer,
    markerBits As Integer
)
Public Sub New (
    name As String,
    ordinal As Integer,
    markerBits As Integer
)
public:
QRCorrectionLevel(
    String^ name,
    int ordinal,
    int markerBits
)
public:
QRCorrectionLevel(
    String^ name,
    int ordinal,
    int markerBits
)
new :
        name : string *
        ordinal : int *
        markerBits : int -> QRCorrectionLevel
new :
        name : string *
        ordinal : int *
        markerBits : int -> QRCorrectionLevel

Parameters

name
Type: Online System String
ordinal
Type: Online System Int32
markerBits
Type: Online System Int32
See Also
QRCorrectionLevel Class
QRCorrectionLevel Members
NFX.Media.TagCodes.QR Namespace


QRCorrectionLevel Fields

QRCorrectionLevel Fields NFX Class Library

The QRCorrectionLevel type exposes the following members.
Fields
 | Name | Description
 | H |
 | L |
 | M |
Public field | MarkerBits |
Public field | Name |
Public field | Ordinal |
 | Q |
Back to Top
See Also
QRCorrectionLevel Class
NFX.Media.TagCodes.QR Namespace


QRCorrectionLevel.H Field

QRCorrectionLevel H Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly QRCorrectionLevel H
public static readonly QRCorrectionLevel H
Public Shared ReadOnly H As QRCorrectionLevel
Public Shared ReadOnly H As QRCorrectionLevel
public:
static initonly QRCorrectionLevel^ H
public:
static initonly QRCorrectionLevel^ H
static val H: QRCorrectionLevel
static val H: QRCorrectionLevel

Field Value

Type: QRCorrectionLevel
See Also
QRCorrectionLevel Class
QRCorrectionLevel Members
NFX.Media.TagCodes.QR Namespace


QRCorrectionLevel.L Field

QRCorrectionLevel L Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly QRCorrectionLevel L
public static readonly QRCorrectionLevel L
Public Shared ReadOnly L As QRCorrectionLevel
Public Shared ReadOnly L As QRCorrectionLevel
public:
static initonly QRCorrectionLevel^ L
public:
static initonly QRCorrectionLevel^ L
static val L: QRCorrectionLevel
static val L: QRCorrectionLevel

Field Value

Type: QRCorrectionLevel
See Also
QRCorrectionLevel Class
QRCorrectionLevel Members
NFX.Media.TagCodes.QR Namespace


QRCorrectionLevel.M Field

QRCorrectionLevel M Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly QRCorrectionLevel M
public static readonly QRCorrectionLevel M
Public Shared ReadOnly M As QRCorrectionLevel
Public Shared ReadOnly M As QRCorrectionLevel
public:
static initonly QRCorrectionLevel^ M
public:
static initonly QRCorrectionLevel^ M
static val M: QRCorrectionLevel
static val M: QRCorrectionLevel

Field Value

Type: QRCorrectionLevel
See Also
QRCorrectionLevel Class
QRCorrectionLevel Members
NFX.Media.TagCodes.QR Namespace


QRCorrectionLevel.MarkerBits Field

QRCorrectionLevel MarkerBits Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int MarkerBits
public readonly int MarkerBits
Public ReadOnly MarkerBits As Integer
Public ReadOnly MarkerBits As Integer
public:
initonly int MarkerBits
public:
initonly int MarkerBits
val MarkerBits: int
val MarkerBits: int

Field Value

Type: Online Int32
See Also
QRCorrectionLevel Class
QRCorrectionLevel Members
NFX.Media.TagCodes.QR Namespace


QRCorrectionLevel.Name Field

QRCorrectionLevel Name Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Name
public readonly string Name
Public ReadOnly Name As String
Public ReadOnly Name As String
public:
initonly String^ Name
public:
initonly String^ Name
val Name: string
val Name: string

Field Value

Type: Online String
See Also
QRCorrectionLevel Class
QRCorrectionLevel Members
NFX.Media.TagCodes.QR Namespace


QRCorrectionLevel.Ordinal Field

QRCorrectionLevel Ordinal Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Ordinal
public readonly int Ordinal
Public ReadOnly Ordinal As Integer
Public ReadOnly Ordinal As Integer
public:
initonly int Ordinal
public:
initonly int Ordinal
val Ordinal: int
val Ordinal: int

Field Value

Type: Online Int32
See Also
QRCorrectionLevel Class
QRCorrectionLevel Members
NFX.Media.TagCodes.QR Namespace


QRCorrectionLevel.Q Field

QRCorrectionLevel Q Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly QRCorrectionLevel Q
public static readonly QRCorrectionLevel Q
Public Shared ReadOnly Q As QRCorrectionLevel
Public Shared ReadOnly Q As QRCorrectionLevel
public:
static initonly QRCorrectionLevel^ Q
public:
static initonly QRCorrectionLevel^ Q
static val Q: QRCorrectionLevel
static val Q: QRCorrectionLevel

Field Value

Type: QRCorrectionLevel
See Also
QRCorrectionLevel Class
QRCorrectionLevel Members
NFX.Media.TagCodes.QR Namespace


QRCorrectionLevel Methods

QRCorrectionLevel Methods NFX Class Library

The QRCorrectionLevel type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
 | GetLevels |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
QRCorrectionLevel Class
NFX.Media.TagCodes.QR Namespace


QRCorrectionLevel.GetLevels Method

QRCorrectionLevel GetLevels Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<QRCorrectionLevel> GetLevels()
public static IEnumerable<QRCorrectionLevel> GetLevels()
Public Shared Function GetLevels As IEnumerable(Of QRCorrectionLevel)
Public Shared Function GetLevels As IEnumerable(Of QRCorrectionLevel)
public:
static IEnumerable<QRCorrectionLevel^>^ GetLevels()
public:
static IEnumerable<QRCorrectionLevel^>^ GetLevels()
static member GetLevels : unit -> IEnumerable<QRCorrectionLevel>
static member GetLevels : unit -> IEnumerable<QRCorrectionLevel>

Return Value

Type: Online IEnumerable QRCorrectionLevel
See Also
QRCorrectionLevel Class
QRCorrectionLevel Members
NFX.Media.TagCodes.QR Namespace


QRCorrectionLevel.ToString Method

QRCorrectionLevel ToString Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
QRCorrectionLevel Class
QRCorrectionLevel Members
NFX.Media.TagCodes.QR Namespace


QRDataNCorrection Class

QRDataNCorrection Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Media.TagCodes.QR QRDataNCorrection

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class QRDataNCorrection
public class QRDataNCorrection
Public Class QRDataNCorrection
Public Class QRDataNCorrection
public ref class QRDataNCorrection
public ref class QRDataNCorrection
type QRDataNCorrection =  class end
type QRDataNCorrection =  class end
See Also
QRDataNCorrection Members
NFX.Media.TagCodes.QR Namespace


QRDataNCorrection Members

QRDataNCorrection Members NFX Class Library

The QRDataNCorrection type exposes the following members.
Constructors
 | Name | Description
Public method | QRDataNCorrection | Initializes a new instance of the QRDataNCorrection class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Correction |
Public field | Data |
Back to Top
See Also
QRDataNCorrection Class
NFX.Media.TagCodes.QR Namespace


QRDataNCorrection Constructor

QRDataNCorrection Constructor NFX Class Library

Initializes a new instance of the QRDataNCorrection class

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public QRDataNCorrection(
    byte[] data,
    byte[] correction
)
public QRDataNCorrection(
    byte[] data,
    byte[] correction
)
Public Sub New (
    data As Byte(),
    correction As Byte()
)
Public Sub New (
    data As Byte(),
    correction As Byte()
)
public:
QRDataNCorrection(
    array<unsigned char>^ data,
    array<unsigned char>^ correction
)
public:
QRDataNCorrection(
    array<unsigned char>^ data,
    array<unsigned char>^ correction
)
new :
        data : byte[] *
        correction : byte[] -> QRDataNCorrection
new :
        data : byte[] *
        correction : byte[] -> QRDataNCorrection

Parameters

data
Type: Online System Byte
correction
Type: Online System Byte
See Also
QRDataNCorrection Class
QRDataNCorrection Members
NFX.Media.TagCodes.QR Namespace


QRDataNCorrection Fields

QRDataNCorrection Fields NFX Class Library

The QRDataNCorrection type exposes the following members.
Fields
 | Name | Description
Public field | Correction |
Public field | Data |
Back to Top
See Also
QRDataNCorrection Class
NFX.Media.TagCodes.QR Namespace


QRDataNCorrection.Correction Field

QRDataNCorrection Correction Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly byte[] Correction
public readonly byte[] Correction
Public ReadOnly Correction As Byte()
Public ReadOnly Correction As Byte()
public:
initonly array<unsigned char>^ Correction
public:
initonly array<unsigned char>^ Correction
val Correction: byte[]
val Correction: byte[]

Field Value

Type: Online Byte
See Also
QRDataNCorrection Class
QRDataNCorrection Members
NFX.Media.TagCodes.QR Namespace


QRDataNCorrection.Data Field

QRDataNCorrection Data Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly byte[] Data
public readonly byte[] Data
Public ReadOnly Data As Byte()
Public ReadOnly Data As Byte()
public:
initonly array<unsigned char>^ Data
public:
initonly array<unsigned char>^ Data
val Data: byte[]
val Data: byte[]

Field Value

Type: Online Byte
See Also
QRDataNCorrection Class
QRDataNCorrection Members
NFX.Media.TagCodes.QR Namespace


QRDataNCorrection Methods

QRDataNCorrection Methods NFX Class Library

The QRDataNCorrection type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
QRDataNCorrection Class
NFX.Media.TagCodes.QR Namespace


QREncoderMatrix Class

QREncoderMatrix Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Collections MatrixBase Online Byte
NFX.Collections Matrix2DBase Online Byte
NFX.Collections Matrix2D Online Byte
NFX.Media.TagCodes.QR QRMatrix
NFX.Media.TagCodes.QR QREncoderMatrix

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class QREncoderMatrix : QRMatrix
public class QREncoderMatrix : QRMatrix
Public Class QREncoderMatrix
    Inherits QRMatrix
Public Class QREncoderMatrix
    Inherits QRMatrix
public ref class QREncoderMatrix : public QRMatrix
public ref class QREncoderMatrix : public QRMatrix
type QREncoderMatrix =
    class
        inherit QRMatrix
    end
type QREncoderMatrix =
    class
        inherit QRMatrix
    end
See Also
QREncoderMatrix Members
NFX.Media.TagCodes.QR Namespace


QREncoderMatrix Members

QREncoderMatrix Members NFX Class Library

The QREncoderMatrix type exposes the following members.
Methods
 | Name | Description
Public method | AddBasicPatterns | (Inherited from QRMatrix.)
Public method | AddTypeInfo | (Inherited from QRMatrix.)
Public method | AddVersionInfoIfRequired | (Inherited from QRMatrix.)
 | Append8BitBytes |
 | AppendAlphanumericBytes |
 | AppendBytes |
 | AppendLengthInfo |
 | AppendNumericBytes |
Public method | Clear | (Inherited from QRMatrix.)
 | CreateMatrix |
 | Encode |
Public method | Equals(Object) | (Inherited from MatrixBase T .)
Public method | Equals(MatrixBase T ) | (Inherited from MatrixBase T .)
Public method | Fill | (Inherited from Matrix2D T .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FormMatrix | (Inherited from QRMatrix.)
 | GetCorrectionBytes |
Public method | GetDataMaskBit | (Inherited from QRMatrix.)
Public method | GetEnumerator | (Inherited from MatrixBase T .)
Public method | GetHashCode | (Inherited from MatrixBase T .)
Public method | GetLowerBound | (Inherited from Matrix2DBase T .)
Public method | GetMaskPenalty | (Inherited from QRMatrix.)
Public method | GetMaskPenaltyRule1 | (Inherited from QRMatrix.)
Public method | GetMaskPenaltyRule2 | (Inherited from QRMatrix.)
Public method | GetMaskPenaltyRule3 | (Inherited from QRMatrix.)
Public method | GetMaskPenaltyRule4 | (Inherited from QRMatrix.)
Public method | GetMatrixEnumerator | (Inherited from Matrix2DBase T .)
 | GetNumDataBytesAndNumCorrectionBytesByBlockID | According to JISX0510:2004 (p.30) tbl 12 in 8.5.1 Calculate data and correction bytes for block
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetUpperBound | (Inherited from Matrix2DBase T .)
Public method | InsertDataBits | (Inherited from QRMatrix.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | MixWithCorrectionBytes | According to JISX0510:2004 8.6 p.37 bits are mixed mixes with their correction bytes.
Public method | ToString | (Overrides QRMatrix ToString .)
 | WriteTerminationSection | Write termination section according 8.4.8 and 8.4.9 of JISX0510:2004 (p.24).
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | CreateDrawingOutput | (Defined by QRImageRenderer.)
Public Extension Method | ToBMP | (Defined by QRImageRenderer.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToGIF | (Defined by QRImageRenderer.)
Public Extension Method | ToJPG | (Defined by QRImageRenderer.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToPNG | (Defined by QRImageRenderer.)
Back to Top
Fields
 | Name | Description
Public field | Array | (Inherited from Matrix2D T .)
Public field | Content |
Public field | CorrectionLevel |
 | DEFAULT_ENCODING |
Public field | Height | (Inherited from Matrix2DBase T .)
Public field | Width | (Inherited from Matrix2DBase T .)
Back to Top
Properties
 | Name | Description
Public property | Item | (Inherited from Matrix2D T .)
Public property | MaskPattern |
Public property | Mode |
Public property | Rank | (Inherited from Matrix2DBase T .)
Public property | Version |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from MatrixBase T .)
Back to Top
See Also
QREncoderMatrix Class
NFX.Media.TagCodes.QR Namespace


QREncoderMatrix Fields

QREncoderMatrix Fields NFX Class Library

The QREncoderMatrix type exposes the following members.
Fields
 | Name | Description
Public field | Array | (Inherited from Matrix2D T .)
Public field | Content |
Public field | CorrectionLevel |
 | DEFAULT_ENCODING |
Public field | Height | (Inherited from Matrix2DBase T .)
Public field | Width | (Inherited from Matrix2DBase T .)
Back to Top
See Also
QREncoderMatrix Class
NFX.Media.TagCodes.QR Namespace


QREncoderMatrix.Content Field

QREncoderMatrix Content Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Content
public readonly string Content
Public ReadOnly Content As String
Public ReadOnly Content As String
public:
initonly String^ Content
public:
initonly String^ Content
val Content: string
val Content: string

Field Value

Type: Online String
See Also
QREncoderMatrix Class
QREncoderMatrix Members
NFX.Media.TagCodes.QR Namespace


QREncoderMatrix.CorrectionLevel Field

QREncoderMatrix CorrectionLevel Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly QRCorrectionLevel CorrectionLevel
public readonly QRCorrectionLevel CorrectionLevel
Public ReadOnly CorrectionLevel As QRCorrectionLevel
Public ReadOnly CorrectionLevel As QRCorrectionLevel
public:
initonly QRCorrectionLevel^ CorrectionLevel
public:
initonly QRCorrectionLevel^ CorrectionLevel
val CorrectionLevel: QRCorrectionLevel
val CorrectionLevel: QRCorrectionLevel

Field Value

Type: QRCorrectionLevel
See Also
QREncoderMatrix Class
QREncoderMatrix Members
NFX.Media.TagCodes.QR Namespace


QREncoderMatrix.DEFAULT_ENCODING Field

QREncoderMatrix DEFAULT_ENCODING Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_ENCODING
public const string DEFAULT_ENCODING
Public Const DEFAULT_ENCODING As String
Public Const DEFAULT_ENCODING As String
public:
literal String^ DEFAULT_ENCODING
public:
literal String^ DEFAULT_ENCODING
static val mutable DEFAULT_ENCODING: string
static val mutable DEFAULT_ENCODING: string

Field Value

Type: Online String
See Also
QREncoderMatrix Class
QREncoderMatrix Members
NFX.Media.TagCodes.QR Namespace


QREncoderMatrix Methods

QREncoderMatrix Methods NFX Class Library

The QREncoderMatrix type exposes the following members.
Methods
 | Name | Description
Public method | AddBasicPatterns | (Inherited from QRMatrix.)
Public method | AddTypeInfo | (Inherited from QRMatrix.)
Public method | AddVersionInfoIfRequired | (Inherited from QRMatrix.)
 | Append8BitBytes |
 | AppendAlphanumericBytes |
 | AppendBytes |
 | AppendLengthInfo |
 | AppendNumericBytes |
Public method | Clear | (Inherited from QRMatrix.)
 | CreateMatrix |
 | Encode |
Public method | Equals(Object) | (Inherited from MatrixBase T .)
Public method | Equals(MatrixBase T ) | (Inherited from MatrixBase T .)
Public method | Fill | (Inherited from Matrix2D T .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FormMatrix | (Inherited from QRMatrix.)
 | GetCorrectionBytes |
Public method | GetDataMaskBit | (Inherited from QRMatrix.)
Public method | GetEnumerator | (Inherited from MatrixBase T .)
Public method | GetHashCode | (Inherited from MatrixBase T .)
Public method | GetLowerBound | (Inherited from Matrix2DBase T .)
Public method | GetMaskPenalty | (Inherited from QRMatrix.)
Public method | GetMaskPenaltyRule1 | (Inherited from QRMatrix.)
Public method | GetMaskPenaltyRule2 | (Inherited from QRMatrix.)
Public method | GetMaskPenaltyRule3 | (Inherited from QRMatrix.)
Public method | GetMaskPenaltyRule4 | (Inherited from QRMatrix.)
Public method | GetMatrixEnumerator | (Inherited from Matrix2DBase T .)
 | GetNumDataBytesAndNumCorrectionBytesByBlockID | According to JISX0510:2004 (p.30) tbl 12 in 8.5.1 Calculate data and correction bytes for block
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetUpperBound | (Inherited from Matrix2DBase T .)
Public method | InsertDataBits | (Inherited from QRMatrix.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | MixWithCorrectionBytes | According to JISX0510:2004 8.6 p.37 bits are mixed mixes with their correction bytes.
Public method | ToString | (Overrides QRMatrix ToString .)
 | WriteTerminationSection | Write termination section according 8.4.8 and 8.4.9 of JISX0510:2004 (p.24).
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | CreateDrawingOutput | (Defined by QRImageRenderer.)
Public Extension Method | ToBMP | (Defined by QRImageRenderer.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToGIF | (Defined by QRImageRenderer.)
Public Extension Method | ToJPG | (Defined by QRImageRenderer.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToPNG | (Defined by QRImageRenderer.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from MatrixBase T .)
Back to Top
See Also
QREncoderMatrix Class
NFX.Media.TagCodes.QR Namespace


QREncoderMatrix.Append8BitBytes Method

QREncoderMatrix Append8BitBytes Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Append8BitBytes(
    string content,
    BitList bits
)
public static void Append8BitBytes(
    string content,
    BitList bits
)
Public Shared Sub Append8BitBytes (
    content As String,
    bits As BitList
)
Public Shared Sub Append8BitBytes (
    content As String,
    bits As BitList
)
public:
static void Append8BitBytes(
    String^ content,
    BitList^ bits
)
public:
static void Append8BitBytes(
    String^ content,
    BitList^ bits
)
static member Append8BitBytes :
        content : string *
        bits : BitList -> unit
static member Append8BitBytes :
        content : string *
        bits : BitList -> unit

Parameters

content
Type: Online System String
bits
Type: NFX.Collections BitList
See Also
QREncoderMatrix Class
QREncoderMatrix Members
NFX.Media.TagCodes.QR Namespace


QREncoderMatrix.AppendAlphanumericBytes Method

QREncoderMatrix AppendAlphanumericBytes Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AppendAlphanumericBytes(
    string content,
    BitList bits
)
public static void AppendAlphanumericBytes(
    string content,
    BitList bits
)
Public Shared Sub AppendAlphanumericBytes (
    content As String,
    bits As BitList
)
Public Shared Sub AppendAlphanumericBytes (
    content As String,
    bits As BitList
)
public:
static void AppendAlphanumericBytes(
    String^ content,
    BitList^ bits
)
public:
static void AppendAlphanumericBytes(
    String^ content,
    BitList^ bits
)
static member AppendAlphanumericBytes :
        content : string *
        bits : BitList -> unit
static member AppendAlphanumericBytes :
        content : string *
        bits : BitList -> unit

Parameters

content
Type: Online System String
bits
Type: NFX.Collections BitList
See Also
QREncoderMatrix Class
QREncoderMatrix Members
NFX.Media.TagCodes.QR Namespace


QREncoderMatrix.AppendBytes Method

QREncoderMatrix AppendBytes Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AppendBytes(
    string content,
    QRMode mode,
    BitList bits
)
public static void AppendBytes(
    string content,
    QRMode mode,
    BitList bits
)
Public Shared Sub AppendBytes (
    content As String,
    mode As QRMode,
    bits As BitList
)
Public Shared Sub AppendBytes (
    content As String,
    mode As QRMode,
    bits As BitList
)
public:
static void AppendBytes(
    String^ content,
    QRMode^ mode,
    BitList^ bits
)
public:
static void AppendBytes(
    String^ content,
    QRMode^ mode,
    BitList^ bits
)
static member AppendBytes :
        content : string *
        mode : QRMode *
        bits : BitList -> unit
static member AppendBytes :
        content : string *
        mode : QRMode *
        bits : BitList -> unit

Parameters

content
Type: Online System String
mode
Type: NFX.Media.TagCodes.QR QRMode
bits
Type: NFX.Collections BitList
See Also
QREncoderMatrix Class
QREncoderMatrix Members
NFX.Media.TagCodes.QR Namespace


QREncoderMatrix.AppendLengthInfo Method

QREncoderMatrix AppendLengthInfo Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AppendLengthInfo(
    int numLetters,
    QRVersion version,
    QRMode mode,
    BitList bits
)
public static void AppendLengthInfo(
    int numLetters,
    QRVersion version,
    QRMode mode,
    BitList bits
)
Public Shared Sub AppendLengthInfo (
    numLetters As Integer,
    version As QRVersion,
    mode As QRMode,
    bits As BitList
)
Public Shared Sub AppendLengthInfo (
    numLetters As Integer,
    version As QRVersion,
    mode As QRMode,
    bits As BitList
)
public:
static void AppendLengthInfo(
    int numLetters,
    QRVersion^ version,
    QRMode^ mode,
    BitList^ bits
)
public:
static void AppendLengthInfo(
    int numLetters,
    QRVersion^ version,
    QRMode^ mode,
    BitList^ bits
)
static member AppendLengthInfo :
        numLetters : int *
        version : QRVersion *
        mode : QRMode *
        bits : BitList -> unit
static member AppendLengthInfo :
        numLetters : int *
        version : QRVersion *
        mode : QRMode *
        bits : BitList -> unit

Parameters

numLetters
Type: Online System Int32
version
Type: NFX.Media.TagCodes.QR QRVersion
mode
Type: NFX.Media.TagCodes.QR QRMode
bits
Type: NFX.Collections BitList
See Also
QREncoderMatrix Class
QREncoderMatrix Members
NFX.Media.TagCodes.QR Namespace


QREncoderMatrix.AppendNumericBytes Method

QREncoderMatrix AppendNumericBytes Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AppendNumericBytes(
    string content,
    BitList bits
)
public static void AppendNumericBytes(
    string content,
    BitList bits
)
Public Shared Sub AppendNumericBytes (
    content As String,
    bits As BitList
)
Public Shared Sub AppendNumericBytes (
    content As String,
    bits As BitList
)
public:
static void AppendNumericBytes(
    String^ content,
    BitList^ bits
)
public:
static void AppendNumericBytes(
    String^ content,
    BitList^ bits
)
static member AppendNumericBytes :
        content : string *
        bits : BitList -> unit
static member AppendNumericBytes :
        content : string *
        bits : BitList -> unit

Parameters

content
Type: Online System String
bits
Type: NFX.Collections BitList
See Also
QREncoderMatrix Class
QREncoderMatrix Members
NFX.Media.TagCodes.QR Namespace


QREncoderMatrix.CreateMatrix Method

QREncoderMatrix CreateMatrix Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static QREncoderMatrix CreateMatrix(
    string content,
    QRCorrectionLevel correctionLevel
)
public static QREncoderMatrix CreateMatrix(
    string content,
    QRCorrectionLevel correctionLevel
)
Public Shared Function CreateMatrix (
    content As String,
    correctionLevel As QRCorrectionLevel
) As QREncoderMatrix
Public Shared Function CreateMatrix (
    content As String,
    correctionLevel As QRCorrectionLevel
) As QREncoderMatrix
public:
static QREncoderMatrix^ CreateMatrix(
    String^ content,
    QRCorrectionLevel^ correctionLevel
)
public:
static QREncoderMatrix^ CreateMatrix(
    String^ content,
    QRCorrectionLevel^ correctionLevel
)
static member CreateMatrix :
        content : string *
        correctionLevel : QRCorrectionLevel -> QREncoderMatrix
static member CreateMatrix :
        content : string *
        correctionLevel : QRCorrectionLevel -> QREncoderMatrix

Parameters

content
Type: Online System String
correctionLevel
Type: NFX.Media.TagCodes.QR QRCorrectionLevel

Return Value

Type: QREncoderMatrix
See Also
QREncoderMatrix Class
QREncoderMatrix Members
NFX.Media.TagCodes.QR Namespace


QREncoderMatrix.Encode Method

QREncoderMatrix Encode Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static QREncoderMatrix Encode(
    string content,
    QRCorrectionLevel correctionLevel
)
public static QREncoderMatrix Encode(
    string content,
    QRCorrectionLevel correctionLevel
)
Public Shared Function Encode (
    content As String,
    correctionLevel As QRCorrectionLevel
) As QREncoderMatrix
Public Shared Function Encode (
    content As String,
    correctionLevel As QRCorrectionLevel
) As QREncoderMatrix
public:
static QREncoderMatrix^ Encode(
    String^ content,
    QRCorrectionLevel^ correctionLevel
)
public:
static QREncoderMatrix^ Encode(
    String^ content,
    QRCorrectionLevel^ correctionLevel
)
static member Encode :
        content : string *
        correctionLevel : QRCorrectionLevel -> QREncoderMatrix
static member Encode :
        content : string *
        correctionLevel : QRCorrectionLevel -> QREncoderMatrix

Parameters

content
Type: Online System String
correctionLevel
Type: NFX.Media.TagCodes.QR QRCorrectionLevel

Return Value

Type: QREncoderMatrix
See Also
QREncoderMatrix Class
QREncoderMatrix Members
NFX.Media.TagCodes.QR Namespace


QREncoderMatrix.GetCorrectionBytes Method

QREncoderMatrix GetCorrectionBytes Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte[] GetCorrectionBytes(
    byte[] dataBytes,
    int numEcBytesInBlock
)
public static byte[] GetCorrectionBytes(
    byte[] dataBytes,
    int numEcBytesInBlock
)
Public Shared Function GetCorrectionBytes (
    dataBytes As Byte(),
    numEcBytesInBlock As Integer
) As Byte()
Public Shared Function GetCorrectionBytes (
    dataBytes As Byte(),
    numEcBytesInBlock As Integer
) As Byte()
public:
static array<unsigned char>^ GetCorrectionBytes(
    array<unsigned char>^ dataBytes,
    int numEcBytesInBlock
)
public:
static array<unsigned char>^ GetCorrectionBytes(
    array<unsigned char>^ dataBytes,
    int numEcBytesInBlock
)
static member GetCorrectionBytes :
        dataBytes : byte[] *
        numEcBytesInBlock : int -> byte[]
static member GetCorrectionBytes :
        dataBytes : byte[] *
        numEcBytesInBlock : int -> byte[]

Parameters

dataBytes
Type: Online System Byte
numEcBytesInBlock
Type: Online System Int32

Return Value

Type: Online Byte
See Also
QREncoderMatrix Class
QREncoderMatrix Members
NFX.Media.TagCodes.QR Namespace


QREncoderMatrix.GetNumDataBytesAndNumCorrectionBytesByBlockID Method

QREncoderMatrix GetNumDataBytesAndNumCorrectionBytesByBlockID Method NFX Class Library

[This is preliminary documentation and is subject to change.]

According to JISX0510:2004 (p.30) tbl 12 in 8.5.1 Calculate data and correction bytes for block

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void GetNumDataBytesAndNumCorrectionBytesByBlockID(
    int numTotalBytes,
    int numDataBytes,
    int numRSBlocks,
    int blockID,
    int[] numDataBytesInBlock,
    int[] numECBytesInBlock
)
public static void GetNumDataBytesAndNumCorrectionBytesByBlockID(
    int numTotalBytes,
    int numDataBytes,
    int numRSBlocks,
    int blockID,
    int[] numDataBytesInBlock,
    int[] numECBytesInBlock
)
Public Shared Sub GetNumDataBytesAndNumCorrectionBytesByBlockID (
    numTotalBytes As Integer,
    numDataBytes As Integer,
    numRSBlocks As Integer,
    blockID As Integer,
    numDataBytesInBlock As Integer(),
    numECBytesInBlock As Integer()
)
Public Shared Sub GetNumDataBytesAndNumCorrectionBytesByBlockID (
    numTotalBytes As Integer,
    numDataBytes As Integer,
    numRSBlocks As Integer,
    blockID As Integer,
    numDataBytesInBlock As Integer(),
    numECBytesInBlock As Integer()
)
public:
static void GetNumDataBytesAndNumCorrectionBytesByBlockID(
    int numTotalBytes,
    int numDataBytes,
    int numRSBlocks,
    int blockID,
    array<int>^ numDataBytesInBlock,
    array<int>^ numECBytesInBlock
)
public:
static void GetNumDataBytesAndNumCorrectionBytesByBlockID(
    int numTotalBytes,
    int numDataBytes,
    int numRSBlocks,
    int blockID,
    array<int>^ numDataBytesInBlock,
    array<int>^ numECBytesInBlock
)
static member GetNumDataBytesAndNumCorrectionBytesByBlockID :
        numTotalBytes : int *
        numDataBytes : int *
        numRSBlocks : int *
        blockID : int *
        numDataBytesInBlock : int[] *
        numECBytesInBlock : int[] -> unit
static member GetNumDataBytesAndNumCorrectionBytesByBlockID :
        numTotalBytes : int *
        numDataBytes : int *
        numRSBlocks : int *
        blockID : int *
        numDataBytesInBlock : int[] *
        numECBytesInBlock : int[] -> unit

Parameters

numTotalBytes
Type: Online System Int32
Total bytes count
numDataBytes
Type: Online System Int32
Data bytes count
numRSBlocks
Type: Online System Int32
Reed/Solomon blocks count
blockID
Type: Online System Int32
Block Id
numDataBytesInBlock
Type: Online System Int32
Data bytes count in this block
numECBytesInBlock
Type: Online System Int32
Correction bytes count in this block
See Also
QREncoderMatrix Class
QREncoderMatrix Members
NFX.Media.TagCodes.QR Namespace


QREncoderMatrix.MixWithCorrectionBytes Method

QREncoderMatrix MixWithCorrectionBytes Method NFX Class Library

[This is preliminary documentation and is subject to change.]

According to JISX0510:2004 8.6 p.37 bits are mixed mixes with their correction bytes.

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static BitList MixWithCorrectionBytes(
    BitList bits,
    int numTotalBytes,
    int numDataBytes,
    int rsBlocksQty
)
public static BitList MixWithCorrectionBytes(
    BitList bits,
    int numTotalBytes,
    int numDataBytes,
    int rsBlocksQty
)
Public Shared Function MixWithCorrectionBytes (
    bits As BitList,
    numTotalBytes As Integer,
    numDataBytes As Integer,
    rsBlocksQty As Integer
) As BitList
Public Shared Function MixWithCorrectionBytes (
    bits As BitList,
    numTotalBytes As Integer,
    numDataBytes As Integer,
    rsBlocksQty As Integer
) As BitList
public:
static BitList^ MixWithCorrectionBytes(
    BitList^ bits,
    int numTotalBytes,
    int numDataBytes,
    int rsBlocksQty
)
public:
static BitList^ MixWithCorrectionBytes(
    BitList^ bits,
    int numTotalBytes,
    int numDataBytes,
    int rsBlocksQty
)
static member MixWithCorrectionBytes :
        bits : BitList *
        numTotalBytes : int *
        numDataBytes : int *
        rsBlocksQty : int -> BitList
static member MixWithCorrectionBytes :
        bits : BitList *
        numTotalBytes : int *
        numDataBytes : int *
        rsBlocksQty : int -> BitList

Parameters

bits
Type: NFX.Collections BitList
Data bits
numTotalBytes
Type: Online System Int32
Total bytes count
numDataBytes
Type: Online System Int32
Data bytes count
rsBlocksQty
Type: Online System Int32
Reed/Solomon blocks count

Return Value

Type: BitList
Mixed bits
See Also
QREncoderMatrix Class
QREncoderMatrix Members
NFX.Media.TagCodes.QR Namespace


QREncoderMatrix.ToString Method

QREncoderMatrix ToString Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
QREncoderMatrix Class
QREncoderMatrix Members
NFX.Media.TagCodes.QR Namespace


QREncoderMatrix.WriteTerminationSection Method

QREncoderMatrix WriteTerminationSection Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Write termination section according 8.4.8 and 8.4.9 of JISX0510:2004 (p.24).

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteTerminationSection(
    int dataBytesQty,
    BitList bits
)
public static void WriteTerminationSection(
    int dataBytesQty,
    BitList bits
)
Public Shared Sub WriteTerminationSection (
    dataBytesQty As Integer,
    bits As BitList
)
Public Shared Sub WriteTerminationSection (
    dataBytesQty As Integer,
    bits As BitList
)
public:
static void WriteTerminationSection(
    int dataBytesQty,
    BitList^ bits
)
public:
static void WriteTerminationSection(
    int dataBytesQty,
    BitList^ bits
)
static member WriteTerminationSection :
        dataBytesQty : int *
        bits : BitList -> unit
static member WriteTerminationSection :
        dataBytesQty : int *
        bits : BitList -> unit

Parameters

dataBytesQty
Type: Online System Int32
bits
Type: NFX.Collections BitList
See Also
QREncoderMatrix Class
QREncoderMatrix Members
NFX.Media.TagCodes.QR Namespace


QREncoderMatrix Properties

QREncoderMatrix Properties NFX Class Library

The QREncoderMatrix type exposes the following members.
Properties
 | Name | Description
Public property | Item | (Inherited from Matrix2D T .)
Public property | MaskPattern |
Public property | Mode |
Public property | Rank | (Inherited from Matrix2DBase T .)
Public property | Version |
Back to Top
See Also
QREncoderMatrix Class
NFX.Media.TagCodes.QR Namespace


QREncoderMatrix.MaskPattern Property

QREncoderMatrix MaskPattern Property NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MaskPattern { get; private set; }
public int MaskPattern { get; private set; }
Public Property MaskPattern As Integer
    Get
    Private Set
Public Property MaskPattern As Integer
    Get
    Private Set
public:
property int MaskPattern {
    int get ();
    private: void set (int value);
}
public:
property int MaskPattern {
    int get ();
    private: void set (int value);
}
member MaskPattern : int with get, private set
member MaskPattern : int with get, private set

Property Value

Type: Online Int32
See Also
QREncoderMatrix Class
QREncoderMatrix Members
NFX.Media.TagCodes.QR Namespace


QREncoderMatrix.Mode Property

QREncoderMatrix Mode Property NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public QRMode Mode { get; private set; }
public QRMode Mode { get; private set; }
Public Property Mode As QRMode
    Get
    Private Set
Public Property Mode As QRMode
    Get
    Private Set
public:
property QRMode^ Mode {
    QRMode^ get ();
    private: void set (QRMode^ value);
}
public:
property QRMode^ Mode {
    QRMode^ get ();
    private: void set (QRMode^ value);
}
member Mode : QRMode with get, private set
member Mode : QRMode with get, private set

Property Value

Type: QRMode
See Also
QREncoderMatrix Class
QREncoderMatrix Members
NFX.Media.TagCodes.QR Namespace


QREncoderMatrix.Version Property

QREncoderMatrix Version Property NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public QRVersion Version { get; private set; }
public QRVersion Version { get; private set; }
Public Property Version As QRVersion
    Get
    Private Set
Public Property Version As QRVersion
    Get
    Private Set
public:
property QRVersion^ Version {
    QRVersion^ get ();
    private: void set (QRVersion^ value);
}
public:
property QRVersion^ Version {
    QRVersion^ get ();
    private: void set (QRVersion^ value);
}
member Version : QRVersion with get, private set
member Version : QRVersion with get, private set

Property Value

Type: QRVersion
See Also
QREncoderMatrix Class
QREncoderMatrix Members
NFX.Media.TagCodes.QR Namespace


QRImageRenderer Class

QRImageRenderer Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Media.TagCodes.QR QRImageRenderer

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class QRImageRenderer
public static class QRImageRenderer
<ExtensionAttribute>
Public NotInheritable Class QRImageRenderer
<ExtensionAttribute>
Public NotInheritable Class QRImageRenderer
[ExtensionAttribute]
public ref class QRImageRenderer abstract sealed
[ExtensionAttribute]
public ref class QRImageRenderer abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type QRImageRenderer =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type QRImageRenderer =  class end
See Also
QRImageRenderer Members
NFX.Media.TagCodes.QR Namespace


QRImageRenderer Members

QRImageRenderer Members NFX Class Library

The QRImageRenderer type exposes the following members.
Methods
Name | Description
CreateDrawingOutput |
ToBMP |
ToGIF |
ToJPG |
ToPNG |
Back to Top
See Also
QRImageRenderer Class
NFX.Media.TagCodes.QR Namespace


QRImageRenderer Methods

QRImageRenderer Methods NFX Class Library

The QRImageRenderer type exposes the following members.
Methods
Name | Description
CreateDrawingOutput |
ToBMP |
ToGIF |
ToJPG |
ToPNG |
Back to Top
See Also
QRImageRenderer Class
NFX.Media.TagCodes.QR Namespace


QRImageRenderer.CreateDrawingOutput Method

QRImageRenderer CreateDrawingOutput Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DrawingOutput CreateDrawingOutput(
    this QRMatrix matrix,
    Nullable<Color> trueColor = null,
    Nullable<Color> falseColor = null,
    Nullable<QRImageRenderer..::..ImageScale> scale = 1
)
public static DrawingOutput CreateDrawingOutput(
    this QRMatrix matrix,
    Nullable<Color> trueColor = null,
    Nullable<Color> falseColor = null,
    Nullable<QRImageRenderer..::..ImageScale> scale = 1
)
<ExtensionAttribute>
Public Shared Function CreateDrawingOutput (
    matrix As QRMatrix,
    Optional trueColor As Nullable(Of Color) = Nothing,
    Optional falseColor As Nullable(Of Color) = Nothing,
    Optional scale As Nullable(Of QRImageRenderer..::..ImageScale) = 1
) As DrawingOutput
<ExtensionAttribute>
Public Shared Function CreateDrawingOutput (
    matrix As QRMatrix,
    Optional trueColor As Nullable(Of Color) = Nothing,
    Optional falseColor As Nullable(Of Color) = Nothing,
    Optional scale As Nullable(Of QRImageRenderer..::..ImageScale) = 1
) As DrawingOutput
public:
[ExtensionAttribute]
static DrawingOutput^ CreateDrawingOutput(
    QRMatrix^ matrix,
    Nullable<Color> trueColor = nullptr,
    Nullable<Color> falseColor = nullptr,
    Nullable<QRImageRenderer..::..ImageScale> scale = 1
)
public:
[ExtensionAttribute]
static DrawingOutput^ CreateDrawingOutput(
    QRMatrix^ matrix,
    Nullable<Color> trueColor = nullptr,
    Nullable<Color> falseColor = nullptr,
    Nullable<QRImageRenderer..::..ImageScale> scale = 1
)
static member CreateDrawingOutput :
        matrix : QRMatrix *
        ?trueColor : Nullable<Color> *
        ?falseColor : Nullable<Color> *
        ?scale : Nullable<QRImageRenderer..::..ImageScale>
(* Defaults:
        let _trueColor = defaultArg trueColor null
        let _falseColor = defaultArg falseColor null
        let _scale = defaultArg scale 1
*)
-> DrawingOutput
static member CreateDrawingOutput :
        matrix : QRMatrix *
        ?trueColor : Nullable<Color> *
        ?falseColor : Nullable<Color> *
        ?scale : Nullable<QRImageRenderer..::..ImageScale>
(* Defaults:
        let _trueColor = defaultArg trueColor null
        let _falseColor = defaultArg falseColor null
        let _scale = defaultArg scale 1
*)
-> DrawingOutput

Parameters

matrix
Type: NFX.Media.TagCodes.QR QRMatrix
trueColor (Optional)
Type: Online System Nullable Online Color
falseColor (Optional)
Type: Online System Nullable Online Color
scale (Optional)
Type: Online System Nullable QRImageRenderer ImageScale

Return Value

Type: DrawingOutput

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type QRMatrix. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
QRImageRenderer Class
QRImageRenderer Members
NFX.Media.TagCodes.QR Namespace


QRImageRenderer.ToBMP Method

QRImageRenderer ToBMP Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ToBMP(
    this QRMatrix matrix,
    Stream stream,
    Nullable<Color> trueColor = null,
    Nullable<Color> falseColor = null,
    Nullable<QRImageRenderer..::..ImageScale> scale = 1
)
public static void ToBMP(
    this QRMatrix matrix,
    Stream stream,
    Nullable<Color> trueColor = null,
    Nullable<Color> falseColor = null,
    Nullable<QRImageRenderer..::..ImageScale> scale = 1
)
<ExtensionAttribute>
Public Shared Sub ToBMP (
    matrix As QRMatrix,
    stream As Stream,
    Optional trueColor As Nullable(Of Color) = Nothing,
    Optional falseColor As Nullable(Of Color) = Nothing,
    Optional scale As Nullable(Of QRImageRenderer..::..ImageScale) = 1
)
<ExtensionAttribute>
Public Shared Sub ToBMP (
    matrix As QRMatrix,
    stream As Stream,
    Optional trueColor As Nullable(Of Color) = Nothing,
    Optional falseColor As Nullable(Of Color) = Nothing,
    Optional scale As Nullable(Of QRImageRenderer..::..ImageScale) = 1
)
public:
[ExtensionAttribute]
static void ToBMP(
    QRMatrix^ matrix,
    Stream^ stream,
    Nullable<Color> trueColor = nullptr,
    Nullable<Color> falseColor = nullptr,
    Nullable<QRImageRenderer..::..ImageScale> scale = 1
)
public:
[ExtensionAttribute]
static void ToBMP(
    QRMatrix^ matrix,
    Stream^ stream,
    Nullable<Color> trueColor = nullptr,
    Nullable<Color> falseColor = nullptr,
    Nullable<QRImageRenderer..::..ImageScale> scale = 1
)
static member ToBMP :
        matrix : QRMatrix *
        stream : Stream *
        ?trueColor : Nullable<Color> *
        ?falseColor : Nullable<Color> *
        ?scale : Nullable<QRImageRenderer..::..ImageScale>
(* Defaults:
        let _trueColor = defaultArg trueColor null
        let _falseColor = defaultArg falseColor null
        let _scale = defaultArg scale 1
*)
-> unit
static member ToBMP :
        matrix : QRMatrix *
        stream : Stream *
        ?trueColor : Nullable<Color> *
        ?falseColor : Nullable<Color> *
        ?scale : Nullable<QRImageRenderer..::..ImageScale>
(* Defaults:
        let _trueColor = defaultArg trueColor null
        let _falseColor = defaultArg falseColor null
        let _scale = defaultArg scale 1
*)
-> unit

Parameters

matrix
Type: NFX.Media.TagCodes.QR QRMatrix
stream
Type: Online System.IO Stream
trueColor (Optional)
Type: Online System Nullable Online Color
falseColor (Optional)
Type: Online System Nullable Online Color
scale (Optional)
Type: Online System Nullable QRImageRenderer ImageScale

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type QRMatrix. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
QRImageRenderer Class
QRImageRenderer Members
NFX.Media.TagCodes.QR Namespace


QRImageRenderer.ToGIF Method

QRImageRenderer ToGIF Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ToGIF(
    this QRMatrix matrix,
    Stream stream,
    Nullable<Color> trueColor = null,
    Nullable<Color> falseColor = null,
    Nullable<QRImageRenderer..::..ImageScale> scale = 1
)
public static void ToGIF(
    this QRMatrix matrix,
    Stream stream,
    Nullable<Color> trueColor = null,
    Nullable<Color> falseColor = null,
    Nullable<QRImageRenderer..::..ImageScale> scale = 1
)
<ExtensionAttribute>
Public Shared Sub ToGIF (
    matrix As QRMatrix,
    stream As Stream,
    Optional trueColor As Nullable(Of Color) = Nothing,
    Optional falseColor As Nullable(Of Color) = Nothing,
    Optional scale As Nullable(Of QRImageRenderer..::..ImageScale) = 1
)
<ExtensionAttribute>
Public Shared Sub ToGIF (
    matrix As QRMatrix,
    stream As Stream,
    Optional trueColor As Nullable(Of Color) = Nothing,
    Optional falseColor As Nullable(Of Color) = Nothing,
    Optional scale As Nullable(Of QRImageRenderer..::..ImageScale) = 1
)
public:
[ExtensionAttribute]
static void ToGIF(
    QRMatrix^ matrix,
    Stream^ stream,
    Nullable<Color> trueColor = nullptr,
    Nullable<Color> falseColor = nullptr,
    Nullable<QRImageRenderer..::..ImageScale> scale = 1
)
public:
[ExtensionAttribute]
static void ToGIF(
    QRMatrix^ matrix,
    Stream^ stream,
    Nullable<Color> trueColor = nullptr,
    Nullable<Color> falseColor = nullptr,
    Nullable<QRImageRenderer..::..ImageScale> scale = 1
)
static member ToGIF :
        matrix : QRMatrix *
        stream : Stream *
        ?trueColor : Nullable<Color> *
        ?falseColor : Nullable<Color> *
        ?scale : Nullable<QRImageRenderer..::..ImageScale>
(* Defaults:
        let _trueColor = defaultArg trueColor null
        let _falseColor = defaultArg falseColor null
        let _scale = defaultArg scale 1
*)
-> unit
static member ToGIF :
        matrix : QRMatrix *
        stream : Stream *
        ?trueColor : Nullable<Color> *
        ?falseColor : Nullable<Color> *
        ?scale : Nullable<QRImageRenderer..::..ImageScale>
(* Defaults:
        let _trueColor = defaultArg trueColor null
        let _falseColor = defaultArg falseColor null
        let _scale = defaultArg scale 1
*)
-> unit

Parameters

matrix
Type: NFX.Media.TagCodes.QR QRMatrix
stream
Type: Online System.IO Stream
trueColor (Optional)
Type: Online System Nullable Online Color
falseColor (Optional)
Type: Online System Nullable Online Color
scale (Optional)
Type: Online System Nullable QRImageRenderer ImageScale

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type QRMatrix. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
QRImageRenderer Class
QRImageRenderer Members
NFX.Media.TagCodes.QR Namespace


QRImageRenderer.ToJPG Method

QRImageRenderer ToJPG Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ToJPG(
    this QRMatrix matrix,
    Stream stream,
    Nullable<Color> trueColor = null,
    Nullable<Color> falseColor = null,
    Nullable<QRImageRenderer..::..ImageScale> scale = 1
)
public static void ToJPG(
    this QRMatrix matrix,
    Stream stream,
    Nullable<Color> trueColor = null,
    Nullable<Color> falseColor = null,
    Nullable<QRImageRenderer..::..ImageScale> scale = 1
)
<ExtensionAttribute>
Public Shared Sub ToJPG (
    matrix As QRMatrix,
    stream As Stream,
    Optional trueColor As Nullable(Of Color) = Nothing,
    Optional falseColor As Nullable(Of Color) = Nothing,
    Optional scale As Nullable(Of QRImageRenderer..::..ImageScale) = 1
)
<ExtensionAttribute>
Public Shared Sub ToJPG (
    matrix As QRMatrix,
    stream As Stream,
    Optional trueColor As Nullable(Of Color) = Nothing,
    Optional falseColor As Nullable(Of Color) = Nothing,
    Optional scale As Nullable(Of QRImageRenderer..::..ImageScale) = 1
)
public:
[ExtensionAttribute]
static void ToJPG(
    QRMatrix^ matrix,
    Stream^ stream,
    Nullable<Color> trueColor = nullptr,
    Nullable<Color> falseColor = nullptr,
    Nullable<QRImageRenderer..::..ImageScale> scale = 1
)
public:
[ExtensionAttribute]
static void ToJPG(
    QRMatrix^ matrix,
    Stream^ stream,
    Nullable<Color> trueColor = nullptr,
    Nullable<Color> falseColor = nullptr,
    Nullable<QRImageRenderer..::..ImageScale> scale = 1
)
static member ToJPG :
        matrix : QRMatrix *
        stream : Stream *
        ?trueColor : Nullable<Color> *
        ?falseColor : Nullable<Color> *
        ?scale : Nullable<QRImageRenderer..::..ImageScale>
(* Defaults:
        let _trueColor = defaultArg trueColor null
        let _falseColor = defaultArg falseColor null
        let _scale = defaultArg scale 1
*)
-> unit
static member ToJPG :
        matrix : QRMatrix *
        stream : Stream *
        ?trueColor : Nullable<Color> *
        ?falseColor : Nullable<Color> *
        ?scale : Nullable<QRImageRenderer..::..ImageScale>
(* Defaults:
        let _trueColor = defaultArg trueColor null
        let _falseColor = defaultArg falseColor null
        let _scale = defaultArg scale 1
*)
-> unit

Parameters

matrix
Type: NFX.Media.TagCodes.QR QRMatrix
stream
Type: Online System.IO Stream
trueColor (Optional)
Type: Online System Nullable Online Color
falseColor (Optional)
Type: Online System Nullable Online Color
scale (Optional)
Type: Online System Nullable QRImageRenderer ImageScale

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type QRMatrix. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
QRImageRenderer Class
QRImageRenderer Members
NFX.Media.TagCodes.QR Namespace


QRImageRenderer.ToPNG Method

QRImageRenderer ToPNG Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ToPNG(
    this QRMatrix matrix,
    Stream stream,
    Nullable<Color> trueColor = null,
    Nullable<Color> falseColor = null,
    Nullable<QRImageRenderer..::..ImageScale> scale = 1
)
public static void ToPNG(
    this QRMatrix matrix,
    Stream stream,
    Nullable<Color> trueColor = null,
    Nullable<Color> falseColor = null,
    Nullable<QRImageRenderer..::..ImageScale> scale = 1
)
<ExtensionAttribute>
Public Shared Sub ToPNG (
    matrix As QRMatrix,
    stream As Stream,
    Optional trueColor As Nullable(Of Color) = Nothing,
    Optional falseColor As Nullable(Of Color) = Nothing,
    Optional scale As Nullable(Of QRImageRenderer..::..ImageScale) = 1
)
<ExtensionAttribute>
Public Shared Sub ToPNG (
    matrix As QRMatrix,
    stream As Stream,
    Optional trueColor As Nullable(Of Color) = Nothing,
    Optional falseColor As Nullable(Of Color) = Nothing,
    Optional scale As Nullable(Of QRImageRenderer..::..ImageScale) = 1
)
public:
[ExtensionAttribute]
static void ToPNG(
    QRMatrix^ matrix,
    Stream^ stream,
    Nullable<Color> trueColor = nullptr,
    Nullable<Color> falseColor = nullptr,
    Nullable<QRImageRenderer..::..ImageScale> scale = 1
)
public:
[ExtensionAttribute]
static void ToPNG(
    QRMatrix^ matrix,
    Stream^ stream,
    Nullable<Color> trueColor = nullptr,
    Nullable<Color> falseColor = nullptr,
    Nullable<QRImageRenderer..::..ImageScale> scale = 1
)
static member ToPNG :
        matrix : QRMatrix *
        stream : Stream *
        ?trueColor : Nullable<Color> *
        ?falseColor : Nullable<Color> *
        ?scale : Nullable<QRImageRenderer..::..ImageScale>
(* Defaults:
        let _trueColor = defaultArg trueColor null
        let _falseColor = defaultArg falseColor null
        let _scale = defaultArg scale 1
*)
-> unit
static member ToPNG :
        matrix : QRMatrix *
        stream : Stream *
        ?trueColor : Nullable<Color> *
        ?falseColor : Nullable<Color> *
        ?scale : Nullable<QRImageRenderer..::..ImageScale>
(* Defaults:
        let _trueColor = defaultArg trueColor null
        let _falseColor = defaultArg falseColor null
        let _scale = defaultArg scale 1
*)
-> unit

Parameters

matrix
Type: NFX.Media.TagCodes.QR QRMatrix
stream
Type: Online System.IO Stream
trueColor (Optional)
Type: Online System Nullable Online Color
falseColor (Optional)
Type: Online System Nullable Online Color
scale (Optional)
Type: Online System Nullable QRImageRenderer ImageScale

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type QRMatrix. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
QRImageRenderer Class
QRImageRenderer Members
NFX.Media.TagCodes.QR Namespace


QRImageRenderer.ImageScale Enumeration

QRImageRenderer ImageScale Enumeration NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum ImageScale
public enum ImageScale
Public Enumeration ImageScale
Public Enumeration ImageScale
public enum class ImageScale
public enum class ImageScale
type ImageScale
type ImageScale
Members
Member name | Value | Description
Scale1x | 1 |
Scale2x | 2 |
Scale3x | 3 |
Scale4x | 4 |
Scale5x | 5 |
Scale6x | 6 |
Scale7x | 7 |
Scale8x | 8 |
See Also
NFX.Media.TagCodes.QR Namespace


QRMatrix Class

QRMatrix Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Collections MatrixBase Online Byte
NFX.Collections Matrix2DBase Online Byte
NFX.Collections Matrix2D Online Byte
NFX.Media.TagCodes.QR QRMatrix
NFX.Media.TagCodes.QR QREncoderMatrix

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class QRMatrix : Matrix2D<byte>
public class QRMatrix : Matrix2D<byte>
Public Class QRMatrix
    Inherits Matrix2D(Of Byte)
Public Class QRMatrix
    Inherits Matrix2D(Of Byte)
public ref class QRMatrix : public Matrix2D<unsigned char>
public ref class QRMatrix : public Matrix2D<unsigned char>
type QRMatrix =
    class
        inherit Matrix2D<byte>
    end
type QRMatrix =
    class
        inherit Matrix2D<byte>
    end
See Also
QRMatrix Members
NFX.Media.TagCodes.QR Namespace


QRMatrix Members

QRMatrix Members NFX Class Library

The QRMatrix type exposes the following members.
Constructors
 | Name | Description
Public method | QRMatrix | Initializes a new instance of the QRMatrix class
Back to Top
Methods
 | Name | Description
Public method | AddBasicPatterns |
Public method | AddTypeInfo |
Public method | AddVersionInfoIfRequired |
 | CalculateBCHCode |
 | CalculateMSBSet |
Public method | Clear |
Public method | Equals(Object) | (Inherited from MatrixBase T .)
Public method | Equals(MatrixBase T ) | (Inherited from MatrixBase T .)
Public method | Fill | (Inherited from Matrix2D T .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FormMatrix |
 | GenerateTypeInfoBits |
 | GenerateVersionInfoBits |
Public method | GetDataMaskBit |
Public method | GetEnumerator | (Inherited from MatrixBase T .)
Public method | GetHashCode | (Inherited from MatrixBase T .)
Public method | GetLowerBound | (Inherited from Matrix2DBase T .)
Public method | GetMaskPenalty |
Public method | GetMaskPenaltyRule1 |
Public method | GetMaskPenaltyRule2 |
Public method | GetMaskPenaltyRule3 |
Public method | GetMaskPenaltyRule4 |
Public method | GetMatrixEnumerator | (Inherited from Matrix2DBase T .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetUpperBound | (Inherited from Matrix2DBase T .)
Public method | InsertDataBits |
 | IsValidMaskPattern |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Matrix2DBase T ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | CreateDrawingOutput | (Defined by QRImageRenderer.)
Public Extension Method | ToBMP | (Defined by QRImageRenderer.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToGIF | (Defined by QRImageRenderer.)
Public Extension Method | ToJPG | (Defined by QRImageRenderer.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToPNG | (Defined by QRImageRenderer.)
Back to Top
Fields
 | Name | Description
Public field | Array | (Inherited from Matrix2D T .)
Public field | Height | (Inherited from Matrix2DBase T .)
 | MASK_PATTERNS_QTY |
Public field | Width | (Inherited from Matrix2DBase T .)
Back to Top
Properties
 | Name | Description
Public property | Item | (Inherited from Matrix2D T .)
Public property | Rank | (Inherited from Matrix2DBase T .)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from MatrixBase T .)
Back to Top
See Also
QRMatrix Class
NFX.Media.TagCodes.QR Namespace


QRMatrix Constructor

QRMatrix Constructor NFX Class Library

Initializes a new instance of the QRMatrix class

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public QRMatrix(
    int width,
    int height
)
public QRMatrix(
    int width,
    int height
)
Public Sub New (
    width As Integer,
    height As Integer
)
Public Sub New (
    width As Integer,
    height As Integer
)
public:
QRMatrix(
    int width,
    int height
)
public:
QRMatrix(
    int width,
    int height
)
new :
        width : int *
        height : int -> QRMatrix
new :
        width : int *
        height : int -> QRMatrix

Parameters

width
Type: Online System Int32
height
Type: Online System Int32
See Also
QRMatrix Class
QRMatrix Members
NFX.Media.TagCodes.QR Namespace


QRMatrix Fields

QRMatrix Fields NFX Class Library

The QRMatrix type exposes the following members.
Fields
 | Name | Description
Public field | Array | (Inherited from Matrix2D T .)
Public field | Height | (Inherited from Matrix2DBase T .)
 | MASK_PATTERNS_QTY |
Public field | Width | (Inherited from Matrix2DBase T .)
Back to Top
See Also
QRMatrix Class
NFX.Media.TagCodes.QR Namespace


QRMatrix.MASK_PATTERNS_QTY Field

QRMatrix MASK_PATTERNS_QTY Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected const int MASK_PATTERNS_QTY
protected const int MASK_PATTERNS_QTY
Protected Const MASK_PATTERNS_QTY As Integer
Protected Const MASK_PATTERNS_QTY As Integer
protected:
literal int MASK_PATTERNS_QTY
protected:
literal int MASK_PATTERNS_QTY
static val mutable MASK_PATTERNS_QTY: int
static val mutable MASK_PATTERNS_QTY: int

Field Value

Type: Online Int32
See Also
QRMatrix Class
QRMatrix Members
NFX.Media.TagCodes.QR Namespace


QRMatrix Methods

QRMatrix Methods NFX Class Library

The QRMatrix type exposes the following members.
Methods
 | Name | Description
Public method | AddBasicPatterns |
Public method | AddTypeInfo |
Public method | AddVersionInfoIfRequired |
 | CalculateBCHCode |
 | CalculateMSBSet |
Public method | Clear |
Public method | Equals(Object) | (Inherited from MatrixBase T .)
Public method | Equals(MatrixBase T ) | (Inherited from MatrixBase T .)
Public method | Fill | (Inherited from Matrix2D T .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | FormMatrix |
 | GenerateTypeInfoBits |
 | GenerateVersionInfoBits |
Public method | GetDataMaskBit |
Public method | GetEnumerator | (Inherited from MatrixBase T .)
Public method | GetHashCode | (Inherited from MatrixBase T .)
Public method | GetLowerBound | (Inherited from Matrix2DBase T .)
Public method | GetMaskPenalty |
Public method | GetMaskPenaltyRule1 |
Public method | GetMaskPenaltyRule2 |
Public method | GetMaskPenaltyRule3 |
Public method | GetMaskPenaltyRule4 |
Public method | GetMatrixEnumerator | (Inherited from Matrix2DBase T .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetUpperBound | (Inherited from Matrix2DBase T .)
Public method | InsertDataBits |
 | IsValidMaskPattern |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Matrix2DBase T ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | CreateDrawingOutput | (Defined by QRImageRenderer.)
Public Extension Method | ToBMP | (Defined by QRImageRenderer.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToGIF | (Defined by QRImageRenderer.)
Public Extension Method | ToJPG | (Defined by QRImageRenderer.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToPNG | (Defined by QRImageRenderer.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from MatrixBase T .)
Back to Top
See Also
QRMatrix Class
NFX.Media.TagCodes.QR Namespace


QRMatrix.AddBasicPatterns Method

QRMatrix AddBasicPatterns Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddBasicPatterns(
    QRVersion version
)
public void AddBasicPatterns(
    QRVersion version
)
Public Sub AddBasicPatterns (
    version As QRVersion
)
Public Sub AddBasicPatterns (
    version As QRVersion
)
public:
void AddBasicPatterns(
    QRVersion^ version
)
public:
void AddBasicPatterns(
    QRVersion^ version
)
member AddBasicPatterns :
        version : QRVersion -> unit
member AddBasicPatterns :
        version : QRVersion -> unit

Parameters

version
Type: NFX.Media.TagCodes.QR QRVersion
See Also
QRMatrix Class
QRMatrix Members
NFX.Media.TagCodes.QR Namespace


QRMatrix.AddTypeInfo Method

QRMatrix AddTypeInfo Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddTypeInfo(
    QRCorrectionLevel ecLevel,
    int maskPattern
)
public void AddTypeInfo(
    QRCorrectionLevel ecLevel,
    int maskPattern
)
Public Sub AddTypeInfo (
    ecLevel As QRCorrectionLevel,
    maskPattern As Integer
)
Public Sub AddTypeInfo (
    ecLevel As QRCorrectionLevel,
    maskPattern As Integer
)
public:
void AddTypeInfo(
    QRCorrectionLevel^ ecLevel,
    int maskPattern
)
public:
void AddTypeInfo(
    QRCorrectionLevel^ ecLevel,
    int maskPattern
)
member AddTypeInfo :
        ecLevel : QRCorrectionLevel *
        maskPattern : int -> unit
member AddTypeInfo :
        ecLevel : QRCorrectionLevel *
        maskPattern : int -> unit

Parameters

ecLevel
Type: NFX.Media.TagCodes.QR QRCorrectionLevel
maskPattern
Type: Online System Int32
See Also
QRMatrix Class
QRMatrix Members
NFX.Media.TagCodes.QR Namespace


QRMatrix.AddVersionInfoIfRequired Method

QRMatrix AddVersionInfoIfRequired Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddVersionInfoIfRequired(
    QRVersion version
)
public void AddVersionInfoIfRequired(
    QRVersion version
)
Public Sub AddVersionInfoIfRequired (
    version As QRVersion
)
Public Sub AddVersionInfoIfRequired (
    version As QRVersion
)
public:
void AddVersionInfoIfRequired(
    QRVersion^ version
)
public:
void AddVersionInfoIfRequired(
    QRVersion^ version
)
member AddVersionInfoIfRequired :
        version : QRVersion -> unit
member AddVersionInfoIfRequired :
        version : QRVersion -> unit

Parameters

version
Type: NFX.Media.TagCodes.QR QRVersion
See Also
QRMatrix Class
QRMatrix Members
NFX.Media.TagCodes.QR Namespace


QRMatrix.CalculateBCHCode Method

QRMatrix CalculateBCHCode Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int CalculateBCHCode(
    int value,
    int poly
)
public static int CalculateBCHCode(
    int value,
    int poly
)
Public Shared Function CalculateBCHCode (
    value As Integer,
    poly As Integer
) As Integer
Public Shared Function CalculateBCHCode (
    value As Integer,
    poly As Integer
) As Integer
public:
static int CalculateBCHCode(
    int value,
    int poly
)
public:
static int CalculateBCHCode(
    int value,
    int poly
)
static member CalculateBCHCode :
        value : int *
        poly : int -> int
static member CalculateBCHCode :
        value : int *
        poly : int -> int

Parameters

value
Type: Online System Int32
poly
Type: Online System Int32

Return Value

Type: Online Int32
See Also
QRMatrix Class
QRMatrix Members
NFX.Media.TagCodes.QR Namespace


QRMatrix.CalculateMSBSet Method

QRMatrix CalculateMSBSet Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int CalculateMSBSet(
    int valueRenamed
)
public static int CalculateMSBSet(
    int valueRenamed
)
Public Shared Function CalculateMSBSet (
    valueRenamed As Integer
) As Integer
Public Shared Function CalculateMSBSet (
    valueRenamed As Integer
) As Integer
public:
static int CalculateMSBSet(
    int valueRenamed
)
public:
static int CalculateMSBSet(
    int valueRenamed
)
static member CalculateMSBSet :
        valueRenamed : int -> int
static member CalculateMSBSet :
        valueRenamed : int -> int

Parameters

valueRenamed
Type: Online System Int32

Return Value

Type: Online Int32
See Also
QRMatrix Class
QRMatrix Members
NFX.Media.TagCodes.QR Namespace


QRMatrix.Clear Method

QRMatrix Clear Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
void Clear()
public:
void Clear()
member Clear : unit -> unit
member Clear : unit -> unit
See Also
QRMatrix Class
QRMatrix Members
NFX.Media.TagCodes.QR Namespace


QRMatrix.FormMatrix Method

QRMatrix FormMatrix Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void FormMatrix(
    BitList dataBits,
    QRCorrectionLevel correctionLevel,
    QRVersion version,
    int maskPattern
)
public void FormMatrix(
    BitList dataBits,
    QRCorrectionLevel correctionLevel,
    QRVersion version,
    int maskPattern
)
Public Sub FormMatrix (
    dataBits As BitList,
    correctionLevel As QRCorrectionLevel,
    version As QRVersion,
    maskPattern As Integer
)
Public Sub FormMatrix (
    dataBits As BitList,
    correctionLevel As QRCorrectionLevel,
    version As QRVersion,
    maskPattern As Integer
)
public:
void FormMatrix(
    BitList^ dataBits,
    QRCorrectionLevel^ correctionLevel,
    QRVersion^ version,
    int maskPattern
)
public:
void FormMatrix(
    BitList^ dataBits,
    QRCorrectionLevel^ correctionLevel,
    QRVersion^ version,
    int maskPattern
)
member FormMatrix :
        dataBits : BitList *
        correctionLevel : QRCorrectionLevel *
        version : QRVersion *
        maskPattern : int -> unit
member FormMatrix :
        dataBits : BitList *
        correctionLevel : QRCorrectionLevel *
        version : QRVersion *
        maskPattern : int -> unit

Parameters

dataBits
Type: NFX.Collections BitList
correctionLevel
Type: NFX.Media.TagCodes.QR QRCorrectionLevel
version
Type: NFX.Media.TagCodes.QR QRVersion
maskPattern
Type: Online System Int32
See Also
QRMatrix Class
QRMatrix Members
NFX.Media.TagCodes.QR Namespace


QRMatrix.GenerateTypeInfoBits Method

QRMatrix GenerateTypeInfoBits Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void GenerateTypeInfoBits(
    BitList bits,
    QRCorrectionLevel correctionLevel,
    int maskPattern
)
public static void GenerateTypeInfoBits(
    BitList bits,
    QRCorrectionLevel correctionLevel,
    int maskPattern
)
Public Shared Sub GenerateTypeInfoBits (
    bits As BitList,
    correctionLevel As QRCorrectionLevel,
    maskPattern As Integer
)
Public Shared Sub GenerateTypeInfoBits (
    bits As BitList,
    correctionLevel As QRCorrectionLevel,
    maskPattern As Integer
)
public:
static void GenerateTypeInfoBits(
    BitList^ bits,
    QRCorrectionLevel^ correctionLevel,
    int maskPattern
)
public:
static void GenerateTypeInfoBits(
    BitList^ bits,
    QRCorrectionLevel^ correctionLevel,
    int maskPattern
)
static member GenerateTypeInfoBits :
        bits : BitList *
        correctionLevel : QRCorrectionLevel *
        maskPattern : int -> unit
static member GenerateTypeInfoBits :
        bits : BitList *
        correctionLevel : QRCorrectionLevel *
        maskPattern : int -> unit

Parameters

bits
Type: NFX.Collections BitList
correctionLevel
Type: NFX.Media.TagCodes.QR QRCorrectionLevel
maskPattern
Type: Online System Int32
See Also
QRMatrix Class
QRMatrix Members
NFX.Media.TagCodes.QR Namespace


QRMatrix.GenerateVersionInfoBits Method

QRMatrix GenerateVersionInfoBits Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void GenerateVersionInfoBits(
    BitList bits,
    QRVersion version
)
public static void GenerateVersionInfoBits(
    BitList bits,
    QRVersion version
)
Public Shared Sub GenerateVersionInfoBits (
    bits As BitList,
    version As QRVersion
)
Public Shared Sub GenerateVersionInfoBits (
    bits As BitList,
    version As QRVersion
)
public:
static void GenerateVersionInfoBits(
    BitList^ bits,
    QRVersion^ version
)
public:
static void GenerateVersionInfoBits(
    BitList^ bits,
    QRVersion^ version
)
static member GenerateVersionInfoBits :
        bits : BitList *
        version : QRVersion -> unit
static member GenerateVersionInfoBits :
        bits : BitList *
        version : QRVersion -> unit

Parameters

bits
Type: NFX.Collections BitList
version
Type: NFX.Media.TagCodes.QR QRVersion
See Also
QRMatrix Class
QRMatrix Members
NFX.Media.TagCodes.QR Namespace


QRMatrix.GetDataMaskBit Method

QRMatrix GetDataMaskBit Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool GetDataMaskBit(
    int maskPattern,
    int x,
    int y
)
public bool GetDataMaskBit(
    int maskPattern,
    int x,
    int y
)
Public Function GetDataMaskBit (
    maskPattern As Integer,
    x As Integer,
    y As Integer
) As Boolean
Public Function GetDataMaskBit (
    maskPattern As Integer,
    x As Integer,
    y As Integer
) As Boolean
public:
bool GetDataMaskBit(
    int maskPattern,
    int x,
    int y
)
public:
bool GetDataMaskBit(
    int maskPattern,
    int x,
    int y
)
member GetDataMaskBit :
        maskPattern : int *
        x : int *
        y : int -> bool
member GetDataMaskBit :
        maskPattern : int *
        x : int *
        y : int -> bool

Parameters

maskPattern
Type: Online System Int32
x
Type: Online System Int32
y
Type: Online System Int32

Return Value

Type: Online Boolean
See Also
QRMatrix Class
QRMatrix Members
NFX.Media.TagCodes.QR Namespace


QRMatrix.GetMaskPenalty Method

QRMatrix GetMaskPenalty Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int GetMaskPenalty()
public int GetMaskPenalty()
Public Function GetMaskPenalty As Integer
Public Function GetMaskPenalty As Integer
public:
int GetMaskPenalty()
public:
int GetMaskPenalty()
member GetMaskPenalty : unit -> int
member GetMaskPenalty : unit -> int

Return Value

Type: Online Int32
See Also
QRMatrix Class
QRMatrix Members
NFX.Media.TagCodes.QR Namespace


QRMatrix.GetMaskPenaltyRule1 Method

QRMatrix GetMaskPenaltyRule1 Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int GetMaskPenaltyRule1()
public int GetMaskPenaltyRule1()
Public Function GetMaskPenaltyRule1 As Integer
Public Function GetMaskPenaltyRule1 As Integer
public:
int GetMaskPenaltyRule1()
public:
int GetMaskPenaltyRule1()
member GetMaskPenaltyRule1 : unit -> int
member GetMaskPenaltyRule1 : unit -> int

Return Value

Type: Online Int32
See Also
QRMatrix Class
QRMatrix Members
NFX.Media.TagCodes.QR Namespace


QRMatrix.GetMaskPenaltyRule2 Method

QRMatrix GetMaskPenaltyRule2 Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int GetMaskPenaltyRule2()
public int GetMaskPenaltyRule2()
Public Function GetMaskPenaltyRule2 As Integer
Public Function GetMaskPenaltyRule2 As Integer
public:
int GetMaskPenaltyRule2()
public:
int GetMaskPenaltyRule2()
member GetMaskPenaltyRule2 : unit -> int
member GetMaskPenaltyRule2 : unit -> int

Return Value

Type: Online Int32
See Also
QRMatrix Class
QRMatrix Members
NFX.Media.TagCodes.QR Namespace


QRMatrix.GetMaskPenaltyRule3 Method

QRMatrix GetMaskPenaltyRule3 Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int GetMaskPenaltyRule3()
public int GetMaskPenaltyRule3()
Public Function GetMaskPenaltyRule3 As Integer
Public Function GetMaskPenaltyRule3 As Integer
public:
int GetMaskPenaltyRule3()
public:
int GetMaskPenaltyRule3()
member GetMaskPenaltyRule3 : unit -> int
member GetMaskPenaltyRule3 : unit -> int

Return Value

Type: Online Int32
See Also
QRMatrix Class
QRMatrix Members
NFX.Media.TagCodes.QR Namespace


QRMatrix.GetMaskPenaltyRule4 Method

QRMatrix GetMaskPenaltyRule4 Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int GetMaskPenaltyRule4()
public int GetMaskPenaltyRule4()
Public Function GetMaskPenaltyRule4 As Integer
Public Function GetMaskPenaltyRule4 As Integer
public:
int GetMaskPenaltyRule4()
public:
int GetMaskPenaltyRule4()
member GetMaskPenaltyRule4 : unit -> int
member GetMaskPenaltyRule4 : unit -> int

Return Value

Type: Online Int32
See Also
QRMatrix Class
QRMatrix Members
NFX.Media.TagCodes.QR Namespace


QRMatrix.InsertDataBits Method

QRMatrix InsertDataBits Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void InsertDataBits(
    BitList dataBits,
    int maskPattern
)
public void InsertDataBits(
    BitList dataBits,
    int maskPattern
)
Public Sub InsertDataBits (
    dataBits As BitList,
    maskPattern As Integer
)
Public Sub InsertDataBits (
    dataBits As BitList,
    maskPattern As Integer
)
public:
void InsertDataBits(
    BitList^ dataBits,
    int maskPattern
)
public:
void InsertDataBits(
    BitList^ dataBits,
    int maskPattern
)
member InsertDataBits :
        dataBits : BitList *
        maskPattern : int -> unit
member InsertDataBits :
        dataBits : BitList *
        maskPattern : int -> unit

Parameters

dataBits
Type: NFX.Collections BitList
maskPattern
Type: Online System Int32
See Also
QRMatrix Class
QRMatrix Members
NFX.Media.TagCodes.QR Namespace


QRMatrix.IsValidMaskPattern Method

QRMatrix IsValidMaskPattern Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected static bool IsValidMaskPattern(
    int maskPattern
)
protected static bool IsValidMaskPattern(
    int maskPattern
)
Protected Shared Function IsValidMaskPattern (
    maskPattern As Integer
) As Boolean
Protected Shared Function IsValidMaskPattern (
    maskPattern As Integer
) As Boolean
protected:
static bool IsValidMaskPattern(
    int maskPattern
)
protected:
static bool IsValidMaskPattern(
    int maskPattern
)
static member IsValidMaskPattern :
        maskPattern : int -> bool
static member IsValidMaskPattern :
        maskPattern : int -> bool

Parameters

maskPattern
Type: Online System Int32

Return Value

Type: Online Boolean
See Also
QRMatrix Class
QRMatrix Members
NFX.Media.TagCodes.QR Namespace


QRMatrix.ToString Method

QRMatrix ToString Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
QRMatrix Class
QRMatrix Members
NFX.Media.TagCodes.QR Namespace


QRMatrix Properties

QRMatrix Properties NFX Class Library

The QRMatrix type exposes the following members.
Properties
 | Name | Description
Public property | Item | (Inherited from Matrix2D T .)
Public property | Rank | (Inherited from Matrix2DBase T .)
Back to Top
See Also
QRMatrix Class
NFX.Media.TagCodes.QR Namespace


QRMode Class

QRMode Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Media.TagCodes.QR QRMode

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class QRMode
public sealed class QRMode
Public NotInheritable Class QRMode
Public NotInheritable Class QRMode
public ref class QRMode sealed
public ref class QRMode sealed
[<SealedAttribute>]
type QRMode =  class end
[<SealedAttribute>]
type QRMode =  class end
See Also
QRMode Members
NFX.Media.TagCodes.QR Namespace


QRMode Members

QRMode Members NFX Class Library

The QRMode type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetVersionCharacterCount |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | ALPHANUMERIC |
 | BYTE |
 | ECI |
 | FNC1_FIRST_POSITION |
 | FNC1_SECOND_POSITION |
 | HANZI |
 | KANJI |
Public field | Mode |
Public field | ModeSignature |
 | NUMERIC |
 | STRUCTURED_APPEND |
 | TERMINATOR |
Public field | VersionCharacterCount |
Back to Top
See Also
QRMode Class
NFX.Media.TagCodes.QR Namespace


QRMode Fields

QRMode Fields NFX Class Library

The QRMode type exposes the following members.
Fields
 | Name | Description
 | ALPHANUMERIC |
 | BYTE |
 | ECI |
 | FNC1_FIRST_POSITION |
 | FNC1_SECOND_POSITION |
 | HANZI |
 | KANJI |
Public field | Mode |
Public field | ModeSignature |
 | NUMERIC |
 | STRUCTURED_APPEND |
 | TERMINATOR |
Public field | VersionCharacterCount |
Back to Top
See Also
QRMode Class
NFX.Media.TagCodes.QR Namespace


QRMode.ALPHANUMERIC Field

QRMode ALPHANUMERIC Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly QRMode ALPHANUMERIC
public static readonly QRMode ALPHANUMERIC
Public Shared ReadOnly ALPHANUMERIC As QRMode
Public Shared ReadOnly ALPHANUMERIC As QRMode
public:
static initonly QRMode^ ALPHANUMERIC
public:
static initonly QRMode^ ALPHANUMERIC
static val ALPHANUMERIC: QRMode
static val ALPHANUMERIC: QRMode

Field Value

Type: QRMode
See Also
QRMode Class
QRMode Members
NFX.Media.TagCodes.QR Namespace


QRMode.BYTE Field

QRMode BYTE Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly QRMode BYTE
public static readonly QRMode BYTE
Public Shared ReadOnly BYTE As QRMode
Public Shared ReadOnly BYTE As QRMode
public:
static initonly QRMode^ BYTE
public:
static initonly QRMode^ BYTE
static val BYTE: QRMode
static val BYTE: QRMode

Field Value

Type: QRMode
See Also
QRMode Class
QRMode Members
NFX.Media.TagCodes.QR Namespace


QRMode.ECI Field

QRMode ECI Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly QRMode ECI
public static readonly QRMode ECI
Public Shared ReadOnly ECI As QRMode
Public Shared ReadOnly ECI As QRMode
public:
static initonly QRMode^ ECI
public:
static initonly QRMode^ ECI
static val ECI: QRMode
static val ECI: QRMode

Field Value

Type: QRMode
See Also
QRMode Class
QRMode Members
NFX.Media.TagCodes.QR Namespace


QRMode.FNC1_FIRST_POSITION Field

QRMode FNC1_FIRST_POSITION Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly QRMode FNC1_FIRST_POSITION
public static readonly QRMode FNC1_FIRST_POSITION
Public Shared ReadOnly FNC1_FIRST_POSITION As QRMode
Public Shared ReadOnly FNC1_FIRST_POSITION As QRMode
public:
static initonly QRMode^ FNC1_FIRST_POSITION
public:
static initonly QRMode^ FNC1_FIRST_POSITION
static val FNC1_FIRST_POSITION: QRMode
static val FNC1_FIRST_POSITION: QRMode

Field Value

Type: QRMode
See Also
QRMode Class
QRMode Members
NFX.Media.TagCodes.QR Namespace


QRMode.FNC1_SECOND_POSITION Field

QRMode FNC1_SECOND_POSITION Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly QRMode FNC1_SECOND_POSITION
public static readonly QRMode FNC1_SECOND_POSITION
Public Shared ReadOnly FNC1_SECOND_POSITION As QRMode
Public Shared ReadOnly FNC1_SECOND_POSITION As QRMode
public:
static initonly QRMode^ FNC1_SECOND_POSITION
public:
static initonly QRMode^ FNC1_SECOND_POSITION
static val FNC1_SECOND_POSITION: QRMode
static val FNC1_SECOND_POSITION: QRMode

Field Value

Type: QRMode
See Also
QRMode Class
QRMode Members
NFX.Media.TagCodes.QR Namespace


QRMode.HANZI Field

QRMode HANZI Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly QRMode HANZI
public static readonly QRMode HANZI
Public Shared ReadOnly HANZI As QRMode
Public Shared ReadOnly HANZI As QRMode
public:
static initonly QRMode^ HANZI
public:
static initonly QRMode^ HANZI
static val HANZI: QRMode
static val HANZI: QRMode

Field Value

Type: QRMode
See Also
QRMode Class
QRMode Members
NFX.Media.TagCodes.QR Namespace


QRMode.KANJI Field

QRMode KANJI Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly QRMode KANJI
public static readonly QRMode KANJI
Public Shared ReadOnly KANJI As QRMode
Public Shared ReadOnly KANJI As QRMode
public:
static initonly QRMode^ KANJI
public:
static initonly QRMode^ KANJI
static val KANJI: QRMode
static val KANJI: QRMode

Field Value

Type: QRMode
See Also
QRMode Class
QRMode Members
NFX.Media.TagCodes.QR Namespace


QRMode.Mode Field

QRMode Mode Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly QRMode..::..EMode Mode
public readonly QRMode..::..EMode Mode
Public ReadOnly Mode As QRMode..::..EMode
Public ReadOnly Mode As QRMode..::..EMode
public:
initonly QRMode..::..EMode Mode
public:
initonly QRMode..::..EMode Mode
val Mode: QRMode..::..EMode
val Mode: QRMode..::..EMode

Field Value

Type: QRMode EMode
See Also
QRMode Class
QRMode Members
NFX.Media.TagCodes.QR Namespace


QRMode.ModeSignature Field

QRMode ModeSignature Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int ModeSignature
public readonly int ModeSignature
Public ReadOnly ModeSignature As Integer
Public ReadOnly ModeSignature As Integer
public:
initonly int ModeSignature
public:
initonly int ModeSignature
val ModeSignature: int
val ModeSignature: int

Field Value

Type: Online Int32
See Also
QRMode Class
QRMode Members
NFX.Media.TagCodes.QR Namespace


QRMode.NUMERIC Field

QRMode NUMERIC Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly QRMode NUMERIC
public static readonly QRMode NUMERIC
Public Shared ReadOnly NUMERIC As QRMode
Public Shared ReadOnly NUMERIC As QRMode
public:
static initonly QRMode^ NUMERIC
public:
static initonly QRMode^ NUMERIC
static val NUMERIC: QRMode
static val NUMERIC: QRMode

Field Value

Type: QRMode
See Also
QRMode Class
QRMode Members
NFX.Media.TagCodes.QR Namespace


QRMode.STRUCTURED_APPEND Field

QRMode STRUCTURED_APPEND Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly QRMode STRUCTURED_APPEND
public static readonly QRMode STRUCTURED_APPEND
Public Shared ReadOnly STRUCTURED_APPEND As QRMode
Public Shared ReadOnly STRUCTURED_APPEND As QRMode
public:
static initonly QRMode^ STRUCTURED_APPEND
public:
static initonly QRMode^ STRUCTURED_APPEND
static val STRUCTURED_APPEND: QRMode
static val STRUCTURED_APPEND: QRMode

Field Value

Type: QRMode
See Also
QRMode Class
QRMode Members
NFX.Media.TagCodes.QR Namespace


QRMode.TERMINATOR Field

QRMode TERMINATOR Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly QRMode TERMINATOR
public static readonly QRMode TERMINATOR
Public Shared ReadOnly TERMINATOR As QRMode
Public Shared ReadOnly TERMINATOR As QRMode
public:
static initonly QRMode^ TERMINATOR
public:
static initonly QRMode^ TERMINATOR
static val TERMINATOR: QRMode
static val TERMINATOR: QRMode

Field Value

Type: QRMode
See Also
QRMode Class
QRMode Members
NFX.Media.TagCodes.QR Namespace


QRMode.VersionCharacterCount Field

QRMode VersionCharacterCount Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int[] VersionCharacterCount
public readonly int[] VersionCharacterCount
Public ReadOnly VersionCharacterCount As Integer()
Public ReadOnly VersionCharacterCount As Integer()
public:
initonly array<int>^ VersionCharacterCount
public:
initonly array<int>^ VersionCharacterCount
val VersionCharacterCount: int[]
val VersionCharacterCount: int[]

Field Value

Type: Online Int32
See Also
QRMode Class
QRMode Members
NFX.Media.TagCodes.QR Namespace


QRMode Methods

QRMode Methods NFX Class Library

The QRMode type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetVersionCharacterCount |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
QRMode Class
NFX.Media.TagCodes.QR Namespace


QRMode.GetVersionCharacterCount Method

QRMode GetVersionCharacterCount Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int GetVersionCharacterCount(
    QRVersion version
)
public int GetVersionCharacterCount(
    QRVersion version
)
Public Function GetVersionCharacterCount (
    version As QRVersion
) As Integer
Public Function GetVersionCharacterCount (
    version As QRVersion
) As Integer
public:
int GetVersionCharacterCount(
    QRVersion^ version
)
public:
int GetVersionCharacterCount(
    QRVersion^ version
)
member GetVersionCharacterCount :
        version : QRVersion -> int
member GetVersionCharacterCount :
        version : QRVersion -> int

Parameters

version
Type: NFX.Media.TagCodes.QR QRVersion

Return Value

Type: Online Int32
See Also
QRMode Class
QRMode Members
NFX.Media.TagCodes.QR Namespace


QRMode.ToString Method

QRMode ToString Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
QRMode Class
QRMode Members
NFX.Media.TagCodes.QR Namespace


QRMode.EMode Enumeration

QRMode EMode Enumeration NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum EMode
public enum EMode
Public Enumeration EMode
Public Enumeration EMode
public enum class EMode
public enum class EMode
type EMode
type EMode
Members
Member name | Value | Description
TERMINATOR | 0 |
NUMERIC | 1 |
ALPHANUMERIC | 2 |
STRUCTURED_APPEND | 3 |
BYTE | 4 |
ECI | 5 |
KANJI | 6 |
FNC1_FIRST_POSITION | 7 |
FNC1_SECOND_POSITION | 8 |
HANZI | 9 |
See Also
NFX.Media.TagCodes.QR Namespace


QRVersion Class

QRVersion Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Media.TagCodes.QR QRVersion

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class QRVersion
public class QRVersion
Public Class QRVersion
Public Class QRVersion
public ref class QRVersion
public ref class QRVersion
type QRVersion =  class end
type QRVersion =  class end
See Also
QRVersion Members
NFX.Media.TagCodes.QR Namespace


QRVersion Members

QRVersion Members NFX Class Library

The QRVersion type exposes the following members.
Constructors
 | Name | Description
Public method | QRVersion | Initializes a new instance of the QRVersion class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetBlockSetByLevel |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | GetVersionByNumber |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | AlignmentPatternCenters |
Public field | Dimension |
Public field | Number |
Public field | TotalCodewords |
Back to Top
See Also
QRVersion Class
NFX.Media.TagCodes.QR Namespace


QRVersion Constructor

QRVersion Constructor NFX Class Library

Initializes a new instance of the QRVersion class

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public QRVersion(
    int number,
    int[] alignmentCenters,
    params QRVersion..::..CorrectionBlockSet[] correctionBlockSets
)
public QRVersion(
    int number,
    int[] alignmentCenters,
    params QRVersion..::..CorrectionBlockSet[] correctionBlockSets
)
Public Sub New (
    number As Integer,
    alignmentCenters As Integer(),
    ParamArray correctionBlockSets As QRVersion..::..CorrectionBlockSet()
)
Public Sub New (
    number As Integer,
    alignmentCenters As Integer(),
    ParamArray correctionBlockSets As QRVersion..::..CorrectionBlockSet()
)
public:
QRVersion(
    int number,
    array<int>^ alignmentCenters,
    ... array<QRVersion..::..CorrectionBlockSet^>^ correctionBlockSets
)
public:
QRVersion(
    int number,
    array<int>^ alignmentCenters,
    ... array<QRVersion..::..CorrectionBlockSet^>^ correctionBlockSets
)
new :
        number : int *
        alignmentCenters : int[] *
        correctionBlockSets : QRVersion..::..CorrectionBlockSet[] -> QRVersion
new :
        number : int *
        alignmentCenters : int[] *
        correctionBlockSets : QRVersion..::..CorrectionBlockSet[] -> QRVersion

Parameters

number
Type: Online System Int32
alignmentCenters
Type: Online System Int32
correctionBlockSets
Type: NFX.Media.TagCodes.QR QRVersion CorrectionBlockSet
See Also
QRVersion Class
QRVersion Members
NFX.Media.TagCodes.QR Namespace


QRVersion Fields

QRVersion Fields NFX Class Library

The QRVersion type exposes the following members.
Fields
 | Name | Description
Public field | AlignmentPatternCenters |
Public field | Dimension |
Public field | Number |
Public field | TotalCodewords |
Back to Top
See Also
QRVersion Class
NFX.Media.TagCodes.QR Namespace


QRVersion.AlignmentPatternCenters Field

QRVersion AlignmentPatternCenters Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int[] AlignmentPatternCenters
public readonly int[] AlignmentPatternCenters
Public ReadOnly AlignmentPatternCenters As Integer()
Public ReadOnly AlignmentPatternCenters As Integer()
public:
initonly array<int>^ AlignmentPatternCenters
public:
initonly array<int>^ AlignmentPatternCenters
val AlignmentPatternCenters: int[]
val AlignmentPatternCenters: int[]

Field Value

Type: Online Int32
See Also
QRVersion Class
QRVersion Members
NFX.Media.TagCodes.QR Namespace


QRVersion.Dimension Field

QRVersion Dimension Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Dimension
public readonly int Dimension
Public ReadOnly Dimension As Integer
Public ReadOnly Dimension As Integer
public:
initonly int Dimension
public:
initonly int Dimension
val Dimension: int
val Dimension: int

Field Value

Type: Online Int32
See Also
QRVersion Class
QRVersion Members
NFX.Media.TagCodes.QR Namespace


QRVersion.Number Field

QRVersion Number Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Number
public readonly int Number
Public ReadOnly Number As Integer
Public ReadOnly Number As Integer
public:
initonly int Number
public:
initonly int Number
val Number: int
val Number: int

Field Value

Type: Online Int32
See Also
QRVersion Class
QRVersion Members
NFX.Media.TagCodes.QR Namespace


QRVersion.TotalCodewords Field

QRVersion TotalCodewords Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int TotalCodewords
public readonly int TotalCodewords
Public ReadOnly TotalCodewords As Integer
Public ReadOnly TotalCodewords As Integer
public:
initonly int TotalCodewords
public:
initonly int TotalCodewords
val TotalCodewords: int
val TotalCodewords: int

Field Value

Type: Online Int32
See Also
QRVersion Class
QRVersion Members
NFX.Media.TagCodes.QR Namespace


QRVersion Methods

QRVersion Methods NFX Class Library

The QRVersion type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetBlockSetByLevel |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | GetVersionByNumber |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
QRVersion Class
NFX.Media.TagCodes.QR Namespace


QRVersion.GetBlockSetByLevel Method

QRVersion GetBlockSetByLevel Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public QRVersion..::..CorrectionBlockSet GetBlockSetByLevel(
    QRCorrectionLevel level
)
public QRVersion..::..CorrectionBlockSet GetBlockSetByLevel(
    QRCorrectionLevel level
)
Public Function GetBlockSetByLevel (
    level As QRCorrectionLevel
) As QRVersion..::..CorrectionBlockSet
Public Function GetBlockSetByLevel (
    level As QRCorrectionLevel
) As QRVersion..::..CorrectionBlockSet
public:
QRVersion..::..CorrectionBlockSet^ GetBlockSetByLevel(
    QRCorrectionLevel^ level
)
public:
QRVersion..::..CorrectionBlockSet^ GetBlockSetByLevel(
    QRCorrectionLevel^ level
)
member GetBlockSetByLevel :
        level : QRCorrectionLevel -> QRVersion..::..CorrectionBlockSet
member GetBlockSetByLevel :
        level : QRCorrectionLevel -> QRVersion..::..CorrectionBlockSet

Parameters

level
Type: NFX.Media.TagCodes.QR QRCorrectionLevel

Return Value

Type: QRVersion CorrectionBlockSet
See Also
QRVersion Class
QRVersion Members
NFX.Media.TagCodes.QR Namespace


QRVersion.GetVersionByNumber Method

QRVersion GetVersionByNumber Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static QRVersion GetVersionByNumber(
    int number
)
public static QRVersion GetVersionByNumber(
    int number
)
Public Shared Function GetVersionByNumber (
    number As Integer
) As QRVersion
Public Shared Function GetVersionByNumber (
    number As Integer
) As QRVersion
public:
static QRVersion^ GetVersionByNumber(
    int number
)
public:
static QRVersion^ GetVersionByNumber(
    int number
)
static member GetVersionByNumber :
        number : int -> QRVersion
static member GetVersionByNumber :
        number : int -> QRVersion

Parameters

number
Type: Online System Int32

Return Value

Type: QRVersion
See Also
QRVersion Class
QRVersion Members
NFX.Media.TagCodes.QR Namespace


QRVersion.ToString Method

QRVersion ToString Method NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
QRVersion Class
QRVersion Members
NFX.Media.TagCodes.QR Namespace


QRVersion.CorrectionBlock Class

QRVersion CorrectionBlock Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Media.TagCodes.QR QRVersion CorrectionBlock

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class CorrectionBlock
public sealed class CorrectionBlock
Public NotInheritable Class CorrectionBlock
Public NotInheritable Class CorrectionBlock
public ref class CorrectionBlock sealed
public ref class CorrectionBlock sealed
[<SealedAttribute>]
type CorrectionBlock =  class end
[<SealedAttribute>]
type CorrectionBlock =  class end
See Also
QRVersion CorrectionBlock Members
NFX.Media.TagCodes.QR Namespace


QRVersion.CorrectionBlock Members

QRVersion CorrectionBlock Members NFX Class Library

The QRVersion CorrectionBlock type exposes the following members.
Constructors
 | Name | Description
Public method | QRVersion CorrectionBlock | Initializes a new instance of the QRVersion CorrectionBlock class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Codewords |
Public field | Qty |
Back to Top
See Also
QRVersion CorrectionBlock Class
NFX.Media.TagCodes.QR Namespace


QRVersion.CorrectionBlock Constructor

QRVersion CorrectionBlock Constructor NFX Class Library

Initializes a new instance of the QRVersion CorrectionBlock class

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CorrectionBlock(
    int qty,
    int codewords
)
public CorrectionBlock(
    int qty,
    int codewords
)
Public Sub New (
    qty As Integer,
    codewords As Integer
)
Public Sub New (
    qty As Integer,
    codewords As Integer
)
public:
CorrectionBlock(
    int qty,
    int codewords
)
public:
CorrectionBlock(
    int qty,
    int codewords
)
new :
        qty : int *
        codewords : int -> CorrectionBlock
new :
        qty : int *
        codewords : int -> CorrectionBlock

Parameters

qty
Type: Online System Int32
codewords
Type: Online System Int32
See Also
QRVersion CorrectionBlock Class
QRVersion CorrectionBlock Members
NFX.Media.TagCodes.QR Namespace


QRVersion.CorrectionBlock Fields

QRVersion CorrectionBlock Fields NFX Class Library

The QRVersion CorrectionBlock type exposes the following members.
Fields
 | Name | Description
Public field | Codewords |
Public field | Qty |
Back to Top
See Also
QRVersion CorrectionBlock Class
NFX.Media.TagCodes.QR Namespace


QRVersion.CorrectionBlock.Codewords Field

QRVersion CorrectionBlock Codewords Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Codewords
public readonly int Codewords
Public ReadOnly Codewords As Integer
Public ReadOnly Codewords As Integer
public:
initonly int Codewords
public:
initonly int Codewords
val Codewords: int
val Codewords: int

Field Value

Type: Online Int32
See Also
QRVersion CorrectionBlock Class
QRVersion CorrectionBlock Members
NFX.Media.TagCodes.QR Namespace


QRVersion.CorrectionBlock.Qty Field

QRVersion CorrectionBlock Qty Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Qty
public readonly int Qty
Public ReadOnly Qty As Integer
Public ReadOnly Qty As Integer
public:
initonly int Qty
public:
initonly int Qty
val Qty: int
val Qty: int

Field Value

Type: Online Int32
See Also
QRVersion CorrectionBlock Class
QRVersion CorrectionBlock Members
NFX.Media.TagCodes.QR Namespace


QRVersion.CorrectionBlock Methods

QRVersion CorrectionBlock Methods NFX Class Library

The QRVersion CorrectionBlock type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
QRVersion CorrectionBlock Class
NFX.Media.TagCodes.QR Namespace


QRVersion.CorrectionBlockSet Class

QRVersion CorrectionBlockSet Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Media.TagCodes.QR QRVersion CorrectionBlockSet

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class CorrectionBlockSet
public sealed class CorrectionBlockSet
Public NotInheritable Class CorrectionBlockSet
Public NotInheritable Class CorrectionBlockSet
public ref class CorrectionBlockSet sealed
public ref class CorrectionBlockSet sealed
[<SealedAttribute>]
type CorrectionBlockSet =  class end
[<SealedAttribute>]
type CorrectionBlockSet =  class end
See Also
QRVersion CorrectionBlockSet Members
NFX.Media.TagCodes.QR Namespace


QRVersion.CorrectionBlockSet Members

QRVersion CorrectionBlockSet Members NFX Class Library

The QRVersion CorrectionBlockSet type exposes the following members.
Constructors
 | Name | Description
Public method | QRVersion CorrectionBlockSet | Initializes a new instance of the QRVersion CorrectionBlockSet class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Blocks |
Public field | CodewordsPerBlock |
Public field | TotalCodewords |
Public field | TotalQty |
Back to Top
See Also
QRVersion CorrectionBlockSet Class
NFX.Media.TagCodes.QR Namespace


QRVersion.CorrectionBlockSet Constructor

QRVersion CorrectionBlockSet Constructor NFX Class Library

Initializes a new instance of the QRVersion CorrectionBlockSet class

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CorrectionBlockSet(
    int codewordsPerBlock,
    params QRVersion..::..CorrectionBlock[] blocks
)
public CorrectionBlockSet(
    int codewordsPerBlock,
    params QRVersion..::..CorrectionBlock[] blocks
)
Public Sub New (
    codewordsPerBlock As Integer,
    ParamArray blocks As QRVersion..::..CorrectionBlock()
)
Public Sub New (
    codewordsPerBlock As Integer,
    ParamArray blocks As QRVersion..::..CorrectionBlock()
)
public:
CorrectionBlockSet(
    int codewordsPerBlock,
    ... array<QRVersion..::..CorrectionBlock^>^ blocks
)
public:
CorrectionBlockSet(
    int codewordsPerBlock,
    ... array<QRVersion..::..CorrectionBlock^>^ blocks
)
new :
        codewordsPerBlock : int *
        blocks : QRVersion..::..CorrectionBlock[] -> CorrectionBlockSet
new :
        codewordsPerBlock : int *
        blocks : QRVersion..::..CorrectionBlock[] -> CorrectionBlockSet

Parameters

codewordsPerBlock
Type: Online System Int32
blocks
Type: NFX.Media.TagCodes.QR QRVersion CorrectionBlock
See Also
QRVersion CorrectionBlockSet Class
QRVersion CorrectionBlockSet Members
NFX.Media.TagCodes.QR Namespace


QRVersion.CorrectionBlockSet Fields

QRVersion CorrectionBlockSet Fields NFX Class Library

The QRVersion CorrectionBlockSet type exposes the following members.
Fields
 | Name | Description
Public field | Blocks |
Public field | CodewordsPerBlock |
Public field | TotalCodewords |
Public field | TotalQty |
Back to Top
See Also
QRVersion CorrectionBlockSet Class
NFX.Media.TagCodes.QR Namespace


QRVersion.CorrectionBlockSet.Blocks Field

QRVersion CorrectionBlockSet Blocks Field NFX Class Library

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly QRVersion..::..CorrectionBlock[] Blocks
public readonly QRVersion..::..CorrectionBlock[] Blocks
Public ReadOnly Blocks As QRVersion..::..CorrectionBlock()
Public ReadOnly Blocks As QRVersion..::..CorrectionBlock()
public:
initonly array<QRVersion..::..CorrectionBlock^>^ Blocks
public:
initonly array<QRVersion..::..CorrectionBlock^>^ Blocks
val Blocks: QRVersion..::..CorrectionBlock[]
val Blocks: QRVersion..::..CorrectionBlock[]

Field Value

Type: QRVersion CorrectionBlock
See Also
QRVersion CorrectionBlockSet Class
QRVersion CorrectionBlockSet Members
NFX.Media.TagCodes.QR Namespace


QRVersion.CorrectionBlockSet.CodewordsPerBlock Field

QRVersion CorrectionBlockSet CodewordsPerBlock Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int CodewordsPerBlock
public readonly int CodewordsPerBlock
Public ReadOnly CodewordsPerBlock As Integer
Public ReadOnly CodewordsPerBlock As Integer
public:
initonly int CodewordsPerBlock
public:
initonly int CodewordsPerBlock
val CodewordsPerBlock: int
val CodewordsPerBlock: int

Field Value

Type: Online Int32
See Also
QRVersion CorrectionBlockSet Class
QRVersion CorrectionBlockSet Members
NFX.Media.TagCodes.QR Namespace


QRVersion.CorrectionBlockSet.TotalCodewords Field

QRVersion CorrectionBlockSet TotalCodewords Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int TotalCodewords
public int TotalCodewords
Public TotalCodewords As Integer
Public TotalCodewords As Integer
public:
int TotalCodewords
public:
int TotalCodewords
val mutable TotalCodewords: int
val mutable TotalCodewords: int

Field Value

Type: Online Int32
See Also
QRVersion CorrectionBlockSet Class
QRVersion CorrectionBlockSet Members
NFX.Media.TagCodes.QR Namespace


QRVersion.CorrectionBlockSet.TotalQty Field

QRVersion CorrectionBlockSet TotalQty Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Media.TagCodes.QR
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int TotalQty
public int TotalQty
Public TotalQty As Integer
Public TotalQty As Integer
public:
int TotalQty
public:
int TotalQty
val mutable TotalQty: int
val mutable TotalQty: int

Field Value

Type: Online Int32
See Also
QRVersion CorrectionBlockSet Class
QRVersion CorrectionBlockSet Members
NFX.Media.TagCodes.QR Namespace


QRVersion.CorrectionBlockSet Methods

QRVersion CorrectionBlockSet Methods NFX Class Library

The QRVersion CorrectionBlockSet type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
QRVersion CorrectionBlockSet Class
NFX.Media.TagCodes.QR Namespace


NFX.OS Namespace

NFX.OS Namespace NFX Class Library

OS-related functions, like running processes and getting information about local machine
Classes
 | Class | Description
Public class | Computer | Facilitates various computer-related tasks such as CPU usage, memory utilization etc.
Public class | HostNetInfo | Provides information about IP network host
Public class | HostNetInfo NetAdapterInfo | Describes a network adapter on subordinate host
Public class | HostNetInfo NetAddrInfo | Describes an address supported by net adapter
Public class | NetworkUtils | Provides network-related utilities
Public class | ProcessRunner | Provides simple process invocation and output capture functionality
Structures
 | Structure | Description
Public structure | ManyReadersOneWriterSynchronizer | This struct is for ADVANCED SYSTEM use-cases. DEVELOPERS: do not use this in a business application code. Represents an efficient SpinWait/Yield-based lock that allows many readers to operate concurrently and only one single concurrent writer. This struct must be used ONLY with a very fast/tight operations that do not block on IO and other locks, and are expected to complete under a tenth fraction of a second. Warning: this lock CAN NOT be held for longer than 5 hrs by design. DO NOT use this lock with IO-dependent operations. This is not really a limitation as this class is used to guard operations which are very fast (fractions of a second) and should fail faster otherwise. This lock IS NOT REENTRANT!
Public structure | MemoryStatus | Provides current memory status snapshot
Enumerations
 | Enumeration | Description
Public enumeration | OSFamily | Denots primary OS Families: Win/Mac/Lin*nix


Computer Class

Computer Class NFX Class Library

Facilitates various computer-related tasks such as CPU usage, memory utilization etc.
Inheritance Hierarchy
Online System Object
NFX.OS Computer

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class Computer
public static class Computer
Public NotInheritable Class Computer
Public NotInheritable Class Computer
public ref class Computer abstract sealed
public ref class Computer abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Computer =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Computer =  class end
See Also
Computer Members
NFX.OS Namespace


Computer Members

Computer Members NFX Class Library

The Computer type exposes the following members.
Methods
Name | Description
GetMemoryStatus |
Back to Top
Properties
Name | Description
CurrentAvailableMemoryMb | Returns current computer-wide RAM availability in mbytes
CurrentProcessorUsagePct | Returns current computer-wide CPU utilization percentage
OSFamily | Rsturns OS family for this computer: Linux vs Win vs Mac
UniqueNetworkSignature | Returns network signature for this machine which is unique in the eclosing network segment (MAC-based)
Back to Top
See Also
Computer Class
NFX.OS Namespace


Computer Methods

Computer Methods NFX Class Library

The Computer type exposes the following members.
Methods
Name | Description
GetMemoryStatus |
Back to Top
See Also
Computer Class
NFX.OS Namespace


Computer.GetMemoryStatus Method

Computer GetMemoryStatus Method NFX Class Library

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static MemoryStatus GetMemoryStatus()
public static MemoryStatus GetMemoryStatus()
Public Shared Function GetMemoryStatus As MemoryStatus
Public Shared Function GetMemoryStatus As MemoryStatus
public:
static MemoryStatus GetMemoryStatus()
public:
static MemoryStatus GetMemoryStatus()
static member GetMemoryStatus : unit -> MemoryStatus
static member GetMemoryStatus : unit -> MemoryStatus

Return Value

Type: MemoryStatus
See Also
Computer Class
Computer Members
NFX.OS Namespace


Computer Properties

Computer Properties NFX Class Library

The Computer type exposes the following members.
Properties
Name | Description
CurrentAvailableMemoryMb | Returns current computer-wide RAM availability in mbytes
CurrentProcessorUsagePct | Returns current computer-wide CPU utilization percentage
OSFamily | Rsturns OS family for this computer: Linux vs Win vs Mac
UniqueNetworkSignature | Returns network signature for this machine which is unique in the eclosing network segment (MAC-based)
Back to Top
See Also
Computer Class
NFX.OS Namespace


Computer.CurrentAvailableMemoryMb Property

Computer CurrentAvailableMemoryMb Property NFX Class Library

Returns current computer-wide RAM availability in mbytes

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int CurrentAvailableMemoryMb { get; }
public static int CurrentAvailableMemoryMb { get; }
Public Shared ReadOnly Property CurrentAvailableMemoryMb As Integer
    Get
Public Shared ReadOnly Property CurrentAvailableMemoryMb As Integer
    Get
public:
static property int CurrentAvailableMemoryMb {
    int get ();
}
public:
static property int CurrentAvailableMemoryMb {
    int get ();
}
static member CurrentAvailableMemoryMb : int with get
static member CurrentAvailableMemoryMb : int with get

Property Value

Type: Online Int32
See Also
Computer Class
Computer Members
NFX.OS Namespace


Computer.CurrentProcessorUsagePct Property

Computer CurrentProcessorUsagePct Property NFX Class Library

Returns current computer-wide CPU utilization percentage

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int CurrentProcessorUsagePct { get; }
public static int CurrentProcessorUsagePct { get; }
Public Shared ReadOnly Property CurrentProcessorUsagePct As Integer
    Get
Public Shared ReadOnly Property CurrentProcessorUsagePct As Integer
    Get
public:
static property int CurrentProcessorUsagePct {
    int get ();
}
public:
static property int CurrentProcessorUsagePct {
    int get ();
}
static member CurrentProcessorUsagePct : int with get
static member CurrentProcessorUsagePct : int with get

Property Value

Type: Online Int32
See Also
Computer Class
Computer Members
NFX.OS Namespace


Computer.OSFamily Property

Computer OSFamily Property NFX Class Library

Rsturns OS family for this computer: Linux vs Win vs Mac

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static OSFamily OSFamily { get; }
public static OSFamily OSFamily { get; }
Public Shared ReadOnly Property OSFamily As OSFamily
    Get
Public Shared ReadOnly Property OSFamily As OSFamily
    Get
public:
static property OSFamily OSFamily {
    OSFamily get ();
}
public:
static property OSFamily OSFamily {
    OSFamily get ();
}
static member OSFamily : OSFamily with get
static member OSFamily : OSFamily with get

Property Value

Type: OSFamily
See Also
Computer Class
Computer Members
NFX.OS Namespace


Computer.UniqueNetworkSignature Property

Computer UniqueNetworkSignature Property NFX Class Library

Returns network signature for this machine which is unique in the eclosing network segment (MAC-based)

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string UniqueNetworkSignature { get; }
public static string UniqueNetworkSignature { get; }
Public Shared ReadOnly Property UniqueNetworkSignature As String
    Get
Public Shared ReadOnly Property UniqueNetworkSignature As String
    Get
public:
static property String^ UniqueNetworkSignature {
    String^ get ();
}
public:
static property String^ UniqueNetworkSignature {
    String^ get ();
}
static member UniqueNetworkSignature : string with get
static member UniqueNetworkSignature : string with get

Property Value

Type: Online String
See Also
Computer Class
Computer Members
NFX.OS Namespace


HostNetInfo Class

HostNetInfo Class NFX Class Library

Provides information about IP network host
Inheritance Hierarchy
Online System Object
NFX.OS HostNetInfo

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class HostNetInfo : INamed
[SerializableAttribute]
public sealed class HostNetInfo : INamed
<SerializableAttribute>
Public NotInheritable Class HostNetInfo
    Implements INamed
<SerializableAttribute>
Public NotInheritable Class HostNetInfo
    Implements INamed
[SerializableAttribute]
public ref class HostNetInfo sealed : INamed
[SerializableAttribute]
public ref class HostNetInfo sealed : INamed
[<SealedAttribute>]
[<SerializableAttribute>]
type HostNetInfo =
    class
        interface INamed
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type HostNetInfo =
    class
        interface INamed
    end
See Also
HostNetInfo Members
NFX.OS Namespace


HostNetInfo Members

HostNetInfo Members NFX Class Library

The HostNetInfo type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | ForThisHost |
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Adapters | Network adapters on the host
Public property | DomainNameSegment | Domain name segment of Name
Public property | HostNameSegment | Host name segment of Name
Public property | Name | Full host name including domain
Back to Top
See Also
HostNetInfo Class
NFX.OS Namespace


HostNetInfo Methods

HostNetInfo Methods NFX Class Library

The HostNetInfo type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | ForThisHost |
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
HostNetInfo Class
NFX.OS Namespace


HostNetInfo.Equals Method

HostNetInfo Equals Method NFX Class Library

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
HostNetInfo Class
HostNetInfo Members
NFX.OS Namespace


HostNetInfo.ForThisHost Method

HostNetInfo ForThisHost Method NFX Class Library

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static HostNetInfo ForThisHost()
public static HostNetInfo ForThisHost()
Public Shared Function ForThisHost As HostNetInfo
Public Shared Function ForThisHost As HostNetInfo
public:
static HostNetInfo^ ForThisHost()
public:
static HostNetInfo^ ForThisHost()
static member ForThisHost : unit -> HostNetInfo
static member ForThisHost : unit -> HostNetInfo

Return Value

Type: HostNetInfo
See Also
HostNetInfo Class
HostNetInfo Members
NFX.OS Namespace


HostNetInfo.GetHashCode Method

HostNetInfo GetHashCode Method NFX Class Library

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
HostNetInfo Class
HostNetInfo Members
NFX.OS Namespace


HostNetInfo.ToString Method

HostNetInfo ToString Method NFX Class Library

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
HostNetInfo Class
HostNetInfo Members
NFX.OS Namespace


HostNetInfo Properties

HostNetInfo Properties NFX Class Library

The HostNetInfo type exposes the following members.
Properties
 | Name | Description
Public property | Adapters | Network adapters on the host
Public property | DomainNameSegment | Domain name segment of Name
Public property | HostNameSegment | Host name segment of Name
Public property | Name | Full host name including domain
Back to Top
See Also
HostNetInfo Class
NFX.OS Namespace


HostNetInfo.Adapters Property

HostNetInfo Adapters Property NFX Class Library

Network adapters on the host

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<HostNetInfo..::..NetAdapterInfo> Adapters { get; }
public IRegistry<HostNetInfo..::..NetAdapterInfo> Adapters { get; }
Public ReadOnly Property Adapters As IRegistry(Of HostNetInfo..::..NetAdapterInfo)
    Get
Public ReadOnly Property Adapters As IRegistry(Of HostNetInfo..::..NetAdapterInfo)
    Get
public:
property IRegistry<HostNetInfo..::..NetAdapterInfo^>^ Adapters {
    IRegistry<HostNetInfo..::..NetAdapterInfo^>^ get ();
}
public:
property IRegistry<HostNetInfo..::..NetAdapterInfo^>^ Adapters {
    IRegistry<HostNetInfo..::..NetAdapterInfo^>^ get ();
}
member Adapters : IRegistry<HostNetInfo..::..NetAdapterInfo> with get
member Adapters : IRegistry<HostNetInfo..::..NetAdapterInfo> with get

Property Value

Type: IRegistry HostNetInfo NetAdapterInfo
See Also
HostNetInfo Class
HostNetInfo Members
NFX.OS Namespace


HostNetInfo.DomainNameSegment Property

HostNetInfo DomainNameSegment Property NFX Class Library

Domain name segment of Name

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DomainNameSegment { get; }
public string DomainNameSegment { get; }
Public ReadOnly Property DomainNameSegment As String
    Get
Public ReadOnly Property DomainNameSegment As String
    Get
public:
property String^ DomainNameSegment {
    String^ get ();
}
public:
property String^ DomainNameSegment {
    String^ get ();
}
member DomainNameSegment : string with get
member DomainNameSegment : string with get

Property Value

Type: Online String
See Also
HostNetInfo Class
HostNetInfo Members
NFX.OS Namespace


HostNetInfo.HostNameSegment Property

HostNetInfo HostNameSegment Property NFX Class Library

Host name segment of Name

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string HostNameSegment { get; }
public string HostNameSegment { get; }
Public ReadOnly Property HostNameSegment As String
    Get
Public ReadOnly Property HostNameSegment As String
    Get
public:
property String^ HostNameSegment {
    String^ get ();
}
public:
property String^ HostNameSegment {
    String^ get ();
}
member HostNameSegment : string with get
member HostNameSegment : string with get

Property Value

Type: Online String
See Also
HostNetInfo Class
HostNetInfo Members
NFX.OS Namespace


HostNetInfo.Name Property

HostNetInfo Name Property NFX Class Library

Full host name including domain

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
HostNetInfo Class
HostNetInfo Members
NFX.OS Namespace


HostNetInfo.NetAdapterInfo Class

HostNetInfo NetAdapterInfo Class NFX Class Library

Describes a network adapter on subordinate host
Inheritance Hierarchy
Online System Object
NFX.OS HostNetInfo NetAdapterInfo

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class NetAdapterInfo : INamed,
    IOrdered
[SerializableAttribute]
public sealed class NetAdapterInfo : INamed,
    IOrdered
<SerializableAttribute>
Public NotInheritable Class NetAdapterInfo
    Implements INamed, IOrdered
<SerializableAttribute>
Public NotInheritable Class NetAdapterInfo
    Implements INamed, IOrdered
[SerializableAttribute]
public ref class NetAdapterInfo sealed : INamed,
    IOrdered
[SerializableAttribute]
public ref class NetAdapterInfo sealed : INamed,
    IOrdered
[<SealedAttribute>]
[<SerializableAttribute>]
type NetAdapterInfo =
    class
        interface INamed
        interface IOrdered
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type NetAdapterInfo =
    class
        interface INamed
        interface IOrdered
    end
See Also
HostNetInfo NetAdapterInfo Members
NFX.OS Namespace


HostNetInfo.NetAdapterInfo Members

HostNetInfo NetAdapterInfo Members NFX Class Library

The HostNetInfo NetAdapterInfo type exposes the following members.
Constructors
 | Name | Description
Protected method | HostNetInfo NetAdapterInfo | Initializes a new instance of the HostNetInfo NetAdapterInfo class
Back to Top
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | AdapterType |
Public property | Addresses |
Public property | Description |
Public property | IPV4Support |
Public property | IPV6Support |
Public property | Name |
Public property | Order |
Public property | ReceiveOnly |
Public property | Speed |
Public property | Status |
Back to Top
See Also
HostNetInfo NetAdapterInfo Class
NFX.OS Namespace


HostNetInfo.NetAdapterInfo Constructor

HostNetInfo NetAdapterInfo Constructor NFX Class Library

Initializes a new instance of the HostNetInfo NetAdapterInfo class

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal NetAdapterInfo(
    NetworkInterface nic,
    int order
)
internal NetAdapterInfo(
    NetworkInterface nic,
    int order
)
Friend Sub New (
    nic As NetworkInterface,
    order As Integer
)
Friend Sub New (
    nic As NetworkInterface,
    order As Integer
)
internal:
NetAdapterInfo(
    NetworkInterface^ nic,
    int order
)
internal:
NetAdapterInfo(
    NetworkInterface^ nic,
    int order
)
new :
        nic : NetworkInterface *
        order : int -> NetAdapterInfo
new :
        nic : NetworkInterface *
        order : int -> NetAdapterInfo

Parameters

nic
Type: Online System.Net.NetworkInformation NetworkInterface
order
Type: Online System Int32
See Also
HostNetInfo NetAdapterInfo Class
HostNetInfo NetAdapterInfo Members
NFX.OS Namespace


HostNetInfo.NetAdapterInfo Methods

HostNetInfo NetAdapterInfo Methods NFX Class Library

The HostNetInfo NetAdapterInfo type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
HostNetInfo NetAdapterInfo Class
NFX.OS Namespace


HostNetInfo.NetAdapterInfo.Equals Method

HostNetInfo NetAdapterInfo Equals Method NFX Class Library

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
HostNetInfo NetAdapterInfo Class
HostNetInfo NetAdapterInfo Members
NFX.OS Namespace


HostNetInfo.NetAdapterInfo.GetHashCode Method

HostNetInfo NetAdapterInfo GetHashCode Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
HostNetInfo NetAdapterInfo Class
HostNetInfo NetAdapterInfo Members
NFX.OS Namespace


HostNetInfo.NetAdapterInfo.ToString Method

HostNetInfo NetAdapterInfo ToString Method NFX Class Library

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
HostNetInfo NetAdapterInfo Class
HostNetInfo NetAdapterInfo Members
NFX.OS Namespace


HostNetInfo.NetAdapterInfo Properties

HostNetInfo NetAdapterInfo Properties NFX Class Library

The HostNetInfo NetAdapterInfo type exposes the following members.
Properties
 | Name | Description
Public property | AdapterType |
Public property | Addresses |
Public property | Description |
Public property | IPV4Support |
Public property | IPV6Support |
Public property | Name |
Public property | Order |
Public property | ReceiveOnly |
Public property | Speed |
Public property | Status |
Back to Top
See Also
HostNetInfo NetAdapterInfo Class
NFX.OS Namespace


HostNetInfo.NetAdapterInfo.AdapterType Property

HostNetInfo NetAdapterInfo AdapterType Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AdapterType { get; }
public string AdapterType { get; }
Public ReadOnly Property AdapterType As String
    Get
Public ReadOnly Property AdapterType As String
    Get
public:
property String^ AdapterType {
    String^ get ();
}
public:
property String^ AdapterType {
    String^ get ();
}
member AdapterType : string with get
member AdapterType : string with get

Property Value

Type: Online String
See Also
HostNetInfo NetAdapterInfo Class
HostNetInfo NetAdapterInfo Members
NFX.OS Namespace


HostNetInfo.NetAdapterInfo.Addresses Property

HostNetInfo NetAdapterInfo Addresses Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<HostNetInfo..::..NetAddrInfo> Addresses { get; }
public IRegistry<HostNetInfo..::..NetAddrInfo> Addresses { get; }
Public ReadOnly Property Addresses As IRegistry(Of HostNetInfo..::..NetAddrInfo)
    Get
Public ReadOnly Property Addresses As IRegistry(Of HostNetInfo..::..NetAddrInfo)
    Get
public:
property IRegistry<HostNetInfo..::..NetAddrInfo^>^ Addresses {
    IRegistry<HostNetInfo..::..NetAddrInfo^>^ get ();
}
public:
property IRegistry<HostNetInfo..::..NetAddrInfo^>^ Addresses {
    IRegistry<HostNetInfo..::..NetAddrInfo^>^ get ();
}
member Addresses : IRegistry<HostNetInfo..::..NetAddrInfo> with get
member Addresses : IRegistry<HostNetInfo..::..NetAddrInfo> with get

Property Value

Type: IRegistry HostNetInfo NetAddrInfo
See Also
HostNetInfo NetAdapterInfo Class
HostNetInfo NetAdapterInfo Members
NFX.OS Namespace


HostNetInfo.NetAdapterInfo.Description Property

HostNetInfo NetAdapterInfo Description Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Description { get; }
public string Description { get; }
Public ReadOnly Property Description As String
    Get
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
public:
property String^ Description {
    String^ get ();
}
member Description : string with get
member Description : string with get

Property Value

Type: Online String
See Also
HostNetInfo NetAdapterInfo Class
HostNetInfo NetAdapterInfo Members
NFX.OS Namespace


HostNetInfo.NetAdapterInfo.IPV4Support Property

HostNetInfo NetAdapterInfo IPV4Support Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IPV4Support { get; }
public bool IPV4Support { get; }
Public ReadOnly Property IPV4Support As Boolean
    Get
Public ReadOnly Property IPV4Support As Boolean
    Get
public:
property bool IPV4Support {
    bool get ();
}
public:
property bool IPV4Support {
    bool get ();
}
member IPV4Support : bool with get
member IPV4Support : bool with get

Property Value

Type: Online Boolean
See Also
HostNetInfo NetAdapterInfo Class
HostNetInfo NetAdapterInfo Members
NFX.OS Namespace


HostNetInfo.NetAdapterInfo.IPV6Support Property

HostNetInfo NetAdapterInfo IPV6Support Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IPV6Support { get; }
public bool IPV6Support { get; }
Public ReadOnly Property IPV6Support As Boolean
    Get
Public ReadOnly Property IPV6Support As Boolean
    Get
public:
property bool IPV6Support {
    bool get ();
}
public:
property bool IPV6Support {
    bool get ();
}
member IPV6Support : bool with get
member IPV6Support : bool with get

Property Value

Type: Online Boolean
See Also
HostNetInfo NetAdapterInfo Class
HostNetInfo NetAdapterInfo Members
NFX.OS Namespace


HostNetInfo.NetAdapterInfo.Name Property

HostNetInfo NetAdapterInfo Name Property NFX Class Library

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
HostNetInfo NetAdapterInfo Class
HostNetInfo NetAdapterInfo Members
NFX.OS Namespace


HostNetInfo.NetAdapterInfo.Order Property

HostNetInfo NetAdapterInfo Order Property NFX Class Library

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Order { get; }
public int Order { get; }
Public ReadOnly Property Order As Integer
    Get
Public ReadOnly Property Order As Integer
    Get
public:
virtual property int Order {
    int get () sealed;
}
public:
virtual property int Order {
    int get () sealed;
}
abstract Order : int with get
override Order : int with get
abstract Order : int with get
override Order : int with get

Property Value

Type: Online Int32

Implements

IOrdered Order
See Also
HostNetInfo NetAdapterInfo Class
HostNetInfo NetAdapterInfo Members
NFX.OS Namespace


HostNetInfo.NetAdapterInfo.ReceiveOnly Property

HostNetInfo NetAdapterInfo ReceiveOnly Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ReceiveOnly { get; }
public bool ReceiveOnly { get; }
Public ReadOnly Property ReceiveOnly As Boolean
    Get
Public ReadOnly Property ReceiveOnly As Boolean
    Get
public:
property bool ReceiveOnly {
    bool get ();
}
public:
property bool ReceiveOnly {
    bool get ();
}
member ReceiveOnly : bool with get
member ReceiveOnly : bool with get

Property Value

Type: Online Boolean
See Also
HostNetInfo NetAdapterInfo Class
HostNetInfo NetAdapterInfo Members
NFX.OS Namespace


HostNetInfo.NetAdapterInfo.Speed Property

HostNetInfo NetAdapterInfo Speed Property NFX Class Library

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long Speed { get; }
public long Speed { get; }
Public ReadOnly Property Speed As Long
    Get
Public ReadOnly Property Speed As Long
    Get
public:
property long long Speed {
    long long get ();
}
public:
property long long Speed {
    long long get ();
}
member Speed : int64 with get
member Speed : int64 with get

Property Value

Type: Online Int64
See Also
HostNetInfo NetAdapterInfo Class
HostNetInfo NetAdapterInfo Members
NFX.OS Namespace


HostNetInfo.NetAdapterInfo.Status Property

HostNetInfo NetAdapterInfo Status Property NFX Class Library

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Status { get; }
public string Status { get; }
Public ReadOnly Property Status As String
    Get
Public ReadOnly Property Status As String
    Get
public:
property String^ Status {
    String^ get ();
}
public:
property String^ Status {
    String^ get ();
}
member Status : string with get
member Status : string with get

Property Value

Type: Online String
See Also
HostNetInfo NetAdapterInfo Class
HostNetInfo NetAdapterInfo Members
NFX.OS Namespace


HostNetInfo.NetAddrInfo Class

HostNetInfo NetAddrInfo Class NFX Class Library

Describes an address supported by net adapter
Inheritance Hierarchy
Online System Object
NFX.OS HostNetInfo NetAddrInfo

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class NetAddrInfo : INamed,
    IOrdered
[SerializableAttribute]
public sealed class NetAddrInfo : INamed,
    IOrdered
<SerializableAttribute>
Public NotInheritable Class NetAddrInfo
    Implements INamed, IOrdered
<SerializableAttribute>
Public NotInheritable Class NetAddrInfo
    Implements INamed, IOrdered
[SerializableAttribute]
public ref class NetAddrInfo sealed : INamed,
    IOrdered
[SerializableAttribute]
public ref class NetAddrInfo sealed : INamed,
    IOrdered
[<SealedAttribute>]
[<SerializableAttribute>]
type NetAddrInfo =
    class
        interface INamed
        interface IOrdered
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type NetAddrInfo =
    class
        interface INamed
        interface IOrdered
    end
See Also
HostNetInfo NetAddrInfo Members
NFX.OS Namespace


HostNetInfo.NetAddrInfo Members

HostNetInfo NetAddrInfo Members NFX Class Library

The HostNetInfo NetAddrInfo type exposes the following members.
Constructors
 | Name | Description
Protected method | HostNetInfo NetAddrInfo | Initializes a new instance of the HostNetInfo NetAddrInfo class
Back to Top
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Bytes |
Public property | Family |
Public property | IPv4 |
Public property | IPv6 |
Public property | Name |
Public property | Order |
Public property | Transient |
Public property | Unicast |
Public property | UnicastDHCPLeaseLifetimeSec |
Public property | UnicastIPv4Mask |
Public property | UnicastPreferredLifetimeSec |
Public property | UnicastValidLifetimeSec |
Back to Top
See Also
HostNetInfo NetAddrInfo Class
NFX.OS Namespace


HostNetInfo.NetAddrInfo Constructor

HostNetInfo NetAddrInfo Constructor NFX Class Library

Initializes a new instance of the HostNetInfo NetAddrInfo class

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal NetAddrInfo(
    IPAddressInformation addr,
    int ord
)
internal NetAddrInfo(
    IPAddressInformation addr,
    int ord
)
Friend Sub New (
    addr As IPAddressInformation,
    ord As Integer
)
Friend Sub New (
    addr As IPAddressInformation,
    ord As Integer
)
internal:
NetAddrInfo(
    IPAddressInformation^ addr,
    int ord
)
internal:
NetAddrInfo(
    IPAddressInformation^ addr,
    int ord
)
new :
        addr : IPAddressInformation *
        ord : int -> NetAddrInfo
new :
        addr : IPAddressInformation *
        ord : int -> NetAddrInfo

Parameters

addr
Type: Online System.Net.NetworkInformation IPAddressInformation
ord
Type: Online System Int32
See Also
HostNetInfo NetAddrInfo Class
HostNetInfo NetAddrInfo Members
NFX.OS Namespace


HostNetInfo.NetAddrInfo Methods

HostNetInfo NetAddrInfo Methods NFX Class Library

The HostNetInfo NetAddrInfo type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
HostNetInfo NetAddrInfo Class
NFX.OS Namespace


HostNetInfo.NetAddrInfo.Equals Method

HostNetInfo NetAddrInfo Equals Method NFX Class Library

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
HostNetInfo NetAddrInfo Class
HostNetInfo NetAddrInfo Members
NFX.OS Namespace


HostNetInfo.NetAddrInfo.GetHashCode Method

HostNetInfo NetAddrInfo GetHashCode Method NFX Class Library

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
HostNetInfo NetAddrInfo Class
HostNetInfo NetAddrInfo Members
NFX.OS Namespace


HostNetInfo.NetAddrInfo.ToString Method

HostNetInfo NetAddrInfo ToString Method NFX Class Library

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
HostNetInfo NetAddrInfo Class
HostNetInfo NetAddrInfo Members
NFX.OS Namespace


HostNetInfo.NetAddrInfo Properties

HostNetInfo NetAddrInfo Properties NFX Class Library

The HostNetInfo NetAddrInfo type exposes the following members.
Properties
 | Name | Description
Public property | Bytes |
Public property | Family |
Public property | IPv4 |
Public property | IPv6 |
Public property | Name |
Public property | Order |
Public property | Transient |
Public property | Unicast |
Public property | UnicastDHCPLeaseLifetimeSec |
Public property | UnicastIPv4Mask |
Public property | UnicastPreferredLifetimeSec |
Public property | UnicastValidLifetimeSec |
Back to Top
See Also
HostNetInfo NetAddrInfo Class
NFX.OS Namespace


HostNetInfo.NetAddrInfo.Bytes Property

HostNetInfo NetAddrInfo Bytes Property NFX Class Library

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] Bytes { get; }
public byte[] Bytes { get; }
Public ReadOnly Property Bytes As Byte()
    Get
Public ReadOnly Property Bytes As Byte()
    Get
public:
property array<unsigned char>^ Bytes {
    array<unsigned char>^ get ();
}
public:
property array<unsigned char>^ Bytes {
    array<unsigned char>^ get ();
}
member Bytes : byte[] with get
member Bytes : byte[] with get

Property Value

Type: Online Byte
See Also
HostNetInfo NetAddrInfo Class
HostNetInfo NetAddrInfo Members
NFX.OS Namespace


HostNetInfo.NetAddrInfo.Family Property

HostNetInfo NetAddrInfo Family Property NFX Class Library

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Family { get; }
public string Family { get; }
Public ReadOnly Property Family As String
    Get
Public ReadOnly Property Family As String
    Get
public:
property String^ Family {
    String^ get ();
}
public:
property String^ Family {
    String^ get ();
}
member Family : string with get
member Family : string with get

Property Value

Type: Online String
See Also
HostNetInfo NetAddrInfo Class
HostNetInfo NetAddrInfo Members
NFX.OS Namespace


HostNetInfo.NetAddrInfo.IPv4 Property

HostNetInfo NetAddrInfo IPv4 Property NFX Class Library

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IPv4 { get; }
public bool IPv4 { get; }
Public ReadOnly Property IPv4 As Boolean
    Get
Public ReadOnly Property IPv4 As Boolean
    Get
public:
property bool IPv4 {
    bool get ();
}
public:
property bool IPv4 {
    bool get ();
}
member IPv4 : bool with get
member IPv4 : bool with get

Property Value

Type: Online Boolean
See Also
HostNetInfo NetAddrInfo Class
HostNetInfo NetAddrInfo Members
NFX.OS Namespace


HostNetInfo.NetAddrInfo.IPv6 Property

HostNetInfo NetAddrInfo IPv6 Property NFX Class Library

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IPv6 { get; }
public bool IPv6 { get; }
Public ReadOnly Property IPv6 As Boolean
    Get
Public ReadOnly Property IPv6 As Boolean
    Get
public:
property bool IPv6 {
    bool get ();
}
public:
property bool IPv6 {
    bool get ();
}
member IPv6 : bool with get
member IPv6 : bool with get

Property Value

Type: Online Boolean
See Also
HostNetInfo NetAddrInfo Class
HostNetInfo NetAddrInfo Members
NFX.OS Namespace


HostNetInfo.NetAddrInfo.Name Property

HostNetInfo NetAddrInfo Name Property NFX Class Library

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
HostNetInfo NetAddrInfo Class
HostNetInfo NetAddrInfo Members
NFX.OS Namespace


HostNetInfo.NetAddrInfo.Order Property

HostNetInfo NetAddrInfo Order Property NFX Class Library

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Order { get; }
public int Order { get; }
Public ReadOnly Property Order As Integer
    Get
Public ReadOnly Property Order As Integer
    Get
public:
virtual property int Order {
    int get () sealed;
}
public:
virtual property int Order {
    int get () sealed;
}
abstract Order : int with get
override Order : int with get
abstract Order : int with get
override Order : int with get

Property Value

Type: Online Int32

Implements

IOrdered Order
See Also
HostNetInfo NetAddrInfo Class
HostNetInfo NetAddrInfo Members
NFX.OS Namespace


HostNetInfo.NetAddrInfo.Transient Property

HostNetInfo NetAddrInfo Transient Property NFX Class Library

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Transient { get; }
public bool Transient { get; }
Public ReadOnly Property Transient As Boolean
    Get
Public ReadOnly Property Transient As Boolean
    Get
public:
property bool Transient {
    bool get ();
}
public:
property bool Transient {
    bool get ();
}
member Transient : bool with get
member Transient : bool with get

Property Value

Type: Online Boolean
See Also
HostNetInfo NetAddrInfo Class
HostNetInfo NetAddrInfo Members
NFX.OS Namespace


HostNetInfo.NetAddrInfo.Unicast Property

HostNetInfo NetAddrInfo Unicast Property NFX Class Library

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Unicast { get; }
public bool Unicast { get; }
Public ReadOnly Property Unicast As Boolean
    Get
Public ReadOnly Property Unicast As Boolean
    Get
public:
property bool Unicast {
    bool get ();
}
public:
property bool Unicast {
    bool get ();
}
member Unicast : bool with get
member Unicast : bool with get

Property Value

Type: Online Boolean
See Also
HostNetInfo NetAddrInfo Class
HostNetInfo NetAddrInfo Members
NFX.OS Namespace


HostNetInfo.NetAddrInfo.UnicastDHCPLeaseLifetimeSec Property

HostNetInfo NetAddrInfo UnicastDHCPLeaseLifetimeSec Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long UnicastDHCPLeaseLifetimeSec { get; }
public long UnicastDHCPLeaseLifetimeSec { get; }
Public ReadOnly Property UnicastDHCPLeaseLifetimeSec As Long
    Get
Public ReadOnly Property UnicastDHCPLeaseLifetimeSec As Long
    Get
public:
property long long UnicastDHCPLeaseLifetimeSec {
    long long get ();
}
public:
property long long UnicastDHCPLeaseLifetimeSec {
    long long get ();
}
member UnicastDHCPLeaseLifetimeSec : int64 with get
member UnicastDHCPLeaseLifetimeSec : int64 with get

Property Value

Type: Online Int64
See Also
HostNetInfo NetAddrInfo Class
HostNetInfo NetAddrInfo Members
NFX.OS Namespace


HostNetInfo.NetAddrInfo.UnicastIPv4Mask Property

HostNetInfo NetAddrInfo UnicastIPv4Mask Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] UnicastIPv4Mask { get; }
public byte[] UnicastIPv4Mask { get; }
Public ReadOnly Property UnicastIPv4Mask As Byte()
    Get
Public ReadOnly Property UnicastIPv4Mask As Byte()
    Get
public:
property array<unsigned char>^ UnicastIPv4Mask {
    array<unsigned char>^ get ();
}
public:
property array<unsigned char>^ UnicastIPv4Mask {
    array<unsigned char>^ get ();
}
member UnicastIPv4Mask : byte[] with get
member UnicastIPv4Mask : byte[] with get

Property Value

Type: Online Byte
See Also
HostNetInfo NetAddrInfo Class
HostNetInfo NetAddrInfo Members
NFX.OS Namespace


HostNetInfo.NetAddrInfo.UnicastPreferredLifetimeSec Property

HostNetInfo NetAddrInfo UnicastPreferredLifetimeSec Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long UnicastPreferredLifetimeSec { get; }
public long UnicastPreferredLifetimeSec { get; }
Public ReadOnly Property UnicastPreferredLifetimeSec As Long
    Get
Public ReadOnly Property UnicastPreferredLifetimeSec As Long
    Get
public:
property long long UnicastPreferredLifetimeSec {
    long long get ();
}
public:
property long long UnicastPreferredLifetimeSec {
    long long get ();
}
member UnicastPreferredLifetimeSec : int64 with get
member UnicastPreferredLifetimeSec : int64 with get

Property Value

Type: Online Int64
See Also
HostNetInfo NetAddrInfo Class
HostNetInfo NetAddrInfo Members
NFX.OS Namespace


HostNetInfo.NetAddrInfo.UnicastValidLifetimeSec Property

HostNetInfo NetAddrInfo UnicastValidLifetimeSec Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long UnicastValidLifetimeSec { get; }
public long UnicastValidLifetimeSec { get; }
Public ReadOnly Property UnicastValidLifetimeSec As Long
    Get
Public ReadOnly Property UnicastValidLifetimeSec As Long
    Get
public:
property long long UnicastValidLifetimeSec {
    long long get ();
}
public:
property long long UnicastValidLifetimeSec {
    long long get ();
}
member UnicastValidLifetimeSec : int64 with get
member UnicastValidLifetimeSec : int64 with get

Property Value

Type: Online Int64
See Also
HostNetInfo NetAddrInfo Class
HostNetInfo NetAddrInfo Members
NFX.OS Namespace


ManyReadersOneWriterSynchronizer Structure

ManyReadersOneWriterSynchronizer Structure NFX Class Library

This struct is for ADVANCED SYSTEM use-cases. DEVELOPERS: do not use this in a business application code. Represents an efficient SpinWait/Yield-based lock that allows many readers to operate concurrently and only one single concurrent writer. This struct must be used ONLY with a very fast/tight operations that do not block on IO and other locks, and are expected to complete under a tenth fraction of a second. Warning: this lock CAN NOT be held for longer than 5 hrs by design. DO NOT use this lock with IO-dependent operations. This is not really a limitation as this class is used to guard operations which are very fast (fractions of a second) and should fail faster otherwise. This lock IS NOT REENTRANT!

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct ManyReadersOneWriterSynchronizer
public struct ManyReadersOneWriterSynchronizer
Public Structure ManyReadersOneWriterSynchronizer
Public Structure ManyReadersOneWriterSynchronizer
public value class ManyReadersOneWriterSynchronizer
public value class ManyReadersOneWriterSynchronizer
[<SealedAttribute>]
type ManyReadersOneWriterSynchronizer =  struct end
[<SealedAttribute>]
type ManyReadersOneWriterSynchronizer =  struct end
See Also
ManyReadersOneWriterSynchronizer Members
NFX.OS Namespace


ManyReadersOneWriterSynchronizer Members

ManyReadersOneWriterSynchronizer Members NFX Class Library

The ManyReadersOneWriterSynchronizer type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | GetReadLock | Obtains a read lock returning true on success. Many threads may obtain a read lock at the same time, however a single write lock excludes any read locks, corollary any single read lock held excludes anyone obtaining a write lock. False is returned if cancel func was supplied and returned true to cancel-out the waiting
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetWriteLock | Obtains a write lock returning true on success. Only one thread may hold a write lock at a time, and noone else can obtain a read lock until the write lock is released. False is returned if cancel func was supplied and returned true to cancel-out the waiting
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReleaseReadLock | Releases the read lock that was previously obtained by a call to GetReadLock()
Public method | ReleaseWriteLock | Releases the write lock that was previously obtained by a call to GetWriteLock()
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ManyReadersOneWriterSynchronizer Structure
NFX.OS Namespace


ManyReadersOneWriterSynchronizer Methods

ManyReadersOneWriterSynchronizer Methods NFX Class Library

The ManyReadersOneWriterSynchronizer type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | GetReadLock | Obtains a read lock returning true on success. Many threads may obtain a read lock at the same time, however a single write lock excludes any read locks, corollary any single read lock held excludes anyone obtaining a write lock. False is returned if cancel func was supplied and returned true to cancel-out the waiting
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetWriteLock | Obtains a write lock returning true on success. Only one thread may hold a write lock at a time, and noone else can obtain a read lock until the write lock is released. False is returned if cancel func was supplied and returned true to cancel-out the waiting
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReleaseReadLock | Releases the read lock that was previously obtained by a call to GetReadLock()
Public method | ReleaseWriteLock | Releases the write lock that was previously obtained by a call to GetWriteLock()
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ManyReadersOneWriterSynchronizer Structure
NFX.OS Namespace


ManyReadersOneWriterSynchronizer.GetReadLock Method

ManyReadersOneWriterSynchronizer GetReadLock Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Obtains a read lock returning true on success. Many threads may obtain a read lock at the same time, however a single write lock excludes any read locks, corollary any single read lock held excludes anyone obtaining a write lock. False is returned if cancel func was supplied and returned true to cancel-out the waiting

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool GetReadLock(
    Func<Object, bool> cancel = null,
    Object cancelContext = null
)
public bool GetReadLock(
    Func<Object, bool> cancel = null,
    Object cancelContext = null
)
Public Function GetReadLock (
    Optional cancel As Func(Of Object, Boolean) = Nothing,
    Optional cancelContext As Object = Nothing
) As Boolean
Public Function GetReadLock (
    Optional cancel As Func(Of Object, Boolean) = Nothing,
    Optional cancelContext As Object = Nothing
) As Boolean
public:
bool GetReadLock(
    Func<Object^, bool>^ cancel = nullptr,
    Object^ cancelContext = nullptr
)
public:
bool GetReadLock(
    Func<Object^, bool>^ cancel = nullptr,
    Object^ cancelContext = nullptr
)
member GetReadLock :
        ?cancel : Func<Object, bool> *
        ?cancelContext : Object
(* Defaults:
        let _cancel = defaultArg cancel null
        let _cancelContext = defaultArg cancelContext null
*)
-> bool
member GetReadLock :
        ?cancel : Func<Object, bool> *
        ?cancelContext : Object
(* Defaults:
        let _cancel = defaultArg cancel null
        let _cancelContext = defaultArg cancelContext null
*)
-> bool

Parameters

cancel (Optional)
Type: Online System Func Online Object, Online Boolean
cancelContext (Optional)
Type: Online System Object

Return Value

Type: Online Boolean
See Also
ManyReadersOneWriterSynchronizer Structure
ManyReadersOneWriterSynchronizer Members
NFX.OS Namespace


ManyReadersOneWriterSynchronizer.GetWriteLock Method

ManyReadersOneWriterSynchronizer GetWriteLock Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Obtains a write lock returning true on success. Only one thread may hold a write lock at a time, and noone else can obtain a read lock until the write lock is released. False is returned if cancel func was supplied and returned true to cancel-out the waiting

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool GetWriteLock(
    Func<Object, bool> cancel = null,
    Object cancelContext = null
)
public bool GetWriteLock(
    Func<Object, bool> cancel = null,
    Object cancelContext = null
)
Public Function GetWriteLock (
    Optional cancel As Func(Of Object, Boolean) = Nothing,
    Optional cancelContext As Object = Nothing
) As Boolean
Public Function GetWriteLock (
    Optional cancel As Func(Of Object, Boolean) = Nothing,
    Optional cancelContext As Object = Nothing
) As Boolean
public:
bool GetWriteLock(
    Func<Object^, bool>^ cancel = nullptr,
    Object^ cancelContext = nullptr
)
public:
bool GetWriteLock(
    Func<Object^, bool>^ cancel = nullptr,
    Object^ cancelContext = nullptr
)
member GetWriteLock :
        ?cancel : Func<Object, bool> *
        ?cancelContext : Object
(* Defaults:
        let _cancel = defaultArg cancel null
        let _cancelContext = defaultArg cancelContext null
*)
-> bool
member GetWriteLock :
        ?cancel : Func<Object, bool> *
        ?cancelContext : Object
(* Defaults:
        let _cancel = defaultArg cancel null
        let _cancelContext = defaultArg cancelContext null
*)
-> bool

Parameters

cancel (Optional)
Type: Online System Func Online Object, Online Boolean
cancelContext (Optional)
Type: Online System Object

Return Value

Type: Online Boolean
See Also
ManyReadersOneWriterSynchronizer Structure
ManyReadersOneWriterSynchronizer Members
NFX.OS Namespace


ManyReadersOneWriterSynchronizer.ReleaseReadLock Method

ManyReadersOneWriterSynchronizer ReleaseReadLock Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Releases the read lock that was previously obtained by a call to GetReadLock()

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ReleaseReadLock()
public void ReleaseReadLock()
Public Sub ReleaseReadLock
Public Sub ReleaseReadLock
public:
void ReleaseReadLock()
public:
void ReleaseReadLock()
member ReleaseReadLock : unit -> unit
member ReleaseReadLock : unit -> unit
See Also
ManyReadersOneWriterSynchronizer Structure
ManyReadersOneWriterSynchronizer Members
NFX.OS Namespace


ManyReadersOneWriterSynchronizer.ReleaseWriteLock Method

ManyReadersOneWriterSynchronizer ReleaseWriteLock Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Releases the write lock that was previously obtained by a call to GetWriteLock()

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ReleaseWriteLock()
public void ReleaseWriteLock()
Public Sub ReleaseWriteLock
Public Sub ReleaseWriteLock
public:
void ReleaseWriteLock()
public:
void ReleaseWriteLock()
member ReleaseWriteLock : unit -> unit
member ReleaseWriteLock : unit -> unit
See Also
ManyReadersOneWriterSynchronizer Structure
ManyReadersOneWriterSynchronizer Members
NFX.OS Namespace


MemoryStatus Structure

MemoryStatus Structure NFX Class Library

Provides current memory status snapshot

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public struct MemoryStatus
[SerializableAttribute]
public struct MemoryStatus
<SerializableAttribute>
Public Structure MemoryStatus
<SerializableAttribute>
Public Structure MemoryStatus
[SerializableAttribute]
public value class MemoryStatus
[SerializableAttribute]
public value class MemoryStatus
[<SealedAttribute>]
[<SerializableAttribute>]
type MemoryStatus =  struct end
[<SealedAttribute>]
[<SerializableAttribute>]
type MemoryStatus =  struct end
See Also
MemoryStatus Members
NFX.OS Namespace


MemoryStatus Members

MemoryStatus Members NFX Class Library

The MemoryStatus type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | AvailablePageFileBytes |
Public property | AvailablePhysicalBytes |
Public property | AvailableVirtBytes |
Public property | LoadPct |
Public property | TotalPageFileBytes |
Public property | TotalPhysicalBytes |
Public property | TotalVirtBytes |
Back to Top
See Also
MemoryStatus Structure
NFX.OS Namespace


MemoryStatus Methods

MemoryStatus Methods NFX Class Library

The MemoryStatus type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MemoryStatus Structure
NFX.OS Namespace


MemoryStatus Properties

MemoryStatus Properties NFX Class Library

The MemoryStatus type exposes the following members.
Properties
 | Name | Description
Public property | AvailablePageFileBytes |
Public property | AvailablePhysicalBytes |
Public property | AvailableVirtBytes |
Public property | LoadPct |
Public property | TotalPageFileBytes |
Public property | TotalPhysicalBytes |
Public property | TotalVirtBytes |
Back to Top
See Also
MemoryStatus Structure
NFX.OS Namespace


MemoryStatus.AvailablePageFileBytes Property

MemoryStatus AvailablePageFileBytes Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong AvailablePageFileBytes { get; internal set; }
public ulong AvailablePageFileBytes { get; internal set; }
Public Property AvailablePageFileBytes As ULong
    Get
    Friend Set
Public Property AvailablePageFileBytes As ULong
    Get
    Friend Set
public:
property unsigned long long AvailablePageFileBytes {
    unsigned long long get ();
    internal: void set (unsigned long long value);
}
public:
property unsigned long long AvailablePageFileBytes {
    unsigned long long get ();
    internal: void set (unsigned long long value);
}
member AvailablePageFileBytes : uint64 with get, internal set
member AvailablePageFileBytes : uint64 with get, internal set

Property Value

Type: Online UInt64
See Also
MemoryStatus Structure
MemoryStatus Members
NFX.OS Namespace


MemoryStatus.AvailablePhysicalBytes Property

MemoryStatus AvailablePhysicalBytes Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong AvailablePhysicalBytes { get; internal set; }
public ulong AvailablePhysicalBytes { get; internal set; }
Public Property AvailablePhysicalBytes As ULong
    Get
    Friend Set
Public Property AvailablePhysicalBytes As ULong
    Get
    Friend Set
public:
property unsigned long long AvailablePhysicalBytes {
    unsigned long long get ();
    internal: void set (unsigned long long value);
}
public:
property unsigned long long AvailablePhysicalBytes {
    unsigned long long get ();
    internal: void set (unsigned long long value);
}
member AvailablePhysicalBytes : uint64 with get, internal set
member AvailablePhysicalBytes : uint64 with get, internal set

Property Value

Type: Online UInt64
See Also
MemoryStatus Structure
MemoryStatus Members
NFX.OS Namespace


MemoryStatus.AvailableVirtBytes Property

MemoryStatus AvailableVirtBytes Property NFX Class Library

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong AvailableVirtBytes { get; internal set; }
public ulong AvailableVirtBytes { get; internal set; }
Public Property AvailableVirtBytes As ULong
    Get
    Friend Set
Public Property AvailableVirtBytes As ULong
    Get
    Friend Set
public:
property unsigned long long AvailableVirtBytes {
    unsigned long long get ();
    internal: void set (unsigned long long value);
}
public:
property unsigned long long AvailableVirtBytes {
    unsigned long long get ();
    internal: void set (unsigned long long value);
}
member AvailableVirtBytes : uint64 with get, internal set
member AvailableVirtBytes : uint64 with get, internal set

Property Value

Type: Online UInt64
See Also
MemoryStatus Structure
MemoryStatus Members
NFX.OS Namespace


MemoryStatus.LoadPct Property

MemoryStatus LoadPct Property NFX Class Library

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint LoadPct { get; internal set; }
public uint LoadPct { get; internal set; }
Public Property LoadPct As UInteger
    Get
    Friend Set
Public Property LoadPct As UInteger
    Get
    Friend Set
public:
property unsigned int LoadPct {
    unsigned int get ();
    internal: void set (unsigned int value);
}
public:
property unsigned int LoadPct {
    unsigned int get ();
    internal: void set (unsigned int value);
}
member LoadPct : uint32 with get, internal set
member LoadPct : uint32 with get, internal set

Property Value

Type: Online UInt32
See Also
MemoryStatus Structure
MemoryStatus Members
NFX.OS Namespace


MemoryStatus.TotalPageFileBytes Property

MemoryStatus TotalPageFileBytes Property NFX Class Library

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong TotalPageFileBytes { get; internal set; }
public ulong TotalPageFileBytes { get; internal set; }
Public Property TotalPageFileBytes As ULong
    Get
    Friend Set
Public Property TotalPageFileBytes As ULong
    Get
    Friend Set
public:
property unsigned long long TotalPageFileBytes {
    unsigned long long get ();
    internal: void set (unsigned long long value);
}
public:
property unsigned long long TotalPageFileBytes {
    unsigned long long get ();
    internal: void set (unsigned long long value);
}
member TotalPageFileBytes : uint64 with get, internal set
member TotalPageFileBytes : uint64 with get, internal set

Property Value

Type: Online UInt64
See Also
MemoryStatus Structure
MemoryStatus Members
NFX.OS Namespace


MemoryStatus.TotalPhysicalBytes Property

MemoryStatus TotalPhysicalBytes Property NFX Class Library

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong TotalPhysicalBytes { get; internal set; }
public ulong TotalPhysicalBytes { get; internal set; }
Public Property TotalPhysicalBytes As ULong
    Get
    Friend Set
Public Property TotalPhysicalBytes As ULong
    Get
    Friend Set
public:
property unsigned long long TotalPhysicalBytes {
    unsigned long long get ();
    internal: void set (unsigned long long value);
}
public:
property unsigned long long TotalPhysicalBytes {
    unsigned long long get ();
    internal: void set (unsigned long long value);
}
member TotalPhysicalBytes : uint64 with get, internal set
member TotalPhysicalBytes : uint64 with get, internal set

Property Value

Type: Online UInt64
See Also
MemoryStatus Structure
MemoryStatus Members
NFX.OS Namespace


MemoryStatus.TotalVirtBytes Property

MemoryStatus TotalVirtBytes Property NFX Class Library

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong TotalVirtBytes { get; internal set; }
public ulong TotalVirtBytes { get; internal set; }
Public Property TotalVirtBytes As ULong
    Get
    Friend Set
Public Property TotalVirtBytes As ULong
    Get
    Friend Set
public:
property unsigned long long TotalVirtBytes {
    unsigned long long get ();
    internal: void set (unsigned long long value);
}
public:
property unsigned long long TotalVirtBytes {
    unsigned long long get ();
    internal: void set (unsigned long long value);
}
member TotalVirtBytes : uint64 with get, internal set
member TotalVirtBytes : uint64 with get, internal set

Property Value

Type: Online UInt64
See Also
MemoryStatus Structure
MemoryStatus Members
NFX.OS Namespace


NetworkUtils Class

NetworkUtils Class NFX Class Library

Provides network-related utilities
Inheritance Hierarchy
Online System Object
NFX.OS NetworkUtils

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class NetworkUtils
public static class NetworkUtils
Public NotInheritable Class NetworkUtils
Public NotInheritable Class NetworkUtils
public ref class NetworkUtils abstract sealed
public ref class NetworkUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type NetworkUtils =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type NetworkUtils =  class end
See Also
NetworkUtils Members
NFX.OS Namespace


NetworkUtils Members

NetworkUtils Members NFX Class Library

The NetworkUtils type exposes the following members.
Methods
Name | Description
GetMachineUniqueMACSignature | Gets a string which represents a unique signature of this machine based on MAC addresses of interfaces. The signature has a form of: [intf.count]-[CRC32 of all MACs]-[convoluted MD5 of all MACs]
Back to Top
See Also
NetworkUtils Class
NFX.OS Namespace


NetworkUtils Methods

NetworkUtils Methods NFX Class Library

The NetworkUtils type exposes the following members.
Methods
Name | Description
GetMachineUniqueMACSignature | Gets a string which represents a unique signature of this machine based on MAC addresses of interfaces. The signature has a form of: [intf.count]-[CRC32 of all MACs]-[convoluted MD5 of all MACs]
Back to Top
See Also
NetworkUtils Class
NFX.OS Namespace


NetworkUtils.GetMachineUniqueMACSignature Method

NetworkUtils GetMachineUniqueMACSignature Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets a string which represents a unique signature of this machine based on MAC addresses of interfaces. The signature has a form of: [intf.count]-[CRC32 of all MACs]-[convoluted MD5 of all MACs]

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetMachineUniqueMACSignature()
public static string GetMachineUniqueMACSignature()
Public Shared Function GetMachineUniqueMACSignature As String
Public Shared Function GetMachineUniqueMACSignature As String
public:
static String^ GetMachineUniqueMACSignature()
public:
static String^ GetMachineUniqueMACSignature()
static member GetMachineUniqueMACSignature : unit -> string
static member GetMachineUniqueMACSignature : unit -> string

Return Value

Type: Online String
See Also
NetworkUtils Class
NetworkUtils Members
NFX.OS Namespace


OSFamily Enumeration

OSFamily Enumeration NFX Class Library

Denots primary OS Families: Win/Mac/Lin*nix

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum OSFamily
public enum OSFamily
Public Enumeration OSFamily
Public Enumeration OSFamily
public enum class OSFamily
public enum class OSFamily
type OSFamily
type OSFamily
Members
Member name | Value | Description
Undetermined | 0 |
Windows | 1 |
Linux | 100 |
Mac | 200 |
See Also
NFX.OS Namespace


ProcessRunner Class

ProcessRunner Class NFX Class Library

Provides simple process invocation and output capture functionality
Inheritance Hierarchy
Online System Object
NFX.OS ProcessRunner

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class ProcessRunner
public sealed class ProcessRunner
Public NotInheritable Class ProcessRunner
Public NotInheritable Class ProcessRunner
public ref class ProcessRunner sealed
public ref class ProcessRunner sealed
[<SealedAttribute>]
type ProcessRunner =  class end
[<SealedAttribute>]
type ProcessRunner =  class end
See Also
ProcessRunner Members
NFX.OS Namespace


ProcessRunner Members

ProcessRunner Members NFX Class Library

The ProcessRunner type exposes the following members.
Constructors
 | Name | Description
Public method | ProcessRunner | Initializes a new instance of the ProcessRunner class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Run(Int32) | Runs process blocking until it finishes, or timeout is exceeded. Pass zero for time-unconstrained execution
 | Run(String, Int32) | Invokes a process specified by cmd parameters blocking until process finishes and returns stdout Pass optional timeout parameter that will abort the process execution when exceeded, or zero for unlimited time.
 | Run(String, String, Boolean , Int32) | Invokes a process specified by cmd parameters blocking until process finishes and returns stdout. Pass optional timeout parameter that will abort the process execution when exceeded, or zero for unlimited time.
 | Run(String, String, Int32 , Boolean , Int32) | Invokes a process specified by cmd parameters blocking until process finishes and returns stdout. Pass optional timeout parameter that will abort the process execution when exceeded, or zero for unlimited time.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Arguments | Gets/sets process invocation arguments
Public property | BufferedOutput | Returns buffered process output
Public property | ExecutionTimeMs | Returns process execution time in milliseconds
Public property | ExitCode | Returns process last exit code
Public property | ProcessCmd | Gets/sets process to run
Public property | TimedOutAndKilled | Returns process last exit code
Back to Top
See Also
ProcessRunner Class
NFX.OS Namespace


ProcessRunner Constructor

ProcessRunner Constructor NFX Class Library

Initializes a new instance of the ProcessRunner class

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ProcessRunner()
public ProcessRunner()
Public Sub New
Public Sub New
public:
ProcessRunner()
public:
ProcessRunner()
new : unit -> ProcessRunner
new : unit -> ProcessRunner
See Also
ProcessRunner Class
ProcessRunner Members
NFX.OS Namespace


ProcessRunner Methods

ProcessRunner Methods NFX Class Library

The ProcessRunner type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Run(Int32) | Runs process blocking until it finishes, or timeout is exceeded. Pass zero for time-unconstrained execution
 | Run(String, Int32) | Invokes a process specified by cmd parameters blocking until process finishes and returns stdout Pass optional timeout parameter that will abort the process execution when exceeded, or zero for unlimited time.
 | Run(String, String, Boolean , Int32) | Invokes a process specified by cmd parameters blocking until process finishes and returns stdout. Pass optional timeout parameter that will abort the process execution when exceeded, or zero for unlimited time.
 | Run(String, String, Int32 , Boolean , Int32) | Invokes a process specified by cmd parameters blocking until process finishes and returns stdout. Pass optional timeout parameter that will abort the process execution when exceeded, or zero for unlimited time.
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ProcessRunner Class
NFX.OS Namespace


ProcessRunner.Run Method

ProcessRunner Run Method NFX Class Library

Overload List
 | Name | Description
Public method | Run(Int32) | Runs process blocking until it finishes, or timeout is exceeded. Pass zero for time-unconstrained execution
 | Run(String, Int32) | Invokes a process specified by cmd parameters blocking until process finishes and returns stdout Pass optional timeout parameter that will abort the process execution when exceeded, or zero for unlimited time.
 | Run(String, String, Boolean , Int32) | Invokes a process specified by cmd parameters blocking until process finishes and returns stdout. Pass optional timeout parameter that will abort the process execution when exceeded, or zero for unlimited time.
 | Run(String, String, Int32 , Boolean , Int32) | Invokes a process specified by cmd parameters blocking until process finishes and returns stdout. Pass optional timeout parameter that will abort the process execution when exceeded, or zero for unlimited time.
Back to Top
See Also
ProcessRunner Class
ProcessRunner Members
NFX.OS Namespace


ProcessRunner.Run Method (Int32)

ProcessRunner Run Method (Int32) NFX Class Library

Runs process blocking until it finishes, or timeout is exceeded. Pass zero for time-unconstrained execution

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Run(
    int timeoutMs = 0
)
public int Run(
    int timeoutMs = 0
)
Public Function Run (
    Optional timeoutMs As Integer = 0
) As Integer
Public Function Run (
    Optional timeoutMs As Integer = 0
) As Integer
public:
int Run(
    int timeoutMs = 0
)
public:
int Run(
    int timeoutMs = 0
)
member Run :
        ?timeoutMs : int
(* Defaults:
        let _timeoutMs = defaultArg timeoutMs 0
*)
-> int
member Run :
        ?timeoutMs : int
(* Defaults:
        let _timeoutMs = defaultArg timeoutMs 0
*)
-> int

Parameters

timeoutMs (Optional)
Type: Online System Int32

Return Value

Type: Online Int32
See Also
ProcessRunner Class
ProcessRunner Members
Run Overload
NFX.OS Namespace


ProcessRunner.Run Method (String, Int32)

ProcessRunner Run Method (String, Int32) NFX Class Library

Invokes a process specified by cmd parameters blocking until process finishes and returns stdout Pass optional timeout parameter that will abort the process execution when exceeded, or zero for unlimited time.

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Run(
    string cmd,
    int timeoutMs = 0
)
public static string Run(
    string cmd,
    int timeoutMs = 0
)
Public Shared Function Run (
    cmd As String,
    Optional timeoutMs As Integer = 0
) As String
Public Shared Function Run (
    cmd As String,
    Optional timeoutMs As Integer = 0
) As String
public:
static String^ Run(
    String^ cmd,
    int timeoutMs = 0
)
public:
static String^ Run(
    String^ cmd,
    int timeoutMs = 0
)
static member Run :
        cmd : string *
        ?timeoutMs : int
(* Defaults:
        let _timeoutMs = defaultArg timeoutMs 0
*)
-> string
static member Run :
        cmd : string *
        ?timeoutMs : int
(* Defaults:
        let _timeoutMs = defaultArg timeoutMs 0
*)
-> string

Parameters

cmd
Type: Online System String
timeoutMs (Optional)
Type: Online System Int32

Return Value

Type: Online String
See Also
ProcessRunner Class
ProcessRunner Members
Run Overload
NFX.OS Namespace


ProcessRunner.Run Method (String, String, Boolean, Int32)

ProcessRunner Run Method (String, String, Boolean , Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Invokes a process specified by cmd parameters blocking until process finishes and returns stdout. Pass optional timeout parameter that will abort the process execution when exceeded, or zero for unlimited time.

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Run(
    string cmd,
    string args,
    out bool timedOut,
    int timeoutMs = 0
)
public static string Run(
    string cmd,
    string args,
    out bool timedOut,
    int timeoutMs = 0
)
Public Shared Function Run (
    cmd As String,
    args As String,
    <OutAttribute> ByRef timedOut As Boolean,
    Optional timeoutMs As Integer = 0
) As String
Public Shared Function Run (
    cmd As String,
    args As String,
    <OutAttribute> ByRef timedOut As Boolean,
    Optional timeoutMs As Integer = 0
) As String
public:
static String^ Run(
    String^ cmd,
    String^ args,
    [OutAttribute] bool% timedOut,
    int timeoutMs = 0
)
public:
static String^ Run(
    String^ cmd,
    String^ args,
    [OutAttribute] bool% timedOut,
    int timeoutMs = 0
)
static member Run :
        cmd : string *
        args : string *
        timedOut : bool byref *
        ?timeoutMs : int
(* Defaults:
        let _timeoutMs = defaultArg timeoutMs 0
*)
-> string
static member Run :
        cmd : string *
        args : string *
        timedOut : bool byref *
        ?timeoutMs : int
(* Defaults:
        let _timeoutMs = defaultArg timeoutMs 0
*)
-> string

Parameters

cmd
Type: Online System String
args
Type: Online System String
timedOut
Type: Online System Boolean
timeoutMs (Optional)
Type: Online System Int32

Return Value

Type: Online String
See Also
ProcessRunner Class
ProcessRunner Members
Run Overload
NFX.OS Namespace


ProcessRunner.Run Method (String, String, Int32, Boolean, Int32)

ProcessRunner Run Method (String, String, Int32 , Boolean , Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Invokes a process specified by cmd parameters blocking until process finishes and returns stdout. Pass optional timeout parameter that will abort the process execution when exceeded, or zero for unlimited time.

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Run(
    string cmd,
    string args,
    out int exitCode,
    out bool timedOut,
    int timeoutMs = 0
)
public static string Run(
    string cmd,
    string args,
    out int exitCode,
    out bool timedOut,
    int timeoutMs = 0
)
Public Shared Function Run (
    cmd As String,
    args As String,
    <OutAttribute> ByRef exitCode As Integer,
    <OutAttribute> ByRef timedOut As Boolean,
    Optional timeoutMs As Integer = 0
) As String
Public Shared Function Run (
    cmd As String,
    args As String,
    <OutAttribute> ByRef exitCode As Integer,
    <OutAttribute> ByRef timedOut As Boolean,
    Optional timeoutMs As Integer = 0
) As String
public:
static String^ Run(
    String^ cmd,
    String^ args,
    [OutAttribute] int% exitCode,
    [OutAttribute] bool% timedOut,
    int timeoutMs = 0
)
public:
static String^ Run(
    String^ cmd,
    String^ args,
    [OutAttribute] int% exitCode,
    [OutAttribute] bool% timedOut,
    int timeoutMs = 0
)
static member Run :
        cmd : string *
        args : string *
        exitCode : int byref *
        timedOut : bool byref *
        ?timeoutMs : int
(* Defaults:
        let _timeoutMs = defaultArg timeoutMs 0
*)
-> string
static member Run :
        cmd : string *
        args : string *
        exitCode : int byref *
        timedOut : bool byref *
        ?timeoutMs : int
(* Defaults:
        let _timeoutMs = defaultArg timeoutMs 0
*)
-> string

Parameters

cmd
Type: Online System String
args
Type: Online System String
exitCode
Type: Online System Int32
timedOut
Type: Online System Boolean
timeoutMs (Optional)
Type: Online System Int32

Return Value

Type: Online String
See Also
ProcessRunner Class
ProcessRunner Members
Run Overload
NFX.OS Namespace


ProcessRunner Properties

ProcessRunner Properties NFX Class Library

The ProcessRunner type exposes the following members.
Properties
 | Name | Description
Public property | Arguments | Gets/sets process invocation arguments
Public property | BufferedOutput | Returns buffered process output
Public property | ExecutionTimeMs | Returns process execution time in milliseconds
Public property | ExitCode | Returns process last exit code
Public property | ProcessCmd | Gets/sets process to run
Public property | TimedOutAndKilled | Returns process last exit code
Back to Top
See Also
ProcessRunner Class
NFX.OS Namespace


ProcessRunner.Arguments Property

ProcessRunner Arguments Property NFX Class Library

Gets/sets process invocation arguments

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Arguments { get; set; }
public string Arguments { get; set; }
Public Property Arguments As String
    Get
    Set
Public Property Arguments As String
    Get
    Set
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
member Arguments : string with get, set
member Arguments : string with get, set

Property Value

Type: Online String
See Also
ProcessRunner Class
ProcessRunner Members
NFX.OS Namespace


ProcessRunner.BufferedOutput Property

ProcessRunner BufferedOutput Property NFX Class Library

Returns buffered process output

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string BufferedOutput { get; }
public string BufferedOutput { get; }
Public ReadOnly Property BufferedOutput As String
    Get
Public ReadOnly Property BufferedOutput As String
    Get
public:
property String^ BufferedOutput {
    String^ get ();
}
public:
property String^ BufferedOutput {
    String^ get ();
}
member BufferedOutput : string with get
member BufferedOutput : string with get

Property Value

Type: Online String
See Also
ProcessRunner Class
ProcessRunner Members
NFX.OS Namespace


ProcessRunner.ExecutionTimeMs Property

ProcessRunner ExecutionTimeMs Property NFX Class Library

Returns process execution time in milliseconds

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ExecutionTimeMs { get; }
public int ExecutionTimeMs { get; }
Public ReadOnly Property ExecutionTimeMs As Integer
    Get
Public ReadOnly Property ExecutionTimeMs As Integer
    Get
public:
property int ExecutionTimeMs {
    int get ();
}
public:
property int ExecutionTimeMs {
    int get ();
}
member ExecutionTimeMs : int with get
member ExecutionTimeMs : int with get

Property Value

Type: Online Int32
See Also
ProcessRunner Class
ProcessRunner Members
NFX.OS Namespace


ProcessRunner.ExitCode Property

ProcessRunner ExitCode Property NFX Class Library

Returns process last exit code

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ExitCode { get; }
public int ExitCode { get; }
Public ReadOnly Property ExitCode As Integer
    Get
Public ReadOnly Property ExitCode As Integer
    Get
public:
property int ExitCode {
    int get ();
}
public:
property int ExitCode {
    int get ();
}
member ExitCode : int with get
member ExitCode : int with get

Property Value

Type: Online Int32
See Also
ProcessRunner Class
ProcessRunner Members
NFX.OS Namespace


ProcessRunner.ProcessCmd Property

ProcessRunner ProcessCmd Property NFX Class Library

Gets/sets process to run

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ProcessCmd { get; set; }
public string ProcessCmd { get; set; }
Public Property ProcessCmd As String
    Get
    Set
Public Property ProcessCmd As String
    Get
    Set
public:
property String^ ProcessCmd {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ProcessCmd {
    String^ get ();
    void set (String^ value);
}
member ProcessCmd : string with get, set
member ProcessCmd : string with get, set

Property Value

Type: Online String
See Also
ProcessRunner Class
ProcessRunner Members
NFX.OS Namespace


ProcessRunner.TimedOutAndKilled Property

ProcessRunner TimedOutAndKilled Property NFX Class Library

Returns process last exit code

Namespace: NFX.OS
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TimedOutAndKilled { get; }
public bool TimedOutAndKilled { get; }
Public ReadOnly Property TimedOutAndKilled As Boolean
    Get
Public ReadOnly Property TimedOutAndKilled As Boolean
    Get
public:
property bool TimedOutAndKilled {
    bool get ();
}
public:
property bool TimedOutAndKilled {
    bool get ();
}
member TimedOutAndKilled : bool with get
member TimedOutAndKilled : bool with get

Property Value

Type: Online Boolean
See Also
ProcessRunner Class
ProcessRunner Members
NFX.OS Namespace


NFX.OS.Instrumentation Namespace

NFX.OS.Instrumentation Namespace NFX Class Library

Classes
 | Class | Description
Public class | AvailableRAM |
Public class | CPUUsage |
Public class | OSDoubleGauge |
Public class | OSLongGauge |
Public class | RAMUsage |


AvailableRAM Class

AvailableRAM Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.OS.Instrumentation OSLongGauge
NFX.OS.Instrumentation AvailableRAM

Namespace: NFX.OS.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class AvailableRAM : OSLongGauge,
    IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public class AvailableRAM : OSLongGauge,
    IMemoryInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class AvailableRAM
    Inherits OSLongGauge
    Implements IMemoryInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class AvailableRAM
    Inherits OSLongGauge
    Implements IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class AvailableRAM : public OSLongGauge,
    IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class AvailableRAM : public OSLongGauge,
    IMemoryInstrument, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type AvailableRAM =
    class
        inherit OSLongGauge
        interface IMemoryInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type AvailableRAM =
    class
        inherit OSLongGauge
        interface IMemoryInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
AvailableRAM Members
NFX.OS.Instrumentation Namespace


AvailableRAM Members

AvailableRAM Members NFX Class Library

The AvailableRAM type exposes the following members.
Constructors
 | Name | Description
Protected method | AvailableRAM | Initializes a new instance of the AvailableRAM class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
AvailableRAM Class
NFX.OS.Instrumentation Namespace


AvailableRAM Constructor

AvailableRAM Constructor NFX Class Library

Initializes a new instance of the AvailableRAM class

Namespace: NFX.OS.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected AvailableRAM(
    string src,
    long value
)
protected AvailableRAM(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
AvailableRAM(
    String^ src,
    long long value
)
protected:
AvailableRAM(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> AvailableRAM
new :
        src : string *
        value : int64 -> AvailableRAM

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
AvailableRAM Class
AvailableRAM Members
NFX.OS.Instrumentation Namespace


AvailableRAM Fields

AvailableRAM Fields NFX Class Library

The AvailableRAM type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
AvailableRAM Class
NFX.OS.Instrumentation Namespace


AvailableRAM Methods

AvailableRAM Methods NFX Class Library

The AvailableRAM type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
AvailableRAM Class
NFX.OS.Instrumentation Namespace


AvailableRAM.MakeAggregateInstance Method

AvailableRAM MakeAggregateInstance Method NFX Class Library

Namespace: NFX.OS.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
AvailableRAM Class
AvailableRAM Members
NFX.OS.Instrumentation Namespace


AvailableRAM.Record Method

AvailableRAM Record Method NFX Class Library

Namespace: NFX.OS.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    long value,
    string src = null
)
public static void Record(
    long value,
    string src = null
)
Public Shared Sub Record (
    value As Long,
    Optional src As String = Nothing
)
Public Shared Sub Record (
    value As Long,
    Optional src As String = Nothing
)
public:
static void Record(
    long long value,
    String^ src = nullptr
)
public:
static void Record(
    long long value,
    String^ src = nullptr
)
static member Record :
        value : int64 *
        ?src : string
(* Defaults:
        let _src = defaultArg src null
*)
-> unit
static member Record :
        value : int64 *
        ?src : string
(* Defaults:
        let _src = defaultArg src null
*)
-> unit

Parameters

value
Type: Online System Int64
src (Optional)
Type: Online System String
See Also
AvailableRAM Class
AvailableRAM Members
NFX.OS.Instrumentation Namespace


AvailableRAM Properties

AvailableRAM Properties NFX Class Library

The AvailableRAM type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
AvailableRAM Class
NFX.OS.Instrumentation Namespace


AvailableRAM.Description Property

AvailableRAM Description Property NFX Class Library

Namespace: NFX.OS.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
AvailableRAM Class
AvailableRAM Members
NFX.OS.Instrumentation Namespace


AvailableRAM.ValueUnitName Property

AvailableRAM ValueUnitName Property NFX Class Library

Namespace: NFX.OS.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
AvailableRAM Class
AvailableRAM Members
NFX.OS.Instrumentation Namespace


CPUUsage Class

CPUUsage Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.OS.Instrumentation OSLongGauge
NFX.OS.Instrumentation CPUUsage

Namespace: NFX.OS.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CPUUsage : OSLongGauge, ICPUInstrument,
    IOperationClass, IInstrumentClass
[SerializableAttribute]
public class CPUUsage : OSLongGauge, ICPUInstrument,
    IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class CPUUsage
    Inherits OSLongGauge
    Implements ICPUInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class CPUUsage
    Inherits OSLongGauge
    Implements ICPUInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class CPUUsage : public OSLongGauge,
    ICPUInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class CPUUsage : public OSLongGauge,
    ICPUInstrument, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type CPUUsage =
    class
        inherit OSLongGauge
        interface ICPUInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type CPUUsage =
    class
        inherit OSLongGauge
        interface ICPUInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
CPUUsage Members
NFX.OS.Instrumentation Namespace


CPUUsage Members

CPUUsage Members NFX Class Library

The CPUUsage type exposes the following members.
Constructors
 | Name | Description
Protected method | CPUUsage | Initializes a new instance of the CPUUsage class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CPUUsage Class
NFX.OS.Instrumentation Namespace


CPUUsage Constructor

CPUUsage Constructor NFX Class Library

Initializes a new instance of the CPUUsage class

Namespace: NFX.OS.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CPUUsage(
    string src,
    long value
)
protected CPUUsage(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
CPUUsage(
    String^ src,
    long long value
)
protected:
CPUUsage(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> CPUUsage
new :
        src : string *
        value : int64 -> CPUUsage

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
CPUUsage Class
CPUUsage Members
NFX.OS.Instrumentation Namespace


CPUUsage Fields

CPUUsage Fields NFX Class Library

The CPUUsage type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
CPUUsage Class
NFX.OS.Instrumentation Namespace


CPUUsage Methods

CPUUsage Methods NFX Class Library

The CPUUsage type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CPUUsage Class
NFX.OS.Instrumentation Namespace


CPUUsage.MakeAggregateInstance Method

CPUUsage MakeAggregateInstance Method NFX Class Library

Namespace: NFX.OS.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
CPUUsage Class
CPUUsage Members
NFX.OS.Instrumentation Namespace


CPUUsage.Record Method

CPUUsage Record Method NFX Class Library

Namespace: NFX.OS.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    long value,
    string src = null
)
public static void Record(
    long value,
    string src = null
)
Public Shared Sub Record (
    value As Long,
    Optional src As String = Nothing
)
Public Shared Sub Record (
    value As Long,
    Optional src As String = Nothing
)
public:
static void Record(
    long long value,
    String^ src = nullptr
)
public:
static void Record(
    long long value,
    String^ src = nullptr
)
static member Record :
        value : int64 *
        ?src : string
(* Defaults:
        let _src = defaultArg src null
*)
-> unit
static member Record :
        value : int64 *
        ?src : string
(* Defaults:
        let _src = defaultArg src null
*)
-> unit

Parameters

value
Type: Online System Int64
src (Optional)
Type: Online System String
See Also
CPUUsage Class
CPUUsage Members
NFX.OS.Instrumentation Namespace


CPUUsage Properties

CPUUsage Properties NFX Class Library

The CPUUsage type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
CPUUsage Class
NFX.OS.Instrumentation Namespace


CPUUsage.Description Property

CPUUsage Description Property NFX Class Library

Namespace: NFX.OS.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
CPUUsage Class
CPUUsage Members
NFX.OS.Instrumentation Namespace


CPUUsage.ValueUnitName Property

CPUUsage ValueUnitName Property NFX Class Library

Namespace: NFX.OS.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
CPUUsage Class
CPUUsage Members
NFX.OS.Instrumentation Namespace


OSDoubleGauge Class

OSDoubleGauge Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation DoubleGauge
NFX.OS.Instrumentation OSDoubleGauge

Namespace: NFX.OS.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class OSDoubleGauge : DoubleGauge
[SerializableAttribute]
public abstract class OSDoubleGauge : DoubleGauge
<SerializableAttribute>
Public MustInherit Class OSDoubleGauge
    Inherits DoubleGauge
<SerializableAttribute>
Public MustInherit Class OSDoubleGauge
    Inherits DoubleGauge
[SerializableAttribute]
public ref class OSDoubleGauge abstract : public DoubleGauge
[SerializableAttribute]
public ref class OSDoubleGauge abstract : public DoubleGauge
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type OSDoubleGauge =
    class
        inherit DoubleGauge
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type OSDoubleGauge =
    class
        inherit DoubleGauge
    end
See Also
OSDoubleGauge Members
NFX.OS.Instrumentation Namespace


OSDoubleGauge Members

OSDoubleGauge Members NFX Class Library

The OSDoubleGauge type exposes the following members.
Constructors
 | Name | Description
Protected method | OSDoubleGauge | Initializes a new instance of the OSDoubleGauge class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from DoubleGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from DoubleGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from DoubleGauge.)
Public property | ValueAsObject | (Inherited from DoubleGauge.)
Public property | ValueUnitName | (Inherited from DoubleGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
OSDoubleGauge Class
NFX.OS.Instrumentation Namespace


OSDoubleGauge Constructor

OSDoubleGauge Constructor NFX Class Library

Initializes a new instance of the OSDoubleGauge class

Namespace: NFX.OS.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected OSDoubleGauge(
    string src,
    double value
)
protected OSDoubleGauge(
    string src,
    double value
)
Protected Sub New (
    src As String,
    value As Double
)
Protected Sub New (
    src As String,
    value As Double
)
protected:
OSDoubleGauge(
    String^ src,
    double value
)
protected:
OSDoubleGauge(
    String^ src,
    double value
)
new :
        src : string *
        value : float -> OSDoubleGauge
new :
        src : string *
        value : float -> OSDoubleGauge

Parameters

src
Type: Online System String
value
Type: Online System Double
See Also
OSDoubleGauge Class
OSDoubleGauge Members
NFX.OS.Instrumentation Namespace


OSDoubleGauge Fields

OSDoubleGauge Fields NFX Class Library

The OSDoubleGauge type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
OSDoubleGauge Class
NFX.OS.Instrumentation Namespace


OSDoubleGauge Methods

OSDoubleGauge Methods NFX Class Library

The OSDoubleGauge type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from DoubleGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from DoubleGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
OSDoubleGauge Class
NFX.OS.Instrumentation Namespace


OSDoubleGauge Properties

OSDoubleGauge Properties NFX Class Library

The OSDoubleGauge type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from DoubleGauge.)
Public property | ValueAsObject | (Inherited from DoubleGauge.)
Public property | ValueUnitName | (Inherited from DoubleGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
OSDoubleGauge Class
NFX.OS.Instrumentation Namespace


OSLongGauge Class

OSLongGauge Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.OS.Instrumentation OSLongGauge
NFX.OS.Instrumentation AvailableRAM
NFX.OS.Instrumentation CPUUsage
NFX.OS.Instrumentation RAMUsage

Namespace: NFX.OS.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class OSLongGauge : LongGauge
[SerializableAttribute]
public abstract class OSLongGauge : LongGauge
<SerializableAttribute>
Public MustInherit Class OSLongGauge
    Inherits LongGauge
<SerializableAttribute>
Public MustInherit Class OSLongGauge
    Inherits LongGauge
[SerializableAttribute]
public ref class OSLongGauge abstract : public LongGauge
[SerializableAttribute]
public ref class OSLongGauge abstract : public LongGauge
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type OSLongGauge =
    class
        inherit LongGauge
    end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type OSLongGauge =
    class
        inherit LongGauge
    end
See Also
OSLongGauge Members
NFX.OS.Instrumentation Namespace


OSLongGauge Members

OSLongGauge Members NFX Class Library

The OSLongGauge type exposes the following members.
Constructors
 | Name | Description
Protected method | OSLongGauge | Initializes a new instance of the OSLongGauge class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Inherited from LongGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
OSLongGauge Class
NFX.OS.Instrumentation Namespace


OSLongGauge Constructor

OSLongGauge Constructor NFX Class Library

Initializes a new instance of the OSLongGauge class

Namespace: NFX.OS.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected OSLongGauge(
    string src,
    long value
)
protected OSLongGauge(
    string src,
    long value
)
Protected Sub New (
    src As String,
    value As Long
)
Protected Sub New (
    src As String,
    value As Long
)
protected:
OSLongGauge(
    String^ src,
    long long value
)
protected:
OSLongGauge(
    String^ src,
    long long value
)
new :
        src : string *
        value : int64 -> OSLongGauge
new :
        src : string *
        value : int64 -> OSLongGauge

Parameters

src
Type: Online System String
value
Type: Online System Int64
See Also
OSLongGauge Class
OSLongGauge Members
NFX.OS.Instrumentation Namespace


OSLongGauge Fields

OSLongGauge Fields NFX Class Library

The OSLongGauge type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
OSLongGauge Class
NFX.OS.Instrumentation Namespace


OSLongGauge Methods

OSLongGauge Methods NFX Class Library

The OSLongGauge type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Inherited from Datum.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
OSLongGauge Class
NFX.OS.Instrumentation Namespace


OSLongGauge Properties

OSLongGauge Properties NFX Class Library

The OSLongGauge type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | Returns description for data that this datum represents. Base implementation returns full type name of this instance (Inherited from Datum.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Inherited from LongGauge.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
OSLongGauge Class
NFX.OS.Instrumentation Namespace


RAMUsage Class

RAMUsage Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Instrumentation Datum
NFX.Instrumentation Gauge
NFX.Instrumentation LongGauge
NFX.OS.Instrumentation OSLongGauge
NFX.OS.Instrumentation RAMUsage

Namespace: NFX.OS.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class RAMUsage : OSLongGauge, IMemoryInstrument,
    IOperationClass, IInstrumentClass
[SerializableAttribute]
public class RAMUsage : OSLongGauge, IMemoryInstrument,
    IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class RAMUsage
    Inherits OSLongGauge
    Implements IMemoryInstrument, IOperationClass, IInstrumentClass
<SerializableAttribute>
Public Class RAMUsage
    Inherits OSLongGauge
    Implements IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class RAMUsage : public OSLongGauge,
    IMemoryInstrument, IOperationClass, IInstrumentClass
[SerializableAttribute]
public ref class RAMUsage : public OSLongGauge,
    IMemoryInstrument, IOperationClass, IInstrumentClass
[<SerializableAttribute>]
type RAMUsage =
    class
        inherit OSLongGauge
        interface IMemoryInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
[<SerializableAttribute>]
type RAMUsage =
    class
        inherit OSLongGauge
        interface IMemoryInstrument
        interface IOperationClass
        interface IInstrumentClass
    end
See Also
RAMUsage Members
NFX.OS.Instrumentation Namespace


RAMUsage Members

RAMUsage Members NFX Class Library

The RAMUsage type exposes the following members.
Constructors
 | Name | Description
Protected method | RAMUsage | Initializes a new instance of the RAMUsage class
Back to Top
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
RAMUsage Class
NFX.OS.Instrumentation Namespace


RAMUsage Constructor

RAMUsage Constructor NFX Class Library

Initializes a new instance of the RAMUsage class

Namespace: NFX.OS.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected RAMUsage(
    long value
)
protected RAMUsage(
    long value
)
Protected Sub New (
    value As Long
)
Protected Sub New (
    value As Long
)
protected:
RAMUsage(
    long long value
)
protected:
RAMUsage(
    long long value
)
new :
        value : int64 -> RAMUsage
new :
        value : int64 -> RAMUsage

Parameters

value
Type: Online System Int64
See Also
RAMUsage Class
RAMUsage Members
NFX.OS.Instrumentation Namespace


RAMUsage Fields

RAMUsage Fields NFX Class Library

The RAMUsage type exposes the following members.
Fields
 | Name | Description
Protected field | m_Count | (Inherited from Datum.)
Protected field | m_Source | (Inherited from Datum.)
Protected field | m_UTCEndTime | (Inherited from Datum.)
Protected field | m_UTCTime | (Inherited from Datum.)
Back to Top
See Also
RAMUsage Class
NFX.OS.Instrumentation Namespace


RAMUsage Methods

RAMUsage Methods NFX Class Library

The RAMUsage type exposes the following members.
Methods
 | Name | Description
Public method | Aggregate | Aggregates events, for example from multiple threads into one (Inherited from Datum.)
Protected method | AggregateEvent | (Inherited from LongGauge.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | MakeAggregateInstance | (Overrides Datum MakeAggregateInstance .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Record |
Public method | ReduceSourceDetail | Override to set a new source value which is less-specific than existing source. ReductionLevel specifies how much detail should be lost. The function is idempotent, that is - calling more than once with the same arg does not change the state of the object. The default implementation removes all source details (unspecified source) when reductionLevel less than zero. Example: TotalBytesSent("mpx://45.12.123.19:7823 -> MySystem.Contracts.IDoSomething.SomeMethod1()") ReduceSourceDetail(0) -> yields original string ReduceSourceDetail(1) - > "MySystem.Contracts.IDoSomething.SomeMethod1()" ReduceSourceDetail(2) - > "MySystem.Contracts.IDoSomething" ReduceSourceDetail(3) - > "" (Inherited from Datum.)
Protected method | SummarizeAggregation | (Inherited from LongGauge.)
Public method | ToString | (Inherited from Datum.)
Public method | WriteAsJSON | (Inherited from Datum.)
Protected method | WriteJSONFields | (Inherited from Datum.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
RAMUsage Class
NFX.OS.Instrumentation Namespace


RAMUsage.MakeAggregateInstance Method

RAMUsage MakeAggregateInstance Method NFX Class Library

Namespace: NFX.OS.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override Datum MakeAggregateInstance()
protected override Datum MakeAggregateInstance()
Protected Overrides Function MakeAggregateInstance As Datum
Protected Overrides Function MakeAggregateInstance As Datum
protected:
virtual Datum^ MakeAggregateInstance() override
protected:
virtual Datum^ MakeAggregateInstance() override
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum
abstract MakeAggregateInstance : unit -> Datum
override MakeAggregateInstance : unit -> Datum

Return Value

Type: Datum
See Also
RAMUsage Class
RAMUsage Members
NFX.OS.Instrumentation Namespace


RAMUsage.Record Method

RAMUsage Record Method NFX Class Library

Namespace: NFX.OS.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Record(
    long value
)
public static void Record(
    long value
)
Public Shared Sub Record (
    value As Long
)
Public Shared Sub Record (
    value As Long
)
public:
static void Record(
    long long value
)
public:
static void Record(
    long long value
)
static member Record :
        value : int64 -> unit
static member Record :
        value : int64 -> unit

Parameters

value
Type: Online System Int64
See Also
RAMUsage Class
RAMUsage Members
NFX.OS.Instrumentation Namespace


RAMUsage Properties

RAMUsage Properties NFX Class Library

The RAMUsage type exposes the following members.
Properties
 | Name | Description
Public property | Count | Returns count of measurements. This property may be gotten only if IsAggregated==true, otherwise zero is returned (Inherited from Datum.)
Public property | Description | (Overrides Datum Description.)
Public property | IsAggregated | Indicates whether this instance represents a rollup/aggregation of multiple events (Inherited from Datum.)
Public property | PlotValue | Provides numeric value used for charts (Inherited from Datum.)
Public property | Rate | Returns rate of occurrence string (Inherited from Datum.)
Public property | Source | Returns datum source. Data are rolled-up by type of recorded datum instances and source (Inherited from Datum.)
Public property | UTCEndTime | Returns UTC time stamp when event happened. This property may be gotten only if IsAggregated==true, otherwise UTCTime value is returned (Inherited from Datum.)
Public property | UTCTime | Returns UTC time stamp when event happened (Inherited from Datum.)
Public property | Value | Gets gauge value (Inherited from LongGauge.)
Public property | ValueAsObject | (Inherited from LongGauge.)
Public property | ValueUnitName | (Overrides LongGauge ValueUnitName.)
Public property | ViewGroupInterfaces | Returns Datum classification interfaces marked with InstrumentViewGroup attribute. The implementation is cached fr efficiency (Inherited from Datum.)
Back to Top
See Also
RAMUsage Class
NFX.OS.Instrumentation Namespace


RAMUsage.Description Property

RAMUsage Description Property NFX Class Library

Namespace: NFX.OS.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Description { get; }
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
RAMUsage Class
RAMUsage Members
NFX.OS.Instrumentation Namespace


RAMUsage.ValueUnitName Property

RAMUsage ValueUnitName Property NFX Class Library

Namespace: NFX.OS.Instrumentation
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ValueUnitName { get; }
public override string ValueUnitName { get; }
Public Overrides ReadOnly Property ValueUnitName As String
    Get
Public Overrides ReadOnly Property ValueUnitName As String
    Get
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
public:
virtual property String^ ValueUnitName {
    String^ get () override;
}
abstract ValueUnitName : string with get
override ValueUnitName : string with get
abstract ValueUnitName : string with get
override ValueUnitName : string with get

Property Value

Type: Online String
See Also
RAMUsage Class
RAMUsage Members
NFX.OS.Instrumentation Namespace


NFX.Parsing Namespace

NFX.Parsing Namespace NFX Class Library

Provides varios string-parsing/text-related utils
Classes
 | Class | Description
Public class | CompilingExpressionEvaluator TContext, TResult, TArg | Implements an evaluator that compiles all expressions represented by instances of this class in a certain scope into dynamic assemblies. Every unique scope name creates a separate assembly. The compilation of scope is triggered either by a call to Compile() or first attempt to call Evaluate() on any instance within a scope. Once a scope has been compiled, no further allocations in this scoped are allowed, this is because CLR does not allow to unload assemblies dynamically. Within an expression context is passed as "ctx" and argument as "arg". This class is thread-safe.
Public class | DataEntryUtils | Provides misc data-entry parsing routines
Public class | Evaluator |
Public class | Evaluator Node | Node class represents evaluation b-tree element
Public class | NaturalTextGenerator | Generates human-readable English text for tests
Public class | TokenParser | TokenParser class translates tokenized content string to an array list of parsed tokens with attributes
Public class | TokenParser Token | Token class holds parsed token info along with an array of attributes
Public class | TokenParser Token Attribute | Attribute class represents token's attribute
Public class | Utils |
Delegates
 | Delegate | Description
Public delegate | IdentifierLookup | Evaluator class performs math and logical expression parsing and evaluation without allocating .NET compilers
Enumerations
 | Enumeration | Description
Public enumeration | CharCodes | Declares common char codes


CharCodes Enumeration

CharCodes Enumeration NFX Class Library

Declares common char codes

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum CharCodes
public enum CharCodes
Public Enumeration CharCodes
Public Enumeration CharCodes
public enum class CharCodes
public enum class CharCodes
type CharCodes
type CharCodes
Members
Member name | Value | Description
Char0 | 0 |
AlertBell | 7 |
Backspace | 8 |
Formfeed | 12 |
LF | 10 |
CR | 13 |
Tab | 9 |
VerticalQuote | 11 |
See Also
NFX.Parsing Namespace


CompilingExpressionEvaluator(TContext, TResult, TArg) Class

CompilingExpressionEvaluator TContext, TResult, TArg Class NFX Class Library

[This is preliminary documentation and is subject to change.]

Implements an evaluator that compiles all expressions represented by instances of this class in a certain scope into dynamic assemblies. Every unique scope name creates a separate assembly. The compilation of scope is triggered either by a call to Compile() or first attempt to call Evaluate() on any instance within a scope. Once a scope has been compiled, no further allocations in this scoped are allowed, this is because CLR does not allow to unload assemblies dynamically. Within an expression context is passed as "ctx" and argument as "arg". This class is thread-safe.
Inheritance Hierarchy
Online System Object
NFX.Parsing CompilingExpressionEvaluator TContext, TResult, TArg
NFX.Log MessageFilterExpression

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CompilingExpressionEvaluator<TContext, TResult, TArg>
public class CompilingExpressionEvaluator<TContext, TResult, TArg>
Public Class CompilingExpressionEvaluator(Of TContext, TResult, TArg)
Public Class CompilingExpressionEvaluator(Of TContext, TResult, TArg)
generic<typename TContext, typename TResult, typename TArg>
public ref class CompilingExpressionEvaluator
generic<typename TContext, typename TResult, typename TArg>
public ref class CompilingExpressionEvaluator
type CompilingExpressionEvaluator<'TContext, 'TResult, 'TArg> =  class end
type CompilingExpressionEvaluator<'TContext, 'TResult, 'TArg> =  class end
Type Parameters
TContext
TResult
TArg
See Also
CompilingExpressionEvaluator TContext, TResult, TArg Members
NFX.Parsing Namespace


CompilingExpressionEvaluator(TContext, TResult, TArg) Members

CompilingExpressionEvaluator TContext, TResult, TArg Members NFX Class Library

[This is preliminary documentation and is subject to change.]

The CompilingExpressionEvaluator TContext, TResult, TArg type exposes the following members.
Constructors
 | Name | Description
Public method | CompilingExpressionEvaluator TContext, TResult, TArg | Allocates a new expression. This call fails if the scope was already compiled
Back to Top
Methods
 | Name | Description
Public method | Compile | Forces the entire scope compilation now, so no delay is incurred on first call to Evaluate().
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Evaluate | Evaluates expression using supplied arg in a context. Context is passed as "ctx" and argument as "arg".
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | IsScopeAlreadyCompiled | Indicates whether this scope has already been compiled and no more epressions can be allocated in it
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Expression | Returns an original expression as string that is to be evaluated
Public property | Scope | Returns a scope (similar to compilation unit / assembly) that this expression is in
Back to Top
See Also
CompilingExpressionEvaluator TContext, TResult, TArg Class
NFX.Parsing Namespace


CompilingExpressionEvaluator(TContext, TResult, TArg) Constructor

CompilingExpressionEvaluator TContext, TResult, TArg Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Allocates a new expression. This call fails if the scope was already compiled

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CompilingExpressionEvaluator(
    string scope,
    string expression,
    IEnumerable<string> referencedAssemblies = null,
    IEnumerable<string> usings = null
)
public CompilingExpressionEvaluator(
    string scope,
    string expression,
    IEnumerable<string> referencedAssemblies = null,
    IEnumerable<string> usings = null
)
Public Sub New (
    scope As String,
    expression As String,
    Optional referencedAssemblies As IEnumerable(Of String) = Nothing,
    Optional usings As IEnumerable(Of String) = Nothing
)
Public Sub New (
    scope As String,
    expression As String,
    Optional referencedAssemblies As IEnumerable(Of String) = Nothing,
    Optional usings As IEnumerable(Of String) = Nothing
)
public:
CompilingExpressionEvaluator(
    String^ scope,
    String^ expression,
    IEnumerable<String^>^ referencedAssemblies = nullptr,
    IEnumerable<String^>^ usings = nullptr
)
public:
CompilingExpressionEvaluator(
    String^ scope,
    String^ expression,
    IEnumerable<String^>^ referencedAssemblies = nullptr,
    IEnumerable<String^>^ usings = nullptr
)
new :
        scope : string *
        expression : string *
        ?referencedAssemblies : IEnumerable<string> *
        ?usings : IEnumerable<string>
(* Defaults:
        let _referencedAssemblies = defaultArg referencedAssemblies null
        let _usings = defaultArg usings null
*)
-> CompilingExpressionEvaluator
new :
        scope : string *
        expression : string *
        ?referencedAssemblies : IEnumerable<string> *
        ?usings : IEnumerable<string>
(* Defaults:
        let _referencedAssemblies = defaultArg referencedAssemblies null
        let _usings = defaultArg usings null
*)
-> CompilingExpressionEvaluator

Parameters

scope
Type: Online System String
A valid identifier for namespace sub-path like "mycode.test" no leading or trailing "."
expression
Type: Online System String
A C# expression to compile
referencedAssemblies (Optional)
Type: Online System.Collections.Generic IEnumerable Online String
An enumerable of assemblies that compiler should reference while building scope assembly i.e. "MyCompany.dll"
usings (Optional)
Type: Online System.Collections.Generic IEnumerable Online String
Extra usings i.e. "System.IO", "MyCode.Routines" etc.
See Also
CompilingExpressionEvaluator TContext, TResult, TArg Class
CompilingExpressionEvaluator TContext, TResult, TArg Members
NFX.Parsing Namespace


CompilingExpressionEvaluator(TContext, TResult, TArg) Methods

CompilingExpressionEvaluator TContext, TResult, TArg Methods NFX Class Library

[This is preliminary documentation and is subject to change.]

The CompilingExpressionEvaluator TContext, TResult, TArg type exposes the following members.
Methods
 | Name | Description
Public method | Compile | Forces the entire scope compilation now, so no delay is incurred on first call to Evaluate().
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Evaluate | Evaluates expression using supplied arg in a context. Context is passed as "ctx" and argument as "arg".
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | IsScopeAlreadyCompiled | Indicates whether this scope has already been compiled and no more epressions can be allocated in it
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CompilingExpressionEvaluator TContext, TResult, TArg Class
NFX.Parsing Namespace


CompilingExpressionEvaluator(TContext, TResult, TArg).Compile Method

CompilingExpressionEvaluator TContext, TResult, TArg Compile Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Forces the entire scope compilation now, so no delay is incurred on first call to Evaluate().

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Compile()
public void Compile()
Public Sub Compile
Public Sub Compile
public:
void Compile()
public:
void Compile()
member Compile : unit -> unit
member Compile : unit -> unit
See Also
CompilingExpressionEvaluator TContext, TResult, TArg Class
CompilingExpressionEvaluator TContext, TResult, TArg Members
NFX.Parsing Namespace


CompilingExpressionEvaluator(TContext, TResult, TArg).Evaluate Method

CompilingExpressionEvaluator TContext, TResult, TArg Evaluate Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Evaluates expression using supplied arg in a context. Context is passed as "ctx" and argument as "arg".

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TResult Evaluate(
    TContext context,
    TArg arg
)
public TResult Evaluate(
    TContext context,
    TArg arg
)
Public Function Evaluate (
    context As TContext,
    arg As TArg
) As TResult
Public Function Evaluate (
    context As TContext,
    arg As TArg
) As TResult
public:
TResult Evaluate(
    TContext context,
    TArg arg
)
public:
TResult Evaluate(
    TContext context,
    TArg arg
)
member Evaluate :
        context : 'TContext *
        arg : 'TArg -> 'TResult
member Evaluate :
        context : 'TContext *
        arg : 'TArg -> 'TResult

Parameters

context
Type: TContext
arg
Type: TArg

Return Value

Type: TResult
See Also
CompilingExpressionEvaluator TContext, TResult, TArg Class
CompilingExpressionEvaluator TContext, TResult, TArg Members
NFX.Parsing Namespace


CompilingExpressionEvaluator(TContext, TResult, TArg).IsScopeAlreadyCompiled Method

CompilingExpressionEvaluator TContext, TResult, TArg IsScopeAlreadyCompiled Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Indicates whether this scope has already been compiled and no more epressions can be allocated in it

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsScopeAlreadyCompiled(
    string scope
)
public static bool IsScopeAlreadyCompiled(
    string scope
)
Public Shared Function IsScopeAlreadyCompiled (
    scope As String
) As Boolean
Public Shared Function IsScopeAlreadyCompiled (
    scope As String
) As Boolean
public:
static bool IsScopeAlreadyCompiled(
    String^ scope
)
public:
static bool IsScopeAlreadyCompiled(
    String^ scope
)
static member IsScopeAlreadyCompiled :
        scope : string -> bool
static member IsScopeAlreadyCompiled :
        scope : string -> bool

Parameters

scope
Type: Online System String

Return Value

Type: Online Boolean
See Also
CompilingExpressionEvaluator TContext, TResult, TArg Class
CompilingExpressionEvaluator TContext, TResult, TArg Members
NFX.Parsing Namespace


CompilingExpressionEvaluator(TContext, TResult, TArg) Properties

CompilingExpressionEvaluator TContext, TResult, TArg Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The CompilingExpressionEvaluator TContext, TResult, TArg type exposes the following members.
Properties
 | Name | Description
Public property | Expression | Returns an original expression as string that is to be evaluated
Public property | Scope | Returns a scope (similar to compilation unit / assembly) that this expression is in
Back to Top
See Also
CompilingExpressionEvaluator TContext, TResult, TArg Class
NFX.Parsing Namespace


CompilingExpressionEvaluator(TContext, TResult, TArg).Expression Property

CompilingExpressionEvaluator TContext, TResult, TArg Expression Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns an original expression as string that is to be evaluated

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Expression { get; }
public string Expression { get; }
Public ReadOnly Property Expression As String
    Get
Public ReadOnly Property Expression As String
    Get
public:
property String^ Expression {
    String^ get ();
}
public:
property String^ Expression {
    String^ get ();
}
member Expression : string with get
member Expression : string with get

Property Value

Type: Online String
See Also
CompilingExpressionEvaluator TContext, TResult, TArg Class
CompilingExpressionEvaluator TContext, TResult, TArg Members
NFX.Parsing Namespace


CompilingExpressionEvaluator(TContext, TResult, TArg).Scope Property

CompilingExpressionEvaluator TContext, TResult, TArg Scope Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns a scope (similar to compilation unit / assembly) that this expression is in

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Scope { get; }
public string Scope { get; }
Public ReadOnly Property Scope As String
    Get
Public ReadOnly Property Scope As String
    Get
public:
property String^ Scope {
    String^ get ();
}
public:
property String^ Scope {
    String^ get ();
}
member Scope : string with get
member Scope : string with get

Property Value

Type: Online String
See Also
CompilingExpressionEvaluator TContext, TResult, TArg Class
CompilingExpressionEvaluator TContext, TResult, TArg Members
NFX.Parsing Namespace


DataEntryUtils Class

DataEntryUtils Class NFX Class Library

Provides misc data-entry parsing routines
Inheritance Hierarchy
Online System Object
NFX.Parsing DataEntryUtils

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class DataEntryUtils
public static class DataEntryUtils
Public NotInheritable Class DataEntryUtils
Public NotInheritable Class DataEntryUtils
public ref class DataEntryUtils abstract sealed
public ref class DataEntryUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DataEntryUtils =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DataEntryUtils =  class end
See Also
DataEntryUtils Members
NFX.Parsing Namespace


DataEntryUtils Members

DataEntryUtils Members NFX Class Library

The DataEntryUtils type exposes the following members.
Methods
Name | Description
CheckEMail | Returns true if the value is a valid non-null/empty email address
CheckScreenName | Returns true if the value starts from primary language char and contains only those chars separated by one of ['.','-','_']. Subsequent separators not to occur more than once and can not be at the very end. This function supports Latin/Cyrrilic char sets
CheckTelephone | Returns true if the value is a valid non-null/empty telephone
IsLatinLetterOrDigit |
IsValidEMailLocalPartChar |
IsValidScreenNameLetter |
IsValidScreenNameLetterOrDigit |
IsValidScreenNameSeparator |
NormalizeUSPhone | Normalizes US phone string so it looks like (999) 999-9999x9999.
SQLSafeSubstitute | Allows only safe characters and digits replacing characters that may be used in SQL injection. This method may be used to generate column names from entity IDs
Back to Top
See Also
DataEntryUtils Class
NFX.Parsing Namespace


DataEntryUtils Methods

DataEntryUtils Methods NFX Class Library

The DataEntryUtils type exposes the following members.
Methods
Name | Description
CheckEMail | Returns true if the value is a valid non-null/empty email address
CheckScreenName | Returns true if the value starts from primary language char and contains only those chars separated by one of ['.','-','_']. Subsequent separators not to occur more than once and can not be at the very end. This function supports Latin/Cyrrilic char sets
CheckTelephone | Returns true if the value is a valid non-null/empty telephone
IsLatinLetterOrDigit |
IsValidEMailLocalPartChar |
IsValidScreenNameLetter |
IsValidScreenNameLetterOrDigit |
IsValidScreenNameSeparator |
NormalizeUSPhone | Normalizes US phone string so it looks like (999) 999-9999x9999.
SQLSafeSubstitute | Allows only safe characters and digits replacing characters that may be used in SQL injection. This method may be used to generate column names from entity IDs
Back to Top
See Also
DataEntryUtils Class
NFX.Parsing Namespace


DataEntryUtils.CheckEMail Method

DataEntryUtils CheckEMail Method NFX Class Library

Returns true if the value is a valid non-null/empty email address

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool CheckEMail(
    string email
)
public static bool CheckEMail(
    string email
)
Public Shared Function CheckEMail (
    email As String
) As Boolean
Public Shared Function CheckEMail (
    email As String
) As Boolean
public:
static bool CheckEMail(
    String^ email
)
public:
static bool CheckEMail(
    String^ email
)
static member CheckEMail :
        email : string -> bool
static member CheckEMail :
        email : string -> bool

Parameters

email
Type: Online System String

Return Value

Type: Online Boolean
See Also
DataEntryUtils Class
DataEntryUtils Members
NFX.Parsing Namespace


DataEntryUtils.CheckScreenName Method

DataEntryUtils CheckScreenName Method NFX Class Library

Returns true if the value starts from primary language char and contains only those chars separated by one of ['.','-','_']. Subsequent separators not to occur more than once and can not be at the very end. This function supports Latin/Cyrrilic char sets

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool CheckScreenName(
    string name
)
public static bool CheckScreenName(
    string name
)
Public Shared Function CheckScreenName (
    name As String
) As Boolean
Public Shared Function CheckScreenName (
    name As String
) As Boolean
public:
static bool CheckScreenName(
    String^ name
)
public:
static bool CheckScreenName(
    String^ name
)
static member CheckScreenName :
        name : string -> bool
static member CheckScreenName :
        name : string -> bool

Parameters

name
Type: Online System String

Return Value

Type: Online Boolean
See Also
DataEntryUtils Class
DataEntryUtils Members
NFX.Parsing Namespace


DataEntryUtils.CheckTelephone Method

DataEntryUtils CheckTelephone Method NFX Class Library

Returns true if the value is a valid non-null/empty telephone

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool CheckTelephone(
    string phone
)
public static bool CheckTelephone(
    string phone
)
Public Shared Function CheckTelephone (
    phone As String
) As Boolean
Public Shared Function CheckTelephone (
    phone As String
) As Boolean
public:
static bool CheckTelephone(
    String^ phone
)
public:
static bool CheckTelephone(
    String^ phone
)
static member CheckTelephone :
        phone : string -> bool
static member CheckTelephone :
        phone : string -> bool

Parameters

phone
Type: Online System String

Return Value

Type: Online Boolean
See Also
DataEntryUtils Class
DataEntryUtils Members
NFX.Parsing Namespace


DataEntryUtils.IsLatinLetterOrDigit Method

DataEntryUtils IsLatinLetterOrDigit Method NFX Class Library

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsLatinLetterOrDigit(
    char c
)
public static bool IsLatinLetterOrDigit(
    char c
)
Public Shared Function IsLatinLetterOrDigit (
    c As Char
) As Boolean
Public Shared Function IsLatinLetterOrDigit (
    c As Char
) As Boolean
public:
static bool IsLatinLetterOrDigit(
    wchar_t c
)
public:
static bool IsLatinLetterOrDigit(
    wchar_t c
)
static member IsLatinLetterOrDigit :
        c : char -> bool
static member IsLatinLetterOrDigit :
        c : char -> bool

Parameters

c
Type: Online System Char

Return Value

Type: Online Boolean
See Also
DataEntryUtils Class
DataEntryUtils Members
NFX.Parsing Namespace


DataEntryUtils.IsValidEMailLocalPartChar Method

DataEntryUtils IsValidEMailLocalPartChar Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsValidEMailLocalPartChar(
    char c
)
public static bool IsValidEMailLocalPartChar(
    char c
)
Public Shared Function IsValidEMailLocalPartChar (
    c As Char
) As Boolean
Public Shared Function IsValidEMailLocalPartChar (
    c As Char
) As Boolean
public:
static bool IsValidEMailLocalPartChar(
    wchar_t c
)
public:
static bool IsValidEMailLocalPartChar(
    wchar_t c
)
static member IsValidEMailLocalPartChar :
        c : char -> bool
static member IsValidEMailLocalPartChar :
        c : char -> bool

Parameters

c
Type: Online System Char

Return Value

Type: Online Boolean
See Also
DataEntryUtils Class
DataEntryUtils Members
NFX.Parsing Namespace


DataEntryUtils.IsValidScreenNameLetter Method

DataEntryUtils IsValidScreenNameLetter Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsValidScreenNameLetter(
    char c
)
public static bool IsValidScreenNameLetter(
    char c
)
Public Shared Function IsValidScreenNameLetter (
    c As Char
) As Boolean
Public Shared Function IsValidScreenNameLetter (
    c As Char
) As Boolean
public:
static bool IsValidScreenNameLetter(
    wchar_t c
)
public:
static bool IsValidScreenNameLetter(
    wchar_t c
)
static member IsValidScreenNameLetter :
        c : char -> bool
static member IsValidScreenNameLetter :
        c : char -> bool

Parameters

c
Type: Online System Char

Return Value

Type: Online Boolean
See Also
DataEntryUtils Class
DataEntryUtils Members
NFX.Parsing Namespace


DataEntryUtils.IsValidScreenNameLetterOrDigit Method

DataEntryUtils IsValidScreenNameLetterOrDigit Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsValidScreenNameLetterOrDigit(
    char c
)
public static bool IsValidScreenNameLetterOrDigit(
    char c
)
Public Shared Function IsValidScreenNameLetterOrDigit (
    c As Char
) As Boolean
Public Shared Function IsValidScreenNameLetterOrDigit (
    c As Char
) As Boolean
public:
static bool IsValidScreenNameLetterOrDigit(
    wchar_t c
)
public:
static bool IsValidScreenNameLetterOrDigit(
    wchar_t c
)
static member IsValidScreenNameLetterOrDigit :
        c : char -> bool
static member IsValidScreenNameLetterOrDigit :
        c : char -> bool

Parameters

c
Type: Online System Char

Return Value

Type: Online Boolean
See Also
DataEntryUtils Class
DataEntryUtils Members
NFX.Parsing Namespace


DataEntryUtils.IsValidScreenNameSeparator Method

DataEntryUtils IsValidScreenNameSeparator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsValidScreenNameSeparator(
    char c
)
public static bool IsValidScreenNameSeparator(
    char c
)
Public Shared Function IsValidScreenNameSeparator (
    c As Char
) As Boolean
Public Shared Function IsValidScreenNameSeparator (
    c As Char
) As Boolean
public:
static bool IsValidScreenNameSeparator(
    wchar_t c
)
public:
static bool IsValidScreenNameSeparator(
    wchar_t c
)
static member IsValidScreenNameSeparator :
        c : char -> bool
static member IsValidScreenNameSeparator :
        c : char -> bool

Parameters

c
Type: Online System Char

Return Value

Type: Online Boolean
See Also
DataEntryUtils Class
DataEntryUtils Members
NFX.Parsing Namespace


DataEntryUtils.NormalizeUSPhone Method

DataEntryUtils NormalizeUSPhone Method NFX Class Library

Normalizes US phone string so it looks like (999) 999-9999x9999.

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string NormalizeUSPhone(
    string value
)
public static string NormalizeUSPhone(
    string value
)
Public Shared Function NormalizeUSPhone (
    value As String
) As String
Public Shared Function NormalizeUSPhone (
    value As String
) As String
public:
static String^ NormalizeUSPhone(
    String^ value
)
public:
static String^ NormalizeUSPhone(
    String^ value
)
static member NormalizeUSPhone :
        value : string -> string
static member NormalizeUSPhone :
        value : string -> string

Parameters

value
Type: Online System String

Return Value

Type: Online String
See Also
DataEntryUtils Class
DataEntryUtils Members
NFX.Parsing Namespace


DataEntryUtils.SQLSafeSubstitute Method

DataEntryUtils SQLSafeSubstitute Method NFX Class Library

Allows only safe characters and digits replacing characters that may be used in SQL injection. This method may be used to generate column names from entity IDs

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string SQLSafeSubstitute(
    string str,
    char subst = ''
)
public static string SQLSafeSubstitute(
    string str,
    char subst = ''
)
Public Shared Function SQLSafeSubstitute (
    str As String,
    Optional subst As Char = ""C
) As String
Public Shared Function SQLSafeSubstitute (
    str As String,
    Optional subst As Char = ""C
) As String
public:
static String^ SQLSafeSubstitute(
    String^ str,
    wchar_t subst = L''
)
public:
static String^ SQLSafeSubstitute(
    String^ str,
    wchar_t subst = L''
)
static member SQLSafeSubstitute :
        str : string *
        ?subst : char
(* Defaults:
        let _subst = defaultArg subst ''
*)
-> string
static member SQLSafeSubstitute :
        str : string *
        ?subst : char
(* Defaults:
        let _subst = defaultArg subst ''
*)
-> string

Parameters

str
Type: Online System String
subst (Optional)
Type: Online System Char

Return Value

Type: Online String
See Also
DataEntryUtils Class
DataEntryUtils Members
NFX.Parsing Namespace


Evaluator Class

Evaluator Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Parsing Evaluator

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Evaluator
public sealed class Evaluator
Public NotInheritable Class Evaluator
Public NotInheritable Class Evaluator
public ref class Evaluator sealed
public ref class Evaluator sealed
[<SealedAttribute>]
type Evaluator =  class end
[<SealedAttribute>]
type Evaluator =  class end
See Also
Evaluator Members
NFX.Parsing Namespace


Evaluator Members

Evaluator Members NFX Class Library

The Evaluator type exposes the following members.
Constructors
 | Name | Description
Public method | Evaluator | Initializes a new instance of the Evaluator class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Evaluate | Evaluate expression and return result - either string or numerical value
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PrintTree | Returns b-tree traversal in a string form
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Expression | Expression beeing evaluated
Public property | NoStringsExpression | Expression with all strings replaced with tokens
Public property | Root | Root node of expression evaluation tree
Back to Top
Events
 | Name | Description
Public event | OnIdentifierLookup | Event which is fired upon leaf token resolution during evaluation, used to resolve host variables
Back to Top
See Also
Evaluator Class
NFX.Parsing Namespace


Evaluator Constructor

Evaluator Constructor NFX Class Library

Initializes a new instance of the Evaluator class

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Evaluator(
    string expression
)
public Evaluator(
    string expression
)
Public Sub New (
    expression As String
)
Public Sub New (
    expression As String
)
public:
Evaluator(
    String^ expression
)
public:
Evaluator(
    String^ expression
)
new :
        expression : string -> Evaluator
new :
        expression : string -> Evaluator

Parameters

expression
Type: Online System String
See Also
Evaluator Class
Evaluator Members
NFX.Parsing Namespace


Evaluator Methods

Evaluator Methods NFX Class Library

The Evaluator type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Evaluate | Evaluate expression and return result - either string or numerical value
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PrintTree | Returns b-tree traversal in a string form
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Evaluator Class
NFX.Parsing Namespace


Evaluator.Evaluate Method

Evaluator Evaluate Method NFX Class Library

Evaluate expression and return result - either string or numerical value

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Evaluate(
    IdentifierLookup lookup = null
)
public string Evaluate(
    IdentifierLookup lookup = null
)
Public Function Evaluate (
    Optional lookup As IdentifierLookup = Nothing
) As String
Public Function Evaluate (
    Optional lookup As IdentifierLookup = Nothing
) As String
public:
String^ Evaluate(
    IdentifierLookup^ lookup = nullptr
)
public:
String^ Evaluate(
    IdentifierLookup^ lookup = nullptr
)
member Evaluate :
        ?lookup : IdentifierLookup
(* Defaults:
        let _lookup = defaultArg lookup null
*)
-> string
member Evaluate :
        ?lookup : IdentifierLookup
(* Defaults:
        let _lookup = defaultArg lookup null
*)
-> string

Parameters

lookup (Optional)
Type: NFX.Parsing IdentifierLookup

Return Value

Type: Online String
See Also
Evaluator Class
Evaluator Members
NFX.Parsing Namespace


Evaluator.PrintTree Method

Evaluator PrintTree Method NFX Class Library

Returns b-tree traversal in a string form

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string PrintTree()
public string PrintTree()
Public Function PrintTree As String
Public Function PrintTree As String
public:
String^ PrintTree()
public:
String^ PrintTree()
member PrintTree : unit -> string
member PrintTree : unit -> string

Return Value

Type: Online String
See Also
Evaluator Class
Evaluator Members
NFX.Parsing Namespace


Evaluator Properties

Evaluator Properties NFX Class Library

The Evaluator type exposes the following members.
Properties
 | Name | Description
Public property | Expression | Expression beeing evaluated
Public property | NoStringsExpression | Expression with all strings replaced with tokens
Public property | Root | Root node of expression evaluation tree
Back to Top
See Also
Evaluator Class
NFX.Parsing Namespace


Evaluator.Expression Property

Evaluator Expression Property NFX Class Library

Expression beeing evaluated

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Expression { get; }
public string Expression { get; }
Public ReadOnly Property Expression As String
    Get
Public ReadOnly Property Expression As String
    Get
public:
property String^ Expression {
    String^ get ();
}
public:
property String^ Expression {
    String^ get ();
}
member Expression : string with get
member Expression : string with get

Property Value

Type: Online String
See Also
Evaluator Class
Evaluator Members
NFX.Parsing Namespace


Evaluator.NoStringsExpression Property

Evaluator NoStringsExpression Property NFX Class Library

Expression with all strings replaced with tokens

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string NoStringsExpression { get; }
public string NoStringsExpression { get; }
Public ReadOnly Property NoStringsExpression As String
    Get
Public ReadOnly Property NoStringsExpression As String
    Get
public:
property String^ NoStringsExpression {
    String^ get ();
}
public:
property String^ NoStringsExpression {
    String^ get ();
}
member NoStringsExpression : string with get
member NoStringsExpression : string with get

Property Value

Type: Online String
See Also
Evaluator Class
Evaluator Members
NFX.Parsing Namespace


Evaluator.Root Property

Evaluator Root Property NFX Class Library

Root node of expression evaluation tree

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Evaluator..::..Node Root { get; }
public Evaluator..::..Node Root { get; }
Public ReadOnly Property Root As Evaluator..::..Node
    Get
Public ReadOnly Property Root As Evaluator..::..Node
    Get
public:
property Evaluator..::..Node^ Root {
    Evaluator..::..Node^ get ();
}
public:
property Evaluator..::..Node^ Root {
    Evaluator..::..Node^ get ();
}
member Root : Evaluator..::..Node with get
member Root : Evaluator..::..Node with get

Property Value

Type: Evaluator Node
See Also
Evaluator Class
Evaluator Members
NFX.Parsing Namespace


Evaluator Events

Evaluator Events NFX Class Library

The Evaluator type exposes the following members.
Events
 | Name | Description
Public event | OnIdentifierLookup | Event which is fired upon leaf token resolution during evaluation, used to resolve host variables
Back to Top
See Also
Evaluator Class
NFX.Parsing Namespace


Evaluator.OnIdentifierLookup Event

Evaluator OnIdentifierLookup Event NFX Class Library

Event which is fired upon leaf token resolution during evaluation, used to resolve host variables

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event IdentifierLookup OnIdentifierLookup
public event IdentifierLookup OnIdentifierLookup
Public Event OnIdentifierLookup As IdentifierLookup
Public Event OnIdentifierLookup As IdentifierLookup
public:
 event IdentifierLookup^ OnIdentifierLookup {
    void add (IdentifierLookup^ value);
    void remove (IdentifierLookup^ value);
}
public:
 event IdentifierLookup^ OnIdentifierLookup {
    void add (IdentifierLookup^ value);
    void remove (IdentifierLookup^ value);
}
member OnIdentifierLookup : IEvent<IdentifierLookup,
    EventArgs>
member OnIdentifierLookup : IEvent<IdentifierLookup,
    EventArgs>

Value

Type: NFX.Parsing IdentifierLookup
See Also
Evaluator Class
Evaluator Members
NFX.Parsing Namespace


Evaluator.Node Class

Evaluator Node Class NFX Class Library

Node class represents evaluation b-tree element
Inheritance Hierarchy
Online System Object
NFX.Parsing Evaluator Node

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Node
public sealed class Node
Public NotInheritable Class Node
Public NotInheritable Class Node
public ref class Node sealed
public ref class Node sealed
[<SealedAttribute>]
type Node =  class end
[<SealedAttribute>]
type Node =  class end
See Also
Evaluator Node Members
NFX.Parsing Namespace


Evaluator.Node Members

Evaluator Node Members NFX Class Library

The Evaluator Node type exposes the following members.
Constructors
 | Name | Description
Public method | Evaluator Node | Initializes a new instance of the Evaluator Node class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PrintTree |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Operator |
Back to Top
Properties
 | Name | Description
Public property | Condition | Boolean condition expression (subnode) used for conditional (ternary) operator
Public property | Expression | This node sub-expression
Public property | Left | Left b-tree branch, may be blank (in case of unary operators)
Public property | Level | Node depth level within expression b-tree
Public property | Operator | Head operator performed on left and right b-tree branches
Public property | Right | Right b-tree branch, used for unary operators
Back to Top
See Also
Evaluator Node Class
NFX.Parsing Namespace


Evaluator.Node Constructor

Evaluator Node Constructor NFX Class Library

Initializes a new instance of the Evaluator Node class

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Node(
    string expression,
    int level
)
public Node(
    string expression,
    int level
)
Public Sub New (
    expression As String,
    level As Integer
)
Public Sub New (
    expression As String,
    level As Integer
)
public:
Node(
    String^ expression,
    int level
)
public:
Node(
    String^ expression,
    int level
)
new :
        expression : string *
        level : int -> Node
new :
        expression : string *
        level : int -> Node

Parameters

expression
Type: Online System String
level
Type: Online System Int32
See Also
Evaluator Node Class
Evaluator Node Members
NFX.Parsing Namespace


Evaluator.Node Fields

Evaluator Node Fields NFX Class Library

The Evaluator Node type exposes the following members.
Fields
 | Name | Description
Protected field | m_Operator |
Back to Top
See Also
Evaluator Node Class
NFX.Parsing Namespace


Evaluator.Node.m_Operator Field

Evaluator Node m_Operator Field NFX Class Library

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal string m_Operator
internal string m_Operator
Friend m_Operator As String
Friend m_Operator As String
internal:
String^ m_Operator
internal:
String^ m_Operator
val mutable internal m_Operator: string
val mutable internal m_Operator: string

Field Value

Type: Online String
See Also
Evaluator Node Class
Evaluator Node Members
NFX.Parsing Namespace


Evaluator.Node Methods

Evaluator Node Methods NFX Class Library

The Evaluator Node type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PrintTree |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Evaluator Node Class
NFX.Parsing Namespace


Evaluator.Node.PrintTree Method

Evaluator Node PrintTree Method NFX Class Library

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string PrintTree()
public string PrintTree()
Public Function PrintTree As String
Public Function PrintTree As String
public:
String^ PrintTree()
public:
String^ PrintTree()
member PrintTree : unit -> string
member PrintTree : unit -> string

Return Value

Type: Online String
See Also
Evaluator Node Class
Evaluator Node Members
NFX.Parsing Namespace


Evaluator.Node Properties

Evaluator Node Properties NFX Class Library

The Evaluator Node type exposes the following members.
Properties
 | Name | Description
Public property | Condition | Boolean condition expression (subnode) used for conditional (ternary) operator
Public property | Expression | This node sub-expression
Public property | Left | Left b-tree branch, may be blank (in case of unary operators)
Public property | Level | Node depth level within expression b-tree
Public property | Operator | Head operator performed on left and right b-tree branches
Public property | Right | Right b-tree branch, used for unary operators
Back to Top
See Also
Evaluator Node Class
NFX.Parsing Namespace


Evaluator.Node.Condition Property

Evaluator Node Condition Property NFX Class Library

Boolean condition expression (subnode) used for conditional (ternary) operator

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Evaluator..::..Node Condition { get; }
public Evaluator..::..Node Condition { get; }
Public ReadOnly Property Condition As Evaluator..::..Node
    Get
Public ReadOnly Property Condition As Evaluator..::..Node
    Get
public:
property Evaluator..::..Node^ Condition {
    Evaluator..::..Node^ get ();
}
public:
property Evaluator..::..Node^ Condition {
    Evaluator..::..Node^ get ();
}
member Condition : Evaluator..::..Node with get
member Condition : Evaluator..::..Node with get

Property Value

Type: Evaluator Node
See Also
Evaluator Node Class
Evaluator Node Members
NFX.Parsing Namespace


Evaluator.Node.Expression Property

Evaluator Node Expression Property NFX Class Library

This node sub-expression

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Expression { get; }
public string Expression { get; }
Public ReadOnly Property Expression As String
    Get
Public ReadOnly Property Expression As String
    Get
public:
property String^ Expression {
    String^ get ();
}
public:
property String^ Expression {
    String^ get ();
}
member Expression : string with get
member Expression : string with get

Property Value

Type: Online String
See Also
Evaluator Node Class
Evaluator Node Members
NFX.Parsing Namespace


Evaluator.Node.Left Property

Evaluator Node Left Property NFX Class Library

Left b-tree branch, may be blank (in case of unary operators)

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Evaluator..::..Node Left { get; }
public Evaluator..::..Node Left { get; }
Public ReadOnly Property Left As Evaluator..::..Node
    Get
Public ReadOnly Property Left As Evaluator..::..Node
    Get
public:
property Evaluator..::..Node^ Left {
    Evaluator..::..Node^ get ();
}
public:
property Evaluator..::..Node^ Left {
    Evaluator..::..Node^ get ();
}
member Left : Evaluator..::..Node with get
member Left : Evaluator..::..Node with get

Property Value

Type: Evaluator Node
See Also
Evaluator Node Class
Evaluator Node Members
NFX.Parsing Namespace


Evaluator.Node.Level Property

Evaluator Node Level Property NFX Class Library

Node depth level within expression b-tree

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Level { get; }
public int Level { get; }
Public ReadOnly Property Level As Integer
    Get
Public ReadOnly Property Level As Integer
    Get
public:
property int Level {
    int get ();
}
public:
property int Level {
    int get ();
}
member Level : int with get
member Level : int with get

Property Value

Type: Online Int32
See Also
Evaluator Node Class
Evaluator Node Members
NFX.Parsing Namespace


Evaluator.Node.Operator Property

Evaluator Node Operator Property NFX Class Library

Head operator performed on left and right b-tree branches

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Operator { get; }
public string Operator { get; }
Public ReadOnly Property Operator As String
    Get
Public ReadOnly Property Operator As String
    Get
public:
property String^ Operator {
    String^ get ();
}
public:
property String^ Operator {
    String^ get ();
}
member Operator : string with get
member Operator : string with get

Property Value

Type: Online String
See Also
Evaluator Node Class
Evaluator Node Members
NFX.Parsing Namespace


Evaluator.Node.Right Property

Evaluator Node Right Property NFX Class Library

Right b-tree branch, used for unary operators

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Evaluator..::..Node Right { get; }
public Evaluator..::..Node Right { get; }
Public ReadOnly Property Right As Evaluator..::..Node
    Get
Public ReadOnly Property Right As Evaluator..::..Node
    Get
public:
property Evaluator..::..Node^ Right {
    Evaluator..::..Node^ get ();
}
public:
property Evaluator..::..Node^ Right {
    Evaluator..::..Node^ get ();
}
member Right : Evaluator..::..Node with get
member Right : Evaluator..::..Node with get

Property Value

Type: Evaluator Node
See Also
Evaluator Node Class
Evaluator Node Members
NFX.Parsing Namespace


IdentifierLookup Delegate

IdentifierLookup Delegate NFX Class Library

Evaluator class performs math and logical expression parsing and evaluation without allocating .NET compilers

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate string IdentifierLookup(
    string ident
)
public delegate string IdentifierLookup(
    string ident
)
Public Delegate Function IdentifierLookup (
    ident As String
) As String
Public Delegate Function IdentifierLookup (
    ident As String
) As String
public delegate String^ IdentifierLookup(
    String^ ident
)
public delegate String^ IdentifierLookup(
    String^ ident
)
type IdentifierLookup =
    delegate of
        ident : string -> string
type IdentifierLookup =
    delegate of
        ident : string -> string

Parameters

ident
Type: Online System String

Return Value

Type: Online String
See Also
NFX.Parsing Namespace


NaturalTextGenerator Class

NaturalTextGenerator Class NFX Class Library

Generates human-readable English text for tests
Inheritance Hierarchy
Online System Object
NFX.Parsing NaturalTextGenerator

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class NaturalTextGenerator
public static class NaturalTextGenerator
Public NotInheritable Class NaturalTextGenerator
Public NotInheritable Class NaturalTextGenerator
public ref class NaturalTextGenerator abstract sealed
public ref class NaturalTextGenerator abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type NaturalTextGenerator =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type NaturalTextGenerator =  class end
See Also
NaturalTextGenerator Members
NFX.Parsing Namespace


NaturalTextGenerator Members

NaturalTextGenerator Members NFX Class Library

The NaturalTextGenerator type exposes the following members.
Methods
Name | Description
Generate | Generates human-readable English text of up to specified length which is of 10 chars at minimum. If zero passed then generates msg of random length
GenerateAddressLine | Generates a string that resembles an address line
GenerateCityName | Generates a string that resembles a city name
GenerateEMail | Generates a string that looks like an email
GenerateFirstName | Generates a string that resembles a human first name
GenerateFullName | Generates a string that looks like a human name
GenerateLastName | Generates a string that resembles a human last name
GenerateUSCityStateZip | Generates a string that resembles a city/state/zip in a US address. The states/zips are NOT consistent
GenerateWord | Generates a random English word which is of the specified size. The min size must be of at least 4 chars
Back to Top
Fields
Name | Description
CITY_SUFFIXES |
DOMAIN_NAMES |
LAST_NAME_SUFFIXES |
POPULAR_CITY_NAMES |
POPULAR_FIRST_NAMES |
POPULAR_LAST_NAMES |
STREET_SUFFIXES |
TLD_NAMES |
US_STATES |
Back to Top
See Also
NaturalTextGenerator Class
NFX.Parsing Namespace


NaturalTextGenerator Fields

NaturalTextGenerator Fields NFX Class Library

The NaturalTextGenerator type exposes the following members.
Fields
Name | Description
CITY_SUFFIXES |
DOMAIN_NAMES |
LAST_NAME_SUFFIXES |
POPULAR_CITY_NAMES |
POPULAR_FIRST_NAMES |
POPULAR_LAST_NAMES |
STREET_SUFFIXES |
TLD_NAMES |
US_STATES |
Back to Top
See Also
NaturalTextGenerator Class
NFX.Parsing Namespace


NaturalTextGenerator.CITY_SUFFIXES Field

NaturalTextGenerator CITY_SUFFIXES Field NFX Class Library

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string[] CITY_SUFFIXES
public static readonly string[] CITY_SUFFIXES
Public Shared ReadOnly CITY_SUFFIXES As String()
Public Shared ReadOnly CITY_SUFFIXES As String()
public:
static initonly array<String^>^ CITY_SUFFIXES
public:
static initonly array<String^>^ CITY_SUFFIXES
static val CITY_SUFFIXES: string[]
static val CITY_SUFFIXES: string[]

Field Value

Type: Online String
See Also
NaturalTextGenerator Class
NaturalTextGenerator Members
NFX.Parsing Namespace


NaturalTextGenerator.DOMAIN_NAMES Field

NaturalTextGenerator DOMAIN_NAMES Field NFX Class Library

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string[] DOMAIN_NAMES
public static readonly string[] DOMAIN_NAMES
Public Shared ReadOnly DOMAIN_NAMES As String()
Public Shared ReadOnly DOMAIN_NAMES As String()
public:
static initonly array<String^>^ DOMAIN_NAMES
public:
static initonly array<String^>^ DOMAIN_NAMES
static val DOMAIN_NAMES: string[]
static val DOMAIN_NAMES: string[]

Field Value

Type: Online String
See Also
NaturalTextGenerator Class
NaturalTextGenerator Members
NFX.Parsing Namespace


NaturalTextGenerator.LAST_NAME_SUFFIXES Field

NaturalTextGenerator LAST_NAME_SUFFIXES Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string[] LAST_NAME_SUFFIXES
public static readonly string[] LAST_NAME_SUFFIXES
Public Shared ReadOnly LAST_NAME_SUFFIXES As String()
Public Shared ReadOnly LAST_NAME_SUFFIXES As String()
public:
static initonly array<String^>^ LAST_NAME_SUFFIXES
public:
static initonly array<String^>^ LAST_NAME_SUFFIXES
static val LAST_NAME_SUFFIXES: string[]
static val LAST_NAME_SUFFIXES: string[]

Field Value

Type: Online String
See Also
NaturalTextGenerator Class
NaturalTextGenerator Members
NFX.Parsing Namespace


NaturalTextGenerator.POPULAR_CITY_NAMES Field

NaturalTextGenerator POPULAR_CITY_NAMES Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string[] POPULAR_CITY_NAMES
public static readonly string[] POPULAR_CITY_NAMES
Public Shared ReadOnly POPULAR_CITY_NAMES As String()
Public Shared ReadOnly POPULAR_CITY_NAMES As String()
public:
static initonly array<String^>^ POPULAR_CITY_NAMES
public:
static initonly array<String^>^ POPULAR_CITY_NAMES
static val POPULAR_CITY_NAMES: string[]
static val POPULAR_CITY_NAMES: string[]

Field Value

Type: Online String
See Also
NaturalTextGenerator Class
NaturalTextGenerator Members
NFX.Parsing Namespace


NaturalTextGenerator.POPULAR_FIRST_NAMES Field

NaturalTextGenerator POPULAR_FIRST_NAMES Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string[] POPULAR_FIRST_NAMES
public static readonly string[] POPULAR_FIRST_NAMES
Public Shared ReadOnly POPULAR_FIRST_NAMES As String()
Public Shared ReadOnly POPULAR_FIRST_NAMES As String()
public:
static initonly array<String^>^ POPULAR_FIRST_NAMES
public:
static initonly array<String^>^ POPULAR_FIRST_NAMES
static val POPULAR_FIRST_NAMES: string[]
static val POPULAR_FIRST_NAMES: string[]

Field Value

Type: Online String
See Also
NaturalTextGenerator Class
NaturalTextGenerator Members
NFX.Parsing Namespace


NaturalTextGenerator.POPULAR_LAST_NAMES Field

NaturalTextGenerator POPULAR_LAST_NAMES Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string[] POPULAR_LAST_NAMES
public static readonly string[] POPULAR_LAST_NAMES
Public Shared ReadOnly POPULAR_LAST_NAMES As String()
Public Shared ReadOnly POPULAR_LAST_NAMES As String()
public:
static initonly array<String^>^ POPULAR_LAST_NAMES
public:
static initonly array<String^>^ POPULAR_LAST_NAMES
static val POPULAR_LAST_NAMES: string[]
static val POPULAR_LAST_NAMES: string[]

Field Value

Type: Online String
See Also
NaturalTextGenerator Class
NaturalTextGenerator Members
NFX.Parsing Namespace


NaturalTextGenerator.STREET_SUFFIXES Field

NaturalTextGenerator STREET_SUFFIXES Field NFX Class Library

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string[] STREET_SUFFIXES
public static readonly string[] STREET_SUFFIXES
Public Shared ReadOnly STREET_SUFFIXES As String()
Public Shared ReadOnly STREET_SUFFIXES As String()
public:
static initonly array<String^>^ STREET_SUFFIXES
public:
static initonly array<String^>^ STREET_SUFFIXES
static val STREET_SUFFIXES: string[]
static val STREET_SUFFIXES: string[]

Field Value

Type: Online String
See Also
NaturalTextGenerator Class
NaturalTextGenerator Members
NFX.Parsing Namespace


NaturalTextGenerator.TLD_NAMES Field

NaturalTextGenerator TLD_NAMES Field NFX Class Library

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string[] TLD_NAMES
public static readonly string[] TLD_NAMES
Public Shared ReadOnly TLD_NAMES As String()
Public Shared ReadOnly TLD_NAMES As String()
public:
static initonly array<String^>^ TLD_NAMES
public:
static initonly array<String^>^ TLD_NAMES
static val TLD_NAMES: string[]
static val TLD_NAMES: string[]

Field Value

Type: Online String
See Also
NaturalTextGenerator Class
NaturalTextGenerator Members
NFX.Parsing Namespace


NaturalTextGenerator.US_STATES Field

NaturalTextGenerator US_STATES Field NFX Class Library

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string[] US_STATES
public static readonly string[] US_STATES
Public Shared ReadOnly US_STATES As String()
Public Shared ReadOnly US_STATES As String()
public:
static initonly array<String^>^ US_STATES
public:
static initonly array<String^>^ US_STATES
static val US_STATES: string[]
static val US_STATES: string[]

Field Value

Type: Online String
See Also
NaturalTextGenerator Class
NaturalTextGenerator Members
NFX.Parsing Namespace


NaturalTextGenerator Methods

NaturalTextGenerator Methods NFX Class Library

The NaturalTextGenerator type exposes the following members.
Methods
Name | Description
Generate | Generates human-readable English text of up to specified length which is of 10 chars at minimum. If zero passed then generates msg of random length
GenerateAddressLine | Generates a string that resembles an address line
GenerateCityName | Generates a string that resembles a city name
GenerateEMail | Generates a string that looks like an email
GenerateFirstName | Generates a string that resembles a human first name
GenerateFullName | Generates a string that looks like a human name
GenerateLastName | Generates a string that resembles a human last name
GenerateUSCityStateZip | Generates a string that resembles a city/state/zip in a US address. The states/zips are NOT consistent
GenerateWord | Generates a random English word which is of the specified size. The min size must be of at least 4 chars
Back to Top
See Also
NaturalTextGenerator Class
NFX.Parsing Namespace


NaturalTextGenerator.Generate Method

NaturalTextGenerator Generate Method NFX Class Library

Generates human-readable English text of up to specified length which is of 10 chars at minimum. If zero passed then generates msg of random length

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Generate(
    int length = 150
)
public static string Generate(
    int length = 150
)
Public Shared Function Generate (
    Optional length As Integer = 150
) As String
Public Shared Function Generate (
    Optional length As Integer = 150
) As String
public:
static String^ Generate(
    int length = 150
)
public:
static String^ Generate(
    int length = 150
)
static member Generate :
        ?length : int
(* Defaults:
        let _length = defaultArg length 150
*)
-> string
static member Generate :
        ?length : int
(* Defaults:
        let _length = defaultArg length 150
*)
-> string

Parameters

length (Optional)
Type: Online System Int32

Return Value

Type: Online String
See Also
NaturalTextGenerator Class
NaturalTextGenerator Members
NFX.Parsing Namespace


NaturalTextGenerator.GenerateAddressLine Method

NaturalTextGenerator GenerateAddressLine Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Generates a string that resembles an address line

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GenerateAddressLine()
public static string GenerateAddressLine()
Public Shared Function GenerateAddressLine As String
Public Shared Function GenerateAddressLine As String
public:
static String^ GenerateAddressLine()
public:
static String^ GenerateAddressLine()
static member GenerateAddressLine : unit -> string
static member GenerateAddressLine : unit -> string

Return Value

Type: Online String
See Also
NaturalTextGenerator Class
NaturalTextGenerator Members
NFX.Parsing Namespace


NaturalTextGenerator.GenerateCityName Method

NaturalTextGenerator GenerateCityName Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Generates a string that resembles a city name

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GenerateCityName()
public static string GenerateCityName()
Public Shared Function GenerateCityName As String
Public Shared Function GenerateCityName As String
public:
static String^ GenerateCityName()
public:
static String^ GenerateCityName()
static member GenerateCityName : unit -> string
static member GenerateCityName : unit -> string

Return Value

Type: Online String
See Also
NaturalTextGenerator Class
NaturalTextGenerator Members
NFX.Parsing Namespace


NaturalTextGenerator.GenerateEMail Method

NaturalTextGenerator GenerateEMail Method NFX Class Library

Generates a string that looks like an email

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GenerateEMail()
public static string GenerateEMail()
Public Shared Function GenerateEMail As String
Public Shared Function GenerateEMail As String
public:
static String^ GenerateEMail()
public:
static String^ GenerateEMail()
static member GenerateEMail : unit -> string
static member GenerateEMail : unit -> string

Return Value

Type: Online String
See Also
NaturalTextGenerator Class
NaturalTextGenerator Members
NFX.Parsing Namespace


NaturalTextGenerator.GenerateFirstName Method

NaturalTextGenerator GenerateFirstName Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Generates a string that resembles a human first name

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GenerateFirstName()
public static string GenerateFirstName()
Public Shared Function GenerateFirstName As String
Public Shared Function GenerateFirstName As String
public:
static String^ GenerateFirstName()
public:
static String^ GenerateFirstName()
static member GenerateFirstName : unit -> string
static member GenerateFirstName : unit -> string

Return Value

Type: Online String
See Also
NaturalTextGenerator Class
NaturalTextGenerator Members
NFX.Parsing Namespace


NaturalTextGenerator.GenerateFullName Method

NaturalTextGenerator GenerateFullName Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Generates a string that looks like a human name

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GenerateFullName(
    bool middle = false
)
public static string GenerateFullName(
    bool middle = false
)
Public Shared Function GenerateFullName (
    Optional middle As Boolean = false
) As String
Public Shared Function GenerateFullName (
    Optional middle As Boolean = false
) As String
public:
static String^ GenerateFullName(
    bool middle = false
)
public:
static String^ GenerateFullName(
    bool middle = false
)
static member GenerateFullName :
        ?middle : bool
(* Defaults:
        let _middle = defaultArg middle false
*)
-> string
static member GenerateFullName :
        ?middle : bool
(* Defaults:
        let _middle = defaultArg middle false
*)
-> string

Parameters

middle (Optional)
Type: Online System Boolean

Return Value

Type: Online String
See Also
NaturalTextGenerator Class
NaturalTextGenerator Members
NFX.Parsing Namespace


NaturalTextGenerator.GenerateLastName Method

NaturalTextGenerator GenerateLastName Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Generates a string that resembles a human last name

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GenerateLastName()
public static string GenerateLastName()
Public Shared Function GenerateLastName As String
Public Shared Function GenerateLastName As String
public:
static String^ GenerateLastName()
public:
static String^ GenerateLastName()
static member GenerateLastName : unit -> string
static member GenerateLastName : unit -> string

Return Value

Type: Online String
See Also
NaturalTextGenerator Class
NaturalTextGenerator Members
NFX.Parsing Namespace


NaturalTextGenerator.GenerateUSCityStateZip Method

NaturalTextGenerator GenerateUSCityStateZip Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Generates a string that resembles a city/state/zip in a US address. The states/zips are NOT consistent

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GenerateUSCityStateZip()
public static string GenerateUSCityStateZip()
Public Shared Function GenerateUSCityStateZip As String
Public Shared Function GenerateUSCityStateZip As String
public:
static String^ GenerateUSCityStateZip()
public:
static String^ GenerateUSCityStateZip()
static member GenerateUSCityStateZip : unit -> string
static member GenerateUSCityStateZip : unit -> string

Return Value

Type: Online String
See Also
NaturalTextGenerator Class
NaturalTextGenerator Members
NFX.Parsing Namespace


NaturalTextGenerator.GenerateWord Method

NaturalTextGenerator GenerateWord Method NFX Class Library

Generates a random English word which is of the specified size. The min size must be of at least 4 chars

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GenerateWord(
    int minLength = 4,
    int maxLength = 20
)
public static string GenerateWord(
    int minLength = 4,
    int maxLength = 20
)
Public Shared Function GenerateWord (
    Optional minLength As Integer = 4,
    Optional maxLength As Integer = 20
) As String
Public Shared Function GenerateWord (
    Optional minLength As Integer = 4,
    Optional maxLength As Integer = 20
) As String
public:
static String^ GenerateWord(
    int minLength = 4,
    int maxLength = 20
)
public:
static String^ GenerateWord(
    int minLength = 4,
    int maxLength = 20
)
static member GenerateWord :
        ?minLength : int *
        ?maxLength : int
(* Defaults:
        let _minLength = defaultArg minLength 4
        let _maxLength = defaultArg maxLength 20
*)
-> string
static member GenerateWord :
        ?minLength : int *
        ?maxLength : int
(* Defaults:
        let _minLength = defaultArg minLength 4
        let _maxLength = defaultArg maxLength 20
*)
-> string

Parameters

minLength (Optional)
Type: Online System Int32
maxLength (Optional)
Type: Online System Int32

Return Value

Type: Online String
See Also
NaturalTextGenerator Class
NaturalTextGenerator Members
NFX.Parsing Namespace


TokenParser Class

TokenParser Class NFX Class Library

TokenParser class translates tokenized content string to an array list of parsed tokens with attributes
Inheritance Hierarchy
Online System Object
Online System.Collections.Generic List TokenParser Token
NFX.Parsing TokenParser

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TokenParser : List<TokenParser..::..Token>
public class TokenParser : List<TokenParser..::..Token>
Public Class TokenParser
    Inherits List(Of TokenParser..::..Token)
Public Class TokenParser
    Inherits List(Of TokenParser..::..Token)
public ref class TokenParser : public List<TokenParser..::..Token^>
public ref class TokenParser : public List<TokenParser..::..Token^>
type TokenParser =
    class
        inherit List<TokenParser..::..Token>
    end
type TokenParser =
    class
        inherit List<TokenParser..::..Token>
    end
See Also
TokenParser Members
NFX.Parsing Namespace


TokenParser Members

TokenParser Members NFX Class Library

The TokenParser type exposes the following members.
Constructors
 | Name | Description
Public method | TokenParser(String) | Initializes a new instance of the TokenParser class
Public method | TokenParser(String, Char, Char) | Initializes a new instance of the TokenParser class
Back to Top
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List TokenParser Token .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List TokenParser Token .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List TokenParser Token .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List TokenParser Token .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List TokenParser Token .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List TokenParser Token .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List TokenParser Token .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List TokenParser Token .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List TokenParser Token .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List TokenParser Token .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List TokenParser Token .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List TokenParser Token .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List TokenParser Token .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List TokenParser Token .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List TokenParser Token .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List TokenParser Token .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List TokenParser Token .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List TokenParser Token .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List TokenParser Token .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List TokenParser Token .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List TokenParser Token .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List TokenParser Token .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List TokenParser Token .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List TokenParser Token .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List TokenParser Token .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List TokenParser Token .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List TokenParser Token .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List TokenParser Token .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List TokenParser Token .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List TokenParser Token .)
Public property | Content | Retrieves raw unparsed content
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List TokenParser Token .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List TokenParser Token .)
Back to Top
See Also
TokenParser Class
NFX.Parsing Namespace


TokenParser Constructor

TokenParser Constructor NFX Class Library

Overload List
 | Name | Description
Public method | TokenParser(String) | Initializes a new instance of the TokenParser class
Public method | TokenParser(String, Char, Char) | Initializes a new instance of the TokenParser class
Back to Top
See Also
TokenParser Class
TokenParser Members
NFX.Parsing Namespace


TokenParser Constructor (String)

TokenParser Constructor (String) NFX Class Library

Initializes a new instance of the TokenParser class

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TokenParser(
    string content
)
public TokenParser(
    string content
)
Public Sub New (
    content As String
)
Public Sub New (
    content As String
)
public:
TokenParser(
    String^ content
)
public:
TokenParser(
    String^ content
)
new :
        content : string -> TokenParser
new :
        content : string -> TokenParser

Parameters

content
Type: Online System String
See Also
TokenParser Class
TokenParser Members
TokenParser Overload
NFX.Parsing Namespace


TokenParser Constructor (String, Char, Char)

TokenParser Constructor (String, Char, Char) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TokenParser class

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TokenParser(
    string content,
    char open,
    char close
)
public TokenParser(
    string content,
    char open,
    char close
)
Public Sub New (
    content As String,
    open As Char,
    close As Char
)
Public Sub New (
    content As String,
    open As Char,
    close As Char
)
public:
TokenParser(
    String^ content,
    wchar_t open,
    wchar_t close
)
public:
TokenParser(
    String^ content,
    wchar_t open,
    wchar_t close
)
new :
        content : string *
        open : char *
        close : char -> TokenParser
new :
        content : string *
        open : char *
        close : char -> TokenParser

Parameters

content
Type: Online System String
open
Type: Online System Char
close
Type: Online System Char
See Also
TokenParser Class
TokenParser Members
TokenParser Overload
NFX.Parsing Namespace


TokenParser Methods

TokenParser Methods NFX Class Library

The TokenParser type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List TokenParser Token .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List TokenParser Token .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List TokenParser Token .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List TokenParser Token .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List TokenParser Token .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List TokenParser Token .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List TokenParser Token .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List TokenParser Token .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List TokenParser Token .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List TokenParser Token .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List TokenParser Token .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List TokenParser Token .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List TokenParser Token .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List TokenParser Token .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List TokenParser Token .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List TokenParser Token .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List TokenParser Token .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List TokenParser Token .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List TokenParser Token .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List TokenParser Token .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List TokenParser Token .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List TokenParser Token .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List TokenParser Token .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List TokenParser Token .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List TokenParser Token .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List TokenParser Token .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List TokenParser Token .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List TokenParser Token .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List TokenParser Token .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List TokenParser Token .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TokenParser Class
NFX.Parsing Namespace


TokenParser Properties

TokenParser Properties NFX Class Library

The TokenParser type exposes the following members.
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List TokenParser Token .)
Public property | Content | Retrieves raw unparsed content
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List TokenParser Token .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List TokenParser Token .)
Back to Top
See Also
TokenParser Class
NFX.Parsing Namespace


TokenParser.Content Property

TokenParser Content Property NFX Class Library

Retrieves raw unparsed content

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Content { get; }
public string Content { get; }
Public ReadOnly Property Content As String
    Get
Public ReadOnly Property Content As String
    Get
public:
property String^ Content {
    String^ get ();
}
public:
property String^ Content {
    String^ get ();
}
member Content : string with get
member Content : string with get

Property Value

Type: Online String
See Also
TokenParser Class
TokenParser Members
NFX.Parsing Namespace


TokenParser.Token Class

TokenParser Token Class NFX Class Library

Token class holds parsed token info along with an array of attributes
Inheritance Hierarchy
Online System Object
Online System.Collections Hashtable
NFX.Parsing TokenParser Token

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Token : Hashtable
public class Token : Hashtable
Public Class Token
    Inherits Hashtable
Public Class Token
    Inherits Hashtable
public ref class Token : public Hashtable
public ref class Token : public Hashtable
type Token =
    class
        inherit Hashtable
    end
type Token =
    class
        inherit Hashtable
    end
See Also
TokenParser Token Members
NFX.Parsing Namespace


TokenParser.Token Members

TokenParser Token Members NFX Class Library

The TokenParser Token type exposes the following members.
Constructors
 | Name | Description
Public method | TokenParser Token | Initializes a new instance of the TokenParser Token class
Back to Top
Methods
 | Name | Description
Public method | Online Add | (Inherited from Online Hashtable.)
Public method | Online Clear | (Inherited from Online Hashtable.)
Public method | Online Clone | (Inherited from Online Hashtable.)
Public method | Online Contains | (Inherited from Online Hashtable.)
Public method | Online ContainsKey | (Inherited from Online Hashtable.)
Public method | Online ContainsValue | (Inherited from Online Hashtable.)
Public method | Online CopyTo | (Inherited from Online Hashtable.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | (Inherited from Online Hashtable.)
Protected method | Online GetHash | (Inherited from Online Hashtable.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online Hashtable. (Inherited from Online Hashtable.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online KeyEquals | (Inherited from Online Hashtable.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online Hashtable.)
Public method | Online Remove | (Inherited from Online Hashtable.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Protected property | Online comparer | Obsolete. Gets or sets the Online IComparer to use for the Online Hashtable. (Inherited from Online Hashtable.)
Public property | Content | A string representing whole token body, in between open and close chars
Public property | Online Count | (Inherited from Online Hashtable.)
Protected property | Online EqualityComparer | (Inherited from Online Hashtable.)
Protected property | Online hcp | Obsolete. Gets or sets the object that can dispense hash codes. (Inherited from Online Hashtable.)
Public property | Online IsFixedSize | (Inherited from Online Hashtable.)
Public property | Online IsReadOnly | (Inherited from Online Hashtable.)
Public property | IsSimpleText | True if a token represents literal text that gets embedded in response as is
Public property | Online IsSynchronized | (Inherited from Online Hashtable.)
Public property | Online Item Object | (Inherited from Online Hashtable.)
Public property | Item String |
Public property | Online Keys | (Inherited from Online Hashtable.)
Public property | Name | A string representing token name - first identifier within token content
Public property | Online SyncRoot | (Inherited from Online Hashtable.)
Public property | Online Values | (Inherited from Online Hashtable.)
Back to Top
See Also
TokenParser Token Class
NFX.Parsing Namespace


TokenParser.Token Constructor

TokenParser Token Constructor NFX Class Library

Initializes a new instance of the TokenParser Token class

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Token(
    bool simple,
    string content
)
public Token(
    bool simple,
    string content
)
Public Sub New (
    simple As Boolean,
    content As String
)
Public Sub New (
    simple As Boolean,
    content As String
)
public:
Token(
    bool simple,
    String^ content
)
public:
Token(
    bool simple,
    String^ content
)
new :
        simple : bool *
        content : string -> Token
new :
        simple : bool *
        content : string -> Token

Parameters

simple
Type: Online System Boolean
content
Type: Online System String
See Also
TokenParser Token Class
TokenParser Token Members
NFX.Parsing Namespace


TokenParser.Token Methods

TokenParser Token Methods NFX Class Library

The TokenParser Token type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | (Inherited from Online Hashtable.)
Public method | Online Clear | (Inherited from Online Hashtable.)
Public method | Online Clone | (Inherited from Online Hashtable.)
Public method | Online Contains | (Inherited from Online Hashtable.)
Public method | Online ContainsKey | (Inherited from Online Hashtable.)
Public method | Online ContainsValue | (Inherited from Online Hashtable.)
Public method | Online CopyTo | (Inherited from Online Hashtable.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | (Inherited from Online Hashtable.)
Protected method | Online GetHash | (Inherited from Online Hashtable.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online Hashtable. (Inherited from Online Hashtable.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online KeyEquals | (Inherited from Online Hashtable.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online Hashtable.)
Public method | Online Remove | (Inherited from Online Hashtable.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TokenParser Token Class
NFX.Parsing Namespace


TokenParser.Token Properties

TokenParser Token Properties NFX Class Library

The TokenParser Token type exposes the following members.
Properties
 | Name | Description
Protected property | Online comparer | Obsolete. Gets or sets the Online IComparer to use for the Online Hashtable. (Inherited from Online Hashtable.)
Public property | Content | A string representing whole token body, in between open and close chars
Public property | Online Count | (Inherited from Online Hashtable.)
Protected property | Online EqualityComparer | (Inherited from Online Hashtable.)
Protected property | Online hcp | Obsolete. Gets or sets the object that can dispense hash codes. (Inherited from Online Hashtable.)
Public property | Online IsFixedSize | (Inherited from Online Hashtable.)
Public property | Online IsReadOnly | (Inherited from Online Hashtable.)
Public property | IsSimpleText | True if a token represents literal text that gets embedded in response as is
Public property | Online IsSynchronized | (Inherited from Online Hashtable.)
Public property | Online Item Object | (Inherited from Online Hashtable.)
Public property | Item String |
Public property | Online Keys | (Inherited from Online Hashtable.)
Public property | Name | A string representing token name - first identifier within token content
Public property | Online SyncRoot | (Inherited from Online Hashtable.)
Public property | Online Values | (Inherited from Online Hashtable.)
Back to Top
See Also
TokenParser Token Class
NFX.Parsing Namespace


TokenParser.Token.Content Property

TokenParser Token Content Property NFX Class Library

A string representing whole token body, in between open and close chars

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Content { get; }
public string Content { get; }
Public ReadOnly Property Content As String
    Get
Public ReadOnly Property Content As String
    Get
public:
property String^ Content {
    String^ get ();
}
public:
property String^ Content {
    String^ get ();
}
member Content : string with get
member Content : string with get

Property Value

Type: Online String
See Also
TokenParser Token Class
TokenParser Token Members
NFX.Parsing Namespace


TokenParser.Token.IsSimpleText Property

TokenParser Token IsSimpleText Property NFX Class Library

True if a token represents literal text that gets embedded in response as is

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsSimpleText { get; }
public bool IsSimpleText { get; }
Public ReadOnly Property IsSimpleText As Boolean
    Get
Public ReadOnly Property IsSimpleText As Boolean
    Get
public:
property bool IsSimpleText {
    bool get ();
}
public:
property bool IsSimpleText {
    bool get ();
}
member IsSimpleText : bool with get
member IsSimpleText : bool with get

Property Value

Type: Online Boolean
See Also
TokenParser Token Class
TokenParser Token Members
NFX.Parsing Namespace


TokenParser.Token.Item Property

TokenParser Token Item Property NFX Class Library

Overload List
 | Name | Description
Public property | Online Item Object | (Inherited from Online Hashtable.)
Public property | Item String |
Back to Top
See Also
TokenParser Token Class
TokenParser Token Members
NFX.Parsing Namespace


TokenParser.Token.Item Property (String)

TokenParser Token Item Property (String) NFX Class Library

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string this[
    string key
] { get; }
public string this[
    string key
] { get; }
Public ReadOnly Default Property Item (
    key As String
) As String
    Get
Public ReadOnly Default Property Item (
    key As String
) As String
    Get
public:
property String^ default[String^ key] {
    String^ get (String^ key);
}
public:
property String^ default[String^ key] {
    String^ get (String^ key);
}
member Item : string with get
member Item : string with get

Parameters

key
Type: Online System String

Property Value

Type: Online String
See Also
TokenParser Token Class
TokenParser Token Members
Item Overload
NFX.Parsing Namespace


TokenParser.Token.Name Property

TokenParser Token Name Property NFX Class Library

A string representing token name - first identifier within token content

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
public:
property String^ Name {
    String^ get ();
}
member Name : string with get
member Name : string with get

Property Value

Type: Online String
See Also
TokenParser Token Class
TokenParser Token Members
NFX.Parsing Namespace


TokenParser.Token.Attribute Class

TokenParser Token Attribute Class NFX Class Library

Attribute class represents token's attribute
Inheritance Hierarchy
Online System Object
NFX.Parsing TokenParser Token Attribute

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Attribute
public class Attribute
Public Class Attribute
Public Class Attribute
public ref class Attribute
public ref class Attribute
type Attribute =  class end
type Attribute =  class end
See Also
TokenParser Token Attribute Members
NFX.Parsing Namespace


TokenParser.Token.Attribute Members

TokenParser Token Attribute Members NFX Class Library

The TokenParser Token Attribute type exposes the following members.
Constructors
 | Name | Description
Public method | TokenParser Token Attribute | Initializes a new instance of the TokenParser Token Attribute class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ContentIndex | Attribute body index in content string
Public property | ContentLength | Attribute body length in content string
Public property | Index | Attribute index (0-based position) within token tag parse order
Public property | Name | Represents token's attribute name
Public property | Value | Represents token's attribute value
Back to Top
See Also
TokenParser Token Attribute Class
NFX.Parsing Namespace


TokenParser.Token.Attribute Constructor

TokenParser Token Attribute Constructor NFX Class Library

Initializes a new instance of the TokenParser Token Attribute class

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Attribute(
    string name,
    string val,
    int idx,
    int cidx,
    int clen
)
public Attribute(
    string name,
    string val,
    int idx,
    int cidx,
    int clen
)
Public Sub New (
    name As String,
    val As String,
    idx As Integer,
    cidx As Integer,
    clen As Integer
)
Public Sub New (
    name As String,
    val As String,
    idx As Integer,
    cidx As Integer,
    clen As Integer
)
public:
Attribute(
    String^ name,
    String^ val,
    int idx,
    int cidx,
    int clen
)
public:
Attribute(
    String^ name,
    String^ val,
    int idx,
    int cidx,
    int clen
)
new :
        name : string *
        val : string *
        idx : int *
        cidx : int *
        clen : int -> Attribute
new :
        name : string *
        val : string *
        idx : int *
        cidx : int *
        clen : int -> Attribute

Parameters

name
Type: Online System String
val
Type: Online System String
idx
Type: Online System Int32
cidx
Type: Online System Int32
clen
Type: Online System Int32
See Also
TokenParser Token Attribute Class
TokenParser Token Attribute Members
NFX.Parsing Namespace


TokenParser.Token.Attribute Methods

TokenParser Token Attribute Methods NFX Class Library

The TokenParser Token Attribute type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TokenParser Token Attribute Class
NFX.Parsing Namespace


TokenParser.Token.Attribute Properties

TokenParser Token Attribute Properties NFX Class Library

The TokenParser Token Attribute type exposes the following members.
Properties
 | Name | Description
Public property | ContentIndex | Attribute body index in content string
Public property | ContentLength | Attribute body length in content string
Public property | Index | Attribute index (0-based position) within token tag parse order
Public property | Name | Represents token's attribute name
Public property | Value | Represents token's attribute value
Back to Top
See Also
TokenParser Token Attribute Class
NFX.Parsing Namespace


TokenParser.Token.Attribute.ContentIndex Property

TokenParser Token Attribute ContentIndex Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Attribute body index in content string

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ContentIndex { get; }
public int ContentIndex { get; }
Public ReadOnly Property ContentIndex As Integer
    Get
Public ReadOnly Property ContentIndex As Integer
    Get
public:
property int ContentIndex {
    int get ();
}
public:
property int ContentIndex {
    int get ();
}
member ContentIndex : int with get
member ContentIndex : int with get

Property Value

Type: Online Int32
See Also
TokenParser Token Attribute Class
TokenParser Token Attribute Members
NFX.Parsing Namespace


TokenParser.Token.Attribute.ContentLength Property

TokenParser Token Attribute ContentLength Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Attribute body length in content string

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ContentLength { get; }
public int ContentLength { get; }
Public ReadOnly Property ContentLength As Integer
    Get
Public ReadOnly Property ContentLength As Integer
    Get
public:
property int ContentLength {
    int get ();
}
public:
property int ContentLength {
    int get ();
}
member ContentLength : int with get
member ContentLength : int with get

Property Value

Type: Online Int32
See Also
TokenParser Token Attribute Class
TokenParser Token Attribute Members
NFX.Parsing Namespace


TokenParser.Token.Attribute.Index Property

TokenParser Token Attribute Index Property NFX Class Library

Attribute index (0-based position) within token tag parse order

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Index { get; }
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
Public ReadOnly Property Index As Integer
    Get
public:
property int Index {
    int get ();
}
public:
property int Index {
    int get ();
}
member Index : int with get
member Index : int with get

Property Value

Type: Online Int32
See Also
TokenParser Token Attribute Class
TokenParser Token Attribute Members
NFX.Parsing Namespace


TokenParser.Token.Attribute.Name Property

TokenParser Token Attribute Name Property NFX Class Library

Represents token's attribute name

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
public:
property String^ Name {
    String^ get ();
}
member Name : string with get
member Name : string with get

Property Value

Type: Online String
See Also
TokenParser Token Attribute Class
TokenParser Token Attribute Members
NFX.Parsing Namespace


TokenParser.Token.Attribute.Value Property

TokenParser Token Attribute Value Property NFX Class Library

Represents token's attribute value

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Value { get; }
public string Value { get; }
Public ReadOnly Property Value As String
    Get
Public ReadOnly Property Value As String
    Get
public:
property String^ Value {
    String^ get ();
}
public:
property String^ Value {
    String^ get ();
}
member Value : string with get
member Value : string with get

Property Value

Type: Online String
See Also
TokenParser Token Attribute Class
TokenParser Token Attribute Members
NFX.Parsing Namespace


Utils Class

Utils Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Parsing Utils

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class Utils
public static class Utils
<ExtensionAttribute>
Public NotInheritable Class Utils
<ExtensionAttribute>
Public NotInheritable Class Utils
[ExtensionAttribute]
public ref class Utils abstract sealed
[ExtensionAttribute]
public ref class Utils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Utils =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Utils =  class end
See Also
Utils Members
NFX.Parsing Namespace


Utils Members

Utils Members NFX Class Library

The Utils type exposes the following members.
Methods
Name | Description
CapturePatternMatch | Returns a captured wildcard segment from string. Pattern uses '*' for match capture by default and may contain a single capture
IsURLValid | Checks URL string for validity
MakeSentenceLines | Puts every sentence on a separate line
MatchPattern | Returns true if supplied string matches pattern that can contain up to one * wildcard and multiple ? wildcards
ParseFieldNameToDescription | Parses database field names (column names) and converts parts to human-readable description like: "FIRST_NAME" -> "First Name", "FirstName" -> "First Name", "CHART_OF_ACCOUNTS" -> "Chart of Accounts"
Back to Top
See Also
Utils Class
NFX.Parsing Namespace


Utils Methods

Utils Methods NFX Class Library

The Utils type exposes the following members.
Methods
Name | Description
CapturePatternMatch | Returns a captured wildcard segment from string. Pattern uses '*' for match capture by default and may contain a single capture
IsURLValid | Checks URL string for validity
MakeSentenceLines | Puts every sentence on a separate line
MatchPattern | Returns true if supplied string matches pattern that can contain up to one * wildcard and multiple ? wildcards
ParseFieldNameToDescription | Parses database field names (column names) and converts parts to human-readable description like: "FIRST_NAME" -> "First Name", "FirstName" -> "First Name", "CHART_OF_ACCOUNTS" -> "Chart of Accounts"
Back to Top
See Also
Utils Class
NFX.Parsing Namespace


Utils.CapturePatternMatch Method

Utils CapturePatternMatch Method NFX Class Library

Returns a captured wildcard segment from string. Pattern uses '*' for match capture by default and may contain a single capture

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string CapturePatternMatch(
    this string str,
    string pattern,
    char wc = '*',
    StringComparison comparisonType = StringComparison.InvariantCultureIgnoreCase
)
public static string CapturePatternMatch(
    this string str,
    string pattern,
    char wc = '*',
    StringComparison comparisonType = StringComparison.InvariantCultureIgnoreCase
)
<ExtensionAttribute>
Public Shared Function CapturePatternMatch (
    str As String,
    pattern As String,
    Optional wc As Char = "*"C,
    Optional comparisonType As StringComparison = StringComparison.InvariantCultureIgnoreCase
) As String
<ExtensionAttribute>
Public Shared Function CapturePatternMatch (
    str As String,
    pattern As String,
    Optional wc As Char = "*"C,
    Optional comparisonType As StringComparison = StringComparison.InvariantCultureIgnoreCase
) As String
public:
[ExtensionAttribute]
static String^ CapturePatternMatch(
    String^ str,
    String^ pattern,
    wchar_t wc = L'*',
    StringComparison comparisonType = StringComparison::InvariantCultureIgnoreCase
)
public:
[ExtensionAttribute]
static String^ CapturePatternMatch(
    String^ str,
    String^ pattern,
    wchar_t wc = L'*',
    StringComparison comparisonType = StringComparison::InvariantCultureIgnoreCase
)
static member CapturePatternMatch :
        str : string *
        pattern : string *
        ?wc : char *
        ?comparisonType : StringComparison
(* Defaults:
        let _wc = defaultArg wc '*'
        let _comparisonType = defaultArg comparisonType StringComparison.InvariantCultureIgnoreCase
*)
-> string
static member CapturePatternMatch :
        str : string *
        pattern : string *
        ?wc : char *
        ?comparisonType : StringComparison
(* Defaults:
        let _wc = defaultArg wc '*'
        let _comparisonType = defaultArg comparisonType StringComparison.InvariantCultureIgnoreCase
*)
-> string

Parameters

str
Type: Online System String
pattern
Type: Online System String
wc (Optional)
Type: Online System Char
comparisonType (Optional)
Type: Online System StringComparison

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
Utils Class
Utils Members
NFX.Parsing Namespace


Utils.IsURLValid Method

Utils IsURLValid Method NFX Class Library

Checks URL string for validity

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsURLValid(
    this string url
)
public static bool IsURLValid(
    this string url
)
<ExtensionAttribute>
Public Shared Function IsURLValid (
    url As String
) As Boolean
<ExtensionAttribute>
Public Shared Function IsURLValid (
    url As String
) As Boolean
public:
[ExtensionAttribute]
static bool IsURLValid(
    String^ url
)
public:
[ExtensionAttribute]
static bool IsURLValid(
    String^ url
)
static member IsURLValid :
        url : string -> bool
static member IsURLValid :
        url : string -> bool

Parameters

url
Type: Online System String

Return Value

Type: Online Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
Utils Class
Utils Members
NFX.Parsing Namespace


Utils.MakeSentenceLines Method

Utils MakeSentenceLines Method NFX Class Library

Puts every sentence on a separate line

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string MakeSentenceLines(
    this string text
)
public static string MakeSentenceLines(
    this string text
)
<ExtensionAttribute>
Public Shared Function MakeSentenceLines (
    text As String
) As String
<ExtensionAttribute>
Public Shared Function MakeSentenceLines (
    text As String
) As String
public:
[ExtensionAttribute]
static String^ MakeSentenceLines(
    String^ text
)
public:
[ExtensionAttribute]
static String^ MakeSentenceLines(
    String^ text
)
static member MakeSentenceLines :
        text : string -> string
static member MakeSentenceLines :
        text : string -> string

Parameters

text
Type: Online System String

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
Utils Class
Utils Members
NFX.Parsing Namespace


Utils.MatchPattern Method

Utils MatchPattern Method NFX Class Library

Returns true if supplied string matches pattern that can contain up to one * wildcard and multiple ? wildcards

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool MatchPattern(
    this string str,
    string pattern,
    char wc = '*',
    char wsc = '?',
    bool senseCase = false
)
public static bool MatchPattern(
    this string str,
    string pattern,
    char wc = '*',
    char wsc = '?',
    bool senseCase = false
)
<ExtensionAttribute>
Public Shared Function MatchPattern (
    str As String,
    pattern As String,
    Optional wc As Char = "*"C,
    Optional wsc As Char = "?"C,
    Optional senseCase As Boolean = false
) As Boolean
<ExtensionAttribute>
Public Shared Function MatchPattern (
    str As String,
    pattern As String,
    Optional wc As Char = "*"C,
    Optional wsc As Char = "?"C,
    Optional senseCase As Boolean = false
) As Boolean
public:
[ExtensionAttribute]
static bool MatchPattern(
    String^ str,
    String^ pattern,
    wchar_t wc = L'*',
    wchar_t wsc = L'?',
    bool senseCase = false
)
public:
[ExtensionAttribute]
static bool MatchPattern(
    String^ str,
    String^ pattern,
    wchar_t wc = L'*',
    wchar_t wsc = L'?',
    bool senseCase = false
)
static member MatchPattern :
        str : string *
        pattern : string *
        ?wc : char *
        ?wsc : char *
        ?senseCase : bool
(* Defaults:
        let _wc = defaultArg wc '*'
        let _wsc = defaultArg wsc '?'
        let _senseCase = defaultArg senseCase false
*)
-> bool
static member MatchPattern :
        str : string *
        pattern : string *
        ?wc : char *
        ?wsc : char *
        ?senseCase : bool
(* Defaults:
        let _wc = defaultArg wc '*'
        let _wsc = defaultArg wsc '?'
        let _senseCase = defaultArg senseCase false
*)
-> bool

Parameters

str
Type: Online System String
pattern
Type: Online System String
wc (Optional)
Type: Online System Char
wsc (Optional)
Type: Online System Char
senseCase (Optional)
Type: Online System Boolean

Return Value

Type: Online Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
Utils Class
Utils Members
NFX.Parsing Namespace


Utils.ParseFieldNameToDescription Method

Utils ParseFieldNameToDescription Method NFX Class Library

Parses database field names (column names) and converts parts to human-readable description like: "FIRST_NAME" -> "First Name", "FirstName" -> "First Name", "CHART_OF_ACCOUNTS" -> "Chart of Accounts"

Namespace: NFX.Parsing
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ParseFieldNameToDescription(
    this string fieldName,
    bool capitalize
)
public static string ParseFieldNameToDescription(
    this string fieldName,
    bool capitalize
)
<ExtensionAttribute>
Public Shared Function ParseFieldNameToDescription (
    fieldName As String,
    capitalize As Boolean
) As String
<ExtensionAttribute>
Public Shared Function ParseFieldNameToDescription (
    fieldName As String,
    capitalize As Boolean
) As String
public:
[ExtensionAttribute]
static String^ ParseFieldNameToDescription(
    String^ fieldName,
    bool capitalize
)
public:
[ExtensionAttribute]
static String^ ParseFieldNameToDescription(
    String^ fieldName,
    bool capitalize
)
static member ParseFieldNameToDescription :
        fieldName : string *
        capitalize : bool -> string
static member ParseFieldNameToDescription :
        fieldName : string *
        capitalize : bool -> string

Parameters

fieldName
Type: Online System String
capitalize
Type: Online System Boolean

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
Utils Class
Utils Members
NFX.Parsing Namespace


NFX.Parsing.JavaScript Namespace

NFX.Parsing.JavaScript Namespace NFX Class Library

Provides JavaScript-related parsing utils
Classes
 | Class | Description
Public class | Stripper | Strips JavaScript content off comments and whitespaces


Stripper Class

Stripper Class NFX Class Library

Strips JavaScript content off comments and whitespaces
Inheritance Hierarchy
Online System Object
NFX.Parsing.JavaScript Stripper

Namespace: NFX.Parsing.JavaScript
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Stripper
public class Stripper
Public Class Stripper
Public Class Stripper
public ref class Stripper
public ref class Stripper
type Stripper =  class end
type Stripper =  class end
See Also
Stripper Members
NFX.Parsing.JavaScript Namespace


Stripper Members

Stripper Members NFX Class Library

The Stripper type exposes the following members.
Constructors
 | Name | Description
Public method | Stripper | Initializes a new instance of the Stripper class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Source |
Public property | StrippedSource |
Back to Top
See Also
Stripper Class
NFX.Parsing.JavaScript Namespace


Stripper Constructor

Stripper Constructor NFX Class Library

Initializes a new instance of the Stripper class

Namespace: NFX.Parsing.JavaScript
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Stripper(
    string source
)
public Stripper(
    string source
)
Public Sub New (
    source As String
)
Public Sub New (
    source As String
)
public:
Stripper(
    String^ source
)
public:
Stripper(
    String^ source
)
new :
        source : string -> Stripper
new :
        source : string -> Stripper

Parameters

source
Type: Online System String
See Also
Stripper Class
Stripper Members
NFX.Parsing.JavaScript Namespace


Stripper Methods

Stripper Methods NFX Class Library

The Stripper type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Stripper Class
NFX.Parsing.JavaScript Namespace


Stripper Properties

Stripper Properties NFX Class Library

The Stripper type exposes the following members.
Properties
 | Name | Description
Public property | Source |
Public property | StrippedSource |
Back to Top
See Also
Stripper Class
NFX.Parsing.JavaScript Namespace


Stripper.Source Property

Stripper Source Property NFX Class Library

Namespace: NFX.Parsing.JavaScript
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Source { get; }
public string Source { get; }
Public ReadOnly Property Source As String
    Get
Public ReadOnly Property Source As String
    Get
public:
property String^ Source {
    String^ get ();
}
public:
property String^ Source {
    String^ get ();
}
member Source : string with get
member Source : string with get

Property Value

Type: Online String
See Also
Stripper Class
Stripper Members
NFX.Parsing.JavaScript Namespace


Stripper.StrippedSource Property

Stripper StrippedSource Property NFX Class Library

Namespace: NFX.Parsing.JavaScript
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string StrippedSource { get; }
public string StrippedSource { get; }
Public ReadOnly Property StrippedSource As String
    Get
Public ReadOnly Property StrippedSource As String
    Get
public:
property String^ StrippedSource {
    String^ get ();
}
public:
property String^ StrippedSource {
    String^ get ();
}
member StrippedSource : string with get
member StrippedSource : string with get

Property Value

Type: Online String
See Also
Stripper Class
Stripper Members
NFX.Parsing.JavaScript Namespace


NFX.RelationalModel Namespace

NFX.RelationalModel Namespace NFX Class Library

Provides types for working with relational schemas that can be compiled to DDL and other kinds of scripts
Classes
 | Class | Description
Public class | Compiler | Represents a compiler that can turn source schema into particular target script/schema, i.e. into database creation script for particular technology (i.e. Oracle, MySQL, PostgreSQL, etc..) or some other code/script (i.e. RecordModel classes, JavaScript classes)
Public class | Compiler Outputs |
Public class | CompilerException | Thrown by relational schema compiler
Public class | MsSQLServerCompiler | Compiles relation schema into Ms SQL Server scripts
Public class | MySQLCompiler | Compiles relation schema into MySQL scripts
Public class | RDBMSCompiler | Compiles schema scripts into RDBMS-family of outputs - the ones that have tables, keys, indexes, constraints etc...
Public class | RDBMSEntity |
Public class | RelationalException | Base exception thrown by the Relational-* framework
Public class | Schema | Represents an instance of relational schema source
Public class | SchemaCompilationException | Thrown by relational schema compiler while processing the source schema
Public class | SchemaException | Thrown by relational schema
Enumerations
 | Enumeration | Description
Public enumeration | NameCaseSensitivity | Denotes naming case sensitivity
Public enumeration | RDBMSEntityType | Denotes a type of RDBMS entity
Public enumeration | RDBMSSortOrder |
Public enumeration | TargetType | Specifies a type of target that compiler produces output for


Compiler Class

Compiler Class NFX Class Library

Represents a compiler that can turn source schema into particular target script/schema, i.e. into database creation script for particular technology (i.e. Oracle, MySQL, PostgreSQL, etc..) or some other code/script (i.e. RecordModel classes, JavaScript classes)
Inheritance Hierarchy
Online System Object
NFX.RelationalModel Compiler
NFX.RelationalModel RDBMSCompiler

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Compiler : IConfigurable,
    INamed
public abstract class Compiler : IConfigurable,
    INamed
Public MustInherit Class Compiler
    Implements IConfigurable, INamed
Public MustInherit Class Compiler
    Implements IConfigurable, INamed
public ref class Compiler abstract : IConfigurable,
    INamed
public ref class Compiler abstract : IConfigurable,
    INamed
[<AbstractClassAttribute>]
type Compiler =
    class
        interface IConfigurable
        interface INamed
    end
[<AbstractClassAttribute>]
type Compiler =
    class
        interface IConfigurable
        interface INamed
    end
See Also
Compiler Members
NFX.RelationalModel Namespace


Compiler Members

Compiler Members NFX Class Library

The Compiler type exposes the following members.
Constructors
 | Name | Description
Protected method | Compiler | Initializes a new instance of the Compiler class
Back to Top
Methods
 | Name | Description
Protected method | BuildNodeOutput | Override to perform custom interpretation per particular compiler target
Protected method | BuildOutputs | Override to perform compilation into output, the base implementation loops over all nodes and interprets script includes
Public method | Compile |
Public method | Configure |
Protected method | DoCompile | Performs a compilation - this is a root override-able method where compilation starts
Protected method | EnsureNotCompiled |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | EscapeFileName | Replaces incompatible characters for file names with "_"
Public method | EscapeString |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetOutputFileSuffix | Override to provide meaningful extension for particular technology, i.e. SQL
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IncludeScriptFile | Performs a script file include
Public method | IncludeScriptText | Performs a verbatim script text include
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_CompileErrors |
 | SCRIPT_COMMENT_ATTR | Specifies the comment that will be output for decorated entity in the script
 | SCRIPT_INCLUDE_SECTION | Specifies the name of the file to be included in the output verbatim, i.e.: script-include="mytypes.txt"{}
 | SCRIPT_OUTPUT_NAME_ATTR | Specifies the name of the output that script text has to be placed in
 | SCRIPT_TEXT_SECTION | Specifies the text to be included in the output verbatim, i.e.: script-text="INSERT INTO TBL_ABC VALUES(1, true, now())"{}
Back to Top
Properties
 | Name | Description
Public property | CompileErrors | Returns exception errors that were generated during compilation. This property returns "planned" errors that were caused by input, whereas CompileException returns exception that indicates some more drastic abnormality that broke the compilation
Public property | CompileException | Returns exception that surfaced during compilation, or null if source has not compiled yet or no exception happened. This exception is different form CompileErrors because it indicates some un=planned condition that broke the compilation process
Public property | HasCompiled | Returns true to indicate that compiler has already processed the source schema
Public property | HasErrors | Returns true when this instance did not compile properly
Public property | Name | Returns the name of the technology that this compiler targets. i.e. "ORACLE", "RecordModel"
Public property | NameCaseSensitivity | Determines whether output script is case sensitive
Public property | NameComparison | Returns string comparison options for names that depend on target case sensitivity
Public property | OutputPath | Determines where compiled output is placed
Public property | OutputPrefix | Determines the prefix for output names
Public property | Schema | Returns source schema
Public property | Target | Returns type of target that this instance produces output for
Back to Top
See Also
Compiler Class
NFX.RelationalModel Namespace


Compiler Constructor

Compiler Constructor NFX Class Library

Initializes a new instance of the Compiler class

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Compiler(
    Schema schema
)
protected Compiler(
    Schema schema
)
Protected Sub New (
    schema As Schema
)
Protected Sub New (
    schema As Schema
)
protected:
Compiler(
    Schema^ schema
)
protected:
Compiler(
    Schema^ schema
)
new :
        schema : Schema -> Compiler
new :
        schema : Schema -> Compiler

Parameters

schema
Type: NFX.RelationalModel Schema
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler Fields

Compiler Fields NFX Class Library

The Compiler type exposes the following members.
Fields
 | Name | Description
Protected field | m_CompileErrors |
 | SCRIPT_COMMENT_ATTR | Specifies the comment that will be output for decorated entity in the script
 | SCRIPT_INCLUDE_SECTION | Specifies the name of the file to be included in the output verbatim, i.e.: script-include="mytypes.txt"{}
 | SCRIPT_OUTPUT_NAME_ATTR | Specifies the name of the output that script text has to be placed in
 | SCRIPT_TEXT_SECTION | Specifies the text to be included in the output verbatim, i.e.: script-text="INSERT INTO TBL_ABC VALUES(1, true, now())"{}
Back to Top
See Also
Compiler Class
NFX.RelationalModel Namespace


Compiler.m_CompileErrors Field

Compiler m_CompileErrors Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected List<SchemaCompilationException> m_CompileErrors
protected List<SchemaCompilationException> m_CompileErrors
Protected m_CompileErrors As List(Of SchemaCompilationException)
Protected m_CompileErrors As List(Of SchemaCompilationException)
protected:
List<SchemaCompilationException^>^ m_CompileErrors
protected:
List<SchemaCompilationException^>^ m_CompileErrors
val mutable m_CompileErrors: List<SchemaCompilationException>
val mutable m_CompileErrors: List<SchemaCompilationException>

Field Value

Type: Online List SchemaCompilationException
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler.SCRIPT_COMMENT_ATTR Field

Compiler SCRIPT_COMMENT_ATTR Field NFX Class Library

Specifies the comment that will be output for decorated entity in the script

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SCRIPT_COMMENT_ATTR
public const string SCRIPT_COMMENT_ATTR
Public Const SCRIPT_COMMENT_ATTR As String
Public Const SCRIPT_COMMENT_ATTR As String
public:
literal String^ SCRIPT_COMMENT_ATTR
public:
literal String^ SCRIPT_COMMENT_ATTR
static val mutable SCRIPT_COMMENT_ATTR: string
static val mutable SCRIPT_COMMENT_ATTR: string

Field Value

Type: Online String
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler.SCRIPT_INCLUDE_SECTION Field

Compiler SCRIPT_INCLUDE_SECTION Field NFX Class Library

Specifies the name of the file to be included in the output verbatim, i.e.: script-include="mytypes.txt"{}

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SCRIPT_INCLUDE_SECTION
public const string SCRIPT_INCLUDE_SECTION
Public Const SCRIPT_INCLUDE_SECTION As String
Public Const SCRIPT_INCLUDE_SECTION As String
public:
literal String^ SCRIPT_INCLUDE_SECTION
public:
literal String^ SCRIPT_INCLUDE_SECTION
static val mutable SCRIPT_INCLUDE_SECTION: string
static val mutable SCRIPT_INCLUDE_SECTION: string

Field Value

Type: Online String
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler.SCRIPT_OUTPUT_NAME_ATTR Field

Compiler SCRIPT_OUTPUT_NAME_ATTR Field NFX Class Library

Specifies the name of the output that script text has to be placed in

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SCRIPT_OUTPUT_NAME_ATTR
public const string SCRIPT_OUTPUT_NAME_ATTR
Public Const SCRIPT_OUTPUT_NAME_ATTR As String
Public Const SCRIPT_OUTPUT_NAME_ATTR As String
public:
literal String^ SCRIPT_OUTPUT_NAME_ATTR
public:
literal String^ SCRIPT_OUTPUT_NAME_ATTR
static val mutable SCRIPT_OUTPUT_NAME_ATTR: string
static val mutable SCRIPT_OUTPUT_NAME_ATTR: string

Field Value

Type: Online String
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler.SCRIPT_TEXT_SECTION Field

Compiler SCRIPT_TEXT_SECTION Field NFX Class Library

Specifies the text to be included in the output verbatim, i.e.: script-text="INSERT INTO TBL_ABC VALUES(1, true, now())"{}

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SCRIPT_TEXT_SECTION
public const string SCRIPT_TEXT_SECTION
Public Const SCRIPT_TEXT_SECTION As String
Public Const SCRIPT_TEXT_SECTION As String
public:
literal String^ SCRIPT_TEXT_SECTION
public:
literal String^ SCRIPT_TEXT_SECTION
static val mutable SCRIPT_TEXT_SECTION: string
static val mutable SCRIPT_TEXT_SECTION: string

Field Value

Type: Online String
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler Methods

Compiler Methods NFX Class Library

The Compiler type exposes the following members.
Methods
 | Name | Description
Protected method | BuildNodeOutput | Override to perform custom interpretation per particular compiler target
Protected method | BuildOutputs | Override to perform compilation into output, the base implementation loops over all nodes and interprets script includes
Public method | Compile |
Public method | Configure |
Protected method | DoCompile | Performs a compilation - this is a root override-able method where compilation starts
Protected method | EnsureNotCompiled |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | EscapeFileName | Replaces incompatible characters for file names with "_"
Public method | EscapeString |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetOutputFileSuffix | Override to provide meaningful extension for particular technology, i.e. SQL
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IncludeScriptFile | Performs a script file include
Public method | IncludeScriptText | Performs a verbatim script text include
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Compiler Class
NFX.RelationalModel Namespace


Compiler.BuildNodeOutput Method

Compiler BuildNodeOutput Method NFX Class Library

Override to perform custom interpretation per particular compiler target

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void BuildNodeOutput(
    IConfigSectionNode node,
    Compiler..::..Outputs outputs
)
protected abstract void BuildNodeOutput(
    IConfigSectionNode node,
    Compiler..::..Outputs outputs
)
Protected MustOverride Sub BuildNodeOutput (
    node As IConfigSectionNode,
    outputs As Compiler..::..Outputs
)
Protected MustOverride Sub BuildNodeOutput (
    node As IConfigSectionNode,
    outputs As Compiler..::..Outputs
)
protected:
virtual void BuildNodeOutput(
    IConfigSectionNode^ node,
    Compiler..::..Outputs^ outputs
) abstract
protected:
virtual void BuildNodeOutput(
    IConfigSectionNode^ node,
    Compiler..::..Outputs^ outputs
) abstract
abstract BuildNodeOutput :
        node : IConfigSectionNode *
        outputs : Compiler..::..Outputs -> unit
abstract BuildNodeOutput :
        node : IConfigSectionNode *
        outputs : Compiler..::..Outputs -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
outputs
Type: NFX.RelationalModel Compiler Outputs
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler.BuildOutputs Method

Compiler BuildOutputs Method NFX Class Library

Override to perform compilation into output, the base implementation loops over all nodes and interprets script includes

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void BuildOutputs(
    Compiler..::..Outputs outputs
)
protected virtual void BuildOutputs(
    Compiler..::..Outputs outputs
)
Protected Overridable Sub BuildOutputs (
    outputs As Compiler..::..Outputs
)
Protected Overridable Sub BuildOutputs (
    outputs As Compiler..::..Outputs
)
protected:
virtual void BuildOutputs(
    Compiler..::..Outputs^ outputs
)
protected:
virtual void BuildOutputs(
    Compiler..::..Outputs^ outputs
)
abstract BuildOutputs :
        outputs : Compiler..::..Outputs -> unit
override BuildOutputs :
        outputs : Compiler..::..Outputs -> unit
abstract BuildOutputs :
        outputs : Compiler..::..Outputs -> unit
override BuildOutputs :
        outputs : Compiler..::..Outputs -> unit

Parameters

outputs
Type: NFX.RelationalModel Compiler Outputs
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler.Compile Method

Compiler Compile Method NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Compile()
public void Compile()
Public Sub Compile
Public Sub Compile
public:
void Compile()
public:
void Compile()
member Compile : unit -> unit
member Compile : unit -> unit
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler.Configure Method

Compiler Configure Method NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode node
)
public void Configure(
    IConfigSectionNode node
)
Public Sub Configure (
    node As IConfigSectionNode
)
Public Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler.DoCompile Method

Compiler DoCompile Method NFX Class Library

Performs a compilation - this is a root override-able method where compilation starts

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoCompile()
protected virtual void DoCompile()
Protected Overridable Sub DoCompile
Protected Overridable Sub DoCompile
protected:
virtual void DoCompile()
protected:
virtual void DoCompile()
abstract DoCompile : unit -> unit
override DoCompile : unit -> unit
abstract DoCompile : unit -> unit
override DoCompile : unit -> unit
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler.EnsureNotCompiled Method

Compiler EnsureNotCompiled Method NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void EnsureNotCompiled()
protected void EnsureNotCompiled()
Protected Sub EnsureNotCompiled
Protected Sub EnsureNotCompiled
protected:
void EnsureNotCompiled()
protected:
void EnsureNotCompiled()
member EnsureNotCompiled : unit -> unit
member EnsureNotCompiled : unit -> unit
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler.EscapeFileName Method

Compiler EscapeFileName Method NFX Class Library

Replaces incompatible characters for file names with "_"

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string EscapeFileName(
    string fn
)
public string EscapeFileName(
    string fn
)
Public Function EscapeFileName (
    fn As String
) As String
Public Function EscapeFileName (
    fn As String
) As String
public:
String^ EscapeFileName(
    String^ fn
)
public:
String^ EscapeFileName(
    String^ fn
)
member EscapeFileName :
        fn : string -> string
member EscapeFileName :
        fn : string -> string

Parameters

fn
Type: Online System String

Return Value

Type: Online String
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler.EscapeString Method

Compiler EscapeString Method NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string EscapeString(
    string str
)
public virtual string EscapeString(
    string str
)
Public Overridable Function EscapeString (
    str As String
) As String
Public Overridable Function EscapeString (
    str As String
) As String
public:
virtual String^ EscapeString(
    String^ str
)
public:
virtual String^ EscapeString(
    String^ str
)
abstract EscapeString :
        str : string -> string
override EscapeString :
        str : string -> string
abstract EscapeString :
        str : string -> string
override EscapeString :
        str : string -> string

Parameters

str
Type: Online System String

Return Value

Type: Online String
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler.GetOutputFileSuffix Method

Compiler GetOutputFileSuffix Method NFX Class Library

Override to provide meaningful extension for particular technology, i.e. SQL

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string GetOutputFileSuffix(
    string outputName
)
public virtual string GetOutputFileSuffix(
    string outputName
)
Public Overridable Function GetOutputFileSuffix (
    outputName As String
) As String
Public Overridable Function GetOutputFileSuffix (
    outputName As String
) As String
public:
virtual String^ GetOutputFileSuffix(
    String^ outputName
)
public:
virtual String^ GetOutputFileSuffix(
    String^ outputName
)
abstract GetOutputFileSuffix :
        outputName : string -> string
override GetOutputFileSuffix :
        outputName : string -> string
abstract GetOutputFileSuffix :
        outputName : string -> string
override GetOutputFileSuffix :
        outputName : string -> string

Parameters

outputName
Type: Online System String

Return Value

Type: Online String
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler.IncludeScriptFile Method

Compiler IncludeScriptFile Method NFX Class Library

Performs a script file include

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void IncludeScriptFile(
    IConfigSectionNode node,
    Compiler..::..Outputs outputs
)
protected virtual void IncludeScriptFile(
    IConfigSectionNode node,
    Compiler..::..Outputs outputs
)
Protected Overridable Sub IncludeScriptFile (
    node As IConfigSectionNode,
    outputs As Compiler..::..Outputs
)
Protected Overridable Sub IncludeScriptFile (
    node As IConfigSectionNode,
    outputs As Compiler..::..Outputs
)
protected:
virtual void IncludeScriptFile(
    IConfigSectionNode^ node,
    Compiler..::..Outputs^ outputs
)
protected:
virtual void IncludeScriptFile(
    IConfigSectionNode^ node,
    Compiler..::..Outputs^ outputs
)
abstract IncludeScriptFile :
        node : IConfigSectionNode *
        outputs : Compiler..::..Outputs -> unit
override IncludeScriptFile :
        node : IConfigSectionNode *
        outputs : Compiler..::..Outputs -> unit
abstract IncludeScriptFile :
        node : IConfigSectionNode *
        outputs : Compiler..::..Outputs -> unit
override IncludeScriptFile :
        node : IConfigSectionNode *
        outputs : Compiler..::..Outputs -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
outputs
Type: NFX.RelationalModel Compiler Outputs
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler.IncludeScriptText Method

Compiler IncludeScriptText Method NFX Class Library

Performs a verbatim script text include

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void IncludeScriptText(
    IConfigSectionNode node,
    Compiler..::..Outputs outputs
)
public virtual void IncludeScriptText(
    IConfigSectionNode node,
    Compiler..::..Outputs outputs
)
Public Overridable Sub IncludeScriptText (
    node As IConfigSectionNode,
    outputs As Compiler..::..Outputs
)
Public Overridable Sub IncludeScriptText (
    node As IConfigSectionNode,
    outputs As Compiler..::..Outputs
)
public:
virtual void IncludeScriptText(
    IConfigSectionNode^ node,
    Compiler..::..Outputs^ outputs
)
public:
virtual void IncludeScriptText(
    IConfigSectionNode^ node,
    Compiler..::..Outputs^ outputs
)
abstract IncludeScriptText :
        node : IConfigSectionNode *
        outputs : Compiler..::..Outputs -> unit
override IncludeScriptText :
        node : IConfigSectionNode *
        outputs : Compiler..::..Outputs -> unit
abstract IncludeScriptText :
        node : IConfigSectionNode *
        outputs : Compiler..::..Outputs -> unit
override IncludeScriptText :
        node : IConfigSectionNode *
        outputs : Compiler..::..Outputs -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
outputs
Type: NFX.RelationalModel Compiler Outputs
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler Properties

Compiler Properties NFX Class Library

The Compiler type exposes the following members.
Properties
 | Name | Description
Public property | CompileErrors | Returns exception errors that were generated during compilation. This property returns "planned" errors that were caused by input, whereas CompileException returns exception that indicates some more drastic abnormality that broke the compilation
Public property | CompileException | Returns exception that surfaced during compilation, or null if source has not compiled yet or no exception happened. This exception is different form CompileErrors because it indicates some un=planned condition that broke the compilation process
Public property | HasCompiled | Returns true to indicate that compiler has already processed the source schema
Public property | HasErrors | Returns true when this instance did not compile properly
Public property | Name | Returns the name of the technology that this compiler targets. i.e. "ORACLE", "RecordModel"
Public property | NameCaseSensitivity | Determines whether output script is case sensitive
Public property | NameComparison | Returns string comparison options for names that depend on target case sensitivity
Public property | OutputPath | Determines where compiled output is placed
Public property | OutputPrefix | Determines the prefix for output names
Public property | Schema | Returns source schema
Public property | Target | Returns type of target that this instance produces output for
Back to Top
See Also
Compiler Class
NFX.RelationalModel Namespace


Compiler.CompileErrors Property

Compiler CompileErrors Property NFX Class Library

Returns exception errors that were generated during compilation. This property returns "planned" errors that were caused by input, whereas CompileException returns exception that indicates some more drastic abnormality that broke the compilation

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<SchemaCompilationException> CompileErrors { get; }
public IEnumerable<SchemaCompilationException> CompileErrors { get; }
Public ReadOnly Property CompileErrors As IEnumerable(Of SchemaCompilationException)
    Get
Public ReadOnly Property CompileErrors As IEnumerable(Of SchemaCompilationException)
    Get
public:
property IEnumerable<SchemaCompilationException^>^ CompileErrors {
    IEnumerable<SchemaCompilationException^>^ get ();
}
public:
property IEnumerable<SchemaCompilationException^>^ CompileErrors {
    IEnumerable<SchemaCompilationException^>^ get ();
}
member CompileErrors : IEnumerable<SchemaCompilationException> with get
member CompileErrors : IEnumerable<SchemaCompilationException> with get

Property Value

Type: Online IEnumerable SchemaCompilationException
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler.CompileException Property

Compiler CompileException Property NFX Class Library

Returns exception that surfaced during compilation, or null if source has not compiled yet or no exception happened. This exception is different form CompileErrors because it indicates some un=planned condition that broke the compilation process

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Exception CompileException { get; }
public Exception CompileException { get; }
Public ReadOnly Property CompileException As Exception
    Get
Public ReadOnly Property CompileException As Exception
    Get
public:
property Exception^ CompileException {
    Exception^ get ();
}
public:
property Exception^ CompileException {
    Exception^ get ();
}
member CompileException : Exception with get
member CompileException : Exception with get

Property Value

Type: Online Exception
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler.HasCompiled Property

Compiler HasCompiled Property NFX Class Library

Returns true to indicate that compiler has already processed the source schema

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasCompiled { get; }
public bool HasCompiled { get; }
Public ReadOnly Property HasCompiled As Boolean
    Get
Public ReadOnly Property HasCompiled As Boolean
    Get
public:
property bool HasCompiled {
    bool get ();
}
public:
property bool HasCompiled {
    bool get ();
}
member HasCompiled : bool with get
member HasCompiled : bool with get

Property Value

Type: Online Boolean
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler.HasErrors Property

Compiler HasErrors Property NFX Class Library

Returns true when this instance did not compile properly

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasErrors { get; }
public bool HasErrors { get; }
Public ReadOnly Property HasErrors As Boolean
    Get
Public ReadOnly Property HasErrors As Boolean
    Get
public:
property bool HasErrors {
    bool get ();
}
public:
property bool HasErrors {
    bool get ();
}
member HasErrors : bool with get
member HasErrors : bool with get

Property Value

Type: Online Boolean
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler.Name Property

Compiler Name Property NFX Class Library

Returns the name of the technology that this compiler targets. i.e. "ORACLE", "RecordModel"

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string Name { get; }
public abstract string Name { get; }
Public MustOverride ReadOnly Property Name As String
    Get
Public MustOverride ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () abstract;
}
public:
virtual property String^ Name {
    String^ get () abstract;
}
abstract Name : string with get
abstract Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler.NameCaseSensitivity Property

Compiler NameCaseSensitivity Property NFX Class Library

Determines whether output script is case sensitive

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$name-case-sensitivity|$case-sensitivity")]
public virtual NameCaseSensitivity NameCaseSensitivity { get; set; }
[ConfigAttribute("$name-case-sensitivity|$case-sensitivity")]
public virtual NameCaseSensitivity NameCaseSensitivity { get; set; }
<ConfigAttribute("$name-case-sensitivity|$case-sensitivity")>
Public Overridable Property NameCaseSensitivity As NameCaseSensitivity
    Get
    Set
<ConfigAttribute("$name-case-sensitivity|$case-sensitivity")>
Public Overridable Property NameCaseSensitivity As NameCaseSensitivity
    Get
    Set
public:
[ConfigAttribute(L"$name-case-sensitivity|$case-sensitivity")]
virtual property NameCaseSensitivity NameCaseSensitivity {
    NameCaseSensitivity get ();
    void set (NameCaseSensitivity value);
}
public:
[ConfigAttribute(L"$name-case-sensitivity|$case-sensitivity")]
virtual property NameCaseSensitivity NameCaseSensitivity {
    NameCaseSensitivity get ();
    void set (NameCaseSensitivity value);
}
[<ConfigAttribute("$name-case-sensitivity|$case-sensitivity")>]
abstract NameCaseSensitivity : NameCaseSensitivity with get, set
[<ConfigAttribute("$name-case-sensitivity|$case-sensitivity")>]
override NameCaseSensitivity : NameCaseSensitivity with get, set
[<ConfigAttribute("$name-case-sensitivity|$case-sensitivity")>]
abstract NameCaseSensitivity : NameCaseSensitivity with get, set
[<ConfigAttribute("$name-case-sensitivity|$case-sensitivity")>]
override NameCaseSensitivity : NameCaseSensitivity with get, set

Property Value

Type: NameCaseSensitivity
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler.NameComparison Property

Compiler NameComparison Property NFX Class Library

Returns string comparison options for names that depend on target case sensitivity

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StringComparison NameComparison { get; }
public StringComparison NameComparison { get; }
Public ReadOnly Property NameComparison As StringComparison
    Get
Public ReadOnly Property NameComparison As StringComparison
    Get
public:
property StringComparison NameComparison {
    StringComparison get ();
}
public:
property StringComparison NameComparison {
    StringComparison get ();
}
member NameComparison : StringComparison with get
member NameComparison : StringComparison with get

Property Value

Type: Online StringComparison
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler.OutputPath Property

Compiler OutputPath Property NFX Class Library

Determines where compiled output is placed

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$out-path")]
public string OutputPath { get; set; }
[ConfigAttribute("$out-path")]
public string OutputPath { get; set; }
<ConfigAttribute("$out-path")>
Public Property OutputPath As String
    Get
    Set
<ConfigAttribute("$out-path")>
Public Property OutputPath As String
    Get
    Set
public:
[ConfigAttribute(L"$out-path")]
property String^ OutputPath {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute(L"$out-path")]
property String^ OutputPath {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute("$out-path")>]
member OutputPath : string with get, set
[<ConfigAttribute("$out-path")>]
member OutputPath : string with get, set

Property Value

Type: Online String
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler.OutputPrefix Property

Compiler OutputPrefix Property NFX Class Library

Determines the prefix for output names

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$out-name-prefix")]
public string OutputPrefix { get; set; }
[ConfigAttribute("$out-name-prefix")]
public string OutputPrefix { get; set; }
<ConfigAttribute("$out-name-prefix")>
Public Property OutputPrefix As String
    Get
    Set
<ConfigAttribute("$out-name-prefix")>
Public Property OutputPrefix As String
    Get
    Set
public:
[ConfigAttribute(L"$out-name-prefix")]
property String^ OutputPrefix {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute(L"$out-name-prefix")]
property String^ OutputPrefix {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute("$out-name-prefix")>]
member OutputPrefix : string with get, set
[<ConfigAttribute("$out-name-prefix")>]
member OutputPrefix : string with get, set

Property Value

Type: Online String
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler.Schema Property

Compiler Schema Property NFX Class Library

Returns source schema

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Schema Schema { get; }
public Schema Schema { get; }
Public ReadOnly Property Schema As Schema
    Get
Public ReadOnly Property Schema As Schema
    Get
public:
property Schema^ Schema {
    Schema^ get ();
}
public:
property Schema^ Schema {
    Schema^ get ();
}
member Schema : Schema with get
member Schema : Schema with get

Property Value

Type: Schema
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler.Target Property

Compiler Target Property NFX Class Library

Returns type of target that this instance produces output for

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract TargetType Target { get; }
public abstract TargetType Target { get; }
Public MustOverride ReadOnly Property Target As TargetType
    Get
Public MustOverride ReadOnly Property Target As TargetType
    Get
public:
virtual property TargetType Target {
    TargetType get () abstract;
}
public:
virtual property TargetType Target {
    TargetType get () abstract;
}
abstract Target : TargetType with get
abstract Target : TargetType with get

Property Value

Type: TargetType
See Also
Compiler Class
Compiler Members
NFX.RelationalModel Namespace


Compiler.Outputs Class

Compiler Outputs Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel Compiler Outputs

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Outputs : IEnumerable<KeyValuePair<string, StringBuilder>>,
    IEnumerable
public sealed class Outputs : IEnumerable<KeyValuePair<string, StringBuilder>>,
    IEnumerable
Public NotInheritable Class Outputs
    Implements IEnumerable(Of KeyValuePair(Of String, StringBuilder)),
    IEnumerable
Public NotInheritable Class Outputs
    Implements IEnumerable(Of KeyValuePair(Of String, StringBuilder)),
    IEnumerable
public ref class Outputs sealed : IEnumerable<KeyValuePair<String^, StringBuilder^>>,
    IEnumerable
public ref class Outputs sealed : IEnumerable<KeyValuePair<String^, StringBuilder^>>,
    IEnumerable
[<SealedAttribute>]
type Outputs =
    class
        interface IEnumerable<KeyValuePair<string, StringBuilder>>
        interface IEnumerable
    end
[<SealedAttribute>]
type Outputs =
    class
        interface IEnumerable<KeyValuePair<string, StringBuilder>>
        interface IEnumerable
    end
See Also
Compiler Outputs Members
NFX.RelationalModel Namespace


Compiler.Outputs Members

Compiler Outputs Members NFX Class Library

The Compiler Outputs type exposes the following members.
Constructors
 | Name | Description
Public method | Compiler Outputs | Initializes a new instance of the Compiler Outputs class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable KeyValuePair String, StringBuilder | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct KeyValuePair String, StringBuilder , TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair String, StringBuilder , TComparand (Func KeyValuePair String, StringBuilder , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair String, StringBuilder , TComparand (Func KeyValuePair String, StringBuilder , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair String, StringBuilder , TComparand (Func KeyValuePair String, StringBuilder , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair String, StringBuilder , TComparand (Func KeyValuePair String, StringBuilder , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault KeyValuePair String, StringBuilder | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair String, StringBuilder (Action KeyValuePair String, StringBuilder ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair String, StringBuilder (Action KeyValuePair String, StringBuilder , Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair String, StringBuilder | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair String, StringBuilder (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | CurrentOrUnspecified | Returns last output used or Unspecified output
Public property | Item |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
Compiler Outputs Class
NFX.RelationalModel Namespace


Compiler.Outputs Constructor

Compiler Outputs Constructor NFX Class Library

Initializes a new instance of the Compiler Outputs class

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Outputs()
public Outputs()
Public Sub New
Public Sub New
public:
Outputs()
public:
Outputs()
new : unit -> Outputs
new : unit -> Outputs
See Also
Compiler Outputs Class
Compiler Outputs Members
NFX.RelationalModel Namespace


Compiler.Outputs Methods

Compiler Outputs Methods NFX Class Library

The Compiler Outputs type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable KeyValuePair String, StringBuilder | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct KeyValuePair String, StringBuilder , TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair String, StringBuilder , TComparand (Func KeyValuePair String, StringBuilder , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair String, StringBuilder , TComparand (Func KeyValuePair String, StringBuilder , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair String, StringBuilder , TComparand (Func KeyValuePair String, StringBuilder , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair String, StringBuilder , TComparand (Func KeyValuePair String, StringBuilder , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault KeyValuePair String, StringBuilder | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair String, StringBuilder (Action KeyValuePair String, StringBuilder ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair String, StringBuilder (Action KeyValuePair String, StringBuilder , Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair String, StringBuilder | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair String, StringBuilder (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
Compiler Outputs Class
NFX.RelationalModel Namespace


Compiler.Outputs.IEnumerable.GetEnumerator Method

Compiler Outputs IEnumerable GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
Compiler Outputs Class
Compiler Outputs Members
NFX.RelationalModel Namespace


Compiler.Outputs.GetEnumerator Method

Compiler Outputs GetEnumerator Method NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<KeyValuePair<string, StringBuilder>> GetEnumerator()
public IEnumerator<KeyValuePair<string, StringBuilder>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of String, StringBuilder))
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of String, StringBuilder))
public:
virtual IEnumerator<KeyValuePair<String^, StringBuilder^>>^ GetEnumerator() sealed
public:
virtual IEnumerator<KeyValuePair<String^, StringBuilder^>>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<string, StringBuilder>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<string, StringBuilder>>
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<string, StringBuilder>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<string, StringBuilder>>

Return Value

Type: Online IEnumerator Online KeyValuePair Online String, Online StringBuilder

Implements

Online IEnumerable T GetEnumerator
See Also
Compiler Outputs Class
Compiler Outputs Members
NFX.RelationalModel Namespace


Compiler.Outputs Properties

Compiler Outputs Properties NFX Class Library

The Compiler Outputs type exposes the following members.
Properties
 | Name | Description
Public property | CurrentOrUnspecified | Returns last output used or Unspecified output
Public property | Item |
Back to Top
See Also
Compiler Outputs Class
NFX.RelationalModel Namespace


Compiler.Outputs.CurrentOrUnspecified Property

Compiler Outputs CurrentOrUnspecified Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns last output used or Unspecified output

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StringBuilder CurrentOrUnspecified { get; }
public StringBuilder CurrentOrUnspecified { get; }
Public ReadOnly Property CurrentOrUnspecified As StringBuilder
    Get
Public ReadOnly Property CurrentOrUnspecified As StringBuilder
    Get
public:
property StringBuilder^ CurrentOrUnspecified {
    StringBuilder^ get ();
}
public:
property StringBuilder^ CurrentOrUnspecified {
    StringBuilder^ get ();
}
member CurrentOrUnspecified : StringBuilder with get
member CurrentOrUnspecified : StringBuilder with get

Property Value

Type: Online StringBuilder
See Also
Compiler Outputs Class
Compiler Outputs Members
NFX.RelationalModel Namespace


Compiler.Outputs.Item Property

Compiler Outputs Item Property NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StringBuilder this[
    string key
] { get; }
public StringBuilder this[
    string key
] { get; }
Public ReadOnly Default Property Item (
    key As String
) As StringBuilder
    Get
Public ReadOnly Default Property Item (
    key As String
) As StringBuilder
    Get
public:
property StringBuilder^ default[String^ key] {
    StringBuilder^ get (String^ key);
}
public:
property StringBuilder^ default[String^ key] {
    StringBuilder^ get (String^ key);
}
member Item : StringBuilder with get
member Item : StringBuilder with get

Parameters

key
Type: Online System String

Property Value

Type: Online StringBuilder
See Also
Compiler Outputs Class
Compiler Outputs Members
NFX.RelationalModel Namespace


CompilerException Class

CompilerException Class NFX Class Library

Thrown by relational schema compiler
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.RelationalModel RelationalException
NFX.RelationalModel CompilerException

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CompilerException : RelationalException
[SerializableAttribute]
public class CompilerException : RelationalException
<SerializableAttribute>
Public Class CompilerException
    Inherits RelationalException
<SerializableAttribute>
Public Class CompilerException
    Inherits RelationalException
[SerializableAttribute]
public ref class CompilerException : public RelationalException
[SerializableAttribute]
public ref class CompilerException : public RelationalException
[<SerializableAttribute>]
type CompilerException =
    class
        inherit RelationalException
    end
[<SerializableAttribute>]
type CompilerException =
    class
        inherit RelationalException
    end
See Also
CompilerException Members
NFX.RelationalModel Namespace


CompilerException Members

CompilerException Members NFX Class Library

The CompilerException type exposes the following members.
Constructors
 | Name | Description
Public method | CompilerException(String) | Initializes a new instance of the CompilerException class
Public method | CompilerException(String, Exception) | Initializes a new instance of the CompilerException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
CompilerException Class
NFX.RelationalModel Namespace


CompilerException Constructor

CompilerException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | CompilerException(String) | Initializes a new instance of the CompilerException class
Public method | CompilerException(String, Exception) | Initializes a new instance of the CompilerException class
Back to Top
See Also
CompilerException Class
CompilerException Members
NFX.RelationalModel Namespace


CompilerException Constructor (String)

CompilerException Constructor (String) NFX Class Library

Initializes a new instance of the CompilerException class

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CompilerException(
    string message
)
public CompilerException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
CompilerException(
    String^ message
)
public:
CompilerException(
    String^ message
)
new :
        message : string -> CompilerException
new :
        message : string -> CompilerException

Parameters

message
Type: Online System String
See Also
CompilerException Class
CompilerException Members
CompilerException Overload
NFX.RelationalModel Namespace


CompilerException Constructor (String, Exception)

CompilerException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CompilerException class

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CompilerException(
    string message,
    Exception inner
)
public CompilerException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
CompilerException(
    String^ message,
    Exception^ inner
)
public:
CompilerException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> CompilerException
new :
        message : string *
        inner : Exception -> CompilerException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
CompilerException Class
CompilerException Members
CompilerException Overload
NFX.RelationalModel Namespace


CompilerException Methods

CompilerException Methods NFX Class Library

The CompilerException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
CompilerException Class
NFX.RelationalModel Namespace


CompilerException Properties

CompilerException Properties NFX Class Library

The CompilerException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
CompilerException Class
NFX.RelationalModel Namespace


CompilerException Events

CompilerException Events NFX Class Library

The CompilerException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
CompilerException Class
NFX.RelationalModel Namespace


MsSQLServerCompiler Class

MsSQLServerCompiler Class NFX Class Library

Compiles relation schema into Ms SQL Server scripts
Inheritance Hierarchy
Online System Object
NFX.RelationalModel Compiler
NFX.RelationalModel RDBMSCompiler
NFX.RelationalModel MsSQLServerCompiler

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MsSQLServerCompiler : RDBMSCompiler
public class MsSQLServerCompiler : RDBMSCompiler
Public Class MsSQLServerCompiler
    Inherits RDBMSCompiler
Public Class MsSQLServerCompiler
    Inherits RDBMSCompiler
public ref class MsSQLServerCompiler : public RDBMSCompiler
public ref class MsSQLServerCompiler : public RDBMSCompiler
type MsSQLServerCompiler =
    class
        inherit RDBMSCompiler
    end
type MsSQLServerCompiler =
    class
        inherit RDBMSCompiler
    end
See Also
MsSQLServerCompiler Members
NFX.RelationalModel Namespace


MsSQLServerCompiler Members

MsSQLServerCompiler Members NFX Class Library

The MsSQLServerCompiler type exposes the following members.
Constructors
 | Name | Description
Public method | MsSQLServerCompiler | Initializes a new instance of the MsSQLServerCompiler class
Back to Top
Methods
 | Name | Description
Protected method | BuildNodeOutput | (Inherited from RDBMSCompiler.)
Protected method | BuildOutputs | Override to perform compilation into output, the base implementation loops over all nodes and interprets script includes (Inherited from Compiler.)
Public method | Compile | (Inherited from Compiler.)
Public method | Configure | (Inherited from Compiler.)
Protected method | CreateDomain | Turns domain name into domain instance (Inherited from RDBMSCompiler.)
Protected method | DoColumn | Override to compile a RDBMS Table (Inherited from RDBMSCompiler.)
Protected method | DoCompile | (Inherited from RDBMSCompiler.)
Protected method | DoForeignKeys | Override to outpur foreign keys (Inherited from RDBMSCompiler.)
Protected method | DoPrimaryKeys | Override to output primary keys (Inherited from RDBMSCompiler.)
Protected method | DoReadIndexSection | Override to read primary key definition form sub-section of table (not column level) (Inherited from RDBMSCompiler.)
Protected method | DoReadPrimaryKeySection | Override to read primary key definition form sub-section of table (not column level) (Inherited from RDBMSCompiler.)
Protected method | DoTable | Override to compile a RDBMS Table (Inherited from RDBMSCompiler.)
Protected method | DoTableIndexes | Override to compile a indexes per table (Inherited from RDBMSCompiler.)
Protected method | EnsureNotCompiled | (Inherited from Compiler.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | EscapeFileName | Replaces incompatible characters for file names with "_" (Inherited from Compiler.)
Public method | EscapeString | (Inherited from Compiler.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | FormatColumnStatement | (Inherited from RDBMSCompiler.)
Public method | GetColumnNullNotNullClause | (Inherited from RDBMSCompiler.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetOutputFileSuffix | (Inherited from RDBMSCompiler.)
Public method | GetQuotedIdentifierName | (Overrides RDBMSCompiler GetQuotedIdentifierName(RDBMSEntityType, String).)
Public method | GetStatementDelimiterScript | (Overrides RDBMSCompiler GetStatementDelimiterScript(RDBMSEntityType, Boolean).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IncludeScriptFile | Performs a script file include (Inherited from Compiler.)
Public method | IncludeScriptText | Performs a verbatim script text include (Inherited from Compiler.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformEntityName | Override to map a name from schema into the name that should be used in the output (i.e. real table name) (Inherited from RDBMSCompiler.)
Public method | TransformKeywordCase | (Inherited from RDBMSCompiler.)
Public method | TransformSortOrder | (Inherited from RDBMSCompiler.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_CompileErrors | (Inherited from Compiler.)
Back to Top
Properties
 | Name | Description
Public property | CompileErrors | Returns exception errors that were generated during compilation. This property returns "planned" errors that were caused by input, whereas CompileException returns exception that indicates some more drastic abnormality that broke the compilation (Inherited from Compiler.)
Public property | CompileException | Returns exception that surfaced during compilation, or null if source has not compiled yet or no exception happened. This exception is different form CompileErrors because it indicates some un=planned condition that broke the compilation process (Inherited from Compiler.)
Public property | DomainSearchPaths | Gets/sets ';' separated list of domain search namespaces paths (Inherited from RDBMSCompiler.)
Public property | HasCompiled | Returns true to indicate that compiler has already processed the source schema (Inherited from Compiler.)
Public property | HasErrors | Returns true when this instance did not compile properly (Inherited from Compiler.)
Public property | Name | (Overrides Compiler Name.)
Public property | NameCaseSensitivity | Determines whether output script is case sensitive (Inherited from Compiler.)
Public property | NameComparison | Returns string comparison options for names that depend on target case sensitivity (Inherited from Compiler.)
Public property | OutputPath | Determines where compiled output is placed (Inherited from Compiler.)
Public property | OutputPrefix | Determines the prefix for output names (Inherited from Compiler.)
Public property | Schema | Returns source schema (Inherited from Compiler.)
Public property | SeparateForeignKeys | Gets/sets the flag that indicates whether foreign keys should be written in the separate output from tables. Foreign keys get added as constraints under the table when referenced table is already present and this flag is false (Inherited from RDBMSCompiler.)
Public property | SeparateIndexes | Gets/sets the flag that indicates whether indexes should be written in the separate output from tables (Inherited from RDBMSCompiler.)
Public property | Target | (Overrides RDBMSCompiler Target.)
Back to Top
See Also
MsSQLServerCompiler Class
NFX.RelationalModel Namespace


MsSQLServerCompiler Constructor

MsSQLServerCompiler Constructor NFX Class Library

Initializes a new instance of the MsSQLServerCompiler class

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MsSQLServerCompiler(
    Schema schema
)
public MsSQLServerCompiler(
    Schema schema
)
Public Sub New (
    schema As Schema
)
Public Sub New (
    schema As Schema
)
public:
MsSQLServerCompiler(
    Schema^ schema
)
public:
MsSQLServerCompiler(
    Schema^ schema
)
new :
        schema : Schema -> MsSQLServerCompiler
new :
        schema : Schema -> MsSQLServerCompiler

Parameters

schema
Type: NFX.RelationalModel Schema
See Also
MsSQLServerCompiler Class
MsSQLServerCompiler Members
NFX.RelationalModel Namespace


MsSQLServerCompiler Fields

MsSQLServerCompiler Fields NFX Class Library

The MsSQLServerCompiler type exposes the following members.
Fields
 | Name | Description
Protected field | m_CompileErrors | (Inherited from Compiler.)
Back to Top
See Also
MsSQLServerCompiler Class
NFX.RelationalModel Namespace


MsSQLServerCompiler Methods

MsSQLServerCompiler Methods NFX Class Library

The MsSQLServerCompiler type exposes the following members.
Methods
 | Name | Description
Protected method | BuildNodeOutput | (Inherited from RDBMSCompiler.)
Protected method | BuildOutputs | Override to perform compilation into output, the base implementation loops over all nodes and interprets script includes (Inherited from Compiler.)
Public method | Compile | (Inherited from Compiler.)
Public method | Configure | (Inherited from Compiler.)
Protected method | CreateDomain | Turns domain name into domain instance (Inherited from RDBMSCompiler.)
Protected method | DoColumn | Override to compile a RDBMS Table (Inherited from RDBMSCompiler.)
Protected method | DoCompile | (Inherited from RDBMSCompiler.)
Protected method | DoForeignKeys | Override to outpur foreign keys (Inherited from RDBMSCompiler.)
Protected method | DoPrimaryKeys | Override to output primary keys (Inherited from RDBMSCompiler.)
Protected method | DoReadIndexSection | Override to read primary key definition form sub-section of table (not column level) (Inherited from RDBMSCompiler.)
Protected method | DoReadPrimaryKeySection | Override to read primary key definition form sub-section of table (not column level) (Inherited from RDBMSCompiler.)
Protected method | DoTable | Override to compile a RDBMS Table (Inherited from RDBMSCompiler.)
Protected method | DoTableIndexes | Override to compile a indexes per table (Inherited from RDBMSCompiler.)
Protected method | EnsureNotCompiled | (Inherited from Compiler.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | EscapeFileName | Replaces incompatible characters for file names with "_" (Inherited from Compiler.)
Public method | EscapeString | (Inherited from Compiler.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | FormatColumnStatement | (Inherited from RDBMSCompiler.)
Public method | GetColumnNullNotNullClause | (Inherited from RDBMSCompiler.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetOutputFileSuffix | (Inherited from RDBMSCompiler.)
Public method | GetQuotedIdentifierName | (Overrides RDBMSCompiler GetQuotedIdentifierName(RDBMSEntityType, String).)
Public method | GetStatementDelimiterScript | (Overrides RDBMSCompiler GetStatementDelimiterScript(RDBMSEntityType, Boolean).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IncludeScriptFile | Performs a script file include (Inherited from Compiler.)
Public method | IncludeScriptText | Performs a verbatim script text include (Inherited from Compiler.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformEntityName | Override to map a name from schema into the name that should be used in the output (i.e. real table name) (Inherited from RDBMSCompiler.)
Public method | TransformKeywordCase | (Inherited from RDBMSCompiler.)
Public method | TransformSortOrder | (Inherited from RDBMSCompiler.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MsSQLServerCompiler Class
NFX.RelationalModel Namespace


MsSQLServerCompiler.GetQuotedIdentifierName Method

MsSQLServerCompiler GetQuotedIdentifierName Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetQuotedIdentifierName(
    RDBMSEntityType type,
    string name
)
public override string GetQuotedIdentifierName(
    RDBMSEntityType type,
    string name
)
Public Overrides Function GetQuotedIdentifierName (
    type As RDBMSEntityType,
    name As String
) As String
Public Overrides Function GetQuotedIdentifierName (
    type As RDBMSEntityType,
    name As String
) As String
public:
virtual String^ GetQuotedIdentifierName(
    RDBMSEntityType type,
    String^ name
) override
public:
virtual String^ GetQuotedIdentifierName(
    RDBMSEntityType type,
    String^ name
) override
abstract GetQuotedIdentifierName :
        type : RDBMSEntityType *
        name : string -> string
override GetQuotedIdentifierName :
        type : RDBMSEntityType *
        name : string -> string
abstract GetQuotedIdentifierName :
        type : RDBMSEntityType *
        name : string -> string
override GetQuotedIdentifierName :
        type : RDBMSEntityType *
        name : string -> string

Parameters

type
Type: NFX.RelationalModel RDBMSEntityType
name
Type: Online System String

Return Value

Type: Online String
See Also
MsSQLServerCompiler Class
MsSQLServerCompiler Members
NFX.RelationalModel Namespace


MsSQLServerCompiler.GetStatementDelimiterScript Method

MsSQLServerCompiler GetStatementDelimiterScript Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetStatementDelimiterScript(
    RDBMSEntityType type,
    bool start
)
public override string GetStatementDelimiterScript(
    RDBMSEntityType type,
    bool start
)
Public Overrides Function GetStatementDelimiterScript (
    type As RDBMSEntityType,
    start As Boolean
) As String
Public Overrides Function GetStatementDelimiterScript (
    type As RDBMSEntityType,
    start As Boolean
) As String
public:
virtual String^ GetStatementDelimiterScript(
    RDBMSEntityType type,
    bool start
) override
public:
virtual String^ GetStatementDelimiterScript(
    RDBMSEntityType type,
    bool start
) override
abstract GetStatementDelimiterScript :
        type : RDBMSEntityType *
        start : bool -> string
override GetStatementDelimiterScript :
        type : RDBMSEntityType *
        start : bool -> string
abstract GetStatementDelimiterScript :
        type : RDBMSEntityType *
        start : bool -> string
override GetStatementDelimiterScript :
        type : RDBMSEntityType *
        start : bool -> string

Parameters

type
Type: NFX.RelationalModel RDBMSEntityType
start
Type: Online System Boolean

Return Value

Type: Online String
See Also
MsSQLServerCompiler Class
MsSQLServerCompiler Members
NFX.RelationalModel Namespace


MsSQLServerCompiler Properties

MsSQLServerCompiler Properties NFX Class Library

The MsSQLServerCompiler type exposes the following members.
Properties
 | Name | Description
Public property | CompileErrors | Returns exception errors that were generated during compilation. This property returns "planned" errors that were caused by input, whereas CompileException returns exception that indicates some more drastic abnormality that broke the compilation (Inherited from Compiler.)
Public property | CompileException | Returns exception that surfaced during compilation, or null if source has not compiled yet or no exception happened. This exception is different form CompileErrors because it indicates some un=planned condition that broke the compilation process (Inherited from Compiler.)
Public property | DomainSearchPaths | Gets/sets ';' separated list of domain search namespaces paths (Inherited from RDBMSCompiler.)
Public property | HasCompiled | Returns true to indicate that compiler has already processed the source schema (Inherited from Compiler.)
Public property | HasErrors | Returns true when this instance did not compile properly (Inherited from Compiler.)
Public property | Name | (Overrides Compiler Name.)
Public property | NameCaseSensitivity | Determines whether output script is case sensitive (Inherited from Compiler.)
Public property | NameComparison | Returns string comparison options for names that depend on target case sensitivity (Inherited from Compiler.)
Public property | OutputPath | Determines where compiled output is placed (Inherited from Compiler.)
Public property | OutputPrefix | Determines the prefix for output names (Inherited from Compiler.)
Public property | Schema | Returns source schema (Inherited from Compiler.)
Public property | SeparateForeignKeys | Gets/sets the flag that indicates whether foreign keys should be written in the separate output from tables. Foreign keys get added as constraints under the table when referenced table is already present and this flag is false (Inherited from RDBMSCompiler.)
Public property | SeparateIndexes | Gets/sets the flag that indicates whether indexes should be written in the separate output from tables (Inherited from RDBMSCompiler.)
Public property | Target | (Overrides RDBMSCompiler Target.)
Back to Top
See Also
MsSQLServerCompiler Class
NFX.RelationalModel Namespace


MsSQLServerCompiler.Name Property

MsSQLServerCompiler Name Property NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Name { get; }
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
MsSQLServerCompiler Class
MsSQLServerCompiler Members
NFX.RelationalModel Namespace


MsSQLServerCompiler.Target Property

MsSQLServerCompiler Target Property NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TargetType Target { get; }
public override TargetType Target { get; }
Public Overrides ReadOnly Property Target As TargetType
    Get
Public Overrides ReadOnly Property Target As TargetType
    Get
public:
virtual property TargetType Target {
    TargetType get () override;
}
public:
virtual property TargetType Target {
    TargetType get () override;
}
abstract Target : TargetType with get
override Target : TargetType with get
abstract Target : TargetType with get
override Target : TargetType with get

Property Value

Type: TargetType
See Also
MsSQLServerCompiler Class
MsSQLServerCompiler Members
NFX.RelationalModel Namespace


MySQLCompiler Class

MySQLCompiler Class NFX Class Library

Compiles relation schema into MySQL scripts
Inheritance Hierarchy
Online System Object
NFX.RelationalModel Compiler
NFX.RelationalModel RDBMSCompiler
NFX.RelationalModel MySQLCompiler

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MySQLCompiler : RDBMSCompiler
public class MySQLCompiler : RDBMSCompiler
Public Class MySQLCompiler
    Inherits RDBMSCompiler
Public Class MySQLCompiler
    Inherits RDBMSCompiler
public ref class MySQLCompiler : public RDBMSCompiler
public ref class MySQLCompiler : public RDBMSCompiler
type MySQLCompiler =
    class
        inherit RDBMSCompiler
    end
type MySQLCompiler =
    class
        inherit RDBMSCompiler
    end
See Also
MySQLCompiler Members
NFX.RelationalModel Namespace


MySQLCompiler Members

MySQLCompiler Members NFX Class Library

The MySQLCompiler type exposes the following members.
Constructors
 | Name | Description
Public method | MySQLCompiler | Initializes a new instance of the MySQLCompiler class
Back to Top
Methods
 | Name | Description
Protected method | BuildNodeOutput | (Inherited from RDBMSCompiler.)
Protected method | BuildOutputs | Override to perform compilation into output, the base implementation loops over all nodes and interprets script includes (Inherited from Compiler.)
Public method | Compile | (Inherited from Compiler.)
Public method | Configure | (Inherited from Compiler.)
Protected method | CreateDomain | Turns domain name into domain instance (Inherited from RDBMSCompiler.)
Protected method | DoColumn | Override to compile a RDBMS Table (Inherited from RDBMSCompiler.)
Protected method | DoCompile | (Inherited from RDBMSCompiler.)
Protected method | DoForeignKeys | Override to outpur foreign keys (Inherited from RDBMSCompiler.)
Protected method | DoPrimaryKeys | Override to output primary keys (Inherited from RDBMSCompiler.)
Protected method | DoReadIndexSection | Override to read primary key definition form sub-section of table (not column level) (Inherited from RDBMSCompiler.)
Protected method | DoReadPrimaryKeySection | Override to read primary key definition form sub-section of table (not column level) (Inherited from RDBMSCompiler.)
Protected method | DoTable | Override to compile a RDBMS Table (Inherited from RDBMSCompiler.)
Protected method | DoTableIndexes | Override to compile a indexes per table (Inherited from RDBMSCompiler.)
Protected method | EnsureNotCompiled | (Inherited from Compiler.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | EscapeFileName | Replaces incompatible characters for file names with "_" (Inherited from Compiler.)
Public method | EscapeString | (Inherited from Compiler.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | FormatColumnStatement | (Overrides RDBMSCompiler FormatColumnStatement(String, String, String, String, String, String, String).)
Public method | GetColumnNullNotNullClause | (Inherited from RDBMSCompiler.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetOutputFileSuffix | (Inherited from RDBMSCompiler.)
Public method | GetQuotedIdentifierName | (Overrides RDBMSCompiler GetQuotedIdentifierName(RDBMSEntityType, String).)
Public method | GetStatementDelimiterScript | (Overrides RDBMSCompiler GetStatementDelimiterScript(RDBMSEntityType, Boolean).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IncludeScriptFile | Performs a script file include (Inherited from Compiler.)
Public method | IncludeScriptText | Performs a verbatim script text include (Inherited from Compiler.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformEntityName | (Overrides RDBMSCompiler TransformEntityName(RDBMSEntity).)
Public method | TransformKeywordCase | (Inherited from RDBMSCompiler.)
Public method | TransformSortOrder | (Inherited from RDBMSCompiler.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_CompileErrors | (Inherited from Compiler.)
Back to Top
Properties
 | Name | Description
Public property | CompileErrors | Returns exception errors that were generated during compilation. This property returns "planned" errors that were caused by input, whereas CompileException returns exception that indicates some more drastic abnormality that broke the compilation (Inherited from Compiler.)
Public property | CompileException | Returns exception that surfaced during compilation, or null if source has not compiled yet or no exception happened. This exception is different form CompileErrors because it indicates some un=planned condition that broke the compilation process (Inherited from Compiler.)
Public property | DomainSearchPaths | Gets/sets ';' separated list of domain search namespaces paths (Inherited from RDBMSCompiler.)
Public property | HasCompiled | Returns true to indicate that compiler has already processed the source schema (Inherited from Compiler.)
Public property | HasErrors | Returns true when this instance did not compile properly (Inherited from Compiler.)
Public property | Name | (Overrides Compiler Name.)
Public property | NameCaseSensitivity | Determines whether output script is case sensitive (Inherited from Compiler.)
Public property | NameComparison | Returns string comparison options for names that depend on target case sensitivity (Inherited from Compiler.)
Public property | OutputPath | Determines where compiled output is placed (Inherited from Compiler.)
Public property | OutputPrefix | Determines the prefix for output names (Inherited from Compiler.)
Public property | Schema | Returns source schema (Inherited from Compiler.)
Public property | SeparateForeignKeys | Gets/sets the flag that indicates whether foreign keys should be written in the separate output from tables. Foreign keys get added as constraints under the table when referenced table is already present and this flag is false (Inherited from RDBMSCompiler.)
Public property | SeparateIndexes | Gets/sets the flag that indicates whether indexes should be written in the separate output from tables (Inherited from RDBMSCompiler.)
Public property | Target | (Overrides RDBMSCompiler Target.)
Back to Top
See Also
MySQLCompiler Class
NFX.RelationalModel Namespace


MySQLCompiler Constructor

MySQLCompiler Constructor NFX Class Library

Initializes a new instance of the MySQLCompiler class

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MySQLCompiler(
    Schema schema
)
public MySQLCompiler(
    Schema schema
)
Public Sub New (
    schema As Schema
)
Public Sub New (
    schema As Schema
)
public:
MySQLCompiler(
    Schema^ schema
)
public:
MySQLCompiler(
    Schema^ schema
)
new :
        schema : Schema -> MySQLCompiler
new :
        schema : Schema -> MySQLCompiler

Parameters

schema
Type: NFX.RelationalModel Schema
See Also
MySQLCompiler Class
MySQLCompiler Members
NFX.RelationalModel Namespace


MySQLCompiler Fields

MySQLCompiler Fields NFX Class Library

The MySQLCompiler type exposes the following members.
Fields
 | Name | Description
Protected field | m_CompileErrors | (Inherited from Compiler.)
Back to Top
See Also
MySQLCompiler Class
NFX.RelationalModel Namespace


MySQLCompiler Methods

MySQLCompiler Methods NFX Class Library

The MySQLCompiler type exposes the following members.
Methods
 | Name | Description
Protected method | BuildNodeOutput | (Inherited from RDBMSCompiler.)
Protected method | BuildOutputs | Override to perform compilation into output, the base implementation loops over all nodes and interprets script includes (Inherited from Compiler.)
Public method | Compile | (Inherited from Compiler.)
Public method | Configure | (Inherited from Compiler.)
Protected method | CreateDomain | Turns domain name into domain instance (Inherited from RDBMSCompiler.)
Protected method | DoColumn | Override to compile a RDBMS Table (Inherited from RDBMSCompiler.)
Protected method | DoCompile | (Inherited from RDBMSCompiler.)
Protected method | DoForeignKeys | Override to outpur foreign keys (Inherited from RDBMSCompiler.)
Protected method | DoPrimaryKeys | Override to output primary keys (Inherited from RDBMSCompiler.)
Protected method | DoReadIndexSection | Override to read primary key definition form sub-section of table (not column level) (Inherited from RDBMSCompiler.)
Protected method | DoReadPrimaryKeySection | Override to read primary key definition form sub-section of table (not column level) (Inherited from RDBMSCompiler.)
Protected method | DoTable | Override to compile a RDBMS Table (Inherited from RDBMSCompiler.)
Protected method | DoTableIndexes | Override to compile a indexes per table (Inherited from RDBMSCompiler.)
Protected method | EnsureNotCompiled | (Inherited from Compiler.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | EscapeFileName | Replaces incompatible characters for file names with "_" (Inherited from Compiler.)
Public method | EscapeString | (Inherited from Compiler.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | FormatColumnStatement | (Overrides RDBMSCompiler FormatColumnStatement(String, String, String, String, String, String, String).)
Public method | GetColumnNullNotNullClause | (Inherited from RDBMSCompiler.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetOutputFileSuffix | (Inherited from RDBMSCompiler.)
Public method | GetQuotedIdentifierName | (Overrides RDBMSCompiler GetQuotedIdentifierName(RDBMSEntityType, String).)
Public method | GetStatementDelimiterScript | (Overrides RDBMSCompiler GetStatementDelimiterScript(RDBMSEntityType, Boolean).)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IncludeScriptFile | Performs a script file include (Inherited from Compiler.)
Public method | IncludeScriptText | Performs a verbatim script text include (Inherited from Compiler.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformEntityName | (Overrides RDBMSCompiler TransformEntityName(RDBMSEntity).)
Public method | TransformKeywordCase | (Inherited from RDBMSCompiler.)
Public method | TransformSortOrder | (Inherited from RDBMSCompiler.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MySQLCompiler Class
NFX.RelationalModel Namespace


MySQLCompiler.FormatColumnStatement Method

MySQLCompiler FormatColumnStatement Method NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override string FormatColumnStatement(
    string column,
    string type,
    string nnull,
    string auto,
    string dflt,
    string chk,
    string comment
)
protected override string FormatColumnStatement(
    string column,
    string type,
    string nnull,
    string auto,
    string dflt,
    string chk,
    string comment
)
Protected Overrides Function FormatColumnStatement (
    column As String,
    type As String,
    nnull As String,
    auto As String,
    dflt As String,
    chk As String,
    comment As String
) As String
Protected Overrides Function FormatColumnStatement (
    column As String,
    type As String,
    nnull As String,
    auto As String,
    dflt As String,
    chk As String,
    comment As String
) As String
protected:
virtual String^ FormatColumnStatement(
    String^ column,
    String^ type,
    String^ nnull,
    String^ auto,
    String^ dflt,
    String^ chk,
    String^ comment
) override
protected:
virtual String^ FormatColumnStatement(
    String^ column,
    String^ type,
    String^ nnull,
    String^ auto,
    String^ dflt,
    String^ chk,
    String^ comment
) override
abstract FormatColumnStatement :
        column : string *
        type : string *
        nnull : string *
        auto : string *
        dflt : string *
        chk : string *
        comment : string -> string
override FormatColumnStatement :
        column : string *
        type : string *
        nnull : string *
        auto : string *
        dflt : string *
        chk : string *
        comment : string -> string
abstract FormatColumnStatement :
        column : string *
        type : string *
        nnull : string *
        auto : string *
        dflt : string *
        chk : string *
        comment : string -> string
override FormatColumnStatement :
        column : string *
        type : string *
        nnull : string *
        auto : string *
        dflt : string *
        chk : string *
        comment : string -> string

Parameters

column
Type: Online System String
type
Type: Online System String
nnull
Type: Online System String
auto
Type: Online System String
dflt
Type: Online System String
chk
Type: Online System String
comment
Type: Online System String

Return Value

Type: Online String
See Also
MySQLCompiler Class
MySQLCompiler Members
NFX.RelationalModel Namespace


MySQLCompiler.GetQuotedIdentifierName Method

MySQLCompiler GetQuotedIdentifierName Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetQuotedIdentifierName(
    RDBMSEntityType type,
    string name
)
public override string GetQuotedIdentifierName(
    RDBMSEntityType type,
    string name
)
Public Overrides Function GetQuotedIdentifierName (
    type As RDBMSEntityType,
    name As String
) As String
Public Overrides Function GetQuotedIdentifierName (
    type As RDBMSEntityType,
    name As String
) As String
public:
virtual String^ GetQuotedIdentifierName(
    RDBMSEntityType type,
    String^ name
) override
public:
virtual String^ GetQuotedIdentifierName(
    RDBMSEntityType type,
    String^ name
) override
abstract GetQuotedIdentifierName :
        type : RDBMSEntityType *
        name : string -> string
override GetQuotedIdentifierName :
        type : RDBMSEntityType *
        name : string -> string
abstract GetQuotedIdentifierName :
        type : RDBMSEntityType *
        name : string -> string
override GetQuotedIdentifierName :
        type : RDBMSEntityType *
        name : string -> string

Parameters

type
Type: NFX.RelationalModel RDBMSEntityType
name
Type: Online System String

Return Value

Type: Online String
See Also
MySQLCompiler Class
MySQLCompiler Members
NFX.RelationalModel Namespace


MySQLCompiler.GetStatementDelimiterScript Method

MySQLCompiler GetStatementDelimiterScript Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetStatementDelimiterScript(
    RDBMSEntityType type,
    bool start
)
public override string GetStatementDelimiterScript(
    RDBMSEntityType type,
    bool start
)
Public Overrides Function GetStatementDelimiterScript (
    type As RDBMSEntityType,
    start As Boolean
) As String
Public Overrides Function GetStatementDelimiterScript (
    type As RDBMSEntityType,
    start As Boolean
) As String
public:
virtual String^ GetStatementDelimiterScript(
    RDBMSEntityType type,
    bool start
) override
public:
virtual String^ GetStatementDelimiterScript(
    RDBMSEntityType type,
    bool start
) override
abstract GetStatementDelimiterScript :
        type : RDBMSEntityType *
        start : bool -> string
override GetStatementDelimiterScript :
        type : RDBMSEntityType *
        start : bool -> string
abstract GetStatementDelimiterScript :
        type : RDBMSEntityType *
        start : bool -> string
override GetStatementDelimiterScript :
        type : RDBMSEntityType *
        start : bool -> string

Parameters

type
Type: NFX.RelationalModel RDBMSEntityType
start
Type: Online System Boolean

Return Value

Type: Online String
See Also
MySQLCompiler Class
MySQLCompiler Members
NFX.RelationalModel Namespace


MySQLCompiler.TransformEntityName Method

MySQLCompiler TransformEntityName Method NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void TransformEntityName(
    RDBMSEntity entity
)
public override void TransformEntityName(
    RDBMSEntity entity
)
Public Overrides Sub TransformEntityName (
    entity As RDBMSEntity
)
Public Overrides Sub TransformEntityName (
    entity As RDBMSEntity
)
public:
virtual void TransformEntityName(
    RDBMSEntity^ entity
) override
public:
virtual void TransformEntityName(
    RDBMSEntity^ entity
) override
abstract TransformEntityName :
        entity : RDBMSEntity -> unit
override TransformEntityName :
        entity : RDBMSEntity -> unit
abstract TransformEntityName :
        entity : RDBMSEntity -> unit
override TransformEntityName :
        entity : RDBMSEntity -> unit

Parameters

entity
Type: NFX.RelationalModel RDBMSEntity
See Also
MySQLCompiler Class
MySQLCompiler Members
NFX.RelationalModel Namespace


MySQLCompiler Properties

MySQLCompiler Properties NFX Class Library

The MySQLCompiler type exposes the following members.
Properties
 | Name | Description
Public property | CompileErrors | Returns exception errors that were generated during compilation. This property returns "planned" errors that were caused by input, whereas CompileException returns exception that indicates some more drastic abnormality that broke the compilation (Inherited from Compiler.)
Public property | CompileException | Returns exception that surfaced during compilation, or null if source has not compiled yet or no exception happened. This exception is different form CompileErrors because it indicates some un=planned condition that broke the compilation process (Inherited from Compiler.)
Public property | DomainSearchPaths | Gets/sets ';' separated list of domain search namespaces paths (Inherited from RDBMSCompiler.)
Public property | HasCompiled | Returns true to indicate that compiler has already processed the source schema (Inherited from Compiler.)
Public property | HasErrors | Returns true when this instance did not compile properly (Inherited from Compiler.)
Public property | Name | (Overrides Compiler Name.)
Public property | NameCaseSensitivity | Determines whether output script is case sensitive (Inherited from Compiler.)
Public property | NameComparison | Returns string comparison options for names that depend on target case sensitivity (Inherited from Compiler.)
Public property | OutputPath | Determines where compiled output is placed (Inherited from Compiler.)
Public property | OutputPrefix | Determines the prefix for output names (Inherited from Compiler.)
Public property | Schema | Returns source schema (Inherited from Compiler.)
Public property | SeparateForeignKeys | Gets/sets the flag that indicates whether foreign keys should be written in the separate output from tables. Foreign keys get added as constraints under the table when referenced table is already present and this flag is false (Inherited from RDBMSCompiler.)
Public property | SeparateIndexes | Gets/sets the flag that indicates whether indexes should be written in the separate output from tables (Inherited from RDBMSCompiler.)
Public property | Target | (Overrides RDBMSCompiler Target.)
Back to Top
See Also
MySQLCompiler Class
NFX.RelationalModel Namespace


MySQLCompiler.Name Property

MySQLCompiler Name Property NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Name { get; }
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
MySQLCompiler Class
MySQLCompiler Members
NFX.RelationalModel Namespace


MySQLCompiler.Target Property

MySQLCompiler Target Property NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TargetType Target { get; }
public override TargetType Target { get; }
Public Overrides ReadOnly Property Target As TargetType
    Get
Public Overrides ReadOnly Property Target As TargetType
    Get
public:
virtual property TargetType Target {
    TargetType get () override;
}
public:
virtual property TargetType Target {
    TargetType get () override;
}
abstract Target : TargetType with get
override Target : TargetType with get
abstract Target : TargetType with get
override Target : TargetType with get

Property Value

Type: TargetType
See Also
MySQLCompiler Class
MySQLCompiler Members
NFX.RelationalModel Namespace


NameCaseSensitivity Enumeration

NameCaseSensitivity Enumeration NFX Class Library

Denotes naming case sensitivity

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum NameCaseSensitivity
public enum NameCaseSensitivity
Public Enumeration NameCaseSensitivity
Public Enumeration NameCaseSensitivity
public enum class NameCaseSensitivity
public enum class NameCaseSensitivity
type NameCaseSensitivity
type NameCaseSensitivity
Members
Member name | Value | Description
ToLower | 0 |
ToUpper | 1 |
AsIs | 2 |
See Also
NFX.RelationalModel Namespace


RDBMSCompiler Class

RDBMSCompiler Class NFX Class Library

Compiles schema scripts into RDBMS-family of outputs - the ones that have tables, keys, indexes, constraints etc...
Inheritance Hierarchy
Online System Object
NFX.RelationalModel Compiler
NFX.RelationalModel RDBMSCompiler
NFX.RelationalModel MsSQLServerCompiler
NFX.RelationalModel MySQLCompiler

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class RDBMSCompiler : Compiler
public abstract class RDBMSCompiler : Compiler
Public MustInherit Class RDBMSCompiler
    Inherits Compiler
Public MustInherit Class RDBMSCompiler
    Inherits Compiler
public ref class RDBMSCompiler abstract : public Compiler
public ref class RDBMSCompiler abstract : public Compiler
[<AbstractClassAttribute>]
type RDBMSCompiler =
    class
        inherit Compiler
    end
[<AbstractClassAttribute>]
type RDBMSCompiler =
    class
        inherit Compiler
    end
See Also
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler Members

RDBMSCompiler Members NFX Class Library

The RDBMSCompiler type exposes the following members.
Constructors
 | Name | Description
Public method | RDBMSCompiler | Initializes a new instance of the RDBMSCompiler class
Back to Top
Methods
 | Name | Description
Protected method | BuildNodeOutput | (Overrides Compiler BuildNodeOutput(IConfigSectionNode, Compiler Outputs).)
Protected method | BuildOutputs | Override to perform compilation into output, the base implementation loops over all nodes and interprets script includes (Inherited from Compiler.)
Public method | Compile | (Inherited from Compiler.)
Public method | Configure | (Inherited from Compiler.)
Protected method | CreateDomain | Turns domain name into domain instance
Protected method | DoColumn | Override to compile a RDBMS Table
Protected method | DoCompile | (Overrides Compiler DoCompile .)
Protected method | DoForeignKeys | Override to outpur foreign keys
Protected method | DoPrimaryKeys | Override to output primary keys
Protected method | DoReadIndexSection | Override to read primary key definition form sub-section of table (not column level)
Protected method | DoReadPrimaryKeySection | Override to read primary key definition form sub-section of table (not column level)
Protected method | DoTable | Override to compile a RDBMS Table
Protected method | DoTableIndexes | Override to compile a indexes per table
Protected method | EnsureNotCompiled | (Inherited from Compiler.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | EscapeFileName | Replaces incompatible characters for file names with "_" (Inherited from Compiler.)
Public method | EscapeString | (Inherited from Compiler.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | FormatColumnStatement |
Public method | GetColumnNullNotNullClause |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetOutputFileSuffix | (Overrides Compiler GetOutputFileSuffix(String).)
Public method | GetQuotedIdentifierName | Gets quoted name per particular technology
Public method | GetStatementDelimiterScript | Override to return statement delimiter script for particular target , i.e. "Go" at the statementend for MsSQL Server T-SQL
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IncludeScriptFile | Performs a script file include (Inherited from Compiler.)
Public method | IncludeScriptText | Performs a verbatim script text include (Inherited from Compiler.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformEntityName | Override to map a name from schema into the name that should be used in the output (i.e. real table name)
Public method | TransformKeywordCase |
Public method | TransformSortOrder |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | CLUSTERED_ATTR |
 | COLUMN_SECTION |
 | COMMENT_ATTR |
 | DEFAULT_ATTR |
 | DEFAULT_DOMAIN_SEARCH_PATHS |
 | FOREIGN_KEYS_OUTPUT |
 | INDEX_SECTION |
 | INDEXES_OUTPUT |
 | LENGTH_ATTR |
Protected field | m_CompileErrors | (Inherited from Compiler.)
 | NAME_ATTR |
 | NOW_FUNC |
 | ORDER_ATTR |
 | PRIMARY_KEY_SECTION |
 | REFERENCE_SECTION |
 | REQUIRED_ATTR |
 | SEQUENCES_OUTPUT |
 | SHORT_NAME_ATTR |
 | TABLE_SECTION |
 | TABLES_OUTPUT |
 | TYPE_ATTR |
 | UNIQUE_ATTR |
Back to Top
Properties
 | Name | Description
Public property | CompileErrors | Returns exception errors that were generated during compilation. This property returns "planned" errors that were caused by input, whereas CompileException returns exception that indicates some more drastic abnormality that broke the compilation (Inherited from Compiler.)
Public property | CompileException | Returns exception that surfaced during compilation, or null if source has not compiled yet or no exception happened. This exception is different form CompileErrors because it indicates some un=planned condition that broke the compilation process (Inherited from Compiler.)
Public property | DomainSearchPaths | Gets/sets ';' separated list of domain search namespaces paths
Public property | HasCompiled | Returns true to indicate that compiler has already processed the source schema (Inherited from Compiler.)
Public property | HasErrors | Returns true when this instance did not compile properly (Inherited from Compiler.)
Public property | Name | Returns the name of the technology that this compiler targets. i.e. "ORACLE", "RecordModel" (Inherited from Compiler.)
Public property | NameCaseSensitivity | Determines whether output script is case sensitive (Inherited from Compiler.)
Public property | NameComparison | Returns string comparison options for names that depend on target case sensitivity (Inherited from Compiler.)
Public property | OutputPath | Determines where compiled output is placed (Inherited from Compiler.)
Public property | OutputPrefix | Determines the prefix for output names (Inherited from Compiler.)
Public property | Schema | Returns source schema (Inherited from Compiler.)
Public property | SeparateForeignKeys | Gets/sets the flag that indicates whether foreign keys should be written in the separate output from tables. Foreign keys get added as constraints under the table when referenced table is already present and this flag is false
Public property | SeparateIndexes | Gets/sets the flag that indicates whether indexes should be written in the separate output from tables
Public property | Target | (Overrides Compiler Target.)
Back to Top
See Also
RDBMSCompiler Class
NFX.RelationalModel Namespace


RDBMSCompiler Constructor

RDBMSCompiler Constructor NFX Class Library

Initializes a new instance of the RDBMSCompiler class

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RDBMSCompiler(
    Schema schema
)
public RDBMSCompiler(
    Schema schema
)
Public Sub New (
    schema As Schema
)
Public Sub New (
    schema As Schema
)
public:
RDBMSCompiler(
    Schema^ schema
)
public:
RDBMSCompiler(
    Schema^ schema
)
new :
        schema : Schema -> RDBMSCompiler
new :
        schema : Schema -> RDBMSCompiler

Parameters

schema
Type: NFX.RelationalModel Schema
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler Fields

RDBMSCompiler Fields NFX Class Library

The RDBMSCompiler type exposes the following members.
Fields
 | Name | Description
 | CLUSTERED_ATTR |
 | COLUMN_SECTION |
 | COMMENT_ATTR |
 | DEFAULT_ATTR |
 | DEFAULT_DOMAIN_SEARCH_PATHS |
 | FOREIGN_KEYS_OUTPUT |
 | INDEX_SECTION |
 | INDEXES_OUTPUT |
 | LENGTH_ATTR |
Protected field | m_CompileErrors | (Inherited from Compiler.)
 | NAME_ATTR |
 | NOW_FUNC |
 | ORDER_ATTR |
 | PRIMARY_KEY_SECTION |
 | REFERENCE_SECTION |
 | REQUIRED_ATTR |
 | SEQUENCES_OUTPUT |
 | SHORT_NAME_ATTR |
 | TABLE_SECTION |
 | TABLES_OUTPUT |
 | TYPE_ATTR |
 | UNIQUE_ATTR |
Back to Top
See Also
RDBMSCompiler Class
NFX.RelationalModel Namespace


RDBMSCompiler.CLUSTERED_ATTR Field

RDBMSCompiler CLUSTERED_ATTR Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CLUSTERED_ATTR
public const string CLUSTERED_ATTR
Public Const CLUSTERED_ATTR As String
Public Const CLUSTERED_ATTR As String
public:
literal String^ CLUSTERED_ATTR
public:
literal String^ CLUSTERED_ATTR
static val mutable CLUSTERED_ATTR: string
static val mutable CLUSTERED_ATTR: string

Field Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.COLUMN_SECTION Field

RDBMSCompiler COLUMN_SECTION Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string COLUMN_SECTION
public const string COLUMN_SECTION
Public Const COLUMN_SECTION As String
Public Const COLUMN_SECTION As String
public:
literal String^ COLUMN_SECTION
public:
literal String^ COLUMN_SECTION
static val mutable COLUMN_SECTION: string
static val mutable COLUMN_SECTION: string

Field Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.COMMENT_ATTR Field

RDBMSCompiler COMMENT_ATTR Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string COMMENT_ATTR
public const string COMMENT_ATTR
Public Const COMMENT_ATTR As String
Public Const COMMENT_ATTR As String
public:
literal String^ COMMENT_ATTR
public:
literal String^ COMMENT_ATTR
static val mutable COMMENT_ATTR: string
static val mutable COMMENT_ATTR: string

Field Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.DEFAULT_ATTR Field

RDBMSCompiler DEFAULT_ATTR Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_ATTR
public const string DEFAULT_ATTR
Public Const DEFAULT_ATTR As String
Public Const DEFAULT_ATTR As String
public:
literal String^ DEFAULT_ATTR
public:
literal String^ DEFAULT_ATTR
static val mutable DEFAULT_ATTR: string
static val mutable DEFAULT_ATTR: string

Field Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.DEFAULT_DOMAIN_SEARCH_PATHS Field

RDBMSCompiler DEFAULT_DOMAIN_SEARCH_PATHS Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_DOMAIN_SEARCH_PATHS
public const string DEFAULT_DOMAIN_SEARCH_PATHS
Public Const DEFAULT_DOMAIN_SEARCH_PATHS As String
Public Const DEFAULT_DOMAIN_SEARCH_PATHS As String
public:
literal String^ DEFAULT_DOMAIN_SEARCH_PATHS
public:
literal String^ DEFAULT_DOMAIN_SEARCH_PATHS
static val mutable DEFAULT_DOMAIN_SEARCH_PATHS: string
static val mutable DEFAULT_DOMAIN_SEARCH_PATHS: string

Field Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.FOREIGN_KEYS_OUTPUT Field

RDBMSCompiler FOREIGN_KEYS_OUTPUT Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string FOREIGN_KEYS_OUTPUT
public const string FOREIGN_KEYS_OUTPUT
Public Const FOREIGN_KEYS_OUTPUT As String
Public Const FOREIGN_KEYS_OUTPUT As String
public:
literal String^ FOREIGN_KEYS_OUTPUT
public:
literal String^ FOREIGN_KEYS_OUTPUT
static val mutable FOREIGN_KEYS_OUTPUT: string
static val mutable FOREIGN_KEYS_OUTPUT: string

Field Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.INDEX_SECTION Field

RDBMSCompiler INDEX_SECTION Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string INDEX_SECTION
public const string INDEX_SECTION
Public Const INDEX_SECTION As String
Public Const INDEX_SECTION As String
public:
literal String^ INDEX_SECTION
public:
literal String^ INDEX_SECTION
static val mutable INDEX_SECTION: string
static val mutable INDEX_SECTION: string

Field Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.INDEXES_OUTPUT Field

RDBMSCompiler INDEXES_OUTPUT Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string INDEXES_OUTPUT
public const string INDEXES_OUTPUT
Public Const INDEXES_OUTPUT As String
Public Const INDEXES_OUTPUT As String
public:
literal String^ INDEXES_OUTPUT
public:
literal String^ INDEXES_OUTPUT
static val mutable INDEXES_OUTPUT: string
static val mutable INDEXES_OUTPUT: string

Field Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.LENGTH_ATTR Field

RDBMSCompiler LENGTH_ATTR Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string LENGTH_ATTR
public const string LENGTH_ATTR
Public Const LENGTH_ATTR As String
Public Const LENGTH_ATTR As String
public:
literal String^ LENGTH_ATTR
public:
literal String^ LENGTH_ATTR
static val mutable LENGTH_ATTR: string
static val mutable LENGTH_ATTR: string

Field Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.NAME_ATTR Field

RDBMSCompiler NAME_ATTR Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string NAME_ATTR
public const string NAME_ATTR
Public Const NAME_ATTR As String
Public Const NAME_ATTR As String
public:
literal String^ NAME_ATTR
public:
literal String^ NAME_ATTR
static val mutable NAME_ATTR: string
static val mutable NAME_ATTR: string

Field Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.NOW_FUNC Field

RDBMSCompiler NOW_FUNC Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string NOW_FUNC
public const string NOW_FUNC
Public Const NOW_FUNC As String
Public Const NOW_FUNC As String
public:
literal String^ NOW_FUNC
public:
literal String^ NOW_FUNC
static val mutable NOW_FUNC: string
static val mutable NOW_FUNC: string

Field Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.ORDER_ATTR Field

RDBMSCompiler ORDER_ATTR Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ORDER_ATTR
public const string ORDER_ATTR
Public Const ORDER_ATTR As String
Public Const ORDER_ATTR As String
public:
literal String^ ORDER_ATTR
public:
literal String^ ORDER_ATTR
static val mutable ORDER_ATTR: string
static val mutable ORDER_ATTR: string

Field Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.PRIMARY_KEY_SECTION Field

RDBMSCompiler PRIMARY_KEY_SECTION Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PRIMARY_KEY_SECTION
public const string PRIMARY_KEY_SECTION
Public Const PRIMARY_KEY_SECTION As String
Public Const PRIMARY_KEY_SECTION As String
public:
literal String^ PRIMARY_KEY_SECTION
public:
literal String^ PRIMARY_KEY_SECTION
static val mutable PRIMARY_KEY_SECTION: string
static val mutable PRIMARY_KEY_SECTION: string

Field Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.REFERENCE_SECTION Field

RDBMSCompiler REFERENCE_SECTION Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string REFERENCE_SECTION
public const string REFERENCE_SECTION
Public Const REFERENCE_SECTION As String
Public Const REFERENCE_SECTION As String
public:
literal String^ REFERENCE_SECTION
public:
literal String^ REFERENCE_SECTION
static val mutable REFERENCE_SECTION: string
static val mutable REFERENCE_SECTION: string

Field Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.REQUIRED_ATTR Field

RDBMSCompiler REQUIRED_ATTR Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string REQUIRED_ATTR
public const string REQUIRED_ATTR
Public Const REQUIRED_ATTR As String
Public Const REQUIRED_ATTR As String
public:
literal String^ REQUIRED_ATTR
public:
literal String^ REQUIRED_ATTR
static val mutable REQUIRED_ATTR: string
static val mutable REQUIRED_ATTR: string

Field Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.SEQUENCES_OUTPUT Field

RDBMSCompiler SEQUENCES_OUTPUT Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SEQUENCES_OUTPUT
public const string SEQUENCES_OUTPUT
Public Const SEQUENCES_OUTPUT As String
Public Const SEQUENCES_OUTPUT As String
public:
literal String^ SEQUENCES_OUTPUT
public:
literal String^ SEQUENCES_OUTPUT
static val mutable SEQUENCES_OUTPUT: string
static val mutable SEQUENCES_OUTPUT: string

Field Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.SHORT_NAME_ATTR Field

RDBMSCompiler SHORT_NAME_ATTR Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string SHORT_NAME_ATTR
public const string SHORT_NAME_ATTR
Public Const SHORT_NAME_ATTR As String
Public Const SHORT_NAME_ATTR As String
public:
literal String^ SHORT_NAME_ATTR
public:
literal String^ SHORT_NAME_ATTR
static val mutable SHORT_NAME_ATTR: string
static val mutable SHORT_NAME_ATTR: string

Field Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.TABLE_SECTION Field

RDBMSCompiler TABLE_SECTION Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string TABLE_SECTION
public const string TABLE_SECTION
Public Const TABLE_SECTION As String
Public Const TABLE_SECTION As String
public:
literal String^ TABLE_SECTION
public:
literal String^ TABLE_SECTION
static val mutable TABLE_SECTION: string
static val mutable TABLE_SECTION: string

Field Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.TABLES_OUTPUT Field

RDBMSCompiler TABLES_OUTPUT Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string TABLES_OUTPUT
public const string TABLES_OUTPUT
Public Const TABLES_OUTPUT As String
Public Const TABLES_OUTPUT As String
public:
literal String^ TABLES_OUTPUT
public:
literal String^ TABLES_OUTPUT
static val mutable TABLES_OUTPUT: string
static val mutable TABLES_OUTPUT: string

Field Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.TYPE_ATTR Field

RDBMSCompiler TYPE_ATTR Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string TYPE_ATTR
public const string TYPE_ATTR
Public Const TYPE_ATTR As String
Public Const TYPE_ATTR As String
public:
literal String^ TYPE_ATTR
public:
literal String^ TYPE_ATTR
static val mutable TYPE_ATTR: string
static val mutable TYPE_ATTR: string

Field Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.UNIQUE_ATTR Field

RDBMSCompiler UNIQUE_ATTR Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string UNIQUE_ATTR
public const string UNIQUE_ATTR
Public Const UNIQUE_ATTR As String
Public Const UNIQUE_ATTR As String
public:
literal String^ UNIQUE_ATTR
public:
literal String^ UNIQUE_ATTR
static val mutable UNIQUE_ATTR: string
static val mutable UNIQUE_ATTR: string

Field Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler Methods

RDBMSCompiler Methods NFX Class Library

The RDBMSCompiler type exposes the following members.
Methods
 | Name | Description
Protected method | BuildNodeOutput | (Overrides Compiler BuildNodeOutput(IConfigSectionNode, Compiler Outputs).)
Protected method | BuildOutputs | Override to perform compilation into output, the base implementation loops over all nodes and interprets script includes (Inherited from Compiler.)
Public method | Compile | (Inherited from Compiler.)
Public method | Configure | (Inherited from Compiler.)
Protected method | CreateDomain | Turns domain name into domain instance
Protected method | DoColumn | Override to compile a RDBMS Table
Protected method | DoCompile | (Overrides Compiler DoCompile .)
Protected method | DoForeignKeys | Override to outpur foreign keys
Protected method | DoPrimaryKeys | Override to output primary keys
Protected method | DoReadIndexSection | Override to read primary key definition form sub-section of table (not column level)
Protected method | DoReadPrimaryKeySection | Override to read primary key definition form sub-section of table (not column level)
Protected method | DoTable | Override to compile a RDBMS Table
Protected method | DoTableIndexes | Override to compile a indexes per table
Protected method | EnsureNotCompiled | (Inherited from Compiler.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | EscapeFileName | Replaces incompatible characters for file names with "_" (Inherited from Compiler.)
Public method | EscapeString | (Inherited from Compiler.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | FormatColumnStatement |
Public method | GetColumnNullNotNullClause |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetOutputFileSuffix | (Overrides Compiler GetOutputFileSuffix(String).)
Public method | GetQuotedIdentifierName | Gets quoted name per particular technology
Public method | GetStatementDelimiterScript | Override to return statement delimiter script for particular target , i.e. "Go" at the statementend for MsSQL Server T-SQL
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | IncludeScriptFile | Performs a script file include (Inherited from Compiler.)
Public method | IncludeScriptText | Performs a verbatim script text include (Inherited from Compiler.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformEntityName | Override to map a name from schema into the name that should be used in the output (i.e. real table name)
Public method | TransformKeywordCase |
Public method | TransformSortOrder |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
RDBMSCompiler Class
NFX.RelationalModel Namespace


RDBMSCompiler.BuildNodeOutput Method

RDBMSCompiler BuildNodeOutput Method NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void BuildNodeOutput(
    IConfigSectionNode node,
    Compiler..::..Outputs outputs
)
protected override void BuildNodeOutput(
    IConfigSectionNode node,
    Compiler..::..Outputs outputs
)
Protected Overrides Sub BuildNodeOutput (
    node As IConfigSectionNode,
    outputs As Compiler..::..Outputs
)
Protected Overrides Sub BuildNodeOutput (
    node As IConfigSectionNode,
    outputs As Compiler..::..Outputs
)
protected:
virtual void BuildNodeOutput(
    IConfigSectionNode^ node,
    Compiler..::..Outputs^ outputs
) override
protected:
virtual void BuildNodeOutput(
    IConfigSectionNode^ node,
    Compiler..::..Outputs^ outputs
) override
abstract BuildNodeOutput :
        node : IConfigSectionNode *
        outputs : Compiler..::..Outputs -> unit
override BuildNodeOutput :
        node : IConfigSectionNode *
        outputs : Compiler..::..Outputs -> unit
abstract BuildNodeOutput :
        node : IConfigSectionNode *
        outputs : Compiler..::..Outputs -> unit
override BuildNodeOutput :
        node : IConfigSectionNode *
        outputs : Compiler..::..Outputs -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
outputs
Type: NFX.RelationalModel Compiler Outputs
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.CreateDomain Method

RDBMSCompiler CreateDomain Method NFX Class Library

Turns domain name into domain instance

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual RDBMSDomain CreateDomain(
    string sourcePath,
    string name,
    IConfigNode node
)
protected virtual RDBMSDomain CreateDomain(
    string sourcePath,
    string name,
    IConfigNode node
)
Protected Overridable Function CreateDomain (
    sourcePath As String,
    name As String,
    node As IConfigNode
) As RDBMSDomain
Protected Overridable Function CreateDomain (
    sourcePath As String,
    name As String,
    node As IConfigNode
) As RDBMSDomain
protected:
virtual RDBMSDomain^ CreateDomain(
    String^ sourcePath,
    String^ name,
    IConfigNode^ node
)
protected:
virtual RDBMSDomain^ CreateDomain(
    String^ sourcePath,
    String^ name,
    IConfigNode^ node
)
abstract CreateDomain :
        sourcePath : string *
        name : string *
        node : IConfigNode -> RDBMSDomain
override CreateDomain :
        sourcePath : string *
        name : string *
        node : IConfigNode -> RDBMSDomain
abstract CreateDomain :
        sourcePath : string *
        name : string *
        node : IConfigNode -> RDBMSDomain
override CreateDomain :
        sourcePath : string *
        name : string *
        node : IConfigNode -> RDBMSDomain

Parameters

sourcePath
Type: Online System String
name
Type: Online System String
node
Type: NFX.Environment IConfigNode

Return Value

Type: RDBMSDomain
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.DoColumn Method

RDBMSCompiler DoColumn Method NFX Class Library

Override to compile a RDBMS Table

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoColumn(
    IConfigSectionNode columnNode,
    RDBMSEntity table,
    StringBuilder sb,
    ref bool firstColumn,
    Compiler..::..Outputs outputs
)
protected virtual void DoColumn(
    IConfigSectionNode columnNode,
    RDBMSEntity table,
    StringBuilder sb,
    ref bool firstColumn,
    Compiler..::..Outputs outputs
)
Protected Overridable Sub DoColumn (
    columnNode As IConfigSectionNode,
    table As RDBMSEntity,
    sb As StringBuilder,
    ByRef firstColumn As Boolean,
    outputs As Compiler..::..Outputs
)
Protected Overridable Sub DoColumn (
    columnNode As IConfigSectionNode,
    table As RDBMSEntity,
    sb As StringBuilder,
    ByRef firstColumn As Boolean,
    outputs As Compiler..::..Outputs
)
protected:
virtual void DoColumn(
    IConfigSectionNode^ columnNode,
    RDBMSEntity^ table,
    StringBuilder^ sb,
    bool% firstColumn,
    Compiler..::..Outputs^ outputs
)
protected:
virtual void DoColumn(
    IConfigSectionNode^ columnNode,
    RDBMSEntity^ table,
    StringBuilder^ sb,
    bool% firstColumn,
    Compiler..::..Outputs^ outputs
)
abstract DoColumn :
        columnNode : IConfigSectionNode *
        table : RDBMSEntity *
        sb : StringBuilder *
        firstColumn : bool byref *
        outputs : Compiler..::..Outputs -> unit
override DoColumn :
        columnNode : IConfigSectionNode *
        table : RDBMSEntity *
        sb : StringBuilder *
        firstColumn : bool byref *
        outputs : Compiler..::..Outputs -> unit
abstract DoColumn :
        columnNode : IConfigSectionNode *
        table : RDBMSEntity *
        sb : StringBuilder *
        firstColumn : bool byref *
        outputs : Compiler..::..Outputs -> unit
override DoColumn :
        columnNode : IConfigSectionNode *
        table : RDBMSEntity *
        sb : StringBuilder *
        firstColumn : bool byref *
        outputs : Compiler..::..Outputs -> unit

Parameters

columnNode
Type: NFX.Environment IConfigSectionNode
table
Type: NFX.RelationalModel RDBMSEntity
sb
Type: Online System.Text StringBuilder
firstColumn
Type: Online System Boolean
outputs
Type: NFX.RelationalModel Compiler Outputs
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.DoCompile Method

RDBMSCompiler DoCompile Method NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoCompile()
protected override void DoCompile()
Protected Overrides Sub DoCompile
Protected Overrides Sub DoCompile
protected:
virtual void DoCompile() override
protected:
virtual void DoCompile() override
abstract DoCompile : unit -> unit
override DoCompile : unit -> unit
abstract DoCompile : unit -> unit
override DoCompile : unit -> unit
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.DoForeignKeys Method

RDBMSCompiler DoForeignKeys Method NFX Class Library

Override to outpur foreign keys

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoForeignKeys(
    RDBMSEntity table,
    StringBuilder sb,
    ref bool firstItem,
    Compiler..::..Outputs outputs
)
protected virtual void DoForeignKeys(
    RDBMSEntity table,
    StringBuilder sb,
    ref bool firstItem,
    Compiler..::..Outputs outputs
)
Protected Overridable Sub DoForeignKeys (
    table As RDBMSEntity,
    sb As StringBuilder,
    ByRef firstItem As Boolean,
    outputs As Compiler..::..Outputs
)
Protected Overridable Sub DoForeignKeys (
    table As RDBMSEntity,
    sb As StringBuilder,
    ByRef firstItem As Boolean,
    outputs As Compiler..::..Outputs
)
protected:
virtual void DoForeignKeys(
    RDBMSEntity^ table,
    StringBuilder^ sb,
    bool% firstItem,
    Compiler..::..Outputs^ outputs
)
protected:
virtual void DoForeignKeys(
    RDBMSEntity^ table,
    StringBuilder^ sb,
    bool% firstItem,
    Compiler..::..Outputs^ outputs
)
abstract DoForeignKeys :
        table : RDBMSEntity *
        sb : StringBuilder *
        firstItem : bool byref *
        outputs : Compiler..::..Outputs -> unit
override DoForeignKeys :
        table : RDBMSEntity *
        sb : StringBuilder *
        firstItem : bool byref *
        outputs : Compiler..::..Outputs -> unit
abstract DoForeignKeys :
        table : RDBMSEntity *
        sb : StringBuilder *
        firstItem : bool byref *
        outputs : Compiler..::..Outputs -> unit
override DoForeignKeys :
        table : RDBMSEntity *
        sb : StringBuilder *
        firstItem : bool byref *
        outputs : Compiler..::..Outputs -> unit

Parameters

table
Type: NFX.RelationalModel RDBMSEntity
sb
Type: Online System.Text StringBuilder
firstItem
Type: Online System Boolean
outputs
Type: NFX.RelationalModel Compiler Outputs
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.DoPrimaryKeys Method

RDBMSCompiler DoPrimaryKeys Method NFX Class Library

Override to output primary keys

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoPrimaryKeys(
    RDBMSEntity table,
    StringBuilder sb,
    ref bool firstItem
)
protected virtual void DoPrimaryKeys(
    RDBMSEntity table,
    StringBuilder sb,
    ref bool firstItem
)
Protected Overridable Sub DoPrimaryKeys (
    table As RDBMSEntity,
    sb As StringBuilder,
    ByRef firstItem As Boolean
)
Protected Overridable Sub DoPrimaryKeys (
    table As RDBMSEntity,
    sb As StringBuilder,
    ByRef firstItem As Boolean
)
protected:
virtual void DoPrimaryKeys(
    RDBMSEntity^ table,
    StringBuilder^ sb,
    bool% firstItem
)
protected:
virtual void DoPrimaryKeys(
    RDBMSEntity^ table,
    StringBuilder^ sb,
    bool% firstItem
)
abstract DoPrimaryKeys :
        table : RDBMSEntity *
        sb : StringBuilder *
        firstItem : bool byref -> unit
override DoPrimaryKeys :
        table : RDBMSEntity *
        sb : StringBuilder *
        firstItem : bool byref -> unit
abstract DoPrimaryKeys :
        table : RDBMSEntity *
        sb : StringBuilder *
        firstItem : bool byref -> unit
override DoPrimaryKeys :
        table : RDBMSEntity *
        sb : StringBuilder *
        firstItem : bool byref -> unit

Parameters

table
Type: NFX.RelationalModel RDBMSEntity
sb
Type: Online System.Text StringBuilder
firstItem
Type: Online System Boolean
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.DoReadIndexSection Method

RDBMSCompiler DoReadIndexSection Method NFX Class Library

Override to read primary key definition form sub-section of table (not column level)

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoReadIndexSection(
    IConfigSectionNode idxNode,
    RDBMSEntity table
)
protected virtual void DoReadIndexSection(
    IConfigSectionNode idxNode,
    RDBMSEntity table
)
Protected Overridable Sub DoReadIndexSection (
    idxNode As IConfigSectionNode,
    table As RDBMSEntity
)
Protected Overridable Sub DoReadIndexSection (
    idxNode As IConfigSectionNode,
    table As RDBMSEntity
)
protected:
virtual void DoReadIndexSection(
    IConfigSectionNode^ idxNode,
    RDBMSEntity^ table
)
protected:
virtual void DoReadIndexSection(
    IConfigSectionNode^ idxNode,
    RDBMSEntity^ table
)
abstract DoReadIndexSection :
        idxNode : IConfigSectionNode *
        table : RDBMSEntity -> unit
override DoReadIndexSection :
        idxNode : IConfigSectionNode *
        table : RDBMSEntity -> unit
abstract DoReadIndexSection :
        idxNode : IConfigSectionNode *
        table : RDBMSEntity -> unit
override DoReadIndexSection :
        idxNode : IConfigSectionNode *
        table : RDBMSEntity -> unit

Parameters

idxNode
Type: NFX.Environment IConfigSectionNode
table
Type: NFX.RelationalModel RDBMSEntity
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.DoReadPrimaryKeySection Method

RDBMSCompiler DoReadPrimaryKeySection Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to read primary key definition form sub-section of table (not column level)

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoReadPrimaryKeySection(
    IConfigSectionNode pkNode,
    RDBMSEntity table
)
protected virtual void DoReadPrimaryKeySection(
    IConfigSectionNode pkNode,
    RDBMSEntity table
)
Protected Overridable Sub DoReadPrimaryKeySection (
    pkNode As IConfigSectionNode,
    table As RDBMSEntity
)
Protected Overridable Sub DoReadPrimaryKeySection (
    pkNode As IConfigSectionNode,
    table As RDBMSEntity
)
protected:
virtual void DoReadPrimaryKeySection(
    IConfigSectionNode^ pkNode,
    RDBMSEntity^ table
)
protected:
virtual void DoReadPrimaryKeySection(
    IConfigSectionNode^ pkNode,
    RDBMSEntity^ table
)
abstract DoReadPrimaryKeySection :
        pkNode : IConfigSectionNode *
        table : RDBMSEntity -> unit
override DoReadPrimaryKeySection :
        pkNode : IConfigSectionNode *
        table : RDBMSEntity -> unit
abstract DoReadPrimaryKeySection :
        pkNode : IConfigSectionNode *
        table : RDBMSEntity -> unit
override DoReadPrimaryKeySection :
        pkNode : IConfigSectionNode *
        table : RDBMSEntity -> unit

Parameters

pkNode
Type: NFX.Environment IConfigSectionNode
table
Type: NFX.RelationalModel RDBMSEntity
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.DoTable Method

RDBMSCompiler DoTable Method NFX Class Library

Override to compile a RDBMS Table

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoTable(
    IConfigSectionNode tableNode,
    Compiler..::..Outputs outputs
)
protected virtual void DoTable(
    IConfigSectionNode tableNode,
    Compiler..::..Outputs outputs
)
Protected Overridable Sub DoTable (
    tableNode As IConfigSectionNode,
    outputs As Compiler..::..Outputs
)
Protected Overridable Sub DoTable (
    tableNode As IConfigSectionNode,
    outputs As Compiler..::..Outputs
)
protected:
virtual void DoTable(
    IConfigSectionNode^ tableNode,
    Compiler..::..Outputs^ outputs
)
protected:
virtual void DoTable(
    IConfigSectionNode^ tableNode,
    Compiler..::..Outputs^ outputs
)
abstract DoTable :
        tableNode : IConfigSectionNode *
        outputs : Compiler..::..Outputs -> unit
override DoTable :
        tableNode : IConfigSectionNode *
        outputs : Compiler..::..Outputs -> unit
abstract DoTable :
        tableNode : IConfigSectionNode *
        outputs : Compiler..::..Outputs -> unit
override DoTable :
        tableNode : IConfigSectionNode *
        outputs : Compiler..::..Outputs -> unit

Parameters

tableNode
Type: NFX.Environment IConfigSectionNode
outputs
Type: NFX.RelationalModel Compiler Outputs
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.DoTableIndexes Method

RDBMSCompiler DoTableIndexes Method NFX Class Library

Override to compile a indexes per table

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoTableIndexes(
    RDBMSEntity table,
    Compiler..::..Outputs outputs
)
protected virtual void DoTableIndexes(
    RDBMSEntity table,
    Compiler..::..Outputs outputs
)
Protected Overridable Sub DoTableIndexes (
    table As RDBMSEntity,
    outputs As Compiler..::..Outputs
)
Protected Overridable Sub DoTableIndexes (
    table As RDBMSEntity,
    outputs As Compiler..::..Outputs
)
protected:
virtual void DoTableIndexes(
    RDBMSEntity^ table,
    Compiler..::..Outputs^ outputs
)
protected:
virtual void DoTableIndexes(
    RDBMSEntity^ table,
    Compiler..::..Outputs^ outputs
)
abstract DoTableIndexes :
        table : RDBMSEntity *
        outputs : Compiler..::..Outputs -> unit
override DoTableIndexes :
        table : RDBMSEntity *
        outputs : Compiler..::..Outputs -> unit
abstract DoTableIndexes :
        table : RDBMSEntity *
        outputs : Compiler..::..Outputs -> unit
override DoTableIndexes :
        table : RDBMSEntity *
        outputs : Compiler..::..Outputs -> unit

Parameters

table
Type: NFX.RelationalModel RDBMSEntity
outputs
Type: NFX.RelationalModel Compiler Outputs
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.FormatColumnStatement Method

RDBMSCompiler FormatColumnStatement Method NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual string FormatColumnStatement(
    string column,
    string type,
    string nnull,
    string auto,
    string dflt,
    string chk,
    string comment
)
protected virtual string FormatColumnStatement(
    string column,
    string type,
    string nnull,
    string auto,
    string dflt,
    string chk,
    string comment
)
Protected Overridable Function FormatColumnStatement (
    column As String,
    type As String,
    nnull As String,
    auto As String,
    dflt As String,
    chk As String,
    comment As String
) As String
Protected Overridable Function FormatColumnStatement (
    column As String,
    type As String,
    nnull As String,
    auto As String,
    dflt As String,
    chk As String,
    comment As String
) As String
protected:
virtual String^ FormatColumnStatement(
    String^ column,
    String^ type,
    String^ nnull,
    String^ auto,
    String^ dflt,
    String^ chk,
    String^ comment
)
protected:
virtual String^ FormatColumnStatement(
    String^ column,
    String^ type,
    String^ nnull,
    String^ auto,
    String^ dflt,
    String^ chk,
    String^ comment
)
abstract FormatColumnStatement :
        column : string *
        type : string *
        nnull : string *
        auto : string *
        dflt : string *
        chk : string *
        comment : string -> string
override FormatColumnStatement :
        column : string *
        type : string *
        nnull : string *
        auto : string *
        dflt : string *
        chk : string *
        comment : string -> string
abstract FormatColumnStatement :
        column : string *
        type : string *
        nnull : string *
        auto : string *
        dflt : string *
        chk : string *
        comment : string -> string
override FormatColumnStatement :
        column : string *
        type : string *
        nnull : string *
        auto : string *
        dflt : string *
        chk : string *
        comment : string -> string

Parameters

column
Type: Online System String
type
Type: Online System String
nnull
Type: Online System String
auto
Type: Online System String
dflt
Type: Online System String
chk
Type: Online System String
comment
Type: Online System String

Return Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.GetColumnNullNotNullClause Method

RDBMSCompiler GetColumnNullNotNullClause Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string GetColumnNullNotNullClause(
    RDBMSEntity column,
    bool required
)
public virtual string GetColumnNullNotNullClause(
    RDBMSEntity column,
    bool required
)
Public Overridable Function GetColumnNullNotNullClause (
    column As RDBMSEntity,
    required As Boolean
) As String
Public Overridable Function GetColumnNullNotNullClause (
    column As RDBMSEntity,
    required As Boolean
) As String
public:
virtual String^ GetColumnNullNotNullClause(
    RDBMSEntity^ column,
    bool required
)
public:
virtual String^ GetColumnNullNotNullClause(
    RDBMSEntity^ column,
    bool required
)
abstract GetColumnNullNotNullClause :
        column : RDBMSEntity *
        required : bool -> string
override GetColumnNullNotNullClause :
        column : RDBMSEntity *
        required : bool -> string
abstract GetColumnNullNotNullClause :
        column : RDBMSEntity *
        required : bool -> string
override GetColumnNullNotNullClause :
        column : RDBMSEntity *
        required : bool -> string

Parameters

column
Type: NFX.RelationalModel RDBMSEntity
required
Type: Online System Boolean

Return Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.GetOutputFileSuffix Method

RDBMSCompiler GetOutputFileSuffix Method NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetOutputFileSuffix(
    string outputName
)
public override string GetOutputFileSuffix(
    string outputName
)
Public Overrides Function GetOutputFileSuffix (
    outputName As String
) As String
Public Overrides Function GetOutputFileSuffix (
    outputName As String
) As String
public:
virtual String^ GetOutputFileSuffix(
    String^ outputName
) override
public:
virtual String^ GetOutputFileSuffix(
    String^ outputName
) override
abstract GetOutputFileSuffix :
        outputName : string -> string
override GetOutputFileSuffix :
        outputName : string -> string
abstract GetOutputFileSuffix :
        outputName : string -> string
override GetOutputFileSuffix :
        outputName : string -> string

Parameters

outputName
Type: Online System String

Return Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.GetQuotedIdentifierName Method

RDBMSCompiler GetQuotedIdentifierName Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets quoted name per particular technology

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string GetQuotedIdentifierName(
    RDBMSEntityType type,
    string name
)
public virtual string GetQuotedIdentifierName(
    RDBMSEntityType type,
    string name
)
Public Overridable Function GetQuotedIdentifierName (
    type As RDBMSEntityType,
    name As String
) As String
Public Overridable Function GetQuotedIdentifierName (
    type As RDBMSEntityType,
    name As String
) As String
public:
virtual String^ GetQuotedIdentifierName(
    RDBMSEntityType type,
    String^ name
)
public:
virtual String^ GetQuotedIdentifierName(
    RDBMSEntityType type,
    String^ name
)
abstract GetQuotedIdentifierName :
        type : RDBMSEntityType *
        name : string -> string
override GetQuotedIdentifierName :
        type : RDBMSEntityType *
        name : string -> string
abstract GetQuotedIdentifierName :
        type : RDBMSEntityType *
        name : string -> string
override GetQuotedIdentifierName :
        type : RDBMSEntityType *
        name : string -> string

Parameters

type
Type: NFX.RelationalModel RDBMSEntityType
name
Type: Online System String

Return Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.GetStatementDelimiterScript Method

RDBMSCompiler GetStatementDelimiterScript Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to return statement delimiter script for particular target , i.e. "Go" at the statementend for MsSQL Server T-SQL

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string GetStatementDelimiterScript(
    RDBMSEntityType type,
    bool start
)
public virtual string GetStatementDelimiterScript(
    RDBMSEntityType type,
    bool start
)
Public Overridable Function GetStatementDelimiterScript (
    type As RDBMSEntityType,
    start As Boolean
) As String
Public Overridable Function GetStatementDelimiterScript (
    type As RDBMSEntityType,
    start As Boolean
) As String
public:
virtual String^ GetStatementDelimiterScript(
    RDBMSEntityType type,
    bool start
)
public:
virtual String^ GetStatementDelimiterScript(
    RDBMSEntityType type,
    bool start
)
abstract GetStatementDelimiterScript :
        type : RDBMSEntityType *
        start : bool -> string
override GetStatementDelimiterScript :
        type : RDBMSEntityType *
        start : bool -> string
abstract GetStatementDelimiterScript :
        type : RDBMSEntityType *
        start : bool -> string
override GetStatementDelimiterScript :
        type : RDBMSEntityType *
        start : bool -> string

Parameters

type
Type: NFX.RelationalModel RDBMSEntityType
start
Type: Online System Boolean

Return Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.TransformEntityName Method

RDBMSCompiler TransformEntityName Method NFX Class Library

Override to map a name from schema into the name that should be used in the output (i.e. real table name)

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void TransformEntityName(
    RDBMSEntity entity
)
public virtual void TransformEntityName(
    RDBMSEntity entity
)
Public Overridable Sub TransformEntityName (
    entity As RDBMSEntity
)
Public Overridable Sub TransformEntityName (
    entity As RDBMSEntity
)
public:
virtual void TransformEntityName(
    RDBMSEntity^ entity
)
public:
virtual void TransformEntityName(
    RDBMSEntity^ entity
)
abstract TransformEntityName :
        entity : RDBMSEntity -> unit
override TransformEntityName :
        entity : RDBMSEntity -> unit
abstract TransformEntityName :
        entity : RDBMSEntity -> unit
override TransformEntityName :
        entity : RDBMSEntity -> unit

Parameters

entity
Type: NFX.RelationalModel RDBMSEntity
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.TransformKeywordCase Method

RDBMSCompiler TransformKeywordCase Method NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string TransformKeywordCase(
    string keywords
)
public virtual string TransformKeywordCase(
    string keywords
)
Public Overridable Function TransformKeywordCase (
    keywords As String
) As String
Public Overridable Function TransformKeywordCase (
    keywords As String
) As String
public:
virtual String^ TransformKeywordCase(
    String^ keywords
)
public:
virtual String^ TransformKeywordCase(
    String^ keywords
)
abstract TransformKeywordCase :
        keywords : string -> string
override TransformKeywordCase :
        keywords : string -> string
abstract TransformKeywordCase :
        keywords : string -> string
override TransformKeywordCase :
        keywords : string -> string

Parameters

keywords
Type: Online System String

Return Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.TransformSortOrder Method

RDBMSCompiler TransformSortOrder Method NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string TransformSortOrder(
    RDBMSSortOrder order
)
public virtual string TransformSortOrder(
    RDBMSSortOrder order
)
Public Overridable Function TransformSortOrder (
    order As RDBMSSortOrder
) As String
Public Overridable Function TransformSortOrder (
    order As RDBMSSortOrder
) As String
public:
virtual String^ TransformSortOrder(
    RDBMSSortOrder order
)
public:
virtual String^ TransformSortOrder(
    RDBMSSortOrder order
)
abstract TransformSortOrder :
        order : RDBMSSortOrder -> string
override TransformSortOrder :
        order : RDBMSSortOrder -> string
abstract TransformSortOrder :
        order : RDBMSSortOrder -> string
override TransformSortOrder :
        order : RDBMSSortOrder -> string

Parameters

order
Type: NFX.RelationalModel RDBMSSortOrder

Return Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler Properties

RDBMSCompiler Properties NFX Class Library

The RDBMSCompiler type exposes the following members.
Properties
 | Name | Description
Public property | CompileErrors | Returns exception errors that were generated during compilation. This property returns "planned" errors that were caused by input, whereas CompileException returns exception that indicates some more drastic abnormality that broke the compilation (Inherited from Compiler.)
Public property | CompileException | Returns exception that surfaced during compilation, or null if source has not compiled yet or no exception happened. This exception is different form CompileErrors because it indicates some un=planned condition that broke the compilation process (Inherited from Compiler.)
Public property | DomainSearchPaths | Gets/sets ';' separated list of domain search namespaces paths
Public property | HasCompiled | Returns true to indicate that compiler has already processed the source schema (Inherited from Compiler.)
Public property | HasErrors | Returns true when this instance did not compile properly (Inherited from Compiler.)
Public property | Name | Returns the name of the technology that this compiler targets. i.e. "ORACLE", "RecordModel" (Inherited from Compiler.)
Public property | NameCaseSensitivity | Determines whether output script is case sensitive (Inherited from Compiler.)
Public property | NameComparison | Returns string comparison options for names that depend on target case sensitivity (Inherited from Compiler.)
Public property | OutputPath | Determines where compiled output is placed (Inherited from Compiler.)
Public property | OutputPrefix | Determines the prefix for output names (Inherited from Compiler.)
Public property | Schema | Returns source schema (Inherited from Compiler.)
Public property | SeparateForeignKeys | Gets/sets the flag that indicates whether foreign keys should be written in the separate output from tables. Foreign keys get added as constraints under the table when referenced table is already present and this flag is false
Public property | SeparateIndexes | Gets/sets the flag that indicates whether indexes should be written in the separate output from tables
Public property | Target | (Overrides Compiler Target.)
Back to Top
See Also
RDBMSCompiler Class
NFX.RelationalModel Namespace


RDBMSCompiler.DomainSearchPaths Property

RDBMSCompiler DomainSearchPaths Property NFX Class Library

Gets/sets ';' separated list of domain search namespaces paths

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$domain-search-paths", "NFX.RelationalModel.DataTypes.*")]
public virtual string DomainSearchPaths { get; set; }
[ConfigAttribute("$domain-search-paths", "NFX.RelationalModel.DataTypes.*")]
public virtual string DomainSearchPaths { get; set; }
<ConfigAttribute("$domain-search-paths", "NFX.RelationalModel.DataTypes.*")>
Public Overridable Property DomainSearchPaths As String
    Get
    Set
<ConfigAttribute("$domain-search-paths", "NFX.RelationalModel.DataTypes.*")>
Public Overridable Property DomainSearchPaths As String
    Get
    Set
public:
[ConfigAttribute(L"$domain-search-paths", L"NFX.RelationalModel.DataTypes.*")]
virtual property String^ DomainSearchPaths {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute(L"$domain-search-paths", L"NFX.RelationalModel.DataTypes.*")]
virtual property String^ DomainSearchPaths {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute("$domain-search-paths", "NFX.RelationalModel.DataTypes.*")>]
abstract DomainSearchPaths : string with get, set
[<ConfigAttribute("$domain-search-paths", "NFX.RelationalModel.DataTypes.*")>]
override DomainSearchPaths : string with get, set
[<ConfigAttribute("$domain-search-paths", "NFX.RelationalModel.DataTypes.*")>]
abstract DomainSearchPaths : string with get, set
[<ConfigAttribute("$domain-search-paths", "NFX.RelationalModel.DataTypes.*")>]
override DomainSearchPaths : string with get, set

Property Value

Type: Online String
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.SeparateForeignKeys Property

RDBMSCompiler SeparateForeignKeys Property NFX Class Library

Gets/sets the flag that indicates whether foreign keys should be written in the separate output from tables. Foreign keys get added as constraints under the table when referenced table is already present and this flag is false

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$separate-fkeys")]
public virtual bool SeparateForeignKeys { get; set; }
[ConfigAttribute("$separate-fkeys")]
public virtual bool SeparateForeignKeys { get; set; }
<ConfigAttribute("$separate-fkeys")>
Public Overridable Property SeparateForeignKeys As Boolean
    Get
    Set
<ConfigAttribute("$separate-fkeys")>
Public Overridable Property SeparateForeignKeys As Boolean
    Get
    Set
public:
[ConfigAttribute(L"$separate-fkeys")]
virtual property bool SeparateForeignKeys {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute(L"$separate-fkeys")]
virtual property bool SeparateForeignKeys {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute("$separate-fkeys")>]
abstract SeparateForeignKeys : bool with get, set
[<ConfigAttribute("$separate-fkeys")>]
override SeparateForeignKeys : bool with get, set
[<ConfigAttribute("$separate-fkeys")>]
abstract SeparateForeignKeys : bool with get, set
[<ConfigAttribute("$separate-fkeys")>]
override SeparateForeignKeys : bool with get, set

Property Value

Type: Online Boolean
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.SeparateIndexes Property

RDBMSCompiler SeparateIndexes Property NFX Class Library

Gets/sets the flag that indicates whether indexes should be written in the separate output from tables

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$separate-indexes")]
public virtual bool SeparateIndexes { get; set; }
[ConfigAttribute("$separate-indexes")]
public virtual bool SeparateIndexes { get; set; }
<ConfigAttribute("$separate-indexes")>
Public Overridable Property SeparateIndexes As Boolean
    Get
    Set
<ConfigAttribute("$separate-indexes")>
Public Overridable Property SeparateIndexes As Boolean
    Get
    Set
public:
[ConfigAttribute(L"$separate-indexes")]
virtual property bool SeparateIndexes {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute(L"$separate-indexes")]
virtual property bool SeparateIndexes {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute("$separate-indexes")>]
abstract SeparateIndexes : bool with get, set
[<ConfigAttribute("$separate-indexes")>]
override SeparateIndexes : bool with get, set
[<ConfigAttribute("$separate-indexes")>]
abstract SeparateIndexes : bool with get, set
[<ConfigAttribute("$separate-indexes")>]
override SeparateIndexes : bool with get, set

Property Value

Type: Online Boolean
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSCompiler.Target Property

RDBMSCompiler Target Property NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override TargetType Target { get; }
public override TargetType Target { get; }
Public Overrides ReadOnly Property Target As TargetType
    Get
Public Overrides ReadOnly Property Target As TargetType
    Get
public:
virtual property TargetType Target {
    TargetType get () override;
}
public:
virtual property TargetType Target {
    TargetType get () override;
}
abstract Target : TargetType with get
override Target : TargetType with get
abstract Target : TargetType with get
override Target : TargetType with get

Property Value

Type: TargetType
See Also
RDBMSCompiler Class
RDBMSCompiler Members
NFX.RelationalModel Namespace


RDBMSEntity Class

RDBMSEntity Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel RDBMSEntity

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class RDBMSEntity
public class RDBMSEntity
Public Class RDBMSEntity
Public Class RDBMSEntity
public ref class RDBMSEntity
public ref class RDBMSEntity
type RDBMSEntity =  class end
type RDBMSEntity =  class end
See Also
RDBMSEntity Members
NFX.RelationalModel Namespace


RDBMSEntity Members

RDBMSEntity Members NFX Class Library

The RDBMSEntity type exposes the following members.
Constructors
 | Name | Description
Public method | RDBMSEntity | Initializes a new instance of the RDBMSEntity class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Children |
Public field | Domain |
Public field | EntityType |
Public field | OriginalName |
Public field | OriginalShortName |
Public field | ParentEntity |
Public field | SourceNode |
Public field | TransformedName |
Public field | TransformedShortName |
Back to Top
See Also
RDBMSEntity Class
NFX.RelationalModel Namespace


RDBMSEntity Constructor

RDBMSEntity Constructor NFX Class Library

Initializes a new instance of the RDBMSEntity class

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RDBMSEntity(
    RDBMSEntity parentEntity,
    IConfigNode sourceNode,
    RDBMSEntityType entityType,
    string originalName,
    string originalShortName = null,
    string transformedName = null,
    string transformedShortName = null
)
public RDBMSEntity(
    RDBMSEntity parentEntity,
    IConfigNode sourceNode,
    RDBMSEntityType entityType,
    string originalName,
    string originalShortName = null,
    string transformedName = null,
    string transformedShortName = null
)
Public Sub New (
    parentEntity As RDBMSEntity,
    sourceNode As IConfigNode,
    entityType As RDBMSEntityType,
    originalName As String,
    Optional originalShortName As String = Nothing,
    Optional transformedName As String = Nothing,
    Optional transformedShortName As String = Nothing
)
Public Sub New (
    parentEntity As RDBMSEntity,
    sourceNode As IConfigNode,
    entityType As RDBMSEntityType,
    originalName As String,
    Optional originalShortName As String = Nothing,
    Optional transformedName As String = Nothing,
    Optional transformedShortName As String = Nothing
)
public:
RDBMSEntity(
    RDBMSEntity^ parentEntity,
    IConfigNode^ sourceNode,
    RDBMSEntityType entityType,
    String^ originalName,
    String^ originalShortName = nullptr,
    String^ transformedName = nullptr,
    String^ transformedShortName = nullptr
)
public:
RDBMSEntity(
    RDBMSEntity^ parentEntity,
    IConfigNode^ sourceNode,
    RDBMSEntityType entityType,
    String^ originalName,
    String^ originalShortName = nullptr,
    String^ transformedName = nullptr,
    String^ transformedShortName = nullptr
)
new :
        parentEntity : RDBMSEntity *
        sourceNode : IConfigNode *
        entityType : RDBMSEntityType *
        originalName : string *
        ?originalShortName : string *
        ?transformedName : string *
        ?transformedShortName : string
(* Defaults:
        let _originalShortName = defaultArg originalShortName null
        let _transformedName = defaultArg transformedName null
        let _transformedShortName = defaultArg transformedShortName null
*)
-> RDBMSEntity
new :
        parentEntity : RDBMSEntity *
        sourceNode : IConfigNode *
        entityType : RDBMSEntityType *
        originalName : string *
        ?originalShortName : string *
        ?transformedName : string *
        ?transformedShortName : string
(* Defaults:
        let _originalShortName = defaultArg originalShortName null
        let _transformedName = defaultArg transformedName null
        let _transformedShortName = defaultArg transformedShortName null
*)
-> RDBMSEntity

Parameters

parentEntity
Type: NFX.RelationalModel RDBMSEntity
sourceNode
Type: NFX.Environment IConfigNode
entityType
Type: NFX.RelationalModel RDBMSEntityType
originalName
Type: Online System String
originalShortName (Optional)
Type: Online System String
transformedName (Optional)
Type: Online System String
transformedShortName (Optional)
Type: Online System String
See Also
RDBMSEntity Class
RDBMSEntity Members
NFX.RelationalModel Namespace


RDBMSEntity Fields

RDBMSEntity Fields NFX Class Library

The RDBMSEntity type exposes the following members.
Fields
 | Name | Description
Public field | Children |
Public field | Domain |
Public field | EntityType |
Public field | OriginalName |
Public field | OriginalShortName |
Public field | ParentEntity |
Public field | SourceNode |
Public field | TransformedName |
Public field | TransformedShortName |
Back to Top
See Also
RDBMSEntity Class
NFX.RelationalModel Namespace


RDBMSEntity.Children Field

RDBMSEntity Children Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly List<RDBMSEntity> Children
public readonly List<RDBMSEntity> Children
Public ReadOnly Children As List(Of RDBMSEntity)
Public ReadOnly Children As List(Of RDBMSEntity)
public:
initonly List<RDBMSEntity^>^ Children
public:
initonly List<RDBMSEntity^>^ Children
val Children: List<RDBMSEntity>
val Children: List<RDBMSEntity>

Field Value

Type: Online List RDBMSEntity
See Also
RDBMSEntity Class
RDBMSEntity Members
NFX.RelationalModel Namespace


RDBMSEntity.Domain Field

RDBMSEntity Domain Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RDBMSDomain Domain
public RDBMSDomain Domain
Public Domain As RDBMSDomain
Public Domain As RDBMSDomain
public:
RDBMSDomain^ Domain
public:
RDBMSDomain^ Domain
val mutable Domain: RDBMSDomain
val mutable Domain: RDBMSDomain

Field Value

Type: RDBMSDomain
See Also
RDBMSEntity Class
RDBMSEntity Members
NFX.RelationalModel Namespace


RDBMSEntity.EntityType Field

RDBMSEntity EntityType Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly RDBMSEntityType EntityType
public readonly RDBMSEntityType EntityType
Public ReadOnly EntityType As RDBMSEntityType
Public ReadOnly EntityType As RDBMSEntityType
public:
initonly RDBMSEntityType EntityType
public:
initonly RDBMSEntityType EntityType
val EntityType: RDBMSEntityType
val EntityType: RDBMSEntityType

Field Value

Type: RDBMSEntityType
See Also
RDBMSEntity Class
RDBMSEntity Members
NFX.RelationalModel Namespace


RDBMSEntity.OriginalName Field

RDBMSEntity OriginalName Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string OriginalName
public readonly string OriginalName
Public ReadOnly OriginalName As String
Public ReadOnly OriginalName As String
public:
initonly String^ OriginalName
public:
initonly String^ OriginalName
val OriginalName: string
val OriginalName: string

Field Value

Type: Online String
See Also
RDBMSEntity Class
RDBMSEntity Members
NFX.RelationalModel Namespace


RDBMSEntity.OriginalShortName Field

RDBMSEntity OriginalShortName Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string OriginalShortName
public readonly string OriginalShortName
Public ReadOnly OriginalShortName As String
Public ReadOnly OriginalShortName As String
public:
initonly String^ OriginalShortName
public:
initonly String^ OriginalShortName
val OriginalShortName: string
val OriginalShortName: string

Field Value

Type: Online String
See Also
RDBMSEntity Class
RDBMSEntity Members
NFX.RelationalModel Namespace


RDBMSEntity.ParentEntity Field

RDBMSEntity ParentEntity Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly RDBMSEntity ParentEntity
public readonly RDBMSEntity ParentEntity
Public ReadOnly ParentEntity As RDBMSEntity
Public ReadOnly ParentEntity As RDBMSEntity
public:
initonly RDBMSEntity^ ParentEntity
public:
initonly RDBMSEntity^ ParentEntity
val ParentEntity: RDBMSEntity
val ParentEntity: RDBMSEntity

Field Value

Type: RDBMSEntity
See Also
RDBMSEntity Class
RDBMSEntity Members
NFX.RelationalModel Namespace


RDBMSEntity.SourceNode Field

RDBMSEntity SourceNode Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly IConfigNode SourceNode
public readonly IConfigNode SourceNode
Public ReadOnly SourceNode As IConfigNode
Public ReadOnly SourceNode As IConfigNode
public:
initonly IConfigNode^ SourceNode
public:
initonly IConfigNode^ SourceNode
val SourceNode: IConfigNode
val SourceNode: IConfigNode

Field Value

Type: IConfigNode
See Also
RDBMSEntity Class
RDBMSEntity Members
NFX.RelationalModel Namespace


RDBMSEntity.TransformedName Field

RDBMSEntity TransformedName Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string TransformedName
public string TransformedName
Public TransformedName As String
Public TransformedName As String
public:
String^ TransformedName
public:
String^ TransformedName
val mutable TransformedName: string
val mutable TransformedName: string

Field Value

Type: Online String
See Also
RDBMSEntity Class
RDBMSEntity Members
NFX.RelationalModel Namespace


RDBMSEntity.TransformedShortName Field

RDBMSEntity TransformedShortName Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string TransformedShortName
public string TransformedShortName
Public TransformedShortName As String
Public TransformedShortName As String
public:
String^ TransformedShortName
public:
String^ TransformedShortName
val mutable TransformedShortName: string
val mutable TransformedShortName: string

Field Value

Type: Online String
See Also
RDBMSEntity Class
RDBMSEntity Members
NFX.RelationalModel Namespace


RDBMSEntity Methods

RDBMSEntity Methods NFX Class Library

The RDBMSEntity type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
RDBMSEntity Class
NFX.RelationalModel Namespace


RDBMSEntityType Enumeration

RDBMSEntityType Enumeration NFX Class Library

Denotes a type of RDBMS entity

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum RDBMSEntityType
public enum RDBMSEntityType
Public Enumeration RDBMSEntityType
Public Enumeration RDBMSEntityType
public enum class RDBMSEntityType
public enum class RDBMSEntityType
type RDBMSEntityType
type RDBMSEntityType
Members
Member name | Value | Description
Unknown | 0 |
Schema | 1 |
Table | 2 |
Column | 3 |
Domain | 4 |
PrimaryKey | 5 |
Index | 6 |
Trigger | 7 |
View | 8 |
StoreProc | 9 |
CheckConstraint | 10 |
Reference | 11 |
See Also
NFX.RelationalModel Namespace


RDBMSSortOrder Enumeration

RDBMSSortOrder Enumeration NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum RDBMSSortOrder
public enum RDBMSSortOrder
Public Enumeration RDBMSSortOrder
Public Enumeration RDBMSSortOrder
public enum class RDBMSSortOrder
public enum class RDBMSSortOrder
type RDBMSSortOrder
type RDBMSSortOrder
Members
Member name | Value | Description
Asc | 0 |
Ascending | 0 |
Desc | 1 |
Descending | 1 |
See Also
NFX.RelationalModel Namespace


RelationalException Class

RelationalException Class NFX Class Library

Base exception thrown by the Relational-* framework
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.RelationalModel RelationalException
NFX.RelationalModel CompilerException
NFX.RelationalModel SchemaException

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class RelationalException : NFXException
[SerializableAttribute]
public class RelationalException : NFXException
<SerializableAttribute>
Public Class RelationalException
    Inherits NFXException
<SerializableAttribute>
Public Class RelationalException
    Inherits NFXException
[SerializableAttribute]
public ref class RelationalException : public NFXException
[SerializableAttribute]
public ref class RelationalException : public NFXException
[<SerializableAttribute>]
type RelationalException =
    class
        inherit NFXException
    end
[<SerializableAttribute>]
type RelationalException =
    class
        inherit NFXException
    end
See Also
RelationalException Members
NFX.RelationalModel Namespace


RelationalException Members

RelationalException Members NFX Class Library

The RelationalException type exposes the following members.
Constructors
 | Name | Description
Public method | RelationalException | Initializes a new instance of the RelationalException class
Public method | RelationalException(String) | Initializes a new instance of the RelationalException class
Protected method | RelationalException(SerializationInfo, StreamingContext) | Initializes a new instance of the RelationalException class
Public method | RelationalException(String, Exception) | Initializes a new instance of the RelationalException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
RelationalException Class
NFX.RelationalModel Namespace


RelationalException Constructor

RelationalException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | RelationalException | Initializes a new instance of the RelationalException class
Public method | RelationalException(String) | Initializes a new instance of the RelationalException class
Protected method | RelationalException(SerializationInfo, StreamingContext) | Initializes a new instance of the RelationalException class
Public method | RelationalException(String, Exception) | Initializes a new instance of the RelationalException class
Back to Top
See Also
RelationalException Class
RelationalException Members
NFX.RelationalModel Namespace


RelationalException Constructor

RelationalException Constructor NFX Class Library

Initializes a new instance of the RelationalException class

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RelationalException()
public RelationalException()
Public Sub New
Public Sub New
public:
RelationalException()
public:
RelationalException()
new : unit -> RelationalException
new : unit -> RelationalException
See Also
RelationalException Class
RelationalException Members
RelationalException Overload
NFX.RelationalModel Namespace


RelationalException Constructor (String)

RelationalException Constructor (String) NFX Class Library

Initializes a new instance of the RelationalException class

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RelationalException(
    string message
)
public RelationalException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
RelationalException(
    String^ message
)
public:
RelationalException(
    String^ message
)
new :
        message : string -> RelationalException
new :
        message : string -> RelationalException

Parameters

message
Type: Online System String
See Also
RelationalException Class
RelationalException Members
RelationalException Overload
NFX.RelationalModel Namespace


RelationalException Constructor (SerializationInfo, StreamingContext)

RelationalException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RelationalException class

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected RelationalException(
    SerializationInfo info,
    StreamingContext context
)
protected RelationalException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
RelationalException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
RelationalException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> RelationalException
new :
        info : SerializationInfo *
        context : StreamingContext -> RelationalException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
RelationalException Class
RelationalException Members
RelationalException Overload
NFX.RelationalModel Namespace


RelationalException Constructor (String, Exception)

RelationalException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RelationalException class

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RelationalException(
    string message,
    Exception inner
)
public RelationalException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
RelationalException(
    String^ message,
    Exception^ inner
)
public:
RelationalException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> RelationalException
new :
        message : string *
        inner : Exception -> RelationalException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
RelationalException Class
RelationalException Members
RelationalException Overload
NFX.RelationalModel Namespace


RelationalException Methods

RelationalException Methods NFX Class Library

The RelationalException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
RelationalException Class
NFX.RelationalModel Namespace


RelationalException Properties

RelationalException Properties NFX Class Library

The RelationalException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
RelationalException Class
NFX.RelationalModel Namespace


RelationalException Events

RelationalException Events NFX Class Library

The RelationalException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
RelationalException Class
NFX.RelationalModel Namespace


Schema Class

Schema Class NFX Class Library

Represents an instance of relational schema source
Inheritance Hierarchy
Online System Object
NFX.RelationalModel Schema

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Schema
public class Schema
Public Class Schema
Public Class Schema
public ref class Schema
public ref class Schema
type Schema =  class end
type Schema =  class end
See Also
Schema Members
NFX.RelationalModel Namespace


Schema Members

Schema Members NFX Class Library

The Schema type exposes the following members.
Constructors
 | Name | Description
Public method | Schema(String, IEnumerable String , Boolean, ScriptRunner) | Initializes a new instance of the Schema class
Public method | Schema(Configuration, IEnumerable String , Boolean, ScriptRunner) | Initializes a new instance of the Schema class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_INCLUDE_SECTION |
CONFIG_SCHEMA_SECTION |
Back to Top
Properties
 | Name | Description
Public property | IncludePaths | Returns include paths that are searched for included files
Public property | Source | Returns the source root tree after includes were processed and script was run
Public property | SourceOriginal | Returns the source root tree before script was run but all includes processed
Public property | SourceScriptRunner | Returns script runner used for schema source evaluation. Null returned when no scripts were executed
Back to Top
See Also
Schema Class
NFX.RelationalModel Namespace


Schema Constructor

Schema Constructor NFX Class Library

Overload List
 | Name | Description
Public method | Schema(String, IEnumerable String , Boolean, ScriptRunner) | Initializes a new instance of the Schema class
Public method | Schema(Configuration, IEnumerable String , Boolean, ScriptRunner) | Initializes a new instance of the Schema class
Back to Top
See Also
Schema Class
Schema Members
NFX.RelationalModel Namespace


Schema Constructor (String, IEnumerable(String), Boolean, ScriptRunner)

Schema Constructor (String, IEnumerable String , Boolean, ScriptRunner) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Schema class

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Schema(
    string fileName,
    IEnumerable<string> includePaths = null,
    bool runScript = true,
    ScriptRunner runner = null
)
public Schema(
    string fileName,
    IEnumerable<string> includePaths = null,
    bool runScript = true,
    ScriptRunner runner = null
)
Public Sub New (
    fileName As String,
    Optional includePaths As IEnumerable(Of String) = Nothing,
    Optional runScript As Boolean = true,
    Optional runner As ScriptRunner = Nothing
)
Public Sub New (
    fileName As String,
    Optional includePaths As IEnumerable(Of String) = Nothing,
    Optional runScript As Boolean = true,
    Optional runner As ScriptRunner = Nothing
)
public:
Schema(
    String^ fileName,
    IEnumerable<String^>^ includePaths = nullptr,
    bool runScript = true,
    ScriptRunner^ runner = nullptr
)
public:
Schema(
    String^ fileName,
    IEnumerable<String^>^ includePaths = nullptr,
    bool runScript = true,
    ScriptRunner^ runner = nullptr
)
new :
        fileName : string *
        ?includePaths : IEnumerable<string> *
        ?runScript : bool *
        ?runner : ScriptRunner
(* Defaults:
        let _includePaths = defaultArg includePaths null
        let _runScript = defaultArg runScript true
        let _runner = defaultArg runner null
*)
-> Schema
new :
        fileName : string *
        ?includePaths : IEnumerable<string> *
        ?runScript : bool *
        ?runner : ScriptRunner
(* Defaults:
        let _includePaths = defaultArg includePaths null
        let _runScript = defaultArg runScript true
        let _runner = defaultArg runner null
*)
-> Schema

Parameters

fileName
Type: Online System String
includePaths (Optional)
Type: Online System.Collections.Generic IEnumerable Online String
runScript (Optional)
Type: Online System Boolean
runner (Optional)
Type: NFX.Environment ScriptRunner
See Also
Schema Class
Schema Members
Schema Overload
NFX.RelationalModel Namespace


Schema Constructor (Configuration, IEnumerable(String), Boolean, ScriptRunner)

Schema Constructor (Configuration, IEnumerable String , Boolean, ScriptRunner) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Schema class

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Schema(
    Configuration source,
    IEnumerable<string> includePaths = null,
    bool runScript = true,
    ScriptRunner runner = null
)
public Schema(
    Configuration source,
    IEnumerable<string> includePaths = null,
    bool runScript = true,
    ScriptRunner runner = null
)
Public Sub New (
    source As Configuration,
    Optional includePaths As IEnumerable(Of String) = Nothing,
    Optional runScript As Boolean = true,
    Optional runner As ScriptRunner = Nothing
)
Public Sub New (
    source As Configuration,
    Optional includePaths As IEnumerable(Of String) = Nothing,
    Optional runScript As Boolean = true,
    Optional runner As ScriptRunner = Nothing
)
public:
Schema(
    Configuration^ source,
    IEnumerable<String^>^ includePaths = nullptr,
    bool runScript = true,
    ScriptRunner^ runner = nullptr
)
public:
Schema(
    Configuration^ source,
    IEnumerable<String^>^ includePaths = nullptr,
    bool runScript = true,
    ScriptRunner^ runner = nullptr
)
new :
        source : Configuration *
        ?includePaths : IEnumerable<string> *
        ?runScript : bool *
        ?runner : ScriptRunner
(* Defaults:
        let _includePaths = defaultArg includePaths null
        let _runScript = defaultArg runScript true
        let _runner = defaultArg runner null
*)
-> Schema
new :
        source : Configuration *
        ?includePaths : IEnumerable<string> *
        ?runScript : bool *
        ?runner : ScriptRunner
(* Defaults:
        let _includePaths = defaultArg includePaths null
        let _runScript = defaultArg runScript true
        let _runner = defaultArg runner null
*)
-> Schema

Parameters

source
Type: NFX.Environment Configuration
includePaths (Optional)
Type: Online System.Collections.Generic IEnumerable Online String
runScript (Optional)
Type: Online System Boolean
runner (Optional)
Type: NFX.Environment ScriptRunner
See Also
Schema Class
Schema Members
Schema Overload
NFX.RelationalModel Namespace


Schema Fields

Schema Fields NFX Class Library

The Schema type exposes the following members.
Fields
Name | Description
CONFIG_INCLUDE_SECTION |
CONFIG_SCHEMA_SECTION |
Back to Top
See Also
Schema Class
NFX.RelationalModel Namespace


Schema.CONFIG_INCLUDE_SECTION Field

Schema CONFIG_INCLUDE_SECTION Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_INCLUDE_SECTION
public const string CONFIG_INCLUDE_SECTION
Public Const CONFIG_INCLUDE_SECTION As String
Public Const CONFIG_INCLUDE_SECTION As String
public:
literal String^ CONFIG_INCLUDE_SECTION
public:
literal String^ CONFIG_INCLUDE_SECTION
static val mutable CONFIG_INCLUDE_SECTION: string
static val mutable CONFIG_INCLUDE_SECTION: string

Field Value

Type: Online String
See Also
Schema Class
Schema Members
NFX.RelationalModel Namespace


Schema.CONFIG_SCHEMA_SECTION Field

Schema CONFIG_SCHEMA_SECTION Field NFX Class Library

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SCHEMA_SECTION
public const string CONFIG_SCHEMA_SECTION
Public Const CONFIG_SCHEMA_SECTION As String
Public Const CONFIG_SCHEMA_SECTION As String
public:
literal String^ CONFIG_SCHEMA_SECTION
public:
literal String^ CONFIG_SCHEMA_SECTION
static val mutable CONFIG_SCHEMA_SECTION: string
static val mutable CONFIG_SCHEMA_SECTION: string

Field Value

Type: Online String
See Also
Schema Class
Schema Members
NFX.RelationalModel Namespace


Schema Methods

Schema Methods NFX Class Library

The Schema type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Schema Class
NFX.RelationalModel Namespace


Schema Properties

Schema Properties NFX Class Library

The Schema type exposes the following members.
Properties
 | Name | Description
Public property | IncludePaths | Returns include paths that are searched for included files
Public property | Source | Returns the source root tree after includes were processed and script was run
Public property | SourceOriginal | Returns the source root tree before script was run but all includes processed
Public property | SourceScriptRunner | Returns script runner used for schema source evaluation. Null returned when no scripts were executed
Back to Top
See Also
Schema Class
NFX.RelationalModel Namespace


Schema.IncludePaths Property

Schema IncludePaths Property NFX Class Library

Returns include paths that are searched for included files

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<string> IncludePaths { get; }
public IEnumerable<string> IncludePaths { get; }
Public ReadOnly Property IncludePaths As IEnumerable(Of String)
    Get
Public ReadOnly Property IncludePaths As IEnumerable(Of String)
    Get
public:
property IEnumerable<String^>^ IncludePaths {
    IEnumerable<String^>^ get ();
}
public:
property IEnumerable<String^>^ IncludePaths {
    IEnumerable<String^>^ get ();
}
member IncludePaths : IEnumerable<string> with get
member IncludePaths : IEnumerable<string> with get

Property Value

Type: Online IEnumerable Online String
See Also
Schema Class
Schema Members
NFX.RelationalModel Namespace


Schema.Source Property

Schema Source Property NFX Class Library

Returns the source root tree after includes were processed and script was run

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IConfigSectionNode Source { get; }
public IConfigSectionNode Source { get; }
Public ReadOnly Property Source As IConfigSectionNode
    Get
Public ReadOnly Property Source As IConfigSectionNode
    Get
public:
property IConfigSectionNode^ Source {
    IConfigSectionNode^ get ();
}
public:
property IConfigSectionNode^ Source {
    IConfigSectionNode^ get ();
}
member Source : IConfigSectionNode with get
member Source : IConfigSectionNode with get

Property Value

Type: IConfigSectionNode
See Also
Schema Class
Schema Members
NFX.RelationalModel Namespace


Schema.SourceOriginal Property

Schema SourceOriginal Property NFX Class Library

Returns the source root tree before script was run but all includes processed

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IConfigSectionNode SourceOriginal { get; }
public IConfigSectionNode SourceOriginal { get; }
Public ReadOnly Property SourceOriginal As IConfigSectionNode
    Get
Public ReadOnly Property SourceOriginal As IConfigSectionNode
    Get
public:
property IConfigSectionNode^ SourceOriginal {
    IConfigSectionNode^ get ();
}
public:
property IConfigSectionNode^ SourceOriginal {
    IConfigSectionNode^ get ();
}
member SourceOriginal : IConfigSectionNode with get
member SourceOriginal : IConfigSectionNode with get

Property Value

Type: IConfigSectionNode
See Also
Schema Class
Schema Members
NFX.RelationalModel Namespace


Schema.SourceScriptRunner Property

Schema SourceScriptRunner Property NFX Class Library

Returns script runner used for schema source evaluation. Null returned when no scripts were executed

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ScriptRunner SourceScriptRunner { get; }
public ScriptRunner SourceScriptRunner { get; }
Public ReadOnly Property SourceScriptRunner As ScriptRunner
    Get
Public ReadOnly Property SourceScriptRunner As ScriptRunner
    Get
public:
property ScriptRunner^ SourceScriptRunner {
    ScriptRunner^ get ();
}
public:
property ScriptRunner^ SourceScriptRunner {
    ScriptRunner^ get ();
}
member SourceScriptRunner : ScriptRunner with get
member SourceScriptRunner : ScriptRunner with get

Property Value

Type: ScriptRunner
See Also
Schema Class
Schema Members
NFX.RelationalModel Namespace


SchemaCompilationException Class

SchemaCompilationException Class NFX Class Library

Thrown by relational schema compiler while processing the source schema
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.RelationalModel RelationalException
NFX.RelationalModel SchemaException
NFX.RelationalModel SchemaCompilationException

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SchemaCompilationException : SchemaException
[SerializableAttribute]
public class SchemaCompilationException : SchemaException
<SerializableAttribute>
Public Class SchemaCompilationException
    Inherits SchemaException
<SerializableAttribute>
Public Class SchemaCompilationException
    Inherits SchemaException
[SerializableAttribute]
public ref class SchemaCompilationException : public SchemaException
[SerializableAttribute]
public ref class SchemaCompilationException : public SchemaException
[<SerializableAttribute>]
type SchemaCompilationException =
    class
        inherit SchemaException
    end
[<SerializableAttribute>]
type SchemaCompilationException =
    class
        inherit SchemaException
    end
See Also
SchemaCompilationException Members
NFX.RelationalModel Namespace


SchemaCompilationException Members

SchemaCompilationException Members NFX Class Library

The SchemaCompilationException type exposes the following members.
Constructors
 | Name | Description
Public method | SchemaCompilationException(String, String) | Initializes a new instance of the SchemaCompilationException class
Public method | SchemaCompilationException(String, String, Exception) | Initializes a new instance of the SchemaCompilationException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | NodePath | Returns node that issued compilation error
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Message | (Overrides Online Exception Message.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
SchemaCompilationException Class
NFX.RelationalModel Namespace


SchemaCompilationException Constructor

SchemaCompilationException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | SchemaCompilationException(String, String) | Initializes a new instance of the SchemaCompilationException class
Public method | SchemaCompilationException(String, String, Exception) | Initializes a new instance of the SchemaCompilationException class
Back to Top
See Also
SchemaCompilationException Class
SchemaCompilationException Members
NFX.RelationalModel Namespace


SchemaCompilationException Constructor (String, String)

SchemaCompilationException Constructor (String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SchemaCompilationException class

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SchemaCompilationException(
    string nodePath,
    string message
)
public SchemaCompilationException(
    string nodePath,
    string message
)
Public Sub New (
    nodePath As String,
    message As String
)
Public Sub New (
    nodePath As String,
    message As String
)
public:
SchemaCompilationException(
    String^ nodePath,
    String^ message
)
public:
SchemaCompilationException(
    String^ nodePath,
    String^ message
)
new :
        nodePath : string *
        message : string -> SchemaCompilationException
new :
        nodePath : string *
        message : string -> SchemaCompilationException

Parameters

nodePath
Type: Online System String
message
Type: Online System String
See Also
SchemaCompilationException Class
SchemaCompilationException Members
SchemaCompilationException Overload
NFX.RelationalModel Namespace


SchemaCompilationException Constructor (String, String, Exception)

SchemaCompilationException Constructor (String, String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SchemaCompilationException class

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SchemaCompilationException(
    string nodePath,
    string message,
    Exception inner
)
public SchemaCompilationException(
    string nodePath,
    string message,
    Exception inner
)
Public Sub New (
    nodePath As String,
    message As String,
    inner As Exception
)
Public Sub New (
    nodePath As String,
    message As String,
    inner As Exception
)
public:
SchemaCompilationException(
    String^ nodePath,
    String^ message,
    Exception^ inner
)
public:
SchemaCompilationException(
    String^ nodePath,
    String^ message,
    Exception^ inner
)
new :
        nodePath : string *
        message : string *
        inner : Exception -> SchemaCompilationException
new :
        nodePath : string *
        message : string *
        inner : Exception -> SchemaCompilationException

Parameters

nodePath
Type: Online System String
message
Type: Online System String
inner
Type: Online System Exception
See Also
SchemaCompilationException Class
SchemaCompilationException Members
SchemaCompilationException Overload
NFX.RelationalModel Namespace


SchemaCompilationException Fields

SchemaCompilationException Fields NFX Class Library

The SchemaCompilationException type exposes the following members.
Fields
 | Name | Description
Public field | NodePath | Returns node that issued compilation error
Back to Top
See Also
SchemaCompilationException Class
NFX.RelationalModel Namespace


SchemaCompilationException.NodePath Field

SchemaCompilationException NodePath Field NFX Class Library

Returns node that issued compilation error

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string NodePath
public readonly string NodePath
Public ReadOnly NodePath As String
Public ReadOnly NodePath As String
public:
initonly String^ NodePath
public:
initonly String^ NodePath
val NodePath: string
val NodePath: string

Field Value

Type: Online String
See Also
SchemaCompilationException Class
SchemaCompilationException Members
NFX.RelationalModel Namespace


SchemaCompilationException Methods

SchemaCompilationException Methods NFX Class Library

The SchemaCompilationException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
SchemaCompilationException Class
NFX.RelationalModel Namespace


SchemaCompilationException Properties

SchemaCompilationException Properties NFX Class Library

The SchemaCompilationException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Message | (Overrides Online Exception Message.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
SchemaCompilationException Class
NFX.RelationalModel Namespace


SchemaCompilationException.Message Property

SchemaCompilationException Message Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Message { get; }
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get
Public Overrides ReadOnly Property Message As String
    Get
public:
virtual property String^ Message {
    String^ get () override;
}
public:
virtual property String^ Message {
    String^ get () override;
}
abstract Message : string with get
override Message : string with get
abstract Message : string with get
override Message : string with get

Property Value

Type: Online String

Implements

Online _Exception Message
See Also
SchemaCompilationException Class
SchemaCompilationException Members
NFX.RelationalModel Namespace


SchemaCompilationException Events

SchemaCompilationException Events NFX Class Library

The SchemaCompilationException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
SchemaCompilationException Class
NFX.RelationalModel Namespace


SchemaException Class

SchemaException Class NFX Class Library

Thrown by relational schema
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.RelationalModel RelationalException
NFX.RelationalModel SchemaException
NFX.RelationalModel SchemaCompilationException

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SchemaException : RelationalException
[SerializableAttribute]
public class SchemaException : RelationalException
<SerializableAttribute>
Public Class SchemaException
    Inherits RelationalException
<SerializableAttribute>
Public Class SchemaException
    Inherits RelationalException
[SerializableAttribute]
public ref class SchemaException : public RelationalException
[SerializableAttribute]
public ref class SchemaException : public RelationalException
[<SerializableAttribute>]
type SchemaException =
    class
        inherit RelationalException
    end
[<SerializableAttribute>]
type SchemaException =
    class
        inherit RelationalException
    end
See Also
SchemaException Members
NFX.RelationalModel Namespace


SchemaException Members

SchemaException Members NFX Class Library

The SchemaException type exposes the following members.
Constructors
 | Name | Description
Public method | SchemaException(String) | Initializes a new instance of the SchemaException class
Public method | SchemaException(String, Exception) | Initializes a new instance of the SchemaException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
SchemaException Class
NFX.RelationalModel Namespace


SchemaException Constructor

SchemaException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | SchemaException(String) | Initializes a new instance of the SchemaException class
Public method | SchemaException(String, Exception) | Initializes a new instance of the SchemaException class
Back to Top
See Also
SchemaException Class
SchemaException Members
NFX.RelationalModel Namespace


SchemaException Constructor (String)

SchemaException Constructor (String) NFX Class Library

Initializes a new instance of the SchemaException class

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SchemaException(
    string message
)
public SchemaException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
SchemaException(
    String^ message
)
public:
SchemaException(
    String^ message
)
new :
        message : string -> SchemaException
new :
        message : string -> SchemaException

Parameters

message
Type: Online System String
See Also
SchemaException Class
SchemaException Members
SchemaException Overload
NFX.RelationalModel Namespace


SchemaException Constructor (String, Exception)

SchemaException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SchemaException class

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SchemaException(
    string message,
    Exception inner
)
public SchemaException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
SchemaException(
    String^ message,
    Exception^ inner
)
public:
SchemaException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> SchemaException
new :
        message : string *
        inner : Exception -> SchemaException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
SchemaException Class
SchemaException Members
SchemaException Overload
NFX.RelationalModel Namespace


SchemaException Methods

SchemaException Methods NFX Class Library

The SchemaException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
SchemaException Class
NFX.RelationalModel Namespace


SchemaException Properties

SchemaException Properties NFX Class Library

The SchemaException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
SchemaException Class
NFX.RelationalModel Namespace


SchemaException Events

SchemaException Events NFX Class Library

The SchemaException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
SchemaException Class
NFX.RelationalModel Namespace


TargetType Enumeration

TargetType Enumeration NFX Class Library

Specifies a type of target that compiler produces output for

Namespace: NFX.RelationalModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum TargetType
public enum TargetType
Public Enumeration TargetType
Public Enumeration TargetType
public enum class TargetType
public enum class TargetType
type TargetType
type TargetType
Members
Member name | Value | Description
Other | 0 |
GenericSQL | 1 |
Oracle | 2 |
MsSQLServer | 3 |
DB2 | 4 |
PostgreSQL | 5 |
MySQL | 6 |
Interbase | 7 |
Firebird | 8 |
Mnesia | 9 |
MongoDB | 10 |
JSON | 11 |
JavaScript | 12 |
RecordModel | 13 |
ErlScript | 14 |
See Also
NFX.RelationalModel Namespace


NFX.RelationalModel.DataTypes Namespace

NFX.RelationalModel.DataTypes Namespace NFX Class Library

Provides types for domains used by relational schemas
Classes
 | Class | Description
Public class | Domain | Represents a domain - a named type
Public class | HumanAttribute |
Public class | NonInteligentGDIDKey |
Public class | NonInteligentKey |
Public class | PostalAttribute |
Public class | RDBMSDomain | Represents a domain - named type with optional constraints/checks for permitted values
Public class | TAddrCity |
Public class | TAddrInternationalStateTerritory |
Public class | TAddrInternationalZipPostal |
Public class | TAddrLine |
Public class | TAddrUSState |
Public class | TAddrUSZip |
Public class | TBool |
Public class | TChar |
Public class | TCounter |
Public class | TCounterRef |
Public class | TDateTime |
Public class | TDouble |
Public class | TEMail |
Public class | TEnum |
Public class | TGDID |
Public class | TGDIDRef |
Public class | THumanAge |
Public class | THumanName |
Public class | TInt |
Public class | TMonetaryAmount |
Public class | TNote |
Public class | TPercent |
Public class | TPhone |
Public class | TScreenName |
Public class | TScript |
Public class | TSex |
Public class | TVarchar |
Public class | UncategorizedNumericValue |
Public class | UncategorizedTextualValue |
Public class | UncategorizedValue |
Enumerations
 | Enumeration | Description
Public enumeration | DBCharType |


DBCharType Enumeration

DBCharType Enumeration NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum DBCharType
public enum DBCharType
Public Enumeration DBCharType
Public Enumeration DBCharType
public enum class DBCharType
public enum class DBCharType
type DBCharType
type DBCharType
Members
Member name | Value | Description
Char | 0 |
Varchar | 1 |
See Also
NFX.RelationalModel.DataTypes Namespace


Domain Class

Domain Class NFX Class Library

Represents a domain - a named type
Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Domain : INamed,
    IConfigurable
public abstract class Domain : INamed,
    IConfigurable
Public MustInherit Class Domain
    Implements INamed, IConfigurable
Public MustInherit Class Domain
    Implements INamed, IConfigurable
public ref class Domain abstract : INamed,
    IConfigurable
public ref class Domain abstract : INamed,
    IConfigurable
[<AbstractClassAttribute>]
type Domain =
    class
        interface INamed
        interface IConfigurable
    end
[<AbstractClassAttribute>]
type Domain =
    class
        interface INamed
        interface IConfigurable
    end
See Also
Domain Members
NFX.RelationalModel.DataTypes Namespace


Domain Members

Domain Members NFX Class Library

The Domain type exposes the following members.
Constructors
 | Name | Description
Protected method | Domain | Initializes a new instance of the Domain class
Back to Top
Methods
 | Name | Description
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary'
Back to Top
See Also
Domain Class
NFX.RelationalModel.DataTypes Namespace


Domain Constructor

Domain Constructor NFX Class Library

Initializes a new instance of the Domain class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Domain()
protected Domain()
Protected Sub New
Protected Sub New
protected:
Domain()
protected:
Domain()
new : unit -> Domain
new : unit -> Domain
See Also
Domain Class
Domain Members
NFX.RelationalModel.DataTypes Namespace


Domain Methods

Domain Methods NFX Class Library

The Domain type exposes the following members.
Methods
 | Name | Description
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Domain Class
NFX.RelationalModel.DataTypes Namespace


Domain.Configure Method

Domain Configure Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Configure(
    IConfigSectionNode node
)
public virtual void Configure(
    IConfigSectionNode node
)
Public Overridable Sub Configure (
    node As IConfigSectionNode
)
Public Overridable Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
)
public:
virtual void Configure(
    IConfigSectionNode^ node
)
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
Domain Class
Domain Members
NFX.RelationalModel.DataTypes Namespace


Domain Properties

Domain Properties NFX Class Library

The Domain type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary'
Back to Top
See Also
Domain Class
NFX.RelationalModel.DataTypes Namespace


Domain.Name Property

Domain Name Property NFX Class Library

Returns the name of this domain, i.e. 'THumanAge', 'TSalary'

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Name { get; }
public virtual string Name { get; }
Public Overridable ReadOnly Property Name As String
    Get
Public Overridable ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get ();
}
public:
virtual property String^ Name {
    String^ get ();
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
Domain Class
Domain Members
NFX.RelationalModel.DataTypes Namespace


HumanAttribute Class

HumanAttribute Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes HumanAttribute
NFX.RelationalModel.DataTypes THumanAge
NFX.RelationalModel.DataTypes THumanName

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class HumanAttribute : RDBMSDomain
public abstract class HumanAttribute : RDBMSDomain
Public MustInherit Class HumanAttribute
    Inherits RDBMSDomain
Public MustInherit Class HumanAttribute
    Inherits RDBMSDomain
public ref class HumanAttribute abstract : public RDBMSDomain
public ref class HumanAttribute abstract : public RDBMSDomain
[<AbstractClassAttribute>]
type HumanAttribute =
    class
        inherit RDBMSDomain
    end
[<AbstractClassAttribute>]
type HumanAttribute =
    class
        inherit RDBMSDomain
    end
See Also
HumanAttribute Members
NFX.RelationalModel.DataTypes Namespace


HumanAttribute Members

HumanAttribute Members NFX Class Library

The HumanAttribute type exposes the following members.
Constructors
 | Name | Description
Protected method | HumanAttribute | Initializes a new instance of the HumanAttribute class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | Returns the name of the resulting type that this domain maps to (Inherited from RDBMSDomain.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
HumanAttribute Class
NFX.RelationalModel.DataTypes Namespace


HumanAttribute Constructor

HumanAttribute Constructor NFX Class Library

Initializes a new instance of the HumanAttribute class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected HumanAttribute()
protected HumanAttribute()
Protected Sub New
Protected Sub New
protected:
HumanAttribute()
protected:
HumanAttribute()
new : unit -> HumanAttribute
new : unit -> HumanAttribute
See Also
HumanAttribute Class
HumanAttribute Members
NFX.RelationalModel.DataTypes Namespace


HumanAttribute Methods

HumanAttribute Methods NFX Class Library

The HumanAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | Returns the name of the resulting type that this domain maps to (Inherited from RDBMSDomain.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
HumanAttribute Class
NFX.RelationalModel.DataTypes Namespace


HumanAttribute Properties

HumanAttribute Properties NFX Class Library

The HumanAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
HumanAttribute Class
NFX.RelationalModel.DataTypes Namespace


NonInteligentGDIDKey Class

NonInteligentGDIDKey Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes NonInteligentKey
NFX.RelationalModel.DataTypes NonInteligentGDIDKey
NFX.RelationalModel.DataTypes TGDID
NFX.RelationalModel.DataTypes TGDIDRef

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NonInteligentGDIDKey : NonInteligentKey
public class NonInteligentGDIDKey : NonInteligentKey
Public Class NonInteligentGDIDKey
    Inherits NonInteligentKey
Public Class NonInteligentGDIDKey
    Inherits NonInteligentKey
public ref class NonInteligentGDIDKey : public NonInteligentKey
public ref class NonInteligentGDIDKey : public NonInteligentKey
type NonInteligentGDIDKey =
    class
        inherit NonInteligentKey
    end
type NonInteligentGDIDKey =
    class
        inherit NonInteligentKey
    end
See Also
NonInteligentGDIDKey Members
NFX.RelationalModel.DataTypes Namespace


NonInteligentGDIDKey Members

NonInteligentGDIDKey Members NFX Class Library

The NonInteligentGDIDKey type exposes the following members.
Constructors
 | Name | Description
Public method | NonInteligentGDIDKey | Initializes a new instance of the NonInteligentGDIDKey class
Public method | NonInteligentGDIDKey(Boolean) | Initializes a new instance of the NonInteligentGDIDKey class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | (Overrides NonInteligentKey GetColumnRequirement(RDBMSCompiler).)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides NonInteligentKey GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Required |
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
NonInteligentGDIDKey Class
NFX.RelationalModel.DataTypes Namespace


NonInteligentGDIDKey Constructor

NonInteligentGDIDKey Constructor NFX Class Library

Overload List
 | Name | Description
Public method | NonInteligentGDIDKey | Initializes a new instance of the NonInteligentGDIDKey class
Public method | NonInteligentGDIDKey(Boolean) | Initializes a new instance of the NonInteligentGDIDKey class
Back to Top
See Also
NonInteligentGDIDKey Class
NonInteligentGDIDKey Members
NFX.RelationalModel.DataTypes Namespace


NonInteligentGDIDKey Constructor

NonInteligentGDIDKey Constructor NFX Class Library

Initializes a new instance of the NonInteligentGDIDKey class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NonInteligentGDIDKey()
public NonInteligentGDIDKey()
Public Sub New
Public Sub New
public:
NonInteligentGDIDKey()
public:
NonInteligentGDIDKey()
new : unit -> NonInteligentGDIDKey
new : unit -> NonInteligentGDIDKey
See Also
NonInteligentGDIDKey Class
NonInteligentGDIDKey Members
NonInteligentGDIDKey Overload
NFX.RelationalModel.DataTypes Namespace


NonInteligentGDIDKey Constructor (Boolean)

NonInteligentGDIDKey Constructor (Boolean) NFX Class Library

Initializes a new instance of the NonInteligentGDIDKey class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NonInteligentGDIDKey(
    bool required
)
public NonInteligentGDIDKey(
    bool required
)
Public Sub New (
    required As Boolean
)
Public Sub New (
    required As Boolean
)
public:
NonInteligentGDIDKey(
    bool required
)
public:
NonInteligentGDIDKey(
    bool required
)
new :
        required : bool -> NonInteligentGDIDKey
new :
        required : bool -> NonInteligentGDIDKey

Parameters

required
Type: Online System Boolean
See Also
NonInteligentGDIDKey Class
NonInteligentGDIDKey Members
NonInteligentGDIDKey Overload
NFX.RelationalModel.DataTypes Namespace


NonInteligentGDIDKey Fields

NonInteligentGDIDKey Fields NFX Class Library

The NonInteligentGDIDKey type exposes the following members.
Fields
 | Name | Description
Public field | Required |
Back to Top
See Also
NonInteligentGDIDKey Class
NFX.RelationalModel.DataTypes Namespace


NonInteligentGDIDKey.Required Field

NonInteligentGDIDKey Required Field NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool Required
[ConfigAttribute]
public bool Required
<ConfigAttribute>
Public Required As Boolean
<ConfigAttribute>
Public Required As Boolean
public:
[ConfigAttribute]
bool Required
public:
[ConfigAttribute]
bool Required
[<ConfigAttribute>]
val mutable Required: bool
[<ConfigAttribute>]
val mutable Required: bool

Field Value

Type: Online Boolean
See Also
NonInteligentGDIDKey Class
NonInteligentGDIDKey Members
NFX.RelationalModel.DataTypes Namespace


NonInteligentGDIDKey Methods

NonInteligentGDIDKey Methods NFX Class Library

The NonInteligentGDIDKey type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | (Overrides NonInteligentKey GetColumnRequirement(RDBMSCompiler).)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides NonInteligentKey GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NonInteligentGDIDKey Class
NFX.RelationalModel.DataTypes Namespace


NonInteligentGDIDKey.GetColumnRequirement Method

NonInteligentGDIDKey GetColumnRequirement Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Nullable<bool> GetColumnRequirement(
    RDBMSCompiler compiler
)
public override Nullable<bool> GetColumnRequirement(
    RDBMSCompiler compiler
)
Public Overrides Function GetColumnRequirement (
    compiler As RDBMSCompiler
) As Nullable(Of Boolean)
Public Overrides Function GetColumnRequirement (
    compiler As RDBMSCompiler
) As Nullable(Of Boolean)
public:
virtual Nullable<bool> GetColumnRequirement(
    RDBMSCompiler^ compiler
) override
public:
virtual Nullable<bool> GetColumnRequirement(
    RDBMSCompiler^ compiler
) override
abstract GetColumnRequirement :
        compiler : RDBMSCompiler -> Nullable<bool>
override GetColumnRequirement :
        compiler : RDBMSCompiler -> Nullable<bool>
abstract GetColumnRequirement :
        compiler : RDBMSCompiler -> Nullable<bool>
override GetColumnRequirement :
        compiler : RDBMSCompiler -> Nullable<bool>

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online Nullable Online Boolean
See Also
NonInteligentGDIDKey Class
NonInteligentGDIDKey Members
NFX.RelationalModel.DataTypes Namespace


NonInteligentGDIDKey.GetTypeName Method

NonInteligentGDIDKey GetTypeName Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetTypeName(
    RDBMSCompiler compiler
)
public override string GetTypeName(
    RDBMSCompiler compiler
)
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online String
See Also
NonInteligentGDIDKey Class
NonInteligentGDIDKey Members
NFX.RelationalModel.DataTypes Namespace


NonInteligentGDIDKey Properties

NonInteligentGDIDKey Properties NFX Class Library

The NonInteligentGDIDKey type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
NonInteligentGDIDKey Class
NFX.RelationalModel.DataTypes Namespace


NonInteligentKey Class

NonInteligentKey Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes NonInteligentKey
NFX.RelationalModel.DataTypes NonInteligentGDIDKey
NFX.RelationalModel.DataTypes TCounter
NFX.RelationalModel.DataTypes TCounterRef

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class NonInteligentKey : RDBMSDomain
public abstract class NonInteligentKey : RDBMSDomain
Public MustInherit Class NonInteligentKey
    Inherits RDBMSDomain
Public MustInherit Class NonInteligentKey
    Inherits RDBMSDomain
public ref class NonInteligentKey abstract : public RDBMSDomain
public ref class NonInteligentKey abstract : public RDBMSDomain
[<AbstractClassAttribute>]
type NonInteligentKey =
    class
        inherit RDBMSDomain
    end
[<AbstractClassAttribute>]
type NonInteligentKey =
    class
        inherit RDBMSDomain
    end
See Also
NonInteligentKey Members
NFX.RelationalModel.DataTypes Namespace


NonInteligentKey Members

NonInteligentKey Members NFX Class Library

The NonInteligentKey type exposes the following members.
Constructors
 | Name | Description
Protected method | NonInteligentKey | Initializes a new instance of the NonInteligentKey class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | (Overrides RDBMSDomain GetColumnRequirement(RDBMSCompiler).)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
NonInteligentKey Class
NFX.RelationalModel.DataTypes Namespace


NonInteligentKey Constructor

NonInteligentKey Constructor NFX Class Library

Initializes a new instance of the NonInteligentKey class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected NonInteligentKey()
protected NonInteligentKey()
Protected Sub New
Protected Sub New
protected:
NonInteligentKey()
protected:
NonInteligentKey()
new : unit -> NonInteligentKey
new : unit -> NonInteligentKey
See Also
NonInteligentKey Class
NonInteligentKey Members
NFX.RelationalModel.DataTypes Namespace


NonInteligentKey Methods

NonInteligentKey Methods NFX Class Library

The NonInteligentKey type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | (Overrides RDBMSDomain GetColumnRequirement(RDBMSCompiler).)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NonInteligentKey Class
NFX.RelationalModel.DataTypes Namespace


NonInteligentKey.GetColumnRequirement Method

NonInteligentKey GetColumnRequirement Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Nullable<bool> GetColumnRequirement(
    RDBMSCompiler compiler
)
public override Nullable<bool> GetColumnRequirement(
    RDBMSCompiler compiler
)
Public Overrides Function GetColumnRequirement (
    compiler As RDBMSCompiler
) As Nullable(Of Boolean)
Public Overrides Function GetColumnRequirement (
    compiler As RDBMSCompiler
) As Nullable(Of Boolean)
public:
virtual Nullable<bool> GetColumnRequirement(
    RDBMSCompiler^ compiler
) override
public:
virtual Nullable<bool> GetColumnRequirement(
    RDBMSCompiler^ compiler
) override
abstract GetColumnRequirement :
        compiler : RDBMSCompiler -> Nullable<bool>
override GetColumnRequirement :
        compiler : RDBMSCompiler -> Nullable<bool>
abstract GetColumnRequirement :
        compiler : RDBMSCompiler -> Nullable<bool>
override GetColumnRequirement :
        compiler : RDBMSCompiler -> Nullable<bool>

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online Nullable Online Boolean
See Also
NonInteligentKey Class
NonInteligentKey Members
NFX.RelationalModel.DataTypes Namespace


NonInteligentKey.GetTypeName Method

NonInteligentKey GetTypeName Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetTypeName(
    RDBMSCompiler compiler
)
public override string GetTypeName(
    RDBMSCompiler compiler
)
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online String
See Also
NonInteligentKey Class
NonInteligentKey Members
NFX.RelationalModel.DataTypes Namespace


NonInteligentKey Properties

NonInteligentKey Properties NFX Class Library

The NonInteligentKey type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
NonInteligentKey Class
NFX.RelationalModel.DataTypes Namespace


PostalAttribute Class

PostalAttribute Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes PostalAttribute
NFX.RelationalModel.DataTypes TAddrCity
NFX.RelationalModel.DataTypes TAddrInternationalStateTerritory
NFX.RelationalModel.DataTypes TAddrInternationalZipPostal
NFX.RelationalModel.DataTypes TAddrLine
NFX.RelationalModel.DataTypes TAddrUSState
NFX.RelationalModel.DataTypes TAddrUSZip

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class PostalAttribute : RDBMSDomain
public abstract class PostalAttribute : RDBMSDomain
Public MustInherit Class PostalAttribute
    Inherits RDBMSDomain
Public MustInherit Class PostalAttribute
    Inherits RDBMSDomain
public ref class PostalAttribute abstract : public RDBMSDomain
public ref class PostalAttribute abstract : public RDBMSDomain
[<AbstractClassAttribute>]
type PostalAttribute =
    class
        inherit RDBMSDomain
    end
[<AbstractClassAttribute>]
type PostalAttribute =
    class
        inherit RDBMSDomain
    end
See Also
PostalAttribute Members
NFX.RelationalModel.DataTypes Namespace


PostalAttribute Members

PostalAttribute Members NFX Class Library

The PostalAttribute type exposes the following members.
Constructors
 | Name | Description
Protected method | PostalAttribute | Initializes a new instance of the PostalAttribute class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | Returns the name of the resulting type that this domain maps to (Inherited from RDBMSDomain.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
PostalAttribute Class
NFX.RelationalModel.DataTypes Namespace


PostalAttribute Constructor

PostalAttribute Constructor NFX Class Library

Initializes a new instance of the PostalAttribute class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PostalAttribute()
protected PostalAttribute()
Protected Sub New
Protected Sub New
protected:
PostalAttribute()
protected:
PostalAttribute()
new : unit -> PostalAttribute
new : unit -> PostalAttribute
See Also
PostalAttribute Class
PostalAttribute Members
NFX.RelationalModel.DataTypes Namespace


PostalAttribute Methods

PostalAttribute Methods NFX Class Library

The PostalAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | Returns the name of the resulting type that this domain maps to (Inherited from RDBMSDomain.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PostalAttribute Class
NFX.RelationalModel.DataTypes Namespace


PostalAttribute Properties

PostalAttribute Properties NFX Class Library

The PostalAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
PostalAttribute Class
NFX.RelationalModel.DataTypes Namespace


RDBMSDomain Class

RDBMSDomain Class NFX Class Library

Represents a domain - named type with optional constraints/checks for permitted values
Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes HumanAttribute
NFX.RelationalModel.DataTypes NonInteligentKey
NFX.RelationalModel.DataTypes PostalAttribute
NFX.RelationalModel.DataTypes TBool
NFX.RelationalModel.DataTypes TDateTime
NFX.RelationalModel.DataTypes TEMail
NFX.RelationalModel.DataTypes TMonetaryAmount
NFX.RelationalModel.DataTypes TNote
NFX.RelationalModel.DataTypes TPhone
NFX.RelationalModel.DataTypes TScreenName
NFX.RelationalModel.DataTypes TScript
NFX.RelationalModel.DataTypes TSex
NFX.RelationalModel.DataTypes UncategorizedValue

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class RDBMSDomain : Domain
public abstract class RDBMSDomain : Domain
Public MustInherit Class RDBMSDomain
    Inherits Domain
Public MustInherit Class RDBMSDomain
    Inherits Domain
public ref class RDBMSDomain abstract : public Domain
public ref class RDBMSDomain abstract : public Domain
[<AbstractClassAttribute>]
type RDBMSDomain =
    class
        inherit Domain
    end
[<AbstractClassAttribute>]
type RDBMSDomain =
    class
        inherit Domain
    end
See Also
RDBMSDomain Members
NFX.RelationalModel.DataTypes Namespace


RDBMSDomain Members

RDBMSDomain Members NFX Class Library

The RDBMSDomain type exposes the following members.
Constructors
 | Name | Description
Protected method | RDBMSDomain | Initializes a new instance of the RDBMSDomain class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator
Public method | GetColumnCheckScript | Returns script for check constraint on column level
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | Returns the name of the resulting type that this domain maps to
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
RDBMSDomain Class
NFX.RelationalModel.DataTypes Namespace


RDBMSDomain Constructor

RDBMSDomain Constructor NFX Class Library

Initializes a new instance of the RDBMSDomain class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected RDBMSDomain()
protected RDBMSDomain()
Protected Sub New
Protected Sub New
protected:
RDBMSDomain()
protected:
RDBMSDomain()
new : unit -> RDBMSDomain
new : unit -> RDBMSDomain
See Also
RDBMSDomain Class
RDBMSDomain Members
NFX.RelationalModel.DataTypes Namespace


RDBMSDomain Methods

RDBMSDomain Methods NFX Class Library

The RDBMSDomain type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator
Public method | GetColumnCheckScript | Returns script for check constraint on column level
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | Returns the name of the resulting type that this domain maps to
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
RDBMSDomain Class
NFX.RelationalModel.DataTypes Namespace


RDBMSDomain.GetColumnAutoGeneratedScript Method

RDBMSDomain GetColumnAutoGeneratedScript Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string GetColumnAutoGeneratedScript(
    RDBMSCompiler compiler,
    RDBMSEntity column,
    Compiler..::..Outputs outputs
)
public virtual string GetColumnAutoGeneratedScript(
    RDBMSCompiler compiler,
    RDBMSEntity column,
    Compiler..::..Outputs outputs
)
Public Overridable Function GetColumnAutoGeneratedScript (
    compiler As RDBMSCompiler,
    column As RDBMSEntity,
    outputs As Compiler..::..Outputs
) As String
Public Overridable Function GetColumnAutoGeneratedScript (
    compiler As RDBMSCompiler,
    column As RDBMSEntity,
    outputs As Compiler..::..Outputs
) As String
public:
virtual String^ GetColumnAutoGeneratedScript(
    RDBMSCompiler^ compiler,
    RDBMSEntity^ column,
    Compiler..::..Outputs^ outputs
)
public:
virtual String^ GetColumnAutoGeneratedScript(
    RDBMSCompiler^ compiler,
    RDBMSEntity^ column,
    Compiler..::..Outputs^ outputs
)
abstract GetColumnAutoGeneratedScript :
        compiler : RDBMSCompiler *
        column : RDBMSEntity *
        outputs : Compiler..::..Outputs -> string
override GetColumnAutoGeneratedScript :
        compiler : RDBMSCompiler *
        column : RDBMSEntity *
        outputs : Compiler..::..Outputs -> string
abstract GetColumnAutoGeneratedScript :
        compiler : RDBMSCompiler *
        column : RDBMSEntity *
        outputs : Compiler..::..Outputs -> string
override GetColumnAutoGeneratedScript :
        compiler : RDBMSCompiler *
        column : RDBMSEntity *
        outputs : Compiler..::..Outputs -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler
column
Type: NFX.RelationalModel RDBMSEntity
outputs
Type: NFX.RelationalModel Compiler Outputs

Return Value

Type: Online String
See Also
RDBMSDomain Class
RDBMSDomain Members
NFX.RelationalModel.DataTypes Namespace


RDBMSDomain.GetColumnCheckScript Method

RDBMSDomain GetColumnCheckScript Method NFX Class Library

Returns script for check constraint on column level

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string GetColumnCheckScript(
    RDBMSCompiler compiler,
    RDBMSEntity column,
    Compiler..::..Outputs outputs
)
public virtual string GetColumnCheckScript(
    RDBMSCompiler compiler,
    RDBMSEntity column,
    Compiler..::..Outputs outputs
)
Public Overridable Function GetColumnCheckScript (
    compiler As RDBMSCompiler,
    column As RDBMSEntity,
    outputs As Compiler..::..Outputs
) As String
Public Overridable Function GetColumnCheckScript (
    compiler As RDBMSCompiler,
    column As RDBMSEntity,
    outputs As Compiler..::..Outputs
) As String
public:
virtual String^ GetColumnCheckScript(
    RDBMSCompiler^ compiler,
    RDBMSEntity^ column,
    Compiler..::..Outputs^ outputs
)
public:
virtual String^ GetColumnCheckScript(
    RDBMSCompiler^ compiler,
    RDBMSEntity^ column,
    Compiler..::..Outputs^ outputs
)
abstract GetColumnCheckScript :
        compiler : RDBMSCompiler *
        column : RDBMSEntity *
        outputs : Compiler..::..Outputs -> string
override GetColumnCheckScript :
        compiler : RDBMSCompiler *
        column : RDBMSEntity *
        outputs : Compiler..::..Outputs -> string
abstract GetColumnCheckScript :
        compiler : RDBMSCompiler *
        column : RDBMSEntity *
        outputs : Compiler..::..Outputs -> string
override GetColumnCheckScript :
        compiler : RDBMSCompiler *
        column : RDBMSEntity *
        outputs : Compiler..::..Outputs -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler
column
Type: NFX.RelationalModel RDBMSEntity
outputs
Type: NFX.RelationalModel Compiler Outputs

Return Value

Type: Online String
See Also
RDBMSDomain Class
RDBMSDomain Members
NFX.RelationalModel.DataTypes Namespace


RDBMSDomain.GetColumnDefaultScript Method

RDBMSDomain GetColumnDefaultScript Method NFX Class Library

Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string GetColumnDefaultScript(
    RDBMSCompiler compiler,
    RDBMSEntity column,
    Compiler..::..Outputs outputs
)
public virtual string GetColumnDefaultScript(
    RDBMSCompiler compiler,
    RDBMSEntity column,
    Compiler..::..Outputs outputs
)
Public Overridable Function GetColumnDefaultScript (
    compiler As RDBMSCompiler,
    column As RDBMSEntity,
    outputs As Compiler..::..Outputs
) As String
Public Overridable Function GetColumnDefaultScript (
    compiler As RDBMSCompiler,
    column As RDBMSEntity,
    outputs As Compiler..::..Outputs
) As String
public:
virtual String^ GetColumnDefaultScript(
    RDBMSCompiler^ compiler,
    RDBMSEntity^ column,
    Compiler..::..Outputs^ outputs
)
public:
virtual String^ GetColumnDefaultScript(
    RDBMSCompiler^ compiler,
    RDBMSEntity^ column,
    Compiler..::..Outputs^ outputs
)
abstract GetColumnDefaultScript :
        compiler : RDBMSCompiler *
        column : RDBMSEntity *
        outputs : Compiler..::..Outputs -> string
override GetColumnDefaultScript :
        compiler : RDBMSCompiler *
        column : RDBMSEntity *
        outputs : Compiler..::..Outputs -> string
abstract GetColumnDefaultScript :
        compiler : RDBMSCompiler *
        column : RDBMSEntity *
        outputs : Compiler..::..Outputs -> string
override GetColumnDefaultScript :
        compiler : RDBMSCompiler *
        column : RDBMSEntity *
        outputs : Compiler..::..Outputs -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler
column
Type: NFX.RelationalModel RDBMSEntity
outputs
Type: NFX.RelationalModel Compiler Outputs

Return Value

Type: Online String
See Also
RDBMSDomain Class
RDBMSDomain Members
NFX.RelationalModel.DataTypes Namespace


RDBMSDomain.GetColumnRequirement Method

RDBMSDomain GetColumnRequirement Method NFX Class Library

Returns true to indicate that column of this type is always required

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Nullable<bool> GetColumnRequirement(
    RDBMSCompiler compiler
)
public virtual Nullable<bool> GetColumnRequirement(
    RDBMSCompiler compiler
)
Public Overridable Function GetColumnRequirement (
    compiler As RDBMSCompiler
) As Nullable(Of Boolean)
Public Overridable Function GetColumnRequirement (
    compiler As RDBMSCompiler
) As Nullable(Of Boolean)
public:
virtual Nullable<bool> GetColumnRequirement(
    RDBMSCompiler^ compiler
)
public:
virtual Nullable<bool> GetColumnRequirement(
    RDBMSCompiler^ compiler
)
abstract GetColumnRequirement :
        compiler : RDBMSCompiler -> Nullable<bool>
override GetColumnRequirement :
        compiler : RDBMSCompiler -> Nullable<bool>
abstract GetColumnRequirement :
        compiler : RDBMSCompiler -> Nullable<bool>
override GetColumnRequirement :
        compiler : RDBMSCompiler -> Nullable<bool>

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler
The context that the result depends on

Return Value

Type: Online Nullable Online Boolean
See Also
RDBMSDomain Class
RDBMSDomain Members
NFX.RelationalModel.DataTypes Namespace


RDBMSDomain.GetTypeName Method

RDBMSDomain GetTypeName Method NFX Class Library

Returns the name of the resulting type that this domain maps to

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string GetTypeName(
    RDBMSCompiler compiler
)
public abstract string GetTypeName(
    RDBMSCompiler compiler
)
Public MustOverride Function GetTypeName (
    compiler As RDBMSCompiler
) As String
Public MustOverride Function GetTypeName (
    compiler As RDBMSCompiler
) As String
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) abstract
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) abstract
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
abstract GetTypeName :
        compiler : RDBMSCompiler -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler
The context that the result depends on

Return Value

Type: Online String
Target type name, i.e. BIGINT, DECIMAL(8,2) etc...
See Also
RDBMSDomain Class
RDBMSDomain Members
NFX.RelationalModel.DataTypes Namespace


RDBMSDomain.TransformColumnName Method

RDBMSDomain TransformColumnName Method NFX Class Library

Changes column name, i.e. adds prefix

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void TransformColumnName(
    RDBMSCompiler compiler,
    RDBMSEntity column
)
public virtual void TransformColumnName(
    RDBMSCompiler compiler,
    RDBMSEntity column
)
Public Overridable Sub TransformColumnName (
    compiler As RDBMSCompiler,
    column As RDBMSEntity
)
Public Overridable Sub TransformColumnName (
    compiler As RDBMSCompiler,
    column As RDBMSEntity
)
public:
virtual void TransformColumnName(
    RDBMSCompiler^ compiler,
    RDBMSEntity^ column
)
public:
virtual void TransformColumnName(
    RDBMSCompiler^ compiler,
    RDBMSEntity^ column
)
abstract TransformColumnName :
        compiler : RDBMSCompiler *
        column : RDBMSEntity -> unit
override TransformColumnName :
        compiler : RDBMSCompiler *
        column : RDBMSEntity -> unit
abstract TransformColumnName :
        compiler : RDBMSCompiler *
        column : RDBMSEntity -> unit
override TransformColumnName :
        compiler : RDBMSCompiler *
        column : RDBMSEntity -> unit

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler
column
Type: NFX.RelationalModel RDBMSEntity
See Also
RDBMSDomain Class
RDBMSDomain Members
NFX.RelationalModel.DataTypes Namespace


RDBMSDomain Properties

RDBMSDomain Properties NFX Class Library

The RDBMSDomain type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
RDBMSDomain Class
NFX.RelationalModel.DataTypes Namespace


TAddrCity Class

TAddrCity Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes PostalAttribute
NFX.RelationalModel.DataTypes TAddrCity

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TAddrCity : PostalAttribute
public class TAddrCity : PostalAttribute
Public Class TAddrCity
    Inherits PostalAttribute
Public Class TAddrCity
    Inherits PostalAttribute
public ref class TAddrCity : public PostalAttribute
public ref class TAddrCity : public PostalAttribute
type TAddrCity =
    class
        inherit PostalAttribute
    end
type TAddrCity =
    class
        inherit PostalAttribute
    end
See Also
TAddrCity Members
NFX.RelationalModel.DataTypes Namespace


TAddrCity Members

TAddrCity Members NFX Class Library

The TAddrCity type exposes the following members.
Constructors
 | Name | Description
Public method | TAddrCity | Initializes a new instance of the TAddrCity class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TAddrCity Class
NFX.RelationalModel.DataTypes Namespace


TAddrCity Constructor

TAddrCity Constructor NFX Class Library

Initializes a new instance of the TAddrCity class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TAddrCity()
public TAddrCity()
Public Sub New
Public Sub New
public:
TAddrCity()
public:
TAddrCity()
new : unit -> TAddrCity
new : unit -> TAddrCity
See Also
TAddrCity Class
TAddrCity Members
NFX.RelationalModel.DataTypes Namespace


TAddrCity Methods

TAddrCity Methods NFX Class Library

The TAddrCity type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TAddrCity Class
NFX.RelationalModel.DataTypes Namespace


TAddrCity.GetTypeName Method

TAddrCity GetTypeName Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetTypeName(
    RDBMSCompiler compiler
)
public override string GetTypeName(
    RDBMSCompiler compiler
)
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online String
See Also
TAddrCity Class
TAddrCity Members
NFX.RelationalModel.DataTypes Namespace


TAddrCity Properties

TAddrCity Properties NFX Class Library

The TAddrCity type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TAddrCity Class
NFX.RelationalModel.DataTypes Namespace


TAddrInternationalStateTerritory Class

TAddrInternationalStateTerritory Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes PostalAttribute
NFX.RelationalModel.DataTypes TAddrInternationalStateTerritory

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TAddrInternationalStateTerritory : PostalAttribute
public class TAddrInternationalStateTerritory : PostalAttribute
Public Class TAddrInternationalStateTerritory
    Inherits PostalAttribute
Public Class TAddrInternationalStateTerritory
    Inherits PostalAttribute
public ref class TAddrInternationalStateTerritory : public PostalAttribute
public ref class TAddrInternationalStateTerritory : public PostalAttribute
type TAddrInternationalStateTerritory =
    class
        inherit PostalAttribute
    end
type TAddrInternationalStateTerritory =
    class
        inherit PostalAttribute
    end
See Also
TAddrInternationalStateTerritory Members
NFX.RelationalModel.DataTypes Namespace


TAddrInternationalStateTerritory Members

TAddrInternationalStateTerritory Members NFX Class Library

The TAddrInternationalStateTerritory type exposes the following members.
Constructors
 | Name | Description
Public method | TAddrInternationalStateTerritory | Initializes a new instance of the TAddrInternationalStateTerritory class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TAddrInternationalStateTerritory Class
NFX.RelationalModel.DataTypes Namespace


TAddrInternationalStateTerritory Constructor

TAddrInternationalStateTerritory Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TAddrInternationalStateTerritory class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TAddrInternationalStateTerritory()
public TAddrInternationalStateTerritory()
Public Sub New
Public Sub New
public:
TAddrInternationalStateTerritory()
public:
TAddrInternationalStateTerritory()
new : unit -> TAddrInternationalStateTerritory
new : unit -> TAddrInternationalStateTerritory
See Also
TAddrInternationalStateTerritory Class
TAddrInternationalStateTerritory Members
NFX.RelationalModel.DataTypes Namespace


TAddrInternationalStateTerritory Methods

TAddrInternationalStateTerritory Methods NFX Class Library

The TAddrInternationalStateTerritory type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TAddrInternationalStateTerritory Class
NFX.RelationalModel.DataTypes Namespace


TAddrInternationalStateTerritory.GetTypeName Method

TAddrInternationalStateTerritory GetTypeName Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetTypeName(
    RDBMSCompiler compiler
)
public override string GetTypeName(
    RDBMSCompiler compiler
)
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online String
See Also
TAddrInternationalStateTerritory Class
TAddrInternationalStateTerritory Members
NFX.RelationalModel.DataTypes Namespace


TAddrInternationalStateTerritory Properties

TAddrInternationalStateTerritory Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The TAddrInternationalStateTerritory type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TAddrInternationalStateTerritory Class
NFX.RelationalModel.DataTypes Namespace


TAddrInternationalZipPostal Class

TAddrInternationalZipPostal Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes PostalAttribute
NFX.RelationalModel.DataTypes TAddrInternationalZipPostal

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TAddrInternationalZipPostal : PostalAttribute
public class TAddrInternationalZipPostal : PostalAttribute
Public Class TAddrInternationalZipPostal
    Inherits PostalAttribute
Public Class TAddrInternationalZipPostal
    Inherits PostalAttribute
public ref class TAddrInternationalZipPostal : public PostalAttribute
public ref class TAddrInternationalZipPostal : public PostalAttribute
type TAddrInternationalZipPostal =
    class
        inherit PostalAttribute
    end
type TAddrInternationalZipPostal =
    class
        inherit PostalAttribute
    end
See Also
TAddrInternationalZipPostal Members
NFX.RelationalModel.DataTypes Namespace


TAddrInternationalZipPostal Members

TAddrInternationalZipPostal Members NFX Class Library

The TAddrInternationalZipPostal type exposes the following members.
Constructors
 | Name | Description
Public method | TAddrInternationalZipPostal | Initializes a new instance of the TAddrInternationalZipPostal class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TAddrInternationalZipPostal Class
NFX.RelationalModel.DataTypes Namespace


TAddrInternationalZipPostal Constructor

TAddrInternationalZipPostal Constructor NFX Class Library

Initializes a new instance of the TAddrInternationalZipPostal class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TAddrInternationalZipPostal()
public TAddrInternationalZipPostal()
Public Sub New
Public Sub New
public:
TAddrInternationalZipPostal()
public:
TAddrInternationalZipPostal()
new : unit -> TAddrInternationalZipPostal
new : unit -> TAddrInternationalZipPostal
See Also
TAddrInternationalZipPostal Class
TAddrInternationalZipPostal Members
NFX.RelationalModel.DataTypes Namespace


TAddrInternationalZipPostal Methods

TAddrInternationalZipPostal Methods NFX Class Library

The TAddrInternationalZipPostal type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TAddrInternationalZipPostal Class
NFX.RelationalModel.DataTypes Namespace


TAddrInternationalZipPostal.GetTypeName Method

TAddrInternationalZipPostal GetTypeName Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetTypeName(
    RDBMSCompiler compiler
)
public override string GetTypeName(
    RDBMSCompiler compiler
)
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online String
See Also
TAddrInternationalZipPostal Class
TAddrInternationalZipPostal Members
NFX.RelationalModel.DataTypes Namespace


TAddrInternationalZipPostal Properties

TAddrInternationalZipPostal Properties NFX Class Library

The TAddrInternationalZipPostal type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TAddrInternationalZipPostal Class
NFX.RelationalModel.DataTypes Namespace


TAddrLine Class

TAddrLine Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes PostalAttribute
NFX.RelationalModel.DataTypes TAddrLine

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TAddrLine : PostalAttribute
public class TAddrLine : PostalAttribute
Public Class TAddrLine
    Inherits PostalAttribute
Public Class TAddrLine
    Inherits PostalAttribute
public ref class TAddrLine : public PostalAttribute
public ref class TAddrLine : public PostalAttribute
type TAddrLine =
    class
        inherit PostalAttribute
    end
type TAddrLine =
    class
        inherit PostalAttribute
    end
See Also
TAddrLine Members
NFX.RelationalModel.DataTypes Namespace


TAddrLine Members

TAddrLine Members NFX Class Library

The TAddrLine type exposes the following members.
Constructors
 | Name | Description
Public method | TAddrLine | Initializes a new instance of the TAddrLine class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TAddrLine Class
NFX.RelationalModel.DataTypes Namespace


TAddrLine Constructor

TAddrLine Constructor NFX Class Library

Initializes a new instance of the TAddrLine class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TAddrLine()
public TAddrLine()
Public Sub New
Public Sub New
public:
TAddrLine()
public:
TAddrLine()
new : unit -> TAddrLine
new : unit -> TAddrLine
See Also
TAddrLine Class
TAddrLine Members
NFX.RelationalModel.DataTypes Namespace


TAddrLine Methods

TAddrLine Methods NFX Class Library

The TAddrLine type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TAddrLine Class
NFX.RelationalModel.DataTypes Namespace


TAddrLine.GetTypeName Method

TAddrLine GetTypeName Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetTypeName(
    RDBMSCompiler compiler
)
public override string GetTypeName(
    RDBMSCompiler compiler
)
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online String
See Also
TAddrLine Class
TAddrLine Members
NFX.RelationalModel.DataTypes Namespace


TAddrLine Properties

TAddrLine Properties NFX Class Library

The TAddrLine type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TAddrLine Class
NFX.RelationalModel.DataTypes Namespace


TAddrUSState Class

TAddrUSState Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes PostalAttribute
NFX.RelationalModel.DataTypes TAddrUSState

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TAddrUSState : PostalAttribute
public class TAddrUSState : PostalAttribute
Public Class TAddrUSState
    Inherits PostalAttribute
Public Class TAddrUSState
    Inherits PostalAttribute
public ref class TAddrUSState : public PostalAttribute
public ref class TAddrUSState : public PostalAttribute
type TAddrUSState =
    class
        inherit PostalAttribute
    end
type TAddrUSState =
    class
        inherit PostalAttribute
    end
See Also
TAddrUSState Members
NFX.RelationalModel.DataTypes Namespace


TAddrUSState Members

TAddrUSState Members NFX Class Library

The TAddrUSState type exposes the following members.
Constructors
 | Name | Description
Public method | TAddrUSState | Initializes a new instance of the TAddrUSState class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TAddrUSState Class
NFX.RelationalModel.DataTypes Namespace


TAddrUSState Constructor

TAddrUSState Constructor NFX Class Library

Initializes a new instance of the TAddrUSState class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TAddrUSState()
public TAddrUSState()
Public Sub New
Public Sub New
public:
TAddrUSState()
public:
TAddrUSState()
new : unit -> TAddrUSState
new : unit -> TAddrUSState
See Also
TAddrUSState Class
TAddrUSState Members
NFX.RelationalModel.DataTypes Namespace


TAddrUSState Methods

TAddrUSState Methods NFX Class Library

The TAddrUSState type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TAddrUSState Class
NFX.RelationalModel.DataTypes Namespace


TAddrUSState.GetTypeName Method

TAddrUSState GetTypeName Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetTypeName(
    RDBMSCompiler compiler
)
public override string GetTypeName(
    RDBMSCompiler compiler
)
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online String
See Also
TAddrUSState Class
TAddrUSState Members
NFX.RelationalModel.DataTypes Namespace


TAddrUSState Properties

TAddrUSState Properties NFX Class Library

The TAddrUSState type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TAddrUSState Class
NFX.RelationalModel.DataTypes Namespace


TAddrUSZip Class

TAddrUSZip Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes PostalAttribute
NFX.RelationalModel.DataTypes TAddrUSZip

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TAddrUSZip : PostalAttribute
public class TAddrUSZip : PostalAttribute
Public Class TAddrUSZip
    Inherits PostalAttribute
Public Class TAddrUSZip
    Inherits PostalAttribute
public ref class TAddrUSZip : public PostalAttribute
public ref class TAddrUSZip : public PostalAttribute
type TAddrUSZip =
    class
        inherit PostalAttribute
    end
type TAddrUSZip =
    class
        inherit PostalAttribute
    end
See Also
TAddrUSZip Members
NFX.RelationalModel.DataTypes Namespace


TAddrUSZip Members

TAddrUSZip Members NFX Class Library

The TAddrUSZip type exposes the following members.
Constructors
 | Name | Description
Public method | TAddrUSZip | Initializes a new instance of the TAddrUSZip class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TAddrUSZip Class
NFX.RelationalModel.DataTypes Namespace


TAddrUSZip Constructor

TAddrUSZip Constructor NFX Class Library

Initializes a new instance of the TAddrUSZip class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TAddrUSZip()
public TAddrUSZip()
Public Sub New
Public Sub New
public:
TAddrUSZip()
public:
TAddrUSZip()
new : unit -> TAddrUSZip
new : unit -> TAddrUSZip
See Also
TAddrUSZip Class
TAddrUSZip Members
NFX.RelationalModel.DataTypes Namespace


TAddrUSZip Methods

TAddrUSZip Methods NFX Class Library

The TAddrUSZip type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TAddrUSZip Class
NFX.RelationalModel.DataTypes Namespace


TAddrUSZip.GetTypeName Method

TAddrUSZip GetTypeName Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetTypeName(
    RDBMSCompiler compiler
)
public override string GetTypeName(
    RDBMSCompiler compiler
)
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online String
See Also
TAddrUSZip Class
TAddrUSZip Members
NFX.RelationalModel.DataTypes Namespace


TAddrUSZip Properties

TAddrUSZip Properties NFX Class Library

The TAddrUSZip type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TAddrUSZip Class
NFX.RelationalModel.DataTypes Namespace


TBool Class

TBool Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes TBool

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TBool : RDBMSDomain
public class TBool : RDBMSDomain
Public Class TBool
    Inherits RDBMSDomain
Public Class TBool
    Inherits RDBMSDomain
public ref class TBool : public RDBMSDomain
public ref class TBool : public RDBMSDomain
type TBool =
    class
        inherit RDBMSDomain
    end
type TBool =
    class
        inherit RDBMSDomain
    end
See Also
TBool Members
NFX.RelationalModel.DataTypes Namespace


TBool Members

TBool Members NFX Class Library

The TBool type exposes the following members.
Constructors
 | Name | Description
Public method | TBool | Initializes a new instance of the TBool class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TBool Class
NFX.RelationalModel.DataTypes Namespace


TBool Constructor

TBool Constructor NFX Class Library

Initializes a new instance of the TBool class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TBool()
public TBool()
Public Sub New
Public Sub New
public:
TBool()
public:
TBool()
new : unit -> TBool
new : unit -> TBool
See Also
TBool Class
TBool Members
NFX.RelationalModel.DataTypes Namespace


TBool Methods

TBool Methods NFX Class Library

The TBool type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TBool Class
NFX.RelationalModel.DataTypes Namespace


TBool.GetTypeName Method

TBool GetTypeName Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetTypeName(
    RDBMSCompiler compiler
)
public override string GetTypeName(
    RDBMSCompiler compiler
)
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online String
See Also
TBool Class
TBool Members
NFX.RelationalModel.DataTypes Namespace


TBool Properties

TBool Properties NFX Class Library

The TBool type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TBool Class
NFX.RelationalModel.DataTypes Namespace


TChar Class

TChar Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes UncategorizedValue
NFX.RelationalModel.DataTypes UncategorizedTextualValue
NFX.RelationalModel.DataTypes TChar

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class TChar : UncategorizedTextualValue
public sealed class TChar : UncategorizedTextualValue
Public NotInheritable Class TChar
    Inherits UncategorizedTextualValue
Public NotInheritable Class TChar
    Inherits UncategorizedTextualValue
public ref class TChar sealed : public UncategorizedTextualValue
public ref class TChar sealed : public UncategorizedTextualValue
[<SealedAttribute>]
type TChar =
    class
        inherit UncategorizedTextualValue
    end
[<SealedAttribute>]
type TChar =
    class
        inherit UncategorizedTextualValue
    end
See Also
TChar Members
NFX.RelationalModel.DataTypes Namespace


TChar Members

TChar Members NFX Class Library

The TChar type exposes the following members.
Constructors
 | Name | Description
Public method | TChar | Initializes a new instance of the TChar class
Public method | TChar(Int32) | Initializes a new instance of the TChar class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Size |
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TChar Class
NFX.RelationalModel.DataTypes Namespace


TChar Constructor

TChar Constructor NFX Class Library

Overload List
 | Name | Description
Public method | TChar | Initializes a new instance of the TChar class
Public method | TChar(Int32) | Initializes a new instance of the TChar class
Back to Top
See Also
TChar Class
TChar Members
NFX.RelationalModel.DataTypes Namespace


TChar Constructor

TChar Constructor NFX Class Library

Initializes a new instance of the TChar class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TChar()
public TChar()
Public Sub New
Public Sub New
public:
TChar()
public:
TChar()
new : unit -> TChar
new : unit -> TChar
See Also
TChar Class
TChar Members
TChar Overload
NFX.RelationalModel.DataTypes Namespace


TChar Constructor (Int32)

TChar Constructor (Int32) NFX Class Library

Initializes a new instance of the TChar class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TChar(
    int size
)
public TChar(
    int size
)
Public Sub New (
    size As Integer
)
Public Sub New (
    size As Integer
)
public:
TChar(
    int size
)
public:
TChar(
    int size
)
new :
        size : int -> TChar
new :
        size : int -> TChar

Parameters

size
Type: Online System Int32
See Also
TChar Class
TChar Members
TChar Overload
NFX.RelationalModel.DataTypes Namespace


TChar Fields

TChar Fields NFX Class Library

The TChar type exposes the following members.
Fields
 | Name | Description
Public field | Size |
Back to Top
See Also
TChar Class
NFX.RelationalModel.DataTypes Namespace


TChar.Size Field

TChar Size Field NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Size
public readonly int Size
Public ReadOnly Size As Integer
Public ReadOnly Size As Integer
public:
initonly int Size
public:
initonly int Size
val Size: int
val Size: int

Field Value

Type: Online Int32
See Also
TChar Class
TChar Members
NFX.RelationalModel.DataTypes Namespace


TChar Methods

TChar Methods NFX Class Library

The TChar type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TChar Class
NFX.RelationalModel.DataTypes Namespace


TChar.GetTypeName Method

TChar GetTypeName Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetTypeName(
    RDBMSCompiler compiler
)
public override string GetTypeName(
    RDBMSCompiler compiler
)
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online String
See Also
TChar Class
TChar Members
NFX.RelationalModel.DataTypes Namespace


TChar Properties

TChar Properties NFX Class Library

The TChar type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TChar Class
NFX.RelationalModel.DataTypes Namespace


TCounter Class

TCounter Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes NonInteligentKey
NFX.RelationalModel.DataTypes TCounter

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TCounter : NonInteligentKey
public class TCounter : NonInteligentKey
Public Class TCounter
    Inherits NonInteligentKey
Public Class TCounter
    Inherits NonInteligentKey
public ref class TCounter : public NonInteligentKey
public ref class TCounter : public NonInteligentKey
type TCounter =
    class
        inherit NonInteligentKey
    end
type TCounter =
    class
        inherit NonInteligentKey
    end
See Also
TCounter Members
NFX.RelationalModel.DataTypes Namespace


TCounter Members

TCounter Members NFX Class Library

The TCounter type exposes the following members.
Constructors
 | Name | Description
Public method | TCounter | Initializes a new instance of the TCounter class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | (Overrides RDBMSDomain GetColumnAutoGeneratedScript(RDBMSCompiler, RDBMSEntity, Compiler Outputs).)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | (Overrides NonInteligentKey GetColumnRequirement(RDBMSCompiler).)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Inherited from NonInteligentKey.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TCounter Class
NFX.RelationalModel.DataTypes Namespace


TCounter Constructor

TCounter Constructor NFX Class Library

Initializes a new instance of the TCounter class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TCounter()
public TCounter()
Public Sub New
Public Sub New
public:
TCounter()
public:
TCounter()
new : unit -> TCounter
new : unit -> TCounter
See Also
TCounter Class
TCounter Members
NFX.RelationalModel.DataTypes Namespace


TCounter Methods

TCounter Methods NFX Class Library

The TCounter type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | (Overrides RDBMSDomain GetColumnAutoGeneratedScript(RDBMSCompiler, RDBMSEntity, Compiler Outputs).)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | (Overrides NonInteligentKey GetColumnRequirement(RDBMSCompiler).)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Inherited from NonInteligentKey.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TCounter Class
NFX.RelationalModel.DataTypes Namespace


TCounter.GetColumnAutoGeneratedScript Method

TCounter GetColumnAutoGeneratedScript Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetColumnAutoGeneratedScript(
    RDBMSCompiler compiler,
    RDBMSEntity column,
    Compiler..::..Outputs outputs
)
public override string GetColumnAutoGeneratedScript(
    RDBMSCompiler compiler,
    RDBMSEntity column,
    Compiler..::..Outputs outputs
)
Public Overrides Function GetColumnAutoGeneratedScript (
    compiler As RDBMSCompiler,
    column As RDBMSEntity,
    outputs As Compiler..::..Outputs
) As String
Public Overrides Function GetColumnAutoGeneratedScript (
    compiler As RDBMSCompiler,
    column As RDBMSEntity,
    outputs As Compiler..::..Outputs
) As String
public:
virtual String^ GetColumnAutoGeneratedScript(
    RDBMSCompiler^ compiler,
    RDBMSEntity^ column,
    Compiler..::..Outputs^ outputs
) override
public:
virtual String^ GetColumnAutoGeneratedScript(
    RDBMSCompiler^ compiler,
    RDBMSEntity^ column,
    Compiler..::..Outputs^ outputs
) override
abstract GetColumnAutoGeneratedScript :
        compiler : RDBMSCompiler *
        column : RDBMSEntity *
        outputs : Compiler..::..Outputs -> string
override GetColumnAutoGeneratedScript :
        compiler : RDBMSCompiler *
        column : RDBMSEntity *
        outputs : Compiler..::..Outputs -> string
abstract GetColumnAutoGeneratedScript :
        compiler : RDBMSCompiler *
        column : RDBMSEntity *
        outputs : Compiler..::..Outputs -> string
override GetColumnAutoGeneratedScript :
        compiler : RDBMSCompiler *
        column : RDBMSEntity *
        outputs : Compiler..::..Outputs -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler
column
Type: NFX.RelationalModel RDBMSEntity
outputs
Type: NFX.RelationalModel Compiler Outputs

Return Value

Type: Online String
See Also
TCounter Class
TCounter Members
NFX.RelationalModel.DataTypes Namespace


TCounter.GetColumnRequirement Method

TCounter GetColumnRequirement Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Nullable<bool> GetColumnRequirement(
    RDBMSCompiler compiler
)
public override Nullable<bool> GetColumnRequirement(
    RDBMSCompiler compiler
)
Public Overrides Function GetColumnRequirement (
    compiler As RDBMSCompiler
) As Nullable(Of Boolean)
Public Overrides Function GetColumnRequirement (
    compiler As RDBMSCompiler
) As Nullable(Of Boolean)
public:
virtual Nullable<bool> GetColumnRequirement(
    RDBMSCompiler^ compiler
) override
public:
virtual Nullable<bool> GetColumnRequirement(
    RDBMSCompiler^ compiler
) override
abstract GetColumnRequirement :
        compiler : RDBMSCompiler -> Nullable<bool>
override GetColumnRequirement :
        compiler : RDBMSCompiler -> Nullable<bool>
abstract GetColumnRequirement :
        compiler : RDBMSCompiler -> Nullable<bool>
override GetColumnRequirement :
        compiler : RDBMSCompiler -> Nullable<bool>

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online Nullable Online Boolean
See Also
TCounter Class
TCounter Members
NFX.RelationalModel.DataTypes Namespace


TCounter Properties

TCounter Properties NFX Class Library

The TCounter type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TCounter Class
NFX.RelationalModel.DataTypes Namespace


TCounterRef Class

TCounterRef Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes NonInteligentKey
NFX.RelationalModel.DataTypes TCounterRef

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TCounterRef : NonInteligentKey
public class TCounterRef : NonInteligentKey
Public Class TCounterRef
    Inherits NonInteligentKey
Public Class TCounterRef
    Inherits NonInteligentKey
public ref class TCounterRef : public NonInteligentKey
public ref class TCounterRef : public NonInteligentKey
type TCounterRef =
    class
        inherit NonInteligentKey
    end
type TCounterRef =
    class
        inherit NonInteligentKey
    end
See Also
TCounterRef Members
NFX.RelationalModel.DataTypes Namespace


TCounterRef Members

TCounterRef Members NFX Class Library

The TCounterRef type exposes the following members.
Constructors
 | Name | Description
Public method | TCounterRef | Initializes a new instance of the TCounterRef class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | (Inherited from NonInteligentKey.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Inherited from NonInteligentKey.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | (Overrides RDBMSDomain TransformColumnName(RDBMSCompiler, RDBMSEntity).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TCounterRef Class
NFX.RelationalModel.DataTypes Namespace


TCounterRef Constructor

TCounterRef Constructor NFX Class Library

Initializes a new instance of the TCounterRef class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TCounterRef()
public TCounterRef()
Public Sub New
Public Sub New
public:
TCounterRef()
public:
TCounterRef()
new : unit -> TCounterRef
new : unit -> TCounterRef
See Also
TCounterRef Class
TCounterRef Members
NFX.RelationalModel.DataTypes Namespace


TCounterRef Methods

TCounterRef Methods NFX Class Library

The TCounterRef type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | (Inherited from NonInteligentKey.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Inherited from NonInteligentKey.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | (Overrides RDBMSDomain TransformColumnName(RDBMSCompiler, RDBMSEntity).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TCounterRef Class
NFX.RelationalModel.DataTypes Namespace


TCounterRef.TransformColumnName Method

TCounterRef TransformColumnName Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void TransformColumnName(
    RDBMSCompiler compiler,
    RDBMSEntity column
)
public override void TransformColumnName(
    RDBMSCompiler compiler,
    RDBMSEntity column
)
Public Overrides Sub TransformColumnName (
    compiler As RDBMSCompiler,
    column As RDBMSEntity
)
Public Overrides Sub TransformColumnName (
    compiler As RDBMSCompiler,
    column As RDBMSEntity
)
public:
virtual void TransformColumnName(
    RDBMSCompiler^ compiler,
    RDBMSEntity^ column
) override
public:
virtual void TransformColumnName(
    RDBMSCompiler^ compiler,
    RDBMSEntity^ column
) override
abstract TransformColumnName :
        compiler : RDBMSCompiler *
        column : RDBMSEntity -> unit
override TransformColumnName :
        compiler : RDBMSCompiler *
        column : RDBMSEntity -> unit
abstract TransformColumnName :
        compiler : RDBMSCompiler *
        column : RDBMSEntity -> unit
override TransformColumnName :
        compiler : RDBMSCompiler *
        column : RDBMSEntity -> unit

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler
column
Type: NFX.RelationalModel RDBMSEntity
See Also
TCounterRef Class
TCounterRef Members
NFX.RelationalModel.DataTypes Namespace


TCounterRef Properties

TCounterRef Properties NFX Class Library

The TCounterRef type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TCounterRef Class
NFX.RelationalModel.DataTypes Namespace


TDateTime Class

TDateTime Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes TDateTime

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TDateTime : RDBMSDomain
public class TDateTime : RDBMSDomain
Public Class TDateTime
    Inherits RDBMSDomain
Public Class TDateTime
    Inherits RDBMSDomain
public ref class TDateTime : public RDBMSDomain
public ref class TDateTime : public RDBMSDomain
type TDateTime =
    class
        inherit RDBMSDomain
    end
type TDateTime =
    class
        inherit RDBMSDomain
    end
See Also
TDateTime Members
NFX.RelationalModel.DataTypes Namespace


TDateTime Members

TDateTime Members NFX Class Library

The TDateTime type exposes the following members.
Constructors
 | Name | Description
Public method | TDateTime | Initializes a new instance of the TDateTime class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TDateTime Class
NFX.RelationalModel.DataTypes Namespace


TDateTime Constructor

TDateTime Constructor NFX Class Library

Initializes a new instance of the TDateTime class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TDateTime()
public TDateTime()
Public Sub New
Public Sub New
public:
TDateTime()
public:
TDateTime()
new : unit -> TDateTime
new : unit -> TDateTime
See Also
TDateTime Class
TDateTime Members
NFX.RelationalModel.DataTypes Namespace


TDateTime Methods

TDateTime Methods NFX Class Library

The TDateTime type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TDateTime Class
NFX.RelationalModel.DataTypes Namespace


TDateTime.GetTypeName Method

TDateTime GetTypeName Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetTypeName(
    RDBMSCompiler compiler
)
public override string GetTypeName(
    RDBMSCompiler compiler
)
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online String
See Also
TDateTime Class
TDateTime Members
NFX.RelationalModel.DataTypes Namespace


TDateTime Properties

TDateTime Properties NFX Class Library

The TDateTime type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TDateTime Class
NFX.RelationalModel.DataTypes Namespace


TDouble Class

TDouble Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes UncategorizedValue
NFX.RelationalModel.DataTypes UncategorizedNumericValue
NFX.RelationalModel.DataTypes TDouble

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class TDouble : UncategorizedNumericValue
public sealed class TDouble : UncategorizedNumericValue
Public NotInheritable Class TDouble
    Inherits UncategorizedNumericValue
Public NotInheritable Class TDouble
    Inherits UncategorizedNumericValue
public ref class TDouble sealed : public UncategorizedNumericValue
public ref class TDouble sealed : public UncategorizedNumericValue
[<SealedAttribute>]
type TDouble =
    class
        inherit UncategorizedNumericValue
    end
[<SealedAttribute>]
type TDouble =
    class
        inherit UncategorizedNumericValue
    end
See Also
TDouble Members
NFX.RelationalModel.DataTypes Namespace


TDouble Members

TDouble Members NFX Class Library

The TDouble type exposes the following members.
Constructors
 | Name | Description
Public method | TDouble | Initializes a new instance of the TDouble class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TDouble Class
NFX.RelationalModel.DataTypes Namespace


TDouble Constructor

TDouble Constructor NFX Class Library

Initializes a new instance of the TDouble class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TDouble()
public TDouble()
Public Sub New
Public Sub New
public:
TDouble()
public:
TDouble()
new : unit -> TDouble
new : unit -> TDouble
See Also
TDouble Class
TDouble Members
NFX.RelationalModel.DataTypes Namespace


TDouble Methods

TDouble Methods NFX Class Library

The TDouble type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TDouble Class
NFX.RelationalModel.DataTypes Namespace


TDouble.GetTypeName Method

TDouble GetTypeName Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetTypeName(
    RDBMSCompiler compiler
)
public override string GetTypeName(
    RDBMSCompiler compiler
)
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online String
See Also
TDouble Class
TDouble Members
NFX.RelationalModel.DataTypes Namespace


TDouble Properties

TDouble Properties NFX Class Library

The TDouble type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TDouble Class
NFX.RelationalModel.DataTypes Namespace


TEMail Class

TEMail Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes TEMail

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TEMail : RDBMSDomain
public class TEMail : RDBMSDomain
Public Class TEMail
    Inherits RDBMSDomain
Public Class TEMail
    Inherits RDBMSDomain
public ref class TEMail : public RDBMSDomain
public ref class TEMail : public RDBMSDomain
type TEMail =
    class
        inherit RDBMSDomain
    end
type TEMail =
    class
        inherit RDBMSDomain
    end
See Also
TEMail Members
NFX.RelationalModel.DataTypes Namespace


TEMail Members

TEMail Members NFX Class Library

The TEMail type exposes the following members.
Constructors
 | Name | Description
Public method | TEMail | Initializes a new instance of the TEMail class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TEMail Class
NFX.RelationalModel.DataTypes Namespace


TEMail Constructor

TEMail Constructor NFX Class Library

Initializes a new instance of the TEMail class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TEMail()
public TEMail()
Public Sub New
Public Sub New
public:
TEMail()
public:
TEMail()
new : unit -> TEMail
new : unit -> TEMail
See Also
TEMail Class
TEMail Members
NFX.RelationalModel.DataTypes Namespace


TEMail Methods

TEMail Methods NFX Class Library

The TEMail type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TEMail Class
NFX.RelationalModel.DataTypes Namespace


TEMail.GetTypeName Method

TEMail GetTypeName Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetTypeName(
    RDBMSCompiler compiler
)
public override string GetTypeName(
    RDBMSCompiler compiler
)
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online String
See Also
TEMail Class
TEMail Members
NFX.RelationalModel.DataTypes Namespace


TEMail Properties

TEMail Properties NFX Class Library

The TEMail type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TEMail Class
NFX.RelationalModel.DataTypes Namespace


TEnum Class

TEnum Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes UncategorizedValue
NFX.RelationalModel.DataTypes UncategorizedTextualValue
NFX.RelationalModel.DataTypes TEnum

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class TEnum : UncategorizedTextualValue
public sealed class TEnum : UncategorizedTextualValue
Public NotInheritable Class TEnum
    Inherits UncategorizedTextualValue
Public NotInheritable Class TEnum
    Inherits UncategorizedTextualValue
public ref class TEnum sealed : public UncategorizedTextualValue
public ref class TEnum sealed : public UncategorizedTextualValue
[<SealedAttribute>]
type TEnum =
    class
        inherit UncategorizedTextualValue
    end
[<SealedAttribute>]
type TEnum =
    class
        inherit UncategorizedTextualValue
    end
See Also
TEnum Members
NFX.RelationalModel.DataTypes Namespace


TEnum Members

TEnum Members NFX Class Library

The TEnum type exposes the following members.
Constructors
 | Name | Description
Public method | TEnum | Initializes a new instance of the TEnum class
Public method | TEnum(String) | Initializes a new instance of the TEnum class
Public method | TEnum(DBCharType, String) | Initializes a new instance of the TEnum class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Overrides Domain Configure(IConfigSectionNode).)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | (Overrides RDBMSDomain GetColumnCheckScript(RDBMSCompiler, RDBMSEntity, Compiler Outputs).)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Size |
Public field | Type |
Public field | Values |
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TEnum Class
NFX.RelationalModel.DataTypes Namespace


TEnum Constructor

TEnum Constructor NFX Class Library

Overload List
 | Name | Description
Public method | TEnum | Initializes a new instance of the TEnum class
Public method | TEnum(String) | Initializes a new instance of the TEnum class
Public method | TEnum(DBCharType, String) | Initializes a new instance of the TEnum class
Back to Top
See Also
TEnum Class
TEnum Members
NFX.RelationalModel.DataTypes Namespace


TEnum Constructor

TEnum Constructor NFX Class Library

Initializes a new instance of the TEnum class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TEnum()
public TEnum()
Public Sub New
Public Sub New
public:
TEnum()
public:
TEnum()
new : unit -> TEnum
new : unit -> TEnum
See Also
TEnum Class
TEnum Members
TEnum Overload
NFX.RelationalModel.DataTypes Namespace


TEnum Constructor (String)

TEnum Constructor (String) NFX Class Library

Initializes a new instance of the TEnum class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TEnum(
    string values
)
public TEnum(
    string values
)
Public Sub New (
    values As String
)
Public Sub New (
    values As String
)
public:
TEnum(
    String^ values
)
public:
TEnum(
    String^ values
)
new :
        values : string -> TEnum
new :
        values : string -> TEnum

Parameters

values
Type: Online System String
See Also
TEnum Class
TEnum Members
TEnum Overload
NFX.RelationalModel.DataTypes Namespace


TEnum Constructor (DBCharType, String)

TEnum Constructor (DBCharType, String) NFX Class Library

Initializes a new instance of the TEnum class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TEnum(
    DBCharType type,
    string values
)
public TEnum(
    DBCharType type,
    string values
)
Public Sub New (
    type As DBCharType,
    values As String
)
Public Sub New (
    type As DBCharType,
    values As String
)
public:
TEnum(
    DBCharType type,
    String^ values
)
public:
TEnum(
    DBCharType type,
    String^ values
)
new :
        type : DBCharType *
        values : string -> TEnum
new :
        type : DBCharType *
        values : string -> TEnum

Parameters

type
Type: NFX.RelationalModel.DataTypes DBCharType
values
Type: Online System String
See Also
TEnum Class
TEnum Members
TEnum Overload
NFX.RelationalModel.DataTypes Namespace


TEnum Fields

TEnum Fields NFX Class Library

The TEnum type exposes the following members.
Fields
 | Name | Description
Public field | Size |
Public field | Type |
Public field | Values |
Back to Top
See Also
TEnum Class
NFX.RelationalModel.DataTypes Namespace


TEnum.Size Field

TEnum Size Field NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int Size
[ConfigAttribute]
public int Size
<ConfigAttribute>
Public Size As Integer
<ConfigAttribute>
Public Size As Integer
public:
[ConfigAttribute]
int Size
public:
[ConfigAttribute]
int Size
[<ConfigAttribute>]
val mutable Size: int
[<ConfigAttribute>]
val mutable Size: int

Field Value

Type: Online Int32
See Also
TEnum Class
TEnum Members
NFX.RelationalModel.DataTypes Namespace


TEnum.Type Field

TEnum Type Field NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public DBCharType Type
[ConfigAttribute]
public DBCharType Type
<ConfigAttribute>
Public Type As DBCharType
<ConfigAttribute>
Public Type As DBCharType
public:
[ConfigAttribute]
DBCharType Type
public:
[ConfigAttribute]
DBCharType Type
[<ConfigAttribute>]
val mutable Type: DBCharType
[<ConfigAttribute>]
val mutable Type: DBCharType

Field Value

Type: DBCharType
See Also
TEnum Class
TEnum Members
NFX.RelationalModel.DataTypes Namespace


TEnum.Values Field

TEnum Values Field NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string[] Values
public string[] Values
Public Values As String()
Public Values As String()
public:
array<String^>^ Values
public:
array<String^>^ Values
val mutable Values: string[]
val mutable Values: string[]

Field Value

Type: Online String
See Also
TEnum Class
TEnum Members
NFX.RelationalModel.DataTypes Namespace


TEnum Methods

TEnum Methods NFX Class Library

The TEnum type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Overrides Domain Configure(IConfigSectionNode).)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | (Overrides RDBMSDomain GetColumnCheckScript(RDBMSCompiler, RDBMSEntity, Compiler Outputs).)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TEnum Class
NFX.RelationalModel.DataTypes Namespace


TEnum.Configure Method

TEnum Configure Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Configure(
    IConfigSectionNode node
)
public override void Configure(
    IConfigSectionNode node
)
Public Overrides Sub Configure (
    node As IConfigSectionNode
)
Public Overrides Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) override
public:
virtual void Configure(
    IConfigSectionNode^ node
) override
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
TEnum Class
TEnum Members
NFX.RelationalModel.DataTypes Namespace


TEnum.GetColumnCheckScript Method

TEnum GetColumnCheckScript Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetColumnCheckScript(
    RDBMSCompiler compiler,
    RDBMSEntity column,
    Compiler..::..Outputs outputs
)
public override string GetColumnCheckScript(
    RDBMSCompiler compiler,
    RDBMSEntity column,
    Compiler..::..Outputs outputs
)
Public Overrides Function GetColumnCheckScript (
    compiler As RDBMSCompiler,
    column As RDBMSEntity,
    outputs As Compiler..::..Outputs
) As String
Public Overrides Function GetColumnCheckScript (
    compiler As RDBMSCompiler,
    column As RDBMSEntity,
    outputs As Compiler..::..Outputs
) As String
public:
virtual String^ GetColumnCheckScript(
    RDBMSCompiler^ compiler,
    RDBMSEntity^ column,
    Compiler..::..Outputs^ outputs
) override
public:
virtual String^ GetColumnCheckScript(
    RDBMSCompiler^ compiler,
    RDBMSEntity^ column,
    Compiler..::..Outputs^ outputs
) override
abstract GetColumnCheckScript :
        compiler : RDBMSCompiler *
        column : RDBMSEntity *
        outputs : Compiler..::..Outputs -> string
override GetColumnCheckScript :
        compiler : RDBMSCompiler *
        column : RDBMSEntity *
        outputs : Compiler..::..Outputs -> string
abstract GetColumnCheckScript :
        compiler : RDBMSCompiler *
        column : RDBMSEntity *
        outputs : Compiler..::..Outputs -> string
override GetColumnCheckScript :
        compiler : RDBMSCompiler *
        column : RDBMSEntity *
        outputs : Compiler..::..Outputs -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler
column
Type: NFX.RelationalModel RDBMSEntity
outputs
Type: NFX.RelationalModel Compiler Outputs

Return Value

Type: Online String
See Also
TEnum Class
TEnum Members
NFX.RelationalModel.DataTypes Namespace


TEnum.GetTypeName Method

TEnum GetTypeName Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetTypeName(
    RDBMSCompiler compiler
)
public override string GetTypeName(
    RDBMSCompiler compiler
)
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online String
See Also
TEnum Class
TEnum Members
NFX.RelationalModel.DataTypes Namespace


TEnum Properties

TEnum Properties NFX Class Library

The TEnum type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TEnum Class
NFX.RelationalModel.DataTypes Namespace


TGDID Class

TGDID Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes NonInteligentKey
NFX.RelationalModel.DataTypes NonInteligentGDIDKey
NFX.RelationalModel.DataTypes TGDID

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TGDID : NonInteligentGDIDKey
public class TGDID : NonInteligentGDIDKey
Public Class TGDID
    Inherits NonInteligentGDIDKey
Public Class TGDID
    Inherits NonInteligentGDIDKey
public ref class TGDID : public NonInteligentGDIDKey
public ref class TGDID : public NonInteligentGDIDKey
type TGDID =
    class
        inherit NonInteligentGDIDKey
    end
type TGDID =
    class
        inherit NonInteligentGDIDKey
    end
See Also
TGDID Members
NFX.RelationalModel.DataTypes Namespace


TGDID Members

TGDID Members NFX Class Library

The TGDID type exposes the following members.
Constructors
 | Name | Description
Public method | TGDID | Initializes a new instance of the TGDID class
Public method | TGDID(Boolean) | Initializes a new instance of the TGDID class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | (Inherited from NonInteligentGDIDKey.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Inherited from NonInteligentGDIDKey.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Required | (Inherited from NonInteligentGDIDKey.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TGDID Class
NFX.RelationalModel.DataTypes Namespace


TGDID Constructor

TGDID Constructor NFX Class Library

Overload List
 | Name | Description
Public method | TGDID | Initializes a new instance of the TGDID class
Public method | TGDID(Boolean) | Initializes a new instance of the TGDID class
Back to Top
See Also
TGDID Class
TGDID Members
NFX.RelationalModel.DataTypes Namespace


TGDID Constructor

TGDID Constructor NFX Class Library

Initializes a new instance of the TGDID class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TGDID()
public TGDID()
Public Sub New
Public Sub New
public:
TGDID()
public:
TGDID()
new : unit -> TGDID
new : unit -> TGDID
See Also
TGDID Class
TGDID Members
TGDID Overload
NFX.RelationalModel.DataTypes Namespace


TGDID Constructor (Boolean)

TGDID Constructor (Boolean) NFX Class Library

Initializes a new instance of the TGDID class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TGDID(
    bool required
)
public TGDID(
    bool required
)
Public Sub New (
    required As Boolean
)
Public Sub New (
    required As Boolean
)
public:
TGDID(
    bool required
)
public:
TGDID(
    bool required
)
new :
        required : bool -> TGDID
new :
        required : bool -> TGDID

Parameters

required
Type: Online System Boolean
See Also
TGDID Class
TGDID Members
TGDID Overload
NFX.RelationalModel.DataTypes Namespace


TGDID Fields

TGDID Fields NFX Class Library

The TGDID type exposes the following members.
Fields
 | Name | Description
Public field | Required | (Inherited from NonInteligentGDIDKey.)
Back to Top
See Also
TGDID Class
NFX.RelationalModel.DataTypes Namespace


TGDID Methods

TGDID Methods NFX Class Library

The TGDID type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | (Inherited from NonInteligentGDIDKey.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Inherited from NonInteligentGDIDKey.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TGDID Class
NFX.RelationalModel.DataTypes Namespace


TGDID Properties

TGDID Properties NFX Class Library

The TGDID type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TGDID Class
NFX.RelationalModel.DataTypes Namespace


TGDIDRef Class

TGDIDRef Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes NonInteligentKey
NFX.RelationalModel.DataTypes NonInteligentGDIDKey
NFX.RelationalModel.DataTypes TGDIDRef

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TGDIDRef : NonInteligentGDIDKey
public class TGDIDRef : NonInteligentGDIDKey
Public Class TGDIDRef
    Inherits NonInteligentGDIDKey
Public Class TGDIDRef
    Inherits NonInteligentGDIDKey
public ref class TGDIDRef : public NonInteligentGDIDKey
public ref class TGDIDRef : public NonInteligentGDIDKey
type TGDIDRef =
    class
        inherit NonInteligentGDIDKey
    end
type TGDIDRef =
    class
        inherit NonInteligentGDIDKey
    end
See Also
TGDIDRef Members
NFX.RelationalModel.DataTypes Namespace


TGDIDRef Members

TGDIDRef Members NFX Class Library

The TGDIDRef type exposes the following members.
Constructors
 | Name | Description
Public method | TGDIDRef | Initializes a new instance of the TGDIDRef class
Public method | TGDIDRef(Boolean) | Initializes a new instance of the TGDIDRef class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | (Inherited from NonInteligentGDIDKey.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Inherited from NonInteligentGDIDKey.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | (Overrides RDBMSDomain TransformColumnName(RDBMSCompiler, RDBMSEntity).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Required | (Inherited from NonInteligentGDIDKey.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TGDIDRef Class
NFX.RelationalModel.DataTypes Namespace


TGDIDRef Constructor

TGDIDRef Constructor NFX Class Library

Overload List
 | Name | Description
Public method | TGDIDRef | Initializes a new instance of the TGDIDRef class
Public method | TGDIDRef(Boolean) | Initializes a new instance of the TGDIDRef class
Back to Top
See Also
TGDIDRef Class
TGDIDRef Members
NFX.RelationalModel.DataTypes Namespace


TGDIDRef Constructor

TGDIDRef Constructor NFX Class Library

Initializes a new instance of the TGDIDRef class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TGDIDRef()
public TGDIDRef()
Public Sub New
Public Sub New
public:
TGDIDRef()
public:
TGDIDRef()
new : unit -> TGDIDRef
new : unit -> TGDIDRef
See Also
TGDIDRef Class
TGDIDRef Members
TGDIDRef Overload
NFX.RelationalModel.DataTypes Namespace


TGDIDRef Constructor (Boolean)

TGDIDRef Constructor (Boolean) NFX Class Library

Initializes a new instance of the TGDIDRef class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TGDIDRef(
    bool required
)
public TGDIDRef(
    bool required
)
Public Sub New (
    required As Boolean
)
Public Sub New (
    required As Boolean
)
public:
TGDIDRef(
    bool required
)
public:
TGDIDRef(
    bool required
)
new :
        required : bool -> TGDIDRef
new :
        required : bool -> TGDIDRef

Parameters

required
Type: Online System Boolean
See Also
TGDIDRef Class
TGDIDRef Members
TGDIDRef Overload
NFX.RelationalModel.DataTypes Namespace


TGDIDRef Fields

TGDIDRef Fields NFX Class Library

The TGDIDRef type exposes the following members.
Fields
 | Name | Description
Public field | Required | (Inherited from NonInteligentGDIDKey.)
Back to Top
See Also
TGDIDRef Class
NFX.RelationalModel.DataTypes Namespace


TGDIDRef Methods

TGDIDRef Methods NFX Class Library

The TGDIDRef type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | (Inherited from NonInteligentGDIDKey.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Inherited from NonInteligentGDIDKey.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | (Overrides RDBMSDomain TransformColumnName(RDBMSCompiler, RDBMSEntity).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TGDIDRef Class
NFX.RelationalModel.DataTypes Namespace


TGDIDRef.TransformColumnName Method

TGDIDRef TransformColumnName Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void TransformColumnName(
    RDBMSCompiler compiler,
    RDBMSEntity column
)
public override void TransformColumnName(
    RDBMSCompiler compiler,
    RDBMSEntity column
)
Public Overrides Sub TransformColumnName (
    compiler As RDBMSCompiler,
    column As RDBMSEntity
)
Public Overrides Sub TransformColumnName (
    compiler As RDBMSCompiler,
    column As RDBMSEntity
)
public:
virtual void TransformColumnName(
    RDBMSCompiler^ compiler,
    RDBMSEntity^ column
) override
public:
virtual void TransformColumnName(
    RDBMSCompiler^ compiler,
    RDBMSEntity^ column
) override
abstract TransformColumnName :
        compiler : RDBMSCompiler *
        column : RDBMSEntity -> unit
override TransformColumnName :
        compiler : RDBMSCompiler *
        column : RDBMSEntity -> unit
abstract TransformColumnName :
        compiler : RDBMSCompiler *
        column : RDBMSEntity -> unit
override TransformColumnName :
        compiler : RDBMSCompiler *
        column : RDBMSEntity -> unit

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler
column
Type: NFX.RelationalModel RDBMSEntity
See Also
TGDIDRef Class
TGDIDRef Members
NFX.RelationalModel.DataTypes Namespace


TGDIDRef Properties

TGDIDRef Properties NFX Class Library

The TGDIDRef type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TGDIDRef Class
NFX.RelationalModel.DataTypes Namespace


THumanAge Class

THumanAge Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes HumanAttribute
NFX.RelationalModel.DataTypes THumanAge

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class THumanAge : HumanAttribute
public class THumanAge : HumanAttribute
Public Class THumanAge
    Inherits HumanAttribute
Public Class THumanAge
    Inherits HumanAttribute
public ref class THumanAge : public HumanAttribute
public ref class THumanAge : public HumanAttribute
type THumanAge =
    class
        inherit HumanAttribute
    end
type THumanAge =
    class
        inherit HumanAttribute
    end
See Also
THumanAge Members
NFX.RelationalModel.DataTypes Namespace


THumanAge Members

THumanAge Members NFX Class Library

The THumanAge type exposes the following members.
Constructors
 | Name | Description
Public method | THumanAge | Initializes a new instance of the THumanAge class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | (Overrides RDBMSDomain GetColumnCheckScript(RDBMSCompiler, RDBMSEntity, Compiler Outputs).)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
THumanAge Class
NFX.RelationalModel.DataTypes Namespace


THumanAge Constructor

THumanAge Constructor NFX Class Library

Initializes a new instance of the THumanAge class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public THumanAge()
public THumanAge()
Public Sub New
Public Sub New
public:
THumanAge()
public:
THumanAge()
new : unit -> THumanAge
new : unit -> THumanAge
See Also
THumanAge Class
THumanAge Members
NFX.RelationalModel.DataTypes Namespace


THumanAge Methods

THumanAge Methods NFX Class Library

The THumanAge type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | (Overrides RDBMSDomain GetColumnCheckScript(RDBMSCompiler, RDBMSEntity, Compiler Outputs).)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
THumanAge Class
NFX.RelationalModel.DataTypes Namespace


THumanAge.GetColumnCheckScript Method

THumanAge GetColumnCheckScript Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetColumnCheckScript(
    RDBMSCompiler compiler,
    RDBMSEntity column,
    Compiler..::..Outputs outputs
)
public override string GetColumnCheckScript(
    RDBMSCompiler compiler,
    RDBMSEntity column,
    Compiler..::..Outputs outputs
)
Public Overrides Function GetColumnCheckScript (
    compiler As RDBMSCompiler,
    column As RDBMSEntity,
    outputs As Compiler..::..Outputs
) As String
Public Overrides Function GetColumnCheckScript (
    compiler As RDBMSCompiler,
    column As RDBMSEntity,
    outputs As Compiler..::..Outputs
) As String
public:
virtual String^ GetColumnCheckScript(
    RDBMSCompiler^ compiler,
    RDBMSEntity^ column,
    Compiler..::..Outputs^ outputs
) override
public:
virtual String^ GetColumnCheckScript(
    RDBMSCompiler^ compiler,
    RDBMSEntity^ column,
    Compiler..::..Outputs^ outputs
) override
abstract GetColumnCheckScript :
        compiler : RDBMSCompiler *
        column : RDBMSEntity *
        outputs : Compiler..::..Outputs -> string
override GetColumnCheckScript :
        compiler : RDBMSCompiler *
        column : RDBMSEntity *
        outputs : Compiler..::..Outputs -> string
abstract GetColumnCheckScript :
        compiler : RDBMSCompiler *
        column : RDBMSEntity *
        outputs : Compiler..::..Outputs -> string
override GetColumnCheckScript :
        compiler : RDBMSCompiler *
        column : RDBMSEntity *
        outputs : Compiler..::..Outputs -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler
column
Type: NFX.RelationalModel RDBMSEntity
outputs
Type: NFX.RelationalModel Compiler Outputs

Return Value

Type: Online String
See Also
THumanAge Class
THumanAge Members
NFX.RelationalModel.DataTypes Namespace


THumanAge.GetTypeName Method

THumanAge GetTypeName Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetTypeName(
    RDBMSCompiler compiler
)
public override string GetTypeName(
    RDBMSCompiler compiler
)
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online String
See Also
THumanAge Class
THumanAge Members
NFX.RelationalModel.DataTypes Namespace


THumanAge Properties

THumanAge Properties NFX Class Library

The THumanAge type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
THumanAge Class
NFX.RelationalModel.DataTypes Namespace


THumanName Class

THumanName Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes HumanAttribute
NFX.RelationalModel.DataTypes THumanName

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class THumanName : HumanAttribute
public class THumanName : HumanAttribute
Public Class THumanName
    Inherits HumanAttribute
Public Class THumanName
    Inherits HumanAttribute
public ref class THumanName : public HumanAttribute
public ref class THumanName : public HumanAttribute
type THumanName =
    class
        inherit HumanAttribute
    end
type THumanName =
    class
        inherit HumanAttribute
    end
See Also
THumanName Members
NFX.RelationalModel.DataTypes Namespace


THumanName Members

THumanName Members NFX Class Library

The THumanName type exposes the following members.
Constructors
 | Name | Description
Public method | THumanName | Initializes a new instance of the THumanName class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | (Overrides RDBMSDomain GetColumnRequirement(RDBMSCompiler).)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
THumanName Class
NFX.RelationalModel.DataTypes Namespace


THumanName Constructor

THumanName Constructor NFX Class Library

Initializes a new instance of the THumanName class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public THumanName()
public THumanName()
Public Sub New
Public Sub New
public:
THumanName()
public:
THumanName()
new : unit -> THumanName
new : unit -> THumanName
See Also
THumanName Class
THumanName Members
NFX.RelationalModel.DataTypes Namespace


THumanName Methods

THumanName Methods NFX Class Library

The THumanName type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | (Overrides RDBMSDomain GetColumnRequirement(RDBMSCompiler).)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
THumanName Class
NFX.RelationalModel.DataTypes Namespace


THumanName.GetColumnRequirement Method

THumanName GetColumnRequirement Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Nullable<bool> GetColumnRequirement(
    RDBMSCompiler compiler
)
public override Nullable<bool> GetColumnRequirement(
    RDBMSCompiler compiler
)
Public Overrides Function GetColumnRequirement (
    compiler As RDBMSCompiler
) As Nullable(Of Boolean)
Public Overrides Function GetColumnRequirement (
    compiler As RDBMSCompiler
) As Nullable(Of Boolean)
public:
virtual Nullable<bool> GetColumnRequirement(
    RDBMSCompiler^ compiler
) override
public:
virtual Nullable<bool> GetColumnRequirement(
    RDBMSCompiler^ compiler
) override
abstract GetColumnRequirement :
        compiler : RDBMSCompiler -> Nullable<bool>
override GetColumnRequirement :
        compiler : RDBMSCompiler -> Nullable<bool>
abstract GetColumnRequirement :
        compiler : RDBMSCompiler -> Nullable<bool>
override GetColumnRequirement :
        compiler : RDBMSCompiler -> Nullable<bool>

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online Nullable Online Boolean
See Also
THumanName Class
THumanName Members
NFX.RelationalModel.DataTypes Namespace


THumanName.GetTypeName Method

THumanName GetTypeName Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetTypeName(
    RDBMSCompiler compiler
)
public override string GetTypeName(
    RDBMSCompiler compiler
)
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online String
See Also
THumanName Class
THumanName Members
NFX.RelationalModel.DataTypes Namespace


THumanName Properties

THumanName Properties NFX Class Library

The THumanName type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
THumanName Class
NFX.RelationalModel.DataTypes Namespace


TInt Class

TInt Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes UncategorizedValue
NFX.RelationalModel.DataTypes UncategorizedNumericValue
NFX.RelationalModel.DataTypes TInt

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class TInt : UncategorizedNumericValue
public sealed class TInt : UncategorizedNumericValue
Public NotInheritable Class TInt
    Inherits UncategorizedNumericValue
Public NotInheritable Class TInt
    Inherits UncategorizedNumericValue
public ref class TInt sealed : public UncategorizedNumericValue
public ref class TInt sealed : public UncategorizedNumericValue
[<SealedAttribute>]
type TInt =
    class
        inherit UncategorizedNumericValue
    end
[<SealedAttribute>]
type TInt =
    class
        inherit UncategorizedNumericValue
    end
See Also
TInt Members
NFX.RelationalModel.DataTypes Namespace


TInt Members

TInt Members NFX Class Library

The TInt type exposes the following members.
Constructors
 | Name | Description
Public method | TInt | Initializes a new instance of the TInt class
Public method | TInt(Int32) | Initializes a new instance of the TInt class
Public method | TInt(Int32, Boolean) | Initializes a new instance of the TInt class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Size |
Public field | Unsigned |
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TInt Class
NFX.RelationalModel.DataTypes Namespace


TInt Constructor

TInt Constructor NFX Class Library

Overload List
 | Name | Description
Public method | TInt | Initializes a new instance of the TInt class
Public method | TInt(Int32) | Initializes a new instance of the TInt class
Public method | TInt(Int32, Boolean) | Initializes a new instance of the TInt class
Back to Top
See Also
TInt Class
TInt Members
NFX.RelationalModel.DataTypes Namespace


TInt Constructor

TInt Constructor NFX Class Library

Initializes a new instance of the TInt class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TInt()
public TInt()
Public Sub New
Public Sub New
public:
TInt()
public:
TInt()
new : unit -> TInt
new : unit -> TInt
See Also
TInt Class
TInt Members
TInt Overload
NFX.RelationalModel.DataTypes Namespace


TInt Constructor (Int32)

TInt Constructor (Int32) NFX Class Library

Initializes a new instance of the TInt class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TInt(
    int size
)
public TInt(
    int size
)
Public Sub New (
    size As Integer
)
Public Sub New (
    size As Integer
)
public:
TInt(
    int size
)
public:
TInt(
    int size
)
new :
        size : int -> TInt
new :
        size : int -> TInt

Parameters

size
Type: Online System Int32
See Also
TInt Class
TInt Members
TInt Overload
NFX.RelationalModel.DataTypes Namespace


TInt Constructor (Int32, Boolean)

TInt Constructor (Int32, Boolean) NFX Class Library

Initializes a new instance of the TInt class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TInt(
    int size,
    bool unsigned
)
public TInt(
    int size,
    bool unsigned
)
Public Sub New (
    size As Integer,
    unsigned As Boolean
)
Public Sub New (
    size As Integer,
    unsigned As Boolean
)
public:
TInt(
    int size,
    bool unsigned
)
public:
TInt(
    int size,
    bool unsigned
)
new :
        size : int *
        unsigned : bool -> TInt
new :
        size : int *
        unsigned : bool -> TInt

Parameters

size
Type: Online System Int32
unsigned
Type: Online System Boolean
See Also
TInt Class
TInt Members
TInt Overload
NFX.RelationalModel.DataTypes Namespace


TInt Fields

TInt Fields NFX Class Library

The TInt type exposes the following members.
Fields
 | Name | Description
Public field | Size |
Public field | Unsigned |
Back to Top
See Also
TInt Class
NFX.RelationalModel.DataTypes Namespace


TInt.Size Field

TInt Size Field NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Size
public readonly int Size
Public ReadOnly Size As Integer
Public ReadOnly Size As Integer
public:
initonly int Size
public:
initonly int Size
val Size: int
val Size: int

Field Value

Type: Online Int32
See Also
TInt Class
TInt Members
NFX.RelationalModel.DataTypes Namespace


TInt.Unsigned Field

TInt Unsigned Field NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool Unsigned
public readonly bool Unsigned
Public ReadOnly Unsigned As Boolean
Public ReadOnly Unsigned As Boolean
public:
initonly bool Unsigned
public:
initonly bool Unsigned
val Unsigned: bool
val Unsigned: bool

Field Value

Type: Online Boolean
See Also
TInt Class
TInt Members
NFX.RelationalModel.DataTypes Namespace


TInt Methods

TInt Methods NFX Class Library

The TInt type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TInt Class
NFX.RelationalModel.DataTypes Namespace


TInt.GetTypeName Method

TInt GetTypeName Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetTypeName(
    RDBMSCompiler compiler
)
public override string GetTypeName(
    RDBMSCompiler compiler
)
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online String
See Also
TInt Class
TInt Members
NFX.RelationalModel.DataTypes Namespace


TInt Properties

TInt Properties NFX Class Library

The TInt type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TInt Class
NFX.RelationalModel.DataTypes Namespace


TMonetaryAmount Class

TMonetaryAmount Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes TMonetaryAmount

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TMonetaryAmount : RDBMSDomain
public class TMonetaryAmount : RDBMSDomain
Public Class TMonetaryAmount
    Inherits RDBMSDomain
Public Class TMonetaryAmount
    Inherits RDBMSDomain
public ref class TMonetaryAmount : public RDBMSDomain
public ref class TMonetaryAmount : public RDBMSDomain
type TMonetaryAmount =
    class
        inherit RDBMSDomain
    end
type TMonetaryAmount =
    class
        inherit RDBMSDomain
    end
See Also
TMonetaryAmount Members
NFX.RelationalModel.DataTypes Namespace


TMonetaryAmount Members

TMonetaryAmount Members NFX Class Library

The TMonetaryAmount type exposes the following members.
Constructors
 | Name | Description
Public method | TMonetaryAmount | Initializes a new instance of the TMonetaryAmount class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TMonetaryAmount Class
NFX.RelationalModel.DataTypes Namespace


TMonetaryAmount Constructor

TMonetaryAmount Constructor NFX Class Library

Initializes a new instance of the TMonetaryAmount class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TMonetaryAmount()
public TMonetaryAmount()
Public Sub New
Public Sub New
public:
TMonetaryAmount()
public:
TMonetaryAmount()
new : unit -> TMonetaryAmount
new : unit -> TMonetaryAmount
See Also
TMonetaryAmount Class
TMonetaryAmount Members
NFX.RelationalModel.DataTypes Namespace


TMonetaryAmount Methods

TMonetaryAmount Methods NFX Class Library

The TMonetaryAmount type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TMonetaryAmount Class
NFX.RelationalModel.DataTypes Namespace


TMonetaryAmount.GetTypeName Method

TMonetaryAmount GetTypeName Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetTypeName(
    RDBMSCompiler compiler
)
public override string GetTypeName(
    RDBMSCompiler compiler
)
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online String
See Also
TMonetaryAmount Class
TMonetaryAmount Members
NFX.RelationalModel.DataTypes Namespace


TMonetaryAmount Properties

TMonetaryAmount Properties NFX Class Library

The TMonetaryAmount type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TMonetaryAmount Class
NFX.RelationalModel.DataTypes Namespace


TNote Class

TNote Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes TNote

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TNote : RDBMSDomain
public class TNote : RDBMSDomain
Public Class TNote
    Inherits RDBMSDomain
Public Class TNote
    Inherits RDBMSDomain
public ref class TNote : public RDBMSDomain
public ref class TNote : public RDBMSDomain
type TNote =
    class
        inherit RDBMSDomain
    end
type TNote =
    class
        inherit RDBMSDomain
    end
See Also
TNote Members
NFX.RelationalModel.DataTypes Namespace


TNote Members

TNote Members NFX Class Library

The TNote type exposes the following members.
Constructors
 | Name | Description
Public method | TNote | Initializes a new instance of the TNote class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TNote Class
NFX.RelationalModel.DataTypes Namespace


TNote Constructor

TNote Constructor NFX Class Library

Initializes a new instance of the TNote class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TNote()
public TNote()
Public Sub New
Public Sub New
public:
TNote()
public:
TNote()
new : unit -> TNote
new : unit -> TNote
See Also
TNote Class
TNote Members
NFX.RelationalModel.DataTypes Namespace


TNote Methods

TNote Methods NFX Class Library

The TNote type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TNote Class
NFX.RelationalModel.DataTypes Namespace


TNote.GetTypeName Method

TNote GetTypeName Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetTypeName(
    RDBMSCompiler compiler
)
public override string GetTypeName(
    RDBMSCompiler compiler
)
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online String
See Also
TNote Class
TNote Members
NFX.RelationalModel.DataTypes Namespace


TNote Properties

TNote Properties NFX Class Library

The TNote type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TNote Class
NFX.RelationalModel.DataTypes Namespace


TPercent Class

TPercent Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes UncategorizedValue
NFX.RelationalModel.DataTypes UncategorizedNumericValue
NFX.RelationalModel.DataTypes TPercent

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class TPercent : UncategorizedNumericValue
public sealed class TPercent : UncategorizedNumericValue
Public NotInheritable Class TPercent
    Inherits UncategorizedNumericValue
Public NotInheritable Class TPercent
    Inherits UncategorizedNumericValue
public ref class TPercent sealed : public UncategorizedNumericValue
public ref class TPercent sealed : public UncategorizedNumericValue
[<SealedAttribute>]
type TPercent =
    class
        inherit UncategorizedNumericValue
    end
[<SealedAttribute>]
type TPercent =
    class
        inherit UncategorizedNumericValue
    end
See Also
TPercent Members
NFX.RelationalModel.DataTypes Namespace


TPercent Members

TPercent Members NFX Class Library

The TPercent type exposes the following members.
Constructors
 | Name | Description
Public method | TPercent | Initializes a new instance of the TPercent class
Public method | TPercent(Int32) | Initializes a new instance of the TPercent class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Scale |
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TPercent Class
NFX.RelationalModel.DataTypes Namespace


TPercent Constructor

TPercent Constructor NFX Class Library

Overload List
 | Name | Description
Public method | TPercent | Initializes a new instance of the TPercent class
Public method | TPercent(Int32) | Initializes a new instance of the TPercent class
Back to Top
See Also
TPercent Class
TPercent Members
NFX.RelationalModel.DataTypes Namespace


TPercent Constructor

TPercent Constructor NFX Class Library

Initializes a new instance of the TPercent class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TPercent()
public TPercent()
Public Sub New
Public Sub New
public:
TPercent()
public:
TPercent()
new : unit -> TPercent
new : unit -> TPercent
See Also
TPercent Class
TPercent Members
TPercent Overload
NFX.RelationalModel.DataTypes Namespace


TPercent Constructor (Int32)

TPercent Constructor (Int32) NFX Class Library

Initializes a new instance of the TPercent class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TPercent(
    int scale
)
public TPercent(
    int scale
)
Public Sub New (
    scale As Integer
)
Public Sub New (
    scale As Integer
)
public:
TPercent(
    int scale
)
public:
TPercent(
    int scale
)
new :
        scale : int -> TPercent
new :
        scale : int -> TPercent

Parameters

scale
Type: Online System Int32
See Also
TPercent Class
TPercent Members
TPercent Overload
NFX.RelationalModel.DataTypes Namespace


TPercent Fields

TPercent Fields NFX Class Library

The TPercent type exposes the following members.
Fields
 | Name | Description
Public field | Scale |
Back to Top
See Also
TPercent Class
NFX.RelationalModel.DataTypes Namespace


TPercent.Scale Field

TPercent Scale Field NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Scale
public readonly int Scale
Public ReadOnly Scale As Integer
Public ReadOnly Scale As Integer
public:
initonly int Scale
public:
initonly int Scale
val Scale: int
val Scale: int

Field Value

Type: Online Int32
See Also
TPercent Class
TPercent Members
NFX.RelationalModel.DataTypes Namespace


TPercent Methods

TPercent Methods NFX Class Library

The TPercent type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TPercent Class
NFX.RelationalModel.DataTypes Namespace


TPercent.GetTypeName Method

TPercent GetTypeName Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetTypeName(
    RDBMSCompiler compiler
)
public override string GetTypeName(
    RDBMSCompiler compiler
)
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online String
See Also
TPercent Class
TPercent Members
NFX.RelationalModel.DataTypes Namespace


TPercent Properties

TPercent Properties NFX Class Library

The TPercent type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TPercent Class
NFX.RelationalModel.DataTypes Namespace


TPhone Class

TPhone Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes TPhone

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TPhone : RDBMSDomain
public class TPhone : RDBMSDomain
Public Class TPhone
    Inherits RDBMSDomain
Public Class TPhone
    Inherits RDBMSDomain
public ref class TPhone : public RDBMSDomain
public ref class TPhone : public RDBMSDomain
type TPhone =
    class
        inherit RDBMSDomain
    end
type TPhone =
    class
        inherit RDBMSDomain
    end
See Also
TPhone Members
NFX.RelationalModel.DataTypes Namespace


TPhone Members

TPhone Members NFX Class Library

The TPhone type exposes the following members.
Constructors
 | Name | Description
Public method | TPhone | Initializes a new instance of the TPhone class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TPhone Class
NFX.RelationalModel.DataTypes Namespace


TPhone Constructor

TPhone Constructor NFX Class Library

Initializes a new instance of the TPhone class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TPhone()
public TPhone()
Public Sub New
Public Sub New
public:
TPhone()
public:
TPhone()
new : unit -> TPhone
new : unit -> TPhone
See Also
TPhone Class
TPhone Members
NFX.RelationalModel.DataTypes Namespace


TPhone Methods

TPhone Methods NFX Class Library

The TPhone type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TPhone Class
NFX.RelationalModel.DataTypes Namespace


TPhone.GetTypeName Method

TPhone GetTypeName Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetTypeName(
    RDBMSCompiler compiler
)
public override string GetTypeName(
    RDBMSCompiler compiler
)
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online String
See Also
TPhone Class
TPhone Members
NFX.RelationalModel.DataTypes Namespace


TPhone Properties

TPhone Properties NFX Class Library

The TPhone type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TPhone Class
NFX.RelationalModel.DataTypes Namespace


TScreenName Class

TScreenName Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes TScreenName

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TScreenName : RDBMSDomain
public class TScreenName : RDBMSDomain
Public Class TScreenName
    Inherits RDBMSDomain
Public Class TScreenName
    Inherits RDBMSDomain
public ref class TScreenName : public RDBMSDomain
public ref class TScreenName : public RDBMSDomain
type TScreenName =
    class
        inherit RDBMSDomain
    end
type TScreenName =
    class
        inherit RDBMSDomain
    end
See Also
TScreenName Members
NFX.RelationalModel.DataTypes Namespace


TScreenName Members

TScreenName Members NFX Class Library

The TScreenName type exposes the following members.
Constructors
 | Name | Description
Public method | TScreenName | Initializes a new instance of the TScreenName class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TScreenName Class
NFX.RelationalModel.DataTypes Namespace


TScreenName Constructor

TScreenName Constructor NFX Class Library

Initializes a new instance of the TScreenName class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TScreenName()
public TScreenName()
Public Sub New
Public Sub New
public:
TScreenName()
public:
TScreenName()
new : unit -> TScreenName
new : unit -> TScreenName
See Also
TScreenName Class
TScreenName Members
NFX.RelationalModel.DataTypes Namespace


TScreenName Methods

TScreenName Methods NFX Class Library

The TScreenName type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TScreenName Class
NFX.RelationalModel.DataTypes Namespace


TScreenName.GetTypeName Method

TScreenName GetTypeName Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetTypeName(
    RDBMSCompiler compiler
)
public override string GetTypeName(
    RDBMSCompiler compiler
)
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online String
See Also
TScreenName Class
TScreenName Members
NFX.RelationalModel.DataTypes Namespace


TScreenName Properties

TScreenName Properties NFX Class Library

The TScreenName type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TScreenName Class
NFX.RelationalModel.DataTypes Namespace


TScript Class

TScript Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes TScript

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TScript : RDBMSDomain
public class TScript : RDBMSDomain
Public Class TScript
    Inherits RDBMSDomain
Public Class TScript
    Inherits RDBMSDomain
public ref class TScript : public RDBMSDomain
public ref class TScript : public RDBMSDomain
type TScript =
    class
        inherit RDBMSDomain
    end
type TScript =
    class
        inherit RDBMSDomain
    end
See Also
TScript Members
NFX.RelationalModel.DataTypes Namespace


TScript Members

TScript Members NFX Class Library

The TScript type exposes the following members.
Constructors
 | Name | Description
Public method | TScript | Initializes a new instance of the TScript class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TScript Class
NFX.RelationalModel.DataTypes Namespace


TScript Constructor

TScript Constructor NFX Class Library

Initializes a new instance of the TScript class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TScript()
public TScript()
Public Sub New
Public Sub New
public:
TScript()
public:
TScript()
new : unit -> TScript
new : unit -> TScript
See Also
TScript Class
TScript Members
NFX.RelationalModel.DataTypes Namespace


TScript Methods

TScript Methods NFX Class Library

The TScript type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TScript Class
NFX.RelationalModel.DataTypes Namespace


TScript.GetTypeName Method

TScript GetTypeName Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetTypeName(
    RDBMSCompiler compiler
)
public override string GetTypeName(
    RDBMSCompiler compiler
)
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online String
See Also
TScript Class
TScript Members
NFX.RelationalModel.DataTypes Namespace


TScript Properties

TScript Properties NFX Class Library

The TScript type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TScript Class
NFX.RelationalModel.DataTypes Namespace


TSex Class

TSex Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes TSex

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TSex : RDBMSDomain
public class TSex : RDBMSDomain
Public Class TSex
    Inherits RDBMSDomain
Public Class TSex
    Inherits RDBMSDomain
public ref class TSex : public RDBMSDomain
public ref class TSex : public RDBMSDomain
type TSex =
    class
        inherit RDBMSDomain
    end
type TSex =
    class
        inherit RDBMSDomain
    end
See Also
TSex Members
NFX.RelationalModel.DataTypes Namespace


TSex Members

TSex Members NFX Class Library

The TSex type exposes the following members.
Constructors
 | Name | Description
Public method | TSex | Initializes a new instance of the TSex class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TSex Class
NFX.RelationalModel.DataTypes Namespace


TSex Constructor

TSex Constructor NFX Class Library

Initializes a new instance of the TSex class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TSex()
public TSex()
Public Sub New
Public Sub New
public:
TSex()
public:
TSex()
new : unit -> TSex
new : unit -> TSex
See Also
TSex Class
TSex Members
NFX.RelationalModel.DataTypes Namespace


TSex Methods

TSex Methods NFX Class Library

The TSex type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TSex Class
NFX.RelationalModel.DataTypes Namespace


TSex.GetTypeName Method

TSex GetTypeName Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetTypeName(
    RDBMSCompiler compiler
)
public override string GetTypeName(
    RDBMSCompiler compiler
)
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online String
See Also
TSex Class
TSex Members
NFX.RelationalModel.DataTypes Namespace


TSex Properties

TSex Properties NFX Class Library

The TSex type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TSex Class
NFX.RelationalModel.DataTypes Namespace


TVarchar Class

TVarchar Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes UncategorizedValue
NFX.RelationalModel.DataTypes UncategorizedTextualValue
NFX.RelationalModel.DataTypes TVarchar

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class TVarchar : UncategorizedTextualValue
public sealed class TVarchar : UncategorizedTextualValue
Public NotInheritable Class TVarchar
    Inherits UncategorizedTextualValue
Public NotInheritable Class TVarchar
    Inherits UncategorizedTextualValue
public ref class TVarchar sealed : public UncategorizedTextualValue
public ref class TVarchar sealed : public UncategorizedTextualValue
[<SealedAttribute>]
type TVarchar =
    class
        inherit UncategorizedTextualValue
    end
[<SealedAttribute>]
type TVarchar =
    class
        inherit UncategorizedTextualValue
    end
See Also
TVarchar Members
NFX.RelationalModel.DataTypes Namespace


TVarchar Members

TVarchar Members NFX Class Library

The TVarchar type exposes the following members.
Constructors
 | Name | Description
Public method | TVarchar | Initializes a new instance of the TVarchar class
Public method | TVarchar(Int32) | Initializes a new instance of the TVarchar class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Size |
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TVarchar Class
NFX.RelationalModel.DataTypes Namespace


TVarchar Constructor

TVarchar Constructor NFX Class Library

Overload List
 | Name | Description
Public method | TVarchar | Initializes a new instance of the TVarchar class
Public method | TVarchar(Int32) | Initializes a new instance of the TVarchar class
Back to Top
See Also
TVarchar Class
TVarchar Members
NFX.RelationalModel.DataTypes Namespace


TVarchar Constructor

TVarchar Constructor NFX Class Library

Initializes a new instance of the TVarchar class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TVarchar()
public TVarchar()
Public Sub New
Public Sub New
public:
TVarchar()
public:
TVarchar()
new : unit -> TVarchar
new : unit -> TVarchar
See Also
TVarchar Class
TVarchar Members
TVarchar Overload
NFX.RelationalModel.DataTypes Namespace


TVarchar Constructor (Int32)

TVarchar Constructor (Int32) NFX Class Library

Initializes a new instance of the TVarchar class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TVarchar(
    int size
)
public TVarchar(
    int size
)
Public Sub New (
    size As Integer
)
Public Sub New (
    size As Integer
)
public:
TVarchar(
    int size
)
public:
TVarchar(
    int size
)
new :
        size : int -> TVarchar
new :
        size : int -> TVarchar

Parameters

size
Type: Online System Int32
See Also
TVarchar Class
TVarchar Members
TVarchar Overload
NFX.RelationalModel.DataTypes Namespace


TVarchar Fields

TVarchar Fields NFX Class Library

The TVarchar type exposes the following members.
Fields
 | Name | Description
Public field | Size |
Back to Top
See Also
TVarchar Class
NFX.RelationalModel.DataTypes Namespace


TVarchar.Size Field

TVarchar Size Field NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Size
public readonly int Size
Public ReadOnly Size As Integer
Public ReadOnly Size As Integer
public:
initonly int Size
public:
initonly int Size
val Size: int
val Size: int

Field Value

Type: Online Int32
See Also
TVarchar Class
TVarchar Members
NFX.RelationalModel.DataTypes Namespace


TVarchar Methods

TVarchar Methods NFX Class Library

The TVarchar type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | (Overrides RDBMSDomain GetTypeName(RDBMSCompiler).)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TVarchar Class
NFX.RelationalModel.DataTypes Namespace


TVarchar.GetTypeName Method

TVarchar GetTypeName Method NFX Class Library

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string GetTypeName(
    RDBMSCompiler compiler
)
public override string GetTypeName(
    RDBMSCompiler compiler
)
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
Public Overrides Function GetTypeName (
    compiler As RDBMSCompiler
) As String
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
public:
virtual String^ GetTypeName(
    RDBMSCompiler^ compiler
) override
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string
abstract GetTypeName :
        compiler : RDBMSCompiler -> string
override GetTypeName :
        compiler : RDBMSCompiler -> string

Parameters

compiler
Type: NFX.RelationalModel RDBMSCompiler

Return Value

Type: Online String
See Also
TVarchar Class
TVarchar Members
NFX.RelationalModel.DataTypes Namespace


TVarchar Properties

TVarchar Properties NFX Class Library

The TVarchar type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
TVarchar Class
NFX.RelationalModel.DataTypes Namespace


UncategorizedNumericValue Class

UncategorizedNumericValue Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes UncategorizedValue
NFX.RelationalModel.DataTypes UncategorizedNumericValue
NFX.RelationalModel.DataTypes TDouble
NFX.RelationalModel.DataTypes TInt
NFX.RelationalModel.DataTypes TPercent

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class UncategorizedNumericValue : UncategorizedValue
public abstract class UncategorizedNumericValue : UncategorizedValue
Public MustInherit Class UncategorizedNumericValue
    Inherits UncategorizedValue
Public MustInherit Class UncategorizedNumericValue
    Inherits UncategorizedValue
public ref class UncategorizedNumericValue abstract : public UncategorizedValue
public ref class UncategorizedNumericValue abstract : public UncategorizedValue
[<AbstractClassAttribute>]
type UncategorizedNumericValue =
    class
        inherit UncategorizedValue
    end
[<AbstractClassAttribute>]
type UncategorizedNumericValue =
    class
        inherit UncategorizedValue
    end
See Also
UncategorizedNumericValue Members
NFX.RelationalModel.DataTypes Namespace


UncategorizedNumericValue Members

UncategorizedNumericValue Members NFX Class Library

The UncategorizedNumericValue type exposes the following members.
Constructors
 | Name | Description
Protected method | UncategorizedNumericValue | Initializes a new instance of the UncategorizedNumericValue class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | Returns the name of the resulting type that this domain maps to (Inherited from RDBMSDomain.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
UncategorizedNumericValue Class
NFX.RelationalModel.DataTypes Namespace


UncategorizedNumericValue Constructor

UncategorizedNumericValue Constructor NFX Class Library

Initializes a new instance of the UncategorizedNumericValue class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected UncategorizedNumericValue()
protected UncategorizedNumericValue()
Protected Sub New
Protected Sub New
protected:
UncategorizedNumericValue()
protected:
UncategorizedNumericValue()
new : unit -> UncategorizedNumericValue
new : unit -> UncategorizedNumericValue
See Also
UncategorizedNumericValue Class
UncategorizedNumericValue Members
NFX.RelationalModel.DataTypes Namespace


UncategorizedNumericValue Methods

UncategorizedNumericValue Methods NFX Class Library

The UncategorizedNumericValue type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | Returns the name of the resulting type that this domain maps to (Inherited from RDBMSDomain.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
UncategorizedNumericValue Class
NFX.RelationalModel.DataTypes Namespace


UncategorizedNumericValue Properties

UncategorizedNumericValue Properties NFX Class Library

The UncategorizedNumericValue type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
UncategorizedNumericValue Class
NFX.RelationalModel.DataTypes Namespace


UncategorizedTextualValue Class

UncategorizedTextualValue Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes UncategorizedValue
NFX.RelationalModel.DataTypes UncategorizedTextualValue
NFX.RelationalModel.DataTypes TChar
NFX.RelationalModel.DataTypes TEnum
NFX.RelationalModel.DataTypes TVarchar

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class UncategorizedTextualValue : UncategorizedValue
public abstract class UncategorizedTextualValue : UncategorizedValue
Public MustInherit Class UncategorizedTextualValue
    Inherits UncategorizedValue
Public MustInherit Class UncategorizedTextualValue
    Inherits UncategorizedValue
public ref class UncategorizedTextualValue abstract : public UncategorizedValue
public ref class UncategorizedTextualValue abstract : public UncategorizedValue
[<AbstractClassAttribute>]
type UncategorizedTextualValue =
    class
        inherit UncategorizedValue
    end
[<AbstractClassAttribute>]
type UncategorizedTextualValue =
    class
        inherit UncategorizedValue
    end
See Also
UncategorizedTextualValue Members
NFX.RelationalModel.DataTypes Namespace


UncategorizedTextualValue Members

UncategorizedTextualValue Members NFX Class Library

The UncategorizedTextualValue type exposes the following members.
Constructors
 | Name | Description
Protected method | UncategorizedTextualValue | Initializes a new instance of the UncategorizedTextualValue class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | Returns the name of the resulting type that this domain maps to (Inherited from RDBMSDomain.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
UncategorizedTextualValue Class
NFX.RelationalModel.DataTypes Namespace


UncategorizedTextualValue Constructor

UncategorizedTextualValue Constructor NFX Class Library

Initializes a new instance of the UncategorizedTextualValue class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected UncategorizedTextualValue()
protected UncategorizedTextualValue()
Protected Sub New
Protected Sub New
protected:
UncategorizedTextualValue()
protected:
UncategorizedTextualValue()
new : unit -> UncategorizedTextualValue
new : unit -> UncategorizedTextualValue
See Also
UncategorizedTextualValue Class
UncategorizedTextualValue Members
NFX.RelationalModel.DataTypes Namespace


UncategorizedTextualValue Methods

UncategorizedTextualValue Methods NFX Class Library

The UncategorizedTextualValue type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | Returns the name of the resulting type that this domain maps to (Inherited from RDBMSDomain.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
UncategorizedTextualValue Class
NFX.RelationalModel.DataTypes Namespace


UncategorizedTextualValue Properties

UncategorizedTextualValue Properties NFX Class Library

The UncategorizedTextualValue type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
UncategorizedTextualValue Class
NFX.RelationalModel.DataTypes Namespace


UncategorizedValue Class

UncategorizedValue Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.RelationalModel.DataTypes Domain
NFX.RelationalModel.DataTypes RDBMSDomain
NFX.RelationalModel.DataTypes UncategorizedValue
NFX.RelationalModel.DataTypes UncategorizedNumericValue
NFX.RelationalModel.DataTypes UncategorizedTextualValue

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class UncategorizedValue : RDBMSDomain
public abstract class UncategorizedValue : RDBMSDomain
Public MustInherit Class UncategorizedValue
    Inherits RDBMSDomain
Public MustInherit Class UncategorizedValue
    Inherits RDBMSDomain
public ref class UncategorizedValue abstract : public RDBMSDomain
public ref class UncategorizedValue abstract : public RDBMSDomain
[<AbstractClassAttribute>]
type UncategorizedValue =
    class
        inherit RDBMSDomain
    end
[<AbstractClassAttribute>]
type UncategorizedValue =
    class
        inherit RDBMSDomain
    end
See Also
UncategorizedValue Members
NFX.RelationalModel.DataTypes Namespace


UncategorizedValue Members

UncategorizedValue Members NFX Class Library

The UncategorizedValue type exposes the following members.
Constructors
 | Name | Description
Protected method | UncategorizedValue | Initializes a new instance of the UncategorizedValue class
Back to Top
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | Returns the name of the resulting type that this domain maps to (Inherited from RDBMSDomain.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
UncategorizedValue Class
NFX.RelationalModel.DataTypes Namespace


UncategorizedValue Constructor

UncategorizedValue Constructor NFX Class Library

Initializes a new instance of the UncategorizedValue class

Namespace: NFX.RelationalModel.DataTypes
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected UncategorizedValue()
protected UncategorizedValue()
Protected Sub New
Protected Sub New
protected:
UncategorizedValue()
protected:
UncategorizedValue()
new : unit -> UncategorizedValue
new : unit -> UncategorizedValue
See Also
UncategorizedValue Class
UncategorizedValue Members
NFX.RelationalModel.DataTypes Namespace


UncategorizedValue Methods

UncategorizedValue Methods NFX Class Library

The UncategorizedValue type exposes the following members.
Methods
 | Name | Description
Public method | Configure | (Inherited from Domain.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetColumnAutoGeneratedScript | Returns script for auto-generated values, may also emit compiler-specific object like sequence or generator (Inherited from RDBMSDomain.)
Public method | GetColumnCheckScript | Returns script for check constraint on column level (Inherited from RDBMSDomain.)
Public method | GetColumnDefaultScript | Returns script for default values, may also emit compiler-specific object like sequence or generator or insert rows in some other table (Inherited from RDBMSDomain.)
Public method | GetColumnRequirement | Returns true to indicate that column of this type is always required (Inherited from RDBMSDomain.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeName | Returns the name of the resulting type that this domain maps to (Inherited from RDBMSDomain.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | TransformColumnName | Changes column name, i.e. adds prefix (Inherited from RDBMSDomain.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
UncategorizedValue Class
NFX.RelationalModel.DataTypes Namespace


UncategorizedValue Properties

UncategorizedValue Properties NFX Class Library

The UncategorizedValue type exposes the following members.
Properties
 | Name | Description
Public property | Name | Returns the name of this domain, i.e. 'THumanAge', 'TSalary' (Inherited from Domain.)
Back to Top
See Also
UncategorizedValue Class
NFX.RelationalModel.DataTypes Namespace


NFX.Security Namespace

NFX.Security Namespace NFX Class Library

Defines fundamental security types like users and permissions
Classes
 | Class | Description
Public class | AccessLevel | A level of access granted to user for certain permission, i.e. if (level.Denied).....
Public class | AdHocPermission | Represents a permission check instance which is a-typical and is based on string arguments
Public class | AuthorizationException | Base exception thrown by the security framework
Public class | BlankCredentials | Represents credentials that are absent. This is a singleton class
Public class | ConfigSecurityManager | Provides security manager implementation that authenticates and authorizes users from configuration
Public class | Credentials | User credentials base class. A credentials may be as simple as user+password, access card codes, door key, Twitter account token etc...
Public class | DefaultPasswordManager | Provides default implementation for password managment functionality based on injectable algorithms and default password strength calculation
Public class | GDIDCredentials | Represents credentials based on Global Distributed ID
Public class | HashedPassword | Represents abstraction of a hashed password, the concreate password algorithm provide implementation (i.e. bytebuffer, dictionary, string)
Public class | IDPasswordCredentials | Represents simple ID/password textual credentials. Note: The password is stored as plain text
Public class | MD5PasswordHashingAlgorithm |
Public class | NOPSecurityManager | Provides security manager implementation that does nothing and always returns fake user instance
Public class | PasswordHashingAlgorithm | Represents an abstraction of password algorithm that performs hashing and verification of passwords supplied as SecureBuffer
Public class | PasswordHashingAlgorithm TOptions |
Public class | PasswordRepresentation | Provides password representation content, i.e. an image with drawn password which is understandable by humans
Public class | Permission | Represents a general permission abstraction - where permission type represents the path/name of the permission in User's rights and .ctor takes specific parameters to check while authorizing user. Permission-derived class represents a certain permission type, whereas its instance is a check for particular desired level. To authorize certain actions, one creates an instance of Permission-derived class passing in its .ctor required access levels, then calls a Check() method that returns true if action is authorized. This scheme provides a great deal of flexibility, i.e. for very complex security cases developers may inherit leaf-level permissions from intermediate ones that have logic tied to session-level variables, this way user's access may vary by permission/session state, i.e. a user may have "Patient.Master" level 4 access in database "A", while having acess denied to the same named permission in database "B". User's database, or system instance is a flag in user-session context
Public class | Rights | User rights contains data about access levels to permissions in the system. Use Configuration internally to keep the data organized in hierarchical navigable structure. Configuration also allows to cross-link permission levels using vars and make acess level dependent on settings on a particular machine using environmental vars
Public class | SecureBuffer |
Public class | SecurityException | Base exception thrown by the Security framework
Public class | SocialNetTokenCredentials | Represents credentials supplied from/to Social Net site (i.e. Facebook, Twitter etc.)
Public class | TypedPermission | A general ancestor for all typed permissions - the ones declared in code
Public class | User | Provides base user functionality. Particular security manager implementations may return users derived from this class
Structures
 | Structure | Description
Public structure | AuthenticationToken | Represents security provider-internal ID that SecurityManager assigns into User object on authentication. These tokens can be used in place of Credentials to re-authenticate users or to requery user rights. External parties should never be supplied with this struct as it is backend-internal
Public structure | MD5PasswordHashingOptions |
Interfaces
 | Interface | Description
Public interface | IPasswordHashingOptions |
Public interface | IPasswordManager | Denoutes an entity that manages passwords such as: computes and verified hash tokens and provides password strength verification
Public interface | IPasswordManagerImplementation |
Public interface | ISecurityException | Marker interface for security exceptions
Public interface | ISecurityManager | Represents an entity that performs user authentication based on passed credentials and other security-related global tasks
Public interface | ISecurityManagerImplementation | Represents an implementation of an entity that performs user authentication based on passed credentials and other security-related global tasks
Public interface | IStringRepresentableCredentials | Denotes credentials that can be represented as a string that can be used for example in Authorization header
Delegates
 | Delegate | Description
Public delegate | GetSessionFunc | Invoked by permission checker to get session
Enumerations
 | Enumeration | Description
Public enumeration | PasswordFamily | Denoutes kinds of passwords i.e.: text that user types on login, short PIN, geometrical curve that users need to trace with their finger, select areas of picture
Public enumeration | PasswordRepresentationType | Flags denote types of password representation: Text/Image/Audio
Public enumeration | PasswordStrengthLevel |
Public enumeration | UserStatus | User status enumeration - super-permission levels


AccessLevel Class

AccessLevel Class NFX Class Library

A level of access granted to user for certain permission, i.e. if (level.Denied).....
Inheritance Hierarchy
Online System Object
NFX.Security AccessLevel

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class AccessLevel
public sealed class AccessLevel
Public NotInheritable Class AccessLevel
Public NotInheritable Class AccessLevel
public ref class AccessLevel sealed
public ref class AccessLevel sealed
[<SealedAttribute>]
type AccessLevel =  class end
[<SealedAttribute>]
type AccessLevel =  class end
See Also
AccessLevel Members
NFX.Security Namespace


AccessLevel Members

AccessLevel Members NFX Class Library

The AccessLevel type exposes the following members.
Constructors
 | Name | Description
Public method | AccessLevel | Initializes a new instance of the AccessLevel class
Back to Top
Methods
 | Name | Description
 | DeniedFor |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_LEVEL_ATTR |
DENIED |
DENIED_CONF |
VIEW |
VIEW_CHANGE |
VIEW_CHANGE_DELETE |
Back to Top
Properties
 | Name | Description
Public property | Data | Returns security data for this level
Public property | Denied | Indicates whether access is denied
Public property | Level | Returns security level attribute from Data
Public property | Permission | Returns permission that this access level is for
Public property | User | Returns user that this access level is for
Back to Top
See Also
AccessLevel Class
NFX.Security Namespace


AccessLevel Constructor

AccessLevel Constructor NFX Class Library

Initializes a new instance of the AccessLevel class

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccessLevel(
    User user,
    Permission permission,
    IConfigSectionNode data
)
public AccessLevel(
    User user,
    Permission permission,
    IConfigSectionNode data
)
Public Sub New (
    user As User,
    permission As Permission,
    data As IConfigSectionNode
)
Public Sub New (
    user As User,
    permission As Permission,
    data As IConfigSectionNode
)
public:
AccessLevel(
    User^ user,
    Permission^ permission,
    IConfigSectionNode^ data
)
public:
AccessLevel(
    User^ user,
    Permission^ permission,
    IConfigSectionNode^ data
)
new :
        user : User *
        permission : Permission *
        data : IConfigSectionNode -> AccessLevel
new :
        user : User *
        permission : Permission *
        data : IConfigSectionNode -> AccessLevel

Parameters

user
Type: NFX.Security User
permission
Type: NFX.Security Permission
data
Type: NFX.Environment IConfigSectionNode
See Also
AccessLevel Class
AccessLevel Members
NFX.Security Namespace


AccessLevel Fields

AccessLevel Fields NFX Class Library

The AccessLevel type exposes the following members.
Fields
Name | Description
CONFIG_LEVEL_ATTR |
DENIED |
DENIED_CONF |
VIEW |
VIEW_CHANGE |
VIEW_CHANGE_DELETE |
Back to Top
See Also
AccessLevel Class
NFX.Security Namespace


AccessLevel.CONFIG_LEVEL_ATTR Field

AccessLevel CONFIG_LEVEL_ATTR Field NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_LEVEL_ATTR
public const string CONFIG_LEVEL_ATTR
Public Const CONFIG_LEVEL_ATTR As String
Public Const CONFIG_LEVEL_ATTR As String
public:
literal String^ CONFIG_LEVEL_ATTR
public:
literal String^ CONFIG_LEVEL_ATTR
static val mutable CONFIG_LEVEL_ATTR: string
static val mutable CONFIG_LEVEL_ATTR: string

Field Value

Type: Online String
See Also
AccessLevel Class
AccessLevel Members
NFX.Security Namespace


AccessLevel.DENIED Field

AccessLevel DENIED Field NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DENIED
public const int DENIED
Public Const DENIED As Integer
Public Const DENIED As Integer
public:
literal int DENIED
public:
literal int DENIED
static val mutable DENIED: int
static val mutable DENIED: int

Field Value

Type: Online Int32
See Also
AccessLevel Class
AccessLevel Members
NFX.Security Namespace


AccessLevel.DENIED_CONF Field

AccessLevel DENIED_CONF Field NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly IConfigSectionNode DENIED_CONF
public static readonly IConfigSectionNode DENIED_CONF
Public Shared ReadOnly DENIED_CONF As IConfigSectionNode
Public Shared ReadOnly DENIED_CONF As IConfigSectionNode
public:
static initonly IConfigSectionNode^ DENIED_CONF
public:
static initonly IConfigSectionNode^ DENIED_CONF
static val DENIED_CONF: IConfigSectionNode
static val DENIED_CONF: IConfigSectionNode

Field Value

Type: IConfigSectionNode
See Also
AccessLevel Class
AccessLevel Members
NFX.Security Namespace


AccessLevel.VIEW Field

AccessLevel VIEW Field NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int VIEW
public const int VIEW
Public Const VIEW As Integer
Public Const VIEW As Integer
public:
literal int VIEW
public:
literal int VIEW
static val mutable VIEW: int
static val mutable VIEW: int

Field Value

Type: Online Int32
See Also
AccessLevel Class
AccessLevel Members
NFX.Security Namespace


AccessLevel.VIEW_CHANGE Field

AccessLevel VIEW_CHANGE Field NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int VIEW_CHANGE
public const int VIEW_CHANGE
Public Const VIEW_CHANGE As Integer
Public Const VIEW_CHANGE As Integer
public:
literal int VIEW_CHANGE
public:
literal int VIEW_CHANGE
static val mutable VIEW_CHANGE: int
static val mutable VIEW_CHANGE: int

Field Value

Type: Online Int32
See Also
AccessLevel Class
AccessLevel Members
NFX.Security Namespace


AccessLevel.VIEW_CHANGE_DELETE Field

AccessLevel VIEW_CHANGE_DELETE Field NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int VIEW_CHANGE_DELETE
public const int VIEW_CHANGE_DELETE
Public Const VIEW_CHANGE_DELETE As Integer
Public Const VIEW_CHANGE_DELETE As Integer
public:
literal int VIEW_CHANGE_DELETE
public:
literal int VIEW_CHANGE_DELETE
static val mutable VIEW_CHANGE_DELETE: int
static val mutable VIEW_CHANGE_DELETE: int

Field Value

Type: Online Int32
See Also
AccessLevel Class
AccessLevel Members
NFX.Security Namespace


AccessLevel Methods

AccessLevel Methods NFX Class Library

The AccessLevel type exposes the following members.
Methods
 | Name | Description
 | DeniedFor |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
AccessLevel Class
NFX.Security Namespace


AccessLevel.DeniedFor Method

AccessLevel DeniedFor Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static AccessLevel DeniedFor(
    User user,
    Permission permission
)
public static AccessLevel DeniedFor(
    User user,
    Permission permission
)
Public Shared Function DeniedFor (
    user As User,
    permission As Permission
) As AccessLevel
Public Shared Function DeniedFor (
    user As User,
    permission As Permission
) As AccessLevel
public:
static AccessLevel^ DeniedFor(
    User^ user,
    Permission^ permission
)
public:
static AccessLevel^ DeniedFor(
    User^ user,
    Permission^ permission
)
static member DeniedFor :
        user : User *
        permission : Permission -> AccessLevel
static member DeniedFor :
        user : User *
        permission : Permission -> AccessLevel

Parameters

user
Type: NFX.Security User
permission
Type: NFX.Security Permission

Return Value

Type: AccessLevel
See Also
AccessLevel Class
AccessLevel Members
NFX.Security Namespace


AccessLevel Properties

AccessLevel Properties NFX Class Library

The AccessLevel type exposes the following members.
Properties
 | Name | Description
Public property | Data | Returns security data for this level
Public property | Denied | Indicates whether access is denied
Public property | Level | Returns security level attribute from Data
Public property | Permission | Returns permission that this access level is for
Public property | User | Returns user that this access level is for
Back to Top
See Also
AccessLevel Class
NFX.Security Namespace


AccessLevel.Data Property

AccessLevel Data Property NFX Class Library

Returns security data for this level

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IConfigSectionNode Data { get; }
public IConfigSectionNode Data { get; }
Public ReadOnly Property Data As IConfigSectionNode
    Get
Public ReadOnly Property Data As IConfigSectionNode
    Get
public:
property IConfigSectionNode^ Data {
    IConfigSectionNode^ get ();
}
public:
property IConfigSectionNode^ Data {
    IConfigSectionNode^ get ();
}
member Data : IConfigSectionNode with get
member Data : IConfigSectionNode with get

Property Value

Type: IConfigSectionNode
See Also
AccessLevel Class
AccessLevel Members
NFX.Security Namespace


AccessLevel.Denied Property

AccessLevel Denied Property NFX Class Library

Indicates whether access is denied

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Denied { get; }
public bool Denied { get; }
Public ReadOnly Property Denied As Boolean
    Get
Public ReadOnly Property Denied As Boolean
    Get
public:
property bool Denied {
    bool get ();
}
public:
property bool Denied {
    bool get ();
}
member Denied : bool with get
member Denied : bool with get

Property Value

Type: Online Boolean
See Also
AccessLevel Class
AccessLevel Members
NFX.Security Namespace


AccessLevel.Level Property

AccessLevel Level Property NFX Class Library

Returns security level attribute from Data

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Level { get; }
public int Level { get; }
Public ReadOnly Property Level As Integer
    Get
Public ReadOnly Property Level As Integer
    Get
public:
property int Level {
    int get ();
}
public:
property int Level {
    int get ();
}
member Level : int with get
member Level : int with get

Property Value

Type: Online Int32
See Also
AccessLevel Class
AccessLevel Members
NFX.Security Namespace


AccessLevel.Permission Property

AccessLevel Permission Property NFX Class Library

Returns permission that this access level is for

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Permission Permission { get; }
public Permission Permission { get; }
Public ReadOnly Property Permission As Permission
    Get
Public ReadOnly Property Permission As Permission
    Get
public:
property Permission^ Permission {
    Permission^ get ();
}
public:
property Permission^ Permission {
    Permission^ get ();
}
member Permission : Permission with get
member Permission : Permission with get

Property Value

Type: Permission
See Also
AccessLevel Class
AccessLevel Members
NFX.Security Namespace


AccessLevel.User Property

AccessLevel User Property NFX Class Library

Returns user that this access level is for

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public User User { get; }
public User User { get; }
Public ReadOnly Property User As User
    Get
Public ReadOnly Property User As User
    Get
public:
property User^ User {
    User^ get ();
}
public:
property User^ User {
    User^ get ();
}
member User : User with get
member User : User with get

Property Value

Type: User
See Also
AccessLevel Class
AccessLevel Members
NFX.Security Namespace


AdHocPermission Class

AdHocPermission Class NFX Class Library

Represents a permission check instance which is a-typical and is based on string arguments
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.Security Permission
NFX.Security AdHocPermission

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class AdHocPermission : Permission
public sealed class AdHocPermission : Permission
Public NotInheritable Class AdHocPermission
    Inherits Permission
Public NotInheritable Class AdHocPermission
    Inherits Permission
public ref class AdHocPermission sealed : public Permission
public ref class AdHocPermission sealed : public Permission
[<SealedAttribute>]
type AdHocPermission =
    class
        inherit Permission
    end
[<SealedAttribute>]
type AdHocPermission =
    class
        inherit Permission
    end
See Also
AdHocPermission Members
NFX.Security Namespace


AdHocPermission Members

AdHocPermission Members NFX Class Library

The AdHocPermission type exposes the following members.
Constructors
 | Name | Description
Public method | AdHocPermission | Initializes a new instance of the AdHocPermission class
Back to Top
Methods
 | Name | Description
Public method | Check(ISession) | Checks the permission for requested action as specified in particular permission .ctor. The check is performed in the scope of supplied session, or if no session was supplied then current execution context session is assumed (Inherited from Permission.)
Public method | Check(User) | Shortcut method that creates a temp/mock BaseSession object thus checking permission in mock BaseSession context (Inherited from Permission.)
Protected method | DoCheckAccessLevel | Override to perform access level checks per user's AccessLevel instance. True if accessLevel satisfies permission requirements. The default implementation checks the access.Level (Inherited from Permission.)
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from Permission.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Description | Returns the permission description - base implementation returns permission name (Inherited from Permission.)
Public property | FullPath | Returns full permission path - a concatenation of its path and name (Inherited from Permission.)
Public property | Level | Specifies the minimum access level for the permission check to pass (Inherited from Permission.)
Public property | Name | Returns the permission name - the last segment of the path (Overrides Permission Name.)
Public property | Path | Returns a top-rooted path to this permission (without name) (Overrides Permission Path.)
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
AdHocPermission Class
NFX.Security Namespace


AdHocPermission Constructor

AdHocPermission Constructor NFX Class Library

Initializes a new instance of the AdHocPermission class

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AdHocPermission(
    string path,
    string name,
    int level
)
public AdHocPermission(
    string path,
    string name,
    int level
)
Public Sub New (
    path As String,
    name As String,
    level As Integer
)
Public Sub New (
    path As String,
    name As String,
    level As Integer
)
public:
AdHocPermission(
    String^ path,
    String^ name,
    int level
)
public:
AdHocPermission(
    String^ path,
    String^ name,
    int level
)
new :
        path : string *
        name : string *
        level : int -> AdHocPermission
new :
        path : string *
        name : string *
        level : int -> AdHocPermission

Parameters

path
Type: Online System String
name
Type: Online System String
level
Type: Online System Int32
See Also
AdHocPermission Class
AdHocPermission Members
NFX.Security Namespace


AdHocPermission Methods

AdHocPermission Methods NFX Class Library

The AdHocPermission type exposes the following members.
Methods
 | Name | Description
Public method | Check(ISession) | Checks the permission for requested action as specified in particular permission .ctor. The check is performed in the scope of supplied session, or if no session was supplied then current execution context session is assumed (Inherited from Permission.)
Public method | Check(User) | Shortcut method that creates a temp/mock BaseSession object thus checking permission in mock BaseSession context (Inherited from Permission.)
Protected method | DoCheckAccessLevel | Override to perform access level checks per user's AccessLevel instance. True if accessLevel satisfies permission requirements. The default implementation checks the access.Level (Inherited from Permission.)
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from Permission.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
AdHocPermission Class
NFX.Security Namespace


AdHocPermission Properties

AdHocPermission Properties NFX Class Library

The AdHocPermission type exposes the following members.
Properties
 | Name | Description
Public property | Description | Returns the permission description - base implementation returns permission name (Inherited from Permission.)
Public property | FullPath | Returns full permission path - a concatenation of its path and name (Inherited from Permission.)
Public property | Level | Specifies the minimum access level for the permission check to pass (Inherited from Permission.)
Public property | Name | Returns the permission name - the last segment of the path (Overrides Permission Name.)
Public property | Path | Returns a top-rooted path to this permission (without name) (Overrides Permission Path.)
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
AdHocPermission Class
NFX.Security Namespace


AdHocPermission.Name Property

AdHocPermission Name Property NFX Class Library

Returns the permission name - the last segment of the path

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Name { get; }
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String
See Also
AdHocPermission Class
AdHocPermission Members
NFX.Security Namespace


AdHocPermission.Path Property

AdHocPermission Path Property NFX Class Library

Returns a top-rooted path to this permission (without name)

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Path { get; }
public override string Path { get; }
Public Overrides ReadOnly Property Path As String
    Get
Public Overrides ReadOnly Property Path As String
    Get
public:
virtual property String^ Path {
    String^ get () override;
}
public:
virtual property String^ Path {
    String^ get () override;
}
abstract Path : string with get
override Path : string with get
abstract Path : string with get
override Path : string with get

Property Value

Type: Online String
See Also
AdHocPermission Class
AdHocPermission Members
NFX.Security Namespace


AuthenticationToken Structure

AuthenticationToken Structure NFX Class Library

Represents security provider-internal ID that SecurityManager assigns into User object on authentication. These tokens can be used in place of Credentials to re-authenticate users or to requery user rights. External parties should never be supplied with this struct as it is backend-internal

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public struct AuthenticationToken
[SerializableAttribute]
public struct AuthenticationToken
<SerializableAttribute>
Public Structure AuthenticationToken
<SerializableAttribute>
Public Structure AuthenticationToken
[SerializableAttribute]
public value class AuthenticationToken
[SerializableAttribute]
public value class AuthenticationToken
[<SealedAttribute>]
[<SerializableAttribute>]
type AuthenticationToken =  struct end
[<SealedAttribute>]
[<SerializableAttribute>]
type AuthenticationToken =  struct end
See Also
AuthenticationToken Members
NFX.Security Namespace


AuthenticationToken Members

AuthenticationToken Members NFX Class Library

The AuthenticationToken type exposes the following members.
Constructors
 | Name | Description
Public method | AuthenticationToken | Initializes a new instance of the AuthenticationToken class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Data | Provides provider-specific key/id that uniquely identifies the user in the realm
Public property | Realm | Provides information about back-end security source (realm) that perfomed authentication, i.e. LDAP instance, Database name etc...
Back to Top
See Also
AuthenticationToken Structure
NFX.Security Namespace


AuthenticationToken Constructor

AuthenticationToken Constructor NFX Class Library

Initializes a new instance of the AuthenticationToken class

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AuthenticationToken(
    string realm,
    Object data
)
public AuthenticationToken(
    string realm,
    Object data
)
Public Sub New (
    realm As String,
    data As Object
)
Public Sub New (
    realm As String,
    data As Object
)
public:
AuthenticationToken(
    String^ realm,
    Object^ data
)
public:
AuthenticationToken(
    String^ realm,
    Object^ data
)
new :
        realm : string *
        data : Object -> AuthenticationToken
new :
        realm : string *
        data : Object -> AuthenticationToken

Parameters

realm
Type: Online System String
data
Type: Online System Object
See Also
AuthenticationToken Structure
AuthenticationToken Members
NFX.Security Namespace


AuthenticationToken Methods

AuthenticationToken Methods NFX Class Library

The AuthenticationToken type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
AuthenticationToken Structure
NFX.Security Namespace


AuthenticationToken.ToString Method

AuthenticationToken ToString Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
AuthenticationToken Structure
AuthenticationToken Members
NFX.Security Namespace


AuthenticationToken Properties

AuthenticationToken Properties NFX Class Library

The AuthenticationToken type exposes the following members.
Properties
 | Name | Description
Public property | Data | Provides provider-specific key/id that uniquely identifies the user in the realm
Public property | Realm | Provides information about back-end security source (realm) that perfomed authentication, i.e. LDAP instance, Database name etc...
Back to Top
See Also
AuthenticationToken Structure
NFX.Security Namespace


AuthenticationToken.Data Property

AuthenticationToken Data Property NFX Class Library

Provides provider-specific key/id that uniquely identifies the user in the realm

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Data { get; }
public Object Data { get; }
Public ReadOnly Property Data As Object
    Get
Public ReadOnly Property Data As Object
    Get
public:
property Object^ Data {
    Object^ get ();
}
public:
property Object^ Data {
    Object^ get ();
}
member Data : Object with get
member Data : Object with get

Property Value

Type: Online Object
See Also
AuthenticationToken Structure
AuthenticationToken Members
NFX.Security Namespace


AuthenticationToken.Realm Property

AuthenticationToken Realm Property NFX Class Library

Provides information about back-end security source (realm) that perfomed authentication, i.e. LDAP instance, Database name etc...

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Realm { get; }
public string Realm { get; }
Public ReadOnly Property Realm As String
    Get
Public ReadOnly Property Realm As String
    Get
public:
property String^ Realm {
    String^ get ();
}
public:
property String^ Realm {
    String^ get ();
}
member Realm : string with get
member Realm : string with get

Property Value

Type: Online String
See Also
AuthenticationToken Structure
AuthenticationToken Members
NFX.Security Namespace


AuthorizationException Class

AuthorizationException Class NFX Class Library

Base exception thrown by the security framework
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Security SecurityException
NFX.Security AuthorizationException

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class AuthorizationException : SecurityException
[SerializableAttribute]
public class AuthorizationException : SecurityException
<SerializableAttribute>
Public Class AuthorizationException
    Inherits SecurityException
<SerializableAttribute>
Public Class AuthorizationException
    Inherits SecurityException
[SerializableAttribute]
public ref class AuthorizationException : public SecurityException
[SerializableAttribute]
public ref class AuthorizationException : public SecurityException
[<SerializableAttribute>]
type AuthorizationException =
    class
        inherit SecurityException
    end
[<SerializableAttribute>]
type AuthorizationException =
    class
        inherit SecurityException
    end
See Also
AuthorizationException Members
NFX.Security Namespace


AuthorizationException Members

AuthorizationException Members NFX Class Library

The AuthorizationException type exposes the following members.
Constructors
 | Name | Description
Public method | AuthorizationException | Initializes a new instance of the AuthorizationException class
Public method | AuthorizationException(String) | Initializes a new instance of the AuthorizationException class
Protected method | AuthorizationException(SerializationInfo, StreamingContext) | Initializes a new instance of the AuthorizationException class
Public method | AuthorizationException(String, Exception) | Initializes a new instance of the AuthorizationException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
AuthorizationException Class
NFX.Security Namespace


AuthorizationException Constructor

AuthorizationException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | AuthorizationException | Initializes a new instance of the AuthorizationException class
Public method | AuthorizationException(String) | Initializes a new instance of the AuthorizationException class
Protected method | AuthorizationException(SerializationInfo, StreamingContext) | Initializes a new instance of the AuthorizationException class
Public method | AuthorizationException(String, Exception) | Initializes a new instance of the AuthorizationException class
Back to Top
See Also
AuthorizationException Class
AuthorizationException Members
NFX.Security Namespace


AuthorizationException Constructor

AuthorizationException Constructor NFX Class Library

Initializes a new instance of the AuthorizationException class

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AuthorizationException()
public AuthorizationException()
Public Sub New
Public Sub New
public:
AuthorizationException()
public:
AuthorizationException()
new : unit -> AuthorizationException
new : unit -> AuthorizationException
See Also
AuthorizationException Class
AuthorizationException Members
AuthorizationException Overload
NFX.Security Namespace


AuthorizationException Constructor (String)

AuthorizationException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AuthorizationException class

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AuthorizationException(
    string message
)
public AuthorizationException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
AuthorizationException(
    String^ message
)
public:
AuthorizationException(
    String^ message
)
new :
        message : string -> AuthorizationException
new :
        message : string -> AuthorizationException

Parameters

message
Type: Online System String
See Also
AuthorizationException Class
AuthorizationException Members
AuthorizationException Overload
NFX.Security Namespace


AuthorizationException Constructor (SerializationInfo, StreamingContext)

AuthorizationException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AuthorizationException class

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected AuthorizationException(
    SerializationInfo info,
    StreamingContext context
)
protected AuthorizationException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
AuthorizationException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
AuthorizationException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> AuthorizationException
new :
        info : SerializationInfo *
        context : StreamingContext -> AuthorizationException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
AuthorizationException Class
AuthorizationException Members
AuthorizationException Overload
NFX.Security Namespace


AuthorizationException Constructor (String, Exception)

AuthorizationException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AuthorizationException class

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AuthorizationException(
    string message,
    Exception inner
)
public AuthorizationException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
AuthorizationException(
    String^ message,
    Exception^ inner
)
public:
AuthorizationException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> AuthorizationException
new :
        message : string *
        inner : Exception -> AuthorizationException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
AuthorizationException Class
AuthorizationException Members
AuthorizationException Overload
NFX.Security Namespace


AuthorizationException Methods

AuthorizationException Methods NFX Class Library

The AuthorizationException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
AuthorizationException Class
NFX.Security Namespace


AuthorizationException Properties

AuthorizationException Properties NFX Class Library

The AuthorizationException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
AuthorizationException Class
NFX.Security Namespace


AuthorizationException Events

AuthorizationException Events NFX Class Library

The AuthorizationException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
AuthorizationException Class
NFX.Security Namespace


BlankCredentials Class

BlankCredentials Class NFX Class Library

Represents credentials that are absent. This is a singleton class
Inheritance Hierarchy
Online System Object
NFX.Security Credentials
NFX.Security BlankCredentials

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class BlankCredentials : Credentials
[SerializableAttribute]
public class BlankCredentials : Credentials
<SerializableAttribute>
Public Class BlankCredentials
    Inherits Credentials
<SerializableAttribute>
Public Class BlankCredentials
    Inherits Credentials
[SerializableAttribute]
public ref class BlankCredentials : public Credentials
[SerializableAttribute]
public ref class BlankCredentials : public Credentials
[<SerializableAttribute>]
type BlankCredentials =
    class
        inherit Credentials
    end
[<SerializableAttribute>]
type BlankCredentials =
    class
        inherit Credentials
    end
See Also
BlankCredentials Members
NFX.Security Namespace


BlankCredentials Members

BlankCredentials Members NFX Class Library

The BlankCredentials type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Forget | Deletes sensitive information (such as password). This method is mostly used on client (vs. server) to prevent process memory-inspection attack. Its is usually called right after Login() was called. Implementers may consider forcing post-factum GC.Collect() on all generations to make sure that orphaned memory buff with sensitive information, that remains in RAM even after all references are killed, gets compacted; consequently, this method may take considerable time to execute. (Inherited from Credentials.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Forgotten | Indicates whether Forget() was called on this instance (Inherited from Credentials.)
 | Instance | Singleton instance of blank credentials
Back to Top
See Also
BlankCredentials Class
NFX.Security Namespace


BlankCredentials Methods

BlankCredentials Methods NFX Class Library

The BlankCredentials type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Forget | Deletes sensitive information (such as password). This method is mostly used on client (vs. server) to prevent process memory-inspection attack. Its is usually called right after Login() was called. Implementers may consider forcing post-factum GC.Collect() on all generations to make sure that orphaned memory buff with sensitive information, that remains in RAM even after all references are killed, gets compacted; consequently, this method may take considerable time to execute. (Inherited from Credentials.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BlankCredentials Class
NFX.Security Namespace


BlankCredentials Properties

BlankCredentials Properties NFX Class Library

The BlankCredentials type exposes the following members.
Properties
 | Name | Description
Public property | Forgotten | Indicates whether Forget() was called on this instance (Inherited from Credentials.)
 | Instance | Singleton instance of blank credentials
Back to Top
See Also
BlankCredentials Class
NFX.Security Namespace


BlankCredentials.Instance Property

BlankCredentials Instance Property NFX Class Library

Singleton instance of blank credentials

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static BlankCredentials Instance { get; }
public static BlankCredentials Instance { get; }
Public Shared ReadOnly Property Instance As BlankCredentials
    Get
Public Shared ReadOnly Property Instance As BlankCredentials
    Get
public:
static property BlankCredentials^ Instance {
    BlankCredentials^ get ();
}
public:
static property BlankCredentials^ Instance {
    BlankCredentials^ get ();
}
static member Instance : BlankCredentials with get
static member Instance : BlankCredentials with get

Property Value

Type: BlankCredentials
See Also
BlankCredentials Class
BlankCredentials Members
NFX.Security Namespace


ConfigSecurityManager Class

ConfigSecurityManager Class NFX Class Library

Provides security manager implementation that authenticates and authorizes users from configuration
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service Online Object
NFX.ServiceModel ServiceWithInstrumentationBase Online Object
NFX.Security ConfigSecurityManager

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ConfigSecurityManager : ServiceWithInstrumentationBase<Object>,
    ISecurityManagerImplementation, ISecurityManager, IApplicationComponent, IDisposable, IConfigurable
public class ConfigSecurityManager : ServiceWithInstrumentationBase<Object>,
    ISecurityManagerImplementation, ISecurityManager, IApplicationComponent, IDisposable, IConfigurable
Public Class ConfigSecurityManager
    Inherits ServiceWithInstrumentationBase(Of Object)
    Implements ISecurityManagerImplementation, ISecurityManager, IApplicationComponent, IDisposable,
    IConfigurable
Public Class ConfigSecurityManager
    Inherits ServiceWithInstrumentationBase(Of Object)
    Implements ISecurityManagerImplementation, ISecurityManager, IApplicationComponent, IDisposable,
    IConfigurable
public ref class ConfigSecurityManager : public ServiceWithInstrumentationBase<Object^>,
    ISecurityManagerImplementation, ISecurityManager, IApplicationComponent, IDisposable, IConfigurable
public ref class ConfigSecurityManager : public ServiceWithInstrumentationBase<Object^>,
    ISecurityManagerImplementation, ISecurityManager, IApplicationComponent, IDisposable, IConfigurable
type ConfigSecurityManager =
    class
        inherit ServiceWithInstrumentationBase<Object>
        interface ISecurityManagerImplementation
        interface ISecurityManager
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
    end
type ConfigSecurityManager =
    class
        inherit ServiceWithInstrumentationBase<Object>
        interface ISecurityManagerImplementation
        interface ISecurityManager
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
    end
See Also
ConfigSecurityManager Members
NFX.Security Namespace


ConfigSecurityManager Members

ConfigSecurityManager Members NFX Class Library

The ConfigSecurityManager type exposes the following members.
Constructors
 | Name | Description
Public method | ConfigSecurityManager | Constructs security manager that authenticates users listed in application configuration
Public method | ConfigSecurityManager(Object) | Constructs security manager that authenticates users listed in the supplied configuration section
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | Authenticate(AuthenticationToken) |
Public method | Authenticate(Credentials) |
Public method | Authenticate(User) |
Public method | Authorize |
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_DESCRIPTION_ATTR |
CONFIG_ID_ATTR |
CONFIG_PASSWORD_ATTR |
CONFIG_PASSWORD_MANAGER_SECTION |
CONFIG_PERMISSION_SECTION |
CONFIG_RIGHTS_SECTION |
CONFIG_STATUS_ATTR |
CONFIG_USER_SECTION |
CONFIG_USERS_SECTION |
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | (Overrides ApplicationComponent ComponentCommonName.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Config | Returns config node that this instance is configured from. If null is returned then manager performs authentication from application configuration
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | InstrumentationEnabled | (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | PasswordManager |
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
ConfigSecurityManager Class
NFX.Security Namespace


ConfigSecurityManager Constructor

ConfigSecurityManager Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ConfigSecurityManager | Constructs security manager that authenticates users listed in application configuration
Public method | ConfigSecurityManager(Object) | Constructs security manager that authenticates users listed in the supplied configuration section
Back to Top
See Also
ConfigSecurityManager Class
ConfigSecurityManager Members
NFX.Security Namespace


ConfigSecurityManager Constructor

ConfigSecurityManager Constructor NFX Class Library

Constructs security manager that authenticates users listed in application configuration

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigSecurityManager()
public ConfigSecurityManager()
Public Sub New
Public Sub New
public:
ConfigSecurityManager()
public:
ConfigSecurityManager()
new : unit -> ConfigSecurityManager
new : unit -> ConfigSecurityManager
See Also
ConfigSecurityManager Class
ConfigSecurityManager Members
ConfigSecurityManager Overload
NFX.Security Namespace


ConfigSecurityManager Constructor (Object)

ConfigSecurityManager Constructor (Object) NFX Class Library

Constructs security manager that authenticates users listed in the supplied configuration section

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigSecurityManager(
    Object director
)
public ConfigSecurityManager(
    Object director
)
Public Sub New (
    director As Object
)
Public Sub New (
    director As Object
)
public:
ConfigSecurityManager(
    Object^ director
)
public:
ConfigSecurityManager(
    Object^ director
)
new :
        director : Object -> ConfigSecurityManager
new :
        director : Object -> ConfigSecurityManager

Parameters

director
Type: Online System Object
See Also
ConfigSecurityManager Class
ConfigSecurityManager Members
ConfigSecurityManager Overload
NFX.Security Namespace


ConfigSecurityManager Fields

ConfigSecurityManager Fields NFX Class Library

The ConfigSecurityManager type exposes the following members.
Fields
Name | Description
CONFIG_DESCRIPTION_ATTR |
CONFIG_ID_ATTR |
CONFIG_PASSWORD_ATTR |
CONFIG_PASSWORD_MANAGER_SECTION |
CONFIG_PERMISSION_SECTION |
CONFIG_RIGHTS_SECTION |
CONFIG_STATUS_ATTR |
CONFIG_USER_SECTION |
CONFIG_USERS_SECTION |
Back to Top
See Also
ConfigSecurityManager Class
NFX.Security Namespace


ConfigSecurityManager.CONFIG_DESCRIPTION_ATTR Field

ConfigSecurityManager CONFIG_DESCRIPTION_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_DESCRIPTION_ATTR
public const string CONFIG_DESCRIPTION_ATTR
Public Const CONFIG_DESCRIPTION_ATTR As String
Public Const CONFIG_DESCRIPTION_ATTR As String
public:
literal String^ CONFIG_DESCRIPTION_ATTR
public:
literal String^ CONFIG_DESCRIPTION_ATTR
static val mutable CONFIG_DESCRIPTION_ATTR: string
static val mutable CONFIG_DESCRIPTION_ATTR: string

Field Value

Type: Online String
See Also
ConfigSecurityManager Class
ConfigSecurityManager Members
NFX.Security Namespace


ConfigSecurityManager.CONFIG_ID_ATTR Field

ConfigSecurityManager CONFIG_ID_ATTR Field NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_ID_ATTR
public const string CONFIG_ID_ATTR
Public Const CONFIG_ID_ATTR As String
Public Const CONFIG_ID_ATTR As String
public:
literal String^ CONFIG_ID_ATTR
public:
literal String^ CONFIG_ID_ATTR
static val mutable CONFIG_ID_ATTR: string
static val mutable CONFIG_ID_ATTR: string

Field Value

Type: Online String
See Also
ConfigSecurityManager Class
ConfigSecurityManager Members
NFX.Security Namespace


ConfigSecurityManager.CONFIG_PASSWORD_ATTR Field

ConfigSecurityManager CONFIG_PASSWORD_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PASSWORD_ATTR
public const string CONFIG_PASSWORD_ATTR
Public Const CONFIG_PASSWORD_ATTR As String
Public Const CONFIG_PASSWORD_ATTR As String
public:
literal String^ CONFIG_PASSWORD_ATTR
public:
literal String^ CONFIG_PASSWORD_ATTR
static val mutable CONFIG_PASSWORD_ATTR: string
static val mutable CONFIG_PASSWORD_ATTR: string

Field Value

Type: Online String
See Also
ConfigSecurityManager Class
ConfigSecurityManager Members
NFX.Security Namespace


ConfigSecurityManager.CONFIG_PASSWORD_MANAGER_SECTION Field

ConfigSecurityManager CONFIG_PASSWORD_MANAGER_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PASSWORD_MANAGER_SECTION
public const string CONFIG_PASSWORD_MANAGER_SECTION
Public Const CONFIG_PASSWORD_MANAGER_SECTION As String
Public Const CONFIG_PASSWORD_MANAGER_SECTION As String
public:
literal String^ CONFIG_PASSWORD_MANAGER_SECTION
public:
literal String^ CONFIG_PASSWORD_MANAGER_SECTION
static val mutable CONFIG_PASSWORD_MANAGER_SECTION: string
static val mutable CONFIG_PASSWORD_MANAGER_SECTION: string

Field Value

Type: Online String
See Also
ConfigSecurityManager Class
ConfigSecurityManager Members
NFX.Security Namespace


ConfigSecurityManager.CONFIG_PERMISSION_SECTION Field

ConfigSecurityManager CONFIG_PERMISSION_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PERMISSION_SECTION
public const string CONFIG_PERMISSION_SECTION
Public Const CONFIG_PERMISSION_SECTION As String
Public Const CONFIG_PERMISSION_SECTION As String
public:
literal String^ CONFIG_PERMISSION_SECTION
public:
literal String^ CONFIG_PERMISSION_SECTION
static val mutable CONFIG_PERMISSION_SECTION: string
static val mutable CONFIG_PERMISSION_SECTION: string

Field Value

Type: Online String
See Also
ConfigSecurityManager Class
ConfigSecurityManager Members
NFX.Security Namespace


ConfigSecurityManager.CONFIG_RIGHTS_SECTION Field

ConfigSecurityManager CONFIG_RIGHTS_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_RIGHTS_SECTION
public const string CONFIG_RIGHTS_SECTION
Public Const CONFIG_RIGHTS_SECTION As String
Public Const CONFIG_RIGHTS_SECTION As String
public:
literal String^ CONFIG_RIGHTS_SECTION
public:
literal String^ CONFIG_RIGHTS_SECTION
static val mutable CONFIG_RIGHTS_SECTION: string
static val mutable CONFIG_RIGHTS_SECTION: string

Field Value

Type: Online String
See Also
ConfigSecurityManager Class
ConfigSecurityManager Members
NFX.Security Namespace


ConfigSecurityManager.CONFIG_STATUS_ATTR Field

ConfigSecurityManager CONFIG_STATUS_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_STATUS_ATTR
public const string CONFIG_STATUS_ATTR
Public Const CONFIG_STATUS_ATTR As String
Public Const CONFIG_STATUS_ATTR As String
public:
literal String^ CONFIG_STATUS_ATTR
public:
literal String^ CONFIG_STATUS_ATTR
static val mutable CONFIG_STATUS_ATTR: string
static val mutable CONFIG_STATUS_ATTR: string

Field Value

Type: Online String
See Also
ConfigSecurityManager Class
ConfigSecurityManager Members
NFX.Security Namespace


ConfigSecurityManager.CONFIG_USER_SECTION Field

ConfigSecurityManager CONFIG_USER_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_USER_SECTION
public const string CONFIG_USER_SECTION
Public Const CONFIG_USER_SECTION As String
Public Const CONFIG_USER_SECTION As String
public:
literal String^ CONFIG_USER_SECTION
public:
literal String^ CONFIG_USER_SECTION
static val mutable CONFIG_USER_SECTION: string
static val mutable CONFIG_USER_SECTION: string

Field Value

Type: Online String
See Also
ConfigSecurityManager Class
ConfigSecurityManager Members
NFX.Security Namespace


ConfigSecurityManager.CONFIG_USERS_SECTION Field

ConfigSecurityManager CONFIG_USERS_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_USERS_SECTION
public const string CONFIG_USERS_SECTION
Public Const CONFIG_USERS_SECTION As String
Public Const CONFIG_USERS_SECTION As String
public:
literal String^ CONFIG_USERS_SECTION
public:
literal String^ CONFIG_USERS_SECTION
static val mutable CONFIG_USERS_SECTION: string
static val mutable CONFIG_USERS_SECTION: string

Field Value

Type: Online String
See Also
ConfigSecurityManager Class
ConfigSecurityManager Members
NFX.Security Namespace


ConfigSecurityManager Methods

ConfigSecurityManager Methods NFX Class Library

The ConfigSecurityManager type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | Authenticate(AuthenticationToken) |
Public method | Authenticate(Credentials) |
Public method | Authenticate(User) |
Public method | Authorize |
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ConfigSecurityManager Class
NFX.Security Namespace


ConfigSecurityManager.Authenticate Method

ConfigSecurityManager Authenticate Method NFX Class Library

Overload List
 | Name | Description
Public method | Authenticate(AuthenticationToken) |
Public method | Authenticate(Credentials) |
Public method | Authenticate(User) |
Back to Top
See Also
ConfigSecurityManager Class
ConfigSecurityManager Members
NFX.Security Namespace


ConfigSecurityManager.Authenticate Method (AuthenticationToken)

ConfigSecurityManager Authenticate Method (AuthenticationToken) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public User Authenticate(
    AuthenticationToken token
)
public User Authenticate(
    AuthenticationToken token
)
Public Function Authenticate (
    token As AuthenticationToken
) As User
Public Function Authenticate (
    token As AuthenticationToken
) As User
public:
virtual User^ Authenticate(
    AuthenticationToken token
) sealed
public:
virtual User^ Authenticate(
    AuthenticationToken token
) sealed
abstract Authenticate :
        token : AuthenticationToken -> User
override Authenticate :
        token : AuthenticationToken -> User
abstract Authenticate :
        token : AuthenticationToken -> User
override Authenticate :
        token : AuthenticationToken -> User

Parameters

token
Type: NFX.Security AuthenticationToken

Return Value

Type: User

Implements

ISecurityManager Authenticate(AuthenticationToken)
See Also
ConfigSecurityManager Class
ConfigSecurityManager Members
Authenticate Overload
NFX.Security Namespace


ConfigSecurityManager.Authenticate Method (Credentials)

ConfigSecurityManager Authenticate Method (Credentials) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public User Authenticate(
    Credentials credentials
)
public User Authenticate(
    Credentials credentials
)
Public Function Authenticate (
    credentials As Credentials
) As User
Public Function Authenticate (
    credentials As Credentials
) As User
public:
virtual User^ Authenticate(
    Credentials^ credentials
) sealed
public:
virtual User^ Authenticate(
    Credentials^ credentials
) sealed
abstract Authenticate :
        credentials : Credentials -> User
override Authenticate :
        credentials : Credentials -> User
abstract Authenticate :
        credentials : Credentials -> User
override Authenticate :
        credentials : Credentials -> User

Parameters

credentials
Type: NFX.Security Credentials

Return Value

Type: User

Implements

ISecurityManager Authenticate(Credentials)
See Also
ConfigSecurityManager Class
ConfigSecurityManager Members
Authenticate Overload
NFX.Security Namespace


ConfigSecurityManager.Authenticate Method (User)

ConfigSecurityManager Authenticate Method (User) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Authenticate(
    User user
)
public void Authenticate(
    User user
)
Public Sub Authenticate (
    user As User
)
Public Sub Authenticate (
    user As User
)
public:
virtual void Authenticate(
    User^ user
) sealed
public:
virtual void Authenticate(
    User^ user
) sealed
abstract Authenticate :
        user : User -> unit
override Authenticate :
        user : User -> unit
abstract Authenticate :
        user : User -> unit
override Authenticate :
        user : User -> unit

Parameters

user
Type: NFX.Security User

Implements

ISecurityManager Authenticate(User)
See Also
ConfigSecurityManager Class
ConfigSecurityManager Members
Authenticate Overload
NFX.Security Namespace


ConfigSecurityManager.Authorize Method

ConfigSecurityManager Authorize Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccessLevel Authorize(
    User user,
    Permission permission
)
public AccessLevel Authorize(
    User user,
    Permission permission
)
Public Function Authorize (
    user As User,
    permission As Permission
) As AccessLevel
Public Function Authorize (
    user As User,
    permission As Permission
) As AccessLevel
public:
virtual AccessLevel^ Authorize(
    User^ user,
    Permission^ permission
) sealed
public:
virtual AccessLevel^ Authorize(
    User^ user,
    Permission^ permission
) sealed
abstract Authorize :
        user : User *
        permission : Permission -> AccessLevel
override Authorize :
        user : User *
        permission : Permission -> AccessLevel
abstract Authorize :
        user : User *
        permission : Permission -> AccessLevel
override Authorize :
        user : User *
        permission : Permission -> AccessLevel

Parameters

user
Type: NFX.Security User
permission
Type: NFX.Security Permission

Return Value

Type: AccessLevel

Implements

ISecurityManager Authorize(User, Permission)
See Also
ConfigSecurityManager Class
ConfigSecurityManager Members
NFX.Security Namespace


ConfigSecurityManager.DoConfigure Method

ConfigSecurityManager DoConfigure Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
ConfigSecurityManager Class
ConfigSecurityManager Members
NFX.Security Namespace


ConfigSecurityManager.DoSignalStop Method

ConfigSecurityManager DoSignalStop Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSignalStop()
protected override void DoSignalStop()
Protected Overrides Sub DoSignalStop
Protected Overrides Sub DoSignalStop
protected:
virtual void DoSignalStop() override
protected:
virtual void DoSignalStop() override
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
See Also
ConfigSecurityManager Class
ConfigSecurityManager Members
NFX.Security Namespace


ConfigSecurityManager.DoStart Method

ConfigSecurityManager DoStart Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
ConfigSecurityManager Class
ConfigSecurityManager Members
NFX.Security Namespace


ConfigSecurityManager.DoWaitForCompleteStop Method

ConfigSecurityManager DoWaitForCompleteStop Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
ConfigSecurityManager Class
ConfigSecurityManager Members
NFX.Security Namespace


ConfigSecurityManager Properties

ConfigSecurityManager Properties NFX Class Library

The ConfigSecurityManager type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | (Overrides ApplicationComponent ComponentCommonName.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Config | Returns config node that this instance is configured from. If null is returned then manager performs authentication from application configuration
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | InstrumentationEnabled | (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | PasswordManager |
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
ConfigSecurityManager Class
NFX.Security Namespace


ConfigSecurityManager.ComponentCommonName Property

ConfigSecurityManager ComponentCommonName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ComponentCommonName { get; }
public override string ComponentCommonName { get; }
Public Overrides ReadOnly Property ComponentCommonName As String
    Get
Public Overrides ReadOnly Property ComponentCommonName As String
    Get
public:
virtual property String^ ComponentCommonName {
    String^ get () override;
}
public:
virtual property String^ ComponentCommonName {
    String^ get () override;
}
abstract ComponentCommonName : string with get
override ComponentCommonName : string with get
abstract ComponentCommonName : string with get
override ComponentCommonName : string with get

Property Value

Type: Online String

Implements

IApplicationComponent ComponentCommonName
IApplicationComponent ComponentCommonName
See Also
ConfigSecurityManager Class
ConfigSecurityManager Members
NFX.Security Namespace


ConfigSecurityManager.Config Property

ConfigSecurityManager Config Property NFX Class Library

Returns config node that this instance is configured from. If null is returned then manager performs authentication from application configuration

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IConfigSectionNode Config { get; }
public IConfigSectionNode Config { get; }
Public ReadOnly Property Config As IConfigSectionNode
    Get
Public ReadOnly Property Config As IConfigSectionNode
    Get
public:
property IConfigSectionNode^ Config {
    IConfigSectionNode^ get ();
}
public:
property IConfigSectionNode^ Config {
    IConfigSectionNode^ get ();
}
member Config : IConfigSectionNode with get
member Config : IConfigSectionNode with get

Property Value

Type: IConfigSectionNode
See Also
ConfigSecurityManager Class
ConfigSecurityManager Members
NFX.Security Namespace


ConfigSecurityManager.InstrumentationEnabled Property

ConfigSecurityManager InstrumentationEnabled Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(new string[] { ... })]
public override bool InstrumentationEnabled { get; set; }
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(new string[] { ... })]
public override bool InstrumentationEnabled { get; set; }
<ConfigAttribute(Default := false)>
<ExternalParameterAttribute(New String() { ... })>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
<ConfigAttribute(Default := false)>
<ExternalParameterAttribute(New String() { ... })>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
public:
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
public:
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
abstract InstrumentationEnabled : bool with get, set
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
override InstrumentationEnabled : bool with get, set
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
abstract InstrumentationEnabled : bool with get, set
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
override InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentable InstrumentationEnabled
See Also
ConfigSecurityManager Class
ConfigSecurityManager Members
NFX.Security Namespace


ConfigSecurityManager.PasswordManager Property

ConfigSecurityManager PasswordManager Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IPasswordManager PasswordManager { get; }
public IPasswordManager PasswordManager { get; }
Public ReadOnly Property PasswordManager As IPasswordManager
    Get
Public ReadOnly Property PasswordManager As IPasswordManager
    Get
public:
virtual property IPasswordManager^ PasswordManager {
    IPasswordManager^ get () sealed;
}
public:
virtual property IPasswordManager^ PasswordManager {
    IPasswordManager^ get () sealed;
}
abstract PasswordManager : IPasswordManager with get
override PasswordManager : IPasswordManager with get
abstract PasswordManager : IPasswordManager with get
override PasswordManager : IPasswordManager with get

Property Value

Type: IPasswordManager

Implements

ISecurityManager PasswordManager
See Also
ConfigSecurityManager Class
ConfigSecurityManager Members
NFX.Security Namespace


Credentials Class

Credentials Class NFX Class Library

User credentials base class. A credentials may be as simple as user+password, access card codes, door key, Twitter account token etc...
Inheritance Hierarchy
Online System Object
NFX.Security Credentials
NFX.IO.FileSystem.GoogleDrive GoogleDriveCredentials
NFX.IO.FileSystem.S3 S3Credentials
NFX.Security BlankCredentials
NFX.Security GDIDCredentials
NFX.Security IDPasswordCredentials
NFX.Security SocialNetTokenCredentials
NFX.Web.Pay.Braintree BraintreeCredentials
NFX.Web.Pay.Mock MockCredentials
NFX.Web.Pay.PayPal PayPalCredentials
NFX.Web.Pay.Stripe StripeCredentials
NFX.Web.Shipping.Shippo ShippoCredentials

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class Credentials
[SerializableAttribute]
public abstract class Credentials
<SerializableAttribute>
Public MustInherit Class Credentials
<SerializableAttribute>
Public MustInherit Class Credentials
[SerializableAttribute]
public ref class Credentials abstract
[SerializableAttribute]
public ref class Credentials abstract
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type Credentials =  class end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type Credentials =  class end
See Also
Credentials Members
NFX.Security Namespace


Credentials Members

Credentials Members NFX Class Library

The Credentials type exposes the following members.
Constructors
 | Name | Description
Protected method | Credentials | Initializes a new instance of the Credentials class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Forget | Deletes sensitive information (such as password). This method is mostly used on client (vs. server) to prevent process memory-inspection attack. Its is usually called right after Login() was called. Implementers may consider forcing post-factum GC.Collect() on all generations to make sure that orphaned memory buff with sensitive information, that remains in RAM even after all references are killed, gets compacted; consequently, this method may take considerable time to execute.
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Forgotten | Indicates whether Forget() was called on this instance
Back to Top
See Also
Credentials Class
NFX.Security Namespace


Credentials Constructor

Credentials Constructor NFX Class Library

Initializes a new instance of the Credentials class

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Credentials()
protected Credentials()
Protected Sub New
Protected Sub New
protected:
Credentials()
protected:
Credentials()
new : unit -> Credentials
new : unit -> Credentials
See Also
Credentials Class
Credentials Members
NFX.Security Namespace


Credentials Methods

Credentials Methods NFX Class Library

The Credentials type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Forget | Deletes sensitive information (such as password). This method is mostly used on client (vs. server) to prevent process memory-inspection attack. Its is usually called right after Login() was called. Implementers may consider forcing post-factum GC.Collect() on all generations to make sure that orphaned memory buff with sensitive information, that remains in RAM even after all references are killed, gets compacted; consequently, this method may take considerable time to execute.
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Credentials Class
NFX.Security Namespace


Credentials.Forget Method

Credentials Forget Method NFX Class Library

Deletes sensitive information (such as password). This method is mostly used on client (vs. server) to prevent process memory-inspection attack. Its is usually called right after Login() was called. Implementers may consider forcing post-factum GC.Collect() on all generations to make sure that orphaned memory buff with sensitive information, that remains in RAM even after all references are killed, gets compacted; consequently, this method may take considerable time to execute.

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Forget()
public virtual void Forget()
Public Overridable Sub Forget
Public Overridable Sub Forget
public:
virtual void Forget()
public:
virtual void Forget()
abstract Forget : unit -> unit
override Forget : unit -> unit
abstract Forget : unit -> unit
override Forget : unit -> unit
See Also
Credentials Class
Credentials Members
NFX.Security Namespace


Credentials Properties

Credentials Properties NFX Class Library

The Credentials type exposes the following members.
Properties
 | Name | Description
Public property | Forgotten | Indicates whether Forget() was called on this instance
Back to Top
See Also
Credentials Class
NFX.Security Namespace


Credentials.Forgotten Property

Credentials Forgotten Property NFX Class Library

Indicates whether Forget() was called on this instance

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Forgotten { get; }
public bool Forgotten { get; }
Public ReadOnly Property Forgotten As Boolean
    Get
Public ReadOnly Property Forgotten As Boolean
    Get
public:
virtual property bool Forgotten {
    bool get () sealed;
}
public:
virtual property bool Forgotten {
    bool get () sealed;
}
abstract Forgotten : bool with get
override Forgotten : bool with get
abstract Forgotten : bool with get
override Forgotten : bool with get

Property Value

Type: Online Boolean
See Also
Credentials Class
Credentials Members
NFX.Security Namespace


DefaultPasswordManager Class

DefaultPasswordManager Class NFX Class Library

Provides default implementation for password managment functionality based on injectable algorithms and default password strength calculation
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service ISecurityManagerImplementation
NFX.ServiceModel ServiceWithInstrumentationBase ISecurityManagerImplementation
NFX.Security DefaultPasswordManager

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class DefaultPasswordManager : ServiceWithInstrumentationBase<ISecurityManagerImplementation>,
    IPasswordManagerImplementation, IPasswordManager, IApplicationComponent, IDisposable, IInstrumentable,
    IExternallyParameterized, IService, INamed, IConfigurable
public class DefaultPasswordManager : ServiceWithInstrumentationBase<ISecurityManagerImplementation>,
    IPasswordManagerImplementation, IPasswordManager, IApplicationComponent, IDisposable, IInstrumentable,
    IExternallyParameterized, IService, INamed, IConfigurable
Public Class DefaultPasswordManager
    Inherits ServiceWithInstrumentationBase(Of ISecurityManagerImplementation)
    Implements IPasswordManagerImplementation, IPasswordManager, IApplicationComponent, IDisposable,
    IInstrumentable, IExternallyParameterized, IService, INamed, IConfigurable
Public Class DefaultPasswordManager
    Inherits ServiceWithInstrumentationBase(Of ISecurityManagerImplementation)
    Implements IPasswordManagerImplementation, IPasswordManager, IApplicationComponent, IDisposable,
    IInstrumentable, IExternallyParameterized, IService, INamed, IConfigurable
public ref class DefaultPasswordManager : public ServiceWithInstrumentationBase<ISecurityManagerImplementation^>,
    IPasswordManagerImplementation, IPasswordManager, IApplicationComponent, IDisposable, IInstrumentable,
    IExternallyParameterized, IService, INamed, IConfigurable
public ref class DefaultPasswordManager : public ServiceWithInstrumentationBase<ISecurityManagerImplementation^>,
    IPasswordManagerImplementation, IPasswordManager, IApplicationComponent, IDisposable, IInstrumentable,
    IExternallyParameterized, IService, INamed, IConfigurable
type DefaultPasswordManager =
    class
        inherit ServiceWithInstrumentationBase<ISecurityManagerImplementation>
        interface IPasswordManagerImplementation
        interface IPasswordManager
        interface IApplicationComponent
        interface IDisposable
        interface IInstrumentable
        interface IExternallyParameterized
        interface IService
        interface INamed
        interface IConfigurable
    end
type DefaultPasswordManager =
    class
        inherit ServiceWithInstrumentationBase<ISecurityManagerImplementation>
        interface IPasswordManagerImplementation
        interface IPasswordManager
        interface IApplicationComponent
        interface IDisposable
        interface IInstrumentable
        interface IExternallyParameterized
        interface IService
        interface INamed
        interface IConfigurable
    end
See Also
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager Members

DefaultPasswordManager Members NFX Class Library

The DefaultPasswordManager type exposes the following members.
Constructors
 | Name | Description
Public method | DefaultPasswordManager | Initializes a new instance of the DefaultPasswordManager class
Public method | DefaultPasswordManager(ISecurityManagerImplementation) | Initializes a new instance of the DefaultPasswordManager class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | AreEquivalent |
Public method | CalculateStrenghtPercent |
Public method | CalculateStrenghtScore |
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | ComputeHash |
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoAreEquivalent |
Protected method | DoCalculateStrenghtScore |
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoComputeHash |
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoGeneratePassword |
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoVerify |
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GeneratePassword |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Register |
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | Unregister(String) |
Public method | Unregister(PasswordHashingAlgorithm) |
Public method | Verify |
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_ALGORITHM_SECTION |
DEFAULT_COMMON_WORDS |
TOP_SCORE_ABOVE_NORMAL |
TOP_SCORE_BELOW_NORMAL |
TOP_SCORE_MAXIMUM |
TOP_SCORE_MINIMUM |
TOP_SCORE_NORMAL |
Back to Top
Properties
 | Name | Description
Public property | Algorithms |
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DefaultStrengthLevel |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | InstrumentationEnabled | (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
DefaultPasswordManager Class
NFX.Security Namespace


DefaultPasswordManager Constructor

DefaultPasswordManager Constructor NFX Class Library

Overload List
 | Name | Description
Public method | DefaultPasswordManager | Initializes a new instance of the DefaultPasswordManager class
Public method | DefaultPasswordManager(ISecurityManagerImplementation) | Initializes a new instance of the DefaultPasswordManager class
Back to Top
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager Constructor

DefaultPasswordManager Constructor NFX Class Library

Initializes a new instance of the DefaultPasswordManager class

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DefaultPasswordManager()
public DefaultPasswordManager()
Public Sub New
Public Sub New
public:
DefaultPasswordManager()
public:
DefaultPasswordManager()
new : unit -> DefaultPasswordManager
new : unit -> DefaultPasswordManager
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
DefaultPasswordManager Overload
NFX.Security Namespace


DefaultPasswordManager Constructor (ISecurityManagerImplementation)

DefaultPasswordManager Constructor (ISecurityManagerImplementation) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DefaultPasswordManager class

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DefaultPasswordManager(
    ISecurityManagerImplementation director
)
public DefaultPasswordManager(
    ISecurityManagerImplementation director
)
Public Sub New (
    director As ISecurityManagerImplementation
)
Public Sub New (
    director As ISecurityManagerImplementation
)
public:
DefaultPasswordManager(
    ISecurityManagerImplementation^ director
)
public:
DefaultPasswordManager(
    ISecurityManagerImplementation^ director
)
new :
        director : ISecurityManagerImplementation -> DefaultPasswordManager
new :
        director : ISecurityManagerImplementation -> DefaultPasswordManager

Parameters

director
Type: NFX.Security ISecurityManagerImplementation
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
DefaultPasswordManager Overload
NFX.Security Namespace


DefaultPasswordManager Fields

DefaultPasswordManager Fields NFX Class Library

The DefaultPasswordManager type exposes the following members.
Fields
Name | Description
CONFIG_ALGORITHM_SECTION |
DEFAULT_COMMON_WORDS |
TOP_SCORE_ABOVE_NORMAL |
TOP_SCORE_BELOW_NORMAL |
TOP_SCORE_MAXIMUM |
TOP_SCORE_MINIMUM |
TOP_SCORE_NORMAL |
Back to Top
See Also
DefaultPasswordManager Class
NFX.Security Namespace


DefaultPasswordManager.CONFIG_ALGORITHM_SECTION Field

DefaultPasswordManager CONFIG_ALGORITHM_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_ALGORITHM_SECTION
public const string CONFIG_ALGORITHM_SECTION
Public Const CONFIG_ALGORITHM_SECTION As String
Public Const CONFIG_ALGORITHM_SECTION As String
public:
literal String^ CONFIG_ALGORITHM_SECTION
public:
literal String^ CONFIG_ALGORITHM_SECTION
static val mutable CONFIG_ALGORITHM_SECTION: string
static val mutable CONFIG_ALGORITHM_SECTION: string

Field Value

Type: Online String
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager.DEFAULT_COMMON_WORDS Field

DefaultPasswordManager DEFAULT_COMMON_WORDS Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly string[] DEFAULT_COMMON_WORDS
public static readonly string[] DEFAULT_COMMON_WORDS
Public Shared ReadOnly DEFAULT_COMMON_WORDS As String()
Public Shared ReadOnly DEFAULT_COMMON_WORDS As String()
public:
static initonly array<String^>^ DEFAULT_COMMON_WORDS
public:
static initonly array<String^>^ DEFAULT_COMMON_WORDS
static val DEFAULT_COMMON_WORDS: string[]
static val DEFAULT_COMMON_WORDS: string[]

Field Value

Type: Online String
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager.TOP_SCORE_ABOVE_NORMAL Field

DefaultPasswordManager TOP_SCORE_ABOVE_NORMAL Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int TOP_SCORE_ABOVE_NORMAL
public const int TOP_SCORE_ABOVE_NORMAL
Public Const TOP_SCORE_ABOVE_NORMAL As Integer
Public Const TOP_SCORE_ABOVE_NORMAL As Integer
public:
literal int TOP_SCORE_ABOVE_NORMAL
public:
literal int TOP_SCORE_ABOVE_NORMAL
static val mutable TOP_SCORE_ABOVE_NORMAL: int
static val mutable TOP_SCORE_ABOVE_NORMAL: int

Field Value

Type: Online Int32
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager.TOP_SCORE_BELOW_NORMAL Field

DefaultPasswordManager TOP_SCORE_BELOW_NORMAL Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int TOP_SCORE_BELOW_NORMAL
public const int TOP_SCORE_BELOW_NORMAL
Public Const TOP_SCORE_BELOW_NORMAL As Integer
Public Const TOP_SCORE_BELOW_NORMAL As Integer
public:
literal int TOP_SCORE_BELOW_NORMAL
public:
literal int TOP_SCORE_BELOW_NORMAL
static val mutable TOP_SCORE_BELOW_NORMAL: int
static val mutable TOP_SCORE_BELOW_NORMAL: int

Field Value

Type: Online Int32
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager.TOP_SCORE_MAXIMUM Field

DefaultPasswordManager TOP_SCORE_MAXIMUM Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int TOP_SCORE_MAXIMUM
public const int TOP_SCORE_MAXIMUM
Public Const TOP_SCORE_MAXIMUM As Integer
Public Const TOP_SCORE_MAXIMUM As Integer
public:
literal int TOP_SCORE_MAXIMUM
public:
literal int TOP_SCORE_MAXIMUM
static val mutable TOP_SCORE_MAXIMUM: int
static val mutable TOP_SCORE_MAXIMUM: int

Field Value

Type: Online Int32
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager.TOP_SCORE_MINIMUM Field

DefaultPasswordManager TOP_SCORE_MINIMUM Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int TOP_SCORE_MINIMUM
public const int TOP_SCORE_MINIMUM
Public Const TOP_SCORE_MINIMUM As Integer
Public Const TOP_SCORE_MINIMUM As Integer
public:
literal int TOP_SCORE_MINIMUM
public:
literal int TOP_SCORE_MINIMUM
static val mutable TOP_SCORE_MINIMUM: int
static val mutable TOP_SCORE_MINIMUM: int

Field Value

Type: Online Int32
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager.TOP_SCORE_NORMAL Field

DefaultPasswordManager TOP_SCORE_NORMAL Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int TOP_SCORE_NORMAL
public const int TOP_SCORE_NORMAL
Public Const TOP_SCORE_NORMAL As Integer
Public Const TOP_SCORE_NORMAL As Integer
public:
literal int TOP_SCORE_NORMAL
public:
literal int TOP_SCORE_NORMAL
static val mutable TOP_SCORE_NORMAL: int
static val mutable TOP_SCORE_NORMAL: int

Field Value

Type: Online Int32
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager Methods

DefaultPasswordManager Methods NFX Class Library

The DefaultPasswordManager type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | AreEquivalent |
Public method | CalculateStrenghtPercent |
Public method | CalculateStrenghtScore |
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | ComputeHash |
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoAreEquivalent |
Protected method | DoCalculateStrenghtScore |
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoComputeHash |
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoGeneratePassword |
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoVerify |
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GeneratePassword |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Register |
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | Unregister(String) |
Public method | Unregister(PasswordHashingAlgorithm) |
Public method | Verify |
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
DefaultPasswordManager Class
NFX.Security Namespace


DefaultPasswordManager.AreEquivalent Method

DefaultPasswordManager AreEquivalent Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool AreEquivalent(
    HashedPassword a,
    HashedPassword b
)
public bool AreEquivalent(
    HashedPassword a,
    HashedPassword b
)
Public Function AreEquivalent (
    a As HashedPassword,
    b As HashedPassword
) As Boolean
Public Function AreEquivalent (
    a As HashedPassword,
    b As HashedPassword
) As Boolean
public:
virtual bool AreEquivalent(
    HashedPassword^ a,
    HashedPassword^ b
) sealed
public:
virtual bool AreEquivalent(
    HashedPassword^ a,
    HashedPassword^ b
) sealed
abstract AreEquivalent :
        a : HashedPassword *
        b : HashedPassword -> bool
override AreEquivalent :
        a : HashedPassword *
        b : HashedPassword -> bool
abstract AreEquivalent :
        a : HashedPassword *
        b : HashedPassword -> bool
override AreEquivalent :
        a : HashedPassword *
        b : HashedPassword -> bool

Parameters

a
Type: NFX.Security HashedPassword
b
Type: NFX.Security HashedPassword

Return Value

Type: Online Boolean

Implements

IPasswordManager AreEquivalent(HashedPassword, HashedPassword)
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager.CalculateStrenghtPercent Method

DefaultPasswordManager CalculateStrenghtPercent Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CalculateStrenghtPercent(
    PasswordFamily family,
    SecureBuffer password,
    int maxScore = 0
)
public int CalculateStrenghtPercent(
    PasswordFamily family,
    SecureBuffer password,
    int maxScore = 0
)
Public Function CalculateStrenghtPercent (
    family As PasswordFamily,
    password As SecureBuffer,
    Optional maxScore As Integer = 0
) As Integer
Public Function CalculateStrenghtPercent (
    family As PasswordFamily,
    password As SecureBuffer,
    Optional maxScore As Integer = 0
) As Integer
public:
virtual int CalculateStrenghtPercent(
    PasswordFamily family,
    SecureBuffer^ password,
    int maxScore = 0
) sealed
public:
virtual int CalculateStrenghtPercent(
    PasswordFamily family,
    SecureBuffer^ password,
    int maxScore = 0
) sealed
abstract CalculateStrenghtPercent :
        family : PasswordFamily *
        password : SecureBuffer *
        ?maxScore : int
(* Defaults:
        let _maxScore = defaultArg maxScore 0
*)
-> int
override CalculateStrenghtPercent :
        family : PasswordFamily *
        password : SecureBuffer *
        ?maxScore : int
(* Defaults:
        let _maxScore = defaultArg maxScore 0
*)
-> int
abstract CalculateStrenghtPercent :
        family : PasswordFamily *
        password : SecureBuffer *
        ?maxScore : int
(* Defaults:
        let _maxScore = defaultArg maxScore 0
*)
-> int
override CalculateStrenghtPercent :
        family : PasswordFamily *
        password : SecureBuffer *
        ?maxScore : int
(* Defaults:
        let _maxScore = defaultArg maxScore 0
*)
-> int

Parameters

family
Type: NFX.Security PasswordFamily
password
Type: NFX.Security SecureBuffer
maxScore (Optional)
Type: Online System Int32

Return Value

Type: Online Int32

Implements

IPasswordManager CalculateStrenghtPercent(PasswordFamily, SecureBuffer, Int32)
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager.CalculateStrenghtScore Method

DefaultPasswordManager CalculateStrenghtScore Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CalculateStrenghtScore(
    PasswordFamily family,
    SecureBuffer password
)
public int CalculateStrenghtScore(
    PasswordFamily family,
    SecureBuffer password
)
Public Function CalculateStrenghtScore (
    family As PasswordFamily,
    password As SecureBuffer
) As Integer
Public Function CalculateStrenghtScore (
    family As PasswordFamily,
    password As SecureBuffer
) As Integer
public:
virtual int CalculateStrenghtScore(
    PasswordFamily family,
    SecureBuffer^ password
) sealed
public:
virtual int CalculateStrenghtScore(
    PasswordFamily family,
    SecureBuffer^ password
) sealed
abstract CalculateStrenghtScore :
        family : PasswordFamily *
        password : SecureBuffer -> int
override CalculateStrenghtScore :
        family : PasswordFamily *
        password : SecureBuffer -> int
abstract CalculateStrenghtScore :
        family : PasswordFamily *
        password : SecureBuffer -> int
override CalculateStrenghtScore :
        family : PasswordFamily *
        password : SecureBuffer -> int

Parameters

family
Type: NFX.Security PasswordFamily
password
Type: NFX.Security SecureBuffer

Return Value

Type: Online Int32

Implements

IPasswordManager CalculateStrenghtScore(PasswordFamily, SecureBuffer)
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager.ComputeHash Method

DefaultPasswordManager ComputeHash Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HashedPassword ComputeHash(
    PasswordFamily family,
    SecureBuffer password,
    PasswordStrengthLevel level = PasswordStrengthLevel.Default
)
public HashedPassword ComputeHash(
    PasswordFamily family,
    SecureBuffer password,
    PasswordStrengthLevel level = PasswordStrengthLevel.Default
)
Public Function ComputeHash (
    family As PasswordFamily,
    password As SecureBuffer,
    Optional level As PasswordStrengthLevel = PasswordStrengthLevel.Default
) As HashedPassword
Public Function ComputeHash (
    family As PasswordFamily,
    password As SecureBuffer,
    Optional level As PasswordStrengthLevel = PasswordStrengthLevel.Default
) As HashedPassword
public:
virtual HashedPassword^ ComputeHash(
    PasswordFamily family,
    SecureBuffer^ password,
    PasswordStrengthLevel level = PasswordStrengthLevel::Default
) sealed
public:
virtual HashedPassword^ ComputeHash(
    PasswordFamily family,
    SecureBuffer^ password,
    PasswordStrengthLevel level = PasswordStrengthLevel::Default
) sealed
abstract ComputeHash :
        family : PasswordFamily *
        password : SecureBuffer *
        ?level : PasswordStrengthLevel
(* Defaults:
        let _level = defaultArg level PasswordStrengthLevel.Default
*)
-> HashedPassword
override ComputeHash :
        family : PasswordFamily *
        password : SecureBuffer *
        ?level : PasswordStrengthLevel
(* Defaults:
        let _level = defaultArg level PasswordStrengthLevel.Default
*)
-> HashedPassword
abstract ComputeHash :
        family : PasswordFamily *
        password : SecureBuffer *
        ?level : PasswordStrengthLevel
(* Defaults:
        let _level = defaultArg level PasswordStrengthLevel.Default
*)
-> HashedPassword
override ComputeHash :
        family : PasswordFamily *
        password : SecureBuffer *
        ?level : PasswordStrengthLevel
(* Defaults:
        let _level = defaultArg level PasswordStrengthLevel.Default
*)
-> HashedPassword

Parameters

family
Type: NFX.Security PasswordFamily
password
Type: NFX.Security SecureBuffer
level (Optional)
Type: NFX.Security PasswordStrengthLevel

Return Value

Type: HashedPassword

Implements

IPasswordManager ComputeHash(PasswordFamily, SecureBuffer, PasswordStrengthLevel)
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager.DoAreEquivalent Method

DefaultPasswordManager DoAreEquivalent Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool DoAreEquivalent(
    HashedPassword a,
    HashedPassword b
)
protected virtual bool DoAreEquivalent(
    HashedPassword a,
    HashedPassword b
)
Protected Overridable Function DoAreEquivalent (
    a As HashedPassword,
    b As HashedPassword
) As Boolean
Protected Overridable Function DoAreEquivalent (
    a As HashedPassword,
    b As HashedPassword
) As Boolean
protected:
virtual bool DoAreEquivalent(
    HashedPassword^ a,
    HashedPassword^ b
)
protected:
virtual bool DoAreEquivalent(
    HashedPassword^ a,
    HashedPassword^ b
)
abstract DoAreEquivalent :
        a : HashedPassword *
        b : HashedPassword -> bool
override DoAreEquivalent :
        a : HashedPassword *
        b : HashedPassword -> bool
abstract DoAreEquivalent :
        a : HashedPassword *
        b : HashedPassword -> bool
override DoAreEquivalent :
        a : HashedPassword *
        b : HashedPassword -> bool

Parameters

a
Type: NFX.Security HashedPassword
b
Type: NFX.Security HashedPassword

Return Value

Type: Online Boolean
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager.DoCalculateStrenghtScore Method

DefaultPasswordManager DoCalculateStrenghtScore Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual int DoCalculateStrenghtScore(
    PasswordFamily family,
    SecureBuffer password
)
protected virtual int DoCalculateStrenghtScore(
    PasswordFamily family,
    SecureBuffer password
)
Protected Overridable Function DoCalculateStrenghtScore (
    family As PasswordFamily,
    password As SecureBuffer
) As Integer
Protected Overridable Function DoCalculateStrenghtScore (
    family As PasswordFamily,
    password As SecureBuffer
) As Integer
protected:
virtual int DoCalculateStrenghtScore(
    PasswordFamily family,
    SecureBuffer^ password
)
protected:
virtual int DoCalculateStrenghtScore(
    PasswordFamily family,
    SecureBuffer^ password
)
abstract DoCalculateStrenghtScore :
        family : PasswordFamily *
        password : SecureBuffer -> int
override DoCalculateStrenghtScore :
        family : PasswordFamily *
        password : SecureBuffer -> int
abstract DoCalculateStrenghtScore :
        family : PasswordFamily *
        password : SecureBuffer -> int
override DoCalculateStrenghtScore :
        family : PasswordFamily *
        password : SecureBuffer -> int

Parameters

family
Type: NFX.Security PasswordFamily
password
Type: NFX.Security SecureBuffer

Return Value

Type: Online Int32
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager.DoComputeHash Method

DefaultPasswordManager DoComputeHash Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual HashedPassword DoComputeHash(
    PasswordFamily family,
    SecureBuffer password,
    PasswordStrengthLevel level
)
protected virtual HashedPassword DoComputeHash(
    PasswordFamily family,
    SecureBuffer password,
    PasswordStrengthLevel level
)
Protected Overridable Function DoComputeHash (
    family As PasswordFamily,
    password As SecureBuffer,
    level As PasswordStrengthLevel
) As HashedPassword
Protected Overridable Function DoComputeHash (
    family As PasswordFamily,
    password As SecureBuffer,
    level As PasswordStrengthLevel
) As HashedPassword
protected:
virtual HashedPassword^ DoComputeHash(
    PasswordFamily family,
    SecureBuffer^ password,
    PasswordStrengthLevel level
)
protected:
virtual HashedPassword^ DoComputeHash(
    PasswordFamily family,
    SecureBuffer^ password,
    PasswordStrengthLevel level
)
abstract DoComputeHash :
        family : PasswordFamily *
        password : SecureBuffer *
        level : PasswordStrengthLevel -> HashedPassword
override DoComputeHash :
        family : PasswordFamily *
        password : SecureBuffer *
        level : PasswordStrengthLevel -> HashedPassword
abstract DoComputeHash :
        family : PasswordFamily *
        password : SecureBuffer *
        level : PasswordStrengthLevel -> HashedPassword
override DoComputeHash :
        family : PasswordFamily *
        password : SecureBuffer *
        level : PasswordStrengthLevel -> HashedPassword

Parameters

family
Type: NFX.Security PasswordFamily
password
Type: NFX.Security SecureBuffer
level
Type: NFX.Security PasswordStrengthLevel

Return Value

Type: HashedPassword
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager.DoConfigure Method

DefaultPasswordManager DoConfigure Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager.DoGeneratePassword Method

DefaultPasswordManager DoGeneratePassword Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual IEnumerable<PasswordRepresentation> DoGeneratePassword(
    PasswordFamily family,
    PasswordRepresentationType type,
    PasswordStrengthLevel level
)
protected virtual IEnumerable<PasswordRepresentation> DoGeneratePassword(
    PasswordFamily family,
    PasswordRepresentationType type,
    PasswordStrengthLevel level
)
Protected Overridable Function DoGeneratePassword (
    family As PasswordFamily,
    type As PasswordRepresentationType,
    level As PasswordStrengthLevel
) As IEnumerable(Of PasswordRepresentation)
Protected Overridable Function DoGeneratePassword (
    family As PasswordFamily,
    type As PasswordRepresentationType,
    level As PasswordStrengthLevel
) As IEnumerable(Of PasswordRepresentation)
protected:
virtual IEnumerable<PasswordRepresentation^>^ DoGeneratePassword(
    PasswordFamily family,
    PasswordRepresentationType type,
    PasswordStrengthLevel level
)
protected:
virtual IEnumerable<PasswordRepresentation^>^ DoGeneratePassword(
    PasswordFamily family,
    PasswordRepresentationType type,
    PasswordStrengthLevel level
)
abstract DoGeneratePassword :
        family : PasswordFamily *
        type : PasswordRepresentationType *
        level : PasswordStrengthLevel -> IEnumerable<PasswordRepresentation>
override DoGeneratePassword :
        family : PasswordFamily *
        type : PasswordRepresentationType *
        level : PasswordStrengthLevel -> IEnumerable<PasswordRepresentation>
abstract DoGeneratePassword :
        family : PasswordFamily *
        type : PasswordRepresentationType *
        level : PasswordStrengthLevel -> IEnumerable<PasswordRepresentation>
override DoGeneratePassword :
        family : PasswordFamily *
        type : PasswordRepresentationType *
        level : PasswordStrengthLevel -> IEnumerable<PasswordRepresentation>

Parameters

family
Type: NFX.Security PasswordFamily
type
Type: NFX.Security PasswordRepresentationType
level
Type: NFX.Security PasswordStrengthLevel

Return Value

Type: Online IEnumerable PasswordRepresentation
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager.DoSignalStop Method

DefaultPasswordManager DoSignalStop Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSignalStop()
protected override void DoSignalStop()
Protected Overrides Sub DoSignalStop
Protected Overrides Sub DoSignalStop
protected:
virtual void DoSignalStop() override
protected:
virtual void DoSignalStop() override
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager.DoStart Method

DefaultPasswordManager DoStart Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager.DoVerify Method

DefaultPasswordManager DoVerify Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool DoVerify(
    SecureBuffer password,
    HashedPassword hash,
    out bool needRehash
)
protected virtual bool DoVerify(
    SecureBuffer password,
    HashedPassword hash,
    out bool needRehash
)
Protected Overridable Function DoVerify (
    password As SecureBuffer,
    hash As HashedPassword,
    <OutAttribute> ByRef needRehash As Boolean
) As Boolean
Protected Overridable Function DoVerify (
    password As SecureBuffer,
    hash As HashedPassword,
    <OutAttribute> ByRef needRehash As Boolean
) As Boolean
protected:
virtual bool DoVerify(
    SecureBuffer^ password,
    HashedPassword^ hash,
    [OutAttribute] bool% needRehash
)
protected:
virtual bool DoVerify(
    SecureBuffer^ password,
    HashedPassword^ hash,
    [OutAttribute] bool% needRehash
)
abstract DoVerify :
        password : SecureBuffer *
        hash : HashedPassword *
        needRehash : bool byref -> bool
override DoVerify :
        password : SecureBuffer *
        hash : HashedPassword *
        needRehash : bool byref -> bool
abstract DoVerify :
        password : SecureBuffer *
        hash : HashedPassword *
        needRehash : bool byref -> bool
override DoVerify :
        password : SecureBuffer *
        hash : HashedPassword *
        needRehash : bool byref -> bool

Parameters

password
Type: NFX.Security SecureBuffer
hash
Type: NFX.Security HashedPassword
needRehash
Type: Online System Boolean

Return Value

Type: Online Boolean
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager.DoWaitForCompleteStop Method

DefaultPasswordManager DoWaitForCompleteStop Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager.GeneratePassword Method

DefaultPasswordManager GeneratePassword Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<PasswordRepresentation> GeneratePassword(
    PasswordFamily family,
    PasswordRepresentationType type,
    PasswordStrengthLevel level = PasswordStrengthLevel.Default
)
public IEnumerable<PasswordRepresentation> GeneratePassword(
    PasswordFamily family,
    PasswordRepresentationType type,
    PasswordStrengthLevel level = PasswordStrengthLevel.Default
)
Public Function GeneratePassword (
    family As PasswordFamily,
    type As PasswordRepresentationType,
    Optional level As PasswordStrengthLevel = PasswordStrengthLevel.Default
) As IEnumerable(Of PasswordRepresentation)
Public Function GeneratePassword (
    family As PasswordFamily,
    type As PasswordRepresentationType,
    Optional level As PasswordStrengthLevel = PasswordStrengthLevel.Default
) As IEnumerable(Of PasswordRepresentation)
public:
virtual IEnumerable<PasswordRepresentation^>^ GeneratePassword(
    PasswordFamily family,
    PasswordRepresentationType type,
    PasswordStrengthLevel level = PasswordStrengthLevel::Default
) sealed
public:
virtual IEnumerable<PasswordRepresentation^>^ GeneratePassword(
    PasswordFamily family,
    PasswordRepresentationType type,
    PasswordStrengthLevel level = PasswordStrengthLevel::Default
) sealed
abstract GeneratePassword :
        family : PasswordFamily *
        type : PasswordRepresentationType *
        ?level : PasswordStrengthLevel
(* Defaults:
        let _level = defaultArg level PasswordStrengthLevel.Default
*)
-> IEnumerable<PasswordRepresentation>
override GeneratePassword :
        family : PasswordFamily *
        type : PasswordRepresentationType *
        ?level : PasswordStrengthLevel
(* Defaults:
        let _level = defaultArg level PasswordStrengthLevel.Default
*)
-> IEnumerable<PasswordRepresentation>
abstract GeneratePassword :
        family : PasswordFamily *
        type : PasswordRepresentationType *
        ?level : PasswordStrengthLevel
(* Defaults:
        let _level = defaultArg level PasswordStrengthLevel.Default
*)
-> IEnumerable<PasswordRepresentation>
override GeneratePassword :
        family : PasswordFamily *
        type : PasswordRepresentationType *
        ?level : PasswordStrengthLevel
(* Defaults:
        let _level = defaultArg level PasswordStrengthLevel.Default
*)
-> IEnumerable<PasswordRepresentation>

Parameters

family
Type: NFX.Security PasswordFamily
type
Type: NFX.Security PasswordRepresentationType
level (Optional)
Type: NFX.Security PasswordStrengthLevel

Return Value

Type: Online IEnumerable PasswordRepresentation

Implements

IPasswordManager GeneratePassword(PasswordFamily, PasswordRepresentationType, PasswordStrengthLevel)
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager.Register Method

DefaultPasswordManager Register Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Register(
    PasswordHashingAlgorithm algo
)
public bool Register(
    PasswordHashingAlgorithm algo
)
Public Function Register (
    algo As PasswordHashingAlgorithm
) As Boolean
Public Function Register (
    algo As PasswordHashingAlgorithm
) As Boolean
public:
virtual bool Register(
    PasswordHashingAlgorithm^ algo
) sealed
public:
virtual bool Register(
    PasswordHashingAlgorithm^ algo
) sealed
abstract Register :
        algo : PasswordHashingAlgorithm -> bool
override Register :
        algo : PasswordHashingAlgorithm -> bool
abstract Register :
        algo : PasswordHashingAlgorithm -> bool
override Register :
        algo : PasswordHashingAlgorithm -> bool

Parameters

algo
Type: NFX.Security PasswordHashingAlgorithm

Return Value

Type: Online Boolean

Implements

IPasswordManagerImplementation Register(PasswordHashingAlgorithm)
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager.Unregister Method

DefaultPasswordManager Unregister Method NFX Class Library

Overload List
 | Name | Description
Public method | Unregister(String) |
Public method | Unregister(PasswordHashingAlgorithm) |
Back to Top
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager.Unregister Method (String)

DefaultPasswordManager Unregister Method (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Unregister(
    string algoName
)
public bool Unregister(
    string algoName
)
Public Function Unregister (
    algoName As String
) As Boolean
Public Function Unregister (
    algoName As String
) As Boolean
public:
virtual bool Unregister(
    String^ algoName
) sealed
public:
virtual bool Unregister(
    String^ algoName
) sealed
abstract Unregister :
        algoName : string -> bool
override Unregister :
        algoName : string -> bool
abstract Unregister :
        algoName : string -> bool
override Unregister :
        algoName : string -> bool

Parameters

algoName
Type: Online System String

Return Value

Type: Online Boolean

Implements

IPasswordManagerImplementation Unregister(String)
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
Unregister Overload
NFX.Security Namespace


DefaultPasswordManager.Unregister Method (PasswordHashingAlgorithm)

DefaultPasswordManager Unregister Method (PasswordHashingAlgorithm) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Unregister(
    PasswordHashingAlgorithm algo
)
public bool Unregister(
    PasswordHashingAlgorithm algo
)
Public Function Unregister (
    algo As PasswordHashingAlgorithm
) As Boolean
Public Function Unregister (
    algo As PasswordHashingAlgorithm
) As Boolean
public:
virtual bool Unregister(
    PasswordHashingAlgorithm^ algo
) sealed
public:
virtual bool Unregister(
    PasswordHashingAlgorithm^ algo
) sealed
abstract Unregister :
        algo : PasswordHashingAlgorithm -> bool
override Unregister :
        algo : PasswordHashingAlgorithm -> bool
abstract Unregister :
        algo : PasswordHashingAlgorithm -> bool
override Unregister :
        algo : PasswordHashingAlgorithm -> bool

Parameters

algo
Type: NFX.Security PasswordHashingAlgorithm

Return Value

Type: Online Boolean

Implements

IPasswordManagerImplementation Unregister(PasswordHashingAlgorithm)
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
Unregister Overload
NFX.Security Namespace


DefaultPasswordManager.Verify Method

DefaultPasswordManager Verify Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Verify(
    SecureBuffer password,
    HashedPassword hash,
    out bool needRehash
)
public bool Verify(
    SecureBuffer password,
    HashedPassword hash,
    out bool needRehash
)
Public Function Verify (
    password As SecureBuffer,
    hash As HashedPassword,
    <OutAttribute> ByRef needRehash As Boolean
) As Boolean
Public Function Verify (
    password As SecureBuffer,
    hash As HashedPassword,
    <OutAttribute> ByRef needRehash As Boolean
) As Boolean
public:
virtual bool Verify(
    SecureBuffer^ password,
    HashedPassword^ hash,
    [OutAttribute] bool% needRehash
) sealed
public:
virtual bool Verify(
    SecureBuffer^ password,
    HashedPassword^ hash,
    [OutAttribute] bool% needRehash
) sealed
abstract Verify :
        password : SecureBuffer *
        hash : HashedPassword *
        needRehash : bool byref -> bool
override Verify :
        password : SecureBuffer *
        hash : HashedPassword *
        needRehash : bool byref -> bool
abstract Verify :
        password : SecureBuffer *
        hash : HashedPassword *
        needRehash : bool byref -> bool
override Verify :
        password : SecureBuffer *
        hash : HashedPassword *
        needRehash : bool byref -> bool

Parameters

password
Type: NFX.Security SecureBuffer
hash
Type: NFX.Security HashedPassword
needRehash
Type: Online System Boolean

Return Value

Type: Online Boolean

Implements

IPasswordManager Verify(SecureBuffer, HashedPassword, Boolean )
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager Properties

DefaultPasswordManager Properties NFX Class Library

The DefaultPasswordManager type exposes the following members.
Properties
 | Name | Description
Public property | Algorithms |
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | DefaultStrengthLevel |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | InstrumentationEnabled | (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
DefaultPasswordManager Class
NFX.Security Namespace


DefaultPasswordManager.Algorithms Property

DefaultPasswordManager Algorithms Property NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<PasswordHashingAlgorithm> Algorithms { get; }
public IRegistry<PasswordHashingAlgorithm> Algorithms { get; }
Public ReadOnly Property Algorithms As IRegistry(Of PasswordHashingAlgorithm)
    Get
Public ReadOnly Property Algorithms As IRegistry(Of PasswordHashingAlgorithm)
    Get
public:
virtual property IRegistry<PasswordHashingAlgorithm^>^ Algorithms {
    IRegistry<PasswordHashingAlgorithm^>^ get () sealed;
}
public:
virtual property IRegistry<PasswordHashingAlgorithm^>^ Algorithms {
    IRegistry<PasswordHashingAlgorithm^>^ get () sealed;
}
abstract Algorithms : IRegistry<PasswordHashingAlgorithm> with get
override Algorithms : IRegistry<PasswordHashingAlgorithm> with get
abstract Algorithms : IRegistry<PasswordHashingAlgorithm> with get
override Algorithms : IRegistry<PasswordHashingAlgorithm> with get

Property Value

Type: IRegistry PasswordHashingAlgorithm

Implements

IPasswordManager Algorithms
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager.DefaultStrengthLevel Property

DefaultPasswordManager DefaultStrengthLevel Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(Default = PasswordStrengthLevel.Normal)]
public PasswordStrengthLevel DefaultStrengthLevel { get; set; }
[ConfigAttribute(Default = PasswordStrengthLevel.Normal)]
public PasswordStrengthLevel DefaultStrengthLevel { get; set; }
<ConfigAttribute(Default := PasswordStrengthLevel.Normal)>
Public Property DefaultStrengthLevel As PasswordStrengthLevel
    Get
    Set
<ConfigAttribute(Default := PasswordStrengthLevel.Normal)>
Public Property DefaultStrengthLevel As PasswordStrengthLevel
    Get
    Set
public:
[ConfigAttribute(Default = PasswordStrengthLevel::Normal)]
property PasswordStrengthLevel DefaultStrengthLevel {
    PasswordStrengthLevel get ();
    void set (PasswordStrengthLevel value);
}
public:
[ConfigAttribute(Default = PasswordStrengthLevel::Normal)]
property PasswordStrengthLevel DefaultStrengthLevel {
    PasswordStrengthLevel get ();
    void set (PasswordStrengthLevel value);
}
[<ConfigAttribute(Default = PasswordStrengthLevel.Normal)>]
member DefaultStrengthLevel : PasswordStrengthLevel with get, set
[<ConfigAttribute(Default = PasswordStrengthLevel.Normal)>]
member DefaultStrengthLevel : PasswordStrengthLevel with get, set

Property Value

Type: PasswordStrengthLevel
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


DefaultPasswordManager.InstrumentationEnabled Property

DefaultPasswordManager InstrumentationEnabled Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(new string[] { ... })]
public override bool InstrumentationEnabled { get; set; }
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(new string[] { ... })]
public override bool InstrumentationEnabled { get; set; }
<ConfigAttribute(Default := false)>
<ExternalParameterAttribute(New String() { ... })>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
<ConfigAttribute(Default := false)>
<ExternalParameterAttribute(New String() { ... })>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
public:
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
public:
[ConfigAttribute(Default = false)]
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
abstract InstrumentationEnabled : bool with get, set
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
override InstrumentationEnabled : bool with get, set
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
abstract InstrumentationEnabled : bool with get, set
[<ConfigAttribute(Default = false)>]
[<ExternalParameterAttribute(new string[] { ... })>]
override InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentable InstrumentationEnabled
IInstrumentable InstrumentationEnabled
See Also
DefaultPasswordManager Class
DefaultPasswordManager Members
NFX.Security Namespace


GDIDCredentials Class

GDIDCredentials Class NFX Class Library

Represents credentials based on Global Distributed ID
Inheritance Hierarchy
Online System Object
NFX.Security Credentials
NFX.Security GDIDCredentials

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class GDIDCredentials : Credentials
[SerializableAttribute]
public class GDIDCredentials : Credentials
<SerializableAttribute>
Public Class GDIDCredentials
    Inherits Credentials
<SerializableAttribute>
Public Class GDIDCredentials
    Inherits Credentials
[SerializableAttribute]
public ref class GDIDCredentials : public Credentials
[SerializableAttribute]
public ref class GDIDCredentials : public Credentials
[<SerializableAttribute>]
type GDIDCredentials =
    class
        inherit Credentials
    end
[<SerializableAttribute>]
type GDIDCredentials =
    class
        inherit Credentials
    end
See Also
GDIDCredentials Members
NFX.Security Namespace


GDIDCredentials Members

GDIDCredentials Members NFX Class Library

The GDIDCredentials type exposes the following members.
Constructors
 | Name | Description
Public method | GDIDCredentials | Initializes a new instance of the GDIDCredentials class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Forget | (Overrides Credentials Forget .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Forgotten | Indicates whether Forget() was called on this instance (Inherited from Credentials.)
Public property | GDID |
Back to Top
See Also
GDIDCredentials Class
NFX.Security Namespace


GDIDCredentials Constructor

GDIDCredentials Constructor NFX Class Library

Initializes a new instance of the GDIDCredentials class

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GDIDCredentials(
    GDID gdid
)
public GDIDCredentials(
    GDID gdid
)
Public Sub New (
    gdid As GDID
)
Public Sub New (
    gdid As GDID
)
public:
GDIDCredentials(
    GDID gdid
)
public:
GDIDCredentials(
    GDID gdid
)
new :
        gdid : GDID -> GDIDCredentials
new :
        gdid : GDID -> GDIDCredentials

Parameters

gdid
Type: NFX.DataAccess.Distributed GDID
See Also
GDIDCredentials Class
GDIDCredentials Members
NFX.Security Namespace


GDIDCredentials Methods

GDIDCredentials Methods NFX Class Library

The GDIDCredentials type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Forget | (Overrides Credentials Forget .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
GDIDCredentials Class
NFX.Security Namespace


GDIDCredentials.Forget Method

GDIDCredentials Forget Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Forget()
public override void Forget()
Public Overrides Sub Forget
Public Overrides Sub Forget
public:
virtual void Forget() override
public:
virtual void Forget() override
abstract Forget : unit -> unit
override Forget : unit -> unit
abstract Forget : unit -> unit
override Forget : unit -> unit
See Also
GDIDCredentials Class
GDIDCredentials Members
NFX.Security Namespace


GDIDCredentials.ToString Method

GDIDCredentials ToString Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
GDIDCredentials Class
GDIDCredentials Members
NFX.Security Namespace


GDIDCredentials Properties

GDIDCredentials Properties NFX Class Library

The GDIDCredentials type exposes the following members.
Properties
 | Name | Description
Public property | Forgotten | Indicates whether Forget() was called on this instance (Inherited from Credentials.)
Public property | GDID |
Back to Top
See Also
GDIDCredentials Class
NFX.Security Namespace


GDIDCredentials.GDID Property

GDIDCredentials GDID Property NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GDID GDID { get; }
public GDID GDID { get; }
Public ReadOnly Property GDID As GDID
    Get
Public ReadOnly Property GDID As GDID
    Get
public:
property GDID GDID {
    GDID get ();
}
public:
property GDID GDID {
    GDID get ();
}
member GDID : GDID with get
member GDID : GDID with get

Property Value

Type: GDID
See Also
GDIDCredentials Class
GDIDCredentials Members
NFX.Security Namespace


GetSessionFunc Delegate

GetSessionFunc Delegate NFX Class Library

Invoked by permission checker to get session

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate ISession GetSessionFunc()
public delegate ISession GetSessionFunc()
Public Delegate Function GetSessionFunc As ISession
Public Delegate Function GetSessionFunc As ISession
public delegate ISession^ GetSessionFunc()
public delegate ISession^ GetSessionFunc()
type GetSessionFunc =
    delegate of unit -> ISession
type GetSessionFunc =
    delegate of unit -> ISession

Return Value

Type: ISession
See Also
NFX.Security Namespace


HashedPassword Class

HashedPassword Class NFX Class Library

Represents abstraction of a hashed password, the concreate password algorithm provide implementation (i.e. bytebuffer, dictionary, string)
Inheritance Hierarchy
Online System Object
NFX.Security HashedPassword

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SlimSerializationProhibitedAttribute]
public sealed class HashedPassword : IJSONWritable,
    IEnumerable<KeyValuePair<string, Object>>, IEnumerable
[SlimSerializationProhibitedAttribute]
public sealed class HashedPassword : IJSONWritable,
    IEnumerable<KeyValuePair<string, Object>>, IEnumerable
<SlimSerializationProhibitedAttribute>
Public NotInheritable Class HashedPassword
    Implements IJSONWritable, IEnumerable(Of KeyValuePair(Of String, Object)),
    IEnumerable
<SlimSerializationProhibitedAttribute>
Public NotInheritable Class HashedPassword
    Implements IJSONWritable, IEnumerable(Of KeyValuePair(Of String, Object)),
    IEnumerable
[SlimSerializationProhibitedAttribute]
public ref class HashedPassword sealed : IJSONWritable,
    IEnumerable<KeyValuePair<String^, Object^>>, IEnumerable
[SlimSerializationProhibitedAttribute]
public ref class HashedPassword sealed : IJSONWritable,
    IEnumerable<KeyValuePair<String^, Object^>>, IEnumerable
[<SealedAttribute>]
[<SlimSerializationProhibitedAttribute>]
type HashedPassword =
    class
        interface IJSONWritable
        interface IEnumerable<KeyValuePair<string, Object>>
        interface IEnumerable
    end
[<SealedAttribute>]
[<SlimSerializationProhibitedAttribute>]
type HashedPassword =
    class
        interface IJSONWritable
        interface IEnumerable<KeyValuePair<string, Object>>
        interface IEnumerable
    end
See Also
HashedPassword Members
NFX.Security Namespace


HashedPassword Members

HashedPassword Members NFX Class Library

The HashedPassword type exposes the following members.
Constructors
 | Name | Description
Public method | HashedPassword | Initializes a new instance of the HashedPassword class
Back to Top
Methods
 | Name | Description
Public method | Add |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | FromString |
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Public method | WriteAsJSON |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable KeyValuePair String, Object | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct KeyValuePair String, Object , TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair String, Object , TComparand (Func KeyValuePair String, Object , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair String, Object , TComparand (Func KeyValuePair String, Object , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair String, Object , TComparand (Func KeyValuePair String, Object , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair String, Object , TComparand (Func KeyValuePair String, Object , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault KeyValuePair String, Object | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair String, Object (Action KeyValuePair String, Object ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair String, Object (Action KeyValuePair String, Object , Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair String, Object | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair String, Object (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
KEY_ALGO |
KEY_FAM |
Back to Top
Properties
 | Name | Description
Public property | AlgoName |
Public property | Family |
Public property | Item |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
HashedPassword Class
NFX.Security Namespace


HashedPassword Constructor

HashedPassword Constructor NFX Class Library

Initializes a new instance of the HashedPassword class

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HashedPassword(
    string algoName,
    PasswordFamily family
)
public HashedPassword(
    string algoName,
    PasswordFamily family
)
Public Sub New (
    algoName As String,
    family As PasswordFamily
)
Public Sub New (
    algoName As String,
    family As PasswordFamily
)
public:
HashedPassword(
    String^ algoName,
    PasswordFamily family
)
public:
HashedPassword(
    String^ algoName,
    PasswordFamily family
)
new :
        algoName : string *
        family : PasswordFamily -> HashedPassword
new :
        algoName : string *
        family : PasswordFamily -> HashedPassword

Parameters

algoName
Type: Online System String
family
Type: NFX.Security PasswordFamily
See Also
HashedPassword Class
HashedPassword Members
NFX.Security Namespace


HashedPassword Fields

HashedPassword Fields NFX Class Library

The HashedPassword type exposes the following members.
Fields
Name | Description
KEY_ALGO |
KEY_FAM |
Back to Top
See Also
HashedPassword Class
NFX.Security Namespace


HashedPassword.KEY_ALGO Field

HashedPassword KEY_ALGO Field NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string KEY_ALGO
public const string KEY_ALGO
Public Const KEY_ALGO As String
Public Const KEY_ALGO As String
public:
literal String^ KEY_ALGO
public:
literal String^ KEY_ALGO
static val mutable KEY_ALGO: string
static val mutable KEY_ALGO: string

Field Value

Type: Online String
See Also
HashedPassword Class
HashedPassword Members
NFX.Security Namespace


HashedPassword.KEY_FAM Field

HashedPassword KEY_FAM Field NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string KEY_FAM
public const string KEY_FAM
Public Const KEY_FAM As String
Public Const KEY_FAM As String
public:
literal String^ KEY_FAM
public:
literal String^ KEY_FAM
static val mutable KEY_FAM: string
static val mutable KEY_FAM: string

Field Value

Type: Online String
See Also
HashedPassword Class
HashedPassword Members
NFX.Security Namespace


HashedPassword Methods

HashedPassword Methods NFX Class Library

The HashedPassword type exposes the following members.
Methods
 | Name | Description
Public method | Add |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | FromString |
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Public method | WriteAsJSON |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable KeyValuePair String, Object | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct KeyValuePair String, Object , TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair String, Object , TComparand (Func KeyValuePair String, Object , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair String, Object , TComparand (Func KeyValuePair String, Object , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair String, Object , TComparand (Func KeyValuePair String, Object , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair String, Object , TComparand (Func KeyValuePair String, Object , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault KeyValuePair String, Object | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair String, Object (Action KeyValuePair String, Object ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair String, Object (Action KeyValuePair String, Object , Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair String, Object | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair String, Object (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
HashedPassword Class
NFX.Security Namespace


HashedPassword.IEnumerable.GetEnumerator Method

HashedPassword IEnumerable GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
HashedPassword Class
HashedPassword Members
NFX.Security Namespace


HashedPassword.Add Method

HashedPassword Add Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    string key,
    Object value
)
public void Add(
    string key,
    Object value
)
Public Sub Add (
    key As String,
    value As Object
)
Public Sub Add (
    key As String,
    value As Object
)
public:
void Add(
    String^ key,
    Object^ value
)
public:
void Add(
    String^ key,
    Object^ value
)
member Add :
        key : string *
        value : Object -> unit
member Add :
        key : string *
        value : Object -> unit

Parameters

key
Type: Online System String
value
Type: Online System Object
See Also
HashedPassword Class
HashedPassword Members
NFX.Security Namespace


HashedPassword.FromString Method

HashedPassword FromString Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static HashedPassword FromString(
    string str
)
public static HashedPassword FromString(
    string str
)
Public Shared Function FromString (
    str As String
) As HashedPassword
Public Shared Function FromString (
    str As String
) As HashedPassword
public:
static HashedPassword^ FromString(
    String^ str
)
public:
static HashedPassword^ FromString(
    String^ str
)
static member FromString :
        str : string -> HashedPassword
static member FromString :
        str : string -> HashedPassword

Parameters

str
Type: Online System String

Return Value

Type: HashedPassword
See Also
HashedPassword Class
HashedPassword Members
NFX.Security Namespace


HashedPassword.GetEnumerator Method

HashedPassword GetEnumerator Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<KeyValuePair<string, Object>> GetEnumerator()
public IEnumerator<KeyValuePair<string, Object>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of String, Object))
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of String, Object))
public:
virtual IEnumerator<KeyValuePair<String^, Object^>>^ GetEnumerator() sealed
public:
virtual IEnumerator<KeyValuePair<String^, Object^>>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<string, Object>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<string, Object>>
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<string, Object>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<string, Object>>

Return Value

Type: Online IEnumerator Online KeyValuePair Online String, Online Object

Implements

Online IEnumerable T GetEnumerator
See Also
HashedPassword Class
HashedPassword Members
NFX.Security Namespace


HashedPassword.ToString Method

HashedPassword ToString Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
HashedPassword Class
HashedPassword Members
NFX.Security Namespace


HashedPassword.WriteAsJSON Method

HashedPassword WriteAsJSON Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
nestingLevel
Type: Online System Int32
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Implements

IJSONWritable WriteAsJSON(TextWriter, Int32, JSONWritingOptions)
See Also
HashedPassword Class
HashedPassword Members
NFX.Security Namespace


HashedPassword Properties

HashedPassword Properties NFX Class Library

The HashedPassword type exposes the following members.
Properties
 | Name | Description
Public property | AlgoName |
Public property | Family |
Public property | Item |
Back to Top
See Also
HashedPassword Class
NFX.Security Namespace


HashedPassword.AlgoName Property

HashedPassword AlgoName Property NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AlgoName { get; }
public string AlgoName { get; }
Public ReadOnly Property AlgoName As String
    Get
Public ReadOnly Property AlgoName As String
    Get
public:
property String^ AlgoName {
    String^ get ();
}
public:
property String^ AlgoName {
    String^ get ();
}
member AlgoName : string with get
member AlgoName : string with get

Property Value

Type: Online String
See Also
HashedPassword Class
HashedPassword Members
NFX.Security Namespace


HashedPassword.Family Property

HashedPassword Family Property NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PasswordFamily Family { get; }
public PasswordFamily Family { get; }
Public ReadOnly Property Family As PasswordFamily
    Get
Public ReadOnly Property Family As PasswordFamily
    Get
public:
property PasswordFamily Family {
    PasswordFamily get ();
}
public:
property PasswordFamily Family {
    PasswordFamily get ();
}
member Family : PasswordFamily with get
member Family : PasswordFamily with get

Property Value

Type: PasswordFamily
See Also
HashedPassword Class
HashedPassword Members
NFX.Security Namespace


HashedPassword.Item Property

HashedPassword Item Property NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object this[
    string key
] { get; set; }
public Object this[
    string key
] { get; set; }
Public Default Property Item (
    key As String
) As Object
    Get
    Set
Public Default Property Item (
    key As String
) As Object
    Get
    Set
public:
property Object^ default[String^ key] {
    Object^ get (String^ key);
    void set (String^ key, Object^ value);
}
public:
property Object^ default[String^ key] {
    Object^ get (String^ key);
    void set (String^ key, Object^ value);
}
member Item : Object with get, set
member Item : Object with get, set

Parameters

key
Type: Online System String

Property Value

Type: Online Object
See Also
HashedPassword Class
HashedPassword Members
NFX.Security Namespace


IDPasswordCredentials Class

IDPasswordCredentials Class NFX Class Library

Represents simple ID/password textual credentials. Note: The password is stored as plain text
Inheritance Hierarchy
Online System Object
NFX.Security Credentials
NFX.Security IDPasswordCredentials

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class IDPasswordCredentials : Credentials,
    IStringRepresentableCredentials
[SerializableAttribute]
public class IDPasswordCredentials : Credentials,
    IStringRepresentableCredentials
<SerializableAttribute>
Public Class IDPasswordCredentials
    Inherits Credentials
    Implements IStringRepresentableCredentials
<SerializableAttribute>
Public Class IDPasswordCredentials
    Inherits Credentials
    Implements IStringRepresentableCredentials
[SerializableAttribute]
public ref class IDPasswordCredentials : public Credentials,
    IStringRepresentableCredentials
[SerializableAttribute]
public ref class IDPasswordCredentials : public Credentials,
    IStringRepresentableCredentials
[<SerializableAttribute>]
type IDPasswordCredentials =
    class
        inherit Credentials
        interface IStringRepresentableCredentials
    end
[<SerializableAttribute>]
type IDPasswordCredentials =
    class
        inherit Credentials
        interface IStringRepresentableCredentials
    end
See Also
IDPasswordCredentials Members
NFX.Security Namespace


IDPasswordCredentials Members

IDPasswordCredentials Members NFX Class Library

The IDPasswordCredentials type exposes the following members.
Constructors
 | Name | Description
Public method | IDPasswordCredentials(IConfigSectionNode) | Warning: storing plain credentials in config file is not secure. Use this method for the most simplistic cases like unit testing
Public method | IDPasswordCredentials(String, String) | Initializes a new instance of the IDPasswordCredentials class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Forget | Deletes sensitive password information. This method is mostly used on client (vs. server) to prevent process memory-inspection attack. Its is usually called right after Login() was called. Implementers may consider forcing post-factum GC.Collect() on all generations to make sure that orphaned memory buff with sensitive information, that remains in RAM even after all references are killed, gets compacted. This class implementation DOES NOT call Gc.Collect(); (Overrides Credentials Forget .)
 | FromBasicAuth | Creates IDPass credentials from base64 encoded auth header content as provided by RepresentAsString() method. Returns null if the content is unparsable
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | PlainPasswordToSecureBuffer | Obtains an unsecure string password as SecureBuffer. Note: The IDPasswordCredentials class is purposely designed to store password as plain text. This is needed for simple cases and HTTP application where login credentials are posted via plain text anyway
Public method | RepresentAsString |
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Forgotten | Indicates whether Forget() was called on this instance (Inherited from Credentials.)
Public property | ID |
Public property | Password |
Public property | SecurePassword | Obtains an unsecure string password as SecureBuffer. Note: The IDPasswordCredentials class is purposely designed to store password as plain text. This is needed for simple cases and HTTP application where login credentials are posted via plain text anyway
Back to Top
See Also
IDPasswordCredentials Class
NFX.Security Namespace


IDPasswordCredentials Constructor

IDPasswordCredentials Constructor NFX Class Library

Overload List
 | Name | Description
Public method | IDPasswordCredentials(IConfigSectionNode) | Warning: storing plain credentials in config file is not secure. Use this method for the most simplistic cases like unit testing
Public method | IDPasswordCredentials(String, String) | Initializes a new instance of the IDPasswordCredentials class
Back to Top
See Also
IDPasswordCredentials Class
IDPasswordCredentials Members
NFX.Security Namespace


IDPasswordCredentials Constructor (IConfigSectionNode)

IDPasswordCredentials Constructor (IConfigSectionNode) NFX Class Library

[This is preliminary documentation and is subject to change.]

Warning: storing plain credentials in config file is not secure. Use this method for the most simplistic cases like unit testing

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDPasswordCredentials(
    IConfigSectionNode cfg
)
public IDPasswordCredentials(
    IConfigSectionNode cfg
)
Public Sub New (
    cfg As IConfigSectionNode
)
Public Sub New (
    cfg As IConfigSectionNode
)
public:
IDPasswordCredentials(
    IConfigSectionNode^ cfg
)
public:
IDPasswordCredentials(
    IConfigSectionNode^ cfg
)
new :
        cfg : IConfigSectionNode -> IDPasswordCredentials
new :
        cfg : IConfigSectionNode -> IDPasswordCredentials

Parameters

cfg
Type: NFX.Environment IConfigSectionNode
See Also
IDPasswordCredentials Class
IDPasswordCredentials Members
IDPasswordCredentials Overload
NFX.Security Namespace


IDPasswordCredentials Constructor (String, String)

IDPasswordCredentials Constructor (String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the IDPasswordCredentials class

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDPasswordCredentials(
    string id,
    string pwd
)
public IDPasswordCredentials(
    string id,
    string pwd
)
Public Sub New (
    id As String,
    pwd As String
)
Public Sub New (
    id As String,
    pwd As String
)
public:
IDPasswordCredentials(
    String^ id,
    String^ pwd
)
public:
IDPasswordCredentials(
    String^ id,
    String^ pwd
)
new :
        id : string *
        pwd : string -> IDPasswordCredentials
new :
        id : string *
        pwd : string -> IDPasswordCredentials

Parameters

id
Type: Online System String
pwd
Type: Online System String
See Also
IDPasswordCredentials Class
IDPasswordCredentials Members
IDPasswordCredentials Overload
NFX.Security Namespace


IDPasswordCredentials Methods

IDPasswordCredentials Methods NFX Class Library

The IDPasswordCredentials type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Forget | Deletes sensitive password information. This method is mostly used on client (vs. server) to prevent process memory-inspection attack. Its is usually called right after Login() was called. Implementers may consider forcing post-factum GC.Collect() on all generations to make sure that orphaned memory buff with sensitive information, that remains in RAM even after all references are killed, gets compacted. This class implementation DOES NOT call Gc.Collect(); (Overrides Credentials Forget .)
 | FromBasicAuth | Creates IDPass credentials from base64 encoded auth header content as provided by RepresentAsString() method. Returns null if the content is unparsable
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | PlainPasswordToSecureBuffer | Obtains an unsecure string password as SecureBuffer. Note: The IDPasswordCredentials class is purposely designed to store password as plain text. This is needed for simple cases and HTTP application where login credentials are posted via plain text anyway
Public method | RepresentAsString |
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
IDPasswordCredentials Class
NFX.Security Namespace


IDPasswordCredentials.Forget Method

IDPasswordCredentials Forget Method NFX Class Library

Deletes sensitive password information. This method is mostly used on client (vs. server) to prevent process memory-inspection attack. Its is usually called right after Login() was called. Implementers may consider forcing post-factum GC.Collect() on all generations to make sure that orphaned memory buff with sensitive information, that remains in RAM even after all references are killed, gets compacted. This class implementation DOES NOT call Gc.Collect();

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Forget()
public override void Forget()
Public Overrides Sub Forget
Public Overrides Sub Forget
public:
virtual void Forget() override
public:
virtual void Forget() override
abstract Forget : unit -> unit
override Forget : unit -> unit
abstract Forget : unit -> unit
override Forget : unit -> unit

Implements

IStringRepresentableCredentials Forget
See Also
IDPasswordCredentials Class
IDPasswordCredentials Members
NFX.Security Namespace


IDPasswordCredentials.FromBasicAuth Method

IDPasswordCredentials FromBasicAuth Method NFX Class Library

Creates IDPass credentials from base64 encoded auth header content as provided by RepresentAsString() method. Returns null if the content is unparsable

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IDPasswordCredentials FromBasicAuth(
    string basicAuth
)
public static IDPasswordCredentials FromBasicAuth(
    string basicAuth
)
Public Shared Function FromBasicAuth (
    basicAuth As String
) As IDPasswordCredentials
Public Shared Function FromBasicAuth (
    basicAuth As String
) As IDPasswordCredentials
public:
static IDPasswordCredentials^ FromBasicAuth(
    String^ basicAuth
)
public:
static IDPasswordCredentials^ FromBasicAuth(
    String^ basicAuth
)
static member FromBasicAuth :
        basicAuth : string -> IDPasswordCredentials
static member FromBasicAuth :
        basicAuth : string -> IDPasswordCredentials

Parameters

basicAuth
Type: Online System String

Return Value

Type: IDPasswordCredentials
See Also
IDPasswordCredentials Class
IDPasswordCredentials Members
NFX.Security Namespace


IDPasswordCredentials.PlainPasswordToSecureBuffer Method

IDPasswordCredentials PlainPasswordToSecureBuffer Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Obtains an unsecure string password as SecureBuffer. Note: The IDPasswordCredentials class is purposely designed to store password as plain text. This is needed for simple cases and HTTP application where login credentials are posted via plain text anyway

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static SecureBuffer PlainPasswordToSecureBuffer(
    string password
)
public static SecureBuffer PlainPasswordToSecureBuffer(
    string password
)
Public Shared Function PlainPasswordToSecureBuffer (
    password As String
) As SecureBuffer
Public Shared Function PlainPasswordToSecureBuffer (
    password As String
) As SecureBuffer
public:
static SecureBuffer^ PlainPasswordToSecureBuffer(
    String^ password
)
public:
static SecureBuffer^ PlainPasswordToSecureBuffer(
    String^ password
)
static member PlainPasswordToSecureBuffer :
        password : string -> SecureBuffer
static member PlainPasswordToSecureBuffer :
        password : string -> SecureBuffer

Parameters

password
Type: Online System String

Return Value

Type: SecureBuffer
See Also
IDPasswordCredentials Class
IDPasswordCredentials Members
NFX.Security Namespace


IDPasswordCredentials.RepresentAsString Method

IDPasswordCredentials RepresentAsString Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string RepresentAsString()
public string RepresentAsString()
Public Function RepresentAsString As String
Public Function RepresentAsString As String
public:
virtual String^ RepresentAsString() sealed
public:
virtual String^ RepresentAsString() sealed
abstract RepresentAsString : unit -> string
override RepresentAsString : unit -> string
abstract RepresentAsString : unit -> string
override RepresentAsString : unit -> string

Return Value

Type: Online String

Implements

IStringRepresentableCredentials RepresentAsString
See Also
IDPasswordCredentials Class
IDPasswordCredentials Members
NFX.Security Namespace


IDPasswordCredentials.ToString Method

IDPasswordCredentials ToString Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
IDPasswordCredentials Class
IDPasswordCredentials Members
NFX.Security Namespace


IDPasswordCredentials Properties

IDPasswordCredentials Properties NFX Class Library

The IDPasswordCredentials type exposes the following members.
Properties
 | Name | Description
Public property | Forgotten | Indicates whether Forget() was called on this instance (Inherited from Credentials.)
Public property | ID |
Public property | Password |
Public property | SecurePassword | Obtains an unsecure string password as SecureBuffer. Note: The IDPasswordCredentials class is purposely designed to store password as plain text. This is needed for simple cases and HTTP application where login credentials are posted via plain text anyway
Back to Top
See Also
IDPasswordCredentials Class
NFX.Security Namespace


IDPasswordCredentials.ID Property

IDPasswordCredentials ID Property NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ID { get; }
public string ID { get; }
Public ReadOnly Property ID As String
    Get
Public ReadOnly Property ID As String
    Get
public:
property String^ ID {
    String^ get ();
}
public:
property String^ ID {
    String^ get ();
}
member ID : string with get
member ID : string with get

Property Value

Type: Online String
See Also
IDPasswordCredentials Class
IDPasswordCredentials Members
NFX.Security Namespace


IDPasswordCredentials.Password Property

IDPasswordCredentials Password Property NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Password { get; }
public string Password { get; }
Public ReadOnly Property Password As String
    Get
Public ReadOnly Property Password As String
    Get
public:
property String^ Password {
    String^ get ();
}
public:
property String^ Password {
    String^ get ();
}
member Password : string with get
member Password : string with get

Property Value

Type: Online String
See Also
IDPasswordCredentials Class
IDPasswordCredentials Members
NFX.Security Namespace


IDPasswordCredentials.SecurePassword Property

IDPasswordCredentials SecurePassword Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Obtains an unsecure string password as SecureBuffer. Note: The IDPasswordCredentials class is purposely designed to store password as plain text. This is needed for simple cases and HTTP application where login credentials are posted via plain text anyway

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SecureBuffer SecurePassword { get; }
public SecureBuffer SecurePassword { get; }
Public ReadOnly Property SecurePassword As SecureBuffer
    Get
Public ReadOnly Property SecurePassword As SecureBuffer
    Get
public:
property SecureBuffer^ SecurePassword {
    SecureBuffer^ get ();
}
public:
property SecureBuffer^ SecurePassword {
    SecureBuffer^ get ();
}
member SecurePassword : SecureBuffer with get
member SecurePassword : SecureBuffer with get

Property Value

Type: SecureBuffer
See Also
IDPasswordCredentials Class
IDPasswordCredentials Members
NFX.Security Namespace


IPasswordHashingOptions Interface

IPasswordHashingOptions Interface NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IPasswordHashingOptions
public interface IPasswordHashingOptions
Public Interface IPasswordHashingOptions
Public Interface IPasswordHashingOptions
public interface class IPasswordHashingOptions
public interface class IPasswordHashingOptions
type IPasswordHashingOptions =  interface end
type IPasswordHashingOptions =  interface end
See Also
NFX.Security Namespace


IPasswordManager Interface

IPasswordManager Interface NFX Class Library

Denoutes an entity that manages passwords such as: computes and verified hash tokens and provides password strength verification

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IPasswordManager : IApplicationComponent,
    IDisposable
public interface IPasswordManager : IApplicationComponent,
    IDisposable
Public Interface IPasswordManager
    Inherits IApplicationComponent, IDisposable
Public Interface IPasswordManager
    Inherits IApplicationComponent, IDisposable
public interface class IPasswordManager : IApplicationComponent,
    IDisposable
public interface class IPasswordManager : IApplicationComponent,
    IDisposable
type IPasswordManager =
    interface
        interface IApplicationComponent
        interface IDisposable
    end
type IPasswordManager =
    interface
        interface IApplicationComponent
        interface IDisposable
    end
See Also
IPasswordManager Members
NFX.Security Namespace


IPasswordManager Members

IPasswordManager Members NFX Class Library

The IPasswordManager type exposes the following members.
Methods
 | Name | Description
Public method | AreEquivalent |
Public method | CalculateStrenghtPercent |
Public method | CalculateStrenghtScore |
Public method | ComputeHash |
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | GeneratePassword |
Public method | Verify |
Back to Top
Properties
 | Name | Description
Public property | Algorithms |
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Back to Top
See Also
IPasswordManager Interface
NFX.Security Namespace


IPasswordManager Methods

IPasswordManager Methods NFX Class Library

The IPasswordManager type exposes the following members.
Methods
 | Name | Description
Public method | AreEquivalent |
Public method | CalculateStrenghtPercent |
Public method | CalculateStrenghtScore |
Public method | ComputeHash |
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | GeneratePassword |
Public method | Verify |
Back to Top
See Also
IPasswordManager Interface
NFX.Security Namespace


IPasswordManager.AreEquivalent Method

IPasswordManager AreEquivalent Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool AreEquivalent(
    HashedPassword a,
    HashedPassword b
)
bool AreEquivalent(
    HashedPassword a,
    HashedPassword b
)
Function AreEquivalent (
    a As HashedPassword,
    b As HashedPassword
) As Boolean
Function AreEquivalent (
    a As HashedPassword,
    b As HashedPassword
) As Boolean
bool AreEquivalent(
    HashedPassword^ a,
    HashedPassword^ b
)
bool AreEquivalent(
    HashedPassword^ a,
    HashedPassword^ b
)
abstract AreEquivalent :
        a : HashedPassword *
        b : HashedPassword -> bool
abstract AreEquivalent :
        a : HashedPassword *
        b : HashedPassword -> bool

Parameters

a
Type: NFX.Security HashedPassword
b
Type: NFX.Security HashedPassword

Return Value

Type: Online Boolean
See Also
IPasswordManager Interface
IPasswordManager Members
NFX.Security Namespace


IPasswordManager.CalculateStrenghtPercent Method

IPasswordManager CalculateStrenghtPercent Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int CalculateStrenghtPercent(
    PasswordFamily family,
    SecureBuffer password,
    int maxScore = 0
)
int CalculateStrenghtPercent(
    PasswordFamily family,
    SecureBuffer password,
    int maxScore = 0
)
Function CalculateStrenghtPercent (
    family As PasswordFamily,
    password As SecureBuffer,
    Optional maxScore As Integer = 0
) As Integer
Function CalculateStrenghtPercent (
    family As PasswordFamily,
    password As SecureBuffer,
    Optional maxScore As Integer = 0
) As Integer
int CalculateStrenghtPercent(
    PasswordFamily family,
    SecureBuffer^ password,
    int maxScore = 0
)
int CalculateStrenghtPercent(
    PasswordFamily family,
    SecureBuffer^ password,
    int maxScore = 0
)
abstract CalculateStrenghtPercent :
        family : PasswordFamily *
        password : SecureBuffer *
        ?maxScore : int
(* Defaults:
        let _maxScore = defaultArg maxScore 0
*)
-> int
abstract CalculateStrenghtPercent :
        family : PasswordFamily *
        password : SecureBuffer *
        ?maxScore : int
(* Defaults:
        let _maxScore = defaultArg maxScore 0
*)
-> int

Parameters

family
Type: NFX.Security PasswordFamily
password
Type: NFX.Security SecureBuffer
maxScore (Optional)
Type: Online System Int32

Return Value

Type: Online Int32
See Also
IPasswordManager Interface
IPasswordManager Members
NFX.Security Namespace


IPasswordManager.CalculateStrenghtScore Method

IPasswordManager CalculateStrenghtScore Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
int CalculateStrenghtScore(
    PasswordFamily family,
    SecureBuffer password
)
int CalculateStrenghtScore(
    PasswordFamily family,
    SecureBuffer password
)
Function CalculateStrenghtScore (
    family As PasswordFamily,
    password As SecureBuffer
) As Integer
Function CalculateStrenghtScore (
    family As PasswordFamily,
    password As SecureBuffer
) As Integer
int CalculateStrenghtScore(
    PasswordFamily family,
    SecureBuffer^ password
)
int CalculateStrenghtScore(
    PasswordFamily family,
    SecureBuffer^ password
)
abstract CalculateStrenghtScore :
        family : PasswordFamily *
        password : SecureBuffer -> int
abstract CalculateStrenghtScore :
        family : PasswordFamily *
        password : SecureBuffer -> int

Parameters

family
Type: NFX.Security PasswordFamily
password
Type: NFX.Security SecureBuffer

Return Value

Type: Online Int32
See Also
IPasswordManager Interface
IPasswordManager Members
NFX.Security Namespace


IPasswordManager.ComputeHash Method

IPasswordManager ComputeHash Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
HashedPassword ComputeHash(
    PasswordFamily family,
    SecureBuffer password,
    PasswordStrengthLevel level = PasswordStrengthLevel.Default
)
HashedPassword ComputeHash(
    PasswordFamily family,
    SecureBuffer password,
    PasswordStrengthLevel level = PasswordStrengthLevel.Default
)
Function ComputeHash (
    family As PasswordFamily,
    password As SecureBuffer,
    Optional level As PasswordStrengthLevel = PasswordStrengthLevel.Default
) As HashedPassword
Function ComputeHash (
    family As PasswordFamily,
    password As SecureBuffer,
    Optional level As PasswordStrengthLevel = PasswordStrengthLevel.Default
) As HashedPassword
HashedPassword^ ComputeHash(
    PasswordFamily family,
    SecureBuffer^ password,
    PasswordStrengthLevel level = PasswordStrengthLevel::Default
)
HashedPassword^ ComputeHash(
    PasswordFamily family,
    SecureBuffer^ password,
    PasswordStrengthLevel level = PasswordStrengthLevel::Default
)
abstract ComputeHash :
        family : PasswordFamily *
        password : SecureBuffer *
        ?level : PasswordStrengthLevel
(* Defaults:
        let _level = defaultArg level PasswordStrengthLevel.Default
*)
-> HashedPassword
abstract ComputeHash :
        family : PasswordFamily *
        password : SecureBuffer *
        ?level : PasswordStrengthLevel
(* Defaults:
        let _level = defaultArg level PasswordStrengthLevel.Default
*)
-> HashedPassword

Parameters

family
Type: NFX.Security PasswordFamily
password
Type: NFX.Security SecureBuffer
level (Optional)
Type: NFX.Security PasswordStrengthLevel

Return Value

Type: HashedPassword
See Also
IPasswordManager Interface
IPasswordManager Members
NFX.Security Namespace


IPasswordManager.GeneratePassword Method

IPasswordManager GeneratePassword Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerable<PasswordRepresentation> GeneratePassword(
    PasswordFamily family,
    PasswordRepresentationType type,
    PasswordStrengthLevel level = PasswordStrengthLevel.Default
)
IEnumerable<PasswordRepresentation> GeneratePassword(
    PasswordFamily family,
    PasswordRepresentationType type,
    PasswordStrengthLevel level = PasswordStrengthLevel.Default
)
Function GeneratePassword (
    family As PasswordFamily,
    type As PasswordRepresentationType,
    Optional level As PasswordStrengthLevel = PasswordStrengthLevel.Default
) As IEnumerable(Of PasswordRepresentation)
Function GeneratePassword (
    family As PasswordFamily,
    type As PasswordRepresentationType,
    Optional level As PasswordStrengthLevel = PasswordStrengthLevel.Default
) As IEnumerable(Of PasswordRepresentation)
IEnumerable<PasswordRepresentation^>^ GeneratePassword(
    PasswordFamily family,
    PasswordRepresentationType type,
    PasswordStrengthLevel level = PasswordStrengthLevel::Default
)
IEnumerable<PasswordRepresentation^>^ GeneratePassword(
    PasswordFamily family,
    PasswordRepresentationType type,
    PasswordStrengthLevel level = PasswordStrengthLevel::Default
)
abstract GeneratePassword :
        family : PasswordFamily *
        type : PasswordRepresentationType *
        ?level : PasswordStrengthLevel
(* Defaults:
        let _level = defaultArg level PasswordStrengthLevel.Default
*)
-> IEnumerable<PasswordRepresentation>
abstract GeneratePassword :
        family : PasswordFamily *
        type : PasswordRepresentationType *
        ?level : PasswordStrengthLevel
(* Defaults:
        let _level = defaultArg level PasswordStrengthLevel.Default
*)
-> IEnumerable<PasswordRepresentation>

Parameters

family
Type: NFX.Security PasswordFamily
type
Type: NFX.Security PasswordRepresentationType
level (Optional)
Type: NFX.Security PasswordStrengthLevel

Return Value

Type: Online IEnumerable PasswordRepresentation
See Also
IPasswordManager Interface
IPasswordManager Members
NFX.Security Namespace


IPasswordManager.Verify Method

IPasswordManager Verify Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Verify(
    SecureBuffer password,
    HashedPassword hash,
    out bool needRehash
)
bool Verify(
    SecureBuffer password,
    HashedPassword hash,
    out bool needRehash
)
Function Verify (
    password As SecureBuffer,
    hash As HashedPassword,
    <OutAttribute> ByRef needRehash As Boolean
) As Boolean
Function Verify (
    password As SecureBuffer,
    hash As HashedPassword,
    <OutAttribute> ByRef needRehash As Boolean
) As Boolean
bool Verify(
    SecureBuffer^ password,
    HashedPassword^ hash,
    [OutAttribute] bool% needRehash
)
bool Verify(
    SecureBuffer^ password,
    HashedPassword^ hash,
    [OutAttribute] bool% needRehash
)
abstract Verify :
        password : SecureBuffer *
        hash : HashedPassword *
        needRehash : bool byref -> bool
abstract Verify :
        password : SecureBuffer *
        hash : HashedPassword *
        needRehash : bool byref -> bool

Parameters

password
Type: NFX.Security SecureBuffer
hash
Type: NFX.Security HashedPassword
needRehash
Type: Online System Boolean

Return Value

Type: Online Boolean
See Also
IPasswordManager Interface
IPasswordManager Members
NFX.Security Namespace


IPasswordManager Properties

IPasswordManager Properties NFX Class Library

The IPasswordManager type exposes the following members.
Properties
 | Name | Description
Public property | Algorithms |
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Back to Top
See Also
IPasswordManager Interface
NFX.Security Namespace


IPasswordManager.Algorithms Property

IPasswordManager Algorithms Property NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IRegistry<PasswordHashingAlgorithm> Algorithms { get; }
IRegistry<PasswordHashingAlgorithm> Algorithms { get; }
ReadOnly Property Algorithms As IRegistry(Of PasswordHashingAlgorithm)
    Get
ReadOnly Property Algorithms As IRegistry(Of PasswordHashingAlgorithm)
    Get
property IRegistry<PasswordHashingAlgorithm^>^ Algorithms {
    IRegistry<PasswordHashingAlgorithm^>^ get ();
}
property IRegistry<PasswordHashingAlgorithm^>^ Algorithms {
    IRegistry<PasswordHashingAlgorithm^>^ get ();
}
abstract Algorithms : IRegistry<PasswordHashingAlgorithm> with get
abstract Algorithms : IRegistry<PasswordHashingAlgorithm> with get

Property Value

Type: IRegistry PasswordHashingAlgorithm
See Also
IPasswordManager Interface
IPasswordManager Members
NFX.Security Namespace


IPasswordManagerImplementation Interface

IPasswordManagerImplementation Interface NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IPasswordManagerImplementation : IPasswordManager,
    IApplicationComponent, IDisposable, IInstrumentable, IExternallyParameterized, IService,
    INamed, IConfigurable
public interface IPasswordManagerImplementation : IPasswordManager,
    IApplicationComponent, IDisposable, IInstrumentable, IExternallyParameterized, IService,
    INamed, IConfigurable
Public Interface IPasswordManagerImplementation
    Inherits IPasswordManager, IApplicationComponent, IDisposable, IInstrumentable,
    IExternallyParameterized, IService, INamed, IConfigurable
Public Interface IPasswordManagerImplementation
    Inherits IPasswordManager, IApplicationComponent, IDisposable, IInstrumentable,
    IExternallyParameterized, IService, INamed, IConfigurable
public interface class IPasswordManagerImplementation : IPasswordManager,
    IApplicationComponent, IDisposable, IInstrumentable, IExternallyParameterized, IService,
    INamed, IConfigurable
public interface class IPasswordManagerImplementation : IPasswordManager,
    IApplicationComponent, IDisposable, IInstrumentable, IExternallyParameterized, IService,
    INamed, IConfigurable
type IPasswordManagerImplementation =
    interface
        interface IPasswordManager
        interface IApplicationComponent
        interface IDisposable
        interface IInstrumentable
        interface IExternallyParameterized
        interface IService
        interface INamed
        interface IConfigurable
    end
type IPasswordManagerImplementation =
    interface
        interface IPasswordManager
        interface IApplicationComponent
        interface IDisposable
        interface IInstrumentable
        interface IExternallyParameterized
        interface IService
        interface INamed
        interface IConfigurable
    end
See Also
IPasswordManagerImplementation Members
NFX.Security Namespace


IPasswordManagerImplementation Members

IPasswordManagerImplementation Members NFX Class Library

The IPasswordManagerImplementation type exposes the following members.
Methods
 | Name | Description
Public method | AreEquivalent | (Inherited from IPasswordManager.)
Public method | CalculateStrenghtPercent | (Inherited from IPasswordManager.)
Public method | CalculateStrenghtScore | (Inherited from IPasswordManager.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from IService.)
Public method | ComputeHash | (Inherited from IPasswordManager.)
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Public method | GeneratePassword | (Inherited from IPasswordManager.)
Public method | Register |
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from IService.)
Public method | Start | Blocking call that starts the service instance (Inherited from IService.)
Public method | Unregister(String) |
Public method | Unregister(PasswordHashingAlgorithm) |
Public method | Verify | (Inherited from IPasswordManager.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from IService.)
Back to Top
Properties
 | Name | Description
Public property | Algorithms | (Inherited from IPasswordManager.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | Name | (Inherited from INamed.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from IService.)
Public property | Status | Current service status (Inherited from IService.)
Back to Top
See Also
IPasswordManagerImplementation Interface
NFX.Security Namespace


IPasswordManagerImplementation Methods

IPasswordManagerImplementation Methods NFX Class Library

The IPasswordManagerImplementation type exposes the following members.
Methods
 | Name | Description
Public method | AreEquivalent | (Inherited from IPasswordManager.)
Public method | CalculateStrenghtPercent | (Inherited from IPasswordManager.)
Public method | CalculateStrenghtScore | (Inherited from IPasswordManager.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from IService.)
Public method | ComputeHash | (Inherited from IPasswordManager.)
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from IExternallyParameterized.)
Public method | ExternalParametersForGroups | Gets names of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public method | ExternalSetParameter | Sets external parameter value, true if parameter name was found and set succeeded (Inherited from IExternallyParameterized.)
Public method | GeneratePassword | (Inherited from IPasswordManager.)
Public method | Register |
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from IService.)
Public method | Start | Blocking call that starts the service instance (Inherited from IService.)
Public method | Unregister(String) |
Public method | Unregister(PasswordHashingAlgorithm) |
Public method | Verify | (Inherited from IPasswordManager.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from IService.)
Back to Top
See Also
IPasswordManagerImplementation Interface
NFX.Security Namespace


IPasswordManagerImplementation.Register Method

IPasswordManagerImplementation Register Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Register(
    PasswordHashingAlgorithm algo
)
bool Register(
    PasswordHashingAlgorithm algo
)
Function Register (
    algo As PasswordHashingAlgorithm
) As Boolean
Function Register (
    algo As PasswordHashingAlgorithm
) As Boolean
bool Register(
    PasswordHashingAlgorithm^ algo
)
bool Register(
    PasswordHashingAlgorithm^ algo
)
abstract Register :
        algo : PasswordHashingAlgorithm -> bool
abstract Register :
        algo : PasswordHashingAlgorithm -> bool

Parameters

algo
Type: NFX.Security PasswordHashingAlgorithm

Return Value

Type: Online Boolean
See Also
IPasswordManagerImplementation Interface
IPasswordManagerImplementation Members
NFX.Security Namespace


IPasswordManagerImplementation.Unregister Method

IPasswordManagerImplementation Unregister Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public method | Unregister(String) |
Public method | Unregister(PasswordHashingAlgorithm) |
Back to Top
See Also
IPasswordManagerImplementation Interface
IPasswordManagerImplementation Members
NFX.Security Namespace


IPasswordManagerImplementation.Unregister Method (String)

IPasswordManagerImplementation Unregister Method (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Unregister(
    string algoName
)
bool Unregister(
    string algoName
)
Function Unregister (
    algoName As String
) As Boolean
Function Unregister (
    algoName As String
) As Boolean
bool Unregister(
    String^ algoName
)
bool Unregister(
    String^ algoName
)
abstract Unregister :
        algoName : string -> bool
abstract Unregister :
        algoName : string -> bool

Parameters

algoName
Type: Online System String

Return Value

Type: Online Boolean
See Also
IPasswordManagerImplementation Interface
IPasswordManagerImplementation Members
Unregister Overload
NFX.Security Namespace


IPasswordManagerImplementation.Unregister Method (PasswordHashingAlgorithm)

IPasswordManagerImplementation Unregister Method (PasswordHashingAlgorithm) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Unregister(
    PasswordHashingAlgorithm algo
)
bool Unregister(
    PasswordHashingAlgorithm algo
)
Function Unregister (
    algo As PasswordHashingAlgorithm
) As Boolean
Function Unregister (
    algo As PasswordHashingAlgorithm
) As Boolean
bool Unregister(
    PasswordHashingAlgorithm^ algo
)
bool Unregister(
    PasswordHashingAlgorithm^ algo
)
abstract Unregister :
        algo : PasswordHashingAlgorithm -> bool
abstract Unregister :
        algo : PasswordHashingAlgorithm -> bool

Parameters

algo
Type: NFX.Security PasswordHashingAlgorithm

Return Value

Type: Online Boolean
See Also
IPasswordManagerImplementation Interface
IPasswordManagerImplementation Members
Unregister Overload
NFX.Security Namespace


IPasswordManagerImplementation Properties

IPasswordManagerImplementation Properties NFX Class Library

The IPasswordManagerImplementation type exposes the following members.
Properties
 | Name | Description
Public property | Algorithms | (Inherited from IPasswordManager.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | ExternalParameters | Gets names/types of supported external parameters or null if parameters are not supported in principle (Inherited from IExternallyParameterized.)
Public property | InstrumentationEnabled | Turns on/off instrumentation (Inherited from IInstrumentable.)
Public property | Name | (Inherited from INamed.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from IService.)
Public property | Status | Current service status (Inherited from IService.)
Back to Top
See Also
IPasswordManagerImplementation Interface
NFX.Security Namespace


ISecurityException Interface

ISecurityException Interface NFX Class Library

Marker interface for security exceptions

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ISecurityException
public interface ISecurityException
Public Interface ISecurityException
Public Interface ISecurityException
public interface class ISecurityException
public interface class ISecurityException
type ISecurityException =  interface end
type ISecurityException =  interface end
See Also
NFX.Security Namespace


ISecurityManager Interface

ISecurityManager Interface NFX Class Library

Represents an entity that performs user authentication based on passed credentials and other security-related global tasks

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ISecurityManager : IApplicationComponent,
    IDisposable
public interface ISecurityManager : IApplicationComponent,
    IDisposable
Public Interface ISecurityManager
    Inherits IApplicationComponent, IDisposable
Public Interface ISecurityManager
    Inherits IApplicationComponent, IDisposable
public interface class ISecurityManager : IApplicationComponent,
    IDisposable
public interface class ISecurityManager : IApplicationComponent,
    IDisposable
type ISecurityManager =
    interface
        interface IApplicationComponent
        interface IDisposable
    end
type ISecurityManager =
    interface
        interface IApplicationComponent
        interface IDisposable
    end
See Also
ISecurityManager Members
NFX.Security Namespace


ISecurityManager Members

ISecurityManager Members NFX Class Library

The ISecurityManager type exposes the following members.
Methods
 | Name | Description
Public method | Authenticate(AuthenticationToken) | Authenticates user by checking the supplied token against the authentication store that this manager represents. If token is invalid then UserKind.Invalid is returned. This method may populate user access rights completely or partially - depending on store implementation. If rights are computed on authentication than Authorize() just checks existing in-memory structure, otherwise Authorize() may re-fetch permissions from store on every call or cache them for the specified interval in memory
Public method | Authenticate(Credentials) | Authenticates user by checking the supplied credentials against the authentication store that this manager represents. If credential are invalid then UserKind.Invalid is returned. This method may populate user access rights completely or partially - depending on store implementation. If rights are computed on authentication than Authorize() just checks existing in-memory structure, otherwise Authorize() may re-fetch permissions from store on every call or cache them for the specified interval in memory
Public method | Authenticate(User) | Authenticates user by checking the supplied user's token against the authentication store that this manager represents. This method is called by the framework after User object was deserialized and it's Rights need to be re-fetched. If token is invalid then UserStatus.Invalid is set. This method may populate user access rights completely or partially - depending on store implementation. If rights are computed on authentication than Authorize() just checks existing in-memory structure, otherwise Authorize() may re-fetch permissions from store on every call or cache them for the specified interval in memory
Public method | Authorize | Authorizes user by finding appropriate access level to permission by supplied path. Depending on particular implementation, rights may be fully or partially cached in memory. Note: this authorization call returns AccessLevel object that may contain a complex data structure. The final assertion of user's ability to perform a certain action is encapsulated in Permission.Check() method. Call Permission.AuthorizeAndGuardAction(MemberInfo, ISession) to guard classes and methods from unauthorized access
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | PasswordManager |
Back to Top
See Also
ISecurityManager Interface
NFX.Security Namespace


ISecurityManager Methods

ISecurityManager Methods NFX Class Library

The ISecurityManager type exposes the following members.
Methods
 | Name | Description
Public method | Authenticate(AuthenticationToken) | Authenticates user by checking the supplied token against the authentication store that this manager represents. If token is invalid then UserKind.Invalid is returned. This method may populate user access rights completely or partially - depending on store implementation. If rights are computed on authentication than Authorize() just checks existing in-memory structure, otherwise Authorize() may re-fetch permissions from store on every call or cache them for the specified interval in memory
Public method | Authenticate(Credentials) | Authenticates user by checking the supplied credentials against the authentication store that this manager represents. If credential are invalid then UserKind.Invalid is returned. This method may populate user access rights completely or partially - depending on store implementation. If rights are computed on authentication than Authorize() just checks existing in-memory structure, otherwise Authorize() may re-fetch permissions from store on every call or cache them for the specified interval in memory
Public method | Authenticate(User) | Authenticates user by checking the supplied user's token against the authentication store that this manager represents. This method is called by the framework after User object was deserialized and it's Rights need to be re-fetched. If token is invalid then UserStatus.Invalid is set. This method may populate user access rights completely or partially - depending on store implementation. If rights are computed on authentication than Authorize() just checks existing in-memory structure, otherwise Authorize() may re-fetch permissions from store on every call or cache them for the specified interval in memory
Public method | Authorize | Authorizes user by finding appropriate access level to permission by supplied path. Depending on particular implementation, rights may be fully or partially cached in memory. Note: this authorization call returns AccessLevel object that may contain a complex data structure. The final assertion of user's ability to perform a certain action is encapsulated in Permission.Check() method. Call Permission.AuthorizeAndGuardAction(MemberInfo, ISession) to guard classes and methods from unauthorized access
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Back to Top
See Also
ISecurityManager Interface
NFX.Security Namespace


ISecurityManager.Authenticate Method

ISecurityManager Authenticate Method NFX Class Library

Overload List
 | Name | Description
Public method | Authenticate(AuthenticationToken) | Authenticates user by checking the supplied token against the authentication store that this manager represents. If token is invalid then UserKind.Invalid is returned. This method may populate user access rights completely or partially - depending on store implementation. If rights are computed on authentication than Authorize() just checks existing in-memory structure, otherwise Authorize() may re-fetch permissions from store on every call or cache them for the specified interval in memory
Public method | Authenticate(Credentials) | Authenticates user by checking the supplied credentials against the authentication store that this manager represents. If credential are invalid then UserKind.Invalid is returned. This method may populate user access rights completely or partially - depending on store implementation. If rights are computed on authentication than Authorize() just checks existing in-memory structure, otherwise Authorize() may re-fetch permissions from store on every call or cache them for the specified interval in memory
Public method | Authenticate(User) | Authenticates user by checking the supplied user's token against the authentication store that this manager represents. This method is called by the framework after User object was deserialized and it's Rights need to be re-fetched. If token is invalid then UserStatus.Invalid is set. This method may populate user access rights completely or partially - depending on store implementation. If rights are computed on authentication than Authorize() just checks existing in-memory structure, otherwise Authorize() may re-fetch permissions from store on every call or cache them for the specified interval in memory
Back to Top
See Also
ISecurityManager Interface
ISecurityManager Members
NFX.Security Namespace


ISecurityManager.Authenticate Method (AuthenticationToken)

ISecurityManager Authenticate Method (AuthenticationToken) NFX Class Library

[This is preliminary documentation and is subject to change.]

Authenticates user by checking the supplied token against the authentication store that this manager represents. If token is invalid then UserKind.Invalid is returned. This method may populate user access rights completely or partially - depending on store implementation. If rights are computed on authentication than Authorize() just checks existing in-memory structure, otherwise Authorize() may re-fetch permissions from store on every call or cache them for the specified interval in memory

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
User Authenticate(
    AuthenticationToken token
)
User Authenticate(
    AuthenticationToken token
)
Function Authenticate (
    token As AuthenticationToken
) As User
Function Authenticate (
    token As AuthenticationToken
) As User
User^ Authenticate(
    AuthenticationToken token
)
User^ Authenticate(
    AuthenticationToken token
)
abstract Authenticate :
        token : AuthenticationToken -> User
abstract Authenticate :
        token : AuthenticationToken -> User

Parameters

token
Type: NFX.Security AuthenticationToken
User authentication token

Return Value

Type: User
User object. Check User.Status for UserStatus.Invalid flag to see if authentication succeeded
See Also
ISecurityManager Interface
ISecurityManager Members
Authenticate Overload
NFX.Security Namespace


ISecurityManager.Authenticate Method (Credentials)

ISecurityManager Authenticate Method (Credentials) NFX Class Library

[This is preliminary documentation and is subject to change.]

Authenticates user by checking the supplied credentials against the authentication store that this manager represents. If credential are invalid then UserKind.Invalid is returned. This method may populate user access rights completely or partially - depending on store implementation. If rights are computed on authentication than Authorize() just checks existing in-memory structure, otherwise Authorize() may re-fetch permissions from store on every call or cache them for the specified interval in memory

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
User Authenticate(
    Credentials credentials
)
User Authenticate(
    Credentials credentials
)
Function Authenticate (
    credentials As Credentials
) As User
Function Authenticate (
    credentials As Credentials
) As User
User^ Authenticate(
    Credentials^ credentials
)
User^ Authenticate(
    Credentials^ credentials
)
abstract Authenticate :
        credentials : Credentials -> User
abstract Authenticate :
        credentials : Credentials -> User

Parameters

credentials
Type: NFX.Security Credentials
User credentials. Particular manager implementation may elect to support multiple credential types, i.e. IdPassword, Twitter, Facebook, OAuth, LegacySystemA/B/C etc.

Return Value

Type: User
User object. Check User.Status for UserStatus.Invalid flag to see if authentication succeeded
See Also
ISecurityManager Interface
ISecurityManager Members
Authenticate Overload
NFX.Security Namespace


ISecurityManager.Authenticate Method (User)

ISecurityManager Authenticate Method (User) NFX Class Library

[This is preliminary documentation and is subject to change.]

Authenticates user by checking the supplied user's token against the authentication store that this manager represents. This method is called by the framework after User object was deserialized and it's Rights need to be re-fetched. If token is invalid then UserStatus.Invalid is set. This method may populate user access rights completely or partially - depending on store implementation. If rights are computed on authentication than Authorize() just checks existing in-memory structure, otherwise Authorize() may re-fetch permissions from store on every call or cache them for the specified interval in memory

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Authenticate(
    User user
)
void Authenticate(
    User user
)
Sub Authenticate (
    user As User
)
Sub Authenticate (
    user As User
)
void Authenticate(
    User^ user
)
void Authenticate(
    User^ user
)
abstract Authenticate :
        user : User -> unit
abstract Authenticate :
        user : User -> unit

Parameters

user
Type: NFX.Security User
User object which is checked and updated
See Also
ISecurityManager Interface
ISecurityManager Members
Authenticate Overload
NFX.Security Namespace


ISecurityManager.Authorize Method

ISecurityManager Authorize Method NFX Class Library

Authorizes user by finding appropriate access level to permission by supplied path. Depending on particular implementation, rights may be fully or partially cached in memory. Note: this authorization call returns AccessLevel object that may contain a complex data structure. The final assertion of user's ability to perform a certain action is encapsulated in Permission.Check() method. Call Permission.AuthorizeAndGuardAction(MemberInfo, ISession) to guard classes and methods from unauthorized access

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
AccessLevel Authorize(
    User user,
    Permission permission
)
AccessLevel Authorize(
    User user,
    Permission permission
)
Function Authorize (
    user As User,
    permission As Permission
) As AccessLevel
Function Authorize (
    user As User,
    permission As Permission
) As AccessLevel
AccessLevel^ Authorize(
    User^ user,
    Permission^ permission
)
AccessLevel^ Authorize(
    User^ user,
    Permission^ permission
)
abstract Authorize :
        user : User *
        permission : Permission -> AccessLevel
abstract Authorize :
        user : User *
        permission : Permission -> AccessLevel

Parameters

user
Type: NFX.Security User
A user to perform authorization for
permission
Type: NFX.Security Permission
An instance of permission to get

Return Value

Type: AccessLevel
AccessLevel granted to specified permission
See Also
ISecurityManager Interface
ISecurityManager Members
NFX.Security Namespace


ISecurityManager Properties

ISecurityManager Properties NFX Class Library

The ISecurityManager type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | PasswordManager |
Back to Top
See Also
ISecurityManager Interface
NFX.Security Namespace


ISecurityManager.PasswordManager Property

ISecurityManager PasswordManager Property NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IPasswordManager PasswordManager { get; }
IPasswordManager PasswordManager { get; }
ReadOnly Property PasswordManager As IPasswordManager
    Get
ReadOnly Property PasswordManager As IPasswordManager
    Get
property IPasswordManager^ PasswordManager {
    IPasswordManager^ get ();
}
property IPasswordManager^ PasswordManager {
    IPasswordManager^ get ();
}
abstract PasswordManager : IPasswordManager with get
abstract PasswordManager : IPasswordManager with get

Property Value

Type: IPasswordManager
See Also
ISecurityManager Interface
ISecurityManager Members
NFX.Security Namespace


ISecurityManagerImplementation Interface

ISecurityManagerImplementation Interface NFX Class Library

Represents an implementation of an entity that performs user authentication based on passed credentials and other security-related global tasks

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ISecurityManagerImplementation : ISecurityManager,
    IApplicationComponent, IDisposable, IConfigurable
public interface ISecurityManagerImplementation : ISecurityManager,
    IApplicationComponent, IDisposable, IConfigurable
Public Interface ISecurityManagerImplementation
    Inherits ISecurityManager, IApplicationComponent, IDisposable, IConfigurable
Public Interface ISecurityManagerImplementation
    Inherits ISecurityManager, IApplicationComponent, IDisposable, IConfigurable
public interface class ISecurityManagerImplementation : ISecurityManager,
    IApplicationComponent, IDisposable, IConfigurable
public interface class ISecurityManagerImplementation : ISecurityManager,
    IApplicationComponent, IDisposable, IConfigurable
type ISecurityManagerImplementation =
    interface
        interface ISecurityManager
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
    end
type ISecurityManagerImplementation =
    interface
        interface ISecurityManager
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
    end
See Also
ISecurityManagerImplementation Members
NFX.Security Namespace


ISecurityManagerImplementation Members

ISecurityManagerImplementation Members NFX Class Library

The ISecurityManagerImplementation type exposes the following members.
Methods
 | Name | Description
Public method | Authenticate(AuthenticationToken) | Authenticates user by checking the supplied token against the authentication store that this manager represents. If token is invalid then UserKind.Invalid is returned. This method may populate user access rights completely or partially - depending on store implementation. If rights are computed on authentication than Authorize() just checks existing in-memory structure, otherwise Authorize() may re-fetch permissions from store on every call or cache them for the specified interval in memory (Inherited from ISecurityManager.)
Public method | Authenticate(Credentials) | Authenticates user by checking the supplied credentials against the authentication store that this manager represents. If credential are invalid then UserKind.Invalid is returned. This method may populate user access rights completely or partially - depending on store implementation. If rights are computed on authentication than Authorize() just checks existing in-memory structure, otherwise Authorize() may re-fetch permissions from store on every call or cache them for the specified interval in memory (Inherited from ISecurityManager.)
Public method | Authenticate(User) | Authenticates user by checking the supplied user's token against the authentication store that this manager represents. This method is called by the framework after User object was deserialized and it's Rights need to be re-fetched. If token is invalid then UserStatus.Invalid is set. This method may populate user access rights completely or partially - depending on store implementation. If rights are computed on authentication than Authorize() just checks existing in-memory structure, otherwise Authorize() may re-fetch permissions from store on every call or cache them for the specified interval in memory (Inherited from ISecurityManager.)
Public method | Authorize | Authorizes user by finding appropriate access level to permission by supplied path. Depending on particular implementation, rights may be fully or partially cached in memory. Note: this authorization call returns AccessLevel object that may contain a complex data structure. The final assertion of user's ability to perform a certain action is encapsulated in Permission.Check() method. Call Permission.AuthorizeAndGuardAction(MemberInfo, ISession) to guard classes and methods from unauthorized access (Inherited from ISecurityManager.)
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | PasswordManager | (Inherited from ISecurityManager.)
Back to Top
See Also
ISecurityManagerImplementation Interface
NFX.Security Namespace


ISecurityManagerImplementation Methods

ISecurityManagerImplementation Methods NFX Class Library

The ISecurityManagerImplementation type exposes the following members.
Methods
 | Name | Description
Public method | Authenticate(AuthenticationToken) | Authenticates user by checking the supplied token against the authentication store that this manager represents. If token is invalid then UserKind.Invalid is returned. This method may populate user access rights completely or partially - depending on store implementation. If rights are computed on authentication than Authorize() just checks existing in-memory structure, otherwise Authorize() may re-fetch permissions from store on every call or cache them for the specified interval in memory (Inherited from ISecurityManager.)
Public method | Authenticate(Credentials) | Authenticates user by checking the supplied credentials against the authentication store that this manager represents. If credential are invalid then UserKind.Invalid is returned. This method may populate user access rights completely or partially - depending on store implementation. If rights are computed on authentication than Authorize() just checks existing in-memory structure, otherwise Authorize() may re-fetch permissions from store on every call or cache them for the specified interval in memory (Inherited from ISecurityManager.)
Public method | Authenticate(User) | Authenticates user by checking the supplied user's token against the authentication store that this manager represents. This method is called by the framework after User object was deserialized and it's Rights need to be re-fetched. If token is invalid then UserStatus.Invalid is set. This method may populate user access rights completely or partially - depending on store implementation. If rights are computed on authentication than Authorize() just checks existing in-memory structure, otherwise Authorize() may re-fetch permissions from store on every call or cache them for the specified interval in memory (Inherited from ISecurityManager.)
Public method | Authorize | Authorizes user by finding appropriate access level to permission by supplied path. Depending on particular implementation, rights may be fully or partially cached in memory. Note: this authorization call returns AccessLevel object that may contain a complex data structure. The final assertion of user's ability to perform a certain action is encapsulated in Permission.Check() method. Call Permission.AuthorizeAndGuardAction(MemberInfo, ISession) to guard classes and methods from unauthorized access (Inherited from ISecurityManager.)
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Back to Top
See Also
ISecurityManagerImplementation Interface
NFX.Security Namespace


ISecurityManagerImplementation Properties

ISecurityManagerImplementation Properties NFX Class Library

The ISecurityManagerImplementation type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from IApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from IApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from IApplicationComponent.)
Public property | PasswordManager | (Inherited from ISecurityManager.)
Back to Top
See Also
ISecurityManagerImplementation Interface
NFX.Security Namespace


IStringRepresentableCredentials Interface

IStringRepresentableCredentials Interface NFX Class Library

Denotes credentials that can be represented as a string that can be used for example in Authorization header

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IStringRepresentableCredentials
public interface IStringRepresentableCredentials
Public Interface IStringRepresentableCredentials
Public Interface IStringRepresentableCredentials
public interface class IStringRepresentableCredentials
public interface class IStringRepresentableCredentials
type IStringRepresentableCredentials =  interface end
type IStringRepresentableCredentials =  interface end
See Also
IStringRepresentableCredentials Members
NFX.Security Namespace


IStringRepresentableCredentials Members

IStringRepresentableCredentials Members NFX Class Library

The IStringRepresentableCredentials type exposes the following members.
Methods
 | Name | Description
Public method | Forget |
Public method | RepresentAsString |
Back to Top
Properties
 | Name | Description
Public property | Forgotten |
Back to Top
See Also
IStringRepresentableCredentials Interface
NFX.Security Namespace


IStringRepresentableCredentials Methods

IStringRepresentableCredentials Methods NFX Class Library

The IStringRepresentableCredentials type exposes the following members.
Methods
 | Name | Description
Public method | Forget |
Public method | RepresentAsString |
Back to Top
See Also
IStringRepresentableCredentials Interface
NFX.Security Namespace


IStringRepresentableCredentials.Forget Method

IStringRepresentableCredentials Forget Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Forget()
void Forget()
Sub Forget
Sub Forget
void Forget()
void Forget()
abstract Forget : unit -> unit
abstract Forget : unit -> unit
See Also
IStringRepresentableCredentials Interface
IStringRepresentableCredentials Members
NFX.Security Namespace


IStringRepresentableCredentials.RepresentAsString Method

IStringRepresentableCredentials RepresentAsString Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string RepresentAsString()
string RepresentAsString()
Function RepresentAsString As String
Function RepresentAsString As String
String^ RepresentAsString()
String^ RepresentAsString()
abstract RepresentAsString : unit -> string
abstract RepresentAsString : unit -> string

Return Value

Type: Online String
See Also
IStringRepresentableCredentials Interface
IStringRepresentableCredentials Members
NFX.Security Namespace


IStringRepresentableCredentials Properties

IStringRepresentableCredentials Properties NFX Class Library

The IStringRepresentableCredentials type exposes the following members.
Properties
 | Name | Description
Public property | Forgotten |
Back to Top
See Also
IStringRepresentableCredentials Interface
NFX.Security Namespace


IStringRepresentableCredentials.Forgotten Property

IStringRepresentableCredentials Forgotten Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Forgotten { get; }
bool Forgotten { get; }
ReadOnly Property Forgotten As Boolean
    Get
ReadOnly Property Forgotten As Boolean
    Get
property bool Forgotten {
    bool get ();
}
property bool Forgotten {
    bool get ();
}
abstract Forgotten : bool with get
abstract Forgotten : bool with get

Property Value

Type: Online Boolean
See Also
IStringRepresentableCredentials Interface
IStringRepresentableCredentials Members
NFX.Security Namespace


MD5PasswordHashingAlgorithm Class

MD5PasswordHashingAlgorithm Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service IPasswordManagerImplementation
NFX.ServiceModel ServiceWithInstrumentationBase IPasswordManagerImplementation
NFX.Security PasswordHashingAlgorithm
NFX.Security PasswordHashingAlgorithm MD5PasswordHashingOptions
NFX.Security MD5PasswordHashingAlgorithm

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MD5PasswordHashingAlgorithm : PasswordHashingAlgorithm<MD5PasswordHashingOptions>
public class MD5PasswordHashingAlgorithm : PasswordHashingAlgorithm<MD5PasswordHashingOptions>
Public Class MD5PasswordHashingAlgorithm
    Inherits PasswordHashingAlgorithm(Of MD5PasswordHashingOptions)
Public Class MD5PasswordHashingAlgorithm
    Inherits PasswordHashingAlgorithm(Of MD5PasswordHashingOptions)
public ref class MD5PasswordHashingAlgorithm : public PasswordHashingAlgorithm<MD5PasswordHashingOptions>
public ref class MD5PasswordHashingAlgorithm : public PasswordHashingAlgorithm<MD5PasswordHashingOptions>
type MD5PasswordHashingAlgorithm =
    class
        inherit PasswordHashingAlgorithm<MD5PasswordHashingOptions>
    end
type MD5PasswordHashingAlgorithm =
    class
        inherit PasswordHashingAlgorithm<MD5PasswordHashingOptions>
    end
See Also
MD5PasswordHashingAlgorithm Members
NFX.Security Namespace


MD5PasswordHashingAlgorithm Members

MD5PasswordHashingAlgorithm Members NFX Class Library

The MD5PasswordHashingAlgorithm type exposes the following members.
Constructors
 | Name | Description
Public method | MD5PasswordHashingAlgorithm | Initializes a new instance of the MD5PasswordHashingAlgorithm class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | AreEquivalent | (Inherited from PasswordHashingAlgorithm.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | ComputeHash(PasswordFamily, SecureBuffer) | (Inherited from PasswordHashingAlgorithm.)
Public method | ComputeHash(PasswordFamily, SecureBuffer, TOptions) | (Inherited from PasswordHashingAlgorithm TOptions .)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoAreEquivalent | (Overrides PasswordHashingAlgorithm DoAreEquivalent(HashedPassword, HashedPassword).)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoComputeHash(PasswordFamily, SecureBuffer) | (Inherited from PasswordHashingAlgorithm TOptions .)
Protected method | DoComputeHash(PasswordFamily, SecureBuffer, MD5PasswordHashingOptions) | (Overrides PasswordHashingAlgorithm TOptions DoComputeHash(PasswordFamily, SecureBuffer, TOptions).)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoExtractPasswordHashingOptions | (Overrides PasswordHashingAlgorithm TOptions DoExtractPasswordHashingOptions(HashedPassword, Boolean ).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoVerify | (Inherited from PasswordHashingAlgorithm TOptions .)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExtractPasswordHashingOptions | (Inherited from PasswordHashingAlgorithm TOptions .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Public method | Match | (Inherited from PasswordHashingAlgorithm.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | Verify | (Inherited from PasswordHashingAlgorithm.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
DEFAULT_SALT_MAX_LENGTH |
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Protected property | DefaultPasswordHashingOptions | (Overrides PasswordHashingAlgorithm TOptions DefaultPasswordHashingOptions.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | InstrumentationEnabled | (Inherited from PasswordHashingAlgorithm.)
Public property | IsDefault | (Inherited from PasswordHashingAlgorithm.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | SaltMaxLenght |
Public property | SaltMinLenght |
Public property | Status | Current service status (Inherited from Service.)
Public property | StrengthLevel | (Inherited from PasswordHashingAlgorithm.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
MD5PasswordHashingAlgorithm Class
NFX.Security Namespace


MD5PasswordHashingAlgorithm Constructor

MD5PasswordHashingAlgorithm Constructor NFX Class Library

Initializes a new instance of the MD5PasswordHashingAlgorithm class

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MD5PasswordHashingAlgorithm(
    IPasswordManagerImplementation director,
    string name
)
public MD5PasswordHashingAlgorithm(
    IPasswordManagerImplementation director,
    string name
)
Public Sub New (
    director As IPasswordManagerImplementation,
    name As String
)
Public Sub New (
    director As IPasswordManagerImplementation,
    name As String
)
public:
MD5PasswordHashingAlgorithm(
    IPasswordManagerImplementation^ director,
    String^ name
)
public:
MD5PasswordHashingAlgorithm(
    IPasswordManagerImplementation^ director,
    String^ name
)
new :
        director : IPasswordManagerImplementation *
        name : string -> MD5PasswordHashingAlgorithm
new :
        director : IPasswordManagerImplementation *
        name : string -> MD5PasswordHashingAlgorithm

Parameters

director
Type: NFX.Security IPasswordManagerImplementation
name
Type: Online System String
See Also
MD5PasswordHashingAlgorithm Class
MD5PasswordHashingAlgorithm Members
NFX.Security Namespace


MD5PasswordHashingAlgorithm Fields

MD5PasswordHashingAlgorithm Fields NFX Class Library

The MD5PasswordHashingAlgorithm type exposes the following members.
Fields
Name | Description
DEFAULT_SALT_MAX_LENGTH |
Back to Top
See Also
MD5PasswordHashingAlgorithm Class
NFX.Security Namespace


MD5PasswordHashingAlgorithm.DEFAULT_SALT_MAX_LENGTH Field

MD5PasswordHashingAlgorithm DEFAULT_SALT_MAX_LENGTH Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_SALT_MAX_LENGTH
public const int DEFAULT_SALT_MAX_LENGTH
Public Const DEFAULT_SALT_MAX_LENGTH As Integer
Public Const DEFAULT_SALT_MAX_LENGTH As Integer
public:
literal int DEFAULT_SALT_MAX_LENGTH
public:
literal int DEFAULT_SALT_MAX_LENGTH
static val mutable DEFAULT_SALT_MAX_LENGTH: int
static val mutable DEFAULT_SALT_MAX_LENGTH: int

Field Value

Type: Online Int32
See Also
MD5PasswordHashingAlgorithm Class
MD5PasswordHashingAlgorithm Members
NFX.Security Namespace


MD5PasswordHashingAlgorithm Methods

MD5PasswordHashingAlgorithm Methods NFX Class Library

The MD5PasswordHashingAlgorithm type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | AreEquivalent | (Inherited from PasswordHashingAlgorithm.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | ComputeHash(PasswordFamily, SecureBuffer) | (Inherited from PasswordHashingAlgorithm.)
Public method | ComputeHash(PasswordFamily, SecureBuffer, TOptions) | (Inherited from PasswordHashingAlgorithm TOptions .)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoAreEquivalent | (Overrides PasswordHashingAlgorithm DoAreEquivalent(HashedPassword, HashedPassword).)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoComputeHash(PasswordFamily, SecureBuffer) | (Inherited from PasswordHashingAlgorithm TOptions .)
Protected method | DoComputeHash(PasswordFamily, SecureBuffer, MD5PasswordHashingOptions) | (Overrides PasswordHashingAlgorithm TOptions DoComputeHash(PasswordFamily, SecureBuffer, TOptions).)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoExtractPasswordHashingOptions | (Overrides PasswordHashingAlgorithm TOptions DoExtractPasswordHashingOptions(HashedPassword, Boolean ).)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoVerify | (Inherited from PasswordHashingAlgorithm TOptions .)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExtractPasswordHashingOptions | (Inherited from PasswordHashingAlgorithm TOptions .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Public method | Match | (Inherited from PasswordHashingAlgorithm.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | Verify | (Inherited from PasswordHashingAlgorithm.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MD5PasswordHashingAlgorithm Class
NFX.Security Namespace


MD5PasswordHashingAlgorithm.DoAreEquivalent Method

MD5PasswordHashingAlgorithm DoAreEquivalent Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool DoAreEquivalent(
    HashedPassword hash,
    HashedPassword rehash
)
protected override bool DoAreEquivalent(
    HashedPassword hash,
    HashedPassword rehash
)
Protected Overrides Function DoAreEquivalent (
    hash As HashedPassword,
    rehash As HashedPassword
) As Boolean
Protected Overrides Function DoAreEquivalent (
    hash As HashedPassword,
    rehash As HashedPassword
) As Boolean
protected:
virtual bool DoAreEquivalent(
    HashedPassword^ hash,
    HashedPassword^ rehash
) override
protected:
virtual bool DoAreEquivalent(
    HashedPassword^ hash,
    HashedPassword^ rehash
) override
abstract DoAreEquivalent :
        hash : HashedPassword *
        rehash : HashedPassword -> bool
override DoAreEquivalent :
        hash : HashedPassword *
        rehash : HashedPassword -> bool
abstract DoAreEquivalent :
        hash : HashedPassword *
        rehash : HashedPassword -> bool
override DoAreEquivalent :
        hash : HashedPassword *
        rehash : HashedPassword -> bool

Parameters

hash
Type: NFX.Security HashedPassword
rehash
Type: NFX.Security HashedPassword

Return Value

Type: Online Boolean
See Also
MD5PasswordHashingAlgorithm Class
MD5PasswordHashingAlgorithm Members
NFX.Security Namespace


MD5PasswordHashingAlgorithm.DoComputeHash Method

MD5PasswordHashingAlgorithm DoComputeHash Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Protected method | DoComputeHash(PasswordFamily, SecureBuffer) | (Inherited from PasswordHashingAlgorithm TOptions .)
Protected method | DoComputeHash(PasswordFamily, SecureBuffer, MD5PasswordHashingOptions) | (Overrides PasswordHashingAlgorithm TOptions DoComputeHash(PasswordFamily, SecureBuffer, TOptions).)
Back to Top
See Also
MD5PasswordHashingAlgorithm Class
MD5PasswordHashingAlgorithm Members
NFX.Security Namespace


MD5PasswordHashingAlgorithm.DoComputeHash Method (PasswordFamily, SecureBuffer, MD5PasswordHashingOptions)

MD5PasswordHashingAlgorithm DoComputeHash Method (PasswordFamily, SecureBuffer, MD5PasswordHashingOptions) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override HashedPassword DoComputeHash(
    PasswordFamily family,
    SecureBuffer password,
    MD5PasswordHashingOptions options
)
protected override HashedPassword DoComputeHash(
    PasswordFamily family,
    SecureBuffer password,
    MD5PasswordHashingOptions options
)
Protected Overrides Function DoComputeHash (
    family As PasswordFamily,
    password As SecureBuffer,
    options As MD5PasswordHashingOptions
) As HashedPassword
Protected Overrides Function DoComputeHash (
    family As PasswordFamily,
    password As SecureBuffer,
    options As MD5PasswordHashingOptions
) As HashedPassword
protected:
virtual HashedPassword^ DoComputeHash(
    PasswordFamily family,
    SecureBuffer^ password,
    MD5PasswordHashingOptions options
) override
protected:
virtual HashedPassword^ DoComputeHash(
    PasswordFamily family,
    SecureBuffer^ password,
    MD5PasswordHashingOptions options
) override
abstract DoComputeHash :
        family : PasswordFamily *
        password : SecureBuffer *
        options : MD5PasswordHashingOptions -> HashedPassword
override DoComputeHash :
        family : PasswordFamily *
        password : SecureBuffer *
        options : MD5PasswordHashingOptions -> HashedPassword
abstract DoComputeHash :
        family : PasswordFamily *
        password : SecureBuffer *
        options : MD5PasswordHashingOptions -> HashedPassword
override DoComputeHash :
        family : PasswordFamily *
        password : SecureBuffer *
        options : MD5PasswordHashingOptions -> HashedPassword

Parameters

family
Type: NFX.Security PasswordFamily
password
Type: NFX.Security SecureBuffer
options
Type: NFX.Security MD5PasswordHashingOptions

Return Value

Type: HashedPassword
See Also
MD5PasswordHashingAlgorithm Class
MD5PasswordHashingAlgorithm Members
DoComputeHash Overload
NFX.Security Namespace


MD5PasswordHashingAlgorithm.DoExtractPasswordHashingOptions Method

MD5PasswordHashingAlgorithm DoExtractPasswordHashingOptions Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override MD5PasswordHashingOptions DoExtractPasswordHashingOptions(
    HashedPassword hash,
    out bool needRehash
)
protected override MD5PasswordHashingOptions DoExtractPasswordHashingOptions(
    HashedPassword hash,
    out bool needRehash
)
Protected Overrides Function DoExtractPasswordHashingOptions (
    hash As HashedPassword,
    <OutAttribute> ByRef needRehash As Boolean
) As MD5PasswordHashingOptions
Protected Overrides Function DoExtractPasswordHashingOptions (
    hash As HashedPassword,
    <OutAttribute> ByRef needRehash As Boolean
) As MD5PasswordHashingOptions
protected:
virtual MD5PasswordHashingOptions DoExtractPasswordHashingOptions(
    HashedPassword^ hash,
    [OutAttribute] bool% needRehash
) override
protected:
virtual MD5PasswordHashingOptions DoExtractPasswordHashingOptions(
    HashedPassword^ hash,
    [OutAttribute] bool% needRehash
) override
abstract DoExtractPasswordHashingOptions :
        hash : HashedPassword *
        needRehash : bool byref -> MD5PasswordHashingOptions
override DoExtractPasswordHashingOptions :
        hash : HashedPassword *
        needRehash : bool byref -> MD5PasswordHashingOptions
abstract DoExtractPasswordHashingOptions :
        hash : HashedPassword *
        needRehash : bool byref -> MD5PasswordHashingOptions
override DoExtractPasswordHashingOptions :
        hash : HashedPassword *
        needRehash : bool byref -> MD5PasswordHashingOptions

Parameters

hash
Type: NFX.Security HashedPassword
needRehash
Type: Online System Boolean

Return Value

Type: MD5PasswordHashingOptions
See Also
MD5PasswordHashingAlgorithm Class
MD5PasswordHashingAlgorithm Members
NFX.Security Namespace


MD5PasswordHashingAlgorithm Properties

MD5PasswordHashingAlgorithm Properties NFX Class Library

The MD5PasswordHashingAlgorithm type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Protected property | DefaultPasswordHashingOptions | (Overrides PasswordHashingAlgorithm TOptions DefaultPasswordHashingOptions.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | InstrumentationEnabled | (Inherited from PasswordHashingAlgorithm.)
Public property | IsDefault | (Inherited from PasswordHashingAlgorithm.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | SaltMaxLenght |
Public property | SaltMinLenght |
Public property | Status | Current service status (Inherited from Service.)
Public property | StrengthLevel | (Inherited from PasswordHashingAlgorithm.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
MD5PasswordHashingAlgorithm Class
NFX.Security Namespace


MD5PasswordHashingAlgorithm.DefaultPasswordHashingOptions Property

MD5PasswordHashingAlgorithm DefaultPasswordHashingOptions Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override MD5PasswordHashingOptions DefaultPasswordHashingOptions { get; }
protected override MD5PasswordHashingOptions DefaultPasswordHashingOptions { get; }
Protected Overrides ReadOnly Property DefaultPasswordHashingOptions As MD5PasswordHashingOptions
    Get
Protected Overrides ReadOnly Property DefaultPasswordHashingOptions As MD5PasswordHashingOptions
    Get
protected:
virtual property MD5PasswordHashingOptions DefaultPasswordHashingOptions {
    MD5PasswordHashingOptions get () override;
}
protected:
virtual property MD5PasswordHashingOptions DefaultPasswordHashingOptions {
    MD5PasswordHashingOptions get () override;
}
abstract DefaultPasswordHashingOptions : MD5PasswordHashingOptions with get
override DefaultPasswordHashingOptions : MD5PasswordHashingOptions with get
abstract DefaultPasswordHashingOptions : MD5PasswordHashingOptions with get
override DefaultPasswordHashingOptions : MD5PasswordHashingOptions with get

Property Value

Type: MD5PasswordHashingOptions
See Also
MD5PasswordHashingAlgorithm Class
MD5PasswordHashingAlgorithm Members
NFX.Security Namespace


MD5PasswordHashingAlgorithm.SaltMaxLenght Property

MD5PasswordHashingAlgorithm SaltMaxLenght Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(Default = 32)]
public int SaltMaxLenght { get; set; }
[ConfigAttribute(Default = 32)]
public int SaltMaxLenght { get; set; }
<ConfigAttribute(Default := 32)>
Public Property SaltMaxLenght As Integer
    Get
    Set
<ConfigAttribute(Default := 32)>
Public Property SaltMaxLenght As Integer
    Get
    Set
public:
[ConfigAttribute(Default = 32)]
property int SaltMaxLenght {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(Default = 32)]
property int SaltMaxLenght {
    int get ();
    void set (int value);
}
[<ConfigAttribute(Default = 32)>]
member SaltMaxLenght : int with get, set
[<ConfigAttribute(Default = 32)>]
member SaltMaxLenght : int with get, set

Property Value

Type: Online Int32
See Also
MD5PasswordHashingAlgorithm Class
MD5PasswordHashingAlgorithm Members
NFX.Security Namespace


MD5PasswordHashingAlgorithm.SaltMinLenght Property

MD5PasswordHashingAlgorithm SaltMinLenght Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute(Default = 16)]
public int SaltMinLenght { get; set; }
[ConfigAttribute(Default = 16)]
public int SaltMinLenght { get; set; }
<ConfigAttribute(Default := 16)>
Public Property SaltMinLenght As Integer
    Get
    Set
<ConfigAttribute(Default := 16)>
Public Property SaltMinLenght As Integer
    Get
    Set
public:
[ConfigAttribute(Default = 16)]
property int SaltMinLenght {
    int get ();
    void set (int value);
}
public:
[ConfigAttribute(Default = 16)]
property int SaltMinLenght {
    int get ();
    void set (int value);
}
[<ConfigAttribute(Default = 16)>]
member SaltMinLenght : int with get, set
[<ConfigAttribute(Default = 16)>]
member SaltMinLenght : int with get, set

Property Value

Type: Online Int32
See Also
MD5PasswordHashingAlgorithm Class
MD5PasswordHashingAlgorithm Members
NFX.Security Namespace


MD5PasswordHashingOptions Structure

MD5PasswordHashingOptions Structure NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct MD5PasswordHashingOptions : IPasswordHashingOptions
public struct MD5PasswordHashingOptions : IPasswordHashingOptions
Public Structure MD5PasswordHashingOptions
    Implements IPasswordHashingOptions
Public Structure MD5PasswordHashingOptions
    Implements IPasswordHashingOptions
public value class MD5PasswordHashingOptions : IPasswordHashingOptions
public value class MD5PasswordHashingOptions : IPasswordHashingOptions
[<SealedAttribute>]
type MD5PasswordHashingOptions =
    struct
        interface IPasswordHashingOptions
    end
[<SealedAttribute>]
type MD5PasswordHashingOptions =
    struct
        interface IPasswordHashingOptions
    end
See Also
MD5PasswordHashingOptions Members
NFX.Security Namespace


MD5PasswordHashingOptions Members

MD5PasswordHashingOptions Members NFX Class Library

The MD5PasswordHashingOptions type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Salt |
Back to Top
See Also
MD5PasswordHashingOptions Structure
NFX.Security Namespace


MD5PasswordHashingOptions Methods

MD5PasswordHashingOptions Methods NFX Class Library

The MD5PasswordHashingOptions type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MD5PasswordHashingOptions Structure
NFX.Security Namespace


MD5PasswordHashingOptions Properties

MD5PasswordHashingOptions Properties NFX Class Library

The MD5PasswordHashingOptions type exposes the following members.
Properties
 | Name | Description
Public property | Salt |
Back to Top
See Also
MD5PasswordHashingOptions Structure
NFX.Security Namespace


MD5PasswordHashingOptions.Salt Property

MD5PasswordHashingOptions Salt Property NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] Salt { get; set; }
public byte[] Salt { get; set; }
Public Property Salt As Byte()
    Get
    Set
Public Property Salt As Byte()
    Get
    Set
public:
property array<unsigned char>^ Salt {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
public:
property array<unsigned char>^ Salt {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member Salt : byte[] with get, set
member Salt : byte[] with get, set

Property Value

Type: Online Byte
See Also
MD5PasswordHashingOptions Structure
MD5PasswordHashingOptions Members
NFX.Security Namespace


NOPSecurityManager Class

NOPSecurityManager Class NFX Class Library

Provides security manager implementation that does nothing and always returns fake user instance
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.Security NOPSecurityManager

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class NOPSecurityManager : ApplicationComponent,
    ISecurityManagerImplementation, ISecurityManager, IApplicationComponent, IDisposable, IConfigurable
public sealed class NOPSecurityManager : ApplicationComponent,
    ISecurityManagerImplementation, ISecurityManager, IApplicationComponent, IDisposable, IConfigurable
Public NotInheritable Class NOPSecurityManager
    Inherits ApplicationComponent
    Implements ISecurityManagerImplementation, ISecurityManager, IApplicationComponent, IDisposable,
    IConfigurable
Public NotInheritable Class NOPSecurityManager
    Inherits ApplicationComponent
    Implements ISecurityManagerImplementation, ISecurityManager, IApplicationComponent, IDisposable,
    IConfigurable
public ref class NOPSecurityManager sealed : public ApplicationComponent,
    ISecurityManagerImplementation, ISecurityManager, IApplicationComponent, IDisposable, IConfigurable
public ref class NOPSecurityManager sealed : public ApplicationComponent,
    ISecurityManagerImplementation, ISecurityManager, IApplicationComponent, IDisposable, IConfigurable
[<SealedAttribute>]
type NOPSecurityManager =
    class
        inherit ApplicationComponent
        interface ISecurityManagerImplementation
        interface ISecurityManager
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
    end
[<SealedAttribute>]
type NOPSecurityManager =
    class
        inherit ApplicationComponent
        interface ISecurityManagerImplementation
        interface ISecurityManager
        interface IApplicationComponent
        interface IDisposable
        interface IConfigurable
    end
See Also
NOPSecurityManager Members
NFX.Security Namespace


NOPSecurityManager Members

NOPSecurityManager Members NFX Class Library

The NOPSecurityManager type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | Authenticate(AuthenticationToken) |
Public method | Authenticate(Credentials) |
Public method | Authenticate(User) |
Public method | Authorize |
Public method | Configure |
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
 | Instance |
Public property | PasswordManager |
Back to Top
See Also
NOPSecurityManager Class
NFX.Security Namespace


NOPSecurityManager Methods

NOPSecurityManager Methods NFX Class Library

The NOPSecurityManager type exposes the following members.
Methods
 | Name | Description
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Public method | Authenticate(AuthenticationToken) |
Public method | Authenticate(Credentials) |
Public method | Authenticate(User) |
Public method | Authorize |
Public method | Configure |
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NOPSecurityManager Class
NFX.Security Namespace


NOPSecurityManager.Authenticate Method

NOPSecurityManager Authenticate Method NFX Class Library

Overload List
 | Name | Description
Public method | Authenticate(AuthenticationToken) |
Public method | Authenticate(Credentials) |
Public method | Authenticate(User) |
Back to Top
See Also
NOPSecurityManager Class
NOPSecurityManager Members
NFX.Security Namespace


NOPSecurityManager.Authenticate Method (AuthenticationToken)

NOPSecurityManager Authenticate Method (AuthenticationToken) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public User Authenticate(
    AuthenticationToken token
)
public User Authenticate(
    AuthenticationToken token
)
Public Function Authenticate (
    token As AuthenticationToken
) As User
Public Function Authenticate (
    token As AuthenticationToken
) As User
public:
virtual User^ Authenticate(
    AuthenticationToken token
) sealed
public:
virtual User^ Authenticate(
    AuthenticationToken token
) sealed
abstract Authenticate :
        token : AuthenticationToken -> User
override Authenticate :
        token : AuthenticationToken -> User
abstract Authenticate :
        token : AuthenticationToken -> User
override Authenticate :
        token : AuthenticationToken -> User

Parameters

token
Type: NFX.Security AuthenticationToken

Return Value

Type: User

Implements

ISecurityManager Authenticate(AuthenticationToken)
See Also
NOPSecurityManager Class
NOPSecurityManager Members
Authenticate Overload
NFX.Security Namespace


NOPSecurityManager.Authenticate Method (Credentials)

NOPSecurityManager Authenticate Method (Credentials) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public User Authenticate(
    Credentials credentials
)
public User Authenticate(
    Credentials credentials
)
Public Function Authenticate (
    credentials As Credentials
) As User
Public Function Authenticate (
    credentials As Credentials
) As User
public:
virtual User^ Authenticate(
    Credentials^ credentials
) sealed
public:
virtual User^ Authenticate(
    Credentials^ credentials
) sealed
abstract Authenticate :
        credentials : Credentials -> User
override Authenticate :
        credentials : Credentials -> User
abstract Authenticate :
        credentials : Credentials -> User
override Authenticate :
        credentials : Credentials -> User

Parameters

credentials
Type: NFX.Security Credentials

Return Value

Type: User

Implements

ISecurityManager Authenticate(Credentials)
See Also
NOPSecurityManager Class
NOPSecurityManager Members
Authenticate Overload
NFX.Security Namespace


NOPSecurityManager.Authenticate Method (User)

NOPSecurityManager Authenticate Method (User) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Authenticate(
    User user
)
public void Authenticate(
    User user
)
Public Sub Authenticate (
    user As User
)
Public Sub Authenticate (
    user As User
)
public:
virtual void Authenticate(
    User^ user
) sealed
public:
virtual void Authenticate(
    User^ user
) sealed
abstract Authenticate :
        user : User -> unit
override Authenticate :
        user : User -> unit
abstract Authenticate :
        user : User -> unit
override Authenticate :
        user : User -> unit

Parameters

user
Type: NFX.Security User

Implements

ISecurityManager Authenticate(User)
See Also
NOPSecurityManager Class
NOPSecurityManager Members
Authenticate Overload
NFX.Security Namespace


NOPSecurityManager.Authorize Method

NOPSecurityManager Authorize Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccessLevel Authorize(
    User user,
    Permission permission
)
public AccessLevel Authorize(
    User user,
    Permission permission
)
Public Function Authorize (
    user As User,
    permission As Permission
) As AccessLevel
Public Function Authorize (
    user As User,
    permission As Permission
) As AccessLevel
public:
virtual AccessLevel^ Authorize(
    User^ user,
    Permission^ permission
) sealed
public:
virtual AccessLevel^ Authorize(
    User^ user,
    Permission^ permission
) sealed
abstract Authorize :
        user : User *
        permission : Permission -> AccessLevel
override Authorize :
        user : User *
        permission : Permission -> AccessLevel
abstract Authorize :
        user : User *
        permission : Permission -> AccessLevel
override Authorize :
        user : User *
        permission : Permission -> AccessLevel

Parameters

user
Type: NFX.Security User
permission
Type: NFX.Security Permission

Return Value

Type: AccessLevel

Implements

ISecurityManager Authorize(User, Permission)
See Also
NOPSecurityManager Class
NOPSecurityManager Members
NFX.Security Namespace


NOPSecurityManager.Configure Method

NOPSecurityManager Configure Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode node
)
public void Configure(
    IConfigSectionNode node
)
Public Sub Configure (
    node As IConfigSectionNode
)
Public Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
NOPSecurityManager Class
NOPSecurityManager Members
NFX.Security Namespace


NOPSecurityManager.Destructor Method

NOPSecurityManager Destructor Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
NOPSecurityManager Class
NOPSecurityManager Members
NFX.Security Namespace


NOPSecurityManager Properties

NOPSecurityManager Properties NFX Class Library

The NOPSecurityManager type exposes the following members.
Properties
 | Name | Description
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
 | Instance |
Public property | PasswordManager |
Back to Top
See Also
NOPSecurityManager Class
NFX.Security Namespace


NOPSecurityManager.Instance Property

NOPSecurityManager Instance Property NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NOPSecurityManager Instance { get; }
public static NOPSecurityManager Instance { get; }
Public Shared ReadOnly Property Instance As NOPSecurityManager
    Get
Public Shared ReadOnly Property Instance As NOPSecurityManager
    Get
public:
static property NOPSecurityManager^ Instance {
    NOPSecurityManager^ get ();
}
public:
static property NOPSecurityManager^ Instance {
    NOPSecurityManager^ get ();
}
static member Instance : NOPSecurityManager with get
static member Instance : NOPSecurityManager with get

Property Value

Type: NOPSecurityManager
See Also
NOPSecurityManager Class
NOPSecurityManager Members
NFX.Security Namespace


NOPSecurityManager.PasswordManager Property

NOPSecurityManager PasswordManager Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IPasswordManager PasswordManager { get; }
public IPasswordManager PasswordManager { get; }
Public ReadOnly Property PasswordManager As IPasswordManager
    Get
Public ReadOnly Property PasswordManager As IPasswordManager
    Get
public:
virtual property IPasswordManager^ PasswordManager {
    IPasswordManager^ get () sealed;
}
public:
virtual property IPasswordManager^ PasswordManager {
    IPasswordManager^ get () sealed;
}
abstract PasswordManager : IPasswordManager with get
override PasswordManager : IPasswordManager with get
abstract PasswordManager : IPasswordManager with get
override PasswordManager : IPasswordManager with get

Property Value

Type: IPasswordManager

Implements

ISecurityManager PasswordManager
See Also
NOPSecurityManager Class
NOPSecurityManager Members
NFX.Security Namespace


PasswordFamily Enumeration

PasswordFamily Enumeration NFX Class Library

Denoutes kinds of passwords i.e.: text that user types on login, short PIN, geometrical curve that users need to trace with their finger, select areas of picture

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum PasswordFamily
public enum PasswordFamily
Public Enumeration PasswordFamily
Public Enumeration PasswordFamily
public enum class PasswordFamily
public enum class PasswordFamily
type PasswordFamily
type PasswordFamily
Members
Member name | Value | Description
Unspecified | 0 |
Text | 1 |
PIN | 2 |
Geometry | 3 |
Picture | 4 |
Other | 5 |
See Also
NFX.Security Namespace


PasswordHashingAlgorithm Class

PasswordHashingAlgorithm Class NFX Class Library

Represents an abstraction of password algorithm that performs hashing and verification of passwords supplied as SecureBuffer
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service IPasswordManagerImplementation
NFX.ServiceModel ServiceWithInstrumentationBase IPasswordManagerImplementation
NFX.Security PasswordHashingAlgorithm
NFX.Security PasswordHashingAlgorithm TOptions

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class PasswordHashingAlgorithm : ServiceWithInstrumentationBase<IPasswordManagerImplementation>,
    INamed
public abstract class PasswordHashingAlgorithm : ServiceWithInstrumentationBase<IPasswordManagerImplementation>,
    INamed
Public MustInherit Class PasswordHashingAlgorithm
    Inherits ServiceWithInstrumentationBase(Of IPasswordManagerImplementation)
    Implements INamed
Public MustInherit Class PasswordHashingAlgorithm
    Inherits ServiceWithInstrumentationBase(Of IPasswordManagerImplementation)
    Implements INamed
public ref class PasswordHashingAlgorithm abstract : public ServiceWithInstrumentationBase<IPasswordManagerImplementation^>,
    INamed
public ref class PasswordHashingAlgorithm abstract : public ServiceWithInstrumentationBase<IPasswordManagerImplementation^>,
    INamed
[<AbstractClassAttribute>]
type PasswordHashingAlgorithm =
    class
        inherit ServiceWithInstrumentationBase<IPasswordManagerImplementation>
        interface INamed
    end
[<AbstractClassAttribute>]
type PasswordHashingAlgorithm =
    class
        inherit ServiceWithInstrumentationBase<IPasswordManagerImplementation>
        interface INamed
    end
See Also
PasswordHashingAlgorithm Members
NFX.Security Namespace


PasswordHashingAlgorithm Members

PasswordHashingAlgorithm Members NFX Class Library

The PasswordHashingAlgorithm type exposes the following members.
Constructors
 | Name | Description
Protected method | PasswordHashingAlgorithm | Initializes a new instance of the PasswordHashingAlgorithm class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | AreEquivalent |
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | ComputeHash |
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoAreEquivalent |
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoComputeHash |
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoVerify |
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Public method | Match |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | Verify |
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | InstrumentationEnabled | (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | IsDefault |
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | StrengthLevel |
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
PasswordHashingAlgorithm Class
NFX.Security Namespace


PasswordHashingAlgorithm Constructor

PasswordHashingAlgorithm Constructor NFX Class Library

Initializes a new instance of the PasswordHashingAlgorithm class

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PasswordHashingAlgorithm(
    IPasswordManagerImplementation director,
    string name
)
protected PasswordHashingAlgorithm(
    IPasswordManagerImplementation director,
    string name
)
Protected Sub New (
    director As IPasswordManagerImplementation,
    name As String
)
Protected Sub New (
    director As IPasswordManagerImplementation,
    name As String
)
protected:
PasswordHashingAlgorithm(
    IPasswordManagerImplementation^ director,
    String^ name
)
protected:
PasswordHashingAlgorithm(
    IPasswordManagerImplementation^ director,
    String^ name
)
new :
        director : IPasswordManagerImplementation *
        name : string -> PasswordHashingAlgorithm
new :
        director : IPasswordManagerImplementation *
        name : string -> PasswordHashingAlgorithm

Parameters

director
Type: NFX.Security IPasswordManagerImplementation
name
Type: Online System String
See Also
PasswordHashingAlgorithm Class
PasswordHashingAlgorithm Members
NFX.Security Namespace


PasswordHashingAlgorithm Methods

PasswordHashingAlgorithm Methods NFX Class Library

The PasswordHashingAlgorithm type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | AreEquivalent |
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | ComputeHash |
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoAreEquivalent |
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoComputeHash |
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoVerify |
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Public method | Match |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | Verify |
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PasswordHashingAlgorithm Class
NFX.Security Namespace


PasswordHashingAlgorithm.AreEquivalent Method

PasswordHashingAlgorithm AreEquivalent Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool AreEquivalent(
    HashedPassword hash,
    HashedPassword rehash
)
public bool AreEquivalent(
    HashedPassword hash,
    HashedPassword rehash
)
Public Function AreEquivalent (
    hash As HashedPassword,
    rehash As HashedPassword
) As Boolean
Public Function AreEquivalent (
    hash As HashedPassword,
    rehash As HashedPassword
) As Boolean
public:
bool AreEquivalent(
    HashedPassword^ hash,
    HashedPassword^ rehash
)
public:
bool AreEquivalent(
    HashedPassword^ hash,
    HashedPassword^ rehash
)
member AreEquivalent :
        hash : HashedPassword *
        rehash : HashedPassword -> bool
member AreEquivalent :
        hash : HashedPassword *
        rehash : HashedPassword -> bool

Parameters

hash
Type: NFX.Security HashedPassword
rehash
Type: NFX.Security HashedPassword

Return Value

Type: Online Boolean
See Also
PasswordHashingAlgorithm Class
PasswordHashingAlgorithm Members
NFX.Security Namespace


PasswordHashingAlgorithm.ComputeHash Method

PasswordHashingAlgorithm ComputeHash Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HashedPassword ComputeHash(
    PasswordFamily family,
    SecureBuffer password
)
public HashedPassword ComputeHash(
    PasswordFamily family,
    SecureBuffer password
)
Public Function ComputeHash (
    family As PasswordFamily,
    password As SecureBuffer
) As HashedPassword
Public Function ComputeHash (
    family As PasswordFamily,
    password As SecureBuffer
) As HashedPassword
public:
HashedPassword^ ComputeHash(
    PasswordFamily family,
    SecureBuffer^ password
)
public:
HashedPassword^ ComputeHash(
    PasswordFamily family,
    SecureBuffer^ password
)
member ComputeHash :
        family : PasswordFamily *
        password : SecureBuffer -> HashedPassword
member ComputeHash :
        family : PasswordFamily *
        password : SecureBuffer -> HashedPassword

Parameters

family
Type: NFX.Security PasswordFamily
password
Type: NFX.Security SecureBuffer

Return Value

Type: HashedPassword
See Also
PasswordHashingAlgorithm Class
PasswordHashingAlgorithm Members
NFX.Security Namespace


PasswordHashingAlgorithm.DoAreEquivalent Method

PasswordHashingAlgorithm DoAreEquivalent Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract bool DoAreEquivalent(
    HashedPassword hash,
    HashedPassword rehash
)
protected abstract bool DoAreEquivalent(
    HashedPassword hash,
    HashedPassword rehash
)
Protected MustOverride Function DoAreEquivalent (
    hash As HashedPassword,
    rehash As HashedPassword
) As Boolean
Protected MustOverride Function DoAreEquivalent (
    hash As HashedPassword,
    rehash As HashedPassword
) As Boolean
protected:
virtual bool DoAreEquivalent(
    HashedPassword^ hash,
    HashedPassword^ rehash
) abstract
protected:
virtual bool DoAreEquivalent(
    HashedPassword^ hash,
    HashedPassword^ rehash
) abstract
abstract DoAreEquivalent :
        hash : HashedPassword *
        rehash : HashedPassword -> bool
abstract DoAreEquivalent :
        hash : HashedPassword *
        rehash : HashedPassword -> bool

Parameters

hash
Type: NFX.Security HashedPassword
rehash
Type: NFX.Security HashedPassword

Return Value

Type: Online Boolean
See Also
PasswordHashingAlgorithm Class
PasswordHashingAlgorithm Members
NFX.Security Namespace


PasswordHashingAlgorithm.DoComputeHash Method

PasswordHashingAlgorithm DoComputeHash Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract HashedPassword DoComputeHash(
    PasswordFamily family,
    SecureBuffer password
)
protected abstract HashedPassword DoComputeHash(
    PasswordFamily family,
    SecureBuffer password
)
Protected MustOverride Function DoComputeHash (
    family As PasswordFamily,
    password As SecureBuffer
) As HashedPassword
Protected MustOverride Function DoComputeHash (
    family As PasswordFamily,
    password As SecureBuffer
) As HashedPassword
protected:
virtual HashedPassword^ DoComputeHash(
    PasswordFamily family,
    SecureBuffer^ password
) abstract
protected:
virtual HashedPassword^ DoComputeHash(
    PasswordFamily family,
    SecureBuffer^ password
) abstract
abstract DoComputeHash :
        family : PasswordFamily *
        password : SecureBuffer -> HashedPassword
abstract DoComputeHash :
        family : PasswordFamily *
        password : SecureBuffer -> HashedPassword

Parameters

family
Type: NFX.Security PasswordFamily
password
Type: NFX.Security SecureBuffer

Return Value

Type: HashedPassword
See Also
PasswordHashingAlgorithm Class
PasswordHashingAlgorithm Members
NFX.Security Namespace


PasswordHashingAlgorithm.DoVerify Method

PasswordHashingAlgorithm DoVerify Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract bool DoVerify(
    SecureBuffer password,
    HashedPassword hash,
    out bool needRehash
)
protected abstract bool DoVerify(
    SecureBuffer password,
    HashedPassword hash,
    out bool needRehash
)
Protected MustOverride Function DoVerify (
    password As SecureBuffer,
    hash As HashedPassword,
    <OutAttribute> ByRef needRehash As Boolean
) As Boolean
Protected MustOverride Function DoVerify (
    password As SecureBuffer,
    hash As HashedPassword,
    <OutAttribute> ByRef needRehash As Boolean
) As Boolean
protected:
virtual bool DoVerify(
    SecureBuffer^ password,
    HashedPassword^ hash,
    [OutAttribute] bool% needRehash
) abstract
protected:
virtual bool DoVerify(
    SecureBuffer^ password,
    HashedPassword^ hash,
    [OutAttribute] bool% needRehash
) abstract
abstract DoVerify :
        password : SecureBuffer *
        hash : HashedPassword *
        needRehash : bool byref -> bool
abstract DoVerify :
        password : SecureBuffer *
        hash : HashedPassword *
        needRehash : bool byref -> bool

Parameters

password
Type: NFX.Security SecureBuffer
hash
Type: NFX.Security HashedPassword
needRehash
Type: Online System Boolean

Return Value

Type: Online Boolean
See Also
PasswordHashingAlgorithm Class
PasswordHashingAlgorithm Members
NFX.Security Namespace


PasswordHashingAlgorithm.Match Method

PasswordHashingAlgorithm Match Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Match(
    PasswordFamily family
)
public virtual bool Match(
    PasswordFamily family
)
Public Overridable Function Match (
    family As PasswordFamily
) As Boolean
Public Overridable Function Match (
    family As PasswordFamily
) As Boolean
public:
virtual bool Match(
    PasswordFamily family
)
public:
virtual bool Match(
    PasswordFamily family
)
abstract Match :
        family : PasswordFamily -> bool
override Match :
        family : PasswordFamily -> bool
abstract Match :
        family : PasswordFamily -> bool
override Match :
        family : PasswordFamily -> bool

Parameters

family
Type: NFX.Security PasswordFamily

Return Value

Type: Online Boolean
See Also
PasswordHashingAlgorithm Class
PasswordHashingAlgorithm Members
NFX.Security Namespace


PasswordHashingAlgorithm.Verify Method

PasswordHashingAlgorithm Verify Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Verify(
    SecureBuffer password,
    HashedPassword hash,
    out bool needRehash
)
public bool Verify(
    SecureBuffer password,
    HashedPassword hash,
    out bool needRehash
)
Public Function Verify (
    password As SecureBuffer,
    hash As HashedPassword,
    <OutAttribute> ByRef needRehash As Boolean
) As Boolean
Public Function Verify (
    password As SecureBuffer,
    hash As HashedPassword,
    <OutAttribute> ByRef needRehash As Boolean
) As Boolean
public:
bool Verify(
    SecureBuffer^ password,
    HashedPassword^ hash,
    [OutAttribute] bool% needRehash
)
public:
bool Verify(
    SecureBuffer^ password,
    HashedPassword^ hash,
    [OutAttribute] bool% needRehash
)
member Verify :
        password : SecureBuffer *
        hash : HashedPassword *
        needRehash : bool byref -> bool
member Verify :
        password : SecureBuffer *
        hash : HashedPassword *
        needRehash : bool byref -> bool

Parameters

password
Type: NFX.Security SecureBuffer
hash
Type: NFX.Security HashedPassword
needRehash
Type: Online System Boolean

Return Value

Type: Online Boolean
See Also
PasswordHashingAlgorithm Class
PasswordHashingAlgorithm Members
NFX.Security Namespace


PasswordHashingAlgorithm Properties

PasswordHashingAlgorithm Properties NFX Class Library

The PasswordHashingAlgorithm type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | InstrumentationEnabled | (Overrides ServiceWithInstrumentationBase TDirector InstrumentationEnabled.)
Public property | IsDefault |
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | StrengthLevel |
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
PasswordHashingAlgorithm Class
NFX.Security Namespace


PasswordHashingAlgorithm.InstrumentationEnabled Property

PasswordHashingAlgorithm InstrumentationEnabled Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute(Default = false)]
public override bool InstrumentationEnabled { get; set; }
[ExternalParameterAttribute(new string[] { ... })]
[ConfigAttribute(Default = false)]
public override bool InstrumentationEnabled { get; set; }
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute(Default := false)>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
<ExternalParameterAttribute(New String() { ... })>
<ConfigAttribute(Default := false)>
Public Overrides Property InstrumentationEnabled As Boolean
    Get
    Set
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(Default = false)]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
public:
[ExternalParameterAttribute(__gc new array<String^>^ { ... })]
[ConfigAttribute(Default = false)]
virtual property bool InstrumentationEnabled {
    bool get () override;
    void set (bool value) override;
}
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
abstract InstrumentationEnabled : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
override InstrumentationEnabled : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
abstract InstrumentationEnabled : bool with get, set
[<ExternalParameterAttribute(new string[] { ... })>]
[<ConfigAttribute(Default = false)>]
override InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentable InstrumentationEnabled
See Also
PasswordHashingAlgorithm Class
PasswordHashingAlgorithm Members
NFX.Security Namespace


PasswordHashingAlgorithm.IsDefault Property

PasswordHashingAlgorithm IsDefault Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsDefault { get; }
public bool IsDefault { get; }
Public ReadOnly Property IsDefault As Boolean
    Get
Public ReadOnly Property IsDefault As Boolean
    Get
public:
property bool IsDefault {
    bool get ();
}
public:
property bool IsDefault {
    bool get ();
}
member IsDefault : bool with get
member IsDefault : bool with get

Property Value

Type: Online Boolean
See Also
PasswordHashingAlgorithm Class
PasswordHashingAlgorithm Members
NFX.Security Namespace


PasswordHashingAlgorithm.StrengthLevel Property

PasswordHashingAlgorithm StrengthLevel Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PasswordStrengthLevel StrengthLevel { get; }
public PasswordStrengthLevel StrengthLevel { get; }
Public ReadOnly Property StrengthLevel As PasswordStrengthLevel
    Get
Public ReadOnly Property StrengthLevel As PasswordStrengthLevel
    Get
public:
property PasswordStrengthLevel StrengthLevel {
    PasswordStrengthLevel get ();
}
public:
property PasswordStrengthLevel StrengthLevel {
    PasswordStrengthLevel get ();
}
member StrengthLevel : PasswordStrengthLevel with get
member StrengthLevel : PasswordStrengthLevel with get

Property Value

Type: PasswordStrengthLevel
See Also
PasswordHashingAlgorithm Class
PasswordHashingAlgorithm Members
NFX.Security Namespace


PasswordHashingAlgorithm(TOptions) Class

PasswordHashingAlgorithm TOptions Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service IPasswordManagerImplementation
NFX.ServiceModel ServiceWithInstrumentationBase IPasswordManagerImplementation
NFX.Security PasswordHashingAlgorithm
NFX.Security PasswordHashingAlgorithm TOptions
NFX.Security MD5PasswordHashingAlgorithm

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class PasswordHashingAlgorithm<TOptions> : PasswordHashingAlgorithm
where TOptions : IPasswordHashingOptions
public abstract class PasswordHashingAlgorithm<TOptions> : PasswordHashingAlgorithm
where TOptions : IPasswordHashingOptions
Public MustInherit Class PasswordHashingAlgorithm(Of TOptions As IPasswordHashingOptions)
    Inherits PasswordHashingAlgorithm
Public MustInherit Class PasswordHashingAlgorithm(Of TOptions As IPasswordHashingOptions)
    Inherits PasswordHashingAlgorithm
generic<typename TOptions>
where TOptions : IPasswordHashingOptions
public ref class PasswordHashingAlgorithm abstract : public PasswordHashingAlgorithm
generic<typename TOptions>
where TOptions : IPasswordHashingOptions
public ref class PasswordHashingAlgorithm abstract : public PasswordHashingAlgorithm
[<AbstractClassAttribute>]
type PasswordHashingAlgorithm<'TOptions when 'TOptions : IPasswordHashingOptions> =
    class
        inherit PasswordHashingAlgorithm
    end
[<AbstractClassAttribute>]
type PasswordHashingAlgorithm<'TOptions when 'TOptions : IPasswordHashingOptions> =
    class
        inherit PasswordHashingAlgorithm
    end
Type Parameters
TOptions
See Also
PasswordHashingAlgorithm TOptions Members
NFX.Security Namespace


PasswordHashingAlgorithm(TOptions) Members

PasswordHashingAlgorithm TOptions Members NFX Class Library

The PasswordHashingAlgorithm TOptions type exposes the following members.
Constructors
 | Name | Description
Public method | PasswordHashingAlgorithm TOptions | Initializes a new instance of the PasswordHashingAlgorithm TOptions class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | AreEquivalent | (Inherited from PasswordHashingAlgorithm.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | ComputeHash(PasswordFamily, SecureBuffer) | (Inherited from PasswordHashingAlgorithm.)
Public method | ComputeHash(PasswordFamily, SecureBuffer, TOptions) |
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoAreEquivalent | (Inherited from PasswordHashingAlgorithm.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoComputeHash(PasswordFamily, SecureBuffer) | (Overrides PasswordHashingAlgorithm DoComputeHash(PasswordFamily, SecureBuffer).)
Protected method | DoComputeHash(PasswordFamily, SecureBuffer, TOptions) |
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoExtractPasswordHashingOptions |
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoVerify | (Overrides PasswordHashingAlgorithm DoVerify(SecureBuffer, HashedPassword, Boolean ).)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExtractPasswordHashingOptions |
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Public method | Match | (Inherited from PasswordHashingAlgorithm.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | Verify | (Inherited from PasswordHashingAlgorithm.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Protected property | DefaultPasswordHashingOptions |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | InstrumentationEnabled | (Inherited from PasswordHashingAlgorithm.)
Public property | IsDefault | (Inherited from PasswordHashingAlgorithm.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | StrengthLevel | (Inherited from PasswordHashingAlgorithm.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
PasswordHashingAlgorithm TOptions Class
NFX.Security Namespace


PasswordHashingAlgorithm(TOptions) Constructor

PasswordHashingAlgorithm TOptions Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PasswordHashingAlgorithm TOptions class

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PasswordHashingAlgorithm(
    IPasswordManagerImplementation director,
    string name
)
public PasswordHashingAlgorithm(
    IPasswordManagerImplementation director,
    string name
)
Public Sub New (
    director As IPasswordManagerImplementation,
    name As String
)
Public Sub New (
    director As IPasswordManagerImplementation,
    name As String
)
public:
PasswordHashingAlgorithm(
    IPasswordManagerImplementation^ director,
    String^ name
)
public:
PasswordHashingAlgorithm(
    IPasswordManagerImplementation^ director,
    String^ name
)
new :
        director : IPasswordManagerImplementation *
        name : string -> PasswordHashingAlgorithm
new :
        director : IPasswordManagerImplementation *
        name : string -> PasswordHashingAlgorithm

Parameters

director
Type: NFX.Security IPasswordManagerImplementation
name
Type: Online System String
See Also
PasswordHashingAlgorithm TOptions Class
PasswordHashingAlgorithm TOptions Members
NFX.Security Namespace


PasswordHashingAlgorithm(TOptions) Methods

PasswordHashingAlgorithm TOptions Methods NFX Class Library

The PasswordHashingAlgorithm TOptions type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | AreEquivalent | (Inherited from PasswordHashingAlgorithm.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | ComputeHash(PasswordFamily, SecureBuffer) | (Inherited from PasswordHashingAlgorithm.)
Public method | ComputeHash(PasswordFamily, SecureBuffer, TOptions) |
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoAreEquivalent | (Inherited from PasswordHashingAlgorithm.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoComputeHash(PasswordFamily, SecureBuffer) | (Overrides PasswordHashingAlgorithm DoComputeHash(PasswordFamily, SecureBuffer).)
Protected method | DoComputeHash(PasswordFamily, SecureBuffer, TOptions) |
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoExtractPasswordHashingOptions |
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoVerify | (Overrides PasswordHashingAlgorithm DoVerify(SecureBuffer, HashedPassword, Boolean ).)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set (Inherited from ServiceWithInstrumentationBase TDirector .)
Public method | ExtractPasswordHashingOptions |
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Public method | Match | (Inherited from PasswordHashingAlgorithm.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | Verify | (Inherited from PasswordHashingAlgorithm.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PasswordHashingAlgorithm TOptions Class
NFX.Security Namespace


PasswordHashingAlgorithm(TOptions).ComputeHash Method

PasswordHashingAlgorithm TOptions ComputeHash Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public method | ComputeHash(PasswordFamily, SecureBuffer) | (Inherited from PasswordHashingAlgorithm.)
Public method | ComputeHash(PasswordFamily, SecureBuffer, TOptions) |
Back to Top
See Also
PasswordHashingAlgorithm TOptions Class
PasswordHashingAlgorithm TOptions Members
NFX.Security Namespace


PasswordHashingAlgorithm(TOptions).ComputeHash Method (PasswordFamily, SecureBuffer, TOptions)

PasswordHashingAlgorithm TOptions ComputeHash Method (PasswordFamily, SecureBuffer, TOptions) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HashedPassword ComputeHash(
    PasswordFamily family,
    SecureBuffer password,
    TOptions options
)
public HashedPassword ComputeHash(
    PasswordFamily family,
    SecureBuffer password,
    TOptions options
)
Public Function ComputeHash (
    family As PasswordFamily,
    password As SecureBuffer,
    options As TOptions
) As HashedPassword
Public Function ComputeHash (
    family As PasswordFamily,
    password As SecureBuffer,
    options As TOptions
) As HashedPassword
public:
HashedPassword^ ComputeHash(
    PasswordFamily family,
    SecureBuffer^ password,
    TOptions options
)
public:
HashedPassword^ ComputeHash(
    PasswordFamily family,
    SecureBuffer^ password,
    TOptions options
)
member ComputeHash :
        family : PasswordFamily *
        password : SecureBuffer *
        options : 'TOptions -> HashedPassword
member ComputeHash :
        family : PasswordFamily *
        password : SecureBuffer *
        options : 'TOptions -> HashedPassword

Parameters

family
Type: NFX.Security PasswordFamily
password
Type: NFX.Security SecureBuffer
options
Type: TOptions

Return Value

Type: HashedPassword
See Also
PasswordHashingAlgorithm TOptions Class
PasswordHashingAlgorithm TOptions Members
ComputeHash Overload
NFX.Security Namespace


PasswordHashingAlgorithm(TOptions).DoComputeHash Method

PasswordHashingAlgorithm TOptions DoComputeHash Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Protected method | DoComputeHash(PasswordFamily, SecureBuffer) | (Overrides PasswordHashingAlgorithm DoComputeHash(PasswordFamily, SecureBuffer).)
Protected method | DoComputeHash(PasswordFamily, SecureBuffer, TOptions) |
Back to Top
See Also
PasswordHashingAlgorithm TOptions Class
PasswordHashingAlgorithm TOptions Members
NFX.Security Namespace


PasswordHashingAlgorithm(TOptions).DoComputeHash Method (PasswordFamily, SecureBuffer)

PasswordHashingAlgorithm TOptions DoComputeHash Method (PasswordFamily, SecureBuffer) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override HashedPassword DoComputeHash(
    PasswordFamily family,
    SecureBuffer password
)
protected override HashedPassword DoComputeHash(
    PasswordFamily family,
    SecureBuffer password
)
Protected Overrides Function DoComputeHash (
    family As PasswordFamily,
    password As SecureBuffer
) As HashedPassword
Protected Overrides Function DoComputeHash (
    family As PasswordFamily,
    password As SecureBuffer
) As HashedPassword
protected:
virtual HashedPassword^ DoComputeHash(
    PasswordFamily family,
    SecureBuffer^ password
) override
protected:
virtual HashedPassword^ DoComputeHash(
    PasswordFamily family,
    SecureBuffer^ password
) override
abstract DoComputeHash :
        family : PasswordFamily *
        password : SecureBuffer -> HashedPassword
override DoComputeHash :
        family : PasswordFamily *
        password : SecureBuffer -> HashedPassword
abstract DoComputeHash :
        family : PasswordFamily *
        password : SecureBuffer -> HashedPassword
override DoComputeHash :
        family : PasswordFamily *
        password : SecureBuffer -> HashedPassword

Parameters

family
Type: NFX.Security PasswordFamily
password
Type: NFX.Security SecureBuffer

Return Value

Type: HashedPassword
See Also
PasswordHashingAlgorithm TOptions Class
PasswordHashingAlgorithm TOptions Members
DoComputeHash Overload
NFX.Security Namespace


PasswordHashingAlgorithm(TOptions).DoComputeHash Method (PasswordFamily, SecureBuffer, TOptions)

PasswordHashingAlgorithm TOptions DoComputeHash Method (PasswordFamily, SecureBuffer, TOptions) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract HashedPassword DoComputeHash(
    PasswordFamily family,
    SecureBuffer password,
    TOptions options
)
protected abstract HashedPassword DoComputeHash(
    PasswordFamily family,
    SecureBuffer password,
    TOptions options
)
Protected MustOverride Function DoComputeHash (
    family As PasswordFamily,
    password As SecureBuffer,
    options As TOptions
) As HashedPassword
Protected MustOverride Function DoComputeHash (
    family As PasswordFamily,
    password As SecureBuffer,
    options As TOptions
) As HashedPassword
protected:
virtual HashedPassword^ DoComputeHash(
    PasswordFamily family,
    SecureBuffer^ password,
    TOptions options
) abstract
protected:
virtual HashedPassword^ DoComputeHash(
    PasswordFamily family,
    SecureBuffer^ password,
    TOptions options
) abstract
abstract DoComputeHash :
        family : PasswordFamily *
        password : SecureBuffer *
        options : 'TOptions -> HashedPassword
abstract DoComputeHash :
        family : PasswordFamily *
        password : SecureBuffer *
        options : 'TOptions -> HashedPassword

Parameters

family
Type: NFX.Security PasswordFamily
password
Type: NFX.Security SecureBuffer
options
Type: TOptions

Return Value

Type: HashedPassword
See Also
PasswordHashingAlgorithm TOptions Class
PasswordHashingAlgorithm TOptions Members
DoComputeHash Overload
NFX.Security Namespace


PasswordHashingAlgorithm(TOptions).DoExtractPasswordHashingOptions Method

PasswordHashingAlgorithm TOptions DoExtractPasswordHashingOptions Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract TOptions DoExtractPasswordHashingOptions(
    HashedPassword hash,
    out bool needRehash
)
protected abstract TOptions DoExtractPasswordHashingOptions(
    HashedPassword hash,
    out bool needRehash
)
Protected MustOverride Function DoExtractPasswordHashingOptions (
    hash As HashedPassword,
    <OutAttribute> ByRef needRehash As Boolean
) As TOptions
Protected MustOverride Function DoExtractPasswordHashingOptions (
    hash As HashedPassword,
    <OutAttribute> ByRef needRehash As Boolean
) As TOptions
protected:
virtual TOptions DoExtractPasswordHashingOptions(
    HashedPassword^ hash,
    [OutAttribute] bool% needRehash
) abstract
protected:
virtual TOptions DoExtractPasswordHashingOptions(
    HashedPassword^ hash,
    [OutAttribute] bool% needRehash
) abstract
abstract DoExtractPasswordHashingOptions :
        hash : HashedPassword *
        needRehash : bool byref -> 'TOptions
abstract DoExtractPasswordHashingOptions :
        hash : HashedPassword *
        needRehash : bool byref -> 'TOptions

Parameters

hash
Type: NFX.Security HashedPassword
needRehash
Type: Online System Boolean

Return Value

Type: TOptions
See Also
PasswordHashingAlgorithm TOptions Class
PasswordHashingAlgorithm TOptions Members
NFX.Security Namespace


PasswordHashingAlgorithm(TOptions).DoVerify Method

PasswordHashingAlgorithm TOptions DoVerify Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool DoVerify(
    SecureBuffer password,
    HashedPassword hash,
    out bool needRehash
)
protected override bool DoVerify(
    SecureBuffer password,
    HashedPassword hash,
    out bool needRehash
)
Protected Overrides Function DoVerify (
    password As SecureBuffer,
    hash As HashedPassword,
    <OutAttribute> ByRef needRehash As Boolean
) As Boolean
Protected Overrides Function DoVerify (
    password As SecureBuffer,
    hash As HashedPassword,
    <OutAttribute> ByRef needRehash As Boolean
) As Boolean
protected:
virtual bool DoVerify(
    SecureBuffer^ password,
    HashedPassword^ hash,
    [OutAttribute] bool% needRehash
) override
protected:
virtual bool DoVerify(
    SecureBuffer^ password,
    HashedPassword^ hash,
    [OutAttribute] bool% needRehash
) override
abstract DoVerify :
        password : SecureBuffer *
        hash : HashedPassword *
        needRehash : bool byref -> bool
override DoVerify :
        password : SecureBuffer *
        hash : HashedPassword *
        needRehash : bool byref -> bool
abstract DoVerify :
        password : SecureBuffer *
        hash : HashedPassword *
        needRehash : bool byref -> bool
override DoVerify :
        password : SecureBuffer *
        hash : HashedPassword *
        needRehash : bool byref -> bool

Parameters

password
Type: NFX.Security SecureBuffer
hash
Type: NFX.Security HashedPassword
needRehash
Type: Online System Boolean

Return Value

Type: Online Boolean
See Also
PasswordHashingAlgorithm TOptions Class
PasswordHashingAlgorithm TOptions Members
NFX.Security Namespace


PasswordHashingAlgorithm(TOptions).ExtractPasswordHashingOptions Method

PasswordHashingAlgorithm TOptions ExtractPasswordHashingOptions Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TOptions ExtractPasswordHashingOptions(
    HashedPassword hash,
    out bool needRehash
)
public TOptions ExtractPasswordHashingOptions(
    HashedPassword hash,
    out bool needRehash
)
Public Function ExtractPasswordHashingOptions (
    hash As HashedPassword,
    <OutAttribute> ByRef needRehash As Boolean
) As TOptions
Public Function ExtractPasswordHashingOptions (
    hash As HashedPassword,
    <OutAttribute> ByRef needRehash As Boolean
) As TOptions
public:
TOptions ExtractPasswordHashingOptions(
    HashedPassword^ hash,
    [OutAttribute] bool% needRehash
)
public:
TOptions ExtractPasswordHashingOptions(
    HashedPassword^ hash,
    [OutAttribute] bool% needRehash
)
member ExtractPasswordHashingOptions :
        hash : HashedPassword *
        needRehash : bool byref -> 'TOptions
member ExtractPasswordHashingOptions :
        hash : HashedPassword *
        needRehash : bool byref -> 'TOptions

Parameters

hash
Type: NFX.Security HashedPassword
needRehash
Type: Online System Boolean

Return Value

Type: TOptions
See Also
PasswordHashingAlgorithm TOptions Class
PasswordHashingAlgorithm TOptions Members
NFX.Security Namespace


PasswordHashingAlgorithm(TOptions) Properties

PasswordHashingAlgorithm TOptions Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The PasswordHashingAlgorithm TOptions type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Protected property | DefaultPasswordHashingOptions |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component (Inherited from ServiceWithInstrumentationBase TDirector .)
Public property | InstrumentationEnabled | (Inherited from PasswordHashingAlgorithm.)
Public property | IsDefault | (Inherited from PasswordHashingAlgorithm.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | StrengthLevel | (Inherited from PasswordHashingAlgorithm.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
PasswordHashingAlgorithm TOptions Class
NFX.Security Namespace


PasswordHashingAlgorithm(TOptions).DefaultPasswordHashingOptions Property

PasswordHashingAlgorithm TOptions DefaultPasswordHashingOptions Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract TOptions DefaultPasswordHashingOptions { get; }
protected abstract TOptions DefaultPasswordHashingOptions { get; }
Protected MustOverride ReadOnly Property DefaultPasswordHashingOptions As TOptions
    Get
Protected MustOverride ReadOnly Property DefaultPasswordHashingOptions As TOptions
    Get
protected:
virtual property TOptions DefaultPasswordHashingOptions {
    TOptions get () abstract;
}
protected:
virtual property TOptions DefaultPasswordHashingOptions {
    TOptions get () abstract;
}
abstract DefaultPasswordHashingOptions : 'TOptions with get
abstract DefaultPasswordHashingOptions : 'TOptions with get

Property Value

Type: TOptions
See Also
PasswordHashingAlgorithm TOptions Class
PasswordHashingAlgorithm TOptions Members
NFX.Security Namespace


PasswordRepresentation Class

PasswordRepresentation Class NFX Class Library

Provides password representation content, i.e. an image with drawn password which is understandable by humans
Inheritance Hierarchy
Online System Object
NFX.Security PasswordRepresentation

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PasswordRepresentation
public class PasswordRepresentation
Public Class PasswordRepresentation
Public Class PasswordRepresentation
public ref class PasswordRepresentation
public ref class PasswordRepresentation
type PasswordRepresentation =  class end
type PasswordRepresentation =  class end
See Also
PasswordRepresentation Members
NFX.Security Namespace


PasswordRepresentation Members

PasswordRepresentation Members NFX Class Library

The PasswordRepresentation type exposes the following members.
Constructors
 | Name | Description
Public method | PasswordRepresentation | Initializes a new instance of the PasswordRepresentation class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Content |
Public property | ContentType |
Public property | Type |
Back to Top
See Also
PasswordRepresentation Class
NFX.Security Namespace


PasswordRepresentation Constructor

PasswordRepresentation Constructor NFX Class Library

Initializes a new instance of the PasswordRepresentation class

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PasswordRepresentation(
    PasswordRepresentationType type,
    string contentType,
    byte[] content
)
public PasswordRepresentation(
    PasswordRepresentationType type,
    string contentType,
    byte[] content
)
Public Sub New (
    type As PasswordRepresentationType,
    contentType As String,
    content As Byte()
)
Public Sub New (
    type As PasswordRepresentationType,
    contentType As String,
    content As Byte()
)
public:
PasswordRepresentation(
    PasswordRepresentationType type,
    String^ contentType,
    array<unsigned char>^ content
)
public:
PasswordRepresentation(
    PasswordRepresentationType type,
    String^ contentType,
    array<unsigned char>^ content
)
new :
        type : PasswordRepresentationType *
        contentType : string *
        content : byte[] -> PasswordRepresentation
new :
        type : PasswordRepresentationType *
        contentType : string *
        content : byte[] -> PasswordRepresentation

Parameters

type
Type: NFX.Security PasswordRepresentationType
contentType
Type: Online System String
content
Type: Online System Byte
See Also
PasswordRepresentation Class
PasswordRepresentation Members
NFX.Security Namespace


PasswordRepresentation Methods

PasswordRepresentation Methods NFX Class Library

The PasswordRepresentation type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PasswordRepresentation Class
NFX.Security Namespace


PasswordRepresentation Properties

PasswordRepresentation Properties NFX Class Library

The PasswordRepresentation type exposes the following members.
Properties
 | Name | Description
Public property | Content |
Public property | ContentType |
Public property | Type |
Back to Top
See Also
PasswordRepresentation Class
NFX.Security Namespace


PasswordRepresentation.Content Property

PasswordRepresentation Content Property NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] Content { get; }
public byte[] Content { get; }
Public ReadOnly Property Content As Byte()
    Get
Public ReadOnly Property Content As Byte()
    Get
public:
property array<unsigned char>^ Content {
    array<unsigned char>^ get ();
}
public:
property array<unsigned char>^ Content {
    array<unsigned char>^ get ();
}
member Content : byte[] with get
member Content : byte[] with get

Property Value

Type: Online Byte
See Also
PasswordRepresentation Class
PasswordRepresentation Members
NFX.Security Namespace


PasswordRepresentation.ContentType Property

PasswordRepresentation ContentType Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ContentType { get; }
public string ContentType { get; }
Public ReadOnly Property ContentType As String
    Get
Public ReadOnly Property ContentType As String
    Get
public:
property String^ ContentType {
    String^ get ();
}
public:
property String^ ContentType {
    String^ get ();
}
member ContentType : string with get
member ContentType : string with get

Property Value

Type: Online String
See Also
PasswordRepresentation Class
PasswordRepresentation Members
NFX.Security Namespace


PasswordRepresentation.Type Property

PasswordRepresentation Type Property NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PasswordRepresentationType Type { get; }
public PasswordRepresentationType Type { get; }
Public ReadOnly Property Type As PasswordRepresentationType
    Get
Public ReadOnly Property Type As PasswordRepresentationType
    Get
public:
property PasswordRepresentationType Type {
    PasswordRepresentationType get ();
}
public:
property PasswordRepresentationType Type {
    PasswordRepresentationType get ();
}
member Type : PasswordRepresentationType with get
member Type : PasswordRepresentationType with get

Property Value

Type: PasswordRepresentationType
See Also
PasswordRepresentation Class
PasswordRepresentation Members
NFX.Security Namespace


PasswordRepresentationType Enumeration

PasswordRepresentationType Enumeration NFX Class Library

Flags denote types of password representation: Text/Image/Audio

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[FlagsAttribute]
public enum PasswordRepresentationType
[FlagsAttribute]
public enum PasswordRepresentationType
<FlagsAttribute>
Public Enumeration PasswordRepresentationType
<FlagsAttribute>
Public Enumeration PasswordRepresentationType
[FlagsAttribute]
public enum class PasswordRepresentationType
[FlagsAttribute]
public enum class PasswordRepresentationType
[<FlagsAttribute>]
type PasswordRepresentationType
[<FlagsAttribute>]
type PasswordRepresentationType
Members
Member name | Value | Description
Text | 1 |
Image | 2 |
Audio | 4 |
See Also
NFX.Security Namespace


PasswordStrengthLevel Enumeration

PasswordStrengthLevel Enumeration NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum PasswordStrengthLevel
public enum PasswordStrengthLevel
Public Enumeration PasswordStrengthLevel
Public Enumeration PasswordStrengthLevel
public enum class PasswordStrengthLevel
public enum class PasswordStrengthLevel
type PasswordStrengthLevel
type PasswordStrengthLevel
Members
Member name | Value | Description
Default | 0 |
Minimum | 1 |
BelowNormal | 2 |
Normal | 3 |
AboveNormal | 4 |
Maximum | 5 |
See Also
NFX.Security Namespace


Permission Class

Permission Class NFX Class Library

Represents a general permission abstraction - where permission type represents the path/name of the permission in User's rights and .ctor takes specific parameters to check while authorizing user. Permission-derived class represents a certain permission type, whereas its instance is a check for particular desired level. To authorize certain actions, one creates an instance of Permission-derived class passing in its .ctor required access levels, then calls a Check() method that returns true if action is authorized. This scheme provides a great deal of flexibility, i.e. for very complex security cases developers may inherit leaf-level permissions from intermediate ones that have logic tied to session-level variables, this way user's access may vary by permission/session state, i.e. a user may have "Patient.Master" level 4 access in database "A", while having acess denied to the same named permission in database "B". User's database, or system instance is a flag in user-session context
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.Security Permission
NFX.Security AdHocPermission
NFX.Security TypedPermission

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Constructor|AttributeTargets.Method|AttributeTargets.Property|AttributeTargets.Field|AttributeTargets.Interface, Inherited = true,
    AllowMultiple = true)]
public abstract class Permission : Attribute
[AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Constructor|AttributeTargets.Method|AttributeTargets.Property|AttributeTargets.Field|AttributeTargets.Interface, Inherited = true,
    AllowMultiple = true)]
public abstract class Permission : Attribute
<AttributeUsageAttribute(AttributeTargets.Class Or AttributeTargets.Constructor Or AttributeTargets.Method Or AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Interface, Inherited := true,
    AllowMultiple := true)>
Public MustInherit Class Permission
    Inherits Attribute
<AttributeUsageAttribute(AttributeTargets.Class Or AttributeTargets.Constructor Or AttributeTargets.Method Or AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Interface, Inherited := true,
    AllowMultiple := true)>
Public MustInherit Class Permission
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Class|AttributeTargets::Constructor|AttributeTargets::Method|AttributeTargets::Property|AttributeTargets::Field|AttributeTargets::Interface, Inherited = true,
    AllowMultiple = true)]
public ref class Permission abstract : public Attribute
[AttributeUsageAttribute(AttributeTargets::Class|AttributeTargets::Constructor|AttributeTargets::Method|AttributeTargets::Property|AttributeTargets::Field|AttributeTargets::Interface, Inherited = true,
    AllowMultiple = true)]
public ref class Permission abstract : public Attribute
[<AbstractClassAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Constructor|AttributeTargets.Method|AttributeTargets.Property|AttributeTargets.Field|AttributeTargets.Interface, Inherited = true,
    AllowMultiple = true)>]
type Permission =
    class
        inherit Attribute
    end
[<AbstractClassAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Constructor|AttributeTargets.Method|AttributeTargets.Property|AttributeTargets.Field|AttributeTargets.Interface, Inherited = true,
    AllowMultiple = true)>]
type Permission =
    class
        inherit Attribute
    end
See Also
Permission Members
NFX.Security Namespace


Permission Members

Permission Members NFX Class Library

The Permission type exposes the following members.
Constructors
 | Name | Description
Protected method | Permission | Creates the check instance against the minimum access level for this permission
Back to Top
Methods
 | Name | Description
 | AuthorizeAction | Checks the action represented by MemberInfo by checking the permission-derived attributes and returns false if any of authorization attributes do not pass
 | AuthorizeAndGuardAction(MemberInfo, ISession, GetSessionFunc) | Guards the action represented by MemberInfo by checking the permission-derived attributes and throwing exception if any of authorization attributes do not pass
 | AuthorizeAndGuardAction(IEnumerable Permission , String, ISession, GetSessionFunc) | Guards the action represented by enumerable of permissions by checking all permissions and throwing exception if any of authorization attributes do not pass
Public method | Check(ISession) | Checks the permission for requested action as specified in particular permission .ctor. The check is performed in the scope of supplied session, or if no session was supplied then current execution context session is assumed
Public method | Check(User) | Shortcut method that creates a temp/mock BaseSession object thus checking permission in mock BaseSession context
Protected method | DoCheckAccessLevel | Override to perform access level checks per user's AccessLevel instance. True if accessLevel satisfies permission requirements. The default implementation checks the access.Level
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | FindAuthorizationFailingPermission | Checks the action represented by MemberInfo by checking the permission-derived attributes and returns false if any of authorization attributes do not pass
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | MultipleFromConf | Makes multiple permissions from conf node
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_PERMISSION_SECTION |
CONFIG_PERMISSIONS_SECTION |
Back to Top
Properties
 | Name | Description
Public property | Description | Returns the permission description - base implementation returns permission name
Public property | FullPath | Returns full permission path - a concatenation of its path and name
Public property | Level | Specifies the minimum access level for the permission check to pass
Public property | Name | Returns the permission name - the last segment of the path
Public property | Path | Returns a top-rooted path to this permission (without name)
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
Permission Class
NFX.Security Namespace


Permission Constructor

Permission Constructor NFX Class Library

Creates the check instance against the minimum access level for this permission

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Permission(
    int level
)
protected Permission(
    int level
)
Protected Sub New (
    level As Integer
)
Protected Sub New (
    level As Integer
)
protected:
Permission(
    int level
)
protected:
Permission(
    int level
)
new :
        level : int -> Permission
new :
        level : int -> Permission

Parameters

level
Type: Online System Int32
See Also
Permission Class
Permission Members
NFX.Security Namespace


Permission Fields

Permission Fields NFX Class Library

The Permission type exposes the following members.
Fields
Name | Description
CONFIG_PERMISSION_SECTION |
CONFIG_PERMISSIONS_SECTION |
Back to Top
See Also
Permission Class
NFX.Security Namespace


Permission.CONFIG_PERMISSION_SECTION Field

Permission CONFIG_PERMISSION_SECTION Field NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PERMISSION_SECTION
public const string CONFIG_PERMISSION_SECTION
Public Const CONFIG_PERMISSION_SECTION As String
Public Const CONFIG_PERMISSION_SECTION As String
public:
literal String^ CONFIG_PERMISSION_SECTION
public:
literal String^ CONFIG_PERMISSION_SECTION
static val mutable CONFIG_PERMISSION_SECTION: string
static val mutable CONFIG_PERMISSION_SECTION: string

Field Value

Type: Online String
See Also
Permission Class
Permission Members
NFX.Security Namespace


Permission.CONFIG_PERMISSIONS_SECTION Field

Permission CONFIG_PERMISSIONS_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_PERMISSIONS_SECTION
public const string CONFIG_PERMISSIONS_SECTION
Public Const CONFIG_PERMISSIONS_SECTION As String
Public Const CONFIG_PERMISSIONS_SECTION As String
public:
literal String^ CONFIG_PERMISSIONS_SECTION
public:
literal String^ CONFIG_PERMISSIONS_SECTION
static val mutable CONFIG_PERMISSIONS_SECTION: string
static val mutable CONFIG_PERMISSIONS_SECTION: string

Field Value

Type: Online String
See Also
Permission Class
Permission Members
NFX.Security Namespace


Permission Methods

Permission Methods NFX Class Library

The Permission type exposes the following members.
Methods
 | Name | Description
 | AuthorizeAction | Checks the action represented by MemberInfo by checking the permission-derived attributes and returns false if any of authorization attributes do not pass
 | AuthorizeAndGuardAction(MemberInfo, ISession, GetSessionFunc) | Guards the action represented by MemberInfo by checking the permission-derived attributes and throwing exception if any of authorization attributes do not pass
 | AuthorizeAndGuardAction(IEnumerable Permission , String, ISession, GetSessionFunc) | Guards the action represented by enumerable of permissions by checking all permissions and throwing exception if any of authorization attributes do not pass
Public method | Check(ISession) | Checks the permission for requested action as specified in particular permission .ctor. The check is performed in the scope of supplied session, or if no session was supplied then current execution context session is assumed
Public method | Check(User) | Shortcut method that creates a temp/mock BaseSession object thus checking permission in mock BaseSession context
Protected method | DoCheckAccessLevel | Override to perform access level checks per user's AccessLevel instance. True if accessLevel satisfies permission requirements. The default implementation checks the access.Level
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | FindAuthorizationFailingPermission | Checks the action represented by MemberInfo by checking the permission-derived attributes and returns false if any of authorization attributes do not pass
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | MultipleFromConf | Makes multiple permissions from conf node
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Permission Class
NFX.Security Namespace


Permission.AuthorizeAction Method

Permission AuthorizeAction Method NFX Class Library

Checks the action represented by MemberInfo by checking the permission-derived attributes and returns false if any of authorization attributes do not pass

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool AuthorizeAction(
    MemberInfo actionInfo,
    ISession session = null,
    GetSessionFunc getSessionFunc = null
)
public static bool AuthorizeAction(
    MemberInfo actionInfo,
    ISession session = null,
    GetSessionFunc getSessionFunc = null
)
Public Shared Function AuthorizeAction (
    actionInfo As MemberInfo,
    Optional session As ISession = Nothing,
    Optional getSessionFunc As GetSessionFunc = Nothing
) As Boolean
Public Shared Function AuthorizeAction (
    actionInfo As MemberInfo,
    Optional session As ISession = Nothing,
    Optional getSessionFunc As GetSessionFunc = Nothing
) As Boolean
public:
static bool AuthorizeAction(
    MemberInfo^ actionInfo,
    ISession^ session = nullptr,
    GetSessionFunc^ getSessionFunc = nullptr
)
public:
static bool AuthorizeAction(
    MemberInfo^ actionInfo,
    ISession^ session = nullptr,
    GetSessionFunc^ getSessionFunc = nullptr
)
static member AuthorizeAction :
        actionInfo : MemberInfo *
        ?session : ISession *
        ?getSessionFunc : GetSessionFunc
(* Defaults:
        let _session = defaultArg session null
        let _getSessionFunc = defaultArg getSessionFunc null
*)
-> bool
static member AuthorizeAction :
        actionInfo : MemberInfo *
        ?session : ISession *
        ?getSessionFunc : GetSessionFunc
(* Defaults:
        let _session = defaultArg session null
        let _getSessionFunc = defaultArg getSessionFunc null
*)
-> bool

Parameters

actionInfo
Type: Online System.Reflection MemberInfo
session (Optional)
Type: NFX.ApplicationModel ISession
getSessionFunc (Optional)
Type: NFX.Security GetSessionFunc

Return Value

Type: Online Boolean
See Also
Permission Class
Permission Members
NFX.Security Namespace


Permission.AuthorizeAndGuardAction Method

Permission AuthorizeAndGuardAction Method NFX Class Library

Overload List
Name | Description
AuthorizeAndGuardAction(MemberInfo, ISession, GetSessionFunc) | Guards the action represented by MemberInfo by checking the permission-derived attributes and throwing exception if any of authorization attributes do not pass
AuthorizeAndGuardAction(IEnumerable Permission , String, ISession, GetSessionFunc) | Guards the action represented by enumerable of permissions by checking all permissions and throwing exception if any of authorization attributes do not pass
Back to Top
See Also
Permission Class
Permission Members
NFX.Security Namespace


Permission.AuthorizeAndGuardAction Method (MemberInfo, ISession, GetSessionFunc)

Permission AuthorizeAndGuardAction Method (MemberInfo, ISession, GetSessionFunc) NFX Class Library

[This is preliminary documentation and is subject to change.]

Guards the action represented by MemberInfo by checking the permission-derived attributes and throwing exception if any of authorization attributes do not pass

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AuthorizeAndGuardAction(
    MemberInfo actionInfo,
    ISession session = null,
    GetSessionFunc getSessionFunc = null
)
public static void AuthorizeAndGuardAction(
    MemberInfo actionInfo,
    ISession session = null,
    GetSessionFunc getSessionFunc = null
)
Public Shared Sub AuthorizeAndGuardAction (
    actionInfo As MemberInfo,
    Optional session As ISession = Nothing,
    Optional getSessionFunc As GetSessionFunc = Nothing
)
Public Shared Sub AuthorizeAndGuardAction (
    actionInfo As MemberInfo,
    Optional session As ISession = Nothing,
    Optional getSessionFunc As GetSessionFunc = Nothing
)
public:
static void AuthorizeAndGuardAction(
    MemberInfo^ actionInfo,
    ISession^ session = nullptr,
    GetSessionFunc^ getSessionFunc = nullptr
)
public:
static void AuthorizeAndGuardAction(
    MemberInfo^ actionInfo,
    ISession^ session = nullptr,
    GetSessionFunc^ getSessionFunc = nullptr
)
static member AuthorizeAndGuardAction :
        actionInfo : MemberInfo *
        ?session : ISession *
        ?getSessionFunc : GetSessionFunc
(* Defaults:
        let _session = defaultArg session null
        let _getSessionFunc = defaultArg getSessionFunc null
*)
-> unit
static member AuthorizeAndGuardAction :
        actionInfo : MemberInfo *
        ?session : ISession *
        ?getSessionFunc : GetSessionFunc
(* Defaults:
        let _session = defaultArg session null
        let _getSessionFunc = defaultArg getSessionFunc null
*)
-> unit

Parameters

actionInfo
Type: Online System.Reflection MemberInfo
session (Optional)
Type: NFX.ApplicationModel ISession
getSessionFunc (Optional)
Type: NFX.Security GetSessionFunc
See Also
Permission Class
Permission Members
AuthorizeAndGuardAction Overload
NFX.Security Namespace


Permission.AuthorizeAndGuardAction Method (IEnumerable(Permission), String, ISession, GetSessionFunc)

Permission AuthorizeAndGuardAction Method (IEnumerable Permission , String, ISession, GetSessionFunc) NFX Class Library

[This is preliminary documentation and is subject to change.]

Guards the action represented by enumerable of permissions by checking all permissions and throwing exception if any of authorization attributes do not pass

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void AuthorizeAndGuardAction(
    IEnumerable<Permission> permissions,
    string actionName,
    ISession session = null,
    GetSessionFunc getSessionFunc = null
)
public static void AuthorizeAndGuardAction(
    IEnumerable<Permission> permissions,
    string actionName,
    ISession session = null,
    GetSessionFunc getSessionFunc = null
)
Public Shared Sub AuthorizeAndGuardAction (
    permissions As IEnumerable(Of Permission),
    actionName As String,
    Optional session As ISession = Nothing,
    Optional getSessionFunc As GetSessionFunc = Nothing
)
Public Shared Sub AuthorizeAndGuardAction (
    permissions As IEnumerable(Of Permission),
    actionName As String,
    Optional session As ISession = Nothing,
    Optional getSessionFunc As GetSessionFunc = Nothing
)
public:
static void AuthorizeAndGuardAction(
    IEnumerable<Permission^>^ permissions,
    String^ actionName,
    ISession^ session = nullptr,
    GetSessionFunc^ getSessionFunc = nullptr
)
public:
static void AuthorizeAndGuardAction(
    IEnumerable<Permission^>^ permissions,
    String^ actionName,
    ISession^ session = nullptr,
    GetSessionFunc^ getSessionFunc = nullptr
)
static member AuthorizeAndGuardAction :
        permissions : IEnumerable<Permission> *
        actionName : string *
        ?session : ISession *
        ?getSessionFunc : GetSessionFunc
(* Defaults:
        let _session = defaultArg session null
        let _getSessionFunc = defaultArg getSessionFunc null
*)
-> unit
static member AuthorizeAndGuardAction :
        permissions : IEnumerable<Permission> *
        actionName : string *
        ?session : ISession *
        ?getSessionFunc : GetSessionFunc
(* Defaults:
        let _session = defaultArg session null
        let _getSessionFunc = defaultArg getSessionFunc null
*)
-> unit

Parameters

permissions
Type: Online System.Collections.Generic IEnumerable Permission
actionName
Type: Online System String
session (Optional)
Type: NFX.ApplicationModel ISession
getSessionFunc (Optional)
Type: NFX.Security GetSessionFunc
See Also
Permission Class
Permission Members
AuthorizeAndGuardAction Overload
NFX.Security Namespace


Permission.Check Method

Permission Check Method NFX Class Library

Overload List
 | Name | Description
Public method | Check(ISession) | Checks the permission for requested action as specified in particular permission .ctor. The check is performed in the scope of supplied session, or if no session was supplied then current execution context session is assumed
Public method | Check(User) | Shortcut method that creates a temp/mock BaseSession object thus checking permission in mock BaseSession context
Back to Top
See Also
Permission Class
Permission Members
NFX.Security Namespace


Permission.Check Method (ISession)

Permission Check Method (ISession) NFX Class Library

Checks the permission for requested action as specified in particular permission .ctor. The check is performed in the scope of supplied session, or if no session was supplied then current execution context session is assumed

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool Check(
    ISession sessionInstance = null
)
public virtual bool Check(
    ISession sessionInstance = null
)
Public Overridable Function Check (
    Optional sessionInstance As ISession = Nothing
) As Boolean
Public Overridable Function Check (
    Optional sessionInstance As ISession = Nothing
) As Boolean
public:
virtual bool Check(
    ISession^ sessionInstance = nullptr
)
public:
virtual bool Check(
    ISession^ sessionInstance = nullptr
)
abstract Check :
        ?sessionInstance : ISession
(* Defaults:
        let _sessionInstance = defaultArg sessionInstance null
*)
-> bool
override Check :
        ?sessionInstance : ISession
(* Defaults:
        let _sessionInstance = defaultArg sessionInstance null
*)
-> bool
abstract Check :
        ?sessionInstance : ISession
(* Defaults:
        let _sessionInstance = defaultArg sessionInstance null
*)
-> bool
override Check :
        ?sessionInstance : ISession
(* Defaults:
        let _sessionInstance = defaultArg sessionInstance null
*)
-> bool

Parameters

sessionInstance (Optional)
Type: NFX.ApplicationModel ISession

Return Value

Type: Online Boolean
True when action is authorized, false otherwise
See Also
Permission Class
Permission Members
Check Overload
NFX.Security Namespace


Permission.Check Method (User)

Permission Check Method (User) NFX Class Library

Shortcut method that creates a temp/mock BaseSession object thus checking permission in mock BaseSession context

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Check(
    User user
)
public bool Check(
    User user
)
Public Function Check (
    user As User
) As Boolean
Public Function Check (
    user As User
) As Boolean
public:
bool Check(
    User^ user
)
public:
bool Check(
    User^ user
)
member Check :
        user : User -> bool
member Check :
        user : User -> bool

Parameters

user
Type: NFX.Security User

Return Value

Type: Online Boolean
See Also
Permission Class
Permission Members
Check Overload
NFX.Security Namespace


Permission.DoCheckAccessLevel Method

Permission DoCheckAccessLevel Method NFX Class Library

Override to perform access level checks per user's AccessLevel instance. True if accessLevel satisfies permission requirements. The default implementation checks the access.Level

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool DoCheckAccessLevel(
    ISession session,
    AccessLevel access
)
protected virtual bool DoCheckAccessLevel(
    ISession session,
    AccessLevel access
)
Protected Overridable Function DoCheckAccessLevel (
    session As ISession,
    access As AccessLevel
) As Boolean
Protected Overridable Function DoCheckAccessLevel (
    session As ISession,
    access As AccessLevel
) As Boolean
protected:
virtual bool DoCheckAccessLevel(
    ISession^ session,
    AccessLevel^ access
)
protected:
virtual bool DoCheckAccessLevel(
    ISession^ session,
    AccessLevel^ access
)
abstract DoCheckAccessLevel :
        session : ISession *
        access : AccessLevel -> bool
override DoCheckAccessLevel :
        session : ISession *
        access : AccessLevel -> bool
abstract DoCheckAccessLevel :
        session : ISession *
        access : AccessLevel -> bool
override DoCheckAccessLevel :
        session : ISession *
        access : AccessLevel -> bool

Parameters

session
Type: NFX.ApplicationModel ISession
access
Type: NFX.Security AccessLevel

Return Value

Type: Online Boolean
See Also
Permission Class
Permission Members
NFX.Security Namespace


Permission.FindAuthorizationFailingPermission Method

Permission FindAuthorizationFailingPermission Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Checks the action represented by MemberInfo by checking the permission-derived attributes and returns false if any of authorization attributes do not pass

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Permission FindAuthorizationFailingPermission(
    MemberInfo actionInfo,
    ISession session = null,
    GetSessionFunc getSessionFunc = null
)
public static Permission FindAuthorizationFailingPermission(
    MemberInfo actionInfo,
    ISession session = null,
    GetSessionFunc getSessionFunc = null
)
Public Shared Function FindAuthorizationFailingPermission (
    actionInfo As MemberInfo,
    Optional session As ISession = Nothing,
    Optional getSessionFunc As GetSessionFunc = Nothing
) As Permission
Public Shared Function FindAuthorizationFailingPermission (
    actionInfo As MemberInfo,
    Optional session As ISession = Nothing,
    Optional getSessionFunc As GetSessionFunc = Nothing
) As Permission
public:
static Permission^ FindAuthorizationFailingPermission(
    MemberInfo^ actionInfo,
    ISession^ session = nullptr,
    GetSessionFunc^ getSessionFunc = nullptr
)
public:
static Permission^ FindAuthorizationFailingPermission(
    MemberInfo^ actionInfo,
    ISession^ session = nullptr,
    GetSessionFunc^ getSessionFunc = nullptr
)
static member FindAuthorizationFailingPermission :
        actionInfo : MemberInfo *
        ?session : ISession *
        ?getSessionFunc : GetSessionFunc
(* Defaults:
        let _session = defaultArg session null
        let _getSessionFunc = defaultArg getSessionFunc null
*)
-> Permission
static member FindAuthorizationFailingPermission :
        actionInfo : MemberInfo *
        ?session : ISession *
        ?getSessionFunc : GetSessionFunc
(* Defaults:
        let _session = defaultArg session null
        let _getSessionFunc = defaultArg getSessionFunc null
*)
-> Permission

Parameters

actionInfo
Type: Online System.Reflection MemberInfo
session (Optional)
Type: NFX.ApplicationModel ISession
getSessionFunc (Optional)
Type: NFX.Security GetSessionFunc

Return Value

Type: Permission
See Also
Permission Class
Permission Members
NFX.Security Namespace


Permission.MultipleFromConf Method

Permission MultipleFromConf Method NFX Class Library

Makes multiple permissions from conf node

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<Permission> MultipleFromConf(
    IConfigSectionNode node,
    string shortNodeName = null,
    string typePattern = null
)
public static IEnumerable<Permission> MultipleFromConf(
    IConfigSectionNode node,
    string shortNodeName = null,
    string typePattern = null
)
Public Shared Function MultipleFromConf (
    node As IConfigSectionNode,
    Optional shortNodeName As String = Nothing,
    Optional typePattern As String = Nothing
) As IEnumerable(Of Permission)
Public Shared Function MultipleFromConf (
    node As IConfigSectionNode,
    Optional shortNodeName As String = Nothing,
    Optional typePattern As String = Nothing
) As IEnumerable(Of Permission)
public:
static IEnumerable<Permission^>^ MultipleFromConf(
    IConfigSectionNode^ node,
    String^ shortNodeName = nullptr,
    String^ typePattern = nullptr
)
public:
static IEnumerable<Permission^>^ MultipleFromConf(
    IConfigSectionNode^ node,
    String^ shortNodeName = nullptr,
    String^ typePattern = nullptr
)
static member MultipleFromConf :
        node : IConfigSectionNode *
        ?shortNodeName : string *
        ?typePattern : string
(* Defaults:
        let _shortNodeName = defaultArg shortNodeName null
        let _typePattern = defaultArg typePattern null
*)
-> IEnumerable<Permission>
static member MultipleFromConf :
        node : IConfigSectionNode *
        ?shortNodeName : string *
        ?typePattern : string
(* Defaults:
        let _shortNodeName = defaultArg shortNodeName null
        let _typePattern = defaultArg typePattern null
*)
-> IEnumerable<Permission>

Parameters

node
Type: NFX.Environment IConfigSectionNode
shortNodeName (Optional)
Type: Online System String
typePattern (Optional)
Type: Online System String

Return Value

Type: Online IEnumerable Permission
See Also
Permission Class
Permission Members
NFX.Security Namespace


Permission.ToString Method

Permission ToString Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
Permission Class
Permission Members
NFX.Security Namespace


Permission Properties

Permission Properties NFX Class Library

The Permission type exposes the following members.
Properties
 | Name | Description
Public property | Description | Returns the permission description - base implementation returns permission name
Public property | FullPath | Returns full permission path - a concatenation of its path and name
Public property | Level | Specifies the minimum access level for the permission check to pass
Public property | Name | Returns the permission name - the last segment of the path
Public property | Path | Returns a top-rooted path to this permission (without name)
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
Permission Class
NFX.Security Namespace


Permission.Description Property

Permission Description Property NFX Class Library

Returns the permission description - base implementation returns permission name

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual string Description { get; }
public virtual string Description { get; }
Public Overridable ReadOnly Property Description As String
    Get
Public Overridable ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get ();
}
public:
virtual property String^ Description {
    String^ get ();
}
abstract Description : string with get
override Description : string with get
abstract Description : string with get
override Description : string with get

Property Value

Type: Online String
See Also
Permission Class
Permission Members
NFX.Security Namespace


Permission.FullPath Property

Permission FullPath Property NFX Class Library

Returns full permission path - a concatenation of its path and name

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string FullPath { get; }
public string FullPath { get; }
Public ReadOnly Property FullPath As String
    Get
Public ReadOnly Property FullPath As String
    Get
public:
property String^ FullPath {
    String^ get ();
}
public:
property String^ FullPath {
    String^ get ();
}
member FullPath : string with get
member FullPath : string with get

Property Value

Type: Online String
See Also
Permission Class
Permission Members
NFX.Security Namespace


Permission.Level Property

Permission Level Property NFX Class Library

Specifies the minimum access level for the permission check to pass

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Level { get; }
public int Level { get; }
Public ReadOnly Property Level As Integer
    Get
Public ReadOnly Property Level As Integer
    Get
public:
property int Level {
    int get ();
}
public:
property int Level {
    int get ();
}
member Level : int with get
member Level : int with get

Property Value

Type: Online Int32
See Also
Permission Class
Permission Members
NFX.Security Namespace


Permission.Name Property

Permission Name Property NFX Class Library

Returns the permission name - the last segment of the path

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string Name { get; }
public abstract string Name { get; }
Public MustOverride ReadOnly Property Name As String
    Get
Public MustOverride ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () abstract;
}
public:
virtual property String^ Name {
    String^ get () abstract;
}
abstract Name : string with get
abstract Name : string with get

Property Value

Type: Online String
See Also
Permission Class
Permission Members
NFX.Security Namespace


Permission.Path Property

Permission Path Property NFX Class Library

Returns a top-rooted path to this permission (without name)

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string Path { get; }
public abstract string Path { get; }
Public MustOverride ReadOnly Property Path As String
    Get
Public MustOverride ReadOnly Property Path As String
    Get
public:
virtual property String^ Path {
    String^ get () abstract;
}
public:
virtual property String^ Path {
    String^ get () abstract;
}
abstract Path : string with get
abstract Path : string with get

Property Value

Type: Online String
See Also
Permission Class
Permission Members
NFX.Security Namespace


Rights Class

Rights Class NFX Class Library

User rights contains data about access levels to permissions in the system. Use Configuration internally to keep the data organized in hierarchical navigable structure. Configuration also allows to cross-link permission levels using vars and make acess level dependent on settings on a particular machine using environmental vars
Inheritance Hierarchy
Online System Object
NFX.Security Rights

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class Rights
public sealed class Rights
Public NotInheritable Class Rights
Public NotInheritable Class Rights
public ref class Rights sealed
public ref class Rights sealed
[<SealedAttribute>]
type Rights =  class end
[<SealedAttribute>]
type Rights =  class end
See Also
Rights Members
NFX.Security Namespace


Rights Members

Rights Members NFX Class Library

The Rights type exposes the following members.
Constructors
 | Name | Description
Public method | Rights | Initializes a new instance of the Rights class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_ROOT_SECTION |
Back to Top
Properties
 | Name | Description
 | None | An instance that signifies an absence of any rights at all - complete access denied
Public property | Root |
Back to Top
See Also
Rights Class
NFX.Security Namespace


Rights Constructor

Rights Constructor NFX Class Library

Initializes a new instance of the Rights class

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Rights(
    Configuration data
)
public Rights(
    Configuration data
)
Public Sub New (
    data As Configuration
)
Public Sub New (
    data As Configuration
)
public:
Rights(
    Configuration^ data
)
public:
Rights(
    Configuration^ data
)
new :
        data : Configuration -> Rights
new :
        data : Configuration -> Rights

Parameters

data
Type: NFX.Environment Configuration
See Also
Rights Class
Rights Members
NFX.Security Namespace


Rights Fields

Rights Fields NFX Class Library

The Rights type exposes the following members.
Fields
Name | Description
CONFIG_ROOT_SECTION |
Back to Top
See Also
Rights Class
NFX.Security Namespace


Rights.CONFIG_ROOT_SECTION Field

Rights CONFIG_ROOT_SECTION Field NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_ROOT_SECTION
public const string CONFIG_ROOT_SECTION
Public Const CONFIG_ROOT_SECTION As String
Public Const CONFIG_ROOT_SECTION As String
public:
literal String^ CONFIG_ROOT_SECTION
public:
literal String^ CONFIG_ROOT_SECTION
static val mutable CONFIG_ROOT_SECTION: string
static val mutable CONFIG_ROOT_SECTION: string

Field Value

Type: Online String
See Also
Rights Class
Rights Members
NFX.Security Namespace


Rights Methods

Rights Methods NFX Class Library

The Rights type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Rights Class
NFX.Security Namespace


Rights Properties

Rights Properties NFX Class Library

The Rights type exposes the following members.
Properties
 | Name | Description
 | None | An instance that signifies an absence of any rights at all - complete access denied
Public property | Root |
Back to Top
See Also
Rights Class
NFX.Security Namespace


Rights.None Property

Rights None Property NFX Class Library

An instance that signifies an absence of any rights at all - complete access denied

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Rights None { get; }
public static Rights None { get; }
Public Shared ReadOnly Property None As Rights
    Get
Public Shared ReadOnly Property None As Rights
    Get
public:
static property Rights^ None {
    Rights^ get ();
}
public:
static property Rights^ None {
    Rights^ get ();
}
static member None : Rights with get
static member None : Rights with get

Property Value

Type: Rights
See Also
Rights Class
Rights Members
NFX.Security Namespace


Rights.Root Property

Rights Root Property NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IConfigSectionNode Root { get; }
public IConfigSectionNode Root { get; }
Public ReadOnly Property Root As IConfigSectionNode
    Get
Public ReadOnly Property Root As IConfigSectionNode
    Get
public:
property IConfigSectionNode^ Root {
    IConfigSectionNode^ get ();
}
public:
property IConfigSectionNode^ Root {
    IConfigSectionNode^ get ();
}
member Root : IConfigSectionNode with get
member Root : IConfigSectionNode with get

Property Value

Type: IConfigSectionNode
See Also
Rights Class
Rights Members
NFX.Security Namespace


SecureBuffer Class

SecureBuffer Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Security SecureBuffer

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SlimSerializationProhibitedAttribute]
public sealed class SecureBuffer : DisposableObject
[SlimSerializationProhibitedAttribute]
public sealed class SecureBuffer : DisposableObject
<SlimSerializationProhibitedAttribute>
Public NotInheritable Class SecureBuffer
    Inherits DisposableObject
<SlimSerializationProhibitedAttribute>
Public NotInheritable Class SecureBuffer
    Inherits DisposableObject
[SlimSerializationProhibitedAttribute]
public ref class SecureBuffer sealed : public DisposableObject
[SlimSerializationProhibitedAttribute]
public ref class SecureBuffer sealed : public DisposableObject
[<SealedAttribute>]
[<SlimSerializationProhibitedAttribute>]
type SecureBuffer =
    class
        inherit DisposableObject
    end
[<SealedAttribute>]
[<SlimSerializationProhibitedAttribute>]
type SecureBuffer =
    class
        inherit DisposableObject
    end
See Also
SecureBuffer Members
NFX.Security Namespace


SecureBuffer Members

SecureBuffer Members NFX Class Library

The SecureBuffer type exposes the following members.
Constructors
 | Name | Description
Public method | SecureBuffer | Initializes a new instance of the SecureBuffer class
Back to Top
Methods
 | Name | Description
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Forget |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Push |
Public method | Seal |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Content |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | IsSealed |
Back to Top
See Also
SecureBuffer Class
NFX.Security Namespace


SecureBuffer Constructor

SecureBuffer Constructor NFX Class Library

Initializes a new instance of the SecureBuffer class

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SecureBuffer(
    int capacity = 32
)
public SecureBuffer(
    int capacity = 32
)
Public Sub New (
    Optional capacity As Integer = 32
)
Public Sub New (
    Optional capacity As Integer = 32
)
public:
SecureBuffer(
    int capacity = 32
)
public:
SecureBuffer(
    int capacity = 32
)
new :
        ?capacity : int
(* Defaults:
        let _capacity = defaultArg capacity 32
*)
-> SecureBuffer
new :
        ?capacity : int
(* Defaults:
        let _capacity = defaultArg capacity 32
*)
-> SecureBuffer

Parameters

capacity (Optional)
Type: Online System Int32
See Also
SecureBuffer Class
SecureBuffer Members
NFX.Security Namespace


SecureBuffer Methods

SecureBuffer Methods NFX Class Library

The SecureBuffer type exposes the following members.
Methods
 | Name | Description
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Forget |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Push |
Public method | Seal |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SecureBuffer Class
NFX.Security Namespace


SecureBuffer.Destructor Method

SecureBuffer Destructor Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
SecureBuffer Class
SecureBuffer Members
NFX.Security Namespace


SecureBuffer.Forget Method

SecureBuffer Forget Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Forget()
public void Forget()
Public Sub Forget
Public Sub Forget
public:
void Forget()
public:
void Forget()
member Forget : unit -> unit
member Forget : unit -> unit
See Also
SecureBuffer Class
SecureBuffer Members
NFX.Security Namespace


SecureBuffer.Push Method

SecureBuffer Push Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Push(
    byte b
)
public void Push(
    byte b
)
Public Sub Push (
    b As Byte
)
Public Sub Push (
    b As Byte
)
public:
void Push(
    unsigned char b
)
public:
void Push(
    unsigned char b
)
member Push :
        b : byte -> unit
member Push :
        b : byte -> unit

Parameters

b
Type: Online System Byte
See Also
SecureBuffer Class
SecureBuffer Members
NFX.Security Namespace


SecureBuffer.Seal Method

SecureBuffer Seal Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Seal()
public void Seal()
Public Sub Seal
Public Sub Seal
public:
void Seal()
public:
void Seal()
member Seal : unit -> unit
member Seal : unit -> unit
See Also
SecureBuffer Class
SecureBuffer Members
NFX.Security Namespace


SecureBuffer Properties

SecureBuffer Properties NFX Class Library

The SecureBuffer type exposes the following members.
Properties
 | Name | Description
Public property | Content |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | IsSealed |
Back to Top
See Also
SecureBuffer Class
NFX.Security Namespace


SecureBuffer.Content Property

SecureBuffer Content Property NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] Content { get; }
public byte[] Content { get; }
Public ReadOnly Property Content As Byte()
    Get
Public ReadOnly Property Content As Byte()
    Get
public:
property array<unsigned char>^ Content {
    array<unsigned char>^ get ();
}
public:
property array<unsigned char>^ Content {
    array<unsigned char>^ get ();
}
member Content : byte[] with get
member Content : byte[] with get

Property Value

Type: Online Byte
See Also
SecureBuffer Class
SecureBuffer Members
NFX.Security Namespace


SecureBuffer.IsSealed Property

SecureBuffer IsSealed Property NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsSealed { get; }
public bool IsSealed { get; }
Public ReadOnly Property IsSealed As Boolean
    Get
Public ReadOnly Property IsSealed As Boolean
    Get
public:
property bool IsSealed {
    bool get ();
}
public:
property bool IsSealed {
    bool get ();
}
member IsSealed : bool with get
member IsSealed : bool with get

Property Value

Type: Online Boolean
See Also
SecureBuffer Class
SecureBuffer Members
NFX.Security Namespace


SecurityException Class

SecurityException Class NFX Class Library

Base exception thrown by the Security framework
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Security SecurityException
NFX.Security AuthorizationException

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SecurityException : NFXException,
    ISecurityException
[SerializableAttribute]
public class SecurityException : NFXException,
    ISecurityException
<SerializableAttribute>
Public Class SecurityException
    Inherits NFXException
    Implements ISecurityException
<SerializableAttribute>
Public Class SecurityException
    Inherits NFXException
    Implements ISecurityException
[SerializableAttribute]
public ref class SecurityException : public NFXException,
    ISecurityException
[SerializableAttribute]
public ref class SecurityException : public NFXException,
    ISecurityException
[<SerializableAttribute>]
type SecurityException =
    class
        inherit NFXException
        interface ISecurityException
    end
[<SerializableAttribute>]
type SecurityException =
    class
        inherit NFXException
        interface ISecurityException
    end
See Also
SecurityException Members
NFX.Security Namespace


SecurityException Members

SecurityException Members NFX Class Library

The SecurityException type exposes the following members.
Constructors
 | Name | Description
Public method | SecurityException | Initializes a new instance of the SecurityException class
Public method | SecurityException(String) | Initializes a new instance of the SecurityException class
Protected method | SecurityException(SerializationInfo, StreamingContext) | Initializes a new instance of the SecurityException class
Public method | SecurityException(String, Exception) | Initializes a new instance of the SecurityException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
SecurityException Class
NFX.Security Namespace


SecurityException Constructor

SecurityException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | SecurityException | Initializes a new instance of the SecurityException class
Public method | SecurityException(String) | Initializes a new instance of the SecurityException class
Protected method | SecurityException(SerializationInfo, StreamingContext) | Initializes a new instance of the SecurityException class
Public method | SecurityException(String, Exception) | Initializes a new instance of the SecurityException class
Back to Top
See Also
SecurityException Class
SecurityException Members
NFX.Security Namespace


SecurityException Constructor

SecurityException Constructor NFX Class Library

Initializes a new instance of the SecurityException class

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SecurityException()
public SecurityException()
Public Sub New
Public Sub New
public:
SecurityException()
public:
SecurityException()
new : unit -> SecurityException
new : unit -> SecurityException
See Also
SecurityException Class
SecurityException Members
SecurityException Overload
NFX.Security Namespace


SecurityException Constructor (String)

SecurityException Constructor (String) NFX Class Library

Initializes a new instance of the SecurityException class

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SecurityException(
    string message
)
public SecurityException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
SecurityException(
    String^ message
)
public:
SecurityException(
    String^ message
)
new :
        message : string -> SecurityException
new :
        message : string -> SecurityException

Parameters

message
Type: Online System String
See Also
SecurityException Class
SecurityException Members
SecurityException Overload
NFX.Security Namespace


SecurityException Constructor (SerializationInfo, StreamingContext)

SecurityException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SecurityException class

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected SecurityException(
    SerializationInfo info,
    StreamingContext context
)
protected SecurityException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
SecurityException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
SecurityException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SecurityException
new :
        info : SerializationInfo *
        context : StreamingContext -> SecurityException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
SecurityException Class
SecurityException Members
SecurityException Overload
NFX.Security Namespace


SecurityException Constructor (String, Exception)

SecurityException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SecurityException class

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SecurityException(
    string message,
    Exception inner
)
public SecurityException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
SecurityException(
    String^ message,
    Exception^ inner
)
public:
SecurityException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> SecurityException
new :
        message : string *
        inner : Exception -> SecurityException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
SecurityException Class
SecurityException Members
SecurityException Overload
NFX.Security Namespace


SecurityException Methods

SecurityException Methods NFX Class Library

The SecurityException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
SecurityException Class
NFX.Security Namespace


SecurityException Properties

SecurityException Properties NFX Class Library

The SecurityException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
SecurityException Class
NFX.Security Namespace


SecurityException Events

SecurityException Events NFX Class Library

The SecurityException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
SecurityException Class
NFX.Security Namespace


SocialNetTokenCredentials Class

SocialNetTokenCredentials Class NFX Class Library

Represents credentials supplied from/to Social Net site (i.e. Facebook, Twitter etc.)
Inheritance Hierarchy
Online System Object
NFX.Security Credentials
NFX.Security SocialNetTokenCredentials

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SocialNetTokenCredentials : Credentials
[SerializableAttribute]
public class SocialNetTokenCredentials : Credentials
<SerializableAttribute>
Public Class SocialNetTokenCredentials
    Inherits Credentials
<SerializableAttribute>
Public Class SocialNetTokenCredentials
    Inherits Credentials
[SerializableAttribute]
public ref class SocialNetTokenCredentials : public Credentials
[SerializableAttribute]
public ref class SocialNetTokenCredentials : public Credentials
[<SerializableAttribute>]
type SocialNetTokenCredentials =
    class
        inherit Credentials
    end
[<SerializableAttribute>]
type SocialNetTokenCredentials =
    class
        inherit Credentials
    end
See Also
SocialNetTokenCredentials Members
NFX.Security Namespace


SocialNetTokenCredentials Members

SocialNetTokenCredentials Members NFX Class Library

The SocialNetTokenCredentials type exposes the following members.
Constructors
 | Name | Description
Public method | SocialNetTokenCredentials | Initializes a new instance of the SocialNetTokenCredentials class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Forget | (Overrides Credentials Forget .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Forgotten | Indicates whether Forget() was called on this instance (Inherited from Credentials.)
Public property | NetName | Name of social network that returned the token
Public property | Token | Auth token returned by the network
Public property | UserName | Optional user name as returned from social network (i.e. email or account screen name)
Back to Top
See Also
SocialNetTokenCredentials Class
NFX.Security Namespace


SocialNetTokenCredentials Constructor

SocialNetTokenCredentials Constructor NFX Class Library

Initializes a new instance of the SocialNetTokenCredentials class

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SocialNetTokenCredentials(
    string netName,
    string token,
    string userName = null
)
public SocialNetTokenCredentials(
    string netName,
    string token,
    string userName = null
)
Public Sub New (
    netName As String,
    token As String,
    Optional userName As String = Nothing
)
Public Sub New (
    netName As String,
    token As String,
    Optional userName As String = Nothing
)
public:
SocialNetTokenCredentials(
    String^ netName,
    String^ token,
    String^ userName = nullptr
)
public:
SocialNetTokenCredentials(
    String^ netName,
    String^ token,
    String^ userName = nullptr
)
new :
        netName : string *
        token : string *
        ?userName : string
(* Defaults:
        let _userName = defaultArg userName null
*)
-> SocialNetTokenCredentials
new :
        netName : string *
        token : string *
        ?userName : string
(* Defaults:
        let _userName = defaultArg userName null
*)
-> SocialNetTokenCredentials

Parameters

netName
Type: Online System String
token
Type: Online System String
userName (Optional)
Type: Online System String
See Also
SocialNetTokenCredentials Class
SocialNetTokenCredentials Members
NFX.Security Namespace


SocialNetTokenCredentials Methods

SocialNetTokenCredentials Methods NFX Class Library

The SocialNetTokenCredentials type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Forget | (Overrides Credentials Forget .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SocialNetTokenCredentials Class
NFX.Security Namespace


SocialNetTokenCredentials.Forget Method

SocialNetTokenCredentials Forget Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void Forget()
public override void Forget()
Public Overrides Sub Forget
Public Overrides Sub Forget
public:
virtual void Forget() override
public:
virtual void Forget() override
abstract Forget : unit -> unit
override Forget : unit -> unit
abstract Forget : unit -> unit
override Forget : unit -> unit
See Also
SocialNetTokenCredentials Class
SocialNetTokenCredentials Members
NFX.Security Namespace


SocialNetTokenCredentials.ToString Method

SocialNetTokenCredentials ToString Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
SocialNetTokenCredentials Class
SocialNetTokenCredentials Members
NFX.Security Namespace


SocialNetTokenCredentials Properties

SocialNetTokenCredentials Properties NFX Class Library

The SocialNetTokenCredentials type exposes the following members.
Properties
 | Name | Description
Public property | Forgotten | Indicates whether Forget() was called on this instance (Inherited from Credentials.)
Public property | NetName | Name of social network that returned the token
Public property | Token | Auth token returned by the network
Public property | UserName | Optional user name as returned from social network (i.e. email or account screen name)
Back to Top
See Also
SocialNetTokenCredentials Class
NFX.Security Namespace


SocialNetTokenCredentials.NetName Property

SocialNetTokenCredentials NetName Property NFX Class Library

Name of social network that returned the token

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string NetName { get; }
public string NetName { get; }
Public ReadOnly Property NetName As String
    Get
Public ReadOnly Property NetName As String
    Get
public:
property String^ NetName {
    String^ get ();
}
public:
property String^ NetName {
    String^ get ();
}
member NetName : string with get
member NetName : string with get

Property Value

Type: Online String
See Also
SocialNetTokenCredentials Class
SocialNetTokenCredentials Members
NFX.Security Namespace


SocialNetTokenCredentials.Token Property

SocialNetTokenCredentials Token Property NFX Class Library

Auth token returned by the network

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Token { get; }
public string Token { get; }
Public ReadOnly Property Token As String
    Get
Public ReadOnly Property Token As String
    Get
public:
property String^ Token {
    String^ get ();
}
public:
property String^ Token {
    String^ get ();
}
member Token : string with get
member Token : string with get

Property Value

Type: Online String
See Also
SocialNetTokenCredentials Class
SocialNetTokenCredentials Members
NFX.Security Namespace


SocialNetTokenCredentials.UserName Property

SocialNetTokenCredentials UserName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Optional user name as returned from social network (i.e. email or account screen name)

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string UserName { get; }
public string UserName { get; }
Public ReadOnly Property UserName As String
    Get
Public ReadOnly Property UserName As String
    Get
public:
property String^ UserName {
    String^ get ();
}
public:
property String^ UserName {
    String^ get ();
}
member UserName : string with get
member UserName : string with get

Property Value

Type: Online String
See Also
SocialNetTokenCredentials Class
SocialNetTokenCredentials Members
NFX.Security Namespace


TypedPermission Class

TypedPermission Class NFX Class Library

A general ancestor for all typed permissions - the ones declared in code
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.Security Permission
NFX.Security TypedPermission

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class TypedPermission : Permission
public abstract class TypedPermission : Permission
Public MustInherit Class TypedPermission
    Inherits Permission
Public MustInherit Class TypedPermission
    Inherits Permission
public ref class TypedPermission abstract : public Permission
public ref class TypedPermission abstract : public Permission
[<AbstractClassAttribute>]
type TypedPermission =
    class
        inherit Permission
    end
[<AbstractClassAttribute>]
type TypedPermission =
    class
        inherit Permission
    end
See Also
TypedPermission Members
NFX.Security Namespace


TypedPermission Members

TypedPermission Members NFX Class Library

The TypedPermission type exposes the following members.
Constructors
 | Name | Description
Protected method | TypedPermission | Creates the check instance against the minimum access level for this typed permission
Back to Top
Methods
 | Name | Description
Public method | Check(ISession) | Checks the permission for requested action as specified in particular permission .ctor. The check is performed in the scope of supplied session, or if no session was supplied then current execution context session is assumed (Inherited from Permission.)
Public method | Check(User) | Shortcut method that creates a temp/mock BaseSession object thus checking permission in mock BaseSession context (Inherited from Permission.)
Protected method | DoCheckAccessLevel | Override to perform access level checks per user's AccessLevel instance. True if accessLevel satisfies permission requirements. The default implementation checks the access.Level (Inherited from Permission.)
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from Permission.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
PERMISSION_SUFFIX |
Back to Top
Properties
 | Name | Description
Public property | Description | Returns the permission description - base implementation returns permission name (Inherited from Permission.)
Public property | FullPath | Returns full permission path - a concatenation of its path and name (Inherited from Permission.)
Public property | Level | Specifies the minimum access level for the permission check to pass (Inherited from Permission.)
Public property | Name | (Overrides Permission Name.)
Public property | Path | (Overrides Permission Path.)
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
TypedPermission Class
NFX.Security Namespace


TypedPermission Constructor

TypedPermission Constructor NFX Class Library

Creates the check instance against the minimum access level for this typed permission

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TypedPermission(
    int level
)
protected TypedPermission(
    int level
)
Protected Sub New (
    level As Integer
)
Protected Sub New (
    level As Integer
)
protected:
TypedPermission(
    int level
)
protected:
TypedPermission(
    int level
)
new :
        level : int -> TypedPermission
new :
        level : int -> TypedPermission

Parameters

level
Type: Online System Int32
See Also
TypedPermission Class
TypedPermission Members
NFX.Security Namespace


TypedPermission Fields

TypedPermission Fields NFX Class Library

The TypedPermission type exposes the following members.
Fields
Name | Description
PERMISSION_SUFFIX |
Back to Top
See Also
TypedPermission Class
NFX.Security Namespace


TypedPermission.PERMISSION_SUFFIX Field

TypedPermission PERMISSION_SUFFIX Field NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string PERMISSION_SUFFIX
public const string PERMISSION_SUFFIX
Public Const PERMISSION_SUFFIX As String
Public Const PERMISSION_SUFFIX As String
public:
literal String^ PERMISSION_SUFFIX
public:
literal String^ PERMISSION_SUFFIX
static val mutable PERMISSION_SUFFIX: string
static val mutable PERMISSION_SUFFIX: string

Field Value

Type: Online String
See Also
TypedPermission Class
TypedPermission Members
NFX.Security Namespace


TypedPermission Methods

TypedPermission Methods NFX Class Library

The TypedPermission type exposes the following members.
Methods
 | Name | Description
Public method | Check(ISession) | Checks the permission for requested action as specified in particular permission .ctor. The check is performed in the scope of supplied session, or if no session was supplied then current execution context session is assumed (Inherited from Permission.)
Public method | Check(User) | Shortcut method that creates a temp/mock BaseSession object thus checking permission in mock BaseSession context (Inherited from Permission.)
Protected method | DoCheckAccessLevel | Override to perform access level checks per user's AccessLevel instance. True if accessLevel satisfies permission requirements. The default implementation checks the access.Level (Inherited from Permission.)
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Inherited from Permission.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TypedPermission Class
NFX.Security Namespace


TypedPermission Properties

TypedPermission Properties NFX Class Library

The TypedPermission type exposes the following members.
Properties
 | Name | Description
Public property | Description | Returns the permission description - base implementation returns permission name (Inherited from Permission.)
Public property | FullPath | Returns full permission path - a concatenation of its path and name (Inherited from Permission.)
Public property | Level | Specifies the minimum access level for the permission check to pass (Inherited from Permission.)
Public property | Name | (Overrides Permission Name.)
Public property | Path | (Overrides Permission Path.)
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
TypedPermission Class
NFX.Security Namespace


TypedPermission.Name Property

TypedPermission Name Property NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Name { get; }
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String
See Also
TypedPermission Class
TypedPermission Members
NFX.Security Namespace


TypedPermission.Path Property

TypedPermission Path Property NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string Path { get; }
public override string Path { get; }
Public Overrides ReadOnly Property Path As String
    Get
Public Overrides ReadOnly Property Path As String
    Get
public:
virtual property String^ Path {
    String^ get () override;
}
public:
virtual property String^ Path {
    String^ get () override;
}
abstract Path : string with get
override Path : string with get
abstract Path : string with get
override Path : string with get

Property Value

Type: Online String
See Also
TypedPermission Class
TypedPermission Members
NFX.Security Namespace


User Class

User Class NFX Class Library

Provides base user functionality. Particular security manager implementations may return users derived from this class
Inheritance Hierarchy
Online System Object
NFX.Security User

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class User : IIdentity, IPrincipal, IDeserializationCallback
[SerializableAttribute]
public class User : IIdentity, IPrincipal, IDeserializationCallback
<SerializableAttribute>
Public Class User
    Implements IIdentity, IPrincipal, IDeserializationCallback
<SerializableAttribute>
Public Class User
    Implements IIdentity, IPrincipal, IDeserializationCallback
[SerializableAttribute]
public ref class User : IIdentity, IPrincipal,
    IDeserializationCallback
[SerializableAttribute]
public ref class User : IIdentity, IPrincipal,
    IDeserializationCallback
[<SerializableAttribute>]
type User =
    class
        interface IIdentity
        interface IPrincipal
        interface IDeserializationCallback
    end
[<SerializableAttribute>]
type User =
    class
        interface IIdentity
        interface IPrincipal
        interface IDeserializationCallback
    end
See Also
User Members
NFX.Security Namespace


User Members

User Members NFX Class Library

The User type exposes the following members.
Constructors
 | Name | Description
Public method | User(Credentials, AuthenticationToken, String, Rights) | Initializes a new instance of the User class
Public method | User(Credentials, AuthenticationToken, UserStatus, String, String, Rights) | Initializes a new instance of the User class
Back to Top
Methods
 | Name | Description
Public method | ___update_status | Framework-internal. Do not call
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Invalidate | Makes user invalid
Public method | IsInRole | Determines whether the current principal belongs to the specified role. This method implements IPrincipal and has little application in NFX framework context as NFX permissions are more granular than just boolean. This method really checks user kind (User/Admin/Sys). Confusion comes from the fact that what Microsoft calls role really is just a single named permission - a role is a named permission set in NFX.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OnDeserialization |
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | AuthenticationType | Implementation of IIdentity interface
Public property | AuthToken |
Public property | Credentials |
Public property | Description |
 | Fake | Returns default instance of the fake user that has no rights
Public property | Identity | Implementation of IPrincipal interface
Public property | IsAuthenticated | Implementation of IIdentity interface. Checks to see if user is not in invalid status
Public property | Item | Authorizes user to specified permission. Note: this authorization call returns AccessLevel object that may contain a complex data structure. The final assertion of user's ability to perform a certain action is encapsulated in Permission.Check() method. Call Permission.AuthorizeAndGuardAction(MemberInfo, ISession) to guard classes and methods from unauthorized access
Public property | Name |
Public property | Rights | Returns data bag that contains user rights. This is a framework-only internal property which should not be used by application developers. This bag may get populated fully-or-partially by ISecurityManager implementation. Use User[permission] indexer or Application.SecurityManager.Authorize() to obtain AccessLevel
Public property | Status |
Public property | StatusTimeStampUTC | Captures timestamp when this user was set to current status (created/set rights) Security managers may elect to reftech user rights after some period
Back to Top
See Also
User Class
NFX.Security Namespace


User Constructor

User Constructor NFX Class Library

Overload List
 | Name | Description
Public method | User(Credentials, AuthenticationToken, String, Rights) | Initializes a new instance of the User class
Public method | User(Credentials, AuthenticationToken, UserStatus, String, String, Rights) | Initializes a new instance of the User class
Back to Top
See Also
User Class
User Members
NFX.Security Namespace


User Constructor (Credentials, AuthenticationToken, String, Rights)

User Constructor (Credentials, AuthenticationToken, String, Rights) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the User class

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public User(
    Credentials credentials,
    AuthenticationToken token,
    string name,
    Rights rights
)
public User(
    Credentials credentials,
    AuthenticationToken token,
    string name,
    Rights rights
)
Public Sub New (
    credentials As Credentials,
    token As AuthenticationToken,
    name As String,
    rights As Rights
)
Public Sub New (
    credentials As Credentials,
    token As AuthenticationToken,
    name As String,
    rights As Rights
)
public:
User(
    Credentials^ credentials,
    AuthenticationToken token,
    String^ name,
    Rights^ rights
)
public:
User(
    Credentials^ credentials,
    AuthenticationToken token,
    String^ name,
    Rights^ rights
)
new :
        credentials : Credentials *
        token : AuthenticationToken *
        name : string *
        rights : Rights -> User
new :
        credentials : Credentials *
        token : AuthenticationToken *
        name : string *
        rights : Rights -> User

Parameters

credentials
Type: NFX.Security Credentials
token
Type: NFX.Security AuthenticationToken
name
Type: Online System String
rights
Type: NFX.Security Rights
See Also
User Class
User Members
User Overload
NFX.Security Namespace


User Constructor (Credentials, AuthenticationToken, UserStatus, String, String, Rights)

User Constructor (Credentials, AuthenticationToken, UserStatus, String, String, Rights) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the User class

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public User(
    Credentials credentials,
    AuthenticationToken token,
    UserStatus status,
    string name,
    string descr,
    Rights rights
)
public User(
    Credentials credentials,
    AuthenticationToken token,
    UserStatus status,
    string name,
    string descr,
    Rights rights
)
Public Sub New (
    credentials As Credentials,
    token As AuthenticationToken,
    status As UserStatus,
    name As String,
    descr As String,
    rights As Rights
)
Public Sub New (
    credentials As Credentials,
    token As AuthenticationToken,
    status As UserStatus,
    name As String,
    descr As String,
    rights As Rights
)
public:
User(
    Credentials^ credentials,
    AuthenticationToken token,
    UserStatus status,
    String^ name,
    String^ descr,
    Rights^ rights
)
public:
User(
    Credentials^ credentials,
    AuthenticationToken token,
    UserStatus status,
    String^ name,
    String^ descr,
    Rights^ rights
)
new :
        credentials : Credentials *
        token : AuthenticationToken *
        status : UserStatus *
        name : string *
        descr : string *
        rights : Rights -> User
new :
        credentials : Credentials *
        token : AuthenticationToken *
        status : UserStatus *
        name : string *
        descr : string *
        rights : Rights -> User

Parameters

credentials
Type: NFX.Security Credentials
token
Type: NFX.Security AuthenticationToken
status
Type: NFX.Security UserStatus
name
Type: Online System String
descr
Type: Online System String
rights
Type: NFX.Security Rights
See Also
User Class
User Members
User Overload
NFX.Security Namespace


User Methods

User Methods NFX Class Library

The User type exposes the following members.
Methods
 | Name | Description
Public method | ___update_status | Framework-internal. Do not call
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Invalidate | Makes user invalid
Public method | IsInRole | Determines whether the current principal belongs to the specified role. This method implements IPrincipal and has little application in NFX framework context as NFX permissions are more granular than just boolean. This method really checks user kind (User/Admin/Sys). Confusion comes from the fact that what Microsoft calls role really is just a single named permission - a role is a named permission set in NFX.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OnDeserialization |
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
User Class
NFX.Security Namespace


User.___update_status Method

User ___update_status Method NFX Class Library

Framework-internal. Do not call

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ___update_status(
    UserStatus status,
    string name,
    string descr,
    Rights rights
)
public void ___update_status(
    UserStatus status,
    string name,
    string descr,
    Rights rights
)
Public Sub ___update_status (
    status As UserStatus,
    name As String,
    descr As String,
    rights As Rights
)
Public Sub ___update_status (
    status As UserStatus,
    name As String,
    descr As String,
    rights As Rights
)
public:
void ___update_status(
    UserStatus status,
    String^ name,
    String^ descr,
    Rights^ rights
)
public:
void ___update_status(
    UserStatus status,
    String^ name,
    String^ descr,
    Rights^ rights
)
member ___update_status :
        status : UserStatus *
        name : string *
        descr : string *
        rights : Rights -> unit
member ___update_status :
        status : UserStatus *
        name : string *
        descr : string *
        rights : Rights -> unit

Parameters

status
Type: NFX.Security UserStatus
name
Type: Online System String
descr
Type: Online System String
rights
Type: NFX.Security Rights
See Also
User Class
User Members
NFX.Security Namespace


User.Invalidate Method

User Invalidate Method NFX Class Library

Makes user invalid

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Invalidate()
public void Invalidate()
Public Sub Invalidate
Public Sub Invalidate
public:
void Invalidate()
public:
void Invalidate()
member Invalidate : unit -> unit
member Invalidate : unit -> unit
See Also
User Class
User Members
NFX.Security Namespace


User.IsInRole Method

User IsInRole Method NFX Class Library

Determines whether the current principal belongs to the specified role. This method implements IPrincipal and has little application in NFX framework context as NFX permissions are more granular than just boolean. This method really checks user kind (User/Admin/Sys). Confusion comes from the fact that what Microsoft calls role really is just a single named permission - a role is a named permission set in NFX.

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsInRole(
    string role
)
public bool IsInRole(
    string role
)
Public Function IsInRole (
    role As String
) As Boolean
Public Function IsInRole (
    role As String
) As Boolean
public:
virtual bool IsInRole(
    String^ role
) sealed
public:
virtual bool IsInRole(
    String^ role
) sealed
abstract IsInRole :
        role : string -> bool
override IsInRole :
        role : string -> bool
abstract IsInRole :
        role : string -> bool
override IsInRole :
        role : string -> bool

Parameters

role
Type: Online System String

Return Value

Type: Online Boolean

Implements

Online IPrincipal IsInRole(String)
See Also
User Class
User Members
NFX.Security Namespace


User.OnDeserialization Method

User OnDeserialization Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void OnDeserialization(
    Object sender
)
public void OnDeserialization(
    Object sender
)
Public Sub OnDeserialization (
    sender As Object
)
Public Sub OnDeserialization (
    sender As Object
)
public:
virtual void OnDeserialization(
    Object^ sender
) sealed
public:
virtual void OnDeserialization(
    Object^ sender
) sealed
abstract OnDeserialization :
        sender : Object -> unit
override OnDeserialization :
        sender : Object -> unit
abstract OnDeserialization :
        sender : Object -> unit
override OnDeserialization :
        sender : Object -> unit

Parameters

sender
Type: Online System Object

Implements

Online IDeserializationCallback OnDeserialization(Object)
See Also
User Class
User Members
NFX.Security Namespace


User.ToString Method

User ToString Method NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
User Class
User Members
NFX.Security Namespace


User Properties

User Properties NFX Class Library

The User type exposes the following members.
Properties
 | Name | Description
Public property | AuthenticationType | Implementation of IIdentity interface
Public property | AuthToken |
Public property | Credentials |
Public property | Description |
 | Fake | Returns default instance of the fake user that has no rights
Public property | Identity | Implementation of IPrincipal interface
Public property | IsAuthenticated | Implementation of IIdentity interface. Checks to see if user is not in invalid status
Public property | Item | Authorizes user to specified permission. Note: this authorization call returns AccessLevel object that may contain a complex data structure. The final assertion of user's ability to perform a certain action is encapsulated in Permission.Check() method. Call Permission.AuthorizeAndGuardAction(MemberInfo, ISession) to guard classes and methods from unauthorized access
Public property | Name |
Public property | Rights | Returns data bag that contains user rights. This is a framework-only internal property which should not be used by application developers. This bag may get populated fully-or-partially by ISecurityManager implementation. Use User[permission] indexer or Application.SecurityManager.Authorize() to obtain AccessLevel
Public property | Status |
Public property | StatusTimeStampUTC | Captures timestamp when this user was set to current status (created/set rights) Security managers may elect to reftech user rights after some period
Back to Top
See Also
User Class
NFX.Security Namespace


User.AuthenticationType Property

User AuthenticationType Property NFX Class Library

Implementation of IIdentity interface

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AuthenticationType { get; }
public string AuthenticationType { get; }
Public ReadOnly Property AuthenticationType As String
    Get
Public ReadOnly Property AuthenticationType As String
    Get
public:
virtual property String^ AuthenticationType {
    String^ get () sealed;
}
public:
virtual property String^ AuthenticationType {
    String^ get () sealed;
}
abstract AuthenticationType : string with get
override AuthenticationType : string with get
abstract AuthenticationType : string with get
override AuthenticationType : string with get

Property Value

Type: Online String

Implements

Online IIdentity AuthenticationType
See Also
User Class
User Members
NFX.Security Namespace


User.AuthToken Property

User AuthToken Property NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AuthenticationToken AuthToken { get; }
public AuthenticationToken AuthToken { get; }
Public ReadOnly Property AuthToken As AuthenticationToken
    Get
Public ReadOnly Property AuthToken As AuthenticationToken
    Get
public:
property AuthenticationToken AuthToken {
    AuthenticationToken get ();
}
public:
property AuthenticationToken AuthToken {
    AuthenticationToken get ();
}
member AuthToken : AuthenticationToken with get
member AuthToken : AuthenticationToken with get

Property Value

Type: AuthenticationToken
See Also
User Class
User Members
NFX.Security Namespace


User.Credentials Property

User Credentials Property NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Credentials Credentials { get; }
public Credentials Credentials { get; }
Public ReadOnly Property Credentials As Credentials
    Get
Public ReadOnly Property Credentials As Credentials
    Get
public:
property Credentials^ Credentials {
    Credentials^ get ();
}
public:
property Credentials^ Credentials {
    Credentials^ get ();
}
member Credentials : Credentials with get
member Credentials : Credentials with get

Property Value

Type: Credentials
See Also
User Class
User Members
NFX.Security Namespace


User.Description Property

User Description Property NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Description { get; }
public string Description { get; }
Public ReadOnly Property Description As String
    Get
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
public:
property String^ Description {
    String^ get ();
}
member Description : string with get
member Description : string with get

Property Value

Type: Online String
See Also
User Class
User Members
NFX.Security Namespace


User.Fake Property

User Fake Property NFX Class Library

Returns default instance of the fake user that has no rights

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static User Fake { get; }
public static User Fake { get; }
Public Shared ReadOnly Property Fake As User
    Get
Public Shared ReadOnly Property Fake As User
    Get
public:
static property User^ Fake {
    User^ get ();
}
public:
static property User^ Fake {
    User^ get ();
}
static member Fake : User with get
static member Fake : User with get

Property Value

Type: User
See Also
User Class
User Members
NFX.Security Namespace


User.Identity Property

User Identity Property NFX Class Library

Implementation of IPrincipal interface

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IIdentity Identity { get; }
public IIdentity Identity { get; }
Public ReadOnly Property Identity As IIdentity
    Get
Public ReadOnly Property Identity As IIdentity
    Get
public:
virtual property IIdentity^ Identity {
    IIdentity^ get () sealed;
}
public:
virtual property IIdentity^ Identity {
    IIdentity^ get () sealed;
}
abstract Identity : IIdentity with get
override Identity : IIdentity with get
abstract Identity : IIdentity with get
override Identity : IIdentity with get

Property Value

Type: Online IIdentity

Implements

Online IPrincipal Identity
See Also
User Class
User Members
NFX.Security Namespace


User.IsAuthenticated Property

User IsAuthenticated Property NFX Class Library

Implementation of IIdentity interface. Checks to see if user is not in invalid status

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsAuthenticated { get; }
public bool IsAuthenticated { get; }
Public ReadOnly Property IsAuthenticated As Boolean
    Get
Public ReadOnly Property IsAuthenticated As Boolean
    Get
public:
virtual property bool IsAuthenticated {
    bool get () sealed;
}
public:
virtual property bool IsAuthenticated {
    bool get () sealed;
}
abstract IsAuthenticated : bool with get
override IsAuthenticated : bool with get
abstract IsAuthenticated : bool with get
override IsAuthenticated : bool with get

Property Value

Type: Online Boolean

Implements

Online IIdentity IsAuthenticated
See Also
User Class
User Members
NFX.Security Namespace


User.Item Property

User Item Property NFX Class Library

Authorizes user to specified permission. Note: this authorization call returns AccessLevel object that may contain a complex data structure. The final assertion of user's ability to perform a certain action is encapsulated in Permission.Check() method. Call Permission.AuthorizeAndGuardAction(MemberInfo, ISession) to guard classes and methods from unauthorized access

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AccessLevel this[
    Permission permission
] { get; }
public AccessLevel this[
    Permission permission
] { get; }
Public ReadOnly Default Property Item (
    permission As Permission
) As AccessLevel
    Get
Public ReadOnly Default Property Item (
    permission As Permission
) As AccessLevel
    Get
public:
property AccessLevel^ default[Permission^ permission] {
    AccessLevel^ get (Permission^ permission);
}
public:
property AccessLevel^ default[Permission^ permission] {
    AccessLevel^ get (Permission^ permission);
}
member Item : AccessLevel with get
member Item : AccessLevel with get

Parameters

permission
Type: NFX.Security Permission

Property Value

Type: AccessLevel
See Also
User Class
User Members
NFX.Security Namespace


User.Name Property

User Name Property NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

Online IIdentity Name
See Also
User Class
User Members
NFX.Security Namespace


User.Rights Property

User Rights Property NFX Class Library

Returns data bag that contains user rights. This is a framework-only internal property which should not be used by application developers. This bag may get populated fully-or-partially by ISecurityManager implementation. Use User[permission] indexer or Application.SecurityManager.Authorize() to obtain AccessLevel

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Rights Rights { get; }
public Rights Rights { get; }
Public ReadOnly Property Rights As Rights
    Get
Public ReadOnly Property Rights As Rights
    Get
public:
property Rights^ Rights {
    Rights^ get ();
}
public:
property Rights^ Rights {
    Rights^ get ();
}
member Rights : Rights with get
member Rights : Rights with get

Property Value

Type: Rights
See Also
User Class
User Members
NFX.Security Namespace


User.Status Property

User Status Property NFX Class Library

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public UserStatus Status { get; }
public UserStatus Status { get; }
Public ReadOnly Property Status As UserStatus
    Get
Public ReadOnly Property Status As UserStatus
    Get
public:
property UserStatus Status {
    UserStatus get ();
}
public:
property UserStatus Status {
    UserStatus get ();
}
member Status : UserStatus with get
member Status : UserStatus with get

Property Value

Type: UserStatus
See Also
User Class
User Members
NFX.Security Namespace


User.StatusTimeStampUTC Property

User StatusTimeStampUTC Property NFX Class Library

Captures timestamp when this user was set to current status (created/set rights) Security managers may elect to reftech user rights after some period

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime StatusTimeStampUTC { get; }
public DateTime StatusTimeStampUTC { get; }
Public ReadOnly Property StatusTimeStampUTC As DateTime
    Get
Public ReadOnly Property StatusTimeStampUTC As DateTime
    Get
public:
property DateTime StatusTimeStampUTC {
    DateTime get ();
}
public:
property DateTime StatusTimeStampUTC {
    DateTime get ();
}
member StatusTimeStampUTC : DateTime with get
member StatusTimeStampUTC : DateTime with get

Property Value

Type: Online DateTime
See Also
User Class
User Members
NFX.Security Namespace


UserStatus Enumeration

UserStatus Enumeration NFX Class Library

User status enumeration - super-permission levels

Namespace: NFX.Security
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum UserStatus
public enum UserStatus
Public Enumeration UserStatus
Public Enumeration UserStatus
public enum class UserStatus
public enum class UserStatus
type UserStatus
type UserStatus
Members
Member name | Value | Description
Invalid | 0 | Invalid user, not authenticated and not authorized
User | 1 | The lowest level of a user, bound by permissions inside their domain and domain section (such as facility)
Usr | 1 |
Administrator | 1000 | Administrators may run administration console, but always bound by their domain
Admin | 1000 |
Adm | 1000 |
System | 1000000 | Cross domain user, all restrictions are lifted
Sys | 1000000 |
See Also
NFX.Security Namespace


NFX.Security.CAPTCHA Namespace

NFX.Security.CAPTCHA Namespace NFX Class Library

Classes
 | Class | Description
Public class | PuzzleKeypad | Provides methods for generation, storing, and interpretation of user actions with a keypad of random layout. This .ctor is supplied some code that user has to punch-in(touch/click) on a randomly laid-out keypad which is usually rendered as an image. Use DecipherCoordinates() methods to convert user click/touch coordinates into characters
Structures
 | Structure | Description
Public structure | PuzzleKeypad CharBox |


PuzzleKeypad Class

PuzzleKeypad Class NFX Class Library

Provides methods for generation, storing, and interpretation of user actions with a keypad of random layout. This .ctor is supplied some code that user has to punch-in(touch/click) on a randomly laid-out keypad which is usually rendered as an image. Use DecipherCoordinates() methods to convert user click/touch coordinates into characters
Inheritance Hierarchy
Online System Object
NFX.Security.CAPTCHA PuzzleKeypad

Namespace: NFX.Security.CAPTCHA
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class PuzzleKeypad
[SerializableAttribute]
public sealed class PuzzleKeypad
<SerializableAttribute>
Public NotInheritable Class PuzzleKeypad
<SerializableAttribute>
Public NotInheritable Class PuzzleKeypad
[SerializableAttribute]
public ref class PuzzleKeypad sealed
[SerializableAttribute]
public ref class PuzzleKeypad sealed
[<SealedAttribute>]
[<SerializableAttribute>]
type PuzzleKeypad =  class end
[<SealedAttribute>]
[<SerializableAttribute>]
type PuzzleKeypad =  class end
See Also
PuzzleKeypad Members
NFX.Security.CAPTCHA Namespace


PuzzleKeypad Members

PuzzleKeypad Members NFX Class Library

The PuzzleKeypad type exposes the following members.
Constructors
 | Name | Description
Public method | PuzzleKeypad | Initializes a new instance of the PuzzleKeypad class
Back to Top
Methods
 | Name | Description
Public method | DecipherCoordinates(IEnumerable Point , Nullable Int32 , Nullable Int32 ) | Translates user action coordinates (i.e. screen touches or mouse clicks) into a string. The coordinates are supplied as IEnumerable(Point)
Public method | DecipherCoordinates(JSONDataArray, Nullable Int32 , Nullable Int32 ) | Translates user action coordinates (i.e. screen touches or mouse clicks) into a string. The coordinates must be supplied as a JSON array of json objects that have '{x: [int], y: [int]}' structure
Public method | DefaultRender | Renders default image of the keypad suitable for user entry (i.e. touch or mouse clicks)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
DEFAULT_RENDER_OFFSET_X |
DEFAULT_RENDER_OFFSET_Y |
Back to Top
Properties
 | Name | Description
Public property | Boxes | Returns char boxes
Public property | Code | Returns the original secret code that this keypad was created for
Public property | Size | Returns the size of rectangle that covers all boxes
Back to Top
See Also
PuzzleKeypad Class
NFX.Security.CAPTCHA Namespace


PuzzleKeypad Constructor

PuzzleKeypad Constructor NFX Class Library

Initializes a new instance of the PuzzleKeypad class

Namespace: NFX.Security.CAPTCHA
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PuzzleKeypad(
    string code,
    string extra = null,
    int puzzleBoxWidth = 5,
    int boxWidth = 35,
    int boxHeight = 50,
    double boxSizeVariance = 0.3,
    int minBoxWidth = 10,
    int minBoxHeight = 16
)
public PuzzleKeypad(
    string code,
    string extra = null,
    int puzzleBoxWidth = 5,
    int boxWidth = 35,
    int boxHeight = 50,
    double boxSizeVariance = 0.3,
    int minBoxWidth = 10,
    int minBoxHeight = 16
)
Public Sub New (
    code As String,
    Optional extra As String = Nothing,
    Optional puzzleBoxWidth As Integer = 5,
    Optional boxWidth As Integer = 35,
    Optional boxHeight As Integer = 50,
    Optional boxSizeVariance As Double = 0.3,
    Optional minBoxWidth As Integer = 10,
    Optional minBoxHeight As Integer = 16
)
Public Sub New (
    code As String,
    Optional extra As String = Nothing,
    Optional puzzleBoxWidth As Integer = 5,
    Optional boxWidth As Integer = 35,
    Optional boxHeight As Integer = 50,
    Optional boxSizeVariance As Double = 0.3,
    Optional minBoxWidth As Integer = 10,
    Optional minBoxHeight As Integer = 16
)
public:
PuzzleKeypad(
    String^ code,
    String^ extra = nullptr,
    int puzzleBoxWidth = 5,
    int boxWidth = 35,
    int boxHeight = 50,
    double boxSizeVariance = 0.3,
    int minBoxWidth = 10,
    int minBoxHeight = 16
)
public:
PuzzleKeypad(
    String^ code,
    String^ extra = nullptr,
    int puzzleBoxWidth = 5,
    int boxWidth = 35,
    int boxHeight = 50,
    double boxSizeVariance = 0.3,
    int minBoxWidth = 10,
    int minBoxHeight = 16
)
new :
        code : string *
        ?extra : string *
        ?puzzleBoxWidth : int *
        ?boxWidth : int *
        ?boxHeight : int *
        ?boxSizeVariance : float *
        ?minBoxWidth : int *
        ?minBoxHeight : int
(* Defaults:
        let _extra = defaultArg extra null
        let _puzzleBoxWidth = defaultArg puzzleBoxWidth 5
        let _boxWidth = defaultArg boxWidth 35
        let _boxHeight = defaultArg boxHeight 50
        let _boxSizeVariance = defaultArg boxSizeVariance 0.3
        let _minBoxWidth = defaultArg minBoxWidth 10
        let _minBoxHeight = defaultArg minBoxHeight 16
*)
-> PuzzleKeypad
new :
        code : string *
        ?extra : string *
        ?puzzleBoxWidth : int *
        ?boxWidth : int *
        ?boxHeight : int *
        ?boxSizeVariance : float *
        ?minBoxWidth : int *
        ?minBoxHeight : int
(* Defaults:
        let _extra = defaultArg extra null
        let _puzzleBoxWidth = defaultArg puzzleBoxWidth 5
        let _boxWidth = defaultArg boxWidth 35
        let _boxHeight = defaultArg boxHeight 50
        let _boxSizeVariance = defaultArg boxSizeVariance 0.3
        let _minBoxWidth = defaultArg minBoxWidth 10
        let _minBoxHeight = defaultArg minBoxHeight 16
*)
-> PuzzleKeypad

Parameters

code
Type: Online System String
extra (Optional)
Type: Online System String
puzzleBoxWidth (Optional)
Type: Online System Int32
boxWidth (Optional)
Type: Online System Int32
boxHeight (Optional)
Type: Online System Int32
boxSizeVariance (Optional)
Type: Online System Double
minBoxWidth (Optional)
Type: Online System Int32
minBoxHeight (Optional)
Type: Online System Int32
See Also
PuzzleKeypad Class
PuzzleKeypad Members
NFX.Security.CAPTCHA Namespace


PuzzleKeypad Fields

PuzzleKeypad Fields NFX Class Library

The PuzzleKeypad type exposes the following members.
Fields
Name | Description
DEFAULT_RENDER_OFFSET_X |
DEFAULT_RENDER_OFFSET_Y |
Back to Top
See Also
PuzzleKeypad Class
NFX.Security.CAPTCHA Namespace


PuzzleKeypad.DEFAULT_RENDER_OFFSET_X Field

PuzzleKeypad DEFAULT_RENDER_OFFSET_X Field NFX Class Library

Namespace: NFX.Security.CAPTCHA
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_RENDER_OFFSET_X
public const int DEFAULT_RENDER_OFFSET_X
Public Const DEFAULT_RENDER_OFFSET_X As Integer
Public Const DEFAULT_RENDER_OFFSET_X As Integer
public:
literal int DEFAULT_RENDER_OFFSET_X
public:
literal int DEFAULT_RENDER_OFFSET_X
static val mutable DEFAULT_RENDER_OFFSET_X: int
static val mutable DEFAULT_RENDER_OFFSET_X: int

Field Value

Type: Online Int32
See Also
PuzzleKeypad Class
PuzzleKeypad Members
NFX.Security.CAPTCHA Namespace


PuzzleKeypad.DEFAULT_RENDER_OFFSET_Y Field

PuzzleKeypad DEFAULT_RENDER_OFFSET_Y Field NFX Class Library

Namespace: NFX.Security.CAPTCHA
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DEFAULT_RENDER_OFFSET_Y
public const int DEFAULT_RENDER_OFFSET_Y
Public Const DEFAULT_RENDER_OFFSET_Y As Integer
Public Const DEFAULT_RENDER_OFFSET_Y As Integer
public:
literal int DEFAULT_RENDER_OFFSET_Y
public:
literal int DEFAULT_RENDER_OFFSET_Y
static val mutable DEFAULT_RENDER_OFFSET_Y: int
static val mutable DEFAULT_RENDER_OFFSET_Y: int

Field Value

Type: Online Int32
See Also
PuzzleKeypad Class
PuzzleKeypad Members
NFX.Security.CAPTCHA Namespace


PuzzleKeypad Methods

PuzzleKeypad Methods NFX Class Library

The PuzzleKeypad type exposes the following members.
Methods
 | Name | Description
Public method | DecipherCoordinates(IEnumerable Point , Nullable Int32 , Nullable Int32 ) | Translates user action coordinates (i.e. screen touches or mouse clicks) into a string. The coordinates are supplied as IEnumerable(Point)
Public method | DecipherCoordinates(JSONDataArray, Nullable Int32 , Nullable Int32 ) | Translates user action coordinates (i.e. screen touches or mouse clicks) into a string. The coordinates must be supplied as a JSON array of json objects that have '{x: [int], y: [int]}' structure
Public method | DefaultRender | Renders default image of the keypad suitable for user entry (i.e. touch or mouse clicks)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PuzzleKeypad Class
NFX.Security.CAPTCHA Namespace


PuzzleKeypad.DecipherCoordinates Method

PuzzleKeypad DecipherCoordinates Method NFX Class Library

Overload List
 | Name | Description
Public method | DecipherCoordinates(IEnumerable Point , Nullable Int32 , Nullable Int32 ) | Translates user action coordinates (i.e. screen touches or mouse clicks) into a string. The coordinates are supplied as IEnumerable(Point)
Public method | DecipherCoordinates(JSONDataArray, Nullable Int32 , Nullable Int32 ) | Translates user action coordinates (i.e. screen touches or mouse clicks) into a string. The coordinates must be supplied as a JSON array of json objects that have '{x: [int], y: [int]}' structure
Back to Top
See Also
PuzzleKeypad Class
PuzzleKeypad Members
NFX.Security.CAPTCHA Namespace


PuzzleKeypad.DecipherCoordinates Method (IEnumerable(Point), Nullable(Int32), Nullable(Int32))

PuzzleKeypad DecipherCoordinates Method (IEnumerable Point , Nullable Int32 , Nullable Int32 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Translates user action coordinates (i.e. screen touches or mouse clicks) into a string. The coordinates are supplied as IEnumerable(Point)

Namespace: NFX.Security.CAPTCHA
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DecipherCoordinates(
    IEnumerable<Point> coords,
    Nullable<int> offsetX = null,
    Nullable<int> offsetY = null
)
public string DecipherCoordinates(
    IEnumerable<Point> coords,
    Nullable<int> offsetX = null,
    Nullable<int> offsetY = null
)
Public Function DecipherCoordinates (
    coords As IEnumerable(Of Point),
    Optional offsetX As Nullable(Of Integer) = Nothing,
    Optional offsetY As Nullable(Of Integer) = Nothing
) As String
Public Function DecipherCoordinates (
    coords As IEnumerable(Of Point),
    Optional offsetX As Nullable(Of Integer) = Nothing,
    Optional offsetY As Nullable(Of Integer) = Nothing
) As String
public:
String^ DecipherCoordinates(
    IEnumerable<Point>^ coords,
    Nullable<int> offsetX = nullptr,
    Nullable<int> offsetY = nullptr
)
public:
String^ DecipherCoordinates(
    IEnumerable<Point>^ coords,
    Nullable<int> offsetX = nullptr,
    Nullable<int> offsetY = nullptr
)
member DecipherCoordinates :
        coords : IEnumerable<Point> *
        ?offsetX : Nullable<int> *
        ?offsetY : Nullable<int>
(* Defaults:
        let _offsetX = defaultArg offsetX null
        let _offsetY = defaultArg offsetY null
*)
-> string
member DecipherCoordinates :
        coords : IEnumerable<Point> *
        ?offsetX : Nullable<int> *
        ?offsetY : Nullable<int>
(* Defaults:
        let _offsetX = defaultArg offsetX null
        let _offsetY = defaultArg offsetY null
*)
-> string

Parameters

coords
Type: Online System.Collections.Generic IEnumerable Online Point
offsetX (Optional)
Type: Online System Nullable Online Int32
offsetY (Optional)
Type: Online System Nullable Online Int32

Return Value

Type: Online String
See Also
PuzzleKeypad Class
PuzzleKeypad Members
DecipherCoordinates Overload
NFX.Security.CAPTCHA Namespace


PuzzleKeypad.DecipherCoordinates Method (JSONDataArray, Nullable(Int32), Nullable(Int32))

PuzzleKeypad DecipherCoordinates Method (JSONDataArray, Nullable Int32 , Nullable Int32 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Translates user action coordinates (i.e. screen touches or mouse clicks) into a string. The coordinates must be supplied as a JSON array of json objects that have '{x: [int], y: [int]}' structure

Namespace: NFX.Security.CAPTCHA
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DecipherCoordinates(
    JSONDataArray coords,
    Nullable<int> offsetX = null,
    Nullable<int> offsetY = null
)
public string DecipherCoordinates(
    JSONDataArray coords,
    Nullable<int> offsetX = null,
    Nullable<int> offsetY = null
)
Public Function DecipherCoordinates (
    coords As JSONDataArray,
    Optional offsetX As Nullable(Of Integer) = Nothing,
    Optional offsetY As Nullable(Of Integer) = Nothing
) As String
Public Function DecipherCoordinates (
    coords As JSONDataArray,
    Optional offsetX As Nullable(Of Integer) = Nothing,
    Optional offsetY As Nullable(Of Integer) = Nothing
) As String
public:
String^ DecipherCoordinates(
    JSONDataArray^ coords,
    Nullable<int> offsetX = nullptr,
    Nullable<int> offsetY = nullptr
)
public:
String^ DecipherCoordinates(
    JSONDataArray^ coords,
    Nullable<int> offsetX = nullptr,
    Nullable<int> offsetY = nullptr
)
member DecipherCoordinates :
        coords : JSONDataArray *
        ?offsetX : Nullable<int> *
        ?offsetY : Nullable<int>
(* Defaults:
        let _offsetX = defaultArg offsetX null
        let _offsetY = defaultArg offsetY null
*)
-> string
member DecipherCoordinates :
        coords : JSONDataArray *
        ?offsetX : Nullable<int> *
        ?offsetY : Nullable<int>
(* Defaults:
        let _offsetX = defaultArg offsetX null
        let _offsetY = defaultArg offsetY null
*)
-> string

Parameters

coords
Type: NFX.Serialization.JSON JSONDataArray
offsetX (Optional)
Type: Online System Nullable Online Int32
offsetY (Optional)
Type: Online System Nullable Online Int32

Return Value

Type: Online String
See Also
PuzzleKeypad Class
PuzzleKeypad Members
DecipherCoordinates Overload
NFX.Security.CAPTCHA Namespace


PuzzleKeypad.DefaultRender Method

PuzzleKeypad DefaultRender Method NFX Class Library

Renders default image of the keypad suitable for user entry (i.e. touch or mouse clicks)

Namespace: NFX.Security.CAPTCHA
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Image DefaultRender(
    Nullable<Color> bgColor = null,
    bool showRects = false
)
public Image DefaultRender(
    Nullable<Color> bgColor = null,
    bool showRects = false
)
Public Function DefaultRender (
    Optional bgColor As Nullable(Of Color) = Nothing,
    Optional showRects As Boolean = false
) As Image
Public Function DefaultRender (
    Optional bgColor As Nullable(Of Color) = Nothing,
    Optional showRects As Boolean = false
) As Image
public:
Image^ DefaultRender(
    Nullable<Color> bgColor = nullptr,
    bool showRects = false
)
public:
Image^ DefaultRender(
    Nullable<Color> bgColor = nullptr,
    bool showRects = false
)
member DefaultRender :
        ?bgColor : Nullable<Color> *
        ?showRects : bool
(* Defaults:
        let _bgColor = defaultArg bgColor null
        let _showRects = defaultArg showRects false
*)
-> Image
member DefaultRender :
        ?bgColor : Nullable<Color> *
        ?showRects : bool
(* Defaults:
        let _bgColor = defaultArg bgColor null
        let _showRects = defaultArg showRects false
*)
-> Image

Parameters

bgColor (Optional)
Type: Online System Nullable Online Color
showRects (Optional)
Type: Online System Boolean

Return Value

Type: Online Image
See Also
PuzzleKeypad Class
PuzzleKeypad Members
NFX.Security.CAPTCHA Namespace


PuzzleKeypad Properties

PuzzleKeypad Properties NFX Class Library

The PuzzleKeypad type exposes the following members.
Properties
 | Name | Description
Public property | Boxes | Returns char boxes
Public property | Code | Returns the original secret code that this keypad was created for
Public property | Size | Returns the size of rectangle that covers all boxes
Back to Top
See Also
PuzzleKeypad Class
NFX.Security.CAPTCHA Namespace


PuzzleKeypad.Boxes Property

PuzzleKeypad Boxes Property NFX Class Library

Returns char boxes

Namespace: NFX.Security.CAPTCHA
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<PuzzleKeypad..::..CharBox> Boxes { get; }
public IEnumerable<PuzzleKeypad..::..CharBox> Boxes { get; }
Public ReadOnly Property Boxes As IEnumerable(Of PuzzleKeypad..::..CharBox)
    Get
Public ReadOnly Property Boxes As IEnumerable(Of PuzzleKeypad..::..CharBox)
    Get
public:
property IEnumerable<PuzzleKeypad..::..CharBox>^ Boxes {
    IEnumerable<PuzzleKeypad..::..CharBox>^ get ();
}
public:
property IEnumerable<PuzzleKeypad..::..CharBox>^ Boxes {
    IEnumerable<PuzzleKeypad..::..CharBox>^ get ();
}
member Boxes : IEnumerable<PuzzleKeypad..::..CharBox> with get
member Boxes : IEnumerable<PuzzleKeypad..::..CharBox> with get

Property Value

Type: Online IEnumerable PuzzleKeypad CharBox
See Also
PuzzleKeypad Class
PuzzleKeypad Members
NFX.Security.CAPTCHA Namespace


PuzzleKeypad.Code Property

PuzzleKeypad Code Property NFX Class Library

Returns the original secret code that this keypad was created for

Namespace: NFX.Security.CAPTCHA
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Code { get; }
public string Code { get; }
Public ReadOnly Property Code As String
    Get
Public ReadOnly Property Code As String
    Get
public:
property String^ Code {
    String^ get ();
}
public:
property String^ Code {
    String^ get ();
}
member Code : string with get
member Code : string with get

Property Value

Type: Online String
See Also
PuzzleKeypad Class
PuzzleKeypad Members
NFX.Security.CAPTCHA Namespace


PuzzleKeypad.Size Property

PuzzleKeypad Size Property NFX Class Library

Returns the size of rectangle that covers all boxes

Namespace: NFX.Security.CAPTCHA
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Size Size { get; }
public Size Size { get; }
Public ReadOnly Property Size As Size
    Get
Public ReadOnly Property Size As Size
    Get
public:
property Size Size {
    Size get ();
}
public:
property Size Size {
    Size get ();
}
member Size : Size with get
member Size : Size with get

Property Value

Type: Online Size
See Also
PuzzleKeypad Class
PuzzleKeypad Members
NFX.Security.CAPTCHA Namespace


PuzzleKeypad.CharBox Structure

PuzzleKeypad CharBox Structure NFX Class Library

Namespace: NFX.Security.CAPTCHA
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public struct CharBox
[SerializableAttribute]
public struct CharBox
<SerializableAttribute>
Public Structure CharBox
<SerializableAttribute>
Public Structure CharBox
[SerializableAttribute]
public value class CharBox
[SerializableAttribute]
public value class CharBox
[<SealedAttribute>]
[<SerializableAttribute>]
type CharBox =  struct end
[<SealedAttribute>]
[<SerializableAttribute>]
type CharBox =  struct end
See Also
PuzzleKeypad CharBox Members
NFX.Security.CAPTCHA Namespace


PuzzleKeypad.CharBox Members

PuzzleKeypad CharBox Members NFX Class Library

The PuzzleKeypad CharBox type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Char |
Public field | Rect |
Back to Top
See Also
PuzzleKeypad CharBox Structure
NFX.Security.CAPTCHA Namespace


PuzzleKeypad.CharBox Fields

PuzzleKeypad CharBox Fields NFX Class Library

The PuzzleKeypad CharBox type exposes the following members.
Fields
 | Name | Description
Public field | Char |
Public field | Rect |
Back to Top
See Also
PuzzleKeypad CharBox Structure
NFX.Security.CAPTCHA Namespace


PuzzleKeypad.CharBox.Char Field

PuzzleKeypad CharBox Char Field NFX Class Library

Namespace: NFX.Security.CAPTCHA
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char Char
public char Char
Public Char As Char
Public Char As Char
public:
wchar_t Char
public:
wchar_t Char
val mutable Char: char
val mutable Char: char

Field Value

Type: Online Char
See Also
PuzzleKeypad CharBox Structure
PuzzleKeypad CharBox Members
NFX.Security.CAPTCHA Namespace


PuzzleKeypad.CharBox.Rect Field

PuzzleKeypad CharBox Rect Field NFX Class Library

Namespace: NFX.Security.CAPTCHA
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Rectangle Rect
public Rectangle Rect
Public Rect As Rectangle
Public Rect As Rectangle
public:
Rectangle Rect
public:
Rectangle Rect
val mutable Rect: Rectangle
val mutable Rect: Rectangle

Field Value

Type: Online Rectangle
See Also
PuzzleKeypad CharBox Structure
PuzzleKeypad CharBox Members
NFX.Security.CAPTCHA Namespace


PuzzleKeypad.CharBox Methods

PuzzleKeypad CharBox Methods NFX Class Library

The PuzzleKeypad CharBox type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PuzzleKeypad CharBox Structure
NFX.Security.CAPTCHA Namespace


NFX.Serialization Namespace

NFX.Serialization Namespace NFX Class Library

Provides serialization functionality
Classes
 | Class | Description
Public class | MSBinaryFormatter | Implements ISerializer with Ms BinaryFormatter
Public class | NFXSerializationException | Base exception thrown by the serialization-related classes
Public class | SerializationUtils | Provides misc serialization-related functions that are really low-level and not intended to be used by developers. Methods are thread-safe
Interfaces
 | Interface | Description
Public interface | IDisposableSerializer | Describes an entity that can serialize and deserialize objects and can be disposed
Public interface | ISerializer | Describes an entity that can serialize and deserialize objects
Enumerations
 | Enumeration | Description
Public enumeration | SerializationOperation | Denotes ser/deser operations


IDisposableSerializer Interface

IDisposableSerializer Interface NFX Class Library

Describes an entity that can serialize and deserialize objects and can be disposed

Namespace: NFX.Serialization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IDisposableSerializer : ISerializer,
    IDisposable
public interface IDisposableSerializer : ISerializer,
    IDisposable
Public Interface IDisposableSerializer
    Inherits ISerializer, IDisposable
Public Interface IDisposableSerializer
    Inherits ISerializer, IDisposable
public interface class IDisposableSerializer : ISerializer,
    IDisposable
public interface class IDisposableSerializer : ISerializer,
    IDisposable
type IDisposableSerializer =
    interface
        interface ISerializer
        interface IDisposable
    end
type IDisposableSerializer =
    interface
        interface ISerializer
        interface IDisposable
    end
See Also
IDisposableSerializer Members
NFX.Serialization Namespace


IDisposableSerializer Members

IDisposableSerializer Members NFX Class Library

The IDisposableSerializer type exposes the following members.
Methods
 | Name | Description
Public method | Deserialize | (Inherited from ISerializer.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | Serialize | (Inherited from ISerializer.)
Back to Top
Properties
 | Name | Description
Public property | IsThreadSafe | Indicates whether Serialize/Deserialize may be called by multiple threads at the same time (Inherited from ISerializer.)
Back to Top
See Also
IDisposableSerializer Interface
NFX.Serialization Namespace


IDisposableSerializer Methods

IDisposableSerializer Methods NFX Class Library

The IDisposableSerializer type exposes the following members.
Methods
 | Name | Description
Public method | Deserialize | (Inherited from ISerializer.)
Public method | Online Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from Online IDisposable.)
Public method | Serialize | (Inherited from ISerializer.)
Back to Top
See Also
IDisposableSerializer Interface
NFX.Serialization Namespace


IDisposableSerializer Properties

IDisposableSerializer Properties NFX Class Library

The IDisposableSerializer type exposes the following members.
Properties
 | Name | Description
Public property | IsThreadSafe | Indicates whether Serialize/Deserialize may be called by multiple threads at the same time (Inherited from ISerializer.)
Back to Top
See Also
IDisposableSerializer Interface
NFX.Serialization Namespace


ISerializer Interface

ISerializer Interface NFX Class Library

Describes an entity that can serialize and deserialize objects

Namespace: NFX.Serialization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ISerializer
public interface ISerializer
Public Interface ISerializer
Public Interface ISerializer
public interface class ISerializer
public interface class ISerializer
type ISerializer =  interface end
type ISerializer =  interface end
See Also
ISerializer Members
NFX.Serialization Namespace


ISerializer Members

ISerializer Members NFX Class Library

The ISerializer type exposes the following members.
Methods
 | Name | Description
Public method | Deserialize |
Public method | Serialize |
Back to Top
Properties
 | Name | Description
Public property | IsThreadSafe | Indicates whether Serialize/Deserialize may be called by multiple threads at the same time
Back to Top
See Also
ISerializer Interface
NFX.Serialization Namespace


ISerializer Methods

ISerializer Methods NFX Class Library

The ISerializer type exposes the following members.
Methods
 | Name | Description
Public method | Deserialize |
Public method | Serialize |
Back to Top
See Also
ISerializer Interface
NFX.Serialization Namespace


ISerializer.Deserialize Method

ISerializer Deserialize Method NFX Class Library

Namespace: NFX.Serialization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object Deserialize(
    Stream stream
)
Object Deserialize(
    Stream stream
)
Function Deserialize (
    stream As Stream
) As Object
Function Deserialize (
    stream As Stream
) As Object
Object^ Deserialize(
    Stream^ stream
)
Object^ Deserialize(
    Stream^ stream
)
abstract Deserialize :
        stream : Stream -> Object
abstract Deserialize :
        stream : Stream -> Object

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online Object
See Also
ISerializer Interface
ISerializer Members
NFX.Serialization Namespace


ISerializer.Serialize Method

ISerializer Serialize Method NFX Class Library

Namespace: NFX.Serialization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Serialize(
    Stream stream,
    Object root
)
void Serialize(
    Stream stream,
    Object root
)
Sub Serialize (
    stream As Stream,
    root As Object
)
Sub Serialize (
    stream As Stream,
    root As Object
)
void Serialize(
    Stream^ stream,
    Object^ root
)
void Serialize(
    Stream^ stream,
    Object^ root
)
abstract Serialize :
        stream : Stream *
        root : Object -> unit
abstract Serialize :
        stream : Stream *
        root : Object -> unit

Parameters

stream
Type: Online System.IO Stream
root
Type: Online System Object
See Also
ISerializer Interface
ISerializer Members
NFX.Serialization Namespace


ISerializer Properties

ISerializer Properties NFX Class Library

The ISerializer type exposes the following members.
Properties
 | Name | Description
Public property | IsThreadSafe | Indicates whether Serialize/Deserialize may be called by multiple threads at the same time
Back to Top
See Also
ISerializer Interface
NFX.Serialization Namespace


ISerializer.IsThreadSafe Property

ISerializer IsThreadSafe Property NFX Class Library

Indicates whether Serialize/Deserialize may be called by multiple threads at the same time

Namespace: NFX.Serialization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool IsThreadSafe { get; }
bool IsThreadSafe { get; }
ReadOnly Property IsThreadSafe As Boolean
    Get
ReadOnly Property IsThreadSafe As Boolean
    Get
property bool IsThreadSafe {
    bool get ();
}
property bool IsThreadSafe {
    bool get ();
}
abstract IsThreadSafe : bool with get
abstract IsThreadSafe : bool with get

Property Value

Type: Online Boolean
See Also
ISerializer Interface
ISerializer Members
NFX.Serialization Namespace


MSBinaryFormatter Class

MSBinaryFormatter Class NFX Class Library

Implements ISerializer with Ms BinaryFormatter
Inheritance Hierarchy
Online System Object
NFX.Serialization MSBinaryFormatter

Namespace: NFX.Serialization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MSBinaryFormatter : ISerializer
public class MSBinaryFormatter : ISerializer
Public Class MSBinaryFormatter
    Implements ISerializer
Public Class MSBinaryFormatter
    Implements ISerializer
public ref class MSBinaryFormatter : ISerializer
public ref class MSBinaryFormatter : ISerializer
type MSBinaryFormatter =
    class
        interface ISerializer
    end
type MSBinaryFormatter =
    class
        interface ISerializer
    end
See Also
MSBinaryFormatter Members
NFX.Serialization Namespace


MSBinaryFormatter Members

MSBinaryFormatter Members NFX Class Library

The MSBinaryFormatter type exposes the following members.
Constructors
 | Name | Description
Public method | MSBinaryFormatter | Initializes a new instance of the MSBinaryFormatter class
Back to Top
Methods
 | Name | Description
Public method | Deserialize |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Serialize |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | IsThreadSafe |
Back to Top
See Also
MSBinaryFormatter Class
NFX.Serialization Namespace


MSBinaryFormatter Constructor

MSBinaryFormatter Constructor NFX Class Library

Initializes a new instance of the MSBinaryFormatter class

Namespace: NFX.Serialization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MSBinaryFormatter()
public MSBinaryFormatter()
Public Sub New
Public Sub New
public:
MSBinaryFormatter()
public:
MSBinaryFormatter()
new : unit -> MSBinaryFormatter
new : unit -> MSBinaryFormatter
See Also
MSBinaryFormatter Class
MSBinaryFormatter Members
NFX.Serialization Namespace


MSBinaryFormatter Methods

MSBinaryFormatter Methods NFX Class Library

The MSBinaryFormatter type exposes the following members.
Methods
 | Name | Description
Public method | Deserialize |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Serialize |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MSBinaryFormatter Class
NFX.Serialization Namespace


MSBinaryFormatter.Deserialize Method

MSBinaryFormatter Deserialize Method NFX Class Library

Namespace: NFX.Serialization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Deserialize(
    Stream stream
)
public Object Deserialize(
    Stream stream
)
Public Function Deserialize (
    stream As Stream
) As Object
Public Function Deserialize (
    stream As Stream
) As Object
public:
virtual Object^ Deserialize(
    Stream^ stream
) sealed
public:
virtual Object^ Deserialize(
    Stream^ stream
) sealed
abstract Deserialize :
        stream : Stream -> Object
override Deserialize :
        stream : Stream -> Object
abstract Deserialize :
        stream : Stream -> Object
override Deserialize :
        stream : Stream -> Object

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online Object

Implements

ISerializer Deserialize(Stream)
See Also
MSBinaryFormatter Class
MSBinaryFormatter Members
NFX.Serialization Namespace


MSBinaryFormatter.Serialize Method

MSBinaryFormatter Serialize Method NFX Class Library

Namespace: NFX.Serialization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Serialize(
    Stream stream,
    Object root
)
public void Serialize(
    Stream stream,
    Object root
)
Public Sub Serialize (
    stream As Stream,
    root As Object
)
Public Sub Serialize (
    stream As Stream,
    root As Object
)
public:
virtual void Serialize(
    Stream^ stream,
    Object^ root
) sealed
public:
virtual void Serialize(
    Stream^ stream,
    Object^ root
) sealed
abstract Serialize :
        stream : Stream *
        root : Object -> unit
override Serialize :
        stream : Stream *
        root : Object -> unit
abstract Serialize :
        stream : Stream *
        root : Object -> unit
override Serialize :
        stream : Stream *
        root : Object -> unit

Parameters

stream
Type: Online System.IO Stream
root
Type: Online System Object

Implements

ISerializer Serialize(Stream, Object)
See Also
MSBinaryFormatter Class
MSBinaryFormatter Members
NFX.Serialization Namespace


MSBinaryFormatter Properties

MSBinaryFormatter Properties NFX Class Library

The MSBinaryFormatter type exposes the following members.
Properties
 | Name | Description
Public property | IsThreadSafe |
Back to Top
See Also
MSBinaryFormatter Class
NFX.Serialization Namespace


MSBinaryFormatter.IsThreadSafe Property

MSBinaryFormatter IsThreadSafe Property NFX Class Library

Namespace: NFX.Serialization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsThreadSafe { get; }
public bool IsThreadSafe { get; }
Public ReadOnly Property IsThreadSafe As Boolean
    Get
Public ReadOnly Property IsThreadSafe As Boolean
    Get
public:
virtual property bool IsThreadSafe {
    bool get () sealed;
}
public:
virtual property bool IsThreadSafe {
    bool get () sealed;
}
abstract IsThreadSafe : bool with get
override IsThreadSafe : bool with get
abstract IsThreadSafe : bool with get
override IsThreadSafe : bool with get

Property Value

Type: Online Boolean

Implements

ISerializer IsThreadSafe
See Also
MSBinaryFormatter Class
MSBinaryFormatter Members
NFX.Serialization Namespace


NFXSerializationException Class

NFXSerializationException Class NFX Class Library

Base exception thrown by the serialization-related classes
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Serialization NFXSerializationException
NFX.Serialization.Arow ArowException
NFX.Serialization.JSON JSONException
NFX.Serialization.POD PODException
NFX.Serialization.Slim SlimException

Namespace: NFX.Serialization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class NFXSerializationException : NFXException
[SerializableAttribute]
public class NFXSerializationException : NFXException
<SerializableAttribute>
Public Class NFXSerializationException
    Inherits NFXException
<SerializableAttribute>
Public Class NFXSerializationException
    Inherits NFXException
[SerializableAttribute]
public ref class NFXSerializationException : public NFXException
[SerializableAttribute]
public ref class NFXSerializationException : public NFXException
[<SerializableAttribute>]
type NFXSerializationException =
    class
        inherit NFXException
    end
[<SerializableAttribute>]
type NFXSerializationException =
    class
        inherit NFXException
    end
See Also
NFXSerializationException Members
NFX.Serialization Namespace


NFXSerializationException Members

NFXSerializationException Members NFX Class Library

The NFXSerializationException type exposes the following members.
Constructors
 | Name | Description
Public method | NFXSerializationException | Initializes a new instance of the NFXSerializationException class
Public method | NFXSerializationException(String) | Initializes a new instance of the NFXSerializationException class
Protected method | NFXSerializationException(SerializationInfo, StreamingContext) | Initializes a new instance of the NFXSerializationException class
Public method | NFXSerializationException(String, Exception) | Initializes a new instance of the NFXSerializationException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
NFXSerializationException Class
NFX.Serialization Namespace


NFXSerializationException Constructor

NFXSerializationException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | NFXSerializationException | Initializes a new instance of the NFXSerializationException class
Public method | NFXSerializationException(String) | Initializes a new instance of the NFXSerializationException class
Protected method | NFXSerializationException(SerializationInfo, StreamingContext) | Initializes a new instance of the NFXSerializationException class
Public method | NFXSerializationException(String, Exception) | Initializes a new instance of the NFXSerializationException class
Back to Top
See Also
NFXSerializationException Class
NFXSerializationException Members
NFX.Serialization Namespace


NFXSerializationException Constructor

NFXSerializationException Constructor NFX Class Library

Initializes a new instance of the NFXSerializationException class

Namespace: NFX.Serialization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NFXSerializationException()
public NFXSerializationException()
Public Sub New
Public Sub New
public:
NFXSerializationException()
public:
NFXSerializationException()
new : unit -> NFXSerializationException
new : unit -> NFXSerializationException
See Also
NFXSerializationException Class
NFXSerializationException Members
NFXSerializationException Overload
NFX.Serialization Namespace


NFXSerializationException Constructor (String)

NFXSerializationException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NFXSerializationException class

Namespace: NFX.Serialization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NFXSerializationException(
    string message
)
public NFXSerializationException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
NFXSerializationException(
    String^ message
)
public:
NFXSerializationException(
    String^ message
)
new :
        message : string -> NFXSerializationException
new :
        message : string -> NFXSerializationException

Parameters

message
Type: Online System String
See Also
NFXSerializationException Class
NFXSerializationException Members
NFXSerializationException Overload
NFX.Serialization Namespace


NFXSerializationException Constructor (SerializationInfo, StreamingContext)

NFXSerializationException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NFXSerializationException class

Namespace: NFX.Serialization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected NFXSerializationException(
    SerializationInfo info,
    StreamingContext context
)
protected NFXSerializationException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
NFXSerializationException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
NFXSerializationException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> NFXSerializationException
new :
        info : SerializationInfo *
        context : StreamingContext -> NFXSerializationException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
NFXSerializationException Class
NFXSerializationException Members
NFXSerializationException Overload
NFX.Serialization Namespace


NFXSerializationException Constructor (String, Exception)

NFXSerializationException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NFXSerializationException class

Namespace: NFX.Serialization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NFXSerializationException(
    string message,
    Exception inner
)
public NFXSerializationException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
NFXSerializationException(
    String^ message,
    Exception^ inner
)
public:
NFXSerializationException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> NFXSerializationException
new :
        message : string *
        inner : Exception -> NFXSerializationException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
NFXSerializationException Class
NFXSerializationException Members
NFXSerializationException Overload
NFX.Serialization Namespace


NFXSerializationException Methods

NFXSerializationException Methods NFX Class Library

The NFXSerializationException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
NFXSerializationException Class
NFX.Serialization Namespace


NFXSerializationException Properties

NFXSerializationException Properties NFX Class Library

The NFXSerializationException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
NFXSerializationException Class
NFX.Serialization Namespace


NFXSerializationException Events

NFXSerializationException Events NFX Class Library

The NFXSerializationException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
NFXSerializationException Class
NFX.Serialization Namespace


SerializationOperation Enumeration

SerializationOperation Enumeration NFX Class Library

Denotes ser/deser operations

Namespace: NFX.Serialization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum SerializationOperation
public enum SerializationOperation
Public Enumeration SerializationOperation
Public Enumeration SerializationOperation
public enum class SerializationOperation
public enum class SerializationOperation
type SerializationOperation
type SerializationOperation
Members
Member name | Value | Description
Serializing | 0 | Serializing object to stream
Deserializing | 1 | Deserializing object from stream
See Also
NFX.Serialization Namespace


SerializationUtils Class

SerializationUtils Class NFX Class Library

Provides misc serialization-related functions that are really low-level and not intended to be used by developers. Methods are thread-safe
Inheritance Hierarchy
Online System Object
NFX.Serialization SerializationUtils

Namespace: NFX.Serialization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class SerializationUtils
public static class SerializationUtils
<ExtensionAttribute>
Public NotInheritable Class SerializationUtils
<ExtensionAttribute>
Public NotInheritable Class SerializationUtils
[ExtensionAttribute]
public ref class SerializationUtils abstract sealed
[ExtensionAttribute]
public ref class SerializationUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SerializationUtils =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SerializationUtils =  class end
See Also
SerializationUtils Members
NFX.Serialization Namespace


SerializationUtils Members

SerializationUtils Members NFX Class Library

The SerializationUtils type exposes the following members.
Methods
Name | Description
FindSerializationAttributedMethods | Finds methods decorated by [On(De)Seriali(zing/zed)]
GetISerializableCtorInfo | Returns .ctor(SerializationInfo, StreamingContext) that complies with ISerializable concept, or null.
GetNodeByPath | Navigates through JSON datamap by subsequent node names.
GetSerializableFields | Gets all serializable fields for type in parent->child declaraion order, sub-ordered by case within the segment
InvokeSerializationAttributedMethods | Calls method in the list that was returned by a call to FindSerializationAttributedMethods
MakeNewObjectInstance | Create new object instance for type, calling default ctor
WalkArrayRead T | Performs an action on each element of a possibly mutidimensional array
WalkArrayWrite | Performs an action on each element of a possibly mutidimensional array
Back to Top
See Also
SerializationUtils Class
NFX.Serialization Namespace


SerializationUtils Methods

SerializationUtils Methods NFX Class Library

The SerializationUtils type exposes the following members.
Methods
Name | Description
FindSerializationAttributedMethods | Finds methods decorated by [On(De)Seriali(zing/zed)]
GetISerializableCtorInfo | Returns .ctor(SerializationInfo, StreamingContext) that complies with ISerializable concept, or null.
GetNodeByPath | Navigates through JSON datamap by subsequent node names.
GetSerializableFields | Gets all serializable fields for type in parent->child declaraion order, sub-ordered by case within the segment
InvokeSerializationAttributedMethods | Calls method in the list that was returned by a call to FindSerializationAttributedMethods
MakeNewObjectInstance | Create new object instance for type, calling default ctor
WalkArrayRead T | Performs an action on each element of a possibly mutidimensional array
WalkArrayWrite | Performs an action on each element of a possibly mutidimensional array
Back to Top
See Also
SerializationUtils Class
NFX.Serialization Namespace


SerializationUtils.FindSerializationAttributedMethods Method

SerializationUtils FindSerializationAttributedMethods Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Finds methods decorated by [On(De)Seriali(zing/zed)]

Namespace: NFX.Serialization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static List<MethodInfo> FindSerializationAttributedMethods(
    Type t,
    Type atype
)
public static List<MethodInfo> FindSerializationAttributedMethods(
    Type t,
    Type atype
)
Public Shared Function FindSerializationAttributedMethods (
    t As Type,
    atype As Type
) As List(Of MethodInfo)
Public Shared Function FindSerializationAttributedMethods (
    t As Type,
    atype As Type
) As List(Of MethodInfo)
public:
static List<MethodInfo^>^ FindSerializationAttributedMethods(
    Type^ t,
    Type^ atype
)
public:
static List<MethodInfo^>^ FindSerializationAttributedMethods(
    Type^ t,
    Type^ atype
)
static member FindSerializationAttributedMethods :
        t : Type *
        atype : Type -> List<MethodInfo>
static member FindSerializationAttributedMethods :
        t : Type *
        atype : Type -> List<MethodInfo>

Parameters

t
Type: Online System Type
A type whose methods to search
atype
Type: Online System Type
Attribute type to search

Return Value

Type: Online List Online MethodInfo
List(MethodInfo) that qualifies or NULL if none found
See Also
SerializationUtils Class
SerializationUtils Members
NFX.Serialization Namespace


SerializationUtils.GetISerializableCtorInfo Method

SerializationUtils GetISerializableCtorInfo Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns .ctor(SerializationInfo, StreamingContext) that complies with ISerializable concept, or null.

Namespace: NFX.Serialization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ConstructorInfo GetISerializableCtorInfo(
    Type type
)
public static ConstructorInfo GetISerializableCtorInfo(
    Type type
)
Public Shared Function GetISerializableCtorInfo (
    type As Type
) As ConstructorInfo
Public Shared Function GetISerializableCtorInfo (
    type As Type
) As ConstructorInfo
public:
static ConstructorInfo^ GetISerializableCtorInfo(
    Type^ type
)
public:
static ConstructorInfo^ GetISerializableCtorInfo(
    Type^ type
)
static member GetISerializableCtorInfo :
        type : Type -> ConstructorInfo
static member GetISerializableCtorInfo :
        type : Type -> ConstructorInfo

Parameters

type
Type: Online System Type

Return Value

Type: Online ConstructorInfo
See Also
SerializationUtils Class
SerializationUtils Members
NFX.Serialization Namespace


SerializationUtils.GetNodeByPath Method

SerializationUtils GetNodeByPath Method NFX Class Library

Navigates through JSON datamap by subsequent node names.

Namespace: NFX.Serialization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Object GetNodeByPath(
    this JSONDataMap json,
    params string[] nodeNames
)
public static Object GetNodeByPath(
    this JSONDataMap json,
    params string[] nodeNames
)
<ExtensionAttribute>
Public Shared Function GetNodeByPath (
    json As JSONDataMap,
    ParamArray nodeNames As String()
) As Object
<ExtensionAttribute>
Public Shared Function GetNodeByPath (
    json As JSONDataMap,
    ParamArray nodeNames As String()
) As Object
public:
[ExtensionAttribute]
static Object^ GetNodeByPath(
    JSONDataMap^ json,
    ... array<String^>^ nodeNames
)
public:
[ExtensionAttribute]
static Object^ GetNodeByPath(
    JSONDataMap^ json,
    ... array<String^>^ nodeNames
)
static member GetNodeByPath :
        json : JSONDataMap *
        nodeNames : string[] -> Object
static member GetNodeByPath :
        json : JSONDataMap *
        nodeNames : string[] -> Object

Parameters

json
Type: NFX.Serialization.JSON JSONDataMap
nodeNames
Type: Online System String

Return Value

Type: Online Object
null if navigation path is not exists. JSONDataMap if navigation ends up with non-leaf node. object if navigation ends up with leaf node.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type JSONDataMap. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
SerializationUtils Class
SerializationUtils Members
NFX.Serialization Namespace


SerializationUtils.GetSerializableFields Method

SerializationUtils GetSerializableFields Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets all serializable fields for type in parent->child declaraion order, sub-ordered by case within the segment

Namespace: NFX.Serialization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<FieldInfo> GetSerializableFields(
    Type type
)
public static IEnumerable<FieldInfo> GetSerializableFields(
    Type type
)
Public Shared Function GetSerializableFields (
    type As Type
) As IEnumerable(Of FieldInfo)
Public Shared Function GetSerializableFields (
    type As Type
) As IEnumerable(Of FieldInfo)
public:
static IEnumerable<FieldInfo^>^ GetSerializableFields(
    Type^ type
)
public:
static IEnumerable<FieldInfo^>^ GetSerializableFields(
    Type^ type
)
static member GetSerializableFields :
        type : Type -> IEnumerable<FieldInfo>
static member GetSerializableFields :
        type : Type -> IEnumerable<FieldInfo>

Parameters

type
Type: Online System Type

Return Value

Type: Online IEnumerable Online FieldInfo
See Also
SerializationUtils Class
SerializationUtils Members
NFX.Serialization Namespace


SerializationUtils.InvokeSerializationAttributedMethods Method

SerializationUtils InvokeSerializationAttributedMethods Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Calls method in the list that was returned by a call to FindSerializationAttributedMethods

Namespace: NFX.Serialization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void InvokeSerializationAttributedMethods(
    List<MethodInfo> methods,
    Object instance,
    StreamingContext streamingContext
)
public static void InvokeSerializationAttributedMethods(
    List<MethodInfo> methods,
    Object instance,
    StreamingContext streamingContext
)
Public Shared Sub InvokeSerializationAttributedMethods (
    methods As List(Of MethodInfo),
    instance As Object,
    streamingContext As StreamingContext
)
Public Shared Sub InvokeSerializationAttributedMethods (
    methods As List(Of MethodInfo),
    instance As Object,
    streamingContext As StreamingContext
)
public:
static void InvokeSerializationAttributedMethods(
    List<MethodInfo^>^ methods,
    Object^ instance,
    StreamingContext streamingContext
)
public:
static void InvokeSerializationAttributedMethods(
    List<MethodInfo^>^ methods,
    Object^ instance,
    StreamingContext streamingContext
)
static member InvokeSerializationAttributedMethods :
        methods : List<MethodInfo> *
        instance : Object *
        streamingContext : StreamingContext -> unit
static member InvokeSerializationAttributedMethods :
        methods : List<MethodInfo> *
        instance : Object *
        streamingContext : StreamingContext -> unit

Parameters

methods
Type: Online System.Collections.Generic List Online MethodInfo
list that was returned by a call to FindSerializationAttributedMethods
instance
Type: Online System Object
Instance to invoke mathods on
streamingContext
Type: Online System.Runtime.Serialization StreamingContext
Streaming Context
See Also
SerializationUtils Class
SerializationUtils Members
NFX.Serialization Namespace


SerializationUtils.MakeNewObjectInstance Method

SerializationUtils MakeNewObjectInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Create new object instance for type, calling default ctor

Namespace: NFX.Serialization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Object MakeNewObjectInstance(
    Type type
)
public static Object MakeNewObjectInstance(
    Type type
)
Public Shared Function MakeNewObjectInstance (
    type As Type
) As Object
Public Shared Function MakeNewObjectInstance (
    type As Type
) As Object
public:
static Object^ MakeNewObjectInstance(
    Type^ type
)
public:
static Object^ MakeNewObjectInstance(
    Type^ type
)
static member MakeNewObjectInstance :
        type : Type -> Object
static member MakeNewObjectInstance :
        type : Type -> Object

Parameters

type
Type: Online System Type

Return Value

Type: Online Object
See Also
SerializationUtils Class
SerializationUtils Members
NFX.Serialization Namespace


SerializationUtils.WalkArrayRead(T) Method

SerializationUtils WalkArrayRead T Method NFX Class Library

Performs an action on each element of a possibly mutidimensional array

Namespace: NFX.Serialization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WalkArrayRead<T>(
    Array arr,
    Func<T> each
)
public static void WalkArrayRead<T>(
    Array arr,
    Func<T> each
)
Public Shared Sub WalkArrayRead(Of T) (
    arr As Array,
    each As Func(Of T)
)
Public Shared Sub WalkArrayRead(Of T) (
    arr As Array,
    each As Func(Of T)
)
public:
generic<typename T>
static void WalkArrayRead(
    Array^ arr,
    Func<T>^ each
)
public:
generic<typename T>
static void WalkArrayRead(
    Array^ arr,
    Func<T>^ each
)
static member WalkArrayRead :
        arr : Array *
        each : Func<'T> -> unit
static member WalkArrayRead :
        arr : Array *
        each : Func<'T> -> unit

Parameters

arr
Type: Online System Array
each
Type: Online System Func T
Type Parameters
T
See Also
SerializationUtils Class
SerializationUtils Members
NFX.Serialization Namespace


SerializationUtils.WalkArrayWrite Method

SerializationUtils WalkArrayWrite Method NFX Class Library

Performs an action on each element of a possibly mutidimensional array

Namespace: NFX.Serialization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WalkArrayWrite(
    Array arr,
    Action<Object> each
)
public static void WalkArrayWrite(
    Array arr,
    Action<Object> each
)
Public Shared Sub WalkArrayWrite (
    arr As Array,
    each As Action(Of Object)
)
Public Shared Sub WalkArrayWrite (
    arr As Array,
    each As Action(Of Object)
)
public:
static void WalkArrayWrite(
    Array^ arr,
    Action<Object^>^ each
)
public:
static void WalkArrayWrite(
    Array^ arr,
    Action<Object^>^ each
)
static member WalkArrayWrite :
        arr : Array *
        each : Action<Object> -> unit
static member WalkArrayWrite :
        arr : Array *
        each : Action<Object> -> unit

Parameters

arr
Type: Online System Array
each
Type: Online System Action Online Object
See Also
SerializationUtils Class
SerializationUtils Members
NFX.Serialization Namespace


NFX.Serialization.Arow Namespace

NFX.Serialization.Arow Namespace NFX Class Library

Classes
 | Class | Description
Public class | ArowAttribute | Denotes types that generate Arow ser/deser core
Public class | ArowException | Base exception thrown by the Arow serialization format
Public class | ArowSerializer | Facade for performing Arow serilalization. Arow format is purposely designed for "[a]daptable [row]"/version tolerant serialization that eschews creating extra copies and object instances. The serializer is used in conjunction with cl compiler that generates type-specific static serializer cores for every type that supports the format
Public class | CodeGenerator | Generates code for serilaizer and deserializer
Public class | Reader | Provides low-level Arow format reading
Public class | Writer | Provides low-level Arow format writing
Interfaces
 | Interface | Description
Public interface | ITypeSerializationCore | Designates classes that register their single instance via a call to ArowSerializer.Register(). These classes are generated by cl arow compiler
Enumerations
 | Enumeration | Description
Public enumeration | CodeGenerator GeneratedCodeSegregation | Defines how generated files should be stored on disk
Public enumeration | DataType | Denotes types that Arow directly supports. Complex object are serialized as POD


ArowAttribute Class

ArowAttribute Class NFX Class Library

Denotes types that generate Arow ser/deser core
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.Serialization.Arow ArowAttribute

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false, Inherited = false)]
public sealed class ArowAttribute : Attribute
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false, Inherited = false)]
public sealed class ArowAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := false, Inherited := false)>
Public NotInheritable Class ArowAttribute
    Inherits Attribute
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := false, Inherited := false)>
Public NotInheritable Class ArowAttribute
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = false, Inherited = false)]
public ref class ArowAttribute sealed : public Attribute
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = false, Inherited = false)]
public ref class ArowAttribute sealed : public Attribute
[<SealedAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false, Inherited = false)>]
type ArowAttribute =
    class
        inherit Attribute
    end
[<SealedAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false, Inherited = false)>]
type ArowAttribute =
    class
        inherit Attribute
    end
See Also
ArowAttribute Members
NFX.Serialization.Arow Namespace


ArowAttribute Members

ArowAttribute Members NFX Class Library

The ArowAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | ArowAttribute | Initializes a new instance of the ArowAttribute class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
ArowAttribute Class
NFX.Serialization.Arow Namespace


ArowAttribute Constructor

ArowAttribute Constructor NFX Class Library

Initializes a new instance of the ArowAttribute class

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ArowAttribute()
public ArowAttribute()
Public Sub New
Public Sub New
public:
ArowAttribute()
public:
ArowAttribute()
new : unit -> ArowAttribute
new : unit -> ArowAttribute
See Also
ArowAttribute Class
ArowAttribute Members
NFX.Serialization.Arow Namespace


ArowAttribute Methods

ArowAttribute Methods NFX Class Library

The ArowAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ArowAttribute Class
NFX.Serialization.Arow Namespace


ArowAttribute Properties

ArowAttribute Properties NFX Class Library

The ArowAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
ArowAttribute Class
NFX.Serialization.Arow Namespace


ArowException Class

ArowException Class NFX Class Library

Base exception thrown by the Arow serialization format
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Serialization NFXSerializationException
NFX.Serialization.Arow ArowException

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ArowException : NFXSerializationException
[SerializableAttribute]
public class ArowException : NFXSerializationException
<SerializableAttribute>
Public Class ArowException
    Inherits NFXSerializationException
<SerializableAttribute>
Public Class ArowException
    Inherits NFXSerializationException
[SerializableAttribute]
public ref class ArowException : public NFXSerializationException
[SerializableAttribute]
public ref class ArowException : public NFXSerializationException
[<SerializableAttribute>]
type ArowException =
    class
        inherit NFXSerializationException
    end
[<SerializableAttribute>]
type ArowException =
    class
        inherit NFXSerializationException
    end
See Also
ArowException Members
NFX.Serialization.Arow Namespace


ArowException Members

ArowException Members NFX Class Library

The ArowException type exposes the following members.
Constructors
 | Name | Description
Public method | ArowException | Initializes a new instance of the ArowException class
Public method | ArowException(String) | Initializes a new instance of the ArowException class
Protected method | ArowException(SerializationInfo, StreamingContext) | Initializes a new instance of the ArowException class
Public method | ArowException(String, Exception) | Initializes a new instance of the ArowException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ArowException Class
NFX.Serialization.Arow Namespace


ArowException Constructor

ArowException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | ArowException | Initializes a new instance of the ArowException class
Public method | ArowException(String) | Initializes a new instance of the ArowException class
Protected method | ArowException(SerializationInfo, StreamingContext) | Initializes a new instance of the ArowException class
Public method | ArowException(String, Exception) | Initializes a new instance of the ArowException class
Back to Top
See Also
ArowException Class
ArowException Members
NFX.Serialization.Arow Namespace


ArowException Constructor

ArowException Constructor NFX Class Library

Initializes a new instance of the ArowException class

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ArowException()
public ArowException()
Public Sub New
Public Sub New
public:
ArowException()
public:
ArowException()
new : unit -> ArowException
new : unit -> ArowException
See Also
ArowException Class
ArowException Members
ArowException Overload
NFX.Serialization.Arow Namespace


ArowException Constructor (String)

ArowException Constructor (String) NFX Class Library

Initializes a new instance of the ArowException class

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ArowException(
    string message
)
public ArowException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
ArowException(
    String^ message
)
public:
ArowException(
    String^ message
)
new :
        message : string -> ArowException
new :
        message : string -> ArowException

Parameters

message
Type: Online System String
See Also
ArowException Class
ArowException Members
ArowException Overload
NFX.Serialization.Arow Namespace


ArowException Constructor (SerializationInfo, StreamingContext)

ArowException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ArowException class

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ArowException(
    SerializationInfo info,
    StreamingContext context
)
protected ArowException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
ArowException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
ArowException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ArowException
new :
        info : SerializationInfo *
        context : StreamingContext -> ArowException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
ArowException Class
ArowException Members
ArowException Overload
NFX.Serialization.Arow Namespace


ArowException Constructor (String, Exception)

ArowException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ArowException class

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ArowException(
    string message,
    Exception inner
)
public ArowException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
ArowException(
    String^ message,
    Exception^ inner
)
public:
ArowException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> ArowException
new :
        message : string *
        inner : Exception -> ArowException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
ArowException Class
ArowException Members
ArowException Overload
NFX.Serialization.Arow Namespace


ArowException Methods

ArowException Methods NFX Class Library

The ArowException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
ArowException Class
NFX.Serialization.Arow Namespace


ArowException Properties

ArowException Properties NFX Class Library

The ArowException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
ArowException Class
NFX.Serialization.Arow Namespace


ArowException Events

ArowException Events NFX Class Library

The ArowException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
ArowException Class
NFX.Serialization.Arow Namespace


ArowSerializer Class

ArowSerializer Class NFX Class Library

Facade for performing Arow serilalization. Arow format is purposely designed for "[a]daptable [row]"/version tolerant serialization that eschews creating extra copies and object instances. The serializer is used in conjunction with cl compiler that generates type-specific static serializer cores for every type that supports the format
Inheritance Hierarchy
Online System Object
NFX.Serialization.Arow ArowSerializer

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class ArowSerializer
public static class ArowSerializer
Public NotInheritable Class ArowSerializer
Public NotInheritable Class ArowSerializer
public ref class ArowSerializer abstract sealed
public ref class ArowSerializer abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ArowSerializer =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ArowSerializer =  class end
See Also
ArowSerializer Members
NFX.Serialization.Arow Namespace


ArowSerializer Members

ArowSerializer Members NFX Class Library

The ArowSerializer type exposes the following members.
Methods
Name | Description
Deserialize |
IsRowTypeSupported |
Register | Registers ITypeSerializationCore so it can be used globaly to serialize TypedRows in Arow format
RegisterTypeSerializationCores |
Serialize |
TryDeserialize |
Back to Top
See Also
ArowSerializer Class
NFX.Serialization.Arow Namespace


ArowSerializer Methods

ArowSerializer Methods NFX Class Library

The ArowSerializer type exposes the following members.
Methods
Name | Description
Deserialize |
IsRowTypeSupported |
Register | Registers ITypeSerializationCore so it can be used globaly to serialize TypedRows in Arow format
RegisterTypeSerializationCores |
Serialize |
TryDeserialize |
Back to Top
See Also
ArowSerializer Class
NFX.Serialization.Arow Namespace


ArowSerializer.Deserialize Method

ArowSerializer Deserialize Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Deserialize(
    TypedRow row,
    ReadingStreamer streamer,
    bool header = true
)
public static void Deserialize(
    TypedRow row,
    ReadingStreamer streamer,
    bool header = true
)
Public Shared Sub Deserialize (
    row As TypedRow,
    streamer As ReadingStreamer,
    Optional header As Boolean = true
)
Public Shared Sub Deserialize (
    row As TypedRow,
    streamer As ReadingStreamer,
    Optional header As Boolean = true
)
public:
static void Deserialize(
    TypedRow^ row,
    ReadingStreamer^ streamer,
    bool header = true
)
public:
static void Deserialize(
    TypedRow^ row,
    ReadingStreamer^ streamer,
    bool header = true
)
static member Deserialize :
        row : TypedRow *
        streamer : ReadingStreamer *
        ?header : bool
(* Defaults:
        let _header = defaultArg header true
*)
-> unit
static member Deserialize :
        row : TypedRow *
        streamer : ReadingStreamer *
        ?header : bool
(* Defaults:
        let _header = defaultArg header true
*)
-> unit

Parameters

row
Type: NFX.DataAccess.CRUD TypedRow
streamer
Type: NFX.IO ReadingStreamer
header (Optional)
Type: Online System Boolean
See Also
ArowSerializer Class
ArowSerializer Members
NFX.Serialization.Arow Namespace


ArowSerializer.IsRowTypeSupported Method

ArowSerializer IsRowTypeSupported Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsRowTypeSupported(
    Type tRow
)
public static bool IsRowTypeSupported(
    Type tRow
)
Public Shared Function IsRowTypeSupported (
    tRow As Type
) As Boolean
Public Shared Function IsRowTypeSupported (
    tRow As Type
) As Boolean
public:
static bool IsRowTypeSupported(
    Type^ tRow
)
public:
static bool IsRowTypeSupported(
    Type^ tRow
)
static member IsRowTypeSupported :
        tRow : Type -> bool
static member IsRowTypeSupported :
        tRow : Type -> bool

Parameters

tRow
Type: Online System Type

Return Value

Type: Online Boolean
See Also
ArowSerializer Class
ArowSerializer Members
NFX.Serialization.Arow Namespace


ArowSerializer.Register Method

ArowSerializer Register Method NFX Class Library

Registers ITypeSerializationCore so it can be used globaly to serialize TypedRows in Arow format

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool Register(
    Type tRow,
    ITypeSerializationCore core
)
public static bool Register(
    Type tRow,
    ITypeSerializationCore core
)
Public Shared Function Register (
    tRow As Type,
    core As ITypeSerializationCore
) As Boolean
Public Shared Function Register (
    tRow As Type,
    core As ITypeSerializationCore
) As Boolean
public:
static bool Register(
    Type^ tRow,
    ITypeSerializationCore^ core
)
public:
static bool Register(
    Type^ tRow,
    ITypeSerializationCore^ core
)
static member Register :
        tRow : Type *
        core : ITypeSerializationCore -> bool
static member Register :
        tRow : Type *
        core : ITypeSerializationCore -> bool

Parameters

tRow
Type: Online System Type
core
Type: NFX.Serialization.Arow ITypeSerializationCore

Return Value

Type: Online Boolean
See Also
ArowSerializer Class
ArowSerializer Members
NFX.Serialization.Arow Namespace


ArowSerializer.RegisterTypeSerializationCores Method

ArowSerializer RegisterTypeSerializationCores Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void RegisterTypeSerializationCores(
    Assembly asm
)
public static void RegisterTypeSerializationCores(
    Assembly asm
)
Public Shared Sub RegisterTypeSerializationCores (
    asm As Assembly
)
Public Shared Sub RegisterTypeSerializationCores (
    asm As Assembly
)
public:
static void RegisterTypeSerializationCores(
    Assembly^ asm
)
public:
static void RegisterTypeSerializationCores(
    Assembly^ asm
)
static member RegisterTypeSerializationCores :
        asm : Assembly -> unit
static member RegisterTypeSerializationCores :
        asm : Assembly -> unit

Parameters

asm
Type: Online System.Reflection Assembly
See Also
ArowSerializer Class
ArowSerializer Members
NFX.Serialization.Arow Namespace


ArowSerializer.Serialize Method

ArowSerializer Serialize Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Serialize(
    TypedRow row,
    WritingStreamer streamer,
    bool header = true
)
public static void Serialize(
    TypedRow row,
    WritingStreamer streamer,
    bool header = true
)
Public Shared Sub Serialize (
    row As TypedRow,
    streamer As WritingStreamer,
    Optional header As Boolean = true
)
Public Shared Sub Serialize (
    row As TypedRow,
    streamer As WritingStreamer,
    Optional header As Boolean = true
)
public:
static void Serialize(
    TypedRow^ row,
    WritingStreamer^ streamer,
    bool header = true
)
public:
static void Serialize(
    TypedRow^ row,
    WritingStreamer^ streamer,
    bool header = true
)
static member Serialize :
        row : TypedRow *
        streamer : WritingStreamer *
        ?header : bool
(* Defaults:
        let _header = defaultArg header true
*)
-> unit
static member Serialize :
        row : TypedRow *
        streamer : WritingStreamer *
        ?header : bool
(* Defaults:
        let _header = defaultArg header true
*)
-> unit

Parameters

row
Type: NFX.DataAccess.CRUD TypedRow
streamer
Type: NFX.IO WritingStreamer
header (Optional)
Type: Online System Boolean
See Also
ArowSerializer Class
ArowSerializer Members
NFX.Serialization.Arow Namespace


ArowSerializer.TryDeserialize Method

ArowSerializer TryDeserialize Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool TryDeserialize(
    TypedRow row,
    ReadingStreamer streamer,
    bool header = true
)
public static bool TryDeserialize(
    TypedRow row,
    ReadingStreamer streamer,
    bool header = true
)
Public Shared Function TryDeserialize (
    row As TypedRow,
    streamer As ReadingStreamer,
    Optional header As Boolean = true
) As Boolean
Public Shared Function TryDeserialize (
    row As TypedRow,
    streamer As ReadingStreamer,
    Optional header As Boolean = true
) As Boolean
public:
static bool TryDeserialize(
    TypedRow^ row,
    ReadingStreamer^ streamer,
    bool header = true
)
public:
static bool TryDeserialize(
    TypedRow^ row,
    ReadingStreamer^ streamer,
    bool header = true
)
static member TryDeserialize :
        row : TypedRow *
        streamer : ReadingStreamer *
        ?header : bool
(* Defaults:
        let _header = defaultArg header true
*)
-> bool
static member TryDeserialize :
        row : TypedRow *
        streamer : ReadingStreamer *
        ?header : bool
(* Defaults:
        let _header = defaultArg header true
*)
-> bool

Parameters

row
Type: NFX.DataAccess.CRUD TypedRow
streamer
Type: NFX.IO ReadingStreamer
header (Optional)
Type: Online System Boolean

Return Value

Type: Online Boolean
See Also
ArowSerializer Class
ArowSerializer Members
NFX.Serialization.Arow Namespace


CodeGenerator Class

CodeGenerator Class NFX Class Library

Generates code for serilaizer and deserializer
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Serialization.Arow CodeGenerator

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CodeGenerator : DisposableObject
public class CodeGenerator : DisposableObject
Public Class CodeGenerator
    Inherits DisposableObject
Public Class CodeGenerator
    Inherits DisposableObject
public ref class CodeGenerator : public DisposableObject
public ref class CodeGenerator : public DisposableObject
type CodeGenerator =
    class
        inherit DisposableObject
    end
type CodeGenerator =
    class
        inherit DisposableObject
    end
See Also
CodeGenerator Members
NFX.Serialization.Arow Namespace


CodeGenerator Members

CodeGenerator Members NFX Class Library

The CodeGenerator type exposes the following members.
Constructors
 | Name | Description
Public method | CodeGenerator | Initializes a new instance of the CodeGenerator class
Back to Top
Methods
 | Name | Description
Protected method | Destructor | Override this method to do actual destructor work (Inherited from DisposableObject.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoGenerate |
Protected method | EmitDeserialize |
Protected method | EmitDeserializeBody |
Protected method | EmitDeserializeField |
Protected method | EmitFileFooter |
Protected method | EmitFileHeader |
Protected method | EmitITypeSerializationCore |
Protected method | EmitNamespaceFooter |
Protected method | EmitNamespaceHeader |
Protected method | EmitSerialize |
Protected method | EmitSerializeBody |
Protected method | EmitSerializeFieldLine |
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Generate |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
 | GetName(String) | Converts backend name of up to 8 ASCII chars in length
 | GetName(UInt64) | Converts backend name of up to 8 ASCII chars in length
Protected method | GetRowTypes |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | WriteContent |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | CodeSegregation |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | RootPath |
Back to Top
See Also
CodeGenerator Class
NFX.Serialization.Arow Namespace


CodeGenerator Constructor

CodeGenerator Constructor NFX Class Library

Initializes a new instance of the CodeGenerator class

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CodeGenerator()
public CodeGenerator()
Public Sub New
Public Sub New
public:
CodeGenerator()
public:
CodeGenerator()
new : unit -> CodeGenerator
new : unit -> CodeGenerator
See Also
CodeGenerator Class
CodeGenerator Members
NFX.Serialization.Arow Namespace


CodeGenerator Methods

CodeGenerator Methods NFX Class Library

The CodeGenerator type exposes the following members.
Methods
 | Name | Description
Protected method | Destructor | Override this method to do actual destructor work (Inherited from DisposableObject.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoGenerate |
Protected method | EmitDeserialize |
Protected method | EmitDeserializeBody |
Protected method | EmitDeserializeField |
Protected method | EmitFileFooter |
Protected method | EmitFileHeader |
Protected method | EmitITypeSerializationCore |
Protected method | EmitNamespaceFooter |
Protected method | EmitNamespaceHeader |
Protected method | EmitSerialize |
Protected method | EmitSerializeBody |
Protected method | EmitSerializeFieldLine |
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Generate |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
 | GetName(String) | Converts backend name of up to 8 ASCII chars in length
 | GetName(UInt64) | Converts backend name of up to 8 ASCII chars in length
Protected method | GetRowTypes |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | WriteContent |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CodeGenerator Class
NFX.Serialization.Arow Namespace


CodeGenerator.DoGenerate Method

CodeGenerator DoGenerate Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoGenerate(
    Assembly asm
)
protected virtual void DoGenerate(
    Assembly asm
)
Protected Overridable Sub DoGenerate (
    asm As Assembly
)
Protected Overridable Sub DoGenerate (
    asm As Assembly
)
protected:
virtual void DoGenerate(
    Assembly^ asm
)
protected:
virtual void DoGenerate(
    Assembly^ asm
)
abstract DoGenerate :
        asm : Assembly -> unit
override DoGenerate :
        asm : Assembly -> unit
abstract DoGenerate :
        asm : Assembly -> unit
override DoGenerate :
        asm : Assembly -> unit

Parameters

asm
Type: Online System.Reflection Assembly
See Also
CodeGenerator Class
CodeGenerator Members
NFX.Serialization.Arow Namespace


CodeGenerator.EmitDeserialize Method

CodeGenerator EmitDeserialize Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void EmitDeserialize(
    StringBuilder source,
    Schema schema
)
protected virtual void EmitDeserialize(
    StringBuilder source,
    Schema schema
)
Protected Overridable Sub EmitDeserialize (
    source As StringBuilder,
    schema As Schema
)
Protected Overridable Sub EmitDeserialize (
    source As StringBuilder,
    schema As Schema
)
protected:
virtual void EmitDeserialize(
    StringBuilder^ source,
    Schema^ schema
)
protected:
virtual void EmitDeserialize(
    StringBuilder^ source,
    Schema^ schema
)
abstract EmitDeserialize :
        source : StringBuilder *
        schema : Schema -> unit
override EmitDeserialize :
        source : StringBuilder *
        schema : Schema -> unit
abstract EmitDeserialize :
        source : StringBuilder *
        schema : Schema -> unit
override EmitDeserialize :
        source : StringBuilder *
        schema : Schema -> unit

Parameters

source
Type: Online System.Text StringBuilder
schema
Type: NFX.DataAccess.CRUD Schema
See Also
CodeGenerator Class
CodeGenerator Members
NFX.Serialization.Arow Namespace


CodeGenerator.EmitDeserializeBody Method

CodeGenerator EmitDeserializeBody Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void EmitDeserializeBody(
    StringBuilder source,
    Schema schema
)
protected virtual void EmitDeserializeBody(
    StringBuilder source,
    Schema schema
)
Protected Overridable Sub EmitDeserializeBody (
    source As StringBuilder,
    schema As Schema
)
Protected Overridable Sub EmitDeserializeBody (
    source As StringBuilder,
    schema As Schema
)
protected:
virtual void EmitDeserializeBody(
    StringBuilder^ source,
    Schema^ schema
)
protected:
virtual void EmitDeserializeBody(
    StringBuilder^ source,
    Schema^ schema
)
abstract EmitDeserializeBody :
        source : StringBuilder *
        schema : Schema -> unit
override EmitDeserializeBody :
        source : StringBuilder *
        schema : Schema -> unit
abstract EmitDeserializeBody :
        source : StringBuilder *
        schema : Schema -> unit
override EmitDeserializeBody :
        source : StringBuilder *
        schema : Schema -> unit

Parameters

source
Type: Online System.Text StringBuilder
schema
Type: NFX.DataAccess.CRUD Schema
See Also
CodeGenerator Class
CodeGenerator Members
NFX.Serialization.Arow Namespace


CodeGenerator.EmitDeserializeField Method

CodeGenerator EmitDeserializeField Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void EmitDeserializeField(
    StringBuilder source,
    Schema..::..FieldDef fdef
)
protected virtual void EmitDeserializeField(
    StringBuilder source,
    Schema..::..FieldDef fdef
)
Protected Overridable Sub EmitDeserializeField (
    source As StringBuilder,
    fdef As Schema..::..FieldDef
)
Protected Overridable Sub EmitDeserializeField (
    source As StringBuilder,
    fdef As Schema..::..FieldDef
)
protected:
virtual void EmitDeserializeField(
    StringBuilder^ source,
    Schema..::..FieldDef^ fdef
)
protected:
virtual void EmitDeserializeField(
    StringBuilder^ source,
    Schema..::..FieldDef^ fdef
)
abstract EmitDeserializeField :
        source : StringBuilder *
        fdef : Schema..::..FieldDef -> unit
override EmitDeserializeField :
        source : StringBuilder *
        fdef : Schema..::..FieldDef -> unit
abstract EmitDeserializeField :
        source : StringBuilder *
        fdef : Schema..::..FieldDef -> unit
override EmitDeserializeField :
        source : StringBuilder *
        fdef : Schema..::..FieldDef -> unit

Parameters

source
Type: Online System.Text StringBuilder
fdef
Type: NFX.DataAccess.CRUD Schema FieldDef
See Also
CodeGenerator Class
CodeGenerator Members
NFX.Serialization.Arow Namespace


CodeGenerator.EmitFileFooter Method

CodeGenerator EmitFileFooter Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void EmitFileFooter(
    StringBuilder source
)
protected virtual void EmitFileFooter(
    StringBuilder source
)
Protected Overridable Sub EmitFileFooter (
    source As StringBuilder
)
Protected Overridable Sub EmitFileFooter (
    source As StringBuilder
)
protected:
virtual void EmitFileFooter(
    StringBuilder^ source
)
protected:
virtual void EmitFileFooter(
    StringBuilder^ source
)
abstract EmitFileFooter :
        source : StringBuilder -> unit
override EmitFileFooter :
        source : StringBuilder -> unit
abstract EmitFileFooter :
        source : StringBuilder -> unit
override EmitFileFooter :
        source : StringBuilder -> unit

Parameters

source
Type: Online System.Text StringBuilder
See Also
CodeGenerator Class
CodeGenerator Members
NFX.Serialization.Arow Namespace


CodeGenerator.EmitFileHeader Method

CodeGenerator EmitFileHeader Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void EmitFileHeader(
    StringBuilder source
)
protected virtual void EmitFileHeader(
    StringBuilder source
)
Protected Overridable Sub EmitFileHeader (
    source As StringBuilder
)
Protected Overridable Sub EmitFileHeader (
    source As StringBuilder
)
protected:
virtual void EmitFileHeader(
    StringBuilder^ source
)
protected:
virtual void EmitFileHeader(
    StringBuilder^ source
)
abstract EmitFileHeader :
        source : StringBuilder -> unit
override EmitFileHeader :
        source : StringBuilder -> unit
abstract EmitFileHeader :
        source : StringBuilder -> unit
override EmitFileHeader :
        source : StringBuilder -> unit

Parameters

source
Type: Online System.Text StringBuilder
See Also
CodeGenerator Class
CodeGenerator Members
NFX.Serialization.Arow Namespace


CodeGenerator.EmitITypeSerializationCore Method

CodeGenerator EmitITypeSerializationCore Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void EmitITypeSerializationCore(
    StringBuilder source,
    Type tRow
)
protected virtual void EmitITypeSerializationCore(
    StringBuilder source,
    Type tRow
)
Protected Overridable Sub EmitITypeSerializationCore (
    source As StringBuilder,
    tRow As Type
)
Protected Overridable Sub EmitITypeSerializationCore (
    source As StringBuilder,
    tRow As Type
)
protected:
virtual void EmitITypeSerializationCore(
    StringBuilder^ source,
    Type^ tRow
)
protected:
virtual void EmitITypeSerializationCore(
    StringBuilder^ source,
    Type^ tRow
)
abstract EmitITypeSerializationCore :
        source : StringBuilder *
        tRow : Type -> unit
override EmitITypeSerializationCore :
        source : StringBuilder *
        tRow : Type -> unit
abstract EmitITypeSerializationCore :
        source : StringBuilder *
        tRow : Type -> unit
override EmitITypeSerializationCore :
        source : StringBuilder *
        tRow : Type -> unit

Parameters

source
Type: Online System.Text StringBuilder
tRow
Type: Online System Type
See Also
CodeGenerator Class
CodeGenerator Members
NFX.Serialization.Arow Namespace


CodeGenerator.EmitNamespaceFooter Method

CodeGenerator EmitNamespaceFooter Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void EmitNamespaceFooter(
    StringBuilder source
)
protected virtual void EmitNamespaceFooter(
    StringBuilder source
)
Protected Overridable Sub EmitNamespaceFooter (
    source As StringBuilder
)
Protected Overridable Sub EmitNamespaceFooter (
    source As StringBuilder
)
protected:
virtual void EmitNamespaceFooter(
    StringBuilder^ source
)
protected:
virtual void EmitNamespaceFooter(
    StringBuilder^ source
)
abstract EmitNamespaceFooter :
        source : StringBuilder -> unit
override EmitNamespaceFooter :
        source : StringBuilder -> unit
abstract EmitNamespaceFooter :
        source : StringBuilder -> unit
override EmitNamespaceFooter :
        source : StringBuilder -> unit

Parameters

source
Type: Online System.Text StringBuilder
See Also
CodeGenerator Class
CodeGenerator Members
NFX.Serialization.Arow Namespace


CodeGenerator.EmitNamespaceHeader Method

CodeGenerator EmitNamespaceHeader Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void EmitNamespaceHeader(
    StringBuilder source,
    string ns
)
protected virtual void EmitNamespaceHeader(
    StringBuilder source,
    string ns
)
Protected Overridable Sub EmitNamespaceHeader (
    source As StringBuilder,
    ns As String
)
Protected Overridable Sub EmitNamespaceHeader (
    source As StringBuilder,
    ns As String
)
protected:
virtual void EmitNamespaceHeader(
    StringBuilder^ source,
    String^ ns
)
protected:
virtual void EmitNamespaceHeader(
    StringBuilder^ source,
    String^ ns
)
abstract EmitNamespaceHeader :
        source : StringBuilder *
        ns : string -> unit
override EmitNamespaceHeader :
        source : StringBuilder *
        ns : string -> unit
abstract EmitNamespaceHeader :
        source : StringBuilder *
        ns : string -> unit
override EmitNamespaceHeader :
        source : StringBuilder *
        ns : string -> unit

Parameters

source
Type: Online System.Text StringBuilder
ns
Type: Online System String
See Also
CodeGenerator Class
CodeGenerator Members
NFX.Serialization.Arow Namespace


CodeGenerator.EmitSerialize Method

CodeGenerator EmitSerialize Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void EmitSerialize(
    StringBuilder source,
    Schema schema
)
protected virtual void EmitSerialize(
    StringBuilder source,
    Schema schema
)
Protected Overridable Sub EmitSerialize (
    source As StringBuilder,
    schema As Schema
)
Protected Overridable Sub EmitSerialize (
    source As StringBuilder,
    schema As Schema
)
protected:
virtual void EmitSerialize(
    StringBuilder^ source,
    Schema^ schema
)
protected:
virtual void EmitSerialize(
    StringBuilder^ source,
    Schema^ schema
)
abstract EmitSerialize :
        source : StringBuilder *
        schema : Schema -> unit
override EmitSerialize :
        source : StringBuilder *
        schema : Schema -> unit
abstract EmitSerialize :
        source : StringBuilder *
        schema : Schema -> unit
override EmitSerialize :
        source : StringBuilder *
        schema : Schema -> unit

Parameters

source
Type: Online System.Text StringBuilder
schema
Type: NFX.DataAccess.CRUD Schema
See Also
CodeGenerator Class
CodeGenerator Members
NFX.Serialization.Arow Namespace


CodeGenerator.EmitSerializeBody Method

CodeGenerator EmitSerializeBody Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void EmitSerializeBody(
    StringBuilder source,
    Schema schema
)
protected virtual void EmitSerializeBody(
    StringBuilder source,
    Schema schema
)
Protected Overridable Sub EmitSerializeBody (
    source As StringBuilder,
    schema As Schema
)
Protected Overridable Sub EmitSerializeBody (
    source As StringBuilder,
    schema As Schema
)
protected:
virtual void EmitSerializeBody(
    StringBuilder^ source,
    Schema^ schema
)
protected:
virtual void EmitSerializeBody(
    StringBuilder^ source,
    Schema^ schema
)
abstract EmitSerializeBody :
        source : StringBuilder *
        schema : Schema -> unit
override EmitSerializeBody :
        source : StringBuilder *
        schema : Schema -> unit
abstract EmitSerializeBody :
        source : StringBuilder *
        schema : Schema -> unit
override EmitSerializeBody :
        source : StringBuilder *
        schema : Schema -> unit

Parameters

source
Type: Online System.Text StringBuilder
schema
Type: NFX.DataAccess.CRUD Schema
See Also
CodeGenerator Class
CodeGenerator Members
NFX.Serialization.Arow Namespace


CodeGenerator.EmitSerializeFieldLine Method

CodeGenerator EmitSerializeFieldLine Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void EmitSerializeFieldLine(
    StringBuilder source,
    Schema..::..FieldDef fdef
)
protected virtual void EmitSerializeFieldLine(
    StringBuilder source,
    Schema..::..FieldDef fdef
)
Protected Overridable Sub EmitSerializeFieldLine (
    source As StringBuilder,
    fdef As Schema..::..FieldDef
)
Protected Overridable Sub EmitSerializeFieldLine (
    source As StringBuilder,
    fdef As Schema..::..FieldDef
)
protected:
virtual void EmitSerializeFieldLine(
    StringBuilder^ source,
    Schema..::..FieldDef^ fdef
)
protected:
virtual void EmitSerializeFieldLine(
    StringBuilder^ source,
    Schema..::..FieldDef^ fdef
)
abstract EmitSerializeFieldLine :
        source : StringBuilder *
        fdef : Schema..::..FieldDef -> unit
override EmitSerializeFieldLine :
        source : StringBuilder *
        fdef : Schema..::..FieldDef -> unit
abstract EmitSerializeFieldLine :
        source : StringBuilder *
        fdef : Schema..::..FieldDef -> unit
override EmitSerializeFieldLine :
        source : StringBuilder *
        fdef : Schema..::..FieldDef -> unit

Parameters

source
Type: Online System.Text StringBuilder
fdef
Type: NFX.DataAccess.CRUD Schema FieldDef
See Also
CodeGenerator Class
CodeGenerator Members
NFX.Serialization.Arow Namespace


CodeGenerator.Generate Method

CodeGenerator Generate Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Generate(
    Assembly asm
)
public void Generate(
    Assembly asm
)
Public Sub Generate (
    asm As Assembly
)
Public Sub Generate (
    asm As Assembly
)
public:
void Generate(
    Assembly^ asm
)
public:
void Generate(
    Assembly^ asm
)
member Generate :
        asm : Assembly -> unit
member Generate :
        asm : Assembly -> unit

Parameters

asm
Type: Online System.Reflection Assembly
See Also
CodeGenerator Class
CodeGenerator Members
NFX.Serialization.Arow Namespace


CodeGenerator.GetName Method

CodeGenerator GetName Method NFX Class Library

Overload List
Name | Description
GetName(String) | Converts backend name of up to 8 ASCII chars in length
GetName(UInt64) | Converts backend name of up to 8 ASCII chars in length
Back to Top
See Also
CodeGenerator Class
CodeGenerator Members
NFX.Serialization.Arow Namespace


CodeGenerator.GetName Method (String)

CodeGenerator GetName Method (String) NFX Class Library

Converts backend name of up to 8 ASCII chars in length

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ulong GetName(
    string name
)
public static ulong GetName(
    string name
)
Public Shared Function GetName (
    name As String
) As ULong
Public Shared Function GetName (
    name As String
) As ULong
public:
static unsigned long long GetName(
    String^ name
)
public:
static unsigned long long GetName(
    String^ name
)
static member GetName :
        name : string -> uint64
static member GetName :
        name : string -> uint64

Parameters

name
Type: Online System String

Return Value

Type: Online UInt64
See Also
CodeGenerator Class
CodeGenerator Members
GetName Overload
NFX.Serialization.Arow Namespace


CodeGenerator.GetName Method (UInt64)

CodeGenerator GetName Method (UInt64) NFX Class Library

Converts backend name of up to 8 ASCII chars in length

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetName(
    ulong name
)
public static string GetName(
    ulong name
)
Public Shared Function GetName (
    name As ULong
) As String
Public Shared Function GetName (
    name As ULong
) As String
public:
static String^ GetName(
    unsigned long long name
)
public:
static String^ GetName(
    unsigned long long name
)
static member GetName :
        name : uint64 -> string
static member GetName :
        name : uint64 -> string

Parameters

name
Type: Online System UInt64

Return Value

Type: Online String
See Also
CodeGenerator Class
CodeGenerator Members
GetName Overload
NFX.Serialization.Arow Namespace


CodeGenerator.GetRowTypes Method

CodeGenerator GetRowTypes Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual IEnumerable<Type> GetRowTypes(
    Assembly asm
)
protected virtual IEnumerable<Type> GetRowTypes(
    Assembly asm
)
Protected Overridable Function GetRowTypes (
    asm As Assembly
) As IEnumerable(Of Type)
Protected Overridable Function GetRowTypes (
    asm As Assembly
) As IEnumerable(Of Type)
protected:
virtual IEnumerable<Type^>^ GetRowTypes(
    Assembly^ asm
)
protected:
virtual IEnumerable<Type^>^ GetRowTypes(
    Assembly^ asm
)
abstract GetRowTypes :
        asm : Assembly -> IEnumerable<Type>
override GetRowTypes :
        asm : Assembly -> IEnumerable<Type>
abstract GetRowTypes :
        asm : Assembly -> IEnumerable<Type>
override GetRowTypes :
        asm : Assembly -> IEnumerable<Type>

Parameters

asm
Type: Online System.Reflection Assembly

Return Value

Type: Online IEnumerable Online Type
See Also
CodeGenerator Class
CodeGenerator Members
NFX.Serialization.Arow Namespace


CodeGenerator.WriteContent Method

CodeGenerator WriteContent Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void WriteContent(
    string ns,
    string name,
    StringBuilder content
)
protected virtual void WriteContent(
    string ns,
    string name,
    StringBuilder content
)
Protected Overridable Sub WriteContent (
    ns As String,
    name As String,
    content As StringBuilder
)
Protected Overridable Sub WriteContent (
    ns As String,
    name As String,
    content As StringBuilder
)
protected:
virtual void WriteContent(
    String^ ns,
    String^ name,
    StringBuilder^ content
)
protected:
virtual void WriteContent(
    String^ ns,
    String^ name,
    StringBuilder^ content
)
abstract WriteContent :
        ns : string *
        name : string *
        content : StringBuilder -> unit
override WriteContent :
        ns : string *
        name : string *
        content : StringBuilder -> unit
abstract WriteContent :
        ns : string *
        name : string *
        content : StringBuilder -> unit
override WriteContent :
        ns : string *
        name : string *
        content : StringBuilder -> unit

Parameters

ns
Type: Online System String
name
Type: Online System String
content
Type: Online System.Text StringBuilder
See Also
CodeGenerator Class
CodeGenerator Members
NFX.Serialization.Arow Namespace


CodeGenerator Properties

CodeGenerator Properties NFX Class Library

The CodeGenerator type exposes the following members.
Properties
 | Name | Description
Public property | CodeSegregation |
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | RootPath |
Back to Top
See Also
CodeGenerator Class
NFX.Serialization.Arow Namespace


CodeGenerator.CodeSegregation Property

CodeGenerator CodeSegregation Property NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public CodeGenerator..::..GeneratedCodeSegregation CodeSegregation { get; set; }
[ConfigAttribute]
public CodeGenerator..::..GeneratedCodeSegregation CodeSegregation { get; set; }
<ConfigAttribute>
Public Property CodeSegregation As CodeGenerator..::..GeneratedCodeSegregation
    Get
    Set
<ConfigAttribute>
Public Property CodeSegregation As CodeGenerator..::..GeneratedCodeSegregation
    Get
    Set
public:
[ConfigAttribute]
property CodeGenerator..::..GeneratedCodeSegregation CodeSegregation {
    CodeGenerator..::..GeneratedCodeSegregation get ();
    void set (CodeGenerator..::..GeneratedCodeSegregation value);
}
public:
[ConfigAttribute]
property CodeGenerator..::..GeneratedCodeSegregation CodeSegregation {
    CodeGenerator..::..GeneratedCodeSegregation get ();
    void set (CodeGenerator..::..GeneratedCodeSegregation value);
}
[<ConfigAttribute>]
member CodeSegregation : CodeGenerator..::..GeneratedCodeSegregation with get, set
[<ConfigAttribute>]
member CodeSegregation : CodeGenerator..::..GeneratedCodeSegregation with get, set

Property Value

Type: CodeGenerator GeneratedCodeSegregation
See Also
CodeGenerator Class
CodeGenerator Members
NFX.Serialization.Arow Namespace


CodeGenerator.RootPath Property

CodeGenerator RootPath Property NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string RootPath { get; set; }
[ConfigAttribute]
public string RootPath { get; set; }
<ConfigAttribute>
Public Property RootPath As String
    Get
    Set
<ConfigAttribute>
Public Property RootPath As String
    Get
    Set
public:
[ConfigAttribute]
property String^ RootPath {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute]
property String^ RootPath {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute>]
member RootPath : string with get, set
[<ConfigAttribute>]
member RootPath : string with get, set

Property Value

Type: Online String
See Also
CodeGenerator Class
CodeGenerator Members
NFX.Serialization.Arow Namespace


CodeGenerator.GeneratedCodeSegregation Enumeration

CodeGenerator GeneratedCodeSegregation Enumeration NFX Class Library

[This is preliminary documentation and is subject to change.]

Defines how generated files should be stored on disk

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum GeneratedCodeSegregation
public enum GeneratedCodeSegregation
Public Enumeration GeneratedCodeSegregation
Public Enumeration GeneratedCodeSegregation
public enum class GeneratedCodeSegregation
public enum class GeneratedCodeSegregation
type GeneratedCodeSegregation
type GeneratedCodeSegregation
Members
Member name | Value | Description
FilePerNamespace | 0 |
FilePerType | 1 |
AllInOne | 2 |
See Also
NFX.Serialization.Arow Namespace


DataType Enumeration

DataType Enumeration NFX Class Library

Denotes types that Arow directly supports. Complex object are serialized as POD

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum DataType
public enum DataType
Public Enumeration DataType
Public Enumeration DataType
public enum class DataType
public enum class DataType
type DataType
type DataType
Members
Member name | Value | Description
Null | 0 |
Row | 1 |
Array | 2 |
POD | 3 |
Boolean | 100 |
Char | 101 |
String | 102 |
Single | 103 |
Double | 104 |
Decimal | 105 |
Amount | 106 |
Byte | 107 |
ByteArray | 108 |
SByte | 109 |
Int16 | 110 |
Int32 | 111 |
Int64 | 112 |
UInt16 | 113 |
UInt32 | 114 |
UInt64 | 115 |
DateTime | 116 |
TimeSpan | 117 |
Guid | 118 |
GDID | 119 |
FID | 120 |
PilePointer | 121 |
NLSMap | 122 |
See Also
NFX.Serialization.Arow Namespace


ITypeSerializationCore Interface

ITypeSerializationCore Interface NFX Class Library

Designates classes that register their single instance via a call to ArowSerializer.Register(). These classes are generated by cl arow compiler

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ITypeSerializationCore
public interface ITypeSerializationCore
Public Interface ITypeSerializationCore
Public Interface ITypeSerializationCore
public interface class ITypeSerializationCore
public interface class ITypeSerializationCore
type ITypeSerializationCore =  interface end
type ITypeSerializationCore =  interface end
See Also
ITypeSerializationCore Members
NFX.Serialization.Arow Namespace


ITypeSerializationCore Members

ITypeSerializationCore Members NFX Class Library

The ITypeSerializationCore type exposes the following members.
Methods
 | Name | Description
Public method | Deserialize |
Public method | Register |
Public method | Serialize |
Back to Top
See Also
ITypeSerializationCore Interface
NFX.Serialization.Arow Namespace


ITypeSerializationCore Methods

ITypeSerializationCore Methods NFX Class Library

The ITypeSerializationCore type exposes the following members.
Methods
 | Name | Description
Public method | Deserialize |
Public method | Register |
Public method | Serialize |
Back to Top
See Also
ITypeSerializationCore Interface
NFX.Serialization.Arow Namespace


ITypeSerializationCore.Deserialize Method

ITypeSerializationCore Deserialize Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Deserialize(
    TypedRow row,
    ReadingStreamer streamer
)
void Deserialize(
    TypedRow row,
    ReadingStreamer streamer
)
Sub Deserialize (
    row As TypedRow,
    streamer As ReadingStreamer
)
Sub Deserialize (
    row As TypedRow,
    streamer As ReadingStreamer
)
void Deserialize(
    TypedRow^ row,
    ReadingStreamer^ streamer
)
void Deserialize(
    TypedRow^ row,
    ReadingStreamer^ streamer
)
abstract Deserialize :
        row : TypedRow *
        streamer : ReadingStreamer -> unit
abstract Deserialize :
        row : TypedRow *
        streamer : ReadingStreamer -> unit

Parameters

row
Type: NFX.DataAccess.CRUD TypedRow
streamer
Type: NFX.IO ReadingStreamer
See Also
ITypeSerializationCore Interface
ITypeSerializationCore Members
NFX.Serialization.Arow Namespace


ITypeSerializationCore.Register Method

ITypeSerializationCore Register Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Register()
void Register()
Sub Register
Sub Register
void Register()
void Register()
abstract Register : unit -> unit
abstract Register : unit -> unit
See Also
ITypeSerializationCore Interface
ITypeSerializationCore Members
NFX.Serialization.Arow Namespace


ITypeSerializationCore.Serialize Method

ITypeSerializationCore Serialize Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Serialize(
    TypedRow row,
    WritingStreamer streamer
)
void Serialize(
    TypedRow row,
    WritingStreamer streamer
)
Sub Serialize (
    row As TypedRow,
    streamer As WritingStreamer
)
Sub Serialize (
    row As TypedRow,
    streamer As WritingStreamer
)
void Serialize(
    TypedRow^ row,
    WritingStreamer^ streamer
)
void Serialize(
    TypedRow^ row,
    WritingStreamer^ streamer
)
abstract Serialize :
        row : TypedRow *
        streamer : WritingStreamer -> unit
abstract Serialize :
        row : TypedRow *
        streamer : WritingStreamer -> unit

Parameters

row
Type: NFX.DataAccess.CRUD TypedRow
streamer
Type: NFX.IO WritingStreamer
See Also
ITypeSerializationCore Interface
ITypeSerializationCore Members
NFX.Serialization.Arow Namespace


Reader Class

Reader Class NFX Class Library

Provides low-level Arow format reading
Inheritance Hierarchy
Online System Object
NFX.Serialization.Arow Reader

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class Reader
public static class Reader
Public NotInheritable Class Reader
Public NotInheritable Class Reader
public ref class Reader abstract sealed
public ref class Reader abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Reader =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Reader =  class end
See Also
Reader Members
NFX.Serialization.Arow Namespace


Reader Members

Reader Members NFX Class Library

The Reader type exposes the following members.
Methods
Name | Description
ConsumeUnmatched |
ReadAmount |
ReadArrayLength |
ReadBoolean |
ReadByte |
ReadByteArray |
ReadChar |
ReadDataType |
ReadDateTime |
ReadDecimal |
ReadDouble |
ReadFID |
ReadGDID |
ReadGuid |
ReadHeader |
ReadInt16 |
ReadInt32 |
ReadInt64 |
ReadName |
ReadNLSMap |
ReadPilePointer |
ReadRowArray TRow |
ReadRowList TRow |
ReadSByte |
ReadSingle |
ReadString |
ReadTimeSpan |
ReadUInt16 |
ReadUInt32 |
ReadUInt64 |
TryReadRow |
Back to Top
Fields
Name | Description
DESER_TYPE_MAP |
Back to Top
See Also
Reader Class
NFX.Serialization.Arow Namespace


Reader Fields

Reader Fields NFX Class Library

The Reader type exposes the following members.
Fields
Name | Description
DESER_TYPE_MAP |
Back to Top
See Also
Reader Class
NFX.Serialization.Arow Namespace


Reader.DESER_TYPE_MAP Field

Reader DESER_TYPE_MAP Field NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Dictionary<Type, string> DESER_TYPE_MAP
public static readonly Dictionary<Type, string> DESER_TYPE_MAP
Public Shared ReadOnly DESER_TYPE_MAP As Dictionary(Of Type, String)
Public Shared ReadOnly DESER_TYPE_MAP As Dictionary(Of Type, String)
public:
static initonly Dictionary<Type^, String^>^ DESER_TYPE_MAP
public:
static initonly Dictionary<Type^, String^>^ DESER_TYPE_MAP
static val DESER_TYPE_MAP: Dictionary<Type, string>
static val DESER_TYPE_MAP: Dictionary<Type, string>

Field Value

Type: Online Dictionary Online Type, Online String
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader Methods

Reader Methods NFX Class Library

The Reader type exposes the following members.
Methods
Name | Description
ConsumeUnmatched |
ReadAmount |
ReadArrayLength |
ReadBoolean |
ReadByte |
ReadByteArray |
ReadChar |
ReadDataType |
ReadDateTime |
ReadDecimal |
ReadDouble |
ReadFID |
ReadGDID |
ReadGuid |
ReadHeader |
ReadInt16 |
ReadInt32 |
ReadInt64 |
ReadName |
ReadNLSMap |
ReadPilePointer |
ReadRowArray TRow |
ReadRowList TRow |
ReadSByte |
ReadSingle |
ReadString |
ReadTimeSpan |
ReadUInt16 |
ReadUInt32 |
ReadUInt64 |
TryReadRow |
Back to Top
See Also
Reader Class
NFX.Serialization.Arow Namespace


Reader.ConsumeUnmatched Method

Reader ConsumeUnmatched Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Object ConsumeUnmatched(
    TypedRow row,
    ReadingStreamer streamer,
    string name,
    DataType dt,
    Nullable<DataType> atp
)
public static Object ConsumeUnmatched(
    TypedRow row,
    ReadingStreamer streamer,
    string name,
    DataType dt,
    Nullable<DataType> atp
)
Public Shared Function ConsumeUnmatched (
    row As TypedRow,
    streamer As ReadingStreamer,
    name As String,
    dt As DataType,
    atp As Nullable(Of DataType)
) As Object
Public Shared Function ConsumeUnmatched (
    row As TypedRow,
    streamer As ReadingStreamer,
    name As String,
    dt As DataType,
    atp As Nullable(Of DataType)
) As Object
public:
static Object^ ConsumeUnmatched(
    TypedRow^ row,
    ReadingStreamer^ streamer,
    String^ name,
    DataType dt,
    Nullable<DataType> atp
)
public:
static Object^ ConsumeUnmatched(
    TypedRow^ row,
    ReadingStreamer^ streamer,
    String^ name,
    DataType dt,
    Nullable<DataType> atp
)
static member ConsumeUnmatched :
        row : TypedRow *
        streamer : ReadingStreamer *
        name : string *
        dt : DataType *
        atp : Nullable<DataType> -> Object
static member ConsumeUnmatched :
        row : TypedRow *
        streamer : ReadingStreamer *
        name : string *
        dt : DataType *
        atp : Nullable<DataType> -> Object

Parameters

row
Type: NFX.DataAccess.CRUD TypedRow
streamer
Type: NFX.IO ReadingStreamer
name
Type: Online System String
dt
Type: NFX.Serialization.Arow DataType
atp
Type: Online System Nullable DataType

Return Value

Type: Online Object
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadAmount Method

Reader ReadAmount Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Amount ReadAmount(
    ReadingStreamer streamer
)
public static Amount ReadAmount(
    ReadingStreamer streamer
)
Public Shared Function ReadAmount (
    streamer As ReadingStreamer
) As Amount
Public Shared Function ReadAmount (
    streamer As ReadingStreamer
) As Amount
public:
static Amount ReadAmount(
    ReadingStreamer^ streamer
)
public:
static Amount ReadAmount(
    ReadingStreamer^ streamer
)
static member ReadAmount :
        streamer : ReadingStreamer -> Amount
static member ReadAmount :
        streamer : ReadingStreamer -> Amount

Parameters

streamer
Type: NFX.IO ReadingStreamer

Return Value

Type: Amount
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadArrayLength Method

Reader ReadArrayLength Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int ReadArrayLength(
    ReadingStreamer streamer
)
public static int ReadArrayLength(
    ReadingStreamer streamer
)
Public Shared Function ReadArrayLength (
    streamer As ReadingStreamer
) As Integer
Public Shared Function ReadArrayLength (
    streamer As ReadingStreamer
) As Integer
public:
static int ReadArrayLength(
    ReadingStreamer^ streamer
)
public:
static int ReadArrayLength(
    ReadingStreamer^ streamer
)
static member ReadArrayLength :
        streamer : ReadingStreamer -> int
static member ReadArrayLength :
        streamer : ReadingStreamer -> int

Parameters

streamer
Type: NFX.IO ReadingStreamer

Return Value

Type: Online Int32
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadBoolean Method

Reader ReadBoolean Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool ReadBoolean(
    ReadingStreamer streamer
)
public static bool ReadBoolean(
    ReadingStreamer streamer
)
Public Shared Function ReadBoolean (
    streamer As ReadingStreamer
) As Boolean
Public Shared Function ReadBoolean (
    streamer As ReadingStreamer
) As Boolean
public:
static bool ReadBoolean(
    ReadingStreamer^ streamer
)
public:
static bool ReadBoolean(
    ReadingStreamer^ streamer
)
static member ReadBoolean :
        streamer : ReadingStreamer -> bool
static member ReadBoolean :
        streamer : ReadingStreamer -> bool

Parameters

streamer
Type: NFX.IO ReadingStreamer

Return Value

Type: Online Boolean
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadByte Method

Reader ReadByte Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte ReadByte(
    ReadingStreamer streamer
)
public static byte ReadByte(
    ReadingStreamer streamer
)
Public Shared Function ReadByte (
    streamer As ReadingStreamer
) As Byte
Public Shared Function ReadByte (
    streamer As ReadingStreamer
) As Byte
public:
static unsigned char ReadByte(
    ReadingStreamer^ streamer
)
public:
static unsigned char ReadByte(
    ReadingStreamer^ streamer
)
static member ReadByte :
        streamer : ReadingStreamer -> byte
static member ReadByte :
        streamer : ReadingStreamer -> byte

Parameters

streamer
Type: NFX.IO ReadingStreamer

Return Value

Type: Online Byte
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadByteArray Method

Reader ReadByteArray Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte[] ReadByteArray(
    ReadingStreamer streamer
)
public static byte[] ReadByteArray(
    ReadingStreamer streamer
)
Public Shared Function ReadByteArray (
    streamer As ReadingStreamer
) As Byte()
Public Shared Function ReadByteArray (
    streamer As ReadingStreamer
) As Byte()
public:
static array<unsigned char>^ ReadByteArray(
    ReadingStreamer^ streamer
)
public:
static array<unsigned char>^ ReadByteArray(
    ReadingStreamer^ streamer
)
static member ReadByteArray :
        streamer : ReadingStreamer -> byte[]
static member ReadByteArray :
        streamer : ReadingStreamer -> byte[]

Parameters

streamer
Type: NFX.IO ReadingStreamer

Return Value

Type: Online Byte
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadChar Method

Reader ReadChar Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static char ReadChar(
    ReadingStreamer streamer
)
public static char ReadChar(
    ReadingStreamer streamer
)
Public Shared Function ReadChar (
    streamer As ReadingStreamer
) As Char
Public Shared Function ReadChar (
    streamer As ReadingStreamer
) As Char
public:
static wchar_t ReadChar(
    ReadingStreamer^ streamer
)
public:
static wchar_t ReadChar(
    ReadingStreamer^ streamer
)
static member ReadChar :
        streamer : ReadingStreamer -> char
static member ReadChar :
        streamer : ReadingStreamer -> char

Parameters

streamer
Type: NFX.IO ReadingStreamer

Return Value

Type: Online Char
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadDataType Method

Reader ReadDataType Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DataType ReadDataType(
    ReadingStreamer streamer
)
public static DataType ReadDataType(
    ReadingStreamer streamer
)
Public Shared Function ReadDataType (
    streamer As ReadingStreamer
) As DataType
Public Shared Function ReadDataType (
    streamer As ReadingStreamer
) As DataType
public:
static DataType ReadDataType(
    ReadingStreamer^ streamer
)
public:
static DataType ReadDataType(
    ReadingStreamer^ streamer
)
static member ReadDataType :
        streamer : ReadingStreamer -> DataType
static member ReadDataType :
        streamer : ReadingStreamer -> DataType

Parameters

streamer
Type: NFX.IO ReadingStreamer

Return Value

Type: DataType
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadDateTime Method

Reader ReadDateTime Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static DateTime ReadDateTime(
    ReadingStreamer streamer
)
public static DateTime ReadDateTime(
    ReadingStreamer streamer
)
Public Shared Function ReadDateTime (
    streamer As ReadingStreamer
) As DateTime
Public Shared Function ReadDateTime (
    streamer As ReadingStreamer
) As DateTime
public:
static DateTime ReadDateTime(
    ReadingStreamer^ streamer
)
public:
static DateTime ReadDateTime(
    ReadingStreamer^ streamer
)
static member ReadDateTime :
        streamer : ReadingStreamer -> DateTime
static member ReadDateTime :
        streamer : ReadingStreamer -> DateTime

Parameters

streamer
Type: NFX.IO ReadingStreamer

Return Value

Type: Online DateTime
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadDecimal Method

Reader ReadDecimal Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static decimal ReadDecimal(
    ReadingStreamer streamer
)
public static decimal ReadDecimal(
    ReadingStreamer streamer
)
Public Shared Function ReadDecimal (
    streamer As ReadingStreamer
) As Decimal
Public Shared Function ReadDecimal (
    streamer As ReadingStreamer
) As Decimal
public:
static Decimal ReadDecimal(
    ReadingStreamer^ streamer
)
public:
static Decimal ReadDecimal(
    ReadingStreamer^ streamer
)
static member ReadDecimal :
        streamer : ReadingStreamer -> decimal
static member ReadDecimal :
        streamer : ReadingStreamer -> decimal

Parameters

streamer
Type: NFX.IO ReadingStreamer

Return Value

Type: Online Decimal
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadDouble Method

Reader ReadDouble Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static double ReadDouble(
    ReadingStreamer streamer
)
public static double ReadDouble(
    ReadingStreamer streamer
)
Public Shared Function ReadDouble (
    streamer As ReadingStreamer
) As Double
Public Shared Function ReadDouble (
    streamer As ReadingStreamer
) As Double
public:
static double ReadDouble(
    ReadingStreamer^ streamer
)
public:
static double ReadDouble(
    ReadingStreamer^ streamer
)
static member ReadDouble :
        streamer : ReadingStreamer -> float
static member ReadDouble :
        streamer : ReadingStreamer -> float

Parameters

streamer
Type: NFX.IO ReadingStreamer

Return Value

Type: Online Double
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadFID Method

Reader ReadFID Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static FID ReadFID(
    ReadingStreamer streamer
)
public static FID ReadFID(
    ReadingStreamer streamer
)
Public Shared Function ReadFID (
    streamer As ReadingStreamer
) As FID
Public Shared Function ReadFID (
    streamer As ReadingStreamer
) As FID
public:
static FID ReadFID(
    ReadingStreamer^ streamer
)
public:
static FID ReadFID(
    ReadingStreamer^ streamer
)
static member ReadFID :
        streamer : ReadingStreamer -> FID
static member ReadFID :
        streamer : ReadingStreamer -> FID

Parameters

streamer
Type: NFX.IO ReadingStreamer

Return Value

Type: FID
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadGDID Method

Reader ReadGDID Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static GDID ReadGDID(
    ReadingStreamer streamer
)
public static GDID ReadGDID(
    ReadingStreamer streamer
)
Public Shared Function ReadGDID (
    streamer As ReadingStreamer
) As GDID
Public Shared Function ReadGDID (
    streamer As ReadingStreamer
) As GDID
public:
static GDID ReadGDID(
    ReadingStreamer^ streamer
)
public:
static GDID ReadGDID(
    ReadingStreamer^ streamer
)
static member ReadGDID :
        streamer : ReadingStreamer -> GDID
static member ReadGDID :
        streamer : ReadingStreamer -> GDID

Parameters

streamer
Type: NFX.IO ReadingStreamer

Return Value

Type: GDID
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadGuid Method

Reader ReadGuid Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Guid ReadGuid(
    ReadingStreamer streamer
)
public static Guid ReadGuid(
    ReadingStreamer streamer
)
Public Shared Function ReadGuid (
    streamer As ReadingStreamer
) As Guid
Public Shared Function ReadGuid (
    streamer As ReadingStreamer
) As Guid
public:
static Guid ReadGuid(
    ReadingStreamer^ streamer
)
public:
static Guid ReadGuid(
    ReadingStreamer^ streamer
)
static member ReadGuid :
        streamer : ReadingStreamer -> Guid
static member ReadGuid :
        streamer : ReadingStreamer -> Guid

Parameters

streamer
Type: NFX.IO ReadingStreamer

Return Value

Type: Online Guid
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadHeader Method

Reader ReadHeader Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ReadHeader(
    ReadingStreamer streamer
)
public static void ReadHeader(
    ReadingStreamer streamer
)
Public Shared Sub ReadHeader (
    streamer As ReadingStreamer
)
Public Shared Sub ReadHeader (
    streamer As ReadingStreamer
)
public:
static void ReadHeader(
    ReadingStreamer^ streamer
)
public:
static void ReadHeader(
    ReadingStreamer^ streamer
)
static member ReadHeader :
        streamer : ReadingStreamer -> unit
static member ReadHeader :
        streamer : ReadingStreamer -> unit

Parameters

streamer
Type: NFX.IO ReadingStreamer
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadInt16 Method

Reader ReadInt16 Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static short ReadInt16(
    ReadingStreamer streamer
)
public static short ReadInt16(
    ReadingStreamer streamer
)
Public Shared Function ReadInt16 (
    streamer As ReadingStreamer
) As Short
Public Shared Function ReadInt16 (
    streamer As ReadingStreamer
) As Short
public:
static short ReadInt16(
    ReadingStreamer^ streamer
)
public:
static short ReadInt16(
    ReadingStreamer^ streamer
)
static member ReadInt16 :
        streamer : ReadingStreamer -> int16
static member ReadInt16 :
        streamer : ReadingStreamer -> int16

Parameters

streamer
Type: NFX.IO ReadingStreamer

Return Value

Type: Online Int16
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadInt32 Method

Reader ReadInt32 Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int ReadInt32(
    ReadingStreamer streamer
)
public static int ReadInt32(
    ReadingStreamer streamer
)
Public Shared Function ReadInt32 (
    streamer As ReadingStreamer
) As Integer
Public Shared Function ReadInt32 (
    streamer As ReadingStreamer
) As Integer
public:
static int ReadInt32(
    ReadingStreamer^ streamer
)
public:
static int ReadInt32(
    ReadingStreamer^ streamer
)
static member ReadInt32 :
        streamer : ReadingStreamer -> int
static member ReadInt32 :
        streamer : ReadingStreamer -> int

Parameters

streamer
Type: NFX.IO ReadingStreamer

Return Value

Type: Online Int32
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadInt64 Method

Reader ReadInt64 Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long ReadInt64(
    ReadingStreamer streamer
)
public static long ReadInt64(
    ReadingStreamer streamer
)
Public Shared Function ReadInt64 (
    streamer As ReadingStreamer
) As Long
Public Shared Function ReadInt64 (
    streamer As ReadingStreamer
) As Long
public:
static long long ReadInt64(
    ReadingStreamer^ streamer
)
public:
static long long ReadInt64(
    ReadingStreamer^ streamer
)
static member ReadInt64 :
        streamer : ReadingStreamer -> int64
static member ReadInt64 :
        streamer : ReadingStreamer -> int64

Parameters

streamer
Type: NFX.IO ReadingStreamer

Return Value

Type: Online Int64
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadName Method

Reader ReadName Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ulong ReadName(
    ReadingStreamer streamer
)
public static ulong ReadName(
    ReadingStreamer streamer
)
Public Shared Function ReadName (
    streamer As ReadingStreamer
) As ULong
Public Shared Function ReadName (
    streamer As ReadingStreamer
) As ULong
public:
static unsigned long long ReadName(
    ReadingStreamer^ streamer
)
public:
static unsigned long long ReadName(
    ReadingStreamer^ streamer
)
static member ReadName :
        streamer : ReadingStreamer -> uint64
static member ReadName :
        streamer : ReadingStreamer -> uint64

Parameters

streamer
Type: NFX.IO ReadingStreamer

Return Value

Type: Online UInt64
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadNLSMap Method

Reader ReadNLSMap Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static NLSMap ReadNLSMap(
    ReadingStreamer streamer
)
public static NLSMap ReadNLSMap(
    ReadingStreamer streamer
)
Public Shared Function ReadNLSMap (
    streamer As ReadingStreamer
) As NLSMap
Public Shared Function ReadNLSMap (
    streamer As ReadingStreamer
) As NLSMap
public:
static NLSMap ReadNLSMap(
    ReadingStreamer^ streamer
)
public:
static NLSMap ReadNLSMap(
    ReadingStreamer^ streamer
)
static member ReadNLSMap :
        streamer : ReadingStreamer -> NLSMap
static member ReadNLSMap :
        streamer : ReadingStreamer -> NLSMap

Parameters

streamer
Type: NFX.IO ReadingStreamer

Return Value

Type: NLSMap
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadPilePointer Method

Reader ReadPilePointer Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static PilePointer ReadPilePointer(
    ReadingStreamer streamer
)
public static PilePointer ReadPilePointer(
    ReadingStreamer streamer
)
Public Shared Function ReadPilePointer (
    streamer As ReadingStreamer
) As PilePointer
Public Shared Function ReadPilePointer (
    streamer As ReadingStreamer
) As PilePointer
public:
static PilePointer ReadPilePointer(
    ReadingStreamer^ streamer
)
public:
static PilePointer ReadPilePointer(
    ReadingStreamer^ streamer
)
static member ReadPilePointer :
        streamer : ReadingStreamer -> PilePointer
static member ReadPilePointer :
        streamer : ReadingStreamer -> PilePointer

Parameters

streamer
Type: NFX.IO ReadingStreamer

Return Value

Type: PilePointer
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadRowArray(TRow) Method

Reader ReadRowArray TRow Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TRow[] ReadRowArray<TRow>(
    TypedRow rowScope,
    ReadingStreamer streamer,
    string name
)
where TRow : new(), TypedRow
public static TRow[] ReadRowArray<TRow>(
    TypedRow rowScope,
    ReadingStreamer streamer,
    string name
)
where TRow : new(), TypedRow
Public Shared Function ReadRowArray(Of TRow As {New, TypedRow}) (
    rowScope As TypedRow,
    streamer As ReadingStreamer,
    name As String
) As TRow()
Public Shared Function ReadRowArray(Of TRow As {New, TypedRow}) (
    rowScope As TypedRow,
    streamer As ReadingStreamer,
    name As String
) As TRow()
public:
generic<typename TRow>
where TRow : gcnew(), TypedRow
static array<TRow>^ ReadRowArray(
    TypedRow^ rowScope,
    ReadingStreamer^ streamer,
    String^ name
)
public:
generic<typename TRow>
where TRow : gcnew(), TypedRow
static array<TRow>^ ReadRowArray(
    TypedRow^ rowScope,
    ReadingStreamer^ streamer,
    String^ name
)
static member ReadRowArray :
        rowScope : TypedRow *
        streamer : ReadingStreamer *
        name : string -> 'TRow[]  when 'TRow : new() and TypedRow
static member ReadRowArray :
        rowScope : TypedRow *
        streamer : ReadingStreamer *
        name : string -> 'TRow[]  when 'TRow : new() and TypedRow

Parameters

rowScope
Type: NFX.DataAccess.CRUD TypedRow
streamer
Type: NFX.IO ReadingStreamer
name
Type: Online System String
Type Parameters
TRow

Return Value

Type: TRow
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadRowList(TRow) Method

Reader ReadRowList TRow Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static List<TRow> ReadRowList<TRow>(
    TypedRow rowScope,
    ReadingStreamer streamer,
    string name
)
where TRow : new(), TypedRow
public static List<TRow> ReadRowList<TRow>(
    TypedRow rowScope,
    ReadingStreamer streamer,
    string name
)
where TRow : new(), TypedRow
Public Shared Function ReadRowList(Of TRow As {New, TypedRow}) (
    rowScope As TypedRow,
    streamer As ReadingStreamer,
    name As String
) As List(Of TRow)
Public Shared Function ReadRowList(Of TRow As {New, TypedRow}) (
    rowScope As TypedRow,
    streamer As ReadingStreamer,
    name As String
) As List(Of TRow)
public:
generic<typename TRow>
where TRow : gcnew(), TypedRow
static List<TRow>^ ReadRowList(
    TypedRow^ rowScope,
    ReadingStreamer^ streamer,
    String^ name
)
public:
generic<typename TRow>
where TRow : gcnew(), TypedRow
static List<TRow>^ ReadRowList(
    TypedRow^ rowScope,
    ReadingStreamer^ streamer,
    String^ name
)
static member ReadRowList :
        rowScope : TypedRow *
        streamer : ReadingStreamer *
        name : string -> List<'TRow>  when 'TRow : new() and TypedRow
static member ReadRowList :
        rowScope : TypedRow *
        streamer : ReadingStreamer *
        name : string -> List<'TRow>  when 'TRow : new() and TypedRow

Parameters

rowScope
Type: NFX.DataAccess.CRUD TypedRow
streamer
Type: NFX.IO ReadingStreamer
name
Type: Online System String
Type Parameters
TRow

Return Value

Type: Online List TRow
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadSByte Method

Reader ReadSByte Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static sbyte ReadSByte(
    ReadingStreamer streamer
)
public static sbyte ReadSByte(
    ReadingStreamer streamer
)
Public Shared Function ReadSByte (
    streamer As ReadingStreamer
) As SByte
Public Shared Function ReadSByte (
    streamer As ReadingStreamer
) As SByte
public:
static signed char ReadSByte(
    ReadingStreamer^ streamer
)
public:
static signed char ReadSByte(
    ReadingStreamer^ streamer
)
static member ReadSByte :
        streamer : ReadingStreamer -> sbyte
static member ReadSByte :
        streamer : ReadingStreamer -> sbyte

Parameters

streamer
Type: NFX.IO ReadingStreamer

Return Value

Type: Online SByte
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadSingle Method

Reader ReadSingle Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static float ReadSingle(
    ReadingStreamer streamer
)
public static float ReadSingle(
    ReadingStreamer streamer
)
Public Shared Function ReadSingle (
    streamer As ReadingStreamer
) As Single
Public Shared Function ReadSingle (
    streamer As ReadingStreamer
) As Single
public:
static float ReadSingle(
    ReadingStreamer^ streamer
)
public:
static float ReadSingle(
    ReadingStreamer^ streamer
)
static member ReadSingle :
        streamer : ReadingStreamer -> float32
static member ReadSingle :
        streamer : ReadingStreamer -> float32

Parameters

streamer
Type: NFX.IO ReadingStreamer

Return Value

Type: Online Single
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadString Method

Reader ReadString Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ReadString(
    ReadingStreamer streamer
)
public static string ReadString(
    ReadingStreamer streamer
)
Public Shared Function ReadString (
    streamer As ReadingStreamer
) As String
Public Shared Function ReadString (
    streamer As ReadingStreamer
) As String
public:
static String^ ReadString(
    ReadingStreamer^ streamer
)
public:
static String^ ReadString(
    ReadingStreamer^ streamer
)
static member ReadString :
        streamer : ReadingStreamer -> string
static member ReadString :
        streamer : ReadingStreamer -> string

Parameters

streamer
Type: NFX.IO ReadingStreamer

Return Value

Type: Online String
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadTimeSpan Method

Reader ReadTimeSpan Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TimeSpan ReadTimeSpan(
    ReadingStreamer streamer
)
public static TimeSpan ReadTimeSpan(
    ReadingStreamer streamer
)
Public Shared Function ReadTimeSpan (
    streamer As ReadingStreamer
) As TimeSpan
Public Shared Function ReadTimeSpan (
    streamer As ReadingStreamer
) As TimeSpan
public:
static TimeSpan ReadTimeSpan(
    ReadingStreamer^ streamer
)
public:
static TimeSpan ReadTimeSpan(
    ReadingStreamer^ streamer
)
static member ReadTimeSpan :
        streamer : ReadingStreamer -> TimeSpan
static member ReadTimeSpan :
        streamer : ReadingStreamer -> TimeSpan

Parameters

streamer
Type: NFX.IO ReadingStreamer

Return Value

Type: Online TimeSpan
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadUInt16 Method

Reader ReadUInt16 Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ushort ReadUInt16(
    ReadingStreamer streamer
)
public static ushort ReadUInt16(
    ReadingStreamer streamer
)
Public Shared Function ReadUInt16 (
    streamer As ReadingStreamer
) As UShort
Public Shared Function ReadUInt16 (
    streamer As ReadingStreamer
) As UShort
public:
static unsigned short ReadUInt16(
    ReadingStreamer^ streamer
)
public:
static unsigned short ReadUInt16(
    ReadingStreamer^ streamer
)
static member ReadUInt16 :
        streamer : ReadingStreamer -> uint16
static member ReadUInt16 :
        streamer : ReadingStreamer -> uint16

Parameters

streamer
Type: NFX.IO ReadingStreamer

Return Value

Type: Online UInt16
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadUInt32 Method

Reader ReadUInt32 Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static uint ReadUInt32(
    ReadingStreamer streamer
)
public static uint ReadUInt32(
    ReadingStreamer streamer
)
Public Shared Function ReadUInt32 (
    streamer As ReadingStreamer
) As UInteger
Public Shared Function ReadUInt32 (
    streamer As ReadingStreamer
) As UInteger
public:
static unsigned int ReadUInt32(
    ReadingStreamer^ streamer
)
public:
static unsigned int ReadUInt32(
    ReadingStreamer^ streamer
)
static member ReadUInt32 :
        streamer : ReadingStreamer -> uint32
static member ReadUInt32 :
        streamer : ReadingStreamer -> uint32

Parameters

streamer
Type: NFX.IO ReadingStreamer

Return Value

Type: Online UInt32
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.ReadUInt64 Method

Reader ReadUInt64 Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ulong ReadUInt64(
    ReadingStreamer streamer
)
public static ulong ReadUInt64(
    ReadingStreamer streamer
)
Public Shared Function ReadUInt64 (
    streamer As ReadingStreamer
) As ULong
Public Shared Function ReadUInt64 (
    streamer As ReadingStreamer
) As ULong
public:
static unsigned long long ReadUInt64(
    ReadingStreamer^ streamer
)
public:
static unsigned long long ReadUInt64(
    ReadingStreamer^ streamer
)
static member ReadUInt64 :
        streamer : ReadingStreamer -> uint64
static member ReadUInt64 :
        streamer : ReadingStreamer -> uint64

Parameters

streamer
Type: NFX.IO ReadingStreamer

Return Value

Type: Online UInt64
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Reader.TryReadRow Method

Reader TryReadRow Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool TryReadRow(
    TypedRow rowScope,
    TypedRow newRow,
    ReadingStreamer streamer,
    string name
)
public static bool TryReadRow(
    TypedRow rowScope,
    TypedRow newRow,
    ReadingStreamer streamer,
    string name
)
Public Shared Function TryReadRow (
    rowScope As TypedRow,
    newRow As TypedRow,
    streamer As ReadingStreamer,
    name As String
) As Boolean
Public Shared Function TryReadRow (
    rowScope As TypedRow,
    newRow As TypedRow,
    streamer As ReadingStreamer,
    name As String
) As Boolean
public:
static bool TryReadRow(
    TypedRow^ rowScope,
    TypedRow^ newRow,
    ReadingStreamer^ streamer,
    String^ name
)
public:
static bool TryReadRow(
    TypedRow^ rowScope,
    TypedRow^ newRow,
    ReadingStreamer^ streamer,
    String^ name
)
static member TryReadRow :
        rowScope : TypedRow *
        newRow : TypedRow *
        streamer : ReadingStreamer *
        name : string -> bool
static member TryReadRow :
        rowScope : TypedRow *
        newRow : TypedRow *
        streamer : ReadingStreamer *
        name : string -> bool

Parameters

rowScope
Type: NFX.DataAccess.CRUD TypedRow
newRow
Type: NFX.DataAccess.CRUD TypedRow
streamer
Type: NFX.IO ReadingStreamer
name
Type: Online System String

Return Value

Type: Online Boolean
See Also
Reader Class
Reader Members
NFX.Serialization.Arow Namespace


Writer Class

Writer Class NFX Class Library

Provides low-level Arow format writing
Inheritance Hierarchy
Online System Object
NFX.Serialization.Arow Writer

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class Writer
public static class Writer
Public NotInheritable Class Writer
Public NotInheritable Class Writer
public ref class Writer abstract sealed
public ref class Writer abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Writer =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Writer =  class end
See Also
Writer Members
NFX.Serialization.Arow Namespace


Writer Members

Writer Members NFX Class Library

The Writer type exposes the following members.
Methods
Name | Description
Write(WritingStreamer, UInt64, PilePointer) |
Write(WritingStreamer, UInt64, GDID) |
Write(WritingStreamer, UInt64, FID) |
Write(WritingStreamer, UInt64, Amount) |
Write(WritingStreamer, UInt64, NLSMap) |
Write(WritingStreamer, UInt64, Boolean) |
Write(WritingStreamer, UInt64, Byte) |
Write(WritingStreamer, UInt64, Byte ) |
Write(WritingStreamer, UInt64, Char) |
Write(WritingStreamer, UInt64, IEnumerable PilePointer ) |
Write(WritingStreamer, UInt64, IEnumerable GDID ) |
Write(WritingStreamer, UInt64, IEnumerable FID ) |
Write(WritingStreamer, UInt64, IEnumerable Amount ) |
Write(WritingStreamer, UInt64, IEnumerable NLSMap ) |
Write(WritingStreamer, UInt64, IEnumerable Boolean ) |
Write(WritingStreamer, UInt64, IEnumerable Byte ) |
Write(WritingStreamer, UInt64, IEnumerable Char ) |
Write(WritingStreamer, UInt64, IEnumerable DateTime ) |
Write(WritingStreamer, UInt64, IEnumerable Decimal ) |
Write(WritingStreamer, UInt64, IEnumerable Double ) |
Write(WritingStreamer, UInt64, IEnumerable Guid ) |
Write(WritingStreamer, UInt64, IEnumerable Int16 ) |
Write(WritingStreamer, UInt64, IEnumerable Int32 ) |
Write(WritingStreamer, UInt64, IEnumerable Int64 ) |
Write(WritingStreamer, UInt64, IEnumerable SByte ) |
Write(WritingStreamer, UInt64, IEnumerable Single ) |
Write(WritingStreamer, UInt64, IEnumerable String ) |
Write(WritingStreamer, UInt64, IEnumerable TimeSpan ) |
Write(WritingStreamer, UInt64, IEnumerable UInt16 ) |
Write(WritingStreamer, UInt64, IEnumerable UInt32 ) |
Write(WritingStreamer, UInt64, IEnumerable UInt64 ) |
Write(WritingStreamer, UInt64, DateTime) |
Write(WritingStreamer, UInt64, Decimal) |
Write(WritingStreamer, UInt64, Double) |
Write(WritingStreamer, UInt64, Guid) |
Write(WritingStreamer, UInt64, Int16) |
Write(WritingStreamer, UInt64, Int32) |
Write(WritingStreamer, UInt64, Int64) |
Write(WritingStreamer, UInt64, SByte) |
Write(WritingStreamer, UInt64, Single) |
Write(WritingStreamer, UInt64, String) |
Write(WritingStreamer, UInt64, TimeSpan) |
Write(WritingStreamer, UInt64, UInt16) |
Write(WritingStreamer, UInt64, UInt32) |
Write(WritingStreamer, UInt64, UInt64) |
WriteEORow |
WriteHeader |
WriteNull |
WriteObject |
WriteObjectArray |
WriteRow |
WriteRowArray |
Back to Top
Fields
Name | Description
MAX_ARRAY_LENGTH |
SER_TYPE_MAP |
Back to Top
See Also
Writer Class
NFX.Serialization.Arow Namespace


Writer Fields

Writer Fields NFX Class Library

The Writer type exposes the following members.
Fields
Name | Description
MAX_ARRAY_LENGTH |
SER_TYPE_MAP |
Back to Top
See Also
Writer Class
NFX.Serialization.Arow Namespace


Writer.MAX_ARRAY_LENGTH Field

Writer MAX_ARRAY_LENGTH Field NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_ARRAY_LENGTH
public const int MAX_ARRAY_LENGTH
Public Const MAX_ARRAY_LENGTH As Integer
Public Const MAX_ARRAY_LENGTH As Integer
public:
literal int MAX_ARRAY_LENGTH
public:
literal int MAX_ARRAY_LENGTH
static val mutable MAX_ARRAY_LENGTH: int
static val mutable MAX_ARRAY_LENGTH: int

Field Value

Type: Online Int32
See Also
Writer Class
Writer Members
NFX.Serialization.Arow Namespace


Writer.SER_TYPE_MAP Field

Writer SER_TYPE_MAP Field NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly Dictionary<Type, string> SER_TYPE_MAP
public static readonly Dictionary<Type, string> SER_TYPE_MAP
Public Shared ReadOnly SER_TYPE_MAP As Dictionary(Of Type, String)
Public Shared ReadOnly SER_TYPE_MAP As Dictionary(Of Type, String)
public:
static initonly Dictionary<Type^, String^>^ SER_TYPE_MAP
public:
static initonly Dictionary<Type^, String^>^ SER_TYPE_MAP
static val SER_TYPE_MAP: Dictionary<Type, string>
static val SER_TYPE_MAP: Dictionary<Type, string>

Field Value

Type: Online Dictionary Online Type, Online String
See Also
Writer Class
Writer Members
NFX.Serialization.Arow Namespace


Writer Methods

Writer Methods NFX Class Library

The Writer type exposes the following members.
Methods
Name | Description
Write(WritingStreamer, UInt64, PilePointer) |
Write(WritingStreamer, UInt64, GDID) |
Write(WritingStreamer, UInt64, FID) |
Write(WritingStreamer, UInt64, Amount) |
Write(WritingStreamer, UInt64, NLSMap) |
Write(WritingStreamer, UInt64, Boolean) |
Write(WritingStreamer, UInt64, Byte) |
Write(WritingStreamer, UInt64, Byte ) |
Write(WritingStreamer, UInt64, Char) |
Write(WritingStreamer, UInt64, IEnumerable PilePointer ) |
Write(WritingStreamer, UInt64, IEnumerable GDID ) |
Write(WritingStreamer, UInt64, IEnumerable FID ) |
Write(WritingStreamer, UInt64, IEnumerable Amount ) |
Write(WritingStreamer, UInt64, IEnumerable NLSMap ) |
Write(WritingStreamer, UInt64, IEnumerable Boolean ) |
Write(WritingStreamer, UInt64, IEnumerable Byte ) |
Write(WritingStreamer, UInt64, IEnumerable Char ) |
Write(WritingStreamer, UInt64, IEnumerable DateTime ) |
Write(WritingStreamer, UInt64, IEnumerable Decimal ) |
Write(WritingStreamer, UInt64, IEnumerable Double ) |
Write(WritingStreamer, UInt64, IEnumerable Guid ) |
Write(WritingStreamer, UInt64, IEnumerable Int16 ) |
Write(WritingStreamer, UInt64, IEnumerable Int32 ) |
Write(WritingStreamer, UInt64, IEnumerable Int64 ) |
Write(WritingStreamer, UInt64, IEnumerable SByte ) |
Write(WritingStreamer, UInt64, IEnumerable Single ) |
Write(WritingStreamer, UInt64, IEnumerable String ) |
Write(WritingStreamer, UInt64, IEnumerable TimeSpan ) |
Write(WritingStreamer, UInt64, IEnumerable UInt16 ) |
Write(WritingStreamer, UInt64, IEnumerable UInt32 ) |
Write(WritingStreamer, UInt64, IEnumerable UInt64 ) |
Write(WritingStreamer, UInt64, DateTime) |
Write(WritingStreamer, UInt64, Decimal) |
Write(WritingStreamer, UInt64, Double) |
Write(WritingStreamer, UInt64, Guid) |
Write(WritingStreamer, UInt64, Int16) |
Write(WritingStreamer, UInt64, Int32) |
Write(WritingStreamer, UInt64, Int64) |
Write(WritingStreamer, UInt64, SByte) |
Write(WritingStreamer, UInt64, Single) |
Write(WritingStreamer, UInt64, String) |
Write(WritingStreamer, UInt64, TimeSpan) |
Write(WritingStreamer, UInt64, UInt16) |
Write(WritingStreamer, UInt64, UInt32) |
Write(WritingStreamer, UInt64, UInt64) |
WriteEORow |
WriteHeader |
WriteNull |
WriteObject |
WriteObjectArray |
WriteRow |
WriteRowArray |
Back to Top
See Also
Writer Class
NFX.Serialization.Arow Namespace


Writer.Write Method

Writer Write Method NFX Class Library

Overload List
Name | Description
Write(WritingStreamer, UInt64, PilePointer) |
Write(WritingStreamer, UInt64, GDID) |
Write(WritingStreamer, UInt64, FID) |
Write(WritingStreamer, UInt64, Amount) |
Write(WritingStreamer, UInt64, NLSMap) |
Write(WritingStreamer, UInt64, Boolean) |
Write(WritingStreamer, UInt64, Byte) |
Write(WritingStreamer, UInt64, Byte ) |
Write(WritingStreamer, UInt64, Char) |
Write(WritingStreamer, UInt64, IEnumerable PilePointer ) |
Write(WritingStreamer, UInt64, IEnumerable GDID ) |
Write(WritingStreamer, UInt64, IEnumerable FID ) |
Write(WritingStreamer, UInt64, IEnumerable Amount ) |
Write(WritingStreamer, UInt64, IEnumerable NLSMap ) |
Write(WritingStreamer, UInt64, IEnumerable Boolean ) |
Write(WritingStreamer, UInt64, IEnumerable Byte ) |
Write(WritingStreamer, UInt64, IEnumerable Char ) |
Write(WritingStreamer, UInt64, IEnumerable DateTime ) |
Write(WritingStreamer, UInt64, IEnumerable Decimal ) |
Write(WritingStreamer, UInt64, IEnumerable Double ) |
Write(WritingStreamer, UInt64, IEnumerable Guid ) |
Write(WritingStreamer, UInt64, IEnumerable Int16 ) |
Write(WritingStreamer, UInt64, IEnumerable Int32 ) |
Write(WritingStreamer, UInt64, IEnumerable Int64 ) |
Write(WritingStreamer, UInt64, IEnumerable SByte ) |
Write(WritingStreamer, UInt64, IEnumerable Single ) |
Write(WritingStreamer, UInt64, IEnumerable String ) |
Write(WritingStreamer, UInt64, IEnumerable TimeSpan ) |
Write(WritingStreamer, UInt64, IEnumerable UInt16 ) |
Write(WritingStreamer, UInt64, IEnumerable UInt32 ) |
Write(WritingStreamer, UInt64, IEnumerable UInt64 ) |
Write(WritingStreamer, UInt64, DateTime) |
Write(WritingStreamer, UInt64, Decimal) |
Write(WritingStreamer, UInt64, Double) |
Write(WritingStreamer, UInt64, Guid) |
Write(WritingStreamer, UInt64, Int16) |
Write(WritingStreamer, UInt64, Int32) |
Write(WritingStreamer, UInt64, Int64) |
Write(WritingStreamer, UInt64, SByte) |
Write(WritingStreamer, UInt64, Single) |
Write(WritingStreamer, UInt64, String) |
Write(WritingStreamer, UInt64, TimeSpan) |
Write(WritingStreamer, UInt64, UInt16) |
Write(WritingStreamer, UInt64, UInt32) |
Write(WritingStreamer, UInt64, UInt64) |
Back to Top
See Also
Writer Class
Writer Members
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, PilePointer)

Writer Write Method (WritingStreamer, UInt64, PilePointer) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    PilePointer value
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    PilePointer value
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As PilePointer
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As PilePointer
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    PilePointer value
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    PilePointer value
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : PilePointer -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : PilePointer -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
value
Type: NFX.ApplicationModel.Pile PilePointer
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, GDID)

Writer Write Method (WritingStreamer, UInt64, GDID) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    GDID value
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    GDID value
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As GDID
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As GDID
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    GDID value
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    GDID value
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : GDID -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : GDID -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
value
Type: NFX.DataAccess.Distributed GDID
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, FID)

Writer Write Method (WritingStreamer, UInt64, FID) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    FID value
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    FID value
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As FID
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As FID
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    FID value
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    FID value
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : FID -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : FID -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
value
Type: NFX FID
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, Amount)

Writer Write Method (WritingStreamer, UInt64, Amount) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    Amount value
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    Amount value
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As Amount
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As Amount
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    Amount value
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    Amount value
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : Amount -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : Amount -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
value
Type: NFX.Financial Amount
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, NLSMap)

Writer Write Method (WritingStreamer, UInt64, NLSMap) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    NLSMap value
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    NLSMap value
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As NLSMap
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As NLSMap
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    NLSMap value
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    NLSMap value
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : NLSMap -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : NLSMap -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
value
Type: NFX.Serialization.JSON NLSMap
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, Boolean)

Writer Write Method (WritingStreamer, UInt64, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    bool value
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    bool value
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As Boolean
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As Boolean
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    bool value
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    bool value
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : bool -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : bool -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
value
Type: Online System Boolean
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, Byte)

Writer Write Method (WritingStreamer, UInt64, Byte) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    byte value
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    byte value
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As Byte
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As Byte
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    unsigned char value
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    unsigned char value
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : byte -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : byte -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
value
Type: Online System Byte
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, Byte[])

Writer Write Method (WritingStreamer, UInt64, Byte ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    byte[] value
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    byte[] value
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As Byte()
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As Byte()
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    array<unsigned char>^ value
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    array<unsigned char>^ value
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : byte[] -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : byte[] -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
value
Type: Online System Byte
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, Char)

Writer Write Method (WritingStreamer, UInt64, Char) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    char value
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    char value
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As Char
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As Char
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    wchar_t value
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    wchar_t value
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : char -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : char -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
value
Type: Online System Char
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, IEnumerable(PilePointer))

Writer Write Method (WritingStreamer, UInt64, IEnumerable PilePointer ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<PilePointer> array
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<PilePointer> array
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of PilePointer)
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of PilePointer)
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<PilePointer>^ array
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<PilePointer>^ array
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<PilePointer> -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<PilePointer> -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
array
Type: Online System.Collections.Generic IEnumerable PilePointer
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, IEnumerable(GDID))

Writer Write Method (WritingStreamer, UInt64, IEnumerable GDID ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<GDID> array
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<GDID> array
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of GDID)
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of GDID)
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<GDID>^ array
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<GDID>^ array
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<GDID> -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<GDID> -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
array
Type: Online System.Collections.Generic IEnumerable GDID
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, IEnumerable(FID))

Writer Write Method (WritingStreamer, UInt64, IEnumerable FID ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<FID> array
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<FID> array
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of FID)
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of FID)
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<FID>^ array
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<FID>^ array
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<FID> -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<FID> -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
array
Type: Online System.Collections.Generic IEnumerable FID
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, IEnumerable(Amount))

Writer Write Method (WritingStreamer, UInt64, IEnumerable Amount ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<Amount> array
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<Amount> array
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of Amount)
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of Amount)
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<Amount>^ array
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<Amount>^ array
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<Amount> -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<Amount> -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
array
Type: Online System.Collections.Generic IEnumerable Amount
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, IEnumerable(NLSMap))

Writer Write Method (WritingStreamer, UInt64, IEnumerable NLSMap ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<NLSMap> array
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<NLSMap> array
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of NLSMap)
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of NLSMap)
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<NLSMap>^ array
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<NLSMap>^ array
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<NLSMap> -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<NLSMap> -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
array
Type: Online System.Collections.Generic IEnumerable NLSMap
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, IEnumerable(Boolean))

Writer Write Method (WritingStreamer, UInt64, IEnumerable Boolean ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<bool> array
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<bool> array
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of Boolean)
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of Boolean)
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<bool>^ array
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<bool>^ array
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<bool> -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<bool> -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
array
Type: Online System.Collections.Generic IEnumerable Online Boolean
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, IEnumerable(Byte))

Writer Write Method (WritingStreamer, UInt64, IEnumerable Byte ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<byte> array
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<byte> array
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of Byte)
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of Byte)
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<unsigned char>^ array
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<unsigned char>^ array
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<byte> -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<byte> -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
array
Type: Online System.Collections.Generic IEnumerable Online Byte
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, IEnumerable(Char))

Writer Write Method (WritingStreamer, UInt64, IEnumerable Char ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<char> array
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<char> array
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of Char)
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of Char)
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<wchar_t>^ array
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<wchar_t>^ array
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<char> -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<char> -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
array
Type: Online System.Collections.Generic IEnumerable Online Char
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, IEnumerable(DateTime))

Writer Write Method (WritingStreamer, UInt64, IEnumerable DateTime ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<DateTime> array
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<DateTime> array
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of DateTime)
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of DateTime)
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<DateTime>^ array
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<DateTime>^ array
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<DateTime> -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<DateTime> -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
array
Type: Online System.Collections.Generic IEnumerable Online DateTime
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, IEnumerable(Decimal))

Writer Write Method (WritingStreamer, UInt64, IEnumerable Decimal ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<decimal> array
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<decimal> array
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of Decimal)
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of Decimal)
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<Decimal>^ array
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<Decimal>^ array
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<decimal> -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<decimal> -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
array
Type: Online System.Collections.Generic IEnumerable Online Decimal
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, IEnumerable(Double))

Writer Write Method (WritingStreamer, UInt64, IEnumerable Double ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<double> array
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<double> array
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of Double)
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of Double)
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<double>^ array
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<double>^ array
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<float> -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<float> -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
array
Type: Online System.Collections.Generic IEnumerable Online Double
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, IEnumerable(Guid))

Writer Write Method (WritingStreamer, UInt64, IEnumerable Guid ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<Guid> array
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<Guid> array
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of Guid)
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of Guid)
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<Guid>^ array
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<Guid>^ array
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<Guid> -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<Guid> -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
array
Type: Online System.Collections.Generic IEnumerable Online Guid
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, IEnumerable(Int16))

Writer Write Method (WritingStreamer, UInt64, IEnumerable Int16 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<short> array
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<short> array
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of Short)
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of Short)
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<short>^ array
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<short>^ array
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<int16> -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<int16> -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
array
Type: Online System.Collections.Generic IEnumerable Online Int16
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, IEnumerable(Int32))

Writer Write Method (WritingStreamer, UInt64, IEnumerable Int32 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<int> array
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<int> array
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of Integer)
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of Integer)
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<int>^ array
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<int>^ array
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<int> -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<int> -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
array
Type: Online System.Collections.Generic IEnumerable Online Int32
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, IEnumerable(Int64))

Writer Write Method (WritingStreamer, UInt64, IEnumerable Int64 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<long> array
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<long> array
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of Long)
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of Long)
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<long long>^ array
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<long long>^ array
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<int64> -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<int64> -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
array
Type: Online System.Collections.Generic IEnumerable Online Int64
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, IEnumerable(SByte))

Writer Write Method (WritingStreamer, UInt64, IEnumerable SByte ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<sbyte> array
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<sbyte> array
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of SByte)
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of SByte)
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<signed char>^ array
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<signed char>^ array
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<sbyte> -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<sbyte> -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
array
Type: Online System.Collections.Generic IEnumerable Online SByte
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, IEnumerable(Single))

Writer Write Method (WritingStreamer, UInt64, IEnumerable Single ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<float> array
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<float> array
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of Single)
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of Single)
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<float>^ array
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<float>^ array
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<float32> -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<float32> -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
array
Type: Online System.Collections.Generic IEnumerable Online Single
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, IEnumerable(String))

Writer Write Method (WritingStreamer, UInt64, IEnumerable String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<string> array
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<string> array
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of String)
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of String)
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<String^>^ array
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<String^>^ array
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<string> -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<string> -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
array
Type: Online System.Collections.Generic IEnumerable Online String
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, IEnumerable(TimeSpan))

Writer Write Method (WritingStreamer, UInt64, IEnumerable TimeSpan ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<TimeSpan> array
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<TimeSpan> array
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of TimeSpan)
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of TimeSpan)
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<TimeSpan>^ array
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<TimeSpan>^ array
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<TimeSpan> -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<TimeSpan> -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
array
Type: Online System.Collections.Generic IEnumerable Online TimeSpan
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, IEnumerable(UInt16))

Writer Write Method (WritingStreamer, UInt64, IEnumerable UInt16 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<ushort> array
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<ushort> array
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of UShort)
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of UShort)
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<unsigned short>^ array
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<unsigned short>^ array
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<uint16> -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<uint16> -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
array
Type: Online System.Collections.Generic IEnumerable Online UInt16
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, IEnumerable(UInt32))

Writer Write Method (WritingStreamer, UInt64, IEnumerable UInt32 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<uint> array
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<uint> array
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of UInteger)
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of UInteger)
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<unsigned int>^ array
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<unsigned int>^ array
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<uint32> -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<uint32> -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
array
Type: Online System.Collections.Generic IEnumerable Online UInt32
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, IEnumerable(UInt64))

Writer Write Method (WritingStreamer, UInt64, IEnumerable UInt64 ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<ulong> array
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<ulong> array
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of ULong)
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of ULong)
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<unsigned long long>^ array
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<unsigned long long>^ array
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<uint64> -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<uint64> -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
array
Type: Online System.Collections.Generic IEnumerable Online UInt64
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, DateTime)

Writer Write Method (WritingStreamer, UInt64, DateTime) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    DateTime value
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    DateTime value
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As DateTime
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As DateTime
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    DateTime value
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    DateTime value
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : DateTime -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : DateTime -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
value
Type: Online System DateTime
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, Decimal)

Writer Write Method (WritingStreamer, UInt64, Decimal) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    decimal value
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    decimal value
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As Decimal
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As Decimal
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    Decimal value
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    Decimal value
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : decimal -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : decimal -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
value
Type: Online System Decimal
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, Double)

Writer Write Method (WritingStreamer, UInt64, Double) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    double value
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    double value
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As Double
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As Double
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    double value
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    double value
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : float -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : float -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
value
Type: Online System Double
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, Guid)

Writer Write Method (WritingStreamer, UInt64, Guid) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    Guid value
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    Guid value
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As Guid
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As Guid
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    Guid value
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    Guid value
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : Guid -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : Guid -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
value
Type: Online System Guid
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, Int16)

Writer Write Method (WritingStreamer, UInt64, Int16) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    short value
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    short value
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As Short
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As Short
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    short value
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    short value
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : int16 -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : int16 -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
value
Type: Online System Int16
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, Int32)

Writer Write Method (WritingStreamer, UInt64, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    int value
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    int value
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As Integer
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As Integer
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    int value
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    int value
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : int -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : int -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
value
Type: Online System Int32
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, Int64)

Writer Write Method (WritingStreamer, UInt64, Int64) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    long value
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    long value
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As Long
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As Long
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    long long value
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    long long value
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : int64 -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : int64 -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
value
Type: Online System Int64
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, SByte)

Writer Write Method (WritingStreamer, UInt64, SByte) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    sbyte value
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    sbyte value
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As SByte
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As SByte
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    signed char value
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    signed char value
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : sbyte -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : sbyte -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
value
Type: Online System SByte
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, Single)

Writer Write Method (WritingStreamer, UInt64, Single) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    float value
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    float value
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As Single
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As Single
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    float value
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    float value
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : float32 -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : float32 -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
value
Type: Online System Single
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, String)

Writer Write Method (WritingStreamer, UInt64, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    string value
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    string value
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As String
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As String
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    String^ value
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    String^ value
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : string -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : string -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
value
Type: Online System String
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, TimeSpan)

Writer Write Method (WritingStreamer, UInt64, TimeSpan) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    TimeSpan value
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    TimeSpan value
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As TimeSpan
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As TimeSpan
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    TimeSpan value
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    TimeSpan value
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : TimeSpan -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : TimeSpan -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
value
Type: Online System TimeSpan
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, UInt16)

Writer Write Method (WritingStreamer, UInt64, UInt16) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    ushort value
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    ushort value
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As UShort
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As UShort
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    unsigned short value
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    unsigned short value
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : uint16 -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : uint16 -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
value
Type: Online System UInt16
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, UInt32)

Writer Write Method (WritingStreamer, UInt64, UInt32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    uint value
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    uint value
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As UInteger
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As UInteger
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    unsigned int value
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    unsigned int value
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : uint32 -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : uint32 -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
value
Type: Online System UInt32
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.Write Method (WritingStreamer, UInt64, UInt64)

Writer Write Method (WritingStreamer, UInt64, UInt64) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    WritingStreamer streamer,
    ulong name,
    ulong value
)
public static void Write(
    WritingStreamer streamer,
    ulong name,
    ulong value
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As ULong
)
Public Shared Sub Write (
    streamer As WritingStreamer,
    name As ULong,
    value As ULong
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    unsigned long long value
)
public:
static void Write(
    WritingStreamer^ streamer,
    unsigned long long name,
    unsigned long long value
)
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : uint64 -> unit
static member Write :
        streamer : WritingStreamer *
        name : uint64 *
        value : uint64 -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
value
Type: Online System UInt64
See Also
Writer Class
Writer Members
Write Overload
NFX.Serialization.Arow Namespace


Writer.WriteEORow Method

Writer WriteEORow Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteEORow(
    WritingStreamer streamer
)
public static void WriteEORow(
    WritingStreamer streamer
)
Public Shared Sub WriteEORow (
    streamer As WritingStreamer
)
Public Shared Sub WriteEORow (
    streamer As WritingStreamer
)
public:
static void WriteEORow(
    WritingStreamer^ streamer
)
public:
static void WriteEORow(
    WritingStreamer^ streamer
)
static member WriteEORow :
        streamer : WritingStreamer -> unit
static member WriteEORow :
        streamer : WritingStreamer -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
See Also
Writer Class
Writer Members
NFX.Serialization.Arow Namespace


Writer.WriteHeader Method

Writer WriteHeader Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteHeader(
    WritingStreamer streamer
)
public static void WriteHeader(
    WritingStreamer streamer
)
Public Shared Sub WriteHeader (
    streamer As WritingStreamer
)
Public Shared Sub WriteHeader (
    streamer As WritingStreamer
)
public:
static void WriteHeader(
    WritingStreamer^ streamer
)
public:
static void WriteHeader(
    WritingStreamer^ streamer
)
static member WriteHeader :
        streamer : WritingStreamer -> unit
static member WriteHeader :
        streamer : WritingStreamer -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
See Also
Writer Class
Writer Members
NFX.Serialization.Arow Namespace


Writer.WriteNull Method

Writer WriteNull Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteNull(
    WritingStreamer streamer,
    ulong name
)
public static void WriteNull(
    WritingStreamer streamer,
    ulong name
)
Public Shared Sub WriteNull (
    streamer As WritingStreamer,
    name As ULong
)
Public Shared Sub WriteNull (
    streamer As WritingStreamer,
    name As ULong
)
public:
static void WriteNull(
    WritingStreamer^ streamer,
    unsigned long long name
)
public:
static void WriteNull(
    WritingStreamer^ streamer,
    unsigned long long name
)
static member WriteNull :
        streamer : WritingStreamer *
        name : uint64 -> unit
static member WriteNull :
        streamer : WritingStreamer *
        name : uint64 -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
See Also
Writer Class
Writer Members
NFX.Serialization.Arow Namespace


Writer.WriteObject Method

Writer WriteObject Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteObject(
    WritingStreamer streamer,
    ulong name,
    Object obj
)
public static void WriteObject(
    WritingStreamer streamer,
    ulong name,
    Object obj
)
Public Shared Sub WriteObject (
    streamer As WritingStreamer,
    name As ULong,
    obj As Object
)
Public Shared Sub WriteObject (
    streamer As WritingStreamer,
    name As ULong,
    obj As Object
)
public:
static void WriteObject(
    WritingStreamer^ streamer,
    unsigned long long name,
    Object^ obj
)
public:
static void WriteObject(
    WritingStreamer^ streamer,
    unsigned long long name,
    Object^ obj
)
static member WriteObject :
        streamer : WritingStreamer *
        name : uint64 *
        obj : Object -> unit
static member WriteObject :
        streamer : WritingStreamer *
        name : uint64 *
        obj : Object -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
obj
Type: Online System Object
See Also
Writer Class
Writer Members
NFX.Serialization.Arow Namespace


Writer.WriteObjectArray Method

Writer WriteObjectArray Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteObjectArray(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<Object> array
)
public static void WriteObjectArray(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<Object> array
)
Public Shared Sub WriteObjectArray (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of Object)
)
Public Shared Sub WriteObjectArray (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of Object)
)
public:
static void WriteObjectArray(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<Object^>^ array
)
public:
static void WriteObjectArray(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<Object^>^ array
)
static member WriteObjectArray :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<Object> -> unit
static member WriteObjectArray :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<Object> -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
array
Type: Online System.Collections.Generic IEnumerable Online Object
See Also
Writer Class
Writer Members
NFX.Serialization.Arow Namespace


Writer.WriteRow Method

Writer WriteRow Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteRow(
    WritingStreamer streamer,
    ulong name,
    TypedRow row
)
public static void WriteRow(
    WritingStreamer streamer,
    ulong name,
    TypedRow row
)
Public Shared Sub WriteRow (
    streamer As WritingStreamer,
    name As ULong,
    row As TypedRow
)
Public Shared Sub WriteRow (
    streamer As WritingStreamer,
    name As ULong,
    row As TypedRow
)
public:
static void WriteRow(
    WritingStreamer^ streamer,
    unsigned long long name,
    TypedRow^ row
)
public:
static void WriteRow(
    WritingStreamer^ streamer,
    unsigned long long name,
    TypedRow^ row
)
static member WriteRow :
        streamer : WritingStreamer *
        name : uint64 *
        row : TypedRow -> unit
static member WriteRow :
        streamer : WritingStreamer *
        name : uint64 *
        row : TypedRow -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
row
Type: NFX.DataAccess.CRUD TypedRow
See Also
Writer Class
Writer Members
NFX.Serialization.Arow Namespace


Writer.WriteRowArray Method

Writer WriteRowArray Method NFX Class Library

Namespace: NFX.Serialization.Arow
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteRowArray(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<TypedRow> array
)
public static void WriteRowArray(
    WritingStreamer streamer,
    ulong name,
    IEnumerable<TypedRow> array
)
Public Shared Sub WriteRowArray (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of TypedRow)
)
Public Shared Sub WriteRowArray (
    streamer As WritingStreamer,
    name As ULong,
    array As IEnumerable(Of TypedRow)
)
public:
static void WriteRowArray(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<TypedRow^>^ array
)
public:
static void WriteRowArray(
    WritingStreamer^ streamer,
    unsigned long long name,
    IEnumerable<TypedRow^>^ array
)
static member WriteRowArray :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<TypedRow> -> unit
static member WriteRowArray :
        streamer : WritingStreamer *
        name : uint64 *
        array : IEnumerable<TypedRow> -> unit

Parameters

streamer
Type: NFX.IO WritingStreamer
name
Type: Online System UInt64
array
Type: Online System.Collections.Generic IEnumerable TypedRow
See Also
Writer Class
Writer Members
NFX.Serialization.Arow Namespace


NFX.Serialization.BSON Namespace

NFX.Serialization.BSON Namespace NFX Class Library

Classes
 | Class | Description
Public class | BinUtils | Facilitates read.writing binary BSON primitives. Developers shopuld not normallu use this class as it is used by serializers and socket low-level code
Public class | BSONArrayElement | Represents a BSON array element with BSONElement[] value
Public class | BSONBinaryElement | Represents a BSON element with an BSONBinary value
Public class | BSONBooleanElement | Represents a BSON element with an bool value
Public class | BSONDateTimeElement | Represents a BSON element with an UTC DateTime value
Public class | BSONDocument | Represents a BSON document
Public class | BSONDocumentElement | Represents a BSON element with a BSON document value
Public class | BSONDoubleElement | Represents a BSON element with an int32 value
Public class | BSONElement | Very base class for BSON elements
Public class | BSONElement T | Base class for BSON elements with typed Value property
Public class | BSONException | Base exception thrown by the BSON framework
Public class | BSONInt32Element | Represents a BSON element with an int32 value
Public class | BSONInt64Element | Represents a BSON element with an int64 value
Public class | BSONJavaScriptElement | Represents a BSON element with a javascript value
Public class | BSONJavaScriptWithScopeElement | Represents a BSON element with a javascript with scope value
Public class | BSONMaxKeyElement | Represents an element with MaxKey value
Public class | BSONMinKeyElement | Represents an element with Min Key value
Public class | BSONNullElement | Represents an element with NULL value
Public class | BSONObjectIDElement | Represents a BSON element with an BSONObjectID value
Public class | BSONRegularExpressionElement | Represents a BSON element with an regular expression value
Public class | BSONStringElement | Represents a BSON element with a string value
Public class | BSONTimestampElement | Represents a BSON element with an Timestamp value
Public class | RegularExpressionExtensions | Utilities methods for BSON regular expression type
Public class | RowConverter | Provides methods for Row to/from BSONDocument conversion
Structures
 | Structure | Description
Public structure | BSONBinary | Represents a BSON bynary type
Public structure | BSONCodeWithScope | Represents a BSON javascript with the scope type
Public structure | BSONObjectID | Represents an ObjectId as a 12-byte BSON type
Public structure | BSONRegularExpression | Represents a BSON regular expression type
Public structure | BSONTimestamp | Represents a BSON timestamp type
Public structure | TemplateArg | Represents template argument
Enumerations
 | Enumeration | Description
Public enumeration | BSONBinaryType |
Public enumeration | BSONBoolean |
Public enumeration | BSONElementType | BSON element types: http://bsonspec.org/spec.html
Public enumeration | BSONRegularExpressionOptions |


BinUtils Class

BinUtils Class NFX Class Library

Facilitates read.writing binary BSON primitives. Developers shopuld not normallu use this class as it is used by serializers and socket low-level code
Inheritance Hierarchy
Online System Object
NFX.Serialization.BSON BinUtils

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class BinUtils
public static class BinUtils
Public NotInheritable Class BinUtils
Public NotInheritable Class BinUtils
public ref class BinUtils abstract sealed
public ref class BinUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type BinUtils =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type BinUtils =  class end
See Also
BinUtils Members
NFX.Serialization.BSON Namespace


BinUtils Members

BinUtils Members NFX Class Library

The BinUtils type exposes the following members.
Methods
Name | Description
GetIntDigitCount | Returns number of digits in 32-bit integer value
ReadByte |
ReadCString(Stream) | Reads BSON cstring from stream
ReadCString(Stream, Int32) | Reads BSON cstring from stream
ReadDouble | Reads double from stream
ReadElementType | Reads BSON element type from stream
ReadInt16(Stream) | Reads 16-bit int from stream
ReadInt16( Byte , Int32) | Reads 16-bit int from byte array
ReadInt32(Stream) | Reads 32-bit int from stream
ReadInt32( Byte , Int32) | Reads 32-bit int from byte array
ReadInt64(Stream) | Reads 64-bit int from stream
ReadInt64( Byte , Int32) | Reads 64-bit int from byte array
ReadUInt16(Stream) | Reads unsigned 16-bit int from stream
ReadUInt16( Byte , Int32) | Reads unsigned 16-bit int from byte array
ReadUInt24 | Reads 24-bit int (less than 2^24) from byte array
ReadUInt32(Stream) | Reads unsigned 32-bit int from stream
ReadUInt32( Byte , Int32) | Reads unsigned 32-bit int from byte array
ReadUInt64(Stream) | Reads unsigned 64-bit int from stream
ReadUInt64( Byte , Int32) | Reads unsigned 64-bit int from byte array
WriteBinary |
WriteByte | Writes byte to stream
WriteCString | Writes BSON cstring to stream
WriteCStringToBuffer |
WriteDouble | Writes double to stream
WriteInt16(Stream, Int16) | Writes 16-bit int to stream
WriteInt16( Byte , Int16, Int32) | Writes 16-bit int to byte array
WriteInt32(Stream, Int32) | Writes 32-bit int to stream
WriteInt32( Byte , Int32, Int32) | Writes 32bit int to byte array
WriteInt64(Stream, Int64) | Writes 64-bit int to stream
WriteInt64( Byte , Int64, Int32) | Writes 64-bit int to byte array
WriteTerminator | Writes terminator 0x00 symbol to stream
WriteUInt16(Stream, UInt16) | Writes unsigned 16-bit int to stream
WriteUInt16( Byte , UInt16, Int32) | Writes unsigned 16-bit int to byte array
WriteUInt24 | Writes unsigned 24bit int (less than 2^24) to byte array
WriteUInt32(Stream, UInt32) | Writes unsigned 32-bit int to stream
WriteUInt32( Byte , UInt32, Int32) | Writes unsigned 32bit int to byte array
WriteUInt64(Stream, UInt64) | Writes unsigned 64-bit int to stream
WriteUInt64( Byte , UInt64, Int32) | Writes unsigned 64-bit int to byte array
Back to Top
Fields
Name | Description
TERMINATOR |
Back to Top
Properties
Name | Description
UTF8Encoding |
Back to Top
See Also
BinUtils Class
NFX.Serialization.BSON Namespace


BinUtils Fields

BinUtils Fields NFX Class Library

The BinUtils type exposes the following members.
Fields
Name | Description
TERMINATOR |
Back to Top
See Also
BinUtils Class
NFX.Serialization.BSON Namespace


BinUtils.TERMINATOR Field

BinUtils TERMINATOR Field NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const byte TERMINATOR
public const byte TERMINATOR
Public Const TERMINATOR As Byte
Public Const TERMINATOR As Byte
public:
literal unsigned char TERMINATOR
public:
literal unsigned char TERMINATOR
static val mutable TERMINATOR: byte
static val mutable TERMINATOR: byte

Field Value

Type: Online Byte
See Also
BinUtils Class
BinUtils Members
NFX.Serialization.BSON Namespace


BinUtils Methods

BinUtils Methods NFX Class Library

The BinUtils type exposes the following members.
Methods
Name | Description
GetIntDigitCount | Returns number of digits in 32-bit integer value
ReadByte |
ReadCString(Stream) | Reads BSON cstring from stream
ReadCString(Stream, Int32) | Reads BSON cstring from stream
ReadDouble | Reads double from stream
ReadElementType | Reads BSON element type from stream
ReadInt16(Stream) | Reads 16-bit int from stream
ReadInt16( Byte , Int32) | Reads 16-bit int from byte array
ReadInt32(Stream) | Reads 32-bit int from stream
ReadInt32( Byte , Int32) | Reads 32-bit int from byte array
ReadInt64(Stream) | Reads 64-bit int from stream
ReadInt64( Byte , Int32) | Reads 64-bit int from byte array
ReadUInt16(Stream) | Reads unsigned 16-bit int from stream
ReadUInt16( Byte , Int32) | Reads unsigned 16-bit int from byte array
ReadUInt24 | Reads 24-bit int (less than 2^24) from byte array
ReadUInt32(Stream) | Reads unsigned 32-bit int from stream
ReadUInt32( Byte , Int32) | Reads unsigned 32-bit int from byte array
ReadUInt64(Stream) | Reads unsigned 64-bit int from stream
ReadUInt64( Byte , Int32) | Reads unsigned 64-bit int from byte array
WriteBinary |
WriteByte | Writes byte to stream
WriteCString | Writes BSON cstring to stream
WriteCStringToBuffer |
WriteDouble | Writes double to stream
WriteInt16(Stream, Int16) | Writes 16-bit int to stream
WriteInt16( Byte , Int16, Int32) | Writes 16-bit int to byte array
WriteInt32(Stream, Int32) | Writes 32-bit int to stream
WriteInt32( Byte , Int32, Int32) | Writes 32bit int to byte array
WriteInt64(Stream, Int64) | Writes 64-bit int to stream
WriteInt64( Byte , Int64, Int32) | Writes 64-bit int to byte array
WriteTerminator | Writes terminator 0x00 symbol to stream
WriteUInt16(Stream, UInt16) | Writes unsigned 16-bit int to stream
WriteUInt16( Byte , UInt16, Int32) | Writes unsigned 16-bit int to byte array
WriteUInt24 | Writes unsigned 24bit int (less than 2^24) to byte array
WriteUInt32(Stream, UInt32) | Writes unsigned 32-bit int to stream
WriteUInt32( Byte , UInt32, Int32) | Writes unsigned 32bit int to byte array
WriteUInt64(Stream, UInt64) | Writes unsigned 64-bit int to stream
WriteUInt64( Byte , UInt64, Int32) | Writes unsigned 64-bit int to byte array
Back to Top
See Also
BinUtils Class
NFX.Serialization.BSON Namespace


BinUtils.GetIntDigitCount Method

BinUtils GetIntDigitCount Method NFX Class Library

Returns number of digits in 32-bit integer value

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static short GetIntDigitCount(
    int value
)
public static short GetIntDigitCount(
    int value
)
Public Shared Function GetIntDigitCount (
    value As Integer
) As Short
Public Shared Function GetIntDigitCount (
    value As Integer
) As Short
public:
static short GetIntDigitCount(
    int value
)
public:
static short GetIntDigitCount(
    int value
)
static member GetIntDigitCount :
        value : int -> int16
static member GetIntDigitCount :
        value : int -> int16

Parameters

value
Type: Online System Int32

Return Value

Type: Online Int16
See Also
BinUtils Class
BinUtils Members
NFX.Serialization.BSON Namespace


BinUtils.ReadByte Method

BinUtils ReadByte Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte ReadByte(
    Stream stream
)
public static byte ReadByte(
    Stream stream
)
Public Shared Function ReadByte (
    stream As Stream
) As Byte
Public Shared Function ReadByte (
    stream As Stream
) As Byte
public:
static unsigned char ReadByte(
    Stream^ stream
)
public:
static unsigned char ReadByte(
    Stream^ stream
)
static member ReadByte :
        stream : Stream -> byte
static member ReadByte :
        stream : Stream -> byte

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online Byte
See Also
BinUtils Class
BinUtils Members
NFX.Serialization.BSON Namespace


BinUtils.ReadCString Method

BinUtils ReadCString Method NFX Class Library

Overload List
Name | Description
ReadCString(Stream) | Reads BSON cstring from stream
ReadCString(Stream, Int32) | Reads BSON cstring from stream
Back to Top
See Also
BinUtils Class
BinUtils Members
NFX.Serialization.BSON Namespace


BinUtils.ReadCString Method (Stream)

BinUtils ReadCString Method (Stream) NFX Class Library

Reads BSON cstring from stream

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ReadCString(
    Stream stream
)
public static string ReadCString(
    Stream stream
)
Public Shared Function ReadCString (
    stream As Stream
) As String
Public Shared Function ReadCString (
    stream As Stream
) As String
public:
static String^ ReadCString(
    Stream^ stream
)
public:
static String^ ReadCString(
    Stream^ stream
)
static member ReadCString :
        stream : Stream -> string
static member ReadCString :
        stream : Stream -> string

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online String
See Also
BinUtils Class
BinUtils Members
ReadCString Overload
NFX.Serialization.BSON Namespace


BinUtils.ReadCString Method (Stream, Int32)

BinUtils ReadCString Method (Stream, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Reads BSON cstring from stream

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ReadCString(
    Stream stream,
    int length
)
public static string ReadCString(
    Stream stream,
    int length
)
Public Shared Function ReadCString (
    stream As Stream,
    length As Integer
) As String
Public Shared Function ReadCString (
    stream As Stream,
    length As Integer
) As String
public:
static String^ ReadCString(
    Stream^ stream,
    int length
)
public:
static String^ ReadCString(
    Stream^ stream,
    int length
)
static member ReadCString :
        stream : Stream *
        length : int -> string
static member ReadCString :
        stream : Stream *
        length : int -> string

Parameters

stream
Type: Online System.IO Stream
length
Type: Online System Int32

Return Value

Type: Online String
See Also
BinUtils Class
BinUtils Members
ReadCString Overload
NFX.Serialization.BSON Namespace


BinUtils.ReadDouble Method

BinUtils ReadDouble Method NFX Class Library

Reads double from stream

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static double ReadDouble(
    Stream stream
)
public static double ReadDouble(
    Stream stream
)
Public Shared Function ReadDouble (
    stream As Stream
) As Double
Public Shared Function ReadDouble (
    stream As Stream
) As Double
public:
static double ReadDouble(
    Stream^ stream
)
public:
static double ReadDouble(
    Stream^ stream
)
static member ReadDouble :
        stream : Stream -> float
static member ReadDouble :
        stream : Stream -> float

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online Double
See Also
BinUtils Class
BinUtils Members
NFX.Serialization.BSON Namespace


BinUtils.ReadElementType Method

BinUtils ReadElementType Method NFX Class Library

Reads BSON element type from stream

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static BSONElementType ReadElementType(
    Stream stream
)
public static BSONElementType ReadElementType(
    Stream stream
)
Public Shared Function ReadElementType (
    stream As Stream
) As BSONElementType
Public Shared Function ReadElementType (
    stream As Stream
) As BSONElementType
public:
static BSONElementType ReadElementType(
    Stream^ stream
)
public:
static BSONElementType ReadElementType(
    Stream^ stream
)
static member ReadElementType :
        stream : Stream -> BSONElementType
static member ReadElementType :
        stream : Stream -> BSONElementType

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: BSONElementType
See Also
BinUtils Class
BinUtils Members
NFX.Serialization.BSON Namespace


BinUtils.ReadInt16 Method

BinUtils ReadInt16 Method NFX Class Library

Overload List
Name | Description
ReadInt16(Stream) | Reads 16-bit int from stream
ReadInt16( Byte , Int32) | Reads 16-bit int from byte array
Back to Top
See Also
BinUtils Class
BinUtils Members
NFX.Serialization.BSON Namespace


BinUtils.ReadInt16 Method (Stream)

BinUtils ReadInt16 Method (Stream) NFX Class Library

Reads 16-bit int from stream

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static short ReadInt16(
    Stream stream
)
public static short ReadInt16(
    Stream stream
)
Public Shared Function ReadInt16 (
    stream As Stream
) As Short
Public Shared Function ReadInt16 (
    stream As Stream
) As Short
public:
static short ReadInt16(
    Stream^ stream
)
public:
static short ReadInt16(
    Stream^ stream
)
static member ReadInt16 :
        stream : Stream -> int16
static member ReadInt16 :
        stream : Stream -> int16

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online Int16
See Also
BinUtils Class
BinUtils Members
ReadInt16 Overload
NFX.Serialization.BSON Namespace


BinUtils.ReadInt16 Method (Byte[], Int32)

BinUtils ReadInt16 Method ( Byte , Int32) NFX Class Library

Reads 16-bit int from byte array

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static short ReadInt16(
    byte[] bytes,
    int startIdx = 0
)
public static short ReadInt16(
    byte[] bytes,
    int startIdx = 0
)
Public Shared Function ReadInt16 (
    bytes As Byte(),
    Optional startIdx As Integer = 0
) As Short
Public Shared Function ReadInt16 (
    bytes As Byte(),
    Optional startIdx As Integer = 0
) As Short
public:
static short ReadInt16(
    array<unsigned char>^ bytes,
    int startIdx = 0
)
public:
static short ReadInt16(
    array<unsigned char>^ bytes,
    int startIdx = 0
)
static member ReadInt16 :
        bytes : byte[] *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> int16
static member ReadInt16 :
        bytes : byte[] *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> int16

Parameters

bytes
Type: Online System Byte
startIdx (Optional)
Type: Online System Int32

Return Value

Type: Online Int16
See Also
BinUtils Class
BinUtils Members
ReadInt16 Overload
NFX.Serialization.BSON Namespace


BinUtils.ReadInt32 Method

BinUtils ReadInt32 Method NFX Class Library

Overload List
Name | Description
ReadInt32(Stream) | Reads 32-bit int from stream
ReadInt32( Byte , Int32) | Reads 32-bit int from byte array
Back to Top
See Also
BinUtils Class
BinUtils Members
NFX.Serialization.BSON Namespace


BinUtils.ReadInt32 Method (Stream)

BinUtils ReadInt32 Method (Stream) NFX Class Library

Reads 32-bit int from stream

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int ReadInt32(
    Stream stream
)
public static int ReadInt32(
    Stream stream
)
Public Shared Function ReadInt32 (
    stream As Stream
) As Integer
Public Shared Function ReadInt32 (
    stream As Stream
) As Integer
public:
static int ReadInt32(
    Stream^ stream
)
public:
static int ReadInt32(
    Stream^ stream
)
static member ReadInt32 :
        stream : Stream -> int
static member ReadInt32 :
        stream : Stream -> int

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online Int32
See Also
BinUtils Class
BinUtils Members
ReadInt32 Overload
NFX.Serialization.BSON Namespace


BinUtils.ReadInt32 Method (Byte[], Int32)

BinUtils ReadInt32 Method ( Byte , Int32) NFX Class Library

Reads 32-bit int from byte array

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int ReadInt32(
    byte[] bytes,
    int startIdx = 0
)
public static int ReadInt32(
    byte[] bytes,
    int startIdx = 0
)
Public Shared Function ReadInt32 (
    bytes As Byte(),
    Optional startIdx As Integer = 0
) As Integer
Public Shared Function ReadInt32 (
    bytes As Byte(),
    Optional startIdx As Integer = 0
) As Integer
public:
static int ReadInt32(
    array<unsigned char>^ bytes,
    int startIdx = 0
)
public:
static int ReadInt32(
    array<unsigned char>^ bytes,
    int startIdx = 0
)
static member ReadInt32 :
        bytes : byte[] *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> int
static member ReadInt32 :
        bytes : byte[] *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> int

Parameters

bytes
Type: Online System Byte
startIdx (Optional)
Type: Online System Int32

Return Value

Type: Online Int32
See Also
BinUtils Class
BinUtils Members
ReadInt32 Overload
NFX.Serialization.BSON Namespace


BinUtils.ReadInt64 Method

BinUtils ReadInt64 Method NFX Class Library

Overload List
Name | Description
ReadInt64(Stream) | Reads 64-bit int from stream
ReadInt64( Byte , Int32) | Reads 64-bit int from byte array
Back to Top
See Also
BinUtils Class
BinUtils Members
NFX.Serialization.BSON Namespace


BinUtils.ReadInt64 Method (Stream)

BinUtils ReadInt64 Method (Stream) NFX Class Library

Reads 64-bit int from stream

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long ReadInt64(
    Stream stream
)
public static long ReadInt64(
    Stream stream
)
Public Shared Function ReadInt64 (
    stream As Stream
) As Long
Public Shared Function ReadInt64 (
    stream As Stream
) As Long
public:
static long long ReadInt64(
    Stream^ stream
)
public:
static long long ReadInt64(
    Stream^ stream
)
static member ReadInt64 :
        stream : Stream -> int64
static member ReadInt64 :
        stream : Stream -> int64

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online Int64
See Also
BinUtils Class
BinUtils Members
ReadInt64 Overload
NFX.Serialization.BSON Namespace


BinUtils.ReadInt64 Method (Byte[], Int32)

BinUtils ReadInt64 Method ( Byte , Int32) NFX Class Library

Reads 64-bit int from byte array

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static long ReadInt64(
    byte[] bytes,
    int startIdx = 0
)
public static long ReadInt64(
    byte[] bytes,
    int startIdx = 0
)
Public Shared Function ReadInt64 (
    bytes As Byte(),
    Optional startIdx As Integer = 0
) As Long
Public Shared Function ReadInt64 (
    bytes As Byte(),
    Optional startIdx As Integer = 0
) As Long
public:
static long long ReadInt64(
    array<unsigned char>^ bytes,
    int startIdx = 0
)
public:
static long long ReadInt64(
    array<unsigned char>^ bytes,
    int startIdx = 0
)
static member ReadInt64 :
        bytes : byte[] *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> int64
static member ReadInt64 :
        bytes : byte[] *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> int64

Parameters

bytes
Type: Online System Byte
startIdx (Optional)
Type: Online System Int32

Return Value

Type: Online Int64
See Also
BinUtils Class
BinUtils Members
ReadInt64 Overload
NFX.Serialization.BSON Namespace


BinUtils.ReadUInt16 Method

BinUtils ReadUInt16 Method NFX Class Library

Overload List
Name | Description
ReadUInt16(Stream) | Reads unsigned 16-bit int from stream
ReadUInt16( Byte , Int32) | Reads unsigned 16-bit int from byte array
Back to Top
See Also
BinUtils Class
BinUtils Members
NFX.Serialization.BSON Namespace


BinUtils.ReadUInt16 Method (Stream)

BinUtils ReadUInt16 Method (Stream) NFX Class Library

Reads unsigned 16-bit int from stream

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ushort ReadUInt16(
    Stream stream
)
public static ushort ReadUInt16(
    Stream stream
)
Public Shared Function ReadUInt16 (
    stream As Stream
) As UShort
Public Shared Function ReadUInt16 (
    stream As Stream
) As UShort
public:
static unsigned short ReadUInt16(
    Stream^ stream
)
public:
static unsigned short ReadUInt16(
    Stream^ stream
)
static member ReadUInt16 :
        stream : Stream -> uint16
static member ReadUInt16 :
        stream : Stream -> uint16

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online UInt16
See Also
BinUtils Class
BinUtils Members
ReadUInt16 Overload
NFX.Serialization.BSON Namespace


BinUtils.ReadUInt16 Method (Byte[], Int32)

BinUtils ReadUInt16 Method ( Byte , Int32) NFX Class Library

Reads unsigned 16-bit int from byte array

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ushort ReadUInt16(
    byte[] bytes,
    int startIdx = 0
)
public static ushort ReadUInt16(
    byte[] bytes,
    int startIdx = 0
)
Public Shared Function ReadUInt16 (
    bytes As Byte(),
    Optional startIdx As Integer = 0
) As UShort
Public Shared Function ReadUInt16 (
    bytes As Byte(),
    Optional startIdx As Integer = 0
) As UShort
public:
static unsigned short ReadUInt16(
    array<unsigned char>^ bytes,
    int startIdx = 0
)
public:
static unsigned short ReadUInt16(
    array<unsigned char>^ bytes,
    int startIdx = 0
)
static member ReadUInt16 :
        bytes : byte[] *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> uint16
static member ReadUInt16 :
        bytes : byte[] *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> uint16

Parameters

bytes
Type: Online System Byte
startIdx (Optional)
Type: Online System Int32

Return Value

Type: Online UInt16
See Also
BinUtils Class
BinUtils Members
ReadUInt16 Overload
NFX.Serialization.BSON Namespace


BinUtils.ReadUInt24 Method

BinUtils ReadUInt24 Method NFX Class Library

Reads 24-bit int (less than 2^24) from byte array

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static uint ReadUInt24(
    byte[] bytes,
    int startIdx = 0
)
public static uint ReadUInt24(
    byte[] bytes,
    int startIdx = 0
)
Public Shared Function ReadUInt24 (
    bytes As Byte(),
    Optional startIdx As Integer = 0
) As UInteger
Public Shared Function ReadUInt24 (
    bytes As Byte(),
    Optional startIdx As Integer = 0
) As UInteger
public:
static unsigned int ReadUInt24(
    array<unsigned char>^ bytes,
    int startIdx = 0
)
public:
static unsigned int ReadUInt24(
    array<unsigned char>^ bytes,
    int startIdx = 0
)
static member ReadUInt24 :
        bytes : byte[] *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> uint32
static member ReadUInt24 :
        bytes : byte[] *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> uint32

Parameters

bytes
Type: Online System Byte
startIdx (Optional)
Type: Online System Int32

Return Value

Type: Online UInt32
See Also
BinUtils Class
BinUtils Members
NFX.Serialization.BSON Namespace


BinUtils.ReadUInt32 Method

BinUtils ReadUInt32 Method NFX Class Library

Overload List
Name | Description
ReadUInt32(Stream) | Reads unsigned 32-bit int from stream
ReadUInt32( Byte , Int32) | Reads unsigned 32-bit int from byte array
Back to Top
See Also
BinUtils Class
BinUtils Members
NFX.Serialization.BSON Namespace


BinUtils.ReadUInt32 Method (Stream)

BinUtils ReadUInt32 Method (Stream) NFX Class Library

Reads unsigned 32-bit int from stream

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static uint ReadUInt32(
    Stream stream
)
public static uint ReadUInt32(
    Stream stream
)
Public Shared Function ReadUInt32 (
    stream As Stream
) As UInteger
Public Shared Function ReadUInt32 (
    stream As Stream
) As UInteger
public:
static unsigned int ReadUInt32(
    Stream^ stream
)
public:
static unsigned int ReadUInt32(
    Stream^ stream
)
static member ReadUInt32 :
        stream : Stream -> uint32
static member ReadUInt32 :
        stream : Stream -> uint32

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online UInt32
See Also
BinUtils Class
BinUtils Members
ReadUInt32 Overload
NFX.Serialization.BSON Namespace


BinUtils.ReadUInt32 Method (Byte[], Int32)

BinUtils ReadUInt32 Method ( Byte , Int32) NFX Class Library

Reads unsigned 32-bit int from byte array

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static uint ReadUInt32(
    byte[] bytes,
    int startIdx = 0
)
public static uint ReadUInt32(
    byte[] bytes,
    int startIdx = 0
)
Public Shared Function ReadUInt32 (
    bytes As Byte(),
    Optional startIdx As Integer = 0
) As UInteger
Public Shared Function ReadUInt32 (
    bytes As Byte(),
    Optional startIdx As Integer = 0
) As UInteger
public:
static unsigned int ReadUInt32(
    array<unsigned char>^ bytes,
    int startIdx = 0
)
public:
static unsigned int ReadUInt32(
    array<unsigned char>^ bytes,
    int startIdx = 0
)
static member ReadUInt32 :
        bytes : byte[] *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> uint32
static member ReadUInt32 :
        bytes : byte[] *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> uint32

Parameters

bytes
Type: Online System Byte
startIdx (Optional)
Type: Online System Int32

Return Value

Type: Online UInt32
See Also
BinUtils Class
BinUtils Members
ReadUInt32 Overload
NFX.Serialization.BSON Namespace


BinUtils.ReadUInt64 Method

BinUtils ReadUInt64 Method NFX Class Library

Overload List
Name | Description
ReadUInt64(Stream) | Reads unsigned 64-bit int from stream
ReadUInt64( Byte , Int32) | Reads unsigned 64-bit int from byte array
Back to Top
See Also
BinUtils Class
BinUtils Members
NFX.Serialization.BSON Namespace


BinUtils.ReadUInt64 Method (Stream)

BinUtils ReadUInt64 Method (Stream) NFX Class Library

Reads unsigned 64-bit int from stream

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ulong ReadUInt64(
    Stream stream
)
public static ulong ReadUInt64(
    Stream stream
)
Public Shared Function ReadUInt64 (
    stream As Stream
) As ULong
Public Shared Function ReadUInt64 (
    stream As Stream
) As ULong
public:
static unsigned long long ReadUInt64(
    Stream^ stream
)
public:
static unsigned long long ReadUInt64(
    Stream^ stream
)
static member ReadUInt64 :
        stream : Stream -> uint64
static member ReadUInt64 :
        stream : Stream -> uint64

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online UInt64
See Also
BinUtils Class
BinUtils Members
ReadUInt64 Overload
NFX.Serialization.BSON Namespace


BinUtils.ReadUInt64 Method (Byte[], Int32)

BinUtils ReadUInt64 Method ( Byte , Int32) NFX Class Library

Reads unsigned 64-bit int from byte array

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ulong ReadUInt64(
    byte[] bytes,
    int startIdx = 0
)
public static ulong ReadUInt64(
    byte[] bytes,
    int startIdx = 0
)
Public Shared Function ReadUInt64 (
    bytes As Byte(),
    Optional startIdx As Integer = 0
) As ULong
Public Shared Function ReadUInt64 (
    bytes As Byte(),
    Optional startIdx As Integer = 0
) As ULong
public:
static unsigned long long ReadUInt64(
    array<unsigned char>^ bytes,
    int startIdx = 0
)
public:
static unsigned long long ReadUInt64(
    array<unsigned char>^ bytes,
    int startIdx = 0
)
static member ReadUInt64 :
        bytes : byte[] *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> uint64
static member ReadUInt64 :
        bytes : byte[] *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> uint64

Parameters

bytes
Type: Online System Byte
startIdx (Optional)
Type: Online System Int32

Return Value

Type: Online UInt64
See Also
BinUtils Class
BinUtils Members
ReadUInt64 Overload
NFX.Serialization.BSON Namespace


BinUtils.WriteBinary Method

BinUtils WriteBinary Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteBinary(
    Stream stream,
    byte[] value
)
public static void WriteBinary(
    Stream stream,
    byte[] value
)
Public Shared Sub WriteBinary (
    stream As Stream,
    value As Byte()
)
Public Shared Sub WriteBinary (
    stream As Stream,
    value As Byte()
)
public:
static void WriteBinary(
    Stream^ stream,
    array<unsigned char>^ value
)
public:
static void WriteBinary(
    Stream^ stream,
    array<unsigned char>^ value
)
static member WriteBinary :
        stream : Stream *
        value : byte[] -> unit
static member WriteBinary :
        stream : Stream *
        value : byte[] -> unit

Parameters

stream
Type: Online System.IO Stream
value
Type: Online System Byte
See Also
BinUtils Class
BinUtils Members
NFX.Serialization.BSON Namespace


BinUtils.WriteByte Method

BinUtils WriteByte Method NFX Class Library

Writes byte to stream

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteByte(
    Stream stream,
    byte value
)
public static void WriteByte(
    Stream stream,
    byte value
)
Public Shared Sub WriteByte (
    stream As Stream,
    value As Byte
)
Public Shared Sub WriteByte (
    stream As Stream,
    value As Byte
)
public:
static void WriteByte(
    Stream^ stream,
    unsigned char value
)
public:
static void WriteByte(
    Stream^ stream,
    unsigned char value
)
static member WriteByte :
        stream : Stream *
        value : byte -> unit
static member WriteByte :
        stream : Stream *
        value : byte -> unit

Parameters

stream
Type: Online System.IO Stream
value
Type: Online System Byte
See Also
BinUtils Class
BinUtils Members
NFX.Serialization.BSON Namespace


BinUtils.WriteCString Method

BinUtils WriteCString Method NFX Class Library

Writes BSON cstring to stream

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteCString(
    Stream stream,
    string value
)
public static void WriteCString(
    Stream stream,
    string value
)
Public Shared Sub WriteCString (
    stream As Stream,
    value As String
)
Public Shared Sub WriteCString (
    stream As Stream,
    value As String
)
public:
static void WriteCString(
    Stream^ stream,
    String^ value
)
public:
static void WriteCString(
    Stream^ stream,
    String^ value
)
static member WriteCString :
        stream : Stream *
        value : string -> unit
static member WriteCString :
        stream : Stream *
        value : string -> unit

Parameters

stream
Type: Online System.IO Stream
value
Type: Online System String
See Also
BinUtils Class
BinUtils Members
NFX.Serialization.BSON Namespace


BinUtils.WriteCStringToBuffer Method

BinUtils WriteCStringToBuffer Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte[] WriteCStringToBuffer(
    string value
)
public static byte[] WriteCStringToBuffer(
    string value
)
Public Shared Function WriteCStringToBuffer (
    value As String
) As Byte()
Public Shared Function WriteCStringToBuffer (
    value As String
) As Byte()
public:
static array<unsigned char>^ WriteCStringToBuffer(
    String^ value
)
public:
static array<unsigned char>^ WriteCStringToBuffer(
    String^ value
)
static member WriteCStringToBuffer :
        value : string -> byte[]
static member WriteCStringToBuffer :
        value : string -> byte[]

Parameters

value
Type: Online System String

Return Value

Type: Online Byte
See Also
BinUtils Class
BinUtils Members
NFX.Serialization.BSON Namespace


BinUtils.WriteDouble Method

BinUtils WriteDouble Method NFX Class Library

Writes double to stream

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteDouble(
    Stream stream,
    double value
)
public static void WriteDouble(
    Stream stream,
    double value
)
Public Shared Sub WriteDouble (
    stream As Stream,
    value As Double
)
Public Shared Sub WriteDouble (
    stream As Stream,
    value As Double
)
public:
static void WriteDouble(
    Stream^ stream,
    double value
)
public:
static void WriteDouble(
    Stream^ stream,
    double value
)
static member WriteDouble :
        stream : Stream *
        value : float -> unit
static member WriteDouble :
        stream : Stream *
        value : float -> unit

Parameters

stream
Type: Online System.IO Stream
value
Type: Online System Double
See Also
BinUtils Class
BinUtils Members
NFX.Serialization.BSON Namespace


BinUtils.WriteInt16 Method

BinUtils WriteInt16 Method NFX Class Library

Overload List
Name | Description
WriteInt16(Stream, Int16) | Writes 16-bit int to stream
WriteInt16( Byte , Int16, Int32) | Writes 16-bit int to byte array
Back to Top
See Also
BinUtils Class
BinUtils Members
NFX.Serialization.BSON Namespace


BinUtils.WriteInt16 Method (Stream, Int16)

BinUtils WriteInt16 Method (Stream, Int16) NFX Class Library

Writes 16-bit int to stream

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteInt16(
    Stream stream,
    short value
)
public static void WriteInt16(
    Stream stream,
    short value
)
Public Shared Sub WriteInt16 (
    stream As Stream,
    value As Short
)
Public Shared Sub WriteInt16 (
    stream As Stream,
    value As Short
)
public:
static void WriteInt16(
    Stream^ stream,
    short value
)
public:
static void WriteInt16(
    Stream^ stream,
    short value
)
static member WriteInt16 :
        stream : Stream *
        value : int16 -> unit
static member WriteInt16 :
        stream : Stream *
        value : int16 -> unit

Parameters

stream
Type: Online System.IO Stream
value
Type: Online System Int16
See Also
BinUtils Class
BinUtils Members
WriteInt16 Overload
NFX.Serialization.BSON Namespace


BinUtils.WriteInt16 Method (Byte[], Int16, Int32)

BinUtils WriteInt16 Method ( Byte , Int16, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes 16-bit int to byte array

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteInt16(
    byte[] buffer,
    short value,
    int startIdx = 0
)
public static void WriteInt16(
    byte[] buffer,
    short value,
    int startIdx = 0
)
Public Shared Sub WriteInt16 (
    buffer As Byte(),
    value As Short,
    Optional startIdx As Integer = 0
)
Public Shared Sub WriteInt16 (
    buffer As Byte(),
    value As Short,
    Optional startIdx As Integer = 0
)
public:
static void WriteInt16(
    array<unsigned char>^ buffer,
    short value,
    int startIdx = 0
)
public:
static void WriteInt16(
    array<unsigned char>^ buffer,
    short value,
    int startIdx = 0
)
static member WriteInt16 :
        buffer : byte[] *
        value : int16 *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> unit
static member WriteInt16 :
        buffer : byte[] *
        value : int16 *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> unit

Parameters

buffer
Type: Online System Byte
value
Type: Online System Int16
startIdx (Optional)
Type: Online System Int32
See Also
BinUtils Class
BinUtils Members
WriteInt16 Overload
NFX.Serialization.BSON Namespace


BinUtils.WriteInt32 Method

BinUtils WriteInt32 Method NFX Class Library

Overload List
Name | Description
WriteInt32(Stream, Int32) | Writes 32-bit int to stream
WriteInt32( Byte , Int32, Int32) | Writes 32bit int to byte array
Back to Top
See Also
BinUtils Class
BinUtils Members
NFX.Serialization.BSON Namespace


BinUtils.WriteInt32 Method (Stream, Int32)

BinUtils WriteInt32 Method (Stream, Int32) NFX Class Library

Writes 32-bit int to stream

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteInt32(
    Stream stream,
    int value
)
public static void WriteInt32(
    Stream stream,
    int value
)
Public Shared Sub WriteInt32 (
    stream As Stream,
    value As Integer
)
Public Shared Sub WriteInt32 (
    stream As Stream,
    value As Integer
)
public:
static void WriteInt32(
    Stream^ stream,
    int value
)
public:
static void WriteInt32(
    Stream^ stream,
    int value
)
static member WriteInt32 :
        stream : Stream *
        value : int -> unit
static member WriteInt32 :
        stream : Stream *
        value : int -> unit

Parameters

stream
Type: Online System.IO Stream
value
Type: Online System Int32
See Also
BinUtils Class
BinUtils Members
WriteInt32 Overload
NFX.Serialization.BSON Namespace


BinUtils.WriteInt32 Method (Byte[], Int32, Int32)

BinUtils WriteInt32 Method ( Byte , Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes 32bit int to byte array

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteInt32(
    byte[] buffer,
    int value,
    int startIdx = 0
)
public static void WriteInt32(
    byte[] buffer,
    int value,
    int startIdx = 0
)
Public Shared Sub WriteInt32 (
    buffer As Byte(),
    value As Integer,
    Optional startIdx As Integer = 0
)
Public Shared Sub WriteInt32 (
    buffer As Byte(),
    value As Integer,
    Optional startIdx As Integer = 0
)
public:
static void WriteInt32(
    array<unsigned char>^ buffer,
    int value,
    int startIdx = 0
)
public:
static void WriteInt32(
    array<unsigned char>^ buffer,
    int value,
    int startIdx = 0
)
static member WriteInt32 :
        buffer : byte[] *
        value : int *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> unit
static member WriteInt32 :
        buffer : byte[] *
        value : int *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> unit

Parameters

buffer
Type: Online System Byte
value
Type: Online System Int32
startIdx (Optional)
Type: Online System Int32
See Also
BinUtils Class
BinUtils Members
WriteInt32 Overload
NFX.Serialization.BSON Namespace


BinUtils.WriteInt64 Method

BinUtils WriteInt64 Method NFX Class Library

Overload List
Name | Description
WriteInt64(Stream, Int64) | Writes 64-bit int to stream
WriteInt64( Byte , Int64, Int32) | Writes 64-bit int to byte array
Back to Top
See Also
BinUtils Class
BinUtils Members
NFX.Serialization.BSON Namespace


BinUtils.WriteInt64 Method (Stream, Int64)

BinUtils WriteInt64 Method (Stream, Int64) NFX Class Library

Writes 64-bit int to stream

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteInt64(
    Stream stream,
    long value
)
public static void WriteInt64(
    Stream stream,
    long value
)
Public Shared Sub WriteInt64 (
    stream As Stream,
    value As Long
)
Public Shared Sub WriteInt64 (
    stream As Stream,
    value As Long
)
public:
static void WriteInt64(
    Stream^ stream,
    long long value
)
public:
static void WriteInt64(
    Stream^ stream,
    long long value
)
static member WriteInt64 :
        stream : Stream *
        value : int64 -> unit
static member WriteInt64 :
        stream : Stream *
        value : int64 -> unit

Parameters

stream
Type: Online System.IO Stream
value
Type: Online System Int64
See Also
BinUtils Class
BinUtils Members
WriteInt64 Overload
NFX.Serialization.BSON Namespace


BinUtils.WriteInt64 Method (Byte[], Int64, Int32)

BinUtils WriteInt64 Method ( Byte , Int64, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes 64-bit int to byte array

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteInt64(
    byte[] buffer,
    long value,
    int startIdx = 0
)
public static void WriteInt64(
    byte[] buffer,
    long value,
    int startIdx = 0
)
Public Shared Sub WriteInt64 (
    buffer As Byte(),
    value As Long,
    Optional startIdx As Integer = 0
)
Public Shared Sub WriteInt64 (
    buffer As Byte(),
    value As Long,
    Optional startIdx As Integer = 0
)
public:
static void WriteInt64(
    array<unsigned char>^ buffer,
    long long value,
    int startIdx = 0
)
public:
static void WriteInt64(
    array<unsigned char>^ buffer,
    long long value,
    int startIdx = 0
)
static member WriteInt64 :
        buffer : byte[] *
        value : int64 *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> unit
static member WriteInt64 :
        buffer : byte[] *
        value : int64 *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> unit

Parameters

buffer
Type: Online System Byte
value
Type: Online System Int64
startIdx (Optional)
Type: Online System Int32
See Also
BinUtils Class
BinUtils Members
WriteInt64 Overload
NFX.Serialization.BSON Namespace


BinUtils.WriteTerminator Method

BinUtils WriteTerminator Method NFX Class Library

Writes terminator 0x00 symbol to stream

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteTerminator(
    Stream stream
)
public static void WriteTerminator(
    Stream stream
)
Public Shared Sub WriteTerminator (
    stream As Stream
)
Public Shared Sub WriteTerminator (
    stream As Stream
)
public:
static void WriteTerminator(
    Stream^ stream
)
public:
static void WriteTerminator(
    Stream^ stream
)
static member WriteTerminator :
        stream : Stream -> unit
static member WriteTerminator :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BinUtils Class
BinUtils Members
NFX.Serialization.BSON Namespace


BinUtils.WriteUInt16 Method

BinUtils WriteUInt16 Method NFX Class Library

Overload List
Name | Description
WriteUInt16(Stream, UInt16) | Writes unsigned 16-bit int to stream
WriteUInt16( Byte , UInt16, Int32) | Writes unsigned 16-bit int to byte array
Back to Top
See Also
BinUtils Class
BinUtils Members
NFX.Serialization.BSON Namespace


BinUtils.WriteUInt16 Method (Stream, UInt16)

BinUtils WriteUInt16 Method (Stream, UInt16) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes unsigned 16-bit int to stream

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteUInt16(
    Stream stream,
    ushort value
)
public static void WriteUInt16(
    Stream stream,
    ushort value
)
Public Shared Sub WriteUInt16 (
    stream As Stream,
    value As UShort
)
Public Shared Sub WriteUInt16 (
    stream As Stream,
    value As UShort
)
public:
static void WriteUInt16(
    Stream^ stream,
    unsigned short value
)
public:
static void WriteUInt16(
    Stream^ stream,
    unsigned short value
)
static member WriteUInt16 :
        stream : Stream *
        value : uint16 -> unit
static member WriteUInt16 :
        stream : Stream *
        value : uint16 -> unit

Parameters

stream
Type: Online System.IO Stream
value
Type: Online System UInt16
See Also
BinUtils Class
BinUtils Members
WriteUInt16 Overload
NFX.Serialization.BSON Namespace


BinUtils.WriteUInt16 Method (Byte[], UInt16, Int32)

BinUtils WriteUInt16 Method ( Byte , UInt16, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes unsigned 16-bit int to byte array

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteUInt16(
    byte[] buffer,
    ushort value,
    int startIdx = 0
)
public static void WriteUInt16(
    byte[] buffer,
    ushort value,
    int startIdx = 0
)
Public Shared Sub WriteUInt16 (
    buffer As Byte(),
    value As UShort,
    Optional startIdx As Integer = 0
)
Public Shared Sub WriteUInt16 (
    buffer As Byte(),
    value As UShort,
    Optional startIdx As Integer = 0
)
public:
static void WriteUInt16(
    array<unsigned char>^ buffer,
    unsigned short value,
    int startIdx = 0
)
public:
static void WriteUInt16(
    array<unsigned char>^ buffer,
    unsigned short value,
    int startIdx = 0
)
static member WriteUInt16 :
        buffer : byte[] *
        value : uint16 *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> unit
static member WriteUInt16 :
        buffer : byte[] *
        value : uint16 *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> unit

Parameters

buffer
Type: Online System Byte
value
Type: Online System UInt16
startIdx (Optional)
Type: Online System Int32
See Also
BinUtils Class
BinUtils Members
WriteUInt16 Overload
NFX.Serialization.BSON Namespace


BinUtils.WriteUInt24 Method

BinUtils WriteUInt24 Method NFX Class Library

Writes unsigned 24bit int (less than 2^24) to byte array

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteUInt24(
    byte[] buffer,
    uint value,
    int startIdx = 0
)
public static void WriteUInt24(
    byte[] buffer,
    uint value,
    int startIdx = 0
)
Public Shared Sub WriteUInt24 (
    buffer As Byte(),
    value As UInteger,
    Optional startIdx As Integer = 0
)
Public Shared Sub WriteUInt24 (
    buffer As Byte(),
    value As UInteger,
    Optional startIdx As Integer = 0
)
public:
static void WriteUInt24(
    array<unsigned char>^ buffer,
    unsigned int value,
    int startIdx = 0
)
public:
static void WriteUInt24(
    array<unsigned char>^ buffer,
    unsigned int value,
    int startIdx = 0
)
static member WriteUInt24 :
        buffer : byte[] *
        value : uint32 *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> unit
static member WriteUInt24 :
        buffer : byte[] *
        value : uint32 *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> unit

Parameters

buffer
Type: Online System Byte
value
Type: Online System UInt32
startIdx (Optional)
Type: Online System Int32
See Also
BinUtils Class
BinUtils Members
NFX.Serialization.BSON Namespace


BinUtils.WriteUInt32 Method

BinUtils WriteUInt32 Method NFX Class Library

Overload List
Name | Description
WriteUInt32(Stream, UInt32) | Writes unsigned 32-bit int to stream
WriteUInt32( Byte , UInt32, Int32) | Writes unsigned 32bit int to byte array
Back to Top
See Also
BinUtils Class
BinUtils Members
NFX.Serialization.BSON Namespace


BinUtils.WriteUInt32 Method (Stream, UInt32)

BinUtils WriteUInt32 Method (Stream, UInt32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes unsigned 32-bit int to stream

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteUInt32(
    Stream stream,
    uint value
)
public static void WriteUInt32(
    Stream stream,
    uint value
)
Public Shared Sub WriteUInt32 (
    stream As Stream,
    value As UInteger
)
Public Shared Sub WriteUInt32 (
    stream As Stream,
    value As UInteger
)
public:
static void WriteUInt32(
    Stream^ stream,
    unsigned int value
)
public:
static void WriteUInt32(
    Stream^ stream,
    unsigned int value
)
static member WriteUInt32 :
        stream : Stream *
        value : uint32 -> unit
static member WriteUInt32 :
        stream : Stream *
        value : uint32 -> unit

Parameters

stream
Type: Online System.IO Stream
value
Type: Online System UInt32
See Also
BinUtils Class
BinUtils Members
WriteUInt32 Overload
NFX.Serialization.BSON Namespace


BinUtils.WriteUInt32 Method (Byte[], UInt32, Int32)

BinUtils WriteUInt32 Method ( Byte , UInt32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes unsigned 32bit int to byte array

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteUInt32(
    byte[] buffer,
    uint value,
    int startIdx = 0
)
public static void WriteUInt32(
    byte[] buffer,
    uint value,
    int startIdx = 0
)
Public Shared Sub WriteUInt32 (
    buffer As Byte(),
    value As UInteger,
    Optional startIdx As Integer = 0
)
Public Shared Sub WriteUInt32 (
    buffer As Byte(),
    value As UInteger,
    Optional startIdx As Integer = 0
)
public:
static void WriteUInt32(
    array<unsigned char>^ buffer,
    unsigned int value,
    int startIdx = 0
)
public:
static void WriteUInt32(
    array<unsigned char>^ buffer,
    unsigned int value,
    int startIdx = 0
)
static member WriteUInt32 :
        buffer : byte[] *
        value : uint32 *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> unit
static member WriteUInt32 :
        buffer : byte[] *
        value : uint32 *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> unit

Parameters

buffer
Type: Online System Byte
value
Type: Online System UInt32
startIdx (Optional)
Type: Online System Int32
See Also
BinUtils Class
BinUtils Members
WriteUInt32 Overload
NFX.Serialization.BSON Namespace


BinUtils.WriteUInt64 Method

BinUtils WriteUInt64 Method NFX Class Library

Overload List
Name | Description
WriteUInt64(Stream, UInt64) | Writes unsigned 64-bit int to stream
WriteUInt64( Byte , UInt64, Int32) | Writes unsigned 64-bit int to byte array
Back to Top
See Also
BinUtils Class
BinUtils Members
NFX.Serialization.BSON Namespace


BinUtils.WriteUInt64 Method (Stream, UInt64)

BinUtils WriteUInt64 Method (Stream, UInt64) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes unsigned 64-bit int to stream

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteUInt64(
    Stream stream,
    ulong value
)
public static void WriteUInt64(
    Stream stream,
    ulong value
)
Public Shared Sub WriteUInt64 (
    stream As Stream,
    value As ULong
)
Public Shared Sub WriteUInt64 (
    stream As Stream,
    value As ULong
)
public:
static void WriteUInt64(
    Stream^ stream,
    unsigned long long value
)
public:
static void WriteUInt64(
    Stream^ stream,
    unsigned long long value
)
static member WriteUInt64 :
        stream : Stream *
        value : uint64 -> unit
static member WriteUInt64 :
        stream : Stream *
        value : uint64 -> unit

Parameters

stream
Type: Online System.IO Stream
value
Type: Online System UInt64
See Also
BinUtils Class
BinUtils Members
WriteUInt64 Overload
NFX.Serialization.BSON Namespace


BinUtils.WriteUInt64 Method (Byte[], UInt64, Int32)

BinUtils WriteUInt64 Method ( Byte , UInt64, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes unsigned 64-bit int to byte array

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteUInt64(
    byte[] buffer,
    ulong value,
    int startIdx = 0
)
public static void WriteUInt64(
    byte[] buffer,
    ulong value,
    int startIdx = 0
)
Public Shared Sub WriteUInt64 (
    buffer As Byte(),
    value As ULong,
    Optional startIdx As Integer = 0
)
Public Shared Sub WriteUInt64 (
    buffer As Byte(),
    value As ULong,
    Optional startIdx As Integer = 0
)
public:
static void WriteUInt64(
    array<unsigned char>^ buffer,
    unsigned long long value,
    int startIdx = 0
)
public:
static void WriteUInt64(
    array<unsigned char>^ buffer,
    unsigned long long value,
    int startIdx = 0
)
static member WriteUInt64 :
        buffer : byte[] *
        value : uint64 *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> unit
static member WriteUInt64 :
        buffer : byte[] *
        value : uint64 *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> unit

Parameters

buffer
Type: Online System Byte
value
Type: Online System UInt64
startIdx (Optional)
Type: Online System Int32
See Also
BinUtils Class
BinUtils Members
WriteUInt64 Overload
NFX.Serialization.BSON Namespace


BinUtils Properties

BinUtils Properties NFX Class Library

The BinUtils type exposes the following members.
Properties
Name | Description
UTF8Encoding |
Back to Top
See Also
BinUtils Class
NFX.Serialization.BSON Namespace


BinUtils.UTF8Encoding Property

BinUtils UTF8Encoding Property NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static UTF8Encoding UTF8Encoding { get; }
public static UTF8Encoding UTF8Encoding { get; }
Public Shared ReadOnly Property UTF8Encoding As UTF8Encoding
    Get
Public Shared ReadOnly Property UTF8Encoding As UTF8Encoding
    Get
public:
static property UTF8Encoding^ UTF8Encoding {
    UTF8Encoding^ get ();
}
public:
static property UTF8Encoding^ UTF8Encoding {
    UTF8Encoding^ get ();
}
static member UTF8Encoding : UTF8Encoding with get
static member UTF8Encoding : UTF8Encoding with get

Property Value

Type: Online UTF8Encoding
See Also
BinUtils Class
BinUtils Members
NFX.Serialization.BSON Namespace


BSONArrayElement Class

BSONArrayElement Class NFX Class Library

Represents a BSON array element with BSONElement[] value
Inheritance Hierarchy
Online System Object
NFX.Serialization.BSON BSONElement
NFX.Serialization.BSON BSONElement BSONElement
NFX.Serialization.BSON BSONArrayElement

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class BSONArrayElement : BSONElement<BSONElement[]>
public sealed class BSONArrayElement : BSONElement<BSONElement[]>
Public NotInheritable Class BSONArrayElement
    Inherits BSONElement(Of BSONElement())
Public NotInheritable Class BSONArrayElement
    Inherits BSONElement(Of BSONElement())
public ref class BSONArrayElement sealed : public BSONElement<array<BSONElement^>^>
public ref class BSONArrayElement sealed : public BSONElement<array<BSONElement^>^>
[<SealedAttribute>]
type BSONArrayElement =
    class
        inherit BSONElement<BSONElement[]>
    end
[<SealedAttribute>]
type BSONArrayElement =
    class
        inherit BSONElement<BSONElement[]>
    end
See Also
BSONArrayElement Members
NFX.Serialization.BSON Namespace


BSONArrayElement Members

BSONArrayElement Members NFX Class Library

The BSONArrayElement type exposes the following members.
Constructors
 | Name | Description
Protected method | BSONArrayElement(Stream) | Initializes a new instance of the BSONArrayElement class
Public method | BSONArrayElement( BSONElement ) | Creates an array element
Public method | BSONArrayElement(String, BSONElement ) | Initializes a new instance of the BSONArrayElement class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONArrayElement Class
NFX.Serialization.BSON Namespace


BSONArrayElement Constructor

BSONArrayElement Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | BSONArrayElement(Stream) | Initializes a new instance of the BSONArrayElement class
Public method | BSONArrayElement( BSONElement ) | Creates an array element
Public method | BSONArrayElement(String, BSONElement ) | Initializes a new instance of the BSONArrayElement class
Back to Top
See Also
BSONArrayElement Class
BSONArrayElement Members
NFX.Serialization.BSON Namespace


BSONArrayElement Constructor (Stream)

BSONArrayElement Constructor (Stream) NFX Class Library

Initializes a new instance of the BSONArrayElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal BSONArrayElement(
    Stream stream
)
internal BSONArrayElement(
    Stream stream
)
Friend Sub New (
    stream As Stream
)
Friend Sub New (
    stream As Stream
)
internal:
BSONArrayElement(
    Stream^ stream
)
internal:
BSONArrayElement(
    Stream^ stream
)
new :
        stream : Stream -> BSONArrayElement
new :
        stream : Stream -> BSONArrayElement

Parameters

stream
Type: Online System.IO Stream
See Also
BSONArrayElement Class
BSONArrayElement Members
BSONArrayElement Overload
NFX.Serialization.BSON Namespace


BSONArrayElement Constructor (BSONElement[])

BSONArrayElement Constructor ( BSONElement ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates an array element

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONArrayElement(
    BSONElement[] value
)
public BSONArrayElement(
    BSONElement[] value
)
Public Sub New (
    value As BSONElement()
)
Public Sub New (
    value As BSONElement()
)
public:
BSONArrayElement(
    array<BSONElement^>^ value
)
public:
BSONArrayElement(
    array<BSONElement^>^ value
)
new :
        value : BSONElement[] -> BSONArrayElement
new :
        value : BSONElement[] -> BSONArrayElement

Parameters

value
Type: NFX.Serialization.BSON BSONElement
See Also
BSONArrayElement Class
BSONArrayElement Members
BSONArrayElement Overload
NFX.Serialization.BSON Namespace


BSONArrayElement Constructor (String, BSONElement[])

BSONArrayElement Constructor (String, BSONElement ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BSONArrayElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONArrayElement(
    string name,
    BSONElement[] value
)
public BSONArrayElement(
    string name,
    BSONElement[] value
)
Public Sub New (
    name As String,
    value As BSONElement()
)
Public Sub New (
    name As String,
    value As BSONElement()
)
public:
BSONArrayElement(
    String^ name,
    array<BSONElement^>^ value
)
public:
BSONArrayElement(
    String^ name,
    array<BSONElement^>^ value
)
new :
        name : string *
        value : BSONElement[] -> BSONArrayElement
new :
        name : string *
        value : BSONElement[] -> BSONArrayElement

Parameters

name
Type: Online System String
value
Type: NFX.Serialization.BSON BSONElement
See Also
BSONArrayElement Class
BSONArrayElement Members
BSONArrayElement Overload
NFX.Serialization.BSON Namespace


BSONArrayElement Fields

BSONArrayElement Fields NFX Class Library

The BSONArrayElement type exposes the following members.
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONArrayElement Class
NFX.Serialization.BSON Namespace


BSONArrayElement Methods

BSONArrayElement Methods NFX Class Library

The BSONArrayElement type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BSONArrayElement Class
NFX.Serialization.BSON Namespace


BSONArrayElement.GetValueByteSize Method

BSONArrayElement GetValueByteSize Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override int GetValueByteSize()
protected internal override int GetValueByteSize()
Protected Friend Overrides Function GetValueByteSize As Integer
Protected Friend Overrides Function GetValueByteSize As Integer
protected public:
virtual int GetValueByteSize() override
protected public:
virtual int GetValueByteSize() override
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int

Return Value

Type: Online Int32
See Also
BSONArrayElement Class
BSONArrayElement Members
NFX.Serialization.BSON Namespace


BSONArrayElement.ReadValueFromStream Method

BSONArrayElement ReadValueFromStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void ReadValueFromStream(
    Stream stream
)
protected override void ReadValueFromStream(
    Stream stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONArrayElement Class
BSONArrayElement Members
NFX.Serialization.BSON Namespace


BSONArrayElement.WriteValueToStream Method

BSONArrayElement WriteValueToStream Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void WriteValueToStream(
    Stream stream
)
protected internal override void WriteValueToStream(
    Stream stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONArrayElement Class
BSONArrayElement Members
NFX.Serialization.BSON Namespace


BSONArrayElement Properties

BSONArrayElement Properties NFX Class Library

The BSONArrayElement type exposes the following members.
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONArrayElement Class
NFX.Serialization.BSON Namespace


BSONArrayElement.ElementType Property

BSONArrayElement ElementType Property NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override BSONElementType ElementType { get; }
public override BSONElementType ElementType { get; }
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get

Property Value

Type: BSONElementType
See Also
BSONArrayElement Class
BSONArrayElement Members
NFX.Serialization.BSON Namespace


BSONBinary Structure

BSONBinary Structure NFX Class Library

Represents a BSON bynary type

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct BSONBinary : IJSONWritable
public struct BSONBinary : IJSONWritable
Public Structure BSONBinary
    Implements IJSONWritable
Public Structure BSONBinary
    Implements IJSONWritable
public value class BSONBinary : IJSONWritable
public value class BSONBinary : IJSONWritable
[<SealedAttribute>]
type BSONBinary =
    struct
        interface IJSONWritable
    end
[<SealedAttribute>]
type BSONBinary =
    struct
        interface IJSONWritable
    end
See Also
BSONBinary Members
NFX.Serialization.BSON Namespace


BSONBinary Members

BSONBinary Members NFX Class Library

The BSONBinary type exposes the following members.
Constructors
 | Name | Description
Public method | BSONBinary | Initializes a new instance of the BSONBinary class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Public method | WriteAsJSON |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Data |
Public field | Type |
Back to Top
See Also
BSONBinary Structure
NFX.Serialization.BSON Namespace


BSONBinary Constructor

BSONBinary Constructor NFX Class Library

Initializes a new instance of the BSONBinary class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONBinary(
    BSONBinaryType type,
    byte[] data
)
public BSONBinary(
    BSONBinaryType type,
    byte[] data
)
Public Sub New (
    type As BSONBinaryType,
    data As Byte()
)
Public Sub New (
    type As BSONBinaryType,
    data As Byte()
)
public:
BSONBinary(
    BSONBinaryType type,
    array<unsigned char>^ data
)
public:
BSONBinary(
    BSONBinaryType type,
    array<unsigned char>^ data
)
new :
        type : BSONBinaryType *
        data : byte[] -> BSONBinary
new :
        type : BSONBinaryType *
        data : byte[] -> BSONBinary

Parameters

type
Type: NFX.Serialization.BSON BSONBinaryType
data
Type: Online System Byte
See Also
BSONBinary Structure
BSONBinary Members
NFX.Serialization.BSON Namespace


BSONBinary Fields

BSONBinary Fields NFX Class Library

The BSONBinary type exposes the following members.
Fields
 | Name | Description
Public field | Data |
Public field | Type |
Back to Top
See Also
BSONBinary Structure
NFX.Serialization.BSON Namespace


BSONBinary.Data Field

BSONBinary Data Field NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly byte[] Data
public readonly byte[] Data
Public ReadOnly Data As Byte()
Public ReadOnly Data As Byte()
public:
initonly array<unsigned char>^ Data
public:
initonly array<unsigned char>^ Data
val Data: byte[]
val Data: byte[]

Field Value

Type: Online Byte
See Also
BSONBinary Structure
BSONBinary Members
NFX.Serialization.BSON Namespace


BSONBinary.Type Field

BSONBinary Type Field NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly BSONBinaryType Type
public readonly BSONBinaryType Type
Public ReadOnly Type As BSONBinaryType
Public ReadOnly Type As BSONBinaryType
public:
initonly BSONBinaryType Type
public:
initonly BSONBinaryType Type
val Type: BSONBinaryType
val Type: BSONBinaryType

Field Value

Type: BSONBinaryType
See Also
BSONBinary Structure
BSONBinary Members
NFX.Serialization.BSON Namespace


BSONBinary Methods

BSONBinary Methods NFX Class Library

The BSONBinary type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Public method | WriteAsJSON |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BSONBinary Structure
NFX.Serialization.BSON Namespace


BSONBinary.WriteAsJSON Method

BSONBinary WriteAsJSON Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
nestingLevel
Type: Online System Int32
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Implements

IJSONWritable WriteAsJSON(TextWriter, Int32, JSONWritingOptions)
See Also
BSONBinary Structure
BSONBinary Members
NFX.Serialization.BSON Namespace


BSONBinaryElement Class

BSONBinaryElement Class NFX Class Library

Represents a BSON element with an BSONBinary value
Inheritance Hierarchy
Online System Object
NFX.Serialization.BSON BSONElement
NFX.Serialization.BSON BSONElement BSONBinary
NFX.Serialization.BSON BSONBinaryElement

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class BSONBinaryElement : BSONElement<BSONBinary>
public sealed class BSONBinaryElement : BSONElement<BSONBinary>
Public NotInheritable Class BSONBinaryElement
    Inherits BSONElement(Of BSONBinary)
Public NotInheritable Class BSONBinaryElement
    Inherits BSONElement(Of BSONBinary)
public ref class BSONBinaryElement sealed : public BSONElement<BSONBinary>
public ref class BSONBinaryElement sealed : public BSONElement<BSONBinary>
[<SealedAttribute>]
type BSONBinaryElement =
    class
        inherit BSONElement<BSONBinary>
    end
[<SealedAttribute>]
type BSONBinaryElement =
    class
        inherit BSONElement<BSONBinary>
    end
See Also
BSONBinaryElement Members
NFX.Serialization.BSON Namespace


BSONBinaryElement Members

BSONBinaryElement Members NFX Class Library

The BSONBinaryElement type exposes the following members.
Constructors
 | Name | Description
Protected method | BSONBinaryElement(Stream) | Initializes a new instance of the BSONBinaryElement class
Public method | BSONBinaryElement(BSONBinary) | Creates an array element
Public method | BSONBinaryElement(String, BSONBinary) | Initializes a new instance of the BSONBinaryElement class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONBinaryElement Class
NFX.Serialization.BSON Namespace


BSONBinaryElement Constructor

BSONBinaryElement Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | BSONBinaryElement(Stream) | Initializes a new instance of the BSONBinaryElement class
Public method | BSONBinaryElement(BSONBinary) | Creates an array element
Public method | BSONBinaryElement(String, BSONBinary) | Initializes a new instance of the BSONBinaryElement class
Back to Top
See Also
BSONBinaryElement Class
BSONBinaryElement Members
NFX.Serialization.BSON Namespace


BSONBinaryElement Constructor (Stream)

BSONBinaryElement Constructor (Stream) NFX Class Library

Initializes a new instance of the BSONBinaryElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal BSONBinaryElement(
    Stream stream
)
internal BSONBinaryElement(
    Stream stream
)
Friend Sub New (
    stream As Stream
)
Friend Sub New (
    stream As Stream
)
internal:
BSONBinaryElement(
    Stream^ stream
)
internal:
BSONBinaryElement(
    Stream^ stream
)
new :
        stream : Stream -> BSONBinaryElement
new :
        stream : Stream -> BSONBinaryElement

Parameters

stream
Type: Online System.IO Stream
See Also
BSONBinaryElement Class
BSONBinaryElement Members
BSONBinaryElement Overload
NFX.Serialization.BSON Namespace


BSONBinaryElement Constructor (BSONBinary)

BSONBinaryElement Constructor (BSONBinary) NFX Class Library

Creates an array element

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONBinaryElement(
    BSONBinary value
)
public BSONBinaryElement(
    BSONBinary value
)
Public Sub New (
    value As BSONBinary
)
Public Sub New (
    value As BSONBinary
)
public:
BSONBinaryElement(
    BSONBinary value
)
public:
BSONBinaryElement(
    BSONBinary value
)
new :
        value : BSONBinary -> BSONBinaryElement
new :
        value : BSONBinary -> BSONBinaryElement

Parameters

value
Type: NFX.Serialization.BSON BSONBinary
See Also
BSONBinaryElement Class
BSONBinaryElement Members
BSONBinaryElement Overload
NFX.Serialization.BSON Namespace


BSONBinaryElement Constructor (String, BSONBinary)

BSONBinaryElement Constructor (String, BSONBinary) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BSONBinaryElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONBinaryElement(
    string name,
    BSONBinary value
)
public BSONBinaryElement(
    string name,
    BSONBinary value
)
Public Sub New (
    name As String,
    value As BSONBinary
)
Public Sub New (
    name As String,
    value As BSONBinary
)
public:
BSONBinaryElement(
    String^ name,
    BSONBinary value
)
public:
BSONBinaryElement(
    String^ name,
    BSONBinary value
)
new :
        name : string *
        value : BSONBinary -> BSONBinaryElement
new :
        name : string *
        value : BSONBinary -> BSONBinaryElement

Parameters

name
Type: Online System String
value
Type: NFX.Serialization.BSON BSONBinary
See Also
BSONBinaryElement Class
BSONBinaryElement Members
BSONBinaryElement Overload
NFX.Serialization.BSON Namespace


BSONBinaryElement Fields

BSONBinaryElement Fields NFX Class Library

The BSONBinaryElement type exposes the following members.
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONBinaryElement Class
NFX.Serialization.BSON Namespace


BSONBinaryElement Methods

BSONBinaryElement Methods NFX Class Library

The BSONBinaryElement type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BSONBinaryElement Class
NFX.Serialization.BSON Namespace


BSONBinaryElement.GetValueByteSize Method

BSONBinaryElement GetValueByteSize Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override int GetValueByteSize()
protected internal override int GetValueByteSize()
Protected Friend Overrides Function GetValueByteSize As Integer
Protected Friend Overrides Function GetValueByteSize As Integer
protected public:
virtual int GetValueByteSize() override
protected public:
virtual int GetValueByteSize() override
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int

Return Value

Type: Online Int32
See Also
BSONBinaryElement Class
BSONBinaryElement Members
NFX.Serialization.BSON Namespace


BSONBinaryElement.ReadValueFromStream Method

BSONBinaryElement ReadValueFromStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void ReadValueFromStream(
    Stream stream
)
protected override void ReadValueFromStream(
    Stream stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONBinaryElement Class
BSONBinaryElement Members
NFX.Serialization.BSON Namespace


BSONBinaryElement.WriteValueToStream Method

BSONBinaryElement WriteValueToStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void WriteValueToStream(
    Stream stream
)
protected internal override void WriteValueToStream(
    Stream stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONBinaryElement Class
BSONBinaryElement Members
NFX.Serialization.BSON Namespace


BSONBinaryElement Properties

BSONBinaryElement Properties NFX Class Library

The BSONBinaryElement type exposes the following members.
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONBinaryElement Class
NFX.Serialization.BSON Namespace


BSONBinaryElement.ElementType Property

BSONBinaryElement ElementType Property NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override BSONElementType ElementType { get; }
public override BSONElementType ElementType { get; }
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get

Property Value

Type: BSONElementType
See Also
BSONBinaryElement Class
BSONBinaryElement Members
NFX.Serialization.BSON Namespace


BSONBinaryType Enumeration

BSONBinaryType Enumeration NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum BSONBinaryType
public enum BSONBinaryType
Public Enumeration BSONBinaryType
Public Enumeration BSONBinaryType
public enum class BSONBinaryType
public enum class BSONBinaryType
type BSONBinaryType
type BSONBinaryType
Members
Member name | Value | Description
GenericBinary | 0 |
Function | 1 |
BinaryOld | 2 |
UUIDOld | 3 |
UUID | 4 |
MD5 | 5 |
UserDefined | 128 |
See Also
NFX.Serialization.BSON Namespace


BSONBoolean Enumeration

BSONBoolean Enumeration NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum BSONBoolean
public enum BSONBoolean
Public Enumeration BSONBoolean
Public Enumeration BSONBoolean
public enum class BSONBoolean
public enum class BSONBoolean
type BSONBoolean
type BSONBoolean
Members
Member name | Value | Description
True | 1 |
False | 0 |
See Also
NFX.Serialization.BSON Namespace


BSONBooleanElement Class

BSONBooleanElement Class NFX Class Library

Represents a BSON element with an bool value
Inheritance Hierarchy
Online System Object
NFX.Serialization.BSON BSONElement
NFX.Serialization.BSON BSONElement Online Boolean
NFX.Serialization.BSON BSONBooleanElement

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class BSONBooleanElement : BSONElement<bool>
public sealed class BSONBooleanElement : BSONElement<bool>
Public NotInheritable Class BSONBooleanElement
    Inherits BSONElement(Of Boolean)
Public NotInheritable Class BSONBooleanElement
    Inherits BSONElement(Of Boolean)
public ref class BSONBooleanElement sealed : public BSONElement<bool>
public ref class BSONBooleanElement sealed : public BSONElement<bool>
[<SealedAttribute>]
type BSONBooleanElement =
    class
        inherit BSONElement<bool>
    end
[<SealedAttribute>]
type BSONBooleanElement =
    class
        inherit BSONElement<bool>
    end
See Also
BSONBooleanElement Members
NFX.Serialization.BSON Namespace


BSONBooleanElement Members

BSONBooleanElement Members NFX Class Library

The BSONBooleanElement type exposes the following members.
Constructors
 | Name | Description
Public method | BSONBooleanElement(Boolean) | Creates an array element
Protected method | BSONBooleanElement(Stream) | Initializes a new instance of the BSONBooleanElement class
Public method | BSONBooleanElement(String, Boolean) | Initializes a new instance of the BSONBooleanElement class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONBooleanElement Class
NFX.Serialization.BSON Namespace


BSONBooleanElement Constructor

BSONBooleanElement Constructor NFX Class Library

Overload List
 | Name | Description
Public method | BSONBooleanElement(Boolean) | Creates an array element
Protected method | BSONBooleanElement(Stream) | Initializes a new instance of the BSONBooleanElement class
Public method | BSONBooleanElement(String, Boolean) | Initializes a new instance of the BSONBooleanElement class
Back to Top
See Also
BSONBooleanElement Class
BSONBooleanElement Members
NFX.Serialization.BSON Namespace


BSONBooleanElement Constructor (Boolean)

BSONBooleanElement Constructor (Boolean) NFX Class Library

Creates an array element

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONBooleanElement(
    bool value
)
public BSONBooleanElement(
    bool value
)
Public Sub New (
    value As Boolean
)
Public Sub New (
    value As Boolean
)
public:
BSONBooleanElement(
    bool value
)
public:
BSONBooleanElement(
    bool value
)
new :
        value : bool -> BSONBooleanElement
new :
        value : bool -> BSONBooleanElement

Parameters

value
Type: Online System Boolean
See Also
BSONBooleanElement Class
BSONBooleanElement Members
BSONBooleanElement Overload
NFX.Serialization.BSON Namespace


BSONBooleanElement Constructor (Stream)

BSONBooleanElement Constructor (Stream) NFX Class Library

Initializes a new instance of the BSONBooleanElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal BSONBooleanElement(
    Stream stream
)
internal BSONBooleanElement(
    Stream stream
)
Friend Sub New (
    stream As Stream
)
Friend Sub New (
    stream As Stream
)
internal:
BSONBooleanElement(
    Stream^ stream
)
internal:
BSONBooleanElement(
    Stream^ stream
)
new :
        stream : Stream -> BSONBooleanElement
new :
        stream : Stream -> BSONBooleanElement

Parameters

stream
Type: Online System.IO Stream
See Also
BSONBooleanElement Class
BSONBooleanElement Members
BSONBooleanElement Overload
NFX.Serialization.BSON Namespace


BSONBooleanElement Constructor (String, Boolean)

BSONBooleanElement Constructor (String, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BSONBooleanElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONBooleanElement(
    string name,
    bool value
)
public BSONBooleanElement(
    string name,
    bool value
)
Public Sub New (
    name As String,
    value As Boolean
)
Public Sub New (
    name As String,
    value As Boolean
)
public:
BSONBooleanElement(
    String^ name,
    bool value
)
public:
BSONBooleanElement(
    String^ name,
    bool value
)
new :
        name : string *
        value : bool -> BSONBooleanElement
new :
        name : string *
        value : bool -> BSONBooleanElement

Parameters

name
Type: Online System String
value
Type: Online System Boolean
See Also
BSONBooleanElement Class
BSONBooleanElement Members
BSONBooleanElement Overload
NFX.Serialization.BSON Namespace


BSONBooleanElement Fields

BSONBooleanElement Fields NFX Class Library

The BSONBooleanElement type exposes the following members.
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONBooleanElement Class
NFX.Serialization.BSON Namespace


BSONBooleanElement Methods

BSONBooleanElement Methods NFX Class Library

The BSONBooleanElement type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BSONBooleanElement Class
NFX.Serialization.BSON Namespace


BSONBooleanElement.GetValueByteSize Method

BSONBooleanElement GetValueByteSize Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override int GetValueByteSize()
protected internal override int GetValueByteSize()
Protected Friend Overrides Function GetValueByteSize As Integer
Protected Friend Overrides Function GetValueByteSize As Integer
protected public:
virtual int GetValueByteSize() override
protected public:
virtual int GetValueByteSize() override
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int

Return Value

Type: Online Int32
See Also
BSONBooleanElement Class
BSONBooleanElement Members
NFX.Serialization.BSON Namespace


BSONBooleanElement.ReadValueFromStream Method

BSONBooleanElement ReadValueFromStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void ReadValueFromStream(
    Stream stream
)
protected override void ReadValueFromStream(
    Stream stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONBooleanElement Class
BSONBooleanElement Members
NFX.Serialization.BSON Namespace


BSONBooleanElement.WriteValueToStream Method

BSONBooleanElement WriteValueToStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void WriteValueToStream(
    Stream stream
)
protected internal override void WriteValueToStream(
    Stream stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONBooleanElement Class
BSONBooleanElement Members
NFX.Serialization.BSON Namespace


BSONBooleanElement Properties

BSONBooleanElement Properties NFX Class Library

The BSONBooleanElement type exposes the following members.
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONBooleanElement Class
NFX.Serialization.BSON Namespace


BSONBooleanElement.ElementType Property

BSONBooleanElement ElementType Property NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override BSONElementType ElementType { get; }
public override BSONElementType ElementType { get; }
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get

Property Value

Type: BSONElementType
See Also
BSONBooleanElement Class
BSONBooleanElement Members
NFX.Serialization.BSON Namespace


BSONCodeWithScope Structure

BSONCodeWithScope Structure NFX Class Library

Represents a BSON javascript with the scope type

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct BSONCodeWithScope : IJSONWritable
public struct BSONCodeWithScope : IJSONWritable
Public Structure BSONCodeWithScope
    Implements IJSONWritable
Public Structure BSONCodeWithScope
    Implements IJSONWritable
public value class BSONCodeWithScope : IJSONWritable
public value class BSONCodeWithScope : IJSONWritable
[<SealedAttribute>]
type BSONCodeWithScope =
    struct
        interface IJSONWritable
    end
[<SealedAttribute>]
type BSONCodeWithScope =
    struct
        interface IJSONWritable
    end
See Also
BSONCodeWithScope Members
NFX.Serialization.BSON Namespace


BSONCodeWithScope Members

BSONCodeWithScope Members NFX Class Library

The BSONCodeWithScope type exposes the following members.
Constructors
 | Name | Description
Public method | BSONCodeWithScope | Initializes a new instance of the BSONCodeWithScope class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Public method | WriteAsJSON |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Code |
Public field | Scope |
Back to Top
See Also
BSONCodeWithScope Structure
NFX.Serialization.BSON Namespace


BSONCodeWithScope Constructor

BSONCodeWithScope Constructor NFX Class Library

Initializes a new instance of the BSONCodeWithScope class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONCodeWithScope(
    string code,
    BSONDocument scope
)
public BSONCodeWithScope(
    string code,
    BSONDocument scope
)
Public Sub New (
    code As String,
    scope As BSONDocument
)
Public Sub New (
    code As String,
    scope As BSONDocument
)
public:
BSONCodeWithScope(
    String^ code,
    BSONDocument^ scope
)
public:
BSONCodeWithScope(
    String^ code,
    BSONDocument^ scope
)
new :
        code : string *
        scope : BSONDocument -> BSONCodeWithScope
new :
        code : string *
        scope : BSONDocument -> BSONCodeWithScope

Parameters

code
Type: Online System String
scope
Type: NFX.Serialization.BSON BSONDocument
See Also
BSONCodeWithScope Structure
BSONCodeWithScope Members
NFX.Serialization.BSON Namespace


BSONCodeWithScope Fields

BSONCodeWithScope Fields NFX Class Library

The BSONCodeWithScope type exposes the following members.
Fields
 | Name | Description
Public field | Code |
Public field | Scope |
Back to Top
See Also
BSONCodeWithScope Structure
NFX.Serialization.BSON Namespace


BSONCodeWithScope.Code Field

BSONCodeWithScope Code Field NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Code
public readonly string Code
Public ReadOnly Code As String
Public ReadOnly Code As String
public:
initonly String^ Code
public:
initonly String^ Code
val Code: string
val Code: string

Field Value

Type: Online String
See Also
BSONCodeWithScope Structure
BSONCodeWithScope Members
NFX.Serialization.BSON Namespace


BSONCodeWithScope.Scope Field

BSONCodeWithScope Scope Field NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly BSONDocument Scope
public readonly BSONDocument Scope
Public ReadOnly Scope As BSONDocument
Public ReadOnly Scope As BSONDocument
public:
initonly BSONDocument^ Scope
public:
initonly BSONDocument^ Scope
val Scope: BSONDocument
val Scope: BSONDocument

Field Value

Type: BSONDocument
See Also
BSONCodeWithScope Structure
BSONCodeWithScope Members
NFX.Serialization.BSON Namespace


BSONCodeWithScope Methods

BSONCodeWithScope Methods NFX Class Library

The BSONCodeWithScope type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Public method | WriteAsJSON |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BSONCodeWithScope Structure
NFX.Serialization.BSON Namespace


BSONCodeWithScope.WriteAsJSON Method

BSONCodeWithScope WriteAsJSON Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
nestingLevel
Type: Online System Int32
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Implements

IJSONWritable WriteAsJSON(TextWriter, Int32, JSONWritingOptions)
See Also
BSONCodeWithScope Structure
BSONCodeWithScope Members
NFX.Serialization.BSON Namespace


BSONDateTimeElement Class

BSONDateTimeElement Class NFX Class Library

Represents a BSON element with an UTC DateTime value
Inheritance Hierarchy
Online System Object
NFX.Serialization.BSON BSONElement
NFX.Serialization.BSON BSONElement Online DateTime
NFX.Serialization.BSON BSONDateTimeElement

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class BSONDateTimeElement : BSONElement<DateTime>
public sealed class BSONDateTimeElement : BSONElement<DateTime>
Public NotInheritable Class BSONDateTimeElement
    Inherits BSONElement(Of DateTime)
Public NotInheritable Class BSONDateTimeElement
    Inherits BSONElement(Of DateTime)
public ref class BSONDateTimeElement sealed : public BSONElement<DateTime>
public ref class BSONDateTimeElement sealed : public BSONElement<DateTime>
[<SealedAttribute>]
type BSONDateTimeElement =
    class
        inherit BSONElement<DateTime>
    end
[<SealedAttribute>]
type BSONDateTimeElement =
    class
        inherit BSONElement<DateTime>
    end
See Also
BSONDateTimeElement Members
NFX.Serialization.BSON Namespace


BSONDateTimeElement Members

BSONDateTimeElement Members NFX Class Library

The BSONDateTimeElement type exposes the following members.
Constructors
 | Name | Description
Public method | BSONDateTimeElement(DateTime) | Creates an array element
Protected method | BSONDateTimeElement(Stream) | Initializes a new instance of the BSONDateTimeElement class
Public method | BSONDateTimeElement(String, DateTime) | Initializes a new instance of the BSONDateTimeElement class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Overrides BSONElement WriteAsJSON(TextWriter, Int32, JSONWritingOptions).)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONDateTimeElement Class
NFX.Serialization.BSON Namespace


BSONDateTimeElement Constructor

BSONDateTimeElement Constructor NFX Class Library

Overload List
 | Name | Description
Public method | BSONDateTimeElement(DateTime) | Creates an array element
Protected method | BSONDateTimeElement(Stream) | Initializes a new instance of the BSONDateTimeElement class
Public method | BSONDateTimeElement(String, DateTime) | Initializes a new instance of the BSONDateTimeElement class
Back to Top
See Also
BSONDateTimeElement Class
BSONDateTimeElement Members
NFX.Serialization.BSON Namespace


BSONDateTimeElement Constructor (DateTime)

BSONDateTimeElement Constructor (DateTime) NFX Class Library

Creates an array element

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONDateTimeElement(
    DateTime value
)
public BSONDateTimeElement(
    DateTime value
)
Public Sub New (
    value As DateTime
)
Public Sub New (
    value As DateTime
)
public:
BSONDateTimeElement(
    DateTime value
)
public:
BSONDateTimeElement(
    DateTime value
)
new :
        value : DateTime -> BSONDateTimeElement
new :
        value : DateTime -> BSONDateTimeElement

Parameters

value
Type: Online System DateTime
See Also
BSONDateTimeElement Class
BSONDateTimeElement Members
BSONDateTimeElement Overload
NFX.Serialization.BSON Namespace


BSONDateTimeElement Constructor (Stream)

BSONDateTimeElement Constructor (Stream) NFX Class Library

Initializes a new instance of the BSONDateTimeElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal BSONDateTimeElement(
    Stream stream
)
internal BSONDateTimeElement(
    Stream stream
)
Friend Sub New (
    stream As Stream
)
Friend Sub New (
    stream As Stream
)
internal:
BSONDateTimeElement(
    Stream^ stream
)
internal:
BSONDateTimeElement(
    Stream^ stream
)
new :
        stream : Stream -> BSONDateTimeElement
new :
        stream : Stream -> BSONDateTimeElement

Parameters

stream
Type: Online System.IO Stream
See Also
BSONDateTimeElement Class
BSONDateTimeElement Members
BSONDateTimeElement Overload
NFX.Serialization.BSON Namespace


BSONDateTimeElement Constructor (String, DateTime)

BSONDateTimeElement Constructor (String, DateTime) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BSONDateTimeElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONDateTimeElement(
    string name,
    DateTime value
)
public BSONDateTimeElement(
    string name,
    DateTime value
)
Public Sub New (
    name As String,
    value As DateTime
)
Public Sub New (
    name As String,
    value As DateTime
)
public:
BSONDateTimeElement(
    String^ name,
    DateTime value
)
public:
BSONDateTimeElement(
    String^ name,
    DateTime value
)
new :
        name : string *
        value : DateTime -> BSONDateTimeElement
new :
        name : string *
        value : DateTime -> BSONDateTimeElement

Parameters

name
Type: Online System String
value
Type: Online System DateTime
See Also
BSONDateTimeElement Class
BSONDateTimeElement Members
BSONDateTimeElement Overload
NFX.Serialization.BSON Namespace


BSONDateTimeElement Fields

BSONDateTimeElement Fields NFX Class Library

The BSONDateTimeElement type exposes the following members.
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONDateTimeElement Class
NFX.Serialization.BSON Namespace


BSONDateTimeElement Methods

BSONDateTimeElement Methods NFX Class Library

The BSONDateTimeElement type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Overrides BSONElement WriteAsJSON(TextWriter, Int32, JSONWritingOptions).)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BSONDateTimeElement Class
NFX.Serialization.BSON Namespace


BSONDateTimeElement.GetValueByteSize Method

BSONDateTimeElement GetValueByteSize Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override int GetValueByteSize()
protected internal override int GetValueByteSize()
Protected Friend Overrides Function GetValueByteSize As Integer
Protected Friend Overrides Function GetValueByteSize As Integer
protected public:
virtual int GetValueByteSize() override
protected public:
virtual int GetValueByteSize() override
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int

Return Value

Type: Online Int32
See Also
BSONDateTimeElement Class
BSONDateTimeElement Members
NFX.Serialization.BSON Namespace


BSONDateTimeElement.ReadValueFromStream Method

BSONDateTimeElement ReadValueFromStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void ReadValueFromStream(
    Stream stream
)
protected override void ReadValueFromStream(
    Stream stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONDateTimeElement Class
BSONDateTimeElement Members
NFX.Serialization.BSON Namespace


BSONDateTimeElement.WriteAsJSON Method

BSONDateTimeElement WriteAsJSON Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
public override void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
Public Overrides Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
Public Overrides Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) override
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) override
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
nestingLevel
Type: Online System Int32
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Implements

IJSONWritable WriteAsJSON(TextWriter, Int32, JSONWritingOptions)
See Also
BSONDateTimeElement Class
BSONDateTimeElement Members
NFX.Serialization.BSON Namespace


BSONDateTimeElement.WriteValueToStream Method

BSONDateTimeElement WriteValueToStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void WriteValueToStream(
    Stream stream
)
protected internal override void WriteValueToStream(
    Stream stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONDateTimeElement Class
BSONDateTimeElement Members
NFX.Serialization.BSON Namespace


BSONDateTimeElement Properties

BSONDateTimeElement Properties NFX Class Library

The BSONDateTimeElement type exposes the following members.
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONDateTimeElement Class
NFX.Serialization.BSON Namespace


BSONDateTimeElement.ElementType Property

BSONDateTimeElement ElementType Property NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override BSONElementType ElementType { get; }
public override BSONElementType ElementType { get; }
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get

Property Value

Type: BSONElementType
See Also
BSONDateTimeElement Class
BSONDateTimeElement Members
NFX.Serialization.BSON Namespace


BSONDocument Class

BSONDocument Class NFX Class Library

Represents a BSON document
Inheritance Hierarchy
Online System Object
NFX.Serialization.BSON BSONDocument
NFX.DataAccess.MongoDB.Connector Query
NFX.DataAccess.MongoDB.Connector Update

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class BSONDocument : IJSONWritable,
    IEnumerable<BSONElement>, IEnumerable
public class BSONDocument : IJSONWritable,
    IEnumerable<BSONElement>, IEnumerable
Public Class BSONDocument
    Implements IJSONWritable, IEnumerable(Of BSONElement),
    IEnumerable
Public Class BSONDocument
    Implements IJSONWritable, IEnumerable(Of BSONElement),
    IEnumerable
public ref class BSONDocument : IJSONWritable,
    IEnumerable<BSONElement^>, IEnumerable
public ref class BSONDocument : IJSONWritable,
    IEnumerable<BSONElement^>, IEnumerable
type BSONDocument =
    class
        interface IJSONWritable
        interface IEnumerable<BSONElement>
        interface IEnumerable
    end
type BSONDocument =
    class
        interface IJSONWritable
        interface IEnumerable<BSONElement>
        interface IEnumerable
    end
See Also
BSONDocument Members
NFX.Serialization.BSON Namespace


BSONDocument Members

BSONDocument Members NFX Class Library

The BSONDocument type exposes the following members.
Constructors
 | Name | Description
Public method | BSONDocument | Create an empty document
Public method | BSONDocument(Stream) | Deserializes BSON document from stream containing BSON-encoded data
Public method | BSONDocument(String, Boolean, TemplateArg ) | Creates an instance of the document from JSON template with parameters populated from args optionally caching the template internal representation. Do not cache templates that change often
Back to Top
Methods
 | Name | Description
Public method | Delete | Deletes an element by name returning true if it was found and deleted
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | FromArray | Creates document from array containing BSON-encoded data
Protected method | GetByteSize | Calculates the BSON binary size of this document expressed in bytes
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IndexOfName | Returns index of named BSONElement or -1 if it does not exist
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Set(BSONElement, Int32) | Inserts BSONElement into document
Public method | Set(BSONElement, Boolean , Int32) | Inserts BSONElement into document
Public method | ToString | (Overrides Online Object ToString .)
Public method | WriteAsBSON | Serializes this document into BSON-format stream
Protected method | WriteAsBSONCore |
Public method | WriteAsBSONToNewArray | Serializes BSON document to byte[]
Public method | WriteAsJSON | Serializes this dosument into a TextWriter - this method is used by JSON serializer(JSONWriter)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable BSONElement | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct BSONElement, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax BSONElement, TComparand (Func BSONElement, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax BSONElement, TComparand (Func BSONElement, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin BSONElement, TComparand (Func BSONElement, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin BSONElement, TComparand (Func BSONElement, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault BSONElement | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach BSONElement (Action BSONElement ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach BSONElement (Action BSONElement, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast BSONElement | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast BSONElement (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
ARG_TPL_PREFIX |
IDX_THRESHOLD |
Back to Top
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes
Public property | Count | Returns the number of BSONElements in this document
Public property | Item Int32 | Returns BSONElement by index or null if index is out of bounds
Public property | Item String | Returns BSONElement by name or null if not found
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
BSONDocument Class
NFX.Serialization.BSON Namespace


BSONDocument Constructor

BSONDocument Constructor NFX Class Library

Overload List
 | Name | Description
Public method | BSONDocument | Create an empty document
Public method | BSONDocument(Stream) | Deserializes BSON document from stream containing BSON-encoded data
Public method | BSONDocument(String, Boolean, TemplateArg ) | Creates an instance of the document from JSON template with parameters populated from args optionally caching the template internal representation. Do not cache templates that change often
Back to Top
See Also
BSONDocument Class
BSONDocument Members
NFX.Serialization.BSON Namespace


BSONDocument Constructor

BSONDocument Constructor NFX Class Library

Create an empty document

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONDocument()
public BSONDocument()
Public Sub New
Public Sub New
public:
BSONDocument()
public:
BSONDocument()
new : unit -> BSONDocument
new : unit -> BSONDocument
See Also
BSONDocument Class
BSONDocument Members
BSONDocument Overload
NFX.Serialization.BSON Namespace


BSONDocument Constructor (Stream)

BSONDocument Constructor (Stream) NFX Class Library

Deserializes BSON document from stream containing BSON-encoded data

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONDocument(
    Stream stream
)
public BSONDocument(
    Stream stream
)
Public Sub New (
    stream As Stream
)
Public Sub New (
    stream As Stream
)
public:
BSONDocument(
    Stream^ stream
)
public:
BSONDocument(
    Stream^ stream
)
new :
        stream : Stream -> BSONDocument
new :
        stream : Stream -> BSONDocument

Parameters

stream
Type: Online System.IO Stream
See Also
BSONDocument Class
BSONDocument Members
BSONDocument Overload
NFX.Serialization.BSON Namespace


BSONDocument Constructor (String, Boolean, TemplateArg[])

BSONDocument Constructor (String, Boolean, TemplateArg ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates an instance of the document from JSON template with parameters populated from args optionally caching the template internal representation. Do not cache templates that change often

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONDocument(
    string template,
    bool cacheTemplate,
    params TemplateArg[] args
)
public BSONDocument(
    string template,
    bool cacheTemplate,
    params TemplateArg[] args
)
Public Sub New (
    template As String,
    cacheTemplate As Boolean,
    ParamArray args As TemplateArg()
)
Public Sub New (
    template As String,
    cacheTemplate As Boolean,
    ParamArray args As TemplateArg()
)
public:
BSONDocument(
    String^ template,
    bool cacheTemplate,
    ... array<TemplateArg>^ args
)
public:
BSONDocument(
    String^ template,
    bool cacheTemplate,
    ... array<TemplateArg>^ args
)
new :
        template : string *
        cacheTemplate : bool *
        args : TemplateArg[] -> BSONDocument
new :
        template : string *
        cacheTemplate : bool *
        args : TemplateArg[] -> BSONDocument

Parameters

template
Type: Online System String
cacheTemplate
Type: Online System Boolean
args
Type: NFX.Serialization.BSON TemplateArg
See Also
BSONDocument Class
BSONDocument Members
BSONDocument Overload
NFX.Serialization.BSON Namespace


BSONDocument Fields

BSONDocument Fields NFX Class Library

The BSONDocument type exposes the following members.
Fields
Name | Description
ARG_TPL_PREFIX |
IDX_THRESHOLD |
Back to Top
See Also
BSONDocument Class
NFX.Serialization.BSON Namespace


BSONDocument.ARG_TPL_PREFIX Field

BSONDocument ARG_TPL_PREFIX Field NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string ARG_TPL_PREFIX
public const string ARG_TPL_PREFIX
Public Const ARG_TPL_PREFIX As String
Public Const ARG_TPL_PREFIX As String
public:
literal String^ ARG_TPL_PREFIX
public:
literal String^ ARG_TPL_PREFIX
static val mutable ARG_TPL_PREFIX: string
static val mutable ARG_TPL_PREFIX: string

Field Value

Type: Online String
See Also
BSONDocument Class
BSONDocument Members
NFX.Serialization.BSON Namespace


BSONDocument.IDX_THRESHOLD Field

BSONDocument IDX_THRESHOLD Field NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int IDX_THRESHOLD
public const int IDX_THRESHOLD
Public Const IDX_THRESHOLD As Integer
Public Const IDX_THRESHOLD As Integer
public:
literal int IDX_THRESHOLD
public:
literal int IDX_THRESHOLD
static val mutable IDX_THRESHOLD: int
static val mutable IDX_THRESHOLD: int

Field Value

Type: Online Int32
See Also
BSONDocument Class
BSONDocument Members
NFX.Serialization.BSON Namespace


BSONDocument Methods

BSONDocument Methods NFX Class Library

The BSONDocument type exposes the following members.
Methods
 | Name | Description
Public method | Delete | Deletes an element by name returning true if it was found and deleted
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | FromArray | Creates document from array containing BSON-encoded data
Protected method | GetByteSize | Calculates the BSON binary size of this document expressed in bytes
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IndexOfName | Returns index of named BSONElement or -1 if it does not exist
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Set(BSONElement, Int32) | Inserts BSONElement into document
Public method | Set(BSONElement, Boolean , Int32) | Inserts BSONElement into document
Public method | ToString | (Overrides Online Object ToString .)
Public method | WriteAsBSON | Serializes this document into BSON-format stream
Protected method | WriteAsBSONCore |
Public method | WriteAsBSONToNewArray | Serializes BSON document to byte[]
Public method | WriteAsJSON | Serializes this dosument into a TextWriter - this method is used by JSON serializer(JSONWriter)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable BSONElement | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct BSONElement, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax BSONElement, TComparand (Func BSONElement, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax BSONElement, TComparand (Func BSONElement, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin BSONElement, TComparand (Func BSONElement, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin BSONElement, TComparand (Func BSONElement, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault BSONElement | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach BSONElement (Action BSONElement ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach BSONElement (Action BSONElement, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast BSONElement | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast BSONElement (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
BSONDocument Class
NFX.Serialization.BSON Namespace


BSONDocument.IEnumerable.GetEnumerator Method

BSONDocument IEnumerable GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
BSONDocument Class
BSONDocument Members
NFX.Serialization.BSON Namespace


BSONDocument.Delete Method

BSONDocument Delete Method NFX Class Library

Deletes an element by name returning true if it was found and deleted

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Delete(
    string name
)
public bool Delete(
    string name
)
Public Function Delete (
    name As String
) As Boolean
Public Function Delete (
    name As String
) As Boolean
public:
bool Delete(
    String^ name
)
public:
bool Delete(
    String^ name
)
member Delete :
        name : string -> bool
member Delete :
        name : string -> bool

Parameters

name
Type: Online System String

Return Value

Type: Online Boolean
See Also
BSONDocument Class
BSONDocument Members
NFX.Serialization.BSON Namespace


BSONDocument.FromArray Method

BSONDocument FromArray Method NFX Class Library

Creates document from array containing BSON-encoded data

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static BSONDocument FromArray(
    byte[] content
)
public static BSONDocument FromArray(
    byte[] content
)
Public Shared Function FromArray (
    content As Byte()
) As BSONDocument
Public Shared Function FromArray (
    content As Byte()
) As BSONDocument
public:
static BSONDocument^ FromArray(
    array<unsigned char>^ content
)
public:
static BSONDocument^ FromArray(
    array<unsigned char>^ content
)
static member FromArray :
        content : byte[] -> BSONDocument
static member FromArray :
        content : byte[] -> BSONDocument

Parameters

content
Type: Online System Byte

Return Value

Type: BSONDocument
See Also
BSONDocument Class
BSONDocument Members
NFX.Serialization.BSON Namespace


BSONDocument.GetByteSize Method

BSONDocument GetByteSize Method NFX Class Library

Calculates the BSON binary size of this document expressed in bytes

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int GetByteSize(
    bool recalc
)
internal int GetByteSize(
    bool recalc
)
Friend Function GetByteSize (
    recalc As Boolean
) As Integer
Friend Function GetByteSize (
    recalc As Boolean
) As Integer
internal:
int GetByteSize(
    bool recalc
)
internal:
int GetByteSize(
    bool recalc
)
internal member GetByteSize :
        recalc : bool -> int
internal member GetByteSize :
        recalc : bool -> int

Parameters

recalc
Type: Online System Boolean

Return Value

Type: Online Int32
See Also
BSONDocument Class
BSONDocument Members
NFX.Serialization.BSON Namespace


BSONDocument.GetEnumerator Method

BSONDocument GetEnumerator Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<BSONElement> GetEnumerator()
public IEnumerator<BSONElement> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of BSONElement)
Public Function GetEnumerator As IEnumerator(Of BSONElement)
public:
virtual IEnumerator<BSONElement^>^ GetEnumerator() sealed
public:
virtual IEnumerator<BSONElement^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<BSONElement>
override GetEnumerator : unit -> IEnumerator<BSONElement>
abstract GetEnumerator : unit -> IEnumerator<BSONElement>
override GetEnumerator : unit -> IEnumerator<BSONElement>

Return Value

Type: Online IEnumerator BSONElement

Implements

Online IEnumerable T GetEnumerator
See Also
BSONDocument Class
BSONDocument Members
NFX.Serialization.BSON Namespace


BSONDocument.IndexOfName Method

BSONDocument IndexOfName Method NFX Class Library

Returns index of named BSONElement or -1 if it does not exist

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int IndexOfName(
    string name
)
public int IndexOfName(
    string name
)
Public Function IndexOfName (
    name As String
) As Integer
Public Function IndexOfName (
    name As String
) As Integer
public:
int IndexOfName(
    String^ name
)
public:
int IndexOfName(
    String^ name
)
member IndexOfName :
        name : string -> int
member IndexOfName :
        name : string -> int

Parameters

name
Type: Online System String

Return Value

Type: Online Int32
See Also
BSONDocument Class
BSONDocument Members
NFX.Serialization.BSON Namespace


BSONDocument.Set Method

BSONDocument Set Method NFX Class Library

Overload List
 | Name | Description
Public method | Set(BSONElement, Int32) | Inserts BSONElement into document
Public method | Set(BSONElement, Boolean , Int32) | Inserts BSONElement into document
Back to Top
See Also
BSONDocument Class
BSONDocument Members
NFX.Serialization.BSON Namespace


BSONDocument.Set Method (BSONElement, Int32)

BSONDocument Set Method (BSONElement, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Inserts BSONElement into document

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONDocument Set(
    BSONElement value,
    int atIndex = -1
)
public BSONDocument Set(
    BSONElement value,
    int atIndex = -1
)
Public Function Set (
    value As BSONElement,
    Optional atIndex As Integer = -1
) As BSONDocument
Public Function Set (
    value As BSONElement,
    Optional atIndex As Integer = -1
) As BSONDocument
public:
BSONDocument^ Set(
    BSONElement^ value,
    int atIndex = -1
)
public:
BSONDocument^ Set(
    BSONElement^ value,
    int atIndex = -1
)
member Set :
        value : BSONElement *
        ?atIndex : int
(* Defaults:
        let _atIndex = defaultArg atIndex -1
*)
-> BSONDocument
member Set :
        value : BSONElement *
        ?atIndex : int
(* Defaults:
        let _atIndex = defaultArg atIndex -1
*)
-> BSONDocument

Parameters

value
Type: NFX.Serialization.BSON BSONElement
atIndex (Optional)
Type: Online System Int32

Return Value

Type: BSONDocument
See Also
BSONDocument Class
BSONDocument Members
Set Overload
NFX.Serialization.BSON Namespace


BSONDocument.Set Method (BSONElement, Boolean, Int32)

BSONDocument Set Method (BSONElement, Boolean , Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Inserts BSONElement into document

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONDocument Set(
    BSONElement value,
    out bool added,
    int atIndex = -1
)
public BSONDocument Set(
    BSONElement value,
    out bool added,
    int atIndex = -1
)
Public Function Set (
    value As BSONElement,
    <OutAttribute> ByRef added As Boolean,
    Optional atIndex As Integer = -1
) As BSONDocument
Public Function Set (
    value As BSONElement,
    <OutAttribute> ByRef added As Boolean,
    Optional atIndex As Integer = -1
) As BSONDocument
public:
BSONDocument^ Set(
    BSONElement^ value,
    [OutAttribute] bool% added,
    int atIndex = -1
)
public:
BSONDocument^ Set(
    BSONElement^ value,
    [OutAttribute] bool% added,
    int atIndex = -1
)
member Set :
        value : BSONElement *
        added : bool byref *
        ?atIndex : int
(* Defaults:
        let _atIndex = defaultArg atIndex -1
*)
-> BSONDocument
member Set :
        value : BSONElement *
        added : bool byref *
        ?atIndex : int
(* Defaults:
        let _atIndex = defaultArg atIndex -1
*)
-> BSONDocument

Parameters

value
Type: NFX.Serialization.BSON BSONElement
added
Type: Online System Boolean
atIndex (Optional)
Type: Online System Int32

Return Value

Type: BSONDocument
See Also
BSONDocument Class
BSONDocument Members
Set Overload
NFX.Serialization.BSON Namespace


BSONDocument.ToString Method

BSONDocument ToString Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
BSONDocument Class
BSONDocument Members
NFX.Serialization.BSON Namespace


BSONDocument.WriteAsBSON Method

BSONDocument WriteAsBSON Method NFX Class Library

Serializes this document into BSON-format stream

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteAsBSON(
    Stream stream
)
public void WriteAsBSON(
    Stream stream
)
Public Sub WriteAsBSON (
    stream As Stream
)
Public Sub WriteAsBSON (
    stream As Stream
)
public:
void WriteAsBSON(
    Stream^ stream
)
public:
void WriteAsBSON(
    Stream^ stream
)
member WriteAsBSON :
        stream : Stream -> unit
member WriteAsBSON :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONDocument Class
BSONDocument Members
NFX.Serialization.BSON Namespace


BSONDocument.WriteAsBSONCore Method

BSONDocument WriteAsBSONCore Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void WriteAsBSONCore(
    Stream stream
)
internal void WriteAsBSONCore(
    Stream stream
)
Friend Sub WriteAsBSONCore (
    stream As Stream
)
Friend Sub WriteAsBSONCore (
    stream As Stream
)
internal:
void WriteAsBSONCore(
    Stream^ stream
)
internal:
void WriteAsBSONCore(
    Stream^ stream
)
internal member WriteAsBSONCore :
        stream : Stream -> unit
internal member WriteAsBSONCore :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONDocument Class
BSONDocument Members
NFX.Serialization.BSON Namespace


BSONDocument.WriteAsBSONToNewArray Method

BSONDocument WriteAsBSONToNewArray Method NFX Class Library

Serializes BSON document to byte[]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] WriteAsBSONToNewArray()
public byte[] WriteAsBSONToNewArray()
Public Function WriteAsBSONToNewArray As Byte()
Public Function WriteAsBSONToNewArray As Byte()
public:
array<unsigned char>^ WriteAsBSONToNewArray()
public:
array<unsigned char>^ WriteAsBSONToNewArray()
member WriteAsBSONToNewArray : unit -> byte[]
member WriteAsBSONToNewArray : unit -> byte[]

Return Value

Type: Online Byte
See Also
BSONDocument Class
BSONDocument Members
NFX.Serialization.BSON Namespace


BSONDocument.WriteAsJSON Method

BSONDocument WriteAsJSON Method NFX Class Library

Serializes this dosument into a TextWriter - this method is used by JSON serializer(JSONWriter)

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
nestingLevel
Type: Online System Int32
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Implements

IJSONWritable WriteAsJSON(TextWriter, Int32, JSONWritingOptions)
See Also
BSONDocument Class
BSONDocument Members
NFX.Serialization.BSON Namespace


BSONDocument Properties

BSONDocument Properties NFX Class Library

The BSONDocument type exposes the following members.
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes
Public property | Count | Returns the number of BSONElements in this document
Public property | Item Int32 | Returns BSONElement by index or null if index is out of bounds
Public property | Item String | Returns BSONElement by name or null if not found
Back to Top
See Also
BSONDocument Class
NFX.Serialization.BSON Namespace


BSONDocument.ByteSize Property

BSONDocument ByteSize Property NFX Class Library

Recalculates the BSON binary size of this document expressed in bytes

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ByteSize { get; }
public int ByteSize { get; }
Public ReadOnly Property ByteSize As Integer
    Get
Public ReadOnly Property ByteSize As Integer
    Get
public:
property int ByteSize {
    int get ();
}
public:
property int ByteSize {
    int get ();
}
member ByteSize : int with get
member ByteSize : int with get

Property Value

Type: Online Int32
See Also
BSONDocument Class
BSONDocument Members
NFX.Serialization.BSON Namespace


BSONDocument.Count Property

BSONDocument Count Property NFX Class Library

Returns the number of BSONElements in this document

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
public:
property int Count {
    int get ();
}
member Count : int with get
member Count : int with get

Property Value

Type: Online Int32
See Also
BSONDocument Class
BSONDocument Members
NFX.Serialization.BSON Namespace


BSONDocument.Item Property

BSONDocument Item Property NFX Class Library

Overload List
 | Name | Description
Public property | Item Int32 | Returns BSONElement by index or null if index is out of bounds
Public property | Item String | Returns BSONElement by name or null if not found
Back to Top
See Also
BSONDocument Class
BSONDocument Members
NFX.Serialization.BSON Namespace


BSONDocument.Item Property (Int32)

BSONDocument Item Property (Int32) NFX Class Library

Returns BSONElement by index or null if index is out of bounds

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONElement this[
    int idx
] { get; }
public BSONElement this[
    int idx
] { get; }
Public ReadOnly Default Property Item (
    idx As Integer
) As BSONElement
    Get
Public ReadOnly Default Property Item (
    idx As Integer
) As BSONElement
    Get
public:
property BSONElement^ default[int idx] {
    BSONElement^ get (int idx);
}
public:
property BSONElement^ default[int idx] {
    BSONElement^ get (int idx);
}
member Item : BSONElement with get
member Item : BSONElement with get

Parameters

idx
Type: Online System Int32

Property Value

Type: BSONElement
See Also
BSONDocument Class
BSONDocument Members
Item Overload
NFX.Serialization.BSON Namespace


BSONDocument.Item Property (String)

BSONDocument Item Property (String) NFX Class Library

Returns BSONElement by name or null if not found

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONElement this[
    string name
] { get; }
public BSONElement this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As BSONElement
    Get
Public ReadOnly Default Property Item (
    name As String
) As BSONElement
    Get
public:
property BSONElement^ default[String^ name] {
    BSONElement^ get (String^ name);
}
public:
property BSONElement^ default[String^ name] {
    BSONElement^ get (String^ name);
}
member Item : BSONElement with get
member Item : BSONElement with get

Parameters

name
Type: Online System String

Property Value

Type: BSONElement
See Also
BSONDocument Class
BSONDocument Members
Item Overload
NFX.Serialization.BSON Namespace


BSONDocumentElement Class

BSONDocumentElement Class NFX Class Library

Represents a BSON element with a BSON document value
Inheritance Hierarchy
Online System Object
NFX.Serialization.BSON BSONElement
NFX.Serialization.BSON BSONElement BSONDocument
NFX.Serialization.BSON BSONDocumentElement

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class BSONDocumentElement : BSONElement<BSONDocument>
public sealed class BSONDocumentElement : BSONElement<BSONDocument>
Public NotInheritable Class BSONDocumentElement
    Inherits BSONElement(Of BSONDocument)
Public NotInheritable Class BSONDocumentElement
    Inherits BSONElement(Of BSONDocument)
public ref class BSONDocumentElement sealed : public BSONElement<BSONDocument^>
public ref class BSONDocumentElement sealed : public BSONElement<BSONDocument^>
[<SealedAttribute>]
type BSONDocumentElement =
    class
        inherit BSONElement<BSONDocument>
    end
[<SealedAttribute>]
type BSONDocumentElement =
    class
        inherit BSONElement<BSONDocument>
    end
See Also
BSONDocumentElement Members
NFX.Serialization.BSON Namespace


BSONDocumentElement Members

BSONDocumentElement Members NFX Class Library

The BSONDocumentElement type exposes the following members.
Constructors
 | Name | Description
Protected method | BSONDocumentElement(Stream) | Initializes a new instance of the BSONDocumentElement class
Public method | BSONDocumentElement(BSONDocument) | Creates an array element
Public method | BSONDocumentElement(String, BSONDocument) | Initializes a new instance of the BSONDocumentElement class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONDocumentElement Class
NFX.Serialization.BSON Namespace


BSONDocumentElement Constructor

BSONDocumentElement Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | BSONDocumentElement(Stream) | Initializes a new instance of the BSONDocumentElement class
Public method | BSONDocumentElement(BSONDocument) | Creates an array element
Public method | BSONDocumentElement(String, BSONDocument) | Initializes a new instance of the BSONDocumentElement class
Back to Top
See Also
BSONDocumentElement Class
BSONDocumentElement Members
NFX.Serialization.BSON Namespace


BSONDocumentElement Constructor (Stream)

BSONDocumentElement Constructor (Stream) NFX Class Library

Initializes a new instance of the BSONDocumentElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal BSONDocumentElement(
    Stream stream
)
internal BSONDocumentElement(
    Stream stream
)
Friend Sub New (
    stream As Stream
)
Friend Sub New (
    stream As Stream
)
internal:
BSONDocumentElement(
    Stream^ stream
)
internal:
BSONDocumentElement(
    Stream^ stream
)
new :
        stream : Stream -> BSONDocumentElement
new :
        stream : Stream -> BSONDocumentElement

Parameters

stream
Type: Online System.IO Stream
See Also
BSONDocumentElement Class
BSONDocumentElement Members
BSONDocumentElement Overload
NFX.Serialization.BSON Namespace


BSONDocumentElement Constructor (BSONDocument)

BSONDocumentElement Constructor (BSONDocument) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates an array element

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONDocumentElement(
    BSONDocument value
)
public BSONDocumentElement(
    BSONDocument value
)
Public Sub New (
    value As BSONDocument
)
Public Sub New (
    value As BSONDocument
)
public:
BSONDocumentElement(
    BSONDocument^ value
)
public:
BSONDocumentElement(
    BSONDocument^ value
)
new :
        value : BSONDocument -> BSONDocumentElement
new :
        value : BSONDocument -> BSONDocumentElement

Parameters

value
Type: NFX.Serialization.BSON BSONDocument
See Also
BSONDocumentElement Class
BSONDocumentElement Members
BSONDocumentElement Overload
NFX.Serialization.BSON Namespace


BSONDocumentElement Constructor (String, BSONDocument)

BSONDocumentElement Constructor (String, BSONDocument) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BSONDocumentElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONDocumentElement(
    string name,
    BSONDocument value
)
public BSONDocumentElement(
    string name,
    BSONDocument value
)
Public Sub New (
    name As String,
    value As BSONDocument
)
Public Sub New (
    name As String,
    value As BSONDocument
)
public:
BSONDocumentElement(
    String^ name,
    BSONDocument^ value
)
public:
BSONDocumentElement(
    String^ name,
    BSONDocument^ value
)
new :
        name : string *
        value : BSONDocument -> BSONDocumentElement
new :
        name : string *
        value : BSONDocument -> BSONDocumentElement

Parameters

name
Type: Online System String
value
Type: NFX.Serialization.BSON BSONDocument
See Also
BSONDocumentElement Class
BSONDocumentElement Members
BSONDocumentElement Overload
NFX.Serialization.BSON Namespace


BSONDocumentElement Fields

BSONDocumentElement Fields NFX Class Library

The BSONDocumentElement type exposes the following members.
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONDocumentElement Class
NFX.Serialization.BSON Namespace


BSONDocumentElement Methods

BSONDocumentElement Methods NFX Class Library

The BSONDocumentElement type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BSONDocumentElement Class
NFX.Serialization.BSON Namespace


BSONDocumentElement.GetValueByteSize Method

BSONDocumentElement GetValueByteSize Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override int GetValueByteSize()
protected internal override int GetValueByteSize()
Protected Friend Overrides Function GetValueByteSize As Integer
Protected Friend Overrides Function GetValueByteSize As Integer
protected public:
virtual int GetValueByteSize() override
protected public:
virtual int GetValueByteSize() override
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int

Return Value

Type: Online Int32
See Also
BSONDocumentElement Class
BSONDocumentElement Members
NFX.Serialization.BSON Namespace


BSONDocumentElement.ReadValueFromStream Method

BSONDocumentElement ReadValueFromStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void ReadValueFromStream(
    Stream stream
)
protected override void ReadValueFromStream(
    Stream stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONDocumentElement Class
BSONDocumentElement Members
NFX.Serialization.BSON Namespace


BSONDocumentElement.WriteValueToStream Method

BSONDocumentElement WriteValueToStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void WriteValueToStream(
    Stream stream
)
protected internal override void WriteValueToStream(
    Stream stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONDocumentElement Class
BSONDocumentElement Members
NFX.Serialization.BSON Namespace


BSONDocumentElement Properties

BSONDocumentElement Properties NFX Class Library

The BSONDocumentElement type exposes the following members.
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONDocumentElement Class
NFX.Serialization.BSON Namespace


BSONDocumentElement.ElementType Property

BSONDocumentElement ElementType Property NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override BSONElementType ElementType { get; }
public override BSONElementType ElementType { get; }
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get

Property Value

Type: BSONElementType
See Also
BSONDocumentElement Class
BSONDocumentElement Members
NFX.Serialization.BSON Namespace


BSONDoubleElement Class

BSONDoubleElement Class NFX Class Library

Represents a BSON element with an int32 value
Inheritance Hierarchy
Online System Object
NFX.Serialization.BSON BSONElement
NFX.Serialization.BSON BSONElement Online Double
NFX.Serialization.BSON BSONDoubleElement

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class BSONDoubleElement : BSONElement<double>
public sealed class BSONDoubleElement : BSONElement<double>
Public NotInheritable Class BSONDoubleElement
    Inherits BSONElement(Of Double)
Public NotInheritable Class BSONDoubleElement
    Inherits BSONElement(Of Double)
public ref class BSONDoubleElement sealed : public BSONElement<double>
public ref class BSONDoubleElement sealed : public BSONElement<double>
[<SealedAttribute>]
type BSONDoubleElement =
    class
        inherit BSONElement<float>
    end
[<SealedAttribute>]
type BSONDoubleElement =
    class
        inherit BSONElement<float>
    end
See Also
BSONDoubleElement Members
NFX.Serialization.BSON Namespace


BSONDoubleElement Members

BSONDoubleElement Members NFX Class Library

The BSONDoubleElement type exposes the following members.
Constructors
 | Name | Description
Public method | BSONDoubleElement(Double) | Creates an array element
Protected method | BSONDoubleElement(Stream) | Initializes a new instance of the BSONDoubleElement class
Public method | BSONDoubleElement(String, Double) | Initializes a new instance of the BSONDoubleElement class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONDoubleElement Class
NFX.Serialization.BSON Namespace


BSONDoubleElement Constructor

BSONDoubleElement Constructor NFX Class Library

Overload List
 | Name | Description
Public method | BSONDoubleElement(Double) | Creates an array element
Protected method | BSONDoubleElement(Stream) | Initializes a new instance of the BSONDoubleElement class
Public method | BSONDoubleElement(String, Double) | Initializes a new instance of the BSONDoubleElement class
Back to Top
See Also
BSONDoubleElement Class
BSONDoubleElement Members
NFX.Serialization.BSON Namespace


BSONDoubleElement Constructor (Double)

BSONDoubleElement Constructor (Double) NFX Class Library

Creates an array element

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONDoubleElement(
    double value
)
public BSONDoubleElement(
    double value
)
Public Sub New (
    value As Double
)
Public Sub New (
    value As Double
)
public:
BSONDoubleElement(
    double value
)
public:
BSONDoubleElement(
    double value
)
new :
        value : float -> BSONDoubleElement
new :
        value : float -> BSONDoubleElement

Parameters

value
Type: Online System Double
See Also
BSONDoubleElement Class
BSONDoubleElement Members
BSONDoubleElement Overload
NFX.Serialization.BSON Namespace


BSONDoubleElement Constructor (Stream)

BSONDoubleElement Constructor (Stream) NFX Class Library

Initializes a new instance of the BSONDoubleElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal BSONDoubleElement(
    Stream stream
)
internal BSONDoubleElement(
    Stream stream
)
Friend Sub New (
    stream As Stream
)
Friend Sub New (
    stream As Stream
)
internal:
BSONDoubleElement(
    Stream^ stream
)
internal:
BSONDoubleElement(
    Stream^ stream
)
new :
        stream : Stream -> BSONDoubleElement
new :
        stream : Stream -> BSONDoubleElement

Parameters

stream
Type: Online System.IO Stream
See Also
BSONDoubleElement Class
BSONDoubleElement Members
BSONDoubleElement Overload
NFX.Serialization.BSON Namespace


BSONDoubleElement Constructor (String, Double)

BSONDoubleElement Constructor (String, Double) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BSONDoubleElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONDoubleElement(
    string name,
    double value
)
public BSONDoubleElement(
    string name,
    double value
)
Public Sub New (
    name As String,
    value As Double
)
Public Sub New (
    name As String,
    value As Double
)
public:
BSONDoubleElement(
    String^ name,
    double value
)
public:
BSONDoubleElement(
    String^ name,
    double value
)
new :
        name : string *
        value : float -> BSONDoubleElement
new :
        name : string *
        value : float -> BSONDoubleElement

Parameters

name
Type: Online System String
value
Type: Online System Double
See Also
BSONDoubleElement Class
BSONDoubleElement Members
BSONDoubleElement Overload
NFX.Serialization.BSON Namespace


BSONDoubleElement Fields

BSONDoubleElement Fields NFX Class Library

The BSONDoubleElement type exposes the following members.
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONDoubleElement Class
NFX.Serialization.BSON Namespace


BSONDoubleElement Methods

BSONDoubleElement Methods NFX Class Library

The BSONDoubleElement type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BSONDoubleElement Class
NFX.Serialization.BSON Namespace


BSONDoubleElement.GetValueByteSize Method

BSONDoubleElement GetValueByteSize Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override int GetValueByteSize()
protected internal override int GetValueByteSize()
Protected Friend Overrides Function GetValueByteSize As Integer
Protected Friend Overrides Function GetValueByteSize As Integer
protected public:
virtual int GetValueByteSize() override
protected public:
virtual int GetValueByteSize() override
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int

Return Value

Type: Online Int32
See Also
BSONDoubleElement Class
BSONDoubleElement Members
NFX.Serialization.BSON Namespace


BSONDoubleElement.ReadValueFromStream Method

BSONDoubleElement ReadValueFromStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void ReadValueFromStream(
    Stream stream
)
protected override void ReadValueFromStream(
    Stream stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONDoubleElement Class
BSONDoubleElement Members
NFX.Serialization.BSON Namespace


BSONDoubleElement.WriteValueToStream Method

BSONDoubleElement WriteValueToStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void WriteValueToStream(
    Stream stream
)
protected internal override void WriteValueToStream(
    Stream stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONDoubleElement Class
BSONDoubleElement Members
NFX.Serialization.BSON Namespace


BSONDoubleElement Properties

BSONDoubleElement Properties NFX Class Library

The BSONDoubleElement type exposes the following members.
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONDoubleElement Class
NFX.Serialization.BSON Namespace


BSONDoubleElement.ElementType Property

BSONDoubleElement ElementType Property NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override BSONElementType ElementType { get; }
public override BSONElementType ElementType { get; }
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get

Property Value

Type: BSONElementType
See Also
BSONDoubleElement Class
BSONDoubleElement Members
NFX.Serialization.BSON Namespace


BSONElement Class

BSONElement Class NFX Class Library

Very base class for BSON elements
Inheritance Hierarchy
Online System Object
NFX.Serialization.BSON BSONElement
NFX.Serialization.BSON BSONElement T
NFX.Serialization.BSON BSONMaxKeyElement
NFX.Serialization.BSON BSONMinKeyElement
NFX.Serialization.BSON BSONNullElement

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class BSONElement : INamed,
    IConvertible, IJSONWritable
public abstract class BSONElement : INamed,
    IConvertible, IJSONWritable
Public MustInherit Class BSONElement
    Implements INamed, IConvertible, IJSONWritable
Public MustInherit Class BSONElement
    Implements INamed, IConvertible, IJSONWritable
public ref class BSONElement abstract : INamed,
    IConvertible, IJSONWritable
public ref class BSONElement abstract : INamed,
    IConvertible, IJSONWritable
[<AbstractClassAttribute>]
type BSONElement =
    class
        interface INamed
        interface IConvertible
        interface IJSONWritable
    end
[<AbstractClassAttribute>]
type BSONElement =
    class
        interface INamed
        interface IConvertible
        interface IJSONWritable
    end
See Also
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement Members

BSONElement Members NFX Class Library

The BSONElement type exposes the following members.
Constructors
 | Name | Description
Protected method | BSONElement(Stream) | Initializes a new instance of the BSONElement class
Protected method | BSONElement(String) | Initializes a new instance of the BSONElement class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes
 | GetElementFactory |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode |
Protected method | GetValueByteSize | Returns the size of this element in bytes
 | MakeOfType |
Protected method | MarkAsArrayItem |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | Override to read element's value from stream
Public method | ToBoolean |
Public method | ToByte |
Public method | ToChar |
Public method | ToDateTime |
Public method | ToDecimal |
Public method | ToDouble |
Public method | ToInt16 |
Public method | ToInt32 |
Public method | ToInt64 |
Public method | ToSByte |
Public method | ToSingle |
Public method | ToString | (Overrides Online Object ToString .)
Public method | ToString(IFormatProvider) |
Public method | ToType |
Public method | ToUInt16 |
Public method | ToUInt32 |
Public method | ToUInt64 |
Public method | WriteAsJSON |
Protected method | WriteToStream | Write element to stream
Protected method | WriteValueToStream | Override to write this element into a stream
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes
Public property | ElementType | Provides BSON classification of data type
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements
Public property | ObjectValue | Gets/sets the value of this element polymorphically
Back to Top
See Also
BSONElement Class
NFX.Serialization.BSON Namespace


BSONElement Constructor

BSONElement Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | BSONElement(Stream) | Initializes a new instance of the BSONElement class
Protected method | BSONElement(String) | Initializes a new instance of the BSONElement class
Back to Top
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement Constructor (Stream)

BSONElement Constructor (Stream) NFX Class Library

Initializes a new instance of the BSONElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected BSONElement(
    Stream stream
)
protected BSONElement(
    Stream stream
)
Protected Sub New (
    stream As Stream
)
Protected Sub New (
    stream As Stream
)
protected:
BSONElement(
    Stream^ stream
)
protected:
BSONElement(
    Stream^ stream
)
new :
        stream : Stream -> BSONElement
new :
        stream : Stream -> BSONElement

Parameters

stream
Type: Online System.IO Stream
See Also
BSONElement Class
BSONElement Members
BSONElement Overload
NFX.Serialization.BSON Namespace


BSONElement Constructor (String)

BSONElement Constructor (String) NFX Class Library

Initializes a new instance of the BSONElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected BSONElement(
    string name
)
protected BSONElement(
    string name
)
Protected Sub New (
    name As String
)
Protected Sub New (
    name As String
)
protected:
BSONElement(
    String^ name
)
protected:
BSONElement(
    String^ name
)
new :
        name : string -> BSONElement
new :
        name : string -> BSONElement

Parameters

name
Type: Online System String
See Also
BSONElement Class
BSONElement Members
BSONElement Overload
NFX.Serialization.BSON Namespace


BSONElement Methods

BSONElement Methods NFX Class Library

The BSONElement type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes
 | GetElementFactory |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode |
Protected method | GetValueByteSize | Returns the size of this element in bytes
 | MakeOfType |
Protected method | MarkAsArrayItem |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | Override to read element's value from stream
Public method | ToBoolean |
Public method | ToByte |
Public method | ToChar |
Public method | ToDateTime |
Public method | ToDecimal |
Public method | ToDouble |
Public method | ToInt16 |
Public method | ToInt32 |
Public method | ToInt64 |
Public method | ToSByte |
Public method | ToSingle |
Public method | ToString | (Overrides Online Object ToString .)
Public method | ToString(IFormatProvider) |
Public method | ToType |
Public method | ToUInt16 |
Public method | ToUInt32 |
Public method | ToUInt64 |
Public method | WriteAsJSON |
Protected method | WriteToStream | Write element to stream
Protected method | WriteValueToStream | Override to write this element into a stream
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BSONElement Class
NFX.Serialization.BSON Namespace


BSONElement.GetByteSize Method

BSONElement GetByteSize Method NFX Class Library

Returns the BSON binary size of this element expressed in bytes

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal int GetByteSize(
    bool recalc
)
internal int GetByteSize(
    bool recalc
)
Friend Function GetByteSize (
    recalc As Boolean
) As Integer
Friend Function GetByteSize (
    recalc As Boolean
) As Integer
internal:
int GetByteSize(
    bool recalc
)
internal:
int GetByteSize(
    bool recalc
)
internal member GetByteSize :
        recalc : bool -> int
internal member GetByteSize :
        recalc : bool -> int

Parameters

recalc
Type: Online System Boolean

Return Value

Type: Online Int32
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.GetElementFactory Method

BSONElement GetElementFactory Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Func<Stream, BSONElement> GetElementFactory(
    BSONElementType bsonType
)
public static Func<Stream, BSONElement> GetElementFactory(
    BSONElementType bsonType
)
Public Shared Function GetElementFactory (
    bsonType As BSONElementType
) As Func(Of Stream, BSONElement)
Public Shared Function GetElementFactory (
    bsonType As BSONElementType
) As Func(Of Stream, BSONElement)
public:
static Func<Stream^, BSONElement^>^ GetElementFactory(
    BSONElementType bsonType
)
public:
static Func<Stream^, BSONElement^>^ GetElementFactory(
    BSONElementType bsonType
)
static member GetElementFactory :
        bsonType : BSONElementType -> Func<Stream, BSONElement>
static member GetElementFactory :
        bsonType : BSONElementType -> Func<Stream, BSONElement>

Parameters

bsonType
Type: NFX.Serialization.BSON BSONElementType

Return Value

Type: Online Func Online Stream, BSONElement
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.GetTypeCode Method

BSONElement GetTypeCode Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TypeCode GetTypeCode()
public TypeCode GetTypeCode()
Public Function GetTypeCode As TypeCode
Public Function GetTypeCode As TypeCode
public:
virtual TypeCode GetTypeCode() sealed
public:
virtual TypeCode GetTypeCode() sealed
abstract GetTypeCode : unit -> TypeCode
override GetTypeCode : unit -> TypeCode
abstract GetTypeCode : unit -> TypeCode
override GetTypeCode : unit -> TypeCode

Return Value

Type: Online TypeCode

Implements

Online IConvertible GetTypeCode
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.GetValueByteSize Method

BSONElement GetValueByteSize Method NFX Class Library

Returns the size of this element in bytes

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract int GetValueByteSize()
protected internal abstract int GetValueByteSize()
Protected Friend MustOverride Function GetValueByteSize As Integer
Protected Friend MustOverride Function GetValueByteSize As Integer
protected public:
virtual int GetValueByteSize() abstract
protected public:
virtual int GetValueByteSize() abstract
abstract GetValueByteSize : unit -> int
abstract GetValueByteSize : unit -> int

Return Value

Type: Online Int32
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.MakeOfType Method

BSONElement MakeOfType Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static BSONElement MakeOfType(
    BSONElementType bsonType,
    string name,
    Object value
)
public static BSONElement MakeOfType(
    BSONElementType bsonType,
    string name,
    Object value
)
Public Shared Function MakeOfType (
    bsonType As BSONElementType,
    name As String,
    value As Object
) As BSONElement
Public Shared Function MakeOfType (
    bsonType As BSONElementType,
    name As String,
    value As Object
) As BSONElement
public:
static BSONElement^ MakeOfType(
    BSONElementType bsonType,
    String^ name,
    Object^ value
)
public:
static BSONElement^ MakeOfType(
    BSONElementType bsonType,
    String^ name,
    Object^ value
)
static member MakeOfType :
        bsonType : BSONElementType *
        name : string *
        value : Object -> BSONElement
static member MakeOfType :
        bsonType : BSONElementType *
        name : string *
        value : Object -> BSONElement

Parameters

bsonType
Type: NFX.Serialization.BSON BSONElementType
name
Type: Online System String
value
Type: Online System Object

Return Value

Type: BSONElement
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.MarkAsArrayItem Method

BSONElement MarkAsArrayItem Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal void MarkAsArrayItem()
internal void MarkAsArrayItem()
Friend Sub MarkAsArrayItem
Friend Sub MarkAsArrayItem
internal:
void MarkAsArrayItem()
internal:
void MarkAsArrayItem()
internal member MarkAsArrayItem : unit -> unit
internal member MarkAsArrayItem : unit -> unit
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.ReadValueFromStream Method

BSONElement ReadValueFromStream Method NFX Class Library

Override to read element's value from stream

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void ReadValueFromStream(
    Stream stream
)
protected abstract void ReadValueFromStream(
    Stream stream
)
Protected MustOverride Sub ReadValueFromStream (
    stream As Stream
)
Protected MustOverride Sub ReadValueFromStream (
    stream As Stream
)
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) abstract
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) abstract
abstract ReadValueFromStream :
        stream : Stream -> unit
abstract ReadValueFromStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.ToBoolean Method

BSONElement ToBoolean Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ToBoolean(
    IFormatProvider provider
)
public bool ToBoolean(
    IFormatProvider provider
)
Public Function ToBoolean (
    provider As IFormatProvider
) As Boolean
Public Function ToBoolean (
    provider As IFormatProvider
) As Boolean
public:
virtual bool ToBoolean(
    IFormatProvider^ provider
) sealed
public:
virtual bool ToBoolean(
    IFormatProvider^ provider
) sealed
abstract ToBoolean :
        provider : IFormatProvider -> bool
override ToBoolean :
        provider : IFormatProvider -> bool
abstract ToBoolean :
        provider : IFormatProvider -> bool
override ToBoolean :
        provider : IFormatProvider -> bool

Parameters

provider
Type: Online System IFormatProvider

Return Value

Type: Online Boolean

Implements

Online IConvertible ToBoolean(IFormatProvider)
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.ToByte Method

BSONElement ToByte Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte ToByte(
    IFormatProvider provider
)
public byte ToByte(
    IFormatProvider provider
)
Public Function ToByte (
    provider As IFormatProvider
) As Byte
Public Function ToByte (
    provider As IFormatProvider
) As Byte
public:
virtual unsigned char ToByte(
    IFormatProvider^ provider
) sealed
public:
virtual unsigned char ToByte(
    IFormatProvider^ provider
) sealed
abstract ToByte :
        provider : IFormatProvider -> byte
override ToByte :
        provider : IFormatProvider -> byte
abstract ToByte :
        provider : IFormatProvider -> byte
override ToByte :
        provider : IFormatProvider -> byte

Parameters

provider
Type: Online System IFormatProvider

Return Value

Type: Online Byte

Implements

Online IConvertible ToByte(IFormatProvider)
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.ToChar Method

BSONElement ToChar Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char ToChar(
    IFormatProvider provider
)
public char ToChar(
    IFormatProvider provider
)
Public Function ToChar (
    provider As IFormatProvider
) As Char
Public Function ToChar (
    provider As IFormatProvider
) As Char
public:
virtual wchar_t ToChar(
    IFormatProvider^ provider
) sealed
public:
virtual wchar_t ToChar(
    IFormatProvider^ provider
) sealed
abstract ToChar :
        provider : IFormatProvider -> char
override ToChar :
        provider : IFormatProvider -> char
abstract ToChar :
        provider : IFormatProvider -> char
override ToChar :
        provider : IFormatProvider -> char

Parameters

provider
Type: Online System IFormatProvider

Return Value

Type: Online Char

Implements

Online IConvertible ToChar(IFormatProvider)
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.ToDateTime Method

BSONElement ToDateTime Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime ToDateTime(
    IFormatProvider provider
)
public DateTime ToDateTime(
    IFormatProvider provider
)
Public Function ToDateTime (
    provider As IFormatProvider
) As DateTime
Public Function ToDateTime (
    provider As IFormatProvider
) As DateTime
public:
virtual DateTime ToDateTime(
    IFormatProvider^ provider
) sealed
public:
virtual DateTime ToDateTime(
    IFormatProvider^ provider
) sealed
abstract ToDateTime :
        provider : IFormatProvider -> DateTime
override ToDateTime :
        provider : IFormatProvider -> DateTime
abstract ToDateTime :
        provider : IFormatProvider -> DateTime
override ToDateTime :
        provider : IFormatProvider -> DateTime

Parameters

provider
Type: Online System IFormatProvider

Return Value

Type: Online DateTime

Implements

Online IConvertible ToDateTime(IFormatProvider)
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.ToDecimal Method

BSONElement ToDecimal Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal ToDecimal(
    IFormatProvider provider
)
public decimal ToDecimal(
    IFormatProvider provider
)
Public Function ToDecimal (
    provider As IFormatProvider
) As Decimal
Public Function ToDecimal (
    provider As IFormatProvider
) As Decimal
public:
virtual Decimal ToDecimal(
    IFormatProvider^ provider
) sealed
public:
virtual Decimal ToDecimal(
    IFormatProvider^ provider
) sealed
abstract ToDecimal :
        provider : IFormatProvider -> decimal
override ToDecimal :
        provider : IFormatProvider -> decimal
abstract ToDecimal :
        provider : IFormatProvider -> decimal
override ToDecimal :
        provider : IFormatProvider -> decimal

Parameters

provider
Type: Online System IFormatProvider

Return Value

Type: Online Decimal

Implements

Online IConvertible ToDecimal(IFormatProvider)
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.ToDouble Method

BSONElement ToDouble Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double ToDouble(
    IFormatProvider provider
)
public double ToDouble(
    IFormatProvider provider
)
Public Function ToDouble (
    provider As IFormatProvider
) As Double
Public Function ToDouble (
    provider As IFormatProvider
) As Double
public:
virtual double ToDouble(
    IFormatProvider^ provider
) sealed
public:
virtual double ToDouble(
    IFormatProvider^ provider
) sealed
abstract ToDouble :
        provider : IFormatProvider -> float
override ToDouble :
        provider : IFormatProvider -> float
abstract ToDouble :
        provider : IFormatProvider -> float
override ToDouble :
        provider : IFormatProvider -> float

Parameters

provider
Type: Online System IFormatProvider

Return Value

Type: Online Double

Implements

Online IConvertible ToDouble(IFormatProvider)
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.ToInt16 Method

BSONElement ToInt16 Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public short ToInt16(
    IFormatProvider provider
)
public short ToInt16(
    IFormatProvider provider
)
Public Function ToInt16 (
    provider As IFormatProvider
) As Short
Public Function ToInt16 (
    provider As IFormatProvider
) As Short
public:
virtual short ToInt16(
    IFormatProvider^ provider
) sealed
public:
virtual short ToInt16(
    IFormatProvider^ provider
) sealed
abstract ToInt16 :
        provider : IFormatProvider -> int16
override ToInt16 :
        provider : IFormatProvider -> int16
abstract ToInt16 :
        provider : IFormatProvider -> int16
override ToInt16 :
        provider : IFormatProvider -> int16

Parameters

provider
Type: Online System IFormatProvider

Return Value

Type: Online Int16

Implements

Online IConvertible ToInt16(IFormatProvider)
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.ToInt32 Method

BSONElement ToInt32 Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ToInt32(
    IFormatProvider provider
)
public int ToInt32(
    IFormatProvider provider
)
Public Function ToInt32 (
    provider As IFormatProvider
) As Integer
Public Function ToInt32 (
    provider As IFormatProvider
) As Integer
public:
virtual int ToInt32(
    IFormatProvider^ provider
) sealed
public:
virtual int ToInt32(
    IFormatProvider^ provider
) sealed
abstract ToInt32 :
        provider : IFormatProvider -> int
override ToInt32 :
        provider : IFormatProvider -> int
abstract ToInt32 :
        provider : IFormatProvider -> int
override ToInt32 :
        provider : IFormatProvider -> int

Parameters

provider
Type: Online System IFormatProvider

Return Value

Type: Online Int32

Implements

Online IConvertible ToInt32(IFormatProvider)
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.ToInt64 Method

BSONElement ToInt64 Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long ToInt64(
    IFormatProvider provider
)
public long ToInt64(
    IFormatProvider provider
)
Public Function ToInt64 (
    provider As IFormatProvider
) As Long
Public Function ToInt64 (
    provider As IFormatProvider
) As Long
public:
virtual long long ToInt64(
    IFormatProvider^ provider
) sealed
public:
virtual long long ToInt64(
    IFormatProvider^ provider
) sealed
abstract ToInt64 :
        provider : IFormatProvider -> int64
override ToInt64 :
        provider : IFormatProvider -> int64
abstract ToInt64 :
        provider : IFormatProvider -> int64
override ToInt64 :
        provider : IFormatProvider -> int64

Parameters

provider
Type: Online System IFormatProvider

Return Value

Type: Online Int64

Implements

Online IConvertible ToInt64(IFormatProvider)
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.ToSByte Method

BSONElement ToSByte Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sbyte ToSByte(
    IFormatProvider provider
)
public sbyte ToSByte(
    IFormatProvider provider
)
Public Function ToSByte (
    provider As IFormatProvider
) As SByte
Public Function ToSByte (
    provider As IFormatProvider
) As SByte
public:
virtual signed char ToSByte(
    IFormatProvider^ provider
) sealed
public:
virtual signed char ToSByte(
    IFormatProvider^ provider
) sealed
abstract ToSByte :
        provider : IFormatProvider -> sbyte
override ToSByte :
        provider : IFormatProvider -> sbyte
abstract ToSByte :
        provider : IFormatProvider -> sbyte
override ToSByte :
        provider : IFormatProvider -> sbyte

Parameters

provider
Type: Online System IFormatProvider

Return Value

Type: Online SByte

Implements

Online IConvertible ToSByte(IFormatProvider)
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.ToSingle Method

BSONElement ToSingle Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float ToSingle(
    IFormatProvider provider
)
public float ToSingle(
    IFormatProvider provider
)
Public Function ToSingle (
    provider As IFormatProvider
) As Single
Public Function ToSingle (
    provider As IFormatProvider
) As Single
public:
virtual float ToSingle(
    IFormatProvider^ provider
) sealed
public:
virtual float ToSingle(
    IFormatProvider^ provider
) sealed
abstract ToSingle :
        provider : IFormatProvider -> float32
override ToSingle :
        provider : IFormatProvider -> float32
abstract ToSingle :
        provider : IFormatProvider -> float32
override ToSingle :
        provider : IFormatProvider -> float32

Parameters

provider
Type: Online System IFormatProvider

Return Value

Type: Online Single

Implements

Online IConvertible ToSingle(IFormatProvider)
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.ToString Method

BSONElement ToString Method NFX Class Library

Overload List
 | Name | Description
Public method | ToString | (Overrides Online Object ToString .)
Public method | ToString(IFormatProvider) |
Back to Top
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.ToString Method

BSONElement ToString Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
BSONElement Class
BSONElement Members
ToString Overload
NFX.Serialization.BSON Namespace


BSONElement.ToString Method (IFormatProvider)

BSONElement ToString Method (IFormatProvider) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ToString(
    IFormatProvider provider
)
public string ToString(
    IFormatProvider provider
)
Public Function ToString (
    provider As IFormatProvider
) As String
Public Function ToString (
    provider As IFormatProvider
) As String
public:
virtual String^ ToString(
    IFormatProvider^ provider
) sealed
public:
virtual String^ ToString(
    IFormatProvider^ provider
) sealed
abstract ToString :
        provider : IFormatProvider -> string
override ToString :
        provider : IFormatProvider -> string
abstract ToString :
        provider : IFormatProvider -> string
override ToString :
        provider : IFormatProvider -> string

Parameters

provider
Type: Online System IFormatProvider

Return Value

Type: Online String

Implements

Online IConvertible ToString(IFormatProvider)
See Also
BSONElement Class
BSONElement Members
ToString Overload
NFX.Serialization.BSON Namespace


BSONElement.ToType Method

BSONElement ToType Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object ToType(
    Type conversionType,
    IFormatProvider provider
)
public Object ToType(
    Type conversionType,
    IFormatProvider provider
)
Public Function ToType (
    conversionType As Type,
    provider As IFormatProvider
) As Object
Public Function ToType (
    conversionType As Type,
    provider As IFormatProvider
) As Object
public:
virtual Object^ ToType(
    Type^ conversionType,
    IFormatProvider^ provider
) sealed
public:
virtual Object^ ToType(
    Type^ conversionType,
    IFormatProvider^ provider
) sealed
abstract ToType :
        conversionType : Type *
        provider : IFormatProvider -> Object
override ToType :
        conversionType : Type *
        provider : IFormatProvider -> Object
abstract ToType :
        conversionType : Type *
        provider : IFormatProvider -> Object
override ToType :
        conversionType : Type *
        provider : IFormatProvider -> Object

Parameters

conversionType
Type: Online System Type
provider
Type: Online System IFormatProvider

Return Value

Type: Online Object

Implements

Online IConvertible ToType(Type, IFormatProvider)
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.ToUInt16 Method

BSONElement ToUInt16 Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ushort ToUInt16(
    IFormatProvider provider
)
public ushort ToUInt16(
    IFormatProvider provider
)
Public Function ToUInt16 (
    provider As IFormatProvider
) As UShort
Public Function ToUInt16 (
    provider As IFormatProvider
) As UShort
public:
virtual unsigned short ToUInt16(
    IFormatProvider^ provider
) sealed
public:
virtual unsigned short ToUInt16(
    IFormatProvider^ provider
) sealed
abstract ToUInt16 :
        provider : IFormatProvider -> uint16
override ToUInt16 :
        provider : IFormatProvider -> uint16
abstract ToUInt16 :
        provider : IFormatProvider -> uint16
override ToUInt16 :
        provider : IFormatProvider -> uint16

Parameters

provider
Type: Online System IFormatProvider

Return Value

Type: Online UInt16

Implements

Online IConvertible ToUInt16(IFormatProvider)
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.ToUInt32 Method

BSONElement ToUInt32 Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint ToUInt32(
    IFormatProvider provider
)
public uint ToUInt32(
    IFormatProvider provider
)
Public Function ToUInt32 (
    provider As IFormatProvider
) As UInteger
Public Function ToUInt32 (
    provider As IFormatProvider
) As UInteger
public:
virtual unsigned int ToUInt32(
    IFormatProvider^ provider
) sealed
public:
virtual unsigned int ToUInt32(
    IFormatProvider^ provider
) sealed
abstract ToUInt32 :
        provider : IFormatProvider -> uint32
override ToUInt32 :
        provider : IFormatProvider -> uint32
abstract ToUInt32 :
        provider : IFormatProvider -> uint32
override ToUInt32 :
        provider : IFormatProvider -> uint32

Parameters

provider
Type: Online System IFormatProvider

Return Value

Type: Online UInt32

Implements

Online IConvertible ToUInt32(IFormatProvider)
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.ToUInt64 Method

BSONElement ToUInt64 Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong ToUInt64(
    IFormatProvider provider
)
public ulong ToUInt64(
    IFormatProvider provider
)
Public Function ToUInt64 (
    provider As IFormatProvider
) As ULong
Public Function ToUInt64 (
    provider As IFormatProvider
) As ULong
public:
virtual unsigned long long ToUInt64(
    IFormatProvider^ provider
) sealed
public:
virtual unsigned long long ToUInt64(
    IFormatProvider^ provider
) sealed
abstract ToUInt64 :
        provider : IFormatProvider -> uint64
override ToUInt64 :
        provider : IFormatProvider -> uint64
abstract ToUInt64 :
        provider : IFormatProvider -> uint64
override ToUInt64 :
        provider : IFormatProvider -> uint64

Parameters

provider
Type: Online System IFormatProvider

Return Value

Type: Online UInt64

Implements

Online IConvertible ToUInt64(IFormatProvider)
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.WriteAsJSON Method

BSONElement WriteAsJSON Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
public virtual void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
Public Overridable Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
Public Overridable Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
)
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
)
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
nestingLevel
Type: Online System Int32
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Implements

IJSONWritable WriteAsJSON(TextWriter, Int32, JSONWritingOptions)
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.WriteToStream Method

BSONElement WriteToStream Method NFX Class Library

Write element to stream

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal void WriteToStream(
    Stream stream
)
protected internal void WriteToStream(
    Stream stream
)
Protected Friend Sub WriteToStream (
    stream As Stream
)
Protected Friend Sub WriteToStream (
    stream As Stream
)
protected public:
void WriteToStream(
    Stream^ stream
)
protected public:
void WriteToStream(
    Stream^ stream
)
member WriteToStream :
        stream : Stream -> unit
member WriteToStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.WriteValueToStream Method

BSONElement WriteValueToStream Method NFX Class Library

Override to write this element into a stream

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal abstract void WriteValueToStream(
    Stream stream
)
protected internal abstract void WriteValueToStream(
    Stream stream
)
Protected Friend MustOverride Sub WriteValueToStream (
    stream As Stream
)
Protected Friend MustOverride Sub WriteValueToStream (
    stream As Stream
)
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) abstract
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) abstract
abstract WriteValueToStream :
        stream : Stream -> unit
abstract WriteValueToStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement Properties

BSONElement Properties NFX Class Library

The BSONElement type exposes the following members.
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes
Public property | ElementType | Provides BSON classification of data type
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements
Public property | ObjectValue | Gets/sets the value of this element polymorphically
Back to Top
See Also
BSONElement Class
NFX.Serialization.BSON Namespace


BSONElement.ByteSize Property

BSONElement ByteSize Property NFX Class Library

Recalculates the BSON binary size of this document expressed in bytes

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ByteSize { get; }
public int ByteSize { get; }
Public ReadOnly Property ByteSize As Integer
    Get
Public ReadOnly Property ByteSize As Integer
    Get
public:
property int ByteSize {
    int get ();
}
public:
property int ByteSize {
    int get ();
}
member ByteSize : int with get
member ByteSize : int with get

Property Value

Type: Online Int32
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.ElementType Property

BSONElement ElementType Property NFX Class Library

Provides BSON classification of data type

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract BSONElementType ElementType { get; }
public abstract BSONElementType ElementType { get; }
Public MustOverride ReadOnly Property ElementType As BSONElementType
    Get
Public MustOverride ReadOnly Property ElementType As BSONElementType
    Get
public:
virtual property BSONElementType ElementType {
    BSONElementType get () abstract;
}
public:
virtual property BSONElementType ElementType {
    BSONElementType get () abstract;
}
abstract ElementType : BSONElementType with get
abstract ElementType : BSONElementType with get

Property Value

Type: BSONElementType
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.IsArrayElement Property

BSONElement IsArrayElement Property NFX Class Library

Returns true when this element does not have a name - it is a part of the array

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsArrayElement { get; }
public bool IsArrayElement { get; }
Public ReadOnly Property IsArrayElement As Boolean
    Get
Public ReadOnly Property IsArrayElement As Boolean
    Get
public:
property bool IsArrayElement {
    bool get ();
}
public:
property bool IsArrayElement {
    bool get ();
}
member IsArrayElement : bool with get
member IsArrayElement : bool with get

Property Value

Type: Online Boolean
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.Name Property

BSONElement Name Property NFX Class Library

Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement.ObjectValue Property

BSONElement ObjectValue Property NFX Class Library

Gets/sets the value of this element polymorphically

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Object ObjectValue { get; set; }
public abstract Object ObjectValue { get; set; }
Public MustOverride Property ObjectValue As Object
    Get
    Set
Public MustOverride Property ObjectValue As Object
    Get
    Set
public:
virtual property Object^ ObjectValue {
    Object^ get () abstract;
    void set (Object^ value) abstract;
}
public:
virtual property Object^ ObjectValue {
    Object^ get () abstract;
    void set (Object^ value) abstract;
}
abstract ObjectValue : Object with get, set
abstract ObjectValue : Object with get, set

Property Value

Type: Online Object
See Also
BSONElement Class
BSONElement Members
NFX.Serialization.BSON Namespace


BSONElement(T) Class

BSONElement T Class NFX Class Library

Base class for BSON elements with typed Value property
Inheritance Hierarchy
Online System Object
NFX.Serialization.BSON BSONElement
NFX.Serialization.BSON BSONElement T
NFX.Serialization.BSON BSONArrayElement
NFX.Serialization.BSON BSONBinaryElement
NFX.Serialization.BSON BSONBooleanElement
NFX.Serialization.BSON BSONDateTimeElement
NFX.Serialization.BSON BSONDocumentElement
NFX.Serialization.BSON BSONDoubleElement
NFX.Serialization.BSON BSONInt32Element
NFX.Serialization.BSON BSONInt64Element
NFX.Serialization.BSON BSONJavaScriptElement
NFX.Serialization.BSON BSONJavaScriptWithScopeElement
NFX.Serialization.BSON BSONObjectIDElement
NFX.Serialization.BSON BSONRegularExpressionElement
NFX.Serialization.BSON BSONStringElement
NFX.Serialization.BSON BSONTimestampElement

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class BSONElement<T> : BSONElement
public abstract class BSONElement<T> : BSONElement
Public MustInherit Class BSONElement(Of T)
    Inherits BSONElement
Public MustInherit Class BSONElement(Of T)
    Inherits BSONElement
generic<typename T>
public ref class BSONElement abstract : public BSONElement
generic<typename T>
public ref class BSONElement abstract : public BSONElement
[<AbstractClassAttribute>]
type BSONElement<'T> =
    class
        inherit BSONElement
    end
[<AbstractClassAttribute>]
type BSONElement<'T> =
    class
        inherit BSONElement
    end
Type Parameters
T
See Also
BSONElement T Members
NFX.Serialization.BSON Namespace


BSONElement(T) Members

BSONElement T Members NFX Class Library

The BSONElement T type exposes the following members.
Constructors
 | Name | Description
Protected method | BSONElement T (Stream) | Initializes a new instance of the BSONElement T class
Protected method | BSONElement T (String, T) | Initializes a new instance of the BSONElement T class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | Returns the size of this element in bytes (Inherited from BSONElement.)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | Override to read element's value from stream (Inherited from BSONElement.)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Overrides BSONElement ToString .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | Override to write this element into a stream (Inherited from BSONElement.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Value |
Back to Top
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | Provides BSON classification of data type (Inherited from BSONElement.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Overrides BSONElement ObjectValue.)
Public property | Value |
Back to Top
See Also
BSONElement T Class
NFX.Serialization.BSON Namespace


BSONElement(T) Constructor

BSONElement T Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | BSONElement T (Stream) | Initializes a new instance of the BSONElement T class
Protected method | BSONElement T (String, T) | Initializes a new instance of the BSONElement T class
Back to Top
See Also
BSONElement T Class
BSONElement T Members
NFX.Serialization.BSON Namespace


BSONElement(T) Constructor (Stream)

BSONElement T Constructor (Stream) NFX Class Library

Initializes a new instance of the BSONElement T class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected BSONElement(
    Stream stream
)
protected BSONElement(
    Stream stream
)
Protected Sub New (
    stream As Stream
)
Protected Sub New (
    stream As Stream
)
protected:
BSONElement(
    Stream^ stream
)
protected:
BSONElement(
    Stream^ stream
)
new :
        stream : Stream -> BSONElement
new :
        stream : Stream -> BSONElement

Parameters

stream
Type: Online System.IO Stream
See Also
BSONElement T Class
BSONElement T Members
BSONElement T Overload
NFX.Serialization.BSON Namespace


BSONElement(T) Constructor (String, T)

BSONElement T Constructor (String, T) NFX Class Library

Initializes a new instance of the BSONElement T class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected BSONElement(
    string name,
    T value
)
protected BSONElement(
    string name,
    T value
)
Protected Sub New (
    name As String,
    value As T
)
Protected Sub New (
    name As String,
    value As T
)
protected:
BSONElement(
    String^ name,
    T value
)
protected:
BSONElement(
    String^ name,
    T value
)
new :
        name : string *
        value : 'T -> BSONElement
new :
        name : string *
        value : 'T -> BSONElement

Parameters

name
Type: Online System String
value
Type: T
See Also
BSONElement T Class
BSONElement T Members
BSONElement T Overload
NFX.Serialization.BSON Namespace


BSONElement(T) Fields

BSONElement T Fields NFX Class Library

The BSONElement T type exposes the following members.
Fields
 | Name | Description
Protected field | m_Value |
Back to Top
See Also
BSONElement T Class
NFX.Serialization.BSON Namespace


BSONElement(T).m_Value Field

BSONElement T m_Value Field NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected T m_Value
protected T m_Value
Protected m_Value As T
Protected m_Value As T
protected:
T m_Value
protected:
T m_Value
val mutable m_Value: 'T
val mutable m_Value: 'T

Field Value

Type: T
See Also
BSONElement T Class
BSONElement T Members
NFX.Serialization.BSON Namespace


BSONElement(T) Methods

BSONElement T Methods NFX Class Library

The BSONElement T type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | Returns the size of this element in bytes (Inherited from BSONElement.)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | Override to read element's value from stream (Inherited from BSONElement.)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Overrides BSONElement ToString .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | Override to write this element into a stream (Inherited from BSONElement.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BSONElement T Class
NFX.Serialization.BSON Namespace


BSONElement(T).ToString Method

BSONElement T ToString Method NFX Class Library

Overload List
 | Name | Description
Public method | ToString | (Overrides BSONElement ToString .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Back to Top
See Also
BSONElement T Class
BSONElement T Members
NFX.Serialization.BSON Namespace


BSONElement(T).ToString Method

BSONElement T ToString Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
BSONElement T Class
BSONElement T Members
ToString Overload
NFX.Serialization.BSON Namespace


BSONElement(T) Properties

BSONElement T Properties NFX Class Library

The BSONElement T type exposes the following members.
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | Provides BSON classification of data type (Inherited from BSONElement.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Overrides BSONElement ObjectValue.)
Public property | Value |
Back to Top
See Also
BSONElement T Class
NFX.Serialization.BSON Namespace


BSONElement(T).ObjectValue Property

BSONElement T ObjectValue Property NFX Class Library

Gets/sets value as object. In normal cases use typed Value to get/set instead

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override sealed Object ObjectValue { get; set; }
public override sealed Object ObjectValue { get; set; }
Public Overrides NotOverridable Property ObjectValue As Object
    Get
    Set
Public Overrides NotOverridable Property ObjectValue As Object
    Get
    Set
public:
virtual property Object^ ObjectValue {
    Object^ get () override sealed;
    void set (Object^ value) override sealed;
}
public:
virtual property Object^ ObjectValue {
    Object^ get () override sealed;
    void set (Object^ value) override sealed;
}
abstract ObjectValue : Object with get, set
override ObjectValue : Object with get, set
abstract ObjectValue : Object with get, set
override ObjectValue : Object with get, set

Property Value

Type: Online Object
See Also
BSONElement T Class
BSONElement T Members
NFX.Serialization.BSON Namespace


BSONElement(T).Value Property

BSONElement T Value Property NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public T Value { get; set; }
public T Value { get; set; }
Public Property Value As T
    Get
    Set
Public Property Value As T
    Get
    Set
public:
property T Value {
    T get ();
    void set (T value);
}
public:
property T Value {
    T get ();
    void set (T value);
}
member Value : 'T with get, set
member Value : 'T with get, set

Property Value

Type: T
See Also
BSONElement T Class
BSONElement T Members
NFX.Serialization.BSON Namespace


BSONElementType Enumeration

BSONElementType Enumeration NFX Class Library

BSON element types: http://bsonspec.org/spec.html

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum BSONElementType
public enum BSONElementType
Public Enumeration BSONElementType
Public Enumeration BSONElementType
public enum class BSONElementType
public enum class BSONElementType
type BSONElementType
type BSONElementType
Members
Member name | Value | Description
Double | 1 |
String | 2 |
Document | 3 |
Array | 4 |
Binary | 5 |
ObjectID | 7 |
Boolean | 8 |
DateTime | 9 |
Null | 10 |
RegularExpression | 11 |
JavaScript | 13 |
JavaScriptWithScope | 15 |
Int32 | 16 |
TimeStamp | 17 |
Int64 | 18 |
MinKey | 255 |
MaxKey | 127 |
See Also
NFX.Serialization.BSON Namespace


BSONException Class

BSONException Class NFX Class Library

Base exception thrown by the BSON framework
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Serialization.BSON BSONException

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class BSONException : NFXException
[SerializableAttribute]
public class BSONException : NFXException
<SerializableAttribute>
Public Class BSONException
    Inherits NFXException
<SerializableAttribute>
Public Class BSONException
    Inherits NFXException
[SerializableAttribute]
public ref class BSONException : public NFXException
[SerializableAttribute]
public ref class BSONException : public NFXException
[<SerializableAttribute>]
type BSONException =
    class
        inherit NFXException
    end
[<SerializableAttribute>]
type BSONException =
    class
        inherit NFXException
    end
See Also
BSONException Members
NFX.Serialization.BSON Namespace


BSONException Members

BSONException Members NFX Class Library

The BSONException type exposes the following members.
Constructors
 | Name | Description
Public method | BSONException | Initializes a new instance of the BSONException class
Public method | BSONException(String) | Initializes a new instance of the BSONException class
Protected method | BSONException(SerializationInfo, StreamingContext) | Initializes a new instance of the BSONException class
Public method | BSONException(String, Exception) | Initializes a new instance of the BSONException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
BSONException Class
NFX.Serialization.BSON Namespace


BSONException Constructor

BSONException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | BSONException | Initializes a new instance of the BSONException class
Public method | BSONException(String) | Initializes a new instance of the BSONException class
Protected method | BSONException(SerializationInfo, StreamingContext) | Initializes a new instance of the BSONException class
Public method | BSONException(String, Exception) | Initializes a new instance of the BSONException class
Back to Top
See Also
BSONException Class
BSONException Members
NFX.Serialization.BSON Namespace


BSONException Constructor

BSONException Constructor NFX Class Library

Initializes a new instance of the BSONException class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONException()
public BSONException()
Public Sub New
Public Sub New
public:
BSONException()
public:
BSONException()
new : unit -> BSONException
new : unit -> BSONException
See Also
BSONException Class
BSONException Members
BSONException Overload
NFX.Serialization.BSON Namespace


BSONException Constructor (String)

BSONException Constructor (String) NFX Class Library

Initializes a new instance of the BSONException class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONException(
    string message
)
public BSONException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
BSONException(
    String^ message
)
public:
BSONException(
    String^ message
)
new :
        message : string -> BSONException
new :
        message : string -> BSONException

Parameters

message
Type: Online System String
See Also
BSONException Class
BSONException Members
BSONException Overload
NFX.Serialization.BSON Namespace


BSONException Constructor (SerializationInfo, StreamingContext)

BSONException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BSONException class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected BSONException(
    SerializationInfo info,
    StreamingContext context
)
protected BSONException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
BSONException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
BSONException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> BSONException
new :
        info : SerializationInfo *
        context : StreamingContext -> BSONException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
BSONException Class
BSONException Members
BSONException Overload
NFX.Serialization.BSON Namespace


BSONException Constructor (String, Exception)

BSONException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BSONException class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONException(
    string message,
    Exception inner
)
public BSONException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
BSONException(
    String^ message,
    Exception^ inner
)
public:
BSONException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> BSONException
new :
        message : string *
        inner : Exception -> BSONException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
BSONException Class
BSONException Members
BSONException Overload
NFX.Serialization.BSON Namespace


BSONException Methods

BSONException Methods NFX Class Library

The BSONException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
BSONException Class
NFX.Serialization.BSON Namespace


BSONException Properties

BSONException Properties NFX Class Library

The BSONException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
BSONException Class
NFX.Serialization.BSON Namespace


BSONException Events

BSONException Events NFX Class Library

The BSONException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
BSONException Class
NFX.Serialization.BSON Namespace


BSONInt32Element Class

BSONInt32Element Class NFX Class Library

Represents a BSON element with an int32 value
Inheritance Hierarchy
Online System Object
NFX.Serialization.BSON BSONElement
NFX.Serialization.BSON BSONElement Online Int32
NFX.Serialization.BSON BSONInt32Element

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class BSONInt32Element : BSONElement<int>
public sealed class BSONInt32Element : BSONElement<int>
Public NotInheritable Class BSONInt32Element
    Inherits BSONElement(Of Integer)
Public NotInheritable Class BSONInt32Element
    Inherits BSONElement(Of Integer)
public ref class BSONInt32Element sealed : public BSONElement<int>
public ref class BSONInt32Element sealed : public BSONElement<int>
[<SealedAttribute>]
type BSONInt32Element =
    class
        inherit BSONElement<int>
    end
[<SealedAttribute>]
type BSONInt32Element =
    class
        inherit BSONElement<int>
    end
See Also
BSONInt32Element Members
NFX.Serialization.BSON Namespace


BSONInt32Element Members

BSONInt32Element Members NFX Class Library

The BSONInt32Element type exposes the following members.
Constructors
 | Name | Description
Public method | BSONInt32Element(Int32) | Creates an array element
Protected method | BSONInt32Element(Stream) | Initializes a new instance of the BSONInt32Element class
Public method | BSONInt32Element(String, Int32) | Initializes a new instance of the BSONInt32Element class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONInt32Element Class
NFX.Serialization.BSON Namespace


BSONInt32Element Constructor

BSONInt32Element Constructor NFX Class Library

Overload List
 | Name | Description
Public method | BSONInt32Element(Int32) | Creates an array element
Protected method | BSONInt32Element(Stream) | Initializes a new instance of the BSONInt32Element class
Public method | BSONInt32Element(String, Int32) | Initializes a new instance of the BSONInt32Element class
Back to Top
See Also
BSONInt32Element Class
BSONInt32Element Members
NFX.Serialization.BSON Namespace


BSONInt32Element Constructor (Int32)

BSONInt32Element Constructor (Int32) NFX Class Library

Creates an array element

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONInt32Element(
    int value
)
public BSONInt32Element(
    int value
)
Public Sub New (
    value As Integer
)
Public Sub New (
    value As Integer
)
public:
BSONInt32Element(
    int value
)
public:
BSONInt32Element(
    int value
)
new :
        value : int -> BSONInt32Element
new :
        value : int -> BSONInt32Element

Parameters

value
Type: Online System Int32
See Also
BSONInt32Element Class
BSONInt32Element Members
BSONInt32Element Overload
NFX.Serialization.BSON Namespace


BSONInt32Element Constructor (Stream)

BSONInt32Element Constructor (Stream) NFX Class Library

Initializes a new instance of the BSONInt32Element class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal BSONInt32Element(
    Stream stream
)
internal BSONInt32Element(
    Stream stream
)
Friend Sub New (
    stream As Stream
)
Friend Sub New (
    stream As Stream
)
internal:
BSONInt32Element(
    Stream^ stream
)
internal:
BSONInt32Element(
    Stream^ stream
)
new :
        stream : Stream -> BSONInt32Element
new :
        stream : Stream -> BSONInt32Element

Parameters

stream
Type: Online System.IO Stream
See Also
BSONInt32Element Class
BSONInt32Element Members
BSONInt32Element Overload
NFX.Serialization.BSON Namespace


BSONInt32Element Constructor (String, Int32)

BSONInt32Element Constructor (String, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BSONInt32Element class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONInt32Element(
    string name,
    int value
)
public BSONInt32Element(
    string name,
    int value
)
Public Sub New (
    name As String,
    value As Integer
)
Public Sub New (
    name As String,
    value As Integer
)
public:
BSONInt32Element(
    String^ name,
    int value
)
public:
BSONInt32Element(
    String^ name,
    int value
)
new :
        name : string *
        value : int -> BSONInt32Element
new :
        name : string *
        value : int -> BSONInt32Element

Parameters

name
Type: Online System String
value
Type: Online System Int32
See Also
BSONInt32Element Class
BSONInt32Element Members
BSONInt32Element Overload
NFX.Serialization.BSON Namespace


BSONInt32Element Fields

BSONInt32Element Fields NFX Class Library

The BSONInt32Element type exposes the following members.
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONInt32Element Class
NFX.Serialization.BSON Namespace


BSONInt32Element Methods

BSONInt32Element Methods NFX Class Library

The BSONInt32Element type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BSONInt32Element Class
NFX.Serialization.BSON Namespace


BSONInt32Element.GetValueByteSize Method

BSONInt32Element GetValueByteSize Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override int GetValueByteSize()
protected internal override int GetValueByteSize()
Protected Friend Overrides Function GetValueByteSize As Integer
Protected Friend Overrides Function GetValueByteSize As Integer
protected public:
virtual int GetValueByteSize() override
protected public:
virtual int GetValueByteSize() override
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int

Return Value

Type: Online Int32
See Also
BSONInt32Element Class
BSONInt32Element Members
NFX.Serialization.BSON Namespace


BSONInt32Element.ReadValueFromStream Method

BSONInt32Element ReadValueFromStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void ReadValueFromStream(
    Stream stream
)
protected override void ReadValueFromStream(
    Stream stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONInt32Element Class
BSONInt32Element Members
NFX.Serialization.BSON Namespace


BSONInt32Element.WriteValueToStream Method

BSONInt32Element WriteValueToStream Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void WriteValueToStream(
    Stream stream
)
protected internal override void WriteValueToStream(
    Stream stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONInt32Element Class
BSONInt32Element Members
NFX.Serialization.BSON Namespace


BSONInt32Element Properties

BSONInt32Element Properties NFX Class Library

The BSONInt32Element type exposes the following members.
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONInt32Element Class
NFX.Serialization.BSON Namespace


BSONInt32Element.ElementType Property

BSONInt32Element ElementType Property NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override BSONElementType ElementType { get; }
public override BSONElementType ElementType { get; }
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get

Property Value

Type: BSONElementType
See Also
BSONInt32Element Class
BSONInt32Element Members
NFX.Serialization.BSON Namespace


BSONInt64Element Class

BSONInt64Element Class NFX Class Library

Represents a BSON element with an int64 value
Inheritance Hierarchy
Online System Object
NFX.Serialization.BSON BSONElement
NFX.Serialization.BSON BSONElement Online Int64
NFX.Serialization.BSON BSONInt64Element

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class BSONInt64Element : BSONElement<long>
public sealed class BSONInt64Element : BSONElement<long>
Public NotInheritable Class BSONInt64Element
    Inherits BSONElement(Of Long)
Public NotInheritable Class BSONInt64Element
    Inherits BSONElement(Of Long)
public ref class BSONInt64Element sealed : public BSONElement<long long>
public ref class BSONInt64Element sealed : public BSONElement<long long>
[<SealedAttribute>]
type BSONInt64Element =
    class
        inherit BSONElement<int64>
    end
[<SealedAttribute>]
type BSONInt64Element =
    class
        inherit BSONElement<int64>
    end
See Also
BSONInt64Element Members
NFX.Serialization.BSON Namespace


BSONInt64Element Members

BSONInt64Element Members NFX Class Library

The BSONInt64Element type exposes the following members.
Constructors
 | Name | Description
Public method | BSONInt64Element(Int64) | Creates an array element
Protected method | BSONInt64Element(Stream) | Initializes a new instance of the BSONInt64Element class
Public method | BSONInt64Element(String, Int64) | Initializes a new instance of the BSONInt64Element class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Overrides BSONElement WriteAsJSON(TextWriter, Int32, JSONWritingOptions).)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONInt64Element Class
NFX.Serialization.BSON Namespace


BSONInt64Element Constructor

BSONInt64Element Constructor NFX Class Library

Overload List
 | Name | Description
Public method | BSONInt64Element(Int64) | Creates an array element
Protected method | BSONInt64Element(Stream) | Initializes a new instance of the BSONInt64Element class
Public method | BSONInt64Element(String, Int64) | Initializes a new instance of the BSONInt64Element class
Back to Top
See Also
BSONInt64Element Class
BSONInt64Element Members
NFX.Serialization.BSON Namespace


BSONInt64Element Constructor (Int64)

BSONInt64Element Constructor (Int64) NFX Class Library

Creates an array element

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONInt64Element(
    long value
)
public BSONInt64Element(
    long value
)
Public Sub New (
    value As Long
)
Public Sub New (
    value As Long
)
public:
BSONInt64Element(
    long long value
)
public:
BSONInt64Element(
    long long value
)
new :
        value : int64 -> BSONInt64Element
new :
        value : int64 -> BSONInt64Element

Parameters

value
Type: Online System Int64
See Also
BSONInt64Element Class
BSONInt64Element Members
BSONInt64Element Overload
NFX.Serialization.BSON Namespace


BSONInt64Element Constructor (Stream)

BSONInt64Element Constructor (Stream) NFX Class Library

Initializes a new instance of the BSONInt64Element class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal BSONInt64Element(
    Stream stream
)
internal BSONInt64Element(
    Stream stream
)
Friend Sub New (
    stream As Stream
)
Friend Sub New (
    stream As Stream
)
internal:
BSONInt64Element(
    Stream^ stream
)
internal:
BSONInt64Element(
    Stream^ stream
)
new :
        stream : Stream -> BSONInt64Element
new :
        stream : Stream -> BSONInt64Element

Parameters

stream
Type: Online System.IO Stream
See Also
BSONInt64Element Class
BSONInt64Element Members
BSONInt64Element Overload
NFX.Serialization.BSON Namespace


BSONInt64Element Constructor (String, Int64)

BSONInt64Element Constructor (String, Int64) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BSONInt64Element class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONInt64Element(
    string name,
    long value
)
public BSONInt64Element(
    string name,
    long value
)
Public Sub New (
    name As String,
    value As Long
)
Public Sub New (
    name As String,
    value As Long
)
public:
BSONInt64Element(
    String^ name,
    long long value
)
public:
BSONInt64Element(
    String^ name,
    long long value
)
new :
        name : string *
        value : int64 -> BSONInt64Element
new :
        name : string *
        value : int64 -> BSONInt64Element

Parameters

name
Type: Online System String
value
Type: Online System Int64
See Also
BSONInt64Element Class
BSONInt64Element Members
BSONInt64Element Overload
NFX.Serialization.BSON Namespace


BSONInt64Element Fields

BSONInt64Element Fields NFX Class Library

The BSONInt64Element type exposes the following members.
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONInt64Element Class
NFX.Serialization.BSON Namespace


BSONInt64Element Methods

BSONInt64Element Methods NFX Class Library

The BSONInt64Element type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Overrides BSONElement WriteAsJSON(TextWriter, Int32, JSONWritingOptions).)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BSONInt64Element Class
NFX.Serialization.BSON Namespace


BSONInt64Element.GetValueByteSize Method

BSONInt64Element GetValueByteSize Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override int GetValueByteSize()
protected internal override int GetValueByteSize()
Protected Friend Overrides Function GetValueByteSize As Integer
Protected Friend Overrides Function GetValueByteSize As Integer
protected public:
virtual int GetValueByteSize() override
protected public:
virtual int GetValueByteSize() override
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int

Return Value

Type: Online Int32
See Also
BSONInt64Element Class
BSONInt64Element Members
NFX.Serialization.BSON Namespace


BSONInt64Element.ReadValueFromStream Method

BSONInt64Element ReadValueFromStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void ReadValueFromStream(
    Stream stream
)
protected override void ReadValueFromStream(
    Stream stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONInt64Element Class
BSONInt64Element Members
NFX.Serialization.BSON Namespace


BSONInt64Element.WriteAsJSON Method

BSONInt64Element WriteAsJSON Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
public override void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
Public Overrides Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
Public Overrides Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) override
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) override
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
nestingLevel
Type: Online System Int32
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Implements

IJSONWritable WriteAsJSON(TextWriter, Int32, JSONWritingOptions)
See Also
BSONInt64Element Class
BSONInt64Element Members
NFX.Serialization.BSON Namespace


BSONInt64Element.WriteValueToStream Method

BSONInt64Element WriteValueToStream Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void WriteValueToStream(
    Stream stream
)
protected internal override void WriteValueToStream(
    Stream stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONInt64Element Class
BSONInt64Element Members
NFX.Serialization.BSON Namespace


BSONInt64Element Properties

BSONInt64Element Properties NFX Class Library

The BSONInt64Element type exposes the following members.
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONInt64Element Class
NFX.Serialization.BSON Namespace


BSONInt64Element.ElementType Property

BSONInt64Element ElementType Property NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override BSONElementType ElementType { get; }
public override BSONElementType ElementType { get; }
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get

Property Value

Type: BSONElementType
See Also
BSONInt64Element Class
BSONInt64Element Members
NFX.Serialization.BSON Namespace


BSONJavaScriptElement Class

BSONJavaScriptElement Class NFX Class Library

Represents a BSON element with a javascript value
Inheritance Hierarchy
Online System Object
NFX.Serialization.BSON BSONElement
NFX.Serialization.BSON BSONElement Online String
NFX.Serialization.BSON BSONJavaScriptElement

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class BSONJavaScriptElement : BSONElement<string>
public sealed class BSONJavaScriptElement : BSONElement<string>
Public NotInheritable Class BSONJavaScriptElement
    Inherits BSONElement(Of String)
Public NotInheritable Class BSONJavaScriptElement
    Inherits BSONElement(Of String)
public ref class BSONJavaScriptElement sealed : public BSONElement<String^>
public ref class BSONJavaScriptElement sealed : public BSONElement<String^>
[<SealedAttribute>]
type BSONJavaScriptElement =
    class
        inherit BSONElement<string>
    end
[<SealedAttribute>]
type BSONJavaScriptElement =
    class
        inherit BSONElement<string>
    end
See Also
BSONJavaScriptElement Members
NFX.Serialization.BSON Namespace


BSONJavaScriptElement Members

BSONJavaScriptElement Members NFX Class Library

The BSONJavaScriptElement type exposes the following members.
Constructors
 | Name | Description
Protected method | BSONJavaScriptElement(Stream) | Initializes a new instance of the BSONJavaScriptElement class
Public method | BSONJavaScriptElement(String) | Creates an array element
Public method | BSONJavaScriptElement(String, String) | Initializes a new instance of the BSONJavaScriptElement class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONJavaScriptElement Class
NFX.Serialization.BSON Namespace


BSONJavaScriptElement Constructor

BSONJavaScriptElement Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | BSONJavaScriptElement(Stream) | Initializes a new instance of the BSONJavaScriptElement class
Public method | BSONJavaScriptElement(String) | Creates an array element
Public method | BSONJavaScriptElement(String, String) | Initializes a new instance of the BSONJavaScriptElement class
Back to Top
See Also
BSONJavaScriptElement Class
BSONJavaScriptElement Members
NFX.Serialization.BSON Namespace


BSONJavaScriptElement Constructor (Stream)

BSONJavaScriptElement Constructor (Stream) NFX Class Library

Initializes a new instance of the BSONJavaScriptElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal BSONJavaScriptElement(
    Stream stream
)
internal BSONJavaScriptElement(
    Stream stream
)
Friend Sub New (
    stream As Stream
)
Friend Sub New (
    stream As Stream
)
internal:
BSONJavaScriptElement(
    Stream^ stream
)
internal:
BSONJavaScriptElement(
    Stream^ stream
)
new :
        stream : Stream -> BSONJavaScriptElement
new :
        stream : Stream -> BSONJavaScriptElement

Parameters

stream
Type: Online System.IO Stream
See Also
BSONJavaScriptElement Class
BSONJavaScriptElement Members
BSONJavaScriptElement Overload
NFX.Serialization.BSON Namespace


BSONJavaScriptElement Constructor (String)

BSONJavaScriptElement Constructor (String) NFX Class Library

Creates an array element

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONJavaScriptElement(
    string value
)
public BSONJavaScriptElement(
    string value
)
Public Sub New (
    value As String
)
Public Sub New (
    value As String
)
public:
BSONJavaScriptElement(
    String^ value
)
public:
BSONJavaScriptElement(
    String^ value
)
new :
        value : string -> BSONJavaScriptElement
new :
        value : string -> BSONJavaScriptElement

Parameters

value
Type: Online System String
See Also
BSONJavaScriptElement Class
BSONJavaScriptElement Members
BSONJavaScriptElement Overload
NFX.Serialization.BSON Namespace


BSONJavaScriptElement Constructor (String, String)

BSONJavaScriptElement Constructor (String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BSONJavaScriptElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONJavaScriptElement(
    string name,
    string value
)
public BSONJavaScriptElement(
    string name,
    string value
)
Public Sub New (
    name As String,
    value As String
)
Public Sub New (
    name As String,
    value As String
)
public:
BSONJavaScriptElement(
    String^ name,
    String^ value
)
public:
BSONJavaScriptElement(
    String^ name,
    String^ value
)
new :
        name : string *
        value : string -> BSONJavaScriptElement
new :
        name : string *
        value : string -> BSONJavaScriptElement

Parameters

name
Type: Online System String
value
Type: Online System String
See Also
BSONJavaScriptElement Class
BSONJavaScriptElement Members
BSONJavaScriptElement Overload
NFX.Serialization.BSON Namespace


BSONJavaScriptElement Fields

BSONJavaScriptElement Fields NFX Class Library

The BSONJavaScriptElement type exposes the following members.
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONJavaScriptElement Class
NFX.Serialization.BSON Namespace


BSONJavaScriptElement Methods

BSONJavaScriptElement Methods NFX Class Library

The BSONJavaScriptElement type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BSONJavaScriptElement Class
NFX.Serialization.BSON Namespace


BSONJavaScriptElement.GetValueByteSize Method

BSONJavaScriptElement GetValueByteSize Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override int GetValueByteSize()
protected internal override int GetValueByteSize()
Protected Friend Overrides Function GetValueByteSize As Integer
Protected Friend Overrides Function GetValueByteSize As Integer
protected public:
virtual int GetValueByteSize() override
protected public:
virtual int GetValueByteSize() override
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int

Return Value

Type: Online Int32
See Also
BSONJavaScriptElement Class
BSONJavaScriptElement Members
NFX.Serialization.BSON Namespace


BSONJavaScriptElement.ReadValueFromStream Method

BSONJavaScriptElement ReadValueFromStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void ReadValueFromStream(
    Stream stream
)
protected override void ReadValueFromStream(
    Stream stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONJavaScriptElement Class
BSONJavaScriptElement Members
NFX.Serialization.BSON Namespace


BSONJavaScriptElement.WriteValueToStream Method

BSONJavaScriptElement WriteValueToStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void WriteValueToStream(
    Stream stream
)
protected internal override void WriteValueToStream(
    Stream stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONJavaScriptElement Class
BSONJavaScriptElement Members
NFX.Serialization.BSON Namespace


BSONJavaScriptElement Properties

BSONJavaScriptElement Properties NFX Class Library

The BSONJavaScriptElement type exposes the following members.
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONJavaScriptElement Class
NFX.Serialization.BSON Namespace


BSONJavaScriptElement.ElementType Property

BSONJavaScriptElement ElementType Property NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override BSONElementType ElementType { get; }
public override BSONElementType ElementType { get; }
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get

Property Value

Type: BSONElementType
See Also
BSONJavaScriptElement Class
BSONJavaScriptElement Members
NFX.Serialization.BSON Namespace


BSONJavaScriptWithScopeElement Class

BSONJavaScriptWithScopeElement Class NFX Class Library

Represents a BSON element with a javascript with scope value
Inheritance Hierarchy
Online System Object
NFX.Serialization.BSON BSONElement
NFX.Serialization.BSON BSONElement BSONCodeWithScope
NFX.Serialization.BSON BSONJavaScriptWithScopeElement

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class BSONJavaScriptWithScopeElement : BSONElement<BSONCodeWithScope>
public sealed class BSONJavaScriptWithScopeElement : BSONElement<BSONCodeWithScope>
Public NotInheritable Class BSONJavaScriptWithScopeElement
    Inherits BSONElement(Of BSONCodeWithScope)
Public NotInheritable Class BSONJavaScriptWithScopeElement
    Inherits BSONElement(Of BSONCodeWithScope)
public ref class BSONJavaScriptWithScopeElement sealed : public BSONElement<BSONCodeWithScope>
public ref class BSONJavaScriptWithScopeElement sealed : public BSONElement<BSONCodeWithScope>
[<SealedAttribute>]
type BSONJavaScriptWithScopeElement =
    class
        inherit BSONElement<BSONCodeWithScope>
    end
[<SealedAttribute>]
type BSONJavaScriptWithScopeElement =
    class
        inherit BSONElement<BSONCodeWithScope>
    end
See Also
BSONJavaScriptWithScopeElement Members
NFX.Serialization.BSON Namespace


BSONJavaScriptWithScopeElement Members

BSONJavaScriptWithScopeElement Members NFX Class Library

The BSONJavaScriptWithScopeElement type exposes the following members.
Constructors
 | Name | Description
Protected method | BSONJavaScriptWithScopeElement(Stream) | Initializes a new instance of the BSONJavaScriptWithScopeElement class
Public method | BSONJavaScriptWithScopeElement(BSONCodeWithScope) | Creates an array element
Public method | BSONJavaScriptWithScopeElement(String, BSONCodeWithScope) | Initializes a new instance of the BSONJavaScriptWithScopeElement class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONJavaScriptWithScopeElement Class
NFX.Serialization.BSON Namespace


BSONJavaScriptWithScopeElement Constructor

BSONJavaScriptWithScopeElement Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | BSONJavaScriptWithScopeElement(Stream) | Initializes a new instance of the BSONJavaScriptWithScopeElement class
Public method | BSONJavaScriptWithScopeElement(BSONCodeWithScope) | Creates an array element
Public method | BSONJavaScriptWithScopeElement(String, BSONCodeWithScope) | Initializes a new instance of the BSONJavaScriptWithScopeElement class
Back to Top
See Also
BSONJavaScriptWithScopeElement Class
BSONJavaScriptWithScopeElement Members
NFX.Serialization.BSON Namespace


BSONJavaScriptWithScopeElement Constructor (Stream)

BSONJavaScriptWithScopeElement Constructor (Stream) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BSONJavaScriptWithScopeElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal BSONJavaScriptWithScopeElement(
    Stream stream
)
internal BSONJavaScriptWithScopeElement(
    Stream stream
)
Friend Sub New (
    stream As Stream
)
Friend Sub New (
    stream As Stream
)
internal:
BSONJavaScriptWithScopeElement(
    Stream^ stream
)
internal:
BSONJavaScriptWithScopeElement(
    Stream^ stream
)
new :
        stream : Stream -> BSONJavaScriptWithScopeElement
new :
        stream : Stream -> BSONJavaScriptWithScopeElement

Parameters

stream
Type: Online System.IO Stream
See Also
BSONJavaScriptWithScopeElement Class
BSONJavaScriptWithScopeElement Members
BSONJavaScriptWithScopeElement Overload
NFX.Serialization.BSON Namespace


BSONJavaScriptWithScopeElement Constructor (BSONCodeWithScope)

BSONJavaScriptWithScopeElement Constructor (BSONCodeWithScope) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates an array element

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONJavaScriptWithScopeElement(
    BSONCodeWithScope value
)
public BSONJavaScriptWithScopeElement(
    BSONCodeWithScope value
)
Public Sub New (
    value As BSONCodeWithScope
)
Public Sub New (
    value As BSONCodeWithScope
)
public:
BSONJavaScriptWithScopeElement(
    BSONCodeWithScope value
)
public:
BSONJavaScriptWithScopeElement(
    BSONCodeWithScope value
)
new :
        value : BSONCodeWithScope -> BSONJavaScriptWithScopeElement
new :
        value : BSONCodeWithScope -> BSONJavaScriptWithScopeElement

Parameters

value
Type: NFX.Serialization.BSON BSONCodeWithScope
See Also
BSONJavaScriptWithScopeElement Class
BSONJavaScriptWithScopeElement Members
BSONJavaScriptWithScopeElement Overload
NFX.Serialization.BSON Namespace


BSONJavaScriptWithScopeElement Constructor (String, BSONCodeWithScope)

BSONJavaScriptWithScopeElement Constructor (String, BSONCodeWithScope) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BSONJavaScriptWithScopeElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONJavaScriptWithScopeElement(
    string name,
    BSONCodeWithScope value
)
public BSONJavaScriptWithScopeElement(
    string name,
    BSONCodeWithScope value
)
Public Sub New (
    name As String,
    value As BSONCodeWithScope
)
Public Sub New (
    name As String,
    value As BSONCodeWithScope
)
public:
BSONJavaScriptWithScopeElement(
    String^ name,
    BSONCodeWithScope value
)
public:
BSONJavaScriptWithScopeElement(
    String^ name,
    BSONCodeWithScope value
)
new :
        name : string *
        value : BSONCodeWithScope -> BSONJavaScriptWithScopeElement
new :
        name : string *
        value : BSONCodeWithScope -> BSONJavaScriptWithScopeElement

Parameters

name
Type: Online System String
value
Type: NFX.Serialization.BSON BSONCodeWithScope
See Also
BSONJavaScriptWithScopeElement Class
BSONJavaScriptWithScopeElement Members
BSONJavaScriptWithScopeElement Overload
NFX.Serialization.BSON Namespace


BSONJavaScriptWithScopeElement Fields

BSONJavaScriptWithScopeElement Fields NFX Class Library

The BSONJavaScriptWithScopeElement type exposes the following members.
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONJavaScriptWithScopeElement Class
NFX.Serialization.BSON Namespace


BSONJavaScriptWithScopeElement Methods

BSONJavaScriptWithScopeElement Methods NFX Class Library

The BSONJavaScriptWithScopeElement type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BSONJavaScriptWithScopeElement Class
NFX.Serialization.BSON Namespace


BSONJavaScriptWithScopeElement.GetValueByteSize Method

BSONJavaScriptWithScopeElement GetValueByteSize Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override int GetValueByteSize()
protected internal override int GetValueByteSize()
Protected Friend Overrides Function GetValueByteSize As Integer
Protected Friend Overrides Function GetValueByteSize As Integer
protected public:
virtual int GetValueByteSize() override
protected public:
virtual int GetValueByteSize() override
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int

Return Value

Type: Online Int32
See Also
BSONJavaScriptWithScopeElement Class
BSONJavaScriptWithScopeElement Members
NFX.Serialization.BSON Namespace


BSONJavaScriptWithScopeElement.ReadValueFromStream Method

BSONJavaScriptWithScopeElement ReadValueFromStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void ReadValueFromStream(
    Stream stream
)
protected override void ReadValueFromStream(
    Stream stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONJavaScriptWithScopeElement Class
BSONJavaScriptWithScopeElement Members
NFX.Serialization.BSON Namespace


BSONJavaScriptWithScopeElement.WriteValueToStream Method

BSONJavaScriptWithScopeElement WriteValueToStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void WriteValueToStream(
    Stream stream
)
protected internal override void WriteValueToStream(
    Stream stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONJavaScriptWithScopeElement Class
BSONJavaScriptWithScopeElement Members
NFX.Serialization.BSON Namespace


BSONJavaScriptWithScopeElement Properties

BSONJavaScriptWithScopeElement Properties NFX Class Library

The BSONJavaScriptWithScopeElement type exposes the following members.
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONJavaScriptWithScopeElement Class
NFX.Serialization.BSON Namespace


BSONJavaScriptWithScopeElement.ElementType Property

BSONJavaScriptWithScopeElement ElementType Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override BSONElementType ElementType { get; }
public override BSONElementType ElementType { get; }
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get

Property Value

Type: BSONElementType
See Also
BSONJavaScriptWithScopeElement Class
BSONJavaScriptWithScopeElement Members
NFX.Serialization.BSON Namespace


BSONMaxKeyElement Class

BSONMaxKeyElement Class NFX Class Library

Represents an element with MaxKey value
Inheritance Hierarchy
Online System Object
NFX.Serialization.BSON BSONElement
NFX.Serialization.BSON BSONMaxKeyElement

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class BSONMaxKeyElement : BSONElement
public sealed class BSONMaxKeyElement : BSONElement
Public NotInheritable Class BSONMaxKeyElement
    Inherits BSONElement
Public NotInheritable Class BSONMaxKeyElement
    Inherits BSONElement
public ref class BSONMaxKeyElement sealed : public BSONElement
public ref class BSONMaxKeyElement sealed : public BSONElement
[<SealedAttribute>]
type BSONMaxKeyElement =
    class
        inherit BSONElement
    end
[<SealedAttribute>]
type BSONMaxKeyElement =
    class
        inherit BSONElement
    end
See Also
BSONMaxKeyElement Members
NFX.Serialization.BSON Namespace


BSONMaxKeyElement Members

BSONMaxKeyElement Members NFX Class Library

The BSONMaxKeyElement type exposes the following members.
Constructors
 | Name | Description
Public method | BSONMaxKeyElement | Initializes a new instance of the BSONMaxKeyElement class
Protected method | BSONMaxKeyElement(Stream) | Initializes a new instance of the BSONMaxKeyElement class
Public method | BSONMaxKeyElement(String) | Initializes a new instance of the BSONMaxKeyElement class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement.)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Overrides BSONElement WriteAsJSON(TextWriter, Int32, JSONWritingOptions).)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | (Overrides BSONElement ObjectValue.)
Back to Top
See Also
BSONMaxKeyElement Class
NFX.Serialization.BSON Namespace


BSONMaxKeyElement Constructor

BSONMaxKeyElement Constructor NFX Class Library

Overload List
 | Name | Description
Public method | BSONMaxKeyElement | Initializes a new instance of the BSONMaxKeyElement class
Protected method | BSONMaxKeyElement(Stream) | Initializes a new instance of the BSONMaxKeyElement class
Public method | BSONMaxKeyElement(String) | Initializes a new instance of the BSONMaxKeyElement class
Back to Top
See Also
BSONMaxKeyElement Class
BSONMaxKeyElement Members
NFX.Serialization.BSON Namespace


BSONMaxKeyElement Constructor

BSONMaxKeyElement Constructor NFX Class Library

Initializes a new instance of the BSONMaxKeyElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONMaxKeyElement()
public BSONMaxKeyElement()
Public Sub New
Public Sub New
public:
BSONMaxKeyElement()
public:
BSONMaxKeyElement()
new : unit -> BSONMaxKeyElement
new : unit -> BSONMaxKeyElement
See Also
BSONMaxKeyElement Class
BSONMaxKeyElement Members
BSONMaxKeyElement Overload
NFX.Serialization.BSON Namespace


BSONMaxKeyElement Constructor (Stream)

BSONMaxKeyElement Constructor (Stream) NFX Class Library

Initializes a new instance of the BSONMaxKeyElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal BSONMaxKeyElement(
    Stream stream
)
internal BSONMaxKeyElement(
    Stream stream
)
Friend Sub New (
    stream As Stream
)
Friend Sub New (
    stream As Stream
)
internal:
BSONMaxKeyElement(
    Stream^ stream
)
internal:
BSONMaxKeyElement(
    Stream^ stream
)
new :
        stream : Stream -> BSONMaxKeyElement
new :
        stream : Stream -> BSONMaxKeyElement

Parameters

stream
Type: Online System.IO Stream
See Also
BSONMaxKeyElement Class
BSONMaxKeyElement Members
BSONMaxKeyElement Overload
NFX.Serialization.BSON Namespace


BSONMaxKeyElement Constructor (String)

BSONMaxKeyElement Constructor (String) NFX Class Library

Initializes a new instance of the BSONMaxKeyElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONMaxKeyElement(
    string name
)
public BSONMaxKeyElement(
    string name
)
Public Sub New (
    name As String
)
Public Sub New (
    name As String
)
public:
BSONMaxKeyElement(
    String^ name
)
public:
BSONMaxKeyElement(
    String^ name
)
new :
        name : string -> BSONMaxKeyElement
new :
        name : string -> BSONMaxKeyElement

Parameters

name
Type: Online System String
See Also
BSONMaxKeyElement Class
BSONMaxKeyElement Members
BSONMaxKeyElement Overload
NFX.Serialization.BSON Namespace


BSONMaxKeyElement Methods

BSONMaxKeyElement Methods NFX Class Library

The BSONMaxKeyElement type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement.)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Overrides BSONElement WriteAsJSON(TextWriter, Int32, JSONWritingOptions).)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BSONMaxKeyElement Class
NFX.Serialization.BSON Namespace


BSONMaxKeyElement.GetValueByteSize Method

BSONMaxKeyElement GetValueByteSize Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override int GetValueByteSize()
protected internal override int GetValueByteSize()
Protected Friend Overrides Function GetValueByteSize As Integer
Protected Friend Overrides Function GetValueByteSize As Integer
protected public:
virtual int GetValueByteSize() override
protected public:
virtual int GetValueByteSize() override
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int

Return Value

Type: Online Int32
See Also
BSONMaxKeyElement Class
BSONMaxKeyElement Members
NFX.Serialization.BSON Namespace


BSONMaxKeyElement.ReadValueFromStream Method

BSONMaxKeyElement ReadValueFromStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void ReadValueFromStream(
    Stream stream
)
protected override void ReadValueFromStream(
    Stream stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONMaxKeyElement Class
BSONMaxKeyElement Members
NFX.Serialization.BSON Namespace


BSONMaxKeyElement.WriteAsJSON Method

BSONMaxKeyElement WriteAsJSON Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
public override void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
Public Overrides Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
Public Overrides Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) override
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) override
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
nestingLevel
Type: Online System Int32
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Implements

IJSONWritable WriteAsJSON(TextWriter, Int32, JSONWritingOptions)
See Also
BSONMaxKeyElement Class
BSONMaxKeyElement Members
NFX.Serialization.BSON Namespace


BSONMaxKeyElement.WriteValueToStream Method

BSONMaxKeyElement WriteValueToStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void WriteValueToStream(
    Stream stream
)
protected internal override void WriteValueToStream(
    Stream stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONMaxKeyElement Class
BSONMaxKeyElement Members
NFX.Serialization.BSON Namespace


BSONMaxKeyElement Properties

BSONMaxKeyElement Properties NFX Class Library

The BSONMaxKeyElement type exposes the following members.
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | (Overrides BSONElement ObjectValue.)
Back to Top
See Also
BSONMaxKeyElement Class
NFX.Serialization.BSON Namespace


BSONMaxKeyElement.ElementType Property

BSONMaxKeyElement ElementType Property NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override BSONElementType ElementType { get; }
public override BSONElementType ElementType { get; }
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get

Property Value

Type: BSONElementType
See Also
BSONMaxKeyElement Class
BSONMaxKeyElement Members
NFX.Serialization.BSON Namespace


BSONMaxKeyElement.ObjectValue Property

BSONMaxKeyElement ObjectValue Property NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object ObjectValue { get; set; }
public override Object ObjectValue { get; set; }
Public Overrides Property ObjectValue As Object
    Get
    Set
Public Overrides Property ObjectValue As Object
    Get
    Set
public:
virtual property Object^ ObjectValue {
    Object^ get () override;
    void set (Object^ value) override;
}
public:
virtual property Object^ ObjectValue {
    Object^ get () override;
    void set (Object^ value) override;
}
abstract ObjectValue : Object with get, set
override ObjectValue : Object with get, set
abstract ObjectValue : Object with get, set
override ObjectValue : Object with get, set

Property Value

Type: Online Object
See Also
BSONMaxKeyElement Class
BSONMaxKeyElement Members
NFX.Serialization.BSON Namespace


BSONMinKeyElement Class

BSONMinKeyElement Class NFX Class Library

Represents an element with Min Key value
Inheritance Hierarchy
Online System Object
NFX.Serialization.BSON BSONElement
NFX.Serialization.BSON BSONMinKeyElement

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class BSONMinKeyElement : BSONElement
public sealed class BSONMinKeyElement : BSONElement
Public NotInheritable Class BSONMinKeyElement
    Inherits BSONElement
Public NotInheritable Class BSONMinKeyElement
    Inherits BSONElement
public ref class BSONMinKeyElement sealed : public BSONElement
public ref class BSONMinKeyElement sealed : public BSONElement
[<SealedAttribute>]
type BSONMinKeyElement =
    class
        inherit BSONElement
    end
[<SealedAttribute>]
type BSONMinKeyElement =
    class
        inherit BSONElement
    end
See Also
BSONMinKeyElement Members
NFX.Serialization.BSON Namespace


BSONMinKeyElement Members

BSONMinKeyElement Members NFX Class Library

The BSONMinKeyElement type exposes the following members.
Constructors
 | Name | Description
Public method | BSONMinKeyElement | Initializes a new instance of the BSONMinKeyElement class
Protected method | BSONMinKeyElement(Stream) | Initializes a new instance of the BSONMinKeyElement class
Public method | BSONMinKeyElement(String) | Initializes a new instance of the BSONMinKeyElement class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement.)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Overrides BSONElement WriteAsJSON(TextWriter, Int32, JSONWritingOptions).)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | (Overrides BSONElement ObjectValue.)
Back to Top
See Also
BSONMinKeyElement Class
NFX.Serialization.BSON Namespace


BSONMinKeyElement Constructor

BSONMinKeyElement Constructor NFX Class Library

Overload List
 | Name | Description
Public method | BSONMinKeyElement | Initializes a new instance of the BSONMinKeyElement class
Protected method | BSONMinKeyElement(Stream) | Initializes a new instance of the BSONMinKeyElement class
Public method | BSONMinKeyElement(String) | Initializes a new instance of the BSONMinKeyElement class
Back to Top
See Also
BSONMinKeyElement Class
BSONMinKeyElement Members
NFX.Serialization.BSON Namespace


BSONMinKeyElement Constructor

BSONMinKeyElement Constructor NFX Class Library

Initializes a new instance of the BSONMinKeyElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONMinKeyElement()
public BSONMinKeyElement()
Public Sub New
Public Sub New
public:
BSONMinKeyElement()
public:
BSONMinKeyElement()
new : unit -> BSONMinKeyElement
new : unit -> BSONMinKeyElement
See Also
BSONMinKeyElement Class
BSONMinKeyElement Members
BSONMinKeyElement Overload
NFX.Serialization.BSON Namespace


BSONMinKeyElement Constructor (Stream)

BSONMinKeyElement Constructor (Stream) NFX Class Library

Initializes a new instance of the BSONMinKeyElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal BSONMinKeyElement(
    Stream stream
)
internal BSONMinKeyElement(
    Stream stream
)
Friend Sub New (
    stream As Stream
)
Friend Sub New (
    stream As Stream
)
internal:
BSONMinKeyElement(
    Stream^ stream
)
internal:
BSONMinKeyElement(
    Stream^ stream
)
new :
        stream : Stream -> BSONMinKeyElement
new :
        stream : Stream -> BSONMinKeyElement

Parameters

stream
Type: Online System.IO Stream
See Also
BSONMinKeyElement Class
BSONMinKeyElement Members
BSONMinKeyElement Overload
NFX.Serialization.BSON Namespace


BSONMinKeyElement Constructor (String)

BSONMinKeyElement Constructor (String) NFX Class Library

Initializes a new instance of the BSONMinKeyElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONMinKeyElement(
    string name
)
public BSONMinKeyElement(
    string name
)
Public Sub New (
    name As String
)
Public Sub New (
    name As String
)
public:
BSONMinKeyElement(
    String^ name
)
public:
BSONMinKeyElement(
    String^ name
)
new :
        name : string -> BSONMinKeyElement
new :
        name : string -> BSONMinKeyElement

Parameters

name
Type: Online System String
See Also
BSONMinKeyElement Class
BSONMinKeyElement Members
BSONMinKeyElement Overload
NFX.Serialization.BSON Namespace


BSONMinKeyElement Methods

BSONMinKeyElement Methods NFX Class Library

The BSONMinKeyElement type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement.)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Overrides BSONElement WriteAsJSON(TextWriter, Int32, JSONWritingOptions).)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BSONMinKeyElement Class
NFX.Serialization.BSON Namespace


BSONMinKeyElement.GetValueByteSize Method

BSONMinKeyElement GetValueByteSize Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override int GetValueByteSize()
protected internal override int GetValueByteSize()
Protected Friend Overrides Function GetValueByteSize As Integer
Protected Friend Overrides Function GetValueByteSize As Integer
protected public:
virtual int GetValueByteSize() override
protected public:
virtual int GetValueByteSize() override
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int

Return Value

Type: Online Int32
See Also
BSONMinKeyElement Class
BSONMinKeyElement Members
NFX.Serialization.BSON Namespace


BSONMinKeyElement.ReadValueFromStream Method

BSONMinKeyElement ReadValueFromStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void ReadValueFromStream(
    Stream stream
)
protected override void ReadValueFromStream(
    Stream stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONMinKeyElement Class
BSONMinKeyElement Members
NFX.Serialization.BSON Namespace


BSONMinKeyElement.WriteAsJSON Method

BSONMinKeyElement WriteAsJSON Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
public override void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
Public Overrides Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
Public Overrides Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) override
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) override
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
nestingLevel
Type: Online System Int32
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Implements

IJSONWritable WriteAsJSON(TextWriter, Int32, JSONWritingOptions)
See Also
BSONMinKeyElement Class
BSONMinKeyElement Members
NFX.Serialization.BSON Namespace


BSONMinKeyElement.WriteValueToStream Method

BSONMinKeyElement WriteValueToStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void WriteValueToStream(
    Stream stream
)
protected internal override void WriteValueToStream(
    Stream stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONMinKeyElement Class
BSONMinKeyElement Members
NFX.Serialization.BSON Namespace


BSONMinKeyElement Properties

BSONMinKeyElement Properties NFX Class Library

The BSONMinKeyElement type exposes the following members.
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | (Overrides BSONElement ObjectValue.)
Back to Top
See Also
BSONMinKeyElement Class
NFX.Serialization.BSON Namespace


BSONMinKeyElement.ElementType Property

BSONMinKeyElement ElementType Property NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override BSONElementType ElementType { get; }
public override BSONElementType ElementType { get; }
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get

Property Value

Type: BSONElementType
See Also
BSONMinKeyElement Class
BSONMinKeyElement Members
NFX.Serialization.BSON Namespace


BSONMinKeyElement.ObjectValue Property

BSONMinKeyElement ObjectValue Property NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object ObjectValue { get; set; }
public override Object ObjectValue { get; set; }
Public Overrides Property ObjectValue As Object
    Get
    Set
Public Overrides Property ObjectValue As Object
    Get
    Set
public:
virtual property Object^ ObjectValue {
    Object^ get () override;
    void set (Object^ value) override;
}
public:
virtual property Object^ ObjectValue {
    Object^ get () override;
    void set (Object^ value) override;
}
abstract ObjectValue : Object with get, set
override ObjectValue : Object with get, set
abstract ObjectValue : Object with get, set
override ObjectValue : Object with get, set

Property Value

Type: Online Object
See Also
BSONMinKeyElement Class
BSONMinKeyElement Members
NFX.Serialization.BSON Namespace


BSONNullElement Class

BSONNullElement Class NFX Class Library

Represents an element with NULL value
Inheritance Hierarchy
Online System Object
NFX.Serialization.BSON BSONElement
NFX.Serialization.BSON BSONNullElement

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class BSONNullElement : BSONElement
public sealed class BSONNullElement : BSONElement
Public NotInheritable Class BSONNullElement
    Inherits BSONElement
Public NotInheritable Class BSONNullElement
    Inherits BSONElement
public ref class BSONNullElement sealed : public BSONElement
public ref class BSONNullElement sealed : public BSONElement
[<SealedAttribute>]
type BSONNullElement =
    class
        inherit BSONElement
    end
[<SealedAttribute>]
type BSONNullElement =
    class
        inherit BSONElement
    end
See Also
BSONNullElement Members
NFX.Serialization.BSON Namespace


BSONNullElement Members

BSONNullElement Members NFX Class Library

The BSONNullElement type exposes the following members.
Constructors
 | Name | Description
Public method | BSONNullElement | Initializes a new instance of the BSONNullElement class
Protected method | BSONNullElement(Stream) | Initializes a new instance of the BSONNullElement class
Public method | BSONNullElement(String) | Initializes a new instance of the BSONNullElement class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement.)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | (Overrides BSONElement ObjectValue.)
Back to Top
See Also
BSONNullElement Class
NFX.Serialization.BSON Namespace


BSONNullElement Constructor

BSONNullElement Constructor NFX Class Library

Overload List
 | Name | Description
Public method | BSONNullElement | Initializes a new instance of the BSONNullElement class
Protected method | BSONNullElement(Stream) | Initializes a new instance of the BSONNullElement class
Public method | BSONNullElement(String) | Initializes a new instance of the BSONNullElement class
Back to Top
See Also
BSONNullElement Class
BSONNullElement Members
NFX.Serialization.BSON Namespace


BSONNullElement Constructor

BSONNullElement Constructor NFX Class Library

Initializes a new instance of the BSONNullElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONNullElement()
public BSONNullElement()
Public Sub New
Public Sub New
public:
BSONNullElement()
public:
BSONNullElement()
new : unit -> BSONNullElement
new : unit -> BSONNullElement
See Also
BSONNullElement Class
BSONNullElement Members
BSONNullElement Overload
NFX.Serialization.BSON Namespace


BSONNullElement Constructor (Stream)

BSONNullElement Constructor (Stream) NFX Class Library

Initializes a new instance of the BSONNullElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal BSONNullElement(
    Stream stream
)
internal BSONNullElement(
    Stream stream
)
Friend Sub New (
    stream As Stream
)
Friend Sub New (
    stream As Stream
)
internal:
BSONNullElement(
    Stream^ stream
)
internal:
BSONNullElement(
    Stream^ stream
)
new :
        stream : Stream -> BSONNullElement
new :
        stream : Stream -> BSONNullElement

Parameters

stream
Type: Online System.IO Stream
See Also
BSONNullElement Class
BSONNullElement Members
BSONNullElement Overload
NFX.Serialization.BSON Namespace


BSONNullElement Constructor (String)

BSONNullElement Constructor (String) NFX Class Library

Initializes a new instance of the BSONNullElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONNullElement(
    string name
)
public BSONNullElement(
    string name
)
Public Sub New (
    name As String
)
Public Sub New (
    name As String
)
public:
BSONNullElement(
    String^ name
)
public:
BSONNullElement(
    String^ name
)
new :
        name : string -> BSONNullElement
new :
        name : string -> BSONNullElement

Parameters

name
Type: Online System String
See Also
BSONNullElement Class
BSONNullElement Members
BSONNullElement Overload
NFX.Serialization.BSON Namespace


BSONNullElement Methods

BSONNullElement Methods NFX Class Library

The BSONNullElement type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement.)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BSONNullElement Class
NFX.Serialization.BSON Namespace


BSONNullElement.GetValueByteSize Method

BSONNullElement GetValueByteSize Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override int GetValueByteSize()
protected internal override int GetValueByteSize()
Protected Friend Overrides Function GetValueByteSize As Integer
Protected Friend Overrides Function GetValueByteSize As Integer
protected public:
virtual int GetValueByteSize() override
protected public:
virtual int GetValueByteSize() override
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int

Return Value

Type: Online Int32
See Also
BSONNullElement Class
BSONNullElement Members
NFX.Serialization.BSON Namespace


BSONNullElement.ReadValueFromStream Method

BSONNullElement ReadValueFromStream Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void ReadValueFromStream(
    Stream stream
)
protected override void ReadValueFromStream(
    Stream stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONNullElement Class
BSONNullElement Members
NFX.Serialization.BSON Namespace


BSONNullElement.WriteValueToStream Method

BSONNullElement WriteValueToStream Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void WriteValueToStream(
    Stream stream
)
protected internal override void WriteValueToStream(
    Stream stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONNullElement Class
BSONNullElement Members
NFX.Serialization.BSON Namespace


BSONNullElement Properties

BSONNullElement Properties NFX Class Library

The BSONNullElement type exposes the following members.
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | (Overrides BSONElement ObjectValue.)
Back to Top
See Also
BSONNullElement Class
NFX.Serialization.BSON Namespace


BSONNullElement.ElementType Property

BSONNullElement ElementType Property NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override BSONElementType ElementType { get; }
public override BSONElementType ElementType { get; }
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get

Property Value

Type: BSONElementType
See Also
BSONNullElement Class
BSONNullElement Members
NFX.Serialization.BSON Namespace


BSONNullElement.ObjectValue Property

BSONNullElement ObjectValue Property NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object ObjectValue { get; set; }
public override Object ObjectValue { get; set; }
Public Overrides Property ObjectValue As Object
    Get
    Set
Public Overrides Property ObjectValue As Object
    Get
    Set
public:
virtual property Object^ ObjectValue {
    Object^ get () override;
    void set (Object^ value) override;
}
public:
virtual property Object^ ObjectValue {
    Object^ get () override;
    void set (Object^ value) override;
}
abstract ObjectValue : Object with get, set
override ObjectValue : Object with get, set
abstract ObjectValue : Object with get, set
override ObjectValue : Object with get, set

Property Value

Type: Online Object
See Also
BSONNullElement Class
BSONNullElement Members
NFX.Serialization.BSON Namespace


BSONObjectID Structure

BSONObjectID Structure NFX Class Library

Represents an ObjectId as a 12-byte BSON type

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct BSONObjectID : IJSONWritable
public struct BSONObjectID : IJSONWritable
Public Structure BSONObjectID
    Implements IJSONWritable
Public Structure BSONObjectID
    Implements IJSONWritable
public value class BSONObjectID : IJSONWritable
public value class BSONObjectID : IJSONWritable
[<SealedAttribute>]
type BSONObjectID =
    struct
        interface IJSONWritable
    end
[<SealedAttribute>]
type BSONObjectID =
    struct
        interface IJSONWritable
    end
See Also
BSONObjectID Members
NFX.Serialization.BSON Namespace


BSONObjectID Members

BSONObjectID Members NFX Class Library

The BSONObjectID type exposes the following members.
Constructors
 | Name | Description
Public method | BSONObjectID( Byte ) | Initializes a new instance of the BSONObjectID class
Public method | BSONObjectID(GDID) | Initializes a new instance of the BSONObjectID class
Public method | BSONObjectID( Byte , Int32) | Initializes a new instance of the BSONObjectID class
Public method | BSONObjectID(UInt32, UInt32, UInt16, UInt32) | Initializes a new instance of the BSONObjectID class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Public method | WriteAsJSON |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Bytes |
Back to Top
Properties
 | Name | Description
Public property | AsGDID | Interprets BSON/MongoDB object ID as NFX GDID
Public property | Counter |
Public property | EpochSeconds |
Public property | MachineID |
Public property | ProcessID |
Back to Top
See Also
BSONObjectID Structure
NFX.Serialization.BSON Namespace


BSONObjectID Constructor

BSONObjectID Constructor NFX Class Library

Overload List
 | Name | Description
Public method | BSONObjectID( Byte ) | Initializes a new instance of the BSONObjectID class
Public method | BSONObjectID(GDID) | Initializes a new instance of the BSONObjectID class
Public method | BSONObjectID( Byte , Int32) | Initializes a new instance of the BSONObjectID class
Public method | BSONObjectID(UInt32, UInt32, UInt16, UInt32) | Initializes a new instance of the BSONObjectID class
Back to Top
See Also
BSONObjectID Structure
BSONObjectID Members
NFX.Serialization.BSON Namespace


BSONObjectID Constructor (Byte[])

BSONObjectID Constructor ( Byte ) NFX Class Library

Initializes a new instance of the BSONObjectID class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONObjectID(
    byte[] data
)
public BSONObjectID(
    byte[] data
)
Public Sub New (
    data As Byte()
)
Public Sub New (
    data As Byte()
)
public:
BSONObjectID(
    array<unsigned char>^ data
)
public:
BSONObjectID(
    array<unsigned char>^ data
)
new :
        data : byte[] -> BSONObjectID
new :
        data : byte[] -> BSONObjectID

Parameters

data
Type: Online System Byte
See Also
BSONObjectID Structure
BSONObjectID Members
BSONObjectID Overload
NFX.Serialization.BSON Namespace


BSONObjectID Constructor (GDID)

BSONObjectID Constructor (GDID) NFX Class Library

Initializes a new instance of the BSONObjectID class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONObjectID(
    GDID gdid
)
public BSONObjectID(
    GDID gdid
)
Public Sub New (
    gdid As GDID
)
Public Sub New (
    gdid As GDID
)
public:
BSONObjectID(
    GDID gdid
)
public:
BSONObjectID(
    GDID gdid
)
new :
        gdid : GDID -> BSONObjectID
new :
        gdid : GDID -> BSONObjectID

Parameters

gdid
Type: NFX.DataAccess.Distributed GDID
See Also
BSONObjectID Structure
BSONObjectID Members
BSONObjectID Overload
NFX.Serialization.BSON Namespace


BSONObjectID Constructor (Byte[], Int32)

BSONObjectID Constructor ( Byte , Int32) NFX Class Library

Initializes a new instance of the BSONObjectID class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONObjectID(
    byte[] data,
    int startIdx = 0
)
public BSONObjectID(
    byte[] data,
    int startIdx = 0
)
Public Sub New (
    data As Byte(),
    Optional startIdx As Integer = 0
)
Public Sub New (
    data As Byte(),
    Optional startIdx As Integer = 0
)
public:
BSONObjectID(
    array<unsigned char>^ data,
    int startIdx = 0
)
public:
BSONObjectID(
    array<unsigned char>^ data,
    int startIdx = 0
)
new :
        data : byte[] *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> BSONObjectID
new :
        data : byte[] *
        ?startIdx : int
(* Defaults:
        let _startIdx = defaultArg startIdx 0
*)
-> BSONObjectID

Parameters

data
Type: Online System Byte
startIdx (Optional)
Type: Online System Int32
See Also
BSONObjectID Structure
BSONObjectID Members
BSONObjectID Overload
NFX.Serialization.BSON Namespace


BSONObjectID Constructor (UInt32, UInt32, UInt16, UInt32)

BSONObjectID Constructor (UInt32, UInt32, UInt16, UInt32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BSONObjectID class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONObjectID(
    uint epochSeconds,
    uint machineId,
    ushort processId,
    uint counter
)
public BSONObjectID(
    uint epochSeconds,
    uint machineId,
    ushort processId,
    uint counter
)
Public Sub New (
    epochSeconds As UInteger,
    machineId As UInteger,
    processId As UShort,
    counter As UInteger
)
Public Sub New (
    epochSeconds As UInteger,
    machineId As UInteger,
    processId As UShort,
    counter As UInteger
)
public:
BSONObjectID(
    unsigned int epochSeconds,
    unsigned int machineId,
    unsigned short processId,
    unsigned int counter
)
public:
BSONObjectID(
    unsigned int epochSeconds,
    unsigned int machineId,
    unsigned short processId,
    unsigned int counter
)
new :
        epochSeconds : uint32 *
        machineId : uint32 *
        processId : uint16 *
        counter : uint32 -> BSONObjectID
new :
        epochSeconds : uint32 *
        machineId : uint32 *
        processId : uint16 *
        counter : uint32 -> BSONObjectID

Parameters

epochSeconds
Type: Online System UInt32
machineId
Type: Online System UInt32
processId
Type: Online System UInt16
counter
Type: Online System UInt32
See Also
BSONObjectID Structure
BSONObjectID Members
BSONObjectID Overload
NFX.Serialization.BSON Namespace


BSONObjectID Fields

BSONObjectID Fields NFX Class Library

The BSONObjectID type exposes the following members.
Fields
 | Name | Description
Public field | Bytes |
Back to Top
See Also
BSONObjectID Structure
NFX.Serialization.BSON Namespace


BSONObjectID.Bytes Field

BSONObjectID Bytes Field NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly byte[] Bytes
public readonly byte[] Bytes
Public ReadOnly Bytes As Byte()
Public ReadOnly Bytes As Byte()
public:
initonly array<unsigned char>^ Bytes
public:
initonly array<unsigned char>^ Bytes
val Bytes: byte[]
val Bytes: byte[]

Field Value

Type: Online Byte
See Also
BSONObjectID Structure
BSONObjectID Members
NFX.Serialization.BSON Namespace


BSONObjectID Methods

BSONObjectID Methods NFX Class Library

The BSONObjectID type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Public method | WriteAsJSON |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BSONObjectID Structure
NFX.Serialization.BSON Namespace


BSONObjectID.WriteAsJSON Method

BSONObjectID WriteAsJSON Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
nestingLevel
Type: Online System Int32
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Implements

IJSONWritable WriteAsJSON(TextWriter, Int32, JSONWritingOptions)
See Also
BSONObjectID Structure
BSONObjectID Members
NFX.Serialization.BSON Namespace


BSONObjectID Properties

BSONObjectID Properties NFX Class Library

The BSONObjectID type exposes the following members.
Properties
 | Name | Description
Public property | AsGDID | Interprets BSON/MongoDB object ID as NFX GDID
Public property | Counter |
Public property | EpochSeconds |
Public property | MachineID |
Public property | ProcessID |
Back to Top
See Also
BSONObjectID Structure
NFX.Serialization.BSON Namespace


BSONObjectID.AsGDID Property

BSONObjectID AsGDID Property NFX Class Library

Interprets BSON/MongoDB object ID as NFX GDID

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GDID AsGDID { get; }
public GDID AsGDID { get; }
Public ReadOnly Property AsGDID As GDID
    Get
Public ReadOnly Property AsGDID As GDID
    Get
public:
property GDID AsGDID {
    GDID get ();
}
public:
property GDID AsGDID {
    GDID get ();
}
member AsGDID : GDID with get
member AsGDID : GDID with get

Property Value

Type: GDID
See Also
BSONObjectID Structure
BSONObjectID Members
NFX.Serialization.BSON Namespace


BSONObjectID.Counter Property

BSONObjectID Counter Property NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint Counter { get; }
public uint Counter { get; }
Public ReadOnly Property Counter As UInteger
    Get
Public ReadOnly Property Counter As UInteger
    Get
public:
property unsigned int Counter {
    unsigned int get ();
}
public:
property unsigned int Counter {
    unsigned int get ();
}
member Counter : uint32 with get
member Counter : uint32 with get

Property Value

Type: Online UInt32
See Also
BSONObjectID Structure
BSONObjectID Members
NFX.Serialization.BSON Namespace


BSONObjectID.EpochSeconds Property

BSONObjectID EpochSeconds Property NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint EpochSeconds { get; }
public uint EpochSeconds { get; }
Public ReadOnly Property EpochSeconds As UInteger
    Get
Public ReadOnly Property EpochSeconds As UInteger
    Get
public:
property unsigned int EpochSeconds {
    unsigned int get ();
}
public:
property unsigned int EpochSeconds {
    unsigned int get ();
}
member EpochSeconds : uint32 with get
member EpochSeconds : uint32 with get

Property Value

Type: Online UInt32
See Also
BSONObjectID Structure
BSONObjectID Members
NFX.Serialization.BSON Namespace


BSONObjectID.MachineID Property

BSONObjectID MachineID Property NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint MachineID { get; }
public uint MachineID { get; }
Public ReadOnly Property MachineID As UInteger
    Get
Public ReadOnly Property MachineID As UInteger
    Get
public:
property unsigned int MachineID {
    unsigned int get ();
}
public:
property unsigned int MachineID {
    unsigned int get ();
}
member MachineID : uint32 with get
member MachineID : uint32 with get

Property Value

Type: Online UInt32
See Also
BSONObjectID Structure
BSONObjectID Members
NFX.Serialization.BSON Namespace


BSONObjectID.ProcessID Property

BSONObjectID ProcessID Property NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ushort ProcessID { get; }
public ushort ProcessID { get; }
Public ReadOnly Property ProcessID As UShort
    Get
Public ReadOnly Property ProcessID As UShort
    Get
public:
property unsigned short ProcessID {
    unsigned short get ();
}
public:
property unsigned short ProcessID {
    unsigned short get ();
}
member ProcessID : uint16 with get
member ProcessID : uint16 with get

Property Value

Type: Online UInt16
See Also
BSONObjectID Structure
BSONObjectID Members
NFX.Serialization.BSON Namespace


BSONObjectIDElement Class

BSONObjectIDElement Class NFX Class Library

Represents a BSON element with an BSONObjectID value
Inheritance Hierarchy
Online System Object
NFX.Serialization.BSON BSONElement
NFX.Serialization.BSON BSONElement BSONObjectID
NFX.Serialization.BSON BSONObjectIDElement

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class BSONObjectIDElement : BSONElement<BSONObjectID>
public sealed class BSONObjectIDElement : BSONElement<BSONObjectID>
Public NotInheritable Class BSONObjectIDElement
    Inherits BSONElement(Of BSONObjectID)
Public NotInheritable Class BSONObjectIDElement
    Inherits BSONElement(Of BSONObjectID)
public ref class BSONObjectIDElement sealed : public BSONElement<BSONObjectID>
public ref class BSONObjectIDElement sealed : public BSONElement<BSONObjectID>
[<SealedAttribute>]
type BSONObjectIDElement =
    class
        inherit BSONElement<BSONObjectID>
    end
[<SealedAttribute>]
type BSONObjectIDElement =
    class
        inherit BSONElement<BSONObjectID>
    end
See Also
BSONObjectIDElement Members
NFX.Serialization.BSON Namespace


BSONObjectIDElement Members

BSONObjectIDElement Members NFX Class Library

The BSONObjectIDElement type exposes the following members.
Constructors
 | Name | Description
Protected method | BSONObjectIDElement(Stream) | Initializes a new instance of the BSONObjectIDElement class
Public method | BSONObjectIDElement(BSONObjectID) | Creates an array element
Public method | BSONObjectIDElement(String, BSONObjectID) | Initializes a new instance of the BSONObjectIDElement class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONObjectIDElement Class
NFX.Serialization.BSON Namespace


BSONObjectIDElement Constructor

BSONObjectIDElement Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | BSONObjectIDElement(Stream) | Initializes a new instance of the BSONObjectIDElement class
Public method | BSONObjectIDElement(BSONObjectID) | Creates an array element
Public method | BSONObjectIDElement(String, BSONObjectID) | Initializes a new instance of the BSONObjectIDElement class
Back to Top
See Also
BSONObjectIDElement Class
BSONObjectIDElement Members
NFX.Serialization.BSON Namespace


BSONObjectIDElement Constructor (Stream)

BSONObjectIDElement Constructor (Stream) NFX Class Library

Initializes a new instance of the BSONObjectIDElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal BSONObjectIDElement(
    Stream stream
)
internal BSONObjectIDElement(
    Stream stream
)
Friend Sub New (
    stream As Stream
)
Friend Sub New (
    stream As Stream
)
internal:
BSONObjectIDElement(
    Stream^ stream
)
internal:
BSONObjectIDElement(
    Stream^ stream
)
new :
        stream : Stream -> BSONObjectIDElement
new :
        stream : Stream -> BSONObjectIDElement

Parameters

stream
Type: Online System.IO Stream
See Also
BSONObjectIDElement Class
BSONObjectIDElement Members
BSONObjectIDElement Overload
NFX.Serialization.BSON Namespace


BSONObjectIDElement Constructor (BSONObjectID)

BSONObjectIDElement Constructor (BSONObjectID) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates an array element

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONObjectIDElement(
    BSONObjectID value
)
public BSONObjectIDElement(
    BSONObjectID value
)
Public Sub New (
    value As BSONObjectID
)
Public Sub New (
    value As BSONObjectID
)
public:
BSONObjectIDElement(
    BSONObjectID value
)
public:
BSONObjectIDElement(
    BSONObjectID value
)
new :
        value : BSONObjectID -> BSONObjectIDElement
new :
        value : BSONObjectID -> BSONObjectIDElement

Parameters

value
Type: NFX.Serialization.BSON BSONObjectID
See Also
BSONObjectIDElement Class
BSONObjectIDElement Members
BSONObjectIDElement Overload
NFX.Serialization.BSON Namespace


BSONObjectIDElement Constructor (String, BSONObjectID)

BSONObjectIDElement Constructor (String, BSONObjectID) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BSONObjectIDElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONObjectIDElement(
    string name,
    BSONObjectID value
)
public BSONObjectIDElement(
    string name,
    BSONObjectID value
)
Public Sub New (
    name As String,
    value As BSONObjectID
)
Public Sub New (
    name As String,
    value As BSONObjectID
)
public:
BSONObjectIDElement(
    String^ name,
    BSONObjectID value
)
public:
BSONObjectIDElement(
    String^ name,
    BSONObjectID value
)
new :
        name : string *
        value : BSONObjectID -> BSONObjectIDElement
new :
        name : string *
        value : BSONObjectID -> BSONObjectIDElement

Parameters

name
Type: Online System String
value
Type: NFX.Serialization.BSON BSONObjectID
See Also
BSONObjectIDElement Class
BSONObjectIDElement Members
BSONObjectIDElement Overload
NFX.Serialization.BSON Namespace


BSONObjectIDElement Fields

BSONObjectIDElement Fields NFX Class Library

The BSONObjectIDElement type exposes the following members.
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONObjectIDElement Class
NFX.Serialization.BSON Namespace


BSONObjectIDElement Methods

BSONObjectIDElement Methods NFX Class Library

The BSONObjectIDElement type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BSONObjectIDElement Class
NFX.Serialization.BSON Namespace


BSONObjectIDElement.GetValueByteSize Method

BSONObjectIDElement GetValueByteSize Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override int GetValueByteSize()
protected internal override int GetValueByteSize()
Protected Friend Overrides Function GetValueByteSize As Integer
Protected Friend Overrides Function GetValueByteSize As Integer
protected public:
virtual int GetValueByteSize() override
protected public:
virtual int GetValueByteSize() override
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int

Return Value

Type: Online Int32
See Also
BSONObjectIDElement Class
BSONObjectIDElement Members
NFX.Serialization.BSON Namespace


BSONObjectIDElement.ReadValueFromStream Method

BSONObjectIDElement ReadValueFromStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void ReadValueFromStream(
    Stream stream
)
protected override void ReadValueFromStream(
    Stream stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONObjectIDElement Class
BSONObjectIDElement Members
NFX.Serialization.BSON Namespace


BSONObjectIDElement.WriteValueToStream Method

BSONObjectIDElement WriteValueToStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void WriteValueToStream(
    Stream stream
)
protected internal override void WriteValueToStream(
    Stream stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONObjectIDElement Class
BSONObjectIDElement Members
NFX.Serialization.BSON Namespace


BSONObjectIDElement Properties

BSONObjectIDElement Properties NFX Class Library

The BSONObjectIDElement type exposes the following members.
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONObjectIDElement Class
NFX.Serialization.BSON Namespace


BSONObjectIDElement.ElementType Property

BSONObjectIDElement ElementType Property NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override BSONElementType ElementType { get; }
public override BSONElementType ElementType { get; }
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get

Property Value

Type: BSONElementType
See Also
BSONObjectIDElement Class
BSONObjectIDElement Members
NFX.Serialization.BSON Namespace


BSONRegularExpression Structure

BSONRegularExpression Structure NFX Class Library

Represents a BSON regular expression type

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct BSONRegularExpression : IJSONWritable
public struct BSONRegularExpression : IJSONWritable
Public Structure BSONRegularExpression
    Implements IJSONWritable
Public Structure BSONRegularExpression
    Implements IJSONWritable
public value class BSONRegularExpression : IJSONWritable
public value class BSONRegularExpression : IJSONWritable
[<SealedAttribute>]
type BSONRegularExpression =
    struct
        interface IJSONWritable
    end
[<SealedAttribute>]
type BSONRegularExpression =
    struct
        interface IJSONWritable
    end
See Also
BSONRegularExpression Members
NFX.Serialization.BSON Namespace


BSONRegularExpression Members

BSONRegularExpression Members NFX Class Library

The BSONRegularExpression type exposes the following members.
Constructors
 | Name | Description
Public method | BSONRegularExpression | Initializes a new instance of the BSONRegularExpression class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Public method | WriteAsJSON |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Options |
Public field | Pattern |
Back to Top
See Also
BSONRegularExpression Structure
NFX.Serialization.BSON Namespace


BSONRegularExpression Constructor

BSONRegularExpression Constructor NFX Class Library

Initializes a new instance of the BSONRegularExpression class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONRegularExpression(
    string pattern,
    BSONRegularExpressionOptions options
)
public BSONRegularExpression(
    string pattern,
    BSONRegularExpressionOptions options
)
Public Sub New (
    pattern As String,
    options As BSONRegularExpressionOptions
)
Public Sub New (
    pattern As String,
    options As BSONRegularExpressionOptions
)
public:
BSONRegularExpression(
    String^ pattern,
    BSONRegularExpressionOptions options
)
public:
BSONRegularExpression(
    String^ pattern,
    BSONRegularExpressionOptions options
)
new :
        pattern : string *
        options : BSONRegularExpressionOptions -> BSONRegularExpression
new :
        pattern : string *
        options : BSONRegularExpressionOptions -> BSONRegularExpression

Parameters

pattern
Type: Online System String
options
Type: NFX.Serialization.BSON BSONRegularExpressionOptions
See Also
BSONRegularExpression Structure
BSONRegularExpression Members
NFX.Serialization.BSON Namespace


BSONRegularExpression Fields

BSONRegularExpression Fields NFX Class Library

The BSONRegularExpression type exposes the following members.
Fields
 | Name | Description
Public field | Options |
Public field | Pattern |
Back to Top
See Also
BSONRegularExpression Structure
NFX.Serialization.BSON Namespace


BSONRegularExpression.Options Field

BSONRegularExpression Options Field NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly BSONRegularExpressionOptions Options
public readonly BSONRegularExpressionOptions Options
Public ReadOnly Options As BSONRegularExpressionOptions
Public ReadOnly Options As BSONRegularExpressionOptions
public:
initonly BSONRegularExpressionOptions Options
public:
initonly BSONRegularExpressionOptions Options
val Options: BSONRegularExpressionOptions
val Options: BSONRegularExpressionOptions

Field Value

Type: BSONRegularExpressionOptions
See Also
BSONRegularExpression Structure
BSONRegularExpression Members
NFX.Serialization.BSON Namespace


BSONRegularExpression.Pattern Field

BSONRegularExpression Pattern Field NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Pattern
public readonly string Pattern
Public ReadOnly Pattern As String
Public ReadOnly Pattern As String
public:
initonly String^ Pattern
public:
initonly String^ Pattern
val Pattern: string
val Pattern: string

Field Value

Type: Online String
See Also
BSONRegularExpression Structure
BSONRegularExpression Members
NFX.Serialization.BSON Namespace


BSONRegularExpression Methods

BSONRegularExpression Methods NFX Class Library

The BSONRegularExpression type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Public method | WriteAsJSON |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BSONRegularExpression Structure
NFX.Serialization.BSON Namespace


BSONRegularExpression.WriteAsJSON Method

BSONRegularExpression WriteAsJSON Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
nestingLevel
Type: Online System Int32
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Implements

IJSONWritable WriteAsJSON(TextWriter, Int32, JSONWritingOptions)
See Also
BSONRegularExpression Structure
BSONRegularExpression Members
NFX.Serialization.BSON Namespace


BSONRegularExpressionElement Class

BSONRegularExpressionElement Class NFX Class Library

Represents a BSON element with an regular expression value
Inheritance Hierarchy
Online System Object
NFX.Serialization.BSON BSONElement
NFX.Serialization.BSON BSONElement BSONRegularExpression
NFX.Serialization.BSON BSONRegularExpressionElement

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class BSONRegularExpressionElement : BSONElement<BSONRegularExpression>
public sealed class BSONRegularExpressionElement : BSONElement<BSONRegularExpression>
Public NotInheritable Class BSONRegularExpressionElement
    Inherits BSONElement(Of BSONRegularExpression)
Public NotInheritable Class BSONRegularExpressionElement
    Inherits BSONElement(Of BSONRegularExpression)
public ref class BSONRegularExpressionElement sealed : public BSONElement<BSONRegularExpression>
public ref class BSONRegularExpressionElement sealed : public BSONElement<BSONRegularExpression>
[<SealedAttribute>]
type BSONRegularExpressionElement =
    class
        inherit BSONElement<BSONRegularExpression>
    end
[<SealedAttribute>]
type BSONRegularExpressionElement =
    class
        inherit BSONElement<BSONRegularExpression>
    end
See Also
BSONRegularExpressionElement Members
NFX.Serialization.BSON Namespace


BSONRegularExpressionElement Members

BSONRegularExpressionElement Members NFX Class Library

The BSONRegularExpressionElement type exposes the following members.
Constructors
 | Name | Description
Protected method | BSONRegularExpressionElement(Stream) | Initializes a new instance of the BSONRegularExpressionElement class
Public method | BSONRegularExpressionElement(BSONRegularExpression) | Creates an array element
Public method | BSONRegularExpressionElement(String, BSONRegularExpression) | Initializes a new instance of the BSONRegularExpressionElement class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONRegularExpressionElement Class
NFX.Serialization.BSON Namespace


BSONRegularExpressionElement Constructor

BSONRegularExpressionElement Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | BSONRegularExpressionElement(Stream) | Initializes a new instance of the BSONRegularExpressionElement class
Public method | BSONRegularExpressionElement(BSONRegularExpression) | Creates an array element
Public method | BSONRegularExpressionElement(String, BSONRegularExpression) | Initializes a new instance of the BSONRegularExpressionElement class
Back to Top
See Also
BSONRegularExpressionElement Class
BSONRegularExpressionElement Members
NFX.Serialization.BSON Namespace


BSONRegularExpressionElement Constructor (Stream)

BSONRegularExpressionElement Constructor (Stream) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BSONRegularExpressionElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal BSONRegularExpressionElement(
    Stream stream
)
internal BSONRegularExpressionElement(
    Stream stream
)
Friend Sub New (
    stream As Stream
)
Friend Sub New (
    stream As Stream
)
internal:
BSONRegularExpressionElement(
    Stream^ stream
)
internal:
BSONRegularExpressionElement(
    Stream^ stream
)
new :
        stream : Stream -> BSONRegularExpressionElement
new :
        stream : Stream -> BSONRegularExpressionElement

Parameters

stream
Type: Online System.IO Stream
See Also
BSONRegularExpressionElement Class
BSONRegularExpressionElement Members
BSONRegularExpressionElement Overload
NFX.Serialization.BSON Namespace


BSONRegularExpressionElement Constructor (BSONRegularExpression)

BSONRegularExpressionElement Constructor (BSONRegularExpression) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates an array element

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONRegularExpressionElement(
    BSONRegularExpression value
)
public BSONRegularExpressionElement(
    BSONRegularExpression value
)
Public Sub New (
    value As BSONRegularExpression
)
Public Sub New (
    value As BSONRegularExpression
)
public:
BSONRegularExpressionElement(
    BSONRegularExpression value
)
public:
BSONRegularExpressionElement(
    BSONRegularExpression value
)
new :
        value : BSONRegularExpression -> BSONRegularExpressionElement
new :
        value : BSONRegularExpression -> BSONRegularExpressionElement

Parameters

value
Type: NFX.Serialization.BSON BSONRegularExpression
See Also
BSONRegularExpressionElement Class
BSONRegularExpressionElement Members
BSONRegularExpressionElement Overload
NFX.Serialization.BSON Namespace


BSONRegularExpressionElement Constructor (String, BSONRegularExpression)

BSONRegularExpressionElement Constructor (String, BSONRegularExpression) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BSONRegularExpressionElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONRegularExpressionElement(
    string name,
    BSONRegularExpression value
)
public BSONRegularExpressionElement(
    string name,
    BSONRegularExpression value
)
Public Sub New (
    name As String,
    value As BSONRegularExpression
)
Public Sub New (
    name As String,
    value As BSONRegularExpression
)
public:
BSONRegularExpressionElement(
    String^ name,
    BSONRegularExpression value
)
public:
BSONRegularExpressionElement(
    String^ name,
    BSONRegularExpression value
)
new :
        name : string *
        value : BSONRegularExpression -> BSONRegularExpressionElement
new :
        name : string *
        value : BSONRegularExpression -> BSONRegularExpressionElement

Parameters

name
Type: Online System String
value
Type: NFX.Serialization.BSON BSONRegularExpression
See Also
BSONRegularExpressionElement Class
BSONRegularExpressionElement Members
BSONRegularExpressionElement Overload
NFX.Serialization.BSON Namespace


BSONRegularExpressionElement Fields

BSONRegularExpressionElement Fields NFX Class Library

The BSONRegularExpressionElement type exposes the following members.
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONRegularExpressionElement Class
NFX.Serialization.BSON Namespace


BSONRegularExpressionElement Methods

BSONRegularExpressionElement Methods NFX Class Library

The BSONRegularExpressionElement type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BSONRegularExpressionElement Class
NFX.Serialization.BSON Namespace


BSONRegularExpressionElement.GetValueByteSize Method

BSONRegularExpressionElement GetValueByteSize Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override int GetValueByteSize()
protected internal override int GetValueByteSize()
Protected Friend Overrides Function GetValueByteSize As Integer
Protected Friend Overrides Function GetValueByteSize As Integer
protected public:
virtual int GetValueByteSize() override
protected public:
virtual int GetValueByteSize() override
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int

Return Value

Type: Online Int32
See Also
BSONRegularExpressionElement Class
BSONRegularExpressionElement Members
NFX.Serialization.BSON Namespace


BSONRegularExpressionElement.ReadValueFromStream Method

BSONRegularExpressionElement ReadValueFromStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void ReadValueFromStream(
    Stream stream
)
protected override void ReadValueFromStream(
    Stream stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONRegularExpressionElement Class
BSONRegularExpressionElement Members
NFX.Serialization.BSON Namespace


BSONRegularExpressionElement.WriteValueToStream Method

BSONRegularExpressionElement WriteValueToStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void WriteValueToStream(
    Stream stream
)
protected internal override void WriteValueToStream(
    Stream stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONRegularExpressionElement Class
BSONRegularExpressionElement Members
NFX.Serialization.BSON Namespace


BSONRegularExpressionElement Properties

BSONRegularExpressionElement Properties NFX Class Library

The BSONRegularExpressionElement type exposes the following members.
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONRegularExpressionElement Class
NFX.Serialization.BSON Namespace


BSONRegularExpressionElement.ElementType Property

BSONRegularExpressionElement ElementType Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override BSONElementType ElementType { get; }
public override BSONElementType ElementType { get; }
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get

Property Value

Type: BSONElementType
See Also
BSONRegularExpressionElement Class
BSONRegularExpressionElement Members
NFX.Serialization.BSON Namespace


BSONRegularExpressionOptions Enumeration

BSONRegularExpressionOptions Enumeration NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[FlagsAttribute]
public enum BSONRegularExpressionOptions
[FlagsAttribute]
public enum BSONRegularExpressionOptions
<FlagsAttribute>
Public Enumeration BSONRegularExpressionOptions
<FlagsAttribute>
Public Enumeration BSONRegularExpressionOptions
[FlagsAttribute]
public enum class BSONRegularExpressionOptions
[FlagsAttribute]
public enum class BSONRegularExpressionOptions
[<FlagsAttribute>]
type BSONRegularExpressionOptions
[<FlagsAttribute>]
type BSONRegularExpressionOptions
Members
Member name | Value | Description
None | 0 |
I | 1 | Insensitive matching
M | 16 | Multiline matching
X | 256 | Verbose mode
L | 4096 | Make \w, \W, etc. locale dependent
S | 65536 | Dotall mode ('.' matches everything)
U | 1048576 | Make \w, \W, etc. match unicode
See Also
NFX.Serialization.BSON Namespace


BSONStringElement Class

BSONStringElement Class NFX Class Library

Represents a BSON element with a string value
Inheritance Hierarchy
Online System Object
NFX.Serialization.BSON BSONElement
NFX.Serialization.BSON BSONElement Online String
NFX.Serialization.BSON BSONStringElement

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class BSONStringElement : BSONElement<string>
public sealed class BSONStringElement : BSONElement<string>
Public NotInheritable Class BSONStringElement
    Inherits BSONElement(Of String)
Public NotInheritable Class BSONStringElement
    Inherits BSONElement(Of String)
public ref class BSONStringElement sealed : public BSONElement<String^>
public ref class BSONStringElement sealed : public BSONElement<String^>
[<SealedAttribute>]
type BSONStringElement =
    class
        inherit BSONElement<string>
    end
[<SealedAttribute>]
type BSONStringElement =
    class
        inherit BSONElement<string>
    end
See Also
BSONStringElement Members
NFX.Serialization.BSON Namespace


BSONStringElement Members

BSONStringElement Members NFX Class Library

The BSONStringElement type exposes the following members.
Constructors
 | Name | Description
Protected method | BSONStringElement(Stream) | Initializes a new instance of the BSONStringElement class
Public method | BSONStringElement(String) | Creates an array element
Public method | BSONStringElement(String, String) | Initializes a new instance of the BSONStringElement class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONStringElement Class
NFX.Serialization.BSON Namespace


BSONStringElement Constructor

BSONStringElement Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | BSONStringElement(Stream) | Initializes a new instance of the BSONStringElement class
Public method | BSONStringElement(String) | Creates an array element
Public method | BSONStringElement(String, String) | Initializes a new instance of the BSONStringElement class
Back to Top
See Also
BSONStringElement Class
BSONStringElement Members
NFX.Serialization.BSON Namespace


BSONStringElement Constructor (Stream)

BSONStringElement Constructor (Stream) NFX Class Library

Initializes a new instance of the BSONStringElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal BSONStringElement(
    Stream stream
)
internal BSONStringElement(
    Stream stream
)
Friend Sub New (
    stream As Stream
)
Friend Sub New (
    stream As Stream
)
internal:
BSONStringElement(
    Stream^ stream
)
internal:
BSONStringElement(
    Stream^ stream
)
new :
        stream : Stream -> BSONStringElement
new :
        stream : Stream -> BSONStringElement

Parameters

stream
Type: Online System.IO Stream
See Also
BSONStringElement Class
BSONStringElement Members
BSONStringElement Overload
NFX.Serialization.BSON Namespace


BSONStringElement Constructor (String)

BSONStringElement Constructor (String) NFX Class Library

Creates an array element

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONStringElement(
    string value
)
public BSONStringElement(
    string value
)
Public Sub New (
    value As String
)
Public Sub New (
    value As String
)
public:
BSONStringElement(
    String^ value
)
public:
BSONStringElement(
    String^ value
)
new :
        value : string -> BSONStringElement
new :
        value : string -> BSONStringElement

Parameters

value
Type: Online System String
See Also
BSONStringElement Class
BSONStringElement Members
BSONStringElement Overload
NFX.Serialization.BSON Namespace


BSONStringElement Constructor (String, String)

BSONStringElement Constructor (String, String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BSONStringElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONStringElement(
    string name,
    string value
)
public BSONStringElement(
    string name,
    string value
)
Public Sub New (
    name As String,
    value As String
)
Public Sub New (
    name As String,
    value As String
)
public:
BSONStringElement(
    String^ name,
    String^ value
)
public:
BSONStringElement(
    String^ name,
    String^ value
)
new :
        name : string *
        value : string -> BSONStringElement
new :
        name : string *
        value : string -> BSONStringElement

Parameters

name
Type: Online System String
value
Type: Online System String
See Also
BSONStringElement Class
BSONStringElement Members
BSONStringElement Overload
NFX.Serialization.BSON Namespace


BSONStringElement Fields

BSONStringElement Fields NFX Class Library

The BSONStringElement type exposes the following members.
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONStringElement Class
NFX.Serialization.BSON Namespace


BSONStringElement Methods

BSONStringElement Methods NFX Class Library

The BSONStringElement type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BSONStringElement Class
NFX.Serialization.BSON Namespace


BSONStringElement.GetValueByteSize Method

BSONStringElement GetValueByteSize Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override int GetValueByteSize()
protected internal override int GetValueByteSize()
Protected Friend Overrides Function GetValueByteSize As Integer
Protected Friend Overrides Function GetValueByteSize As Integer
protected public:
virtual int GetValueByteSize() override
protected public:
virtual int GetValueByteSize() override
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int

Return Value

Type: Online Int32
See Also
BSONStringElement Class
BSONStringElement Members
NFX.Serialization.BSON Namespace


BSONStringElement.ReadValueFromStream Method

BSONStringElement ReadValueFromStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void ReadValueFromStream(
    Stream stream
)
protected override void ReadValueFromStream(
    Stream stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONStringElement Class
BSONStringElement Members
NFX.Serialization.BSON Namespace


BSONStringElement.WriteValueToStream Method

BSONStringElement WriteValueToStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void WriteValueToStream(
    Stream stream
)
protected internal override void WriteValueToStream(
    Stream stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONStringElement Class
BSONStringElement Members
NFX.Serialization.BSON Namespace


BSONStringElement Properties

BSONStringElement Properties NFX Class Library

The BSONStringElement type exposes the following members.
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONStringElement Class
NFX.Serialization.BSON Namespace


BSONStringElement.ElementType Property

BSONStringElement ElementType Property NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override BSONElementType ElementType { get; }
public override BSONElementType ElementType { get; }
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get

Property Value

Type: BSONElementType
See Also
BSONStringElement Class
BSONStringElement Members
NFX.Serialization.BSON Namespace


BSONTimestamp Structure

BSONTimestamp Structure NFX Class Library

Represents a BSON timestamp type

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct BSONTimestamp : IJSONWritable
public struct BSONTimestamp : IJSONWritable
Public Structure BSONTimestamp
    Implements IJSONWritable
Public Structure BSONTimestamp
    Implements IJSONWritable
public value class BSONTimestamp : IJSONWritable
public value class BSONTimestamp : IJSONWritable
[<SealedAttribute>]
type BSONTimestamp =
    struct
        interface IJSONWritable
    end
[<SealedAttribute>]
type BSONTimestamp =
    struct
        interface IJSONWritable
    end
See Also
BSONTimestamp Members
NFX.Serialization.BSON Namespace


BSONTimestamp Members

BSONTimestamp Members NFX Class Library

The BSONTimestamp type exposes the following members.
Constructors
 | Name | Description
Public method | BSONTimestamp | Initializes a new instance of the BSONTimestamp class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Public method | WriteAsJSON |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | EpochSeconds |
Public field | Increment |
Back to Top
See Also
BSONTimestamp Structure
NFX.Serialization.BSON Namespace


BSONTimestamp Constructor

BSONTimestamp Constructor NFX Class Library

Initializes a new instance of the BSONTimestamp class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONTimestamp(
    DateTime value,
    uint increment
)
public BSONTimestamp(
    DateTime value,
    uint increment
)
Public Sub New (
    value As DateTime,
    increment As UInteger
)
Public Sub New (
    value As DateTime,
    increment As UInteger
)
public:
BSONTimestamp(
    DateTime value,
    unsigned int increment
)
public:
BSONTimestamp(
    DateTime value,
    unsigned int increment
)
new :
        value : DateTime *
        increment : uint32 -> BSONTimestamp
new :
        value : DateTime *
        increment : uint32 -> BSONTimestamp

Parameters

value
Type: Online System DateTime
increment
Type: Online System UInt32
See Also
BSONTimestamp Structure
BSONTimestamp Members
NFX.Serialization.BSON Namespace


BSONTimestamp Fields

BSONTimestamp Fields NFX Class Library

The BSONTimestamp type exposes the following members.
Fields
 | Name | Description
Public field | EpochSeconds |
Public field | Increment |
Back to Top
See Also
BSONTimestamp Structure
NFX.Serialization.BSON Namespace


BSONTimestamp.EpochSeconds Field

BSONTimestamp EpochSeconds Field NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly uint EpochSeconds
public readonly uint EpochSeconds
Public ReadOnly EpochSeconds As UInteger
Public ReadOnly EpochSeconds As UInteger
public:
initonly unsigned int EpochSeconds
public:
initonly unsigned int EpochSeconds
val EpochSeconds: uint32
val EpochSeconds: uint32

Field Value

Type: Online UInt32
See Also
BSONTimestamp Structure
BSONTimestamp Members
NFX.Serialization.BSON Namespace


BSONTimestamp.Increment Field

BSONTimestamp Increment Field NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly uint Increment
public readonly uint Increment
Public ReadOnly Increment As UInteger
Public ReadOnly Increment As UInteger
public:
initonly unsigned int Increment
public:
initonly unsigned int Increment
val Increment: uint32
val Increment: uint32

Field Value

Type: Online UInt32
See Also
BSONTimestamp Structure
BSONTimestamp Members
NFX.Serialization.BSON Namespace


BSONTimestamp Methods

BSONTimestamp Methods NFX Class Library

The BSONTimestamp type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Public method | WriteAsJSON |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BSONTimestamp Structure
NFX.Serialization.BSON Namespace


BSONTimestamp.WriteAsJSON Method

BSONTimestamp WriteAsJSON Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
nestingLevel
Type: Online System Int32
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Implements

IJSONWritable WriteAsJSON(TextWriter, Int32, JSONWritingOptions)
See Also
BSONTimestamp Structure
BSONTimestamp Members
NFX.Serialization.BSON Namespace


BSONTimestampElement Class

BSONTimestampElement Class NFX Class Library

Represents a BSON element with an Timestamp value
Inheritance Hierarchy
Online System Object
NFX.Serialization.BSON BSONElement
NFX.Serialization.BSON BSONElement BSONTimestamp
NFX.Serialization.BSON BSONTimestampElement

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class BSONTimestampElement : BSONElement<BSONTimestamp>
public sealed class BSONTimestampElement : BSONElement<BSONTimestamp>
Public NotInheritable Class BSONTimestampElement
    Inherits BSONElement(Of BSONTimestamp)
Public NotInheritable Class BSONTimestampElement
    Inherits BSONElement(Of BSONTimestamp)
public ref class BSONTimestampElement sealed : public BSONElement<BSONTimestamp>
public ref class BSONTimestampElement sealed : public BSONElement<BSONTimestamp>
[<SealedAttribute>]
type BSONTimestampElement =
    class
        inherit BSONElement<BSONTimestamp>
    end
[<SealedAttribute>]
type BSONTimestampElement =
    class
        inherit BSONElement<BSONTimestamp>
    end
See Also
BSONTimestampElement Members
NFX.Serialization.BSON Namespace


BSONTimestampElement Members

BSONTimestampElement Members NFX Class Library

The BSONTimestampElement type exposes the following members.
Constructors
 | Name | Description
Protected method | BSONTimestampElement(Stream) | Initializes a new instance of the BSONTimestampElement class
Public method | BSONTimestampElement(BSONTimestamp) | Creates an array element
Public method | BSONTimestampElement(String, BSONTimestamp) | Initializes a new instance of the BSONTimestampElement class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONTimestampElement Class
NFX.Serialization.BSON Namespace


BSONTimestampElement Constructor

BSONTimestampElement Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | BSONTimestampElement(Stream) | Initializes a new instance of the BSONTimestampElement class
Public method | BSONTimestampElement(BSONTimestamp) | Creates an array element
Public method | BSONTimestampElement(String, BSONTimestamp) | Initializes a new instance of the BSONTimestampElement class
Back to Top
See Also
BSONTimestampElement Class
BSONTimestampElement Members
NFX.Serialization.BSON Namespace


BSONTimestampElement Constructor (Stream)

BSONTimestampElement Constructor (Stream) NFX Class Library

Initializes a new instance of the BSONTimestampElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal BSONTimestampElement(
    Stream stream
)
internal BSONTimestampElement(
    Stream stream
)
Friend Sub New (
    stream As Stream
)
Friend Sub New (
    stream As Stream
)
internal:
BSONTimestampElement(
    Stream^ stream
)
internal:
BSONTimestampElement(
    Stream^ stream
)
new :
        stream : Stream -> BSONTimestampElement
new :
        stream : Stream -> BSONTimestampElement

Parameters

stream
Type: Online System.IO Stream
See Also
BSONTimestampElement Class
BSONTimestampElement Members
BSONTimestampElement Overload
NFX.Serialization.BSON Namespace


BSONTimestampElement Constructor (BSONTimestamp)

BSONTimestampElement Constructor (BSONTimestamp) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates an array element

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONTimestampElement(
    BSONTimestamp value
)
public BSONTimestampElement(
    BSONTimestamp value
)
Public Sub New (
    value As BSONTimestamp
)
Public Sub New (
    value As BSONTimestamp
)
public:
BSONTimestampElement(
    BSONTimestamp value
)
public:
BSONTimestampElement(
    BSONTimestamp value
)
new :
        value : BSONTimestamp -> BSONTimestampElement
new :
        value : BSONTimestamp -> BSONTimestampElement

Parameters

value
Type: NFX.Serialization.BSON BSONTimestamp
See Also
BSONTimestampElement Class
BSONTimestampElement Members
BSONTimestampElement Overload
NFX.Serialization.BSON Namespace


BSONTimestampElement Constructor (String, BSONTimestamp)

BSONTimestampElement Constructor (String, BSONTimestamp) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BSONTimestampElement class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONTimestampElement(
    string name,
    BSONTimestamp value
)
public BSONTimestampElement(
    string name,
    BSONTimestamp value
)
Public Sub New (
    name As String,
    value As BSONTimestamp
)
Public Sub New (
    name As String,
    value As BSONTimestamp
)
public:
BSONTimestampElement(
    String^ name,
    BSONTimestamp value
)
public:
BSONTimestampElement(
    String^ name,
    BSONTimestamp value
)
new :
        name : string *
        value : BSONTimestamp -> BSONTimestampElement
new :
        name : string *
        value : BSONTimestamp -> BSONTimestampElement

Parameters

name
Type: Online System String
value
Type: NFX.Serialization.BSON BSONTimestamp
See Also
BSONTimestampElement Class
BSONTimestampElement Members
BSONTimestampElement Overload
NFX.Serialization.BSON Namespace


BSONTimestampElement Fields

BSONTimestampElement Fields NFX Class Library

The BSONTimestampElement type exposes the following members.
Fields
 | Name | Description
Protected field | m_Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONTimestampElement Class
NFX.Serialization.BSON Namespace


BSONTimestampElement Methods

BSONTimestampElement Methods NFX Class Library

The BSONTimestampElement type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Protected method | GetByteSize | Returns the BSON binary size of this element expressed in bytes (Inherited from BSONElement.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeCode | (Inherited from BSONElement.)
Protected method | GetValueByteSize | (Overrides BSONElement GetValueByteSize .)
Protected method | MarkAsArrayItem | (Inherited from BSONElement.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Protected method | ReadValueFromStream | (Overrides BSONElement ReadValueFromStream(Stream).)
Public method | ToBoolean | (Inherited from BSONElement.)
Public method | ToByte | (Inherited from BSONElement.)
Public method | ToChar | (Inherited from BSONElement.)
Public method | ToDateTime | (Inherited from BSONElement.)
Public method | ToDecimal | (Inherited from BSONElement.)
Public method | ToDouble | (Inherited from BSONElement.)
Public method | ToInt16 | (Inherited from BSONElement.)
Public method | ToInt32 | (Inherited from BSONElement.)
Public method | ToInt64 | (Inherited from BSONElement.)
Public method | ToSByte | (Inherited from BSONElement.)
Public method | ToSingle | (Inherited from BSONElement.)
Public method | ToString | (Inherited from BSONElement T .)
Public method | ToString(IFormatProvider) | (Inherited from BSONElement.)
Public method | ToType | (Inherited from BSONElement.)
Public method | ToUInt16 | (Inherited from BSONElement.)
Public method | ToUInt32 | (Inherited from BSONElement.)
Public method | ToUInt64 | (Inherited from BSONElement.)
Public method | WriteAsJSON | (Inherited from BSONElement.)
Protected method | WriteToStream | Write element to stream (Inherited from BSONElement.)
Protected method | WriteValueToStream | (Overrides BSONElement WriteValueToStream(Stream).)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
BSONTimestampElement Class
NFX.Serialization.BSON Namespace


BSONTimestampElement.GetValueByteSize Method

BSONTimestampElement GetValueByteSize Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override int GetValueByteSize()
protected internal override int GetValueByteSize()
Protected Friend Overrides Function GetValueByteSize As Integer
Protected Friend Overrides Function GetValueByteSize As Integer
protected public:
virtual int GetValueByteSize() override
protected public:
virtual int GetValueByteSize() override
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int
abstract GetValueByteSize : unit -> int
override GetValueByteSize : unit -> int

Return Value

Type: Online Int32
See Also
BSONTimestampElement Class
BSONTimestampElement Members
NFX.Serialization.BSON Namespace


BSONTimestampElement.ReadValueFromStream Method

BSONTimestampElement ReadValueFromStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void ReadValueFromStream(
    Stream stream
)
protected override void ReadValueFromStream(
    Stream stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
Protected Overrides Sub ReadValueFromStream (
    stream As Stream
)
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
protected:
virtual void ReadValueFromStream(
    Stream^ stream
) override
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit
abstract ReadValueFromStream :
        stream : Stream -> unit
override ReadValueFromStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONTimestampElement Class
BSONTimestampElement Members
NFX.Serialization.BSON Namespace


BSONTimestampElement.WriteValueToStream Method

BSONTimestampElement WriteValueToStream Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected internal override void WriteValueToStream(
    Stream stream
)
protected internal override void WriteValueToStream(
    Stream stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
Protected Friend Overrides Sub WriteValueToStream (
    stream As Stream
)
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
protected public:
virtual void WriteValueToStream(
    Stream^ stream
) override
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit
abstract WriteValueToStream :
        stream : Stream -> unit
override WriteValueToStream :
        stream : Stream -> unit

Parameters

stream
Type: Online System.IO Stream
See Also
BSONTimestampElement Class
BSONTimestampElement Members
NFX.Serialization.BSON Namespace


BSONTimestampElement Properties

BSONTimestampElement Properties NFX Class Library

The BSONTimestampElement type exposes the following members.
Properties
 | Name | Description
Public property | ByteSize | Recalculates the BSON binary size of this document expressed in bytes (Inherited from BSONElement.)
Public property | ElementType | (Overrides BSONElement ElementType.)
Public property | IsArrayElement | Returns true when this element does not have a name - it is a part of the array (Inherited from BSONElement.)
Public property | Name | Return the name of this element. The name is immutable. Check IaArrayElelemnt first, as this property can not be gotten for array elements (Inherited from BSONElement.)
Public property | ObjectValue | Gets/sets value as object. In normal cases use typed Value to get/set instead (Inherited from BSONElement T .)
Public property | Value | (Inherited from BSONElement T .)
Back to Top
See Also
BSONTimestampElement Class
NFX.Serialization.BSON Namespace


BSONTimestampElement.ElementType Property

BSONTimestampElement ElementType Property NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override BSONElementType ElementType { get; }
public override BSONElementType ElementType { get; }
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
Public Overrides ReadOnly Property ElementType As BSONElementType
    Get
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
public:
virtual property BSONElementType ElementType {
    BSONElementType get () override;
}
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get
abstract ElementType : BSONElementType with get
override ElementType : BSONElementType with get

Property Value

Type: BSONElementType
See Also
BSONTimestampElement Class
BSONTimestampElement Members
NFX.Serialization.BSON Namespace


RegularExpressionExtensions Class

RegularExpressionExtensions Class NFX Class Library

Utilities methods for BSON regular expression type
Inheritance Hierarchy
Online System Object
NFX.Serialization.BSON RegularExpressionExtensions

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class RegularExpressionExtensions
public static class RegularExpressionExtensions
<ExtensionAttribute>
Public NotInheritable Class RegularExpressionExtensions
<ExtensionAttribute>
Public NotInheritable Class RegularExpressionExtensions
[ExtensionAttribute]
public ref class RegularExpressionExtensions abstract sealed
[ExtensionAttribute]
public ref class RegularExpressionExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RegularExpressionExtensions =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RegularExpressionExtensions =  class end
See Also
RegularExpressionExtensions Members
NFX.Serialization.BSON Namespace


RegularExpressionExtensions Members

RegularExpressionExtensions Members NFX Class Library

The RegularExpressionExtensions type exposes the following members.
Methods
Name | Description
Count | Returns regex options count
ToBSONOptions |
ToBSONString | Returns BSON-formatted string for regeax options (The options are identified by lower-case characters, which must be stored in alphabetical order).
Back to Top
See Also
RegularExpressionExtensions Class
NFX.Serialization.BSON Namespace


RegularExpressionExtensions Methods

RegularExpressionExtensions Methods NFX Class Library

The RegularExpressionExtensions type exposes the following members.
Methods
Name | Description
Count | Returns regex options count
ToBSONOptions |
ToBSONString | Returns BSON-formatted string for regeax options (The options are identified by lower-case characters, which must be stored in alphabetical order).
Back to Top
See Also
RegularExpressionExtensions Class
NFX.Serialization.BSON Namespace


RegularExpressionExtensions.Count Method

RegularExpressionExtensions Count Method NFX Class Library

Returns regex options count

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte Count(
    this BSONRegularExpressionOptions options
)
public static byte Count(
    this BSONRegularExpressionOptions options
)
<ExtensionAttribute>
Public Shared Function Count (
    options As BSONRegularExpressionOptions
) As Byte
<ExtensionAttribute>
Public Shared Function Count (
    options As BSONRegularExpressionOptions
) As Byte
public:
[ExtensionAttribute]
static unsigned char Count(
    BSONRegularExpressionOptions options
)
public:
[ExtensionAttribute]
static unsigned char Count(
    BSONRegularExpressionOptions options
)
static member Count :
        options : BSONRegularExpressionOptions -> byte
static member Count :
        options : BSONRegularExpressionOptions -> byte

Parameters

options
Type: NFX.Serialization.BSON BSONRegularExpressionOptions

Return Value

Type: Online Byte

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type BSONRegularExpressionOptions. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
RegularExpressionExtensions Class
RegularExpressionExtensions Members
NFX.Serialization.BSON Namespace


RegularExpressionExtensions.ToBSONOptions Method

RegularExpressionExtensions ToBSONOptions Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static BSONRegularExpressionOptions ToBSONOptions(
    this string source
)
public static BSONRegularExpressionOptions ToBSONOptions(
    this string source
)
<ExtensionAttribute>
Public Shared Function ToBSONOptions (
    source As String
) As BSONRegularExpressionOptions
<ExtensionAttribute>
Public Shared Function ToBSONOptions (
    source As String
) As BSONRegularExpressionOptions
public:
[ExtensionAttribute]
static BSONRegularExpressionOptions ToBSONOptions(
    String^ source
)
public:
[ExtensionAttribute]
static BSONRegularExpressionOptions ToBSONOptions(
    String^ source
)
static member ToBSONOptions :
        source : string -> BSONRegularExpressionOptions
static member ToBSONOptions :
        source : string -> BSONRegularExpressionOptions

Parameters

source
Type: Online System String

Return Value

Type: BSONRegularExpressionOptions

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
RegularExpressionExtensions Class
RegularExpressionExtensions Members
NFX.Serialization.BSON Namespace


RegularExpressionExtensions.ToBSONString Method

RegularExpressionExtensions ToBSONString Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns BSON-formatted string for regeax options (The options are identified by lower-case characters, which must be stored in alphabetical order).

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ToBSONString(
    this BSONRegularExpressionOptions options
)
public static string ToBSONString(
    this BSONRegularExpressionOptions options
)
<ExtensionAttribute>
Public Shared Function ToBSONString (
    options As BSONRegularExpressionOptions
) As String
<ExtensionAttribute>
Public Shared Function ToBSONString (
    options As BSONRegularExpressionOptions
) As String
public:
[ExtensionAttribute]
static String^ ToBSONString(
    BSONRegularExpressionOptions options
)
public:
[ExtensionAttribute]
static String^ ToBSONString(
    BSONRegularExpressionOptions options
)
static member ToBSONString :
        options : BSONRegularExpressionOptions -> string
static member ToBSONString :
        options : BSONRegularExpressionOptions -> string

Parameters

options
Type: NFX.Serialization.BSON BSONRegularExpressionOptions

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type BSONRegularExpressionOptions. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
RegularExpressionExtensions Class
RegularExpressionExtensions Members
NFX.Serialization.BSON Namespace


RowConverter Class

RowConverter Class NFX Class Library

Provides methods for Row to/from BSONDocument conversion
Inheritance Hierarchy
Online System Object
NFX.Serialization.BSON RowConverter

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class RowConverter : IConfigurable
public class RowConverter : IConfigurable
Public Class RowConverter
    Implements IConfigurable
Public Class RowConverter
    Implements IConfigurable
public ref class RowConverter : IConfigurable
public ref class RowConverter : IConfigurable
type RowConverter =
    class
        interface IConfigurable
    end
type RowConverter =
    class
        interface IConfigurable
    end
See Also
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter Members

RowConverter Members NFX Class Library

The RowConverter type exposes the following members.
Constructors
 | Name | Description
Public method | RowConverter | Initializes a new instance of the RowConverter class
Back to Top
Methods
 | Name | Description
 | Amount_BSONtoCLR |
 | Amount_CLRtoBSON |
Public method | BSONDocumentToJSONMap | Converts BSON document to JSON data map by directly mapping BSON types into corresponding CLR types. The sub-documents get mapped into JSONDataObjects, and BSON arrays get mapped into CLR object[]
Public method | BSONDocumentToRow | Converts BSON document into Row by filling the supplied row instance making necessary type transforms to suit Row.Schema field definitions per target name. If the passed row supports IAmorphousData, then the fields either not found in row, or the fields that could not be type-converted to CLR type will be stowed in amorphous data dictionary
 | ByteBuffer_CLRtoBSON |
 | ByteBufferID_CLRtoBSON | Encodes byte buffer purposed for id, using proper binary subtype
Public method | Configure |
Public method | ConvertCLRtoBSON | Converts CLR value to BSON. The following values are supported: primitives+scaled decimal, enums, TypedRows, GDID, Guid, Amount, IDictionary, IEnumerable (including arrays). If conversion could not be made then exception is thrown
 | Decimal_BSONtoCLR(BSONElement) |
 | Decimal_BSONtoCLR(BSONInt32Element) |
 | Decimal_BSONtoCLR(BSONInt64Element) |
 | Decimal_CLRtoBSON |
Protected method | DirectConvertBSONValue | Converts BSON to CLR value 1:1, without type change
Protected method | DoConvertCLRtoBSON | override to perform the conversion. the data is never null here, and ref cycles a ruled out
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | GDID_BSONtoCLR |
 | GDID_CLRtoBSON |
Protected method | GetAmorphousFieldAsBSON |
Protected method | GetFieldAsBSON |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | InferSchemaFromBSONDocument | Makes CRUD Schema out of BSON document. The types of all fields are object as documents do not have a predictable type of every field (they are dynamic and can change form doc to doc)
 | MapBSONFieldNameToSchemaFieldDef | Maps bsonFieldName to targeted fieldDef from specified schema using cache for TypedRows
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RowToBSONDocument | Converts row to BSON document suitable for storage in MONGO.DB. Pass target name (name of particular store/epoch/implementation) to get targeted field metadata. Note: the supplied row MAY NOT CONTAIN REFERENCE CYCLES - either direct or transitive
Public method | RowToBSONDocumentElement | Converts row to BSON document suitable for storage in MONGO.DB. Pass target name (name of particular store/epoch/implementation) to get targeted field metadata. Note: the supplied row MAY NOT CONTAIN REFERENCE CYCLES - either direct or transitive
Protected method | SetAmorphousFieldAsCLR |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | TryConvertBSONtoCLR | Tries to convert the BSON value into target CLR type. Returns true if conversion was successfull
Protected method | TrySetFieldAsCLR |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | DECIMAL_LONG_MUL |
Protected field | m_BSONtoCLR |
Protected field | m_CLRtoBSON |
 | MAX_BYTE_BUFFER_SIZE | Maximum size of a byte[] field. Large filed (> 1Mbyte) should not be stored as fields in the database
 | MAX_DECIMAL |
 | MIN_DECIMAL |
 | s_BSONtoCLR |
 | s_CLRtoBSON |
Back to Top
Properties
Name | Description
DefaultInstance | Returns the default instance
Back to Top
See Also
RowConverter Class
NFX.Serialization.BSON Namespace


RowConverter Constructor

RowConverter Constructor NFX Class Library

Initializes a new instance of the RowConverter class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RowConverter()
public RowConverter()
Public Sub New
Public Sub New
public:
RowConverter()
public:
RowConverter()
new : unit -> RowConverter
new : unit -> RowConverter
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter Fields

RowConverter Fields NFX Class Library

The RowConverter type exposes the following members.
Fields
 | Name | Description
 | DECIMAL_LONG_MUL |
Protected field | m_BSONtoCLR |
Protected field | m_CLRtoBSON |
 | MAX_BYTE_BUFFER_SIZE | Maximum size of a byte[] field. Large filed (> 1Mbyte) should not be stored as fields in the database
 | MAX_DECIMAL |
 | MIN_DECIMAL |
 | s_BSONtoCLR |
 | s_CLRtoBSON |
Back to Top
See Also
RowConverter Class
NFX.Serialization.BSON Namespace


RowConverter.DECIMAL_LONG_MUL Field

RowConverter DECIMAL_LONG_MUL Field NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly decimal DECIMAL_LONG_MUL
public static readonly decimal DECIMAL_LONG_MUL
Public Shared ReadOnly DECIMAL_LONG_MUL As Decimal
Public Shared ReadOnly DECIMAL_LONG_MUL As Decimal
public:
static initonly Decimal DECIMAL_LONG_MUL
public:
static initonly Decimal DECIMAL_LONG_MUL
static val DECIMAL_LONG_MUL: decimal
static val DECIMAL_LONG_MUL: decimal

Field Value

Type: Online Decimal
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.m_BSONtoCLR Field

RowConverter m_BSONtoCLR Field NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Dictionary<Type, Func<BSONElement, Object>> m_BSONtoCLR
protected Dictionary<Type, Func<BSONElement, Object>> m_BSONtoCLR
Protected m_BSONtoCLR As Dictionary(Of Type, Func(Of BSONElement, Object))
Protected m_BSONtoCLR As Dictionary(Of Type, Func(Of BSONElement, Object))
protected:
Dictionary<Type^, Func<BSONElement^, Object^>^>^ m_BSONtoCLR
protected:
Dictionary<Type^, Func<BSONElement^, Object^>^>^ m_BSONtoCLR
val mutable m_BSONtoCLR: Dictionary<Type, Func<BSONElement, Object>>
val mutable m_BSONtoCLR: Dictionary<Type, Func<BSONElement, Object>>

Field Value

Type: Online Dictionary Online Type, Online Func BSONElement, Online Object
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.m_CLRtoBSON Field

RowConverter m_CLRtoBSON Field NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Dictionary<Type, Func<string, Object, BSONElement>> m_CLRtoBSON
protected Dictionary<Type, Func<string, Object, BSONElement>> m_CLRtoBSON
Protected m_CLRtoBSON As Dictionary(Of Type, Func(Of String, Object, BSONElement))
Protected m_CLRtoBSON As Dictionary(Of Type, Func(Of String, Object, BSONElement))
protected:
Dictionary<Type^, Func<String^, Object^, BSONElement^>^>^ m_CLRtoBSON
protected:
Dictionary<Type^, Func<String^, Object^, BSONElement^>^>^ m_CLRtoBSON
val mutable m_CLRtoBSON: Dictionary<Type, Func<string, Object, BSONElement>>
val mutable m_CLRtoBSON: Dictionary<Type, Func<string, Object, BSONElement>>

Field Value

Type: Online Dictionary Online Type, Online Func Online String, Online Object, BSONElement
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.MAX_BYTE_BUFFER_SIZE Field

RowConverter MAX_BYTE_BUFFER_SIZE Field NFX Class Library

Maximum size of a byte[] field. Large filed (> 1Mbyte) should not be stored as fields in the database

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_BYTE_BUFFER_SIZE
public const int MAX_BYTE_BUFFER_SIZE
Public Const MAX_BYTE_BUFFER_SIZE As Integer
Public Const MAX_BYTE_BUFFER_SIZE As Integer
public:
literal int MAX_BYTE_BUFFER_SIZE
public:
literal int MAX_BYTE_BUFFER_SIZE
static val mutable MAX_BYTE_BUFFER_SIZE: int
static val mutable MAX_BYTE_BUFFER_SIZE: int

Field Value

Type: Online Int32
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.MAX_DECIMAL Field

RowConverter MAX_DECIMAL Field NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly decimal MAX_DECIMAL
public static readonly decimal MAX_DECIMAL
Public Shared ReadOnly MAX_DECIMAL As Decimal
Public Shared ReadOnly MAX_DECIMAL As Decimal
public:
static initonly Decimal MAX_DECIMAL
public:
static initonly Decimal MAX_DECIMAL
static val MAX_DECIMAL: decimal
static val MAX_DECIMAL: decimal

Field Value

Type: Online Decimal
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.MIN_DECIMAL Field

RowConverter MIN_DECIMAL Field NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly decimal MIN_DECIMAL
public static readonly decimal MIN_DECIMAL
Public Shared ReadOnly MIN_DECIMAL As Decimal
Public Shared ReadOnly MIN_DECIMAL As Decimal
public:
static initonly Decimal MIN_DECIMAL
public:
static initonly Decimal MIN_DECIMAL
static val MIN_DECIMAL: decimal
static val MIN_DECIMAL: decimal

Field Value

Type: Online Decimal
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.s_BSONtoCLR Field

RowConverter s_BSONtoCLR Field NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected static Dictionary<Type, Func<BSONElement, Object>> s_BSONtoCLR
protected static Dictionary<Type, Func<BSONElement, Object>> s_BSONtoCLR
Protected Shared s_BSONtoCLR As Dictionary(Of Type, Func(Of BSONElement, Object))
Protected Shared s_BSONtoCLR As Dictionary(Of Type, Func(Of BSONElement, Object))
protected:
static Dictionary<Type^, Func<BSONElement^, Object^>^>^ s_BSONtoCLR
protected:
static Dictionary<Type^, Func<BSONElement^, Object^>^>^ s_BSONtoCLR
static val mutable s_BSONtoCLR: Dictionary<Type, Func<BSONElement, Object>>
static val mutable s_BSONtoCLR: Dictionary<Type, Func<BSONElement, Object>>

Field Value

Type: Online Dictionary Online Type, Online Func BSONElement, Online Object
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.s_CLRtoBSON Field

RowConverter s_CLRtoBSON Field NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected static Dictionary<Type, Func<string, Object, BSONElement>> s_CLRtoBSON
protected static Dictionary<Type, Func<string, Object, BSONElement>> s_CLRtoBSON
Protected Shared s_CLRtoBSON As Dictionary(Of Type, Func(Of String, Object, BSONElement))
Protected Shared s_CLRtoBSON As Dictionary(Of Type, Func(Of String, Object, BSONElement))
protected:
static Dictionary<Type^, Func<String^, Object^, BSONElement^>^>^ s_CLRtoBSON
protected:
static Dictionary<Type^, Func<String^, Object^, BSONElement^>^>^ s_CLRtoBSON
static val mutable s_CLRtoBSON: Dictionary<Type, Func<string, Object, BSONElement>>
static val mutable s_CLRtoBSON: Dictionary<Type, Func<string, Object, BSONElement>>

Field Value

Type: Online Dictionary Online Type, Online Func Online String, Online Object, BSONElement
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter Methods

RowConverter Methods NFX Class Library

The RowConverter type exposes the following members.
Methods
 | Name | Description
 | Amount_BSONtoCLR |
 | Amount_CLRtoBSON |
Public method | BSONDocumentToJSONMap | Converts BSON document to JSON data map by directly mapping BSON types into corresponding CLR types. The sub-documents get mapped into JSONDataObjects, and BSON arrays get mapped into CLR object[]
Public method | BSONDocumentToRow | Converts BSON document into Row by filling the supplied row instance making necessary type transforms to suit Row.Schema field definitions per target name. If the passed row supports IAmorphousData, then the fields either not found in row, or the fields that could not be type-converted to CLR type will be stowed in amorphous data dictionary
 | ByteBuffer_CLRtoBSON |
 | ByteBufferID_CLRtoBSON | Encodes byte buffer purposed for id, using proper binary subtype
Public method | Configure |
Public method | ConvertCLRtoBSON | Converts CLR value to BSON. The following values are supported: primitives+scaled decimal, enums, TypedRows, GDID, Guid, Amount, IDictionary, IEnumerable (including arrays). If conversion could not be made then exception is thrown
 | Decimal_BSONtoCLR(BSONElement) |
 | Decimal_BSONtoCLR(BSONInt32Element) |
 | Decimal_BSONtoCLR(BSONInt64Element) |
 | Decimal_CLRtoBSON |
Protected method | DirectConvertBSONValue | Converts BSON to CLR value 1:1, without type change
Protected method | DoConvertCLRtoBSON | override to perform the conversion. the data is never null here, and ref cycles a ruled out
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | GDID_BSONtoCLR |
 | GDID_CLRtoBSON |
Protected method | GetAmorphousFieldAsBSON |
Protected method | GetFieldAsBSON |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | InferSchemaFromBSONDocument | Makes CRUD Schema out of BSON document. The types of all fields are object as documents do not have a predictable type of every field (they are dynamic and can change form doc to doc)
 | MapBSONFieldNameToSchemaFieldDef | Maps bsonFieldName to targeted fieldDef from specified schema using cache for TypedRows
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RowToBSONDocument | Converts row to BSON document suitable for storage in MONGO.DB. Pass target name (name of particular store/epoch/implementation) to get targeted field metadata. Note: the supplied row MAY NOT CONTAIN REFERENCE CYCLES - either direct or transitive
Public method | RowToBSONDocumentElement | Converts row to BSON document suitable for storage in MONGO.DB. Pass target name (name of particular store/epoch/implementation) to get targeted field metadata. Note: the supplied row MAY NOT CONTAIN REFERENCE CYCLES - either direct or transitive
Protected method | SetAmorphousFieldAsCLR |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Protected method | TryConvertBSONtoCLR | Tries to convert the BSON value into target CLR type. Returns true if conversion was successfull
Protected method | TrySetFieldAsCLR |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
RowConverter Class
NFX.Serialization.BSON Namespace


RowConverter.Amount_BSONtoCLR Method

RowConverter Amount_BSONtoCLR Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Amount Amount_BSONtoCLR(
    BSONDocumentElement el
)
public static Amount Amount_BSONtoCLR(
    BSONDocumentElement el
)
Public Shared Function Amount_BSONtoCLR (
    el As BSONDocumentElement
) As Amount
Public Shared Function Amount_BSONtoCLR (
    el As BSONDocumentElement
) As Amount
public:
static Amount Amount_BSONtoCLR(
    BSONDocumentElement^ el
)
public:
static Amount Amount_BSONtoCLR(
    BSONDocumentElement^ el
)
static member Amount_BSONtoCLR :
        el : BSONDocumentElement -> Amount
static member Amount_BSONtoCLR :
        el : BSONDocumentElement -> Amount

Parameters

el
Type: NFX.Serialization.BSON BSONDocumentElement

Return Value

Type: Amount
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.Amount_CLRtoBSON Method

RowConverter Amount_CLRtoBSON Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static BSONDocumentElement Amount_CLRtoBSON(
    string name,
    Amount amount
)
public static BSONDocumentElement Amount_CLRtoBSON(
    string name,
    Amount amount
)
Public Shared Function Amount_CLRtoBSON (
    name As String,
    amount As Amount
) As BSONDocumentElement
Public Shared Function Amount_CLRtoBSON (
    name As String,
    amount As Amount
) As BSONDocumentElement
public:
static BSONDocumentElement^ Amount_CLRtoBSON(
    String^ name,
    Amount amount
)
public:
static BSONDocumentElement^ Amount_CLRtoBSON(
    String^ name,
    Amount amount
)
static member Amount_CLRtoBSON :
        name : string *
        amount : Amount -> BSONDocumentElement
static member Amount_CLRtoBSON :
        name : string *
        amount : Amount -> BSONDocumentElement

Parameters

name
Type: Online System String
amount
Type: NFX.Financial Amount

Return Value

Type: BSONDocumentElement
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.BSONDocumentToJSONMap Method

RowConverter BSONDocumentToJSONMap Method NFX Class Library

Converts BSON document to JSON data map by directly mapping BSON types into corresponding CLR types. The sub-documents get mapped into JSONDataObjects, and BSON arrays get mapped into CLR object[]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual JSONDataMap BSONDocumentToJSONMap(
    BSONDocument doc,
    Func<BSONDocument, BSONElement, bool> filter = null
)
public virtual JSONDataMap BSONDocumentToJSONMap(
    BSONDocument doc,
    Func<BSONDocument, BSONElement, bool> filter = null
)
Public Overridable Function BSONDocumentToJSONMap (
    doc As BSONDocument,
    Optional filter As Func(Of BSONDocument, BSONElement, Boolean) = Nothing
) As JSONDataMap
Public Overridable Function BSONDocumentToJSONMap (
    doc As BSONDocument,
    Optional filter As Func(Of BSONDocument, BSONElement, Boolean) = Nothing
) As JSONDataMap
public:
virtual JSONDataMap^ BSONDocumentToJSONMap(
    BSONDocument^ doc,
    Func<BSONDocument^, BSONElement^, bool>^ filter = nullptr
)
public:
virtual JSONDataMap^ BSONDocumentToJSONMap(
    BSONDocument^ doc,
    Func<BSONDocument^, BSONElement^, bool>^ filter = nullptr
)
abstract BSONDocumentToJSONMap :
        doc : BSONDocument *
        ?filter : Func<BSONDocument, BSONElement, bool>
(* Defaults:
        let _filter = defaultArg filter null
*)
-> JSONDataMap
override BSONDocumentToJSONMap :
        doc : BSONDocument *
        ?filter : Func<BSONDocument, BSONElement, bool>
(* Defaults:
        let _filter = defaultArg filter null
*)
-> JSONDataMap
abstract BSONDocumentToJSONMap :
        doc : BSONDocument *
        ?filter : Func<BSONDocument, BSONElement, bool>
(* Defaults:
        let _filter = defaultArg filter null
*)
-> JSONDataMap
override BSONDocumentToJSONMap :
        doc : BSONDocument *
        ?filter : Func<BSONDocument, BSONElement, bool>
(* Defaults:
        let _filter = defaultArg filter null
*)
-> JSONDataMap

Parameters

doc
Type: NFX.Serialization.BSON BSONDocument
filter (Optional)
Type: Online System Func BSONDocument, BSONElement, Online Boolean

Return Value

Type: JSONDataMap
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.BSONDocumentToRow Method

RowConverter BSONDocumentToRow Method NFX Class Library

Converts BSON document into Row by filling the supplied row instance making necessary type transforms to suit Row.Schema field definitions per target name. If the passed row supports IAmorphousData, then the fields either not found in row, or the fields that could not be type-converted to CLR type will be stowed in amorphous data dictionary

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void BSONDocumentToRow(
    BSONDocument doc,
    Row row,
    string targetName,
    bool useAmorphousData = true,
    Func<BSONDocument, BSONElement, bool> filter = null
)
public virtual void BSONDocumentToRow(
    BSONDocument doc,
    Row row,
    string targetName,
    bool useAmorphousData = true,
    Func<BSONDocument, BSONElement, bool> filter = null
)
Public Overridable Sub BSONDocumentToRow (
    doc As BSONDocument,
    row As Row,
    targetName As String,
    Optional useAmorphousData As Boolean = true,
    Optional filter As Func(Of BSONDocument, BSONElement, Boolean) = Nothing
)
Public Overridable Sub BSONDocumentToRow (
    doc As BSONDocument,
    row As Row,
    targetName As String,
    Optional useAmorphousData As Boolean = true,
    Optional filter As Func(Of BSONDocument, BSONElement, Boolean) = Nothing
)
public:
virtual void BSONDocumentToRow(
    BSONDocument^ doc,
    Row^ row,
    String^ targetName,
    bool useAmorphousData = true,
    Func<BSONDocument^, BSONElement^, bool>^ filter = nullptr
)
public:
virtual void BSONDocumentToRow(
    BSONDocument^ doc,
    Row^ row,
    String^ targetName,
    bool useAmorphousData = true,
    Func<BSONDocument^, BSONElement^, bool>^ filter = nullptr
)
abstract BSONDocumentToRow :
        doc : BSONDocument *
        row : Row *
        targetName : string *
        ?useAmorphousData : bool *
        ?filter : Func<BSONDocument, BSONElement, bool>
(* Defaults:
        let _useAmorphousData = defaultArg useAmorphousData true
        let _filter = defaultArg filter null
*)
-> unit
override BSONDocumentToRow :
        doc : BSONDocument *
        row : Row *
        targetName : string *
        ?useAmorphousData : bool *
        ?filter : Func<BSONDocument, BSONElement, bool>
(* Defaults:
        let _useAmorphousData = defaultArg useAmorphousData true
        let _filter = defaultArg filter null
*)
-> unit
abstract BSONDocumentToRow :
        doc : BSONDocument *
        row : Row *
        targetName : string *
        ?useAmorphousData : bool *
        ?filter : Func<BSONDocument, BSONElement, bool>
(* Defaults:
        let _useAmorphousData = defaultArg useAmorphousData true
        let _filter = defaultArg filter null
*)
-> unit
override BSONDocumentToRow :
        doc : BSONDocument *
        row : Row *
        targetName : string *
        ?useAmorphousData : bool *
        ?filter : Func<BSONDocument, BSONElement, bool>
(* Defaults:
        let _useAmorphousData = defaultArg useAmorphousData true
        let _filter = defaultArg filter null
*)
-> unit

Parameters

doc
Type: NFX.Serialization.BSON BSONDocument
row
Type: NFX.DataAccess.CRUD Row
targetName
Type: Online System String
useAmorphousData (Optional)
Type: Online System Boolean
filter (Optional)
Type: Online System Func BSONDocument, BSONElement, Online Boolean
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.ByteBuffer_CLRtoBSON Method

RowConverter ByteBuffer_CLRtoBSON Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static BSONElement ByteBuffer_CLRtoBSON(
    string name,
    byte[] buf
)
public static BSONElement ByteBuffer_CLRtoBSON(
    string name,
    byte[] buf
)
Public Shared Function ByteBuffer_CLRtoBSON (
    name As String,
    buf As Byte()
) As BSONElement
Public Shared Function ByteBuffer_CLRtoBSON (
    name As String,
    buf As Byte()
) As BSONElement
public:
static BSONElement^ ByteBuffer_CLRtoBSON(
    String^ name,
    array<unsigned char>^ buf
)
public:
static BSONElement^ ByteBuffer_CLRtoBSON(
    String^ name,
    array<unsigned char>^ buf
)
static member ByteBuffer_CLRtoBSON :
        name : string *
        buf : byte[] -> BSONElement
static member ByteBuffer_CLRtoBSON :
        name : string *
        buf : byte[] -> BSONElement

Parameters

name
Type: Online System String
buf
Type: Online System Byte

Return Value

Type: BSONElement
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.ByteBufferID_CLRtoBSON Method

RowConverter ByteBufferID_CLRtoBSON Method NFX Class Library

Encodes byte buffer purposed for id, using proper binary subtype

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static BSONElement ByteBufferID_CLRtoBSON(
    string name,
    byte[] buf
)
public static BSONElement ByteBufferID_CLRtoBSON(
    string name,
    byte[] buf
)
Public Shared Function ByteBufferID_CLRtoBSON (
    name As String,
    buf As Byte()
) As BSONElement
Public Shared Function ByteBufferID_CLRtoBSON (
    name As String,
    buf As Byte()
) As BSONElement
public:
static BSONElement^ ByteBufferID_CLRtoBSON(
    String^ name,
    array<unsigned char>^ buf
)
public:
static BSONElement^ ByteBufferID_CLRtoBSON(
    String^ name,
    array<unsigned char>^ buf
)
static member ByteBufferID_CLRtoBSON :
        name : string *
        buf : byte[] -> BSONElement
static member ByteBufferID_CLRtoBSON :
        name : string *
        buf : byte[] -> BSONElement

Parameters

name
Type: Online System String
buf
Type: Online System Byte

Return Value

Type: BSONElement
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.Configure Method

RowConverter Configure Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void Configure(
    IConfigSectionNode node
)
public virtual void Configure(
    IConfigSectionNode node
)
Public Overridable Sub Configure (
    node As IConfigSectionNode
)
Public Overridable Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
)
public:
virtual void Configure(
    IConfigSectionNode^ node
)
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.ConvertCLRtoBSON Method

RowConverter ConvertCLRtoBSON Method NFX Class Library

Converts CLR value to BSON. The following values are supported: primitives+scaled decimal, enums, TypedRows, GDID, Guid, Amount, IDictionary, IEnumerable (including arrays). If conversion could not be made then exception is thrown

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BSONElement ConvertCLRtoBSON(
    string fieldName,
    Object data,
    string targetName
)
public BSONElement ConvertCLRtoBSON(
    string fieldName,
    Object data,
    string targetName
)
Public Function ConvertCLRtoBSON (
    fieldName As String,
    data As Object,
    targetName As String
) As BSONElement
Public Function ConvertCLRtoBSON (
    fieldName As String,
    data As Object,
    targetName As String
) As BSONElement
public:
BSONElement^ ConvertCLRtoBSON(
    String^ fieldName,
    Object^ data,
    String^ targetName
)
public:
BSONElement^ ConvertCLRtoBSON(
    String^ fieldName,
    Object^ data,
    String^ targetName
)
member ConvertCLRtoBSON :
        fieldName : string *
        data : Object *
        targetName : string -> BSONElement
member ConvertCLRtoBSON :
        fieldName : string *
        data : Object *
        targetName : string -> BSONElement

Parameters

fieldName
Type: Online System String
data
Type: Online System Object
targetName
Type: Online System String

Return Value

Type: BSONElement
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.Decimal_BSONtoCLR Method

RowConverter Decimal_BSONtoCLR Method NFX Class Library

Overload List
Name | Description
Decimal_BSONtoCLR(BSONElement) |
Decimal_BSONtoCLR(BSONInt32Element) |
Decimal_BSONtoCLR(BSONInt64Element) |
Back to Top
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.Decimal_BSONtoCLR Method (BSONElement)

RowConverter Decimal_BSONtoCLR Method (BSONElement) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static decimal Decimal_BSONtoCLR(
    BSONElement el
)
public static decimal Decimal_BSONtoCLR(
    BSONElement el
)
Public Shared Function Decimal_BSONtoCLR (
    el As BSONElement
) As Decimal
Public Shared Function Decimal_BSONtoCLR (
    el As BSONElement
) As Decimal
public:
static Decimal Decimal_BSONtoCLR(
    BSONElement^ el
)
public:
static Decimal Decimal_BSONtoCLR(
    BSONElement^ el
)
static member Decimal_BSONtoCLR :
        el : BSONElement -> decimal
static member Decimal_BSONtoCLR :
        el : BSONElement -> decimal

Parameters

el
Type: NFX.Serialization.BSON BSONElement

Return Value

Type: Online Decimal
See Also
RowConverter Class
RowConverter Members
Decimal_BSONtoCLR Overload
NFX.Serialization.BSON Namespace


RowConverter.Decimal_BSONtoCLR Method (BSONInt32Element)

RowConverter Decimal_BSONtoCLR Method (BSONInt32Element) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static decimal Decimal_BSONtoCLR(
    BSONInt32Element el
)
public static decimal Decimal_BSONtoCLR(
    BSONInt32Element el
)
Public Shared Function Decimal_BSONtoCLR (
    el As BSONInt32Element
) As Decimal
Public Shared Function Decimal_BSONtoCLR (
    el As BSONInt32Element
) As Decimal
public:
static Decimal Decimal_BSONtoCLR(
    BSONInt32Element^ el
)
public:
static Decimal Decimal_BSONtoCLR(
    BSONInt32Element^ el
)
static member Decimal_BSONtoCLR :
        el : BSONInt32Element -> decimal
static member Decimal_BSONtoCLR :
        el : BSONInt32Element -> decimal

Parameters

el
Type: NFX.Serialization.BSON BSONInt32Element

Return Value

Type: Online Decimal
See Also
RowConverter Class
RowConverter Members
Decimal_BSONtoCLR Overload
NFX.Serialization.BSON Namespace


RowConverter.Decimal_BSONtoCLR Method (BSONInt64Element)

RowConverter Decimal_BSONtoCLR Method (BSONInt64Element) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static decimal Decimal_BSONtoCLR(
    BSONInt64Element el
)
public static decimal Decimal_BSONtoCLR(
    BSONInt64Element el
)
Public Shared Function Decimal_BSONtoCLR (
    el As BSONInt64Element
) As Decimal
Public Shared Function Decimal_BSONtoCLR (
    el As BSONInt64Element
) As Decimal
public:
static Decimal Decimal_BSONtoCLR(
    BSONInt64Element^ el
)
public:
static Decimal Decimal_BSONtoCLR(
    BSONInt64Element^ el
)
static member Decimal_BSONtoCLR :
        el : BSONInt64Element -> decimal
static member Decimal_BSONtoCLR :
        el : BSONInt64Element -> decimal

Parameters

el
Type: NFX.Serialization.BSON BSONInt64Element

Return Value

Type: Online Decimal
See Also
RowConverter Class
RowConverter Members
Decimal_BSONtoCLR Overload
NFX.Serialization.BSON Namespace


RowConverter.Decimal_CLRtoBSON Method

RowConverter Decimal_CLRtoBSON Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static BSONInt64Element Decimal_CLRtoBSON(
    string name,
    decimal v
)
public static BSONInt64Element Decimal_CLRtoBSON(
    string name,
    decimal v
)
Public Shared Function Decimal_CLRtoBSON (
    name As String,
    v As Decimal
) As BSONInt64Element
Public Shared Function Decimal_CLRtoBSON (
    name As String,
    v As Decimal
) As BSONInt64Element
public:
static BSONInt64Element^ Decimal_CLRtoBSON(
    String^ name,
    Decimal v
)
public:
static BSONInt64Element^ Decimal_CLRtoBSON(
    String^ name,
    Decimal v
)
static member Decimal_CLRtoBSON :
        name : string *
        v : decimal -> BSONInt64Element
static member Decimal_CLRtoBSON :
        name : string *
        v : decimal -> BSONInt64Element

Parameters

name
Type: Online System String
v
Type: Online System Decimal

Return Value

Type: BSONInt64Element
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.DirectConvertBSONValue Method

RowConverter DirectConvertBSONValue Method NFX Class Library

Converts BSON to CLR value 1:1, without type change

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual Object DirectConvertBSONValue(
    BSONElement element,
    Func<BSONDocument, BSONElement, bool> filter = null
)
protected virtual Object DirectConvertBSONValue(
    BSONElement element,
    Func<BSONDocument, BSONElement, bool> filter = null
)
Protected Overridable Function DirectConvertBSONValue (
    element As BSONElement,
    Optional filter As Func(Of BSONDocument, BSONElement, Boolean) = Nothing
) As Object
Protected Overridable Function DirectConvertBSONValue (
    element As BSONElement,
    Optional filter As Func(Of BSONDocument, BSONElement, Boolean) = Nothing
) As Object
protected:
virtual Object^ DirectConvertBSONValue(
    BSONElement^ element,
    Func<BSONDocument^, BSONElement^, bool>^ filter = nullptr
)
protected:
virtual Object^ DirectConvertBSONValue(
    BSONElement^ element,
    Func<BSONDocument^, BSONElement^, bool>^ filter = nullptr
)
abstract DirectConvertBSONValue :
        element : BSONElement *
        ?filter : Func<BSONDocument, BSONElement, bool>
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Object
override DirectConvertBSONValue :
        element : BSONElement *
        ?filter : Func<BSONDocument, BSONElement, bool>
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Object
abstract DirectConvertBSONValue :
        element : BSONElement *
        ?filter : Func<BSONDocument, BSONElement, bool>
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Object
override DirectConvertBSONValue :
        element : BSONElement *
        ?filter : Func<BSONDocument, BSONElement, bool>
(* Defaults:
        let _filter = defaultArg filter null
*)
-> Object

Parameters

element
Type: NFX.Serialization.BSON BSONElement
filter (Optional)
Type: Online System Func BSONDocument, BSONElement, Online Boolean

Return Value

Type: Online Object
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.DoConvertCLRtoBSON Method

RowConverter DoConvertCLRtoBSON Method NFX Class Library

override to perform the conversion. the data is never null here, and ref cycles a ruled out

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual BSONElement DoConvertCLRtoBSON(
    string name,
    Object data,
    Type dataType,
    string targetName
)
protected virtual BSONElement DoConvertCLRtoBSON(
    string name,
    Object data,
    Type dataType,
    string targetName
)
Protected Overridable Function DoConvertCLRtoBSON (
    name As String,
    data As Object,
    dataType As Type,
    targetName As String
) As BSONElement
Protected Overridable Function DoConvertCLRtoBSON (
    name As String,
    data As Object,
    dataType As Type,
    targetName As String
) As BSONElement
protected:
virtual BSONElement^ DoConvertCLRtoBSON(
    String^ name,
    Object^ data,
    Type^ dataType,
    String^ targetName
)
protected:
virtual BSONElement^ DoConvertCLRtoBSON(
    String^ name,
    Object^ data,
    Type^ dataType,
    String^ targetName
)
abstract DoConvertCLRtoBSON :
        name : string *
        data : Object *
        dataType : Type *
        targetName : string -> BSONElement
override DoConvertCLRtoBSON :
        name : string *
        data : Object *
        dataType : Type *
        targetName : string -> BSONElement
abstract DoConvertCLRtoBSON :
        name : string *
        data : Object *
        dataType : Type *
        targetName : string -> BSONElement
override DoConvertCLRtoBSON :
        name : string *
        data : Object *
        dataType : Type *
        targetName : string -> BSONElement

Parameters

name
Type: Online System String
data
Type: Online System Object
dataType
Type: Online System Type
targetName
Type: Online System String

Return Value

Type: BSONElement
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.GDID_BSONtoCLR Method

RowConverter GDID_BSONtoCLR Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static GDID GDID_BSONtoCLR(
    BSONBinaryElement el
)
public static GDID GDID_BSONtoCLR(
    BSONBinaryElement el
)
Public Shared Function GDID_BSONtoCLR (
    el As BSONBinaryElement
) As GDID
Public Shared Function GDID_BSONtoCLR (
    el As BSONBinaryElement
) As GDID
public:
static GDID GDID_BSONtoCLR(
    BSONBinaryElement^ el
)
public:
static GDID GDID_BSONtoCLR(
    BSONBinaryElement^ el
)
static member GDID_BSONtoCLR :
        el : BSONBinaryElement -> GDID
static member GDID_BSONtoCLR :
        el : BSONBinaryElement -> GDID

Parameters

el
Type: NFX.Serialization.BSON BSONBinaryElement

Return Value

Type: GDID
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.GDID_CLRtoBSON Method

RowConverter GDID_CLRtoBSON Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static BSONElement GDID_CLRtoBSON(
    string name,
    GDID gdid
)
public static BSONElement GDID_CLRtoBSON(
    string name,
    GDID gdid
)
Public Shared Function GDID_CLRtoBSON (
    name As String,
    gdid As GDID
) As BSONElement
Public Shared Function GDID_CLRtoBSON (
    name As String,
    gdid As GDID
) As BSONElement
public:
static BSONElement^ GDID_CLRtoBSON(
    String^ name,
    GDID gdid
)
public:
static BSONElement^ GDID_CLRtoBSON(
    String^ name,
    GDID gdid
)
static member GDID_CLRtoBSON :
        name : string *
        gdid : GDID -> BSONElement
static member GDID_CLRtoBSON :
        name : string *
        gdid : GDID -> BSONElement

Parameters

name
Type: Online System String
gdid
Type: NFX.DataAccess.Distributed GDID

Return Value

Type: BSONElement
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.GetAmorphousFieldAsBSON Method

RowConverter GetAmorphousFieldAsBSON Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual BSONElement GetAmorphousFieldAsBSON(
    KeyValuePair<string, Object> field,
    string targetName
)
protected virtual BSONElement GetAmorphousFieldAsBSON(
    KeyValuePair<string, Object> field,
    string targetName
)
Protected Overridable Function GetAmorphousFieldAsBSON (
    field As KeyValuePair(Of String, Object),
    targetName As String
) As BSONElement
Protected Overridable Function GetAmorphousFieldAsBSON (
    field As KeyValuePair(Of String, Object),
    targetName As String
) As BSONElement
protected:
virtual BSONElement^ GetAmorphousFieldAsBSON(
    KeyValuePair<String^, Object^> field,
    String^ targetName
)
protected:
virtual BSONElement^ GetAmorphousFieldAsBSON(
    KeyValuePair<String^, Object^> field,
    String^ targetName
)
abstract GetAmorphousFieldAsBSON :
        field : KeyValuePair<string, Object> *
        targetName : string -> BSONElement
override GetAmorphousFieldAsBSON :
        field : KeyValuePair<string, Object> *
        targetName : string -> BSONElement
abstract GetAmorphousFieldAsBSON :
        field : KeyValuePair<string, Object> *
        targetName : string -> BSONElement
override GetAmorphousFieldAsBSON :
        field : KeyValuePair<string, Object> *
        targetName : string -> BSONElement

Parameters

field
Type: Online System.Collections.Generic KeyValuePair Online String, Online Object
targetName
Type: Online System String

Return Value

Type: BSONElement
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.GetFieldAsBSON Method

RowConverter GetFieldAsBSON Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual BSONElement GetFieldAsBSON(
    Row row,
    Schema..::..FieldDef field,
    string targetName
)
protected virtual BSONElement GetFieldAsBSON(
    Row row,
    Schema..::..FieldDef field,
    string targetName
)
Protected Overridable Function GetFieldAsBSON (
    row As Row,
    field As Schema..::..FieldDef,
    targetName As String
) As BSONElement
Protected Overridable Function GetFieldAsBSON (
    row As Row,
    field As Schema..::..FieldDef,
    targetName As String
) As BSONElement
protected:
virtual BSONElement^ GetFieldAsBSON(
    Row^ row,
    Schema..::..FieldDef^ field,
    String^ targetName
)
protected:
virtual BSONElement^ GetFieldAsBSON(
    Row^ row,
    Schema..::..FieldDef^ field,
    String^ targetName
)
abstract GetFieldAsBSON :
        row : Row *
        field : Schema..::..FieldDef *
        targetName : string -> BSONElement
override GetFieldAsBSON :
        row : Row *
        field : Schema..::..FieldDef *
        targetName : string -> BSONElement
abstract GetFieldAsBSON :
        row : Row *
        field : Schema..::..FieldDef *
        targetName : string -> BSONElement
override GetFieldAsBSON :
        row : Row *
        field : Schema..::..FieldDef *
        targetName : string -> BSONElement

Parameters

row
Type: NFX.DataAccess.CRUD Row
field
Type: NFX.DataAccess.CRUD Schema FieldDef
targetName
Type: Online System String

Return Value

Type: BSONElement
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.InferSchemaFromBSONDocument Method

RowConverter InferSchemaFromBSONDocument Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Makes CRUD Schema out of BSON document. The types of all fields are object as documents do not have a predictable type of every field (they are dynamic and can change form doc to doc)

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Schema InferSchemaFromBSONDocument(
    BSONDocument doc,
    string schemaName = null
)
public virtual Schema InferSchemaFromBSONDocument(
    BSONDocument doc,
    string schemaName = null
)
Public Overridable Function InferSchemaFromBSONDocument (
    doc As BSONDocument,
    Optional schemaName As String = Nothing
) As Schema
Public Overridable Function InferSchemaFromBSONDocument (
    doc As BSONDocument,
    Optional schemaName As String = Nothing
) As Schema
public:
virtual Schema^ InferSchemaFromBSONDocument(
    BSONDocument^ doc,
    String^ schemaName = nullptr
)
public:
virtual Schema^ InferSchemaFromBSONDocument(
    BSONDocument^ doc,
    String^ schemaName = nullptr
)
abstract InferSchemaFromBSONDocument :
        doc : BSONDocument *
        ?schemaName : string
(* Defaults:
        let _schemaName = defaultArg schemaName null
*)
-> Schema
override InferSchemaFromBSONDocument :
        doc : BSONDocument *
        ?schemaName : string
(* Defaults:
        let _schemaName = defaultArg schemaName null
*)
-> Schema
abstract InferSchemaFromBSONDocument :
        doc : BSONDocument *
        ?schemaName : string
(* Defaults:
        let _schemaName = defaultArg schemaName null
*)
-> Schema
override InferSchemaFromBSONDocument :
        doc : BSONDocument *
        ?schemaName : string
(* Defaults:
        let _schemaName = defaultArg schemaName null
*)
-> Schema

Parameters

doc
Type: NFX.Serialization.BSON BSONDocument
schemaName (Optional)
Type: Online System String

Return Value

Type: Schema
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.MapBSONFieldNameToSchemaFieldDef Method

RowConverter MapBSONFieldNameToSchemaFieldDef Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Maps bsonFieldName to targeted fieldDef from specified schema using cache for TypedRows

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected static Schema..::..FieldDef MapBSONFieldNameToSchemaFieldDef(
    Schema schema,
    string targetName,
    string bsonFieldName
)
protected static Schema..::..FieldDef MapBSONFieldNameToSchemaFieldDef(
    Schema schema,
    string targetName,
    string bsonFieldName
)
Protected Shared Function MapBSONFieldNameToSchemaFieldDef (
    schema As Schema,
    targetName As String,
    bsonFieldName As String
) As Schema..::..FieldDef
Protected Shared Function MapBSONFieldNameToSchemaFieldDef (
    schema As Schema,
    targetName As String,
    bsonFieldName As String
) As Schema..::..FieldDef
protected:
static Schema..::..FieldDef^ MapBSONFieldNameToSchemaFieldDef(
    Schema^ schema,
    String^ targetName,
    String^ bsonFieldName
)
protected:
static Schema..::..FieldDef^ MapBSONFieldNameToSchemaFieldDef(
    Schema^ schema,
    String^ targetName,
    String^ bsonFieldName
)
static member MapBSONFieldNameToSchemaFieldDef :
        schema : Schema *
        targetName : string *
        bsonFieldName : string -> Schema..::..FieldDef
static member MapBSONFieldNameToSchemaFieldDef :
        schema : Schema *
        targetName : string *
        bsonFieldName : string -> Schema..::..FieldDef

Parameters

schema
Type: NFX.DataAccess.CRUD Schema
targetName
Type: Online System String
bsonFieldName
Type: Online System String

Return Value

Type: Schema FieldDef
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.RowToBSONDocument Method

RowConverter RowToBSONDocument Method NFX Class Library

Converts row to BSON document suitable for storage in MONGO.DB. Pass target name (name of particular store/epoch/implementation) to get targeted field metadata. Note: the supplied row MAY NOT CONTAIN REFERENCE CYCLES - either direct or transitive

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual BSONDocument RowToBSONDocument(
    Row row,
    string targetName,
    bool useAmorphousData = true,
    FieldFilterFunc filter = null
)
public virtual BSONDocument RowToBSONDocument(
    Row row,
    string targetName,
    bool useAmorphousData = true,
    FieldFilterFunc filter = null
)
Public Overridable Function RowToBSONDocument (
    row As Row,
    targetName As String,
    Optional useAmorphousData As Boolean = true,
    Optional filter As FieldFilterFunc = Nothing
) As BSONDocument
Public Overridable Function RowToBSONDocument (
    row As Row,
    targetName As String,
    Optional useAmorphousData As Boolean = true,
    Optional filter As FieldFilterFunc = Nothing
) As BSONDocument
public:
virtual BSONDocument^ RowToBSONDocument(
    Row^ row,
    String^ targetName,
    bool useAmorphousData = true,
    FieldFilterFunc^ filter = nullptr
)
public:
virtual BSONDocument^ RowToBSONDocument(
    Row^ row,
    String^ targetName,
    bool useAmorphousData = true,
    FieldFilterFunc^ filter = nullptr
)
abstract RowToBSONDocument :
        row : Row *
        targetName : string *
        ?useAmorphousData : bool *
        ?filter : FieldFilterFunc
(* Defaults:
        let _useAmorphousData = defaultArg useAmorphousData true
        let _filter = defaultArg filter null
*)
-> BSONDocument
override RowToBSONDocument :
        row : Row *
        targetName : string *
        ?useAmorphousData : bool *
        ?filter : FieldFilterFunc
(* Defaults:
        let _useAmorphousData = defaultArg useAmorphousData true
        let _filter = defaultArg filter null
*)
-> BSONDocument
abstract RowToBSONDocument :
        row : Row *
        targetName : string *
        ?useAmorphousData : bool *
        ?filter : FieldFilterFunc
(* Defaults:
        let _useAmorphousData = defaultArg useAmorphousData true
        let _filter = defaultArg filter null
*)
-> BSONDocument
override RowToBSONDocument :
        row : Row *
        targetName : string *
        ?useAmorphousData : bool *
        ?filter : FieldFilterFunc
(* Defaults:
        let _useAmorphousData = defaultArg useAmorphousData true
        let _filter = defaultArg filter null
*)
-> BSONDocument

Parameters

row
Type: NFX.DataAccess.CRUD Row
targetName
Type: Online System String
useAmorphousData (Optional)
Type: Online System Boolean
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: BSONDocument
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.RowToBSONDocumentElement Method

RowConverter RowToBSONDocumentElement Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Converts row to BSON document suitable for storage in MONGO.DB. Pass target name (name of particular store/epoch/implementation) to get targeted field metadata. Note: the supplied row MAY NOT CONTAIN REFERENCE CYCLES - either direct or transitive

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual BSONDocumentElement RowToBSONDocumentElement(
    Row row,
    string targetName,
    bool useAmorphousData = true,
    string name = null,
    FieldFilterFunc filter = null
)
public virtual BSONDocumentElement RowToBSONDocumentElement(
    Row row,
    string targetName,
    bool useAmorphousData = true,
    string name = null,
    FieldFilterFunc filter = null
)
Public Overridable Function RowToBSONDocumentElement (
    row As Row,
    targetName As String,
    Optional useAmorphousData As Boolean = true,
    Optional name As String = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As BSONDocumentElement
Public Overridable Function RowToBSONDocumentElement (
    row As Row,
    targetName As String,
    Optional useAmorphousData As Boolean = true,
    Optional name As String = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As BSONDocumentElement
public:
virtual BSONDocumentElement^ RowToBSONDocumentElement(
    Row^ row,
    String^ targetName,
    bool useAmorphousData = true,
    String^ name = nullptr,
    FieldFilterFunc^ filter = nullptr
)
public:
virtual BSONDocumentElement^ RowToBSONDocumentElement(
    Row^ row,
    String^ targetName,
    bool useAmorphousData = true,
    String^ name = nullptr,
    FieldFilterFunc^ filter = nullptr
)
abstract RowToBSONDocumentElement :
        row : Row *
        targetName : string *
        ?useAmorphousData : bool *
        ?name : string *
        ?filter : FieldFilterFunc
(* Defaults:
        let _useAmorphousData = defaultArg useAmorphousData true
        let _name = defaultArg name null
        let _filter = defaultArg filter null
*)
-> BSONDocumentElement
override RowToBSONDocumentElement :
        row : Row *
        targetName : string *
        ?useAmorphousData : bool *
        ?name : string *
        ?filter : FieldFilterFunc
(* Defaults:
        let _useAmorphousData = defaultArg useAmorphousData true
        let _name = defaultArg name null
        let _filter = defaultArg filter null
*)
-> BSONDocumentElement
abstract RowToBSONDocumentElement :
        row : Row *
        targetName : string *
        ?useAmorphousData : bool *
        ?name : string *
        ?filter : FieldFilterFunc
(* Defaults:
        let _useAmorphousData = defaultArg useAmorphousData true
        let _name = defaultArg name null
        let _filter = defaultArg filter null
*)
-> BSONDocumentElement
override RowToBSONDocumentElement :
        row : Row *
        targetName : string *
        ?useAmorphousData : bool *
        ?name : string *
        ?filter : FieldFilterFunc
(* Defaults:
        let _useAmorphousData = defaultArg useAmorphousData true
        let _name = defaultArg name null
        let _filter = defaultArg filter null
*)
-> BSONDocumentElement

Parameters

row
Type: NFX.DataAccess.CRUD Row
targetName
Type: Online System String
useAmorphousData (Optional)
Type: Online System Boolean
name (Optional)
Type: Online System String
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: BSONDocumentElement
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.SetAmorphousFieldAsCLR Method

RowConverter SetAmorphousFieldAsCLR Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool SetAmorphousFieldAsCLR(
    IAmorphousData amorph,
    BSONElement bsonElement,
    string targetName,
    Func<BSONDocument, BSONElement, bool> filter
)
protected virtual bool SetAmorphousFieldAsCLR(
    IAmorphousData amorph,
    BSONElement bsonElement,
    string targetName,
    Func<BSONDocument, BSONElement, bool> filter
)
Protected Overridable Function SetAmorphousFieldAsCLR (
    amorph As IAmorphousData,
    bsonElement As BSONElement,
    targetName As String,
    filter As Func(Of BSONDocument, BSONElement, Boolean)
) As Boolean
Protected Overridable Function SetAmorphousFieldAsCLR (
    amorph As IAmorphousData,
    bsonElement As BSONElement,
    targetName As String,
    filter As Func(Of BSONDocument, BSONElement, Boolean)
) As Boolean
protected:
virtual bool SetAmorphousFieldAsCLR(
    IAmorphousData^ amorph,
    BSONElement^ bsonElement,
    String^ targetName,
    Func<BSONDocument^, BSONElement^, bool>^ filter
)
protected:
virtual bool SetAmorphousFieldAsCLR(
    IAmorphousData^ amorph,
    BSONElement^ bsonElement,
    String^ targetName,
    Func<BSONDocument^, BSONElement^, bool>^ filter
)
abstract SetAmorphousFieldAsCLR :
        amorph : IAmorphousData *
        bsonElement : BSONElement *
        targetName : string *
        filter : Func<BSONDocument, BSONElement, bool> -> bool
override SetAmorphousFieldAsCLR :
        amorph : IAmorphousData *
        bsonElement : BSONElement *
        targetName : string *
        filter : Func<BSONDocument, BSONElement, bool> -> bool
abstract SetAmorphousFieldAsCLR :
        amorph : IAmorphousData *
        bsonElement : BSONElement *
        targetName : string *
        filter : Func<BSONDocument, BSONElement, bool> -> bool
override SetAmorphousFieldAsCLR :
        amorph : IAmorphousData *
        bsonElement : BSONElement *
        targetName : string *
        filter : Func<BSONDocument, BSONElement, bool> -> bool

Parameters

amorph
Type: NFX.DataAccess.CRUD IAmorphousData
bsonElement
Type: NFX.Serialization.BSON BSONElement
targetName
Type: Online System String
filter
Type: Online System Func BSONDocument, BSONElement, Online Boolean

Return Value

Type: Online Boolean
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.TryConvertBSONtoCLR Method

RowConverter TryConvertBSONtoCLR Method NFX Class Library

Tries to convert the BSON value into target CLR type. Returns true if conversion was successfull

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool TryConvertBSONtoCLR(
    Type target,
    BSONElement element,
    string targetName,
    out Object clrValue,
    Func<BSONDocument, BSONElement, bool> filter
)
protected virtual bool TryConvertBSONtoCLR(
    Type target,
    BSONElement element,
    string targetName,
    out Object clrValue,
    Func<BSONDocument, BSONElement, bool> filter
)
Protected Overridable Function TryConvertBSONtoCLR (
    target As Type,
    element As BSONElement,
    targetName As String,
    <OutAttribute> ByRef clrValue As Object,
    filter As Func(Of BSONDocument, BSONElement, Boolean)
) As Boolean
Protected Overridable Function TryConvertBSONtoCLR (
    target As Type,
    element As BSONElement,
    targetName As String,
    <OutAttribute> ByRef clrValue As Object,
    filter As Func(Of BSONDocument, BSONElement, Boolean)
) As Boolean
protected:
virtual bool TryConvertBSONtoCLR(
    Type^ target,
    BSONElement^ element,
    String^ targetName,
    [OutAttribute] Object^% clrValue,
    Func<BSONDocument^, BSONElement^, bool>^ filter
)
protected:
virtual bool TryConvertBSONtoCLR(
    Type^ target,
    BSONElement^ element,
    String^ targetName,
    [OutAttribute] Object^% clrValue,
    Func<BSONDocument^, BSONElement^, bool>^ filter
)
abstract TryConvertBSONtoCLR :
        target : Type *
        element : BSONElement *
        targetName : string *
        clrValue : Object byref *
        filter : Func<BSONDocument, BSONElement, bool> -> bool
override TryConvertBSONtoCLR :
        target : Type *
        element : BSONElement *
        targetName : string *
        clrValue : Object byref *
        filter : Func<BSONDocument, BSONElement, bool> -> bool
abstract TryConvertBSONtoCLR :
        target : Type *
        element : BSONElement *
        targetName : string *
        clrValue : Object byref *
        filter : Func<BSONDocument, BSONElement, bool> -> bool
override TryConvertBSONtoCLR :
        target : Type *
        element : BSONElement *
        targetName : string *
        clrValue : Object byref *
        filter : Func<BSONDocument, BSONElement, bool> -> bool

Parameters

target
Type: Online System Type
element
Type: NFX.Serialization.BSON BSONElement
targetName
Type: Online System String
clrValue
Type: Online System Object
filter
Type: Online System Func BSONDocument, BSONElement, Online Boolean

Return Value

Type: Online Boolean
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter.TrySetFieldAsCLR Method

RowConverter TrySetFieldAsCLR Method NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool TrySetFieldAsCLR(
    Row row,
    Schema..::..FieldDef field,
    BSONElement value,
    string targetName,
    Func<BSONDocument, BSONElement, bool> filter
)
protected virtual bool TrySetFieldAsCLR(
    Row row,
    Schema..::..FieldDef field,
    BSONElement value,
    string targetName,
    Func<BSONDocument, BSONElement, bool> filter
)
Protected Overridable Function TrySetFieldAsCLR (
    row As Row,
    field As Schema..::..FieldDef,
    value As BSONElement,
    targetName As String,
    filter As Func(Of BSONDocument, BSONElement, Boolean)
) As Boolean
Protected Overridable Function TrySetFieldAsCLR (
    row As Row,
    field As Schema..::..FieldDef,
    value As BSONElement,
    targetName As String,
    filter As Func(Of BSONDocument, BSONElement, Boolean)
) As Boolean
protected:
virtual bool TrySetFieldAsCLR(
    Row^ row,
    Schema..::..FieldDef^ field,
    BSONElement^ value,
    String^ targetName,
    Func<BSONDocument^, BSONElement^, bool>^ filter
)
protected:
virtual bool TrySetFieldAsCLR(
    Row^ row,
    Schema..::..FieldDef^ field,
    BSONElement^ value,
    String^ targetName,
    Func<BSONDocument^, BSONElement^, bool>^ filter
)
abstract TrySetFieldAsCLR :
        row : Row *
        field : Schema..::..FieldDef *
        value : BSONElement *
        targetName : string *
        filter : Func<BSONDocument, BSONElement, bool> -> bool
override TrySetFieldAsCLR :
        row : Row *
        field : Schema..::..FieldDef *
        value : BSONElement *
        targetName : string *
        filter : Func<BSONDocument, BSONElement, bool> -> bool
abstract TrySetFieldAsCLR :
        row : Row *
        field : Schema..::..FieldDef *
        value : BSONElement *
        targetName : string *
        filter : Func<BSONDocument, BSONElement, bool> -> bool
override TrySetFieldAsCLR :
        row : Row *
        field : Schema..::..FieldDef *
        value : BSONElement *
        targetName : string *
        filter : Func<BSONDocument, BSONElement, bool> -> bool

Parameters

row
Type: NFX.DataAccess.CRUD Row
field
Type: NFX.DataAccess.CRUD Schema FieldDef
value
Type: NFX.Serialization.BSON BSONElement
targetName
Type: Online System String
filter
Type: Online System Func BSONDocument, BSONElement, Online Boolean

Return Value

Type: Online Boolean
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


RowConverter Properties

RowConverter Properties NFX Class Library

The RowConverter type exposes the following members.
Properties
Name | Description
DefaultInstance | Returns the default instance
Back to Top
See Also
RowConverter Class
NFX.Serialization.BSON Namespace


RowConverter.DefaultInstance Property

RowConverter DefaultInstance Property NFX Class Library

Returns the default instance

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static RowConverter DefaultInstance { get; }
public static RowConverter DefaultInstance { get; }
Public Shared ReadOnly Property DefaultInstance As RowConverter
    Get
Public Shared ReadOnly Property DefaultInstance As RowConverter
    Get
public:
static property RowConverter^ DefaultInstance {
    RowConverter^ get ();
}
public:
static property RowConverter^ DefaultInstance {
    RowConverter^ get ();
}
static member DefaultInstance : RowConverter with get
static member DefaultInstance : RowConverter with get

Property Value

Type: RowConverter
See Also
RowConverter Class
RowConverter Members
NFX.Serialization.BSON Namespace


TemplateArg Structure

TemplateArg Structure NFX Class Library

Represents template argument

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct TemplateArg
public struct TemplateArg
Public Structure TemplateArg
Public Structure TemplateArg
public value class TemplateArg
public value class TemplateArg
[<SealedAttribute>]
type TemplateArg =  struct end
[<SealedAttribute>]
type TemplateArg =  struct end
See Also
TemplateArg Members
NFX.Serialization.BSON Namespace


TemplateArg Members

TemplateArg Members NFX Class Library

The TemplateArg type exposes the following members.
Constructors
 | Name | Description
Public method | TemplateArg(BSONElement) | Initializes a new instance of the TemplateArg class
Public method | TemplateArg(String, Object) | Initializes a new instance of the TemplateArg class
Public method | TemplateArg(String, BSONElementType, Object) | Initializes a new instance of the TemplateArg class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | BSONType |
Public field | Name |
Public field | Value |
Back to Top
See Also
TemplateArg Structure
NFX.Serialization.BSON Namespace


TemplateArg Constructor

TemplateArg Constructor NFX Class Library

Overload List
 | Name | Description
Public method | TemplateArg(BSONElement) | Initializes a new instance of the TemplateArg class
Public method | TemplateArg(String, Object) | Initializes a new instance of the TemplateArg class
Public method | TemplateArg(String, BSONElementType, Object) | Initializes a new instance of the TemplateArg class
Back to Top
See Also
TemplateArg Structure
TemplateArg Members
NFX.Serialization.BSON Namespace


TemplateArg Constructor (BSONElement)

TemplateArg Constructor (BSONElement) NFX Class Library

Initializes a new instance of the TemplateArg class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TemplateArg(
    BSONElement element
)
public TemplateArg(
    BSONElement element
)
Public Sub New (
    element As BSONElement
)
Public Sub New (
    element As BSONElement
)
public:
TemplateArg(
    BSONElement^ element
)
public:
TemplateArg(
    BSONElement^ element
)
new :
        element : BSONElement -> TemplateArg
new :
        element : BSONElement -> TemplateArg

Parameters

element
Type: NFX.Serialization.BSON BSONElement
See Also
TemplateArg Structure
TemplateArg Members
TemplateArg Overload
NFX.Serialization.BSON Namespace


TemplateArg Constructor (String, Object)

TemplateArg Constructor (String, Object) NFX Class Library

Initializes a new instance of the TemplateArg class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TemplateArg(
    string name,
    Object value
)
public TemplateArg(
    string name,
    Object value
)
Public Sub New (
    name As String,
    value As Object
)
Public Sub New (
    name As String,
    value As Object
)
public:
TemplateArg(
    String^ name,
    Object^ value
)
public:
TemplateArg(
    String^ name,
    Object^ value
)
new :
        name : string *
        value : Object -> TemplateArg
new :
        name : string *
        value : Object -> TemplateArg

Parameters

name
Type: Online System String
value
Type: Online System Object
See Also
TemplateArg Structure
TemplateArg Members
TemplateArg Overload
NFX.Serialization.BSON Namespace


TemplateArg Constructor (String, BSONElementType, Object)

TemplateArg Constructor (String, BSONElementType, Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TemplateArg class

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TemplateArg(
    string name,
    BSONElementType btype,
    Object value
)
public TemplateArg(
    string name,
    BSONElementType btype,
    Object value
)
Public Sub New (
    name As String,
    btype As BSONElementType,
    value As Object
)
Public Sub New (
    name As String,
    btype As BSONElementType,
    value As Object
)
public:
TemplateArg(
    String^ name,
    BSONElementType btype,
    Object^ value
)
public:
TemplateArg(
    String^ name,
    BSONElementType btype,
    Object^ value
)
new :
        name : string *
        btype : BSONElementType *
        value : Object -> TemplateArg
new :
        name : string *
        btype : BSONElementType *
        value : Object -> TemplateArg

Parameters

name
Type: Online System String
btype
Type: NFX.Serialization.BSON BSONElementType
value
Type: Online System Object
See Also
TemplateArg Structure
TemplateArg Members
TemplateArg Overload
NFX.Serialization.BSON Namespace


TemplateArg Fields

TemplateArg Fields NFX Class Library

The TemplateArg type exposes the following members.
Fields
 | Name | Description
Public field | BSONType |
Public field | Name |
Public field | Value |
Back to Top
See Also
TemplateArg Structure
NFX.Serialization.BSON Namespace


TemplateArg.BSONType Field

TemplateArg BSONType Field NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Nullable<BSONElementType> BSONType
public readonly Nullable<BSONElementType> BSONType
Public ReadOnly BSONType As Nullable(Of BSONElementType)
Public ReadOnly BSONType As Nullable(Of BSONElementType)
public:
initonly Nullable<BSONElementType> BSONType
public:
initonly Nullable<BSONElementType> BSONType
val BSONType: Nullable<BSONElementType>
val BSONType: Nullable<BSONElementType>

Field Value

Type: Online Nullable BSONElementType
See Also
TemplateArg Structure
TemplateArg Members
NFX.Serialization.BSON Namespace


TemplateArg.Name Field

TemplateArg Name Field NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Name
public readonly string Name
Public ReadOnly Name As String
Public ReadOnly Name As String
public:
initonly String^ Name
public:
initonly String^ Name
val Name: string
val Name: string

Field Value

Type: Online String
See Also
TemplateArg Structure
TemplateArg Members
NFX.Serialization.BSON Namespace


TemplateArg.Value Field

TemplateArg Value Field NFX Class Library

Namespace: NFX.Serialization.BSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Object Value
public readonly Object Value
Public ReadOnly Value As Object
Public ReadOnly Value As Object
public:
initonly Object^ Value
public:
initonly Object^ Value
val Value: Object
val Value: Object

Field Value

Type: Online Object
See Also
TemplateArg Structure
TemplateArg Members
NFX.Serialization.BSON Namespace


TemplateArg Methods

TemplateArg Methods NFX Class Library

The TemplateArg type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TemplateArg Structure
NFX.Serialization.BSON Namespace


NFX.Serialization.CSV Namespace

NFX.Serialization.CSV Namespace NFX Class Library

Classes
 | Class | Description
Public class | CSVParser |
Public class | CSVParser CharIteratorWithStats |
Public class | CSVParserException |
Public class | CSVWriter |
Public class | CSVWritingOptions | Specifies how row should be written in CSV. Use CSVWritingOptions.Default static property for typical options


CSVParser Class

CSVParser Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Serialization.CSV CSVParser

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class CSVParser
public static class CSVParser
<ExtensionAttribute>
Public NotInheritable Class CSVParser
<ExtensionAttribute>
Public NotInheritable Class CSVParser
[ExtensionAttribute]
public ref class CSVParser abstract sealed
[ExtensionAttribute]
public ref class CSVParser abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CSVParser =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CSVParser =  class end
See Also
CSVParser Members
NFX.Serialization.CSV Namespace


CSVParser Members

CSVParser Members NFX Class Library

The CSVParser type exposes the following members.
Methods
Name | Description
ParseCSV |
ParseCSVRow |
Back to Top
See Also
CSVParser Class
NFX.Serialization.CSV Namespace


CSVParser Methods

CSVParser Methods NFX Class Library

The CSVParser type exposes the following members.
Methods
Name | Description
ParseCSV |
ParseCSVRow |
Back to Top
See Also
CSVParser Class
NFX.Serialization.CSV Namespace


CSVParser.ParseCSV Method

CSVParser ParseCSV Method NFX Class Library

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<IEnumerable<string>> ParseCSV(
    this IEnumerable<char> stream,
    bool trim = false,
    bool skipHeader = false,
    int columns = -1,
    bool skipIfMore = false,
    bool addIfLess = false
)
public static IEnumerable<IEnumerable<string>> ParseCSV(
    this IEnumerable<char> stream,
    bool trim = false,
    bool skipHeader = false,
    int columns = -1,
    bool skipIfMore = false,
    bool addIfLess = false
)
<ExtensionAttribute>
Public Shared Function ParseCSV (
    stream As IEnumerable(Of Char),
    Optional trim As Boolean = false,
    Optional skipHeader As Boolean = false,
    Optional columns As Integer = -1,
    Optional skipIfMore As Boolean = false,
    Optional addIfLess As Boolean = false
) As IEnumerable(Of IEnumerable(Of String))
<ExtensionAttribute>
Public Shared Function ParseCSV (
    stream As IEnumerable(Of Char),
    Optional trim As Boolean = false,
    Optional skipHeader As Boolean = false,
    Optional columns As Integer = -1,
    Optional skipIfMore As Boolean = false,
    Optional addIfLess As Boolean = false
) As IEnumerable(Of IEnumerable(Of String))
public:
[ExtensionAttribute]
static IEnumerable<IEnumerable<String^>^>^ ParseCSV(
    IEnumerable<wchar_t>^ stream,
    bool trim = false,
    bool skipHeader = false,
    int columns = -1,
    bool skipIfMore = false,
    bool addIfLess = false
)
public:
[ExtensionAttribute]
static IEnumerable<IEnumerable<String^>^>^ ParseCSV(
    IEnumerable<wchar_t>^ stream,
    bool trim = false,
    bool skipHeader = false,
    int columns = -1,
    bool skipIfMore = false,
    bool addIfLess = false
)
static member ParseCSV :
        stream : IEnumerable<char> *
        ?trim : bool *
        ?skipHeader : bool *
        ?columns : int *
        ?skipIfMore : bool *
        ?addIfLess : bool
(* Defaults:
        let _trim = defaultArg trim false
        let _skipHeader = defaultArg skipHeader false
        let _columns = defaultArg columns -1
        let _skipIfMore = defaultArg skipIfMore false
        let _addIfLess = defaultArg addIfLess false
*)
-> IEnumerable<IEnumerable<string>>
static member ParseCSV :
        stream : IEnumerable<char> *
        ?trim : bool *
        ?skipHeader : bool *
        ?columns : int *
        ?skipIfMore : bool *
        ?addIfLess : bool
(* Defaults:
        let _trim = defaultArg trim false
        let _skipHeader = defaultArg skipHeader false
        let _columns = defaultArg columns -1
        let _skipIfMore = defaultArg skipIfMore false
        let _addIfLess = defaultArg addIfLess false
*)
-> IEnumerable<IEnumerable<string>>

Parameters

stream
Type: Online System.Collections.Generic IEnumerable Online Char
trim (Optional)
Type: Online System Boolean
skipHeader (Optional)
Type: Online System Boolean
columns (Optional)
Type: Online System Int32
skipIfMore (Optional)
Type: Online System Boolean
addIfLess (Optional)
Type: Online System Boolean

Return Value

Type: Online IEnumerable Online IEnumerable Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online IEnumerable Online Char . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
CSVParser Class
CSVParser Members
NFX.Serialization.CSV Namespace


CSVParser.ParseCSVRow Method

CSVParser ParseCSVRow Method NFX Class Library

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<string> ParseCSVRow(
    this IEnumerable<char> row,
    bool trim = false,
    int columns = -1,
    bool skipIfMore = false,
    bool addIfLess = false
)
public static IEnumerable<string> ParseCSVRow(
    this IEnumerable<char> row,
    bool trim = false,
    int columns = -1,
    bool skipIfMore = false,
    bool addIfLess = false
)
<ExtensionAttribute>
Public Shared Function ParseCSVRow (
    row As IEnumerable(Of Char),
    Optional trim As Boolean = false,
    Optional columns As Integer = -1,
    Optional skipIfMore As Boolean = false,
    Optional addIfLess As Boolean = false
) As IEnumerable(Of String)
<ExtensionAttribute>
Public Shared Function ParseCSVRow (
    row As IEnumerable(Of Char),
    Optional trim As Boolean = false,
    Optional columns As Integer = -1,
    Optional skipIfMore As Boolean = false,
    Optional addIfLess As Boolean = false
) As IEnumerable(Of String)
public:
[ExtensionAttribute]
static IEnumerable<String^>^ ParseCSVRow(
    IEnumerable<wchar_t>^ row,
    bool trim = false,
    int columns = -1,
    bool skipIfMore = false,
    bool addIfLess = false
)
public:
[ExtensionAttribute]
static IEnumerable<String^>^ ParseCSVRow(
    IEnumerable<wchar_t>^ row,
    bool trim = false,
    int columns = -1,
    bool skipIfMore = false,
    bool addIfLess = false
)
static member ParseCSVRow :
        row : IEnumerable<char> *
        ?trim : bool *
        ?columns : int *
        ?skipIfMore : bool *
        ?addIfLess : bool
(* Defaults:
        let _trim = defaultArg trim false
        let _columns = defaultArg columns -1
        let _skipIfMore = defaultArg skipIfMore false
        let _addIfLess = defaultArg addIfLess false
*)
-> IEnumerable<string>
static member ParseCSVRow :
        row : IEnumerable<char> *
        ?trim : bool *
        ?columns : int *
        ?skipIfMore : bool *
        ?addIfLess : bool
(* Defaults:
        let _trim = defaultArg trim false
        let _columns = defaultArg columns -1
        let _skipIfMore = defaultArg skipIfMore false
        let _addIfLess = defaultArg addIfLess false
*)
-> IEnumerable<string>

Parameters

row
Type: Online System.Collections.Generic IEnumerable Online Char
trim (Optional)
Type: Online System Boolean
columns (Optional)
Type: Online System Int32
skipIfMore (Optional)
Type: Online System Boolean
addIfLess (Optional)
Type: Online System Boolean

Return Value

Type: Online IEnumerable Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online IEnumerable Online Char . When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
CSVParser Class
CSVParser Members
NFX.Serialization.CSV Namespace


CSVParser.CharIteratorWithStats Class

CSVParser CharIteratorWithStats Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Serialization.CSV CSVParser CharIteratorWithStats

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class CharIteratorWithStats : ILookAheadEnumerator<char>,
    IEnumerator<char>, IDisposable, IEnumerator
public sealed class CharIteratorWithStats : ILookAheadEnumerator<char>,
    IEnumerator<char>, IDisposable, IEnumerator
Public NotInheritable Class CharIteratorWithStats
    Implements ILookAheadEnumerator(Of Char), IEnumerator(Of Char),
    IDisposable, IEnumerator
Public NotInheritable Class CharIteratorWithStats
    Implements ILookAheadEnumerator(Of Char), IEnumerator(Of Char),
    IDisposable, IEnumerator
public ref class CharIteratorWithStats sealed : ILookAheadEnumerator<wchar_t>,
    IEnumerator<wchar_t>, IDisposable, IEnumerator
public ref class CharIteratorWithStats sealed : ILookAheadEnumerator<wchar_t>,
    IEnumerator<wchar_t>, IDisposable, IEnumerator
[<SealedAttribute>]
type CharIteratorWithStats =
    class
        interface ILookAheadEnumerator<char>
        interface IEnumerator<char>
        interface IDisposable
        interface IEnumerator
    end
[<SealedAttribute>]
type CharIteratorWithStats =
    class
        interface ILookAheadEnumerator<char>
        interface IEnumerator<char>
        interface IDisposable
        interface IEnumerator
    end
See Also
CSVParser CharIteratorWithStats Members
NFX.Serialization.CSV Namespace


CSVParser.CharIteratorWithStats Members

CSVParser CharIteratorWithStats Members NFX Class Library

The CSVParser CharIteratorWithStats type exposes the following members.
Constructors
 | Name | Description
Public method | CSVParser CharIteratorWithStats | Initializes a new instance of the CSVParser CharIteratorWithStats class
Back to Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the CSVParser CharIteratorWithStats
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MoveNext |
Public method | Reset |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Column |
Public property | Count |
Public property | Current |
Public property | DetectCount |
Public property | HasNext |
Public property | Line |
Public property | Next |
Public property | RequiredCount |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerator Current |
Back to Top
See Also
CSVParser CharIteratorWithStats Class
NFX.Serialization.CSV Namespace


CSVParser.CharIteratorWithStats Constructor

CSVParser CharIteratorWithStats Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CSVParser CharIteratorWithStats class

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CharIteratorWithStats(
    ILookAheadEnumerator<char> enumerator,
    int count = -1
)
public CharIteratorWithStats(
    ILookAheadEnumerator<char> enumerator,
    int count = -1
)
Public Sub New (
    enumerator As ILookAheadEnumerator(Of Char),
    Optional count As Integer = -1
)
Public Sub New (
    enumerator As ILookAheadEnumerator(Of Char),
    Optional count As Integer = -1
)
public:
CharIteratorWithStats(
    ILookAheadEnumerator<wchar_t>^ enumerator,
    int count = -1
)
public:
CharIteratorWithStats(
    ILookAheadEnumerator<wchar_t>^ enumerator,
    int count = -1
)
new :
        enumerator : ILookAheadEnumerator<char> *
        ?count : int
(* Defaults:
        let _count = defaultArg count -1
*)
-> CharIteratorWithStats
new :
        enumerator : ILookAheadEnumerator<char> *
        ?count : int
(* Defaults:
        let _count = defaultArg count -1
*)
-> CharIteratorWithStats

Parameters

enumerator
Type: NFX.Collections ILookAheadEnumerator Online Char
count (Optional)
Type: Online System Int32
See Also
CSVParser CharIteratorWithStats Class
CSVParser CharIteratorWithStats Members
NFX.Serialization.CSV Namespace


CSVParser.CharIteratorWithStats Methods

CSVParser CharIteratorWithStats Methods NFX Class Library

The CSVParser CharIteratorWithStats type exposes the following members.
Methods
 | Name | Description
Public method | Dispose |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | MoveNext |
Public method | Reset |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CSVParser CharIteratorWithStats Class
NFX.Serialization.CSV Namespace


CSVParser.CharIteratorWithStats.Dispose Method

CSVParser CharIteratorWithStats Dispose Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Releases all resources used by the CSVParser CharIteratorWithStats

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

Online IDisposable Dispose
See Also
CSVParser CharIteratorWithStats Class
CSVParser CharIteratorWithStats Members
NFX.Serialization.CSV Namespace


CSVParser.CharIteratorWithStats.MoveNext Method

CSVParser CharIteratorWithStats MoveNext Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool MoveNext()
public bool MoveNext()
Public Function MoveNext As Boolean
Public Function MoveNext As Boolean
public:
virtual bool MoveNext() sealed
public:
virtual bool MoveNext() sealed
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Type: Online Boolean

Implements

Online IEnumerator MoveNext
See Also
CSVParser CharIteratorWithStats Class
CSVParser CharIteratorWithStats Members
NFX.Serialization.CSV Namespace


CSVParser.CharIteratorWithStats.Reset Method

CSVParser CharIteratorWithStats Reset Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Reset()
public void Reset()
Public Sub Reset
Public Sub Reset
public:
virtual void Reset() sealed
public:
virtual void Reset() sealed
abstract Reset : unit -> unit
override Reset : unit -> unit
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

Online IEnumerator Reset
See Also
CSVParser CharIteratorWithStats Class
CSVParser CharIteratorWithStats Members
NFX.Serialization.CSV Namespace


CSVParser.CharIteratorWithStats Properties

CSVParser CharIteratorWithStats Properties NFX Class Library

The CSVParser CharIteratorWithStats type exposes the following members.
Properties
 | Name | Description
Public property | Column |
Public property | Count |
Public property | Current |
Public property | DetectCount |
Public property | HasNext |
Public property | Line |
Public property | Next |
Public property | RequiredCount |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerator Current |
Back to Top
See Also
CSVParser CharIteratorWithStats Class
NFX.Serialization.CSV Namespace


CSVParser.CharIteratorWithStats.IEnumerator.Current Property

CSVParser CharIteratorWithStats IEnumerator Current Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object IEnumerator.Current { get; }
Object IEnumerator.Current { get; }
Private ReadOnly Property Current As Object
    Implements IEnumerator.Current
    Get
Private ReadOnly Property Current As Object
    Implements IEnumerator.Current
    Get
private:
virtual property Object^ Current {
    Object^ get () sealed = IEnumerator::Current::get;
}
private:
virtual property Object^ Current {
    Object^ get () sealed = IEnumerator::Current::get;
}
private abstract Current : Object with get
private override Current : Object with get
private abstract Current : Object with get
private override Current : Object with get

Property Value

Type: Online Object

Implements

Online IEnumerator Current
See Also
CSVParser CharIteratorWithStats Class
CSVParser CharIteratorWithStats Members
NFX.Serialization.CSV Namespace


CSVParser.CharIteratorWithStats.Column Property

CSVParser CharIteratorWithStats Column Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Column { get; private set; }
public int Column { get; private set; }
Public Property Column As Integer
    Get
    Private Set
Public Property Column As Integer
    Get
    Private Set
public:
property int Column {
    int get ();
    private: void set (int value);
}
public:
property int Column {
    int get ();
    private: void set (int value);
}
member Column : int with get, private set
member Column : int with get, private set

Property Value

Type: Online Int32
See Also
CSVParser CharIteratorWithStats Class
CSVParser CharIteratorWithStats Members
NFX.Serialization.CSV Namespace


CSVParser.CharIteratorWithStats.Count Property

CSVParser CharIteratorWithStats Count Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; set; }
public int Count { get; set; }
Public Property Count As Integer
    Get
    Set
Public Property Count As Integer
    Get
    Set
public:
property int Count {
    int get ();
    void set (int value);
}
public:
property int Count {
    int get ();
    void set (int value);
}
member Count : int with get, set
member Count : int with get, set

Property Value

Type: Online Int32
See Also
CSVParser CharIteratorWithStats Class
CSVParser CharIteratorWithStats Members
NFX.Serialization.CSV Namespace


CSVParser.CharIteratorWithStats.Current Property

CSVParser CharIteratorWithStats Current Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char Current { get; }
public char Current { get; }
Public ReadOnly Property Current As Char
    Get
Public ReadOnly Property Current As Char
    Get
public:
virtual property wchar_t Current {
    wchar_t get () sealed;
}
public:
virtual property wchar_t Current {
    wchar_t get () sealed;
}
abstract Current : char with get
override Current : char with get
abstract Current : char with get
override Current : char with get

Property Value

Type: Online Char

Implements

Online IEnumerator T Current
See Also
CSVParser CharIteratorWithStats Class
CSVParser CharIteratorWithStats Members
NFX.Serialization.CSV Namespace


CSVParser.CharIteratorWithStats.DetectCount Property

CSVParser CharIteratorWithStats DetectCount Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool DetectCount { get; set; }
public bool DetectCount { get; set; }
Public Property DetectCount As Boolean
    Get
    Set
Public Property DetectCount As Boolean
    Get
    Set
public:
property bool DetectCount {
    bool get ();
    void set (bool value);
}
public:
property bool DetectCount {
    bool get ();
    void set (bool value);
}
member DetectCount : bool with get, set
member DetectCount : bool with get, set

Property Value

Type: Online Boolean
See Also
CSVParser CharIteratorWithStats Class
CSVParser CharIteratorWithStats Members
NFX.Serialization.CSV Namespace


CSVParser.CharIteratorWithStats.HasNext Property

CSVParser CharIteratorWithStats HasNext Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasNext { get; }
public bool HasNext { get; }
Public ReadOnly Property HasNext As Boolean
    Get
Public ReadOnly Property HasNext As Boolean
    Get
public:
virtual property bool HasNext {
    bool get () sealed;
}
public:
virtual property bool HasNext {
    bool get () sealed;
}
abstract HasNext : bool with get
override HasNext : bool with get
abstract HasNext : bool with get
override HasNext : bool with get

Property Value

Type: Online Boolean

Implements

ILookAheadEnumerator T HasNext
See Also
CSVParser CharIteratorWithStats Class
CSVParser CharIteratorWithStats Members
NFX.Serialization.CSV Namespace


CSVParser.CharIteratorWithStats.Line Property

CSVParser CharIteratorWithStats Line Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Line { get; private set; }
public int Line { get; private set; }
Public Property Line As Integer
    Get
    Private Set
Public Property Line As Integer
    Get
    Private Set
public:
property int Line {
    int get ();
    private: void set (int value);
}
public:
property int Line {
    int get ();
    private: void set (int value);
}
member Line : int with get, private set
member Line : int with get, private set

Property Value

Type: Online Int32
See Also
CSVParser CharIteratorWithStats Class
CSVParser CharIteratorWithStats Members
NFX.Serialization.CSV Namespace


CSVParser.CharIteratorWithStats.Next Property

CSVParser CharIteratorWithStats Next Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public char Next { get; }
public char Next { get; }
Public ReadOnly Property Next As Char
    Get
Public ReadOnly Property Next As Char
    Get
public:
virtual property wchar_t Next {
    wchar_t get () sealed;
}
public:
virtual property wchar_t Next {
    wchar_t get () sealed;
}
abstract Next : char with get
override Next : char with get
abstract Next : char with get
override Next : char with get

Property Value

Type: Online Char

Implements

ILookAheadEnumerator T Next
See Also
CSVParser CharIteratorWithStats Class
CSVParser CharIteratorWithStats Members
NFX.Serialization.CSV Namespace


CSVParser.CharIteratorWithStats.RequiredCount Property

CSVParser CharIteratorWithStats RequiredCount Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int RequiredCount { get; set; }
public int RequiredCount { get; set; }
Public Property RequiredCount As Integer
    Get
    Set
Public Property RequiredCount As Integer
    Get
    Set
public:
property int RequiredCount {
    int get ();
    void set (int value);
}
public:
property int RequiredCount {
    int get ();
    void set (int value);
}
member RequiredCount : int with get, set
member RequiredCount : int with get, set

Property Value

Type: Online Int32
See Also
CSVParser CharIteratorWithStats Class
CSVParser CharIteratorWithStats Members
NFX.Serialization.CSV Namespace


CSVParserException Class

CSVParserException Class NFX Class Library

Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Serialization.CSV CSVParserException

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class CSVParserException : NFXException
[SerializableAttribute]
public class CSVParserException : NFXException
<SerializableAttribute>
Public Class CSVParserException
    Inherits NFXException
<SerializableAttribute>
Public Class CSVParserException
    Inherits NFXException
[SerializableAttribute]
public ref class CSVParserException : public NFXException
[SerializableAttribute]
public ref class CSVParserException : public NFXException
[<SerializableAttribute>]
type CSVParserException =
    class
        inherit NFXException
    end
[<SerializableAttribute>]
type CSVParserException =
    class
        inherit NFXException
    end
See Also
CSVParserException Members
NFX.Serialization.CSV Namespace


CSVParserException Members

CSVParserException Members NFX Class Library

The CSVParserException type exposes the following members.
Constructors
 | Name | Description
Public method | CSVParserException(Int32, Int32) | Initializes a new instance of the CSVParserException class
Public method | CSVParserException(String, Int32, Int32) | Initializes a new instance of the CSVParserException class
Protected method | CSVParserException(SerializationInfo, StreamingContext, Int32, Int32) | Initializes a new instance of the CSVParserException class
Public method | CSVParserException(String, Exception, Int32, Int32) | Initializes a new instance of the CSVParserException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | Column |
Public field | Line |
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
CSVParserException Class
NFX.Serialization.CSV Namespace


CSVParserException Constructor

CSVParserException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | CSVParserException(Int32, Int32) | Initializes a new instance of the CSVParserException class
Public method | CSVParserException(String, Int32, Int32) | Initializes a new instance of the CSVParserException class
Protected method | CSVParserException(SerializationInfo, StreamingContext, Int32, Int32) | Initializes a new instance of the CSVParserException class
Public method | CSVParserException(String, Exception, Int32, Int32) | Initializes a new instance of the CSVParserException class
Back to Top
See Also
CSVParserException Class
CSVParserException Members
NFX.Serialization.CSV Namespace


CSVParserException Constructor (Int32, Int32)

CSVParserException Constructor (Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CSVParserException class

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CSVParserException(
    int line = -1,
    int column = -1
)
public CSVParserException(
    int line = -1,
    int column = -1
)
Public Sub New (
    Optional line As Integer = -1,
    Optional column As Integer = -1
)
Public Sub New (
    Optional line As Integer = -1,
    Optional column As Integer = -1
)
public:
CSVParserException(
    int line = -1,
    int column = -1
)
public:
CSVParserException(
    int line = -1,
    int column = -1
)
new :
        ?line : int *
        ?column : int
(* Defaults:
        let _line = defaultArg line -1
        let _column = defaultArg column -1
*)
-> CSVParserException
new :
        ?line : int *
        ?column : int
(* Defaults:
        let _line = defaultArg line -1
        let _column = defaultArg column -1
*)
-> CSVParserException

Parameters

line (Optional)
Type: Online System Int32
column (Optional)
Type: Online System Int32
See Also
CSVParserException Class
CSVParserException Members
CSVParserException Overload
NFX.Serialization.CSV Namespace


CSVParserException Constructor (String, Int32, Int32)

CSVParserException Constructor (String, Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CSVParserException class

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CSVParserException(
    string message,
    int line = -1,
    int column = -1
)
public CSVParserException(
    string message,
    int line = -1,
    int column = -1
)
Public Sub New (
    message As String,
    Optional line As Integer = -1,
    Optional column As Integer = -1
)
Public Sub New (
    message As String,
    Optional line As Integer = -1,
    Optional column As Integer = -1
)
public:
CSVParserException(
    String^ message,
    int line = -1,
    int column = -1
)
public:
CSVParserException(
    String^ message,
    int line = -1,
    int column = -1
)
new :
        message : string *
        ?line : int *
        ?column : int
(* Defaults:
        let _line = defaultArg line -1
        let _column = defaultArg column -1
*)
-> CSVParserException
new :
        message : string *
        ?line : int *
        ?column : int
(* Defaults:
        let _line = defaultArg line -1
        let _column = defaultArg column -1
*)
-> CSVParserException

Parameters

message
Type: Online System String
line (Optional)
Type: Online System Int32
column (Optional)
Type: Online System Int32
See Also
CSVParserException Class
CSVParserException Members
CSVParserException Overload
NFX.Serialization.CSV Namespace


CSVParserException Constructor (SerializationInfo, StreamingContext, Int32, Int32)

CSVParserException Constructor (SerializationInfo, StreamingContext, Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CSVParserException class

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CSVParserException(
    SerializationInfo info,
    StreamingContext context,
    int line = -1,
    int column = -1
)
protected CSVParserException(
    SerializationInfo info,
    StreamingContext context,
    int line = -1,
    int column = -1
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext,
    Optional line As Integer = -1,
    Optional column As Integer = -1
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext,
    Optional line As Integer = -1,
    Optional column As Integer = -1
)
protected:
CSVParserException(
    SerializationInfo^ info,
    StreamingContext context,
    int line = -1,
    int column = -1
)
protected:
CSVParserException(
    SerializationInfo^ info,
    StreamingContext context,
    int line = -1,
    int column = -1
)
new :
        info : SerializationInfo *
        context : StreamingContext *
        ?line : int *
        ?column : int
(* Defaults:
        let _line = defaultArg line -1
        let _column = defaultArg column -1
*)
-> CSVParserException
new :
        info : SerializationInfo *
        context : StreamingContext *
        ?line : int *
        ?column : int
(* Defaults:
        let _line = defaultArg line -1
        let _column = defaultArg column -1
*)
-> CSVParserException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
line (Optional)
Type: Online System Int32
column (Optional)
Type: Online System Int32
See Also
CSVParserException Class
CSVParserException Members
CSVParserException Overload
NFX.Serialization.CSV Namespace


CSVParserException Constructor (String, Exception, Int32, Int32)

CSVParserException Constructor (String, Exception, Int32, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CSVParserException class

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CSVParserException(
    string message,
    Exception inner,
    int line = -1,
    int column = -1
)
public CSVParserException(
    string message,
    Exception inner,
    int line = -1,
    int column = -1
)
Public Sub New (
    message As String,
    inner As Exception,
    Optional line As Integer = -1,
    Optional column As Integer = -1
)
Public Sub New (
    message As String,
    inner As Exception,
    Optional line As Integer = -1,
    Optional column As Integer = -1
)
public:
CSVParserException(
    String^ message,
    Exception^ inner,
    int line = -1,
    int column = -1
)
public:
CSVParserException(
    String^ message,
    Exception^ inner,
    int line = -1,
    int column = -1
)
new :
        message : string *
        inner : Exception *
        ?line : int *
        ?column : int
(* Defaults:
        let _line = defaultArg line -1
        let _column = defaultArg column -1
*)
-> CSVParserException
new :
        message : string *
        inner : Exception *
        ?line : int *
        ?column : int
(* Defaults:
        let _line = defaultArg line -1
        let _column = defaultArg column -1
*)
-> CSVParserException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
line (Optional)
Type: Online System Int32
column (Optional)
Type: Online System Int32
See Also
CSVParserException Class
CSVParserException Members
CSVParserException Overload
NFX.Serialization.CSV Namespace


CSVParserException Fields

CSVParserException Fields NFX Class Library

The CSVParserException type exposes the following members.
Fields
 | Name | Description
Public field | Column |
Public field | Line |
Back to Top
See Also
CSVParserException Class
NFX.Serialization.CSV Namespace


CSVParserException.Column Field

CSVParserException Column Field NFX Class Library

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Column
public readonly int Column
Public ReadOnly Column As Integer
Public ReadOnly Column As Integer
public:
initonly int Column
public:
initonly int Column
val Column: int
val Column: int

Field Value

Type: Online Int32
See Also
CSVParserException Class
CSVParserException Members
NFX.Serialization.CSV Namespace


CSVParserException.Line Field

CSVParserException Line Field NFX Class Library

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int Line
public readonly int Line
Public ReadOnly Line As Integer
Public ReadOnly Line As Integer
public:
initonly int Line
public:
initonly int Line
val Line: int
val Line: int

Field Value

Type: Online Int32
See Also
CSVParserException Class
CSVParserException Members
NFX.Serialization.CSV Namespace


CSVParserException Methods

CSVParserException Methods NFX Class Library

The CSVParserException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
CSVParserException Class
NFX.Serialization.CSV Namespace


CSVParserException Properties

CSVParserException Properties NFX Class Library

The CSVParserException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
CSVParserException Class
NFX.Serialization.CSV Namespace


CSVParserException Events

CSVParserException Events NFX Class Library

The CSVParserException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
CSVParserException Class
NFX.Serialization.CSV Namespace


CSVWriter Class

CSVWriter Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Serialization.CSV CSVWriter

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class CSVWriter
public static class CSVWriter
Public NotInheritable Class CSVWriter
Public NotInheritable Class CSVWriter
public ref class CSVWriter abstract sealed
public ref class CSVWriter abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CSVWriter =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CSVWriter =  class end
See Also
CSVWriter Members
NFX.Serialization.CSV Namespace


CSVWriter Members

CSVWriter Members NFX Class Library

Methods
Name | Description
Write(Row, CSVWritingOptions, FieldFilterFunc) |
Write(RowsetBase, CSVWritingOptions, FieldFilterFunc) |
Write(Row, TextWriter, CSVWritingOptions, FieldFilterFunc) |
Write(RowsetBase, TextWriter, CSVWritingOptions, FieldFilterFunc) |
Write(Row, Stream, CSVWritingOptions, Encoding, FieldFilterFunc) |
Write(RowsetBase, Stream, CSVWritingOptions, Encoding, FieldFilterFunc) |
WriteToBuffer(Row, CSVWritingOptions, Encoding, FieldFilterFunc) |
WriteToBuffer(RowsetBase, CSVWritingOptions, Encoding, FieldFilterFunc) |
WriteToFile(Row, String, CSVWritingOptions, Encoding, FieldFilterFunc) |
WriteToFile(RowsetBase, String, CSVWritingOptions, Encoding, FieldFilterFunc) |
Back to Top
See Also
CSVWriter Class
NFX.Serialization.CSV Namespace


CSVWriter Methods

CSVWriter Methods NFX Class Library

Methods
Name | Description
Write(Row, CSVWritingOptions, FieldFilterFunc) |
Write(RowsetBase, CSVWritingOptions, FieldFilterFunc) |
Write(Row, TextWriter, CSVWritingOptions, FieldFilterFunc) |
Write(RowsetBase, TextWriter, CSVWritingOptions, FieldFilterFunc) |
Write(Row, Stream, CSVWritingOptions, Encoding, FieldFilterFunc) |
Write(RowsetBase, Stream, CSVWritingOptions, Encoding, FieldFilterFunc) |
WriteToBuffer(Row, CSVWritingOptions, Encoding, FieldFilterFunc) |
WriteToBuffer(RowsetBase, CSVWritingOptions, Encoding, FieldFilterFunc) |
WriteToFile(Row, String, CSVWritingOptions, Encoding, FieldFilterFunc) |
WriteToFile(RowsetBase, String, CSVWritingOptions, Encoding, FieldFilterFunc) |
Back to Top
See Also
CSVWriter Class
NFX.Serialization.CSV Namespace


CSVWriter.Write Method

CSVWriter Write Method NFX Class Library

Overload List
Name | Description
Write(Row, CSVWritingOptions, FieldFilterFunc) |
Write(RowsetBase, CSVWritingOptions, FieldFilterFunc) |
Write(Row, TextWriter, CSVWritingOptions, FieldFilterFunc) |
Write(RowsetBase, TextWriter, CSVWritingOptions, FieldFilterFunc) |
Write(Row, Stream, CSVWritingOptions, Encoding, FieldFilterFunc) |
Write(RowsetBase, Stream, CSVWritingOptions, Encoding, FieldFilterFunc) |
Back to Top
See Also
CSVWriter Class
CSVWriter Members
NFX.Serialization.CSV Namespace


CSVWriter.Write Method (Row, CSVWritingOptions, FieldFilterFunc)

CSVWriter Write Method (Row, CSVWritingOptions, FieldFilterFunc) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Write(
    Row row,
    CSVWritingOptions options = null,
    FieldFilterFunc filter = null
)
public static string Write(
    Row row,
    CSVWritingOptions options = null,
    FieldFilterFunc filter = null
)
Public Shared Function Write (
    row As Row,
    Optional options As CSVWritingOptions = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As String
Public Shared Function Write (
    row As Row,
    Optional options As CSVWritingOptions = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As String
public:
static String^ Write(
    Row^ row,
    CSVWritingOptions^ options = nullptr,
    FieldFilterFunc^ filter = nullptr
)
public:
static String^ Write(
    Row^ row,
    CSVWritingOptions^ options = nullptr,
    FieldFilterFunc^ filter = nullptr
)
static member Write :
        row : Row *
        ?options : CSVWritingOptions *
        ?filter : FieldFilterFunc
(* Defaults:
        let _options = defaultArg options null
        let _filter = defaultArg filter null
*)
-> string
static member Write :
        row : Row *
        ?options : CSVWritingOptions *
        ?filter : FieldFilterFunc
(* Defaults:
        let _options = defaultArg options null
        let _filter = defaultArg filter null
*)
-> string

Parameters

row
Type: NFX.DataAccess.CRUD Row
options (Optional)
Type: NFX.Serialization.CSV CSVWritingOptions
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online String
See Also
CSVWriter Class
CSVWriter Members
Write Overload
NFX.Serialization.CSV Namespace


CSVWriter.Write Method (RowsetBase, CSVWritingOptions, FieldFilterFunc)

CSVWriter Write Method (RowsetBase, CSVWritingOptions, FieldFilterFunc) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Write(
    RowsetBase rowset,
    CSVWritingOptions options = null,
    FieldFilterFunc filter = null
)
public static string Write(
    RowsetBase rowset,
    CSVWritingOptions options = null,
    FieldFilterFunc filter = null
)
Public Shared Function Write (
    rowset As RowsetBase,
    Optional options As CSVWritingOptions = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As String
Public Shared Function Write (
    rowset As RowsetBase,
    Optional options As CSVWritingOptions = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As String
public:
static String^ Write(
    RowsetBase^ rowset,
    CSVWritingOptions^ options = nullptr,
    FieldFilterFunc^ filter = nullptr
)
public:
static String^ Write(
    RowsetBase^ rowset,
    CSVWritingOptions^ options = nullptr,
    FieldFilterFunc^ filter = nullptr
)
static member Write :
        rowset : RowsetBase *
        ?options : CSVWritingOptions *
        ?filter : FieldFilterFunc
(* Defaults:
        let _options = defaultArg options null
        let _filter = defaultArg filter null
*)
-> string
static member Write :
        rowset : RowsetBase *
        ?options : CSVWritingOptions *
        ?filter : FieldFilterFunc
(* Defaults:
        let _options = defaultArg options null
        let _filter = defaultArg filter null
*)
-> string

Parameters

rowset
Type: NFX.DataAccess.CRUD RowsetBase
options (Optional)
Type: NFX.Serialization.CSV CSVWritingOptions
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online String
See Also
CSVWriter Class
CSVWriter Members
Write Overload
NFX.Serialization.CSV Namespace


CSVWriter.Write Method (Row, TextWriter, CSVWritingOptions, FieldFilterFunc)

CSVWriter Write Method (Row, TextWriter, CSVWritingOptions, FieldFilterFunc) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    Row row,
    TextWriter wri,
    CSVWritingOptions options = null,
    FieldFilterFunc filter = null
)
public static void Write(
    Row row,
    TextWriter wri,
    CSVWritingOptions options = null,
    FieldFilterFunc filter = null
)
Public Shared Sub Write (
    row As Row,
    wri As TextWriter,
    Optional options As CSVWritingOptions = Nothing,
    Optional filter As FieldFilterFunc = Nothing
)
Public Shared Sub Write (
    row As Row,
    wri As TextWriter,
    Optional options As CSVWritingOptions = Nothing,
    Optional filter As FieldFilterFunc = Nothing
)
public:
static void Write(
    Row^ row,
    TextWriter^ wri,
    CSVWritingOptions^ options = nullptr,
    FieldFilterFunc^ filter = nullptr
)
public:
static void Write(
    Row^ row,
    TextWriter^ wri,
    CSVWritingOptions^ options = nullptr,
    FieldFilterFunc^ filter = nullptr
)
static member Write :
        row : Row *
        wri : TextWriter *
        ?options : CSVWritingOptions *
        ?filter : FieldFilterFunc
(* Defaults:
        let _options = defaultArg options null
        let _filter = defaultArg filter null
*)
-> unit
static member Write :
        row : Row *
        wri : TextWriter *
        ?options : CSVWritingOptions *
        ?filter : FieldFilterFunc
(* Defaults:
        let _options = defaultArg options null
        let _filter = defaultArg filter null
*)
-> unit

Parameters

row
Type: NFX.DataAccess.CRUD Row
wri
Type: Online System.IO TextWriter
options (Optional)
Type: NFX.Serialization.CSV CSVWritingOptions
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc
See Also
CSVWriter Class
CSVWriter Members
Write Overload
NFX.Serialization.CSV Namespace


CSVWriter.Write Method (RowsetBase, TextWriter, CSVWritingOptions, FieldFilterFunc)

CSVWriter Write Method (RowsetBase, TextWriter, CSVWritingOptions, FieldFilterFunc) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    RowsetBase rowset,
    TextWriter wri,
    CSVWritingOptions options = null,
    FieldFilterFunc filter = null
)
public static void Write(
    RowsetBase rowset,
    TextWriter wri,
    CSVWritingOptions options = null,
    FieldFilterFunc filter = null
)
Public Shared Sub Write (
    rowset As RowsetBase,
    wri As TextWriter,
    Optional options As CSVWritingOptions = Nothing,
    Optional filter As FieldFilterFunc = Nothing
)
Public Shared Sub Write (
    rowset As RowsetBase,
    wri As TextWriter,
    Optional options As CSVWritingOptions = Nothing,
    Optional filter As FieldFilterFunc = Nothing
)
public:
static void Write(
    RowsetBase^ rowset,
    TextWriter^ wri,
    CSVWritingOptions^ options = nullptr,
    FieldFilterFunc^ filter = nullptr
)
public:
static void Write(
    RowsetBase^ rowset,
    TextWriter^ wri,
    CSVWritingOptions^ options = nullptr,
    FieldFilterFunc^ filter = nullptr
)
static member Write :
        rowset : RowsetBase *
        wri : TextWriter *
        ?options : CSVWritingOptions *
        ?filter : FieldFilterFunc
(* Defaults:
        let _options = defaultArg options null
        let _filter = defaultArg filter null
*)
-> unit
static member Write :
        rowset : RowsetBase *
        wri : TextWriter *
        ?options : CSVWritingOptions *
        ?filter : FieldFilterFunc
(* Defaults:
        let _options = defaultArg options null
        let _filter = defaultArg filter null
*)
-> unit

Parameters

rowset
Type: NFX.DataAccess.CRUD RowsetBase
wri
Type: Online System.IO TextWriter
options (Optional)
Type: NFX.Serialization.CSV CSVWritingOptions
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc
See Also
CSVWriter Class
CSVWriter Members
Write Overload
NFX.Serialization.CSV Namespace


CSVWriter.Write Method (Row, Stream, CSVWritingOptions, Encoding, FieldFilterFunc)

CSVWriter Write Method (Row, Stream, CSVWritingOptions, Encoding, FieldFilterFunc) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    Row row,
    Stream stream,
    CSVWritingOptions options = null,
    Encoding encoding = null,
    FieldFilterFunc filter = null
)
public static void Write(
    Row row,
    Stream stream,
    CSVWritingOptions options = null,
    Encoding encoding = null,
    FieldFilterFunc filter = null
)
Public Shared Sub Write (
    row As Row,
    stream As Stream,
    Optional options As CSVWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing,
    Optional filter As FieldFilterFunc = Nothing
)
Public Shared Sub Write (
    row As Row,
    stream As Stream,
    Optional options As CSVWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing,
    Optional filter As FieldFilterFunc = Nothing
)
public:
static void Write(
    Row^ row,
    Stream^ stream,
    CSVWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr,
    FieldFilterFunc^ filter = nullptr
)
public:
static void Write(
    Row^ row,
    Stream^ stream,
    CSVWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr,
    FieldFilterFunc^ filter = nullptr
)
static member Write :
        row : Row *
        stream : Stream *
        ?options : CSVWritingOptions *
        ?encoding : Encoding *
        ?filter : FieldFilterFunc
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
        let _filter = defaultArg filter null
*)
-> unit
static member Write :
        row : Row *
        stream : Stream *
        ?options : CSVWritingOptions *
        ?encoding : Encoding *
        ?filter : FieldFilterFunc
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
        let _filter = defaultArg filter null
*)
-> unit

Parameters

row
Type: NFX.DataAccess.CRUD Row
stream
Type: Online System.IO Stream
options (Optional)
Type: NFX.Serialization.CSV CSVWritingOptions
encoding (Optional)
Type: Online System.Text Encoding
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc
See Also
CSVWriter Class
CSVWriter Members
Write Overload
NFX.Serialization.CSV Namespace


CSVWriter.Write Method (RowsetBase, Stream, CSVWritingOptions, Encoding, FieldFilterFunc)

CSVWriter Write Method (RowsetBase, Stream, CSVWritingOptions, Encoding, FieldFilterFunc) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    RowsetBase rowset,
    Stream stream,
    CSVWritingOptions options = null,
    Encoding encoding = null,
    FieldFilterFunc filter = null
)
public static void Write(
    RowsetBase rowset,
    Stream stream,
    CSVWritingOptions options = null,
    Encoding encoding = null,
    FieldFilterFunc filter = null
)
Public Shared Sub Write (
    rowset As RowsetBase,
    stream As Stream,
    Optional options As CSVWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing,
    Optional filter As FieldFilterFunc = Nothing
)
Public Shared Sub Write (
    rowset As RowsetBase,
    stream As Stream,
    Optional options As CSVWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing,
    Optional filter As FieldFilterFunc = Nothing
)
public:
static void Write(
    RowsetBase^ rowset,
    Stream^ stream,
    CSVWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr,
    FieldFilterFunc^ filter = nullptr
)
public:
static void Write(
    RowsetBase^ rowset,
    Stream^ stream,
    CSVWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr,
    FieldFilterFunc^ filter = nullptr
)
static member Write :
        rowset : RowsetBase *
        stream : Stream *
        ?options : CSVWritingOptions *
        ?encoding : Encoding *
        ?filter : FieldFilterFunc
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
        let _filter = defaultArg filter null
*)
-> unit
static member Write :
        rowset : RowsetBase *
        stream : Stream *
        ?options : CSVWritingOptions *
        ?encoding : Encoding *
        ?filter : FieldFilterFunc
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
        let _filter = defaultArg filter null
*)
-> unit

Parameters

rowset
Type: NFX.DataAccess.CRUD RowsetBase
stream
Type: Online System.IO Stream
options (Optional)
Type: NFX.Serialization.CSV CSVWritingOptions
encoding (Optional)
Type: Online System.Text Encoding
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc
See Also
CSVWriter Class
CSVWriter Members
Write Overload
NFX.Serialization.CSV Namespace


CSVWriter.WriteToBuffer Method

CSVWriter WriteToBuffer Method NFX Class Library

Overload List
Name | Description
WriteToBuffer(Row, CSVWritingOptions, Encoding, FieldFilterFunc) |
WriteToBuffer(RowsetBase, CSVWritingOptions, Encoding, FieldFilterFunc) |
Back to Top
See Also
CSVWriter Class
CSVWriter Members
NFX.Serialization.CSV Namespace


CSVWriter.WriteToBuffer Method (Row, CSVWritingOptions, Encoding, FieldFilterFunc)

CSVWriter WriteToBuffer Method (Row, CSVWritingOptions, Encoding, FieldFilterFunc) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte[] WriteToBuffer(
    Row row,
    CSVWritingOptions options = null,
    Encoding encoding = null,
    FieldFilterFunc filter = null
)
public static byte[] WriteToBuffer(
    Row row,
    CSVWritingOptions options = null,
    Encoding encoding = null,
    FieldFilterFunc filter = null
)
Public Shared Function WriteToBuffer (
    row As Row,
    Optional options As CSVWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Byte()
Public Shared Function WriteToBuffer (
    row As Row,
    Optional options As CSVWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Byte()
public:
static array<unsigned char>^ WriteToBuffer(
    Row^ row,
    CSVWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr,
    FieldFilterFunc^ filter = nullptr
)
public:
static array<unsigned char>^ WriteToBuffer(
    Row^ row,
    CSVWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr,
    FieldFilterFunc^ filter = nullptr
)
static member WriteToBuffer :
        row : Row *
        ?options : CSVWritingOptions *
        ?encoding : Encoding *
        ?filter : FieldFilterFunc
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
        let _filter = defaultArg filter null
*)
-> byte[]
static member WriteToBuffer :
        row : Row *
        ?options : CSVWritingOptions *
        ?encoding : Encoding *
        ?filter : FieldFilterFunc
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
        let _filter = defaultArg filter null
*)
-> byte[]

Parameters

row
Type: NFX.DataAccess.CRUD Row
options (Optional)
Type: NFX.Serialization.CSV CSVWritingOptions
encoding (Optional)
Type: Online System.Text Encoding
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Byte
See Also
CSVWriter Class
CSVWriter Members
WriteToBuffer Overload
NFX.Serialization.CSV Namespace


CSVWriter.WriteToBuffer Method (RowsetBase, CSVWritingOptions, Encoding, FieldFilterFunc)

CSVWriter WriteToBuffer Method (RowsetBase, CSVWritingOptions, Encoding, FieldFilterFunc) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte[] WriteToBuffer(
    RowsetBase rowset,
    CSVWritingOptions options = null,
    Encoding encoding = null,
    FieldFilterFunc filter = null
)
public static byte[] WriteToBuffer(
    RowsetBase rowset,
    CSVWritingOptions options = null,
    Encoding encoding = null,
    FieldFilterFunc filter = null
)
Public Shared Function WriteToBuffer (
    rowset As RowsetBase,
    Optional options As CSVWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Byte()
Public Shared Function WriteToBuffer (
    rowset As RowsetBase,
    Optional options As CSVWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing,
    Optional filter As FieldFilterFunc = Nothing
) As Byte()
public:
static array<unsigned char>^ WriteToBuffer(
    RowsetBase^ rowset,
    CSVWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr,
    FieldFilterFunc^ filter = nullptr
)
public:
static array<unsigned char>^ WriteToBuffer(
    RowsetBase^ rowset,
    CSVWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr,
    FieldFilterFunc^ filter = nullptr
)
static member WriteToBuffer :
        rowset : RowsetBase *
        ?options : CSVWritingOptions *
        ?encoding : Encoding *
        ?filter : FieldFilterFunc
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
        let _filter = defaultArg filter null
*)
-> byte[]
static member WriteToBuffer :
        rowset : RowsetBase *
        ?options : CSVWritingOptions *
        ?encoding : Encoding *
        ?filter : FieldFilterFunc
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
        let _filter = defaultArg filter null
*)
-> byte[]

Parameters

rowset
Type: NFX.DataAccess.CRUD RowsetBase
options (Optional)
Type: NFX.Serialization.CSV CSVWritingOptions
encoding (Optional)
Type: Online System.Text Encoding
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc

Return Value

Type: Online Byte
See Also
CSVWriter Class
CSVWriter Members
WriteToBuffer Overload
NFX.Serialization.CSV Namespace


CSVWriter.WriteToFile Method

CSVWriter WriteToFile Method NFX Class Library

Overload List
Name | Description
WriteToFile(Row, String, CSVWritingOptions, Encoding, FieldFilterFunc) |
WriteToFile(RowsetBase, String, CSVWritingOptions, Encoding, FieldFilterFunc) |
Back to Top
See Also
CSVWriter Class
CSVWriter Members
NFX.Serialization.CSV Namespace


CSVWriter.WriteToFile Method (Row, String, CSVWritingOptions, Encoding, FieldFilterFunc)

CSVWriter WriteToFile Method (Row, String, CSVWritingOptions, Encoding, FieldFilterFunc) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteToFile(
    Row row,
    string fileName,
    CSVWritingOptions options = null,
    Encoding encoding = null,
    FieldFilterFunc filter = null
)
public static void WriteToFile(
    Row row,
    string fileName,
    CSVWritingOptions options = null,
    Encoding encoding = null,
    FieldFilterFunc filter = null
)
Public Shared Sub WriteToFile (
    row As Row,
    fileName As String,
    Optional options As CSVWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing,
    Optional filter As FieldFilterFunc = Nothing
)
Public Shared Sub WriteToFile (
    row As Row,
    fileName As String,
    Optional options As CSVWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing,
    Optional filter As FieldFilterFunc = Nothing
)
public:
static void WriteToFile(
    Row^ row,
    String^ fileName,
    CSVWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr,
    FieldFilterFunc^ filter = nullptr
)
public:
static void WriteToFile(
    Row^ row,
    String^ fileName,
    CSVWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr,
    FieldFilterFunc^ filter = nullptr
)
static member WriteToFile :
        row : Row *
        fileName : string *
        ?options : CSVWritingOptions *
        ?encoding : Encoding *
        ?filter : FieldFilterFunc
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
        let _filter = defaultArg filter null
*)
-> unit
static member WriteToFile :
        row : Row *
        fileName : string *
        ?options : CSVWritingOptions *
        ?encoding : Encoding *
        ?filter : FieldFilterFunc
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
        let _filter = defaultArg filter null
*)
-> unit

Parameters

row
Type: NFX.DataAccess.CRUD Row
fileName
Type: Online System String
options (Optional)
Type: NFX.Serialization.CSV CSVWritingOptions
encoding (Optional)
Type: Online System.Text Encoding
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc
See Also
CSVWriter Class
CSVWriter Members
WriteToFile Overload
NFX.Serialization.CSV Namespace


CSVWriter.WriteToFile Method (RowsetBase, String, CSVWritingOptions, Encoding, FieldFilterFunc)

CSVWriter WriteToFile Method (RowsetBase, String, CSVWritingOptions, Encoding, FieldFilterFunc) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteToFile(
    RowsetBase rowset,
    string fileName,
    CSVWritingOptions options = null,
    Encoding encoding = null,
    FieldFilterFunc filter = null
)
public static void WriteToFile(
    RowsetBase rowset,
    string fileName,
    CSVWritingOptions options = null,
    Encoding encoding = null,
    FieldFilterFunc filter = null
)
Public Shared Sub WriteToFile (
    rowset As RowsetBase,
    fileName As String,
    Optional options As CSVWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing,
    Optional filter As FieldFilterFunc = Nothing
)
Public Shared Sub WriteToFile (
    rowset As RowsetBase,
    fileName As String,
    Optional options As CSVWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing,
    Optional filter As FieldFilterFunc = Nothing
)
public:
static void WriteToFile(
    RowsetBase^ rowset,
    String^ fileName,
    CSVWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr,
    FieldFilterFunc^ filter = nullptr
)
public:
static void WriteToFile(
    RowsetBase^ rowset,
    String^ fileName,
    CSVWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr,
    FieldFilterFunc^ filter = nullptr
)
static member WriteToFile :
        rowset : RowsetBase *
        fileName : string *
        ?options : CSVWritingOptions *
        ?encoding : Encoding *
        ?filter : FieldFilterFunc
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
        let _filter = defaultArg filter null
*)
-> unit
static member WriteToFile :
        rowset : RowsetBase *
        fileName : string *
        ?options : CSVWritingOptions *
        ?encoding : Encoding *
        ?filter : FieldFilterFunc
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
        let _filter = defaultArg filter null
*)
-> unit

Parameters

rowset
Type: NFX.DataAccess.CRUD RowsetBase
fileName
Type: Online System String
options (Optional)
Type: NFX.Serialization.CSV CSVWritingOptions
encoding (Optional)
Type: Online System.Text Encoding
filter (Optional)
Type: NFX.DataAccess.CRUD FieldFilterFunc
See Also
CSVWriter Class
CSVWriter Members
WriteToFile Overload
NFX.Serialization.CSV Namespace


CSVWritingOptions Class

CSVWritingOptions Class NFX Class Library

Specifies how row should be written in CSV. Use CSVWritingOptions.Default static property for typical options
Inheritance Hierarchy
Online System Object
NFX.Serialization.CSV CSVWritingOptions

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CSVWritingOptions : IConfigurable
public class CSVWritingOptions : IConfigurable
Public Class CSVWritingOptions
    Implements IConfigurable
Public Class CSVWritingOptions
    Implements IConfigurable
public ref class CSVWritingOptions : IConfigurable
public ref class CSVWritingOptions : IConfigurable
type CSVWritingOptions =
    class
        interface IConfigurable
    end
type CSVWritingOptions =
    class
        interface IConfigurable
    end
See Also
CSVWritingOptions Members
NFX.Serialization.CSV Namespace


CSVWritingOptions Members

CSVWritingOptions Members NFX Class Library

The CSVWritingOptions type exposes the following members.
Constructors
 | Name | Description
Public method | CSVWritingOptions | Initializes a new instance of the CSVWritingOptions class
Public method | CSVWritingOptions(CSVWritingOptions) | Initializes a new instance of the CSVWritingOptions class
Back to Top
Methods
 | Name | Description
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | FieldDelimiter | Specifies field delimiter, comma is default
Public field | IncludeHeader | Indicates if field names must be included in result
Public field | LoadAllFields | Indicates if nonUI/non-stored fields must be loaded
Public field | NullValue | Specifies string that will be used for null values
Back to Top
Properties
Name | Description
AllFields | Writes all fields with comma as field delimiter, empty string for null values, including field names
Default | Writes CSV with comma as field delimiter, empty string for null values, skipping nonUI/non-stored fields, including field names
NoHeader | Writes CSV with comma as field delimiter, empty string for null values, skipping nonUI/non-stored fields, but without field names
Back to Top
See Also
CSVWritingOptions Class
NFX.Serialization.CSV Namespace


CSVWritingOptions Constructor

CSVWritingOptions Constructor NFX Class Library

Overload List
 | Name | Description
Public method | CSVWritingOptions | Initializes a new instance of the CSVWritingOptions class
Public method | CSVWritingOptions(CSVWritingOptions) | Initializes a new instance of the CSVWritingOptions class
Back to Top
See Also
CSVWritingOptions Class
CSVWritingOptions Members
NFX.Serialization.CSV Namespace


CSVWritingOptions Constructor

CSVWritingOptions Constructor NFX Class Library

Initializes a new instance of the CSVWritingOptions class

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CSVWritingOptions()
public CSVWritingOptions()
Public Sub New
Public Sub New
public:
CSVWritingOptions()
public:
CSVWritingOptions()
new : unit -> CSVWritingOptions
new : unit -> CSVWritingOptions
See Also
CSVWritingOptions Class
CSVWritingOptions Members
CSVWritingOptions Overload
NFX.Serialization.CSV Namespace


CSVWritingOptions Constructor (CSVWritingOptions)

CSVWritingOptions Constructor (CSVWritingOptions) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CSVWritingOptions class

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CSVWritingOptions(
    CSVWritingOptions other
)
public CSVWritingOptions(
    CSVWritingOptions other
)
Public Sub New (
    other As CSVWritingOptions
)
Public Sub New (
    other As CSVWritingOptions
)
public:
CSVWritingOptions(
    CSVWritingOptions^ other
)
public:
CSVWritingOptions(
    CSVWritingOptions^ other
)
new :
        other : CSVWritingOptions -> CSVWritingOptions
new :
        other : CSVWritingOptions -> CSVWritingOptions

Parameters

other
Type: NFX.Serialization.CSV CSVWritingOptions
See Also
CSVWritingOptions Class
CSVWritingOptions Members
CSVWritingOptions Overload
NFX.Serialization.CSV Namespace


CSVWritingOptions Fields

CSVWritingOptions Fields NFX Class Library

The CSVWritingOptions type exposes the following members.
Fields
 | Name | Description
Public field | FieldDelimiter | Specifies field delimiter, comma is default
Public field | IncludeHeader | Indicates if field names must be included in result
Public field | LoadAllFields | Indicates if nonUI/non-stored fields must be loaded
Public field | NullValue | Specifies string that will be used for null values
Back to Top
See Also
CSVWritingOptions Class
NFX.Serialization.CSV Namespace


CSVWritingOptions.FieldDelimiter Field

CSVWritingOptions FieldDelimiter Field NFX Class Library

Specifies field delimiter, comma is default

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public char FieldDelimiter
[ConfigAttribute]
public char FieldDelimiter
<ConfigAttribute>
Public FieldDelimiter As Char
<ConfigAttribute>
Public FieldDelimiter As Char
public:
[ConfigAttribute]
wchar_t FieldDelimiter
public:
[ConfigAttribute]
wchar_t FieldDelimiter
[<ConfigAttribute>]
val mutable FieldDelimiter: char
[<ConfigAttribute>]
val mutable FieldDelimiter: char

Field Value

Type: Online Char
See Also
CSVWritingOptions Class
CSVWritingOptions Members
NFX.Serialization.CSV Namespace


CSVWritingOptions.IncludeHeader Field

CSVWritingOptions IncludeHeader Field NFX Class Library

Indicates if field names must be included in result

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool IncludeHeader
[ConfigAttribute]
public bool IncludeHeader
<ConfigAttribute>
Public IncludeHeader As Boolean
<ConfigAttribute>
Public IncludeHeader As Boolean
public:
[ConfigAttribute]
bool IncludeHeader
public:
[ConfigAttribute]
bool IncludeHeader
[<ConfigAttribute>]
val mutable IncludeHeader: bool
[<ConfigAttribute>]
val mutable IncludeHeader: bool

Field Value

Type: Online Boolean
See Also
CSVWritingOptions Class
CSVWritingOptions Members
NFX.Serialization.CSV Namespace


CSVWritingOptions.LoadAllFields Field

CSVWritingOptions LoadAllFields Field NFX Class Library

Indicates if nonUI/non-stored fields must be loaded

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool LoadAllFields
[ConfigAttribute]
public bool LoadAllFields
<ConfigAttribute>
Public LoadAllFields As Boolean
<ConfigAttribute>
Public LoadAllFields As Boolean
public:
[ConfigAttribute]
bool LoadAllFields
public:
[ConfigAttribute]
bool LoadAllFields
[<ConfigAttribute>]
val mutable LoadAllFields: bool
[<ConfigAttribute>]
val mutable LoadAllFields: bool

Field Value

Type: Online Boolean
See Also
CSVWritingOptions Class
CSVWritingOptions Members
NFX.Serialization.CSV Namespace


CSVWritingOptions.NullValue Field

CSVWritingOptions NullValue Field NFX Class Library

Specifies string that will be used for null values

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string NullValue
[ConfigAttribute]
public string NullValue
<ConfigAttribute>
Public NullValue As String
<ConfigAttribute>
Public NullValue As String
public:
[ConfigAttribute]
String^ NullValue
public:
[ConfigAttribute]
String^ NullValue
[<ConfigAttribute>]
val mutable NullValue: string
[<ConfigAttribute>]
val mutable NullValue: string

Field Value

Type: Online String
See Also
CSVWritingOptions Class
CSVWritingOptions Members
NFX.Serialization.CSV Namespace


CSVWritingOptions Methods

CSVWritingOptions Methods NFX Class Library

The CSVWritingOptions type exposes the following members.
Methods
 | Name | Description
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CSVWritingOptions Class
NFX.Serialization.CSV Namespace


CSVWritingOptions.Configure Method

CSVWritingOptions Configure Method NFX Class Library

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode node
)
public void Configure(
    IConfigSectionNode node
)
Public Sub Configure (
    node As IConfigSectionNode
)
Public Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
CSVWritingOptions Class
CSVWritingOptions Members
NFX.Serialization.CSV Namespace


CSVWritingOptions Properties

CSVWritingOptions Properties NFX Class Library

The CSVWritingOptions type exposes the following members.
Properties
Name | Description
AllFields | Writes all fields with comma as field delimiter, empty string for null values, including field names
Default | Writes CSV with comma as field delimiter, empty string for null values, skipping nonUI/non-stored fields, including field names
NoHeader | Writes CSV with comma as field delimiter, empty string for null values, skipping nonUI/non-stored fields, but without field names
Back to Top
See Also
CSVWritingOptions Class
NFX.Serialization.CSV Namespace


CSVWritingOptions.AllFields Property

CSVWritingOptions AllFields Property NFX Class Library

Writes all fields with comma as field delimiter, empty string for null values, including field names

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static CSVWritingOptions AllFields { get; }
public static CSVWritingOptions AllFields { get; }
Public Shared ReadOnly Property AllFields As CSVWritingOptions
    Get
Public Shared ReadOnly Property AllFields As CSVWritingOptions
    Get
public:
static property CSVWritingOptions^ AllFields {
    CSVWritingOptions^ get ();
}
public:
static property CSVWritingOptions^ AllFields {
    CSVWritingOptions^ get ();
}
static member AllFields : CSVWritingOptions with get
static member AllFields : CSVWritingOptions with get

Property Value

Type: CSVWritingOptions
See Also
CSVWritingOptions Class
CSVWritingOptions Members
NFX.Serialization.CSV Namespace


CSVWritingOptions.Default Property

CSVWritingOptions Default Property NFX Class Library

Writes CSV with comma as field delimiter, empty string for null values, skipping nonUI/non-stored fields, including field names

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static CSVWritingOptions Default { get; }
public static CSVWritingOptions Default { get; }
Public Shared ReadOnly Property Default As CSVWritingOptions
    Get
Public Shared ReadOnly Property Default As CSVWritingOptions
    Get
public:
static property CSVWritingOptions^ Default {
    CSVWritingOptions^ get ();
}
public:
static property CSVWritingOptions^ Default {
    CSVWritingOptions^ get ();
}
static member Default : CSVWritingOptions with get
static member Default : CSVWritingOptions with get

Property Value

Type: CSVWritingOptions
See Also
CSVWritingOptions Class
CSVWritingOptions Members
NFX.Serialization.CSV Namespace


CSVWritingOptions.NoHeader Property

CSVWritingOptions NoHeader Property NFX Class Library

Writes CSV with comma as field delimiter, empty string for null values, skipping nonUI/non-stored fields, but without field names

Namespace: NFX.Serialization.CSV
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static CSVWritingOptions NoHeader { get; }
public static CSVWritingOptions NoHeader { get; }
Public Shared ReadOnly Property NoHeader As CSVWritingOptions
    Get
Public Shared ReadOnly Property NoHeader As CSVWritingOptions
    Get
public:
static property CSVWritingOptions^ NoHeader {
    CSVWritingOptions^ get ();
}
public:
static property CSVWritingOptions^ NoHeader {
    CSVWritingOptions^ get ();
}
static member NoHeader : CSVWritingOptions with get
static member NoHeader : CSVWritingOptions with get

Property Value

Type: CSVWritingOptions
See Also
CSVWritingOptions Class
CSVWritingOptions Members
NFX.Serialization.CSV Namespace


NFX.Serialization.JSON Namespace

NFX.Serialization.JSON Namespace NFX Class Library

Provides JSON+ serialization functionality
Classes
 | Class | Description
Public class | JSONDataArray | Represents a data transfer object (DTO) JSON array, that holds a list of values
Public class | JSONDataMap | Represents a data transfer object (DTO) JSON map, that associates keys with values
Public class | JSONDeserializationException | Base exception thrown by the JSON when deserializing objects
Public class | JSONDynamicObject | Implements a JSON dynamic object that shapes itself at runtime
Public class | JSONException | Base exception thrown by the JSON serialization format
Public class | JSONExtensions | Provides JSON extension methods
Public class | JSONReader | Provides deserialization functionality from JSON format
Public class | JSONSerializationException | Base exception thrown by the JSON when serializing objects
Public class | JSONWriter | Writes primitive types, JSONDataObjects, JSONDynamicObjects, IEnumerable and IDictionary - implementers into string or stream. Can also write IJSONWritable-implementing types that directly serialize their state into JSON. This class does not serialize regular CLR types (that do not implement IJSONWritable), use JSONSerializer for full functionality
Public class | JSONWritingOptions | Specifies how JSON should be written as text. Use JSONWritingOptions.Compact or JSONWritingOptions.PrettyPrint static properties for typical options
Structures
 | Structure | Description
Public structure | NLSMap | Represents a JSON-serializable structure that keys [N]ame and [D]escription on lang ISO. It respects JSONWritingOptions.NLSMapLanguageISO and NLSMapLanguageISODefault
Public structure | NLSMap Builder | Facilitates the population of NLSMap from code
Public structure | NLSMap NDPair | Localized Name:Description pair
Interfaces
 | Interface | Description
Public interface | IJSONDataObject | Represents a data transfer object (DTO) abstraction used to read/write JSON data
Public interface | IJSONReadable | Denotes a CLR type-safe entity (class or struct) that can directly read itself from IJSONDataObject which is supplied by JSON parser. This mechanism bypasses all of the reflection/dynamic code. This approach may be far more performant for some classes that need to de-serialize their state/data from JSON format, than relying on general-purpose JSON serializer that can deserialize any type but is slower. The particular type has to be allocated first, then it's instance can be hydrated with data/state using this method
Public interface | IJSONWritable | Denotes a CLR type-safe entity (class or struct) that can directly write itself as JSON content string. This mechanism bypasses all of the reflection/dynamic code. This approach may be far more performant for some classes that need to serialize their state/data in JSON format, than relying on general-purpose JSON serializer that can serialize any type but is slower
Enumerations
 | Enumeration | Description
Public enumeration | JSONDynamicObjectKind | Specifies what kind the dynamic object is - map or array
Public enumeration | JSONSerializationPurpose | Specifies the purpose of JSON serialization so the level of detail may be dynamically adjusted. Depending on this parameter IJSONWritable implementors may include additional details that are otherwise not needed
Public enumeration | NLSMap GetParts |


IJSONDataObject Interface

IJSONDataObject Interface NFX Class Library

Represents a data transfer object (DTO) abstraction used to read/write JSON data

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IJSONDataObject
public interface IJSONDataObject
Public Interface IJSONDataObject
Public Interface IJSONDataObject
public interface class IJSONDataObject
public interface class IJSONDataObject
type IJSONDataObject =  interface end
type IJSONDataObject =  interface end
See Also
NFX.Serialization.JSON Namespace


IJSONReadable Interface

IJSONReadable Interface NFX Class Library

Denotes a CLR type-safe entity (class or struct) that can directly read itself from IJSONDataObject which is supplied by JSON parser. This mechanism bypasses all of the reflection/dynamic code. This approach may be far more performant for some classes that need to de-serialize their state/data from JSON format, than relying on general-purpose JSON serializer that can deserialize any type but is slower. The particular type has to be allocated first, then it's instance can be hydrated with data/state using this method

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IJSONReadable
public interface IJSONReadable
Public Interface IJSONReadable
Public Interface IJSONReadable
public interface class IJSONReadable
public interface class IJSONReadable
type IJSONReadable =  interface end
type IJSONReadable =  interface end
See Also
IJSONReadable Members
NFX.Serialization.JSON Namespace


IJSONReadable Members

IJSONReadable Members NFX Class Library

The IJSONReadable type exposes the following members.
Methods
 | Name | Description
Public method | ReadAsJSON | Reads entitie's data/state from low-level IJSONDataObject which is supplied right by JSONParser. An implementer may elect to throw various types of esceptions to signal such conditions as: unknown key map, or too many fields not supplied etc.
Back to Top
See Also
IJSONReadable Interface
NFX.Serialization.JSON Namespace


IJSONReadable Methods

IJSONReadable Methods NFX Class Library

The IJSONReadable type exposes the following members.
Methods
 | Name | Description
Public method | ReadAsJSON | Reads entitie's data/state from low-level IJSONDataObject which is supplied right by JSONParser. An implementer may elect to throw various types of esceptions to signal such conditions as: unknown key map, or too many fields not supplied etc.
Back to Top
See Also
IJSONReadable Interface
NFX.Serialization.JSON Namespace


IJSONReadable.ReadAsJSON Method

IJSONReadable ReadAsJSON Method NFX Class Library

Reads entitie's data/state from low-level IJSONDataObject which is supplied right by JSONParser. An implementer may elect to throw various types of esceptions to signal such conditions as: unknown key map, or too many fields not supplied etc.

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ReadAsJSON(
    IJSONDataObject data
)
void ReadAsJSON(
    IJSONDataObject data
)
Sub ReadAsJSON (
    data As IJSONDataObject
)
Sub ReadAsJSON (
    data As IJSONDataObject
)
void ReadAsJSON(
    IJSONDataObject^ data
)
void ReadAsJSON(
    IJSONDataObject^ data
)
abstract ReadAsJSON :
        data : IJSONDataObject -> unit
abstract ReadAsJSON :
        data : IJSONDataObject -> unit

Parameters

data
Type: NFX.Serialization.JSON IJSONDataObject
JSONParser-supplied object
See Also
IJSONReadable Interface
IJSONReadable Members
NFX.Serialization.JSON Namespace


IJSONWritable Interface

IJSONWritable Interface NFX Class Library

Denotes a CLR type-safe entity (class or struct) that can directly write itself as JSON content string. This mechanism bypasses all of the reflection/dynamic code. This approach may be far more performant for some classes that need to serialize their state/data in JSON format, than relying on general-purpose JSON serializer that can serialize any type but is slower

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IJSONWritable
public interface IJSONWritable
Public Interface IJSONWritable
Public Interface IJSONWritable
public interface class IJSONWritable
public interface class IJSONWritable
type IJSONWritable =  interface end
type IJSONWritable =  interface end
See Also
IJSONWritable Members
NFX.Serialization.JSON Namespace


IJSONWritable Members

IJSONWritable Members NFX Class Library

The IJSONWritable type exposes the following members.
Methods
 | Name | Description
Public method | WriteAsJSON | Writes entitie's data/state as JSON string
Back to Top
See Also
IJSONWritable Interface
NFX.Serialization.JSON Namespace


IJSONWritable Methods

IJSONWritable Methods NFX Class Library

The IJSONWritable type exposes the following members.
Methods
 | Name | Description
Public method | WriteAsJSON | Writes entitie's data/state as JSON string
Back to Top
See Also
IJSONWritable Interface
NFX.Serialization.JSON Namespace


IJSONWritable.WriteAsJSON Method

IJSONWritable WriteAsJSON Method NFX Class Library

Writes entitie's data/state as JSON string

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
)
void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
)
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
TextWriter to write JSON content into
nestingLevel
Type: Online System Int32
A level of nesting that this instance is at, relative to the graph root. Implementations may elect to use this parameter to control indenting or ignore it
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions
Writing options, such as indenting. Implementations may elect to use this parameter to control text output or ignore it
See Also
IJSONWritable Interface
IJSONWritable Members
NFX.Serialization.JSON Namespace


JSONDataArray Class

JSONDataArray Class NFX Class Library

Represents a data transfer object (DTO) JSON array, that holds a list of values
Inheritance Hierarchy
Online System Object
Online System.Collections.Generic List Online Object
NFX.Serialization.JSON JSONDataArray

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class JSONDataArray : List<Object>,
    IJSONDataObject
public class JSONDataArray : List<Object>,
    IJSONDataObject
Public Class JSONDataArray
    Inherits List(Of Object)
    Implements IJSONDataObject
Public Class JSONDataArray
    Inherits List(Of Object)
    Implements IJSONDataObject
public ref class JSONDataArray : public List<Object^>,
    IJSONDataObject
public ref class JSONDataArray : public List<Object^>,
    IJSONDataObject
type JSONDataArray =
    class
        inherit List<Object>
        interface IJSONDataObject
    end
type JSONDataArray =
    class
        inherit List<Object>
        interface IJSONDataObject
    end
See Also
JSONDataArray Members
NFX.Serialization.JSON Namespace


JSONDataArray Members

JSONDataArray Members NFX Class Library

The JSONDataArray type exposes the following members.
Constructors
 | Name | Description
Public method | JSONDataArray | Initializes a new instance of the JSONDataArray class
Public method | JSONDataArray(IEnumerable Object ) | Initializes a new instance of the JSONDataArray class
Public method | JSONDataArray(Int32) | Initializes a new instance of the JSONDataArray class
Back to Top
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List Online Object .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List Online Object .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List Online Object .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List Online Object .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Online Object .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Online Object .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List Online Object .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List Online Object .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List Online Object .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List Online Object .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Online Object .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Online Object .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List Online Object .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List Online Object .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Online Object .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Online Object .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Online Object .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Online Object .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List Online Object .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Online Object .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Online Object .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Online Object .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List Online Object .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List Online Object .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List Online Object .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Online Object .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Online Object .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Online Object .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List Online Object .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List Online Object .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Online Object .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Online Object .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Online Object .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List Online Object .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Online Object .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List Online Object .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List Online Object .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List Online Object .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List Online Object .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List Online Object .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List Online Object .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List Online Object .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List Online Object .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List Online Object .)
Public method | ToString | (Overrides Online Object ToString .)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List Online Object .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List Online Object .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List Online Object .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List Online Object .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List Online Object .)
Back to Top
See Also
JSONDataArray Class
NFX.Serialization.JSON Namespace


JSONDataArray Constructor

JSONDataArray Constructor NFX Class Library

Overload List
 | Name | Description
Public method | JSONDataArray | Initializes a new instance of the JSONDataArray class
Public method | JSONDataArray(IEnumerable Object ) | Initializes a new instance of the JSONDataArray class
Public method | JSONDataArray(Int32) | Initializes a new instance of the JSONDataArray class
Back to Top
See Also
JSONDataArray Class
JSONDataArray Members
NFX.Serialization.JSON Namespace


JSONDataArray Constructor

JSONDataArray Constructor NFX Class Library

Initializes a new instance of the JSONDataArray class

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDataArray()
public JSONDataArray()
Public Sub New
Public Sub New
public:
JSONDataArray()
public:
JSONDataArray()
new : unit -> JSONDataArray
new : unit -> JSONDataArray
See Also
JSONDataArray Class
JSONDataArray Members
JSONDataArray Overload
NFX.Serialization.JSON Namespace


JSONDataArray Constructor (IEnumerable(Object))

JSONDataArray Constructor (IEnumerable Object ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the JSONDataArray class

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDataArray(
    IEnumerable<Object> other
)
public JSONDataArray(
    IEnumerable<Object> other
)
Public Sub New (
    other As IEnumerable(Of Object)
)
Public Sub New (
    other As IEnumerable(Of Object)
)
public:
JSONDataArray(
    IEnumerable<Object^>^ other
)
public:
JSONDataArray(
    IEnumerable<Object^>^ other
)
new :
        other : IEnumerable<Object> -> JSONDataArray
new :
        other : IEnumerable<Object> -> JSONDataArray

Parameters

other
Type: Online System.Collections.Generic IEnumerable Online Object
See Also
JSONDataArray Class
JSONDataArray Members
JSONDataArray Overload
NFX.Serialization.JSON Namespace


JSONDataArray Constructor (Int32)

JSONDataArray Constructor (Int32) NFX Class Library

Initializes a new instance of the JSONDataArray class

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDataArray(
    int capacity
)
public JSONDataArray(
    int capacity
)
Public Sub New (
    capacity As Integer
)
Public Sub New (
    capacity As Integer
)
public:
JSONDataArray(
    int capacity
)
public:
JSONDataArray(
    int capacity
)
new :
        capacity : int -> JSONDataArray
new :
        capacity : int -> JSONDataArray

Parameters

capacity
Type: Online System Int32
See Also
JSONDataArray Class
JSONDataArray Members
JSONDataArray Overload
NFX.Serialization.JSON Namespace


JSONDataArray Methods

JSONDataArray Methods NFX Class Library

The JSONDataArray type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | Adds an object to the end of the Online List T . (Inherited from Online List Online Object .)
Public method | Online AddRange | Adds the elements of the specified collection to the end of the Online List T . (Inherited from Online List Online Object .)
Public method | Online AsReadOnly | Returns a read-only Online IList T wrapper for the current collection. (Inherited from Online List Online Object .)
Public method | Online BinarySearch(T) | Searches the entire sorted Online List T for an element using the default comparer and returns the zero-based index of the element. (Inherited from Online List Online Object .)
Public method | Online BinarySearch(T, IComparer T ) | Searches the entire sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Online Object .)
Public method | Online BinarySearch(Int32, Int32, T, IComparer T ) | Searches a range of elements in the sorted Online List T for an element using the specified comparer and returns the zero-based index of the element. (Inherited from Online List Online Object .)
Public method | Online Clear | Removes all elements from the Online List T . (Inherited from Online List Online Object .)
Public method | Online Contains | Determines whether an element is in the Online List T . (Inherited from Online List Online Object .)
Public method | Online ConvertAll TOutput | Converts the elements in the current Online List T to another type, and returns a list containing the converted elements. (Inherited from Online List Online Object .)
Public method | Online CopyTo( T ) | Copies the entire Online List T to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from Online List Online Object .)
Public method | Online CopyTo( T , Int32) | Copies the entire Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Online Object .)
Public method | Online CopyTo(Int32, T , Int32, Int32) | Copies a range of elements from the Online List T to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from Online List Online Object .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | Online Exists | Determines whether the Online List T contains elements that match the conditions defined by the specified predicate. (Inherited from Online List Online Object .)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire Online List T . (Inherited from Online List Online Object .)
Public method | Online FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Online Object .)
Public method | Online FindIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Online Object .)
Public method | Online FindIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Online Object .)
Public method | Online FindIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Online Object .)
Public method | Online FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire Online List T . (Inherited from Online List Online Object .)
Public method | Online FindLastIndex(Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Online Object .)
Public method | Online FindLastIndex(Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Online Object .)
Public method | Online FindLastIndex(Int32, Int32, Predicate T ) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Online Object .)
Public method | Online ForEach | Performs the specified action on each element of the Online List T . (Inherited from Online List Online Object .)
Public method | Online GetEnumerator | Returns an enumerator that iterates through the Online List T . (Inherited from Online List Online Object .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetRange | Creates a shallow copy of a range of elements in the source Online List T . (Inherited from Online List Online Object .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Online List T . (Inherited from Online List Online Object .)
Public method | Online IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that extends from the specified index to the last element. (Inherited from Online List Online Object .)
Public method | Online IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the Online List T that starts at the specified index and contains the specified number of elements. (Inherited from Online List Online Object .)
Public method | Online Insert | Inserts an element into the Online List T at the specified index. (Inherited from Online List Online Object .)
Public method | Online InsertRange | Inserts the elements of a collection into the Online List T at the specified index. (Inherited from Online List Online Object .)
Public method | Online LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire Online List T . (Inherited from Online List Online Object .)
Public method | Online LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that extends from the first element to the specified index. (Inherited from Online List Online Object .)
Public method | Online LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the Online List T that contains the specified number of elements and ends at the specified index. (Inherited from Online List Online Object .)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online Remove | Removes the first occurrence of a specific object from the Online List T . (Inherited from Online List Online Object .)
Public method | Online RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from Online List Online Object .)
Public method | Online RemoveAt | Removes the element at the specified index of the Online List T . (Inherited from Online List Online Object .)
Public method | Online RemoveRange | Removes a range of elements from the Online List T . (Inherited from Online List Online Object .)
Public method | Online Reverse | Reverses the order of the elements in the entire Online List T . (Inherited from Online List Online Object .)
Public method | Online Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from Online List Online Object .)
Public method | Online Sort | Sorts the elements in the entire Online List T using the default comparer. (Inherited from Online List Online Object .)
Public method | Online Sort(IComparer T ) | Sorts the elements in the entire Online List T using the specified comparer. (Inherited from Online List Online Object .)
Public method | Online Sort(Comparison T ) | Sorts the elements in the entire Online List T using the specified Online Comparison T . (Inherited from Online List Online Object .)
Public method | Online Sort(Int32, Int32, IComparer T ) | Sorts the elements in a range of elements in Online List T using the specified comparer. (Inherited from Online List Online Object .)
Public method | Online ToArray | Copies the elements of the Online List T to a new array. (Inherited from Online List Online Object .)
Public method | ToString | (Overrides Online Object ToString .)
Public method | Online TrimExcess | Sets the capacity to the actual number of elements in the Online List T , if that number is less than a threshold value. (Inherited from Online List Online Object .)
Public method | Online TrueForAll | Determines whether every element in the Online List T matches the conditions defined by the specified predicate. (Inherited from Online List Online Object .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
JSONDataArray Class
NFX.Serialization.JSON Namespace


JSONDataArray.ToString Method

JSONDataArray ToString Method NFX Class Library

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
JSONDataArray Class
JSONDataArray Members
NFX.Serialization.JSON Namespace


JSONDataArray Properties

JSONDataArray Properties NFX Class Library

The JSONDataArray type exposes the following members.
Properties
 | Name | Description
Public property | Online Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from Online List Online Object .)
Public property | Online Count | Gets the number of elements contained in the Online List T . (Inherited from Online List Online Object .)
Public property | Online Item | Gets or sets the element at the specified index. (Inherited from Online List Online Object .)
Back to Top
See Also
JSONDataArray Class
NFX.Serialization.JSON Namespace


JSONDataMap Class

JSONDataMap Class NFX Class Library

Represents a data transfer object (DTO) JSON map, that associates keys with values
Inheritance Hierarchy
Online System Object
Online System.Collections.Generic Dictionary Online String, Online Object
NFX.Serialization.JSON JSONDataMap

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class JSONDataMap : Dictionary<string, Object>,
    IJSONDataObject
[SerializableAttribute]
public class JSONDataMap : Dictionary<string, Object>,
    IJSONDataObject
<SerializableAttribute>
Public Class JSONDataMap
    Inherits Dictionary(Of String, Object)
    Implements IJSONDataObject
<SerializableAttribute>
Public Class JSONDataMap
    Inherits Dictionary(Of String, Object)
    Implements IJSONDataObject
[SerializableAttribute]
public ref class JSONDataMap : public Dictionary<String^, Object^>,
    IJSONDataObject
[SerializableAttribute]
public ref class JSONDataMap : public Dictionary<String^, Object^>,
    IJSONDataObject
[<SerializableAttribute>]
type JSONDataMap =
    class
        inherit Dictionary<string, Object>
        interface IJSONDataObject
    end
[<SerializableAttribute>]
type JSONDataMap =
    class
        inherit Dictionary<string, Object>
        interface IJSONDataObject
    end
See Also
JSONDataMap Members
NFX.Serialization.JSON Namespace


JSONDataMap Members

JSONDataMap Members NFX Class Library

The JSONDataMap type exposes the following members.
Constructors
 | Name | Description
Public method | JSONDataMap | Initializes a new instance of the JSONDataMap class
Public method | JSONDataMap(Boolean) | Initializes a new instance of the JSONDataMap class
Back to Top
Methods
 | Name | Description
Public method | Online Add | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Append | Appends contents of another JSONDataMap for keys that do not exist in this one or null. Only appends references, does not provide deep reference copy
Public method | Online Clear | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online ContainsKey | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online ContainsValue | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | FromURLEncodedStream | Turns URL encoded content into JSONDataMap
 | FromURLEncodedString | Turns URL encoded content into JSONDataMap
Public method | Online GetEnumerator | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online Dictionary TKey, TValue instance. (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online Remove | (Inherited from Online Dictionary Online String, Online Object .)
Public method | ToConfigNode | Returns this object as a config tree
Public method | ToString | (Overrides Online Object ToString .)
Public method | Online TryGetValue | (Inherited from Online Dictionary Online String, Online Object .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | GetNodeByPath | Navigates through JSON datamap by subsequent node names. (Defined by SerializationUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | CaseSensitive |
Back to Top
Properties
 | Name | Description
Public property | Online Comparer | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Online Count | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Item |
Public property | Online Keys | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Online Values | (Inherited from Online Dictionary Online String, Online Object .)
Back to Top
See Also
JSONDataMap Class
NFX.Serialization.JSON Namespace


JSONDataMap Constructor

JSONDataMap Constructor NFX Class Library

Overload List
 | Name | Description
Public method | JSONDataMap | Initializes a new instance of the JSONDataMap class
Public method | JSONDataMap(Boolean) | Initializes a new instance of the JSONDataMap class
Back to Top
See Also
JSONDataMap Class
JSONDataMap Members
NFX.Serialization.JSON Namespace


JSONDataMap Constructor

JSONDataMap Constructor NFX Class Library

Initializes a new instance of the JSONDataMap class

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDataMap()
public JSONDataMap()
Public Sub New
Public Sub New
public:
JSONDataMap()
public:
JSONDataMap()
new : unit -> JSONDataMap
new : unit -> JSONDataMap
See Also
JSONDataMap Class
JSONDataMap Members
JSONDataMap Overload
NFX.Serialization.JSON Namespace


JSONDataMap Constructor (Boolean)

JSONDataMap Constructor (Boolean) NFX Class Library

Initializes a new instance of the JSONDataMap class

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDataMap(
    bool caseSensitive
)
public JSONDataMap(
    bool caseSensitive
)
Public Sub New (
    caseSensitive As Boolean
)
Public Sub New (
    caseSensitive As Boolean
)
public:
JSONDataMap(
    bool caseSensitive
)
public:
JSONDataMap(
    bool caseSensitive
)
new :
        caseSensitive : bool -> JSONDataMap
new :
        caseSensitive : bool -> JSONDataMap

Parameters

caseSensitive
Type: Online System Boolean
See Also
JSONDataMap Class
JSONDataMap Members
JSONDataMap Overload
NFX.Serialization.JSON Namespace


JSONDataMap Fields

JSONDataMap Fields NFX Class Library

The JSONDataMap type exposes the following members.
Fields
 | Name | Description
Public field | CaseSensitive |
Back to Top
See Also
JSONDataMap Class
NFX.Serialization.JSON Namespace


JSONDataMap.CaseSensitive Field

JSONDataMap CaseSensitive Field NFX Class Library

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool CaseSensitive
public readonly bool CaseSensitive
Public ReadOnly CaseSensitive As Boolean
Public ReadOnly CaseSensitive As Boolean
public:
initonly bool CaseSensitive
public:
initonly bool CaseSensitive
val CaseSensitive: bool
val CaseSensitive: bool

Field Value

Type: Online Boolean
See Also
JSONDataMap Class
JSONDataMap Members
NFX.Serialization.JSON Namespace


JSONDataMap Methods

JSONDataMap Methods NFX Class Library

The JSONDataMap type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Append | Appends contents of another JSONDataMap for keys that do not exist in this one or null. Only appends references, does not provide deep reference copy
Public method | Online Clear | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online ContainsKey | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online ContainsValue | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | FromURLEncodedStream | Turns URL encoded content into JSONDataMap
 | FromURLEncodedString | Turns URL encoded content into JSONDataMap
Public method | Online GetEnumerator | (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online Dictionary TKey, TValue instance. (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online Dictionary Online String, Online Object .)
Public method | Online Remove | (Inherited from Online Dictionary Online String, Online Object .)
Public method | ToConfigNode | Returns this object as a config tree
Public method | ToString | (Overrides Online Object ToString .)
Public method | Online TryGetValue | (Inherited from Online Dictionary Online String, Online Object .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | GetNodeByPath | Navigates through JSON datamap by subsequent node names. (Defined by SerializationUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
JSONDataMap Class
NFX.Serialization.JSON Namespace


JSONDataMap.Append Method

JSONDataMap Append Method NFX Class Library

Appends contents of another JSONDataMap for keys that do not exist in this one or null. Only appends references, does not provide deep reference copy

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDataMap Append(
    JSONDataMap other,
    bool deep = false
)
public JSONDataMap Append(
    JSONDataMap other,
    bool deep = false
)
Public Function Append (
    other As JSONDataMap,
    Optional deep As Boolean = false
) As JSONDataMap
Public Function Append (
    other As JSONDataMap,
    Optional deep As Boolean = false
) As JSONDataMap
public:
JSONDataMap^ Append(
    JSONDataMap^ other,
    bool deep = false
)
public:
JSONDataMap^ Append(
    JSONDataMap^ other,
    bool deep = false
)
member Append :
        other : JSONDataMap *
        ?deep : bool
(* Defaults:
        let _deep = defaultArg deep false
*)
-> JSONDataMap
member Append :
        other : JSONDataMap *
        ?deep : bool
(* Defaults:
        let _deep = defaultArg deep false
*)
-> JSONDataMap

Parameters

other
Type: NFX.Serialization.JSON JSONDataMap
deep (Optional)
Type: Online System Boolean

Return Value

Type: JSONDataMap
See Also
JSONDataMap Class
JSONDataMap Members
NFX.Serialization.JSON Namespace


JSONDataMap.FromURLEncodedStream Method

JSONDataMap FromURLEncodedStream Method NFX Class Library

Turns URL encoded content into JSONDataMap

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static JSONDataMap FromURLEncodedStream(
    Stream stream,
    Encoding encoding = null,
    bool caseSensitive = false
)
public static JSONDataMap FromURLEncodedStream(
    Stream stream,
    Encoding encoding = null,
    bool caseSensitive = false
)
Public Shared Function FromURLEncodedStream (
    stream As Stream,
    Optional encoding As Encoding = Nothing,
    Optional caseSensitive As Boolean = false
) As JSONDataMap
Public Shared Function FromURLEncodedStream (
    stream As Stream,
    Optional encoding As Encoding = Nothing,
    Optional caseSensitive As Boolean = false
) As JSONDataMap
public:
static JSONDataMap^ FromURLEncodedStream(
    Stream^ stream,
    Encoding^ encoding = nullptr,
    bool caseSensitive = false
)
public:
static JSONDataMap^ FromURLEncodedStream(
    Stream^ stream,
    Encoding^ encoding = nullptr,
    bool caseSensitive = false
)
static member FromURLEncodedStream :
        stream : Stream *
        ?encoding : Encoding *
        ?caseSensitive : bool
(* Defaults:
        let _encoding = defaultArg encoding null
        let _caseSensitive = defaultArg caseSensitive false
*)
-> JSONDataMap
static member FromURLEncodedStream :
        stream : Stream *
        ?encoding : Encoding *
        ?caseSensitive : bool
(* Defaults:
        let _encoding = defaultArg encoding null
        let _caseSensitive = defaultArg caseSensitive false
*)
-> JSONDataMap

Parameters

stream
Type: Online System.IO Stream
encoding (Optional)
Type: Online System.Text Encoding
caseSensitive (Optional)
Type: Online System Boolean

Return Value

Type: JSONDataMap
See Also
JSONDataMap Class
JSONDataMap Members
NFX.Serialization.JSON Namespace


JSONDataMap.FromURLEncodedString Method

JSONDataMap FromURLEncodedString Method NFX Class Library

Turns URL encoded content into JSONDataMap

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static JSONDataMap FromURLEncodedString(
    string content,
    bool caseSensitive = false
)
public static JSONDataMap FromURLEncodedString(
    string content,
    bool caseSensitive = false
)
Public Shared Function FromURLEncodedString (
    content As String,
    Optional caseSensitive As Boolean = false
) As JSONDataMap
Public Shared Function FromURLEncodedString (
    content As String,
    Optional caseSensitive As Boolean = false
) As JSONDataMap
public:
static JSONDataMap^ FromURLEncodedString(
    String^ content,
    bool caseSensitive = false
)
public:
static JSONDataMap^ FromURLEncodedString(
    String^ content,
    bool caseSensitive = false
)
static member FromURLEncodedString :
        content : string *
        ?caseSensitive : bool
(* Defaults:
        let _caseSensitive = defaultArg caseSensitive false
*)
-> JSONDataMap
static member FromURLEncodedString :
        content : string *
        ?caseSensitive : bool
(* Defaults:
        let _caseSensitive = defaultArg caseSensitive false
*)
-> JSONDataMap

Parameters

content
Type: Online System String
caseSensitive (Optional)
Type: Online System Boolean

Return Value

Type: JSONDataMap
See Also
JSONDataMap Class
JSONDataMap Members
NFX.Serialization.JSON Namespace


JSONDataMap.ToConfigNode Method

JSONDataMap ToConfigNode Method NFX Class Library

Returns this object as a config tree

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConfigSectionNode ToConfigNode(
    string rootName = null
)
public ConfigSectionNode ToConfigNode(
    string rootName = null
)
Public Function ToConfigNode (
    Optional rootName As String = Nothing
) As ConfigSectionNode
Public Function ToConfigNode (
    Optional rootName As String = Nothing
) As ConfigSectionNode
public:
ConfigSectionNode^ ToConfigNode(
    String^ rootName = nullptr
)
public:
ConfigSectionNode^ ToConfigNode(
    String^ rootName = nullptr
)
member ToConfigNode :
        ?rootName : string
(* Defaults:
        let _rootName = defaultArg rootName null
*)
-> ConfigSectionNode
member ToConfigNode :
        ?rootName : string
(* Defaults:
        let _rootName = defaultArg rootName null
*)
-> ConfigSectionNode

Parameters

rootName (Optional)
Type: Online System String

Return Value

Type: ConfigSectionNode
See Also
JSONDataMap Class
JSONDataMap Members
NFX.Serialization.JSON Namespace


JSONDataMap.ToString Method

JSONDataMap ToString Method NFX Class Library

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
JSONDataMap Class
JSONDataMap Members
NFX.Serialization.JSON Namespace


JSONDataMap Properties

JSONDataMap Properties NFX Class Library

The JSONDataMap type exposes the following members.
Properties
 | Name | Description
Public property | Online Comparer | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Online Count | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Item |
Public property | Online Keys | (Inherited from Online Dictionary Online String, Online Object .)
Public property | Online Values | (Inherited from Online Dictionary Online String, Online Object .)
Back to Top
See Also
JSONDataMap Class
NFX.Serialization.JSON Namespace


JSONDataMap.Item Property

JSONDataMap Item Property NFX Class Library

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object this[
    string key
] { get; set; }
public Object this[
    string key
] { get; set; }
Public Default Property Item (
    key As String
) As Object
    Get
    Set
Public Default Property Item (
    key As String
) As Object
    Get
    Set
public:
property Object^ default[String^ key] {
    Object^ get (String^ key);
    void set (String^ key, Object^ value);
}
public:
property Object^ default[String^ key] {
    Object^ get (String^ key);
    void set (String^ key, Object^ value);
}
member Item : Object with get, set
member Item : Object with get, set

Parameters

key
Type: Online System String

Property Value

Type: Online Object
See Also
JSONDataMap Class
JSONDataMap Members
NFX.Serialization.JSON Namespace


JSONDeserializationException Class

JSONDeserializationException Class NFX Class Library

Base exception thrown by the JSON when deserializing objects
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Serialization NFXSerializationException
NFX.Serialization.JSON JSONException
NFX.Serialization.JSON JSONDeserializationException

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class JSONDeserializationException : JSONException
[SerializableAttribute]
public class JSONDeserializationException : JSONException
<SerializableAttribute>
Public Class JSONDeserializationException
    Inherits JSONException
<SerializableAttribute>
Public Class JSONDeserializationException
    Inherits JSONException
[SerializableAttribute]
public ref class JSONDeserializationException : public JSONException
[SerializableAttribute]
public ref class JSONDeserializationException : public JSONException
[<SerializableAttribute>]
type JSONDeserializationException =
    class
        inherit JSONException
    end
[<SerializableAttribute>]
type JSONDeserializationException =
    class
        inherit JSONException
    end
See Also
JSONDeserializationException Members
NFX.Serialization.JSON Namespace


JSONDeserializationException Members

JSONDeserializationException Members NFX Class Library

The JSONDeserializationException type exposes the following members.
Constructors
 | Name | Description
Public method | JSONDeserializationException | Initializes a new instance of the JSONDeserializationException class
Public method | JSONDeserializationException(String) | Initializes a new instance of the JSONDeserializationException class
Protected method | JSONDeserializationException(SerializationInfo, StreamingContext) | Initializes a new instance of the JSONDeserializationException class
Public method | JSONDeserializationException(String, Exception) | Initializes a new instance of the JSONDeserializationException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
JSONDeserializationException Class
NFX.Serialization.JSON Namespace


JSONDeserializationException Constructor

JSONDeserializationException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | JSONDeserializationException | Initializes a new instance of the JSONDeserializationException class
Public method | JSONDeserializationException(String) | Initializes a new instance of the JSONDeserializationException class
Protected method | JSONDeserializationException(SerializationInfo, StreamingContext) | Initializes a new instance of the JSONDeserializationException class
Public method | JSONDeserializationException(String, Exception) | Initializes a new instance of the JSONDeserializationException class
Back to Top
See Also
JSONDeserializationException Class
JSONDeserializationException Members
NFX.Serialization.JSON Namespace


JSONDeserializationException Constructor

JSONDeserializationException Constructor NFX Class Library

Initializes a new instance of the JSONDeserializationException class

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDeserializationException()
public JSONDeserializationException()
Public Sub New
Public Sub New
public:
JSONDeserializationException()
public:
JSONDeserializationException()
new : unit -> JSONDeserializationException
new : unit -> JSONDeserializationException
See Also
JSONDeserializationException Class
JSONDeserializationException Members
JSONDeserializationException Overload
NFX.Serialization.JSON Namespace


JSONDeserializationException Constructor (String)

JSONDeserializationException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the JSONDeserializationException class

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDeserializationException(
    string message
)
public JSONDeserializationException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
JSONDeserializationException(
    String^ message
)
public:
JSONDeserializationException(
    String^ message
)
new :
        message : string -> JSONDeserializationException
new :
        message : string -> JSONDeserializationException

Parameters

message
Type: Online System String
See Also
JSONDeserializationException Class
JSONDeserializationException Members
JSONDeserializationException Overload
NFX.Serialization.JSON Namespace


JSONDeserializationException Constructor (SerializationInfo, StreamingContext)

JSONDeserializationException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the JSONDeserializationException class

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected JSONDeserializationException(
    SerializationInfo info,
    StreamingContext context
)
protected JSONDeserializationException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
JSONDeserializationException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
JSONDeserializationException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> JSONDeserializationException
new :
        info : SerializationInfo *
        context : StreamingContext -> JSONDeserializationException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
JSONDeserializationException Class
JSONDeserializationException Members
JSONDeserializationException Overload
NFX.Serialization.JSON Namespace


JSONDeserializationException Constructor (String, Exception)

JSONDeserializationException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the JSONDeserializationException class

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDeserializationException(
    string message,
    Exception inner
)
public JSONDeserializationException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
JSONDeserializationException(
    String^ message,
    Exception^ inner
)
public:
JSONDeserializationException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> JSONDeserializationException
new :
        message : string *
        inner : Exception -> JSONDeserializationException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
JSONDeserializationException Class
JSONDeserializationException Members
JSONDeserializationException Overload
NFX.Serialization.JSON Namespace


JSONDeserializationException Methods

JSONDeserializationException Methods NFX Class Library

The JSONDeserializationException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
JSONDeserializationException Class
NFX.Serialization.JSON Namespace


JSONDeserializationException Properties

JSONDeserializationException Properties NFX Class Library

The JSONDeserializationException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
JSONDeserializationException Class
NFX.Serialization.JSON Namespace


JSONDeserializationException Events

JSONDeserializationException Events NFX Class Library

The JSONDeserializationException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
JSONDeserializationException Class
NFX.Serialization.JSON Namespace


JSONDynamicObject Class

JSONDynamicObject Class NFX Class Library

Implements a JSON dynamic object that shapes itself at runtime
Inheritance Hierarchy
Online System Object
Online System.Dynamic DynamicObject
NFX.Serialization.JSON JSONDynamicObject

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class JSONDynamicObject : DynamicObject
[SerializableAttribute]
public sealed class JSONDynamicObject : DynamicObject
<SerializableAttribute>
Public NotInheritable Class JSONDynamicObject
    Inherits DynamicObject
<SerializableAttribute>
Public NotInheritable Class JSONDynamicObject
    Inherits DynamicObject
[SerializableAttribute]
public ref class JSONDynamicObject sealed : public DynamicObject
[SerializableAttribute]
public ref class JSONDynamicObject sealed : public DynamicObject
[<SealedAttribute>]
[<SerializableAttribute>]
type JSONDynamicObject =
    class
        inherit DynamicObject
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type JSONDynamicObject =
    class
        inherit DynamicObject
    end
See Also
JSONDynamicObject Members
NFX.Serialization.JSON Namespace


JSONDynamicObject Members

JSONDynamicObject Members NFX Class Library

The JSONDynamicObject type exposes the following members.
Constructors
 | Name | Description
Public method | JSONDynamicObject(IJSONDataObject) | Initializes a new instance of the JSONDynamicObject class
Public method | JSONDynamicObject(JSONDynamicObjectKind, Boolean) | Creates a dynamic wrapper around existing array or map. Optionally specifies map key case sensitivity
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDynamicMemberNames | (Overrides Online DynamicObject GetDynamicMemberNames .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetMetaObject | Provides a Online DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another Online DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from Online DynamicObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TryBinaryOperation | Provides implementation for binary operations. Classes derived from the Online DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from Online DynamicObject.)
Public method | TryConvert | (Overrides Online DynamicObject TryConvert(ConvertBinder, Object ).)
Public method | Online TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from Online DynamicObject.)
Public method | Online TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from Online DynamicObject.)
Public method | Online TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from Online DynamicObject.)
Public method | TryGetIndex | (Overrides Online DynamicObject TryGetIndex(GetIndexBinder, Object , Object ).)
Public method | TryGetMember | (Overrides Online DynamicObject TryGetMember(GetMemberBinder, Object ).)
Public method | Online TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the Online DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from Online DynamicObject.)
Public method | TryInvokeMember | (Overrides Online DynamicObject TryInvokeMember(InvokeMemberBinder, Object , Object ).)
Public method | TrySetIndex | (Overrides Online DynamicObject TrySetIndex(SetIndexBinder, Object , Object).)
Public method | TrySetMember | (Overrides Online DynamicObject TrySetMember(SetMemberBinder, Object).)
Public method | Online TryUnaryOperation | Provides implementation for unary operations. Classes derived from the Online DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from Online DynamicObject.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Data | Returns the underlying JSON data
Public property | Kind |
Back to Top
See Also
JSONDynamicObject Class
NFX.Serialization.JSON Namespace


JSONDynamicObject Constructor

JSONDynamicObject Constructor NFX Class Library

Overload List
 | Name | Description
Public method | JSONDynamicObject(IJSONDataObject) | Initializes a new instance of the JSONDynamicObject class
Public method | JSONDynamicObject(JSONDynamicObjectKind, Boolean) | Creates a dynamic wrapper around existing array or map. Optionally specifies map key case sensitivity
Back to Top
See Also
JSONDynamicObject Class
JSONDynamicObject Members
NFX.Serialization.JSON Namespace


JSONDynamicObject Constructor (IJSONDataObject)

JSONDynamicObject Constructor (IJSONDataObject) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the JSONDynamicObject class

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDynamicObject(
    IJSONDataObject data
)
public JSONDynamicObject(
    IJSONDataObject data
)
Public Sub New (
    data As IJSONDataObject
)
Public Sub New (
    data As IJSONDataObject
)
public:
JSONDynamicObject(
    IJSONDataObject^ data
)
public:
JSONDynamicObject(
    IJSONDataObject^ data
)
new :
        data : IJSONDataObject -> JSONDynamicObject
new :
        data : IJSONDataObject -> JSONDynamicObject

Parameters

data
Type: NFX.Serialization.JSON IJSONDataObject
See Also
JSONDynamicObject Class
JSONDynamicObject Members
JSONDynamicObject Overload
NFX.Serialization.JSON Namespace


JSONDynamicObject Constructor (JSONDynamicObjectKind, Boolean)

JSONDynamicObject Constructor (JSONDynamicObjectKind, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates a dynamic wrapper around existing array or map. Optionally specifies map key case sensitivity

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDynamicObject(
    JSONDynamicObjectKind kind,
    bool caseSensitiveMap = true
)
public JSONDynamicObject(
    JSONDynamicObjectKind kind,
    bool caseSensitiveMap = true
)
Public Sub New (
    kind As JSONDynamicObjectKind,
    Optional caseSensitiveMap As Boolean = true
)
Public Sub New (
    kind As JSONDynamicObjectKind,
    Optional caseSensitiveMap As Boolean = true
)
public:
JSONDynamicObject(
    JSONDynamicObjectKind kind,
    bool caseSensitiveMap = true
)
public:
JSONDynamicObject(
    JSONDynamicObjectKind kind,
    bool caseSensitiveMap = true
)
new :
        kind : JSONDynamicObjectKind *
        ?caseSensitiveMap : bool
(* Defaults:
        let _caseSensitiveMap = defaultArg caseSensitiveMap true
*)
-> JSONDynamicObject
new :
        kind : JSONDynamicObjectKind *
        ?caseSensitiveMap : bool
(* Defaults:
        let _caseSensitiveMap = defaultArg caseSensitiveMap true
*)
-> JSONDynamicObject

Parameters

kind
Type: NFX.Serialization.JSON JSONDynamicObjectKind
caseSensitiveMap (Optional)
Type: Online System Boolean
See Also
JSONDynamicObject Class
JSONDynamicObject Members
JSONDynamicObject Overload
NFX.Serialization.JSON Namespace


JSONDynamicObject Methods

JSONDynamicObject Methods NFX Class Library

The JSONDynamicObject type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetDynamicMemberNames | (Overrides Online DynamicObject GetDynamicMemberNames .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetMetaObject | Provides a Online DynamicMetaObject that dispatches to the dynamic virtual methods. The object can be encapsulated inside another Online DynamicMetaObject to provide custom behavior for individual actions. This method supports the Dynamic Language Runtime infrastructure for language implementers and it is not intended to be used directly from your code. (Inherited from Online DynamicObject.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TryBinaryOperation | Provides implementation for binary operations. Classes derived from the Online DynamicObject class can override this method to specify dynamic behavior for operations such as addition and multiplication. (Inherited from Online DynamicObject.)
Public method | TryConvert | (Overrides Online DynamicObject TryConvert(ConvertBinder, Object ).)
Public method | Online TryCreateInstance | Provides the implementation for operations that initialize a new instance of a dynamic object. This method is not intended for use in C# or Visual Basic. (Inherited from Online DynamicObject.)
Public method | Online TryDeleteIndex | Provides the implementation for operations that delete an object by index. This method is not intended for use in C# or Visual Basic. (Inherited from Online DynamicObject.)
Public method | Online TryDeleteMember | Provides the implementation for operations that delete an object member. This method is not intended for use in C# or Visual Basic. (Inherited from Online DynamicObject.)
Public method | TryGetIndex | (Overrides Online DynamicObject TryGetIndex(GetIndexBinder, Object , Object ).)
Public method | TryGetMember | (Overrides Online DynamicObject TryGetMember(GetMemberBinder, Object ).)
Public method | Online TryInvoke | Provides the implementation for operations that invoke an object. Classes derived from the Online DynamicObject class can override this method to specify dynamic behavior for operations such as invoking an object or a delegate. (Inherited from Online DynamicObject.)
Public method | TryInvokeMember | (Overrides Online DynamicObject TryInvokeMember(InvokeMemberBinder, Object , Object ).)
Public method | TrySetIndex | (Overrides Online DynamicObject TrySetIndex(SetIndexBinder, Object , Object).)
Public method | TrySetMember | (Overrides Online DynamicObject TrySetMember(SetMemberBinder, Object).)
Public method | Online TryUnaryOperation | Provides implementation for unary operations. Classes derived from the Online DynamicObject class can override this method to specify dynamic behavior for operations such as negation, increment, or decrement. (Inherited from Online DynamicObject.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
JSONDynamicObject Class
NFX.Serialization.JSON Namespace


JSONDynamicObject.GetDynamicMemberNames Method

JSONDynamicObject GetDynamicMemberNames Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IEnumerable<string> GetDynamicMemberNames()
public override IEnumerable<string> GetDynamicMemberNames()
Public Overrides Function GetDynamicMemberNames As IEnumerable(Of String)
Public Overrides Function GetDynamicMemberNames As IEnumerable(Of String)
public:
virtual IEnumerable<String^>^ GetDynamicMemberNames() override
public:
virtual IEnumerable<String^>^ GetDynamicMemberNames() override
abstract GetDynamicMemberNames : unit -> IEnumerable<string>
override GetDynamicMemberNames : unit -> IEnumerable<string>
abstract GetDynamicMemberNames : unit -> IEnumerable<string>
override GetDynamicMemberNames : unit -> IEnumerable<string>

Return Value

Type: Online IEnumerable Online String
See Also
JSONDynamicObject Class
JSONDynamicObject Members
NFX.Serialization.JSON Namespace


JSONDynamicObject.TryConvert Method

JSONDynamicObject TryConvert Method NFX Class Library

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool TryConvert(
    ConvertBinder binder,
    out Object result
)
public override bool TryConvert(
    ConvertBinder binder,
    out Object result
)
Public Overrides Function TryConvert (
    binder As ConvertBinder,
    <OutAttribute> ByRef result As Object
) As Boolean
Public Overrides Function TryConvert (
    binder As ConvertBinder,
    <OutAttribute> ByRef result As Object
) As Boolean
public:
virtual bool TryConvert(
    ConvertBinder^ binder,
    [OutAttribute] Object^% result
) override
public:
virtual bool TryConvert(
    ConvertBinder^ binder,
    [OutAttribute] Object^% result
) override
abstract TryConvert :
        binder : ConvertBinder *
        result : Object byref -> bool
override TryConvert :
        binder : ConvertBinder *
        result : Object byref -> bool
abstract TryConvert :
        binder : ConvertBinder *
        result : Object byref -> bool
override TryConvert :
        binder : ConvertBinder *
        result : Object byref -> bool

Parameters

binder
Type: Online System.Dynamic ConvertBinder
result
Type: Online System Object

Return Value

Type: Online Boolean
See Also
JSONDynamicObject Class
JSONDynamicObject Members
NFX.Serialization.JSON Namespace


JSONDynamicObject.TryGetIndex Method

JSONDynamicObject TryGetIndex Method NFX Class Library

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool TryGetIndex(
    GetIndexBinder binder,
    Object[] indexes,
    out Object result
)
public override bool TryGetIndex(
    GetIndexBinder binder,
    Object[] indexes,
    out Object result
)
Public Overrides Function TryGetIndex (
    binder As GetIndexBinder,
    indexes As Object(),
    <OutAttribute> ByRef result As Object
) As Boolean
Public Overrides Function TryGetIndex (
    binder As GetIndexBinder,
    indexes As Object(),
    <OutAttribute> ByRef result As Object
) As Boolean
public:
virtual bool TryGetIndex(
    GetIndexBinder^ binder,
    array<Object^>^ indexes,
    [OutAttribute] Object^% result
) override
public:
virtual bool TryGetIndex(
    GetIndexBinder^ binder,
    array<Object^>^ indexes,
    [OutAttribute] Object^% result
) override
abstract TryGetIndex :
        binder : GetIndexBinder *
        indexes : Object[] *
        result : Object byref -> bool
override TryGetIndex :
        binder : GetIndexBinder *
        indexes : Object[] *
        result : Object byref -> bool
abstract TryGetIndex :
        binder : GetIndexBinder *
        indexes : Object[] *
        result : Object byref -> bool
override TryGetIndex :
        binder : GetIndexBinder *
        indexes : Object[] *
        result : Object byref -> bool

Parameters

binder
Type: Online System.Dynamic GetIndexBinder
indexes
Type: Online System Object
result
Type: Online System Object

Return Value

Type: Online Boolean
See Also
JSONDynamicObject Class
JSONDynamicObject Members
NFX.Serialization.JSON Namespace


JSONDynamicObject.TryGetMember Method

JSONDynamicObject TryGetMember Method NFX Class Library

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool TryGetMember(
    GetMemberBinder binder,
    out Object result
)
public override bool TryGetMember(
    GetMemberBinder binder,
    out Object result
)
Public Overrides Function TryGetMember (
    binder As GetMemberBinder,
    <OutAttribute> ByRef result As Object
) As Boolean
Public Overrides Function TryGetMember (
    binder As GetMemberBinder,
    <OutAttribute> ByRef result As Object
) As Boolean
public:
virtual bool TryGetMember(
    GetMemberBinder^ binder,
    [OutAttribute] Object^% result
) override
public:
virtual bool TryGetMember(
    GetMemberBinder^ binder,
    [OutAttribute] Object^% result
) override
abstract TryGetMember :
        binder : GetMemberBinder *
        result : Object byref -> bool
override TryGetMember :
        binder : GetMemberBinder *
        result : Object byref -> bool
abstract TryGetMember :
        binder : GetMemberBinder *
        result : Object byref -> bool
override TryGetMember :
        binder : GetMemberBinder *
        result : Object byref -> bool

Parameters

binder
Type: Online System.Dynamic GetMemberBinder
result
Type: Online System Object

Return Value

Type: Online Boolean
See Also
JSONDynamicObject Class
JSONDynamicObject Members
NFX.Serialization.JSON Namespace


JSONDynamicObject.TryInvokeMember Method

JSONDynamicObject TryInvokeMember Method NFX Class Library

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool TryInvokeMember(
    InvokeMemberBinder binder,
    Object[] args,
    out Object result
)
public override bool TryInvokeMember(
    InvokeMemberBinder binder,
    Object[] args,
    out Object result
)
Public Overrides Function TryInvokeMember (
    binder As InvokeMemberBinder,
    args As Object(),
    <OutAttribute> ByRef result As Object
) As Boolean
Public Overrides Function TryInvokeMember (
    binder As InvokeMemberBinder,
    args As Object(),
    <OutAttribute> ByRef result As Object
) As Boolean
public:
virtual bool TryInvokeMember(
    InvokeMemberBinder^ binder,
    array<Object^>^ args,
    [OutAttribute] Object^% result
) override
public:
virtual bool TryInvokeMember(
    InvokeMemberBinder^ binder,
    array<Object^>^ args,
    [OutAttribute] Object^% result
) override
abstract TryInvokeMember :
        binder : InvokeMemberBinder *
        args : Object[] *
        result : Object byref -> bool
override TryInvokeMember :
        binder : InvokeMemberBinder *
        args : Object[] *
        result : Object byref -> bool
abstract TryInvokeMember :
        binder : InvokeMemberBinder *
        args : Object[] *
        result : Object byref -> bool
override TryInvokeMember :
        binder : InvokeMemberBinder *
        args : Object[] *
        result : Object byref -> bool

Parameters

binder
Type: Online System.Dynamic InvokeMemberBinder
args
Type: Online System Object
result
Type: Online System Object

Return Value

Type: Online Boolean
See Also
JSONDynamicObject Class
JSONDynamicObject Members
NFX.Serialization.JSON Namespace


JSONDynamicObject.TrySetIndex Method

JSONDynamicObject TrySetIndex Method NFX Class Library

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool TrySetIndex(
    SetIndexBinder binder,
    Object[] indexes,
    Object value
)
public override bool TrySetIndex(
    SetIndexBinder binder,
    Object[] indexes,
    Object value
)
Public Overrides Function TrySetIndex (
    binder As SetIndexBinder,
    indexes As Object(),
    value As Object
) As Boolean
Public Overrides Function TrySetIndex (
    binder As SetIndexBinder,
    indexes As Object(),
    value As Object
) As Boolean
public:
virtual bool TrySetIndex(
    SetIndexBinder^ binder,
    array<Object^>^ indexes,
    Object^ value
) override
public:
virtual bool TrySetIndex(
    SetIndexBinder^ binder,
    array<Object^>^ indexes,
    Object^ value
) override
abstract TrySetIndex :
        binder : SetIndexBinder *
        indexes : Object[] *
        value : Object -> bool
override TrySetIndex :
        binder : SetIndexBinder *
        indexes : Object[] *
        value : Object -> bool
abstract TrySetIndex :
        binder : SetIndexBinder *
        indexes : Object[] *
        value : Object -> bool
override TrySetIndex :
        binder : SetIndexBinder *
        indexes : Object[] *
        value : Object -> bool

Parameters

binder
Type: Online System.Dynamic SetIndexBinder
indexes
Type: Online System Object
value
Type: Online System Object

Return Value

Type: Online Boolean
See Also
JSONDynamicObject Class
JSONDynamicObject Members
NFX.Serialization.JSON Namespace


JSONDynamicObject.TrySetMember Method

JSONDynamicObject TrySetMember Method NFX Class Library

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool TrySetMember(
    SetMemberBinder binder,
    Object value
)
public override bool TrySetMember(
    SetMemberBinder binder,
    Object value
)
Public Overrides Function TrySetMember (
    binder As SetMemberBinder,
    value As Object
) As Boolean
Public Overrides Function TrySetMember (
    binder As SetMemberBinder,
    value As Object
) As Boolean
public:
virtual bool TrySetMember(
    SetMemberBinder^ binder,
    Object^ value
) override
public:
virtual bool TrySetMember(
    SetMemberBinder^ binder,
    Object^ value
) override
abstract TrySetMember :
        binder : SetMemberBinder *
        value : Object -> bool
override TrySetMember :
        binder : SetMemberBinder *
        value : Object -> bool
abstract TrySetMember :
        binder : SetMemberBinder *
        value : Object -> bool
override TrySetMember :
        binder : SetMemberBinder *
        value : Object -> bool

Parameters

binder
Type: Online System.Dynamic SetMemberBinder
value
Type: Online System Object

Return Value

Type: Online Boolean
See Also
JSONDynamicObject Class
JSONDynamicObject Members
NFX.Serialization.JSON Namespace


JSONDynamicObject Properties

JSONDynamicObject Properties NFX Class Library

The JSONDynamicObject type exposes the following members.
Properties
 | Name | Description
Public property | Data | Returns the underlying JSON data
Public property | Kind |
Back to Top
See Also
JSONDynamicObject Class
NFX.Serialization.JSON Namespace


JSONDynamicObject.Data Property

JSONDynamicObject Data Property NFX Class Library

Returns the underlying JSON data

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IJSONDataObject Data { get; }
public IJSONDataObject Data { get; }
Public ReadOnly Property Data As IJSONDataObject
    Get
Public ReadOnly Property Data As IJSONDataObject
    Get
public:
property IJSONDataObject^ Data {
    IJSONDataObject^ get ();
}
public:
property IJSONDataObject^ Data {
    IJSONDataObject^ get ();
}
member Data : IJSONDataObject with get
member Data : IJSONDataObject with get

Property Value

Type: IJSONDataObject
See Also
JSONDynamicObject Class
JSONDynamicObject Members
NFX.Serialization.JSON Namespace


JSONDynamicObject.Kind Property

JSONDynamicObject Kind Property NFX Class Library

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONDynamicObjectKind Kind { get; }
public JSONDynamicObjectKind Kind { get; }
Public ReadOnly Property Kind As JSONDynamicObjectKind
    Get
Public ReadOnly Property Kind As JSONDynamicObjectKind
    Get
public:
property JSONDynamicObjectKind Kind {
    JSONDynamicObjectKind get ();
}
public:
property JSONDynamicObjectKind Kind {
    JSONDynamicObjectKind get ();
}
member Kind : JSONDynamicObjectKind with get
member Kind : JSONDynamicObjectKind with get

Property Value

Type: JSONDynamicObjectKind
See Also
JSONDynamicObject Class
JSONDynamicObject Members
NFX.Serialization.JSON Namespace


JSONDynamicObjectKind Enumeration

JSONDynamicObjectKind Enumeration NFX Class Library

Specifies what kind the dynamic object is - map or array

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum JSONDynamicObjectKind
public enum JSONDynamicObjectKind
Public Enumeration JSONDynamicObjectKind
Public Enumeration JSONDynamicObjectKind
public enum class JSONDynamicObjectKind
public enum class JSONDynamicObjectKind
type JSONDynamicObjectKind
type JSONDynamicObjectKind
Members
Member name | Value | Description
Map | 0 |
Array | 1 |
See Also
NFX.Serialization.JSON Namespace


JSONException Class

JSONException Class NFX Class Library

Base exception thrown by the JSON serialization format
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Serialization NFXSerializationException
NFX.Serialization.JSON JSONException
NFX.Serialization.JSON JSONDeserializationException
NFX.Serialization.JSON JSONSerializationException

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class JSONException : NFXSerializationException
[SerializableAttribute]
public class JSONException : NFXSerializationException
<SerializableAttribute>
Public Class JSONException
    Inherits NFXSerializationException
<SerializableAttribute>
Public Class JSONException
    Inherits NFXSerializationException
[SerializableAttribute]
public ref class JSONException : public NFXSerializationException
[SerializableAttribute]
public ref class JSONException : public NFXSerializationException
[<SerializableAttribute>]
type JSONException =
    class
        inherit NFXSerializationException
    end
[<SerializableAttribute>]
type JSONException =
    class
        inherit NFXSerializationException
    end
See Also
JSONException Members
NFX.Serialization.JSON Namespace


JSONException Members

JSONException Members NFX Class Library

The JSONException type exposes the following members.
Constructors
 | Name | Description
Public method | JSONException | Initializes a new instance of the JSONException class
Public method | JSONException(String) | Initializes a new instance of the JSONException class
Protected method | JSONException(SerializationInfo, StreamingContext) | Initializes a new instance of the JSONException class
Public method | JSONException(String, Exception) | Initializes a new instance of the JSONException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
JSONException Class
NFX.Serialization.JSON Namespace


JSONException Constructor

JSONException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | JSONException | Initializes a new instance of the JSONException class
Public method | JSONException(String) | Initializes a new instance of the JSONException class
Protected method | JSONException(SerializationInfo, StreamingContext) | Initializes a new instance of the JSONException class
Public method | JSONException(String, Exception) | Initializes a new instance of the JSONException class
Back to Top
See Also
JSONException Class
JSONException Members
NFX.Serialization.JSON Namespace


JSONException Constructor

JSONException Constructor NFX Class Library

Initializes a new instance of the JSONException class

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONException()
public JSONException()
Public Sub New
Public Sub New
public:
JSONException()
public:
JSONException()
new : unit -> JSONException
new : unit -> JSONException
See Also
JSONException Class
JSONException Members
JSONException Overload
NFX.Serialization.JSON Namespace


JSONException Constructor (String)

JSONException Constructor (String) NFX Class Library

Initializes a new instance of the JSONException class

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONException(
    string message
)
public JSONException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
JSONException(
    String^ message
)
public:
JSONException(
    String^ message
)
new :
        message : string -> JSONException
new :
        message : string -> JSONException

Parameters

message
Type: Online System String
See Also
JSONException Class
JSONException Members
JSONException Overload
NFX.Serialization.JSON Namespace


JSONException Constructor (SerializationInfo, StreamingContext)

JSONException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the JSONException class

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected JSONException(
    SerializationInfo info,
    StreamingContext context
)
protected JSONException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
JSONException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
JSONException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> JSONException
new :
        info : SerializationInfo *
        context : StreamingContext -> JSONException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
JSONException Class
JSONException Members
JSONException Overload
NFX.Serialization.JSON Namespace


JSONException Constructor (String, Exception)

JSONException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the JSONException class

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONException(
    string message,
    Exception inner
)
public JSONException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
JSONException(
    String^ message,
    Exception^ inner
)
public:
JSONException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> JSONException
new :
        message : string *
        inner : Exception -> JSONException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
JSONException Class
JSONException Members
JSONException Overload
NFX.Serialization.JSON Namespace


JSONException Methods

JSONException Methods NFX Class Library

The JSONException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
JSONException Class
NFX.Serialization.JSON Namespace


JSONException Properties

JSONException Properties NFX Class Library

The JSONException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
JSONException Class
NFX.Serialization.JSON Namespace


JSONException Events

JSONException Events NFX Class Library

The JSONException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
JSONException Class
NFX.Serialization.JSON Namespace


JSONExtensions Class

JSONExtensions Class NFX Class Library

Provides JSON extension methods
Inheritance Hierarchy
Online System Object
NFX.Serialization.JSON JSONExtensions

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class JSONExtensions
public static class JSONExtensions
<ExtensionAttribute>
Public NotInheritable Class JSONExtensions
<ExtensionAttribute>
Public NotInheritable Class JSONExtensions
[ExtensionAttribute]
public ref class JSONExtensions abstract sealed
[ExtensionAttribute]
public ref class JSONExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type JSONExtensions =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type JSONExtensions =  class end
See Also
JSONExtensions Members
NFX.Serialization.JSON Namespace


JSONExtensions Members

JSONExtensions Members NFX Class Library

Methods
Name | Description
JSONToDataObject(String, Boolean) | Deserializes JSON content into IJSONDataObject
JSONToDataObject(ISourceText, Boolean) | Deserializes JSON content into IJSONDataObject
JSONToDataObject(Stream, Encoding, Boolean) | Deserializes JSON content into IJSONDataObject
JSONToDynamic(String, Boolean) | Deserializes JSON content into dynamic JSON object
JSONToDynamic(ISourceText, Boolean) | Deserializes JSON content into dynamic JSON object
JSONToDynamic(Stream, Encoding, Boolean) | Deserializes JSON content into dynamic JSON object
ToJSON(Object, JSONWritingOptions) | Serializes object into JSON string
ToJSON(Object, TextWriter, JSONWritingOptions) | Serializes object into JSON format using provided TextWriter
ToJSON(Object, Stream, JSONWritingOptions, Encoding) | Serializes object into JSON format using provided stream and optional encoding
Back to Top
See Also
JSONExtensions Class
NFX.Serialization.JSON Namespace


JSONExtensions Methods

JSONExtensions Methods NFX Class Library

Methods
Name | Description
JSONToDataObject(String, Boolean) | Deserializes JSON content into IJSONDataObject
JSONToDataObject(ISourceText, Boolean) | Deserializes JSON content into IJSONDataObject
JSONToDataObject(Stream, Encoding, Boolean) | Deserializes JSON content into IJSONDataObject
JSONToDynamic(String, Boolean) | Deserializes JSON content into dynamic JSON object
JSONToDynamic(ISourceText, Boolean) | Deserializes JSON content into dynamic JSON object
JSONToDynamic(Stream, Encoding, Boolean) | Deserializes JSON content into dynamic JSON object
ToJSON(Object, JSONWritingOptions) | Serializes object into JSON string
ToJSON(Object, TextWriter, JSONWritingOptions) | Serializes object into JSON format using provided TextWriter
ToJSON(Object, Stream, JSONWritingOptions, Encoding) | Serializes object into JSON format using provided stream and optional encoding
Back to Top
See Also
JSONExtensions Class
NFX.Serialization.JSON Namespace


JSONExtensions.JSONToDataObject Method

JSONExtensions JSONToDataObject Method NFX Class Library

Overload List
Name | Description
JSONToDataObject(String, Boolean) | Deserializes JSON content into IJSONDataObject
JSONToDataObject(ISourceText, Boolean) | Deserializes JSON content into IJSONDataObject
JSONToDataObject(Stream, Encoding, Boolean) | Deserializes JSON content into IJSONDataObject
Back to Top
See Also
JSONExtensions Class
JSONExtensions Members
NFX.Serialization.JSON Namespace


JSONExtensions.JSONToDataObject Method (String, Boolean)

JSONExtensions JSONToDataObject Method (String, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Deserializes JSON content into IJSONDataObject

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IJSONDataObject JSONToDataObject(
    this string json,
    bool caseSensitiveMaps = true
)
public static IJSONDataObject JSONToDataObject(
    this string json,
    bool caseSensitiveMaps = true
)
<ExtensionAttribute>
Public Shared Function JSONToDataObject (
    json As String,
    Optional caseSensitiveMaps As Boolean = true
) As IJSONDataObject
<ExtensionAttribute>
Public Shared Function JSONToDataObject (
    json As String,
    Optional caseSensitiveMaps As Boolean = true
) As IJSONDataObject
public:
[ExtensionAttribute]
static IJSONDataObject^ JSONToDataObject(
    String^ json,
    bool caseSensitiveMaps = true
)
public:
[ExtensionAttribute]
static IJSONDataObject^ JSONToDataObject(
    String^ json,
    bool caseSensitiveMaps = true
)
static member JSONToDataObject :
        json : string *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> IJSONDataObject
static member JSONToDataObject :
        json : string *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> IJSONDataObject

Parameters

json
Type: Online System String
caseSensitiveMaps (Optional)
Type: Online System Boolean

Return Value

Type: IJSONDataObject

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
JSONExtensions Class
JSONExtensions Members
JSONToDataObject Overload
NFX.Serialization.JSON Namespace


JSONExtensions.JSONToDataObject Method (ISourceText, Boolean)

JSONExtensions JSONToDataObject Method (ISourceText, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Deserializes JSON content into IJSONDataObject

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IJSONDataObject JSONToDataObject(
    this ISourceText json,
    bool caseSensitiveMaps = true
)
public static IJSONDataObject JSONToDataObject(
    this ISourceText json,
    bool caseSensitiveMaps = true
)
<ExtensionAttribute>
Public Shared Function JSONToDataObject (
    json As ISourceText,
    Optional caseSensitiveMaps As Boolean = true
) As IJSONDataObject
<ExtensionAttribute>
Public Shared Function JSONToDataObject (
    json As ISourceText,
    Optional caseSensitiveMaps As Boolean = true
) As IJSONDataObject
public:
[ExtensionAttribute]
static IJSONDataObject^ JSONToDataObject(
    ISourceText^ json,
    bool caseSensitiveMaps = true
)
public:
[ExtensionAttribute]
static IJSONDataObject^ JSONToDataObject(
    ISourceText^ json,
    bool caseSensitiveMaps = true
)
static member JSONToDataObject :
        json : ISourceText *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> IJSONDataObject
static member JSONToDataObject :
        json : ISourceText *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> IJSONDataObject

Parameters

json
Type: NFX.CodeAnalysis.Source ISourceText
caseSensitiveMaps (Optional)
Type: Online System Boolean

Return Value

Type: IJSONDataObject

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISourceText. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
JSONExtensions Class
JSONExtensions Members
JSONToDataObject Overload
NFX.Serialization.JSON Namespace


JSONExtensions.JSONToDataObject Method (Stream, Encoding, Boolean)

JSONExtensions JSONToDataObject Method (Stream, Encoding, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Deserializes JSON content into IJSONDataObject

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IJSONDataObject JSONToDataObject(
    this Stream json,
    Encoding encoding = null,
    bool caseSensitiveMaps = true
)
public static IJSONDataObject JSONToDataObject(
    this Stream json,
    Encoding encoding = null,
    bool caseSensitiveMaps = true
)
<ExtensionAttribute>
Public Shared Function JSONToDataObject (
    json As Stream,
    Optional encoding As Encoding = Nothing,
    Optional caseSensitiveMaps As Boolean = true
) As IJSONDataObject
<ExtensionAttribute>
Public Shared Function JSONToDataObject (
    json As Stream,
    Optional encoding As Encoding = Nothing,
    Optional caseSensitiveMaps As Boolean = true
) As IJSONDataObject
public:
[ExtensionAttribute]
static IJSONDataObject^ JSONToDataObject(
    Stream^ json,
    Encoding^ encoding = nullptr,
    bool caseSensitiveMaps = true
)
public:
[ExtensionAttribute]
static IJSONDataObject^ JSONToDataObject(
    Stream^ json,
    Encoding^ encoding = nullptr,
    bool caseSensitiveMaps = true
)
static member JSONToDataObject :
        json : Stream *
        ?encoding : Encoding *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _encoding = defaultArg encoding null
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> IJSONDataObject
static member JSONToDataObject :
        json : Stream *
        ?encoding : Encoding *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _encoding = defaultArg encoding null
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> IJSONDataObject

Parameters

json
Type: Online System.IO Stream
encoding (Optional)
Type: Online System.Text Encoding
caseSensitiveMaps (Optional)
Type: Online System Boolean

Return Value

Type: IJSONDataObject

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
JSONExtensions Class
JSONExtensions Members
JSONToDataObject Overload
NFX.Serialization.JSON Namespace


JSONExtensions.JSONToDynamic Method

JSONExtensions JSONToDynamic Method NFX Class Library

Overload List
Name | Description
JSONToDynamic(String, Boolean) | Deserializes JSON content into dynamic JSON object
JSONToDynamic(ISourceText, Boolean) | Deserializes JSON content into dynamic JSON object
JSONToDynamic(Stream, Encoding, Boolean) | Deserializes JSON content into dynamic JSON object
Back to Top
See Also
JSONExtensions Class
JSONExtensions Members
NFX.Serialization.JSON Namespace


JSONExtensions.JSONToDynamic Method (String, Boolean)

JSONExtensions JSONToDynamic Method (String, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Deserializes JSON content into dynamic JSON object

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Object JSONToDynamic(
    this string json,
    bool caseSensitiveMaps = true
)
public static Object JSONToDynamic(
    this string json,
    bool caseSensitiveMaps = true
)
<ExtensionAttribute>
Public Shared Function JSONToDynamic (
    json As String,
    Optional caseSensitiveMaps As Boolean = true
) As Object
<ExtensionAttribute>
Public Shared Function JSONToDynamic (
    json As String,
    Optional caseSensitiveMaps As Boolean = true
) As Object
public:
[ExtensionAttribute]
static Object^ JSONToDynamic(
    String^ json,
    bool caseSensitiveMaps = true
)
public:
[ExtensionAttribute]
static Object^ JSONToDynamic(
    String^ json,
    bool caseSensitiveMaps = true
)
static member JSONToDynamic :
        json : string *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> Object
static member JSONToDynamic :
        json : string *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> Object

Parameters

json
Type: Online System String
caseSensitiveMaps (Optional)
Type: Online System Boolean

Return Value

Type: Online Object

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
JSONExtensions Class
JSONExtensions Members
JSONToDynamic Overload
NFX.Serialization.JSON Namespace


JSONExtensions.JSONToDynamic Method (ISourceText, Boolean)

JSONExtensions JSONToDynamic Method (ISourceText, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Deserializes JSON content into dynamic JSON object

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Object JSONToDynamic(
    this ISourceText json,
    bool caseSensitiveMaps = true
)
public static Object JSONToDynamic(
    this ISourceText json,
    bool caseSensitiveMaps = true
)
<ExtensionAttribute>
Public Shared Function JSONToDynamic (
    json As ISourceText,
    Optional caseSensitiveMaps As Boolean = true
) As Object
<ExtensionAttribute>
Public Shared Function JSONToDynamic (
    json As ISourceText,
    Optional caseSensitiveMaps As Boolean = true
) As Object
public:
[ExtensionAttribute]
static Object^ JSONToDynamic(
    ISourceText^ json,
    bool caseSensitiveMaps = true
)
public:
[ExtensionAttribute]
static Object^ JSONToDynamic(
    ISourceText^ json,
    bool caseSensitiveMaps = true
)
static member JSONToDynamic :
        json : ISourceText *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> Object
static member JSONToDynamic :
        json : ISourceText *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> Object

Parameters

json
Type: NFX.CodeAnalysis.Source ISourceText
caseSensitiveMaps (Optional)
Type: Online System Boolean

Return Value

Type: Online Object

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISourceText. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
JSONExtensions Class
JSONExtensions Members
JSONToDynamic Overload
NFX.Serialization.JSON Namespace


JSONExtensions.JSONToDynamic Method (Stream, Encoding, Boolean)

JSONExtensions JSONToDynamic Method (Stream, Encoding, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Deserializes JSON content into dynamic JSON object

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Object JSONToDynamic(
    this Stream json,
    Encoding encoding = null,
    bool caseSensitiveMaps = true
)
public static Object JSONToDynamic(
    this Stream json,
    Encoding encoding = null,
    bool caseSensitiveMaps = true
)
<ExtensionAttribute>
Public Shared Function JSONToDynamic (
    json As Stream,
    Optional encoding As Encoding = Nothing,
    Optional caseSensitiveMaps As Boolean = true
) As Object
<ExtensionAttribute>
Public Shared Function JSONToDynamic (
    json As Stream,
    Optional encoding As Encoding = Nothing,
    Optional caseSensitiveMaps As Boolean = true
) As Object
public:
[ExtensionAttribute]
static Object^ JSONToDynamic(
    Stream^ json,
    Encoding^ encoding = nullptr,
    bool caseSensitiveMaps = true
)
public:
[ExtensionAttribute]
static Object^ JSONToDynamic(
    Stream^ json,
    Encoding^ encoding = nullptr,
    bool caseSensitiveMaps = true
)
static member JSONToDynamic :
        json : Stream *
        ?encoding : Encoding *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _encoding = defaultArg encoding null
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> Object
static member JSONToDynamic :
        json : Stream *
        ?encoding : Encoding *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _encoding = defaultArg encoding null
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> Object

Parameters

json
Type: Online System.IO Stream
encoding (Optional)
Type: Online System.Text Encoding
caseSensitiveMaps (Optional)
Type: Online System Boolean

Return Value

Type: Online Object

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
JSONExtensions Class
JSONExtensions Members
JSONToDynamic Overload
NFX.Serialization.JSON Namespace


JSONExtensions.ToJSON Method

JSONExtensions ToJSON Method NFX Class Library

Overload List
Name | Description
ToJSON(Object, JSONWritingOptions) | Serializes object into JSON string
ToJSON(Object, TextWriter, JSONWritingOptions) | Serializes object into JSON format using provided TextWriter
ToJSON(Object, Stream, JSONWritingOptions, Encoding) | Serializes object into JSON format using provided stream and optional encoding
Back to Top
See Also
JSONExtensions Class
JSONExtensions Members
NFX.Serialization.JSON Namespace


JSONExtensions.ToJSON Method (Object, JSONWritingOptions)

JSONExtensions ToJSON Method (Object, JSONWritingOptions) NFX Class Library

[This is preliminary documentation and is subject to change.]

Serializes object into JSON string

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ToJSON(
    this Object root,
    JSONWritingOptions options = null
)
public static string ToJSON(
    this Object root,
    JSONWritingOptions options = null
)
<ExtensionAttribute>
Public Shared Function ToJSON (
    root As Object,
    Optional options As JSONWritingOptions = Nothing
) As String
<ExtensionAttribute>
Public Shared Function ToJSON (
    root As Object,
    Optional options As JSONWritingOptions = Nothing
) As String
public:
[ExtensionAttribute]
static String^ ToJSON(
    Object^ root,
    JSONWritingOptions^ options = nullptr
)
public:
[ExtensionAttribute]
static String^ ToJSON(
    Object^ root,
    JSONWritingOptions^ options = nullptr
)
static member ToJSON :
        root : Object *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> string
static member ToJSON :
        root : Object *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> string

Parameters

root
Type: Online System Object
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Return Value

Type: Online String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
JSONExtensions Class
JSONExtensions Members
ToJSON Overload
NFX.Serialization.JSON Namespace


JSONExtensions.ToJSON Method (Object, TextWriter, JSONWritingOptions)

JSONExtensions ToJSON Method (Object, TextWriter, JSONWritingOptions) NFX Class Library

[This is preliminary documentation and is subject to change.]

Serializes object into JSON format using provided TextWriter

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ToJSON(
    this Object root,
    TextWriter wri,
    JSONWritingOptions options = null
)
public static void ToJSON(
    this Object root,
    TextWriter wri,
    JSONWritingOptions options = null
)
<ExtensionAttribute>
Public Shared Sub ToJSON (
    root As Object,
    wri As TextWriter,
    Optional options As JSONWritingOptions = Nothing
)
<ExtensionAttribute>
Public Shared Sub ToJSON (
    root As Object,
    wri As TextWriter,
    Optional options As JSONWritingOptions = Nothing
)
public:
[ExtensionAttribute]
static void ToJSON(
    Object^ root,
    TextWriter^ wri,
    JSONWritingOptions^ options = nullptr
)
public:
[ExtensionAttribute]
static void ToJSON(
    Object^ root,
    TextWriter^ wri,
    JSONWritingOptions^ options = nullptr
)
static member ToJSON :
        root : Object *
        wri : TextWriter *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
static member ToJSON :
        root : Object *
        wri : TextWriter *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

root
Type: Online System Object
wri
Type: Online System.IO TextWriter
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
JSONExtensions Class
JSONExtensions Members
ToJSON Overload
NFX.Serialization.JSON Namespace


JSONExtensions.ToJSON Method (Object, Stream, JSONWritingOptions, Encoding)

JSONExtensions ToJSON Method (Object, Stream, JSONWritingOptions, Encoding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Serializes object into JSON format using provided stream and optional encoding

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ToJSON(
    this Object root,
    Stream stream,
    JSONWritingOptions options = null,
    Encoding encoding = null
)
public static void ToJSON(
    this Object root,
    Stream stream,
    JSONWritingOptions options = null,
    Encoding encoding = null
)
<ExtensionAttribute>
Public Shared Sub ToJSON (
    root As Object,
    stream As Stream,
    Optional options As JSONWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing
)
<ExtensionAttribute>
Public Shared Sub ToJSON (
    root As Object,
    stream As Stream,
    Optional options As JSONWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing
)
public:
[ExtensionAttribute]
static void ToJSON(
    Object^ root,
    Stream^ stream,
    JSONWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr
)
public:
[ExtensionAttribute]
static void ToJSON(
    Object^ root,
    Stream^ stream,
    JSONWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr
)
static member ToJSON :
        root : Object *
        stream : Stream *
        ?options : JSONWritingOptions *
        ?encoding : Encoding
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
*)
-> unit
static member ToJSON :
        root : Object *
        stream : Stream *
        ?options : JSONWritingOptions *
        ?encoding : Encoding
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
*)
-> unit

Parameters

root
Type: Online System Object
stream
Type: Online System.IO Stream
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions
encoding (Optional)
Type: Online System.Text Encoding

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Online Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Online Extension Methods (Visual Basic) or Online Extension Methods (C# Programming Guide).
See Also
JSONExtensions Class
JSONExtensions Members
ToJSON Overload
NFX.Serialization.JSON Namespace


JSONReader Class

JSONReader Class NFX Class Library

Provides deserialization functionality from JSON format
Inheritance Hierarchy
Online System Object
NFX.Serialization.JSON JSONReader

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class JSONReader
public static class JSONReader
Public NotInheritable Class JSONReader
Public NotInheritable Class JSONReader
public ref class JSONReader abstract sealed
public ref class JSONReader abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type JSONReader =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type JSONReader =  class end
See Also
JSONReader Members
NFX.Serialization.JSON Namespace


JSONReader Members

JSONReader Members NFX Class Library

The JSONReader type exposes the following members.
Methods
Name | Description
DeserializeDataObject(String, Boolean) |
DeserializeDataObject(ISourceText, Boolean) |
DeserializeDataObject(Stream, Encoding, Boolean) |
DeserializeDataObjectFromFile |
DeserializeDynamic(String, Boolean) |
DeserializeDynamic(ISourceText, Boolean) |
DeserializeDynamic(Stream, Encoding, Boolean) |
ToRow(Type, JSONDataMap, Boolean) | Converts JSONMap into typed row of the requested type. The requested type must be derived from NFX.DataAccess.CRUD.TypedRow. The extra data found in JSON map will be placed in AmorphousData dictionary if the row implemets IAmorphousData, discarded otherwise. Note: This method provides "the best match" and does not guarantee that all data will/can be converted from JSON, i.e. it can only convert one dimensional arrays and Lists of either primitive or TypeRow-derived entries
ToRow(Row, JSONDataMap, Boolean) | Converts JSONMap into supplied row instance. The extra data found in JSON map will be placed in AmorphousData dictionary if the row implemets IAmorphousData, discarded otherwise. Note: This method provides "the best match" and does not guarantee that all data will/can be converted from JSON, i.e. it can only convert one dimensional arrays and Lists of either primitive or TypeRow-derived entries
ToRow T (JSONDataMap, Boolean) | Generic version of ToRow(Type, JSONDataMap, Boolean)
ToRowset(String, Boolean, Boolean) | Deserializes into Rowset or Table from JSOnDataMap, as serialized by RowsedBase.WriteAsJSON()
ToRowset(JSONDataMap, Boolean, Boolean) | Deserializes into Rowset or Table from JSONDataMap, as serialized by RowsedBase.WriteAsJSON()
Back to Top
See Also
JSONReader Class
NFX.Serialization.JSON Namespace


JSONReader Methods

JSONReader Methods NFX Class Library

The JSONReader type exposes the following members.
Methods
Name | Description
DeserializeDataObject(String, Boolean) |
DeserializeDataObject(ISourceText, Boolean) |
DeserializeDataObject(Stream, Encoding, Boolean) |
DeserializeDataObjectFromFile |
DeserializeDynamic(String, Boolean) |
DeserializeDynamic(ISourceText, Boolean) |
DeserializeDynamic(Stream, Encoding, Boolean) |
ToRow(Type, JSONDataMap, Boolean) | Converts JSONMap into typed row of the requested type. The requested type must be derived from NFX.DataAccess.CRUD.TypedRow. The extra data found in JSON map will be placed in AmorphousData dictionary if the row implemets IAmorphousData, discarded otherwise. Note: This method provides "the best match" and does not guarantee that all data will/can be converted from JSON, i.e. it can only convert one dimensional arrays and Lists of either primitive or TypeRow-derived entries
ToRow(Row, JSONDataMap, Boolean) | Converts JSONMap into supplied row instance. The extra data found in JSON map will be placed in AmorphousData dictionary if the row implemets IAmorphousData, discarded otherwise. Note: This method provides "the best match" and does not guarantee that all data will/can be converted from JSON, i.e. it can only convert one dimensional arrays and Lists of either primitive or TypeRow-derived entries
ToRow T (JSONDataMap, Boolean) | Generic version of ToRow(Type, JSONDataMap, Boolean)
ToRowset(String, Boolean, Boolean) | Deserializes into Rowset or Table from JSOnDataMap, as serialized by RowsedBase.WriteAsJSON()
ToRowset(JSONDataMap, Boolean, Boolean) | Deserializes into Rowset or Table from JSONDataMap, as serialized by RowsedBase.WriteAsJSON()
Back to Top
See Also
JSONReader Class
NFX.Serialization.JSON Namespace


JSONReader.DeserializeDataObject Method

JSONReader DeserializeDataObject Method NFX Class Library

Overload List
Name | Description
DeserializeDataObject(String, Boolean) |
DeserializeDataObject(ISourceText, Boolean) |
DeserializeDataObject(Stream, Encoding, Boolean) |
Back to Top
See Also
JSONReader Class
JSONReader Members
NFX.Serialization.JSON Namespace


JSONReader.DeserializeDataObject Method (String, Boolean)

JSONReader DeserializeDataObject Method (String, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IJSONDataObject DeserializeDataObject(
    string source,
    bool caseSensitiveMaps = true
)
public static IJSONDataObject DeserializeDataObject(
    string source,
    bool caseSensitiveMaps = true
)
Public Shared Function DeserializeDataObject (
    source As String,
    Optional caseSensitiveMaps As Boolean = true
) As IJSONDataObject
Public Shared Function DeserializeDataObject (
    source As String,
    Optional caseSensitiveMaps As Boolean = true
) As IJSONDataObject
public:
static IJSONDataObject^ DeserializeDataObject(
    String^ source,
    bool caseSensitiveMaps = true
)
public:
static IJSONDataObject^ DeserializeDataObject(
    String^ source,
    bool caseSensitiveMaps = true
)
static member DeserializeDataObject :
        source : string *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> IJSONDataObject
static member DeserializeDataObject :
        source : string *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> IJSONDataObject

Parameters

source
Type: Online System String
caseSensitiveMaps (Optional)
Type: Online System Boolean

Return Value

Type: IJSONDataObject
See Also
JSONReader Class
JSONReader Members
DeserializeDataObject Overload
NFX.Serialization.JSON Namespace


JSONReader.DeserializeDataObject Method (ISourceText, Boolean)

JSONReader DeserializeDataObject Method (ISourceText, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IJSONDataObject DeserializeDataObject(
    ISourceText source,
    bool caseSensitiveMaps = true
)
public static IJSONDataObject DeserializeDataObject(
    ISourceText source,
    bool caseSensitiveMaps = true
)
Public Shared Function DeserializeDataObject (
    source As ISourceText,
    Optional caseSensitiveMaps As Boolean = true
) As IJSONDataObject
Public Shared Function DeserializeDataObject (
    source As ISourceText,
    Optional caseSensitiveMaps As Boolean = true
) As IJSONDataObject
public:
static IJSONDataObject^ DeserializeDataObject(
    ISourceText^ source,
    bool caseSensitiveMaps = true
)
public:
static IJSONDataObject^ DeserializeDataObject(
    ISourceText^ source,
    bool caseSensitiveMaps = true
)
static member DeserializeDataObject :
        source : ISourceText *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> IJSONDataObject
static member DeserializeDataObject :
        source : ISourceText *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> IJSONDataObject

Parameters

source
Type: NFX.CodeAnalysis.Source ISourceText
caseSensitiveMaps (Optional)
Type: Online System Boolean

Return Value

Type: IJSONDataObject
See Also
JSONReader Class
JSONReader Members
DeserializeDataObject Overload
NFX.Serialization.JSON Namespace


JSONReader.DeserializeDataObject Method (Stream, Encoding, Boolean)

JSONReader DeserializeDataObject Method (Stream, Encoding, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IJSONDataObject DeserializeDataObject(
    Stream stream,
    Encoding encoding = null,
    bool caseSensitiveMaps = true
)
public static IJSONDataObject DeserializeDataObject(
    Stream stream,
    Encoding encoding = null,
    bool caseSensitiveMaps = true
)
Public Shared Function DeserializeDataObject (
    stream As Stream,
    Optional encoding As Encoding = Nothing,
    Optional caseSensitiveMaps As Boolean = true
) As IJSONDataObject
Public Shared Function DeserializeDataObject (
    stream As Stream,
    Optional encoding As Encoding = Nothing,
    Optional caseSensitiveMaps As Boolean = true
) As IJSONDataObject
public:
static IJSONDataObject^ DeserializeDataObject(
    Stream^ stream,
    Encoding^ encoding = nullptr,
    bool caseSensitiveMaps = true
)
public:
static IJSONDataObject^ DeserializeDataObject(
    Stream^ stream,
    Encoding^ encoding = nullptr,
    bool caseSensitiveMaps = true
)
static member DeserializeDataObject :
        stream : Stream *
        ?encoding : Encoding *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _encoding = defaultArg encoding null
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> IJSONDataObject
static member DeserializeDataObject :
        stream : Stream *
        ?encoding : Encoding *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _encoding = defaultArg encoding null
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> IJSONDataObject

Parameters

stream
Type: Online System.IO Stream
encoding (Optional)
Type: Online System.Text Encoding
caseSensitiveMaps (Optional)
Type: Online System Boolean

Return Value

Type: IJSONDataObject
See Also
JSONReader Class
JSONReader Members
DeserializeDataObject Overload
NFX.Serialization.JSON Namespace


JSONReader.DeserializeDataObjectFromFile Method

JSONReader DeserializeDataObjectFromFile Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IJSONDataObject DeserializeDataObjectFromFile(
    string filePath,
    Encoding encoding = null,
    bool caseSensitiveMaps = true
)
public static IJSONDataObject DeserializeDataObjectFromFile(
    string filePath,
    Encoding encoding = null,
    bool caseSensitiveMaps = true
)
Public Shared Function DeserializeDataObjectFromFile (
    filePath As String,
    Optional encoding As Encoding = Nothing,
    Optional caseSensitiveMaps As Boolean = true
) As IJSONDataObject
Public Shared Function DeserializeDataObjectFromFile (
    filePath As String,
    Optional encoding As Encoding = Nothing,
    Optional caseSensitiveMaps As Boolean = true
) As IJSONDataObject
public:
static IJSONDataObject^ DeserializeDataObjectFromFile(
    String^ filePath,
    Encoding^ encoding = nullptr,
    bool caseSensitiveMaps = true
)
public:
static IJSONDataObject^ DeserializeDataObjectFromFile(
    String^ filePath,
    Encoding^ encoding = nullptr,
    bool caseSensitiveMaps = true
)
static member DeserializeDataObjectFromFile :
        filePath : string *
        ?encoding : Encoding *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _encoding = defaultArg encoding null
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> IJSONDataObject
static member DeserializeDataObjectFromFile :
        filePath : string *
        ?encoding : Encoding *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _encoding = defaultArg encoding null
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> IJSONDataObject

Parameters

filePath
Type: Online System String
encoding (Optional)
Type: Online System.Text Encoding
caseSensitiveMaps (Optional)
Type: Online System Boolean

Return Value

Type: IJSONDataObject
See Also
JSONReader Class
JSONReader Members
NFX.Serialization.JSON Namespace


JSONReader.DeserializeDynamic Method

JSONReader DeserializeDynamic Method NFX Class Library

Overload List
Name | Description
DeserializeDynamic(String, Boolean) |
DeserializeDynamic(ISourceText, Boolean) |
DeserializeDynamic(Stream, Encoding, Boolean) |
Back to Top
See Also
JSONReader Class
JSONReader Members
NFX.Serialization.JSON Namespace


JSONReader.DeserializeDynamic Method (String, Boolean)

JSONReader DeserializeDynamic Method (String, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Object DeserializeDynamic(
    string source,
    bool caseSensitiveMaps = true
)
public static Object DeserializeDynamic(
    string source,
    bool caseSensitiveMaps = true
)
Public Shared Function DeserializeDynamic (
    source As String,
    Optional caseSensitiveMaps As Boolean = true
) As Object
Public Shared Function DeserializeDynamic (
    source As String,
    Optional caseSensitiveMaps As Boolean = true
) As Object
public:
static Object^ DeserializeDynamic(
    String^ source,
    bool caseSensitiveMaps = true
)
public:
static Object^ DeserializeDynamic(
    String^ source,
    bool caseSensitiveMaps = true
)
static member DeserializeDynamic :
        source : string *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> Object
static member DeserializeDynamic :
        source : string *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> Object

Parameters

source
Type: Online System String
caseSensitiveMaps (Optional)
Type: Online System Boolean

Return Value

Type: Online Object
See Also
JSONReader Class
JSONReader Members
DeserializeDynamic Overload
NFX.Serialization.JSON Namespace


JSONReader.DeserializeDynamic Method (ISourceText, Boolean)

JSONReader DeserializeDynamic Method (ISourceText, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Object DeserializeDynamic(
    ISourceText source,
    bool caseSensitiveMaps = true
)
public static Object DeserializeDynamic(
    ISourceText source,
    bool caseSensitiveMaps = true
)
Public Shared Function DeserializeDynamic (
    source As ISourceText,
    Optional caseSensitiveMaps As Boolean = true
) As Object
Public Shared Function DeserializeDynamic (
    source As ISourceText,
    Optional caseSensitiveMaps As Boolean = true
) As Object
public:
static Object^ DeserializeDynamic(
    ISourceText^ source,
    bool caseSensitiveMaps = true
)
public:
static Object^ DeserializeDynamic(
    ISourceText^ source,
    bool caseSensitiveMaps = true
)
static member DeserializeDynamic :
        source : ISourceText *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> Object
static member DeserializeDynamic :
        source : ISourceText *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> Object

Parameters

source
Type: NFX.CodeAnalysis.Source ISourceText
caseSensitiveMaps (Optional)
Type: Online System Boolean

Return Value

Type: Online Object
See Also
JSONReader Class
JSONReader Members
DeserializeDynamic Overload
NFX.Serialization.JSON Namespace


JSONReader.DeserializeDynamic Method (Stream, Encoding, Boolean)

JSONReader DeserializeDynamic Method (Stream, Encoding, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Object DeserializeDynamic(
    Stream stream,
    Encoding encoding = null,
    bool caseSensitiveMaps = true
)
public static Object DeserializeDynamic(
    Stream stream,
    Encoding encoding = null,
    bool caseSensitiveMaps = true
)
Public Shared Function DeserializeDynamic (
    stream As Stream,
    Optional encoding As Encoding = Nothing,
    Optional caseSensitiveMaps As Boolean = true
) As Object
Public Shared Function DeserializeDynamic (
    stream As Stream,
    Optional encoding As Encoding = Nothing,
    Optional caseSensitiveMaps As Boolean = true
) As Object
public:
static Object^ DeserializeDynamic(
    Stream^ stream,
    Encoding^ encoding = nullptr,
    bool caseSensitiveMaps = true
)
public:
static Object^ DeserializeDynamic(
    Stream^ stream,
    Encoding^ encoding = nullptr,
    bool caseSensitiveMaps = true
)
static member DeserializeDynamic :
        stream : Stream *
        ?encoding : Encoding *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _encoding = defaultArg encoding null
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> Object
static member DeserializeDynamic :
        stream : Stream *
        ?encoding : Encoding *
        ?caseSensitiveMaps : bool
(* Defaults:
        let _encoding = defaultArg encoding null
        let _caseSensitiveMaps = defaultArg caseSensitiveMaps true
*)
-> Object

Parameters

stream
Type: Online System.IO Stream
encoding (Optional)
Type: Online System.Text Encoding
caseSensitiveMaps (Optional)
Type: Online System Boolean

Return Value

Type: Online Object
See Also
JSONReader Class
JSONReader Members
DeserializeDynamic Overload
NFX.Serialization.JSON Namespace


JSONReader.ToRow Method

JSONReader ToRow Method NFX Class Library

Overload List
Name | Description
ToRow T (JSONDataMap, Boolean) | Generic version of ToRow(Type, JSONDataMap, Boolean)
ToRow(Type, JSONDataMap, Boolean) | Converts JSONMap into typed row of the requested type. The requested type must be derived from NFX.DataAccess.CRUD.TypedRow. The extra data found in JSON map will be placed in AmorphousData dictionary if the row implemets IAmorphousData, discarded otherwise. Note: This method provides "the best match" and does not guarantee that all data will/can be converted from JSON, i.e. it can only convert one dimensional arrays and Lists of either primitive or TypeRow-derived entries
ToRow(Row, JSONDataMap, Boolean) | Converts JSONMap into supplied row instance. The extra data found in JSON map will be placed in AmorphousData dictionary if the row implemets IAmorphousData, discarded otherwise. Note: This method provides "the best match" and does not guarantee that all data will/can be converted from JSON, i.e. it can only convert one dimensional arrays and Lists of either primitive or TypeRow-derived entries
Back to Top
See Also
JSONReader Class
JSONReader Members
NFX.Serialization.JSON Namespace


JSONReader.ToRow(T) Method (JSONDataMap, Boolean)

JSONReader ToRow T Method (JSONDataMap, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Generic version of ToRow(Type, JSONDataMap, Boolean)

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static T ToRow<T>(
    JSONDataMap jsonMap,
    bool fromUI = true
)
where T : TypedRow
public static T ToRow<T>(
    JSONDataMap jsonMap,
    bool fromUI = true
)
where T : TypedRow
Public Shared Function ToRow(Of T As TypedRow) (
    jsonMap As JSONDataMap,
    Optional fromUI As Boolean = true
) As T
Public Shared Function ToRow(Of T As TypedRow) (
    jsonMap As JSONDataMap,
    Optional fromUI As Boolean = true
) As T
public:
generic<typename T>
where T : TypedRow
static T ToRow(
    JSONDataMap^ jsonMap,
    bool fromUI = true
)
public:
generic<typename T>
where T : TypedRow
static T ToRow(
    JSONDataMap^ jsonMap,
    bool fromUI = true
)
static member ToRow :
        jsonMap : JSONDataMap *
        ?fromUI : bool
(* Defaults:
        let _fromUI = defaultArg fromUI true
*)
-> 'T  when 'T : TypedRow
static member ToRow :
        jsonMap : JSONDataMap *
        ?fromUI : bool
(* Defaults:
        let _fromUI = defaultArg fromUI true
*)
-> 'T  when 'T : TypedRow

Parameters

jsonMap
Type: NFX.Serialization.JSON JSONDataMap
fromUI (Optional)
Type: Online System Boolean
Type Parameters
T
TypedRow

Return Value

Type: T
See Also
JSONReader Class
JSONReader Members
ToRow Overload
NFX.Serialization.JSON Namespace


JSONReader.ToRow Method (Type, JSONDataMap, Boolean)

JSONReader ToRow Method (Type, JSONDataMap, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Converts JSONMap into typed row of the requested type. The requested type must be derived from NFX.DataAccess.CRUD.TypedRow. The extra data found in JSON map will be placed in AmorphousData dictionary if the row implemets IAmorphousData, discarded otherwise. Note: This method provides "the best match" and does not guarantee that all data will/can be converted from JSON, i.e. it can only convert one dimensional arrays and Lists of either primitive or TypeRow-derived entries

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static TypedRow ToRow(
    Type type,
    JSONDataMap jsonMap,
    bool fromUI = true
)
public static TypedRow ToRow(
    Type type,
    JSONDataMap jsonMap,
    bool fromUI = true
)
Public Shared Function ToRow (
    type As Type,
    jsonMap As JSONDataMap,
    Optional fromUI As Boolean = true
) As TypedRow
Public Shared Function ToRow (
    type As Type,
    jsonMap As JSONDataMap,
    Optional fromUI As Boolean = true
) As TypedRow
public:
static TypedRow^ ToRow(
    Type^ type,
    JSONDataMap^ jsonMap,
    bool fromUI = true
)
public:
static TypedRow^ ToRow(
    Type^ type,
    JSONDataMap^ jsonMap,
    bool fromUI = true
)
static member ToRow :
        type : Type *
        jsonMap : JSONDataMap *
        ?fromUI : bool
(* Defaults:
        let _fromUI = defaultArg fromUI true
*)
-> TypedRow
static member ToRow :
        type : Type *
        jsonMap : JSONDataMap *
        ?fromUI : bool
(* Defaults:
        let _fromUI = defaultArg fromUI true
*)
-> TypedRow

Parameters

type
Type: Online System Type
TypedRow subtype to convert into
jsonMap
Type: NFX.Serialization.JSON JSONDataMap
JSON data to convert into row
fromUI (Optional)
Type: Online System Boolean
When true indicates that data came from UI, hence NonUI-marked fields should be skipped. True by default

Return Value

Type: TypedRow
See Also
JSONReader Class
JSONReader Members
ToRow Overload
NFX.Serialization.JSON Namespace


JSONReader.ToRow Method (Row, JSONDataMap, Boolean)

JSONReader ToRow Method (Row, JSONDataMap, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Converts JSONMap into supplied row instance. The extra data found in JSON map will be placed in AmorphousData dictionary if the row implemets IAmorphousData, discarded otherwise. Note: This method provides "the best match" and does not guarantee that all data will/can be converted from JSON, i.e. it can only convert one dimensional arrays and Lists of either primitive or TypeRow-derived entries

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void ToRow(
    Row row,
    JSONDataMap jsonMap,
    bool fromUI = true
)
public static void ToRow(
    Row row,
    JSONDataMap jsonMap,
    bool fromUI = true
)
Public Shared Sub ToRow (
    row As Row,
    jsonMap As JSONDataMap,
    Optional fromUI As Boolean = true
)
Public Shared Sub ToRow (
    row As Row,
    jsonMap As JSONDataMap,
    Optional fromUI As Boolean = true
)
public:
static void ToRow(
    Row^ row,
    JSONDataMap^ jsonMap,
    bool fromUI = true
)
public:
static void ToRow(
    Row^ row,
    JSONDataMap^ jsonMap,
    bool fromUI = true
)
static member ToRow :
        row : Row *
        jsonMap : JSONDataMap *
        ?fromUI : bool
(* Defaults:
        let _fromUI = defaultArg fromUI true
*)
-> unit
static member ToRow :
        row : Row *
        jsonMap : JSONDataMap *
        ?fromUI : bool
(* Defaults:
        let _fromUI = defaultArg fromUI true
*)
-> unit

Parameters

row
Type: NFX.DataAccess.CRUD Row
Row instance to convert into
jsonMap
Type: NFX.Serialization.JSON JSONDataMap
JSON data to convert into row
fromUI (Optional)
Type: Online System Boolean
When true indicates that data came from UI, hence NonUI-marked fields should be skipped. True by default
See Also
JSONReader Class
JSONReader Members
ToRow Overload
NFX.Serialization.JSON Namespace


JSONReader.ToRowset Method

JSONReader ToRowset Method NFX Class Library

Overload List
Name | Description
ToRowset(String, Boolean, Boolean) | Deserializes into Rowset or Table from JSOnDataMap, as serialized by RowsedBase.WriteAsJSON()
ToRowset(JSONDataMap, Boolean, Boolean) | Deserializes into Rowset or Table from JSONDataMap, as serialized by RowsedBase.WriteAsJSON()
Back to Top
See Also
JSONReader Class
JSONReader Members
NFX.Serialization.JSON Namespace


JSONReader.ToRowset Method (String, Boolean, Boolean)

JSONReader ToRowset Method (String, Boolean, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Deserializes into Rowset or Table from JSOnDataMap, as serialized by RowsedBase.WriteAsJSON()

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static RowsetBase ToRowset(
    string json,
    bool schemaOnly = false,
    bool readOnlySchema = false
)
public static RowsetBase ToRowset(
    string json,
    bool schemaOnly = false,
    bool readOnlySchema = false
)
Public Shared Function ToRowset (
    json As String,
    Optional schemaOnly As Boolean = false,
    Optional readOnlySchema As Boolean = false
) As RowsetBase
Public Shared Function ToRowset (
    json As String,
    Optional schemaOnly As Boolean = false,
    Optional readOnlySchema As Boolean = false
) As RowsetBase
public:
static RowsetBase^ ToRowset(
    String^ json,
    bool schemaOnly = false,
    bool readOnlySchema = false
)
public:
static RowsetBase^ ToRowset(
    String^ json,
    bool schemaOnly = false,
    bool readOnlySchema = false
)
static member ToRowset :
        json : string *
        ?schemaOnly : bool *
        ?readOnlySchema : bool
(* Defaults:
        let _schemaOnly = defaultArg schemaOnly false
        let _readOnlySchema = defaultArg readOnlySchema false
*)
-> RowsetBase
static member ToRowset :
        json : string *
        ?schemaOnly : bool *
        ?readOnlySchema : bool
(* Defaults:
        let _schemaOnly = defaultArg schemaOnly false
        let _readOnlySchema = defaultArg readOnlySchema false
*)
-> RowsetBase

Parameters

json
Type: Online System String
schemaOnly (Optional)
Type: Online System Boolean
readOnlySchema (Optional)
Type: Online System Boolean

Return Value

Type: RowsetBase
See Also
JSONReader Class
JSONReader Members
ToRowset Overload
NFX.Serialization.JSON Namespace


JSONReader.ToRowset Method (JSONDataMap, Boolean, Boolean)

JSONReader ToRowset Method (JSONDataMap, Boolean, Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Deserializes into Rowset or Table from JSONDataMap, as serialized by RowsedBase.WriteAsJSON()

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static RowsetBase ToRowset(
    JSONDataMap jsonMap,
    bool schemaOnly = false,
    bool readOnlySchema = false
)
public static RowsetBase ToRowset(
    JSONDataMap jsonMap,
    bool schemaOnly = false,
    bool readOnlySchema = false
)
Public Shared Function ToRowset (
    jsonMap As JSONDataMap,
    Optional schemaOnly As Boolean = false,
    Optional readOnlySchema As Boolean = false
) As RowsetBase
Public Shared Function ToRowset (
    jsonMap As JSONDataMap,
    Optional schemaOnly As Boolean = false,
    Optional readOnlySchema As Boolean = false
) As RowsetBase
public:
static RowsetBase^ ToRowset(
    JSONDataMap^ jsonMap,
    bool schemaOnly = false,
    bool readOnlySchema = false
)
public:
static RowsetBase^ ToRowset(
    JSONDataMap^ jsonMap,
    bool schemaOnly = false,
    bool readOnlySchema = false
)
static member ToRowset :
        jsonMap : JSONDataMap *
        ?schemaOnly : bool *
        ?readOnlySchema : bool
(* Defaults:
        let _schemaOnly = defaultArg schemaOnly false
        let _readOnlySchema = defaultArg readOnlySchema false
*)
-> RowsetBase
static member ToRowset :
        jsonMap : JSONDataMap *
        ?schemaOnly : bool *
        ?readOnlySchema : bool
(* Defaults:
        let _schemaOnly = defaultArg schemaOnly false
        let _readOnlySchema = defaultArg readOnlySchema false
*)
-> RowsetBase

Parameters

jsonMap
Type: NFX.Serialization.JSON JSONDataMap
schemaOnly (Optional)
Type: Online System Boolean
readOnlySchema (Optional)
Type: Online System Boolean

Return Value

Type: RowsetBase
See Also
JSONReader Class
JSONReader Members
ToRowset Overload
NFX.Serialization.JSON Namespace


JSONSerializationException Class

JSONSerializationException Class NFX Class Library

Base exception thrown by the JSON when serializing objects
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Serialization NFXSerializationException
NFX.Serialization.JSON JSONException
NFX.Serialization.JSON JSONSerializationException

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class JSONSerializationException : JSONException
[SerializableAttribute]
public class JSONSerializationException : JSONException
<SerializableAttribute>
Public Class JSONSerializationException
    Inherits JSONException
<SerializableAttribute>
Public Class JSONSerializationException
    Inherits JSONException
[SerializableAttribute]
public ref class JSONSerializationException : public JSONException
[SerializableAttribute]
public ref class JSONSerializationException : public JSONException
[<SerializableAttribute>]
type JSONSerializationException =
    class
        inherit JSONException
    end
[<SerializableAttribute>]
type JSONSerializationException =
    class
        inherit JSONException
    end
See Also
JSONSerializationException Members
NFX.Serialization.JSON Namespace


JSONSerializationException Members

JSONSerializationException Members NFX Class Library

The JSONSerializationException type exposes the following members.
Constructors
 | Name | Description
Public method | JSONSerializationException | Initializes a new instance of the JSONSerializationException class
Public method | JSONSerializationException(String) | Initializes a new instance of the JSONSerializationException class
Protected method | JSONSerializationException(SerializationInfo, StreamingContext) | Initializes a new instance of the JSONSerializationException class
Public method | JSONSerializationException(String, Exception) | Initializes a new instance of the JSONSerializationException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
JSONSerializationException Class
NFX.Serialization.JSON Namespace


JSONSerializationException Constructor

JSONSerializationException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | JSONSerializationException | Initializes a new instance of the JSONSerializationException class
Public method | JSONSerializationException(String) | Initializes a new instance of the JSONSerializationException class
Protected method | JSONSerializationException(SerializationInfo, StreamingContext) | Initializes a new instance of the JSONSerializationException class
Public method | JSONSerializationException(String, Exception) | Initializes a new instance of the JSONSerializationException class
Back to Top
See Also
JSONSerializationException Class
JSONSerializationException Members
NFX.Serialization.JSON Namespace


JSONSerializationException Constructor

JSONSerializationException Constructor NFX Class Library

Initializes a new instance of the JSONSerializationException class

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONSerializationException()
public JSONSerializationException()
Public Sub New
Public Sub New
public:
JSONSerializationException()
public:
JSONSerializationException()
new : unit -> JSONSerializationException
new : unit -> JSONSerializationException
See Also
JSONSerializationException Class
JSONSerializationException Members
JSONSerializationException Overload
NFX.Serialization.JSON Namespace


JSONSerializationException Constructor (String)

JSONSerializationException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the JSONSerializationException class

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONSerializationException(
    string message
)
public JSONSerializationException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
JSONSerializationException(
    String^ message
)
public:
JSONSerializationException(
    String^ message
)
new :
        message : string -> JSONSerializationException
new :
        message : string -> JSONSerializationException

Parameters

message
Type: Online System String
See Also
JSONSerializationException Class
JSONSerializationException Members
JSONSerializationException Overload
NFX.Serialization.JSON Namespace


JSONSerializationException Constructor (SerializationInfo, StreamingContext)

JSONSerializationException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the JSONSerializationException class

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected JSONSerializationException(
    SerializationInfo info,
    StreamingContext context
)
protected JSONSerializationException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
JSONSerializationException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
JSONSerializationException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> JSONSerializationException
new :
        info : SerializationInfo *
        context : StreamingContext -> JSONSerializationException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
JSONSerializationException Class
JSONSerializationException Members
JSONSerializationException Overload
NFX.Serialization.JSON Namespace


JSONSerializationException Constructor (String, Exception)

JSONSerializationException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the JSONSerializationException class

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONSerializationException(
    string message,
    Exception inner
)
public JSONSerializationException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
JSONSerializationException(
    String^ message,
    Exception^ inner
)
public:
JSONSerializationException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> JSONSerializationException
new :
        message : string *
        inner : Exception -> JSONSerializationException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
JSONSerializationException Class
JSONSerializationException Members
JSONSerializationException Overload
NFX.Serialization.JSON Namespace


JSONSerializationException Methods

JSONSerializationException Methods NFX Class Library

The JSONSerializationException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
JSONSerializationException Class
NFX.Serialization.JSON Namespace


JSONSerializationException Properties

JSONSerializationException Properties NFX Class Library

The JSONSerializationException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
JSONSerializationException Class
NFX.Serialization.JSON Namespace


JSONSerializationException Events

JSONSerializationException Events NFX Class Library

The JSONSerializationException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
JSONSerializationException Class
NFX.Serialization.JSON Namespace


JSONSerializationPurpose Enumeration

JSONSerializationPurpose Enumeration NFX Class Library

Specifies the purpose of JSON serialization so the level of detail may be dynamically adjusted. Depending on this parameter IJSONWritable implementors may include additional details that are otherwise not needed

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum JSONSerializationPurpose
public enum JSONSerializationPurpose
Public Enumeration JSONSerializationPurpose
Public Enumeration JSONSerializationPurpose
public enum class JSONSerializationPurpose
public enum class JSONSerializationPurpose
type JSONSerializationPurpose
type JSONSerializationPurpose
Members
Member name | Value | Description
Unspecified | 0 |
UIFeed | 1 | UI Interface feeding - include only the data needed to show to the user
Marshalling | 2 | Include as much data as possible for remote object reconstruction
See Also
NFX.Serialization.JSON Namespace


JSONWriter Class

JSONWriter Class NFX Class Library

Writes primitive types, JSONDataObjects, JSONDynamicObjects, IEnumerable and IDictionary - implementers into string or stream. Can also write IJSONWritable-implementing types that directly serialize their state into JSON. This class does not serialize regular CLR types (that do not implement IJSONWritable), use JSONSerializer for full functionality
Inheritance Hierarchy
Online System Object
NFX.Serialization.JSON JSONWriter

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class JSONWriter
public static class JSONWriter
Public NotInheritable Class JSONWriter
Public NotInheritable Class JSONWriter
public ref class JSONWriter abstract sealed
public ref class JSONWriter abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type JSONWriter =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type JSONWriter =  class end
See Also
JSONWriter Members
NFX.Serialization.JSON Namespace


JSONWriter Members

JSONWriter Members NFX Class Library

The JSONWriter type exposes the following members.
Methods
Name | Description
EncodeDateTime | Writes a string in JSON format (a la "JSON encode string") - using quotes and escaping charecters that need it
EncodeString | Writes a string in JSON format (a la "JSON encode string") - using quotes and escaping charecters that need it
Write(Object, JSONWritingOptions, IFormatProvider) | Writes JSON data to the string
Write(Object, TextWriter, JSONWritingOptions) | Appends JSON data into the instance of StringBuilder
Write(Object, Stream, JSONWritingOptions, Encoding) | Writes JSON data to the stream
WriteArray | Appends JSON representation of an IEnumerable
WriteMap(TextWriter, IEnumerable DictionaryEntry , Int32, JSONWritingOptions) | Appends JSON representation of a map(IEnumerable(DictionaryEntry))
WriteMap(TextWriter, IDictionary, Int32, JSONWritingOptions) | Appends JSON representation of a map(IDictionary)
WriteMap(TextWriter, Int32, JSONWritingOptions, DictionaryEntry ) | Appends JSON representation of a map(IEnumerable(DictionaryEntry))
WriteToBuffer | Writes JSON data to the byte[]
WriteToFile | Writes JSON data to the file
Back to Top
See Also
JSONWriter Class
NFX.Serialization.JSON Namespace


JSONWriter Methods

JSONWriter Methods NFX Class Library

The JSONWriter type exposes the following members.
Methods
Name | Description
EncodeDateTime | Writes a string in JSON format (a la "JSON encode string") - using quotes and escaping charecters that need it
EncodeString | Writes a string in JSON format (a la "JSON encode string") - using quotes and escaping charecters that need it
Write(Object, JSONWritingOptions, IFormatProvider) | Writes JSON data to the string
Write(Object, TextWriter, JSONWritingOptions) | Appends JSON data into the instance of StringBuilder
Write(Object, Stream, JSONWritingOptions, Encoding) | Writes JSON data to the stream
WriteArray | Appends JSON representation of an IEnumerable
WriteMap(TextWriter, IEnumerable DictionaryEntry , Int32, JSONWritingOptions) | Appends JSON representation of a map(IEnumerable(DictionaryEntry))
WriteMap(TextWriter, IDictionary, Int32, JSONWritingOptions) | Appends JSON representation of a map(IDictionary)
WriteMap(TextWriter, Int32, JSONWritingOptions, DictionaryEntry ) | Appends JSON representation of a map(IEnumerable(DictionaryEntry))
WriteToBuffer | Writes JSON data to the byte[]
WriteToFile | Writes JSON data to the file
Back to Top
See Also
JSONWriter Class
NFX.Serialization.JSON Namespace


JSONWriter.EncodeDateTime Method

JSONWriter EncodeDateTime Method NFX Class Library

Writes a string in JSON format (a la "JSON encode string") - using quotes and escaping charecters that need it

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void EncodeDateTime(
    TextWriter wri,
    DateTime data,
    JSONWritingOptions opt = null,
    Nullable<TimeSpan> utcOffset = null
)
public static void EncodeDateTime(
    TextWriter wri,
    DateTime data,
    JSONWritingOptions opt = null,
    Nullable<TimeSpan> utcOffset = null
)
Public Shared Sub EncodeDateTime (
    wri As TextWriter,
    data As DateTime,
    Optional opt As JSONWritingOptions = Nothing,
    Optional utcOffset As Nullable(Of TimeSpan) = Nothing
)
Public Shared Sub EncodeDateTime (
    wri As TextWriter,
    data As DateTime,
    Optional opt As JSONWritingOptions = Nothing,
    Optional utcOffset As Nullable(Of TimeSpan) = Nothing
)
public:
static void EncodeDateTime(
    TextWriter^ wri,
    DateTime data,
    JSONWritingOptions^ opt = nullptr,
    Nullable<TimeSpan> utcOffset = nullptr
)
public:
static void EncodeDateTime(
    TextWriter^ wri,
    DateTime data,
    JSONWritingOptions^ opt = nullptr,
    Nullable<TimeSpan> utcOffset = nullptr
)
static member EncodeDateTime :
        wri : TextWriter *
        data : DateTime *
        ?opt : JSONWritingOptions *
        ?utcOffset : Nullable<TimeSpan>
(* Defaults:
        let _opt = defaultArg opt null
        let _utcOffset = defaultArg utcOffset null
*)
-> unit
static member EncodeDateTime :
        wri : TextWriter *
        data : DateTime *
        ?opt : JSONWritingOptions *
        ?utcOffset : Nullable<TimeSpan>
(* Defaults:
        let _opt = defaultArg opt null
        let _utcOffset = defaultArg utcOffset null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
TextWriter instance to append data into
data
Type: Online System DateTime
Original string to encode as JSON
opt (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions
JSONWriting options instance, if omitted then JSONWritingOptions.Compact is used
utcOffset (Optional)
Type: Online System Nullable Online TimeSpan
UTC offset override. If not supplied then offset form local time zone is used
See Also
JSONWriter Class
JSONWriter Members
NFX.Serialization.JSON Namespace


JSONWriter.EncodeString Method

JSONWriter EncodeString Method NFX Class Library

Writes a string in JSON format (a la "JSON encode string") - using quotes and escaping charecters that need it

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void EncodeString(
    TextWriter wri,
    string data,
    JSONWritingOptions opt = null
)
public static void EncodeString(
    TextWriter wri,
    string data,
    JSONWritingOptions opt = null
)
Public Shared Sub EncodeString (
    wri As TextWriter,
    data As String,
    Optional opt As JSONWritingOptions = Nothing
)
Public Shared Sub EncodeString (
    wri As TextWriter,
    data As String,
    Optional opt As JSONWritingOptions = Nothing
)
public:
static void EncodeString(
    TextWriter^ wri,
    String^ data,
    JSONWritingOptions^ opt = nullptr
)
public:
static void EncodeString(
    TextWriter^ wri,
    String^ data,
    JSONWritingOptions^ opt = nullptr
)
static member EncodeString :
        wri : TextWriter *
        data : string *
        ?opt : JSONWritingOptions
(* Defaults:
        let _opt = defaultArg opt null
*)
-> unit
static member EncodeString :
        wri : TextWriter *
        data : string *
        ?opt : JSONWritingOptions
(* Defaults:
        let _opt = defaultArg opt null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
TextWriter instance to append data into
data
Type: Online System String
Original string to encode as JSON
opt (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions
JSONWriting options instance, if omitted then JSONWritingOptions.Compact is used
See Also
JSONWriter Class
JSONWriter Members
NFX.Serialization.JSON Namespace


JSONWriter.Write Method

JSONWriter Write Method NFX Class Library

Overload List
Name | Description
Write(Object, JSONWritingOptions, IFormatProvider) | Writes JSON data to the string
Write(Object, TextWriter, JSONWritingOptions) | Appends JSON data into the instance of StringBuilder
Write(Object, Stream, JSONWritingOptions, Encoding) | Writes JSON data to the stream
Back to Top
See Also
JSONWriter Class
JSONWriter Members
NFX.Serialization.JSON Namespace


JSONWriter.Write Method (Object, JSONWritingOptions, IFormatProvider)

JSONWriter Write Method (Object, JSONWritingOptions, IFormatProvider) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes JSON data to the string

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Write(
    Object data,
    JSONWritingOptions options = null,
    IFormatProvider formatProvider = null
)
public static string Write(
    Object data,
    JSONWritingOptions options = null,
    IFormatProvider formatProvider = null
)
Public Shared Function Write (
    data As Object,
    Optional options As JSONWritingOptions = Nothing,
    Optional formatProvider As IFormatProvider = Nothing
) As String
Public Shared Function Write (
    data As Object,
    Optional options As JSONWritingOptions = Nothing,
    Optional formatProvider As IFormatProvider = Nothing
) As String
public:
static String^ Write(
    Object^ data,
    JSONWritingOptions^ options = nullptr,
    IFormatProvider^ formatProvider = nullptr
)
public:
static String^ Write(
    Object^ data,
    JSONWritingOptions^ options = nullptr,
    IFormatProvider^ formatProvider = nullptr
)
static member Write :
        data : Object *
        ?options : JSONWritingOptions *
        ?formatProvider : IFormatProvider
(* Defaults:
        let _options = defaultArg options null
        let _formatProvider = defaultArg formatProvider null
*)
-> string
static member Write :
        data : Object *
        ?options : JSONWritingOptions *
        ?formatProvider : IFormatProvider
(* Defaults:
        let _options = defaultArg options null
        let _formatProvider = defaultArg formatProvider null
*)
-> string

Parameters

data
Type: Online System Object
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions
formatProvider (Optional)
Type: Online System IFormatProvider

Return Value

Type: Online String
See Also
JSONWriter Class
JSONWriter Members
Write Overload
NFX.Serialization.JSON Namespace


JSONWriter.Write Method (Object, TextWriter, JSONWritingOptions)

JSONWriter Write Method (Object, TextWriter, JSONWritingOptions) NFX Class Library

[This is preliminary documentation and is subject to change.]

Appends JSON data into the instance of StringBuilder

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    Object data,
    TextWriter wri,
    JSONWritingOptions options = null
)
public static void Write(
    Object data,
    TextWriter wri,
    JSONWritingOptions options = null
)
Public Shared Sub Write (
    data As Object,
    wri As TextWriter,
    Optional options As JSONWritingOptions = Nothing
)
Public Shared Sub Write (
    data As Object,
    wri As TextWriter,
    Optional options As JSONWritingOptions = Nothing
)
public:
static void Write(
    Object^ data,
    TextWriter^ wri,
    JSONWritingOptions^ options = nullptr
)
public:
static void Write(
    Object^ data,
    TextWriter^ wri,
    JSONWritingOptions^ options = nullptr
)
static member Write :
        data : Object *
        wri : TextWriter *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
static member Write :
        data : Object *
        wri : TextWriter *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

data
Type: Online System Object
wri
Type: Online System.IO TextWriter
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions
See Also
JSONWriter Class
JSONWriter Members
Write Overload
NFX.Serialization.JSON Namespace


JSONWriter.Write Method (Object, Stream, JSONWritingOptions, Encoding)

JSONWriter Write Method (Object, Stream, JSONWritingOptions, Encoding) NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes JSON data to the stream

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void Write(
    Object data,
    Stream stream,
    JSONWritingOptions options = null,
    Encoding encoding = null
)
public static void Write(
    Object data,
    Stream stream,
    JSONWritingOptions options = null,
    Encoding encoding = null
)
Public Shared Sub Write (
    data As Object,
    stream As Stream,
    Optional options As JSONWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing
)
Public Shared Sub Write (
    data As Object,
    stream As Stream,
    Optional options As JSONWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing
)
public:
static void Write(
    Object^ data,
    Stream^ stream,
    JSONWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr
)
public:
static void Write(
    Object^ data,
    Stream^ stream,
    JSONWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr
)
static member Write :
        data : Object *
        stream : Stream *
        ?options : JSONWritingOptions *
        ?encoding : Encoding
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
*)
-> unit
static member Write :
        data : Object *
        stream : Stream *
        ?options : JSONWritingOptions *
        ?encoding : Encoding
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
*)
-> unit

Parameters

data
Type: Online System Object
stream
Type: Online System.IO Stream
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions
encoding (Optional)
Type: Online System.Text Encoding
See Also
JSONWriter Class
JSONWriter Members
Write Overload
NFX.Serialization.JSON Namespace


JSONWriter.WriteArray Method

JSONWriter WriteArray Method NFX Class Library

Appends JSON representation of an IEnumerable

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteArray(
    TextWriter wri,
    IEnumerable data,
    int level,
    JSONWritingOptions options
)
public static void WriteArray(
    TextWriter wri,
    IEnumerable data,
    int level,
    JSONWritingOptions options
)
Public Shared Sub WriteArray (
    wri As TextWriter,
    data As IEnumerable,
    level As Integer,
    options As JSONWritingOptions
)
Public Shared Sub WriteArray (
    wri As TextWriter,
    data As IEnumerable,
    level As Integer,
    options As JSONWritingOptions
)
public:
static void WriteArray(
    TextWriter^ wri,
    IEnumerable^ data,
    int level,
    JSONWritingOptions^ options
)
public:
static void WriteArray(
    TextWriter^ wri,
    IEnumerable^ data,
    int level,
    JSONWritingOptions^ options
)
static member WriteArray :
        wri : TextWriter *
        data : IEnumerable *
        level : int *
        options : JSONWritingOptions -> unit
static member WriteArray :
        wri : TextWriter *
        data : IEnumerable *
        level : int *
        options : JSONWritingOptions -> unit

Parameters

wri
Type: Online System.IO TextWriter
data
Type: Online System.Collections IEnumerable
level
Type: Online System Int32
options
Type: NFX.Serialization.JSON JSONWritingOptions
See Also
JSONWriter Class
JSONWriter Members
NFX.Serialization.JSON Namespace


JSONWriter.WriteMap Method

JSONWriter WriteMap Method NFX Class Library

Overload List
Name | Description
WriteMap(TextWriter, IEnumerable DictionaryEntry , Int32, JSONWritingOptions) | Appends JSON representation of a map(IEnumerable(DictionaryEntry))
WriteMap(TextWriter, IDictionary, Int32, JSONWritingOptions) | Appends JSON representation of a map(IDictionary)
WriteMap(TextWriter, Int32, JSONWritingOptions, DictionaryEntry ) | Appends JSON representation of a map(IEnumerable(DictionaryEntry))
Back to Top
See Also
JSONWriter Class
JSONWriter Members
NFX.Serialization.JSON Namespace


JSONWriter.WriteMap Method (TextWriter, IEnumerable(DictionaryEntry), Int32, JSONWritingOptions)

JSONWriter WriteMap Method (TextWriter, IEnumerable DictionaryEntry , Int32, JSONWritingOptions) NFX Class Library

[This is preliminary documentation and is subject to change.]

Appends JSON representation of a map(IEnumerable(DictionaryEntry))

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteMap(
    TextWriter wri,
    IEnumerable<DictionaryEntry> data,
    int level,
    JSONWritingOptions options = null
)
public static void WriteMap(
    TextWriter wri,
    IEnumerable<DictionaryEntry> data,
    int level,
    JSONWritingOptions options = null
)
Public Shared Sub WriteMap (
    wri As TextWriter,
    data As IEnumerable(Of DictionaryEntry),
    level As Integer,
    Optional options As JSONWritingOptions = Nothing
)
Public Shared Sub WriteMap (
    wri As TextWriter,
    data As IEnumerable(Of DictionaryEntry),
    level As Integer,
    Optional options As JSONWritingOptions = Nothing
)
public:
static void WriteMap(
    TextWriter^ wri,
    IEnumerable<DictionaryEntry>^ data,
    int level,
    JSONWritingOptions^ options = nullptr
)
public:
static void WriteMap(
    TextWriter^ wri,
    IEnumerable<DictionaryEntry>^ data,
    int level,
    JSONWritingOptions^ options = nullptr
)
static member WriteMap :
        wri : TextWriter *
        data : IEnumerable<DictionaryEntry> *
        level : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
static member WriteMap :
        wri : TextWriter *
        data : IEnumerable<DictionaryEntry> *
        level : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
data
Type: Online System.Collections.Generic IEnumerable Online DictionaryEntry
level
Type: Online System Int32
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions
See Also
JSONWriter Class
JSONWriter Members
WriteMap Overload
NFX.Serialization.JSON Namespace


JSONWriter.WriteMap Method (TextWriter, IDictionary, Int32, JSONWritingOptions)

JSONWriter WriteMap Method (TextWriter, IDictionary, Int32, JSONWritingOptions) NFX Class Library

[This is preliminary documentation and is subject to change.]

Appends JSON representation of a map(IDictionary)

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteMap(
    TextWriter wri,
    IDictionary data,
    int level,
    JSONWritingOptions options = null
)
public static void WriteMap(
    TextWriter wri,
    IDictionary data,
    int level,
    JSONWritingOptions options = null
)
Public Shared Sub WriteMap (
    wri As TextWriter,
    data As IDictionary,
    level As Integer,
    Optional options As JSONWritingOptions = Nothing
)
Public Shared Sub WriteMap (
    wri As TextWriter,
    data As IDictionary,
    level As Integer,
    Optional options As JSONWritingOptions = Nothing
)
public:
static void WriteMap(
    TextWriter^ wri,
    IDictionary^ data,
    int level,
    JSONWritingOptions^ options = nullptr
)
public:
static void WriteMap(
    TextWriter^ wri,
    IDictionary^ data,
    int level,
    JSONWritingOptions^ options = nullptr
)
static member WriteMap :
        wri : TextWriter *
        data : IDictionary *
        level : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
static member WriteMap :
        wri : TextWriter *
        data : IDictionary *
        level : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
data
Type: Online System.Collections IDictionary
level
Type: Online System Int32
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions
See Also
JSONWriter Class
JSONWriter Members
WriteMap Overload
NFX.Serialization.JSON Namespace


JSONWriter.WriteMap Method (TextWriter, Int32, JSONWritingOptions, DictionaryEntry[])

JSONWriter WriteMap Method (TextWriter, Int32, JSONWritingOptions, DictionaryEntry ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Appends JSON representation of a map(IEnumerable(DictionaryEntry))

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteMap(
    TextWriter wri,
    int level,
    JSONWritingOptions options,
    params DictionaryEntry[] data
)
public static void WriteMap(
    TextWriter wri,
    int level,
    JSONWritingOptions options,
    params DictionaryEntry[] data
)
Public Shared Sub WriteMap (
    wri As TextWriter,
    level As Integer,
    options As JSONWritingOptions,
    ParamArray data As DictionaryEntry()
)
Public Shared Sub WriteMap (
    wri As TextWriter,
    level As Integer,
    options As JSONWritingOptions,
    ParamArray data As DictionaryEntry()
)
public:
static void WriteMap(
    TextWriter^ wri,
    int level,
    JSONWritingOptions^ options,
    ... array<DictionaryEntry>^ data
)
public:
static void WriteMap(
    TextWriter^ wri,
    int level,
    JSONWritingOptions^ options,
    ... array<DictionaryEntry>^ data
)
static member WriteMap :
        wri : TextWriter *
        level : int *
        options : JSONWritingOptions *
        data : DictionaryEntry[] -> unit
static member WriteMap :
        wri : TextWriter *
        level : int *
        options : JSONWritingOptions *
        data : DictionaryEntry[] -> unit

Parameters

wri
Type: Online System.IO TextWriter
level
Type: Online System Int32
options
Type: NFX.Serialization.JSON JSONWritingOptions
data
Type: Online System.Collections DictionaryEntry
See Also
JSONWriter Class
JSONWriter Members
WriteMap Overload
NFX.Serialization.JSON Namespace


JSONWriter.WriteToBuffer Method

JSONWriter WriteToBuffer Method NFX Class Library

Writes JSON data to the byte[]

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static byte[] WriteToBuffer(
    Object data,
    JSONWritingOptions options = null,
    Encoding encoding = null
)
public static byte[] WriteToBuffer(
    Object data,
    JSONWritingOptions options = null,
    Encoding encoding = null
)
Public Shared Function WriteToBuffer (
    data As Object,
    Optional options As JSONWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing
) As Byte()
Public Shared Function WriteToBuffer (
    data As Object,
    Optional options As JSONWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing
) As Byte()
public:
static array<unsigned char>^ WriteToBuffer(
    Object^ data,
    JSONWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr
)
public:
static array<unsigned char>^ WriteToBuffer(
    Object^ data,
    JSONWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr
)
static member WriteToBuffer :
        data : Object *
        ?options : JSONWritingOptions *
        ?encoding : Encoding
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
*)
-> byte[]
static member WriteToBuffer :
        data : Object *
        ?options : JSONWritingOptions *
        ?encoding : Encoding
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
*)
-> byte[]

Parameters

data
Type: Online System Object
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions
encoding (Optional)
Type: Online System.Text Encoding

Return Value

Type: Online Byte
See Also
JSONWriter Class
JSONWriter Members
NFX.Serialization.JSON Namespace


JSONWriter.WriteToFile Method

JSONWriter WriteToFile Method NFX Class Library

Writes JSON data to the file

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void WriteToFile(
    Object data,
    string fileName,
    JSONWritingOptions options = null,
    Encoding encoding = null
)
public static void WriteToFile(
    Object data,
    string fileName,
    JSONWritingOptions options = null,
    Encoding encoding = null
)
Public Shared Sub WriteToFile (
    data As Object,
    fileName As String,
    Optional options As JSONWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing
)
Public Shared Sub WriteToFile (
    data As Object,
    fileName As String,
    Optional options As JSONWritingOptions = Nothing,
    Optional encoding As Encoding = Nothing
)
public:
static void WriteToFile(
    Object^ data,
    String^ fileName,
    JSONWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr
)
public:
static void WriteToFile(
    Object^ data,
    String^ fileName,
    JSONWritingOptions^ options = nullptr,
    Encoding^ encoding = nullptr
)
static member WriteToFile :
        data : Object *
        fileName : string *
        ?options : JSONWritingOptions *
        ?encoding : Encoding
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
*)
-> unit
static member WriteToFile :
        data : Object *
        fileName : string *
        ?options : JSONWritingOptions *
        ?encoding : Encoding
(* Defaults:
        let _options = defaultArg options null
        let _encoding = defaultArg encoding null
*)
-> unit

Parameters

data
Type: Online System Object
fileName
Type: Online System String
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions
encoding (Optional)
Type: Online System.Text Encoding
See Also
JSONWriter Class
JSONWriter Members
NFX.Serialization.JSON Namespace


JSONWritingOptions Class

JSONWritingOptions Class NFX Class Library

Specifies how JSON should be written as text. Use JSONWritingOptions.Compact or JSONWritingOptions.PrettyPrint static properties for typical options
Inheritance Hierarchy
Online System Object
NFX.Serialization.JSON JSONWritingOptions

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class JSONWritingOptions : IConfigurable
public class JSONWritingOptions : IConfigurable
Public Class JSONWritingOptions
    Implements IConfigurable
Public Class JSONWritingOptions
    Implements IConfigurable
public ref class JSONWritingOptions : IConfigurable
public ref class JSONWritingOptions : IConfigurable
type JSONWritingOptions =
    class
        interface IConfigurable
    end
type JSONWritingOptions =
    class
        interface IConfigurable
    end
See Also
JSONWritingOptions Members
NFX.Serialization.JSON Namespace


JSONWritingOptions Members

JSONWritingOptions Members NFX Class Library

The JSONWritingOptions type exposes the following members.
Constructors
 | Name | Description
Public method | JSONWritingOptions | Initializes a new instance of the JSONWritingOptions class
Public method | JSONWritingOptions(JSONWritingOptions) | Initializes a new instance of the JSONWritingOptions class
Back to Top
Methods
 | Name | Description
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | ASCIITarget | Specifies whether the target of serialization only deals with ASCII characeters, so any non-ASCII character with code above 127 must be escaped with unicode escape sequence
Public field | IndentWidth | Specifies character width of single indent level
Public field | ISODates | Specifies whether DateTime must be encoded using ISO8601 format that look like "2011-03-18T14:25:00Z", otherwise dates are encoded using "new Date(milliseconds_since_unix_epoch)" which is technically not a valid JSON, however most JSON parsers understand it very well
Public field | MapSkipNulls | If true, then does not write map keys which are null
Public field | MaxNestingLevel | Sets a limit of object nesting, i.e. for recursive graph depth. Default is 0xff
Public field | MemberLineBreak | Specifies whether every object member must be placed on a separate line for better readability
Public field | NLSMapLanguageISO | Specifies language ISO code (3 chars) that is used (when set) by the NLSMap class, so only entries for that particular language are included. When NLSMap contains entries for more than 1 language, but user needs only one entry received for his/her selected language, this option can be set, then NLSMap will only inline Name:Descr pair for that language. If a map does not contain an entry for the reequested lang then NLSMapLanguageISODefault will be tried
Public field | NLSMapLanguageISODefault | Specified language ISO default for NLSMap lookup, "eng" is used for default
Public field | ObjectLineBreak | Specifies whether objects need to be separated by line brakes for better readability
Public field | Purpose | Specifies the purpose of JSON serialization so the level of detail may be dynamically adjusted. Depending on this parameter IJSONWritable implementors may include additional details that are otherwise not needed
Public field | RowMapTargetName | When set, specifies the target name for Row's fields when they are written as map
Public field | RowsAsMap | When true, writes every row as a map {FieldName: FieldValue,...} instead of array of values
Public field | RowsetMetadata | When true, writes rowset metadata (i.e. schema, instance id etc.)
Public field | SpaceSymbols | Indicates whether a space must be placed right after the symbol, such as coma in array declaration or colon in member declaration for better readability
Back to Top
Properties
Name | Description
Compact | Writes JSON without line breaks between members and no indenting. Suitable for data transmission
CompactASCII | Writes JSON without line breaks between members and no indenting escaping any characters with codes above 127 suitable for ASCII transmission
CompactRowsAsMap | Writes JSON without line breaks between members and no indenting writing rows as maps(key:values) instead of arrays. Suitable for data transmission
PrettyPrint | Writes JSON suitable for printing/screen display
PrettyPrintASCII | Writes JSON suitable for printing/screen display with codes above 127 suitable for ASCII transmission
PrettyPrintRowsAsMap | Writes JSON suitable for printing/screen display writing rows as maps(key:values) instead of arrays
Back to Top
See Also
JSONWritingOptions Class
NFX.Serialization.JSON Namespace


JSONWritingOptions Constructor

JSONWritingOptions Constructor NFX Class Library

Overload List
 | Name | Description
Public method | JSONWritingOptions | Initializes a new instance of the JSONWritingOptions class
Public method | JSONWritingOptions(JSONWritingOptions) | Initializes a new instance of the JSONWritingOptions class
Back to Top
See Also
JSONWritingOptions Class
JSONWritingOptions Members
NFX.Serialization.JSON Namespace


JSONWritingOptions Constructor

JSONWritingOptions Constructor NFX Class Library

Initializes a new instance of the JSONWritingOptions class

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONWritingOptions()
public JSONWritingOptions()
Public Sub New
Public Sub New
public:
JSONWritingOptions()
public:
JSONWritingOptions()
new : unit -> JSONWritingOptions
new : unit -> JSONWritingOptions
See Also
JSONWritingOptions Class
JSONWritingOptions Members
JSONWritingOptions Overload
NFX.Serialization.JSON Namespace


JSONWritingOptions Constructor (JSONWritingOptions)

JSONWritingOptions Constructor (JSONWritingOptions) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the JSONWritingOptions class

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JSONWritingOptions(
    JSONWritingOptions other
)
public JSONWritingOptions(
    JSONWritingOptions other
)
Public Sub New (
    other As JSONWritingOptions
)
Public Sub New (
    other As JSONWritingOptions
)
public:
JSONWritingOptions(
    JSONWritingOptions^ other
)
public:
JSONWritingOptions(
    JSONWritingOptions^ other
)
new :
        other : JSONWritingOptions -> JSONWritingOptions
new :
        other : JSONWritingOptions -> JSONWritingOptions

Parameters

other
Type: NFX.Serialization.JSON JSONWritingOptions
See Also
JSONWritingOptions Class
JSONWritingOptions Members
JSONWritingOptions Overload
NFX.Serialization.JSON Namespace


JSONWritingOptions Fields

JSONWritingOptions Fields NFX Class Library

The JSONWritingOptions type exposes the following members.
Fields
 | Name | Description
Public field | ASCIITarget | Specifies whether the target of serialization only deals with ASCII characeters, so any non-ASCII character with code above 127 must be escaped with unicode escape sequence
Public field | IndentWidth | Specifies character width of single indent level
Public field | ISODates | Specifies whether DateTime must be encoded using ISO8601 format that look like "2011-03-18T14:25:00Z", otherwise dates are encoded using "new Date(milliseconds_since_unix_epoch)" which is technically not a valid JSON, however most JSON parsers understand it very well
Public field | MapSkipNulls | If true, then does not write map keys which are null
Public field | MaxNestingLevel | Sets a limit of object nesting, i.e. for recursive graph depth. Default is 0xff
Public field | MemberLineBreak | Specifies whether every object member must be placed on a separate line for better readability
Public field | NLSMapLanguageISO | Specifies language ISO code (3 chars) that is used (when set) by the NLSMap class, so only entries for that particular language are included. When NLSMap contains entries for more than 1 language, but user needs only one entry received for his/her selected language, this option can be set, then NLSMap will only inline Name:Descr pair for that language. If a map does not contain an entry for the reequested lang then NLSMapLanguageISODefault will be tried
Public field | NLSMapLanguageISODefault | Specified language ISO default for NLSMap lookup, "eng" is used for default
Public field | ObjectLineBreak | Specifies whether objects need to be separated by line brakes for better readability
Public field | Purpose | Specifies the purpose of JSON serialization so the level of detail may be dynamically adjusted. Depending on this parameter IJSONWritable implementors may include additional details that are otherwise not needed
Public field | RowMapTargetName | When set, specifies the target name for Row's fields when they are written as map
Public field | RowsAsMap | When true, writes every row as a map {FieldName: FieldValue,...} instead of array of values
Public field | RowsetMetadata | When true, writes rowset metadata (i.e. schema, instance id etc.)
Public field | SpaceSymbols | Indicates whether a space must be placed right after the symbol, such as coma in array declaration or colon in member declaration for better readability
Back to Top
See Also
JSONWritingOptions Class
NFX.Serialization.JSON Namespace


JSONWritingOptions.ASCIITarget Field

JSONWritingOptions ASCIITarget Field NFX Class Library

Specifies whether the target of serialization only deals with ASCII characeters, so any non-ASCII character with code above 127 must be escaped with unicode escape sequence

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool ASCIITarget
[ConfigAttribute]
public bool ASCIITarget
<ConfigAttribute>
Public ASCIITarget As Boolean
<ConfigAttribute>
Public ASCIITarget As Boolean
public:
[ConfigAttribute]
bool ASCIITarget
public:
[ConfigAttribute]
bool ASCIITarget
[<ConfigAttribute>]
val mutable ASCIITarget: bool
[<ConfigAttribute>]
val mutable ASCIITarget: bool

Field Value

Type: Online Boolean
See Also
JSONWritingOptions Class
JSONWritingOptions Members
NFX.Serialization.JSON Namespace


JSONWritingOptions.IndentWidth Field

JSONWritingOptions IndentWidth Field NFX Class Library

Specifies character width of single indent level

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int IndentWidth
[ConfigAttribute]
public int IndentWidth
<ConfigAttribute>
Public IndentWidth As Integer
<ConfigAttribute>
Public IndentWidth As Integer
public:
[ConfigAttribute]
int IndentWidth
public:
[ConfigAttribute]
int IndentWidth
[<ConfigAttribute>]
val mutable IndentWidth: int
[<ConfigAttribute>]
val mutable IndentWidth: int

Field Value

Type: Online Int32
See Also
JSONWritingOptions Class
JSONWritingOptions Members
NFX.Serialization.JSON Namespace


JSONWritingOptions.ISODates Field

JSONWritingOptions ISODates Field NFX Class Library

Specifies whether DateTime must be encoded using ISO8601 format that look like "2011-03-18T14:25:00Z", otherwise dates are encoded using "new Date(milliseconds_since_unix_epoch)" which is technically not a valid JSON, however most JSON parsers understand it very well

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool ISODates
[ConfigAttribute]
public bool ISODates
<ConfigAttribute>
Public ISODates As Boolean
<ConfigAttribute>
Public ISODates As Boolean
public:
[ConfigAttribute]
bool ISODates
public:
[ConfigAttribute]
bool ISODates
[<ConfigAttribute>]
val mutable ISODates: bool
[<ConfigAttribute>]
val mutable ISODates: bool

Field Value

Type: Online Boolean
See Also
JSONWritingOptions Class
JSONWritingOptions Members
NFX.Serialization.JSON Namespace


JSONWritingOptions.MapSkipNulls Field

JSONWritingOptions MapSkipNulls Field NFX Class Library

If true, then does not write map keys which are null

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool MapSkipNulls
[ConfigAttribute]
public bool MapSkipNulls
<ConfigAttribute>
Public MapSkipNulls As Boolean
<ConfigAttribute>
Public MapSkipNulls As Boolean
public:
[ConfigAttribute]
bool MapSkipNulls
public:
[ConfigAttribute]
bool MapSkipNulls
[<ConfigAttribute>]
val mutable MapSkipNulls: bool
[<ConfigAttribute>]
val mutable MapSkipNulls: bool

Field Value

Type: Online Boolean
See Also
JSONWritingOptions Class
JSONWritingOptions Members
NFX.Serialization.JSON Namespace


JSONWritingOptions.MaxNestingLevel Field

JSONWritingOptions MaxNestingLevel Field NFX Class Library

Sets a limit of object nesting, i.e. for recursive graph depth. Default is 0xff

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public int MaxNestingLevel
[ConfigAttribute]
public int MaxNestingLevel
<ConfigAttribute>
Public MaxNestingLevel As Integer
<ConfigAttribute>
Public MaxNestingLevel As Integer
public:
[ConfigAttribute]
int MaxNestingLevel
public:
[ConfigAttribute]
int MaxNestingLevel
[<ConfigAttribute>]
val mutable MaxNestingLevel: int
[<ConfigAttribute>]
val mutable MaxNestingLevel: int

Field Value

Type: Online Int32
See Also
JSONWritingOptions Class
JSONWritingOptions Members
NFX.Serialization.JSON Namespace


JSONWritingOptions.MemberLineBreak Field

JSONWritingOptions MemberLineBreak Field NFX Class Library

Specifies whether every object member must be placed on a separate line for better readability

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool MemberLineBreak
[ConfigAttribute]
public bool MemberLineBreak
<ConfigAttribute>
Public MemberLineBreak As Boolean
<ConfigAttribute>
Public MemberLineBreak As Boolean
public:
[ConfigAttribute]
bool MemberLineBreak
public:
[ConfigAttribute]
bool MemberLineBreak
[<ConfigAttribute>]
val mutable MemberLineBreak: bool
[<ConfigAttribute>]
val mutable MemberLineBreak: bool

Field Value

Type: Online Boolean
See Also
JSONWritingOptions Class
JSONWritingOptions Members
NFX.Serialization.JSON Namespace


JSONWritingOptions.NLSMapLanguageISO Field

JSONWritingOptions NLSMapLanguageISO Field NFX Class Library

Specifies language ISO code (3 chars) that is used (when set) by the NLSMap class, so only entries for that particular language are included. When NLSMap contains entries for more than 1 language, but user needs only one entry received for his/her selected language, this option can be set, then NLSMap will only inline Name:Descr pair for that language. If a map does not contain an entry for the reequested lang then NLSMapLanguageISODefault will be tried

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string NLSMapLanguageISO
[ConfigAttribute]
public string NLSMapLanguageISO
<ConfigAttribute>
Public NLSMapLanguageISO As String
<ConfigAttribute>
Public NLSMapLanguageISO As String
public:
[ConfigAttribute]
String^ NLSMapLanguageISO
public:
[ConfigAttribute]
String^ NLSMapLanguageISO
[<ConfigAttribute>]
val mutable NLSMapLanguageISO: string
[<ConfigAttribute>]
val mutable NLSMapLanguageISO: string

Field Value

Type: Online String
See Also
JSONWritingOptions Class
JSONWritingOptions Members
NFX.Serialization.JSON Namespace


JSONWritingOptions.NLSMapLanguageISODefault Field

JSONWritingOptions NLSMapLanguageISODefault Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Specified language ISO default for NLSMap lookup, "eng" is used for default

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string NLSMapLanguageISODefault
[ConfigAttribute]
public string NLSMapLanguageISODefault
<ConfigAttribute>
Public NLSMapLanguageISODefault As String
<ConfigAttribute>
Public NLSMapLanguageISODefault As String
public:
[ConfigAttribute]
String^ NLSMapLanguageISODefault
public:
[ConfigAttribute]
String^ NLSMapLanguageISODefault
[<ConfigAttribute>]
val mutable NLSMapLanguageISODefault: string
[<ConfigAttribute>]
val mutable NLSMapLanguageISODefault: string

Field Value

Type: Online String
See Also
JSONWritingOptions Class
JSONWritingOptions Members
NFX.Serialization.JSON Namespace


JSONWritingOptions.ObjectLineBreak Field

JSONWritingOptions ObjectLineBreak Field NFX Class Library

Specifies whether objects need to be separated by line brakes for better readability

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool ObjectLineBreak
[ConfigAttribute]
public bool ObjectLineBreak
<ConfigAttribute>
Public ObjectLineBreak As Boolean
<ConfigAttribute>
Public ObjectLineBreak As Boolean
public:
[ConfigAttribute]
bool ObjectLineBreak
public:
[ConfigAttribute]
bool ObjectLineBreak
[<ConfigAttribute>]
val mutable ObjectLineBreak: bool
[<ConfigAttribute>]
val mutable ObjectLineBreak: bool

Field Value

Type: Online Boolean
See Also
JSONWritingOptions Class
JSONWritingOptions Members
NFX.Serialization.JSON Namespace


JSONWritingOptions.Purpose Field

JSONWritingOptions Purpose Field NFX Class Library

Specifies the purpose of JSON serialization so the level of detail may be dynamically adjusted. Depending on this parameter IJSONWritable implementors may include additional details that are otherwise not needed

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public JSONSerializationPurpose Purpose
[ConfigAttribute]
public JSONSerializationPurpose Purpose
<ConfigAttribute>
Public Purpose As JSONSerializationPurpose
<ConfigAttribute>
Public Purpose As JSONSerializationPurpose
public:
[ConfigAttribute]
JSONSerializationPurpose Purpose
public:
[ConfigAttribute]
JSONSerializationPurpose Purpose
[<ConfigAttribute>]
val mutable Purpose: JSONSerializationPurpose
[<ConfigAttribute>]
val mutable Purpose: JSONSerializationPurpose

Field Value

Type: JSONSerializationPurpose
See Also
JSONWritingOptions Class
JSONWritingOptions Members
NFX.Serialization.JSON Namespace


JSONWritingOptions.RowMapTargetName Field

JSONWritingOptions RowMapTargetName Field NFX Class Library

When set, specifies the target name for Row's fields when they are written as map

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public string RowMapTargetName
[ConfigAttribute]
public string RowMapTargetName
<ConfigAttribute>
Public RowMapTargetName As String
<ConfigAttribute>
Public RowMapTargetName As String
public:
[ConfigAttribute]
String^ RowMapTargetName
public:
[ConfigAttribute]
String^ RowMapTargetName
[<ConfigAttribute>]
val mutable RowMapTargetName: string
[<ConfigAttribute>]
val mutable RowMapTargetName: string

Field Value

Type: Online String
See Also
JSONWritingOptions Class
JSONWritingOptions Members
NFX.Serialization.JSON Namespace


JSONWritingOptions.RowsAsMap Field

JSONWritingOptions RowsAsMap Field NFX Class Library

When true, writes every row as a map {FieldName: FieldValue,...} instead of array of values

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool RowsAsMap
[ConfigAttribute]
public bool RowsAsMap
<ConfigAttribute>
Public RowsAsMap As Boolean
<ConfigAttribute>
Public RowsAsMap As Boolean
public:
[ConfigAttribute]
bool RowsAsMap
public:
[ConfigAttribute]
bool RowsAsMap
[<ConfigAttribute>]
val mutable RowsAsMap: bool
[<ConfigAttribute>]
val mutable RowsAsMap: bool

Field Value

Type: Online Boolean
See Also
JSONWritingOptions Class
JSONWritingOptions Members
NFX.Serialization.JSON Namespace


JSONWritingOptions.RowsetMetadata Field

JSONWritingOptions RowsetMetadata Field NFX Class Library

When true, writes rowset metadata (i.e. schema, instance id etc.)

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool RowsetMetadata
[ConfigAttribute]
public bool RowsetMetadata
<ConfigAttribute>
Public RowsetMetadata As Boolean
<ConfigAttribute>
Public RowsetMetadata As Boolean
public:
[ConfigAttribute]
bool RowsetMetadata
public:
[ConfigAttribute]
bool RowsetMetadata
[<ConfigAttribute>]
val mutable RowsetMetadata: bool
[<ConfigAttribute>]
val mutable RowsetMetadata: bool

Field Value

Type: Online Boolean
See Also
JSONWritingOptions Class
JSONWritingOptions Members
NFX.Serialization.JSON Namespace


JSONWritingOptions.SpaceSymbols Field

JSONWritingOptions SpaceSymbols Field NFX Class Library

Indicates whether a space must be placed right after the symbol, such as coma in array declaration or colon in member declaration for better readability

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute]
public bool SpaceSymbols
[ConfigAttribute]
public bool SpaceSymbols
<ConfigAttribute>
Public SpaceSymbols As Boolean
<ConfigAttribute>
Public SpaceSymbols As Boolean
public:
[ConfigAttribute]
bool SpaceSymbols
public:
[ConfigAttribute]
bool SpaceSymbols
[<ConfigAttribute>]
val mutable SpaceSymbols: bool
[<ConfigAttribute>]
val mutable SpaceSymbols: bool

Field Value

Type: Online Boolean
See Also
JSONWritingOptions Class
JSONWritingOptions Members
NFX.Serialization.JSON Namespace


JSONWritingOptions Methods

JSONWritingOptions Methods NFX Class Library

The JSONWritingOptions type exposes the following members.
Methods
 | Name | Description
Public method | Configure |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
JSONWritingOptions Class
NFX.Serialization.JSON Namespace


JSONWritingOptions.Configure Method

JSONWritingOptions Configure Method NFX Class Library

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode node
)
public void Configure(
    IConfigSectionNode node
)
Public Sub Configure (
    node As IConfigSectionNode
)
Public Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
JSONWritingOptions Class
JSONWritingOptions Members
NFX.Serialization.JSON Namespace


JSONWritingOptions Properties

JSONWritingOptions Properties NFX Class Library

The JSONWritingOptions type exposes the following members.
Properties
Name | Description
Compact | Writes JSON without line breaks between members and no indenting. Suitable for data transmission
CompactASCII | Writes JSON without line breaks between members and no indenting escaping any characters with codes above 127 suitable for ASCII transmission
CompactRowsAsMap | Writes JSON without line breaks between members and no indenting writing rows as maps(key:values) instead of arrays. Suitable for data transmission
PrettyPrint | Writes JSON suitable for printing/screen display
PrettyPrintASCII | Writes JSON suitable for printing/screen display with codes above 127 suitable for ASCII transmission
PrettyPrintRowsAsMap | Writes JSON suitable for printing/screen display writing rows as maps(key:values) instead of arrays
Back to Top
See Also
JSONWritingOptions Class
NFX.Serialization.JSON Namespace


JSONWritingOptions.Compact Property

JSONWritingOptions Compact Property NFX Class Library

Writes JSON without line breaks between members and no indenting. Suitable for data transmission

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static JSONWritingOptions Compact { get; }
public static JSONWritingOptions Compact { get; }
Public Shared ReadOnly Property Compact As JSONWritingOptions
    Get
Public Shared ReadOnly Property Compact As JSONWritingOptions
    Get
public:
static property JSONWritingOptions^ Compact {
    JSONWritingOptions^ get ();
}
public:
static property JSONWritingOptions^ Compact {
    JSONWritingOptions^ get ();
}
static member Compact : JSONWritingOptions with get
static member Compact : JSONWritingOptions with get

Property Value

Type: JSONWritingOptions
See Also
JSONWritingOptions Class
JSONWritingOptions Members
NFX.Serialization.JSON Namespace


JSONWritingOptions.CompactASCII Property

JSONWritingOptions CompactASCII Property NFX Class Library

Writes JSON without line breaks between members and no indenting escaping any characters with codes above 127 suitable for ASCII transmission

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static JSONWritingOptions CompactASCII { get; }
public static JSONWritingOptions CompactASCII { get; }
Public Shared ReadOnly Property CompactASCII As JSONWritingOptions
    Get
Public Shared ReadOnly Property CompactASCII As JSONWritingOptions
    Get
public:
static property JSONWritingOptions^ CompactASCII {
    JSONWritingOptions^ get ();
}
public:
static property JSONWritingOptions^ CompactASCII {
    JSONWritingOptions^ get ();
}
static member CompactASCII : JSONWritingOptions with get
static member CompactASCII : JSONWritingOptions with get

Property Value

Type: JSONWritingOptions
See Also
JSONWritingOptions Class
JSONWritingOptions Members
NFX.Serialization.JSON Namespace


JSONWritingOptions.CompactRowsAsMap Property

JSONWritingOptions CompactRowsAsMap Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes JSON without line breaks between members and no indenting writing rows as maps(key:values) instead of arrays. Suitable for data transmission

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static JSONWritingOptions CompactRowsAsMap { get; }
public static JSONWritingOptions CompactRowsAsMap { get; }
Public Shared ReadOnly Property CompactRowsAsMap As JSONWritingOptions
    Get
Public Shared ReadOnly Property CompactRowsAsMap As JSONWritingOptions
    Get
public:
static property JSONWritingOptions^ CompactRowsAsMap {
    JSONWritingOptions^ get ();
}
public:
static property JSONWritingOptions^ CompactRowsAsMap {
    JSONWritingOptions^ get ();
}
static member CompactRowsAsMap : JSONWritingOptions with get
static member CompactRowsAsMap : JSONWritingOptions with get

Property Value

Type: JSONWritingOptions
See Also
JSONWritingOptions Class
JSONWritingOptions Members
NFX.Serialization.JSON Namespace


JSONWritingOptions.PrettyPrint Property

JSONWritingOptions PrettyPrint Property NFX Class Library

Writes JSON suitable for printing/screen display

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static JSONWritingOptions PrettyPrint { get; }
public static JSONWritingOptions PrettyPrint { get; }
Public Shared ReadOnly Property PrettyPrint As JSONWritingOptions
    Get
Public Shared ReadOnly Property PrettyPrint As JSONWritingOptions
    Get
public:
static property JSONWritingOptions^ PrettyPrint {
    JSONWritingOptions^ get ();
}
public:
static property JSONWritingOptions^ PrettyPrint {
    JSONWritingOptions^ get ();
}
static member PrettyPrint : JSONWritingOptions with get
static member PrettyPrint : JSONWritingOptions with get

Property Value

Type: JSONWritingOptions
See Also
JSONWritingOptions Class
JSONWritingOptions Members
NFX.Serialization.JSON Namespace


JSONWritingOptions.PrettyPrintASCII Property

JSONWritingOptions PrettyPrintASCII Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes JSON suitable for printing/screen display with codes above 127 suitable for ASCII transmission

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static JSONWritingOptions PrettyPrintASCII { get; }
public static JSONWritingOptions PrettyPrintASCII { get; }
Public Shared ReadOnly Property PrettyPrintASCII As JSONWritingOptions
    Get
Public Shared ReadOnly Property PrettyPrintASCII As JSONWritingOptions
    Get
public:
static property JSONWritingOptions^ PrettyPrintASCII {
    JSONWritingOptions^ get ();
}
public:
static property JSONWritingOptions^ PrettyPrintASCII {
    JSONWritingOptions^ get ();
}
static member PrettyPrintASCII : JSONWritingOptions with get
static member PrettyPrintASCII : JSONWritingOptions with get

Property Value

Type: JSONWritingOptions
See Also
JSONWritingOptions Class
JSONWritingOptions Members
NFX.Serialization.JSON Namespace


JSONWritingOptions.PrettyPrintRowsAsMap Property

JSONWritingOptions PrettyPrintRowsAsMap Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Writes JSON suitable for printing/screen display writing rows as maps(key:values) instead of arrays

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static JSONWritingOptions PrettyPrintRowsAsMap { get; }
public static JSONWritingOptions PrettyPrintRowsAsMap { get; }
Public Shared ReadOnly Property PrettyPrintRowsAsMap As JSONWritingOptions
    Get
Public Shared ReadOnly Property PrettyPrintRowsAsMap As JSONWritingOptions
    Get
public:
static property JSONWritingOptions^ PrettyPrintRowsAsMap {
    JSONWritingOptions^ get ();
}
public:
static property JSONWritingOptions^ PrettyPrintRowsAsMap {
    JSONWritingOptions^ get ();
}
static member PrettyPrintRowsAsMap : JSONWritingOptions with get
static member PrettyPrintRowsAsMap : JSONWritingOptions with get

Property Value

Type: JSONWritingOptions
See Also
JSONWritingOptions Class
JSONWritingOptions Members
NFX.Serialization.JSON Namespace


NLSMap Structure

NLSMap Structure NFX Class Library

Represents a JSON-serializable structure that keys [N]ame and [D]escription on lang ISO. It respects JSONWritingOptions.NLSMapLanguageISO and NLSMapLanguageISODefault

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public struct NLSMap : IEnumerable<KeyValuePair<string, NLSMap..::..NDPair>>,
    IEnumerable, IJSONWritable
[SerializableAttribute]
public struct NLSMap : IEnumerable<KeyValuePair<string, NLSMap..::..NDPair>>,
    IEnumerable, IJSONWritable
<SerializableAttribute>
Public Structure NLSMap
    Implements IEnumerable(Of KeyValuePair(Of String, NLSMap..::..NDPair)),
    IEnumerable, IJSONWritable
<SerializableAttribute>
Public Structure NLSMap
    Implements IEnumerable(Of KeyValuePair(Of String, NLSMap..::..NDPair)),
    IEnumerable, IJSONWritable
[SerializableAttribute]
public value class NLSMap : IEnumerable<KeyValuePair<String^, NLSMap..::..NDPair>>,
    IEnumerable, IJSONWritable
[SerializableAttribute]
public value class NLSMap : IEnumerable<KeyValuePair<String^, NLSMap..::..NDPair>>,
    IEnumerable, IJSONWritable
[<SealedAttribute>]
[<SerializableAttribute>]
type NLSMap =
    struct
        interface IEnumerable<KeyValuePair<string, NLSMap..::..NDPair>>
        interface IEnumerable
        interface IJSONWritable
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type NLSMap =
    struct
        interface IEnumerable<KeyValuePair<string, NLSMap..::..NDPair>>
        interface IEnumerable
        interface IJSONWritable
    end
See Also
NLSMap Members
NFX.Serialization.JSON Namespace


NLSMap Members

NLSMap Members NFX Class Library

The NLSMap type exposes the following members.
Constructors
 | Name | Description
Public method | NLSMap(String) | Makes NLSMap out of JSON string: {eng: {n: 'Cucumber',d: 'It is green'}, deu: {n='Gurke',d='Es ist grün'}}
Public method | NLSMap(IConfigSectionNode) | Makes NLSMap out of conf node: eng{n='Cucumber' d='It is green'} deu{n='Gurke' d='Es ist grün'}
Protected method | NLSMap( NLSMap NDPair ) | Initializes a new instance of the NLSMap class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get | Tries to get the specified part(s) from the map defaulting to another lang if requested lang is not found. Returns null if nothing is found
Public method | GetEnumerator |
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OverrideBy | Takes entries from this instance and overides them by ISO keys from another instance returning the new instance
Public method | ToString | (Overrides Online ValueType ToString .)
 | TryGet | Tries to get the specified part(s) from the JSON content that represents map defaulting to another lang if requested lang is not found. Returns null if nothing is found
Public method | WriteAsJSON | Writes NLSMap either as a dict or as a {n:"", d: ""} pair as Options.NLSMapLanguageISO filter dictates
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable KeyValuePair String, NLSMap NDPair | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct KeyValuePair String, NLSMap NDPair , TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair String, NLSMap NDPair , TComparand (Func KeyValuePair String, NLSMap NDPair , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair String, NLSMap NDPair , TComparand (Func KeyValuePair String, NLSMap NDPair , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair String, NLSMap NDPair , TComparand (Func KeyValuePair String, NLSMap NDPair , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair String, NLSMap NDPair , TComparand (Func KeyValuePair String, NLSMap NDPair , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault KeyValuePair String, NLSMap NDPair | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair String, NLSMap NDPair (Action KeyValuePair String, NLSMap NDPair ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair String, NLSMap NDPair (Action KeyValuePair String, NLSMap NDPair , Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair String, NLSMap NDPair | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair String, NLSMap NDPair (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Data |
 | MAX_ISO_COUNT |
Back to Top
Properties
 | Name | Description
Public property | Count |
Public property | Item Int32 |
Public property | Item String |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
NLSMap Structure
NFX.Serialization.JSON Namespace


NLSMap Constructor

NLSMap Constructor NFX Class Library

Overload List
 | Name | Description
Public method | NLSMap(String) | Makes NLSMap out of JSON string: {eng: {n: 'Cucumber',d: 'It is green'}, deu: {n='Gurke',d='Es ist grün'}}
Public method | NLSMap(IConfigSectionNode) | Makes NLSMap out of conf node: eng{n='Cucumber' d='It is green'} deu{n='Gurke' d='Es ist grün'}
Protected method | NLSMap( NLSMap NDPair ) | Initializes a new instance of the NLSMap class
Back to Top
See Also
NLSMap Structure
NLSMap Members
NFX.Serialization.JSON Namespace


NLSMap Constructor (String)

NLSMap Constructor (String) NFX Class Library

Makes NLSMap out of JSON string: {eng: {n: 'Cucumber',d: 'It is green'}, deu: {n='Gurke',d='Es ist grün'}}

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NLSMap(
    string nlsConf
)
public NLSMap(
    string nlsConf
)
Public Sub New (
    nlsConf As String
)
Public Sub New (
    nlsConf As String
)
public:
NLSMap(
    String^ nlsConf
)
public:
NLSMap(
    String^ nlsConf
)
new :
        nlsConf : string -> NLSMap
new :
        nlsConf : string -> NLSMap

Parameters

nlsConf
Type: Online System String
See Also
NLSMap Structure
NLSMap Members
NLSMap Overload
NFX.Serialization.JSON Namespace


NLSMap Constructor (IConfigSectionNode)

NLSMap Constructor (IConfigSectionNode) NFX Class Library

Makes NLSMap out of conf node: eng{n='Cucumber' d='It is green'} deu{n='Gurke' d='Es ist grün'}

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NLSMap(
    IConfigSectionNode nlsNode
)
public NLSMap(
    IConfigSectionNode nlsNode
)
Public Sub New (
    nlsNode As IConfigSectionNode
)
Public Sub New (
    nlsNode As IConfigSectionNode
)
public:
NLSMap(
    IConfigSectionNode^ nlsNode
)
public:
NLSMap(
    IConfigSectionNode^ nlsNode
)
new :
        nlsNode : IConfigSectionNode -> NLSMap
new :
        nlsNode : IConfigSectionNode -> NLSMap

Parameters

nlsNode
Type: NFX.Environment IConfigSectionNode
See Also
NLSMap Structure
NLSMap Members
NLSMap Overload
NFX.Serialization.JSON Namespace


NLSMap Constructor (NLSMap.NDPair[])

NLSMap Constructor ( NLSMap NDPair ) NFX Class Library

Initializes a new instance of the NLSMap class

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal NLSMap(
    NLSMap..::..NDPair[] data
)
internal NLSMap(
    NLSMap..::..NDPair[] data
)
Friend Sub New (
    data As NLSMap..::..NDPair()
)
Friend Sub New (
    data As NLSMap..::..NDPair()
)
internal:
NLSMap(
    array<NLSMap..::..NDPair>^ data
)
internal:
NLSMap(
    array<NLSMap..::..NDPair>^ data
)
new :
        data : NLSMap..::..NDPair[] -> NLSMap
new :
        data : NLSMap..::..NDPair[] -> NLSMap

Parameters

data
Type: NFX.Serialization.JSON NLSMap NDPair
See Also
NLSMap Structure
NLSMap Members
NLSMap Overload
NFX.Serialization.JSON Namespace


NLSMap Fields

NLSMap Fields NFX Class Library

The NLSMap type exposes the following members.
Fields
 | Name | Description
Protected field | m_Data |
 | MAX_ISO_COUNT |
Back to Top
See Also
NLSMap Structure
NFX.Serialization.JSON Namespace


NLSMap.m_Data Field

NLSMap m_Data Field NFX Class Library

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal NLSMap..::..NDPair[] m_Data
internal NLSMap..::..NDPair[] m_Data
Friend m_Data As NLSMap..::..NDPair()
Friend m_Data As NLSMap..::..NDPair()
internal:
array<NLSMap..::..NDPair>^ m_Data
internal:
array<NLSMap..::..NDPair>^ m_Data
val mutable internal m_Data: NLSMap..::..NDPair[]
val mutable internal m_Data: NLSMap..::..NDPair[]

Field Value

Type: NLSMap NDPair
See Also
NLSMap Structure
NLSMap Members
NFX.Serialization.JSON Namespace


NLSMap.MAX_ISO_COUNT Field

NLSMap MAX_ISO_COUNT Field NFX Class Library

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_ISO_COUNT
public const int MAX_ISO_COUNT
Public Const MAX_ISO_COUNT As Integer
Public Const MAX_ISO_COUNT As Integer
public:
literal int MAX_ISO_COUNT
public:
literal int MAX_ISO_COUNT
static val mutable MAX_ISO_COUNT: int
static val mutable MAX_ISO_COUNT: int

Field Value

Type: Online Int32
See Also
NLSMap Structure
NLSMap Members
NFX.Serialization.JSON Namespace


NLSMap Methods

NLSMap Methods NFX Class Library

The NLSMap type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Get | Tries to get the specified part(s) from the map defaulting to another lang if requested lang is not found. Returns null if nothing is found
Public method | GetEnumerator |
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OverrideBy | Takes entries from this instance and overides them by ISO keys from another instance returning the new instance
Public method | ToString | (Overrides Online ValueType ToString .)
 | TryGet | Tries to get the specified part(s) from the JSON content that represents map defaulting to another lang if requested lang is not found. Returns null if nothing is found
Public method | WriteAsJSON | Writes NLSMap either as a dict or as a {n:"", d: ""} pair as Options.NLSMapLanguageISO filter dictates
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable KeyValuePair String, NLSMap NDPair | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct KeyValuePair String, NLSMap NDPair , TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair String, NLSMap NDPair , TComparand (Func KeyValuePair String, NLSMap NDPair , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax KeyValuePair String, NLSMap NDPair , TComparand (Func KeyValuePair String, NLSMap NDPair , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair String, NLSMap NDPair , TComparand (Func KeyValuePair String, NLSMap NDPair , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin KeyValuePair String, NLSMap NDPair , TComparand (Func KeyValuePair String, NLSMap NDPair , TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault KeyValuePair String, NLSMap NDPair | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair String, NLSMap NDPair (Action KeyValuePair String, NLSMap NDPair ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach KeyValuePair String, NLSMap NDPair (Action KeyValuePair String, NLSMap NDPair , Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair String, NLSMap NDPair | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast KeyValuePair String, NLSMap NDPair (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
NLSMap Structure
NFX.Serialization.JSON Namespace


NLSMap.IEnumerable.GetEnumerator Method

NLSMap IEnumerable GetEnumerator Method NFX Class Library

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
NLSMap Structure
NLSMap Members
NFX.Serialization.JSON Namespace


NLSMap.Get Method

NLSMap Get Method NFX Class Library

Tries to get the specified part(s) from the map defaulting to another lang if requested lang is not found. Returns null if nothing is found

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Get(
    NLSMap..::..GetParts tp,
    string langIso = null,
    string dfltLangIso = null,
    string concat = null
)
public string Get(
    NLSMap..::..GetParts tp,
    string langIso = null,
    string dfltLangIso = null,
    string concat = null
)
Public Function Get (
    tp As NLSMap..::..GetParts,
    Optional langIso As String = Nothing,
    Optional dfltLangIso As String = Nothing,
    Optional concat As String = Nothing
) As String
Public Function Get (
    tp As NLSMap..::..GetParts,
    Optional langIso As String = Nothing,
    Optional dfltLangIso As String = Nothing,
    Optional concat As String = Nothing
) As String
public:
String^ Get(
    NLSMap..::..GetParts tp,
    String^ langIso = nullptr,
    String^ dfltLangIso = nullptr,
    String^ concat = nullptr
)
public:
String^ Get(
    NLSMap..::..GetParts tp,
    String^ langIso = nullptr,
    String^ dfltLangIso = nullptr,
    String^ concat = nullptr
)
member Get :
        tp : NLSMap..::..GetParts *
        ?langIso : string *
        ?dfltLangIso : string *
        ?concat : string
(* Defaults:
        let _langIso = defaultArg langIso null
        let _dfltLangIso = defaultArg dfltLangIso null
        let _concat = defaultArg concat null
*)
-> string
member Get :
        tp : NLSMap..::..GetParts *
        ?langIso : string *
        ?dfltLangIso : string *
        ?concat : string
(* Defaults:
        let _langIso = defaultArg langIso null
        let _dfltLangIso = defaultArg dfltLangIso null
        let _concat = defaultArg concat null
*)
-> string

Parameters

tp
Type: NFX.Serialization.JSON NLSMap GetParts
langIso (Optional)
Type: Online System String
dfltLangIso (Optional)
Type: Online System String
concat (Optional)
Type: Online System String

Return Value

Type: Online String
See Also
NLSMap Structure
NLSMap Members
NFX.Serialization.JSON Namespace


NLSMap.GetEnumerator Method

NLSMap GetEnumerator Method NFX Class Library

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<KeyValuePair<string, NLSMap..::..NDPair>> GetEnumerator()
public IEnumerator<KeyValuePair<string, NLSMap..::..NDPair>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of String, NLSMap..::..NDPair))
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of String, NLSMap..::..NDPair))
public:
virtual IEnumerator<KeyValuePair<String^, NLSMap..::..NDPair>>^ GetEnumerator() sealed
public:
virtual IEnumerator<KeyValuePair<String^, NLSMap..::..NDPair>>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<string, NLSMap..::..NDPair>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<string, NLSMap..::..NDPair>>
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<string, NLSMap..::..NDPair>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<string, NLSMap..::..NDPair>>

Return Value

Type: Online IEnumerator Online KeyValuePair Online String, NLSMap NDPair

Implements

Online IEnumerable T GetEnumerator
See Also
NLSMap Structure
NLSMap Members
NFX.Serialization.JSON Namespace


NLSMap.OverrideBy Method

NLSMap OverrideBy Method NFX Class Library

Takes entries from this instance and overides them by ISO keys from another instance returning the new instance

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NLSMap OverrideBy(
    NLSMap other
)
public NLSMap OverrideBy(
    NLSMap other
)
Public Function OverrideBy (
    other As NLSMap
) As NLSMap
Public Function OverrideBy (
    other As NLSMap
) As NLSMap
public:
NLSMap OverrideBy(
    NLSMap other
)
public:
NLSMap OverrideBy(
    NLSMap other
)
member OverrideBy :
        other : NLSMap -> NLSMap
member OverrideBy :
        other : NLSMap -> NLSMap

Parameters

other
Type: NFX.Serialization.JSON NLSMap

Return Value

Type: NLSMap
See Also
NLSMap Structure
NLSMap Members
NFX.Serialization.JSON Namespace


NLSMap.ToString Method

NLSMap ToString Method NFX Class Library

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
NLSMap Structure
NLSMap Members
NFX.Serialization.JSON Namespace


NLSMap.TryGet Method

NLSMap TryGet Method NFX Class Library

Tries to get the specified part(s) from the JSON content that represents map defaulting to another lang if requested lang is not found. Returns null if nothing is found

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool TryGet(
    string json,
    out string result,
    NLSMap..::..GetParts tp,
    string langIso = null,
    string dfltLangIso = null,
    string concat = null
)
public static bool TryGet(
    string json,
    out string result,
    NLSMap..::..GetParts tp,
    string langIso = null,
    string dfltLangIso = null,
    string concat = null
)
Public Shared Function TryGet (
    json As String,
    <OutAttribute> ByRef result As String,
    tp As NLSMap..::..GetParts,
    Optional langIso As String = Nothing,
    Optional dfltLangIso As String = Nothing,
    Optional concat As String = Nothing
) As Boolean
Public Shared Function TryGet (
    json As String,
    <OutAttribute> ByRef result As String,
    tp As NLSMap..::..GetParts,
    Optional langIso As String = Nothing,
    Optional dfltLangIso As String = Nothing,
    Optional concat As String = Nothing
) As Boolean
public:
static bool TryGet(
    String^ json,
    [OutAttribute] String^% result,
    NLSMap..::..GetParts tp,
    String^ langIso = nullptr,
    String^ dfltLangIso = nullptr,
    String^ concat = nullptr
)
public:
static bool TryGet(
    String^ json,
    [OutAttribute] String^% result,
    NLSMap..::..GetParts tp,
    String^ langIso = nullptr,
    String^ dfltLangIso = nullptr,
    String^ concat = nullptr
)
static member TryGet :
        json : string *
        result : string byref *
        tp : NLSMap..::..GetParts *
        ?langIso : string *
        ?dfltLangIso : string *
        ?concat : string
(* Defaults:
        let _langIso = defaultArg langIso null
        let _dfltLangIso = defaultArg dfltLangIso null
        let _concat = defaultArg concat null
*)
-> bool
static member TryGet :
        json : string *
        result : string byref *
        tp : NLSMap..::..GetParts *
        ?langIso : string *
        ?dfltLangIso : string *
        ?concat : string
(* Defaults:
        let _langIso = defaultArg langIso null
        let _dfltLangIso = defaultArg dfltLangIso null
        let _concat = defaultArg concat null
*)
-> bool

Parameters

json
Type: Online System String
result
Type: Online System String
tp
Type: NFX.Serialization.JSON NLSMap GetParts
langIso (Optional)
Type: Online System String
dfltLangIso (Optional)
Type: Online System String
concat (Optional)
Type: Online System String

Return Value

Type: Online Boolean
See Also
NLSMap Structure
NLSMap Members
NFX.Serialization.JSON Namespace


NLSMap.WriteAsJSON Method

NLSMap WriteAsJSON Method NFX Class Library

Writes NLSMap either as a dict or as a {n:"", d: ""} pair as Options.NLSMapLanguageISO filter dictates

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
nestingLevel
Type: Online System Int32
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Implements

IJSONWritable WriteAsJSON(TextWriter, Int32, JSONWritingOptions)
See Also
NLSMap Structure
NLSMap Members
NFX.Serialization.JSON Namespace


NLSMap Properties

NLSMap Properties NFX Class Library

The NLSMap type exposes the following members.
Properties
 | Name | Description
Public property | Count |
Public property | Item Int32 |
Public property | Item String |
Back to Top
See Also
NLSMap Structure
NFX.Serialization.JSON Namespace


NLSMap.Count Property

NLSMap Count Property NFX Class Library

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
public:
property int Count {
    int get ();
}
member Count : int with get
member Count : int with get

Property Value

Type: Online Int32
See Also
NLSMap Structure
NLSMap Members
NFX.Serialization.JSON Namespace


NLSMap.Item Property

NLSMap Item Property NFX Class Library

Overload List
 | Name | Description
Public property | Item Int32 |
Public property | Item String |
Back to Top
See Also
NLSMap Structure
NLSMap Members
NFX.Serialization.JSON Namespace


NLSMap.Item Property (Int32)

NLSMap Item Property (Int32) NFX Class Library

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NLSMap..::..NDPair this[
    int iso
] { get; }
public NLSMap..::..NDPair this[
    int iso
] { get; }
Public ReadOnly Default Property Item (
    iso As Integer
) As NLSMap..::..NDPair
    Get
Public ReadOnly Default Property Item (
    iso As Integer
) As NLSMap..::..NDPair
    Get
public:
property NLSMap..::..NDPair default[int iso] {
    NLSMap..::..NDPair get (int iso);
}
public:
property NLSMap..::..NDPair default[int iso] {
    NLSMap..::..NDPair get (int iso);
}
member Item : NLSMap..::..NDPair with get
member Item : NLSMap..::..NDPair with get

Parameters

iso
Type: Online System Int32

Property Value

Type: NLSMap NDPair
See Also
NLSMap Structure
NLSMap Members
Item Overload
NFX.Serialization.JSON Namespace


NLSMap.Item Property (String)

NLSMap Item Property (String) NFX Class Library

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NLSMap..::..NDPair this[
    string langIso
] { get; }
public NLSMap..::..NDPair this[
    string langIso
] { get; }
Public ReadOnly Default Property Item (
    langIso As String
) As NLSMap..::..NDPair
    Get
Public ReadOnly Default Property Item (
    langIso As String
) As NLSMap..::..NDPair
    Get
public:
property NLSMap..::..NDPair default[String^ langIso] {
    NLSMap..::..NDPair get (String^ langIso);
}
public:
property NLSMap..::..NDPair default[String^ langIso] {
    NLSMap..::..NDPair get (String^ langIso);
}
member Item : NLSMap..::..NDPair with get
member Item : NLSMap..::..NDPair with get

Parameters

langIso
Type: Online System String

Property Value

Type: NLSMap NDPair
See Also
NLSMap Structure
NLSMap Members
Item Overload
NFX.Serialization.JSON Namespace


NLSMap.Builder Structure

NLSMap Builder Structure NFX Class Library

Facilitates the population of NLSMap from code

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct Builder
public struct Builder
Public Structure Builder
Public Structure Builder
public value class Builder
public value class Builder
[<SealedAttribute>]
type Builder =  struct end
[<SealedAttribute>]
type Builder =  struct end
See Also
NLSMap Builder Members
NFX.Serialization.JSON Namespace


NLSMap.Builder Members

NLSMap Builder Members NFX Class Library

The NLSMap Builder type exposes the following members.
Methods
 | Name | Description
Public method | Add |
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Map | Returns the built map
Back to Top
See Also
NLSMap Builder Structure
NFX.Serialization.JSON Namespace


NLSMap.Builder Methods

NLSMap Builder Methods NFX Class Library

The NLSMap Builder type exposes the following members.
Methods
 | Name | Description
Public method | Add |
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
NLSMap Builder Structure
NFX.Serialization.JSON Namespace


NLSMap.Builder.Add Method

NLSMap Builder Add Method NFX Class Library

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NLSMap..::..Builder Add(
    string langIso,
    string n,
    string d
)
public NLSMap..::..Builder Add(
    string langIso,
    string n,
    string d
)
Public Function Add (
    langIso As String,
    n As String,
    d As String
) As NLSMap..::..Builder
Public Function Add (
    langIso As String,
    n As String,
    d As String
) As NLSMap..::..Builder
public:
NLSMap..::..Builder Add(
    String^ langIso,
    String^ n,
    String^ d
)
public:
NLSMap..::..Builder Add(
    String^ langIso,
    String^ n,
    String^ d
)
member Add :
        langIso : string *
        n : string *
        d : string -> NLSMap..::..Builder
member Add :
        langIso : string *
        n : string *
        d : string -> NLSMap..::..Builder

Parameters

langIso
Type: Online System String
n
Type: Online System String
d
Type: Online System String

Return Value

Type: NLSMap Builder
See Also
NLSMap Builder Structure
NLSMap Builder Members
NFX.Serialization.JSON Namespace


NLSMap.Builder Properties

NLSMap Builder Properties NFX Class Library

The NLSMap Builder type exposes the following members.
Properties
 | Name | Description
Public property | Map | Returns the built map
Back to Top
See Also
NLSMap Builder Structure
NFX.Serialization.JSON Namespace


NLSMap.Builder.Map Property

NLSMap Builder Map Property NFX Class Library

Returns the built map

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NLSMap Map { get; }
public NLSMap Map { get; }
Public ReadOnly Property Map As NLSMap
    Get
Public ReadOnly Property Map As NLSMap
    Get
public:
property NLSMap Map {
    NLSMap get ();
}
public:
property NLSMap Map {
    NLSMap get ();
}
member Map : NLSMap with get
member Map : NLSMap with get

Property Value

Type: NLSMap
See Also
NLSMap Builder Structure
NLSMap Builder Members
NFX.Serialization.JSON Namespace


NLSMap.GetParts Enumeration

NLSMap GetParts Enumeration NFX Class Library

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum GetParts
public enum GetParts
Public Enumeration GetParts
Public Enumeration GetParts
public enum class GetParts
public enum class GetParts
type GetParts
type GetParts
Members
Member name | Value | Description
Name | 0 |
Description | 1 |
NameOrDescription | 2 |
DescriptionOrName | 3 |
NameAndDescription | 4 |
DescriptionAndName | 5 |
See Also
NFX.Serialization.JSON Namespace


NLSMap.NDPair Structure

NLSMap NDPair Structure NFX Class Library

Localized Name:Description pair

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct NDPair : IJSONWritable
public struct NDPair : IJSONWritable
Public Structure NDPair
    Implements IJSONWritable
Public Structure NDPair
    Implements IJSONWritable
public value class NDPair : IJSONWritable
public value class NDPair : IJSONWritable
[<SealedAttribute>]
type NDPair =
    struct
        interface IJSONWritable
    end
[<SealedAttribute>]
type NDPair =
    struct
        interface IJSONWritable
    end
See Also
NLSMap NDPair Members
NFX.Serialization.JSON Namespace


NLSMap.NDPair Members

NLSMap NDPair Members NFX Class Library

The NLSMap NDPair type exposes the following members.
Constructors
 | Name | Description
Protected method | NLSMap NDPair | Initializes a new instance of the NLSMap NDPair class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Description |
Public field | ISO |
Public field | Name |
Back to Top
Properties
 | Name | Description
Public property | IsAssigned |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IJSONWritable WriteAsJSON |
Back to Top
See Also
NLSMap NDPair Structure
NFX.Serialization.JSON Namespace


NLSMap.NDPair Constructor

NLSMap NDPair Constructor NFX Class Library

Initializes a new instance of the NLSMap NDPair class

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal NDPair(
    int iso,
    string name,
    string descr
)
internal NDPair(
    int iso,
    string name,
    string descr
)
Friend Sub New (
    iso As Integer,
    name As String,
    descr As String
)
Friend Sub New (
    iso As Integer,
    name As String,
    descr As String
)
internal:
NDPair(
    int iso,
    String^ name,
    String^ descr
)
internal:
NDPair(
    int iso,
    String^ name,
    String^ descr
)
new :
        iso : int *
        name : string *
        descr : string -> NDPair
new :
        iso : int *
        name : string *
        descr : string -> NDPair

Parameters

iso
Type: Online System Int32
name
Type: Online System String
descr
Type: Online System String
See Also
NLSMap NDPair Structure
NLSMap NDPair Members
NFX.Serialization.JSON Namespace


NLSMap.NDPair Fields

NLSMap NDPair Fields NFX Class Library

The NLSMap NDPair type exposes the following members.
Fields
 | Name | Description
Public field | Description |
Public field | ISO |
Public field | Name |
Back to Top
See Also
NLSMap NDPair Structure
NFX.Serialization.JSON Namespace


NLSMap.NDPair.Description Field

NLSMap NDPair Description Field NFX Class Library

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Description
public readonly string Description
Public ReadOnly Description As String
Public ReadOnly Description As String
public:
initonly String^ Description
public:
initonly String^ Description
val Description: string
val Description: string

Field Value

Type: Online String
See Also
NLSMap NDPair Structure
NLSMap NDPair Members
NFX.Serialization.JSON Namespace


NLSMap.NDPair.ISO Field

NLSMap NDPair ISO Field NFX Class Library

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly int ISO
public readonly int ISO
Public ReadOnly ISO As Integer
Public ReadOnly ISO As Integer
public:
initonly int ISO
public:
initonly int ISO
val ISO: int
val ISO: int

Field Value

Type: Online Int32
See Also
NLSMap NDPair Structure
NLSMap NDPair Members
NFX.Serialization.JSON Namespace


NLSMap.NDPair.Name Field

NLSMap NDPair Name Field NFX Class Library

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Name
public readonly string Name
Public ReadOnly Name As String
Public ReadOnly Name As String
public:
initonly String^ Name
public:
initonly String^ Name
val Name: string
val Name: string

Field Value

Type: Online String
See Also
NLSMap NDPair Structure
NLSMap NDPair Members
NFX.Serialization.JSON Namespace


NLSMap.NDPair Methods

NLSMap NDPair Methods NFX Class Library

The NLSMap NDPair type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IJSONWritable WriteAsJSON |
Back to Top
See Also
NLSMap NDPair Structure
NFX.Serialization.JSON Namespace


NLSMap.NDPair.IJSONWritable.WriteAsJSON Method

NLSMap NDPair IJSONWritable WriteAsJSON Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void IJSONWritable.WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options
)
void IJSONWritable.WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options
)
Private Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    options As JSONWritingOptions
) Implements IJSONWritable.WriteAsJSON
Private Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    options As JSONWritingOptions
) Implements IJSONWritable.WriteAsJSON
private:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options
) sealed = IJSONWritable::WriteAsJSON
private:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options
) sealed = IJSONWritable::WriteAsJSON
private abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        options : JSONWritingOptions -> unit
private override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        options : JSONWritingOptions -> unit
private abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        options : JSONWritingOptions -> unit
private override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        options : JSONWritingOptions -> unit

Parameters

wri
Type: Online System.IO TextWriter
nestingLevel
Type: Online System Int32
options
Type: NFX.Serialization.JSON JSONWritingOptions

Implements

IJSONWritable WriteAsJSON(TextWriter, Int32, JSONWritingOptions)
See Also
NLSMap NDPair Structure
NLSMap NDPair Members
NFX.Serialization.JSON Namespace


NLSMap.NDPair Properties

NLSMap NDPair Properties NFX Class Library

The NLSMap NDPair type exposes the following members.
Properties
 | Name | Description
Public property | IsAssigned |
Back to Top
See Also
NLSMap NDPair Structure
NFX.Serialization.JSON Namespace


NLSMap.NDPair.IsAssigned Property

NLSMap NDPair IsAssigned Property NFX Class Library

Namespace: NFX.Serialization.JSON
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsAssigned { get; }
public bool IsAssigned { get; }
Public ReadOnly Property IsAssigned As Boolean
    Get
Public ReadOnly Property IsAssigned As Boolean
    Get
public:
property bool IsAssigned {
    bool get ();
}
public:
property bool IsAssigned {
    bool get ();
}
member IsAssigned : bool with get
member IsAssigned : bool with get

Property Value

Type: Online Boolean
See Also
NLSMap NDPair Structure
NLSMap NDPair Members
NFX.Serialization.JSON Namespace


NFX.Serialization.POD Namespace

NFX.Serialization.POD Namespace NFX Class Library

Provides Portable Object Document serialization functionality
Classes
 | Class | Description
Public class | CompositeArrayData | Represents a composite (non primitive) array data stored in Portable Object Document.
Public class | CompositeCustomData | Represents a composite (non primitive) data stored in Portable Object Document. This data is obtained from native types using ISerializable interface or running PortableObjectDocumentTransform attribute. This class is NOT used for native types that perform default reflection-based serialization, for that CompositeReflectedData is used
Public class | CompositeData | Represents a composite (non primitive) data stored in Portable Object Document. This data is obtained from native types either automatically using reflection or from types that perform custom serialization using ISerializable interface
Public class | CompositeReflectedData | Represents a composite (non primitive) data stored in Portable Object Document. This data is obtained from native types automatically using reflection. This class is NOT used for native types that perform custom serialization using ISerializable interface, for that CompositeCustomData is used
Public class | MetaComplexType | Represents information about the composite type of data that is stored in Portable Object Document
Public class | MetaComplexType MetaField | Represents an information about a field of same type
Public class | MetaPrimitiveType | Represents primitive built-in types in the framework that are stored in Portable Object Document
Public class | MetaType | Provides information about data types stored in Portable Object Document
Public class | PODDeserializationException | Base exception thrown by the PortableObjectDocument when deserializing original objects
Public class | PODException | Base exception thrown by the Portable Object Document serialization format
Public class | PODSerializationException | Base exception thrown by the PortableObjectDocument when serializing objects into document
Public class | PortableObjectDocument | Represents an graph of arbitrary CLR objects as a graph of well known POD-objects which are based on primitive-only types. This class acts as a Document-Object-Model container that hosts comlex CLR types that may change their structure but need to be deserialized even if deserialization is partial / requires transform
Public class | PortableObjectDocumentDeserializationTransform | Represents an entity that knows how to transform/apply CLR data types from PortableObjectDocument
Public class | PortableObjectDocumentSerializationTransform | Represents an entity that knows how to transform/apply CLR data types to PortableObjectDocument
Public class | ReadingStrategy | Represents logic that resolves POD data types and field layouts to CLR types/layouts. Extend this type and pass its instance into PortableObjectDocument.ToOriginalObject(ReadingStrategy)
Structures
 | Structure | Description
Public structure | CustomTypedEntry | Used in custom data bags to specify the type of the object contained in Data property if it is intended to be re-interpreted


CompositeArrayData Class

CompositeArrayData Class NFX Class Library

Represents a composite (non primitive) array data stored in Portable Object Document.
Inheritance Hierarchy
Online System Object
NFX.Serialization.POD CompositeData
NFX.Serialization.POD CompositeArrayData

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class CompositeArrayData : CompositeData
[SerializableAttribute]
public sealed class CompositeArrayData : CompositeData
<SerializableAttribute>
Public NotInheritable Class CompositeArrayData
    Inherits CompositeData
<SerializableAttribute>
Public NotInheritable Class CompositeArrayData
    Inherits CompositeData
[SerializableAttribute]
public ref class CompositeArrayData sealed : public CompositeData
[SerializableAttribute]
public ref class CompositeArrayData sealed : public CompositeData
[<SealedAttribute>]
[<SerializableAttribute>]
type CompositeArrayData =
    class
        inherit CompositeData
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type CompositeArrayData =
    class
        inherit CompositeData
    end
See Also
CompositeArrayData Members
NFX.Serialization.POD Namespace


CompositeArrayData Members

CompositeArrayData Members NFX Class Library

The CompositeArrayData type exposes the following members.
Constructors
 | Name | Description
Protected method | CompositeArrayData | Initializes a new instance of the CompositeArrayData class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | __CLRObject | (Inherited from CompositeData.)
Public field | m_ArrayData |
Public field | m_ArrayDims |
Protected field | m_Document | (Inherited from CompositeData.)
Public field | m_ExistingReferenceIndex | (Inherited from CompositeData.)
Public field | m_MetaTypeIndex | (Inherited from CompositeData.)
Back to Top
Properties
 | Name | Description
Public property | ArrayData | Returns field data that this instance contains, or null if this instance is a reference to another object
Public property | ArrayDims | Returns array dimensions
Public property | Document | Returns document instance that contains this type (Inherited from CompositeData.)
Public property | ExistingReference | Returns true when this instance contains a reference to existing object (Inherited from CompositeData.)
Public property | ExistingReferenceIndex | Returns either an index that is less than 0 or and index to an existing object which is >=0 (Inherited from CompositeData.)
Public property | Referenced | Returns another composite data that is referenced, if nothing is referenced, returns null (Inherited from CompositeData.)
Public property | Type | Returns type of this data (Inherited from CompositeData.)
Back to Top
See Also
CompositeArrayData Class
NFX.Serialization.POD Namespace


CompositeArrayData Constructor

CompositeArrayData Constructor NFX Class Library

Initializes a new instance of the CompositeArrayData class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CompositeArrayData(
    PortableObjectDocument document,
    Array data,
    int metaTypeIndex = -1
)
internal CompositeArrayData(
    PortableObjectDocument document,
    Array data,
    int metaTypeIndex = -1
)
Friend Sub New (
    document As PortableObjectDocument,
    data As Array,
    Optional metaTypeIndex As Integer = -1
)
Friend Sub New (
    document As PortableObjectDocument,
    data As Array,
    Optional metaTypeIndex As Integer = -1
)
internal:
CompositeArrayData(
    PortableObjectDocument^ document,
    Array^ data,
    int metaTypeIndex = -1
)
internal:
CompositeArrayData(
    PortableObjectDocument^ document,
    Array^ data,
    int metaTypeIndex = -1
)
new :
        document : PortableObjectDocument *
        data : Array *
        ?metaTypeIndex : int
(* Defaults:
        let _metaTypeIndex = defaultArg metaTypeIndex -1
*)
-> CompositeArrayData
new :
        document : PortableObjectDocument *
        data : Array *
        ?metaTypeIndex : int
(* Defaults:
        let _metaTypeIndex = defaultArg metaTypeIndex -1
*)
-> CompositeArrayData

Parameters

document
Type: NFX.Serialization.POD PortableObjectDocument
data
Type: Online System Array
metaTypeIndex (Optional)
Type: Online System Int32
See Also
CompositeArrayData Class
CompositeArrayData Members
NFX.Serialization.POD Namespace


CompositeArrayData Fields

CompositeArrayData Fields NFX Class Library

The CompositeArrayData type exposes the following members.
Fields
 | Name | Description
Protected field | __CLRObject | (Inherited from CompositeData.)
Public field | m_ArrayData |
Public field | m_ArrayDims |
Protected field | m_Document | (Inherited from CompositeData.)
Public field | m_ExistingReferenceIndex | (Inherited from CompositeData.)
Public field | m_MetaTypeIndex | (Inherited from CompositeData.)
Back to Top
See Also
CompositeArrayData Class
NFX.Serialization.POD Namespace


CompositeArrayData.m_ArrayData Field

CompositeArrayData m_ArrayData Field NFX Class Library

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object[] m_ArrayData
public Object[] m_ArrayData
Public m_ArrayData As Object()
Public m_ArrayData As Object()
public:
array<Object^>^ m_ArrayData
public:
array<Object^>^ m_ArrayData
val mutable m_ArrayData: Object[]
val mutable m_ArrayData: Object[]

Field Value

Type: Online Object
See Also
CompositeArrayData Class
CompositeArrayData Members
NFX.Serialization.POD Namespace


CompositeArrayData.m_ArrayDims Field

CompositeArrayData m_ArrayDims Field NFX Class Library

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int[] m_ArrayDims
public int[] m_ArrayDims
Public m_ArrayDims As Integer()
Public m_ArrayDims As Integer()
public:
array<int>^ m_ArrayDims
public:
array<int>^ m_ArrayDims
val mutable m_ArrayDims: int[]
val mutable m_ArrayDims: int[]

Field Value

Type: Online Int32
See Also
CompositeArrayData Class
CompositeArrayData Members
NFX.Serialization.POD Namespace


CompositeArrayData Methods

CompositeArrayData Methods NFX Class Library

The CompositeArrayData type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CompositeArrayData Class
NFX.Serialization.POD Namespace


CompositeArrayData Properties

CompositeArrayData Properties NFX Class Library

The CompositeArrayData type exposes the following members.
Properties
 | Name | Description
Public property | ArrayData | Returns field data that this instance contains, or null if this instance is a reference to another object
Public property | ArrayDims | Returns array dimensions
Public property | Document | Returns document instance that contains this type (Inherited from CompositeData.)
Public property | ExistingReference | Returns true when this instance contains a reference to existing object (Inherited from CompositeData.)
Public property | ExistingReferenceIndex | Returns either an index that is less than 0 or and index to an existing object which is >=0 (Inherited from CompositeData.)
Public property | Referenced | Returns another composite data that is referenced, if nothing is referenced, returns null (Inherited from CompositeData.)
Public property | Type | Returns type of this data (Inherited from CompositeData.)
Back to Top
See Also
CompositeArrayData Class
NFX.Serialization.POD Namespace


CompositeArrayData.ArrayData Property

CompositeArrayData ArrayData Property NFX Class Library

Returns field data that this instance contains, or null if this instance is a reference to another object

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object[] ArrayData { get; }
public Object[] ArrayData { get; }
Public ReadOnly Property ArrayData As Object()
    Get
Public ReadOnly Property ArrayData As Object()
    Get
public:
property array<Object^>^ ArrayData {
    array<Object^>^ get ();
}
public:
property array<Object^>^ ArrayData {
    array<Object^>^ get ();
}
member ArrayData : Object[] with get
member ArrayData : Object[] with get

Property Value

Type: Online Object
See Also
CompositeArrayData Class
CompositeArrayData Members
NFX.Serialization.POD Namespace


CompositeArrayData.ArrayDims Property

CompositeArrayData ArrayDims Property NFX Class Library

Returns array dimensions

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int[] ArrayDims { get; }
public int[] ArrayDims { get; }
Public ReadOnly Property ArrayDims As Integer()
    Get
Public ReadOnly Property ArrayDims As Integer()
    Get
public:
property array<int>^ ArrayDims {
    array<int>^ get ();
}
public:
property array<int>^ ArrayDims {
    array<int>^ get ();
}
member ArrayDims : int[] with get
member ArrayDims : int[] with get

Property Value

Type: Online Int32
See Also
CompositeArrayData Class
CompositeArrayData Members
NFX.Serialization.POD Namespace


CompositeCustomData Class

CompositeCustomData Class NFX Class Library

Represents a composite (non primitive) data stored in Portable Object Document. This data is obtained from native types using ISerializable interface or running PortableObjectDocumentTransform attribute. This class is NOT used for native types that perform default reflection-based serialization, for that CompositeReflectedData is used
Inheritance Hierarchy
Online System Object
NFX.Serialization.POD CompositeData
NFX.Serialization.POD CompositeCustomData

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class CompositeCustomData : CompositeData
[SerializableAttribute]
public sealed class CompositeCustomData : CompositeData
<SerializableAttribute>
Public NotInheritable Class CompositeCustomData
    Inherits CompositeData
<SerializableAttribute>
Public NotInheritable Class CompositeCustomData
    Inherits CompositeData
[SerializableAttribute]
public ref class CompositeCustomData sealed : public CompositeData
[SerializableAttribute]
public ref class CompositeCustomData sealed : public CompositeData
[<SealedAttribute>]
[<SerializableAttribute>]
type CompositeCustomData =
    class
        inherit CompositeData
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type CompositeCustomData =
    class
        inherit CompositeData
    end
See Also
CompositeCustomData Members
NFX.Serialization.POD Namespace


CompositeCustomData Members

CompositeCustomData Members NFX Class Library

The CompositeCustomData type exposes the following members.
Constructors
 | Name | Description
Protected method | CompositeCustomData(PortableObjectDocument, Object, Int32) | Initializes a new instance of the CompositeCustomData class
Protected method | CompositeCustomData(PortableObjectDocument, ISerializable, Int32) | Initializes a new instance of the CompositeCustomData class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | __CLRObject | (Inherited from CompositeData.)
Protected field | m_Document | (Inherited from CompositeData.)
Public field | m_ExistingReferenceIndex | (Inherited from CompositeData.)
Public field | m_MetaTypeIndex | (Inherited from CompositeData.)
Back to Top
Properties
 | Name | Description
Public property | CustomData | Returns custom data that this instance contains, or null if this instance is a reference to another object
Public property | Document | Returns document instance that contains this type (Inherited from CompositeData.)
Public property | ExistingReference | Returns true when this instance contains a reference to existing object (Inherited from CompositeData.)
Public property | ExistingReferenceIndex | Returns either an index that is less than 0 or and index to an existing object which is >=0 (Inherited from CompositeData.)
Public property | Referenced | Returns another composite data that is referenced, if nothing is referenced, returns null (Inherited from CompositeData.)
Public property | Type | Returns type of this data (Inherited from CompositeData.)
Back to Top
See Also
CompositeCustomData Class
NFX.Serialization.POD Namespace


CompositeCustomData Constructor

CompositeCustomData Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | CompositeCustomData(PortableObjectDocument, Object, Int32) | Initializes a new instance of the CompositeCustomData class
Protected method | CompositeCustomData(PortableObjectDocument, ISerializable, Int32) | Initializes a new instance of the CompositeCustomData class
Back to Top
See Also
CompositeCustomData Class
CompositeCustomData Members
NFX.Serialization.POD Namespace


CompositeCustomData Constructor (PortableObjectDocument, Object, Int32)

CompositeCustomData Constructor (PortableObjectDocument, Object, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CompositeCustomData class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CompositeCustomData(
    PortableObjectDocument document,
    Object data,
    int metaTypeIndex = -1
)
internal CompositeCustomData(
    PortableObjectDocument document,
    Object data,
    int metaTypeIndex = -1
)
Friend Sub New (
    document As PortableObjectDocument,
    data As Object,
    Optional metaTypeIndex As Integer = -1
)
Friend Sub New (
    document As PortableObjectDocument,
    data As Object,
    Optional metaTypeIndex As Integer = -1
)
internal:
CompositeCustomData(
    PortableObjectDocument^ document,
    Object^ data,
    int metaTypeIndex = -1
)
internal:
CompositeCustomData(
    PortableObjectDocument^ document,
    Object^ data,
    int metaTypeIndex = -1
)
new :
        document : PortableObjectDocument *
        data : Object *
        ?metaTypeIndex : int
(* Defaults:
        let _metaTypeIndex = defaultArg metaTypeIndex -1
*)
-> CompositeCustomData
new :
        document : PortableObjectDocument *
        data : Object *
        ?metaTypeIndex : int
(* Defaults:
        let _metaTypeIndex = defaultArg metaTypeIndex -1
*)
-> CompositeCustomData

Parameters

document
Type: NFX.Serialization.POD PortableObjectDocument
data
Type: Online System Object
metaTypeIndex (Optional)
Type: Online System Int32
See Also
CompositeCustomData Class
CompositeCustomData Members
CompositeCustomData Overload
NFX.Serialization.POD Namespace


CompositeCustomData Constructor (PortableObjectDocument, ISerializable, Int32)

CompositeCustomData Constructor (PortableObjectDocument, ISerializable, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CompositeCustomData class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CompositeCustomData(
    PortableObjectDocument document,
    ISerializable data,
    int metaTypeIndex = -1
)
internal CompositeCustomData(
    PortableObjectDocument document,
    ISerializable data,
    int metaTypeIndex = -1
)
Friend Sub New (
    document As PortableObjectDocument,
    data As ISerializable,
    Optional metaTypeIndex As Integer = -1
)
Friend Sub New (
    document As PortableObjectDocument,
    data As ISerializable,
    Optional metaTypeIndex As Integer = -1
)
internal:
CompositeCustomData(
    PortableObjectDocument^ document,
    ISerializable^ data,
    int metaTypeIndex = -1
)
internal:
CompositeCustomData(
    PortableObjectDocument^ document,
    ISerializable^ data,
    int metaTypeIndex = -1
)
new :
        document : PortableObjectDocument *
        data : ISerializable *
        ?metaTypeIndex : int
(* Defaults:
        let _metaTypeIndex = defaultArg metaTypeIndex -1
*)
-> CompositeCustomData
new :
        document : PortableObjectDocument *
        data : ISerializable *
        ?metaTypeIndex : int
(* Defaults:
        let _metaTypeIndex = defaultArg metaTypeIndex -1
*)
-> CompositeCustomData

Parameters

document
Type: NFX.Serialization.POD PortableObjectDocument
data
Type: Online System.Runtime.Serialization ISerializable
metaTypeIndex (Optional)
Type: Online System Int32
See Also
CompositeCustomData Class
CompositeCustomData Members
CompositeCustomData Overload
NFX.Serialization.POD Namespace


CompositeCustomData Fields

CompositeCustomData Fields NFX Class Library

The CompositeCustomData type exposes the following members.
Fields
 | Name | Description
Protected field | __CLRObject | (Inherited from CompositeData.)
Protected field | m_Document | (Inherited from CompositeData.)
Public field | m_ExistingReferenceIndex | (Inherited from CompositeData.)
Public field | m_MetaTypeIndex | (Inherited from CompositeData.)
Back to Top
See Also
CompositeCustomData Class
NFX.Serialization.POD Namespace


CompositeCustomData Methods

CompositeCustomData Methods NFX Class Library

The CompositeCustomData type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CompositeCustomData Class
NFX.Serialization.POD Namespace


CompositeCustomData Properties

CompositeCustomData Properties NFX Class Library

The CompositeCustomData type exposes the following members.
Properties
 | Name | Description
Public property | CustomData | Returns custom data that this instance contains, or null if this instance is a reference to another object
Public property | Document | Returns document instance that contains this type (Inherited from CompositeData.)
Public property | ExistingReference | Returns true when this instance contains a reference to existing object (Inherited from CompositeData.)
Public property | ExistingReferenceIndex | Returns either an index that is less than 0 or and index to an existing object which is >=0 (Inherited from CompositeData.)
Public property | Referenced | Returns another composite data that is referenced, if nothing is referenced, returns null (Inherited from CompositeData.)
Public property | Type | Returns type of this data (Inherited from CompositeData.)
Back to Top
See Also
CompositeCustomData Class
NFX.Serialization.POD Namespace


CompositeCustomData.CustomData Property

CompositeCustomData CustomData Property NFX Class Library

Returns custom data that this instance contains, or null if this instance is a reference to another object

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Dictionary<string, CustomTypedEntry> CustomData { get; }
public Dictionary<string, CustomTypedEntry> CustomData { get; }
Public ReadOnly Property CustomData As Dictionary(Of String, CustomTypedEntry)
    Get
Public ReadOnly Property CustomData As Dictionary(Of String, CustomTypedEntry)
    Get
public:
property Dictionary<String^, CustomTypedEntry>^ CustomData {
    Dictionary<String^, CustomTypedEntry>^ get ();
}
public:
property Dictionary<String^, CustomTypedEntry>^ CustomData {
    Dictionary<String^, CustomTypedEntry>^ get ();
}
member CustomData : Dictionary<string, CustomTypedEntry> with get
member CustomData : Dictionary<string, CustomTypedEntry> with get

Property Value

Type: Online Dictionary Online String, CustomTypedEntry
See Also
CompositeCustomData Class
CompositeCustomData Members
NFX.Serialization.POD Namespace


CompositeData Class

CompositeData Class NFX Class Library

Represents a composite (non primitive) data stored in Portable Object Document. This data is obtained from native types either automatically using reflection or from types that perform custom serialization using ISerializable interface
Inheritance Hierarchy
Online System Object
NFX.Serialization.POD CompositeData
NFX.Serialization.POD CompositeArrayData
NFX.Serialization.POD CompositeCustomData
NFX.Serialization.POD CompositeReflectedData

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class CompositeData
[SerializableAttribute]
public abstract class CompositeData
<SerializableAttribute>
Public MustInherit Class CompositeData
<SerializableAttribute>
Public MustInherit Class CompositeData
[SerializableAttribute]
public ref class CompositeData abstract
[SerializableAttribute]
public ref class CompositeData abstract
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type CompositeData =  class end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type CompositeData =  class end
See Also
CompositeData Members
NFX.Serialization.POD Namespace


CompositeData Members

CompositeData Members NFX Class Library

The CompositeData type exposes the following members.
Constructors
 | Name | Description
Protected method | CompositeData | Initializes a new instance of the CompositeData class
Protected method | CompositeData(PortableObjectDocument, Object, Int32) | Initializes a new instance of the CompositeData class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | __CLRObject |
Protected field | m_Document |
Public field | m_ExistingReferenceIndex |
Public field | m_MetaTypeIndex |
Back to Top
Properties
 | Name | Description
Public property | Document | Returns document instance that contains this type
Public property | ExistingReference | Returns true when this instance contains a reference to existing object
Public property | ExistingReferenceIndex | Returns either an index that is less than 0 or and index to an existing object which is >=0
Public property | Referenced | Returns another composite data that is referenced, if nothing is referenced, returns null
Public property | Type | Returns type of this data
Back to Top
See Also
CompositeData Class
NFX.Serialization.POD Namespace


CompositeData Constructor

CompositeData Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | CompositeData | Initializes a new instance of the CompositeData class
Protected method | CompositeData(PortableObjectDocument, Object, Int32) | Initializes a new instance of the CompositeData class
Back to Top
See Also
CompositeData Class
CompositeData Members
NFX.Serialization.POD Namespace


CompositeData Constructor

CompositeData Constructor NFX Class Library

Initializes a new instance of the CompositeData class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CompositeData()
internal CompositeData()
Friend Sub New
Friend Sub New
internal:
CompositeData()
internal:
CompositeData()
new : unit -> CompositeData
new : unit -> CompositeData
See Also
CompositeData Class
CompositeData Members
CompositeData Overload
NFX.Serialization.POD Namespace


CompositeData Constructor (PortableObjectDocument, Object, Int32)

CompositeData Constructor (PortableObjectDocument, Object, Int32) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CompositeData class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CompositeData(
    PortableObjectDocument document,
    Object data,
    int metaTypeIndex = -1
)
internal CompositeData(
    PortableObjectDocument document,
    Object data,
    int metaTypeIndex = -1
)
Friend Sub New (
    document As PortableObjectDocument,
    data As Object,
    Optional metaTypeIndex As Integer = -1
)
Friend Sub New (
    document As PortableObjectDocument,
    data As Object,
    Optional metaTypeIndex As Integer = -1
)
internal:
CompositeData(
    PortableObjectDocument^ document,
    Object^ data,
    int metaTypeIndex = -1
)
internal:
CompositeData(
    PortableObjectDocument^ document,
    Object^ data,
    int metaTypeIndex = -1
)
new :
        document : PortableObjectDocument *
        data : Object *
        ?metaTypeIndex : int
(* Defaults:
        let _metaTypeIndex = defaultArg metaTypeIndex -1
*)
-> CompositeData
new :
        document : PortableObjectDocument *
        data : Object *
        ?metaTypeIndex : int
(* Defaults:
        let _metaTypeIndex = defaultArg metaTypeIndex -1
*)
-> CompositeData

Parameters

document
Type: NFX.Serialization.POD PortableObjectDocument
data
Type: Online System Object
metaTypeIndex (Optional)
Type: Online System Int32
See Also
CompositeData Class
CompositeData Members
CompositeData Overload
NFX.Serialization.POD Namespace


CompositeData Fields

CompositeData Fields NFX Class Library

The CompositeData type exposes the following members.
Fields
 | Name | Description
Protected field | __CLRObject |
Protected field | m_Document |
Public field | m_ExistingReferenceIndex |
Public field | m_MetaTypeIndex |
Back to Top
See Also
CompositeData Class
NFX.Serialization.POD Namespace


CompositeData.__CLRObject Field

CompositeData __CLRObject Field NFX Class Library

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[NonSerializedAttribute]
internal Object __CLRObject
[NonSerializedAttribute]
internal Object __CLRObject
<NonSerializedAttribute>
Friend __CLRObject As Object
<NonSerializedAttribute>
Friend __CLRObject As Object
internal:
[NonSerializedAttribute]
Object^ __CLRObject
internal:
[NonSerializedAttribute]
Object^ __CLRObject
[<NonSerializedAttribute>]
val mutable internal __CLRObject: Object
[<NonSerializedAttribute>]
val mutable internal __CLRObject: Object

Field Value

Type: Online Object
See Also
CompositeData Class
CompositeData Members
NFX.Serialization.POD Namespace


CompositeData.m_Document Field

CompositeData m_Document Field NFX Class Library

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal PortableObjectDocument m_Document
internal PortableObjectDocument m_Document
Friend m_Document As PortableObjectDocument
Friend m_Document As PortableObjectDocument
internal:
PortableObjectDocument^ m_Document
internal:
PortableObjectDocument^ m_Document
val mutable internal m_Document: PortableObjectDocument
val mutable internal m_Document: PortableObjectDocument

Field Value

Type: PortableObjectDocument
See Also
CompositeData Class
CompositeData Members
NFX.Serialization.POD Namespace


CompositeData.m_ExistingReferenceIndex Field

CompositeData m_ExistingReferenceIndex Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<int> m_ExistingReferenceIndex
public Nullable<int> m_ExistingReferenceIndex
Public m_ExistingReferenceIndex As Nullable(Of Integer)
Public m_ExistingReferenceIndex As Nullable(Of Integer)
public:
Nullable<int> m_ExistingReferenceIndex
public:
Nullable<int> m_ExistingReferenceIndex
val mutable m_ExistingReferenceIndex: Nullable<int>
val mutable m_ExistingReferenceIndex: Nullable<int>

Field Value

Type: Online Nullable Online Int32
See Also
CompositeData Class
CompositeData Members
NFX.Serialization.POD Namespace


CompositeData.m_MetaTypeIndex Field

CompositeData m_MetaTypeIndex Field NFX Class Library

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int m_MetaTypeIndex
public int m_MetaTypeIndex
Public m_MetaTypeIndex As Integer
Public m_MetaTypeIndex As Integer
public:
int m_MetaTypeIndex
public:
int m_MetaTypeIndex
val mutable m_MetaTypeIndex: int
val mutable m_MetaTypeIndex: int

Field Value

Type: Online Int32
See Also
CompositeData Class
CompositeData Members
NFX.Serialization.POD Namespace


CompositeData Methods

CompositeData Methods NFX Class Library

The CompositeData type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CompositeData Class
NFX.Serialization.POD Namespace


CompositeData Properties

CompositeData Properties NFX Class Library

The CompositeData type exposes the following members.
Properties
 | Name | Description
Public property | Document | Returns document instance that contains this type
Public property | ExistingReference | Returns true when this instance contains a reference to existing object
Public property | ExistingReferenceIndex | Returns either an index that is less than 0 or and index to an existing object which is >=0
Public property | Referenced | Returns another composite data that is referenced, if nothing is referenced, returns null
Public property | Type | Returns type of this data
Back to Top
See Also
CompositeData Class
NFX.Serialization.POD Namespace


CompositeData.Document Property

CompositeData Document Property NFX Class Library

Returns document instance that contains this type

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PortableObjectDocument Document { get; }
public PortableObjectDocument Document { get; }
Public ReadOnly Property Document As PortableObjectDocument
    Get
Public ReadOnly Property Document As PortableObjectDocument
    Get
public:
property PortableObjectDocument^ Document {
    PortableObjectDocument^ get ();
}
public:
property PortableObjectDocument^ Document {
    PortableObjectDocument^ get ();
}
member Document : PortableObjectDocument with get
member Document : PortableObjectDocument with get

Property Value

Type: PortableObjectDocument
See Also
CompositeData Class
CompositeData Members
NFX.Serialization.POD Namespace


CompositeData.ExistingReference Property

CompositeData ExistingReference Property NFX Class Library

Returns true when this instance contains a reference to existing object

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExistingReference { get; }
public bool ExistingReference { get; }
Public ReadOnly Property ExistingReference As Boolean
    Get
Public ReadOnly Property ExistingReference As Boolean
    Get
public:
property bool ExistingReference {
    bool get ();
}
public:
property bool ExistingReference {
    bool get ();
}
member ExistingReference : bool with get
member ExistingReference : bool with get

Property Value

Type: Online Boolean
See Also
CompositeData Class
CompositeData Members
NFX.Serialization.POD Namespace


CompositeData.ExistingReferenceIndex Property

CompositeData ExistingReferenceIndex Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns either an index that is less than 0 or and index to an existing object which is >=0

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ExistingReferenceIndex { get; }
public int ExistingReferenceIndex { get; }
Public ReadOnly Property ExistingReferenceIndex As Integer
    Get
Public ReadOnly Property ExistingReferenceIndex As Integer
    Get
public:
property int ExistingReferenceIndex {
    int get ();
}
public:
property int ExistingReferenceIndex {
    int get ();
}
member ExistingReferenceIndex : int with get
member ExistingReferenceIndex : int with get

Property Value

Type: Online Int32
See Also
CompositeData Class
CompositeData Members
NFX.Serialization.POD Namespace


CompositeData.Referenced Property

CompositeData Referenced Property NFX Class Library

Returns another composite data that is referenced, if nothing is referenced, returns null

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CompositeData Referenced { get; }
public CompositeData Referenced { get; }
Public ReadOnly Property Referenced As CompositeData
    Get
Public ReadOnly Property Referenced As CompositeData
    Get
public:
property CompositeData^ Referenced {
    CompositeData^ get ();
}
public:
property CompositeData^ Referenced {
    CompositeData^ get ();
}
member Referenced : CompositeData with get
member Referenced : CompositeData with get

Property Value

Type: CompositeData
See Also
CompositeData Class
CompositeData Members
NFX.Serialization.POD Namespace


CompositeData.Type Property

CompositeData Type Property NFX Class Library

Returns type of this data

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MetaComplexType Type { get; }
public MetaComplexType Type { get; }
Public ReadOnly Property Type As MetaComplexType
    Get
Public ReadOnly Property Type As MetaComplexType
    Get
public:
property MetaComplexType^ Type {
    MetaComplexType^ get ();
}
public:
property MetaComplexType^ Type {
    MetaComplexType^ get ();
}
member Type : MetaComplexType with get
member Type : MetaComplexType with get

Property Value

Type: MetaComplexType
See Also
CompositeData Class
CompositeData Members
NFX.Serialization.POD Namespace


CompositeReflectedData Class

CompositeReflectedData Class NFX Class Library

Represents a composite (non primitive) data stored in Portable Object Document. This data is obtained from native types automatically using reflection. This class is NOT used for native types that perform custom serialization using ISerializable interface, for that CompositeCustomData is used
Inheritance Hierarchy
Online System Object
NFX.Serialization.POD CompositeData
NFX.Serialization.POD CompositeReflectedData

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class CompositeReflectedData : CompositeData
[SerializableAttribute]
public sealed class CompositeReflectedData : CompositeData
<SerializableAttribute>
Public NotInheritable Class CompositeReflectedData
    Inherits CompositeData
<SerializableAttribute>
Public NotInheritable Class CompositeReflectedData
    Inherits CompositeData
[SerializableAttribute]
public ref class CompositeReflectedData sealed : public CompositeData
[SerializableAttribute]
public ref class CompositeReflectedData sealed : public CompositeData
[<SealedAttribute>]
[<SerializableAttribute>]
type CompositeReflectedData =
    class
        inherit CompositeData
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type CompositeReflectedData =
    class
        inherit CompositeData
    end
See Also
CompositeReflectedData Members
NFX.Serialization.POD Namespace


CompositeReflectedData Members

CompositeReflectedData Members NFX Class Library

The CompositeReflectedData type exposes the following members.
Constructors
 | Name | Description
Protected method | CompositeReflectedData | Initializes a new instance of the CompositeReflectedData class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | __CLRObject | (Inherited from CompositeData.)
Protected field | m_Document | (Inherited from CompositeData.)
Public field | m_ExistingReferenceIndex | (Inherited from CompositeData.)
Public field | m_FieldData |
Public field | m_MetaTypeIndex | (Inherited from CompositeData.)
Back to Top
Properties
 | Name | Description
Public property | Document | Returns document instance that contains this type (Inherited from CompositeData.)
Public property | ExistingReference | Returns true when this instance contains a reference to existing object (Inherited from CompositeData.)
Public property | ExistingReferenceIndex | Returns either an index that is less than 0 or and index to an existing object which is >=0 (Inherited from CompositeData.)
Public property | FieldData | Returns field data that this instance contains, or null if this instance is a reference to another object
Public property | Referenced | Returns another composite data that is referenced, if nothing is referenced, returns null (Inherited from CompositeData.)
Public property | Type | Returns type of this data (Inherited from CompositeData.)
Back to Top
See Also
CompositeReflectedData Class
NFX.Serialization.POD Namespace


CompositeReflectedData Constructor

CompositeReflectedData Constructor NFX Class Library

Initializes a new instance of the CompositeReflectedData class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CompositeReflectedData(
    PortableObjectDocument document,
    Object data,
    int metaTypeIndex = -1
)
internal CompositeReflectedData(
    PortableObjectDocument document,
    Object data,
    int metaTypeIndex = -1
)
Friend Sub New (
    document As PortableObjectDocument,
    data As Object,
    Optional metaTypeIndex As Integer = -1
)
Friend Sub New (
    document As PortableObjectDocument,
    data As Object,
    Optional metaTypeIndex As Integer = -1
)
internal:
CompositeReflectedData(
    PortableObjectDocument^ document,
    Object^ data,
    int metaTypeIndex = -1
)
internal:
CompositeReflectedData(
    PortableObjectDocument^ document,
    Object^ data,
    int metaTypeIndex = -1
)
new :
        document : PortableObjectDocument *
        data : Object *
        ?metaTypeIndex : int
(* Defaults:
        let _metaTypeIndex = defaultArg metaTypeIndex -1
*)
-> CompositeReflectedData
new :
        document : PortableObjectDocument *
        data : Object *
        ?metaTypeIndex : int
(* Defaults:
        let _metaTypeIndex = defaultArg metaTypeIndex -1
*)
-> CompositeReflectedData

Parameters

document
Type: NFX.Serialization.POD PortableObjectDocument
data
Type: Online System Object
metaTypeIndex (Optional)
Type: Online System Int32
See Also
CompositeReflectedData Class
CompositeReflectedData Members
NFX.Serialization.POD Namespace


CompositeReflectedData Fields

CompositeReflectedData Fields NFX Class Library

The CompositeReflectedData type exposes the following members.
Fields
 | Name | Description
Protected field | __CLRObject | (Inherited from CompositeData.)
Protected field | m_Document | (Inherited from CompositeData.)
Public field | m_ExistingReferenceIndex | (Inherited from CompositeData.)
Public field | m_FieldData |
Public field | m_MetaTypeIndex | (Inherited from CompositeData.)
Back to Top
See Also
CompositeReflectedData Class
NFX.Serialization.POD Namespace


CompositeReflectedData.m_FieldData Field

CompositeReflectedData m_FieldData Field NFX Class Library

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object[] m_FieldData
public Object[] m_FieldData
Public m_FieldData As Object()
Public m_FieldData As Object()
public:
array<Object^>^ m_FieldData
public:
array<Object^>^ m_FieldData
val mutable m_FieldData: Object[]
val mutable m_FieldData: Object[]

Field Value

Type: Online Object
See Also
CompositeReflectedData Class
CompositeReflectedData Members
NFX.Serialization.POD Namespace


CompositeReflectedData Methods

CompositeReflectedData Methods NFX Class Library

The CompositeReflectedData type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CompositeReflectedData Class
NFX.Serialization.POD Namespace


CompositeReflectedData Properties

CompositeReflectedData Properties NFX Class Library

The CompositeReflectedData type exposes the following members.
Properties
 | Name | Description
Public property | Document | Returns document instance that contains this type (Inherited from CompositeData.)
Public property | ExistingReference | Returns true when this instance contains a reference to existing object (Inherited from CompositeData.)
Public property | ExistingReferenceIndex | Returns either an index that is less than 0 or and index to an existing object which is >=0 (Inherited from CompositeData.)
Public property | FieldData | Returns field data that this instance contains, or null if this instance is a reference to another object
Public property | Referenced | Returns another composite data that is referenced, if nothing is referenced, returns null (Inherited from CompositeData.)
Public property | Type | Returns type of this data (Inherited from CompositeData.)
Back to Top
See Also
CompositeReflectedData Class
NFX.Serialization.POD Namespace


CompositeReflectedData.FieldData Property

CompositeReflectedData FieldData Property NFX Class Library

Returns field data that this instance contains, or null if this instance is a reference to another object

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object[] FieldData { get; }
public Object[] FieldData { get; }
Public ReadOnly Property FieldData As Object()
    Get
Public ReadOnly Property FieldData As Object()
    Get
public:
property array<Object^>^ FieldData {
    array<Object^>^ get ();
}
public:
property array<Object^>^ FieldData {
    array<Object^>^ get ();
}
member FieldData : Object[] with get
member FieldData : Object[] with get

Property Value

Type: Online Object
See Also
CompositeReflectedData Class
CompositeReflectedData Members
NFX.Serialization.POD Namespace


CustomTypedEntry Structure

CustomTypedEntry Structure NFX Class Library

Used in custom data bags to specify the type of the object contained in Data property if it is intended to be re-interpreted

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct CustomTypedEntry
public struct CustomTypedEntry
Public Structure CustomTypedEntry
Public Structure CustomTypedEntry
public value class CustomTypedEntry
public value class CustomTypedEntry
[<SealedAttribute>]
type CustomTypedEntry =  struct end
[<SealedAttribute>]
type CustomTypedEntry =  struct end
See Also
CustomTypedEntry Members
NFX.Serialization.POD Namespace


CustomTypedEntry Members

CustomTypedEntry Members NFX Class Library

The CustomTypedEntry type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Data |
Public field | TypeIndex |
Back to Top
See Also
CustomTypedEntry Structure
NFX.Serialization.POD Namespace


CustomTypedEntry Fields

CustomTypedEntry Fields NFX Class Library

The CustomTypedEntry type exposes the following members.
Fields
 | Name | Description
Public field | Data |
Public field | TypeIndex |
Back to Top
See Also
CustomTypedEntry Structure
NFX.Serialization.POD Namespace


CustomTypedEntry.Data Field

CustomTypedEntry Data Field NFX Class Library

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Data
public Object Data
Public Data As Object
Public Data As Object
public:
Object^ Data
public:
Object^ Data
val mutable Data: Object
val mutable Data: Object

Field Value

Type: Online Object
See Also
CustomTypedEntry Structure
CustomTypedEntry Members
NFX.Serialization.POD Namespace


CustomTypedEntry.TypeIndex Field

CustomTypedEntry TypeIndex Field NFX Class Library

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int TypeIndex
public int TypeIndex
Public TypeIndex As Integer
Public TypeIndex As Integer
public:
int TypeIndex
public:
int TypeIndex
val mutable TypeIndex: int
val mutable TypeIndex: int

Field Value

Type: Online Int32
See Also
CustomTypedEntry Structure
CustomTypedEntry Members
NFX.Serialization.POD Namespace


CustomTypedEntry Methods

CustomTypedEntry Methods NFX Class Library

The CustomTypedEntry type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CustomTypedEntry Structure
NFX.Serialization.POD Namespace


MetaComplexType Class

MetaComplexType Class NFX Class Library

Represents information about the composite type of data that is stored in Portable Object Document
Inheritance Hierarchy
Online System Object
NFX.Serialization.POD MetaType
NFX.Serialization.POD MetaComplexType

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class MetaComplexType : MetaType,
    IEnumerable<MetaComplexType..::..MetaField>, IEnumerable, IDeserializationCallback
[SerializableAttribute]
public sealed class MetaComplexType : MetaType,
    IEnumerable<MetaComplexType..::..MetaField>, IEnumerable, IDeserializationCallback
<SerializableAttribute>
Public NotInheritable Class MetaComplexType
    Inherits MetaType
    Implements IEnumerable(Of MetaComplexType..::..MetaField), IEnumerable,
    IDeserializationCallback
<SerializableAttribute>
Public NotInheritable Class MetaComplexType
    Inherits MetaType
    Implements IEnumerable(Of MetaComplexType..::..MetaField), IEnumerable,
    IDeserializationCallback
[SerializableAttribute]
public ref class MetaComplexType sealed : public MetaType,
    IEnumerable<MetaComplexType..::..MetaField^>, IEnumerable, IDeserializationCallback
[SerializableAttribute]
public ref class MetaComplexType sealed : public MetaType,
    IEnumerable<MetaComplexType..::..MetaField^>, IEnumerable, IDeserializationCallback
[<SealedAttribute>]
[<SerializableAttribute>]
type MetaComplexType =
    class
        inherit MetaType
        interface IEnumerable<MetaComplexType..::..MetaField>
        interface IEnumerable
        interface IDeserializationCallback
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type MetaComplexType =
    class
        inherit MetaType
        interface IEnumerable<MetaComplexType..::..MetaField>
        interface IEnumerable
        interface IDeserializationCallback
    end
See Also
MetaComplexType Members
NFX.Serialization.POD Namespace


MetaComplexType Members

MetaComplexType Members NFX Class Library

The MetaComplexType type exposes the following members.
Constructors
 | Name | Description
Protected method | MetaComplexType | Initializes a new instance of the MetaComplexType class
Protected method | MetaComplexType(PortableObjectDocument, Type) | Initializes a new instance of the MetaComplexType class
Back to Top
Methods
 | Name | Description
Protected method | Build | (Overrides MetaType Build .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OnDeserialization |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable MetaComplexType MetaField | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct MetaComplexType MetaField, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax MetaComplexType MetaField, TComparand (Func MetaComplexType MetaField, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax MetaComplexType MetaField, TComparand (Func MetaComplexType MetaField, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin MetaComplexType MetaField, TComparand (Func MetaComplexType MetaField, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin MetaComplexType MetaField, TComparand (Func MetaComplexType MetaField, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault MetaComplexType MetaField | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach MetaComplexType MetaField (Action MetaComplexType MetaField ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach MetaComplexType MetaField (Action MetaComplexType MetaField, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast MetaComplexType MetaField | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast MetaComplexType MetaField (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | __CLRType | (Inherited from MetaType.)
Protected field | m_Document | (Inherited from MetaType.)
Protected field | m_Fields |
Protected field | m_MethodsOnSerialized |
Protected field | m_MethodsOnSerializing |
Back to Top
Properties
 | Name | Description
Public property | ArrayElementType | Returns MetaType of array element
Public property | ArrayElementTypeIndex | Returns index of the meta type of array element
Public property | ArrayRank | Returns number of dimensions for arrays
Public property | AssemblyQualifiedName | Returns Type.AssemblyQualifiedName (Inherited from MetaType.)
Public property | BuildInfo | Returns assembly build information
Public property | Document | Returns document instance that contains this type (Inherited from MetaType.)
Public property | FieldCount | Returns the serializable field count described by this type
Public property | IsAbstract |
Public property | IsArray |
Public property | IsValueType |
Public property | IsVisible |
Public property | Name | Returns Type.Name (Inherited from MetaType.)
Public property | Namespace | Returns Type.Namespace (Inherited from MetaType.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
MetaComplexType Class
NFX.Serialization.POD Namespace


MetaComplexType Constructor

MetaComplexType Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | MetaComplexType | Initializes a new instance of the MetaComplexType class
Protected method | MetaComplexType(PortableObjectDocument, Type) | Initializes a new instance of the MetaComplexType class
Back to Top
See Also
MetaComplexType Class
MetaComplexType Members
NFX.Serialization.POD Namespace


MetaComplexType Constructor

MetaComplexType Constructor NFX Class Library

Initializes a new instance of the MetaComplexType class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal MetaComplexType()
internal MetaComplexType()
Friend Sub New
Friend Sub New
internal:
MetaComplexType()
internal:
MetaComplexType()
new : unit -> MetaComplexType
new : unit -> MetaComplexType
See Also
MetaComplexType Class
MetaComplexType Members
MetaComplexType Overload
NFX.Serialization.POD Namespace


MetaComplexType Constructor (PortableObjectDocument, Type)

MetaComplexType Constructor (PortableObjectDocument, Type) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MetaComplexType class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal MetaComplexType(
    PortableObjectDocument document,
    Type type
)
internal MetaComplexType(
    PortableObjectDocument document,
    Type type
)
Friend Sub New (
    document As PortableObjectDocument,
    type As Type
)
Friend Sub New (
    document As PortableObjectDocument,
    type As Type
)
internal:
MetaComplexType(
    PortableObjectDocument^ document,
    Type^ type
)
internal:
MetaComplexType(
    PortableObjectDocument^ document,
    Type^ type
)
new :
        document : PortableObjectDocument *
        type : Type -> MetaComplexType
new :
        document : PortableObjectDocument *
        type : Type -> MetaComplexType

Parameters

document
Type: NFX.Serialization.POD PortableObjectDocument
type
Type: Online System Type
See Also
MetaComplexType Class
MetaComplexType Members
MetaComplexType Overload
NFX.Serialization.POD Namespace


MetaComplexType Fields

MetaComplexType Fields NFX Class Library

The MetaComplexType type exposes the following members.
Fields
 | Name | Description
Protected field | __CLRType | (Inherited from MetaType.)
Protected field | m_Document | (Inherited from MetaType.)
Protected field | m_Fields |
Protected field | m_MethodsOnSerialized |
Protected field | m_MethodsOnSerializing |
Back to Top
See Also
MetaComplexType Class
NFX.Serialization.POD Namespace


MetaComplexType.m_Fields Field

MetaComplexType m_Fields Field NFX Class Library

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal List<MetaComplexType..::..MetaField> m_Fields
internal List<MetaComplexType..::..MetaField> m_Fields
Friend m_Fields As List(Of MetaComplexType..::..MetaField)
Friend m_Fields As List(Of MetaComplexType..::..MetaField)
internal:
List<MetaComplexType..::..MetaField^>^ m_Fields
internal:
List<MetaComplexType..::..MetaField^>^ m_Fields
val mutable internal m_Fields: List<MetaComplexType..::..MetaField>
val mutable internal m_Fields: List<MetaComplexType..::..MetaField>

Field Value

Type: Online List MetaComplexType MetaField
See Also
MetaComplexType Class
MetaComplexType Members
NFX.Serialization.POD Namespace


MetaComplexType.m_MethodsOnSerialized Field

MetaComplexType m_MethodsOnSerialized Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[NonSerializedAttribute]
internal List<MethodInfo> m_MethodsOnSerialized
[NonSerializedAttribute]
internal List<MethodInfo> m_MethodsOnSerialized
<NonSerializedAttribute>
Friend m_MethodsOnSerialized As List(Of MethodInfo)
<NonSerializedAttribute>
Friend m_MethodsOnSerialized As List(Of MethodInfo)
internal:
[NonSerializedAttribute]
List<MethodInfo^>^ m_MethodsOnSerialized
internal:
[NonSerializedAttribute]
List<MethodInfo^>^ m_MethodsOnSerialized
[<NonSerializedAttribute>]
val mutable internal m_MethodsOnSerialized: List<MethodInfo>
[<NonSerializedAttribute>]
val mutable internal m_MethodsOnSerialized: List<MethodInfo>

Field Value

Type: Online List Online MethodInfo
See Also
MetaComplexType Class
MetaComplexType Members
NFX.Serialization.POD Namespace


MetaComplexType.m_MethodsOnSerializing Field

MetaComplexType m_MethodsOnSerializing Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[NonSerializedAttribute]
internal List<MethodInfo> m_MethodsOnSerializing
[NonSerializedAttribute]
internal List<MethodInfo> m_MethodsOnSerializing
<NonSerializedAttribute>
Friend m_MethodsOnSerializing As List(Of MethodInfo)
<NonSerializedAttribute>
Friend m_MethodsOnSerializing As List(Of MethodInfo)
internal:
[NonSerializedAttribute]
List<MethodInfo^>^ m_MethodsOnSerializing
internal:
[NonSerializedAttribute]
List<MethodInfo^>^ m_MethodsOnSerializing
[<NonSerializedAttribute>]
val mutable internal m_MethodsOnSerializing: List<MethodInfo>
[<NonSerializedAttribute>]
val mutable internal m_MethodsOnSerializing: List<MethodInfo>

Field Value

Type: Online List Online MethodInfo
See Also
MetaComplexType Class
MetaComplexType Members
NFX.Serialization.POD Namespace


MetaComplexType Methods

MetaComplexType Methods NFX Class Library

The MetaComplexType type exposes the following members.
Methods
 | Name | Description
Protected method | Build | (Overrides MetaType Build .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | OnDeserialization |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable MetaComplexType MetaField | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct MetaComplexType MetaField, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax MetaComplexType MetaField, TComparand (Func MetaComplexType MetaField, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax MetaComplexType MetaField, TComparand (Func MetaComplexType MetaField, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin MetaComplexType MetaField, TComparand (Func MetaComplexType MetaField, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin MetaComplexType MetaField, TComparand (Func MetaComplexType MetaField, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault MetaComplexType MetaField | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach MetaComplexType MetaField (Action MetaComplexType MetaField ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach MetaComplexType MetaField (Action MetaComplexType MetaField, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast MetaComplexType MetaField | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast MetaComplexType MetaField (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
MetaComplexType Class
NFX.Serialization.POD Namespace


MetaComplexType.IEnumerable.GetEnumerator Method

MetaComplexType IEnumerable GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
MetaComplexType Class
MetaComplexType Members
NFX.Serialization.POD Namespace


MetaComplexType.Build Method

MetaComplexType Build Method NFX Class Library

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Build()
protected override void Build()
Protected Overrides Sub Build
Protected Overrides Sub Build
protected:
virtual void Build() override
protected:
virtual void Build() override
abstract Build : unit -> unit
override Build : unit -> unit
abstract Build : unit -> unit
override Build : unit -> unit
See Also
MetaComplexType Class
MetaComplexType Members
NFX.Serialization.POD Namespace


MetaComplexType.GetEnumerator Method

MetaComplexType GetEnumerator Method NFX Class Library

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<MetaComplexType..::..MetaField> GetEnumerator()
public IEnumerator<MetaComplexType..::..MetaField> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of MetaComplexType..::..MetaField)
Public Function GetEnumerator As IEnumerator(Of MetaComplexType..::..MetaField)
public:
virtual IEnumerator<MetaComplexType..::..MetaField^>^ GetEnumerator() sealed
public:
virtual IEnumerator<MetaComplexType..::..MetaField^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<MetaComplexType..::..MetaField>
override GetEnumerator : unit -> IEnumerator<MetaComplexType..::..MetaField>
abstract GetEnumerator : unit -> IEnumerator<MetaComplexType..::..MetaField>
override GetEnumerator : unit -> IEnumerator<MetaComplexType..::..MetaField>

Return Value

Type: Online IEnumerator MetaComplexType MetaField

Implements

Online IEnumerable T GetEnumerator
See Also
MetaComplexType Class
MetaComplexType Members
NFX.Serialization.POD Namespace


MetaComplexType.OnDeserialization Method

MetaComplexType OnDeserialization Method NFX Class Library

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void OnDeserialization(
    Object sender
)
public void OnDeserialization(
    Object sender
)
Public Sub OnDeserialization (
    sender As Object
)
Public Sub OnDeserialization (
    sender As Object
)
public:
virtual void OnDeserialization(
    Object^ sender
) sealed
public:
virtual void OnDeserialization(
    Object^ sender
) sealed
abstract OnDeserialization :
        sender : Object -> unit
override OnDeserialization :
        sender : Object -> unit
abstract OnDeserialization :
        sender : Object -> unit
override OnDeserialization :
        sender : Object -> unit

Parameters

sender
Type: Online System Object

Implements

Online IDeserializationCallback OnDeserialization(Object)
See Also
MetaComplexType Class
MetaComplexType Members
NFX.Serialization.POD Namespace


MetaComplexType Properties

MetaComplexType Properties NFX Class Library

The MetaComplexType type exposes the following members.
Properties
 | Name | Description
Public property | ArrayElementType | Returns MetaType of array element
Public property | ArrayElementTypeIndex | Returns index of the meta type of array element
Public property | ArrayRank | Returns number of dimensions for arrays
Public property | AssemblyQualifiedName | Returns Type.AssemblyQualifiedName (Inherited from MetaType.)
Public property | BuildInfo | Returns assembly build information
Public property | Document | Returns document instance that contains this type (Inherited from MetaType.)
Public property | FieldCount | Returns the serializable field count described by this type
Public property | IsAbstract |
Public property | IsArray |
Public property | IsValueType |
Public property | IsVisible |
Public property | Name | Returns Type.Name (Inherited from MetaType.)
Public property | Namespace | Returns Type.Namespace (Inherited from MetaType.)
Back to Top
See Also
MetaComplexType Class
NFX.Serialization.POD Namespace


MetaComplexType.ArrayElementType Property

MetaComplexType ArrayElementType Property NFX Class Library

Returns MetaType of array element

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MetaType ArrayElementType { get; }
public MetaType ArrayElementType { get; }
Public ReadOnly Property ArrayElementType As MetaType
    Get
Public ReadOnly Property ArrayElementType As MetaType
    Get
public:
property MetaType^ ArrayElementType {
    MetaType^ get ();
}
public:
property MetaType^ ArrayElementType {
    MetaType^ get ();
}
member ArrayElementType : MetaType with get
member ArrayElementType : MetaType with get

Property Value

Type: MetaType
See Also
MetaComplexType Class
MetaComplexType Members
NFX.Serialization.POD Namespace


MetaComplexType.ArrayElementTypeIndex Property

MetaComplexType ArrayElementTypeIndex Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns index of the meta type of array element

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ArrayElementTypeIndex { get; }
public int ArrayElementTypeIndex { get; }
Public ReadOnly Property ArrayElementTypeIndex As Integer
    Get
Public ReadOnly Property ArrayElementTypeIndex As Integer
    Get
public:
property int ArrayElementTypeIndex {
    int get ();
}
public:
property int ArrayElementTypeIndex {
    int get ();
}
member ArrayElementTypeIndex : int with get
member ArrayElementTypeIndex : int with get

Property Value

Type: Online Int32
See Also
MetaComplexType Class
MetaComplexType Members
NFX.Serialization.POD Namespace


MetaComplexType.ArrayRank Property

MetaComplexType ArrayRank Property NFX Class Library

Returns number of dimensions for arrays

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ArrayRank { get; }
public int ArrayRank { get; }
Public ReadOnly Property ArrayRank As Integer
    Get
Public ReadOnly Property ArrayRank As Integer
    Get
public:
property int ArrayRank {
    int get ();
}
public:
property int ArrayRank {
    int get ();
}
member ArrayRank : int with get
member ArrayRank : int with get

Property Value

Type: Online Int32
See Also
MetaComplexType Class
MetaComplexType Members
NFX.Serialization.POD Namespace


MetaComplexType.BuildInfo Property

MetaComplexType BuildInfo Property NFX Class Library

Returns assembly build information

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BuildInformation BuildInfo { get; }
public BuildInformation BuildInfo { get; }
Public ReadOnly Property BuildInfo As BuildInformation
    Get
Public ReadOnly Property BuildInfo As BuildInformation
    Get
public:
property BuildInformation^ BuildInfo {
    BuildInformation^ get ();
}
public:
property BuildInformation^ BuildInfo {
    BuildInformation^ get ();
}
member BuildInfo : BuildInformation with get
member BuildInfo : BuildInformation with get

Property Value

Type: BuildInformation
See Also
MetaComplexType Class
MetaComplexType Members
NFX.Serialization.POD Namespace


MetaComplexType.FieldCount Property

MetaComplexType FieldCount Property NFX Class Library

Returns the serializable field count described by this type

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int FieldCount { get; }
public int FieldCount { get; }
Public ReadOnly Property FieldCount As Integer
    Get
Public ReadOnly Property FieldCount As Integer
    Get
public:
property int FieldCount {
    int get ();
}
public:
property int FieldCount {
    int get ();
}
member FieldCount : int with get
member FieldCount : int with get

Property Value

Type: Online Int32
See Also
MetaComplexType Class
MetaComplexType Members
NFX.Serialization.POD Namespace


MetaComplexType.IsAbstract Property

MetaComplexType IsAbstract Property NFX Class Library

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsAbstract { get; }
public bool IsAbstract { get; }
Public ReadOnly Property IsAbstract As Boolean
    Get
Public ReadOnly Property IsAbstract As Boolean
    Get
public:
property bool IsAbstract {
    bool get ();
}
public:
property bool IsAbstract {
    bool get ();
}
member IsAbstract : bool with get
member IsAbstract : bool with get

Property Value

Type: Online Boolean
See Also
MetaComplexType Class
MetaComplexType Members
NFX.Serialization.POD Namespace


MetaComplexType.IsArray Property

MetaComplexType IsArray Property NFX Class Library

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsArray { get; }
public bool IsArray { get; }
Public ReadOnly Property IsArray As Boolean
    Get
Public ReadOnly Property IsArray As Boolean
    Get
public:
property bool IsArray {
    bool get ();
}
public:
property bool IsArray {
    bool get ();
}
member IsArray : bool with get
member IsArray : bool with get

Property Value

Type: Online Boolean
See Also
MetaComplexType Class
MetaComplexType Members
NFX.Serialization.POD Namespace


MetaComplexType.IsValueType Property

MetaComplexType IsValueType Property NFX Class Library

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsValueType { get; }
public bool IsValueType { get; }
Public ReadOnly Property IsValueType As Boolean
    Get
Public ReadOnly Property IsValueType As Boolean
    Get
public:
property bool IsValueType {
    bool get ();
}
public:
property bool IsValueType {
    bool get ();
}
member IsValueType : bool with get
member IsValueType : bool with get

Property Value

Type: Online Boolean
See Also
MetaComplexType Class
MetaComplexType Members
NFX.Serialization.POD Namespace


MetaComplexType.IsVisible Property

MetaComplexType IsVisible Property NFX Class Library

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsVisible { get; }
public bool IsVisible { get; }
Public ReadOnly Property IsVisible As Boolean
    Get
Public ReadOnly Property IsVisible As Boolean
    Get
public:
property bool IsVisible {
    bool get ();
}
public:
property bool IsVisible {
    bool get ();
}
member IsVisible : bool with get
member IsVisible : bool with get

Property Value

Type: Online Boolean
See Also
MetaComplexType Class
MetaComplexType Members
NFX.Serialization.POD Namespace


MetaComplexType.MetaField Class

MetaComplexType MetaField Class NFX Class Library

Represents an information about a field of same type
Inheritance Hierarchy
Online System Object
NFX.Serialization.POD MetaComplexType MetaField

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class MetaField
public class MetaField
Public Class MetaField
Public Class MetaField
public ref class MetaField
public ref class MetaField
type MetaField =  class end
type MetaField =  class end
See Also
MetaComplexType MetaField Members
NFX.Serialization.POD Namespace


MetaComplexType.MetaField Members

MetaComplexType MetaField Members NFX Class Library

The MetaComplexType MetaField type exposes the following members.
Constructors
 | Name | Description
Protected method | MetaComplexType MetaField | Initializes a new instance of the MetaComplexType MetaField class
Protected method | MetaComplexType MetaField(MetaComplexType, FieldInfo) | Initializes a new instance of the MetaComplexType MetaField class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_DeclaringType |
Protected field | m_FieldInfo |
Protected field | m_Index |
Back to Top
Properties
 | Name | Description
Public property | DeclaringType |
Public property | FieldMetaTypeIndex |
Public property | FieldName |
Public property | FieldType |
Public property | Index |
Back to Top
See Also
MetaComplexType MetaField Class
NFX.Serialization.POD Namespace


MetaComplexType.MetaField Constructor

MetaComplexType MetaField Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | MetaComplexType MetaField | Initializes a new instance of the MetaComplexType MetaField class
Protected method | MetaComplexType MetaField(MetaComplexType, FieldInfo) | Initializes a new instance of the MetaComplexType MetaField class
Back to Top
See Also
MetaComplexType MetaField Class
MetaComplexType MetaField Members
NFX.Serialization.POD Namespace


MetaComplexType.MetaField Constructor

MetaComplexType MetaField Constructor NFX Class Library

Initializes a new instance of the MetaComplexType MetaField class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal MetaField()
internal MetaField()
Friend Sub New
Friend Sub New
internal:
MetaField()
internal:
MetaField()
new : unit -> MetaField
new : unit -> MetaField
See Also
MetaComplexType MetaField Class
MetaComplexType MetaField Members
MetaComplexType MetaField Overload
NFX.Serialization.POD Namespace


MetaComplexType.MetaField Constructor (MetaComplexType, FieldInfo)

MetaComplexType MetaField Constructor (MetaComplexType, FieldInfo) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MetaComplexType MetaField class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal MetaField(
    MetaComplexType declaringType,
    FieldInfo fieldInfo
)
internal MetaField(
    MetaComplexType declaringType,
    FieldInfo fieldInfo
)
Friend Sub New (
    declaringType As MetaComplexType,
    fieldInfo As FieldInfo
)
Friend Sub New (
    declaringType As MetaComplexType,
    fieldInfo As FieldInfo
)
internal:
MetaField(
    MetaComplexType^ declaringType,
    FieldInfo^ fieldInfo
)
internal:
MetaField(
    MetaComplexType^ declaringType,
    FieldInfo^ fieldInfo
)
new :
        declaringType : MetaComplexType *
        fieldInfo : FieldInfo -> MetaField
new :
        declaringType : MetaComplexType *
        fieldInfo : FieldInfo -> MetaField

Parameters

declaringType
Type: NFX.Serialization.POD MetaComplexType
fieldInfo
Type: Online System.Reflection FieldInfo
See Also
MetaComplexType MetaField Class
MetaComplexType MetaField Members
MetaComplexType MetaField Overload
NFX.Serialization.POD Namespace


MetaComplexType.MetaField Fields

MetaComplexType MetaField Fields NFX Class Library

The MetaComplexType MetaField type exposes the following members.
Fields
 | Name | Description
Protected field | m_DeclaringType |
Protected field | m_FieldInfo |
Protected field | m_Index |
Back to Top
See Also
MetaComplexType MetaField Class
NFX.Serialization.POD Namespace


MetaComplexType.MetaField.m_DeclaringType Field

MetaComplexType MetaField m_DeclaringType Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[NonSerializedAttribute]
internal MetaComplexType m_DeclaringType
[NonSerializedAttribute]
internal MetaComplexType m_DeclaringType
<NonSerializedAttribute>
Friend m_DeclaringType As MetaComplexType
<NonSerializedAttribute>
Friend m_DeclaringType As MetaComplexType
internal:
[NonSerializedAttribute]
MetaComplexType^ m_DeclaringType
internal:
[NonSerializedAttribute]
MetaComplexType^ m_DeclaringType
[<NonSerializedAttribute>]
val mutable internal m_DeclaringType: MetaComplexType
[<NonSerializedAttribute>]
val mutable internal m_DeclaringType: MetaComplexType

Field Value

Type: MetaComplexType
See Also
MetaComplexType MetaField Class
MetaComplexType MetaField Members
NFX.Serialization.POD Namespace


MetaComplexType.MetaField.m_FieldInfo Field

MetaComplexType MetaField m_FieldInfo Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[NonSerializedAttribute]
internal FieldInfo m_FieldInfo
[NonSerializedAttribute]
internal FieldInfo m_FieldInfo
<NonSerializedAttribute>
Friend m_FieldInfo As FieldInfo
<NonSerializedAttribute>
Friend m_FieldInfo As FieldInfo
internal:
[NonSerializedAttribute]
FieldInfo^ m_FieldInfo
internal:
[NonSerializedAttribute]
FieldInfo^ m_FieldInfo
[<NonSerializedAttribute>]
val mutable internal m_FieldInfo: FieldInfo
[<NonSerializedAttribute>]
val mutable internal m_FieldInfo: FieldInfo

Field Value

Type: Online FieldInfo
See Also
MetaComplexType MetaField Class
MetaComplexType MetaField Members
NFX.Serialization.POD Namespace


MetaComplexType.MetaField.m_Index Field

MetaComplexType MetaField m_Index Field NFX Class Library

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[NonSerializedAttribute]
internal int m_Index
[NonSerializedAttribute]
internal int m_Index
<NonSerializedAttribute>
Friend m_Index As Integer
<NonSerializedAttribute>
Friend m_Index As Integer
internal:
[NonSerializedAttribute]
int m_Index
internal:
[NonSerializedAttribute]
int m_Index
[<NonSerializedAttribute>]
val mutable internal m_Index: int
[<NonSerializedAttribute>]
val mutable internal m_Index: int

Field Value

Type: Online Int32
See Also
MetaComplexType MetaField Class
MetaComplexType MetaField Members
NFX.Serialization.POD Namespace


MetaComplexType.MetaField Methods

MetaComplexType MetaField Methods NFX Class Library

The MetaComplexType MetaField type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MetaComplexType MetaField Class
NFX.Serialization.POD Namespace


MetaComplexType.MetaField Properties

MetaComplexType MetaField Properties NFX Class Library

The MetaComplexType MetaField type exposes the following members.
Properties
 | Name | Description
Public property | DeclaringType |
Public property | FieldMetaTypeIndex |
Public property | FieldName |
Public property | FieldType |
Public property | Index |
Back to Top
See Also
MetaComplexType MetaField Class
NFX.Serialization.POD Namespace


MetaComplexType.MetaField.DeclaringType Property

MetaComplexType MetaField DeclaringType Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MetaComplexType DeclaringType { get; }
public MetaComplexType DeclaringType { get; }
Public ReadOnly Property DeclaringType As MetaComplexType
    Get
Public ReadOnly Property DeclaringType As MetaComplexType
    Get
public:
property MetaComplexType^ DeclaringType {
    MetaComplexType^ get ();
}
public:
property MetaComplexType^ DeclaringType {
    MetaComplexType^ get ();
}
member DeclaringType : MetaComplexType with get
member DeclaringType : MetaComplexType with get

Property Value

Type: MetaComplexType
See Also
MetaComplexType MetaField Class
MetaComplexType MetaField Members
NFX.Serialization.POD Namespace


MetaComplexType.MetaField.FieldMetaTypeIndex Property

MetaComplexType MetaField FieldMetaTypeIndex Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int FieldMetaTypeIndex { get; }
public int FieldMetaTypeIndex { get; }
Public ReadOnly Property FieldMetaTypeIndex As Integer
    Get
Public ReadOnly Property FieldMetaTypeIndex As Integer
    Get
public:
property int FieldMetaTypeIndex {
    int get ();
}
public:
property int FieldMetaTypeIndex {
    int get ();
}
member FieldMetaTypeIndex : int with get
member FieldMetaTypeIndex : int with get

Property Value

Type: Online Int32
See Also
MetaComplexType MetaField Class
MetaComplexType MetaField Members
NFX.Serialization.POD Namespace


MetaComplexType.MetaField.FieldName Property

MetaComplexType MetaField FieldName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string FieldName { get; }
public string FieldName { get; }
Public ReadOnly Property FieldName As String
    Get
Public ReadOnly Property FieldName As String
    Get
public:
property String^ FieldName {
    String^ get ();
}
public:
property String^ FieldName {
    String^ get ();
}
member FieldName : string with get
member FieldName : string with get

Property Value

Type: Online String
See Also
MetaComplexType MetaField Class
MetaComplexType MetaField Members
NFX.Serialization.POD Namespace


MetaComplexType.MetaField.FieldType Property

MetaComplexType MetaField FieldType Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MetaType FieldType { get; }
public MetaType FieldType { get; }
Public ReadOnly Property FieldType As MetaType
    Get
Public ReadOnly Property FieldType As MetaType
    Get
public:
property MetaType^ FieldType {
    MetaType^ get ();
}
public:
property MetaType^ FieldType {
    MetaType^ get ();
}
member FieldType : MetaType with get
member FieldType : MetaType with get

Property Value

Type: MetaType
See Also
MetaComplexType MetaField Class
MetaComplexType MetaField Members
NFX.Serialization.POD Namespace


MetaComplexType.MetaField.Index Property

MetaComplexType MetaField Index Property NFX Class Library

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Index { get; }
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
Public ReadOnly Property Index As Integer
    Get
public:
property int Index {
    int get ();
}
public:
property int Index {
    int get ();
}
member Index : int with get
member Index : int with get

Property Value

Type: Online Int32
See Also
MetaComplexType MetaField Class
MetaComplexType MetaField Members
NFX.Serialization.POD Namespace


MetaPrimitiveType Class

MetaPrimitiveType Class NFX Class Library

Represents primitive built-in types in the framework that are stored in Portable Object Document
Inheritance Hierarchy
Online System Object
NFX.Serialization.POD MetaType
NFX.Serialization.POD MetaPrimitiveType

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class MetaPrimitiveType : MetaType
[SerializableAttribute]
public sealed class MetaPrimitiveType : MetaType
<SerializableAttribute>
Public NotInheritable Class MetaPrimitiveType
    Inherits MetaType
<SerializableAttribute>
Public NotInheritable Class MetaPrimitiveType
    Inherits MetaType
[SerializableAttribute]
public ref class MetaPrimitiveType sealed : public MetaType
[SerializableAttribute]
public ref class MetaPrimitiveType sealed : public MetaType
[<SealedAttribute>]
[<SerializableAttribute>]
type MetaPrimitiveType =
    class
        inherit MetaType
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type MetaPrimitiveType =
    class
        inherit MetaType
    end
See Also
MetaPrimitiveType Members
NFX.Serialization.POD Namespace


MetaPrimitiveType Members

MetaPrimitiveType Members NFX Class Library

The MetaPrimitiveType type exposes the following members.
Constructors
 | Name | Description
Protected method | MetaPrimitiveType | Initializes a new instance of the MetaPrimitiveType class
Protected method | MetaPrimitiveType(PortableObjectDocument, Type) | Initializes a new instance of the MetaPrimitiveType class
Back to Top
Methods
 | Name | Description
Protected method | Build | (Inherited from MetaType.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | __CLRType | (Inherited from MetaType.)
Protected field | m_Document | (Inherited from MetaType.)
Back to Top
Properties
 | Name | Description
Public property | AssemblyQualifiedName | Returns Type.AssemblyQualifiedName (Inherited from MetaType.)
Public property | Document | Returns document instance that contains this type (Inherited from MetaType.)
Public property | Name | Returns Type.Name (Inherited from MetaType.)
Public property | Namespace | Returns Type.Namespace (Inherited from MetaType.)
Back to Top
See Also
MetaPrimitiveType Class
NFX.Serialization.POD Namespace


MetaPrimitiveType Constructor

MetaPrimitiveType Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | MetaPrimitiveType | Initializes a new instance of the MetaPrimitiveType class
Protected method | MetaPrimitiveType(PortableObjectDocument, Type) | Initializes a new instance of the MetaPrimitiveType class
Back to Top
See Also
MetaPrimitiveType Class
MetaPrimitiveType Members
NFX.Serialization.POD Namespace


MetaPrimitiveType Constructor

MetaPrimitiveType Constructor NFX Class Library

Initializes a new instance of the MetaPrimitiveType class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal MetaPrimitiveType()
internal MetaPrimitiveType()
Friend Sub New
Friend Sub New
internal:
MetaPrimitiveType()
internal:
MetaPrimitiveType()
new : unit -> MetaPrimitiveType
new : unit -> MetaPrimitiveType
See Also
MetaPrimitiveType Class
MetaPrimitiveType Members
MetaPrimitiveType Overload
NFX.Serialization.POD Namespace


MetaPrimitiveType Constructor (PortableObjectDocument, Type)

MetaPrimitiveType Constructor (PortableObjectDocument, Type) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MetaPrimitiveType class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal MetaPrimitiveType(
    PortableObjectDocument document,
    Type type
)
internal MetaPrimitiveType(
    PortableObjectDocument document,
    Type type
)
Friend Sub New (
    document As PortableObjectDocument,
    type As Type
)
Friend Sub New (
    document As PortableObjectDocument,
    type As Type
)
internal:
MetaPrimitiveType(
    PortableObjectDocument^ document,
    Type^ type
)
internal:
MetaPrimitiveType(
    PortableObjectDocument^ document,
    Type^ type
)
new :
        document : PortableObjectDocument *
        type : Type -> MetaPrimitiveType
new :
        document : PortableObjectDocument *
        type : Type -> MetaPrimitiveType

Parameters

document
Type: NFX.Serialization.POD PortableObjectDocument
type
Type: Online System Type
See Also
MetaPrimitiveType Class
MetaPrimitiveType Members
MetaPrimitiveType Overload
NFX.Serialization.POD Namespace


MetaPrimitiveType Fields

MetaPrimitiveType Fields NFX Class Library

The MetaPrimitiveType type exposes the following members.
Fields
 | Name | Description
Protected field | __CLRType | (Inherited from MetaType.)
Protected field | m_Document | (Inherited from MetaType.)
Back to Top
See Also
MetaPrimitiveType Class
NFX.Serialization.POD Namespace


MetaPrimitiveType Methods

MetaPrimitiveType Methods NFX Class Library

The MetaPrimitiveType type exposes the following members.
Methods
 | Name | Description
Protected method | Build | (Inherited from MetaType.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MetaPrimitiveType Class
NFX.Serialization.POD Namespace


MetaPrimitiveType Properties

MetaPrimitiveType Properties NFX Class Library

The MetaPrimitiveType type exposes the following members.
Properties
 | Name | Description
Public property | AssemblyQualifiedName | Returns Type.AssemblyQualifiedName (Inherited from MetaType.)
Public property | Document | Returns document instance that contains this type (Inherited from MetaType.)
Public property | Name | Returns Type.Name (Inherited from MetaType.)
Public property | Namespace | Returns Type.Namespace (Inherited from MetaType.)
Back to Top
See Also
MetaPrimitiveType Class
NFX.Serialization.POD Namespace


MetaType Class

MetaType Class NFX Class Library

Provides information about data types stored in Portable Object Document
Inheritance Hierarchy
Online System Object
NFX.Serialization.POD MetaType
NFX.Serialization.POD MetaComplexType
NFX.Serialization.POD MetaPrimitiveType

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class MetaType
[SerializableAttribute]
public abstract class MetaType
<SerializableAttribute>
Public MustInherit Class MetaType
<SerializableAttribute>
Public MustInherit Class MetaType
[SerializableAttribute]
public ref class MetaType abstract
[SerializableAttribute]
public ref class MetaType abstract
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type MetaType =  class end
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type MetaType =  class end
See Also
MetaType Members
NFX.Serialization.POD Namespace


MetaType Members

MetaType Members NFX Class Library

The MetaType type exposes the following members.
Constructors
 | Name | Description
Protected method | MetaType | Initializes a new instance of the MetaType class
Protected method | MetaType(PortableObjectDocument, Type) | Initializes a new instance of the MetaType class
Back to Top
Methods
 | Name | Description
Protected method | Build |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | GetExistingOrNewMetaTypeIndex | Obtains new or existing instance of MetaType that represents a Type in the document instance
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | __CLRType |
Protected field | m_Document |
Back to Top
Properties
 | Name | Description
Public property | AssemblyQualifiedName | Returns Type.AssemblyQualifiedName
Public property | Document | Returns document instance that contains this type
Public property | Name | Returns Type.Name
Public property | Namespace | Returns Type.Namespace
Back to Top
See Also
MetaType Class
NFX.Serialization.POD Namespace


MetaType Constructor

MetaType Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | MetaType | Initializes a new instance of the MetaType class
Protected method | MetaType(PortableObjectDocument, Type) | Initializes a new instance of the MetaType class
Back to Top
See Also
MetaType Class
MetaType Members
NFX.Serialization.POD Namespace


MetaType Constructor

MetaType Constructor NFX Class Library

Initializes a new instance of the MetaType class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal MetaType()
internal MetaType()
Friend Sub New
Friend Sub New
internal:
MetaType()
internal:
MetaType()
new : unit -> MetaType
new : unit -> MetaType
See Also
MetaType Class
MetaType Members
MetaType Overload
NFX.Serialization.POD Namespace


MetaType Constructor (PortableObjectDocument, Type)

MetaType Constructor (PortableObjectDocument, Type) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MetaType class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal MetaType(
    PortableObjectDocument document,
    Type type
)
internal MetaType(
    PortableObjectDocument document,
    Type type
)
Friend Sub New (
    document As PortableObjectDocument,
    type As Type
)
Friend Sub New (
    document As PortableObjectDocument,
    type As Type
)
internal:
MetaType(
    PortableObjectDocument^ document,
    Type^ type
)
internal:
MetaType(
    PortableObjectDocument^ document,
    Type^ type
)
new :
        document : PortableObjectDocument *
        type : Type -> MetaType
new :
        document : PortableObjectDocument *
        type : Type -> MetaType

Parameters

document
Type: NFX.Serialization.POD PortableObjectDocument
type
Type: Online System Type
See Also
MetaType Class
MetaType Members
MetaType Overload
NFX.Serialization.POD Namespace


MetaType Fields

MetaType Fields NFX Class Library

The MetaType type exposes the following members.
Fields
 | Name | Description
Protected field | __CLRType |
Protected field | m_Document |
Back to Top
See Also
MetaType Class
NFX.Serialization.POD Namespace


MetaType.__CLRType Field

MetaType __CLRType Field NFX Class Library

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[NonSerializedAttribute]
internal Type __CLRType
[NonSerializedAttribute]
internal Type __CLRType
<NonSerializedAttribute>
Friend __CLRType As Type
<NonSerializedAttribute>
Friend __CLRType As Type
internal:
[NonSerializedAttribute]
Type^ __CLRType
internal:
[NonSerializedAttribute]
Type^ __CLRType
[<NonSerializedAttribute>]
val mutable internal __CLRType: Type
[<NonSerializedAttribute>]
val mutable internal __CLRType: Type

Field Value

Type: Online Type
See Also
MetaType Class
MetaType Members
NFX.Serialization.POD Namespace


MetaType.m_Document Field

MetaType m_Document Field NFX Class Library

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal PortableObjectDocument m_Document
internal PortableObjectDocument m_Document
Friend m_Document As PortableObjectDocument
Friend m_Document As PortableObjectDocument
internal:
PortableObjectDocument^ m_Document
internal:
PortableObjectDocument^ m_Document
val mutable internal m_Document: PortableObjectDocument
val mutable internal m_Document: PortableObjectDocument

Field Value

Type: PortableObjectDocument
See Also
MetaType Class
MetaType Members
NFX.Serialization.POD Namespace


MetaType Methods

MetaType Methods NFX Class Library

The MetaType type exposes the following members.
Methods
 | Name | Description
Protected method | Build |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
 | GetExistingOrNewMetaTypeIndex | Obtains new or existing instance of MetaType that represents a Type in the document instance
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
MetaType Class
NFX.Serialization.POD Namespace


MetaType.Build Method

MetaType Build Method NFX Class Library

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void Build()
protected virtual void Build()
Protected Overridable Sub Build
Protected Overridable Sub Build
protected:
virtual void Build()
protected:
virtual void Build()
abstract Build : unit -> unit
override Build : unit -> unit
abstract Build : unit -> unit
override Build : unit -> unit
See Also
MetaType Class
MetaType Members
NFX.Serialization.POD Namespace


MetaType.GetExistingOrNewMetaTypeIndex Method

MetaType GetExistingOrNewMetaTypeIndex Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Obtains new or existing instance of MetaType that represents a Type in the document instance

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static int GetExistingOrNewMetaTypeIndex(
    PortableObjectDocument document,
    Type type
)
internal static int GetExistingOrNewMetaTypeIndex(
    PortableObjectDocument document,
    Type type
)
Friend Shared Function GetExistingOrNewMetaTypeIndex (
    document As PortableObjectDocument,
    type As Type
) As Integer
Friend Shared Function GetExistingOrNewMetaTypeIndex (
    document As PortableObjectDocument,
    type As Type
) As Integer
internal:
static int GetExistingOrNewMetaTypeIndex(
    PortableObjectDocument^ document,
    Type^ type
)
internal:
static int GetExistingOrNewMetaTypeIndex(
    PortableObjectDocument^ document,
    Type^ type
)
internal static member GetExistingOrNewMetaTypeIndex :
        document : PortableObjectDocument *
        type : Type -> int
internal static member GetExistingOrNewMetaTypeIndex :
        document : PortableObjectDocument *
        type : Type -> int

Parameters

document
Type: NFX.Serialization.POD PortableObjectDocument
type
Type: Online System Type

Return Value

Type: Online Int32
See Also
MetaType Class
MetaType Members
NFX.Serialization.POD Namespace


MetaType Properties

MetaType Properties NFX Class Library

The MetaType type exposes the following members.
Properties
 | Name | Description
Public property | AssemblyQualifiedName | Returns Type.AssemblyQualifiedName
Public property | Document | Returns document instance that contains this type
Public property | Name | Returns Type.Name
Public property | Namespace | Returns Type.Namespace
Back to Top
See Also
MetaType Class
NFX.Serialization.POD Namespace


MetaType.AssemblyQualifiedName Property

MetaType AssemblyQualifiedName Property NFX Class Library

Returns Type.AssemblyQualifiedName

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AssemblyQualifiedName { get; }
public string AssemblyQualifiedName { get; }
Public ReadOnly Property AssemblyQualifiedName As String
    Get
Public ReadOnly Property AssemblyQualifiedName As String
    Get
public:
property String^ AssemblyQualifiedName {
    String^ get ();
}
public:
property String^ AssemblyQualifiedName {
    String^ get ();
}
member AssemblyQualifiedName : string with get
member AssemblyQualifiedName : string with get

Property Value

Type: Online String
See Also
MetaType Class
MetaType Members
NFX.Serialization.POD Namespace


MetaType.Document Property

MetaType Document Property NFX Class Library

Returns document instance that contains this type

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PortableObjectDocument Document { get; }
public PortableObjectDocument Document { get; }
Public ReadOnly Property Document As PortableObjectDocument
    Get
Public ReadOnly Property Document As PortableObjectDocument
    Get
public:
property PortableObjectDocument^ Document {
    PortableObjectDocument^ get ();
}
public:
property PortableObjectDocument^ Document {
    PortableObjectDocument^ get ();
}
member Document : PortableObjectDocument with get
member Document : PortableObjectDocument with get

Property Value

Type: PortableObjectDocument
See Also
MetaType Class
MetaType Members
NFX.Serialization.POD Namespace


MetaType.Name Property

MetaType Name Property NFX Class Library

Returns Type.Name

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
public:
property String^ Name {
    String^ get ();
}
member Name : string with get
member Name : string with get

Property Value

Type: Online String
See Also
MetaType Class
MetaType Members
NFX.Serialization.POD Namespace


MetaType.Namespace Property

MetaType Namespace Property NFX Class Library

Returns Type.Namespace

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Namespace { get; }
public string Namespace { get; }
Public ReadOnly Property Namespace As String
    Get
Public ReadOnly Property Namespace As String
    Get
public:
property String^ Namespace {
    String^ get ();
}
public:
property String^ Namespace {
    String^ get ();
}
member Namespace : string with get
member Namespace : string with get

Property Value

Type: Online String
See Also
MetaType Class
MetaType Members
NFX.Serialization.POD Namespace


PODDeserializationException Class

PODDeserializationException Class NFX Class Library

Base exception thrown by the PortableObjectDocument when deserializing original objects
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Serialization NFXSerializationException
NFX.Serialization.POD PODException
NFX.Serialization.POD PODDeserializationException

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PODDeserializationException : PODException
[SerializableAttribute]
public class PODDeserializationException : PODException
<SerializableAttribute>
Public Class PODDeserializationException
    Inherits PODException
<SerializableAttribute>
Public Class PODDeserializationException
    Inherits PODException
[SerializableAttribute]
public ref class PODDeserializationException : public PODException
[SerializableAttribute]
public ref class PODDeserializationException : public PODException
[<SerializableAttribute>]
type PODDeserializationException =
    class
        inherit PODException
    end
[<SerializableAttribute>]
type PODDeserializationException =
    class
        inherit PODException
    end
See Also
PODDeserializationException Members
NFX.Serialization.POD Namespace


PODDeserializationException Members

PODDeserializationException Members NFX Class Library

The PODDeserializationException type exposes the following members.
Constructors
 | Name | Description
Public method | PODDeserializationException | Initializes a new instance of the PODDeserializationException class
Public method | PODDeserializationException(String) | Initializes a new instance of the PODDeserializationException class
Protected method | PODDeserializationException(SerializationInfo, StreamingContext) | Initializes a new instance of the PODDeserializationException class
Public method | PODDeserializationException(String, Exception) | Initializes a new instance of the PODDeserializationException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
PODDeserializationException Class
NFX.Serialization.POD Namespace


PODDeserializationException Constructor

PODDeserializationException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | PODDeserializationException | Initializes a new instance of the PODDeserializationException class
Public method | PODDeserializationException(String) | Initializes a new instance of the PODDeserializationException class
Protected method | PODDeserializationException(SerializationInfo, StreamingContext) | Initializes a new instance of the PODDeserializationException class
Public method | PODDeserializationException(String, Exception) | Initializes a new instance of the PODDeserializationException class
Back to Top
See Also
PODDeserializationException Class
PODDeserializationException Members
NFX.Serialization.POD Namespace


PODDeserializationException Constructor

PODDeserializationException Constructor NFX Class Library

Initializes a new instance of the PODDeserializationException class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PODDeserializationException()
public PODDeserializationException()
Public Sub New
Public Sub New
public:
PODDeserializationException()
public:
PODDeserializationException()
new : unit -> PODDeserializationException
new : unit -> PODDeserializationException
See Also
PODDeserializationException Class
PODDeserializationException Members
PODDeserializationException Overload
NFX.Serialization.POD Namespace


PODDeserializationException Constructor (String)

PODDeserializationException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PODDeserializationException class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PODDeserializationException(
    string message
)
public PODDeserializationException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
PODDeserializationException(
    String^ message
)
public:
PODDeserializationException(
    String^ message
)
new :
        message : string -> PODDeserializationException
new :
        message : string -> PODDeserializationException

Parameters

message
Type: Online System String
See Also
PODDeserializationException Class
PODDeserializationException Members
PODDeserializationException Overload
NFX.Serialization.POD Namespace


PODDeserializationException Constructor (SerializationInfo, StreamingContext)

PODDeserializationException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PODDeserializationException class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PODDeserializationException(
    SerializationInfo info,
    StreamingContext context
)
protected PODDeserializationException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
PODDeserializationException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
PODDeserializationException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PODDeserializationException
new :
        info : SerializationInfo *
        context : StreamingContext -> PODDeserializationException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
PODDeserializationException Class
PODDeserializationException Members
PODDeserializationException Overload
NFX.Serialization.POD Namespace


PODDeserializationException Constructor (String, Exception)

PODDeserializationException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PODDeserializationException class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PODDeserializationException(
    string message,
    Exception inner
)
public PODDeserializationException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
PODDeserializationException(
    String^ message,
    Exception^ inner
)
public:
PODDeserializationException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> PODDeserializationException
new :
        message : string *
        inner : Exception -> PODDeserializationException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
PODDeserializationException Class
PODDeserializationException Members
PODDeserializationException Overload
NFX.Serialization.POD Namespace


PODDeserializationException Methods

PODDeserializationException Methods NFX Class Library

The PODDeserializationException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
PODDeserializationException Class
NFX.Serialization.POD Namespace


PODDeserializationException Properties

PODDeserializationException Properties NFX Class Library

The PODDeserializationException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
PODDeserializationException Class
NFX.Serialization.POD Namespace


PODDeserializationException Events

PODDeserializationException Events NFX Class Library

The PODDeserializationException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
PODDeserializationException Class
NFX.Serialization.POD Namespace


PODException Class

PODException Class NFX Class Library

Base exception thrown by the Portable Object Document serialization format
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Serialization NFXSerializationException
NFX.Serialization.POD PODException
NFX.Serialization.POD PODDeserializationException
NFX.Serialization.POD PODSerializationException

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PODException : NFXSerializationException
[SerializableAttribute]
public class PODException : NFXSerializationException
<SerializableAttribute>
Public Class PODException
    Inherits NFXSerializationException
<SerializableAttribute>
Public Class PODException
    Inherits NFXSerializationException
[SerializableAttribute]
public ref class PODException : public NFXSerializationException
[SerializableAttribute]
public ref class PODException : public NFXSerializationException
[<SerializableAttribute>]
type PODException =
    class
        inherit NFXSerializationException
    end
[<SerializableAttribute>]
type PODException =
    class
        inherit NFXSerializationException
    end
See Also
PODException Members
NFX.Serialization.POD Namespace


PODException Members

PODException Members NFX Class Library

The PODException type exposes the following members.
Constructors
 | Name | Description
Public method | PODException | Initializes a new instance of the PODException class
Public method | PODException(String) | Initializes a new instance of the PODException class
Protected method | PODException(SerializationInfo, StreamingContext) | Initializes a new instance of the PODException class
Public method | PODException(String, Exception) | Initializes a new instance of the PODException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
PODException Class
NFX.Serialization.POD Namespace


PODException Constructor

PODException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | PODException | Initializes a new instance of the PODException class
Public method | PODException(String) | Initializes a new instance of the PODException class
Protected method | PODException(SerializationInfo, StreamingContext) | Initializes a new instance of the PODException class
Public method | PODException(String, Exception) | Initializes a new instance of the PODException class
Back to Top
See Also
PODException Class
PODException Members
NFX.Serialization.POD Namespace


PODException Constructor

PODException Constructor NFX Class Library

Initializes a new instance of the PODException class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PODException()
public PODException()
Public Sub New
Public Sub New
public:
PODException()
public:
PODException()
new : unit -> PODException
new : unit -> PODException
See Also
PODException Class
PODException Members
PODException Overload
NFX.Serialization.POD Namespace


PODException Constructor (String)

PODException Constructor (String) NFX Class Library

Initializes a new instance of the PODException class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PODException(
    string message
)
public PODException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
PODException(
    String^ message
)
public:
PODException(
    String^ message
)
new :
        message : string -> PODException
new :
        message : string -> PODException

Parameters

message
Type: Online System String
See Also
PODException Class
PODException Members
PODException Overload
NFX.Serialization.POD Namespace


PODException Constructor (SerializationInfo, StreamingContext)

PODException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PODException class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PODException(
    SerializationInfo info,
    StreamingContext context
)
protected PODException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
PODException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
PODException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PODException
new :
        info : SerializationInfo *
        context : StreamingContext -> PODException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
PODException Class
PODException Members
PODException Overload
NFX.Serialization.POD Namespace


PODException Constructor (String, Exception)

PODException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PODException class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PODException(
    string message,
    Exception inner
)
public PODException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
PODException(
    String^ message,
    Exception^ inner
)
public:
PODException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> PODException
new :
        message : string *
        inner : Exception -> PODException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
PODException Class
PODException Members
PODException Overload
NFX.Serialization.POD Namespace


PODException Methods

PODException Methods NFX Class Library

The PODException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
PODException Class
NFX.Serialization.POD Namespace


PODException Properties

PODException Properties NFX Class Library

The PODException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
PODException Class
NFX.Serialization.POD Namespace


PODException Events

PODException Events NFX Class Library

The PODException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
PODException Class
NFX.Serialization.POD Namespace


PODSerializationException Class

PODSerializationException Class NFX Class Library

Base exception thrown by the PortableObjectDocument when serializing objects into document
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Serialization NFXSerializationException
NFX.Serialization.POD PODException
NFX.Serialization.POD PODSerializationException

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PODSerializationException : PODException
[SerializableAttribute]
public class PODSerializationException : PODException
<SerializableAttribute>
Public Class PODSerializationException
    Inherits PODException
<SerializableAttribute>
Public Class PODSerializationException
    Inherits PODException
[SerializableAttribute]
public ref class PODSerializationException : public PODException
[SerializableAttribute]
public ref class PODSerializationException : public PODException
[<SerializableAttribute>]
type PODSerializationException =
    class
        inherit PODException
    end
[<SerializableAttribute>]
type PODSerializationException =
    class
        inherit PODException
    end
See Also
PODSerializationException Members
NFX.Serialization.POD Namespace


PODSerializationException Members

PODSerializationException Members NFX Class Library

The PODSerializationException type exposes the following members.
Constructors
 | Name | Description
Public method | PODSerializationException | Initializes a new instance of the PODSerializationException class
Public method | PODSerializationException(String) | Initializes a new instance of the PODSerializationException class
Protected method | PODSerializationException(SerializationInfo, StreamingContext) | Initializes a new instance of the PODSerializationException class
Public method | PODSerializationException(String, Exception) | Initializes a new instance of the PODSerializationException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
PODSerializationException Class
NFX.Serialization.POD Namespace


PODSerializationException Constructor

PODSerializationException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | PODSerializationException | Initializes a new instance of the PODSerializationException class
Public method | PODSerializationException(String) | Initializes a new instance of the PODSerializationException class
Protected method | PODSerializationException(SerializationInfo, StreamingContext) | Initializes a new instance of the PODSerializationException class
Public method | PODSerializationException(String, Exception) | Initializes a new instance of the PODSerializationException class
Back to Top
See Also
PODSerializationException Class
PODSerializationException Members
NFX.Serialization.POD Namespace


PODSerializationException Constructor

PODSerializationException Constructor NFX Class Library

Initializes a new instance of the PODSerializationException class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PODSerializationException()
public PODSerializationException()
Public Sub New
Public Sub New
public:
PODSerializationException()
public:
PODSerializationException()
new : unit -> PODSerializationException
new : unit -> PODSerializationException
See Also
PODSerializationException Class
PODSerializationException Members
PODSerializationException Overload
NFX.Serialization.POD Namespace


PODSerializationException Constructor (String)

PODSerializationException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PODSerializationException class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PODSerializationException(
    string message
)
public PODSerializationException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
PODSerializationException(
    String^ message
)
public:
PODSerializationException(
    String^ message
)
new :
        message : string -> PODSerializationException
new :
        message : string -> PODSerializationException

Parameters

message
Type: Online System String
See Also
PODSerializationException Class
PODSerializationException Members
PODSerializationException Overload
NFX.Serialization.POD Namespace


PODSerializationException Constructor (SerializationInfo, StreamingContext)

PODSerializationException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PODSerializationException class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PODSerializationException(
    SerializationInfo info,
    StreamingContext context
)
protected PODSerializationException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
PODSerializationException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
PODSerializationException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PODSerializationException
new :
        info : SerializationInfo *
        context : StreamingContext -> PODSerializationException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
PODSerializationException Class
PODSerializationException Members
PODSerializationException Overload
NFX.Serialization.POD Namespace


PODSerializationException Constructor (String, Exception)

PODSerializationException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PODSerializationException class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PODSerializationException(
    string message,
    Exception inner
)
public PODSerializationException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
PODSerializationException(
    String^ message,
    Exception^ inner
)
public:
PODSerializationException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> PODSerializationException
new :
        message : string *
        inner : Exception -> PODSerializationException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
PODSerializationException Class
PODSerializationException Members
PODSerializationException Overload
NFX.Serialization.POD Namespace


PODSerializationException Methods

PODSerializationException Methods NFX Class Library

The PODSerializationException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
PODSerializationException Class
NFX.Serialization.POD Namespace


PODSerializationException Properties

PODSerializationException Properties NFX Class Library

The PODSerializationException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
PODSerializationException Class
NFX.Serialization.POD Namespace


PODSerializationException Events

PODSerializationException Events NFX Class Library

The PODSerializationException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
PODSerializationException Class
NFX.Serialization.POD Namespace


PortableObjectDocument Class

PortableObjectDocument Class NFX Class Library

Represents an graph of arbitrary CLR objects as a graph of well known POD-objects which are based on primitive-only types. This class acts as a Document-Object-Model container that hosts comlex CLR types that may change their structure but need to be deserialized even if deserialization is partial / requires transform
Inheritance Hierarchy
Online System Object
NFX.Serialization.POD PortableObjectDocument

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class PortableObjectDocument
[SerializableAttribute]
public sealed class PortableObjectDocument
<SerializableAttribute>
Public NotInheritable Class PortableObjectDocument
<SerializableAttribute>
Public NotInheritable Class PortableObjectDocument
[SerializableAttribute]
public ref class PortableObjectDocument sealed
[SerializableAttribute]
public ref class PortableObjectDocument sealed
[<SealedAttribute>]
[<SerializableAttribute>]
type PortableObjectDocument =  class end
[<SealedAttribute>]
[<SerializableAttribute>]
type PortableObjectDocument =  class end
See Also
PortableObjectDocument Members
NFX.Serialization.POD Namespace


PortableObjectDocument Members

PortableObjectDocument Members NFX Class Library

The PortableObjectDocument type exposes the following members.
Constructors
 | Name | Description
Public method | PortableObjectDocument | Creates a new instance of object document from the graph of arbitrary CLR objects serializing them into well-known POD object types
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetExistingOrNewMetaType | Obtains new or existing MetaType instance that represents a Type in this document instance. If this document instance already has this type registered, then existing MetaType instance is returned, otherwise the new MetaType instance that represents the supplied CLR Type is created and registered under the document-unique index
Public method | GetExistingOrNewMetaTypeIndex | Obtains new or existing index of MetaType that represents a Type in this document instance. If this document instance already has this type registered, then existing index is returned, otherwise the new MetaType instance that represents the supplied CLR Type is created and registered under the document-unique index
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetMetaTypeFromIndex | Returns MetaType by index
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NativeDataToPortableData | Transforms a native value, such as object, primitive, struct etc.. into a value that can be stored in the PortableObjectDocument. The complex types are stored as CompositeData, primitives are stored as-is (boxed)
Public method | PortableDataToNativeData | Transforms a portable data value, such as object, primitive, struct etc.. into a CLR
Public method | ToOriginalObject | Deserializes PortableObjectDocument into original graph of arbitrary CLR objects trying to preserve/convert as much data as possible using optionally supplied strategy
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_CompositeData |
Protected field | m_CompositeDataDict |
Protected field | m_StreamingContext |
Protected field | m_Types |
Protected field | m_TypesDict |
Back to Top
Properties
 | Name | Description
Public property | BuildInformation | Returns build information for framework that contains the PortableObjectDocuemnt type
Public property | CreationDate | Returns timestamp when this doc was created
Public property | MetaTypes | Returns meta types that this document contains
Public property | Notes | Returns notes supplied when document was created
Public property | Root | Returns graph root potable object that this document represents, not a native object
Public property | RootMetaType | Returns graph root object meta type index, if root is null them MetaCompositeType(Object) is returned
Public property | RootMetaTypeIndex | Returns graph root object meta type index, if root data is null then 0 is returned which is an index of MetaCompositeType(Object) type
Back to Top
See Also
PortableObjectDocument Class
NFX.Serialization.POD Namespace


PortableObjectDocument Constructor

PortableObjectDocument Constructor NFX Class Library

Creates a new instance of object document from the graph of arbitrary CLR objects serializing them into well-known POD object types

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PortableObjectDocument(
    Object graph,
    Nullable<DateTime> creationDate = null,
    string notes = null
)
public PortableObjectDocument(
    Object graph,
    Nullable<DateTime> creationDate = null,
    string notes = null
)
Public Sub New (
    graph As Object,
    Optional creationDate As Nullable(Of DateTime) = Nothing,
    Optional notes As String = Nothing
)
Public Sub New (
    graph As Object,
    Optional creationDate As Nullable(Of DateTime) = Nothing,
    Optional notes As String = Nothing
)
public:
PortableObjectDocument(
    Object^ graph,
    Nullable<DateTime> creationDate = nullptr,
    String^ notes = nullptr
)
public:
PortableObjectDocument(
    Object^ graph,
    Nullable<DateTime> creationDate = nullptr,
    String^ notes = nullptr
)
new :
        graph : Object *
        ?creationDate : Nullable<DateTime> *
        ?notes : string
(* Defaults:
        let _creationDate = defaultArg creationDate null
        let _notes = defaultArg notes null
*)
-> PortableObjectDocument
new :
        graph : Object *
        ?creationDate : Nullable<DateTime> *
        ?notes : string
(* Defaults:
        let _creationDate = defaultArg creationDate null
        let _notes = defaultArg notes null
*)
-> PortableObjectDocument

Parameters

graph
Type: Online System Object
creationDate (Optional)
Type: Online System Nullable Online DateTime
notes (Optional)
Type: Online System String
See Also
PortableObjectDocument Class
PortableObjectDocument Members
NFX.Serialization.POD Namespace


PortableObjectDocument Fields

PortableObjectDocument Fields NFX Class Library

The PortableObjectDocument type exposes the following members.
Fields
 | Name | Description
Protected field | m_CompositeData |
Protected field | m_CompositeDataDict |
Protected field | m_StreamingContext |
Protected field | m_Types |
Protected field | m_TypesDict |
Back to Top
See Also
PortableObjectDocument Class
NFX.Serialization.POD Namespace


PortableObjectDocument.m_CompositeData Field

PortableObjectDocument m_CompositeData Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal List<CompositeData> m_CompositeData
internal List<CompositeData> m_CompositeData
Friend m_CompositeData As List(Of CompositeData)
Friend m_CompositeData As List(Of CompositeData)
internal:
List<CompositeData^>^ m_CompositeData
internal:
List<CompositeData^>^ m_CompositeData
val mutable internal m_CompositeData: List<CompositeData>
val mutable internal m_CompositeData: List<CompositeData>

Field Value

Type: Online List CompositeData
See Also
PortableObjectDocument Class
PortableObjectDocument Members
NFX.Serialization.POD Namespace


PortableObjectDocument.m_CompositeDataDict Field

PortableObjectDocument m_CompositeDataDict Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[NonSerializedAttribute]
internal Dictionary<Object, int> m_CompositeDataDict
[NonSerializedAttribute]
internal Dictionary<Object, int> m_CompositeDataDict
<NonSerializedAttribute>
Friend m_CompositeDataDict As Dictionary(Of Object, Integer)
<NonSerializedAttribute>
Friend m_CompositeDataDict As Dictionary(Of Object, Integer)
internal:
[NonSerializedAttribute]
Dictionary<Object^, int>^ m_CompositeDataDict
internal:
[NonSerializedAttribute]
Dictionary<Object^, int>^ m_CompositeDataDict
[<NonSerializedAttribute>]
val mutable internal m_CompositeDataDict: Dictionary<Object, int>
[<NonSerializedAttribute>]
val mutable internal m_CompositeDataDict: Dictionary<Object, int>

Field Value

Type: Online Dictionary Online Object, Online Int32
See Also
PortableObjectDocument Class
PortableObjectDocument Members
NFX.Serialization.POD Namespace


PortableObjectDocument.m_StreamingContext Field

PortableObjectDocument m_StreamingContext Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[NonSerializedAttribute]
internal StreamingContext m_StreamingContext
[NonSerializedAttribute]
internal StreamingContext m_StreamingContext
<NonSerializedAttribute>
Friend m_StreamingContext As StreamingContext
<NonSerializedAttribute>
Friend m_StreamingContext As StreamingContext
internal:
[NonSerializedAttribute]
StreamingContext m_StreamingContext
internal:
[NonSerializedAttribute]
StreamingContext m_StreamingContext
[<NonSerializedAttribute>]
val mutable internal m_StreamingContext: StreamingContext
[<NonSerializedAttribute>]
val mutable internal m_StreamingContext: StreamingContext

Field Value

Type: Online StreamingContext
See Also
PortableObjectDocument Class
PortableObjectDocument Members
NFX.Serialization.POD Namespace


PortableObjectDocument.m_Types Field

PortableObjectDocument m_Types Field NFX Class Library

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal List<MetaType> m_Types
internal List<MetaType> m_Types
Friend m_Types As List(Of MetaType)
Friend m_Types As List(Of MetaType)
internal:
List<MetaType^>^ m_Types
internal:
List<MetaType^>^ m_Types
val mutable internal m_Types: List<MetaType>
val mutable internal m_Types: List<MetaType>

Field Value

Type: Online List MetaType
See Also
PortableObjectDocument Class
PortableObjectDocument Members
NFX.Serialization.POD Namespace


PortableObjectDocument.m_TypesDict Field

PortableObjectDocument m_TypesDict Field NFX Class Library

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[NonSerializedAttribute]
internal Dictionary<Type, int> m_TypesDict
[NonSerializedAttribute]
internal Dictionary<Type, int> m_TypesDict
<NonSerializedAttribute>
Friend m_TypesDict As Dictionary(Of Type, Integer)
<NonSerializedAttribute>
Friend m_TypesDict As Dictionary(Of Type, Integer)
internal:
[NonSerializedAttribute]
Dictionary<Type^, int>^ m_TypesDict
internal:
[NonSerializedAttribute]
Dictionary<Type^, int>^ m_TypesDict
[<NonSerializedAttribute>]
val mutable internal m_TypesDict: Dictionary<Type, int>
[<NonSerializedAttribute>]
val mutable internal m_TypesDict: Dictionary<Type, int>

Field Value

Type: Online Dictionary Online Type, Online Int32
See Also
PortableObjectDocument Class
PortableObjectDocument Members
NFX.Serialization.POD Namespace


PortableObjectDocument Methods

PortableObjectDocument Methods NFX Class Library

The PortableObjectDocument type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetExistingOrNewMetaType | Obtains new or existing MetaType instance that represents a Type in this document instance. If this document instance already has this type registered, then existing MetaType instance is returned, otherwise the new MetaType instance that represents the supplied CLR Type is created and registered under the document-unique index
Public method | GetExistingOrNewMetaTypeIndex | Obtains new or existing index of MetaType that represents a Type in this document instance. If this document instance already has this type registered, then existing index is returned, otherwise the new MetaType instance that represents the supplied CLR Type is created and registered under the document-unique index
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | GetMetaTypeFromIndex | Returns MetaType by index
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | NativeDataToPortableData | Transforms a native value, such as object, primitive, struct etc.. into a value that can be stored in the PortableObjectDocument. The complex types are stored as CompositeData, primitives are stored as-is (boxed)
Public method | PortableDataToNativeData | Transforms a portable data value, such as object, primitive, struct etc.. into a CLR
Public method | ToOriginalObject | Deserializes PortableObjectDocument into original graph of arbitrary CLR objects trying to preserve/convert as much data as possible using optionally supplied strategy
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PortableObjectDocument Class
NFX.Serialization.POD Namespace


PortableObjectDocument.GetExistingOrNewMetaType Method

PortableObjectDocument GetExistingOrNewMetaType Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Obtains new or existing MetaType instance that represents a Type in this document instance. If this document instance already has this type registered, then existing MetaType instance is returned, otherwise the new MetaType instance that represents the supplied CLR Type is created and registered under the document-unique index

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MetaType GetExistingOrNewMetaType(
    Type type
)
public MetaType GetExistingOrNewMetaType(
    Type type
)
Public Function GetExistingOrNewMetaType (
    type As Type
) As MetaType
Public Function GetExistingOrNewMetaType (
    type As Type
) As MetaType
public:
MetaType^ GetExistingOrNewMetaType(
    Type^ type
)
public:
MetaType^ GetExistingOrNewMetaType(
    Type^ type
)
member GetExistingOrNewMetaType :
        type : Type -> MetaType
member GetExistingOrNewMetaType :
        type : Type -> MetaType

Parameters

type
Type: Online System Type

Return Value

Type: MetaType
See Also
PortableObjectDocument Class
PortableObjectDocument Members
NFX.Serialization.POD Namespace


PortableObjectDocument.GetExistingOrNewMetaTypeIndex Method

PortableObjectDocument GetExistingOrNewMetaTypeIndex Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Obtains new or existing index of MetaType that represents a Type in this document instance. If this document instance already has this type registered, then existing index is returned, otherwise the new MetaType instance that represents the supplied CLR Type is created and registered under the document-unique index

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int GetExistingOrNewMetaTypeIndex(
    Type type
)
public int GetExistingOrNewMetaTypeIndex(
    Type type
)
Public Function GetExistingOrNewMetaTypeIndex (
    type As Type
) As Integer
Public Function GetExistingOrNewMetaTypeIndex (
    type As Type
) As Integer
public:
int GetExistingOrNewMetaTypeIndex(
    Type^ type
)
public:
int GetExistingOrNewMetaTypeIndex(
    Type^ type
)
member GetExistingOrNewMetaTypeIndex :
        type : Type -> int
member GetExistingOrNewMetaTypeIndex :
        type : Type -> int

Parameters

type
Type: Online System Type

Return Value

Type: Online Int32
See Also
PortableObjectDocument Class
PortableObjectDocument Members
NFX.Serialization.POD Namespace


PortableObjectDocument.GetMetaTypeFromIndex Method

PortableObjectDocument GetMetaTypeFromIndex Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns MetaType by index

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MetaType GetMetaTypeFromIndex(
    int index
)
public MetaType GetMetaTypeFromIndex(
    int index
)
Public Function GetMetaTypeFromIndex (
    index As Integer
) As MetaType
Public Function GetMetaTypeFromIndex (
    index As Integer
) As MetaType
public:
MetaType^ GetMetaTypeFromIndex(
    int index
)
public:
MetaType^ GetMetaTypeFromIndex(
    int index
)
member GetMetaTypeFromIndex :
        index : int -> MetaType
member GetMetaTypeFromIndex :
        index : int -> MetaType

Parameters

index
Type: Online System Int32

Return Value

Type: MetaType
See Also
PortableObjectDocument Class
PortableObjectDocument Members
NFX.Serialization.POD Namespace


PortableObjectDocument.NativeDataToPortableData Method

PortableObjectDocument NativeDataToPortableData Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Transforms a native value, such as object, primitive, struct etc.. into a value that can be stored in the PortableObjectDocument. The complex types are stored as CompositeData, primitives are stored as-is (boxed)

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object NativeDataToPortableData(
    Object data
)
public Object NativeDataToPortableData(
    Object data
)
Public Function NativeDataToPortableData (
    data As Object
) As Object
Public Function NativeDataToPortableData (
    data As Object
) As Object
public:
Object^ NativeDataToPortableData(
    Object^ data
)
public:
Object^ NativeDataToPortableData(
    Object^ data
)
member NativeDataToPortableData :
        data : Object -> Object
member NativeDataToPortableData :
        data : Object -> Object

Parameters

data
Type: Online System Object

Return Value

Type: Online Object
See Also
PortableObjectDocument Class
PortableObjectDocument Members
NFX.Serialization.POD Namespace


PortableObjectDocument.PortableDataToNativeData Method

PortableObjectDocument PortableDataToNativeData Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Transforms a portable data value, such as object, primitive, struct etc.. into a CLR

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object PortableDataToNativeData(
    ReadingStrategy strategy,
    Object data
)
public Object PortableDataToNativeData(
    ReadingStrategy strategy,
    Object data
)
Public Function PortableDataToNativeData (
    strategy As ReadingStrategy,
    data As Object
) As Object
Public Function PortableDataToNativeData (
    strategy As ReadingStrategy,
    data As Object
) As Object
public:
Object^ PortableDataToNativeData(
    ReadingStrategy^ strategy,
    Object^ data
)
public:
Object^ PortableDataToNativeData(
    ReadingStrategy^ strategy,
    Object^ data
)
member PortableDataToNativeData :
        strategy : ReadingStrategy *
        data : Object -> Object
member PortableDataToNativeData :
        strategy : ReadingStrategy *
        data : Object -> Object

Parameters

strategy
Type: NFX.Serialization.POD ReadingStrategy
data
Type: Online System Object

Return Value

Type: Online Object
See Also
PortableObjectDocument Class
PortableObjectDocument Members
NFX.Serialization.POD Namespace


PortableObjectDocument.ToOriginalObject Method

PortableObjectDocument ToOriginalObject Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Deserializes PortableObjectDocument into original graph of arbitrary CLR objects trying to preserve/convert as much data as possible using optionally supplied strategy

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object ToOriginalObject(
    ReadingStrategy strategy = null
)
public Object ToOriginalObject(
    ReadingStrategy strategy = null
)
Public Function ToOriginalObject (
    Optional strategy As ReadingStrategy = Nothing
) As Object
Public Function ToOriginalObject (
    Optional strategy As ReadingStrategy = Nothing
) As Object
public:
Object^ ToOriginalObject(
    ReadingStrategy^ strategy = nullptr
)
public:
Object^ ToOriginalObject(
    ReadingStrategy^ strategy = nullptr
)
member ToOriginalObject :
        ?strategy : ReadingStrategy
(* Defaults:
        let _strategy = defaultArg strategy null
*)
-> Object
member ToOriginalObject :
        ?strategy : ReadingStrategy
(* Defaults:
        let _strategy = defaultArg strategy null
*)
-> Object

Parameters

strategy (Optional)
Type: NFX.Serialization.POD ReadingStrategy

Return Value

Type: Online Object
See Also
PortableObjectDocument Class
PortableObjectDocument Members
NFX.Serialization.POD Namespace


PortableObjectDocument Properties

PortableObjectDocument Properties NFX Class Library

The PortableObjectDocument type exposes the following members.
Properties
 | Name | Description
Public property | BuildInformation | Returns build information for framework that contains the PortableObjectDocuemnt type
Public property | CreationDate | Returns timestamp when this doc was created
Public property | MetaTypes | Returns meta types that this document contains
Public property | Notes | Returns notes supplied when document was created
Public property | Root | Returns graph root potable object that this document represents, not a native object
Public property | RootMetaType | Returns graph root object meta type index, if root is null them MetaCompositeType(Object) is returned
Public property | RootMetaTypeIndex | Returns graph root object meta type index, if root data is null then 0 is returned which is an index of MetaCompositeType(Object) type
Back to Top
See Also
PortableObjectDocument Class
NFX.Serialization.POD Namespace


PortableObjectDocument.BuildInformation Property

PortableObjectDocument BuildInformation Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns build information for framework that contains the PortableObjectDocuemnt type

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BuildInformation BuildInformation { get; }
public BuildInformation BuildInformation { get; }
Public ReadOnly Property BuildInformation As BuildInformation
    Get
Public ReadOnly Property BuildInformation As BuildInformation
    Get
public:
property BuildInformation^ BuildInformation {
    BuildInformation^ get ();
}
public:
property BuildInformation^ BuildInformation {
    BuildInformation^ get ();
}
member BuildInformation : BuildInformation with get
member BuildInformation : BuildInformation with get

Property Value

Type: BuildInformation
See Also
PortableObjectDocument Class
PortableObjectDocument Members
NFX.Serialization.POD Namespace


PortableObjectDocument.CreationDate Property

PortableObjectDocument CreationDate Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns timestamp when this doc was created

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime CreationDate { get; }
public DateTime CreationDate { get; }
Public ReadOnly Property CreationDate As DateTime
    Get
Public ReadOnly Property CreationDate As DateTime
    Get
public:
property DateTime CreationDate {
    DateTime get ();
}
public:
property DateTime CreationDate {
    DateTime get ();
}
member CreationDate : DateTime with get
member CreationDate : DateTime with get

Property Value

Type: Online DateTime
See Also
PortableObjectDocument Class
PortableObjectDocument Members
NFX.Serialization.POD Namespace


PortableObjectDocument.MetaTypes Property

PortableObjectDocument MetaTypes Property NFX Class Library

Returns meta types that this document contains

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<MetaType> MetaTypes { get; }
public IEnumerable<MetaType> MetaTypes { get; }
Public ReadOnly Property MetaTypes As IEnumerable(Of MetaType)
    Get
Public ReadOnly Property MetaTypes As IEnumerable(Of MetaType)
    Get
public:
property IEnumerable<MetaType^>^ MetaTypes {
    IEnumerable<MetaType^>^ get ();
}
public:
property IEnumerable<MetaType^>^ MetaTypes {
    IEnumerable<MetaType^>^ get ();
}
member MetaTypes : IEnumerable<MetaType> with get
member MetaTypes : IEnumerable<MetaType> with get

Property Value

Type: Online IEnumerable MetaType
See Also
PortableObjectDocument Class
PortableObjectDocument Members
NFX.Serialization.POD Namespace


PortableObjectDocument.Notes Property

PortableObjectDocument Notes Property NFX Class Library

Returns notes supplied when document was created

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Notes { get; }
public string Notes { get; }
Public ReadOnly Property Notes As String
    Get
Public ReadOnly Property Notes As String
    Get
public:
property String^ Notes {
    String^ get ();
}
public:
property String^ Notes {
    String^ get ();
}
member Notes : string with get
member Notes : string with get

Property Value

Type: Online String
See Also
PortableObjectDocument Class
PortableObjectDocument Members
NFX.Serialization.POD Namespace


PortableObjectDocument.Root Property

PortableObjectDocument Root Property NFX Class Library

Returns graph root potable object that this document represents, not a native object

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Root { get; }
public Object Root { get; }
Public ReadOnly Property Root As Object
    Get
Public ReadOnly Property Root As Object
    Get
public:
property Object^ Root {
    Object^ get ();
}
public:
property Object^ Root {
    Object^ get ();
}
member Root : Object with get
member Root : Object with get

Property Value

Type: Online Object
See Also
PortableObjectDocument Class
PortableObjectDocument Members
NFX.Serialization.POD Namespace


PortableObjectDocument.RootMetaType Property

PortableObjectDocument RootMetaType Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns graph root object meta type index, if root is null them MetaCompositeType(Object) is returned

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MetaType RootMetaType { get; }
public MetaType RootMetaType { get; }
Public ReadOnly Property RootMetaType As MetaType
    Get
Public ReadOnly Property RootMetaType As MetaType
    Get
public:
property MetaType^ RootMetaType {
    MetaType^ get ();
}
public:
property MetaType^ RootMetaType {
    MetaType^ get ();
}
member RootMetaType : MetaType with get
member RootMetaType : MetaType with get

Property Value

Type: MetaType
See Also
PortableObjectDocument Class
PortableObjectDocument Members
NFX.Serialization.POD Namespace


PortableObjectDocument.RootMetaTypeIndex Property

PortableObjectDocument RootMetaTypeIndex Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns graph root object meta type index, if root data is null then 0 is returned which is an index of MetaCompositeType(Object) type

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int RootMetaTypeIndex { get; }
public int RootMetaTypeIndex { get; }
Public ReadOnly Property RootMetaTypeIndex As Integer
    Get
Public ReadOnly Property RootMetaTypeIndex As Integer
    Get
public:
property int RootMetaTypeIndex {
    int get ();
}
public:
property int RootMetaTypeIndex {
    int get ();
}
member RootMetaTypeIndex : int with get
member RootMetaTypeIndex : int with get

Property Value

Type: Online Int32
See Also
PortableObjectDocument Class
PortableObjectDocument Members
NFX.Serialization.POD Namespace


PortableObjectDocumentDeserializationTransform Class

PortableObjectDocumentDeserializationTransform Class NFX Class Library

[This is preliminary documentation and is subject to change.]

Represents an entity that knows how to transform/apply CLR data types from PortableObjectDocument
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.Serialization.POD PortableObjectDocumentDeserializationTransform

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Struct|AttributeTargets.Interface, AllowMultiple = false,
    Inherited = false)]
public abstract class PortableObjectDocumentDeserializationTransform : Attribute
[AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Struct|AttributeTargets.Interface, AllowMultiple = false,
    Inherited = false)]
public abstract class PortableObjectDocumentDeserializationTransform : Attribute
<AttributeUsageAttribute(AttributeTargets.Class Or AttributeTargets.Struct Or AttributeTargets.Interface, AllowMultiple := false,
    Inherited := false)>
Public MustInherit Class PortableObjectDocumentDeserializationTransform
    Inherits Attribute
<AttributeUsageAttribute(AttributeTargets.Class Or AttributeTargets.Struct Or AttributeTargets.Interface, AllowMultiple := false,
    Inherited := false)>
Public MustInherit Class PortableObjectDocumentDeserializationTransform
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Class|AttributeTargets::Struct|AttributeTargets::Interface, AllowMultiple = false,
    Inherited = false)]
public ref class PortableObjectDocumentDeserializationTransform abstract : public Attribute
[AttributeUsageAttribute(AttributeTargets::Class|AttributeTargets::Struct|AttributeTargets::Interface, AllowMultiple = false,
    Inherited = false)]
public ref class PortableObjectDocumentDeserializationTransform abstract : public Attribute
[<AbstractClassAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Struct|AttributeTargets.Interface, AllowMultiple = false,
    Inherited = false)>]
type PortableObjectDocumentDeserializationTransform =
    class
        inherit Attribute
    end
[<AbstractClassAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Struct|AttributeTargets.Interface, AllowMultiple = false,
    Inherited = false)>]
type PortableObjectDocumentDeserializationTransform =
    class
        inherit Attribute
    end
See Also
PortableObjectDocumentDeserializationTransform Members
NFX.Serialization.POD Namespace


PortableObjectDocumentDeserializationTransform Members

PortableObjectDocumentDeserializationTransform Members NFX Class Library

[This is preliminary documentation and is subject to change.]

The PortableObjectDocumentDeserializationTransform type exposes the following members.
Constructors
 | Name | Description
Protected method | PortableObjectDocumentDeserializationTransform | Initializes a new instance of the PortableObjectDocumentDeserializationTransform class
Back to Top
Methods
 | Name | Description
Public method | ConstructObjectInstance | Override to construct new object instance from CompositeData. Return null to let the default implementatiom/ctor be invoked by the framework
Public method | DeserializeFromCompositeCustomData | Handles the deserialization of the object instance from CompoisteCustomData bag. Returns true to indicate that deserialization was handled completely here and default framework implementation should not be called
Public method | DeserializeFromCompositeReflectedData | Handles the deserialization of the object instance from CompoisteReflectedData. Returns a set of fields that were handles by this implementation so that framework code can skip them. Return null or empty set when method is not implemented
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ResolveField | Resolves a meta field definition into actual native field. Returns null wen resolution is not possible and field should be skipped
Public method | SetFieldValue | Handles the assignemnt from ReflectedData into CLR fieldInfo. Override to make conversions, i.e. string to bool, int to string etc... Return true to indicate that default framework implementation should not be called
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
PortableObjectDocumentDeserializationTransform Class
NFX.Serialization.POD Namespace


PortableObjectDocumentDeserializationTransform Constructor

PortableObjectDocumentDeserializationTransform Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PortableObjectDocumentDeserializationTransform class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PortableObjectDocumentDeserializationTransform()
protected PortableObjectDocumentDeserializationTransform()
Protected Sub New
Protected Sub New
protected:
PortableObjectDocumentDeserializationTransform()
protected:
PortableObjectDocumentDeserializationTransform()
new : unit -> PortableObjectDocumentDeserializationTransform
new : unit -> PortableObjectDocumentDeserializationTransform
See Also
PortableObjectDocumentDeserializationTransform Class
PortableObjectDocumentDeserializationTransform Members
NFX.Serialization.POD Namespace


PortableObjectDocumentDeserializationTransform Methods

PortableObjectDocumentDeserializationTransform Methods NFX Class Library

[This is preliminary documentation and is subject to change.]

The PortableObjectDocumentDeserializationTransform type exposes the following members.
Methods
 | Name | Description
Public method | ConstructObjectInstance | Override to construct new object instance from CompositeData. Return null to let the default implementatiom/ctor be invoked by the framework
Public method | DeserializeFromCompositeCustomData | Handles the deserialization of the object instance from CompoisteCustomData bag. Returns true to indicate that deserialization was handled completely here and default framework implementation should not be called
Public method | DeserializeFromCompositeReflectedData | Handles the deserialization of the object instance from CompoisteReflectedData. Returns a set of fields that were handles by this implementation so that framework code can skip them. Return null or empty set when method is not implemented
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ResolveField | Resolves a meta field definition into actual native field. Returns null wen resolution is not possible and field should be skipped
Public method | SetFieldValue | Handles the assignemnt from ReflectedData into CLR fieldInfo. Override to make conversions, i.e. string to bool, int to string etc... Return true to indicate that default framework implementation should not be called
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PortableObjectDocumentDeserializationTransform Class
NFX.Serialization.POD Namespace


PortableObjectDocumentDeserializationTransform.ConstructObjectInstance Method

PortableObjectDocumentDeserializationTransform ConstructObjectInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to construct new object instance from CompositeData. Return null to let the default implementatiom/ctor be invoked by the framework

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract Object ConstructObjectInstance(
    CompositeData data
)
public abstract Object ConstructObjectInstance(
    CompositeData data
)
Public MustOverride Function ConstructObjectInstance (
    data As CompositeData
) As Object
Public MustOverride Function ConstructObjectInstance (
    data As CompositeData
) As Object
public:
virtual Object^ ConstructObjectInstance(
    CompositeData^ data
) abstract
public:
virtual Object^ ConstructObjectInstance(
    CompositeData^ data
) abstract
abstract ConstructObjectInstance :
        data : CompositeData -> Object
abstract ConstructObjectInstance :
        data : CompositeData -> Object

Parameters

data
Type: NFX.Serialization.POD CompositeData

Return Value

Type: Online Object
See Also
PortableObjectDocumentDeserializationTransform Class
PortableObjectDocumentDeserializationTransform Members
NFX.Serialization.POD Namespace


PortableObjectDocumentDeserializationTransform.DeserializeFromCompositeCustomData Method

PortableObjectDocumentDeserializationTransform DeserializeFromCompositeCustomData Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Handles the deserialization of the object instance from CompoisteCustomData bag. Returns true to indicate that deserialization was handled completely here and default framework implementation should not be called

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool DeserializeFromCompositeCustomData(
    Object instance,
    CompositeCustomData data
)
public abstract bool DeserializeFromCompositeCustomData(
    Object instance,
    CompositeCustomData data
)
Public MustOverride Function DeserializeFromCompositeCustomData (
    instance As Object,
    data As CompositeCustomData
) As Boolean
Public MustOverride Function DeserializeFromCompositeCustomData (
    instance As Object,
    data As CompositeCustomData
) As Boolean
public:
virtual bool DeserializeFromCompositeCustomData(
    Object^ instance,
    CompositeCustomData^ data
) abstract
public:
virtual bool DeserializeFromCompositeCustomData(
    Object^ instance,
    CompositeCustomData^ data
) abstract
abstract DeserializeFromCompositeCustomData :
        instance : Object *
        data : CompositeCustomData -> bool
abstract DeserializeFromCompositeCustomData :
        instance : Object *
        data : CompositeCustomData -> bool

Parameters

instance
Type: Online System Object
data
Type: NFX.Serialization.POD CompositeCustomData

Return Value

Type: Online Boolean
See Also
PortableObjectDocumentDeserializationTransform Class
PortableObjectDocumentDeserializationTransform Members
NFX.Serialization.POD Namespace


PortableObjectDocumentDeserializationTransform.DeserializeFromCompositeReflectedData Method

PortableObjectDocumentDeserializationTransform DeserializeFromCompositeReflectedData Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Handles the deserialization of the object instance from CompoisteReflectedData. Returns a set of fields that were handles by this implementation so that framework code can skip them. Return null or empty set when method is not implemented

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract HashSet<MetaComplexType..::..MetaField> DeserializeFromCompositeReflectedData(
    Object instance,
    CompositeReflectedData data
)
public abstract HashSet<MetaComplexType..::..MetaField> DeserializeFromCompositeReflectedData(
    Object instance,
    CompositeReflectedData data
)
Public MustOverride Function DeserializeFromCompositeReflectedData (
    instance As Object,
    data As CompositeReflectedData
) As HashSet(Of MetaComplexType..::..MetaField)
Public MustOverride Function DeserializeFromCompositeReflectedData (
    instance As Object,
    data As CompositeReflectedData
) As HashSet(Of MetaComplexType..::..MetaField)
public:
virtual HashSet<MetaComplexType..::..MetaField^>^ DeserializeFromCompositeReflectedData(
    Object^ instance,
    CompositeReflectedData^ data
) abstract
public:
virtual HashSet<MetaComplexType..::..MetaField^>^ DeserializeFromCompositeReflectedData(
    Object^ instance,
    CompositeReflectedData^ data
) abstract
abstract DeserializeFromCompositeReflectedData :
        instance : Object *
        data : CompositeReflectedData -> HashSet<MetaComplexType..::..MetaField>
abstract DeserializeFromCompositeReflectedData :
        instance : Object *
        data : CompositeReflectedData -> HashSet<MetaComplexType..::..MetaField>

Parameters

instance
Type: Online System Object
data
Type: NFX.Serialization.POD CompositeReflectedData

Return Value

Type: Online HashSet MetaComplexType MetaField
See Also
PortableObjectDocumentDeserializationTransform Class
PortableObjectDocumentDeserializationTransform Members
NFX.Serialization.POD Namespace


PortableObjectDocumentDeserializationTransform.ResolveField Method

PortableObjectDocumentDeserializationTransform ResolveField Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Resolves a meta field definition into actual native field. Returns null wen resolution is not possible and field should be skipped

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract FieldInfo ResolveField(
    Type nativeType,
    MetaComplexType..::..MetaField mfield
)
public abstract FieldInfo ResolveField(
    Type nativeType,
    MetaComplexType..::..MetaField mfield
)
Public MustOverride Function ResolveField (
    nativeType As Type,
    mfield As MetaComplexType..::..MetaField
) As FieldInfo
Public MustOverride Function ResolveField (
    nativeType As Type,
    mfield As MetaComplexType..::..MetaField
) As FieldInfo
public:
virtual FieldInfo^ ResolveField(
    Type^ nativeType,
    MetaComplexType..::..MetaField^ mfield
) abstract
public:
virtual FieldInfo^ ResolveField(
    Type^ nativeType,
    MetaComplexType..::..MetaField^ mfield
) abstract
abstract ResolveField :
        nativeType : Type *
        mfield : MetaComplexType..::..MetaField -> FieldInfo
abstract ResolveField :
        nativeType : Type *
        mfield : MetaComplexType..::..MetaField -> FieldInfo

Parameters

nativeType
Type: Online System Type
mfield
Type: NFX.Serialization.POD MetaComplexType MetaField

Return Value

Type: Online FieldInfo
See Also
PortableObjectDocumentDeserializationTransform Class
PortableObjectDocumentDeserializationTransform Members
NFX.Serialization.POD Namespace


PortableObjectDocumentDeserializationTransform.SetFieldValue Method

PortableObjectDocumentDeserializationTransform SetFieldValue Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Handles the assignemnt from ReflectedData into CLR fieldInfo. Override to make conversions, i.e. string to bool, int to string etc... Return true to indicate that default framework implementation should not be called

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool SetFieldValue(
    ReadingStrategy readingStrategy,
    Object instance,
    FieldInfo fieldInfo,
    CompositeReflectedData data,
    MetaComplexType..::..MetaField mfield
)
public abstract bool SetFieldValue(
    ReadingStrategy readingStrategy,
    Object instance,
    FieldInfo fieldInfo,
    CompositeReflectedData data,
    MetaComplexType..::..MetaField mfield
)
Public MustOverride Function SetFieldValue (
    readingStrategy As ReadingStrategy,
    instance As Object,
    fieldInfo As FieldInfo,
    data As CompositeReflectedData,
    mfield As MetaComplexType..::..MetaField
) As Boolean
Public MustOverride Function SetFieldValue (
    readingStrategy As ReadingStrategy,
    instance As Object,
    fieldInfo As FieldInfo,
    data As CompositeReflectedData,
    mfield As MetaComplexType..::..MetaField
) As Boolean
public:
virtual bool SetFieldValue(
    ReadingStrategy^ readingStrategy,
    Object^ instance,
    FieldInfo^ fieldInfo,
    CompositeReflectedData^ data,
    MetaComplexType..::..MetaField^ mfield
) abstract
public:
virtual bool SetFieldValue(
    ReadingStrategy^ readingStrategy,
    Object^ instance,
    FieldInfo^ fieldInfo,
    CompositeReflectedData^ data,
    MetaComplexType..::..MetaField^ mfield
) abstract
abstract SetFieldValue :
        readingStrategy : ReadingStrategy *
        instance : Object *
        fieldInfo : FieldInfo *
        data : CompositeReflectedData *
        mfield : MetaComplexType..::..MetaField -> bool
abstract SetFieldValue :
        readingStrategy : ReadingStrategy *
        instance : Object *
        fieldInfo : FieldInfo *
        data : CompositeReflectedData *
        mfield : MetaComplexType..::..MetaField -> bool

Parameters

readingStrategy
Type: NFX.Serialization.POD ReadingStrategy
instance
Type: Online System Object
fieldInfo
Type: Online System.Reflection FieldInfo
data
Type: NFX.Serialization.POD CompositeReflectedData
mfield
Type: NFX.Serialization.POD MetaComplexType MetaField

Return Value

Type: Online Boolean
See Also
PortableObjectDocumentDeserializationTransform Class
PortableObjectDocumentDeserializationTransform Members
NFX.Serialization.POD Namespace


PortableObjectDocumentDeserializationTransform Properties

PortableObjectDocumentDeserializationTransform Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The PortableObjectDocumentDeserializationTransform type exposes the following members.
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
PortableObjectDocumentDeserializationTransform Class
NFX.Serialization.POD Namespace


PortableObjectDocumentSerializationTransform Class

PortableObjectDocumentSerializationTransform Class NFX Class Library

[This is preliminary documentation and is subject to change.]

Represents an entity that knows how to transform/apply CLR data types to PortableObjectDocument
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.Serialization.POD PortableObjectDocumentSerializationTransform

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Struct|AttributeTargets.Interface, AllowMultiple = false,
    Inherited = false)]
public abstract class PortableObjectDocumentSerializationTransform : Attribute
[AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Struct|AttributeTargets.Interface, AllowMultiple = false,
    Inherited = false)]
public abstract class PortableObjectDocumentSerializationTransform : Attribute
<AttributeUsageAttribute(AttributeTargets.Class Or AttributeTargets.Struct Or AttributeTargets.Interface, AllowMultiple := false,
    Inherited := false)>
Public MustInherit Class PortableObjectDocumentSerializationTransform
    Inherits Attribute
<AttributeUsageAttribute(AttributeTargets.Class Or AttributeTargets.Struct Or AttributeTargets.Interface, AllowMultiple := false,
    Inherited := false)>
Public MustInherit Class PortableObjectDocumentSerializationTransform
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Class|AttributeTargets::Struct|AttributeTargets::Interface, AllowMultiple = false,
    Inherited = false)]
public ref class PortableObjectDocumentSerializationTransform abstract : public Attribute
[AttributeUsageAttribute(AttributeTargets::Class|AttributeTargets::Struct|AttributeTargets::Interface, AllowMultiple = false,
    Inherited = false)]
public ref class PortableObjectDocumentSerializationTransform abstract : public Attribute
[<AbstractClassAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Struct|AttributeTargets.Interface, AllowMultiple = false,
    Inherited = false)>]
type PortableObjectDocumentSerializationTransform =
    class
        inherit Attribute
    end
[<AbstractClassAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Struct|AttributeTargets.Interface, AllowMultiple = false,
    Inherited = false)>]
type PortableObjectDocumentSerializationTransform =
    class
        inherit Attribute
    end
See Also
PortableObjectDocumentSerializationTransform Members
NFX.Serialization.POD Namespace


PortableObjectDocumentSerializationTransform Members

PortableObjectDocumentSerializationTransform Members NFX Class Library

[This is preliminary documentation and is subject to change.]

The PortableObjectDocumentSerializationTransform type exposes the following members.
Constructors
 | Name | Description
Protected method | PortableObjectDocumentSerializationTransform | Initializes a new instance of the PortableObjectDocumentSerializationTransform class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SerializeCustomObjectData | Override to provide custome seriallization of type marked with this attribute into custom name/value bag
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
PortableObjectDocumentSerializationTransform Class
NFX.Serialization.POD Namespace


PortableObjectDocumentSerializationTransform Constructor

PortableObjectDocumentSerializationTransform Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PortableObjectDocumentSerializationTransform class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected PortableObjectDocumentSerializationTransform()
protected PortableObjectDocumentSerializationTransform()
Protected Sub New
Protected Sub New
protected:
PortableObjectDocumentSerializationTransform()
protected:
PortableObjectDocumentSerializationTransform()
new : unit -> PortableObjectDocumentSerializationTransform
new : unit -> PortableObjectDocumentSerializationTransform
See Also
PortableObjectDocumentSerializationTransform Class
PortableObjectDocumentSerializationTransform Members
NFX.Serialization.POD Namespace


PortableObjectDocumentSerializationTransform Methods

PortableObjectDocumentSerializationTransform Methods NFX Class Library

[This is preliminary documentation and is subject to change.]

The PortableObjectDocumentSerializationTransform type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SerializeCustomObjectData | Override to provide custome seriallization of type marked with this attribute into custom name/value bag
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
PortableObjectDocumentSerializationTransform Class
NFX.Serialization.POD Namespace


PortableObjectDocumentSerializationTransform.SerializeCustomObjectData Method

PortableObjectDocumentSerializationTransform SerializeCustomObjectData Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to provide custome seriallization of type marked with this attribute into custom name/value bag

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void SerializeCustomObjectData(
    PortableObjectDocument document,
    Object source,
    Dictionary<string, CustomTypedEntry> data
)
public abstract void SerializeCustomObjectData(
    PortableObjectDocument document,
    Object source,
    Dictionary<string, CustomTypedEntry> data
)
Public MustOverride Sub SerializeCustomObjectData (
    document As PortableObjectDocument,
    source As Object,
    data As Dictionary(Of String, CustomTypedEntry)
)
Public MustOverride Sub SerializeCustomObjectData (
    document As PortableObjectDocument,
    source As Object,
    data As Dictionary(Of String, CustomTypedEntry)
)
public:
virtual void SerializeCustomObjectData(
    PortableObjectDocument^ document,
    Object^ source,
    Dictionary<String^, CustomTypedEntry>^ data
) abstract
public:
virtual void SerializeCustomObjectData(
    PortableObjectDocument^ document,
    Object^ source,
    Dictionary<String^, CustomTypedEntry>^ data
) abstract
abstract SerializeCustomObjectData :
        document : PortableObjectDocument *
        source : Object *
        data : Dictionary<string, CustomTypedEntry> -> unit
abstract SerializeCustomObjectData :
        document : PortableObjectDocument *
        source : Object *
        data : Dictionary<string, CustomTypedEntry> -> unit

Parameters

document
Type: NFX.Serialization.POD PortableObjectDocument
Document context that this operation executes under
source
Type: Online System Object
Source native data to serialize / populate data from
data
Type: Online System.Collections.Generic Dictionary Online String, CustomTypedEntry
Name/value bag to write data into
See Also
PortableObjectDocumentSerializationTransform Class
PortableObjectDocumentSerializationTransform Members
NFX.Serialization.POD Namespace


PortableObjectDocumentSerializationTransform Properties

PortableObjectDocumentSerializationTransform Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The PortableObjectDocumentSerializationTransform type exposes the following members.
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
PortableObjectDocumentSerializationTransform Class
NFX.Serialization.POD Namespace


ReadingStrategy Class

ReadingStrategy Class NFX Class Library

Represents logic that resolves POD data types and field layouts to CLR types/layouts. Extend this type and pass its instance into PortableObjectDocument.ToOriginalObject(ReadingStrategy)
Inheritance Hierarchy
Online System Object
NFX.Serialization.POD ReadingStrategy

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ReadingStrategy
public class ReadingStrategy
Public Class ReadingStrategy
Public Class ReadingStrategy
public ref class ReadingStrategy
public ref class ReadingStrategy
type ReadingStrategy =  class end
type ReadingStrategy =  class end
See Also
ReadingStrategy Members
NFX.Serialization.POD Namespace


ReadingStrategy Members

ReadingStrategy Members NFX Class Library

The ReadingStrategy type exposes the following members.
Constructors
 | Name | Description
Protected method | ReadingStrategy | Initializes a new instance of the ReadingStrategy class
Back to Top
Methods
 | Name | Description
Public method | CompositeToNative | Resolves composite data into CLR object
Public method | ConstructObject | Constructs object out of CompositeData. This implementation calls ResolveType then tries to invoke attribute constructor first then create instance using default ctor
Public method | DeserializeArray |
Public method | DeserializeObjectFromCompositeCustomData |
Public method | DeserializeObjectFromCompositeReflectedData |
Protected method | DeserializeSerializationInfo | Performs deserialization of SerializationInfo from CompositeCustomData bag
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeNewArrayInstance | Creates an array instance described by the CompositeArrayData instance
Public method | MakeNewObjectInstanceUsingDefaultCtor | Creates an object using its default .ctor. This implementation uses "magic" to create uninit buffer first
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ResolveField | Resolves a meta field definition into actual native field. Returns null wen resolution is not possible and field should be skipped
Public method | ResolveType | Resolves a MetaType instance from a particular document into CLR Type, i.e. an obsolete class named "ABC" may be resolved into newer class "ABCX"
Public method | SetFieldData | Performs the assignment of portable data into native field
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
Name | Description
Default | Returns an instance of default strategy
Back to Top
See Also
ReadingStrategy Class
NFX.Serialization.POD Namespace


ReadingStrategy Constructor

ReadingStrategy Constructor NFX Class Library

Initializes a new instance of the ReadingStrategy class

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ReadingStrategy()
protected ReadingStrategy()
Protected Sub New
Protected Sub New
protected:
ReadingStrategy()
protected:
ReadingStrategy()
new : unit -> ReadingStrategy
new : unit -> ReadingStrategy
See Also
ReadingStrategy Class
ReadingStrategy Members
NFX.Serialization.POD Namespace


ReadingStrategy Methods

ReadingStrategy Methods NFX Class Library

The ReadingStrategy type exposes the following members.
Methods
 | Name | Description
Public method | CompositeToNative | Resolves composite data into CLR object
Public method | ConstructObject | Constructs object out of CompositeData. This implementation calls ResolveType then tries to invoke attribute constructor first then create instance using default ctor
Public method | DeserializeArray |
Public method | DeserializeObjectFromCompositeCustomData |
Public method | DeserializeObjectFromCompositeReflectedData |
Protected method | DeserializeSerializationInfo | Performs deserialization of SerializationInfo from CompositeCustomData bag
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | MakeNewArrayInstance | Creates an array instance described by the CompositeArrayData instance
Public method | MakeNewObjectInstanceUsingDefaultCtor | Creates an object using its default .ctor. This implementation uses "magic" to create uninit buffer first
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ResolveField | Resolves a meta field definition into actual native field. Returns null wen resolution is not possible and field should be skipped
Public method | ResolveType | Resolves a MetaType instance from a particular document into CLR Type, i.e. an obsolete class named "ABC" may be resolved into newer class "ABCX"
Public method | SetFieldData | Performs the assignment of portable data into native field
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ReadingStrategy Class
NFX.Serialization.POD Namespace


ReadingStrategy.CompositeToNative Method

ReadingStrategy CompositeToNative Method NFX Class Library

Resolves composite data into CLR object

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object CompositeToNative(
    CompositeData data
)
public virtual Object CompositeToNative(
    CompositeData data
)
Public Overridable Function CompositeToNative (
    data As CompositeData
) As Object
Public Overridable Function CompositeToNative (
    data As CompositeData
) As Object
public:
virtual Object^ CompositeToNative(
    CompositeData^ data
)
public:
virtual Object^ CompositeToNative(
    CompositeData^ data
)
abstract CompositeToNative :
        data : CompositeData -> Object
override CompositeToNative :
        data : CompositeData -> Object
abstract CompositeToNative :
        data : CompositeData -> Object
override CompositeToNative :
        data : CompositeData -> Object

Parameters

data
Type: NFX.Serialization.POD CompositeData

Return Value

Type: Online Object
See Also
ReadingStrategy Class
ReadingStrategy Members
NFX.Serialization.POD Namespace


ReadingStrategy.ConstructObject Method

ReadingStrategy ConstructObject Method NFX Class Library

Constructs object out of CompositeData. This implementation calls ResolveType then tries to invoke attribute constructor first then create instance using default ctor

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object ConstructObject(
    CompositeData data
)
public virtual Object ConstructObject(
    CompositeData data
)
Public Overridable Function ConstructObject (
    data As CompositeData
) As Object
Public Overridable Function ConstructObject (
    data As CompositeData
) As Object
public:
virtual Object^ ConstructObject(
    CompositeData^ data
)
public:
virtual Object^ ConstructObject(
    CompositeData^ data
)
abstract ConstructObject :
        data : CompositeData -> Object
override ConstructObject :
        data : CompositeData -> Object
abstract ConstructObject :
        data : CompositeData -> Object
override ConstructObject :
        data : CompositeData -> Object

Parameters

data
Type: NFX.Serialization.POD CompositeData

Return Value

Type: Online Object
See Also
ReadingStrategy Class
ReadingStrategy Members
NFX.Serialization.POD Namespace


ReadingStrategy.DeserializeArray Method

ReadingStrategy DeserializeArray Method NFX Class Library

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void DeserializeArray(
    Array array,
    CompositeArrayData data
)
public virtual void DeserializeArray(
    Array array,
    CompositeArrayData data
)
Public Overridable Sub DeserializeArray (
    array As Array,
    data As CompositeArrayData
)
Public Overridable Sub DeserializeArray (
    array As Array,
    data As CompositeArrayData
)
public:
virtual void DeserializeArray(
    Array^ array,
    CompositeArrayData^ data
)
public:
virtual void DeserializeArray(
    Array^ array,
    CompositeArrayData^ data
)
abstract DeserializeArray :
        array : Array *
        data : CompositeArrayData -> unit
override DeserializeArray :
        array : Array *
        data : CompositeArrayData -> unit
abstract DeserializeArray :
        array : Array *
        data : CompositeArrayData -> unit
override DeserializeArray :
        array : Array *
        data : CompositeArrayData -> unit

Parameters

array
Type: Online System Array
data
Type: NFX.Serialization.POD CompositeArrayData
See Also
ReadingStrategy Class
ReadingStrategy Members
NFX.Serialization.POD Namespace


ReadingStrategy.DeserializeObjectFromCompositeCustomData Method

ReadingStrategy DeserializeObjectFromCompositeCustomData Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void DeserializeObjectFromCompositeCustomData(
    Object instance,
    CompositeCustomData data
)
public virtual void DeserializeObjectFromCompositeCustomData(
    Object instance,
    CompositeCustomData data
)
Public Overridable Sub DeserializeObjectFromCompositeCustomData (
    instance As Object,
    data As CompositeCustomData
)
Public Overridable Sub DeserializeObjectFromCompositeCustomData (
    instance As Object,
    data As CompositeCustomData
)
public:
virtual void DeserializeObjectFromCompositeCustomData(
    Object^ instance,
    CompositeCustomData^ data
)
public:
virtual void DeserializeObjectFromCompositeCustomData(
    Object^ instance,
    CompositeCustomData^ data
)
abstract DeserializeObjectFromCompositeCustomData :
        instance : Object *
        data : CompositeCustomData -> unit
override DeserializeObjectFromCompositeCustomData :
        instance : Object *
        data : CompositeCustomData -> unit
abstract DeserializeObjectFromCompositeCustomData :
        instance : Object *
        data : CompositeCustomData -> unit
override DeserializeObjectFromCompositeCustomData :
        instance : Object *
        data : CompositeCustomData -> unit

Parameters

instance
Type: Online System Object
data
Type: NFX.Serialization.POD CompositeCustomData
See Also
ReadingStrategy Class
ReadingStrategy Members
NFX.Serialization.POD Namespace


ReadingStrategy.DeserializeObjectFromCompositeReflectedData Method

ReadingStrategy DeserializeObjectFromCompositeReflectedData Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void DeserializeObjectFromCompositeReflectedData(
    Object instance,
    CompositeReflectedData data
)
public virtual void DeserializeObjectFromCompositeReflectedData(
    Object instance,
    CompositeReflectedData data
)
Public Overridable Sub DeserializeObjectFromCompositeReflectedData (
    instance As Object,
    data As CompositeReflectedData
)
Public Overridable Sub DeserializeObjectFromCompositeReflectedData (
    instance As Object,
    data As CompositeReflectedData
)
public:
virtual void DeserializeObjectFromCompositeReflectedData(
    Object^ instance,
    CompositeReflectedData^ data
)
public:
virtual void DeserializeObjectFromCompositeReflectedData(
    Object^ instance,
    CompositeReflectedData^ data
)
abstract DeserializeObjectFromCompositeReflectedData :
        instance : Object *
        data : CompositeReflectedData -> unit
override DeserializeObjectFromCompositeReflectedData :
        instance : Object *
        data : CompositeReflectedData -> unit
abstract DeserializeObjectFromCompositeReflectedData :
        instance : Object *
        data : CompositeReflectedData -> unit
override DeserializeObjectFromCompositeReflectedData :
        instance : Object *
        data : CompositeReflectedData -> unit

Parameters

instance
Type: Online System Object
data
Type: NFX.Serialization.POD CompositeReflectedData
See Also
ReadingStrategy Class
ReadingStrategy Members
NFX.Serialization.POD Namespace


ReadingStrategy.DeserializeSerializationInfo Method

ReadingStrategy DeserializeSerializationInfo Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Performs deserialization of SerializationInfo from CompositeCustomData bag

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual SerializationInfo DeserializeSerializationInfo(
    Type objType,
    CompositeCustomData data,
    StreamingContext context
)
protected virtual SerializationInfo DeserializeSerializationInfo(
    Type objType,
    CompositeCustomData data,
    StreamingContext context
)
Protected Overridable Function DeserializeSerializationInfo (
    objType As Type,
    data As CompositeCustomData,
    context As StreamingContext
) As SerializationInfo
Protected Overridable Function DeserializeSerializationInfo (
    objType As Type,
    data As CompositeCustomData,
    context As StreamingContext
) As SerializationInfo
protected:
virtual SerializationInfo^ DeserializeSerializationInfo(
    Type^ objType,
    CompositeCustomData^ data,
    StreamingContext context
)
protected:
virtual SerializationInfo^ DeserializeSerializationInfo(
    Type^ objType,
    CompositeCustomData^ data,
    StreamingContext context
)
abstract DeserializeSerializationInfo :
        objType : Type *
        data : CompositeCustomData *
        context : StreamingContext -> SerializationInfo
override DeserializeSerializationInfo :
        objType : Type *
        data : CompositeCustomData *
        context : StreamingContext -> SerializationInfo
abstract DeserializeSerializationInfo :
        objType : Type *
        data : CompositeCustomData *
        context : StreamingContext -> SerializationInfo
override DeserializeSerializationInfo :
        objType : Type *
        data : CompositeCustomData *
        context : StreamingContext -> SerializationInfo

Parameters

objType
Type: Online System Type
data
Type: NFX.Serialization.POD CompositeCustomData
context
Type: Online System.Runtime.Serialization StreamingContext

Return Value

Type: Online SerializationInfo
See Also
ReadingStrategy Class
ReadingStrategy Members
NFX.Serialization.POD Namespace


ReadingStrategy.MakeNewArrayInstance Method

ReadingStrategy MakeNewArrayInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates an array instance described by the CompositeArrayData instance

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object MakeNewArrayInstance(
    CompositeArrayData arrayData
)
public virtual Object MakeNewArrayInstance(
    CompositeArrayData arrayData
)
Public Overridable Function MakeNewArrayInstance (
    arrayData As CompositeArrayData
) As Object
Public Overridable Function MakeNewArrayInstance (
    arrayData As CompositeArrayData
) As Object
public:
virtual Object^ MakeNewArrayInstance(
    CompositeArrayData^ arrayData
)
public:
virtual Object^ MakeNewArrayInstance(
    CompositeArrayData^ arrayData
)
abstract MakeNewArrayInstance :
        arrayData : CompositeArrayData -> Object
override MakeNewArrayInstance :
        arrayData : CompositeArrayData -> Object
abstract MakeNewArrayInstance :
        arrayData : CompositeArrayData -> Object
override MakeNewArrayInstance :
        arrayData : CompositeArrayData -> Object

Parameters

arrayData
Type: NFX.Serialization.POD CompositeArrayData

Return Value

Type: Online Object
See Also
ReadingStrategy Class
ReadingStrategy Members
NFX.Serialization.POD Namespace


ReadingStrategy.MakeNewObjectInstanceUsingDefaultCtor Method

ReadingStrategy MakeNewObjectInstanceUsingDefaultCtor Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates an object using its default .ctor. This implementation uses "magic" to create uninit buffer first

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Object MakeNewObjectInstanceUsingDefaultCtor(
    Type clrType
)
public virtual Object MakeNewObjectInstanceUsingDefaultCtor(
    Type clrType
)
Public Overridable Function MakeNewObjectInstanceUsingDefaultCtor (
    clrType As Type
) As Object
Public Overridable Function MakeNewObjectInstanceUsingDefaultCtor (
    clrType As Type
) As Object
public:
virtual Object^ MakeNewObjectInstanceUsingDefaultCtor(
    Type^ clrType
)
public:
virtual Object^ MakeNewObjectInstanceUsingDefaultCtor(
    Type^ clrType
)
abstract MakeNewObjectInstanceUsingDefaultCtor :
        clrType : Type -> Object
override MakeNewObjectInstanceUsingDefaultCtor :
        clrType : Type -> Object
abstract MakeNewObjectInstanceUsingDefaultCtor :
        clrType : Type -> Object
override MakeNewObjectInstanceUsingDefaultCtor :
        clrType : Type -> Object

Parameters

clrType
Type: Online System Type

Return Value

Type: Online Object
See Also
ReadingStrategy Class
ReadingStrategy Members
NFX.Serialization.POD Namespace


ReadingStrategy.ResolveField Method

ReadingStrategy ResolveField Method NFX Class Library

Resolves a meta field definition into actual native field. Returns null wen resolution is not possible and field should be skipped

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual FieldInfo ResolveField(
    Type nativeType,
    MetaComplexType..::..MetaField mfield
)
public virtual FieldInfo ResolveField(
    Type nativeType,
    MetaComplexType..::..MetaField mfield
)
Public Overridable Function ResolveField (
    nativeType As Type,
    mfield As MetaComplexType..::..MetaField
) As FieldInfo
Public Overridable Function ResolveField (
    nativeType As Type,
    mfield As MetaComplexType..::..MetaField
) As FieldInfo
public:
virtual FieldInfo^ ResolveField(
    Type^ nativeType,
    MetaComplexType..::..MetaField^ mfield
)
public:
virtual FieldInfo^ ResolveField(
    Type^ nativeType,
    MetaComplexType..::..MetaField^ mfield
)
abstract ResolveField :
        nativeType : Type *
        mfield : MetaComplexType..::..MetaField -> FieldInfo
override ResolveField :
        nativeType : Type *
        mfield : MetaComplexType..::..MetaField -> FieldInfo
abstract ResolveField :
        nativeType : Type *
        mfield : MetaComplexType..::..MetaField -> FieldInfo
override ResolveField :
        nativeType : Type *
        mfield : MetaComplexType..::..MetaField -> FieldInfo

Parameters

nativeType
Type: Online System Type
mfield
Type: NFX.Serialization.POD MetaComplexType MetaField

Return Value

Type: Online FieldInfo
See Also
ReadingStrategy Class
ReadingStrategy Members
NFX.Serialization.POD Namespace


ReadingStrategy.ResolveType Method

ReadingStrategy ResolveType Method NFX Class Library

Resolves a MetaType instance from a particular document into CLR Type, i.e. an obsolete class named "ABC" may be resolved into newer class "ABCX"

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual Type ResolveType(
    MetaType metaType
)
public virtual Type ResolveType(
    MetaType metaType
)
Public Overridable Function ResolveType (
    metaType As MetaType
) As Type
Public Overridable Function ResolveType (
    metaType As MetaType
) As Type
public:
virtual Type^ ResolveType(
    MetaType^ metaType
)
public:
virtual Type^ ResolveType(
    MetaType^ metaType
)
abstract ResolveType :
        metaType : MetaType -> Type
override ResolveType :
        metaType : MetaType -> Type
abstract ResolveType :
        metaType : MetaType -> Type
override ResolveType :
        metaType : MetaType -> Type

Parameters

metaType
Type: NFX.Serialization.POD MetaType

Return Value

Type: Online Type
See Also
ReadingStrategy Class
ReadingStrategy Members
NFX.Serialization.POD Namespace


ReadingStrategy.SetFieldData Method

ReadingStrategy SetFieldData Method NFX Class Library

Performs the assignment of portable data into native field

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void SetFieldData(
    Object instance,
    FieldInfo fieldInfo,
    CompositeReflectedData data,
    MetaComplexType..::..MetaField mfield
)
public virtual void SetFieldData(
    Object instance,
    FieldInfo fieldInfo,
    CompositeReflectedData data,
    MetaComplexType..::..MetaField mfield
)
Public Overridable Sub SetFieldData (
    instance As Object,
    fieldInfo As FieldInfo,
    data As CompositeReflectedData,
    mfield As MetaComplexType..::..MetaField
)
Public Overridable Sub SetFieldData (
    instance As Object,
    fieldInfo As FieldInfo,
    data As CompositeReflectedData,
    mfield As MetaComplexType..::..MetaField
)
public:
virtual void SetFieldData(
    Object^ instance,
    FieldInfo^ fieldInfo,
    CompositeReflectedData^ data,
    MetaComplexType..::..MetaField^ mfield
)
public:
virtual void SetFieldData(
    Object^ instance,
    FieldInfo^ fieldInfo,
    CompositeReflectedData^ data,
    MetaComplexType..::..MetaField^ mfield
)
abstract SetFieldData :
        instance : Object *
        fieldInfo : FieldInfo *
        data : CompositeReflectedData *
        mfield : MetaComplexType..::..MetaField -> unit
override SetFieldData :
        instance : Object *
        fieldInfo : FieldInfo *
        data : CompositeReflectedData *
        mfield : MetaComplexType..::..MetaField -> unit
abstract SetFieldData :
        instance : Object *
        fieldInfo : FieldInfo *
        data : CompositeReflectedData *
        mfield : MetaComplexType..::..MetaField -> unit
override SetFieldData :
        instance : Object *
        fieldInfo : FieldInfo *
        data : CompositeReflectedData *
        mfield : MetaComplexType..::..MetaField -> unit

Parameters

instance
Type: Online System Object
fieldInfo
Type: Online System.Reflection FieldInfo
data
Type: NFX.Serialization.POD CompositeReflectedData
mfield
Type: NFX.Serialization.POD MetaComplexType MetaField
See Also
ReadingStrategy Class
ReadingStrategy Members
NFX.Serialization.POD Namespace


ReadingStrategy Properties

ReadingStrategy Properties NFX Class Library

The ReadingStrategy type exposes the following members.
Properties
Name | Description
Default | Returns an instance of default strategy
Back to Top
See Also
ReadingStrategy Class
NFX.Serialization.POD Namespace


ReadingStrategy.Default Property

ReadingStrategy Default Property NFX Class Library

Returns an instance of default strategy

Namespace: NFX.Serialization.POD
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static ReadingStrategy Default { get; }
public static ReadingStrategy Default { get; }
Public Shared ReadOnly Property Default As ReadingStrategy
    Get
Public Shared ReadOnly Property Default As ReadingStrategy
    Get
public:
static property ReadingStrategy^ Default {
    ReadingStrategy^ get ();
}
public:
static property ReadingStrategy^ Default {
    ReadingStrategy^ get ();
}
static member Default : ReadingStrategy with get
static member Default : ReadingStrategy with get

Property Value

Type: ReadingStrategy
See Also
ReadingStrategy Class
ReadingStrategy Members
NFX.Serialization.POD Namespace


NFX.Serialization.Slim Namespace

NFX.Serialization.Slim Namespace NFX Class Library

Provides Slim serialization functionality
Classes
 | Class | Description
Protected class | _ISerializableFixup |
Protected class | _OnDeserializedCallback |
Protected class | Arrays |
Public class | PODSlimSerializer | Serializes CLR object graphs using PortableObjectDocument container and Slim binary serialization algorithm. This class is far less performant than SlimSerializer, however it serializes types using document model that allows to transform/change data during serialization/deserialization. This class is needed for upgrades, when object metadata may change but need to be read (maybe partially) back into the new type structure
Protected class | RefPool |
Public class | SlimDeserializationCtorSkipAttribute | When set on a parameterless constructor, instructs the Slim serializer not to invoke the ctor() on deserialization
Public class | SlimDeserializationException | Base exception thrown by the Slim when deserializing objects
Public class | SlimException | Base exception thrown by the Slim serialization format
Public class | SlimInvalidTypeHandleException | Thrown by type registry when supplied type handle is invalid/not found
Public class | SlimSerializationException | Base exception thrown by the Slim when serializing objects
Public class | SlimSerializationProhibitedAttribute | When set fails an attempt to serialize the decorated type
Public class | SlimSerializationProhibitedException | Thrown when a type is decoreted with SlimSerializationProhibitedAttribute
Public class | SlimSerializer | Implements Slim serialization algorithm that relies on an injectable SlimFormat-derivative (through .ctor) paremeter. This class was designed for highly-efficient serialization of types without versioning. SlimSerializer supports a concept of "known types" that save space by not emitting their names into stream. Performance note: This serializer yields on average 1/4 serialization and 1/2 deserialization times while compared to BinaryFormatter. Serialization of Record-instances usually takes 1/6 of BinaryFormatter time. Format takes 1/10 space for records and 1/2 for general object graphs. Such performance is achieved because of dynamic compilation of type-specific serialization/deserialization methods. This type is thread-safe for serializations/deserializations when TypeMode is set to "PerCall"
Protected class | TypeDescriptor | Type descriptor dynamicaly compiles serialization/deserialization expressions for a particular type
Public class | TypeRegistry | Provides a registry of types, types that do not need to be described in a serialization stream
Protected class | TypeSchema |
Structures
 | Structure | Description
Protected structure | QuickRefList |
Interfaces
 | Interface | Description
Public interface | ISlimSerializer | Marker interface for formats based on Slim algorithm family
Delegates
 | Delegate | Description
Protected delegate | dyn_deserialize |
Protected delegate | dyn_serialize |
Enumerations
 | Enumeration | Description
Public enumeration | TypeRegistryMode | Denotes modes of handling type registry by Slim serializer


_ISerializableFixup Class

_ISerializableFixup Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Serialization.Slim _ISerializableFixup

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class _ISerializableFixup
internal class _ISerializableFixup
Friend Class _ISerializableFixup
Friend Class _ISerializableFixup
internal ref class _ISerializableFixup
internal ref class _ISerializableFixup
type _ISerializableFixup =  class end
type _ISerializableFixup =  class end
See Also
_ISerializableFixup Members
NFX.Serialization.Slim Namespace


_ISerializableFixup Members

_ISerializableFixup Members NFX Class Library

The _ISerializableFixup type exposes the following members.
Constructors
 | Name | Description
Public method | _ISerializableFixup | Initializes a new instance of the _ISerializableFixup class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Info |
Public field | Instance |
Back to Top
See Also
_ISerializableFixup Class
NFX.Serialization.Slim Namespace


_ISerializableFixup Constructor

_ISerializableFixup Constructor NFX Class Library

Initializes a new instance of the _ISerializableFixup class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public _ISerializableFixup()
public _ISerializableFixup()
Public Sub New
Public Sub New
public:
_ISerializableFixup()
public:
_ISerializableFixup()
new : unit -> _ISerializableFixup
new : unit -> _ISerializableFixup
See Also
_ISerializableFixup Class
_ISerializableFixup Members
NFX.Serialization.Slim Namespace


_ISerializableFixup Fields

_ISerializableFixup Fields NFX Class Library

The _ISerializableFixup type exposes the following members.
Fields
 | Name | Description
Public field | Info |
Public field | Instance |
Back to Top
See Also
_ISerializableFixup Class
NFX.Serialization.Slim Namespace


_ISerializableFixup.Info Field

_ISerializableFixup Info Field NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SerializationInfo Info
public SerializationInfo Info
Public Info As SerializationInfo
Public Info As SerializationInfo
public:
SerializationInfo^ Info
public:
SerializationInfo^ Info
val mutable Info: SerializationInfo
val mutable Info: SerializationInfo

Field Value

Type: Online SerializationInfo
See Also
_ISerializableFixup Class
_ISerializableFixup Members
NFX.Serialization.Slim Namespace


_ISerializableFixup.Instance Field

_ISerializableFixup Instance Field NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Instance
public Object Instance
Public Instance As Object
Public Instance As Object
public:
Object^ Instance
public:
Object^ Instance
val mutable Instance: Object
val mutable Instance: Object

Field Value

Type: Online Object
See Also
_ISerializableFixup Class
_ISerializableFixup Members
NFX.Serialization.Slim Namespace


_ISerializableFixup Methods

_ISerializableFixup Methods NFX Class Library

The _ISerializableFixup type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
_ISerializableFixup Class
NFX.Serialization.Slim Namespace


_OnDeserializedCallback Class

_OnDeserializedCallback Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Serialization.Slim _OnDeserializedCallback

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class _OnDeserializedCallback
internal class _OnDeserializedCallback
Friend Class _OnDeserializedCallback
Friend Class _OnDeserializedCallback
internal ref class _OnDeserializedCallback
internal ref class _OnDeserializedCallback
type _OnDeserializedCallback =  class end
type _OnDeserializedCallback =  class end
See Also
_OnDeserializedCallback Members
NFX.Serialization.Slim Namespace


_OnDeserializedCallback Members

_OnDeserializedCallback Members NFX Class Library

The _OnDeserializedCallback type exposes the following members.
Constructors
 | Name | Description
Public method | _OnDeserializedCallback | Initializes a new instance of the _OnDeserializedCallback class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Descriptor |
Public field | Instance |
Back to Top
See Also
_OnDeserializedCallback Class
NFX.Serialization.Slim Namespace


_OnDeserializedCallback Constructor

_OnDeserializedCallback Constructor NFX Class Library

Initializes a new instance of the _OnDeserializedCallback class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public _OnDeserializedCallback()
public _OnDeserializedCallback()
Public Sub New
Public Sub New
public:
_OnDeserializedCallback()
public:
_OnDeserializedCallback()
new : unit -> _OnDeserializedCallback
new : unit -> _OnDeserializedCallback
See Also
_OnDeserializedCallback Class
_OnDeserializedCallback Members
NFX.Serialization.Slim Namespace


_OnDeserializedCallback Fields

_OnDeserializedCallback Fields NFX Class Library

The _OnDeserializedCallback type exposes the following members.
Fields
 | Name | Description
Public field | Descriptor |
Public field | Instance |
Back to Top
See Also
_OnDeserializedCallback Class
NFX.Serialization.Slim Namespace


_OnDeserializedCallback.Descriptor Field

_OnDeserializedCallback Descriptor Field NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TypeDescriptor Descriptor
public TypeDescriptor Descriptor
Public Descriptor As TypeDescriptor
Public Descriptor As TypeDescriptor
public:
TypeDescriptor^ Descriptor
public:
TypeDescriptor^ Descriptor
val mutable Descriptor: TypeDescriptor
val mutable Descriptor: TypeDescriptor

Field Value

Type: TypeDescriptor
See Also
_OnDeserializedCallback Class
_OnDeserializedCallback Members
NFX.Serialization.Slim Namespace


_OnDeserializedCallback.Instance Field

_OnDeserializedCallback Instance Field NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Instance
public Object Instance
Public Instance As Object
Public Instance As Object
public:
Object^ Instance
public:
Object^ Instance
val mutable Instance: Object
val mutable Instance: Object

Field Value

Type: Online Object
See Also
_OnDeserializedCallback Class
_OnDeserializedCallback Members
NFX.Serialization.Slim Namespace


_OnDeserializedCallback Methods

_OnDeserializedCallback Methods NFX Class Library

The _OnDeserializedCallback type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
_OnDeserializedCallback Class
NFX.Serialization.Slim Namespace


Arrays Class

Arrays Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Serialization.Slim Arrays

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static class Arrays
internal static class Arrays
Friend NotInheritable Class Arrays
Friend NotInheritable Class Arrays
internal ref class Arrays abstract sealed
internal ref class Arrays abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Arrays =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Arrays =  class end
See Also
Arrays Members
NFX.Serialization.Slim Namespace


Arrays Members

Arrays Members NFX Class Library

The Arrays type exposes the following members.
Methods
Name | Description
ArrayToDescriptor |
DescriptorToArray |
Back to Top
Fields
Name | Description
MAX_DIM_COUNT | Maximum number of supported array dimensions. Used for possible stream corruption detection
MAX_ELM_COUNT | Maximum number of elements in any array. Used for possible stream corruption detection
Back to Top
See Also
Arrays Class
NFX.Serialization.Slim Namespace


Arrays Fields

Arrays Fields NFX Class Library

The Arrays type exposes the following members.
Fields
Name | Description
MAX_DIM_COUNT | Maximum number of supported array dimensions. Used for possible stream corruption detection
MAX_ELM_COUNT | Maximum number of elements in any array. Used for possible stream corruption detection
Back to Top
See Also
Arrays Class
NFX.Serialization.Slim Namespace


Arrays.MAX_DIM_COUNT Field

Arrays MAX_DIM_COUNT Field NFX Class Library

Maximum number of supported array dimensions. Used for possible stream corruption detection

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_DIM_COUNT
public const int MAX_DIM_COUNT
Public Const MAX_DIM_COUNT As Integer
Public Const MAX_DIM_COUNT As Integer
public:
literal int MAX_DIM_COUNT
public:
literal int MAX_DIM_COUNT
static val mutable MAX_DIM_COUNT: int
static val mutable MAX_DIM_COUNT: int

Field Value

Type: Online Int32
See Also
Arrays Class
Arrays Members
NFX.Serialization.Slim Namespace


Arrays.MAX_ELM_COUNT Field

Arrays MAX_ELM_COUNT Field NFX Class Library

Maximum number of elements in any array. Used for possible stream corruption detection

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int MAX_ELM_COUNT
public const int MAX_ELM_COUNT
Public Const MAX_ELM_COUNT As Integer
Public Const MAX_ELM_COUNT As Integer
public:
literal int MAX_ELM_COUNT
public:
literal int MAX_ELM_COUNT
static val mutable MAX_ELM_COUNT: int
static val mutable MAX_ELM_COUNT: int

Field Value

Type: Online Int32
See Also
Arrays Class
Arrays Members
NFX.Serialization.Slim Namespace


Arrays Methods

Arrays Methods NFX Class Library

The Arrays type exposes the following members.
Methods
Name | Description
ArrayToDescriptor |
DescriptorToArray |
Back to Top
See Also
Arrays Class
NFX.Serialization.Slim Namespace


Arrays.ArrayToDescriptor Method

Arrays ArrayToDescriptor Method NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ArrayToDescriptor(
    Array array,
    Type type,
    VarIntStr typeHandle
)
public static string ArrayToDescriptor(
    Array array,
    Type type,
    VarIntStr typeHandle
)
Public Shared Function ArrayToDescriptor (
    array As Array,
    type As Type,
    typeHandle As VarIntStr
) As String
Public Shared Function ArrayToDescriptor (
    array As Array,
    type As Type,
    typeHandle As VarIntStr
) As String
public:
static String^ ArrayToDescriptor(
    Array^ array,
    Type^ type,
    VarIntStr typeHandle
)
public:
static String^ ArrayToDescriptor(
    Array^ array,
    Type^ type,
    VarIntStr typeHandle
)
static member ArrayToDescriptor :
        array : Array *
        type : Type *
        typeHandle : VarIntStr -> string
static member ArrayToDescriptor :
        array : Array *
        type : Type *
        typeHandle : VarIntStr -> string

Parameters

array
Type: Online System Array
type
Type: Online System Type
typeHandle
Type: NFX.IO VarIntStr

Return Value

Type: Online String
See Also
Arrays Class
Arrays Members
NFX.Serialization.Slim Namespace


Arrays.DescriptorToArray Method

Arrays DescriptorToArray Method NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Array DescriptorToArray(
    string descr,
    Type type
)
public static Array DescriptorToArray(
    string descr,
    Type type
)
Public Shared Function DescriptorToArray (
    descr As String,
    type As Type
) As Array
Public Shared Function DescriptorToArray (
    descr As String,
    type As Type
) As Array
public:
static Array^ DescriptorToArray(
    String^ descr,
    Type^ type
)
public:
static Array^ DescriptorToArray(
    String^ descr,
    Type^ type
)
static member DescriptorToArray :
        descr : string *
        type : Type -> Array
static member DescriptorToArray :
        descr : string *
        type : Type -> Array

Parameters

descr
Type: Online System String
type
Type: Online System Type

Return Value

Type: Online Array
See Also
Arrays Class
Arrays Members
NFX.Serialization.Slim Namespace


dyn_deserialize Delegate

dyn_deserialize Delegate NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal delegate void dyn_deserialize(
    TypeSchema schema,
    SlimReader reader,
    TypeRegistry tregistry,
    RefPool refs,
    ref Object instance,
    StreamingContext context
)
internal delegate void dyn_deserialize(
    TypeSchema schema,
    SlimReader reader,
    TypeRegistry tregistry,
    RefPool refs,
    ref Object instance,
    StreamingContext context
)
Friend Delegate Sub dyn_deserialize (
    schema As TypeSchema,
    reader As SlimReader,
    tregistry As TypeRegistry,
    refs As RefPool,
    ByRef instance As Object,
    context As StreamingContext
)
Friend Delegate Sub dyn_deserialize (
    schema As TypeSchema,
    reader As SlimReader,
    tregistry As TypeRegistry,
    refs As RefPool,
    ByRef instance As Object,
    context As StreamingContext
)
internal delegate void dyn_deserialize(
    TypeSchema^ schema,
    SlimReader^ reader,
    TypeRegistry^ tregistry,
    RefPool^ refs,
    Object^% instance,
    StreamingContext context
)
internal delegate void dyn_deserialize(
    TypeSchema^ schema,
    SlimReader^ reader,
    TypeRegistry^ tregistry,
    RefPool^ refs,
    Object^% instance,
    StreamingContext context
)
type dyn_deserialize =
    delegate of
        schema : TypeSchema *
        reader : SlimReader *
        tregistry : TypeRegistry *
        refs : RefPool *
        instance : Object byref *
        context : StreamingContext -> unit
type dyn_deserialize =
    delegate of
        schema : TypeSchema *
        reader : SlimReader *
        tregistry : TypeRegistry *
        refs : RefPool *
        instance : Object byref *
        context : StreamingContext -> unit

Parameters

schema
Type: NFX.Serialization.Slim TypeSchema
reader
Type: NFX.IO SlimReader
tregistry
Type: NFX.Serialization.Slim TypeRegistry
refs
Type: NFX.Serialization.Slim RefPool
instance
Type: Online System Object
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
NFX.Serialization.Slim Namespace


dyn_serialize Delegate

dyn_serialize Delegate NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal delegate void dyn_serialize(
    TypeSchema schema,
    SlimWriter writer,
    TypeRegistry tregistry,
    RefPool refs,
    Object instance,
    StreamingContext context
)
internal delegate void dyn_serialize(
    TypeSchema schema,
    SlimWriter writer,
    TypeRegistry tregistry,
    RefPool refs,
    Object instance,
    StreamingContext context
)
Friend Delegate Sub dyn_serialize (
    schema As TypeSchema,
    writer As SlimWriter,
    tregistry As TypeRegistry,
    refs As RefPool,
    instance As Object,
    context As StreamingContext
)
Friend Delegate Sub dyn_serialize (
    schema As TypeSchema,
    writer As SlimWriter,
    tregistry As TypeRegistry,
    refs As RefPool,
    instance As Object,
    context As StreamingContext
)
internal delegate void dyn_serialize(
    TypeSchema^ schema,
    SlimWriter^ writer,
    TypeRegistry^ tregistry,
    RefPool^ refs,
    Object^ instance,
    StreamingContext context
)
internal delegate void dyn_serialize(
    TypeSchema^ schema,
    SlimWriter^ writer,
    TypeRegistry^ tregistry,
    RefPool^ refs,
    Object^ instance,
    StreamingContext context
)
type dyn_serialize =
    delegate of
        schema : TypeSchema *
        writer : SlimWriter *
        tregistry : TypeRegistry *
        refs : RefPool *
        instance : Object *
        context : StreamingContext -> unit
type dyn_serialize =
    delegate of
        schema : TypeSchema *
        writer : SlimWriter *
        tregistry : TypeRegistry *
        refs : RefPool *
        instance : Object *
        context : StreamingContext -> unit

Parameters

schema
Type: NFX.Serialization.Slim TypeSchema
writer
Type: NFX.IO SlimWriter
tregistry
Type: NFX.Serialization.Slim TypeRegistry
refs
Type: NFX.Serialization.Slim RefPool
instance
Type: Online System Object
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
NFX.Serialization.Slim Namespace


ISlimSerializer Interface

ISlimSerializer Interface NFX Class Library

Marker interface for formats based on Slim algorithm family

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ISlimSerializer : ISerializer
public interface ISlimSerializer : ISerializer
Public Interface ISlimSerializer
    Inherits ISerializer
Public Interface ISlimSerializer
    Inherits ISerializer
public interface class ISlimSerializer : ISerializer
public interface class ISlimSerializer : ISerializer
type ISlimSerializer =
    interface
        interface ISerializer
    end
type ISlimSerializer =
    interface
        interface ISerializer
    end
See Also
ISlimSerializer Members
NFX.Serialization.Slim Namespace


ISlimSerializer Members

ISlimSerializer Members NFX Class Library

The ISlimSerializer type exposes the following members.
Methods
 | Name | Description
Public method | Deserialize | (Inherited from ISerializer.)
Public method | ResetCallBatch | Resets type registry state to initial state (which is based on global types) for TypeMode = "Batch", otherwise does nothing
Public method | Serialize | (Inherited from ISerializer.)
Back to Top
Properties
 | Name | Description
Public property | BatchTypesAdded | Returns true if last call to Serialize or Deserialize in batch mode added more types to type registry. This call is only valid in TypeMode = "Batch" and is inherently not thread-safe
Public property | IsThreadSafe | Indicates whether Serialize/Deserialize may be called by multiple threads at the same time (Inherited from ISerializer.)
Public property | TypeMode | Gets/sets how serializer handles type information between calls to Serialize/Deserialize. This property itself is not thread-safe, that is - it should be only set once by control/initiating thread
Back to Top
See Also
ISlimSerializer Interface
NFX.Serialization.Slim Namespace


ISlimSerializer Methods

ISlimSerializer Methods NFX Class Library

The ISlimSerializer type exposes the following members.
Methods
 | Name | Description
Public method | Deserialize | (Inherited from ISerializer.)
Public method | ResetCallBatch | Resets type registry state to initial state (which is based on global types) for TypeMode = "Batch", otherwise does nothing
Public method | Serialize | (Inherited from ISerializer.)
Back to Top
See Also
ISlimSerializer Interface
NFX.Serialization.Slim Namespace


ISlimSerializer.ResetCallBatch Method

ISlimSerializer ResetCallBatch Method NFX Class Library

Resets type registry state to initial state (which is based on global types) for TypeMode = "Batch", otherwise does nothing

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ResetCallBatch()
void ResetCallBatch()
Sub ResetCallBatch
Sub ResetCallBatch
void ResetCallBatch()
void ResetCallBatch()
abstract ResetCallBatch : unit -> unit
abstract ResetCallBatch : unit -> unit
See Also
ISlimSerializer Interface
ISlimSerializer Members
NFX.Serialization.Slim Namespace


ISlimSerializer Properties

ISlimSerializer Properties NFX Class Library

The ISlimSerializer type exposes the following members.
Properties
 | Name | Description
Public property | BatchTypesAdded | Returns true if last call to Serialize or Deserialize in batch mode added more types to type registry. This call is only valid in TypeMode = "Batch" and is inherently not thread-safe
Public property | IsThreadSafe | Indicates whether Serialize/Deserialize may be called by multiple threads at the same time (Inherited from ISerializer.)
Public property | TypeMode | Gets/sets how serializer handles type information between calls to Serialize/Deserialize. This property itself is not thread-safe, that is - it should be only set once by control/initiating thread
Back to Top
See Also
ISlimSerializer Interface
NFX.Serialization.Slim Namespace


ISlimSerializer.BatchTypesAdded Property

ISlimSerializer BatchTypesAdded Property NFX Class Library

Returns true if last call to Serialize or Deserialize in batch mode added more types to type registry. This call is only valid in TypeMode = "Batch" and is inherently not thread-safe

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool BatchTypesAdded { get; }
bool BatchTypesAdded { get; }
ReadOnly Property BatchTypesAdded As Boolean
    Get
ReadOnly Property BatchTypesAdded As Boolean
    Get
property bool BatchTypesAdded {
    bool get ();
}
property bool BatchTypesAdded {
    bool get ();
}
abstract BatchTypesAdded : bool with get
abstract BatchTypesAdded : bool with get

Property Value

Type: Online Boolean
See Also
ISlimSerializer Interface
ISlimSerializer Members
NFX.Serialization.Slim Namespace


ISlimSerializer.TypeMode Property

ISlimSerializer TypeMode Property NFX Class Library

Gets/sets how serializer handles type information between calls to Serialize/Deserialize. This property itself is not thread-safe, that is - it should be only set once by control/initiating thread

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
TypeRegistryMode TypeMode { get; set; }
TypeRegistryMode TypeMode { get; set; }
Property TypeMode As TypeRegistryMode
    Get
    Set
Property TypeMode As TypeRegistryMode
    Get
    Set
property TypeRegistryMode TypeMode {
    TypeRegistryMode get ();
    void set (TypeRegistryMode value);
}
property TypeRegistryMode TypeMode {
    TypeRegistryMode get ();
    void set (TypeRegistryMode value);
}
abstract TypeMode : TypeRegistryMode with get, set
abstract TypeMode : TypeRegistryMode with get, set

Property Value

Type: TypeRegistryMode
See Also
ISlimSerializer Interface
ISlimSerializer Members
NFX.Serialization.Slim Namespace


PODSlimSerializer Class

PODSlimSerializer Class NFX Class Library

Serializes CLR object graphs using PortableObjectDocument container and Slim binary serialization algorithm. This class is far less performant than SlimSerializer, however it serializes types using document model that allows to transform/change data during serialization/deserialization. This class is needed for upgrades, when object metadata may change but need to be read (maybe partially) back into the new type structure
Inheritance Hierarchy
Online System Object
NFX.Serialization.Slim PODSlimSerializer

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PODSlimSerializer : ISlimSerializer,
    ISerializer
public class PODSlimSerializer : ISlimSerializer,
    ISerializer
Public Class PODSlimSerializer
    Implements ISlimSerializer, ISerializer
Public Class PODSlimSerializer
    Implements ISlimSerializer, ISerializer
public ref class PODSlimSerializer : ISlimSerializer,
    ISerializer
public ref class PODSlimSerializer : ISlimSerializer,
    ISerializer
type PODSlimSerializer =
    class
        interface ISlimSerializer
        interface ISerializer
    end
type PODSlimSerializer =
    class
        interface ISlimSerializer
        interface ISerializer
    end
See Also
PODSlimSerializer Members
NFX.Serialization.Slim Namespace


PODSlimSerializer Members

PODSlimSerializer Members NFX Class Library

The PODSlimSerializer type exposes the following members.
Constructors
 | Name | Description
Public method | PODSlimSerializer | Initializes a new instance of the PODSlimSerializer class
Back to Top
Methods
 | Name | Description
Public method | Deserialize(Stream) | Desirializes a graph of arbitrary CLR objects that was serialized before
Public method | Deserialize(Stream, ReadingStrategy) | Desirializes a graph of arbitrary CLR objects that was serialized before
Public method | DeserializeDocument | Deserializes a PortableObjectDocument container instance
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Serialize(Stream, Object) | Serializes a graph of arbitrary CLR objects into stream using PortableObjectDocument container
Public method | Serialize(Stream, Object, Nullable DateTime , String) | Serializes a graph of arbitrary CLR objects into stream using PortableObjectDocument container, optionally taking document creation attributes
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ISerializer IsThreadSafe | This serializer is thread-safe
Explicit interface implemetation | ISlimSerializer BatchTypesAdded | Not supported here
Explicit interface implemetation | ISlimSerializer ResetCallBatch | This method does nothig in this class
Explicit interface implemetation | ISlimSerializer TypeMode | This serializer always uses "PerCall" setting. Setting this property has no effect
Back to Top
See Also
PODSlimSerializer Class
NFX.Serialization.Slim Namespace


PODSlimSerializer Constructor

PODSlimSerializer Constructor NFX Class Library

Initializes a new instance of the PODSlimSerializer class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PODSlimSerializer()
public PODSlimSerializer()
Public Sub New
Public Sub New
public:
PODSlimSerializer()
public:
PODSlimSerializer()
new : unit -> PODSlimSerializer
new : unit -> PODSlimSerializer
See Also
PODSlimSerializer Class
PODSlimSerializer Members
NFX.Serialization.Slim Namespace


PODSlimSerializer Methods

PODSlimSerializer Methods NFX Class Library

The PODSlimSerializer type exposes the following members.
Methods
 | Name | Description
Public method | Deserialize(Stream) | Desirializes a graph of arbitrary CLR objects that was serialized before
Public method | Deserialize(Stream, ReadingStrategy) | Desirializes a graph of arbitrary CLR objects that was serialized before
Public method | DeserializeDocument | Deserializes a PortableObjectDocument container instance
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Serialize(Stream, Object) | Serializes a graph of arbitrary CLR objects into stream using PortableObjectDocument container
Public method | Serialize(Stream, Object, Nullable DateTime , String) | Serializes a graph of arbitrary CLR objects into stream using PortableObjectDocument container, optionally taking document creation attributes
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ISlimSerializer ResetCallBatch | This method does nothig in this class
Back to Top
See Also
PODSlimSerializer Class
NFX.Serialization.Slim Namespace


PODSlimSerializer.Deserialize Method

PODSlimSerializer Deserialize Method NFX Class Library

Overload List
 | Name | Description
Public method | Deserialize(Stream) | Desirializes a graph of arbitrary CLR objects that was serialized before
Public method | Deserialize(Stream, ReadingStrategy) | Desirializes a graph of arbitrary CLR objects that was serialized before
Back to Top
See Also
PODSlimSerializer Class
PODSlimSerializer Members
NFX.Serialization.Slim Namespace


PODSlimSerializer.Deserialize Method (Stream)

PODSlimSerializer Deserialize Method (Stream) NFX Class Library

[This is preliminary documentation and is subject to change.]

Desirializes a graph of arbitrary CLR objects that was serialized before

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Deserialize(
    Stream stream
)
public Object Deserialize(
    Stream stream
)
Public Function Deserialize (
    stream As Stream
) As Object
Public Function Deserialize (
    stream As Stream
) As Object
public:
virtual Object^ Deserialize(
    Stream^ stream
) sealed
public:
virtual Object^ Deserialize(
    Stream^ stream
) sealed
abstract Deserialize :
        stream : Stream -> Object
override Deserialize :
        stream : Stream -> Object
abstract Deserialize :
        stream : Stream -> Object
override Deserialize :
        stream : Stream -> Object

Parameters

stream
Type: Online System.IO Stream
Source data stream in Slim binary format

Return Value

Type: Online Object
CLR object graph which is deserialized from possibly transformed PortableObjectDocument container

Implements

ISerializer Deserialize(Stream)
See Also
PODSlimSerializer Class
PODSlimSerializer Members
Deserialize Overload
NFX.Serialization.Slim Namespace


PODSlimSerializer.Deserialize Method (Stream, ReadingStrategy)

PODSlimSerializer Deserialize Method (Stream, ReadingStrategy) NFX Class Library

[This is preliminary documentation and is subject to change.]

Desirializes a graph of arbitrary CLR objects that was serialized before

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Deserialize(
    Stream stream,
    ReadingStrategy readingStrategy = null
)
public Object Deserialize(
    Stream stream,
    ReadingStrategy readingStrategy = null
)
Public Function Deserialize (
    stream As Stream,
    Optional readingStrategy As ReadingStrategy = Nothing
) As Object
Public Function Deserialize (
    stream As Stream,
    Optional readingStrategy As ReadingStrategy = Nothing
) As Object
public:
Object^ Deserialize(
    Stream^ stream,
    ReadingStrategy^ readingStrategy = nullptr
)
public:
Object^ Deserialize(
    Stream^ stream,
    ReadingStrategy^ readingStrategy = nullptr
)
member Deserialize :
        stream : Stream *
        ?readingStrategy : ReadingStrategy
(* Defaults:
        let _readingStrategy = defaultArg readingStrategy null
*)
-> Object
member Deserialize :
        stream : Stream *
        ?readingStrategy : ReadingStrategy
(* Defaults:
        let _readingStrategy = defaultArg readingStrategy null
*)
-> Object

Parameters

stream
Type: Online System.IO Stream
Source data stream in Slim binary format
readingStrategy (Optional)
Type: NFX.Serialization.POD ReadingStrategy
Optional reading strategy

Return Value

Type: Online Object
CLR object graph which is deserialized from possibly transformed PortableObjectDocument container
See Also
PODSlimSerializer Class
PODSlimSerializer Members
Deserialize Overload
NFX.Serialization.Slim Namespace


PODSlimSerializer.DeserializeDocument Method

PODSlimSerializer DeserializeDocument Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Deserializes a PortableObjectDocument container instance

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PortableObjectDocument DeserializeDocument(
    Stream stream
)
public PortableObjectDocument DeserializeDocument(
    Stream stream
)
Public Function DeserializeDocument (
    stream As Stream
) As PortableObjectDocument
Public Function DeserializeDocument (
    stream As Stream
) As PortableObjectDocument
public:
PortableObjectDocument^ DeserializeDocument(
    Stream^ stream
)
public:
PortableObjectDocument^ DeserializeDocument(
    Stream^ stream
)
member DeserializeDocument :
        stream : Stream -> PortableObjectDocument
member DeserializeDocument :
        stream : Stream -> PortableObjectDocument

Parameters

stream
Type: Online System.IO Stream
Source data stream in Slim binary format

Return Value

Type: PortableObjectDocument
PortableObjectDocument instance
See Also
PODSlimSerializer Class
PODSlimSerializer Members
NFX.Serialization.Slim Namespace


PODSlimSerializer.ISlimSerializer.ResetCallBatch Method

PODSlimSerializer ISlimSerializer ResetCallBatch Method NFX Class Library

[This is preliminary documentation and is subject to change.]

This method does nothig in this class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ISlimSerializer.ResetCallBatch()
void ISlimSerializer.ResetCallBatch()
Private Sub ResetCallBatch Implements ISlimSerializer.ResetCallBatch
Private Sub ResetCallBatch Implements ISlimSerializer.ResetCallBatch
private:
virtual void ResetCallBatch() sealed = ISlimSerializer::ResetCallBatch
private:
virtual void ResetCallBatch() sealed = ISlimSerializer::ResetCallBatch
private abstract ResetCallBatch : unit -> unit
private override ResetCallBatch : unit -> unit
private abstract ResetCallBatch : unit -> unit
private override ResetCallBatch : unit -> unit

Implements

ISlimSerializer ResetCallBatch
See Also
PODSlimSerializer Class
PODSlimSerializer Members
NFX.Serialization.Slim Namespace


PODSlimSerializer.Serialize Method

PODSlimSerializer Serialize Method NFX Class Library

Overload List
 | Name | Description
Public method | Serialize(Stream, Object) | Serializes a graph of arbitrary CLR objects into stream using PortableObjectDocument container
Public method | Serialize(Stream, Object, Nullable DateTime , String) | Serializes a graph of arbitrary CLR objects into stream using PortableObjectDocument container, optionally taking document creation attributes
Back to Top
See Also
PODSlimSerializer Class
PODSlimSerializer Members
NFX.Serialization.Slim Namespace


PODSlimSerializer.Serialize Method (Stream, Object)

PODSlimSerializer Serialize Method (Stream, Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Serializes a graph of arbitrary CLR objects into stream using PortableObjectDocument container

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Serialize(
    Stream stream,
    Object root
)
public void Serialize(
    Stream stream,
    Object root
)
Public Sub Serialize (
    stream As Stream,
    root As Object
)
Public Sub Serialize (
    stream As Stream,
    root As Object
)
public:
virtual void Serialize(
    Stream^ stream,
    Object^ root
) sealed
public:
virtual void Serialize(
    Stream^ stream,
    Object^ root
) sealed
abstract Serialize :
        stream : Stream *
        root : Object -> unit
override Serialize :
        stream : Stream *
        root : Object -> unit
abstract Serialize :
        stream : Stream *
        root : Object -> unit
override Serialize :
        stream : Stream *
        root : Object -> unit

Parameters

stream
Type: Online System.IO Stream
Target stream
root
Type: Online System Object
CLR object graph

Implements

ISerializer Serialize(Stream, Object)
See Also
PODSlimSerializer Class
PODSlimSerializer Members
Serialize Overload
NFX.Serialization.Slim Namespace


PODSlimSerializer.Serialize Method (Stream, Object, Nullable(DateTime), String)

PODSlimSerializer Serialize Method (Stream, Object, Nullable DateTime , String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Serializes a graph of arbitrary CLR objects into stream using PortableObjectDocument container, optionally taking document creation attributes

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Serialize(
    Stream stream,
    Object root,
    Nullable<DateTime> documentCreationDate = null,
    string documentNotes = null
)
public void Serialize(
    Stream stream,
    Object root,
    Nullable<DateTime> documentCreationDate = null,
    string documentNotes = null
)
Public Sub Serialize (
    stream As Stream,
    root As Object,
    Optional documentCreationDate As Nullable(Of DateTime) = Nothing,
    Optional documentNotes As String = Nothing
)
Public Sub Serialize (
    stream As Stream,
    root As Object,
    Optional documentCreationDate As Nullable(Of DateTime) = Nothing,
    Optional documentNotes As String = Nothing
)
public:
void Serialize(
    Stream^ stream,
    Object^ root,
    Nullable<DateTime> documentCreationDate = nullptr,
    String^ documentNotes = nullptr
)
public:
void Serialize(
    Stream^ stream,
    Object^ root,
    Nullable<DateTime> documentCreationDate = nullptr,
    String^ documentNotes = nullptr
)
member Serialize :
        stream : Stream *
        root : Object *
        ?documentCreationDate : Nullable<DateTime> *
        ?documentNotes : string
(* Defaults:
        let _documentCreationDate = defaultArg documentCreationDate null
        let _documentNotes = defaultArg documentNotes null
*)
-> unit
member Serialize :
        stream : Stream *
        root : Object *
        ?documentCreationDate : Nullable<DateTime> *
        ?documentNotes : string
(* Defaults:
        let _documentCreationDate = defaultArg documentCreationDate null
        let _documentNotes = defaultArg documentNotes null
*)
-> unit

Parameters

stream
Type: Online System.IO Stream
Target stream
root
Type: Online System Object
CLR object graph
documentCreationDate (Optional)
Type: Online System Nullable Online DateTime
Optional document creation attribute
documentNotes (Optional)
Type: Online System String
Optional document creation attribute
See Also
PODSlimSerializer Class
PODSlimSerializer Members
Serialize Overload
NFX.Serialization.Slim Namespace


PODSlimSerializer Properties

PODSlimSerializer Properties NFX Class Library

Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ISerializer IsThreadSafe | This serializer is thread-safe
Explicit interface implemetation | ISlimSerializer BatchTypesAdded | Not supported here
Explicit interface implemetation | ISlimSerializer TypeMode | This serializer always uses "PerCall" setting. Setting this property has no effect
Back to Top
See Also
PODSlimSerializer Class
NFX.Serialization.Slim Namespace


PODSlimSerializer.ISerializer.IsThreadSafe Property

PODSlimSerializer ISerializer IsThreadSafe Property NFX Class Library

[This is preliminary documentation and is subject to change.]

This serializer is thread-safe

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool ISerializer.IsThreadSafe { get; }
bool ISerializer.IsThreadSafe { get; }
Private ReadOnly Property IsThreadSafe As Boolean
    Implements ISerializer.IsThreadSafe
    Get
Private ReadOnly Property IsThreadSafe As Boolean
    Implements ISerializer.IsThreadSafe
    Get
private:
virtual property bool IsThreadSafe {
    bool get () sealed = ISerializer::IsThreadSafe::get;
}
private:
virtual property bool IsThreadSafe {
    bool get () sealed = ISerializer::IsThreadSafe::get;
}
private abstract IsThreadSafe : bool with get
private override IsThreadSafe : bool with get
private abstract IsThreadSafe : bool with get
private override IsThreadSafe : bool with get

Property Value

Type: Online Boolean

Implements

ISerializer IsThreadSafe
See Also
PODSlimSerializer Class
PODSlimSerializer Members
NFX.Serialization.Slim Namespace


PODSlimSerializer.ISlimSerializer.BatchTypesAdded Property

PODSlimSerializer ISlimSerializer BatchTypesAdded Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Not supported here

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool ISlimSerializer.BatchTypesAdded { get; }
bool ISlimSerializer.BatchTypesAdded { get; }
Private ReadOnly Property BatchTypesAdded As Boolean
    Implements ISlimSerializer.BatchTypesAdded
    Get
Private ReadOnly Property BatchTypesAdded As Boolean
    Implements ISlimSerializer.BatchTypesAdded
    Get
private:
virtual property bool BatchTypesAdded {
    bool get () sealed = ISlimSerializer::BatchTypesAdded::get;
}
private:
virtual property bool BatchTypesAdded {
    bool get () sealed = ISlimSerializer::BatchTypesAdded::get;
}
private abstract BatchTypesAdded : bool with get
private override BatchTypesAdded : bool with get
private abstract BatchTypesAdded : bool with get
private override BatchTypesAdded : bool with get

Property Value

Type: Online Boolean

Implements

ISlimSerializer BatchTypesAdded
See Also
PODSlimSerializer Class
PODSlimSerializer Members
NFX.Serialization.Slim Namespace


PODSlimSerializer.ISlimSerializer.TypeMode Property

PODSlimSerializer ISlimSerializer TypeMode Property NFX Class Library

[This is preliminary documentation and is subject to change.]

This serializer always uses "PerCall" setting. Setting this property has no effect

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
TypeRegistryMode ISlimSerializer.TypeMode { get; set; }
TypeRegistryMode ISlimSerializer.TypeMode { get; set; }
Private Property TypeMode As TypeRegistryMode
    Implements ISlimSerializer.TypeMode
    Get
    Set
Private Property TypeMode As TypeRegistryMode
    Implements ISlimSerializer.TypeMode
    Get
    Set
private:
virtual property TypeRegistryMode TypeMode {
    TypeRegistryMode get () sealed = ISlimSerializer::TypeMode::get;
    void set (TypeRegistryMode value) sealed = ISlimSerializer::TypeMode::set;
}
private:
virtual property TypeRegistryMode TypeMode {
    TypeRegistryMode get () sealed = ISlimSerializer::TypeMode::get;
    void set (TypeRegistryMode value) sealed = ISlimSerializer::TypeMode::set;
}
private abstract TypeMode : TypeRegistryMode with get, set
private override TypeMode : TypeRegistryMode with get, set
private abstract TypeMode : TypeRegistryMode with get, set
private override TypeMode : TypeRegistryMode with get, set

Property Value

Type: TypeRegistryMode

Implements

ISlimSerializer TypeMode
See Also
PODSlimSerializer Class
PODSlimSerializer Members
NFX.Serialization.Slim Namespace


QuickRefList Structure

QuickRefList Structure NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal struct QuickRefList
internal struct QuickRefList
Friend Structure QuickRefList
Friend Structure QuickRefList
internal value class QuickRefList
internal value class QuickRefList
[<SealedAttribute>]
type QuickRefList =  struct end
[<SealedAttribute>]
type QuickRefList =  struct end
See Also
QuickRefList Members
NFX.Serialization.Slim Namespace


QuickRefList Members

QuickRefList Members NFX Class Library

The QuickRefList type exposes the following members.
Constructors
 | Name | Description
Public method | QuickRefList | Initializes a new instance of the QuickRefList class
Back to Top
Methods
 | Name | Description
Public method | Add |
Public method | Clear |
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Count |
Public property | Item |
Back to Top
See Also
QuickRefList Structure
NFX.Serialization.Slim Namespace


QuickRefList Constructor

QuickRefList Constructor NFX Class Library

Initializes a new instance of the QuickRefList class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public QuickRefList(
    int capacity
)
public QuickRefList(
    int capacity
)
Public Sub New (
    capacity As Integer
)
Public Sub New (
    capacity As Integer
)
public:
QuickRefList(
    int capacity
)
public:
QuickRefList(
    int capacity
)
new :
        capacity : int -> QuickRefList
new :
        capacity : int -> QuickRefList

Parameters

capacity
Type: Online System Int32
See Also
QuickRefList Structure
QuickRefList Members
NFX.Serialization.Slim Namespace


QuickRefList Methods

QuickRefList Methods NFX Class Library

The QuickRefList type exposes the following members.
Methods
 | Name | Description
Public method | Add |
Public method | Clear |
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
QuickRefList Structure
NFX.Serialization.Slim Namespace


QuickRefList.Add Method

QuickRefList Add Method NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Add(
    Object reference
)
public void Add(
    Object reference
)
Public Sub Add (
    reference As Object
)
Public Sub Add (
    reference As Object
)
public:
void Add(
    Object^ reference
)
public:
void Add(
    Object^ reference
)
member Add :
        reference : Object -> unit
member Add :
        reference : Object -> unit

Parameters

reference
Type: Online System Object
See Also
QuickRefList Structure
QuickRefList Members
NFX.Serialization.Slim Namespace


QuickRefList.Clear Method

QuickRefList Clear Method NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
void Clear()
public:
void Clear()
member Clear : unit -> unit
member Clear : unit -> unit
See Also
QuickRefList Structure
QuickRefList Members
NFX.Serialization.Slim Namespace


QuickRefList Properties

QuickRefList Properties NFX Class Library

The QuickRefList type exposes the following members.
Properties
 | Name | Description
Public property | Count |
Public property | Item |
Back to Top
See Also
QuickRefList Structure
NFX.Serialization.Slim Namespace


QuickRefList.Count Property

QuickRefList Count Property NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
public:
property int Count {
    int get ();
}
member Count : int with get
member Count : int with get

Property Value

Type: Online Int32
See Also
QuickRefList Structure
QuickRefList Members
NFX.Serialization.Slim Namespace


QuickRefList.Item Property

QuickRefList Item Property NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object this[
    int i
] { get; }
public Object this[
    int i
] { get; }
Public ReadOnly Default Property Item (
    i As Integer
) As Object
    Get
Public ReadOnly Default Property Item (
    i As Integer
) As Object
    Get
public:
property Object^ default[int i] {
    Object^ get (int i);
}
public:
property Object^ default[int i] {
    Object^ get (int i);
}
member Item : Object with get
member Item : Object with get

Parameters

i
Type: Online System Int32

Property Value

Type: Online Object
See Also
QuickRefList Structure
QuickRefList Members
NFX.Serialization.Slim Namespace


RefPool Class

RefPool Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Serialization.Slim RefPool

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class RefPool
internal class RefPool
Friend Class RefPool
Friend Class RefPool
internal ref class RefPool
internal ref class RefPool
type RefPool =  class end
type RefPool =  class end
See Also
RefPool Members
NFX.Serialization.Slim Namespace


RefPool Members

RefPool Members NFX Class Library

The RefPool type exposes the following members.
Constructors
 | Name | Description
Public method | RefPool | Initializes a new instance of the RefPool class
Back to Top
Methods
 | Name | Description
Public method | Acquire |
Public method | Add |
Public method | AddISerializableFixup |
Public method | AddOnDeserializedCallback |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHandle | Emits MetaHandle that contains type handle for reference handle only when this referenced is added to pool for the first time. Emits inlined string for strings and inlined value types for boxed objects. Emits additional array dimensions info for array refernces who's types are emitted for the first time
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HandleToReference | Returns object reference for supplied metahandle
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Release |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Count |
Public property | Fixups |
Public property | Item |
Public property | OnDeserializedCallbacks |
Back to Top
See Also
RefPool Class
NFX.Serialization.Slim Namespace


RefPool Constructor

RefPool Constructor NFX Class Library

Initializes a new instance of the RefPool class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RefPool()
public RefPool()
Public Sub New
Public Sub New
public:
RefPool()
public:
RefPool()
new : unit -> RefPool
new : unit -> RefPool
See Also
RefPool Class
RefPool Members
NFX.Serialization.Slim Namespace


RefPool Methods

RefPool Methods NFX Class Library

The RefPool type exposes the following members.
Methods
 | Name | Description
Public method | Acquire |
Public method | Add |
Public method | AddISerializableFixup |
Public method | AddOnDeserializedCallback |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHandle | Emits MetaHandle that contains type handle for reference handle only when this referenced is added to pool for the first time. Emits inlined string for strings and inlined value types for boxed objects. Emits additional array dimensions info for array refernces who's types are emitted for the first time
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | HandleToReference | Returns object reference for supplied metahandle
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Release |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
RefPool Class
NFX.Serialization.Slim Namespace


RefPool.Acquire Method

RefPool Acquire Method NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Acquire(
    SerializationOperation mode
)
public void Acquire(
    SerializationOperation mode
)
Public Sub Acquire (
    mode As SerializationOperation
)
Public Sub Acquire (
    mode As SerializationOperation
)
public:
void Acquire(
    SerializationOperation mode
)
public:
void Acquire(
    SerializationOperation mode
)
member Acquire :
        mode : SerializationOperation -> unit
member Acquire :
        mode : SerializationOperation -> unit

Parameters

mode
Type: NFX.Serialization SerializationOperation
See Also
RefPool Class
RefPool Members
NFX.Serialization.Slim Namespace


RefPool.Add Method

RefPool Add Method NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Add(
    Object reference
)
public bool Add(
    Object reference
)
Public Function Add (
    reference As Object
) As Boolean
Public Function Add (
    reference As Object
) As Boolean
public:
bool Add(
    Object^ reference
)
public:
bool Add(
    Object^ reference
)
member Add :
        reference : Object -> bool
member Add :
        reference : Object -> bool

Parameters

reference
Type: Online System Object

Return Value

Type: Online Boolean
See Also
RefPool Class
RefPool Members
NFX.Serialization.Slim Namespace


RefPool.AddISerializableFixup Method

RefPool AddISerializableFixup Method NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddISerializableFixup(
    Object instance,
    SerializationInfo info
)
public void AddISerializableFixup(
    Object instance,
    SerializationInfo info
)
Public Sub AddISerializableFixup (
    instance As Object,
    info As SerializationInfo
)
Public Sub AddISerializableFixup (
    instance As Object,
    info As SerializationInfo
)
public:
void AddISerializableFixup(
    Object^ instance,
    SerializationInfo^ info
)
public:
void AddISerializableFixup(
    Object^ instance,
    SerializationInfo^ info
)
member AddISerializableFixup :
        instance : Object *
        info : SerializationInfo -> unit
member AddISerializableFixup :
        instance : Object *
        info : SerializationInfo -> unit

Parameters

instance
Type: Online System Object
info
Type: Online System.Runtime.Serialization SerializationInfo
See Also
RefPool Class
RefPool Members
NFX.Serialization.Slim Namespace


RefPool.AddOnDeserializedCallback Method

RefPool AddOnDeserializedCallback Method NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AddOnDeserializedCallback(
    Object instance,
    TypeDescriptor descriptor
)
public void AddOnDeserializedCallback(
    Object instance,
    TypeDescriptor descriptor
)
Public Sub AddOnDeserializedCallback (
    instance As Object,
    descriptor As TypeDescriptor
)
Public Sub AddOnDeserializedCallback (
    instance As Object,
    descriptor As TypeDescriptor
)
public:
void AddOnDeserializedCallback(
    Object^ instance,
    TypeDescriptor^ descriptor
)
public:
void AddOnDeserializedCallback(
    Object^ instance,
    TypeDescriptor^ descriptor
)
member AddOnDeserializedCallback :
        instance : Object *
        descriptor : TypeDescriptor -> unit
member AddOnDeserializedCallback :
        instance : Object *
        descriptor : TypeDescriptor -> unit

Parameters

instance
Type: Online System Object
descriptor
Type: NFX.Serialization.Slim TypeDescriptor
See Also
RefPool Class
RefPool Members
NFX.Serialization.Slim Namespace


RefPool.GetHandle Method

RefPool GetHandle Method NFX Class Library

Emits MetaHandle that contains type handle for reference handle only when this referenced is added to pool for the first time. Emits inlined string for strings and inlined value types for boxed objects. Emits additional array dimensions info for array refernces who's types are emitted for the first time

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MetaHandle GetHandle(
    Object reference,
    TypeRegistry treg,
    SlimFormat format,
    out Type type
)
public MetaHandle GetHandle(
    Object reference,
    TypeRegistry treg,
    SlimFormat format,
    out Type type
)
Public Function GetHandle (
    reference As Object,
    treg As TypeRegistry,
    format As SlimFormat,
    <OutAttribute> ByRef type As Type
) As MetaHandle
Public Function GetHandle (
    reference As Object,
    treg As TypeRegistry,
    format As SlimFormat,
    <OutAttribute> ByRef type As Type
) As MetaHandle
public:
MetaHandle GetHandle(
    Object^ reference,
    TypeRegistry^ treg,
    SlimFormat^ format,
    [OutAttribute] Type^% type
)
public:
MetaHandle GetHandle(
    Object^ reference,
    TypeRegistry^ treg,
    SlimFormat^ format,
    [OutAttribute] Type^% type
)
member GetHandle :
        reference : Object *
        treg : TypeRegistry *
        format : SlimFormat *
        type : Type byref -> MetaHandle
member GetHandle :
        reference : Object *
        treg : TypeRegistry *
        format : SlimFormat *
        type : Type byref -> MetaHandle

Parameters

reference
Type: Online System Object
treg
Type: NFX.Serialization.Slim TypeRegistry
format
Type: NFX.IO SlimFormat
type
Type: Online System Type

Return Value

Type: MetaHandle
See Also
RefPool Class
RefPool Members
NFX.Serialization.Slim Namespace


RefPool.HandleToReference Method

RefPool HandleToReference Method NFX Class Library

Returns object reference for supplied metahandle

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object HandleToReference(
    MetaHandle handle,
    TypeRegistry treg,
    SlimFormat format,
    SlimReader reader
)
public Object HandleToReference(
    MetaHandle handle,
    TypeRegistry treg,
    SlimFormat format,
    SlimReader reader
)
Public Function HandleToReference (
    handle As MetaHandle,
    treg As TypeRegistry,
    format As SlimFormat,
    reader As SlimReader
) As Object
Public Function HandleToReference (
    handle As MetaHandle,
    treg As TypeRegistry,
    format As SlimFormat,
    reader As SlimReader
) As Object
public:
Object^ HandleToReference(
    MetaHandle handle,
    TypeRegistry^ treg,
    SlimFormat^ format,
    SlimReader^ reader
)
public:
Object^ HandleToReference(
    MetaHandle handle,
    TypeRegistry^ treg,
    SlimFormat^ format,
    SlimReader^ reader
)
member HandleToReference :
        handle : MetaHandle *
        treg : TypeRegistry *
        format : SlimFormat *
        reader : SlimReader -> Object
member HandleToReference :
        handle : MetaHandle *
        treg : TypeRegistry *
        format : SlimFormat *
        reader : SlimReader -> Object

Parameters

handle
Type: NFX.IO MetaHandle
treg
Type: NFX.Serialization.Slim TypeRegistry
format
Type: NFX.IO SlimFormat
reader
Type: NFX.IO SlimReader

Return Value

Type: Online Object
See Also
RefPool Class
RefPool Members
NFX.Serialization.Slim Namespace


RefPool.Release Method

RefPool Release Method NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Release()
public void Release()
Public Sub Release
Public Sub Release
public:
void Release()
public:
void Release()
member Release : unit -> unit
member Release : unit -> unit
See Also
RefPool Class
RefPool Members
NFX.Serialization.Slim Namespace


RefPool Properties

RefPool Properties NFX Class Library

The RefPool type exposes the following members.
Properties
 | Name | Description
Public property | Count |
Public property | Fixups |
Public property | Item |
Public property | OnDeserializedCallbacks |
Back to Top
See Also
RefPool Class
NFX.Serialization.Slim Namespace


RefPool.Count Property

RefPool Count Property NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
public:
property int Count {
    int get ();
}
member Count : int with get
member Count : int with get

Property Value

Type: Online Int32
See Also
RefPool Class
RefPool Members
NFX.Serialization.Slim Namespace


RefPool.Fixups Property

RefPool Fixups Property NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<_ISerializableFixup> Fixups { get; }
public List<_ISerializableFixup> Fixups { get; }
Public ReadOnly Property Fixups As List(Of _ISerializableFixup)
    Get
Public ReadOnly Property Fixups As List(Of _ISerializableFixup)
    Get
public:
property List<_ISerializableFixup^>^ Fixups {
    List<_ISerializableFixup^>^ get ();
}
public:
property List<_ISerializableFixup^>^ Fixups {
    List<_ISerializableFixup^>^ get ();
}
member Fixups : List<_ISerializableFixup> with get
member Fixups : List<_ISerializableFixup> with get

Property Value

Type: Online List _ISerializableFixup
See Also
RefPool Class
RefPool Members
NFX.Serialization.Slim Namespace


RefPool.Item Property

RefPool Item Property NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object this[
    int i
] { get; }
public Object this[
    int i
] { get; }
Public ReadOnly Default Property Item (
    i As Integer
) As Object
    Get
Public ReadOnly Default Property Item (
    i As Integer
) As Object
    Get
public:
property Object^ default[int i] {
    Object^ get (int i);
}
public:
property Object^ default[int i] {
    Object^ get (int i);
}
member Item : Object with get
member Item : Object with get

Parameters

i
Type: Online System Int32

Property Value

Type: Online Object
See Also
RefPool Class
RefPool Members
NFX.Serialization.Slim Namespace


RefPool.OnDeserializedCallbacks Property

RefPool OnDeserializedCallbacks Property NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<_OnDeserializedCallback> OnDeserializedCallbacks { get; }
public List<_OnDeserializedCallback> OnDeserializedCallbacks { get; }
Public ReadOnly Property OnDeserializedCallbacks As List(Of _OnDeserializedCallback)
    Get
Public ReadOnly Property OnDeserializedCallbacks As List(Of _OnDeserializedCallback)
    Get
public:
property List<_OnDeserializedCallback^>^ OnDeserializedCallbacks {
    List<_OnDeserializedCallback^>^ get ();
}
public:
property List<_OnDeserializedCallback^>^ OnDeserializedCallbacks {
    List<_OnDeserializedCallback^>^ get ();
}
member OnDeserializedCallbacks : List<_OnDeserializedCallback> with get
member OnDeserializedCallbacks : List<_OnDeserializedCallback> with get

Property Value

Type: Online List _OnDeserializedCallback
See Also
RefPool Class
RefPool Members
NFX.Serialization.Slim Namespace


SlimDeserializationCtorSkipAttribute Class

SlimDeserializationCtorSkipAttribute Class NFX Class Library

When set on a parameterless constructor, instructs the Slim serializer not to invoke the ctor() on deserialization
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.Serialization.Slim SlimDeserializationCtorSkipAttribute

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.Constructor, AllowMultiple = false,
    Inherited = false)]
public class SlimDeserializationCtorSkipAttribute : Attribute
[AttributeUsageAttribute(AttributeTargets.Constructor, AllowMultiple = false,
    Inherited = false)]
public class SlimDeserializationCtorSkipAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Constructor, AllowMultiple := false,
    Inherited := false)>
Public Class SlimDeserializationCtorSkipAttribute
    Inherits Attribute
<AttributeUsageAttribute(AttributeTargets.Constructor, AllowMultiple := false,
    Inherited := false)>
Public Class SlimDeserializationCtorSkipAttribute
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Constructor, AllowMultiple = false,
    Inherited = false)]
public ref class SlimDeserializationCtorSkipAttribute : public Attribute
[AttributeUsageAttribute(AttributeTargets::Constructor, AllowMultiple = false,
    Inherited = false)]
public ref class SlimDeserializationCtorSkipAttribute : public Attribute
[<AttributeUsageAttribute(AttributeTargets.Constructor, AllowMultiple = false,
    Inherited = false)>]
type SlimDeserializationCtorSkipAttribute =
    class
        inherit Attribute
    end
[<AttributeUsageAttribute(AttributeTargets.Constructor, AllowMultiple = false,
    Inherited = false)>]
type SlimDeserializationCtorSkipAttribute =
    class
        inherit Attribute
    end
See Also
SlimDeserializationCtorSkipAttribute Members
NFX.Serialization.Slim Namespace


SlimDeserializationCtorSkipAttribute Members

SlimDeserializationCtorSkipAttribute Members NFX Class Library

[This is preliminary documentation and is subject to change.]

The SlimDeserializationCtorSkipAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | SlimDeserializationCtorSkipAttribute | Initializes a new instance of the SlimDeserializationCtorSkipAttribute class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
SlimDeserializationCtorSkipAttribute Class
NFX.Serialization.Slim Namespace


SlimDeserializationCtorSkipAttribute Constructor

SlimDeserializationCtorSkipAttribute Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SlimDeserializationCtorSkipAttribute class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SlimDeserializationCtorSkipAttribute()
public SlimDeserializationCtorSkipAttribute()
Public Sub New
Public Sub New
public:
SlimDeserializationCtorSkipAttribute()
public:
SlimDeserializationCtorSkipAttribute()
new : unit -> SlimDeserializationCtorSkipAttribute
new : unit -> SlimDeserializationCtorSkipAttribute
See Also
SlimDeserializationCtorSkipAttribute Class
SlimDeserializationCtorSkipAttribute Members
NFX.Serialization.Slim Namespace


SlimDeserializationCtorSkipAttribute Methods

SlimDeserializationCtorSkipAttribute Methods NFX Class Library

[This is preliminary documentation and is subject to change.]

The SlimDeserializationCtorSkipAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SlimDeserializationCtorSkipAttribute Class
NFX.Serialization.Slim Namespace


SlimDeserializationCtorSkipAttribute Properties

SlimDeserializationCtorSkipAttribute Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The SlimDeserializationCtorSkipAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
SlimDeserializationCtorSkipAttribute Class
NFX.Serialization.Slim Namespace


SlimDeserializationException Class

SlimDeserializationException Class NFX Class Library

Base exception thrown by the Slim when deserializing objects
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Serialization NFXSerializationException
NFX.Serialization.Slim SlimException
NFX.Serialization.Slim SlimDeserializationException

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SlimDeserializationException : SlimException
[SerializableAttribute]
public class SlimDeserializationException : SlimException
<SerializableAttribute>
Public Class SlimDeserializationException
    Inherits SlimException
<SerializableAttribute>
Public Class SlimDeserializationException
    Inherits SlimException
[SerializableAttribute]
public ref class SlimDeserializationException : public SlimException
[SerializableAttribute]
public ref class SlimDeserializationException : public SlimException
[<SerializableAttribute>]
type SlimDeserializationException =
    class
        inherit SlimException
    end
[<SerializableAttribute>]
type SlimDeserializationException =
    class
        inherit SlimException
    end
See Also
SlimDeserializationException Members
NFX.Serialization.Slim Namespace


SlimDeserializationException Members

SlimDeserializationException Members NFX Class Library

The SlimDeserializationException type exposes the following members.
Constructors
 | Name | Description
Public method | SlimDeserializationException | Initializes a new instance of the SlimDeserializationException class
Public method | SlimDeserializationException(String) | Initializes a new instance of the SlimDeserializationException class
Protected method | SlimDeserializationException(SerializationInfo, StreamingContext) | Initializes a new instance of the SlimDeserializationException class
Public method | SlimDeserializationException(String, Exception) | Initializes a new instance of the SlimDeserializationException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
SlimDeserializationException Class
NFX.Serialization.Slim Namespace


SlimDeserializationException Constructor

SlimDeserializationException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | SlimDeserializationException | Initializes a new instance of the SlimDeserializationException class
Public method | SlimDeserializationException(String) | Initializes a new instance of the SlimDeserializationException class
Protected method | SlimDeserializationException(SerializationInfo, StreamingContext) | Initializes a new instance of the SlimDeserializationException class
Public method | SlimDeserializationException(String, Exception) | Initializes a new instance of the SlimDeserializationException class
Back to Top
See Also
SlimDeserializationException Class
SlimDeserializationException Members
NFX.Serialization.Slim Namespace


SlimDeserializationException Constructor

SlimDeserializationException Constructor NFX Class Library

Initializes a new instance of the SlimDeserializationException class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SlimDeserializationException()
public SlimDeserializationException()
Public Sub New
Public Sub New
public:
SlimDeserializationException()
public:
SlimDeserializationException()
new : unit -> SlimDeserializationException
new : unit -> SlimDeserializationException
See Also
SlimDeserializationException Class
SlimDeserializationException Members
SlimDeserializationException Overload
NFX.Serialization.Slim Namespace


SlimDeserializationException Constructor (String)

SlimDeserializationException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SlimDeserializationException class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SlimDeserializationException(
    string message
)
public SlimDeserializationException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
SlimDeserializationException(
    String^ message
)
public:
SlimDeserializationException(
    String^ message
)
new :
        message : string -> SlimDeserializationException
new :
        message : string -> SlimDeserializationException

Parameters

message
Type: Online System String
See Also
SlimDeserializationException Class
SlimDeserializationException Members
SlimDeserializationException Overload
NFX.Serialization.Slim Namespace


SlimDeserializationException Constructor (SerializationInfo, StreamingContext)

SlimDeserializationException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SlimDeserializationException class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected SlimDeserializationException(
    SerializationInfo info,
    StreamingContext context
)
protected SlimDeserializationException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
SlimDeserializationException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
SlimDeserializationException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SlimDeserializationException
new :
        info : SerializationInfo *
        context : StreamingContext -> SlimDeserializationException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
SlimDeserializationException Class
SlimDeserializationException Members
SlimDeserializationException Overload
NFX.Serialization.Slim Namespace


SlimDeserializationException Constructor (String, Exception)

SlimDeserializationException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SlimDeserializationException class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SlimDeserializationException(
    string message,
    Exception inner
)
public SlimDeserializationException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
SlimDeserializationException(
    String^ message,
    Exception^ inner
)
public:
SlimDeserializationException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> SlimDeserializationException
new :
        message : string *
        inner : Exception -> SlimDeserializationException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
SlimDeserializationException Class
SlimDeserializationException Members
SlimDeserializationException Overload
NFX.Serialization.Slim Namespace


SlimDeserializationException Methods

SlimDeserializationException Methods NFX Class Library

The SlimDeserializationException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
SlimDeserializationException Class
NFX.Serialization.Slim Namespace


SlimDeserializationException Properties

SlimDeserializationException Properties NFX Class Library

The SlimDeserializationException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
SlimDeserializationException Class
NFX.Serialization.Slim Namespace


SlimDeserializationException Events

SlimDeserializationException Events NFX Class Library

The SlimDeserializationException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
SlimDeserializationException Class
NFX.Serialization.Slim Namespace


SlimException Class

SlimException Class NFX Class Library

Base exception thrown by the Slim serialization format
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Serialization NFXSerializationException
NFX.Serialization.Slim SlimException
NFX.Serialization.Slim SlimDeserializationException
NFX.Serialization.Slim SlimInvalidTypeHandleException
NFX.Serialization.Slim SlimSerializationException
NFX.Serialization.Slim SlimSerializationProhibitedException

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SlimException : NFXSerializationException
[SerializableAttribute]
public class SlimException : NFXSerializationException
<SerializableAttribute>
Public Class SlimException
    Inherits NFXSerializationException
<SerializableAttribute>
Public Class SlimException
    Inherits NFXSerializationException
[SerializableAttribute]
public ref class SlimException : public NFXSerializationException
[SerializableAttribute]
public ref class SlimException : public NFXSerializationException
[<SerializableAttribute>]
type SlimException =
    class
        inherit NFXSerializationException
    end
[<SerializableAttribute>]
type SlimException =
    class
        inherit NFXSerializationException
    end
See Also
SlimException Members
NFX.Serialization.Slim Namespace


SlimException Members

SlimException Members NFX Class Library

The SlimException type exposes the following members.
Constructors
 | Name | Description
Public method | SlimException | Initializes a new instance of the SlimException class
Public method | SlimException(String) | Initializes a new instance of the SlimException class
Protected method | SlimException(SerializationInfo, StreamingContext) | Initializes a new instance of the SlimException class
Public method | SlimException(String, Exception) | Initializes a new instance of the SlimException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
SlimException Class
NFX.Serialization.Slim Namespace


SlimException Constructor

SlimException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | SlimException | Initializes a new instance of the SlimException class
Public method | SlimException(String) | Initializes a new instance of the SlimException class
Protected method | SlimException(SerializationInfo, StreamingContext) | Initializes a new instance of the SlimException class
Public method | SlimException(String, Exception) | Initializes a new instance of the SlimException class
Back to Top
See Also
SlimException Class
SlimException Members
NFX.Serialization.Slim Namespace


SlimException Constructor

SlimException Constructor NFX Class Library

Initializes a new instance of the SlimException class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SlimException()
public SlimException()
Public Sub New
Public Sub New
public:
SlimException()
public:
SlimException()
new : unit -> SlimException
new : unit -> SlimException
See Also
SlimException Class
SlimException Members
SlimException Overload
NFX.Serialization.Slim Namespace


SlimException Constructor (String)

SlimException Constructor (String) NFX Class Library

Initializes a new instance of the SlimException class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SlimException(
    string message
)
public SlimException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
SlimException(
    String^ message
)
public:
SlimException(
    String^ message
)
new :
        message : string -> SlimException
new :
        message : string -> SlimException

Parameters

message
Type: Online System String
See Also
SlimException Class
SlimException Members
SlimException Overload
NFX.Serialization.Slim Namespace


SlimException Constructor (SerializationInfo, StreamingContext)

SlimException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SlimException class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected SlimException(
    SerializationInfo info,
    StreamingContext context
)
protected SlimException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
SlimException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
SlimException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SlimException
new :
        info : SerializationInfo *
        context : StreamingContext -> SlimException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
SlimException Class
SlimException Members
SlimException Overload
NFX.Serialization.Slim Namespace


SlimException Constructor (String, Exception)

SlimException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SlimException class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SlimException(
    string message,
    Exception inner
)
public SlimException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
SlimException(
    String^ message,
    Exception^ inner
)
public:
SlimException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> SlimException
new :
        message : string *
        inner : Exception -> SlimException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
SlimException Class
SlimException Members
SlimException Overload
NFX.Serialization.Slim Namespace


SlimException Methods

SlimException Methods NFX Class Library

The SlimException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
SlimException Class
NFX.Serialization.Slim Namespace


SlimException Properties

SlimException Properties NFX Class Library

The SlimException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
SlimException Class
NFX.Serialization.Slim Namespace


SlimException Events

SlimException Events NFX Class Library

The SlimException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
SlimException Class
NFX.Serialization.Slim Namespace


SlimInvalidTypeHandleException Class

SlimInvalidTypeHandleException Class NFX Class Library

Thrown by type registry when supplied type handle is invalid/not found
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Serialization NFXSerializationException
NFX.Serialization.Slim SlimException
NFX.Serialization.Slim SlimInvalidTypeHandleException

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SlimInvalidTypeHandleException : SlimException
[SerializableAttribute]
public class SlimInvalidTypeHandleException : SlimException
<SerializableAttribute>
Public Class SlimInvalidTypeHandleException
    Inherits SlimException
<SerializableAttribute>
Public Class SlimInvalidTypeHandleException
    Inherits SlimException
[SerializableAttribute]
public ref class SlimInvalidTypeHandleException : public SlimException
[SerializableAttribute]
public ref class SlimInvalidTypeHandleException : public SlimException
[<SerializableAttribute>]
type SlimInvalidTypeHandleException =
    class
        inherit SlimException
    end
[<SerializableAttribute>]
type SlimInvalidTypeHandleException =
    class
        inherit SlimException
    end
See Also
SlimInvalidTypeHandleException Members
NFX.Serialization.Slim Namespace


SlimInvalidTypeHandleException Members

SlimInvalidTypeHandleException Members NFX Class Library

The SlimInvalidTypeHandleException type exposes the following members.
Constructors
 | Name | Description
Public method | SlimInvalidTypeHandleException | Initializes a new instance of the SlimInvalidTypeHandleException class
Public method | SlimInvalidTypeHandleException(String) | Initializes a new instance of the SlimInvalidTypeHandleException class
Protected method | SlimInvalidTypeHandleException(SerializationInfo, StreamingContext) | Initializes a new instance of the SlimInvalidTypeHandleException class
Public method | SlimInvalidTypeHandleException(String, Exception) | Initializes a new instance of the SlimInvalidTypeHandleException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
SlimInvalidTypeHandleException Class
NFX.Serialization.Slim Namespace


SlimInvalidTypeHandleException Constructor

SlimInvalidTypeHandleException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | SlimInvalidTypeHandleException | Initializes a new instance of the SlimInvalidTypeHandleException class
Public method | SlimInvalidTypeHandleException(String) | Initializes a new instance of the SlimInvalidTypeHandleException class
Protected method | SlimInvalidTypeHandleException(SerializationInfo, StreamingContext) | Initializes a new instance of the SlimInvalidTypeHandleException class
Public method | SlimInvalidTypeHandleException(String, Exception) | Initializes a new instance of the SlimInvalidTypeHandleException class
Back to Top
See Also
SlimInvalidTypeHandleException Class
SlimInvalidTypeHandleException Members
NFX.Serialization.Slim Namespace


SlimInvalidTypeHandleException Constructor

SlimInvalidTypeHandleException Constructor NFX Class Library

Initializes a new instance of the SlimInvalidTypeHandleException class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SlimInvalidTypeHandleException()
public SlimInvalidTypeHandleException()
Public Sub New
Public Sub New
public:
SlimInvalidTypeHandleException()
public:
SlimInvalidTypeHandleException()
new : unit -> SlimInvalidTypeHandleException
new : unit -> SlimInvalidTypeHandleException
See Also
SlimInvalidTypeHandleException Class
SlimInvalidTypeHandleException Members
SlimInvalidTypeHandleException Overload
NFX.Serialization.Slim Namespace


SlimInvalidTypeHandleException Constructor (String)

SlimInvalidTypeHandleException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SlimInvalidTypeHandleException class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SlimInvalidTypeHandleException(
    string message
)
public SlimInvalidTypeHandleException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
SlimInvalidTypeHandleException(
    String^ message
)
public:
SlimInvalidTypeHandleException(
    String^ message
)
new :
        message : string -> SlimInvalidTypeHandleException
new :
        message : string -> SlimInvalidTypeHandleException

Parameters

message
Type: Online System String
See Also
SlimInvalidTypeHandleException Class
SlimInvalidTypeHandleException Members
SlimInvalidTypeHandleException Overload
NFX.Serialization.Slim Namespace


SlimInvalidTypeHandleException Constructor (SerializationInfo, StreamingContext)

SlimInvalidTypeHandleException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SlimInvalidTypeHandleException class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected SlimInvalidTypeHandleException(
    SerializationInfo info,
    StreamingContext context
)
protected SlimInvalidTypeHandleException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
SlimInvalidTypeHandleException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
SlimInvalidTypeHandleException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SlimInvalidTypeHandleException
new :
        info : SerializationInfo *
        context : StreamingContext -> SlimInvalidTypeHandleException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
SlimInvalidTypeHandleException Class
SlimInvalidTypeHandleException Members
SlimInvalidTypeHandleException Overload
NFX.Serialization.Slim Namespace


SlimInvalidTypeHandleException Constructor (String, Exception)

SlimInvalidTypeHandleException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SlimInvalidTypeHandleException class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SlimInvalidTypeHandleException(
    string message,
    Exception inner
)
public SlimInvalidTypeHandleException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
SlimInvalidTypeHandleException(
    String^ message,
    Exception^ inner
)
public:
SlimInvalidTypeHandleException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> SlimInvalidTypeHandleException
new :
        message : string *
        inner : Exception -> SlimInvalidTypeHandleException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
SlimInvalidTypeHandleException Class
SlimInvalidTypeHandleException Members
SlimInvalidTypeHandleException Overload
NFX.Serialization.Slim Namespace


SlimInvalidTypeHandleException Methods

SlimInvalidTypeHandleException Methods NFX Class Library

The SlimInvalidTypeHandleException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
SlimInvalidTypeHandleException Class
NFX.Serialization.Slim Namespace


SlimInvalidTypeHandleException Properties

SlimInvalidTypeHandleException Properties NFX Class Library

The SlimInvalidTypeHandleException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
SlimInvalidTypeHandleException Class
NFX.Serialization.Slim Namespace


SlimInvalidTypeHandleException Events

SlimInvalidTypeHandleException Events NFX Class Library

The SlimInvalidTypeHandleException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
SlimInvalidTypeHandleException Class
NFX.Serialization.Slim Namespace


SlimSerializationException Class

SlimSerializationException Class NFX Class Library

Base exception thrown by the Slim when serializing objects
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Serialization NFXSerializationException
NFX.Serialization.Slim SlimException
NFX.Serialization.Slim SlimSerializationException

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SlimSerializationException : SlimException
[SerializableAttribute]
public class SlimSerializationException : SlimException
<SerializableAttribute>
Public Class SlimSerializationException
    Inherits SlimException
<SerializableAttribute>
Public Class SlimSerializationException
    Inherits SlimException
[SerializableAttribute]
public ref class SlimSerializationException : public SlimException
[SerializableAttribute]
public ref class SlimSerializationException : public SlimException
[<SerializableAttribute>]
type SlimSerializationException =
    class
        inherit SlimException
    end
[<SerializableAttribute>]
type SlimSerializationException =
    class
        inherit SlimException
    end
See Also
SlimSerializationException Members
NFX.Serialization.Slim Namespace


SlimSerializationException Members

SlimSerializationException Members NFX Class Library

The SlimSerializationException type exposes the following members.
Constructors
 | Name | Description
Public method | SlimSerializationException | Initializes a new instance of the SlimSerializationException class
Public method | SlimSerializationException(String) | Initializes a new instance of the SlimSerializationException class
Protected method | SlimSerializationException(SerializationInfo, StreamingContext) | Initializes a new instance of the SlimSerializationException class
Public method | SlimSerializationException(String, Exception) | Initializes a new instance of the SlimSerializationException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
SlimSerializationException Class
NFX.Serialization.Slim Namespace


SlimSerializationException Constructor

SlimSerializationException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | SlimSerializationException | Initializes a new instance of the SlimSerializationException class
Public method | SlimSerializationException(String) | Initializes a new instance of the SlimSerializationException class
Protected method | SlimSerializationException(SerializationInfo, StreamingContext) | Initializes a new instance of the SlimSerializationException class
Public method | SlimSerializationException(String, Exception) | Initializes a new instance of the SlimSerializationException class
Back to Top
See Also
SlimSerializationException Class
SlimSerializationException Members
NFX.Serialization.Slim Namespace


SlimSerializationException Constructor

SlimSerializationException Constructor NFX Class Library

Initializes a new instance of the SlimSerializationException class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SlimSerializationException()
public SlimSerializationException()
Public Sub New
Public Sub New
public:
SlimSerializationException()
public:
SlimSerializationException()
new : unit -> SlimSerializationException
new : unit -> SlimSerializationException
See Also
SlimSerializationException Class
SlimSerializationException Members
SlimSerializationException Overload
NFX.Serialization.Slim Namespace


SlimSerializationException Constructor (String)

SlimSerializationException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SlimSerializationException class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SlimSerializationException(
    string message
)
public SlimSerializationException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
SlimSerializationException(
    String^ message
)
public:
SlimSerializationException(
    String^ message
)
new :
        message : string -> SlimSerializationException
new :
        message : string -> SlimSerializationException

Parameters

message
Type: Online System String
See Also
SlimSerializationException Class
SlimSerializationException Members
SlimSerializationException Overload
NFX.Serialization.Slim Namespace


SlimSerializationException Constructor (SerializationInfo, StreamingContext)

SlimSerializationException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SlimSerializationException class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected SlimSerializationException(
    SerializationInfo info,
    StreamingContext context
)
protected SlimSerializationException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
SlimSerializationException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
SlimSerializationException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SlimSerializationException
new :
        info : SerializationInfo *
        context : StreamingContext -> SlimSerializationException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
SlimSerializationException Class
SlimSerializationException Members
SlimSerializationException Overload
NFX.Serialization.Slim Namespace


SlimSerializationException Constructor (String, Exception)

SlimSerializationException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SlimSerializationException class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SlimSerializationException(
    string message,
    Exception inner
)
public SlimSerializationException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
SlimSerializationException(
    String^ message,
    Exception^ inner
)
public:
SlimSerializationException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> SlimSerializationException
new :
        message : string *
        inner : Exception -> SlimSerializationException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
SlimSerializationException Class
SlimSerializationException Members
SlimSerializationException Overload
NFX.Serialization.Slim Namespace


SlimSerializationException Methods

SlimSerializationException Methods NFX Class Library

The SlimSerializationException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
SlimSerializationException Class
NFX.Serialization.Slim Namespace


SlimSerializationException Properties

SlimSerializationException Properties NFX Class Library

The SlimSerializationException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
SlimSerializationException Class
NFX.Serialization.Slim Namespace


SlimSerializationException Events

SlimSerializationException Events NFX Class Library

The SlimSerializationException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
SlimSerializationException Class
NFX.Serialization.Slim Namespace


SlimSerializationProhibitedAttribute Class

SlimSerializationProhibitedAttribute Class NFX Class Library

When set fails an attempt to serialize the decorated type
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.Serialization.Slim SlimSerializationProhibitedAttribute

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Struct, AllowMultiple = false,
    Inherited = true)]
public class SlimSerializationProhibitedAttribute : Attribute
[AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Struct, AllowMultiple = false,
    Inherited = true)]
public class SlimSerializationProhibitedAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Class Or AttributeTargets.Struct, AllowMultiple := false,
    Inherited := true)>
Public Class SlimSerializationProhibitedAttribute
    Inherits Attribute
<AttributeUsageAttribute(AttributeTargets.Class Or AttributeTargets.Struct, AllowMultiple := false,
    Inherited := true)>
Public Class SlimSerializationProhibitedAttribute
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Class|AttributeTargets::Struct, AllowMultiple = false,
    Inherited = true)]
public ref class SlimSerializationProhibitedAttribute : public Attribute
[AttributeUsageAttribute(AttributeTargets::Class|AttributeTargets::Struct, AllowMultiple = false,
    Inherited = true)]
public ref class SlimSerializationProhibitedAttribute : public Attribute
[<AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Struct, AllowMultiple = false,
    Inherited = true)>]
type SlimSerializationProhibitedAttribute =
    class
        inherit Attribute
    end
[<AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Struct, AllowMultiple = false,
    Inherited = true)>]
type SlimSerializationProhibitedAttribute =
    class
        inherit Attribute
    end
See Also
SlimSerializationProhibitedAttribute Members
NFX.Serialization.Slim Namespace


SlimSerializationProhibitedAttribute Members

SlimSerializationProhibitedAttribute Members NFX Class Library

[This is preliminary documentation and is subject to change.]

The SlimSerializationProhibitedAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | SlimSerializationProhibitedAttribute | Initializes a new instance of the SlimSerializationProhibitedAttribute class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
SlimSerializationProhibitedAttribute Class
NFX.Serialization.Slim Namespace


SlimSerializationProhibitedAttribute Constructor

SlimSerializationProhibitedAttribute Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SlimSerializationProhibitedAttribute class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SlimSerializationProhibitedAttribute()
public SlimSerializationProhibitedAttribute()
Public Sub New
Public Sub New
public:
SlimSerializationProhibitedAttribute()
public:
SlimSerializationProhibitedAttribute()
new : unit -> SlimSerializationProhibitedAttribute
new : unit -> SlimSerializationProhibitedAttribute
See Also
SlimSerializationProhibitedAttribute Class
SlimSerializationProhibitedAttribute Members
NFX.Serialization.Slim Namespace


SlimSerializationProhibitedAttribute Methods

SlimSerializationProhibitedAttribute Methods NFX Class Library

[This is preliminary documentation and is subject to change.]

The SlimSerializationProhibitedAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SlimSerializationProhibitedAttribute Class
NFX.Serialization.Slim Namespace


SlimSerializationProhibitedAttribute Properties

SlimSerializationProhibitedAttribute Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The SlimSerializationProhibitedAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
SlimSerializationProhibitedAttribute Class
NFX.Serialization.Slim Namespace


SlimSerializationProhibitedException Class

SlimSerializationProhibitedException Class NFX Class Library

Thrown when a type is decoreted with SlimSerializationProhibitedAttribute
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Serialization NFXSerializationException
NFX.Serialization.Slim SlimException
NFX.Serialization.Slim SlimSerializationProhibitedException

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SlimSerializationProhibitedException : SlimException
[SerializableAttribute]
public class SlimSerializationProhibitedException : SlimException
<SerializableAttribute>
Public Class SlimSerializationProhibitedException
    Inherits SlimException
<SerializableAttribute>
Public Class SlimSerializationProhibitedException
    Inherits SlimException
[SerializableAttribute]
public ref class SlimSerializationProhibitedException : public SlimException
[SerializableAttribute]
public ref class SlimSerializationProhibitedException : public SlimException
[<SerializableAttribute>]
type SlimSerializationProhibitedException =
    class
        inherit SlimException
    end
[<SerializableAttribute>]
type SlimSerializationProhibitedException =
    class
        inherit SlimException
    end
See Also
SlimSerializationProhibitedException Members
NFX.Serialization.Slim Namespace


SlimSerializationProhibitedException Members

SlimSerializationProhibitedException Members NFX Class Library

[This is preliminary documentation and is subject to change.]

The SlimSerializationProhibitedException type exposes the following members.
Constructors
 | Name | Description
Protected method | SlimSerializationProhibitedException | Initializes a new instance of the SlimSerializationProhibitedException class
Public method | SlimSerializationProhibitedException(Type) | Initializes a new instance of the SlimSerializationProhibitedException class
Protected method | SlimSerializationProhibitedException(SerializationInfo, StreamingContext) | Initializes a new instance of the SlimSerializationProhibitedException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
SlimSerializationProhibitedException Class
NFX.Serialization.Slim Namespace


SlimSerializationProhibitedException Constructor

SlimSerializationProhibitedException Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Protected method | SlimSerializationProhibitedException | Initializes a new instance of the SlimSerializationProhibitedException class
Public method | SlimSerializationProhibitedException(Type) | Initializes a new instance of the SlimSerializationProhibitedException class
Protected method | SlimSerializationProhibitedException(SerializationInfo, StreamingContext) | Initializes a new instance of the SlimSerializationProhibitedException class
Back to Top
See Also
SlimSerializationProhibitedException Class
SlimSerializationProhibitedException Members
NFX.Serialization.Slim Namespace


SlimSerializationProhibitedException Constructor

SlimSerializationProhibitedException Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SlimSerializationProhibitedException class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected SlimSerializationProhibitedException()
protected SlimSerializationProhibitedException()
Protected Sub New
Protected Sub New
protected:
SlimSerializationProhibitedException()
protected:
SlimSerializationProhibitedException()
new : unit -> SlimSerializationProhibitedException
new : unit -> SlimSerializationProhibitedException
See Also
SlimSerializationProhibitedException Class
SlimSerializationProhibitedException Members
SlimSerializationProhibitedException Overload
NFX.Serialization.Slim Namespace


SlimSerializationProhibitedException Constructor (Type)

SlimSerializationProhibitedException Constructor (Type) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SlimSerializationProhibitedException class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SlimSerializationProhibitedException(
    Type type
)
public SlimSerializationProhibitedException(
    Type type
)
Public Sub New (
    type As Type
)
Public Sub New (
    type As Type
)
public:
SlimSerializationProhibitedException(
    Type^ type
)
public:
SlimSerializationProhibitedException(
    Type^ type
)
new :
        type : Type -> SlimSerializationProhibitedException
new :
        type : Type -> SlimSerializationProhibitedException

Parameters

type
Type: Online System Type
See Also
SlimSerializationProhibitedException Class
SlimSerializationProhibitedException Members
SlimSerializationProhibitedException Overload
NFX.Serialization.Slim Namespace


SlimSerializationProhibitedException Constructor (SerializationInfo, StreamingContext)

SlimSerializationProhibitedException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SlimSerializationProhibitedException class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected SlimSerializationProhibitedException(
    SerializationInfo info,
    StreamingContext context
)
protected SlimSerializationProhibitedException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
SlimSerializationProhibitedException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
SlimSerializationProhibitedException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SlimSerializationProhibitedException
new :
        info : SerializationInfo *
        context : StreamingContext -> SlimSerializationProhibitedException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
SlimSerializationProhibitedException Class
SlimSerializationProhibitedException Members
SlimSerializationProhibitedException Overload
NFX.Serialization.Slim Namespace


SlimSerializationProhibitedException Methods

SlimSerializationProhibitedException Methods NFX Class Library

[This is preliminary documentation and is subject to change.]

The SlimSerializationProhibitedException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
SlimSerializationProhibitedException Class
NFX.Serialization.Slim Namespace


SlimSerializationProhibitedException Properties

SlimSerializationProhibitedException Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The SlimSerializationProhibitedException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
SlimSerializationProhibitedException Class
NFX.Serialization.Slim Namespace


SlimSerializationProhibitedException Events

SlimSerializationProhibitedException Events NFX Class Library

[This is preliminary documentation and is subject to change.]

The SlimSerializationProhibitedException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
SlimSerializationProhibitedException Class
NFX.Serialization.Slim Namespace


SlimSerializer Class

SlimSerializer Class NFX Class Library

Implements Slim serialization algorithm that relies on an injectable SlimFormat-derivative (through .ctor) paremeter. This class was designed for highly-efficient serialization of types without versioning. SlimSerializer supports a concept of "known types" that save space by not emitting their names into stream. Performance note: This serializer yields on average 1/4 serialization and 1/2 deserialization times while compared to BinaryFormatter. Serialization of Record-instances usually takes 1/6 of BinaryFormatter time. Format takes 1/10 space for records and 1/2 for general object graphs. Such performance is achieved because of dynamic compilation of type-specific serialization/deserialization methods. This type is thread-safe for serializations/deserializations when TypeMode is set to "PerCall"
Inheritance Hierarchy
Online System Object
NFX.Serialization.Slim SlimSerializer

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SlimSerializationProhibitedAttribute]
public class SlimSerializer : ISlimSerializer,
    ISerializer
[SlimSerializationProhibitedAttribute]
public class SlimSerializer : ISlimSerializer,
    ISerializer
<SlimSerializationProhibitedAttribute>
Public Class SlimSerializer
    Implements ISlimSerializer, ISerializer
<SlimSerializationProhibitedAttribute>
Public Class SlimSerializer
    Implements ISlimSerializer, ISerializer
[SlimSerializationProhibitedAttribute]
public ref class SlimSerializer : ISlimSerializer,
    ISerializer
[SlimSerializationProhibitedAttribute]
public ref class SlimSerializer : ISlimSerializer,
    ISerializer
[<SlimSerializationProhibitedAttribute>]
type SlimSerializer =
    class
        interface ISlimSerializer
        interface ISerializer
    end
[<SlimSerializationProhibitedAttribute>]
type SlimSerializer =
    class
        interface ISlimSerializer
        interface ISerializer
    end
See Also
SlimSerializer Members
NFX.Serialization.Slim Namespace


SlimSerializer Members

SlimSerializer Members NFX Class Library

The SlimSerializer type exposes the following members.
Constructors
 | Name | Description
Public method | SlimSerializer | Initializes a new instance of the SlimSerializer class
Public method | SlimSerializer( IEnumerable Type ) | Initializes a new instance of the SlimSerializer class
Public method | SlimSerializer(SlimFormat) | Initializes a new instance of the SlimSerializer class
Public method | SlimSerializer(SlimFormat, IEnumerable Type ) | Initializes a new instance of the SlimSerializer class
Protected method | SlimSerializer(TypeRegistry, SlimFormat) | Initializes a new instance of the SlimSerializer class
Back to Top
Methods
 | Name | Description
Public method | Deserialize |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ResetCallBatch | Resets type registry to initial state (which is based on global types) for TypeMode = "Batch", otherwise does nothing. This method is not thread-safe
Public method | Serialize |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | __globalTypeRegistry |
 | HEADER |
Public field | Owner | Associates arbitrary owner object with this instance. Slim serializer does not use this field internally for any purpose
Back to Top
Properties
 | Name | Description
Public property | BatchTypeRegistry | ADVANCED FEATURE! Developers do not use. Returns type registry used in batch. This call is only valid in TypeMode = "Batch" and is inherently not thread-safe. Be careful not to mutate the returned object
Public property | BatchTypesAdded | Returns true if last call to Serialize or Deserialize in batch mode added more types to type registry. This call is only valid in TypeMode = "Batch" and is inherently not thread-safe
Public property | Format |
Public property | IsThreadSafe | Returns true when TypeMode is "PerCall"
Public property | TypeMode | Gets/sets how serializer handles type information between calls to Serialize/Deserialize. Setting this to "Batch" makes this serializer instance not thread-safe for calling Serialize/Deserialize. This property itself is not thread-safe, that is - it should be only set once by control/initiating thread
Back to Top
See Also
SlimSerializer Class
NFX.Serialization.Slim Namespace


SlimSerializer Constructor

SlimSerializer Constructor NFX Class Library

Overload List
 | Name | Description
Public method | SlimSerializer | Initializes a new instance of the SlimSerializer class
Public method | SlimSerializer( IEnumerable Type ) | Initializes a new instance of the SlimSerializer class
Public method | SlimSerializer(SlimFormat) | Initializes a new instance of the SlimSerializer class
Public method | SlimSerializer(SlimFormat, IEnumerable Type ) | Initializes a new instance of the SlimSerializer class
Protected method | SlimSerializer(TypeRegistry, SlimFormat) | Initializes a new instance of the SlimSerializer class
Back to Top
See Also
SlimSerializer Class
SlimSerializer Members
NFX.Serialization.Slim Namespace


SlimSerializer Constructor

SlimSerializer Constructor NFX Class Library

Initializes a new instance of the SlimSerializer class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SlimSerializer()
public SlimSerializer()
Public Sub New
Public Sub New
public:
SlimSerializer()
public:
SlimSerializer()
new : unit -> SlimSerializer
new : unit -> SlimSerializer
See Also
SlimSerializer Class
SlimSerializer Members
SlimSerializer Overload
NFX.Serialization.Slim Namespace


SlimSerializer Constructor (IEnumerable(Type)[])

SlimSerializer Constructor ( IEnumerable Type ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SlimSerializer class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SlimSerializer(
    params IEnumerable<Type>[] globalTypes
)
public SlimSerializer(
    params IEnumerable<Type>[] globalTypes
)
Public Sub New (
    ParamArray globalTypes As IEnumerable(Of Type)()
)
Public Sub New (
    ParamArray globalTypes As IEnumerable(Of Type)()
)
public:
SlimSerializer(
    ... array<IEnumerable<Type^>^>^ globalTypes
)
public:
SlimSerializer(
    ... array<IEnumerable<Type^>^>^ globalTypes
)
new :
        globalTypes : IEnumerable<Type>[] -> SlimSerializer
new :
        globalTypes : IEnumerable<Type>[] -> SlimSerializer

Parameters

globalTypes
Type: Online System.Collections.Generic IEnumerable Online Type
See Also
SlimSerializer Class
SlimSerializer Members
SlimSerializer Overload
NFX.Serialization.Slim Namespace


SlimSerializer Constructor (SlimFormat)

SlimSerializer Constructor (SlimFormat) NFX Class Library

Initializes a new instance of the SlimSerializer class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SlimSerializer(
    SlimFormat format
)
public SlimSerializer(
    SlimFormat format
)
Public Sub New (
    format As SlimFormat
)
Public Sub New (
    format As SlimFormat
)
public:
SlimSerializer(
    SlimFormat^ format
)
public:
SlimSerializer(
    SlimFormat^ format
)
new :
        format : SlimFormat -> SlimSerializer
new :
        format : SlimFormat -> SlimSerializer

Parameters

format
Type: NFX.IO SlimFormat
See Also
SlimSerializer Class
SlimSerializer Members
SlimSerializer Overload
NFX.Serialization.Slim Namespace


SlimSerializer Constructor (SlimFormat, IEnumerable(Type)[])

SlimSerializer Constructor (SlimFormat, IEnumerable Type ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SlimSerializer class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SlimSerializer(
    SlimFormat format,
    params IEnumerable<Type>[] globalTypes
)
public SlimSerializer(
    SlimFormat format,
    params IEnumerable<Type>[] globalTypes
)
Public Sub New (
    format As SlimFormat,
    ParamArray globalTypes As IEnumerable(Of Type)()
)
Public Sub New (
    format As SlimFormat,
    ParamArray globalTypes As IEnumerable(Of Type)()
)
public:
SlimSerializer(
    SlimFormat^ format,
    ... array<IEnumerable<Type^>^>^ globalTypes
)
public:
SlimSerializer(
    SlimFormat^ format,
    ... array<IEnumerable<Type^>^>^ globalTypes
)
new :
        format : SlimFormat *
        globalTypes : IEnumerable<Type>[] -> SlimSerializer
new :
        format : SlimFormat *
        globalTypes : IEnumerable<Type>[] -> SlimSerializer

Parameters

format
Type: NFX.IO SlimFormat
globalTypes
Type: Online System.Collections.Generic IEnumerable Online Type
See Also
SlimSerializer Class
SlimSerializer Members
SlimSerializer Overload
NFX.Serialization.Slim Namespace


SlimSerializer Constructor (TypeRegistry, SlimFormat)

SlimSerializer Constructor (TypeRegistry, SlimFormat) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SlimSerializer class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal SlimSerializer(
    TypeRegistry global,
    SlimFormat format
)
internal SlimSerializer(
    TypeRegistry global,
    SlimFormat format
)
Friend Sub New (
    global As TypeRegistry,
    format As SlimFormat
)
Friend Sub New (
    global As TypeRegistry,
    format As SlimFormat
)
internal:
SlimSerializer(
    TypeRegistry^ global,
    SlimFormat^ format
)
internal:
SlimSerializer(
    TypeRegistry^ global,
    SlimFormat^ format
)
new :
        global : TypeRegistry *
        format : SlimFormat -> SlimSerializer
new :
        global : TypeRegistry *
        format : SlimFormat -> SlimSerializer

Parameters

global
Type: NFX.Serialization.Slim TypeRegistry
format
Type: NFX.IO SlimFormat
See Also
SlimSerializer Class
SlimSerializer Members
SlimSerializer Overload
NFX.Serialization.Slim Namespace


SlimSerializer Fields

SlimSerializer Fields NFX Class Library

The SlimSerializer type exposes the following members.
Fields
 | Name | Description
Protected field | __globalTypeRegistry |
 | HEADER |
Public field | Owner | Associates arbitrary owner object with this instance. Slim serializer does not use this field internally for any purpose
Back to Top
See Also
SlimSerializer Class
NFX.Serialization.Slim Namespace


SlimSerializer.__globalTypeRegistry Field

SlimSerializer __globalTypeRegistry Field NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal readonly TypeRegistry __globalTypeRegistry
internal readonly TypeRegistry __globalTypeRegistry
Friend ReadOnly __globalTypeRegistry As TypeRegistry
Friend ReadOnly __globalTypeRegistry As TypeRegistry
internal:
initonly TypeRegistry^ __globalTypeRegistry
internal:
initonly TypeRegistry^ __globalTypeRegistry
val internal __globalTypeRegistry: TypeRegistry
val internal __globalTypeRegistry: TypeRegistry

Field Value

Type: TypeRegistry
See Also
SlimSerializer Class
SlimSerializer Members
NFX.Serialization.Slim Namespace


SlimSerializer.HEADER Field

SlimSerializer HEADER Field NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const ushort HEADER
public const ushort HEADER
Public Const HEADER As UShort
Public Const HEADER As UShort
public:
literal unsigned short HEADER
public:
literal unsigned short HEADER
static val mutable HEADER: uint16
static val mutable HEADER: uint16

Field Value

Type: Online UInt16
See Also
SlimSerializer Class
SlimSerializer Members
NFX.Serialization.Slim Namespace


SlimSerializer.Owner Field

SlimSerializer Owner Field NFX Class Library

Associates arbitrary owner object with this instance. Slim serializer does not use this field internally for any purpose

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Owner
public Object Owner
Public Owner As Object
Public Owner As Object
public:
Object^ Owner
public:
Object^ Owner
val mutable Owner: Object
val mutable Owner: Object

Field Value

Type: Online Object
See Also
SlimSerializer Class
SlimSerializer Members
NFX.Serialization.Slim Namespace


SlimSerializer Methods

SlimSerializer Methods NFX Class Library

The SlimSerializer type exposes the following members.
Methods
 | Name | Description
Public method | Deserialize |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ResetCallBatch | Resets type registry to initial state (which is based on global types) for TypeMode = "Batch", otherwise does nothing. This method is not thread-safe
Public method | Serialize |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
SlimSerializer Class
NFX.Serialization.Slim Namespace


SlimSerializer.Deserialize Method

SlimSerializer Deserialize Method NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Deserialize(
    Stream stream
)
public Object Deserialize(
    Stream stream
)
Public Function Deserialize (
    stream As Stream
) As Object
Public Function Deserialize (
    stream As Stream
) As Object
public:
virtual Object^ Deserialize(
    Stream^ stream
) sealed
public:
virtual Object^ Deserialize(
    Stream^ stream
) sealed
abstract Deserialize :
        stream : Stream -> Object
override Deserialize :
        stream : Stream -> Object
abstract Deserialize :
        stream : Stream -> Object
override Deserialize :
        stream : Stream -> Object

Parameters

stream
Type: Online System.IO Stream

Return Value

Type: Online Object

Implements

ISerializer Deserialize(Stream)
See Also
SlimSerializer Class
SlimSerializer Members
NFX.Serialization.Slim Namespace


SlimSerializer.ResetCallBatch Method

SlimSerializer ResetCallBatch Method NFX Class Library

Resets type registry to initial state (which is based on global types) for TypeMode = "Batch", otherwise does nothing. This method is not thread-safe

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ResetCallBatch()
public void ResetCallBatch()
Public Sub ResetCallBatch
Public Sub ResetCallBatch
public:
virtual void ResetCallBatch() sealed
public:
virtual void ResetCallBatch() sealed
abstract ResetCallBatch : unit -> unit
override ResetCallBatch : unit -> unit
abstract ResetCallBatch : unit -> unit
override ResetCallBatch : unit -> unit

Implements

ISlimSerializer ResetCallBatch
See Also
SlimSerializer Class
SlimSerializer Members
NFX.Serialization.Slim Namespace


SlimSerializer.Serialize Method

SlimSerializer Serialize Method NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Serialize(
    Stream stream,
    Object root
)
public void Serialize(
    Stream stream,
    Object root
)
Public Sub Serialize (
    stream As Stream,
    root As Object
)
Public Sub Serialize (
    stream As Stream,
    root As Object
)
public:
virtual void Serialize(
    Stream^ stream,
    Object^ root
) sealed
public:
virtual void Serialize(
    Stream^ stream,
    Object^ root
) sealed
abstract Serialize :
        stream : Stream *
        root : Object -> unit
override Serialize :
        stream : Stream *
        root : Object -> unit
abstract Serialize :
        stream : Stream *
        root : Object -> unit
override Serialize :
        stream : Stream *
        root : Object -> unit

Parameters

stream
Type: Online System.IO Stream
root
Type: Online System Object

Implements

ISerializer Serialize(Stream, Object)
See Also
SlimSerializer Class
SlimSerializer Members
NFX.Serialization.Slim Namespace


SlimSerializer Properties

SlimSerializer Properties NFX Class Library

The SlimSerializer type exposes the following members.
Properties
 | Name | Description
Public property | BatchTypeRegistry | ADVANCED FEATURE! Developers do not use. Returns type registry used in batch. This call is only valid in TypeMode = "Batch" and is inherently not thread-safe. Be careful not to mutate the returned object
Public property | BatchTypesAdded | Returns true if last call to Serialize or Deserialize in batch mode added more types to type registry. This call is only valid in TypeMode = "Batch" and is inherently not thread-safe
Public property | Format |
Public property | IsThreadSafe | Returns true when TypeMode is "PerCall"
Public property | TypeMode | Gets/sets how serializer handles type information between calls to Serialize/Deserialize. Setting this to "Batch" makes this serializer instance not thread-safe for calling Serialize/Deserialize. This property itself is not thread-safe, that is - it should be only set once by control/initiating thread
Back to Top
See Also
SlimSerializer Class
NFX.Serialization.Slim Namespace


SlimSerializer.BatchTypeRegistry Property

SlimSerializer BatchTypeRegistry Property NFX Class Library

ADVANCED FEATURE! Developers do not use. Returns type registry used in batch. This call is only valid in TypeMode = "Batch" and is inherently not thread-safe. Be careful not to mutate the returned object

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TypeRegistry BatchTypeRegistry { get; }
public TypeRegistry BatchTypeRegistry { get; }
Public ReadOnly Property BatchTypeRegistry As TypeRegistry
    Get
Public ReadOnly Property BatchTypeRegistry As TypeRegistry
    Get
public:
property TypeRegistry^ BatchTypeRegistry {
    TypeRegistry^ get ();
}
public:
property TypeRegistry^ BatchTypeRegistry {
    TypeRegistry^ get ();
}
member BatchTypeRegistry : TypeRegistry with get
member BatchTypeRegistry : TypeRegistry with get

Property Value

Type: TypeRegistry
See Also
SlimSerializer Class
SlimSerializer Members
NFX.Serialization.Slim Namespace


SlimSerializer.BatchTypesAdded Property

SlimSerializer BatchTypesAdded Property NFX Class Library

Returns true if last call to Serialize or Deserialize in batch mode added more types to type registry. This call is only valid in TypeMode = "Batch" and is inherently not thread-safe

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool BatchTypesAdded { get; }
public bool BatchTypesAdded { get; }
Public ReadOnly Property BatchTypesAdded As Boolean
    Get
Public ReadOnly Property BatchTypesAdded As Boolean
    Get
public:
virtual property bool BatchTypesAdded {
    bool get () sealed;
}
public:
virtual property bool BatchTypesAdded {
    bool get () sealed;
}
abstract BatchTypesAdded : bool with get
override BatchTypesAdded : bool with get
abstract BatchTypesAdded : bool with get
override BatchTypesAdded : bool with get

Property Value

Type: Online Boolean

Implements

ISlimSerializer BatchTypesAdded
See Also
SlimSerializer Class
SlimSerializer Members
NFX.Serialization.Slim Namespace


SlimSerializer.Format Property

SlimSerializer Format Property NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SlimFormat Format { get; }
public SlimFormat Format { get; }
Public ReadOnly Property Format As SlimFormat
    Get
Public ReadOnly Property Format As SlimFormat
    Get
public:
property SlimFormat^ Format {
    SlimFormat^ get ();
}
public:
property SlimFormat^ Format {
    SlimFormat^ get ();
}
member Format : SlimFormat with get
member Format : SlimFormat with get

Property Value

Type: SlimFormat
See Also
SlimSerializer Class
SlimSerializer Members
NFX.Serialization.Slim Namespace


SlimSerializer.IsThreadSafe Property

SlimSerializer IsThreadSafe Property NFX Class Library

Returns true when TypeMode is "PerCall"

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsThreadSafe { get; }
public bool IsThreadSafe { get; }
Public ReadOnly Property IsThreadSafe As Boolean
    Get
Public ReadOnly Property IsThreadSafe As Boolean
    Get
public:
virtual property bool IsThreadSafe {
    bool get () sealed;
}
public:
virtual property bool IsThreadSafe {
    bool get () sealed;
}
abstract IsThreadSafe : bool with get
override IsThreadSafe : bool with get
abstract IsThreadSafe : bool with get
override IsThreadSafe : bool with get

Property Value

Type: Online Boolean

Implements

ISerializer IsThreadSafe
See Also
SlimSerializer Class
SlimSerializer Members
NFX.Serialization.Slim Namespace


SlimSerializer.TypeMode Property

SlimSerializer TypeMode Property NFX Class Library

Gets/sets how serializer handles type information between calls to Serialize/Deserialize. Setting this to "Batch" makes this serializer instance not thread-safe for calling Serialize/Deserialize. This property itself is not thread-safe, that is - it should be only set once by control/initiating thread

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TypeRegistryMode TypeMode { get; set; }
public TypeRegistryMode TypeMode { get; set; }
Public Property TypeMode As TypeRegistryMode
    Get
    Set
Public Property TypeMode As TypeRegistryMode
    Get
    Set
public:
virtual property TypeRegistryMode TypeMode {
    TypeRegistryMode get () sealed;
    void set (TypeRegistryMode value) sealed;
}
public:
virtual property TypeRegistryMode TypeMode {
    TypeRegistryMode get () sealed;
    void set (TypeRegistryMode value) sealed;
}
abstract TypeMode : TypeRegistryMode with get, set
override TypeMode : TypeRegistryMode with get, set
abstract TypeMode : TypeRegistryMode with get, set
override TypeMode : TypeRegistryMode with get, set

Property Value

Type: TypeRegistryMode

Implements

ISlimSerializer TypeMode
See Also
SlimSerializer Class
SlimSerializer Members
NFX.Serialization.Slim Namespace


TypeDescriptor Class

TypeDescriptor Class NFX Class Library

Type descriptor dynamicaly compiles serialization/deserialization expressions for a particular type
Inheritance Hierarchy
Online System Object
NFX.Serialization.Slim TypeDescriptor

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class TypeDescriptor
internal class TypeDescriptor
Friend Class TypeDescriptor
Friend Class TypeDescriptor
internal ref class TypeDescriptor
internal ref class TypeDescriptor
type TypeDescriptor =  class end
type TypeDescriptor =  class end
See Also
TypeDescriptor Members
NFX.Serialization.Slim Namespace


TypeDescriptor Members

TypeDescriptor Members NFX Class Library

The TypeDescriptor type exposes the following members.
Constructors
 | Name | Description
Public method | TypeDescriptor | Initializes a new instance of the TypeDescriptor class
Back to Top
Methods
 | Name | Description
Public method | DeserializeInstance |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | InvokeOnDeserializedCallbak |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SerializeInstance |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | CustomIsSerializable |
Public field | Fields |
Public field | Format |
Public field | IsArray |
Public field | IsPrimitive |
Public field | IsPrimitiveArray |
Public field | Schema |
Public field | Type |
Back to Top
See Also
TypeDescriptor Class
NFX.Serialization.Slim Namespace


TypeDescriptor Constructor

TypeDescriptor Constructor NFX Class Library

Initializes a new instance of the TypeDescriptor class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TypeDescriptor(
    TypeSchema schema,
    Type type
)
public TypeDescriptor(
    TypeSchema schema,
    Type type
)
Public Sub New (
    schema As TypeSchema,
    type As Type
)
Public Sub New (
    schema As TypeSchema,
    type As Type
)
public:
TypeDescriptor(
    TypeSchema^ schema,
    Type^ type
)
public:
TypeDescriptor(
    TypeSchema^ schema,
    Type^ type
)
new :
        schema : TypeSchema *
        type : Type -> TypeDescriptor
new :
        schema : TypeSchema *
        type : Type -> TypeDescriptor

Parameters

schema
Type: NFX.Serialization.Slim TypeSchema
type
Type: Online System Type
See Also
TypeDescriptor Class
TypeDescriptor Members
NFX.Serialization.Slim Namespace


TypeDescriptor Fields

TypeDescriptor Fields NFX Class Library

The TypeDescriptor type exposes the following members.
Fields
 | Name | Description
Public field | CustomIsSerializable |
Public field | Fields |
Public field | Format |
Public field | IsArray |
Public field | IsPrimitive |
Public field | IsPrimitiveArray |
Public field | Schema |
Public field | Type |
Back to Top
See Also
TypeDescriptor Class
NFX.Serialization.Slim Namespace


TypeDescriptor.CustomIsSerializable Field

TypeDescriptor CustomIsSerializable Field NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool CustomIsSerializable
public readonly bool CustomIsSerializable
Public ReadOnly CustomIsSerializable As Boolean
Public ReadOnly CustomIsSerializable As Boolean
public:
initonly bool CustomIsSerializable
public:
initonly bool CustomIsSerializable
val CustomIsSerializable: bool
val CustomIsSerializable: bool

Field Value

Type: Online Boolean
See Also
TypeDescriptor Class
TypeDescriptor Members
NFX.Serialization.Slim Namespace


TypeDescriptor.Fields Field

TypeDescriptor Fields Field NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly FieldInfo[] Fields
public readonly FieldInfo[] Fields
Public ReadOnly Fields As FieldInfo()
Public ReadOnly Fields As FieldInfo()
public:
initonly array<FieldInfo^>^ Fields
public:
initonly array<FieldInfo^>^ Fields
val Fields: FieldInfo[]
val Fields: FieldInfo[]

Field Value

Type: Online FieldInfo
See Also
TypeDescriptor Class
TypeDescriptor Members
NFX.Serialization.Slim Namespace


TypeDescriptor.Format Field

TypeDescriptor Format Field NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly SlimFormat Format
public readonly SlimFormat Format
Public ReadOnly Format As SlimFormat
Public ReadOnly Format As SlimFormat
public:
initonly SlimFormat^ Format
public:
initonly SlimFormat^ Format
val Format: SlimFormat
val Format: SlimFormat

Field Value

Type: SlimFormat
See Also
TypeDescriptor Class
TypeDescriptor Members
NFX.Serialization.Slim Namespace


TypeDescriptor.IsArray Field

TypeDescriptor IsArray Field NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool IsArray
public readonly bool IsArray
Public ReadOnly IsArray As Boolean
Public ReadOnly IsArray As Boolean
public:
initonly bool IsArray
public:
initonly bool IsArray
val IsArray: bool
val IsArray: bool

Field Value

Type: Online Boolean
See Also
TypeDescriptor Class
TypeDescriptor Members
NFX.Serialization.Slim Namespace


TypeDescriptor.IsPrimitive Field

TypeDescriptor IsPrimitive Field NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool IsPrimitive
public readonly bool IsPrimitive
Public ReadOnly IsPrimitive As Boolean
Public ReadOnly IsPrimitive As Boolean
public:
initonly bool IsPrimitive
public:
initonly bool IsPrimitive
val IsPrimitive: bool
val IsPrimitive: bool

Field Value

Type: Online Boolean
See Also
TypeDescriptor Class
TypeDescriptor Members
NFX.Serialization.Slim Namespace


TypeDescriptor.IsPrimitiveArray Field

TypeDescriptor IsPrimitiveArray Field NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool IsPrimitiveArray
public readonly bool IsPrimitiveArray
Public ReadOnly IsPrimitiveArray As Boolean
Public ReadOnly IsPrimitiveArray As Boolean
public:
initonly bool IsPrimitiveArray
public:
initonly bool IsPrimitiveArray
val IsPrimitiveArray: bool
val IsPrimitiveArray: bool

Field Value

Type: Online Boolean
See Also
TypeDescriptor Class
TypeDescriptor Members
NFX.Serialization.Slim Namespace


TypeDescriptor.Schema Field

TypeDescriptor Schema Field NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly TypeSchema Schema
public readonly TypeSchema Schema
Public ReadOnly Schema As TypeSchema
Public ReadOnly Schema As TypeSchema
public:
initonly TypeSchema^ Schema
public:
initonly TypeSchema^ Schema
val Schema: TypeSchema
val Schema: TypeSchema

Field Value

Type: TypeSchema
See Also
TypeDescriptor Class
TypeDescriptor Members
NFX.Serialization.Slim Namespace


TypeDescriptor.Type Field

TypeDescriptor Type Field NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Type Type
public readonly Type Type
Public ReadOnly Type As Type
Public ReadOnly Type As Type
public:
initonly Type^ Type
public:
initonly Type^ Type
val Type: Type
val Type: Type

Field Value

Type: Online Type
See Also
TypeDescriptor Class
TypeDescriptor Members
NFX.Serialization.Slim Namespace


TypeDescriptor Methods

TypeDescriptor Methods NFX Class Library

The TypeDescriptor type exposes the following members.
Methods
 | Name | Description
Public method | DeserializeInstance |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | InvokeOnDeserializedCallbak |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SerializeInstance |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TypeDescriptor Class
NFX.Serialization.Slim Namespace


TypeDescriptor.DeserializeInstance Method

TypeDescriptor DeserializeInstance Method NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DeserializeInstance(
    SlimReader reader,
    TypeRegistry registry,
    RefPool refs,
    ref Object instance,
    StreamingContext streamingContext
)
public void DeserializeInstance(
    SlimReader reader,
    TypeRegistry registry,
    RefPool refs,
    ref Object instance,
    StreamingContext streamingContext
)
Public Sub DeserializeInstance (
    reader As SlimReader,
    registry As TypeRegistry,
    refs As RefPool,
    ByRef instance As Object,
    streamingContext As StreamingContext
)
Public Sub DeserializeInstance (
    reader As SlimReader,
    registry As TypeRegistry,
    refs As RefPool,
    ByRef instance As Object,
    streamingContext As StreamingContext
)
public:
void DeserializeInstance(
    SlimReader^ reader,
    TypeRegistry^ registry,
    RefPool^ refs,
    Object^% instance,
    StreamingContext streamingContext
)
public:
void DeserializeInstance(
    SlimReader^ reader,
    TypeRegistry^ registry,
    RefPool^ refs,
    Object^% instance,
    StreamingContext streamingContext
)
member DeserializeInstance :
        reader : SlimReader *
        registry : TypeRegistry *
        refs : RefPool *
        instance : Object byref *
        streamingContext : StreamingContext -> unit
member DeserializeInstance :
        reader : SlimReader *
        registry : TypeRegistry *
        refs : RefPool *
        instance : Object byref *
        streamingContext : StreamingContext -> unit

Parameters

reader
Type: NFX.IO SlimReader
registry
Type: NFX.Serialization.Slim TypeRegistry
refs
Type: NFX.Serialization.Slim RefPool
instance
Type: Online System Object
streamingContext
Type: Online System.Runtime.Serialization StreamingContext
See Also
TypeDescriptor Class
TypeDescriptor Members
NFX.Serialization.Slim Namespace


TypeDescriptor.InvokeOnDeserializedCallbak Method

TypeDescriptor InvokeOnDeserializedCallbak Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void InvokeOnDeserializedCallbak(
    Object instance,
    StreamingContext streamingContext
)
public void InvokeOnDeserializedCallbak(
    Object instance,
    StreamingContext streamingContext
)
Public Sub InvokeOnDeserializedCallbak (
    instance As Object,
    streamingContext As StreamingContext
)
Public Sub InvokeOnDeserializedCallbak (
    instance As Object,
    streamingContext As StreamingContext
)
public:
void InvokeOnDeserializedCallbak(
    Object^ instance,
    StreamingContext streamingContext
)
public:
void InvokeOnDeserializedCallbak(
    Object^ instance,
    StreamingContext streamingContext
)
member InvokeOnDeserializedCallbak :
        instance : Object *
        streamingContext : StreamingContext -> unit
member InvokeOnDeserializedCallbak :
        instance : Object *
        streamingContext : StreamingContext -> unit

Parameters

instance
Type: Online System Object
streamingContext
Type: Online System.Runtime.Serialization StreamingContext
See Also
TypeDescriptor Class
TypeDescriptor Members
NFX.Serialization.Slim Namespace


TypeDescriptor.SerializeInstance Method

TypeDescriptor SerializeInstance Method NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SerializeInstance(
    SlimWriter writer,
    TypeRegistry registry,
    RefPool refs,
    Object instance,
    StreamingContext streamingContext
)
public void SerializeInstance(
    SlimWriter writer,
    TypeRegistry registry,
    RefPool refs,
    Object instance,
    StreamingContext streamingContext
)
Public Sub SerializeInstance (
    writer As SlimWriter,
    registry As TypeRegistry,
    refs As RefPool,
    instance As Object,
    streamingContext As StreamingContext
)
Public Sub SerializeInstance (
    writer As SlimWriter,
    registry As TypeRegistry,
    refs As RefPool,
    instance As Object,
    streamingContext As StreamingContext
)
public:
void SerializeInstance(
    SlimWriter^ writer,
    TypeRegistry^ registry,
    RefPool^ refs,
    Object^ instance,
    StreamingContext streamingContext
)
public:
void SerializeInstance(
    SlimWriter^ writer,
    TypeRegistry^ registry,
    RefPool^ refs,
    Object^ instance,
    StreamingContext streamingContext
)
member SerializeInstance :
        writer : SlimWriter *
        registry : TypeRegistry *
        refs : RefPool *
        instance : Object *
        streamingContext : StreamingContext -> unit
member SerializeInstance :
        writer : SlimWriter *
        registry : TypeRegistry *
        refs : RefPool *
        instance : Object *
        streamingContext : StreamingContext -> unit

Parameters

writer
Type: NFX.IO SlimWriter
registry
Type: NFX.Serialization.Slim TypeRegistry
refs
Type: NFX.Serialization.Slim RefPool
instance
Type: Online System Object
streamingContext
Type: Online System.Runtime.Serialization StreamingContext
See Also
TypeDescriptor Class
TypeDescriptor Members
NFX.Serialization.Slim Namespace


TypeRegistry Class

TypeRegistry Class NFX Class Library

Provides a registry of types, types that do not need to be described in a serialization stream
Inheritance Hierarchy
Online System Object
NFX.Serialization.Slim TypeRegistry

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class TypeRegistry : IEnumerable<Type>,
    IEnumerable, ISerializable
[SerializableAttribute]
public class TypeRegistry : IEnumerable<Type>,
    IEnumerable, ISerializable
<SerializableAttribute>
Public Class TypeRegistry
    Implements IEnumerable(Of Type), IEnumerable,
    ISerializable
<SerializableAttribute>
Public Class TypeRegistry
    Implements IEnumerable(Of Type), IEnumerable,
    ISerializable
[SerializableAttribute]
public ref class TypeRegistry : IEnumerable<Type^>,
    IEnumerable, ISerializable
[SerializableAttribute]
public ref class TypeRegistry : IEnumerable<Type^>,
    IEnumerable, ISerializable
[<SerializableAttribute>]
type TypeRegistry =
    class
        interface IEnumerable<Type>
        interface IEnumerable
        interface ISerializable
    end
[<SerializableAttribute>]
type TypeRegistry =
    class
        interface IEnumerable<Type>
        interface IEnumerable
        interface ISerializable
    end
See Also
TypeRegistry Members
NFX.Serialization.Slim Namespace


TypeRegistry Members

TypeRegistry Members NFX Class Library

The TypeRegistry type exposes the following members.
Constructors
 | Name | Description
Public method | TypeRegistry | Initializes TypeRegistry with types from other sources
Back to Top
Methods
 | Name | Description
Public method | Add | Adds the type if it not already in registry and returns true
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeHandle | Returns a VarIntStr with the type index formatted as handle if type exists in registry, or fully qualified type name otherwise
Public method | GetTypeHandleAsString | Returns a string with the type index formatted as handle if type exists in registry, or fully qualified type name otherwise
 | IsNullHandle(String) |
 | IsNullHandle(VarIntStr) |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable Type | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct Type, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax Type, TComparand (Func Type, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax Type, TComparand (Func Type, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin Type, TComparand (Func Type, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin Type, TComparand (Func Type, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault Type | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach Type (Action Type ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach Type (Action Type, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast Type | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast Type (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
NULL_HANDLE | Denotes a special type which is object==null
STR_HNDL_POOL |
Back to Top
Properties
 | Name | Description
 | BoxedCommonNullableTypes | Returns common nullable types - use when much boxing is expected
 | BoxedCommonTypes | Returns common primitive types - use when much boxing is expected
 | CommonCollectionTypes | Returns frequently-used generic collections
Public property | Count | How many items in the registry
Public property | CSum | Returns quick checksum of type registry contents. It is updated when new types get added into the registry
 | DataAccessCRUDTypes | Returns common types for DataAccess.CRUD
 | GlueProtocolTypes | Returns Glue protocol specific types
Public property | Item String | Returns type by handle i.e. '$11' or full name. Throws in case of error
Public property | Item VarIntStr | Returns type by handle i.e. VarIntStr(1) or VarIntStr("full name"). Throws in case of error
 | PODTypes | Returns PortableObjectDocument types
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Explicit interface implemetation | ISerializable GetObjectData |
Back to Top
See Also
TypeRegistry Class
NFX.Serialization.Slim Namespace


TypeRegistry Constructor

TypeRegistry Constructor NFX Class Library

Initializes TypeRegistry with types from other sources

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TypeRegistry(
    params IEnumerable<Type>[] others
)
public TypeRegistry(
    params IEnumerable<Type>[] others
)
Public Sub New (
    ParamArray others As IEnumerable(Of Type)()
)
Public Sub New (
    ParamArray others As IEnumerable(Of Type)()
)
public:
TypeRegistry(
    ... array<IEnumerable<Type^>^>^ others
)
public:
TypeRegistry(
    ... array<IEnumerable<Type^>^>^ others
)
new :
        others : IEnumerable<Type>[] -> TypeRegistry
new :
        others : IEnumerable<Type>[] -> TypeRegistry

Parameters

others
Type: Online System.Collections.Generic IEnumerable Online Type
See Also
TypeRegistry Class
TypeRegistry Members
NFX.Serialization.Slim Namespace


TypeRegistry Fields

TypeRegistry Fields NFX Class Library

The TypeRegistry type exposes the following members.
Fields
Name | Description
NULL_HANDLE | Denotes a special type which is object==null
STR_HNDL_POOL |
Back to Top
See Also
TypeRegistry Class
NFX.Serialization.Slim Namespace


TypeRegistry.NULL_HANDLE Field

TypeRegistry NULL_HANDLE Field NFX Class Library

Denotes a special type which is object==null

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly VarIntStr NULL_HANDLE
public static readonly VarIntStr NULL_HANDLE
Public Shared ReadOnly NULL_HANDLE As VarIntStr
Public Shared ReadOnly NULL_HANDLE As VarIntStr
public:
static initonly VarIntStr NULL_HANDLE
public:
static initonly VarIntStr NULL_HANDLE
static val NULL_HANDLE: VarIntStr
static val NULL_HANDLE: VarIntStr

Field Value

Type: VarIntStr
See Also
TypeRegistry Class
TypeRegistry Members
NFX.Serialization.Slim Namespace


TypeRegistry.STR_HNDL_POOL Field

TypeRegistry STR_HNDL_POOL Field NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal static readonly string[] STR_HNDL_POOL
internal static readonly string[] STR_HNDL_POOL
Friend Shared ReadOnly STR_HNDL_POOL As String()
Friend Shared ReadOnly STR_HNDL_POOL As String()
internal:
static initonly array<String^>^ STR_HNDL_POOL
internal:
static initonly array<String^>^ STR_HNDL_POOL
static val internal STR_HNDL_POOL: string[]
static val internal STR_HNDL_POOL: string[]

Field Value

Type: Online String
See Also
TypeRegistry Class
TypeRegistry Members
NFX.Serialization.Slim Namespace


TypeRegistry Methods

TypeRegistry Methods NFX Class Library

The TypeRegistry type exposes the following members.
Methods
 | Name | Description
Public method | Add | Adds the type if it not already in registry and returns true
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | GetTypeHandle | Returns a VarIntStr with the type index formatted as handle if type exists in registry, or fully qualified type name otherwise
Public method | GetTypeHandleAsString | Returns a string with the type index formatted as handle if type exists in registry, or fully qualified type name otherwise
 | IsNullHandle(String) |
 | IsNullHandle(VarIntStr) |
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable Type | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct Type, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax Type, TComparand (Func Type, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax Type, TComparand (Func Type, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin Type, TComparand (Func Type, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin Type, TComparand (Func Type, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault Type | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach Type (Action Type ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach Type (Action Type, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast Type | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast Type (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Explicit interface implemetation | ISerializable GetObjectData |
Back to Top
See Also
TypeRegistry Class
NFX.Serialization.Slim Namespace


TypeRegistry.IEnumerable.GetEnumerator Method

TypeRegistry IEnumerable GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
TypeRegistry Class
TypeRegistry Members
NFX.Serialization.Slim Namespace


TypeRegistry.ISerializable.GetObjectData Method

TypeRegistry ISerializable GetObjectData Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ISerializable.GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
void ISerializable.GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Private Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
) Implements ISerializable.GetObjectData
Private Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
) Implements ISerializable.GetObjectData
private:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed = ISerializable::GetObjectData
private:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed = ISerializable::GetObjectData
private abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
private override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
private abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
private override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext

Implements

Online ISerializable GetObjectData(SerializationInfo, StreamingContext)
See Also
TypeRegistry Class
TypeRegistry Members
NFX.Serialization.Slim Namespace


TypeRegistry.Add Method

TypeRegistry Add Method NFX Class Library

Adds the type if it not already in registry and returns true

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Add(
    Type type
)
public bool Add(
    Type type
)
Public Function Add (
    type As Type
) As Boolean
Public Function Add (
    type As Type
) As Boolean
public:
bool Add(
    Type^ type
)
public:
bool Add(
    Type^ type
)
member Add :
        type : Type -> bool
member Add :
        type : Type -> bool

Parameters

type
Type: Online System Type

Return Value

Type: Online Boolean
See Also
TypeRegistry Class
TypeRegistry Members
NFX.Serialization.Slim Namespace


TypeRegistry.GetEnumerator Method

TypeRegistry GetEnumerator Method NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<Type> GetEnumerator()
public IEnumerator<Type> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of Type)
Public Function GetEnumerator As IEnumerator(Of Type)
public:
virtual IEnumerator<Type^>^ GetEnumerator() sealed
public:
virtual IEnumerator<Type^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<Type>
override GetEnumerator : unit -> IEnumerator<Type>
abstract GetEnumerator : unit -> IEnumerator<Type>
override GetEnumerator : unit -> IEnumerator<Type>

Return Value

Type: Online IEnumerator Online Type

Implements

Online IEnumerable T GetEnumerator
See Also
TypeRegistry Class
TypeRegistry Members
NFX.Serialization.Slim Namespace


TypeRegistry.GetTypeHandle Method

TypeRegistry GetTypeHandle Method NFX Class Library

Returns a VarIntStr with the type index formatted as handle if type exists in registry, or fully qualified type name otherwise

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public VarIntStr GetTypeHandle(
    Type type
)
public VarIntStr GetTypeHandle(
    Type type
)
Public Function GetTypeHandle (
    type As Type
) As VarIntStr
Public Function GetTypeHandle (
    type As Type
) As VarIntStr
public:
VarIntStr GetTypeHandle(
    Type^ type
)
public:
VarIntStr GetTypeHandle(
    Type^ type
)
member GetTypeHandle :
        type : Type -> VarIntStr
member GetTypeHandle :
        type : Type -> VarIntStr

Parameters

type
Type: Online System Type

Return Value

Type: VarIntStr
See Also
TypeRegistry Class
TypeRegistry Members
NFX.Serialization.Slim Namespace


TypeRegistry.GetTypeHandleAsString Method

TypeRegistry GetTypeHandleAsString Method NFX Class Library

Returns a string with the type index formatted as handle if type exists in registry, or fully qualified type name otherwise

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetTypeHandleAsString(
    Type type
)
public string GetTypeHandleAsString(
    Type type
)
Public Function GetTypeHandleAsString (
    type As Type
) As String
Public Function GetTypeHandleAsString (
    type As Type
) As String
public:
String^ GetTypeHandleAsString(
    Type^ type
)
public:
String^ GetTypeHandleAsString(
    Type^ type
)
member GetTypeHandleAsString :
        type : Type -> string
member GetTypeHandleAsString :
        type : Type -> string

Parameters

type
Type: Online System Type

Return Value

Type: Online String
See Also
TypeRegistry Class
TypeRegistry Members
NFX.Serialization.Slim Namespace


TypeRegistry.IsNullHandle Method

TypeRegistry IsNullHandle Method NFX Class Library

Overload List
Name | Description
IsNullHandle(String) |
IsNullHandle(VarIntStr) |
Back to Top
See Also
TypeRegistry Class
TypeRegistry Members
NFX.Serialization.Slim Namespace


TypeRegistry.IsNullHandle Method (String)

TypeRegistry IsNullHandle Method (String) NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsNullHandle(
    string handle
)
public static bool IsNullHandle(
    string handle
)
Public Shared Function IsNullHandle (
    handle As String
) As Boolean
Public Shared Function IsNullHandle (
    handle As String
) As Boolean
public:
static bool IsNullHandle(
    String^ handle
)
public:
static bool IsNullHandle(
    String^ handle
)
static member IsNullHandle :
        handle : string -> bool
static member IsNullHandle :
        handle : string -> bool

Parameters

handle
Type: Online System String

Return Value

Type: Online Boolean
See Also
TypeRegistry Class
TypeRegistry Members
IsNullHandle Overload
NFX.Serialization.Slim Namespace


TypeRegistry.IsNullHandle Method (VarIntStr)

TypeRegistry IsNullHandle Method (VarIntStr) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsNullHandle(
    VarIntStr handle
)
public static bool IsNullHandle(
    VarIntStr handle
)
Public Shared Function IsNullHandle (
    handle As VarIntStr
) As Boolean
Public Shared Function IsNullHandle (
    handle As VarIntStr
) As Boolean
public:
static bool IsNullHandle(
    VarIntStr handle
)
public:
static bool IsNullHandle(
    VarIntStr handle
)
static member IsNullHandle :
        handle : VarIntStr -> bool
static member IsNullHandle :
        handle : VarIntStr -> bool

Parameters

handle
Type: NFX.IO VarIntStr

Return Value

Type: Online Boolean
See Also
TypeRegistry Class
TypeRegistry Members
IsNullHandle Overload
NFX.Serialization.Slim Namespace


TypeRegistry Properties

TypeRegistry Properties NFX Class Library

The TypeRegistry type exposes the following members.
Properties
 | Name | Description
 | BoxedCommonNullableTypes | Returns common nullable types - use when much boxing is expected
 | BoxedCommonTypes | Returns common primitive types - use when much boxing is expected
 | CommonCollectionTypes | Returns frequently-used generic collections
Public property | Count | How many items in the registry
Public property | CSum | Returns quick checksum of type registry contents. It is updated when new types get added into the registry
 | DataAccessCRUDTypes | Returns common types for DataAccess.CRUD
 | GlueProtocolTypes | Returns Glue protocol specific types
Public property | Item String | Returns type by handle i.e. '$11' or full name. Throws in case of error
Public property | Item VarIntStr | Returns type by handle i.e. VarIntStr(1) or VarIntStr("full name"). Throws in case of error
 | PODTypes | Returns PortableObjectDocument types
Back to Top
See Also
TypeRegistry Class
NFX.Serialization.Slim Namespace


TypeRegistry.BoxedCommonNullableTypes Property

TypeRegistry BoxedCommonNullableTypes Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns common nullable types - use when much boxing is expected

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<Type> BoxedCommonNullableTypes { get; }
public static IEnumerable<Type> BoxedCommonNullableTypes { get; }
Public Shared ReadOnly Property BoxedCommonNullableTypes As IEnumerable(Of Type)
    Get
Public Shared ReadOnly Property BoxedCommonNullableTypes As IEnumerable(Of Type)
    Get
public:
static property IEnumerable<Type^>^ BoxedCommonNullableTypes {
    IEnumerable<Type^>^ get ();
}
public:
static property IEnumerable<Type^>^ BoxedCommonNullableTypes {
    IEnumerable<Type^>^ get ();
}
static member BoxedCommonNullableTypes : IEnumerable<Type> with get
static member BoxedCommonNullableTypes : IEnumerable<Type> with get

Property Value

Type: Online IEnumerable Online Type
See Also
TypeRegistry Class
TypeRegistry Members
NFX.Serialization.Slim Namespace


TypeRegistry.BoxedCommonTypes Property

TypeRegistry BoxedCommonTypes Property NFX Class Library

Returns common primitive types - use when much boxing is expected

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<Type> BoxedCommonTypes { get; }
public static IEnumerable<Type> BoxedCommonTypes { get; }
Public Shared ReadOnly Property BoxedCommonTypes As IEnumerable(Of Type)
    Get
Public Shared ReadOnly Property BoxedCommonTypes As IEnumerable(Of Type)
    Get
public:
static property IEnumerable<Type^>^ BoxedCommonTypes {
    IEnumerable<Type^>^ get ();
}
public:
static property IEnumerable<Type^>^ BoxedCommonTypes {
    IEnumerable<Type^>^ get ();
}
static member BoxedCommonTypes : IEnumerable<Type> with get
static member BoxedCommonTypes : IEnumerable<Type> with get

Property Value

Type: Online IEnumerable Online Type
See Also
TypeRegistry Class
TypeRegistry Members
NFX.Serialization.Slim Namespace


TypeRegistry.CommonCollectionTypes Property

TypeRegistry CommonCollectionTypes Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns frequently-used generic collections

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<Type> CommonCollectionTypes { get; }
public static IEnumerable<Type> CommonCollectionTypes { get; }
Public Shared ReadOnly Property CommonCollectionTypes As IEnumerable(Of Type)
    Get
Public Shared ReadOnly Property CommonCollectionTypes As IEnumerable(Of Type)
    Get
public:
static property IEnumerable<Type^>^ CommonCollectionTypes {
    IEnumerable<Type^>^ get ();
}
public:
static property IEnumerable<Type^>^ CommonCollectionTypes {
    IEnumerable<Type^>^ get ();
}
static member CommonCollectionTypes : IEnumerable<Type> with get
static member CommonCollectionTypes : IEnumerable<Type> with get

Property Value

Type: Online IEnumerable Online Type
See Also
TypeRegistry Class
TypeRegistry Members
NFX.Serialization.Slim Namespace


TypeRegistry.Count Property

TypeRegistry Count Property NFX Class Library

How many items in the registry

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Count { get; }
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
public:
property int Count {
    int get ();
}
member Count : int with get
member Count : int with get

Property Value

Type: Online Int32
See Also
TypeRegistry Class
TypeRegistry Members
NFX.Serialization.Slim Namespace


TypeRegistry.CSum Property

TypeRegistry CSum Property NFX Class Library

Returns quick checksum of type registry contents. It is updated when new types get added into the registry

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ulong CSum { get; }
public ulong CSum { get; }
Public ReadOnly Property CSum As ULong
    Get
Public ReadOnly Property CSum As ULong
    Get
public:
property unsigned long long CSum {
    unsigned long long get ();
}
public:
property unsigned long long CSum {
    unsigned long long get ();
}
member CSum : uint64 with get
member CSum : uint64 with get

Property Value

Type: Online UInt64
See Also
TypeRegistry Class
TypeRegistry Members
NFX.Serialization.Slim Namespace


TypeRegistry.DataAccessCRUDTypes Property

TypeRegistry DataAccessCRUDTypes Property NFX Class Library

Returns common types for DataAccess.CRUD

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<Type> DataAccessCRUDTypes { get; }
public static IEnumerable<Type> DataAccessCRUDTypes { get; }
Public Shared ReadOnly Property DataAccessCRUDTypes As IEnumerable(Of Type)
    Get
Public Shared ReadOnly Property DataAccessCRUDTypes As IEnumerable(Of Type)
    Get
public:
static property IEnumerable<Type^>^ DataAccessCRUDTypes {
    IEnumerable<Type^>^ get ();
}
public:
static property IEnumerable<Type^>^ DataAccessCRUDTypes {
    IEnumerable<Type^>^ get ();
}
static member DataAccessCRUDTypes : IEnumerable<Type> with get
static member DataAccessCRUDTypes : IEnumerable<Type> with get

Property Value

Type: Online IEnumerable Online Type
See Also
TypeRegistry Class
TypeRegistry Members
NFX.Serialization.Slim Namespace


TypeRegistry.GlueProtocolTypes Property

TypeRegistry GlueProtocolTypes Property NFX Class Library

Returns Glue protocol specific types

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<Type> GlueProtocolTypes { get; }
public static IEnumerable<Type> GlueProtocolTypes { get; }
Public Shared ReadOnly Property GlueProtocolTypes As IEnumerable(Of Type)
    Get
Public Shared ReadOnly Property GlueProtocolTypes As IEnumerable(Of Type)
    Get
public:
static property IEnumerable<Type^>^ GlueProtocolTypes {
    IEnumerable<Type^>^ get ();
}
public:
static property IEnumerable<Type^>^ GlueProtocolTypes {
    IEnumerable<Type^>^ get ();
}
static member GlueProtocolTypes : IEnumerable<Type> with get
static member GlueProtocolTypes : IEnumerable<Type> with get

Property Value

Type: Online IEnumerable Online Type
See Also
TypeRegistry Class
TypeRegistry Members
NFX.Serialization.Slim Namespace


TypeRegistry.Item Property

TypeRegistry Item Property NFX Class Library

Overload List
 | Name | Description
Public property | Item String | Returns type by handle i.e. '$11' or full name. Throws in case of error
Public property | Item VarIntStr | Returns type by handle i.e. VarIntStr(1) or VarIntStr("full name"). Throws in case of error
Back to Top
See Also
TypeRegistry Class
TypeRegistry Members
NFX.Serialization.Slim Namespace


TypeRegistry.Item Property (String)

TypeRegistry Item Property (String) NFX Class Library

Returns type by handle i.e. '$11' or full name. Throws in case of error

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Type this[
    string handle
] { get; }
public Type this[
    string handle
] { get; }
Public ReadOnly Default Property Item (
    handle As String
) As Type
    Get
Public ReadOnly Default Property Item (
    handle As String
) As Type
    Get
public:
property Type^ default[String^ handle] {
    Type^ get (String^ handle);
}
public:
property Type^ default[String^ handle] {
    Type^ get (String^ handle);
}
member Item : Type with get
member Item : Type with get

Parameters

handle
Type: Online System String

Property Value

Type: Online Type
See Also
TypeRegistry Class
TypeRegistry Members
Item Overload
NFX.Serialization.Slim Namespace


TypeRegistry.Item Property (VarIntStr)

TypeRegistry Item Property (VarIntStr) NFX Class Library

Returns type by handle i.e. VarIntStr(1) or VarIntStr("full name"). Throws in case of error

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Type this[
    VarIntStr handle
] { get; }
public Type this[
    VarIntStr handle
] { get; }
Public ReadOnly Default Property Item (
    handle As VarIntStr
) As Type
    Get
Public ReadOnly Default Property Item (
    handle As VarIntStr
) As Type
    Get
public:
property Type^ default[VarIntStr handle] {
    Type^ get (VarIntStr handle);
}
public:
property Type^ default[VarIntStr handle] {
    Type^ get (VarIntStr handle);
}
member Item : Type with get
member Item : Type with get

Parameters

handle
Type: NFX.IO VarIntStr

Property Value

Type: Online Type
See Also
TypeRegistry Class
TypeRegistry Members
Item Overload
NFX.Serialization.Slim Namespace


TypeRegistry.PODTypes Property

TypeRegistry PODTypes Property NFX Class Library

Returns PortableObjectDocument types

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<Type> PODTypes { get; }
public static IEnumerable<Type> PODTypes { get; }
Public Shared ReadOnly Property PODTypes As IEnumerable(Of Type)
    Get
Public Shared ReadOnly Property PODTypes As IEnumerable(Of Type)
    Get
public:
static property IEnumerable<Type^>^ PODTypes {
    IEnumerable<Type^>^ get ();
}
public:
static property IEnumerable<Type^>^ PODTypes {
    IEnumerable<Type^>^ get ();
}
static member PODTypes : IEnumerable<Type> with get
static member PODTypes : IEnumerable<Type> with get

Property Value

Type: Online IEnumerable Online Type
See Also
TypeRegistry Class
TypeRegistry Members
NFX.Serialization.Slim Namespace


TypeRegistryMode Enumeration

TypeRegistryMode Enumeration NFX Class Library

Denotes modes of handling type registry by Slim serializer

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum TypeRegistryMode
public enum TypeRegistryMode
Public Enumeration TypeRegistryMode
Public Enumeration TypeRegistryMode
public enum class TypeRegistryMode
public enum class TypeRegistryMode
type TypeRegistryMode
type TypeRegistryMode
Members
Member name | Value | Description
PerCall | 0 | Type registry object is created for every Serialize/Deserialize call only cloning global types. This is the default mode which is thread-safe(many threads can call Serialize/Deserialize at the same time)
Batch | 1 | Type registry object is cloned from global types only once and it is retained after making calls. This is not a thread-safe mode, so only one thread may call Serialize/Deserialize at a time. This mode is beneficial for cases when many object instances of various types need to be transmitted so repeating their type names in every Ser/Deser is not efficient. In batch mode the type name is written/read to/from stream only once, then type handles are transmitted instead thus saving space and extra allocations
See Also
NFX.Serialization.Slim Namespace


TypeSchema Class

TypeSchema Class NFX Class Library

Inheritance Hierarchy
Online System Object
NFX.Serialization.Slim TypeSchema

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class TypeSchema
internal class TypeSchema
Friend Class TypeSchema
Friend Class TypeSchema
internal ref class TypeSchema
internal ref class TypeSchema
type TypeSchema =  class end
type TypeSchema =  class end
See Also
TypeSchema Members
NFX.Serialization.Slim Namespace


TypeSchema Members

TypeSchema Members NFX Class Library

The TypeSchema type exposes the following members.
Constructors
 | Name | Description
Public method | TypeSchema | Initializes a new instance of the TypeSchema class
Back to Top
Methods
 | Name | Description
Public method | Deserialize |
Public method | DeserializeRefTypeInstance |
Public method | DeserializeRootOrInner |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | readRefMetaHandle |
Public method | Serialize |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | writeRefMetaHandle |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Format |
Back to Top
See Also
TypeSchema Class
NFX.Serialization.Slim Namespace


TypeSchema Constructor

TypeSchema Constructor NFX Class Library

Initializes a new instance of the TypeSchema class

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TypeSchema(
    SlimFormat format
)
public TypeSchema(
    SlimFormat format
)
Public Sub New (
    format As SlimFormat
)
Public Sub New (
    format As SlimFormat
)
public:
TypeSchema(
    SlimFormat^ format
)
public:
TypeSchema(
    SlimFormat^ format
)
new :
        format : SlimFormat -> TypeSchema
new :
        format : SlimFormat -> TypeSchema

Parameters

format
Type: NFX.IO SlimFormat
See Also
TypeSchema Class
TypeSchema Members
NFX.Serialization.Slim Namespace


TypeSchema Methods

TypeSchema Methods NFX Class Library

The TypeSchema type exposes the following members.
Methods
 | Name | Description
Public method | Deserialize |
Public method | DeserializeRefTypeInstance |
Public method | DeserializeRootOrInner |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | readRefMetaHandle |
Public method | Serialize |
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | writeRefMetaHandle |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
TypeSchema Class
NFX.Serialization.Slim Namespace


TypeSchema.Deserialize Method

TypeSchema Deserialize Method NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Deserialize(
    SlimReader reader,
    TypeRegistry registry,
    RefPool refs,
    StreamingContext streamingContext,
    Type valueType = null
)
public Object Deserialize(
    SlimReader reader,
    TypeRegistry registry,
    RefPool refs,
    StreamingContext streamingContext,
    Type valueType = null
)
Public Function Deserialize (
    reader As SlimReader,
    registry As TypeRegistry,
    refs As RefPool,
    streamingContext As StreamingContext,
    Optional valueType As Type = Nothing
) As Object
Public Function Deserialize (
    reader As SlimReader,
    registry As TypeRegistry,
    refs As RefPool,
    streamingContext As StreamingContext,
    Optional valueType As Type = Nothing
) As Object
public:
Object^ Deserialize(
    SlimReader^ reader,
    TypeRegistry^ registry,
    RefPool^ refs,
    StreamingContext streamingContext,
    Type^ valueType = nullptr
)
public:
Object^ Deserialize(
    SlimReader^ reader,
    TypeRegistry^ registry,
    RefPool^ refs,
    StreamingContext streamingContext,
    Type^ valueType = nullptr
)
member Deserialize :
        reader : SlimReader *
        registry : TypeRegistry *
        refs : RefPool *
        streamingContext : StreamingContext *
        ?valueType : Type
(* Defaults:
        let _valueType = defaultArg valueType null
*)
-> Object
member Deserialize :
        reader : SlimReader *
        registry : TypeRegistry *
        refs : RefPool *
        streamingContext : StreamingContext *
        ?valueType : Type
(* Defaults:
        let _valueType = defaultArg valueType null
*)
-> Object

Parameters

reader
Type: NFX.IO SlimReader
registry
Type: NFX.Serialization.Slim TypeRegistry
refs
Type: NFX.Serialization.Slim RefPool
streamingContext
Type: Online System.Runtime.Serialization StreamingContext
valueType (Optional)
Type: Online System Type

Return Value

Type: Online Object
See Also
TypeSchema Class
TypeSchema Members
NFX.Serialization.Slim Namespace


TypeSchema.DeserializeRefTypeInstance Method

TypeSchema DeserializeRefTypeInstance Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DeserializeRefTypeInstance(
    Object instance,
    SlimReader reader,
    TypeRegistry registry,
    RefPool refs,
    StreamingContext streamingContext
)
public void DeserializeRefTypeInstance(
    Object instance,
    SlimReader reader,
    TypeRegistry registry,
    RefPool refs,
    StreamingContext streamingContext
)
Public Sub DeserializeRefTypeInstance (
    instance As Object,
    reader As SlimReader,
    registry As TypeRegistry,
    refs As RefPool,
    streamingContext As StreamingContext
)
Public Sub DeserializeRefTypeInstance (
    instance As Object,
    reader As SlimReader,
    registry As TypeRegistry,
    refs As RefPool,
    streamingContext As StreamingContext
)
public:
void DeserializeRefTypeInstance(
    Object^ instance,
    SlimReader^ reader,
    TypeRegistry^ registry,
    RefPool^ refs,
    StreamingContext streamingContext
)
public:
void DeserializeRefTypeInstance(
    Object^ instance,
    SlimReader^ reader,
    TypeRegistry^ registry,
    RefPool^ refs,
    StreamingContext streamingContext
)
member DeserializeRefTypeInstance :
        instance : Object *
        reader : SlimReader *
        registry : TypeRegistry *
        refs : RefPool *
        streamingContext : StreamingContext -> unit
member DeserializeRefTypeInstance :
        instance : Object *
        reader : SlimReader *
        registry : TypeRegistry *
        refs : RefPool *
        streamingContext : StreamingContext -> unit

Parameters

instance
Type: Online System Object
reader
Type: NFX.IO SlimReader
registry
Type: NFX.Serialization.Slim TypeRegistry
refs
Type: NFX.Serialization.Slim RefPool
streamingContext
Type: Online System.Runtime.Serialization StreamingContext
See Also
TypeSchema Class
TypeSchema Members
NFX.Serialization.Slim Namespace


TypeSchema.DeserializeRootOrInner Method

TypeSchema DeserializeRootOrInner Method NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object DeserializeRootOrInner(
    SlimReader reader,
    TypeRegistry registry,
    RefPool refs,
    StreamingContext streamingContext,
    bool root,
    Type valueType = null
)
public Object DeserializeRootOrInner(
    SlimReader reader,
    TypeRegistry registry,
    RefPool refs,
    StreamingContext streamingContext,
    bool root,
    Type valueType = null
)
Public Function DeserializeRootOrInner (
    reader As SlimReader,
    registry As TypeRegistry,
    refs As RefPool,
    streamingContext As StreamingContext,
    root As Boolean,
    Optional valueType As Type = Nothing
) As Object
Public Function DeserializeRootOrInner (
    reader As SlimReader,
    registry As TypeRegistry,
    refs As RefPool,
    streamingContext As StreamingContext,
    root As Boolean,
    Optional valueType As Type = Nothing
) As Object
public:
Object^ DeserializeRootOrInner(
    SlimReader^ reader,
    TypeRegistry^ registry,
    RefPool^ refs,
    StreamingContext streamingContext,
    bool root,
    Type^ valueType = nullptr
)
public:
Object^ DeserializeRootOrInner(
    SlimReader^ reader,
    TypeRegistry^ registry,
    RefPool^ refs,
    StreamingContext streamingContext,
    bool root,
    Type^ valueType = nullptr
)
member DeserializeRootOrInner :
        reader : SlimReader *
        registry : TypeRegistry *
        refs : RefPool *
        streamingContext : StreamingContext *
        root : bool *
        ?valueType : Type
(* Defaults:
        let _valueType = defaultArg valueType null
*)
-> Object
member DeserializeRootOrInner :
        reader : SlimReader *
        registry : TypeRegistry *
        refs : RefPool *
        streamingContext : StreamingContext *
        root : bool *
        ?valueType : Type
(* Defaults:
        let _valueType = defaultArg valueType null
*)
-> Object

Parameters

reader
Type: NFX.IO SlimReader
registry
Type: NFX.Serialization.Slim TypeRegistry
refs
Type: NFX.Serialization.Slim RefPool
streamingContext
Type: Online System.Runtime.Serialization StreamingContext
root
Type: Online System Boolean
valueType (Optional)
Type: Online System Type

Return Value

Type: Online Object
See Also
TypeSchema Class
TypeSchema Members
NFX.Serialization.Slim Namespace


TypeSchema.readRefMetaHandle Method

TypeSchema readRefMetaHandle Method NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object readRefMetaHandle(
    SlimReader reader,
    TypeRegistry registry,
    RefPool refs,
    StreamingContext streamingContext
)
public Object readRefMetaHandle(
    SlimReader reader,
    TypeRegistry registry,
    RefPool refs,
    StreamingContext streamingContext
)
Public Function readRefMetaHandle (
    reader As SlimReader,
    registry As TypeRegistry,
    refs As RefPool,
    streamingContext As StreamingContext
) As Object
Public Function readRefMetaHandle (
    reader As SlimReader,
    registry As TypeRegistry,
    refs As RefPool,
    streamingContext As StreamingContext
) As Object
public:
Object^ readRefMetaHandle(
    SlimReader^ reader,
    TypeRegistry^ registry,
    RefPool^ refs,
    StreamingContext streamingContext
)
public:
Object^ readRefMetaHandle(
    SlimReader^ reader,
    TypeRegistry^ registry,
    RefPool^ refs,
    StreamingContext streamingContext
)
member readRefMetaHandle :
        reader : SlimReader *
        registry : TypeRegistry *
        refs : RefPool *
        streamingContext : StreamingContext -> Object
member readRefMetaHandle :
        reader : SlimReader *
        registry : TypeRegistry *
        refs : RefPool *
        streamingContext : StreamingContext -> Object

Parameters

reader
Type: NFX.IO SlimReader
registry
Type: NFX.Serialization.Slim TypeRegistry
refs
Type: NFX.Serialization.Slim RefPool
streamingContext
Type: Online System.Runtime.Serialization StreamingContext

Return Value

Type: Online Object
See Also
TypeSchema Class
TypeSchema Members
NFX.Serialization.Slim Namespace


TypeSchema.Serialize Method

TypeSchema Serialize Method NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Serialize(
    SlimWriter writer,
    TypeRegistry registry,
    RefPool refs,
    Object instance,
    StreamingContext streamingContext,
    Type valueType = null
)
public void Serialize(
    SlimWriter writer,
    TypeRegistry registry,
    RefPool refs,
    Object instance,
    StreamingContext streamingContext,
    Type valueType = null
)
Public Sub Serialize (
    writer As SlimWriter,
    registry As TypeRegistry,
    refs As RefPool,
    instance As Object,
    streamingContext As StreamingContext,
    Optional valueType As Type = Nothing
)
Public Sub Serialize (
    writer As SlimWriter,
    registry As TypeRegistry,
    refs As RefPool,
    instance As Object,
    streamingContext As StreamingContext,
    Optional valueType As Type = Nothing
)
public:
void Serialize(
    SlimWriter^ writer,
    TypeRegistry^ registry,
    RefPool^ refs,
    Object^ instance,
    StreamingContext streamingContext,
    Type^ valueType = nullptr
)
public:
void Serialize(
    SlimWriter^ writer,
    TypeRegistry^ registry,
    RefPool^ refs,
    Object^ instance,
    StreamingContext streamingContext,
    Type^ valueType = nullptr
)
member Serialize :
        writer : SlimWriter *
        registry : TypeRegistry *
        refs : RefPool *
        instance : Object *
        streamingContext : StreamingContext *
        ?valueType : Type
(* Defaults:
        let _valueType = defaultArg valueType null
*)
-> unit
member Serialize :
        writer : SlimWriter *
        registry : TypeRegistry *
        refs : RefPool *
        instance : Object *
        streamingContext : StreamingContext *
        ?valueType : Type
(* Defaults:
        let _valueType = defaultArg valueType null
*)
-> unit

Parameters

writer
Type: NFX.IO SlimWriter
registry
Type: NFX.Serialization.Slim TypeRegistry
refs
Type: NFX.Serialization.Slim RefPool
instance
Type: Online System Object
streamingContext
Type: Online System.Runtime.Serialization StreamingContext
valueType (Optional)
Type: Online System Type
See Also
TypeSchema Class
TypeSchema Members
NFX.Serialization.Slim Namespace


TypeSchema.writeRefMetaHandle Method

TypeSchema writeRefMetaHandle Method NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void writeRefMetaHandle(
    SlimWriter writer,
    TypeRegistry registry,
    RefPool refs,
    Object instance,
    StreamingContext streamingContext
)
public void writeRefMetaHandle(
    SlimWriter writer,
    TypeRegistry registry,
    RefPool refs,
    Object instance,
    StreamingContext streamingContext
)
Public Sub writeRefMetaHandle (
    writer As SlimWriter,
    registry As TypeRegistry,
    refs As RefPool,
    instance As Object,
    streamingContext As StreamingContext
)
Public Sub writeRefMetaHandle (
    writer As SlimWriter,
    registry As TypeRegistry,
    refs As RefPool,
    instance As Object,
    streamingContext As StreamingContext
)
public:
void writeRefMetaHandle(
    SlimWriter^ writer,
    TypeRegistry^ registry,
    RefPool^ refs,
    Object^ instance,
    StreamingContext streamingContext
)
public:
void writeRefMetaHandle(
    SlimWriter^ writer,
    TypeRegistry^ registry,
    RefPool^ refs,
    Object^ instance,
    StreamingContext streamingContext
)
member writeRefMetaHandle :
        writer : SlimWriter *
        registry : TypeRegistry *
        refs : RefPool *
        instance : Object *
        streamingContext : StreamingContext -> unit
member writeRefMetaHandle :
        writer : SlimWriter *
        registry : TypeRegistry *
        refs : RefPool *
        instance : Object *
        streamingContext : StreamingContext -> unit

Parameters

writer
Type: NFX.IO SlimWriter
registry
Type: NFX.Serialization.Slim TypeRegistry
refs
Type: NFX.Serialization.Slim RefPool
instance
Type: Online System Object
streamingContext
Type: Online System.Runtime.Serialization StreamingContext
See Also
TypeSchema Class
TypeSchema Members
NFX.Serialization.Slim Namespace


TypeSchema Properties

TypeSchema Properties NFX Class Library

The TypeSchema type exposes the following members.
Properties
 | Name | Description
Public property | Format |
Back to Top
See Also
TypeSchema Class
NFX.Serialization.Slim Namespace


TypeSchema.Format Property

TypeSchema Format Property NFX Class Library

Namespace: NFX.Serialization.Slim
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SlimFormat Format { get; }
public SlimFormat Format { get; }
Public ReadOnly Property Format As SlimFormat
    Get
Public ReadOnly Property Format As SlimFormat
    Get
public:
property SlimFormat^ Format {
    SlimFormat^ get ();
}
public:
property SlimFormat^ Format {
    SlimFormat^ get ();
}
member Format : SlimFormat with get
member Format : SlimFormat with get

Property Value

Type: SlimFormat
See Also
TypeSchema Class
TypeSchema Members
NFX.Serialization.Slim Namespace


NFX.ServiceModel Namespace

NFX.ServiceModel Namespace NFX Class Library

Provides fundamental concepts for writing in-process services
Classes
 | Class | Description
Public class | ApplicationDontAutoStartServiceAttribute | Designates service-derivative classes that should NOT be auto-started by the app container
Public class | CompositeServiceHost | Represents a service that contains other child services. Start/Stop commands translate into child sub-commands. This class is used to host other services in various job/background process hosts
Public class | Service | Represents a lightweight service that can be controlled by Start/SignalStop-like commands. This class serves a a base for various implementations (i.e. LogService) including their composites. This class is thread-safe
Public class | Service TDirector | Represents service with typed ComponentDirector property
Public class | ServiceWithInstrumentationBase TDirector | Provides base implementation for Service with IInstrumentable logic
Public class | SvcHostException | Thrown by CompositeServiceHost
Public class | WorkItemAggregatorService TContext | Aggregates same/equal (as defined by item's IAggregatableWorkItem.AggregationKey) work items posted into queue to limit the penetration of duplicate work items in destination queue
Protected class | WorkItemList TContext |
Public class | WorkQueue TContext | Maintains a queue of pending work - every WorkItem posting in the queue will be executed by the host of the queue. WorkQueues are useful for coordination of complex data/event flows in multi-threaded/service applications
Structures
 | Structure | Description
Public structure | ChildService | Child service entry as managed by CompositeServiceHost class
Interfaces
 | Interface | Description
Public interface | IAggregatableWorkItem | Represents an item that may be posted into WorkItemAggregatorService queue
Public interface | IService | Defines abstraction for an entity that is controlled by Start/Stop commands and has a status
Public interface | IWorkItem TContext | Defines a base for items executable by WorkQueue
Public interface | IWorkQueue TContext | Defines contract for work queue that work items can be posted to
Delegates
 | Delegate | Description
Public delegate | PostItemFilter TContext | A filter delegate that gets called within PostItem before adding work to this queue. This is useful for re-routing work to some other queue/s when needed. Return null if work item is going to be processed by some other queue that this delegate should post into. Keep in mind that this delegate is invoked by posters thread
Enumerations
 | Enumeration | Description
Public enumeration | ControlStatus | Stipulates control phase statuses like: Active/Inactive etc...
Public enumeration | WorkItemAggregationIntervalKind | Defines how intervals should be handled. Sliding means that every time message is posted into in queue interval starts to count from scratch, periodic counts from the first message post


ApplicationDontAutoStartServiceAttribute Class

ApplicationDontAutoStartServiceAttribute Class NFX Class Library

[This is preliminary documentation and is subject to change.]

Designates service-derivative classes that should NOT be auto-started by the app container
Inheritance Hierarchy
Online System Object
Online System Attribute
NFX.ServiceModel ApplicationDontAutoStartServiceAttribute

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false, Inherited = false)]
public class ApplicationDontAutoStartServiceAttribute : Attribute
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false, Inherited = false)]
public class ApplicationDontAutoStartServiceAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := false, Inherited := false)>
Public Class ApplicationDontAutoStartServiceAttribute
    Inherits Attribute
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := false, Inherited := false)>
Public Class ApplicationDontAutoStartServiceAttribute
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = false, Inherited = false)]
public ref class ApplicationDontAutoStartServiceAttribute : public Attribute
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = false, Inherited = false)]
public ref class ApplicationDontAutoStartServiceAttribute : public Attribute
[<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false, Inherited = false)>]
type ApplicationDontAutoStartServiceAttribute =
    class
        inherit Attribute
    end
[<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false, Inherited = false)>]
type ApplicationDontAutoStartServiceAttribute =
    class
        inherit Attribute
    end
See Also
ApplicationDontAutoStartServiceAttribute Members
NFX.ServiceModel Namespace


ApplicationDontAutoStartServiceAttribute Members

ApplicationDontAutoStartServiceAttribute Members NFX Class Library

[This is preliminary documentation and is subject to change.]

The ApplicationDontAutoStartServiceAttribute type exposes the following members.
Constructors
 | Name | Description
Public method | ApplicationDontAutoStartServiceAttribute | Initializes a new instance of the ApplicationDontAutoStartServiceAttribute class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
ApplicationDontAutoStartServiceAttribute Class
NFX.ServiceModel Namespace


ApplicationDontAutoStartServiceAttribute Constructor

ApplicationDontAutoStartServiceAttribute Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ApplicationDontAutoStartServiceAttribute class

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ApplicationDontAutoStartServiceAttribute()
public ApplicationDontAutoStartServiceAttribute()
Public Sub New
Public Sub New
public:
ApplicationDontAutoStartServiceAttribute()
public:
ApplicationDontAutoStartServiceAttribute()
new : unit -> ApplicationDontAutoStartServiceAttribute
new : unit -> ApplicationDontAutoStartServiceAttribute
See Also
ApplicationDontAutoStartServiceAttribute Class
ApplicationDontAutoStartServiceAttribute Members
NFX.ServiceModel Namespace


ApplicationDontAutoStartServiceAttribute Methods

ApplicationDontAutoStartServiceAttribute Methods NFX Class Library

[This is preliminary documentation and is subject to change.]

The ApplicationDontAutoStartServiceAttribute type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Online Attribute.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online Attribute.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | Online IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Online Attribute.)
Public method | Online Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Online Attribute.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ApplicationDontAutoStartServiceAttribute Class
NFX.ServiceModel Namespace


ApplicationDontAutoStartServiceAttribute Properties

ApplicationDontAutoStartServiceAttribute Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The ApplicationDontAutoStartServiceAttribute type exposes the following members.
Properties
 | Name | Description
Public property | Online TypeId | When implemented in a derived class, gets a unique identifier for this Online Attribute. (Inherited from Online Attribute.)
Back to Top
See Also
ApplicationDontAutoStartServiceAttribute Class
NFX.ServiceModel Namespace


ChildService Structure

ChildService Structure NFX Class Library

Child service entry as managed by CompositeServiceHost class

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct ChildService : INamed,
    IOrdered
public struct ChildService : INamed,
    IOrdered
Public Structure ChildService
    Implements INamed, IOrdered
Public Structure ChildService
    Implements INamed, IOrdered
public value class ChildService : INamed,
    IOrdered
public value class ChildService : INamed,
    IOrdered
[<SealedAttribute>]
type ChildService =
    struct
        interface INamed
        interface IOrdered
    end
[<SealedAttribute>]
type ChildService =
    struct
        interface INamed
        interface IOrdered
    end
See Also
ChildService Members
NFX.ServiceModel Namespace


ChildService Members

ChildService Members NFX Class Library

The ChildService type exposes the following members.
Constructors
 | Name | Description
Public method | ChildService | Initializes a new instance of the ChildService class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | AbortStart |
Public property | Name |
Public property | Order |
Public property | Service |
Back to Top
See Also
ChildService Structure
NFX.ServiceModel Namespace


ChildService Constructor

ChildService Constructor NFX Class Library

Initializes a new instance of the ChildService class

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ChildService(
    Service svc,
    int order,
    bool abortStart
)
public ChildService(
    Service svc,
    int order,
    bool abortStart
)
Public Sub New (
    svc As Service,
    order As Integer,
    abortStart As Boolean
)
Public Sub New (
    svc As Service,
    order As Integer,
    abortStart As Boolean
)
public:
ChildService(
    Service^ svc,
    int order,
    bool abortStart
)
public:
ChildService(
    Service^ svc,
    int order,
    bool abortStart
)
new :
        svc : Service *
        order : int *
        abortStart : bool -> ChildService
new :
        svc : Service *
        order : int *
        abortStart : bool -> ChildService

Parameters

svc
Type: NFX.ServiceModel Service
order
Type: Online System Int32
abortStart
Type: Online System Boolean
See Also
ChildService Structure
ChildService Members
NFX.ServiceModel Namespace


ChildService Methods

ChildService Methods NFX Class Library

The ChildService type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online ValueType ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ChildService Structure
NFX.ServiceModel Namespace


ChildService.ToString Method

ChildService ToString Method NFX Class Library

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
ChildService Structure
ChildService Members
NFX.ServiceModel Namespace


ChildService Properties

ChildService Properties NFX Class Library

The ChildService type exposes the following members.
Properties
 | Name | Description
Public property | AbortStart |
Public property | Name |
Public property | Order |
Public property | Service |
Back to Top
See Also
ChildService Structure
NFX.ServiceModel Namespace


ChildService.AbortStart Property

ChildService AbortStart Property NFX Class Library

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool AbortStart { get; }
public bool AbortStart { get; }
Public ReadOnly Property AbortStart As Boolean
    Get
Public ReadOnly Property AbortStart As Boolean
    Get
public:
property bool AbortStart {
    bool get ();
}
public:
property bool AbortStart {
    bool get ();
}
member AbortStart : bool with get
member AbortStart : bool with get

Property Value

Type: Online Boolean
See Also
ChildService Structure
ChildService Members
NFX.ServiceModel Namespace


ChildService.Name Property

ChildService Name Property NFX Class Library

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; }
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get
abstract Name : string with get
override Name : string with get

Property Value

Type: Online String

Implements

INamed Name
See Also
ChildService Structure
ChildService Members
NFX.ServiceModel Namespace


ChildService.Order Property

ChildService Order Property NFX Class Library

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Order { get; }
public int Order { get; }
Public ReadOnly Property Order As Integer
    Get
Public ReadOnly Property Order As Integer
    Get
public:
virtual property int Order {
    int get () sealed;
}
public:
virtual property int Order {
    int get () sealed;
}
abstract Order : int with get
override Order : int with get
abstract Order : int with get
override Order : int with get

Property Value

Type: Online Int32

Implements

IOrdered Order
See Also
ChildService Structure
ChildService Members
NFX.ServiceModel Namespace


ChildService.Service Property

ChildService Service Property NFX Class Library

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Service Service { get; }
public Service Service { get; }
Public ReadOnly Property Service As Service
    Get
Public ReadOnly Property Service As Service
    Get
public:
property Service^ Service {
    Service^ get ();
}
public:
property Service^ Service {
    Service^ get ();
}
member Service : Service with get
member Service : Service with get

Property Value

Type: Service
See Also
ChildService Structure
ChildService Members
NFX.ServiceModel Namespace


CompositeServiceHost Class

CompositeServiceHost Class NFX Class Library

Represents a service that contains other child services. Start/Stop commands translate into child sub-commands. This class is used to host other services in various job/background process hosts
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel CompositeServiceHost

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CompositeServiceHost : Service
public class CompositeServiceHost : Service
Public Class CompositeServiceHost
    Inherits Service
Public Class CompositeServiceHost
    Inherits Service
public ref class CompositeServiceHost : public Service
public ref class CompositeServiceHost : public Service
type CompositeServiceHost =
    class
        inherit Service
    end
type CompositeServiceHost =
    class
        inherit Service
    end
See Also
CompositeServiceHost Members
NFX.ServiceModel Namespace


CompositeServiceHost Members

CompositeServiceHost Members NFX Class Library

The CompositeServiceHost type exposes the following members.
Constructors
 | Name | Description
Public method | CompositeServiceHost | Initializes a new instance of the CompositeServiceHost class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | (Overrides Service DoAcceptManagerVisit(Object, DateTime).)
Protected method | DoCheckForCompleteStop | (Overrides Service DoCheckForCompleteStop .)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegisterService | Returns true if child service was registered, false if it was already registered prior tp this call. The method may only be called on stopped (this) service
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | UnregisterService | Returns true if child service was unregistered, false if it did not exist. The method may only be called on stopped (this) service
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_ABORT_START_ATTR |
CONFIG_SERVICE_HOST_SECTION |
CONFIG_SERVICE_SECTION |
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ChildServices | Returns service registry where services can be looked-up by name
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | OrderedChildServices | Returns services ordered by their order property
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
CompositeServiceHost Class
NFX.ServiceModel Namespace


CompositeServiceHost Constructor

CompositeServiceHost Constructor NFX Class Library

Initializes a new instance of the CompositeServiceHost class

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CompositeServiceHost(
    Object director
)
public CompositeServiceHost(
    Object director
)
Public Sub New (
    director As Object
)
Public Sub New (
    director As Object
)
public:
CompositeServiceHost(
    Object^ director
)
public:
CompositeServiceHost(
    Object^ director
)
new :
        director : Object -> CompositeServiceHost
new :
        director : Object -> CompositeServiceHost

Parameters

director
Type: Online System Object
See Also
CompositeServiceHost Class
CompositeServiceHost Members
NFX.ServiceModel Namespace


CompositeServiceHost Fields

CompositeServiceHost Fields NFX Class Library

The CompositeServiceHost type exposes the following members.
Fields
Name | Description
CONFIG_ABORT_START_ATTR |
CONFIG_SERVICE_HOST_SECTION |
CONFIG_SERVICE_SECTION |
Back to Top
See Also
CompositeServiceHost Class
NFX.ServiceModel Namespace


CompositeServiceHost.CONFIG_ABORT_START_ATTR Field

CompositeServiceHost CONFIG_ABORT_START_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_ABORT_START_ATTR
public const string CONFIG_ABORT_START_ATTR
Public Const CONFIG_ABORT_START_ATTR As String
Public Const CONFIG_ABORT_START_ATTR As String
public:
literal String^ CONFIG_ABORT_START_ATTR
public:
literal String^ CONFIG_ABORT_START_ATTR
static val mutable CONFIG_ABORT_START_ATTR: string
static val mutable CONFIG_ABORT_START_ATTR: string

Field Value

Type: Online String
See Also
CompositeServiceHost Class
CompositeServiceHost Members
NFX.ServiceModel Namespace


CompositeServiceHost.CONFIG_SERVICE_HOST_SECTION Field

CompositeServiceHost CONFIG_SERVICE_HOST_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SERVICE_HOST_SECTION
public const string CONFIG_SERVICE_HOST_SECTION
Public Const CONFIG_SERVICE_HOST_SECTION As String
Public Const CONFIG_SERVICE_HOST_SECTION As String
public:
literal String^ CONFIG_SERVICE_HOST_SECTION
public:
literal String^ CONFIG_SERVICE_HOST_SECTION
static val mutable CONFIG_SERVICE_HOST_SECTION: string
static val mutable CONFIG_SERVICE_HOST_SECTION: string

Field Value

Type: Online String
See Also
CompositeServiceHost Class
CompositeServiceHost Members
NFX.ServiceModel Namespace


CompositeServiceHost.CONFIG_SERVICE_SECTION Field

CompositeServiceHost CONFIG_SERVICE_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SERVICE_SECTION
public const string CONFIG_SERVICE_SECTION
Public Const CONFIG_SERVICE_SECTION As String
Public Const CONFIG_SERVICE_SECTION As String
public:
literal String^ CONFIG_SERVICE_SECTION
public:
literal String^ CONFIG_SERVICE_SECTION
static val mutable CONFIG_SERVICE_SECTION: string
static val mutable CONFIG_SERVICE_SECTION: string

Field Value

Type: Online String
See Also
CompositeServiceHost Class
CompositeServiceHost Members
NFX.ServiceModel Namespace


CompositeServiceHost Methods

CompositeServiceHost Methods NFX Class Library

The CompositeServiceHost type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | (Overrides Service DoAcceptManagerVisit(Object, DateTime).)
Protected method | DoCheckForCompleteStop | (Overrides Service DoCheckForCompleteStop .)
Protected method | DoConfigure | (Overrides Service DoConfigure(IConfigSectionNode).)
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | RegisterService | Returns true if child service was registered, false if it was already registered prior tp this call. The method may only be called on stopped (this) service
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | UnregisterService | Returns true if child service was unregistered, false if it did not exist. The method may only be called on stopped (this) service
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CompositeServiceHost Class
NFX.ServiceModel Namespace


CompositeServiceHost.DoAcceptManagerVisit Method

CompositeServiceHost DoAcceptManagerVisit Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoAcceptManagerVisit(
    Object manager,
    DateTime managerNow
)
protected override void DoAcceptManagerVisit(
    Object manager,
    DateTime managerNow
)
Protected Overrides Sub DoAcceptManagerVisit (
    manager As Object,
    managerNow As DateTime
)
Protected Overrides Sub DoAcceptManagerVisit (
    manager As Object,
    managerNow As DateTime
)
protected:
virtual void DoAcceptManagerVisit(
    Object^ manager,
    DateTime managerNow
) override
protected:
virtual void DoAcceptManagerVisit(
    Object^ manager,
    DateTime managerNow
) override
abstract DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit
override DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit
abstract DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit
override DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit

Parameters

manager
Type: Online System Object
managerNow
Type: Online System DateTime
See Also
CompositeServiceHost Class
CompositeServiceHost Members
NFX.ServiceModel Namespace


CompositeServiceHost.DoCheckForCompleteStop Method

CompositeServiceHost DoCheckForCompleteStop Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override bool DoCheckForCompleteStop()
protected override bool DoCheckForCompleteStop()
Protected Overrides Function DoCheckForCompleteStop As Boolean
Protected Overrides Function DoCheckForCompleteStop As Boolean
protected:
virtual bool DoCheckForCompleteStop() override
protected:
virtual bool DoCheckForCompleteStop() override
abstract DoCheckForCompleteStop : unit -> bool
override DoCheckForCompleteStop : unit -> bool
abstract DoCheckForCompleteStop : unit -> bool
override DoCheckForCompleteStop : unit -> bool

Return Value

Type: Online Boolean
See Also
CompositeServiceHost Class
CompositeServiceHost Members
NFX.ServiceModel Namespace


CompositeServiceHost.DoConfigure Method

CompositeServiceHost DoConfigure Method NFX Class Library

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoConfigure(
    IConfigSectionNode node
)
protected override void DoConfigure(
    IConfigSectionNode node
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overrides Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
) override
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
CompositeServiceHost Class
CompositeServiceHost Members
NFX.ServiceModel Namespace


CompositeServiceHost.DoSignalStop Method

CompositeServiceHost DoSignalStop Method NFX Class Library

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSignalStop()
protected override void DoSignalStop()
Protected Overrides Sub DoSignalStop
Protected Overrides Sub DoSignalStop
protected:
virtual void DoSignalStop() override
protected:
virtual void DoSignalStop() override
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
See Also
CompositeServiceHost Class
CompositeServiceHost Members
NFX.ServiceModel Namespace


CompositeServiceHost.DoStart Method

CompositeServiceHost DoStart Method NFX Class Library

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
CompositeServiceHost Class
CompositeServiceHost Members
NFX.ServiceModel Namespace


CompositeServiceHost.DoWaitForCompleteStop Method

CompositeServiceHost DoWaitForCompleteStop Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
CompositeServiceHost Class
CompositeServiceHost Members
NFX.ServiceModel Namespace


CompositeServiceHost.RegisterService Method

CompositeServiceHost RegisterService Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns true if child service was registered, false if it was already registered prior tp this call. The method may only be called on stopped (this) service

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool RegisterService(
    Service service,
    int order,
    bool abortStart
)
public bool RegisterService(
    Service service,
    int order,
    bool abortStart
)
Public Function RegisterService (
    service As Service,
    order As Integer,
    abortStart As Boolean
) As Boolean
Public Function RegisterService (
    service As Service,
    order As Integer,
    abortStart As Boolean
) As Boolean
public:
bool RegisterService(
    Service^ service,
    int order,
    bool abortStart
)
public:
bool RegisterService(
    Service^ service,
    int order,
    bool abortStart
)
member RegisterService :
        service : Service *
        order : int *
        abortStart : bool -> bool
member RegisterService :
        service : Service *
        order : int *
        abortStart : bool -> bool

Parameters

service
Type: NFX.ServiceModel Service
order
Type: Online System Int32
abortStart
Type: Online System Boolean

Return Value

Type: Online Boolean
See Also
CompositeServiceHost Class
CompositeServiceHost Members
NFX.ServiceModel Namespace


CompositeServiceHost.UnregisterService Method

CompositeServiceHost UnregisterService Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns true if child service was unregistered, false if it did not exist. The method may only be called on stopped (this) service

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool UnregisterService(
    Service service
)
public bool UnregisterService(
    Service service
)
Public Function UnregisterService (
    service As Service
) As Boolean
Public Function UnregisterService (
    service As Service
) As Boolean
public:
bool UnregisterService(
    Service^ service
)
public:
bool UnregisterService(
    Service^ service
)
member UnregisterService :
        service : Service -> bool
member UnregisterService :
        service : Service -> bool

Parameters

service
Type: NFX.ServiceModel Service

Return Value

Type: Online Boolean
See Also
CompositeServiceHost Class
CompositeServiceHost Members
NFX.ServiceModel Namespace


CompositeServiceHost Properties

CompositeServiceHost Properties NFX Class Library

The CompositeServiceHost type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ChildServices | Returns service registry where services can be looked-up by name
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | OrderedChildServices | Returns services ordered by their order property
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
CompositeServiceHost Class
NFX.ServiceModel Namespace


CompositeServiceHost.ChildServices Property

CompositeServiceHost ChildServices Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns service registry where services can be looked-up by name

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IRegistry<ChildService> ChildServices { get; }
public IRegistry<ChildService> ChildServices { get; }
Public ReadOnly Property ChildServices As IRegistry(Of ChildService)
    Get
Public ReadOnly Property ChildServices As IRegistry(Of ChildService)
    Get
public:
property IRegistry<ChildService>^ ChildServices {
    IRegistry<ChildService>^ get ();
}
public:
property IRegistry<ChildService>^ ChildServices {
    IRegistry<ChildService>^ get ();
}
member ChildServices : IRegistry<ChildService> with get
member ChildServices : IRegistry<ChildService> with get

Property Value

Type: IRegistry ChildService
See Also
CompositeServiceHost Class
CompositeServiceHost Members
NFX.ServiceModel Namespace


CompositeServiceHost.OrderedChildServices Property

CompositeServiceHost OrderedChildServices Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns services ordered by their order property

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<ChildService> OrderedChildServices { get; }
public IEnumerable<ChildService> OrderedChildServices { get; }
Public ReadOnly Property OrderedChildServices As IEnumerable(Of ChildService)
    Get
Public ReadOnly Property OrderedChildServices As IEnumerable(Of ChildService)
    Get
public:
property IEnumerable<ChildService>^ OrderedChildServices {
    IEnumerable<ChildService>^ get ();
}
public:
property IEnumerable<ChildService>^ OrderedChildServices {
    IEnumerable<ChildService>^ get ();
}
member OrderedChildServices : IEnumerable<ChildService> with get
member OrderedChildServices : IEnumerable<ChildService> with get

Property Value

Type: Online IEnumerable ChildService
See Also
CompositeServiceHost Class
CompositeServiceHost Members
NFX.ServiceModel Namespace


ControlStatus Enumeration

ControlStatus Enumeration NFX Class Library

Stipulates control phase statuses like: Active/Inactive etc...

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum ControlStatus
public enum ControlStatus
Public Enumeration ControlStatus
Public Enumeration ControlStatus
public enum class ControlStatus
public enum class ControlStatus
type ControlStatus
type ControlStatus
Members
Member name | Value | Description
Inactive | 0 |
Starting | 1 |
AbortingStart | 2 |
Active | 3 |
Stopping | 4 |
See Also
NFX.ServiceModel Namespace


IAggregatableWorkItem Interface

IAggregatableWorkItem Interface NFX Class Library

Represents an item that may be posted into WorkItemAggregatorService queue

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IAggregatableWorkItem
public interface IAggregatableWorkItem
Public Interface IAggregatableWorkItem
Public Interface IAggregatableWorkItem
public interface class IAggregatableWorkItem
public interface class IAggregatableWorkItem
type IAggregatableWorkItem =  interface end
type IAggregatableWorkItem =  interface end
See Also
IAggregatableWorkItem Members
NFX.ServiceModel Namespace


IAggregatableWorkItem Members

IAggregatableWorkItem Members NFX Class Library

The IAggregatableWorkItem type exposes the following members.
Properties
 | Name | Description
Public property | AggregationIntervalKind |
Public property | AggregationKey |
Back to Top
See Also
IAggregatableWorkItem Interface
NFX.ServiceModel Namespace


IAggregatableWorkItem Properties

IAggregatableWorkItem Properties NFX Class Library

The IAggregatableWorkItem type exposes the following members.
Properties
 | Name | Description
Public property | AggregationIntervalKind |
Public property | AggregationKey |
Back to Top
See Also
IAggregatableWorkItem Interface
NFX.ServiceModel Namespace


IAggregatableWorkItem.AggregationIntervalKind Property

IAggregatableWorkItem AggregationIntervalKind Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
WorkItemAggregationIntervalKind AggregationIntervalKind { get; }
WorkItemAggregationIntervalKind AggregationIntervalKind { get; }
ReadOnly Property AggregationIntervalKind As WorkItemAggregationIntervalKind
    Get
ReadOnly Property AggregationIntervalKind As WorkItemAggregationIntervalKind
    Get
property WorkItemAggregationIntervalKind AggregationIntervalKind {
    WorkItemAggregationIntervalKind get ();
}
property WorkItemAggregationIntervalKind AggregationIntervalKind {
    WorkItemAggregationIntervalKind get ();
}
abstract AggregationIntervalKind : WorkItemAggregationIntervalKind with get
abstract AggregationIntervalKind : WorkItemAggregationIntervalKind with get

Property Value

Type: WorkItemAggregationIntervalKind
See Also
IAggregatableWorkItem Interface
IAggregatableWorkItem Members
NFX.ServiceModel Namespace


IAggregatableWorkItem.AggregationKey Property

IAggregatableWorkItem AggregationKey Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object AggregationKey { get; }
Object AggregationKey { get; }
ReadOnly Property AggregationKey As Object
    Get
ReadOnly Property AggregationKey As Object
    Get
property Object^ AggregationKey {
    Object^ get ();
}
property Object^ AggregationKey {
    Object^ get ();
}
abstract AggregationKey : Object with get
abstract AggregationKey : Object with get

Property Value

Type: Online Object
See Also
IAggregatableWorkItem Interface
IAggregatableWorkItem Members
NFX.ServiceModel Namespace


IService Interface

IService Interface NFX Class Library

Defines abstraction for an entity that is controlled by Start/Stop commands and has a status

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IService : INamed,
    IConfigurable
public interface IService : INamed,
    IConfigurable
Public Interface IService
    Inherits INamed, IConfigurable
Public Interface IService
    Inherits INamed, IConfigurable
public interface class IService : INamed,
    IConfigurable
public interface class IService : INamed,
    IConfigurable
type IService =
    interface
        interface INamed
        interface IConfigurable
    end
type IService =
    interface
        interface INamed
        interface IConfigurable
    end
See Also
IService Members
NFX.ServiceModel Namespace


IService Members

IService Members NFX Class Library

The IService type exposes the following members.
Methods
 | Name | Description
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop()
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service
Public method | Start | Blocking call that starts the service instance
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped
Back to Top
Properties
 | Name | Description
Public property | Name | (Inherited from INamed.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks
Public property | Status | Current service status
Back to Top
See Also
IService Interface
NFX.ServiceModel Namespace


IService Methods

IService Methods NFX Class Library

The IService type exposes the following members.
Methods
 | Name | Description
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop()
Public method | Configure | Configures an entity from supplied config node (Inherited from IConfigurable.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service
Public method | Start | Blocking call that starts the service instance
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped
Back to Top
See Also
IService Interface
NFX.ServiceModel Namespace


IService.CheckForCompleteStop Method

IService CheckForCompleteStop Method NFX Class Library

Non-blocking call that returns true when the service instance has completely stopped after SignalStop()

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool CheckForCompleteStop()
bool CheckForCompleteStop()
Function CheckForCompleteStop As Boolean
Function CheckForCompleteStop As Boolean
bool CheckForCompleteStop()
bool CheckForCompleteStop()
abstract CheckForCompleteStop : unit -> bool
abstract CheckForCompleteStop : unit -> bool

Return Value

Type: Online Boolean
See Also
IService Interface
IService Members
NFX.ServiceModel Namespace


IService.SignalStop Method

IService SignalStop Method NFX Class Library

Non-blocking call that initiates the stopping of the service

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void SignalStop()
void SignalStop()
Sub SignalStop
Sub SignalStop
void SignalStop()
void SignalStop()
abstract SignalStop : unit -> unit
abstract SignalStop : unit -> unit
See Also
IService Interface
IService Members
NFX.ServiceModel Namespace


IService.Start Method

IService Start Method NFX Class Library

Blocking call that starts the service instance

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Start()
void Start()
Sub Start
Sub Start
void Start()
void Start()
abstract Start : unit -> unit
abstract Start : unit -> unit
See Also
IService Interface
IService Members
NFX.ServiceModel Namespace


IService.WaitForCompleteStop Method

IService WaitForCompleteStop Method NFX Class Library

Blocks execution of current thread until this service has completely stopped

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void WaitForCompleteStop()
void WaitForCompleteStop()
Sub WaitForCompleteStop
Sub WaitForCompleteStop
void WaitForCompleteStop()
void WaitForCompleteStop()
abstract WaitForCompleteStop : unit -> unit
abstract WaitForCompleteStop : unit -> unit
See Also
IService Interface
IService Members
NFX.ServiceModel Namespace


IService Properties

IService Properties NFX Class Library

The IService type exposes the following members.
Properties
 | Name | Description
Public property | Name | (Inherited from INamed.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks
Public property | Status | Current service status
Back to Top
See Also
IService Interface
NFX.ServiceModel Namespace


IService.Running Property

IService Running Property NFX Class Library

Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool Running { get; }
bool Running { get; }
ReadOnly Property Running As Boolean
    Get
ReadOnly Property Running As Boolean
    Get
property bool Running {
    bool get ();
}
property bool Running {
    bool get ();
}
abstract Running : bool with get
abstract Running : bool with get

Property Value

Type: Online Boolean
See Also
IService Interface
IService Members
NFX.ServiceModel Namespace


IService.Status Property

IService Status Property NFX Class Library

Current service status

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
ControlStatus Status { get; }
ControlStatus Status { get; }
ReadOnly Property Status As ControlStatus
    Get
ReadOnly Property Status As ControlStatus
    Get
property ControlStatus Status {
    ControlStatus get ();
}
property ControlStatus Status {
    ControlStatus get ();
}
abstract Status : ControlStatus with get
abstract Status : ControlStatus with get

Property Value

Type: ControlStatus
See Also
IService Interface
IService Members
NFX.ServiceModel Namespace


IWorkItem(TContext) Interface

IWorkItem TContext Interface NFX Class Library

Defines a base for items executable by WorkQueue

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IWorkItem<TContext>
where TContext : class
public interface IWorkItem<TContext>
where TContext : class
Public Interface IWorkItem(Of TContext As Class)
Public Interface IWorkItem(Of TContext As Class)
generic<typename TContext>
where TContext : ref class
public interface class IWorkItem
generic<typename TContext>
where TContext : ref class
public interface class IWorkItem
type IWorkItem<'TContext when 'TContext : not struct> =  interface end
type IWorkItem<'TContext when 'TContext : not struct> =  interface end
Type Parameters
TContext
See Also
IWorkItem TContext Members
NFX.ServiceModel Namespace


IWorkItem(TContext) Members

IWorkItem TContext Members NFX Class Library

The IWorkItem TContext type exposes the following members.
Methods
 | Name | Description
Public method | PerformWork | Invoked on an item to perform actual work. For example: repaint grid from changed data source, refresh file, send email etc...
Public method | WorkFailed | Invoked when either work execution or work success method threw an exception and did not succeed
Public method | WorkSucceeded | Invoked after successfull work execution - when no exception happened
Back to Top
See Also
IWorkItem TContext Interface
NFX.ServiceModel Namespace


IWorkItem(TContext) Methods

IWorkItem TContext Methods NFX Class Library

The IWorkItem TContext type exposes the following members.
Methods
 | Name | Description
Public method | PerformWork | Invoked on an item to perform actual work. For example: repaint grid from changed data source, refresh file, send email etc...
Public method | WorkFailed | Invoked when either work execution or work success method threw an exception and did not succeed
Public method | WorkSucceeded | Invoked after successfull work execution - when no exception happened
Back to Top
See Also
IWorkItem TContext Interface
NFX.ServiceModel Namespace


IWorkItem(TContext).PerformWork Method

IWorkItem TContext PerformWork Method NFX Class Library

Invoked on an item to perform actual work. For example: repaint grid from changed data source, refresh file, send email etc...

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void PerformWork(
    TContext context
)
void PerformWork(
    TContext context
)
Sub PerformWork (
    context As TContext
)
Sub PerformWork (
    context As TContext
)
void PerformWork(
    TContext context
)
void PerformWork(
    TContext context
)
abstract PerformWork :
        context : 'TContext -> unit
abstract PerformWork :
        context : 'TContext -> unit

Parameters

context
Type: TContext
See Also
IWorkItem TContext Interface
IWorkItem TContext Members
NFX.ServiceModel Namespace


IWorkItem(TContext).WorkFailed Method

IWorkItem TContext WorkFailed Method NFX Class Library

Invoked when either work execution or work success method threw an exception and did not succeed

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void WorkFailed(
    bool workPerformed,
    Exception error
)
void WorkFailed(
    bool workPerformed,
    Exception error
)
Sub WorkFailed (
    workPerformed As Boolean,
    error As Exception
)
Sub WorkFailed (
    workPerformed As Boolean,
    error As Exception
)
void WorkFailed(
    bool workPerformed,
    Exception^ error
)
void WorkFailed(
    bool workPerformed,
    Exception^ error
)
abstract WorkFailed :
        workPerformed : bool *
        error : Exception -> unit
abstract WorkFailed :
        workPerformed : bool *
        error : Exception -> unit

Parameters

workPerformed
Type: Online System Boolean
When true indicates that PerformWork() worked without exception but exception happened later
error
Type: Online System Exception
Exception instance
See Also
IWorkItem TContext Interface
IWorkItem TContext Members
NFX.ServiceModel Namespace


IWorkItem(TContext).WorkSucceeded Method

IWorkItem TContext WorkSucceeded Method NFX Class Library

Invoked after successfull work execution - when no exception happened

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void WorkSucceeded()
void WorkSucceeded()
Sub WorkSucceeded
Sub WorkSucceeded
void WorkSucceeded()
void WorkSucceeded()
abstract WorkSucceeded : unit -> unit
abstract WorkSucceeded : unit -> unit
See Also
IWorkItem TContext Interface
IWorkItem TContext Members
NFX.ServiceModel Namespace


IWorkQueue(TContext) Interface

IWorkQueue TContext Interface NFX Class Library

Defines contract for work queue that work items can be posted to

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IWorkQueue<TContext>
where TContext : class
public interface IWorkQueue<TContext>
where TContext : class
Public Interface IWorkQueue(Of TContext As Class)
Public Interface IWorkQueue(Of TContext As Class)
generic<typename TContext>
where TContext : ref class
public interface class IWorkQueue
generic<typename TContext>
where TContext : ref class
public interface class IWorkQueue
type IWorkQueue<'TContext when 'TContext : not struct> =  interface end
type IWorkQueue<'TContext when 'TContext : not struct> =  interface end
Type Parameters
TContext
See Also
IWorkQueue TContext Members
NFX.ServiceModel Namespace


IWorkQueue(TContext) Members

IWorkQueue TContext Members NFX Class Library

The IWorkQueue TContext type exposes the following members.
Methods
 | Name | Description
Public method | PostItem | Posts work item into the queue in natural queue order (at the end of the queue)
Back to Top
Properties
 | Name | Description
Public property | Context |
Public property | ProcessedFailureCount |
Public property | ProcessedSuccessCount |
Back to Top
See Also
IWorkQueue TContext Interface
NFX.ServiceModel Namespace


IWorkQueue(TContext) Methods

IWorkQueue TContext Methods NFX Class Library

The IWorkQueue TContext type exposes the following members.
Methods
 | Name | Description
Public method | PostItem | Posts work item into the queue in natural queue order (at the end of the queue)
Back to Top
See Also
IWorkQueue TContext Interface
NFX.ServiceModel Namespace


IWorkQueue(TContext).PostItem Method

IWorkQueue TContext PostItem Method NFX Class Library

Posts work item into the queue in natural queue order (at the end of the queue)

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void PostItem(
    IWorkItem<TContext> work
)
void PostItem(
    IWorkItem<TContext> work
)
Sub PostItem (
    work As IWorkItem(Of TContext)
)
Sub PostItem (
    work As IWorkItem(Of TContext)
)
void PostItem(
    IWorkItem<TContext>^ work
)
void PostItem(
    IWorkItem<TContext>^ work
)
abstract PostItem :
        work : IWorkItem<'TContext> -> unit
abstract PostItem :
        work : IWorkItem<'TContext> -> unit

Parameters

work
Type: NFX.ServiceModel IWorkItem TContext
See Also
IWorkQueue TContext Interface
IWorkQueue TContext Members
NFX.ServiceModel Namespace


IWorkQueue(TContext) Properties

IWorkQueue TContext Properties NFX Class Library

The IWorkQueue TContext type exposes the following members.
Properties
 | Name | Description
Public property | Context |
Public property | ProcessedFailureCount |
Public property | ProcessedSuccessCount |
Back to Top
See Also
IWorkQueue TContext Interface
NFX.ServiceModel Namespace


IWorkQueue(TContext).Context Property

IWorkQueue TContext Context Property NFX Class Library

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
TContext Context { get; }
TContext Context { get; }
ReadOnly Property Context As TContext
    Get
ReadOnly Property Context As TContext
    Get
property TContext Context {
    TContext get ();
}
property TContext Context {
    TContext get ();
}
abstract Context : 'TContext with get
abstract Context : 'TContext with get

Property Value

Type: TContext
See Also
IWorkQueue TContext Interface
IWorkQueue TContext Members
NFX.ServiceModel Namespace


IWorkQueue(TContext).ProcessedFailureCount Property

IWorkQueue TContext ProcessedFailureCount Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
long ProcessedFailureCount { get; }
long ProcessedFailureCount { get; }
ReadOnly Property ProcessedFailureCount As Long
    Get
ReadOnly Property ProcessedFailureCount As Long
    Get
property long long ProcessedFailureCount {
    long long get ();
}
property long long ProcessedFailureCount {
    long long get ();
}
abstract ProcessedFailureCount : int64 with get
abstract ProcessedFailureCount : int64 with get

Property Value

Type: Online Int64
See Also
IWorkQueue TContext Interface
IWorkQueue TContext Members
NFX.ServiceModel Namespace


IWorkQueue(TContext).ProcessedSuccessCount Property

IWorkQueue TContext ProcessedSuccessCount Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
long ProcessedSuccessCount { get; }
long ProcessedSuccessCount { get; }
ReadOnly Property ProcessedSuccessCount As Long
    Get
ReadOnly Property ProcessedSuccessCount As Long
    Get
property long long ProcessedSuccessCount {
    long long get ();
}
property long long ProcessedSuccessCount {
    long long get ();
}
abstract ProcessedSuccessCount : int64 with get
abstract ProcessedSuccessCount : int64 with get

Property Value

Type: Online Int64
See Also
IWorkQueue TContext Interface
IWorkQueue TContext Members
NFX.ServiceModel Namespace


PostItemFilter(TContext) Delegate

PostItemFilter TContext Delegate NFX Class Library

A filter delegate that gets called within PostItem before adding work to this queue. This is useful for re-routing work to some other queue/s when needed. Return null if work item is going to be processed by some other queue that this delegate should post into. Keep in mind that this delegate is invoked by posters thread

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate IWorkItem<TContext> PostItemFilter<TContext>(
    IWorkItem<TContext> work
)
where TContext : class
public delegate IWorkItem<TContext> PostItemFilter<TContext>(
    IWorkItem<TContext> work
)
where TContext : class
Public Delegate Function PostItemFilter(Of TContext As Class) (
    work As IWorkItem(Of TContext)
) As IWorkItem(Of TContext)
Public Delegate Function PostItemFilter(Of TContext As Class) (
    work As IWorkItem(Of TContext)
) As IWorkItem(Of TContext)
generic<typename TContext>
where TContext : ref class
public delegate IWorkItem<TContext>^ PostItemFilter(
    IWorkItem<TContext>^ work
)
generic<typename TContext>
where TContext : ref class
public delegate IWorkItem<TContext>^ PostItemFilter(
    IWorkItem<TContext>^ work
)
type PostItemFilter =
    delegate of
        work : IWorkItem<'TContext> -> IWorkItem<'TContext>
type PostItemFilter =
    delegate of
        work : IWorkItem<'TContext> -> IWorkItem<'TContext>

Parameters

work
Type: NFX.ServiceModel IWorkItem TContext
Type Parameters
TContext

Return Value

Type: IWorkItem TContext
See Also
NFX.ServiceModel Namespace


Service Class

Service Class NFX Class Library

Represents a lightweight service that can be controlled by Start/SignalStop-like commands. This class serves a a base for various implementations (i.e. LogService) including their composites. This class is thread-safe
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.Erlang ErlAbstractNode
NFX.IO.Net.Gate NetGate
NFX.ServiceModel CompositeServiceHost
NFX.ServiceModel Service TDirector
NFX.ServiceModel WorkItemAggregatorService TContext
NFX.Throttling ThrottlingService
NFX.Web.GeoLookup GeoLookupService
NFX.Web.Messaging MessageService
NFX.Web.Messaging NOPMessenger

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Service : ApplicationComponent,
    IService, INamed, IConfigurable, ILocalizedTimeProvider
public abstract class Service : ApplicationComponent,
    IService, INamed, IConfigurable, ILocalizedTimeProvider
Public MustInherit Class Service
    Inherits ApplicationComponent
    Implements IService, INamed, IConfigurable, ILocalizedTimeProvider
Public MustInherit Class Service
    Inherits ApplicationComponent
    Implements IService, INamed, IConfigurable, ILocalizedTimeProvider
public ref class Service abstract : public ApplicationComponent,
    IService, INamed, IConfigurable, ILocalizedTimeProvider
public ref class Service abstract : public ApplicationComponent,
    IService, INamed, IConfigurable, ILocalizedTimeProvider
[<AbstractClassAttribute>]
type Service =
    class
        inherit ApplicationComponent
        interface IService
        interface INamed
        interface IConfigurable
        interface ILocalizedTimeProvider
    end
[<AbstractClassAttribute>]
type Service =
    class
        inherit ApplicationComponent
        interface IService
        interface INamed
        interface IConfigurable
        interface ILocalizedTimeProvider
    end
See Also
Service Members
NFX.ServiceModel Namespace


Service Members

Service Members NFX Class Library

The Service type exposes the following members.
Constructors
 | Name | Description
Protected method | Service | Initializes a new instance of the Service class
Protected method | Service(Object) | Initializes a new instance of the Service class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart()
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop()
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes)
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block
Protected method | DoStart | Provides implementation that starts the service
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service
Public method | Start | Blocking call that starts the service instance
Protected method | StartByApplication | Blocking call that starts the service instance
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
Name | Description
CONFIG_NAME_ATTR |
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | LocalizedTime | Returns current time localized per TimeLocation
Public property | Name | Provides textual name for the service
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks
Public property | Status | Current service status
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation
Back to Top
See Also
Service Class
NFX.ServiceModel Namespace


Service Constructor

Service Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | Service | Initializes a new instance of the Service class
Protected method | Service(Object) | Initializes a new instance of the Service class
Back to Top
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service Constructor

Service Constructor NFX Class Library

Initializes a new instance of the Service class

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Service()
protected Service()
Protected Sub New
Protected Sub New
protected:
Service()
protected:
Service()
new : unit -> Service
new : unit -> Service
See Also
Service Class
Service Members
Service Overload
NFX.ServiceModel Namespace


Service Constructor (Object)

Service Constructor (Object) NFX Class Library

Initializes a new instance of the Service class

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Service(
    Object director
)
protected Service(
    Object director
)
Protected Sub New (
    director As Object
)
Protected Sub New (
    director As Object
)
protected:
Service(
    Object^ director
)
protected:
Service(
    Object^ director
)
new :
        director : Object -> Service
new :
        director : Object -> Service

Parameters

director
Type: Online System Object
See Also
Service Class
Service Members
Service Overload
NFX.ServiceModel Namespace


Service Fields

Service Fields NFX Class Library

The Service type exposes the following members.
Fields
Name | Description
CONFIG_NAME_ATTR |
Back to Top
See Also
Service Class
NFX.ServiceModel Namespace


Service.CONFIG_NAME_ATTR Field

Service CONFIG_NAME_ATTR Field NFX Class Library

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_NAME_ATTR
public const string CONFIG_NAME_ATTR
Public Const CONFIG_NAME_ATTR As String
Public Const CONFIG_NAME_ATTR As String
public:
literal String^ CONFIG_NAME_ATTR
public:
literal String^ CONFIG_NAME_ATTR
static val mutable CONFIG_NAME_ATTR: string
static val mutable CONFIG_NAME_ATTR: string

Field Value

Type: Online String
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service Methods

Service Methods NFX Class Library

The Service type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart()
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop()
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes)
Protected method | Destructor | (Overrides ApplicationComponent Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block
Protected method | DoStart | Provides implementation that starts the service
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service
Public method | Start | Blocking call that starts the service instance
Protected method | StartByApplication | Blocking call that starts the service instance
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Service Class
NFX.ServiceModel Namespace


Service.____ObtainPrivateServiceStatusLockObject Method

Service ____ObtainPrivateServiceStatusLockObject Method NFX Class Library

[This is preliminary documentation and is subject to change.]

WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Object ____ObtainPrivateServiceStatusLockObject()
protected Object ____ObtainPrivateServiceStatusLockObject()
Protected Function ____ObtainPrivateServiceStatusLockObject As Object
Protected Function ____ObtainPrivateServiceStatusLockObject As Object
protected:
Object^ ____ObtainPrivateServiceStatusLockObject()
protected:
Object^ ____ObtainPrivateServiceStatusLockObject()
member ____ObtainPrivateServiceStatusLockObject : unit -> Object
member ____ObtainPrivateServiceStatusLockObject : unit -> Object

Return Value

Type: Online Object
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service.AbortStart Method

Service AbortStart Method NFX Class Library

Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart()

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void AbortStart()
protected void AbortStart()
Protected Sub AbortStart
Protected Sub AbortStart
protected:
void AbortStart()
protected:
void AbortStart()
member AbortStart : unit -> unit
member AbortStart : unit -> unit
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service.AcceptManagerVisit Method

Service AcceptManagerVisit Method NFX Class Library

Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void AcceptManagerVisit(
    Object manager,
    DateTime managerNow
)
public void AcceptManagerVisit(
    Object manager,
    DateTime managerNow
)
Public Sub AcceptManagerVisit (
    manager As Object,
    managerNow As DateTime
)
Public Sub AcceptManagerVisit (
    manager As Object,
    managerNow As DateTime
)
public:
void AcceptManagerVisit(
    Object^ manager,
    DateTime managerNow
)
public:
void AcceptManagerVisit(
    Object^ manager,
    DateTime managerNow
)
member AcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit
member AcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit

Parameters

manager
Type: Online System Object
managerNow
Type: Online System DateTime
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service.CheckForCompleteStop Method

Service CheckForCompleteStop Method NFX Class Library

Non-blocking call that returns true when the service instance has completely stopped after SignalStop()

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool CheckForCompleteStop()
public bool CheckForCompleteStop()
Public Function CheckForCompleteStop As Boolean
Public Function CheckForCompleteStop As Boolean
public:
virtual bool CheckForCompleteStop() sealed
public:
virtual bool CheckForCompleteStop() sealed
abstract CheckForCompleteStop : unit -> bool
override CheckForCompleteStop : unit -> bool
abstract CheckForCompleteStop : unit -> bool
override CheckForCompleteStop : unit -> bool

Return Value

Type: Online Boolean

Implements

IService CheckForCompleteStop
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service.CheckServiceActive Method

Service CheckServiceActive Method NFX Class Library

Checks for service activity and throws exception if service is not in ControlStatus.Active state

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void CheckServiceActive()
protected void CheckServiceActive()
Protected Sub CheckServiceActive
Protected Sub CheckServiceActive
protected:
void CheckServiceActive()
protected:
void CheckServiceActive()
member CheckServiceActive : unit -> unit
member CheckServiceActive : unit -> unit
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service.CheckServiceActiveOrStarting Method

Service CheckServiceActiveOrStarting Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Checks for service activity and throws exception if service is not in ControlStatus.Active state

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void CheckServiceActiveOrStarting()
protected void CheckServiceActiveOrStarting()
Protected Sub CheckServiceActiveOrStarting
Protected Sub CheckServiceActiveOrStarting
protected:
void CheckServiceActiveOrStarting()
protected:
void CheckServiceActiveOrStarting()
member CheckServiceActiveOrStarting : unit -> unit
member CheckServiceActiveOrStarting : unit -> unit
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service.CheckServiceInactive Method

Service CheckServiceInactive Method NFX Class Library

Checks for service inactivity and throws exception if service is running (started, starting or stopping)

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected void CheckServiceInactive()
protected void CheckServiceInactive()
Protected Sub CheckServiceInactive
Protected Sub CheckServiceInactive
protected:
void CheckServiceInactive()
protected:
void CheckServiceInactive()
member CheckServiceInactive : unit -> unit
member CheckServiceInactive : unit -> unit
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service.Configure Method

Service Configure Method NFX Class Library

Configures service from configuration node (and possibly it's sub-nodes)

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode fromNode
)
public void Configure(
    IConfigSectionNode fromNode
)
Public Sub Configure (
    fromNode As IConfigSectionNode
)
Public Sub Configure (
    fromNode As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ fromNode
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ fromNode
) sealed
abstract Configure :
        fromNode : IConfigSectionNode -> unit
override Configure :
        fromNode : IConfigSectionNode -> unit
abstract Configure :
        fromNode : IConfigSectionNode -> unit
override Configure :
        fromNode : IConfigSectionNode -> unit

Parameters

fromNode
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service.Destructor Method

Service Destructor Method NFX Class Library

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service.DoAcceptManagerVisit Method

Service DoAcceptManagerVisit Method NFX Class Library

Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoAcceptManagerVisit(
    Object manager,
    DateTime managerNow
)
protected virtual void DoAcceptManagerVisit(
    Object manager,
    DateTime managerNow
)
Protected Overridable Sub DoAcceptManagerVisit (
    manager As Object,
    managerNow As DateTime
)
Protected Overridable Sub DoAcceptManagerVisit (
    manager As Object,
    managerNow As DateTime
)
protected:
virtual void DoAcceptManagerVisit(
    Object^ manager,
    DateTime managerNow
)
protected:
virtual void DoAcceptManagerVisit(
    Object^ manager,
    DateTime managerNow
)
abstract DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit
override DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit
abstract DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit
override DoAcceptManagerVisit :
        manager : Object *
        managerNow : DateTime -> unit

Parameters

manager
Type: Online System Object
managerNow
Type: Online System DateTime
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service.DoCheckForCompleteStop Method

Service DoCheckForCompleteStop Method NFX Class Library

Provides implementation for checking whether the service has completely stopped

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool DoCheckForCompleteStop()
protected virtual bool DoCheckForCompleteStop()
Protected Overridable Function DoCheckForCompleteStop As Boolean
Protected Overridable Function DoCheckForCompleteStop As Boolean
protected:
virtual bool DoCheckForCompleteStop()
protected:
virtual bool DoCheckForCompleteStop()
abstract DoCheckForCompleteStop : unit -> bool
override DoCheckForCompleteStop : unit -> bool
abstract DoCheckForCompleteStop : unit -> bool
override DoCheckForCompleteStop : unit -> bool

Return Value

Type: Online Boolean
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service.DoConfigure Method

Service DoConfigure Method NFX Class Library

Provides implementation that configures service from configuration node (and possibly it's sub-nodes)

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoConfigure(
    IConfigSectionNode node
)
protected virtual void DoConfigure(
    IConfigSectionNode node
)
Protected Overridable Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overridable Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
)
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service.DoSignalStop Method

Service DoSignalStop Method NFX Class Library

Provides implementation that signals service to stop. This is expected not to block

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoSignalStop()
protected virtual void DoSignalStop()
Protected Overridable Sub DoSignalStop
Protected Overridable Sub DoSignalStop
protected:
virtual void DoSignalStop()
protected:
virtual void DoSignalStop()
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service.DoStart Method

Service DoStart Method NFX Class Library

Provides implementation that starts the service

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoStart()
protected virtual void DoStart()
Protected Overridable Sub DoStart
Protected Overridable Sub DoStart
protected:
virtual void DoStart()
protected:
virtual void DoStart()
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service.DoWaitForCompleteStop Method

Service DoWaitForCompleteStop Method NFX Class Library

Provides implementation for a blocking call that returns only after a complete service stop

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoWaitForCompleteStop()
protected virtual void DoWaitForCompleteStop()
Protected Overridable Sub DoWaitForCompleteStop
Protected Overridable Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop()
protected:
virtual void DoWaitForCompleteStop()
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service.LocalizedTimeToUniversalTime Method

Service LocalizedTimeToUniversalTime Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Converts localized time to UTC time as of TimeLocation property

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
public DateTime LocalizedTimeToUniversalTime(
    DateTime local
)
Public Function LocalizedTimeToUniversalTime (
    local As DateTime
) As DateTime
Public Function LocalizedTimeToUniversalTime (
    local As DateTime
) As DateTime
public:
virtual DateTime LocalizedTimeToUniversalTime(
    DateTime local
) sealed
public:
virtual DateTime LocalizedTimeToUniversalTime(
    DateTime local
) sealed
abstract LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
override LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
abstract LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime
override LocalizedTimeToUniversalTime :
        local : DateTime -> DateTime

Parameters

local
Type: Online System DateTime

Return Value

Type: Online DateTime

Implements

ILocalizedTimeProvider LocalizedTimeToUniversalTime(DateTime)
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service.SignalStop Method

Service SignalStop Method NFX Class Library

Non-blocking call that initiates the stopping of the service

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SignalStop()
public void SignalStop()
Public Sub SignalStop
Public Sub SignalStop
public:
virtual void SignalStop() sealed
public:
virtual void SignalStop() sealed
abstract SignalStop : unit -> unit
override SignalStop : unit -> unit
abstract SignalStop : unit -> unit
override SignalStop : unit -> unit

Implements

IService SignalStop
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service.Start Method

Service Start Method NFX Class Library

Blocking call that starts the service instance

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Start()
public void Start()
Public Sub Start
Public Sub Start
public:
virtual void Start() sealed
public:
virtual void Start() sealed
abstract Start : unit -> unit
override Start : unit -> unit
abstract Start : unit -> unit
override Start : unit -> unit

Implements

IService Start
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service.StartByApplication Method

Service StartByApplication Method NFX Class Library

Blocking call that starts the service instance

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal bool StartByApplication()
internal bool StartByApplication()
Friend Function StartByApplication As Boolean
Friend Function StartByApplication As Boolean
internal:
bool StartByApplication()
internal:
bool StartByApplication()
internal member StartByApplication : unit -> bool
internal member StartByApplication : unit -> bool

Return Value

Type: Online Boolean
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service.UniversalTimeToLocalizedTime Method

Service UniversalTimeToLocalizedTime Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Converts universal time to local time as of TimeLocation property

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
public DateTime UniversalTimeToLocalizedTime(
    DateTime utc
)
Public Function UniversalTimeToLocalizedTime (
    utc As DateTime
) As DateTime
Public Function UniversalTimeToLocalizedTime (
    utc As DateTime
) As DateTime
public:
virtual DateTime UniversalTimeToLocalizedTime(
    DateTime utc
) sealed
public:
virtual DateTime UniversalTimeToLocalizedTime(
    DateTime utc
) sealed
abstract UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
override UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
abstract UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime
override UniversalTimeToLocalizedTime :
        utc : DateTime -> DateTime

Parameters

utc
Type: Online System DateTime

Return Value

Type: Online DateTime

Implements

ILocalizedTimeProvider UniversalTimeToLocalizedTime(DateTime)
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service.WaitForCompleteStop Method

Service WaitForCompleteStop Method NFX Class Library

Blocks execution of current thread until this service has completely stopped

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WaitForCompleteStop()
public void WaitForCompleteStop()
Public Sub WaitForCompleteStop
Public Sub WaitForCompleteStop
public:
virtual void WaitForCompleteStop() sealed
public:
virtual void WaitForCompleteStop() sealed
abstract WaitForCompleteStop : unit -> unit
override WaitForCompleteStop : unit -> unit
abstract WaitForCompleteStop : unit -> unit
override WaitForCompleteStop : unit -> unit

Implements

IService WaitForCompleteStop
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service Properties

Service Properties NFX Class Library

The Service type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | LocalizedTime | Returns current time localized per TimeLocation
Public property | Name | Provides textual name for the service
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks
Public property | Status | Current service status
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation
Back to Top
See Also
Service Class
NFX.ServiceModel Namespace


Service.ApplicationDontAutoStartService Property

Service ApplicationDontAutoStartService Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ApplicationDontAutoStartService { get; }
public bool ApplicationDontAutoStartService { get; }
Public ReadOnly Property ApplicationDontAutoStartService As Boolean
    Get
Public ReadOnly Property ApplicationDontAutoStartService As Boolean
    Get
public:
property bool ApplicationDontAutoStartService {
    bool get ();
}
public:
property bool ApplicationDontAutoStartService {
    bool get ();
}
member ApplicationDontAutoStartService : bool with get
member ApplicationDontAutoStartService : bool with get

Property Value

Type: Online Boolean
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service.LocalizedTime Property

Service LocalizedTime Property NFX Class Library

Returns current time localized per TimeLocation

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime LocalizedTime { get; }
public DateTime LocalizedTime { get; }
Public ReadOnly Property LocalizedTime As DateTime
    Get
Public ReadOnly Property LocalizedTime As DateTime
    Get
public:
virtual property DateTime LocalizedTime {
    DateTime get () sealed;
}
public:
virtual property DateTime LocalizedTime {
    DateTime get () sealed;
}
abstract LocalizedTime : DateTime with get
override LocalizedTime : DateTime with get
abstract LocalizedTime : DateTime with get
override LocalizedTime : DateTime with get

Property Value

Type: Online DateTime

Implements

ILocalizedTimeProvider LocalizedTime
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service.Name Property

Service Name Property NFX Class Library

Provides textual name for the service

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; protected set; }
public string Name { get; protected set; }
Public Property Name As String
    Get
    Protected Set
Public Property Name As String
    Get
    Protected Set
public:
virtual property String^ Name {
    String^ get () sealed;
    protected: void set (String^ value) sealed;
}
public:
virtual property String^ Name {
    String^ get () sealed;
    protected: void set (String^ value) sealed;
}
abstract Name : string with get, set
override Name : string with get, set
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: Online String

Implements

INamed Name
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service.Running Property

Service Running Property NFX Class Library

Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Running { get; }
public bool Running { get; }
Public ReadOnly Property Running As Boolean
    Get
Public ReadOnly Property Running As Boolean
    Get
public:
virtual property bool Running {
    bool get () sealed;
}
public:
virtual property bool Running {
    bool get () sealed;
}
abstract Running : bool with get
override Running : bool with get
abstract Running : bool with get
override Running : bool with get

Property Value

Type: Online Boolean

Implements

IService Running
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service.Status Property

Service Status Property NFX Class Library

Current service status

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ControlStatus Status { get; }
public ControlStatus Status { get; }
Public ReadOnly Property Status As ControlStatus
    Get
Public ReadOnly Property Status As ControlStatus
    Get
public:
virtual property ControlStatus Status {
    ControlStatus get () sealed;
}
public:
virtual property ControlStatus Status {
    ControlStatus get () sealed;
}
abstract Status : ControlStatus with get
override Status : ControlStatus with get
abstract Status : ControlStatus with get
override Status : ControlStatus with get

Property Value

Type: ControlStatus

Implements

IService Status
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service.TimeLocation Property

Service TimeLocation Property NFX Class Library

Returns time location of this LocalizedTimeProvider implementation

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeLocation TimeLocation { get; set; }
public TimeLocation TimeLocation { get; set; }
Public Property TimeLocation As TimeLocation
    Get
    Set
Public Property TimeLocation As TimeLocation
    Get
    Set
public:
virtual property TimeLocation^ TimeLocation {
    TimeLocation^ get () sealed;
    void set (TimeLocation^ value) sealed;
}
public:
virtual property TimeLocation^ TimeLocation {
    TimeLocation^ get () sealed;
    void set (TimeLocation^ value) sealed;
}
abstract TimeLocation : TimeLocation with get, set
override TimeLocation : TimeLocation with get, set
abstract TimeLocation : TimeLocation with get, set
override TimeLocation : TimeLocation with get, set

Property Value

Type: TimeLocation

Implements

ILocalizedTimeProvider TimeLocation
See Also
Service Class
Service Members
NFX.ServiceModel Namespace


Service(TDirector) Class

Service TDirector Class NFX Class Library

Represents service with typed ComponentDirector property
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service TDirector
NFX.ApplicationModel.Volatile ObjectStoreProvider
NFX.Glue Transport
NFX.Instrumentation InstrumentationProvider
NFX.ServiceModel ServiceWithInstrumentationBase TDirector
NFX.Wave WorkDispatcher
NFX.Web.Messaging MessageSink

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Service<TDirector> : Service
where TDirector : class
public class Service<TDirector> : Service
where TDirector : class
Public Class Service(Of TDirector As Class)
    Inherits Service
Public Class Service(Of TDirector As Class)
    Inherits Service
generic<typename TDirector>
where TDirector : ref class
public ref class Service : public Service
generic<typename TDirector>
where TDirector : ref class
public ref class Service : public Service
type Service<'TDirector when 'TDirector : not struct> =
    class
        inherit Service
    end
type Service<'TDirector when 'TDirector : not struct> =
    class
        inherit Service
    end
Type Parameters
TDirector
See Also
Service TDirector Members
NFX.ServiceModel Namespace


Service(TDirector) Members

Service TDirector Members NFX Class Library

The Service TDirector type exposes the following members.
Constructors
 | Name | Description
Protected method | Service TDirector | Initializes a new instance of the Service TDirector class
Protected method | Service TDirector (TDirector) | Initializes a new instance of the Service TDirector class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector |
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
Service TDirector Class
NFX.ServiceModel Namespace


Service(TDirector) Constructor

Service TDirector Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | Service TDirector | Initializes a new instance of the Service TDirector class
Protected method | Service TDirector (TDirector) | Initializes a new instance of the Service TDirector class
Back to Top
See Also
Service TDirector Class
Service TDirector Members
NFX.ServiceModel Namespace


Service(TDirector) Constructor

Service TDirector Constructor NFX Class Library

Initializes a new instance of the Service TDirector class

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Service()
protected Service()
Protected Sub New
Protected Sub New
protected:
Service()
protected:
Service()
new : unit -> Service
new : unit -> Service
See Also
Service TDirector Class
Service TDirector Members
Service TDirector Overload
NFX.ServiceModel Namespace


Service(TDirector) Constructor (TDirector)

Service TDirector Constructor (TDirector) NFX Class Library

Initializes a new instance of the Service TDirector class

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Service(
    TDirector director
)
protected Service(
    TDirector director
)
Protected Sub New (
    director As TDirector
)
Protected Sub New (
    director As TDirector
)
protected:
Service(
    TDirector director
)
protected:
Service(
    TDirector director
)
new :
        director : 'TDirector -> Service
new :
        director : 'TDirector -> Service

Parameters

director
Type: TDirector
See Also
Service TDirector Class
Service TDirector Members
Service TDirector Overload
NFX.ServiceModel Namespace


Service(TDirector) Methods

Service TDirector Methods NFX Class Library

The Service TDirector type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Service TDirector Class
NFX.ServiceModel Namespace


Service(TDirector) Properties

Service TDirector Properties NFX Class Library

The Service TDirector type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector |
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
Service TDirector Class
NFX.ServiceModel Namespace


Service(TDirector).ComponentDirector Property

Service TDirector ComponentDirector Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TDirector ComponentDirector { get; }
public TDirector ComponentDirector { get; }
Public ReadOnly Property ComponentDirector As TDirector
    Get
Public ReadOnly Property ComponentDirector As TDirector
    Get
public:
property TDirector ComponentDirector {
    TDirector get ();
}
public:
property TDirector ComponentDirector {
    TDirector get ();
}
member ComponentDirector : 'TDirector with get
member ComponentDirector : 'TDirector with get

Property Value

Type: TDirector
See Also
Service TDirector Class
Service TDirector Members
NFX.ServiceModel Namespace


ServiceWithInstrumentationBase(TDirector) Class

ServiceWithInstrumentationBase TDirector Class NFX Class Library

[This is preliminary documentation and is subject to change.]

Provides base implementation for Service with IInstrumentable logic
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel Service TDirector
NFX.ServiceModel ServiceWithInstrumentationBase TDirector
NFX.ApplicationModel.Pile DefaultPile
NFX.ApplicationModel.Pile LocalCache
NFX.ApplicationModel.Volatile ObjectStoreService
NFX.DataAccess.Erlang ErlDataStore
NFX.Glue GlueComponentService
NFX.Glue.Implementation GlueService
NFX.Instrumentation InstrumentationService
NFX.Log LogServiceBase
NFX.Security ConfigSecurityManager
NFX.Security DefaultPasswordManager
NFX.Security PasswordHashingAlgorithm
NFX.Time EventTimer
NFX.Wave WaveServer
NFX.Web.Pay PaySystem
NFX.Web.Pay PaySystemHost
NFX.Web.Shipping ShippingSystem
NFX.Web.Shipping ShippingSystemHost
NFX.Web.Social SocialNetwork

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class ServiceWithInstrumentationBase<TDirector> : Service<TDirector>,
    IInstrumentable, IExternallyParameterized
where TDirector : class
public abstract class ServiceWithInstrumentationBase<TDirector> : Service<TDirector>,
    IInstrumentable, IExternallyParameterized
where TDirector : class
Public MustInherit Class ServiceWithInstrumentationBase(Of TDirector As Class)
    Inherits Service(Of TDirector)
    Implements IInstrumentable, IExternallyParameterized
Public MustInherit Class ServiceWithInstrumentationBase(Of TDirector As Class)
    Inherits Service(Of TDirector)
    Implements IInstrumentable, IExternallyParameterized
generic<typename TDirector>
where TDirector : ref class
public ref class ServiceWithInstrumentationBase abstract : public Service<TDirector>,
    IInstrumentable, IExternallyParameterized
generic<typename TDirector>
where TDirector : ref class
public ref class ServiceWithInstrumentationBase abstract : public Service<TDirector>,
    IInstrumentable, IExternallyParameterized
[<AbstractClassAttribute>]
type ServiceWithInstrumentationBase<'TDirector when 'TDirector : not struct> =
    class
        inherit Service<'TDirector>
        interface IInstrumentable
        interface IExternallyParameterized
    end
[<AbstractClassAttribute>]
type ServiceWithInstrumentationBase<'TDirector when 'TDirector : not struct> =
    class
        inherit Service<'TDirector>
        interface IInstrumentable
        interface IExternallyParameterized
    end
Type Parameters
TDirector
See Also
ServiceWithInstrumentationBase TDirector Members
NFX.ServiceModel Namespace


ServiceWithInstrumentationBase(TDirector) Members

ServiceWithInstrumentationBase TDirector Members NFX Class Library

[This is preliminary documentation and is subject to change.]

The ServiceWithInstrumentationBase TDirector type exposes the following members.
Constructors
 | Name | Description
Protected method | ServiceWithInstrumentationBase TDirector | Initializes a new instance of the ServiceWithInstrumentationBase TDirector class
Protected method | ServiceWithInstrumentationBase TDirector (TDirector) | Initializes a new instance of the ServiceWithInstrumentationBase TDirector class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component
Public property | InstrumentationEnabled | Turns instrumentation on/off
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
ServiceWithInstrumentationBase TDirector Class
NFX.ServiceModel Namespace


ServiceWithInstrumentationBase(TDirector) Constructor

ServiceWithInstrumentationBase TDirector Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Protected method | ServiceWithInstrumentationBase TDirector | Initializes a new instance of the ServiceWithInstrumentationBase TDirector class
Protected method | ServiceWithInstrumentationBase TDirector (TDirector) | Initializes a new instance of the ServiceWithInstrumentationBase TDirector class
Back to Top
See Also
ServiceWithInstrumentationBase TDirector Class
ServiceWithInstrumentationBase TDirector Members
NFX.ServiceModel Namespace


ServiceWithInstrumentationBase(TDirector) Constructor

ServiceWithInstrumentationBase TDirector Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServiceWithInstrumentationBase TDirector class

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServiceWithInstrumentationBase()
protected ServiceWithInstrumentationBase()
Protected Sub New
Protected Sub New
protected:
ServiceWithInstrumentationBase()
protected:
ServiceWithInstrumentationBase()
new : unit -> ServiceWithInstrumentationBase
new : unit -> ServiceWithInstrumentationBase
See Also
ServiceWithInstrumentationBase TDirector Class
ServiceWithInstrumentationBase TDirector Members
ServiceWithInstrumentationBase TDirector Overload
NFX.ServiceModel Namespace


ServiceWithInstrumentationBase(TDirector) Constructor (TDirector)

ServiceWithInstrumentationBase TDirector Constructor (TDirector) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServiceWithInstrumentationBase TDirector class

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected ServiceWithInstrumentationBase(
    TDirector director
)
protected ServiceWithInstrumentationBase(
    TDirector director
)
Protected Sub New (
    director As TDirector
)
Protected Sub New (
    director As TDirector
)
protected:
ServiceWithInstrumentationBase(
    TDirector director
)
protected:
ServiceWithInstrumentationBase(
    TDirector director
)
new :
        director : 'TDirector -> ServiceWithInstrumentationBase
new :
        director : 'TDirector -> ServiceWithInstrumentationBase

Parameters

director
Type: TDirector
See Also
ServiceWithInstrumentationBase TDirector Class
ServiceWithInstrumentationBase TDirector Members
ServiceWithInstrumentationBase TDirector Overload
NFX.ServiceModel Namespace


ServiceWithInstrumentationBase(TDirector) Methods

ServiceWithInstrumentationBase TDirector Methods NFX Class Library

[This is preliminary documentation and is subject to change.]

The ServiceWithInstrumentationBase TDirector type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Inherited from Service.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoSignalStop | Provides implementation that signals service to stop. This is expected not to block (Inherited from Service.)
Protected method | DoStart | Provides implementation that starts the service (Inherited from Service.)
Protected method | DoWaitForCompleteStop | Provides implementation for a blocking call that returns only after a complete service stop (Inherited from Service.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExternalGetParameter | Gets external parameter value returning true if parameter was found
Public method | ExternalParametersForGroups | Returns named parameters that can be used to control this component
Public method | ExternalSetParameter | Sets external parameter value returning true if parameter was found and set
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
ServiceWithInstrumentationBase TDirector Class
NFX.ServiceModel Namespace


ServiceWithInstrumentationBase(TDirector).ExternalGetParameter Method

ServiceWithInstrumentationBase TDirector ExternalGetParameter Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets external parameter value returning true if parameter was found

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
public virtual bool ExternalGetParameter(
    string name,
    out Object value,
    params string[] groups
)
Public Overridable Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
Public Overridable Function ExternalGetParameter (
    name As String,
    <OutAttribute> ByRef value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
)
public:
virtual bool ExternalGetParameter(
    String^ name,
    [OutAttribute] Object^% value,
    ... array<String^>^ groups
)
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
abstract ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool
override ExternalGetParameter :
        name : string *
        value : Object byref *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalGetParameter(String, Object , String )
See Also
ServiceWithInstrumentationBase TDirector Class
ServiceWithInstrumentationBase TDirector Members
NFX.ServiceModel Namespace


ServiceWithInstrumentationBase(TDirector).ExternalParametersForGroups Method

ServiceWithInstrumentationBase TDirector ExternalParametersForGroups Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns named parameters that can be used to control this component

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
public virtual IEnumerable<KeyValuePair<string, Type>> ExternalParametersForGroups(
    params string[] groups
)
Public Overridable Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
Public Overridable Function ExternalParametersForGroups (
    ParamArray groups As String()
) As IEnumerable(Of KeyValuePair(Of String, Type))
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
)
public:
virtual IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParametersForGroups(
    ... array<String^>^ groups
)
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
abstract ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>
override ExternalParametersForGroups :
        groups : string[] -> IEnumerable<KeyValuePair<string, Type>>

Parameters

groups
Type: Online System String

Return Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParametersForGroups( String )
See Also
ServiceWithInstrumentationBase TDirector Class
ServiceWithInstrumentationBase TDirector Members
NFX.ServiceModel Namespace


ServiceWithInstrumentationBase(TDirector).ExternalSetParameter Method

ServiceWithInstrumentationBase TDirector ExternalSetParameter Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Sets external parameter value returning true if parameter was found and set

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
public virtual bool ExternalSetParameter(
    string name,
    Object value,
    params string[] groups
)
Public Overridable Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
Public Overridable Function ExternalSetParameter (
    name As String,
    value As Object,
    ParamArray groups As String()
) As Boolean
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
)
public:
virtual bool ExternalSetParameter(
    String^ name,
    Object^ value,
    ... array<String^>^ groups
)
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
abstract ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool
override ExternalSetParameter :
        name : string *
        value : Object *
        groups : string[] -> bool

Parameters

name
Type: Online System String
value
Type: Online System Object
groups
Type: Online System String

Return Value

Type: Online Boolean

Implements

IExternallyParameterized ExternalSetParameter(String, Object, String )
See Also
ServiceWithInstrumentationBase TDirector Class
ServiceWithInstrumentationBase TDirector Members
NFX.ServiceModel Namespace


ServiceWithInstrumentationBase(TDirector) Properties

ServiceWithInstrumentationBase TDirector Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The ServiceWithInstrumentationBase TDirector type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | (Inherited from Service TDirector .)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | ExternalParameters | Returns named parameters that can be used to control this component
Public property | InstrumentationEnabled | Turns instrumentation on/off
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
ServiceWithInstrumentationBase TDirector Class
NFX.ServiceModel Namespace


ServiceWithInstrumentationBase(TDirector).ExternalParameters Property

ServiceWithInstrumentationBase TDirector ExternalParameters Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns named parameters that can be used to control this component

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
public virtual IEnumerable<KeyValuePair<string, Type>> ExternalParameters { get; }
Public Overridable ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
Public Overridable ReadOnly Property ExternalParameters As IEnumerable(Of KeyValuePair(Of String, Type))
    Get
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get ();
}
public:
virtual property IEnumerable<KeyValuePair<String^, Type^>>^ ExternalParameters {
    IEnumerable<KeyValuePair<String^, Type^>>^ get ();
}
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
abstract ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get
override ExternalParameters : IEnumerable<KeyValuePair<string, Type>> with get

Property Value

Type: Online IEnumerable Online KeyValuePair Online String, Online Type

Implements

IExternallyParameterized ExternalParameters
See Also
ServiceWithInstrumentationBase TDirector Class
ServiceWithInstrumentationBase TDirector Members
NFX.ServiceModel Namespace


ServiceWithInstrumentationBase(TDirector).InstrumentationEnabled Property

ServiceWithInstrumentationBase TDirector InstrumentationEnabled Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Turns instrumentation on/off

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool InstrumentationEnabled { get; set; }
public abstract bool InstrumentationEnabled { get; set; }
Public MustOverride Property InstrumentationEnabled As Boolean
    Get
    Set
Public MustOverride Property InstrumentationEnabled As Boolean
    Get
    Set
public:
virtual property bool InstrumentationEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
public:
virtual property bool InstrumentationEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
abstract InstrumentationEnabled : bool with get, set
abstract InstrumentationEnabled : bool with get, set

Property Value

Type: Online Boolean

Implements

IInstrumentable InstrumentationEnabled
See Also
ServiceWithInstrumentationBase TDirector Class
ServiceWithInstrumentationBase TDirector Members
NFX.ServiceModel Namespace


SvcHostException Class

SvcHostException Class NFX Class Library

Thrown by CompositeServiceHost
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.ServiceModel SvcHostException

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class SvcHostException : NFXException
[SerializableAttribute]
public class SvcHostException : NFXException
<SerializableAttribute>
Public Class SvcHostException
    Inherits NFXException
<SerializableAttribute>
Public Class SvcHostException
    Inherits NFXException
[SerializableAttribute]
public ref class SvcHostException : public NFXException
[SerializableAttribute]
public ref class SvcHostException : public NFXException
[<SerializableAttribute>]
type SvcHostException =
    class
        inherit NFXException
    end
[<SerializableAttribute>]
type SvcHostException =
    class
        inherit NFXException
    end
See Also
SvcHostException Members
NFX.ServiceModel Namespace


SvcHostException Members

SvcHostException Members NFX Class Library

The SvcHostException type exposes the following members.
Constructors
 | Name | Description
Public method | SvcHostException | Initializes a new instance of the SvcHostException class
Public method | SvcHostException(String) | Initializes a new instance of the SvcHostException class
Protected method | SvcHostException(SerializationInfo, StreamingContext) | Initializes a new instance of the SvcHostException class
Public method | SvcHostException(String, Exception) | Initializes a new instance of the SvcHostException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
SvcHostException Class
NFX.ServiceModel Namespace


SvcHostException Constructor

SvcHostException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | SvcHostException | Initializes a new instance of the SvcHostException class
Public method | SvcHostException(String) | Initializes a new instance of the SvcHostException class
Protected method | SvcHostException(SerializationInfo, StreamingContext) | Initializes a new instance of the SvcHostException class
Public method | SvcHostException(String, Exception) | Initializes a new instance of the SvcHostException class
Back to Top
See Also
SvcHostException Class
SvcHostException Members
NFX.ServiceModel Namespace


SvcHostException Constructor

SvcHostException Constructor NFX Class Library

Initializes a new instance of the SvcHostException class

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SvcHostException()
public SvcHostException()
Public Sub New
Public Sub New
public:
SvcHostException()
public:
SvcHostException()
new : unit -> SvcHostException
new : unit -> SvcHostException
See Also
SvcHostException Class
SvcHostException Members
SvcHostException Overload
NFX.ServiceModel Namespace


SvcHostException Constructor (String)

SvcHostException Constructor (String) NFX Class Library

Initializes a new instance of the SvcHostException class

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SvcHostException(
    string message
)
public SvcHostException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
SvcHostException(
    String^ message
)
public:
SvcHostException(
    String^ message
)
new :
        message : string -> SvcHostException
new :
        message : string -> SvcHostException

Parameters

message
Type: Online System String
See Also
SvcHostException Class
SvcHostException Members
SvcHostException Overload
NFX.ServiceModel Namespace


SvcHostException Constructor (SerializationInfo, StreamingContext)

SvcHostException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SvcHostException class

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected SvcHostException(
    SerializationInfo info,
    StreamingContext context
)
protected SvcHostException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
SvcHostException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
SvcHostException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SvcHostException
new :
        info : SerializationInfo *
        context : StreamingContext -> SvcHostException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
SvcHostException Class
SvcHostException Members
SvcHostException Overload
NFX.ServiceModel Namespace


SvcHostException Constructor (String, Exception)

SvcHostException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SvcHostException class

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SvcHostException(
    string message,
    Exception inner
)
public SvcHostException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
SvcHostException(
    String^ message,
    Exception^ inner
)
public:
SvcHostException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> SvcHostException
new :
        message : string *
        inner : Exception -> SvcHostException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
SvcHostException Class
SvcHostException Members
SvcHostException Overload
NFX.ServiceModel Namespace


SvcHostException Methods

SvcHostException Methods NFX Class Library

The SvcHostException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
SvcHostException Class
NFX.ServiceModel Namespace


SvcHostException Properties

SvcHostException Properties NFX Class Library

The SvcHostException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
SvcHostException Class
NFX.ServiceModel Namespace


SvcHostException Events

SvcHostException Events NFX Class Library

The SvcHostException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
SvcHostException Class
NFX.ServiceModel Namespace


WorkItemAggregationIntervalKind Enumeration

WorkItemAggregationIntervalKind Enumeration NFX Class Library

[This is preliminary documentation and is subject to change.]

Defines how intervals should be handled. Sliding means that every time message is posted into in queue interval starts to count from scratch, periodic counts from the first message post

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum WorkItemAggregationIntervalKind
public enum WorkItemAggregationIntervalKind
Public Enumeration WorkItemAggregationIntervalKind
Public Enumeration WorkItemAggregationIntervalKind
public enum class WorkItemAggregationIntervalKind
public enum class WorkItemAggregationIntervalKind
type WorkItemAggregationIntervalKind
type WorkItemAggregationIntervalKind
Members
Member name | Value | Description
Sliding | 0 |
Periodic | 1 |
See Also
NFX.ServiceModel Namespace


WorkItemAggregatorService(TContext) Class

WorkItemAggregatorService TContext Class NFX Class Library

Aggregates same/equal (as defined by item's IAggregatableWorkItem.AggregationKey) work items posted into queue to limit the penetration of duplicate work items in destination queue
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.ApplicationModel ApplicationComponent
NFX.ServiceModel Service
NFX.ServiceModel WorkItemAggregatorService TContext

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class WorkItemAggregatorService<TContext> : Service,
    IWorkQueue<TContext>
where TContext : class
public class WorkItemAggregatorService<TContext> : Service,
    IWorkQueue<TContext>
where TContext : class
Public Class WorkItemAggregatorService(Of TContext As Class)
    Inherits Service
    Implements IWorkQueue(Of TContext)
Public Class WorkItemAggregatorService(Of TContext As Class)
    Inherits Service
    Implements IWorkQueue(Of TContext)
generic<typename TContext>
where TContext : ref class
public ref class WorkItemAggregatorService : public Service,
    IWorkQueue<TContext>
generic<typename TContext>
where TContext : ref class
public ref class WorkItemAggregatorService : public Service,
    IWorkQueue<TContext>
type WorkItemAggregatorService<'TContext when 'TContext : not struct> =
    class
        inherit Service
        interface IWorkQueue<'TContext>
    end
type WorkItemAggregatorService<'TContext when 'TContext : not struct> =
    class
        inherit Service
        interface IWorkQueue<'TContext>
    end
Type Parameters
TContext
See Also
WorkItemAggregatorService TContext Members
NFX.ServiceModel Namespace


WorkItemAggregatorService(TContext) Members

WorkItemAggregatorService TContext Members NFX Class Library

The WorkItemAggregatorService TContext type exposes the following members.
Constructors
 | Name | Description
Public method | WorkItemAggregatorService TContext | Initializes a new instance of the WorkItemAggregatorService TContext class
Back to Top
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Overrides Service Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PostItem | Posts work item in the service. This item may not be posted into destination if the same item was already recently posted into destination queue, however if no same work item will come within timeout, then this item will eventually post
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Context |
Public property | DestinationPostInterval | Defines an interval measured in milliseconds for posting into destination queue
Public property | DestinationQueue | Returns the destination queue
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | ProcessedFailureCount |
Public property | ProcessedSuccessCount |
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
WorkItemAggregatorService TContext Class
NFX.ServiceModel Namespace


WorkItemAggregatorService(TContext) Constructor

WorkItemAggregatorService TContext Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the WorkItemAggregatorService TContext class

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WorkItemAggregatorService(
    IWorkQueue<TContext> destination
)
public WorkItemAggregatorService(
    IWorkQueue<TContext> destination
)
Public Sub New (
    destination As IWorkQueue(Of TContext)
)
Public Sub New (
    destination As IWorkQueue(Of TContext)
)
public:
WorkItemAggregatorService(
    IWorkQueue<TContext>^ destination
)
public:
WorkItemAggregatorService(
    IWorkQueue<TContext>^ destination
)
new :
        destination : IWorkQueue<'TContext> -> WorkItemAggregatorService
new :
        destination : IWorkQueue<'TContext> -> WorkItemAggregatorService

Parameters

destination
Type: NFX.ServiceModel IWorkQueue TContext
See Also
WorkItemAggregatorService TContext Class
WorkItemAggregatorService TContext Members
NFX.ServiceModel Namespace


WorkItemAggregatorService(TContext) Methods

WorkItemAggregatorService TContext Methods NFX Class Library

The WorkItemAggregatorService TContext type exposes the following members.
Methods
 | Name | Description
Protected method | ____ObtainPrivateServiceStatusLockObject | WARNING: Developers never call this method!!! It is used by advanced derived implementations that need to synchronize status updates. We do not want to make statuslock protected as it is almost never needed, hence this accessor (Inherited from Service.)
Protected method | __setComponentDirector | (Inherited from ApplicationComponent.)
Protected method | AbortStart | Allows to abort unsuccessful DoStart() overridden implementation. This method must be called from within DoStart() (Inherited from Service.)
Public method | AcceptManagerVisit | Accepts a visit of a manager entity - this call is useful for periodic updates of service status, i.e. when service does not have a thread of its own it can be periodically managed by some other service through this method. The default implementation of DoAcceptManagerVisit(object, DateTime) does nothing (Inherited from Service.)
Public method | CheckForCompleteStop | Non-blocking call that returns true when the service instance has completely stopped after SignalStop() (Inherited from Service.)
Protected method | CheckServiceActive | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceActiveOrStarting | Checks for service activity and throws exception if service is not in ControlStatus.Active state (Inherited from Service.)
Protected method | CheckServiceInactive | Checks for service inactivity and throws exception if service is running (started, starting or stopping) (Inherited from Service.)
Public method | Configure | Configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | Destructor | (Overrides Service Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoAcceptManagerVisit | Accepts a visit from external manager. Base implementation does nothing. Override in services that need external management calls to update their state periodically, i.e. when they don't have a thread on their own (Inherited from Service.)
Protected method | DoCheckForCompleteStop | Provides implementation for checking whether the service has completely stopped (Inherited from Service.)
Protected method | DoConfigure | Provides implementation that configures service from configuration node (and possibly it's sub-nodes) (Inherited from Service.)
Protected method | DoSignalStop | (Overrides Service DoSignalStop .)
Protected method | DoStart | (Overrides Service DoStart .)
Protected method | DoWaitForCompleteStop | (Overrides Service DoWaitForCompleteStop .)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | LocalizedTimeToUniversalTime | Converts localized time to UTC time as of TimeLocation property (Inherited from Service.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PostItem | Posts work item in the service. This item may not be posted into destination if the same item was already recently posted into destination queue, however if no same work item will come within timeout, then this item will eventually post
Public method | SignalStop | Non-blocking call that initiates the stopping of the service (Inherited from Service.)
Public method | Start | Blocking call that starts the service instance (Inherited from Service.)
Protected method | StartByApplication | Blocking call that starts the service instance (Inherited from Service.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UniversalTimeToLocalizedTime | Converts universal time to local time as of TimeLocation property (Inherited from Service.)
Public method | WaitForCompleteStop | Blocks execution of current thread until this service has completely stopped (Inherited from Service.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WorkItemAggregatorService TContext Class
NFX.ServiceModel Namespace


WorkItemAggregatorService(TContext).Destructor Method

WorkItemAggregatorService TContext Destructor Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
WorkItemAggregatorService TContext Class
WorkItemAggregatorService TContext Members
NFX.ServiceModel Namespace


WorkItemAggregatorService(TContext).DoSignalStop Method

WorkItemAggregatorService TContext DoSignalStop Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoSignalStop()
protected override void DoSignalStop()
Protected Overrides Sub DoSignalStop
Protected Overrides Sub DoSignalStop
protected:
virtual void DoSignalStop() override
protected:
virtual void DoSignalStop() override
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
abstract DoSignalStop : unit -> unit
override DoSignalStop : unit -> unit
See Also
WorkItemAggregatorService TContext Class
WorkItemAggregatorService TContext Members
NFX.ServiceModel Namespace


WorkItemAggregatorService(TContext).DoStart Method

WorkItemAggregatorService TContext DoStart Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoStart()
protected override void DoStart()
Protected Overrides Sub DoStart
Protected Overrides Sub DoStart
protected:
virtual void DoStart() override
protected:
virtual void DoStart() override
abstract DoStart : unit -> unit
override DoStart : unit -> unit
abstract DoStart : unit -> unit
override DoStart : unit -> unit
See Also
WorkItemAggregatorService TContext Class
WorkItemAggregatorService TContext Members
NFX.ServiceModel Namespace


WorkItemAggregatorService(TContext).DoWaitForCompleteStop Method

WorkItemAggregatorService TContext DoWaitForCompleteStop Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void DoWaitForCompleteStop()
protected override void DoWaitForCompleteStop()
Protected Overrides Sub DoWaitForCompleteStop
Protected Overrides Sub DoWaitForCompleteStop
protected:
virtual void DoWaitForCompleteStop() override
protected:
virtual void DoWaitForCompleteStop() override
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
abstract DoWaitForCompleteStop : unit -> unit
override DoWaitForCompleteStop : unit -> unit
See Also
WorkItemAggregatorService TContext Class
WorkItemAggregatorService TContext Members
NFX.ServiceModel Namespace


WorkItemAggregatorService(TContext).PostItem Method

WorkItemAggregatorService TContext PostItem Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Posts work item in the service. This item may not be posted into destination if the same item was already recently posted into destination queue, however if no same work item will come within timeout, then this item will eventually post

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void PostItem(
    IWorkItem<TContext> work
)
public void PostItem(
    IWorkItem<TContext> work
)
Public Sub PostItem (
    work As IWorkItem(Of TContext)
)
Public Sub PostItem (
    work As IWorkItem(Of TContext)
)
public:
virtual void PostItem(
    IWorkItem<TContext>^ work
) sealed
public:
virtual void PostItem(
    IWorkItem<TContext>^ work
) sealed
abstract PostItem :
        work : IWorkItem<'TContext> -> unit
override PostItem :
        work : IWorkItem<'TContext> -> unit
abstract PostItem :
        work : IWorkItem<'TContext> -> unit
override PostItem :
        work : IWorkItem<'TContext> -> unit

Parameters

work
Type: NFX.ServiceModel IWorkItem TContext

Implements

IWorkQueue TContext PostItem(IWorkItem TContext )
See Also
WorkItemAggregatorService TContext Class
WorkItemAggregatorService TContext Members
NFX.ServiceModel Namespace


WorkItemAggregatorService(TContext) Properties

WorkItemAggregatorService TContext Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The WorkItemAggregatorService TContext type exposes the following members.
Properties
 | Name | Description
Public property | ApplicationDontAutoStartService | Checks whether the class is decorated with ApplicationDontAutoStartServiceAttribute (Inherited from Service.)
Public property | ComponentCommonName | Returns the common name used to identify the component, for example "Glue" for various IGlue implementations. This name is searched-by some management tools that allow to find component by this name that does not change between application restarts like ComponentSID does. Subordinate (non-root) components return null (Inherited from ApplicationComponent.)
Public property | ComponentDirector | Returns a reference to an object that this app component services/operates under, or null (Inherited from ApplicationComponent.)
Public property | ComponentSID | Returns process/instance unique app component system id (Inherited from ApplicationComponent.)
Public property | ComponentStartTime | Returns local computer time of component start (not from application container time) (Inherited from ApplicationComponent.)
Public property | Context |
Public property | DestinationPostInterval | Defines an interval measured in milliseconds for posting into destination queue
Public property | DestinationQueue | Returns the destination queue
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | LocalizedTime | Returns current time localized per TimeLocation (Inherited from Service.)
Public property | Name | Provides textual name for the service (Inherited from Service.)
Public property | ProcessedFailureCount |
Public property | ProcessedSuccessCount |
Public property | Running | Returns true when service is active or about to become active. Check in service implementation loops/threads/tasks (Inherited from Service.)
Public property | Status | Current service status (Inherited from Service.)
Public property | TimeLocation | Returns time location of this LocalizedTimeProvider implementation (Inherited from Service.)
Back to Top
See Also
WorkItemAggregatorService TContext Class
NFX.ServiceModel Namespace


WorkItemAggregatorService(TContext).Context Property

WorkItemAggregatorService TContext Context Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TContext Context { get; }
public TContext Context { get; }
Public ReadOnly Property Context As TContext
    Get
Public ReadOnly Property Context As TContext
    Get
public:
virtual property TContext Context {
    TContext get () sealed;
}
public:
virtual property TContext Context {
    TContext get () sealed;
}
abstract Context : 'TContext with get
override Context : 'TContext with get
abstract Context : 'TContext with get
override Context : 'TContext with get

Property Value

Type: TContext

Implements

IWorkQueue TContext Context
See Also
WorkItemAggregatorService TContext Class
WorkItemAggregatorService TContext Members
NFX.ServiceModel Namespace


WorkItemAggregatorService(TContext).DestinationPostInterval Property

WorkItemAggregatorService TContext DestinationPostInterval Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Defines an interval measured in milliseconds for posting into destination queue

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int DestinationPostInterval { get; set; }
public int DestinationPostInterval { get; set; }
Public Property DestinationPostInterval As Integer
    Get
    Set
Public Property DestinationPostInterval As Integer
    Get
    Set
public:
property int DestinationPostInterval {
    int get ();
    void set (int value);
}
public:
property int DestinationPostInterval {
    int get ();
    void set (int value);
}
member DestinationPostInterval : int with get, set
member DestinationPostInterval : int with get, set

Property Value

Type: Online Int32
See Also
WorkItemAggregatorService TContext Class
WorkItemAggregatorService TContext Members
NFX.ServiceModel Namespace


WorkItemAggregatorService(TContext).DestinationQueue Property

WorkItemAggregatorService TContext DestinationQueue Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns the destination queue

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IWorkQueue<TContext> DestinationQueue { get; }
public IWorkQueue<TContext> DestinationQueue { get; }
Public ReadOnly Property DestinationQueue As IWorkQueue(Of TContext)
    Get
Public ReadOnly Property DestinationQueue As IWorkQueue(Of TContext)
    Get
public:
property IWorkQueue<TContext>^ DestinationQueue {
    IWorkQueue<TContext>^ get ();
}
public:
property IWorkQueue<TContext>^ DestinationQueue {
    IWorkQueue<TContext>^ get ();
}
member DestinationQueue : IWorkQueue<'TContext> with get
member DestinationQueue : IWorkQueue<'TContext> with get

Property Value

Type: IWorkQueue TContext
See Also
WorkItemAggregatorService TContext Class
WorkItemAggregatorService TContext Members
NFX.ServiceModel Namespace


WorkItemAggregatorService(TContext).ProcessedFailureCount Property

WorkItemAggregatorService TContext ProcessedFailureCount Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long ProcessedFailureCount { get; }
public long ProcessedFailureCount { get; }
Public ReadOnly Property ProcessedFailureCount As Long
    Get
Public ReadOnly Property ProcessedFailureCount As Long
    Get
public:
virtual property long long ProcessedFailureCount {
    long long get () sealed;
}
public:
virtual property long long ProcessedFailureCount {
    long long get () sealed;
}
abstract ProcessedFailureCount : int64 with get
override ProcessedFailureCount : int64 with get
abstract ProcessedFailureCount : int64 with get
override ProcessedFailureCount : int64 with get

Property Value

Type: Online Int64

Implements

IWorkQueue TContext ProcessedFailureCount
See Also
WorkItemAggregatorService TContext Class
WorkItemAggregatorService TContext Members
NFX.ServiceModel Namespace


WorkItemAggregatorService(TContext).ProcessedSuccessCount Property

WorkItemAggregatorService TContext ProcessedSuccessCount Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long ProcessedSuccessCount { get; }
public long ProcessedSuccessCount { get; }
Public ReadOnly Property ProcessedSuccessCount As Long
    Get
Public ReadOnly Property ProcessedSuccessCount As Long
    Get
public:
virtual property long long ProcessedSuccessCount {
    long long get () sealed;
}
public:
virtual property long long ProcessedSuccessCount {
    long long get () sealed;
}
abstract ProcessedSuccessCount : int64 with get
override ProcessedSuccessCount : int64 with get
abstract ProcessedSuccessCount : int64 with get
override ProcessedSuccessCount : int64 with get

Property Value

Type: Online Int64

Implements

IWorkQueue TContext ProcessedSuccessCount
See Also
WorkItemAggregatorService TContext Class
WorkItemAggregatorService TContext Members
NFX.ServiceModel Namespace


WorkItemList(TContext) Class

WorkItemList TContext Class NFX Class Library

Inheritance Hierarchy
Online System Object
Online System.Collections.Generic LinkedList IWorkItem TContext
NFX.ServiceModel WorkItemList TContext

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal class WorkItemList<TContext> : LinkedList<IWorkItem<TContext>>
where TContext : class
internal class WorkItemList<TContext> : LinkedList<IWorkItem<TContext>>
where TContext : class
Friend Class WorkItemList(Of TContext As Class)
    Inherits LinkedList(Of IWorkItem(Of TContext))
Friend Class WorkItemList(Of TContext As Class)
    Inherits LinkedList(Of IWorkItem(Of TContext))
generic<typename TContext>
where TContext : ref class
internal ref class WorkItemList : public LinkedList<IWorkItem<TContext>^>
generic<typename TContext>
where TContext : ref class
internal ref class WorkItemList : public LinkedList<IWorkItem<TContext>^>
type WorkItemList<'TContext when 'TContext : not struct> =
    class
        inherit LinkedList<IWorkItem<'TContext>>
    end
type WorkItemList<'TContext when 'TContext : not struct> =
    class
        inherit LinkedList<IWorkItem<'TContext>>
    end
Type Parameters
TContext
See Also
WorkItemList TContext Members
NFX.ServiceModel Namespace


WorkItemList(TContext) Members

WorkItemList TContext Members NFX Class Library

The WorkItemList TContext type exposes the following members.
Constructors
 | Name | Description
Public method | WorkItemList TContext | Initializes a new instance of the WorkItemList TContext class
Back to Top
Methods
 | Name | Description
Public method | Online AddAfter(LinkedListNode T , T) | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online AddAfter(LinkedListNode T , LinkedListNode T ) | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online AddBefore(LinkedListNode T , T) | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online AddBefore(LinkedListNode T , LinkedListNode T ) | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online AddFirst(T) | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online AddFirst(LinkedListNode T ) | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online AddLast(T) | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online AddLast(LinkedListNode T ) | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online Clear | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online Contains | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online CopyTo | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online FindLast | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online GetEnumerator | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online LinkedList T instance. (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online Remove(T) | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online Remove(LinkedListNode T ) | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online RemoveFirst | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online RemoveLast | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online Count | (Inherited from Online LinkedList IWorkItem TContext .)
Public property | Online First | (Inherited from Online LinkedList IWorkItem TContext .)
Public property | Online Last | (Inherited from Online LinkedList IWorkItem TContext .)
Back to Top
See Also
WorkItemList TContext Class
NFX.ServiceModel Namespace


WorkItemList(TContext) Constructor

WorkItemList TContext Constructor NFX Class Library

Initializes a new instance of the WorkItemList TContext class

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WorkItemList()
public WorkItemList()
Public Sub New
Public Sub New
public:
WorkItemList()
public:
WorkItemList()
new : unit -> WorkItemList
new : unit -> WorkItemList
See Also
WorkItemList TContext Class
WorkItemList TContext Members
NFX.ServiceModel Namespace


WorkItemList(TContext) Methods

WorkItemList TContext Methods NFX Class Library

The WorkItemList TContext type exposes the following members.
Methods
 | Name | Description
Public method | Online AddAfter(LinkedListNode T , T) | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online AddAfter(LinkedListNode T , LinkedListNode T ) | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online AddBefore(LinkedListNode T , T) | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online AddBefore(LinkedListNode T , LinkedListNode T ) | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online AddFirst(T) | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online AddFirst(LinkedListNode T ) | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online AddLast(T) | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online AddLast(LinkedListNode T ) | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online Clear | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online Contains | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online CopyTo | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online Find | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online FindLast | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online GetEnumerator | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online LinkedList T instance. (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online Remove(T) | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online Remove(LinkedListNode T ) | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online RemoveFirst | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online RemoveLast | (Inherited from Online LinkedList IWorkItem TContext .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WorkItemList TContext Class
NFX.ServiceModel Namespace


WorkItemList(TContext) Properties

WorkItemList TContext Properties NFX Class Library

The WorkItemList TContext type exposes the following members.
Properties
 | Name | Description
Public property | Online Count | (Inherited from Online LinkedList IWorkItem TContext .)
Public property | Online First | (Inherited from Online LinkedList IWorkItem TContext .)
Public property | Online Last | (Inherited from Online LinkedList IWorkItem TContext .)
Back to Top
See Also
WorkItemList TContext Class
NFX.ServiceModel Namespace


WorkQueue(TContext) Class

WorkQueue TContext Class NFX Class Library

Maintains a queue of pending work - every WorkItem posting in the queue will be executed by the host of the queue. WorkQueues are useful for coordination of complex data/event flows in multi-threaded/service applications
Inheritance Hierarchy
Online System Object
NFX.ServiceModel WorkQueue TContext

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class WorkQueue<TContext> : IWorkQueue<TContext>
where TContext : class
public class WorkQueue<TContext> : IWorkQueue<TContext>
where TContext : class
Public Class WorkQueue(Of TContext As Class)
    Implements IWorkQueue(Of TContext)
Public Class WorkQueue(Of TContext As Class)
    Implements IWorkQueue(Of TContext)
generic<typename TContext>
where TContext : ref class
public ref class WorkQueue : IWorkQueue<TContext>
generic<typename TContext>
where TContext : ref class
public ref class WorkQueue : IWorkQueue<TContext>
type WorkQueue<'TContext when 'TContext : not struct> =
    class
        interface IWorkQueue<'TContext>
    end
type WorkQueue<'TContext when 'TContext : not struct> =
    class
        interface IWorkQueue<'TContext>
    end
Type Parameters
TContext
See Also
WorkQueue TContext Members
NFX.ServiceModel Namespace


WorkQueue(TContext) Members

WorkQueue TContext Members NFX Class Library

The WorkQueue TContext type exposes the following members.
Constructors
 | Name | Description
Public method | WorkQueue TContext (TContext) | Creates an instance of work queue in particular context
Public method | WorkQueue TContext (TContext, PostItemFilter TContext ) | Creates an instance of work queue in particular context with specific woprk item post filter
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FetchDueItem | Takes due item off the queue without executing it and returns it, or returns null when queue is empty.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PostItem | Posts work item into the queue in natural queue order (at the end of the queue)
Public method | ProcessDueItem | Processes item in normal queue order (the item that is due to be processed). Returns true when there was an item in the queue. This method does not leak exceptions from work performance unless they are re-thrown by particular work item WorkFailed(error)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Context | Returns context that work is processed in
Public property | PendingCount | Returns pending number of work items
Public property | ProcessedFailureCount | Returns total number of work items processed with errors by this queue since its creation
Public property | ProcessedSuccessCount | Returns total number of work items processed without errors by this queue since its creation
Public property | ProcessedTotalCount | Returns total number of work items processed with or without errors by this queue since its creation
Back to Top
See Also
WorkQueue TContext Class
NFX.ServiceModel Namespace


WorkQueue(TContext) Constructor

WorkQueue TContext Constructor NFX Class Library

Overload List
 | Name | Description
Public method | WorkQueue TContext (TContext) | Creates an instance of work queue in particular context
Public method | WorkQueue TContext (TContext, PostItemFilter TContext ) | Creates an instance of work queue in particular context with specific woprk item post filter
Back to Top
See Also
WorkQueue TContext Class
WorkQueue TContext Members
NFX.ServiceModel Namespace


WorkQueue(TContext) Constructor (TContext)

WorkQueue TContext Constructor (TContext) NFX Class Library

Creates an instance of work queue in particular context

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WorkQueue(
    TContext context
)
public WorkQueue(
    TContext context
)
Public Sub New (
    context As TContext
)
Public Sub New (
    context As TContext
)
public:
WorkQueue(
    TContext context
)
public:
WorkQueue(
    TContext context
)
new :
        context : 'TContext -> WorkQueue
new :
        context : 'TContext -> WorkQueue

Parameters

context
Type: TContext
See Also
WorkQueue TContext Class
WorkQueue TContext Members
WorkQueue TContext Overload
NFX.ServiceModel Namespace


WorkQueue(TContext) Constructor (TContext, PostItemFilter(TContext))

WorkQueue TContext Constructor (TContext, PostItemFilter TContext ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Creates an instance of work queue in particular context with specific woprk item post filter

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public WorkQueue(
    TContext context,
    PostItemFilter<TContext> filter
)
public WorkQueue(
    TContext context,
    PostItemFilter<TContext> filter
)
Public Sub New (
    context As TContext,
    filter As PostItemFilter(Of TContext)
)
Public Sub New (
    context As TContext,
    filter As PostItemFilter(Of TContext)
)
public:
WorkQueue(
    TContext context,
    PostItemFilter<TContext>^ filter
)
public:
WorkQueue(
    TContext context,
    PostItemFilter<TContext>^ filter
)
new :
        context : 'TContext *
        filter : PostItemFilter<'TContext> -> WorkQueue
new :
        context : 'TContext *
        filter : PostItemFilter<'TContext> -> WorkQueue

Parameters

context
Type: TContext
filter
Type: NFX.ServiceModel PostItemFilter TContext
See Also
WorkQueue TContext Class
WorkQueue TContext Members
WorkQueue TContext Overload
NFX.ServiceModel Namespace


WorkQueue(TContext) Methods

WorkQueue TContext Methods NFX Class Library

The WorkQueue TContext type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | FetchDueItem | Takes due item off the queue without executing it and returns it, or returns null when queue is empty.
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | PostItem | Posts work item into the queue in natural queue order (at the end of the queue)
Public method | ProcessDueItem | Processes item in normal queue order (the item that is due to be processed). Returns true when there was an item in the queue. This method does not leak exceptions from work performance unless they are re-thrown by particular work item WorkFailed(error)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
WorkQueue TContext Class
NFX.ServiceModel Namespace


WorkQueue(TContext).FetchDueItem Method

WorkQueue TContext FetchDueItem Method NFX Class Library

Takes due item off the queue without executing it and returns it, or returns null when queue is empty.

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IWorkItem<TContext> FetchDueItem()
public IWorkItem<TContext> FetchDueItem()
Public Function FetchDueItem As IWorkItem(Of TContext)
Public Function FetchDueItem As IWorkItem(Of TContext)
public:
IWorkItem<TContext>^ FetchDueItem()
public:
IWorkItem<TContext>^ FetchDueItem()
member FetchDueItem : unit -> IWorkItem<'TContext>
member FetchDueItem : unit -> IWorkItem<'TContext>

Return Value

Type: IWorkItem TContext
See Also
WorkQueue TContext Class
WorkQueue TContext Members
NFX.ServiceModel Namespace


WorkQueue(TContext).PostItem Method

WorkQueue TContext PostItem Method NFX Class Library

Posts work item into the queue in natural queue order (at the end of the queue)

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void PostItem(
    IWorkItem<TContext> work
)
public void PostItem(
    IWorkItem<TContext> work
)
Public Sub PostItem (
    work As IWorkItem(Of TContext)
)
Public Sub PostItem (
    work As IWorkItem(Of TContext)
)
public:
virtual void PostItem(
    IWorkItem<TContext>^ work
) sealed
public:
virtual void PostItem(
    IWorkItem<TContext>^ work
) sealed
abstract PostItem :
        work : IWorkItem<'TContext> -> unit
override PostItem :
        work : IWorkItem<'TContext> -> unit
abstract PostItem :
        work : IWorkItem<'TContext> -> unit
override PostItem :
        work : IWorkItem<'TContext> -> unit

Parameters

work
Type: NFX.ServiceModel IWorkItem TContext

Implements

IWorkQueue TContext PostItem(IWorkItem TContext )
See Also
WorkQueue TContext Class
WorkQueue TContext Members
NFX.ServiceModel Namespace


WorkQueue(TContext).ProcessDueItem Method

WorkQueue TContext ProcessDueItem Method NFX Class Library

Processes item in normal queue order (the item that is due to be processed). Returns true when there was an item in the queue. This method does not leak exceptions from work performance unless they are re-thrown by particular work item WorkFailed(error)

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ProcessDueItem()
public bool ProcessDueItem()
Public Function ProcessDueItem As Boolean
Public Function ProcessDueItem As Boolean
public:
bool ProcessDueItem()
public:
bool ProcessDueItem()
member ProcessDueItem : unit -> bool
member ProcessDueItem : unit -> bool

Return Value

Type: Online Boolean
See Also
WorkQueue TContext Class
WorkQueue TContext Members
NFX.ServiceModel Namespace


WorkQueue(TContext) Properties

WorkQueue TContext Properties NFX Class Library

The WorkQueue TContext type exposes the following members.
Properties
 | Name | Description
Public property | Context | Returns context that work is processed in
Public property | PendingCount | Returns pending number of work items
Public property | ProcessedFailureCount | Returns total number of work items processed with errors by this queue since its creation
Public property | ProcessedSuccessCount | Returns total number of work items processed without errors by this queue since its creation
Public property | ProcessedTotalCount | Returns total number of work items processed with or without errors by this queue since its creation
Back to Top
See Also
WorkQueue TContext Class
NFX.ServiceModel Namespace


WorkQueue(TContext).Context Property

WorkQueue TContext Context Property NFX Class Library

Returns context that work is processed in

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TContext Context { get; }
public TContext Context { get; }
Public ReadOnly Property Context As TContext
    Get
Public ReadOnly Property Context As TContext
    Get
public:
virtual property TContext Context {
    TContext get () sealed;
}
public:
virtual property TContext Context {
    TContext get () sealed;
}
abstract Context : 'TContext with get
override Context : 'TContext with get
abstract Context : 'TContext with get
override Context : 'TContext with get

Property Value

Type: TContext

Implements

IWorkQueue TContext Context
See Also
WorkQueue TContext Class
WorkQueue TContext Members
NFX.ServiceModel Namespace


WorkQueue(TContext).PendingCount Property

WorkQueue TContext PendingCount Property NFX Class Library

Returns pending number of work items

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int PendingCount { get; }
public int PendingCount { get; }
Public ReadOnly Property PendingCount As Integer
    Get
Public ReadOnly Property PendingCount As Integer
    Get
public:
property int PendingCount {
    int get ();
}
public:
property int PendingCount {
    int get ();
}
member PendingCount : int with get
member PendingCount : int with get

Property Value

Type: Online Int32
See Also
WorkQueue TContext Class
WorkQueue TContext Members
NFX.ServiceModel Namespace


WorkQueue(TContext).ProcessedFailureCount Property

WorkQueue TContext ProcessedFailureCount Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns total number of work items processed with errors by this queue since its creation

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long ProcessedFailureCount { get; }
public long ProcessedFailureCount { get; }
Public ReadOnly Property ProcessedFailureCount As Long
    Get
Public ReadOnly Property ProcessedFailureCount As Long
    Get
public:
virtual property long long ProcessedFailureCount {
    long long get () sealed;
}
public:
virtual property long long ProcessedFailureCount {
    long long get () sealed;
}
abstract ProcessedFailureCount : int64 with get
override ProcessedFailureCount : int64 with get
abstract ProcessedFailureCount : int64 with get
override ProcessedFailureCount : int64 with get

Property Value

Type: Online Int64

Implements

IWorkQueue TContext ProcessedFailureCount
See Also
WorkQueue TContext Class
WorkQueue TContext Members
NFX.ServiceModel Namespace


WorkQueue(TContext).ProcessedSuccessCount Property

WorkQueue TContext ProcessedSuccessCount Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns total number of work items processed without errors by this queue since its creation

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long ProcessedSuccessCount { get; }
public long ProcessedSuccessCount { get; }
Public ReadOnly Property ProcessedSuccessCount As Long
    Get
Public ReadOnly Property ProcessedSuccessCount As Long
    Get
public:
virtual property long long ProcessedSuccessCount {
    long long get () sealed;
}
public:
virtual property long long ProcessedSuccessCount {
    long long get () sealed;
}
abstract ProcessedSuccessCount : int64 with get
override ProcessedSuccessCount : int64 with get
abstract ProcessedSuccessCount : int64 with get
override ProcessedSuccessCount : int64 with get

Property Value

Type: Online Int64

Implements

IWorkQueue TContext ProcessedSuccessCount
See Also
WorkQueue TContext Class
WorkQueue TContext Members
NFX.ServiceModel Namespace


WorkQueue(TContext).ProcessedTotalCount Property

WorkQueue TContext ProcessedTotalCount Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns total number of work items processed with or without errors by this queue since its creation

Namespace: NFX.ServiceModel
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public long ProcessedTotalCount { get; }
public long ProcessedTotalCount { get; }
Public ReadOnly Property ProcessedTotalCount As Long
    Get
Public ReadOnly Property ProcessedTotalCount As Long
    Get
public:
property long long ProcessedTotalCount {
    long long get ();
}
public:
property long long ProcessedTotalCount {
    long long get ();
}
member ProcessedTotalCount : int64 with get
member ProcessedTotalCount : int64 with get

Property Value

Type: Online Int64
See Also
WorkQueue TContext Class
WorkQueue TContext Members
NFX.ServiceModel Namespace


NFX.Standards Namespace

NFX.Standards Namespace NFX Class Library

Classes
 | Class | Description
Public class | Countries_ISO3166_1 | Performs mapping and normalization of ISO country codes between 2 and 3 digit form, for examle 'US' and 'USA'
Structures
 | Structure | Description
Public structure | Distance | Represents length distance with unit type. All operations are done with presision of 1 micrometer (10^(-3) mm)
Public structure | Weight | Represents weight with unit type. All operations are done with presision of 1 milligramm
Enumerations
 | Enumeration | Description
Public enumeration | Distance UnitType |
Public enumeration | Weight UnitType |


Countries_ISO3166_1 Class

Countries_ISO3166_1 Class NFX Class Library

Performs mapping and normalization of ISO country codes between 2 and 3 digit form, for examle 'US' and 'USA'
Inheritance Hierarchy
Online System Object
NFX.Standards Countries_ISO3166_1

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class Countries_ISO3166_1
public static class Countries_ISO3166_1
Public NotInheritable Class Countries_ISO3166_1
Public NotInheritable Class Countries_ISO3166_1
public ref class Countries_ISO3166_1 abstract sealed
public ref class Countries_ISO3166_1 abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Countries_ISO3166_1 =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Countries_ISO3166_1 =  class end
See Also
Countries_ISO3166_1 Members
NFX.Standards Namespace


Countries_ISO3166_1 Members

Countries_ISO3166_1 Members NFX Class Library

The Countries_ISO3166_1 type exposes the following members.
Methods
Name | Description
Normalize2 |
Normalize3 |
ToAlpha2 |
ToAlpha3 |
Back to Top
See Also
Countries_ISO3166_1 Class
NFX.Standards Namespace


Countries_ISO3166_1 Methods

Countries_ISO3166_1 Methods NFX Class Library

The Countries_ISO3166_1 type exposes the following members.
Methods
Name | Description
Normalize2 |
Normalize3 |
ToAlpha2 |
ToAlpha3 |
Back to Top
See Also
Countries_ISO3166_1 Class
NFX.Standards Namespace


Countries_ISO3166_1.Normalize2 Method

Countries_ISO3166_1 Normalize2 Method NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Normalize2(
    string code,
    string def = null
)
public static string Normalize2(
    string code,
    string def = null
)
Public Shared Function Normalize2 (
    code As String,
    Optional def As String = Nothing
) As String
Public Shared Function Normalize2 (
    code As String,
    Optional def As String = Nothing
) As String
public:
static String^ Normalize2(
    String^ code,
    String^ def = nullptr
)
public:
static String^ Normalize2(
    String^ code,
    String^ def = nullptr
)
static member Normalize2 :
        code : string *
        ?def : string
(* Defaults:
        let _def = defaultArg def null
*)
-> string
static member Normalize2 :
        code : string *
        ?def : string
(* Defaults:
        let _def = defaultArg def null
*)
-> string

Parameters

code
Type: Online System String
def (Optional)
Type: Online System String

Return Value

Type: Online String
See Also
Countries_ISO3166_1 Class
Countries_ISO3166_1 Members
NFX.Standards Namespace


Countries_ISO3166_1.Normalize3 Method

Countries_ISO3166_1 Normalize3 Method NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string Normalize3(
    string code,
    string def = null
)
public static string Normalize3(
    string code,
    string def = null
)
Public Shared Function Normalize3 (
    code As String,
    Optional def As String = Nothing
) As String
Public Shared Function Normalize3 (
    code As String,
    Optional def As String = Nothing
) As String
public:
static String^ Normalize3(
    String^ code,
    String^ def = nullptr
)
public:
static String^ Normalize3(
    String^ code,
    String^ def = nullptr
)
static member Normalize3 :
        code : string *
        ?def : string
(* Defaults:
        let _def = defaultArg def null
*)
-> string
static member Normalize3 :
        code : string *
        ?def : string
(* Defaults:
        let _def = defaultArg def null
*)
-> string

Parameters

code
Type: Online System String
def (Optional)
Type: Online System String

Return Value

Type: Online String
See Also
Countries_ISO3166_1 Class
Countries_ISO3166_1 Members
NFX.Standards Namespace


Countries_ISO3166_1.ToAlpha2 Method

Countries_ISO3166_1 ToAlpha2 Method NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ToAlpha2(
    string alpha3,
    string def = null
)
public static string ToAlpha2(
    string alpha3,
    string def = null
)
Public Shared Function ToAlpha2 (
    alpha3 As String,
    Optional def As String = Nothing
) As String
Public Shared Function ToAlpha2 (
    alpha3 As String,
    Optional def As String = Nothing
) As String
public:
static String^ ToAlpha2(
    String^ alpha3,
    String^ def = nullptr
)
public:
static String^ ToAlpha2(
    String^ alpha3,
    String^ def = nullptr
)
static member ToAlpha2 :
        alpha3 : string *
        ?def : string
(* Defaults:
        let _def = defaultArg def null
*)
-> string
static member ToAlpha2 :
        alpha3 : string *
        ?def : string
(* Defaults:
        let _def = defaultArg def null
*)
-> string

Parameters

alpha3
Type: Online System String
def (Optional)
Type: Online System String

Return Value

Type: Online String
See Also
Countries_ISO3166_1 Class
Countries_ISO3166_1 Members
NFX.Standards Namespace


Countries_ISO3166_1.ToAlpha3 Method

Countries_ISO3166_1 ToAlpha3 Method NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string ToAlpha3(
    string alpha2,
    string def = null
)
public static string ToAlpha3(
    string alpha2,
    string def = null
)
Public Shared Function ToAlpha3 (
    alpha2 As String,
    Optional def As String = Nothing
) As String
Public Shared Function ToAlpha3 (
    alpha2 As String,
    Optional def As String = Nothing
) As String
public:
static String^ ToAlpha3(
    String^ alpha2,
    String^ def = nullptr
)
public:
static String^ ToAlpha3(
    String^ alpha2,
    String^ def = nullptr
)
static member ToAlpha3 :
        alpha2 : string *
        ?def : string
(* Defaults:
        let _def = defaultArg def null
*)
-> string
static member ToAlpha3 :
        alpha2 : string *
        ?def : string
(* Defaults:
        let _def = defaultArg def null
*)
-> string

Parameters

alpha2
Type: Online System String
def (Optional)
Type: Online System String

Return Value

Type: Online String
See Also
Countries_ISO3166_1 Class
Countries_ISO3166_1 Members
NFX.Standards Namespace


Distance Structure

Distance Structure NFX Class Library

Represents length distance with unit type. All operations are done with presision of 1 micrometer (10^(-3) mm)

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct Distance : IEquatable<Distance>,
    IComparable<Distance>, IJSONWritable, IFormattable
public struct Distance : IEquatable<Distance>,
    IComparable<Distance>, IJSONWritable, IFormattable
Public Structure Distance
    Implements IEquatable(Of Distance), IComparable(Of Distance),
    IJSONWritable, IFormattable
Public Structure Distance
    Implements IEquatable(Of Distance), IComparable(Of Distance),
    IJSONWritable, IFormattable
public value class Distance : IEquatable<Distance>,
    IComparable<Distance>, IJSONWritable, IFormattable
public value class Distance : IEquatable<Distance>,
    IComparable<Distance>, IJSONWritable, IFormattable
[<SealedAttribute>]
type Distance =
    struct
        interface IEquatable<Distance>
        interface IComparable<Distance>
        interface IJSONWritable
        interface IFormattable
    end
[<SealedAttribute>]
type Distance =
    struct
        interface IEquatable<Distance>
        interface IComparable<Distance>
        interface IJSONWritable
        interface IFormattable
    end
See Also
Distance Members
NFX.Standards Namespace


Distance Members

Distance Members NFX Class Library

The Distance type exposes the following members.
Constructors
 | Name | Description
Public method | Distance | Initializes a new instance of the Distance class
Back to Top
Methods
 | Name | Description
Public method | CompareTo |
Public method | Convert |
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(Distance) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Parse |
Public method | ToString | (Overrides Online ValueType ToString .)
Public method | ToString(String, IFormatProvider) |
 | TryParse |
Public method | ValueIn |
Public method | WriteAsJSON |
Back to Top
Operators
Name | Description
Addition |
Division |
Equality |
GreaterThan |
GreaterThanOrEqual |
Inequality |
LessThan |
LessThanOrEqual |
Multiply |
Subtraction |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | MM_IN_CM |
 | MM_IN_FT |
 | MM_IN_IN |
 | MM_IN_M |
 | MM_IN_YD |
Public field | Unit |
Public field | Value |
 | VALUE_PRECISION |
Public field | ValueInMm |
Back to Top
Properties
 | Name | Description
Public property | UnitName |
Back to Top
See Also
Distance Structure
NFX.Standards Namespace


Distance Constructor

Distance Constructor NFX Class Library

Initializes a new instance of the Distance class

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Distance(
    decimal value,
    Distance..::..UnitType unit
)
public Distance(
    decimal value,
    Distance..::..UnitType unit
)
Public Sub New (
    value As Decimal,
    unit As Distance..::..UnitType
)
Public Sub New (
    value As Decimal,
    unit As Distance..::..UnitType
)
public:
Distance(
    Decimal value,
    Distance..::..UnitType unit
)
public:
Distance(
    Decimal value,
    Distance..::..UnitType unit
)
new :
        value : decimal *
        unit : Distance..::..UnitType -> Distance
new :
        value : decimal *
        unit : Distance..::..UnitType -> Distance

Parameters

value
Type: Online System Decimal
unit
Type: NFX.Standards Distance UnitType
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance Fields

Distance Fields NFX Class Library

The Distance type exposes the following members.
Fields
 | Name | Description
 | MM_IN_CM |
 | MM_IN_FT |
 | MM_IN_IN |
 | MM_IN_M |
 | MM_IN_YD |
Public field | Unit |
Public field | Value |
 | VALUE_PRECISION |
Public field | ValueInMm |
Back to Top
See Also
Distance Structure
NFX.Standards Namespace


Distance.MM_IN_CM Field

Distance MM_IN_CM Field NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly decimal MM_IN_CM
public static readonly decimal MM_IN_CM
Public Shared ReadOnly MM_IN_CM As Decimal
Public Shared ReadOnly MM_IN_CM As Decimal
public:
static initonly Decimal MM_IN_CM
public:
static initonly Decimal MM_IN_CM
static val MM_IN_CM: decimal
static val MM_IN_CM: decimal

Field Value

Type: Online Decimal
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance.MM_IN_FT Field

Distance MM_IN_FT Field NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly decimal MM_IN_FT
public static readonly decimal MM_IN_FT
Public Shared ReadOnly MM_IN_FT As Decimal
Public Shared ReadOnly MM_IN_FT As Decimal
public:
static initonly Decimal MM_IN_FT
public:
static initonly Decimal MM_IN_FT
static val MM_IN_FT: decimal
static val MM_IN_FT: decimal

Field Value

Type: Online Decimal
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance.MM_IN_IN Field

Distance MM_IN_IN Field NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly decimal MM_IN_IN
public static readonly decimal MM_IN_IN
Public Shared ReadOnly MM_IN_IN As Decimal
Public Shared ReadOnly MM_IN_IN As Decimal
public:
static initonly Decimal MM_IN_IN
public:
static initonly Decimal MM_IN_IN
static val MM_IN_IN: decimal
static val MM_IN_IN: decimal

Field Value

Type: Online Decimal
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance.MM_IN_M Field

Distance MM_IN_M Field NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly decimal MM_IN_M
public static readonly decimal MM_IN_M
Public Shared ReadOnly MM_IN_M As Decimal
Public Shared ReadOnly MM_IN_M As Decimal
public:
static initonly Decimal MM_IN_M
public:
static initonly Decimal MM_IN_M
static val MM_IN_M: decimal
static val MM_IN_M: decimal

Field Value

Type: Online Decimal
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance.MM_IN_YD Field

Distance MM_IN_YD Field NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly decimal MM_IN_YD
public static readonly decimal MM_IN_YD
Public Shared ReadOnly MM_IN_YD As Decimal
Public Shared ReadOnly MM_IN_YD As Decimal
public:
static initonly Decimal MM_IN_YD
public:
static initonly Decimal MM_IN_YD
static val MM_IN_YD: decimal
static val MM_IN_YD: decimal

Field Value

Type: Online Decimal
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance.Unit Field

Distance Unit Field NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Distance..::..UnitType Unit
public readonly Distance..::..UnitType Unit
Public ReadOnly Unit As Distance..::..UnitType
Public ReadOnly Unit As Distance..::..UnitType
public:
initonly Distance..::..UnitType Unit
public:
initonly Distance..::..UnitType Unit
val Unit: Distance..::..UnitType
val Unit: Distance..::..UnitType

Field Value

Type: Distance UnitType
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance.Value Field

Distance Value Field NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly decimal Value
public readonly decimal Value
Public ReadOnly Value As Decimal
Public ReadOnly Value As Decimal
public:
initonly Decimal Value
public:
initonly Decimal Value
val Value: decimal
val Value: decimal

Field Value

Type: Online Decimal
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance.VALUE_PRECISION Field

Distance VALUE_PRECISION Field NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int VALUE_PRECISION
public const int VALUE_PRECISION
Public Const VALUE_PRECISION As Integer
Public Const VALUE_PRECISION As Integer
public:
literal int VALUE_PRECISION
public:
literal int VALUE_PRECISION
static val mutable VALUE_PRECISION: int
static val mutable VALUE_PRECISION: int

Field Value

Type: Online Int32
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance.ValueInMm Field

Distance ValueInMm Field NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly decimal ValueInMm
public readonly decimal ValueInMm
Public ReadOnly ValueInMm As Decimal
Public ReadOnly ValueInMm As Decimal
public:
initonly Decimal ValueInMm
public:
initonly Decimal ValueInMm
val ValueInMm: decimal
val ValueInMm: decimal

Field Value

Type: Online Decimal
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance Methods

Distance Methods NFX Class Library

The Distance type exposes the following members.
Methods
 | Name | Description
Public method | CompareTo |
Public method | Convert |
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(Distance) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Parse |
Public method | ToString | (Overrides Online ValueType ToString .)
Public method | ToString(String, IFormatProvider) |
 | TryParse |
Public method | ValueIn |
Public method | WriteAsJSON |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Distance Structure
NFX.Standards Namespace


Distance.CompareTo Method

Distance CompareTo Method NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    Distance other
)
public int CompareTo(
    Distance other
)
Public Function CompareTo (
    other As Distance
) As Integer
Public Function CompareTo (
    other As Distance
) As Integer
public:
virtual int CompareTo(
    Distance other
) sealed
public:
virtual int CompareTo(
    Distance other
) sealed
abstract CompareTo :
        other : Distance -> int
override CompareTo :
        other : Distance -> int
abstract CompareTo :
        other : Distance -> int
override CompareTo :
        other : Distance -> int

Parameters

other
Type: NFX.Standards Distance

Return Value

Type: Online Int32

Implements

Online IComparable T CompareTo(T)
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance.Convert Method

Distance Convert Method NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Distance Convert(
    Distance..::..UnitType toUnit
)
public Distance Convert(
    Distance..::..UnitType toUnit
)
Public Function Convert (
    toUnit As Distance..::..UnitType
) As Distance
Public Function Convert (
    toUnit As Distance..::..UnitType
) As Distance
public:
Distance Convert(
    Distance..::..UnitType toUnit
)
public:
Distance Convert(
    Distance..::..UnitType toUnit
)
member Convert :
        toUnit : Distance..::..UnitType -> Distance
member Convert :
        toUnit : Distance..::..UnitType -> Distance

Parameters

toUnit
Type: NFX.Standards Distance UnitType

Return Value

Type: Distance
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance.Equals Method

Distance Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(Distance) |
Back to Top
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance.Equals Method (Object)

Distance Equals Method (Object) NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
Distance Structure
Distance Members
Equals Overload
NFX.Standards Namespace


Distance.Equals Method (Distance)

Distance Equals Method (Distance) NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    Distance other
)
public bool Equals(
    Distance other
)
Public Function Equals (
    other As Distance
) As Boolean
Public Function Equals (
    other As Distance
) As Boolean
public:
virtual bool Equals(
    Distance other
) sealed
public:
virtual bool Equals(
    Distance other
) sealed
abstract Equals :
        other : Distance -> bool
override Equals :
        other : Distance -> bool
abstract Equals :
        other : Distance -> bool
override Equals :
        other : Distance -> bool

Parameters

other
Type: NFX.Standards Distance

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
Distance Structure
Distance Members
Equals Overload
NFX.Standards Namespace


Distance.GetHashCode Method

Distance GetHashCode Method NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance.Parse Method

Distance Parse Method NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Distance Parse(
    string val
)
public static Distance Parse(
    string val
)
Public Shared Function Parse (
    val As String
) As Distance
Public Shared Function Parse (
    val As String
) As Distance
public:
static Distance Parse(
    String^ val
)
public:
static Distance Parse(
    String^ val
)
static member Parse :
        val : string -> Distance
static member Parse :
        val : string -> Distance

Parameters

val
Type: Online System String

Return Value

Type: Distance
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance.ToString Method

Distance ToString Method NFX Class Library

Overload List
 | Name | Description
Public method | ToString | (Overrides Online ValueType ToString .)
Public method | ToString(String, IFormatProvider) |
Back to Top
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance.ToString Method

Distance ToString Method NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
Distance Structure
Distance Members
ToString Overload
NFX.Standards Namespace


Distance.ToString Method (String, IFormatProvider)

Distance ToString Method (String, IFormatProvider) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ToString(
    string format,
    IFormatProvider formatProvider
)
public string ToString(
    string format,
    IFormatProvider formatProvider
)
Public Function ToString (
    format As String,
    formatProvider As IFormatProvider
) As String
Public Function ToString (
    format As String,
    formatProvider As IFormatProvider
) As String
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ formatProvider
) sealed
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ formatProvider
) sealed
abstract ToString :
        format : string *
        formatProvider : IFormatProvider -> string
override ToString :
        format : string *
        formatProvider : IFormatProvider -> string
abstract ToString :
        format : string *
        formatProvider : IFormatProvider -> string
override ToString :
        format : string *
        formatProvider : IFormatProvider -> string

Parameters

format
Type: Online System String
formatProvider
Type: Online System IFormatProvider

Return Value

Type: Online String

Implements

Online IFormattable ToString(String, IFormatProvider)
See Also
Distance Structure
Distance Members
ToString Overload
NFX.Standards Namespace


Distance.TryParse Method

Distance TryParse Method NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool TryParse(
    string val,
    out Nullable<Distance> result
)
public static bool TryParse(
    string val,
    out Nullable<Distance> result
)
Public Shared Function TryParse (
    val As String,
    <OutAttribute> ByRef result As Nullable(Of Distance)
) As Boolean
Public Shared Function TryParse (
    val As String,
    <OutAttribute> ByRef result As Nullable(Of Distance)
) As Boolean
public:
static bool TryParse(
    String^ val,
    [OutAttribute] Nullable<Distance>% result
)
public:
static bool TryParse(
    String^ val,
    [OutAttribute] Nullable<Distance>% result
)
static member TryParse :
        val : string *
        result : Nullable<Distance> byref -> bool
static member TryParse :
        val : string *
        result : Nullable<Distance> byref -> bool

Parameters

val
Type: Online System String
result
Type: Online System Nullable Distance

Return Value

Type: Online Boolean
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance.ValueIn Method

Distance ValueIn Method NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal ValueIn(
    Distance..::..UnitType toUnit
)
public decimal ValueIn(
    Distance..::..UnitType toUnit
)
Public Function ValueIn (
    toUnit As Distance..::..UnitType
) As Decimal
Public Function ValueIn (
    toUnit As Distance..::..UnitType
) As Decimal
public:
Decimal ValueIn(
    Distance..::..UnitType toUnit
)
public:
Decimal ValueIn(
    Distance..::..UnitType toUnit
)
member ValueIn :
        toUnit : Distance..::..UnitType -> decimal
member ValueIn :
        toUnit : Distance..::..UnitType -> decimal

Parameters

toUnit
Type: NFX.Standards Distance UnitType

Return Value

Type: Online Decimal
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance.WriteAsJSON Method

Distance WriteAsJSON Method NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
nestingLevel
Type: Online System Int32
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Implements

IJSONWritable WriteAsJSON(TextWriter, Int32, JSONWritingOptions)
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance Operators

Distance Operators NFX Class Library

The Distance type exposes the following members.
Operators
Name | Description
Addition |
Division |
Equality |
GreaterThan |
GreaterThanOrEqual |
Inequality |
LessThan |
LessThanOrEqual |
Multiply |
Subtraction |
Back to Top
See Also
Distance Structure
NFX.Standards Namespace


Distance.Addition Operator

Distance Addition Operator NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Distance operator +(
    Distance obj1,
    Distance obj2
)
public static Distance operator +(
    Distance obj1,
    Distance obj2
)
Public Shared Operator + (
    obj1 As Distance,
    obj2 As Distance
) As Distance
Public Shared Operator + (
    obj1 As Distance,
    obj2 As Distance
) As Distance
public:
static Distance operator +(
    Distance obj1,
    Distance obj2
)
public:
static Distance operator +(
    Distance obj1,
    Distance obj2
)
static let inline (+)
        obj1 : Distance *
        obj2 : Distance  : Distance
static let inline (+)
        obj1 : Distance *
        obj2 : Distance  : Distance

Parameters

obj1
Type: NFX.Standards Distance
obj2
Type: NFX.Standards Distance

Return Value

Type: Distance
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance.Division Operator

Distance Division Operator NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Distance operator /(
    Distance obj1,
    decimal obj2
)
public static Distance operator /(
    Distance obj1,
    decimal obj2
)
Public Shared Operator / (
    obj1 As Distance,
    obj2 As Decimal
) As Distance
Public Shared Operator / (
    obj1 As Distance,
    obj2 As Decimal
) As Distance
public:
static Distance operator /(
    Distance obj1,
    Decimal obj2
)
public:
static Distance operator /(
    Distance obj1,
    Decimal obj2
)
static let inline (/)
        obj1 : Distance *
        obj2 : decimal  : Distance
static let inline (/)
        obj1 : Distance *
        obj2 : decimal  : Distance

Parameters

obj1
Type: NFX.Standards Distance
obj2
Type: Online System Decimal

Return Value

Type: Distance
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance.Equality Operator

Distance Equality Operator NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    Distance obj1,
    Distance obj2
)
public static bool operator ==(
    Distance obj1,
    Distance obj2
)
Public Shared Operator = (
    obj1 As Distance,
    obj2 As Distance
) As Boolean
Public Shared Operator = (
    obj1 As Distance,
    obj2 As Distance
) As Boolean
public:
static bool operator ==(
    Distance obj1,
    Distance obj2
)
public:
static bool operator ==(
    Distance obj1,
    Distance obj2
)
static let inline (=)
        obj1 : Distance *
        obj2 : Distance  : bool
static let inline (=)
        obj1 : Distance *
        obj2 : Distance  : bool

Parameters

obj1
Type: NFX.Standards Distance
obj2
Type: NFX.Standards Distance

Return Value

Type: Online Boolean
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance.GreaterThan Operator

Distance GreaterThan Operator NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator >(
    Distance obj1,
    Distance obj2
)
public static bool operator >(
    Distance obj1,
    Distance obj2
)
Public Shared Operator > (
    obj1 As Distance,
    obj2 As Distance
) As Boolean
Public Shared Operator > (
    obj1 As Distance,
    obj2 As Distance
) As Boolean
public:
static bool operator >(
    Distance obj1,
    Distance obj2
)
public:
static bool operator >(
    Distance obj1,
    Distance obj2
)
static let inline (>)
        obj1 : Distance *
        obj2 : Distance  : bool
static let inline (>)
        obj1 : Distance *
        obj2 : Distance  : bool

Parameters

obj1
Type: NFX.Standards Distance
obj2
Type: NFX.Standards Distance

Return Value

Type: Online Boolean
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance.GreaterThanOrEqual Operator

Distance GreaterThanOrEqual Operator NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator >=(
    Distance obj1,
    Distance obj2
)
public static bool operator >=(
    Distance obj1,
    Distance obj2
)
Public Shared Operator >= (
    obj1 As Distance,
    obj2 As Distance
) As Boolean
Public Shared Operator >= (
    obj1 As Distance,
    obj2 As Distance
) As Boolean
public:
static bool operator >=(
    Distance obj1,
    Distance obj2
)
public:
static bool operator >=(
    Distance obj1,
    Distance obj2
)
static let inline (>=)
        obj1 : Distance *
        obj2 : Distance  : bool
static let inline (>=)
        obj1 : Distance *
        obj2 : Distance  : bool

Parameters

obj1
Type: NFX.Standards Distance
obj2
Type: NFX.Standards Distance

Return Value

Type: Online Boolean
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance.Inequality Operator

Distance Inequality Operator NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    Distance obj1,
    Distance obj2
)
public static bool operator !=(
    Distance obj1,
    Distance obj2
)
Public Shared Operator <> (
    obj1 As Distance,
    obj2 As Distance
) As Boolean
Public Shared Operator <> (
    obj1 As Distance,
    obj2 As Distance
) As Boolean
public:
static bool operator !=(
    Distance obj1,
    Distance obj2
)
public:
static bool operator !=(
    Distance obj1,
    Distance obj2
)
static let inline (<>)
        obj1 : Distance *
        obj2 : Distance  : bool
static let inline (<>)
        obj1 : Distance *
        obj2 : Distance  : bool

Parameters

obj1
Type: NFX.Standards Distance
obj2
Type: NFX.Standards Distance

Return Value

Type: Online Boolean
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance.LessThan Operator

Distance LessThan Operator NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator <(
    Distance obj1,
    Distance obj2
)
public static bool operator <(
    Distance obj1,
    Distance obj2
)
Public Shared Operator < (
    obj1 As Distance,
    obj2 As Distance
) As Boolean
Public Shared Operator < (
    obj1 As Distance,
    obj2 As Distance
) As Boolean
public:
static bool operator <(
    Distance obj1,
    Distance obj2
)
public:
static bool operator <(
    Distance obj1,
    Distance obj2
)
static let inline (<)
        obj1 : Distance *
        obj2 : Distance  : bool
static let inline (<)
        obj1 : Distance *
        obj2 : Distance  : bool

Parameters

obj1
Type: NFX.Standards Distance
obj2
Type: NFX.Standards Distance

Return Value

Type: Online Boolean
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance.LessThanOrEqual Operator

Distance LessThanOrEqual Operator NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator <=(
    Distance obj1,
    Distance obj2
)
public static bool operator <=(
    Distance obj1,
    Distance obj2
)
Public Shared Operator <= (
    obj1 As Distance,
    obj2 As Distance
) As Boolean
Public Shared Operator <= (
    obj1 As Distance,
    obj2 As Distance
) As Boolean
public:
static bool operator <=(
    Distance obj1,
    Distance obj2
)
public:
static bool operator <=(
    Distance obj1,
    Distance obj2
)
static let inline (<=)
        obj1 : Distance *
        obj2 : Distance  : bool
static let inline (<=)
        obj1 : Distance *
        obj2 : Distance  : bool

Parameters

obj1
Type: NFX.Standards Distance
obj2
Type: NFX.Standards Distance

Return Value

Type: Online Boolean
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance.Multiply Operator

Distance Multiply Operator NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Distance operator *(
    Distance obj1,
    decimal obj2
)
public static Distance operator *(
    Distance obj1,
    decimal obj2
)
Public Shared Operator * (
    obj1 As Distance,
    obj2 As Decimal
) As Distance
Public Shared Operator * (
    obj1 As Distance,
    obj2 As Decimal
) As Distance
public:
static Distance operator *(
    Distance obj1,
    Decimal obj2
)
public:
static Distance operator *(
    Distance obj1,
    Decimal obj2
)
static let inline (*)
        obj1 : Distance *
        obj2 : decimal  : Distance
static let inline (*)
        obj1 : Distance *
        obj2 : decimal  : Distance

Parameters

obj1
Type: NFX.Standards Distance
obj2
Type: Online System Decimal

Return Value

Type: Distance
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance.Subtraction Operator

Distance Subtraction Operator NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Distance operator -(
    Distance obj1,
    Distance obj2
)
public static Distance operator -(
    Distance obj1,
    Distance obj2
)
Public Shared Operator - (
    obj1 As Distance,
    obj2 As Distance
) As Distance
Public Shared Operator - (
    obj1 As Distance,
    obj2 As Distance
) As Distance
public:
static Distance operator -(
    Distance obj1,
    Distance obj2
)
public:
static Distance operator -(
    Distance obj1,
    Distance obj2
)
static let inline (-)
        obj1 : Distance *
        obj2 : Distance  : Distance
static let inline (-)
        obj1 : Distance *
        obj2 : Distance  : Distance

Parameters

obj1
Type: NFX.Standards Distance
obj2
Type: NFX.Standards Distance

Return Value

Type: Distance
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance Properties

Distance Properties NFX Class Library

The Distance type exposes the following members.
Properties
 | Name | Description
Public property | UnitName |
Back to Top
See Also
Distance Structure
NFX.Standards Namespace


Distance.UnitName Property

Distance UnitName Property NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string UnitName { get; }
public string UnitName { get; }
Public ReadOnly Property UnitName As String
    Get
Public ReadOnly Property UnitName As String
    Get
public:
property String^ UnitName {
    String^ get ();
}
public:
property String^ UnitName {
    String^ get ();
}
member UnitName : string with get
member UnitName : string with get

Property Value

Type: Online String
See Also
Distance Structure
Distance Members
NFX.Standards Namespace


Distance.UnitType Enumeration

Distance UnitType Enumeration NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum UnitType
public enum UnitType
Public Enumeration UnitType
Public Enumeration UnitType
public enum class UnitType
public enum class UnitType
type UnitType
type UnitType
Members
Member name | Value | Description
Cm | 0 |
In | 1 |
Ft | 2 |
Mm | 3 |
M | 4 |
Yd | 5 |
See Also
NFX.Standards Namespace


Weight Structure

Weight Structure NFX Class Library

Represents weight with unit type. All operations are done with presision of 1 milligramm

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct Weight : IEquatable<Weight>,
    IComparable<Weight>, IJSONWritable, IFormattable
public struct Weight : IEquatable<Weight>,
    IComparable<Weight>, IJSONWritable, IFormattable
Public Structure Weight
    Implements IEquatable(Of Weight), IComparable(Of Weight),
    IJSONWritable, IFormattable
Public Structure Weight
    Implements IEquatable(Of Weight), IComparable(Of Weight),
    IJSONWritable, IFormattable
public value class Weight : IEquatable<Weight>,
    IComparable<Weight>, IJSONWritable, IFormattable
public value class Weight : IEquatable<Weight>,
    IComparable<Weight>, IJSONWritable, IFormattable
[<SealedAttribute>]
type Weight =
    struct
        interface IEquatable<Weight>
        interface IComparable<Weight>
        interface IJSONWritable
        interface IFormattable
    end
[<SealedAttribute>]
type Weight =
    struct
        interface IEquatable<Weight>
        interface IComparable<Weight>
        interface IJSONWritable
        interface IFormattable
    end
See Also
Weight Members
NFX.Standards Namespace


Weight Members

Weight Members NFX Class Library

The Weight type exposes the following members.
Constructors
 | Name | Description
Public method | Weight | Initializes a new instance of the Weight class
Back to Top
Methods
 | Name | Description
Public method | CompareTo |
Public method | Convert |
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(Weight) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Parse |
Public method | ToString | (Overrides Online ValueType ToString .)
Public method | ToString(String, IFormatProvider) |
 | TryParse |
Public method | ValueIn |
Public method | WriteAsJSON |
Back to Top
Operators
Name | Description
Addition |
Division |
Equality |
GreaterThan |
GreaterThanOrEqual |
Inequality |
LessThan |
LessThanOrEqual |
Multiply |
Subtraction |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | G_IN_KG |
 | G_IN_LB |
 | G_IN_OZ |
Public field | Unit |
Public field | Value |
 | VALUE_PRECISION |
Public field | ValueInGrams |
Back to Top
Properties
 | Name | Description
Public property | UnitName |
Back to Top
See Also
Weight Structure
NFX.Standards Namespace


Weight Constructor

Weight Constructor NFX Class Library

Initializes a new instance of the Weight class

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Weight(
    decimal value,
    Weight..::..UnitType unit
)
public Weight(
    decimal value,
    Weight..::..UnitType unit
)
Public Sub New (
    value As Decimal,
    unit As Weight..::..UnitType
)
Public Sub New (
    value As Decimal,
    unit As Weight..::..UnitType
)
public:
Weight(
    Decimal value,
    Weight..::..UnitType unit
)
public:
Weight(
    Decimal value,
    Weight..::..UnitType unit
)
new :
        value : decimal *
        unit : Weight..::..UnitType -> Weight
new :
        value : decimal *
        unit : Weight..::..UnitType -> Weight

Parameters

value
Type: Online System Decimal
unit
Type: NFX.Standards Weight UnitType
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight Fields

Weight Fields NFX Class Library

The Weight type exposes the following members.
Fields
 | Name | Description
 | G_IN_KG |
 | G_IN_LB |
 | G_IN_OZ |
Public field | Unit |
Public field | Value |
 | VALUE_PRECISION |
Public field | ValueInGrams |
Back to Top
See Also
Weight Structure
NFX.Standards Namespace


Weight.G_IN_KG Field

Weight G_IN_KG Field NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly decimal G_IN_KG
public static readonly decimal G_IN_KG
Public Shared ReadOnly G_IN_KG As Decimal
Public Shared ReadOnly G_IN_KG As Decimal
public:
static initonly Decimal G_IN_KG
public:
static initonly Decimal G_IN_KG
static val G_IN_KG: decimal
static val G_IN_KG: decimal

Field Value

Type: Online Decimal
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight.G_IN_LB Field

Weight G_IN_LB Field NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly decimal G_IN_LB
public static readonly decimal G_IN_LB
Public Shared ReadOnly G_IN_LB As Decimal
Public Shared ReadOnly G_IN_LB As Decimal
public:
static initonly Decimal G_IN_LB
public:
static initonly Decimal G_IN_LB
static val G_IN_LB: decimal
static val G_IN_LB: decimal

Field Value

Type: Online Decimal
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight.G_IN_OZ Field

Weight G_IN_OZ Field NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly decimal G_IN_OZ
public static readonly decimal G_IN_OZ
Public Shared ReadOnly G_IN_OZ As Decimal
Public Shared ReadOnly G_IN_OZ As Decimal
public:
static initonly Decimal G_IN_OZ
public:
static initonly Decimal G_IN_OZ
static val G_IN_OZ: decimal
static val G_IN_OZ: decimal

Field Value

Type: Online Decimal
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight.Unit Field

Weight Unit Field NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly Weight..::..UnitType Unit
public readonly Weight..::..UnitType Unit
Public ReadOnly Unit As Weight..::..UnitType
Public ReadOnly Unit As Weight..::..UnitType
public:
initonly Weight..::..UnitType Unit
public:
initonly Weight..::..UnitType Unit
val Unit: Weight..::..UnitType
val Unit: Weight..::..UnitType

Field Value

Type: Weight UnitType
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight.Value Field

Weight Value Field NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly decimal Value
public readonly decimal Value
Public ReadOnly Value As Decimal
Public ReadOnly Value As Decimal
public:
initonly Decimal Value
public:
initonly Decimal Value
val Value: decimal
val Value: decimal

Field Value

Type: Online Decimal
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight.VALUE_PRECISION Field

Weight VALUE_PRECISION Field NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int VALUE_PRECISION
public const int VALUE_PRECISION
Public Const VALUE_PRECISION As Integer
Public Const VALUE_PRECISION As Integer
public:
literal int VALUE_PRECISION
public:
literal int VALUE_PRECISION
static val mutable VALUE_PRECISION: int
static val mutable VALUE_PRECISION: int

Field Value

Type: Online Int32
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight.ValueInGrams Field

Weight ValueInGrams Field NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly decimal ValueInGrams
public readonly decimal ValueInGrams
Public ReadOnly ValueInGrams As Decimal
Public ReadOnly ValueInGrams As Decimal
public:
initonly Decimal ValueInGrams
public:
initonly Decimal ValueInGrams
val ValueInGrams: decimal
val ValueInGrams: decimal

Field Value

Type: Online Decimal
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight Methods

Weight Methods NFX Class Library

The Weight type exposes the following members.
Methods
 | Name | Description
Public method | CompareTo |
Public method | Convert |
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(Weight) |
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online ValueType GetHashCode .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
 | Parse |
Public method | ToString | (Overrides Online ValueType ToString .)
Public method | ToString(String, IFormatProvider) |
 | TryParse |
Public method | ValueIn |
Public method | WriteAsJSON |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
Weight Structure
NFX.Standards Namespace


Weight.CompareTo Method

Weight CompareTo Method NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CompareTo(
    Weight other
)
public int CompareTo(
    Weight other
)
Public Function CompareTo (
    other As Weight
) As Integer
Public Function CompareTo (
    other As Weight
) As Integer
public:
virtual int CompareTo(
    Weight other
) sealed
public:
virtual int CompareTo(
    Weight other
) sealed
abstract CompareTo :
        other : Weight -> int
override CompareTo :
        other : Weight -> int
abstract CompareTo :
        other : Weight -> int
override CompareTo :
        other : Weight -> int

Parameters

other
Type: NFX.Standards Weight

Return Value

Type: Online Int32

Implements

Online IComparable T CompareTo(T)
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight.Convert Method

Weight Convert Method NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Weight Convert(
    Weight..::..UnitType toUnit
)
public Weight Convert(
    Weight..::..UnitType toUnit
)
Public Function Convert (
    toUnit As Weight..::..UnitType
) As Weight
Public Function Convert (
    toUnit As Weight..::..UnitType
) As Weight
public:
Weight Convert(
    Weight..::..UnitType toUnit
)
public:
Weight Convert(
    Weight..::..UnitType toUnit
)
member Convert :
        toUnit : Weight..::..UnitType -> Weight
member Convert :
        toUnit : Weight..::..UnitType -> Weight

Parameters

toUnit
Type: NFX.Standards Weight UnitType

Return Value

Type: Weight
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight.Equals Method

Weight Equals Method NFX Class Library

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides Online ValueType Equals(Object).)
Public method | Equals(Weight) |
Back to Top
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight.Equals Method (Object)

Weight Equals Method (Object) NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
Weight Structure
Weight Members
Equals Overload
NFX.Standards Namespace


Weight.Equals Method (Weight)

Weight Equals Method (Weight) NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    Weight other
)
public bool Equals(
    Weight other
)
Public Function Equals (
    other As Weight
) As Boolean
Public Function Equals (
    other As Weight
) As Boolean
public:
virtual bool Equals(
    Weight other
) sealed
public:
virtual bool Equals(
    Weight other
) sealed
abstract Equals :
        other : Weight -> bool
override Equals :
        other : Weight -> bool
abstract Equals :
        other : Weight -> bool
override Equals :
        other : Weight -> bool

Parameters

other
Type: NFX.Standards Weight

Return Value

Type: Online Boolean

Implements

Online IEquatable T Equals(T)
See Also
Weight Structure
Weight Members
Equals Overload
NFX.Standards Namespace


Weight.GetHashCode Method

Weight GetHashCode Method NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight.Parse Method

Weight Parse Method NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Weight Parse(
    string val
)
public static Weight Parse(
    string val
)
Public Shared Function Parse (
    val As String
) As Weight
Public Shared Function Parse (
    val As String
) As Weight
public:
static Weight Parse(
    String^ val
)
public:
static Weight Parse(
    String^ val
)
static member Parse :
        val : string -> Weight
static member Parse :
        val : string -> Weight

Parameters

val
Type: Online System String

Return Value

Type: Weight
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight.ToString Method

Weight ToString Method NFX Class Library

Overload List
 | Name | Description
Public method | ToString | (Overrides Online ValueType ToString .)
Public method | ToString(String, IFormatProvider) |
Back to Top
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight.ToString Method

Weight ToString Method NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
Weight Structure
Weight Members
ToString Overload
NFX.Standards Namespace


Weight.ToString Method (String, IFormatProvider)

Weight ToString Method (String, IFormatProvider) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ToString(
    string format,
    IFormatProvider formatProvider
)
public string ToString(
    string format,
    IFormatProvider formatProvider
)
Public Function ToString (
    format As String,
    formatProvider As IFormatProvider
) As String
Public Function ToString (
    format As String,
    formatProvider As IFormatProvider
) As String
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ formatProvider
) sealed
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ formatProvider
) sealed
abstract ToString :
        format : string *
        formatProvider : IFormatProvider -> string
override ToString :
        format : string *
        formatProvider : IFormatProvider -> string
abstract ToString :
        format : string *
        formatProvider : IFormatProvider -> string
override ToString :
        format : string *
        formatProvider : IFormatProvider -> string

Parameters

format
Type: Online System String
formatProvider
Type: Online System IFormatProvider

Return Value

Type: Online String

Implements

Online IFormattable ToString(String, IFormatProvider)
See Also
Weight Structure
Weight Members
ToString Overload
NFX.Standards Namespace


Weight.TryParse Method

Weight TryParse Method NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool TryParse(
    string val,
    out Nullable<Weight> result
)
public static bool TryParse(
    string val,
    out Nullable<Weight> result
)
Public Shared Function TryParse (
    val As String,
    <OutAttribute> ByRef result As Nullable(Of Weight)
) As Boolean
Public Shared Function TryParse (
    val As String,
    <OutAttribute> ByRef result As Nullable(Of Weight)
) As Boolean
public:
static bool TryParse(
    String^ val,
    [OutAttribute] Nullable<Weight>% result
)
public:
static bool TryParse(
    String^ val,
    [OutAttribute] Nullable<Weight>% result
)
static member TryParse :
        val : string *
        result : Nullable<Weight> byref -> bool
static member TryParse :
        val : string *
        result : Nullable<Weight> byref -> bool

Parameters

val
Type: Online System String
result
Type: Online System Nullable Weight

Return Value

Type: Online Boolean
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight.ValueIn Method

Weight ValueIn Method NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal ValueIn(
    Weight..::..UnitType toUnit
)
public decimal ValueIn(
    Weight..::..UnitType toUnit
)
Public Function ValueIn (
    toUnit As Weight..::..UnitType
) As Decimal
Public Function ValueIn (
    toUnit As Weight..::..UnitType
) As Decimal
public:
Decimal ValueIn(
    Weight..::..UnitType toUnit
)
public:
Decimal ValueIn(
    Weight..::..UnitType toUnit
)
member ValueIn :
        toUnit : Weight..::..UnitType -> decimal
member ValueIn :
        toUnit : Weight..::..UnitType -> decimal

Parameters

toUnit
Type: NFX.Standards Weight UnitType

Return Value

Type: Online Decimal
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight.WriteAsJSON Method

Weight WriteAsJSON Method NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
public void WriteAsJSON(
    TextWriter wri,
    int nestingLevel,
    JSONWritingOptions options = null
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
Public Sub WriteAsJSON (
    wri As TextWriter,
    nestingLevel As Integer,
    Optional options As JSONWritingOptions = Nothing
)
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
public:
virtual void WriteAsJSON(
    TextWriter^ wri,
    int nestingLevel,
    JSONWritingOptions^ options = nullptr
) sealed
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
abstract WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
override WriteAsJSON :
        wri : TextWriter *
        nestingLevel : int *
        ?options : JSONWritingOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

wri
Type: Online System.IO TextWriter
nestingLevel
Type: Online System Int32
options (Optional)
Type: NFX.Serialization.JSON JSONWritingOptions

Implements

IJSONWritable WriteAsJSON(TextWriter, Int32, JSONWritingOptions)
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight Operators

Weight Operators NFX Class Library

The Weight type exposes the following members.
Operators
Name | Description
Addition |
Division |
Equality |
GreaterThan |
GreaterThanOrEqual |
Inequality |
LessThan |
LessThanOrEqual |
Multiply |
Subtraction |
Back to Top
See Also
Weight Structure
NFX.Standards Namespace


Weight.Addition Operator

Weight Addition Operator NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Weight operator +(
    Weight obj1,
    Weight obj2
)
public static Weight operator +(
    Weight obj1,
    Weight obj2
)
Public Shared Operator + (
    obj1 As Weight,
    obj2 As Weight
) As Weight
Public Shared Operator + (
    obj1 As Weight,
    obj2 As Weight
) As Weight
public:
static Weight operator +(
    Weight obj1,
    Weight obj2
)
public:
static Weight operator +(
    Weight obj1,
    Weight obj2
)
static let inline (+)
        obj1 : Weight *
        obj2 : Weight  : Weight
static let inline (+)
        obj1 : Weight *
        obj2 : Weight  : Weight

Parameters

obj1
Type: NFX.Standards Weight
obj2
Type: NFX.Standards Weight

Return Value

Type: Weight
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight.Division Operator

Weight Division Operator NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Weight operator /(
    Weight obj1,
    decimal obj2
)
public static Weight operator /(
    Weight obj1,
    decimal obj2
)
Public Shared Operator / (
    obj1 As Weight,
    obj2 As Decimal
) As Weight
Public Shared Operator / (
    obj1 As Weight,
    obj2 As Decimal
) As Weight
public:
static Weight operator /(
    Weight obj1,
    Decimal obj2
)
public:
static Weight operator /(
    Weight obj1,
    Decimal obj2
)
static let inline (/)
        obj1 : Weight *
        obj2 : decimal  : Weight
static let inline (/)
        obj1 : Weight *
        obj2 : decimal  : Weight

Parameters

obj1
Type: NFX.Standards Weight
obj2
Type: Online System Decimal

Return Value

Type: Weight
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight.Equality Operator

Weight Equality Operator NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    Weight obj1,
    Weight obj2
)
public static bool operator ==(
    Weight obj1,
    Weight obj2
)
Public Shared Operator = (
    obj1 As Weight,
    obj2 As Weight
) As Boolean
Public Shared Operator = (
    obj1 As Weight,
    obj2 As Weight
) As Boolean
public:
static bool operator ==(
    Weight obj1,
    Weight obj2
)
public:
static bool operator ==(
    Weight obj1,
    Weight obj2
)
static let inline (=)
        obj1 : Weight *
        obj2 : Weight  : bool
static let inline (=)
        obj1 : Weight *
        obj2 : Weight  : bool

Parameters

obj1
Type: NFX.Standards Weight
obj2
Type: NFX.Standards Weight

Return Value

Type: Online Boolean
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight.GreaterThan Operator

Weight GreaterThan Operator NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator >(
    Weight obj1,
    Weight obj2
)
public static bool operator >(
    Weight obj1,
    Weight obj2
)
Public Shared Operator > (
    obj1 As Weight,
    obj2 As Weight
) As Boolean
Public Shared Operator > (
    obj1 As Weight,
    obj2 As Weight
) As Boolean
public:
static bool operator >(
    Weight obj1,
    Weight obj2
)
public:
static bool operator >(
    Weight obj1,
    Weight obj2
)
static let inline (>)
        obj1 : Weight *
        obj2 : Weight  : bool
static let inline (>)
        obj1 : Weight *
        obj2 : Weight  : bool

Parameters

obj1
Type: NFX.Standards Weight
obj2
Type: NFX.Standards Weight

Return Value

Type: Online Boolean
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight.GreaterThanOrEqual Operator

Weight GreaterThanOrEqual Operator NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator >=(
    Weight obj1,
    Weight obj2
)
public static bool operator >=(
    Weight obj1,
    Weight obj2
)
Public Shared Operator >= (
    obj1 As Weight,
    obj2 As Weight
) As Boolean
Public Shared Operator >= (
    obj1 As Weight,
    obj2 As Weight
) As Boolean
public:
static bool operator >=(
    Weight obj1,
    Weight obj2
)
public:
static bool operator >=(
    Weight obj1,
    Weight obj2
)
static let inline (>=)
        obj1 : Weight *
        obj2 : Weight  : bool
static let inline (>=)
        obj1 : Weight *
        obj2 : Weight  : bool

Parameters

obj1
Type: NFX.Standards Weight
obj2
Type: NFX.Standards Weight

Return Value

Type: Online Boolean
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight.Inequality Operator

Weight Inequality Operator NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    Weight obj1,
    Weight obj2
)
public static bool operator !=(
    Weight obj1,
    Weight obj2
)
Public Shared Operator <> (
    obj1 As Weight,
    obj2 As Weight
) As Boolean
Public Shared Operator <> (
    obj1 As Weight,
    obj2 As Weight
) As Boolean
public:
static bool operator !=(
    Weight obj1,
    Weight obj2
)
public:
static bool operator !=(
    Weight obj1,
    Weight obj2
)
static let inline (<>)
        obj1 : Weight *
        obj2 : Weight  : bool
static let inline (<>)
        obj1 : Weight *
        obj2 : Weight  : bool

Parameters

obj1
Type: NFX.Standards Weight
obj2
Type: NFX.Standards Weight

Return Value

Type: Online Boolean
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight.LessThan Operator

Weight LessThan Operator NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator <(
    Weight obj1,
    Weight obj2
)
public static bool operator <(
    Weight obj1,
    Weight obj2
)
Public Shared Operator < (
    obj1 As Weight,
    obj2 As Weight
) As Boolean
Public Shared Operator < (
    obj1 As Weight,
    obj2 As Weight
) As Boolean
public:
static bool operator <(
    Weight obj1,
    Weight obj2
)
public:
static bool operator <(
    Weight obj1,
    Weight obj2
)
static let inline (<)
        obj1 : Weight *
        obj2 : Weight  : bool
static let inline (<)
        obj1 : Weight *
        obj2 : Weight  : bool

Parameters

obj1
Type: NFX.Standards Weight
obj2
Type: NFX.Standards Weight

Return Value

Type: Online Boolean
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight.LessThanOrEqual Operator

Weight LessThanOrEqual Operator NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator <=(
    Weight obj1,
    Weight obj2
)
public static bool operator <=(
    Weight obj1,
    Weight obj2
)
Public Shared Operator <= (
    obj1 As Weight,
    obj2 As Weight
) As Boolean
Public Shared Operator <= (
    obj1 As Weight,
    obj2 As Weight
) As Boolean
public:
static bool operator <=(
    Weight obj1,
    Weight obj2
)
public:
static bool operator <=(
    Weight obj1,
    Weight obj2
)
static let inline (<=)
        obj1 : Weight *
        obj2 : Weight  : bool
static let inline (<=)
        obj1 : Weight *
        obj2 : Weight  : bool

Parameters

obj1
Type: NFX.Standards Weight
obj2
Type: NFX.Standards Weight

Return Value

Type: Online Boolean
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight.Multiply Operator

Weight Multiply Operator NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Weight operator *(
    Weight obj1,
    decimal obj2
)
public static Weight operator *(
    Weight obj1,
    decimal obj2
)
Public Shared Operator * (
    obj1 As Weight,
    obj2 As Decimal
) As Weight
Public Shared Operator * (
    obj1 As Weight,
    obj2 As Decimal
) As Weight
public:
static Weight operator *(
    Weight obj1,
    Decimal obj2
)
public:
static Weight operator *(
    Weight obj1,
    Decimal obj2
)
static let inline (*)
        obj1 : Weight *
        obj2 : decimal  : Weight
static let inline (*)
        obj1 : Weight *
        obj2 : decimal  : Weight

Parameters

obj1
Type: NFX.Standards Weight
obj2
Type: Online System Decimal

Return Value

Type: Weight
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight.Subtraction Operator

Weight Subtraction Operator NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Weight operator -(
    Weight obj1,
    Weight obj2
)
public static Weight operator -(
    Weight obj1,
    Weight obj2
)
Public Shared Operator - (
    obj1 As Weight,
    obj2 As Weight
) As Weight
Public Shared Operator - (
    obj1 As Weight,
    obj2 As Weight
) As Weight
public:
static Weight operator -(
    Weight obj1,
    Weight obj2
)
public:
static Weight operator -(
    Weight obj1,
    Weight obj2
)
static let inline (-)
        obj1 : Weight *
        obj2 : Weight  : Weight
static let inline (-)
        obj1 : Weight *
        obj2 : Weight  : Weight

Parameters

obj1
Type: NFX.Standards Weight
obj2
Type: NFX.Standards Weight

Return Value

Type: Weight
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight Properties

Weight Properties NFX Class Library

The Weight type exposes the following members.
Properties
 | Name | Description
Public property | UnitName |
Back to Top
See Also
Weight Structure
NFX.Standards Namespace


Weight.UnitName Property

Weight UnitName Property NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string UnitName { get; }
public string UnitName { get; }
Public ReadOnly Property UnitName As String
    Get
Public ReadOnly Property UnitName As String
    Get
public:
property String^ UnitName {
    String^ get ();
}
public:
property String^ UnitName {
    String^ get ();
}
member UnitName : string with get
member UnitName : string with get

Property Value

Type: Online String
See Also
Weight Structure
Weight Members
NFX.Standards Namespace


Weight.UnitType Enumeration

Weight UnitType Enumeration NFX Class Library

Namespace: NFX.Standards
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum UnitType
public enum UnitType
Public Enumeration UnitType
Public Enumeration UnitType
public enum class UnitType
public enum class UnitType
type UnitType
type UnitType
Members
Member name | Value | Description
G | 0 |
Oz | 1 |
Lb | 2 |
Kg | 3 |
See Also
NFX.Standards Namespace


NFX.Templatization Namespace

NFX.Templatization Namespace NFX Class Library

Defines base template types and compilers
Classes
 | Class | Description
Public class | CompileUnit | Represents a compilation unit which is compiled by TemplateCompiler. Use TemplateCompiler.IncludeTemplateSource() method or pass sources to .ctor
Public class | CompileUnits | Represents a bag of compile units
Public class | FileTemplateStringContentSource | Represents a string template source that comes from a file
Public class | StringRenderingTarget | Renders templates into string
Public class | Template TContext, TTarget, TRenderingContext | A general ancestor for any template. All templates derive from this class directly or indirectly. A template is a class that gets instantiated at some point to Render() its content into IRenderingTarget instance. Templates are not necessarily text-based, i.e. they can be image-based or based on various kinds of binary files
Public class | TemplateCodeCompilerException | Thrown by template code compilers
Public class | TemplateCompiler | Represents abstraction of template compilers. This class is not thread-safe
Public class | TemplateCompilerException | Base exception thrown by the template compilers
Public class | TemplateParseException | Indicates template source parsing exception
Public class | TemplateStringContentSource | Represents a string template source that comes from a string
Public class | TemplatizationException | Base exception thrown by the templatization-related functionality
Public class | TextCSTemplateCompiler | Compiles templates based of text files that use C# language syntax
Interfaces
 | Interface | Description
Public interface | IRenderingTarget | Defines an entity that a template can be rendered into. Templates are not necessarily text-based, consequently data is supplied as objects
Public interface | ITemplate | A general template interface. A template is a class that gets instantiated at some point to Render() its content into IRenderingTarget instance. Templates are not necessarily text-based, i.e. they can be image-based or based on various kinds of binary files
Public interface | ITemplateSource | Describes an entity that provides source for template
Public interface | ITemplateSource T | Describes an entity that provides source for templates


CompileUnit Class

CompileUnit Class NFX Class Library

Represents a compilation unit which is compiled by TemplateCompiler. Use TemplateCompiler.IncludeTemplateSource() method or pass sources to .ctor
Inheritance Hierarchy
Online System Object
NFX.Templatization CompileUnit

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CompileUnit
public class CompileUnit
Public Class CompileUnit
Public Class CompileUnit
public ref class CompileUnit
public ref class CompileUnit
type CompileUnit =  class end
type CompileUnit =  class end
See Also
CompileUnit Members
NFX.Templatization Namespace


CompileUnit Members

CompileUnit Members NFX Class Library

The CompileUnit type exposes the following members.
Constructors
 | Name | Description
Protected method | CompileUnit | Initializes a new instance of the CompileUnit class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | CompilationException | Returns an exception that was thrown during compilation
Public property | CompiledSource | Returns source code in a language that particular TemplateCompiler derivative supports. Use TemplateCompiler.LanguageName to determine language polymorphicaly
Public property | CompiledTemplateType | Returns CLR type that compiler produced IF language source compilation was performed
Public property | CompiledTemplateTypeName | Returns fully-qualified CLR type name that compiler produced
Public property | TemplateSource | References original template source such as a string for text-based templates or an image
Back to Top
See Also
CompileUnit Class
NFX.Templatization Namespace


CompileUnit Constructor

CompileUnit Constructor NFX Class Library

Initializes a new instance of the CompileUnit class

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
internal CompileUnit(
    ITemplateSource source
)
internal CompileUnit(
    ITemplateSource source
)
Friend Sub New (
    source As ITemplateSource
)
Friend Sub New (
    source As ITemplateSource
)
internal:
CompileUnit(
    ITemplateSource^ source
)
internal:
CompileUnit(
    ITemplateSource^ source
)
new :
        source : ITemplateSource -> CompileUnit
new :
        source : ITemplateSource -> CompileUnit

Parameters

source
Type: NFX.Templatization ITemplateSource
See Also
CompileUnit Class
CompileUnit Members
NFX.Templatization Namespace


CompileUnit Methods

CompileUnit Methods NFX Class Library

The CompileUnit type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CompileUnit Class
NFX.Templatization Namespace


CompileUnit Properties

CompileUnit Properties NFX Class Library

The CompileUnit type exposes the following members.
Properties
 | Name | Description
Public property | CompilationException | Returns an exception that was thrown during compilation
Public property | CompiledSource | Returns source code in a language that particular TemplateCompiler derivative supports. Use TemplateCompiler.LanguageName to determine language polymorphicaly
Public property | CompiledTemplateType | Returns CLR type that compiler produced IF language source compilation was performed
Public property | CompiledTemplateTypeName | Returns fully-qualified CLR type name that compiler produced
Public property | TemplateSource | References original template source such as a string for text-based templates or an image
Back to Top
See Also
CompileUnit Class
NFX.Templatization Namespace


CompileUnit.CompilationException Property

CompileUnit CompilationException Property NFX Class Library

Returns an exception that was thrown during compilation

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Exception CompilationException { get; internal set; }
public Exception CompilationException { get; internal set; }
Public Property CompilationException As Exception
    Get
    Friend Set
Public Property CompilationException As Exception
    Get
    Friend Set
public:
property Exception^ CompilationException {
    Exception^ get ();
    internal: void set (Exception^ value);
}
public:
property Exception^ CompilationException {
    Exception^ get ();
    internal: void set (Exception^ value);
}
member CompilationException : Exception with get, internal set
member CompilationException : Exception with get, internal set

Property Value

Type: Online Exception
See Also
CompileUnit Class
CompileUnit Members
NFX.Templatization Namespace


CompileUnit.CompiledSource Property

CompileUnit CompiledSource Property NFX Class Library

Returns source code in a language that particular TemplateCompiler derivative supports. Use TemplateCompiler.LanguageName to determine language polymorphicaly

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CompiledSource { get; internal set; }
public string CompiledSource { get; internal set; }
Public Property CompiledSource As String
    Get
    Friend Set
Public Property CompiledSource As String
    Get
    Friend Set
public:
property String^ CompiledSource {
    String^ get ();
    internal: void set (String^ value);
}
public:
property String^ CompiledSource {
    String^ get ();
    internal: void set (String^ value);
}
member CompiledSource : string with get, internal set
member CompiledSource : string with get, internal set

Property Value

Type: Online String
See Also
CompileUnit Class
CompileUnit Members
NFX.Templatization Namespace


CompileUnit.CompiledTemplateType Property

CompileUnit CompiledTemplateType Property NFX Class Library

Returns CLR type that compiler produced IF language source compilation was performed

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Type CompiledTemplateType { get; internal set; }
public Type CompiledTemplateType { get; internal set; }
Public Property CompiledTemplateType As Type
    Get
    Friend Set
Public Property CompiledTemplateType As Type
    Get
    Friend Set
public:
property Type^ CompiledTemplateType {
    Type^ get ();
    internal: void set (Type^ value);
}
public:
property Type^ CompiledTemplateType {
    Type^ get ();
    internal: void set (Type^ value);
}
member CompiledTemplateType : Type with get, internal set
member CompiledTemplateType : Type with get, internal set

Property Value

Type: Online Type
See Also
CompileUnit Class
CompileUnit Members
NFX.Templatization Namespace


CompileUnit.CompiledTemplateTypeName Property

CompileUnit CompiledTemplateTypeName Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns fully-qualified CLR type name that compiler produced

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CompiledTemplateTypeName { get; internal set; }
public string CompiledTemplateTypeName { get; internal set; }
Public Property CompiledTemplateTypeName As String
    Get
    Friend Set
Public Property CompiledTemplateTypeName As String
    Get
    Friend Set
public:
property String^ CompiledTemplateTypeName {
    String^ get ();
    internal: void set (String^ value);
}
public:
property String^ CompiledTemplateTypeName {
    String^ get ();
    internal: void set (String^ value);
}
member CompiledTemplateTypeName : string with get, internal set
member CompiledTemplateTypeName : string with get, internal set

Property Value

Type: Online String
See Also
CompileUnit Class
CompileUnit Members
NFX.Templatization Namespace


CompileUnit.TemplateSource Property

CompileUnit TemplateSource Property NFX Class Library

References original template source such as a string for text-based templates or an image

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ITemplateSource TemplateSource { get; }
public ITemplateSource TemplateSource { get; }
Public ReadOnly Property TemplateSource As ITemplateSource
    Get
Public ReadOnly Property TemplateSource As ITemplateSource
    Get
public:
property ITemplateSource^ TemplateSource {
    ITemplateSource^ get ();
}
public:
property ITemplateSource^ TemplateSource {
    ITemplateSource^ get ();
}
member TemplateSource : ITemplateSource with get
member TemplateSource : ITemplateSource with get

Property Value

Type: ITemplateSource
See Also
CompileUnit Class
CompileUnit Members
NFX.Templatization Namespace


CompileUnits Class

CompileUnits Class NFX Class Library

Represents a bag of compile units
Inheritance Hierarchy
Online System Object
Online System.Collections.Generic Dictionary ITemplateSource, CompileUnit
NFX.Templatization CompileUnits

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CompileUnits : Dictionary<ITemplateSource, CompileUnit>
public class CompileUnits : Dictionary<ITemplateSource, CompileUnit>
Public Class CompileUnits
    Inherits Dictionary(Of ITemplateSource, CompileUnit)
Public Class CompileUnits
    Inherits Dictionary(Of ITemplateSource, CompileUnit)
public ref class CompileUnits : public Dictionary<ITemplateSource^, CompileUnit^>
public ref class CompileUnits : public Dictionary<ITemplateSource^, CompileUnit^>
type CompileUnits =
    class
        inherit Dictionary<ITemplateSource, CompileUnit>
    end
type CompileUnits =
    class
        inherit Dictionary<ITemplateSource, CompileUnit>
    end
See Also
CompileUnits Members
NFX.Templatization Namespace


CompileUnits Members

CompileUnits Members NFX Class Library

The CompileUnits type exposes the following members.
Constructors
 | Name | Description
Public method | CompileUnits | Initializes a new instance of the CompileUnits class
Back to Top
Methods
 | Name | Description
Public method | Online Add | (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Public method | Online Clear | (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Public method | Online ContainsKey | (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Public method | Online ContainsValue | (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online Dictionary TKey, TValue instance. (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Public method | Online Remove | (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TryGetValue | (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | Online Comparer | (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Public property | Online Count | (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Public property | Online Item | (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Public property | Online Keys | (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Public property | Online Values | (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Back to Top
See Also
CompileUnits Class
NFX.Templatization Namespace


CompileUnits Constructor

CompileUnits Constructor NFX Class Library

Initializes a new instance of the CompileUnits class

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CompileUnits()
public CompileUnits()
Public Sub New
Public Sub New
public:
CompileUnits()
public:
CompileUnits()
new : unit -> CompileUnits
new : unit -> CompileUnits
See Also
CompileUnits Class
CompileUnits Members
NFX.Templatization Namespace


CompileUnits Methods

CompileUnits Methods NFX Class Library

The CompileUnits type exposes the following members.
Methods
 | Name | Description
Public method | Online Add | (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Public method | Online Clear | (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Public method | Online ContainsKey | (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Public method | Online ContainsValue | (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetEnumerator | (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | Implements the Online ISerializable interface and returns the data needed to serialize the Online Dictionary TKey, TValue instance. (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online OnDeserialization | Implements the Online ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Public method | Online Remove | (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | Online TryGetValue | (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
CompileUnits Class
NFX.Templatization Namespace


CompileUnits Properties

CompileUnits Properties NFX Class Library

The CompileUnits type exposes the following members.
Properties
 | Name | Description
Public property | Online Comparer | (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Public property | Online Count | (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Public property | Online Item | (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Public property | Online Keys | (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Public property | Online Values | (Inherited from Online Dictionary ITemplateSource, CompileUnit .)
Back to Top
See Also
CompileUnits Class
NFX.Templatization Namespace


FileTemplateStringContentSource Class

FileTemplateStringContentSource Class NFX Class Library

Represents a string template source that comes from a file
Inheritance Hierarchy
Online System Object
NFX.Templatization FileTemplateStringContentSource

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class FileTemplateStringContentSource : ITemplateSource<string>,
    ITemplateSource
public class FileTemplateStringContentSource : ITemplateSource<string>,
    ITemplateSource
Public Class FileTemplateStringContentSource
    Implements ITemplateSource(Of String), ITemplateSource
Public Class FileTemplateStringContentSource
    Implements ITemplateSource(Of String), ITemplateSource
public ref class FileTemplateStringContentSource : ITemplateSource<String^>,
    ITemplateSource
public ref class FileTemplateStringContentSource : ITemplateSource<String^>,
    ITemplateSource
type FileTemplateStringContentSource =
    class
        interface ITemplateSource<string>
        interface ITemplateSource
    end
type FileTemplateStringContentSource =
    class
        interface ITemplateSource<string>
        interface ITemplateSource
    end
See Also
FileTemplateStringContentSource Members
NFX.Templatization Namespace


FileTemplateStringContentSource Members

FileTemplateStringContentSource Members NFX Class Library

The FileTemplateStringContentSource type exposes the following members.
Constructors
 | Name | Description
Public method | FileTemplateStringContentSource | Initializes a new instance of the FileTemplateStringContentSource class
Back to Top
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | GetName | Gets printable source name
Public method | GetSourceContent |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | InferClassName | Returns the name of template class inferred from file name
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | FileName |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ITemplateSource GetSourceContent |
Back to Top
See Also
FileTemplateStringContentSource Class
NFX.Templatization Namespace


FileTemplateStringContentSource Constructor

FileTemplateStringContentSource Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FileTemplateStringContentSource class

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FileTemplateStringContentSource(
    string fileName
)
public FileTemplateStringContentSource(
    string fileName
)
Public Sub New (
    fileName As String
)
Public Sub New (
    fileName As String
)
public:
FileTemplateStringContentSource(
    String^ fileName
)
public:
FileTemplateStringContentSource(
    String^ fileName
)
new :
        fileName : string -> FileTemplateStringContentSource
new :
        fileName : string -> FileTemplateStringContentSource

Parameters

fileName
Type: Online System String
See Also
FileTemplateStringContentSource Class
FileTemplateStringContentSource Members
NFX.Templatization Namespace


FileTemplateStringContentSource Fields

FileTemplateStringContentSource Fields NFX Class Library

The FileTemplateStringContentSource type exposes the following members.
Fields
 | Name | Description
Public field | FileName |
Back to Top
See Also
FileTemplateStringContentSource Class
NFX.Templatization Namespace


FileTemplateStringContentSource.FileName Field

FileTemplateStringContentSource FileName Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string FileName
public readonly string FileName
Public ReadOnly FileName As String
Public ReadOnly FileName As String
public:
initonly String^ FileName
public:
initonly String^ FileName
val FileName: string
val FileName: string

Field Value

Type: Online String
See Also
FileTemplateStringContentSource Class
FileTemplateStringContentSource Members
NFX.Templatization Namespace


FileTemplateStringContentSource Methods

FileTemplateStringContentSource Methods NFX Class Library

The FileTemplateStringContentSource type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | GetName | Gets printable source name
Public method | GetSourceContent |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | InferClassName | Returns the name of template class inferred from file name
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ITemplateSource GetSourceContent |
Back to Top
See Also
FileTemplateStringContentSource Class
NFX.Templatization Namespace


FileTemplateStringContentSource.Equals Method

FileTemplateStringContentSource Equals Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
FileTemplateStringContentSource Class
FileTemplateStringContentSource Members
NFX.Templatization Namespace


FileTemplateStringContentSource.GetHashCode Method

FileTemplateStringContentSource GetHashCode Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
FileTemplateStringContentSource Class
FileTemplateStringContentSource Members
NFX.Templatization Namespace


FileTemplateStringContentSource.GetName Method

FileTemplateStringContentSource GetName Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets printable source name

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetName(
    int maxLength
)
public string GetName(
    int maxLength
)
Public Function GetName (
    maxLength As Integer
) As String
Public Function GetName (
    maxLength As Integer
) As String
public:
virtual String^ GetName(
    int maxLength
) sealed
public:
virtual String^ GetName(
    int maxLength
) sealed
abstract GetName :
        maxLength : int -> string
override GetName :
        maxLength : int -> string
abstract GetName :
        maxLength : int -> string
override GetName :
        maxLength : int -> string

Parameters

maxLength
Type: Online System Int32

Return Value

Type: Online String

Implements

ITemplateSource GetName(Int32)
See Also
FileTemplateStringContentSource Class
FileTemplateStringContentSource Members
NFX.Templatization Namespace


FileTemplateStringContentSource.GetSourceContent Method

FileTemplateStringContentSource GetSourceContent Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetSourceContent()
public string GetSourceContent()
Public Function GetSourceContent As String
Public Function GetSourceContent As String
public:
virtual String^ GetSourceContent() sealed
public:
virtual String^ GetSourceContent() sealed
abstract GetSourceContent : unit -> string
override GetSourceContent : unit -> string
abstract GetSourceContent : unit -> string
override GetSourceContent : unit -> string

Return Value

Type: Online String

Implements

ITemplateSource T GetSourceContent
See Also
FileTemplateStringContentSource Class
FileTemplateStringContentSource Members
NFX.Templatization Namespace


FileTemplateStringContentSource.InferClassName Method

FileTemplateStringContentSource InferClassName Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns the name of template class inferred from file name

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string InferClassName()
public string InferClassName()
Public Function InferClassName As String
Public Function InferClassName As String
public:
virtual String^ InferClassName() sealed
public:
virtual String^ InferClassName() sealed
abstract InferClassName : unit -> string
override InferClassName : unit -> string
abstract InferClassName : unit -> string
override InferClassName : unit -> string

Return Value

Type: Online String

Implements

ITemplateSource InferClassName
See Also
FileTemplateStringContentSource Class
FileTemplateStringContentSource Members
NFX.Templatization Namespace


FileTemplateStringContentSource.ITemplateSource.GetSourceContent Method

FileTemplateStringContentSource ITemplateSource GetSourceContent Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object ITemplateSource.GetSourceContent()
Object ITemplateSource.GetSourceContent()
Private Function GetSourceContent As Object
    Implements ITemplateSource.GetSourceContent
Private Function GetSourceContent As Object
    Implements ITemplateSource.GetSourceContent
private:
virtual Object^ GetSourceContent() sealed = ITemplateSource::GetSourceContent
private:
virtual Object^ GetSourceContent() sealed = ITemplateSource::GetSourceContent
private abstract GetSourceContent : unit -> Object
private override GetSourceContent : unit -> Object
private abstract GetSourceContent : unit -> Object
private override GetSourceContent : unit -> Object

Return Value

Type: Online Object

Implements

ITemplateSource GetSourceContent
See Also
FileTemplateStringContentSource Class
FileTemplateStringContentSource Members
NFX.Templatization Namespace


FileTemplateStringContentSource.ToString Method

FileTemplateStringContentSource ToString Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
FileTemplateStringContentSource Class
FileTemplateStringContentSource Members
NFX.Templatization Namespace


IRenderingTarget Interface

IRenderingTarget Interface NFX Class Library

Defines an entity that a template can be rendered into. Templates are not necessarily text-based, consequently data is supplied as objects

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface IRenderingTarget
public interface IRenderingTarget
Public Interface IRenderingTarget
Public Interface IRenderingTarget
public interface class IRenderingTarget
public interface class IRenderingTarget
type IRenderingTarget =  interface end
type IRenderingTarget =  interface end
See Also
IRenderingTarget Members
NFX.Templatization Namespace


IRenderingTarget Members

IRenderingTarget Members NFX Class Library

The IRenderingTarget type exposes the following members.
Methods
 | Name | Description
Public method | Encode | Encodes an object per underlying target specification. For example, a Http-related target may encode strings using HttpEncoder. If particular target does not support encoding then this method should just return the argument unmodified
Public method | Flush | Flushes writes into underlying target implementation. If target does not support buffering then this call does nothing
Public method | Write | Writes a generic object into target. Templates are not necessarily text-based, consequently this method takes an object argument
Back to Top
See Also
IRenderingTarget Interface
NFX.Templatization Namespace


IRenderingTarget Methods

IRenderingTarget Methods NFX Class Library

The IRenderingTarget type exposes the following members.
Methods
 | Name | Description
Public method | Encode | Encodes an object per underlying target specification. For example, a Http-related target may encode strings using HttpEncoder. If particular target does not support encoding then this method should just return the argument unmodified
Public method | Flush | Flushes writes into underlying target implementation. If target does not support buffering then this call does nothing
Public method | Write | Writes a generic object into target. Templates are not necessarily text-based, consequently this method takes an object argument
Back to Top
See Also
IRenderingTarget Interface
NFX.Templatization Namespace


IRenderingTarget.Encode Method

IRenderingTarget Encode Method NFX Class Library

Encodes an object per underlying target specification. For example, a Http-related target may encode strings using HttpEncoder. If particular target does not support encoding then this method should just return the argument unmodified

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object Encode(
    Object value
)
Object Encode(
    Object value
)
Function Encode (
    value As Object
) As Object
Function Encode (
    value As Object
) As Object
Object^ Encode(
    Object^ value
)
Object^ Encode(
    Object^ value
)
abstract Encode :
        value : Object -> Object
abstract Encode :
        value : Object -> Object

Parameters

value
Type: Online System Object

Return Value

Type: Online Object
See Also
IRenderingTarget Interface
IRenderingTarget Members
NFX.Templatization Namespace


IRenderingTarget.Flush Method

IRenderingTarget Flush Method NFX Class Library

Flushes writes into underlying target implementation. If target does not support buffering then this call does nothing

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Flush()
void Flush()
Sub Flush
Sub Flush
void Flush()
void Flush()
abstract Flush : unit -> unit
abstract Flush : unit -> unit
See Also
IRenderingTarget Interface
IRenderingTarget Members
NFX.Templatization Namespace


IRenderingTarget.Write Method

IRenderingTarget Write Method NFX Class Library

Writes a generic object into target. Templates are not necessarily text-based, consequently this method takes an object argument

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Write(
    Object value
)
void Write(
    Object value
)
Sub Write (
    value As Object
)
Sub Write (
    value As Object
)
void Write(
    Object^ value
)
void Write(
    Object^ value
)
abstract Write :
        value : Object -> unit
abstract Write :
        value : Object -> unit

Parameters

value
Type: Online System Object
See Also
IRenderingTarget Interface
IRenderingTarget Members
NFX.Templatization Namespace


ITemplate Interface

ITemplate Interface NFX Class Library

A general template interface. A template is a class that gets instantiated at some point to Render() its content into IRenderingTarget instance. Templates are not necessarily text-based, i.e. they can be image-based or based on various kinds of binary files

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ITemplate
public interface ITemplate
Public Interface ITemplate
Public Interface ITemplate
public interface class ITemplate
public interface class ITemplate
type ITemplate =  interface end
type ITemplate =  interface end
See Also
ITemplate Members
NFX.Templatization Namespace


ITemplate Members

ITemplate Members NFX Class Library

The ITemplate type exposes the following members.
Methods
 | Name | Description
Public method | Render | Renders template by generating content into target
Back to Top
Properties
 | Name | Description
Public property | CanReuseInstance | Indicates whether an instance of template class may be reused for invocation of Render() more than once (possibly with different rendering target and/or rendering context)
Public property | Context | Custom context for the lifetime of this template
Back to Top
See Also
ITemplate Interface
NFX.Templatization Namespace


ITemplate Methods

ITemplate Methods NFX Class Library

The ITemplate type exposes the following members.
Methods
 | Name | Description
Public method | Render | Renders template by generating content into target
Back to Top
See Also
ITemplate Interface
NFX.Templatization Namespace


ITemplate.Render Method

ITemplate Render Method NFX Class Library

Renders template by generating content into target

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void Render(
    IRenderingTarget target,
    Object renderingContext
)
void Render(
    IRenderingTarget target,
    Object renderingContext
)
Sub Render (
    target As IRenderingTarget,
    renderingContext As Object
)
Sub Render (
    target As IRenderingTarget,
    renderingContext As Object
)
void Render(
    IRenderingTarget^ target,
    Object^ renderingContext
)
void Render(
    IRenderingTarget^ target,
    Object^ renderingContext
)
abstract Render :
        target : IRenderingTarget *
        renderingContext : Object -> unit
abstract Render :
        target : IRenderingTarget *
        renderingContext : Object -> unit

Parameters

target
Type: NFX.Templatization IRenderingTarget
A target that rendering is done into
renderingContext
Type: Online System Object
A context object for this rendering call
See Also
ITemplate Interface
ITemplate Members
NFX.Templatization Namespace


ITemplate Properties

ITemplate Properties NFX Class Library

The ITemplate type exposes the following members.
Properties
 | Name | Description
Public property | CanReuseInstance | Indicates whether an instance of template class may be reused for invocation of Render() more than once (possibly with different rendering target and/or rendering context)
Public property | Context | Custom context for the lifetime of this template
Back to Top
See Also
ITemplate Interface
NFX.Templatization Namespace


ITemplate.CanReuseInstance Property

ITemplate CanReuseInstance Property NFX Class Library

Indicates whether an instance of template class may be reused for invocation of Render() more than once (possibly with different rendering target and/or rendering context)

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
bool CanReuseInstance { get; }
bool CanReuseInstance { get; }
ReadOnly Property CanReuseInstance As Boolean
    Get
ReadOnly Property CanReuseInstance As Boolean
    Get
property bool CanReuseInstance {
    bool get ();
}
property bool CanReuseInstance {
    bool get ();
}
abstract CanReuseInstance : bool with get
abstract CanReuseInstance : bool with get

Property Value

Type: Online Boolean
See Also
ITemplate Interface
ITemplate Members
NFX.Templatization Namespace


ITemplate.Context Property

ITemplate Context Property NFX Class Library

Custom context for the lifetime of this template

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object Context { get; }
Object Context { get; }
ReadOnly Property Context As Object
    Get
ReadOnly Property Context As Object
    Get
property Object^ Context {
    Object^ get ();
}
property Object^ Context {
    Object^ get ();
}
abstract Context : Object with get
abstract Context : Object with get

Property Value

Type: Online Object
See Also
ITemplate Interface
ITemplate Members
NFX.Templatization Namespace


ITemplateSource Interface

ITemplateSource Interface NFX Class Library

Describes an entity that provides source for template

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ITemplateSource
public interface ITemplateSource
Public Interface ITemplateSource
Public Interface ITemplateSource
public interface class ITemplateSource
public interface class ITemplateSource
type ITemplateSource =  interface end
type ITemplateSource =  interface end
See Also
ITemplateSource Members
NFX.Templatization Namespace


ITemplateSource Members

ITemplateSource Members NFX Class Library

The ITemplateSource type exposes the following members.
Methods
 | Name | Description
Public method | GetName | Gets printable source name
Public method | GetSourceContent | Returns template source content
Public method | InferClassName | Tries to suggest a class name for this content or null
Back to Top
See Also
ITemplateSource Interface
NFX.Templatization Namespace


ITemplateSource Methods

ITemplateSource Methods NFX Class Library

The ITemplateSource type exposes the following members.
Methods
 | Name | Description
Public method | GetName | Gets printable source name
Public method | GetSourceContent | Returns template source content
Public method | InferClassName | Tries to suggest a class name for this content or null
Back to Top
See Also
ITemplateSource Interface
NFX.Templatization Namespace


ITemplateSource.GetName Method

ITemplateSource GetName Method NFX Class Library

Gets printable source name

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string GetName(
    int maxLength
)
string GetName(
    int maxLength
)
Function GetName (
    maxLength As Integer
) As String
Function GetName (
    maxLength As Integer
) As String
String^ GetName(
    int maxLength
)
String^ GetName(
    int maxLength
)
abstract GetName :
        maxLength : int -> string
abstract GetName :
        maxLength : int -> string

Parameters

maxLength
Type: Online System Int32

Return Value

Type: Online String
See Also
ITemplateSource Interface
ITemplateSource Members
NFX.Templatization Namespace


ITemplateSource.GetSourceContent Method

ITemplateSource GetSourceContent Method NFX Class Library

Returns template source content

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object GetSourceContent()
Object GetSourceContent()
Function GetSourceContent As Object
Function GetSourceContent As Object
Object^ GetSourceContent()
Object^ GetSourceContent()
abstract GetSourceContent : unit -> Object
abstract GetSourceContent : unit -> Object

Return Value

Type: Online Object
See Also
ITemplateSource Interface
ITemplateSource Members
NFX.Templatization Namespace


ITemplateSource.InferClassName Method

ITemplateSource InferClassName Method NFX Class Library

Tries to suggest a class name for this content or null

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
string InferClassName()
string InferClassName()
Function InferClassName As String
Function InferClassName As String
String^ InferClassName()
String^ InferClassName()
abstract InferClassName : unit -> string
abstract InferClassName : unit -> string

Return Value

Type: Online String
See Also
ITemplateSource Interface
ITemplateSource Members
NFX.Templatization Namespace


ITemplateSource(T) Interface

ITemplateSource T Interface NFX Class Library

Describes an entity that provides source for templates

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public interface ITemplateSource<T> : ITemplateSource
public interface ITemplateSource<T> : ITemplateSource
Public Interface ITemplateSource(Of T)
    Inherits ITemplateSource
Public Interface ITemplateSource(Of T)
    Inherits ITemplateSource
generic<typename T>
public interface class ITemplateSource : ITemplateSource
generic<typename T>
public interface class ITemplateSource : ITemplateSource
type ITemplateSource<'T> =
    interface
        interface ITemplateSource
    end
type ITemplateSource<'T> =
    interface
        interface ITemplateSource
    end
Type Parameters
T
See Also
ITemplateSource T Members
NFX.Templatization Namespace


ITemplateSource(T) Members

ITemplateSource T Members NFX Class Library

The ITemplateSource T type exposes the following members.
Methods
 | Name | Description
Public method | GetName | Gets printable source name (Inherited from ITemplateSource.)
Public method | GetSourceContent | Returns template source content (Inherited from ITemplateSource.)
Public method | GetSourceContent | Returns template source content
Public method | InferClassName | Tries to suggest a class name for this content or null (Inherited from ITemplateSource.)
Back to Top
See Also
ITemplateSource T Interface
NFX.Templatization Namespace


ITemplateSource(T) Methods

ITemplateSource T Methods NFX Class Library

The ITemplateSource T type exposes the following members.
Methods
 | Name | Description
Public method | GetName | Gets printable source name (Inherited from ITemplateSource.)
Public method | GetSourceContent | Returns template source content (Inherited from ITemplateSource.)
Public method | GetSourceContent | Returns template source content
Public method | InferClassName | Tries to suggest a class name for this content or null (Inherited from ITemplateSource.)
Back to Top
See Also
ITemplateSource T Interface
NFX.Templatization Namespace


ITemplateSource(T).GetSourceContent Method

ITemplateSource T GetSourceContent Method NFX Class Library

Overload List
 | Name | Description
Public method | GetSourceContent | Returns template source content (Inherited from ITemplateSource.)
Public method | GetSourceContent | Returns template source content
Back to Top
See Also
ITemplateSource T Interface
ITemplateSource T Members
NFX.Templatization Namespace


ITemplateSource(T).GetSourceContent Method

ITemplateSource T GetSourceContent Method NFX Class Library

Returns template source content

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
T GetSourceContent()
T GetSourceContent()
Function GetSourceContent As T
Function GetSourceContent As T
T GetSourceContent()
T GetSourceContent()
abstract GetSourceContent : unit -> 'T
abstract GetSourceContent : unit -> 'T

Return Value

Type: T
See Also
ITemplateSource T Interface
ITemplateSource T Members
GetSourceContent Overload
NFX.Templatization Namespace


StringRenderingTarget Class

StringRenderingTarget Class NFX Class Library

Renders templates into string
Inheritance Hierarchy
Online System Object
NFX.Templatization StringRenderingTarget

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class StringRenderingTarget : IRenderingTarget
public class StringRenderingTarget : IRenderingTarget
Public Class StringRenderingTarget
    Implements IRenderingTarget
Public Class StringRenderingTarget
    Implements IRenderingTarget
public ref class StringRenderingTarget : IRenderingTarget
public ref class StringRenderingTarget : IRenderingTarget
type StringRenderingTarget =
    class
        interface IRenderingTarget
    end
type StringRenderingTarget =
    class
        interface IRenderingTarget
    end
See Also
StringRenderingTarget Members
NFX.Templatization Namespace


StringRenderingTarget Members

StringRenderingTarget Members NFX Class Library

The StringRenderingTarget type exposes the following members.
Constructors
 | Name | Description
Public method | StringRenderingTarget | Initializes a new instance of the StringRenderingTarget class
Public method | StringRenderingTarget(Boolean) | Initializes a new instance of the StringRenderingTarget class
Back to Top
Methods
 | Name | Description
Public method | Encode |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Returns what has been written (Overrides Online Object ToString .)
Public method | Write(Object) |
Public method | Write(String) |
Public method | WriteLine(Object) |
Public method | WriteLine(String) |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | EncodeHtml |
Back to Top
Properties
 | Name | Description
Public property | Value | Returns what has been written
Back to Top
See Also
StringRenderingTarget Class
NFX.Templatization Namespace


StringRenderingTarget Constructor

StringRenderingTarget Constructor NFX Class Library

Overload List
 | Name | Description
Public method | StringRenderingTarget | Initializes a new instance of the StringRenderingTarget class
Public method | StringRenderingTarget(Boolean) | Initializes a new instance of the StringRenderingTarget class
Back to Top
See Also
StringRenderingTarget Class
StringRenderingTarget Members
NFX.Templatization Namespace


StringRenderingTarget Constructor

StringRenderingTarget Constructor NFX Class Library

Initializes a new instance of the StringRenderingTarget class

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StringRenderingTarget()
public StringRenderingTarget()
Public Sub New
Public Sub New
public:
StringRenderingTarget()
public:
StringRenderingTarget()
new : unit -> StringRenderingTarget
new : unit -> StringRenderingTarget
See Also
StringRenderingTarget Class
StringRenderingTarget Members
StringRenderingTarget Overload
NFX.Templatization Namespace


StringRenderingTarget Constructor (Boolean)

StringRenderingTarget Constructor (Boolean) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the StringRenderingTarget class

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public StringRenderingTarget(
    bool encodeHtml
)
public StringRenderingTarget(
    bool encodeHtml
)
Public Sub New (
    encodeHtml As Boolean
)
Public Sub New (
    encodeHtml As Boolean
)
public:
StringRenderingTarget(
    bool encodeHtml
)
public:
StringRenderingTarget(
    bool encodeHtml
)
new :
        encodeHtml : bool -> StringRenderingTarget
new :
        encodeHtml : bool -> StringRenderingTarget

Parameters

encodeHtml
Type: Online System Boolean
See Also
StringRenderingTarget Class
StringRenderingTarget Members
StringRenderingTarget Overload
NFX.Templatization Namespace


StringRenderingTarget Fields

StringRenderingTarget Fields NFX Class Library

The StringRenderingTarget type exposes the following members.
Fields
 | Name | Description
Public field | EncodeHtml |
Back to Top
See Also
StringRenderingTarget Class
NFX.Templatization Namespace


StringRenderingTarget.EncodeHtml Field

StringRenderingTarget EncodeHtml Field NFX Class Library

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly bool EncodeHtml
public readonly bool EncodeHtml
Public ReadOnly EncodeHtml As Boolean
Public ReadOnly EncodeHtml As Boolean
public:
initonly bool EncodeHtml
public:
initonly bool EncodeHtml
val EncodeHtml: bool
val EncodeHtml: bool

Field Value

Type: Online Boolean
See Also
StringRenderingTarget Class
StringRenderingTarget Members
NFX.Templatization Namespace


StringRenderingTarget Methods

StringRenderingTarget Methods NFX Class Library

The StringRenderingTarget type exposes the following members.
Methods
 | Name | Description
Public method | Encode |
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Flush |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | Returns what has been written (Overrides Online Object ToString .)
Public method | Write(Object) |
Public method | Write(String) |
Public method | WriteLine(Object) |
Public method | WriteLine(String) |
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
See Also
StringRenderingTarget Class
NFX.Templatization Namespace


StringRenderingTarget.Encode Method

StringRenderingTarget Encode Method NFX Class Library

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Encode(
    Object value
)
public Object Encode(
    Object value
)
Public Function Encode (
    value As Object
) As Object
Public Function Encode (
    value As Object
) As Object
public:
virtual Object^ Encode(
    Object^ value
) sealed
public:
virtual Object^ Encode(
    Object^ value
) sealed
abstract Encode :
        value : Object -> Object
override Encode :
        value : Object -> Object
abstract Encode :
        value : Object -> Object
override Encode :
        value : Object -> Object

Parameters

value
Type: Online System Object

Return Value

Type: Online Object

Implements

IRenderingTarget Encode(Object)
See Also
StringRenderingTarget Class
StringRenderingTarget Members
NFX.Templatization Namespace


StringRenderingTarget.Flush Method

StringRenderingTarget Flush Method NFX Class Library

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Flush()
public void Flush()
Public Sub Flush
Public Sub Flush
public:
virtual void Flush() sealed
public:
virtual void Flush() sealed
abstract Flush : unit -> unit
override Flush : unit -> unit
abstract Flush : unit -> unit
override Flush : unit -> unit

Implements

IRenderingTarget Flush
See Also
StringRenderingTarget Class
StringRenderingTarget Members
NFX.Templatization Namespace


StringRenderingTarget.ToString Method

StringRenderingTarget ToString Method NFX Class Library

Returns what has been written

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
StringRenderingTarget Class
StringRenderingTarget Members
NFX.Templatization Namespace


StringRenderingTarget.Write Method

StringRenderingTarget Write Method NFX Class Library

Overload List
 | Name | Description
Public method | Write(Object) |
Public method | Write(String) |
Back to Top
See Also
StringRenderingTarget Class
StringRenderingTarget Members
NFX.Templatization Namespace


StringRenderingTarget.Write Method (Object)

StringRenderingTarget Write Method (Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Write(
    Object value
)
public void Write(
    Object value
)
Public Sub Write (
    value As Object
)
Public Sub Write (
    value As Object
)
public:
virtual void Write(
    Object^ value
) sealed
public:
virtual void Write(
    Object^ value
) sealed
abstract Write :
        value : Object -> unit
override Write :
        value : Object -> unit
abstract Write :
        value : Object -> unit
override Write :
        value : Object -> unit

Parameters

value
Type: Online System Object

Implements

IRenderingTarget Write(Object)
See Also
StringRenderingTarget Class
StringRenderingTarget Members
Write Overload
NFX.Templatization Namespace


StringRenderingTarget.Write Method (String)

StringRenderingTarget Write Method (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Write(
    string value
)
public void Write(
    string value
)
Public Sub Write (
    value As String
)
Public Sub Write (
    value As String
)
public:
void Write(
    String^ value
)
public:
void Write(
    String^ value
)
member Write :
        value : string -> unit
member Write :
        value : string -> unit

Parameters

value
Type: Online System String
See Also
StringRenderingTarget Class
StringRenderingTarget Members
Write Overload
NFX.Templatization Namespace


StringRenderingTarget.WriteLine Method

StringRenderingTarget WriteLine Method NFX Class Library

Overload List
 | Name | Description
Public method | WriteLine(Object) |
Public method | WriteLine(String) |
Back to Top
See Also
StringRenderingTarget Class
StringRenderingTarget Members
NFX.Templatization Namespace


StringRenderingTarget.WriteLine Method (Object)

StringRenderingTarget WriteLine Method (Object) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteLine(
    Object value
)
public void WriteLine(
    Object value
)
Public Sub WriteLine (
    value As Object
)
Public Sub WriteLine (
    value As Object
)
public:
void WriteLine(
    Object^ value
)
public:
void WriteLine(
    Object^ value
)
member WriteLine :
        value : Object -> unit
member WriteLine :
        value : Object -> unit

Parameters

value
Type: Online System Object
See Also
StringRenderingTarget Class
StringRenderingTarget Members
WriteLine Overload
NFX.Templatization Namespace


StringRenderingTarget.WriteLine Method (String)

StringRenderingTarget WriteLine Method (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteLine(
    string value
)
public void WriteLine(
    string value
)
Public Sub WriteLine (
    value As String
)
Public Sub WriteLine (
    value As String
)
public:
void WriteLine(
    String^ value
)
public:
void WriteLine(
    String^ value
)
member WriteLine :
        value : string -> unit
member WriteLine :
        value : string -> unit

Parameters

value
Type: Online System String
See Also
StringRenderingTarget Class
StringRenderingTarget Members
WriteLine Overload
NFX.Templatization Namespace


StringRenderingTarget Properties

StringRenderingTarget Properties NFX Class Library

The StringRenderingTarget type exposes the following members.
Properties
 | Name | Description
Public property | Value | Returns what has been written
Back to Top
See Also
StringRenderingTarget Class
NFX.Templatization Namespace


StringRenderingTarget.Value Property

StringRenderingTarget Value Property NFX Class Library

Returns what has been written

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Value { get; }
public string Value { get; }
Public ReadOnly Property Value As String
    Get
Public ReadOnly Property Value As String
    Get
public:
property String^ Value {
    String^ get ();
}
public:
property String^ Value {
    String^ get ();
}
member Value : string with get
member Value : string with get

Property Value

Type: Online String
See Also
StringRenderingTarget Class
StringRenderingTarget Members
NFX.Templatization Namespace


Template(TContext, TTarget, TRenderingContext) Class

Template TContext, TTarget, TRenderingContext Class NFX Class Library

[This is preliminary documentation and is subject to change.]

A general ancestor for any template. All templates derive from this class directly or indirectly. A template is a class that gets instantiated at some point to Render() its content into IRenderingTarget instance. Templates are not necessarily text-based, i.e. they can be image-based or based on various kinds of binary files
Inheritance Hierarchy
Online System Object
NFX.Templatization Template TContext, TTarget, TRenderingContext
NFX.Wave.Templatization WaveTemplate

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class Template<TContext, TTarget, TRenderingContext> : ITemplate
where TContext : class
where TTarget : class, IRenderingTarget
public abstract class Template<TContext, TTarget, TRenderingContext> : ITemplate
where TContext : class
where TTarget : class, IRenderingTarget
Public MustInherit Class Template(Of TContext As Class, TTarget As {Class, IRenderingTarget}, TRenderingContext)
    Implements ITemplate
Public MustInherit Class Template(Of TContext As Class, TTarget As {Class, IRenderingTarget}, TRenderingContext)
    Implements ITemplate
generic<typename TContext, typename TTarget, typename TRenderingContext>
where TContext : ref class
where TTarget : ref class, IRenderingTarget
public ref class Template abstract : ITemplate
generic<typename TContext, typename TTarget, typename TRenderingContext>
where TContext : ref class
where TTarget : ref class, IRenderingTarget
public ref class Template abstract : ITemplate
[<AbstractClassAttribute>]
type Template<'TContext, 'TTarget, 'TRenderingContext when 'TContext : not struct when 'TTarget : not struct and IRenderingTarget> =
    class
        interface ITemplate
    end
[<AbstractClassAttribute>]
type Template<'TContext, 'TTarget, 'TRenderingContext when 'TContext : not struct when 'TTarget : not struct and IRenderingTarget> =
    class
        interface ITemplate
    end
Type Parameters
TContext
TTarget
TRenderingContext
See Also
Template TContext, TTarget, TRenderingContext Members
NFX.Templatization Namespace


Template(TContext, TTarget, TRenderingContext) Members

Template TContext, TTarget, TRenderingContext Members NFX Class Library

[This is preliminary documentation and is subject to change.]

The Template TContext, TTarget, TRenderingContext type exposes the following members.
Constructors
 | Name | Description
Protected method | Template TContext, TTarget, TRenderingContext | Initializes a new instance of the Template TContext, TTarget, TRenderingContext class
Protected method | Template TContext, TTarget, TRenderingContext (TContext) | Initializes a new instance of the Template TContext, TTarget, TRenderingContext class
Back to Top
Methods
 | Name | Description
Public method | BindGlobalContexts | Infrastructure. Sets Context property. Normally this method should never be called by developers
Protected method | DoContextBinding | Infrastructure. Override to perform extra steps after Context property gets set. Normally this method should never be called by developers
Protected method | DoPostRender | Performs post-rendering actions. Return true to rethrow error
Protected method | DoPreRender | Performs pre-rendering actions
Protected method | DoRender | Performs actual rendering
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Render | Renders template by generating content into target
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Properties
 | Name | Description
Public property | CanReuseInstance | Indicates whether an instance of template class may be reused for invocation of Render() more than once (possibly with different rendering target and/or rendering context)
Public property | Context | Custom context for the lifetime of this template
Public property | RenderingContext | Returns thread-local rendering context which is specific for this call to Render()
Public property | Target | Returns thread-local target which is specific for this call to Render()
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ITemplate Context |
Explicit interface implemetation | ITemplate Render |
Back to Top
See Also
Template TContext, TTarget, TRenderingContext Class
NFX.Templatization Namespace


Template(TContext, TTarget, TRenderingContext) Constructor

Template TContext, TTarget, TRenderingContext Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Protected method | Template TContext, TTarget, TRenderingContext | Initializes a new instance of the Template TContext, TTarget, TRenderingContext class
Protected method | Template TContext, TTarget, TRenderingContext (TContext) | Initializes a new instance of the Template TContext, TTarget, TRenderingContext class
Back to Top
See Also
Template TContext, TTarget, TRenderingContext Class
Template TContext, TTarget, TRenderingContext Members
NFX.Templatization Namespace


Template(TContext, TTarget, TRenderingContext) Constructor

Template TContext, TTarget, TRenderingContext Constructor NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Template TContext, TTarget, TRenderingContext class

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Template()
protected Template()
Protected Sub New
Protected Sub New
protected:
Template()
protected:
Template()
new : unit -> Template
new : unit -> Template
See Also
Template TContext, TTarget, TRenderingContext Class
Template TContext, TTarget, TRenderingContext Members
Template TContext, TTarget, TRenderingContext Overload
NFX.Templatization Namespace


Template(TContext, TTarget, TRenderingContext) Constructor (TContext)

Template TContext, TTarget, TRenderingContext Constructor (TContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Template TContext, TTarget, TRenderingContext class

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Template(
    TContext context
)
protected Template(
    TContext context
)
Protected Sub New (
    context As TContext
)
Protected Sub New (
    context As TContext
)
protected:
Template(
    TContext context
)
protected:
Template(
    TContext context
)
new :
        context : 'TContext -> Template
new :
        context : 'TContext -> Template

Parameters

context
Type: TContext
See Also
Template TContext, TTarget, TRenderingContext Class
Template TContext, TTarget, TRenderingContext Members
Template TContext, TTarget, TRenderingContext Overload
NFX.Templatization Namespace


Template(TContext, TTarget, TRenderingContext) Methods

Template TContext, TTarget, TRenderingContext Methods NFX Class Library

[This is preliminary documentation and is subject to change.]

The Template TContext, TTarget, TRenderingContext type exposes the following members.
Methods
 | Name | Description
Public method | BindGlobalContexts | Infrastructure. Sets Context property. Normally this method should never be called by developers
Protected method | DoContextBinding | Infrastructure. Override to perform extra steps after Context property gets set. Normally this method should never be called by developers
Protected method | DoPostRender | Performs post-rendering actions. Return true to rethrow error
Protected method | DoPreRender | Performs pre-rendering actions
Protected method | DoRender | Performs actual rendering
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Render | Renders template by generating content into target
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ITemplate Render |
Back to Top
See Also
Template TContext, TTarget, TRenderingContext Class
NFX.Templatization Namespace


Template(TContext, TTarget, TRenderingContext).BindGlobalContexts Method

Template TContext, TTarget, TRenderingContext BindGlobalContexts Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Infrastructure. Sets Context property. Normally this method should never be called by developers

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void BindGlobalContexts(
    TContext context
)
public void BindGlobalContexts(
    TContext context
)
Public Sub BindGlobalContexts (
    context As TContext
)
Public Sub BindGlobalContexts (
    context As TContext
)
public:
void BindGlobalContexts(
    TContext context
)
public:
void BindGlobalContexts(
    TContext context
)
member BindGlobalContexts :
        context : 'TContext -> unit
member BindGlobalContexts :
        context : 'TContext -> unit

Parameters

context
Type: TContext
See Also
Template TContext, TTarget, TRenderingContext Class
Template TContext, TTarget, TRenderingContext Members
NFX.Templatization Namespace


Template(TContext, TTarget, TRenderingContext).DoContextBinding Method

Template TContext, TTarget, TRenderingContext DoContextBinding Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Infrastructure. Override to perform extra steps after Context property gets set. Normally this method should never be called by developers

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoContextBinding()
protected virtual void DoContextBinding()
Protected Overridable Sub DoContextBinding
Protected Overridable Sub DoContextBinding
protected:
virtual void DoContextBinding()
protected:
virtual void DoContextBinding()
abstract DoContextBinding : unit -> unit
override DoContextBinding : unit -> unit
abstract DoContextBinding : unit -> unit
override DoContextBinding : unit -> unit
See Also
Template TContext, TTarget, TRenderingContext Class
Template TContext, TTarget, TRenderingContext Members
NFX.Templatization Namespace


Template(TContext, TTarget, TRenderingContext).DoPostRender Method

Template TContext, TTarget, TRenderingContext DoPostRender Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Performs post-rendering actions. Return true to rethrow error

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual bool DoPostRender(
    Exception error
)
protected virtual bool DoPostRender(
    Exception error
)
Protected Overridable Function DoPostRender (
    error As Exception
) As Boolean
Protected Overridable Function DoPostRender (
    error As Exception
) As Boolean
protected:
virtual bool DoPostRender(
    Exception^ error
)
protected:
virtual bool DoPostRender(
    Exception^ error
)
abstract DoPostRender :
        error : Exception -> bool
override DoPostRender :
        error : Exception -> bool
abstract DoPostRender :
        error : Exception -> bool
override DoPostRender :
        error : Exception -> bool

Parameters

error
Type: Online System Exception

Return Value

Type: Online Boolean
See Also
Template TContext, TTarget, TRenderingContext Class
Template TContext, TTarget, TRenderingContext Members
NFX.Templatization Namespace


Template(TContext, TTarget, TRenderingContext).DoPreRender Method

Template TContext, TTarget, TRenderingContext DoPreRender Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Performs pre-rendering actions

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoPreRender()
protected virtual void DoPreRender()
Protected Overridable Sub DoPreRender
Protected Overridable Sub DoPreRender
protected:
virtual void DoPreRender()
protected:
virtual void DoPreRender()
abstract DoPreRender : unit -> unit
override DoPreRender : unit -> unit
abstract DoPreRender : unit -> unit
override DoPreRender : unit -> unit
See Also
Template TContext, TTarget, TRenderingContext Class
Template TContext, TTarget, TRenderingContext Members
NFX.Templatization Namespace


Template(TContext, TTarget, TRenderingContext).DoRender Method

Template TContext, TTarget, TRenderingContext DoRender Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Performs actual rendering

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoRender()
protected virtual void DoRender()
Protected Overridable Sub DoRender
Protected Overridable Sub DoRender
protected:
virtual void DoRender()
protected:
virtual void DoRender()
abstract DoRender : unit -> unit
override DoRender : unit -> unit
abstract DoRender : unit -> unit
override DoRender : unit -> unit
See Also
Template TContext, TTarget, TRenderingContext Class
Template TContext, TTarget, TRenderingContext Members
NFX.Templatization Namespace


Template(TContext, TTarget, TRenderingContext).ITemplate.Render Method

Template TContext, TTarget, TRenderingContext ITemplate Render Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
void ITemplate.Render(
    IRenderingTarget target,
    Object renderingContext
)
void ITemplate.Render(
    IRenderingTarget target,
    Object renderingContext
)
Private Sub Render (
    target As IRenderingTarget,
    renderingContext As Object
) Implements ITemplate.Render
Private Sub Render (
    target As IRenderingTarget,
    renderingContext As Object
) Implements ITemplate.Render
private:
virtual void Render(
    IRenderingTarget^ target,
    Object^ renderingContext
) sealed = ITemplate::Render
private:
virtual void Render(
    IRenderingTarget^ target,
    Object^ renderingContext
) sealed = ITemplate::Render
private abstract Render :
        target : IRenderingTarget *
        renderingContext : Object -> unit
private override Render :
        target : IRenderingTarget *
        renderingContext : Object -> unit
private abstract Render :
        target : IRenderingTarget *
        renderingContext : Object -> unit
private override Render :
        target : IRenderingTarget *
        renderingContext : Object -> unit

Parameters

target
Type: NFX.Templatization IRenderingTarget
renderingContext
Type: Online System Object

Implements

ITemplate Render(IRenderingTarget, Object)
See Also
Template TContext, TTarget, TRenderingContext Class
Template TContext, TTarget, TRenderingContext Members
NFX.Templatization Namespace


Template(TContext, TTarget, TRenderingContext).Render Method

Template TContext, TTarget, TRenderingContext Render Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Renders template by generating content into target

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Render(
    TTarget target,
    TRenderingContext renderingContext
)
public void Render(
    TTarget target,
    TRenderingContext renderingContext
)
Public Sub Render (
    target As TTarget,
    renderingContext As TRenderingContext
)
Public Sub Render (
    target As TTarget,
    renderingContext As TRenderingContext
)
public:
void Render(
    TTarget target,
    TRenderingContext renderingContext
)
public:
void Render(
    TTarget target,
    TRenderingContext renderingContext
)
member Render :
        target : 'TTarget *
        renderingContext : 'TRenderingContext -> unit
member Render :
        target : 'TTarget *
        renderingContext : 'TRenderingContext -> unit

Parameters

target
Type: TTarget
A target to render output into
renderingContext
Type: TRenderingContext
A context object for this rendering call
See Also
Template TContext, TTarget, TRenderingContext Class
Template TContext, TTarget, TRenderingContext Members
NFX.Templatization Namespace


Template(TContext, TTarget, TRenderingContext) Properties

Template TContext, TTarget, TRenderingContext Properties NFX Class Library

[This is preliminary documentation and is subject to change.]

The Template TContext, TTarget, TRenderingContext type exposes the following members.
Properties
 | Name | Description
Public property | CanReuseInstance | Indicates whether an instance of template class may be reused for invocation of Render() more than once (possibly with different rendering target and/or rendering context)
Public property | Context | Custom context for the lifetime of this template
Public property | RenderingContext | Returns thread-local rendering context which is specific for this call to Render()
Public property | Target | Returns thread-local target which is specific for this call to Render()
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ITemplate Context |
Back to Top
See Also
Template TContext, TTarget, TRenderingContext Class
NFX.Templatization Namespace


Template(TContext, TTarget, TRenderingContext).CanReuseInstance Property

Template TContext, TTarget, TRenderingContext CanReuseInstance Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Indicates whether an instance of template class may be reused for invocation of Render() more than once (possibly with different rendering target and/or rendering context)

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract bool CanReuseInstance { get; }
public abstract bool CanReuseInstance { get; }
Public MustOverride ReadOnly Property CanReuseInstance As Boolean
    Get
Public MustOverride ReadOnly Property CanReuseInstance As Boolean
    Get
public:
virtual property bool CanReuseInstance {
    bool get () abstract;
}
public:
virtual property bool CanReuseInstance {
    bool get () abstract;
}
abstract CanReuseInstance : bool with get
abstract CanReuseInstance : bool with get

Property Value

Type: Online Boolean

Implements

ITemplate CanReuseInstance
See Also
Template TContext, TTarget, TRenderingContext Class
Template TContext, TTarget, TRenderingContext Members
NFX.Templatization Namespace


Template(TContext, TTarget, TRenderingContext).Context Property

Template TContext, TTarget, TRenderingContext Context Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Custom context for the lifetime of this template

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TContext Context { get; }
public TContext Context { get; }
Public ReadOnly Property Context As TContext
    Get
Public ReadOnly Property Context As TContext
    Get
public:
property TContext Context {
    TContext get ();
}
public:
property TContext Context {
    TContext get ();
}
member Context : 'TContext with get
member Context : 'TContext with get

Property Value

Type: TContext
See Also
Template TContext, TTarget, TRenderingContext Class
Template TContext, TTarget, TRenderingContext Members
NFX.Templatization Namespace


Template(TContext, TTarget, TRenderingContext).ITemplate.Context Property

Template TContext, TTarget, TRenderingContext ITemplate Context Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object ITemplate.Context { get; }
Object ITemplate.Context { get; }
Private ReadOnly Property Context As Object
    Implements ITemplate.Context
    Get
Private ReadOnly Property Context As Object
    Implements ITemplate.Context
    Get
private:
virtual property Object^ Context {
    Object^ get () sealed = ITemplate::Context::get;
}
private:
virtual property Object^ Context {
    Object^ get () sealed = ITemplate::Context::get;
}
private abstract Context : Object with get
private override Context : Object with get
private abstract Context : Object with get
private override Context : Object with get

Property Value

Type: Online Object

Implements

ITemplate Context
See Also
Template TContext, TTarget, TRenderingContext Class
Template TContext, TTarget, TRenderingContext Members
NFX.Templatization Namespace


Template(TContext, TTarget, TRenderingContext).RenderingContext Property

Template TContext, TTarget, TRenderingContext RenderingContext Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns thread-local rendering context which is specific for this call to Render()

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TRenderingContext RenderingContext { get; }
public TRenderingContext RenderingContext { get; }
Public ReadOnly Property RenderingContext As TRenderingContext
    Get
Public ReadOnly Property RenderingContext As TRenderingContext
    Get
public:
property TRenderingContext RenderingContext {
    TRenderingContext get ();
}
public:
property TRenderingContext RenderingContext {
    TRenderingContext get ();
}
member RenderingContext : 'TRenderingContext with get
member RenderingContext : 'TRenderingContext with get

Property Value

Type: TRenderingContext
See Also
Template TContext, TTarget, TRenderingContext Class
Template TContext, TTarget, TRenderingContext Members
NFX.Templatization Namespace


Template(TContext, TTarget, TRenderingContext).Target Property

Template TContext, TTarget, TRenderingContext Target Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns thread-local target which is specific for this call to Render()

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TTarget Target { get; }
public TTarget Target { get; }
Public ReadOnly Property Target As TTarget
    Get
Public ReadOnly Property Target As TTarget
    Get
public:
property TTarget Target {
    TTarget get ();
}
public:
property TTarget Target {
    TTarget get ();
}
member Target : 'TTarget with get
member Target : 'TTarget with get

Property Value

Type: TTarget
See Also
Template TContext, TTarget, TRenderingContext Class
Template TContext, TTarget, TRenderingContext Members
NFX.Templatization Namespace


TemplateCodeCompilerException Class

TemplateCodeCompilerException Class NFX Class Library

Thrown by template code compilers
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Templatization TemplatizationException
NFX.Templatization TemplateCompilerException
NFX.Templatization TemplateCodeCompilerException

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class TemplateCodeCompilerException : TemplateCompilerException
[SerializableAttribute]
public class TemplateCodeCompilerException : TemplateCompilerException
<SerializableAttribute>
Public Class TemplateCodeCompilerException
    Inherits TemplateCompilerException
<SerializableAttribute>
Public Class TemplateCodeCompilerException
    Inherits TemplateCompilerException
[SerializableAttribute]
public ref class TemplateCodeCompilerException : public TemplateCompilerException
[SerializableAttribute]
public ref class TemplateCodeCompilerException : public TemplateCompilerException
[<SerializableAttribute>]
type TemplateCodeCompilerException =
    class
        inherit TemplateCompilerException
    end
[<SerializableAttribute>]
type TemplateCodeCompilerException =
    class
        inherit TemplateCompilerException
    end
See Also
TemplateCodeCompilerException Members
NFX.Templatization Namespace


TemplateCodeCompilerException Members

TemplateCodeCompilerException Members NFX Class Library

The TemplateCodeCompilerException type exposes the following members.
Constructors
 | Name | Description
Public method | TemplateCodeCompilerException | Initializes a new instance of the TemplateCodeCompilerException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Exception ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Fields
 | Name | Description
Public field | Error |
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
TemplateCodeCompilerException Class
NFX.Templatization Namespace


TemplateCodeCompilerException Constructor

TemplateCodeCompilerException Constructor NFX Class Library

Initializes a new instance of the TemplateCodeCompilerException class

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TemplateCodeCompilerException(
    CompilerError err
)
public TemplateCodeCompilerException(
    CompilerError err
)
Public Sub New (
    err As CompilerError
)
Public Sub New (
    err As CompilerError
)
public:
TemplateCodeCompilerException(
    CompilerError^ err
)
public:
TemplateCodeCompilerException(
    CompilerError^ err
)
new :
        err : CompilerError -> TemplateCodeCompilerException
new :
        err : CompilerError -> TemplateCodeCompilerException

Parameters

err
Type: Online System.CodeDom.Compiler CompilerError
See Also
TemplateCodeCompilerException Class
TemplateCodeCompilerException Members
NFX.Templatization Namespace


TemplateCodeCompilerException Fields

TemplateCodeCompilerException Fields NFX Class Library

The TemplateCodeCompilerException type exposes the following members.
Fields
 | Name | Description
Public field | Error |
Back to Top
See Also
TemplateCodeCompilerException Class
NFX.Templatization Namespace


TemplateCodeCompilerException.Error Field

TemplateCodeCompilerException Error Field NFX Class Library

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly CompilerError Error
public readonly CompilerError Error
Public ReadOnly Error As CompilerError
Public ReadOnly Error As CompilerError
public:
initonly CompilerError^ Error
public:
initonly CompilerError^ Error
val Error: CompilerError
val Error: CompilerError

Field Value

Type: Online CompilerError
See Also
TemplateCodeCompilerException Class
TemplateCodeCompilerException Members
NFX.Templatization Namespace


TemplateCodeCompilerException Methods

TemplateCodeCompilerException Methods NFX Class Library

The TemplateCodeCompilerException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Exception ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
TemplateCodeCompilerException Class
NFX.Templatization Namespace


TemplateCodeCompilerException.ToString Method

TemplateCodeCompilerException ToString Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String

Implements

Online _Exception ToString
See Also
TemplateCodeCompilerException Class
TemplateCodeCompilerException Members
NFX.Templatization Namespace


TemplateCodeCompilerException Properties

TemplateCodeCompilerException Properties NFX Class Library

The TemplateCodeCompilerException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
TemplateCodeCompilerException Class
NFX.Templatization Namespace


TemplateCodeCompilerException Events

TemplateCodeCompilerException Events NFX Class Library

The TemplateCodeCompilerException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
TemplateCodeCompilerException Class
NFX.Templatization Namespace


TemplateCompiler Class

TemplateCompiler Class NFX Class Library

Represents abstraction of template compilers. This class is not thread-safe
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Templatization TemplateCompiler
NFX.Templatization TextCSTemplateCompiler

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class TemplateCompiler : DisposableObject,
    IConfigurable, IEnumerable<CompileUnit>, IEnumerable
public abstract class TemplateCompiler : DisposableObject,
    IConfigurable, IEnumerable<CompileUnit>, IEnumerable
Public MustInherit Class TemplateCompiler
    Inherits DisposableObject
    Implements IConfigurable, IEnumerable(Of CompileUnit),
    IEnumerable
Public MustInherit Class TemplateCompiler
    Inherits DisposableObject
    Implements IConfigurable, IEnumerable(Of CompileUnit),
    IEnumerable
public ref class TemplateCompiler abstract : public DisposableObject,
    IConfigurable, IEnumerable<CompileUnit^>, IEnumerable
public ref class TemplateCompiler abstract : public DisposableObject,
    IConfigurable, IEnumerable<CompileUnit^>, IEnumerable
[<AbstractClassAttribute>]
type TemplateCompiler =
    class
        inherit DisposableObject
        interface IConfigurable
        interface IEnumerable<CompileUnit>
        interface IEnumerable
    end
[<AbstractClassAttribute>]
type TemplateCompiler =
    class
        inherit DisposableObject
        interface IConfigurable
        interface IEnumerable<CompileUnit>
        interface IEnumerable
    end
See Also
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler Members

TemplateCompiler Members NFX Class Library

The TemplateCompiler type exposes the following members.
Constructors
 | Name | Description
Protected method | TemplateCompiler | Initializes a new instance of the TemplateCompiler class
Protected method | TemplateCompiler( ITemplateSource ) | Initializes a new instance of the TemplateCompiler class
Protected method | TemplateCompiler(IEnumerable ITemplateSource ) | Initializes a new instance of the TemplateCompiler class
Back to Top
Methods
 | Name | Description
Public method | Compile | Performs compilation if it has not already been performed
Public method | Configure |
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoCompileCode | Override to perform compilation of code into assembly
Protected method | DoCompileTemplateSource | Override to perform code generation from template source into code
Protected method | DoConfigure | Override to perform custom configuration
Public method | EnsureNotCompiled | Throws an exception if this instance has already been compiled
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExcludeTemplateSource | Exclude template source from compilation
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GenerateUniqueName | Generates unique identifier suitable for use in code per compiler instance
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IncludeTemplateSource | Includes template source into compilation
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReferenceAssembly | References assembly by its name if it is already not referenced
Protected method | RegisterDefaultUsings | Override to provide default using clauses
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UnReferenceAssembly | Removes assembly reference by its name if it was already referenced
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable CompileUnit | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct CompileUnit, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax CompileUnit, TComparand (Func CompileUnit, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax CompileUnit, TComparand (Func CompileUnit, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin CompileUnit, TComparand (Func CompileUnit, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin CompileUnit, TComparand (Func CompileUnit, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault CompileUnit | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach CompileUnit (Action CompileUnit ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach CompileUnit (Action CompileUnit, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast CompileUnit | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast CompileUnit (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Protected field | m_Assembly |
Protected field | m_AssemblyFileName |
Protected field | m_CodeCompilerErrors |
Protected field | m_Options |
Protected field | m_ReferencedAssemblies |
Protected field | m_ReferencedAssembliesSearchPath |
Protected field | m_Units |
Back to Top
Properties
 | Name | Description
Public property | Assembly | Returns compiled assembly or null if only source have been compiled when CompileCode=false;
Public property | AssemblyFileName | Gets/sets filename for assembly, if null then assembly is created in-memory only
Public property | BaseTypeName | Sets the name of base type that templates inherit from. This type must directly or indirectly inherit from Template
Public property | CodeCompilerErrors | Returns code compilation errors
Public property | CompileCode | Indicates whether language compilation should be performed and Assembly be built
Public property | Compiled | Indicates whether this instance was compiled
Public property | CompileUnitsWithErrors | Returns compile units that have errors
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | HasErrors | Indicates whether some units have template compilation errors or code compiler errors exist
Public property | Item | Returns a compile unit by template source or throws if it does not exist
Public property | LanguageName | Gets the name of the language that this compiler supports, i.e. "C#"
Public property | LanguageSourceFileExtension | Gets the name of the language source code file extension that this compiler supports, i.e. ".cs"
Public property | Namespace | Sets the name of namespace that classes compiled into
Public property | Options | Config options section used for compilation
Public property | ReferencedAssemblies | Returns referenced assemblies
Public property | ReferencedAssembliesSearchPath | Gets/sets path for referenced assemblies that do not have a path in their names
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
TemplateCompiler Class
NFX.Templatization Namespace


TemplateCompiler Constructor

TemplateCompiler Constructor NFX Class Library

Overload List
 | Name | Description
Protected method | TemplateCompiler | Initializes a new instance of the TemplateCompiler class
Protected method | TemplateCompiler( ITemplateSource ) | Initializes a new instance of the TemplateCompiler class
Protected method | TemplateCompiler(IEnumerable ITemplateSource ) | Initializes a new instance of the TemplateCompiler class
Back to Top
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler Constructor

TemplateCompiler Constructor NFX Class Library

Initializes a new instance of the TemplateCompiler class

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TemplateCompiler()
protected TemplateCompiler()
Protected Sub New
Protected Sub New
protected:
TemplateCompiler()
protected:
TemplateCompiler()
new : unit -> TemplateCompiler
new : unit -> TemplateCompiler
See Also
TemplateCompiler Class
TemplateCompiler Members
TemplateCompiler Overload
NFX.Templatization Namespace


TemplateCompiler Constructor (ITemplateSource[])

TemplateCompiler Constructor ( ITemplateSource ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TemplateCompiler class

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TemplateCompiler(
    params ITemplateSource[] sources
)
protected TemplateCompiler(
    params ITemplateSource[] sources
)
Protected Sub New (
    ParamArray sources As ITemplateSource()
)
Protected Sub New (
    ParamArray sources As ITemplateSource()
)
protected:
TemplateCompiler(
    ... array<ITemplateSource^>^ sources
)
protected:
TemplateCompiler(
    ... array<ITemplateSource^>^ sources
)
new :
        sources : ITemplateSource[] -> TemplateCompiler
new :
        sources : ITemplateSource[] -> TemplateCompiler

Parameters

sources
Type: NFX.Templatization ITemplateSource
See Also
TemplateCompiler Class
TemplateCompiler Members
TemplateCompiler Overload
NFX.Templatization Namespace


TemplateCompiler Constructor (IEnumerable(ITemplateSource))

TemplateCompiler Constructor (IEnumerable ITemplateSource ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TemplateCompiler class

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TemplateCompiler(
    IEnumerable<ITemplateSource> sources
)
protected TemplateCompiler(
    IEnumerable<ITemplateSource> sources
)
Protected Sub New (
    sources As IEnumerable(Of ITemplateSource)
)
Protected Sub New (
    sources As IEnumerable(Of ITemplateSource)
)
protected:
TemplateCompiler(
    IEnumerable<ITemplateSource^>^ sources
)
protected:
TemplateCompiler(
    IEnumerable<ITemplateSource^>^ sources
)
new :
        sources : IEnumerable<ITemplateSource> -> TemplateCompiler
new :
        sources : IEnumerable<ITemplateSource> -> TemplateCompiler

Parameters

sources
Type: Online System.Collections.Generic IEnumerable ITemplateSource
See Also
TemplateCompiler Class
TemplateCompiler Members
TemplateCompiler Overload
NFX.Templatization Namespace


TemplateCompiler Fields

TemplateCompiler Fields NFX Class Library

The TemplateCompiler type exposes the following members.
Fields
 | Name | Description
Protected field | m_Assembly |
Protected field | m_AssemblyFileName |
Protected field | m_CodeCompilerErrors |
Protected field | m_Options |
Protected field | m_ReferencedAssemblies |
Protected field | m_ReferencedAssembliesSearchPath |
Protected field | m_Units |
Back to Top
See Also
TemplateCompiler Class
NFX.Templatization Namespace


TemplateCompiler.m_Assembly Field

TemplateCompiler m_Assembly Field NFX Class Library

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected Assembly m_Assembly
protected Assembly m_Assembly
Protected m_Assembly As Assembly
Protected m_Assembly As Assembly
protected:
Assembly^ m_Assembly
protected:
Assembly^ m_Assembly
val mutable m_Assembly: Assembly
val mutable m_Assembly: Assembly

Field Value

Type: Online Assembly
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.m_AssemblyFileName Field

TemplateCompiler m_AssemblyFileName Field NFX Class Library

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected string m_AssemblyFileName
protected string m_AssemblyFileName
Protected m_AssemblyFileName As String
Protected m_AssemblyFileName As String
protected:
String^ m_AssemblyFileName
protected:
String^ m_AssemblyFileName
val mutable m_AssemblyFileName: string
val mutable m_AssemblyFileName: string

Field Value

Type: Online String
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.m_CodeCompilerErrors Field

TemplateCompiler m_CodeCompilerErrors Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected List<Exception> m_CodeCompilerErrors
protected List<Exception> m_CodeCompilerErrors
Protected m_CodeCompilerErrors As List(Of Exception)
Protected m_CodeCompilerErrors As List(Of Exception)
protected:
List<Exception^>^ m_CodeCompilerErrors
protected:
List<Exception^>^ m_CodeCompilerErrors
val mutable m_CodeCompilerErrors: List<Exception>
val mutable m_CodeCompilerErrors: List<Exception>

Field Value

Type: Online List Online Exception
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.m_Options Field

TemplateCompiler m_Options Field NFX Class Library

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected IConfigSectionNode m_Options
protected IConfigSectionNode m_Options
Protected m_Options As IConfigSectionNode
Protected m_Options As IConfigSectionNode
protected:
IConfigSectionNode^ m_Options
protected:
IConfigSectionNode^ m_Options
val mutable m_Options: IConfigSectionNode
val mutable m_Options: IConfigSectionNode

Field Value

Type: IConfigSectionNode
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.m_ReferencedAssemblies Field

TemplateCompiler m_ReferencedAssemblies Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected List<string> m_ReferencedAssemblies
protected List<string> m_ReferencedAssemblies
Protected m_ReferencedAssemblies As List(Of String)
Protected m_ReferencedAssemblies As List(Of String)
protected:
List<String^>^ m_ReferencedAssemblies
protected:
List<String^>^ m_ReferencedAssemblies
val mutable m_ReferencedAssemblies: List<string>
val mutable m_ReferencedAssemblies: List<string>

Field Value

Type: Online List Online String
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.m_ReferencedAssembliesSearchPath Field

TemplateCompiler m_ReferencedAssembliesSearchPath Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected string m_ReferencedAssembliesSearchPath
protected string m_ReferencedAssembliesSearchPath
Protected m_ReferencedAssembliesSearchPath As String
Protected m_ReferencedAssembliesSearchPath As String
protected:
String^ m_ReferencedAssembliesSearchPath
protected:
String^ m_ReferencedAssembliesSearchPath
val mutable m_ReferencedAssembliesSearchPath: string
val mutable m_ReferencedAssembliesSearchPath: string

Field Value

Type: Online String
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.m_Units Field

TemplateCompiler m_Units Field NFX Class Library

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected CompileUnits m_Units
protected CompileUnits m_Units
Protected m_Units As CompileUnits
Protected m_Units As CompileUnits
protected:
CompileUnits^ m_Units
protected:
CompileUnits^ m_Units
val mutable m_Units: CompileUnits
val mutable m_Units: CompileUnits

Field Value

Type: CompileUnits
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler Methods

TemplateCompiler Methods NFX Class Library

The TemplateCompiler type exposes the following members.
Methods
 | Name | Description
Public method | Compile | Performs compilation if it has not already been performed
Public method | Configure |
Protected method | Destructor | (Overrides DisposableObject Destructor .)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoCompileCode | Override to perform compilation of code into assembly
Protected method | DoCompileTemplateSource | Override to perform code generation from template source into code
Protected method | DoConfigure | Override to perform custom configuration
Public method | EnsureNotCompiled | Throws an exception if this instance has already been compiled
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExcludeTemplateSource | Exclude template source from compilation
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GenerateUniqueName | Generates unique identifier suitable for use in code per compiler instance
Public method | GetEnumerator |
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IncludeTemplateSource | Includes template source into compilation
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReferenceAssembly | References assembly by its name if it is already not referenced
Protected method | RegisterDefaultUsings | Override to provide default using clauses
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UnReferenceAssembly | Removes assembly reference by its name if it was already referenced
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsLookAheadEnumerable CompileUnit | (Defined by LookAheadExtensions.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | Distinct CompileUnit, TKey | (Defined by CollectionUtils.)
Public Extension Method | FirstMax CompileUnit, TComparand (Func CompileUnit, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMax CompileUnit, TComparand (Func CompileUnit, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin CompileUnit, TComparand (Func CompileUnit, TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstMin CompileUnit, TComparand (Func CompileUnit, TComparand , TComparand ) | Overloaded. (Defined by CollectionUtils.)
Public Extension Method | FirstOrAnyOrDefault CompileUnit | Tries to find the first element that matches the predicate and returns it, otherwise returns the first element found or default (i.e. null) (Defined by CollectionUtils.)
Public Extension Method | ForEach CompileUnit (Action CompileUnit ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | ForEach CompileUnit (Action CompileUnit, Int32 ) | Overloaded. Runs some method over each element of src sequence (Defined by CollectionUtils.)
Public Extension Method | SkipLast CompileUnit | Overloaded. Takes all elements except for last element from the given source (Defined by CollectionUtils.)
Public Extension Method | SkipLast CompileUnit (Int32) | Overloaded. Takes all but last N elements from the source (Defined by CollectionUtils.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator |
Back to Top
See Also
TemplateCompiler Class
NFX.Templatization Namespace


TemplateCompiler.IEnumerable.GetEnumerator Method

TemplateCompiler IEnumerable GetEnumerator Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
IEnumerator IEnumerable.GetEnumerator()
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: Online IEnumerator

Implements

Online IEnumerable GetEnumerator
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.Compile Method

TemplateCompiler Compile Method NFX Class Library

Performs compilation if it has not already been performed

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Compile()
public void Compile()
Public Sub Compile
Public Sub Compile
public:
void Compile()
public:
void Compile()
member Compile : unit -> unit
member Compile : unit -> unit
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.Configure Method

TemplateCompiler Configure Method NFX Class Library

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Configure(
    IConfigSectionNode node
)
public void Configure(
    IConfigSectionNode node
)
Public Sub Configure (
    node As IConfigSectionNode
)
Public Sub Configure (
    node As IConfigSectionNode
)
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
public:
virtual void Configure(
    IConfigSectionNode^ node
) sealed
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit
abstract Configure :
        node : IConfigSectionNode -> unit
override Configure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode

Implements

IConfigurable Configure(IConfigSectionNode)
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.Destructor Method

TemplateCompiler Destructor Method NFX Class Library

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected override void Destructor()
protected override void Destructor()
Protected Overrides Sub Destructor
Protected Overrides Sub Destructor
protected:
virtual void Destructor() override
protected:
virtual void Destructor() override
abstract Destructor : unit -> unit
override Destructor : unit -> unit
abstract Destructor : unit -> unit
override Destructor : unit -> unit
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.DoCompileCode Method

TemplateCompiler DoCompileCode Method NFX Class Library

Override to perform compilation of code into assembly

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void DoCompileCode()
protected abstract void DoCompileCode()
Protected MustOverride Sub DoCompileCode
Protected MustOverride Sub DoCompileCode
protected:
virtual void DoCompileCode() abstract
protected:
virtual void DoCompileCode() abstract
abstract DoCompileCode : unit -> unit
abstract DoCompileCode : unit -> unit
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.DoCompileTemplateSource Method

TemplateCompiler DoCompileTemplateSource Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to perform code generation from template source into code

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected abstract void DoCompileTemplateSource(
    CompileUnit unit
)
protected abstract void DoCompileTemplateSource(
    CompileUnit unit
)
Protected MustOverride Sub DoCompileTemplateSource (
    unit As CompileUnit
)
Protected MustOverride Sub DoCompileTemplateSource (
    unit As CompileUnit
)
protected:
virtual void DoCompileTemplateSource(
    CompileUnit^ unit
) abstract
protected:
virtual void DoCompileTemplateSource(
    CompileUnit^ unit
) abstract
abstract DoCompileTemplateSource :
        unit : CompileUnit -> unit
abstract DoCompileTemplateSource :
        unit : CompileUnit -> unit

Parameters

unit
Type: NFX.Templatization CompileUnit
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.DoConfigure Method

TemplateCompiler DoConfigure Method NFX Class Library

Override to perform custom configuration

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void DoConfigure(
    IConfigSectionNode node
)
protected virtual void DoConfigure(
    IConfigSectionNode node
)
Protected Overridable Sub DoConfigure (
    node As IConfigSectionNode
)
Protected Overridable Sub DoConfigure (
    node As IConfigSectionNode
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
)
protected:
virtual void DoConfigure(
    IConfigSectionNode^ node
)
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit
abstract DoConfigure :
        node : IConfigSectionNode -> unit
override DoConfigure :
        node : IConfigSectionNode -> unit

Parameters

node
Type: NFX.Environment IConfigSectionNode
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.EnsureNotCompiled Method

TemplateCompiler EnsureNotCompiled Method NFX Class Library

Throws an exception if this instance has already been compiled

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void EnsureNotCompiled()
public void EnsureNotCompiled()
Public Sub EnsureNotCompiled
Public Sub EnsureNotCompiled
public:
void EnsureNotCompiled()
public:
void EnsureNotCompiled()
member EnsureNotCompiled : unit -> unit
member EnsureNotCompiled : unit -> unit
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.ExcludeTemplateSource Method

TemplateCompiler ExcludeTemplateSource Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Exclude template source from compilation

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExcludeTemplateSource(
    ITemplateSource source
)
public bool ExcludeTemplateSource(
    ITemplateSource source
)
Public Function ExcludeTemplateSource (
    source As ITemplateSource
) As Boolean
Public Function ExcludeTemplateSource (
    source As ITemplateSource
) As Boolean
public:
bool ExcludeTemplateSource(
    ITemplateSource^ source
)
public:
bool ExcludeTemplateSource(
    ITemplateSource^ source
)
member ExcludeTemplateSource :
        source : ITemplateSource -> bool
member ExcludeTemplateSource :
        source : ITemplateSource -> bool

Parameters

source
Type: NFX.Templatization ITemplateSource

Return Value

Type: Online Boolean
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.GenerateUniqueName Method

TemplateCompiler GenerateUniqueName Method NFX Class Library

Generates unique identifier suitable for use in code per compiler instance

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GenerateUniqueName()
public string GenerateUniqueName()
Public Function GenerateUniqueName As String
Public Function GenerateUniqueName As String
public:
String^ GenerateUniqueName()
public:
String^ GenerateUniqueName()
member GenerateUniqueName : unit -> string
member GenerateUniqueName : unit -> string

Return Value

Type: Online String
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.GetEnumerator Method

TemplateCompiler GetEnumerator Method NFX Class Library

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<CompileUnit> GetEnumerator()
public IEnumerator<CompileUnit> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of CompileUnit)
Public Function GetEnumerator As IEnumerator(Of CompileUnit)
public:
virtual IEnumerator<CompileUnit^>^ GetEnumerator() sealed
public:
virtual IEnumerator<CompileUnit^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<CompileUnit>
override GetEnumerator : unit -> IEnumerator<CompileUnit>
abstract GetEnumerator : unit -> IEnumerator<CompileUnit>
override GetEnumerator : unit -> IEnumerator<CompileUnit>

Return Value

Type: Online IEnumerator CompileUnit

Implements

Online IEnumerable T GetEnumerator
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.IncludeTemplateSource Method

TemplateCompiler IncludeTemplateSource Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Includes template source into compilation

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void IncludeTemplateSource(
    ITemplateSource source
)
public void IncludeTemplateSource(
    ITemplateSource source
)
Public Sub IncludeTemplateSource (
    source As ITemplateSource
)
Public Sub IncludeTemplateSource (
    source As ITemplateSource
)
public:
void IncludeTemplateSource(
    ITemplateSource^ source
)
public:
void IncludeTemplateSource(
    ITemplateSource^ source
)
member IncludeTemplateSource :
        source : ITemplateSource -> unit
member IncludeTemplateSource :
        source : ITemplateSource -> unit

Parameters

source
Type: NFX.Templatization ITemplateSource
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.ReferenceAssembly Method

TemplateCompiler ReferenceAssembly Method NFX Class Library

References assembly by its name if it is already not referenced

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ReferenceAssembly(
    string aname
)
public void ReferenceAssembly(
    string aname
)
Public Sub ReferenceAssembly (
    aname As String
)
Public Sub ReferenceAssembly (
    aname As String
)
public:
void ReferenceAssembly(
    String^ aname
)
public:
void ReferenceAssembly(
    String^ aname
)
member ReferenceAssembly :
        aname : string -> unit
member ReferenceAssembly :
        aname : string -> unit

Parameters

aname
Type: Online System String
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.RegisterDefaultUsings Method

TemplateCompiler RegisterDefaultUsings Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Override to provide default using clauses

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected virtual void RegisterDefaultUsings(
    HashSet<string> usings
)
protected virtual void RegisterDefaultUsings(
    HashSet<string> usings
)
Protected Overridable Sub RegisterDefaultUsings (
    usings As HashSet(Of String)
)
Protected Overridable Sub RegisterDefaultUsings (
    usings As HashSet(Of String)
)
protected:
virtual void RegisterDefaultUsings(
    HashSet<String^>^ usings
)
protected:
virtual void RegisterDefaultUsings(
    HashSet<String^>^ usings
)
abstract RegisterDefaultUsings :
        usings : HashSet<string> -> unit
override RegisterDefaultUsings :
        usings : HashSet<string> -> unit
abstract RegisterDefaultUsings :
        usings : HashSet<string> -> unit
override RegisterDefaultUsings :
        usings : HashSet<string> -> unit

Parameters

usings
Type: Online System.Collections.Generic HashSet Online String
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.UnReferenceAssembly Method

TemplateCompiler UnReferenceAssembly Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Removes assembly reference by its name if it was already referenced

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool UnReferenceAssembly(
    string aname
)
public bool UnReferenceAssembly(
    string aname
)
Public Function UnReferenceAssembly (
    aname As String
) As Boolean
Public Function UnReferenceAssembly (
    aname As String
) As Boolean
public:
bool UnReferenceAssembly(
    String^ aname
)
public:
bool UnReferenceAssembly(
    String^ aname
)
member UnReferenceAssembly :
        aname : string -> bool
member UnReferenceAssembly :
        aname : string -> bool

Parameters

aname
Type: Online System String

Return Value

Type: Online Boolean
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler Properties

TemplateCompiler Properties NFX Class Library

The TemplateCompiler type exposes the following members.
Properties
 | Name | Description
Public property | Assembly | Returns compiled assembly or null if only source have been compiled when CompileCode=false;
Public property | AssemblyFileName | Gets/sets filename for assembly, if null then assembly is created in-memory only
Public property | BaseTypeName | Sets the name of base type that templates inherit from. This type must directly or indirectly inherit from Template
Public property | CodeCompilerErrors | Returns code compilation errors
Public property | CompileCode | Indicates whether language compilation should be performed and Assembly be built
Public property | Compiled | Indicates whether this instance was compiled
Public property | CompileUnitsWithErrors | Returns compile units that have errors
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | HasErrors | Indicates whether some units have template compilation errors or code compiler errors exist
Public property | Item | Returns a compile unit by template source or throws if it does not exist
Public property | LanguageName | Gets the name of the language that this compiler supports, i.e. "C#"
Public property | LanguageSourceFileExtension | Gets the name of the language source code file extension that this compiler supports, i.e. ".cs"
Public property | Namespace | Sets the name of namespace that classes compiled into
Public property | Options | Config options section used for compilation
Public property | ReferencedAssemblies | Returns referenced assemblies
Public property | ReferencedAssembliesSearchPath | Gets/sets path for referenced assemblies that do not have a path in their names
Back to Top
See Also
TemplateCompiler Class
NFX.Templatization Namespace


TemplateCompiler.Assembly Property

TemplateCompiler Assembly Property NFX Class Library

Returns compiled assembly or null if only source have been compiled when CompileCode=false;

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Assembly Assembly { get; }
public Assembly Assembly { get; }
Public ReadOnly Property Assembly As Assembly
    Get
Public ReadOnly Property Assembly As Assembly
    Get
public:
property Assembly^ Assembly {
    Assembly^ get ();
}
public:
property Assembly^ Assembly {
    Assembly^ get ();
}
member Assembly : Assembly with get
member Assembly : Assembly with get

Property Value

Type: Online Assembly
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.AssemblyFileName Property

TemplateCompiler AssemblyFileName Property NFX Class Library

Gets/sets filename for assembly, if null then assembly is created in-memory only

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$asm-file")]
public string AssemblyFileName { get; set; }
[ConfigAttribute("$asm-file")]
public string AssemblyFileName { get; set; }
<ConfigAttribute("$asm-file")>
Public Property AssemblyFileName As String
    Get
    Set
<ConfigAttribute("$asm-file")>
Public Property AssemblyFileName As String
    Get
    Set
public:
[ConfigAttribute(L"$asm-file")]
property String^ AssemblyFileName {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute(L"$asm-file")]
property String^ AssemblyFileName {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute("$asm-file")>]
member AssemblyFileName : string with get, set
[<ConfigAttribute("$asm-file")>]
member AssemblyFileName : string with get, set

Property Value

Type: Online String
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.BaseTypeName Property

TemplateCompiler BaseTypeName Property NFX Class Library

Sets the name of base type that templates inherit from. This type must directly or indirectly inherit from Template

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$base-type")]
public string BaseTypeName { get; set; }
[ConfigAttribute("$base-type")]
public string BaseTypeName { get; set; }
<ConfigAttribute("$base-type")>
Public Property BaseTypeName As String
    Get
    Set
<ConfigAttribute("$base-type")>
Public Property BaseTypeName As String
    Get
    Set
public:
[ConfigAttribute(L"$base-type")]
property String^ BaseTypeName {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute(L"$base-type")]
property String^ BaseTypeName {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute("$base-type")>]
member BaseTypeName : string with get, set
[<ConfigAttribute("$base-type")>]
member BaseTypeName : string with get, set

Property Value

Type: Online String
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.CodeCompilerErrors Property

TemplateCompiler CodeCompilerErrors Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns code compilation errors

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Exception> CodeCompilerErrors { get; }
public IEnumerable<Exception> CodeCompilerErrors { get; }
Public ReadOnly Property CodeCompilerErrors As IEnumerable(Of Exception)
    Get
Public ReadOnly Property CodeCompilerErrors As IEnumerable(Of Exception)
    Get
public:
property IEnumerable<Exception^>^ CodeCompilerErrors {
    IEnumerable<Exception^>^ get ();
}
public:
property IEnumerable<Exception^>^ CodeCompilerErrors {
    IEnumerable<Exception^>^ get ();
}
member CodeCompilerErrors : IEnumerable<Exception> with get
member CodeCompilerErrors : IEnumerable<Exception> with get

Property Value

Type: Online IEnumerable Online Exception
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.CompileCode Property

TemplateCompiler CompileCode Property NFX Class Library

Indicates whether language compilation should be performed and Assembly be built

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$compile-code")]
public bool CompileCode { get; set; }
[ConfigAttribute("$compile-code")]
public bool CompileCode { get; set; }
<ConfigAttribute("$compile-code")>
Public Property CompileCode As Boolean
    Get
    Set
<ConfigAttribute("$compile-code")>
Public Property CompileCode As Boolean
    Get
    Set
public:
[ConfigAttribute(L"$compile-code")]
property bool CompileCode {
    bool get ();
    void set (bool value);
}
public:
[ConfigAttribute(L"$compile-code")]
property bool CompileCode {
    bool get ();
    void set (bool value);
}
[<ConfigAttribute("$compile-code")>]
member CompileCode : bool with get, set
[<ConfigAttribute("$compile-code")>]
member CompileCode : bool with get, set

Property Value

Type: Online Boolean
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.Compiled Property

TemplateCompiler Compiled Property NFX Class Library

Indicates whether this instance was compiled

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Compiled { get; }
public bool Compiled { get; }
Public ReadOnly Property Compiled As Boolean
    Get
Public ReadOnly Property Compiled As Boolean
    Get
public:
property bool Compiled {
    bool get ();
}
public:
property bool Compiled {
    bool get ();
}
member Compiled : bool with get
member Compiled : bool with get

Property Value

Type: Online Boolean
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.CompileUnitsWithErrors Property

TemplateCompiler CompileUnitsWithErrors Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns compile units that have errors

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<CompileUnit> CompileUnitsWithErrors { get; }
public IEnumerable<CompileUnit> CompileUnitsWithErrors { get; }
Public ReadOnly Property CompileUnitsWithErrors As IEnumerable(Of CompileUnit)
    Get
Public ReadOnly Property CompileUnitsWithErrors As IEnumerable(Of CompileUnit)
    Get
public:
property IEnumerable<CompileUnit^>^ CompileUnitsWithErrors {
    IEnumerable<CompileUnit^>^ get ();
}
public:
property IEnumerable<CompileUnit^>^ CompileUnitsWithErrors {
    IEnumerable<CompileUnit^>^ get ();
}
member CompileUnitsWithErrors : IEnumerable<CompileUnit> with get
member CompileUnitsWithErrors : IEnumerable<CompileUnit> with get

Property Value

Type: Online IEnumerable CompileUnit
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.HasErrors Property

TemplateCompiler HasErrors Property NFX Class Library

Indicates whether some units have template compilation errors or code compiler errors exist

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HasErrors { get; }
public bool HasErrors { get; }
Public ReadOnly Property HasErrors As Boolean
    Get
Public ReadOnly Property HasErrors As Boolean
    Get
public:
property bool HasErrors {
    bool get ();
}
public:
property bool HasErrors {
    bool get ();
}
member HasErrors : bool with get
member HasErrors : bool with get

Property Value

Type: Online Boolean
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.Item Property

TemplateCompiler Item Property NFX Class Library

Returns a compile unit by template source or throws if it does not exist

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CompileUnit this[
    ITemplateSource templateSource
] { get; }
public CompileUnit this[
    ITemplateSource templateSource
] { get; }
Public ReadOnly Default Property Item (
    templateSource As ITemplateSource
) As CompileUnit
    Get
Public ReadOnly Default Property Item (
    templateSource As ITemplateSource
) As CompileUnit
    Get
public:
property CompileUnit^ default[ITemplateSource^ templateSource] {
    CompileUnit^ get (ITemplateSource^ templateSource);
}
public:
property CompileUnit^ default[ITemplateSource^ templateSource] {
    CompileUnit^ get (ITemplateSource^ templateSource);
}
member Item : CompileUnit with get
member Item : CompileUnit with get

Parameters

templateSource
Type: NFX.Templatization ITemplateSource

Property Value

Type: CompileUnit
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.LanguageName Property

TemplateCompiler LanguageName Property NFX Class Library

Gets the name of the language that this compiler supports, i.e. "C#"

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string LanguageName { get; }
public abstract string LanguageName { get; }
Public MustOverride ReadOnly Property LanguageName As String
    Get
Public MustOverride ReadOnly Property LanguageName As String
    Get
public:
virtual property String^ LanguageName {
    String^ get () abstract;
}
public:
virtual property String^ LanguageName {
    String^ get () abstract;
}
abstract LanguageName : string with get
abstract LanguageName : string with get

Property Value

Type: Online String
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.LanguageSourceFileExtension Property

TemplateCompiler LanguageSourceFileExtension Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets the name of the language source code file extension that this compiler supports, i.e. ".cs"

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string LanguageSourceFileExtension { get; }
public abstract string LanguageSourceFileExtension { get; }
Public MustOverride ReadOnly Property LanguageSourceFileExtension As String
    Get
Public MustOverride ReadOnly Property LanguageSourceFileExtension As String
    Get
public:
virtual property String^ LanguageSourceFileExtension {
    String^ get () abstract;
}
public:
virtual property String^ LanguageSourceFileExtension {
    String^ get () abstract;
}
abstract LanguageSourceFileExtension : string with get
abstract LanguageSourceFileExtension : string with get

Property Value

Type: Online String
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.Namespace Property

TemplateCompiler Namespace Property NFX Class Library

Sets the name of namespace that classes compiled into

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$namespace")]
public string Namespace { get; set; }
[ConfigAttribute("$namespace")]
public string Namespace { get; set; }
<ConfigAttribute("$namespace")>
Public Property Namespace As String
    Get
    Set
<ConfigAttribute("$namespace")>
Public Property Namespace As String
    Get
    Set
public:
[ConfigAttribute(L"$namespace")]
property String^ Namespace {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute(L"$namespace")]
property String^ Namespace {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute("$namespace")>]
member Namespace : string with get, set
[<ConfigAttribute("$namespace")>]
member Namespace : string with get, set

Property Value

Type: Online String
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.Options Property

TemplateCompiler Options Property NFX Class Library

Config options section used for compilation

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("options")]
public IConfigSectionNode Options { get; set; }
[ConfigAttribute("options")]
public IConfigSectionNode Options { get; set; }
<ConfigAttribute("options")>
Public Property Options As IConfigSectionNode
    Get
    Set
<ConfigAttribute("options")>
Public Property Options As IConfigSectionNode
    Get
    Set
public:
[ConfigAttribute(L"options")]
property IConfigSectionNode^ Options {
    IConfigSectionNode^ get ();
    void set (IConfigSectionNode^ value);
}
public:
[ConfigAttribute(L"options")]
property IConfigSectionNode^ Options {
    IConfigSectionNode^ get ();
    void set (IConfigSectionNode^ value);
}
[<ConfigAttribute("options")>]
member Options : IConfigSectionNode with get, set
[<ConfigAttribute("options")>]
member Options : IConfigSectionNode with get, set

Property Value

Type: IConfigSectionNode
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.ReferencedAssemblies Property

TemplateCompiler ReferencedAssemblies Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns referenced assemblies

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<string> ReferencedAssemblies { get; }
public IEnumerable<string> ReferencedAssemblies { get; }
Public ReadOnly Property ReferencedAssemblies As IEnumerable(Of String)
    Get
Public ReadOnly Property ReferencedAssemblies As IEnumerable(Of String)
    Get
public:
property IEnumerable<String^>^ ReferencedAssemblies {
    IEnumerable<String^>^ get ();
}
public:
property IEnumerable<String^>^ ReferencedAssemblies {
    IEnumerable<String^>^ get ();
}
member ReferencedAssemblies : IEnumerable<string> with get
member ReferencedAssemblies : IEnumerable<string> with get

Property Value

Type: Online IEnumerable Online String
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompiler.ReferencedAssembliesSearchPath Property

TemplateCompiler ReferencedAssembliesSearchPath Property NFX Class Library

[This is preliminary documentation and is subject to change.]

Gets/sets path for referenced assemblies that do not have a path in their names

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[ConfigAttribute("$ref-path")]
public string ReferencedAssembliesSearchPath { get; set; }
[ConfigAttribute("$ref-path")]
public string ReferencedAssembliesSearchPath { get; set; }
<ConfigAttribute("$ref-path")>
Public Property ReferencedAssembliesSearchPath As String
    Get
    Set
<ConfigAttribute("$ref-path")>
Public Property ReferencedAssembliesSearchPath As String
    Get
    Set
public:
[ConfigAttribute(L"$ref-path")]
property String^ ReferencedAssembliesSearchPath {
    String^ get ();
    void set (String^ value);
}
public:
[ConfigAttribute(L"$ref-path")]
property String^ ReferencedAssembliesSearchPath {
    String^ get ();
    void set (String^ value);
}
[<ConfigAttribute("$ref-path")>]
member ReferencedAssembliesSearchPath : string with get, set
[<ConfigAttribute("$ref-path")>]
member ReferencedAssembliesSearchPath : string with get, set

Property Value

Type: Online String
See Also
TemplateCompiler Class
TemplateCompiler Members
NFX.Templatization Namespace


TemplateCompilerException Class

TemplateCompilerException Class NFX Class Library

Base exception thrown by the template compilers
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Templatization TemplatizationException
NFX.Templatization TemplateCompilerException
NFX.Templatization TemplateCodeCompilerException
NFX.Templatization TemplateParseException

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class TemplateCompilerException : TemplatizationException
[SerializableAttribute]
public class TemplateCompilerException : TemplatizationException
<SerializableAttribute>
Public Class TemplateCompilerException
    Inherits TemplatizationException
<SerializableAttribute>
Public Class TemplateCompilerException
    Inherits TemplatizationException
[SerializableAttribute]
public ref class TemplateCompilerException : public TemplatizationException
[SerializableAttribute]
public ref class TemplateCompilerException : public TemplatizationException
[<SerializableAttribute>]
type TemplateCompilerException =
    class
        inherit TemplatizationException
    end
[<SerializableAttribute>]
type TemplateCompilerException =
    class
        inherit TemplatizationException
    end
See Also
TemplateCompilerException Members
NFX.Templatization Namespace


TemplateCompilerException Members

TemplateCompilerException Members NFX Class Library

The TemplateCompilerException type exposes the following members.
Constructors
 | Name | Description
Public method | TemplateCompilerException | Initializes a new instance of the TemplateCompilerException class
Public method | TemplateCompilerException(String) | Initializes a new instance of the TemplateCompilerException class
Protected method | TemplateCompilerException(SerializationInfo, StreamingContext) | Initializes a new instance of the TemplateCompilerException class
Public method | TemplateCompilerException(String, Exception) | Initializes a new instance of the TemplateCompilerException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
TemplateCompilerException Class
NFX.Templatization Namespace


TemplateCompilerException Constructor

TemplateCompilerException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | TemplateCompilerException | Initializes a new instance of the TemplateCompilerException class
Public method | TemplateCompilerException(String) | Initializes a new instance of the TemplateCompilerException class
Protected method | TemplateCompilerException(SerializationInfo, StreamingContext) | Initializes a new instance of the TemplateCompilerException class
Public method | TemplateCompilerException(String, Exception) | Initializes a new instance of the TemplateCompilerException class
Back to Top
See Also
TemplateCompilerException Class
TemplateCompilerException Members
NFX.Templatization Namespace


TemplateCompilerException Constructor

TemplateCompilerException Constructor NFX Class Library

Initializes a new instance of the TemplateCompilerException class

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TemplateCompilerException()
public TemplateCompilerException()
Public Sub New
Public Sub New
public:
TemplateCompilerException()
public:
TemplateCompilerException()
new : unit -> TemplateCompilerException
new : unit -> TemplateCompilerException
See Also
TemplateCompilerException Class
TemplateCompilerException Members
TemplateCompilerException Overload
NFX.Templatization Namespace


TemplateCompilerException Constructor (String)

TemplateCompilerException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TemplateCompilerException class

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TemplateCompilerException(
    string message
)
public TemplateCompilerException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
TemplateCompilerException(
    String^ message
)
public:
TemplateCompilerException(
    String^ message
)
new :
        message : string -> TemplateCompilerException
new :
        message : string -> TemplateCompilerException

Parameters

message
Type: Online System String
See Also
TemplateCompilerException Class
TemplateCompilerException Members
TemplateCompilerException Overload
NFX.Templatization Namespace


TemplateCompilerException Constructor (SerializationInfo, StreamingContext)

TemplateCompilerException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TemplateCompilerException class

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TemplateCompilerException(
    SerializationInfo info,
    StreamingContext context
)
protected TemplateCompilerException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
TemplateCompilerException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
TemplateCompilerException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> TemplateCompilerException
new :
        info : SerializationInfo *
        context : StreamingContext -> TemplateCompilerException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
TemplateCompilerException Class
TemplateCompilerException Members
TemplateCompilerException Overload
NFX.Templatization Namespace


TemplateCompilerException Constructor (String, Exception)

TemplateCompilerException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TemplateCompilerException class

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TemplateCompilerException(
    string message,
    Exception inner
)
public TemplateCompilerException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
TemplateCompilerException(
    String^ message,
    Exception^ inner
)
public:
TemplateCompilerException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> TemplateCompilerException
new :
        message : string *
        inner : Exception -> TemplateCompilerException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
TemplateCompilerException Class
TemplateCompilerException Members
TemplateCompilerException Overload
NFX.Templatization Namespace


TemplateCompilerException Methods

TemplateCompilerException Methods NFX Class Library

The TemplateCompilerException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
TemplateCompilerException Class
NFX.Templatization Namespace


TemplateCompilerException Properties

TemplateCompilerException Properties NFX Class Library

The TemplateCompilerException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
TemplateCompilerException Class
NFX.Templatization Namespace


TemplateCompilerException Events

TemplateCompilerException Events NFX Class Library

The TemplateCompilerException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
TemplateCompilerException Class
NFX.Templatization Namespace


TemplateParseException Class

TemplateParseException Class NFX Class Library

Indicates template source parsing exception
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Templatization TemplatizationException
NFX.Templatization TemplateCompilerException
NFX.Templatization TemplateParseException

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class TemplateParseException : TemplateCompilerException
[SerializableAttribute]
public class TemplateParseException : TemplateCompilerException
<SerializableAttribute>
Public Class TemplateParseException
    Inherits TemplateCompilerException
<SerializableAttribute>
Public Class TemplateParseException
    Inherits TemplateCompilerException
[SerializableAttribute]
public ref class TemplateParseException : public TemplateCompilerException
[SerializableAttribute]
public ref class TemplateParseException : public TemplateCompilerException
[<SerializableAttribute>]
type TemplateParseException =
    class
        inherit TemplateCompilerException
    end
[<SerializableAttribute>]
type TemplateParseException =
    class
        inherit TemplateCompilerException
    end
See Also
TemplateParseException Members
NFX.Templatization Namespace


TemplateParseException Members

TemplateParseException Members NFX Class Library

The TemplateParseException type exposes the following members.
Constructors
 | Name | Description
Public method | TemplateParseException | Initializes a new instance of the TemplateParseException class
Public method | TemplateParseException(String) | Initializes a new instance of the TemplateParseException class
Protected method | TemplateParseException(SerializationInfo, StreamingContext) | Initializes a new instance of the TemplateParseException class
Public method | TemplateParseException(String, Exception) | Initializes a new instance of the TemplateParseException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
TemplateParseException Class
NFX.Templatization Namespace


TemplateParseException Constructor

TemplateParseException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | TemplateParseException | Initializes a new instance of the TemplateParseException class
Public method | TemplateParseException(String) | Initializes a new instance of the TemplateParseException class
Protected method | TemplateParseException(SerializationInfo, StreamingContext) | Initializes a new instance of the TemplateParseException class
Public method | TemplateParseException(String, Exception) | Initializes a new instance of the TemplateParseException class
Back to Top
See Also
TemplateParseException Class
TemplateParseException Members
NFX.Templatization Namespace


TemplateParseException Constructor

TemplateParseException Constructor NFX Class Library

Initializes a new instance of the TemplateParseException class

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TemplateParseException()
public TemplateParseException()
Public Sub New
Public Sub New
public:
TemplateParseException()
public:
TemplateParseException()
new : unit -> TemplateParseException
new : unit -> TemplateParseException
See Also
TemplateParseException Class
TemplateParseException Members
TemplateParseException Overload
NFX.Templatization Namespace


TemplateParseException Constructor (String)

TemplateParseException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TemplateParseException class

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TemplateParseException(
    string message
)
public TemplateParseException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
TemplateParseException(
    String^ message
)
public:
TemplateParseException(
    String^ message
)
new :
        message : string -> TemplateParseException
new :
        message : string -> TemplateParseException

Parameters

message
Type: Online System String
See Also
TemplateParseException Class
TemplateParseException Members
TemplateParseException Overload
NFX.Templatization Namespace


TemplateParseException Constructor (SerializationInfo, StreamingContext)

TemplateParseException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TemplateParseException class

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TemplateParseException(
    SerializationInfo info,
    StreamingContext context
)
protected TemplateParseException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
TemplateParseException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
TemplateParseException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> TemplateParseException
new :
        info : SerializationInfo *
        context : StreamingContext -> TemplateParseException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
TemplateParseException Class
TemplateParseException Members
TemplateParseException Overload
NFX.Templatization Namespace


TemplateParseException Constructor (String, Exception)

TemplateParseException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TemplateParseException class

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TemplateParseException(
    string message,
    Exception inner
)
public TemplateParseException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
TemplateParseException(
    String^ message,
    Exception^ inner
)
public:
TemplateParseException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> TemplateParseException
new :
        message : string *
        inner : Exception -> TemplateParseException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
TemplateParseException Class
TemplateParseException Members
TemplateParseException Overload
NFX.Templatization Namespace


TemplateParseException Methods

TemplateParseException Methods NFX Class Library

The TemplateParseException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
TemplateParseException Class
NFX.Templatization Namespace


TemplateParseException Properties

TemplateParseException Properties NFX Class Library

The TemplateParseException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
TemplateParseException Class
NFX.Templatization Namespace


TemplateParseException Events

TemplateParseException Events NFX Class Library

The TemplateParseException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
TemplateParseException Class
NFX.Templatization Namespace


TemplateStringContentSource Class

TemplateStringContentSource Class NFX Class Library

Represents a string template source that comes from a string
Inheritance Hierarchy
Online System Object
NFX.Templatization TemplateStringContentSource

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TemplateStringContentSource : ITemplateSource<string>,
    ITemplateSource
public class TemplateStringContentSource : ITemplateSource<string>,
    ITemplateSource
Public Class TemplateStringContentSource
    Implements ITemplateSource(Of String), ITemplateSource
Public Class TemplateStringContentSource
    Implements ITemplateSource(Of String), ITemplateSource
public ref class TemplateStringContentSource : ITemplateSource<String^>,
    ITemplateSource
public ref class TemplateStringContentSource : ITemplateSource<String^>,
    ITemplateSource
type TemplateStringContentSource =
    class
        interface ITemplateSource<string>
        interface ITemplateSource
    end
type TemplateStringContentSource =
    class
        interface ITemplateSource<string>
        interface ITemplateSource
    end
See Also
TemplateStringContentSource Members
NFX.Templatization Namespace


TemplateStringContentSource Members

TemplateStringContentSource Members NFX Class Library

The TemplateStringContentSource type exposes the following members.
Constructors
 | Name | Description
Public method | TemplateStringContentSource | Initializes a new instance of the TemplateStringContentSource class
Back to Top
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | GetName | Gets printable source name
Public method | GetSourceContent |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | InferClassName | Returns null as class name can not be inferred from string
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
Public field | Content |
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ITemplateSource GetSourceContent |
Back to Top
See Also
TemplateStringContentSource Class
NFX.Templatization Namespace


TemplateStringContentSource Constructor

TemplateStringContentSource Constructor NFX Class Library

Initializes a new instance of the TemplateStringContentSource class

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TemplateStringContentSource(
    string content
)
public TemplateStringContentSource(
    string content
)
Public Sub New (
    content As String
)
Public Sub New (
    content As String
)
public:
TemplateStringContentSource(
    String^ content
)
public:
TemplateStringContentSource(
    String^ content
)
new :
        content : string -> TemplateStringContentSource
new :
        content : string -> TemplateStringContentSource

Parameters

content
Type: Online System String
See Also
TemplateStringContentSource Class
TemplateStringContentSource Members
NFX.Templatization Namespace


TemplateStringContentSource Fields

TemplateStringContentSource Fields NFX Class Library

The TemplateStringContentSource type exposes the following members.
Fields
 | Name | Description
Public field | Content |
Back to Top
See Also
TemplateStringContentSource Class
NFX.Templatization Namespace


TemplateStringContentSource.Content Field

TemplateStringContentSource Content Field NFX Class Library

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public readonly string Content
public readonly string Content
Public ReadOnly Content As String
Public ReadOnly Content As String
public:
initonly String^ Content
public:
initonly String^ Content
val Content: string
val Content: string

Field Value

Type: Online String
See Also
TemplateStringContentSource Class
TemplateStringContentSource Members
NFX.Templatization Namespace


TemplateStringContentSource Methods

TemplateStringContentSource Methods NFX Class Library

The TemplateStringContentSource type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | GetName | Gets printable source name
Public method | GetSourceContent |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | InferClassName | Returns null as class name can not be inferred from string
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ToString | (Overrides Online Object ToString .)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | ITemplateSource GetSourceContent |
Back to Top
See Also
TemplateStringContentSource Class
NFX.Templatization Namespace


TemplateStringContentSource.Equals Method

TemplateStringContentSource Equals Method NFX Class Library

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object

Return Value

Type: Online Boolean
See Also
TemplateStringContentSource Class
TemplateStringContentSource Members
NFX.Templatization Namespace


TemplateStringContentSource.GetHashCode Method

TemplateStringContentSource GetHashCode Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Online Int32
See Also
TemplateStringContentSource Class
TemplateStringContentSource Members
NFX.Templatization Namespace


TemplateStringContentSource.GetName Method

TemplateStringContentSource GetName Method NFX Class Library

Gets printable source name

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetName(
    int maxLength
)
public string GetName(
    int maxLength
)
Public Function GetName (
    maxLength As Integer
) As String
Public Function GetName (
    maxLength As Integer
) As String
public:
virtual String^ GetName(
    int maxLength
) sealed
public:
virtual String^ GetName(
    int maxLength
) sealed
abstract GetName :
        maxLength : int -> string
override GetName :
        maxLength : int -> string
abstract GetName :
        maxLength : int -> string
override GetName :
        maxLength : int -> string

Parameters

maxLength
Type: Online System Int32

Return Value

Type: Online String

Implements

ITemplateSource GetName(Int32)
See Also
TemplateStringContentSource Class
TemplateStringContentSource Members
NFX.Templatization Namespace


TemplateStringContentSource.GetSourceContent Method

TemplateStringContentSource GetSourceContent Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetSourceContent()
public string GetSourceContent()
Public Function GetSourceContent As String
Public Function GetSourceContent As String
public:
virtual String^ GetSourceContent() sealed
public:
virtual String^ GetSourceContent() sealed
abstract GetSourceContent : unit -> string
override GetSourceContent : unit -> string
abstract GetSourceContent : unit -> string
override GetSourceContent : unit -> string

Return Value

Type: Online String

Implements

ITemplateSource T GetSourceContent
See Also
TemplateStringContentSource Class
TemplateStringContentSource Members
NFX.Templatization Namespace


TemplateStringContentSource.InferClassName Method

TemplateStringContentSource InferClassName Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Returns null as class name can not be inferred from string

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string InferClassName()
public string InferClassName()
Public Function InferClassName As String
Public Function InferClassName As String
public:
virtual String^ InferClassName() sealed
public:
virtual String^ InferClassName() sealed
abstract InferClassName : unit -> string
override InferClassName : unit -> string
abstract InferClassName : unit -> string
override InferClassName : unit -> string

Return Value

Type: Online String

Implements

ITemplateSource InferClassName
See Also
TemplateStringContentSource Class
TemplateStringContentSource Members
NFX.Templatization Namespace


TemplateStringContentSource.ITemplateSource.GetSourceContent Method

TemplateStringContentSource ITemplateSource GetSourceContent Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
Object ITemplateSource.GetSourceContent()
Object ITemplateSource.GetSourceContent()
Private Function GetSourceContent As Object
    Implements ITemplateSource.GetSourceContent
Private Function GetSourceContent As Object
    Implements ITemplateSource.GetSourceContent
private:
virtual Object^ GetSourceContent() sealed = ITemplateSource::GetSourceContent
private:
virtual Object^ GetSourceContent() sealed = ITemplateSource::GetSourceContent
private abstract GetSourceContent : unit -> Object
private override GetSourceContent : unit -> Object
private abstract GetSourceContent : unit -> Object
private override GetSourceContent : unit -> Object

Return Value

Type: Online Object

Implements

ITemplateSource GetSourceContent
See Also
TemplateStringContentSource Class
TemplateStringContentSource Members
NFX.Templatization Namespace


TemplateStringContentSource.ToString Method

TemplateStringContentSource ToString Method NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: Online String
See Also
TemplateStringContentSource Class
TemplateStringContentSource Members
NFX.Templatization Namespace


TemplatizationException Class

TemplatizationException Class NFX Class Library

Base exception thrown by the templatization-related functionality
Inheritance Hierarchy
Online System Object
Online System Exception
NFX NFXException
NFX.Templatization TemplatizationException
NFX.Templatization TemplateCompilerException

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class TemplatizationException : NFXException
[SerializableAttribute]
public class TemplatizationException : NFXException
<SerializableAttribute>
Public Class TemplatizationException
    Inherits NFXException
<SerializableAttribute>
Public Class TemplatizationException
    Inherits NFXException
[SerializableAttribute]
public ref class TemplatizationException : public NFXException
[SerializableAttribute]
public ref class TemplatizationException : public NFXException
[<SerializableAttribute>]
type TemplatizationException =
    class
        inherit NFXException
    end
[<SerializableAttribute>]
type TemplatizationException =
    class
        inherit NFXException
    end
See Also
TemplatizationException Members
NFX.Templatization Namespace


TemplatizationException Members

TemplatizationException Members NFX Class Library

The TemplatizationException type exposes the following members.
Constructors
 | Name | Description
Public method | TemplatizationException | Initializes a new instance of the TemplatizationException class
Public method | TemplatizationException(String) | Initializes a new instance of the TemplatizationException class
Protected method | TemplatizationException(SerializationInfo, StreamingContext) | Initializes a new instance of the TemplatizationException class
Public method | TemplatizationException(String, Exception) | Initializes a new instance of the TemplatizationException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
TemplatizationException Class
NFX.Templatization Namespace


TemplatizationException Constructor

TemplatizationException Constructor NFX Class Library

Overload List
 | Name | Description
Public method | TemplatizationException | Initializes a new instance of the TemplatizationException class
Public method | TemplatizationException(String) | Initializes a new instance of the TemplatizationException class
Protected method | TemplatizationException(SerializationInfo, StreamingContext) | Initializes a new instance of the TemplatizationException class
Public method | TemplatizationException(String, Exception) | Initializes a new instance of the TemplatizationException class
Back to Top
See Also
TemplatizationException Class
TemplatizationException Members
NFX.Templatization Namespace


TemplatizationException Constructor

TemplatizationException Constructor NFX Class Library

Initializes a new instance of the TemplatizationException class

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TemplatizationException()
public TemplatizationException()
Public Sub New
Public Sub New
public:
TemplatizationException()
public:
TemplatizationException()
new : unit -> TemplatizationException
new : unit -> TemplatizationException
See Also
TemplatizationException Class
TemplatizationException Members
TemplatizationException Overload
NFX.Templatization Namespace


TemplatizationException Constructor (String)

TemplatizationException Constructor (String) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TemplatizationException class

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TemplatizationException(
    string message
)
public TemplatizationException(
    string message
)
Public Sub New (
    message As String
)
Public Sub New (
    message As String
)
public:
TemplatizationException(
    String^ message
)
public:
TemplatizationException(
    String^ message
)
new :
        message : string -> TemplatizationException
new :
        message : string -> TemplatizationException

Parameters

message
Type: Online System String
See Also
TemplatizationException Class
TemplatizationException Members
TemplatizationException Overload
NFX.Templatization Namespace


TemplatizationException Constructor (SerializationInfo, StreamingContext)

TemplatizationException Constructor (SerializationInfo, StreamingContext) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TemplatizationException class

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected TemplatizationException(
    SerializationInfo info,
    StreamingContext context
)
protected TemplatizationException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
TemplatizationException(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
TemplatizationException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> TemplatizationException
new :
        info : SerializationInfo *
        context : StreamingContext -> TemplatizationException

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
TemplatizationException Class
TemplatizationException Members
TemplatizationException Overload
NFX.Templatization Namespace


TemplatizationException Constructor (String, Exception)

TemplatizationException Constructor (String, Exception) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TemplatizationException class

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TemplatizationException(
    string message,
    Exception inner
)
public TemplatizationException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
TemplatizationException(
    String^ message,
    Exception^ inner
)
public:
TemplatizationException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> TemplatizationException
new :
        message : string *
        inner : Exception -> TemplatizationException

Parameters

message
Type: Online System String
inner
Type: Online System Exception
See Also
TemplatizationException Class
TemplatizationException Members
TemplatizationException Overload
NFX.Templatization Namespace


TemplatizationException Methods

TemplatizationException Methods NFX Class Library

The TemplatizationException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToClientResponseJSONMap | Describes exception for client response transmission as JSONDataMap (Defined by ExceptionExtensions.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Public Extension Method | ToJSONDataMap | If there is error, converts its details to JSOnDataMap (Defined by MiscUtils.)
Public Extension Method | ToMessageWithType | Writes exception message with exception type (Defined by MiscUtils.)
Back to Top
See Also
TemplatizationException Class
NFX.Templatization Namespace


TemplatizationException Properties

TemplatizationException Properties NFX Class Library

The TemplatizationException type exposes the following members.
Properties
 | Name | Description
Public property | Code | Provides general-purpose error code (Inherited from NFXException.)
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Public property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
TemplatizationException Class
NFX.Templatization Namespace


TemplatizationException Events

TemplatizationException Events NFX Class Library

The TemplatizationException type exposes the following members.
Events
 | Name | Description
Protected event | Online SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Online Exception.)
Back to Top
See Also
TemplatizationException Class
NFX.Templatization Namespace


TextCSTemplateCompiler Class

TextCSTemplateCompiler Class NFX Class Library

Compiles templates based of text files that use C# language syntax
Inheritance Hierarchy
Online System Object
NFX DisposableObject
NFX.Templatization TemplateCompiler
NFX.Templatization TextCSTemplateCompiler

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TextCSTemplateCompiler : TemplateCompiler
public class TextCSTemplateCompiler : TemplateCompiler
Public Class TextCSTemplateCompiler
    Inherits TemplateCompiler
Public Class TextCSTemplateCompiler
    Inherits TemplateCompiler
public ref class TextCSTemplateCompiler : public TemplateCompiler
public ref class TextCSTemplateCompiler : public TemplateCompiler
type TextCSTemplateCompiler =
    class
        inherit TemplateCompiler
    end
type TextCSTemplateCompiler =
    class
        inherit TemplateCompiler
    end
Examples
View Colorized Copy to Clipboard Print
 #<conf>
  <compiler base-class-name="NFX.Web.Templatization.SimpleWebTemplate"
            namespace="TestWebApp.Templates"
            abstract="true"
            summary="Test master page"
   />
#</conf>
#[class]

    public string Title { get {return "aaaaa"; } }

    protected abstract void renderHeader();
    protected abstract void renderBody(bool showDetails);
    protected abstract void renderFooter();

#[render]
<html>
 <head>
   <title>?[Title]</title>
 </head>
 <body>

  <h1>This is Header</h1>
   @[renderHeader();]

  <h1>This is Body</h1>
   @[renderBody(true);]
  <p>This is in master page</p>

  <h1>This is Footer</h1>
   @[renderFooter();]

 </body>
</html>
 #<conf>
  <compiler base-class-name="NFX.Web.Templatization.SimpleWebTemplate"
            namespace="TestWebApp.Templates"
            abstract="true"
            summary="Test master page"
   />
#</conf>
#[class]

    public string Title { get {return "aaaaa"; } }

    protected abstract void renderHeader();
    protected abstract void renderBody(bool showDetails);
    protected abstract void renderFooter();

#[render]
<html>
 <head>
   <title>?[Title]</title>
 </head>
 <body>

  <h1>This is Header</h1>
   @[renderHeader();]

  <h1>This is Body</h1>
   @[renderBody(true);]
  <p>This is in master page</p>

  <h1>This is Footer</h1>
   @[renderFooter();]

 </body>
</html>
See Also
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler Members

TextCSTemplateCompiler Members NFX Class Library

The TextCSTemplateCompiler type exposes the following members.
Constructors
 | Name | Description
Public method | TextCSTemplateCompiler | Initializes a new instance of the TextCSTemplateCompiler class
Public method | TextCSTemplateCompiler( ITemplateSource String ) | Initializes a new instance of the TextCSTemplateCompiler class
Public method | TextCSTemplateCompiler(IEnumerable ITemplateSource String ) | Initializes a new instance of the TextCSTemplateCompiler class
Back to Top
Methods
 | Name | Description
Public method | Compile | Performs compilation if it has not already been performed (Inherited from TemplateCompiler.)
Public method | Configure | (Inherited from TemplateCompiler.)
Protected method | Destructor | (Inherited from TemplateCompiler.)
Public method | Dispose | Deterministically disposes object. DO NOT OVERRIDE this method, override Destructor() instead (Inherited from DisposableObject.)
Protected method | DoCompileCode | (Overrides TemplateCompiler DoCompileCode .)
Protected method | DoCompileTemplateSource | (Overrides TemplateCompiler DoCompileTemplateSource(CompileUnit).)
Protected method | DoConfigure | Override to perform custom configuration (Inherited from TemplateCompiler.)
Public method | EnsureNotCompiled | Throws an exception if this instance has already been compiled (Inherited from TemplateCompiler.)
Public method | EnsureObjectNotDisposed | Checks to see whether object dispose started or has already been disposed and throws an exception if Dispose() was called (Inherited from DisposableObject.)
Public method | Online Equals | Determines whether the specified object is equal to the current object. (Inherited from Online Object.)
Public method | ExcludeTemplateSource | Exclude template source from compilation (Inherited from TemplateCompiler.)
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GenerateUniqueName | Generates unique identifier suitable for use in code per compiler instance (Inherited from TemplateCompiler.)
Public method | GetEnumerator | (Inherited from TemplateCompiler.)
Public method | Online GetHashCode | Serves as the default hash function. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Public method | IncludeTemplateSource | Includes template source into compilation (Inherited from TemplateCompiler.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReferenceAssembly | References assembly by its name if it is already not referenced (Inherited from TemplateCompiler.)
Protected method | RegisterDefaultUsings | Override to provide default using clauses (Inherited from TemplateCompiler.)
Public method | Online ToString | Returns a string that represents the current object. (Inherited from Online Object.)
Public method | UnReferenceAssembly | Removes assembly reference by its name if it was already referenced (Inherited from TemplateCompiler.)
Back to Top
Extension Methods
 | Name | Description
Public Extension Method | AsBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDateTime(DateTime, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDID(GDID, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGDIDSymbol(GDIDSymbol, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsJSONConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLaconicConfig | (Defined by ObjectValueConversion.)
Public Extension Method | AsLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNonNullOrEmptyString | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableBool | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableChar | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDateTime | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDecimal | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableDouble | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableEnum TEnum | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableFloat | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGDIDSymbol | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableGUID | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableLong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableTimeSpan | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsNullableUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsSByte | (Defined by ObjectValueConversion.)
Public Extension Method | AsShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsString | (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsTimeSpan(TimeSpan, ConvertErrorHandling) | Overloaded. (Defined by ObjectValueConversion.)
Public Extension Method | AsUInt | (Defined by ObjectValueConversion.)
Public Extension Method | AsULong | (Defined by ObjectValueConversion.)
Public Extension Method | AsUri | (Defined by ObjectValueConversion.)
Public Extension Method | AsUShort | (Defined by ObjectValueConversion.)
Public Extension Method | AsXMLConfig | (Defined by ObjectValueConversion.)
Public Extension Method | ToErlObject | Overloaded. Try to convert .NET native object type to corresponding Erlang term. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToErlObject(ErlTypeOrder, Boolean) | Overloaded. Try to convert .NET native object type to corresponding Erlang term of given type. Throw exception if conversion is not possible (Defined by ErlObject.)
Public Extension Method | ToJSON(JSONWritingOptions) | Overloaded. Serializes object into JSON string (Defined by JSONExtensions.)
Public Extension Method | ToJSON(TextWriter, JSONWritingOptions) | Overloaded. Serializes object into JSON format using provided TextWriter (Defined by JSONExtensions.)
Public Extension Method | ToJSON(Stream, JSONWritingOptions, Encoding) | Overloaded. Serializes object into JSON format using provided stream and optional encoding (Defined by JSONExtensions.)
Back to Top
Fields
 | Name | Description
 | AREA |
 | AREA_ESCAPE |
 | CLASS_AREA |
 | CONFIG_ABSTRACT_ATTR |
 | CONFIG_ATTRIBUTE_DECL_ATTR |
 | CONFIG_ATTRIBUTE_SECTION |
 | CONFIG_BASE_CLASS_NAME_ATTR |
 | CONFIG_BASE_RENDER_ATTR |
 | CONFIG_CLASS_CONSTRAINT_ATTR |
 | CONFIG_CLASS_DECLARATION_ATTR |
 | CONFIG_CLASS_NAME_ATTR |
 | CONFIG_COMPILER_SECTION |
 | CONFIG_END |
 | CONFIG_NAMESPACE_ATTR |
 | CONFIG_REF_ASSEMBLY_NAME_ATTR |
 | CONFIG_REF_ASSEMBLY_SECTION |
 | CONFIG_START |
 | CONFIG_SUMMARY_ATTR |
 | CONFIG_USING_NS_ATTR |
 | CONFIG_USING_SECTION |
 | DEFAULT_BASE_TEMPLATE_CLASS_NAME |
 | EXPRESSION |
 | EXPRESSION_ESCAPE |
 | LACONFIG_END |
 | LACONFIG_START |
Protected field | m_Assembly | (Inherited from TemplateCompiler.)
Protected field | m_AssemblyFileName | (Inherited from TemplateCompiler.)
Protected field | m_CodeCompilerErrors | (Inherited from TemplateCompiler.)
Protected field | m_Options | (Inherited from TemplateCompiler.)
Protected field | m_ReferencedAssemblies | (Inherited from TemplateCompiler.)
Protected field | m_ReferencedAssembliesSearchPath | (Inherited from TemplateCompiler.)
Protected field | m_Units | (Inherited from TemplateCompiler.)
 | OVERRIDE |
 | RENDER_AREA |
 | SPAN_CLOSE |
 | SPAN_OPEN |
 | STATEMENT |
 | STATEMENT_ESCAPE |
 | VERBATIM |
 | VIRTUAL |
Back to Top
Properties
 | Name | Description
Public property | Assembly | Returns compiled assembly or null if only source have been compiled when CompileCode=false; (Inherited from TemplateCompiler.)
Public property | AssemblyFileName | Gets/sets filename for assembly, if null then assembly is created in-memory only (Inherited from TemplateCompiler.)
Public property | BaseTypeName | Sets the name of base type that templates inherit from. This type must directly or indirectly inherit from Template (Inherited from TemplateCompiler.)
Public property | CodeCompilerErrors | Returns code compilation errors (Inherited from TemplateCompiler.)
Public property | CompileCode | Indicates whether language compilation should be performed and Assembly be built (Inherited from TemplateCompiler.)
Public property | Compiled | Indicates whether this instance was compiled (Inherited from TemplateCompiler.)
Public property | CompileUnitsWithErrors | Returns compile units that have errors (Inherited from TemplateCompiler.)
Public property | Disposed | Indicates whether this object was already disposed - the Dispose() has finished (Inherited from DisposableObject.)
Public property | DisposeStarted | Indicates whether this object Dispose() has been called and dispose started but not finished yet (Inherited from DisposableObject.)
Public property | HasErrors | Indicates whether some units have template compilation errors or code compiler errors exist (Inherited from TemplateCompiler.)
Public property | Item | Returns a compile unit by template source or throws if it does not exist (Inherited from TemplateCompiler.)
Public property | LanguageName | (Overrides TemplateCompiler LanguageName.)
Public property | LanguageSourceFileExtension | (Overrides TemplateCompiler LanguageSourceFileExtension.)
Public property | Namespace | Sets the name of namespace that classes compiled into (Inherited from TemplateCompiler.)
Public property | Options | Config options section used for compilation (Inherited from TemplateCompiler.)
Public property | ReferencedAssemblies | Returns referenced assemblies (Inherited from TemplateCompiler.)
Public property | ReferencedAssembliesSearchPath | Gets/sets path for referenced assemblies that do not have a path in their names (Inherited from TemplateCompiler.)
Back to Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implemetation | IEnumerable GetEnumerator | (Inherited from TemplateCompiler.)
Back to Top
See Also
TextCSTemplateCompiler Class
NFX.Templatization Namespace


TextCSTemplateCompiler Constructor

TextCSTemplateCompiler Constructor NFX Class Library

Overload List
 | Name | Description
Public method | TextCSTemplateCompiler | Initializes a new instance of the TextCSTemplateCompiler class
Public method | TextCSTemplateCompiler( ITemplateSource String ) | Initializes a new instance of the TextCSTemplateCompiler class
Public method | TextCSTemplateCompiler(IEnumerable ITemplateSource String ) | Initializes a new instance of the TextCSTemplateCompiler class
Back to Top
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler Constructor

TextCSTemplateCompiler Constructor NFX Class Library

Initializes a new instance of the TextCSTemplateCompiler class

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TextCSTemplateCompiler()
public TextCSTemplateCompiler()
Public Sub New
Public Sub New
public:
TextCSTemplateCompiler()
public:
TextCSTemplateCompiler()
new : unit -> TextCSTemplateCompiler
new : unit -> TextCSTemplateCompiler
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
TextCSTemplateCompiler Overload
NFX.Templatization Namespace


TextCSTemplateCompiler Constructor (ITemplateSource(String)[])

TextCSTemplateCompiler Constructor ( ITemplateSource String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TextCSTemplateCompiler class

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TextCSTemplateCompiler(
    params ITemplateSource<string>[] sources
)
public TextCSTemplateCompiler(
    params ITemplateSource<string>[] sources
)
Public Sub New (
    ParamArray sources As ITemplateSource(Of String)()
)
Public Sub New (
    ParamArray sources As ITemplateSource(Of String)()
)
public:
TextCSTemplateCompiler(
    ... array<ITemplateSource<String^>^>^ sources
)
public:
TextCSTemplateCompiler(
    ... array<ITemplateSource<String^>^>^ sources
)
new :
        sources : ITemplateSource<string>[] -> TextCSTemplateCompiler
new :
        sources : ITemplateSource<string>[] -> TextCSTemplateCompiler

Parameters

sources
Type: NFX.Templatization ITemplateSource Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
TextCSTemplateCompiler Overload
NFX.Templatization Namespace


TextCSTemplateCompiler Constructor (IEnumerable(ITemplateSource(String)))

TextCSTemplateCompiler Constructor (IEnumerable ITemplateSource String ) NFX Class Library

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TextCSTemplateCompiler class

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TextCSTemplateCompiler(
    IEnumerable<ITemplateSource<string>> sources
)
public TextCSTemplateCompiler(
    IEnumerable<ITemplateSource<string>> sources
)
Public Sub New (
    sources As IEnumerable(Of ITemplateSource(Of String))
)
Public Sub New (
    sources As IEnumerable(Of ITemplateSource(Of String))
)
public:
TextCSTemplateCompiler(
    IEnumerable<ITemplateSource<String^>^>^ sources
)
public:
TextCSTemplateCompiler(
    IEnumerable<ITemplateSource<String^>^>^ sources
)
new :
        sources : IEnumerable<ITemplateSource<string>> -> TextCSTemplateCompiler
new :
        sources : IEnumerable<ITemplateSource<string>> -> TextCSTemplateCompiler

Parameters

sources
Type: Online System.Collections.Generic IEnumerable ITemplateSource Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
TextCSTemplateCompiler Overload
NFX.Templatization Namespace


TextCSTemplateCompiler Fields

TextCSTemplateCompiler Fields NFX Class Library

The TextCSTemplateCompiler type exposes the following members.
Fields
 | Name | Description
 | AREA |
 | AREA_ESCAPE |
 | CLASS_AREA |
 | CONFIG_ABSTRACT_ATTR |
 | CONFIG_ATTRIBUTE_DECL_ATTR |
 | CONFIG_ATTRIBUTE_SECTION |
 | CONFIG_BASE_CLASS_NAME_ATTR |
 | CONFIG_BASE_RENDER_ATTR |
 | CONFIG_CLASS_CONSTRAINT_ATTR |
 | CONFIG_CLASS_DECLARATION_ATTR |
 | CONFIG_CLASS_NAME_ATTR |
 | CONFIG_COMPILER_SECTION |
 | CONFIG_END |
 | CONFIG_NAMESPACE_ATTR |
 | CONFIG_REF_ASSEMBLY_NAME_ATTR |
 | CONFIG_REF_ASSEMBLY_SECTION |
 | CONFIG_START |
 | CONFIG_SUMMARY_ATTR |
 | CONFIG_USING_NS_ATTR |
 | CONFIG_USING_SECTION |
 | DEFAULT_BASE_TEMPLATE_CLASS_NAME |
 | EXPRESSION |
 | EXPRESSION_ESCAPE |
 | LACONFIG_END |
 | LACONFIG_START |
Protected field | m_Assembly | (Inherited from TemplateCompiler.)
Protected field | m_AssemblyFileName | (Inherited from TemplateCompiler.)
Protected field | m_CodeCompilerErrors | (Inherited from TemplateCompiler.)
Protected field | m_Options | (Inherited from TemplateCompiler.)
Protected field | m_ReferencedAssemblies | (Inherited from TemplateCompiler.)
Protected field | m_ReferencedAssembliesSearchPath | (Inherited from TemplateCompiler.)
Protected field | m_Units | (Inherited from TemplateCompiler.)
 | OVERRIDE |
 | RENDER_AREA |
 | SPAN_CLOSE |
 | SPAN_OPEN |
 | STATEMENT |
 | STATEMENT_ESCAPE |
 | VERBATIM |
 | VIRTUAL |
Back to Top
See Also
TextCSTemplateCompiler Class
NFX.Templatization Namespace


TextCSTemplateCompiler.AREA Field

TextCSTemplateCompiler AREA Field NFX Class Library

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string AREA
public const string AREA
Public Const AREA As String
Public Const AREA As String
public:
literal String^ AREA
public:
literal String^ AREA
static val mutable AREA: string
static val mutable AREA: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.AREA_ESCAPE Field

TextCSTemplateCompiler AREA_ESCAPE Field NFX Class Library

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string AREA_ESCAPE
public const string AREA_ESCAPE
Public Const AREA_ESCAPE As String
Public Const AREA_ESCAPE As String
public:
literal String^ AREA_ESCAPE
public:
literal String^ AREA_ESCAPE
static val mutable AREA_ESCAPE: string
static val mutable AREA_ESCAPE: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.CLASS_AREA Field

TextCSTemplateCompiler CLASS_AREA Field NFX Class Library

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CLASS_AREA
public const string CLASS_AREA
Public Const CLASS_AREA As String
Public Const CLASS_AREA As String
public:
literal String^ CLASS_AREA
public:
literal String^ CLASS_AREA
static val mutable CLASS_AREA: string
static val mutable CLASS_AREA: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.CONFIG_ABSTRACT_ATTR Field

TextCSTemplateCompiler CONFIG_ABSTRACT_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_ABSTRACT_ATTR
public const string CONFIG_ABSTRACT_ATTR
Public Const CONFIG_ABSTRACT_ATTR As String
Public Const CONFIG_ABSTRACT_ATTR As String
public:
literal String^ CONFIG_ABSTRACT_ATTR
public:
literal String^ CONFIG_ABSTRACT_ATTR
static val mutable CONFIG_ABSTRACT_ATTR: string
static val mutable CONFIG_ABSTRACT_ATTR: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.CONFIG_ATTRIBUTE_DECL_ATTR Field

TextCSTemplateCompiler CONFIG_ATTRIBUTE_DECL_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_ATTRIBUTE_DECL_ATTR
public const string CONFIG_ATTRIBUTE_DECL_ATTR
Public Const CONFIG_ATTRIBUTE_DECL_ATTR As String
Public Const CONFIG_ATTRIBUTE_DECL_ATTR As String
public:
literal String^ CONFIG_ATTRIBUTE_DECL_ATTR
public:
literal String^ CONFIG_ATTRIBUTE_DECL_ATTR
static val mutable CONFIG_ATTRIBUTE_DECL_ATTR: string
static val mutable CONFIG_ATTRIBUTE_DECL_ATTR: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.CONFIG_ATTRIBUTE_SECTION Field

TextCSTemplateCompiler CONFIG_ATTRIBUTE_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_ATTRIBUTE_SECTION
public const string CONFIG_ATTRIBUTE_SECTION
Public Const CONFIG_ATTRIBUTE_SECTION As String
Public Const CONFIG_ATTRIBUTE_SECTION As String
public:
literal String^ CONFIG_ATTRIBUTE_SECTION
public:
literal String^ CONFIG_ATTRIBUTE_SECTION
static val mutable CONFIG_ATTRIBUTE_SECTION: string
static val mutable CONFIG_ATTRIBUTE_SECTION: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.CONFIG_BASE_CLASS_NAME_ATTR Field

TextCSTemplateCompiler CONFIG_BASE_CLASS_NAME_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_BASE_CLASS_NAME_ATTR
public const string CONFIG_BASE_CLASS_NAME_ATTR
Public Const CONFIG_BASE_CLASS_NAME_ATTR As String
Public Const CONFIG_BASE_CLASS_NAME_ATTR As String
public:
literal String^ CONFIG_BASE_CLASS_NAME_ATTR
public:
literal String^ CONFIG_BASE_CLASS_NAME_ATTR
static val mutable CONFIG_BASE_CLASS_NAME_ATTR: string
static val mutable CONFIG_BASE_CLASS_NAME_ATTR: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.CONFIG_BASE_RENDER_ATTR Field

TextCSTemplateCompiler CONFIG_BASE_RENDER_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_BASE_RENDER_ATTR
public const string CONFIG_BASE_RENDER_ATTR
Public Const CONFIG_BASE_RENDER_ATTR As String
Public Const CONFIG_BASE_RENDER_ATTR As String
public:
literal String^ CONFIG_BASE_RENDER_ATTR
public:
literal String^ CONFIG_BASE_RENDER_ATTR
static val mutable CONFIG_BASE_RENDER_ATTR: string
static val mutable CONFIG_BASE_RENDER_ATTR: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.CONFIG_CLASS_CONSTRAINT_ATTR Field

TextCSTemplateCompiler CONFIG_CLASS_CONSTRAINT_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CLASS_CONSTRAINT_ATTR
public const string CONFIG_CLASS_CONSTRAINT_ATTR
Public Const CONFIG_CLASS_CONSTRAINT_ATTR As String
Public Const CONFIG_CLASS_CONSTRAINT_ATTR As String
public:
literal String^ CONFIG_CLASS_CONSTRAINT_ATTR
public:
literal String^ CONFIG_CLASS_CONSTRAINT_ATTR
static val mutable CONFIG_CLASS_CONSTRAINT_ATTR: string
static val mutable CONFIG_CLASS_CONSTRAINT_ATTR: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.CONFIG_CLASS_DECLARATION_ATTR Field

TextCSTemplateCompiler CONFIG_CLASS_DECLARATION_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CLASS_DECLARATION_ATTR
public const string CONFIG_CLASS_DECLARATION_ATTR
Public Const CONFIG_CLASS_DECLARATION_ATTR As String
Public Const CONFIG_CLASS_DECLARATION_ATTR As String
public:
literal String^ CONFIG_CLASS_DECLARATION_ATTR
public:
literal String^ CONFIG_CLASS_DECLARATION_ATTR
static val mutable CONFIG_CLASS_DECLARATION_ATTR: string
static val mutable CONFIG_CLASS_DECLARATION_ATTR: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.CONFIG_CLASS_NAME_ATTR Field

TextCSTemplateCompiler CONFIG_CLASS_NAME_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_CLASS_NAME_ATTR
public const string CONFIG_CLASS_NAME_ATTR
Public Const CONFIG_CLASS_NAME_ATTR As String
Public Const CONFIG_CLASS_NAME_ATTR As String
public:
literal String^ CONFIG_CLASS_NAME_ATTR
public:
literal String^ CONFIG_CLASS_NAME_ATTR
static val mutable CONFIG_CLASS_NAME_ATTR: string
static val mutable CONFIG_CLASS_NAME_ATTR: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.CONFIG_COMPILER_SECTION Field

TextCSTemplateCompiler CONFIG_COMPILER_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_COMPILER_SECTION
public const string CONFIG_COMPILER_SECTION
Public Const CONFIG_COMPILER_SECTION As String
Public Const CONFIG_COMPILER_SECTION As String
public:
literal String^ CONFIG_COMPILER_SECTION
public:
literal String^ CONFIG_COMPILER_SECTION
static val mutable CONFIG_COMPILER_SECTION: string
static val mutable CONFIG_COMPILER_SECTION: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.CONFIG_END Field

TextCSTemplateCompiler CONFIG_END Field NFX Class Library

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_END
public const string CONFIG_END
Public Const CONFIG_END As String
Public Const CONFIG_END As String
public:
literal String^ CONFIG_END
public:
literal String^ CONFIG_END
static val mutable CONFIG_END: string
static val mutable CONFIG_END: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.CONFIG_NAMESPACE_ATTR Field

TextCSTemplateCompiler CONFIG_NAMESPACE_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_NAMESPACE_ATTR
public const string CONFIG_NAMESPACE_ATTR
Public Const CONFIG_NAMESPACE_ATTR As String
Public Const CONFIG_NAMESPACE_ATTR As String
public:
literal String^ CONFIG_NAMESPACE_ATTR
public:
literal String^ CONFIG_NAMESPACE_ATTR
static val mutable CONFIG_NAMESPACE_ATTR: string
static val mutable CONFIG_NAMESPACE_ATTR: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.CONFIG_REF_ASSEMBLY_NAME_ATTR Field

TextCSTemplateCompiler CONFIG_REF_ASSEMBLY_NAME_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_REF_ASSEMBLY_NAME_ATTR
public const string CONFIG_REF_ASSEMBLY_NAME_ATTR
Public Const CONFIG_REF_ASSEMBLY_NAME_ATTR As String
Public Const CONFIG_REF_ASSEMBLY_NAME_ATTR As String
public:
literal String^ CONFIG_REF_ASSEMBLY_NAME_ATTR
public:
literal String^ CONFIG_REF_ASSEMBLY_NAME_ATTR
static val mutable CONFIG_REF_ASSEMBLY_NAME_ATTR: string
static val mutable CONFIG_REF_ASSEMBLY_NAME_ATTR: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.CONFIG_REF_ASSEMBLY_SECTION Field

TextCSTemplateCompiler CONFIG_REF_ASSEMBLY_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_REF_ASSEMBLY_SECTION
public const string CONFIG_REF_ASSEMBLY_SECTION
Public Const CONFIG_REF_ASSEMBLY_SECTION As String
Public Const CONFIG_REF_ASSEMBLY_SECTION As String
public:
literal String^ CONFIG_REF_ASSEMBLY_SECTION
public:
literal String^ CONFIG_REF_ASSEMBLY_SECTION
static val mutable CONFIG_REF_ASSEMBLY_SECTION: string
static val mutable CONFIG_REF_ASSEMBLY_SECTION: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.CONFIG_START Field

TextCSTemplateCompiler CONFIG_START Field NFX Class Library

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_START
public const string CONFIG_START
Public Const CONFIG_START As String
Public Const CONFIG_START As String
public:
literal String^ CONFIG_START
public:
literal String^ CONFIG_START
static val mutable CONFIG_START: string
static val mutable CONFIG_START: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.CONFIG_SUMMARY_ATTR Field

TextCSTemplateCompiler CONFIG_SUMMARY_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_SUMMARY_ATTR
public const string CONFIG_SUMMARY_ATTR
Public Const CONFIG_SUMMARY_ATTR As String
Public Const CONFIG_SUMMARY_ATTR As String
public:
literal String^ CONFIG_SUMMARY_ATTR
public:
literal String^ CONFIG_SUMMARY_ATTR
static val mutable CONFIG_SUMMARY_ATTR: string
static val mutable CONFIG_SUMMARY_ATTR: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.CONFIG_USING_NS_ATTR Field

TextCSTemplateCompiler CONFIG_USING_NS_ATTR Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_USING_NS_ATTR
public const string CONFIG_USING_NS_ATTR
Public Const CONFIG_USING_NS_ATTR As String
Public Const CONFIG_USING_NS_ATTR As String
public:
literal String^ CONFIG_USING_NS_ATTR
public:
literal String^ CONFIG_USING_NS_ATTR
static val mutable CONFIG_USING_NS_ATTR: string
static val mutable CONFIG_USING_NS_ATTR: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.CONFIG_USING_SECTION Field

TextCSTemplateCompiler CONFIG_USING_SECTION Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string CONFIG_USING_SECTION
public const string CONFIG_USING_SECTION
Public Const CONFIG_USING_SECTION As String
Public Const CONFIG_USING_SECTION As String
public:
literal String^ CONFIG_USING_SECTION
public:
literal String^ CONFIG_USING_SECTION
static val mutable CONFIG_USING_SECTION: string
static val mutable CONFIG_USING_SECTION: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.DEFAULT_BASE_TEMPLATE_CLASS_NAME Field

TextCSTemplateCompiler DEFAULT_BASE_TEMPLATE_CLASS_NAME Field NFX Class Library

[This is preliminary documentation and is subject to change.]

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string DEFAULT_BASE_TEMPLATE_CLASS_NAME
public const string DEFAULT_BASE_TEMPLATE_CLASS_NAME
Public Const DEFAULT_BASE_TEMPLATE_CLASS_NAME As String
Public Const DEFAULT_BASE_TEMPLATE_CLASS_NAME As String
public:
literal String^ DEFAULT_BASE_TEMPLATE_CLASS_NAME
public:
literal String^ DEFAULT_BASE_TEMPLATE_CLASS_NAME
static val mutable DEFAULT_BASE_TEMPLATE_CLASS_NAME: string
static val mutable DEFAULT_BASE_TEMPLATE_CLASS_NAME: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace


TextCSTemplateCompiler.EXPRESSION Field

TextCSTemplateCompiler EXPRESSION Field NFX Class Library

Namespace: NFX.Templatization
Assembly: NFX (in NFX.dll) Version: 3.0.0.1 (3.0.0.1)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const string EXPRESSION
public const string EXPRESSION
Public Const EXPRESSION As String
Public Const EXPRESSION As String
public:
literal String^ EXPRESSION
public:
literal String^ EXPRESSION
static val mutable EXPRESSION: string
static val mutable EXPRESSION: string

Field Value

Type: Online String
See Also
TextCSTemplateCompiler Class
TextCSTemplateCompiler Members
NFX.Templatization Namespace